Overview

ActiveReports 19 .NET Edition
Overview
Introduction > Overview

Glossary Item Box

To stay relevant in the digital era, incorporating dynamic reporting solutions into your applications is not an option but a requirement. ActiveReports.NET is a reporting solution for designing and delivering reports using reliable and user-friendly report designers and controls for, .NET/.NET Framework, Blazor, WinForms, WPF, ASP.NET MVC, ASP.NET Core MVC, Angular, React, and Vue.

ActiveReports offers a comprehensive suite of design tools tailored for creating and printing digital documents efficiently. Its integrated designer lets users create layouts in Visual Studio and edit them at design time, visually, and through code, script, or regular expressions. Another designer provided by ActiveReports is WebDesigner, which enables end-users to create ad hoc reports in all major browsers. The product also includes a Standalone designer, which allows users to view, edit, and create complete design-based, code-free, .NET reports all in a single application.

ActiveReports .NET supports unique reporting features, including:

  • Lightweight report designers and viewers for powerful .NET Core reporting.
  • Available in two editions, Standard and Professional to deliver outstanding reporting capabilities.
  • Provides report viewers that support technologies such as Blazor, ASP.NET Core, ASP.NET MVC, Angular, React, HTML5/JS, WPF, and WinForms.
  • Extensive API for customizing and maintaining control.
  • Provides an interactive look to your report at runtime by supporting parameters, filters, drill-down drill-through, document map and sorting.
  • Report distribution in JavaScript, ASP.NET, WPF, WinForms applications without additional licensing.
  • Deliver interactive reports under cloud services, such as Azure or AWS, on Linux. With no reliance on GDI+ and easy DevOps integration, ActiveReports.NET makes deployment on Linux and macOS easy without complicated system configuration.
  • Customizable end-user designers and report viewers for your applications.
  • Rich report controls to visualize the data with feature-packed controls such as, Table, Tablix, Barcode, Sparkline, Shape, and more.
  • Create reusable connections to ODBC, OLEDB, .NET, XML, Web Services, Data Objects, and runtime data sources.
  • Supports multiple types of open source software (OSS) programs based on the license agreement and usage rights.

ActiveReports provides a number of ways to design a report using a versatile set of controls such as Barcode, Shape, Chart, Table, Tablix and more. You can choose from the RDLX, RDLX Dashboard, Page, and Section report types based on your layout requirements and bind these reports to different data sources, including Microsoft SQL Server, MySQL, JSON, Excel, Data Provider, CSV, and more. Also, you can export your reports in different formats, such as Excel, PDF, CSV, Word, PDF, and more.

Start your ActiveReports Professional 30-Day Free Trial now and explore the advanced features of ActiveReports.NET.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Product Requirements

Product Requirements
Introduction > Product Requirements

Glossary Item Box

To install and use ActiveReports 19, you need the following hardware and software.

Hardware requirements (minimum)

  • Hard drive space: 1 GB available

Development Environments

 |  | .NET Framework 4.7.2 to 4.8.1 | .NET 8, .NET 9
 |  | Desktop (WinForms, WPF) ASP.NET (WebForms, MVC 5) | Console 1 Desktop (WinForms, WPF) ASP.NET Core (MVC, Blazor) Azure Function 2
IDE | Visual Studio 2022 (17.8) | ✓ | ✓
 | Visual Studio 2019 (16.11) | ✓ | ✗
Operating System | Windows 11 | ✓ | ✓ 3
 | Windows 10 | ✓ | ✓ 3
 | Windows Server 2022 | ✓ | ✓ 3
 | Windows Server 2019 | ✓ | ✓ 3
 | Windows Server 2016 | ✓ 3 | ✓ 3

1 Tutorial: Create a .NET console application using Visual Studio
2 Quickstart: Create your first C# function in Azure using Visual Studio
3 Install .NET on Windows

Note: The Express Editions of Visual Studio do not work with ActiveReports, as they do not support packages.
You are required to perform the following updates from the links provided for the proper working in Visual Studio.
  • Developer Pack for .NET Framework 4.7.2 or above
  • TypeScript Plugin for VS2019/2022
  • node.js and npm

Run Time Supported Environments

Console and Desktop

Controls | Framework |  | Operating System
 | .NET Framework 4.7.2 to 4.8.1 | .NET 8 .NET 9 | Windows 11 Windows 10 | Windows Server 2022 Windows Server 2019 Windows Server 2016 | macOS 10.15+ 1 Linux 2
Console Application (Page/RDLX reports) | ✓ | ✓ | ✓ | ✓ | ✓
Console Application (Section Reports) | ✓ | ✓ | ✓ | ✓ | ✓
WinForms Controls (Viewer, Designer) | ✓ | ✓ | ✓ | ✓ | ✗
WPF Controls (Viewer) | ✓ | ✓ | ✓ | ✓ | ✗

1 .NET on macOS
2 .NET on Linux

Web

Server | Framework |  | Operating System 1
 | .NET Framework 4.7.2 - 4.8.1 | .NET 8 .NET 9 | Windows 11 Windows 10 | Windows Server 2022 Windows Server 2019 Windows Server 2016 | macOS 10.15+ 2 Linux 3
ASP.NET WebForms (WebViewer) | ✓ | ✗ | ✓ | ✓ | ✗
ASP.NET MVC 5 (JS Viewer, WebDesigner) | ✓ | ✗ | ✓ | ✓ | ✗
ASP.NET Core MVC (JS Viewer, WebDesigner) | ✗ | ✓ | ✓ | ✓ | ✓
ASP.NET Core Blazor (Viewer) | ✗ | ✓ | ✓ | ✓ | ✓

Client

Controls | Browser |  |  | Operating System |  |  | Mobile
 | Edge Cromium 109 Chrome 109 | Firefox 115 Safari 15.6 | Internet Explorer 11 Edge Legacy | Windows 11 Windows 10 | Windows Server 2022 Windows Server 2019 Windows Server 2016 | macOS 10.15+ Linux | iPadOS | iOS | Android
ASP.NET WebForms (WebViewer) | ✓ | ✗ | ✗ | ✓ | ✓ | ✗ | ✗ | ✗ | ✗
JS Viewer, WebDesigner | ✓ | ✓ | ✗ | ✓ | ✓ | ✓ | ✓ | ✓ | ✗
ASP.NET Core Blazor (Viewer, Designer) | ✓ | ✓ | ✗ | ✓ | ✓ | ✓ | ✓ | ✓ | ✗

1 Requires IIS 10. Also read the following links:

  • Web server implementations in ASP.NET Core
  • The .NET Core Hosting Bundle

2 Install .NET on macOS
3 Install .NET on Linux

Cloud

 | Framework
 | .NET Framework 4.7.2 to 4.8.1 | .NET 8, .NET 9
Azure Functions (Linux) 2 | ✗ | ✓
Azure Functions (Windows) | ✓ 1 | ✓
Azure App Service (Linux) 2 | ✗ | ✓
Azure App Service (Windows) | ✓ 1 | ✓
Azure WMs (Linux) | ✗ | ✓
Azure WMs (Windows) | ✓ | ✓
Amazon ES2 (Linux) | ✗ | ✓
Amazon ES2 (Windows) | ✓ | ✓
Google Compute Engine (Linux) | ✗ | ✓
Red Hat OpenShift (Linux) 2 | ✗ | ✓

1 Azure Functions and App Services support only .NET Framework 4.8
2 Page/RDLX reports support only

Limitations of .NET Core support

  • You need to specify encodings before using ActiveReports with ASP.NET Core MVC. See Troubleshooting for details.
  • While working with Section Reports with scripts in WinForms Viewer, WPF Viewer, and Windows Designer components in .NET Core applications, it is mandatory to install 'System.Text.Encoding.CodePages' NuGet package and update the Program.cs file accordingly. Otherwise 'System.NotSupportedException' is thrown on previewing the report. See Troubleshooting for details.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


What's New

What's New
Introduction > What's New

Glossary Item Box

Since the last version of ActiveReports, we have introduced several new features and implemented many key improvements to enhance performance, usability, and functionality.

.NET 9 Support

ActiveReports.NET 19 introduces support for .NET 9, ensuring compatibility with the latest version of Microsoft's development platform. Developers upgrading existing applications or building new projects on .NET 9 can continue using ActiveReports without compatibility concerns. This update allows seamless integration with the latest advancements in .NET while maintaining the reliability and functionality of ActiveReports.

Product Requirements

Improved Report Wizard

ActiveReports.NET 19 introduces an enhanced Report Wizard that simplifies the report creation process with additional configuration options. Previously, the wizard only supported data binding. In this release, the following new capabilities have been added:

  • Use Sample Reports as a Starting Point – Select from built-in product samples to accelerate development.
    Select Sample Report
  • Define Page Settings – Configure page size, orientation, and margins at the start.
    Configure Page Setting
  • Set Up Data Visualizations – Choose and configure Tables, Tablices, and Charts directly within the wizard.
    Add a New Data Region
  • Customize Report Colors – Apply predefined or custom color schemes for a consistent report appearance.
    Chart Wizard

These enhancements make it easier to create professional reports in just a few clicks.

Report Wizard

Enhanced Design-Time Actions

ActiveReports.NET 19 introduces several improvements to the report designer, enhancing the user experience when working with report items and datasets. These updates streamline report creation by automating common workflows and providing quick access to key functionalities.

  • Automatic Wizard Invocation for Report Items – To simplify report configuration, the following wizards are now triggered automatically when corresponding report items are dragged onto the design surface, unless disabled in the configuration file:
    • Table Wizard – Invoked when a Table report item is added.
      Table Wizard
    • Tablix Wizard – Invoked when a Tablix report item is added.
      Tablix Wizard
    • Chart Wizard – Invoked when a Chart report item is added.
      Chart Wizard
  • Improved Dataset and Data Region Management – To provide more control over dataset usage, new actions have been added:
    Data Display Control
    • "Add Data Display Control..." – A new option in the dataset context menu that launches the Adding Data Region page.
    • "Add Data Region..." – A button in the data panel's top bar, active when a dataset is selected, that opens the Adding Data Region dialog.
    • Dataset Drag-and-Drop Support – When a dataset is dragged onto the report body, the Adding Data Region dialog is automatically invoked, allowing users to select the appropriate data region.

These enhancements improve design-time efficiency, making report creation more intuitive and reducing manual setup steps.

Configuring Report Controls

Revamped Chart Report Item

ActiveReports.NET 19 introduces a completely revised Chart report item, offering greater flexibility and configurability across all aspects of chart design. From data binding to legend customization, the new chart model provides more dynamic options to better suit various reporting needs. See the following image on how expressions for Data Tooltip > Value and Fill Color Properties are set for a chart and how the chart looks in the preview.

  • Set Expressions in Chart:
    Set Expressions in ActiveReports Chart
  • Preview Chart:
    Preview Chart with Data Tooltip Value and Fill Color Set as Expressions

  • Enhanced Configurability – Every aspect of the chart, including data binding, axis settings, labels, and legend items, is now more customizable by using dynamic expressions.
  • Seamless Migration – Existing charts are automatically converted to the new model when an older report is opened in the designer, ensuring a smooth transition without manual adjustments.

This update simplifies chart configuration while providing more control over data visualization, making it easier to create clear and insightful reports.

Configuring Chart

Custom TextBox and CheckBox Styles

ActiveReports.NET 19 introduces the CustomCSSClasses property for TextBox and CheckBox report items, allowing you to apply custom CSS class names when rendering reports in the JS Report Viewer. This feature provides greater flexibility in styling report elements, enabling custom appearances such as making a TextBox look like a button.
TextBox as Button

  • Flexible Styling – Assign one or more CSS classes to TextBox and CheckBox elements using the CustomCSSClasses property.
  • Predefined Styles – The JS Report Viewer deliverables now include the jsViewer.custom.styles.css file, which provides built-in styles such as:
    • ar-button – Styles elements to resemble buttons.
    • ar-button-pressed – Represents a pressed button state.
  • Custom Styling – You can either apply the predefined styles or define your own custom styles to match the report design requirements.
  • Dynamic Conditional Styling – The CustomCSSClasses property supports dynamic expressions, allowing styles to be applied conditionally based on report data or parameter values.

This enhancement allows for more visually appealing and interactive reports by giving you greater control over how report elements are presented.

CheckBox | TextBox

Public API for Customizing JS Report Viewer and Web Designer Themes

ActiveReports.NET 19 introduces a public API that allows you to easily customize the appearance of the browser-based Report Viewer and Designer. This enhancement provides flexibility in theming, enabling you to create a fully customized look and feel for your reporting applications.

  • Full UI Customization – Modify the styling of the JS Report Viewer and Web-based Report Designer to match your application's design.
  • Theme Creation – Quickly create a new theme from scratch or customize an existing one based on predefined color schemes.
  • Theme Selector in Toolbar – The JS Report Viewer now includes a theme selector in the toolbar, allowing report readers to switch themes dynamically.
  • Public API for Theme Management – You can use the API to:
    • Enable or disable the theme selector in the toolbar.
    • Set the default theme for the viewer.
    • Define the list of available themes, including custom themes.

This feature simplifies UI customization, ensuring a consistent and branded experience across reporting solutions while giving end users control over their preferred theme.

Js Viewer API | WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Get Started

Get Started
See Also
Introduction > Get Started

Glossary Item Box

The help file divides the ActiveReports.NET knowledge base based on the target audience - the Developers, the DevOps, the Report Authors, and the Report Readers. The primary target audience of ActiveReports is developers. If you are a developer, we recommend that you start with Quick Start.

For Report Authors, we have Quick Start and tutorials to create reports.

You should feel free to see our demos and samples (web samples) that provide quick demonstrations of core features and capabilities.

See Also

Report Readers
Report Authors
DevOps
Developers

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Readers

Report Readers

Glossary Item Box

Report readers use viewer components to display a report generated by the reporting engine using designer components. You get complete .NET embedded reporting tool for web and desktop applications. Our viewers support technologies such as Blazor, ASP.NET Core, ASP.NET MVC, Angular, React, HTML5/JS, WPF, and WinForms.

This section introduces the available report viewing options for desktop and web applications, the Desktop Viewers and Web Viewers.

You can also preview the report at design time in Visual Studio Integrated Designer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Desktop Viewers

Desktop Viewers
See Also
Report Readers > Desktop Viewers

Glossary Item Box

As a report reader, you can view reports by running an application with the ActiveReports Viewer control integrated, and loading the report in the viewer. ActiveReports provides executable files for the Viewer controls (Windows and WPF) in the startup menu. You can use the samples available for WinForms and WPF platforms: WinViewer or the WpfViewer.

All the viewers provided by ActiveReports are feature-rich that allow you to easily view, print, and export reports. The viewers are highly interactive, giving you the ability to enter parameters, perform sort and drill down, navigate to other reports using drill-through links, and so on. The ActiveReports viewers toolbar and sidebar offer a handful of features. In addition, the viewers are customizable and localizable according to the personal needs.

Key Features

  • Highly Interactive
  • Touch-enabled
  • Support Annotations
  • Provide Advanced Print Options
  • Provide Exportability to Different Outputs
  • Customizable when used as a Control
  • Desktop Viewers provide two views in one display, as shown:
    Desktop Viewer Split into two displays

See Also

DevOps
Configuration and Customization

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Windows Forms Viewer

Windows Forms Viewer
See Also
Report Readers > Desktop Viewers > Windows Forms Viewer

Glossary Item Box

The ActiveReports provides the Windows Forms Viewer application ActiveReports.Viewer.exe, bundled with the ActiveReports installer. The app can be launched by installing the ActiveReports installer package.

You can run the application by selecting the ActiveReports 19 Viewer from the Start menu, or by running the ActiveReports.Viewer.exe from the C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools\ location.

Report readers wanting to quickly preview a report in WinForms platform can use WinViewer sample. You just need to load the report you want to view in the viewer control. The Windows Forms Viewer with a report loaded looks like the following.

The Windows Forms Viewer is basically a Windows Forms application with an ActiveReports Viewer control in it. The default user interface of this application provides an ActiveReports Viewer control along with a menu bar.

You can open a .rdlx or .rpx report in the standalone viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer. Unlike the Viewer control, no code implementation is required to load the report in the standalone application.

Please note that any additional features activated through code like the annotation toolbar, are not available in the standalone viewer application.

Interface Elements

Viewer Toolbar

The features available through the Viewer Toolbar are elaborated in this table.

Toolbar Element | Name | Description

Toggle Sidebar button

Toggle sidebar Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print button | Print | Displays the Print dialog where you can specify the printing options.
Galley Mode button | Galley mode | Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDLX) and displays data in a single scrollable page. This mode maintains page breaks you create in the report and removes only automatic page breaks.
Copy button | Copy | Copies text that you select in the Selection mode to the clipboard.
Find button | Find | Displays the Find dialog to find any text in the report.
Zoom Out button | Zoom out | Decreases the magnification of your report.
Current Zoom button | Current zoom | Displays the current zoom percentage, which can also be edited.
Zoom In button | Zoom in | Increases the magnification of your report.
Fit Width button | Fit width | Fits the width of the page according to viewer dimensions.
Fit Page button | Fit page | Fits the whole page within the current viewer dimensions.
Single Page View button | Single page view | Shows one page at a time in the viewer.
Continuous View button | Continuous view | Shows all preview pages one below the other.
Multipage View button | Multipage view | Offers you an option to select how many pages to preview in the viewer at one time.
First Page button | Navigate to First Page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
Previous Page button | Navigate to Preceding Pages | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Next Page button | Navigate to Next pages | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Last Page button | Navigate to Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
Current Page button | Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Backward button | Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
Forward button | Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
Back to Parent Report button | Back to parent report | Returns you to the parent report in a drillthrough report.
Default button | Default | Allows you to specify a default mouse pointer mode.
Refresh button | Refresh | Refreshes the report.
Pan Mode button | Pan mode | A hand symbol serves as the cursor that you can use to navigate.
Selection Mode button | Selection mode | Allows you to select contents on the report. Click the Copy icon (see image and description below) to copy the selected content to the clipboard.
Snapshot Mode button | Snapshot mode | Allows you to select content on the report that you can paste as an image into any application that accepts pasted images.
Cancel button | Cancel | Cancels the report rendering.
Touch Mode button Touch Mode Allows you to select touch mode for the viewer.
Note: The Touch Mode button only appears on the toolbar while working on touch enabled devices.
Viewer Annotations Annotations

Lets you add annotations.

  • Text: A rectangular box in which you can enter text.
  • Circle: A circle without text. You can change the shape to an oval.
    Rectangle: A rectangular box without text.
  • Arrow: A 2D arrow in which you can enter text. You can change the arrow direction.
  • Balloon: A balloon caption in which you can enter text. You can point the balloon's tail in any direction.
  • Line: A line with text above or below it. You can add arrow caps to one or both ends and select different dash styles.
  • Image: A rectangle with a background image and text. You can select an image and its position, and place text on the image.

Viewer Sidebar

The Viewer sidebar appears on the left of the viewer when you click the Toggle sidebar button in the toolbar. By default, the sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar according to the interactive features added in the report. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also zoom in and zoom out of the thumbnails using (+) or (-) button.

WinForms Viewer Thumbnails Pane

Document map pane

The Documents Map pane is enabled for reports where the Label property or the Document map label is set. This pane displays the labels of the report sections (for RDLX and RDLX Dashboard reports) as well as for the TextBox, SubReport, and other controls that you label by setting the Label property. The Document Map pane lets you easily navigate to the corresponding area of the report in the viewer by just clicking on the labels.

WinForms Viewer Document Map Pane

If a report does not have the Label property or Document map label set, the Documents map pane does not appear in the sidebar.

Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase to search within the report.

WinForms Viewer Search Pane

To search in a report:

  1. Enter the word or phrase in the search field.
  2. Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  3. Click the Search button to see the results appear in the Find results list.
  4. Click an item in the list to jump to that item in the report.

To start a new search or clear the current search results, use the Clear button under the Find results list.

Parameters pane

The Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.

WinForms Viewer Parameters Pane

  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Keyboard Shortcuts

The following shortcuts are available on the WinForms Viewer.

Keyboard Shortcut | Action
Ctrl + F | Shows the find dialog.
Ctrl + P | Shows the print dialog.
Esc | Closes the find or print dialogs.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + M | Turns on the continuous view.
Ctrl + S | Turns off the continuous view.
Ctrl + I | Shows multiple pages.
Ctrl + G | Focuses on PageNumber area and selects content.
Shift + rotate mouse wheel | Scrolls horizontally.
Rotate mouse wheel | Scrolls vertically.
F5 | Refreshes the report.
Home | Moves to the start of the current page.
End | Moves to the end of the current page.

Viewer's Thumbnails pane shortcut keys

You can use the following shortcut keys while using the thumbnails pane in the Viewer.

Keyboard Shortcut | Action
Up Arrow | Goes to the previous page.
Down Arrow | Goes to the next page.
Right Arrow | Goes to right page. If no thumbnail exist on the right, it goes to the next page.
Left Arrow | Goes to left page. If no thumbnail exist on the left, it goes to the previous page.
Page Down | Scrolls to the next thumbnail's view port. It also keeps the current selected page unchanged.
Page Up | Scrolls to the previous thumbnail's view port. It also keeps the current selected page unchanged.
Home | Goes to the first page.
End | Goes to last page.

See Also

Developers
Windows Forms Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Windows Presentation Foundation Viewer

Windows Presentation Foundation Viewer
See Also
Report Readers > Desktop Viewers > Windows Presentation Foundation Viewer

Glossary Item Box

The ActiveReports provides the Windows Presentation Foundation Viewer application ActiveReports.WpfViewer.exe, which supports previewing all types of reports - Page, RDLX, and Section. The app can be launched by installing the ActiveReports installer package.

You can run the application by selecting the ActiveReports 19 Viewer from the Start menu, or by running the ActiveReports.WpfViewer.exe from the C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools\ location.

Report readers wanting to quickly preview a report in WPF platform can use WpfViewer. You just need to load the report you want to view in the viewer control. The WPF Viewer with a report loaded looks like the following.

The WPF viewer is basically a WPF application with an ActiveReports WPF Viewer control in it. The default user interface of this application provides an ActiveReports along with a menu bar.

You can open an .rdlx or .rpx report in the standalone WPF Viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer. Unlike the Viewer control, no code implementation is required to load the report in the standalone application.

Note: The toolbar customization through code is not available in the standalone WPF Viewer application.

The WPF Viewer includes a toolbar and a sidebar with Thumbnails, Search results, Document map and Parameters panes.

The WPF Viewer has a limitation in the continuous mode. In this mode, a report is always rendered on top of the WPF Viewer because the WinForms content always appears on top of the WPF content.

Interface Elements

Viewer Toolbar

The following table lists the actions you can perform through the WPF Viewer toolbar. The toolbar allows you to perform the common or report-specific tasks on the report that is currently displayed.

Toolbar Element | Name | Description
Toggle Sidebar button | Toggle sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print button | Print | Displays the Print dialog where you can specify the printing options.
Galley Mode button | Galley mode | Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDLX) and displays data in a single scrollable page. This mode maintains page breaks you create in the report.1
Copy button | Copy | Copies text that you select in the Selection mode to the clipboard.
Find button | Find | Displays the Find dialog to find any text in the report.
Zoom Out button | Zoom out | Decreases the magnification of your report.
Current Zoom button | Current zoom | Displays the current zoom percentage, which can also be edited.
Zoom In button | Zoom in | Increases the magnification of your report.
Fit Width button | Fit width | Fits the width of the page according to viewer dimensions.
Fit Page button | Fit page | Fits the whole page within the current viewer dimensions.
Single Page View button | Single page view | Shows one page at a time in the viewer.
Continuous View button | Continuous view | Shows all preview pages one below the other.
Multipage View button | Multipage view | Offers you an option to select how many pages to preview in the viewer at one time.
First Page button | Navigate to First Page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
Previous Page button | Navigate to Preceding Pages | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Next Page button | Navigate to Next pages | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Last Page button | Navigate to Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
Current Page button | Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Backward button | Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
Forward button | Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
Back to Parent Report button | Back to parent report | Returns you to the parent report in a drillthrough report.
Refresh button | Refresh | Refreshes the report.
Cancel button | Cancel | Cancels the report rendering.

1To view drillthrough reports in WPF Viewer, you need to turn off the Galley mode.

Viewer Sidebar

The Viewer sidebar appears on the left of the Viewer when you click the Toggle sidebar button in the toolbar. By default, the sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also modify the size of the thumbnail using (+) or (-) button to zoom in and zoom out.

WPF Viewer Thumbnails Pane

Documents map pane

The Documents Map pane is enabled for reports where the Label property or the Document map label is set. This pane displays the labels of the report sections (only for RDLX and RDLX Dashboard reports) as well as for the TabelOfContent, TextBox, SubReport, and other controls that you label by setting the Label property. The Document Map pane lets you easily navigate to the corresponding area of the report in the viewer by just clicking on the labels.

WPF Viewer Document Map Pane

If a report does not have the Label property or Document map label set, the Documents map panes does not appear in the sidebar.

Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase from which to search within the report.

WPF Viewer Search Pane

To search in a report:

  1. Enter the word or phrase in the search field.
  2. Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  3. Click the Search button to see the results appear in the Find results list.
  4. Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Parameters pane

The Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.

WPF Viewer Parameters Pane

  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Keyboard Shortcuts

The following shortcuts are available on the WPF Viewer.

Keyboard Shortcut | Action
Ctrl + F | Shows the search pane.
Ctrl + P | Shows the print dialog.
Esc | Closes the print dialog.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + G | Moves the focus to current page toolbar option.
Shift + rotate mouse wheel | Scrolls horizontally.
Rotate mouse wheel | Scrolls vertically.
F5 | Refreshes the report.

See Also

Developers
WPF Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print in Desktop Viewers

Print in Desktop Viewers
See Also
Report Readers > Desktop Viewers > Print in Desktop Viewers

Glossary Item Box

The advanced report printing options in ActiveReports Viewer allow end-users to specify a printer and set options like page scale, page margins, and watermark.

Set Advanced Print Options

  1. In the Viewer toolbar, click the Print button. See Windows Forms Viewer for information on the Viewer toolbar.
  2. In the Print dialog, click Advanced.
  3. In the Page Setup dialog, go to the Layout tab to set page scaling and page margins, and Watermark tab to set watermark text.
Property | Description
Layout Set page scaling and page margins.
Advanced Print Options Layout Settings
Page Scaling

Choose from any of the following options to set the page scaling:

  • Fit to printable area
  • Shrink to printable area
  • Multiple pages per sheet
  • Booklet
Pages per sheet | Specify the pages per sheet in case you select 'Multiple pages per sheet' in 'Page Scaling'.
Page order | Specify the page order in case you select 'Multiple pages per sheet' in 'Page Scaling'.
Print page border

Select whether to print the page border from:

  • Horizontal
  • Horizontal Reversed
  • Vertical
  • Vertical Reversed
Auto-Rotate Pages | Select the check-box if you want to set the page orientation based on the content and the page size.
Margins | Enter the values for the Left, Top, Right, and Bottom margins for the page.
Watermark Specify the watermark text and other settings.
Advanced Print Options Watermark Settings
Text | Specify the watermark text.
Font | Specify the font style of the text.
Size | Specify the font size of the text.
Color | Set a color for the watermark text.
Angle | Enter a numeric value between 0 and 360. A value of 0 renders straight left-to-right text. A value of 180 renders inverted text.

See Also

Print Presets

Developers
Print Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Export in Desktop Viewers

Export in Desktop Viewers
See Also
Report Readers > Desktop Viewers > Export in Desktop Viewers

Glossary Item Box

Your application with the ActiveReports Viewer can contain any exports with any available dialogs. You can export your reports from ActiveReports Viewers to various formats, depending on the report type. This topic discusses all possible export options.

Note: As export options are customizable, the Export dialog may display a different list of export options.

To export a report in the Viewer, go to File menu and select Export (Ctrl+E).

Viewer Export Dialog

Below you can find full information on properties of each export format option.

Page/RDLX reports

For Page and RDLX reports, the following export formats are available.

  • Portable Document Format (PDF)
  • Microsoft Excel WorkSheet (XLS, XLSX)
  • Microsoft Excel WorkSheet - Data (CSV, XLSX)
  • Microsoft Word Document (DOC, DOCX)
  • Comma-separated values (CSV)
  • JavaScript Object Notation (JSON)
  • Text Print (TXT)
  • Image Format (BMP, GIF, JPEG, TIFF, PNG)
  • Hypertext Markup Language (HTML)
  • MIME Hypertext Markup Language (MHT)
  • Rich Text Format (RTF)
  • eXtensible Markup Language (XML)

For RDLX Dashboard reports, the following formats are available.

  • Comma-Separated Values (CSV)
  • JavaScript Object Notation (JSON)
  • Text Print (TXT)
  • Microsoft Excel WorkSheet - Data (CSV, XLSX)
  • eXtensible Markup Language (XML)

Portable Document Format (PDF)

Portable Document Format (PDF) is a format recommended for printing and for preserving formatting.

PDF is considered as the best format for printing and it also supports interactive features like Document Map, Bookmarks and Hyperlinks. However, in case you have any data hidden (like in a drill-down report) at the time of rendering, it does not show up in the output.

PDF Rendering Properties

Property | Description
Application | Set the value that appears for application in the Document Properties dialog of the PDF viewer application.
Author | Enter the name of the author to appear in the Document Properties dialog of the PDF viewer application.
CenterWindow | Set to True to position the document's window in the center of the screen.
DisplayMode | Specifies how the document is displayed when opened. FullScreen mode displays the document with no menu bar, window controls, or any other window visible.
DisplayTitle | Set to True to display text you enter in the Title property. When set to False it displays the name of the PDF file.
DocumentToAddAfterReport | Indicates the path of the PDF document to be inserted at the end of the rendering output.
DocumentToAddBeforeReport | Indicates the path of the PDF document to be inserted at the beginning of the rendering output.
DpiX | Set the horizontal resolution of the rendered PDF file.
DpiY | Set the vertical resolution of the rendered PDF file.
EmbedFonts | Select how the fonts used in the report should be embedded in the PDF document. Note: By default, all fonts get embedded in the exported PDF document.
Encrypt | Determines whether the document is encrypted or not. Note: If Encrypt is set to False, permissions and passwords have no effect.
EndPage | The last page of the report to render. The default value is the value for StartPage, that is, 0.
FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Keywords | Keywords associated with the document.
NeverEmbedFonts | Gets or sets the semicolon-delimited string of the font families to be embedded in the PDF document.
OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Pagination | Gets or sets the value that indicates whether to use pagination in the exported PDF document.
Permissions | Specifies the user permissions for the document. Permissions can be combined using a comma between values.
PrintLayoutMode | Specifies layout mode to be used for PDF document.
PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
PrintPresets | Gets or sets the PDF print preset dialog.
SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered.
Subject | The subject of the document.
Title | The title of the document.
UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Version | Set the PDF version. The supported versions are: PDF-1.2 | PDF-1.3 | PDF-1.4(default) | PDF-1.5 | PDF-1.6 | PDF-1.7 | PDF-2.0 | PDF/A-1a | PDF/A-1b | PDF/A-2a | PDF/A-2b | PDF/A-2u | PDF/A-3a | PDF/A-3b | PDF/A-3u | PDF/UA-1
WatermarkAngle | Specify the degree of angle for the watermark text on the PDF document. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the PDF document. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFontName | Set the font to use for the watermark on the PDF document.
WatermarkFontSize | Set the font size to use for the watermark on the PDF document.
WatermarkFontStyle | Set the font style to use for the watermark on the PDF document.
WatermarkPrintOnly | Specify whether to print a report with a watermark on it. The default value is False.
WatermarkTitle | Enter text (i.e. CONFIDENTIAL) to use as the watermark on the PDF document.

Microsoft Excel WorkSheet (XLS, XLSX)

You can export excel files in two formats: Xls and Xlsx. XLSX is a format that opens in Microsoft Excel as a spreadsheet. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats. The XLSX export filter has a number of useful properties that allow you to control your output.

Reports rendered in Excel support a number of interactive features like Bookmarks and Hyperlinks. However, in case you have any data hidden at the time of rendering (like in a drill-down report), it does not show up in the output. It is recommended that you expand all toggle items prior to rendering.

Excel Rendering Properties

Property | Description
Author | Gets or sets the name of the author of the document.
Categories | Sets the name of the categories that appears in the Categories field in the Properties of the exported Excel document.
FileFormat | Specifies the output format of the Excel document, i.e. Xls or Xlsx.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Strict: The default value.
  • Transitional: The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices.
PageSettings | Initializes Excel file print settings: PageOrientation and PaperSize.
Pagination | Forces pagination or galley report layout mode.
RightToLeft

Shows direction of sheets from right to left.
Security | Initializes the document security.
SheetMode

Indicates how to split the report pages into the excel sheets. You can choose from the following modes:

  • PagePerSheet: Each report page is exported to a separate excel sheet
  • SectionPerSheet: Each report section is exported to a separate excel sheet
  • SingleSheet: Entire report is exported to a single excel sheet
SheetName | Indicates the name of the sheet.
Title | Gets or sets the title of the document.
UseCompression | Indicates whether to use compression when exporting document to an Xlsx file.
UseDefaultPalette | Indicates whether to export the document with the default Excel palette.

Microsoft Excel WorkSheet - Data (CSV, XLSX)

You can export excel files in two formats, Xlsx and Csv.

Excel Data exports only data from Tablix, Table, and Matrix data regions, preserving the data region structure and ignoring layout-related features (page break, cumulative total, etc). Other controls and data regions of the original report are ignored at this export.

Note: If a report does not contain any data region (Table or Tablix), a Csv file is not generated.

For the Xlsx format, when a report has multiple data regions, each data region is exported to a separate excel sheet.

For the Csv format, a separate CSV file is created for each data region, available in the report.

Excel Data Rendering Properties

Property | Description
Csv | Csv related properties. See Csv Rendering Properties below.
FileFormat | Indicates whether to use Csv or OpenXml format for the output file.
Xlsx | OpenXml related properties. See Xlsx Rendering Properties below.

Csv Rendering Properties

Property | Description
ColumnsDelimiter | Sets or returns the text inserted between columns.
DateTimeFormat | Specifies the default format for date values.
Encoding | Specifies the encoding schema for output.
NoHeader | Specifies whether to omit the CSV Header.
NumericFormat | Specifies the default format for numeric values.
QuotationSymbol | Sets or returns the qualifier character to put around results.
RowsDelimiter | Sets or returns the text inserted between rows.

Xlsx Rendering Properties

Property | Description
AllowImages | Indicates whether to allow images or just plain data content.

Author

Gets or sets the name of the author of the document.
AutoRowsHeight | Indicates whether to export rows height or specify auto height.
Categories

Sets the name of the categories that appears in the Categories field in the Properties of the exported Excel document.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Strict: The default value.
  • Transitional: The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices.
RightToLeft

Shows direction of sheets from right to left.
Security | Sets the document encryption and security.
Title | Gets or sets the title of the document.
UseCompression | Indicates whether to use compression on exporting to an Xlsx file.

Microsoft Word Document (DOC, DOCX)

You can export Page reports and RDLX reports to Microsoft Office Open XML (OOXML) format (.Docx) or Word HTML format (.Doc) using the FileFormat property.

The Word HTML format (.Doc) provides greater layout accuracy for Page and RDLX Reports in Microsoft Word, while the OOXML format (.Docx) provides excellent editing experience for the exported reports.

Note: OOXML and Word HTML formats have a great difference: while Word HTML is almost WYSIWYG, OOXML allows editing and has a number of limitations. To learn about the limitations for both Word HTML and OOXML, see Word Export.

The OOXML format (.Docx) is recommended in the following scenarios:

  • Open exported reports in a wide range of applications: You can open and modify the exported Word document in any of the following applications.
    • Microsoft Office 2013+
    • Microsoft Office for Mac 2016+
    • iWork and Pages for OS X (all supported versions)
    • LibreOffice
    • Google Quickoffice for Android
    • Documents Free (Mobile Office Suite) by SavySoda for iOS
  • Customize reports after exporting: Positioning and arrangement of report elements in the exported document is implemented using the OOXML format (.Docx) which provides a natural document flow for editing the exported documents.
  • Use Word automation features: With support for automation features in the OOXML format (.Docx), tasks that previously required manual adjustments in the exported Word document are now handled automatically. Report elements such as page header and footer, expressions, heading levels, and table of contents are automatically transformed to the OOXML format (.Docx).
  • Set compatibility mode: You can render a report as a Word document that is compatible with Microsoft Word 2007, 2010, or 2013 using the DocumentCompatibleVersion property from the export settings.

Word Rendering Properties

Common properties

Property | Description
Author | Sets the name of the author that appears in the Author field of the Properties dialog in the rendered Word document.
Categories | Sets the name of the categories that appears in the Categories field in the Properties of the exported Word document.
FileFormat | Sets the output file format to HTML (.Doc) or Office Open XML (OOXML) (.Docx). By default the file format is set to HTML format.
Title | Sets the title for a document that appears in the Title field of properties dialog in the rendered Word document.

HTML format

Property | Description
BaseUrl | Sets the base URL for any relative hyperlinks that appear in the Hyperlink base field of the Properties dialog in the rendered Word document.
Generator | Sets the identity of the document generator in the rendered Word document.
PageHeight | Sets the height of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
PageWidth | Sets the width of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.

OOXML format

Property | Description
CompanyName | Sets the name of the organization or company that appears in the Company field of Properties dialog in the rendered Word document.
DocumentCompatibilityVersion

Sets the compatibility mode of the document to previous versions (Microsoft Word 2007 - 2013) of Word. By default the compatibility version is set to Word2013.

DpiX | Sets the horizontal resolution of the images in the rendered Word document. By default DpiX is set to 96.
DpiY | Sets the vertical resolution of the images in the rendered Word document. By default DpiY is set to 96.
PageSettings

Initializes Word document print settings wrt. PageOrientation and PaperSize.

  • PageOrientation: sets a value that specifies whether the document pages should be printed in portrait or landscape in the rendered Word document.
  • PaperSize sets the paper size for the page.
SecuritySettings

Sets the document encryption and security.

  • Password: Sets a password that must be provided to open the rendered Word document.
  • ReadOnlyRecommended: Sets a value that indicates whether Microsoft Office Word displays a message whenever a user opens the document, suggesting that the document is read-only.
  • WritePassword: Sets the write password that is required for saving changes in the rendered Word document.
TOCAutoUpdate | Automatically updates the TableOfContents control while opening the Word document. By default TOCAutoUpdate is set to False.

Comma-separated values (CSV)

Comma-Separated Values (CSV) is a form of structured data in a plain text. The text in a CSV file is saved as series of values separated by comma.

CSV Rendering Properties

Property | Description
ColumnsDelimiter | Sets or returns the text inserted between columns.
DateTimeFormat | Specifies the default format for date values, for example, 'yyyy-MM-dd'.
Encoding | Specifies the encoding schema for output.
NoHeader | Specifies whether to omit the CSV Header.
NumericFormat | Specifies the format for numeric values, for example, '0.####'.
QuotationMode Specifies whether to add double quotes to the exported data.
  • AutoQuote – Simple values are exported without quotes. The quotes are added only when the data contains column or row delimiters. This is the default export behavior.
  • AlwaysQuote – Exported values are always quoted.
QuotationSymbol | Sets or returns the qualifier character to put around results.
RowsDelimiter | Sets or returns the text inserted between rows.

JavaScript Object Notation (JSON)

JavaScript Object Notation (JSON) is a text-based data format in which the data is stored in the hierarchical form.

JSON Rendering Properties

Property | Description
Formatted | Specifies whether to format the file with tabs and spaces for readability.
QuotePropertyNames | Specifies whether to enclose property names in quotation marks.

Image Format (BMP, GIF, JPEG, TIFF, PNG)

Image Format option converts your report to an image file. Make sure that you select the ImageType property to any of the image formats available: BMP, GIF, JPEG, TIFF, and PNG.

By default, a separate file is created for each page in a report and an index to each corresponding file name is added (for example, image001.PNG, image002.PNG, etc).

Reports rendered as images do not support any of the interactive features of ActiveReports reports. Any data hidden at the time of export is hidden in the image.

Note: To render the entire report as a single image, set the Pagination property to False.

Image Rendering Properties

Property | Description
Compression | Sets or returns a value which specifies the compression to be used when exporting.
Dither | Specifies whether the TIFF image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
DpiX | Adjust the horizontal resolution of rendered images. The default value is 200.
DpiY | Adjust the vertical resolution of rendered images. The default value is 200.
ImageType | Select the type of image to which you want to render the report. Supported types are BMP, GIF, JPEG, TIFF, and PNG.
Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Quality | Gets or sets the quality of the report to be rendered as a JPEG image.

Hypertext Markup Language (HTML)

HTML, or hypertext markup language, is a format that opens in a Web browser. You can export your reports to HTML format. It is a good format for delivering content because virtually all users have an HTML browser.

Reports rendered in HTML support a number of interactive features. Hyperlinks, Bookmarks and Drill through links can be rendered to HTML. However, Document Maps are not available in this format. For a drill down report, make sure that the data you want to display is expanded before rendering, otherwise it renders in the hidden state.

Note: HTML is not the best format for printing. Use the PDF rendering extension instead.

HTML Rendering Properties

Property | Description
EmbedImages | Set to true to embed image in the html file.
Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is False.
OutputTOC | Indicates whether the report's existing TOC should be added in the output.
RenderingEngine | The RenderingEngine property is set to Mixed by default for improved quality output. The choices are Html or Mixed, where Mixed uses SVG to render charts.
StyleStream | Set the StyleStream to True to create an external .css file containing style information from your report controls' style properties. If you prefer to have style information embedded in the HTML file, set the StyleStream property to False.
LinkTarget | Specify a link target to control whether drill down reports and other links open in a new window or reuse the current window. By default, no value is set and links open in the same window. A value of _blank opens the link in a new window, or you can specify a window using window_name. By default this value is not set.
Mode | Galley mode renders the report in one HTML stream. Select Paginated mode to render each page as a section inside the HTML document.

MIME Hypertext Markup Language (MHT)

The MHT file extension refers to MIME HTML documents, a format for archiving web pages saved by web browsers, including Internet Explorer and Firefox. MHT files can contain resources like images, flash, java, audio, external links and html code. At that, MHT files contain all elements within a single file.

MHT Rendering Properties

Property | Description
Fragment | Set to True to return only the contents inside the body tags (to embed it within a Web page). Set to False to return the full HTML text.
Output TOC | Indicates whether to include a table of contents, if available, in the exported report.
Mode | Select Paginated to render each page as a section inside the HTML document, with page headers and footers. The Galley mode renders one long page with a single page header and footer.
Link Target | Enter a value of a target for hyperlinks contained inside a report. A value of _blank opens a new window; _self opens in the same window.

Rich Text Format (RTF)

Note: The RTF export, otherwise supported only in Section reports, is possible in Page/RDLX reports too since this export uses the section report document (RDF format) internally.

RTF or RichText format, opens in Microsoft Word, and is native to WordPad. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats.

RTF Rendering Properties

Property | Description
EnableShapes | Indicates whether to export the Shapes and Lines to the RTF format if set to True. Microsoft Word is required to view it correctly.
Pagination | Indicates whether to use pagination for the output RTF document.

eXtensible Markup Language (XML)

XML is a useful format for delivering data to other applications as the resulting XML file opens in an internet browser.

XML format does not support interactive features except that when rendering a report to XML, complete drill-down data is shown regardless of whether the data is rendered in expanded state or not.

Xml Rendering Properties

Property | Description
Encoding | Select the encoding schema to use in the XML transformation.
XslStylesheet | Select the existing XSL Stylesheet file to use to transform the resulting XML file. Note: When using the XslStylesheet option, be sure to save the file in the correct file format, such as HTML.

Text Print (TXT)

Text Print is a format recommended for printing the reports with Table and Tablix data regions in the tabular format, preserving the grouping, layout, and formatting.

Xml Rendering Properties

Property | Description
CharHeight | Specifies the character height in points.
CharWidth

Specifies the character width in points.
FontFamily

Specifies the monospace font family. You can choose from Consolas, Courier New, and Lucida Console.
FontSize | Specifies the font height in points. Recommended values are: 11 for Consolas, 10 for Courier New, and 10 for Lucida Console.
HorizontalPaddings

Specifies the horizontal padding:

  • Keep: Retain the original padding
  • Adjust: Adjust the padding
  • Remove: Remove the padding
LineEnding | Specifies the end of a line.

Section Reports

For Section reports, you can use these export format options.

  • Portable Document Format (PDF)
  • Microsoft Excel Workbook (XLS, XLSX)
  • Hypertext Markup Language (HTML)
  • MIME Hypertext Markup Language (MHT)
  • Rich Text Format (RTF)
  • Tagged Image Format (TIFF)
  • Plain Text (TXT)

PDF Document Format (PDF) (Section report)

PDF Rendering Properties

Property | Description
ConvertMetaToPng | Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
ExportBookmarks | Sets or returns a value indicating whether bookmarks are exported to the PDF document.
FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in the original font.
ImageInterpolation | Specifies the images interpolation value. Allows to enable/disable image interpolation, when exporting the file to PDF.
ImageQuality | Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
ImageResolution | Sets or returns the resolution of images converted from metafiles.
NeverEmbedFonts

Sets or returns a semicolon-delimited string of values indicating fonts that should not be embedded in a PDF document.

Note: When you add fonts to NeverEmbedFonts property, 2 bytes characters may be distorted in PDF output since the export filter in such cases uses the glyphs from the default system font.
Options | Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Application | Set the value that appears for application in the Document Properties dialog of the PDF viewer application.
Author | Enter the name of the author to appear in the Document Properties dialog of the PDF viewer application.
CenterWindow | Set to True to position the document's window in the center of the screen.
DisplayMode

Select how to display bookmarks when the document is first opened.

  • None (default) bookmarks are not displayed until opened by the user.
  • Outlines shows bookmarks in outline format.
  • Thumbs shows bookmarks as thumbnails.
  • FullScreen shows the document in full screen, and bookmarks are not displayed.
DisplayTitle | Set to True to display text you enter in the Title property. When set to False it displays the name of the PDF file.
FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Keywords | Keywords associated with the document.
OnlyForPrint | Indicates whether the PDF is only for print.
Subject | The subject of the document.
Title | The title of the document.
PrintPresets | Returns an object allowing you to specify the print presets.
Security | Returns the PdfSecurity object for initializing document encryption and security.
Encrypt Determines whether the document is encrypted or not.
Note: If Encrypt is set to False, permissions and passwords have no effect.
OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Permissions | Specifies the user permissions for the document. Permissions can be combined using a comma between values.
UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Version | Sets or returns the version of the PDF format the exported document is saved in.
Pagination | Gets or sets the value that indicates whether to use pagination in the exported PDF document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
Watermark | Specifies whether a report is exported to PDF with a watermark on it.

Microsoft Excel Workbook (XLS, XLSX) (Section report)

Excel Rendering Properties

Property | Description
AutoRowHeight

Sets the height of rows based on the contents. Otherwise, XlsExport calculates the height of rows.
DisplayGridLines | Indicated whether to export the document with grid lines.
MinColumnWidth | Specifies the minimum width (in inches) of the column in the exported document.
MinRowHeight

Specifies the minimum height (in inches) of the row in the exported document.
PageSettings | Initializes Excel file print settings: PageOrientation and PaperSize.
Pagination | Forces pagination or galley report layout mode. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
RemoveVerticalSpace | Specifies whether to completely remove empty vertical spacing from the output.
RightToLeft

Shows direction of sheets from right to left.
SheetName | Specifies the name of the sheet.
Security | Initializes the document security.
UseDefaultPalette | Indicates whether to export the document with the default Excel palette.
FileFormat | Specifies the output format of the Excel document, i.e. Xls or Xlsx.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Strict: The default value.
  • Transitional: The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices.
MultiSheet | Indicates whether to generate a single-sheet or multi-sheet Excel document.
EnableToggles | Allows to export collapsible rows in the detail and row groups of the Table control of an RDLX report. This property gets displayed in the Export menu when the Pagination property is set to False
UseCellMerging | Set to True to merge the cells together.
UseCompression | Indicates whether to use compression on exporting an Xlsx file.

Hypertext Markup Language (Section report)

HTML Rendering Properties

Property | Description
BookmarkStyle | Sets or returns a value indicating whether to create a page of bookmarks if the ActiveReports document contains bookmarks.
CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Output Type | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Pagination | Gets or sets the value, that indicates whether to use pagination for the resultant html document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
RemoveVerticalSpace | Sets or returns a value indicating whether to completely remove empty vertical spacing from the output.
Title | Sets or returns the Title used in the header of HTML pages.

MIME Hypertext Markup Language (MHT) (Section report)

The MHT file extension refers to MIME HTML documents, a format for archiving web pages saved by web browsers, including Internet Explorer and Firefox. MHT files can contain resources like images, flash, java, audio, external links and html code. At that, MHT files contain all elements within a single file.

MHT Rendering Properties

Property | Description
BookmarkStyle | Sets or returns a value indicating whether to create a page of bookmarks if the ActiveReports document contains bookmarks.
CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Output Type | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Pagination | Gets or sets the value, that indicates whether to use pagination for the resultant html document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
RemoveVerticalSpace | Sets or returns a value indicating whether to completely remove empty vertical spacing from the output.
Title | Sets or returns the Title used in the header of HTML pages.

Rich Text Format (RTF) (Section report)

RTF, or RichText format, opens in Microsoft Word, and is native to WordPad. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats.

RTF Rendering Properties

Property | Description
EnableShapes | Indicates whether to export the Shapes and Lines to the RTF format if set to True. Microsoft Word is required to view it correctly.
Pagination | Indicates whether to use pagination for the output RTF document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.

Tagged Image Format (TIFF) (Section report)

TIFF Rendering Properties

Property | Description
CompressionScheme | Specifies the compression scheme to be used when exporting a TIFF file.
Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
DpiX | Adjust the horizontal resolution of rendered images. The default value is 96.
DpiY | Adjust the vertical resolution of rendered images.
Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.

Plain Text (TXT) (Section report)

Export your ActiveReports documents to plain text.

TXT Rendering Properties

Property | Description
Encoding | Gets or sets the character encoding used for the exported text.
PageDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a page.
QuotationMode | Specifies whether to add double quotes to the exported data.
QuotationSymbol | Gets or sets the quotation symbol.
SuppressEmptyLines | Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
TextDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a text field.

See Also

Print Presets

Developers
Export Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print Presets

Print Presets
See Also
Report Readers > Desktop Viewers > Export > Print Presets

Glossary Item Box

To economize your efforts each time a PDF document is printed, you can preset basic print options when exporting a report to a PDF format.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.

Set PDF Print Presets using Export Dialog

  1. Open the Export dialog.
  2. In the Export Format field of the Export dialog, select Portable Document Format (PDF).
  3. Expand PrintPresets options and set the required properties for print presets.
    PDF Export Print Presets Options
    Note: These properties are available in PDF version 1.7 or higher.
Property | Description
DuplexMode | Specify the printer duplex mode.
NumberOfCopies | Specify the number of print copies.
PageScaling | Specify the page scale. The PageScaling property is supported in PDF version 1.6.
PaperSourceByPageSize | Set it to 'True' to set the page size according to the PDF page size rather than the page specified in the page setup option.
PrintPageRange | Specify the page range to print.

See Also

Developers
Set PDF Print Presets

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Annotations

Annotations
Report Readers > Desktop Viewers > Annotations

Glossary Item Box

Annotations are floating text bars or images to call attention to specific items or values or to add notes and special instructions directly to the reports. Annotations added via the viewer's toolbar are temporary and are destroyed when the report closes.

These annotations are accessible through the Annotation button present on the Viewer toolbar which is hidden by default. You can make the Annotations toolbar visible by setting the AnnotationDropDownVisible property to True in the viewer's Properties panel.

Available Annotations

Each annotation type allows you to change the colors, transparency, border, font, and alignment, plus other properties specific to the type of annotation. Available annotations include:

Annotation Name | Description
AnnotationText AnnotationText annotation | A rectangular box to enter text using the Text property.
AnnotationCircle AnnotationCircle annotation | A circle without text. You can change the shape to an oval by dragging its corners.
AnnotationRectangle AnnotationRectangle annotation | A rectangular box without text. You can change the shape to a square by dragging its corners.
AnnotationArrow AnnotationArrow annotation | A 2D arrow to enter text using the Text property. You can also change the arrow direction using the ArrowDirection property.
AnnotationBalloon AnnotationBalloon annotation | A balloon caption to enter text using its Text property. You can also point the balloon's tail in any direction using its Quadrant property.
AnnotationLine AnnotationLine annotation | A line to enter text above or below it using its Text and LineLocation properties. You can also add arrow caps to one or both ends and select different dash styles using DashCap, DashStyle, and ShowArrowCaps properties.
AnnotationImage AnnotationImage annotation | A rectangle with a background image and text. You can select an any image inside it using the BackgroundImage property. You can also place text on the image using the Text property.

Add annotations in the Viewer

These steps assume that you have already placed the Viewer control onto a Windows Form and loaded a report in it. See Windows Forms Viewer for more information.

  1. In your Visual Studio project, on the Form where the Viewer control is placed, select the Viewer control an right-click to choose Properties.
  2. In the Properties Panel that appears, set the AnnotationDropDownVisible property to True to get an additional toolbar in the viewer control.
    Toolbar
  3. Run the report application and select the annotation you want use from the Annotation toolbar on the Viewer.
  4. Drag the annotation to the desired location on the report design surface. The annotation appears with a Delete and a Properties button on the top left corner.
    Delete and Properties button
  5. Inside the annotation, click the Properties button to view its properties in the Properties Panel and use those properties to enter text, change color or transparency, set border or font, alignment etc.
  6. Close the Properties Panel to apply changes to the annotation.
  7. Drag the corners to resize the annotation as needed. You can also select entire annotation to move it to another location on the report.
  8. Right-click the annotation to display the annotation context menu. The context menu includes the Properties and Delete commands.
    Delete and Properties command
Note: You can print a Page, RDLX or Section Report that contains annotations. In a Section Report, you can also save a report with annotations in RDF format. See Add and Save Annotations for further details.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Web Viewers

Web Viewers
Report Readers > Web Viewers

Glossary Item Box

With Web Viewers, you can view reports in Blazor, ASP.NET Core, ASP.NET MVC, Angular, React, HTML5/JS applications. These viewers are lightweight with built-in support for client-side printing. Like Desktop Viewers, the Web Viewers are feature-rich that allow you to easily view, print, and export reports. The viewers are highly interactive, giving you the ability to enter parameters, perform sort and drill down, navigate to other reports using drill-through links, and so on. Multiple View Modes let you display your reports as Paginated, Continuous, or in Galley view. In addition, the viewers are customizable and localizable according to your personal needs.

The viewer API lets you customize the viewers and blend them into your web page. You can add or hide features or buttons on viewers toolbar and sidebar, you can customize the parameters panel, and so on. For this, you must have hands-on experience in coding, see this set of articles for details.

  • JS Viewer Application
  • Blazor Viewer Application
  • ASP.NET WebViewer Application

As Report Readers, let us focus on the UI of Web Viewers.

Web Viewer UI

Viewer UI

Viewer Sidebar

Sidebar Element | Name | Description
Display Sidebar button | Display Sidebar | Displays the sidebar that includes the Search, Export, and Parameters panes.
Search button | Search | Displays the Search pane.
Export button | Export | Displays the Export pane where you can select an export format and options for the report you are previewing.
Parameters button | Parameters | Displays the Parameters pane. If a report does not have parameters, the Parameters button is not displayed.
Table of Contents button | Table of Contents | Displays the Table of Contents pane. If a report does not have the Label property or Document map label set, the Table of Contents or Documents map pane does not appear.

Viewer Top Toolbar

Toolbar Element | Name | Description
Go to First page button Go to Last page button | Go to First/Last page | Jumps to the first or last page of a report.
Go to Previous/Next page buttons Go to Next page button | Go to Previous/Next page | Navigates through a report page by page.
Current page button | Current page | Displays the current page number and page total. Enter the page number to view a specific page.
Refresh button | Refresh | Refreshes the report.
History: Back to Parent button | History: Back to Parent | Returns to the parent report in a drill-down Page Report or RDLX report.
History: Go Back button | History: Go Back | Navigates to a previous page in a parent report in a drill-down Page Report or RDLX report.
History: Go Forward button | History: Go Forward | Navigates to a next page in a parent report in a drill-down Page Report or RDLX report.
Move button | Move Tool | A move tool that you can use to navigate the report.
Zoom Out button | Zoom Out | Decreases the magnification of your report.
Zoom mode button | Zoom mode | Displays the current zoom percentage which can also be edited. Allows you to select from the available zoom options - 50%, 100%, 150%, 200%, 300%, Fit to Page, and Fit to Width.
Zoom In button | Zoom In | Increases the magnification of your report.
Toggle Fullscreen button | Toggle Fullscreen | Switches to a Fullsreen mode.
Print button | Print | Displays the Print screen to specify printing options.
Single Page View button | Single Page View | Shows one page at a time in the viewer.
Continious View button | Continuous View | Shows all preview pages one below the other.
Galley mode button | Galley mode | Provides a viewer mode which removes automatic page breaks from an RDLX report and displays data in a single scrollable page. This mode maintains page breaks you create in the report.

Viewer Search

The Search pane lets you enter a word or phrase for which to search within the report. Under Use these additional criteria, you may optionally select additional criteria. When you click Search, any results appear in the Find results list. Click an item in the list to jump to the item you selected and highlight it.

Viewer Export

To display the Export pane, click Export in the sidebar. The Export pane lets you enter parameters for exporting a report that you are previewing. The available format options for Page/RDLX reports are Excel 2003, Excel, Word 2003, Word, PDF, CSV, JSON, XML, Tagged Image, Web Archive, and Excel Data (hidden by default).

The available format options for Section Reports are Rich Text Format, Excel 2003, Excel, PDF, Tagged Image, Plain Text, and Web Archive.

After you set all necessary export properties, click Export.

Viewer Parameters Pane

The Parameters pane appears when you click the Parameters button in the sidebar. In the Parameters pane, enter a value to filter the data to be displayed and click Preview.

If a report does not have parameters, the Parameters pane is disabled.

JSViewer supports previewing a custom parameter panel, designed in ActiveReports WebDesigner.

Viewer Table of Contents Pane

The Table of Contents pane appears when you click the Table of Contents button in the sidebar. Click any TOC item to navigate to the corresponding section of the report in the Viewer.

Note that the Table of Contents is only available for reports with Bookmarks. The Table of Contents displays each value for the text box, group, or subreport that you bookmark, and you can click them to navigate to the corresponding section of the report in the Viewer.

Table of Contents pane

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Export

Export
Report Readers > Web Viewers > Export

Glossary Item Box

Use the Export button to export RDLX and Page reports to the following export formats:

  • Excel 2003 (.xls)
  • Excel (.xlsx)
  • Word (.docx)
  • Word 2003 (.doc)
  • PDF (.pdf)
  • CSV (.csv)
  • JSON (.json)
  • XML (.xml)
  • Tagged Image (.tiff)
  • Web Archive (.mht)

The following exports are supported in RDLX Dashboard reports:

  • CSV (.csv)
  • JSON (.json)
  • XML (.xml)
  • Excel Data (.xlsx)
  • Text Print (.txt)

The following exports are supported in Section reports:

  • PDF (.pdf)
  • Excel (.xlsx)
  • Excel 2003 (.xls)
  • Tagged Image (.tiff)
  • Web Archive (.mht)
  • Plain Text (TXT)
  • Rich Text Format (RTF)

The Export dialog enables you to export the report preview results to a file with several options to fill. Please see Predefined Export Settings for more details on the export settings and how a developer can predefine export settings via code.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Authors

Report Authors

Glossary Item Box

A report author prepares a complete report—designs the layout of the report, defines data sources and datasets, uses the data regions and report items/controls to represent data.

ActiveReports provides report authors with a compiled tool—a standalone designer application for desktop applications. The predefined templates and simple drag-and-drop operations in the designer make report designing easy and quick, without using any code.

Another designer that allows end-users to create ad hoc reports in all major browsers is WebDesigner, available for the ASP.NET Core MVC application. The rich API enables UI customization based on the functionality you want the users to experience.

Developers may be report authors, who can in addition use the Visual Studio Integrated Designer to create report layouts in Visual Studio and edit them at design time, visually and through code, script, or expressions, and prepare applications based on the Win or Web samples; for example, see the FlatEndUserDesigner sample.

The Report Authors section assumes that you are using the standalone designer application as the primary way to create your report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Standalone Designer

Standalone Designer
See Also
Report Authors > Standalone Designer

Glossary Item Box

ActiveReports provides the standalone designer application ActiveReports.Designer.exe, which supports all types of reports - Page, RDLX, RDLX Dashboard, and Section. The application can be launched by installing the ActiveReports installer package. The standalone designer application appears with an RDLX layout by default.

You can run the standalone report designer application by selecting the ActiveReports 19 Designer from the Start menu, or by running the ActiveReports.Designer.exe from the C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools\ location.

The standalone designer application can be used to create a report layout, save it in .rpx or .rdlx format and then load it in the WinForms Viewer application to view the report.

Design area

The UI of ActiveReports designer application consists of the following regions:

Quick Access Toolbar

The Quick Access Toolbar contains a set of quickly accessible commands such as Undo, Redo, New, Open, and Save. It is located on the top-left corner of the app.

Standalone Designer Quick Access Toolbar

Toolbox

The Toolbox contains a set of elements including the Report controls.

Standalone Designer Toolbox

The key elements of the Toolbox are listed below:

  • Preview: Shows report preview.
  • Report Explorer: Provides an overview of the hierarchy of added report items and allows managing data sources, parameters, embedded images, embedded stylesheets, etc.
  • Group Editor: Shows Column and Row group hierarchies of Tablix members for currently selected Tablix data region. You can also switch between Horizontal and Vertical mode.
  • Layers: Provides options to add or remove layers and send the Layer back or bring it to the front. You can edit or customize any element only in the layer in which it was added.
  • Report Controls: Report controls to be used while creating a report, such as BandedList, Barcode, Bullet, Chart, CheckBox, Container, FormattedText, Image, InputField, Line, List, Map, Shape, Sparkline, Subreport, Table, TableOfContents, Tablix and TextBox.

Ribbon

Standalone Designer Ribbon

The Ribbon contains the following tabs:

  • File: Contains options to create, open, save reports or exit the designer. It also contains the version information in the About option.
  • Home: Consists of report editing options such as cut, copy, paste, and delete. It also provides shortcuts for text formatting such as font, font size, font color, and horizontal and vertical text alignments.
  • Layout: Contains options to align to grid, size to grid, bring to front, send to back and other sizing and spacing options.
  • Report: Contains options to define report parameters, embedded images, report properties, and add or remove header and footer (RDLX report), and change report stylesheets. It also contains option to create and manage report parts in case of RDLX report.
  • Script: Allows you to embed Visual Basic .NET or C# script in reports.

Properties panel

The Properties tab is located on the right-hand side of the app. Click the tab to view the Properties panel, which displays the properties of the selected report element. If more than one element is selected, only their common properties are shown.

Standalone Designer Properties panel

Library panel

The Library panel, located on the right-hand side of the app, is disabled by default. See Enable Report Library for details. Click the tab to view the Library panel, which allows adding reports to the designer along with its data source, dataset, parameter, etc. The elements of the reports added in the library can be used in creating a report.

Standalone Designer Library panel

Status bar

The Status bar appears like a horizontal bar at the bottom of the designer app.

Standalone Designer Status bar

The key elements of the status bar are listed below:

  • Grid Mode: Shows or hides the grid. Grids help in accurate placements of controls.
  • Zoom Support: Changes the zoom level of the design area by using zoom in (+) and zoom out (-) buttons, or by using shortcuts [Ctrl] + [+] to zoom in and [Ctrl] + [-] to zoom out.
  • Grid Settings: Includes the following settings:
    • Grid Size - Changes the size of the grid. The value should be between 0.025in and 2in.
    • Snap to Grid- Allows the selected control to snap to the grid at set locations.
    • Snap to Lines - Allows the selected control to snap to the vertical or horizontal lines relative to the position of other controls.
    • Dimension Lines - Displays the dimensions of the element when it is being resized.
  • Actual Size: Restores the actual size of the report.
  • Pan Mode: Easy report navigation by dragging it up or down.
  • Select Mode: Selects all the elements in the selected area.

Preview

When the user clicks the Preview button, a Preview window opens up as shown below:

Standalone Designer Preview

The Preview toolbar consists of the following elements:

  • Back: Back to the designer.
  • Side Panel: Includes the following elements:
    • Page Thumbnails - Displays thumbnails of all the report pages in the side panel.
    • Search Results - Searches any word or phrase.
  • Find: Opens Find window to find any word or phrase.
  • Copy: Copies the selected text on clipboard.
  • Export: Exports report to various formats like csv, json, jpeg, etc.
  • Print: Prints the report.
  • First Page: Navigates to the first page of the report.
  • Previous Page: Navigates to previous page. Page Number: Navigates to the specific page of the report.
  • Next Page: Navigates to the next page.
  • Last Page: Navigates to the last page of the report.
  • Backward: Navigates to the page you accessed before the current page.
  • Forward: Navigates to the page from where you accessed the current page.
  • Refresh: Refreshes the report.
  • View: You can select the following view modes from the dropdown list:
    • Single Page - Shows one page of a report at a time.
    • Continuous - Shows all pages of the report one below the other.
    • Galley - Shows RDLX reports by removing automatic page breaks and displaying data in a single scrollable page.
    • Multipage - Shows multiple pages at one glance in a tabular format.
  • Tools: Includes the following elements:
    • Pan - Easy report navigation by dragging it up or down.
    • Selection - Select report element(s).
    • Snapshot - Captures a snapshot and saves it on clipboard.
  • Zoom Support: Changes the zoom level of the design area by using zoom in (+) and zoom out (-) buttons, or by using shortcuts [Ctrl] + [+] to zoom in and [Ctrl] + [-] to zoom out.

Show Keyboard Shortcuts

The following shortcuts are available in the Standalone Designer.

 | Keyboard Shortcut | Action
Designing | Ctrl + A | Selects all cells in the Table and Tablix controls. In the List, Body and Container controls, selects all controls in the current container.
 | Ctrl + O | Opens the Open report dialog.
 | Ctrl + S | Opens the Save report dialog.
 | Ctrl + Z | Undoes the last action.
 | Ctrl + Y | Redoes the last action.
 | Ctrl + X | Cuts text and controls.
 | Ctrl + C | Copies text and controls.
 | Ctrl + V | Pastes text and controls.
 | Del | Deletes text and controls.
 | Left, Right, Up, Down arrow keys | Moves the visible area of the page in the corresponding direction. In the Table, navigates between the cells. When controls inside List and Container controls and in the Body of the report are selected, arrow keys allow moving controls by grid-size. In the Chart Control, arrow keys move data-fields and category-fields.
 | Tab | Navigates in the forward direction between the cells in the Table and Tablix controls. When controls inside List and Container controls and in the Body of the report are selected, Tab key switches between controls in the forward direction.
 | Shift + Tab | Navigates in the backward direction between the cells in the Table and Tablix controls. When controls inside List and Container controls and in the Body of the report are selected, Shift + Tab switches between controls in the backward direction.
 | Shift + rotate mouse wheel | Scrolls horizontally.
 | Rotate mouse wheel | Scrolls vertically.
Formatting | Ctrl + B | Makes the text bold.
 | Ctrl + I | Makes the text italic.
 | Ctrl + U | Underlines the text.
 | Ctrl + L | Aligns text to the left.
 | Ctrl + E | Aligns text to the center.
 | Ctrl + R | Aligns text to the right.
 | Ctrl + J | Aligns text justified.
 | Ctrl + T | Aligns text to the top.
 | Ctrl + M | Aligns text to the middle.
 | Ctrl + H | Aligns text to the bottom.
Previewing (F5) | Ctrl + F | Finds a text in the report.
 | Ctrl + E | Exports the report.
 | Ctrl + P | Prints the report.
 | Ctrl + S | Switches view mode to Single page.
 | Ctrl + M | Switches view mode to Continuous.
 | Ctrl + I | Switches view mode to Multiple page.
 | Shift + rotate mouse wheel | Scrolls horizontally.
 | Rotate mouse wheel | Scrolls vertically.

See Also

Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Quick Start

Quick Start
See Also
Report Authors > Standalone Designer > Quick Start

Glossary Item Box

Let us create a report to represent sales data using tables and charts.

Multi-Section RDL Report

Create Report in Visual Studio Integrated Designer

  1. Install ActiveReports.

  2. In Microsoft Visual Studio 2022 (version 17.0 or above), select ActiveReports 19 ASP.NET Core template and click Next.
    Create new project in Visual Studio
    For complete list of built-in templates, see the Project Templates.

  3. Type a name for your project and click Create.
    Configure Visual Studio new project

  4. In the New Report wizard, choose the Report Type as RDLX and click Next.
    Choose a Report Type from New Report Dialog
  5. In the Configure Page Settings screen that appears, adjust the report page settings and click Next >.
    Configure Page Settings

Bind Report to Data

  1. On the Choose Data Source Type screen of the wizard, select CSV and click Next. Choose Data Source Type as CSV
  2. On the Configure CSV Connection screen, specify the File Path by clicking the Browse button and navigating to the desired folder on your system. Let us bind data to the AcmeStore.csv file. See CSV topic for more information.
    Configure CSV Connection screen
  3. Click Next to proceed to the step of configuring CSV data fields.
    Configure CSV Data
  4. Click Next to proceed to the next step of selecting a report control.
  5. Select Chart and click Next >.
    Select Chart
  6. Let's design a chart that shows the total sales in different cities. On the Choose Chart Query and Plot Type screen, select Column in the Plot Type area and click Next >.
    Choose Chart Plot Type
  7. Configure chart data in the Configure Chart Data Values screen and click Next >. See Create Clustered Column Chart tutorial to visualize the data in a stacked column chart.
    Configure Chart Data Values
  8. At the next step, you can configure chart groupings.
    Configure Chart Data Groupings
  9. On the final screen of the Report Wizard, choose the report colors and preview the report.
    Report Wizard Final screen
  10. Click Finish to successfully add the report with the CSV data source. Inserting a new page

Design Report Layout

ReportSection2

  1. From the New tab that appears below the design area, add ReportSection2.
  2. In this section of the report, drag-drop the Table data region.
  3. Delete the third column of the table since we want to display payment methods and the order prices as the sales data. This data will be grouped by payment method, city, and region.
  4. Select the Details row, right-click, and select Insert Group from the context menu. We will be adding three groups - payment method, city, and region.
  5. In the Table - Groups dialog, add the groups and set the Name and Group on > Expression in the following sequence as follows:
    S.no. | Name | Expression
    1. | GroupByRegion | =[region]
    2. | GroupByCity | =[city]
    3. | GroupByPaymentMethod | =[payment_method]
  6. Click OK to close the dialog.
  7. Delete the Details row of the table.
  8. Populate the data in the Table data region as follows:
    1. Merge the first table group and in the Value property of the merged cell, enter the expression ="Region: "Fields!region.Value
    2. Merge the second table group and in the Value property of the merged cell, enter the expression ="City: "&Fields!city.Value
    3. In the third table group, enter the following expression in the first and second cell, respectively:
      1. =Fields!payment_method.Value
      2. =Sum(Fields!order_price.Value)
  9. Click the ReportSection2 tab and from the Properties panel, set PaperOrientation to 'Portrait'.
    Report Preview

ReportSection3

  1. From the New tab that appears below the design area, add ReportSection3.
  2. In this section, drag-drop a Chart data region to plot the average order price by payment method using a Bubble chart. See Create Bubble Chart tutorial to visualize the data in a bubble chart.
  3. Click the ReportSection3 tab and from the Properties panel, set PaperOrientation to 'Landscape'.
    Inserting a new page

ReportSection4

  1. From the New tab that appears below the design area, add ReportSection4.
  2. In this section, drag-drop a Table data region and drop the fields onto the table cells to display the average order price and payment method and the product item count.
  3. Click the ReportSection4 tab and from the Properties panel, set PaperOrientation to 'Portrait'.
    Inserting a new page

Preview Report

The final report is shown at the beginning of this page.

See Also

Standalone Designer

Developers
Visual Studio Integrated Designer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebDesigner

WebDesigner
Report Authors > WebDesigner

Glossary Item Box

ActiveReports WebDesigner is based on the HTML5/JS technology stack. The designer is an integrated reporting application that comes packed with a powerful yet intuitive user interface that facilitates users to create summarized and structured reports anywhere on any device. The designer supports all types of reports that a desktop designer supports - RDLX, RDLX Dashboard, Page, and Section.

WebDesigner Interface

The UI of WebDesigner Interface consists of the following regions:

WebDesigner Interface

Ribbon Tabs

The ribbon on the designer window consists of the following tabs:
Ribbon tabs

  • Undo/Redo: Undo or redo actions on the designer.
  • Save/Save as: Lets you save the report.
  • File: Contains options to create, open, or save all types of reports - Page report, RDLX report (+Master report), and Section report.
  • Preview: Shows the report preview.
  • Home: Consists of report editing options such as cut, copy, paste, and delete. It also provides shortcuts for text formatting such as font, font size, Text color, Background color and horizontal and vertical text alignments.
  • Layout: Contains options to align to grid, size to grid, bring to front, send to back and other alignment, sizing, and spacing options.
  • Report: Contains options to add continuous section, convert to master report, set master report (in RDLX report), switch themes, add, delete, hide, or move pages (in Page report), and add or remove header and footer (in Section report).
  • Section: Enables only in the RDLX report. It contains the options to add header or footer and add or move section.
  • Script: Enables you to use a VB.NET or C# script to port your custom logic to report layouts. This permits layout saved to report XML (.rpx) files to serve as standalone reports.

    Note: Following points must be noted in WebDesigner as compared to ActiveReports Designer control (see link):

    • Script tab is not available for any report except Section report. Users can still work with scripts, but cannot add or edit them directly.
    • The built-in code editor is currently a simple text area without any additional functionality like syntax highlighting.
  • Dashboard: Contains options to add, move, hide, duplicate sections and switch theme. This tab is available for the RDLX Dashboard Report only.
  • Parameters: Contains the design area for designing a custom parameter panel. The controls making the panel have default properties set, like name, label, default value, etc.

Menu Button

The Menu on the designer window contains the explorer, group editor, layers and report controls that assist in designing reports. You can preview the report by clicking on the Preview button.
Menu Button

  • Explorer: Provides an overview of the hierarchy of added report items. It displays the current selection and allows for the selection of other report items. The section names in Section report can also be viewed in the Explorer. To resize any section, use the Properties panel.
  • Group Editor: Shows column and row hierarchies of Tablix members for the currently selected Tablix or Table data region.
  • Layers: Opens the Layers List window that displays a list of layers in the report along with their possibility and lock options. See Layers for details.
  • Report Controls: Report controls to be used while creating a report. For an RDLX report, the report controls available are: TextBox, CheckBox, Container, Line, Shape, Table Of Contents, Image, List, Table, Tablix, Chart, Bullet, Barcode, Formatted Text, Sparkline, Subreport, Banded list, and Input Field.

Properties tab

The Properties tab is located on the right-hand side of the app. Click the tab to view the Properties panel, which displays the properties of the designer or the selected report element. If more than one element is selected, only their common properties are shown.

You can sort the properties in Section report using the vertical ellipses in the Properties tab, as shown:
Properties tab - Section Reports

In RDLX and Page reports, by default only basic set of properties are displayed. To view advanced properties, you need to change the property mode using the vertical ellipses in the Properties tab, as shown:

Properties tab - Page/RDL Reports

Data tab

Data tab is located next to the properties tab. It manages the data sources, data sets, parameters, and subreports. It also displays common values such as the current date and time, page number, total pages, and more.

Style Sheet tab

It contains styles, which are a set of properties that you can apply to selected controls in your reports to quickly change their appearance. In EUD you must open report’s properties dialog to edit the style sheet. In WebDesigner we have a separate tab for that.

Note: Style Sheet tab is available only for the Section report.

Designer Buttons
Designer Buttons

  • Designer Buttons: Designer buttons consist of options to change the appearance and behavior of the design area:
    • Grid: Click this option to show or hide the grid. Grids help in accurate placements of controls.
    • Grid Size, Snap to Grid, and Snap to Guides: Grid Size allows you to specify the size of the grid. When the Snap to Grid option is enabled, the selected control snaps to the grid at set locations. When the Snap to Guides option is enabled, the selected control snaps to the vertical or horizontal lines relative to the position of other controls. This is helpful for consistent spacing and alignment of controls.
      Note: Snap to Guides option is not supported in Section report's design area.
    • Ruler (disabled by default): When the ruler is enabled, you can drag the ruler's markers to change the report margins.
  • Zoom support: Using the zoom in (+) and zoom out (-) buttons, you can change the zoom level of the design area. You can also use shortcuts [Ctrl] + [+] to zoom in and [Ctrl] + [-] to zoom out.
  • Ruler Units: Lets you change the ruler measurements for a report to Centimeters (cm) or Inches (in) using ruler units.
  • Theme Picker: Lets you change the theme of the designer from the 'System Theme' and the themes defined via API.

Preview

When the user clicks the Preview button, a Preview window opens as shown below:

Preview the report

The Preview toolbar consists of the following elements:

  • Go To First: Navigates to the first page of the report.
  • Go to Previous: Navigates to the previous page.
  • Go To Next: Navigates to the next page.
  • Go To Last: Navigates to the last page of the report.
  • Refresh: Refreshes the report.
  • History: Back To Parent: Navigates to the parent report (only available for drill through report)
  • History: Go Back: Navigates to the previous page in the drill through report.
  • History: Go to Forward: Navigates to the next page in the drill through report.
  • Move Tool: Allows you to change the visible part of a page if it does not fit on the screen.
  • Zoom support: Changes the zoom level of the design area by using zoom in (+) and zoom out (-) buttons, or by using shortcuts [Ctrl] + [+] to zoom in and [Ctrl] + [-] to zoom out.
  • Toggle Fullscreen: Toggles the full screen.
  • Print: Prints the report.
  • Single Page View: Shows one page of the report at a time.
  • Continuous View: Shows all pages of the report one below the other.
  • Galley Mode: Shows RDLX reports by removing automatic page break and displaying data in a single scrollable page.

Show Keyboard Shortcuts

The following shortcuts are available in the WebDesigner.

Keyboard Shortcut | Action
Ctrl + A | Selects all cells in the Table and Tablix controls. In the List, Body and Container controls, selects all controls in the current container.
Ctrl + E | Opens the New Report page.
Ctrl + O | Opens the Open Report page.
Ctrl + S | Opens the Save Report page.
Ctrl + Z | Undoes the last action.
Ctrl + Y | Redoes the last action.
Ctrl + X | Cuts text and controls.
Ctrl + C | Copies text and controls.
Ctrl + V | Pastes text and controls.
Del | Deletes text and controls.
Left, Right, Up, Down arrow keys | Moves the visible area of the page in the corresponding direction. In the Table and Tablix controls, navigates between the cells. When controls inside List and Container controls and in the Body of the report are selected, arrow keys allow moving controls by grid-size. In the Chart Control, arrow keys move data-fields and category-fields.
Tab | Navigates in the forward direction between the cells in the Table and Tablix controls. When controls inside List and Container controls and in the Body of the report are selected, Tab key switches between controls in the forward direction.
Shift + Tab | Navigates in the backward direction between the cells in the Table and Tablix controls. When controls inside List and Container controls and in the Body of the report are selected, Shift + Tab switches between controls in the backward direction.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Quick Start

Quick Start
Report Authors > WebDesigner > Quick Start

Glossary Item Box

In tabular reports, the data is organized along the rows and columns of a Table data region. The data in the form of fields and entities is fetched from the data set added to the report.

This tutorial guides you through the steps to create a tabular report in ActiveReports WebDesigner.

After you complete this tutorial, you will have a report that looks similar to the following.

An Example for Tabular Report

Access the ActiveReports WebDesigner

Run the WebDesigner sample (WebDesigner_MVC(Core)) that you can download from the following link:

https://github.com/activereports/WebSamples19/tree/main/

The WebDesigner is opened in the browser and is ready to create your reports. By default, you have a blank RDLX Report.

Bind Data to Report

  1. Connect to a data source.
    1. Go to Data tab and click Add next to Data Sources.
    2. In the Data Source Editor dialog, fill-in the Name field as 'Customers'.
    3. Select Provider as 'JSON Provider'.
    4. Select Type as 'External'.
    5. Enter the following URL in Path: https://demodata.mescius.io/northwind/api/v1/Customers
    6. Test the data source connection and click Add.
  2. Add a dataset.
    1. Click Add Data Set next to the added data source.
    2. In the New Data Set dialog, fill-in a dataset name and enter the Query: $.[*]
    3. Validate the query to obtain the bound fields and select OK to add the dataset.

Create Data-bound Table

Create Table data region

  1. Expand the dataset fields and enable Select Fields...
  2. Select the required fields and drag and drop them onto the design area.

A table with its columns bound to the fields is created. The Header row above the Details row is automatically filled with labels.

Alternatively, you can first drag and drop the Table data region Table Toolbar Icon onto the design area of the report and then drag and drop fields onto the details row.

Sort Table Data

Apply sort on any field in the table data in ascending or descending order. Let us sort our table data by the customerId field in descending order.

  1. From the adorner on the right side of the table, select <Details Group> and go to the Sort Expressions property.
    Textbox Control
  2. Select Add Item.
  3. Click the radio button to display the fields and select the 'customerId' field.
    Sort Expression

    Note: You can also enter a sort expression in the Expression Editor: Data - Sort Expressions dialog by selecting Expression...
  4. Click descending Sort Descending Icon icon to sort the 'customerId field' in descending order. You can change the sort order to ascending by clicking the ascending Sort Ascending Icon icon (default).

Group Table Data

You can organize the table data in groups to add more meaning to the table. Let us group the table with respect to the country field, so that our table displays unique country values.
  1. From the adorner on the right side of the Table data region, select <Details Group>, and go to the Properties pane.
  2. Next to the Group Expressions property, click Add Item.
  3. Click the radio button to display the fields and select the 'country' field.
    Group Expressions in Table

Add Report Title

  1. Drag and drop a TextBox control Textbox Control above Table data region.
  2. Click inside the text box and enter the text 'Customer Report'.

Customize Appearance of Tabular Report

An Example for Customized Tabular Report

Note: You may need to resize and reposition the controls on the report to accommodate data, and for a cleaner look.
  1. To customize the Page Header, set the BACKGROUND - Color property to '#f1f1f1'.
  2. Select the text box containing the text 'Customer Report' and set the following properties.
    Property | Value
    TEXT - Color | #3da7a8
    TEXT - Font Size | 16pt
    TEXT - Text Align | Left
    TEXT - Vertical Align | Middle

  3. To customize Header row of the table, set the following properties for all text boxes in the row.
    Property | Value
    BORDER - Width | 0.25pt
    BORDER - Style | Solid
    BORDER - Color | Gainsboro
    TEXT - Text Align | Left
    TEXT - Vertical Align | Middle
  4. Similarly, customize the text boxes in the Details row of the table.

Preview and Save Report

  1. Click Preview Preview Button to view the final output of your report.
  2. Exit the preview mode by clicking Back on the left side of the designer.
  3. Click Save to open the Save dialog box. Enter the report name and click Save Report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Expressions

Expressions
Report Authors > WebDesigner > Expressions

Glossary Item Box

An expression can be used to set the value of a control in the report or to define a condition to set specific styles. You can set expressions through the Expression Editor dialog while setting values in the properties window.

The editor allows you to choose from a number of fields available to the report as well as to a particular property. You can access the Expression Editor by selecting nearly any property of a control and choosing f Expression from the drop-down list. All expressions are enclosed within curly braces '{}'. Even the expression for a field value for a TextBox is set as follows: {LastName}.

While building an expression, you can directly add the entire expression or part of it in the Expression pane of the Expression Editor. Then use the Insert or Append buttons to create a complete expression.

Expression Editor Dialog

Concatenating Fields and Strings

You can concatenate fields with strings and with other fields. For e.g., use the following expression to get a result like "Customer Name: Bossert, Lewis":
Customer Name: {LastName} , {FirstName}

Conditional Formatting

You can use expressions in properties like Color, Font, Border, etc. on specific field values based on a condition, to highlight a part of data. The formula for conditional formatting is:
{IIF(<Condition>, <TruePart>, <FalsePart>)}

For e.g., if you enter the following expression in the Font > FontWeight property of a text box that displays names of people, you get the name "Denise" in bold.
{IIF(FirstName = "Denise", "Bold", "Normal")}

Similarly, if you enter the following expression in the Background >Color property of a text box in a table, then you get alternating 'Transparent' and 'LightGray' colored text boxes in the rows of the table.

{IIF(RowNumber(Nothing) mod 2, "Transparent", "LightGray")}

Functions

You can use a number of aggregate and other functions in your expressions. ActiveReports includes a range of functions, including running value, population standard variance, standard deviation, count, minimum and maximum. For e.g., use the following expression to get a count of employees.

{Count(EmployeeID, Nothing)}

Summary and Total Value Calculations

You can set the following calculations for Summary and Total Value Calculations.

Calculation Option | Result
Default | current value
% Grand Total | current value ÷ grand total of the tablix
% Row Group Total | current value ÷ current row group grand total
% Parent Row Group Total | current value ÷ parent row group subtotal in the current column group For subtotals, subtotal ÷ grand total of the current column group
% Column Group Total | current value ÷ current column group grand total
% Parent Column Group Total | current value ÷ parent column group subtotal in the current row group For subtotals, subtotal ÷ grand total of the current row group

Multiple TextBoxes Operations

It is now possible to set the common expression for multiple TextBoxes (including TextBoxes in Table and Tablix) for all the properties.

To set the common expression for multiple TextBoxes (having the same or different data fields), first select the TextBoxes. In the Properties Window, select the property for which you want to set the expression, and then select Expression to open the Expression Editor. Under the Values, expand the Common Values node, select Current Textbox Value, enter a valid expression with the ($$$) variable, and click Save.

Let us see how this works by looking at two samples, applied to the 'Page/Invoice.rdlx' report. This report is available in the 'resources' folder of WebDesigner_MVC_Core sample.

Example 1: Add the Sum expression to multiple data fields in a Table data region.

Steps:

  1. From the WebDesigner_MVCcore sample, open the 'Page/Invoice.rdlx' report.
  2. Select the {Quantity} and {UnitPrice} fields in the Details row of the Table data region.
  3. Go to Common > Value property and enter the following expression in the Expression Editor:
    $$COPYCODE$$
    {Sum($$$)}
  4. Save the expression and close the Expression Editor.
  5. Check that the 'Value' expression is updated for each of the selected fields to the following values:
    • {Sum(Quantity)}

    • {Sum(UnitPrice)}

($$$) variable with Sum expession

Example 2: Add a background color to multiple data fields in a Table data region.

Steps:

  1. From the WebDesigner_MVCcore sample, open 'Page/Invoice.rdlx' report.
  2. Select the {UnitPrice} and {UnitPrice - UnitPrice * Discount} fields in the Details row of the Table data region.
  3. Go to Background > Color property and enter the following expression in the Expression Editor:
    $$COPYCODE$$
    {iif($$$ > 14, "Green")}
  4. Save the expression and close the Expression Editor.
  5. Check that the 'Background Color' expression is updated for both selected fields to the following values:
    • {iif(UnitPrice > 14, "Green")}

    • {iif(UnitPrice - UnitPrice * Discount > 14, "Green")}

This expression evaluates the background color to Green color if the selected values are greater than '14'.

Using ($$$) variable for the background color

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Custom Parameters View

Custom Parameters View
Report Authors > WebDesigner > Custom Parameters View

Glossary Item Box

The Parameters View/Panel can be designed in Report Designer using the exclusive set of controls to create and define parameters and prompts quickly. The controls include input controls like text editor, number editor, heading, and plain text; range editors like date range and date-time range; and list and dropdown editors.

On previewing the report, the customized parameters view/panel is shown in the Parameter Panel of the viewer on preview.

Design a Parameters View

Design a Parameter Panel

The reference to AcmeStore.rdlx will be taken.

  1. Go to the Parameters tab at the top.
  2. Create the custom parameters view for the report by clicking the Generate View button in the toolbar or clicking the Generate button in the center of the designer
    If the report already has pre-defined report parameters, a default parameters layout is generated in the design area from these parameters. You can then build the parameters view from the default view or simply create a fresh parameter view using the controls available in the parameters designer.
  3. Drag-drop the controls from the toolbox that will be used for inputting parameters.
  4. Set the properties of each of the control such as Binding, Type, depending on the function each of the control.
  5. Add buttons to preview the report based on selected parameters, reset the parameter selection to default, and clear the selection.

Preview the Report with Custom Parameters View

Preview a Custom Parameter Panel

The controls provide an intuitive user experience with customization possibilities. Following is the list of controls available for designing a parameters view.

  • Text Editor: For single-line parameter of the String type.
  • Number Editor: For parameters of integer or float type. Set the control's type as Up-down Editor for increasing or decreasing at specified steps, or as Slider to be able to slide the value of the parameter.
  • Number Range Editor: For a parameter range of integer or float type. You need to specify the range in From and To fields in Binding.
  • Boolean Editor: For parameters with the Boolean value. The Boolean editor can be a Toggle, Checkbox, or a Radio button. As you change the type of the Boolean editor, the options accordingly can be filled in.
  • DateTime Editor: For parameters with date and date-time values.
  • Date Range Editor: For parameters with a date field. Specify the start date and end date in the From and To fields in Binding.
    You can also add custom ranges manually using the Ranges property (Add > Edit) or select ranges from the pre-defined options in a dropdown menu (Current, Last, Next, ToDate, and LastToDate) for intervals (specified via the Unit property: Year, Quarter, Month, Week, etc.) Using the View Mode property, you can set the calendar's initial view to Default, Days, Months, or Years.
  • DateTime Range Editor: For parameters with a range of dates with an explicit starting and ending time.
    You can also add custom ranges manually using the Ranges property (Add > Edit) or select ranges from the pre-defined options in a dropdown menu (Current, Last, Next, ToDate, and LastToDate) for intervals (specified via the Unit property: Year, Quarter, Month, Week, etc.)
  • Multivalue Editor: For multi-value parameters whose values are required to be entered manually. It appears with a list of multiple values in the drop-down with the search box.
  • Dropdown Editor: A list of fields in the parameter appears in the drop-down with a search box. Single or multiple values can be selected depending on whether the Multi Value property is enabled or not.
  • List Editor: Fields bound to parameter appears as a list, with checkboxes to select the field.
  • Tree View: For hierarchical parameter. Select the Tree View type as List or Dropdown.
  • Heading: For static text, e.g., entering a heading with a choice of colors for error or warning.
  • Plain Text: For static text, eg., entering single or multiline text.
  • Button: To perform actions on the preview screen, select Preview to preview report based on the selected parameters, Reset to reset the parameter selection to default, and Clear to clear the selection, on preview window.

Use Free Form/Stack switch to see how parameters will look in the preview window.

When the 'Free Form' layout type is on, the view matches the current parameter panel on the viewer's sidebar. The order of parameters can be changed by dragging the controls. You can also change the location and size of the controls.

When the 'Stack' layout is on, the view arranges the controls vertically. The order of parameters can be changed by dragging the controls. Also, you can select the 'Highlight Required' option to highlight any errors while designing the parameter panel.

For information on the WebDesigner API and its integration into applications, see WebDesigner Application.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Types

Report Types
Report Authors > Report Types

Glossary Item Box

As Report Authors, you can design a report using a number of pre-defined templates, where each report type has its advantages and purpose.

When choosing what report type best meets your needs, you should pay attention to the key benefit of each report type.

RDLX

A multi-section continuous page layout that combines multiple continuous page layouts together.

RDLX Dashboard

A multi-section pageless layout for creating dashboard-like reports.

Page

A fixed page layout that builds pixel-perfect reports.

Section

A banded layout that consists bands for special layouts in reports.

The guidelines for choosing a report type for DevOps and Developers are elaborated here.

The topics in this section provide you with more details on each report type.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


RDLX Report

RDLX Report
See Also
Report Authors > Report Types > RDLX Report

Glossary Item Box

Multi-Section RDL Report

The RDLX report (.rdlx), provides you the ability to define multiple layouts in a report for the flexible presentation of your report data. In this report, you can place data regions that require different viewing layouts, on separate sections, and set margins, page size, and page orientation for pages in each section to accommodate the data regions.

An RDLX report has the following additional features.

Key Features

Manage Report Sections

You can add new sections from the New tab that appears below the design area. You can also add new sections by right-clicking the ReportSection tab and selecting the Insert option from the context menu. To duplicate the report section, select the Duplicate option from the context menu. You can drag the section tabs to reorder report sections.

You can also change the report section's name using the Name property. Just right-click on the section's name (for example, ReportSection2) to quickly add a Page Header or Page Footer to the section or Delete the section. A report section can have its own page header or footer.

Inserting a new section

The report sections can be added to the viewer's Document Map for ease of navigation through the report. To do so, simply set the report section’s Label property. For more information, see the Document Map topic.

To control the visibility of the initial state of the section, use the Hidden property from the Properties panel and enter a Boolean value or an expression that evaluates to a Boolean value. See the topic to Hide or Show Sections in RDLX and RDLX Dashboard Reports.

Also see Quick Start topic that adds two report sections to create the report.

Set Layout of each Section

The layout of pages in each report section can be independently controlled using the following properties:

  • Margins - Left, Right, Top, Bottom
  • PageSize
  • PaperOrientation - Landscape, Portrait

Merge Reports

You can combine multiple report types (.rdlx) into a single report using ReportCombiner.Mode property in code.

While SubReports mode combines multiple reports as subreports, the ReportSections mode converts the reports being combined to a report with multiple report sections, that is, the output is an RDLX report. See Merge Multiple Reports for more information.

Create Report Parts for use in WebDesigner

The report lets you create report parts and the collection of these, called the report library, can be reused in WebDesigner. Use the Report menu > Report Parts option in the toolbar or from the Properties panel > ReportParts collection.

Report Parts Menu

See creating Report Parts for more information.

See Also

Quick Start
Demo: Multi-Section Layout

Developers
Merge Multiple Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


RDLX Dashboard Report

RDLX Dashboard Report
See Also
Report Authors > Report Types > RDLX Dashboard Report

Glossary Item Box

RDL Dashboard Report Preview

The RDLX Dashboard (.rdlx) report is the latest addition to the varied reports that you can design in ActiveReports. The RDLX Dashboard reports are best viewed in the JS Viewer.

Key Features

Manage Sections

RDLX Dashboard Reports can be multi-page like RDLX Report. With multiple pages or sections, you can make the dashboard report more informative with details spread across the pages. These pages of the report can be navigated using the tabs.

You can add new sections to the report from the New tab that appears below the design area. You can also add new sections by right-clicking the Section tab and selecting the Insert option from the context menu. To duplicate the report section, select the Duplicate option from the context menu. You can also delete the section by selecting the Delete option.

Add and duplicate sections

You can use a slider that allows to scroll the tabs horizontally. This slider appears if a report has many sections, which tabs do not fit into the page.

The report sections can be added to the viewer's Document Map for ease of navigation through the report. To do so, simply set the report section’s Label property. For more information, see the Document Map topic.

To control the visibility of the initial state of the section, use the Hidden property from the Properties panel and enter a Boolean value or an expression that evaluates to a Boolean value. See Hide or Show Sections in RDLX and RDLX Dashboard Reports for more information.

Scrollable Container Component

The Container control in the RDLX Dashboard Report is scrollable. You can manage the scroll behavior by using the Overflow property. See Container Control in RDLX Dashboard Report for more information.

Actionable Items Provide Extensive Interactivity

The Action property in report controls and data regions makes the dashboards highly interactive and helps slice and dice the report metrics. You can click on an action and see the action. The action works across dashboard pages too.

If in addition, there is action(s) set on control(s) inside a Table cell, List, or BandedList, that action will be given priority over the action set on the Table's row, List data region, and BandedList's band.

Note: Since RDLX Dashboard reports have a page-less view, the page-related properties or expressions such as Page Totals, Page Numbers, and Page Breaks, are not supported.

Preview Limitations for Standalone and Visual Studio Integrated Designers

It is suggested to use JSViewer or WebDesigner preview for viewing RDLX Dashboard reports due to the following limitations at the moment:

  • It is not possible to switch between report sections (sections are rendered as separate pages).
  • Scrollable regions are not supported at preview.

See Also

Create RDLX Dashboard Report
Demo: Sales Dashboard

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Page Report

Page Report
Report Authors > Report Types > Page Report

Glossary Item Box

Page Report Design View

In a Page report (.rdlx) layout, you can create very specific styles of reports that are very difficult, if not impossible, in other .NET reporting tools. You design this type of report on a page where none of the report controls can grow or shrink at run time, making it ideal for duplicating legacy paper forms. This report type is great for billing statements, mail merge, catalogs, forms, and other reports with layout constrictions.

Page report controls do not change in size based on the data, but you can use an Overflow Place Holder to handle any extra data.

With Page reports, there is no need to use code or add measurements to make sure that everything fits. Unlike the RDLX report, the controls remain fixed at run time, so you can drop a table on the report, set a property to size it exactly how you want it, and have something very close to a WYSIWYG report at design time.

Key Features

Grouping

You can set page level grouping to render one row of data on each page. This is ideal for something like a tax form that you want to print for every client or every employee, or an invoice that you want to print for every customer.

OverflowPlaceholder

If there is data that does not fit within the space allocated for the data region at design time, you can assign it to flow into an OverflowPlaceholder control. This can go on the same page in a different area, for example, in the form of columns, or it can go on a separate page.

Themes

You can add multiple themes to a report. In this case, the report renders a combination of multiple outputs for each theme. For example, if a report has two themes, then the report output includes a combination of the first and the second themes, applied to each report page. You can control the combination rules of the report output in the CollateBy property.

Fixed Page Dialog

Fixed Page Dialog

In a Page Report, you can set the basic properties for your page from the FixedPage dialog. You can access the FixedPage dialog by doing one of the following:

  • Right-click the gray area outside the design surface and from the context menu that appears, select Fixed Layout Settings.
  • Click the gray area outside the design surface to select the Report and in the commands section at the bottom of the Properties Panel, click the Fixed Layout Settings command.
  • Click the design surface to select the Page and in the Commands section at the bottom of the Properties Panel, click the Property dialog command.
  • In the Report Explorer, select the Report node or the page node and in the commands section at the bottom of the Properties Panel, click the Fixed Layout Settings or Property dialog command respectively.
General
Grouping
Sorting
Filters
Data Output

The General page of the FixedPage dialog allows you to control the following properties:

  • Name: Enter a name for the Page Report. This name is used to call the page in code so it should be unique within the report.
  • Dataset name: Select a dataset to associate with the Page Report. The dropdown list is automatically populated with all the datasets in the report's dataset collection.

The Grouping page is useful when you want to show data grouped on a field or an expression on report's pages. See Group Data for more information.

The Grouping page contains following tabs which provide access to various grouping properties:

General

  • Name: Enter a name for the Fixed Layout group that is unique within the report. This property cannot be set until after a Group on expression is supplied. A name is created automatically if you do not enter one.
  • Group On: Enter an expression to use for grouping the data.
  • Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Filters

The Filters tab allows you to add and control the Filter collection for the Fixed Layout Group. Use the + button to add a filter and the X button to delete a filter. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the group.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.
  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

Data Output

The Data Output tab allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for this group.
  • Collection: Enter a name to be used in the XML output for the collection of all instances of this group.
  • Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

Has own page numbering: Check this box to enable section page numbering like Page N of M (Section). See Add Page Numbering for further information on setting page numbering in Page Report.

The Sorting page of the FixedPage dialog allows you to enter sort expressions for sorting data alphabetically or numerically.

Expression: Enter an expression by which to sort the data.

Direction: Select whether you want to sort the data in an Ascending or Descending order.

The Filters page of the FixedPage dialog allows you to control the Filter collection for the Fixed Layout. Use the + button to add filters and X buttons to delete them. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the Fixed Layout.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

The Data Output page of the FixedPage dialog allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for the Page Report.
  • Output: Choose Auto, Yes, or No to decide whether to include the Page Report in the XML output. Choosing Auto exports the contents of the fixed layout.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Section Report

Section Report
Report Authors > Report Types > Section Report

Glossary Item Box

Section Report Design View

In a Section report (.rpx) layout, you design reports in banded sections. A PageHeader, Detail and PageFooter section appear by default, and you can remove any but the detail section. Right-click the report and select Insert to add other section pairs like ReportHeader and ReportFooter, or GroupHeader and GroupFooter.

You can hide any section that you do not want shown by setting the Visible property of the section to False.

Code-based Section Report

When you add an ActiveReports 19 Section Report (code-based) to your Visual Studio project, report layouts are saved as C# or Visual Basic files within the project in which they are created. These files are compiled into the application when you build it.

Note: In Visual Studio 2022, only .NET Framework 4.7.2 and 4.8 are supported for code-based section reports.

This type of report is the most flexible in terms of what a .NET developer can achieve using code. It has an extensive API and is event-based, which allows you to control all aspects of the report and how it is generated. If you like, you can even build a report completely in code.

Xml-based Section Report

When you add an ActiveReports 19 Section Report (xml-based) report to your Visual Studio project, the layout is saved as a standalone Report XML (RPX) file. Since these files are not compiled into your application, they are a good option for solutions in which you need to update or add reports frequently.

The RPX format cannot contain Visual Basic.NET or C# code. Instead, you can add VB.NET or C# script in the Script view of the report.

Note: You can combine multiple Section reports by combining the RDF document. For details, see Work with RDF Document.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Controls

Report Controls
Report Authors > Report Controls

Glossary Item Box

ActiveReports provides an extensive collection of report controls (and data regions) that you can use when creating your reports. Just drag these report controls from the toolbox and drop them onto the design area to begin as the first step in designing the reports. The reports controls may be unbound like Label, Line, Shape, and Container that do not need data source to show data, or bound like Table, Tablix, Chart, etc. that need data source to show data.

  • Report Controls in Page/RDLX Report
  • Report Controls in Section Report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Controls in Page/RDLX Report

Report Controls in Page/RDLX Report
Report Authors > Report Controls > Report Controls in Page/RDLX Report

Glossary Item Box

The Page or RDLX report (including RDLX Dashboard reports) toolbox group offers a number of report controls and data regions that you can use when creating a report. You can drag these from the toolbox and drop them onto your reports. These tools are different than those in the Section Report Toolbox.

Report Control/Data Region | Page Report | RDLX Report, RDLX Dashboard Report
BandedList | ✓ | ✓
Barcode | ✓ | ✓
Bullet | ✓ | ✓
Chart | ✓ | ✓
CheckBox | ✓ | ✓
Container | ✓ | ✓
FormattedText | ✓ | ✓
Image | ✓ | ✓
InputField | ✓ | ✓
Line | ✓ | ✓
List | ✓ | ✓
Map | ✓1 | ✓1
OverflowPlaceHolder | ✓ | ✗
Shape | ✓ | ✓
Sparkline | ✓ | ✓
Subreport | ✓ | ✓
Table | ✓ | ✓
TableofContents | ✓ | ✓
Tablix | ✓ | ✓
TextBox | ✓ | ✓

1 In Page/RDLX reports in WebDesigner, Map control is not fully supported at design time. However, it is correctly displayed at preview.

Banded List

The BandedList is a data region with freeform bands in which you can place report controls. With a detail band that repeats data for every row in the dataset, this data region resembles the Section report design surface.

Barcode

The BarCode report control renders scannable barcodes in any of 39 popular symbologies. You can bind it to data, control the bar width, rotation, quiet zones, caption locations etc.

Bullet

The Bullet report control is an easy-to-read linear gauge that is a good alternative to using a dashboard for data visualization. You can bind it to data and set best, worst, and satisfactory values as well as labels and ranges.

Chart

The new Chart is a graphic data region similar to Classic Chart, which is based on representing the data using encodings. It is the default chart available in the designer.

Classic Chart (hidden by default)

Classic charts are legacy RDLX-like charts. The Classic Chart is a graphic data region which allows you to display data in a variety of chart styles with 3D effects and colors, and provides many options for customization. To enable the Classic charts, see Configure ActiveReports using Config File.

Note: A classic chart is hidden by default and not supported in the WebDesigner.

CheckBox

The CheckBox report control can display Boolean data, or you can set its Checked property. You can also enter static text to display.

Container

The Container report control is a graphical element that is used as a container for other items. The Container report control has no data associated with it.

ContentPlaceHolder (RDLX Master Report)

The ControlPlaceHolder control is used to show the edit area when a Master report is available.

Formatted Text

The FormattedText report control displays data, and allows you to format selected areas of text within the control in different ways. This report control accepts XHTML input, and allows you to set up mail merge.

Image

The Image report control allows you to specify any image file to display from an external source, a database or an embedded image.

InputField

The InputField report control provides support for editable fields in an exported PDF report.

Line

The Line report control, a graphical element that has no data associated with it, visually marks boundaries or highlights specific areas of a report. You can use lines of various weight, color, and style to highlight regions of your reports and to add style and polish.

List

The List is a freeform data region in which you can place other report controls. It repeats any report control it contains for every record in the dataset.

Map

The Map data region shows your business data against a geographical background. You can select different types of map, depending on the type of information you want to communicate in your report.

Matrix (hidden by default)

The Matrix is an old-style tabular control, which has been replaced with a more powerful Tablix data region.

Note: The Matrix control is hidden by default and not supported in the WebDesigner.

Overflow Place Holder

The Overflow Placeholder report control is only available with page reports. It is a simple rectangle that you link to a List, BandedList, Tablix, or Table data region to display data that extends beyond one page.

Shape

The Shape report control, a graphical element that has no data associated with it, allows you to mark visual boundaries or highlight specific areas of a report with rectangles, rounded rectangles, or elliptical shapes. Unlike the Container report control, it cannot contain other controls.

Sparkline

The Sparkline report control displays a data trend over time in a graph small enough to be used inline, with a height similar to the surrounding text. You can select from line, area, stacked bar, column, and whisker sparkline types.

Subreport

The Subreport control displays data from a separate report that you specify. You can pass a parameter to the subreport from the main report to filter data displayed in a subreport.

Table

The Table is a data region that shows data in rows. By default, it has three columns and three rows. Once set at design time, the columns are static, while the rows repeat for each row of data. The default rows are the header, detail, and footer.

TableOfContents

The TableOfContents (ToC) report control is used to display the document map, an organized hierarchy of the report bookmarks and labels along with their page numbers, in the body of a report. The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports.

Tablix

Tablix data region displays data in cells that are arranged in rows and columns. Tablix is mainly a combination of two data regions- table and a matrix.

TextBox

The TextBox displays data, and is the default data region that appears in each cell of a Table or Tablix data region. It is also the data region that is created automatically when you drag a field from the Data Explorer onto your report. You can use expressions to modify the data that appears in a TextBox.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


BandedList

BandedList
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > BandedList

Glossary Item Box

You can use the BandedList data region in your Page and RDLX reports to visualize bound data as free-form bands where data may be grouped by data field or an aggregate function like summary and total value.

The BandedList data region is a collection of bands. By default, it is composed of three bands: a header, a footer and a details band. The BandedList may also have group header and group footer bands, which are created when you add a data group to a banded list. Report controls in these bands repeat once for each group in a banded list.

Structure

Header Band

The Header band appears at the beginning of a banded list. Also, if its RepeatOnNewPage property is on, it prints on every page taken by the banded list content. You could use the header band to display the title or the logo on top of the report.

Group Header Band

The Group Header band appears at the beginning of a group when a group is added in the Details band. Also, if its RepeatOnNewPage property is on, it prints on every page taken by the banded list content. You could use the group header band to display the group's field value or summary value.

Details Band

The Details band repeats for each bound data set record that passed through the data set filters and data region filters. For example, the details band may display the name, title, email, phone and photo of each employee.

If a banded list has groups, then the details bands appear between the header and footer of the enclosing group instance.

Group Footer Band

The Group Footer band appears at the end of a group when a group is added in the Details band. Also, if its RepeatOnNewPage property is on, it prints on every page taken by the banded list content. You could use the group footer band to display summary values.

Footer Band

The Footer band appears at the end of a banded list. Also, if its RepeatOnNewPage property is on, it prints on every page taken by the banded list content. You could use the footer band to display grand totals.

Important Properties

Band Properties

Clicking inside each band reveals its properties in the Properties panel.

Property | Description
BreakLocation (Details only) | Indicates where the report is broken on a new page of the band. Select from None, Start, End, StartAndEnd, and Between.
CanGrow | Change to True to allow the data region to grow vertically to accommodate data.
CanShrink | Change to True to allow the data region to shrink if there is not enough data to fill it.
KeepTogether | Change to True to have ActiveReports attempt to keep all of the data in the band together on one page.
RepeatOnNewPage | With header and footer bands, repeats the band on every page when the related details span multiple pages.
PageBreakAtStart (all bands except Details) | Indicates whether the report breaks to a new page at the start of the band.
PageBreakAtEnd (all bands except Details) | Indicates whether the header or footer bands are displayed on each page that includes the banded list.

BandedList Properties

Clicking the four-way arrow selects the entire data region and reveals its properties.

Property | Description
DataSetName | Select the dataset to use in the data region.
DataSetParameters | Specify the parameters for the data set.
KeepTogether (RDLX) | Change to True to have ActiveReports attempt to keep all of the data in the data region together on one page.
NewSection | Change to True to render the data region in a new section.
OverflowName (Page) | Select the name of the OverflowPlaceHolder control in which to render data that exceeds the allowed space for the data region on the first page of the report.

Banded List Dialog Properties

You can set the BandedList properties in the Banded List dialog. To open it, with the BandedList selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Navigation
Groups
Filters
Data Output

Name: Enter a name for the banded list that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the banded list. The combo box is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this banded list is in its own section with regards to pagination.

Consume all white space during report rendering (RDLX): Select to have all white space consumed at report rendering.

Page Breaks (RDLX): Select any of the following options to apply to each instance of the banded list.

  • Insert a page break before this banded list
  • Insert a page break after this banded list
  • Fit banded list on a single page if possible

NewPage (RDLX): Indicates on which page the content to start after the page break.

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

Header and Footer: Select any of the following options.

  • Repeat header band on each page
  • Repeat footer band on each page
  • Prevent orphaned header on the page
  • Prevent orphaned footer on next page
  • Print footer at the bottom of the page

By default, the banded list is visible when the report runs, but you can hide it when certain conditions are met, or toggle its visibility with another report control. The same applies to banded list groups.

Initial visibility

  • Visible: The banded list is visible when the report runs.
  • Hidden: The banded list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the BandedList is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the BandedList. The user can click the toggle item to show or hide this BandedList.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this BandedList. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Click the plus sign button to add a new group to the banded list, and delete them using the X button. Once you add one or more groups, you can reorder them using the arrow buttons, and set up information for each group on the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Caution: You cannot sort the detail data in a BandedList, so any sorting of this type must be done at the query level.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending.

Visibility

By default, the group is visible when the report runs, but you can hide a group when certain conditions are met, or toggle its visibility with another report item.

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Data Output

Element Name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

BreakLocation: Select from these options to decide where to insert a page break in relation to the group.

  • None: Inserts no page break.
  • Start: Inserts a page break before the group.
  • End: Inserts a page break after the group.
  • StartAndEnd: Inserts a page break before and after the group.
  • Between: Inserts a page break between groups (at the end of a current group and the beginning of a next group).

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Keep together on one page if possible: Indicates that the group is kept together on one page if possible.

Prevent orphaned header: Indicates whether the orphaned header is displayed for the group.

Prevent orphaned footer: Indicates whether the orphaned footer is displayed for the group

Print footer at the bottom of the page: Indicates whether to print the group footer at the bottom of the page.

NewPage: Indicates on which page the content to start after the page break.

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

The Data Output page of the Banded List dialog allows you to control the following properties when you export to XML.

  • Element Name: Enter a name to be used in the XML output for this BandedList.
  • Output: Choose Auto, Yes, No, or Contents only to decide whether to include this BandedList in the XML output. Choosing Auto exports the contents of the BandedList.

BandedList Features

Adding Data Group

You can group data in the Details band by one or multiple criteria, for example, group sales data in the sales list by region, district and year.

  1. In the Designer, select a banded list control and right-click it.
  2. In the context menu that appears, select Insert Group.
  3. In the Banded List - Groups dialog that opens, enter a grouping expression for each group in the Group on property. You can also nest groups, plus, in RDLX reports, you can nest other data regions in any header or footer band.
  4. Click the plus sign button to add a new group to the BandedList, and delete them using the X button. Once you add one or more groups, you can reorder them using the arrow buttons, and set up information for each group on the tabs

    BandedList Groups dialog

In the example of the report with the banded list data region, you can see three (3) data groups - data group #1 (=[RegionID]), data group #2 (=[DistrictID]), and data group #3 (=[SaleYear]).

Data grouping in BandedList

Adding Aggregates

You can use aggregate functions to group data in the BandedList header, footer and group header/footer bands. See Common Functions for the complete list of aggregate functions you can use.

  1. Select the banded list and click the Property dialog link at the bottom of the Properties panel.
  2. In the Banded List dialog that appears, go to the Groups tab.
  3. In the Expession field under Group on, select <Expression...> to open the Expression Editor.
  4. In the Expression Editor, select an aggregate function in the list of fields under Common Functions and click OK.
  5. In the Banded List dialog, click OK.

For example, the Sum aggregate function calculates the sum of the values returned by the expression: =Sum(Fields!TotalSales.Value). If you use this aggregate in the group header of the banded list, it will display the total sales value for a data group - in the example below, this is the district sales total value. The same aggregate function, =Sum(Fields!TotalSales.Value), placed to the group footer of the banded list, displays the sum of the values for the District data group.

Sum aggregate in the BandedList data group

See Also

BandedList Data Region for Free-form Bands
Demo: Banded List - Game Catalog

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Barcode

Barcode
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Barcode

Glossary Item Box

The Barcode report control displays data in a machine-readable format to enable accurate scanning of sensitive information quickly and efficiently. This saves you the time and expense of finding and integrating a separate component.

Structure

Quiet zone is the left and right ends of the barcode. Both of the ends must be at least 10 times as wide as the minimum element width for proper scanning of the barcode data.

Start character indicates the start of the barcode data.

Stop character indicates the end of the barcode data.

Check digit is a numeric value used to check for read errors. It is located right after the barcode data.

Bar height is recommended to be greater than 15% of the barcode length. If the bar height is not high enough, it may lead to unstable readings of the barcode by the laser.

Note: If you create reports programmatically, the Page report/RDLX report barcode is treated as a CustomReportItem.

Barcode Types

ActiveReports supports all of the most popular symbologies.

Symbology Name | Example | Description
Ansi39 | Ansi39 barcode | ANSI 3 of 9 (Code 39) uses uses upper case alphabets (A to Z), numerals (0 to 9), - , * $ / + %. This is the default barcode style.
Ansi39x | Ansi39x barcode | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Aztec | Aztec barcode | Aztec is a two-dimensional barcode symbology that supports all the ASCII characters from 0 to 255.
BC412 | BC412 barcode | Data BC412 uses 35 characters, numerals (0 to 9), and upper case alphabets (A to Z). It is designed for semiconductor wafer identification.
Codabar | Codabar barcode | Data that can be encoded are numerals (0 to 9) and symbols ("-", "$", ":", "/", "+" and ";"). For the Start Character and the Stop Character, A, B, C or D can be selected.
Code_11 | Encodes the numerals (0 to 9), the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numerals (0 to 9), punctuation, and upper case alphabets (A to Z).
Code_128_B | Code 128 B uses punctuation, numerals (0 to 9), upper case, and lower case alphabets.
Code_128_C | Code 128 C uses only numerals (0 to 9).
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numerals (0 to 9).
Code_93 | Code 93 uses upper case alphabets (A to Z), % $ * / , + -, and numerals (0 to 9).
Code25intlv | Code25intlv barcode | Interleaved 2 of 5 uses only numerals (0 to 9).
Code39 | Code39 barcode | Code 39 uses numerals (0 to 9), % * $ /. , - +, and upper case alphabets (A to Z).
Code39x | Code39x barcode | Extended Code 39 uses the complete ASCII character set.
Code49 | Code49 barcode | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Code93x barcode | Extended Code 93 uses the complete ASCII character set.
DataMatrix | DataMatrix barcode | Data Matrix is a high-density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numerals (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSum property is set to True.
EAN_8 | EAN-8 uses only numerals (7 numbers and a check digit).
EAN128FNC1* | EAN128FNC1 barcode | EAN-128FNC1 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry.
GS1QRCode GS1QRCode barcode

GS1QRCode is a subset of the QR Code. The GS1 QR Code is a 2D symbol that denotes the Extended Packaging URL for a trade item. It is processed to obtain one URL address associated with the trade item identified by the Global Trade Item Number (GTIN). GS1 QR Code requires the mandatory association of the GTIN and Extended Packaging URL.

GS1 QR Code allows encoding GS1 System Application Identifiers (AI) into QR Code 2D barcodes.

Limitation: Kanji, CN, JP and Korean characters.
HIBCCode128 | HIBCCode128 barcode | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as a delimiter. It is used in the health care products industry for identification purposes.
HIBCCode39 | HIBCCode39 barcode | HIBCCode39 barcode uses the Code39 symbology, with the Code39OptionalCheckDigit property set to True. It encodes Primary Data and Secondary Data using slash (/) as a delimiter. It is used in the health care products industry for identification purposes.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numerals with a check digit.
IntelligentMail | IntelligentMail barcode | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage barcode | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | ISBN barcode | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | ISMN barcode | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | ISSN barcode | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | ITF14 barcode | Interleaved Two of Five code is used to mark cartons that contain goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | JapanesePostal barcode | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MaxiCode MaxiCode barcode

MaxiCode is a special polar barcode that uses 256 characters. It is used to encode a specific amount of data.
MicroPDF417 MicroPDF417 barcode

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert an FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
MicroQRCode MicroQRCode barcode

MicroQRCode is a two-dimensional (2D) barcode that is designed for applications that use a small amount of data. It can handle numeric and alphanumeric data as well as Japanese kanji and kana characters. This symbology can encode up to 35 numeric characters.
MSI | MSI barcode | MSI Code uses only numerals (0 to 9).
Pdf417 | Pdf417 barcode | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. This symbology can encode up to 35 alphanumeric characters or 2,710 numeric characters.
Pharmacode | Pharmacode barcode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey barcode | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet barcode | PostNet uses only numerals (0 to 9) with a check digit.
PZN | PZN barcode | Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode barcode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric, and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | RM4SCC barcode | Royal Mail (RM4SCC) uses only letters and numerals (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14
(GS1 DataBar) 		RSS14 (GS1 DataBar) RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning. The RSS family of barcodes is also known as GS1 DataBar.
RSS14Stacked
(GS1 DataBar Stacked) 		RSS14Stacked (GS1 DataBar Stacked) RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14StackedOmnidirectional
(GS1 DataBar Stacked Omnidirectional) 		RSS14StackedOmnidirectional barcode RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated
(GS1 DataBar Truncated) 		RSS14Truncated barcode RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded
(GS1 DataBar Expanded) 		RSSExpanded (GS1 DataBar Expanded) barcode

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates. RSSExpanded allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSExpandedStacked
(GS1 DataBar Expanded Stacked) 		RSSExpandedStacked (GS1 DataBar Expanded Stacked)

RssExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width. RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert an FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSLimited
(GS1 DataBar Limited) 		RSSLimited (GS1 DataBar Limited) RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen barcode | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCCEAN128 barcode | UCCEAN-128 complies to GS1-128 standards. GS1-128 uses a series of Application Identifiers to encode data. This barcode uses the complete ASCII character set. It also uses the FNC1 character as the first character position. Using AI's, it encodes best before dates, batch numbers, weights, and more such attributes. It is also used in HIBC applications.
UPC_A | UPC-A uses only numerals (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numerals. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numerals. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.

Note that the following barcodes support FNC1 characters:

  • Aztec
  • UCCEAN128
  • MicroPDF417
  • RSSExpanded
  • RSSExpandedStacked

*The barcode EAN128FNC1 is now obsolete; you should use UCCEAN128 instead. The UCCEAN128 provides similar functionality with better performance and some default properties. You should choose EAN128FNC1 only if you do not need the default properties.

Important Properties

Clicking the barcode control reveals its properties in the Properties panel.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
BarHeight | Set the height, in inches, of the barcode's bars. If the bar height exceeds the height of the control, this property is ignored.
CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read. This property is only available with certain styles of barcode and is ignored with other styles.
CaptionLocation | The vertical alignment of the caption in the control. Select from None, Above, or Below. See Alignment for horizontal alignment. None is selected by default, and no caption is displayed.
Font | Set the font for the caption. Only takes effect if you set the CaptionPosition property to a value other than None.
NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in pixels (for example, 10 pixels).
NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Quiet Zone | Sets an area of blank space on each side of a barcode that tells the scanner where the symbology starts and stops. You can set separate values for the Left, Right, Top, and Bottom.
Rotation | Sets the amount of rotation to use for the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.
SupplementOptions | Sets the 2/5-digit add-ons for EAN/UPC symbologies. You can specify Text, DataField, BarHeight, CaptionPosition, and Spacing for the supplement.
BackgroundColor | Select a background fill color for the barcode.
CheckSum | Some barcode styles require a checksum and some have an optional checksum. CheckSumEnabled has no effect if the style already requires a check digit or if the style does not offer a checksum option.
Color | Select a color for the barcode and caption.
Symbology | Sets the symbology used to render the barcode. See the table below for details about each symbology.

Barcode Specific Properties

Aztec Options

Aztec options are available for the Aztec barcode style.

Error Correction: Indicates whether to allow code recovery if the barcode image is partly damaged, the value is ranging from 10% to 90%.

Layers: Indicates the number of the barcode layers.

Encoding: Select the barcode encoding from the drop-down list.

Code49 Options

Code49 options are available for the Code49 barcode style.

Use Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False (default). If Grouping is set to True, any value not expressed by a single barcode is expressed by splitting it into several barcodes.

GroupNumber: Enter a number between 0 (default) and 8 for the barcode grouping. When the Group property is set to 2, the grouped barcode's second symbol is created. When invalid group numbers are set, the BarCodeDataException is thrown.

DataMatrix Options

DataMatrix options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT, or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

Encoding: Select the barcode encoding from the drop-down list.

EAN128FNC1 Options

EAN128FNC1 options are available for the EAN128FNC1 barcode style.

DPI: Specify the printer resolution.

Module Size: Enter the horizontal size of the barcode module.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1DataMatrix Options

GS1DataMatrix options are available for the GS1DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT, or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

Encoding: Select the barcode encoding from the drop-down list.

GS1QRCode Options

ErrorLevel: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. Version M4 stores maximum amount of data.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

MaxiCode Options

MaxiCode option is available for the MaxiCode barcode.

Mode: Select the mode of the MaxiCode barcode. The available values are Mode2 to Mode6.

MicroPDF417 Options

MicroPDF417 options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

MicroQRCode Options

MicroQRCode options are available for the MicroQRCode barcode style.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. Version M4 stores maximum amount of data.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

PDF417 Options

PDF417 options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode. Values for this property range from 1 to 30. The default value is -1 which automatically determines column numbers.

Rows: Enter row numbers for the barcode. Values range between 3 and 90. The default value is -1 which automatically determines row numbers.

ErrorLevel: Enter the error correction level for the barcode. Values range between 0 and 8. The error correction capability increases as the value increases. With each increase in the ErrorLevel value, the size of the barcode increases. The default value is -1 for automatic configuration.

PDF 417 Barcode Type: Select the PDF417 barcode type from the drop-down list. The possible values are Normal or Simple. Simple is the compact type in which the right indicator is neither displayed nor printed.

QRCode Options

QRCode options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1, the original model or Model2, the extended model. For GS1QRCode, Model1 is not supported.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. The possible values are L (7% restorable), M (15% restorable), Q (25% restorable), and H (30% restorable). The higher the percentage, the larger the barcode becomes.

Version: Enter the version of the QRCode barcode style. Version indicates the size of the barcode. As the value increases, the barcode's size increases, enabling more information to be stored. Specify any value between 1 and 14 when the Model property is set to Model1 and 1 to 40 for Model2. The default value is -1, which automatically determines the version most suited to the value.

Mask: Select the pattern for the barcode masking from the drop-down list. Mask is used to balance brightness and offers 8 patterns in the QRCodeMask enumeration. The default value is Auto, which sets the masking pattern automatically, and is recommended for most uses.

  • Mask000 (i+j) mod 2 = 0
  • Mask001 i mod 2 = 0
  • Mask010 j mod 3 = 0
  • Mask011 (i+j) mod 3 = 0
  • Mask100 (( i div 2)+(j div 3)) mod 2 = 0
  • Mask101 (ij) mod 2 + (ij) mod 3 = 0
  • Mask110 ((ij) mod 2 +(ij) mod 3) mod 2 = 0
  • Mask111 ((ij)mod 3 + (i+j) mod 2) mod 2 = 0

Use Connection: Select whether to use the connection for the barcode. The possible values are True or False. This property is used in conjunction with the ConnectionNumber property. This property does not apply to the GS1QRCode barcode.

ConnectionNumber: Enter the connection number for the barcode. Use this property with the Connection property to set the number of barcodes it can split into. Values between 0 and 15 are valid. An invalid number raises the BarCodeData Exception. This property does not apply to the GS1QRCode barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

UPC Supplementary Options

Supplementary options are available for UPC_A, UPC_E0, UPC_E1, EAN_13, and EAN_8 barcode styles.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above, or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Barcode Dialog Properties

You can set the Barcode properties in the Barcode dialog. To open it, with the Barcode selected in the report, under the Properties panel, click the Property dialog link.

General
Barcode Settings
Appearance
Format
Visibility
Navigation
Data Output

Name: Enter a name for the barcode that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is used to render the barcode in the report.

Invalid Barcode Text: Enter a message to display if the barcode contains invalid values (content, character, length).

Caption

Location: Select whether to display the caption above or below the barcode, or select None to display the barcode without a caption.

Text Alignment: Select the horizontal alignment of the caption. The default value of General centers the caption.

Symbology: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies.

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a symbology which offers supplemental options, the additional options appear after the general collection of properties.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): Enter a value in points (for example, 0.8pt) for the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

Narrow bar width

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio: Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

QuietZone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.
Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

For more information, see the section on Barcode Specific Properties.

Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Amount of space to leave around report control

Top margin: Set the top padding in points.

Left margin: Set the left padding in points.

Right margin: Set the right padding in points.

Bottom margin: Set the bottom padding in points.

Rotation: Choose None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Initial visibility
  • Visible: The barcode is visible when the report runs.
  • Hidden: The barcode is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the barcode is visible.

Visibility can be toggled by another report item: Select this check box to display a toggle icon next to another report item. This enables the drop-down box where you can select the TextBox control that users can click to show or hide this barcode in the viewer.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this barcode. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Element Name: Enter a name to be used in the XML output for this barcode.

Output: Choose Auto, Yes, or No to decide whether to include this barcode in the XML output. Auto exports the contents of the barcode only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render barcodes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

See Also

Demo: Barcode Types

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bullet

Bullet
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Bullet

Glossary Item Box

With Bullet control, you can take a single value, the year-to-date revenue, for example, and compare it to a target value that you define in the control's properties. You can also define the beginning of the graph as the worst value and the end of the graph as the best value. To make the data visualization even more intuitive, you can also define a qualitative range (bad, satisfactory and good) for segments on the bullet graph and immediately see the position of the key measure within the bullet graph range.

Multiple bullet graphs can be combined into a data region, a table for example, to show single values side by side. You can orient bullets horizontally or vertically, and put them together as a stack to analyze several data dimensions at once. Bullet graphs are a great way to show progress towards a certain goal and serve as an alternative to dashboard gauges and meters.

Structure

The Value of the bullet defines the key measure displayed on the graph.

The Target Value defines a target for the Value to be compared to. You can select the target shape from a line, dot or square, and define its color and other properties.

The Worst Value and the Best Value define the value range on the graph.

In the Range1Boundary (bad/satisfactory boundary) and Range2Boundary (satisfactory/good boundary), you can optionally set the segments on the graph as qualitative ranges indicating bad, satisfactory and good sections.

Important Properties

By clicking on the Bullet control, you can set its properties in the Properties panel.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
BestValue | Enter a value or expression to define the highest value on the bullet graph.
Interval | Set the interval at which you want to show tick marks.
Range1Boundary | Enter a value or expression to define the boundary between bad and satisfactory values.
Range2Boundary | Enter a value or expression to define the boundary between satisfactory and good values.
TargetValue | Define a target for the Value to be compared to.
TargetShape | Choose the shape of the target from Line, Dot, or Square. By default, the shape is set to Line.
TargetStyle | Choose the border color from Color Picker and set the width of the target value marker. This property applies only when the Shape is set to Line.
TickMark | Select the position of marks on the bullet control from None, Inside, or Outside.
Value | Enter a value or expression to use as the bullet value.
ValueColor | Choose a color for the defined value.
WorstValue | Enter a value or expression to define the lowest value on the bullet graph.

Bullet Dialog Properties

You can set the Bullet properties in the Bullet dialog. To open it, with the Bullet selected on the report, under the Properties panel, click the Property dialog link.

General
Data
Appearance
Ranges
Labels
Navigation
Visibility
Data Output

Name: Enter a name for the Bullet that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Value: Enter an expression to use as the bullet value.

Target Value: Enter an expression to use as the target value of the bullet graph.

Bullet Graph Orientation

Horizontal: Select to display a horizontal bullet graph.

Vertical: Select to display a vertical bullet graph.

Value Style

Color: Select a color to use for the value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Target Style

Line

Dot

Square
Bullet line style Bullet dot style Bullet square style

Target Type: Choose Line, Dot or Square. The default value is Line.

Color: Select a color to use for the target value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Width: Enter a value in points to set the width of the target value marker. The default value is 3pt.

Note: The Width setting applies only when the Target Type is set to Line.

Tick Marks

None

Inside

Outside
Bullet without tick marks Bullet tick marks inside position Bullet tick marks outside position

Position: Choose None, Inside or Outside. The default value is Outside.

Color: Select a color to use for the tick marks, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is LightGray.

Width: Enter a value in points to set the width of the tick marks. The default value is 1pt.

Interval between tick marks: Set the interval at which you want to show tick marks.

Worst Value: Enter a value or expression to define the lowest value on the graph.

Bad/Satisfactory Boundary: Enter a value or expression to define the boundary between bad and satisfactory values.

Display 3 Sections: Select this check box to show three separate value ranges (bad, satisfactory, and good) instead of two (bad and satisfactory). This enables the Satisfactory/Good Boundary.

Satisfactory/Good Boundary: Enter a value or expression to define the boundary between satisfactory and good values.

Best Value: Enter a value or expression to define the highest value on the graph.

Display Labels: Select this check box to display axis labels for the bullet graph. Selecting this box enables the rest of the properties on this page.

Format: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Font

Family: Choose the font family name. The default value is Arial.

Size: Choose the size in points for the font. The default value is 10pt.

Style: Choose Regular, Bold, Italic, Underline or Strikeout. The default value is Regular.

Color: Select a Web or custom color for the font. The default value is Black.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this Bullet. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Initial visibility

  • Visible: The bullet graph is visible when the report runs.
  • Hidden: The bullet graph is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the bullet graph is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the bullet. The user can click the toggle item to show or hide this bullet.

Element Name: Enter a name to be used in the XML output for this Bullet.

Output: Choose Auto, Yes, No, or Content only to decide whether to include this Bullet in the XML output. Auto exports the contents of the bullet graph only when the value is not a constant.

See Also

Bullet Control to Visualize Sales against Target

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Chart

Chart
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart

Glossary Item Box

A Chart data region lets you visualize your data graphically at a glance. The various chart types allow you to represent your data in the best suitable way. It is important to understand the fundamentals, such as the elements that define the context of the chart, the wizard that quickly guides you through the steps of creating a chart, the areas for adding and grouping data in the chart, and the panels and adorners available for accessing the chart properties and performing quick actions.

This article provides information about the chart elements. Further subtopics provide details on every other aspect of charts that will help you design any chart supported by ActiveReports.

Chart Elements

The below image illustrates the elements that make up the Chart data region. These elements help you analyze the visual information and interpret numerical and relational data in a chart.

You can view all the chart elements in the Report Explorer and access properties through the Chart Smart Panels and Properties panel.

Plot Area
The plot area is the area of the chart where the data is plotted graphically. It also includes the chart axes and legend.
Plot
The plot is where the actual chart is configured and converted to visual attributes, that is, graphs. It also includes other configuration settings like adding Trendlines, setting clipping mode, offset, etc. For more information, see the Plots topic.
Axes
Typically, a chart consists of two axes that are used to plot the data - vertical axis (also known as Y-axis) and horizontal axis (also known as X-axis). You can change the axis type, hide the axis label or title, customize the line appearance, etc. For more information, see the Axes topic.
Legend
The legend serves as a key to the specific colors or patterns being used to show series values in the chart. For more information, see the Legends topic.
Header
The chart header is used to display a title for the chart. The chart header appears above the plot area. Use the header settings to control the text formatting, padding, background color, alignment, etc. for a chart header.
Footer
The chart footer is used to add a footer for the chart. The chart footer is displayed below the plot area. Use the footer settings to control the text formatting, padding, background color, alignment, etc. for a chart footer.

Supported Chart Types

Following is the list of supported chart types in Page/RDLX reports. Each of these are discussed under Plots topic.

  • Column and Bar Charts
  • Area Chart
  • Line Chart
  • Pie and Doughnut Charts
  • Scatter and Bubble Charts
  • Radar Scatter and Radial Bubble Charts
  • Radar Line Chart
  • Radar Area Chart
  • Spiral Chart
  • Polar Chart
  • Gantt Chart
  • Funnel and Pyramid Charts
  • Candlestick Chart
  • High Low Close Chart
  • High Low Open Close Chart
  • Range Charts
  • Gauge Chart

See Also

Configuring Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Chart Wizard

Chart Wizard
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Chart Wizard

Glossary Item Box

The Chart Wizard guides you through the process of creating a chart. When you drag and drop the Chart control onto the report design surface, the Chart Wizard is displayed.

Note: The Chart Wizard is displayed only if a report is bound to a data set. For the information on how to bind a chart to data, see our walkthrough Create Clustered Column Chart.

Choose Chart Query and Plot

The first screen of the Chart Wizard asks you to select a chart query and a plot type.

Choose ActiveReports Chart Query and Plot

In the Query drop-down, select one of the report's available data queries. For information on setting up queries, see the Configuring Data Queries in Report Wizard.
In the Plot Type section, you will find the list of supported chart types organized into categories. These chart types are grouped to assist you in selecting the most appropriate visualization for your data. To learn more about the available chart types, refer to the chart tutorials under Plots topic.

Configure Chart Data Values

In the second screen of the Chart Wizard, configure the data values.

Choose ActiveReports Chart Query and Plot

In this step, you can configure the data values that will be visualized as graphical shapes in your chart. Each data point represents a value or summary (e.g., a sum or average) that corresponds to a part of the data displayed in the chart.

Field

This drop-down allows you to select the specific field from your data query that you want to visualize. If there is only one data value, then the axis title is set as the field's 'Caption'.

Aggregate

Choose how the data should be aggregated. The wizard supports multiple aggregation functions to evaluate all the data value fields into a single value. Choose the aggregate function for the chart values from Average, Count, CountOfAll, CountDistinct, List, Min, Max, PopulationStandardDeviation, PopulationVariance, StandardDeviation, Sum, and Variance.

The selected function will be applied to the chosen field, summarizing the data based on the specified aggregate function and grouping that can be configured on the next steps.

Caption

The caption provides a label for the data series in the chart. This label is especially useful when your chart displays multiple values, and you want to display a legend to distinguish between them.

For charts that only require a single value (like a pie or donut chart), one data field is sufficient. However, some chart types (such as range charts) may require multiple data values. For more details on handling multiple data values and advanced configurations, refer to the Using Chart article.

You can use the Add and Remove buttons to adjust the data fields shown in the chart. The up and down arrow buttons allow you to reorder the fields if your chart supports multiple values.

Click Next to proceed to the next step in the wizard.

Configure Chart Data Groupings

In the third screen of the Chart Wizard, configure the data groupings.

Choose ActiveReports Chart Query and Plot

Categories

Group By

Specify the field to group the data into categories that exist for each unique value (or numerical range) for the specified field. The title of the axis is set to the corresponding category field name.

Sorting

Choose the data sorting direction from None, Ascending, or Descending.

Series

Group By

To group the data into series.

Sorting

Choose the data sorting direction from None, Ascending, or Descending. The sorting field is automatically set to the subcategory field.

Layout Type

Select the way you want the series groups to arrange from Cluster and Stack. The Layout type option is available for the supported chart types only, which are Column, Bar, Area, Spiral, Polar, and Range charts.

Choose Report Colors

Choose ActiveReports Theme and Style for Charts

In the final step of the Chart Wizard, you can apply a color theme and style to your chart to make it visually appealing and ensure consistency in the design. The preview pane on the right allows you to see how your chart will look with the selected theme and style before finalizing the configuration.

Theme

The Theme dropdown allows you to select from a variety of pre-defined themes that determine the base color palette for the chart. For instance, the screenshot shows the Active theme selected, which applies a specific set of colors to different chart elements, such as headers, footers, and data rows.

Style

The Style dropdown provides additional customization within the selected theme by offering various styles to apply. These styles can subtly change how colors are used in the chart. In the screenshot, the Light Style 1 Accent 1 is selected, which applies different shades of blue to the headers and footers, giving the chart a clean and professional appearance.

Preview

On the right side, the Preview section shows how your selections will look when applied to the chart. The preview displays how different chart elements—like the header, group headers, group footers, details, and the chart footer—will be styled. Each group header and footer is visually distinct, using alternating colors to improve readability.

Once you’ve chosen the desired theme and style, click Finish>> to apply the settings and generate the chart in your report.

See Also

Create Clustered Column Chart
Plots

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Chart Smart Panels and Adorners

Chart Smart Panels and Adorners
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Chart Smart Panels and Adorners

Glossary Item Box

Smart panels are the dialogs that group commonly used properties of the chart elements using tabs and groups. ActiveReports provides you with the smart panels for the chart elements. These smart panels can be accessed from the Report Explorer. You need to select the chart element you want the smart panel to show and click the Property dialog link on the Properties pane.

Chart Smart Panel

The Chart Smart Panel can also be accessed from the context menu when selecting a Chart on the design area.

Chart Smart Panel

General

Name: A name for the chart that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to bind to the chart. The combo box is populated with all of the datasets in the report's dataset collection.

Filters

Add a new filter by specifying the Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Palette

Select a palette for the chart from the list of pre-defined palettes, including the Custom palette.

Appearance

Border

Style: Select a border style from the list of available options.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the borderlines.

Color: Choose a Web or Custom color to use for the borderlines.

Background Fill Color: Choose a color to fill the background of the chart.

Plot Area

Border

Style: Choose an enumerated style for the border.

Width: Choose a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color: Select a Web or Custom color.

Padding: Set padding values - Top, Left, Right, and Bottom, for the chart.

Chart Header and Chart Footer Smart Panels

Chart Header and Footer Smart Panels

General

Title: Enter an expression or text to use for the chart header/footer.

Height: Set the height of the chart header/footer in percent.

Appearance

Border

Style: Select a border style from the list of available options.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the borderlines.

Color: Choose a Web or Custom color to use for the borderlines.

Background Fill Color: Choose a Web or Custom color to fill the background of the chart header/footer.

Font

Family: Choose the font family name for the header/footer text.

Size: Choose the size in points for the header/footer text font.

Style: Choose one from the enumerated styles for the text font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, and DoubleUnderline.

Alignment

Horizontal Alignment: Choose Left, Center, or Right.

Vertical Alignment: Choose Top, Middle, or Bottom.

Padding: Set the padding values - Top, Left, Right, and Bottom, for the chart header/footer.

Chart Axis Smart Panel

Chart Axis Smart Panel

Title

Title: Enter an expression or text to use for the chart axis title.

Font

Family: Choose the font family name for the chart axis title.

Size: Choose the size in points for the chart axis title.

Style: Choose one from the enumerated styles for the text font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, and DoubleUnderline.

Padding: Set the padding values - Top, Left, Right, and Bottom, for the chart axis title.

Layout

Overlapping Labels Mode: Select Auto or Show to specify whether the labels can be overlapped.

Size

Height: Set the height in percent relative to the overall chart height.

Width: Set the width in percent relative to the overall chart width.

MaxHeight: Set the maximum height in percent relative to the overall chart height.

MaxWidth: Set the width in percent relative to the overall chart width.

Position

Reversed: Select this check box to reverse the direction of the axis -top to bottom, or right to left.

Origin: Value or ordinal number, at which an axis crosses the perpendicular axis.

Position: Select from Far, Near, or None for the label position.

Labels

General

Show Labels: Select this checkbox to have the axis labels displayed.

Format: The formatting string used to render dates and numbers.

Angle: Rotation angle for the axis label. The angle is measured in degrees with valid values from -90 to 90.

Writing mode: The horizontal (lr-tb) or vertical direction (tb-rl) of the label text. The default value is lr-tb (left to right top to bottom). If set to tb-lr (top to bottom left to right), the chart axis labels appear vertically.

Label Row Count: Sets the number of rows for axis labels, ranging from 1 to 10 for a multi-row arrangement. This property is supported in Column, Area, Line, Scatter, Bubble, Candlestick, High Low Close, High Low Open Close, Range Column, and Range Area charts, for X-Axis.

Appearance

Font

Family: Choose the font family name for the chart axis label.

Size: Choose the size in points for the chart axis label.

Style: Choose one from the enumerated styles for the text font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, and DoubleUnderline.

Padding: Set the padding values - Top, Left, Right, and Bottom, for the chart axis label.

Line

Show Line: Select this checkbox to have the axis line shown.

Appearance

Color: Select a Web or Custom color.

Width: Specify the width of the axis line in points.

Style: Choose from an enumerated style for the axis line.

Minor Gridline

Grid Interval: Set the interval at which you want to show minor grid lines or tick marks or both.

Grid Appearance

Show grid: Select this check box to show minor grid lines for the axis.

Color: Select a color for the grid line.

Width: Enter a width value between 0.25pt and 20pt.

Style: Choose one from the enumerated styles for the gird line.

Tick mark appearance

Position: Select the tick mark position from None, Inside, Outside, or Cross.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Size: Specify the length of the minor grid tick marks.

Color: Select a Web or Custom color.

Width: Specify the width of the tick mark in points.

Style: Choose from an enumerated style for the minor grid tick mark.

Major Gridline

Grid Interval: Set the interval at which you want to show major grid lines or tick marks or both

Grid Appearance

Show grid: Select this check box to show major grid lines for the axis.

Color: Select a color for the grid line.

Width: Enter a width value between 0.25pt and 20pt.

Style: Choose one from the enumerated styles for the gird line.

Tick mark appearance

Position: Select the tick mark position from None, Inside, Outside, or Cross.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Size: Specify the length of the major grid tick marks.

Color: Select a Web or Custom color.

Width: Specify the width of the tick mark in points.

Style: Choose from an enumerated style for the major grid tick mark.

Scale

Scale Type: Select the axis scale from Linear, Logarithmic, Ordinal, or Percentage.

Minimum scale value: Leave this value blank to allow the data to determine the minimum value to use.

Maximum scale value: Leave this value blank to allow the data to determine the maximum value to use.

Logarithmic base: The axis logarithmic base for the logarithmic scale type.

See Axes for more information.

Chart Plot Smart Panel

Chart Plot Smart Panel

General

Name: Enter the chart plot name.

Plot Type: Select a chart plot type from the following available types:

Bar | Column | Line | Area | Funnel
Pie | Doughnut | Spiral | Polar | Pyramid
Radar Area | Radar Scatter | Radar Line | Radar Bubble | Bubble
Gantt | Candlestick | High Low Close | High Low Open Close | Scatter
Range Area | Range Bar | Range Column | Gauge |

See Plots topic for more information.

Data Series

General tab

Name: Name of the category group or series group.

Value: Add data series expression.

Caption: Add caption for the data series expression

Tooltip: Set the tooltip for the data series, a field, constant, or an expression.

Format: Set the format of the tooltip's value.

Styles tab

Common > Opacity: The opacity of the data series plot.

Line Style: Set the style for the line representing the data series plot.

Lable Connecting Line: Set the style for the label's line.

Labels tab

Set the labels for the data points.

Point Labels

Value: The value of the data label.

Format: The format of the data label's value.

Text Position: Position of the text that you can choose as Auto, Center, Inside, or Outside.

Offset: Percentage offset of the data point.

Background Color: Data label's background color.

Font: Set font and the appearance for the data label.

Border: Set the border for the data label.

Action tab

Action type: Action to perform when the user clicks on the data points. See the Interactivity topic on more information.

Category/Series Groups

General tab

Name: Name of the category group or series group.

Group on >Expression: The expression based on which categories/series should be grouped.

Label: The text for the category group label.

Filters tab

Filters
Add a new filter by specifying the Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting tab

Expression: A field used for sorting.

Direction: Choose the data sorting direction from Ascending or Descending.

Color Series

Specify the series for the color legend.

Legend Mode: Specify the mode depending on which the color legend is applied to the chart.

Data Values: Data points are colored based on the data values.

Series Groups: Data points are colored based on the series groups.

Custom: To set custom legend, you should set the expression for the legend series in Custom Expression.

Action Type: Chart color action. See the Interactivity topic on more information.

Shape/Size Series

Specify the series for the shape or size legend to display on each data point.

Legend Mode:

Series Groups: Data points are colored based on the series groups.

Custom: To set custom legend, you should set the expression for the legend series in Custom Expression.

Appearance

Clipping Mode: The Clipping Mode determines how a plot extends within the plot area. The ClippingMode can be set to:

Fit: Utilizes the free space to fit the plots within the plot area
Clip: Clips off the excess plot lengths (eg. bar or column lengths) toward the right or the bottom

Offset: The Offset is the percentage relative by which the plots should move to the right or the bottom side, respectively.

Overlapping Labels Mode: Select Auto or Show to specify whether the labels can be overlapped.

Overlays

See Trendlines topic for more information.

General tab

Caption: Enter the chart overlay name.

Type: Set the type of the overlay by selecting it from the predefined list.

Display: Select the display position from Front or Back.

Appearance tab

Border

Style: Select a border style from the list of available options.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the borderlines.

Color: Choose a Web or Custom color to use for the borderlines.

Config tab

Axis: Specify the axis, to which the overlay belongs.

Detail Level: Specify if the overlay calculation should include the entire dataset or each detail group.

Field: Set the field name for the overlay to use.

Aggregate: Set the reference line aggregate function.

Legend Label: Enter the legend label text.

Chart Color Legend Smart Panel

Chart Color Legend Smart Panel

General

Legend Mode: Specify the mode depending on which the color legend is applied to the chart.

Data Values: Data points are colored based on the data values.

Series Groups: Data points are colored based on the series groups.

Custom: To set custom legend, you should set the expression for the legend series in Custom Expression.

Title

Title: Enter an expression or text to use for the chart legend.

Font

Family: Choose the font family name for the chart legend.

Size: Choose the size in points for the chart legend.

Style: Choose one from the enumerated styles for the text font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, and DoubleUnderline.

Appearance

Border

Style: Select a border style from the list of available options.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the borderlines.

Color: Choose a Web or Custom color to use for the borderlines.

Font

Family: Choose the font family name for the chart legend.

Size: Choose the size in points for the header/footer text font.

Style: Choose one from the enumerated styles for the text font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, and DoubleUnderline.

Background Fill Color: Choose a Web or Custom color to fill the background of the chart legend.

Layout

Hide Legend: Select this checkbox to hide the chart legend.

Position: Select an enumerated value from Bottom, Left, Right, or Top to determine the position of the legend relative to the chart area.

Orientation: Select the legend orientation from Horizontal or Vertical.

Size

MaxHeight: Sets the maximum height in percent relative to the overall chart height.

MaxWidth: Sets the maximum width in percent relative to the overall chart width.

Padding: Set the padding values - Top, Left, Right, and Bottom, for the chart legend.

See Legends topic for more information.

Chart Data - Category Groups Smart Panel

Chart Smart Panel

For the available settings, see Category/Series Groups section.

Chart Data - Series Groups Smart Panel

Chart Smart Panel

For the available settings, see Category/Series Groups section.

Chart Data - Series Values Smart Panel

Chart Smart Panel

For the available settings, see Data Series section.

Adorners

Chart Smart Panel

Adorners are visual indicators for quick actions that are required for displaying data on chart.

Chart Data Adorner

The Chart Data adorner lets you add, edit, and delete chart data series.

Add: Adds a stub data series to plot, with Name, Values, and Captions set to “Series{index}”. The data series can also be added using the drag-drop action.
Data adorner items take the name specified in DataSeries.Name property. This property has no effect on rendering; it is visible during the design time to give a more meaningful or a short name to Data Series as needed and in data exports (CSV/XML).
On the other hand, the caption has an effect on the rendering. In the Color Series settings, the legend displays the name supplied in the Caption property.

Edit: Opens Chart Data - Series smart panel.

Delete: Deletes the data series.

Series/Category Groups Adorner

The Series/Category groups adorner lets you manage the series or category groups.

Add: Adds a stub series/category group with a name equal to
“ChartPlot{plot_index}_SeriesGroup{group_index}” or “ChartPlot{plot_index}_CategoryGroup{group_index}”

and a single group expression equal to “SeriesGroup{index}” “CategoryGroup{index}”. You can also use the drag-drop action to add a series/category group.

Edit: Opens the Series/Category groups smart panel for the selected series/category group.

Delete: Deletes the selected series/category.

Legend Data Adorner

Depending on the type of plot, different legend series are available. See the Legends topic for more information. The legends displayed in the Legend Data adorner, the Color, Shape, and Size, depend on the plot type.

Edit: Opens the legend series smart panel. See Chart Color Legend Smart Panel section for details.
Reset: Resets series to default state.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Plots

Plots
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots

Glossary Item Box

A plot in a Chart data region plots Data values into geometrical shapes based on configurations.

Refer to the following sub-topics on plots for detailed descriptions of various plot template configurations. Each of these plots is explained in the dedicated pages with end-to-end walkthroughs.

  • Column and Bar Charts
  • Area Chart
  • Line Chart
  • Pie and Doughnut Charts
  • Scatter and Bubble Charts
  • Radar Scatter and Radar Bubble Charts
  • Radar Line Chart
  • Radar Area Chart
  • Spiral Chart
  • Polar Chart
  • Gantt Chart
  • Funnel and Pyramid Charts
  • Candlestick Chart
  • High Low Close Chart
  • High Low Open Close Chart
  • Range Charts
  • Gauge Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Column and Bar Charts

Column and Bar Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Column and Bar Charts

Glossary Item Box

The Column and Bar charts present the comparison of data values across categories. The plot settings of these two charts are similar, however, they represent the data differently.

Column Charts

Column Charts plot the data values as vertical columns against the categories that are arranged horizontally. The y-axis values determine the heights of the columns, while the x-axis displays the category labels. The Column charts are vertical versions of bar charts and use the x-axis as a category axis.

Clustered Column Chart

A Clustered Column chart is used to compare different values across different categories. See Create Clustered Column Chart walkthrough to learn how to create this chart.

Clustered Column Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Column Chart

A Stacked Column chart is used to display the relationship of specific items to the whole across different categories and plot values. This chart stacks the data series vertically.

Stacked Column Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Percentage Column Chart

A Percentage Stacked Column chart is used to perform comparisons of percentages that each of the values are contributing to the total, across all your categories. This chart stacks the data series vertically and also equalizes the plotted values to meet 100%.

Percentage Stacked Column Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Bar Charts

Bar charts compare categorical data through horizontal bars, where the length of each bar represents the value of the corresponding category. In bar charts, categories are organized along the vertical axis and data values along the horizontal axis. For example, sales of various product categories can be presented through a bar chart. The Bar charts are preferred when the number of categories is too large to be used on an x-axis.

Clustered Bar Chart

A Clustered Bar chart can be used to display the comparisons of values across different categories. The Create Clustered Bar Chart walkthrough showcases plotting the chart comparing the Sales for different Product Categories and Sales Channel.

Clustered Bar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Bar Chart

A Stacked Bar chart is used to display the relationship of each category to the whole.

Stacked Bar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Percentage Bar Chart

A Percentage Stacked Bar chart is used to display the comparisons of the percentage that each value contributes to the total across different categories.

Percentage Stacked Bar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Clustered Column Chart

Create Clustered Column Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Column and Bar Charts > Create Clustered Column Chart

Glossary Item Box

This walkthrough creates a Clustered Column Chart. The chart consists of two columns comparing the 'Net Sales' and 'Net Income' per 'Product Category'. The final chart appears like this:

Clustered Column Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and validate the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes.

Add a Dataset

  1. Right click the added datasource and in the DataSet dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. Go to the Fields page to view the available fields and modify the Name of the [SalesAmount] field to [Net Sales].
  4. On the same page, add two calculated fields:
    Name | Value
    Net Income | =[Net Sales] - [UnitCost] - [DiscountAmount] - [ReturnAmount]
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  5. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Column'.
  3. Click Next to configure data values.
    Here, we will define two series values to form a cluster (or group), one column to show the 'Net Sales' and the other to show the 'Net Income'.
  4. Under Configure Chart Data Values, add the following two values from the drop-down, set the corresponding aggregates and captions, and click Next.
    Field | Aggregate | Caption
    [Net Sales] | Sum | Net Sales
    [Net Income] | Sum | Net Income
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Product Category]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Cluster'.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Clustered Column Chart - Preview

Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Category Groups

  1. In the Category Groups, right-click the [Product Category] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, go to Sorting tab and add the following expression to sort the product category in the order of decreasing total net sales:
    =Sum([Net Sales])
  3. Click OK to complete setting up the plot.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped.
  3. In the Chart Axis dialog, go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Go to the Line page and uncheck the Show Line option
  5. Go to the Major Gridline page and set Grid Interval to '100000'.
  6. Set the following properties under Grid appearance:
    • Show grid: Check-on
    • Color: #cccccc
    • Style: Dotted
  7. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 1000000.
  8. Proceed with other adjustments and click OK to complete setting up the Y-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select DataValues as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.

You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.

Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Clustered Bar Chart

Create Clustered Bar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Column and Bar Charts > Create Clustered Bar Chart

Glossary Item Box

This walkthrough creates a Clustered Bar Chart. The chart compares the Store, Reseller, Online, and Catalog sales for the different sales categories as shown. The final chart appears like this:

Clustered Bar Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. Go to the Fields page to view the available fields and modify the Name of the [SalesAmount] field to [Net Sales].
  4. On the same page, add two calculated fields:
    Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  5. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Bar'.
  3. Click Next to configure data values.
    Here, we will define two series values to form a cluster (or group), one column to show the 'Net Sales' and the other to show the 'Net Income'.
  4. Under Configure Chart Data Values, add the following two values from the drop-down, set the corresponding aggregates and captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Product Category].
  6. Set the Series > Group By to [Sales Channel]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Cluster'.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    clustered bar chart at preview time
    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Category Groups

  1. In the Category Groups, right-click the Product Category and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, go to Sorting tab and add the following expression to sort the product category in the order of decreasing total net sales:
    =Sum([Net Sales])
  3. Click OK to complete setting up the plot.

Set Advanced Customization

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Currency (with 0 decimal points)
    • Angle: 45
  4. Now go to the Appearance tab and set the following properties.
    • Font > Size: 9pt
    • Font > Color: Gray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page, check-on the Show Grid option and set the following properties.
    • Grid Interval: 50000
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dotted
  7. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 450000
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 9pt
    • Font > Color: Gray
  4. Go to the Line page and set the following properties.
    • Color: Gray
    • Width: 2pt
  5. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page, select Custom from the drop-down and add the following colors.
    • #f26324
    • #1fd537
    • #e40010
    • #8fcd37
  3. Click OK to complete setting up the custom palette.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 9pt
    • Font > Color: DimGray
  4. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  5. Click OK to complete setting up the chart legend.

Chart Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Area Chart

Area Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Area Chart

Glossary Item Box

An Area Chart is similar to a line chart that is connected using line segments. The Area Chart arranges a period horizontally, connects them by line, encodes values into points, and fills the area between the line segments and x-axis with color. An area plot is a good chart option when you want to observe the volume change over a period. It gives the summation of the quantitative data.

Stacked Area Chart

A Stacked Area chart is a type of area chart that helps in breaking down data values into subcategories by placing corresponding area subsections on top of each other. The Create Stacked Area Chart walkthrough showcases plotting the Net Sales over a year with stacked areas for each Product Category.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Percentage Area Chart

A Percentage Stacked Area chart combines the stacked area and the Percentage axis scale. Apart from showing changes in data values, the chart can also show each subcategory's contribution to a total. The Create Stacked Percent Area Chart walkthrough showcases plotting the percentage share of Product Categories in Net Sales.

Percentage Stacked Area
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Clustered Area Chart

A Clustered Area chart is used to break down data values into subcategories for granular analysis. For example, the Clustered Area Chart can be used to depict the total sales changes over a year segregated into clustered areas per product category.

Clustered Area Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Clustered Area Chart

Create Clustered Area Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Area Chart > Create Clustered Area Chart

Glossary Item Box

This walkthrough creates a Clustered Area Chart. The chart displays the sales amount by product categories for each month. The final chart appears like this:

Clustered Area Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and validate the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes.

Add a Dataset

  1. Right click the added datasource and in the DataSet dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add a calculated field:
    Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Area'.
  3. Click Next to configure data values.
    Here, we will define a series value to display the sales amount value along the vertical axis.
  4. Under Configure Chart Data Values, add a new data value, and set the aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [DateKey].
  6. Set Series > Group By to [Product Category]. Ensure that Series > Layout Type is 'Cluster'. We will add more customizations to the category in later steps.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Clustered Area Chart in Design View

Add Customizations to Chart

Category Groups

  1. In the Category Groups area, right-click the [Date Key] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, In the General tab, go to Group on > Expression, and update the expression to =MonthName(Month(Fields!DateKey.Value)) to group based on month rather than actual dates.
  3. Go to Sorting tab and add the following expression:
    =Month(Fields!DateKey.Value)
  4. Set the Direction as 'Ascending'.
  5. Click OK to complete setting up the category groups.

Chart Data

  1. In the Chart Data area, right-click the [Sales Amount] and from the adorner, click Edit.
  2. Go to the Styles tab and set Common > Opacity to '50%' to change the opacity value for the plot fill color.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Plot

  1. From the Report Explorer, select Plot.
  2. Go to the Properties panel and set LineAspect to 'Spline' to display curved lines in the area chart.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped .
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the Grid Interval to '25000'.
  6. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 170000.
  8. Proceed with other adjustments and click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field, as X-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Angle to '-45'.
  4. Now, navigate to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  6. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales Report'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.

    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Area Chart

Create Stacked Area Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Area Chart > Create Stacked Area Chart

Glossary Item Box

This walkthrough creates a Stacked Area Chart. The chart displays the sales amount by product categories for each month. In a stacked area chart, the data values are broken down into subcategories and are stacked on top of each other. The final chart appears like this:

Stacked Area Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add a calculated field:
    Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Area'.
  3. Click Next to configure data values.
    Here, we will define a series value to display the sales amount value along the vertical axis.
  4. Under Configure Chart Data Values, add a new data value, and set the aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [DateKey].
  6. Set Series > Group By to [Product Category]. Ensure that Series > Layout Type is 'Stack', since we want to subcategorize the sales amount by product categories (i.e. cell phones, computers, cameras, tv and video, and audio) in a stack.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Stacked Area Chart in Design View

Add Customizations to Chart

Category Groups

  1. In the Category Groups area, right-click the [Date Key] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, In the General tab, go to Group on > Expression, and update the expression to =MonthName(Month(Fields!DateKey.Value)) to group based on month rather than actual dates.
  3. Go to Sorting tab and add the following expression to sort the sales date in the ascending order:
    =Month(Fields!DateKey.Value)
  4. Click OK to complete setting up the category groups.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Plot

  1. From the Report Explorer, select Plot.
  2. Go to the Properties panel and set LineAspect to 'Spline' to display curved lines in the area chart.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped .
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the Grid Interval to '25000'.
  6. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 250000.
  8. Proceed with other adjustments and click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field, as X-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Angle to '-45'.
  4. Now, navigate to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  6. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. On the Palette page, select Custom from the drop-down and add the following colors:
    • #f26324
    • #1fd537
    • #e40010
    • #8fcd37
    • #00b32c
  3. Click OK to complete setting up the palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales Report'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.

    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Percentage Area Chart

Create Stacked Percentage Area Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Area Chart > Create Stacked Percentage Area Chart

Glossary Item Box

This walkthrough creates a Stacked Percentage Area Chart. The stacked percentage area chart displays the percentage values that each Product Category contributes toward the Sales Amount in each month. The final chart appears like this:

Percent Stacked Area Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. Click OK to save the changes.
  4. Go to the Fields page to view the available fields and modify the Name of the [DateKey] field to [Sales Date].
  5. On the same page, add a calculated field:
    Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  6. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Area'.
  3. Click Next to configure data values.
    Here, we will define a series value to display the sales amount value along the vertical axis.
  4. Under Configure Chart Data Values, add a new data value, and set the aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [DateKey].
  6. Set Series > Group By to [Product Category]. Ensure that Series > Layout Type is 'Stack', since we want to subcategorize the sales amount by product categories (i.e. cell phones, computers, cameras, tv and video, and audio) in a stack.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Stacked Area Chart

Add Customizations to Chart

Category Groups

  1. In the Category Groups area, right-click the [Date Key] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, In the General tab, go to Group on > Expression, and update the expression to =MonthName(Month(Fields!DateKey.Value)) to group based on month rather than actual dates.
  3. Go to Sorting tab and add the following expression to sort the sales date in the ascending order:
    =Month(Fields!DateKey.Value)
  4. Click OK to complete setting up the category groups.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Plot

  1. From the Report Explorer, select Plot.
  2. Go to the Properties panel and set LineAspect to 'Spline' to display curved lines in the area chart.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped .
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the following properties under Tick Mark:
    • Position: Outside
    • Color: #cccccc
    • Style: Solid
  6. Go to the Scale page and set Scale Type to 'Percentage'.
  7. Proceed with other adjustments and click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field, as X-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Angle to '-45'.
  4. Now, navigate to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  6. Go to the Major Gridline page and set the following properties:
    • Tick Mark > Position: Outside
    • Tick Mark > Color: #cccccc
    • Tick Mark > Style: Solid
  7. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. On the Palette page, select Custom from the drop-down and add the following colors:
    • #f26324
    • #1fd537
    • #e40010
    • #8fcd37
    • #00b32c
  3. Click OK to complete setting up the palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales Report'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.

    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line Chart

Line Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Line Chart

Glossary Item Box

The Line Charts represent the data points connected using straight lines. A line chart arranges a period horizontally, encodes data points into Symbols, and connects them by line segments. As the most basic chart type, Line Chart is highly beneficial in visualizing data trends as they compare values against periodic intervals such as temperature, time, etc. Some of the good examples that can be conveniently demonstrated through a line chart are the monthly average sale of a product and the closing prices of a stock in a given time frame.

Single Line Chart

A Single Line chart helps you visualize the changes of a single data value. The Create Single Line Chart walkthrough showcases plotting the changes in Product Returns over a year.

Single Line Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Multiple Line Chart

A Multiple Line chart lets you split the data values into subcategories for granular analysis of the total changes. The Create Multiple Line Chart walkthrough showcases plotting the change in the Net Sales of products over a year for two Sales Channels.

Multiple Line Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Multiple Values Line Chart

A Multiple Values Line chart lets you display changes of related or unrelated data values over the same period. For example, the Multiple Values Line Chart can be used to show the change of the Net Sales, the Cost of Goods Sold, and the Net Income for a product in a year as shown.

Multiple Values Line Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Single Line Chart

Create Single Line Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Line Chart > Create Single Line Chart

Glossary Item Box

This walkthrough creates a Single Line Chart. The chart shows the trend in the return quantity over the year. The final chart appears like this:

Single Line Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Line'.
  3. Click Next to configure data values.
    Here, we will define a data series value to display the return quantity values.
  4. Under Configure Chart Data Values, add a new data value, and set the aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [Return Quantity] | Sum | Return Quantity
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [DateKey].
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
  7. Click Next to preview your chart.
    Line Chart in Design Area
    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Category Groups

  1. In the Category Groups section, right-click the [Date Key] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, in the General tab, go to Group on > Expression, and update the expression to group based on month rather than actual dates.
    =MonthName(Month(Fields!DateKey.Value))
  3. Go to Sorting tab and add the following expression to sort the sales date in the ascending order:
    =Month(Fields!DateKey.Value)
  4. Click OK to complete setting up the category groups.

Chart Data

  1. In the Chart Data section, right-click the [Return Quantity] and from the adorner, click Edit.
  2. Go to the Styles tab and set the Line Style > Width to '1.5pt'.
  3. Go to the Markers tab and set the Shape to 'Dot'.
    • Border > Style: Solid
    • Border > Color: Black
  4. Click OK to complete setting up the plot.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped.
  3. Go to the Labels page > Appearance tab, and set the following properties:
    • Font > Size: 10pt
    • Font > Color: DimGray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the following properties under Grid appearance.
    • Show grid: Check-on
    • Color: #cccccc
    • Width: 0.25pt
    • Style: Dashed
  6. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 11
  7. Proceed with other adjustments and click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as X-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Angle to '-45'.
  4. Now go to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  6. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Product Returns'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #555555
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Multiple Line Chart

Create Multiple Line Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Line Chart > Create Multiple Line Chart

Glossary Item Box

This walkthrough creates a Multiple Line Chart. The chart shows the sales trend for 'Store' and 'Online' over a year. The final chart appears like this:

Multiple Line Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add one calculated field:
    Name | Value
    Channel Name | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online")

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Line'.
  3. Click Next to configure data values.
    Here, we will define a data series value to display the sales amount values.
  4. Under Configure Chart Data Values, add a new data value, and set the aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings dialog, set the Categories > Group By to [DateKey].
  6. Set Series > Group By to [Channel Name].
  7. Click Next and Choose Report Colors from Theme and Style, and click Finish to finish configuring chart.
    Multiple Line Chart in Design Area
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Add Customizations to Chart

Category Groups

  1. In the Category Groups section, right-click the [Date Key] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, in the General tab, go to Group on > Expression, and update the expression to group based on month rather than actual dates.
    =MonthName(Month(Fields!DateKey.Value))
  3. Go to Sorting tab and add the following expression to sort the sales date in the ascending order:
    =Month(Fields!DateKey.Value)
  4. Click OK.

Chart Data

  1. In the Chart Data section, right-click the [Sales Amount] and from the adorner, click Edit.
  2. Go to the Styles tab and set the Line Style > Width to '1.5pt'.
  3. Go to the Markers tab and set the following:
    • Border > Style: Solid
    • Border > Color: Black
  4. Click OK.

Series Groups

  1. In the Series Gropus section, right-click the [Channel Name] and from the adorner, click Edit.
  2. Go to Filters tab and add following filter with settings as below.
    Expression Operator Values
    =[ChannelKey] In =1
    =2
  3. Click OK.

Plot

  1. From the Report Explorer, select Plot.
  2. Go to the Properties panel and set LineAspect to 'Spline' to display curved lines.

Legend Data

  1. In the Legend Data section, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as Y-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Now, navigate to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set Grid Interval to '10000'.
  7. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  8. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum scale value: 0
    • Maximum scale value: 150000
  9. Proceed with other adjustments and click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field as X-axis title can be skipped.
  3. Go to the Labels page > General tab and set the Angle to '-45'.
  4. Now go to the Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  6. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales By Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Pie and Doughnut Charts

Pie and Doughnut Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Pie and Doughnut Charts

Glossary Item Box

Pie charts are circular charts that display the contribution of each category which is represented by a slice. Each and every slice represents a category of data that makes up the whole pie. A pie chart is able to provide information at a glance itself. For example, you can use a pie chart to compare growth areas within a business such as profit and turnover.

A doughnut chart is like a pie chart with a center hole. It encodes the data values into rings divided into segments. For instance, a donut chart can be used to display a survey of book sales in various genres in a bookstore.

Single Value Pie Chart

A Single Value Pie chart visualizes parts of a single data value. For instance, the Single Value Plot can be used to show the contribution of product categories in Net Sales. See Create Pie Chart walkthrough to learn how to create this chart.

Single Value Pie Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Multiple Value Pie or Doughnut Chart

A Multiple Value Pie or Doughnut chart can be used to display various values divided into common parts using a Doughnut or Pie plot. For example, the Doughnut Plot can be used to show the contribution of product categories into Discounts, Returns, and Unit Cost. See Create Doughnut Chart walkthrough to learn how to create a Multiple Value Doughnut Chart.

Multiple Value Doughnut Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Doughnut Chart

Create Doughnut Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Pie and Doughnut Charts > Create Doughnut Chart

Glossary Item Box

This walkthrough creates a Doughnut Chart. The chart shows the contribution of sales channels to the total unit cost, return, and discount. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. Click OK to save the changes.
  4. On the Fields page, add following calculated field:
    Name | Value
    Channel Name | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values. The wizard appears by default if you have a dataset added to your report. See the topic on Chart Wizard for more information.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Column'.
  3. Click Next to configure data values.
    Here, we will define two series values to form a cluster (or group), one column to show the 'Net Sales' and the other to show the 'Net Income'.
  4. Under Configure Chart Data Values, add the following data values to display the return amount, unit cost, and discount for the sales channels.
    Field | Aggregate
    [UnitCost] | Sum | Unit Cost
    [ReturnAmount] | Sum | Return Amount
    [DiscountAmount] | Sum | Discount Amount
  5. Click Next to preview your chart.
    Doughnut Chart
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Add Customizations to Chart

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Chart Data

  1. In the Chart Data area, right-click [Unit Cost] and from the adorner, click Edit.
  2. With Series Values page selected, go to Labels tab and do the following settings:
    Point Labels > Value: Unit Cost
    Point Labels >Text Position: Center
    Font > Weight: SemiBold
    Font > Color: White
  3. In Styles tab, set the Line Style as follows:
    Style: Solid
    Width: 1pt
    Color: White
  4. Repeat the above steps for the other two data values.
  5. Click OK to complete setting up the series values.

Y-Axis

  1. Go to the Title page and remove the text from the Title field to hide the axis title in the chart.
  2. Go to Labels page and uncheck Show Labels to hide axis labels. We are displaying data labels instead of axis labels.
  3. Go to Scale page and ensure that Scale Type is set to 'Percentage'.
  4. Click OK to complete setting up the Y-axis.

Plot

  1. From the Report Explorer, select Plot.
  2. Go to the Properties pane and set the InnerRadius property for the doughnut to '20%' to reduce the inner radius.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Chart Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Expenses and Losses'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Pie Chart

Create Pie Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Pie and Doughnut Charts > Create Pie Chart

Glossary Item Box

This walkthrough creates a Pie Chart. The chart shows how the total sales amount is divided between different product categories such as cameras, computers, cell phones, TV and video, and audio. Each slice in the chart represents the percentage values that each part of the category contributes. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Copy Code
    $.value[*]
  3. Go to the Fields page to view the available fields. On the same page, add following calculated field:
    Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values. The wizard appears by default if you have a dataset added to your report. See the topic on Chart Wizard for more information.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (FactSales) and the Plot Type as 'Column'.
  3. Click Next to configure data values.
    Here, we will define two series values to form a cluster (or group), one column to show the 'Net Sales' and the other to show the 'Net Income'.
  4. Under Configure Chart Data Values, add the following data value and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Series > Group By to [Product Category].
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Pie Chart

Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Chart Data

  1. In the Chart Data area, right-click the [Sales Amount] and from the adorner, click Edit.
  2. With Series Values selected, go to Labels tab and do the following settings under Point Labels:
    Value: =Sum([SalesAmount])/Sum([SalesAmount],"Chartname")
    Format code: p2
    Text Position: Outside
    Offset: 4
  3. In Styles tab, set the Label Connecting Line as follows:
    Style: Solid
    Color: #e6e6e6
    Width: 0.25
    Position: Auto
  4. Click OK to complete setting up the series value.

Y-Axis

  1. Go to the Title page and remove the text from the Title field to hide the axis title in the chart.
  2. Go to Labels page and uncheck Show Labels to hide axis labels. We are displaying data labels instead of axis labels.
  3. Go to Scale page and ensure that Scale Type is set to 'Percentage'.
  4. Click OK to complete setting up the Y-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Click OK to complete setting up the Legend.

Chart Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales By Category'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Scatter and Bubble Charts

Scatter and Bubble Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Scatter and Bubble Charts

Glossary Item Box

Scatter and Bubble plots are chart types used to visualize relationships between value points. Both plots arrange data values along the vertical and horizontal axes and display points called Symbols on the intersections.

Scatter Chart

A scatter chart visualizes relationships between two variables. The Scatter graph uses dots to represent two different numeric variables. For example, the scatter chart can be used to depict the correlation between variables like GDP per capita and life expectancy.

Simple Scatter Chart

A Simple Scatter Plot visualizes relationships between two variables. For instance, the Simple Scatter Charts can be used to depict the correlation between life expectancy and GDP per Capita. See Create Scatter Chart walkthrough to learn how to create this chart.

Simple Scatter Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Bubble Chart

Bubble charts are used while plotting data points in terms of three numeric parameters. Note that the third numeric parameter is represented by the bubble's diameter. A bubble plot simply adds the third variable by encoding it into the size of the displayed symbols. For instance, the bubble chart can be used to depict the correlation between the diameter of a tree, its height, and volume.

Simple Bubble Chart

A Simple Bubble chart adds a third variable into visualization by encoding it into the size of the showcased symbols. For instance, the simple bubble chart can be used to display the correlation between a tree's diameter, its height and volume. See Create Bubble Chart walkthrough to learn how to create this chart.

Simple Bubble Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Multi-Category Scatter and Bubble Charts

The Multi-Category Scatter and Bubble chart splits the data values into categories and visualizes them using the shape and color of the symbol. For example, the multi-category scatter chart can be used to display the correlation between the life expectancy and GDP per capita categorized by the continent.

Multi-Category Scatter Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Scatter and Bubble Plot Properties

The Scatter and Bubble Plot properties discussed below can be accessed from the Properties Panel on selecting the Chart > Plot from the Report Explorer. You can access some of the important properties from the Plot's Smart Panel too. See Chart Smart Panels topic for more information. Both the Properties Panel and the Smart Panel can be accessed by right-clicking the plot in the design area.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Bubble Chart

Create Bubble Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Scatter and Bubble Charts > Create Bubble Chart

Glossary Item Box

This walkthrough creates a Bubble Chart. The chart shows the correlation between the height, diameter, and volume of the trees. The final chart appears like this:

Create a Report

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Girth": 8.3,
    "Height": 70,
    "Volume": 10.3
  },
  {
    "Girth": 8.6,
    "Height": 65,
    "Volume": 10.3
  },
  {
    "Girth": 8.8,
    "Height": 63,
    "Volume": 10.2
  },
  {
    "Girth": 10.5,
    "Height": 72,
    "Volume": 16.4
  },
  {
    "Girth": 10.7,
    "Height": 81,
    "Volume": 18.8
  },
  {
    "Girth": 10.8,
    "Height": 83,
    "Volume": 19.7
  },
  {
    "Girth": 11,
    "Height": 66,
    "Volume": 15.6
  },
  {
    "Girth": 11,
    "Height": 75,
    "Volume": 18.2
  },
  {
    "Girth": 11.1,
    "Height": 80,
    "Volume": 22.6
  },
  {
    "Girth": 11.2,
    "Height": 75,
    "Volume": 19.9
  },
  {
    "Girth": 11.3,
    "Height": 79,
    "Volume": 24.2
  },
  {
    "Girth": 11.4,
    "Height": 76,
    "Volume": 21
  },
  {
    "Girth": 11.4,
    "Height": 76,
    "Volume": 21.4
  },
  {
    "Girth": 11.7,
    "Height": 69,
    "Volume": 21.3
  },
  {
    "Girth": 12,
    "Height": 75,
    "Volume": 19.1
  },
  {
    "Girth": 12.9,
    "Height": 74,
    "Volume": 22.2
  },
  {
    "Girth": 12.9,
    "Height": 85,
    "Volume": 33.8
  },
  {
    "Girth": 13.3,
    "Height": 86,
    "Volume": 27.4
  },
  {
    "Girth": 13.7,
    "Height": 71,
    "Volume": 25.7
  },
  {
    "Girth": 13.8,
    "Height": 64,
    "Volume": 24.9
  },
  {
    "Girth": 14,
    "Height": 78,
    "Volume": 34.5
  },
  {
    "Girth": 14.2,
    "Height": 80,
    "Volume": 31.7
  },
  {
    "Girth": 14.5,
    "Height": 74,
    "Volume": 36.3
  },
  {
    "Girth": 16,
    "Height": 72,
    "Volume": 38.3
  },
  {
    "Girth": 16.3,
    "Height": 77,
    "Volume": 42.6
  },
  {
    "Girth": 17.3,
    "Height": 81,
    "Volume": 55.4
  },
  {
    "Girth": 17.5,
    "Height": 82,
    "Volume": 55.7
  },
  {
    "Girth": 17.9,
    "Height": 80,
    "Volume": 58.3
  },
  {
    "Girth": 18,
    "Height": 80,
    "Volume": 51.5
  },
  {
    "Girth": 18,
    "Height": 80,
    "Volume": 51
  },
  {
    "Girth": 20.6,
    "Height": 87,
    "Volume": 77
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Measurements'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Measurements) and the Plot Type as 'Bubble'.
  3. Click Next to configure data values. We will define three data values to show the 'Girth', 'Height', and 'Volume' of the trees.
  4. Under Configure Chart Data Values, add the following two values from the drop-down, set the corresponding aggregates and captions, and click Next.
    Field | Caption
    [Girth] | X
    [Height] | Y
    [Volume] | Size
  5. Skip the Configure Chart Data Groupings.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Bubble Chart in Design Area
    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties:
    • Title: Height (ft.)
    • Font > Size: 12pt
    • Font > Color: Gray
  3. Go to the Labels page and set the following properties:
    • Font > Size: 12pt
    • Font > Color: Gray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the Grid Interval to '5'.
  6. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Grid Interval: 5
    • Show grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
  7. Go to the Scale page and set the following properties:
    • Scale Type: Linear
    • Minimum scale value: 60
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties.
    • Title: Diameter (in.)
    • Font > Size: 12pt
    • Font > Color: Gray
  3. Go to the Labels page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Gray
  4. Go to the Line page and set the following properties.
    • Color: #cccccc
    • Width: 2pt
  5. Click OK to complete setting up the X-axis.

Legend Data

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the Title page and set the following properties.
    • Title: Volume (cubic ft.)
    • Font > Size: 12pt
    • Font >Color: Gray
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Background Fill Color > Icon Color: DimGray
  4. Click OK to complete setting up the chart legend.

Chart Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Tree Measurements'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.
  5. Once you are done with configuring and customizing the chart, press F5 to preview the report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Scatter Chart

Create Scatter Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Scatter and Bubble Charts > Create Scatter Chart

Glossary Item Box

This walkthrough creates a Scatter Chart. The chart shows the relationship between the 'GDP per Capita' and 'Life Expectancy'. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
 {
   "country": "Afghanistan",
   "continent": "Asia",
   "lifeExp": 43.828,
   "gdpPercap": 974.5803384,
   "pop": 31889923
 },
 {
   "country": "Albania",
   "continent": "Europe",
   "lifeExp": 76.423,
   "gdpPercap": 5937.029526,
   "pop": 3600523
 },
 {
   "country": "Algeria",
   "continent": "Africa",
   "lifeExp": 72.301,
   "gdpPercap": 6223.367465,
   "pop": 33333216
 },
 {
   "country": "Angola",
   "continent": "Africa",
   "lifeExp": 42.731,
   "gdpPercap": 4797.231267,
   "pop": 12420476
 },
 {
   "country": "Argentina",
   "continent": "Americas",
   "lifeExp": 75.32,
   "gdpPercap": 12779.37964,
   "pop": 40301927
 },
 {
   "country": "Australia",
   "continent": "Oceania",
   "lifeExp": 81.235,
   "gdpPercap": 34435.36744,
   "pop": 20434176
 },
 {
   "country": "Austria",
   "continent": "Europe",
   "lifeExp": 79.829,
   "gdpPercap": 36126.4927,
   "pop": 8199783
 },
 {
   "country": "Bahrain",
   "continent": "Asia",
   "lifeExp": 75.635,
   "gdpPercap": 29796.04834,
   "pop": 708573
 },
 {
   "country": "Bangladesh",
   "continent": "Asia",
   "lifeExp": 64.062,
   "gdpPercap": 1391.253792,
   "pop": 150448339
 },
 {
   "country": "Belgium",
   "continent": "Europe",
   "lifeExp": 79.441,
   "gdpPercap": 33692.60508,
   "pop": 10392226
 },
 {
   "country": "Benin",
   "continent": "Africa",
   "lifeExp": 56.728,
   "gdpPercap": 1441.284873,
   "pop": 8078314
 },
 {
   "country": "Bolivia",
   "continent": "Americas",
   "lifeExp": 65.554,
   "gdpPercap": 3822.137084,
   "pop": 9119152
 },
 {
   "country": "Bosnia and Herzegovina",
   "continent": "Europe",
   "lifeExp": 74.852,
   "gdpPercap": 7446.298803,
   "pop": 4552198
 },
 {
   "country": "Botswana",
   "continent": "Africa",
   "lifeExp": 50.728,
   "gdpPercap": 12569.85177,
   "pop": 1639131
 },
 {
   "country": "Brazil",
   "continent": "Americas",
   "lifeExp": 72.39,
   "gdpPercap": 9065.800825,
   "pop": 190010647
 },
 {
   "country": "Bulgaria",
   "continent": "Europe",
   "lifeExp": 73.005,
   "gdpPercap": 10680.79282,
   "pop": 7322858
 },
 {
   "country": "Burkina Faso",
   "continent": "Africa",
   "lifeExp": 52.295,
   "gdpPercap": 1217.032994,
   "pop": 14326203
 },
 {
   "country": "Burundi",
   "continent": "Africa",
   "lifeExp": 49.58,
   "gdpPercap": 430.0706916,
   "pop": 8390505
 },
 {
   "country": "Cambodia",
   "continent": "Asia",
   "lifeExp": 59.723,
   "gdpPercap": 1713.778686,
   "pop": 14131858
 },
 {
   "country": "Cameroon",
   "continent": "Africa",
   "lifeExp": 50.43,
   "gdpPercap": 2042.09524,
   "pop": 17696293
 },
 {
   "country": "Canada",
   "continent": "Americas",
   "lifeExp": 80.653,
   "gdpPercap": 36319.23501,
   "pop": 33390141
 },
 {
   "country": "Central African Republic",
   "continent": "Africa",
   "lifeExp": 44.741,
   "gdpPercap": 706.016537,
   "pop": 4369038
 },
 {
   "country": "Chad",
   "continent": "Africa",
   "lifeExp": 50.651,
   "gdpPercap": 1704.063724,
   "pop": 10238807
 },
 {
   "country": "Chile",
   "continent": "Americas",
   "lifeExp": 78.553,
   "gdpPercap": 13171.63885,
   "pop": 16284741
 },
 {
   "country": "China",
   "continent": "Asia",
   "lifeExp": 72.961,
   "gdpPercap": 4959.114854,
   "pop": 1318683096
 },
 {
   "country": "Colombia",
   "continent": "Americas",
   "lifeExp": 72.889,
   "gdpPercap": 7006.580419,
   "pop": 44227550
 },
 {
   "country": "Comoros",
   "continent": "Africa",
   "lifeExp": 65.152,
   "gdpPercap": 986.1478792,
   "pop": 710960
 },
 {
   "country": "Congo, Dem. Rep.",
   "continent": "Africa",
   "lifeExp": 46.462,
   "gdpPercap": 277.5518587,
   "pop": 64606759
 },
 {
   "country": "Congo, Rep.",
   "continent": "Africa",
   "lifeExp": 55.322,
   "gdpPercap": 3632.557798,
   "pop": 3800610
 },
 {
   "country": "Costa Rica",
   "continent": "Americas",
   "lifeExp": 78.782,
   "gdpPercap": 9645.06142,
   "pop": 4133884
 },
 {
   "country": "Cote d'Ivoire",
   "continent": "Africa",
   "lifeExp": 48.328,
   "gdpPercap": 1544.750112,
   "pop": 18013409
 },
 {
   "country": "Croatia",
   "continent": "Europe",
   "lifeExp": 75.748,
   "gdpPercap": 14619.22272,
   "pop": 4493312
 },
 {
   "country": "Cuba",
   "continent": "Americas",
   "lifeExp": 78.273,
   "gdpPercap": 8948.102923,
   "pop": 11416987
 },
 {
   "country": "Czech Republic",
   "continent": "Europe",
   "lifeExp": 76.486,
   "gdpPercap": 22833.30851,
   "pop": 10228744
 },
 {
   "country": "Denmark",
   "continent": "Europe",
   "lifeExp": 78.332,
   "gdpPercap": 35278.41874,
   "pop": 5468120
 },
 {
   "country": "Djibouti",
   "continent": "Africa",
   "lifeExp": 54.791,
   "gdpPercap": 2082.481567,
   "pop": 496374
 },
 {
   "country": "Dominican Republic",
   "continent": "Americas",
   "lifeExp": 72.235,
   "gdpPercap": 6025.374752,
   "pop": 9319622
 },
 {
   "country": "Ecuador",
   "continent": "Americas",
   "lifeExp": 74.994,
   "gdpPercap": 6873.262326,
   "pop": 13755680
 },
 {
   "country": "Egypt",
   "continent": "Africa",
   "lifeExp": 71.338,
   "gdpPercap": 5581.180998,
   "pop": 80264543
 },
 {
   "country": "El Salvador",
   "continent": "Americas",
   "lifeExp": 71.878,
   "gdpPercap": 5728.353514,
   "pop": 6939688
 },
 {
   "country": "Equatorial Guinea",
   "continent": "Africa",
   "lifeExp": 51.579,
   "gdpPercap": 12154.08975,
   "pop": 551201
 },
 {
   "country": "Eritrea",
   "continent": "Africa",
   "lifeExp": 58.04,
   "gdpPercap": 641.3695236,
   "pop": 4906585
 },
 {
   "country": "Ethiopia",
   "continent": "Africa",
   "lifeExp": 52.947,
   "gdpPercap": 690.8055759,
   "pop": 76511887
 },
 {
   "country": "Finland",
   "continent": "Europe",
   "lifeExp": 79.313,
   "gdpPercap": 33207.0844,
   "pop": 5238460
 },
 {
   "country": "France",
   "continent": "Europe",
   "lifeExp": 80.657,
   "gdpPercap": 30470.0167,
   "pop": 61083916
 },
 {
   "country": "Gabon",
   "continent": "Africa",
   "lifeExp": 56.735,
   "gdpPercap": 13206.48452,
   "pop": 1454867
 },
 {
   "country": "Gambia",
   "continent": "Africa",
   "lifeExp": 59.448,
   "gdpPercap": 752.7497265,
   "pop": 1688359
 },
 {
   "country": "Germany",
   "continent": "Europe",
   "lifeExp": 79.406,
   "gdpPercap": 32170.37442,
   "pop": 82400996
 },
 {
   "country": "Ghana",
   "continent": "Africa",
   "lifeExp": 60.022,
   "gdpPercap": 1327.60891,
   "pop": 22873338
 },
 {
   "country": "Greece",
   "continent": "Europe",
   "lifeExp": 79.483,
   "gdpPercap": 27538.41188,
   "pop": 10706290
 },
 {
   "country": "Guatemala",
   "continent": "Americas",
   "lifeExp": 70.259,
   "gdpPercap": 5186.050003,
   "pop": 12572928
 },
 {
   "country": "Guinea",
   "continent": "Africa",
   "lifeExp": 56.007,
   "gdpPercap": 942.6542111,
   "pop": 9947814
 },
 {
   "country": "Guinea-Bissau",
   "continent": "Africa",
   "lifeExp": 46.388,
   "gdpPercap": 579.231743,
   "pop": 1472041
 },
 {
   "country": "Haiti",
   "continent": "Americas",
   "lifeExp": 60.916,
   "gdpPercap": 1201.637154,
   "pop": 8502814
 },
 {
   "country": "Honduras",
   "continent": "Americas",
   "lifeExp": 70.198,
   "gdpPercap": 3548.330846,
   "pop": 7483763
 },
 {
   "country": "Hong Kong, China",
   "continent": "Asia",
   "lifeExp": 82.208,
   "gdpPercap": 39724.97867,
   "pop": 6980412
 },
 {
   "country": "Hungary",
   "continent": "Europe",
   "lifeExp": 73.338,
   "gdpPercap": 18008.94444,
   "pop": 9956108
 },
 {
   "country": "Iceland",
   "continent": "Europe",
   "lifeExp": 81.757,
   "gdpPercap": 36180.78919,
   "pop": 301931
 },
 {
   "country": "India",
   "continent": "Asia",
   "lifeExp": 64.698,
   "gdpPercap": 2452.210407,
   "pop": 1110396331
 },
 {
   "country": "Indonesia",
   "continent": "Asia",
   "lifeExp": 70.65,
   "gdpPercap": 3540.651564,
   "pop": 223547000
 },
 {
   "country": "Iran",
   "continent": "Asia",
   "lifeExp": 70.964,
   "gdpPercap": 11605.71449,
   "pop": 69453570
 },
 {
   "country": "Iraq",
   "continent": "Asia",
   "lifeExp": 59.545,
   "gdpPercap": 4471.061906,
   "pop": 27499638
 },
 {
   "country": "Ireland",
   "continent": "Europe",
   "lifeExp": 78.885,
   "gdpPercap": 40675.99635,
   "pop": 4109086
 },
 {
   "country": "Israel",
   "continent": "Asia",
   "lifeExp": 80.745,
   "gdpPercap": 25523.2771,
   "pop": 6426679
 },
 {
   "country": "Italy",
   "continent": "Europe",
   "lifeExp": 80.546,
   "gdpPercap": 28569.7197,
   "pop": 58147733
 },
 {
   "country": "Jamaica",
   "continent": "Americas",
   "lifeExp": 72.567,
   "gdpPercap": 7320.880262,
   "pop": 2780132
 },
 {
   "country": "Japan",
   "continent": "Asia",
   "lifeExp": 82.603,
   "gdpPercap": 31656.06806,
   "pop": 127467972
 },
 {
   "country": "Jordan",
   "continent": "Asia",
   "lifeExp": 72.535,
   "gdpPercap": 4519.461171,
   "pop": 6053193
 },
 {
   "country": "Kenya",
   "continent": "Africa",
   "lifeExp": 54.11,
   "gdpPercap": 1463.249282,
   "pop": 35610177
 },
 {
   "country": "Korea, Dem. Rep.",
   "continent": "Asia",
   "lifeExp": 67.297,
   "gdpPercap": 1593.06548,
   "pop": 23301725
 },
 {
   "country": "Korea, Rep.",
   "continent": "Asia",
   "lifeExp": 78.623,
   "gdpPercap": 23348.13973,
   "pop": 49044790
 },
 {
   "country": "Kuwait",
   "continent": "Asia",
   "lifeExp": 77.588,
   "gdpPercap": 47306.98978,
   "pop": 2505559
 },
 {
   "country": "Lebanon",
   "continent": "Asia",
   "lifeExp": 71.993,
   "gdpPercap": 10461.05868,
   "pop": 3921278
 },
 {
   "country": "Lesotho",
   "continent": "Africa",
   "lifeExp": 42.592,
   "gdpPercap": 1569.331442,
   "pop": 2012649
 },
 {
   "country": "Liberia",
   "continent": "Africa",
   "lifeExp": 45.678,
   "gdpPercap": 414.5073415,
   "pop": 3193942
 },
 {
   "country": "Libya",
   "continent": "Africa",
   "lifeExp": 73.952,
   "gdpPercap": 12057.49928,
   "pop": 6036914
 },
 {
   "country": "Madagascar",
   "continent": "Africa",
   "lifeExp": 59.443,
   "gdpPercap": 1044.770126,
   "pop": 19167654
 },
 {
   "country": "Malawi",
   "continent": "Africa",
   "lifeExp": 48.303,
   "gdpPercap": 759.3499101,
   "pop": 13327079
 },
 {
   "country": "Malaysia",
   "continent": "Asia",
   "lifeExp": 74.241,
   "gdpPercap": 12451.6558,
   "pop": 24821286
 },
 {
   "country": "Mali",
   "continent": "Africa",
   "lifeExp": 54.467,
   "gdpPercap": 1042.581557,
   "pop": 12031795
 },
 {
   "country": "Mauritania",
   "continent": "Africa",
   "lifeExp": 64.164,
   "gdpPercap": 1803.151496,
   "pop": 3270065
 },
 {
   "country": "Mauritius",
   "continent": "Africa",
   "lifeExp": 72.801,
   "gdpPercap": 10956.99112,
   "pop": 1250882
 },
 {
   "country": "Mexico",
   "continent": "Americas",
   "lifeExp": 76.195,
   "gdpPercap": 11977.57496,
   "pop": 108700891
 },
 {
   "country": "Mongolia",
   "continent": "Asia",
   "lifeExp": 66.803,
   "gdpPercap": 3095.772271,
   "pop": 2874127
 },
 {
   "country": "Montenegro",
   "continent": "Europe",
   "lifeExp": 74.543,
   "gdpPercap": 9253.896111,
   "pop": 684736
 },
 {
   "country": "Morocco",
   "continent": "Africa",
   "lifeExp": 71.164,
   "gdpPercap": 3820.17523,
   "pop": 33757175
 },
 {
   "country": "Mozambique",
   "continent": "Africa",
   "lifeExp": 42.082,
   "gdpPercap": 823.6856205,
   "pop": 19951656
 },
 {
   "country": "Myanmar",
   "continent": "Asia",
   "lifeExp": 62.069,
   "gdpPercap": 944,
   "pop": 47761980
 },
 {
   "country": "Namibia",
   "continent": "Africa",
   "lifeExp": 52.906,
   "gdpPercap": 4811.060429,
   "pop": 2055080
 },
 {
   "country": "Nepal",
   "continent": "Asia",
   "lifeExp": 63.785,
   "gdpPercap": 1091.359778,
   "pop": 28901790
 },
 {
   "country": "Netherlands",
   "continent": "Europe",
   "lifeExp": 79.762,
   "gdpPercap": 36797.93332,
   "pop": 16570613
 },
 {
   "country": "New Zealand",
   "continent": "Oceania",
   "lifeExp": 80.204,
   "gdpPercap": 25185.00911,
   "pop": 4115771
 },
 {
   "country": "Nicaragua",
   "continent": "Americas",
   "lifeExp": 72.899,
   "gdpPercap": 2749.320965,
   "pop": 5675356
 },
 {
   "country": "Niger",
   "continent": "Africa",
   "lifeExp": 56.867,
   "gdpPercap": 619.6768924,
   "pop": 12894865
 },
 {
   "country": "Nigeria",
   "continent": "Africa",
   "lifeExp": 46.859,
   "gdpPercap": 2013.977305,
   "pop": 135031164
 },
 {
   "country": "Norway",
   "continent": "Europe",
   "lifeExp": 80.196,
   "gdpPercap": 49357.19017,
   "pop": 4627926
 },
 {
   "country": "Oman",
   "continent": "Asia",
   "lifeExp": 75.64,
   "gdpPercap": 22316.19287,
   "pop": 3204897
 },
 {
   "country": "Pakistan",
   "continent": "Asia",
   "lifeExp": 65.483,
   "gdpPercap": 2605.94758,
   "pop": 169270617
 },
 {
   "country": "Panama",
   "continent": "Americas",
   "lifeExp": 75.537,
   "gdpPercap": 9809.185636,
   "pop": 3242173
 },
 {
   "country": "Paraguay",
   "continent": "Americas",
   "lifeExp": 71.752,
   "gdpPercap": 4172.838464,
   "pop": 6667147
 },
 {
   "country": "Peru",
   "continent": "Americas",
   "lifeExp": 71.421,
   "gdpPercap": 7408.905561,
   "pop": 28674757
 },
 {
   "country": "Philippines",
   "continent": "Asia",
   "lifeExp": 71.688,
   "gdpPercap": 3190.481016,
   "pop": 91077287
 },
 {
   "country": "Poland",
   "continent": "Europe",
   "lifeExp": 75.563,
   "gdpPercap": 15389.92468,
   "pop": 38518241
 },
 {
   "country": "Portugal",
   "continent": "Europe",
   "lifeExp": 78.098,
   "gdpPercap": 20509.64777,
   "pop": 10642836
 },
 {
   "country": "Puerto Rico",
   "continent": "Americas",
   "lifeExp": 78.746,
   "gdpPercap": 19328.70901,
   "pop": 3942491
 },
 {
   "country": "Reunion",
   "continent": "Africa",
   "lifeExp": 76.442,
   "gdpPercap": 7670.122558,
   "pop": 798094
 },
 {
   "country": "Romania",
   "continent": "Europe",
   "lifeExp": 72.476,
   "gdpPercap": 10808.47561,
   "pop": 22276056
 },
 {
   "country": "Rwanda",
   "continent": "Africa",
   "lifeExp": 46.242,
   "gdpPercap": 863.0884639,
   "pop": 8860588
 },
 {
   "country": "Sao Tome and Principe",
   "continent": "Africa",
   "lifeExp": 65.528,
   "gdpPercap": 1598.435089,
   "pop": 199579
 },
 {
   "country": "Saudi Arabia",
   "continent": "Asia",
   "lifeExp": 72.777,
   "gdpPercap": 21654.83194,
   "pop": 27601038
 },
 {
   "country": "Senegal",
   "continent": "Africa",
   "lifeExp": 63.062,
   "gdpPercap": 1712.472136,
   "pop": 12267493
 },
 {
   "country": "Serbia",
   "continent": "Europe",
   "lifeExp": 74.002,
   "gdpPercap": 9786.534714,
   "pop": 10150265
 },
 {
   "country": "Sierra Leone",
   "continent": "Africa",
   "lifeExp": 42.568,
   "gdpPercap": 862.5407561,
   "pop": 6144562
 },
 {
   "country": "Singapore",
   "continent": "Asia",
   "lifeExp": 79.972,
   "gdpPercap": 47143.17964,
   "pop": 4553009
 },
 {
   "country": "Slovak Republic",
   "continent": "Europe",
   "lifeExp": 74.663,
   "gdpPercap": 18678.31435,
   "pop": 5447502
 },
 {
   "country": "Slovenia",
   "continent": "Europe",
   "lifeExp": 77.926,
   "gdpPercap": 25768.25759,
   "pop": 2009245
 },
 {
   "country": "Somalia",
   "continent": "Africa",
   "lifeExp": 48.159,
   "gdpPercap": 926.1410683,
   "pop": 9118773
 },
 {
   "country": "South Africa",
   "continent": "Africa",
   "lifeExp": 49.339,
   "gdpPercap": 9269.657808,
   "pop": 43997828
 },
 {
   "country": "Spain",
   "continent": "Europe",
   "lifeExp": 80.941,
   "gdpPercap": 28821.0637,
   "pop": 40448191
 },
 {
   "country": "Sri Lanka",
   "continent": "Asia",
   "lifeExp": 72.396,
   "gdpPercap": 3970.095407,
   "pop": 20378239
 },
 {
   "country": "Sudan",
   "continent": "Africa",
   "lifeExp": 58.556,
   "gdpPercap": 2602.394995,
   "pop": 42292929
 },
 {
   "country": "Swaziland",
   "continent": "Africa",
   "lifeExp": 39.613,
   "gdpPercap": 4513.480643,
   "pop": 1133066
 },
 {
   "country": "Sweden",
   "continent": "Europe",
   "lifeExp": 80.884,
   "gdpPercap": 33859.74835,
   "pop": 9031088
 },
 {
   "country": "Switzerland",
   "continent": "Europe",
   "lifeExp": 81.701,
   "gdpPercap": 37506.41907,
   "pop": 7554661
 },
 {
   "country": "Syria",
   "continent": "Asia",
   "lifeExp": 74.143,
   "gdpPercap": 4184.548089,
   "pop": 19314747
 },
 {
   "country": "Taiwan",
   "continent": "Asia",
   "lifeExp": 78.4,
   "gdpPercap": 28718.27684,
   "pop": 23174294
 },
 {
   "country": "Tanzania",
   "continent": "Africa",
   "lifeExp": 52.517,
   "gdpPercap": 1107.482182,
   "pop": 38139640
 },
 {
   "country": "Thailand",
   "continent": "Asia",
   "lifeExp": 70.616,
   "gdpPercap": 7458.396327,
   "pop": 65068149
 },
 {
   "country": "Togo",
   "continent": "Africa",
   "lifeExp": 58.42,
   "gdpPercap": 882.9699438,
   "pop": 5701579
 },
 {
   "country": "Trinidad and Tobago",
   "continent": "Americas",
   "lifeExp": 69.819,
   "gdpPercap": 18008.50924,
   "pop": 1056608
 },
 {
   "country": "Tunisia",
   "continent": "Africa",
   "lifeExp": 73.923,
   "gdpPercap": 7092.923025,
   "pop": 10276158
 },
 {
   "country": "Turkey",
   "continent": "Europe",
   "lifeExp": 71.777,
   "gdpPercap": 8458.276384,
   "pop": 71158647
 },
 {
   "country": "Uganda",
   "continent": "Africa",
   "lifeExp": 51.542,
   "gdpPercap": 1056.380121,
   "pop": 29170398
 },
 {
   "country": "United Kingdom",
   "continent": "Europe",
   "lifeExp": 79.425,
   "gdpPercap": 33203.26128,
   "pop": 60776238
 },
 {
   "country": "United States",
   "continent": "Americas",
   "lifeExp": 78.242,
   "gdpPercap": 42951.65309,
   "pop": 301139947
 },
 {
   "country": "Uruguay",
   "continent": "Americas",
   "lifeExp": 76.384,
   "gdpPercap": 10611.46299,
   "pop": 3447496
 },
 {
   "country": "Venezuela",
   "continent": "Americas",
   "lifeExp": 73.747,
   "gdpPercap": 11415.80569,
   "pop": 26084662
 },
 {
   "country": "Vietnam",
   "continent": "Asia",
   "lifeExp": 74.249,
   "gdpPercap": 2441.576404,
   "pop": 85262356
 },
 {
   "country": "West Bank and Gaza",
   "continent": "Asia",
   "lifeExp": 73.422,
   "gdpPercap": 3025.349798,
   "pop": 4018332
 },
 {
   "country": "Yemen, Rep.",
   "continent": "Asia",
   "lifeExp": 62.698,
   "gdpPercap": 2280.769906,
   "pop": 22211743
 },
 {
   "country": "Zambia",
   "continent": "Africa",
   "lifeExp": 42.384,
   "gdpPercap": 1271.211593,
   "pop": 11746035
 },
 {
   "country": "Zimbabwe",
   "continent": "Africa",
   "lifeExp": 43.487,
   "gdpPercap": 469.7092981,
   "pop": 12311143
 }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Stats'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Scatter'.
  3. Click Next to configure data values. We will define two data values to show the 'GDP per Capita' and 'Life Expectancy'.
  4. Under Configure Chart Data Values, add the following two values from the drop-down, set the corresponding captions, and click Next.
    Field | Caption
    [gdpPercap] | X
    [lifeExp] | Y
  5. Skip the Configure Chart Data Groupings.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Scatter Chart at Preview Time

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties.
    • Title: Life Expectancy
    • Font > Size: 12pt
    • Font > Color: Gray
  3. Go to the Labels page > Appearance tab and set the following properties:
    • Font > Size: 12pt
    • Font > Color: Gray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the Grid Interval to '20'.
  6. Set the following properties under Grid appearance:
    • Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties:
    • Title: GDP per Capita
    • Font > Size: 12pt
    • Font > Color: Gray
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Gray
  5. Go to the Line page and set the following properties:
    • Color: #cccccc
    • Width: 2pt
  6. Go to the Scale page and set the Scale Type to 'Logarithmic'.
  7. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page, select Custom from the drop-down, and add the first color as '#f26324'.
  3. Click OK to complete setting up the custom palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Life Expectancy vs. GDP per Capita'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.

    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Radar Scatter and Radar Bubble Charts

Radar Scatter and Radar Bubble Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Scatter and Radar Bubble Charts

Glossary Item Box

Radar Scatter and Radar Bubble charts are useful in showing ordered measurements of one or two variables across a category range. Radar Scatter and Radar Bubble plots arrange categories on a circle and link the corresponding points with straight lines. Data values are represented by value points called Symbols. The symbol size in a Radar Bubble plot can represent extra information about the data point. In Radar and Radar Bubble charts, the symbols are laid out along the radial lines. The major difference between the Radar Scatter plot and Radar Bubble plot is that the former visualizes a single variable measurement, while the latter encodes the size of data points.

Simple Radar Scatter Chart

A Simple Radar Scatter chart visualizes measurements of a single variable. For instance, the simple radar bubble plot can be used to display the average monthly temperature and precipitation in Paris, France.

Simple Radar Scatter Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Simple Radar Bubble Chart

A radar bubble chart encodes surplus data using data point sizes. For instance, the simple radar bubble plot can be used to display the average monthly temperature and precipitation in Paris, France. See Create Simple Radar Bubble Chart walkthrough to learn how to create this chart.

Simple Radar Bubble Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Multi-Category Radar Scatter and Bubble Charts

A Multi-Category Radar Scatter and Bubble charts can be used to configure Radar Scatter and Bubble charts to split data values into subcategories and depict them with symbols' colors, shapes, or both. For instance, the Multi-Category Radar Scatter and Bubble charts can be used to depict the average monthly temperature in three European cities that are distinguished by data points' colors. See Create Multi-Category Radar Scatter Chart walkthrough to learn how to create this chart.

Multi-Category Radar Scatter Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Radar Scatter and Bubble Plot Properties

The Radar Scatter Plot properties discussed below can be accessed from the Properties Panel on selecting the Chart > Plot from the Report Explorer. You can access some of the important properties from the Plot's Smart Panel too. See Chart Smart Panels topic for more information. Both the Properties Panel and the Smart Panel can be accessed by right-clicking the plot in the design area.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Radar Bubble Chart

Create Radar Bubble Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Scatter and Radar Bubble Charts > Create Radar Bubble Chart

Glossary Item Box

This walkthrough creates a Radar Bubble Chart. The chart shows the average monthly temperature and precipitation for Barcelona city. The final chart appears like this:

Radar Bubble Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "City": "Amsterdam",
    "Month": "January",
    "MinT": 1,
    "MaxT": 6,
    "Precipitation": 65
  },
  {
    "City": "Amsterdam",
    "Month": "February",
    "MinT": 1,
    "MaxT": 7,
    "Precipitation": 50
  },
  {
    "City": "Amsterdam",
    "Month": "March",
    "MinT": 3,
    "MaxT": 10,
    "Precipitation": 50
  },
  {
    "City": "Amsterdam",
    "Month": "April",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Amsterdam",
    "Month": "May",
    "MinT": 9,
    "MaxT": 18,
    "Precipitation": 55
  },
  {
    "City": "Amsterdam",
    "Month": "June",
    "MinT": 11,
    "MaxT": 20,
    "Precipitation": 65
  },
  {
    "City": "Amsterdam",
    "Month": "July",
    "MinT": 13,
    "MaxT": 23,
    "Precipitation": 80
  },
  {
    "City": "Amsterdam",
    "Month": "August",
    "MinT": 13,
    "MaxT": 22,
    "Precipitation": 100
  },
  {
    "City": "Amsterdam",
    "Month": "September",
    "MinT": 11,
    "MaxT": 19,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "October",
    "MinT": 8,
    "MaxT": 15,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "November",
    "MinT": 4,
    "MaxT": 10,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "December",
    "MinT": 2,
    "MaxT": 7,
    "Precipitation": 80
  },
  {
    "City": "Paris",
    "Month": "January",
    "MinT": 2,
    "MaxT": 7,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "February",
    "MinT": 2,
    "MaxT": 8,
    "Precipitation": 40
  },
  {
    "City": "Paris",
    "Month": "March",
    "MinT": 5,
    "MaxT": 12,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "April",
    "MinT": 7,
    "MaxT": 16,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "May",
    "MinT": 10,
    "MaxT": 20,
    "Precipitation": 65
  },
  {
    "City": "Paris",
    "Month": "June",
    "MinT": 13,
    "MaxT": 23,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "July",
    "MinT": 15,
    "MaxT": 25,
    "Precipitation": 60
  },
  {
    "City": "Paris",
    "Month": "August",
    "MinT": 15,
    "MaxT": 25,
    "Precipitation": 55
  },
  {
    "City": "Paris",
    "Month": "September",
    "MinT": 12,
    "MaxT": 21,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "October",
    "MinT": 9,
    "MaxT": 16,
    "Precipitation": 60
  },
  {
    "City": "Paris",
    "Month": "November",
    "MinT": 5,
    "MaxT": 11,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "December",
    "MinT": 3,
    "MaxT": 8,
    "Precipitation": 60
  },
  {
    "City": "Barcelona",
    "Month": "January",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "February",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "March",
    "MinT": 7,
    "MaxT": 16,
    "Precipitation": 35
  },
  {
    "City": "Barcelona",
    "Month": "April",
    "MinT": 9,
    "MaxT": 18,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "May",
    "MinT": 13,
    "MaxT": 21,
    "Precipitation": 55
  },
  {
    "City": "Barcelona",
    "Month": "June",
    "MinT": 17,
    "MaxT": 25,
    "Precipitation": 30
  },
  {
    "City": "Barcelona",
    "Month": "July",
    "MinT": 20,
    "MaxT": 28,
    "Precipitation": 20
  },
  {
    "City": "Barcelona",
    "Month": "August",
    "MinT": 20,
    "MaxT": 29,
    "Precipitation": 65
  },
  {
    "City": "Barcelona",
    "Month": "September",
    "MinT": 17,
    "MaxT": 26,
    "Precipitation": 85
  },
  {
    "City": "Barcelona",
    "Month": "October",
    "MinT": 14,
    "MaxT": 22,
    "Precipitation": 100
  },
  {
    "City": "Barcelona",
    "Month": "November",
    "MinT": 9,
    "MaxT": 17,
    "Precipitation": 65
  },
  {
    "City": "Barcelona",
    "Month": "December",
    "MinT": 6,
    "MaxT": 14,
    "Precipitation": 40
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Climate'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Go to the Fields page to view the available fields. On the same page, add one calculated field:
    Name | Value
    AvgT | =([MinT] + [MaxT]) / 2
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Radar Bubble'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the Y and Size values from the drop-down (since we will be specifying Category group, we need to specify only Y value; the value of X will be ignored), set the corresponding captions, and click Next.
    Field | Caption
    [AvgT] | Y
    [Precipitation] | Size
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Month].
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Radar Bubble Chart

Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Filter

  1. Select 'Chart' on the Report Explorer and go to Filters property in the Properties Panel.
  2. In the Filters page, add a new filter and set its properties as below.
    Expression | Operator | Value
    =[City] | Equal | Barcelona
  3. Click OK to save the changes.

Y-Axis

  1. To open the smart panel for Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties:
    • Title: T °C
    • Font > Size: 12pt
    • Font > Color: Gray
    • Font > Weight: SemiBold
  3. Go to the Labels page > Appearance tab and set the following properties:
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Line page and set the following properties:
    • Show Line: Check-on
    • Color: #3c3c3c
    • Width: 0.5pt
    • Style: Solid
  5. Go to the Major Gridline page and set the Grid Interval to '5'.
  6. In the same page, set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the following properties:
    • Scale Type: Linear
    • Maximum scale value: 30
    • Minimum scale value: 0
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  5. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select Custom from the drop-down and add the following colors.
    • #f26324
  3. Click OK to complete setting up the custom palette.

Legend

  1. In the Legend Data, right-click Size and from the adorner, click Edit.
  2. Go to the Title page and set the following properties.
    • Title: Precipitation, mm
    • Size: 12pt
    • Color: #3da7a8
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: Gray
    • Background Fill Color > Icon Color: DimGray

    By default, charts like line (line and smooth), bubble, radar bubble, and radar line automatically calculate the size of the markers.
  4. To specify custom marker size in the chart, follow the below steps:
    1. Navigate to the Ranges page and add six ranges using the Add button.
    2. Define the upper bound of the ranges in the To field, as follows:
      Range | To
      Range1 | 35
      Range2 | 50
      Range3 | 65
      Range4 | 80
      Range5 | 95
      Range6 | 110

      You can also choose to display custom titles instead of the range values using the Title field in the legend.

  5. Click OK to complete setting up the chart legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Barcelona Climate'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Multi-Category Radar Scatter Chart

Create Multi-Category Radar Scatter Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Scatter and Radar Bubble Charts > Create Multi-Category Radar Scatter Chart

Glossary Item Box

This walkthrough creates a Multi-Category Radar Scatter Chart. The chart shows the average monthly temperature for three cities - Amsterdam, Paris, and Barcelona. The final chart appears like this:

Multi Category Radar Scatter Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "City": "Amsterdam",
    "Month": "January",
    "MinT": 1,
    "MaxT": 6,
    "Precipitation": 65
  },
  {
    "City": "Amsterdam",
    "Month": "February",
    "MinT": 1,
    "MaxT": 7,
    "Precipitation": 50
  },
  {
    "City": "Amsterdam",
    "Month": "March",
    "MinT": 3,
    "MaxT": 10,
    "Precipitation": 50
  },
  {
    "City": "Amsterdam",
    "Month": "April",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Amsterdam",
    "Month": "May",
    "MinT": 9,
    "MaxT": 18,
    "Precipitation": 55
  },
  {
    "City": "Amsterdam",
    "Month": "June",
    "MinT": 11,
    "MaxT": 20,
    "Precipitation": 65
  },
  {
    "City": "Amsterdam",
    "Month": "July",
    "MinT": 13,
    "MaxT": 23,
    "Precipitation": 80
  },
  {
    "City": "Amsterdam",
    "Month": "August",
    "MinT": 13,
    "MaxT": 22,
    "Precipitation": 100
  },
  {
    "City": "Amsterdam",
    "Month": "September",
    "MinT": 11,
    "MaxT": 19,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "October",
    "MinT": 8,
    "MaxT": 15,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "November",
    "MinT": 4,
    "MaxT": 10,
    "Precipitation": 85
  },
  {
    "City": "Amsterdam",
    "Month": "December",
    "MinT": 2,
    "MaxT": 7,
    "Precipitation": 80
  },
  {
    "City": "Paris",
    "Month": "January",
    "MinT": 2,
    "MaxT": 7,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "February",
    "MinT": 2,
    "MaxT": 8,
    "Precipitation": 40
  },
  {
    "City": "Paris",
    "Month": "March",
    "MinT": 5,
    "MaxT": 12,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "April",
    "MinT": 7,
    "MaxT": 16,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "May",
    "MinT": 10,
    "MaxT": 20,
    "Precipitation": 65
  },
  {
    "City": "Paris",
    "Month": "June",
    "MinT": 13,
    "MaxT": 23,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "July",
    "MinT": 15,
    "MaxT": 25,
    "Precipitation": 60
  },
  {
    "City": "Paris",
    "Month": "August",
    "MinT": 15,
    "MaxT": 25,
    "Precipitation": 55
  },
  {
    "City": "Paris",
    "Month": "September",
    "MinT": 12,
    "MaxT": 21,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "October",
    "MinT": 9,
    "MaxT": 16,
    "Precipitation": 60
  },
  {
    "City": "Paris",
    "Month": "November",
    "MinT": 5,
    "MaxT": 11,
    "Precipitation": 50
  },
  {
    "City": "Paris",
    "Month": "December",
    "MinT": 3,
    "MaxT": 8,
    "Precipitation": 60
  },
  {
    "City": "Barcelona",
    "Month": "January",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "February",
    "MinT": 5,
    "MaxT": 14,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "March",
    "MinT": 7,
    "MaxT": 16,
    "Precipitation": 35
  },
  {
    "City": "Barcelona",
    "Month": "April",
    "MinT": 9,
    "MaxT": 18,
    "Precipitation": 40
  },
  {
    "City": "Barcelona",
    "Month": "May",
    "MinT": 13,
    "MaxT": 21,
    "Precipitation": 55
  },
  {
    "City": "Barcelona",
    "Month": "June",
    "MinT": 17,
    "MaxT": 25,
    "Precipitation": 30
  },
  {
    "City": "Barcelona",
    "Month": "July",
    "MinT": 20,
    "MaxT": 28,
    "Precipitation": 20
  },
  {
    "City": "Barcelona",
    "Month": "August",
    "MinT": 20,
    "MaxT": 29,
    "Precipitation": 65
  },
  {
    "City": "Barcelona",
    "Month": "September",
    "MinT": 17,
    "MaxT": 26,
    "Precipitation": 85
  },
  {
    "City": "Barcelona",
    "Month": "October",
    "MinT": 14,
    "MaxT": 22,
    "Precipitation": 100
  },
  {
    "City": "Barcelona",
    "Month": "November",
    "MinT": 9,
    "MaxT": 17,
    "Precipitation": 65
  },
  {
    "City": "Barcelona",
    "Month": "December",
    "MinT": 6,
    "MaxT": 14,
    "Precipitation": 40
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Climate'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Go to the Fields page to view the available fields. On the same page, add one calculated field:
    Name | Value
    AvgT | =([MinT] + [MaxT]) / 2
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Radar Scatter'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the Y value from the drop-down (since we will be specifying Category group, we need to specify only Y value; the value of X will be ignored) as shown and click Next.
    Field | Caption
    AvgT | Y
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Month].
  6. Set Series > Group By to [City].
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Radar Scatter Chart

Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties:
    • Title: °C
    • Font > Size: 12pt
    • Font > Color: Gray
    • Font > Weight: SemiBold
  3. Go to the Labels page > Appearance tab and set the following properties:
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Line page and set the following properties:
    • Show Line: Check-on
    • Color: #3c3c3c
    • Width: 0.5pt
    • Style: Solid
  5. Go to the Major Gridline page and set the Grid Interval to '5'.
  6. In the same page, set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the following properties:
    • Scale Type: Linear
    • Maximum scale value: 30
    • Minimum scale value: 0
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and set the following properties:
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  5. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select Custom from the drop-down and add the following colors.
    • #f26324
    • #1fd537
    • #e40010
  3. Click OK to complete setting up the custom palette.

Legend

  1. In the Legend Data area, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Go to the Appearance page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: Gray
  5. Click OK to complete setting up the Legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Average Monthly Temperature'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Radar Line Chart

Radar Line Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Line Chart

Glossary Item Box

Radar Line Charts are plot types useful to depict ordered measurements of single or multiple variables across different category ranges. A radar line chart arranges categories radially and connects corresponding points with straight lines. The data values are represented by Symbols or shapes laid out across radial lines and connected via straight or curved lines.

Radar Line Chart with Multiple Values

A radar line chart can be used to depict measurements of one or multiple variables across various category ranges. For example, the Radar Line Plot with Multiple Values can be used to display two types of average ratings for many movie genres.

Radar Line Chart with Multiple Values
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Radar Line Chart with Multiple Lines

A multiple-line radar chart lets you split data values into subcategories for finer analysis. For instance, the Radar Line with Multiple Lines chart can be used to depict average movie ratings in different countries for several movie genres. See Radar Line Chart with Multiple Lines walkthrough to learn how to create this chart.

Radar Line Chart with Multiple Lines
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Radar Line Chart with Multiple Lines

Create Radar Line Chart with Multiple Lines
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Line Chart > Create Radar Line Chart with Multiple Lines

Glossary Item Box

This walkthrough creates a Radar Line Chart with Multiple Lines. The chart shows the average movie ratings by certain genres in different countries. Such a chart helps you to analyze the multivariate data for deeper insights. The final chart appears like this:

Radar Line with Multiple Lines Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 87,
    "AudienceRating": 81,
    "Budget": 8,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 9,
    "AudienceRating": 44,
    "Budget": 105,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 30,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 18,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 55,
    "AudienceRating": 70,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 63,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 71,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 50,
    "AudienceRating": 57,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 48,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 93,
    "AudienceRating": 93,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 5,
    "AudienceRating": 51,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 79,
    "AudienceRating": 89,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 13,
    "AudienceRating": 40,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 89,
    "AudienceRating": 64,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 71,
    "Budget": 19,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 4,
    "AudienceRating": 46,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 54,
    "AudienceRating": 84,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 89,
    "AudienceRating": 56,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 53,
    "AudienceRating": 43,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 52,
    "AudienceRating": 72,
    "Budget": 200,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 14,
    "AudienceRating": 37,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 30,
    "AudienceRating": 46,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 6,
    "AudienceRating": 35,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 64,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 21,
    "AudienceRating": 35,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 94,
    "AudienceRating": 78,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 66,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 23,
    "AudienceRating": 31,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 55,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 34,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 55,
    "AudienceRating": 69,
    "Budget": 78,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 83,
    "AudienceRating": 92,
    "Budget": 237,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 67,
    "AudienceRating": 74,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 63,
    "AudienceRating": 59,
    "Budget": 70,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 7,
    "AudienceRating": 32,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 44,
    "AudienceRating": 38,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 79,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 9,
    "AudienceRating": 33,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 35,
    "AudienceRating": 50,
    "Budget": 70,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 65,
    "AudienceRating": 57,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 19,
    "AudienceRating": 50,
    "Budget": 17,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 25,
    "AudienceRating": 63,
    "Budget": 80,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 84,
    "AudienceRating": 80,
    "Budget": 4,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 52,
    "Budget": 150,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 41,
    "AudienceRating": 56,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 88,
    "AudienceRating": 86,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 69,
    "AudienceRating": 66,
    "Budget": 61,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 65,
    "Budget": 68,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 11,
    "AudienceRating": 56,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 90,
    "AudienceRating": 77,
    "Budget": 33,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 47,
    "Budget": 17,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 61,
    "AudienceRating": 62,
    "Budget": 26,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 48,
    "Budget": 42,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 86,
    "AudienceRating": 63,
    "Budget": 2,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 36,
    "AudienceRating": 66,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 64,
    "Budget": 37,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 75,
    "Budget": 140,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 23,
    "AudienceRating": 42,
    "Budget": 26,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 13,
    "AudienceRating": 43,
    "Budget": 85,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 86,
    "AudienceRating": 61,
    "Budget": 10,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 62,
    "AudienceRating": 84,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 50,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 81,
    "AudienceRating": 77,
    "Budget": 6,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 52,
    "AudienceRating": 48,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 48,
    "Budget": 125,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 67,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 13,
    "AudienceRating": 56,
    "Budget": 140,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 55,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 34,
    "Budget": 90,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 84,
    "AudienceRating": 63,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 19,
    "AudienceRating": 45,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 20,
    "AudienceRating": 56,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 12,
    "AudienceRating": 47,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 44,
    "AudienceRating": 50,
    "Budget": 163,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 62,
    "AudienceRating": 54,
    "Budget": 13,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 78,
    "AudienceRating": 81,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 80,
    "AudienceRating": 51,
    "Budget": 7,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 1,
    "AudienceRating": 63,
    "Budget": 6,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 17,
    "AudienceRating": 35,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 66,
    "AudienceRating": 58,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 29,
    "AudienceRating": 66,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 48,
    "Budget": 21,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 69,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 71,
    "AudienceRating": 72,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 52,
    "AudienceRating": 45,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 49,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 47,
    "AudienceRating": 63,
    "Budget": 21,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 12,
    "AudienceRating": 31,
    "Budget": 58,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 47,
    "Budget": 69,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 28,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 91,
    "AudienceRating": 81,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 67,
    "AudienceRating": 75,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 84,
    "AudienceRating": 81,
    "Budget": 37,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 59,
    "AudienceRating": 37,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 48,
    "AudienceRating": 47,
    "Budget": 33,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 78,
    "AudienceRating": 75,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 92,
    "AudienceRating": 61,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 44,
    "Budget": 75,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 15,
    "AudienceRating": 28,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 7,
    "AudienceRating": 38,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 93,
    "AudienceRating": 79,
    "Budget": 15,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 45,
    "AudienceRating": 38,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 56,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 64,
    "AudienceRating": 38,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 6,
    "AudienceRating": 28,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 72,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 75,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 36,
    "AudienceRating": 46,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 93,
    "AudienceRating": 80,
    "Budget": 85,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 38,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 23,
    "AudienceRating": 56,
    "Budget": 175,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 55,
    "Budget": 21,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 74,
    "AudienceRating": 53,
    "Budget": 5,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 62,
    "AudienceRating": 37,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 55,
    "Budget": 31,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 47,
    "AudienceRating": 62,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 25,
    "AudienceRating": 43,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 35,
    "AudienceRating": 55,
    "Budget": 130,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 76,
    "Budget": 85,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 83,
    "Budget": 125,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 41,
    "AudienceRating": 50,
    "Budget": 24,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 61,
    "AudienceRating": 56,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 40,
    "AudienceRating": 51,
    "Budget": 1,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 59,
    "Budget": 13,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 11,
    "AudienceRating": 53,
    "Budget": 73,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 71,
    "AudienceRating": 71,
    "Budget": 24,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 73,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 75,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 52,
    "Budget": 80,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 25,
    "AudienceRating": 52,
    "Budget": 19,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 71,
    "AudienceRating": 68,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 75,
    "AudienceRating": 68,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 57,
    "Budget": 52,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 58,
    "Budget": 75,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 8,
    "AudienceRating": 36,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 50,
    "Budget": 150,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 62,
    "Budget": 175,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 29,
    "AudienceRating": 43,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 73,
    "AudienceRating": 63,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 51,
    "AudienceRating": 73,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 56,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 27,
    "AudienceRating": 47,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 56,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 3,
    "AudienceRating": 61,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 80,
    "AudienceRating": 90,
    "Budget": 33,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 48,
    "Budget": 200,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 60,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 75,
    "AudienceRating": 40,
    "Budget": 0,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 82,
    "AudienceRating": 86,
    "Budget": 53,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 10,
    "AudienceRating": 59,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 31,
    "Budget": 112,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 58,
    "AudienceRating": 85,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 35,
    "AudienceRating": 44,
    "Budget": 36,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 26,
    "AudienceRating": 64,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 20,
    "AudienceRating": 45,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 67,
    "Budget": 150,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 67,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 44,
    "AudienceRating": 66,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 54,
    "AudienceRating": 65,
    "Budget": 12,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 125,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 83,
    "AudienceRating": 75,
    "Budget": 250,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 78,
    "AudienceRating": 82,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 42,
    "AudienceRating": 60,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 87,
    "AudienceRating": 70,
    "Budget": 83,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 54,
    "AudienceRating": 68,
    "Budget": 7,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 65,
    "AudienceRating": 76,
    "Budget": 11,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 15,
    "AudienceRating": 61,
    "Budget": 18,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 69,
    "AudienceRating": 72,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 44,
    "AudienceRating": 45,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 64,
    "AudienceRating": 57,
    "Budget": 36,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 46,
    "AudienceRating": 57,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 150,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 69,
    "AudienceRating": 69,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 32,
    "AudienceRating": 57,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 38,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 71,
    "AudienceRating": 57,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 83,
    "AudienceRating": 72,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 73,
    "Budget": 85,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 38,
    "Budget": 0,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 44,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 59,
    "Budget": 75,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 72,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 38,
    "AudienceRating": 55,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 86,
    "AudienceRating": 93,
    "Budget": 160,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 59,
    "Budget": 185,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 88,
    "AudienceRating": 87,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 39,
    "AudienceRating": 51,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 67,
    "AudienceRating": 65,
    "Budget": 2,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 82,
    "AudienceRating": 90,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 94,
    "AudienceRating": 91,
    "Budget": 186,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 74,
    "AudienceRating": 80,
    "Budget": 200,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 56,
    "AudienceRating": 63,
    "Budget": 85,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 42,
    "AudienceRating": 84,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 4,
    "AudienceRating": 59,
    "Budget": 79,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 85,
    "AudienceRating": 77,
    "Budget": 0,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 42,
    "AudienceRating": 37,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 55,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 13,
    "AudienceRating": 24,
    "Budget": 47,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 61,
    "AudienceRating": 55,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 50,
    "Budget": 83,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 94,
    "AudienceRating": 89,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 19,
    "AudienceRating": 63,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 45,
    "AudienceRating": 58,
    "Budget": 12,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 76,
    "AudienceRating": 83,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 25,
    "AudienceRating": 48,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 11,
    "AudienceRating": 45,
    "Budget": 75,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 78,
    "AudienceRating": 26,
    "Budget": 10,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 52,
    "Budget": 117,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 91,
    "AudienceRating": 83,
    "Budget": 33,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 50,
    "Budget": 50,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 26,
    "AudienceRating": 38,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 34,
    "AudienceRating": 46,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 49,
    "Budget": 19,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 41,
    "Budget": 58,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 19,
    "AudienceRating": 36,
    "Budget": 26,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 62,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 8,
    "AudienceRating": 55,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 28,
    "AudienceRating": 62,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 69,
    "AudienceRating": 73,
    "Budget": 27,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 48,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 40,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 79,
    "AudienceRating": 86,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 48,
    "AudienceRating": 55,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 18,
    "AudienceRating": 40,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 33,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 73,
    "AudienceRating": 66,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 29,
    "AudienceRating": 71,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 51,
    "Budget": 22,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 61,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 76,
    "Budget": 66,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 86,
    "AudienceRating": 73,
    "Budget": 4,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 63,
    "AudienceRating": 77,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 46,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 36,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 19,
    "AudienceRating": 42,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 31,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 90,
    "AudienceRating": 72,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 17,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 34,
    "AudienceRating": 68,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 14,
    "AudienceRating": 49,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 70,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 93,
    "AudienceRating": 86,
    "Budget": 145,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 95,
    "AudienceRating": 89,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 38,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 54,
    "AudienceRating": 54,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 79,
    "AudienceRating": 61,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 56,
    "AudienceRating": 75,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 47,
    "AudienceRating": 54,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 63,
    "AudienceRating": 70,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 51,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 43,
    "Budget": 17,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 47,
    "AudienceRating": 73,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 9,
    "AudienceRating": 29,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 83,
    "AudienceRating": 84,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 49,
    "AudienceRating": 61,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 77,
    "AudienceRating": 54,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 31,
    "AudienceRating": 72,
    "Budget": 130,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 23,
    "AudienceRating": 37,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 70,
    "AudienceRating": 70,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 8,
    "AudienceRating": 48,
    "Budget": 56,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 29,
    "AudienceRating": 59,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 21,
    "AudienceRating": 27,
    "Budget": 3,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 73,
    "AudienceRating": 67,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 43,
    "AudienceRating": 60,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 31,
    "AudienceRating": 56,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 51,
    "AudienceRating": 50,
    "Budget": 37,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 37,
    "AudienceRating": 40,
    "Budget": 80,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 25,
    "AudienceRating": 57,
    "Budget": 50,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 95,
    "AudienceRating": 84,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 64,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 49,
    "AudienceRating": 57,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 56,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 34,
    "AudienceRating": 66,
    "Budget": 5,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 51,
    "AudienceRating": 40,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 20,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 70,
    "AudienceRating": 74,
    "Budget": 85,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 5,
    "AudienceRating": 49,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 37,
    "AudienceRating": 54,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 0,
    "AudienceRating": 36,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 55,
    "AudienceRating": 65,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 49,
    "Budget": 0,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 79,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 47,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 21,
    "AudienceRating": 82,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 82,
    "AudienceRating": 56,
    "Budget": 1,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 0,
    "AudienceRating": 0,
    "Budget": 3,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 68,
    "AudienceRating": 58,
    "Budget": 5,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 11,
    "AudienceRating": 41,
    "Budget": 26,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 70,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 50,
    "Budget": 26,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 74,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 50,
    "AudienceRating": 57,
    "Budget": 95,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 68,
    "AudienceRating": 74,
    "Budget": 26,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 74,
    "AudienceRating": 45,
    "Budget": 24,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 60,
    "AudienceRating": 72,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 34,
    "AudienceRating": 61,
    "Budget": 250,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 45,
    "AudienceRating": 74,
    "Budget": 300,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 88,
    "AudienceRating": 62,
    "Budget": 3,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 7,
    "AudienceRating": 31,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 8,
    "AudienceRating": 55,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 17,
    "AudienceRating": 37,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 71,
    "Budget": 200,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 8,
    "AudienceRating": 46,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 47,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 47,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 62,
    "Budget": 230,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 59,
    "AudienceRating": 46,
    "Budget": 12,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 50,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 85,
    "AudienceRating": 61,
    "Budget": 12,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 70,
    "Budget": 48,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 81,
    "Budget": 110,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 72,
    "Budget": 58,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 11,
    "AudienceRating": 41,
    "Budget": 42,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 57,
    "AudienceRating": 59,
    "Budget": 4,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 28,
    "AudienceRating": 70,
    "Budget": 16,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 43,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 83,
    "AudienceRating": 87,
    "Budget": 93,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 59,
    "Budget": 200,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 77,
    "AudienceRating": 75,
    "Budget": 28,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 20,
    "AudienceRating": 68,
    "Budget": 140,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 62,
    "AudienceRating": 62,
    "Budget": 110,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 30,
    "AudienceRating": 39,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 18,
    "AudienceRating": 70,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 40,
    "AudienceRating": 67,
    "Budget": 11,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 81,
    "AudienceRating": 83,
    "Budget": 60,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 58,
    "AudienceRating": 57,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 10,
    "AudienceRating": 32,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 41,
    "Budget": 3,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 77,
    "Budget": 55,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 49,
    "AudienceRating": 81,
    "Budget": 58,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 49,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 46,
    "AudienceRating": 61,
    "Budget": 19,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 80,
    "AudienceRating": 80,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 16,
    "AudienceRating": 25,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 57,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 70,
    "AudienceRating": 81,
    "Budget": 90,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 60,
    "AudienceRating": 79,
    "Budget": 125,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 66,
    "Budget": 39,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 82,
    "Budget": 61,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 7,
    "AudienceRating": 40,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 68,
    "AudienceRating": 73,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 19,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 50,
    "AudienceRating": 41,
    "Budget": 7,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 81,
    "AudienceRating": 47,
    "Budget": 15,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 0,
    "AudienceRating": 0,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 22,
    "AudienceRating": 38,
    "Budget": 13,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 45,
    "AudienceRating": 42,
    "Budget": 0,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 79,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 92,
    "AudienceRating": 81,
    "Budget": 32,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 61,
    "Budget": 120,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 61,
    "AudienceRating": 54,
    "Budget": 258,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 40,
    "Budget": 27,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 94,
    "AudienceRating": 91,
    "Budget": 140,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 76,
    "AudienceRating": 86,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 54,
    "AudienceRating": 68,
    "Budget": 65,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 26,
    "AudienceRating": 81,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 67,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 49,
    "AudienceRating": 20,
    "Budget": 22,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 65,
    "AudienceRating": 27,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 28,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 37,
    "AudienceRating": 62,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 23,
    "AudienceRating": 48,
    "Budget": 82,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 59,
    "Budget": 5,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 82,
    "AudienceRating": 78,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 88,
    "AudienceRating": 87,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 36,
    "Budget": 65,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 42,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 36,
    "AudienceRating": 44,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 28,
    "AudienceRating": 46,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 92,
    "AudienceRating": 85,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 83,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 57,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 48,
    "AudienceRating": 48,
    "Budget": 29,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 64,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 71,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 72,
    "AudienceRating": 67,
    "Budget": 51,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 74,
    "AudienceRating": 78,
    "Budget": 130,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 97,
    "AudienceRating": 91,
    "Budget": 16,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 20,
    "AudienceRating": 47,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 78,
    "AudienceRating": 74,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 62,
    "AudienceRating": 57,
    "Budget": 21,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 62,
    "Budget": 41,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 48,
    "AudienceRating": 68,
    "Budget": 80,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 7,
    "AudienceRating": 41,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 93,
    "AudienceRating": 91,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 27,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 63,
    "AudienceRating": 84,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 43,
    "AudienceRating": 65,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 41,
    "AudienceRating": 81,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 52,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 66,
    "AudienceRating": 78,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 49,
    "AudienceRating": 63,
    "Budget": 155,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 66,
    "AudienceRating": 55,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 65,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 72,
    "AudienceRating": 54,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 67,
    "AudienceRating": 79,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 94,
    "AudienceRating": 96,
    "Budget": 185,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 19,
    "AudienceRating": 34,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 76,
    "AudienceRating": 70,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 89,
    "AudienceRating": 88,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 23,
    "AudienceRating": 31,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 60,
    "AudienceRating": 68,
    "Budget": 14,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 58,
    "Budget": 82,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 22,
    "AudienceRating": 51,
    "Budget": 12,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 91,
    "AudienceRating": 88,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 29,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 65,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 27,
    "AudienceRating": 75,
    "Budget": 22,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 87,
    "AudienceRating": 89,
    "Budget": 90,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 55,
    "Budget": 180,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 44,
    "AudienceRating": 47,
    "Budget": 120,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 35,
    "AudienceRating": 58,
    "Budget": 80,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 19,
    "AudienceRating": 29,
    "Budget": 48,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 17,
    "AudienceRating": 51,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 3,
    "AudienceRating": 22,
    "Budget": 5,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 30,
    "AudienceRating": 41,
    "Budget": 60,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 75,
    "AudienceRating": 91,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 11,
    "AudienceRating": 50,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 54,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 97,
    "AudienceRating": 83,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 85,
    "AudienceRating": 76,
    "Budget": 13,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 75,
    "Budget": 138,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 42,
    "Budget": 22,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 39,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 56,
    "AudienceRating": 47,
    "Budget": 19,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 53,
    "AudienceRating": 54,
    "Budget": 13,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 61,
    "AudienceRating": 47,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 66,
    "AudienceRating": 75,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 94,
    "AudienceRating": 72,
    "Budget": 4,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 52,
    "AudienceRating": 78,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 66,
    "AudienceRating": 85,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 6,
    "AudienceRating": 42,
    "Budget": 150,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 73,
    "AudienceRating": 32,
    "Budget": 2,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 19,
    "AudienceRating": 66,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 84,
    "AudienceRating": 82,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 39,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 55,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 38,
    "Budget": 62,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 32,
    "AudienceRating": 57,
    "Budget": 65,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 72,
    "AudienceRating": 64,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 14,
    "AudienceRating": 40,
    "Budget": 145,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 97,
    "AudienceRating": 87,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 33,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 41,
    "AudienceRating": 65,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 57,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 12,
    "AudienceRating": 47,
    "Budget": 59,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 74,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 9,
    "AudienceRating": 53,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 20,
    "AudienceRating": 43,
    "Budget": 37,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 75,
    "AudienceRating": 65,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 4,
    "AudienceRating": 29,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 46,
    "AudienceRating": 32,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 50,
    "AudienceRating": 48,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 78,
    "Budget": 11,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 90,
    "AudienceRating": 78,
    "Budget": 75,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 59,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 18,
    "AudienceRating": 61,
    "Budget": 15,
    "Country": "UK"
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Ratings'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Ratings) and the Plot Type as 'Radar Line'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add a value and do the following settings, and click Next.
    Field | Aggregate | Caption
    [RottenTomatoesRating] | Average | Rotten Tomatoes Rating
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Genre].
  6. Set Series > Group By to [Country].
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Radar Line with Multiple Lines
    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > Appearance tab and set the following properties:
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the Grid Interval to '10'.
  6. In the same page, set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and set the following properties:
    • Font > Size: 10pt
    • Font > Color: Gray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  6. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select Custom from the drop-down and add the following colors.
    • #8fcd37
    • #f26324
  3. Click OK to complete setting up the custom palette.

Legend

  2. In the Legend Data area, right-click Color and from the adorner, click Edit.
  3. Go to the General page and select SeriesGroups as Legend Mode.
  4. Go to the Appearance page and set the following properties.
    • Font > Size: 8pt
    • Font > Color: Gray
  5. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  6. Click OK to complete setting up the chart legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Movie Ratings by Genre and Country'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Radar Area Chart

Radar Area Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Area Chart

Glossary Item Box

The Radar area plot arranges categories on the circumference of a circle and connects the corresponding points with straight lines. The data values are plotted radially and are connected with straight lines resulting in a polygon shape. Radar Area plots are generally used to display ordinal variables across different category ranges.

Radar Area Plot with Single Value

A single value radar area chart shows measurements of one variable.

Radar Area Plot with Single Value
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Radar Area Plot with Multiple Values

A multiple values radar chart lets you split data values into subcategories for finer analysis. The Create Radar Area Chart with Multiple Values walkthrough showcases the average movie budget in a country for different movie genres.

Radar Area Plot with Multiple Values
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Radar Area Chart with Multiple Values

Create Radar Area Chart with Multiple Values
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Radar Area Chart > Create Radar Area Chart with Multiple Values

Glossary Item Box

This walkthrough creates a Radar Area Chart with Multiple Values. The chart shows the average budget for certain movie genres in different countries. The final chart appears like this:

Radar Area Chart with Multiple Values

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 87,
    "AudienceRating": 81,
    "Budget": 8,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 9,
    "AudienceRating": 44,
    "Budget": 105,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 30,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 18,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 55,
    "AudienceRating": 70,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 63,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 71,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 50,
    "AudienceRating": 57,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 48,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 93,
    "AudienceRating": 93,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 5,
    "AudienceRating": 51,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 79,
    "AudienceRating": 89,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 13,
    "AudienceRating": 40,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 89,
    "AudienceRating": 64,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 71,
    "Budget": 19,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 4,
    "AudienceRating": 46,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 54,
    "AudienceRating": 84,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 89,
    "AudienceRating": 56,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 53,
    "AudienceRating": 43,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 52,
    "AudienceRating": 72,
    "Budget": 200,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 14,
    "AudienceRating": 37,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 30,
    "AudienceRating": 46,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 6,
    "AudienceRating": 35,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 64,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 21,
    "AudienceRating": 35,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 94,
    "AudienceRating": 78,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 66,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 23,
    "AudienceRating": 31,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 55,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 34,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 55,
    "AudienceRating": 69,
    "Budget": 78,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 83,
    "AudienceRating": 92,
    "Budget": 237,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 67,
    "AudienceRating": 74,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 63,
    "AudienceRating": 59,
    "Budget": 70,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 7,
    "AudienceRating": 32,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 44,
    "AudienceRating": 38,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 79,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 9,
    "AudienceRating": 33,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 35,
    "AudienceRating": 50,
    "Budget": 70,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 65,
    "AudienceRating": 57,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 19,
    "AudienceRating": 50,
    "Budget": 17,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 25,
    "AudienceRating": 63,
    "Budget": 80,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 84,
    "AudienceRating": 80,
    "Budget": 4,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 52,
    "Budget": 150,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 41,
    "AudienceRating": 56,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 88,
    "AudienceRating": 86,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 69,
    "AudienceRating": 66,
    "Budget": 61,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 65,
    "Budget": 68,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 11,
    "AudienceRating": 56,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 90,
    "AudienceRating": 77,
    "Budget": 33,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 47,
    "Budget": 17,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 61,
    "AudienceRating": 62,
    "Budget": 26,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 48,
    "Budget": 42,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 86,
    "AudienceRating": 63,
    "Budget": 2,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 36,
    "AudienceRating": 66,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 64,
    "Budget": 37,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 75,
    "Budget": 140,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 23,
    "AudienceRating": 42,
    "Budget": 26,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 13,
    "AudienceRating": 43,
    "Budget": 85,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 86,
    "AudienceRating": 61,
    "Budget": 10,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 62,
    "AudienceRating": 84,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 50,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 81,
    "AudienceRating": 77,
    "Budget": 6,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 52,
    "AudienceRating": 48,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 48,
    "Budget": 125,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 67,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 13,
    "AudienceRating": 56,
    "Budget": 140,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 55,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 34,
    "Budget": 90,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 84,
    "AudienceRating": 63,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 19,
    "AudienceRating": 45,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 20,
    "AudienceRating": 56,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 12,
    "AudienceRating": 47,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 44,
    "AudienceRating": 50,
    "Budget": 163,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 62,
    "AudienceRating": 54,
    "Budget": 13,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 78,
    "AudienceRating": 81,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 80,
    "AudienceRating": 51,
    "Budget": 7,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 1,
    "AudienceRating": 63,
    "Budget": 6,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 17,
    "AudienceRating": 35,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 66,
    "AudienceRating": 58,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 29,
    "AudienceRating": 66,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 48,
    "Budget": 21,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 69,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 71,
    "AudienceRating": 72,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 52,
    "AudienceRating": 45,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 49,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 47,
    "AudienceRating": 63,
    "Budget": 21,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 12,
    "AudienceRating": 31,
    "Budget": 58,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 47,
    "Budget": 69,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 28,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 91,
    "AudienceRating": 81,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 67,
    "AudienceRating": 75,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 84,
    "AudienceRating": 81,
    "Budget": 37,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 59,
    "AudienceRating": 37,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 48,
    "AudienceRating": 47,
    "Budget": 33,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 78,
    "AudienceRating": 75,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 92,
    "AudienceRating": 61,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 44,
    "Budget": 75,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 15,
    "AudienceRating": 28,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 7,
    "AudienceRating": 38,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 93,
    "AudienceRating": 79,
    "Budget": 15,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 45,
    "AudienceRating": 38,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 56,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 64,
    "AudienceRating": 38,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 6,
    "AudienceRating": 28,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 72,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 75,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 36,
    "AudienceRating": 46,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 93,
    "AudienceRating": 80,
    "Budget": 85,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 38,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 23,
    "AudienceRating": 56,
    "Budget": 175,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 55,
    "Budget": 21,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 74,
    "AudienceRating": 53,
    "Budget": 5,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 62,
    "AudienceRating": 37,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 55,
    "Budget": 31,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 47,
    "AudienceRating": 62,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 25,
    "AudienceRating": 43,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 35,
    "AudienceRating": 55,
    "Budget": 130,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 76,
    "Budget": 85,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 83,
    "Budget": 125,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 41,
    "AudienceRating": 50,
    "Budget": 24,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 61,
    "AudienceRating": 56,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 40,
    "AudienceRating": 51,
    "Budget": 1,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 59,
    "Budget": 13,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 11,
    "AudienceRating": 53,
    "Budget": 73,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 71,
    "AudienceRating": 71,
    "Budget": 24,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 73,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 75,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 26,
    "AudienceRating": 52,
    "Budget": 80,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 25,
    "AudienceRating": 52,
    "Budget": 19,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 71,
    "AudienceRating": 68,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 75,
    "AudienceRating": 68,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 57,
    "Budget": 52,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 58,
    "Budget": 75,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 8,
    "AudienceRating": 36,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 50,
    "Budget": 150,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 62,
    "Budget": 175,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 29,
    "AudienceRating": 43,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 73,
    "AudienceRating": 63,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 51,
    "AudienceRating": 73,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 56,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 85,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 27,
    "AudienceRating": 47,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 56,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 3,
    "AudienceRating": 61,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 80,
    "AudienceRating": 90,
    "Budget": 33,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 48,
    "Budget": 200,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 60,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 75,
    "AudienceRating": 40,
    "Budget": 0,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 82,
    "AudienceRating": 86,
    "Budget": 53,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 10,
    "AudienceRating": 59,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 31,
    "Budget": 112,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 58,
    "AudienceRating": 85,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 35,
    "AudienceRating": 44,
    "Budget": 36,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 26,
    "AudienceRating": 64,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 20,
    "AudienceRating": 45,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 67,
    "Budget": 150,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 67,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 44,
    "AudienceRating": 66,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 54,
    "AudienceRating": 65,
    "Budget": 12,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 125,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 83,
    "AudienceRating": 75,
    "Budget": 250,
    "Country": "Germany"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 78,
    "AudienceRating": 82,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 42,
    "AudienceRating": 60,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 87,
    "AudienceRating": 70,
    "Budget": 83,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 54,
    "AudienceRating": 68,
    "Budget": 7,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 65,
    "AudienceRating": 76,
    "Budget": 11,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 15,
    "AudienceRating": 61,
    "Budget": 18,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 69,
    "AudienceRating": 72,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 44,
    "AudienceRating": 45,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 64,
    "AudienceRating": 57,
    "Budget": 36,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 46,
    "AudienceRating": 57,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 150,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 69,
    "AudienceRating": 69,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 32,
    "AudienceRating": 57,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 38,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 71,
    "AudienceRating": 57,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 83,
    "AudienceRating": 72,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 73,
    "Budget": 85,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 38,
    "Budget": 0,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 44,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 59,
    "Budget": 75,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 72,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 38,
    "AudienceRating": 55,
    "Budget": 40,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 86,
    "AudienceRating": 93,
    "Budget": 160,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 77,
    "AudienceRating": 59,
    "Budget": 185,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 88,
    "AudienceRating": 87,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 39,
    "AudienceRating": 51,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 67,
    "AudienceRating": 65,
    "Budget": 2,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 82,
    "AudienceRating": 90,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 94,
    "AudienceRating": 91,
    "Budget": 186,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 74,
    "AudienceRating": 80,
    "Budget": 200,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 56,
    "AudienceRating": 63,
    "Budget": 85,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 42,
    "AudienceRating": 84,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 4,
    "AudienceRating": 59,
    "Budget": 79,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 85,
    "AudienceRating": 77,
    "Budget": 0,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 42,
    "AudienceRating": 37,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 55,
    "Budget": 45,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 13,
    "AudienceRating": 24,
    "Budget": 47,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 61,
    "AudienceRating": 55,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 50,
    "Budget": 83,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 94,
    "AudienceRating": 89,
    "Budget": 8,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 19,
    "AudienceRating": 63,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 45,
    "AudienceRating": 58,
    "Budget": 12,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 76,
    "AudienceRating": 83,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 25,
    "AudienceRating": 48,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 11,
    "AudienceRating": 45,
    "Budget": 75,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 78,
    "AudienceRating": 26,
    "Budget": 10,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 52,
    "Budget": 117,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 91,
    "AudienceRating": 83,
    "Budget": 33,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 33,
    "AudienceRating": 50,
    "Budget": 50,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 26,
    "AudienceRating": 38,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 34,
    "AudienceRating": 46,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 49,
    "Budget": 19,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 41,
    "Budget": 58,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 19,
    "AudienceRating": 36,
    "Budget": 26,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 40,
    "AudienceRating": 62,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 8,
    "AudienceRating": 55,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 28,
    "AudienceRating": 62,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 69,
    "AudienceRating": 73,
    "Budget": 27,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 48,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 40,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 79,
    "AudienceRating": 86,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 48,
    "AudienceRating": 55,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 18,
    "AudienceRating": 40,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 33,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 73,
    "AudienceRating": 66,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 29,
    "AudienceRating": 71,
    "Budget": 30,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 51,
    "Budget": 22,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 13,
    "AudienceRating": 61,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 53,
    "AudienceRating": 76,
    "Budget": 66,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 86,
    "AudienceRating": 73,
    "Budget": 4,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 63,
    "AudienceRating": 77,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 46,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 36,
    "Budget": 35,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 19,
    "AudienceRating": 42,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 2,
    "AudienceRating": 31,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 90,
    "AudienceRating": 72,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 93,
    "AudienceRating": 84,
    "Budget": 17,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 34,
    "AudienceRating": 68,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 14,
    "AudienceRating": 49,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 70,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 93,
    "AudienceRating": 86,
    "Budget": 145,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 95,
    "AudienceRating": 89,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 38,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 54,
    "AudienceRating": 54,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 79,
    "AudienceRating": 61,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 56,
    "AudienceRating": 75,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 47,
    "AudienceRating": 54,
    "Budget": 55,
    "Country": "USA"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 63,
    "AudienceRating": 70,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 51,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 43,
    "Budget": 17,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 47,
    "AudienceRating": 73,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 9,
    "AudienceRating": 29,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 83,
    "AudienceRating": 84,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 49,
    "AudienceRating": 61,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 77,
    "AudienceRating": 54,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 31,
    "AudienceRating": 72,
    "Budget": 130,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 23,
    "AudienceRating": 37,
    "Budget": 21,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 70,
    "AudienceRating": 70,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 8,
    "AudienceRating": 48,
    "Budget": 56,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 29,
    "AudienceRating": 59,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 21,
    "AudienceRating": 27,
    "Budget": 3,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 73,
    "AudienceRating": 67,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 43,
    "AudienceRating": 60,
    "Budget": 150,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 31,
    "AudienceRating": 56,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 51,
    "AudienceRating": 50,
    "Budget": 37,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 37,
    "AudienceRating": 40,
    "Budget": 80,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 25,
    "AudienceRating": 57,
    "Budget": 50,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 95,
    "AudienceRating": 84,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 64,
    "Budget": 28,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 49,
    "AudienceRating": 57,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 9,
    "AudienceRating": 56,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 34,
    "AudienceRating": 66,
    "Budget": 5,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 51,
    "AudienceRating": 40,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 20,
    "AudienceRating": 50,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 70,
    "AudienceRating": 74,
    "Budget": 85,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 5,
    "AudienceRating": 49,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 37,
    "AudienceRating": 54,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 0,
    "AudienceRating": 36,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 55,
    "AudienceRating": 65,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 49,
    "Budget": 0,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 68,
    "AudienceRating": 79,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 47,
    "Budget": 10,
    "Country": "Germany"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 21,
    "AudienceRating": 82,
    "Budget": 30,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 28,
    "AudienceRating": 49,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 82,
    "AudienceRating": 56,
    "Budget": 1,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 0,
    "AudienceRating": 0,
    "Budget": 3,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 68,
    "AudienceRating": 58,
    "Budget": 5,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 11,
    "AudienceRating": 41,
    "Budget": 26,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 70,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 50,
    "Budget": 26,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 74,
    "Budget": 15,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 50,
    "AudienceRating": 57,
    "Budget": 95,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 68,
    "AudienceRating": 74,
    "Budget": 26,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 74,
    "AudienceRating": 45,
    "Budget": 24,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 60,
    "AudienceRating": 72,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 34,
    "AudienceRating": 61,
    "Budget": 250,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 45,
    "AudienceRating": 74,
    "Budget": 300,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 88,
    "AudienceRating": 62,
    "Budget": 3,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 7,
    "AudienceRating": 31,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 8,
    "AudienceRating": 55,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 17,
    "AudienceRating": 37,
    "Budget": 60,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 71,
    "Budget": 200,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 8,
    "AudienceRating": 46,
    "Budget": 18,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 47,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 47,
    "Budget": 38,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 62,
    "Budget": 230,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 59,
    "AudienceRating": 46,
    "Budget": 12,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 50,
    "Budget": 50,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 85,
    "AudienceRating": 61,
    "Budget": 12,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 36,
    "AudienceRating": 70,
    "Budget": 48,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 81,
    "Budget": 110,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 71,
    "AudienceRating": 72,
    "Budget": 58,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 11,
    "AudienceRating": 41,
    "Budget": 42,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 57,
    "AudienceRating": 59,
    "Budget": 4,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 28,
    "AudienceRating": 70,
    "Budget": 16,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 43,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 60,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 83,
    "AudienceRating": 87,
    "Budget": 93,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 59,
    "Budget": 200,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 77,
    "AudienceRating": 75,
    "Budget": 28,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 20,
    "AudienceRating": 68,
    "Budget": 140,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 62,
    "AudienceRating": 62,
    "Budget": 110,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 30,
    "AudienceRating": 39,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 18,
    "AudienceRating": 70,
    "Budget": 10,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 40,
    "AudienceRating": 67,
    "Budget": 11,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 81,
    "AudienceRating": 83,
    "Budget": 60,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 58,
    "AudienceRating": 57,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 10,
    "AudienceRating": 32,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 21,
    "AudienceRating": 41,
    "Budget": 3,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 27,
    "AudienceRating": 77,
    "Budget": 55,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 49,
    "AudienceRating": 81,
    "Budget": 58,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 49,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 46,
    "AudienceRating": 61,
    "Budget": 19,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 80,
    "AudienceRating": 80,
    "Budget": 7,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 16,
    "AudienceRating": 25,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 57,
    "AudienceRating": 60,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 70,
    "AudienceRating": 81,
    "Budget": 90,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 60,
    "AudienceRating": 79,
    "Budget": 125,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 66,
    "Budget": 39,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 82,
    "Budget": 61,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 7,
    "AudienceRating": 40,
    "Budget": 8,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 68,
    "AudienceRating": 73,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 19,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 50,
    "AudienceRating": 41,
    "Budget": 7,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 81,
    "AudienceRating": 47,
    "Budget": 15,
    "Country": "South Korea"
  },
  {
    "Genre": "Romance",
    "RottenTomatoesRating": 0,
    "AudienceRating": 0,
    "Budget": 35,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 22,
    "AudienceRating": 38,
    "Budget": 13,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 45,
    "AudienceRating": 42,
    "Budget": 0,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 79,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 92,
    "AudienceRating": 81,
    "Budget": 32,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 38,
    "AudienceRating": 61,
    "Budget": 120,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 61,
    "AudienceRating": 54,
    "Budget": 258,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 22,
    "AudienceRating": 40,
    "Budget": 27,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 94,
    "AudienceRating": 91,
    "Budget": 140,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 76,
    "AudienceRating": 86,
    "Budget": 70,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 54,
    "AudienceRating": 68,
    "Budget": 65,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 26,
    "AudienceRating": 81,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 67,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 49,
    "AudienceRating": 20,
    "Budget": 22,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 65,
    "AudienceRating": 27,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 16,
    "AudienceRating": 28,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 37,
    "AudienceRating": 62,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 23,
    "AudienceRating": 48,
    "Budget": 82,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 72,
    "AudienceRating": 59,
    "Budget": 5,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 82,
    "AudienceRating": 78,
    "Budget": 50,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 88,
    "AudienceRating": 87,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 15,
    "AudienceRating": 36,
    "Budget": 65,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 42,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 36,
    "AudienceRating": 44,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 28,
    "AudienceRating": 46,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 92,
    "AudienceRating": 85,
    "Budget": 5,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 83,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 27,
    "AudienceRating": 57,
    "Budget": 32,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 48,
    "AudienceRating": 48,
    "Budget": 29,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 33,
    "AudienceRating": 64,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 71,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 72,
    "AudienceRating": 67,
    "Budget": 51,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 74,
    "AudienceRating": 78,
    "Budget": 130,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 97,
    "AudienceRating": 91,
    "Budget": 16,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 20,
    "AudienceRating": 47,
    "Budget": 35,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 78,
    "AudienceRating": 74,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 62,
    "AudienceRating": 57,
    "Budget": 21,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 38,
    "AudienceRating": 62,
    "Budget": 41,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 48,
    "AudienceRating": 68,
    "Budget": 80,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 7,
    "AudienceRating": 41,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 93,
    "AudienceRating": 91,
    "Budget": 110,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 46,
    "AudienceRating": 27,
    "Budget": 30,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 63,
    "AudienceRating": 84,
    "Budget": 13,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 43,
    "AudienceRating": 65,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 41,
    "AudienceRating": 81,
    "Budget": 45,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 24,
    "AudienceRating": 53,
    "Budget": 52,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 66,
    "AudienceRating": 78,
    "Budget": 200,
    "Country": "South Korea"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 49,
    "AudienceRating": 63,
    "Budget": 155,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 66,
    "AudienceRating": 55,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 65,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 72,
    "AudienceRating": 54,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 67,
    "AudienceRating": 79,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 94,
    "AudienceRating": 96,
    "Budget": 185,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 19,
    "AudienceRating": 34,
    "Budget": 100,
    "Country": "South Korea"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 76,
    "AudienceRating": 70,
    "Budget": 20,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 89,
    "AudienceRating": 88,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 23,
    "AudienceRating": 31,
    "Budget": 70,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 60,
    "AudienceRating": 68,
    "Budget": 14,
    "Country": "South Korea"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 39,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 40,
    "AudienceRating": 58,
    "Budget": 82,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 22,
    "AudienceRating": 51,
    "Budget": 12,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 91,
    "AudienceRating": 88,
    "Budget": 25,
    "Country": "South Korea"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 29,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 64,
    "AudienceRating": 65,
    "Budget": 55,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 27,
    "AudienceRating": 75,
    "Budget": 22,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 87,
    "AudienceRating": 89,
    "Budget": 90,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 42,
    "AudienceRating": 55,
    "Budget": 180,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 44,
    "AudienceRating": 47,
    "Budget": 120,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 79,
    "AudienceRating": 87,
    "Budget": 35,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 35,
    "AudienceRating": 58,
    "Budget": 80,
    "Country": "UK"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 19,
    "AudienceRating": 29,
    "Budget": 48,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 17,
    "AudienceRating": 51,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 3,
    "AudienceRating": 22,
    "Budget": 5,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 30,
    "AudienceRating": 41,
    "Budget": 60,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 75,
    "AudienceRating": 91,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 11,
    "AudienceRating": 50,
    "Budget": 15,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 54,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 97,
    "AudienceRating": 83,
    "Budget": 15,
    "Country": "USA"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 85,
    "AudienceRating": 76,
    "Budget": 13,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 67,
    "AudienceRating": 75,
    "Budget": 138,
    "Country": "UK"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 78,
    "AudienceRating": 42,
    "Budget": 22,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 58,
    "AudienceRating": 39,
    "Budget": 50,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 56,
    "AudienceRating": 47,
    "Budget": 19,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 53,
    "AudienceRating": 54,
    "Budget": 13,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 61,
    "AudienceRating": 47,
    "Budget": 10,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 66,
    "AudienceRating": 75,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 94,
    "AudienceRating": 72,
    "Budget": 4,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 52,
    "AudienceRating": 78,
    "Budget": 80,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 66,
    "AudienceRating": 85,
    "Budget": 20,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 6,
    "AudienceRating": 42,
    "Budget": 150,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 73,
    "AudienceRating": 32,
    "Budget": 2,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 19,
    "AudienceRating": 66,
    "Budget": 20,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 84,
    "AudienceRating": 82,
    "Budget": 40,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 39,
    "AudienceRating": 39,
    "Budget": 30,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 47,
    "AudienceRating": 55,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 14,
    "AudienceRating": 38,
    "Budget": 62,
    "Country": "UK"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 32,
    "AudienceRating": 57,
    "Budget": 65,
    "Country": "UK"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 53,
    "AudienceRating": 52,
    "Budget": 40,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 52,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 72,
    "AudienceRating": 64,
    "Budget": 18,
    "Country": "USA"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 14,
    "AudienceRating": 40,
    "Budget": 145,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 97,
    "AudienceRating": 87,
    "Budget": 45,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 33,
    "AudienceRating": 52,
    "Budget": 20,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 41,
    "AudienceRating": 65,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Action",
    "RottenTomatoesRating": 78,
    "AudienceRating": 57,
    "Budget": 100,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 12,
    "AudienceRating": 47,
    "Budget": 59,
    "Country": "Germany"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 43,
    "AudienceRating": 74,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 9,
    "AudienceRating": 53,
    "Budget": 40,
    "Country": "Germany"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 20,
    "AudienceRating": 43,
    "Budget": 37,
    "Country": "UK"
  },
  {
    "Genre": "Adventure",
    "RottenTomatoesRating": 75,
    "AudienceRating": 65,
    "Budget": 25,
    "Country": "UK"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 4,
    "AudienceRating": 29,
    "Budget": 16,
    "Country": "USA"
  },
  {
    "Genre": "Horror",
    "RottenTomatoesRating": 46,
    "AudienceRating": 32,
    "Budget": 25,
    "Country": "Germany"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 50,
    "AudienceRating": 48,
    "Budget": 45,
    "Country": "South Korea"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 78,
    "Budget": 11,
    "Country": "South Korea"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 90,
    "AudienceRating": 78,
    "Budget": 75,
    "Country": "USA"
  },
  {
    "Genre": "Comedy",
    "RottenTomatoesRating": 22,
    "AudienceRating": 43,
    "Budget": 25,
    "Country": "USA"
  },
  {
    "Genre": "Drama",
    "RottenTomatoesRating": 56,
    "AudienceRating": 59,
    "Budget": 60,
    "Country": "Germany"
  },
  {
    "Genre": "Thriller",
    "RottenTomatoesRating": 18,
    "AudienceRating": 61,
    "Budget": 15,
    "Country": "UK"
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Ratings'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Go to the Filters page, add a new filter value, and set its properties as below.
    Expression Operator Values
    [Country] In ="UK"
    ="USA"
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Ratings) and the Plot Type as 'Radar Area'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add a value and do the following settings, and then click Next.
    Field | Aggregate | Caption
    [Budget] | Average | Budget
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Genre].
  6. Set Series > Group By to [Country].
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Radar Area Chart
    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Filter

  1. Select 'Chart' on the Report Explorer and go to Filters property in the Properties Panel.
  2. On the Filters page, add a new filter and set its properties as below.
    Expression Operator Values
    =[Country] In ="UK"
    ="USA"
  3. Click OK to save the changes.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the Format to '$'0'M'.
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the Grid Interval to '20'.
  7. In the same page, set the following properties under Grid appearance.
    • Show Grid: Check on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  6. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select 'Blue2' from the drop-down.
  3. Click OK to complete setting up the chart palette.

Legend

  1. In the Legend Data area, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Click OK to complete setting up the chart legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Movie Budget by Genre and Country'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Spiral Chart

Spiral Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Spiral Chart

Glossary Item Box

The Spiral plot originates at the center of a circle and then progresses outward, arranging the categories across a radial line and encoding the data values into circular bars along the spiral path. The Spiral plot is suitable for comparing data values across categories using a spiral shape. The categories can be further split to represent data values as clusters or stacks. Spiral Plots are highly useful in showing large data sets, usually in displaying trends over an extended period. This makes Spiral Plots a good option for displaying periodic patterns.

Simple Spiral Chart

The simplest type of a spiral chart is quite similar to a bar chart showcased on a polar coordinate system. The Create Stacked Spiral Chart walkthrough showcases plotting the Sales Amount per Product Category.

Simple Spiral Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Spiral Chart

A Stacked Spiral chart breaks down values of data into subcategories by placing corresponding circular subsections next to each other within the containing category. The Create Stacked Spiral Chart walkthrough showcases plotting the Sales Amount for each Sales Channel per Product Category.

Stacked Spiral Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Percentage Spiral Chart

A Stacked Percentage Spiral chart combines the stacked spiral plot and the Percentage axis scale. The chart indicates the contribution of each data values' sub-category to a containing category's total. The Create Stacked Percentage Spiral Chart walkthrough showcases plotting the share of Sales Channels' Sales Amount per Product Category.

Stacked Spiral Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Simple Spiral Chart

Create Simple Spiral Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Spiral Chart > Create Simple Spiral Chart

Glossary Item Box

This walkthrough creates a Simple Spiral Chart. The chart shows the total sales for different product categories. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add a calculated field:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Spiral'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Series > Group By to [Product Category]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Cluster'.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Spiral Chart at Preview Time

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Series Groups

  1. In the Series Groups area, right-click the [Product Category] and from the adorner, click Edit.
  2. In the Chart Data - Series Groups dialog, go to Sorting tab and add the following expression to sort the product category based on this expression:
    =Sum([SalesAmount])
  3. Set the Direction as 'Ascending'.
  4. Click OK to complete setting up the category groups.

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set StartAngle property to '90'.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal places)'.
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Appearance > Color: #cccccc
    • Appearance > Width: 2pt
    • Appearance > Style: Solid
  6. Go to the Major Gridline page and set the Grid Interval to '100000'.
  7. In the Major Gridline page, set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and uncheck the Show Labels option to hide the data labels.
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set Grid Interval to '1'.
  6. In the Major Gridline page, set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Solid
  7. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  4. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  5. Click OK to complete setting up the chart legend.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Spiral Chart

Create Stacked Spiral Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Spiral Chart > Create Stacked Spiral Chart

Glossary Item Box

This walkthrough creates a Stacked Spiral Chart. The chart shows the sales by product categories for each sales channel. In a stacked spiral chart, the data values are broken down into subcategories and are stacked next to each other. The final chart appears like this:

Stacked Spiral Chart Final

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add two calculated fields:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Spiral'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Product Category].
  6. Set the Series > Group By to [Sales Channel]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Stack'.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Stacked Spiral Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Category Groups

  1. In the Category Groups area, right-click the [Product Category] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, go to Sorting tab and add the following expression to sort the product category based on this expression:
    =Sum([SalesAmount])
  3. Set the Direction as 'Ascending'.
  4. Click OK to complete setting up the category groups.

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set the StartAngle property to '90' to set the start angle of the plot.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to remove the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal places)'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Appearance > Color: #cccccc
    • Appearance > Width: 2pt
    • Appearance > Style: Solid
  6. Go to the Major Gridline page and set the Grid Interval to '100000'.
  7. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > General tab and set the Angle to '-90'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the Grid Interval to '1'.
  7. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Solid
  8. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Click OK to complete setting up the chart.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Percentage Spiral Chart

Create Stacked Percentage Spiral Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Spiral Chart > Create Stacked Percentage Spiral Chart

Glossary Item Box

This walkthrough creates a Stacked Percentage Spiral Chart. The chart shows the sales by product categories for each sales channel. The stacked percentage spiral chart is used to display the percentage values that each subcategory contributes within a category. The final chart appears like this:

Stacked Percentage Spiral Chart Final

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add two calculated fields:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Spiral'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Product Category].
  6. Set the Series > Group By to [Sales Channel]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Stack'.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Stacked Spiral Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Category Groups

  1. In the Category Groups area, right-click the [Product Category] and from the adorner, click Edit.
  2. In the Chart Data - Category Groups dialog, go to Sorting tab and add the following expression to sort the product category based on this expression:
    =Sum([SalesAmount])
  3. Set the Direction as 'Ascending'.
  4. Click OK to complete setting up the category groups.

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set the StartAngle property to '90' to set the start angle of the plot.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to remove the Y-axis title in the chart.
  3. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  4. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Appearance > Color: #cccccc
    • Appearance > Width: 2pt
    • Appearance > Style: Solid
  5. Go to the Major Gridline page and set the Grid Interval to '100000'.
  6. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the Scale Type to 'Percentage'.
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > General tab and set the Angle to '-90'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the Grid Interval to '1'.
  7. Set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Solid
  8. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  4. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Click OK to complete setting up the chart.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Polar Chart

Polar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Polar Chart

Glossary Item Box

The Polar plot arranges categories along the circumference of a circle and encodes data values into sectors along radial lines. The Polar plot is suitable for comparing data values across categories using a circular shape. The categories can be further split to represent data values as clusters or stacks.

There are different types of Polar charts, which are elaborated below:

Simple Polar Chart

A Simple Polar chart displays one value for each category. See Create Simple Polar Chart walkthrough showcases plotting the Sales Amount per Product Category.

Simple Polar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Clustered Polar Chart

A Clustered Polar chart splits the values into subcategories by placing corresponding circular sectors adjacent to each other within the containing category. The Create Clustered Polar Chart walkthrough showcases plotting the Sales Amount for each Sales Channel per Product Category.

Clustered Polar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Polar Chart

A Stacked Polar chart is a good option to split the data values into subcategories by dividing corresponding circular sectors into subsections. The Create Stacked Polar Chart walkthrough showcases plotting the Sales Amount for each Product Category per Sales Channel.

Clustered Polar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stacked Percentage Polar Chart

A Stacked Percentage Polar chart combines the stacked polar plot and the Percentage axis scale. This chart type indicates the contribution of each data values' sub-category to a total of the containing category. The Create Stacked Percentage Polar Chart walkthrough showcases plotting the percentage share of the Sales Amount of product categories for each Sales Channel.

Percentage Stacked Polar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Simple Polar Chart

Create Simple Polar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Polar Chart > Create Simple Polar Chart

Glossary Item Box

This walkthrough creates a Simple Polar Chart. The chart shows the total sales for different product categories. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add a calculated field:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Polar'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding aggregate and caption, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set Categories > Group By to [Product Category]. Keep the remaining settings as it is.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Polar Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set StartAngle property to '90'.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Currency (with 0 decimal places)
    • Angle: -90
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the following properties.
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
  7. Go to the Scale page and set the following properties.
    • Scale Type: Logarithmic
    • Logarithmic base: 10
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and check-on the Show Labels option.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  7. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and set Legend Series Data Field to =[Product Category].
  3. Keep the Legend Mode as 'None'.
  4. Go to the Layout page and select the Hide Legend option.
    We can hide the legend since the chart can be easily visualized with colors and corresponding X-axis labels for each product category.
  5. Click OK to save the settings.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Clustered Polar Chart

Create Clustered Polar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Polar Chart > Create Clustered Polar Chart

Glossary Item Box

This walkthrough creates a Clustered Polar Chart. The chart displays the sales amount by product categories for each sales channel. In a clustered polar chart, the data values are broken down into subcategories and are placed next to each other. The final chart appears like this:

Clustered Polar Chart Final

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add two calculated fields:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Polar'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Product Category]. Keep the remaining settings as it is. Ensure that Series > Layout Type is 'Cluster'.
  6. Set the Series > Group By to [Sales Channel]
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Cluster Polar Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set StartAngle property to '90'.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Currency (with 0 decimal places)
    • Angle: -90
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set Grid Interval to '100000'.
  7. In the same page, set the following properties under Grid appearance:
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  8. Go to the Scale page and set the following properties.
    • Scale Type: Logarithmic
    • Logarithmic base: 10
  9. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and check-on the Show Labels option.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  7. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  4. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  5. Click OK to save the settings.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Polar Chart

Create Stacked Polar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Polar Chart > Create Stacked Polar Chart

Glossary Item Box

This walkthrough creates a Stacked Polar Chart. The chart displays the sales amount by product categories for each sales channel. In a stacked polar chart, the data values are broken down into subcategories and are stacked on top of each other. The final chart appears like this:

Stacked Polar Chart Final

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add two calculated fields:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  4. Go to the Filters page, and add these filters:
    Expression | Operator | Value
    =[ChannelKey] | NotEqual | 1
    =[ProductKey] | GreaterThan | 338
  5. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Polar'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Sales Channel].
  6. Set the Series > Group By to [Product Category].
  7. Set Series > Layout Type to 'Stack'.
  8. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Cluster Polar Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set StartAngle property to '90'.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Currency (with 0 decimal places)
    • Angle: -90
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 100000
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and in the General tab, check-on the Show Labels option.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  7. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  4. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  5. Click OK to save the settings.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Stacked Percentage Polar Chart

Create Stacked Percentage Polar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Polar Chart > Create Stacked Percentage Polar Chart

Glossary Item Box

This walkthrough creates a Stacked Percentage Polar Chart. The chart displays the sales amount by sales channels for each product category. The stacked percentage polar chart is used to display the percentage values that each subcategory contributes within a category. The final chart appears like this:

Stacked Percentage Polar Chart Final

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/contoso/odata/v1/FactSales
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'FactSales'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.value[*]
  3. On the same page, add two calculated fields:
    Field Name | Value
    Product Category | =Switch([ProductKey] < 116, "Audio", [ProductKey] >= 116 And [ProductKey] < 338, "TV and Video", [ProductKey] >= 338 And [ProductKey] < 944, "Computers", [ProductKey] >= 944 And [ProductKey] < 1316, "Cameras", [ProductKey] >= 1316, "Cell Phones")
    Sales Channel | =Switch([ChannelKey] = 1, "Store", [ChannelKey] = 2, "Online", [ChannelKey] = 3, "Catalog", [ChannelKey] = 4, "Reseller")
  4. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Polar'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, add the following value from the drop-down, set the corresponding captions, and click Next.
    Field | Aggregate | Caption
    [SalesAmount] | Sum | Sales Amount
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Sales Channel].
  6. Set the Series > Group By to [Product Category].
  7. Set Series > Layout Type to 'Stack'.
  8. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Cluster Polar Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Plot Settings

  1. Select 'Plot - Chart' on the Report Explorer.
  2. From the Properties Panel, set StartAngle property to '90'.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the Angle to '-90'.
  4. Then, navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the following properties under Grid appearance.
    • Show Grid: Check-on
    • Width: 0.25pt
    • Color: #cccccc
    • Style: Dashed
  7. Go to the Scale page and set the Scale Type to 'Percentage'.
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and in the General tab, check-on the Show Labels option.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: Black
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and uncheck the Show Grid option to hide the gridlines.
  7. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and select SeriesGroups as Legend Mode.
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  4. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  5. Click OK to save the settings.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sales by Category and Channel'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Gantt Chart

Gantt Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Gantt Chart

Glossary Item Box

A Gantt chart is a common chart type used in project management. Gantt plots provide the most useful ways of displaying activities (tasks or events) against time periods. Gantt charts can also be used to schedule big projects by breaking them into tasks and subtasks. The Gantt plot helps lay the tasks and subtasks on a timeline. In the Gantt chart, each task is listed on the chart's one side and each has a horizontal bar opposite it corresponding to the task length. By using the Gantt chart, you can find out how long each task will take and which tasks can overlap.

See Create Gantt Chart walkthrough to learn how the immunization schedule can be laid out using the Gantt chart.

A Gantt chart is made of essential elements, such as:

  • Task: An activity involved in the project.
  • Start: The date or time when the task execution begins.
  • End: The date or time when the task execution ends.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Gantt Chart

Create Gantt Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Gantt Chart > Create Gantt Chart

Glossary Item Box

This walkthrough creates a Gantt Chart to layout recommended child immunization schedule based on age in the United States. The schedule shows recommended vaccines at an acceptable age range, the number of doses, and highlights the recommendations for all children, catch-up vaccinations in case of missed vaccines, and other high-risk groups.

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
 {
   "Vaccine": "Hepatitis B (HepB)",
   "Start": 0,
   "End": 1,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Hepatitis B (HepB)",
   "Start": 1,
   "End": 3,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Hepatitis B (HepB)",
   "Start": 4,
   "End": 5,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Hepatitis B (HepB)",
   "Start": 6,
   "End": 18,
   "Dose": "3rd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Hepatitis B (HepB)",
   "Start": 19,
   "End": 216,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Rotavirus (RV)",
   "Start": 2,
   "End": 3,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Rotavirus (RV)",
   "Start": 4,
   "End": 5,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Rotavirus (RV)",
   "Start": 6,
   "End": 7,
   "Dose": "3rd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 2,
   "End": 3,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 4,
   "End": 5,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 6,
   "End": 7,
   "Dose": "3rd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 9,
   "End": 12,
   "Dose": " ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 15,
   "End": 18,
   "Dose": "4th Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 18.5,
   "End": 48,
   "Dose": " ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Diptheria, Tetanus & Acellular pertussis (DTaP)",
   "Start": 48,
   "End": 84,
   "Dose": "5th Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 2,
   "End": 3,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 4,
   "End": 5,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 9,
   "End": 10,
   "Dose": "  ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 12,
   "End": 16,
   "Dose": "3rd Dose or 4th Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 18,
   "End": 36,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 48,
   "End": 84,
   "Dose": " ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Haemophilus Influenzae type b (Hib)",
   "Start": 84,
   "End": 216,
   "Dose": " ",
   "Range": "For certain high-risks groups"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 2,
   "End": 3,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 4,
   "End": 5,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 6,
   "End": 7,
   "Dose": "3rd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 9,
   "End": 10,
   "Dose": "  ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 12,
   "End": 16,
   "Dose": "4th Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 19,
   "End": 84,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Pneumococcal conjugate (PCV13)",
   "Start": 84,
   "End": 216,
   "Dose": " ",
   "Range": "For certain high-risks groups"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 2,
   "End": 3,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 4,
   "End": 5,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 6,
   "End": 18,
   "Dose": "3rd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 18.1,
   "End": 48,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 48,
   "End": 84,
   "Dose": "4th Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Inactivated poliovirus (IPV)",
   "Start": 84,
   "End": 204,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Influenza (IIV)",
   "Start": 6,
   "End": 18,
   "Dose": "Annual vaccination 1 or 2 doses ",
   "Range": "For all children"
 },
 {
  "Vaccine": "Influenza (IIV)",
  "Start": 18,
  "End": 19,
  "Dose": " ",
  "Range": "For all children"
},
 {
   "Vaccine": "Influenza (IIV)",
   "Start": 19,
   "End": 84,
   "Dose": "Annual vaccination 1 or 2 doses",
   "Range": "For all children"
 },
 {
   "Vaccine": "Influenza (IIV)",
   "Start": 96,
   "End": 216,
   "Dose": "Annual vaccination 1 dose only",
   "Range": "For all children"
 },
 {
  "Vaccine": "Measles, mumps, rubella (MMR)",
  "Start": 6,
  "End": 9,
  "Dose": " ",
  "Range": "For certain high-risks groups"
},
 {
   "Vaccine": "Measles, mumps, rubella (MMR)",
   "Start": 12,
   "End": 16,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Measles, mumps, rubella (MMR)",
   "Start": 18.1,
   "End": 48,
   "Dose": "  ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Measles, mumps, rubella (MMR)",
   "Start": 48,
   "End": 84,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Measles, mumps, rubella (MMR)",
   "Start": 84,
   "End": 216,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Varicella (VAR)",
   "Start": 12,
   "End": 16,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Varicella (VAR)",
   "Start": 18.1,
   "End": 48,
   "Dose": "  ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Varicella (VAR)",
   "Start": 48,
   "End": 84,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Varicella (VAR)",
   "Start": 84,
   "End": 216,
   "Dose": "",
   "Range": "For catch-up immunization"
 },
 {
  "Vaccine": "Hepatitis A (HepA)",
  "Start": 6,
  "End": 9,
  "Dose": "  ",
  "Range": "For certain high-risks groups"
},
 {
   "Vaccine": "Hepatitis A (HepA)",
   "Start": 12,
   "End": 18,
   "Dose": "2nd Dose Series",
   "Range": "For all children"
 },
 {
   "Vaccine": "Hepatitis A (HepA)",
   "Start": 18,
   "End": 23,
   "Dose": " ",
   "Range": "For all children"
 },
 {
   "Vaccine": "Hepatitis A (HepA)",
   "Start": 24,
   "End": 216,
   "Dose": "",
   "Range": "For catch-up immunization"
 },

 {
  "Vaccine": "Meningococcal (MenACWY)",
  "Start": 2,
  "End": 132,
  "Dose": " ",
  "Range": "For certain high-risks groups"
},
 {
   "Vaccine": "Meningococcal (MenACWY)",
   "Start": 132,
   "End": 156,
   "Dose": "1st Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Meningococcal (MenACWY)",
   "Start": 156,
   "End": 180,
   "Dose": "   ",
   "Range": "For catch-up immunization"
 },
 {
   "Vaccine": "Meningococcal (MenACWY)",
   "Start": 180,
   "End": 191,
   "Dose": "2nd Dose",
   "Range": "For all children"
 },
 {
   "Vaccine": "Meningococcal (MenACWY)",
   "Start": 191,
   "End": 216,
   "Dose": "  ",
   "Range": "For catch-up immunization"
 }
]

    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Chart Wizard, from the Select Data Set dialog, select a suitable Dataset name from the dropdown menu.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query
    Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Stats) and the Plot Type as 'Gantt'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the Start and End fields, aggregates, and captions as shown below, and click Next.
    Field | Aggregate | Caption
    [Start] | Min | Start
    [End] | Max | End
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Vaccine].
  6. Set Series > Group By to [Dose]. Keep the remaining settings as it is.
  7. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Gantt Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Chart Data

  1. In the Chart Data area, right-click the Start, End and from the adorner, click Edit.
  2. In the Chart Data - Series Values dialog, go to Labels tab and set following under Point Labels:
    • Value: =[Dose]
    • Text Position: Center
  3. Click OK to close the dialog.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties.
    • Title: Age (in months)
    • Font > Size: 10pt
    • Padding > Top: 4pt
    • Padding > Bottom: 4pt
  3. Go to the Layout page and set Position to 'Far'.
  4. Go to the Labels page > General, check-on Show Labels and set Format to 'n0'.
  5. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 9pt
    • Font > Color: DimGray
  6. Go to the Line page and check the Show Line option. Set the color to 'Gainsboro'.
  7. Go to the Major Gridline page and set Grid appearance > Show Grid: Uncheck
  8. Go to the Scale page and set the following properties.
    • Scale Type: Linear
    • Minimum Scale value: 0
    • Maximum Scale value: 18
  9. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Layout page and check the Position > Reversed option to reverse the axis to appear from top to bottom.
  4. Go to the Labels page > General tab and check the Show Labels option to show the data labels.
  5. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 9pt
    • Font > Color: DimGray
  6. Go to the Line page and uncheck the Show Line option.
  7. Go to the Minor Gridline page and uncheck the Show Grid option to hide minor gridlines.
  8. Go to the Major Gridline page, check the Show Grid option, and set the Color to 'GainsBoro'.
  9. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and add these custom palette colors, #bfecb8, #9ebac4, and #ffb1ae.
  3. Click OK to complete setting up the chart palette.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the General page and set Legend Series Data Field to =[Range].
  3. Keep the Legend Mode as 'None'.
  4. Go to the Title page and set the title to 'Recommended age range' and Font > Size to '12pt'.
  5. Go to the Appearance page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  6. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  7. Click OK to complete setting up the Legend.

Chart

  1. From the Report Explorer, select Chart.
  2. In the Properties panel, go to BarSettings > Overlap and set it to some percentage, say '98%'.

Header

  1. To open the smart panel, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Child Immunization Schedule'.
  3. Set the Horizontal Alignment to Center and Vertical Alignment to Middle.
  4. Go to the Font page and set the properties as below.
    • Size: 20pt
    • Color: #3da7a8
  5. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Funnel and Pyramid Charts

Funnel and Pyramid Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Funnel and Pyramid Charts

Glossary Item Box

Funnel Chart

A Funnel chart helps in visualizing sequential stages in a linear process such as the flow of users via a sales or business process. The chart takes its name from the funnel shape it has - which starts with a broad head and ends with a narrow neck. The number of users at different process stage are indicated by the width of the funnel.

Funnel charts can help identify potential problem areas in processes where it is noticeable at what stages and rate the values decrease. A real-time use case for Funnel Charts can be an order fulfillment process scenario, which tracks the number of orders getting across a stage, such as orders received, processed, approved, released, shipped, completed, and delivered. Each stage in such a process represents a percentage or proportion of the total. That's the reason why the chart takes a funnel shape with the first stage being the largest and the consecutive stage smaller than the predecessor.

A Funnel chart arranges related values stacked on top of one another.

The Create Funnel Chart walkthrough showcases plotting parameters like Visitors, Opportunities, Total Quality Organization, and Customers.

Stacked Funnel Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Pyramid Chart

A Pyramid chart is an easy-to-understand chart type, which can be used to depict directional workflows or hierarchies. The Pyramid chart is beneficial for organizing and visualizing data and explaining internal business management structures or workflows. A Pyramid chart can quickly communicate processes, hierarchies, and relationships between categories of information.

A Pyramid chart arranges each series vertically stacked one over the other. The Create Pyramid Chart walkthrough showcases plotting the Sales Amount for each Product Category per Sales Channel.

Stacked Pyramid Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Funnel and Pyramid Plot Properties

The plot properties discussed below can be accessed from the Properties Panel on selecting the Chart > Plot from the Report Explorer. You can access some of the important properties from the Plot's Smart Panel too. See Chart Smart Panels topic for more information. Both the Properties Panel and the Smart Panel can be accessed by right-clicking the plot in the design area.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Funnel Chart

Create Funnel Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Funnel and Pyramid Charts > Create Funnel Chart

Glossary Item Box

This walkthrough creates a Funnel Chart, which shows how various related values are stacked or arranged on top of one another. For example, the chart represents a Sales Funnel, which depicts many factors like Visitor count, Opportunities, TQO (Total Quality Organization) and Customers in an organization. By Visitor count, we mean the total number of visitors at a website. By Opportunities, we imply the number of potential visitors that can be converted to successful customers. Further, TQO is an important aspect, which drives customer satisfaction and is essential for the growth and survival of the organization.

The final chart appears like this, which looks very similar to an ideal marketing sales funnel in its symmetrical form – a paradigm of efficiency that makes sense of a website's visitors, opportunities, TQO and customers.

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    {
   "data":{
      "values":[
         {
            "Type":"Customers",
            "Value":91658
         },
         {
            "Type":"TQO",
            "Value":200400
         },
         {
            "Type":"Opportunities",
            "Value":360470
         },
         {
            "Type":"Visitors",
            "Value":550000
         }
      ]
   }
}

    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'SaleProcess'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query
    Copy Code
    $.data.values[*]
  3. Click OK to save the changes and open the DataSet dialog.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (SaleProcess) and the Plot Type as 'Funnel'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the field, aggregate, and caption as shown below, and click Next.
    Field | Aggregate | Caption
    [Value] | Sum | Value
  5. In the Configure Chart Data Groupings, set Series > Group By to Type and Layout Type to 'Stack'.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    Funnel Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Chart Data

  1. In the Chart Data area, right-click Value and from the adorner, click Edit.
  2. In the Chart Data - Series Values dialog, go to Styles tab and set Common> Opacity to '70%'.
  3. Go to Labels tab and set following under Point Labels:
    • Value: =[Type]
    • Text Position: Center
  4. Set the following properties under Font:
    • Size: 10pt
    • Color: DimGray
  5. Click OK to close the dialog.

Chart

  1. From the Report Explorer, select Chart.
  2. In the Properties panel, go to BarSettings and set the following properties:
    • BottomWidth: 15%
    • NeckHeight: 20%
    • Overlap: 98%
  3. Click OK to complete setting up the plot.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and set the Format to 'Default'.
  4. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 8pt
    • Font > Color: DimGray
  5. Go to the Line page and uncheck the Show Line option.
  6. Go to the Major Gridline page and set the following properties under Grid appearance:
    • Show Grid: Check-on
    • Width: 1pt
    • Color: WhiteSmoke
    • Style: Solid
  7. Go to the Scale page and set Scale Type as 'Linear'.
  8. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and uncheck the Show Labels option to hide the data labels.
  4. Go to the Line page and uncheck the Show Line option.
  5. Click OK to complete setting up the X-axis.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the Layout page and select the Hide Legend option.
    We can hide the legend since the chart can be easily visualized with colors and corresponding data labels for each type.
  3. Click OK to save the settings.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and add the 'Flatly' palette.
  3. Click OK to complete setting up the chart palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Sale Process'.
  3. Go to the Font page and set the properties as below.
    • Size: 20pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.
  5. Once you are done with configuring and customizing the chart, press F5 to preview the report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Pyramid Chart

Create Pyramid Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Funnel and Pyramid Charts > Create Pyramid Chart

Glossary Item Box

This walkthrough creates a Clustered Pyramid Chart. The chart shows the hierarchical structure of employees in an organization, which is depicted in the form of discrete vertical pyramids. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    {
   "data":{
      "Counts":[
         {
            "Title":"Managers",
            "Layer":4,
            "Count":15
         },
         {
            "Title":"Sr. VPs",
            "Layer":2,
            "Count":3
         },
         {
            "Title":"Directors",
            "Layer":3,
            "Count":8
         },
         {
            "Title":"Developers",
            "Layer":6,
            "Count":23
         },
         {
            "Title":"CEO",
            "Layer":1,
            "Count":1
         },
         {
            "Title":"Sr. Developers",
            "Layer":5,
            "Count":10
         },
         {
            "Title":"Jr. Developers",
            "Layer":7,
            "Count":11
         }
      ]
   }
}
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'OrgDS'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query
    Copy Code
    $.data.Counts[*]
  3. Click OK to complete adding the dataset.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (OrgDs) and the Plot Type as 'Pyramid'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the field, aggregate, and caption as shown below, and click Next.
    Field | Aggregate | Caption
    [Count] | Sum | Count
  5. In the Configure Chart Data Groupings, set Series > Group By to [Title] and Layout Type to 'Stack'.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Pyramid Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Series Groups

  1. In the Series Groups area, right-click [Title] and from the adorner, click Edit.
  2. In the Chart Data - Series Groups dialog, go to the Sorting tab, and add an Expression as[Layer] and Direction as 'Descending'.
  3. Click OK to close the dialog.

Legend

  1. In the Legend Data, right-click Color and from the adorner, click Edit.
  2. Go to the Layout page and set the Orientation to 'Horizontal' and Position to 'Bottom'.
  3. Click OK to save the settings.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' from the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General tab and uncheck the Show Labels option to hide the data labels.
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and uncheck the Show grid option to hide the gridlines.
  6. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page and uncheck the Show Labels option to hide the data labels.
  4. Go to the Line page and uncheck the Show Line option.
  5. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select the 'Flatly' palette.
  3. Click OK to complete setting up the chart palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Organization Structure'.
  3. Go to the Font page and set the properties as below.
    • Size: 20pt
    • Color: DimGray
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart, change the chart palette, and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Candlestick Chart

Candlestick Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Candlestick Chart

Glossary Item Box

Candlestick charts are plot types used by traders to analyze the possible price changes in trading. Or, let's put it this way, that the CandleStick chart is perhaps a trader's best friend, for the reason that it provides a visual representation of the magnitude of price fluctuations. Without a shadow of a doubt, Candlestick plots never fail to depict the investor sentiment. The relationship between the supply and demand in the trade market comes out really well via the CandleStick pattern.

A Candlestick chart includes a rectangle with a dividing long line projecting from the top and bottom (of the same rectangle), which displays the high and low values. This chart type is also useful to show the opening and closing price points in trading scenarios. So, when the open value is greater than the close value, the rectangle appears filled with the color of the background.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Candlestick Chart

Create Candlestick Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Candlestick Chart > Create Candlestick Chart

Glossary Item Box

This walkthrough creates a Candlestick Chart. The chart shows the movement of the stock price for a certain company over time. The rectangles in the chart show the relationship between the opening and closing values. If the rectangle is filled with a background color, it means that the opening value is greater than the closing value. Else, the rectangle is empty. Moreover, the vertical lines above and below the rectangle represent the high and low values in the chart. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Date": "1/4/2021",
    "Close": 129.41,
    "Open": 133.52,
    "High": 133.61,
    "Low": 126.76
  },
  {
    "Date": "1/5/2021",
    "Close": 131.01,
    "Open": 128.89,
    "High": 131.74,
    "Low": 128.43
  },
  {
    "Date": "1/6/2021",
    "Close": 126.6,
    "Open": 127.72,
    "High": 131.05,
    "Low": 126.38
  },
  {
    "Date": "1/7/2021",
    "Close": 130.92,
    "Open": 128.36,
    "High": 131.63,
    "Low": 127.86
  },
  {
    "Date": "1/8/2021",
    "Close": 132.05,
    "Open": 132.43,
    "High": 132.63,
    "Low": 130.23
  },
  {
    "Date": "1/11/2021",
    "Close": 128.98,
    "Open": 129.19,
    "High": 130.17,
    "Low": 128.5
  },
  {
    "Date": "1/12/2021",
    "Close": 128.8,
    "Open": 128.5,
    "High": 129.69,
    "Low": 126.86
  },
  {
    "Date": "1/13/2021",
    "Close": 130.89,
    "Open": 128.76,
    "High": 131.45,
    "Low": 128.49
  },
  {
    "Date": "1/14/2021",
    "Close": 128.91,
    "Open": 130.8,
    "High": 131,
    "Low": 128.76
  },
  {
    "Date": "1/15/2021",
    "Close": 127.14,
    "Open": 128.78,
    "High": 130.22,
    "Low": 127
  },
  {
    "Date": "1/19/2021",
    "Close": 127.83,
    "Open": 127.78,
    "High": 128.71,
    "Low": 126.94
  },
  {
    "Date": "1/20/2021",
    "Close": 132.03,
    "Open": 128.66,
    "High": 132.49,
    "Low": 128.55
  },
  {
    "Date": "1/21/2021",
    "Close": 136.87,
    "Open": 133.8,
    "High": 139.67,
    "Low": 133.59
  },
  {
    "Date": "1/22/2021",
    "Close": 139.07,
    "Open": 136.28,
    "High": 139.85,
    "Low": 135.02
  },
  {
    "Date": "1/25/2021",
    "Close": 142.92,
    "Open": 143.07,
    "High": 145.09,
    "Low": 136.54
  },
  {
    "Date": "1/26/2021",
    "Close": 143.16,
    "Open": 143.6,
    "High": 144.3,
    "Low": 141.37
  },
  {
    "Date": "1/27/2021",
    "Close": 142.06,
    "Open": 143.43,
    "High": 144.3,
    "Low": 140.41
  },
  {
    "Date": "1/28/2021",
    "Close": 137.09,
    "Open": 139.52,
    "High": 141.99,
    "Low": 136.7
  },
  {
    "Date": "1/29/2021",
    "Close": 131.96,
    "Open": 135.83,
    "High": 136.74,
    "Low": 130.21
  },
  {
    "Date": "2/1/2021",
    "Close": 134.14,
    "Open": 133.75,
    "High": 135.38,
    "Low": 130.93
  },
  {
    "Date": "2/2/2021",
    "Close": 134.99,
    "Open": 135.73,
    "High": 136.31,
    "Low": 134.61
  },
  {
    "Date": "2/3/2021",
    "Close": 133.94,
    "Open": 135.76,
    "High": 135.77,
    "Low": 133.61
  },
  {
    "Date": "2/4/2021",
    "Close": 137.39,
    "Open": 136.3,
    "High": 137.4,
    "Low": 134.59
  },
  {
    "Date": "2/5/2021",
    "Close": 136.76,
    "Open": 137.35,
    "High": 137.42,
    "Low": 135.86
  },
  {
    "Date": "2/8/2021",
    "Close": 136.91,
    "Open": 136.03,
    "High": 136.96,
    "Low": 134.92
  },
  {
    "Date": "2/9/2021",
    "Close": 136.01,
    "Open": 136.62,
    "High": 137.88,
    "Low": 135.85
  },
  {
    "Date": "2/10/2021",
    "Close": 135.39,
    "Open": 136.48,
    "High": 136.99,
    "Low": 134.4
  },
  {
    "Date": "2/11/2021",
    "Close": 135.13,
    "Open": 135.9,
    "High": 136.39,
    "Low": 133.77
  },
  {
    "Date": "2/12/2021",
    "Close": 135.37,
    "Open": 134.35,
    "High": 135.53,
    "Low": 133.69
  },
  {
    "Date": "2/16/2021",
    "Close": 133.19,
    "Open": 135.49,
    "High": 136.01,
    "Low": 132.79
  },
  {
    "Date": "2/17/2021",
    "Close": 130.84,
    "Open": 131.25,
    "High": 132.22,
    "Low": 129.47
  },
  {
    "Date": "2/18/2021",
    "Close": 129.71,
    "Open": 129.2,
    "High": 130,
    "Low": 127.41
  },
  {
    "Date": "2/19/2021",
    "Close": 129.87,
    "Open": 130.24,
    "High": 130.71,
    "Low": 128.8
  },
  {
    "Date": "2/22/2021",
    "Close": 126,
    "Open": 128.01,
    "High": 129.72,
    "Low": 125.6
  },
  {
    "Date": "2/23/2021",
    "Close": 125.86,
    "Open": 123.76,
    "High": 126.71,
    "Low": 118.39
  },
  {
    "Date": "2/24/2021",
    "Close": 125.35,
    "Open": 124.94,
    "High": 125.56,
    "Low": 122.23
  },
  {
    "Date": "2/25/2021",
    "Close": 120.99,
    "Open": 124.68,
    "High": 126.46,
    "Low": 120.54
  },
  {
    "Date": "2/26/2021",
    "Close": 121.26,
    "Open": 122.59,
    "High": 124.85,
    "Low": 121.2
  },
  {
    "Date": "3/1/2021",
    "Close": 127.79,
    "Open": 123.75,
    "High": 127.93,
    "Low": 122.79
  },
  {
    "Date": "3/2/2021",
    "Close": 125.12,
    "Open": 128.41,
    "High": 128.72,
    "Low": 125.01
  },
  {
    "Date": "3/3/2021",
    "Close": 122.06,
    "Open": 124.81,
    "High": 125.71,
    "Low": 121.84
  },
  {
    "Date": "3/4/2021",
    "Close": 120.13,
    "Open": 121.75,
    "High": 123.6,
    "Low": 118.62
  },
  {
    "Date": "3/5/2021",
    "Close": 121.42,
    "Open": 120.98,
    "High": 121.94,
    "Low": 117.57
  },
  {
    "Date": "3/8/2021",
    "Close": 116.36,
    "Open": 120.93,
    "High": 121,
    "Low": 116.21
  },
  {
    "Date": "3/9/2021",
    "Close": 121.09,
    "Open": 119.03,
    "High": 122.06,
    "Low": 118.79
  },
  {
    "Date": "3/10/2021",
    "Close": 119.98,
    "Open": 121.69,
    "High": 122.17,
    "Low": 119.45
  },
  {
    "Date": "3/11/2021",
    "Close": 121.96,
    "Open": 122.54,
    "High": 123.21,
    "Low": 121.26
  },
  {
    "Date": "3/12/2021",
    "Close": 121.03,
    "Open": 120.4,
    "High": 121.17,
    "Low": 119.16
  },
  {
    "Date": "3/15/2021",
    "Close": 123.99,
    "Open": 121.41,
    "High": 124,
    "Low": 120.42
  },
  {
    "Date": "3/16/2021",
    "Close": 125.57,
    "Open": 125.7,
    "High": 127.22,
    "Low": 124.72
  },
  {
    "Date": "3/17/2021",
    "Close": 124.76,
    "Open": 124.05,
    "High": 125.86,
    "Low": 122.34
  },
  {
    "Date": "3/18/2021",
    "Close": 120.53,
    "Open": 122.88,
    "High": 123.18,
    "Low": 120.32
  },
  {
    "Date": "3/19/2021",
    "Close": 119.99,
    "Open": 119.9,
    "High": 121.43,
    "Low": 119.68
  },
  {
    "Date": "3/22/2021",
    "Close": 123.39,
    "Open": 120.33,
    "High": 123.87,
    "Low": 120.26
  },
  {
    "Date": "3/23/2021",
    "Close": 122.54,
    "Open": 123.33,
    "High": 124.24,
    "Low": 122.14
  },
  {
    "Date": "3/24/2021",
    "Close": 120.09,
    "Open": 122.82,
    "High": 122.9,
    "Low": 120.07
  },
  {
    "Date": "3/25/2021",
    "Close": 120.59,
    "Open": 119.54,
    "High": 121.66,
    "Low": 119
  },
  {
    "Date": "3/26/2021",
    "Close": 121.21,
    "Open": 120.35,
    "High": 121.48,
    "Low": 118.92
  },
  {
    "Date": "3/29/2021",
    "Close": 121.39,
    "Open": 121.65,
    "High": 122.58,
    "Low": 120.73
  },
  {
    "Date": "3/30/2021",
    "Close": 119.9,
    "Open": 120.11,
    "High": 120.4,
    "Low": 118.86
  },
  {
    "Date": "3/31/2021",
    "Close": 122.15,
    "Open": 121.65,
    "High": 123.52,
    "Low": 121.15
  },
  {
    "Date": "4/1/2021",
    "Close": 123,
    "Open": 123.66,
    "High": 124.18,
    "Low": 122.49
  },
  {
    "Date": "4/5/2021",
    "Close": 125.9,
    "Open": 123.87,
    "High": 126.16,
    "Low": 123.07
  },
  {
    "Date": "4/6/2021",
    "Close": 126.21,
    "Open": 126.5,
    "High": 127.13,
    "Low": 125.65
  },
  {
    "Date": "4/7/2021",
    "Close": 127.9,
    "Open": 125.83,
    "High": 127.92,
    "Low": 125.14
  },
  {
    "Date": "4/8/2021",
    "Close": 130.36,
    "Open": 128.95,
    "High": 130.39,
    "Low": 128.52
  },
  {
    "Date": "4/9/2021",
    "Close": 133,
    "Open": 129.8,
    "High": 133.04,
    "Low": 129.47
  },
  {
    "Date": "4/12/2021",
    "Close": 131.24,
    "Open": 132.52,
    "High": 132.85,
    "Low": 130.63
  },
  {
    "Date": "4/13/2021",
    "Close": 134.43,
    "Open": 132.44,
    "High": 134.66,
    "Low": 131.93
  },
  {
    "Date": "4/14/2021",
    "Close": 132.03,
    "Open": 134.94,
    "High": 135,
    "Low": 131.66
  },
  {
    "Date": "4/15/2021",
    "Close": 134.5,
    "Open": 133.82,
    "High": 135,
    "Low": 133.64
  },
  {
    "Date": "4/16/2021",
    "Close": 134.16,
    "Open": 134.3,
    "High": 134.67,
    "Low": 133.28
  },
  {
    "Date": "4/19/2021",
    "Close": 134.84,
    "Open": 133.51,
    "High": 135.47,
    "Low": 133.34
  },
  {
    "Date": "4/20/2021",
    "Close": 133.11,
    "Open": 135.02,
    "High": 135.53,
    "Low": 131.81
  },
  {
    "Date": "4/21/2021",
    "Close": 133.5,
    "Open": 132.36,
    "High": 133.75,
    "Low": 131.3
  },
  {
    "Date": "4/22/2021",
    "Close": 131.94,
    "Open": 133.04,
    "High": 134.15,
    "Low": 131.41
  },
  {
    "Date": "4/23/2021",
    "Close": 134.32,
    "Open": 132.16,
    "High": 135.12,
    "Low": 132.16
  },
  {
    "Date": "4/26/2021",
    "Close": 134.72,
    "Open": 134.83,
    "High": 135.06,
    "Low": 133.56
  },
  {
    "Date": "4/27/2021",
    "Close": 134.39,
    "Open": 135.01,
    "High": 135.41,
    "Low": 134.11
  },
  {
    "Date": "4/28/2021",
    "Close": 133.58,
    "Open": 134.31,
    "High": 135.02,
    "Low": 133.08
  },
  {
    "Date": "4/29/2021",
    "Close": 133.48,
    "Open": 136.47,
    "High": 137.07,
    "Low": 132.45
  },
  {
    "Date": "4/30/2021",
    "Close": 131.46,
    "Open": 131.78,
    "High": 133.56,
    "Low": 131.07
  },
  {
    "Date": "5/3/2021",
    "Close": 132.54,
    "Open": 132.04,
    "High": 134.07,
    "Low": 131.83
  },
  {
    "Date": "5/4/2021",
    "Close": 127.85,
    "Open": 131.19,
    "High": 131.49,
    "Low": 126.7
  },
  {
    "Date": "5/5/2021",
    "Close": 128.1,
    "Open": 129.2,
    "High": 130.45,
    "Low": 127.97
  },
  {
    "Date": "5/6/2021",
    "Close": 129.74,
    "Open": 127.89,
    "High": 129.75,
    "Low": 127.13
  },
  {
    "Date": "5/7/2021",
    "Close": 130.21,
    "Open": 130.85,
    "High": 131.26,
    "Low": 129.48
  },
  {
    "Date": "5/10/2021",
    "Close": 126.85,
    "Open": 129.41,
    "High": 129.54,
    "Low": 126.81
  },
  {
    "Date": "5/11/2021",
    "Close": 125.91,
    "Open": 123.5,
    "High": 126.27,
    "Low": 122.77
  },
  {
    "Date": "5/12/2021",
    "Close": 122.77,
    "Open": 123.4,
    "High": 124.64,
    "Low": 122.25
  },
  {
    "Date": "5/13/2021",
    "Close": 124.97,
    "Open": 124.58,
    "High": 126.15,
    "Low": 124.26
  },
  {
    "Date": "5/14/2021",
    "Close": 127.45,
    "Open": 126.25,
    "High": 127.89,
    "Low": 125.85
  },
  {
    "Date": "5/17/2021",
    "Close": 126.27,
    "Open": 126.82,
    "High": 126.93,
    "Low": 125.17
  },
  {
    "Date": "5/18/2021",
    "Close": 124.85,
    "Open": 126.56,
    "High": 126.99,
    "Low": 124.78
  },
  {
    "Date": "5/19/2021",
    "Close": 124.69,
    "Open": 123.16,
    "High": 124.92,
    "Low": 122.86
  },
  {
    "Date": "5/20/2021",
    "Close": 127.31,
    "Open": 125.23,
    "High": 127.72,
    "Low": 125.1
  },
  {
    "Date": "5/21/2021",
    "Close": 125.43,
    "Open": 127.82,
    "High": 128,
    "Low": 125.21
  },
  {
    "Date": "5/24/2021",
    "Close": 127.1,
    "Open": 126.01,
    "High": 127.94,
    "Low": 125.94
  },
  {
    "Date": "5/25/2021",
    "Close": 126.9,
    "Open": 127.82,
    "High": 128.32,
    "Low": 126.32
  },
  {
    "Date": "5/26/2021",
    "Close": 126.85,
    "Open": 126.96,
    "High": 127.39,
    "Low": 126.42
  },
  {
    "Date": "5/27/2021",
    "Close": 125.28,
    "Open": 126.44,
    "High": 127.64,
    "Low": 125.08
  },
  {
    "Date": "5/28/2021",
    "Close": 124.61,
    "Open": 125.57,
    "High": 125.8,
    "Low": 124.55
  },
  {
    "Date": "6/1/2021",
    "Close": 124.28,
    "Open": 125.08,
    "High": 125.35,
    "Low": 123.94
  },
  {
    "Date": "6/2/2021",
    "Close": 125.06,
    "Open": 124.28,
    "High": 125.24,
    "Low": 124.05
  },
  {
    "Date": "6/3/2021",
    "Close": 123.54,
    "Open": 124.68,
    "High": 124.85,
    "Low": 123.13
  },
  {
    "Date": "6/4/2021",
    "Close": 125.89,
    "Open": 124.07,
    "High": 126.16,
    "Low": 123.85
  },
  {
    "Date": "6/7/2021",
    "Close": 125.9,
    "Open": 126.17,
    "High": 126.32,
    "Low": 124.83
  },
  {
    "Date": "6/8/2021",
    "Close": 126.74,
    "Open": 126.6,
    "High": 128.46,
    "Low": 126.21
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'StockPrice'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (StockPrice) and the Plot Type as 'Candlestick'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the High, Low, Open, and Close data values as follows, and click Next.
    Data Values | Field | Aggregate | Caption
    High | [High] | None | High
    Low | [Low] | None | Low
    Open | [Open] | None | Open
    Close | [Close] | None | Close
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Date] and Sorting to 'Ascending'
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Candlestick Chart

    Now that the basic structure of your chart is ready, let us add more meaning to the chart using the properties via the Chart Panels, Adorners, and Property Panel.

Add Customizations to Chart

Chart Data

  1. In the Chart Data area, select the series value.
  2. Go to Properties Panel and set FillColor property to '#f77268'.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General page and set the Format to 'Currency (with 0 decimal points)'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 10
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Short Date
    • Angle: -45
  4. Now, navigate to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 7 (to view weekly stock prices)
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Stock Price'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


High Low Close Chart

High Low Close Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > High Low Close Chart

Glossary Item Box

A High Low Close chart encodes the price points using lines with a marker. The marker stands for the closing value. Also, the high and low values are indicated via the upper and the lower ends of the line. For example, the High-Low-Close plot type can be used to depict the stock price movement for a virtual company.

High Low Close Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create High Low Close Chart

Create High Low Close Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > High Low Close Chart > Create High Low Close Chart

Glossary Item Box

This walkthrough creates a High Low Close Chart. The chart shows the movement of stock price for a certain company over time. In the high low close chart, the upper and the lower ends of the line represent the high and low values, while the marker represents the closing value. The final chart appears like this:

High Low Close Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Date": "1/4/2021",
    "Close": 129.41,
    "Open": 133.52,
    "High": 133.61,
    "Low": 126.76
  },
  {
    "Date": "1/5/2021",
    "Close": 131.01,
    "Open": 128.89,
    "High": 131.74,
    "Low": 128.43
  },
  {
    "Date": "1/6/2021",
    "Close": 126.6,
    "Open": 127.72,
    "High": 131.05,
    "Low": 126.38
  },
  {
    "Date": "1/7/2021",
    "Close": 130.92,
    "Open": 128.36,
    "High": 131.63,
    "Low": 127.86
  },
  {
    "Date": "1/8/2021",
    "Close": 132.05,
    "Open": 132.43,
    "High": 132.63,
    "Low": 130.23
  },
  {
    "Date": "1/11/2021",
    "Close": 128.98,
    "Open": 129.19,
    "High": 130.17,
    "Low": 128.5
  },
  {
    "Date": "1/12/2021",
    "Close": 128.8,
    "Open": 128.5,
    "High": 129.69,
    "Low": 126.86
  },
  {
    "Date": "1/13/2021",
    "Close": 130.89,
    "Open": 128.76,
    "High": 131.45,
    "Low": 128.49
  },
  {
    "Date": "1/14/2021",
    "Close": 128.91,
    "Open": 130.8,
    "High": 131,
    "Low": 128.76
  },
  {
    "Date": "1/15/2021",
    "Close": 127.14,
    "Open": 128.78,
    "High": 130.22,
    "Low": 127
  },
  {
    "Date": "1/19/2021",
    "Close": 127.83,
    "Open": 127.78,
    "High": 128.71,
    "Low": 126.94
  },
  {
    "Date": "1/20/2021",
    "Close": 132.03,
    "Open": 128.66,
    "High": 132.49,
    "Low": 128.55
  },
  {
    "Date": "1/21/2021",
    "Close": 136.87,
    "Open": 133.8,
    "High": 139.67,
    "Low": 133.59
  },
  {
    "Date": "1/22/2021",
    "Close": 139.07,
    "Open": 136.28,
    "High": 139.85,
    "Low": 135.02
  },
  {
    "Date": "1/25/2021",
    "Close": 142.92,
    "Open": 143.07,
    "High": 145.09,
    "Low": 136.54
  },
  {
    "Date": "1/26/2021",
    "Close": 143.16,
    "Open": 143.6,
    "High": 144.3,
    "Low": 141.37
  },
  {
    "Date": "1/27/2021",
    "Close": 142.06,
    "Open": 143.43,
    "High": 144.3,
    "Low": 140.41
  },
  {
    "Date": "1/28/2021",
    "Close": 137.09,
    "Open": 139.52,
    "High": 141.99,
    "Low": 136.7
  },
  {
    "Date": "1/29/2021",
    "Close": 131.96,
    "Open": 135.83,
    "High": 136.74,
    "Low": 130.21
  },
  {
    "Date": "2/1/2021",
    "Close": 134.14,
    "Open": 133.75,
    "High": 135.38,
    "Low": 130.93
  },
  {
    "Date": "2/2/2021",
    "Close": 134.99,
    "Open": 135.73,
    "High": 136.31,
    "Low": 134.61
  },
  {
    "Date": "2/3/2021",
    "Close": 133.94,
    "Open": 135.76,
    "High": 135.77,
    "Low": 133.61
  },
  {
    "Date": "2/4/2021",
    "Close": 137.39,
    "Open": 136.3,
    "High": 137.4,
    "Low": 134.59
  },
  {
    "Date": "2/5/2021",
    "Close": 136.76,
    "Open": 137.35,
    "High": 137.42,
    "Low": 135.86
  },
  {
    "Date": "2/8/2021",
    "Close": 136.91,
    "Open": 136.03,
    "High": 136.96,
    "Low": 134.92
  },
  {
    "Date": "2/9/2021",
    "Close": 136.01,
    "Open": 136.62,
    "High": 137.88,
    "Low": 135.85
  },
  {
    "Date": "2/10/2021",
    "Close": 135.39,
    "Open": 136.48,
    "High": 136.99,
    "Low": 134.4
  },
  {
    "Date": "2/11/2021",
    "Close": 135.13,
    "Open": 135.9,
    "High": 136.39,
    "Low": 133.77
  },
  {
    "Date": "2/12/2021",
    "Close": 135.37,
    "Open": 134.35,
    "High": 135.53,
    "Low": 133.69
  },
  {
    "Date": "2/16/2021",
    "Close": 133.19,
    "Open": 135.49,
    "High": 136.01,
    "Low": 132.79
  },
  {
    "Date": "2/17/2021",
    "Close": 130.84,
    "Open": 131.25,
    "High": 132.22,
    "Low": 129.47
  },
  {
    "Date": "2/18/2021",
    "Close": 129.71,
    "Open": 129.2,
    "High": 130,
    "Low": 127.41
  },
  {
    "Date": "2/19/2021",
    "Close": 129.87,
    "Open": 130.24,
    "High": 130.71,
    "Low": 128.8
  },
  {
    "Date": "2/22/2021",
    "Close": 126,
    "Open": 128.01,
    "High": 129.72,
    "Low": 125.6
  },
  {
    "Date": "2/23/2021",
    "Close": 125.86,
    "Open": 123.76,
    "High": 126.71,
    "Low": 118.39
  },
  {
    "Date": "2/24/2021",
    "Close": 125.35,
    "Open": 124.94,
    "High": 125.56,
    "Low": 122.23
  },
  {
    "Date": "2/25/2021",
    "Close": 120.99,
    "Open": 124.68,
    "High": 126.46,
    "Low": 120.54
  },
  {
    "Date": "2/26/2021",
    "Close": 121.26,
    "Open": 122.59,
    "High": 124.85,
    "Low": 121.2
  },
  {
    "Date": "3/1/2021",
    "Close": 127.79,
    "Open": 123.75,
    "High": 127.93,
    "Low": 122.79
  },
  {
    "Date": "3/2/2021",
    "Close": 125.12,
    "Open": 128.41,
    "High": 128.72,
    "Low": 125.01
  },
  {
    "Date": "3/3/2021",
    "Close": 122.06,
    "Open": 124.81,
    "High": 125.71,
    "Low": 121.84
  },
  {
    "Date": "3/4/2021",
    "Close": 120.13,
    "Open": 121.75,
    "High": 123.6,
    "Low": 118.62
  },
  {
    "Date": "3/5/2021",
    "Close": 121.42,
    "Open": 120.98,
    "High": 121.94,
    "Low": 117.57
  },
  {
    "Date": "3/8/2021",
    "Close": 116.36,
    "Open": 120.93,
    "High": 121,
    "Low": 116.21
  },
  {
    "Date": "3/9/2021",
    "Close": 121.09,
    "Open": 119.03,
    "High": 122.06,
    "Low": 118.79
  },
  {
    "Date": "3/10/2021",
    "Close": 119.98,
    "Open": 121.69,
    "High": 122.17,
    "Low": 119.45
  },
  {
    "Date": "3/11/2021",
    "Close": 121.96,
    "Open": 122.54,
    "High": 123.21,
    "Low": 121.26
  },
  {
    "Date": "3/12/2021",
    "Close": 121.03,
    "Open": 120.4,
    "High": 121.17,
    "Low": 119.16
  },
  {
    "Date": "3/15/2021",
    "Close": 123.99,
    "Open": 121.41,
    "High": 124,
    "Low": 120.42
  },
  {
    "Date": "3/16/2021",
    "Close": 125.57,
    "Open": 125.7,
    "High": 127.22,
    "Low": 124.72
  },
  {
    "Date": "3/17/2021",
    "Close": 124.76,
    "Open": 124.05,
    "High": 125.86,
    "Low": 122.34
  },
  {
    "Date": "3/18/2021",
    "Close": 120.53,
    "Open": 122.88,
    "High": 123.18,
    "Low": 120.32
  },
  {
    "Date": "3/19/2021",
    "Close": 119.99,
    "Open": 119.9,
    "High": 121.43,
    "Low": 119.68
  },
  {
    "Date": "3/22/2021",
    "Close": 123.39,
    "Open": 120.33,
    "High": 123.87,
    "Low": 120.26
  },
  {
    "Date": "3/23/2021",
    "Close": 122.54,
    "Open": 123.33,
    "High": 124.24,
    "Low": 122.14
  },
  {
    "Date": "3/24/2021",
    "Close": 120.09,
    "Open": 122.82,
    "High": 122.9,
    "Low": 120.07
  },
  {
    "Date": "3/25/2021",
    "Close": 120.59,
    "Open": 119.54,
    "High": 121.66,
    "Low": 119
  },
  {
    "Date": "3/26/2021",
    "Close": 121.21,
    "Open": 120.35,
    "High": 121.48,
    "Low": 118.92
  },
  {
    "Date": "3/29/2021",
    "Close": 121.39,
    "Open": 121.65,
    "High": 122.58,
    "Low": 120.73
  },
  {
    "Date": "3/30/2021",
    "Close": 119.9,
    "Open": 120.11,
    "High": 120.4,
    "Low": 118.86
  },
  {
    "Date": "3/31/2021",
    "Close": 122.15,
    "Open": 121.65,
    "High": 123.52,
    "Low": 121.15
  },
  {
    "Date": "4/1/2021",
    "Close": 123,
    "Open": 123.66,
    "High": 124.18,
    "Low": 122.49
  },
  {
    "Date": "4/5/2021",
    "Close": 125.9,
    "Open": 123.87,
    "High": 126.16,
    "Low": 123.07
  },
  {
    "Date": "4/6/2021",
    "Close": 126.21,
    "Open": 126.5,
    "High": 127.13,
    "Low": 125.65
  },
  {
    "Date": "4/7/2021",
    "Close": 127.9,
    "Open": 125.83,
    "High": 127.92,
    "Low": 125.14
  },
  {
    "Date": "4/8/2021",
    "Close": 130.36,
    "Open": 128.95,
    "High": 130.39,
    "Low": 128.52
  },
  {
    "Date": "4/9/2021",
    "Close": 133,
    "Open": 129.8,
    "High": 133.04,
    "Low": 129.47
  },
  {
    "Date": "4/12/2021",
    "Close": 131.24,
    "Open": 132.52,
    "High": 132.85,
    "Low": 130.63
  },
  {
    "Date": "4/13/2021",
    "Close": 134.43,
    "Open": 132.44,
    "High": 134.66,
    "Low": 131.93
  },
  {
    "Date": "4/14/2021",
    "Close": 132.03,
    "Open": 134.94,
    "High": 135,
    "Low": 131.66
  },
  {
    "Date": "4/15/2021",
    "Close": 134.5,
    "Open": 133.82,
    "High": 135,
    "Low": 133.64
  },
  {
    "Date": "4/16/2021",
    "Close": 134.16,
    "Open": 134.3,
    "High": 134.67,
    "Low": 133.28
  },
  {
    "Date": "4/19/2021",
    "Close": 134.84,
    "Open": 133.51,
    "High": 135.47,
    "Low": 133.34
  },
  {
    "Date": "4/20/2021",
    "Close": 133.11,
    "Open": 135.02,
    "High": 135.53,
    "Low": 131.81
  },
  {
    "Date": "4/21/2021",
    "Close": 133.5,
    "Open": 132.36,
    "High": 133.75,
    "Low": 131.3
  },
  {
    "Date": "4/22/2021",
    "Close": 131.94,
    "Open": 133.04,
    "High": 134.15,
    "Low": 131.41
  },
  {
    "Date": "4/23/2021",
    "Close": 134.32,
    "Open": 132.16,
    "High": 135.12,
    "Low": 132.16
  },
  {
    "Date": "4/26/2021",
    "Close": 134.72,
    "Open": 134.83,
    "High": 135.06,
    "Low": 133.56
  },
  {
    "Date": "4/27/2021",
    "Close": 134.39,
    "Open": 135.01,
    "High": 135.41,
    "Low": 134.11
  },
  {
    "Date": "4/28/2021",
    "Close": 133.58,
    "Open": 134.31,
    "High": 135.02,
    "Low": 133.08
  },
  {
    "Date": "4/29/2021",
    "Close": 133.48,
    "Open": 136.47,
    "High": 137.07,
    "Low": 132.45
  },
  {
    "Date": "4/30/2021",
    "Close": 131.46,
    "Open": 131.78,
    "High": 133.56,
    "Low": 131.07
  },
  {
    "Date": "5/3/2021",
    "Close": 132.54,
    "Open": 132.04,
    "High": 134.07,
    "Low": 131.83
  },
  {
    "Date": "5/4/2021",
    "Close": 127.85,
    "Open": 131.19,
    "High": 131.49,
    "Low": 126.7
  },
  {
    "Date": "5/5/2021",
    "Close": 128.1,
    "Open": 129.2,
    "High": 130.45,
    "Low": 127.97
  },
  {
    "Date": "5/6/2021",
    "Close": 129.74,
    "Open": 127.89,
    "High": 129.75,
    "Low": 127.13
  },
  {
    "Date": "5/7/2021",
    "Close": 130.21,
    "Open": 130.85,
    "High": 131.26,
    "Low": 129.48
  },
  {
    "Date": "5/10/2021",
    "Close": 126.85,
    "Open": 129.41,
    "High": 129.54,
    "Low": 126.81
  },
  {
    "Date": "5/11/2021",
    "Close": 125.91,
    "Open": 123.5,
    "High": 126.27,
    "Low": 122.77
  },
  {
    "Date": "5/12/2021",
    "Close": 122.77,
    "Open": 123.4,
    "High": 124.64,
    "Low": 122.25
  },
  {
    "Date": "5/13/2021",
    "Close": 124.97,
    "Open": 124.58,
    "High": 126.15,
    "Low": 124.26
  },
  {
    "Date": "5/14/2021",
    "Close": 127.45,
    "Open": 126.25,
    "High": 127.89,
    "Low": 125.85
  },
  {
    "Date": "5/17/2021",
    "Close": 126.27,
    "Open": 126.82,
    "High": 126.93,
    "Low": 125.17
  },
  {
    "Date": "5/18/2021",
    "Close": 124.85,
    "Open": 126.56,
    "High": 126.99,
    "Low": 124.78
  },
  {
    "Date": "5/19/2021",
    "Close": 124.69,
    "Open": 123.16,
    "High": 124.92,
    "Low": 122.86
  },
  {
    "Date": "5/20/2021",
    "Close": 127.31,
    "Open": 125.23,
    "High": 127.72,
    "Low": 125.1
  },
  {
    "Date": "5/21/2021",
    "Close": 125.43,
    "Open": 127.82,
    "High": 128,
    "Low": 125.21
  },
  {
    "Date": "5/24/2021",
    "Close": 127.1,
    "Open": 126.01,
    "High": 127.94,
    "Low": 125.94
  },
  {
    "Date": "5/25/2021",
    "Close": 126.9,
    "Open": 127.82,
    "High": 128.32,
    "Low": 126.32
  },
  {
    "Date": "5/26/2021",
    "Close": 126.85,
    "Open": 126.96,
    "High": 127.39,
    "Low": 126.42
  },
  {
    "Date": "5/27/2021",
    "Close": 125.28,
    "Open": 126.44,
    "High": 127.64,
    "Low": 125.08
  },
  {
    "Date": "5/28/2021",
    "Close": 124.61,
    "Open": 125.57,
    "High": 125.8,
    "Low": 124.55
  },
  {
    "Date": "6/1/2021",
    "Close": 124.28,
    "Open": 125.08,
    "High": 125.35,
    "Low": 123.94
  },
  {
    "Date": "6/2/2021",
    "Close": 125.06,
    "Open": 124.28,
    "High": 125.24,
    "Low": 124.05
  },
  {
    "Date": "6/3/2021",
    "Close": 123.54,
    "Open": 124.68,
    "High": 124.85,
    "Low": 123.13
  },
  {
    "Date": "6/4/2021",
    "Close": 125.89,
    "Open": 124.07,
    "High": 126.16,
    "Low": 123.85
  },
  {
    "Date": "6/7/2021",
    "Close": 125.9,
    "Open": 126.17,
    "High": 126.32,
    "Low": 124.83
  },
  {
    "Date": "6/8/2021",
    "Close": 126.74,
    "Open": 126.6,
    "High": 128.46,
    "Low": 126.21
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'StockPrice'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (StockPrice) and the Plot Type as 'High Low Close'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the High, Low, Open, and Close data values as follows, and click Next.
    Data Values | Field | Aggregate | Caption
    High | [High] | None | High
    Low | [Low] | None | Low
    Close | [Close] | None | Close
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Date] and Sorting to 'Ascending'
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.

    High Low Close Chart Dialog Box
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Add Customizations to Chart

Chart Data

  1. In the Chart Data area, select the series value.
  2. Go to Properties Panel and set following properties under Appearance > LineStyle:
    • Style: Solid
    • Color: #8fcd37
    • Width: 1pt

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General page and set the Format to 'Currency (with 0 decimal points)'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 10
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Short Date
    • Angle: -45
  4. Now, navigate to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 7 (to view weekly stock prices)
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Stock Price'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


High Low Open Close Chart

High Low Open Close Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > High Low Open Close Chart

Glossary Item Box

HighLowOpenClose charts help to portray the price movements of a security, currency, or derivative over time with clarity. Though these are quite similar to the candlestick charts, a striking feature of the HighLowOpenClose charts is that they show the opening values using lines to the left, and closing values using lines to the right. The vertical line size is determined by the High and Low values. A suitable example for the HighLowOpenClose plot type is the movement of the stock price of a virtual company.

High Low Open Close Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create High Low Open Close Chart

Create High Low Open Close Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > High Low Open Close Chart > Create High Low Open Close Chart

Glossary Item Box

This walkthrough creates a High Low Open Close Chart. The chart shows the movement of stock price for a certain company over time. In the high low open close chart, the upper and the lower ends of the line represent the high and low values, while the markers on the left and right of the line represent the opening and closing values. The final chart appears like this:

High Low Open Close Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
  {
    "Date": "1/4/2021",
    "Close": 129.41,
    "Open": 133.52,
    "High": 133.61,
    "Low": 126.76
  },
  {
    "Date": "1/5/2021",
    "Close": 131.01,
    "Open": 128.89,
    "High": 131.74,
    "Low": 128.43
  },
  {
    "Date": "1/6/2021",
    "Close": 126.6,
    "Open": 127.72,
    "High": 131.05,
    "Low": 126.38
  },
  {
    "Date": "1/7/2021",
    "Close": 130.92,
    "Open": 128.36,
    "High": 131.63,
    "Low": 127.86
  },
  {
    "Date": "1/8/2021",
    "Close": 132.05,
    "Open": 132.43,
    "High": 132.63,
    "Low": 130.23
  },
  {
    "Date": "1/11/2021",
    "Close": 128.98,
    "Open": 129.19,
    "High": 130.17,
    "Low": 128.5
  },
  {
    "Date": "1/12/2021",
    "Close": 128.8,
    "Open": 128.5,
    "High": 129.69,
    "Low": 126.86
  },
  {
    "Date": "1/13/2021",
    "Close": 130.89,
    "Open": 128.76,
    "High": 131.45,
    "Low": 128.49
  },
  {
    "Date": "1/14/2021",
    "Close": 128.91,
    "Open": 130.8,
    "High": 131,
    "Low": 128.76
  },
  {
    "Date": "1/15/2021",
    "Close": 127.14,
    "Open": 128.78,
    "High": 130.22,
    "Low": 127
  },
  {
    "Date": "1/19/2021",
    "Close": 127.83,
    "Open": 127.78,
    "High": 128.71,
    "Low": 126.94
  },
  {
    "Date": "1/20/2021",
    "Close": 132.03,
    "Open": 128.66,
    "High": 132.49,
    "Low": 128.55
  },
  {
    "Date": "1/21/2021",
    "Close": 136.87,
    "Open": 133.8,
    "High": 139.67,
    "Low": 133.59
  },
  {
    "Date": "1/22/2021",
    "Close": 139.07,
    "Open": 136.28,
    "High": 139.85,
    "Low": 135.02
  },
  {
    "Date": "1/25/2021",
    "Close": 142.92,
    "Open": 143.07,
    "High": 145.09,
    "Low": 136.54
  },
  {
    "Date": "1/26/2021",
    "Close": 143.16,
    "Open": 143.6,
    "High": 144.3,
    "Low": 141.37
  },
  {
    "Date": "1/27/2021",
    "Close": 142.06,
    "Open": 143.43,
    "High": 144.3,
    "Low": 140.41
  },
  {
    "Date": "1/28/2021",
    "Close": 137.09,
    "Open": 139.52,
    "High": 141.99,
    "Low": 136.7
  },
  {
    "Date": "1/29/2021",
    "Close": 131.96,
    "Open": 135.83,
    "High": 136.74,
    "Low": 130.21
  },
  {
    "Date": "2/1/2021",
    "Close": 134.14,
    "Open": 133.75,
    "High": 135.38,
    "Low": 130.93
  },
  {
    "Date": "2/2/2021",
    "Close": 134.99,
    "Open": 135.73,
    "High": 136.31,
    "Low": 134.61
  },
  {
    "Date": "2/3/2021",
    "Close": 133.94,
    "Open": 135.76,
    "High": 135.77,
    "Low": 133.61
  },
  {
    "Date": "2/4/2021",
    "Close": 137.39,
    "Open": 136.3,
    "High": 137.4,
    "Low": 134.59
  },
  {
    "Date": "2/5/2021",
    "Close": 136.76,
    "Open": 137.35,
    "High": 137.42,
    "Low": 135.86
  },
  {
    "Date": "2/8/2021",
    "Close": 136.91,
    "Open": 136.03,
    "High": 136.96,
    "Low": 134.92
  },
  {
    "Date": "2/9/2021",
    "Close": 136.01,
    "Open": 136.62,
    "High": 137.88,
    "Low": 135.85
  },
  {
    "Date": "2/10/2021",
    "Close": 135.39,
    "Open": 136.48,
    "High": 136.99,
    "Low": 134.4
  },
  {
    "Date": "2/11/2021",
    "Close": 135.13,
    "Open": 135.9,
    "High": 136.39,
    "Low": 133.77
  },
  {
    "Date": "2/12/2021",
    "Close": 135.37,
    "Open": 134.35,
    "High": 135.53,
    "Low": 133.69
  },
  {
    "Date": "2/16/2021",
    "Close": 133.19,
    "Open": 135.49,
    "High": 136.01,
    "Low": 132.79
  },
  {
    "Date": "2/17/2021",
    "Close": 130.84,
    "Open": 131.25,
    "High": 132.22,
    "Low": 129.47
  },
  {
    "Date": "2/18/2021",
    "Close": 129.71,
    "Open": 129.2,
    "High": 130,
    "Low": 127.41
  },
  {
    "Date": "2/19/2021",
    "Close": 129.87,
    "Open": 130.24,
    "High": 130.71,
    "Low": 128.8
  },
  {
    "Date": "2/22/2021",
    "Close": 126,
    "Open": 128.01,
    "High": 129.72,
    "Low": 125.6
  },
  {
    "Date": "2/23/2021",
    "Close": 125.86,
    "Open": 123.76,
    "High": 126.71,
    "Low": 118.39
  },
  {
    "Date": "2/24/2021",
    "Close": 125.35,
    "Open": 124.94,
    "High": 125.56,
    "Low": 122.23
  },
  {
    "Date": "2/25/2021",
    "Close": 120.99,
    "Open": 124.68,
    "High": 126.46,
    "Low": 120.54
  },
  {
    "Date": "2/26/2021",
    "Close": 121.26,
    "Open": 122.59,
    "High": 124.85,
    "Low": 121.2
  },
  {
    "Date": "3/1/2021",
    "Close": 127.79,
    "Open": 123.75,
    "High": 127.93,
    "Low": 122.79
  },
  {
    "Date": "3/2/2021",
    "Close": 125.12,
    "Open": 128.41,
    "High": 128.72,
    "Low": 125.01
  },
  {
    "Date": "3/3/2021",
    "Close": 122.06,
    "Open": 124.81,
    "High": 125.71,
    "Low": 121.84
  },
  {
    "Date": "3/4/2021",
    "Close": 120.13,
    "Open": 121.75,
    "High": 123.6,
    "Low": 118.62
  },
  {
    "Date": "3/5/2021",
    "Close": 121.42,
    "Open": 120.98,
    "High": 121.94,
    "Low": 117.57
  },
  {
    "Date": "3/8/2021",
    "Close": 116.36,
    "Open": 120.93,
    "High": 121,
    "Low": 116.21
  },
  {
    "Date": "3/9/2021",
    "Close": 121.09,
    "Open": 119.03,
    "High": 122.06,
    "Low": 118.79
  },
  {
    "Date": "3/10/2021",
    "Close": 119.98,
    "Open": 121.69,
    "High": 122.17,
    "Low": 119.45
  },
  {
    "Date": "3/11/2021",
    "Close": 121.96,
    "Open": 122.54,
    "High": 123.21,
    "Low": 121.26
  },
  {
    "Date": "3/12/2021",
    "Close": 121.03,
    "Open": 120.4,
    "High": 121.17,
    "Low": 119.16
  },
  {
    "Date": "3/15/2021",
    "Close": 123.99,
    "Open": 121.41,
    "High": 124,
    "Low": 120.42
  },
  {
    "Date": "3/16/2021",
    "Close": 125.57,
    "Open": 125.7,
    "High": 127.22,
    "Low": 124.72
  },
  {
    "Date": "3/17/2021",
    "Close": 124.76,
    "Open": 124.05,
    "High": 125.86,
    "Low": 122.34
  },
  {
    "Date": "3/18/2021",
    "Close": 120.53,
    "Open": 122.88,
    "High": 123.18,
    "Low": 120.32
  },
  {
    "Date": "3/19/2021",
    "Close": 119.99,
    "Open": 119.9,
    "High": 121.43,
    "Low": 119.68
  },
  {
    "Date": "3/22/2021",
    "Close": 123.39,
    "Open": 120.33,
    "High": 123.87,
    "Low": 120.26
  },
  {
    "Date": "3/23/2021",
    "Close": 122.54,
    "Open": 123.33,
    "High": 124.24,
    "Low": 122.14
  },
  {
    "Date": "3/24/2021",
    "Close": 120.09,
    "Open": 122.82,
    "High": 122.9,
    "Low": 120.07
  },
  {
    "Date": "3/25/2021",
    "Close": 120.59,
    "Open": 119.54,
    "High": 121.66,
    "Low": 119
  },
  {
    "Date": "3/26/2021",
    "Close": 121.21,
    "Open": 120.35,
    "High": 121.48,
    "Low": 118.92
  },
  {
    "Date": "3/29/2021",
    "Close": 121.39,
    "Open": 121.65,
    "High": 122.58,
    "Low": 120.73
  },
  {
    "Date": "3/30/2021",
    "Close": 119.9,
    "Open": 120.11,
    "High": 120.4,
    "Low": 118.86
  },
  {
    "Date": "3/31/2021",
    "Close": 122.15,
    "Open": 121.65,
    "High": 123.52,
    "Low": 121.15
  },
  {
    "Date": "4/1/2021",
    "Close": 123,
    "Open": 123.66,
    "High": 124.18,
    "Low": 122.49
  },
  {
    "Date": "4/5/2021",
    "Close": 125.9,
    "Open": 123.87,
    "High": 126.16,
    "Low": 123.07
  },
  {
    "Date": "4/6/2021",
    "Close": 126.21,
    "Open": 126.5,
    "High": 127.13,
    "Low": 125.65
  },
  {
    "Date": "4/7/2021",
    "Close": 127.9,
    "Open": 125.83,
    "High": 127.92,
    "Low": 125.14
  },
  {
    "Date": "4/8/2021",
    "Close": 130.36,
    "Open": 128.95,
    "High": 130.39,
    "Low": 128.52
  },
  {
    "Date": "4/9/2021",
    "Close": 133,
    "Open": 129.8,
    "High": 133.04,
    "Low": 129.47
  },
  {
    "Date": "4/12/2021",
    "Close": 131.24,
    "Open": 132.52,
    "High": 132.85,
    "Low": 130.63
  },
  {
    "Date": "4/13/2021",
    "Close": 134.43,
    "Open": 132.44,
    "High": 134.66,
    "Low": 131.93
  },
  {
    "Date": "4/14/2021",
    "Close": 132.03,
    "Open": 134.94,
    "High": 135,
    "Low": 131.66
  },
  {
    "Date": "4/15/2021",
    "Close": 134.5,
    "Open": 133.82,
    "High": 135,
    "Low": 133.64
  },
  {
    "Date": "4/16/2021",
    "Close": 134.16,
    "Open": 134.3,
    "High": 134.67,
    "Low": 133.28
  },
  {
    "Date": "4/19/2021",
    "Close": 134.84,
    "Open": 133.51,
    "High": 135.47,
    "Low": 133.34
  },
  {
    "Date": "4/20/2021",
    "Close": 133.11,
    "Open": 135.02,
    "High": 135.53,
    "Low": 131.81
  },
  {
    "Date": "4/21/2021",
    "Close": 133.5,
    "Open": 132.36,
    "High": 133.75,
    "Low": 131.3
  },
  {
    "Date": "4/22/2021",
    "Close": 131.94,
    "Open": 133.04,
    "High": 134.15,
    "Low": 131.41
  },
  {
    "Date": "4/23/2021",
    "Close": 134.32,
    "Open": 132.16,
    "High": 135.12,
    "Low": 132.16
  },
  {
    "Date": "4/26/2021",
    "Close": 134.72,
    "Open": 134.83,
    "High": 135.06,
    "Low": 133.56
  },
  {
    "Date": "4/27/2021",
    "Close": 134.39,
    "Open": 135.01,
    "High": 135.41,
    "Low": 134.11
  },
  {
    "Date": "4/28/2021",
    "Close": 133.58,
    "Open": 134.31,
    "High": 135.02,
    "Low": 133.08
  },
  {
    "Date": "4/29/2021",
    "Close": 133.48,
    "Open": 136.47,
    "High": 137.07,
    "Low": 132.45
  },
  {
    "Date": "4/30/2021",
    "Close": 131.46,
    "Open": 131.78,
    "High": 133.56,
    "Low": 131.07
  },
  {
    "Date": "5/3/2021",
    "Close": 132.54,
    "Open": 132.04,
    "High": 134.07,
    "Low": 131.83
  },
  {
    "Date": "5/4/2021",
    "Close": 127.85,
    "Open": 131.19,
    "High": 131.49,
    "Low": 126.7
  },
  {
    "Date": "5/5/2021",
    "Close": 128.1,
    "Open": 129.2,
    "High": 130.45,
    "Low": 127.97
  },
  {
    "Date": "5/6/2021",
    "Close": 129.74,
    "Open": 127.89,
    "High": 129.75,
    "Low": 127.13
  },
  {
    "Date": "5/7/2021",
    "Close": 130.21,
    "Open": 130.85,
    "High": 131.26,
    "Low": 129.48
  },
  {
    "Date": "5/10/2021",
    "Close": 126.85,
    "Open": 129.41,
    "High": 129.54,
    "Low": 126.81
  },
  {
    "Date": "5/11/2021",
    "Close": 125.91,
    "Open": 123.5,
    "High": 126.27,
    "Low": 122.77
  },
  {
    "Date": "5/12/2021",
    "Close": 122.77,
    "Open": 123.4,
    "High": 124.64,
    "Low": 122.25
  },
  {
    "Date": "5/13/2021",
    "Close": 124.97,
    "Open": 124.58,
    "High": 126.15,
    "Low": 124.26
  },
  {
    "Date": "5/14/2021",
    "Close": 127.45,
    "Open": 126.25,
    "High": 127.89,
    "Low": 125.85
  },
  {
    "Date": "5/17/2021",
    "Close": 126.27,
    "Open": 126.82,
    "High": 126.93,
    "Low": 125.17
  },
  {
    "Date": "5/18/2021",
    "Close": 124.85,
    "Open": 126.56,
    "High": 126.99,
    "Low": 124.78
  },
  {
    "Date": "5/19/2021",
    "Close": 124.69,
    "Open": 123.16,
    "High": 124.92,
    "Low": 122.86
  },
  {
    "Date": "5/20/2021",
    "Close": 127.31,
    "Open": 125.23,
    "High": 127.72,
    "Low": 125.1
  },
  {
    "Date": "5/21/2021",
    "Close": 125.43,
    "Open": 127.82,
    "High": 128,
    "Low": 125.21
  },
  {
    "Date": "5/24/2021",
    "Close": 127.1,
    "Open": 126.01,
    "High": 127.94,
    "Low": 125.94
  },
  {
    "Date": "5/25/2021",
    "Close": 126.9,
    "Open": 127.82,
    "High": 128.32,
    "Low": 126.32
  },
  {
    "Date": "5/26/2021",
    "Close": 126.85,
    "Open": 126.96,
    "High": 127.39,
    "Low": 126.42
  },
  {
    "Date": "5/27/2021",
    "Close": 125.28,
    "Open": 126.44,
    "High": 127.64,
    "Low": 125.08
  },
  {
    "Date": "5/28/2021",
    "Close": 124.61,
    "Open": 125.57,
    "High": 125.8,
    "Low": 124.55
  },
  {
    "Date": "6/1/2021",
    "Close": 124.28,
    "Open": 125.08,
    "High": 125.35,
    "Low": 123.94
  },
  {
    "Date": "6/2/2021",
    "Close": 125.06,
    "Open": 124.28,
    "High": 125.24,
    "Low": 124.05
  },
  {
    "Date": "6/3/2021",
    "Close": 123.54,
    "Open": 124.68,
    "High": 124.85,
    "Low": 123.13
  },
  {
    "Date": "6/4/2021",
    "Close": 125.89,
    "Open": 124.07,
    "High": 126.16,
    "Low": 123.85
  },
  {
    "Date": "6/7/2021",
    "Close": 125.9,
    "Open": 126.17,
    "High": 126.32,
    "Low": 124.83
  },
  {
    "Date": "6/8/2021",
    "Close": 126.74,
    "Open": 126.6,
    "High": 128.46,
    "Low": 126.21
  }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'StockPrice'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (StockPrice) and the Plot Type as 'High Low Open Close'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the High, Low, Open, and Close data values as follows, and click Next.
    Data Values | Field | Aggregate | Caption
    High | [High] | None | High
    Low | [Low] | None | Low
    Open | [Open] | None | Open
    Close | [Close] | None | Close
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Date] and Sorting to 'Ascending'
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    High Low Open Close Chart
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Add Customizations to Chart

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Chart Data

  1. In the Chart Data area, select the series value.
  2. Go to Properties Panel and set following properties under Appearance > LineStyle:
    • Style: Solid
    • Color: #8fcd37
    • Width: 1pt

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the Y-axis title in the chart.
  3. Go to the Labels page > General page and set the Format to 'Currency (with 0 decimal points)'.
  4. Navigate to the Appearance tab and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 10
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and remove the text from the Title field to hide the X-axis title in the chart.
  3. Go to the Labels page > General tab and set the following properties.
    • Format: Short Date
    • Angle: -45
  4. Now, navigate to the Appearance page and set the following properties.
    • Font > Size: 12pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties.
    • Show Line: Check-on
    • Color: Black
    • Width: 1pt
    • Style: Solid
  6. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 7 (to view weekly stock prices)
    • Grid appearance > Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
    • Tick mark appearance > Position: Outside
    • Tick mark appearance > Color: #cccccc
    • Tick mark appearance > Width: 0.25pt
    • Tick mark appearance > Style: Solid
  7. Click OK to complete setting up the X-axis.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to 'Stock Price'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Range Charts

Range Charts
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Range Charts

Glossary Item Box

Range Charts display a pair of values (low and high) for each data point to visualize a range of values rather than a single value. These charts emphasize the distance (range) between the two values.

Range Bar

Range Bar Chart is a variation of regular Bar Chart. While the Range Bar Chart visualizes two values along the horizontal axis at a time — a low value and a high value, in Bar chart, the values are plotted on the horizontal axis one by one. The Create Range Bar Chart walkthrough showcases plotting the average daytime hours across one year.

Range Bar Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Range Column

Range Column Chart is a variation of regular Column Chart. While the Range Column Chart visualizes two values on the vertical axis at a time — a low value and a high value, in Column chart, the values are plotted on the vertical axis one by one.

Range Column Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Range Area

Range Area chart is a variation of regular Area Chart. While the filled area in Range Area chart is between its lowest and highest values, in Area chart, the filled area is between the line segments plotted by data values and the horizontal axis.

Range Area Chart
Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The Range Area Chart fills in the area between the top and the bottom value for each data point.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Range Bar Chart

Create Range Bar Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Range Charts > Create Range Bar Chart

Glossary Item Box

This walkthrough shows creating a Range Bar chart. The final chart appears like this:

Range Bar Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Csv Provider'.
    For more information, see the CSV topic.
  3. Go to the Connection String tab and click Build
  4. In the Path field, navigate to the CSV file with content: weatherdata.csv
  5. Click Get from preview and edit the Data Type column for the following fields as shown.
    Name | Data Type
    DATE | DateTime
    CITY | String
    AVG MIN TEMP | Float
    AVG MAX TEMP | Float
    RAINFALL Min | Float
    RAINFALL Max | Float
    SUNRISE | DateTime
    SUNSET | DateTime
  6. Click OK to view the generated connection string, which will be similar to the following:
    Connection String Copy Code
    Path=C:\\Data\\weatherdata.csv;Locale=en-US;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;Columns=DATE(DateTime),CITY,AVG MIN TEMP,AVG MAX TEMP,RAINFALL Min,RAINFALL Max,SUNRISE,SUNSET;HasHeaders=True
  7. Click OK to complete connecting to data.

Create Basic Structure of Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (weatherdata) and the Plot Type as 'Range Bar'.
  3. Click Next to configure data values.
  4. Under Configure Chart Data Values, set the start and end fields. and click Next.
    Start Field | End Field | Caption
    =Fields!SUNRISE.Value | =Fields!SUNSET.Value | Start, End
  5. In the Configure Chart Data Groupings, set the Categories > Group By to [Date] and Sorting to 'Ascending'
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Range Bar Chart

Add Customizations to Chart

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels. range-bar-design.png

Add Filter to Chart

  1. Right-click the 'weatherdata' dataset and select Edit.
  2. Go to Filters page and add following two filters:
    S.no. | Expression | Operator | Value
    1. | =Fields!CITY.Value | Equal | MelbourneAirport
    2. | =Year(Fields!DATE.Value) | Equal | 2015
  3. Now that the filters are added in the dataset, click OK.

Chart Data

  1. From Category Groups area, right-click [DATE].
  2. In the General page, edit the expression to =MonthName(Month([DATE])).
  3. Go to the Categories page and in the Sorting > Sorting field, select =Fields!DATE.Value field and set the Sort direction to 'Ascending'.
  4. Click OK to complete setting up the plot.

Y-Axis

  1. To open the smart panel, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page. Enter the text in the Title field as 'Sunrise-Sunset Time' and set Color to 'DimGray'.
  3. Go to the Labels page > General tab and set Format to 'HH:MM'.
  4. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 9pt
    • Font > Color: DimGray
  5. Go to the Major Gridline page and set the following properties.
    • Show grid: Check-on
    • Grid appearance > Color: #cccccc
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Style: Dashed
  6. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and edit the text in the Title field to 'Month' and set Color to 'DimGray'.
  3. Go to the Labels page > Appearance tab and set Font > Color to DimGray.

Chart Palette

  1. To open the smart panel, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page and select 'Aspect'
  3. Click OK to complete setting up the chart palette.

Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set the Title to the following expression:
    Copy Code
    ="Monthly Average Daytime Hours for the Year " & Parameters!YearParameter.Value
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Gauge Chart

Gauge Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Gauge Chart

Glossary Item Box

A Gauge chart is a Bar chart with a radial axis and overlapping bars to show ranges. It uses the needle and the dial to represent the data. The direction of the needle and the colors in the dial shows the performance at a glance.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Gauge Chart

Create Gauge Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Plots > Gauge Chart > Create Gauge Chart

Glossary Item Box

This walkthrough shows creating a Gauge chart. The Gauge chart is placed in a multi-column list to show the units in stock in each category of products. The final chart appears like this:

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'External file or URL'.
  4. In the Select or type the file name or URL field, enter the following URL:
    https://demodata.mescius.io/northwind/api/v1/Products
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Data Source icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Products'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Similarly, we will connect to another data source from where we will fetch [categoryName] corresponding to the [categoryId] in 'Products' dataset, in the Chart Header.

The data source URL is https://demodata.mescius.io/northwind/api/v1/Categories and the dataset query is $.[*]. Let's name this dataset, 'Categories'.

Design Report Layout

  1. Drag-drop the List data region.
  2. In the Properties panel, set the following properties:
    Property | Value
    DataSetName | Products
    GrowDirection | Column
    RowsOrColumnsCount | 4
  3. With List data region selected, click Property dialog.
  4. Go to Detail Grouping page, and in the General tab, provide a Name to the group and in the Group on: Expression, select =[categoryId].
  5. Go to the Sorting tab and add a sorting Expression =[categoryId] and Direction as 'Ascending'.

Create a Chart

We will use the Chart Wizard dialog to configure chart data values and basic customization. If you have a dataset added to your report, on Chart's drag-drop operation, the wizard appears. See the topic on Chart Wizard for more information. You can make further adjustments to the chart after you exit the wizard by accessing the properties of chart elements through dialogs, property panels, and adorners.

  1. Drag-drop Chart data region onto the design area. The New Chart dialog appears with an option to select the query and the plot type.
  2. Select the Query as the dataset name (Products) and the Plot Type as 'Gauge'.
  3. Click Next to configure data values.
  4. Under Configure Gauge Pointers, add Field as [unitsInStock], Aggregate as 'Sum', and click Next.
  5. In the Specify Range Boundaries From Max To Min, add any field. We will add Ranges later.
  6. Click Next and Choose Report Colors from Theme and Style, and preview your chart.
    Gauge Chart Dialog Box
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Add Customizations to Chart

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Ranges

  1. Right-click the Ranges area and to define the constant data values to display the ranges on the gauge's dial, add four data values, and set Value and Caption as follows:
    • 800
    • 600
    • 400
    • 200
      Set Aggregate as 'Max' for all the above fields.

    Note: The first field should be the one with greater value.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. In Palette, select Custom from the drop-down and add the following four colors for each value.
    • RoyalBlue
    • Green
    • Orange
    • Red
  3. Click OK to complete setting up the custom chart palette.

Plot Settings

  1. To set a needle color, go to Gauge Pointers property.
  2. In the PointerDesigner Collection Editor, go to BackgroundColor property and set 'SlateBlue'.

Header

We want chart header to display the category name from another dataset, 'Categories'. For this, we will use Lookup expression.

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Title to the following expression:
    Copy Code
    =Lookup(Fields!categoryId.Value,Fields!categoryId.Value,Fields!categoryName.Value,"Categories")
  3. Go to the Font page and set the properties as below.
    • Size: 11pt
    • Color: #551e5f
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart and customize other chart elements. Once you are done, press F5 to preview the report.
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Axes

Axes
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Axes

Glossary Item Box

Being an essential part of most chart types, the Axis can perform the following functions:

  • Provide a coordinate system for one or multiple plots.
  • Display measuring units for the data to be visualized.
  • Produce the grid lines.

General Axis Properties

Appearance

Height: Represents the height of the Axis in percentage relative to the overall chart height. This property is applicable to the horizontal axis.

MaxHeight: Represents the maximum height of the Axis in percentage relative to the overall chart height. This property applies to the horizontal axis and its default value is 100%.

MaxWidth: Represents the maximum width of the Axis in percentage relative to the overall chart width. This property applies to the vertical axis and its default value is 100%.

Width: Represents width of the Axis in percentage relative to the overall chart width. This property applies to the vertical axis.

See the section Set Position of Axis to know about customizing the position of Y-axis.

Common

AxisType: Designates the type of Axis, whether be it X or Y.

DateMode: Axis Date mode to set the size of the time span of the axis. This property works only in these charts when they do not have any categories: Bar, Scatter, Line, Area, Range area, Range bar, Text, Funnel, Pyramid, HLOC, Candlestick, Pie, and Donut.

Plots: Designates the plot in which the X or Y axis exists.

Labels

Format: Represents the formatting string used for rendering dates and numbers.

LabelRowCount: Sets the number of rows for axis labels, ranging from 1 to 10 for a multi-row arrangement. This property is supported in Column, Area, Line, Scatter, Bubble, Candlestick, High Low Close, High Low Open Close, Range Column, and Range Area charts, for X-Axis.

LabelsAngle: Represents the rotation angle of axis labels in degrees.

LabelsStyle: Represents the style of the axis labels

  • Color: The label text color.
  • Font: The font properties for the label.
  • Padding: The padding to place between the label text and the axis.
  • TextDecoration: The decorative lines on the label text.
  • WritingMode: The horizontal (lr-tb) or vertical direction (tb-rl) of the label text. The default value is lr-tb (left to right top to bottom). If set to tb-lr (top to bottom left to right), the chart axis labels appear vertically.

ShowLabels: Indicate whether to show or hide axis labels.

Layout

Origin: Represents the value or ordinal number at which both the axes cross each other.

Overlapping: Indicates whether the labels can be overlapped.

Position: Indicates the axis position.

  • Far
  • Near
  • None

Reversed: Indicates whether the axis is reversed from top to bottom, or left to right.

Line

LineStyle: Select the style of the line.

  • LineColor: The line color.
  • LineStyle: The style of the line.
  • LineWidth: The width of the line.

ShowLine: Indicates whether or not to show the line.

Major Grid

MajorGridInterval: Number of units between the major axis ticks.

MajorGridStyle: Style of the major gridline.

MajorTickMark: Location of the major grid tick marks, inside the plot area, outside the plot area, or across the axis.

MajorTickSize: Length of the major grid tick marks.

MajorTickStyle: Style of the major grid ticks.

ShowMajorGrid: Indicates whether or not to show the major gridlines.

Minor Grid

MinorGridInterval: Number of units between minor axis ticks.

MinorGridStyle: Style of the minor grid line.

MinorTickMark: Location of the minor grid line tick marks, inside the plot area, outside the plot area, or across the axis.

MinorTickSize: Length of the minor gridline tick marks.

MinorTickStyle: Style of the minor grid ticks.

ShowMinorGrid: Indicates whether or not to show the minor gridlines.

Scale

LogarithmicBase: Represents the axis logarithmic base for logarithmic scale.

Max: Shows the maximum axis value.

Min: Shows the minimum axis value.

Scale: Represents the scale of the axis.

  • Linear: In the Linear scale type, the values are evenly distributed along the axis. It is the default scale type. The Create Clustered Bar Chart walkthrough sets the Linear scale on Y-axis.
  • Logarithmic: In the Logarithmic scale type, the axis uses the logarithm of values rather than the values themselves. This scale type is best suitable for displaying a wide range of numerical values in a compact manner. When using a logarithmic scale, the axis can use a logarithmic base. The Create Simple Polar Chart walkthrough sets the Logarithmic scale on Y-axis.
  • Ordinal: In the Ordinal scale type, the values are evenly distributed along the axis according to their order. It applies to non-numerical values like product categories.
  • Percentage: In the Percentage scale, the values are represented as a percentage. The Create Stacked Percentage Area Chart walkthrough sets the Percentage scale on Y-axis.

Title

Title: Represents the title of the axis.

TitleStyle: Represents the styling of the Axis Title.

  • Color: The title color.
  • Font: The font properties for the title.
  • Padding: The padding to place between the title and the axis.
  • TextDecoration: The decorative lines on the title.

User Scenario

Set Position of Axis

A set of four properties for the X and Y axes - Width, MaxWidth, Height, and MaxHeight help users to control the position of the axes by specifying the height and width values for the X and Y axes, and their corresponding maximum values up to which the axes can grow. If the length of the data labels and titles in a chart exceeds the specified maximum height and width, labels are clipped-off. These properties are used to align a chart with the other controls or data regions.

Note that when a user does not specify these properties, the height and width for the chart axes are calculated automatically depending on the bound data. If the user wants to set the exact Y-axis position, the 'Width' and 'MaxWidth' properties should be set to one value. This value should be found by the user at design time.

Let us see how to align the vertical axis of a Chart data region relative to a Textbox control on the same page. The below image shows how the chart appears with the following properties set for the vertical axis.

  • MaxWidth: 100%
  • Width: Default

Chart Y-Axis Position-Default

The steps to set the Y-Axis position of the chart are as follows.

  1. From the Report Explorer, go to Chart > Plot Area and select Y Axis - [Plot1].
  2. In the Properties window, go to Appearance > Width property and enter a suitable value.
    In our case, 30% aligns the Y-Axis with the TextBox control.
  3. Preview the report.

The below image shows how the vertical axis of the chart is aligned with the textbox after the 'Width' property is set to a suitable value observed at the design time:
Chart Y-Axis Position-Width Property Set

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Legends

Legends
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Legends

Glossary Item Box

A Legend in a Chart data region helps a user understand the data plots easily. A legend is connected to the data which is being graphically displayed in the plot area of the chart and is an especially useful tool to analyze data in the case of multiple series.
Several legend types depending on the Chart type are available.

Line plots support all types of legends. Column, Bar, and Area plots support only the Color legend. Scatter plots support Color and Shape legends. Bubble plots support Color and Size, since the shape is circular. The financial charts, on the other hand, do not support any legend series because they do not contain groups.

Color Legend

The color legend displays the match between the plot subsections's fill or stroke color and the corresponding data value subcategories. Almost all types of plot support this legend. See Create Clustered Polar Chart walkthrough.

You can configure the appearance of Color Legend using the properties given below.

BackgroundColor: Indicates the color of the background.

Border: Represents the border settings.

Hidden: Indicates whether the legend is hidden.

MaxHeight: Represents the maximum height of the element in percentage.

MaxWidth: Represents the maximum width of the element in percentage.

Orientation: The Orientation property determines the direction of legend item's appearance:

  • Horizontal: from left to right
  • Vertical: from top to bottom

Padding: You could also set the Padding between the legend box and its content. This will automatically increase the legend size.

Position: The Position value sets the location of the legend relative to the plot area.

Title: The string Expression determines the legend heading.

TextStyle and TitleStyle: The TextStyle and TitleStyle properties aid in styling the legend's Text and Title, respectively. The TextStyle and TitleStyle consist of the following settings:

  • Color: Adds the color for the Text or Title.
  • Font: Adds the FontFamily, FontSize, FontStyle and FontWeight.
  • TextDecoration: Adds a line under, over or through the text.

Action: Chart color action.

Mode: Specifies how legend items are populated.

  • Data Values: Data points are colored based on the data values.
  • Series Groups: Data points are colored based on the series groups.
  • Custom: To set custom legend, you should set the expression for the legend series in Custom Expression property.

Shape Legend

The Shape Legend shows the relationship between the shape of data point symbols and corresponding subcategories of a value in the plot data. Consider the Create Multiple Line Chart walkthrough.
With the [Sales Amount] field selected from the Chart Data area, go to the Properties panel and set Appearance > Marker > Shape to 'Auto'. You can change the shape property to see the effects.

You can configure the appearance of Shape Legend using the properties given below.

BackgroundColor: Indicates the color of the background.

Border: Represents the border settings.

Hidden: Indicates whether the legend is hidden.

IconColor: Represents the color of the legend icon shape.

MaxHeight: Represents the maximum height of the element in percentage.

MaxWidth: Represents the maximum width of the element in percentage.

Orientation: The Orientation property determines the direction of legend item's appearance:

  • Horizontal: from left to right
  • Vertical: from top to bottom

Padding: Represents the amount of padding to place between the text or graphics and the edge of the report item.

Position: Represents the legend position.

Title: The string Expression determines the legend heading.

TextStyle and TitleStyle: The TextStyle and TitleStyle properties aid in styling the legend's Text and Title, respectively. The TextStyle and TitleStyle consist of the following settings:

  • Color: Adds the color for the Text or Title.
  • Font: Adds the FontFamily, FontSize, FontStyle and FontWeight.
  • TextDecoration: Adds a line under, over or through the text.

Mode: Specifies how legend items are populated.

  • Series Groups: Data points are colored based on the series groups.
  • Custom: To set custom legend, you should set the expression for the legend series in Custom Expression property.

Size Legend

The Size Legend shows the match between the size of data point symbols and corresponding subcategories of a data value. You need to configure the Size Encoding of a plot to depict the Size Legend. The Create Radar Bubble Chart walkthrough illustrates setting up a Size Legend.

You can configure the appearance of Size Legend using the properties given below.

BackgroundColor: Indicates the color of the background.

Border: Represents the border settings.

Hidden: Indicates whether the legend is hidden.

IconColor: Represents the color of the legend icon shape.

MaxHeight: Represents the maximum height of the element in percentage.

MaxWidth: Represents the maximum width of the element in percentage.

Orientation: The Orientation property determines the direction of legend item's appearance:

  • Horizontal: from left to right
  • Vertical: from top to bottom

Padding: Represents the amount of padding to place between the text or graphics and the edge of the report item.

Position: Represents the legend position.

Ranges: Represents the collection of ranges for size legend.

TextStyle and TitleStyle: The TextStyle and TitleStyle properties aid in styling the legend's Text and Title, respectively. The TextStyle and TitleStyle consist of the following settings:

  • Color: Adds the color for the Text or Title.
  • Font: Adds the FontFamily, FontSize, FontStyle and FontWeight.
  • TextDecoration: Adds a line under, over or through the text.

Action: Chart color action.

Mode: Specifies how legend items are populated.

  • Series Groups: Data points are colored based on the series groups.
  • Custom: To set custom legend, you should set the expression for the legend series in Custom Expression property.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize Chart Appearance

Customize Chart Appearance
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Customize Chart Appearance

Glossary Item Box

You can customize the chart appearance by changing these target properties of the chart plot.

Custom Labels

Set Custom Labels for X-Axis

Let us add custom labels in the following chart, where the default labels for the X-Axis show Ship Names since the Category Groups area is bound to [ShipName].
The chart binds to the 'Invoices' table of the Nwind.db. See Custom Data Provider for more information.
Label Axis

You can customize the X-Axis labels of the above chart as follows to show 'City' along with 'Ship Name'.

  1. From the Category Groups area, select the field, [ShipName], which is displayed along the X-Axis.
  2. In the Properties window, go to Label property and set it to the following expression:
    =Fields!ShipName.Value + " , " + Fields!City.Value
  3. Now select the X Axis and go to Labels > LabelsAngle property and set it to say, '45' degrees.
  4. Go to Title > Title and set it to 'Ship Name, City', to display this text as the X-Axis's title.
  5. Preview the report.

The below image shows how the X-Axis labels show customized labels.

Customized X-Axis Labels

Set Custom Labels for Chart Data Series

Let us add custom labels for the chart data series in the chart created in the Create Multiple Line Chart tutorial by following the below steps.

  1. From the Chart Data area, select the [Sales Amount] field.
  2. From the Properties panel, go to Appearance > Labels > Value property and set the property to the following expression:
    =Sum(Fields!SalesAmount.Value) & " $"
  3. Preview the report.
    Customized Labels for Data Series

ToolTips

To add a tooltip in a chart with ['Global_Sales'] as chart data, displayed along the Y-Axis, follow the below steps:

  1. From the Chart Data area, select ['Global_Sales'].
  2. Set DataToolTip > Value and add the expression to display the field; e.g.
    =Sum(Fields.Item("['Global_Sales']").Value)
  3. Set the DataToolTip > Format to 'c'.
  4. Preview the report.
    Displaying tooltips in Charts

Conditional Chart Formatting

Select the series data and use expressions as follows in the corresponding properties to see the effect. Refer to the Create Clustered Column Chart tutorial, with only one series for simplicity.

FillColor

Conditional Chart Formatting - Fill Color

Select the Chart Data series (here [Net Sales]) and from the Properties panel, set the expression of FillColor property to the following:

Copy Code
IIF(Sum(Fields.Item("Net Sales").Value)>450000,"Red")

LineColor/LineStyle/LineWidth

Conditional Chart Formatting - Line color, style, width

Select the Chart Data series (here [Net Sales]) and from the Properties panel, set the expression of LineColor, LineStyle, and LineWidth properties respectively to the following:

LineColor Copy Code
=IIF(Sum(Fields.Item("Net Sales").Value)>450000,"Red","Grey")

LineStyle Copy Code
=IIF(Sum(Fields.Item("Net Sales").Value)>450000,"Double","Dotted")

LineWidth Copy Code
=IIF(Sum(Fields.Item("Net Sales").Value)>450000,"4pt","1pt")

For charts such as Line, Radar Line, which are composed of markers or data point symbols, have the properties that can be set for conditional formatting. For example, in Create Single Line Chart tutorial, we can highlight the markers as shown.

Line Chart Markers

To do so, with the Chart Data series (here [Return Quantity]) selected, from the Properties panel, go to Marker > BackgroundColor. and set the expression to the following.

Example Title Copy Code
=IIF(Sum(Fields!ReturnQuantity.Value)>5,"Red","Grey")

Similarly, expressions for Marker border settings > LineColor, LineStyle, and Width can be set.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Trendlines

Trendlines
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Chart > Trendlines

Glossary Item Box

You can add a trendline element to the chart to display additional information like a trendline for the chart data, reference information, and more. A trendline is a helpful element for the analysis of chart data.

The following trendline types are available.

  • Reference Line
  • Reference Band
  • Linear Trendline
  • Exponential Trendline
  • Power Trendline
  • Logarithmic Trendline
  • Polynomial Trendline
  • Fourier Trendline
  • MovingAverage Trendline
  • CumulativeMovingAverage Trendline
  • ExponentialMovingAverage Trendline
  • WeightedMovingAverage Trendline
  • MovingAnnualTotal Trendline
Property | Description
Aggregate Type (Reference Line) | Sets the reference line aggregation function. Select from Sum, Count, Average, Max, Min, Median, and Percentile.
Axis (Reference Line, Reference Band) | Specifies the axis to which the trendline belongs. Select from X or Y.
BackwardForecastPeriod (Linear Trendline, Exponential Trendline, Power Trendline, Logarithmic Trendline, Polynomial Trendline, Fourier Trendline) | Sets a number of periods that the forecast extends backward.
DetailLevel | Specifies if the overlay calculation should include the entire data set or each detail group. Select from Total or Group.
End (Reference Band) | Specifies the end position on the value axis or the end index on the category axis.
Start (Reference Band) | Specifies the start position on the value axis or the start index on the category axis.
FieldName | Sets the field name for the reference line to use.
ForwardForecastPeriod (Linear Trendline, Exponential Trendline, Power Trendline, Logarithmic Trendline, Polynomial Trendline, Fourier Trendline) | Sets a number of periods that the forecast extends forward.
Intercept (Linear Trendline, Exponential Trendline, Power Trendline, Logarithmic Trendline, Polynomial Trendline, Fourier Trendline) | Sets the intercept value of Y-axis.
Order (Polynomial Trendline, Fourier Trendline) | Sets a number of terms in the equation. The default value is 2 for Polynomial Trendline, the value less than 2 is treated as 2, values greater than 6 are treated as 6.
Period (MovingAverage Trendline, CumulativeMovingAverage Trendline, ExponentialMovingAverage Trendline, WeightedMovingAverage Trendline, MovingAnnualTotal Trendline) | Specifies the number of data values used to create a line. The default value is 2.
LegendLabel | Sets the legend label of the reference line.
Value | Sets the position of the reference line on the specified axis.
Display | Sets the display position. Select from Front or Back.
Name | Enter the name of the trendline.
Type | Select the type of the trendline from the list of available types.
LineStyle | Sets the style of the line. Select the LineColor, LineStyle and LineWidth properties of the line.
BackgroundColor (Reference Band) | Select the color to use for the background, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Add a trendline

  1. Select a Сhart plot.
  2. In the Properties window, go to the Overlays property and click (Collection).
  3. In the OverlayDesigner Collection Editor that opens, click Add to add a new overlay.
    OverlayDesigner Collection Editor
  4. Specify the Type property and other important properties.
  5. Click OK.

Reference Line

A Reference Line is a static line, drawn at a single point along a single axis that stretches indefinitely along the opposite axis. You can set the line's position or have it calculated by the data set. For example, you may want to add a reference line at the average value to see how each value is compared against the average.

Chart Trendlines - Reference Line

In the OverlayDesigner Collection Editor, you can set a Reference Line with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > AggregateType | Average
Configurations > Axis | Y
Configurations > DetailLevel | Total
Configurations > LegendLabel | Average
General > Display | Front
General > Type | ReferenceLine

Reference Band

A Reference Band is a shaded area, which is positioned along a single axis between two calculated values and extend indefinitely along the opposite axis. Each band has a start and end position that you set in the Properties.

This overlay type is not available for Candlestick, High Low Close, and High Low Open Close type charts.

Chart Trendlines - Reference Band

In the OverlayDesigner Collection Editor, you can set a Reference Band with the properties as follows.

Property | Value
BackgroundColor | Green
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > Axis | Y
Configurations > End | 20
Configurations > Start | 10
General > Display | Back
General > Type | ReferenceBand

Linear Trendline

A Linear trendline creates a best fit straight line that shows how values in a data series increase or decrease at a steady rate. This trendline uses the following equation:

y=mx + b

where "m" is the slope and "b" is the intercept.

Chart Trendlines - Linear

In the OverlayDesigner Collection Editor, you can set a Linear trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
General > Display | Front
General > Type | LinearTrendline

Exponential Trendline

An Exponential trendline creates a best-fit curved line that illustrates how data values increase or decrease and then level out. You can use this trendline only with positive numbers. If the data series contains any zero or negative numbers, then this trendline is not available.

This trendline uses the following equation:

y=cebx

where "c" and "b" are constants, and "e" is the base of the natural logarithm.

Chart Trendlines - Exponential

In the OverlayDesigner Collection Editor, you can set an Exponential trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
General > Display | Front
General > Type | ExponentialTrendline

Power Trendline

A Power trendline creates a curved line to compare measurements that increase at a specific rate. You can use this trendline only with positive numbers. If the data series contains any zero or negative numbers, then this trendline is not available.

This trendline uses the following equation:

y = axb

where "a" and "b" are constants.

Chart Trendlines - Power

In the OverlayDesigner Collection Editor, you can set a Power trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
General > Display | Front
General > Type | PowerTrendline

Logarithmic Trendline

A Logarithmic trendline creates a best-fit curved line that illustrates how data values increase or decrease and then level out. This trendline uses the following equation:

y=c ln x + b

where "c" and "b" are constants, and "ln" is the natural logarithm function.

Chart Trendlines - Logarithmic

In the OverlayDesigner Collection Editor, you can set a Logarithmic trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
General > Display | Front
General > Type | LogarithmicTrendline

Polynomial Trendline

A Polynomial trendline creates a curved line, illustrating fluctuations in the data values. The trendline uses the following equation:

y = b + (c1 x) + (c2 x2) + (c3 x3) + ...

where c1, c2, c3 are constants.

Chart Trendlines - Polynomial

In the OverlayDesigner Collection Editor, you can set a Polynomial trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
Configurations > Order | 2
General > Display | Front
General > Type | PolynomialTrendline

Fourier Trendline

A Fourier trendline creates a trendline, based on Fourier Series. It identifies patterns or cycles in a series data set, and removes the effects of trends or other complicating factors from the data set, thereby providing a good estimate of the direction that the data under analysis will take in the future.

y = C0 + C1 cos(x) + C2 sin(x) + C3 cos(2x) + C4 sin(2x) + ...

Chart Trendlines - Fourier

In the OverlayDesigner Collection Editor, you can set a Fourier trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > BackwardForecastPeriod | 0
Configurations > DetailLevel | Total
Configurations > ForwardForecastPeriod | 0
Configurations > Order | 1
General > Display | Front
General > Type | FourierTrendline

MovingAverage Trendline

A MovingAverage trendline reduces the fluctuations in the trendline to show a smoother pattern. This trendline uses the following equation:

Ft = (At + At-1 + At-2 ) / n

Chart Trendlines - Moving Average

In the OverlayDesigner Collection Editor, you can set a MovingAverage trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > DetailLevel | Total
Configurations > Period | 2
General > Display | Front
General > Type | MovingAverageTrendline

CumulativeMovingAverage Trendline

In a CumulativeMovingAverage trendline, the data arrive in an ordered datum stream, and you get the average of all data up until the current datum point.

Chart Trendlines - Cumulative Moving Average

In the OverlayDesigner Collection Editor, you can set a CumulativeMovingAverage trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > DetailLevel | Total
Configurations > Period | 2
General > Display | Front
General > Type | CumulativeMovingAverageTrendline

ExponentialMovingAverage Trendline

An exponential moving average (EMA), also known as an exponentially weighted moving average (EWMA), is a first-order infinite impulse response filter that applies weighting factors, which decrease exponentially. The weighting for each older datum decreases exponentially, never reaching zero.

Chart Trendlines - Exponential Moving Average

In the OverlayDesigner Collection Editor, you can set an ExponentialMovingAverage trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > DetailLevel | Total
Configurations > Period | 2
General > Display | Front
General > Type | ExponentialMovingAverageTrendline

WeightedMovingAverage Trendline

A WeightedMovingAverage trendline is an average that has multiplying factors to give different weights to data at different positions. Mathematically, the moving average is the convolution of the datum points with a fixed weighting function.

Chart Trendlines - Weighted Moving Average

In the OverlayDesigner Collection Editor, you can set a WeightedMovingAverage trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > DetailLevel | Total
Configurations > Period | 2
General > Display | Front
General > Type | WeightedMovingAverageTrendline

MovingAnnualTotal Trendline

A MovingAnnualTotal trendline is a moving total of the prior 'n' points at an abstract level.

Chart Trendlines - Moving Annual Total

In the OverlayDesigner Collection Editor, you can set a MovingAnnualTotal trendline with the properties as follows.

Property | Value
LineStyle > LineColor | Red
LineStyle > LineStyle | Solid
LineStyle > LineWidth | 3pt
Configurations > DetailLevel | Total
Configurations > Period | 2
General > Display | Front
General > Type | MovingAnnualTotalTrendline

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Classic Chart

Classic Chart
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Classic Chart

Glossary Item Box

    Note: The Classic Chart is by default hidden from the toolbox. If you want to use Classic Chart instead of new Chart, you can enable it from ActiveReports.config file located at C:\Program Files (x86)\MESCIUS\ActiveReports 19. See Configure ActiveReports using Config File for more information
    The Chart data region shows your data in a graphical representation that often makes it easier for users to comprehend large amounts of data quickly. Different types of charts are more efficient for different types of information, so we offer a wide variety of chart types. This makes it easy and cost effective to add charting to your reports, as there is no need to purchase and integrate a separate charting tool.

    Chart Types

    Bar Charts

    Bar charts present each series as a horizontal bar, and group the bars by category. The x-axis values determine the lengths of the bars, while the y-axis displays the category labels. With a bar chart, you can select from the following subtypes.

    • Plain or Simple Bar: A bar chart used to compare values of items across categories.
    • Stacked Bar: A bar chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
    • Percent Stacked Bar: A bar chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

    Column Charts

    Column charts present each series as a vertical column, and group the columns by category. The y-axis values determine the heights of the columns, while the x-axis displays the category labels. With a column chart, you can select from the following subtypes.

    • Plain or Simple Bar: Compares values of items across categories.
    • Stacked Bar: A column chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
    • Percent Stacked Bar: A column chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to a total with the relative size of each series representing its contribution to the total.

    Scatter Charts

    Scatter charts present each series as a point or bubble. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a scatter chart, you can select from the following subtypes.

    • Plain or Simple Scatter: Shows the relationships between numeric values in two or more series sets of XY values.
    • Scatter or Lines: Plots points on the X and Y axes as one series and uses a line to connect points to each other.
    • Scatter or Smooth Lines: Plots points on the X and Y axes as one series and uses a line with the angles smoothed out to connect points to each other.

    Line Charts

    Line charts present each series as a point, and connect the points with a line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a line chart, you can select from the following subtypes.

    • Plain or Simple Line: Compares trends over a period of time or in certain categories.
    • Smooth Line: Plots curves rather than angled lines through the data points in a series to compare trends over a period of time or in certain categories. Also known as a Bezier chart.

    Pie Charts

    Pie charts are circular plots that display the proportionate contribution of each category which is represented by a slice or pie. The magnitude of the dependent variable is proportional to the pie or slice angle. These charts can be used for plotting a single series with non-zero and positive values.

    • Simple Pie: Shows how the percentage of each data item contributes to the total.
    • Exploded Pie: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.

    Bubble Charts

    Bubble charts are used to plot three dimensional data. These charts are often used to depict financial data.

    Doughnut Charts

    A doughnut chart is a pie chart with a hole in the center. The chart is divided into different portions that show the percentage each value contributes to the total. Like pie charts, the doughnut chart is used with small sets of data to compare categories.

    • Simple Doughnut: Shows how the percentage of each data item contributes to a total percentage.
    • Exploded Doughnut: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.

    Stock Charts

    Stock charts present each series as a line with markers showing some combination of high, low, open, and close values. The y-axis values determine the heights of the lines, while the x-axis displays the category labels.

    • High Low Close: Displays stock information using High, Low, and Close values. High and low values are displayed using vertical lines, while tick marks on the right indicate closing values.
    • Open High Low Close: Displays stock information using Open, High, Low, and Close values. Opening values are displayed using lines to the left, while lines to the right indicate closing values. The high and low values determine the top and bottom points of the vertical lines.
    • Candlestick: Displays stock information using High, Low, Open and Close values. The height of the wick line is determined by the High and Low values, while the height of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.

    Funnel Charts

    Funnel charts show how the percentage of each data item contributes to the whole, with the largest value at the top and the smallest at the bottom. This chart type works best with relatively few data items.

    Pyramid Charts

    Pyramid charts show how the percentage of each data item contributes to the whole, with the smallest value at the top and the largest at the bottom. This chart type works best with relatively few data items.

    Three Line Break Charts

    In Three Line Break Charts, vertical boxes or lines illustrate price changes of an asset or market. The price in a three line break graph must break the prior high or low set in the NewLineBreak property in order to reverse the direction of the graph.

    Kagi Charts

    Kagi charts display supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

    Renko Charts

    Renko charts depict bricks of uniform size chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. A change in box color and direction signifies a trend reversal.

    Point and Figure Charts

    In Point and Figure charts, stacked columns of Xs indicate that demand exceeds supply and columns of Os indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value you set. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount you set. This calculation of pricing trends is best suited for long-term financial analysis.

    Gantt Charts

    The Gantt Chart is a project management tool that tracks the progress of individual project tasks. The chart compares project task completion to the task schedule.

    Dot Plot Chart

    A Dot Plot chart is a statistical chart containing group of data points plotted on a simple scale. Dot Plot chart are used for continuous, quantitative, and univariate data. The dot plot chart has one subtype. The plain Dot Plot chart displays simple statistical plots. It is ideal for small to moderate sized data sets. You can also highlight clusters and gaps, as well as outliers, while conserving numerical information.

    Smart Panels

    Smart panels are the dialogs that group commonly-used properties of the chart elements using tabs and groups. ActiveReports.NET provides you with the smart panels for the following chart features:

    • Chart appearance
    • Chart data
    • Chart legend
    • Chart X axis
    • Chart Y axis

    These smart panels can be accessed from the Property dialog link on the Properties pane:

    Chart Properties Panel

    Chart Appearance Smart Panel

    Chart Appearance Smart Panel

    Gallery

    • Chart Types: Select the type of classic chart.
    • Subtype: Select a sub-category of the selected chart types.

    Title

    Chart title: Enter an expression or text to use for the title.

    Font

    Family: Choose the font family name.

    Size: Choose the size in points for the font.

    Style: Choose Normal or Italic.

    Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

    Color: Select a Web or custom color for the font.

    Decoration: Choose from None, Underline, Overline, and LineThrough.

    Palette

    • Palette: Select a suitable palette from the available color palettes.

    Area and Plot Area

    Border

    Style: Choose an enumerated style for the border.

    Width: Choose a width value between 0.25pt and 20pt.

    Color: Select a Web or Custom color.

    Background Fill Color

    Fill Color: Select a Web or Custom color.

    Gradient: Choose from one of the following gradient styles.

    • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
    • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
    • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
    • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
    • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
    • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
    • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
    • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

    Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

    3D Effect

    Display the chart with 3D visual effects.

    Chart Data Smart Panel

    Chart Data Smart Panel

    When you first open the Chart Data dialog, you can select a Dataset name to associate with the chart. The list is populated with all of the datasets in the report's dataset collection.

    This dialog also gives you access to the following related pages.

    General

    Name: Enter a name for the chart that is unique within the report. This name is displayed in the Document Outline and in XML exports.

    Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

    Dataset name: Assign a dataset name to associate with the chart. The combo box is populated with all of the datasets in the report's dataset collection.

    Series Values

    Add at least one Value series to determine the size of the chart element. Click the plus sign button to enable the General tab. Once you have one or more value series in place, you can use the arrow buttons to change the order or the X button to delete them.

    Another way to add Chart Series Values is to drag fields from the Report Explorer onto the tray along the top edge of the chart that reads Drop data fields here.

    If you have already added values, you can right-click any value displayed in the UI along the top of the chart and choose Edit to open this dialog.

    The Series Values page has the following tabs.

    Show General

    The General tab of the Series Values page allows you to control different items depending on the Chart Type you have chosen.

    For all Chart types

    Series label: Enter an expression to use as a series label to display in the legend.

    For Scatter or Bubble Chart types

    X: Enter an expression to use as an X value.

    Y: Enter an expression to use as a Y value.

    Size: If the chart type is bubble, enter an expression to use as the bubble size value.

    For Stock Chart

    High: Enter an expression to use as the high value.

    Low: Enter an expression to use as the low value.

    Open: Enter an expression to use as the open value.

    Close: Enter an expression to use as the close value.

    For Column, Bar, Line, Pie, Area, Doughnut, Funnel, Pyramid, ThreeLineBreak, Kagi, Renko, PointAndFigure, or DotPlot Chart types

    Value: Enter an expression to use as a series value.

    For Column, Line, or Area Chart types

    Chart Type: For Composite charts, select the chart type to use in combination with other chart types within the same plot area. The available chart types are:

    • Column Plain
    • Column Stacked
    • Column Percent Stacked
    • Area Plain
    • Area Stacked
    • Area Percent Stacked
    • Line Plain
    • Smooth Line
    Y-Axis: Select the Y-axis from the list of available Y-axes.

    Show Styles

    Line/Border

    These properties control the appearance of the border of bars or columns, or the lines, depending on the type of chart.

    Style: Choose one of the enumerated styles for the lines.

    Width: Choose a width value between 0.25pt and 20pt for the thickness of the lines.

    Color: Choose a Web or Custom color to use for the lines.

    Background Fill Color

    These properties control the appearance of the background of the series values.

    Fill Color: Choose a Web or Custom color to fill the background.

    Gradient: Choose from one of the following gradient styles.

    • None: No gradient is used. A single color (defined by the Fill Color property above) is used to fill the area and the Gradient End Color property remains disabled.
    • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
    • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
    • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
    • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
    • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
    • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
    • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

    Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color to blend with the Fill Color in the background of the series.

    Show Markers

    Marker type: Choose one of the following values to determine the shape of the marker or whether one is displayed.

    • None - Markers are not used. (Default)
    • Square - Markers are square.
    • Circle - Markers are circular.
    • Diamond - Markers are diamond shaped.
    • Triangle - Markers are triangular.
    • Cross - Markers are cross shaped.
    • Auto - A shape is chosen automatically.

    Marker size: Enter a value between 2pt and 10pt to determine the size of the plotting area of the markers.

    Plot data as secondary: If the chart type is Column, Bar, or DotPlot, you can select this check box and select whether to use a Line or Points to show the data.

    Show Labels

    Show point labels: Select this check box to display a label for each chart value. Selecting this box enables the disabled properties on this page.

    Data label: Enter a value to use as the label, or select <Expression...> to open the Expression Editor.

    Format code: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

    Position: Leave Auto selected to use the default point label position for the chart type, or select an enumerated value to position the labels.

    Angle: Enter the value in tenths of degrees to use for the angle of the point label text. The default (0°) position denotes no angle and renders regular horizontal text.

    Font

    Family: Choose the font family name.

    Size: Choose the size in points for the font.

    Style: Choose Normal or Italic.

    Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

    Color: Select a Web or custom color for the font.

    Decoration: Choose from None, Underline, Overline, and LineThrough.

    Show Action

    Choose from the following actions to perform when the user clicks on the chart element.

    None: The default behavior is to do nothing when a user clicks the chart element at run time.

    Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

    Parameters

    • Name: Supply the exact names of any parameters required for the targeted report. Note that parameter names you supply in this must match parameters in the target report.
      Important: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report will fail.
    • Value: Enter a Parameter Value to pass to the detail report. This value must evaluate to a valid value for the parameter.
    • Omit: Select this check box to omit this parameter from the report.

    Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

    Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

    Show Data Output

    Element name: Enter a name to be used in the XML output for this chart element.

    Output: Choose Yes or No to decide whether to include this chart element in the XML output.

    Category Groups

    Add Category Groups to group data and provide labels for the chart elements. Click the Add button to enable the General tab. Once you have one or more category groups in place, you can use the arrow buttons to change the order or the X button to delete them.

    Another way to add Category Groups is to drag fields from the Report Explorer onto the tray along the bottom edge of the chart that reads Drop category fields here.

    If you have already added values, you can right-click the value displayed in the UI along the bottom of the chart and choose Edit to open this dialog.

    The Category Groups page has the following tabs.

    Show General

    Name: Enter a name for the group that is unique within the report. This name can be called in code.

    Group on: Enter an expression to use for grouping the data.

    Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

    Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

    Show Filters

    You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

    Expression: Enter the expression to use for evaluating whether data should be included in the group.

    Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right.
      For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right.
      Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

    Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

    Values: When you choose the In operator, you can enter as many values as you need in this list.

    Show Sorting

    The Sorting tab of Category Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

    Expression: Enter an expression by which to sort the data in the group.

    Direction: Select whether you want to sort the data in an Ascending or Descending direction.

    Show Data Output

    Element name: Enter a name to be used in the XML output for this group.

    Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

    Output: Choose Yes or No to decide whether to include this group in the XML output.

    Series Groups

    Optionally add Series Groups for extra levels of data (for example, Orders by Country can be broken down by year as well). Labels for the series are displayed in the chart legend. Click the Add button to open the General page. Once you have one or more series groups in place, you can use the arrow buttons to change the order or the X button to delete them.

    Another way to add Series Groups is to drag fields from the Report Explorer onto the tray along the right edge of the chart that reads Optionally drop series fields here.

    If you have already added values, you can right-click the value displayed in the UI along the right edge of the chart and choose Edit to open this dialog.

    The Series Groups page has the following tabs.

    Show General

    Name: Enter a name for the group that is unique within the report. This name can be called in code.

    Group on: Enter an expression to use for grouping the data.

    Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

    Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

    Show Filters

    You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

    Expression: Enter the expression to use for evaluating whether data should be included in the group.

    Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right.
      For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right.
      Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

    Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

    Values: When you choose the In operator, you can enter as many values as you need in this list.

    Show Sorting

    The Sorting tab of Series Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

    Expression: Enter an expression by which to sort the data in the group.

    Direction: Select whether you want to sort the data in an Ascending or Descending direction.

    Show Data Output

    Element name: Enter a name to be used in the XML output for this group.

    Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

    Output: Choose Yes or No to decide whether to include this group in the XML output.

    Filters

    Show Chart Data Filters Page

    You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

    Expression: Enter the expression to use for evaluating whether data should be included in the chart.

    Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right.
      For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right.
      Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

    Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

    Values: When you choose the In operator, you can enter as many values as you need in this list.

    Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

    Data Output

    Show Chart Data Output Page

    Element name: Enter a name to be used in the XML output for the chart.

    Output: Choose one between Auto, Yes, No or Contents Only to decide whether to include this group in the XML output.

    Chart Legend Smart Panel

    Chart Legend Smart Panel

    General

    • Show chart legend and use smart settings.

    Style

    • Select style settings related to font, border and background color.

    Chart X Axis Smart Panel

    Chart X Axis Smart Panel

    Title

    Add the x-axis title, change text alignment, orientation and font.

    Line Style

    Change the styling properties related to the appearance of line.

    Labels

    Show x-axis labels.

    Major Grid Lines

    Show major gridlines.

    Minor Grid Lines

    Show minor grid lines.

    Scale

    Specify the minimum and maximum scale.

    Chart Y Axis Smart Panel

    Chart Y Axis Smart Panel

    Axis

    Add the y-axis title, change text alignment, orientation and font.

    Line Style

    Change the styling properties related to the appearance of line.

    Labels

    Show y-axis labels.

    Major Grid Lines

    Show major gridlines.

    Minor Grid Lines

    Show minor grid lines.

    Scale

    Specify the minimum and maximum scale.

    Copyright © MESCIUS inc. All rights reserved.

    Product Support Forum | Print this page

    ©2025. All Rights Reserved.


CheckBox

CheckBox
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > CheckBox

Glossary Item Box

You can use the CheckBox control to represent a Boolean value in a report. By default, the CheckBox control appears as a small box inside an empty textbox. If the Checked value is set to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Structure

Important Properties

Clicking the four-way arrow selects the control and reveals its properties in the Properties panel.

Property | Description
Checked | Gets or sets a value indicating whether the check box is in the checked state. You can also set the Checked property of the check box in code or bind it to a Boolean database value.
Text | Gets or sets the printed caption of the check box.
CheckAlignment | Gets or sets the alignment of the check box text within the control drawing area.
Custom CSS Classes

Allows to apply custom CSS class names to the check box when rendering a report in the JS Report Viewer.

For example, you can use the jsViewer.custom.styles.css file from the JS Report Viewer deliverables to style the check box as a button. When designing a report in the Standalone Designer, set this property to a style class from the jsViewer.custom.styles.css file (e.g., ar-button), then add the report to your JS Viewer project. After you open the report in your JS Viewer project, the class will automatically apply to the check box.

Similarly, you can apply your own custom styles to match the design requirements.

You can double-click the CheckBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties panel or you can assign data to display in code through the Text property.

In edit mode, using the toolbar you can format text in the CheckBox control using the toolbar or you modify properties in the Properties panel. Formats apply to all of the text in the control. Text formatting changes in the Properties panel immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties panel.

CheckBox Dialog Properties

You can set the CheckBox properties in the CheckBox dialog. To open it, with the CheckBox selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Navigation
Appearance
Font
Alignment
Data Output

Name: Enter a name for the checkbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Text : Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is displayed in the report to the right of the checkbox.

Initial visibility

Visible: The checkbox is visible when the report runs.

Hidden: The checkbox is hidden when the report runs.

Expression: Use an expression with a Boolean result to decide whether the checkbox is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this checkbox to specify a report control to use as a toggle to show or hide the checkbox. Then specify the TextBox control to display with a toggle image button. When the user clicks the TextBox control, the checkbox changes between visible and hidden.

Choose one of the following actions to carry out when the checkbox is selected:

None: The default behavior is to do nothing when you select the checkbox at runtime.

Jump to Report: It allows you to jump to another report by selecting the checkbox at runtime. For a drill-through report, select the Jump to Report option and choose the name of a local report from the dropdown. To display a report from another folder, enter the relative path of the report. For the report from another server, provide the full path of the report. You can also use expressions to create drill-through links.

Parameters: Enter the Name and Value of each parameter you want to pass to the targeted report. You can also Omit the parameter by setting the value to True. The parameter names you supply must be the same in both reports.

Jump to bookmark: Select this option and provide a valid Bookmark ID to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page, and then at runtime, select the checkbox to jump to that Web page.

Apply Parameters: Select the Name, Type, and Value of the parameter to set a parameter value through user action. See Actionable Parameters for more information.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the checkbox.

Image: Enter an image to use for the background of the CheckBox.

Image Source: Select the location of the image.

MIME Type: Select the MIME type of the image.

Background repeat: Specify how the background image fills the space of the CheckBox.

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose an enumerated weight value or select a theme.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Amount of space to leave around report control

Top padding: Set the top padding in points.

Left padding: Set the left padding in points.

Right padding: Set the right padding in points.

Bottom padding: Set the bottom padding in points.

Element Name: Enter a name to be used in the XML output for this checkbox.

Output: Choose Auto, Yes, or No to decide whether to include this checkbox in the XML output. Auto exports the contents of the checkbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render checkboxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property

Attribute example: <table1 checkbox3="Report created on: 7/26/2005 1:13:00 PM">

Element example: <table1> <checkbox3>Report created on: 7/26/2005 1:13:28 PM</checkbox3>

Keyboard Shortcuts

In the edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In Visual Studio Integrated Designer, you can disable this feature in the EditModeEntering Event and EditModeExit Event.

See Also

CheckBox Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Container

Container
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Container

Glossary Item Box

Using the Container report control in your Page/RDLX report gives you more possibilities for visual presentation of your report. The Container is a visual element that is used as a container for other report controls. It highlights a part of a report and how the report controls appear inside it. The Container control has no data associated with it.

For Container control to work, you must drag the items into the Container instead of drawing it around the existing items.

The Container control can be used in several ways to enhance your reports:

  • Group the report controls visually by placing them within the Container control.
  • Anchor report controls, which may otherwise be pushed down by a vertically expanding data region.
  • Create visual effects by adding borders to the Container control.
  • Display an image behind a group of report controls by adding a background image.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
KeepTogether (RDLX) | Change to True to have ActiveReports attempt to keep all of the repeated data together on one page.

Container Dialog Properties

General
Appearance
Visibility
Navigation
Data Output

Name: Enter a name for the container that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Consume all white space during report rendering (RDLX): Select this checkbox to have all white space consumed at report rendering.

Page breaks (RDLX):

  • Insert a page break before this container (RDLX): Insert a page break before the container.
  • Insert a page break after this container (RDLX): Insert a page break after the container.

Background

Color: Select a color to use for the background of the container or select the <Expression...> option to open the Expression Editor.

Image: Specify the background image of container using Expression or Data Visualizer, or directly open the image file on your system.

If the Hatch and Gradient background styles are set using Data Visualizers, these are not displayed at design time.

Image Source: Select the location of the image for the background from External, Embedded, Database or select the <Expression...> option to open the Expression Editor.

MIME Type: Select the MIME type of the image.

Background repeat: Specify how the background image fills the space of the container.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border or select the <Expression...> option to open the Expression Editor.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Rounded Rectangle: Specify the radius for each corner of the shape independently. Drag the handlers Handler available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, select the checkbox available near each corner of the Container control.

Initial visibility

  • Visible: The container is visible when the report runs.
  • Hidden: The container is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the container is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the container. The user can click the toggle item to show or hide this container.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this container. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

The Data Output page of the Container dialog allows you to control the following properties when you export to XML:

  • Element Name: Enter a name to be used in the XML output for this container.
  • Output: Choose Auto, Yes, No, or Contents only to decide whether to include the contents of this container in the XML output. Choosing Auto exports the contents of the container only when the value is not a constant.

Container Control in RDLX Dashboard Report

The Container is a visual element that is used as a container for other report controls. The properties and workings are the same as Page or RDLX Reports. The Container control in the RDLX Dashboard Report has the following additional property to manage the scroll behavior:

Overflow: By Setting the overflow property to Auto, Clip, Grow, or Scroll, you can specify the scroll behavior of the Container control in the RDLX Dashboard Report.

Choose one of the following options to specify the scroll behavior of the Container:

  • Auto: The Container size remains the same, but you can scroll the data. By default, the value is set to ‘Auto’.
  • Clip: The Container size remains the same, and only the content that fits in the control is displayed.
  • Grow: The Container size grows automatically to fit the data completely.
  • Scroll: The Container size remains the same, and the scroll appears only if necessary.

See Also

Container Control for Enhanced Report Appearance

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ContentPlaceHolder (RDLX Master Report)

ContentPlaceHolder (RDLX Master Report)
Report Authors > Report Controls > Report Controls in Page/RDLX Report > ContentPlaceHolder (RDLX Master Report)

Glossary Item Box

The ControlPlaceHolder control is used to show the edit area when a Master Report is available. See Master Report (RDLX Report) page for complete information on usage and implementation.

ControlPlaceHolder control in Master report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


FormattedText

FormattedText
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > FormattedText

Glossary Item Box

The FormattedText report control can perform mail merge operations, plus it displays richly formatted text in HTML. To format text in the FormattedText report control, enter HTML code into the Html property.

Note: All text written in the Html property must be enclosed in the <body></body> tags.

The design-time editor displays the HTML text with the applied formatting, so you can view the text just as it will be displayed on the preview.

Important Properties

By clicking on the FormattedText control, you can set its properties in the Properties window.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
EncodeMailMergeFields | Select whether you want to encode mail merge fields or not.
Html | Enter HTML code to format text.
MailMergeFields | Add new mail merge fields to the FormattedText.
Size | Set the Width and Height of the FormattedText control.

FormattedText Dialog Properties

You can set the FormattedText properties in the FormattedText dialog. To open it, with the FormattedText selected on the report, under the Properties window, click the Property dialog link.

General
Visibility
Navigation
Appearance
Data Output
Mail Merge

Name: Enter a name for the FormattedText that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Initial visibility

  • Visible: The FormattedText is visible when the report runs.
  • Hidden: The FormattedText is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the FormattedText is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the FormattedText. The user can click the toggle item to show or hide this FormattedText.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this FormattedText. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Background

Color: Select a color to use for the background of the FormattedText.

Image: Add an image to use for the background of the FormattedText.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Element Name: Enter a name to be used in the XML output for this FormattedText report control.

Output: Choose Auto, Yes, No, or Contents Only to decide whether to include this FormattedText in the XML output. Choosing Auto exports the contents of the FormattedText report control.

Check on the Encode Mail Merge Fields option to encode mail merge fields.

Click the plus sign button to add a new mail merge field to the FormattedText, and delete them using the X button.

Field: Enter a name for the field that is unique within the report. This is used in the Html property inside <%FieldName%> tags to display the field in the formatted text.

Value: Enter an expression to pull data into the control for mail merge operations.

Here is a very simple example of HTML code that you can use to add mail merge fields to formatted text. This example assumes that you have added two mail merge fields named Field1 and Field2.

Paste this code in the Html property of the FormattedText control. Copy Code
<body><p>This is <%Field1/%> and this is <%Field2/%>.</p></body>

Supported HTML Tags and Attributes

The FormattedText control supports almost all HTML tags and attributes from the XHTML 1.1 specification (see https://www.w3.org/TR/xhtml11/ for details) with some extensions to partially support the HTML5 specification (see https://www.w3.org/TR/2011/WD-html5-20110405/ for details). Additionally, the FormattedText control supports many (but not all) CSS styles.

For example, the FormattedText control supports these HTML tags and attributes. If you use valid HTML tags that are not in the list below, ActiveReports ignores them.

Caution: To enter & in the HTML property, you need to use &amp;.

Show Supported HTML Tags and Attributes

HTML Tags | Attributes | Description
<%MergeFieldName/%> | Inserts a mail merge field.
<!-- -- > Defines a comment
<!DOCTYPE> | Defines the document type
<a> | Defines an anchor
<abbr> | Defines an abbreviation
<acronym> | Defines an acronym
<address> | Defines an address element
<b> | Defines bold text
<base /> | Defines a base URL for all the links in a page
<bdo> | Defines the direction of text display
<big> | Defines big text
<blockquote> | Defines a long quotation
<body> | Defines the body element (Required)
<br /> | Inserts a single line break
<caption> | Defines a table caption
<center> | Defines centered text
<cite> | Defines a citation
<code> | Defines computer code text
<col> | Defines attributes for table columns
<dd> | Defines a definition description
<del> | Defines deleted text
<dir> | Defines a directory list
<div> | style | Defines a section in a document
<dfn> | Defines a definition term
<dl> | Defines a definition list
<dt> | Defines a definition term
<em> | Defines emphasized text
<h1> to <h6> | align | Defines header 1 to header 6
<head> | Defines information about the document
<hr /> | Defines a horizontal rule
<html> | Defines an html document
<i> | Defines italic text
<img /> align
src
height
width

Defines an image. Use src attribute to define path of the image, for example:
<img src="https://.../images/image.png"/>

To refer an image embedded within the report, specify the image name:
<img src="image_name"/>
<ins> | Defines inserted text
<kbd> | Defines keyboard text
<li> | Defines a list item
<link> | href | Defines a link
<map> | Defines an image map
<menu> | Defines a menu list
<ol>

type
align

 Defines an ordered list
<p> | Defines a paragraph
<pre> | Defines preformatted text
<q> | Defines a short quotation
<s> | Defines strikethrough text
<samp> | Defines sample computer code
<small> | Defines small text
<span> | Defines a section in a document
<strike> | Defines strikethrough text
<strong> | Defines strong text
<style> | Defines a style definition
<sub> | Defines subscripted text
<sup> | Defines superscripted text
<table>

align
bgcolor
border
bordercolor
cellpadding
cellspacing
width

 Defines a table
<tbody>

Defines a table body.
<td> align
bgcolor
colspan
height
nowrap
rowspan
valign
width 		Defines a table cell
<tfoot> | Defines a table footer
<th> abbr
align
axis
bgcolor
colspan
headers
height
nowrap
rowspan
scope
sorted
valign
width 		Defines a table header
<thead> | Defines a table header. It is used along with <tbody> and <tfoot>.
<tr> align
bgcolor
bordercolor
height
valign 		Defines a table row
<tt> | Defines teletype text
<u> | Defines underlined text
<ul> | Defines an unordered list

See Also

FormattedText Control for Mail Merge
Demo: Mail Merge

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Image

Image
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Image

Glossary Item Box

The Image report control displays an image that you embed in the report, add to the project, store in a database, or access through a URL. You can choose the Image Source in the Properties panel after you place the Image report control on the report.

The supported image formats are Base64 string, Byte[], BMP, JPG/JPEG/JPE, GIF, PNG, EMF, WMF, and SVG.

Important Properties

By clicking on the Image control, you can set its properties in the Properties panel.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
Action | From Navigation Dialog choose one of the actions to carry out at runtime.
MIMEType | Choose MIME Type from the dropdown.
Size | Enter the Width and Height of the image.
Sizing | Specify the way an image should be sized within the image report control.
Source | Select the source of the image from External, Embedded, or Database.
Value | Depending on the Source chosen specify the path of the image.

Image Dialog Properties

You can set the Image properties in the Image dialog. To open it, with the Image selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Navigation

Name: Enter a name for the image that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Image Value: Enter the name of the image to display. Depending on the Image Source chosen below, you can give a path to the image, select an image to embed, or pull images from a database. This property also allows you to choose the <Data Visualizer...> option to launch a dialog that will let you build a data visualization expression.

Image Source: Select whether the image comes from a source that is External, Embedded, or Database.

MIME Type: Select the MIME type of the image chosen.

Initial visibility

  • Visible: The image is visible when the report runs.
  • Hidden: The image is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the image is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the image. The user can click the toggle item to show or hide this image.

Action

Select one of the following actions to perform when a user clicks on this image.

None: The default behavior is to do nothing when a user clicks the image at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that the parameter names you supply must exactly match the parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Apply Parameters: Select the Name, the Type, and the Value of the parameter to set a parameter value through user action. See Actionable Parameters for more information.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this image. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Image Features

Embedded Images

The benefit of using an embedded image is that there is no separate image file to locate or to keep track of when you move the report between projects. The drawback is that the larger the file size of the image you embed, the more inflated your report file size becomes.

To embed an image in your report:

  1. From the Report Explorer, right-click Embedded Images.
    Embedding an image into a report
  2. Select Add Embedded Image and navigate to an image file from your local files.
  3. Now that the image is embedded in the report and appears under Embedded Images, drag-drop the image to the design area.
    The MIMEType, Source, and Value properties are filled in automatically and the image file's data is stored in the report definition.

Data Visualizer Images

You can use a data visualizer to display data in small graphs that are easy to comprehend. To add a data visualizer image to your report:

  1. Select the Image control and in the Properties panel, drop down the Value property and select <Data Visualizer...>.
  2. In the Data Visualizers dialog that appears, select the Visualizer Type that you want to use - Icon Set, Range Bar, Data Bar, Gradient, or Hatch.
  3. Use expressions related to your data to set other values in the dialog.

SVG Images

There are several cases where you can use an SVG image:

  • as a background image for Chart, Container, CheckBox, FormattedText, List, Shape, Table, Tablix, TextBox.
  • as a report's embedded image.
  • as a report's theme, where you can add an image in the Images tab of the Theme Editor.

Image files with the mime-type image/svg+xml are allowed, which you can set in the MimeType property of the Image control.

See Also

Tutorial: Image Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputField

InputField
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > InputField

Glossary Item Box

The InputField report control in Page and RDLX reports provides support for editable fields in an exported PDF report where the InputField’s value can be modified. An exported editable PDF file is an AcroForm. See Creating AcroForm fields for details.

The InputField report control can be one of the two types – Text and CheckBox, which you can choose in the InputType property. Each selected type has its own set of properties. In case of the Text type, the InputField control gets the set of properties of the TextBox control. If the CheckBox type is selected, then the control inherits the set of properties of the CheckBox control.

Note: The InputField control is part of the Professional Edition. With the Standard license, the InputField control is not displayed in an exported file.

Important Properties

Property | Description
InputType | Specifies the form field type - Text or CheckBox, in the resulted PDF file.
ReadOnly | Prevents the user from changing the entered text content in the resulted PDF file.
FieldName | Specifies a unique name of the field in the resulted PDF file.
Required | Forces the user to fill in the selected field of the resulted PDF file. If a user attempts to submit the form where the required field is blank, the error message appears and the empty required field is highlighted.
Checked (for CheckBox) | Gets or sets a value indicating whether the check box is in the checked state.
CheckStyle (for CheckBox) | Gets or sets the style of the check symbol inside the CheckBox. The available options are Check, Circle, Cross, Diamond, Square, and Star.
MaxLength (for Text) | Specifies the maximum length of the entered text in the resulted PDF file. When set to null, the text is not restricted to any specified length.
MultiLine (for Text) | Gets or sets a value indicating whether to allow text to break to multiple lines within the control in the resulted PDF file.
Password (for Text) | Displays the user-entered text as a series of asterisks (*).
SpellCheck (for Text) | Indicates whether to spell check the text during its input or not in the resulted PDF file.
TabIndex | Sets the tab order of editable fields in the resulted PDF file. A field with the lowest TabIndex value is selected first.

Limitations

  • (Preview limitation) Border drawing is displayed inside the control area.
  • (Preview limitation) A checkmark inside the InputField CheckBox is shown only if the control's size is not smaller than the checkmark size in the CheckSize property. A checkmark cannot be displayed partially.
  • (Preview limitation) Some properties are not supported at preview, like Multiline (False), Password, Required.
  • With the PDF export filter, the InputField control is exported as a static, non-editable control.
  • (PDF limitation) Limited set of enum values for the BorderStyle property are available - None, Solid, Dashed, Inset.
  • (PDF limitation) Padding, VerticalAlign, Justify settings are not available.
  • (PDF limitation) Properties related to the Text/Font settings are not available for the InputType control as Checkbox.
  • (PDF limitation) Border properties can only be set for all sides at once (the option for each side is not available).

See Also

InputField Control for Editable PDFs
Demo: InputField Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line

Line
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Line

Glossary Item Box

The Line control allows you to draw vertical, horizontal or diagonal lines that visually separate or highlight areas within a section on a report. You can also use the Line report control to visually separate data regions in a report layout.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
LineColor | Gets or sets the color of the line.
LineStyle | Gets or sets the pen style used to draw the line. The line styles include Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.
LineWidth | Gets or sets the pen width of the line in points.
Visibility | Indicates whether the line is visible or hidden.
LayerName | Gets or sets the name of the containing layer.
EndPoint | Set the vertical and horizontal end points of the line.
Location | Gets or sets the position of the top-left corner of the report item in relation to its container.

Line Dialog Properties

You can set the Line properties in the Line dialog. To open it, with the Line selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Navigation
Name: Enter a name for the line that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

The Visibility page of the Line dialog allows you to control the following items:

Initial visibility

  • Visible: The line is visible when the report runs.
  • Hidden: The line is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the line is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the line. The user can click the toggle item to show or hide this line.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this line. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

See Also

Line Control for Freehand Forms

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


List

List
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > List

Glossary Item Box

The List data region repeats any report controls it contains for every record in the dataset. Unlike other data regions, the List is free-form, so you can arrange report controls in any configuration you like.

Grouping in the list is done on the details group.

The List data region behavior is the same as the one of Table or Tablix that has one Detail cell with the Container control added to it.

List Dialog Properties

You can set the List properties in the List dialog. To open it, with the List selected on the report, under the Properties window, click the Property dialog link.

General
Detail Grouping
Visibility
Navigation
Filters
Sorting
Data Output

Name: Enter a name for the list that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the list. The drop-down list is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this List is in its own section with regards to pagination.

Consume all white space during report rendering (RDLX): Select to have all white space consumed at report rendering.

Page Breaks (RDLX): Select any of the following options to apply to each instance of the list.

  • Insert a page break before this list
  • Insert a page break after this list
  • Fit list on a single page if possible

NewPage (RDLX): Indicates on which page the content to start after the page break.

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number, for example, you will see no difference in the results.

The Detail Grouping page of the List dialog has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Filters data for which the value on the left is equal to the value on the right.
  • Like Filters data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Filters data for which the value on the left is not equal to the value on the right.
  • GreaterThan Filters data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Filters data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Filters data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Filters data for which the value on the left is less than or equal to the value on the right.
  • TopN Filters data items from the value on the left which are the top number specified in the value on the right.
  • BottomN Filters items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Filters items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Filters items from the value on the left which are the bottom percent specified in the value on the right.
  • In Filters items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Filters items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Data Output

Element Name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

BreakLocation: Select from these options to decide where to insert a page break in relation to the group.

  • None: Inserts no page break.
  • Start: Inserts a page break before the group.
  • End: Inserts a page break after the group.
  • StartAndEnd: Inserts a page break before and after the group.
  • Between: Inserts a page break between groups (at the end of a current group and the beginning of the next group).

NewPage:

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

See Manage Page Breaks in Data Regions topic for more detail.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Initial visibility

  • Visible: The list is visible when the report runs.
  • Hidden: The list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the list is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the list. The user can click the toggle item to show or hide this list.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this list. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

    • Equal Filters data for which the value on the left is equal to the value on the right.
    • Like Filters data for which the value on the left is similar to the value on the right.
      For more information on using the Like operator, see the       MSDN Web site .
    • NotEqual Filters data for which the value on the left is not equal to the value on the right.
    • GreaterThan Filters data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Filters data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Filters data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Filters data for which the value on the left is less than or equal to the value on the right.
    • TopN Filters data items from the value on the left which are the top number specified in the value on the right.
    • BottomN Filters items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Filters items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Filters items from the value on the left which are the bottom percent specified in the value on the right.
    • In Filters items from the value on the left which are in the array of values specified on the right.
      Selecting this operator enables the Values list at the bottom.
    • Between Filters items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.
  • Equal Filters data for which the value on the left is equal to the value on the right.
  • Like Filters data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Filters data for which the value on the left is not equal to the value on the right.
  • GreaterThan Filters data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Filters data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Filters data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Filters data for which the value on the left is less than or equal to the value on the right.
  • TopN Filters data items from the value on the left which are the top number specified in the value on the right.
  • BottomN Filters items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Filters items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Filters items from the value on the left which are the bottom percent specified in the value on the right.
  • In Filters items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Filters items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending for the selected sort expression.

Element Name: Enter a name to be used in the XML output for this list.

Output: Choose Auto, Yes, No, or Contents only to decide whether to include this List in the XML output. Choosing Auto exports the contents of the list.

Instance element name: Enter a name to be used in the XML output for the data element for instances of the list. This name is ignored if you have specified a detail grouping.

Instance element output: Choose Yes or No to decide whether to include the instances of the list in the XML output. This is ignored if you have specified a detail grouping.

See Also

List Control for Hierarchical Relationships
Demo: Hierarchical - Game Catalog
Demo: List - Top 10 Movies

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Map

Map
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map

Glossary Item Box

The Map data region is a professional edition feature that shows your business data against a geographical background. You can create different types of map, depending on the type of information you want to communicate in your report.

Maps consist of a title, a viewport for specifying the center point and scale, legend for interpreting data, distance scale to represent real world distance, and color scale for representing the meaning of colors used in maps. Lets us learn these in detail in the next section.

Note:

  • Map control is not supported by WebDesigner for now.
  • MESCIUS inc. does not provide access to Tile Providers; please ensure that you have a valid license before using it.

Structure

Title

Map Title describes the theme or subject of the map. The purpose of map title is to tell the viewer of what he is looking at. You can add multiple titles to the Map using the MapTitleDesigner Collection Editor. For more information, see Add a Title to the Map tutorial.

Viewport

Viewport refers to the area on the map where data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually displays geographical data and occupies most area of the map control depending on the location and dock position of other map elements. By default, color scale and distance scale appear inside the viewport, and the map legend appears outside the viewport. For information on customizing the viewport, see Modify the Appearance of the Viewport tutorial.

Map Viewport Dialog Properties

The Map Viewport dialog lets you set properties with the following pages.

General
Meridians
Parallels
View
Appearance

Coordinate system: Specify the coordinate system of the viewport. Select from Planar, Geographic, or select the <Expression...> option to open the Expression Editor and create an expression.

Projection: Specify the projection of the map. Tile layers must use the Mercator projection.

Minimum X: Specify the minimum X coordinate of the map in degrees.

Maximum X: Specify the maximum X coordinate of the map in degrees.

Minimum Y: Specify the minimum Y coordinate of the map in degrees.

Maximum Y: Specify the maximum Y coordinate of the map in degrees.

Projection Center X: Specify the X coordinate of the projection center in degrees.

Projection Center Y: Specify the Y coordinate of the projection center in degrees.

Minimum zoom: Specify the minimum zoom value.

Maximum zoom: Specify the maximum zoom value.

Map resolution: Enables the viewport to simplify vector data for polygon and line layers.

Show grid lines below the map: Specify whether to show the grid lines above or below the content of the map.

Hide meridians: Specify whether to hide meridians.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for meridians on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the meridians on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Hide parallels: Specify whether to hide parallels.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for parallels on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the parallels on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Center and zoom: Specify how the map viewport zooms and centers during the report processing.

  • Custom
  • Center map to show a map element
  • Center map to show a map layer
  • Center map to show all map elements

View Center X: Specify the X coordinate of the current view center.

View Center Y: Specify the Y coordinate of the current view center.

Zoom level: Specify the zoom level of the map view.

Border

  • Style: Choose an enumerated style for the border.
  • Width: Set a width value in points between 0.25pt and 20pt.
  • Color: Select a Web or custom color for the border.

Background

  • Color: Select a color to use for the background of the Viewport.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Shadow offset: Specify the size of the shadow. Shadow offsets are drawn to the right and below an element.

Legend

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend. Legends are added in the LegendDesigner Collection Editor. For more information, see Add a Legend to the Map tutorial.

Distance Scale

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. For more information, see Set the Distance Scale on a Map tutorial.

Map Distance Scale Dialog Properties

The Map Distance Scale dialog lets you set properties with the following pages.

General
Appearance
Font
Visibility
Navigation

Location

  • Position: Specify the docking position of the distance scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show distance scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Scale

  • Color: Select the fill color for the distance scale bar.
  • Border color: Select the border color for the distance scale bar.

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Choose the width of the border line.
  • Color: Select a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the distance scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the distance scale panel. Shadow offsets are drawn to the right and below an element.

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic, or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Initial visibility

  • Visible: The distance scale is visible when the report runs.
  • Hidden: The distance scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the distance scale is visible. True for hidden, false for visible.

Action

Select one of the following actions to perform when a user clicks on the distance scale element.

  • None: The default behavior is to do nothing when a user clicks the distance scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.
  • Apply Parameters: Select the Name, the Type, and the Value of the parameter to set a parameter value through user action. See Actionable Parameters for more information.

Color Scale

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. For information, see Set the Color Scale on a Map tutorial.

Map Color Scale Dialog Properties

The Map Color Scale dialog lets you set properties with the following pages.

General
Labels
Title
Appearance
Font
Visibility
Navigation

Location

  • Position: Specify the docking position of the color scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show color scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Color bar

  • Border color: Specify the outline color for color scale divisions.
  • Range gap color: Specify color to fill color divisions for undefined range values.

Display: Specify whether to display color scale labels on the color scale panel. Select from Auto, ShowMiddleValue, ShowBorderValue, or select the <Expression...> option to open the Expression Editor and create an expression.

Hide end labels: Specify whether to display first and last labels on the color scale panel.

Format: Specify the format string to display numeric labels.

Placement: Speciy the position of the color scale labels on the color scale panel. Select from Alternate, Top, Bottom, or select the <Expression...> option to open the Expression Editor and create an expression.

Interval: Specify the frequency of the labels on the color scale panel. A value of 0 means no labels are displayed.

Tick mark length: Specify the length of the tick marks on the color scale panel.

Text: Specify the text of the color scale panel.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Specify a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the color scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the color scale panel. Shadow offsets are drawn to the right and below an element.

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Initial visibility

  • Visible: The color scale is visible when the report runs.
  • Hidden: The color scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the color scale is visible. True for hidden, false for visible.

Action

Select one of the following actions to perform when a user clicks on the color scale element.

  • None: The default behavior is to do nothing when a user clicks the color scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.
  • Apply Parameters: Select the Name, the Type, and the Value of the parameter to set a parameter value through user action. See Actionable Parameters for more information.

Important Properties

By clicking on the Map control, you can set its properties in the Properties panel.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
AntiAliasing | Select the anti-aliasing type from All, None, Text, or Graphic.
BorderColor | Choose a color for the border from the Color Picker.
BorderStyle | Select a style for the border.
BorderWidth | Enter a value or expression to set the width of the border.
Calander | Select the type of calendar you want to use.
ColorScale | Specify the range of colors that are used for data visualization on a layer. See the Color Scale section for details.
DistanceScale | Specify a certain distance on the map that equals a certain distance in the real-world. See the Distance Scale section for details.
Language | Choose the language of the map.
Layers | Specify the layers (Polygon layer, Point layer, Line layer, Tile layer) used to display data on the map. See the Map Layers section for details.
Legends | Specify the map data visualization rules, such as color, size, and marker type differences, for map elements on a layer. See the Legends section for details.
MaximumSpatialElementCount | Specify the maximum number of spatial elements that are allowed in the Map. By default, the value is set to 20000.
MiximumTotalPointCount | Specify the maximum total number of map points in all spatial elements that are allowed in the Map.
NumeralLanguage | Choose the numeral language.
NumeralVariant | Choose numeral variant from 1-7.
PageBreak | Set the Page Break.
ShadowIntensity | Entre a value or expression to specify the intensity of the shadow throughout the map. By default, the value is set to 25.
Size | Set the Width and Height of the map.
TextAntiAliasingQuality | Select the text anti- aliasing quality to High, Normal, or SystemDeafult.
TileLanguage | Choose the primary language of the map tiles.
Titles | Specify the theme or subject of the map. See the Title section for details.
ViewPort | Specify the coordinates, projection system, parallels and meridians, center point, and scale of the map. See the Viewport section for details.

Map Dialog Properties

You can set the Map properties in the Map dialog. To open it, with the Map selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Appearance
Data Output

Name: Enter a name for the map that is unique within the report. This name is called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Antialiasing: Select the smoothing mode to apply to all map control elements. Choose All, None, Text, Graphic, or select the <Expression...> option to open the Expression Editor and create an expression.

Antialiasing quality: Select the quality for antialiasing. Choose High, Normal, SystemDefault, or select the <Expression...> option to open the Expression Editor and create an expression.

Initial visibility

  • Visible: The map is visible when the report runs.
  • Hidden: The map is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the map is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the map. The user can click the toggle item to show or hide this map.

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Select a Web or custom color for the font.

Background

  • Color: Select a color to use for the background of the map.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Element name: Enter a name to be used in the XML output for this map.

Output: Choose Auto, Yes, or No to decide whether to include this map in the XML output. Choosing Auto exports the contents of the map.

Add a Map to a Report

  1. From the Visual Studio toolbox, drag a Map control onto the design surface.

  2. In the Select a Map Template wizard that appears, select a map template from the following options:
    Select a Map Template wizard

    • Empty map: An empty map without any predefined data.
    • USA map: A map with the predefined polygon layer that contains the embedded spatial data with the USA map.
    • From ESRI file: Select from your local .shp file, the shapefile spatial data format that complies with the Environmental Systems Research Institute, Inc. (ESRI). An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, checkout the TIGER/Line Geodatabases article.

For more information on adding a map, see tutorial on Map Data Region in Reports.

Add Data to a Map

The Map data region uses two types of data - spatial data and analytical data.

Spatial Data

Spatial data is a set of coordinates that defines a map element. Each map layer must have spatial data of one of the following types - a polygon, a line, or a point.

Spatial data can be either embedded in a map or can be linked to a map layer. The only difference between the two is that while having the spatial data embedded in a map, there is no separate file to locate or to keep track of when you move the report between projects or machines.

  • Embedded Spatial Data:

    Embedded spatial data can refer to the following:

    • Embedded ESRI shapefile or dataset: When you use the Embedded option in Map Layer Data Properties dialog or the From ESRI file option in the Map Wizard to import spatial data from an ESRI shapefile, the ESRI shapefile gets embedded in the Map. Similarly, if a report dataset is been used to provide spatial data to a map layer, you always have an option of embedding that spatial data in the map using the Embed Spatial Data option that appears in the layers pane. See, Layers to learn embedding spatial data to a map.
    • Custom data: When you add an empty layer to a map and enter spatial data manually in the LayerDesigner Collection Editor, the data entered gets embedded to the map automatically.

  • External Spatial Data:

    External spatial data can refer to the following:

    • Remote or Local ESRI shapefile: When you use the Linked option in Map Layer Data Properties dialog or use the File property in the Properties Panel to specify the local or remote path/location of an ESRI shapefile, the ESRI shapefile gets linked to the Map layer. However, it remains an external source as the dependent ESRI shapefile needs to moved along with the report between projects or machines.
    • Report Dataset: When you use a report dataset to provide spatial data to a map layer and you don't embed the spatial data, it remains an external source. This requires the dependent database file to moved along with the report between projects or machines.

Analytical Data

Analytical data is the data that you want to visualize on the map, for example, tourist attractions in a city or product sales by region. For analytical data, you can associate it with map elements by indicating match fields in the Match box of the Map Layer Data Properties dialog. You can use one or more fields in the Match box of the Map Layer Data Properties dialog; for each spatial data field you must indicate a unique analytical data field. This data is optional.

You can get analytical data from the following types of data sources.

  • Dataset field: A field from a dataset.
  • Spatial data source field: A field from the spatial data source. For example, you can often find that an ESRI Shapefile contains both spatial and analytical data. Field names from the spatial data source are marked with the # sign in the drop-down list of fields.
  • Embedded data for a map element: After you embed polygons, lines, or points in a report, you can select the data fields for map elements and define custom values.

See Add Data to a Map tutorial.

Map Layers

A map is a collection of layers that display data on the map control.

  • Polygon layer: Display outlines of areas or markers for the polygon center point.
  • Point layer: Display markers for point locations.
  • Line layer: Display lines for paths or routes.
  • Tile layer: Adds a Bing map tiles background.

A map can have one or more layers. You can load these layers on top of each other to create a more detailed map. For example, a polygon layer can represent the borders of a country, a line can represent transportation routes, a point can represent the locations and a tile can add a virtual earth background on the map. See Use Map Layers for more information.

Map layer element appearance:

  • Properties that you set on a polygon layer, line layer and a point layer apply to all map elements on that layer, whether or not the map elements are embedded in the report definition.
  • Properties that you set for rules apply to all map elements on a layer. All data visualization options apply only to map elements that are associated with spatial data.

Map Layer Data Dialog

The Map layer Data dialog is used to set up spatial and analytical data for the map control. For more information on spatial and analytical data, see Add Data to a Map.

General
Analytical Data
Filters

Spatial data source: Select one of the spatial data source connection types:

  • Embedded: The map layer data is loaded from the .shp data source that you embed into the map layer by indicating the .shp file in the Import spatial data from file: field. This field appears below when you select this option.

    Spatial fields: Use the plus sign button to add a field, and the X button to delete a field. For each newly added spatial field, you must specify the name and type in the corresponding fields below.

    Field name: Enter a name of a spatial field.

    Field type: Select the type of a spatial field from the list.

  • Linked: The map layer data is linked to the .shp file and is uploaded at report rendering. You select this type of data source by indicating the .shp file in the File Name field that appears.
  • Dataset: The map layer data is loaded from the data source of the report. In the Dataset field and in the Field name field that appear below, select a dataset from the bound data source and a dataset field.
    Caution: In Field name, simply type the name of the dataset field that contains spatial data. For example, enter the dataset field name as StateName, not as =[StateName].
  • Analytical data: The map layer data is loaded from the the analytical dataset of the bound report data source. In the Field name field that appears below, you must set the name of the data field that contains spatial data in the Analytical dataset.
Caution: In Field name, enter the data field name as =[StateName], not as StateName.

Dataset: Select the dataset for the analytical data to be displayed on the map layer.

Match: Use the plus sign button to add a relationship between a spatial data field and an analytical data field.

Spatial field: A field with spatial data that specifies an element on the map surface, for example, boundaries of a country.

Analytical field: A field with analytical data that displays information on the related map element, for example, the country population.

The Filters page of the Map Layer Data Properties dialog allows you to filter the data that is included in the map. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the map.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

Color, Marker, and Size Rules

Rules apply properties to a layer when the layer has map elements that have a relationship to analytical data. For example, the color rule varies map element color based on color palette, color range, custom colors, and further specify the distribution option to control display values.

The type of rule depends on the layer type. For example, use point size rules to vary bubble size based on population.

See Use Color Rule, Marker Rule, and Size Rule for more information.

See Also

Tutorial: Map Data Region

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add a Title to the Map

Add a Title to the Map
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Add a Title to the Map

Glossary Item Box

Map Title describes the theme or subject of the map. Use these steps to learn adding a title on a map control.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Titles (Collection) property and then click the ellipsis (...) button that appears.
  3. In the MapTitleDesigner Collection Editor that appears, in the Members list of titles, Title with the default property settings already exist.

    Map TitleDesigner Collection Editor

  4. In the Properties Panel, you can modify the text, font, border and the background color settings of the map title.

  5. Click OK to close the dialog.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add a Legend to the Map

Add a Legend to the Map
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Add a Legend to the Map

Glossary Item Box

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend. Use these steps to learn adding and setting a legend on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Legends (Collection) property and then click the ellipsis (...) button that appears.
  3. In the LegendDesigner Collection Editor that appears, click Add under the Members list of legends. Legend1 with the default legend settings appears in the Members list.

    Map LegendDesigner Collection Editor
  4. With Legend1 selected in the Members list of legends, you can make modifications to its font, border and background color settings.
  5. Click OK to close the dialog.
    Note: You can associate the newly added legend to a layer by specifying its name in the Legend Name field that appears in the Legend tab on a specific rule page of a Layer dialog. See Use Color Rule, Marker Rule, and Size Rule for more information.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set the Distance Scale on a Map

Set the Distance Scale on a Map
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Set the Distance Scale on a Map

Glossary Item Box

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. Use these steps to learn setting a distance scale on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the DistanceScale property and then click the ellipsis (...) button that appears.
  3. In the Map Distance Scale dialog that appears, on the General page, you can set the location and the color of the distance scale.

    Map Distcance Scale
  4. On the Appearance page of the dialog, you can make modifications to the border width, style, color and background color.
  5. On the Font page of the dialog, you can make modifications to the font properties of the distance scale.
  6. On the Visibility page of the dialog, you can setup the visibility mode of the distance scale.
  7. On the Navigation page of the dialog, you can setup the interactivity features for the distance scale.
  8. Click OK to close the dialog.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set the Color Scale on a Map

Set the Color Scale on a Map
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Set the Color Scale on a Map

Glossary Item Box

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. Use these steps to learn setting a color scale on a map.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the ColorScale property and then click the ellipsis (...) button that appears.
  3. In the Map Color Scale dialog that appears, on the General page, you can set the location and the color of the color scale.

    Map Color Scale
  4. On the Labels page of the dialog, you can make modifications to the properties of the color scale labels.
  5. On the Title page of the dialog, you can make modifications to title text and font properties of the color scale.
  6. On to the Appearance page, you can make modifications to the border width, style, color and background color.
  7. On the Font page, you can make modifications to the font properties of the color scale.
  8. On the Visibility page, you can setup the visibility mode of the color scale.
  9. On the Navigation page, you can setup the interactivity features for the color scale.
  10. Click OK to close the dialog.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add Data to a Map

Add Data to a Map
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Add Data to a Map

Glossary Item Box

ActiveReports provide numerous ways to add spatial data to the map. You can either use the Map Wizard and add data from an ESRI shapefile or use the Map Layer Data Properties dialog for using advance options. You can also add spatial data from the Properties Panel.

Add Spatial Data

Using Map Wizard

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select From ESRI file.
  3. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files, select the .shp file, use the Map Resolution slider to simplify vector data and click Open.

This option automatically imports the spatial data stored in the shapefile and adds a related layer to the map control.

Using the Map Layer Data Properties dialog

The Map Layer Data Properties dialog provide the following advance options to add spatial data. For more information on Map Layer Data Properties dialog, see Map.

Map Data Layer Properties Dialog

Embedded: Use this option where you want to add spatial data from an ESRI file along with an additional option of adding custom spatial data fields if required.

Add Spatial data from an ESRI file using the Embedded option

  1. In the Map Layer Data Properties dialog, on the General page, select the Embedded option and click the Browse button.
  2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
  3. Select the .shp file, use the Map Resolution slider to simplify vector data and click Open. The fields list gets populated with spatial data fields that are added from the shapefile.
  4. In Dataset, set the name of the dataset.
  5. In the Fields list, click the Add (+) button to add a new empty spatial data field.
  6. With the newly added spatial data field selected in the list, in Field name, enter the name of the field.
  7. In Field type, set the field type of newly added spatial data field.
  8. Click OK to close the dialog.
Note: In order to apply the new spatial data field on a layer, you must provide its value for each map layer element like polygons, points or lines in the added map layer Designer Collection Editor dialog.

Linked: Use this option when you just want to add spatial data from an ESRI shapefile without any additional modifications or additions.

Add Spatial data from an ESRI file using the Linked option

  1. In the Map Layer Data Properties dialog, on the General page, select the Linked option and click the Browse button.
  2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
  3. Select the .shp file and click Open.
  4. Click OK to close the dialog.

Dataset: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. You can directly use the data fields from the dataset to display data on a map layer without setting the match fields for analytical data. Therefore, it also provides you an additional option of having different dataset for analytical data and spatial data respectively.

Add Spatial data from a Dataset

  1. In the Map Layer Data Properties dialog, on the General page, select the Dataset option.
  2. In Dataset, set the name of the dataset.
  3. In Field name, enter the data field name that contains the spatial data.

    Caution:

    • Simply type the name of the dataset field that contains spatial data. For example, enter value as StateName, not as =[StateName].
    • You cannot use the MapPoint() function in parameters.
  4. Click OK to close the dialog.

Note:

  • MapPoint() function is supported for Point layer only.
  • Simple (non spatial) data can also be added as Spatial field using MapPoint() expression as  =MapPoint(<Latitude>, <Longitude>) from Expression Editor.

Analytical : Use this option when you want to use the spatial data field from the same dataset that you may use for adding Analytical data to the layer. For using this option you need to first set the dataset for analytical data and then use the spatial data field from the dataset to provide spatial data to the map layer.

Add spatial data from Analytical data

  1. Configure Analytical data for the Map control. See the dropdown section below to learn adding Analytical data.

    Note: Once the Analytical data has been set, the Analytical option on the General page of the Map Layer Data Properties dialog becomes active.
  2. In the Map Layer Data Properties dialog, on the General page, select the Analytical option.
  3. In Field name, enter the data field name that contains the spatial data.
    Caution: In Field name, enter the data field name as =[StateName], not as StateName.
  4. Click OK to close the dialog.

Using Properties Panel

These steps assume that you have a Map control containing at least one map data layer placed on the design surface. To learn how to add a layer to the Map control, see Layers.

  1. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under Members, select the map data layer you want to use and expand the SpatialData property.
    Map LayerDesigner Collection Editor
  3. In Type, choose the spatial data source of the layer from the following supported options:
    • Embedded: Use this option when you want to add custom spatial data to the map data layer. This can be done by first adding the spatial data fields for the embedded spatial data using the MapFieldDefinitionDesigner Collection Editor which can be accessed through the FieldDefinitions property. And then later adding spatial data (points, polygons or lines) using the PolygonDesigner Collection Editor, PointsDesigner Collection Editor or LineDesigner Collection Editor depending on the layer in use. These Editor dialogs can be accessed using the SpatialData > Polygons, SpatialData > Points or SpatialData > Lines property.
    • File: Use this option when you want to add spatial data from an ESRI file. Use the Source property to specify the location of the shapefile.
      Note: The specified location must contain the shape format (.shp) and attribute format (.dbf) files.
    • DataSet: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the DataSet option in the Map Layer Data Properties dialog. Use the SpatialData > DataSetName property to specify the name of the dataset and the SpatialData > SpatialField property to specify the data field that contains spatial data.

      Note:

      • MapPoint() function is supported for Point layer only.
      • Simple (non spatial) data can also be added as Spatial field using MapPoint() expression as  =MapPoint(<Latitude>, <Longitude>) from Expression Editor.

      Caution: You cannot use the MapPoint() function in parameters.
    • DataRegion: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the Analytical option in the Map Layer Data Properties dialog. Use the LayerData > DataSetName property to specify the name of the dataset and the SpatialData > VectorData property to specify the data field or expression that contains spatial data.
  4. Click OK to close the dialog.

Add Analytical Data

Analytical data is the data that you want to visualize on the map, for example, tourist attractions in a city or product sales by region. For analytical data, you can associate it with map elements by indicating match fields in the Match box of the Map Layer Data Properties dialog. You can use one or more fields in the Match box of the Map Layer Data Properties dialog; for each spatial data field you must indicate a unique analytical data field. This data is optional.

You can get analytical data from the following types of data sources.

  • Dataset field: A field from a dataset.
  • Spatial data source field: A field from the spatial data source. For example, you can often find that an ESRI Shapefile contains both spatial and analytical data. Field names from the spatial data source are marked with the # sign in the drop-down list of fields.
  • Embedded data for a map element: After you embed polygons, lines, or points in a report, you can select the data fields for map elements and define custom values.

Add Analytical Data to the Map control

Use the following steps to add analytical data to the map. These steps assume that you have added a page layout template to your report and have a data connection in place.

  1. Add spatial data to the map control. See the dropdown sections above to learn adding spatial data to the map control.
  2. In the Map Layer Data Properties dialog, go to the Analytical data page.
  3. Select the dataset that you want to use from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties.
  4. In the Spatial field and Analytical field options set data fields that contain same data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a map layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  5. Click OK to close the dialog.

See Also

Map

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Modify the Appearance of the Viewport

Modify the Appearance of the Viewport
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Modify the Appearance of the Viewport

Glossary Item Box

Viewport refers to the area on the map where map data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually display geographical data and occupies most area of the map control depending on the location and dock position of other map elements. See Map for more information.

You can modify Viewport properties to make the map look more attractive.

  1. On the design surface, select the Map control.
  2. Go to the Properties window, click the Viewport property and then click the ellipsis (...) button that appears.
  3. In the Map Viewport dialog that appears, on the General page, choose the Coordinate system. The map viewport supports the following two coordinate system:
    MapViewport Dialog

    • Geographic: Specifies Earth coordinates by defining longitude and latitude values. If you set the CoordinateSystem property to Geographic, then you must specify the Projection property. A projection is a set of rules on how to locate three-dimensional objects onto a planar surface.
    • Planar: Specifies geometric coordinates on a two-dimensional surface by using X and Y values. and in case you set it to Geographic then set the Projection.
  4. Go to the Meridians page, set its visibility and its line and font style and color.
  5. Similarly, go to the Parallels page, set its visibility and its line and font style and color.
  6. On the View page of the dialog, choose a Center and Zoom mode. The map viewport supports the following four center and zoom modes:
    • Custom: Choose this option to specify custom values for the view center and the zoom level.
    • Center map to show a map layer: Choose this option to specify a layer and automatically, center the view on its map data. For example, center the view on LineLayer1.
    • Center map to show a map element: Choose this option to center the view on a specific data bound map element. For example, center the view on the map element where the name of the match field is [StateName] and the match value is "Washington".
    • Center map to show all map elements: Choose this option to center the view on all map elements in the layer.
    Note: Zoom and View Center level can also be set from the design surface using the zoom slider and arrow keys that appears in the View Pane of the Map control.
  7. On the Appearance page, set the Border and Background style and color of the viewport.

  8. Click OK to close the dialog.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Use Map Layers

Use Map Layers
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Map Layers

Glossary Item Box

A map is a collection of layers that display data on the Map control.

This topic illustrates how to add, remove, and change order of layers. It also shows how to add interactive navigational feature to map layer elements.

Add a map layer

From the design surface

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. Click the Map until the map panes appear.
  4. Right-click inside the area labeled "right-click to add the new layer." and select the map layer you want to use.

Using the LayerDesigner Collection Editor

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  4. In the LayerDesigner Collection Editor that appears, use the Add combo-box to view the list of available layers and select the map layer you want to use.

Delete a map layer

From the design surface

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right-click the layer you want to remove and select Delete.

Using the LayerDesigner Collection Editor

  1. On the design surface, with the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to delete and click the Remove button.

Change order of layers

Map layers are rendered from left to right in the order that they appear in the map panes. In the image below, the polygon layer is drawn first and the line layer is rendered last. Layers that are rendered later might hide map elements on layers that are rendered earlier. You can change rendering order of layers added to the map control using the LayerDesigner Collection Editor. Follow these to steps learn re-ordering the layers on a map.

Polygon, Point, Line and Tile layers

  1. On the design surface, with the Map control selected, go to the Properties window.
  2. In the Properties Panel, click the Layers (Collection) property and then click the ellipsis button that appears.
  3. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to reorder and use the up or down arrow to change the rendering order of each layer.
  4. Click OK to close the Collection Editor.

Embed layer spatial data or tiles in a map

When you embed map elements or map tiles in a report, the spatial data is stored in the report definition.

  1. Click the map until the map panes appear.
  2. In the layers pane, right-click the added layer that contains spatial data, select Embed Spatial Data and then select All Spatial Data or Currently Visible Data. In case of Tile layer select Embed Tiles.
    Note: All Spatial Data refers to all the spatial data fields, while Currently Visible Data refers to the spatial data field that is set in the Field property.

Add Hyperlinks, Bookmarks, and Drill-through links

Map layer elements like point, polygon and line provides you a functionality to set interactive navigational features like a bookmark link to jump to other areas in the same report, a hyperlink to jump to a Web address, or a drill-through link to jump to another report. Follow these steps to learn adding hyperlinks, bookmarks and drill-through links to a layer element:

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right-click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select from the following actions to perform when a user clicks a data layer element :
    • None: The default behavior to indicate that the item has no action.
    • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.
      • Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

      For detailed steps on adding a drill-through link, see Drill-Through Links.

    • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to another report control with the same Bookmark ID.
      For more information on adding bookmarks, see Bookmarks.

    • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
      For more information on adding hyperlinks, see Hyperlinks.

  5. Click OK to close the dialog.

See Also

Polygon Layer
Point Layer
Line Layer
Tile Layer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Polygon Layer

Polygon Layer
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Map Layers > Polygon Layer

Glossary Item Box

A Polygon layer display outlines of areas or site boundaries that can be linked to Locations and can be used to select records that fall within the boundary for reporting usage.

Use the following steps for creating a basic map using the Polygon layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Data Binding in Page/RDLX Reports for more information.

  1. From the toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right-click inside the area labeled "Right click to add the new layer." and select Add Polygon Layer. This adds a polygon layer to the map and opens the Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (polygons) from a shape file or use a data field from the analytical data to specify the spatial data source.
  6. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties. See, Add Data to a Map for more information.
  7. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a polygon layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  8. Go to the Filters page and set filters if any.
  9. Click OK to close the dialog.
  10. In the layers pane, right-click on PolygonLayer1 and select Edit to open Map Polygon Layer dialog.

    Map Polygon Layer Properties - General dialog

  11. In the General page of the dialog, select any data field from the Label Text combo box to display as labels inside polygons at run time.
  12. Go to the Color Rule page of the dialog, to set rules to visualize data using color pallets, color ranges or custom colors for polygons or polygon center points that gets displayed on the map or keep it set to the default "Use Appearance settings". See, Use Color Rule, Marker Rule, and Size Rule for more information.
  13. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  14. In the Navigation page of the dialog, you can optionally link the polygon to a URL, bookmark or a report.
  15. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  16. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  17. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  18. Click OK to close the dialog and go to the preview tab to view the map.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Point Layer

Point Layer
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Map Layers > Point Layer

Glossary Item Box

A Point layer displays markers for point locations such as a city or an address for a store, restaurant, or school.

Use the following steps for creating a basic map using the Point layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Data Binding in Page/RDLX Reports for more information.

  1. From the toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right-click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot points on. See, Polygon Layer or Tile Layer for steps to add these layers on a Map control.
  5. Right-click again inside the area labeled "Right click to add the new layer." and select Add Point Layer. This adds a point layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (points) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Add Data to a Map for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to the design surface.
  11. In the layers pane, right-click on PointLayer1 and select Edit to open Map Point Layer dialog.

    Map Point Layer Properties - General dialog

  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as a label for each point that gets displayed on the map at run time. You can also set the label placement, size, and marker type.
  13. Go to the Marker Rule page to set rules to visualize data using markers or keep it set to "Use default marker type".
  14. Go to the Size Rule page to set rules to visualize data using different marker sizes or keep it set to "Use default marker size". See, Use Color Rule, Marker Rule, and Size Rule for more information.
  15. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges, or custom colors for markers that gets displayed on the map or keep it set to "Use Appearance settings".
  16. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  17. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark, or a report.
  18. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  19. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set, and color for the label text that you had set in the General page of the dialog.
  20. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  21. Click OK to close the dialog and go to the preview tab to view the map.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line Layer

Line Layer
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Map Layers > Line Layer

Glossary Item Box

A Line layer displays routes and paths between different locations, for example, transportation route between two stores.

Use the following steps for creating a basic map using the Line layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Data Binding in Page/RDLX Reports for more information.

  1. From the toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right-click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot lines on. See, Polygon Layer or Use a Tile Layer for steps to add these layers on a Map control.
  5. Right-click again inside the area labeled "right-click to add the new layer." and select Add Line Layer. This adds a Line layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (lines) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Add Data to a Map for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to the design surface.
  11. In the layers pane, right-click on LineLayer1 and select Edit to open Map Line Layer dialog.

    Map Polygon Layer Properties - General dialog

  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as a label for each line that gets displayed on the map at run time. You can also set the label placement.
  13. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges, or custom colors for lines that get displayed on the map, or keep it set to "Use Appearance settings". See, Use Color Rule, Marker Rule, and Size Rule for more information.
  14. Go to the Size Rule page to set rules to visualize data using line width or keep it set to the default line width.
  15. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide a layer based on any expression or zoom value.
  16. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark, or a report.
  17. Go to the Appearance page of the dialog and set the style, width, and color of the layer border and the layer background.
  18. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set, and color for the label text that you had set in the General page of the dialog.
  19. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  20. Click OK to close the dialog and go to the preview tab to view the map.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tile Layer

Tile Layer
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Map Layers > Tile Layer

Glossary Item Box

Show All Show All
Hide All Hide All

A Tile layer displays the virtual earth tile background on the map.

Use the following steps for creating a basic map using the Tile layer. These steps assume that you have added a page layout template to your report and have a data connection in place. See Data Binding in Page/RDLX Reports for more information.

  1. From the toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right-click inside the area labeled "Right click to add the new layer." and select Add Tile Layer. This adds a tile layer to the map and opens the Map Tile Properties dialog.

    Map Polygon Layer Properties - General dialog

  5. In the Map Tile Properties dialog that appears, on the General page, set the layer name and choose its Source and Type. The default values in these fields also work fine.
  6. In the Provider property, choose one from the following supported tile providers:
    • Bing: The Microsoft Bing Map server offers static map images. This requires an Application key for authentication. The default key provided by ActiveReports is for demo purposes and can't be used by 3rd party applications. To obtain a Bing Map Key, see HowTo - Create a Bing Map Account and HowTo - Get a Bing Map Key.
      Note: After generating the key, add the following script in the ActiveReports.config file to configure embedded Bing tile provider with Application key.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <MapTileServerConfiguration>
   <Timeout>5</Timeout>
   <AppID>"Your Application Key"</AppID>
</MapTileServerConfiguration>

    • Caution: The ActiveReports.config file should always be placed in the same folder as the EndUserDesigner.exe file for displaying a Bing tile layer on a Map.
    • Google: The Google Map server creates your map tiles based on URL parameters sent through a standard HTTP request that returns the map tiles as an image. It is necessary to set the API key to monitor the usage of this tile server with the Google API Console. Please register with Google account with the billing information to obtain a key.

      Note: After obtaining the key, add the following script in the ActiveReports.config file to configure embedded Google tile provider with ApiKey.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <!-- Configure embedded Google tile provider with API Key -->
<MapTileProvider Name="Google" DisplayName="Google" >
    <Settings>
      <add key="ApiKey" value="API Key" />
      <add key="Timeout" value="5000" />
    </Settings>
</MapTileProvider>
    • MapQuest: The MapQuest tile server provides the tiles in a format similar to Google. This tile server requires an API Key for authentication which can be obtained by registering at MapQuest.
      Note: After generating the key, add the following script in the ActiveReports.config file to configure embedded MapQuest tile provider with ApiKey.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <!-- Configure embedded MapQuest tile provider with ApiKey -->
<MapTileProvider Name="MapQuest" DisplayName="Map Quest Tiles Provider">
    <Settings>
      <add key="ApiKey" value="API Key" />
      <add key="Timeout" value="3000" />
    </Settings>
</MapTileProvider>
    • OpenStreetMap: The OpenStreetMap server provides the tiles in an index based format. This tile server provides only the roadmap and returns fixed size images (256x256). Before using the OpenStreetMap server, go through the Copyright and License and Tile usage policy pages.
  7. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide a layer based on any expression or zoom value.
  8. Click OK to close the dialog and go to the preview tab to view the map.

Note: If you are using a proxy server connection to see the map tile images, you need to set credentials for the proxy server in the application config file for authentication. To use your default proxy server credentials, you can do the following:

For Visual Studio Designer (IDE)

  1. Find devenv.exe.config (the devenv.exe configuration file) in: Program Files (x86)\Microsoft Visual Studio\2019 or 2022\Professional\Common7\IDE
  2. In the configuration file, find the <system.net> block, and add this code:
    Paste inside the <system.net></system.net> tags. Copy Code
    <defaultProxy useDefaultCredentials="true" />

For Visual Studio Application

  1. On the menu bar, choose Project, Add New Item and then choose the Application Configuration File template.
  2. In the Name text box, enter a name, and then click Add button.
  3. In the configuration file, add this code:
    Paste inside the <configuration></configuration> tags. Copy Code
    <system.net>
    <defaultProxy useDefaultCredentials="true" />
    </system.net>
Note: ActiveReports.config file should be kept inside the project Debug folder and added to a Visual Studio project for displaying a Tile layer on a Map in any Viewer control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Use Color Rule, Marker Rule, and Size Rule

Use Color Rule, Marker Rule, and Size Rule
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Map > Use Color Rule, Marker Rule, and Size Rule

Glossary Item Box

You can visualize the data displayed on a map by setting rules to control color, size or marker type for all map elements on a layer. You can set three types of rules as explained in the sections below depending on the type of layer in use.

Color Rule

Color Rule is set to fill colors for map elements like polygons, markers (points or polygon center points), and lines while using a Polygon, Point, or Line layer. Color Rule provides four options:
Map Color Rule

  • Apply Appearance Settings: Use the default appearance settings that are set in the Appearance page of the map layer dialog.
  • Visualize data by using color palette: This option uses an in-built palette that you specify. Based on related analytical data, each map element is assigned a different color from the palette.
  • Visualize data by using color ranges: This option, combined with the start, middle, and end colors that you specify on this page and the options that you specify on the Distribution page, divides the related analytical data into ranges. The report then assigns the appropriate color to each map element based on its associated data and the range that it falls into. For example, in a map that uses color to display temperatures on a scale of 0 to 100, low values are blue to represent cold and high values are red to represent hot.
  • Visualize data by using custom colors: This option uses the list of custom colors that you specify. Based on related analytical data, each map element is assigned a color from the list.

Set Color Rule for polygons, lines, and markers

Using color palette

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using color palette option.
  5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
  6. In Palette, set the name of the palette to use.
  7. Click OK to close the dialog.

Using color ranges

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using color ranges option.
  5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
  6. In Start color, set the color to be used for the color range.
  7. In Middle color, set the color to be used for the color range.
  8. In End color, set the color to be used for the color range.
  9. Click OK to close the dialog.

Using custom colors

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using custom colors option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize by color.
  6. Click Add to specify each custom color.
  7. Click OK to close the dialog.

Marker Rule

Marker Rule is set on markers that represent points or polygon center points on a map while using a Point layer. Marker Rule support two options:

Map Marker Rule

  1. Use a default marker type: You specify one of the available marker types.
  2. Visualize data using markers: This option uses a set of markers in the order in which you want them to be used. Marker types include Rectangle, Circle, Diamond, Triangle, Trapezoid, Star, Wedge, Pentagon, PushPin and Image.

Set Marker Rule for points

Visualize points using default marker type

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Marker Rule page.
  4. In the Marker Rule page, select the Visualize data using markers option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
  6. Click Add and specify each Marker type in the order in which you want them to be used.
  7. Click OK to close the dialog.

Visualize points using specific marker types

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Marker Rule page.
  4. In the Marker Rule page, select the Visualize data using markers option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
  6. Click Add and specify each Marker type in the order in which you want them to be used.
  7. Click OK to close the dialog.

Visualize points using Image as marker type

ActiveReports provides Image as one of the many available marker types to use from. You can set this marker type and use any image as a marker on a map layer. Like other marker types, you can either use it as a default marker or use it as one of the member in the markers collection.

Use Image as Default marker type

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, on the General page, set Marker Type to Image. A new set of properties appears on the page.
  4. In Image Source, choose the source of image from the provided options:
    • External: Select this option and set a path or url of the image file in Image Value.
    • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
    • Database: Select this option and set the data field containing the image in the Image Value property.
  5. In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
  6. Set the Transparent Color and the Resize Mode.
  7. Click OK to close the dialog.

Use Image in markers collection

  • Click the Map until the map panes appear.
  • In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  • In the selected map layer dialog that appears, go to the Marker Rule page.
  • In the Marker Rule page, select the Visualize data using markers option.
  • In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
  • Click Add and set Marker type to Image. A new set of properties for image marker types appears on the page.
  • In Image Source, choose the source of image from the provided options:
    • External: Select this option and set a path or url of the image file in Image Value.
    • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
    • Database: Select this option and set the data field containing the image in the Image Value property.
  • In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
  • Set the Transparent Color and the Resize Mode.
  • Click OK to close the dialog.

Size Rule

Size Rule is set on markers, polygon center points or line width while using a Polygon, Point or a Line layer. Size Rule support two options:

Map Size Rule

  1. Use a default marker size or Use a default line width: You specify the marker size or line width in points.
  2. Visualize data by using size or Visualize data by using line width: In this option, you set the minimum (start) and maximum (end) sizes or width for marker or line, specify the data field to be used for varying the marker size or line width and then specify the distribution options to apply to that data.

Set Size Rule for markers and line width

Visualize marker or line using default marker size or line width

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Size Rule page.
  4. In Default, set default size or width for each marker or line that appears on a map.
  5. Click OK to close the dialog.

Visualize marker or line using specific marker size or line width

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Size Rule page.
  4. In the Size Rule page, select Visualize data by using size or Visualize data by using line width depending on the layer type in use.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker sizes or line width.
  6. Set Start size and End size in case of Point Layer or Minimum line width and Maximum line width in case of Line Layer.
  7. Click OK to close the dialog.

Distribution Options

The distribution values are used by the rules to differ the map element display values.

To create a distribution of values, you divide your data into ranges by specifying the distribution method, the number of sub-ranges, and the range start and end values.

To set distribution values for rules, follow these steps:

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify distribution values.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Distribution tab.
  5. On the Distribution tab, select one of the following distribution types:
    • EqualInterval: Create ranges that divide the data into equal range intervals. For the example, the three ranges would be 0-2999, 3000-5999, 6000-8999. Sub-range 1: 1, 10, 200, 500. Sub-range 2: 4777. Sub-range 3: 8999.
    • EqualDistribution: Create ranges that divide that data so that each range has an equal number of items. For example, the three ranges would be 0-10, 11-500, 501-8999. Sub-range 1: 1, 10. Sub-range 2: 200, 500. Sub-range 3: 4777, 8999.
    • Optimal: Specifies ranges that automatically adjust distribution to create balanced sub-ranges. The number of Sub-ranges is determined by the algorithm.
    • Custom: Specify your own number of ranges to control the distribution of values. For example, you can specify your own custom ranges 0-5000 and 5001-10000.
  6. In Number of Sub-ranges, type the number of sub-ranges to use.
  7. In Range start, type a minimum range value. All values less than this number are the same as the range minimum.
  8. In Range end, type a maximum range value. All values larger than this number are the same as the range maximum.
  9. Click OK to close the dialog.

Displaying Rule results in Legend

To display rule results in legend, follow these steps:

  1. Click the Map until the map panes appear.
  2. In the layers pane, right-click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify displaying rule results in a legend.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Legend tab.
  5. Select Show in legend checkbox and set Legend name.
  6. In Legend text, enter text that specify which data should appear in the legend. Use map keywords and custom formats to help control the format of legend text. For example, #VALUE {C2} specifies a currency format with two decimal places. Following are the supported formats that you can use:
    Format | Description | Example
    #Value | Displays a numeric value calculated using "(EndRangeValue - StartRangeValue)/2" formula.
    #FROMVALUE {C0} | Displays the currency of the total value with no decimal places. | $100
    #FROMVALUE {C2} | Displays the currency of the total value to two decimal places. | $40.25
    #TOVALUE | Displays the actual numeric value of the data field. | 100
    #FROMVALUE{N0} - #TOVALUE{N0} | Displays the actual numeric values of the beginning of the range and end of the range. | 10 - 500
  7. Click OK to close the dialog.

See Also

Demo: Polygon Color Rules
Demo: Point Layer Rules

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Matrix

Matrix
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Matrix

Glossary Item Box

Note:

  • Matrix is an old-style tabular control that has been replaced with a more powerful Tablix data region.
  • Matrix is hidden by default and not supported in the WebDesigner, where it is automatically converted to Tablix.

The Matrix data region contains columns and rows in which the data is inserted and arranged. Columns and rows in a matrix can be dynamic or static. Each cell in a matrix contains a textbox by default, but as with the other data regions, the textbox can be replaced with any other report control. Also like other data regions, the matrix also repeats each report control it contains for each row in the dataset, but unlike the others, it also repeats horizontally for dynamic columns.

Show Cells

When you drop a matrix data region onto your report, it is initially composed of four cells.

The top left cell is the corner or label cell. You can leave this cell blank or use it to display a label for the matrix.

The top right cell is a column header and the bottom left cell is a row header. You can drag fields into these cells or use expressions to group the data.

The bottom right cell is used to aggregate the detail data. At run time, detail cells display aggregates of the intersections of columns and rows.

Show Data

The matrix data region is associated with a dataset. You can make this association in the DataSetName property in the Properties grid.

Show Groups

You can group the columns and rows in the matrix by opening the Property dialog, and on the Row Groups or Column Groups page, editing the Group on expression, or by dragging a field into the header cell.

You can nest column and row groups by right-clicking the UI above a column or to the left of row and choosing Add Column Group or Add Row Group, or simply by dragging another field onto the column or row into which you want to insert it.

To determine where new groups are displayed, when you drag a field into an existing group you can move the mouse up or down (for columns) or left or right (for rows) to nest the new group within the existing group, or to nest the existing group within the new group.

At run time, the nested group repeats within the original group. For instance, when you drag the City field from your dataset onto a header already grouped by Country, the report displays the first country with all of its cities, then the next country with all of its cities, and so on until all of the countries in the dataset are displayed with all of their cities.

Show Static Rows and Columns

To insert a static row or column, right-click the detail cell and choose Add Column or Add Row. This displays a column next to or a row above or below the existing one and adds another detail cell.

Show Aggregates

Groups in a matrix do not subtotal data by default. To add this functionality, right-click the group header and choose Subtotal. This adds a cell to the right of the column, or below the row. Subtotal cells have a green triangle in the upper right corner which allows you to select the subtotal and set its properties in the property grid. For more information, see Expressions.

Show Placement of Data

You can control where data is placed in several ways. You can change the Direction property of the matrix to RTL to cause dynamic column headers to expand left instead of right.

You can also move row headers to the right of the detail cells by changing the GroupsBeforeRowHeaders property of the matrix. The integer value you supply for this property equals the number of instances of the outermost column group that displays to the left of the row headers (or to the left if the Direction property is set to RTL).

Matrix Dialog

Properties for the Matrix are available in the Matrix dialog. To open it, with the Matrix control selected on the report, under the Properties Panel, click the Property dialog link.

The Matrix dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to create an expression to determine the value.

Show General

Name: Enter a name for the matrix that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the matrix in the viewer at run time.

Dataset name: Select a dataset to associate with the matrix. The combo box is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this Matrix is in its own section with regards to pagination.

Page breaks: Select any of the following options to apply to each instance of the matrix.

  • Insert a page break before this matrix
  • Insert a page break after this matrix
  • Fit matrix on a single page if possible

Matrix column expand: Select the direction in which columns expand.

  • Left to right
  • Right to left

Groups before row headers: Select the number of columns to show before the row header columns begin. The default value of 0 displays the row header column to the left.

Show Visibility

Initial visibility

  • Visible: The matrix is visible when the report runs.
  • Hidden: The matrix is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the matrix is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down list where you can select the report control that users can click to show or hide this matrix.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this matrix. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Filters

Click the plus sign button to add a filter to the matrix. Use the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the matrix.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site .
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Row Groups

The Row Groups page of the Matrix dialog allows you to add, remove, or change the order of row groups using the plus sign, X and arrow buttons.

Click the Add button to add a new row group to the list and set up information for each group on the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to identify an instance of the group for document map and search functions.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Show Column Groups

The Column Groups page of the Matrix dialog allows you to add, remove, or change the order of row groups using the plus sign, X and arrow buttons.

Click the Add button to add a new column group to the list, and set up information for each group on the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to identify an instance of the group for document map and search functions.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Data Output

Element name: Enter a name to be used in the XML output for this matrix.

Output: Choose Auto, Yes, or No to decide whether to include this matrix in the XML output. Choosing Auto exports the contents of the matrix.

Cell element name: Enter a name to be used in the XML output for the data element for the cell.

Cell element output: Choose Yes or No to decide whether to include the cell contents in the XML output.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Overflow Placeholder (Page report only)

Overflow Placeholder (Page report only)
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Overflow Placeholder (Page report only)

Glossary Item Box

The Overflow Placeholder control (available only in a Page report) is a rectangular placeholder for data that does not fit inside the fixed size of a List, Banded List, Tablix, or Table data region. In this case, you can link a data region to an Overflow Placeholder; the control gets its Size property values from the FixedSize of the data region it is linked with. So, data that overflows the fixed size of your tables or other data regions can span pages, but you control the layout of each page and specify where the overflow data goes with a placeholder.

You can also place multiple Overflow Placeholder controls in a report to create different looks for your data output. With multiple Overflow Placeholder controls, you should link a data region to an Overflow Placeholder control and then link that Overflow Placeholder control to another Overflow Placeholder control. Two common layouts that you can create are:

  • Columnar Report Layout: Place the data region and the Overflow Placeholder on the same page of the report to create a layout that displays data in a columnar format.
  • Multiple Page Layout: Place the data region on the first page of the report and Overflow Placeholder controls on subsequent pages to create a layout with overflow data on multiple pages.

    Note: If a page contains only an OverflowPlaceHolder with no data to display, the empty page does not render. However, if the page also contains any control with static data, the page renders.

    To skip rendering the page, set the ThrowIfPlaceHoldersEmpty property of the report's Page instance to True.

In RDLX reports, a similar report is can be created by setting the number of columns in the report's Columns property.

See Also

OverflowPlaceholder Control for Columnar Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Shape

Shape
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Shape

Glossary Item Box

The Shape report control is used to display one of the available shape types on a report. You can add a shape report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the ShapeStyle property of the Shape report control, you can select Rectangle, RoundRect or Ellipse, or you can use an expression to assign fields, datasets, parameters, constants, operations or common values to it.

You can highlight different sections or parts of a report using a shape report control. For example, you can use a Rectangle as border around different report controls or the entire page or you can use an Ellipse to highlight a note on your report.

Important Properties

By clicking on the Shape control, you can set its properties in the Properties window.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
BackgroundColor | Choose a color for the background from the Color Picker.
BackgroundImage | Add a background image from External, Embedded, or Database as Source. You can also select the MIME type of the image.
BorderColor | Choose a color for the border from the Color Picker.
BorderStyle | Select a style for the border.
BorderWidth | Enter a value to set the width of the border.
RoundingRadius | Enter a value in points to round the corner of the outer border edge of the RoundRect shape style.
ShapeStyle | Choose a shape style from Rectangle, RoundRect, or Ellipse.
Size | Enter the Width and Height of the shape.

Shape Dialog Properties

You can set the Shape properties in the Shape dialog. To open it, with the Shape selected on the report, under the Properties window, click the Property dialog link.

General
Appearance
Visibility
Navigation
Data Output

Name: Enter a name for the image that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Shape Style: Choose Rectangle, RoundRect or Ellipse from the dropdown list, or select the <Expression...> option to open the Expression Editor.

Rectangle | RoundRect | Ellipse
Rectangle Shape style | Rounded Rectangle Shape style | Ellipse Shape style

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers Handler available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, select the checkbox available near each corner of the Shape control.

Background

Color: Select a color to use for the background of the Shape, or select the <Expression...> option to open the Expression Editor.

Image: Specify the background image of shape using Expression or Data Visualizer, or directly open the image file on your system.

Note: If the Hatch and Gradient background styles are set using Data Visualizers, these are not displayed at design time.
Image Source: Select the location of the image for the background from External, Embedded, Database or select the <Expression...> option to open the Expression Editor.

MIME Type: Select the MIME type of the image.

Background repeat: Specify how the background image fills the space of the shape.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border or select the <Expression...> option to open the Expression Editor.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Initial visibility

  • Visible: The shape is visible when the report runs.
  • Hidden: The shape is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the shape is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle shape next to another report item. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the shape.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this shape. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Element Name: Enter a name to be used in the XML output for this shape report control.

Output: Choose Auto, Yes, No, or Contents only to decide whether to include this Shape in the XML output. Choosing Auto exports the contents of the Shape report control.

See Also

Shape Control for Enhanced Report Appearance

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Sparkline

Sparkline
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Sparkline

Glossary Item Box

You can use the Sparkline report control as a simple means of displaying the trend of data in a small graph. The Sparkline displays the most recent value as the rightmost data point and compares it with earlier values on a scale, allowing you to view general changes in data over time. With the height similar to the surrounding text and the width not more than 14 letters wide, the sparkline fits well in dashboards, reports, and other documents.

Important Properties

By clicking on the Sparkline control, you can set its properties in the Properties panel.

Property | Description
AccessibleDescription | Enter the alternative description of the control for use by accessibility client application. The property on exporting the report adds the ‘alternative text’ in PDF and ‘alt’ attribute in HTML.
DataSetName | Specify a dataset associated with the sparkline.
DataSetParameters | Specify a dataset parameter associated with the sparkline.
FillStyle | Choose the type of gradient for the sparkline from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter. You can also select a color to fill the sparkline from the color picker.
Filters | Add a new filter by specifying the Expression, Operator, and Value.
LineStyle | Enter a value to set the Width of the Line type sparkline. You can also choose the color of the line from the color picker.
Location | Enter a value in points to set the location of the sparkline.
MarkerColor | Select a color for the last point marker or select the Expression option to open the Expression Editor and create an expression that evaluates to a .NET color.
MarkerVisibility | Select whether to display a marker at the last point on the sparkline of Line type.
MaximumColumnWidth | Select the maximum width of columns in the sparkline.
Range | Select a value or enter an expression that defines the lower bound and upper bound of the wall range. By using the backdrop, you can choose the type of gradient and color of the wall range.
RangeVisibility | Select whether to display the range or not.
SeriesValue | Enter a series value of the sparkline.
Size | Enter the Width and Height of the sparkline.
SparklineType | Choose the sparkline type from Line, Columns, Whiskers, Area, or StackedBar.

Sparkline Dialog Properties

You can set the Sparkline properties in the Sparkline dialog. To open it, with the Sparkline selected on the report, under the Properties panel, click the Property dialog link.

General
Data
Appearance
Visibility
Navigation
Filters
Sorting
Data Output

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset Name:

Value: Enter an expression to use as the sparkline value.

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code. A name is created automatically if you do not enter one.

Group on: Enter an expression to use for grouping the data. If you open the expression editor, you can select a field from the dataset.

Detail Grouping: Enter an expression to use if you do not want to repeat values within the details. If you open the expression editor, you can select a field from the dataset.

Parent Group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Sparkline Type: Choose from the following sparkline types. Each of these types has its own set of Appearance properties that appears when you select the type. See Types of Sparklines for more details.

  • Line
  • Columns
  • Whiskers
  • Area
  • StackedBar

Initial visibility

  • Visible: The sparkline is visible when the report runs.
  • Hidden: The sparkline is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the sparkline is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control which, if clicked, toggles the visibility of the sparkline in the Viewer.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this sparkline. You will then be able to provide a bookmark link to this item from another report item using a Jump to bookmark action.

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending for the selected sort expression.

Element Name: Enter a name to be used in the XML output for this sparkline report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this Sparkline in the XML output. Choosing Auto exports the contents of the Sparkline report control.

Types of Sparklines

Line

Sparkline Line Type

The Line sparkline is widely used in financial and economic data analysis and is based on a continuous flow of data. The currency exchange rates, price change are examples of the application of this type of sparklines.

Appearance Properties

Property | Description
Last point marker is visible | Select to display a marker at the last point on the sparkline.
Marker Color | Select a color to use for the last point marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Line Style
Color | Select a color to use for the line, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Width | Enter a value in points to set the width of the line.
Enable Wall Range | Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.
Lower Bound | Select a value or enter an expression that defines the lower bound of the wall range.
Upper Bound | Select a value or enter an expression that defines the upper bound of the wall range.
Wall Range Backdrop
Fill Color | Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Gradient | Choose the type of gradient to use for the backdrop: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, or VerticalCenter.
Gradient End Color | Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Columns

Sparkline Columns Type

The Column sparkline is used for sports scores, cash register receipts, and other cases where previous values and the current value do not closely influence one another. This sparkline is used when dealing with discrete data points, and not a continuous flow of data as in the Line sparkline.

Appearance Properties

Property | Description
Fill Color | Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Maximum Column Width | Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.
Enable Wall Range | Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.
Lower Bound | Select a value or enter an expression that defines the lower bound of the wall range.
Upper Bound | Select a value or enter an expression that defines the upper bound of the wall range.
Wall Range Backdrop
Fill Color | Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Gradient | Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, or VerticalCenter.
Gradient End Color | Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Whiskers
Sparkline Whiskers Type

The Whisker sparkline is typically used in win/loss/tie or true/false scenarios. This type is similar to the Column sparkline, but it renders a tie (0 value) in a different manner. The bars in a whisker sparkline render below the baseline for a negative value, above the baseline for a positive value, and on the baseline for a zero value, for example, in a profit/loss and no profit/no loss scenario.

Appearance Properties

Property | Description
Fill Color | Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Maximum Column Width | Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.
Enable Wall Range | Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.
Lower Bound | Select a value or enter an expression that defines the lower bound of the wall range.
Upper Bound | Select a value or enter an expression that defines the upper bound of the wall range.
Wall Range Backdrop
Fill Color | Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Gradient | Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, or VerticalCenter.
Gradient End Color | Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create

Area
Sparkline Area Type

The Area sparkline is similar to the Line sparkline but visually you see the space under the line as shaded.

Appearance Properties

Property | Description
Fill Color | Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Enable Wall Range | Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.
Lower Bound | Select a value or enter an expression that defines the lower bound of the wall range.
Upper Bound | Select a value or enter an expression that defines the upper bound of the wall range.
Wall Range Backdrop
Fill Color | Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
Gradient | Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, or VerticalCenter.
Gradient End Color | Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression

StackedBar
Sparkline Stacked Bar Type

The Stacked Bar sparkline is presented as a horizontal bar with different segment lengths marked by distinct color hues. The Stacked bar illustrates how the various segments of a part-to-whole relationship correspond to one another - the largest segment represents the highest value and the change in brightness indicates a new value on a scale.

Appearance Properties

Property | Description
Fill Color | Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

See Also

Sparkline Control
Demo: Sparkline

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreport

Subreport
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Subreport

Glossary Item Box

The Subreport control is a placeholder for data from a separate report. In ActiveReports, for better performance, we recommend using data regions instead of Subreport controls wherever possible. The reason is that the report server must process every instance of each subreport, which can become burdensome in very large reports with a large number of subreports processed many times per report. Using data regions to display separate groups of data can be much more efficient in such reports. For more information, see Report Controls.

You can also pass parameters to the subreport from the main report so that data related to the main report displays in each instance of the subreport.

Note:
  • A Page report can use an RDLX report as the target subreport.
  • You cannot use a Section report as the target of a Subreport in a Page/RDLX report.

Subreports make sense when you need to nest groups of data from different data sources within a single data region, or when you can reuse a subreport in a number of reports. Here are some things to keep in mind while designing subreports.

  • If you make changes to the subreport without changing the main report, click Refresh to re-run the subreport in the Preview tab.
  • If you design the parent report in a standalone Report Designer application, save the parent report to the same directory as the subreport to render it in the Preview tab.
  • If you set borders on the Subreport control and the body of the report hosted in it, ActiveReports does not merge the two borders.
  • If the report hosted in the Subreport control cannot be found or contains no rows, only the border of the Subreport control is rendered.
  • If the hosted report is found and does contain rows, the border of the hosted report body is rendered.

Subreport Dialog Properties

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General
Visibility
Navigation
Parameters
Data Output

Name: Enter a name for the subreport that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Subreport: Select the <From File...> option to open the Open dialog, and then select a report to display within the Subreport control.

Use this report’s theme when rendering subreport: Select this check box to have the subreport automatically use the same theme as the hosting report.

Use this report’s stylesheet for the subreport: Select this checkbox to have the subreport use the same stylesheet as the parent report.

Initial visibility

  • Visible: The subreport is visible when the report runs.
  • Hidden: The subreport is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the subreport is visible. True for hidden, false for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the subreport.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this subreport. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

The Parameters page of the Subreport dialog allows you to enter new parameters and remove or change the order of parameters using the X and arrow buttons. For each parameter in this list, there is a Parameter Name and a Parameter Value.

Each Parameter Name must exactly match the name of a parameter in the target report.

For the Parameter Value, enter an expression to use to send information from the summary or main report to the subreport target.

Note: The following methods are not supported in the Parameter Value expression for a parameter that passes a value from the main report to subreport. However, this restriction does not apply to parameter default values.

  • RowNumber
  • RunningValue
  • Lookup/LookupSet
  • Previous
  • CountRows
  • CumulativeTotal

Element Name: Enter a name to be used in the XML output for this subreport.

Output: Choose Auto, Yes, or No to decide whether to include this subreport in the XML output. Choosing Auto exports the contents of the subreport.

See Also

Subreport Control for a Master-Detail Report
Demo: Multiple Subreports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Table

Table
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Table

Glossary Item Box

The Table data region is available in Page and RDLX reports. It is used to display the information in tabular format in Tabular Reports. The Table data region consists of columns and rows that organize data. By default, a table has three columns and three rows, a total of nine cells, where each cell is filled with a text box. At design time, you can add or remove columns, rows, and groupings to suit your needs. Also, you can embed other data regions in the table cells.

Structure

Column is a vertical group of cells in a table. If you right-click a column handler, you can add new columns or delete existing ones using the context menu that appears.

Row is a horizontal group of cells in a table. If you right-click a row handler, you can add new rows or delete existing ones using the context menu that appears.

Cell is the intersection of a row and column. By default, each table cell contains a TextBox report item. But you can replace it with other report controls, such as an Image, by drag-and-drop the corresponding item from the Toolbox into the cell.

Header row appears at the beginning of a table. If its RepeatOnNewPage property is set to 'True', it prints on every page taken by the table content. You could use the header row to display the title or the logo of a tabular report. A table may have several header rows.

Group header row appears at the beginning of a group. If its RepeatOnNewPage property is set to 'True', it prints on every page taken by the table content. You could use a group header row to display the group's field value or summary value. A group may have several header rows.

Details row repeats for each bound dataset record that passed through the dataset filters and data region filters. If a table has the grouped data, then the details row appears between the header and footer of the enclosing group instance. A table may have more than one details row.

Group footer row appears at the end of a group. If its RepeatOnNewPage property is set to 'True', it prints on every page taken by the table content. You could use the group footer row to display summary values. A group may have several footer rows.

Footer row appears at the end of a table. If its RepeatOnNewPage property is set to 'True', it prints on every page taken by the table content. You could use the footer rows to display grand totals.

Table Layout Actions

The Table data region provides context menu options to perform basic layout actions. You can access layout options for Table rows from the context menu by right-clicking on a selected row.

  • Insert Row Above: Add a row above the selected row. The inserted row type is similar to the type of selected row, that is, if the selected row type is a header row, a new header row is added.
  • Insert Row Below: Add a row below the selected row. The inserted row type is similar to the type of selected row, that is, if the selected row type is a header row, a new header row is added.
  • Delete Rows: Delete the selected rows.
  • Distribute Rows Evenly: Set the same height for multiple selected rows.
  • Table Header: Show or hide table header rows.
  • Table Details: Show or hide table detail rows.
  • Table Footer: Show or hide table footer rows.
  • Insert Group: Insert groups in a table.
  • Edit Group: Edit a group in a table.
  • Delete Groups: Delete groups in a table.

You can access layout options for Table columns from the context menu by right-clicking on a selected column.

  • Insert Column to the Left: Add a column to the left of the selected column.
  • Insert Column to the Right: Add a column to the right of the selected column.
  • Distribute Columns Evenly: Set the same width for multiple selected columns.
  • Add Columns: Add one or more column(s) to the right of the selected column.
  • Delete Columns: Delete the selected columns.

Table Dialog Properties

You can set the Table properties in the Table dialog. To open it, with the Table selected on the report, under the Properties window, click the Property dialog link.

General
Visibility
Navigation
Sorting
Groups
Detail Grouping
Filters
Data Output

Name: Enter a name for the table that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the table. The combo box is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether the table has its own pagination.

Page Breaks (RDLX report):

  • Insert a page break before this table
  • Insert a page break after this table
  • Fit table on a single page if possible

NewPage (RDLX report):

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

See Manage Page Breaks in Data Regions topic for more detail.

Header and Footer: Select any of the following options.

  • Repeat header row on each page (RepeatHeaderOnNewPage in Properties panel)
  • Repeat footer row on each page (RepeatFooterOnNewPage in Properties panel)
  • Prevent orphaned footer on next page (PreventOrphanedFooter in Properties panel)
  • Prevent orphaned header on the page (PreventOrphanedHeader in Properties panel)

Initial visibility

  • Visible: The table is visible when the report runs.
  • Hidden: The table is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the Table is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the Table. The user can click the toggle item to show or hide this Table.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this Table. You will then be able to provide a bookmark link to this item from another report item using a Jump to bookmark action.

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending.

Click the plus sign button to add a new group to the table, and delete them using the X button. Once you add one or more groups, you can reorder them using the arrow buttons, and set up information for each group on the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending.

Visibility

By default, the group is visible when the report runs, but you can hide a group when certain conditions are met, or toggle its visibility with another report item.

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Data Output

Element Name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Auto, Yes, No, or Contents only to decide whether to include this group in the XML output.

Layout

BreakLocation: Select from these options to decide where to insert a page break in relation to the group.

  • None: Inserts no page break.
  • Start: Inserts a page break before the group.
  • End: Inserts a page break after the group.
  • StartAndEnd: Inserts a page break before and after the group.
  • Between: Inserts a page break between groups (at the end of a current group and the beginning of a next group).

New Page:

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.
    Check Manage Page Breaks in Data Regions topic for more information.

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Keep together on one page if possible: Indicates that the group is kept together on one page if possible.

Prevent orphaned footer: Indicates whether the orphaned footer is displayed for the group.

Prevent orphaned header: Indicates whether the orphaned header is displayed for the group.

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table of the NorthWind database to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number for example, you will see no difference in the results.

The Detail Grouping page has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Visibility

By default, the group is visible when the report runs, but you can hide a group when certain conditions are met, or toggle its visibility with another report item.

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report item: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Data Output

Element Name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

BreakLocation: Select from these options to decide where to insert a page break in relation to the group.

  • None: Inserts no page break.
  • Start: Inserts a page break before the group.
  • End: Inserts a page break after the group.
  • StartAndEnd: Inserts a page break before and after the group.
  • Between: Inserts a page break between groups (at the end of a current group and the beginning of a next group).

NewPage:

  • Next: A default value that makes a new group start from the immediate next page of the report.
  • Odd: A new group starts from the next odd page of the report.
  • Even: A new group starts from the next even page of the report.

See Manage Page Breaks in Data Regions topic for more detail.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

The Data Output page of the Table dialog allows you to control the following properties when you export to XML.

  • Element Name: Enter a name to be used in the XML output for this Table.
  • Output: Choose Auto, Yes, or No to decide whether to include this Table in the XML output. Choosing Auto exports the contents of the Table.
  • Detail element name: Enter a name to be used in the XML output for the data element for instances of the table. This name is ignored if you have specified a details grouping.
  • Detail collection name: Enter a name to be used in the XML output for the data element for the collection of all instances of the detail grouping.
  • Data element output: Choose Yes or No to decide whether to include the details in the XML output.

Adding Data to Table

Once you place the Table data region on a report, you can add data to its cells. As with any data region, you can drag fields from your Fields list onto cells in the table. Although the default report control within each cell of the table is a text box, you can replace it with any other report control or a data region. When you drag a field into a cell in the details row, ActiveReports automatically provides a label in the table header. As with all report controls, you can use expressions to further manipulate the data within the cells of the table. For more information, see Expressions.

  1. From the Toolbox, drag-drop the Table data region onto the design area.
  2. From the Report Explorer, expand the DataSet and drag-drop data fields onto the cells in the details row.

Adding data to Table from Report Explorer

Alternatively, in the table, select a TextBox in the Details row and, from the Fields Selection Adorner, select a field from the list.

Adding data to Table with Fields Selection Adorner

Table Features

Table Grouping

Groups provide a way to organize data and make data analyses easy. In a Table data region, you can also create a document map based on the groups by specifying the group expression in the Document map label option. For information on document map and navigation, see the Document Map topic for more details.

Let us understand grouping using the report shown. The report consists of a Table that displays Movie details – Title, MPAA, and User Rating fields. The report connects to the 'Movie' table from 'Reels.db' data source on GitHub.
Table with Movie Details at design

Table with Movie Details at run time

You can group the table data according to the other dataset field, 'Year Released', to group the details based on the year when a movie was released.

The following steps add a group in the table using Group On expression.

  1. With the Table data region selected, under the Properties window, click the Property dialog link to open the Table dialog.
    Note: Alternatively, you can add a group by selecting Insert Group in the context menu of the Table data region, and adding a group in the Table - Groups dialog that opens.
  2. Go to the Groups page and click Add.
  3. Under Group on, enter the expression on which you want to group the data. For e.g.,
    =Fields!YearReleased.Value.
    Adding a group to Table
  4. Click OK to close the dialog. A Group Header and a Group Footer are added as shown.
    Table with an added group at design
  5. Merge the cells in the Group Header row and enter the expression in the Value property as
    =[YearReleased]
    Merging cells in the Table Group Header
    This makes the group value appear and span above each group.
  6. Preview the report. Here's how the table will look like.
    Table with grouping at preview

Detail Grouping

Another way of grouping the table data is by grouping the Details row without adding a group. The Detail Grouping groups the data in such a way that only one row per distinct grouping value or expression is displayed for each row of data in Details row. Also, it does not add a Group Header and Group Footer. Detail grouping is useful when you do not want the values to repeat within the details as many times as they are present in the data source.

Let us use Detail Grouping to group the table data. For example, we have a report with the Table that displays Movie details – Title, MPAA, and User Rating fields. The report connects to the 'Movie' table from 'Reels.db' data source on GitHub.
Table with Movie Details at design

  1. With the Table selected on the report, under the Properties window, click the Property dialog link to open the Table dialog.
  2. Go to the Detail Grouping page and, under Group on, enter the expression on which you want to group the data. For e.g.,
    =Fields!YearReleased.Value.
    Table Detail Grouping dialog
  3. Click OK to close the dialog.
  4. Preview the report. Here's how the table will look like.
    Note that the report size is smaller after applying the Details Grouping since the details row is shown once for every grouping value.
    Table with added detail grouping at preview

Merge Cells

You can combine adjacent cells in horizontal (same row) or vertical (same column) direction into a single cell. Vertical cell merging is possible within the same row type, that is, within the Header, Group Header, Footer, Group Footer, or Details row.

To merge cells,

  1. Select the cells (Ctrl+Click) and the right-click.
  2. From the context menu, select Merge Cells.

Auto Merge

The AutoMergeMode property lets you set the mode to merge the adjacent cells (text boxes) in details row with the same value. This property takes Always, Never, and Restricted values. The details row with the same data values and with AutoMergeMode property set to:

  • Always - are merged.
  • Never - are not merged.
  • Restricted - are merged only if the corresponding cells in the previous columns are similarly merged. If for example, cells in Column 2 (with same data values) are set 'Restricted' and the corresponding cells (with same the data values) in previous column, that is Column 1, are set 'Never', then cells in Column 2 are not merged.

The following steps take you through how to add automatic merge to the cells in the following table. The report connects to the 'Orders' table from 'NWIND.db' data source on GitHub.

Orders Table at design

Orders Table at preview

  1. Select the cell with EmployeeID field and set the Layout > AutoMergeMode property to 'Restricted'. This merges employee ids depending on whether the corresponding ship names (cells in the previous column) are merged.
  2. Select the cell with ShipName field and set the Layout > AutoMergeMode property to 'Always'. This merges the cells with similar ship names.
  3. Preview the report. Here's how the table will look like.
    Orders Table with auto merged cells at preview

Freeze Rows and Columns (RDLX Reports)

When you use a Table data region containing a large amount of data in an RDLX report, the user must scroll to see all of the data. On scrolling the column or row headers out of sight, the data becomes difficult to understand. To resolve this problem, you can use the FrozenRows and FrozenColumns properties that take effect in the JSViewer in Galley mode, and allow you to freeze headers so that they remain visible while scrolling through the data region. You can freeze as many rows or columns as you have headers in the data region.

  • If your data stretches downward, set the FrozenRows property to a value to float the column headers when scrolling.
  • If your data stretches to the right, set the FrozenColumns property to a value to float the row headers when scrolling.
  • If your data stretches both downward and to the right, set both FrozenRows and FrozenColumns properties.

Here's how a report with one frozen column looks like in JS Viewer.

Table with frozen rows and columns at preview

If any header cells that you want to freeze are merged, you should not set the FrozenRows or FrozenColumns property to a value that would split a merged cell.

Nesting in Tables

To display data from different datasets, you can use nested tables that are bound to different datasets. You can do any one of the following to achieve this:

  • add a filter to a child table (Filters property) which filters the data in the table data region based on the common field in two datasets
  • create a parameter for the child table (DataSetParameters property) that is passed to the dataset query and filters the dataset fields based on the common field in the two datasets

For example, the following report shows three nested Table data regions that fetch data from three different datasets.

Nesting in Tables at design

The report connects to the 'NWIND.db' data source on GitHub.

Table1 is bound to 'Products' dataset, Table2 is bound to 'Invoices' dataset, and Table3 is bound to 'Customers' dataset. The parent table, Table1, shows the Product Name and Units In Stock information from the Products dataset. For each ProductID, child table, Table2 shows the Ship Name and Ship Country information from the Invoices dataset. And for each CustomerID, the child table, Table3, shows the Contact Name, City, and Phone information from the Customers dataset.

Nesting in Tables at preview

Let us create this report using both methods.

Using a filter

For the child tables, add a filter using the Filters property as elaborated below:

  1. Select Table2 and go to the Filters property.
  2. In the Table - Filters, add a filter with the expression =[ProductID]==[ProductID], the common field in the datasets of the parent table and the child table.

    Table Filters Dialog

Similarly,

  1. Select Table3 and go to the Filters property.
  2. In the Table - Filters, add a filter with the expression =[CustomerID]=[CustomerID], the common field in the datasets of the parent table and the child table.

Using a parameter

For each child table, we create a parameter to pass to the dataset and then modify the dataset query to filter the dataset fields.

Note: JSON dataset does not have the parameters collection. Hence, the DataSetParameters from the data region cannot interact with such a dataset.

The following steps elaborate the procedure.

  1. Select Table2 and go to the DataSetParameters property.
  2. Add a new parameter with Name: Parameter_ProductID and Value: =Fields!ProductID.Value.
    DatasetParameterDesigner Collection Editor
  3. Go to the dataset to which the Table2 is bound, that is, Invoices.
  4. In the DataSet designer dialog, go to Parameters and add a new parameter (same name as DataSetParameter): Parameter_ProductID.
    DataSet Parameters Dialog
  5. Go to Query and add a substring with the parameter to the existing dataset query so the updated query is:
    select * from Invoices where ProductID = @Parameter_ProductID

Similarly,

  1. Select Table3 and go to the DataSetParameters property.
  2. Add a new parameter with Name: Parameter_CustomerID and Value: =Fields!CustomerID.Value.
  3. Go to the dataset to which Table3 is bound, that is, Customers.
  4. In the DataSet designer dialog, go to Parameters and add a new parameter (same name as DataSetParameter): Parameter_CustomerID.
  5. Go to Query and add a substring with the parameter to the existing dataset query so the updated query is:
    select * from Invoices where ProductID = @Parameter_CustomerID

Filter, Sort, and Interactive Sort

Filter

Filtering allows you to set filters on a large set of data that has already been retrieved from the data source and use them with datasets or data regions to limit the information you want to display on your report. Although not as efficient performance-wise as query parameters which filter data at the source, there are still scenarios that demand filters. The obvious case is when the data source does not support query parameters.

To apply a filter in a Table data region,

  1. Select the table and go to Filters property.
    Table Filters Dialog
  2. In the Table - Filters dialog, click Add.
    You can also first go to the Property dialog and then select the Filters page.
  3. In the Expression field, select the data field expression (=[UserRating]) available from the dataset to which the table is bound.
  4. Select the filter Operator (GreaterThanOrEqual).
  5. Enter the Value (say 9) to which the expression should evaluate to filter the data.
  6. Click OK.
  7. Preview the report. Here's how the table will look like with the 'User Rating' column showing a rating above '9'.
    Table with a filter at preview

Sort

Sorting helps better organize and present data in your report, you can sort alphabetically or numerically in ascending or descending order.

To apply sort in a Table data region,

  1. Select the table and click the Property dialog link to open the Table dialog.
    Table Sorting Dialog
  2. Go to the Sorting page and click Add.
  3. In the Expression field, select a value to sort the report data (for example, =[Title]).
  4. Select the sorting direction by clicking Ascending or Descending options.
  5. Click OK.
  6. Preview the report. Here's how the table will look like with the 'User Rating' column sorted in ascending order.
    Table with sorting at preview

Interactive Sort

You can use interactive sort or user sort on a TextBox control to sort data columns within a data region in a published report. The Interactive Sort page in the TextBox dialog allows you to enable interactive sorting. See Sort Data topic for further information on applying this kind of sorting on a table.

Dynamic Columns

The dynamic columns in tables are the columns that grow or shrink depending on the visibility of other columns. When a Table has hidden column(s), the other column(s) can be made dynamic by setting the column's AutoWidth property to 'Proportional'.

So, for example, in the following table, we have five columns: Title, MPAA, User Rating, Country, and Language. The visibility of columns MPAA, User Rating, and Language is being toggled by a text box. We want the columns Title and Country to grow or shrink when the visibility of the other three columns is toggled.

Dynamic columns in Table at preview

The above report can be created as elaborated below:

Designing dynamic coulmns in Table

  1. First set the visibility of columns MPAA, User Rating, and Language and set the toggle control:
    1. Select the columns MPAA, User Rating, and Language (Ctrl+Click the column handlers).
    2. From the Properties window, set the Visibility > Hidden to 'False' and ToggleItem to the name of the textbox from which we will toggle the visibility of these columns.
  2. Now make columns Title and Country dynamic:
    1. Select the columns Title and Country.
    2. From the Properties window, set their AutoWidth property to 'Proportional'.
  3. Preview the report.
    The column width of the visible columns is expanded to take up the width of the Table data region. This way, regardless of how many columns a table displays, the width stays the same.

Limit Number of Rows in Table Details

You can control the number of Table Details rows, displayed on a page, with the MaxDetailsPerPage property. If the number of rows exceeds the value, specified in the MaxDetailsPerPage property, a page break is added after the specified number of rows.

For example, we have a Table with six Details rows.

MaxDetailsPerPage for a table with no group

If the MaxDetailsPerPage property is set to '5', a page break is added after five rows and the Table is split to two pages.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

If a Table contains a group (for example, a SalesID group) and the MaxDetailsPerPage property is set to '5', a page break is not added after five rows because, in this case, the Details rows are counted in each group. In the screenshot below, each group has three Details rows and no page break is added.

MaxDetailsPerPage for a table with group

See Also

Table Data Region for a Tabular Report
Show Row Number in Tablix and Table
Demo: Simple Table
Demo: Table With Grouping And Sorting
Demo: Table With Nested Controls
Sort Data
Groups
Filters
Configuring Table

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Table of Contents

Table of Contents
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Table of Contents

Glossary Item Box

The TableOfContents report control is available in Page and RDLX reports. It is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers in the body of a report.

The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports. Unlike the Document Map that is only available in the Viewers and cannot be rendered or printed, you can use the TableOfContents control to embed the table of contents structure in the report body for printing and rendering purposes.

Structure

Table of Contents structure

Important Properties

By clicking on the TableOfContents control, you can set its properties in the Properties panel.

Property | Description
Levels | Contains the collection of TableOfContents levels and allows you to access the LevelDesigner Collection Editor dialog, where you can set up the report TableOfContents levels and their properties
MaxLevel | Restricts the maximum number of levels in the document map.
StyleName | Allows you to apply the selected styles from a style sheet. These styles can be applied to the TableOfContents report control using the StyleName property or to Table Of Contents levels using the LevelDesigner Collection Editor dialog
OverflowName (Page report) | Specify the OverflowPlaceHolder control name to link it with the TableOfContents control.
FixedHeight (Page report) | Allows you to set the maximum height of the TableOfContents control on each page, similar to the FixedSize property that is available with other report controls.

Table of Contents Dialog Properties

General
Visibility
Appearance
Data Output

Name: Enter a name for the table of contents that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

By default, the Table of Contents is visible when the report runs, but you can hide it, hide it only when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

Visible: The Table of Contents is visible when the report runs.

Hidden: The Table of Contents is hidden when the report runs.

Expression: Use an expression with a Boolean result to decide whether the Table of Contents is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle TableOfContents control next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the TableOfContents control.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background.

Element Name: Enter a name to be used in the XML output for the TableOfContents control.

Output: Choose Auto, Yes, No, or Contents only to decide whether to include this Table of Contents in the XML output. Choosing Auto exports the contents of the TableOfContents control.

LevelDesigner Collection Editor

Appearance
Data
General
Layout
Misc

BackgoundColor: Select a color to use for the background of the TableOfContents level.

Color: Select the color of the text.

Font: Select the font to render the TableOfContents level text.

Style: Choose Normal, Italic, or select the <Expression...> option to open the Expression Editor and create an expression.

Family: Choose the font family name.

Size: Choose the size in points for the font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder, or select the <Expression...> option to open the Expression Editor and create an expression.

Padding: Specify left, right, top, and bottom values for the padding to apply to a TableOfContents level.

StyleName: Select a style to apply to the TableOfContents level.

TextAlign: Specify the horizontal alignment of the text.

TextDecoration: Choose from None, Underline, Overline, and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

DataElementName: Enter a name to be used in the XML output for this TableOfContents level.

DisplayFillCharacters: Specifies whether to display a leading character. The Default value is True.

DisplayPageNumber: Specifies whether to display a page number. The Default value is True.

FillCharacter: Use the expression to specify a fill character for a leading character.

TextIndent: Specify the text indent.
Name: Specify a name for the TableOfContents level.

See Also

TableofContent Control for Navigation
Demo: Table Of Contents

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tablix

Tablix
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > Tablix

Glossary Item Box

A Tablix data region displays data in cells that are arranged in rows and columns. It provides enhanced layout capabilities ranging from the creation of simple tables to advanced matrices. Tablix is essentially a combination of two data regions, the table, and the matrix. Therefore, it provides all the features of a table and a matrix along with added capabilities including support for multiple adjacent groups on rows or columns and improved layout flexibility with stepped group layouts.

By default, each tablix cell contains a TextBox control, and the function for each cell is determined by its location. You can change the layout of the Tablix data region using the LayoutDirection property.

Structure

The Tablix data region is composed of four areas denoted by dotted lines on the design surface - the corner, the row group area, the column group area, and the body.

Corner

The Corner element is located in the upper-left corner, or upper-right corner if a tablix has the LayoutDirection property set to Rtl. The layout direction applies at preview time only. This area is automatically expanded horizontally or vertically when you add a new column or row groups. You can merge cells inside the tablix corner and insert a data visualizer such as a TextBox or Image.

A corner may contain only static cells that are rendered only once in Tablix.

Column Group

A Column group is represented by square brackets above the columns. Tablix column groups are located in the upper-right corner (upper-left corner for the Rtl layout). A column group represents a member of the column groups hierarchy and displays the column group instance values.

Row Group

A Row group is represented by square brackets on the left side of the rows. Tablix row groups are located on the lower-left corner (lower right for the Rtl layout). A row group represents a member of the row groups hierarchy and displays row group instance values.

Body

The Body element is used for displaying aggregated data with respect to row and column grouped data in the report. The body may contain only static cells that are rendered only once in Tablix.

Static and Dynamic Rows and Columns

Rows or columns in the Tablix data region can be static or dynamic. The Tablix data region contains multiple rows and columns that provide a grid-type layout, where you can add or remove static or dynamic rows and columns in order to display your data efficiently.

  • Static Rows and Columns - A static row or column is not associated with any group data. When the report runs, a static row or column is rendered only once. Labels and totals are displayed using static rows or columns in the Tablix data region.
  • Dynamic Rows and Columns - A dynamic row or column is associated with one or more groups and renders once for every unique value in the group. You can also create dynamic group rows or columns by adding a row group or a column group.

Static/dynamic rows and columns in Tablix

Row and Column Handlers

When you select a Tablix data region, the row and the column handles appear. These handles help you to work with a Tablix and visually specify the type of data added in your tablix layout.

The following table shows the different types of handles that appear in a Tablix data region.

Handle Icon | Description
Tablix row/column with one outer group | Row or column with one outer group.
Tablix one outer and one inner group | One outer group and one inner group.
Tablix with one outer group with an extra row for totals and one inner group | One outer group with an extra row for totals and one inner group.

Tablix Layout Actions

The Tablix data region provides context menu options to perform basic layout actions. You can access layout options for Tablix rows from the context menu by right-clicking on a selected row.

  • Insert Row: Select from the following options to insert a row inside or outside of the selected group cell.
    • Inside Group: If a row group contains groups having distinct values, then as many rows are inserted as there are groups.
      • Above: Inserts a row above for each unique value of the row group.
      • Below: Inserts a row below for each unique value of the row group.
    • Outside Group: If a row group contains nested groups consisting of child and parent groups, then as many rows are inserted as there are parent groups.
      • Above: Inserts a row above for each unique value of the parent row group.
      • Below: Inserts a row below for each unique value of the parent row group.
  • Delete Row: Delete the selected rows.
  • Distribute Rows Evenly: Set the same height for multiple selected rows.
  • Add Row Group: Select from the following options to insert row groups in a tablix.
    • Parent Group: To insert a parent row group.
    • Child Group: To insert a child row group.
    • Adjacent Above: To insert an adjacent row group above the selected row group.
    • Adjacent Below: To insert an adjacent row group below the selected row group.
  • Row Group: Select the Delete Group option to delete a row group.

You can access layout options for Tablix columns from the context menu by right-clicking on a selected column.

  • Insert Column: Select from the following options to insert a column inside or outside of the selected group cell.
    • Inside Group: If a column group contains groups having distinct values, then as many columns are inserted as there are groups.
      • Left: Inserts a column to the left for each unique value of the column group.
      • Right: Inserts a column to the right for each unique value of the column group.
    • Outside Group: If a column group contains nested groups consisting of child and parent groups, then as many columns are inserted as there are parent groups.
      • Left: Inserts a column to the left for each unique value of the parent column group.
      • Right: Inserts a column to the right for each unique value of the parent column group.
  • Delete Column: Delete the selected columns.
  • Distribute Columns Evenly: Set the same width for multiple selected columns.
  • Add Column Group: Select from the following options to insert column groups in a tablix.
    • Parent Group: To insert a parent column group.
    • Child Group: To insert a child column group.
    • Adjacent Left: To insert an adjacent column group to the left of the selected column group.
    • Adjacent Right: To insert an adjacent column group to the right of the selected column group.
  • Column Group: Select the Delete Group option to delete a column group.

Group Editor

The Group Editor window gets displayed or hidden by the Group Editor icon, located on the left of the Design area. The Group Editor contains the following groups:

  • Row Groups: The Row Groups section in the Group Editor displays all the groups that are applied in the row group area of the Tablix data region.
    Category Name
    The left-center cell of the Tablix data region =[CategoryName] represents the Category group in the Group Editor window. This group displays the category names for products.
    Product Name
    The left-center cell of the Tablix data region =[ProductName] represents the Product group in the Group Editor window. This group displays the product names.
  • Column Groups: The Column Groups section in the Group Editor window displays all the groups that are applied in the column group area of the Tablix data region.
    Year
    The center-left cell of the Tablix data region =[Years] represents the Years group in the Group Editor window. This group displays years of orders.
    Quarter
    The center-right cell of the Tablix data region =[Quarter] represents the Quarter group in the Group Editor window. This group displays quarters for the orders.
  • Static Cells: Static cells in the Row Groups and Column Groups are not represented in the Group Editor window because these cells are not associated with any grouped data. Static row and column cells are used to display labels and totals in a Tablix data region.

The static column cell displays the label YEARS and CATEGORY NAMES in the Tablix data region. The static row cell displays the label Total in the Tablix data region.

The image below displays the subjects in a row group. Nested column groups display practical and theory scores for the students. The total row displays the total scores for all of the subjects.

Tablix with Row and Column Groups

Tablix Features

Column and Row Groups

Groups categorize the report data using a specified expression. You can add a group by using the context menu options or in the Group Editor component that is part of the designer.

In Tablix, you can add row/column groups in the following ways:

  • Parent-child groups: To depict the hierarchical relation.
  • Adjacent groups: To show the side-by-side grouping of report data.

Important Group and Layout Properties for Tablix Groups

  • Filters: The filters to apply on the group.
  • GroupExpressions: Specifies the group expression for the group.
  • NewSection: Determines whether each group instance has its page numbering.
  • PageBreak: Indicates how the rendering engine inserts a page break in relation to the group.
    • BreakLocation: Determines the location of page breaks generated by group instances.
      • None: no page breaks are generated.
      • Start: each group instance inserts the page break before printing its content.
      • End: each group instance inserts the page break after printing its content.
      • StartAndEnd: the combination of the Start and End options.
      • Between: each group instance starts on the new page.
    • Disabled: Indicates whether the page break properties should be ignored. The expression allows you to conditionally prevent page breaks from being inserted by the aforementioned property.
    • NewPage: Indicates on which page the content to start after the page break.
      • Next: A default value that makes a new group start from the immediate next page of the report.
      • Odd: A new group starts from the next odd page of the report.
      • Even: A new group starts from the next even page of the report.

    See Manage Page Breaks in Data Regions topic for more detail.

  • KeepTogether: Setting it True ensures that the group instance always appears on a single page if it fits.

To add a group

  1. Select the Tablix data region in the design area.
  2. Right-click and select any group action in the context menu that appears.
  3. Or, with a Tablix selected, click Group Editor on the left of the Designer.
    Group Editor in Tablix

Totals

The intersection of a Row and Column Group displays one or more summary values. For example, in a report output, Row Groups may display media types, Column Groups - quarters, and their intersections may show the Sales for each media type in each quarter.

A tablix can display two types of totals.

  • The Grand Total appears at the beginning or at the end of all the group instances.
  • The Subtotal appears at the beginning or at the end of each group instance.

To add a total,

  1. Right-click a Tablix cell and select Add Total > Before or Add Total > After menu item.
    If a group does not have a parent, then the grand total will be inserted. Otherwise, the subtotal for the parent group will be created.
    Add total in Tablix
  2. To insert additional totals, you can add rows and columns and set an expression to calculate sum for the newly added cells.
    Expression in Tablix context menu

Merge Cells

Tablix cells with the same value in a row group or a column group area are automatically merged. In the case of static cells, you can combine adjacent cells in horizontal (same row) or vertical (same column) direction into a single cell. For example, you may want a column header to span across the columns.

To merge cells,

  1. Select the cells (Ctrl+Click) and then right-click.
  2. From the context menu, select Merge Cells.

Auto Merge

The AutoMergeMode property lets you set the mode to merge the adjacent cells (text boxes) in a row group with the same value. This property takes Always, Never, and Restricted values. The row groups with the same data values and with AutoMergeMode property set to:

  • Always - are merged.
  • Never - are not merged.
  • Restricted - are merged only if the corresponding cells in the previous columns are similarly merged. If for example, cells in Column 2 (with the same data values) are set 'Restricted' and the corresponding cells (with the same data values) in previous column, that is Column 1, are set 'Never', then cells in Column 2 are not merged.

Let us take an example. In the following simple Tablix data region, 'District' column is Outside Group - Right to the 'Region' column group. We want the 'District' values to merge in case the 'Region' values are the same.
The tablix without AutoMergeMode set in any cell looks as follows:

Example for cell merging

Let us set the AutoMergeMode property for the 'District' and the 'Region' values.

  1. Select the cell with District field in the row group and set the Layout > AutoMergeMode property to 'Restricted'. This merges districts depending on whether the corresponding regions (cells in the previous column) are merged.
  2. Select the cell with Region field in the row group and set the Layout > AutoMergeMode property to 'Always'. This merges the cells with similar regions.
  3. Preview the report. Here's how the tablix will look like.

    Example for cell merging

Repeat to Fill (Page report)

If you set the RepeatToFill property to True (the default value is False), the Tablix will fill extra space with empty rows.

Setting the RepeatToFill property to 'True' (default value is 'False') fills the tablix with empty rows to reach the Fixed Height of the tablix. So, each page of the report displays the tablix with the same height. For example, the following image shows the page of a report where RepeatToFill property for the Tablix data region is set to 'False':

Example of Tablix with RepeatToFill set to False

Then, in the Properties panel, set the RepeatToFill property to 'True'. At the report preview, you will see that the tablix now has additional empty rows on the same page of the report.

Example of Tablix with RepeatToFill set to True

Freeze Rows and Columns (RDLX Reports)

When you use a Tablix data region containing a large amount of data in an RDLX report, the user must scroll to see all of the data. On scrolling the column or row headers out of sight, the data becomes difficult to understand. To resolve this problem, you can use the FrozenRows and FrozenColumns properties that take effect in the JSViewer in Galley mode, and allow you to freeze headers so that they remain visible while scrolling through the data region. You can freeze as many rows or columns as you have headers in the data region.

  • If your data stretches downward, set the FrozenRows property to a value to float the column headers when scrolling.
  • If your data stretches to the right, set the FrozenColumns property to a value to float the row headers when scrolling.
  • If your data stretches both downward and to the right, set both FrozenRows and FrozenColumns properties.

Here's how a report with one frozen row and column headers looks like in JS Viewer.

Tablix with frozen rows and columns

If any header cells that you want to freeze are merged, you should not set the FrozenRows or FrozenColumns property to a value that would split a merged cell.

See Also

Tutorial: Tablix Data Region
Show Row Number in Tablix and Table
Demo: Column Grouping
Demo: Complex Pivot
Demo: Simple Pivot
Demo: Frozen Headers
Configuring Tablix

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TextBox

TextBox
See Also
Report Authors > Report Controls > Report Controls in Page/RDLX Report > TextBox

Glossary Item Box

The Textbox report control is the most commonly used report control that displays textual data in any report.

In Page and RDLX reports, the TextBox by default appears in each cell of a Table or Tablix data region. Also, a TextBox is what is created when you drag a field from the data set onto the report. In the Value property of the TextBox, you can enter static text or an expression. To enter a text directly into the TextBox, just double-click inside the control on the design surface of the report. An expression in TextBox can display fields from a database, calculate a value, or visually display data.

In the Properties panel, there are a number of properties that you can use to control the appearance and behavior of the TextBox. For example, you can set the Action property to have the viewer jump to a bookmark within the report, another report, or a URL when a user clicks the TextBox at run time. The Data Element properties allow you to control how and whether the TextBox displays in XML exports.

By default, in RDLX reports, the TextBox can grow vertically to accommodate the data it displays, and it cannot shrink smaller than it appears at design time. To change this behavior, set the CanShrink and CanGrow properties in the Properties grid.

Edit Mode

You can double-click in the TextBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties panel or code through the Value property.

Textbox in Edit Mode

You can format text in the TextBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties panel. Formats apply to all of the text in the control. Text formatting changes in the Properties panel immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties panel.

Important Properties

Clicking the TextBox control reveals its properties in the Properties panel.

Property | Description

RDLX report
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the control based on its value.
CharacterSpacing | Gets or sets a character spacing in points.
LineSpacing | Gets or sets a line spacing in points.
MinCondenseRate | Specifies the minimal rate of the text horizontal scaling in percentages. Should be between 10 and 100.
ShrinkToFit | Determines whether ActiveReports decreases the font size when text values exceed available space.
TextJustify | Specifies text justification with TextAlign set to Justify.
Value | A field, constant, or expression, which value is displayed in the textbox.
VerticalAlignment | Gets or sets the position of the textbox's text vertically within the bounds of the control.
WrapMode | Indicates whether a multi-line textbox control automatically wraps words or characters to the beginning of the next line when necessary.
Custom CSS Classes

Allows to apply custom CSS class names to the textbox when rendering a report in the JS Report Viewer.

For example, you can use the jsViewer.custom.styles.css file from the JS Report Viewer deliverables to style the textbox as a button. When designing a report in the Standalone Designer, set this property to a style class from the jsViewer.custom.styles.css file (e.g., ar-button), then add the report to your JS Viewer project. After you open the report in your JS Viewer project, the class will automatically apply to the textbox.

Similarly, you can apply your own custom styles to match the design requirements.

Page report
CharacterSpacing | Gets or sets a character spacing in points.
LineSpacing | Gets or sets a line spacing in points.
MinCondenseRate | Specifies the minimal rate of the text horizontal scaling in percentages. Should be between 10 and 100.
ShrinkToFit | Determines whether ActiveReports decreases the font size when text values exceed available space.
TextJustify | Specifies text justification with TextAlign set to Justify.
Value | A field, constant, or expression, which value is displayed in the textbox.
VerticalAlignment | Gets or sets the position of the textbox's text vertically within the bounds of the control.
WrapMode | Indicates whether a multi-line textbox control automatically wraps words or characters to the beginning of the next line when necessary.
Custom CSS Classes

Allows to apply custom CSS class names to the textbox when rendering a report in the JS Report Viewer.

For example, you can use the jsViewer.custom.styles.css file from the JS Report Viewer deliverables to style the textbox as a button. When designing a report in the Standalone Designer, set this property to a style class from the jsViewer.custom.styles.css file (e.g., ar-button), then add the report to your JS Viewer project. After you open the report in your JS Viewer project, the class will automatically apply to the textbox.

Similarly, you can apply your own custom styles to match the design requirements.

TextBox Dialog Properties

You can set the TextBox properties in the TextBox dialog. To open it, with the TextBox selected on the report, under the Properties panel, click the Property dialog link.

General
Visibility
Navigation
Appearance
Font
Format
Alignment
Interactive Sort
Data Output

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Value: A field, constant, or expression, which value is displayed in the textbox.

Note: When the group or dataset breaks to a new page, the first instance of the repeated value is printed.

Initial visibility allows you to select from the following options:

  • Visible: The textbox is visible when the report runs.
  • Hidden: The textbox is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the textbox is visible. For example, on a "Free Shipping" textbox, you could use the expression to see whether the ShippingCountry is international. A value of True hides the textbox, False shows it.

Visibility can be toggled by another report item: If you select this check box, it enables the drop-down box where you can specify the TextBox control that users can click to toggle the visibility of the textbox.

Initial appearance of the toggle image: allows you to select from the following options:

  • Expanded: The toggle image shows as a minus sign, and all instances of this textbox are visible.
  • Collapsed: The toggle image shows as a plus sign, and all instances of this textbox are hidden.
  • Expression: Use an expression with a Boolean result to decide whether the toggle image is expanded. A value of True expands the toggle image, False collapses it.
Select one of the following actions to perform when a user clicks on the textbox.

None: The default behavior is to do nothing when a user clicks the textbox at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server. You can also use expressions to create drill-through links.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Apply Parameters: Select the Name, the Type, and the Value of the parameter to set a parameter value through user action. See Actionable Parameters for more information.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this textbox. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the textbox.

Image: Enter an image to use for the background of the textbox.

Image Source: Select whether the image comes from a source that is External, Embedded, or Database, or select the <Expression...> option to open the Expression Editor.

MIME Type: Select the MIME type of the chosen image.

Background repeat: Select from the options Repeat, NoRepeat, RepeatX, RepeatY, or select the <Expression...> option to open the Expression Editor.

Note: The Background Color and Background Image properties allow you to choose the <Data Visualizer...> option as well to launch the dialog that let you build a data visualization expression.

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Line Spacing: This property sets the space between lines of text.

Character Spacing: This property sets the space between characters.

Textbox height

Can increase to accommodate contents (RDLX report): Select this check box to set CanGrow to True.

Can decrease to accommodate contents (RDLX report): Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Text direction and writing mode

Direction: Choose LTR for left to right, or RTL for right to left.

Mode: Choose lr-tb for left right top bottom (normal horizontal text) or tb-rl for top bottom right left (vertical text on its side).

Upright: Indicates whether the text is written horizontally in the vertical text. Choose from None, Digits, DigitsAndLatinLetters, or the <Expression...> option.

Angle: Enter the number of degrees to rotate the text in a counter-clockwise direction. Enter a negative number to rotate the text in a clockwise direction.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Vertical alignment: Choose Top, Middle, Bottom, or the <Expression...> option.

Horizontal alignment: Choose General, Left, Center, Right, Justify, or the <Expression...> option.

Justify method: Set Horizontal alignment to Justify to enable this property. Choose Auto, Distribute, DistributeAllLines, or the <Expression...> option.

Wrap mode

  • NoWrap: No text wrap.
  • WordWrap: Wrap words from one line to another.
  • CharWrap: Per-character wrapping mode.

Padding

  • Top: Set the top padding in points.
  • Left: Set the left padding in points.
  • Right: Set the right padding in points.
  • Bottom: Set the bottom padding in points.

Select the checkbox next to Add an interactive sort action to this textbox to enable the following controls which allow end users to sort the report data in the viewer.

Sort expression: Enter an expression to use for determining the data to sort.

Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Element Name: Enter a name to be used in the XML output for this textbox.

Output: Choose Auto, Yes, or No to decide whether to include this textbox in the XML output. Auto exports the contents of the textbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render text boxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Attribute example: <table1 textbox3="Report created on: 7/26/2021 1:13:00 PM">

Element example: <table1> <textbox3>Report created on: 7/26/2021 1:13:28 PM</textbox3>

Data Fields

When you drag a field from a dataset and drop it onto the report surface, a TextBox report control with an expression is automatically created. The type of expression that is created depends upon the context where you drop the field. The following table describes the various contexts and expressions created if you drag a field named SalesAmount onto the report.

Expressions created for fields in different contexts

Note: The expression created is different for a field with a string or unknown data type. In these cases, the First aggregate is used in place of the Sum aggregate in the expressions below. At run time, the first value found within the scope is displayed instead of a summary.
Context | Expression | Run-Time Behavior
Directly on the report surface | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the entire dataset.
List data region | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, header, or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the BandedList.
BandedList data region, detail band | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, group header, or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Table data region, header, or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the Table.
Table data region, detail row | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
Table data region, group header or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Tablix data region, corner cell | none | Displays a blank cell. You can add a label or even use this area to embed other report control.
Tablix data region, column group cell | =Fields!SalesAmount.Value | Displays the value at the top of a new column for each row of data running to the right.
Tablix data region, row group cell | =Fields!SalesAmount.Value | Displays the value to the left of a new row for each row of data running down the page.
Tablix data region, body cell | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the intersection of the column and row.

TextBox Features

Text Justification

The TextJustify property of a Textbox control provides you justification options for aligning your text within a control. It is important to note that the TextAlign property must be set to Justify for TextJustify property to affect the text layout.

You can choose from the following values of the TextJustify property:

Auto

Results in Standard MSWord like justification where space at the end of a line is spread across other words in that line. This is the default value.

Distribute

Spaces individual characters within a word, except for the last line.

DistributeAllLines

Spaces individual characters within words and also sets the justification on the last line according to the length of other lines.

To set text justification,

  1. Select the TextBox control to view its properties in the Properties panel.
  2. In the Properties panel, set the TextAlign property
  3. Go to the TextJustify property and from the drop down list select any one option.

Text justification is supported when you preview a report in the Viewer, print a report, export a report in PDF, and TIFF formats, or render a report in Word, HTML, PDF and Image formats using rendering extensions.

Shrink Text to Fit in a Control

When working with the Textbox control in a Page report and RDLX report, you can use the ShrinkToFit property to reduce the size of the text so that it fits within the bounds of the control. The text shrinks at run time, so you can see the reduced font size when you preview, print or export the report.

The following image illustrates the result when the ShrinkToFit property is set to True on 'Title' field.

TextBox with ShrinkToFit set to True

You can use other text formatting properties in combination with the ShrinkToFit property.

Caution:

  • When both CanGrow and ShrinkToFit are set to True, CanGrow setting is ignored and only ShrinkToFit is applied.
  • When ShrinkToFit is set to True and Angle is set to a value other than 0, the ShrinkToFit property is ignored.
  • ShrinkToFit property does not work when the WritingMode property is set for a control.
  • Common value with Page number (in data region or report header/footer) appears clipped in exported files (HTML, MHT, Word, and Excel) even when ShrinkToFit property for the TextBox is set to True.

On exporting a report, various file formats handle ShrinkToFit differently. ShrinkToFit gets exported in all formats except Text. While rendering a Page report or RDLX report using rendering extensions, ShrinkToFit is not supported in XML. However, all other rendering extensions allow ShrinkToFit to display as it is.

Multi-line in TextBox

You can display multi-line text in TextBox and some other controls such as CheckBox for Page/RDLX reports.

In a Page/RDLX report, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter key to create multi-line text. You can also insert line breaks in the Expression Editor through the Value property of the control.

Note: In edit mode, scrollbars appear automatically to fit multi-line content within a control. However, these are not displayed at preview, so you may need to adjust the Size property of the control to display all of the text.

Line Spacing and Character Spacing

In edit mode, scrollbars appear automatically to fit multi-line content within a control. However, these are not displayed at preview, so you may need to adjust the Size property of the control to display all of the text.

Line and Character Spacing in TextBox

To set Line or Character spacing,

  1. On the design surface, click the TextBox control to display it in the Properties panel.
  2. In the Properties panel, click the Property dialog command at the bottom to open the control dialog.
  3. In the TextBox dialog, go to the Format page and set the Line Spacing or Character Spacing values in points.

Line and character spacing are supported when you preview a report, print a report, or export a report. It is also supported while rendering a report through rendering extensions in Word, HTML, PDF and Image formats.

Keyboard Shortcuts

In the edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In Visual Studio Integrated Designer, you can disable this feature in the EditModeEntering Event and EditModeExit Event.

See Also

Tutorial: TextBox Control
Demo: RTL Support

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Controls in Section Report

Report Controls in Section Report
Report Authors > Report Controls > Report Controls in Section Report

Glossary Item Box

When you work on Section Reports in ActiveReports Designer, you get a toolbox group with a set of report controls that can be used to create section reports. These controls can be easily dragged from the toolbox and dropped on to the reports. All the controls in the toolbox have been designed to help you create purposeful section reports.

The following controls are most commonly used to create Section Reports:

Barcode

Learn how to use BarCode control in Section Reports and choose from several barcode styles available.

Chart

Learn about using Chart data region for a graphical presentation of data in a report. There are numerous chart types that you can use to easily design and render data.

Note that in WebDesigner, Chart data region is not supported in design-time. Classic Charts (charts in older versions) are converted to new charts showing notification for same when reports with classic charts are loaded in ActiveReports 15 WebDesigner and later. Unsupported classic charts such as Renko and Kagi are converted to column chart.

CheckBox

Learn how to use checkbox in Section Reports.

Cross Section Controls

Learn about cross section controls and how to use them in section reports.

InputFieldCheckBox

Learn how to use InputFieldCheckBox control in Section Reports.

InputFieldText

Learn how to use InputFieldText report control for editable text fields in an exported PDF reports.

Label

Learn how to use labels in Section Reports to display descriptive text for controls.

Line

Learn how to use lines to draw boundaries or highlights specific areas in a report.

OleObject

Learn about adding an OLE object, bound to a database or unbound, directly to your report. Note that the OleObject control is not displayed in the toolbox by default, because it is obsolete, and is only available for backward compatibility.

Picture

Learn how to use Picture control and displays images files on the screen in section reports.

Report Info

Learn how to use the ReportInfo control to quickly display page numbers, page counts and report dates in section reports.

RichTextBox

Learn how to use the RichTextBox control to enter rich text in the form of formatted text, tables, hyperlinks, images, etc. in section reports.

Shape

Learn how to use shapes in section reports.

SubReport

Learn how to use the subreport control to connect the separate report to the subreport control in section reports.

TextBox

Learn how to use textbox control in Section Reports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Barcode

Barcode
Report Authors > Report Controls > Report Controls in Section Report > Barcode

Glossary Item Box

The Barcode report control, consisting of parallel bars and lines, is used to represent the data in a machine-readable format. This enables accurate scanning of sensitive information quickly and efficiently, and saves you the time and expense of finding and integrating a separate component.

Structure

Quiet zone is the left and right ends of the barcode. Both of the ends must be at least 10 times as wide as the minimum element width for proper scanning of the barcode data.

Start character indicates the start of the barcode data.

Stop character indicates the end of the barcode data.

Check digit is a numeric value used to check for read errors. It is located right after the barcode data.

Bar height is recommended to be greater than 15% of the barcode length. If the bar height is not high enough, it may lead to unstable readings of the barcode by the laser.

Barcode Types

ActiveReports supports all of the most popular symbologies.

Symbology Name | Example | Description
Ansi39 | Ansi39 Barcode | ANSI 3 of 9 (Code 39) uses uses upper case alphabets (A to Z), numerals (0 to 9), - , * $ / + %. This is the default barcode style.
Ansi39x | Ansi39x Barcode | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Aztec | Aztec Barcode | Aztec is a two-dimensional barcode symbology that supports all the ASCII characters from 0 to 255.
BC412 | BC412 Barcode | Data BC412 uses 35 characters, numerals (0 to 9), and upper case alphabets (A to Z). It is designed for semiconductor wafer identification.
Codabar | Codabar Barcode | Data that can be encoded are numerals (0 to 9) and symbols ("-", "$", ":", "/", "+" and ";"). For the Start Character and the Stop Character, A, B, C or D can be selected.
Code_11 | Encodes the numerals (0 to 9), the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numerals (0 to 9), punctuation, and upper case alphabets (A to Z).
Code_128_B | Code 128 B uses punctuation, numerals (0 to 9), upper case, and lower case alphabets.
Code_128_C | Code 128 C uses only numerals (0 to 9).
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numerals (0 to 9).
Code_93 | Code 93 uses upper case alphabets (A to Z), % $ * / , + -, and numerals (0 to 9).
Code25intlv | Code25intlv Barcode | Interleaved 2 of 5 uses only numerals (0 to 9).
Code39 | Code39 Barcode | Code 39 uses numerals (0 to 9), % * $ /. , - +, and upper case alphabets (A to Z).
Code39x | Code39x Barcode | Extended Code 39 uses the complete ASCII character set.
Code49 | Code49 Barcode | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Code93x Barcode | Extended Code 93 uses the complete ASCII character set.
DataMatrix | DataMatrix Barcode | Data Matrix is a high-density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numerals (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSum property is set to True.
EAN_8 | EAN-8 uses only numerals (7 numbers and a check digit).
EAN128FNC1* | EAN128FNC1 Barcode | EAN-128FNC1 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry.
GS1QRCode GS1QRCode Barcode

GS1QRCode is a subset of the QR Code. The GS1 QR Code is a 2D symbol that denotes the Extended Packaging URL for a trade item. It is processed to obtain one URL address associated with the trade item identified by the Global Trade Item Number (GTIN). GS1 QR Code requires the mandatory association of the GTIN and Extended Packaging URL.

GS1 QR Code allows encoding GS1 System Application Identifiers (AI) into QR Code 2D barcodes.

Limitation: Kanji, CN, JP and Korean characters.
HIBCCode128 | HIBCCode128 Barcode | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as a delimiter. It is used in the health care products industry for identification purposes.
HIBCCode39 | HIBCCode39 Barcode | HIBCCode39 barcode uses the Code39 symbology, with the Code39OptionalCheckDigit property set to True. It encodes Primary Data and Secondary Data using slash (/) as a delimiter. It is used in the health care products industry for identification purposes.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numerals with a check digit.
IntelligentMail | IntelligentMail Barcode | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage Barcode | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | ISBN Barcode | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | ISMN Barcode | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | ISSN Barcode | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | ITF14 Barcode | Interleaved Two of Five code is used to mark cartons that contain goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | JapanesePostal Barcode | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MaxiCode MaxiCode Barcode

MaxiCode is a special polar barcode that uses 256 characters. It is used to encode a specific amount of data.
MicroPDF417 MicroPDF417 Barcode

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert an FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
MicroQRCode MicroQRCode Barcode

MicroQRCode is a two-dimensional (2D) barcode that is designed for applications that use a small amount of data. It can handle numeric and alphanumeric data as well as Japanese kanji and kana characters. This symbology can encode up to 35 numeric characters.
MSI | MSI Barcode | MSI Code uses only numerals (0 to 9).
Pdf417 | Pdf417 Barcode | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. This symbology can encode up to 35 alphanumeric characters or 2,710 numeric characters.
Pharmacode | Pharmacode Barcode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey Barcode | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet Barcode | PostNet uses only numerals (0 to 9) with a check digit.
PZN | PZN Barcode | Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode Barcode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric, and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | RM4SCC Barcode | Royal Mail (RM4SCC) uses only letters and numerals (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14
(GS1 DataBar) 		RSS14 Barcode RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning. The RSS family of barcodes is also known as GS1 DataBar.
RSS14Stacked
(GS1 DataBar Stacked) 		RSS14Stacked Barcode RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14StackedOmnidirectional
(GS1 DataBar Stacked Omnidirectional) 		RSS14StackedOmnidirectional Barcode RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated
(GS1 DataBar Truncated) 		RSS14Truncated Barcode RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded
(GS1 DataBar Expanded) 		RSSExpanded Barcode

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates. RSSExpanded allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert an FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSExpandedStacked
(GS1 DataBar Expanded Stacked) 		RSSExpandedStacked Barcode

RssExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width. RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable-length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSLimited
(GS1 DataBar Limited) 		RSSLimited Barcode RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen Barcode | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCCEAN128 Barcode | UCCEAN-128 complies to GS1-128 standards. GS1-128 uses a series of Application Identifiers to encode data. This barcode uses the complete ASCII character set. It also uses the FNC1 character as the first character position. Using AI's, it encodes best before dates, batch numbers, weights, and more such attributes. It is also used in HIBC applications.
UPC_A | UPC-A uses only numerals (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numerals. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numerals. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.

Note that the following barcodes support FNC1 characters:

  • Aztec
  • UCCEAN128
  • MicroPDF417
  • RSSExpanded
  • RSSExpandedStacked

*The barcode EAN128FNC1 is now obsolete; you should use UCCEAN128 instead. The UCCEAN128 provides similar functionality with better performance and some default properties. You should choose EAN128FNC1 only if you do not need the default properties.

Important Properties

Clicking the barcode control reveals its properties in the Properties panel.

Property | Description
BarHeight | Set the height, in inches, of the barcode's bars. If the bar height exceeds the height of the control, this property is ignored.
CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read. This property is only available with certain styles of barcode and is ignored with other styles.
CaptionPosition | The vertical alignment of the caption in the control. Select from None, Above, or Below. See Alignment for horizontal alignment. None is selected by default, and no caption is displayed.
Font | Set the font for the caption. Only takes effect if you set the CaptionPosition property to a value other than None.
NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in pixels (for example, 10 pixels).
NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
QuietZone | Sets an area of blank space on each side of a barcode that tells the scanner where the symbology starts and stops. You can set separate values for the Left, Right, Top, and Bottom.
Rotation | Sets the amount of rotation to use for the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.
SupplementOptions | Sets the 2/5-digit add-ons for EAN/UPC symbologies. You can specify Text, DataField, BarHeight, CaptionPosition, and Spacing for the supplement.
BackColor | Select a background fill color for the barcode.
CheckSumEnabled | Some barcode styles require a checksum and some have an optional checksum. CheckSumEnabled has no effect if the style already requires a check digit or if the style does not offer a checksum option.
ForeColor | Select a color for the barcode and caption.
Style | Sets the symbology used to render the barcode. See the table below for details about each style.
AutoSize

When set to True, the barcode automatically stretches to fit the control.

Caution: This property works only with few barcode types and can break layout, so should be used very carefully.
Text | Sets the value to print as a barcode symbol and caption. ActiveReports fills this value from the bound data field if the control is bound to the data source.

Barcode Specific Properties

Aztec Options

Aztec options are available for the Aztec barcode style.

Error Correction: Indicates whether to allow code recovery if the barcode image is partly damaged, the value is ranging from 10% to 90%.

Layers: Indicates the number of the barcode layers.

Encoding: Select the barcode encoding from the drop-down list.

Code49 Options

Code49 options are available for the Code49 barcode style.

Use Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False (default). If Grouping is set to True, any value not expressed by a single barcode is expressed by splitting it into several barcodes.

GroupNumber: Enter a number between 0 (default) and 8 for the barcode grouping. When the Group property is set to 2, the grouped barcode's second symbol is created. When invalid group numbers are set, the BarCodeDataException is thrown.

DataMatrix Options

DataMatrix options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT, or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

Encoding: Select the barcode encoding from the drop-down list.

EAN128FNC1 Options

EAN128FNC1 options are available for the EAN128FNC1 barcode style.

DPI: Specify the printer resolution.

Module Size: Enter the horizontal size of the barcode module.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1DataMatrix Options

GS1DataMatrix options are available for the GS1DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT, or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

Encoding: Select the barcode encoding from the drop-down list.

GS1QRCode Options

GS1QRCode options are available for the GS1QRCode barcode style.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. Version M4 stores maximum amount of data.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

Composite Options

GS1Composite options are available for the RSS14Stacked and RSSLimited barcode styles.

Type: Select the type of the composite barcode from the drop-down list. The possible values are None or CCA. CCA (Composite Component - Version A) is the smallest variant of the 2-dimensional composite component.

Value: Enter the expression to set the value of the composite barcode.

MaxiCode Options

MaxiCode option is available for the MaxiCode barcode.

Mode: Select the mode of the MaxiCode barcode. The available values are Mode2 to Mode6.

MicroPDF417 Options

MicroPDF417 options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

MicroQRCode Options

MicroQRCode options are available for the MicroQRCode barcode style.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. Version M4 stores maximum amount of data.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

PDF417 Options

PDF417 options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode. Values for this property range from 1 to 30. The default value is -1 which automatically determines column numbers.

Rows: Enter row numbers for the barcode. Values range between 3 and 90. The default value is -1 which automatically determines row numbers.

ErrorLevel: Enter the error correction level for the barcode. Values range between 0 and 8. The error correction capability increases as the value increases. With each increase in the ErrorLevel value, the size of the barcode increases. The default value is -1 for automatic configuration.

PDF 417 Barcode Type: Select the PDF417 barcode type from the drop-down list. The possible values are Normal or Simple. Simple is the compact type in which the right indicator is neither displayed nor printed.

QRCode Options

QRCode options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1, the original model or Model2, the extended model. For GS1QRCode, Model1 is not supported.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. The possible values are L (7% restorable), M (15% restorable), Q (25% restorable), and H (30% restorable). The higher the percentage, the larger the barcode becomes.

Version: Enter the version of the QRCode barcode style. Version indicates the size of the barcode. As the value increases, the barcode's size increases, enabling more information to be stored. Specify any value between 1 and 14 when the Model property is set to Model1 and 1 to 40 for Model2. The default value is -1, which automatically determines the version most suited to the value.

Mask: Select the pattern for the barcode masking from the drop-down list. Mask is used to balance brightness and offers 8 patterns in the QRCodeMask enumeration. The default value is Auto, which sets the masking pattern automatically, and is recommended for most uses.

  • Mask000 (i+j) mod 2 = 0
  • Mask001 i mod 2 = 0
  • Mask010 j mod 3 = 0
  • Mask011 (i+j) mod 3 = 0
  • Mask100 (( i div 2)+(j div 3)) mod 2 = 0
  • Mask101 (ij) mod 2 + (ij) mod 3 = 0
  • Mask110 ((ij) mod 2 +(ij) mod 3) mod 2 = 0
  • Mask111 ((ij)mod 3 + (i+j) mod 2) mod 2 = 0

Use Connection: Select whether to use the connection for the barcode. The possible values are True or False. This property is used in conjunction with the ConnectionNumber property. This property does not apply to the GS1QRCode barcode.

ConnectionNumber: Enter the connection number for the barcode. Use this property with the Connection property to set the number of barcodes it can split into. Values between 0 and 15 are valid. An invalid number raises the BarCodeData Exception. This property does not apply to the GS1QRCode barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

UPC Supplementary Options

Supplementary options are available for UPC_A, UPC_E0, UPC_E1, EAN_13, and EAN_8 barcode styles.

Supplement DataField: Select the data field for the barcode supplement.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above, or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Barcode Dialog Properties

You can set the Barcode properties in the Barcode dialog. To open it, with the Barcode selected in the report, under the Properties panel, click the Property dialog link.

General
Barcode Settings
Appearance
Font

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

Autosize: Clear this check box to prevent the barcode from automatically resizing to fit the control.

Caution: This property works only with few barcode types and can break layout, so should be used very carefully.
Caption

Location: Select a value to indicate whether and where to display a caption for the barcode. You can select from Above, Below, or None.

Text alignment: Select a value to indicate how to align the caption text. You can select from Center, Near, or Far.

Symbology: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies.

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a symbology which offers supplemental options, the additional options appear after the general collection of properties.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): Enter a value in points (for example, 0.8pt) for the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

Narrow Bar Width

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio: Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

QuietZone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.
Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

For more information, see the section on Barcode Specific Properties.

Fore color: Select a color to use for the bars in the barcode.

Background color: Select a color to use for the background of the control.

Rotation: Select a value indicating the degree of rotation to apply to the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Name: Select a font family name to use for the caption.

Size: Choose the size in points for the font.

Style: Choose from Normal or Italic.

Weight: Choose from Normal or Bold.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Chart

Chart
See Also
Report Authors > Report Controls > Report Controls in Section Report > Chart

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use the Chart data region to present data graphically in a report. The chart offers you 17 core chart types along with all of their variations, plus access to properties that control every aspect of your chart's appearance.

The Chart data region presents a series of points in different ways depending upon the chart type you choose. Some chart types display multiple series of data points in a single chart. Add more information to your chart by configuring data points, axes, titles, and labels. You can modify all of these elements in the Properties Panel.

When you first drop a Chart data region onto a report, the Chart Wizard appears, and you can set up your chart type, appearance, series, titles, axes, and legend on the pages of the wizard. You can specify a data source on the Series page.

Show Important Properties

Property | Description
BlackAndWhiteMode | Gets or sets a value indicating whether the chart is drawn in black and white using hatch patterns and line dashing to designate colors.
AutoRefresh | Gets or sets a value indicating whether the chart is automatically refreshed (redrawn) after every property change.
Backdrop | Gets or sets the chart's background style.
ChartAreas | Opens the ChartArea Collection Editor where you can set properties such as axes and wall ranges, and you can add more chart areas.
ChartBorder | Gets or sets the chart's border style.
ColorPalette | Gets or sets the chart's color palette.
DataSource | Gets or sets the data source for the chart.
GridLayout | Gets or sets the layout of the chart's areas in columns and rows.
Legends | Opens the Legend Collection Editor where you can set up the chart's legends.
Series | Opens the Series Collection Editor where you can set up the series collection for the chart.
Titles | Opens the Titles Collection Editor where you can set up titles in the header and footer of the chart.
UIOptions | Gets or sets user interface features for the chart. Choose from None, ContextCustomize, UseCustomTooltips, or ForceHitTesting.
Culture | Gets or sets the chart's culture used for value output formatting.
ImageType | Sets or returns the image generated by the chart. Choose from Metafile or PNG.

Chart Commands and Dialogs

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click any of the commands to open a dialog. Commands in this section include:

  • Clear Chart clears all of the property settings from the chart so that you can begin with a clean slate. You are given an opportunity to cancel this action.
  • Load allows you to load a saved XML file containing a chart that you created using the Chart data region.
  • Save As allows you to save the current chart to an XML file that you can load into a chart on any Section Report.
  • Customize opens the main Chart Designer dialog where you can access Chart Areas, Titles, Series, Legends, and Appearance tabs. This dialog has access to more of the customizable areas than the wizard, but all of the properties in this dialog are also available in the Properties window.
  • Wizard reopens the Chart Wizard that appears by default when you first drop a Chart data region onto a report.
  • Data Source opens the Chart Data Source dialog where you can build a connection string and create a query.

Chart Elements

The Chart elements help you to easily analyze the visual information and interpret numerical and relational data. The following image illustrates the elements that make up the Chart data region.

Section Report Chart Elements

Axis Label

A label along an axis that lets you label the units being shown.

Axis Title

The axis title allows you to provide a title for the information being shown on the axis.

Chart Backdrop

The chart backdrop is the background for the whole chart that is created. You can create your own backdrop using the different styles and colors available or you can use an image as a backdrop for your chart.

Chart Title

The chart title serves as the title for the chart.

Footer Title

The footer title allows you to add a secondary title for the chart along the bottom.

Grid Line

Grid lines can occur on horizontal and vertical axes and normally correlate to the major or minor tick marks for the axes.

Legend

The legend serves as a key to the specific colors or patterns being used to show series values in the chart.

Marker

The marker is used to annotate a specific plotted point in a data series.

Marker Label

The marker label allows you to display the value of a specific plotted point in a data series.

Major Tick

Major tick marks can occur on horizontal and vertical axes and normally correlate to the major gridlines for the axes.

Minor Tick

Minor tick marks can occur on horizontal and vertical axes and normally correlate to the minor gridlines for the axes.

Series

The series is a related group of data values that are plotted on the chart. Each plotted point is a data point that reflects the specific values charted. Most charts, such as the above bar chart, can contain more than one series, while others, such as a pie chart, can contain only one.

Wall Backdrop

The wall is the back section of the chart on which data is plotted.

See Also

Developers
Custom Properties in Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Area Chart

Area Chart
Report Authors > Report Controls > Report Controls in Section Report > Chart > Area Chart

Glossary Item Box

The Area Chart displays quantitative data and is based on the Line chart. In Area charts, the space between axis and line are commonly emphasized with colors, textures and hatchings.

2D Area Charts

This section describes 2D charts that fall under the Area Chart category (ChartType Area2D).

Area Chart
Area Chart in Section Report

An area chart is used to compare trends over a period of time or across categories.

Stacked Area Chart

Stacked Area Chart in Section Report

A stacked area chart is an area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Stacked Area 100% Chart

Stacked Area 100% Chart in Section Report

A stacked area chart (100%) is an 100% area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

3D Area Charts

This section describes 3D charts that fall under the Area Chart category (ChartType Area3D).

Simple Area Chart

Area 3D Chart in Section Report

Use a 3D area chart to compare trends in two or more data series over a period of time or in specific categories, so that data can be viewed side by side.

Note: To view a chart in 3D, in the ChartAreas property open the ChartArea Collection Editor and set the ProjectionType property to Orthogonal.

Stacked Area Chart

A stacked area chart is an area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Stacked Area 100% Chart

A stacked area chart (100%) is an 100% area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bar Chart

Bar Chart
Report Authors > Report Controls > Report Controls in Section Report > Chart > Bar Chart

Glossary Item Box

The Bar Chart is a chart with rectangular bars where the lengths of bars are proportional to the values they represent. The bars can be plotted vertically or horizontally.

2D Bar Charts

Given below is the list of 2D charts that falls under the Bar Chart category (Chart Type ).

Bar Chart

2D Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a bar chart to compare values of items across categories.

Gantt Chart

The Gantt chart is a project management tool used to chart the progress of individual project tasks. The chart compares project task completion to the task schedule.

Caution: In a Gantt chart, the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.

Horizontal Bar Chart

Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal bar chart to compare values of items across categories.

Stacked Bar Chart

Stacked Bar Chart

A stacked bar chart is a bar chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Stacked Bar Chart 100%

Stacked Bar Chart 100%

A StackedBAR110Pct chart is a bar chart with two or more data series stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

3D Bar Charts

Given below is the list of 3D charts that fall under the Bar Chart category.

Note: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Simple Bar Chart

3D Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Gantt Chart

The 3D gantt chart displays a gantt.

Note: In a 3D Gantt chart the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.

Horizontal Bar Chart

3D Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Stacked Bar Chart

3D Stacked Bar Chart

Use a 3D bar graph to compare values of items across categories, allowing the data to be viewed conveniently in a 3D format. A stacked bar graph is a bar graph with two or more data series stacked on top of each other. Use this graph to show how each value contributes to a total.

Stacked Bar Chart 100%

3D Stacked Bar Chart 100%

A Stacked Bar 3D 100% chart is a bar chart with two or more data series in 3D stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

Bar/Cylinder Chart

It is almost similar to a bar chart and values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. The only difference is that in a Bar/Cylinder Chart the data is represented through cylindrical shaped markers.

Bar/Pyramid Chart

In a Bar/Pyramid Chart the data is represented through pyramid shaped bars and values are represented by the height of the bars as measured by the y-axis. Category labels are displayed on the x-axis.

Clustered Bar Chart

3D Clustered Bar Chart

Use a 3D clustered bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line Chart

Line Chart
Report Authors > Report Controls > Report Controls in Section Report > Chart > Line Chart

Glossary Item Box

The Line Chart is a type of chart that displays information as a series of data points, connected by straight line segments.

2D Line Chart

Bezier Chart

Use a Bezier or spline chart to compare trends over a period of time or across categories. It is a line chart that plots curves through the data points in a series.

Bezier XY Chart

A Bezier XY chart connects DataPoints on X and Y with curved lines.

Simple 2D Line Chart

Use a 2D line chart to compare trends over a period of time or in certain categories in a 2D format.

2D Line Chart

Line XY Chart

Line XY Chart

A line XY chart plots points on the X and Y axes as one series and uses a line to connect points to each other.

3D Line Chart

Bezier Chart

Render a Bezier or Spline chart in 3D format.

Line Chart

3D Line Chart

Use a 3D line chart to compare trends over a period of time or in certain categories in a 3D format.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Pie and Doughnut Charts

Pie and Doughnut Charts
Report Authors > Report Controls > Report Controls in Section Report > Chart > Pie and Doughnut Charts

Glossary Item Box

A Pie Chart is a circular chart divided into sectors to illustrate proportion. A Doughnut Chart is functionally identical to a Pie Charts. It also has single-series and multi-series versions, with the only difference that it has a hole in the middle.

2D Pie and Doughnut Charts

Doughnut Chart

A doughnut chart shows how the percentage of each data item contributes to the total.

In order to show each section of the pie in a different color, set the Background property for each data point.

Funnel Chart

A funnel chart shows how the percentage of each data item contributes as a whole

Pyramid Chart

A Pyramid chart shows how the percentage of each data item contributes as a whole.

3D Pie and Doughnut Charts

Doughnut Chart

3D Doughnut Chart

A 3D doughnut chart shows how the percentage of each data item contributes to a total percentage, allowing the data to be viewed in a 3D format.

Funnel Chart

3D Funnel Chart

A 3D funnel chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Pyramid Chart

3D Pyramid Chart

A 3D Pyramid chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Pie Chart

3D Pie Chart

This type of chart displays the contribution of each value to a total.

Ring Chart

This chart type uses rings (inner and outer) to represent data.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Financial Chart

Financial Chart
See Also
Report Authors > Report Controls > Report Controls in Section Report > Chart > Financial Chart

Glossary Item Box

Financial charts are those which are specific to representing data related to financial activities. The Chart data region can draw a number of financial chart types:

  • Candle, High Low, High Low Open Close
  • Kagi, Renko
  • Point and Figure, Three Line Break

2D Financial Chart

Candle

Candle Stick Chart

A candle chart displays stock information, using High, Low, Open and Close values. The size of the wick line is determined by the High and Low values, while the size of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.

HiLo Chart

A HiLo chart displays stock information using High and Low, or Open and Close, values. The length of the HiLo line is determined by the High and Low values, or the Open and Close values.

Point and Figure Chart

Point and Figure Chart

The point and figure chart uses stacked columns of X's to indicate that demand exceeds supply and columns of O's to indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount. The use of these values in the point and figure chart to calculate pricing trends makes this chart best suited for long-term financial analysis.

Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Stock Chart

In a stock chart, series are displayed as a set of lines with markers for high, low, close, and open values. Values are represented by the height of the marker as measured by the y-axis. Category labels are displayed on the x-axis.

Stock chart is a visual representation of data related to the stock market. It may be used to represent data like stock prices and stock activities.

Stock Close Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close).

Stock Open Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close), low, and then close).

Three Line Break Chart

Three Line Break Chart

A Three Line Break chart uses vertical boxes or lines to illustrate price changes of an asset or market. Movements are depicted with box colors and styles; movements that continue the trend of the previous box paint similarly while movements that trend oppositely are indicated with a different color and/or style. The opposite trend is only drawn if its value exceeds the extreme value of the previous three boxes or lines. The below Three Line Break depicts upward pricing movement with black boxes and downward pricing movement with red boxes.

3D Financial Chart

Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Three Line Break Chart

Three line break 3D chart is a chart rendered in 3D.

See Also

Developers
Custom Properties in Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Point and Bubble Charts

Point and Bubble Charts
Report Authors > Report Controls > Report Controls in Section Report > Chart > Point and Bubble Charts

Glossary Item Box

Point or Bubble charts represent data by means of points and bubbles.

The ActiveReports Chart control can draw a number of point/bubble chart types, like, Bubble, BubbleXY, PlotXY, and Scatter.

Given below is the list of 2D charts that fall under the Point/Bubble Chart category.

Bubble Chart

The Bubble chart is an XY chart in which bubbles represent data points. The first Y value is used to plot the bubble along the Y axis, and the second Y value is used to set the size of the bubble. The bubble shape can be changed using the series Shape property.

Bubble XY Chart

The Bubble XY chart is an XY chart in which bubbles represent data points. The BubbleXY uses a numerical X axis and plots the x values and first set of Y values on the chart. The second Y value is used to set the size of the bubble.

Plot XY Chart

Plot XY Chart

A plot XY chart shows the relationships between numeric values in two or more series sets of XY values.

Scatter Chart

Use a scatter chart to compare values across categories.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CheckBox

CheckBox
Report Authors > Report Controls > Report Controls in Section Report > CheckBox

Glossary Item Box

You can use the CheckBox control to represent a Boolean value in a report. By default, the CheckBox control appears as a small box inside an empty textbox. If the Checked value is set to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Note: There is a difference in how the text is rendered in the CrossPlatform and in the GDI compatibility modes. Some text in the CrossPlatform mode (for example, text without spacing, text with non-ASCII characters, etc.) may not appear correctly in the report preview. For the correct text rendering, you must manually update the report layout (for example, change the control's size).

Structure

Important Properties

Clicking the CheckBox control reveals its properties in the Properties window.

Property | Description
Checked | Gets or sets a value indicating whether the check box is in the checked state. You can also set the Checked property of the check box in code or bind it to a Boolean database value.
Text | Gets or sets the printed caption of the check box.
CheckAlignment | Gets or sets the alignment of the check box text within the control drawing area.
DataField | Gets or sets the field from the data source to bind to the control.

You can double-click the CheckBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or you can assign data to display in code through the Text property.

In edit mode, using the toolbar you can format text in the CheckBox control using the toolbar or you modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

CheckBox Dialog Properties

You can set the CheckBox properties in the CheckBox dialog. To open it, with the CheckBox selected on the report, under the Properties window, click the Property dialog link.

General
Appearance
Font
Alignment

Name: Enter a name for the checkbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field that returns a Boolean value from the data source to bind to the control. The value of this field determines how to set the Checked property at run time.

Text : Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is displayed in the report to the right of the checkbox.

Check Alignment: Drop down the visual selector to choose the vertical and horizontal position for the check box within the control.

Checked: Select this check box to have the CheckBox control appear with a check mark in the box.

Background

Color: Select a color to use for the background of the checkbox.

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Alignment: Alignment of the text inside the checkbox.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap.

Padding: Amount of space (in Int32) to leave around report control.

Top padding: Set the top padding.

Left padding: Set the left padding.

Right padding: Set the right padding.

Bottom padding: Set the bottom padding.

Keyboard Shortcuts

In the edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In Visual Studio Integrated Designer, you can disable this feature in the EditModeEntering Event and EditModeExit Event.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CrossSectionBox

CrossSectionBox
Report Authors > Report Controls > Report Controls in Section Report > CrossSectionBox

Glossary Item Box

In section reports, you can use the CrossSectionBox report control to display a frame that runs from a header section through its related footer section, spanning all details that come between.

CrossSectionBox Section Report Control

You can place the CrossSectionBox control in the header section in the designer. On adding the control in the footer section, it automatically associates itself with the related header section in the Report Explorer. The control automatically spans intervening sections to end in the related footer section. Move and sizing handles for cross-section controls are not available; you need to use Properties panel instead.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
Radius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the CrossSectionBox control to a specified percentage. Default value is 0 (pt).
BackColor | Sets the back color.

Caution:

  • The CrossSectionBox and CrossSectionLine are not supported in multi-column reports where a GroupHeader section has the ColumnLayout property set to True.
  • The CrossSectionBox and CrossSectionLine controls are drawn across multiple sections. Therefore, it is not possible to change the control's appearance, etc. in the event of a section. The appearance of the CrossSection control can be dynamically changed only in the ReportStart event.

CrossSectionBox Dialog Properties

You can set the CrossSectionBox properties in the CrossSectionBox dialog. To open it, with the CrossSectionBox selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Line style: Select a line style to use for the borderline. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the borderline.

Line color: Select a color to use for the borderline.

Background color: Select a color to use for the background of the picture control.

CloseBorder: Select the checkbox to close the borders.

Note: The CloseBorder property is only available for CrossSectionBox control placed in Section report's Group Header and Group Footer.

Rounded Rectangle: Specify the radius for each corner of the CrossSectionBox individually. Drag the handlers Handler available at each corner of the CrossSectionBox to set the value of the radius at each corner.

Note: To enable specific corners, check the checkbox available near each corner of the CrossSectionBox control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the CrossSectionBox.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the CrossSectionBox.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CrossSectionLine

CrossSectionLine
Report Authors > Report Controls > Report Controls in Section Report > CrossSectionLine

Glossary Item Box

In section reports, you can use the CrossSectionLine report control to display vertical lines that run from a header section through its related footer section, spanning all details that come between.

CrossSectionLine Section Report Control

You can place the CrossSectionLine control in the header section in the designer. On adding the control in the footer section, it automatically associates itself with the related header section in the Report Explorer. The control automatically spans intervening sections to end in the related footer section. Move and sizing handles for cross-section controls are not available; you need to use Properties panel instead.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
LineColor | Allows you to get or set the color of the line.
LineStyle | Allows you to select the line style from solid, dash, dotted, or double.
LineWeight | Allows you to specify the thickness of the line.

Caution:

  • The CrossSectionBox and CrossSectionLine controls do not render properly in multi-column reports, that is, those in which a GroupHeader section has the ColumnLayout property set to True.
  • The CrossSectionBox and CrossSectionLine controls are drawn across multiple sections. Therefore, it is not possible to change the control's appearance, etc. in the event of a section. The appearance of the CrossSection control can be dynamically changed only in the ReportStart event.

CrossSectionLine Dialog Properties

You can set the CrossSectionLine properties in the CrossSectionLine dialog. To open it, with the CrossSectionLine selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Line style: Select a line style to use for the control. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the line.

Line color: Select a color to use for the line.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputFieldCheckBox

InputFieldCheckBox
See Also
Report Authors > Report Controls > Report Controls in Section Report > InputFieldCheckBox

Glossary Item Box

The InputFieldCheckBox report control provides support for a checkbox element in an exported PDF report where the control's value can be modified. The InputFieldCheckBox control inherits most of its properties from the CheckBox report control.

Note:

  • The InputFieldText control is part of the Professional Edition. With the Standard license, the control is not editable in an exported PDF file and is rendered as fixed text.
  • The report's CompatibilityMode property should be set to CrossPlatform for the InputFieldText control to be editable in PDF. This is the default mode for Section reports. In GDI mode, the control is non-editable.
  • In export formats other than PDF, such as RTF, XLS/XLSX, TXT, HTML, and MHT, the InputFieldCheckBox control is exported as a non-editable checkmark.

Important Properties

Property | Description
CheckAlignment | Gets or sets the alignment of the check box text within the control drawing area.
Checked | Gets or sets a value indicating whether the check box is in the checked state.
CheckStyle | Gets or sets the style of the check symbol inside the CheckBox. The available options are Check, Circle, Cross, Diamond, Square, and Star.
DataField | Gets or sets the field from the data source to bind to the control.
FieldName | Specifies a unique name of the field in the resulted PDF file.
ReadOnly | Prevents the user from changing the entered text content in the resulted PDF file.
Required | Forces the user to fill in the selected field of the resulted PDF file. If a user attempts to submit the form where the required field is blank, the error message appears and the empty required field is highlighted.
TabIndex | Sets the tab order of editable fields in the resulted PDF file. A field with the lowest TabIndex value is selected first.

See Also

InputFieldCheckBox Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputFieldText

InputFieldText
See Also
Report Authors > Report Controls > Report Controls in Section Report > InputFieldText

Glossary Item Box

The InputFieldText report control in section reports provides support for editable text fields in an exported PDF report where the control's value can be edited. The InputFieldText control inherits most of its properties from the TextBox report control.

Note:

  • The InputFieldText control is part of the Professional Edition. With the Standard license, the control is not editable in an exported PDF file and is rendered as fixed text.
  • The report's CompatibilityMode property should be set to CrossPlatform for the InputFieldText control to be editable in PDF. This is the default mode for Section reports. In GDI mode, the control is non-editable.
  • In export formats other than PDF, such as RTF, XLS/XLSX, TXT, HTML, and MHT, the InputFieldText control is exported as non-editable plain text independent of the Compatibility mode of the report.

InputFieldText Section Report control in edit mode

Important Properties

Property | Description
FieldName | Specifies a unique name of the field in the resulted PDF file.
MaxLenth | Specifies the maximum length of the entered text in the resulted PDF file. When set to null, the text is not restricted to any specified length.
MultiLine | Gets or sets a value indicating whether to allow text to break to multiple lines within the control in the resulted PDF file.
Password | Displays the user-entered text as a series of asterisks (*).
ReadOnly | Prevents the user from changing the entered text content in the resulted PDF file.
Required | Forces the user to fill in the selected field of the resulted PDF file. If a user attempts to submit the form where the required field is blank, the error message appears and the empty required field is highlighted.
SpellCheck | Indicates whether to spell check the text during its input or not in the resulted PDF file.
TabIndex | Sets the tab order of editable fields in the resulted PDF file. A field with the lowest TabIndex value is selected first.

See Also

InputFieldText Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Label

Label
Report Authors > Report Controls > Report Controls in Section Report > Label

Glossary Item Box

The Label control is available in Section reports and is very similar to the Section report's TextBox control, just that the Label control takes only the static text. The main difference between the two controls is the Angle property of the Label control, and the following properties of the TextBox control: CanGrow, CanShrink, CountNullValues, Culture, DistinctField, OutputFormat, SummaryFunc, SummaryGroup, SummaryRunning, and SummaryType.

Note: The CrossPlatform and the legacy GDI modes have different typography, so some text in migrated reports (for example, text without spacing, text with non-ASCII characters, etc.) may not appear correctly in the report preview. For the correct text rendering, you must manually update the report layout (for example, change the control's size).

Edit Mode

Double-clicking the Label control changes its mode to edit mode. In the edit mode, you can enter text directly in the control, or you can enter text in the Text property in the Properties panel.

Label Section Report control in edit mode

You can format text in the Label control in edit mode using the designer toolbar, or you can modify properties in the Properties panel. Formats apply to all of the text in the control. Text formatting changes from the Properties panel immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties panel.

Note: The TextBox and Label controls, unlike ReportInfo control, do not support page-related expressions.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
Angle | Gets or sets the angle (slope) of the text within the control area. Set the Angle property to 900 to display text vertically.
CharacterSpacing | Gets or sets the space between characters in points.
DataField | Gets or sets the field name from the data source to bind to the control.
HyperLink | Gets or sets a URL to which the viewer navigates when the user clicks the label at run time. The URL becomes an anchor tag or a hyperlink in HTML and PDF exports.
LineSpacing | Gets or sets the space between lines in points.
MinCondenseRate | Specifies the minimal rate of the text horizontal scaling in percentages. Should be between 10 and 100.
MultiLine | Gets or sets a value indicating whether to allow text to break to multiple lines within the control.
ShrinkToFit | Gets or sets a value indicating whether to decrease the font size so that all of the text shows within the boundaries of the control.
Style | Gets or sets a style string for the label.
Text | Gets or sets the text to show on the report.
TextJustify | Specifies how to distribute text when the Alignment property is set to Justify. With any other Alignment setting, this property is ignored.
VerticalAlignment | Gets or sets the vertical position of the label's text within the bounds of the control.
VerticalText | Indicates whether to render the label's text vertically.
WrapMode | Indicates whether a multi-line label control wraps words or characters to the beginning of the next line when necessary.

Label Dialog Properties

General
Appearance
Font
Format
Alignment

Name: Enter a name for the label that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the label.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Background Color: Select a color from the list to use for the background of the label.

Angle: Use the slider to set the degree of slope for the text within the control area.

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Line spacing: Enter a value in points to use for the amount of space between lines.

Character spacing: Enter a value in points to use for the amount of space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Textbox height

Can shrink text to fit fixed size control: Specify whether to decrease the text font to fit the control size.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Note: Setting the Horizontal alignment property to Justify enables the Justify method property options.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to determine whether and how text breaks to the next line.

Padding

Enter values in points to set the amount of space to leave around the label.

  • Top
  • Left
  • Right
  • Bottom

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line

Line
Report Authors > Report Controls > Report Controls in Section Report > Line

Glossary Item Box

The Line control allows you to draw vertical, horizontal or diagonal lines that visually separate or highlight areas within a section on a report.

Note: If you need lines to span across report sections, please see the CrossSectionLine control.

You can use your mouse to visually move and resize the Line, or you can use the Properties panel to change its X1, X2, Y1, and Y2 properties to specify the coordinates for its starting and ending points.

Important Properties

Clicking the four-way arrow selects the control and reveals its properties.

Property | Description
LineColor | Gets or sets the color of the line.
LineStyle | Gets or sets the pen style used to draw the line. The line styles include Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.
LineWeight | Gets or sets the pen width of the line in points.
X1 | Gets or sets the horizontal coordinate of the line's starting point.
X2 | Gets or sets the horizontal coordinate of the line's end point.
Y1 | Gets or sets the vertical coordinate of the line's starting point.
Y2 | Gets or sets the vertical coordinate of the line's end point.

Line Dialog Properties

You can set the Line properties in the Line dialog. To open it, with the Line selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance

Name: Enter a name for the line that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Line style: Select a line style to use for the line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the line.

Line color: Select a color to use for the line.

Anchor at bottom: Select this check box to automatically change the Y2 value to the value of the bottom edge of the containing section after it has grown to accommodate data at run time.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


OleObject

OleObject
Report Authors > Report Controls > Report Controls in Section Report > OleObject

Glossary Item Box

Note: OleObject is not supported in:

  • Section reports in the CrossPlatform compatibility mode
  • WebDesigner
  • .NET Core 3.1 and .NET 5+

The OleObject control is hidden from the toolbox by default, and is only retained for backward compatibility. You can enable the OleObject control in the Visual Studio toolbox only.

To enable the control in the Visual Studio toolbox, you must change the EnableOleObject property to true. This property can be found here: C:\Program Files (x86)\Common Files\MESCIUS\ActiveReports 19\ActiveReports.config

Once enabled, you can add the OleObject control to reports. When you drop the control onto your report, the Insert Object dialog appears. This dialog allows you to create a new object or select one from an existing file.

Note: When you deploy reports that use the OleObject, you must also deploy the MESCIUS.ActiveReports.Interop dll, or for 64-bit machines, the MESCIUS.ActiveReports.Interop64 dll.
Caution: The WPF Viewer does not support the OLE object. If you preview a report containing the OLE object in the WPF Viewer, the OLE object will not be displayed.

Important Properties

Property | Description
PictureAlignment | Gets or sets the position of the object's content within the control area.
Class | Specifies the class name of the Ole object.
SizeMode | Gets or sets a value that determines how the object is sized to fit the OleObject control area.

Insert Object Dialog

The Insert Object dialog provides the following two options:

  • Create New lets you select from a list of object types that you can insert into your report.

    Show Object Types

    • Adobe Acrobat Document
    • Microsoft Equation 3.0
    • Microsoft Excel 97-2003 Worksheet
    • Microsoft excel Binary Worksheet
    • Microsoft Excel Chart
    • Microsoft Excel Macro-Enabled Worksheet
    • Microsoft Excel Worksheet
    • Microsoft Graph Chart
    • Microsoft PowerPoint 97-2003 Presentation
    • Microsoft PowerPoint 97-2003 Slide
    • Microsoft PowerPoint Macro-Enabled Presentation
    • Microsoft PowerPoint Macro-Enabled Slide
    • Microsoft PowerPoint Presentation
    • Microsoft PowerPoint Slide
    • Microsoft Word 97-2003 Document
    • Microsoft Word Document
    • Microsoft Macro-Enabled Document
    • OpenDocument Presentation
    • OpenDocument Spreadsheet
    • OpenDocument Text
    • Package
    • Paintbrush Picture
    • Wordpad Document
  • Create from File allows you to insert the contents of the file as an object into your document so that you can display it while printing.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Picture

Picture
See Also
Report Authors > Report Controls > Report Controls in Section Report > Picture

Glossary Item Box

The Picture control in section reports is used to print an image on the report. In the Image property of the Picture control, you can select any image file to display on your report. You should use the PictureAlignment and SizeMode properties to control cropping and alignment.

Picture control supports Base64 string, Byte[], BMP, JPG/JPEG/JPE, GIF, PNG, EMF, WMF, SVG, TIF/TIFF formats in both GDI and CrossPlatform compatibility modes.

SVG Support

In CrossPlatform compatibility mode, SVG images are supported as vector images (original images) in all viewers and in PDF export; in other export formats, the images are exported as raster images. The GDI compatibility mode is recommended for use only as a fallback since SVG images are converted to raster images in all viewers and export formats.

Picture Dialog Properties

You can set the Picture properties in the Picture dialog. To open it, with the Picture selected on the report, under the Properties window, click the Property dialog link.

General
Appearance

Name: Enter a name for the picture control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Choose image: Click this button to open a dialog where you can navigate to a folder from which to select an image file to display.

Hyperlink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Title: Gets or sets the title of the control. The entered text appears as a tag when an exported pdf file is opened in the Text Editor. The entered text also appears on hovering the control in an exported PDF File and is audible in the Read Out Loud mode of the Acrobat Reader DC.

Description: Enter text to describe the image for those who cannot see it. This is used in the HTML export for the "alt" attribute of the img tag.

Line style: Select a line style to use for the borderline. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the borderline.

Line color: Select a color to use for the borderline.

Background color: Select a color to use for the background of the picture control.

Picture alignment: Select how to align the image within the control. You can select from TopLeft, TopRight, Center, BottomLeft, or BottomRight.

Size mode: Select how to size the image within the control. You can select from Clip, Stretch, or Zoom - Clip uses the original image size and clips off any excess, Stretch fits the image to the size and shape of the control, and Zoom fits the image into the control while maintaining the aspect ratio of the original image.

See Also

Picture Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ReportInfo

ReportInfo
Report Authors > Report Controls > Report Controls in Section Report > ReportInfo

Glossary Item Box

You can use the ReportInfo control in section reports to quickly display page numbers, page counts, and report dates. The ReportInfo control is a text box with a selection of preset FormatString options. You can set page counts to count the pages for the entire report, or for a specified group.

You can customize the preset values by editing the string after you select it. For example, if you want to display the total number of pages in the ReportHeader section, you can enter a value like: Total of {PageCount} pages

See Date, Time, and Number Formatting for information on creating formatting strings

Caution: With large reports using the CacheToDisk property, placing page counts in header sections may have an adverse effect on memory as well as rendering speed. Since the rendering of the header is delayed until ActiveReports determines the page count of the following sections, CacheToDisk is unable to perform any optimization. For more information on this concept, see Optimizing Section Reports.

ReportInfo Dialog Properties

You can set the ReportInfo properties in the ReportInfo dialog. To open it, with the ReportInfo selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance
Font
Format
Alignment
Summary

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Background Color: Select a color to use for the background of the control.

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Format string: Select a formatted page numbering or report date and time value to display in the control. You may also type in this box to change or add text to display along with the formatted date and page number values.

Multiline: Select this check box to allow text to render on multiple lines within the control.

ReportInfo height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

SummaryGroup: Select a GroupHeader section in the report to display the number of pages in each group when using the PageCount.

SummaryRunning: Select None, Group, or All to display a summarized value.

Displaying Page Numbers and Report Dates

With the ReportInfo control, you can display page numbers and report dates and times by selecting a value in the FormatString property. This property provides the following predefined options for page numbering and date and time formatting.

Numbering Format | Description
Page {PageNumber} of {PageCount} on {RunDateTime} | Display the page numbers along with Date and Time in the following format : Page 1 of 100 on 1/31/2020 2:45:50 PM
Page {PageNumber} of {PageCount} | Display the only the page numbers in the following format : Page 1 of 100
{RunDateTime:} | Display the Date and Time in the following format : 1/31/2020 2:45:50 PM
{RunDateTime: M/d} | Display the Date in the following format : 1/31
{RunDateTime: M/d/yy} | Display the Date in the following format : 1/31/20
{RunDateTime: M/d/yyyy} | Display the Date in the following format : 1/31/2020
{RunDateTime: MM/dd/yy} | Display the Date in the following format : 01/31/20
{RunDateTime: MM/dd/yyyy} | Display the Date in the following format : 01/31/2020
{RunDateTime: d-MMM} | Display the Date in the following format : 31-Jan
{RunDateTime: d-MMM-yy} | Display the Date in the following format : 31-Jan-20
{RunDateTime: d-MMM-yyyy} | Display the Date in the following format : 31-Jan-2020
{RunDateTime: dd-MMM-yy} | Display the Date in the following format : 31-Jan-20
{RunDateTime: dd-MMM-yyyy} | Display the Date in the following format : 31-Jan-2020
{RunDateTime: MMM-yy} | Display the Date in the following format : Jan-20
{RunDateTime: MMM-yyyy} | Display the Date in the following format : Jan-2020
{RunDateTime: MMMM-yy} | Display the Date in the following format : January-20
{RunDateTime: MMMM-yyyy} | Display the Date in the following format : January-2020
{RunDateTime: MMMM d,yyyy} | Display the Date in the following format : January 31, 2020
{RunDateTime: M/d/yy h:mm tt} | Display the Date and Time in the following format : 1/31/20 2:45 PM
{RunDateTime: M/d/yyyy h:mm tt} | Display the Date and Time in the following format : 1/31/2020 2:45 PM
{RunDateTime: M/d/yy h:mm} | Display the Date and Time in the following format : 1/31/20 2:45
{RunDateTime: M/d/yyyy h:mm} | Display the Date and Time in the following format : 1/31/2020 2:45
  1. From the Toolbox, drag the ReportInfo control to the desired location on the report.
  2. With the ReportInfo control selected in the Properties panel, drop down the FormatString property and select the preset value that best suits your needs.

Displaying Group Level Page Counts

  1. From the toolbox, add the ReportInfo control to the GroupHeader or GroupFooter section of a report and set the FormatString property to a value that includes PageCount.
  2. With the ReportInfo control still selected, in the Properties panel, drop down the SummaryGroup property and select the group for which you want to display a page count.
  3. Drop down the SummaryRunning property and select Group.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


RichTextBox

RichTextBox
Report Authors > Report Controls > Report Controls in Section Report > RichTextBox

Glossary Item Box

The RichTextBox control is used to display, insert, and manipulate formatted text. It is different from the TextBox control in several ways. The most obvious is that it allows you to apply different formatting to different parts of its content.

You can add fields to the text you enter directly in the RichTextBox control by right-clicking and choosing Insert Fields and providing a field name or you can load an RTF, an HTML, or a Text file into the control.

Note: The RichTextBox control supports loading an RTF file at design time with both CrossPlatform and GDI compatibility modes of a report. However, the RichTextBox control does not support the RTF file at run-time when the report's CompatibilityMode is set to CrossPlatform.

Supported Formats

ActiveReports supports most of the XHTML 1.1 standard; please see Wikipedia for more information. The limited support for reading XHTML5 and HTML5 documents is also available. The RichTextBox control supports formats such as:

  • Simple RTF content (without complicated tables, styles) with data binding support.
  • Complicated RTF content (if RtfRenderingType property is set to any mode, other than RTF); uses the latest available WordPad features.
  • Plain text content (is converted to simple HTML).
  • HTML content (almost all XHTML 1.1 specification with some HTML5 extensions are supported)

Load File Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties panel, you can click Load file to open the dialog. This allows you to select a file to load into the control at design time. Supported file types are as follows.

  • Text (*.txt)
  • RichText (*.rtf)
  • HTML (*.htm, *.html)

RichText file

When you load a RichText file, the control will display the file in edit mode.

RichText file in edit mode

Text/HTML file

When you load a Text or an HTML file, the control will display the HTML markup in the edit mode.

Text/HTML file in edit mode

Important: The HTML text in an HTML file, loaded into the RichTextBox control, must be enclosed in the <body></body> tags. Otherwise, the HTML data is converted into RTF.

Important Properties

Property | Description
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
RenderRtfAsContinuousImage

If True (default), the property renders the content as one continuous image split across the pages. This property is actual if RtfRenderingType property is set to either Metafile or PNG.

Note: This property should be set to 'False' if the RtfRenderingType property is set to a Metafile or PNG, to avoid any trimmed text at the end of the pages.
RtfRenderingType | Renders the RTF control with a legacy renderer or with the WordPad as a metafile or raster image. Only the legacy RTF renderer supports fields.
DataField | Gets or sets the field name from the data source to bind to the control.

RichTextBox Dialog Properties

You can set the RichTextBox properties in the RichTextBox dialog. To open it, with the RichTextBox selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance
Format

Name: Enter a name for the RichTextBox that is unique within the report. This name is displayed in the Document Outline. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Max length: Enter the maximum number of characters to display in the control. If you do not specify a value, it displays an unlimited number of characters.

Background Color: Select a color to use for the background of the control.

RichTextBox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Multiline: Select this check box to allow the control to display multiple lines of text.

Supported HTML Tags and Attributes

The RichTextBox control supports HTML tags and attributes same as the FormattedText control. For more information, please see the topic on FormattedText.

Write an RTF file to load into a RichTextBox control

  1. Open WordPad, and paste a formatted text into it, for example:

    [Paste the following section into an RTF File]
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Customer List by Country

    Argentina

    • Rancho grande
    • Océano Atlántico Ltda.
    • Cactus Comidas para llevar

    Austria

    • Piccolo und mehr
    • Ernst Handel

    Belgium

    • Suprêmes délices
    • Maison Dewey

    Brazil

    • Familia Arquibaldo
    • Wellington Improtadora
    • Que Delícia
    • Tradição Hipermercados
    • Ricardo Adocicados
    • Hanari Carnes
    • Queen Cozinha
    • Comércio Mineiro
    • Gourmet Lanchonetes
      - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  2. Save the file as sample.rtf.
Note: The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control.

Load an RTF file into a RichTextBox control

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the bottom of the Properties Panel, click Load file.
  3. In the Open dialog that appears, browse to an *.RTF file (For example, sample.rtf) and click the Open button to load the file in the RichTextBox control.

Write an HTML file to load into a RichTextBox control

  1. Open a Notepad, and paste an HTML code into it, for example:
    HTML code. Paste in a NotePad file. Copy Code
    <html>
<body>
<center><h1>Customer List by Country</h1></center>
<h1>Argentina</h1>
<ul>
<li>Rancho grande
<li>Océano Atlántico Ltda.
<li>Cactus Comidas para llevar
</ul>
<h1>Austria</h1>
<ul>
<li>Piccolo und mehr
<li>Ernst Handel
</ul>
<h1>Belgium</h1>
<ul>
<li>Suprêmes délices
<li>Maison Dewey
</ul>
<h1>Brazi1>
<ul>
<li>Familia Arquibaldo
<li>Wellington Improtadora
<li>Que Delícia
<li>Tradição Hipermercados
<li>Ricardo Adocicados
<li>Hanari Carnes
<li>Queen Cozinha
<li>Comércio Mineiro
<li>Gourmet Lanchonetes
</ul>
</body>
</html>
  2. Save the file as sample.html.

Load an HTML file into the RichTextBox control

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the bottom of the Properties panel, click Load file.
  3. In the Open dialog that appears, browse to a *.html file (For example, sample.html) and click the Open button to load the file in the RichTextBox control.

ActiveReports also provides limited support for reading XHTML5 and HTML5 documents.

Keyboard Shortcuts

In the edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Shape

Shape
Report Authors > Report Controls > Report Controls in Section Report > Shape

Glossary Item Box

The Shape report control is used to display one of the available shape types on a report. You can add a shape report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the Style property of the Shape report control, you can select Rectangle, RoundRect or Ellipse, or you can use an expression to assign fields, datasets, parameters, constants, operations or common values to it.

You can highlight different sections or parts of a report using a shape report control. For example, you can use a Rectangle as border around different report controls or the entire page or you can use an Ellipse to highlight a note on your report.

Important Properties

Clicking the Shape control reveals its properties in the Properties panel.

Property | Description
LineColor | Gets or sets the color of the shape lines.
LineStyle | Gets or sets the pen style used to draw the line.
LineWeight | Gets or sets the pen width used to draw the shape.
Style | Gets or sets the shape type to draw. You can select from Rectangle, Ellipse and a RoundedRect.
RoundingRadius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the Shape control to a specified percentage. Default value = 10 (percent).

Shape Dialog Properties

You can set the Shape properties in the Shape dialog. To open it, with the Shape selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance

Name: Enter a name for the shape that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), backslash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Shape type: Select the type of shape to display. You can choose from Rectangle, Ellipse, or RoundRect. For a circle, set the control width and height properties to the same value, and choose Ellipse, or choose RoundRect and set the Rounding radius to 100%.

Rectangle | RoundRect | Ellipse
Rectangle Shape style | Rounded Rectangle Shape style | Ellipse Shape style

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers Shape handlers available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, select the checkbox available near each corner of the Shape control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the shape.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the shape.

Line style: Select a line style to use for the shape line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the shape line.

Line color: Select a color to use for the shape line.

Background style: Select a background style for the shape from Solid, Gradient, and Pattern. Depending on the style selected, other properties are available.

Background color: Select a color to use for the background of the shape.

Background color2: Select a color2 to use for the background of the shape. This property becomes available if the Background style is set to Gradient or Pattern.

Gradient style: Select a gradient style. This property becomes available if the Background style is set to Gradient.

Background pattern: Select a background pattern to hatch style. This property becomes available if the Background style is set to Pattern.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


SubReport

SubReport
Report Authors > Report Controls > Report Controls in Section Report > SubReport

Glossary Item Box

In section reports, you can use the SubReport control to embed a report into another report. There are two (2) ways to select a report to display within the SubReport control:

  • Once you place the SubReport control on a report, use code to create an instance of the report you want to load in it, and attach the report object to the SubReport.
  • After placing the SubReport control on a report, in the ReportName property, select the <From File...> option to open the Open dialog, and then select a report.

You can also pass parameters to the subreport from the main report so that data related to the main report displays in each instance of the subreport.

Note: You cannot use a Page/RDLX report as the target of a SubReport in a Section report.

Remove page-dependent features from reports to be used as subreports

Subreports are disconnected from any concept of a printed page because they render inside the main report. For this reason, page-dependent features are not supported for use in subreports. Keep any such logic in the main report. Page-related concepts that are not supported in subreports include:

  • Page numbers
  • Page header and footer sections (delete these sections to save processing time)
  • KeepTogether properties
  • GroupKeepTogether properties
  • NewPage properties

Coding best practices

Use the ReportStart event of the main report to create an instance of the report for your SubReport control, and then dispose of it in the ReportEnd event. This way, you are creating only one subreport instance when you run the main report.

In the Format event of the containing section, use the Report property of the SubReport control to attach a report object to the SubReport control.

Caution: It is not a recommended practice to initialize the subreport in the Format event. Doing so creates a new instance of the subreport each time the section processes. This consumes a lot of memory and processing time, especially in a report that processes a large amount of data.

Important Properties

Clicking the SubReport control reveals its properties in the Properties panel.

Property | Description
CanGrow | Determines whether ActiveReports increases the height of the control based on its content.
CanShrink | Determines whether ActiveReports decreases the height of the control based on its value.
CloseBorder | By default, the bottom border of the control does not render until the end of the subreport. Set this property to True to have it render at the bottom of each page. (Only available in code)
ReportName | Specifies the name of the subreport with the <From File...> option that opens the Open dialog.

SubReport Dialog Properties

With the control selected on the report, in the Commands section at the bottom of the Properties panel, you can click the Property dialog command to open the dialog.

General
Format

Name: Enter a name for the SubReport that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

ReportName: Select the <From File...> option to open the Open dialog, and then select a report to display within the SubReport control.

SubReport Height

Can increase to accommodate contents: Clear this check box to set CanGrow to False.

Can decrease to accommodate contents: Clear this check box to set CanShrink to False.

Using SubReport Control in Reports

To use the SubReport control in your report, you must create two reports - one parent and one child report. Then, after dragging the SubReport control onto the parent report, you need to either select a report to display within the SubReport control or add code to create an instance of the child report in the parent report, and another code to display the child report in the SubReport control on a parent report.

For details on working with SubReport control in section reports, see Work with Subreports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TextBox

TextBox
See Also
Report Authors > Report Controls > Report Controls in Section Report > TextBox

Glossary Item Box

The TextBox control is the basis of reporting as it is used to display textual data in section reports. You can add multiple lines, wrap text to the control size, shrink text to fit within the bounds of control, and perform basic formatting.

The TextBox control can be bound to any data or set at run time. Also, it is the same control that forms when you drag a field onto a report from the Report Explorer. In the Text property of the TextBox, you can enter static text or an expression. To enter a text directly into the TextBox, just double-click inside the control on the design surface of the report. An expression in TextBox can display fields from a database, calculate a value, or visually display data.

Note: There is a difference in how the text is rendered in the CrossPlatform and in the GDI compatibility modes. Some text in the CrossPlatform mode (for example, text without spacing, text with non-ASCII characters, etc.) may not appear correctly in the report preview. For the correct text rendering, you must manually update the report layout (for example, change the control's size).

Edit Mode

You can double-click in the TextBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties panel or code through the Text property.

TextBox control in Edit Mode

You can format text in the TextBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties panel. Formats apply to all of the text in the control. Text formatting changes in the Properties panel immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties panel.

Note: The TextBox and Label controls, unlike ReportInfo control, do not support page-related expressions.

Important Properties

Clicking the TextBox control reveals its properties in the Properties panel.

Property | Description
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the control based on its value.
CharacterSpacing | Gets or sets a character spacing in points.
CountNullValues | Boolean which determines whether DBNull values should be included as zeroes in summary fields.
Culture | Gets or sets CultureInfo used for value output formatting.
DataField | Gets or sets the field name from the data source to bind to the control.
DistinctField | Gets or sets the name of the data field used in a distinct summary function.
HyperLink | Gets or sets the hyperlink for the text control.
LineSpacing | Gets or sets a line spacing in points.
MinCondenseRate | Specifies the minimal rate of the text horizontal scaling in percentages. Should be between 10 and 100.
MultiLine | Gets or sets a value indicating whether this is a multi-line textbox control.
OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
ShrinkToFit | Determines whether ActiveReports decreases the font size when text values exceed available space.
Style | Gets or sets a style string for the textbox.
SummaryFunc | Gets or sets the summary function type used to process the DataField Values.
SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
SummaryRunning | Gets or sets a value that determines whether that data field summary value will be accumulated or reset for each level (detail, group, or page).
SummaryType | Gets or sets a value that determines the summary type to be performed.
Text | Gets or sets the formatted text value to be rendered in the control.
TextJustify | Specifies text justification with TextAlign set to Justify.
VerticalAlignment | Gets or sets the position of the textbox's text vertically within the bounds of the control.
VerticalText | Gets or sets whether to render text according to vertical layout rules.
WrapMode | Indicates whether a multi-line textbox control automatically wraps words or characters to the beginning of the next line when necessary.

TextBox Dialog Properties

You can set the TextBox properties in the TextBox dialog. To open it, with the TextBox selected on the report, under the Properties panel, click the Property dialog link.

General
Appearance
Font
Format
Alignment
Summary

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties panel or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Background Color: Select a color to use for the background of the textbox.

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Line Spacing: This property sets the space between lines of text.

Character Spacing: This property sets the space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Textbox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Padding

  • Top: Set the top padding in points.
  • Left: Set the left padding in points.
  • Right: Set the right padding in points.
  • Bottom: Set the bottom padding in points.

SummaryFunc: Select a type of summary function to use if you set the SummaryRunning and SummaryType properties to a value other than None. For descriptions of the available functions, see the SummaryFunc enumeration.

SummaryGroup: Select a section group that you have added to the report. If you also set the SummaryRunning property to Group, the textbox summarizes only the values for that group.

SummaryRunning: Select None, Group, or All. If None, the textbox shows the value for each record. If Group, the textbox summarizes the value for the selected SummaryGroup. If All, the textbox summarizes the value for the entire report.

SummaryType: Select the type of summary to use. For descriptions of the available types, see the SummaryType enumeration.

Distinct Field: Select a field to use with one of the SummaryFunc distinct enumerated values.

Count null values: Select this check box to include null values as zeroes in summary fields.

Text Justification

The TextJustify property of a Textbox control provides you justification options for aligning your text within a control. It is important to note that the Alignment property must be set to Justify for TextJustify property to affect the text layout.

Note: The TextJustify property is also available in the Label control.

You can choose from the following values of the TextJustify property:

Auto

Results in Standard MSWord like justification where space at the end of a line is spread across other words in that line. This is the default value.

Distribute

Spaces individual characters within a word, except for the last line.

DistributeAllLines

Spaces individual characters within words and also sets the justification on the last line according to the length of other lines.

To set text justification,

  1. Select the TextBox control to view its properties in the Properties panel.
  2. In the Properties panel, set the Alignment to Justify.
  3. Go to the TextJustify property and from the drop down list select any one option.

Text justification is supported when you preview a report in the Viewer, print a report, or export a report in PDF, and TIFF formats.

Shrink Text to Fit in a Control

When working with the TextBox or Label control in a Section report, you can use the ShrinkToFit property to reduce the size of the text so that it fits within the bounds of the control. The text shrinks at run time, so you can see the reduced font size when you preview, print or export the report.

You can use other text formatting properties in combination with the ShrinkToFit property.

Caution:

  • When both CanGrow and ShrinkToFit are set to True, CanGrow setting is ignored and only ShrinkToFit is applied.
  • When ShrinkToFit is set to True and Angle is set to a value other than 0, the ShrinkToFit property is ignored.
  • ShrinkToFit property does not work in the following conditions:
    • VerticalText property is set for a control.
    • Multiline property is set to False.

On exporting a report, various file formats handle ShrinkToFit differently. ShrinkToFit gets exported in all formats except Text.

Multiline in TextBox

You can display multiline text in TextBox and some other controls such as RichTextBox and Label for section reports.

In a Section report, you can enable multiline display in your report control by setting the Multiline property to True. Then, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter keys to create multiline text. However, when the MultiLine property is set to False, the text entered into the control is displayed on a single line.

Note: In edit mode, scrollbars appear automatically to fit multiline content within a control. However, these are not displayed at preview, so you may need to adjust the Size property of the control to display all of the text.

Line Spacing and Character Spacing

In edit mode, scrollbars appear automatically to fit multiline content within a control. However, these are not displayed at preview, so you may need to adjust the Size property of the control to display all of the text.

TextBox line and character spacing

To set Line or Character spacing,

  1. On the design surface, click the TextBox control to display it in the Properties panel.
  2. In the Properties panel, click the Property dialog command at the bottom to open the control dialog.
  3. In the TextBox dialog, go to the Format page and set the Line Spacing or Character Spacing values in points.

Line and character spacing are supported when you preview a report, print a report, or export a Section report in HTML , PDF, and TIFF formats.

Keyboard Shortcuts

In the edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In Visual Studio Integrated Designer, you can disable this feature in the EditModeEntering Event and EditModeExit Event.

See Also

TextBox Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Wizard

Report Wizard
Report Authors > Report Wizard

Glossary Item Box

The Report Wizard is a handy tool for quickly setting up the report structure, data sources, and layout.

The Report Wizard appears when you invoke the New command in the Standalone Report Designer App, add a new ActiveReports Item to your VS.NET project, or create a new VS.NET project from one of the ActiveReports project templates.

The Report Wizard guides you through a series of steps that allow you to:

  • Choose the type of report to create
  • Configure the page settings of the report
  • Establish the connection to the data source
  • Add queries to the data source
  • Set up the report control - Table, Chart, or Pivot Table

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Selecting Report Type

Selecting Report Type
Report Authors > Report Wizard > Selecting Report Type

Glossary Item Box

The first page of the Report Wizard allows you to select the report type that best suits your needs.

Choose Report Type of the Report Wizard

For detailed explanations of each report type, please refer to the Report Types section of this guide. Below is a brief guide to help you choose the appropriate report type:

  • RDLX: If you're unsure which type to choose, this is the default option and is suitable for most reports.
  • RDLX Dashboard: Select this type if you intend to create a dashboard with interactive and visual elements.
  • Page: Ideal for creating pixel-perfect reports, especially when you have a predefined layout, such as a legal document.
  • Section: This is a straightforward band-based layout, perfect for simple reports without advanced features.
  • Sample Report: Choose this option if you want to explore and test specific features of ActiveReports.NET using pre-designed reports.

After selecting the report type, you can either click Finish >> to create an empty report or Next > to continue with the Page Settings.

Note:

The Finish >> button is disabled for the Sample Report option because you will need to select a specific sample in the next step.

The Next > button is disabled for the Section Report option as no additional configuration is required for this report type.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Page Settings

Configuring Page Settings
Report Authors > Report Wizard > Configuring Page Settings

Glossary Item Box

The Configure Page Settings page of the Report Wizard allows you to define the paper size, orientation, and layout for your report.

Configure Page Settings of the Report Wizard

The available options are:

  • Paper
    • Size: You can choose one of the pre-defined paper sizes, such as Letter or A4 or select the Custom option that allows you to specify the width and height of the paper manually.
    • Orientation: Select either Portrait or Landscape orientation, depending on how you want the content to be laid out on the page. This option is disabled for the Custom size.
    • Width and Height: These fields automatically update based on the selected paper size and orientation. You can also manually set them for the Custom size.
    • Margins: Use the dropdown to select the margin size. Options include Normal, Narrow, Moderate, and None.
  • Header and Footer

You can choose to include a Page Header and/or Page Footer by checking the corresponding boxes.

Additional options include:

  • Show Page Numbers: Displays page numbers on each page footer or header.
  • Show Current Date: Adds the current date to the page header or footer.
  • Show Report Name: Displays the report name in the footer or header.
  • Preview

On the right side of the page, you will see a Preview pane that provides a visual representation of the current settings. This preview updates automatically as you make changes.

After configuring your page settings, click Next > to proceed with the Configuring Data Source step, or Finish >> to finalize your settings and generate an empty report with the selected page settings. If you need to make changes, you can click < Back to return to the previous step or Cancel to exit the wizard.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Data Source

Configuring Data Source
Report Authors > Report Wizard > Configuring Data Source

Glossary Item Box

The Choose Data Source Type page of the Report Wizard allows you to select the type of data source you want to connect to when creating a new report. The available options are categorized into four sections: Database, File, Web API, and Programmatic.

Choose Data Source Type of Report Wizard

Database

In this section, you can select from a variety of database management systems:

  • MS SQL Server: Choose to connect to a Microsoft SQL Server database.
  • MySQL: Choose to connect to a MySQL database.
  • PostgreSQL: Choose to connect to a PostgreSQL database.
  • SQLite: Choose to connect to a SQLite database file.

File

Here, you can choose to connect to various file types:

  • JSON: Select to load data from a JSON file.
  • XML: Select to load data from an XML file.
  • CSV: Select to load data from a CSV (Comma-Separated Values) file.
  • Excel: Select to load data from a Microsoft Excel file.

Web API

  • JSON API: Choose to connect to a web API that returns data in JSON format.

Programmatic

  • Object: Available only in Visual Studio .NET, this option allows you to supply data from your application's code. It lets you bind data from custom objects or collections defined in your code.

After choosing the data source type, click Next > to proceed with configuring the connection. You can also click < Back to return to the previous step, or Cancel to exit the wizard.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Database Data Source

Database Data Source
Report Authors > Report Wizard > Configuring Data Source > Database Data Source

Glossary Item Box

If you selected one of the MS SQL Server, MySQL, PostgreSQL, or SQLite data sources, the next screen of the report wizard allows you to configure the actual connection. The following sections describe the connection settings for each database.

Fixed and Dynamic Settings

Connection settings can either be fixed or dynamic:

  • Fixed Settings: These are hard-coded values that remain constant and can only be modified at design-time.
  • Dynamic Settings: These allow you to supply values programmatically or interactively, giving more flexibility during runtime or when different users view the report.

To make a setting dynamic, click the Parameter... link near the setting name:

Configure Database Data Source Connection

This will open the Parameters dialog:

Configure Parameter for Database Data Source Connection

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following properties can be configured:

  • Name: The parameter name used as a reference in the connection settings. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the connection.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Advantages of Dynamic Settings

Dynamic settings offer flexibility, especially in environments where connection details might change or where different users require different settings. For example, in multi-user applications, parameters can adapt to the current user's credentials or preferences, ensuring the correct data is accessed.

Using Connection String from the Configuration

When you invoke the Report Wizard in Visual Studio to add a new report to an existing project, you have the option to select a pre-configured connection string from the app.config or web.config file. This is particularly useful because it allows the ActiveReports.NET engine to read and use the specified connection string directly from the configuration file when the report runs.

Selecting a Pre-configured Connection String

In the Report Wizard, after selecting your data source (e.g., MS SQL Server), you'll see an option to use a connection string from the configuration file.

Select Connection String from Config File

The UI will present a dropdown list of available connection strings saved in your app.config or web.config file.

The ActiveReports.NET engine will use the selected connection string when the report is executed, ensuring that the connection is made using the details stored in the configuration file.

Manual Configuration Option

If you prefer not to use a pre-configured connection string, you can choose to manually specify the connection string and configure the settings by hand, as described below.

Note on Standalone Report Designer

If you are working with the Standalone Report Designer application, please note that the option to select the connection string from the configuration file is not available.

Configuring MS SQL Server Connection

Configure MS SQL Server Connection

General Settings

  • Server Name: Enter the hostname, the IP Address, or the instance name of the SQL Server instance (e.g., ServerName\InstanceName for named instances). You can make the server name dynamic by using a parameter, as described above.
  • Database: Specify the name of the database. This can also be set dynamically using parameters.

Authentication Settings

  • SQL Server Authentication: If this option is selected, provide the User name and Password for SQL Server login credentials. These can be set as dynamic parameters.
  • Windows Authentication: This option uses the credentials of the currently logged-in Windows user.

Advanced Settings

Click the Advanced... button to configure additional options such as connection timeout, network protocol, etc. All advanced settings can also be made dynamic using parameters.

Configure Advanced Settings for MS SQL Server Connection

Test Connection

After entering the necessary details, click the Test Connection button to verify that the connection to the SQL Server is successful.

Once the connection is confirmed, click Next > to proceed to the Configure MS SQL Server Queries step of the report wizard.

Configuring MySQL Server Connection

Configure MySQL Server Connection

General Settings

  • Server Name: Enter the hostname or IP address of the MySQL server. This can be a static value or made dynamic by using a parameter, as described in the Fixed and Dynamic Settings section above.
  • Database: Specify the name of the database you wish to connect to. This setting can also be dynamic using parameters.
  • Port: The default port for MySQL is 3306. Ensure this is correct or modify it if your MySQL server is configured to use a different port. You can also make the port number dynamic by using a parameter.

Authentication Settings

  • User Name: Enter the MySQL username. You can choose to make this dynamic by using a parameter.
  • Password: Enter the corresponding password for the MySQL user. This can also be set as a dynamic parameter.

Advanced Settings

Click the Advanced... button to configure additional options such as SSL settings or connection timeout. Just like with the other settings, all advanced options can be made dynamic by using parameters.

Configure Advanced Settings for MySQL Server Connection

Test Connection

After filling in the necessary details, click the Test Connection button to ensure that the connection to the MySQL server is successful.

Once you've confirmed that the connection is working, click Next > to proceed to the Configure MySQL Server Queries step of the report wizard.

Configuring PostgreSQL Server Connection

Configure PostgreSQL Server Connection

General Settings

  • Server Name: Enter the hostname or IP address of the PostgreSQL server. This value can be static or made dynamic using a parameter, as described in the Fixed and Dynamic Settings section above.
  • Database: Specify the name of the database you wish to connect to. You can either enter a static value or make it dynamic by using a parameter.
  • Port: The default port for PostgreSQL is 5432. Ensure this is correct or modify it if your PostgreSQL server is configured to use a different port. You can also make the port number dynamic by using a parameter.

Authentication Settings

  • User Name: Enter the PostgreSQL username. This can be set dynamically by using a parameter if needed.
  • Password: Enter the password associated with the PostgreSQL user. This can also be configured as a dynamic parameter.

Advanced Settings

Click the Advanced... button to configure additional options such as SSL settings, connection timeout, or other advanced PostgreSQL-specific options. These settings can also be made dynamic by using parameters.

Configure Advanced Settings for PostgreSQL Server Connection

Test Connection

After filling in the necessary details, click the Test Connection button to ensure that the connection to the PostgreSQL server is successful.

Once you've confirmed that the connection is working, click Next > to proceed to the Configure Postgres Server Queries step of the report wizard.

Configuring SQLite Connection

Configure SQLite Connection

General Settings

  • Database Path: Enter the path to the SQLite database file. You can either type the path directly, use the Browse... button to locate the file, or make the path dynamic by using a parameter, as described in the Fixed and Dynamic Settings section above.

Advanced Settings

Click the Advanced... button to configure additional options such as connection timeout, cache size, or other SQLite-specific settings. These settings can also be made dynamic by using parameters.

Configure Advanced Settings for SQLite Connection

Test Connection

After entering the necessary details, click the Test Connection button to ensure that the connection to the SQLite database file is successful.

Once you've confirmed that the connection is working, click Next > to proceed to the Configure SQLite Queries step of the report wizard.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring File Data Source

Configuring File Data Source
Report Authors > Report Wizard > Configuring Data Source > Configuring File Data Source

Glossary Item Box

If you selected one of the JSON, XML, CSV, or Excel File data sources, the next screen of the report wizard allows you to configure the actual connection. The following sections describe the connection settings for each file type.

Fixed and Dynamic Settings

Connection settings can either be fixed or dynamic:

  • Fixed Settings: These are hard-coded values that remain constant and can only be modified at design-time.
  • Dynamic Settings: These allow you to supply values programmatically or interactively, giving more flexibility during runtime or when different users view the report.

To make a setting dynamic, click the Parameter... link near the setting name:

General section of Configure JSON File Connection

This will open the Parameters dialog:

Configure JSON File Connection Parameter

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following properties can be configured:

  • Name: The parameter name used as a reference in the connection settings. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the connection.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Advantages of Dynamic Settings

Dynamic settings offer flexibility, especially in environments where connection details might change or where different users require different settings. For example, you might want to use different files depending on the current logged-in user in your application.

Configuring JSON File Connection

Configure JSON File Connection

General Settings

  • File Path: Enter the path to the JSON file that contains the data you want to connect to. You can either type the path directly, use the Browse... button to locate the file, or make the path dynamic by using a parameter, as described in the Fixed and Dynamic Settings section above.

Proceeding to Next Steps

Once you have the file path configured, click Next > to proceed to the Configuring JSON Queries step of the report wizard.

Configuring XML File Connection

Configure XML File Connection

  • File Path: Enter the path to the XML file that contains the data you want to connect to. You can either type the path directly, use the Browse... button to locate the file, or make the path dynamic by using a parameter, as described in the Fixed and Dynamic Settings section above.

Transformation Settings

  • XSLT File Path: If your XML data requires transformation, specify the path to the XSLT file here. As with the file path, you can enter this directly, use the Browse... button, or make it dynamic by using a parameter.

Proceeding to Next Steps

Once you have the settings configured, click Next > to proceed to the Configuring XML Queries step of the report wizard.

Configuring CSV File Connection

Configure CSV File Connection

General Settings

  • File Path: Enter the path to the CSV file that contains the data you want to connect to. You can either type the path directly, use the Browse... button to locate the file, or make the path dynamic by using a parameter, as described in the fixed and dynamic settings section.
  • File Type:
  • Delimited: Select this option if your CSV file uses delimiters (such as commas, tabs, or other characters) to separate fields.
  • Fixed: Choose this option if the fields in your file have a fixed width.
  • File Encoding: Select the character encoding used in the CSV file. Common encodings include Unicode (UTF-8) and ANSI. Ensure you select the correct encoding to avoid issues with reading the file.
  • File Locale: Specify the locale that is used in the CSV file, which determines how numbers, dates, and other locale-specific data are interpreted.

Data Settings

  • Data Starts at Row: Enter the row number where the data begins in the file. This is useful if there are header rows or other non-data rows at the beginning of the file.
  • Use Starting Row as Column Headers: Check this box if the first row of your data contains the column headers. This will automatically treat the first row as the header in your report.

Delimiters

  • Column Delimiter: Select the character that is used to separate columns in the CSV file (Comma, Tab, Semicolon, Space).
  • Row Delimiter: Select the character sequence that is used to separate rows in the CSV file (Carriage Return + Line Feed (CRLF), Line Feed (LF), Carriage Return (CR)).
  • Text Qualifier: Choose the character that encloses text fields in the CSV file. This is typically a Single quotes or Quotes, and it is used to ensure that text fields that contain delimiters themselves are parsed correctly.
  • Merge Consecutive Delimiters:
  • Column Delimiters: Check this box to merge consecutive column delimiters in the file, which is useful if there are empty fields.
  • Row Delimiters: Check this box to merge consecutive row delimiters in the file, which is helpful if there are empty rows or if rows are split across multiple lines.

Proceeding to Next Steps

Once you have configured all the settings, click Next > to proceed to the Configure CSV Data Fields step of the report wizard.

Configuring Excel File Connection

Configure Excel File Connection

General Settings

  • File Path: Enter the path to the Excel file that contains the data you want to connect to. You can either type the path directly, use the Browse... button to locate the file, or make the path dynamic by using a parameter, as described in the Fixed and Dynamic Settings section above.

Proceeding to Next Steps

Once you have the file path configured, click Next > to proceed to the Configure Excel Workbook Queries step of the report wizard.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Web API Data Source

Configuring Web API Data Source
Report Authors > Report Wizard > Configuring Data Source > Configuring Web API Data Source

Glossary Item Box

If you selected the JSON API data source in the Web API section, the next screen of the report wizard allows you to connect your report to data provided by a web service via an HTTP request. This type of data source is particularly useful when working with RESTful APIs or other web-based services. The following sections describe the connection settings in detail.

Fixed and Dynamic Settings

Connection settings can either be fixed or dynamic:

  • Fixed Settings: These are hard-coded values that remain constant and can only be modified at design-time.
  • Dynamic Settings: These allow you to supply values programmatically or interactively, giving more flexibility during runtime or when different users view the report.

To make a setting dynamic, click the Parameter... or Insert parameter... link near the setting name:

General Section in Configure Web API Request

This will open the Parameters dialog:

Add Parameter for Web API Request

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following properties can be configured:

  • Name: The parameter name used as a reference in the connection settings. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the connection.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

When you can click the OK button and the reference to the selected parameter will be inserted in the connection setting, for example, the URL will be set to {url}.

Advantages of Dynamic Settings

Dynamic settings offer flexibility, especially in environments where connection details might change or where different users require different settings. For example, you might want to use different URLs depending on the current environment.

Configuring JSON API Connection

Configure Web API Request screen

General Settings

  • URL: Enter the full URL of the Web API endpoint that will provide the data for your report. You can make the entire URL, or part of it, dynamic by using the Insert parameter... link as described above.

HTTP Method

Select the HTTP method to be used for the API request. The available options are:

  • GET: This method is used to retrieve data from the API. It is the default and most commonly used method for data sources.
  • POST: This method is used to send data to the server, along with the request. When this option is selected, the POST Body field becomes available.
  • POST Body: If the POST method is selected, this field is used to specify the content of the HTTP request body. You can make the entire POST Body, or part of it, dynamic by using the Insert parameter... link as described above.

HTTP Headers:

Click on the HTTP Headers... button to add custom headers to the API request. This might include headers for authentication (e.g., Bearer tokens), content type (e.g., application/json), or other necessary metadata required by the API. You can make the header value dynamic by using the Parameter link as described above.

Add Custom HTTP Headers to Web API Request

Test the API Request

Before finalizing the configuration, it's important to test the API request to ensure it is functioning as expected. Click the Test Request button and check the message in the popup dialog. If the request was configured correctly, the message will look like this:

Success Message to Adding Custom Headers to Web API Request

If the request was not configured properly, the error message will be displayed, and you can click the Details >> button for more information:

Error Message to Adding Custom Headers to Web API Request

Proceeding to Next Steps

Once you have configured the connection, click Next > to proceed to the Configure JSON Queries step of the report wizard.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Programmatic Data Source

Configuring Programmatic Data Source
Report Authors > Report Wizard > Configuring Data Source > Configuring Programmatic Data Source

Glossary Item Box

If you invoke the Report Wizard in Visual Studio.NET by adding a new ActiveReports Standalone Report into your project, then the Choose Data Source type screen includes the Programmatic section with the Object data source item. Using the data source type allows you to supply data from your application's code. It lets you bind data from custom objects or collections defined in your code.

Choose Data Source Type screen

If you select the Object data source type and click Next >, the following screen allows you to choose the assembly that contains the classes that represent the data for your report.

Choose Assemblies Containing Data Classes

The list of assemblies includes the application's assembly and all referenced assemblies, except of system and other standard assemblies. The project should be compiled to obtain those referenced assemblies.

Once you select the assembly containing the data classes, click Next > button to proceed with the Configuring Programmatic Queries step.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Data Queries

Configuring Data Queries
Report Authors > Report Wizard > Configuring Data Queries

Glossary Item Box

Once you have configured a valid Data Source, the next step is to specify a query for that data source. The query configuration process varies depending on the type of data source. You can find detailed instructions for each data source type in the following articles:

  • Configuring Database Queries
  • Configuring File Queries
  • Configuring Web API Queries
  • Configuring Programmatic Queries

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Database Queries

Configuring Database Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring Database Queries

Glossary Item Box

General

Once you have configured a valid Database data source, the next screen allows you to add one or more queries to the database.

Configure Queries screen

Adding and Removing Queries

You can add and remove Queries by using the Add and Remove buttons below the list on the left side of the screen. At least one query is required to proceed to the next step.

Configuring Queries

Each query has a Name property, which serves as a unique identifier. By default, the first query is named DataSet1, but you can customize this by changing the name in the Name field at the top of the panel.

In the main section, you can choose the query type Text or Stored Procedure and enter the query.

Dynamic queries

Queries can be made dynamic by using parameters—these are values that can be provided programmatically by your application or interactively by the report user. To insert a parameter into a path expression, click the Insert parameter... link below the Query text area. The Parameters dialog will appear:

Select an Existing Parameter or Add a New One

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following parameter properties can be configured:

  • Name: The parameter name used as a reference in query. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the query.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Once you click the OK button, the reference to the selected parameter will be inserted into the query. For example, it will be updated to Select * from Customers where Country=@country, which filters the data by country using a dynamic value.

Validating Queries

You can click the Validate button to ensure that the query is valid. The popup dialog will either display the Query was successfully executed message or show the error dialog where you can check the error details by clicking the Details >> button:

Query Validation Error

Next steps

Once you have configured and validated one or more queries, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring File Queries

Configuring File Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring File Queries

Glossary Item Box

Once you have configured a valid File Data Source, the next step is to specify a query for the file. The query configuration varies depending on the file type. You can find detailed instructions for each file type in the following articles:

  • Configuring CSV File Queries
  • Configuring JSON File Queries
  • Configuring XML File Queries
  • Configuring Excel File Queries

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring CSV File Queries

Configuring CSV File Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring File Queries > Configuring CSV File Queries

Glossary Item Box

General

Once you have configured a valid CSV File data source, the Configure CSV Data Fields screen allows you to preview the result of data reading and fine-tune the data types for the fields to be visualized in a report.

Configure CSV Data Fields

Fields Configuration

In the top section of the screen, the Fields grid lists all the columns detected from the CSV file. Each row represents a field, with two editable properties:

  • Name: The default name is taken from the first row of the CSV file if Use Starting Row as Column Headers is enabled. You can modify the field name to better fit your report structure.
  • Type: By default, the system sets each field's type to String. However, you can change the type to suit the data by selecting from data types such as Boolean, DateTime, Integer, Float, Decimal, Double, and Long types using the drop-down menu. Ensuring correct data types is crucial for accurate sorting, filtering, and calculations in the report.

Data Preview

In the Preview section below the fields, you can see a sample of the data extracted from the CSV file, displayed in tabular format. This allows you to verify the field names, data types, and actual data values to ensure that everything is read correctly.

For example, in the screenshot above, the SalesQuantity field shows numerical values like 8, 4, and 9, which should ideally be typed as Integer for proper aggregation and formatting in the report.

If the data type for a field was not set properly, the values in the Preview of the corresponding column will show the Error string.

Next Steps

After reviewing and configuring the fields, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring JSON File Queries

Configuring JSON File Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring File Queries > Configuring JSON File Queries

Glossary Item Box

General

Once you have configured a valid JSON File data source, the Configure JSON Queries screen allows you to add one or more queries to the JSON data contained in the file.

Configure JSON Queries

Adding and Removing Queries

You can add and remove Queries by using the Add and Remove buttons below the list on the left side of the screen. At least one query is required to complete proceed to the next steps.

Configuring Queries

Each query has the Name property that is the unique ID of the query and the Path property that is a JSON Path expression that is used to select the repeating nodes from the JSON data to visualize them in a report.

You can set the Path in the JSON data tree by clicking the corresponding node or you can enter the Path manually in the Query textbox. Here are several examples of JSON Path Expressions.

  • If the JSON data is an array, and you want to select all nodes from that array, you can use the expression $.[*], as shown in the screenshot above.
  • If you want to select data from a specific property within an object, such as selecting a customer's orders, you can use an expression like $.orders[*].
  • If you want to filter the data by a specific field, you can use an expression like $.[?(@.country == 'USA')].

For more examples, you can check the original JSON Path specification.

Dynamic queries

You could also make a query dynamic by using parameters in the path expression. Parameters are dynamic values that are either supplied programmatically via your application's code or provided by the report reader through user input. To insert a parameter into a path expression, click the Insert parameter... link below the Query textbox. The Parameters dialog will appear:

Configure JSON Queries Parameters

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following parameter properties can be configured:

  • Name: The parameter name used as a reference in query. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the query.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Once you click the OK button, the reference to the selected parameter will be inserted into the path expression. For example, it will be updated to $.[?(@.country == {country})], which filters the data by country using a dynamic value.

Next steps

Once you have configured one or more queries, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring XML File Queries

Configuring XML File Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring File Queries > Configuring XML File Queries

Glossary Item Box

General

Once you have configured a valid XML File data source, the Configure XML Queries screen allows you to add one or more queries to the XML data contained in the file.

Configure XML Queries

Adding and Removing Queries

You can add and remove Queries by using the Add and Remove buttons below the list on the left side of the screen. At least one query is required to complete proceed to the next steps.

Configuring Queries

Each query has the Name property that is the unique ID of the query and the Path property that is a XPath expression that is used to select the repeating nodes from the XML data to visualize them in a report.

You can set the XPath in the XML data tree by clicking the corresponding node, or you can enter the XPath expression manually in the Query textbox. Here are several examples of XPath Expressions.

  • To select all child nodes of the root element, you can use the expression /*/*, which will select all elements at the second level of the XML document.
  • To select data from a specific element, such as selecting all <Order> elements under <Customer>, you can use an expression like /Customers/Customer/Orders/Order.
  • To filter data by a specific attribute, such as selecting only orders with a status of Completed, you can use an expression like /Customers/Customer/Orders/Order[@status='Completed'].
  • To select elements containing specific text, such as selecting customers in the USA, you can use an expression like /Customers/Customer[address/country='USA'].

For more details on XPath syntax, you can refer to the official XPath specification.

Dynamic queries

You could also make a query dynamic by using parameters in the path expression. Parameters are dynamic values that are either supplied programmatically via your application's code or provided by the report reader through user input. To insert a parameter into an XPath expression, click the Insert parameter... link below the Query textbox. The Parameters dialog will appear:

Configure Parameters for XML Query

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following parameter properties can be configured:

  • Name: The parameter name used as a reference in query. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the query.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Once you click the OK button, the reference to the selected parameter will be inserted into the path expression. For example, it will be updated to /Customers/Customer[address/country={country}], which filters the data by country using a dynamic value.

Next steps

Once you have configured one or more queries, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Excel File Queries

Configuring Excel File Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring File Queries > Configuring Excel File Queries

Glossary Item Box

General

Once you have configured a valid Excel File data source, the Configure Excel Workbook Queries screen allows you to add one or more queries to the data contained in the file.

Configure Excel Workbook Queries

Adding and Removing Queries

You can add and remove Queries by using the Add and Remove buttons below the list on the left side of the screen. At least one query is required to proceed to the next step.

Configuring Queries

Each query has a Name property, which serves as a unique identifier. By default, the first query is named DataSet1, but you can customize this by changing the name in the Name field at the top of the panel.

In the main section, you can choose to retrieve data based on:

  • Sheet: Select a sheet from the Excel workbook. For instance, in the screenshot above, NwindProducts, ContosoSales200Rows, and ContosoSalesOverview are available sheets from the Excel Workbook.
  • Table: Alternatively, you can select a table if there are any in the workbook.
  • Named Range: Choose a named range if the workbook contains any.

For each query, there are several options you can use to refine how the data is read:

  • Read field names from first row: This option allows ActiveReports to use the values from the first row of the sheet as field names.
  • Skip empty rows: Enabling this option skips any rows in the worksheet that do not contain data.
  • Skip hidden rows: This option prevents hidden rows in the sheet from being read into the query.
  • Skip hidden columns: When this is checked, any hidden columns in the sheet will not be included in the dataset.

These options give you the flexibility to filter the data as required before it is loaded into the report.

Next steps

After configuring your queries, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Web API Queries

Configuring Web API Queries
Report Authors > Report Wizard > Configuring Data Queries > Configuring Web API Queries

Glossary Item Box

General

Once you have configured a valid JSON Web API data source, the Configure JSON Queries screen allows you to add one or more queries to the JSON data retrieved by the data source.

Configure JSON Queries

Adding and Removing Queries

You can add and remove Queries by using the Add and Remove buttons below the list on the left side of the screen. At least one query is required to complete proceed to the next steps.

Configuring Queries

Each query has the Name property that is the unique ID of the query and the Path property that is a JSON Path expression that is used to select the repeating nodes from the JSON data to visualize them in a report.

You can set the Path in the JSON data tree by clicking the corresponding node or you can enter the Path manually in the Query textbox. Here are several examples of JSON Path Expressions.

  • If the JSON data is an array, and you want to select all nodes from that array, you can use the expression $.[*], as shown in the screenshot above.
  • If you want to select data from a specific property within an object, such as selecting a customer's orders, you can use an expression like $.orders[*].
  • If you want to filter the data by a specific field, you can use an expression like $.[?(@.country == 'USA')].
  • For more examples, you can check the original JSON Path specification.

Dynamic queries

You could also make a query dynamic by using parameters in the path expression. Parameters are dynamic values that are either supplied programmatically via your application's code or provided by the report reader through user input. To insert a parameter into a path expression, click the Insert parameter... link below the Query textbox. The Parameters dialog will appear:

Configure Dynamic Queries

Here, you can re-use an existing parameter or create a new one by clicking the Add button. The following parameter properties can be configured:

  • Name: The parameter name used as a reference in query. You’ll need this name to supply its value via code if you choose to do so.
  • Type: The data type of the parameter. You can select from Boolean, DateTime, Integer, Float, and String.
  • Testing Value: The value used at design-time to test the query.
  • Input Source: Choose Programmatic to supply the parameter values via your application code, or Interactive to allow report readers to provide the parameter values.

Once you click the OK button, the reference to the selected parameter will be inserted into the path expression. For example, it will be updated to $.[?(@.country == {country})], which filters the data by country using a dynamic value.

Next steps

Once you have configured one or more queries, click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Programmatic Queries

Programmatic Queries
Report Authors > Report Wizard > Configuring Data Queries > Programmatic Queries

Glossary Item Box

Once you selected the assembly containing the data classes, the Choose Data Classes To Use will display the list of public classes from this assembly. You can choose one or more item from this list:

Configure Programmatic Query - Choose Data Classes to Use

Click Finish >> to create a report with data binding configured, or click Next > to add a data display control.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Report Controls

Configuring Report Controls
Report Authors > Report Wizard > Configuring Report Controls

Glossary Item Box

Once you have configured a valid Data Query, the next optional step is to add a data display control to the report.

Select Data Display Control of Report Wizard

The data display configuration varies depending on the type of data display control. You can find detailed instructions for each type in the following articles:

  • Configuring Table
  • Configuring Tablix
  • Configuring Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Table

Configuring Table
See Also
Report Authors > Report Wizard > Configuring Report Controls > Configuring Table

Glossary Item Box

General

A Table is a data display control that visualizes your data in a structured, multicolumn, multirow format. Below is an example of how a table that displays Taxi Drives data appears in the report output:

Table Sample with Grouping

The report wizard guides you through the process of configuring a table with a series of intuitive steps, as described below.

Choosing Table Query and Field

Choosing Table Query and Field in the Table Wizard

In the Query drop-down, you can select one of the report's available data queries. For detailed information on setting up queries, see the Configuring Data Queries in Report Wizard and Configuring Data Set Properties documentation pages.

The Fields list displays all the fields retrieved by the selected query. To display all these fields in the table, click the (select all) checkbox. Alternatively, you can select only a subset of fields that should be displayed in the table, as shown in the screenshot above. Click Next > to proceed to the next step.

Configuring Table Groupings

Configure Table Groupings in the Table Wizard

The Configure Table Groupings step allows you to organize your data into groups, making it easier to analyze and display. Groupings are especially useful when you want to categorize your data by specific fields, such as taxi drive category, as shown in the screenshot.

General Settings

In the Layout section, you can choose how the groups are organized:

  • Rows: This option generates rows for group headers and footers of each group instance. It allows to conditionally include or exclude group header and footer and repeat them on each page. The following screenshot shows a table with taxi drives data grouped by the drive category, displaying the category name in the group header and the summary values in the group footer:
    Rows Setting in Table Groupings
  • Columns: This option generates a column group header for each group instance. With this type of the layout, the column acts as a group header, but the group footer is still a row that could display the summary values.
    Columns Setting in Table Groupings

Group Settings

This section provides settings for configuring the groupings.

  • Group By: Select the field by which you want to group your data. In the example, the data is grouped by the Category field.
  • Sorting: Choose how the group instances should be sorted. The default option is Ascending, but you can also choose Descending depending on how you want to display the groupings.
  • Include Group Header: Checking this option will include a header for each group instance, indicating which data belongs to which group.
  • Repeat Group Header on Each Page: If your group instances span multiple pages, enabling this will repeat the group header at the top of each new page. This is helpful for reports where the group context is important.
  • Include Group Footer: If enabled, this will add a footer at the end of each group instance, which is useful for totals or summaries.
  • Repeat Group Footer on Each Page: Similar to the group header, this will repeat the footer for the group instance on every page where the instance is displayed.
  • Start Each Group Instance on a New Page: This ensures that each new group instance begins on a new page, making the report cleaner and more organized.
  • Expand/Collapse Group Instances: If checked, the report viewer will display a toggle to expand or collapse each group instance, giving report readers more control over how much data is visible at once.

Once you have configured your group settings, click Next > to proceed to the next step.

Configuring Table Columns

Configure Table Columns in Table Wizard

The Configure Table Columns configuration step allows you to customize the columns that will be displayed in your table. The list on the left side shows the fields that were selected on the initial Choose Table Query and Fields screen. However, fields that were selected for groupings in the previous step will be excluded from this list.

Each field in this list will be represented as a column in the table. You can modify various properties for each column, as explained below.

Rearranging Columns

You can change the order in which the columns appear in the table by selecting a field and using the Up (↑) and Down (↓) buttons on the right side of the list. This allows you to rearrange the order of columns according to your reporting needs.

Modifying Column Properties

When a field is selected, its properties can be adjusted in the section on the right.

  • Header Text: This is the text that will be displayed at the top of the column. You can modify it to make it more descriptive or suitable for the report. In the example, the StartDate field has its header text as "Start Date."
  • Alignment: Use the Alignment dropdown to control how the content in this column will be aligned within the table. Options include:
    • Left: Align the content to the left.
    • Center: Center the content.
    • Right: Align the content to the right.
  • Format: The Format option lets you choose how the data in the column will be displayed. This is especially useful for formatting dates, numbers, or currency.
  • Sorting: You can choose to apply sorting to the column’s data. Available options are:
    • None: No sorting will be applied.
    • Ascending: Data will be sorted in ascending order (e.g., A-Z or 1-10).
    • Descending: Data will be sorted in descending order (e.g., Z-A or 10-1).
  • Summaries: You can apply summary functions to the data in this column. Available summary types include:
    • Sum: Adds up all the values.
    • Count: Counts the number of records.
    • Min: Finds the minimum value.
    • Max: Finds the maximum value.
    • Average: Calculates the average value.

Summary values will be displayed in the group footer(s), if they were configured, and also in the table footer.

Once you've made the necessary modifications, click Next > to proceed to the next configuration step.

Configuring Table Colors

Configure Table Colors in Table Wizard

In the final step of the Table Wizard, you can apply a color theme and style to your table to make it visually appealing and ensure consistency in the design. The preview pane on the right allows you to see how your table will look with the selected theme and style before finalizing the configuration.

Theme

The Theme dropdown allows you to select from a variety of pre-defined themes that determine the base color palette for the table. For instance, the screenshot shows the Active theme selected, which applies a specific set of colors to different table elements, such as headers, footers, and data rows.

Style

The Style dropdown provides additional customization within the selected theme by offering various styles to apply. These styles can subtly change how colors are used in the table. In the screenshot, the Light Style 1 Accent 1 is selected, which applies different shades of blue to the headers and footers, giving the table a clean and professional appearance.

Preview

On the right side, the Preview section shows how your selections will look when applied to the table. The preview displays how different table elements—like the header, group headers, group footers, details, and the table footer—will be styled. Each group header and footer is visually distinct, using alternating colors to improve readability.

Once you’ve chosen the desired theme and style, click Finish >> to apply the settings and generate the table in your report.

See Also

Table

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Tablix

Configuring Tablix
See Also
Report Authors > Report Wizard > Configuring Report Controls > Configuring Tablix

Glossary Item Box

General

A Pivot Table, also known as a Tablix, is a data display control that organizes and summarizes your data records into groups. It arranges these groups’ unique values in two directions: horizontal (Column Groups) and vertical (Row Groups). At the intersection of a Row and Column Group, one or more summary values are displayed, providing a clear and concise representation of the data.

Below is an example of a pivot table displaying sales data in a report output:

Tablix Sample with Sales Data

The report wizard guides you through the process of configuring a pivot table with a series of intuitive steps, as described below.

Choosing Tablix Query and Field

Choose Tablix Query and Fields in Tablix Wizard

In the Query drop-down, you can select one of the report's available data queries. For detailed information on setting up queries, see the Configuring Data Queries in Report Wizard and Configuring Data Set Properties documentation pages.

The Fields list displays all the fields retrieved by the selected query. To display all these fields in the tablix, click the (select all) checkbox. Alternatively, you can select only a subset of fields to be displayed in the Tablix, as shown in the screenshot above. Click Next > to proceed to the next step.

Configuring Tablix Row Groupings

Configure Tablix Row Groupings in Tablix Wizard

The Confgure Tablix Row Groupings step helps you configure the row groupings for your Tablix. Grouping allows you to organize your data into meaningful sections based on the selected field. The settings in this dialog allow you to control how rows are grouped and displayed.

General Settings

Arrange Rows Hierarchically: If this option is checked, rows will be arranged in a hierarchical structure. This option is only applicable when there are multiple row groupings.

Row Group Settings

  • Group By: Choose the field you want to group your rows by. In this example, the ProductCategoryName field has been selected for grouping.
  • Sorting: Select a field and sort order to define how the grouped rows should be sorted.
  • Layout:
    • Include Total Rows: This option is checked by default. It includes a total row for each group, summarizing the data within that group.
    • Display Total Rows First: If checked, the total row will appear at the top of each group rather than the bottom.
    • Start Each Group Instance on a New Page: This option, when checked, ensures that each group starts on a new page in the report.
    • Expand/Collapse Group Instances: Enabling this option adds expand/collapse functionality to the group instances, making the report more interactive. This option is only applicable when there are multiple row groupings.

You can add more groups by clicking the Add button, or remove existing groups by selecting them and clicking Remove. You can also adjust the order of the groups using the up and down arrows to the right of the group list.

Click Next > to proceed to the next configuration step.

Configuring Tablix Column Groupings

Configure Tablix Column Groupings In Tablix Wizard

The Configure Tablix Column Groupings step allows you to configure the column groupings for your Tablix. The settings in this dialog allow you to control how columns are grouped and displayed.

Column Group Settings

  • Group By: Select the field by which you want to group the columns. In this example, the CalendarYear field has been selected for grouping.
  • Sorting: Define how the grouped columns should be sorted. No sorting has been applied in this example.
  • Layout:
    • Include Total Rows: This option is checked by default. It includes a total row for each group, summarizing the data across the grouped columns.
    • Display Total Rows First: If checked, the total row will be displayed before the data rows within each group.
    • Start Each Group Instance on a New Page: When this option is checked, each group starts on a new page, ensuring that data is separated visually in the report.
    • Expand/Collapse Group Instances: This option allows users to expand or collapse the grouped column instances, making the report more interactive. This option is only applicable when there are multiple column groupings.

You can add more column groups by clicking the Add button, or remove existing groups by selecting them and clicking Remove. You can also adjust the order of the groups using the up and down arrows to the right of the group list.

Click Next > to proceed to the next step.

Configuring Tablix Values

See Also

Tablix

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuring Chart

Configuring Chart
See Also
Report Authors > Report Wizard > Configuring Report Controls > Configuring Chart

Glossary Item Box

General

A Chart is a data visualization control that represents your data using graphical shapes, allowing the report reader to better understand trends, compare different groups, or assess parts of a whole. Charts are helpful in analyzing data patterns over time, comparing categories, and identifying relationships between variables. Below is an example of a donut chart that illustrates sales contribution per product category:

The report wizard simplifies the process of setting up a chart by guiding you through a series of intuitive steps, which are described below.

Choosing Chart Query and Plot Type

Choose Chart Query and Plot Type

In the Query drop-down, you can select one of the report's available data queries. For detailed information on setting up queries, see the Configuring Data Queries in Report Wizard documentation pages.

Below the query selection, you'll find the list of supported chart types organized into categories. These chart types are grouped to assist you in selecting the most appropriate visualization for your data. To learn more about the available chart types, refer to the Chart Plots article.

Configuring Chart Data Values

Configure Chart Data Values

In this step, you can configure the data values that will be visualized as graphical shapes in your chart. Each data point represents a value or summary (e.g., a sum or average) that corresponds to a part of the data displayed in the chart.

  • Field: This drop-down allows you to select the specific field from your data query that you want to visualize. In this example, the SalesAmount field has been selected.
  • Aggregate: Choose how the data should be aggregated. The wizard supports multiple aggregation functions, including Sum, Average, Count, Max, Min, and more. The selected function will be applied to the chosen field, summarizing the data based on the specified aggregate function and grouping that can be configured on the next steps.
  • Caption: The caption provides a label for the data series in the chart. This label is especially useful when your chart displays multiple values, and you want to display a legend to distinguish between them.

For charts that only require a single value (like a pie or donut chart), one data field is sufficient. However, some chart types (such as range charts) may require multiple data values. For more details on handling multiple data values and advanced configurations, refer to the Chart documentation pages.

For charts that only require a single value (like a pie or donut chart), one data field is sufficient. However, some chart types (such as range charts) may require multiple data values. For more details on handling multiple data values and advanced configurations, refer to the Chart documentation pages.

You can use the Add and Remove buttons to adjust the data fields shown in the chart. The up and down arrow buttons allow you to reorder the fields if your chart supports multiple values.

Click Next to proceed to the next step in the wizard.

Configure Chart Data Groupings

In the third screen of the Chart Wizard, configure the data groupings.

Choose ActiveReports Chart Query and Plot

Categories

Group By

Specify the field to group the data into categories that exist for each unique value (or numerical range) for the specified field. The title of the axis is set to the corresponding category field name.

Sorting

Choose the data sorting direction from None, Ascending, or Descending.

Series

Group By

To group the data into series.

Sorting

Choose the data sorting direction from None, Ascending, or Descending. The sorting field is automatically set to the subcategory field.

Layout Type

Select the way you want the series groups to arrange from Cluster and Stack. The Layout type option is available for the supported chart types only, which are Column, Bar, Area, Spiral, Polar, and Range charts.

Click Next> to proceed to the next step in the wizard.

Choose Report Colors

In the final step of the Chart Wizard, you can apply a color theme and style to your chart to make it visually appealing and ensure consistency in the design. The preview pane on the right allows you to see how your chart will look with the selected theme and style before finalizing the configuration.

Theme

The Theme dropdown allows you to select from a variety of pre-defined themes that determine the base color palette for the chart. For instance, the screenshot shows the Reels theme selected, which applies a specific set of colors to different chart elements, such as headers, footers, and data rows.

Style

The Style dropdown provides additional customization within the selected theme by offering various styles to apply. These styles can subtly change how colors are used in the chart. In the screenshot, the Light Style 1 Accent 1 is selected, which applies different shades of blue to the headers and footers, giving the chart a clean and professional appearance.

Preview

On the right side, the Preview section shows how your selections will look when applied to the chart. The preview displays how different chart elements—like the header, group headers, group footers, details, and the chart footer—will be styled. Each group header and footer is visually distinct, using alternating colors to improve readability.

Once you’ve chosen the desired theme and style, click Finish to apply the settings and generate the chart in your report.

See Also

Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Binding

Data Binding
Report Authors > Data Binding

Glossary Item Box

This section discusses the data binding using the ActiveReports Designer.

Data Binding in ActiveReports

The data binding is explained in the following sections separately for Page/RDL and Section reports.

  • Data Binding in Page/RDLX Reports
  • Data Binding in Section Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Binding in Page/RDLX Reports

Data Binding in Page/RDLX Reports
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports

Glossary Item Box

The data binding process involves setting up the data connection and associating the data with the report.

On creating a new report, you see the New Report wizard, where you first select a report type (a Page report or an RDLX), and then select the data source type from where the data binding process starts. The data binding requires you to set up a connection to the data source by configuring the data source connection properties, and then set up queries to add a dataset to fetch the data you want to show in the report.

In an existing report where you want to bind the report to data, you should navigate to the Report Explorer, right-click the Data Sources node, and select the Add Data Source option, followed by right-clicking an existing data source and selecting Add Data Set.

This section discusses the data binding using the ActiveReports Designer. For information on run-time binding, please see Bind a Page/RDLX report to a Data Source at Run Time topic.

Supported Data Sources

The supported data sources for designing Page/RDLX reports are:

  • Microsoft SQL Server
  • MySQL
  • PostgreSQL
  • SQLite
  • JSON
  • XML
  • CSV
  • Excel
  • JSON API
  • Dataset Provider
  • Microsoft ODBC Provider
  • Microsoft OLEDB Provider

See Also

Query Builder in JSON and XML Providers
Query Builder in Microsoft SQL Client and OLEDB Providers

Developers
Bind a Page/RDLX Report to Data

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Connect to a Data Source

Connect to a Data Source
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source

Glossary Item Box

This topic discusses about connecting to a data source at design time through the Report Explorer in a Page report or an RDLX report. You can also connect to a shared data source if you want to use the same data source for many reports.

Checkout data binding while creating a new report using the wizard that guides you through the whole process in the topics that follow.

In ActiveReports Designer, you can setup the data source connection in the Report Data Source dialog. The Report Data Source dialog is where you select the type of data source to use, provide a connection string, and choose other options for your data source. You can also decide to use a shared data source, use a single transaction, and select a method for handling credentials. Once you add a data source, it appears in the Report Explorer under the Data Sources node. You can also add multiple data sources in a single report.

Add a data source

Use the following steps to add a new data source in your report.

  1. In the designer, go to the Report Explorer-
    • Right-click the Data Sources node and select the Add Data Source option.

      Add icon in the Report Explorer

      Or,

    • Click the Add button and then select the Data Source option.

      Add icon in the Report Explorer
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select the type of data source you want to use.
    • Microsoft SQL Client Provider
    • CSV
    • Dataset and Object Providers
    • Excel
    • JSON Provider
    • Microsoft ODBC Provider
    • Microsoft OLEDB Provider
    • MySQL Provider
    • PostgreSQL Provider
    • XML Provider
  4. Depending on the data source selected, different options/tabs are displayed to configure the connection.
    • For SQL or OleDb data sources, Connection Properties, Connection String, and Advanced Settings tabs appear.
    • For XML data source, the Connection Properties and Connection String tabs appear.
    • For JSON data source, the Content, Schema and Connection String tabs appear.
    • For other data source types, only the Connection String tab appears.
    Note: You can create dynamic connection strings by using the runtime variables, such as report parameters.
  5. Enter the configuration details for the chosen data source type. See Report Data Source dialog properties for more information.
  6. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to a data source.

Custom Data Providers

You can also implement some custom data providers such following, by manually setting up the dependencies and configuration file:

  • SQLite (see Configure ActiveReports)

    For information on writing an SQL query that you can use for SQLite, see the SQLite Tutorial. You will note that there are some differences in writing a standard SQL query and an SQL query for SQLite.

  • Oracle (see Oracle Data Provider sample)
  • OData (see OData Data Source sample)

Also, see the Custom Data Provider sample.

You can also create a shared data source if you want to use the same data source in different reports.

Edit a data source

These steps assume that you have already connected your report to a data source.

  1. To open the Report Data Source dialog, do one of the following:
    • In the Report Explorer, right-click a data source node and in the context menu that appears, select Edit or Edit Shared Data Source option.
    • In the Report Explorer toolbar, click the Edit button.
      Edit Shared Data Source button in Report Explorer toolbar
  2. In the Report Data Source dialog that appears, edit the data connection information.

Report Data Source dialog properties

The Report Data Source dialog provides the following pages where you can set data source properties.

GENERAL
CREDENTIALS

The General page of the Report Data Source dialog is where you can set the Name, Type, and Connection string of a new data source, or choose to use a shared data source reference.

  • Name: Enter a name for the data source. This name must be unique within the report. By default, the name is set to DataSource1.

  • Shared Reference: Select this check box to connect to a shared data source reference. See Add a Shared Data Source for further information. Once you have chosen the Shared Reference option, the Reference field to select a Shared Data Source becomes available. In the Reference field, select From File and select a shared data source file on your machine.

    If the Shared Reference checkbox is clear, you can select a data source type from the Type dropdown field.

  • Use Single Transaction: Check this option to execute the datasets using this data source in a single transaction.

  • Type: Choose the type of data source provider you want to use. The available options are Microsoft SQL Client Provider, Csv Provider, DataSet Provider, Object Provider, JSON Provider, Microsoft ODBC Provider, Microsoft OleDb Provider, and XML Provider.

    If you select SQL or OleDb as the data source Type value, the Connection Properties, Connection String and Advanced Settings pages appear under the Connection section. For XML data source, Connection Properties and Connection String pages appear. For JSON data source, Content, Schema, and Connection String pages appear. In other data source types, only the Connection String page appears.

The Credentials page gives you the following four options for the level of security you need for the data in your report. This page is available if the data source Type value is set to Microsoft SQL Client Provider, Microsoft ODBC Provider, and Microsoft OleDb Provider.

  • Use Windows Authentication: Select this option when you know that any users with a valid Windows account are cleared for access to the data, and you do not want to prompt them for a user name and password.

  • Use a specific user name and password: Select this option when you want to allow only a single user name and password to access the data in the report.

  • Prompt for credentials: Select this option when there is a subset of users who can access the data. The Prompt string textbox allows you to customize the text requesting a user name and password from users.

  • No credentials: Select this option only if the data in the report is for general public consumption.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


MS SQL Server

MS SQL Server
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > MS SQL Server

Glossary Item Box

This article explains connecting a Page or an RDLX report to a MS SQL Server/ Microsoft SQL Client data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to MS SQL Server Data Source using Report Wizard

The steps to connect to the MS SQL Server data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as MS SQL Server and click Next >.
    Select Report Data Source Type as MS SQL Server
  5. Enter the Server name and Database you want to connect.
    Enter the server connection details including Server name and DataBase
  6. To specify the runtime connection values, let us add two parameters: for the Server name and for the Database, as follows:
    1. Click on the Parameter link to open the Parameters dialog, and then click the Add button to add a new parameter.
    2. Specify the below details:
      • Name: Specify the name of the parameter.
      • Type: Select the value type (string by default) from the drop-down list.
      • Testing Value: Specify the runtime value for the connection properties.
      • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
    3. Click OK to finish adding the parameter.
  7. To specify the authentication method for the data source connection, choose the authentication Type as SQL Server or Windows.
    If you choose the SQL Server authentication option, enter the User name and Password in the respective fields.
    Note: The User name and Password fields are disabled in case of Windows authentication.
  8. You can select Advanced properties for additional configuration, for example, setting UI timeout option to allow entering key-value pairs.
  9. Click Test Connection to test the connection.
  10. Click Next and configure the dataset to retrieve the fields.
  11. Click Insert parameter to specify the interactive parameter 'channelKeyParam', to set the value of 'ChannelKey' field of type 'Integer', to '4'.
    Parameters Dialog
  12. You should add a valid query that utilizes the parameter added. Validate the query and click Next.
    Enter a valid Query
  13. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully create the report with the MS SQL Server data source.

Connect to a Microsoft SQL Client Data Source using Report Data Source dialog

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the data source name in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Microsoft Sql Client Provider.
    Report Data Source Dialog Box for Microsoft SQL Client Data Provider
  4. In the Connection Properties tab, enter the server name that you want to connect.
  5. To specify the authentication method for the data source connection, select the Use Windows Authentication or Server authentication option.
    If you choose the Server authentication option, enter the user name and password in the respective fields.
    Note: The User name and Password fields are disabled in case of Windows authentication.

  6. To connect to a Database, choose the Select or enter a database name or Attach a database file option. If you choose the Select or enter a database name option, enter a database name or select it from the drop-down list. In case the Attach a database file option is selected, click on Browse and navigate to the desired database file on your system. You can also give a Logical Name to the selected database.
    Note: The Logical Name field is disabled in case of Select or enter a database name option.

    The Connection String tab displays the generated connection string as shown below.

    data source=20.186.17.78;initial catalog=northwind;user id=qatester;password=*********;

    For more information, see the Configuration Settings for Microsoft SQL Client Data Source section.
  7. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon in Report Data Source Dialog Box.
  8. Click the OK button to save the changes.

Configuration Settings

The Microsoft SQL Client Data Provider provides the following configuration settings under the Connection section in the Report Data Source dialog. Based on the defined configuration settings, the connection string is generated in the Connection String tab.

The Connection Properties tab describes the configuration settings for the Microsoft SQL Client data provider. It includes details related to server name, type of authentication method, and database name.

Setting | Description
Server name | Enter a server name
Log on to server | Select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
Connect to a database | Select whether to enter a database name or attach a database file.

The Advanced Settings tab gives access to the following properties.

Setting | Description
Application Name | Indicates the client application name.
Current Language | Indicates the SQL Server language name. It also identifies the language used for system message selection and formatting. The language must be installed on the SQL Server, otherwise opening the connection will fail.
Network Address | Indicates the network address of the SQL Server, specified by the Location property.
Network Library | Indicates the name of the network library (DLL) used to communicate with the SQL Server. The name should not contain the path or the .dll file name extension. The default name is provided by the SQL Server client configuration.
Packet Size | Indicates a network packet size in bytes. The Packet Size property value must be between 512 and 32767. By default, the SQLOLEDB network packet size is 4096.
Trusted Connection | Indicates the user authentication mode. You can set this property to Yes or No. By default, the property value is set to No. If Yes, the SQLOLEDB uses the Microsoft Windows NT Authentication Mode to authorize user access to the SQL Server database, specified by the Location and Datasource property values. If this property is set to No, then the SQLOLEDB uses the Mixed mode to authorize user access to the SQL Server database. The SQL Server login and password are specified in the User Id and Password properties.
Workstation ID | Denotes a string that identifies the workstation.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


MySQL

MySQL
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > MySQL

Glossary Item Box

This article explains connecting a Page or an RDLX report to the MySQL data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

You need to install MySqlConnector NuGet package to be able to connect to MySQL. Without this NuGet package, the following exception appears.

GrapeCity.ActiveReports.ReportException: Specified data provider was not found: MYSQL ---> GrapeCity.ActiveReports.Rendering.DataProcessingException: Specified data provider was not found: MYSQL.

Connect to MySQL Data Source using Report Wizard

The steps to connect to the MySQL data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as MySQL and click Next.
    Select the Data Source Type as MYSql
  5. Enter the server connection details, including Server name, Database, Port, User name, and Password.
    Enter the server connection details
  6. To specify the runtime connection values, let us add a parameter for the Database, as follows:
      1. Click on the Parameter link to open the Parameters dialog, and then click the Add button to add a new parameter.
      2. Specify the below details:
        • Name: Specify the name of the parameter.
        • Type: Select the value type (string by default) from the drop-down list.
        • Testing Value: Specify the runtime value for the connection properties.
        • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
      3. Click OK to finish adding the parameter.
  7. For additional configuration, for example, setting UI timeout option to allow entering key-value pairs, select Advanced properties.
  8. Click Test Connection to test the connection.
  9. Click the Next option and configure the dataset to retrieve the fields.
  10. Click Insert parameter to specify the interactive parameter 'continentParam', to set the value of 'Continent' field of type 'String', to 'Europe'.
    Parameters Dialog
  11. You should add a valid query that utilizes the parameter added. Validate the query and click Next.
    Add a valid query
  12. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the MySQL data source.

Connect to a MySQL Data Source using Report Data Source dialog

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the data source name in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select MySql Provider.
    Report Data Source Dialog Box for MySql Data Provider
  4. On the same page under the Connection section, enter the connection string to connect to the MySql data source. For example:

    host=10.64.1.240;port=3306;database=mysql;username=root;password=******;
  5. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon.
  6. Click OK to save the changes and close the Report Data Source dialog box.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


PostgreSQL

PostgreSQL
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > PostgreSQL

Glossary Item Box

This article explains connecting a Page or an RDLX report to the PostgreSQL data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to PostgreSQL Data Source using Report Wizard

The steps to connect to the PostgreSQL data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as PostgreSQL and click Next.
    Select the Data Source Type as PostgreSQL
  5. Enter the server connection details, including Server name, Database, Port, User name, and Password.
    Enter the server connection details
  6. To specify the runtime connection values, let us add the parameter for Database.
    1. Click Parameter to open the Parameters dialog. and then click the Add button to add a new parameter.
    2. Specify the below details:
      • Name: Specify the name of the parameter.
      • Type: Select the value type (string by default) from the drop-down list.
      • Testing Value: Specify the runtime value for the connection properties.
      • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
    3. Click OK to finish adding the parameter.
  7. For additional configuration, for example, setting UI timeout option to allow entering key-value pairs, select Advanced properties.
  8. Click Test Connection to test the connection.
  9. Click Next and configure the dataset to retrieve the fields.
  10. Click Insert parameter to specify the interactive parameter 'rentalrateParam', to set the value of 'rental_rate' field of type 'Float', to '4.99'.
    Parameters Dialog
  11. You should add a valid query that utilizes the parameter added. Validate the query and click Next.
    Enter a valid query
  12. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the PostgreSQL data source.

Connect to a PostgreSQL Data Source using Report Data Source dialog

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the data source name in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select PostgreSQL Provider.
    Report Data Source Dialog Box for PostgreSQL Data Provider
  4. On the same page under the Connection section, enter the connection string to connect to the PostgreSQL data source. For example:

    host=10.64.1.240;port=5432;database=postgres;username=postgres;password=********;
  5. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon.
  6. Click OK to save the changes and close the Report Data Source dialog box.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


SQLite

SQLite
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > SQLite

Glossary Item Box

This article explains connecting a Page or an RDLX report to a SQLite data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog). SQLite data source is a custom data provider, so the data provider needs to be configured. See section Custom Data Provider in Configure ActiveReports using Config File topic before you begin connecting to the SQLite Provider.

Connect to SQLite Data Source using Report Wizard

The steps to connect to the SQLite data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as SQLite and click Next.
    Select the Data Source Type as SQLite
  5. To specify the Database Path, click Browse and navigate to the desired file on your system.
    Enter the data source connection details
  6. To specify the runtime connection values for database path, let us add a parameter as follows:
    1. Click on the Parameter link to open the Parameters dialog, and then click the Add button to add a new parameter.
    2. Specify the below details:
      • Name: Specify the name of the parameter.
      • Type: Select the value type (string by default) from the drop-down list.
      • Testing Value: Specify the runtime value for the connection properties, eg 'C:\Data\NWIND.db'.
      • Input Source: Select Interactive (in our case) for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
    3. Click OK to finish adding the parameter.
  7. Select Advanced to specify key-value pairs for additional configuration, and add a new parameter with details as in the previous step.

    Let us add the 'Default Timeout' option to specify the hidden parameter 'DefTimeout' of type 'Integer' to '5'.

    Parameters Dialog
  8. Click Test Connection to test the connection.
  9. Click Next, and configure the dataset to retrieve the fields by adding a valid query.
    You can also provide a parameterized query by first using the 'Insert parameter' option to create a parameter and then utilizing the parameter in the query.
    Configure the data set by adding a valid query
  10. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the SQLite data source.

Connect to a SQLite Data Source using Report Data Source dialog

  1. In the designer, go to the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and then select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select SQLite Provider.
    Report Data Source Dailog - Sqlite Data Source
  4. In the Connection Properties tab, enter the connection string to connect to the data source. For example, you can connect to the 'NWIND.db' sample data source that can be downloaded from GitHub and write the connection string as shown below:

    data source=C:\NWIND.db;
  5. Click the Validate DataSource icon to verify the connection string.
  6. Click OK to close the Report Data Source dialog. Your report is now connected to the SQLite data source successfully.
  7. To specify the authentication method for the data source connection, go to the Credentials page and select the Use Windows Authentication or Use a specific user name and password option.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


JSON

JSON
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > JSON

Glossary Item Box

This article explains connecting a Page or an RDLX report to a JSON data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to JSON Data Source using Report Wizard

The steps to connect to the JSON data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as JSON and click Next.
    Select the Data Source Type as JSON
  5. To specify JSON File Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the 'customer.json' sample data source that can be downloaded from GitHub.
    Specify JSON file path
  6. To specify the runtime connection values, click Parameter to open the Parameters dialog. Then click the Add button to add a new parameter, or select the existing parameter and specify the below details:
    • Name: Specify the name of the parameter.
    • Type: Select the value type (string by default) from the drop-down list.
    • Testing Value: Specify the runtime value for the connection properties.
    • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
      Parameters Dialog
  7. Click the Next option and configure the dataset by adding a valid query. Select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
    Configure the dataset by adding a valid query
  8. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the JSON data source.

Connect to a JSON Data Source using Report Data Source dialog

  1. In the designer, go to the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and then select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Json Provider.
    JSON Provider Data Source
  4. In the Content tab, set the type of Json data to 'External file or URL'.
  5. Click the drop-down icon next to the Select or type the file name or URL field and select the <Browse...> option to specify the json file path, or enter the URL. For example, connect to the 'https://demodata.mescius.io/northwind/odata/v1/Orders' data source.
    The Connection String tab displays the generated connection string as shown below:
    Connection String Copy Code
    jsondoc=https://demodata.mescius.io/northwind/odata/v1/Orders

    The Configuration Settings are explained in the next section.

  6. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon in Report Data Source Dialog Box.
  7. Click OK to save the changes and close the Report Data Source dialog.

Configuration Settings

The JSON Data Provider provides the following configuration settings under the Connection section in the Report Data Source dialog.

The Content tab describes the type of JSON data you want to use for connecting to a data source. The options available for specifying the JSON data are as follows:

  • External file or URL: Enter the path or URL of an external JSON data file or select the file from the drop-down which displays the JSON files available in the same folder as the report. The connection string generated using this option starts with the keyword jsondoc.
  • Embedded: Enter the path of the JSON data file to embed in the report. You can provide JSON data manually or select a JSON file containing the data. The connection string generated using this option starts with the keyword jsondata.
  • Expression: Enter an expression to bind to the JSON data at runtime.

The Schema tab describes the options available for specifying the JSON schema in ActiveReports.

  • Auto: This is the default option that auto-generates the JSON schema.
  • External file or URL: Enter the path or URL of an external JSON schema file or select the file from the drop-down which displays the JSON files available in your system. The connection string generated using this option starts with the keyword schemadoc.
  • Embedded: Enter the path of the JSON schema file to embed in the report. You can enter the schema manually or edit the schema in the selected JSON file. The connection string generated using this option starts with the keyword schemadata.
    For generating JSON schema, use the JSON schema generator available at https://jsonschema.net.

The JSON schema describes the structure of the JSON data. In ActiveReports, the JSON data provider uses the JSON schema to obtain fields. For more information on JSON schema, please see https://json-schema.org/understanding-json-schema/.
JSON data provider does not support the following schema keywords, such as:

  • type: Indicates the type of JSON schema element. See here for more information on the type keyword.
  • properties: Indicates the properties collection for JSON schema elements with the object type. See here for more information on properties keyword.
  • items: Indicates the definition of items for JSON schema elements with array type. Only single values are supported.
    For example, "items" : [ {...}, {...}, {...} ] is not supported because it contains multiple values. See here for more information on items keyword.
  • definitions: Indicates the independent definitions which can be used by other JSON schema elements using $ref keyword. See here for more information on definitions keyword.
  • $ref: Indicates the reference to a definition for JSON schema elements with the object type. Only "definitions" ({ $ref : #/definitions/... }) references are supported.

The Connection String tab displays the JSON connection string based on the defined configuration settings in the Content and Schema tab.

If you choose the External file or URL option, the connection string will be as follows:

Colorized Example Code

Connection String
Copy Code
jsondoc=C:\customers.json

or

Colorized Example Code

Connection String
Copy Code
jsondoc=https://demodata.mescius.io/northwind/odata/v1/Orders

  • If you choose the Embedded option, the connection string will be generated as follows.

Colorized Example Code

Connection String
Copy Code
jsondata={"Customers":[{"Id":"ALFKI", "CompanyName":"Alfreds Futterkiste", "Country":"Germany"}, {"Id":"ANATR", "CompanyName":"Ana Trujillo Emparedados y helados", "Country":"Mexico"}], "ResponseStatus":{}}

  • If you choose the Expression option, the connection string will start with an "equals to" as shown.
  • Connection String Copy Code
    ="jsondata={ 'Name': 'Name'};schemadata={ '$schema': 'http://json-schema.org/draft-04/schema#', 'definitions': {}, 'id': 'http://example.com/example.json', 'properties': { 'Name': { 'id': '/properties/Name', 'type': 'string' } }, 'type': 'object'}"
    Caution: If you include an expression in the connection string, use single quotes (') in jsondoc or jsondata and schemadoc or schemadata instead of the double quotes (") .

    For example, the following connection string is invalid:

    Connection String (invalid) Copy Code
    ="jsondata={ "Name": "Name"};schemadata={ "$schema": "http://json-schema.org/draft-04/schema#", "definitions": {}, "id": "http://example.com/example.json", "properties": { "Name": { "id": "/properties/Name", "type": "string" } }, "type": "object"}"

Build Connection String

It is possible to configure the JSON data source connection string by using the Build button in the Connection String tab of the Report Data Source - General dialog. This allows fetching a JSON from an external URL using the specified method (GET, POST) and other request options. Clicking the Build button opens the Configure JSON Data Source dialog where you can create a JSON connection string with parameters such as data path, method (GET, POST), headers, and body.

To connect to a external URL containing JSON data, some settings are required to be configured as elaborated.

Data Path:

The URL or the endpoint of the request consists of service root URI, resource path, and query options. The fields from json provided in the data source's endpoint are extracted depending on the dataset’s settings. A URL with IP address (eg. http://10.64.2.17:51980/admin) or with a machine name (eg. http://in-esxi-w10v17:8080/) is also valid.

Note: The Data Path must be accurate with a valid URL, else it can not be validated by the builder.

HTTP Headers:

Contains additional info related to the request or the response, for eg, provide expected content type necessary for establishing connection with endpoint which must return json. For example, providing credentials to login to a service/URI to retrieve data. Collection editor to add header/value pair for headers is available. This parameter has to be set to send the request body in JSON format.

Example of Header,Value pairs:

  • Content-Type, application-json (to send the request body in JSON format)

  • Accept, application-json (to read the response in the desired format)

HTTP Method:

Request method can be GET (included in URL) or POST (included in 'body').

  • GET requests data from a specified resource. GET method examples are provided in Sample connection strings and dataset queries section.
  • POST requests allow defining a body as an expression to obtain data.

Request Body (POST):

Text area, applicable only in case of POST HTTP request.

You should provide a valid combination of configuration settings for the successful processing of the connection string with the POST method. If a combination of a valid URL, a valid header name, a valid header value, and a valid body is provided, then the connection string can be saved and validated. Only in this case, it is possible to create a dataset based on this data source.

If an invalid URL, an invalid header name or header value, invalid body, or a combination of these settings is entered, error message is displayed while validating the connection string.

Sample connection strings and dataset queries

Simple

Connection String Copy Code
jsondoc=https://demodata.mescius.io/northwind/api/v1/Categories
Dataset Query Copy Code
$.[*]

To convert the format of data in the requested URI to JSON, use either $format query or Http Header as shown in the following connection strings:

  • $format query:
Connection String Copy Code
jsondoc=https://services.odata.org/v3/northwind/northwind.svc/Invoices?$format=json
  • Http Header:
Connection String Copy Code
headers={"Accept":"application/json"};jsondoc=https://services.odata.org/v3/northwind/northwind.svc/Invoices
Dataset Query Copy Code
$.value[*]

Using Parameters to query specific fields

Connection String Copy Code
headers={"Accept":"application/json"};jsondoc=https://services.odata.org/v3/northwind/northwind.svc/Invoices?$select=ShipName,ShipRegion
Dataset Query Copy Code
$.value[*]

Using Parameters to filter database fields

Connection String Copy Code
headers={"Accept":"application/json"};jsondoc=https://services.odata.org/v3/northwind/northwind.svc/Invoices?$filter=ShipName eq 'Alfreds%20Futterkiste'
Dataset Query Copy Code
$.value[*]

See Also

Query Builder in JSON and XML Providers
Dynamic JSON Connection String

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


XML

XML
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > XML

Glossary Item Box

This article explains connecting a Page or an RDLX report to a XML data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to XML Data Source using Report Wizard

The steps to connect to the XML data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as XML and click Next.
    Select Data Source Type - XML
  5. To specify the xml File Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the 'Factbook.xml' sample data source that can be downloaded from GitHub.
    Specify XML file path
  6. To specify the runtime connection values, click Parameter (or Insert Parameter for queries) to open the Parameters dialog. Then click the Add button to add a new parameter, or select the existing parameter and specify the below details:
    • Name: Specify the name of the parameter.
    • Type: Select the value type (string by default) from the drop-down list.
    • Testing Value: Specify the runtime value for the connection properties.
    • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.

  7. Click the Next option and configure the dataset by adding a valid query. Select the node from the data tree in the Path section to generate the query. The resulting query is displayed in the Query field.
    Configure the dataset by adding a valid query
  8. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the XML data source.

Connect to an XML Data Source using Report Data Source dialog

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the data source name in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Xml Provider.
    Report Data Source Dialog Box for XML Provider
  4. In the Connection Properties tab, select the type of XML data as an External file or URL.
  5. Click the dropdown next to the Select or type the file name or URL field and select the <Browse...> option to specify the xml file path. For example, you can connect to the Factbook.xml sample data source which can be downloaded from GitHub.

    The Connection String tab displays the generated connection string as shown below:
    xmldoc=C:\Factbook.xml

    For more information, see the Configuration Settings for XML Data Source section.
  6. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon in Report Data Source Dialog Box.
  7. Click the OK button to save the changes.

Configuration Settings for XML Data Source

The XML Data Provider provides the following configuration settings in the Report Data Source dialog.

The Connection Properties tab describes the type of xml data you want to use for connecting to a data source. You can also specify an XSLT file to apply to the XML data.
  • External file or URL: This field requires you to enter the path of an external XML source such as a local file or the http location of a file.
  • Embedded: This field requires you to enter the path of the XML file to embed in the report. You can also enter the data manually or edit the data in the selected XML file.
  • Expression: This field requires you to enter the path expression. Users can also enter the path expression in the connection string.

The Connection String tab displays the XML connection string based on the defined configuration settings in the Connection Properties tab.

  • If you choose the External file or URL option, the connection string will be as follows -
    xmldoc=C:\MyXmlFile.xml;

    where the xmldoc refers to a specific XML file located on either the file system or at a web-accessible location.
  • If you choose the Embedded option, the connection string will be as follows -

    xmldata=<people>
          <person>
            <name>
              <given>John</given>
              <family>Doe</family>
            </name>
          </person>
          <person>
            <name>
              <given>Jane</given>
              <family>Smith</family>
            </name>
          </person>
        </people>

    where the xmldata provides specific XML data in the connection string itself.
  • If you choose the Expression option, the connection string will start with an "equals to" as shown -
    ="xmldoc=" & [@Parameter]

Note that elements in the connection string must be terminated with a semicolon (;) character.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CSV

CSV
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > CSV

Glossary Item Box

This article explains connecting a Page or an RDLX report to a CSV data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to CSV Data Source using Report Wizard

The steps to connect to the CSV data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as CSV and click Next.
    Select the Data Source Type as CSV
  5. To specify the File Path, click the Browse button and navigate to the desired folder on your system. For example, you can connect to the MyOrders.csv sample data source which can be downloaded from GitHub.
    configure csv data source
  6. To specify the runtime connection values, click Parameter (or Insert Parameter for queries) to open the Parameters dialog. Then click the Add button to add a new parameter, or select the existing parameter and specify the below details:
    • Name: Specify the name of the parameter.
    • Type: Select the value type (string by default) from the drop-down list.
    • Testing Value: Specify the runtime value for the connection properties.
    • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.

  7. Select the File Type as Delimited or Fixed.
  8. Then click Next to check the Fields section, which includes field names with their corresponding data types present in the CSV file. This allows you to modify the field names and their data type (like String, Boolean, DateTime, Integer, Float, Decimal, Double, or Long) for the columns. You can check the changes in the Preview section.

    Check the data feilds and their corresponding data types present in the CSV file
  9. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the CSV data source.

Connect to a CSV Data Source using Report Data Source dialog

  1. In the designer, go to the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and then select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Csv Provider.
  4. In the Connection String tab, click the Build icon to open the Configure CSV Data Source dialog.
    Configure CSV Data Source Wizard
  5. To specify the Path of the file, click the Open button and navigate to the desired folder on your system. For example, you can connect to the MyOrders.csv sample data source which can be downloaded from GitHub.
  6. Select the Column Separator as Comma from the drop-down menu.
  7. Click the Get from Preview button to fill the Columns area with the column names and their corresponding data types (string by default) present in the CSV file. This allows you to modify the name and data type (like String, Boolean, DateTime, Integer, Float, Decimal, Double, or Long) for the columns.
    For more information, see the Configuration Settings for CSV Data Source section.
  8. Click OK to save the changes and close the Configure CSV Data Source dialog.
    Configure CSV Data Source Wizard

    The Connection String tab displays the generated connection string as shown below:
        Path=C:\\MyOrders.csv;Locale=en-IN;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;Columns=ID,Product,Customer,OrderNumber,Stock,Total(Decimal),UnitPrice(Decimal),City,ProductLine,Discount(Decimal);HasHeaders=True

    You can validate the connection string by clicking theValidate DataSource icon.
  9. Click OK to close the Report Data Source dialog. Your report is now connected to the CSV data source successfully.

Configuration Settings for CSV Data Source

The CSV Data Provider provides the following configuration settings in the Configure CSV Data Source dialog. Based on the defined configuration settings, the CSV connection string is generated.

Setting | Description
File Path/Path | Path to the CSV file - both local and relative; or a URL for centrally located CSV data sources.
File Type/Type | Define the type of CSV file. You can choose from Fixed and Delimited options.
File Encoding/Encoding | Specify the character encoding used in the CSV file.
File Locale/Locale | Specify the locale used in the CSV file.
Data Starts at row/Starting Row | Row number to start fetching data.
Use starting row as column headers | Select this check box to use the first row as column header.
Column Delimiter/Column Separator1 | Specify the symbol used to separate the columns in the CSV file. You can choose from Comma, Semicolon, Tab, and Space options.
Merge consecutive column delimiters | Select this check box to treat consecutive column delimiters as one.
Row Delimiter/Row Separator1 | Symbol used to separate the rows in the CSV file. You can choose from CRLF (carriage return and line feed), CR (carriage return), and LF (line feed) new line formats.
Merge consecutive row delimiters | Select this check box to treat consecutive row delimiters as one.
Text Qualifier1 | Character to specify where the text begins and ends, that is, the character that encloses values in the CSV file. You can choose from Quotes and Single quotes options.
Columns have headers | Specify whether the CSV file has columns with headers or not.
Treat consecutive as one1 | Specify whether to join the column separators or row separators as one.
Get from preview | Fills the Columns area with names and data types (string by default) for columns present in the CSV file. This allows you to modify the name and data type (like String, Boolean, DateTime, Integer, Float, Decimal, Double, or Long) for the columns.
1 These options are not available for Fixed file type.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Excel

Excel
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > Excel

Glossary Item Box

This article explains connecting a Page or an RDLX report to a Excel data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Note: To use an Excel data source in your Visual Studio project, you need to install the MESCIUS.ActiveReports.Core.DataProviders.Excel package.

Connect to Excel Data Source using Report Wizard

The steps to connect to the Excel data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as Excel and click Next.
    Select the Data Source Type as Excel
  5. To specify the File Path, click the Browse button and navigate to the desired file on your system.
    Configure the connection details
  6. To specify the runtime connection values, click Parameter (or Insert Parameter for queries) to open the Parameters dialog. Then click the Add button to add a new parameter, or select the existing parameter and specify the below details:
    • Name: Specify the name of the parameter.
    • Type: Select the value type (string by default) from the drop-down list.
    • Testing Value: Specify the runtime value for the connection properties.
    • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
  7. To configure the dataset, select the desired Sheet , Table, and Named (range) of the Excel file, and click Next.
    Configure the dataset
  8. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the Excel data source.

Connect to a Excel Data Source using Report Data Source dialog

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the data source name in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Excel Provider.
    Add data source using Report Data Source dialog
  4. On the same page under the Connection section, enter the connection string to connect to the Excel data source. For example:
    Path=C:\\ExcelDataSource.xlsx;
  5. Verify the generated connection string by clicking the Validate DataSource icon Validate Icon.
  6. Click OK to save the changes and close the Report Data Source dialog box.

Configuration Settings for Excel Data Source

The Excel Data Provider provides the following configuration settings in the Report Wizard dialog.

Setting | Description
Sheet | Select the sheet of the Excel file that you want to use.
Table | Select the table that you want to use.
Named | Select the desired named range of the Excel file.
Read field names from the first row | Select the check box to use the first row from the Excel table as field names.
Skip hidden rows | Select the check box to skip the hidden rows present in the Excel table.
Skip empty rows | Select the check box to skip the empty rows present in the Excel table.
Skip hidden columns | Select the check box to skip the hidden columns present in the Excel table.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


JSON API

JSON API
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > JSON API

Glossary Item Box

This article explains connecting a Page or an RDLX report to a JSON API/Web API data source. You can connect to this data source while creating a new report (via report wizard) or using report explorer (via report data source dialog).

Connect to JSON API Data Source using Report Wizard

The steps to connect to the JSON API data source are:

  1. Create a New Report.
  2. In the New Report dialog, choose the Report Type as RDLX, RDLX Dashboard, or Page report and click Next.
    Choose a Report Type from New Report Dialog
  3. Configure page settings if you need to customize the report page settings and click Next >.
    Configure Page Settings of the Report Wizard
  4. Select the Data Source Type as JSON API and click Next.
    Select the Data Source Type as JSON API
  5. To configure Web API request, select GET from the HTTP Method section and enter the URL in the General section or you use the POST HTTP method to connect to the server.
    Configure the connection details
  6. To specify the runtime connection values, click Insert Parameter to open the Parameters dialog. Then click the Add button to add a new parameter, or select the existing parameter and specify the below details:
    • Name: Specify the name of the parameter.
    • Type: Select the value type (string by default) from the drop-down list.
    • Testing Value: Specify the runtime value for the connection properties.
    • Input Source: Select Interactive for non-hidden parameters and Programmatic for hidden parameters from the drop-down list.
  7. Then click the Next option and configure the dataset by adding a valid query. Select the node from the data tree in the Path section to generate the query. The resulting query is displayed in the Query field.
    Configure the dataset by adding a valid query
  8. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the JSON API/Web API data source.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Microsoft ODBC Provider

Microsoft ODBC Provider
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > Microsoft ODBC Provider

Glossary Item Box

This article explains connecting a Page or an RDLX report to an ODBC data source.

Note: The ODBC model depends on the installed drivers.

Connect to an ODBC Data Source

  1. In the designer, go to the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and then select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Microsoft Odbc Provider.
    Report Data Source Dialog - Microsoft ODBC Provider
  4. On the same page under the Connection section, enter the connection string to connect to an ODBC data source. The following sample connection string specifies the type of the ODBC Driver along with location of the file required for an ODBC data source connection.
    For example, you can connect to the NWIND.mdb sample data source which can be downloaded from GitHub.

    Driver=Microsoft Access Driver (*.mdb);Dbq=C:\NWIND.mdb;

    For more information about the Credentials page in the Report Data Source dialog, see Report Data Source dialog properties.
  5. Click OK to save the changes and close the Report Data Source dialog box.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Connect to PostgreSQL Database

Connect to PostgreSQL Database
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > Microsoft ODBC Provider > Connect to PostgreSQL Database

Glossary Item Box

This article demonstrates how to connect to a PostgreSQL database with the ODBC driver. The following steps assume that you have the required configuration details to connect to a PostgreSQL database.

You will need to install the PostgreSQL ODBC driver that will allow you to connect with PostgreSQL data.

Install the PostgreSQL ODBC driver

  1. Download the latest 32-bit version of Postgres ODBC driver.
    Note: Since the ActiveReports Designer application is a 32-bit application, you should use the 32-bit PostgreSQL ODBC driver. In case you are using the ActiveReports Visual Studio Integrated Designer in your .NET application, depending on the target platform x86 or x64, you need to accordingly download a 32-bit or a 64-bit PostgreSQL ODBC driver.
  2. Extract the files and run the .msi file.

Set up the ODBC data source for PostgreSQL

  3. Open the ODBC Data Source application. An ODBC Data Source Administrator dialog box appears.
  4. Navigate to the System DSN tab and click Add.
    ODBC Data Source Administrator dialog box
  5. In the Create New Data Source dialog box that displays, select the PostgreSQL Unicode driver from the list, and click Finish.
    Select the PostgreSQL Unicode driver from the Create New Data Source dialog box
  6. Fill in the configuration details required for the PostgreSQL including the server, port, username, password, and database. The configured DSN is PostgreSQL35W as shown.
    Fill in the configuration details for PostgreSQL
  7. Click Test to verify the data source connection. The following dialog box will appear on a successful connection.
    Successful Data Source Connection
  8. Click OK to save the changes.

Connect to PostgreSQL with the ODBC connection string

  8. Open the ActiveReports Designer application. By default, an RDLX report is created.
    As you create a new report, Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
    Add a new data source from the Report Explorer
  9. In the Report Data Source dialog, select the General page and enter the name of the data source in the Name field.
  10. Under the Type field, select Microsoft Odbc Provider.
  11. On the same page, under the Connection section, enter the connection string to connect to the data source.
    The format of the connection string is as follows -
    Connection String Copy Code
    DSN=PostgreSQL35W;Server=<server>;Port=<port>;User Id=<user id>;Password=<password>;Database=<database>

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Microsoft OLEDB Provider

Microsoft OLEDB Provider
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Connect to a Data Source > Microsoft OLEDB Provider

Glossary Item Box

This article explains connecting a Page or an RDLX report to an OLEDB data source.

Note: The OLEDB model depends on the installed drivers.

Connect to an OLEDB Data Source

  1. In the designer, go to the Report Explorer, right-click the Data Sources node and select the Add Data Source option or click the Add button and then select the Data Source option.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source in the Name field. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select Microsoft OleDb Provider.
    Report Data Source Dailog - OLEDB Data Source
  4. In the Connection Properties tab, specify the OLE DB Provider you want to use to connect to the data source.
  5. To specify the Path of the file, click the Browse button and navigate to the desired folder on your system. For example, you can connect to the 'NWIND.mdb' sample data source which can be downloaded from GitHub.

    The Connection String tab displays the generated connection string as shown below:
    provider=Microsoft.Jet.OLEDB.4.0;data source=C:\NWIND.mdb;

    For more information, see the next section on 'Configuration Settings for OLEDB Data Source'.
  6. Click the Validate DataSource icon to verify the connection string. See Report Data Source dialog properties to learn about the properties available in the Credentials page of the dialog.
  7. Click OK to close the Report Data Source dialog. Your report is now connected to the OLEDB data source successfully.

Configuration Settings for OLEDB Data Source

The OLEDB Data Provider provides the following configuration settings under the Connection section in the Report Data Source dialog. Based on the defined configuration settings, the OLEDB connection string is generated in the Connection String tab.

The Connection Properties tab gives access to properties specific to the following data types.

Setting | Description | Example
OLE DB Provider

Choose which OLE DB Provider you want to use for the data source connection.

You need to be selective in the choice of the provider. For example, Microsoft.Jet.OLEDB.4.0 is not supported in 64 bit OS while Microsoft.ACE.OLEDB.12.0 is supported.

See Troubleshooting article if an exception occurs on previewing reports connecting Microsoft Access OLE DB provider in a 64-bit system.

 Microsoft.Jet.OLEDB.4.0
Enter a server or file name | Enter a server or a file name along with its location. | C://NWIND.mdb
Log on to server | Select whether to use Windows NT integrated security or a specific user name and password. | Check the Use Windows NT integrated security option

Show Advanced Settings for Provider-Specific Connection Parameters

The Advanced Settings tab gives access to the Microsoft Jet OLEDB provider-specific connection parameters.

Setting | Description
Jet OLEDB: Compact Reclaimed Space Amount | Indicates an estimate of the amount of space, in bytes, that can be reclaimed by compacting the database. This value is only valid after a database connection has been established.
Jet OLEDB: Connection Control | Indicates whether users can connect to the database.
Jet OLEDB: Create System Database | Indicates whether to create a system database when creating a new data source.
Jet OLEDB: Database Locking Mode | Indicates the locking mode for this database. The first user to open the database determines what mode to use when the database is open.
Jet OLEDB: Database Password | Indicates the database password.
Jet OLEDB: Don't Copy Locale on Compact | Indicates whether the Jet should copy locale information when compacting a database.
Jet OLEDB: Encrypt Database | Indicates whether a compacted database should be encrypted. If this property is not set, the compacted database will be encrypted if the original database was encrypted.
Jet OLEDB: Engine Type | Indicates the storage engine to access the current data store.
Jet OLEDB: Exclusive Async Delay | Indicates the maximum length of time, in milliseconds, that the Jet can delay asynchronous writes to disk when the database is opened exclusively. This property is ignored unless Jet OLEDB: Flush Transaction Timeout is set to 0.
Jet OLEDB: Flush Transaction Timeout | Indicates the amount of time before data stored in a cache for asynchronous writing is actually written to disk. This setting overrides the values for Jet OLEDB:Shared Async Delay and jet OLEDB: Exclusive Async Delay.
Jet OLEDB: Global Bulk Transactions | Indicates whether the SQL bulk transactions are transacted.
Jet OLEDB: Global Partial Bulk Ops | Indicates the password to open the database.
Jet OLEDB: Implicit Commit Sync | Indicates whether the changes made in internal implicit transactions are written in synchronous or asynchronous mode.
Jet OLEDB: Lock Delay | Indicates the number of milliseconds before attempting to acquire a lock after a previous attempt has failed.
Jet OLEDB: Lock Retry | Indicates the frequency of attempts to access a locked page.
Jet OLEDB: Max Buffer Size | Indicates the maximum amount of memory, in kilobytes, the Jet can use before it starts flushing changes to disk.
Jet OLEDB: MaxLocksPerFile | Indicates the maximum number of locks the Jet can place on a database. The default value is 9500.
Jet OLEDB: New Database Password | Indicates the new password for this database. The old password is stored in Jet OLEDB: Database Password.
Jet OLEDB: ODBC Command Time Out | Indicates the number of milliseconds before a remote ODBC query from the Jet will timeout.
Jet OLEDB: Page Locks to Table Lock | Indicates how many pages to lock within a transaction before the Jet attempts to promote the lock to a table lock. If this value is 0, then the lock is never promoted.
Jet OLEDB: Page Timeout | Indicates the number of milliseconds before the Jet will check if its cache is out of date with the database file.
Jet OLEDB: Recycle Long-Valued Pages | Indicates whether the Jet should aggressively try to reclaim BLOB pages when they are freed.
Jet OLEDB: Registry Path | Indicates the Windows registry key that contains values for the Jet database engine.
Jet OLEDB: Reset ISAM Stats | Indicates whether the schema Recordset DBSCHEMA_JETOLEDB_ISAMSTATS should reset its performance counters after returning performance information.
Jet OLEDB: Shared Async Delay | Indicates the maximum amount of time, in milliseconds, the Jet can delay asynchronous writes to disk when the database is opened in the multi-user mode.
Jet OLEDB: System Database | Indicates the path and file name for the workgroup information file (system database).
Jet OLEDB: Transaction Commit Mode | Indicates whether the Jet writes data to disk synchronously or asynchronously when a transaction is committed.
Jet OLEDB: User Commit Sync | Indicates whether changes made in transactions are written in the synchronous or the asynchronous mode.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add Dataset

Add Dataset
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset

Glossary Item Box

After connecting to a data source in a Page/RDLX report, you need to add a dataset. It is the dataset that contains the data to which a report connects. This article demonstrates the steps to add a dataset in a Page/RDLX report, and the various configuration settings available in the Dataset dialog box.

A dataset fetches data from the data source to display in a report. The DataSet dialog is where you provide a command type and query string and choose other options for your dataset.

You can also control the timeout period and other data options, and add fields, parameters, and filters to fetch the data you need. Once you have added a dataset, the dataset fields appear under the Data Source node in the Report Explorer. You can add multiple datasets for a data source. For example, you can use multiple data sets in a report when nesting data regions such as Tablix, List, Chart, BandedList, Table, and Sparkline.

Furthermore, ActiveReports provides a Visual Query Designer for Microsoft SQL Client and Microsoft OLEDB providers and Query Designers for JSON and XML providers, which allow the users to build the dataset queries easily.

Note: The dataset for a CSV data source is automatically added. The default name of the data set is the name of the CSV file selected. You can later modify the dataset through the Edit option in the context menu.

Add a dataset

  1. In ActiveReports designer, go to the Report Explorer.

    • With the Data Source node (like DataSource1) selected, click the Add icon on the top left and select Data Set.

      Adding a Dataset to a Page/RDL report

    • Right-click an existing data source and select Add Data Set.

      Adding a Dataset to a Page/RDL report
  2. In the DataSet dialog box that appears, select the General page and enter the name of the dataset. By default, the dataset name is set to DataSet1. This name appears as a child node to the Data Source node in the Report Explorer.
  3. Navigate to the Query tab. Based on the chosen command type, enter the query to retrieve the data from a database. You can verify the query by clicking the Validate DataSet icon Validate Icon in Report Data Source Dialog Box . See DataSet dialog properties for setting up the dataset.
    The availability of a specific query designer depends on the report's data source connection. For more information on query designers, see articles Query Builder in JSON and XML Providers and Query Builder in Microsoft SQL Client and OLEDB Providers.
  4. Click OK to save the changes.

DataSet dialog properties

The DataSet dialog provides the following pages where you can set the dataset properties.

General
Query
Options
Fields
Parameters
Filters

The General page of the DataSet dialog is where you can set the name of the dataset.

Name: Enter a name for the dataset. By default, the name is set to DataSet1. The name of the dataset appears in the tree view of the Report Explorer. It is also used to call the dataset in code so it should be unique within the report.

The Query page of the DataSet dialog is where you set the SQL query, stored procedure, or table to define the data you want to fetch in the dataset of your report.

Note: The Query page is unavailable for the CSV data provider.

  • Command type: You can choose from the three enumerated command types.

    • Select Text if you want to write an SQL query to retrieve data.
    • Select StoredProcedure if you want to use a stored procedure. This option is not available in SQLite, JSON, and XML data providers. See Stored Procedure as Dataset topic for more information.
    • Select TableDirect if you want to return all rows and columns from one or more tables. This option is available only in OLEDB data provider.

  • Query: Based on the command type you select above, you can set the query string in this field.

    Note:

    • If you select the TableDirect command type, you may need to use escape characters or qualifying characters in case any of the table names include special characters.

    • Specify the calculated index for arrays in a JSONPath expression in the following ways:

      • To obtain the last entry in an array, use -1: square brackets. For example, use $..book[-1:].
      • To obtain evaluated expressions correctly, the field names in square brackets should be in single quotes. For example, use $..book[0]['category','author'].

    To create multiple datasets based on the JSON data provider, check the Select multiple nodes option in the JSON Query Builder.

    For information on writing an SQL query that you can use for SQLite (Custom Data Provider), see the SQLite Tutorial. You will note that there are some differences in writing a standard SQL query and an SQL query for SQLite.

  • Timeout: Specifies the number of seconds you want the report server to wait for the query to return the data before it stops trying.

The Options page is where you select the following options available for the dataset.

Note: The Options page is unavailable in case of CSV, JSON, and XML data providers.
  • CaseSensitivity: Set this value to Auto, True, or False to indicate whether to make distinctions between upper and lower case letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without case sensitivity.
  • Collation: Choose from Default or a country from the list to indicate which collation sequence to use to sort data. The Default value causes the report server to get the value from the data provider. If the data provider does not set the value, the report uses the server locale. This is important with international data, as the sort order for different languages can be different from the machine sort.
  • KanaTypeSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between Hiragana and Katakana kana types. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without kana type sensitivity.
  • WidthSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between single-byte (half-width) characters and double-byte (full-width) characters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without width sensitivity.
  • AccentSensitivity: Set this value to Auto, True, or False to indicate whether distinctions are made between accented and unaccented letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without accent sensitivity.

The Fields page of the DataSet dialog populates automatically for OleDb, ODBC, SQL, JSON, CSV, and XML data providers. To see a list of fields in the Name and Value columns of the Fields page, enter a valid query, table name, or stored procedure on the Query page.

You can edit the populated fields, delete them by using the Remove (X) icon, or add new ones by using the Add (+) icon above the Fields list. Any fields you add in this list show up in the Report Explorer tree view and you can drag and drop them onto the design surface. The field name must be unique within the dataset.

When working with Fields, the meaning of the value varies depending on the data source type. In most cases, this is simply the name of the field. The following list describes the meaning of the field value and gives some examples of how to use the value.

  • In SQL and OleDb data sources, the field value is the name of a field returned by the query. For example,
    OrderQuantity
    FirstName
  • In Dataset data source, the field value can be the name of a field in the DataTable specified by the query. You can also use DataRelations in a DataSet, specify the name of the relation followed by a period and then the name of a field in the related DataTable. For example,
    Quantity
    OrdersToOrderDetails.CustomerID
  • In XML data source, the field value is an XPath expression that returns a value when evaluated with the query. For example,
    Statistics/Game/TeamName
  • In JSON data source, the field value is a JSONPath expression that returns a value when evaluated with the query. For example,
    $.Statistics.Game[*].TeamName
  • In Object data source, the field value can be the name of a property of the object contained in the collection returned by the data provider. You may also use properties available for the object returned from a property. For example,
    Quantity
    Order.Customer.FirstName
  • In CSV data source, the field value is the name of a field returned by each column specified in the connection string. For example,
    Path=C:\\FixedWidth.csv;Locale=en-US;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;HasHeaders=True

The Parameters page of the Dataset dialog is where you can pass a Report Parameter into the parameter you enter in the Query page. You can edit the populated fields, delete them by using the Remove (X) icon, or add new ones by using the Add (+) icon above the Parameters list. For each parameter in this list, there is a Name and a Value.

Note: This Parameters page is unavailable for the CSV, JSON, and XML data providers.
Enter a Name that matches the name of the Report Parameter and a Value for each parameter in this page. The Name of the parameter must be unique within the dataset.

The Value of parameter can be a static value or an expression referring to an object within the report. It cannot refer to a report control or field. To learn about adding parameter for different data sources, see Parameter in SQL query for Data Sources section in Parameters topic.

The Filters page of the Dataset dialog allows you to filter data after it is returned from the data source. This is useful when you have a data source (such as XML) that does not support query parameters.

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

See Also

Query Builder in Microsoft SQL Client and OLEDB Providers
Query Builder in JSON and XML Providers
Stored Procedure as Dataset
Nested Datasets (JSON and XML)
Dynamic JSON Connection String

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Query Builder in JSON and XML Providers

Query Builder in JSON and XML Providers
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset > Query Builder in JSON and XML Providers

Glossary Item Box

ActiveReports provides query builders for some providers that assist in generating complex queries conveniently. This article demonstrates using the query builders for designing queries for JSON and XML providers.

Designing queries in JSON Query Designer

Follow the below steps to build a query using the JSON Query Designer. Our report already connects to the 'customers.json' data source available on GitHub.

  1. In the Report Explorer, right-click an existing data source and select the Add Data Set option.
  2. In the DataSet dialog box that appears, select the General page and enter the name of the dataset. By default, the dataset name is set to DataSet1.
  3. Navigate to the Query page and click the Edit with JSON Query Designer icon Edit in JSON Query Designer Icon to open the JSON Query Builder.
  4. Select a node from the data tree to generate the JSON path. The resulting JSON path is displayed at the bottom of the query builder.
    Edit in JSON Query Builder
  5. If you want to select multiple nodes and create separate datasets for each node, check the Allow to select multiple nodes and create separate dataset for each node option.
  6. Click the OK button to save the query.
  7. Verify the query by clicking the Validate DataSet Validate Dataset Icon icon. You can go to the Fields page to view the dataset fields fetched from the generated query.
  8. Click the OK button to close the DataSet dialog box and complete adding a dataset.

Designing queries in XML Query Designer

Follow the below steps to build a query using the XML Query Designer. Our report already connects to the 'factbook.xml' data source available on GitHub.

  1. In the Report Explorer, right-click an existing data source and select the Add Data Set option.
  2. In the DataSet dialog box that appears, select the General page and enter the name of the dataset. By default, the dataset name is set to DataSet1. This name appears as a child node to the Data Source node in the Report Explorer.
  3. Navigate to the Query tab and click the Edit with XML Query Designer icon Edit in XML Query Designer Icon to open the XML DataSet Query Builder.
  4. Select a node from the data tree to generate the XML path. The resulting XML path is displayed at the bottom of the query builder.
    Edit in XML Dataset Query Builder
  5. Click the OK button to save the changes.
  6. Verify the query by clicking the Validate DataSet Validate Dataset Icon icon in the DataSet dialog box. You can go to the Fields page to view the dataset fields fetched from the generated query.
  7. Click the OK button to close the DataSet dialog box and complete adding a dataset.

See Also

XML
JSON

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Query Builder in Microsoft SQL Client and OLEDB Providers

Query Builder in Microsoft SQL Client and OLEDB Providers
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset > Query Builder in Microsoft SQL Client and OLEDB Providers

Glossary Item Box

In a Page report or an RDLX report, you can use the Visual Query Designer for creating queries in Microsoft SQL Client and OLEDB data providers. The Visual Query Designer is a graphical interface that simplifies data binding by allowing users to interactively build queries and view the results. With its interactive interface, users who are unfamiliar with SQL can easily design, edit, preview, and save queries.

Visual Query Designer supports the following SQL capabilities, such as custom expressions, select fields and tables, sort and filter data, join tables, apply group and aggregate functions to fields, and set aliases for the selected fields and tables.

Visual Query Designer Interface

Interface Elements

Database view

The Database view appears on the left of the query builder. It displays the structure of the database including namespaces, tables, views, and columns based on the data source configuration details specified earlier. You can drag and drop or double click the elements in the Database view to add them to the Design tab. Alternatively, you can double-click the crossed arrow icon on the right-hand side of each element in the Database view to add it to the Design tab. This is the first step in query building through the Visual Query Designer. A SQL query is generated as you add the database elements to the Design tab.

Query Tools

The Visual Query Designer provides several tools to generate a query. The Query Tools appear on the right of the query builder and is broadly classified into the following three major areas:

  • Design tab
  • SQL tab
  • Toolbar buttons

Design tab

The Design tab is the area of the Visual Query Designer where you set up queries. It provides a visual interface for the SQL query you want to generate.

The Design tab consists of two panels: Selected Fields and Table and Relationships.

The Selected Fields panel displays the fields, tables, or any other element selected from the Database view. Each field in this panel has its own set of editable options.

Option | Description
Output

Determines whether the field will be included in the result set. By default, this checkbox is selected when a field is added to the Selected Fields panel. You can clear this checkbox if you do not want the field to be displayed in the Results panel.
Table | Displays the name of the table the selected field belongs to.
Alias | Allows the user to provide an alternative name for the field.
Total

Applies grouping or aggregates on a field. Total (expression) is used to perform a calculation, retrieve the value of a control, define regulations, create calculated fields, and define a group level for a report.

  • Expression - Allows the selection of fields from a table. Custom expressions can also be specified here.
  • GroupBy - Groups data based on the selected field.
  • Count - Returns the number of items in a group. Implements the SQL COUNT aggregate.
  • Avg - Returns the average of values in a group. Implements the SQL AVG aggregate.
  • Sum - Returns the sum of all the values in a group. Implements the SQL SUM aggregate.
  • Min - Returns the minimum value in a group. Implements the SQL MIN aggregate.
  • Max - Returns the maximum value in a group. Implements the SQL MAX aggregate.
  • StDev - Returns the statistical standard deviation of all the values in a group. Implements the SQL STDEV aggregate.
  • Var - Returns the statistical variance of all values in the group. Implements the SQL VAR aggregate.
Sort | Arranges data in a prescribed sequence i.e. in Ascending or Descending order. By default, this option is set to Unsorted.
Sort Order | Allows the user to set the order of sorting in case multiple fields are to be sorted.
Where | Allows the user to set a filtering condition for the column data. The WHERE clause can be used when you want to fetch any specific data from a table omitting other unrelated data.
Note: If you want to delete a field in the Selected Fields panel, hover the mouse cursor over the field and click the Delete button.

The Tables and Relationships panel displays a list of all the tables with fields in the Selected Fields panel. The Relations button at the bottom of the related table's name shows the relationship between two or more tables when associating rows of one table with the rows of another.

You can set up these relationships between tables using SQL Joins like Inner Join, Left Join, and Right Join in the Visual Query Designer. The relationship you set up between the data in these tables determines how the data appears in the result set.

  • Inner Join (simple join): It matches rows from table1 with rows in table2, and allows the user to retrieve rows that show a relationship in both the tables. Inner join produces a set of data that matches both table1 and table2.
    Query Syntax Copy Code
    SELECT table1_name.column_name FROM table1_name INNER JOIN table2_name ON table1_name.column_name = table2_name.column_name
  • Left Outer Join (left join) - It selects rows that match from both the left and right tables, plus all the rows from the left table (table1). This means only those rows from table2 that intersect with table1 appear in the result set.
    Query Syntax Copy Code
    SELECT table1_name.column_name FROM table1_name LEFT [OUTER] JOIN table2_name ON table1_name.column_name = table2_name.column_name
  • Right Outer Join (right join) - Right outer join allows users to select rows that match from both the left and right tables, plus all the rows from the right table (table2). This means that only those rows from table1 that intersect with table2 appear in the result set.
    Query Syntax Copy Code
    SELECT table1_name.column_name FROM table1_name RIGHT [OUTER] JOIN table2_name ON table1_name.column_name = table2_name.column_name

Use the Tables relations dialog box to set up a relationship between two different tables with at least one common field (or column). This dialog box automatically appears when you add another field from a different table in the Database view tab to the Selected Fields panel. Make sure that at least one field between these two tables matches. In other words, the second table should contain a foreign key corresponding to which the first table contains rows with a same primary key.

Table relations dialog box

The Tables relations dialog box provides the following options.

Option | Description
Join Type | Enables users to specify the join type for joining two tables. You can set the join type to Inner Join, Left Outer Join, and Right Outer Join.
<Table Name> Field | Displays the name of the field that is common between tables i.e. the foreign key name in the second table. Example: "Products" Field contains the 'Category ID' field in the image above.
Related table | Displays the name of the table to which the relationship has been set up.
Related table's field | Displays the name of the field from the table to which the relationship has been set up.
Delete | Deletes the currently added relation in the dialog.
Add Relation | Allows users to add another relationship to the table.

The Query Tools section also has a drop-down on the top right corner with the following two options.

  • Toggle Panels: Allows users to expand or collapse the Selected Fields and the Tables and Relationships panel.
  • Show Hints: Enables users to show or hide hints on how to use the Visual Query Designer effectively. For example, a hint is displayed on top of the Selected Fields panel saying - Double click the table or field name in the database view or drag and drop it here.

SQL tab

The SQL tab automatically generates an SQL query based on the options specified in the Designer tab. Here, you can also manually edit an existing query or create a new query.

Toolbar buttons

The options available through the toolbar buttons are elaborated in this table.

Option | Description
Distinct | Allows users to remove duplicate values from the result set of a SELECT statement. You can check this option to display only distinct values.
Execute | Allows users to execute their query and view the result in Results panel.
Save | Allows users to save the query to a DataSet dialog.
Clear | Allows users to clear all the panels in the Visual Query Designer and the SQL tab along with it.

Results panel

Displays the result of the query set in the Visual Query Designer.

This panel is populated when you click the Execute button on the Visual Query Designer toolbar after adding the required fields or tables in the Selected Fields panel.

Limitations

Following are few limitations of Visual Query Designer

  • Unions, nested queries, and stored procedures are not supported in the Design tab.
  • Crosses, full joins, provider-specific joins, and other SQL-specific implementation capabilities are not supported in the Design tab.

Designing queries in Visual Query Designer

Follow the below steps to build a query in the Visual Query Designer.

  1. In the Report Explorer, right-click an existing data source and select the Add Data Set option.
  2. In the DataSet dialog box that appears, select the General page and enter the name of the dataset. By default, the dataset name is set to DataSet1. This name appears as a child node to the Data Source node in the Report Explorer.
  3. Navigate to the Query tab and click the Edit with the Visual Query Designer icon Edit in Visual Query Designer Icon in the DataSet dialog box.

    The following sections describe the operations that you can perform in a Visual Query Designer.

    Add a field or table

    This is the primary step while designing queries in the query designer. There are two ways to add fields in the query.

    • Double-click the field name or table name in the Database view.
    • Drag the desired field or table from the Database view to the Selected Fields panel.

    Note: If you add a table to the Selected Fields panel, all the fields in that table are added to the query.
    Resultant Query Copy Code
    //Query for adding fields
SELECT table_name.field_name FROM table_name

//Query for adding a table
SELECT * FROM table_name

    Specify an alias for a field

    Alias is a temporary name given to a field for the duration of a query. You can specify an alias to make the field name more readable.

    1. Select the desired field in the Selected Fields panel.
    2. Go to the Alias option and enter the alias for the field in the space provided.
    Resultant Query Copy Code
    SELECT table_name.field_name AS alias_name FROM table_name

    Specify an alias for a table

    Alias is a temporary name given to a table for the duration of a query. You can specify an alias to make the table name more readable.

    1. Select the desired table in the Tables and Relationships panel.
    2. Go to the Alias option and enter the alias for the table in the space provided.
    Resultant Query Copy Code
    SELECT * from table_name AS alias_name

    Join tables

    If you want to combine rows from two or more tables, you need to join the tables based on a logical relationship between them. A Tables relation dialog box automatically appears when you add a field belonging to a different table. Use this dialog box to specify the relationships between the two tables.

    1. Drag and drop a field from a table in the Database view to the Selection Fields panel.
    2. Add another field from a different table in the Database view to the Selected Fields panel. The Tables relations dialog automatically pops up on the screen.
      Make sure that at least one field between these two tables matches, i.e., the second table should contain a foreign key corresponding to which the first table contains rows with a same primary key.
    3. Specify the Join Type you want to set for combining the two tables by clicking the Inner Join, Left Outer Join, or Right Outer Join button.
      The dialog box automatically picks the common field name present in both the tables, related table name, and related field name based on the fields selection. However, you can modify these details by clicking the associated drop-down arrows.
    4. Click OK to save the changes.
    Resultant Query Copy Code
    //Query for inner join
SELECT table1_name.column_name FROM table1_name INNER JOIN table2_name ON table1_name.column_name = table2_name.column_name

//Query for left outer join
SELECT table1_name.column_name FROM table1_name LEFT [OUTER] JOIN table2_name ON table1_name.column_name = table2_name.column_name

//Query for right outer join
SELECT table1_name.column_name FROM table1_name RIGHT [OUTER] JOIN table2_name ON table1_name.column_name = table2_name.column_name

    Delete a field

    When you delete a field from a query, the field remains in the database but is no longer used in the query.

    1. In the Selected Fields panel, hover your mouse over the field to display the Delete Delete Icon icon.
    2. Click the Delete icon to delete the field.

    Delete a table

    When you delete a table from a query, the table remains in the database but is no longer used in the query.

    1. In the Tables and Relationships panel, select the table you want to delete.
    2. Click the Close Close Button Icon icon. This will delete the selected table from the query.

    Sort data

    You can sort the fetched data in either ascending or descending order based on one or more fields in the table(s).

    1. Select the desired field in the Selected Fields panel.
    2. Go to the Sort option and choose one of the following options - Ascending or Descending. This will sort the field values in the chosen order.
    Resultant Query Copy Code
    SELECT * FROM table_name ORDER BY field_name ASC|DSC

    Filter data

    Applying filters allows you to fetch a specific data from a table that matches a certain criteria

    1. Select the desired field in the Selected Fields panel.
    2. Go to the Where option and enter the filter criteria with an required operator (like '=', '>', '<', '<>', etc). This will filter the rows based on the specified filter condition.
      If you want to filter the data based on a parameter value instead of a constant value, set the Where field to '=@<field name>'. This will generate a parameterized query that generally prompts the user to enter a value before the query is executed, to determine the type of data to be displayed in the result set.
    Resultant Query Copy Code
    SELECT * FROM table_name where [CONDITION]

    Apply aggregate functions and grouping

    You can group data on a field and create an aggregate query that involves a function such as Sum or Avg in the Visual Query Designer.

    1. Select the desired field in the Selected Fields panel on which you want to apply grouping or aggregate function.
    2. Go to the Total option and choose one of the following options from the drop-down - Expression, GroupBy, Count, Avg, Sum, Min, Max, StDev, and Var.
    Resultant Query Copy Code
    //Query for grouping data
SELECT * FROM table_name WHERE [CONDITION] GROUP BY table_name.field_name

//Query for aggregate functions
SELECT aggregate_function(table_name.field_name) FROM table_name WHERE [CONDITION]
  4. Preview the query using the Execute button in the Toolbar.
    You can save the query in the DataSet dialog box by clicking the Save button next to the Execute button.
  5. Click the Validate DataSet Validate Dataset Icon icon to verify the query in the DataSet dialog box. Go to the Fields page to view the dataset fields fetched from the generated query.
  6. Click the OK button to close the DataSet dialog box.

See Also

Microsoft OLEDB Provider

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Stored Procedure as Dataset

Stored Procedure as Dataset
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset > Stored Procedure as Dataset

Glossary Item Box

A stored procedure is a group of SQL statements that encapsulate a set of operations or queries to execute on a database.

Follow the below steps to add a parameterized stored procedure as a data set.

  1. First, Connect to OLEDB Data Source (here we will connect to Reels.mdb).

  2. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.

  1. In the Add Dataset that appears, select the General page and enter the name of the dataset as 'SalesDataForStore'. This name appears as a child node to the data source icon in the Report Explorer.
  2. On the Query page of this dialog, set the Command Type to 'StoredProcedure'.
  3. In the Query field, enter the stored procedure name (e.g. SalesDataForStore).
  4. Click the Validate icon Validate icon to validate the query.
    Note: You may get an error at this point since the required parameters have not yet been added.
  5. Go to the Parameters page and add a Parameter using the Add(+) button.
  6. On the same page, enter Name as StoreID and Value as 1002.
  7. Select the Query page of DataSet dialog, and click the Validate icon to validate the query and load the fields.
    Validate a Dataset Query with Stored Procedure
  8. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Dynamic JSON Connection String

Dynamic JSON Connection String
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset > Dynamic JSON Connection String

Glossary Item Box

You can enter a connection string for the JSON data as an expression and pass values using parameters to set up the data sources dynamically.

Let us create a tabular report where data in the table is fetched from a dynamically built JSON data source.

Create a Report

In the ActiveReports Designer, create a new RDLX report.

Add First Data Source

Connect to a Data Source

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter the name of the data source, 'Categories'.
  3. Under Type, select 'Json Provider'.
  4. In the Content tab, set the type of Json data to 'External file or URL'.
  5. In the Select or type the file name or URL field, enter the following URL: https://demodata.mescius.io/northwind/api/v1/Categories
    The Connection String tab displays the generated connection string as shown below:
    Connection String Copy Code
    jsondoc=https://demodata.mescius.io/northwind/api/v1/Categories
    For more information, see the JSON Provider topic.
  6. Verify the generated connection string by clicking the Validate DataSource Validate Icon in Report Data Source Dialog Box icon.
  7. Click OK to save the changes and close the Report Data Source dialog.

Add Dataset

  1. Right-click the added data source and select Add Dataset.
  2. In the Dataset dialog, select the General page and enter the name of the dataset, 'dsCategories'.
  3. Go to the Query tab and enter the following query to fetch the required fields:
    Dataset Query Copy Code
    $.[*]

Add a Parameter

  1. In the Report Explorer, right-click the Parameters node and select the Add Parameters option.
  2. In the Report - Parameters dialog box that appears, set the following:
    General tab
    Property | Value
    Name | paramCategories
    Data Type | String
    Text for prompting users for value | Select a Category
    Available Values tab (>From query)
    Property | Value
    Dataset | dsCategories
    Value field | categoryId
    Label field | categoryName
    Order By: Condition | Label
    Order By: Direction | Ascending
  3. Click OK.

Add Dynamically Built Data

Connect to a Data Source

  1. Right-click the Data Sources node in the Report Explorer and then select the Add Data Source option.
  2. In the dialog, select the General page and enter the name of the data source, 'Products'.
  3. Under Type, select 'Json Provider'.

    Let us first fetch the fields from data source using an external URL without expression, to fill the dataset fields collection. We will then replace the URL with an expression to create dynamic JSON connection string.
  4. In the Content tab, set the type of JSON data to 'External file or URL'.
  5. In the Select or type the file name or URL field, enter the following URL: https://demodata.mescius.io/northwind/api/v1/Categories/1/Products
  6. Click OK to close the dialog.

Add Dataset

  1. Right-click the added data source and select Add Dataset.
  2. In the Dataset dialog, select the General page and enter the name of the dataset, 'dsProducts'.
  3. Go to the Query tab and enter the following query to fetch the required fields:
    Dataset Query Copy Code
    $.[*]
  4. Click OK.

    Update Data Source Connection
  1. Edit the 'Products' data source.
  2. Go to the Content tab, select Expression, and enter the expression in the editor like the following:
    Update Expression in the Report Data Source connection
    Connection String Copy Code
    ="jsondoc=https://demodata.mescius.io/northwind/api/v1/Categories/"+[@paramCategories]+"/Products"
  3. Click OK.

Design Report Layout

Design view of the tabular report
  1. Drag and drop the Table data region onto the report's designer and set the DataSetName property to 'dsProducts'.
  2. Fill the details row of the table with the following fields:
    • =Fields!productName.Value
    • =Fields!unitPrice.Value
    • =Fields!UnitsInStock.Value
  3. To display the selected parameter, drag and drop a TextBox control above the table and enter the Value as =Parameters!paramCategories.Label.
  4. Press F5 to preview the report.
  5. Select a parameter from the drop-down and click View report.
Preview of the tabular report

See Also

JSON

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Nested Datasets (JSON and XML)

Nested Datasets (JSON and XML)
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Add Dataset > Nested Datasets (JSON and XML)

Glossary Item Box

A nested dataset represents JSON or XML data as an hierarchical structure. A nested JSON or XML dataset is most commonly used in a bound data region, where you can use the dataset nodes partially. For example, you can create a report with the Table data region, bound to the Customers dataset, and the nested List data region, bound directly to the nested dataset OrderDetails.
JSON nested dataset

Follow these steps to create a new RDLX report with a JSON nested dataset.

  1. In the ActiveReports Designer, create a new RDLX report.
  2. On the Choose Data Source Type screen of the wizard, select JSON and click Next.
  3. On the Configure JSON Path Connection screen, enter the following URL:
    https://demodata.mescius.io/northwind/odata/v1/Customers?$top=3&$expand=Orders($expand=OrderDetails,Shipper)
    and click Next.
  4. On the Configure JSON Queries screen, enter the name of the dataset, 'Customers', and in the Query field, specify $.value[*].
  5. On the Review and Confirm screen, click Finish.
  6. From the Toolbox, drag and drop the Table data region to the design area and set the data fields in the Table Details row to data values (CustomerId, CompanyName, and City) from the bound Customers dataset.
  7. Right-click the Table Details and select Insert Row Below.
    Table Bound to Nested Dataset
  8. From the Toolbox, drag and drop the List data region to a Table cell in the new row.
  9. Drag and drop the Textbox control to the List and set its Value to OrderID from the nested Orders dataset.
  10. Improve the appearance of the report and preview.
    Report with Nested Dataset at Design

See Also

Quick Start
JSON

Developers
Nested Datasets

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with Local Shared Data Sources

Work with Local Shared Data Sources
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Work with Local Shared Data Sources

Glossary Item Box

In ActiveReports, a shared data source refers to a file in RDSX format that contains data connection information. RDSX (Report Data Source XML) is a proprietary file format that functions as a data source for a single report or multiple reports.

You can use this data source in the Page report and the RDLX report.

Note: The WebDesigner and Blazor WebDesigner components uses the 'shared data source' approach to encapsulate the data connection on the server-side. See Configure and Use Shared Data Sources in WebDesigner and Configure and Use Shared Data Sources in Blazor Designer for more information.

Advantages of a shared data source

  • It is a reusable data connection that you can use in a single report or multiple reports.
  • It is a separate file in RDSX format that you can access from any report, move to different folders, and rename.
  • It sets the data connection in a report, so you need only add a SQL query to create a data set.
  • It lets you update the connection string in one place for all reports referencing the Shared Data Source.
  • You can use it with any data connection type.
    Note: An RDSX file contains the connection string, but you cannot define a data set in it. See Add a Dataset for information on creating a data set.

You can save a data connection type such as an OleDb connection, Json connection, or an XML connection as a Shared Data Source (RDSX). This topic provides the steps to create a shared data source with a data connection. Using shared data source, multiple reports can connect to a same data source. See Connect to a Data Source on how to connect a report to a data source.

Create a shared data source

  1. Right-click the data source in the Report Explorer and select Share Data Source option.

    Create a shared data source
  2. In the Save Shared Data Source File dialog that appears, enter the file name and click the Save button to save the file in RDSX format.
    Notice that the data source icon changes to show sharing.
    Data Source Icon | Shared Data Source Icon
    Data Source Icon | Shared Data Source Icon

Connect to a shared data source

In ActiveReports, you can connect to most data sources using the steps in the Connect to a Data Source. However, you need to follow the below steps to connect to a Shared Data Source.

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Select Shared Reference as the Type.
  4. Under Reference, from the drop-down list, select From File...
    Shared Datasource Setting
  5. In the Shared Data Source File dialog that appears, select the file and click Open on the lower right corner to close the dialog.
    A shared data source node appears in the Report Explorer.

Edit a shared data source

These steps assume that you have already connected your report to a shared data source.

  1. Open the Report Data Source dialog using any of the following ways:
    • In the Report Explorer, right-click a shared data source node and from the context menu, select Edit Shared Data Source.
      Edit Shared Data Source button in Report Explorer toolbar
    • In the Report Explorer, select the shared data source node, go to the Report Explorer toolbar and click the Edit Shared Data Source button.
      Edit Shared Data Source button in Report Explorer toolbar
  2. In the Report Data Source dialog that appears, edit the data connection information.
  3. Click OK to save the edits.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Nested Data Regions to Different Datasets

Bind Nested Data Regions to Different Datasets
See Also
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Bind Nested Data Regions to Different Datasets

Glossary Item Box

In Page and RDLX reports, you can use nested data regions that are bound to different datasets. To display data, you can either use a filter for a nested data region or a parameter that is set in the DataSetParameters property.

Binding data regions to different data is available for all data regions that you can use in Page and RDLX reports, that is Tablix, List, Chart, BandedList, Table, and Sparkline.

The report below shows the customer's contact name and phone information for products that are still in stock. The report layout consists of three nested Table data regions, each data region bound to a different dataset - Products (Table1), Invoices (Table2), and Customers (Table3).

Nested Data Regions at design-time

Nested Data Regions at run-time

Using a filter

To display data in nested data regions that are bound to different data, you can set a filter in the Table - Filters dialog. This filter will contain the value from a nested data region in the left side and the value from a parent data region in the right side of it.

In the sample report above, two filters are created. For the Table2 data region bound to the Invoices dataset, we create the filter with the expression [ProductID]=[ProductID]. For the Table3 data region bound to the Customers dataset, we create the filter with the expression [CustomerID]=[CustomerID].

As a result, the report shows the Product Name and Units In Stock information from the Products dataset. For each Product Name, the report shows the Customer Name information from the Invoices dataset and the Contact Name and Phone information from the Customers dataset.

Using a parameter

Setting a parameter in the DataSetParameters property also allows displaying data in nested data regions that are bound to different datasets. The basic steps are as follows.

  1. In the DataSetParameters property of a data region, add a new parameter, for example, productID.

  2. In the data region’s dataset, add a new parameter - productID.
  3. In the data region’s dataset, add a substring with the parameter to the existing dataset query, for example: WHERE productID = @productID
     DataSet - Query dialog box

For the sample report layout above, two parameters are created. For the Table2 data region, bound to the Invoices dataset, we create the parameter productID and modify the dataset query as select * from Invoices where productID = @productID. For the Table3 data region, bound to the Customers dataset, we create the parameter customerID and modify the dataset query as select * from Invoices where customerID = @customerID.

As a result, the report shows the Product Name and Units In Stock information from the Products dataset. For each Product Name, the report shows the Customer Name information from the Invoices dataset and the Contact Name and Phone information from the Customers dataset.

See Also

Demo: Nested Controls

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Dataset/Object Provider

Dataset/Object Provider
Report Authors > Data Binding > Data Binding in Page/RDLX Reports > Dataset/Object Provider

Glossary Item Box

The data source and data set for DataSet Provider and Object Provider data types can be set at run time.

You can find set of topics describing various scenarios, such as binding to Entity Framework, SQL, OLEDB, and ODBC; CSV, JSON and XML Data Providers and dynamic connection string under Bind a Page/RDLX Report to Data topic.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Binding in Section Reports

Data Binding in Section Reports
Report Authors > Data Binding > Data Binding in Section Reports

Glossary Item Box

Setting up a connection to the data source is the first step in binding data to the report. Once a successful connection is established, a query is required to get the data you want to show in the report.

Data Sources

In Section reports, you can set the data source information in the Report Data Source dialog properties.

The Report Data Source dialog is where you select the type of data to use, provide a connection string, create a query string, and choose other options for your data source. You can also control the timeout period and select a method for handling credentials. Once you add a data source, its fields appear under the Bound node in the Report Explorer. You can also add calculated fields in a section report.

To quickly build the query strings, ActiveReports provides a JSON Query Designer for JSON provider, and a Visual Query Designer for OLEDB and SQL providers.

Note: The Chart data region in Section reports have their own data sources and should be bound separately, similar to how the main report is bound.

Supported Data Providers

The supported data providers for designing section reports are:

  • OLEDB Provider
  • ODBC Provider
  • SQL Provider
  • XML Provider
  • CSV Provider
  • JSON Provider
  • Unbound Provider

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Connect to a Data Source

Connect to a Data Source
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source

Glossary Item Box

At design time, you can connect a section report to a data source through the Report Data Source dialog. This topic describes the steps to connect to a data source in a section report.

Add a Data Source

Use the following steps to add a new data source in your report.

  1. In the designer, you can access the Report Data Source dialog by doing one of the following:
    • On the detail section band, click the Data Source icon.
      Data Source Icon
    • Click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog box that appears, there are separate tabs for each data source. For example,
    • OLEDB
    • ODBC
    • SQL
    • XML
    • CSV
    • JSON
    • Unbound
    Report Data Source Dialog Box
  3. Each tab displays different options/settings to configure the data source connection.
  4. Enter the configuration details for the data source connection.
  5. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to a data source.

Custom Data Providers

You can also implement some custom data providers such as SQLite, by manually setting up the dependencies and configuration file. See Bound Data sample for complete implementation and Configure ActiveReports using Config File topic for information on setting up the configuration file.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


OLEDB Provider

OLEDB Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > OLEDB Provider

Glossary Item Box

This article explains connecting a Section report to an OLEDB data source.

Note: The OLEDB model depends on the installed drivers.

Connect to an OLEDB Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the OLE DB tab to connect to an OLEDB data source.
    Connect to an OLEDB Data Provider
  3. Click the Build button next to the Connection String section to open the Data Link Properties dialog box.
    Data Link Dialog Box
  4. In the Providers tab, specify the OLEDB provider you want to use to connect to the data source. For example, select Microsoft JET 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
    The fields in the Connection tab depends on the chosen OLEDB provider. For more information, see the Configuration Settings for OLEDB Data Source.
  5. To specify the path for the file, click the ellipsis (...) button and navigate to the desired folder on your system. For example, you can connect to the 'NWIND.mdb' sample data source which can be downloaded from GitHub.
    Connection Tab in Data Link Properties dialog box
  6. Click the Test Connection button to see if you have successfully connected to the database.
  7. Then, click the OK button to close the Data Link Properties dialog box.
    The Connection String section displays the generated connection string as shown below:
    Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\NWIND.mdb;Persist Security Info=False
  8. In the Command Timeout field, specify the wait time (in seconds) for a command to execute. The default value is 30 seconds.
  9. In the Query field on the OLE DB tab, enter a SQL query to fetch the required data from the connected database. For example,
    SELECT * FROM Customers
    You can also click the Query Designer button to access the Visual Query Designer for creating SQL queries. For information on how to create a query using the interactive query designer, visit the Visual Query Designer article.
  10. Click the OK button to save the changes.

Configuration Settings for OLEDB Data Source

The OLEDB Data Provider provides the following configuration settings in the Report Data Source dialog.

The Provider tab describes the type of OLEDB provider you want to use for connecting to a data source. You can choose from the following -

  • Microsoft JET 4.0 OLE DB Provider
  • Microsoft Office 12.0 Access Database Engine OLE DB Provider
  • Microsoft Office 16.0 Access Database Engine OLE DB Provider
  • Microsoft OLE DB Provider for ODBC Drivers
  • Microsoft OLE DB Provider for Oracle
  • Microsoft OLE DB Provider for Search
  • Microsoft OLE DB Provider for SQL Server
  • Microsoft OLE DB Simple Provider
  • MS Data Shape
  • OLE DB Provider for Microsoft Directory Services
  • SQL Server Native Client 11.0

The Connection tab specifies the properties required for accessing the data. The properties in the tab depend upon the OLEDB provider you want to use.

For Microsoft JET 4.0 OLE DB Provider and Microsoft OLE DB Provider, following properties are available in the Connection tab -

Setting | Description
Select or enter a database name | Enter a server or a file name along with its location.
Enter information to log on to the database | Specify the username and password required to access the database.

For Microsoft Office 12.0 Access Database Engine OLE DB Provider, Microsoft Office 12.0 Access Database Engine OLE DB Provider, Microsoft OLE DB Provider for ODBC Drivers, Microsoft OLE DB Simple Provider, MS Data Shape, and OLE DB Provider for Microsoft Directory Services, following properties are available in the Connection tab -

Setting | Description
Enter the data source and/or location of the data | Enter a server or a file name along with its location.
Enter information to log on to server | Select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
Enter initial catalog to use | Specify the name of the database you want to connect.

For Microsoft OLE DB Provider for SQL Server and SQL Server Native Client 11.0, following properties are available in the Connection tab -

Setting | Description
Select or enter server name | Select your server from the drop down list.
Enter information to log on to the server | Select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
Select the database on the server | Select a database from the server or attach a database file.

The Advanced tab gives access to the initialization properties required by the chosen OLEDB provider.

Setting | Description
Impersonation Level | Set the impersonation level to any of the following options - Anonymous, Delegate, Identify, and Impersonate.
Protection Level | From the drop down, choose Call, Connect, None, Pkt, Pkt Integrity, or Pkt Privacy.
Connect Timeout | Specify the amount of time (in seconds) for a connection to establish.
Access Permissions | Specify the access permissions on the database, such as Read, ReadWrite, Share Deny None, Share Deny Read, and Share Deny Write.
Note: In case of SQL Server Native Client 11.0 provider, only the Connect Timeout setting is available.

The All tab lets you view and edit the initialization properties available for the selected OLEDB provider. These properties can differ based on the OLEDB provider you want to use.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ODBC Provider

ODBC Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > ODBC Provider

Glossary Item Box

This article explains connecting a Section report to an ODBC data source.

Note: The ODBC model depends on the installed drivers.

Connect to an ODBC Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the ODBC tab to connect to an ODBC data source.
    Connect to an ODBC Data Provider
  3. Under the Connection section, enter the connection string to connect to an ODBC data source. The following sample connection string specifies the type of the ODBC Driver along with location of the file required for an ODBC data source connection.
    For example, you can connect to the NWIND.mdb sample data source which can be downloaded from GitHub.
    Driver=Microsoft Access Driver (*.mdb);Dbq=C:\NWIND.mdb;
  4. In the Command Timeout, specify the wait time (in seconds) for a command to execute. The default value is 30 seconds.
  5. On the same page under the Query section, enter a SQL query to retrieve the data from the connected data source. For example,
    SELECT * FROM Orders
  6. Click the OK button to save the changes and close the Report Data Source dialog box.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


SQL Provider

SQL Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > SQL Provider

Glossary Item Box

This article explains connecting a Section report to a SQL data source.

Connect to a SQL Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the SQL tab to connect to a SQL data source.
    Connect to a SQL Data Provider
  3. Click the Build button next to the Connection String section to open the Data Link Properties dialog box.
    Data Link Dialog Box
  4. In the Providers tab, specify the OLEDB provider you want to use to connect to the data source. For example, select Microsoft OLE DB Provider for SQL Server and click the Next button to move to the Connection tab.
    The fields in the Connection tab depends on the chosen OLEDB provider. For more information, see the Configuration Settings for SQL Data Source.
  5. In the Connection tab, enter the server name that you want to connect.
    Connection tab of Data Link Dialog box
  6. To specify the authentication method for the data source connection, select the Use Windows NT Integrated security or Use a specific username and password option.
    If you choose the Use a specific username and password option, enter the user name and password in the respective fields. Note: The User name and Password fields are disabled in case of Windows authentication.
  7. Click the dropdown next to the Select the database on the server field and choose the database you want to use.
  8. You can verify the data source connection through the Test Connection button.
  9. Then, click the OK button to close the Data Link Properties dialog box.
    The Connection String section displays the generated connection string as shown below:
    data source=10.64.1.85\sql_2k8r2;persist security info=False;initial catalog=auditing;user id=sa;password=**********;
  10. In the Query field on the SQL tab, enter a SQL query to fetch the required data from the connected database. For example,
    SELECT * FROM Location
    You can also click the Query Designer button to access the Visual Query Designer for creating SQL queries. For information on how to create a query using the interactive query designer, visit the Visual Query Designer article.
  11. Click the OK button to save the changes.

Configuration Settings for SQL Data Source

The SQL Data Provider provides the following configuration settings in the Report Data Source dialog.

The Provider tab describes the type of OLEDB provider you want to use for connecting to a data source. You can choose from the following -

  • Microsoft JET 4.0 OLE DB Provider
  • Microsoft Office 12.0 Access Database Engine OLE DB Provider
  • Microsoft Office 16.0 Access Database Engine OLE DB Provider
  • Microsoft OLE DB Provider for ODBC Drivers
  • Microsoft OLE DB Provider for Oracle
  • Microsoft OLE DB Provider for Search
  • Microsoft OLE DB Provider for SQL Server
  • Microsoft OLE DB Simple Provider
  • MSDataShape
  • OLE DB Provider for Microsoft Directory Services
  • SQL Server Native Client 11.0

The Connection tab specifies the properties required for accessing the data. The properties in the tab depend upon the OLEDB provider you want to use.

For Microsoft JET 4.0 OLE DB Provider and Microsoft OLE DB Provider, following properties are available in the Connection tab -

Setting | Description
Select or enter a database name | Enter a server or a file name along with its location.
Enter information to log on to the database | Specify the username and password required to access the database.

For Microsoft Office 12.0 Access Database Engine OLE DB Provider, Microsoft Office 12.0 Access Database Engine OLE DB Provider, Microsoft OLE DB Provider for ODBC Drivers, Microsoft OLE DB Simple Provider, MSDataShape, and OLE DB Provider for Microsoft Directory Services, following properties are available in the Connection tab -

Setting | Description
Enter the data source and/or location of the data | Enter a server or a file name along with its location.
Enter information to log on to server | Select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
Enter initial catalog to use | Specify the name of the database you want to connect.

For Microsoft OLE DB Provider for SQL Server and SQL Server Native Client 11.0, following properties are available in the Connection tab -

Setting | Description
Select or enter server name | Select your server from the drop down list.
Enter information to log on to the server | Select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
Select the database on the server | Select a database from the server or attach a database file.

The Advanced tab gives access to the initialization properties required by the chosen OLEDB provider.

Setting | Description
Impersonation Level | Set the impersonation level to any of the following options - Anonymous, Delegate, Identify, and Impersonate.
Protection Level | From the drop down, choose Call, Connect, None, Pkt, Pkt Integrity, or Pkt Privacy.
Connect Timeout | Specify the amount of time (in seconds) for a connection to establish.
Access Permissions | Specify the access permissions on the database, such as Read, ReadWrite, Share Deny None, Share Deny Read, and Share Deny Write.
Note: In case of SQL Server Native Client 11.0 provider, only the Connect Timeout setting is available.

The All tab lets you view and edit the initialization properties available for the selected OLEDB provider. These properties can differ based on the OLEDB provider you want to use.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


XML Provider

XML Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > XML Provider

Glossary Item Box

This article explains connecting a section report to an XML data source.

Connect to an XML Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the XML tab to connect to an XML data source.
    XML Tab in Report Data Source Dialog
  3. Click the Ellipsis (...) button next to File URL field select the <Browse...> option to specify the XML file path. For example, you can connect to the Factbook.xml sample data source which can be downloaded from GitHub.
  4. In the Recordset Pattern field, enter a valid XPath expression. For example,
    XPath Expression Copy Code
    //countries
    For more information about the XPath expressions, please see https://www.w3schools.com/xml/xpath_intro.asp.
  5. Click the OK button to close the Report Data Source dialog. Your report is now connected to the XML data source successfully.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CSV Provider

CSV Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > CSV Provider

Glossary Item Box

This article explains connecting a section report to a CSV data source.

Connect to a CSV Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the CSV tab to connect to a CSV data source.
  3. Click the Build button next to the Connection String section to open the Configure CSV Data Source dialog box.
    Configure CSV Data Source Wizard
  4. To specify the Path of the file, click the Open button and navigate to the desired folder on your system. For example, you can connect to the MyOrders.csv sample data source which can be downloaded from GitHub.
  5. Select the Column Separator as Comma from the drop-down menu.
  6. Click the Get from Preview button to fill the Columns area with the column names and their corresponding data types (string by default) present in the CSV file. This allows you to modify the name and data type (like String, Boolean, DateTime, Integer, Float, Decimal, Double, or Long) for the columns.
    For more information, see the Configuration Properties for CSV Data Source section.
  7. Click the OK button to save the changes and close the Configure CSV Data Source dialog.
    Configure CSV Data Source Wizard

    The Connection String section displays the generated connection string as shown below:
    Connection String Copy Code
    Path=C:\\MyOrders.csv;Locale=en-IN;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;Columns=ID,Product,Customer,OrderNumber,Stock,Total(Decimal),UnitPrice(Decimal),City,ProductLine,Discount(Decimal);HasHeaders=True
  8. Click the OK button to close the Report Data Source dialog. Your report is now connected to the CSV data source successfully.

Configuration Settings for CSV Data Source

The CSV Data Provider provides the following configuration settings in the Configure CSV Data Source dialog. Based on the defined configuration settings, the CSV connection string is generated.

Setting | Description | Example
Path | Path to the CSV file - both local and relative; or a URL for centrally located CSV data sources. | C:\MyOrders.csv
Encoding | Specify the character encoding used in the CSV file. | Unicode (UTF-8)
Locale | Specify the locale used in the CSV file. | English (United States)
File Type | Define the type of CSV file. You can choose from Fixed and Delimited options. | Delimited
Starting Row | Row number to start fetching data. | 0
Text Qualifiers | Character to specify where the text begins and ends, that is, the character that encloses values in the CSV file. You can choose from Quotes and Single quotes options. | Quotes
Columns have headers | Specify whether the CSV file has columns with headers or not. | Checked
Column Separator | Specify the symbol used to separate the columns in the CSV file. You can choose from Comma, Semicolon, Tab, and Space options. | Comma
Row Separator | Symbol used to separate the rows in the CSV file. You can choose from CRLF (carriage return and line feed), CR (carriage return), and LF (line feed) new line formats. | New line (CRLF)
Treat consecutive as one | Specify whether to join the column separators or row separators as one. | Checked for Column separator Unchecked for Row Separator
Get from preview | Fills the Columns area with names and data types (string by default) for columns present in the CSV file. This allows you to modify the name and data type (like String, Boolean, DateTime, Integer, Float, Decimal, Double, or Long) for the columns. | UnitPrice(Decimal)
Note: Text Qualifiers, Column Separator, Row Separator, and Treat Consecutive as one options are not available for Fixed file type.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


JSON Provider

JSON Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > JSON Provider

Glossary Item Box

This article explains connecting a Section report to a JSON data source.

Connect to a JSON Data Source

  1. In the designer, select the Data Source icon on the Detail section of the report or click the gray area around the design surface and select the Edit Data Source link in the Properties pane.
  2. In the Report Data Source dialog that appears, select the JSON tab to connect to a JSON data source.
    Connect to a JSON Data Provider
  3. The External file or URL option is selected by default. Click the Build button next to the Connection String section to open the Configure JSON Data Source dialog box.
    Configure JSON Data Source Dialog Box
  4. To specify the Data Path of the file, click the Open button and navigate to the desired folder on your system. For example, you can connect to the 'Customers.json' sample data source which can be downloaded from GitHub.
    For more information, see the Configuration Settings for JSON Data Source.
  5. Click OK to save the changes and close the Configure JSON Data Source dialog box.
    The Connection String section displays the generated connection string as shown below.
    Connection String Copy Code
    jsondoc=C:\Customers.json
  6. In the JSON Path field, enter a valid JSON Path expression or click the Build button to generate the path using the JSON query designer.
    JSON Path Copy Code
    $.Customers

    For more information on JSON Path expressions, please visit this article.
  7. Click the OK button to save the changes.
    JSON Configuration Details

Configuration Settings for JSON Data Source

The JSON Data Provider provides the following configuration settings under the Connection section in the Report Data Source dialog.

  • External file or URL: Enter the path or URL of an external JSON data file or select the file from the drop-down which displays the JSON files available in the same folder as the report. The connection string generated using this option starts with the keyword jsondoc.
  • Embedded: Enter the path of the JSON data file to embed in the report. You can provide JSON data manually or select a JSON file containing the data. The connection string generated using this option starts with the keyword jsondata.

The JSON Data Provider provides the following configuration settings in the Configure JSON Data Source dialog box.

  • Data Path: Path or URL of an external JSON data file or select the file available on the system using the Open button. You can also pass parameters (including report parameters) to the URL. For example, https://demodata.mescius.io/northwind/odata/v1/customers?$top=7&$orderby=Country.
    The connection string generated starts with the keyword jsondoc.
  • HTTP Headers: Contains information related to authorization. Here you provide the expected content type, bearer token, etc. necessary for establishing the connection. For example, providing credentials to log in to a service/URI to retrieve data.
  • HTTP Method: The HTTP request method, it can either be set to GET (included in URL) or POST (included in Request Body). POST requests allow defining a body as an expression to obtain data.
  • Request Body: Body for the POST request method. The text area is enabled only when the HTTP Method is set to POST.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Unbound Provider

Unbound Provider
Report Authors > Data Binding > Data Binding in Section Reports > Connect to a Data Source > Unbound Provider

Glossary Item Box

The data source and data set for Unbound Provider data type can be set at run time. For more information, see Bind Data Set and Unbound Data to Section Report at Run Time.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Design Reports

Design Reports
See Also
Report Authors > Design Reports

Glossary Item Box

An important milestone in the process of report authoring is designing a report. ActiveReports.NET lets you design Page/RDLX as well as Section reports. This topic gives you an overview about the tutorials, aimed at designing different types of reports in ActiveReports.

  • Design Page/RDLX Reports
  • Design Section Reports

See Also

Developers
Work with Reports using Code

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Design Page/RDLX Reports

Design Page/RDLX Reports
Report Authors > Design Reports > Design Page/RDLX Reports

Glossary Item Box

ActiveReports Designer supports designing useful Page/RDLX reports. This section covers a wide range of topics to transform data into meaningful insights:

Layout

Learn the different types of layout options for your Page/RDLX reports.

Report Dialog

Learn about the features available through report dialog in Page/RDLX reports.

Master Report (RDLX Report)

Learn about using master reports.

Layers

Learn about layers that can overlay with other group of controls on a Page or an RDLX report.

Expressions

Learn about expressions that you can use in reports.

Data Visualizers

Learn about Data Visualizers that let you create small graphs to make data easily comprehensible.

Filters

Learn about filters in Page and RDLX reports,

Groups

Learn about grouping data in Page and RDLX reports,

Interactivity

Learn about the features in RDLX and Page reports that support interactive capabilities.

Scripts

Learn how to use VB script in Page and RDLX reports.

Report Appearance

Learn about customizing the appearance of reports.

Tutorials: Report Controls in Page/RDLX Reports

Learn how to design the Page and RDLX reports in the Report Designer.

Tutorials: Page/RDLX report Scenarios

Learn how to use Page/RDLX report tutorials to create different types of report scenarios.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Layout

Layout
Report Authors > Design Reports > Design Page/RDLX Reports > Layout

Glossary Item Box

ActiveReports provides a wide range of layout options for your Page/RDLX report that you can easily control by using the specific properties.

Page/RDLX reports allow to create a very powerful layout. Here we show a few base use-cases and tutorials. ActiveReports provides a wide range of layout options for your Page/RDLX report that you can easily control by using the specific properties.

In this section

Set Page Size, Margins, and Orientation in Page Reports
Learn about the options to control page layout properties such as page size, page margins, and page orientation. These options allow you to define the layout settings for each page in a Page report.

Skip Page Generation in Page Reports
The topic shows how to hide or show a page when you preview a Page report.

Set Page Layout in Z- or N-Order
A report may have horizontally or vertically growing data rendered across multiple pages during the preview. In this case you can use the LayoutPagesOrder property of the report to specify the page layout order for a Page or an RDLX report. ActiveReports supports two types of page layout order, Z-Order or N-Order.

Manage Blank Rows in a Table Data Region in Page Reports
Learn about the RepeatBlankRows property and how to use it when creating different report layouts.

Hide or Show Sections in RDLX and RDLX Dashboard Reports
The topic shows how to hide or show the sections in reports with multiple sections.

Keep Groups Together in Data Regions
You can keep the contents of a group together on a single page by setting the Keep Together on one page if possible option (Table group) or the KeepTogether property (Tablix row group).

Manage Page Breaks in Data Regions
You can control page breaks in data groups of data regions by using the NewPage property for data regions and its combination with the PageBreakAtStart, PageBreakAtEnd, and BreakLocation properties. These properties help you tune page breaks after or before a data group in your report and on which page to continue displaying the report content.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set Page Size, Margins, and Orientation in Page Reports

Set Page Size, Margins, and Orientation in Page Reports
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Set Page Size, Margins, and Orientation in Page Reports

Glossary Item Box

Page layout properties such as page size, page margins, and page orientation define how the report pages appear when previewed or printed. While a report's layout can be set for a report, you can also control the layout settings for each page in a Page report.

You should note that Page reports make use of Overflow Place Holder control to handle overflowing data on multiple pages, with a data region placed on the first page of the report and the OverflowPlaceHolder controls on subsequent pages. See how data in a Page report flows from the first page to the next in OverflowPlaceholder Control for Columnar Reports tutorial.

Page Size

You can change the default page size using the PageSize property of the page from the Properties panel and set it to the standard sizes such as Letter, Tabloid, Legal, Statement, Executive, A3, A4, A5, B4 (JIS), and B5 (JIS). You can also manually input the values in the Width and Height properties to customize the page size.

Page Margins

Page margin is a space between the edge and the content on your report page. You can set the page margins using the Margins property of the page from the Properties panel. By default, the value of page margins (left, right, top, and bottom) is set to 1 in.

Page Orientation

The Page or paper orientation is how the rectangular report page is oriented. While Portrait orientation is suitable for the text expanding in a vertical direction, Landscape orientation is suitable for horizontally expanding content like in Tablix data regions. You can specify the report page orientation using the PaperOrientation property of the page from the Properties panel. By default, the PaperOrientation property is set to Portrait.

Mixed Page Orientation

You can mix Portrait and Landscape page orientations in a report depending on the data being rendered on the pages. For example, in the employee database handbook report shown below, the front page contains a general introduction inside TextBox controls about the following pages, which contain details on the employees. While the front page looks clear in Portrait, the rest of the pages where the data is wider with a Table data region and an OverflowPlaceholder control side-by-side, the Landscape orientation makes more sense.

Page Orientation - Portrait and Landscape

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Skip Page Generation in Page Reports

Skip Page Generation in Page Reports
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Skip Page Generation in Page Reports

Glossary Item Box

In ActiveReports, you can easily hide the pages in a Page report at run time using the visibility properties.

The visibility properties for a report page can be set using the Hidden property.

In the rendered report, the page generation for the hidden pages is skipped.

Hidden Property

This property controls the visibility of the report page based on the expression that you specify or the value you set, that is, True or False. If you want to hide the report page, set the property to True. In case you want to conditionally hide the report page, enter a suitable expression.

Consider a scenario where a Page report contains three pages: Page 1, Page 2, and Page 3.

  • Page 1 of the report consists of the report header and order summary details,
  • Page 2 of the report contains the overflowing content of Page 1, that is, order summary details, and
  • Page 3 consists of a receipt. You want the page generation for Page 3 to skip in case the order amount or the amount paid is zero.

For the report pages to appear in this manner, you need to set the Hidden property for Page 3 to the expression like follows, which calculates the order amount and hides the receipt page in case the order amount calculates to zero:

Copy Code
=iif(Sum(Fields!Quantity.Value*Fields!UnitPrice.Value)=0, True, False)

This is how the three pages of an order in a report are rendered when the order amount is not zero:

Skip Page Generation

When the order amount is zero, only the first two pages of the order are rendered and the receipt page is skipped:

Skip Page Generation

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set Page Layout in Z- or N-Order

Set Page Layout in Z- or N-Order
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Set Page Layout in Z- or N-Order

Glossary Item Box

If a report has horizontally or vertically growing data rendered across multiple pages during the preview, you may want the preview to show the report pages in a particular order.

Using the LayoutPagesOrder property of the report, you can specify the page layout order for a Page or an RDLX report. There are two types of page layout order, Z-Order or N-Order, supported in ActiveReports as explained below.

Z-Order

The Z-order renders the report in the shape of the alphabet 'Z'. This means the horizontally expanding data in the report is rendered first on the upcoming pages followed by the vertically expanding data.

A report in Multipage view with page layout order set to Z-order is as shown. Note the page layout order: 1A -> 1B -> 1C -> 2A -> 2B -> 2C ->3A -> 3B -> 3C.

Z order page layout

Note: The LayoutPagesOrder property does not affect the page layout when exporting to CSV, JSON, XML, CSV, Excel Data, or DOCX file format.

N-Order

The N-order renders the report in the shape of the alphabet 'N'. This means the vertically expanding data in the report is rendered first on the upcoming pages followed by the horizontally expanding data.

A report in Multipage view with page layout order set to N-order is as shown. Note the page layout order: 1A -> 2A -> 3A -> 1B -> 2B -> 3B -> 1C -> 2C -> 3C.
N order page layout

Set a Z- or N-Order in Report

  1. From the Report Explorer, select the Report node.
  2. Go to the Properties panel, set the LayoutPagesOrder property to 'ZOrder' or 'NOrder'.
    Or,
  1. From the Report Explorer, select the Report node.
  2. Click the Property dialog... to open the Report dialog
  3. From the Appearance page, set Pages layout order to 'Z-order' or 'N-order'.

Layout Order in RDLX Reports

In RDLX reports, controls or data regions grow vertically or horizontally to accommodate data. In an RDLX report with a Tablix data region, if the tablix data is too large to fit inside a single page, the data expands over multiple pages in both horizontal and vertical directions. The following image shows the preview of such a report in Z-order.

(For an enlarged image view, open the image in a separate tab.)
Z order layout

The following image shows the preview of the above report in N-order.

(For an enlarged image view, open the image in a separate tab.)

N order layout

Layout Order in Page Reports

In a Page report, controls or data regions do not change in size based on the data. To handle expanding or overflowing data on multiple pages, Page reports use Overflow Place Holder control, with a data region placed on the first page of the report and the OverflowPlaceHolder controls on subsequent pages.

The following image shows the preview of a Page report with a Tablix data region on one page and an Overflow Place Holder control on the next page in Z-order.

(For an enlarged image view, open the image in a separate tab.)

Z order page layout

The following image shows the preview of the above report in N-order.

(For an enlarged image view, open the image in a separate tab.)

Z order page layout

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Manage Blank Rows in a Table Data Region in Page Reports

Manage Blank Rows in a Table Data Region in Page Reports
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Manage Blank Rows in a Table Data Region in Page Reports

Glossary Item Box

Table data region in Page report has RepeatBlankRows property that lets you control the behavior of blank rows with the help of options:

  • None: indicates no filling of extra space with blank rows.
  • FillPage: fills the empty space within a page with blank rows, to reach the table's FixedHeight. Note that this setting is equivalent to property RepeatToFill property (obsolete) set to 'True'.
  • FillGroup: fills the table with blank rows within a group.

The following image shows the last page of a report with Table data region's RepeatBlankRows property set to 'FillPage'.

Repeat Blank Rows

The following image shows the last page of a report with Table data region's RepeatBlankRows property set to 'None'.

Repeat Blank Rows

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Hide or Show Sections in RDLX and RDLX Dashboard Reports

Hide or Show Sections in RDLX and RDLX Dashboard Reports
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Hide or Show Sections in RDLX and RDLX Dashboard Reports

Glossary Item Box

The RDLX and RDLX Dashboard Reports are reports with multiple sections. You can control the visibility of the initial state of a section using Hidden property.

Hidden property

This property controls the visibility of the report sections based on the expression that you specify or the value you set, that is, True or False. If you want to hide the report page, set the property to True. In case you want to conditionally hide the report page, enter a suitable expression.

Conditionally hide/show a report section

Let us assume that the report has few sections and we want to hide one of the sections. The procedure to hide a section in RDLX and RDLX Dashboard Reports based on user input is described below.

  1. Create a report parameter. In the Report - Parameters dialog, set the following:
    • in General tab:
      • Name: ShowHideParam
      • Data type: Boolean
      • Text for prompting users for a value: Select whether to hide the section
    • in Default Values tab:
      • select Non-queried option
      • Value: false
  2. Select the ReportSection/Section tab of the report that you want to hide.
  3. Go to the Hidden property of the section and enter the expression as shown:
    Copy Code
    =IIF(Parameters!ShowHideParam.Value=True, True, False)
  4. Preview the report.
  5. From the Parameters panel, select 'True' to hide the section.
    Similarly, for the hidden section to show, select 'False'.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Keep Groups Together in Data Regions

Keep Groups Together in Data Regions
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Keep Groups Together in Data Regions

Glossary Item Box

In Table and Tablix data regions of Page and RDLX reports, you can choose to keep the contents of a group together on a single page.

  • For the Table data region, this feature is available as the Keep Together on one page if possible option for a group's layout.
  • For the Tablix data region, this property is available as KeepTogether property in the properties panel for a row group's layout.

With the option selected or the property set to true, you can keep the content of a group (details row along with the group header and the group footer) together on the same page. For example, you can choose to print the grouped data - all on one page instead of printing across multiple pages. The group is attempted to be printed on a single page with no page breaks if possible. In case the group is too large to fit on the current page or the next page, the feature is ignored and the groups split across the report pages.

Table Data Region

In the following image, Keep Together on one page if possible option is selected for a table group in Page report, hence the table groups appear together (if possible) across the pages.

(For an enlarged image view, open the image in a separate tab.)

Table Group with Keep Group Together

In the following image, Keep Together on one page if possible option is unselected for a table group in Page report, hence the table groups split across the pages.
(For an enlarged image view, open the image in a separate tab.)

Table Group Not Set to Keep Group Together

Tablix Data Region

In the following image, KeepTogether property for the parent row group of tablix in Page report is set to True, hence the tablix row group appear together (if possible) across the pages.

Tablix Group with Keep Group Together

In the following image, KeepTogether property for the parent row group of tablix in Page report is set to False, hence the tablix group splits across the pages.

Tablix Group Not Set to Keep Group Together

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Manage Page Breaks in Data Regions

Manage Page Breaks in Data Regions
Report Authors > Design Reports > Design Page/RDLX Reports > Layout > Manage Page Breaks in Data Regions

Glossary Item Box

You can control page breaks in data groups of data regions by using the NewPage property for data regions and its combination with the PageBreakAtStart, PageBreakAtEnd, and BreakLocation properties. These properties help you tune page breaks after or before a data group in your report and on which page to continue displaying the report content.

The NewPage property works for the data regions - List, Table, BandedList, Tablix, Container, TOC, and Chart, and has the following options.

  • Next - a default value that makes a new group start from the immediate next page of the report.
  • Odd - a new group starts from the next odd page of the report.
  • Even - a new group starts from the next even page of the report.

You can use the NewPage property for the following data region groups:

  • Table: Groups, Detail groups
  • Tablix: Row groups, Adjacent Row groups, Child Row groups
  • List: Detail groups
  • BandedList: Groups, Details section

NewPage and PageBreakAtStart / PageBreakAtEnd

See the possible combinations of NewPage with the PageBreakAtStart and PageBreakAtEnd properties.

PageBreakAtStart | PageBreaktEnd | NewPage > Next | NewPage > Odd | NewPage > Even
False | False | No new page | No new page | No new page
False | True | A new page is added after the data region. | A new page is added after the data region and at odd page of the report. | A new page is added after the data region and at even page of the report.
True | False | A new page is added before the data region. | A new page is added before the data region and at odd page of the report. | A new page is added before the data region and at even page of the report.
True | True | A new page is added before and after the data region. | A new page is added before and after the data region and at odd page of the report. | A new page is added before and after the data region and at even page of the report.

The image below uses a report that has a Table data region with the following properties:

  • PageBreakAtEnd > True
  • PageBreakAtStart > False
  • NewPage > Even

As a result, the report renders 10 pages, a page break is added after a table, and a new page is added after the table at an even page (Page 10).

NewPage as Page Break

After the same properties are changed as

  • PageBreakAtEnd > False
  • PageBreakAtStart > True
  • NewPage > Odd

As a result, the report renders 11 pages, a page break is added before a table (Page 2), and a new page is added at odd page of the report (Page 1).

NewPage and BreakLocation

The BreakLocation property controls the break location of a data group. See the possible combination of the NewPage with the BreakLocation property.

 | NewPage > Next | NewPage > Odd | NewPage > Even
BreakLocation > None | No page break
BreakLocation > Start | A page break is added before a new group. A new group starts from the next page of the report. | A page break is added before a new group. A new group starts from the next odd page of the report. | A page break is added before a new group. A new group starts from the next even page of the report.
BreakLocation > End | A page break is added after a current group. A new group starts from the next page of the report. 1 | A page break is added after a current group. A new group starts from the next odd page of the report. 1 | A page break is added before a new group. A new group starts from the next even page of the report. 1
BreakLocation > StartAndEnd | A page break is added before and after a current group. A new group starts from the next page of the report. | A page break is added before and after a current group. A new group starts from the next odd page of the report. | A page break is added before a new group. A new group starts from the next even page of the report.
BreakLocation > Between | A page break is between groups. A new group starts from the next page of the report. 1 | A page break is between groups. A new group starts from the next odd page of the report. 1 | A page break is added before a new group. A new group starts from the next even page of the report. 1

1 The first group always starts on the first page.

Multiple Data Regions Behavior

In a report with multiple data regions, the behavior of the NewPage property is as follows:

  • If at least one data region in a report has the NewPage > Even, page breaks are added with the value Even for all report's data regions.
  • If at least one data region in a report has the NewPage > Odd, page breaks are added with the value Odd for all report's data regions.
  • If NewPage is set to different values in data regions of a report, page breaks are added with the value Next for all data regions.
Page report Limitation: When multiple data regions are added to the same page, the data regions take the Next value; the other values (Odd, Even) are ignored.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Dialog

Report Dialog
Report Authors > Design Reports > Design Page/RDLX Reports > Report Dialog

Glossary Item Box

In a Page Report or an RDLX Report, you can set the basic report properties in the Report dialog. You can access this dialog by doing one of the following:

  • Go to the Visual Studio Report menu and select Report Properties.
  • In the Report Explorer, right-click the Report node and from the context menu that appears, select Report Properties.
  • In the Report Explorer, select the Report node and in the Commands section at the bottom of the Properties Panel, click the Property dialog command.
  • Right-click the gray area outside the design surface to select the Report and in the Commands section at the bottom of the Properties Panel, click the Property dialog command.

The Report dialog provides the following pages where you can set report properties:

Report dialog box

General
Document Map
Appearance
Parameters
Images
References
Data Output
Themes

The General page of the Report dialog allows you to control the following items:

  • Author: Enter the name of the report author here.
  • Description: Enter a description of the report here.
  • Draw grid: Clear this check box to remove the grid lines from the report design surface.
  • Snap to grid: Clear this check box to allow free placement of report items on the report design surface instead of the automatic alignment of report items with grid lines.
  • Grid spacing: Enter the spacing between grid lines in inches. The default value is 0.125 inches.
  • Page headers: These options are enabled when you set a Page Header in a Report Definition Language (RDLX) report.
    • Print on first page - Select this check box to set the page header on the first page of the report.
    • Print on last page - Select this check box to set the page header on the last page of the report.
  • Page footers: These options are enabled when you set a Page Footer in a RDLX report.
    • Print on first page - Select this check box to set the page footer on the first page of the report.
    • Print on last page - Select this check box to set the page footer on the last page of the report.
  • Auto refresh: Select this check box to automatically refresh the pages of the report at regular intervals. When this check box is selected, you can supply the interval in seconds.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 0 and maximum is 10000 pages. If the value is set to 0, the Preview tab displays all the pages. By default, the Preview tab displays all the pages.
  • Start page number: Set the number from which the page numbering should start.
  • Consume all white space during report rendering: In RDLX report, selecting this option consumes all white spaces in report during report rendering.

The Document Map page of the Report dialog allows you to control the following items:

  • Source: The document map source. You can choose the source as Labels, Headings, or both Labels and Headings.
  • Numbering Style: Specifies numbering style for headings like 1, 2, 3, 4 or a, b, c, d, etc.

See Document Map for more information.

The Appearance page of the Report dialog allows you to control the page layout for your report.

Page Layout

  • Pages layout order: See Set Page Layout in Z- or N-Order for more information.

    Z-order: Horizontally expanding data in the report is rendered first on the upcoming pages followed by the vertically expanding data.
    N-order: Vertically expanding data in the report is rendered first on the upcoming pages followed by the horizontally expanding data.

Design

  • Output background only at design-time: Select the checkbox to display background (for example, background image or background color) in the design tab only.

Stylesheet

  • Source: Select one among Embedded and External as your style sheet source.
  • Value: Select the style sheet to apply to the report. Following options are available:

    Expression - Opens the Expression Editor dialog to set an expression.

    New - Opens the New Stylesheet Editor dialog for creating an external or embedded style sheet.

    Open file - Opens the Open Stylesheet from file dialog for navigating to a local style sheet file. This option is only available for external style sheets.
    In case of embedded style sheets, a list of available style sheets in the report is provided.

The Parameters page of the Report dialog allows you to control how a user interface is presented to your users for each parameter. See Parameters for further information.

The Images page of the Report dialog allows you to add and modify images for your report. Click the Open button located at the top left of the page to display the Open file dialog, where you can navigate to an image. Once you select an image file and click the Open button, a thumbnail of the image is displayed in the Image column, and the Name and MIME Type values are automatically populated in their respective columns.

You can use the images you add here in the Image control. The MIME Type column provides a combo-box with a list of image file extensions, where you can change default file filter of the added image.

You can also use the Remove button located at the top right of the page to remove any added image.

The References page of the Report dialog allows you to add references to assemblies and classes so that you can call methods from them in expressions throughout your report. You can also access the References dialog from the Properties Panel by selecting the Classes (Collection) or References (Collection) property of a report and clicking the ellipsis button that appears.

Assembly Name

This is a list of the assemblies available for use in your report. You can delete assemblies using the Remove button, or add them using the Open button which presents the Open file dialog.

Classes

This is a list of instance-based classes you can create for use in your report.

  • Class name: Enter the namespace and name of the class here. (i.e. Invoicing.GetDueDate)
  • Instance name: Enter a name for the instance of the class here. (i.e. m_myGetDueDate)

The Data Output page of the Report dialog allows you to control how the report's data is rendered in XML exports.

  • Element name: Enter the name you want to appear as the top level data element in your exported XML file.
  • Data transform (.xsl file): Enter the name of the XSL file you want to use as a style sheet for the exported XML file.
  • Data schema: Enter the schema or namespace to use for validating data types in the exported XML file.
  • Render textboxes as: Choose whether to render textboxes as Attributes or Elements in the exported XML file.
    • Attributes example: <table1 textbox3="Report created on: 7/26/2005 1:13:00 PM">
    • Elements example: <table1> <textbox3>Report created on: 7/26/2005 1:13:28 PM</textbox3>

The Themes page of the Report dialog displays the report's themes. This dialog allows you to create a new theme, add, modify or remove an existing one, as well as rearrange the order of themes if a report has many themes. When you select to create or modify a theme, the Theme Editor is opened. See Themes for further information.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Master Report (RDLX Report)

Master Report (RDLX Report)
Report Authors > Design Reports > Design Page/RDLX Reports > Master Report (RDLX Report)

Glossary Item Box

Master Reports are like dynamic templates you can design for use with content reports. This assists users in creating reports that share common elements such as a logo in the page header or a web site link in the page footer. You design the master report with controls, code, data sources, and layout properties that cannot be modified from content reports.

Master Reports differ from templates in that they are loaded each time the report is executed. Therefore, you can modify a master report and the changes to the master report automatically appear in any reports that reference it.

In an RDLX report, you can create a master report and apply it to any number of content reports to keep common styles in one easy-to-maintain location.

Master reports help you perform the following tasks:

  • Create a predefined layout with limited modification possibilities.
  • Hide details of data sources.

Design a Master Report

When designing a master report, you use controls, code, data sources, and layout properties in the same way that you do in a normal report. A master report is valid on its own, and can be run without a content report. To prevent end users from modifying a master report, you can set permissions on the file to Read Only for that user or group.

In an RDLX Report, you can create a master report by saving it as an RDLX-master file. You can then apply it like a template to content reports.

A ContentPlaceHolder control appears in the toolbox when you convert an RDLX report to a Master Report. This control defines regions where users can add content after applying a master report template.

Note: These steps assume that you have already created a new RDLX report and connected it to a data source. The Master Report feature is only available with RDLX Reports.
  1. In the Standalone Designer, go to Report menu > Master Report > Convert to Master Report.
    Convert to Master Report in the Report menu
    In WebDesigner, go to Report menu > Convert to Master Report.
    Convert to Master Report in the Report menu
    The same option in Visual Studio Integrated Designer can be accessed from Extensions > Report.
    Convert to Master Report in the Visual Studio Extensions > Report
  2. Right-click the ruler area to the top or left of the report and choose Page header. Repeat and choose Page footer.
  3. From the toolbox, drag and drop controls into the page header and footer sections. These controls appear on every page of a content report when you apply the master report. For example, a company logo image, or a textbox with the company address.
    Create Page Header and Footer content for a master report

  4. A ContentPlaceHolder control appears in the toolbox when you convert an RDLX report to a Master Report. This control defines regions where users can add content. Use the following instructions to add the ContentPlaceHolder control in the master report.

    1. From the toolbox, drag and drop the ContentPlaceHolder control onto the report design surface.
    2. Right-click the control and from the context menu that appears, select Properties to open the properties window.
    3. Set the following properties for the ContentPlaceHolder control.
      Property | Description
      Location | To position the control with respect to the top left corner of the container.
      Size | To set the control size for determining the space available to design a content report.
      Text | To add instructive text for the user. E.g. "Design your content report here." This caption appears in the design view and not in the final output.

  5. Save the master report locally on your system. In the standalone designer, the option is in the File menu.

    1. In Visual Studio, select the report, and from the Extensions menu > Report > Save Layout.
    2. In the Save As dialog that appears, navigate to the location where you want to save the report and click Save to save the report in rdlx-master file format.

Use a Master Report to Create a Content report

The reports to which you apply the master report are content reports. A content report is not valid on its own, and cannot be run without its specified master report.

When the user creates a new report and sets a master report on it, the design view is effectively the opposite of the design view of the master report. Any report controls overlaid by ContentPlaceHolder controls are not visible in the content report at design time, but are visible at run time. These are the only areas where users can add report controls.

  1. With focus on the report to which you want to apply the master report, from the Report menu, select Set Master Report, then Open Local File.
  2. In the Open dialog that appears, navigate to the location where you saved the master report and open it. The master report layout is applied to the content report with all areas locked except for the region with the ContentPlaceHolder, which is available for use.

While designing a Content report, user can:

  • Add elements that do not exist in the master report.
  • Add new data sources that do not exist in the master report.
  • Add new datasets from a data source in the master report.
  • Add images to the EmbeddedImages collection.
  • Add parameters to the ReportParameter collection.
  • Add any number of report controls into placeholder rectangles designated by the master report.
  • Modify the report name and description.
  • Add new custom code that does not exist in the master report.

While designing a Content report, user cannot:

  • Modify or remove elements that exist in the master report (disabled grey area).
  • Remove a master report data source.
  • Remove a master report dataset or modify its query.
  • Modify the sort or filter on a master report dataset.
  • Remove images from the EmbeddedImages collection.
  • Remove parameters from the ReportParameter collection.
  • Modify the margins or page settings of the master report.
Note: Code in the master report is hidden in the content report, so in order to allow content report users to access code, the master report developer must provide information.

Run-Time Sequence of Events

This is what happens behind the scenes when you run a content report.

  1. ActiveReports loads the content report.
  2. The loader parses the master report tag on the content report and requests the master report from the resource resolver.
  3. The master report is loaded into the definition.
  4. As each ContentPlaceHolder in the content report is parsed, it finds the corresponding placeholder in the master report and loads the content from the content report into it.
  5. Data sources, datasets, and fields are merged. The master report has higher priority if there is a conflict.
  6. Themes are merged. The master report has higher priority if there is a conflict.
  7. Report properties from the content report are added to those of the master report. For the following properties, the content report has a higher priority in case of conflict:
    • Report Description
    • Report Author
    • Report AutoRefresh
    • Report Custom
    • Report Language
    • Report DataTransform
    • Report DataSchema
    • Report ElementName
    • Report DataElementStyle
    • Dataset filters
    • Report Theme
    • Report Code
    • All content inside the ContentPlaceHolder controls

Modifying an Aggregated Report Definition

When you run a content report, the content report and its master combine to form an aggregated report definition. Using the ReportDefinition API, you can save this aggregate at run time as a third report definition which has no master or content report. Once this aggregate is saved as a normal report definition (*.rdlx file) you can edit it like any other report definition.

Advantages of a Master Report

  • Implement common report functionality such as adding consistent page headers and footers within master reports.
  • Apply company-wide changes in information such as address changes to a single master instead of modifying each report individually.
  • Apply widespread data-related changes (such as data source location) to a single master report instead of modifying each report.
  • Create code, data sources, themes and page layouts that are shared across the application or enterprise.
  • Hide report complexity from end users who can use the standalone designer application to create content reports.

Advantages of a Shared Master Report

Shared master reports offer the advantages of a local master report, plus:

  • They make your reports portable
  • They allow multiple authors to use them

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Layers

Layers
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Layers

Glossary Item Box

Layers contain a group of controls that can overlay with other groups of controls on a Page or an RDLX report. The controls are editable only on the currently selected layer. You can toggle between the layers and create a design in each layer. You can lock or unlock, add or remove, and show or hide these layers. When you create a new report, a default layer is automatically added to it.

This feature is available in both Page and RDLX reports.

Elements of Layers Editor

The Layers Editor can be accessed from the Toolbox > Layers Access Layers Editor from Toolbox on the left panel of the designer. The following table lists the actions you can perform through the Layers Editor.

Layers Element | Description
Layers Properties
New 		Adds a layer to the layer collection.
Layers Properties
Remove 		Removes the selected layer from the layer collection.
Layers Properties
Bring to Front 		Brings the group of controls placed on a selected Layer to the front of the controls on other layers.
Layers Properties
Send to Back 		Brings the group of controls placed on a selected Layer to the back of the controls on other layers.
Visibility | Toggles the visibility of the selected layer at design time. This lets you see what controls are there on each layer.
Lock | Toggles locking and unlocking of the layers. Locking a layer locks all of the controls on it to prevent accidental changes.
Field Selector Availability

Controls the visibility of the data field icons for the entire report or certain controls placed in a specific layer.

Note: The property is only applicable on selected controls, which are: TextBox, CheckBox, InputField, Image, Table, and Tablix.

Important Properties

Selecting any Layer from the Layers editor reveals the following properties in the Properties panel.

Property | Value | Description
DesignerFieldSelectorAvailability | True/False | Control the visibility of the data field icons for the entire report or certain controls placed in a specific layer. This property can also be set using the checkbox for Field Selector Availability in the Layers Editor.
DesignerLock | True/False | Locks or unlocks controls placed on a Layer. You cannot move or resize the controls placed on the design surface of a locked Layer through a keyboard or a mouse. Other editing functions like cut, copy, or paste and addition or deletion of controls are possible. This property can also be set using the checkbox for Lock in the Layers Editor.
DesignerTransparency | 0 to 1 | Sets the transparency of the controls on a Layer at design time to a value between 0 and 1. A Layer with transparency set to 1 is not visible on the designer.
DesignerVisible | True/False | Determines if the controls placed on a Layer are visible on the designer or not. This property can also be set using the checkbox for Visibility in the Layers Editor.
Name | Layer Name (string) | Sets the name of a Layer (except the Default Layer).
TargetDevice | None, Screen, Paper, Export, All | Specifies or limits the visibility of controls placed on a Layer based on the selected target. See View, Export, or Print Layers for information on TargetDevice-specific outputs.

View, Export, or Print Layers

The TargetDevice property determines whether you can view, export, or print the controls placed on a Layer. This property allows you to show or hide the controls that belong to a Layer on a specific target device. For example, if you want to display controls placed on Layer1 in the WinViewer and export the output to PDF, you can select the Screen and Export options of the TargetDevice property simultaneously.

Note: TargetDevice property only determines the target (i.e. Screen, Export, or Print) where the group of controls placed on a Layer appears. In order to get the output on a viewer or export or print the controls, you need to add code for exporting or printing, or adding a viewer to the application.

TargetDevice property allows you to select from the following options:

  • None
  • Screen
  • Paper
  • Export
  • All

Setting the TargetDevice Property

Use the following steps to set or change the TargetDevice property of a Layer:

  1. Select a Layer from the Layers List window. This becomes the Active Layer of the control.
  2. In the Properties window, select the TargetDevice property.
  3. From the dropdown, select out of the options: None, Screen, Paper, Export, or All.
    You can also select more than one option out of Screen, Paper and Export at the same time.
    TargetDevice | Output Type | Description
    None - Controls placed on a Layer cannot be viewed, exported or printed.
    Screen | WinViewer | Controls placed on a Layer can be viewed on any of the supported viewers.
    WebViewer
    WPF Viewer
    Paper | Physical/ Virtual Printer | Controls placed on a Layer are can be printed to physical or virtual printers.
    Export | Controls placed on a Layer are exported to any of the supported file formats. See Export in Desktop Viewer for more information on the export formats.
    All | All Outputs | Controls placed on a Layer can be viewed, exported and printed.

Add a watermark when your report is exported

Leverage the advantage of Layers in scenarios where you do not want to make changes to an existing report but want to perform minor modifications to the layout. With Layers, it is possible to make modifications to the same report without changing the original report layout. Let's take an example of a sales receipt to see how Layers can help in this scenario.

The requirement in this scenario is that a hard copy of the report is printed with a Customer Copy watermark and the soft copy of the same report is exported to an export format in a PDF format with a Merchant Copy watermark.

Layers

We have created the original sales receipt layout in the default layer and locked the layer by checking the Lock element. This step is necessary to make sure that the existing layout is not modified while making edits in the other layer.

After that, we added two Layers, one layer to contain the Customer Copy watermark image, and the other to contain the Merchant Copy watermark image. The TargetDevice property for the Customer Layer is set to Paper for printing a hard copy of the sales receipt and for the Merchant Layer to Export for exporting it to an export format.

Note: PDF Export has the WatermarkPrintOnly setting that allows adding a watermark to an exported PDF file when printed.

Create Pre-Printed Form

Layers can be used to create a layout of a pre-printed form, a form with some fixed data. This is particularly useful when you want to replicate a layout of a pre-printed form that is either uneditable or unavailable in soft copy.

Let us take an example of an order invoice sent to the customers to see how Layers can help replicate the layout of the scanned image easily. You can also follow the following steps to create the layout of your desired report.

  1. Create a report layout on the Default Layer. We created the invoice report layout by adding controls on the Default Layer.
  2. Set the DesignerLock property of this Layer to True to make sure the controls are not modified or changed by mistake.
  3. Set the DesignerTransparency property of the Default Layer to 0.5 to display the scanned image placed on Default Layer in the background.
  4. Place a date stamp, for example, on Layer1, and set the TargetDevice property to All.

See Also

Demo: Layers

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Expressions

Expressions
Report Authors > Design Reports > Design Page/RDLX Reports > Expressions

Glossary Item Box

In ActiveReports, you can use an expression to set the value of a control in the report, or set conditions under which certain styles apply. You can set Microsoft Visual Basic® .NET in expressions through,

  • Properties in the properties window
  • Expression Editor dialog

All expressions begin with an equal sign (=). Even the expression for a field value for a TextBox is set as follows:

=Fields!LastName.Value

Expression Editor Dialog

You can build expressions quickly using the Expression Editor dialog. This dialog allows you to choose from a number of fields available to the report as well as to a particular property. You can access the Expression Editor by selecting nearly any property of a control and choosing <Expression...> from the drop-down list.

Expression Editor dialog box

There are the following types of fields available in the Expression Editor:

  • Constants
    Constants available for properties which have enumerated values such as TextDecoration or BorderStyle.
  • Common Values
    Run time values available to every property in every report. There are two variables in this list which come from the User collection: User ID and User Language. See Common Values for further information.
  • Parameters
    Parameters fields available in reports which contain report parameters. If available, you can choose a parameter from this field to retrieve the current value of the parameter.
  • Fields (DataSet name)
    All fields from a dataset which is linked to the report control.
  • Datasets
    All fields in each dataset associated with the report. However, the report retrieves only the sum or the first value of any field that is not within the current dataset scope.
  • Operations
    Arithmetic, comparison, concatenation, logical/bitwise, bit shift operators for creating custom expressions.
  • Common Functions
    Predefined Visual Basic .NET functions for which ActiveReports provides intrinsic support. See Common Functions for more information.
  • Document Map
    The DocumentMap.Path expression defines labels for the report's TableOfContents members. The example of such expression is =DocumentMap.Path & " General Information". If this expression is defined in the Label property of the report's control associated with the report's TableOfContents, General Information will be displayed as the label of the corresponding report's TableOfContents member.

Create an Expression in the Expression Editor

The Expression Editor dialog is composed of two panes, Fields and Expression.

  1. From the Fields pane, select a field you want to use in your expression.
  2. Click the Replace, Insert or Append button to add the field to the Expression pane. The expression pane shows the fields in a valid expression format.
  3. Click OK to close the dialog.

The expression appears as the property value in the properties grid.

Tip: While building an expression, you can directly add the entire expression or part of it in the Expression pane of the Expression Editor. Then use the Insert or Append buttons to create a complete expression.

Using Expressions in Reports

In the raw form, your data may not be ideally suited for display in a report. You can customize it and bring it into shape using expressions. Following are some examples of how expressions are set in different scenarios.

Concatenating Fields and Strings

You can concatenate fields with strings and with other fields. For e.g., use the following expression to get a result like Customer Name: Bossert, Lewis.

="Customer Name: " & Fields!LastName.Value & "," & Fields!FirstName.Value

Conditional Formatting

You can use expressions in properties like Color, Font, Border etc. on specific field values based on a condition, to highlight a part of data. The formula for conditional formatting is:
=iif( Fields!YourFieldName.Value operator "Value to compare", "If condition is met, use this value.", "If not, use this one.")

For e.g., if you enter the following expression in the Font > FontWeight property of a textbox that displays names of people, you get the name "Denise" in bold.

=iif(Fields!FirstName.Value = "Denise", "Bold", "Normal")

Functions

You can use a number of aggregate and other functions in your expressions. ActiveReports includes a range of functions, including running value, population standard variance, standard deviation, count, minimum and maximum. For e.g., use the following expression to get a count of employees.

=Count(Fields!EmployeeID.Value, Nothing)

As you design the report, the full text of an expression can get very long. ActiveReports makes expressions easier to read by shortening them.

When an expression is in the form:

=Fields!<FieldName>.Value

On the design surface, you see this text inside that TextBox:

=[<FieldName>]

Double-click the TextBox to view the full expression in edit mode.

For aggregates too, when the Expression value is:

=<Aggregate>(Fields!<FieldName>.Value)

On the design surface, you see this text inside the TextBox:

=<Aggregate>([<FieldName>])

This shortened expression value is only a visual change to allow you to see the field name easily. It shows up in both the TextBox on the design surface as well as any dropdown boxes inside the dialogs.

Note: You can type the format as listed above for either field name values or aggregates on field names. This evaluates the full expression when the report is viewed.

Besides the shorthand for field names, you can also type shorthand like [@Param] for parameters and [&Value] for Globals such as [&PageNumber] on the design surface. Please note that you cannot use shorthand in the Expression Editor.

Common Values

Common Values are run time values available to every property in every report. You can directly drag and drop these common values from the Report Explorer onto the design surface or add and modify the values from the Expression Editor. Following is a list of the values that you can see under the Common Values node in the Report Explorer and in the Expression Editor.

Value | Description | Expression
Page N of M | Gets both the current page and the total number of pages in the report. | ="Page " & Globals!PageNumber & " of" & Globals!TotalPages
Page N of M (Section) | Gets both the current page and the total number of pages in the report section. | ="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) | Gets both the current page and the total number of cumulative pages in a report. | ="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Current Date and Time | Gets the date and time when the report began to run. | =Globals!ExecutionTime
User ID | Gets the machine name/user name of the current user. | =User!UserID
Page Number | Gets the current page number in the report. | =Globals!PageNumber
Page Number (Section) | Gets the current page number in the report section. | =Globals!PageNumberInSection
Total Pages | Gets the total number of pages in the report. | =Globals!TotalPages
Total Pages (Section) | Gets the total number of pages in the report section. | =Globals!TotalPagesInSection
Cumulative Page Number | Gets the current cumulative page number. | =Globals!CumulativePageNumber
Cumulative Total Pages | Gets the total number of cumulative pages in the report. | =Globals!CumulativeTotalPages
Report Folder | Gets the name of the folder containing the report. | =Globals!ReportFolder
Report Name | Gets the name of the report. | =Globals!ReportName
User Language | Gets the language settings of the current user. | =User!Language
Note: Page N of M (Section), Page Number (Section) or Total Pages (Section) is applied to page numbering when you set grouping in a report. Each section represents a group, not to be confused with sections in a Section report.
Note: Page N of M (Cumulative), Page Number (Cumulative) or Total Pages (Cumulative) is applied to page numbering when you use collation in a report.

Common Functions

You can use a function in an expression to perform actions on data in data regions, groups and datasets. You can access these functions in the Expression Editor dialog. In any property that accepts expressions, you can drop down the property and select <Expression...> to open the dialog.

Within the Expression Editor dialog, there is a tree view of Fields. Expand the Common Functions node to view the available functions. The following tables contain details about each of the functions included in ActiveReports for use in property expressions.

Date & Time

These are all methods from the DateAndTime class in Visual Basic. Please see the msdn DateAndTime Class topic for information on overloads for each method.

These are all the available aggregate functions:

Function | Description | Syntax and Example
DateAdd | Returns a date and time value that is the result of adding the interval to the date and time field of the specified unit. | DateAdd(<DateInterval>,<Number>,<DateTime>) =DateAdd("d", 5, Fields!SaleDate.Value); =DateAdd(DateInterval.Day, 5, Fields!SaleDate.Value)
DateDiff | Returns the difference between the start date and time and end date and time of the specified unit. | DateDiff(<DateInterval>,<DateTime1>,<DateTime2>[,<DayOfWeek>[,WeekOfYear]])) =DateDiff("yyyy"), Fields!SaleDate.Value,"1/1/2015");=DateDiff(DateInterval.Year,Fields!SaleDate.Value,"1/1/2015")
DatePart | Returns the Integer value that represents the specified part of the given date. | DatePart(<DateInterval>,<DateTime1>[,<FirstDayOfWeek>[,FirstWeekOfYear]])) =DatePart("m", Fields!SaleDate.Value)
DateSerial | Returns a Date value that represents a specified year, month, and a day, with the time information set to midnight (00:00:00). | DateSerial(<Year Number>,<Month Number>,<Day Number>) =DateSerial(DatePart("yyyy", Fields!SaleDate.Value)-10, DatePart("m", Fields!SaleDate.Value)+5, DatePart("d", Fields!SaleDate.Value)-1)
DateString | Returns the String value that represents the current date in your system. | DateString() =DateString()
DateValue | Returns a Date value that contains the information on date represented by a string, with the time set to midnight (00:00:00). | DateValue(<StringDate>) =DateValue("December 12, 2015")
Now | Returns the current date and time in your system. | Now() =Now()
Today | Returns a Date value that contains the current date in your system. | Today() =Today()
Day | Returns an Integer value from 1 through 31 that represents the day of the month. | Day(<DateTime>) =Day(Fields!SaleDate.Value)
Hour | Returns an Integer value from 0 through 23 that represents the hour of the day. | Hour(<DateTime>) =Hour(Fields!SaleDate.Value)
Minute | Returns an Integer value from 0 through 59 that represents the minute of the hour. | Minute(<DateTime>) =Minute(Fields!SaleDate.Value)
Month | Returns an Integer value from 0 through 12 that represents the month of the year. | Month(<DateTime>) =Month(Fields!SaleDate.Value)
MonthName | Returns the name of the month specified in the date as a String. | MonthName(<Month Number>[,<Abbreviate>]) =MonthName(Fields!SaleDate.Value)
Second | Returns an Integer value from 0 through 59 that represents the second of the minute. | Second(<DateTime>) =Second(Fields!SaleDate.Value)
TimeSerial | Returns a Date value that represents a specified hour, minute, and second, with the date information set relative to January 1 of the year 0001. | TimeSerial(<Hour Number>, <Minute Number>, <Second Number>) =TimeSerial(DatePart("h", Fields!SaleDate.Value), DatePart("n", Fields!SaleDate.Value), DatePart("s", Fields!SalesDate.Value))
TimeValue | Returns a Date value that contains the information on time represented by a string, with the date set to January 1 of the year 0001. | TimeValue(<StringTime>) =TimeValue("15:25:45"); TimeValue(Fields!SaleDate.Value)
TimeOfDay | Returns a Date value containing the current time of day in your system. | TimeOfDay() =TimeOfDay()
Timer | Returns a Double value that represents the number of seconds elapsed since midnight. | Timer() =Timer()
TimeString | Returns the String value that represents the current time of day in your system. | TimeString() =TimeString()
Weekday | Returns an Integer value that contains a number representing the day of the week. | Weekday(<DateTime[,<DayOfWeek>]) =Weekday(Fields!SaleDate.Value,0)
WeekdayName | Returns a String value that contains the name of the specified weekday. | WeekdayName(<WeekDay>[,<Abbreviate[, <FirstDayOfWeek>]]) =WeekdayName(3, True, 0); =WeekDayName("w", Fields!SaleDate.Value), True, 0)
Year | Returns an Integer value from 1 through 9999 representing the year. | Year(<DateTime>) =Year(Fields!SaleDate.Value)
Quarter | Returns an Integer value from 1 through 4 representing the quarter number. | Quarter(<DateTime>) =Quarter(Fields!SaleDate.Value)
QuarterName | Returns a string value representing the quarter name. | QuarterName(<DateTime>) =QuarterName(Fields!SaleDate.Value)

Math

These are all methods and fields from the System.Math class. Please see the msdn Math Class topic for information on overloads for each method.

Function | Description | Syntax and Example
Abs | Returns the absolute or positive value of a single-precision floating-point number. | Abs(<Number>) =Abs(-5.5);=Abs(Fields!YearlyIncome.Value-80000)
Acos | Returns the angle whose cosine is the specified number. | Acos(<Number>) =Acos(.5); =Acos(Fields!Angle.Value)
Asin | Returns the angle whose sine is the specified number | Asin(<Number>) =Asin(.5); =Asin(Fields!Angle.Value)
Atan | Returns the angle whose tangent is the specified number. | Atan(<Number>) =Atan(.5); =Atan(Fields!Angle.Value)
Atan2 | Returns the angle whose tangent is the quotient of two specifed numbers. | Atan2(<Number1>,<Number2>) =Atan2(3,7); =Atan2(Fields!CoordinateY.Value,Fields!CoordinateX.Value)
BigMul | Returns the multiplication of two 32-bit numbers. | BigMul(<Number1>,<Number2>) =BigMul(4294967295,-2147483647); =BigMul(Fields!Int32Value.Value, Fields!Int32Value.Value)
Ceiling | Returns the smallest integer greater than or equal to the specified double-precision floating-point number. | Ceiling(<Number>) =Ceiling(98.4331); =Ceiling(Fields!AnnualSales.Value /6)
Cos | Returns the smallest integer greater than or equal to the specifed double-precision floating-point number. | Cos(<Number>) =Cos(60)
Cosh | Returns the hyperbolic cosine of the specified angle. | Cosh(<Number>) =Cosh(60)
E | Returns the value of E, which is 2.71828182845905. | E =E*2
Exp | Returns e raised to the specified ^, where is Euler s number. It is the inverse of the Log function. | Exp(<Number>) =Exp(3); =Exp(Fields!IntegerCounter.Value)
Fix | Returns the integer portion of a number. | Fix(<Number>) =Fix(-7.15); =Fix(Fields!AnnualSales.Value /-5)
Floor | Returns the longest integer less than or equal to the specified double-precision floating-point number. | Floor(<Number>) =Floor(4.67); =Floor(Fields!AnnualSales.Value/ 12)
IEEERemainder | Returns the remainder after division of one number by another according to IEEE satndards. | IEEERemainder(<Number1>,<Number2>) =IEEERemainder(9,8)
Log | Returns the logarithm of the specified number. | Log(<Number>) =Log(20.5); =Log(Fields!NunberValue.Value)
Log10 | Returns the logarithm of the specified number to the base 10. | Log10(<Number>) =Log10(20.5); =Log10(Fields!NumberValue.Value)
Max | Returns the maximum non-null value from the specified expression. | Max(<Value>) =Max(Fields!OrderTotal.Value)
Min | Returns the minimum non-null value from the specified expression. | Min(<Value>) =Min(Fields!OrderTotal.Value)
PI | Returns the value of PI, which is 3.14159265358979. | PI =2 * PI * Fields!Radius.Value
Pow | Returns one number raised to the ^ of another number. | Pow(<Number1,<Number2>) =Pow(Fields!Quantity.Value, 2)
Round | Returns the round-off of a decimal number to the nearest integer or to the nearest decimal number up to the specified digits. | Round(<Number>) =Round(12.456); =Round(Fields!AnnualSales.Value / 12.3)
Sign | Returns a value indicating the sign of an 8-bit signed integer. | Sign(<Number>) =Sign(Fields!AnnualSales.Value-60000)
Sin | Returns the sine of the specified number. | Sin(<Number>) =Sin(60)
Sinh | Returns the hyperbolic sine of the specified angle. | Sinh(<Number>) =Sinh(60)
Sqrt | Returns the square root of the specified number. | Sqrt(<Number>) =Sqrt(121)
Tan | Returns the tangent of the specified number. | Tan(<Number>) =Tan(60)
Tanh | Returns the hyperbolic tangent of the specified angle. | Tanh(<Number>) =Tanh(60)

Inspection

These are all methods from the DateAndTime class in Visual Basic. Please see the msdn DateAndTime Class topic for information on overloads for each method.

Function | Description | Syntax and Example
IsArray | Returns True if the expression can be evaluated as an array. | IsArray(<Expression>) =IsArray(Parameters!Initials.Value)
IsDate | Returns True if the expression represents a valid Date value. | IsDate(<Expression>) =IsDate(Fields!BirthDate.Value); =IsDate("31/12/2010")
IsDBNull | Returns True if the expression evaluates to a null. | IsDBNull(<Expression>) =IsDBNull(Fields!MonthlySales.Value)
IsError | Returns True if the expression evaluates to an error. | IsError(<Expression>) =IsError(Fields!AnnualSales.Value = 80000)
Isnothing | Returns True if the expression evaluates to nothing. | IsNothing(<Expression>) =IsNothing(Fields!MiddleInitial.Value)
IsNumeric | Returns True if the expression can be evaluated as a number. | IsNumeric(<Expression>) =IsNumeric(Fields!AnnualSales.Value)

ProgramFlow

These are all methods from the Interaction class in Visual Basic. Please see the msdn Interaction Class topic for more information.

Function | Description | Syntax and Example
Choose | Returns a value from a list of arguments. | Choose(<Index>,<Value>[, <Value2>,...[, <Value N>]]) =Choose(3, "10", "15", "20", "25")
IIF | Returns the value if the expression evaluates to True, and the second value if the expression evaluates to False. | IIF(<Condition>, <TruePart>, <FalsePart>) =IIF(Fields!AnnualSales.Value >= 80000, "Above Average", "Below Average")
Partition | Returns a string (in the form x : y) that represents the calculated range based on the specified interval containing the specified number. | Partition(<Value>, <Start>, <End>, <Interval>) =Partition(1999, 1980, 2000, 10)
Switch | Returns the value of the first expression that evaluates to True among a list of expressions. | Switch(<Condition1>, <Value1>[, <Condition2>, <Value2>,...[,<ConditionN>, <ValueN>]]) =Switch(Fields!FirstName.Value = "Abraham", "Adria", Fields!FirstName.Value = "Charelotte", "Cherrie")

Aggregate

You can use aggregate functions within report control value expressions to accrue data. ActiveReports supports aggregate functions from RDLX 2005, plus some proprietary extended set of functions. For all of the functions, you can add an optional <Scope> parameter.

These are all the available aggregate functions:

Function | Description | Syntax and Example
AggregateIf | Decides whether to calculate a custom aggregate from the data provider of the values returned by the expression based on a Boolean expression. | AggregateIf(<Condition>, <AggregateFunction>, <AggregateArguments>) =AggregateIf(Fields!Discontinued.Value=True, Sum, Fields!InStock.Value)
Avg | Calculates the average of the non-null values returned by the expression. | Avg(<Values>) =Avg(Fields!Cost.Value, Nothing)
Count | Calculates the number of non-null values returned by the expression. | Count(<Values>) =Count(Fields!EmployeeID.Value, Nothing)
CountDistinct | Calculates the number of non-repeated values returned by the expression. | CountDistinct(<Values>) =CountDistinct(Fields!ManagerID.Value, "Department")
CountRows | Calculates the number of rows in the scope returned by the expression. | CountRows() =CountRows("Department")
CrossAggregate | Calculates the specified function with the specified expression as an argument in the cross of the specified row and column. | CrossAggregate(<Expression>, <FunctionName>, <ColumnGroupName>, <RowGroupName>) =CrossAggregate(Fields!Count.Value, "Sum", "MonthGroup", "ProductGroup")
CumulativeTotal | Calculates the sum of page-level aggregates returned by the expression for current and previous pages. | CumulativeTotal(<Expression>, <Aggregate>) =CumulativeTotal(Fields!OrderID.Value, Count)
DistinctSum | Calculates the sum of the values returned by an expression using only the rows when the value of another expression is not repeated. | DistinctSum(<Values>, <Value>) =DistinctSum(Fields!OrderID.Value, Fields!OrderFreight.Value, "Order")
First | Shows the first value returned by the expression. | First(<Values>) =First(Fields!ProductNumber.Value, "Category")
Last | Shows the last value returned by the expression. | Last(<Values>) =Last(Fields!ProductNumber.Value, "Category")
Max | Shows the largest non-null value returned by the expression. | Max(<Values>) =Max(Fields!OrderTotal.Value, "Year")
Median | Shows the value that is the mid-point of the values returned by the expression. Half of the values returned will be above this value and half will be below it. | Median(<Values>) =Median(Fields!OrderTotal.Value)
Min | Shows the smallest non-null value returned by the expression | Min(<Values>) =Min(Fields!OrderTotal.Value)
Mode | Shows the value that appears most frequently in the values returned by the expression. | Mode(<Values>) =Mode(Fields!OrderTotal.Value)
RunningValue | Shows a running aggregate of values returned by the expression (Takes one of the other aggregate functions as a parameter), | RunningValue(<Values>, <AggregateFunction>) =RunningValue(Fields!Cost.Value, Sum, Nothing)
StDev | Calculates the dispersion (standard deviation) of all non-null values returned by the expression. | StDev(<Values>) =StDev(Fields!LineTotal.Value, "Order")
StDevP | Calculates the population dispersion (population standard deviation) of all non-null values returned by the expression. | StDevP(<Values>) =StDevP(Fields!LineTotal.Value, "Order")
Sum | Calculates the sum of the values returned by the expression. | Sum(<Values>) =Sum(Fields!LineTotal.Value, "Order")
Var | Calculates the variance (standard deviation squared) of all non-null values returned by the expression. | Var(<Values>) =Var(Fields!LineTotal.Value, "Order")
VarP | Calculates the population variance (population standard deviation squared) of all non-null values returned by the expression. | VarP(<Values>) =VarP(Fields!LineTotal.Value, "Order")

Conversion

These are all methods from the Convert class in the .NET Framework. Please see the msdn Convert Class topic for more information.

Function | Description | Syntax and Example
ToBoolean | Converts the specified value to Boolean. | ToBoolean(<Value>) =ToBoolean(Fields!HouseOwnerFlag.Value)
ToByte | Converts the specified value to Byte. | ToByte(<Value>) =ToByte(Fields!ProductNumber.Value)
ToDateTime | Converts the specified value to a Date and Time value. | ToDateTime(<Value>) =ToDateTime(Fields!SaleDate.Value); =ToDateTime("1 January, 2020")
ToDouble | Converts the specified value to Double. | ToDouble(<Value>) =ToDouble(Fields!AnnualSales.Value); =ToDouble(535.85 * .2691 * 67483)
ToInt16 | Converts the specified value to a 16-bit signed Integer. | ToInt16(<Value>) =ToInt16(Fields!AnnualSales.Value); =ToInt16(535.85)
ToInt32 | Converts the specified value to a 32-bit signed Integer. | ToInt32(<Value>) =ToInt32(Fields!AnnualSales.Value)
ToInt64 | Converts the specified value to a 64-bit signed Integer. | ToInt64(<Value>) =ToInt64(Fields!AnnualSales.Value)
ToSingle | Converts the specified value to a single-precision floating-point number. | ToSingle(<Value>) =ToSingle(Fields!AnnualSales.Value); =ToSingle(15.857692134)
ToUInt16 | Converts the specified value to a 16-bit unsigned Integer. | ToUInt16(<Value>) =ToUInt16(Fields!AnnualSales.Value)
ToUInt32 | Converts the specified value to a 32-bit unsigned Integer. | ToUInt32(<Value>) =ToUInt32(Fields!AnnualSales.Value)
ToUInt64 | Converts the specified value to a 64-bit unsigned Integer. | ToUInt64(<Value>) =ToUInt64(Fields!AnnualSales.Value)

Miscelleneous

ActiveReports also offers several functions which do not aggregate data, but which you can use with an IIf function to help determine which data to display or how to display it.

The first four are miscellaneous functions from the RDLX 2005 specifications. GetFields is a proprietary function to extend RDLX specifications.

Function | Description | Syntax and Example
InScope Determines whether the current value is in the indicated scope. InScope(<Scope>)
=InScope("Order")
Level Returns the level of the current value in a recursive hierarchy. Level()
=Level()
Previous Returns the previous value within the indicated scope. Previous(<Value>)
=Previous(Fields!OrderID.Value)
RowNumber Shows a running count of all the rows in the scope returned by the expression. RowNumber()
=RowNumber()
GetFields

Returns an IDictionary<string,Field> object that contains the current contents of the Fields collection. Only valid when used within a data region. This function makes it easier to write code that deals with complex conditionals. To write the equivalent function without GetFields() would require passing each of the queried field values into the method which could be prohibitive when dealing with many fields.

 GetFields()
=Code.DisplayAccountID(GetFields())
Custom function. Paste in the Code tab. Copy Code
'Within the Code tab, add this function.

Public Function DisplayAccountID( flds as Object) as Object

  If flds("FieldType").Value = "ParentAccount" Then

    Return flds("AccountID").Value

  Else

    Return flds("ParentAccountID").Value

  End If

End Function
Lookup Returns the first matching value for the specified name from the dataset with pairs of name and value. For more information, see
Report Builder Functions - Lookup Function.

Lookup(<SourceExpression>, <DestinationExpression>, <ResultExpression>, <LookupDataset>)

=Lookup(Fields!ProductID.Value, Fields!ProductID.Value, Fields!Quantity.Value, "DataSet2")
LookupSet Returns multiple row values from a specified dataset and can be used for the 1-to-many relationship. For more information, see
Report Builder Functions - LookupSet Function.

LookupSet(source_expression, destination_expression, result_expression, dataset)

=LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products")
MapPoint Allows displaying simple data directly on the Map as a map Point Layer.

MapPoint(<Latitude>, <Longitude>)

=MapPoint(Fields!Latitude.Value, Fields!Longitude.Value)
GroupIndex | Returns the index of the element in the current group. | =GroupIndex()
GroupIndex (with scope) | Returns the index of the element in the specified group. | =GroupIndex(<Group>)

Using Scope Parameter

All functions have a Scope parameter which determines the grouping, data region, or dataset to be considered when calculating the aggregate or other function. Within a data region, the Scope parameter's default value is the innermost grouping to which the report control belongs. Alternately, you can specify the name of another grouping, dataset, or data region, or you can specify Nothing, which sets it to the outermost data region to which the report control belongs.

The Scope parameter must be a data region, grouping, or dataset that directly or indirectly contains the report control using the function in its expression. If the report control is outside of a data region, the Scope parameter refers to a dataset. If there is only one dataset in the report, you can omit the Scope parameter. If there are multiple datasets, you must specify which one to use to avoid ambiguity.

Note: You cannot set the Scope parameter to Nothing outside of a data region.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


LookupSet Function in Data Regions

LookupSet Function in Data Regions
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Expressions > LookupSet Function in Data Regions

Glossary Item Box

The LookupSet function returns multiple row values from a specified dataset, so this function is used for one-to-many relationship in a data. The fields of the dataset returned by the LookupSet function behave as regular dataset fields that you can use in functions/aggregates within the scope of the data region.

The following data regions can use the LookupSet function in the Value property - Tablix, Table, Classic Chart, BandedList, List, and Sparkline.

Syntax

The basic syntax of the Lookup expression is as follows.

LookupSet(<SourceExpression>, <DestinationExpression>, <ResultExpression>, <LookupSetDataset>)

  • SourceExpression: An expression that is evaluated in the current scope and that specifies the name or key to look up.
  • DestinationField: An expression that is evaluated for each row in a dataset and that specifies the name or key to match on.
  • ResultExpression: An expression that is evaluated for the row in the dataset where source_expression = destination_expression, and that specifies the value to retrieve.
  • LookupSetDataset: A constant that specifies the name of a dataset in the report. For example, "ContactInformation".

The report below shows information on addresses for each employee and displays the addresses as string separated by commas. To display all addresses for each employee in a string separated by commas, we need to use the Join function in the expression with the LookupSet function.

For example:

=LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products")
=Join(LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products"), ",")

LookupSet Functions at Design Time

LookupSet Functions at Run Time

Usage

  • The data type of the SourceExpression and the DestinationExpression should be same.
  • When the Lookup function is used as a value expression in a data region, the expression is evaluated for each row or repeated data of the data region's dataset.
  • The Lookup function returns one value if found, and null if no rows are found in the Lookup dataset.
  • The Lookup expressions can be a part of aggregated expressions. A user can use the Lookup function in a table group or table header or footer, and sum all values for the table.

Limitations

  • Only "=" comparison is supported between SourceExpression and DestinationExpression.
  • Non-aggregate expressions such as multiply, mod, AND and OR, are not allowed in the comparison criteria.
  • Only one level of Lookup is allowed, that is, nested Lookup functions are not supported.

See Also

Link Multiple Datasets to Same Data Region

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Visualizers

Data Visualizers
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers

Glossary Item Box

Several report controls support a type of expression called Data Visualizers that lets you create small graphs to make your data easy to comprehend for the user. For instance, you can red flag an overdue account using the Flags Icon Set as a background image in the TextBox control.

There are several types of Data Visualizers available through a dialog linked to properties on the report controls. Let's explore each type of data visualizers in depth.

Image Data Visualizers

These Data Visualizers are supported in the Value property of the image report control, as well as in the BackgroundImage - Value property of TextBox, CheckBox, Shape, and Container report controls. See the topics below to learn more.

Caution: In the following topics, the terms "argument" and "parameter" may seem interchangeable, but within an expression, an argument refers to the returned value of a parameter, while a parameter may be just a variable.
Icon Set
Learn about the included image strips from which you can select using arguments. These include traffic lights, arrows, flags, ratings, symbols, and more, plus you can create your own custom image strips.
Range Bar
Learn how you can provide minimum, maximum, and length arguments to render a 96 by 96 dpi bar image in line with your text to show a quick visual representation of your data values.
Range Bar Progress
Learn how you can use a second bar to show progress along with the data range.
Data Bar
Learn about data bars, which are similar to range bars with a few different arguments.
Gradient
Learn how to apply gradient style to the background of a control.
Hatch
Learn how to apply hatch style to the background of a control.

Background Color Data Visualizer

These Data Visualizers are available in the BackgroundColor property of the TextBox and CheckBox report controls. See the following topics to learn more.

Color Scale 2
Learn about displaying TextBoxes with a range of background colors that are keyed to the value of the data.
Color Scale 3
Learn about color scales with an additional middle color value.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Icon Set

Icon Set
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Icon Set

Glossary Item Box

The Icon Set data visualization allows you to use arguments to select an image from an image strip and display it either as a BackgroundImage, or as a Value. You can use the standard image strips included with ActiveReports, or create custom image strips.

The Icon Set Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Report with Icon Set at Run Time

To open the dialog, drop down the BackgroundImage property of TextBox, CheckBox, Shape, and Container report controls, or the Value property of Image report control, and select <Data Visualizer...>. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Data Visualizers Dialog in the Value property of the Image control

Parameters

  • Icon Set. This designates the name of the icon set to use.
  • Icon 1 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 2 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 3 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 4 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 5 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.

You can use static values or any expression that evaluates to a Boolean value. For icon sets with fewer than five icons, set the unused values to False.

Standard Image Strips

Name | Image
Checkbox | Checkbox image
3TrafficLights | 3TrafficLights image
Arrows | Arrows image
Blank | Blank image
Flags | Flags image
GrayArrows | GrayArrows image
Quarters | Quarters image
Ratings | Ratings image
RedToBlack | RedToBlack image
Signs | Signs image
Symbols1 | Symbols1 image
Symbols2 | Symbols2 image
TrafficLights | TrafficLights image

Note: When using icon sets, you must set the Source property to Database, otherwise it may throw exception.

Syntax

=IconSet("Flags", False, True, False, False, False)

Usage

Following the Icon Set argument, there are five Boolean arguments. The first argument to evaluate to True displays the corresponding image. Use data expressions that evaluate to a Boolean value to replace the literal values in the code above.

Example

This expression displays the first symbol (the green flag) on each row in which the Difference exceeds 10, displays the second symbol (the yellow flag) on each row in which the quantity is greater than 0, and displays the third symbol (the red flag) on each row in which the quantity is equal to or below 0. Notice that we provide literal False values in the fourth and fifth arguments, which have no images in this strip.

Paste in the BackgroundImage Value property of a Textbox Copy Code
=IconSet("Flags",Fields!TaxPercent.Value > 10,Fields!TaxPercent.Value > 0,Fields!TaxPercent.Value <= 0,False,False)

In several of the included image strips, the last spots are empty. When using the Checkbox, 3TrafficLights, Flags, RedToBlack, Signs, Symbols1, Symbols2, or TrafficLights image strip, it generally makes sense to set the Boolean values for all of the unused icon spaces to False.

Custom Image Strips

The Blank image strip is included so that you can customize it. Custom image strips must conform to the following rules.

  1. The format must be of a type that is handled by the .NET framework.
  2. The size of the strip must be 120 x 24 pixels.
  3. Each image must be 24 x 24 pixels in size.
  4. There must be no more than five images in the strip.
  5. If there are fewer than five images in the strip, there must be blank spaces in the image to fill in.

Types of Custom Images

Here is the syntax for various types of custom images, followed by examples of each.

External image syntax Copy Code
=IconSet(location of image strip, condition#1, condition#2, condition#3, condition#4, condition#5)
External image path example Copy Code
=IconSet("C:\Images\customstrip.bmp", 4 > 9, 5 > 9, 10 > 9, False, False)
External image URL example Copy Code
=IconSet("http://mysite.com/images/customstrip.gif", 4 > 9, 5 > 9, 10 > 9, False, False)

Image from an assembly resource syntax Copy Code
=IconSet("res:[Assembly Name]/Resource name", condition#1, condition#2, condition#3, condition#4, condition#5)

Assembly resource image example Copy Code
=IconSet("res:ReportAssembly, Version=1.1.1.1./ReportAssembly.Resources.Images.CustomImage.png", 4 > 9, 5 > 9, 10 > 9, False, False)
Embedded image syntax Copy Code
=IconSet("embeddedImage:ImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Embedded image example Copy Code
=IconSet("embeddedImage:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70, Fields!Score.Value >=60, True)
Theme image syntax Copy Code
=IconSet("theme:ThemeImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Theme image example Copy Code
=IconSet("theme:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70, Fields!Score.Value >=60, True)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Range Bar

Range Bar
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Range Bar

Glossary Item Box

The Range Bar data visualization displays a 96 by 96 dpi bar image. The colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

Rang Bar Data Visualizer

The Minimum and Maximum arguments determine the range of data. The area between the Length argument and the Maximum argument is transparent (or between the Length and the Minimum in the case of a negative value).

The Range Bar Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Rang Bar Data Visualizer Dialog

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length in the bar image.
  • Start. The point from which the Range Bar begins to be rendered. The data type is Single.
  • Length. The width of the bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=RangeBar(Minimum, Maximum, Color, Start, Length)

Usage

Use this data visualizer to render a bar in the color specified, the length of which changes depending on the number returned by the Length parameter, in the case of the simple example, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the DataBar. The area between the Length and the Maximum is transparent.

Example 1: Easy

Set the Length parameter to the value of a field in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBar(0,15000,"BlueViolet",0,Fields!GrossProfit.Value)

An example of using Range Bar Data Visualizer

Example 2: Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In this example, if the Projected Stock value is negative, it renders in Crimson, while positive values render in BlueViolet. You can also see that negative values render to the left of Zero and positive values render to the right. A Length value of exactly zero renders as a diamond.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBar(-5,20,IIf((Fields!InStock.Value - 5) < 0, "Crimson", "BlueViolet"),0,Fields!InStock.Value-5)
An example of using Range Bar Data Visualizer

Default Behavior

The function returns null (i.e. no image is rendered) in the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Range Bar Progress

Range Bar Progress
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Range Bar Progress

Glossary Item Box

The Range Bar Progress data visualization displays a 96 by 96 dpi double bar image. The first colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

The second colored bar renders using the ProgressColor as one fourth of the height of the image, centered vertically over the Length bar. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Progress argument. If the Progress argument is zero, a smaller diamond renders.

Range Bar Progress

The Minimum and Maximum arguments determine the range of data. The area between the Length and Progress arguments and the Maximum argument is transparent (or between the Length and Progress and the Minimum in the case of a negative value).

The Range Bar Progress Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length, the thicker bar in the bar image.
  • Start. The point from which the Range Bar Progress begins to be rendered. The data type is Single.
  • Length. The length of the thicker bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.
  • ProgressColor. The HTML color string to use in rendering the Progress, the thinner bar in the bar image.
  • Progress. The length of the thinner bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Expressions topic.

Syntax

=RangeBarProgress(Minimum, Maximum, Color, Start, Length, ProgressColor, Progress)

Usage

Use this data visualizer to render a double bar in the colors specified, the length of which changes depending on the number returned by the Length parameter for the thick bar, in the case of the simple example, GrossSales. The thin bar length is based on the value returned by the Progress parameter, in this case, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the Range Bar. The area between the Length or Progress and the Maximum is transparent.

Example 1: Easy

Set the Length and Progress parameters to the values of fields in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBarProgress(0,30000,"BlueViolet",0,Fields!GrossSales.Value,"Gold",Fields!GrossProfit.Value)

An example of using Range Bar Progress data visualizer

Example 2: Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In the example below, if the Difference value is negative, it is rendered in red, while positive values are rendered in gold. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right. A Length value of exactly zero is rendered as a diamond. The thicker blue violet bar represents the InStock value.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBarProgress(-10,20,"BlueViolet",0,Fields!InStock.Value,IIf(Fields!Difference.Value < 0, "Red", "Gold"),Fields!Difference.Value)

Using negative values in Range Bar Progress data visualizer

Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

The Progress value changes in the following cases:

  1. If the Start value plus the Progress value is less than the Minimum value, Progress becomes Minimum minus Start.
  2. If the Start value plus the Progress value is greater than the Maximum value, Progress becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0
ProgressColor | Red
Progress | 0

Dialog

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackgroundImage Value property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options on the dialog.

For a Range Bar Progress expression, be sure to select the Display a progress indicator check box. This enables the progress options.

Range Bar Data Visualizer dialog

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Bar

Data Bar
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Data Bar

Glossary Item Box

The Data Bar data visualization displays a 96 by 96 dpi bar image. The colored bar fills the Image top to bottom, while the Value argument determines the amount of colored bar to render to the right of the Zero argument (or to the left in the case of a negative value).

Data Bar data visualization

The Minimum and Maximum arguments determine the range of data. The area between the Value argument and the Maximum argument is transparent (or between the Value and the Minimum in the case of a negative value).

The Data Bar Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. The lowest value in the range of data against which the Value argument is compared. This value corresponds to the leftmost edge of the image. If this argument is greater than the Zero argument, Zero becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data against which the Value argument is compared. This value corresponds to the rightmost edge of the image. If this argument is less than the Zero argument, Zero becomes equal to Maximum. The data type is Single.
  • Zero. This value determines the zero point to the left of which negative data is rendered, and to the right of which positive data is rendered. The data type is Single.
  • Color. The HTML color string to use in rendering the Value in the bar image.
  • Alternate Color. The HTML color string to use when the Value is less than the Zero value (optional).

Select the Use Alternate Color when Value is less than Zero Value check box to enable the Alternate Color parameter. You can use static values or aggregate functions (e.g. Min or Max) to set parameters. For more information on these and other aggregate functions, see the Expressions topic.

Syntax

=DataBar(Value, Minimum, Maximum, Zero, Color)
=DataBar(Value, Minimum, Maximum, Zero, Color, Alternate Color)

Usage

Use this data visualizer to render a bar in the color specified, the length of which changes depending on the number returned by the Value parameter, in the case of the simple example, InStock. If your data contains only positive values, Zero corresponds with Minimum at the left edge of the Data Bar. The area between the Value and the Maximum is transparent.

Example 1: Easy

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundImage Value property of a TextBox Copy Code
=DataBar(Fields!InStock.Value,0,20,0,"BlueViolet")

Using Data Bar data visualizer

Example 2: Using Negative Values

When your data contains negative as well as positive values, you can select the Use Alternate Color when Value is less than Zero Value check box, and then select an Alternate Color. In this example, if the Difference value is negative, it is rendered in Crimson, while positive values are rendered in BlueViolet. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right.

Paste in the BackgroundImage Value property of a TextBox Copy Code
=DataBar(Fields!Difference.Value,-10,20,0,"BlueViolet","Crimson")

Using negative values in Data Bar data visualizer

Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
Zero | 0
Color | Green
Alternate Color | null

Dialog

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Data Bar Data Visualizer dialog

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Gradient

Gradient
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Gradient

Glossary Item Box

The Gradient data visualization displays a gradient of color that transitions from one color to another.

When you select a Shape control on your report, in the Properties window, drop down the BackGroundImage - Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Gradient Data Visualizer

Parameters

  • Gradient type. The available gradient types are Horizontal, Vertical, DiagonalUp, DiagonalDown, FromCenter, and FromCorner.
  • Color1. The start (primary) color of the gradient.
  • Color2. The end (secondary) color of the gradient.

Syntax

=Gradient(Gradient type, Color1, Color2)

Usage

Using Data Visualizers, the gradient can be applied in TextBox, Shape, CheckBox, and Container controls from BackgroundImage - Value property and in Image control from Value property. The following example shows how Gradient background style can be simply applied to a control.

Example

Set the following expression in the BackgroundImage.Value property of the Shape .

Paste into the BackgroundImage Value property of a Shape Copy Code
=Gradient("Vertical","LightCyan","BlueVoilet")

Data Visualizers Dialog for Gradient type with Settings

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Hatch

Hatch
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Hatch

Glossary Item Box

The Hatch data visualization displays the geometric hatch pattern.

When you select a Shape "images/design-reports/ on your report, in the Properties window, drop down the BackGroundImage - Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Data Visualizers dialog with Hatch settings

Parameters

  • Hatch style. The available hatch styles are Horizontal, Vertical, ForwardDiagonal, BackwardDiagonal, LargeGrid, and many more.
  • Color1. The color of pattern or foreground color.
  • Color2. The background color.

Syntax

=Hatch(Hatch style,Color1,Color2)

Usage

Using Data Visualizers, the hatch can be applied in TextBox, Shape, CheckBox, and Container control's from BackgroundImage - Value property and in Image control from Value property. The following example shows how Hatch background style can be simply applied to a control.

Example

Set the following expression in the Shape control's BackgroundImage - Value property.

Paste into BackgroundImage property Copy Code
=Hatch("BackwardDiagonal","LightCyan","BlueViolet")

Hatch Data Visualizer in the Shape control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Color Scale 2

Color Scale 2
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Color Scale 2

Glossary Item Box

The ColorScale2 data visualization displays a background color in a range of colors to indicate minimum and maximum values, and all shades in between. The Color Scale Data Visualizer is available for TextBox and CheckBox controls.

When you select a TextBox or a CheckBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you select the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale3. For more information, see ColorScale3.

Data Visualizers dialog with ColorScale2 settings

Parameters

  • Value. This is the field value in the report to evaluate. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor renders.
  • Maximum. If the Value evaluates to this number, the EndColor renders.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min or Max) to set the Minimum and Maximum parameters. For more information on these and other aggregate functions, see the Expressions topic.

Syntax

=ColorScale2(Value, Minimum, Maximum, StartColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox or a CheckBox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Maximum render with a color between the StartColor and EndColor.

Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox Copy Code
=ColorScale2(Fields!InStock.Value,0,20,"Crimson","MidnightBlue")

ColorScale2 Usage Example in the BackgroundColor of Textbox

Default Behavior

The function returns Transparent in any of the following cases:

  1. The Value is out of range (i.e. does not fall between the Minimum and Maximum values).
  2. The Maximum is less than the Minimum.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
StartColor | Silver
EndColor | WhiteSmoke

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Color Scale 3

Color Scale 3
Report Authors > Design Reports > Design Page/RDLX Reports > Data Visualizers > Color Scale 3

Glossary Item Box

The ColorScale3 data visualization displays a background color in a range of colors to indicate minimum, middle, and maximum values, and all shades in between. The Color Scale Data Visualizer is available for TextBox and CheckBox controls.

When you select a TextBox or a CheckBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you clear the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale2. For more information, see ColorScale2.

Data Visualizers dialog with ColorScale3 settings

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor is rendered.
  • Middle. If the Value evaluates to this number, the MiddleColor is rendered.
  • Maximum. If the Value evaluates to this number, the EndColor is rendered.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • MiddleColor. The HTML color string to use if the Value evaluates to the Middlevalue.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min, Avg, or Max) to set the Minimum, Middle, and Maximum parameters. For more information on these and other aggregate functions, see the Expressions topic.

Syntax

=ColorScale3(Value, Minimum, Middle, Maximum, StartColor, MiddleColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox or a CheckBox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Middle value render with a gradient scale color between the StartColor and MiddleColor. The closer the value is to the Minimum, the closer to Crimson the color renders. In the same way, values falling between the Middle and Maximum render with a color between the MiddleColor and EndColor, in this case, varying shades of yellow-green.

Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox Copy Code
=ColorScale3(Fields!InStock.Value,0,10,20,"Crimson","Yellow","MidnightBlue")

ColorScale3 Usage Example in the BackgroundColor of Textbox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Filters

Filters
Report Authors > Design Reports > Design Page/RDLX Reports > Filters

Glossary Item Box

In Page and RDLX reports, ActiveReports allows you to set filters on a large set of data that has already been retrieved from the data source and use them with datasets or data regions to limit the information you want to display on your report.

Although not as efficient performance-wise as query parameters which filter data at the source, there are still scenarios which demand filters. The obvious case is when the data source does not support query parameters. Another case for using filters is when users who require different sets of data view in the same report.

You can set filters on a Filters page similar to the one in the following image.

DataSet Filters Page

A filter consists of the three major elements:

  • Expression: Type or use the expression editor to provide the expression on which to filter data. See Expressions page on more information.
  • Operator: Select the operator to compare the expression results with the Value.
  • Value: Enter the value with which to compare the expression results.

For example, in the filter =Fields!YearReleased.Value = 1997 applied on a dataset from the Movies table of the Reels.db database, =Fields!YearReleased.Value is set under expression, = is the operator and 1997 is the value on which filter is set.

You can also use multiple values with the In and Between operators. Two fields with an And in the middle appear for the Between operator, and another Expression field is available at the bottom of the Filters page or tab for the In operator. The following table lists all available filtering operators.

Filtering Operators

Filter | Description
Equal | Select this operator if you want to choose data for which the value on the left is equal to the value on the right.
Like | Select this operator if you want to choose data for which the value on the left is similar to the value on the right. See the MSDN Web site for more information on the Like operator.
NotEqual | Select this operator if you want to choose data for which the value on the left is not equal to the value on the right.
GreaterThan | Select this operator if you want to choose data for which the value on the left is greater than the value on the right.
GreaterThanOrEqual | Select this operator if you want to choose data for which the value on the left is greater than or equal to the value on the right.
LessThan | Select this operator if you want to choose data for which the value on the left is less than the value on the right.
LessThanOrEqual | Select this operator if you want to choose data for which the value on the left is less than or equal to the value on the right.
TopN | Select this operator if you want to choose items from the value on the left which are the top number specified in the value on the right.
BottomN | Select this operator if you want to choose items from the value on the left which are the bottom number specified in the value on the right.
TopPercent | Select this operator if you want to choose items from the value on the left which are the top percent specified in the value on the right.
BottomPercent | Select this operator if you want to choose items from the value on the left which are the bottom percent specified in the value on the right.
In | Select this operator if you want to choose items from the value on the left which are in the array of values on the right. This operator enables the Values list at the bottom of the Filters page.
Between | Select this operator if you want to choose items from the value on the left which fall between pair of values you specify on the right. This operator enables two Value boxes instead of one.

You can set filters on the following:

  • DataSet
  • Data Region
  • Groups in a Data Region

Set a Filter on a DataSet

When you set a filter on a dataset, any control you add to the design surface can use this filtered data. Let us elaborate the dataset filtering using the 'Movie' table from Reels.db data source on GitHub.

  1. In the Report Explorer, right-click the DataSet node and select Edit.
  2. In the DataSet dialog that appears, go to the Filters page and click the Add (+) icon to add a new filter for the data set. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  4. Under Operator, select an operator from the list to decide how to compare the 'Expression' with the 'Value'. For example, set a GreaterThan operator on the expression above.
  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2003 to represent the year 2003. The resultant filter looks as follows.
    =Fields!YearReleased.Value > 2003
    DataSet Filters Page Sample
  6. Now that the dataset filter is configured, to view the filtered data, let us add a Table data region and drag-drop fields such as 'Title', 'Year Released', and 'User Rating' on its Details row.
  7. Preview the report. You see that the table displays the records only for the years where 'Year Released' is greater than '2003'.
    Dataset Filter sample at run time

Set a Filter in a Data Region

When you set a filter in a data region, you can limit the amount of data available for use inside that data region. The following steps are applicable to Table and List data regions, and the data regions are bound to the 'Movie' table from Reels.db data source on data source on GitHub.

  1. With the data region selected on the report, under the Properties window, click the Property dialog link to open the data region dialog.
  2. In the data region dialog that appears, select the Filters page and click the Add (+) icon to add a new filter for the data region. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example,
    =Fields!UserRating.Value
  4. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, set a LessThan operator on the Expression above.
  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 6 to represent the Rating 6. The resultant filter looks like the following.
    =Fields!UserRating.Value < 6
    Sample of adding a filter in a data region
  6. Preview the report to get the filtered data.

For Tablix data region, follow these steps to add a filter. Let us demonstrate applying a filter on the Tablix data region using the 'TablixSample.rdlx' report that you can find in Samples19 folder on GitHub. In this report, we will apply filter such that only the records for the year '1995' are shown.

  1. With the Tablix data region selected, go to the Filters property in the Properties window.
  2. Click the ellipses next to '(Collection)' to open the Filter dialog.
  3. Click Add to add a filter, and in the FilterDesigner properties, enter the FilterExpression to =Fields!Years.Value and Operator to Equal.
  4. In the FilterValues property, click the ellipses next to '(Collection)' to open the FilterValueExpressionDesigner Collection Editor.
  5. Click Add to add the filter values and set the filter values properties.
  6. In Expression, specify the value to which the filter expression should be evaluated, in our case, set Expression to '1995'.
    Adding a filter in Tablix
  7. Click OK to complete setting up the filter value and then again to finish adding the filter.
    Sample of Tablix report with filter at run time

Set a Filter on Groups in a Data Region

You can also set filters on grouped data in a data region. The following example uses the Table data region to show filtering on groups.

  1. In the report, set grouping on a data region. For example, on a Table data region, set grouping on the =Fields!YearReleased.Value field.
  2. With the data region selected on the report, under the Properties window, click the Property dialog link to open the data region dialog.
  3. In the Table dialog, go to the Groups tab and select the Group.
  4. After selecting the group, go to the Filters tab and click the Add (+) icon to add a new filter. By default, an empty filter expression gets added to the filter list.
  5. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  6. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, GreaterThan operator set on the Expression above.
  7. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2005 to represent the year 2005. The resultant filter looks like the following.
    =Fields!YearReleased.Value > 2005
    Adding a filter to a Table data group
  8. Preview the report to get the filtered data.
    Sample of Table report with data group filter at run time

For Tablix data region, follow these steps to add a filter. Let us demonstrate applying a filter on the Tablix data region using the 'TablixSample.rdlx' report that you can find in Samples19 folder on GitHub.

  1. With the Tablix data region selected, go to the Filters property in the Properties window.
  2. Click the ellipses next to '(Collection)' to open the Filter dialog.
  3. Click Add to add a filter, and in the FilterDesigner properties, enter the FilterExpression to =Fields!Years.Value and Operator to Equal.
  4. In the FilterValues property, click the ellipses next to '(Collection)' to open the FilterValueExpressionDesigner Collection Editor.
  5. Click Add to add the filter values and set the filter values properties.
  6. In Expression, specify the value to which the filter expression should be evaluated, in our case, set Expression to '1995'.
    Adding a filter to a Tablix data group
  7. Click OK to complete setting up the filter value and then again to finish adding the filter.
    Sample of Tablix report with data group filter at run time

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Groups

Groups
Report Authors > Design Reports > Design Page/RDLX Reports > Groups

Glossary Item Box

In a Page report and RDLX report, you can add groups to organize data in your reports. The most common grouping scenario is to create groups by fields or expressions in a data region.
Depending on the data region you select, you can group data in one of the following ways:

  • In a Table or BandedList, you can add group header and footer rows. You can also set detail grouping in the Table data region.
  • In a List, you can set detail grouping.
  • In a Tablix, you can add columns and rows either dynamically or manually to group data.
  • In a Classic Chart , you can group data by categories or series.

Group in a FixedPage

In a Page report, you can group your data on the fixed page. A group set on the fixed page, applies to the entire report including the controls within the report. Therefore, once you set grouping here, you may decide not to group individual data regions. See Page Report topic for more information on properties available for grouping data.

Use the following steps to understand how to apply grouping on a fixed page. These steps assume that you have already added a Page report template, connected it to a data source and created a dataset.

  1. Right-click the gray area outside the design surface and select Fixed Layout Settings or with the fixed page selected, under the Properties Panel, click the Property dialog link to open the FixedPage dialog.
  2. On the Grouping page, in the General tab, under Group on enter the field name or expression on which you want to group the data. For example, =Fields!YearReleased.Value.
    Note: A default group name like FixedPage1_Group appears under Name, once you set the group. To modify the group name, add a field name or expression under Group on to enable the Name option and enter a new name.
  3. Under the Document map label field, you can optionally set a label to add the item to the document map.
  4. Click OK to close the dialog.
  5. Drag and drop a data region, for example, a Table data region, onto the design surface and set data inside its cells.
  6. Go to the Preview Tab to view the result. You'll notice that the data appears in groups sorted according the YearReleased field on each report page.

Detail Grouping in List and Table Data Regions

Detail grouping is available in the List and Table data regions. It is useful when you do not want to repeat values within the details. When you set detail grouping, the value repeats for each distinct result of the grouping expression instead of each row of data.

For example, in Table topic, if you do not set detail grouping, you see each year as many times as there are movies from that year.
Ungrouped Table Data

If you set detail grouping to =Fields!YearReleased.Value, each year appears only once.

Grouped Table Data

Recursive Hierarchies

If you want to display parent-child relationships in your data, you can create a recursive hierarchy. To do this, you need a unique ID field for the child group and an ID field for the parent group.

For example, if you have pulled data from the Reels database using the following SQL query:

SQL Query Copy Code
SELECT EmployeePosition.*, Employee.*, Employee_1.PositionID AS ManagerPosition FROM Employee AS Employee_1 RIGHT JOIN (EmployeePosition INNER JOIN Employee ON EmployeePosition.PositionID = Employee.PositionID) ON Employee_1.EmployeeID = Employee.ManagementID;

You can set Detail Grouping in a Table data region using the =Fields.Item("EmployeePosition.PositionID").Value field, and the =Fields!ManagerPosition.Value field as the parent group to display parent-child relationships in your data. To view the hierarchy level, add another column in the table and add expression =Level().

Note: You can use only one group expression when you set a parent group.

Level Function

To better visualize data in a recursive hierarchy, you can use the Level function, which indents text and further clarifies the relationships between parent and child data. To do this, you set an expression in the Padding - Left property of the text box you want to indent.

For example, in a Table data region, for the recursive hierarchy example above, you can set the following expression in the Padding - Left property of the text box that contains the 'Title' to indent values according to levels:

=Convert.ToString(2 + (Level()*10)) & "pt"

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Interactivity

Interactivity
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity

Glossary Item Box

ActiveReports supports a number of features like parameters, filters, drill-down, links, document map and sorting to provide reports with interactive capabilities.

ActiveReports supports features like parameters, filters, drill-down, links, document map and sorting to provide an interactive look to your report at run time.

Parameters

ActiveReports allows you to set parameters in your report to filter the data displayed. Parameters make navigation of the report easier for the user at run time. See Parameters for further details.

Drill-Down Links

When you open a report with drill-down features, part of the data is hidden so that you only see high-level data until you request more detail. See Drill-Down Links for more information.

Bookmark, Hyperlinks, and Drill-Through Links

Bookmark Links

When you click a bookmark link, the viewer navigates to a bookmarked item within the current report.

See Bookmarks for further details.

Hyperlinks

When you click a hyperlink, your machine's default internet browser opens to display a Web page.

See Hyperlinks for further details.

Drill-Through

Using the drill-through link feature in your report you can navigate to another report for details about the item you clicked.

See Drill-Through Links for further details.

Sorting

The sorting feature allows you to organize your data and present it in a logical order at run-time. Using this feature you can sort the data alphabetically or numerically in ascending or descending order. See Sort Data for further details.

Note: You cannot use the interactive features in the following cases:
  • With Adobe Acrobat Reader and RawHTML types of the WebViewer.
  • With reports that use the collation feature, i.e. reports that have two or more themes.

Document Map

The Document Map (Table of Contents) feature allows you to navigate to a particular report section, or an item in a report. See Document Map for further details.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Parameters

Parameters
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Parameters

Glossary Item Box

ActiveReports allows you to use parameters to filter or add the data to display in reports. You can either prompt users for parameters so that they control the output, or supply the parameters behind the scenes.

In a Page or an RDLX report, the easiest way to build queries with parameters is to use the Visual Query Designer, as it automatically sets up each parameter.
In the DataSet dialog, click on Button to access Visual Query Designer to create SQL queries. See Query Builder in Microsoft SQL Client and OLEDB Providers for further information on creating a parameterized query using the interactive query designer.

However, if you would like to create parameterized query manually, you must enter each parameter in three locations:

  • The Report Parameters dialog,
  • The Parameters page of the DataSet Dialog, and
  • The Query page of the DataSet Dialog.

Report - Parameters Dialog

The Report - Parameters dialog allows you to control how and whether a user interface is presented to your users for each parameter. Parameter values are collected in the order they appear in the Report Parameters collection. You can change the order using the arrows in the Report - Parameters dialog.

The Report - Parameters dialog contains a parameters page with a list of parameters and three tabs to set parameter properties. You need to set the following properties in the dialog to create a parameter:

  1. In the General tab, enter a report parameter name. Each report parameter in the collection must have a unique name, and the name must match the name you enter or call in the Parameters page of the DataSet dialog.
  2. Set the data type, the text used to prompt the user, whether to allow null, blank, multiple values or multiline text, and whether to hide the user interface. For parameters with Date or DateTime data types, you have the choice to select the display format.
  3. Go to the Available tab to populate a list of available values from which users can choose, or the Default tab to set the default value.

The tabs in the Report - Parameters Dialog are explained below.

General
Available Values
Default Values
  • Name: Set the name for the parameter in this field. The value you supply here appears in the parameters list and must match the corresponding query parameter.
  • Data type: Set the data type for your parameter which must match the data type of the field that it filters. The interface presented might also differ depending on the data type.
    • Boolean: Presents the user with two options True or False
    • Date: Presents the user with a calendar picker to select a date if you do not supply a default value or a drop-down selection of available values
    • DateTime: Presents the user with a calendar picker to select a date and a time picker to select the time in cases where you do not supply a default value or a drop-down selection of available values
    • Integer: Presents the user with a text box or a drop-down selection of available values
    • Float: Presents the user with a text box or a drop-down selection of available values
    • String: Presents the user with a text box or a drop-down selection of available values
  • Text for prompting users for a value: Enter the text you want to see on the user interface to request information from the user in this field. By default this is the same as the Name property.
  • Allow null value: Select this check box if you want to allow null values to be passed for the parameter. It is not selected by default.
  • Allow blank value: Select this check box if you want to allow blank values to be passed for the parameter. It is not selected by default.
  • Multivalue: Select this check box to allow the user to select multiple items in the available values list.
    For a multi-value parameter, you can also allow user to specify special value for 'Select all' option in the Value for 'Select All' property.
  • Multiline: Select this check box to allow multiline values in the parameter. The control will automatically adjust to accommodate multiple lines.
  • Hidden: Select this check box to hide the parameter interface from the user and instead provide a default value or pass in values from a subreport or drill-through link. Please note that if you hide the user interface and do not provide a default value, the report will not run.
  • Name: Set the name for the parameter in this field. The value you supply here appears in the parameters list and must match the corresponding query parameter.
  • Data type: Set the data type for your parameter which must match the data type of the field that it filters. The interface presented might also differ depending on the data type.
    • Boolean: Presents the user with two options True or False
    • Date: Presents the user with a calendar picker to select a date if you do not supply a default value or a drop-down selection of available values
    • DateTime: Presents the user with a calendar picker to select a date and a time picker to select the time in cases where you do not supply a default value or a drop-down selection of available values
    • Integer: Presents the user with a text box or a drop-down selection of available values
    • Float: Presents the user with a text box or a drop-down selection of available values
    • String: Presents the user with a text box or a drop-down selection of available values
  • Text for prompting users for a value: Enter the text you want to see on the user interface to request information from the user in this field. By default this is the same as the Name property.
  • Allow null value: Select this check box if you want to allow null values to be passed for the parameter. It is not selected by default.
  • Allow blank value: Select this check box if you want to allow blank values to be passed for the parameter. It is not selected by default.
  • Multivalue: Select this check box to allow the user to select multiple items in the available values list.
    For a multi-value parameter, you can also allow user to specify special value for 'Select all' option in the Value for 'Select All' property.
  • Multiline: Select this check box to allow multiline values in the parameter. The control will automatically adjust to accommodate multiple lines.
  • Hidden: Select this check box to hide the parameter interface from the user and instead provide a default value or pass in values from a subreport or drill-through link. Please note that if you hide the user interface and do not provide a default value, the report will not run.
  • Display format: Choose a format for a Date or DateTime data type. The selected format is displayed in the preview in the Parameters pane. The Display format applies to parameters with available values specified by a query and the default parameter value.

These values are used to fill a drop-down list from which the end user can choose.

  • Non-queried: You can supply Labels and Values by typing in static values or using expressions.
  • From query: You can select a Dataset from which to select a Value field and Label field.
This is the value that you give for the parameter if the user does not supply one, or if you hide the parameter user interface. You can choose from 'Non-queried' and 'From query' options.
  • Non-queried: You can supply a default Value by entering a static value or using an expression.
  • From query: You can select a Dataset from which to select a Value field.
  • None: You can have your users provide a value for the parameter.
Note: In the Available Values tab the Value is what is passed to the query parameter, and the Label is what is shown to the user. For example, if the Value is an Employee Number, you might want to supply a more user-friendly Label showing Employee Names.

To access the Report - Parameters Dialog

You can access the Report - Parameters dialog through any one of the following:

  • In the Report Explorer, click the Add (+) icon and select the Parameter option.
  • In the Report Explorer, right-click the Parameters node and select Add Parameter.
  • In the Report Explorer, right-click the Report node and select Report Parameters.
  • From the Report Menu, select Report Parameters.

Parameters Page of the DataSet Dialog

On the Parameters page of the DataSet Dialog, pass a Report Parameter into the parameter in your query. You can click the Add (+) icon at the top of the parameters list, enter parameter name, and supply a value like:

=Parameters!MPAA.Value

Query Page of the DataSet Dialog

On the Query page of the DataSet Dialog, enter the parameter in the SQL query. Use the syntax specific to your data source type to create a parameter. For example, with an OleDB data source, add a query like the following for a multi-value Movie Rating parameter:

SELECT * FROM Movie WHERE (MPAA = ? AND YearReleased = ?)

If you want to run a report without prompting the user for a value at run time, you need to set a default value for each parameter, and the Hidden check box should be selected in the Report - Parameters dialog > General tab.

Subreport parameters are also considered hidden parameters, as a user can easily synchronize a subreport's data with that of the parent report. See Subreport for further details.

Drill-Through parameters are also hidden parameters, as drill-through links are used to navigate from one report to another. When you select Jump to report for the action, the parameters list is enabled.

Parameter in SQL query for Data Sources

A query parameter can get its value from the Report Parameters collection (entered by the user or from a value you supply), a field in another dataset, or an expression. Syntax for adding a parameter in your query might differ depending upon the data source that you are using. Use the syntax specific to your data source type to create a parameter.

Parameterized query for different data sources are as follows:

Data Source Parameter Syntax Example
OleDB (?)
SELECT * FROM Customer WHERE (CustomerID = ? AND AccountNumber = ?)
ODBC (?)
SELECT * FROM Customer WHERE (CustomerID = ? AND AccountNumber = ?)
SQL Client @ParameterName
SELECT * FROM Customer WHERE (CustomerID = @CustomerID AND AccountNumber = @AccountNumber)
OracleDB :ParameterName
SELECT * FROM Customer WHERE CustomerID = :CustomerID AND AccountNumber = :AccountNumber

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Multi-Value Parameter

Multi-Value Parameter
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Parameters > Multi-Value Parameter

Glossary Item Box

A multi-value parameter allows you to input one or more than one parameter values in a report. You can choose a few options from the list or simply choose 'Select all' to select all options.

You need to check the Multivalue option to make a parameter multi-value, and optionally set Value for 'Select All'. If there are large number of options to choose from, choosing 'Select all' option creates an SQL query too long for an SQL Command to run. In such a case, you can specify a value to the multi-value parameter in Value for 'Select All' option.

The following procedure takes you through a step by step process of how to create a multi-value parameter and specify a value for selecting all options from the list. The report binds to the 'Products' table from 'NWIND.db' data source available on GitHub. It is a SQLite Provider, a custom data provider that works if System.Data.SQLite package is added and referenced in the ActiveReports.config file. See setting up the dependencies and configuration file as described in the topic Custom Data Providers.

Create a Report

In the ActiveReports Designer, create a new Page or an RDLX report.

Bind Report to Data

As you create a new report, Report Datasource dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'SQLite Provider'.
  3. In the Connection String, enter the path of the .db, here, 'NWIND.db', for example
    Data Source=C:\Data\NWIND.db
  4. Click OK to close the dialog and complete the data source connection.

Create Dataset to Populate Parameter Values

  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set. See Add Dataset for more information.
  2. In the DataSet dialog that appears, select the Query page.
  3. Enter an SQL query like the following into the Query text box:

    SELECT DISTINCT productName FROM Products

    See Query Builder in Microsoft SQL Client and OLEDB Providers for more information on building SQL queries.
  4. Click the OK to close the dialog. You see the data set, DataSet1, and the field, productName, in the Report Explorer.

Add Report Parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
    Add Parameter in the Report Explorer
  2. In the Report - Parameters dialog that appears, add a name for the parameter, ReportParameter1.
  3. Ensure that the Data type matches that of the field (String for ProductName).
  4. Enter some text in the Text for prompting users for a value field.
  5. Select the check box next to Multivalue to allow users to select more than one item from the list.
  6. In the Value for 'Select All' option, enter '1'.
    Report Parameters Dialog

Provide List of Values for Report Parameter

  1. In the Report - Parameters dialog, go to the Available Values tab and select the From query radio button.
  2. Under the Dataset field, select the dataset created in the previous steps (DataSet1).
  3. Under the Value and Label fields, use the drop-down to select the field, productName.
  4. Click OK to close the dialog and add the parameter to the collection.

Add Dataset with Parameter

  1. In the Report Explorer, right-click the Data Source (DataSource1) node and select Add Data Set.
  2. In the DataSet dialog, on the Parameters page, click the Add (+) icon above the parameters list and add the following to the dataset to provide values for the parameters we add to the query in the step 3 below.
    Name: ReportParameter1 Value: =Parameters!ReportParameter1.Value
    Name: Parameter1 Value: =Parameters!ReportParameter1.Value
    DataSet Parameters Dialog
  3. On the Query page, enter a SQL query like the following in the Query text box:

    SELECT * FROM products WHERE ProductName in (?) OR '1' in (?)

    At run time, this query matches the selected product name and fetches data accordingly. If the user chooses 'Select all' (for which we have specified value '1'), then query after 'OR' is evaluated and data is fetched for all products.
  4. Click the Validate DataSet icon to validate the query and to populate the Fields list.
  5. Click the OK to close the dialog. You see the data set, DataSet2, and the fields in the Report Explorer.

Design report

  1. Drag-drop Table data region and bind it to the DataSet2.
  2. Fill-in the table with some fields, for example, [ProductName], [UnitPrice], and [UnitsOnOrder]. See page on Table data region for more information.
  3. Preview the report and observe the 'Parameters panel in the sidebar with Select all option at the top. For more information on Parameters pane, see Windows Forms Viewer.

Sample report with a multi-value parameter at preview

Note: If the Available Values (queried or non-queried) for a parameter contain only some values from database and the Select all value is specified for the parameter, then at report preview, selecting the 'Select all’ checkbox shows all records from the database instead of only those present in the parameter. For example, if the database has four records and in the Available values there are only two records, with the Select all value specified, then on previewing report and selecting 'Select all' checkbox, all four records are shown instead of only two.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Cascading Parameter

Cascading Parameter
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Parameters > Cascading Parameter

Glossary Item Box

When a parameter’s value list depends on the value of another parameter, the report collects the required parameter value and uses it to create the value list for the second parameter. This cascade of parameter values is sometimes also called dependent or hierarchical parameters.

You can create cascading parameters in a Page or an RDLX report using the following steps.

Note: This topic uses the Reels database. The Reels.db file can be downloaded from GitHub.
  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set to create a dataset named Regions.
    Add Data Set in the Report Explorer
  2. On the Query page of the DataSet Dialog, use the following SQL Query to fetch data from the Regions table.
    SELECT RegionID, Region FROM Regions
  3. Click OK to close the dialog.
  4. Follow the step 1 to create another dataset named Districts and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named Region with the value set to:
    =Parameters!Region.Value
    This parameter is added to the Report Parameters collection later.
  5. In the Districts dataset dialog, on the Query page, add the following SQL query to fetch data from the Districts table. This query depends on the Region parameter.
    SELECT DistrictID, District FROM Districts WHERE Region = ?
  6. Click OK to close the Districts DataSet dialog.
  7. Follow the step 1 and create another dataset named StoreNames and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named DistrictID with the value set to:
    =Parameters!DistrictID.Value
    This parameter is added to the Report Parameters collection later.
  8. In the StoreNames dataset, on the Query page, add the following SQL query to retrieve data for the selected region from the selected district. This query depends on the DistrictID parameter.
    SELECT StoreID, StoreName, OpenDate FROM Store WHERE NOT StoreID = 0 AND DistrictID = ?
  9. Click OK to close the StoreNames DataSet dialog.
  10. In the Report Explorer, right-click the Parameters node and select Add Parameter
    Add Parameter in the Report Explorer
  11. In the Report - Parameters dialog that appears, add a parameter named Region with an Integer data type. On the Available Values tab, select From query and set the Dataset to Regions, the Value field to RegionID, and the Label field to Region.
  12. Click OK to close the Report - Parameters dialog.
  13. Follow the same process as steps 10 and 11 to add a second parameter named DistrictID with an Integer data type. On the Available Values tab, select From query and set the Dataset to Districts, DistrictID for the Value field, and District for the Label field.
  14. Drag and drop a Table data region (or any other data region) onto the design surface, and drag the StoreID, StoreName and OpenDate fields onto the Details row.
  15. Preview the report to view the result.
    Sample report with a cascading parameter at preview

Notice that the two drop down lists, for regions and districts appear in the Parameters sidebar while the second drop down list remains disabled until a region is selected. Click the View Report button to see the StoreID, StoreName and OpenDate values returned for the selected region and district.

Note: In a Page report, when you have multiple datasets in the report, you need to set the DataSet property on the General tab of the FixedPage dialog in order to specify which dataset is used to display data in the report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Hidden Parameter

Hidden Parameter
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Parameters > Hidden Parameter

Glossary Item Box

If you want to run a report without prompting the user for a value at run time, you need to set a default value for each parameter. The report collects the required parameter value from the default value and uses it to generate the report.

Default values can be queried or non-queried. A non-queried default value can be a static value or an expression. A queried default value is a field value from a dataset.

Note: This topic uses the DVDStock table in the Reels database. The Reels.db file can be downloaded from GitHub.
  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
    Add Parameter in the Report Explorer
  2. In the Report - Parameters dialog that appears, add a parameter named StorePrice with an Integer data type. Click the checkbox next to Hidden to hide the parameter UI at run time.
  3. On the Default Values tab, select Non-queried and click the Add(+) icon to add an empty expression for the value.
    Note: When you use From query to provide a default value, only the first returned row value is used as the default value.
  4. In the Value field enter 5 and click OK to close the Report - Parameters dialog.
    Note: When adding multiple default values, in the Report - Parameters dialog, General tab, check the Multivalue check box, otherwise the report collects only the first default value from the list and uses it to generate the report.
  5. In the Report Explorer, right-click Data Source (DataSource1 by default) node and select Add Data Set to create a dataset.
    Add Data Set in the Report Explorer
  6. In the DataSet Dialog that appears, on the Parameters page, click the Add(+) icon to add an empty expression for the parameter.
  7. In the Name field, enter the same parameter name (StorePrice) you had added in the steps above and set its value to:
    =Parameters!StorePrice.Value
  8. On the Query page of the DataSet Dialog, use the following SQL query to fetch data from the DvDStock table.
    SELECT * FROM DvDStock WHERE StorePrice IN (?)
  9. From the Toolbox, drag and drop a Table data region (or any other data region) onto the design surface, and from the Report Explorer, drag the Title, StorePrice and In Stock fields onto the table Details row.
  10. Preview the report to view the result.

Notice that the report collects the required parameter value from the default value (i.e. 5) and uses it to display the list of Movie DVDs with Store Price $5.

Sample report with a hidden parameter at preview

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Actionable Parameters

Actionable Parameters
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Parameters > Actionable Parameters

Glossary Item Box

The 'Apply Parameters' action is available for any report item that has the Action property.

A parameter action modifies a parameter value through user interaction, like a mouse click, and displays the data for the currently selected data. You must define where to apply a parameter action to see the outcome (for example, filter in a chart), where the action needs to take place (unselect/select check boxes), and the action type to define the behavior of the action.

When the Apply Parameters action is performed at runtime, the data is re-queried and the viewer re-renders the report with a new set of parameters. This way, a report author can implement cross-filters. Cross filters allow you to dynamically filter the data at runtime, making the report interactive.

Note: The toggle and sorting states are not preserved when the Apply Parameters action takes place.

Parameters Action Type

You can specify any of the following actions for the parameter action:

  • Set: Sets the value of a specified parameter.
  • Reset: Resets the parameter to its default value.
  • Toggle: Adds/removes value to/from multi-value parameter values collection.

The next section discusses a scenario where actionable parameters are useful.

Apply Cross-Filters in Report

The general procedure for applying cross-filters in a report using the 'Apply Parameters' action is described as follows:

  1. Create a report parameter. The report parameter can be a Multi-Value Parameter.
  2. Select the report control or the data region where the mouse click action will take place on the preview. (eg., List).
  3. With the report control or the data region selected, go to the Properties panel and click the ellipses near the Action property to open the Navigation or the Action page in a dialog.
  4. In the Action property, select ‘Apply Parameters’ and fill in the following fields:
    • Select the Name of the parameter.
    • Specify the parameters action Type.
    • Enter the Value of the parameter. The Value is the expression for the new parameter.
  5. Select the data region where the action (to filter data) should take place. For eg., to update the Chart data region on user action, select chart. It is here that the cross-filter will be applied.
    Note that there can be more than one data region where the cross-filter needs to be applied.
  6. Go to the Filters property of the selected data region (here, chart). The filter expression should use the same parameter.

See the Create RDLX Dashboard Report tutorial that showcases applying cross-filters in a report. The action performed on the list toggles the GenreID, which applies a new set of parameters based on the selection, and updates the chart.

See Also

Create RDLX Dashboard Report
Demo: Interactive Filtering

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Drill-Down Links

Drill-Down Links
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Drill-Down Links

Glossary Item Box

With the drill-down feature, you can temporarily hide a part of your report. That hidden part can be controls, groups, columns or rows. When you open a drill-down report, part of the data is hidden so that you can only see high-level data until you request for more detail. In such reports you find an expand icon (plus-sign image) next to the toggle item in the report. Clicking the toggle image, or plus sign, expands hidden content into view and the expand icon changes to a collapse icon (minus-sign). When you click the minus-sign image, it hides the content and returns the report to its previous state.

To create a drill-down report, use the Visibility properties of controls, groups, columns, or rows. Simply set the Visibility-hidden property to True and set the toggle item to the name of another item in the report, usually a text box in the group containing the hidden item. At run time, this puts a plus sign next to the toggle item which the user can click to display the hidden data.

If you export a drill-down report, any content which is hidden at the time of export remains hidden in the exported file. If you want all of the content to appear in the exported file, you must first expand all hidden data.

Create Drill-Down Report

In a Page report, you can set up data regions, report controls, table rows, and tablix row and column groups to collapse, so that users can drill down into the data they choose to view.

In order to collapse an item, you use the Visibility settings available in the Properties Panel or in the control dialog. You set the initial visibility of the report controls to Hidden and allow the user to toggle them by clicking other report controls (usually a TextBox).

When the report is initially displayed at run-time, the toggle items display with plus sign icons that you can click to display the detail data. Follow these steps to set a drill-down link.

  1. Drag and drop a TextBox control and a Table data region onto the report design surface.
  2. Place the TextBox control such that it appears as a header on your report.
  3. From the Report Explorer, expand your data set and drag fields and place them inside the detail row of the Table data region. Expressions for these fields appear in the detail row, and labels appear in the table header row.
  4. With the Table data region selected on the design surface, under the Properties window, click the Property dialog link to open the respective control's dialog.
  5. In the Table dialog that appears, go to the Visibility page, change the Initial visibility to Hidden, and select the checkbox next to Visibility can be toggled by another report item.
  6. From the drop-down list that appears, select the TextBox that you added in step 1. The TextBox is now used to toggle items in the Table and show detail data.
  7. Click OK to save the changes.
  8. When you view the report, the Textbox displays an Expand/Collapse icon to its left.
    Drill-down report with Expand/Collapse icon at preview
  9. Click the Expand/Collapse icon to view the hidden data.
    Drill-down report with expanded data at preview

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bookmarks

Bookmarks
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Bookmarks

Glossary Item Box

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of linking to a web page. You can create these links on a control using a Bookmark ID that connects to another target control.

Bookmarks are displayed at preview.

Add Bookmark

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of opening a web page. You can add bookmarks in a two-step process:

  • Identify the place (target control) where you want to allow a user to jump to with the help of a Bookmark ID.
  • Share that Bookmark ID with another control that links to the target control.

Use the following steps to create a Bookmark ID on a Textbox control and create a bookmark link on another Textbox control at the bottom of the page in a Page / RDLX report.

To add a Bookmark ID on a control

Bookmark ID is like a URL that provides information required by the report viewer to locate the report control. You need to provide a Bookmark ID for any control to which you want to allow users to jump to via a Bookmark Link.

  1. Drag and drop a Textbox control onto the design surface.
  2. Select the Textbox to view its properties in the Properties window and enter any text in the Value property (For e.g., Top).
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the TextBox dialog that appears, select the Navigation page and in the Bookmark ID field enter text like Link Text.
  5. Click OK to close the dialog.
Tip: You can also set the Bookmark ID through the Bookmark property in the Properties window.

To set a Bookmark Link

Bookmark Link is a simple link you create to jump to the location where the Bookmark ID is set.

  1. Drag and drop another Textbox control onto the design surface. Place it at the bottom of the page for this example.
  2. Select the Textbox to view its properties in the Properties window and in the Value property enter Go to Top.
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the Textbox dialog that appears, click on the Navigation page and select the Jump To Bookmark radio button to activate it.
  5. Under Jump To Bookmark, enter the same text (i.e. Link Text) you assigned as Bookmark ID in the steps above.
    Textbox Navigation Dialog with Jump to Bookmark
  6. Click OK to close the dialog.
  7. Preview the report and click Go to Top.
    Report with a bookmark at preview

You move to the top of the page where the Bookmark ID was set on the control.

Tip: You can also access the Navigation page of a control to set the bookmark link through the ellipsis button next to the Action property in the Properties window.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Hyperlinks

Hyperlinks
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Hyperlinks

Glossary Item Box

Hyperlinks take you to a web page that opens in the default browser of the system. You can set hyperlinks in the Textbox, Image, Chart, and Map controls to access a Web page from your report.

Hyperlinks are displayed when you preview a Page or an RDLX report, export a report in HTML, PDF, RTF, and Excel formats.

Add Hyperlink to Textbox or Image

Let's set a hyperlink on the TextBox or Image controls to access a Web page from your a Page or an RDLX report.

  1. Drag and drop a Textbox or Image control to the design surface.
  2. With the control selected, under the Properties window, click the Property dialog link to open the control's dialog and go to the Navigation page.
    OR
    With the control selected, go to the Properties window and click the ellipses near the Action property to open the Navigation page in the dialog.
  3. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  4. Type or use the expression editor to provide a valid Web page address. For example, https://developer.mescius.com/activereportsnet.
  5. Click OK to close the dialog.
  6. In the Properties window, enter text in the Value property of the respective control to set the display text for the Web page hyperlink. For example, 'Company'.

Add Hyperlink to Map Layer Elements

Map layer elements like point, polygon and line provides you with a functionality to set hyperlinks on them to access a Web page from your report.

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right-click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  5. Type or use the expression editor to provide a valid Web page address. For example, https://developer.mescius.com/activereportsnet.
  6. Click OK to close the dialog.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Drill-Through Links

Drill-Through Links
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Drill-Through Links

Glossary Item Box

A drill-through link takes you to another report with more detail. Drill-through links appear as a hyperlink that you can click to move to a completely different report. You can also create more complex links where you pass parameters to the report called by the link.

Drill-through links are displayed when you preview a Page/RDLX report.

Follow these steps to set a drill-through link.

  1. On the design surface, select a report control (like a TextBox) on which you want to set the link and under the Properties window, click the Property dialog link to open the TextBox dialog.
  2. In the control dialog that appears, go to the Navigation page and under Action, select the Jump to report radio button. Doing this activates the fields below it.
    Textbox Navigation dialog with Jump to report
  3. Under the Jump to Report field, enter the name of the report (like BasicReport.rdlx) that you want to navigate to on clicking the drill-through link. You can also use expressions to create drill-through links.
    Note: In the Jump to Report field, enter just the report name if the targeted report is in the same directory as the parent report. Or you can enter a relative path to the report. Use the Custom Resource Locator to jump to a report in your connected database.

  4. After setting the detail report to drill-through, on the Navigation page, under Parameters, you can optionally enter a valid parameter Name and Value to pass to the detail report. This value must evaluate to a valid value for the parameter. By setting parameters you can jump right to the desired information. For example, if your summary report contains a list of invoice numbers and delivery dates for each customer, you could use a drill-through link with the invoice number as the parameter to allow the user to jump to the relevant invoice.

    Caution: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report fails.
  5. Preview the report and click the drill-through link to navigate to the targeted report.
    Sample drill-through report at preview
  6. On the Viewer toolbar, click the Back to Parent Report button to return to the main report.
    Back to Parent Report button in the Report toolbar

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Sort Data

Sort Data
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Sort Data

Glossary Item Box

In order to better organize and present the data in your report, you can sort it alphabetically or numerically in ascending or descending order. You can also use sorting with grouped data to present an easy to understand, comprehensive view of report data.

In a Page or an RDLX report, you can sort data in a data region, in a data grouping, or on a fixed page in a Page report. You can also sort the data directly in the SQL query. In addition, you can also set interactive sorting for your data on a TextBox control.

ActiveReports provides a Sorting page in the dialogs of a data region, grouped data and fixed page to determine where you want to display sorted data.

Sorting Data in a Data Region

In Table and List data regions, you can sort data within the data region. To sort data within these data regions, set sorting in the Sorting page of the specific data region's dialog.

In Tablix, BandedList and Chart data regions, sorting is only possible on grouped data; therefore, there is no independent Sorting page available in their specific dialogs.

Sorting Grouped Data

A Sorting tab is available inside the Groups page of all the data region dialogs and the Detail Grouping page of the List dialog. It allows you to set the sort order of grouped data. This tab is enabled once grouping is set inside the data region.

Sorting on a Fixed Page

In a Page report, sorting is also possible on a fixed page grouped on a dynamic value. Sorting data on a fixed page is similar to sorting grouped data in a data region. The only difference is when you sort data on the fixed page you apply sorting to all the data regions that are placed on the design surface.

Sorting Data via SQL Query

When you connect to a data source and create a data set to fetch data for your report, you define a query. Set the ORDER BY keyword in the query to sort data in ascending or descending order.

By default, the ORDER BY keyword usually sorts the data in ascending order, but you can include the DESC keyword in your query to sort data in descending order. For example, if you want to fetch data from the 'Movie' table of the 'Reels.db' data source and sort it on the Title field, your query looks like the following:
<>SELECT * FROM Movie ORDER BY Title
or
SELECT * FROM Movie ORDER BY Title ASC

In case you want the Title field sorted in descending order, your query looks like the following:
SELECT * FROM Movie ORDER BY Title DESC

Sorting in Data Region

You can set the sorting expression on the Sorting page of the data region dialog. Let us elaborate on the sorting in a data region in a report that uses the 'Movie' table from 'Reels.db' data source on GitHub.

  1. Right-click the data region and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the data region dialog.
  2. In the dialog that appears, go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
    Table Sorting dialog
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag and drop the field on which the sorting expression is set.
  7. Preview the report view the result.
    Sample report with sorting at preview

Sorting on Grouped Data

You can sort the order of groups through the Sorting tab of the Groups page or the Detail Grouping page of the List data region. The data region is bound to the 'Movie' table from 'Reels.db' data source on GitHub.

Note: In a Chart data region dialog, the Sorting tab is available on the Category Groups and Series Groups pages.
  1. On the Groups or the Detail Grouping page of the data region dialog, select the Sorting tab.
  2. In the Sorting tab, click the Add(+) icon to add an empty expression to the sorting list.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data. The expression set here should be the same as the grouping expression.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
    Table Groups dialog with sorting
  5. Click OK to close the dialog.
  6. Preview the report to view the result.
    Sample report with sorting on grouped data at preview

Sorting on Fixed Page

In a Page report, if the fixed page is grouped on a dynamic value, you can sort the order of the groups through the Sorting page of the FixedPage Dialog. Follow these steps to set up sorting on a fixed page in a report bound to the 'Movie' table from 'Reels.db' data source on GitHub:

  1. Right-click the gray area of the report and select Fixed Layout Settings to open the FixedPage dialog.
    OR
    Right-click the report page and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the FixedPage dialog.
  2. In the FixedPage dialog that appears, go to the Grouping page and in the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to group your data.
    Fixed Page Grouping dialog
  3. In the FixedPage dialog, now go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below and in the Expression field enter the same expression you used for grouping the data.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close and apply the settings.
    FixedPage Sorting dialog
  6. From the Report Explorer, drag and drop the field on which sorting is set.
  7. Preview the report to view the result.
    Sample report with sorting on Fixed Page at preview Sample report with sorting on Fixed Page at preview
    Note: The difference in setting sorting on a Fixed Page is that it affects every data region placed on the report layout, whereas sorting on a data region is limited to the data region only.

Interactive Sorting

You can add interactive sorting to a TextBox control to allow users to sort columns of data within a data region on a published report.

The interactive sorting feature is set through the Interactive Sort page that is available in the TextBox dialog.

Once you set interactive sorting on a TextBox control, while previewing the report, the textbox control displays a sort icon inside it. A user can sort data that appears inside the textbox in ascending or descending order by clicking the icons.

On the Interactive Sort page of the TextBox dialog you can find the following fields for entering values:

  • Sort Expression: An expression specifying the sort value for data contained in the column.
  • Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also choose an alternate data region or grouping.
  • Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also choose an alternate data region or grouping.

Set Interactive Sorting on TextBox

Let's set up the interactive sorting in a report that is bound to the 'Movie' table from 'Reels.db' data source on GitHub and displays movies with the title, release year and user rating information. We will add the interactive sorting to the Title textbox, so that you can view the list of movies by the title, changing the descending or ascending order of movies, from A to Z and vice versa.

  1. From the Toolbox, drag and drop a Table data region onto the report.
  2. From the Report Explorer, drag fields into the detail row of the table. Labels appear in the table header row, and expressions appear in the detail row.
  3. Click to select a TextBox in the header row on which you want to allow users to sort, and in the Commands section at the bottom of the Properties Panel, click the Property dialog command.
  4. In the TextBox dialog that appears, select the Interactive Sort page.
  5. Select the checkbox next to Add an interactive sort action to this textbox and enable the other properties on the page.
  6. Under Sort expression, drop down the list and select the expression containing the value of the field on which you want to provide sorting.
    Textbox InteractiveSort dialog
    Note: Under Data region or group to sort, and Evaluate sort expression in this scope, you can optionally choose a different a scope from the Choose data region or grouping drop down list.
  7. Click OK to close the dialog and accept the changes.
  8. Preview the report. At preview, you can see a sort icon next to the TextBox control, the Title header in this case.
    Sample report with interactive sorting at preview

    You can click the icon to sort in descending order. The icon changes to an up arrow that you can click to sort in ascending order.
    Sample report with interactive sorting in descending order at preview

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Document Map

Document Map
Report Authors > Design Reports > Design Page/RDLX Reports > Interactivity > Document Map

Glossary Item Box

A document map functions as a table of contents and provides a convenient way to navigate a lengthy report. When you click an item in the document map, the viewer jumps to that item in the report.

In a Page or an RDLX report, you can add report controls, data regions, groups and detail groups to the document map. In an RDLX and RDLX Dashboard reports, the report sections too can be added to the document map.

Viewing the Document Map

  1. On the Viewer toolbar, click the Side Panel button to display the sidebar.
    Side Panel button in the Viewer toolbar
  2. At the bottom of the sidebar pane, click the Document Map button to display the document map.
    Document Map button in the sidebar pane
    If there is no document map associated with the report, the button does not appear at the bottom of the sidebar pane.
  3. In the Document map that appears, click the item you want to navigate to in the report.

Exporting Document Map

At preview, the document map appears in a sidebar to the left of the report, but when you export your report to various file formats, they handle document maps differently.

Export Filter | Effect on Document Map
HTML | A .toc file containing the document map is exported along with the HTML report.
PDF | Document map appears in the bookmarks panel.
Text | Document map does not appear in the exported report.
Rich Text Format | Document map does not appear in the exported report.
TIFF | Document map does not appear in the exported report.
Excel | Document map does not appear in the exported report.
Note: For printing and rendering purposes use Table of Contents control in your report to display a navigation pane.

DocumentMap Property of Report

The report items that appear in the Document Map are based on the settings in the DocumentMap property as described below. For the setting to apply, the report controls or the report sections must have the Label property or the HeadingLevel (available for only TextBox control) property set.

  • Levels: Customize the document map levels.
  • NumberingStyle: Specifies the numbering style for headings.
  • Source:

    • None: No navigation nodes are added to the document map.

    • Labels Only: Shows navigation nodes for the report controls or sections that have Label property set. The report sections' labels are displayed as a parent for all available labels in that section.

    • Headings Only: Shows navigation nodes for the TextBox controls that have HeadingLevel property (Heading 1, Heading 2, etc.) set. The numbering is applied only to TextBox controls that have HeadingLevel property set. Note that numbering is not applicable to the report sections.

    • Labels and Headings: Shows both Labels and Headings in the navigation panel.

To add a report section to the Document Map

  1. On the design surface, select the report section you want to add to the Document map
  2. Go to the Label property in the Properties panel.
  3. Enter a text or an expression in the Label property to represent the report section in the Document map.
  4. With the Report selected, check that the DocumentMap > Source is set to either the default value 'Labels and Headings' or 'Labels Only'.

    The section’s label is the parent label for all other labels that are contained within that section, preserving the hierarchy of the report structure.

    Report with Document Map at preview

To add a report control to the Document Map

Using Label Property

  1. On the design surface, select the report control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the Properties panel that appears, enter a text or an expression in the Label property to represent the report control in the Document map.
  3. With Report selected, set the DocumentMap > Source to 'Labels Only'

Using Document Map Label Property

  1. On the design surface, select a control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the command section of the Properties Panel, click the Property dialog to open the control's dialog.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.
  4. With Report selected, set the DocumentMap > Source to 'Labels Only'

Using HeadingLevel Property

  1. On the design surface, select the report control you want to add to the Document map (e.g. TextBox).
  2. In the Properties panel that appears, set the HeadingLevel property of the report control.
    Note The HeadingLevel property defines the DocumentMap level for that control.
  3. With Report selected, set the DocumentMap > Source to 'Headings Only' and DocumentMap > NumberingStyle to any marker other than 'None'.

To create a hierarchical Document Map

Let us take a scenario where an RDLX report has multiple sections. The report also contains a Table data region, which has one group nested inside the other.
We want to be able to navigate to the report sections, and the nested table groups. The table groups are such that the outer group is 'region' (=Fields!region.Value) and the inside group is 'city' (=Fields!city.Value). You have already learned how to add report sections to the document map.

To add the hierarchy of table groups to the document map, perform the following steps.

  1. Select the Table data region and in the Properties Panel that appears, select the Property dialog command at the bottom of the panel to open the data region dialog.
  2. On the same Groups page, set the Document map label of the respective groups to the value of the grouping expression, for example, =Fields!region.Value for 'region' and =Fields!city.Value for 'city'. These values will be evaluated as labels in the document map.
  3. For the table goup 'city', set the Parent label as =Fields!region.Value.
  4. From the Report Explorer, select the report and set the DocumentMap > Source property to 'Labels'.
  5. Preview the report to view the document map in the side panel.

    Report with a hierarchical Document Map at preview
Note: In an Page report, you can also set grouping and set the document map label on the FixedPage dialog > Groups page.

To set the numbering style for Document Map levels

You can set the numbering style for all document map levels using the DocumentMap property.
Let us take a scenario where an RDLX report has multiple sections. The report also contains a Table data region, which has one group nested inside the other. We want to be able to navigate to the report sections, and the nested table groups. The table groups are such that the outer group is 'region' (=Fields!region.Value) and the inside group is 'city' (=Fields!city.Value). You have already learned how to add report sections to the document map.

To add the numbered headings from the textboxes in table groups to the document map, perform the following steps.

  1. With the textbox in the outermost group 'region' selected, set its HeadingLevel as 'Heading 2'.
  2. With the textbox in the nested group 'city' select, the HeadingLevel as 'Heading 3'.
  3. In the Report Explorer, select Report.
  4. From the Properties panel, go to DocumentMap property > click the Levels (Collection) property.
  5. In the DocumentMapLevelDesigner Collection Editor, add three levels (Report.DocumentMap.Levels.0, Report.DocumentMap.Levels.1, and Report.DocumentMap.Levels.2) and set a unique NumberingStyle for each level.
    The selected style would be applied to all the document levels and only to the selected source that you set next.
    Note: Any customization made here gets directly applied to the Table of Contents control.
  6. Set the Source property to 'Labels and Headings'.
  7. Click OK to close the dialog.

    Numbered Headings in Document Map

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Scripts

Scripts
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Scripts

Glossary Item Box

Using scripts, you can use custom code in your expressions to extend the capabilities of your report. However, for complex functions, or functions you plan to use many times in the report, you also have the facility to embed the code within the report.

The following sections take you to some scenarios where scripts can be used.

Call a function from the control's property

This is a simple example of a single method code block:

Script in Page/RDLX reports Copy Code
Public Function GetDueDate() as Date
     Return DateTime.Now.AddDays(30)
 End Function

This is an expression used to call the method in the code block from the control's property. For example, you can call this function in the Value property of the Textbox control:

Expression in a TextBox Copy Code
=Code.GetDueDate()

Use the custom constant and variable from the control's property

This is a simple example of how to define custom constants and variables in your code block:

Script in Page/RDLX reports Copy Code
Public Dim MyVersion As String = "123.456"
Public Dim MyDoubleVersion As Double = 123.456
Public Const MyConst As String = "444"

This is an expression to use the custom constant and variable in the code block from the control's property. For example, you can get the value of a variable or a constant in the Value property of the Textbox control:

Expression in a TextBox Copy Code
=Code.MyVersion
=Code.MyDoubleVersion
=Code.MyConst

Call a global collection from the control's property

This is a simple example of a global collection code block where the code block references the report object to access the report parameter value:

Script in Page/RDLX reports Copy Code
Public Function ReturnParam() As String
    Return "param value = " + Report.Parameters!ReportParameter1.value.ToString()
End Function

This is an expression used to call a global collection in the code block from the control's property. For example, you can call the global collection in the Value property of the Textbox control:

Expression in a TextBox Copy Code
=Code.ReturnParam()

Use instance-based Visual Basic .NET code in the form of a code block. You can include multiple methods in your code block, and access those methods from expressions in the control properties.

Note: In a Page Report or an RDLX Report, you can use Visual Basic.NET as the script language. However, you can use both Visual Basic.Net and C# in your script for a Section Report.

Page/RDLX reports are designed to avoid scripts. However, some situations may still require using scripts. Page/RDLX reports support Visual Basic scripts, which can be used as expressions; see the following example:

Script in Page/RDLX reports Copy Code
Public Function GetRandom(ByVal seed As Int32, ByVal maxValue As Int32) As Int32
    Return New System.Random(seed).Next(maxValue)
End Function

Then, you should set a Textbox to a value as in the example below.

Expression in a TextBox Copy Code
=Code.GetRandom(Fields!ID.Value, 10000)

See Also

Developers
Add Code to Layouts Using Script

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Appearance

Report Appearance
Report Authors > Design Reports > Design Page/RDLX Reports > Report Appearance

Glossary Item Box

Customize the appearance of reports by applying styles and themes, as described in this section:

  • Themes
  • Styles

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Themes

Themes
Report Authors > Design Reports > Design Page/RDLX Reports > Report Appearance > Themes

Glossary Item Box

Work with ActiveReports to create and add themes, customize and apply themes, use constant expressions in a theme, and much more. A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and constant expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's CollateBy enumeration to control the page order in a report. See Set Up Collation for more information.

The Theme Editor and the Report - Themes dialog allow you to manage themes in a report.

The theme saved as an .rdlx-theme file on your local machine can be added in your report using the Report – Themes dialog. Or, you can add a dynamic theme using an expression.
Also, in the File menu, select Open to open and modify an existing theme and select Save or Save As to save the changes on your local machine.

To access the Report - Themes dialog

  1. In the Designer, click the gray area around the report page to select a report.
  2. Do one of the following:
    • In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
    • With the report selected, in the Properties window under properties where the commands are displayed, click the Property dialog link. In the Report dialog that appears, go to Themes.
    • On the Report menu, select Report Properties and go to Themes in the Report dialog that appears.

Create and add themes

A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's CollateBy property to control the page order in a report.

Use the following instructions to create and add themes.

Create a new theme

  1. Open Theme Editor.
  2. In the Theme Editor that opens, define the colors, fonts, images, and constant expressions properties for your new theme under the corresponding tabs.
  3. On the File menu, select Save.
  4. Choose a directory on your local machine and enter the name of a new theme, then click Save.

Add a theme to the report

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click the Add... icon.
  4. From the Value drop-down, select <Open File...>.
  5. In the Open dialog that appears, select a theme file from your local files, click Open, and then select OK.

Customize and apply themes

Use the following instructions to customize an existing theme and apply it to your report.

Modify a theme

  1. In the designer, click the gray area around the report page to select a report.
  2. In the Properties panel, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, select an existing report theme.
  4. Click the Edit... icon above the list of themes.
  5. In the Theme Editor that opens, modify the theme properties and click OK to close the dialog.

Apply a theme color

  1. In the designer, select the report’s control (for example, a TextBox).
  2. In the Properties panel, go to the color-related property (for example, the BackgroundColor property) and click the arrow to display the drop-down list of values.
  3. In the list that appears, go to the Theme tab and select the color you want.

Apply a theme font

  1. In the designer, select the report’s control (for example, a TextBox).
  2. In the Properties window, go to a property from the Font properties group (for example, the Font property) and click the arrow to display the drop-down list of values.
  3. In the values list that appears, select a font defined in a theme (for example, =Theme.Fonts!MinorFont.Family).

Use Constant Expressions in a theme

In the Theme Editor, you can define constant expressions to be used in a theme. Later, you can apply a constant expression to the report’s control by selecting it in the Value field of that control.

Constant expressions allow you to define a name and an associated value to be used in themes.

Use the following instructions to create and use constant expressions in themes.

Define a constant expression

  1. In the Theme Editor, go to Constants.
  2. Double-click the field under Name and enter the Constant name (for example, Header).
  3. In the next field to the right, under Value, enter the Constant value (for example, Invoice#).

Use a constant expression

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties Panel, go to the Values field and select the <Expression> option from the drop-down list to open the Expression Editor.
  3. In the Expression Editor, expand the Themes node with the constant expressions defined in the report theme.
  4. In the Themes node, select a constant and then click the Replace or Insert button.
  5. Click OK to add the constant expression in the TextBox.

Use Dynamic Expressions in a theme

Dynamic expressions allow you to define themes based on some condition that is evaluated at run-time.

To add a dynamic expression in a theme

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click Value and then <Expression..> icon.
  4. Enter the expression with dynamic condition and click OK.

See tutorial on how to Apply Theme at Runtime Using Dynamic Expression.

Set Up Collation

You can add multiple themes to a report. In this case, the report renders a combination of multiple outputs for each theme. For example, if a report has two themes, then the report output includes a combination of the first and the second themes, applied to each report page. You can control the combination rules of the report output in the CollateBy property.

Caution: If you are using collation in a report, you cannot use interactive features, such as drill down, links, document map, and sorting.

You can control the page order of a rendered report with multiple themes by selecting the collation mode in the CollateBy property of the report:

Note: The collection of constant expressions must be the same in all themes of a report. See Use Constant Expressions in a Theme for further information.
  1. In the Designer, click the gray area around the report page to select the report.
  2. In the Properties Panel, go to the CollateBy property and select one of the available options:
    • Simple. Renders report pages without any specific sorting. For example, if you have a report with 2 themes, the report renders all pages with theme 1, then all pages with theme 2.

      Simple Collation Mode
    • ValueIndex. Sorts report pages by page number. For example, if you have a report with 2 themes, the report renders page 1 for theme 1 and 2, then page 2 for theme 1 and 2, and so on.

      ValueIndex Collation Mode
    • Value. Sorts report pages by the grouping expression that you specify in the report's FixedPage dialog. For example, if you have a report with 2 themes with grouping, the report renders group1 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), then group 2 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), and so on.

      ValueGroup Collation Mode
      Note: In RDLX Reports, the Value collation mode is not available by design.

See Add Page Numbering for information on setting cumulative page count formats for Page Report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Styles

Styles
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Report Appearance > Styles

Glossary Item Box

Style is a set of properties that you can apply to selected controls in your Page or RDLX reports to quickly change their appearance. Just one single style can define properties for font, background color, line spacing, border color, padding, and many more. You can create four different types of styles:

  • Common
  • Text
  • Table Of Contents
  • Table Of Contents Level

In ActiveReports, you can create multiple styles and store them in a style sheet. A style sheet is a collection of styles.

You can add a style sheet to your Page or RDLX report in the report's StyleSheetSource and StyleSheetValue properties. Then you can apply a style to a control, using the control's StyleName property.

There are two ways to use the style sheets:

  • Embed the style sheets within the report and use its styles on controls in that report
  • Save the style sheets externally in *.rdlx-styles format and use it in multiple reports

Why use Styles?

Using styles gives you more control over the report formatting. Let us look at a few scenarios and see how styles are helpful while designing reports.

Scenario: Reusing Styles

In this example we will learn how styles can help save time and maintain consistent formatting by providing the flexibility to use the same style sheet in multiple subreports.

An organization wants to create an Annual Sales Report with multiple subreports that represent Sales by District and Sales by Product. Since all the subreports are a part of the Annual Sales Report, the formatting must be consistent. If you manually set properties for each control on the report to format it and then replicate those same set of properties for the two subreports, you will spend much time on this routine job. Also, such multiple routine operations may lead to inconsistent styling in your reports. Let us look at the screenshot below and see how the ActiveReports Style feature can help you generate consistent styles in all reports.

Example for Reusing Styles
  • Create a style sheet for designing the Annual Sales Report (main report).
  • Add styles to the style sheet in the Stylesheet Editor dialog. These styles can be applied to various controls on Annual Sales Report in the StyleName property.
    Stylesheet Editor dialog
  • Once the Annual Sales Report is designed, you can set the InheritStyleSheet property to True (by default) for each subreport.
    Setting Inherited StyleSheet Property to True in Properties pane

By setting the InheritStyleSheet property to True, the style sheet used for the Annual Sales Report is automatically inherited in the subreports. This makes all the styles in the style sheet available to the two subreports. To apply the styles to the report controls in a subreport, follow these simple steps:

  1. Select the report control.
  2. In the control's StyleName property, specify the name of the style you want to use.

You can also use the same style sheet in multiple reports by saving the style sheets externally in *.rdlx-styles format.

Scenario: Enhancing Report Portability

In ActiveReports, you can embed external style sheets in a report. This is particularly useful when you want to send reports that are styled with multiple style sheets. Let us take an example of a Sales Report to see how embedded style sheets can help improve the report portability.

An organization wants to send a Sales report that is styled with 4 different external style sheets. While sending the styled report, 5 files must be sent together - one report and 4 external style sheets. The person receiving these files needs to maintain and store 5 different files. Moreover, if the location of a style sheet is changed, the style sheet will no longer be applied to the report until the path is modified in the report.

By embedding the external style sheets within the Sales report, only 1 file needs to be sent which in turn improves the portability of the report.

The styles feature consists of the following elements.

  • Style Sheet Properties
  • Stylesheet Editor
  • Add New Style Dialog
  • Embed Stylesheet Dialog
  • Open Embedded Stylesheet Dialog

Style Sheet Properties

In the Properties panel, the Source property and the Value property are used to define the style sheet of a report. For subreports, use the InheritStyleSheet property.

Property Name Description
Source

The source of a report's style sheet. You can choose from the following options:

External - Choose this option if the style sheet (*.rdlx-styles format) is located as an external source, such as a local file, an http location or a custom resource. To learn how to create external style sheets, see Working with External Style Sheets.

Embedded - Choose this option if style sheet is embedded in the report. The embedded style sheets are displayed under the Embedded StyleSheets node of the Report Explorer.To learn how to create embedded style sheets, see Working with Embedded Style Sheets.
Value

The style sheet to apply to the report. You can choose from the following options:

Expression - Opens the Expression Editor dialog to create a valid expression.

New - Opens the New Stylesheet Editor dialog to create an external or embedded style sheet.

Open file - Opens the Open Stylesheet from file dialog to navigate to a local style sheet file. This option is only available for external style sheets.

For embedded style sheets, a list of available style sheets in the report is provided.
InheritStyleSheet

The style sheet to inherit in a subreport. Setting the InheritStyleSheet property to True (default value) inherits the style sheet of the main report in the subreport.

Note: Field values are not evaluated when used as an expression in Stylesheet Value, StyleName, and Styles properties.

Stylesheet Editor

Add New Style Dialog

To open the Stylesheet Editor dialog:

  1. Go to the Report menu of the standalone designer or Visual Studio .NET designer.
  2. Select the Stylesheet Editor option.

The Stylesheet Editor dialog consists of the following elements.

Element | Description
Open Stylesheet from File | Opens a style sheet (*.rdlx-styles format) located externally.
Open Embedded Stylesheet | Opens a style sheet embedded in the report.
Save Stylesheet to File | Saves the current style sheet as an external style sheet in *.rdlx-styles format.
Embed Stylesheet | Embeds the current style sheet in the report.
New Style | Creates a new style in the current style sheet.
Remove Style | Removes a style from the current style sheet.
Property panel | Modifies the properties of the selected style based on the selected style type. Available style properties change depending on the type of style selected. You set the style type when you create a new style. The style type is selected when a new style is created.
OK | Saves the current style.
Cancel | Closes the dialog without saving the changes.

Note: The values set in the Properties panel override the values defined in the report's style sheet. The overridden values are displayed in bold in the Properties panel.

Add New Style Dialog

Add New Style Dialog

You can open the Add New Style dialog by clicking the New Style option in the Stylesheet Editor dialog.

The Add New Style dialog consists of the following elements.

Element | Description
Name | Contains the name of the new style.
Type

Sets the type of control to which you can apply the style, which determines the options that are available in the Properties panel of the Stylesheet Editor dialog.

Common
Apply this style type to the following report controls:
  • CheckBox
  • Image
  • List
  • Tablix
  • Shape
  • Table
  • TableOfContents
  • TextBox
Text
Apply this style type to the TextBox report control. It includes all properties of the Common style type, plus it offers properties specific to the TextBox control.
TOC
Apply this style type to the TableOfContents control.
TOC Level
Apply this style type to the ToC.Level object of the TableOfContents control.
Parent | Represents the parent style of a new style. If the parent style is specified, the property values are taken from the selected parent style values. By default, the parent style is set to None.

Embed Stylesheet Dialog

Embed Stylesheet Dialog

You can access the Embed Stylesheet dialog by selecting the Save current Stylesheet option and then selecting Embed Stylesheet in the Stylesheet Editor dialog.

The Embed Stylesheet dialog consists of the following elements.

Element | Description
Drop-down list box for style sheet name | Enter a name for the embedded style sheet, or choose an existing style sheet from the drop-down list box to overwrite.

Open Embedded Stylesheet Dialog

Open Embedded Stylesheet Dialog

You can access the Open Embedded Stylesheet dialog by selecting the Open stylesheet option and then selecting Open embedded Stylesheet from the Stylesheet Editor dialog.

The Open Embedded Stylesheet dialog consists of the following elements.

Element | Description
Drop-down list box for opening style sheet | Provides a drop-down list box to choose an existing style sheet to overwrite. You can also enter a new name for the style sheet here.

Working with Styles within a Style Sheet

For any of these operations, you first need to open the style sheet in the editor.

To open the editor for embedded style sheets

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the existing style sheet you want to edit.
  2. Right-click and select Edit to open it in Stylesheet Editor dialog.
    Stylesheet Editor Dialog

To open the editor for external style sheets

  1. In the standalone designer or Visual Studio designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from File option.
    Stylesheet Editor dialog
  3. In the Open dialog, navigate to the *.rdlx-styles file that you want to open.
  4. Click Open to open the external stylesheet in the Stylesheet Editor.

To add a new style to a style sheet

  1. In the Stylesheet Editor dialog, click the New Style button to add a new style.
  2. In the Add New Style dialog, enter the Name of the style, and then select the Type and Parent style.
    Tip: For more information on the style types, see Working with Styles. To create style types for TableOfContents controls and heading levels, see Apply styles to the TableOfContents control and Apply styles to the TableOfContents levels.

To modify a style in a style sheet

  1. In the Stylesheet Editor, select the existing style that you want to modify and use the property fields on the right to make the changes.
  2. Click OK to save the changes.

To remove a style from a style sheet

  1. In the Stylesheet Editor, select the style that you want to remove and click Remove Style.
  2. Click OK to save the changes.

To use a style from a style sheet at design time

  1. Click the gray area around the report to select it, and under the Properties panel, click the Property dialog link in the Commands section. See Properties panel for more information on how to access commands.
  2. In the Report dialog, go to the Appearance page.
  3. In the Appearance page, set the Stylesheet Source to Embedded and in the Value field select an existing embedded style sheet. (Or select External and select the <Open File> option and navigate to an *.rdlx-styles external style sheet.)
    Tip: You can also access the Source and Value properties in the Properties panel by expanding the Stylesheet node.
  4. Click OK to close the dialog.
  5. On the design surface, select the control you want to apply the style to.
  6. In the Properties panel, from the StyleName property drop-down, select a style to apply to the controls.

    Stylesheet Editor dialog

Working with Embedded Style Sheets

Create and save a style sheet

  1. In the Report Explorer, right-click the Embedded StyleSheets node, and select the Add Embedded Stylesheet option to access the Stylesheet Editor dialog.
    Embedding a stylesheet
    Tip: You can also access the Stylesheet Editor dialog from the Report Explorer by clicking the Add button and selecting Embedded Stylesheet. In the standalone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. Click the Save button and select Embed Stylesheet to embed the style sheet into the report.
  3. Enter a name for the style sheet or choose an existing style sheet from the drop-down to overwrite, and then click OK to save the embedded style sheet.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Save embedded style sheet as an external style sheet

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the embedded style sheet.
  2. Right-click and select Edit to open the Stylesheet Editor dialog.
  3. In the Stylesheet Editor dialog, click the Open button and select the Save Stylesheet to file option to save the embedded style sheet externally.

    Saving a stylesheet
  4. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Working with External Style Sheets

Create and save a style sheet

  1. In the standalone designer or Visual Studio designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Save Stylesheet to file option.
  3. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Embed External style sheet into a report

  1. In the standalone designer or Visual Studio .NET designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from file option.
    Opening a stylesheet
  3. In the Open dialog, navigate to the external style sheet (*.rdlx-styles file) that you want to load and click the Open button to load it in the Stylesheet Editor dialog.
  4. In the Stylesheet Editor dialog, click the Save button and then select the Embed Stylesheet option.
    Stylesheet Editor dialog
  5. In the Embedded Stylesheet dialog, enter a name for the style sheet and then click OK to embed the loaded style sheet into your report.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Apply styles to the TableOfContents control

In the TableOfContents control, you can apply styles in the StyleName property.

  1. Create a new style sheet and add styles that you want to apply to the TableOfContents control. For information on how to create style sheets and style types, see the previous sections of this topic.
  2. Apply the style sheet to the report.
  3. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  4. On the design surface, select the TableOfContents control.
  5. In the Properties panel, from the StyleName property drop-down, select a style to apply to the TableOfContents control.

Apply styles to the TableOfContents levels

In the TableOfContents control, you can apply styles to each TableOfContents level in the StyleName property, available in the LevelDesigner Collection Editor dialog.

  1. Create a new style sheet and add styles that you want to apply for the TableOfContents level. For information on how to create style sheets and style types, see the previous sections of this topic.
  2. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  3. With the TableOfContents control selected, click the Levels (Collection) property from the Properties panel and then click the ellipsis button that appears.
  4. In the LevelDesigner Collection Edior dialog that appears, select a TableOfContents level on which to want to apply the style.
  5. From the list of properties on the right, drop-down the StyleName property to select a style to apply.

See Also

Developers
Apply Styles through Code

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tutorials: Report Controls in Page/RDLX Reports

Tutorials: Report Controls in Page/RDLX Reports
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports

Glossary Item Box

This section takes you through the set of tutorials aimed at designing the Page and RDLX reports in the Report Designer from scratch.

  • TableofContent Control for Navigation
  • BandedList Data Region for Free-form Bands
  • Bullet Control to Visualize Sales against Target
  • CheckBox Control
  • OverflowPlaceholder Control for Columnar Reports
  • InputField Control for Editable PDFs
  • Line Control for Freehand Forms
  • List Control for Hierarchical Relationships
  • Table Data Region for a Tabular Report
  • Shape Control for Enhanced Report Appearance
  • Image Control
  • Container Control for Enhanced Report Appearance
  • FormattedText Control for Mail Merge
  • Subreport Control for a Master-Detail Report
  • Sparkline Control
  • Tablix Data Region
  • TextBox Control
  • Map Data Region

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TableofContent Control for Navigation

TableofContent Control for Navigation
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > TableofContent Control for Navigation

Glossary Item Box

Let us add a Table of Contents to the following report. Note that this report is similar to the 'MoviesCatalog.rdlx' report available with samples on GitHub. The report contains nested List data regions to display the hierarchy in report. The parent list is grouped based on 'GenreName'. The child list is grouped based on the 'Title' and displays other information.

Movies Catalog report at preview with no TOC

HeadingLevel property

You can define a hierarchical structure for your report using the Heading Level property of the TextBox control. If a TextBox is set to Heading Level 1 and another TextBox at a different level to Heading Level 2, the entries in Heading Level 2 are clubbed under the Heading Level 1 entry in the Table of Contents. The headings are auto-numbered.

  1. Drag and drop the TableOfContents control on top of the report, below the report title. Grab its corner and adjust its size.
  2. With the TableOfContents control selected, in the Properties window, click the Levels property to open the LevelDesigner Collection Editor.
  3. Select the Level1 (to display [GenreName]) in the Table of Contents and set the following properties:
    LevelDesigner Collection Editor
    • FontSize: 11pt
    • FillCharacter: "-" (a dash)
    • DisplayFillCharacter: True
  4. Click +Add item to add the Level2 (to display [Title]) to the Table of Contents and set the following properties:
    • Padding > Left: 5pt
    • FillCharacter: "." (a dot)
    • DisplayFillCharacter: True
  5. From the Report Explorer, select Report, and from the Properties window, go to the DocumentMap property.
  6. Expand the DocumentMap property and click the ellipses next to Levels (Collection) property.
  7. In the DocumentMapLevelDesigner Collection Editor, that appears, select:
    DocumentMapLevelDesigner Collection Editor
    Report.DocumentMap.Levels.0 and set NumberingStyle to 'A, B, C, D, E'
    Report.DocumentMap.Levels.1 and set NumberingStyle to '1, 2, 3, 4, 5'
  8. Click OK to close the collection editor.
  9. Set the DocumentMap > Source property to 'Headings Only'.
  10. Now, select the Textbox with the Value property set to =Fields!GenreName.Value and, in the Properties window, set its HeadingLevel property to 'Heading 1' from the drop-down list.
  11. Select the Textbox with the Value property set to =Fields!Title.Value and, in the Properties window, set its HeadingLevel property to 'Heading 2' from the drop-down list.
    Movies Catalog with TOC at design
  12. Preview the report. Here's how the table will look like. Click the TOC item to jump to the desired page.

    Movies Catalog with TOC at preview

Label Property

By setting the Label property of the report controls or the report sections, you can show a hierarchical structure based on the parent-child relationship between the controls in the Document Map. For example, if the Label property of the List data region is set and a TextBox control is placed inside the List data region, the TextBox label appears nested inside the List data region label, thereby displaying a hierarchical structure.

  1. Drag-drop the TableOfContents control on top of the report. Grab its corner and adjust its size.
  2. Follow steps 2-8 in the Using HeadingLevel property section above for setting properties of levels in Table of Contents.
  3. Set the DocumentMap > Source property to 'Labels Only'.
  4. Select the List1 data region and set its Label property to =Fields!Genre.Value to have it displayed in the Level1 of the Table of Contents.
  5. Similarly, select the List2 data region and set its Label property to =Fields!Title.Value to have it displayed in the Level2 of the Table of Contents.
  6. Preview the report.
    Note: The Table of Contents mapped using labels are not numbered.

See Also

Demo: Table of Contents
Table of Contents
Styles
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


BandedList Data Region for Free-form Bands

BandedList Data Region for Free-form Bands
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > BandedList Data Region for Free-form Bands

Glossary Item Box

Let us create a report that shows yearly shipments for each country. To display a summarized shipment value for each country and year, we will use BandedList data region and add groups. The report connects to the 'Orders' JSON data available here.

The final report will look as shown.

Report with List Control

Create a Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See JSON for details.

  1. On the Choose Data Source Type screen of the wizard, select JSON and click Next.
  2. To specify JSON File Path, click the Browse button and navigate to the desired file on your system. This report uses the 'orders.json' sample data source that can be downloaded from the following URL:
    https://demodata.mescius.io/northwind/odata/v1/Orders
  3. Click the Next option and configure the dataset by adding a valid query. Enter OrderdsDataset into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  4. Click Finish to successfully add the report with the JSON data source.

Design Report Layout

  1. Drag and drop the BandedList control onto the report's designer.
  2. With the BandedList control selected, click the Property dialog link to open the BandedList dialog.
  3. Go to the Groups page and click Add.
  4. Set the Group on Expression to =Fields!ShipCountry.Value.
    This will ensure that the data in the banded list is grouped based on the [ShipCountry] field.
  5. Again, click Add to insert another group.
  6. Set the Group on Expression to =Year(Fields!OrderDate.Value).
    This will repeat the shipments by year for each country.
  7. Click OK to close the dialog. Group Headers and a Group Footers are added.
  8. From the dataset, drag the [ShipCountry] data field to the Group1 Header of the BandedList control.
  9. Drag and drop two Textbox controls onto the Group2 Header of the control and set their Value property as follows:
    • TextBox1: =Year(Fields!OrderDate.Value)
    • TextBox2: =Sum(Fields!Freight.Value)
  10. In the Properties pane, set the Format property for the [Freight] field to Currency.
  11. Again, drag and drop two Textbox controls onto the Group1 Footer of the control and set their Value property as follows:
    • TextBox3: Total
    • TextBox4: =Sum(Fields!Freight.Value)
  12. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Yearly Shipments'.
    Sample BandedList Design
  13. Improve the appearance of the report and preview.

See Also

BandedList

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bullet Control to Visualize Sales against Target

Bullet Control to Visualize Sales against Target
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Bullet Control to Visualize Sales against Target

Glossary Item Box

Let us create a report that shows the sales relative to a target sale amount for each customer. We will use the Bullet control inside a Table data region to create this report. The report connects to the 'Sale' table from the 'Reels.db' data source available on GitHub.

Sales Report sample with Bullet control

Create a Report

In the ActiveReports Designer, create a new Page or an RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
  5. Enter an SQL query like the following into the Query text box:
    Dataset Query Copy Code
    SELECT * FROM Sale ORDER BY Customer ASC

    See Query Builder in Microsoft SQL Client and OLEDB Providers for more information on building SQL queries.
  6. Click Finish to successfully add the report with the SQLite data source.

Design Report Layout

  1. Drag and drop the Table data region onto the design area of the Report Designer.
  2. Drag a Bullet control onto the Details row of the table and in the Properties panel, set its Value property to
    =Fields!SalesAmount.Value
    This Value property is used to define the key measure displayed on the graph.
    Setting the Value property for Bullet control
  3. With the Bullet control selected on the design area:
    • Set its Target Value property to 200. This property defines a target for the Value to be compared to.
      Setting the Target property for Bullet control
    • Set its Best Value property to 400 and the Worst Value property to 0. The Best Value and Worst Value properties define the value range on the graph.
      Setting the Best Value and Worst Value properties for Bullet control
    • You can also optionally encode the segments on the graph as qualitative ranges indicating bad, satisfactory, and good sections.
      • The Range1Boundary property defines a value for the bad/satisfactory boundary on the graph. Set this property to 150.
      • The Range2Boundary property defines a value for the satisfactory/good boundary on the graph. Set this property to 300.
        Setting the RangeBoundary properties for Bullet control
    • You can also optionally define the Interval property for the graph value range. So, set this property to 100.
  4. Specify the TargetShape as 'Line'.
  5. Specify the position of TickMarks as 'Inside'.
  6. Modify the appearance of the report. You can customize the appearance of bullets as follows:
    1. Set the TargetStyle and the TickStyle properties.
    2. Specify color patterns based on the relative value of the key measure. For example, set the expression like the following in the ValueColor property to show the color pattern based on the value of [SalesAmount]:
      Expression for ValueColor Property Copy Code
      =iif(Fields!SalesAmount.Value >= 200, "#BFECB8", "#FFB1AE")

See Also

Bullet

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CheckBox Control

CheckBox Control
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > CheckBox Control

Glossary Item Box

Let us create a report that displays information on Products that are 'Discontinued' in a Table data region. Since the value of 'Discontinued' is either True (1) or False (0), and a CheckBox control takes the Boolean value, we will use it to show the 'Tick' marks corresponding to the 'True' values. The report connects to the 'Products_header_tab.csv' data source available on GitHub.

The final report will look as shown.

Products Report sample with CheckBox control

Create a Report

In the ActiveReports Designer, create a new Page or an RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access tht Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See CSV for details.

  1. On the Choose Data Source Type screen of the wizard, select CSV and click Next.
  2. To specify the File Path, click the Browse button and navigate to the desired folder on your system. For example, you can connect to the Products_header_tab.csv sample data source which can be downloaded from GitHub.
  3. Select the Column Delimiter as 'Tab'.
  4. Then click Next to check the Fields section, which includes field names with their corresponding data types present in the CSV file.
  5. Click Finish to successfully add the report with the CSV data source.
    See CSV Provider for more information on building SQL queries.

Design Report Layout

  1. Drag and drop Table data region onto the design area of the Report Designer.
  2. In the cells of the details row, drag-drop the [ProductName], [UnitPrice], and [ProductID]fields.
  3. Add another column to the right of the [ProductID] column.
  4. Drag-drop the CheckBox control onto the empty textbox in the details row of the added column.
  5. With CheckBox selected, set the Checked property to the expression:
    =ToBoolean(ToInt32(Fields!Discontinued.Value)).
    Note that since we used the CSV data, the field [Discontinued]needs to be converted to boolean.
  6. Preview the report.

See Also

CheckBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


OverflowPlaceholder Control for Columnar Reports

OverflowPlaceholder Control for Columnar Reports
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > OverflowPlaceholder Control for Columnar Reports

Glossary Item Box

Let us create a report as shown below that uses the OverflowPlaceHolder control to create a columnar report. The report connects to the 'Movie' table from 'Reels.db' data source on GitHub.

Movies Report sample without OverflowPlaceholder at design time

Movies Report sample without OverflowPlaceholder at run time

We will use multiple Overflow Placeholders to create the report layout with multiple columns. We will link the Table data region to an Overflow Placeholder control, followed by linking one Overflow Placeholder control to another to make data flow in case the data does not fit into these placeholders.

Create Report

In the ActiveReports Designer, create a new Page report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
    Dataset Query Copy Code
    SELECT * FROM Movie
  5. Click Finish to successfully add the report with the SQLite data source.

Design Report Layout

  1. On the Page1 of the report, drag-drop a Table data region.
  2. In the cells of the details row, drag-drop the [Title], [MPAA], and the [UserRating] fields. Our table now displays the 'Movie' details – Title, MPAA, and User Rating fields.

Link the Table data region to an Overflow Placeholder

  1. Select the Table data region and from the Properties window, set the following properties to some values, e.g.
    • Location = 0in,1in
      (we want the table to appear on the left side and make space for other Overflow Placeholder controls)
    • RepeatHeaderOnNewPage = True
      (for the table header to repeat on each page as well as inside the Overflow Placeholder)
    • Size = 3.2in, 0.6in
    • FixedSize = 3.2in, 3.5in
    • OverflowName = OverFlowPlaceHolder1 (you can set this property only after you add the OverflowPlaceHolder1 to the design surface, see step 2)

Link an Overflow Placeholder to another Overflow Placeholder

  2. Drag and drop the OverflowPlaceHolder1 control onto the design surface on the right side of the table and from the Properties window, set its properties as follows.
    • Location = 3.25in, 1in
    • Size = 3.2in, 3.5in (same as FixedSize of the table)
    • OverflowName = OverFlowPlaceHolder2 (you can set this property only after you add the OverflowPlaceHolder2 to the design surface, see step 3).
  3. Drag and drop the OverflowPlaceHolder2 control onto the design surface and, in the Properties window, set its properties as follows.
    • Location = 0in, 4.65in
    • Size = 3.2in, 3.5in
    • OverflowName = OverFlowPlaceHolder3 (you can set this property only after you add the OverflowPlaceHolder3 to the design surface, see step 4).
  4. Drag and drop the OverflowPlaceHolder3 control onto the design surface and, in the Properties window, set its properties as follows.
    • Location = 3.25in, 4.65in
    • Size = 3.2in, 3.5in
    The final report in the design view will look similar to this.

    Movies Report sample with OverflowPlaceholder at design time
  5. Preview the report. Observe how the report data is arranged.

    Movies Report sample with OverflowPlaceholder at run time
    Similarly, you can add more Overflow Placeholders to create layout as shown:

    Movies Report sample with multiple OverflowPlaceholder controls at run time
Tip: Depending on your layout requirements, you can place the OverflowPlaceHolder control on the same page tab as the data region or a different page tab.

See Also

Overflow Placeholder (Page report only)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputField Control for Editable PDFs

InputField Control for Editable PDFs
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > InputField Control for Editable PDFs

Glossary Item Box

We are going to create a PDF form, using the InputField controls, where a user, besides entering text information, may also specify Yes (check) or No (uncheck) for such information like Sex, Employment Status, etc.

The final report will look as shown.

Editable PDF Forms Report with InputField controls

Design Report Layout

  1. Drag and drop the TextBox control onto the report designer and set its Value property to Renter's section. This is the form's heading.
  2. Drag and drop the TextBox controls below the Renter's section text; these controls will be the captions to the user's answers. Set the Value property of each of these controls to the following values:
    - TextBox2: Full Name
    - TextBox3: Address
    - TextBox4: City
    - TextBox5: State
    - TextBox6: Zip
    - TextBox7: Phone
    - TextBox8: Email
  3. Now drag and drop the InputField controls next to the TextBox controls added at the previous step. These blank fields are required to be filled by the users filling the PDF form.
  4. Set the InputField's InputType property to Text.
  5. Drag and drop some more TextBox controls and set them to the following values in the Value property.
    - Value9: Sex
    - Value10: Male
    - Value11: Female
  6. Now drag and drop the InputField controls next to the TextBox added at the previous step. These blank fields are required to be filled as yes or no using the checkboxes.
  7. Set the InputField's InputType property to CheckBox.
  8. Set Required property for some fields that you want to make mandatory before submitting the form.
  9. Improve the appearance of the controls and preview the report.
  10. Export the report to PDF format. Users can now enter the text in the blank fields and also enter their choices as yes (check) or no (uncheck) in the editable checkboxes.

See Also

InputField
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Line Control for Freehand Forms

Line Control for Freehand Forms
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Line Control for Freehand Forms

Glossary Item Box

Let’s say that we want to create an order form that needs to be filled out for ordering some goods.

The final report will look like as shown.

Order Form Report created with Line controls

This form requires the billing and shipping information, some information on the product, its price and quantity to order, and the order's subtotals and totals.

Since the information is filled out freely, by hand, or in an electronic form, you don't need to use any datasets. All you need is to create the form with a few Line controls to show blank spaces and draw a blank table - to be filled out by hand.

Design Report Layout

  1. Drag and drop few TextBox controls to contain default information such as the Form name ('Order Form'), address, contact information, instructions to fill the form, etc.
  2. Now, drag and drop the Line controls to draw horizontal lines that will show blank spaces that need to be filled for the 'Bill To:' and 'Ship To:' information.
  3. Draw a table using Line controls. Drag and drop the Line controls one by one and draw the lines in horizontal and vertical directions.
    Tip: To draw a perfect horizontal or vertical line, keep the Shift key pressed while drawing the line.
  4. Drag and drop the TextBox controls to provide labels for table columns: 'Product ID', 'Product Name', 'Unit Price', and 'Quantity'.
  5. Drag and drop the TextBox controls to provide labels for the 'Subtotal:' and 'Total:'.
  6. Modify the appearance of the report and preview.

See Also

Line
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


List Control for Hierarchical Relationships

List Control for Hierarchical Relationships
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > List Control for Hierarchical Relationships

Glossary Item Box

This article demonstrates the steps to create a simple list and a hierarchical list using the List control in ActiveReports.

Create Simple List

Let’s create a report that shows the products information for each category, so the product details will appear corresponding to each category, along with the category name and category description. The report uses 'NWIND.db' data source available on GitHub. It is a SQLite Provider, a custom data provider that works if System.Data.SQLite package is added and referenced in the ActiveReports.config file. See setting up the dependencies and configuration file as described in Configure ActiveReports using Config File topic.

The report uses the List data region with other controls on it so that each control repeats for every record in the dataset. The report also uses a Table to show the details corresponding to each category. The List data region uses detail grouping by the CategoryName grouping value.

The final report will look like as shown.

Movie Catalog report created with List data regions

Create a Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
    Dataset Query Copy Code
    SELECT Movie.Title, Genre.GenreName, Movie.MovieID, Movie.Length, Movie.YearReleased, Movie.UserRating, Movie.MPAA, Movie.Country
FROM Genre INNER JOIN (Movie INNER JOIN MovieGenres ON Movie.MovieID = MovieGenres.MovieID) ON Genre.GenreID = MovieGenres.GenreID;
  5. Into the Name field, enter the name of the dataset as MoviesDataset.
  6. Click Finish to successfully add the report with the SQLite data source.

Design Report Layout

  1. Drag and drop the List data region (List1) on the report’s designer.
  2. With the List selected, click Property dialog to open the List dialog.
  3. In the List dialog, go to Detail Grouping and set the Group on expression =Fields!Title.Value.
  4. Drag and drop the TextBox control onto the List data region and bind it to the [Title] field. This will be the header of each catalog entry for a movie.
  5. Next, drag and drop few TextBox controls below the [Title] textbox on the List2, and set their Value property as follows:
    - TextBox2: Released Year:
    - TextBox3: =Fields!YearReleased.Value
    - TextBox4: Country:
    - TextBox5: =Fields!Country.Value
    - TextBox6: MPAA Rating:
    - TextBox7: =Fields!MPAA.Value
    - TextBox8: Length:
    - TextBox9: ="Length: " & Fields!Length.Value & " min"
    - TextBox10: =Fields!UserRating.Value
  6. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Movies Catalog'.
    Sample Report Layout
  7. Improve the appearance of the report and preview.

Create Hierarchical List

You can create reports with hierarchies of expanded lists, using the List control. The report uses 'reels.db' data source available on GitHub. It is a SQLite Provider, a custom data provider that works if System.Data.SQLite package is added and referenced in the ActiveReports.config file. See setting up the dependencies and configuration file as described in Custom Data Provider topic.

The report displays the movies catalog with the list of movies along with the movies information. The report data is grouped by genre and title of the movies.

The final report will look like as shown.

Report with List Control

Create a Report

In the ActiveReports Designer, create a new RDLX report.

Bind Report to Data

Connect to a Data Source

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter the name of the data source, 'ReelsDataSource'.
  3. Under Type, select 'SQLite Provider'.
  4. In the Connection String, enter the path of the .db, here, 'reels.db', for example
    Connection String Copy Code
    Data Source=C:\Data\reels.db
  5. Click OK to close the dialog and complete the data source connection.

Add Dataset

  1. Right-click the added data source and select Add Dataset.
  2. In the Dataset dialog, select the General page and enter the name of the dataset, 'MoviesDataset'.
  3. Go to the Query tab and enter the following query to fetch the required fields:
    Dataset Query Copy Code
    SELECT Movie.Title, Genre.GenreName, Movie.MovieID, Movie.Length, Movie.YearReleased, Movie.UserRating, Movie.MPAA, Movie.Country
FROM Genre INNER JOIN (Movie INNER JOIN MovieGenres ON Movie.MovieID = MovieGenres.MovieID) ON Genre.GenreID = MovieGenres.GenreID;

Design Report Layout

  1. Drag and drop the List data region (List1) on the report’s designer.
  2. With the List selected, click Property dialog to open the List dialog.
  3. In the List dialog, go to Detail Grouping and set the Group on expression to =Fields!GenreName.Value.
  4. Drag and drop the TextBox control on to the List data region and bind it to the [GenreName] field. This will be the header of the catalog section.
  5. Drag and drop another List data region (List2) onto the first List.
  6. Click Property dialog to open the List dialog.
  7. In the List dialog, go to Detail Grouping and set the Group on expression =Fields!Title.Value.
  8. Drag and drop the TextBox control onto the List data region and bind it to the [Title] field. This will be the header of each catalog entry for a movie.
  9. Next, drag and drop few TextBox controls below the [Title] textbox on the List2, and set their Value property as follows:
    - TextBox3: Release Year:
    - TextBox4: =Fields!YearReleased.Value
    - TextBox5: Country:
    - TextBox6: =Fields!Country.Value
    - TextBox7: MPAA Rating:
    - TextBox8: =Fields!MPAA.Value
    - TextBox9: Length:
    - TextBox10: =Fields!Length.Value & " min"
    - TextBox11: =Fields!UserRating.Value
  10. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Movies Catalog'.
    Report Structure for List Control
  11. Improve the appearance of the report and preview.

See Also

Demo: List - Top 10 Movies
Demo: Hierarchical - Game
List

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Table Data Region for a Tabular Report

Table Data Region for a Tabular Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Table Data Region for a Tabular Report

Glossary Item Box

Let us create an RDLX report that uses the Table data region to display the movie details including its name, released year, country, duration, and user ratings. The report connects to the 'reels.db' data source available on GitHub.

The final report will look as shown. The data in the table is grouped by the released year of movies.

Report with Table Control

Create Report in Visual Studio Integrated Designer

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
    Dataset Query Copy Code
    SELECT * FROM Movie
  5. Into the Name field, enter the name of the dataset as MoviesDataset.
  6. Click Next to proceed to the final screen of the Report Wizard.
  7. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the SQLite data source.

Design Report Layout

  1. Drag and drop the Table data region on the report’s designer.
  2. From the dataset, drag the following data fields to the Details row of the Table data region: [Title], [Country], [Length], and [User Rating]. The Header row above the Details row is automatically filled with labels.
  3. To display the movie length in minutes, select the [Length] textbox and set its Format property to ### mins.
  4. With the Table data region selected, click the Property dialog link to open the Table dialog.
  5. Go to the Groups page and click Add.
    Note: Alternatively, you can add a group by selecting Insert Group in the context menu of the Table data region, and adding a group in the Table - Groups dialog that opens.
  6. Set the Group on Expression to =Fields!YearReleased.Value.
    This will ensure that the data in the table is grouped based on the [YearReleased] field.
  7. Navigate to the Sorting page. Set the Sorting Expression to =Fields!YearReleased.Value and Sorting Direction to Descending.
  8. In the Layout tab and check the Keep together on one page if possible option.
    This property will try to fit the entire group on the same page; either on the current page or on the following page. If this is not possible due to a large number of records, the content will split across multiple pages.
  9. Click the OK button to close the dialog. A Group Header and a Group Footer are added.
  10. Merge the cells in the Group Header row and enter the expression in the Value property as =[YearReleased].
    This makes the group value appear and span above each group.
  11. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Movies List'.
    Sample Table Design
  12. Improve the appearance of the report and preview.

See Also

Table

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Shape Control for Enhanced Report Appearance

Shape Control for Enhanced Report Appearance
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Shape Control for Enhanced Report Appearance

Glossary Item Box

Let’s say that we already have a report displaying a catalog of products grouped by categories as shown below.

Products Catalog Report

By using Shape controls, we will improve the appearance of this report. One shape will highlight each category of products, the other one will visually mark the boundaries of the list of products. Both shapes will use a rectangular shape with round corners for a more powerful visual effect.

Design Report Layout

  1. Drag and drop the Shape control onto the report’s designer, so that it surrounds text boxes [CategoryName] and [Description].
  2. Set the following properties of the Shape control to some values, for example:
    • Border Width: 2pt
    • Border Style: Solid
    • Border Color: Green
    • Shape Style: RoundRect
    • Rounding Radius: 5pt for each corner
  3. Drag and drop another Shape control, on the List data region, and resize it to surround the List data region.
  4. Set the following properties of the Shape control to some values, for example:
    • Border Width: 2pt
    • Border Style: Solid
    • Border Color: Green
    • Shape Style: RoundRect
    • Rounding Radius: 15pt for each corner
  5. Modify the appearance of the report and preview.
    Products Catalog Report with Shape controls
Note: Exports such as Word, Excel, and HTML do not provide good support of overflow items. In such scenarios where overflow items are used, it is better to avoid using shape as background.

See Also

Shape
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Image Control

Image Control
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Image Control

Glossary Item Box

Let's say that we want to create a report that shows the photos of employees along with their details including name, job title, date of birth, mobile, email, and department. For such a report, we will use the BandedList control with Image control in the details band along with other TextBox controls. The report connects to 'DimEmployees' JSON data available here.

The final report will look like as shown.

Image Control in Reports

Create a Report

In the ActiveReports Designer, create a new Page report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See JSON for details.

  1. On the Choose Data Source Type screen of the wizard, select JSON and click Next.
  2. To specify JSON File Path, click the Browse button and navigate to the desired file on your system. This report uses the 'DimEmployees.json' sample data source that can be downloaded from the following URL:
    https://demodata.mescius.io/contoso/odata/v1/DimEmployees
  3. Click the Next option and configure the dataset by adding a valid query. Enter EmployeesDataset into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  4. Click Finish to successfully add the report with the JSON data source.

Design Report Layout

  1. Drag and drop the BandedList control onto the report's designer.
  2. Drag few TextBox controls to the Details band of the BandedList control, and set their Value property as follows:
    • TextBox1: Name
    • TextBox2: =Fields!FirstName.Value & " " & Fields!LastName.Value
    • TextBox3: Title
    • TextBox4: =Fields!Title.Value
    • TextBox5: Date of Birth
    • TextBox6: =Format(Fields!BirthDate.Value, "dd-MM-yyyy")
    • TextBox7: Mobile
    • TextBox8: =Fields!Mobile.Value
    • TextBox9: Email
    • TextBox10: =Fields!EmailAddress.Value
    • TextBox11: Department
    • TextBox12: =Fields!DepartmentName.Value
  3. Drag and drop the Image control and set its properties as follows:
    • Value: =IIF(IsNothing(Fields!AvatarUrl.Value), "https://demodata.mescius.io/images/contoso/EmployeePhotos/no-photo.jpg", "https://demodata.mescius.io" & Fields!AvatarUrl.Value)
    • Source: External
    • Sizing: FitPropotional
    • MIMEType: image/bmp
  4. To provide a heading (label) to the data displayed in the text boxes in Details band, drag and drop a TextBox control onto the Header band of the BandedList control and set its Value property to 'Employee Details'.
  5. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Employee List'.
    Image control in reports
  6. Improve the appearance of the report and preview.

See Also

Image

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Container Control for Enhanced Report Appearance

Container Control for Enhanced Report Appearance
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Container Control for Enhanced Report Appearance

Glossary Item Box

Let us enhance the appearance of the following report using Container controls.

The Invoice report shown above contains the company logo and the invoice issue information, the shipping and billing information, and the products information.

We will re-create the above report to improve its appearance by using two Container controls. The containers will be placed so as to highlight the two parts of the invoice: the first Container to visually group the company logo and the invoice issue information, while the second Container to highlight the shipping and billing information.

Container Control-Design

Design Report Layout

  1. Drag and drop a Container control onto the design area of the Report Designer.
  2. Set the following properties to some values, for example: Width, Height, and Color.
  3. Drag and drop Image controls into the Container and add the company logo.
  4. To add information on order Id, drag-drop the [OrderId] field from the dataset. Also add text boxes on the container to add the labels 'Order ID:' and 'INVOICE'.
  5. To highlight the shipping and billing information, drag-drop another Container control and place it below the first Container control. Set its properties to some values, for example: Width, Height, and Color.
  6. Drag and drop the following data fields from the dataset on the second Container control: [CustomerId], [OrderDate], and [ShipName].
  7. Now, add text boxes to add labels above the data fields: 'Bill To:', 'Order Date:', 'Ship To:', and 'Ship Address:'.
  8. Drag-drop the Table data region onto the report designer, below the second Container control.
  9. Bind the text boxes in the Table's Details row to [ProductName], [UnitPrice], [ProductID], and [Quantity].
  10. Modify the appearance of the report and preview.
    Container Control-Preview

See Also

Container
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


FormattedText Control for Mail Merge

FormattedText Control for Mail Merge
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > FormattedText Control for Mail Merge

Glossary Item Box

Let's create a mail merge report that uses the FormattedText control to display the discount percent, start date, and end date for different sales promotions. We will use the List data region to repeat the data in the FormattedText control for each unique promotion key in the dataset.

The final report will look as shown.

Mail Merge Report with FormattedText

Create a Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See JSON for details.

  1. On the Choose Data Source Type screen of the wizard, select JSON and click Next.
  2. To specify JSON File Path, click the Browse button and navigate to the desired file on your system. This report uses the 'DimPromotions.json' sample data source that can be downloaded from the following URL:
    https://demodata.mescius.io/contoso/odata/v1/DimPromotions
  3. Click the Next option and configure the dataset by adding a valid query. Enter PromotionDataset into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  4. Click Finish to successfully add the report with the JSON data source.

Design Report

  1. Drag and drop the List data region on the design area.
  2. With the List data region selected, set the DataSetName as the name of the dataset, 'PromotionDataset'.
  3. Go to the Property dialog and set the Detail Grouping to expression =Fields!PromotionKey.Value
  4. Now, drag and drop the FormattedText control on the List data region. Check from the Report Explorer that the FormattedText is nested within the List data region.
  5. To encode mail merge fields, go to the MailMergeFields property and click ellipses next to (Collections).
  6. In the Mail Merge dialog, check the Encode Mail Merge Fields option and add the mail merge fields with the following 'Field' and 'Value' pairs:
    • Field1: PromotionName, Value: =Fields!PromotionName.Value
    • Field2: DiscountPercent, Value: =Fields!DiscountPercent.Value * 100
    • Field3: StartDate, Value: =Format(Fields!StartDate.Value, "dd-MM-yyyy")
    • Field4: EndDate, Value: =Format(Fields!EndDate.Value, "dd-MM-yyyy")
  7. Set the control's Html property to the following text.
    HTML Copy Code
    <!DOCTYPE html>

<html lang="en">

   <head>
      <title>Mail Merge Report</title>
   </head>

   <body bgcolor="#E23940">
      <h2 style="color:white; text-align:center;font-family:Segoe UI;"><% PromotionName /%></h2>
      <h1 style="color:white;text-align:center;font-size:50px; font-family:Segoe UI;">GET<br><big><% DiscountPercent /%>%</big> OFF</h1>
      <h2 style="background-color:white;color:#E23940;text-align:center;font-size=35px;font-family:Segoe UI;font-weight:bold">LIMITED PERIOD OFFER</h2>
      <h4 style="color:white;text-align:center;font-size=35px;font-family:Segoe UI;">* Valid from <%StartDate /%> to <% EndDate /%> in all our stores. Cannot be combined with any other offers. No cash value. Northwind Traders can cancel promotion at any time.</h4>
      <img align="center" src="https://demodata.mescius.io/images/NorthWind_large.png" style="width:1.5inin;height:2in" />
   </body>

</html>
  8. Improve the appearance of the controls and preview the report.

See Also

FormattedText

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreport Control for a Master-Detail Report

Subreport Control for a Master-Detail Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Subreport Control for a Master-Detail Report

Glossary Item Box

The Subreport control is embedded into the master report which acts as a placeholder for the details report. A parameter passed from the master report to the details report filters the details for each instance of master record and renders the record. Note that there should be a common field in the two reports to establish the master-detail relationship. This field is used to filter data in the details report based on the parameter passed from the master report.

Let us create Master-Detail report using subreport control. The master report will display basic information of employees - Name, Title, City, and Country, along with the list of orders fetched from the details report. Both reports use SQLite Provider, a custom data provider that works if System.Data.SQLite package is added and referenced in the ActiveReports.config file. See setting up the dependencies and configuration file as described in Custom Data Provider topic.

The master report uses the List data region that will contain TextBox controls to display the data. The List data region repeats any report control it contains for every record in the dataset. The master report uses a parameter that is passed from the master report to detail report to filter the details.

The final report will look like as shown.

Master-Detail Report at Preview

Create Details Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Details Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the NWind.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
  5. Enter EmployeesDataset into the Name and an SQL query like the following into the text box:
    Dataset Query Copy Code
    SELECT * FROM Employees

    See Query Builder in Microsoft SQL Client and OLEDB Providers for more information on building SQL queries.
  6. Click Finish to successfully add the report with the SQLite data source.

Design Details Report Layout

Details Report Layout at Design
(Design view of Details Report)

  1. Drag and drop the Table control onto the report’s designer.
  2. From the dataset, drag the following data fields to the Details row of the Table control: [OrderId], [OrderDate], [ShippedDate], [RequiredDate], [ShipVia], and [Freight]. The Header row above the Details row is automatically filled with labels.
  3. In the Footer row of the table, in the extreme right cell, set the Value property to the following expression =Sum(Fields!Freight.Value).
  4. Let us add a hidden parameter to the details report. This parameter will be passed form the master report to filter the data in the details report. To add a report parameter that filters the data based on the 'EmployeeID', go to the Report Explorer, right-click Report Parameters, and select Add Parameters.
  5. In the Report - Parameters dialog that appears, click Add. A parameter, ReportParameter1, is added.
  6. Select ReportParameter1 to set its properties as follows.
    - Set the Data Type property to Integer (since EmployeeID is integer).
    - Enable the Hidden property to True.
  7. Save the report and enter the name of the report as 'subreport-details.rdlx'.

Create a Master Report

In the ActiveReports Designer, create a new RDLX report.

Bind Master Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the NWind.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
  5. Enter OrdersDataset into the Name and an SQL query like the following into the text box:
    Dataset Query Copy Code
    SELECT * FROM Orders
  6. Click Next to proceed to the final screen of the Report Wizard.
  7. Review the summary of the report and click Finish to successfully add the report with the JSON data source.

Design Master Report Layout

Master Report Layout at Design
(Design view of Master Report)
  1. Drag and drop the List data region onto the design area of the report.
  2. Click Property dialog to open the List dialog.
  3. In the List dialog, go to Detail Grouping and set the Group on expression to =Fields!EmployeeId.Value.
    This ensures the that the data in list is grouped based on [EmployeeId] field.
  4. Click OK to close the dialog.
  5. Drag and drop three TextBox controls onto the List and set the Value property of as under:
    • For TextBox1, Value ="Name: " & Fields!LastName.Value & ", " & Fields!FirstName.Value
    • For TextBox2, Value ="Title: " & Fields!Title.Value
    • For TextBox3, Value ="Location: " & Fields!City.Value & ", " & Fields!Country.Value
  6. Drag and drop the Subreport control onto the List data region as shown.
  7. In the Properties window, set the ReportName property to the detail report's name (e.g., subreport-details.rdlx).
  8. To pass the parameter from master report to details report, go to Parameters property and click the ellipses next to '(Collection)'.
  9. In the Subreport - Parameters dialog, set the Parameter Name to ReportParameter1 (should be same as the report parameter name in details report) and the Parameter Value to =Fields!EmployeeId.Value.
  10. Click OK to close the dialog.
  11. To add the report title, drag and drop a TextBox control above the List data region.
  12. Click inside the text box and enter the text 'Employee Orders Report (Master-Detail Report)'.
  13. Improve the appearance of the report and preview.

See Also

Subreport

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Sparkline Control

Sparkline Control
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Sparkline Control

Glossary Item Box

Line and Area Sparklines

Let us create a report that displays the call center data trend compared to the target (times measured in seconds). Each sparkline control will display data for three criteria - call hold time, call duration, and abandoned calls.

Call Center Dashboard Report with Sparkline control

Create a Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. This report uses the 'CallCenter.xml' data source that you can download from GitHub. See XML for details on binding to XML data.

  1. On the Choose Data Source Type screen of the wizard, select XML and click Next.
  2. To specify XML File Path, click the Browse button and navigate to the desired file on your system. This report uses the 'CallCenter.xml' sample data source that can be downloaded from GitHub.
  3. Click the Next option and configure the following two datasets - Targets and CallAverages.
  4. Enter Targets into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  5. Click Add to add the second dataset.
  6. Enter CallAverages into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  7. Click Finish to successfully add the report with the JSON data source.

Design Report Layout

Report with Sparkline control
  1. Drag and drop three TextBox controls and place them one below another. These controls will be the criterion labels. Set their Value property as follows:
    • TextBox2: Hold Time
    • TextBox3: Call Duration
    • TextBox4: Abandoned
  2. Drag and drop a TextBox control near Hold Time and set its Value to =Last(Fields!AvgHold.Value, "CallAverages").
  3. Drag and drop a TextBox control near Call Duration and set its Value to =Last(Fields!AvgDuration.Value, "CallAverages").
  4. Drag and drop a TextBox control near Abandoned and set its Value to =Last(Fields!Abandonments.Value, "CallAverages").
  5. Drag and drop a TextBox control above the last three TextBoxes and set its Value to 'Actual'.
  6. Drag and drop the Sparkline control against Hold Time and set its Name to HoldTimeSparkline.
  7. Set the following properties of the HoldTimeSparkline to some suitable values, for example:
    • SeriesValue: =Fields!AvgHold.Value / First(Fields!THoldTime.Value, "Targets")
    • LowerBound: 1
    • UpperBound: 1.005
    • RangeVisibility: True
    • DataSetName: CallAverages
  8. Drag and drop the Sparkline control against Call Duration and set its Name to CallDurationSparkline.
  9. Set the following properties of the CallDurationSparkline to some suitable values, for example:
    • SeriesValue: =Fields!AvgDuration.Value / First(Fields!TDuration.Value, "Targets")
    • LowerBound: 1
    • UpperBound: 1.005
    • RangeVisibility: True
    • DataSetName: CallAverages
  10. Drag and drop the Sparkline control against Abandoned and set its Name to AbandonementsSparkline.
  11. Set the following properties of the AbandonementsSparkline to some suitable values, for example:
    • SeriesValue: =Fields!Abandonments.Value
    • LowerBound: 1
    • UpperBound: 1.005
    • RangeVisibility: True
    • DataSetName: CallAverages
  12. Drag and drop the TextBox control above the last three sparklines and set its Value to 'Today (compared to target)'.
  13. Drag-drop a TextBox control below the Sparkline controls and set its Value to '(Times measured in seconds)'.
  14. To create the report's title, drag and drop the TextBox control onto the report’s designer and set its Value to 'Call Center Dashboard: Overall Performance'.
  15. Modify the appearance of the report and preview.

Whisker and Column Sparklines

You can use a whisker sparkline to render “win/loss/tie” scenarios (for example, sports statistics) or “true/false” scenarios (for example, was the sales goal met or the temperature above average).

Let us create a report to show the statistics for the football game using Sparkline controls of type Whisker and Column.

Whisker and Column Sparkline

Create a Report

In the ActiveReports Designer, create a new RDLX report.

Bind Report to Data

Connect to a Data Source

  1. As you create a new report, bind data to connect to the 'FootballStatistics.xml' data source on GitHub. See XML Provider page for details on binding with XML data. The connection string for our data is as shown:
    Connection String Copy Code
    xmldoc=C:\Data\FootballStatistics.xml

    Add Data Set

  2. Add the following dataset with the Query as shown:
    Query Copy Code
    //Game

Design Report Layout

  1. Drag and drop the List data region inside which we will drop all the controls.
    1. Set the DataSetName to 'Games'.
    2. Click open the Property dialog.
    3. Go to Detail Grouping and set the Group on expression to =[Team].
    4. Click OK to close the dialog.
  2. Drag and drop a TextBox control inside the List data region and set its Value to 'Win/Loss Record'
  3. Drag and drop the Sparkline control inside the List data region, below the textbox added in the previous step, and, with the sparkline selected, set the properties as follows:
    • Sparkline Type: Whiskers
    • SeriesValue: Set this property to =Fields!WinLossTie.Value from the connected data set.
    • FillStyle > FillColor: #f26324
    • Click open the Properties dialog, go to the Sorting page, and set the expression to =Fields!Date.Value and Direction to 'Ascending'
  4. Now drag and drop a few more text boxes inside the List data region to show passing and rushing trends and some sparklines to visualize the corresponding data as shown:
    Whiskers Sparkline
  5. Fill in the text in the text boxes as shown above, and set the corresponding sparkline properties as follows:
    Under 'Passing Trends',
    • Select the sparkline next to 'Completions' text and set the SeriesValue to =Fields!PassCMP.Value
    • Select the sparkline next to 'Yards' and set the SeriesValue to =Fields!PassYDS.Value
    • Select the sparkline next to 'Interceptions' and set the SeriesValue to =Fields!PassINT.Value

    Under 'Rushing Trends',

    • Select the sparkline next to 'Carries' and set the SeriesValue to =Fields!RushATT.Value
    • Select the sparkline next to 'Yards' and set the SeriesValue to =Fields!RushYDS.Value
  6. To set the common properties of the sparklines added in the previous step, select the following properties:
    • SparklineType: Columns7
    • FillStyle > FillColor: #f26324
    • Click open the Properties dialog, go to the Sorting page and set the expression to =Fields!Date.Value and Direction to 'Ascending'
  7. To create the report's title, drag and drop the TextBox control inside the List data region on the top of the report and set its Value to =[Team].
  8. Modify the appearance of the report and preview.

Stacked Bar Sparkline

Let us create a report that shows the stacked bar sparkline use case. We will build our player performance data in the report to show the comparative scores of two players.

Sparkline Stacked Bar

Create a Report

In the ActiveReports Designer, create a new RDLX report.

Bind Report to Data

Connect to a Data Source

  1. As you create a new report, bind data to the players.csv file. See CSV Provider page for details on binding with CSV data. The connection string for our data is as shown:
    Connection String Copy Code
    Path=data\\MyOrders.csv;Locale=en-US;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;HasHeaders=True

Design Report Layout

Sparkline Stacked Bar

  1. Drag and drop the Tablix data region onto the report's designer.
  2. Drag and drop the [Round] field onto the Row Group area.
  3. In the Values area, write the expression =Sum([Points]) to calculate the sum of points.
  4. To add a new column, right-click anywhere on the second column of the Tablix and select Insert Column > Outside Group.
  5. Drag and drop the Sparkline control in the third cell.
  6. With the Sparkline selected, set the following properties:
    • DataSetName: Players
    • SeriesValue: =Fields!Points.Value
    • SparklineType: StackedBar
    • FillStyle > FillColor: Coral
  7. Modify the appearance of the report and preview.

See Also

Tutorial: Sparkline Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tablix Data Region

Tablix Data Region
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Tablix Data Region

Glossary Item Box

Let us create an RDLX report that uses the Tablix data region to display shipments by country, quarter, and year. To display a summarized value for each quarter and year, we will add additional adjacent rows/columns or parent or child row/column groups to the tablix. The report connects to the 'Orders' JSON data available here.

The final report will look like as shown.

Report with List Control

Create a Report

In the ActiveReports Designer, create a new RDLX report.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See JSON for details.

  1. On the Choose Data Source Type screen of the wizard, select JSON and click Next.
  2. To specify JSON File Path, click the Browse button and navigate to the desired file on your system. This report uses the 'DimEmployees.json' sample data source that can be downloaded from the following URL:
    https://demodata.mescius.io/northwind/odata/v1/Orders
  3. Click the Next option and configure the dataset by adding a valid query. Enter OrdersDataset into the Name field and select the node from the data tree in the Path section to generate the path. The resulting query is displayed in the Query field.
  4. Click Next to proceed to the final screen of the Report Wizard.
  5. Review the summary of the report and click Finish to successfully add the report with the JSON data source.

Design Report Layout

  1. Drag and drop the Tablix data region on the report's design area.
  2. From the dataset, drag and drop the [ShipName] field onto the Row Group area.
  3. Select the textbox on the upper-left corner of the tablix and set its Value property to 'Ship Name'.
  4. Then, drag and drop the [OrderDate] field onto the Column Group area.
  5. Similarly, drag and drop the [Freight] field onto the Values area, which is the body of the tablix. Note that the [Freight] field changes to Sum(Freight).
  6. In the Properties pane, set the Format property for the Freight field to Currency.
  7. Right-click the OrderDate column group area and select the Add Total > After option from the context menu to display the total freight charges for the order years.
    Tablix data region with bound fields

Manage Data

In a Tablix data region, you need to manage how a grouped data is rendered across the rows and columns. This is done by using Group Expressions as explained below.

  1. Modify the =Fields!OrderDate.Value expression to =Year(Fields!OrderDate.Value) to display only the Year part of the date in the textbox of the column group.
  2. With the Tablix data region selected, go to the Group Editor Group Editor Icon to display row groups and column groups.
  3. Select Tablix1_OrderDate1 column group and go to the Properties pane.
  4. In the Group Expressions property, click Show Items.
  5. Update the Group Expression to =Year(Fields!OrderDate.Value).
  6. Update the textbox with Total label to 'Total Freight Charges'.
    Tablix data region

Add Row and Column Groups

Let us add row and column groups to the tablix data region. We will add a child group to the OrderDate column group to display total prices for each quarter of a year. Similarly, we will add a parent group ShipCountry to ShipName row group to show countries and group the ship names according to the country.

  1. Right-click the OrderDate column group area to view options in the context menu.
  2. Go to Column Group and select the Child option.
  3. From the Group Editor, select the newly added child group i.e. Tablix1_ColumnGroup1 and go to the Properties pane.
  4. In the Group Expressions property, click Show Items and click Add.
  5. Set the Group Expression to =Quarter(Fields!OrderDate.Value).
  6. Now, select the OrderDate child group area in the tablix and set its Value property to ="Q" & Quarter(Fields!OrderDate.Value).
  7. Similarly, right-click the ShipName row group area to add a parent group from the context menu.
  8. Go to Row Group and select Parent option.
  9. From the Group Editor, select the newly added parent group i.e. Tablix1_RowGroup1 and go to the Properties pane.
  10. In the Group Expressions property, click Show Items and click Add.
  11. Set the Group Expression to =Fields!ShipCountry.Value.
  12. Now, select the ShipCountry row group area in the tablix and set its Value property to =Fields!ShipCountry.Value.
  13. Provide a label Ship Country to the column displaying the ship country.
  14. Merge the [Ship Country], Ship Name, and Total Freight Charges textboxes with the empty adjacent cells.
    Tablix Data Region

Add Totals to the Groups

We will add a total row to display the sum of freight charges for each country and a subtotal column to display the total freight charges for each quarter of the order year.

  1. Right-click the ShipCountry column group area and select the Add Total > After option from the context menu.
  2. Similarly, right-click the OrderDate child group area and select the Add Total > After option from the context menu.

Add Report Title and Preview Report

  1. To add the report title, drag and drop the TextBox control to the PageHeader section and set its Value property to 'Shipments by Country, Quarter, and Year'.
  2. Improve the appearance of the report and preview.

See Also

Tablix

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TextBox Control

TextBox Control
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > TextBox Control

Glossary Item Box

Let us create an RDLX report that uses TextBox controls to display the price and total number of items in stock. We will be using BandedList control to contain text boxes and display data for each row. The report connects to the 'Products' JSON data available here. The final report will be as shown.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

Products Report with TextBox controls at Preview

Design Report Layout

  1. Drag and drop the BandedList control on the report’s designer.
  2. Drag the following data fields to the Details band of the BandedList control: [ProductId], [UnitPrice], and [UnitsInStock]. All these fields are bound text boxes.
  3. To provide headings (labels) to the data displayed in the text boxes in Details band, drag and drop three TextBox controls onto the Header band of the BandedList control and set the Value property of the text boxes to 'Product ID', 'Unit Price', and 'In Stock', respectively.
  4. To display the total number of products in stock, drag and drop two TextBox controls onto the Footer band of the BandedList control and set the properties as follows.
    - TextBox1: Set the Value property to Total:. This is an unbound text box.
    - TextBox2: Set the Value property to the expression: =Sum(Fields!UnitsInStock.Value). This is a calculated textbox; the expression calculates the total number of products in stock.
  5. To provide the report's title, drag and drop another TextBox control onto the top center in the design area. Enter the text of the title into the Value property or directly inside the text box, e.g. Products Info.
  6. To add the information on the report generation date, drag and drop a TextBox control on the upper right corner of the report and set the Value property to the expression: ="Report Generation Date:" & Format(Now(), "dd/MM/yyyy").
    Products Report with TextBox controls at Design
  7. Modify the appearance of the report and preview.

See Also

TextBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Map Data Region

Map Data Region
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Report Controls in Page/RDLX Reports > Map Data Region

Glossary Item Box

You can create a Page report that contains a map using the ActiveReports Map data region. The Map data region shows your data on a geographical background. This walkthrough illustrates how to create a report that uses a Map to display data.

The final report will be as shown.

Customers Population Report with Map control at Preview

Create a Report

In the ActiveReports Designer, create a new Page report.

Bind Report to Data

As you create a new report, you can configure the report data connection in the Report Wizard. You can also access the Report Data Source dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option. See SQLite for details.

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
  2. To specify the DataBase Path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub.
  3. Click Test Connection to test the connection.
  4. Then click the Next option and configure the dataset by adding a valid query.
  5. Enter Customers into the Name and an SQL query like the following into the text box:
    Dataset Query Copy Code
    SELECT Address.Region, Customer.CustomerID FROM (Address INNER JOIN Person ON Address.[AddressID] = Person.[AddressID]) INNER JOIN Customer ON Person.[PersonID] = Customer.[PersonID];
  6. Click Finish to successfully add the report with the SQLite data source.

Design Report

  1. Drag and drop the Map data region on the design area.
  2. In the Select a Map Template wizard that appears, select the USA Map template.
  3. Click the Map to have the map panes appear.
  4. In the layers pane, right-click PolygonLayer1 and select Layer Data to open Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, go to the Analytical data page.
  6. Select Customers from the Dataset property combo box and then click the Add (+) button located next to the Match label. This creates an empty match item and enables its Spatial and Analytical fields editor.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  7. In the Spatial field property, select STATE_ABBR from the combo box; and similarly, select =Fields!Region.Value in the Analytical field property. This builds the match field expression and relates the analytical data to map elements on a polygon layer.
  8. Click OK to close the dialog.
    Configure the appearance of the Map
  9. In the layers pane, right-click PolygonLayer1 and select Edit to open Map Polygon Layer dialog.
  10. In the General page of the dialog, select #STATE_NAME from the Label Text combo box to display as a label inside polygons at run time.
  11. Go to the Color Rule page of the dialog, and select Visualize data by using color palette option. This activates the tabs below.
  12. On the General tab, enter the following expression =Count([CustomerID]) in the Data field property and set Palette property to SemiTransparent.
  13. On the Distribution tab, set the Method property to EqualInterval.
  14. On the Legends tab, click to select Show in legend.
  15. In Legend name, select 'Legend'. This name relates to the default legend that appears in the Legend collection.
  16. Click OK to close the dialog.
  17. On the design surface, click the Map control to select it and go to the Properties Panel to set the following properties:
    • BackgroundColor: White
    • BackgroundGradientEndColor: White
    • BorderStyle: Solid
    • ColorScale > Hidden: True
    • DistanceScale > Hidden: True
    • Size: 6.5in, 4.75in
    • ViewPort > BackgroundColor: LightSteelBlue
    • ViewPort > BackgroundGradientEndColor: White
    • ViewPort > BorderStyle: None
    • ViewPort > CoordinateSystem: Planar
    • ViewPort > Meridians > Hidden: True
    • ViewPort > Parallels > Hidden: True
    • ViewPort > View > Zoom: 115
  18. With the Map control selected, go to the Properties window, click the Legends (Collection) property and then click the ellipsis button that appears.
  19. In the LegendDesigner Collection Editor that appears, under the Members list, select the existing legend and set the following properties.
    • BackgroundColor: LightSteelBlue
    • BackgroundGradientEndColor: White
    • Location > DockOutsideViewport: False
    • Location > DockPosition: RightBottom
    • Title > (Caption): Number of Customers
  20. Click OK to close the dialog.
  21. With the Map control selected, go to the Properties window, click the Titles (Collection) property and then click the ellipsis button that appears.
  22. In the MapTitleDesigner Collection Editor that appears, with Title selected in the Members list set the following properties.
    • (Text): Customers Population
    • Color: Black
  23. Click OK to close the dialog.
  24. Preview the report.

See Also

Map
Quick Start

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tutorials: Page/RDLX Report Scenarios

Tutorials: Page/RDLX Report Scenarios
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios

Glossary Item Box

This section takes you through the set of tutorials aimed at covering the scenarios that you come across while designing reports.

  • Create RDLX Dashboard Report
  • Create Multi-Column Layout (or Columnar report)
  • Create Top N Report
  • Create a Red Negatives or a Green Bar Report
  • Apply Theme at Runtime Using Dynamic Expression
  • Add Page Numbering
  • Show Row Number in Tablix and Table
  • Link Multiple Datasets to Same Data Region
  • Localize RDLX Report Content

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create RDLX Dashboard Report

Create RDLX Dashboard Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Create RDLX Dashboard Report

Glossary Item Box

The RDLX Dashboard report is the latest addition to the varied reports that you can design in ActiveReports. To learn about the key features of this report type, see RDLX Dashboard Report.

Let us create an interactive RDLX Dashboard Report. The report will use the List and Chart data regions to visualize data from two datasets. In this report, you will be able to interact with the data through the Apply Parameters action and visualize the manipulated data. See the Actionable Parameters topic for more information.

This article explains creating a new report in the ActiveReports Standalone Designer.

If you are creating a new report in the Visual Studio Integrated Designer, see Quick Start.

RDL Dashboard Report Preview

Create a Report

  1. Create a New Report.
  2. In the New Report wizard, choose the Report Type as RDLX Dashboard and click Next.
    Choose a Report Type from New Report Dialog

Bind Report to Data

  1. On the Choose Data Source Type screen of the wizard, select SQLite and click Next.
    Choose Data Source Type as SQLITE
  2. To specify the Database path, click the Browse button and navigate to the desired file on your system. For example, you can connect to the Reels.db sample data source which can be downloaded from GitHub. See SQLite and Configure ActiveReports using Config File topics for more information.
    Configure SQLIte Queries
  3. Then click the Next option and configure the datasets by adding valid queries.

    Add Datasets

  4. On the Configure SQLite Queries screen, enter Genre in the Name field and the following SQL query: SELECT * FROM Genre.

    Configure SQLite Queries
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

    This dataset contains the following fields:

    • GenreID
    • GenreName
  6. Click Add to add another dataset with the name SalesByGenre.
  7. Enter the following SQL query: SELECT * FROM SalesByGenre.
    Configure SQLite Queries
  8. Click OK to close the dialog. Your dataset and queried fields appear as nodes in the Report Explorer.

    This dataset contains the following fields:

    • GenreID
    • GenreName
    • StorePrice
    • SaleID
    • Quantity
    • SalesID
    • SaleDate
    • Profit
  9. Click Next. On the final screen of the Report Wizard, review the summary of the report and click Finish to successfully add the report with the SQLite data source.

    Configure Dashboard

    Add a Field to Dataset

  10. In the Report Explorer, right-click the Genre dataset and select Edit.
  11. In the DataSet dialog, go to the Fields page and add a new field with Name as GenreIDInt and Value as =Convert.ToInt32([GenreID]).
    You will see how we use the GenreIDInt field to avoid type mismatch.
  12. Click OK to save your changes.

Add Report Parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
  2. In the Report - Parameters dialog that appears, add a name for the parameter, 'paramGenreID'.
  3. Set the Data Type to 'Integer'.
  4. Select the Multivalue and Hidden check boxes.
  5. In the Report - Parameters dialog, go to the Available Values tab and select the From query radio button.
    • Dataset: Genre
    • Value field: GenreIDInt
    • Label field: GenreID
  6. Go to the Default Values tab and select the From query radio button.
    • Dataset: Genre
    • Value field: GenreIDInt
  7. Click OK to close the dialog and add the parameter to the collection.

Design Report Layout

RDL Dashboard Report in Design Time

  1. Add List data region

  2. From the toolbox, drag a List data region onto the design surface of the report.
  3. To display the controls placed inside the list to display in a columnar layout, go to the Properties panel to set the properties of the List data region as follows:
    • DataSetName: Genre
    • RowsOrColumnsCount: 5

  4. Add Apply Parameters Action on the List data region

  5. Go to the Action property and click the ellipses to open the List - Action dialog.
  6. Select 'Apply Parameters' option and set the following values:
    • Name: paramGenreID
    • Type: Toggle
    • Value: =Fields!GenreID.Value
  7. Click OK in the List - Action dialog.
    Action Type for List

    Add Controls onto the List Data Region
  8. Drag and drop the TextBox control onto the List data region and bind it to the =Fields!GenreName.Value field.
  9. Drag and drop the CheckBox control onto the List data region, to the left of the TextBox and set its Checked property to the following expression:
    =IndexOf(Parameters!paramGenreID.Value, Fields!GenreIDInt.Value)>-1.

    Add Chart Data Region

    Let us create a chart that shows the total profit over a period of time. Refer Create Single Line Chart tutorial to visualize the data in a single line chart.
  10. Drag and drop the Chart data region onto the design area, below the List data region. The Chart Wizard dialog appears with an option to select the data and the chart type.
  11. Select the Dataset Name as 'SalesByGenre' and the Chart Type as 'Line'.
  12. Click Next to proceed. Here, you need to specify the line settings. We will define a data series value to display the profit values along the horizontal axis.
    Field | Aggregate
    =[Profit] | Sum
  13. In Choose Data Categories, set Field to =[SaleDate] and Sort Direction to 'Ascending'. We will add more customizations to the category in later steps.
  14. Click Next to preview your chart.
  15. Click Finish to complete adding the Chart.
  16. Expand the width of the Chart control to the width of the List data region in the design area by dragging the side marker.
  17. From the Report Explorer, select 'Plot - Plot1' node and set the LineAspect property to 'Spline'.
  18. Select the chart's X-Axis and from the Properties Panel, set the Labels > Format to 'd' to denote date and the Labels > LabelsAngle to '-45'.
  19. Select the chart's Y-Axis and from the Properties Panel, set the Labels > Format to 'c' to denote currency.

    Add Filter to the Chart Data Region (Cross Filter)

  20. From the Report Explorer, select 'Chart'.
  21. Go to the Filters property and click the ellipses to open the Chart - Filters dialog.
  22. In the Chart - Filters dialog, click the Add (+) icon to add a filter for the chart.
    • Expression: =Fields!GenreID.Value
    • Operator: In
    • Values > Expression: =Parameters!paramGenreID.Value.
    • Click OK.
      Filtering in Chart

Customize Report Appearance

You can do some customizations on the report, especially on the chart using the smart panels. For chart customization, refer the 'Set Advanced Customization' section in the Create Single Line Chart tutorial.

Preview Report

The final report is shown at the beginning of this page. Note that the preview shown is in WebDesigner preview (similar to JSViewer). Ensure that you add System.Data.SQLite or System.Data.SQLite.Core nuget package and add the ActiveReports.config file to your project. See Configure ActiveReports using Config File for more information.

See Also

RDLX Dashboard Report
Parameters
Filters

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Multi-Column Layout (or Columnar report)

Create Multi-Column Layout (or Columnar report)
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Create Multi-Column Layout (or Columnar report)

Glossary Item Box

This topic describes creating a columnar report layout in RDLX and Page reports.

RDLX Report

There are two ways to create a Columnar layout in an RDLX report.

Using RowsOrColumnsCount and Count properties of the List data region

List data region available in Page and RDLX reports (RDLX and RDLX Dashboard), supports generating multiple columns or rows with the help of the following properties:

  • RowsOrColumnsCount, which is the number of rows or columns (By default = 1)
  • GrowDirection, which is the list layout grow direction (Row, RowReverse, Column (default), ColumnReverse)

If the GrowDirection = Column and the Count = number of columns say 4, then the data is rendered horizontally in 4 columns. The rest of the list is populated based on the data region's fixed size. Also, if the GrowDirection = Row and the Count = number of rows say 8, then the data is rendered vertically in 8 rows. The rest of the list is populated based on the data region's fixed size.

  • RowsOrColumnsCount=4 and GrowDirection = Column
    Columnar Report with the GrowDirection property set to Column
  • RowsOrColumnsCount=4 and GrowDirection = ColumnReverse
    Columnar Report with the GrowDirection property set to ColumnReverse
  • RowsOrColumnsCount=8 and GrowDirection = Row
    Columnar Report with the GrowDirection property set to Row
  • RowsOrColumnsCount=8 and GrowDirection = RowReverse
    Columnar Report with the GrowDirection property set to RowReverse

Go through the tutorial on Create Gauge Chart, which provides step-wise instructions on how a multi-column list layout is used for gauge charts to display the units in stock in each category of products.

Using the Columns property of the Report's Body

This section talks about creating a columnar report layout in an RDLX report by using the Columns property of the report's Body.

The final report will look as shown.

RDL Report with Columns Set for Report Body

Create a Report

In the ActiveReports Designer, create a new RDLX Report.
Bind Report to Data
  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter a name for the data source.
  3. Select 'SQLite Provider'. See Custom Data Provider for more information.
  4. Enter the Connection String similar to the following based on the location of nwind.db file:
    Connection String Copy Code
    data source= C:\data\nwind.db;
  5. Click OK.
  6. In the DataSet dialog that appears, set the Name as 'DataSet1'.
  7. Go to the Query page and enter a query in the Query textbox in the following format:
    DataSet Query Copy Code
    Select * from Customers order by ContactName
  8. Click the Validate DataSet icon Validate DataSet Icon to validate the query. If there is no warning, it means the query is validated. Then click OK to close the dialog.

Design Report Layout

Create a Column Layout for the Report
  1. In the Report Explorer, select Body.
    Report Body
  2. Set the following properties in the Properties panel:
    Property Name | Property Value
    Columns | 3
    ColumnSpacing | 0.10in
    Size

    2in, 2.15in

    Populate Data in Report
  3. Drag and drop the List data region onto the design surface.
  4. Go to Report Explorer, expand the DataSet1 node, and drag and drop the following fields inside the List data region, one below the other, with their Value property set to the following fields:
    • =Fields!ContactName.Value
    • =Fields!Address.Value
    • =Fields!City.Value
    • =Fields!Phone.Value
  5. From the toolbox, drag and drop the Barcode control below =Fields!Phone.Value field, inside the List data region, and set its Value property to =Fields!PostalCode.Value.
  6. Ensure that the DataSetName property of the List data region is set to 'DataSet1'.
  7. You will also need to adjust the Size (for example, 1.75in, 2.125in in our case) of the List data region to accommodate the data in the specified columns.
  8. Set the BackgroundColor property of the list to say, 'MistyRose'.
    RDL Report with Columns Set for Report Body
  9. Improve the appearance of the report.

Preview Report

The final report is shown here.

Page Report

There are two ways to create a Columnar layout in Page report.

Using RowsOrColumnsCount and Count properties of the List data region

List data region can be used in Page report in a similar way as RDLX report, to create columnar reports, such as an address labels report. See this Create Address Labels in Page Report topic for details on creating a columnar report.

Using OverflowPlaceholder control

See Create Columnar Reports with OverflowPlaceholder Control topic for details.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Address Labels in Page Report

Create Address Labels in Page Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Create Multi-Column Layout (or Columnar report) > Create Address Labels in Page Report

Glossary Item Box

With Page reports, you can create an address label report using a List data region.

Note: The report connects to NWIND.db file that can be downloaded from GitHub.

The final report will look as shown.

Address Labels Page Report

Create a Report

In the ActiveReports Designer, create a new Page Report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter a name for the data source.
  3. Select 'SQLite Provider'. See Custom Data Provider for more information.
  4. Enter the following Connection String similar to the following based on the location of the nwind.db file:
    Connection String Copy Code
    data source= C:\data\nwind.db;
  5. Click OK.
  6. In the DataSet dialog that appears, set the Name as 'DataSet1'.
  7. Go to the Query page and enter the following query in the Query textbox :
    DataSet Query Copy Code
    Select * from Customers order by ContactName
  8. Click the Validate DataSet icon Validate DataSet Icon at the top right hand corner above the Query box to validate the query. If there is no warning, it means the query is validated. Then click OK to close the dialog.

Design Report Layout

  1. Drag and drop List data region onto the design surface.
  2. Go to Report Explorer, expand DataSet1 node and drag and drop the following fields inside the List data region, one below the other, with their Value property set to the following fields:
    • =Fields!ContactName.Value
    • =Fields!Address.Value
    • =Fields!City.Value
    • =Fields!Phone.Value
  3. From the toolbox, drag and drop the Barcode control below =Fields!Phone.Value field, inside the List data region, and set its Value property to =Fields!PostalCode.Value.
  4. Select List data region and from the Properties panel, set the following:
    • GrowDirection: Column
    • RowsorColumnsCount: 4
  5. Ensure that the DataSetName property of the List data region is set to 'DataSet1'.
  6. You will also need to adjust the FixedSize and the Size of the List data region to accommodate the data in the specified columns and control the number of records displayed on each page.
  7. Set the BackgroundColor property of the list to say, 'MistyRose'.
    Address Labels Page Report at Design
  8. Improve the appearance of the report.

Preview Report

The final report is shown at the beginning of this page.

See Also

List
Overflow Placeholder (Page report only)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Top N Report

Create Top N Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Create Top N Report

Glossary Item Box

Top N reports are beneficial where there is a need to display only the specific number of top-most rows or records from a table or list. You can create this type of report by using the TopN operator in dataset filters or modifying the query while creating a dataset. TopN operator can be used in dataset filters for all data sources. Your data will be more meaningful if you also specify the order of rows.

Consider a scenario where the user wants to display the top ten movie records.

  1. Create a new Page/RDLX report and bind the data to 'reels.db'. See Custom Data Provider for more information. The data source connection string in the Report Data Source dialog will be as follows:
    Data Source Connection String Copy Code
    data source = C:\Data\reels.db;

  2. In the DataSet dialog, go to the Query tab and enter the following query to fetch the data ordered by user rating from highest to lowest:
    Dataset Query Copy Code
    SELECT * FROM Movie ORDER BY UserRating Desc
  3. Navigate to the Filters page and fill in the following entries to fetch the top 10 movie records from the Movie table:

    Expression: =[UserRating]

    Operator: TopN

    Value: 10

  4. Click OK to close the dialog.
  5. Drag-drop the Table data region onto the design surface.
  6. In the Report Explorer, expand the DataSet node and drag and drop the following fields inside the cells of the details row:
    [Title]
    [YearReleased]
    [UserRating]
  7. Drag-drop a TextBox control for the report heading.

    Top N Report at Design Time
  8. Preview the report. You'll see only 10 records in your report.

The following image illustrates Top N Report displaying top 10 movie records:

Top N Report at Run Time

The following sections provide sample dataset queries to obtain top N data from other data sources.

Sqlite

DataSet Query Copy Code
SELECT * FROM Movie LIMIT 10

OLEDB, ODBC, SQL

DataSet Query Copy Code
SELECT Top 10 * FROM Movie

XML

DataSet Query Copy Code
//countries/country[position() <= 10]

JSON

DataSet Query Copy Code
$.Customers[:10]

See Also

Table
Data Binding in Page/RDLX Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create a Red Negatives or a Green Bar Report

Create a Red Negatives or a Green Bar Report
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Create a Red Negatives or a Green Bar Report

Glossary Item Box

A Red Negatives report is a report type that shows negative values in red color such that these values meet the requirements set in a conditional expression. A Green Bar report can be similarly created by alternating the background color of a data region like a Table using conditional formatting.

The following steps show how to generate a report with negative values in red negatives.

  1. Create a new Page/RDLX report and bind the data to 'reels.db'. See Custom Data Provider for more information.
  2. In the DataSet dialog that appears, go to the Query page and enter a query in the Query textbox in the following format:
    DataSet Query Copy Code
    SELECT AccountsChart.AccountId, AccountsChart.ParentId, AccountsChart.Description, AccountsChart.Rollup, Expenses.ExpenseDate, Sum(Expenses.Amount) AS SumOfAmount
FROM AccountsChart LEFT JOIN Expenses ON AccountsChart.AccountId=Expenses.AccountID
GROUP BY AccountsChart.AccountId, AccountsChart.ParentId, AccountsChart.Description, AccountsChart.Rollup, Expenses.ExpenseDate
ORDER BY Expenses.ExpenseDate, AccountsChart.AccountId;
  3. From the Toolbox, drag and drop a Table data region onto the design surface.
  4. In the Report Explorer, expand the DataSet node and drag and drop following fields inside the cells of the details row:
    [Description]
    [Rollup]
    [SumOfAmount]
  5. In the same table, select any cell (Textbox) that displays integer values, for example [Rollup].
  6. In the Properties panel, set the following expression in the Color property:

    =iif(Fields!Rollup.Value < 0, "Red", "Black")
    Note: In general, the expression will be =iif(Fields!FieldName.Value < 0, "Red", "Black") where FieldName refers to field that the textbox contains (of integer type).
  7. To avoid repetition of [Description] in detail row, apply detail grouping based on [Description]field. See Detail Grouping for more information.
  8. Drag-drop a Textbox control for the report heading.

    Red Negatives Report at Design Time

  9. Preview the report.

The following image illustrates a report that contains negative values in red:

Red Negatives Report at Run Time

For a green bar report, click the row handle to the left of the detail row of a Table data region and set the following expression in the BackgroundColor property:

=iif(RowNumber(Nothing) Mod 2, "PaleGreen", "White")

On previewing the report, you will notice that every alternate detail the report displays has a green background as depicted by the following image.

Green Bar Report at Run Time

Note that with Detail Grouping applied on a table, the background color will not appear as expected.

See Also

Table
Data Binding in Page/RDLX Reports
Demo: Conditional Formatting

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Apply Theme at Runtime Using Dynamic Expression

Apply Theme at Runtime Using Dynamic Expression
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Apply Theme at Runtime Using Dynamic Expression

Glossary Item Box

This topic explains how to apply a theme at runtime by using a dynamic expression so that the applied theme depends on the parameter’s value.

Consider a sample report 'PurchaseReport.rdlx' which can be downloaded from GitHub: ..\Samples19\DesignerPro\ReportsGallery\Reports\Page Report\Other.

Add Parameter for User Input

  1. Open 'PurchaseReport.rdlx' report.
  2. From the Report Explorer, right-click the Parameters node and select Add Parameter.
  3. In the General tab of the Report - Parameters dialog, specify the following:
    • Name: ThemeParameter
    • Data type: String
    • Text for prompting users for a value: Select a Theme
  4. Go to the Available Values tab, select Non-queried option and add two themes with Label and Value settings as follows:
    S.no. | Label | Value
    1 | Theme1 | .\theme1.rdlx-theme
    2 | Theme2 | .\theme2.rdlx-theme
  5. Click OK.

    Add Theme to the Report

  6. Select the Report menu and click open the Report Properties.
  7. Go to the Themes page and add a theme with expression:

    =Parameters!ThemeParameter.Value

    Apply Theme to Report Controls
  8. Lets us apply themes to the table header and detail row. First, select the Header row of the table, and set following properties:
    • Color: =Theme.Colors!Dark1
    • Font > FontStyle: =Theme.Fonts!MajorFont.Style
    • Font > FontFamily: =Theme.Fonts!MajorFont.Family
    • Font > FontSize: =Theme.Fonts!MajorFont.Size
    • Font > FontWeight: =Theme.Fonts!MajorFont.Weight

  9. Select the Detail row of the table and set the following properties:
    • Color: =Theme.Colors!Light1
    • Font > FontStyle: =Theme.Fonts!MinorFont.Style
    • Font > FontFamily: =Theme.Fonts!MinorFont.Family
    • Font > FontSize: =Theme.Fonts!MinorFont.Size
    • Font > FontWeight: =Theme.Fonts!MinorFont.Weight

  10. Select all the text boxes below the table and set the BackgroundColor property to =Theme.Colors!Light1
  11. Preview the report and select any one of the two themes and click View Report to view the theme applied to the report.
    Report with Applied Theme
    Note: Since the report needs to be re-rendered for theme to apply, on preview, you can not change the theme of the report by changing the theme selection from the report parameter. The report prompts for the report parameter for the first time and shows the result on clicking View Report, however there is no change in the applied theme if you change the theme and click View Report, unless there are updates in report that causes report to re-render.

See Also

Themes

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add Page Numbering

Add Page Numbering
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Add Page Numbering

Glossary Item Box

You can choose the page numbering format for your Page reports/RDLX reports by selecting from a list of pre-defined formats or by creating a custom page numbering expression.

Adding page numbers to a report

There are two ways to add page numbering to a report.

  • From the Report Explorer, under the Common Values node, drag a pre-defined page numbering format and drop it directly onto the report design surface.
  • Or add a TextBox control to the report design surface and in the Value property of the control, use the Expression Editor Dialog to select a page numbering expression from the Common Values node.

Usually a page number is added to a report header or footer, but you can add it anywhere on the layout page.

Pre-defined page numbering formats

You can find the pre-defined page numbering formats listed in the Report Explorer under the Common Values node, and in the Expression Editor under the Common Values field.

Predefined Format Descriptions
Numbering Format Description
Page N of M This format displays the current page out of the total number of pages in the report. Here N signifies the current page of a report and M the total number of report pages. Use the following expression to set this page numbering format:
="Page " & Globals!PageNumber & " of " & Globals!TotalPages
Page N of M (Section) This format displays the current page out of the total number of pages of a grouped report section. Here N signifies the current page of a grouped report section and M signifies the total number of pages in a grouped report section. Use the following expression to set this page numbering format:
="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) This format displays the current page out of the total number of cumulative pages in a report. Here N signifies the current page of the report and M signifies the total number of cumulative pages in a report. Use the following expression to set this page numbering format:
="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Page Number This format displays only the current page number of a report. Use the following expression to set this page numbering format:
=Globals!PageNumber
Page Number (Section) This format displays only the current page number of a specific grouped report section. Use the following expression to set this page numbering format:
=Globals!PageNumberInSection
Total Pages This format displays only the total number of pages in the report. Use the following expression to set this page numbering format:
=Globals!TotalPages
Total Pages (Section) This format displays only the total number of pages in specific grouped report section. Use the following expression to set this page numbering format:
=Globals!TotalPagesInSection
Cumulative Page Number This format displays only the current cumulative page number of the report. Use the following expression to set this page numbering format:
=Globals!CumulativePageNumber
Cumulative Total Pages This format displays only the total number of cumulative pages in a report. Use the following expression to set this page numbering format:
=Globals!CumulativeTotalPages
Tip: In addition to modifying the page numbering expression in the Expression Editor, you can also modify the pre-defined formats directly in the control on the design surface.

Custom page numbering formats

Use the following steps to create your own page numbering format.

Create a custom page numbering format

  1. From the toolbox, drag and drop a Textbox control onto the report design surface.
  2. With the Textbox selected on the report, under the Properties window, click the Property dialog link. This is a command to open the TextBox dialog. See Properties Panel for more on how to access commands.
  3. In the TextBox - General dialog that appears, in the Value field, enter a page numbering expression like the following:
    =Globals!PageNumber & "/" & Globals!TotalPages
  4. Click OK to close the dialog.
  5. Select the Preview tab. Page numbers appear in the expression format you set in the Value field above, in this case, for a one-Page Report, "1/1."

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Show Row Number in Tablix and Table

Show Row Number in Tablix and Table
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Show Row Number in Tablix and Table

Glossary Item Box

In the Tablix and Table data regions, you can have displayed a number of rows by using the GroupIndex function. The GroupIndex function returns the index of a row or column member in a data region's group.

These steps assume that you have already added a Page Report/RDLX report template to your project. The reports use the Embedded JSON Data Source.

Follow these steps to use the GroupIndex function in Tablix and Table.

Show the row number in a Tablix data region with three row groups

Group Number in Tablix data region

Create a Report

In the ActiveReports Designer, create a new RDLX Report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter the name of the data source, 'PopulationData' and connect your report to the JSON data source as described here.
  3. In the Report Data Source dialog, under Connection, select the Embedded option. Add the report data as follows and then click OK.

    Show Add the JSON embedded data

    JSON embedded data Copy Code
    [{"Region":"East Asia","Country":"Japan","City":"Tokyo","Population":37468000},{"Region":"East Asia","Country":"Japan","City":"Osaka","Population":19281000},{"Region":"East Asia","Country":"China","City":"Shanghai","Population":25582000},{"Region":"East Asia","Country":"China","City":"Beijing","Population":19618000},{"Region":"East Asia","Country":"China","City":"Chongqing","Population":14838000},{"Region":"East Asia","Country":"China","City":"Tianjin","Population":13215000},{"Region":"South Asia","Country":"India","City":"Bangalore","Population":11440000},{"Region":"South Asia","Country":"India","City":"Delhi","Population":28514000},{"Region":"South Asia","Country":"India","City":"Mumbai","Population":19980000},{"Region":"South Asia","Country":"India","City":"Kolkata","Population":14681000}]
  4. In the Report Explorer, right-click the data source and select the Add Data Set option.
  5. In the DataSet dialog that appears, go to Query. Enter the query as follows into the Query textbox and click OK.
    JSON data set query Copy Code
    $.[*]

Design Report Layout

Group Number in Tablix data region

From the toolbox, drag a Tablix data region onto the report design surface and set the DataSetName property to the name of the dataset.

  1. In the Group Editor, select the Tablix row group.
    1. Go to Group property and set the Name property to Region in the Properties grid.
    2. Go to GroupExpressions property and open the Expression Collection Editor.
    3. Click Add and set the Expression to =Fields!Region.Value.
  2. Right-click TextBox3, select Expression... and in the Expression Editor, enter =GroupIndex(Region).
  3. In the Group Editor, go to Row Groups. Select Region and click Add New Group, then Add Group > Child Group.
    1. With the new group selected, go to Group property and set the Name property to Country in the Properties grid.
    2. Go to GroupExpressions property and open the Expression Collection Editor.
    3. Click Add and set the Expression to =Fields!Country.Value.

    Setting Group Expressions in Group Editor
  4. Right-click TextBox5 and select Expression...
  5. In the Expression Editor, enter =GroupIndex(Country).
  6. In the Group Editor, go to Row Groups. Select Country and click Add New Group, then Add Group > Child Group.
    1. With the new group selected, go to Group property and set the Name property to City in the Properties grid.
    2. Go to GroupExpressions property and open the Expression Collection Editor.
    3. Click Add and set the Expression to =Fields!City.Value.
  7. Right-click TextBox7 and select Expression...
  8. In the Expression Editor, enter =GroupIndex(City).
  9. Hover over the column handler next to the Region row group and click Insert Column.
    Group Number in Tablix data region
  10. Set the Value of TextBox9 to =Fields!Region.Value.
  11. Hover over the column handler next to the Country row group and click Insert Column.
  12. Set the Value of TextBox11 to =Fields!Country.Value.
  13. Hover over the column handler next to the City row group and click Insert Column.
  14. Set the Value of TextBox13 to =Fields!City.Value.
  15. Set the values of the last column in the Tablix as follows.
    TextBox | Value
    TextBox2 | Population
    TextBox4 | =Sum(Fields!Population.Value)
  16. Fill-in the Table Header to display the columns they represent.
  17. Select the Tablix and set the BorderStyle property to 'Solid' to view the merged cells clearly.
  18. Select the Tablix header row and set the TextAlign property to 'Center'. Repeat this step for the detail row.
  19. Select TextBox4 and set its Format property to 'n0'.

Show the row number in a Table data region with two table groups

Group Number in Table data region

Create a Report

In the ActiveReports Designer, create a new RDLX Report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter the name of the data source, 'PopulationData' and connect your report to the JSON data source as described here.
  3. In the Report Data Source dialog, under Connection, select the Embedded option. Add the report data as follows and then click OK.

    Show Add the JSON embedded data

    JSON embedded data Copy Code
    [{"Region":"East Asia","Country":"Japan","City":"Tokyo","Population":37468000},{"Region":"East Asia","Country":"Japan","City":"Osaka","Population":19281000},{"Region":"East Asia","Country":"China","City":"Shanghai","Population":25582000},{"Region":"East Asia","Country":"China","City":"Beijing","Population":19618000},{"Region":"East Asia","Country":"China","City":"Chongqing","Population":14838000},{"Region":"East Asia","Country":"China","City":"Tianjin","Population":13215000},{"Region":"South Asia","Country":"India","City":"Bangalore","Population":11440000},{"Region":"South Asia","Country":"India","City":"Delhi","Population":28514000},{"Region":"South Asia","Country":"India","City":"Mumbai","Population":19980000},{"Region":"South Asia","Country":"India","City":"Kolkata","Population":14681000}]
  4. In the Report Explorer, right-click the data source and select the Add Data Set option.
  5. In the DataSet dialog that appears, go to Query. Enter the query as follows into the Query textbox and click OK.
    JSON data set query Copy Code
    $.[*]

Design Report Layout

Group Number in Table data region

  1. From the toolbox, drag a Table data region onto the report design surface.
  2. Set the DataSetName property to the name of the dataset.
  3. Select the Details row, right-click, and select Insert Group from the context menu.
  4. In the Table - Groups dialog, add two groups and set the Name and Group on > Expression in the following sequence as follows:
    S.no. | Name | Expression
    1. | Region | =Fields!Region.Value
    2. | Country | =Fields!Country.Value
  5. Click OK to close the dialog.
    You will see the two groups, and respective group header and group footer rows added to the table.
  6. Merge the cells of the first group header row and enter =Fields!Region.Value.
  7. Similarly, merge the cells of the second group header and enter =Fields!Country.Value.
  8. Delete the footer rows.
  9. Insert two more columns in the table. You can insert a column by selecting the last column of the table, right-clicking, and then selecting the Insert Column to the Right.
  10. In the first textbox of the Details row, enter =GroupIndex(Region) to display the index number for Region table group and in the second textbox, enter =Fields!Region.Value to display the region name.
  11. In the third textbox of the Details row, enter =GroupIndex(Country) to display the index number for Country table group and in the fourth textbox, enter =Fields!Country.Value to display the country name.
  12. In the fifth textbox of the Details row, enter =Fields!Population.Value. and set its Format property to 'n0'.
  13. Fill-in the Table Header to display the columns they represent.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Link Multiple Datasets to Same Data Region

Link Multiple Datasets to Same Data Region
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Link Multiple Datasets to Same Data Region

Glossary Item Box

Many a time, we need to display varied data from different datasets into one data region. This is now possible by using the Lookup function in a data region.

The Lookup function returns a value corresponding to a related or a common field with the same data type in another data set. It is set as an expression in the Value property of a data region's Textbox. The Lookup function in ActiveReports is similar to the Microsoft Excel's VLOOKUP.
Using multiple datasets in a data region at design time

Create a Report

In the ActiveReports Designer, create a new Page Report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by right-clicking the Data Sources node in the Report Explorer and then selecting the Add Data Source option.
  2. In the dialog, select the General page and enter a name for the data source.
  3. Select 'SQLite Provider'. The report connects to the SalesResult.db file can be downloaded from GitHub: ..\Samples19\Data\SalesResult.db. See Custom Data Provider for more information.

Add Dataset1

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the Add Dataset that appears, select the General page and let the name of the dataset be Dataset1. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT M01Product.Category, M01Product.ProductID
FROM M01Product
  4. Click the Validate DataSet icon Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

    The Dataset1 contains following fields:

    • Category
    • ProductID

Add Dataset2

  • Repeat Steps 1 and 2 to add another dataset with name Dataset2.
  • On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM T01Result
  • Click the Validate DataSet icon Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  • Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

The Dataset2 contains following fields:

  • ID
  • ProductID
  • Quantity
  • PDate
  • FY

Design Report
Using multiple datasets in a data region at run time

  1. From the toolbox, drag a Table data region onto the design surface of the report.
  2. Go to the Properties panel to set the properties of Table data region as follows:
    Property Name | Property Value
    FixedSize | 4in, 4in
    Location | 0in, 0in
    DataSetName | Dataset1
  3. Hover your mouse over the text boxes of the Table Details row to access the field selection adorner and set the following fields in the table cells along with their properties.
    Cell | Field
    TextBox4 | Category
    TextBox5 | ProductID
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.

  4. Select TextBox6 of the Table data region and from the Properties pane, set the following properties:

    Property Name | Property Value
    Value | =Lookup(Fields!ProductID.Value, Fields!ProductID.Value, Fields!Quantity.Value, "DataSet2")
    TextAlign | Left

    The expression in the Value property returns the value of Quantity from Dataset2, corresponding to the related data field ProductID in Dataset1.

  5. Select TextBox3 of the Table data region and from the Properties pane, set the following properties:
    Property Name | Property Value
    Value | Quantity
    TextAlign | Left
  6. Select the header row using the row handle to the left and in the Properties Panel, set the FontWeight property to Bold.

Preview Report

The final report is shown at the beginning of this page.

See Also

LookupSet Function in Data Regions

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Localize RDLX Report Content

Localize RDLX Report Content
See Also
Report Authors > Design Reports > Design Page/RDLX Reports > Tutorials: Page/RDLX Report Scenarios > Localize RDLX Report Content

Glossary Item Box

This topic describes how to localize a report that targets different languages and cultures. A localized report displays text based on different cultures.
Let us use the PatientHealthReport.rdlx report to demonstrate localizing report content in a specific language.

Multi-lingual Report

As you may observe, the report is bound to json data sources that contain report data as well as data for localization.

The report utilizes a report parameter to enable users to choose a language out of English, Japanese, and Chinese. The Lookup function is used to fetch data from other datasets, that contain the localized text for each language. Creating such a report mainly requires report-level settings with smart design and no special features. Consider the following steps for creating such reports:

  1. We need a DataSet with all the predefined Resource Strings, to contain localized strings for each language according to the report items’ values. For example, in the attached report we have the 'ReportResourceStrings' data source, and 'ReportResourceStringDataSet' dataset with the following fields:
    Resource Strings
    Language1
    Language2
    Language3

    In the report, we are using Culture Code (e.g., "en-US", "ja-JP", and "zh-CN") as column names, so it is much more simplified.
    Label | en-US | ja-JP | zh-CN
    City Hospital | City Hospital | シティ病院 | 城市医院
    Patient Name | Patient Name | 患者名 | 患者姓名

  2. Setup a report parameter, 'pReportLanguage', to set the report language and culture code. This parameter should prompt the user to select the language.
    Name | pReportLanguage
    Type | String
    Available Values | Label | Value
    English | en-US
    Japanese | ja-JP
    Chinese | zh-CN

  3. Set the Language property of the report as shown below. This property also sets the Format string of the controls*.

=Parameters!pReportLanguage.Value

    This should set up the culture of all textboxes etc. in the report.

  4. As we set the column names as culture codes, we will use the parameter to set fields dynamically in the Lookup function.
    Sample expression to display 'Patient ID' label:

=Lookup("PatientID", Fields!Label.Value, Fields.Item(Parameters!ReportLanguage.Value).Value, "ReportResourceStringsDataSet")

  5. One might also like to add conversion values for units used in different cultures like the Resource string dataset. So, for example, for 'en-US', we would like to show temperature unit in °F and for 'ja-JP', we would like to show them in °C. For this, you can add another data set with the following fields:
    • CultureCode
    • ConversionRateToUSD
    • TemperatureUnit

    In our case, 'ReportCultureInfoDataSet' dataset does the conversion. The data is as shown:
    cultureCode | conversionRateToUSD | temperatureUnit
    en-US | 1 | °F
    ja-JP | 157.3 | °C

    Sample expression to display 'Bill Amount' value:

=Fields!bill_amount.Value * Lookup(Parameters!pReportLanguage.Value, Fields!cultureCode.Value, Fields!conversionRateToUSD.Value, "ReportCultureInfoDataSet")

    Here, 'bill_amount' (default in USD) is converted based on our report language/culture parameter value.

    *You can also select report controls individually and set the Language property so the format changes based on the language parameter. The formatting is applied based on the following priority:

    1. Control.Language property
    2. Report.Language
    3. Application Environment's Language property
    4. System Language settings.
      Our focus is only scoped to the report-level settings.

  6. Preview the report.
    You will see a prompt to select a language. Select a language and click 'View report'.

See Also

Scripts

DevOps
Localization

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Design Section Reports

Design Section Reports
Report Authors > Design Reports > Design Section Reports

Glossary Item Box

ActiveReports Designer supports designing successful section reports driven by data.

Note:

  • We recommend specifying the CrossPlatform compatibility mode for all new reports. The CrossPlatform compatibility mode is the only available mode in the WebDesigner.
  • We also recommend specifying the virtual printer setting for all new reports by adding this script to any new Section report:
    1. Switch to the Script tab.
    2. Add the ReportStart event.
    3. Add this code inside the ReportStart event:
      this.Document.Printer.PrinterName = "";

This section covers a wide range of topics to re-mould data into meaningful insights:

Layout

Learn about the structure of section reports.

Report Settings Dialog

Learn about setting the report margins, printer settings, styles, and design layout of a report.

Aggregates Calculations

Learn what expressions and aggregates are supported in section reports.

Display Page Numbers and Report Dates

Learn about using the ReportInfo control in section reports.

Date, Time, and Number Formatting

Learn about formatting in section reports.

Interactivity

Learn about adding interactive features in section reports.

Scripts

Learn how to use C# or VB script in section reports.

Report Events

Learn how to use events to control report behavior.

Tutorials: Report Controls in Section Reports

Learn how to design the Section reports in the Report Designer from scratch using tutorials.

Tutorials: Section Report Scenarios

Learn how to create commonly-used section reports using tutorials.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Layout
Report Authors > Design Reports > Design Section Reports > Layout

Glossary Item Box

By default, a section report is composed of three banded sections: a PageHeader, a Detail section, and a PageFooter. You can right-click the report and select Insert and choose other section pairs to add: ReportHeader and Footer, or GroupHeader and Footer.

All sections except the detail section come in pairs, above and below the detail section. You can hide any section that you are not using by setting the Visible property of the section to False.

ActiveReports defines the following section types:

Section Report Design Layout

Report Header

A report can have one report header section that prints at the beginning of the report. You generally use this section to print a report title, a summary table, a chart or any information that only needs to appear once at the report's start. This section has a NewPage property that you can use to add a new page before or after it renders.

The Report Header does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Page Header

A report can have one page header section that prints at the top of each page. Unless the page contains a report header section, the page header is the first section that prints on the page. You can use the page header to print column headers, page numbers, a page title, or any information that needs to appear at the top of each page.

Group Header

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the header section immediately before the detail section.

In Columnar Reports, you can use ColumnGroupKeepTogether, and select whether to start a NewColumn before or after a group.

You can also specify whether to print a NewPage before or after the section, and have the section print on every page until the group details complete with the RepeatStyle property. The UnderlayNext property allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.

You can group data by adding a pair of group header and group footer sections to the report. These sections appear immediately above and below the Detail section.

Controls in the group header render once for each instance of the group, so you can place the column header labels to describe the data in the detail fields here.

Caution: You cannot add a header section without a corresponding footer section. If you try to do so in code, the results are unstable.

Reorder Groups

You can reorder Group Header sections in your report by dragging groups in the Group Order dialog. To access the Group Order dialog, right-click the report and select Reorder Groups.

Group Order Dialog

You can set the properties for the GroupHeader and GroupFooter sections in their corresponding dialogs. Following is a list of properties you can set through the options in these dialogs. Each option in the GroupHeader dialog corresponds to a property in the properties panel. To access the properties directly, select the section and open the Properties panel. See the associated property names in parenthesis with each dialog option below.

GroupHeader Dialog

To access the GroupHeader dialog, right click the group header and in the Properties panel under the properties list where the commands are displayed, click the Property dialog link.

General

  • Name (Name): Indicates the name of the GroupHeader in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupHeader section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupHeader section.
  • DataField (DataField): Field or expression on which you group the data.

Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupHeader section.

Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupHeader section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupHeader section.
  • Repeat section (RepeatStyle): Dropdown list to specify whether the GroupHeader section appears with every column or page that the Detail section or associated footer appears on.
  • Keep section and its footer on a single page (GroupKeepTogether): Dropdown list to specify whether the GroupHeader section and its footer appear as a single block on the same page or not.
  • Keep section on a single page (KeepTogether): Checkbox to specify whether the GroupHeader section appears on a single page.
  • Keep section and its footer in a single column (ColumnGroupKeepTogether): Checkbox to specify whether the GroupHeader section and its footer appear as a single block in the same column.
  • Keep section underneath the following section (UnderlayNext): Checkbox to specify whether the GroupHeader section appears in the following section or not. It allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.
  • Use column layout (ColumnLayout): Checkbox to determine whether the GroupHeader section uses the same column layout as the Detail section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupHeader section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupHeader section can adjust to the total height of controls placed in it.

Detail

A report has one detail section. The detail section is the body of the report and one instance of the section is created for each record in the report. You can set the CanShrink property to True to eliminate white space after controls, and you can set up Columnar Reports using ColumnCount, ColumnDirection, ColumnSpacing and NewColumn properties.

The KeepTogether property attempts to keep the section together on a single page, and the RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

See Detail for further information on properties.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Group Footer

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the footer section immediately after the detail section.

Group Footer Dialog

To access the GroupFooter dialog, right click the group footer and in the Properties panel under the properties list where the commands are displayed, click the Property dialog link.

General

  • Name (Name): Indicates the name of the GroupFooter in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupFooter section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupFooter section.

Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupFooter section.

Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupFooter section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupFooter section.
  • Keep section on a single page (KeepTogether): Checkbox to determine whether the GroupFooter section appears on a single page.
  • Use column layout (ColumnLayout): Checkbox to specify whether the GroupFooter section uses the same column layout as the Detail section.
  • Print at the bottom of page (PrintAtBottom): Checkbox to specify whether the GroupFooter section is printed at the bottom of the page immediately before the PageFooter section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupFooter section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupFooter section can adjust to the total height of controls placed in it.

When you run the report, it renders the group header, followed by all related instances of the detail section, and then the group footer. It renders a new group header section for each instance of the grouping field.

Page Footer

A report can have one page footer section that prints at the bottom of each page. You can use the page footer to print page totals, page numbers, or any other information that needs to appear at the bottom of each page.

Report Footer

A report can have one report footer section that prints at the end of the report. Use this section to print a summary of the report, grand totals, or any information that needs to print once at the end of the report.

The Report Footer does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Note: If the report contains a Page Footer on the last page, the Report Footer appears above the Page Footer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Settings Dialog

Report Settings Dialog
Report Authors > Design Reports > Design Section Reports > Report Settings Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

With ActiveReports, you can modify facets of your report, such as the page setup, printer settings, styles, and global settings at design time, as well as at run time. To make changes at design time, access the Report Settings dialog through any of the following:

  • In the Report Explorer, right-click the Settings node and select Show or double-click the Settings node.
  • Click the gray area outside the design surface to select the report and in the Commands section at the bottom of the Properties Panel, click the Property dialog command.

The Report Settings dialog provides the following pages where you can set or modify various settings of your report.

Report Settings dialog box for Section Reports

Page Setup
Printer Settings
Styles
Global Settings

On the Page Setup page, you can make changes to the report margins (left, right, top, and bottom), specify a gutter, and select the Mirror margins option. This page also shows a preview of how each setting appears on the report page.

  • Top margin: Set the Top margin for report pages.
  • Bottom margin: Set the Bottom margin for report pages.
  • Left margin: Set the Left margin for report pages.
  • Right margin: Set the Right margin for report pages.
  • Gutter: Set Gutter to give extra space between the edge of the page and the margins. This allows reports to be bound.
  • Mirror Margins: Select this option to set same inner and outside margins for opposite pages in the report.

By setting a gutter and selecting Mirror margins, you can easily set up reports for publishing.

On the Printer Settings page, you can make changes to the printer paper size and orientation.

  • Paper Size: Select a paper size from the list of pre-defined paper sizes or choose Custom paper from the list to enable the Width and Height options for defining your own custom paper size.
  • Width: Set the width of your custom paper size.
  • Height: Set the height of your custom paper size.
  • Orientation: Select one among Default, Portrait or Landscape as your paper orientation.
  • Collate: Select whether to use collation or not.
  • Duplex: Select whether the report should be printed in Simplex, Horizontal or Vertical duplex.
  • Paper Source: Set the location of the paper source from the dropdown list.
Important: For items set to Printer Default, default printer settings are used from the printer installed on the environment where the report is being created. The paper size might also change based on the run time environment so in case the paper size of your report is fixed, please specify it beforehand.

On the Styles page, you can change the appearance of text associated with controls, either by creating a new style sheet, or by modifying and applying an existing style.

  • New: Use this button to create a new style.
  • Delete: Use this button to delete an existing style.
  • Export styles to file: Use this button to export an existing style to an external XML *.reportstyle file.
  • Import styles from file: Use this button to import styles a *.reportstyle file.
  • Font name: Set or modify the font in your new or existing style.
  • Font size: Set or modify the font size in your new or existing style.
  • Bold: Enable or disable Bold text for your new or existing style.
  • Italic: Enable or disable Italic text in your new or existing style.
  • Underline: Enable or disable Underlined text in your new or existing style.
  • Strikethrough: Enable or disable Strikethrough text in your new or existing style.
  • BackColor: Set the Backcolor to use in your new or existing style.
  • ForeColor: Set the Forecolor to use in your new or existing style.
  • Horizontal Alignment: Set the horizontal alignment to Left, Center, Right, Justify for your new or existing style.
  • Vertical Alignment: Set the vertical alignment to Top, Middle, Bottom for your new or existing style.
  • Script: Select the script to use in your new or existing style.

On the Global Settings page, you can change the design layout of your report.

  • Snap Lines: Select whether to use snap lines at design time or not.
  • Snap to Grid: Select whether the control moves from one snap line to another at design time.
  • Show Grid: Select whether to show or hide the grid at design time.
  • Grid Columns: Set the count of columns in a grid.
  • Grid Rows: Set the count of rows in a grid.
  • Dimension Lines: Set whether to use dimension lines at design time or not.
  • Grid Mode: Select whether to show gridlines as Dots or Lines.
  • Show Delete Prompt: Select this option to get a warning when you try to delete a parameter or calculated field from the Report Explorer.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 1 and maximum is 10000 pages. By default, the Preview tab displays 10 pages.
    Note: This property allows you to set number of pages to display in the Preview tab only. To set the number of pages for viewer/export, you can use MaxPages property.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Aggregates Calculations

Aggregates Calculations
Report Authors > Design Reports > Design Section Reports > Aggregates Calculations

Glossary Item Box

Section reports have a limited support for expressions and aggregates. To add an aggregation, you should specify any of these for TextBox controls in the Detail section:

Function | Description
DistinctField | Gets or sets the name of the data field used in a distinct summary function.
SummaryFunc | Determines the summary calculation function performed on the DataField value.
SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page). Possible options are None, Group, or All.
SummaryType | Determines the type of field summary. Possible options are None, GrandTotal, Sub Total, PageCount, or PageTotal.

The field expressions support simple operators like the following:

Operator | Description
expr ? expr : expr | Ternary conditional operator.
|| | Conditional OR operator.
| | Bitwise OR operator.
^ | XOR (exclusive~ OR) operator
& | Bitwise AND operator.
&& | Conditional AND operator.
== | Conditional equal operator.
!= | Conditional not equal operator.
< | Less than operator.
<= | Less than or equal to operator.
> | Greater than operator.
>= | Greater than or equal to operator.
Is | Type testing operator.
As | Type casting operator.
<< | Bitwise shift left operator.
>> | Bitwise shift right operator.
+ | Addition operator.
- | Subtraction operator.
* | Multiplication operator.
/ | Division operator.
% | Modulo operator.
~ | Bitwise complement.
. | Period operator.
! | Negation operator.
(…) and [..] | Brackets operator.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Display Page Numbers and Report Dates

Display Page Numbers and Report Dates
Report Authors > Design Reports > Design Section Reports > Display Page Numbers and Report Dates

Glossary Item Box

With the ReportInfo control available in a Section Report, you can display page numbers and report dates and times by selecting a value in the FormatString property. This property provides the following pre-defined options for page numbering and date and time formatting.

Predefined Options and their Descriptions

Numbering Format | Description
Page {PageNumber} of {PageCount} on {RunDateTime} | Display the page numbers along with Date and Time in the following format : Page 1 of 100 on 1/31/2012 2:45:50 PM
Page {PageNumber} of {PageCount} | Display the only the page numbers in the following format : Page 1 of 100
{RunDateTime:} | Display the Date and Time in the following format : 1/31/2012 2:45:50 PM
{RunDateTime: M/d} | Display the Date in the following format : 1/31
{RunDateTime: M/d/yy} | Display the Date in the following format : 1/31/12
{RunDateTime: M/d/yyyy} | Display the Date in the following format : 1/31/2012
{RunDateTime: MM/dd/yy} | Display the Date in the following format : 01/31/12
{RunDateTime: MM/dd/yyyy} | Display the Date in the following format : 01/31/2012
{RunDateTime: d-MMM} | Display the Date in the following format : 31-Jan
{RunDateTime: d-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: d-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: dd-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: dd-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: MMM-yy} | Display the Date in the following format : Jan-12
{RunDateTime: MMM-yyyy} | Display the Date in the following format : Jan-2012
{RunDateTime: MMMM-yy} | Display the Date in the following format : January-12
{RunDateTime: MMMM-yyyy} | Display the Date in the following format : January-2012
{RunDateTime: MMMM d,yyyy} | Display the Date in the following format : January 31, 2012
{RunDateTime: M/d/yy h:mm tt} | Display the Date and Time in the following format : 1/31/12 2:45 PM
{RunDateTime: M/d/yyyy h:mm tt} | Display the Date and Time in the following format : 1/31/2012 2:45 PM
{RunDateTime: M/d/yy h:mm} | Display the Date and Time in the following format : 1/31/12 2:45
{RunDateTime: M/d/yyyy h:mm} | Display the Date and Time in the following format : 1/31/2012 2:45

Page numbering can also be set to a group level using the SummaryGroup and SummaryRunning properties.

These steps assume that you have already added a Section Report to a project in Visual Studio.

Display page numbers and report dates on a report

  1. From the ActiveReports 19 Section report tab in the toolbox, drag the ReportInfo control to the desired location on the design surface.
  2. With the ReportInfo control selected in the Properties Panel, drop down the FormatString property.
  3. Select the pre-defined format that best suits your needs.
    Tip: You can customize the pre-defined formats in the Properties Panel. For example, if you change the FormatString property to Page {PageNumber} / {PageCount}, it shows the first page number as Page 1/1. For more information on creating formatting strings, see the Date, Time, and Number Formatting topic.

Display page numbers and page count at the group level

  1. From the ActiveReports 19 Section report tab in the toolbox, drag the ReportInfo control to the GroupHeader or GroupFooter section of the report and set the FormatString property as above.
  2. With the ReportInfo control still selected in the Properties Panel, drop down the SummaryGroup property and select the group for which you want to display a page count.
  3. Drop down the SummaryRunning property and select Group.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Date, Time, and Number Formatting

Date, Time, and Number Formatting
Report Authors > Design Reports > Design Section Reports > Date, Time, and Number Formatting

Glossary Item Box

In Section Reports, you can set formatting strings for date, time, currency, and other numeric values using the OutputFormat property on the TextBox control. The OutputFormat dialog also allows you to select international currency values and select from various built-in string expressions. In addition to the built-in string expressions, you may use any .NET standard formatting strings. You can find information about these strings (Numerics and Date/Time formats) on MSDN.

Note: The ReportInfo control has many preformatted options in the FormatString property for RunDateTime and Page Numbers. For more information, see ReportInfo (Section report).
Caution:
  • The format from the OutputFormat property is applied to the value set in the DataField property or the Value property. It is not applied when a string is set in the Text property.
  • OutputFormat property settings are valid only for Double or DateTime type values. In case of a String or when no data type is set, the format is automatically applied to only those values that can be converted to Double or DateTime, otherwise no format is applied.

The OutputFormat property allows four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.

For example: $#,#00.00; ($#,#00.00_); $0.00; #

Dates:

  • dddd, MMMM d, yyyy = Saturday, December 25, 2012
  • dd/MM/yyyy = 25/12/2012
  • d or dd = day in number format
  • ddd = day in short string format (for example, Sat for Saturday)
  • dddd = day in string format (for example, Saturday)
  • MM = month in number format
  • MMM = month in short string format (for example, Dec for December)
  • MMMM = month in string format (for example, December)
  • y or yy = year in two digit format (for example, 12 for 2012)
  • yyyy or yyyy = year in four digit format (for example, 2012)

Times:

  • hh:mm tt = 09:00 AM
  • HH:mm = 21:00 (twenty-four hour clock)
  • HH = hours in 24 hour clock
  • hh = hours in 12 hour clock
  • mm = minutes
  • ss = seconds
  • tt = AM or PM

Currency and numbers:

  • $0.00 = $6.25
  • $#,#00.00 = $06.25
  • 0 = digit or zero
  • # = digit or nothing
  • % = percent-multiplies the string expression by 100
Note: Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Interactivity

Interactivity
Report Authors > Design Reports > Design Section Reports > Interactivity

Glossary Item Box

ActiveReports provides Section reports with a number of interactive features like parameters, bookmarks,and hyperlinks to provide an interactive look to the reports at runtime.

Learn about how to add these interactive features when creating Section reports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Parameters

Parameters
Report Authors > Design Reports > Design Section Reports > Interactivity > Parameters

Glossary Item Box

In a Section report, you can use the Parameters collection to pass values directly into a control, or you can also use it to display a subset of data in a particular instance of the report.

There are several ways to set up parameters in a report:

  • Enter syntax like the following in your SQL query to filter the data displayed in a report:
    <%Name|Prompt|DefaultValue|Type|PromptUser|DataFormat%>
  • Add parameters through the Report Explorer.
  • Add parameters through the code behind the report, inside the ReportStart event.

Add Parameters via SQL Query

Section report allows you to add parameters to a report's Parameters collection via the SQL query. You can add build queries with parameters using following easy steps:

  1. Create a new section report or open an existing report and in the Detail section band, click the DataSource icon to view the Report Data Source dialog.
  2. Connect the report to 'Nwind.mdb' data source, an OleDB data source. See OLEDB Provider for more information.
  3. In the Query field, enter a SQL query like the one below, which contains the parameter syntax to prompt for parameter values at runtime.
    Query Copy Code
    SELECT * FROM Products
INNER JOIN (Orders INNER JOIN [Order Details] ON Orders.OrderID= [Order Details].OrderID)
ON Products.ProductID = [Order Details].ProductID
WHERE Products.SupplierID = <%SupplierID|Enter Supplier ID|7|||%>
AND OrderDate >= #<%OrderDate|Order date from|11/1/1994|D|true|yyyy/MM/dd%>#
AND Discontinued = <%Discontinued|Is this checked?|true|B||%>

    Report Data Source Dialog

    You can also add SQL query using the Visual Query Designer. To do so, click on the Query Designer button, select the Design option, and select the desired fields to create the query. To preview the query, click on the SQL option and then click Save.

    Visual Query Designer

    Note: In section reports, the Visual Query Designer is only available for the OLEDB, SQL, and Custom Data Sources.
  4. Click OK to save the data source and return to the report design surface.

    The SQL query above causes ActiveReports to display the following dialog to the user at runtime. The user can accept these or input other values to select report data.

    SQL Parameters Dialog

The values below are used while creating the parameter syntax. The values in the parameter syntax are separated by the pipe character (|).

For creating a parameter syntax, the first value (Name) is required. However, if the DefaultValue is not specified, the fields are not populated at the design time. In the syntax, you can provide only the Name value (without pipe character), or you can provide some values along with the Name value and use pipes without space for the missing values. For example, <%ProductID||||False|%>.

  • Name: A unique identifier or name assigned to the parameter that corresponds to the key property in parameters entered via code.
  • Prompt: The string that is displayed in the user prompt to let the user know what sort of value to enter (at runtime).
  • DefaultValue: The initial value assigned to the parameter that allows ActiveReports to populate the bound field list while you are designing your report, enabling you to drag fields onto the report. It also populates the user prompt so that the user can simply click the OK button to accept the default value.
  • Type: Refers to the data type of the parameter's value. By default, the value is set to 'S' (String), defines the type of data the parameter represents. It also dictates the type of control used in the user prompt. The type can be one of three values, as explained below:
    • S (string): Provides a textbox into which the user can enter the string. Depending on your data source, you may need to put apostrophes (single quotes) or quotation marks around the parameter syntax for string values.
      For example, '<%MyStringParameter%>'
      Also, if you provide a default value for a string parameter that is enclosed in apostrophes or quotation marks, ActiveReports sends the apostrophes or quotation marks along with the string to SQL.
      For example, <%MyStringParameter||"DefaultValue"|S|False%>

    • D (date): Provides a drop-down calendar picker from which the user can select a date. Depending on your data source, you may need to put number signs around the parameter syntax.
      For example, #<%MyDateParameter%>#

    • B (Boolean): Provides a checkbox that the user can select or clear. If you provide a default value of True or False, or 0 or 1 for a Boolean parameter, ActiveReports sends it to SQL in that format.
    Note: In the case of Microsoft Access Database, the default value for Boolean parameter is specified as -1(true) or 0(false).
  • PromptUser: This Boolean allows you to indicate whether to display parameters to the user at runtime. If set to True, the parameters are displayed at runtime. If you set the report's ShowParameterUI property to False, users are not prompted for any parameters, regardless of the PromptUser value set for any parameter in the report. The supported PromptUser values are: True and False.
  • DisplayFormat: Choose a format for the 'Date' data type. The selected format is displayed in the preview in the Parameters pane.

Add Parameter from Report Explorer

The steps to add a parameter from Report Explorer are as follows:

  1. In the Report Explorer, right-click the Parameters node and select Add. This adds a parameter (Parameter1) as a child to the Parameters node.
    Add Parameter in Report Explorer
  2. Select the added parameter to open the Properties Panel and set values in the following properties. The description of each of them is given in the previous section:
    • Name
    • DefaultValue
    • Prompt
    • PromptUser
    • Type
    • DisplayFormat
  3. Pass the parameter to a field on the report.

Add Parameters at Runtime

You can add, edit, and delete parameters at runtime. The following code demonstrates how to add a parameter and display its value in a Textbox control.

  1. Double-click in the gray area below the report to create an event-handling method for the ReportStart event.
  2. Add code to the handler to set parameters at runtime.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste at beginning of code view.　 Copy Code

    Imports GrapeCity.ActiveReports.SectionReportModel
    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code

    Dim myParam1 As New Parameter()
    myParam1.Key = "myParam1"
    myParam1.Type = Parameter.DataType.String

    'Set to False if you do not want input from user.
    myParam1.PromptUser = True
    myParam1.Prompt = "Enter Data:"
    myParam1.DefaultValue = "Default Value"
    Me.Parameters.Add(myParam1);

    'Set to True to display parameter dialog box when report is run.
    Me.ShowParameterUI = True

    Show To write the code in C#

    C# code. Paste at beginning of code view. Copy Code

    using GrapeCity.ActiveReports.SectionReportModel;
    C# code. Paste INSIDE the ReportStart event. Copy Code

    Parameter myParam1 = new Parameter();
    myParam1.Key = "myParam1";
    myParam1.Type = Parameter.DataType.String;

    //Set to false if you do not want input from user.
    myParam1.PromptUser = true;
    myParam1.Prompt = "Enter Data:";
    myParam1.DefaultValue = "Default Value";
    this.Parameters.Add(myParam1);

    //Set to true to display parameter dialog box when report is run.
    this.ShowParameterUI = true;
  3. In the design view, click the gray area below the report to select it and open the Properties Panel.
  4. Click the events icon in the Properties Panel to display available events for the report.
  5. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  6. Add code to the handler to pass the parameter at runtime.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the FetchData event. Copy Code
    'Set textbox text equal to the value of the parameter.
    Me.txtParam1.Text = Me.Parameters("myParam1").Value

    Show To write the code in C#

    C# code. Paste INSIDE the FetchData event. Copy Code
    //Set textbox text equal to the value of the parameter.
    this.txtParam1.Text = this.Parameters["myParam1"].Value;
    The run-time implementation above displays the following dialog. You can enter any text in this prompt dialog and display it on the report.
    Enter Report Parameters at Run Time

Prompt for Parameter Values

In order to prompt the user for parameter values, all of the following must be in place:

  • At least one parameter should exist in the Parameters collection of the report.
  • The PromptUser property for at least one parameter must be set to True.
  • On the report object, the ShowParameterUI property must be set to True.

When there are parameters in the collection and the ShowParameterUI property is set to True, the user prompt automatically displays when the report is run. When the user enters the requested values and clicks the OK button, the report gets displayed using the specified values.

Values of a parameter added through the Report Explorer can be applied to a parameter in the SQL query by specifying the param: prefix for a parameter in the SQL query. This prefix relates the current parameter to the one in the Report Explorer.

For e.g., SELECT * FROM CUSTOMERS WHERE CustomerName = '<%param:Parameter1%>'. In this case, the parameter with the param: prefix in the SQL query is updated with values of the corresponding parameter in the Report Explorer.

Note: Within the same report, you can prompt users for some parameters and not for others by setting the PromptUser property to True for some and False for others. However, if the report object's ShowParameterUI property is set to False, the user prompt does not display any parameters, regardless of its PromptUser setting.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bookmarks

Bookmarks
Report Authors > Design Reports > Design Section Reports > Interactivity > Bookmarks

Glossary Item Box

In a Section report, bookmark links take you to a location where the bookmark is set on your report. Bookmarks and nested bookmarks appear in the document map for fields, groups, and subreports. You can also add special bookmarks at run-time.

Bookmarks are supported when you preview a report in the Viewer, or export a report in HTML and PDF formats. See Document map for more information. The following sections show setting up bookmarks in some scenarios in XML-based Section reports. Note that the same scripts are equally applicable to Code-based Section reports with cautious use of casing.

Set up basic bookmarks

  1. From the toolbox, drag and drop a TextBox control onto the Detail section.
  2. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add the following script to set up bookmarks.
    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    Detail.AddBookmark(TextBox1.text)
    C# code. Paste INSIDE the Detail Format event. Copy Code
    Detail.AddBookmark(TextBox1.Text);

Set up leveled or nested bookmarks

Leveled or Nested Bookmarks in a Section Report

Bookmarks can be nested to reflect a hierarchical structure; this is sometimes called a parent-child relationship.

  1. Create a new section report and bind it to JSON data using the following connection string and JSON path. See JSON Provider for more information.
    Connection String Copy Code
    method=POST;headers={"Content-Type":"application/json"};body={ "query": "{employees{country, city, superior{firstName,lastName,title}}}" };jsondoc=https://demodata.mescius.io/northwind/graphql

    JSONPath Copy Code
    $.data.employees[*]
  2. From the Report Explorer, drag and drop country and city onto the Detail section.
  3. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  4. Add the following script to set up leveled or nested bookmarks.
    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    Detail.AddBookmark(txtcountry1.Text + "\\" + txtcity1.Text)
    C# code. Paste INSIDE the Detail Format event. Copy Code
    Detail.AddBookmark(txtcountry1.Text + "\\" + txtcity1.Text);

Nest grandchild bookmarks and use bookmarks in grouping

Nested Grandchild Bookmarks in Grouping

  1. Follow Step 1 of the previous section to create a new section report and bind the data.
  2. From the Report Explorer, drag and drop country, city, and superior.title fields onto the Detail section.
  3. Double-click in the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  4. Add the following script to set up a bookmark for each superior.title and nest superior.title bookmarks within each city, and city bookmarks in each country.
    Visual Basic.NET code. Paste INSIDE the Detail_Format event. Copy Code
    Detail.AddBookmark(txtcountry1.Text + "\\" + txtcity1.Text + "\\" + txtsuperior_title1.Text)
    C# code. Paste INSIDE the Detail_Format event. Copy Code
    Detail.AddBookmark(txtcountry1.Text + "\\" + txtcity1.Text + "\\" + txtsuperior_title1.Text);
  5. Add a Group Header section to the layout and set its DataField property to country.
  6. Double-click in the Group Header section of the report. This creates an event-handling method for the report's Group Header Format event.
  7. Add the following script to set up a bookmark for each instance of the country group.
    Visual Basic.NET code. Paste INSIDE the Group Header Format event. Copy Code
    GroupHeader1.AddBookmark(txtcountry1.Text)
    C# code. Paste INSIDE the Group Header Format event. Copy Code
    GroupHeader1.AddBookmark(txtcountry1.Text);

Add bookmarks to a predefined page

Bookmarks to a Predefined Page

To create and add special bookmarks to the bookmarks collection at run time, add the bookmarks to the report document's page collection.

Caution: Remember that the page collection does not exist until the report runs, so use this code in the ReportEnd event or in form code after the report has run.
  1. Go to the Script tab of the report designer.
  2. Select ActiveReport as Object and ReportEnd as Event. This creates an event-handling method for the ReportEnd event.
  3. Add the following script to create bookmark for the pages.
    Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
    rpt.Document.Pages(0).AddBookmark("Page1", 1)
rpt.Document.Pages(1).AddBookmark("Page2", 2)
rpt.Document.Pages(2).AddBookmark("Page3", 3)
    C# code. Paste INSIDE the ReportEnd event. Copy Code
    rpt.Document.Pages[0].AddBookmark("Page1", 1);
rpt.Document.Pages[1].AddBookmark("Page2", 2);
rpt.Document.Pages[2].AddBookmark("Page3", 3);

Combine parent report and subreport bookmarks

Combined Parent Report and Subreport Bookmarks

  1. Create a new section report and bind the data as Step 1 of another section. This will be the parent report.
  2. From the Report Explorer, drag and drop the country field onto the detail section of the parent report.
  3. Double-click the Detail section to create an event-handling method for the report's Detail Format event.
  4. Add the following script to create a bookmark for each instance of the country field in the parent report.
    Visual Basic.NET code. Paste INSIDE the Detail Format event of the main report. Copy Code
    Private _subRpt As GrapeCity.ActiveReports.SectionReport
Public Sub Detail_Format()
    SubReport1.Report = _subRpt
    Detail.AddBookmark(txtcountry1.Text)
End Sub
Public Sub ActiveReport_ReportStart()
    _subRpt = New GrapeCity.ActiveReports.SectionReport()
    _subRpt.LoadLayout(System.IO.Path.GetFullPath("..\..\..\SubReport1.rpx"))
End Sub
    C# code. Paste INSIDE the Detail Format event of the main report. Copy Code
    GrapeCity.ActiveReports.SectionReport _subRpt;
public void Detail_Format()
{
    SubReport1.Report = _subRpt;
    Detail.AddBookmark(txtcountry1.Text);
}
public void ActiveReport_ReportStart()
{
    _subRpt = new GrapeCity.ActiveReports.SectionReport();
    _subRpt.LoadLayout(System.IO.Path.GetFullPath(@"..\..\..\SubReport1.rpx"));
}
  5. Drag-drop Subreport control onto the design area. By default, the ReportName property is set to SubReport1.
  6. Create a new Section report with the name 'SubReport1', which will be a subreport to the parent report.
  7. Bind a newly created report to data as described in Step 1 of the section above.
  8. From the Report Explorer, drag and drop the city field onto the detail section of the subreport.
  9. Double-click in the Detail section to create an event-handling method for the subreport's Detail Format event.
  10. Add the following script to create a bookmark for each instance of the city field in the subreport.
    Visual Basic.NET code. Paste INSIDE the Detail Format event of the subreport. Copy Code
    Detail.AddBookmark(CType(rpt.ParentReport.Sections("Detail").Controls("txtcountry1"), TextBox).Text + "\" + txtcity1.Text)
    C# code. Paste INSIDE the Detail Format event of the subreport. Copy Code
    Detail.AddBookmark(((TextBox) (rpt.ParentReport.Sections["Detail"].Controls["txtcountry1"])).Text + "\\" + txtcity1.Text);
  11. Preview the main report and navigate to Document Map. You will see bookmarks for city from the subreport nested into bookmarks for country from the main report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Hyperlinks

Hyperlinks
Report Authors > Design Reports > Design Section Reports > Interactivity > Hyperlinks

Glossary Item Box

In Section reports, you can set the HyperLink property available with the Label, TextBox, and Picture controls that allow you to add hyperlinks that connect to a Web page. You can use the HyperLink property to open an e-mail or jump to a bookmark.

You can also use any URI scheme in the HyperLink property of the controls mentioned above. For the full list of URI schemes, see Uniform Resource Identifier (URI) Schemes.

Hyperlinks are supported when you preview a Section report and export a report in HTML, PDF, RTF, and Excel formats.

Note: We recommend that you specify the full URL address (for example, "https://developer.mescius.com") for the Hyperlink property to avoid broken links while viewing reports.

Link to a Web page

  1. Select an existing control or drag and drop a control from the Toolbox onto the design surface.
  2. In the Properties Panel, set the HyperLink property to any valid URL. For example, https://developer.mescius.com.
    Alternatively, you can set the HyperLink property in the control dialog that appears by clicking the Property dialog link under Properties.

Link to an e-mail address

  1. Select an existing control or drag and drop a control from the Toolbox onto the design surface.
  2. In the Properties Panel, set the HyperLink property to mailto: any valid e-mail address.
    Alternatively, you can set the HyperLink property in the control dialog that appears by clicking the Property dialog link under Properties.

Create a hyperlink that jumps to a bookmark

Hyperlink that jumps to a bookmark

  1. Let's first create bookmarks to predefined page. Follow the steps on Add bookmarks to a predefined page
  2. Add a report header where we will place a text box to contain the hyperlink.
  3. Drag-drop a TextBox control onto the ReportHeader section.
  4. With the Textbox control selected, click the Property dialog link to open the control's properties.
  5. On the General page, set the Text to 'Go to page 3' and the Hyperlink to 'TOC://Page3'.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Scripts

Scripts
See Also
Report Authors > Design Reports > Design Section Reports > Scripts

Glossary Item Box

In a section report, ActiveReports allows you to use VB.NET or C# script to port your custom logic to report layouts. This permits layouts saved to report XML (RPX) files to serve as standalone reports. By including scripting before you save the report layout as an RPX file, you can later load, run, and display the report directly to the viewer control without using the designer. In conjunction with report files, scripting allows you to update distributed reports without recompiling your project.

Script Editor

To access the script editor, click the Script tab from the top menu in the Standalone Designer application or below the report design surface in Visual Studio Integrated Designer. The script tab contains two drop-downs (Object and Event).

  • Object: Drop down the list and select one of the report sections, or the report itself.
  • Event: Drop down the list and select from the list of events generated based on your selection in the Object drop down. If you select a report section as the Object, there are three events: Format, BeforePrint, and AfterPrint. If you select ActiveReport as the Object, there are seven events. See Report Events for further information.

Add script to the events in the same way that you add code to events in the code view of the report. When you select an event, the script editor generates a method stub for the event.

Using the ScriptLanguage property of the report, you can set the script language that you want to use.

Select the scripting language to use

  • In design view of the report, click in the grey area below the report to select it.
  • In the Properties window, drop down the ScriptLanguage property and select C# or VB.NET.

You can also add scripts at run time using the Script property.

Caution: Since the RPX file can be read with any text editor, use the AddCode or AddNamedItem method to add secure information such as a connection string.

Tips for Using Script

  • Keep the section report class public: If the Section Report class is private, the script cannot recognize the items in your report. The Section Report class is public by default.
  • Set the Modifiers property of any control referenced in script to Public: If the control's Modifiers property is not set to Public, the control cannot be referenced in script and an error occurs when the report is run. The Modifiers property has a default value of Private, so you must set this property in the designer.
  • Use "this" (as in C# code-behind) or "Me" (as in VB code-behind) to reference the report. Using "rpt" to reference the report is also possible but it is recommended to use the "this" and "Me" keywords.
    Note: The basic approach of using the "this/Me" and "rpt" keywords is as follows - use "this/Me" to access the properties and controls added to the sections of the report, whereas use "rpt" within the instance of the ActiveReports class only to access its public properties, public events and public methods.
  • Use Intellisense support: The script tab supports IntelliSense that helps in inserting the language elements and provides other helpful options when adding script to a report.
    Intellisense support in scripting
  • Use Run-time error handling: When run-time errors occur, a corresponding error message is displayed in the Preview tab stating the problem.
    Run-time error handling in scripting
    Note: A declared variable is not static by default. Use the static keyword to declare static variables.

Difference in script and code-behind event handler

Code-behind and the script tab require a different syntax for the event handler method definition. Use the Private modifier in code-behind and the Public modifier in the script editor.

See the following examples of the ReportStart event handler definition in Visual Basic and C#:

Script and code-behind examples in Visual Basic

The ReportStart event handler definition in the script editor:

Visual Basic.NET Copy Code
Sub ActiveReport_ReportStart End Sub

The ReportStart event handler definition in code-behind:

Visual Basic.NET Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart End Sub

Script and code-behind examples in C#

C# Copy Code
public void ActiveReport_ReportStart() { }

The ReportStart event handler definition in code-behind:

C# Copy Code
private void SectionReport1_ReportStart(object sender, EventArgs e) { }

See Also

Developers
Add Code to Layouts Using Script

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Events

Report Events
Report Authors > Design Reports > Design Section Reports > Report Events

Glossary Item Box

Section reports use events to allow you to control report behavior.

Show All Show All
Hide All Hide All

Single-Occurrence Events

The following events are all of the events that are raised only once during a Section report's processing. These events are raised at the beginning or at the end of the report processing cycle.

Show Events raised once

ReportStart

Use this event to initialize any objects or variables needed while running a report. This event is also used to set any Subreport control objects to a new instance of the report assigned to the Subreport control.

Caution: Be sure to add dynamic items to the report before this event finishes.

DataInitialize

This event is raised after ReportStart. Use it to add custom fields to the report's Fields collection. Custom fields can be added to a bound report (one that uses a Data Control to connect and retrieve records) or an unbound report (one that does not depend on a data control to get its records). In a bound report the dataset is opened and the dataset fields are added to the custom fields collection, then the DataInitialize event is raised so new custom fields can be added. The DataInitialize event can also be used to make adjustments to the DataSource or to set up database connectivity.

ReportEnd

This event is raised after the report finishes processing. Use this event to close or free any objects that you were using while running a report in unbound mode, or to display information or messages to the end user. This event can also be used to export reports.

Multiple-Occurrence Events

The following events are raised multiple times during a Section report's processing.

Show Events raised more than once

FetchData

This event is raised every time a new record is processed. The FetchData has an EOF parameter indicating whether the FetchData event should be raised. This parameter is not the same as the Recordset's EOF property and is defaulted to True. When working with bound reports (reports using a DataControl), the EOF parameter is automatically set by the report; however, when working with unbound reports this parameter needs to be controlled manually.

Use the FetchData event with unbound reports to set the values of custom fields that were added in the DataInitialize event or with bound reports to perform special functions, such as combining fields together or performing calculations. The FetchData event should not have any references to controls on the report.

If you need to use a value from a Dataset with a control in the Detail section, set a variable in the FetchData event and use the variable in the section's Format event to set the value for the control. Please note that this method of setting a variable in the FetchData event and using it to set a control's value is only supported in the Detail_Format event.

Also use the FetchData event to increment counters when working with arrays or collections.

PageStart

This event fires before a page is rendered. Use this event to initialize any variables needed for each page when running an unbound report.

PageEnd

This event is raised after each page in the report is rendered. Use this event to update any variables needed for each page when running an unbound report.

When Bound and Unbound Data Values Are Set

  1. The Fields collection is populated from the dataset that is bound to the report after the DataInitialize event is raised. (In an unbound report, the Fields collection values are not set to anything at this point.)
  2. The FetchData event is raised, giving the user a chance to modify the Fields collection.
  3. Any fields that are bound have the values transferred over.
  4. The Format event is raised.

Events that Occur for Each Instance of Each Section

In a Section report, regardless of the type or content of the various sections, there are three events for each section: Format, BeforePrint and AfterPrint.

Show Section Events

Because there are many possible report designs, the event-raising sequence is dynamic in order to accommodate individual report demands. The only guaranteed sequence is that a section's Format event is raised before the BeforePrint event, which in turn occurs before the AfterPrint event but not necessarily all together. Reports should not be designed to rely on these events being raised in immediate succession.

Important: Never reference the report's Fields collection in these section events. Only reference the Fields collection in theDataInitialize and FetchData events.

Format

ActiveReports raises this event after the data is loaded and bound to the controls contained in a section, but before the section is rendered to a page.

The Format event is the only event in which you can change the section's height. Use this section to set or change the properties of any controls or the section itself.

Also use the Format event to pass information, such as an SQL String, to a Subreport.

If the CanGrow or CanShrink property is True for the section or any control within the section, all of the growing and shrinking takes place in the Format event. Because of this, you cannot obtain information about a control or section's height in this event.

Because a section's height is unknown until the Format event finishes, it is possible for a section's Format event to be raised while the report is on a page to which the section is not rendered. For example, the Detail Format event is raised but the section is too large to fit on the page. This causes the PageFooter events and the PageEnd event to be raised on the current page, and the PageStart, any other Header events, and possibly the FetchData event to be raised before the section is rendered to the canvas on the next page.

BeforePrint

ActiveReports raises this event before the section is rendered to the page.

The growing and shrinking of the section and its controls have already taken place. Therefore, you can use this event to get an accurate height of the section and its controls. You can modify values and resize controls in the BeforePrint event, but you cannot modify the height of the section itself.

Also use this event to do page-specific formatting since the report knows which page the section will be rendered to when this event is raised. Once this event has finished, the section cannot be changed in any way because the section is rendered to the canvas immediately after this event.

Note: If a section contains the SubReport control that occupies more than one page, the SubReport gets split into smaller parts at rendering. In this case, you can use the BeforePrint event - it will fire multiple times to get the height of each part of the rendered SubReport.

AfterPrint

ActiveReports raises this event after the section is rendered to the page.

Although AfterPrint was an important event prior to ActiveReports Version 1 Service Pack 3, it is rarely used in any of the newer builds of ActiveReports. This event is still useful, however, if you want to draw on the page after text has already been rendered to it.

Event Sequence

Multi-threaded, single-pass processing enables Section reports to surpass other reports in processing and output generation speed. ActiveReports processes and renders each page as soon as the page is ready. If a page has unknown data elements or its layout is not final, it places the page in cache until the data is available.

Show Sequence of Events

Summary fields and KeepTogether constraints are two reasons why a page might not render immediately. The summary field is not complete until all the data needed for calculation is read from the data source. When a summary field such as a grand total is placed ahead of its completion level, such as in the report header, the report header and all following sections are delayed until all of the data is read.

There are eleven report events in the code behind a Section report, or seven in an ActiveReport script.

Section report events Section report events in an ActiveReports script

Because there are so many ways in which you can customize your reports, not all reports execute in the same way. However, when you run a report, this is generally what happens:

  1. ActiveReports raises the ReportStart event. The report validates any changes made to the report structure in ReportStart. In some cases, data source properties raise the DataInitialize event.
  2. Printer settings are applied. If none are specified, the local machine's default printer settings are used.
  3. If the DataInitialize event was not already raised, ActiveReports raises it and opens the data source.
  4. If the data source contains Parameters with unset values and the ShowParameterUI property is set to True, ActiveReports displays a parameters dialog to request values from the user.
  5. Closing the dialog raises the ParameterUIClosed event. If the report is a subreport that requires parameters, ActiveReports binds the subreport parameters to any fields in the parent report.
  6. ActiveReports raises the FetchData event.
  7. If there is no data, the NoData event is raised.
  8. The PageStart event raises, and then raises again after each PageEnd event until the final page.
  9. Group sections are bound and sections begin rendering on pages.
  10. ActiveReports raises Section Events to process sections in (roughly) the following order:
    • Report header
    • Page header
    • Group header
    • Detail
    • Group footer
    • Page footer
    • Report footer
  11. After each event, ActiveReports checks the Cancel flag to ensure that it should continue.
  12. Other events may raise, depending on the report logic.
  13. The PageEnd event raises after each page becomes full, and the PageStart raises if the report has not finished.
  14. Finally, ActiveReports raises the ReportEnd event.

Events that May Occur

These events occur in response to user actions, or when there is no data for a report.

Show Other Events

DataSourceChanged

This event occurs if the report's data source is changed. This is mainly useful with the end-user designer control.

NoData

This event occurs if the report's data source returns no records.

ParameterUIClosed

This event occurs when the user closes the parameter dialog.

PrintAborted

This event occurs when the user cancels a print job.

PrintProgress

This event occurs once for each page while the report document is printing.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tutorials: Report Controls in Section Reports

Tutorials: Report Controls in Section Reports
Report Authors > Design Reports > Design Section Reports > Tutorials: Report Controls in Section Reports

Glossary Item Box

This section takes you through the set of tutorials aimed at designing the Section reports in the Report Designer from scratch.

  • InputFieldCheckBox Control
  • InputFieldText Control
  • Picture Control
  • TextBox Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputFieldCheckBox Control

InputFieldCheckBox Control
See Also
Report Authors > Design Reports > Design Section Reports > Tutorials: Report Controls in Section Reports > InputFieldCheckBox Control

Glossary Item Box

We are going to create a PDF form, using the InputFieldCheckBox controls, where a user, besides entering text information, may also specify Yes (check) or No (uncheck) for such information like Sex, Employment Status, etc.

The final report will look as shown.

PDF Forms Report with InputFieldCheckBox controls

Design Report Layout

  1. Drag and drop the Label control onto the report designer and set its Text property to Renter's section. This is the form's heading.
  2. Drag and drop the Label controls below the Renter's section text; these controls will be the captions to the user's answers. Set these control's Text property to the following values:
    • Label2: Full Name
    • Label3: Address
    • Label4: City
    • Label5: State
    • Label6: Zip
    • Label7: Phone
    • Label8: Email
  3. Now drag and drop the InputFieldText controls next to the Label controls added at the previous step. These blank fields are required to be filled by the users filling the form.
  4. Drag and drop some more Label controls and set them to the following values in the Text property.
    • Label9: Sex
    • Label10: Male
    • Label11: Female
  5. Now drag and drop the InputFieldCheckBox controls next to the Labels added at the previous step. These blank fields are required to be filled as yes or no using the checkboxes.
  6. Set Required property for some fields that you want to make mandatory before submitting the form.
  7. Improve the appearance of the controls and preview the report.
  8. Export the report to PDF format. Users can now enter the text in the blank fields and also enter their choices as Yes (check) or No (uncheck) in the editable checkboxes.

See Also

InputFieldCheckBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


InputFieldText Control

InputFieldText Control
See Also
Report Authors > Design Reports > Design Section Reports > Tutorials: Report Controls in Section Reports > InputFieldText Control

Glossary Item Box

We will create a PDF form, using the InputFieldText controls, where a user may enter textual renter's information like Name, Address, etc. We will use Label control to write the captions for these user inputs.

The final report will look as shown.

InputFieldText Control in Reports

Design Report Layout

  1. Drag and drop the Label control onto the report designer and set its Text property to Renter's section. This is the form's heading.
  2. Drag and drop the Label controls below the Renter's section text; these controls will be the captions to the user's answers. Set these control's Text property to the following values:
    • Label2: Full Name
    • Label3: Address
    • Label4: City
    • Label5: State
    • Label6: Zip
    • Label7: Phone
    • Label8: Email
  3. Now drag and drop the InputFieldText controls next to the Label controls added at the previous step. These blank fields are required to be filled by the users filling the form.
  4. Set Required property for some fields that you want to make mandatory before submitting the form.
  5. Improve the appearance of the controls and preview the report.
  6. Export the report to PDF format. Users can now enter the text in the blank fields.

See Also

InputFieldText

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Picture Control

Picture Control
See Also
Report Authors > Design Reports > Design Section Reports > Tutorials: Report Controls in Section Reports > Picture Control

Glossary Item Box

Let's say that we want to create a report that shows the photos of employees along with their details including name, job title, date of birth, mobile, email, and department. For such a report, we will use the Picture control along with other TextBox controls. The report connects to 'DimEmployees' JSON data available here.

The final report will look as shown.

Picture control in section report

Create a Report

In the ActiveReports Designer, create a new Section report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by clicking the Data Source Data Source Icon icon on the Detail section.
  2. In the dialog, go to the JSON tab and click Build to open the Configure JSON Data Source dialog.
  3. Enter the following URL in the Data Path as follows:
    https://demodata.mescius.io/contoso/odata/v1/DimEmployees
  4. Click OK to close the dialog.
    The Connection String displayed is as follows:
    Connection String Copy Code
    jsondoc=https://demodata.mescius.io/contoso/odata/v1/DimEmployees
    For more information, see the JSON Provider article.
  5. Click OK to save the changes and close the Report Data Source dialog.
  6. To fetch the required fields, enter the following query in the JSON Path.
    Query Copy Code
    $.value[*]

Design Report Layout

  1. Drag few Label controls to the Details section of the report, and set their Text property as follows:
    • Label1: Name
    • Label2: Title
    • Label3: Mobile
    • Label4: Email
    • Label5: Email
    • Label6: Department
  2. Drag and drop few TextBox controls next to the Labels controls, and set their DataField property as follows:
    • TextBox1: FirstName
    • TextBox2: Title
    • TextBox3: Mobile
    • TextBox4: Email
    • Department: DepartmentName
  3. Drag and drop the Picture control in the Detail section and set the below properties as:
    • DataField: AvatarUrl
    • SizeMode: Zoom
  4. In the Script tab, set the Object and Event to ActiveReports and ReportStart, respectively.
    For more information, see the Report Events article.
  5. Then, add the below script to download the images from URL. The script will look like as shown.
    Script Copy Code
    public void ActiveReport_ReportStart()
{
    rpt.ResourceLocator = new GrapeCity.ActiveReports.DefaultResourceLocator(new System.Uri("https://demodata.mescius.io"));
}
  6. To provide a report title, drag and drop a Label control onto the PageHeader section of the report and set its Text property to 'Employee List'.
    Picture control in reports
  7. Improve the appearance of the report and preview.

See Also

Picture

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TextBox Control

TextBox Control
See Also
Report Authors > Design Reports > Design Section Reports > Tutorials: Report Controls in Section Reports > TextBox Control

Glossary Item Box

Let us create a report that uses TextBox controls to display the price and total number of items in stock. The report connects to the 'Products' JSON data available here.

The final report will look as shown.

Section report using TextBox Controls

Create a Report

In the ActiveReports Designer, create a new Section report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by clicking the Data Source Data Source Icon icon on the Detail section.
  2. In the dialog, go to the JSON page and click Build to open the Configure JSON Data Source dialog.
  3. Enter the following URL in the Data Path as follows:
    https://demodata.mescius.io/northwind/odata/v1/Products
  4. Click OK to close the dialog.
    The Connection String section displays the connection string as follows:
    Connection String Copy Code
    jsondoc=https://demodata.mescius.io/northwind/odata/v1/Products
  5. Click OK to save the changes and close the Report Data Source dialog.
  6. To fetch the required fields, enter the following query in the JSON Path.
    Query Copy Code
    $.value[*]

Design Report Layout

  1. Drag the following data fields to the Detail section of the report: ProductId, UnitPrice, and UnitsInStock. All these fields are bound text boxes.
  2. To provide headings (labels) to the data displayed in the text boxes in Detail section, drag and drop three Label controls onto the Page Header section of the report and set the Text property of the text boxes to 'Product ID', 'Unit Price', and 'Units In Stock', respectively.
  3. To display the total number of products in stock, drag and drop two TextBox controls onto the Footer section of the report and set the properties as follows.
    • TextBox1: Set the Text property to Total:. This is an unbound text box.
    • TextBox2: Set the DataField property to UnitsInStock and SummaryType property to GrandTotal. This textbox will show the total number of products in stock.
  4. To provide the report's title, drag and drop another TextBox control onto the top center in the PageHeader section. Enter the text of the title into the Text property or directly inside the text box, e.g. 'Products Info'.
  5. To add the information on the report generation date, drag and drop the ReportInfo control on the upper right corner of the PageHeader section and set the FormatString property to the expression: Report Generation Date: {RunDateTime:dd/MMM/yyyy}.
    Sample Report Layout
  6. Modify the appearance of the report and preview.

See Also

TextBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Tutorials: Section Report Scenarios

Tutorials: Section Report Scenarios
Report Authors > Design Reports > Design Section Reports > Tutorials: Section Report Scenarios

Glossary Item Box

This section provides you with step-by-step instructions for creating commonly used section reports.

  • Create Top N Report
  • Create a Summary Report
  • Create Green Bar Report
  • Create Address Labels in Section Report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Top N Report

Create Top N Report
Report Authors > Design Reports > Design Section Reports > Tutorials: Section Report Scenarios > Create Top N Report

Glossary Item Box

In a Section report, in order to display only the top N number of rows or records on a report, you can manipulate the data in query, or use script depending on the data source. Let's see the working example for a report bound to an Sqlite data source. Your data will be more meaningful if you also specify the order of rows.

  1. Create a new Section report and bind the data to 'reels.db'. See Custom Data Provider topic for more information. The data source connection string will be as follows:
    Data Source Connection String Copy Code
    data source = C:\Data\reels.db

  2. In the Report Data Source dialog, paste the following SQL query in the Query field to fetch Top 10 records from the database, ordered by user rating from highest to lowest:

    Sqlite

    Query Copy Code
    SELECT * FROM Movie Order By UserRating Desc LIMIT 10

  3. Then click OK to close the dialog.
  4. In the Report Explorer, expand the Fields node, then the Bound node.
  5. Drag and drop the following fields onto the detail section and set the properties of each textbox as indicated.
    [Title]
    [YearReleased]
    [UserRating]
  6. Drag-drop a Label controls in the PageHeader section for labeling the details in the Detail section, and for the report heading.

    Top N Report Design View
  7. Preview the report. You will notice only 10 number of records displaying in your report. The following image illustrates Top N Report displaying top 10 movie records:
    Top N Report at Run Time

The following sections provide sample queries or script that must be used to obtain top N data for other data sources.

OLEDB, ODBC, SQL

Query Copy Code
SELECT Top 10 * FROM Movie

XML

Query Copy Code
//countries/country[position() <= 10]

JSON

Query Copy Code
$.Customers[:10]

CSV

Script Copy Code
int i = 1;
public bool ActiveReport_FetchData(bool eof)
{
    return i++ > 10;
}
public void ActiveReport_ReportEnd()
{
    i = 0;
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create a Summary Report

Create a Summary Report
Report Authors > Design Reports > Design Section Reports > Tutorials: Section Report Scenarios > Create a Summary Report

Glossary Item Box

In a section report, you can display totals and subtotals by modifying the summary fields of a TextBox control. Use the following steps to learn how to add totals and subtotals in a report.

Note: These steps use the Products table from the NWind database. The NWIND.db file can be downloaded from GitHub.

Create a Report

In the ActiveReports Designer, create a new Section report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by clicking the DataSource Icon in the Detail section band.
  2. Choose Custom tab > SQLite Provider in the Report Data Source dialog, and bind the report to Sqlite data using the following connection string and query.
    Connection String Copy Code
    data source=c:\data\NWIND.db
    DataSet Query Copy Code
    Select * from Products  ORDER BY CategoryID
  3. Click OK to close the Report Data Source dialog and return to the report design surface.

Design Report Layout

Calculate and display subtotals in a report
Design summary report layout

  1. Right-click the design surface and select Insert, then Group Header/Footer to add group header and group footer sections to the layout.
  2. With the GroupHeader section selected in the Properties Window, set its DataField property to CategoryID. This groups the data on the report according to the set field.
  3. From the Report Explorer, drag and drop the following fields onto the corresponding sections of the report.

    • Field Name = CategoryID
      Section = GroupHeader

    • Field Name = ProductName
      Section = Detail

    • Field Name = UnitsInStock
      Section = Detail

    • Field Name = UnitsInStock
      Section = GroupFooter

  4. With the UnitsInStock field in the GroupFooter selected, go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: Sub Total
    • SummaryRunning: Group
    • SummaryGroup: GroupHeader1
  5. Preview the report and see the Sub Total appear below each group of data similar to the following image.

Calculate and display the grand total in a report
Summary section report with totals and subtotals

These steps are a continuation of the procedure above. The report generated at the end of this procedure contains totals and subtotals.

  1. Right-click the design surface and select Insert, then Report Header/Footer to add report header and footer sections to the layout.
  2. From Report Explorer, drag and drop the UnitsInStock field onto the ReportFooter section go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: GrandTotal
    • SummaryRunning: All
  3. Preview the report and see the Grand Total appear on the last page of the report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Green Bar Report

Create Green Bar Report
Report Authors > Design Reports > Design Section Reports > Tutorials: Section Report Scenarios > Create Green Bar Report

Glossary Item Box

In a section report, green bar printouts can be created by setting alternate shades or background color in the report's detail section in the Format event. The following steps demonstrate how to create a Green Bar report in a sample report PurchaseOrder.rpx that can be can be downloaded from GitHub: ..\Samples19\DesignerPro\ReportsGallery\Reports\Section Report\.

Design Report Layout

Design green bar report layout

  1. On the design surface of the report, double-click the detail section of the report to create an event handling method for the Detail Format event.
  2. Add the following script to create alternate background colors.
    Visual Basic.NET code. Paste JUST ABOVE the Detail Format event. Copy Code
    Dim i As Integer = 0
    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    If i Mod 2 = 0 Then
    Me.detail.BackColor = System.Drawing.Color.PaleGreen
Else
    Me.detail.BackColor = System.Drawing.Color.Transparent
End If
i += 1
    C# code. Paste JUST ABOVE the Detail Format event. Copy Code
    int i = 0;
    C# code. Paste INSIDE the Detail Format event. Copy Code
    if (i % 2 == 0) {
  this.detail.BackColor = System.Drawing.Color.PaleGreen;
} else {
  this.detail.BackColor = System.Drawing.Color.Transparent;
}
i++;
  3. Preview the report and see a Green Bar report alternating between Transparent and Pale Green backgrounds.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Address Labels in Section Report

Create Address Labels in Section Report
Report Authors > Design Reports > Design Section Reports > Tutorials: Section Report Scenarios > Create Address Labels in Section Report

Glossary Item Box

You can use ActiveReports to print any label size by using the newspaper column layout.

These steps show how to create a report that repeats labels using the LayoutAction property and prints labels to a laser printer. The labels in this example are 1" x 2.5" and print 30 labels per 8½" x 11" sheet. The report connects to 'NWIND.db' data source on GitHub.

The final report will look as shown.

Address Labels Section Report at Run Time

Create a Report

In the ActiveReports Designer, create a new Section report.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by clicking the DataSource Icon in the Detail section band.
  2. Choose Custom tab > SQLite Provider in the Report Data Source dialog, and bind the report to SQLite data using the following connection string and query.
    Connection String Copy Code
    data source=c:\data\NWIND.db
    DataSet Query Copy Code
    SELECT ContactName, CompanyName, Address, City, PostalCode, Country FROM Customers
  3. Click OK to close the Report Data Source dialog and return to the report design surface.

Design Report Layout

  1. Right-click the PageHeader section and select Delete to remove the PageHeader and PageFooter sections from the report.
  2. Go to Report Explorer, right-click the Settings option and select Show to view the Report Settings.
  3. Change the margins as follows:
    • Top margin: 0.5
    • Bottom margin: 0.5
    • Left margin: 0.2
    • Right margin: 0.2
  4. From the Report Explorer, select Report and in the Properties panel, set the PrintWidth property to 8.1 (the width of the label sheet less the Left and Right margins).
  5. Click the Detail section of the report to select it and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanGrow | False
    ColumnCount | 3
    ColumnSpacing | 0.2
    ColumnDirection | AcrossDown
    Height | 1
  6. From the toolbox, drag the following fields one below the other and set the properties of each textbox as follows.

    Show txtContactName1

    Property Name | Property Value
    DataField | ContactName
    Location | 0, 0 in
    Size | 2.5, 0.2 in
    Font > Bold | True

    Show txtCompanyName1

    Property Name | Property Value
    DataField | CompanyName
    Location | 0, 0.2 in
    Size | 2.5, 0.2 in

    Show txtAddress1

    Property Name | Property Value
    DataField | Address
    Location | 0, 0.4 in
    Size | 2.5, 0.2 in

    Show txtCity1

    Property Name | Property Value
    DataField | City
    Location | 0, 0.6 in
    Size | 2.5, 0.2 in

    Show txtPostalCode1

    Property Name | Property Value
    DataField | PostalCode
    Location | 0, 0.8 in
    Size | 1.45, 0.2 in

    Show txtCountry1

    Property Name | Property Value
    DataField | Country
    Location | 1.5, 0.8 in
    Size | 1, 0.2 in
  7. Select all of the textboxes, and in the Properties Panel, set the CanGrow property to False. This prevents overlapping text, but may crop data if one of the fields contains more data than the control size allows.
    Address Labels Section Report at Design Time

If you preview the report at this point, one copy of each label appears on the page.

Add Code to Detail_Format Event to Repeat Labels

  1. Double-click in the Detail section to create a Detail_Format event.
  2. Add the following code to the event to repeat each label across all three columns.
    Example Title Copy Code
    Imports GrapeCity.ActiveReports.SectionReportModel
    Visual Basic.NET code. Paste INSIDE the Format event Copy Code
    'print each label three times
Static counter As Integer
counter = counter + 1
If counter <= 2 Then
    rpt.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or
 GrapeCity.ActiveReports.LayoutAction.PrintSection
Else
    rpt.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or
 GrapeCity.ActiveReports.LayoutAction.NextRecord Or
 GrapeCity.ActiveReports.LayoutAction.PrintSection
    counter = 0
End If
    C# code. Paste JUST ABOVE the Format event Copy Code
    using GrapeCity.ActiveReports.SectionReportModel;
int counter=0;
    C# code. Paste INSIDE the Format event Copy Code
    //print each label three times
counter = counter + 1;
if (counter <= 2)
{
    rpt.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.MoveLayout|
GrapeCity.ActiveReports.LayoutAction.PrintSection;
}
else
{
    rpt.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout|
GrapeCity.ActiveReports.LayoutAction.NextRecord|
GrapeCity.ActiveReports.LayoutAction.PrintSection;
    counter = 0;
}
  3. Improve the appearance of the report and preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


DevOps

DevOps
See Also

Glossary Item Box

While developers build applications and develop features for users, DevOps are IT specialists responsible for setting up processes, deploying applications, and maintaining the same.

In this section, you will find information about the ActiveReports processes that are not related directly to development practices, but to the application infrastructure:

  • installation,
  • configuration,
  • customization,
  • localization, and
  • deployment.

See Also

Developers
Developers

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveReports Editions

ActiveReports Editions
See Also
DevOps > ActiveReports Editions

Glossary Item Box

Available in two editions, Standard and Professional, ActiveReports delivers outstanding reporting capabilities.

Standard Edition Features

The Standard Edition provides a report designer that is fully integrated with the Visual Studio IDE, a report viewer for Windows Forms, and export filters for generating reports in various file formats. The report designer even includes a barcode control with all of the most popular barcode styles, and its own chart control.

Designer

  • Full integration with the .NET environment
  • Familiar user interfaces
  • Choice of section or a Page or an RDLX report types
    • C# and VB.NET support with code-based section reports
    • Script support with XML-based section reports
    • Expression support with page reports and RDLX reports
  • The ability to compile reports into the application for speed and security or to keep them separate for ease of updating
  • Designer hosting of .NET and user controls

Report Controls

Section Reports Page Reports/RDLX Reports
  • ReportInfo
  • Label
  • Line
  • PageBreak
  • OleObject
  • SubReport
  • Shape
  • Picture
  • RichTextBox with HTML tag support
  • Chart with separate data source
  • Textbox
  • Barcode with standard styles plus RSS and UPC styles
  • Checkbox
  • CrossSectionBox extends from a header section to the related footer section
  • CrossSectionLine extends from a header section to the related footer section
  • Table data region
  • Tablix data region
  • Map data region
  • Chart data region
  • List data region
  • BandedList data region
  • Sparkline data region
  • FormattedText with mail merge capabilities and XHTML + CSS support
  • Bullet Graph
  • BarCode
  • CheckBox
  • TextBox
  • TableOfContents
  • Line
  • Container
  • Shape
  • Image
  • Subreport
  • Overflow Placeholder

Expressions (Page reports/RDLX reports)

  • Aggregates
  • Data visualization
    • Data bar
    • Icon set
    • Range bar
    • Color scale
    • Gradient
    • Hatch

Interactivity

  • Document map (table of contents)
  • Bookmark links, hyperlinks, and drill through links
  • Parameters
  • Drill-down (Page report/RDLX reports)
  • Copy, pan, and zoom
  • Jump to previous, next, first, or last group or search result

Reporting Engine

  • Managed code
  • Binding to ADO.NET, XML, iList, and custom data sources
  • Master reports, themes, and styles
  • All of the features of previous versions of ActiveReports and Data Dynamics Reports

Windows Forms Report Viewer

  • Managed C# code
  • Very small deployment assembly, suitable for use on the Internet
  • Table of contents and bookmarks
  • Thumbnail view
  • HyperLinking
  • Annotations (section reports only)
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Parameters
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting (page reports/RDLX reports)
  • Touch mode

WPF Viewer

  • Managed C# code
  • Table of contents and bookmarks
  • Thumbnail view
  • Parameters
  • Annotations
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting

WebViewer Control

  • The WebViewer control allows quick viewing of ActiveReports on the web as well as printing capability with the AcrobatReader ViewerType enumeration.

Export Filters

ActiveReports includes export filters to generate output into many popular formats.

Export formats | Section report | Page/RDLX report
Html: Export reports to HTML, DHTML, or MHT formats, all of which open in a Web browser. | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | ✓ | ✓
Rtf: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. | ✓ | ✓
Word: Export reports to DOC, a format that opens in Microsoft Word. | ✘ | ✓
Text: Export reports to TXT, plain text, a format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. | ✓ | ✓
Image: Export reports to BMP, GIF, JPEG, or PNG image format. | ✘ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. | ✓ | ✓
Excel: Export reports to formats that open in Microsoft Excel, XLS or XLSX. | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. | ✘ | ✓
CSV: Export reports to a CSV file, a form of structured data in plain text. The text in a CSV file is saved as series of values separated by comma. | ✘ | ✓
JSON: Export reports to a JSON file, a text-based data format in which the data is stored in the hierarchical form. | ✘ | ✓

Import Filters

  • Access® Reports
  • Crystal Reports
  • SSRS Reports
  • Excel file
  • RPX file

Standalone Applications

  • The Report Designer application lets you create report layout, define data, and add interactive features report, and lets you preview the reports and export or print them. It can be opened from the shortcut provided in the Start menu.
  • The Report Viewer application contains all the functionality of the ReportPreview control. It can be opened from the shortcut provided in the Start menu.
  • The WPF Viewer application contains all the functionality of the WPF Viewer control.
  • The ActiveReports Import Wizard application allows importing Microsoft Access reports, Crystal Reports, SSRS Reports, Excel files and RPX files. It can be opened from the shortcut provided in the Start menu.

Professional Edition Features

The Professional Edition includes all of the features of the Standard Edition and supports the following additional features:

End-User Report Designer

The control is a run-time designer that may be distributed royalty-free. It allows the ActiveReports designer to be hosted in an application and provides end-user report editing capabilities. The control's methods and properties provide easy access for saving and loading report layouts, monitoring and controlling the design environment, and customizing the look and feel to the needs of end users.

ASP.NET Integration

  • The Web server control provides convenience for running and exporting reports in ASP.NET.
  • HTTP Handler extensions allow report files (RPX or RDLX) or compiled assemblies containing reports to be dropped on the server and hyperlinked.

HTTP Handlers

  • The RPX and RDLX HTTPHandler allows the developer to hyperlink ActiveReports on a web page to return HTML format or PDF format reports for viewing and/or printing.
  • The Compiled Report HTTPHandler allows the developer to hyperlink ActiveReports compiled in an assembly on a web page to return HTML format or PDF format reports for viewing and/or printing.

Table of Contents Control

  • TableOfContents control is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report.
  • TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports

Map Control

  • The Map data region shows your business data against a geographical background.
  • Create different types of map, depending on the type of information you want to communicate in your report.

PdfSignature and TimeStamp Features

  • The PdfSignature class allows you to provide PDF document digital signatures and certification.
  • The PdfStamp class allows you to draw the digital signatures and certification onto the documents.
  • The TimeStamp class allows you to add a TSA (Time Stamping Authority) stamp to your digital signatures.

Font Linking

  • Font linking helps you resolve the situation when fonts on a deployment machine do not have the glyphs that were used in a development environment.
  • By linking fonts, you can resolve the problem with a different PDF output on deployment and development machines that may occur due to the missing glyphs.

Font Fallback

  • If missing glyphs are not found in linked fonts, the PDF export filter or the PDF rendering extension looks for the glyphs in fonts declared in the FontFallback property.
  • A default font is used if you do not declare one, or you can declare an empty string for this property to leave out missing glyphs from the exported file.

PDF Export

  • PDF/A and PDF/UA support.
  • IVS character support.
  • Devanagari character support.
  • PdfSignature and TimeStamp: The PdfSignature class allows you to generate PDF document digital signatures and certification. The TimeStamp class allows you to add a TSA (Time Stamping Authority) stamp to your digital signatures.
  • Section report-related PDF export in legacy GDI mode for Font Fallback and Font Linking.

Bold Font Emulation (PDF Export Filter)

  • Some fonts (for example, Franklin Gothic Medium, Microsoft Sans Serif, most East Asian fonts, etc.) may loose bold style for the PDF output. The Professional Edition provides bold style emulation in the PDF export filter to eliminate this limitation and obtain WYSIWYG output in case of font fallback.

Word Export

  • Export your reports in .docx format, a format that opens in Microsoft Word application.

Excel Data Export

  • Export only data from Tablix, Table, and Matrix data regions, preserving the data region structure and ignoring layout-related features (page break, cumulative total, etc). Other controls and data regions of the original report are ignored in this export.

WebDesigner

  • Create or modify reports by embedding WebDesigner into your web applications.

JSViewer and Blazor Viewer

  • View reports in all modern browsers using JSViewer or Blazor Viewer. Blazor Viewer uses the same client-server architecture as JS viewer.

InputField Control

  • The InputField report control provides support for editable fields in an exported PDF report where the InputField’s value can be modified.
  • Choose one of the two report control types – Text and Checkbox. Each selected type has its own set of properties.

See Also

Compare ActiveReports Editions

Developers
License Types

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Compare ActiveReports Editions

Compare ActiveReports Editions
DevOps > ActiveReports Editions > Compare ActiveReports Editions

Glossary Item Box

This page assists you in selecting the edition that satisfies your needs. The Professional features are exclusively marked; otherwise, features are available for both Standard and Professional Editions.

Visual Studio Controls

Web Forms

 WebViewer: Use this control to display your reports on the Web. Includes viewer types HTML and PDF.
ProHTTP Handlers: Enable reports to be easily deployed in both HTML and PDF.

Windows Forms

 Viewer: Use this control to offer your users report zoom and preview, multiple tabs for hyperlinks, split-page and multi-page views, a Table of Contents pane, a Thumbnails pane, text searches, and annotations.
ProDesigner: Use this control to create a royalty-free, custom designer that your end users can use to create and modify their own reports.
ReportExplorer: Use this control along with the Designer control to provide functionality to your users.
ToolBox: Use this control along with the Designer control to provide report controls for your users.
LayerList: Use this control along with the Designer control to provide Layers functionality to your users.
ReportsLibrary: Use this control to view, add, or hide report parts.

WPF

 WPF Viewer: Use this control to display your section, page and RDLX reports. The WPF Viewer offers the Thumbnails pane, the Parameters pane, the Document map pane, and the Search results pane.

Web/ Windows Forms

 HtmlExport: Export reports to HTML, DHTML, or MHT formats that open in a Web browser.
PdfExport: Export reports to PDF, a portable document format that opens in the Adobe Reader.
RtfExport: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad.
WordExport (.doc): Export reports to DOC (Word HTML), a format that opens in Microsoft Word.
ProWordExport (.docx): Export reports to DOCX (LibreOffice), a format that opens in any word processing software.
TextExport: Export reports to TXT, plain text, a format that opens in Notepad or any text editor.
This export filter can also export reports to CSV, comma separated values, a format that you can open in Microsoft Excel.
ImageExport: Export reports to BMP, GIF, JPEG, TIFF, or PNG image format.
Note that you can only export section reports to the TIFF image type. All other image types are for page reports and RDLX reports.
XlsExport: Export reports to formats that open in Microsoft Excel, XLS or XLSX.
XmlExport: Export reports to XML, a format that opens in a Web browser or delivers data to other applications.

Components

 ProWebDesigner: Create or modify reports by embedding WebDesigner into your web applications.
ProJSViewer: View reports in all modern browsers using JSViewer.
ProBlazor Viewer: View reports in all modern browsers using Blazor Viewer.

Advanced Features in PDF Export

 ProDigital Signature: Electronic signature to validate authenticity. See Digital Signature Pro topic for more information.
ProTime Stamp: Encapsulates the information necessary to include timestamps from a Time Stamping Authority (TSA) in digital signatures on PDF documents.
This feature can not be used if a report is exported into a password-protected PDF document.
ProPAdES in Digital Signature: Use the SignatureFormat setting, allowing to use PAdES (PDF Advanced Electronic Signatures).
ProEUDC: Use end user-defined characters (EUDC).
ProJapanese embedded fonts or non-embedded fonts.
Note that Japanese fonts can only be output as embedded fonts.
ProBold
Italic
Multi Language
Note that PDF Export does not handle output of multiple language fonts in a single control.
ProPDF/A and PDF/UA Support
ProIVS Character Support
Pro Character Support
ProPrint Presets: Preset print options when exporting a report to a PDF format.

Integrated Report Designer

Design Format

Section reports support banded layouts.
Page reports support fixed page layouts.
RDLX reports support continuous page layout.

Script & Code

 In section reports, you can add C# or VB code to events behind your code-based reports, or add script to events in the script editor in XML-based reports.
In page reports/RDLX reports, you can use regular expressions in any property, plus you can add VB.NET methods to the code tab, and call them in your expressions.
See Design Code-based Section Reports in .NET Core for more information.

Report File Formats

 You can save and load page reports/RDLX reports in RDLX (extended RDLX) format.
You can save and load section reports in RPX (report XML) format, and you can compile section reports in CS or VB code formats.

Report Controls

 The BarCode control supports all of the following styles:
ANSI 3 of 9 | ANSI Extended 3 of 9 | Code 2 of 5 | Interleaved 2 of 5
Code 25 Matrix | Code 39 | Extended Code 39 | Code 128 A
Code 128 B | Code 128 C | Code 128 Auto | Code 93
Extended Code 93 | MSI | PostNet | Codabar
EAN-8 | EAN-13 | UPC-A | UPC-E0
UPC-E1 | RoMail RM4SCC | UCC/EAN-128 | QRCode
Code 49 | Japanese Postal | Pdf417 | EAN-128 FNC1
RSS-14 | RSS-14 Truncated | RSS-14 Stacked | MicroPdf417
RSS-14 Stacked Omnidirectional | RSS Expanded | RSS Expanded Stacked | MicroQRCode
BC412 | Code_11 | ISBN | ISMN
ISSN | ITF14 | MaxiCode | Pharmacode
Plessey | PZN | SSCC_18 | Telepen
IntelligentMail | IntelligentMailPackage | HIBC Code 128 | HIBC Code 39
Aztec2D | GS1 |  |
Pro The InputField control provides support for editable fields in an exported PDF report where the InputField’s value can be modified.
Pro The Map control allows you to display data against a geographical background on the report.

Pro The TableofContents control allows you to display a document map in an organized hierarchy of the report heading levels and labels along with there page numbers, in the body of a report.
The Chart control supports all of the following styles:
  • Common Charts: Area, Bar2D, Bezier, Doughnut/Pie, Line, Scatter, StackedArea, StackedBar, StackedArea100Pct, and StackedBAR110Pct
  • 3D Charts: Area3D, Bar3D, ClusteredBar, Line3D, Doughnut3D/Pie, StackedBar3D, and StackedBar3D100Pct
  • XY Charts: Bubble, BubbleXY, LineXY, and PlotXY
  • Financial Charts: Candle, HiLo, and HiLoOpenClose
  • Composite Charts: For following chart types:
    • Column: Plain, Stacked, Percent Stacked
    • Area: Plain, Stacked, Percent Stacked
    • Line: Plain, Smooth
Other report controls include:
Label | TextBox | CheckBox | Picture
Line | Shape | RichText | PageBreak
SubReport | ReportInfo | CrossSectionLine | CrossSectionBox

Styles & Report Settings

 You can control page settings, printer settings, global settings such as grid display, grid size, and whether to show a verification dialog when deleting controls. You can specify row count or column count in grids, ruler units, and how many pages to display in previews.

External Style Sheets

 You can reuse report designer styles by saving and loading style information in external files.

Others

 The designer also offers snaplines, report preview, designer zoom, various formatting settings, control and text alignment settings, Z order settings, unbound fields, and parameters support.

Input and Output

Data

 Supported data includes: JSON, CSV, XML, Microsoft OLEDB, Microsoft ODBC, Microsoft SQL Client, Dataset, and Object providers, and custom data like Sqlite.

Print

 You can control the page size, orientation, and margins, as well as specifying bound (double page spread), collating, duplex printing, and paper feed trays.

Import

 You can import Crystal Reports, MS Access Reports, SSRS Reports, Excel files, and RPX files using the ActiveReports Import Wizard.

If you have purchased a Standard Edition license, Professional Edition features are disabled or marked with an evaluation banner.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Open Source Software

Open Source Software
DevOps > Open Source Software

Glossary Item Box

ActiveReports.NET leverages various open-source software components to provide robust reporting capabilities. Below is a comprehensive list of these dependencies, their respective licenses, and the areas of the product they support. This transparency reflects our commitment to adhering to open source licensing terms and fostering a collaborative development ecosystem.

Part | Dependency | License
Core | https://github.com/dotnet/roslyn | MIT
 | https://github.com/BrightBitGAMES/MartinezClipper | MIT
 | https://github.com/lovettchris/SgmlReader | MIT
 | https://github.com/micjahn/ZXing.Net | Apache-2.0
 | https://github.com/woo-j/OkapiBarcode | Apache-2.0
 | https://github.com/tupunco/ZXing-CSharp | Apache-2.0
PDF export | https://github.com/bcgit/bc-csharp | MIT
 | https://www.codeproject.com/Articles/348590/A-replacemcMemoryStream | CPOL
Excel export | https://github.com/dotnet/Open-XML-SDK | MIT
 | https://github.com/dotnetcore/NPOI | Apache-2.0
 | https://github.com/hvalidi/ColorMine | MIT
Word export | https://github.com/dotnet/Open-XML-SDK | MIT
WinForms Report Designer | https://github.com/mkoertgen/Rtf2Html | Apache-2.0
 | https://www.codeproject.com/Articles/13793/A-UITypeEditoediting-of-flag-enum-prope | CPOL
 | https://github.com/sergeyt/SharpExpress | MIT
 | https://github.com/sergeyt/korest | MIT
 | https://github.com/fgnass/spin.js | MIT
 | https://github.com/twbs/bootstrap | MIT
 | https://github.com/knockout/knockout | MIT
 | https://github.com/jquery/jquery | MIT
 | https://github.com/IronyProject/IronyArchive | MIT
Web Reporting | https://github.com/dotnet/aspnetcore | MIT
 | https://github.com/owin/museum-piece-owin-hosting | Apache-2.0
 | https://github.com/aspnet/AspNetKatana | Apache-2.0
 | https://github.com/aspnet/AspNetWebStack | Apache-2.0
 | https://github.com/bowser-js/bowser | MIT
 | https://github.com/chaijs/chai | MIT
 | https://github.com/Qix-/color | MIT
 | https://github.com/i18next/i18next | MIT
 | https://github.com/i18next/i18next-parser | MIT
 | https://github.com/i18next/i18next-browser-languageDetector | MIT
 | https://github.com/kolodny/immutability-helper | MIT
 | https://github.com/lodash/lodash | MIT
 | https://github.com/facebook/react | MIT
 | https://github.com/react-dnd/react-dnd | MIT
 | https://github.com/Pomax/react-onclickoutside | MIT
 | https://github.com/omnidan/redux-undo | MIT
 | https://github.com/reduxjs/react-redux | MIT
 | https://github.com/reduxjs/redux | MIT
 | https://github.com/redux-saga/redux-saga | MIT
 | https://github.com/davidbau/seedrandom | MIT
 | https://github.com/davidchambers/string-format | MIT
 | https://github.com/Microsoft/tslib | MIT
 | https://github.com/piotrwitek/typesafe-actions | MIT
 | https://github.com/uuidjs/uuid | MIT
 | https://github.com/slevithan/xregexp | MIT
 | https://github.com/date-fns/date-fns | MIT
 | https://github.com/JedWatson/classnames | MIT
 | https://github.com/rndme/download | MIT
Excel Data Provider | https://github.com/JamesNK/Newtonsoft.json | MIT
Installer Dependencies | https://github.com/Microsoft/vsixbootstrapper | MIT
 | https://github.com/NuGet/NuGet.Client | Apache-2.0
 | https://www.nuget.org/packages/Microsoft.VisualStudio.DpiAwareness | MICROSOFT VISUAL STUDIO 2019 ADD-ONs and EXTENSIONS
 | https://github.com/wixtoolset/wix3 | MS-RL
 | https://github.com/mysql-net/MySqlConnector | MIT
 | https://github.com/npgsql/npgsql | PostgreSQL
 | https://system.data.sqlite.org/src/doc/trunk/www/index.wiki | SQLite

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Copyright Notice

Copyright Notice
DevOps > Copyright Notice

Glossary Item Box

Information in this document, including URLs and web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced, stored in, or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photo copying, recording, or otherwise), or for any purpose, without the express written permission of MESCIUS inc.

The ActiveReports License Agreement constitutes written permission for Professional Edition licensees to copy documentation content for distribution with their end user designer applications so long as MESCIUS inc. is given credit within the distributed documentation.

ActiveReports and the ActiveReports logo are registered trademarks of MESCIUS inc.

All other trademarks are the property of their respective owners. See Open Source Software used in ActiveReports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


End User License Agreement

End User License Agreement
DevOps > End User License Agreement

Glossary Item Box

The End-User license agreement is available online at https://developer.mescius.com/legal/eula.

Please read carefully before installing this software package. Your installation of the package indicates your acceptance of the terms and conditions of this license agreement.

Contact Support if you have any questions about this license.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Install ActiveReports

Install ActiveReports
DevOps > Install ActiveReports

Glossary Item Box

You can download the installer from here and then follow these steps to install ActiveReports.

  1. Double-click the installer.
  2. In the Welcome screen that appears, click the Accept End User License Agreement checkbox and click Next.
  3. In the screen that appears, select the release version to install from the drop-down list. If you want to change the default installation path, click Change in the Installation Directory area. Also, select the corresponding checkboxes for Visual Studio Templates installation and Customer Experience Program. After you select all necessary options, click Next.
  4. Once the installation finishes, a screen notifying of the successful installation appears. Select Close to close the window and complete the installation process, or select Activate to continue with activating the license. See License ActiveReports for information on licensing.

Note: The installer version is not identical to the ActiveReports version.

ActiveReports Utilities and Entries

When you run the installer, you get necessary utilities such as standalone designer and viewer applications, import tool, license manager, VSIX files, localization resources, etc.

  • Shortcuts (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MESCIUS\ActiveReports 19):
    • MESCIUS License Manager
    • ActiveReports 19 Designer
    • ActiveReports 19 Import
    • ActiveReports 19 Theme Editor
    • ActiveReports 19 User Guide(CHM)
    • ActiveReports 19 User Guide(PDF)
    • ActiveReports 19 User Guide(Web)
    • ActiveReports 19 Viewer
  • MESCIUS License Manager (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MESCIUS)
  • Program files (C:\Program Files\MESCIUS\ActiveReports 19 OR C:\Program Files (x86)\MESCIUS\ActiveReports 19)
    • Deployment
    • Icons
    • Localization
    • NuGet
    • Tools
    • VisualStudio
    • ActiveReports.config
  • Registry keys (Computer\HKEY_CURRENT_USER\SOFTWARE\MESCIUS\ActiveReports)
  • Visual Studio integrations

About Visual Studio Integrations

The ActiveReports installation provides you with following Visual Studio Integrations that help you configure projects and design reports. Start a supported version of the Visual Studio IDE and select from the built-in project templates listed in the next section.

Project Templates

Create a report layout using built-in sample application templates:

  • ActiveReports 19 Windows Forms Application (VB and C#)
  • ActiveReports 19 ASP.NET Core Application (VB and C#)
  • ActiveReports 19 Blazor Server Application (C#)
  • ActiveReports 19 Blazor WebAssembly Application (C#)

Item Templates

Add following item templates to your project:

  • ActiveReports 19 Standalone Report
  • ActiveReports 19 Code-Based Report

Toolbox with Report Controls

A new ActiveReports 19 tab is automatically added in the toolbox with the controls in sync with the references.

Integrated Designer

ActiveReports offers an integrated designer that lets you create report layouts in Visual Studio and edit them at design time, visually, and through code and scripts. Along with the designer, you can use:

  • Report Explorer to view the report elements in tree view,
  • Group Editor to manage grouping in Tablix data region,
  • Layers List to view layers in a report,
  • Reports Library to view list of reports and controls added in the reports.

Conversion Tool

Use the conversion or upgrade tool - Convert to ActiveReports 19 - to easily upgrade to the latest version. This tool is available under the Tools menu option of Visual Studio.

The following ActiveReports resources are available on the web:

  • Samples and Web Samples
  • NPM and NuGet Packages. See Available Packages.

To Remove Visual Studio Integration

In case you want to disable or uninstall ActiveReports 19 Visual Studio integration, check Manage Visual Studio Integration article.

Customer Experience Program

When you optionally join the Product Usage Program, your computer automatically transmits information to MESCIUS inc. about the usage of MESCIUS inc. products. This information is used to address issues within MESCIUS inc. products and improve quality/usability.

The Product Usage Program is strictly optional and you can opt-in or opt-out of the program at any time by executing the Web installer and making the appropriate selection within the installation program. The Product Usage Program does not transmit any personally identifiable information such as your name, address, or phone number. The Product Usage Program only collects information related to MESCIUS inc. controls and libraries. This information includes the usage of MESCIUS inc. controls at design time within Visual Studio. No information is collected from applications/demos you create.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Available Packages

Available Packages
DevOps > Install ActiveReports > Available Packages

Glossary Item Box

The following packages are available for download.

NPM

Download the packages for viewer and designer from NPM, a JavaScript package manager .

Reference | Purpose
ActiveReports Js Viewer | Provides the report viewer based on JavaScript.
ActiveReports WebDesigner | Provides the report designer based on HTML5/JS technology stack.

NuGet

Download the following packages from NuGet, an open source package manager.

 | Reference | Purpose
Reports |  |
 | MESCIUS.ActiveReports | Page/RDLX and Section reports API.
 | MESCIUS.ActiveReports.Chart MESCIUS.ActiveReports.Chart.Win | Chart data visualization components.
 | MESCIUS.Data.DataEngine MESCIUS.Data.ExpressionInfo MESCIUS.Data.VBFunctionLib MESCIUS.ActiveReports.Core.DataProviders MESCIUS.ActiveReports.Core.Rdl MESCIUS.ActiveReports.Core.Rendering MESCIUS.ActiveReports.Core.Scripting MESCIUS.ActiveReports.Core.Drawing.Gc MESCIUS.ActiveReports.Core.Drawing.Gdi | Page/RDLX reports' internal implementation.
 | MESCIUS.ActiveReports.Core.Document MESCIUS.ActiveReports.Core.Document.Drawing.Gc MESCIUS.ActiveReports.Core.Document.Drawing.Gdi | ActiveReports RDF document implementation.
 | MESCIUS.Documents.Imaging | See Document Solutions for Imaging.
Desktop Components |  |
 | MESCIUS.ActiveReports.Design.Win | ActiveReports Windows Forms end-user Designer control.
 | MESCIUS.ActiveReports.Viewer.Win MESCIUS.ActiveReports.Viewer.Wpf MESCIUS.ActiveReports.Viewer.Common | ActiveReports Viewer controls and printing implementations.
Web |  |
 | MESCIUS.ActiveReports.Aspnet.Designer MESCIUS.ActiveReports.Aspnetcore.Designer | WebDesigner JS component and Blazor WebDesigner control server-side implementations for ASP.NET MVC 5 and ASP.NET Core.
 | MESCIUS.ActiveReports.Aspnet.Viewer MESCIUS.ActiveReports.Aspnetcore.Viewer MESCIUS.ActiveReports.Web.Viewer | Js Viewer component and Blazor viewer control server-side implementations for ASP.NET MVC 5 and ASP.NET Core.
 | MESCIUS.ActiveReports.Web MESCIUS.ActiveReports.Web.Viewer | ASP.NET WebForms control implementation.
 | MESCIUS.ActiveReports.Blazor.Viewer | Blazor Viewer control implementation.
 | MESCIUS.ActiveReports.Blazor.Designer | Blazor WebDesigner control implementation.
Exports |  |
 | MESCIUS.ActiveReports.Export.Pdf MESCIUS.ActiveReports.Core.Export.Pdf.Page MESCIUS.ActiveReports.Core.Export.Pdf.Section MESCIUS.Documents.Pdf Portable.BouncyCastle | These packages include assemblies needed to export ActiveReports reports to PDF and Document Solutions for PDF.
 | MESCIUS.ActiveReports.Export.Excel MESCIUS.ActiveReports.Core.Export.Excel.Page MESCIUS.ActiveReports.SpreadBuilder DocumentFormat.OpenXml | These packages include assemblies needed to export ActiveReports reports to Excel (Xls/Xlsx).
 | MESCIUS.ActiveReports.Export.Word MESCIUS.ActiveReports.Core.Export.Word.Page DocumentFormat.OpenXml | These packages include assemblies needed to export ActiveReports files to Word (Doc/Docx).
 | MESCIUS.ActiveReports.Export.Image MESCIUS.ActiveReports.Core.Export.Image.Page MESCIUS.ActiveReports.Core.Export.Tiff.Section | These packages include assemblies needed to export ActiveReports files to Image.
 | MESCIUS.ActiveReports.Export.Xml MESCIUS.ActiveReports.Core.Export.Text.Page | These packages include assemblies needed to export ActiveReports files to text-related formats: XML, CSV, TXT, JSON.
 | MESCIUS.ActiveReports.Export.Html MESCIUS.ActiveReports.Core.Export.Html.Page MESCIUS.ActiveReports.Core.Export.Svg.Page | These packages include assemblies needed to export ActiveReports files to HTML.
Design time |  |
 | MESCIUS.ActiveReports.Serializer MESCIUS.ActiveReportsSerializer.2022 | Code-based Section report CodeDOM serializers for Visual Studio 2019 and Visual Studio 2022.
 | MESCIUS.ActiveReports.Web.Design MESCIUS.ActiveReports.Web.Design.VS2022 | ASP.NET WebViewer control design-time support for Visual Studio 2019 and Visual Studio 2022.
Auxiliary |  |
 | MESCIUS.ActiveReports.Export.Rdf | This package includes assemblies needed to export Page/RDLX reports to RDF format.
 | MESCIUS.ActiveReports.Interop | The optional OleObject internal implementation.
 | MESCIUS.Documents.Imaging.Windows MESCIUS.Documents.DX.Windows | Additional Document Solutions for Imaging packages, required to improve export to images.
 | System.Drawing.Common | This package may require .NET desktop components and Section reports for the GDI compatibility mode. In all other situations, this package can be dropped.
Excel Data Source | MESCIUS.ActiveReports.Core.DataProviders.Excel | This package is required for using Excel Data Source.

You can install NuGet packages from a local folder or from web. For details, see Manage ActiveReports Dependencies.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Manage ActiveReports Dependencies

Manage ActiveReports Dependencies
DevOps > Install ActiveReports > Manage ActiveReports Dependencies

Glossary Item Box

The ActiveReports dependencies in Visual Studio projects can be added, updated, or removed using NuGet package manager. How the dependencies are managed depends on the location of package - at a local source or public source. The ActiveReports packages are available in the local directory on installing ActiveReports using the installer. The packages are also available publicly on the NuGet website. For the list of packages, see Available Packages.

The following sections elaborate adding the ActiveReports assemblies in your project by either installing NuGet packages from local source or directly from the NuGet website.

Installing Packages from Local Source

You must first run the installer to obtain the NuGet packages locally - C:\Program Files (x86)\MESCIUS\ActiveReports 19\NuGet. See Install ActiveReports for the steps on installation using MSI file. Then, create the NuGet package source to add the NuGet feed URL into your NuGet settings in Visual Studio, as follows:

1. Configure local NuGet package source
  1. Open NuGet.Config file placed here:
    C:\Users\[UserName]\AppData\Roaming\NuGet.
  2. Modify the content of NuGet.Config as follows. This adds a key that directs to the path where NuGet packages are available locally.
    NuGet.config Copy Code
    <?xml version="1.0" encoding="utf-8"?>
<configuration>
  <packageSources>
    <add key="NuGet.org" value="https://api.NuGet.org/v3/index.json" protocolVersion="3" />
    <add key="ActiveReports" value="C:\Program Files (x86)\MESCIUS\ActiveReports 19\NuGet" />
  </packageSources>
</configuration>
2. Install Packages
  1. Open Visual Studio.
  2. Create any application (any target that supports .NET Standard 2.0).
  3. Right-click the project in Solution Explorer and choose Manage NuGet Packages.
  4. In the Package source on top right, select ActiveReports (key added in NuGet.config).
  5. Click Browse tab on top left and search for any package, say 'MESCIUS.ActiveReports'.
  6. On the left panel, select MESCIUS.ActiveReports.
    Nuget Package Manager
  7. On the right panel, click Install.
  8. In the License Acceptance dialog, select I Accept to proceed the installation.

Installing Packages from NuGet

ActiveReports 19 references are available through NuGet and can be obtained directly from website - https://www.NuGet.org/packages?q=MESCIUS.ActiveReports. When you add reference to MESCIUS.ActiveReports package, a set of core engine assemblies are added to the application. Use following steps to find and install the NuGet packages in your application:

  1. Open Visual Studio.
  2. Create any application (any target that supports .NET Standard 2.0).
  3. Right-click the project in Solution Explorer and choose Manage NuGet Packages.
  4. In the Package source on top right, select NuGet.org.
  5. Click Browse tab on top left and search for 'MESCIUS.ActiveReports'.
  6. On the left panel, select MESCIUS.ActiveReports.
  7. On the right panel, click Install.
  8. In the License Acceptance dialog, select I Accept to proceed the installation.

For more information on NuGet configurations, please see Common NuGet configurations and NuGet Configuration Settings articles by Microsoft.

Note: The assemblies are available in the packages at the following location:

  • if installer is used: C:\Program Files (x86)\MESCIUS\ActiveReports 19\NuGet\{Package name}\lib\net472\{Assembly}
  • if a package is installed in an application: [App name]\packages\{Package name}\lib\net472\{Assembly}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Redistributable Files

Redistributable Files
See Also
DevOps > Install ActiveReports > Redistributable Files

Glossary Item Box

ActiveReports is developed and published by MESCIUS inc. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s).

All files from the NuGet and NPM packages can be redistributed according to the License Agreement.

The following Redistributable Files require the Professional Edition license for redistribution:

  • MESCIUS.ActiveReports.Design.Win.dll
  • MESCIUS.ActiveReports.Web.dll

See Also

ActiveReports Editions

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveReports Features

ActiveReports Features
See Also
DevOps > ActiveReports Features

Glossary Item Box

ActiveReports provides a number of features, enriching you with the possibilities to develop extensive and powerful applications. Most of the features require a Standard Edition license.

You should carefully choose your ActiveReports Edition - Standard or Professional. Consider all benefits of provided features from our Standard and Professional Editions before you make a decision on which one to use.

See Also

ActiveReports Components

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Types

Report Types
DevOps > ActiveReports Features > Report Types

Glossary Item Box

Choosing a Report Type

ActiveReports supports the following report types:

  • Page/RDLX reports: xml-based formats that are similar to the MS SSRS format from Microsoft.
    • RDLX report: similar to the MS SSRS format with some extensions and limitations. In general, you can use Microsoft SQL Server Reporting Services (MS SSRS) reports, but there are complicated situations that require importing. In an RDLX report, controls grow vertically to accommodate data. Controls can grow and shrink, you can set up interactive sorting, you can set up drill-down reports in which detail data is initially hidden, and can be toggled by other items, and you can add drill-through links to other reports and to bookmark links within reports.
      There are a number of common concepts that apply to Page and RDLX reports. You should remember that some features require developer's experience - work with code samples, etc, so you should visit the corresponding pages.
    • Page report: RDLX-like pages with predefined fixed layout pages but without the same growing possibilities. In a Page Layout, you design reports at the page level without any banded sections. This lets you place controls anywhere on the report.
      In a Page report, controls do not change in size based on the data, but you can use an Overflow Placeholder to handle any extra data.
  • Section reports: similar to the RDLX report type with the BandedList data region in the paginated mode.
    • Xml-based Section report (RPX): XML-based format that uses event handlers as restricted scripts.
    • Code-based Section Report (CodeDOM): the Designer is available with Visual Studio only but you can perform many report operations using event handlers.

RDLX is the default report type. If you need special fixed pages, you should choose the Page report type. We suggest using the Section report type for migration use-cases only. For XML-based RPX reports we have an import tool, which allows migrating most of the layout.

For now, each report type has some unique feature, so it is suggested to choose the report type depending on your requirements. This table will help you choose the report type.

Report Type | End-User Designer | WebDesigner | DocX Export | Linux | Custom controls | Galley layout | Primary Target: developers or end-users | Document serialization | Different page sizes in a document | Viewer interactivity
RDLX | ✓ | ✓ | ✓ | ✓ | ✓ | ✓ | end-users | ✗ | ✗ | ✓
Page | ✓ | ✓ | ✓ | ✓ | ✓ | ✗1 | end-users | ✗ | ✓ | ✓
RDLX Dashboard | ✗ | ✓ | ✗ | ✓ | ✓ | ✓ | end-users | ✗ | ✗ | ✓
XML-based Section | ✓ | ✗ | ✗ | ✓ | ✓ | ✗1 | developers | ✓2 | ✓ 3 | ✗
Code-based Section | ✗ | ✗ | ✗ | ✓ | ✓ | ✗1 | developers only | ✓2 | ✓3 | ✗
1Paginated only
2Internal RDF format
3Supported in RDF format, requires manual document merging using scripts/events

All report types support scripts (section reports require scripts in most situations) and the possibility to use functions from external assemblies (in expressions for Page/RDLX reports and in scripts/events for Section reports).

Note: Section report requires using code/scripts for most complicated scenarios. See Scripts topic.

Report File Format Types

You can create reports in a number of file formats with a varied set of features. This section describes the use of each of these file formats.

Report Template Formats

  • RDLX: This is an XML-based proprietary file format that provides custom extensions to the Report Definition Language (RDLX) files used by SQL Server Reporting Services. These are stand-alone files that you can process without compiling them into your application. You can customize the report through the Script Tab by embedding script in the report.
    See this msdn page for more on RDLX report.
  • VB or CS: These are code-based reports, and are saved as C# or Visual Basic files that are compiled into your applications. They have corresponding code views similar to Windows forms and provide a design and coding experience in line with Visual Studio. This format is ideal for developers who are comfortable with coding in .NET programming languages and would like to use the extensive event-based API provided by ActiveReports in the code-behind rather than design view. You may also use the scripts in the Script Tab instead of the code behind.
  • RPX: This is an XML-based proprietary file format that the ActiveReports engine can process without compiling it into an application. Instead of Visual Basic or C# code behind, you can customize the report with script embedded in the report XML using the Script Tab. You can also use an RPX file with script as a stand-alone file in a Web project.

Additional File Formats

ActiveReports also provides some additional file formats for reports. Each of these formats is used for a specific purpose as described below.

  • RDLX-master: This is a master report file that you can reference from other RDLX report files for a standard layout, for example, you can add company logo and address sections. This file is loaded each time the report is executed, so you can change the logo on all of your reports by just changing it on the master report.
  • RDLX-theme: This is a theme file that consists of a collection of styles that you can apply to a report. See Themes for further details.
  • RDSX: This is a proprietary format that is created when you share a data source, making it available to multiple reports.
  • RDF: This is the Report Document Format, in which the data is static. The RDF format is a vector-based image, this means that you can join some documents or render additional graphics. You can open it in any viewer or export it to any supported format (limited to Section reports). The RDF format doesn't require access to data sources and doesn't support parameters.
    You can save a report in this format to display the data that is retrieved. Once a report has been saved to an RDF file, it can be loaded into the viewer control. See Work with RDF Document for further details.

See the following list of file formats available in each layout.

Format | Page Layout/RDLX Layout | Section Layout
RDLX | ✓ | ✗
VB or CS | ✗ | ✓
RPX | ✗ | ✓
RDLX-Master | ✓ | ✗
RDLX-Theme | ✓ | ✗
RDSX | ✓ | ✗
RDF | ✗ | ✓

Features comparison between report types

In ActiveReports, the features available in a report depend on the type of report you select. See the following comparison list of features with each report type:

Feature | Section report | Page report | RDLX report
Viewers & Editors |  |  |
Visual Studio Integrated Designer | ✓ | ✓ | ✓
Expressions Editor | ✗ | ✓ | ✓
Designer Script Editor | ✓ | ✓ | ✓
Windows Form Viewer | ✓ | ✓ | ✓
WebViewer. Includes viewer types HTML, RawHTML, and PDF. | ✓ | ✓ | ✓
HTTP Handlers (Pro Edition) | ✓ | ✓ | ✓
Interactivity |  |  |
Hyperlinks | ✓ | ✓ | ✓
Parameters | ✓ | ✓ | ✓
Drill through | ✗ | ✓ | ✓
Drill down | ✓ | ✓ | ✓
Data Connections |  |  |
Standard Data Sources supported (e.g. SQL, OleDB, XML) | ✓ | ✓ | ✓
Unbound Data Source | ✓ | ✓ | ✓
Shared Data Source | ✗ | ✓ | ✓
Export |  |  |
Export Filters | ✓ | ✓ | ✓
Rendering Extensions | ✗ | ✓ | ✓
PDF advanced export features: digital signatures, time stamp, bold font emulation (Pro Edition) | ✓ | ✓ | ✓
Miscellaneous |  |  |
Master Reports | ✓ | ✗ | ✓
Themes | ✗ | ✓ | ✓
Collation | ✗ | ✓ | ✓
Styles (through Report Settings dialog) | ✓ | ✗ | ✗
Printing | ✓ | ✓ | ✓
Filtering | ✗ | ✓ | ✓
Grouping | ✓ | ✓ | ✓
Sorting | ✗ | ✓ | ✓
Standalone Applications |  |  |
ActiveReports Viewer | ✓ | ✓ | ✓
ActiveReports Theme Editor | ✗ | ✓ | ✓
ActiveReports Designer | ✓ | ✓ | ✓

For comparison of reports with respect to available report controls or data regions, see Report Controls page.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveReports Components

ActiveReports Components
See Also
DevOps > ActiveReports Features > ActiveReports Components

Glossary Item Box

ActiveReports is a tool for developers that provides possibilities to work with reports in the most productive manner.

  • Distributable items
    • Controls
      • WinForms Designer control (Professional Edition feature)
      • WinForms Viewer control
      • WPF Viewer control
      • WebDesigner JS component and backends: ASP.NET MVC 5 and ASP.NET Core (Professional Edition feature)
      • JS Viewer component, Blazor component and backends: ASP.NET MVC 5 and ASP.NET Core (Professional Edition feature)
      • ASP.NET WebViewer control
    • Exports
      • Export to Image (several formats)
      • Export to PDF (some PDF-related features are part of Professional Edition)
      • Export to Excel (XLS/XLSX). Export to Excel Data (XSLX) for Page/RDLX reports is the Professional Edition feature
      • Export to Word (DOC/DOCX for Page/RDLX and RTF for Section). The DOCX option is part of the Professional Edition.
      • Export to HTML/MHT
      • Export to XML (only for Page/RDLX reports)
      • Export to JSON (only for Page/RDLX reports)
      • Export to Text (CSV/TXT for Page/RDLX reports and TXT for Section reports)
    • Imports
      • Import from the MS SSRS RDLX format (see MS SSRS RDLX)
  • For developers only
    • ActiveReports Installer
    • License Manager
    • Visual Studio Integrated Designer
    • Standalone Designer/Viewer applications
    • Theme Editor application
    • Import Wizard and Console tools from Crystal/Access/Excel/RDLX (for details, see Report Import and Migration)
    • Import options from the RPX to RDLX formats.
    • Samples on GitHub

See Also

Developers
Plugins Development

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Designers

Designers
See Also
DevOps > ActiveReports Features > ActiveReports Components > Designers

Glossary Item Box

ActiveReports offers three designers: Standalone Designer, WebDesigner, and Visual Studio Integrated Designer. These designers provide rich report design functionality for web and desktop applications.

Standalone Designer Key Features

ActiveReports provides a compiled tool - a standalone designer application for desktop applications. This designer lets users view, edit, and create complete design-based, code-free, .NET reports in a single application.

  • Predefined templates and simple drag-and-drop operations to make report designing easy and quick, without using any code.
  • Customize the desired Report Designer using the modularized designer controls.
  • Offers deeper insight into the data with rich interactivity, including drill-down, drill-through, sorting, and more.
  • Flexible API for advanced control and customization.

WebDesigner Key Features

ActiveReports WebDesigner is based on HTML5/JS technology stacks available for the ASP.NET MVC and ASP.NET Core MVC, allowing users to create ad hoc reports in all major browsers.

  • Easily create new reports with built-in drag-and-drop functionality, snap lines, guides, and wizards.
  • Provide deeper insight into your data with rich interactivity, including drill-down, drill-through, sorting, and more.
  • Easy to use with an Office-inspired UI designed for a familiar look and feel.
  • Rich API to enable UI customization based on the desired functionality.
  • Create ad-hoc reports in the desired browser.

Visual Studio Integrated Designer Key Features

ActiveReports offers an integrated designer that lets users create report layouts in Visual Studio and edit them at design time, visually, and through code, script, or regular expressions.

  • The Visual Studio-based designer includes full integration into the best .NET IDE.
  • Build code-based functions in the code behind.
  • Drag-and-drop controls to easily create new reports.
  • Select report controls from the built-in Toolbox.
  • Visualize the report layout as a tree view with the Report Explorer.
  • Convert existing reports with the Report Conversion Utility feature.
  • Visualize Tablix row and column groupings with the Group Editor panel.

Report Controls

ActiveReports Designers support the below controls and data regions (report items) in Page, RDLX, and Section Reports:

Section Reports Page Reports/RDLX Reports
  • ReportInfo
  • Label
  • Line
  • PageBreak
  • SubReport
  • Shape
  • Picture
  • RichTextBox with HTML tag support
  • Chart with separate data source
  • Textbox
  • Barcode with standard styles plus RSS and UPC styles
  • Checkbox
  • CrossSectionBox extends from a header section to the related footer section
  • CrossSectionLine extends from a header section to the related footer section
  • InputFieldText
  • InputFieldCheckBox
  • Table data region
  • Tablix data region
  • Map data region
  • Chart data region
  • Classic Chart
  • List data region
  • BandedList data region
  • Sparkline data region
  • FormattedText with mail merge capabilities and XHTML + CSS support
  • Bullet Graph
  • BarCode
  • CheckBox
  • TextBox
  • TableOfContents
  • Line
  • Container
  • Shape
  • Image
  • Subreport
  • Overflow Placeholder (Page Report only)
  • ContentPlaceHolder (RDLX Master Report only)
  • InputField
  • CustomReportItem

See Also

Report Authors
Report Controls
Report Types

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Viewers

Viewers
See Also
DevOps > ActiveReports Features > ActiveReports Components > Viewers

Glossary Item Box

Besides previewing reports at design time, you can also view the reports you design in the Viewers. ActiveReports Viewers support technologies such as Blazor, ASP.NET Core, ASP.NET MVC, Angular, React, HTML5/JS, WPF, and WinForms.

These lightweight Viewers allow you to easily view, print, and export reports. The viewers are highly interactive, providing users the ability to enter parameters, perform sorting and drill-down, navigate to other reports using drill-through links, add hyperlinks to external web pages, and so on.

The report viewers supported by ActiveReports for web and desktop applications are:

Desktop Viewers

  • View reports quickly by running the application with the ActiveReports Viewer controls (WPF and Winforms).
  • Support Annotations to change the colors, transparency, border, font, alignment, and other properties.
  • Advanced report printing options to specify the printer and set options like page scale, page margins, and watermarks.
  • Touch support to flexibly interact with the viewers using simple touch gestures.
  • Customizable when used as a control.

Web Viewers

  • View reports in Blazor, ASP.NET Core, ASP.NET MVC, Angular, React, HTML5/JS, and other applications.
  • Multiple View Modes to display the reports as Paginated, Continuous, or in Galley view.
  • Built-in support for client-side printing to print the reports from the browser easily.
  • Viewer API to customize the viewers and blend them into your web page.
  • Add or hide features or buttons on the viewer toolbar and sidebar, customize the parameters panel, and so on.
  • Export support to export any report type to the desired format (except the RDLX Dashboard report).

Interactive Features

ActiveReports Viewers support the below interactive features.

 | Section Reports | Page/RDLX Reports
Pan/Zoom/Copy | + | +
Bookmarks | + | +
Hyperlinks | + | +
Drill-through links | - | +
Search | + | +
Parameters | + | +
Dependant parameters | - | +
Annotations | + (Windows Forms Viewer only) | -
Sorting | - | +
Toggling | - | +
TOC | + | +
Thumbnails (WinForms/WPF) | + | +
Touch mode | + | +
Page navigation | + | +
Printing | + | +
Note: The JS Viewer component, the Blazor Viewer control, and the WebDesigner JS component require back end (available backends for ASP.NET MVC and ASP.NET Core).

See Also

Report Authors
Interactivity in Page/RDLX Reports
Interactivity in Section Reports

Report Readers
Desktop Viewers
Web Viewers

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Theme Editor

Theme Editor
DevOps > ActiveReports Features > ActiveReports Components > Theme Editor

Glossary Item Box

The Theme Editor is an application that you can use to create a new theme by setting colors, fonts, images, and use constant expressions in a theme and then saving a new theme as an .rdlx-theme file on your local machine.

To access the Theme Editor

You can run the application by selecting the ActiveReports 19 Theme Editor from the Start menu, or by running the ActiveReports.ThemeEditor.exe from the C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools\ location.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Import Wizard

Import Wizard
See Also
DevOps > ActiveReports Features > ActiveReports Components > Import Wizard

Glossary Item Box

You can import a Crystal Reports report, a Microsoft Access report, an Excel file, or an ActiveReports section report in ActiveReports by running the ActiveReports Import Wizard.

You can run the ActiveReports Import Wizard from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.

For details on each import options, see Import Reports and Migration.

See Also

Report Import and Migration

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Exports

Exports
See Also
DevOps > ActiveReports Features > ActiveReports Components > Exports

Glossary Item Box

Export formats | Section report | Page/RDLX report
Html: Export reports to HTML, DHTML, or MHT formats, all of which open in a Web browser. | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | ✓ | ✓
Rtf: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. | ✓ | ✘
Word: Export reports to DOC, a format that opens in Microsoft Word. | ✘ | ✓
Text: Export reports to TXT, plain text, a format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. | ✓ | ✓
Image: Export reports to BMP, GIF, JPEG, or PNG image format. | ✘ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. | ✓ | ✓
Excel: Export reports to formats that open in Microsoft Excel, XLS or XLSX. | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. | ✘ | ✓
CSV: Export reports to a CSV file, a form of structured data in plain text. The text in a CSV file is saved as series of values separated by comma. | ✘ | ✓
JSON: Export reports to a JSON file, a text-based data format in which the data is stored in the hierarchical form. | ✘ | ✓
Note: If you don't find an export you need among the provided exports, you can write it manually. See our CustomPdfExport sample for details.

You can use the section-only exports for Page/RDLX reports too, using the MESCIUS.ActiveReports.Export.Rdf package. Although, Page/RDLX reports have a more powerful set of exports, using this package is helpful for some rare situations like:

  • An RTF output is needed (available only for Section report).
  • Manual rendering of graphic elements is required.
  • Need to save an RDF document and export it later without access to data.

See Also

Developers
Export Page/RDLX Reports
Export Section Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Import and Migration

Report Import and Migration
DevOps > ActiveReports Features > Report Import and Migration

Glossary Item Box

You can import a Crystal Reports report, a Microsoft Access report, an Excel file, or an ActiveReports section report in ActiveReports by running the ActiveReports Import Wizard.

Importing MS Access

Learn about importing MS Access reports.

Importing Crystal

Learn about importing Crystal reports.

Importing Excel

Learn about importing Excel files.

Importing RPX

Learn about importing ActiveReports section reports.

Importing MS SSRS RDLX

Learn about importing SSRS reports.

Other Migration Options

Please contact our support team to learn if we can provide more import possibilities for your requirements.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


MS Access

MS Access
DevOps > ActiveReports Features > Report Import and Migration > MS Access

Glossary Item Box

Importing MS Access Reports in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.
    ActiveReports Import Wizard screen
  3. Choose Microsoft Access (mdb or accdb) as the input format and click Next.
  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the reports to import, click Open, and then click Next to analyze them.
  6. Use the ellipsis button to select a destination folder to store the converted reports. Also select an output format (Section Report, Page report or RDLX report or Both) for each report in the Output Format column.
  7. Click Next to start the conversion.
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.

The import wizard converts reports to the closest possible ActiveReports format, but due to differences between products and versions, the extent to which your reports are converted depends on your specific report layout. You may have to partially redesign the report and add script or code to get the same output as Microsoft Access Reports.

When converting to Page Reports or RDLX Reports, whether a report is imported as a Page report or RDLX report, depends on the following factors:

  • If a report has a single detail section it is imported as a Page report.
  • If a report has a CrossTab control and its layout is composed of multiple sections it is imported as an RDLX report.
Note: Sections in a report appear as BandedList.

Please refer to the additional information below, to understand the conversion process in detail.

Importing Microsoft Access Reports

To import Microsoft® Access® reports in ActiveReports, you must have Access 97, 2000, 2002, 2003, 2007, 2010, or 2013 installed on your system.

Microsoft Access report controls are converted in ActiveReports as follows:

Microsoft Access Report | Section Report | Page report/RDLX report | Note
Rectangle | Shape | Container | Controls placed inside the Rectangle control are also imported along with the parent control.
CheckBox | Label | Textbox | ...
Image | ... | Image | Image control is not converted while converting to a Section Report.
Label | Label | Textbox | ...
Textbox | TextBox | Textbox | ...
Line | Line | Line | ...
Page Break | PageBreak | Container | In Page Reports and RDLX Reports, the PageBreakAtEnd property is automatically set to True on importing a Page Break control.
Subform/Subreport | SubReport | Subreport | ...

Limitations in MS Access conversion

  • Any controls, functions, and text formats which are not supported by ActiveReports are not imported.
  • The shadow property of a control is not imported while converting a report.
  • In Microsoft Access reports, VBA code appears in as commented statements in script. You have to modify the code after importing.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Crystal

Crystal
DevOps > ActiveReports Features > Report Import and Migration > Crystal

Glossary Item Box

Importing Crystal reports in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.
    ActiveReports Import Wizard screen
  3. Choose Crystal Reports (rpt) as the input format and click Next.
  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the reports to import, click Open, and then click Next to analyze them.
    Select the reports to import
  6. Use the ellipsis button to select a destination folder to store the converted reports. Also select an output format (Section Report, Page report or RDLX report or Both) for each report in the Output Format column.
    Select the Output Format for each report
  7. Click Next to start the conversion.
    ActiveReports Imports Wizard screen
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.
    Click Finish to close

The import wizard converts reports to the closest possible ActiveReports format, but due to differences between products and versions, the extent to which your reports are converted depends on your specific report layout. You may have to partially redesign the report and add script or code to get the same output as Crystal Reports.

When converting to Page Reports or RDLX Reports, whether a report is imported as a Page report or RDLX report, depends on the following factors:

  • If a report has a single detail section it is imported as a Page report.
  • If a report has a CrossTab control and its layout is composed of multiple sections it is imported as an RDLX report.
Note: Sections in a report appear as BandedList.

Please refer to the additional information below, to understand the conversion process in detail.

Importing Crystal Reports

To import Crystal Reports in ActiveReports, you need to install Visual Studio and Crystal Reports for Visual Studio on your machine. The supported versions of Visual Studio and corresponding Crystal Reports are as follows:

Visual Studio version for Crystal Reports | Editions | Crystal Reports | Assembly Version
2012, 2013, 2015, 2017, 2019, 2022 | ... | SAP Crystal Reports for Visual Studio, developer version for Microsoft Visual Studio | 13.x.x.x

Crystal Report controls are converted in ActiveReports as follows:

Crystal Report | Section Report | Page report/RDLX report | Note
Box | Shape | Container | The LineWidth property and rounded boxes are not imported. If the Box control extends to multiple sections, the box is imported as line controls.
CrossTab | Empty SubReport | Empty Tablix | CrossTab control is not imported as it is.
Line | Line | Line | The size of Dot and Dash (the LineStyle property) is not the same as the original report.
Subreport | SubReport | Subreport | Set the subreport in code after conversion.
TextObject | TextBox | Textbox | Only page number, total page, page n of m in Special Fields are imported.
FieldObject | TextBox | Textbox | Only page number, total page, page n of m in Special Fields are imported.
Picture | Picture | Image | Picture object is not converted.

Limitations in Crystal Report conversion

  • Any controls, functions, and text formats which are not supported by ActiveReports are not imported.
  • The shadow property of a control is not imported while converting a report.
  • The OLE object is not imported in ActiveReports as it is treated as PictureObject in the object structure of Crystal Reports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Excel

Excel
DevOps > ActiveReports Features > Report Import and Migration > Excel

Glossary Item Box

The migration from Microsoft Excel file to ActiveReports can now be accomplished by using the ActiveReports Import Wizard. The ActiveReports Import Wizard is particularly useful when you want to convert multiple sheets of an Excel file to ActiveReports. It saves the time and effort of a developer to manually replicate the layout of each sheet of an Excel file in ActiveReports.

You can import a single sheet or multiple sheets of an Excel file to a Page or an RDLX report with just a few clicks. A single Excel sheet is imported as a report file, and the report name is the name of the sheet. An Excel file with multiple sheets is by default imported as separate report files, and the report names are the name of the corresponding sheets in the Excel file. You can also set Merge all sheets into a single report file option in the ActiveReports Import Wizard to import multiple sheets of the Excel file as different pages of the report.

  • Importing Excel files in the ActiveReports Import Wizard
  • Defining Table area in an Excel file
  • Naming Rules for defining a Table area in Excel
  • Conversion Rules for Table area in Excel
  • Supported Objects and Properties
  • Limitations
Note: The import formats that are not supported are .xls (Excel 97-2003) and .xlsm (Open XML with macro).

Importing Excel files in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.
    ActiveReports Import Wizard screen
  3. Choose Microsoft Excel (xlsx) as the input format and click Next.
  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the sheets to import, click Open, and then click Next to analyze them.
    Select the sheets to import
  6. Use the ellipsis button to select a destination folder to store the converted reports. You can set the following options:
    • Report Type: Choose from Page report or RDLX report formats to import the Excel file. Note that Page report does not support multiple data sources. You should select RDLX report type if you want to add multiple data sources to the report.
    • Merge all sheets into single report file: Choose this option to import sheets of the Excel file as separate pages of a Page report. The report name is the name of the first sheet of the Excel file.
    • Import Excel formula as text: Choose this option to import Excel formula as text. If you keep the option unchecked, the Excel formula is imported as a calculated result.
    Specify output folder and other options
  7. Click Next to start the conversion.
    ActiveReports Import Wizard screen
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.
    Click Finish to close

Defining Table area in an Excel file

Table area in Excel is the range of cells representing a Tabular data in the Excel.
If an Excel file has the table area that you want to import into ActiveReports as the Table data region, you must define the Table area first and then run the ActiveReports Import Wizard. Otherwise, defining the table area is not required.

  1. Open the Excel file and select the table area.
  2. Right-click to view the context menu.
  3. Select the Define Name option.
  4. In the New Name dialog box, define the table area and the rows based on Naming Rules. These naming rules must be followed for defining table areas in Excel.
    New Name dialog box
  5. Click OK.

Naming Rules for defining a Table area in Excel

To obtain the required table sections in ActiveReports' Table data region, you need to define the table area and its rows in the Excel file. In general, the table area is defined as ARTable#.******, where:

  • # is used to define more than one table areas. It can be any character, except symbol or character restricted by Excel. For example, ARTable, ARTable_1, or ARTableAbc.
  • ****** is the name of the row (section): Detail, TableHeader, TableFooter, GroupHeader, or GroupFooter.
    In case of multiple rows (Table Header/Footer, Detail, Group Header/Footer), you need to set "#" for each row as well (for example, GroupHeader1, GroupHeader2, etc.)

Example 1: To define a single table area

Action | Naming Rule
Define whole table area | ARTable
Define each row | ARTable.Detail ARTable.TableHeader ARTable.TableFooter ARTable.GroupHeader1 ARTable.GroupFooter1

Example 2: To define a multiple table area

Action | Naming Rule
Define whole table area | ARTable1 ARTable2
Define each row | ARTable1.Detail ARTable1.TableHeader ARTable1.TableFooter ARTable2.Detail ARTable2.TableHeader ARTable2.TableFooter

Conversion Rules for Table area in Excel

The table area of Excel is imported as a Table data region in ActiveReports based on the following conversion rules.

  • If the defined table area of Excel has three or more rows, the file data is converted to Table Header, Detail, and Table Footer as:
    Excel Table | ActiveReports Table
    Top Row | Table Header
    Bottom Row | Table Footer
    Other Rows | Detail
Note: For the Table Detail row, values for properties such as Value, Location, Size, etc. are imported from the cells of the first row.
  • If the defined table area of Excel has two rows, the file data is converted as follows.
    Excel Table | ActiveReports Table
    First Row | Table Header
    Second Row | Detail
  • If the defined table area of Excel has only one row, the file data is converted as follows.
    Excel Table | ActiveReports Table
    First Row | Detail

Supported Objects and Properties

Excel | Page/RDLX report
Item | Property | Item | Property
Page Page setting Report -
Size | PaperSize
Orientation: Portrait | PaperOrientation: Portrait
Orientation: Landscape | PaperOrientation: Landscape
Margins (Top, Bottom, Left, Right) | Margins (Top, Bottom, Left, Right)
Cell Value

TextBox

 Value
Location | Location (Left, Top)
Size | Size (Width, Height)
Alignment -
Horizontal alignment: General | TextAlign: General
Horizontal alignment: Left (Indent) | TextAlign: Left
Horizontal alignment: Center | TextAlign: Center
Horizontal alignment: Right (Indent) | TextAlign: Right
Horizontal alignment: Justify | TextAlign: Justify
Horizontal alignment: Distributed (Indent) | TextJustify: DistributeAllLines
Vertical alignment: Top | VerticalAlign: Top
Vertical alignment: Center | VerticalAlign: Middle
Vertical alignment: Bottom | VerticalAlign: Bottom
Text control: Wrap text | WrapMode: WordWrap
Text control: Shrink to fit | ShrinkToFit: True
Text direction: Left-to-Right | Direction: LTR
Text direction: Right-to-Left | Direction: RTL
Font -
Name | FontFamily
Style: Regular | FontStyle: Normal
Style: Italic | FontStyle: Italic
Style: Bold | FontWeight: Bold
Style: Bold Italic | FontWeight: Bold
Size | FontSize
Color | Color
Underline: None | TextDecoration: None
Underline: Single | TextDecoration: Single
Border -
Line style (Top, Bottom, Left, Right): xlLineStyleNone | BorderStyle: None
Line style (Top, Bottom, Left, Right): xlContinuous | BorderStyle: Solid
Line style (Top, Bottom, Left, Right): xlDot | BorderStyle: Dotted
Line style (Top, Bottom, Left, Right): xlDash | BorderStyle: Dashed
Line style (Top, Bottom, Left, Right): xlDouble | BorderStyle: Double
Line color | BorderColor
Line weight: xlThin | BorderWidth: 1pt
Line weight: xlMedium | BorderWidth: 2pt
Line weight: xlThick | BorderWidth: 3pt
Fill -
Background color | BackgroundColor
Table area

Each cell in a table area is converted to TextBox report item.

Note: Whole table area is imported in ActiveReports even if table data is filtered.
Table

Location (Left, Top)
Size (Width, Height)
FixedSize (Width, Height)
Picture Picture object is converted to Image report item. Image

Value
Source: Embedded
Sizing: FitProportional
Location (Left, Top)
Size (Width, Height)

Limitations

  • An Excel file that contains merged cells and table areas that are partially out of bounds, is not imported.
    • Merged cell - If merged cell starts within the page bounds and ends outside of them, the cell is not imported.
    • ​Table area - ​If table area starts within the page bounds and ends outside of them, the table area is not imported.
  • ActiveReports Import Wizard does not support conversion of a password protected Excel file.
  • The layout of only the first page of an Excel, as shown in the Page Break Preview option, is imported.
  • The following Excel items are not imported to ActiveReports.
    1. ​Page
      • Header/Footer
    2. Cell
      • Number format (all categories, like Number, Date, Currency, etc.)
      • Strikethrough
      • Border (diagonal)
      • Fill effect
      • Fill pattern
      • Comment
      • Hyperlink
      • Table styles
      • Conditional formatting
    3. Object
      • Table
      • Shape
      • Chart
      • Pivot Table
      • WordArt
      • ClipArt

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


MS SSRS RDLX

MS SSRS RDLX
DevOps > ActiveReports Features > Report Import and Migration > MS SSRS RDLX

Glossary Item Box

Importing SSRS Reports in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.

    ActiveReports Import Wizard screen
  3. Choose SQL Server Reporting Services (rdl) as the input format and click Next.
    Choose format to import
  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the reports to import, click Open, and then click Next to analyze them.
    Select the reports to import
  6. Use the ellipsis button to select a destination folder to store the converted reports.

    Specify RDL import options
    Select a TextBox Conversion Type for all reports in the drop-down list. The available options are as follows.

    • All - All textbox controls are converted to FormattedText.
    • None - All textbox controls are converted to TextBox, paragraph settings are lost.
    • Smart (default) - Textbox controls with more than one paragraph or TextRun is converted to FormattedText.
    Select the Use Tablix Smart Conversion option to convert an SSRS 'Tablix' to an ActiveReports 'Table' or 'List' data region, if possible. Check the Tablix Conversion limitation below.
  7. Click Next to start the conversion.
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.
    Click Finish to close

Limitations

Tablix Conversion

The ActiveReports model is different from latest SSRS model. ActiveReports does not fully support latest RDLX specification. So, even when you check the Use Tablix Smart Conversion, some properties may be ignored for the closest conversion.

Chart Conversion

The ActiveReports chart model and its implementation is different from the latest RDLX specification, so you may need to manually adjust the conversion to achieve a similar behavior.

These charts are not supported and ignored at conversion to ActiveReports.

    1. Sunburst
    2. Treemap
    3. ErrorBar
    4. Range Column
    5. Range Smooth
    6. Range Plain
    7. Gauges

Multi-Section Reports Conversion

SSRS reports with multiple sections are converted to RDLX Report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Migration between Supported Report Types

Migration between Supported Report Types
DevOps > ActiveReports Features > Report Import and Migration > Migration between Supported Report Types

Glossary Item Box

Another import option is to migrate Section reports to Page/RDLX. You can convert existing ActiveReports Section report(s) (rpx) to Page and RDLX reports using the ActiveReports Import Wizard.

Importing Section Report(s) (rpx) the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing ActiveReports.Imports.Win.exe from C:\Program Files (x86)\MESCIUS\ActiveReports 19\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.
    ActiveReports Import Wizard screen
  3. Choose ActiveReports (rpx) as the input format and click Next.
  4. Click the ellipsis button to browse to the location that contains section report(s).
  5. Select the reports to import and then click Next to analyze them.
    Select the reports to import
  6. Specify the import options.
    Specify the import options
    1. Use the ellipsis button to select a destination folder to store the converted reports. Specify the path to the output folder where the converted reports are saved.
    2. Select the output format of the reports.
      From the drop-down, select output format as Page, RDLX, or Both. If 'Both' is selected, then the converted Page and RDLX reports are added with postfixes _page and _rdl, respectively in the destination folder.
    3. Select whether to use Banded List for Page report.
      The option to select Use Banded List Mode is available if the output format of a report is Page report.
      • If you want all controls to be placed on one BandedList in the same way as in RDLX report, you should use banded list mode. In this case, the Fixed size for Page report needs to be set manually.
      • If you want to convert a Section report that has only one section (that is detail), you should not use banded list mode. With 'Use Banded List Mode' not selected (default):
        • controls are not placed on BandedList
        • sections such as Report Header/Report Footer and Page Header/Page Footer are ignored
        • all converted controls are placed on one Page and treated as they have been on one section

      The option to select Use New Chart lets you convert an existing chart to a new chart. By default, this option is selected; if unselected, the chart converts to classic chart.

  7. Click Next to start the conversion.
    ActiveReports Imports Wizard screen
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.
    Click Finish to close
Important: At conversion, any script from the script editor is ignored.

Section report controls are replaced with the RDLX or Page report controls as follows.

Section Report Control | RDLX/Page report Control
Label | TextBox
TextBox | TextBox
CheckBox | CheckBox
RichTextBox | FormattedText
Shape | Shape
Picture | Image
Line | Line
Barcode | Barcode
SubReport | SubReport
Chart | Chart (New or Classic)
ReportInfo | TextBox
CrossSectionLine | Line (in Page report when BandedList is not used)
CrossSectionBox | Container (in Page report when BandedList is not used)
PageBreak | Container in RDLX report with 'Height=0in' and 'PageBreakAtEnd=True' Not supported in Page report

Conversion rules for Section report to Page report

  • The converted report inherits these properties of Section report - Paper Size, Orientation, and the Margins.
  • If controls are placed outside the paper size (red line appears), they are not converted.
  • If the sum of height of all sections (PageHeader, Detail, etc.) in a Section report is more than its paper height, controls above or below the paper height are ignored.

Conversion rules for Section report to RDLX report

  • The entire Section report is converted to an RDLX report as the BandedList control.
  • PageHeader and PageFooter sections are automatically created at conversion. You must not remove these sections even if no content is available for them.

Conversion Limitations (both Page and RDLX)

  • The support of Chart, Subreport, and RichTextBox controls is limited to the basic functionality.
  • Unused database fields are not imported.
  • Calculated fields are converted into simple expressions.
  • PageTotal and PageCount summary functions are not supported.
  • Visual Basic functions are not supported. Expressions with function calls are imported as is.
  • Following properties of Section report, on conversion to Page/RDLX report, are not supported.
    • Culture
    • DataMember
    • ExpressionErrorMessage
    • MaxPages
    • TrayHeight
    • TrayLargeIcon
    • UserData
    • Watermark (for RDLX and Page (using banded list mode))
  • MaxLength property for RichTextBox control on conversion to Page/RDLX report is not supported.

Conversion Limitations for Classic Chart control to New Chart

  • BezierXY, Bubble, HiLo, HiLo Open Close, and LineXY chart types are not properly implemented.
  • Axis labels may be duplicated when using several Series with the same category grouping.
  • Colors may differ when set to default.
  • Marker labels may disappear when Field type doesn't match Format type and implicit type conversion is required.
  • Custom angle for labels are not supported (can be only fixed 0, 90, 270).
  • Multiple chart titles are not supported (can be only one title).
  • Stacked option for Charts is not supported.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Azure and Medium Trust

Azure and Medium Trust
See Also
DevOps > ActiveReports Features > Azure and Medium Trust

Glossary Item Box

ActiveReports supports Azure. We recommended using Page/RDLX reports or SectionReports in CrossPlatform compatibility mode.

All features of ActiveReports are available without restrictions in a Full trust environment. You can also use ActiveReports under Medium trust, but with limitations on some of the features.

Caution: Medium trust does not adequately protect your application and should not be used. For more information see MSDN link.

Note:

  • Assemblies placed in the Global Assembly Cache, or GAC (C:\WINDOWS\ASSEMBLY), have Full trust permissions, so the results on your deployment machine may differ from those on your development machine.
  • For information on licensing a class library project, see the article on Licensing Compiled Code.

Feature Limitations

  1. Export limitations:
    • RTF, Text, TIFF and Excel filters are not supported in Medium trust.
    • Digital signatures cannot be used in case of PDF rendering extension and PDF export.
    • Chart and Tablix control of Page Reports and RDLX Reports are not displayed properly in case of PDF rendering extension and PDF export.
  2. The End User Designer and Windows Form Viewer controls require Full trust.
  3. The Picture control does not support metafiles, which require Full trust.
  4. The ImageType property of the Chart control must be set to PNG.
  5. OleObject, Formatted Text and Custom controls require Full trust.
  6. Scripts requires Full trust, so if you need to use code in reports under Medium trust, use code-based reports rather than RPX format.
  7. WebViewer limitations:
    • Bullet and Sparkline controls of Page Reports and RDLX Reports are not displayed in all the Viewer types.
    • Report containing the Image control of Page Reports and RDLX Reports is not displayed properly in case of HTML type.

Recommended Development Environment for Medium Trust Tests

To set up a Medium trust environment

Open the Web.config file and paste the following code between the <system.web> and </system.web> tags.

XML code. Paste BETWEEN the system.web tags. Copy Code
<trust level="Medium"></trust>

To set up the PrintingPermission level

Most hosting providers disable the printing permissions in a partially trusted environment.

  1. Open the web_mediumtrust. config file (located in the \Windows\Microsoft.NET\Framework\v4.0.30319\Config folder).
  2. Set the PrintingPermission level to NoPrinting.
XML code. Paste BETWEEN the system.web tags. Copy Code
<IPermission class="PrintingPermission"version="1"Level="NoPrinting"/>
Note: The default set of medium trust permissions is available in the web_mediumtrust.config.default file.

See Also

Developers
Plugins Development

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configuration and Customization

Configuration and Customization
DevOps > Configuration and Customization

Glossary Item Box

ActiveReports provides a wide variety of options for configuration and customization.

This section covers the following aspects:

Configure ActiveReports using Config File

Configure PDF Font Settings for Section report in GDI

More Customization Options

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure ActiveReports using Config File

Configure ActiveReports using Config File
See Also
DevOps > Configuration and Customization > Configure ActiveReports using Config File

Glossary Item Box

The ActiveReports configuration file stores settings that are used by the reporting services and background processing. The default location of the ActiveReports configuration file (ActiveReports.config) is the installer location: C:\Program Files (x86)\MESCIUS\ActiveReports 19. Otherwise, the file may be placed beside the application or the plugin assembly.

You can control various settings from the configuration file, as described in this page.

  • print dialog settings,
  • enable classic charts,
  • disable new charts in Page/RDLX reports,
  • enable Report Library,
  • enable Matrix control (required for some legacy Page/RDLX reports),
  • enable OleObject control (required for some legacy Section reports),
  • custom report items and designers,
  • specify custom fonts,
  • map control and map tile providers,
  • custom map tile providers,
  • custom data providers (including ADO.NET),
  • control the directory for Report Parts, and
  • prevent report crashing.
Note: For now, the WebDesigner and Js Viewer components have only limited support of the configuration file. It is planned to extend this support in future versions. Please check with our support for the details. Learn configuring the viewer and designer during runtime in Configure ActiveReports Using Code page.

Control Print Dialog Settings

Set PrintDialogStyle key to the values shown below to change the default print dialog for the designer.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>

          <!-- For OS native print dialog -->
                <add key="PrintDialogStyle" value="Standard"/>

          <!-- For OS native print dialog shown in Windows XP style
                <add key="PrintDialogStyle" value="XpStyle"/>

               For Print dialog with advanced printing settings, used by default
                <add key="PrintDialogStyle" value="Advanced"/> -->
  </appSettings>
</Configuration>

Enable Classic Charts

Set EnableChartClassic key to the value 'true' to enable the classic chart in the designer.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>
    <add key="EnableChartClassic" value="true"/>
  </appSettings>
</Configuration>

See the Classic Chart topic.

Disable New Charts in Page/RDLX Reports

Set the EnableChart key to the value 'false' to disable the classic chart in the designer.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>
    <add key="EnableChart" value="false"/>
  </appSettings>
</Configuration>

See the Chart topic.

Enable Report Library

Set the ShowReportsLibrary key to the value 'true' to show the Library panel in the designer.

ActiveReports.config file Copy Code
<Configuration>
   <appSettings>
     <add key="ShowReportsLibrary" value="true"/>
   </appSettings>
 </Configuration>

Control the directory for Report Parts

Set the ReportPartsDirectory key to some folder path to specify the reports folder for the designer. This is valid only if Report Library is enabled.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>
    <add key="ReportPartsDirectory" value="path to folder"/>
  </appSettings>
</Configuration>

Enable the OleObject Control

Set the EnableOleObject key to the value 'true' to enable OLEObject control in Visual Studio Designer for Section report.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>
    <add key="EnableOleObject" value="true"/>
  </appSettings>
</Configuration>

Enable Matrix Control

Set the EnableMatrix key to the value 'true' to enable the Matrix control in the designer.

ActiveReports.config file Copy Code
<Configuration>
  <appSettings>
    <add key="EnableMatrix" value="true"/>
  </appSettings>
</Configuration>

Specify Line Breaking Algorithm

Set the LineBreakingAlgorithm key to 'Legacy' to enable legacy mode for wrapping lines when preparing text with numerical values for display. By default, 'Unicode' line breaking algorithm is used.

ActiveReports.config file Copy Code
<Configuration>
    <appSettings>
        <add key="LineBreakingAlgorithm" value="Legacy"/>
    </appSettings>
</Configuration>

Custom Report Items

Page and RDLX reports allow extending the functionality of existing controls in the ActiveReports Designer. The config file should be similar to the following.

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <ReportItems>
            <ReportItem Name="RadarChart" Type="GrapeCity.ActiveReports.Samples.Radar.RadarChart, RadarChart" />
        </ReportItems>
        <ReportItemDesigner>
            <ReportItem Name="RadarChart" Type="GrapeCity.ActiveReports.Samples.Radar.RadarDesigner, RadarDesigner" BitmapResource="GrapeCity.ActiveReports.Samples.Radar.RadarIcon.png" />
        </ReportItemDesigner>
    </Extensions>
</Configuration>

See the Custom Chart sample.

Specify Custom Fonts

In the ActiveReports.config file, you can also specify custom fonts to be used in Page, RDLX, and Section reports (in the CrossPlatform compatibility mode) as in the following example.

Note: Custom font settings have higher priority over default font settings.
ActiveReports.config file Copy Code
<Configuration>
    <Extensions>
        <FontFactory>
             <AddFolder Path="%WINDIR%/Fonts" Recurse="true" />
             <AddFolder Path="%USERPROFILE%/AppData/Local/Microsoft/Windows/Fonts" Recurse="true" />
             <Substitute Font="Arabic Transparent" To="Arial" />
             <Substitute Font="Coutier" To="Coutier New" />
             <Substitute Font="Helv" To="Arial" />
             <Substitute Font="Helvetica" To="Arial" />
             <Substitute Font="MS Sans Serif" To="Microsoft Sans Serif" />
             <Substitute Font="MS Serif" To="Times New Roman" />
             <Substitute Font="Times" To="Times New Roman" />
             <Substitute Font="Tms Rmn" To="Times New Roman" />
             <SetFallbackFont Font="Microsoft Sans Serif" />
             <SetFallbackFont Font="MS UI Gothic" />
             <SetFallbackFont Font="Arial" />
             <AddFontLink Font="Lucida Sans Unicode" List="MS UI Gothic,PMingLiU,SimSun,Gulim,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="Microsoft Sans Serif" List="MS UI Gothic,Yu Gothic UI,PMingLiU,SimSun,Gulim,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="Tahoma" List="MS UI Gothic,PMingLiU,SimSun,Gulim,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="Segoe UI" List="Tahoma,Meiryo UI,MS UI Gothic,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,PMingLiU,SimSun,Gulim,Yu Gothic UI" />
             <AddFontLink Font="Ebrima" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Gadugi" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Khmer UI" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Lao UI" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Leelawadee" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Leelawadee UI" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Nirmala UI" List="Segoe UI,Meiryo UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="MingLiU" List="Microsoft Sans Serif,SimSun,MS Mincho,BatangChe,Microsoft JhengHei UI,Microsoft YaHei UI,Yu Gothic UI,Malgun Gothic" />
             <AddFontLink Font="PMingLiU" List="Microsoft Sans Serif,SimSun,MS PMincho,Batang,Microsoft JhengHei UI,Microsoft YaHei UI,Yu Gothic UI,Malgun Gothic" />
             <AddFontLink Font="Microsoft JhengHei" List="Segoe UI,MingLiU,Microsoft YaHei,Meiryo,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Microsoft JhengHei UI" List="Segoe UI,MingLiU,Microsoft YaHei UI,Meiryo UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="SimSun" List="Microsoft Sans Serif,PMingLiU,MS PMincho,Batang,Microsoft YaHei UI,Microsoft JhengHei UI,Yu Gothic UI,Malgun Gothic" />
             <AddFontLink Font="NSimSun" List="PMingLiU,MS Mincho,BatangChe,Microsoft YaHei UI,Microsoft JhengHei UI,Yu Gothic UI,Malgun Gothic" />
             <AddFontLink Font="Microsoft YaHei" List="Segoe UI,Segoe UI,SimSun,Microsoft JhengHei,Meiryo,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Microsoft YaHei UI" List="Segoe UI,SimSun,Microsoft Jhenghei UI,Meiryo UI,Malgun Gothic,Yu Gothic UI" />
             <AddFontLink Font="Yu Gothic UI" List="Segoe UI,Microsoft JhengHei,Microsoft YaHei,Malgun Gothic" />
             <AddFontLink Font="Meiryo" List="Segoe UI,Yu Gothic UI,MS UI Gothic,Microsoft Jhenghei,Microsoft YaHei,Malgun Gothic" />
             <AddFontLink Font="Meiryo UI" List="Segoe UI,Yu Gothic UI,MS UI Gothic,Microsoft Jhenghei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="MS Gothic" List="MingLiU,SimSun,GulimChe,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="MS PGothic" List="PMingLiU,SimSun,Gulim,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="MS UI Gothic" List="Microsoft Sans Serif,PMingLiU,SimSun,Gulim,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="MS Mincho" List="MingLiU,SimSun,Batang,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="MS PMincho" List="PMingLiU,SimSun,Batang,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI,Malgun Gothic" />
             <AddFontLink Font="Batang" List="MS PMincho,PMingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="BatangChe" List="MS Mincho,MingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="Dotum" List="MS UI Gothic,PMingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="DotumChe" List="MS Gothic,MingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="Gulim" List="Microsoft Sans Serif,MS UI Gothic,PMingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="GulimChe" List="MS Gothic,MingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="Gungsuh" List="MS PMincho,PMingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="GungsuhChe" List="MS Mincho,MingLiU,SimSun,Malgun Gothic,Yu Gothic UI,Microsoft JhengHei UI,Microsoft YaHei UI" />
             <AddFontLink Font="Malgun Gothic" List="Segoe UI,Gulim,Meiryo UI,Microsoft Jhenghei UI,Microsoft YaHei UI,Yu Gothic UI" />
             <DefaultEudcFont File="EUDC.tte" />
             <AddEudcFont Font="MS UI Gothic" File="myEUDC1.tte" />
             <AddEudcFont Font="Meiryo" File="myEUDC2.tte" />
         </FontFactory>
    </Extensions>
</Configuration>

ActiveReports provides a powerful Font Resolver feature for all report types. It allows running ActiveReports on any environment without fonts (like Red Hat OpenShift) and obtain WYSIWYG output on different environments. See the topic Custom Font Resolver and the sample FontResolver for the details on the implementation.

See Configure PDF Font Settings for Section report in GDI topic for information on default and custom font settings required in PDF in the Medium trust environment.

Map Report Item and Map Tile Providers

The Map report item allows configuring built-in tile providers and extensions with custom report items. External providers in general have limited support to the resources. They require something like an external key to access without limits. ActiveReports allows configuring the following keys:

  • Bing provider requires Bing account: https://www.microsoft.com/en-us/maps
  • Google provider requires Google Developer account: https://developers.google.com/maps/get-started
  • MapQuest provider requires MapQuest Developer Network account: https://developer.mapquest.com/documentation/

See the example below.

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <MapTileProviders>
            <MapTileProvider Name="MapQuest" DisplayName="MapQuest Tiles">
                <Settings>
                    <add key="ApiKey" value="Fmjtd%7Cluur21ua2l%2C2x%3Do5-90t5h6" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
            <MapTileProvider Name="Google" DisplayName="Google Tiles">
                <Settings>
                    <add key="ApiKey" value="AIzaSyBdJ88HN7LTGkHHK5whfaVv8a5ozlx2E_k" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
            <MapTileProvider Name="Bing" DisplayName="Bing Tiles" >
                <Settings>
                    <add key="ApiKey" value="Al3SxHf0LOva-5GI5fOajO0LCuKjYKLarjWQFcdGiKfaJNRrE6SBbH9o3-HJDOX7" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
        </MapTileProviders>
    </Extensions>
</Configuration>

Custom Map Tile Providers

You can implement your own tile provider and register it in ActiveReports.

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <MapTileProviders>
            <MapTileProvider Name="MapQuest-Sample" DisplayName="MapQuest-Sample" Type="GrapeCity.ActiveReports.Samples.CustomTileProviders.MapQuestTileProvider, CustomTileProviders, Version=1.0.0.0">
                <Settings>
                    <add key="ApiKey" value="Fmjtd%7Cluur21ua2l%2C2x%3Do5-90t5h6" />
                    <add key="Timeout" value="3000" />
                </Settings>
            </MapTileProvider>
        </MapTileProviders>
    </Extensions>
</Configuration>

See the Custom Tile Provider sample.

Custom Data Providers

You can configure custom data providers by adding just a few lines in the configuration file.

SQLite Provider

The following example shows configuring SQLite data provider:

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="SQLITE" Type="System.Data.SQLite.SQLiteFactory, System.Data.SQLite" DisplayName="SQLite Provider" />
        </Data>
    </Extensions>
</Configuration>
Note: System.Data.SQLite or System.Data.SQLite.Core NuGet package must be installed to be able to use Sqlite data.

CSV Provider

If you require custom UI, use CommandTextEditorType key as shown. The following example shows configuring a custom CSV data provider:

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="CustomCSV"
             DisplayName="CSV Data Provider"
             Type="GrapeCity.ActiveReports.Samples.CustomDataProvider.CSVDataProvider.CsvDataProviderFactory,CustomDataProvider, version=0.0.0.0, Culture=neutral"
             CommandTextEditorType="GrapeCity.ActiveReports.Samples.CustomDataProviderUI.QueryEditor,CustomDataProviderUI, Version=1.0.0.0, Culture=neutral"
            />
        </Data>
    </Extensions>
</Configuration>

Custom Data Providers with ADO.NET

To bind reports to ADO.NET Providers like SQLite, Oracle, and PostgreSQL, you need to add the following lines in configuration file.

MS SQLite Provider

The following example shows configuring SQLite data provider:

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="MSSQLITE" Type="Microsoft.Data.Sqlite.SqliteFactory, Microsoft.Data.Sqlite” DisplayName="MS SQLite Provider" />
        </Data>
    </Extensions>
</Configuration>

Note: Following NuGet packages must be installed to be able to use MS SQLite data:

  • System.Data.SQLite or System.Data.SQLite.Core
    and
  • Microsoft.Data.Sqlite or Microsoft.Data.Sqlite.Core

After updating the configuration file like above, you can easily use SQLite through UI in the designer.

Note: The WebDesigner component requires some extra steps to specify the data providers on client-side. See the WebDesigner Custom Data Providers sample for details.

Oracle Provider

The following example shows configuring Oracle data provider:

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="ORACLE" Type="Oracle.ManagedDataAccess.Client.OracleClientFactory, Oracle.ManagedDataAccess" DisplayName="Oracle Provider" />
        </Data>
    </Extensions>
</Configuration>
Note: Oracle.ManagedDataAccess or Oracle.ManagedDataAccess.Core NuGet package must be installed to be able to use Oracle data.

See the Oracle Data Provider sample for details.

PostgreSQL Provider

The following example shows configuring PostgreSQL data provider:

ActiveReports.config file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="POSTGRESQL" Type="Npgsql.NpgsqlFactory, Npgsql" DisplayName="PostgreSQL Provider" />
        </Data>
    </Extensions>
</Configuration>
Note: Npgsql or Npgsql NuGet package must be installed to be able to use PostgreSQL data.

Prevent Report Crashing

You can disable the report validation in WinViewer and End User Designer, which is performed to prevent report crashing. By default, the report validation is enabled.

ActiveReports.config file Copy Code
<add key="SkipReportValidation" value="true"/>

To disable the report validation in WebViewer, the configuration file has to be specified in the settings in UseReportViewer method.

ActiveReports.config file Copy Code
app.UseReportViewer(settings =>
{
//...
settings.UseConfig("C:\\Program Files (x86)\\MESCIUS\\ActiveReports 19\\ActiveReports.config");
});

See Also

Developers
Configure ActiveReports Using Code

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure PDF Font Settings for Section report in GDI

Configure PDF Font Settings for Section report in GDI
See Also
DevOps > Configuration and Customization > Configure PDF Font Settings for Section report in GDI

Glossary Item Box

Learn about the PDF export behavior for fonts in the legacy GDI compatibility mode.

Note: The section report PDF export does not support font factory settings. Instead, you can configure fonts using APIs in DsPdf and DsImaging.

Default PDF Font Settings

Font linking helps resolve the situation when fonts on a deployment machine do not have the glyphs that are used in a development environment. When you find such a glyph mismatch, there is a possibility that the PDF output on development and deployment machines may be different.

In order to resolve this issue, the PDF export filter or the PDF rendering extension looks for the missing glyphs in the installed fonts as follows:
  • Checks the system font link settings for each font that is used in the report. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink registry key stores the information on font links.
  • If font links are not set or the needed glyphs are not found, searches for the glyphs in the fonts declared in the FontFallback Property.
  • Uses glyphs from the font links collection to replace fonts that do not have their own declared linked fonts.
  • If necessary glyphs are not found by font links or in the fonts declared in the FontFallback property, glyphs from Microsoft Sans Serif font are taken as the predefined font.

Custom PDF Font Settings

Typically, when using PDF export filters and drawing extensions in a Medium trust level environment or Azure web application, ActiveReports does not have access to the System Fonts folder due to security restrictions. Therefore, if your reports use special glyphs or non-ASCII characters that are only found in certain fonts, the PDF output may be incorrect on some machines.

The ActiveReports custom font factory allows you to embed any fonts you need in PDF in the Medium trust environment.

ActiveReports looks for the custom fonts in the order as follows:

  1. A font specified in the control.
  2. A mapped specified font in the Substitute setting.
  3. A font specified in the the AddFontLink setting (Pro Edition only).
  4. A font specified in the SetFallbackFont setting (Pro Edition only).

Notice that you need to copy the required font files (.ttc, .ttf) manually into the font folder you are accessing.

Custom Font Factory in Windows Azure

For your Azure project, you need to set the properties for all fonts in the project Fonts folder as follows:

  1. Set Copy to Output Directory to Copy always.
  2. Set BuildAction to Content.

Custom Font Configuration Settings

EUDC configuration settings

Element | Description
DefaultEUDCFont

This is the node, like the SystemDefaultEudcFont entry in the registry file, that contains the default EUDC font settings.

It specifies a default unique EUDC font for all fonts. It is an absolute path or a relative to the first one, found in the AddFolder setting. The same role as the "SystemDefaultEudcFont" entry in the registry - see https://learn.microsoft.com/en-us/windows/win32/intl/eudc.
DefaultEUDCFont File | Specifies the file name of the default EUDC file.
AddEudcFont

This is the node that associates the EUDC file and the fontname. This node can be added more than once. See https://learn.microsoft.com/en-us/windows/win32/intl/eudc.
AddEudcFont Font | Specifies the font name.
AddEudcFont File

Specifies the file name of the EUDC file to associate the above font.

FontFactory

This is the main font factory node to which you can add fonts.

Attributes

Element | Description
Mode | Setting the Mode attribute to File allows to use a file based factory, or remove the attribute for a Windows GDI factory.

Child Elements

None.

Parent Elements

Element | Description
ActiveReports.PdfExport | The assembly that contains the PdfExport namespace (PDF export, document options, and security classes).

Example

<FontFactory Mode="File">

AddFolder

Adds all TrueType fonts (.ttc, .ttf) from the specified folder.

Attributes

Element | Description
Path | Specifies the absolute path to the folder.
VirtualPath | Specifies the relative path to the folder.
Recurse | When set to True, it can read the subfolder. When set to False, it cannot read the subfolder.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

<AddFolder VirtualPath="~/Fonts" Recurse="true"/>

Substitute

Maps an alternate name of fonts to their official names.

Attributes

Element | Description
Font | Specifies the abbreviated font name (e.g. "Helv").
To | Specifies the official font name (e.g. "Helvetica").

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <Substitute Font="Helv" To="Helvetica"/>

SetFallbackFont (Professional Edition only)

In the Professional Edition, sets the font to use if a) the specified font is not installed, b) the Substitute font is not specified or not installed, or c) the font links are not set or the needed glyphs are not found in the AddFontLink setting. Substitute adds a font substitution entry. See https://learn.microsoft.com/en-us/globalization/fonts-layout/fonts and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes registry key.

Attributes

Element | Description
Font | Specifies the font name.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <SetFallbackFont Font="Arial"/>

AddFontLink (Professional Edition only)

In the Professional Edition, there is the extra support for CJK glyphs. You can add font links that allow the PdfExport to look up any glyphs missing from the specified font in the list of other fonts to check.

Attributes

Element | Description
Font

Specifies the font used in the reports.
List

Specifies the comma-separated list of fonts to be used in case of missing glyphs, specified in the Font attribute. See https://learn.microsoft.com/en-us/globalization/fonts-layout/fonts and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink registry key.

Caution: The character style of the link won't be outputted in case the alternate font file does not exist in the specified folder of the AddFolder setting.
IsDefault | When set to True, indicates to use the specified list for any fonts that do not have their own font links.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <AddFontLink Font="Tahoma" List="MS UI Gothic,SimSun,gulim,PMingLiU"/>

See Also

ActiveReports Editions

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customization Options

Customization Options
See Also
DevOps > Configuration and Customization > Customization Options

Glossary Item Box

A few customizations that can be performed by DevOps are as described.

Windows Forms Viewer

The Windows Forms control allows the Window Forms-related customization. See Windows Forms Viewer topic and the Win Viewer sample for details.

WPF Viewer

You can customize the WPF Viewer by applying themes. See WPF Viewer topic and the WPF Viewer sample for details.

JS Viewer

See the JS Viewer API to learn about the customization possibilities of the JS Viewer.

For example, you can change the viewer toolbar in several ways:

  • Add a custom toolbar item (or button)
  • Remove an existing item from the toolbar
  • Change visible toolbar items and their order

You can also change the position of the sidebar panes such as search, parameters, etc.

Windows Forms Designer

You can turn on/off almost all elements of the Report Explorer and script/preview tabs.

WebDesigner

See the WebDesigner API to learn about the customization possibilities of the Web Designer.

You can change the visibility of many designer components, such as group editor, report explorer, toolbox, tabs, buttons, and more.

See Also

Developers
WebDesigner API
Js Viewer API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Localization

Localization
See Also
DevOps > Localization

Glossary Item Box

In ActiveReports, you can localize your application's UI to the supported languages: English (default), Japanese, and simplified Chinese. You can also perform custom localization into any language you need. Web components contain JSON files with English resource strings, which should be translated and then applied to the component, with the corresponding language specified using an API. .NET application localizations require resources to be translated and then satellite assemblies to be built.

MESCIUS may, from time to time and with the agreement of users who localize components, include additional locales with future hot fixes and service packs. If you are willing to share your localized resources with other users, please inform technical support staff so that they can pass on your resource files to development.

This section elaborates following concepts:

.NET Localization

JS Components Localization

WebViewer Localization

Blazor Localization

Cultures

See Also

Report Authors
Localize RDLX Report Content

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


.NET Localization

.NET Localization
See Also
DevOps > Localization > .NET Localization

Glossary Item Box

ActiveReports uses the Hub and Spoke model for localizing resources. The hub is the main executing assembly and the spokes are the satellite DLLs that contain localized resources for the application.

For example, if you want to localize the Viewer Control, the hub is MESCIUS.ActiveReports.Viewer.Win.dll and the spoke is MESCIUS.ActiveReports.Viewer.Win.resources.dll.

In your Program Files folder, the Localization folder is in a path like ....\MESCIUS\ActiveReports 19\Localization, and contains all of the ActiveReports components that you can localize.

The Localization folder contains ActiveReports components and most have two files.

  • A .bat file that is used to set the Cultures to which you want to localize.
  • A .zip file that contains the resource files (.resx) in which you update or change the strings.

There is one application in the Localization folder: NameCompleter.exe. When you run your .bat file after updating your culture, it runs this application to create a SatelliteAssembly folder with a language sub-folder containing the localized MESCIUS.ActiveReports.AssemblyName.resources.dll file.

Place the language folder containing the *.resources.dll file inside your main executing assembly folder to implement changes.

Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized MESCIUS.ActiveReports.AssemblyName.resources.dll file to Support Team by opening a support ticket, and get it signed with a strong name. Once you receive the signed DLL file, you can drag the language subfolder with the signed DLL file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

When the main executing assembly needs a resource, it uses a ResourceManager object to load the required resource. The ResourceManager uses the thread's CurrentUICulture property.

The common language run time sets the CurrentUICulture property or you can set it in code to force a certain UI Culture so that you can test whether your satellite DLL is loading properly. The ResourceManager class uses the CurrentUICulture property to locate subdirectories that contain a satellite DLL for the current culture. If no subdirectory exists, the ResourceManager uses the resource that is embedded in the assembly. US English ("en-US") is the default culture for ActiveReports.

Tip: For more detailed information about how the Framework locates satellite DLLs, please refer to the help system in Visual Studio® or the book Developing International Software, 2nd edition by MS Press that contains information on localizing applications using the .NET Framework.

See Also

Report Authors
Localize RDLX Report Content

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Js Components Localization

Js Components Localization
DevOps > Localization > Js Components Localization

Glossary Item Box

The NPM packages contain files for the localization of JavaScript components, namely, WebDesigner and Js Viewer. See the topics on WebDesigner Localization and Js Viewer Localization that explain this in detail.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebDesigner Localization

WebDesigner Localization
See Also
DevOps > Localization > Js Components Localization > WebDesigner Localization

Glossary Item Box

WebDesigner automatically sets the UI language the same as that of the browser for the localizations: English, Japanese, and simplified Chinese. This article discusses setting a web designer UI language different from the browser for the supported localizations and adding custom localization for the languages that are not explicitly supported.

Set WebDesigner UI Language

To specify the UI language of WebDesigner, specify the language API while initializing the component. The supported values are 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for simplified Chinese).

Index.html Copy Code
<!DOCTYPE html>
<html>
<head>
    <!-- get these files from the installation location for the package: \node_modules\@mescius\activereportsnet-designer\dist -->
    <link rel="stylesheet" href="web-designer.css" />
    <script src="web-designer.js"></script>
</head>
<body>
    <div id="ar-web-designer" class="ar-web-designer">
    </div>
    <script>
        GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            language: 'ja-JP'
        });
    </script>
</body>
</html>

Add Custom Localization using Resource Strings

With the WebDesigner NPM Package, you can access the resource strings from the custom-resources.json file available in the activereportsnet-designer\dist\docs folder of the package. In the 'custom-resources.json' file, you will find the resources stored in the file as shown:

Structure of custom-resources.json Copy Code
{
   "ns": "bundle namespace",
   "lng": "bundle language",
   "resources":  Record<string,any>
}

To add custom localization to the web designer UI,

  1. Copy the custom-resources.json file to the 'wwwroot' folder and rename the file to, say, 'fr-resources.json'.
  2. Open 'fr-resources.json' file and translate the strings from the ‘resources’ node to a language, say French. Also, set the ‘lng’ node with an appropriate bundle language.
    For example, here we are localizing the WebDesigner component for French language, so the strings must be translated to French language and 'lng' must be set to 'fr-FR'.
    Note: In web designer, resources should be assigned to their specific namespace, so do not modify the ‘ns’ node when translating resources.
    Sample fr-resources.json Copy Code
    [
   {
     "ns": "components",
     "lng": "fr-FR",
     "resources": {
       "appBar": {
         "btnPreview": "Aperçu",
         "btnFile": "Déposer",
         "btnHome": "Maison",
         "btnInsert": "Insérer",
         "textUnsavedChanges": "Modifications non enregistrées",
         "btnParameters": "Paramètres"
       },
       "menu": {
         "btnClose": "Fermer",
         "titlePin": "Broche",
         "btnLayerList": "Couches",
         "btnGroupEditor": "Éditeur de groupe",
         "btnReportExplorer": "Explorateur"
       }
     }
   }
]
    Note: As you may notice,
    • We have modified only the resource values and left the bundle namespace (e.g., components) and resource section (e.g., appBar, menu) untouched.
    • Some of the localization strings are skipped in the above example. The values for which localization strings are missing are by default displayed using EN localization data.

  3. Now that we have the translated resource bundles in the 'fr-resources.json' file, load this file and use addLanguage() and language APIs to localize the web designer. .

    Index.html Copy Code
    <!DOCTYPE html>
<html>
<head>
 <!--get these files from the installation location for the package: \node_modules\@mescius\activereportsnet-designer\dist-->
    <link rel="stylesheet" href="web-designer.css" />
    <script src="web-designer.js"></script>
</head>
<body>
    <div id="ar-web-designer" class="ar-web-designer">
    </div>
    <script>
        fetch("./fr-resources.json").then(res => res.json()).then((res) => {
            var languageResource = res;
            GrapeCity.ActiveReports.Designer.addLanguage('fr-FR', languageResource);
            GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
                language: 'fr-FR'
            });
        });
    </script>
</body>
</html>

An alternate approach is to pass the translated resource strings from custom-resources.json directly as the JSON object, as shown, and use addLanguage() and language APIs to localize the web designer.

Index.html Copy Code
<!DOCTYPE html>
<html>
<head>
    <!--get these files from the installation location for the package: \node_modules\@mescius\activereportsnet-designer\dist-->
    <link rel="stylesheet" href="web-designer.css" />
    <script src="web-designer.js"></script>
</head>
<body>
    <div id="ar-web-designer" class="ar-web-designer">
    </div>
    <script>
        var resourceBundles = [
            {
                "ns": "components",
                "lng": "fr-FR",
                "resources": {
                    "appBar": {
                        "btnPreview": "Aperçu",
                        "btnFile": "Déposer",
                        "btnHome": "Maison",
                        "btnInsert": "Insérer",
                        "textUnsavedChanges": "Modifications non enregistrées",
                        "btnParameters": "Paramètres"
                    },
                    "menu": {
                        "btnClose": "Fermer",
                        "titlePin": "Broche",
                        "btnLayerList": "Couches",
                        "btnGroupEditor": "Éditeur de groupe",
                        "btnReportExplorer": "Explorateur"
                    }
                }
            }
        ];
        GrapeCity.ActiveReports.Designer.addLanguage('fr-FR', resourceBundles);
        GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            language: 'fr-FR'
            });
    </script>
</body>
</html>

See Also

Cultures

Developers
WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Js Viewer Localization

Js Viewer Localization
See Also
DevOps > Localization > Js Components Localization > Js Viewer Localization

Glossary Item Box

Js Viewer supports English, Japanese, and Chinese localizations for which the localized files are already available. This article discusses setting a Js Viewer UI language from the supported localizations and adding custom localization for the languages that are not explicitly supported.

Set Js Viewer UI Language

To set the UI language of Js Viewer, specify the locale API while initializing the component. The supported values are 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for simplified Chinese).

index.html Copy Code
<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8">
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
    <script src="jsViewer.min.js"></script>
</head>
<body onload="loadViewer()">
    <div id="viewerContainer">
    </div>
    <script>
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                locale: 'ja-JP'
            });
            viewer.openReport("Report.rdlx");
        }
    </script>
</body>
</html>

Add Custom Localization using Resource Strings

With the Js Viewer NPM package, you can access the resource strings from the custom-locale.json file available in the activereportsnet-viewer\dist folder of the package. By default, the custom-locale.json file contains all the strings in English that are required to localize the viewer.

To add custom localization to the Js Viewer UI,

  1. Copy the 'custom-locale.json' file to the 'wwwroot' folder and rename the file to, say, 'fr-locale.json'.
  2. Open 'fr-locale.json' file and translate the strings in the file to any language, say French. For example, here we are localizing the Js Viewer component for French language, so the strings must be translated to French language.
    Sample fr-locale.json Copy Code
    {
   "viewer": {
     "toolbar": {
       "refresh": "Rafraîchir",
       "cancel": "Annuler"
     },
     "search": {
       "start-search-btn": "Recherche",
       "paneltitle": "Recherche"
     }
   }
 }
  3. Specify the URL of 'fr-locale.json' file using the localeUri API to add localization to the viewer.
    index.html Copy Code
    <!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8">
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
    <script src="jsViewer.min.js"></script>
</head>
<body onload="loadViewer()">
    <div id="viewerContainer">
    </div>
    <script>
     let viewer;
     function loadViewer() {
       viewer = GrapeCity.ActiveReports.JSViewer.create({
           element: '#viewerContainer',
           localeUri: './fr-locale.json'
       });
         viewer.openReport("Report.rdlx");
     }
   </script>
 </body>
 </html>
    Note: As you may notice, some of the localization strings are skipped in the above example. The values for which localization strings are missing are by default displayed using EN localization data.

An alternate approach is to use the localeData API to directly assign the localized JSON to the viewer, as shown.

index.html Copy Code
<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8">
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
    <script src="jsViewer.min.js"></script>
</head>
<body onload="loadViewer()">
    <div id="viewerContainer">
    </div>
    <script>
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                localeData: {
                    "viewer": {
                        "toolbar": {
                            "refresh": "Rafraîchir",
                            "cancel": "Annuler"
                        },
                        "search": {
                            "start-search-btn": "Recherche",
                            "paneltitle": "Recherche"
                        }
                    }
                }
            });
            viewer.openReport("Report.rdlx");
        }
    </script>
</body>
</html>

See Also

Developers
Js Viewer API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebViewer Localization

WebViewer Localization
See Also
DevOps > Localization > WebViewer Localization

Glossary Item Box

This article discusses setting the WebViewer UI language.

The localization file for WebViewer is ar-webviewer-locale.json. This file is automatically added to the project in the grapecity.activereports.web\content folder when you install the MESCIUS.ActiveReports.Web NuGet package, which is required when using WebViewer. The 'ar-webviewer-locale.json' file contains English localization so that the user can use it as a template for their own localization.

To localize WebViewer, first translate all the resources in the 'ar-webviewer-locale.json' file. Once you have translated all the resources, you must specify the location of the 'ar-webviewer-locale.json' file in the WebViewer’s LocalizationJson property.

Default. aspx. cs Copy Code
WebViewer1.LocalizationJson = File.ReadAllText(Server.MapPath("~") + " ar-webviewer-locale.json ");

See Also

Developers
ASP.NET WebViewer Application

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Localization

Blazor Localization
DevOps > Localization > Blazor Localization

Glossary Item Box

The NuGet packages contain files for the localization of Blazor components, namely, Blazor WebDesigner and Blazor Viewer. See the topics on Blazor WebDesigner Localization and Blazor Viewer Localization that explain this in detail.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor WebDesigner Localization

Blazor WebDesigner Localization
DevOps > Localization > Blazor Localization > Blazor WebDesigner Localization

Glossary Item Box

Blazor WebDesigner automatically sets the UI language the same as that of the browser for the localizations: English, Japanese, and simplified Chinese. This article discusses setting a blazor webdesigner UI language different from the browser for the supported localizations and adding custom localization for the languages that are not explicitly supported.

Set Blazor WebDesigner UI Language

To set the UI language of Blazor WebDesigner, specify the Language API with-in the div tags while initializing the component. The supported values are 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for simplified Chinese).

Index.razor Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<PageTitle>Index</PageTitle>
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings=@_preview Language="ja-JP" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
            {
                CanPreview = false
            };
    }
}

Check the complete HTML code provided below. Note that the code does not localize the viewer, see Blazor Viewer Localization for more information.

Add Custom Localization using Resource Strings

The localization file for Blazor WebDesigner is custom-resources.json. This file is automatically added to the project in the grapecity.activereports.blazor.designer\staticwebassets\docs\ folder when you install the MESCIUS.ActiveReports.Blazor.Designer NuGet package, which is required when using Blazor WebDesigner. In the 'custom-resources.json' file, you will find the resources stored in the file as shown:

Structure of custom-resources.json Copy Code
{
   "ns": "bundle namespace",
   "lng": "bundle language",
   "resources":  Record<string,any>
}

To add custom localization to the blazor web designer UI,

  1. Copy the custom-resources.json file to the 'wwwroot' folder and rename the file to, say, 'fr-resources.json'.
  2. Open 'fr-resources.json' file and translate the strings from the ‘resources’ node to a language, say French. Also, set the ‘lng’ node with an appropriate bundle language.
    For example, here we are localizing the WebDesigner component for French language, so the strings must be translated to French language and 'lng' must be set to 'fr-FR'.
    Note: In web designer, resources should be assigned to their specific namespace, so do not modify the ‘ns’ node when translating resources.
    Sample fr-resources.json Copy Code
    [
   {
     "ns": "components",
     "lng": "fr-FR",
     "resources": {
       "appBar": {
         "btnPreview": "Aperçu",
         "btnFile": "Déposer",
         "btnHome": "Maison",
         "btnInsert": "Insérer",
         "textUnsavedChanges": "Modifications non enregistrées",
         "btnParameters": "Paramètres"
       },
       "menu": {
         "btnClose": "Fermer",
         "titlePin": "Broche",
         "btnLayerList": "Couches",
         "btnGroupEditor": "Éditeur de groupe",
         "btnReportExplorer": "Explorateur"
       }
     }
   }
]
    Note: As you may notice,
    • We have modified only the resource values and left the bundle namespace (e.g., components) and resource section (e.g., appBar, menu) untouched.
    • Some of the localization strings are skipped in the above example. The values for which localization strings are missing are by default displayed using EN localization data.

  3. Now that we have the translated resource bundles in the 'fr-resources.json' file, load this file and use LocalizationResources and Language APIs to localize the web designer. Here is the complete HTML code provided below. Note that the code does not localize the viewer, see Blazor Viewer Localization for more information.

    Complete Index.razor Copy Code
    @page "/"
@inject IJSRuntime JSRuntime
<PageTitle>Index</PageTitle>
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings=@_preview LocalizationResources=@_localizationResources Language="fr"/>
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
                CanPreview = false
        };
    }
    private LocalizationResources[] _localizationResources;

    protected override async Task OnInitializedAsync()
    {
        _localizationResources = new LocalizationResources[]{
            new LocalizationResources(){
                Language = "fr",
                Resources =(await JSRuntime.InvokeAsync<object>("getJsonData", new object[] { "./fr-resources.json" })).ToString()
           }
        };
    }
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Viewer Localization

Blazor Viewer Localization
DevOps > Localization > Blazor Localization > Blazor Viewer Localization

Glossary Item Box

Blazor Viewer supports English, Japanese, and Chinese localizations for which the localized files are already available. This article discusses setting a Blazor Viewer UI language from the supported localizations and adding custom localization for the languages that are not explicitly supported.

Set Blazor Viewer UI Language

To set the UI language of Blazor Viewer, specify the Locale API while initializing the component. The supported values are 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for simplified Chinese).

Index.razor Copy Code
<div id="viewerContainer">
     <ReportViewer @ref="_viewer" ReportName="@_currentReport" Locale="ja-JP" />
</div>

Add Custom Localization using Resource Strings

The localization file for Blazor Viewer is ar-blazor-viewer-locale.json. The file is added to the project in the grapecity.activereports.blazor.viewer\content\ folder when you install the MESCIUS.ActiveReports.Blazor.Viewer NuGet package, which is required when using Blazor Viewer. By default, the 'ar-blazor-viewer-locale.json' file contains all the strings in English that are required to localize the viewer.

Note: The full path where you can find localization file is:
C:\Users\UserName\.nuget\packages\grapecity.activereports.blazor.viewer\version\content\ar-blazor-viewer-locale.json.

To add custom localization to the Blazor Viewer UI,

  1. Copy the 'ar-blazor-viewer-locale.json' file to the 'wwwroot' folder and rename the file to, say, 'ar-blazor-viewer-fr-locale.json'.
  2. Open the file and translate the strings in the file to any language, say French. For example, here we are localizing the Blazor Viewer component for French language, so the strings must be translated to French language.
    Sample ar-blazor-viewer-fr-locale
    .json     		Copy Code
    {
   "viewer": {
     "toolbar": {
       "refresh": "Rafraîchir",
       "cancel": "Annuler"
     },
     "search": {
       "start-search-btn": "Recherche",
       "paneltitle": "Recherche"
     }
   }
 }
  3. Specify the URL of 'ar-blazor-viewer-fr-locale.json' file using the LocaleUri API to add localization to the viewer.
    Index.razor Copy Code
    @page "/"
@using BlazorViewerServer.Data
@inject ReportsService ReportsService
<div class="main">
    <ReportList ReportsList="@reportsList" CurrentReport="@_currentReport" OnClickCallback="OnClick"></ReportList>
    <div id="viewerContainer">
        <ReportViewer @ref="_viewer" ReportName="@_currentReport" LocaleUri="./ar-blazor-viewer-fr-locale.json" />
    </div>
</div>
@code{
    private ReportViewer _viewer;
    private List<string> reportsList;
    private string _currentReport = null;
    protected override void OnInitialized()
    {
        reportsList = ReportsService.GetReports().ToList();
        _currentReport = reportsList.FirstOrDefault();
    }
    private async void OnClick(string res)
    {
        _currentReport = res;
        await _viewer.OpenReport(_currentReport);
    }
}
    Note: As you may notice, some of the localization strings are skipped in the above example. The values for which localization strings are missing are by default displayed using EN localization data.

An alternate approach is to use the LocaleData API to directly assign the localized JSON to the viewer, as shown.

Index.razor Copy Code
@page "/"
@using BlazorViewerServer.Data
@inject ReportsService ReportsService
<div class="main">
    <ReportList ReportsList="@reportsList" CurrentReport="@_currentReport" OnClickCallback="OnClick"></ReportList>
    <div id="viewerContainer">
        <ReportViewer @ref="_viewer" ReportName="@_currentReport" LocaleData="@_localeData" />
    </div>
</div>
@code{
    private ReportViewer _viewer;
    private List<string> reportsList;
    private string _currentReport = null;

    string _localeData = "{\"viewer\":{\"toolbar\":{\"refresh\":\"Rafraîchir\",\"cancel\":\"Annuler\"},\"search\":{\"start-search-btn\":\"Recherche\",\"paneltitle\":\"Recherche\"} } }";

    protected override void OnInitialized()
    {
        reportsList = ReportsService.GetReports().ToList();
        _currentReport = reportsList.FirstOrDefault();
    }
    private async void OnClick(string res)
    {
        _currentReport = res;
        await _viewer.OpenReport(_currentReport);
    }
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Cultures

Cultures
DevOps > Localization > Cultures

Glossary Item Box

For your convenience, here is a list of predefined System.Globalization cultures. (Source: MSDN.) For ActiveReports localization purposes, use the Culture and Language Name value in the first column.

Culture and Language Name | Culture Identifier | Culture
"" (empty string) | 0x007F | Invariant culture
af | 0x0036 | Afrikaans
af-ZA | 0x0436 | Afrikaans (South Africa)
sq | 0x001C | Albanian
sq-AL | 0x041C | Albanian (Albania)
ar | 0x0001 | Arabic
ar-DZ | 0x1401 | Arabic (Algeria)
ar-BH | 0x3C01 | Arabic (Bahrain)
ar-EG | 0x0C01 | Arabic (Egypt)
ar-IQ | 0x0801 | Arabic (Iraq)
ar-JO | 0x2C01 | Arabic (Jordan)
ar-KW | 0x3401 | Arabic (Kuwait)
ar-LB | 0x3001 | Arabic (Lebanon)
ar-LY | 0x1001 | Arabic (Libya)
ar-MA | 0x1801 | Arabic (Morocco)
ar-OM | 0x2001 | Arabic (Oman)
ar-QA | 0x4001 | Arabic (Qatar)
ar-SA | 0x0401 | Arabic (Saudi Arabia)
ar-SY | 0x2801 | Arabic (Syria)
ar-TN | 0x1C01 | Arabic (Tunisia)
ar-AE | 0x3801 | Arabic (U.A.E.)
ar-YE | 0x2401 | Arabic (Yemen)
hy | 0x002B | Armenian
hy-AM | 0x042B | Armenian (Armenia)
az | 0x002C | Azeri
az-Cyrl-AZ | 0x082C | Azeri (Azerbaijan, Cyrillic)
az-Latn-AZ | 0x042C | Azeri (Azerbaijan, Latin)
eu | 0x002D | Basque
eu-ES | 0x042D | Basque (Basque)
be | 0x0023 | Belarusian
be-BY | 0x0423 | Belarusian (Belarus)
bg | 0x0002 | Bulgarian
bg-BG | 0x0402 | Bulgarian (Bulgaria)
ca | 0x0003 | Catalan
ca-ES | 0x0403 | Catalan (Catalan)
zh-HK | 0x0C04 | Chinese (Hong Kong SAR, PRC)
zh-MO | 0x1404 | Chinese (Macao SAR)
zh-CN | 0x0804 | Chinese (PRC)
zh-Hans | 0x0004 | Chinese (Simplified)
zh-SG | 0x1004 | Chinese (Singapore)
zh-TW | 0x0404 | Chinese (Taiwan)
zh-Hant | 0x7C04 | Chinese (Traditional)
hr | 0x001A | Croatian
hr-HR | 0x041A | Croatian (Croatia)
cs | 0x0005 | Czech
cs-CZ | 0x0405 | Czech (Czech Republic)
da | 0x0006 | Danish
da-DK | 0x0406 | Danish (Denmark)
dv | 0x0065 | Divehi
dv-MV | 0x0465 | Divehi (Maldives)
nl | 0x0013 | Dutch
nl-BE | 0x0813 | Dutch (Belgium)
nl-NL | 0x0413 | Dutch (Netherlands)
en | 0x0009 | English
en-AU | 0x0C09 | English (Australia)
en-BZ | 0x2809 | English (Belize)
en-CA | 0x1009 | English (Canada)
en-029 | 0x2409 | English (Caribbean)
en-IE | 0x1809 | English (Ireland)
en-JM | 0x2009 | English (Jamaica)
en-NZ | 0x1409 | English (New Zealand)
en-PH | 0x3409 | English (Philippines)
en-ZA | 0x1C09 | English (South Africa)
en-TT | 0x2C09 | English (Trinidad and Tobago)
en-GB | 0x0809 | English (United Kingdom)
en-US | 0x0409 | English (United States)
en-ZW | 0x3009 | English (Zimbabwe)
et | 0x0025 | Estonian
et-EE | 0x0425 | Estonian (Estonia)
fo | 0x0038 | Faroese
fo-FO | 0x0438 | Faroese (Faroe Islands)
fa | 0x0029 | Farsi
fa-IR | 0x0429 | Farsi (Iran)
fi | 0x000B | Finnish
fi-FI | 0x040B | Finnish (Finland)
fr | 0x000C | French
fr-BE | 0x080C | French (Belgium)
fr-CA | 0x0C0C | French (Canada)
fr-FR | 0x040C | French (France)
fr-LU | 0x140C | French (Luxembourg)
fr-MC | 0x180C | French (Monaco)
fr-CH | 0x100C | French (Switzerland)
gl | 0x0056 | Galician
gl-ES | 0x0456 | Galician (Spain)
ka | 0x0037 | Georgian
ka-GE | 0x0437 | Georgian (Georgia)
de | 0x0007 | German
de-AT | 0x0C07 | German (Austria)
de-DE | 0x0407 | German (Germany)
de-LI | 0x1407 | German (Liechtenstein)
de-LU | 0x1007 | German (Luxembourg)
de-CH | 0x0807 | German (Switzerland)
el | 0x0008 | Greek
el-GR | 0x0408 | Greek (Greece)
gu | 0x0047 | Gujarati
gu-IN | 0x0447 | Gujarati (India)
he | 0x000D | Hebrew
he-IL | 0x040D | Hebrew (Israel)
hi | 0x0039 | Hindi
hi-IN | 0x0439 | Hindi (India)
hu | 0x000E | Hungarian
hu-HU | 0x040E | Hungarian (Hungary)
is | 0x000F | Icelandic
is-IS | 0x040F | Icelandic (Iceland)
id | 0x0021 | Indonesian
id-ID | 0x0421 | Indonesian (Indonesia)
it | 0x0010 | Italian
it-IT | 0x0410 | Italian (Italy)
it-CH | 0x0810 | Italian (Switzerland)
ja | 0x0011 | Japanese
ja-JP | 0x0411 | Japanese (Japan)
kn | 0x004B | Kannada
kn-IN | 0x044B | Kannada (India)
kk | 0x003F | Kazakh
kk-KZ | 0x043F | Kazakh (Kazakhstan)
kok | 0x0057 | Konkani
kok-IN | 0x0457 | Konkani (India)
ko | 0x0012 | Korean
ko-KR | 0x0412 | Korean (Korea)
ky | 0x0040 | Kyrgyz
ky-KG | 0x0440 | Kyrgyz (Kyrgyzstan)
lv | 0x0026 | Latvian
lv-LV | 0x0426 | Latvian (Latvia)
lt | 0x0027 | Lithuanian
lt-LT | 0x0427 | Lithuanian (Lithuania)
mk | 0x002F | Macedonian
mk-MK | 0x042F | Macedonian (Macedonia, FYROM)
ms | 0x003E | Malay
ms-BN | 0x083E | Malay (Brunei Darussalam)
ms-MY | 0x043E | Malay (Malaysia)
mr | 0x004E | Marathi
mr-IN | 0x044E | Marathi (India)
mn | 0x0050 | Mongolian
mn-MN | 0x0450 | Mongolian (Mongolia)
no | 0x0014 | Norwegian
nb-NO | 0x0414 | Norwegian (Bokmål, Norway)
nn-NO | 0x0814 | Norwegian (Nynorsk, Norway)
pl | 0x0015 | Polish
pl-PL | 0x0415 | Polish (Poland)
pt | 0x0016 | Portuguese
pt-BR | 0x0416 | Portuguese (Brazil)
pt-PT | 0x0816 | Portuguese (Portugal)
pa | 0x0046 | Punjabi
pa-IN | 0x0446 | Punjabi (India)
ro | 0x0018 | Romanian
ro-RO | 0x0418 | Romanian (Romania)
ru | 0x0019 | Russian
ru-RU | 0x0419 | Russian (Russia)
sa | 0x004F | Sanskrit
sa-IN | 0x044F | Sanskrit (India)
sr-Cyrl-CS | 0x0C1A | Serbian (Serbia, Cyrillic)
sr-Latn-CS | 0x081A | Serbian (Serbia, Latin)
sk | 0x001B | Slovak
sk-SK | 0x041B | Slovak (Slovakia)
sl | 0x0024 | Slovenian
sl-SI | 0x0424 | Slovenian (Slovenia)
es | 0x000A | Spanish
es-AR | 0x2C0A | Spanish (Argentina)
es-BO | 0x400A | Spanish (Bolivia)
es-CL | 0x340A | Spanish (Chile)
es-CO | 0x240A | Spanish (Colombia)
es-CR | 0x140A | Spanish (Costa Rica)
es-DO | 0x1C0A | Spanish (Dominican Republic)
es-EC | 0x300A | Spanish (Ecuador)
es-SV | 0x440A | Spanish (El Salvador)
es-GT | 0x100A | Spanish (Guatemala)
es-HN | 0x480A | Spanish (Honduras)
es-MX | 0x080A | Spanish (Mexico)
es-NI | 0x4C0A | Spanish (Nicaragua)
es-PA | 0x180A | Spanish (Panama)
es-PY | 0x3C0A | Spanish (Paraguay)
es-PE | 0x280A | Spanish (Peru)
es-PR | 0x500A | Spanish (Puerto Rico)
es-ES | 0x0C0A | Spanish (Spain)
es-ES_tradnl | 0x040A | Spanish (Spain, Traditional Sort)
es-UY | 0x380A | Spanish (Uruguay)
es-VE | 0x200A | Spanish (Venezuela)
sw | 0x0041 | Swahili
sw-KE | 0x0441 | Swahili (Kenya)
sv | 0x001D | Swedish
sv-FI | 0x081D | Swedish (Finland)
sv-SE | 0x041D | Swedish (Sweden)
syr | 0x005A | Syriac
syr-SY | 0x045A | Syriac (Syria)
ta | 0x0049 | Tamil
ta-IN | 0x0449 | Tamil (India)
tt | 0x0044 | Tatar
tt-RU | 0x0444 | Tatar (Russia)
te | 0x004A | Telugu
te-IN | 0x044A | Telugu (India)
th | 0x001E | Thai
th-TH | 0x041E | Thai (Thailand)
tr | 0x001F | Turkish
tr-TR | 0x041F | Turkish (Turkey)
uk | 0x0022 | Ukrainian
uk-UA | 0x0422 | Ukrainian (Ukraine)
ur | 0x0020 | Urdu
ur-PK | 0x0420 | Urdu (Pakistan)
uz | 0x0043 | Uzbek
uz-Cyrl-UZ | 0x0843 | Uzbek (Uzbekistan, Cyrillic)
uz-Latn-UZ | 0x0443 | Uzbek (Uzbekistan, Latin)
vi | 0x002A | Vietnamese
vi-VN | 0x042A | Vietnamese (Vietnam)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deployment

Deployment
See Also
DevOps > Deployment

Glossary Item Box

ActiveReports.NET can be deployed to any supported environment. Depending on the choice of environment and the specific scenario that needs to be addressed, you can choose the environment.

To deploy ActiveReports successfully, you need to have an idea about the following details related to Licensing and GAC.

  • Licensing: Each environment requires its licensing scenario. See the License ActiveReports topic for details.
  • GAC (Global Assembly Cache): ActiveReports supports installation to the GAC. However, you should implement it manually as no special scripts are provided.
Note: If you are deploying a single file application in NET 6.0 or above, you should set IncludeAllContentForSelfExtract property to 'true' in your project or change the Target framework to NET Core 3.1 for custom script to work. See Single-file Deployment for more information.

ActiveReports can be deployed in the following supported environments:

  • Windows apps

    Learn how to deploy ActiveReports Windows projects to your system.

  • Web apps

    Learn how to deploy ActiveReports Web projects to your Web server.

  • Non-Windows environment

    Learn how to deploy applications across non-Windows environments Mac and Linux.

  • Cloud services

    Learn how to deploy applications across cloud services such as Azure App Service, Amazon Web Services, and Google Cloud services.

  • Using Docker on Windows environment

    Learn how to deploy applications using Docker on Windows.

See Also

Developers
License ActiveReports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy Windows Application

Deploy Windows Application
DevOps > Deployment > Deploy Windows Application

Glossary Item Box

Before deploying a Windows application, for the report files, change the Copy to Output Directory property to Copy always from the Properties window.

It is also good to be sure that all of the packages you need for your reports are included.

XCopy Deployment

  1. Open your project in Visual Studio, and set the Solution Configuration to 'Release'.
  2. From the Build menu, select Build Solution.
  3. In File Explorer, navigate to the project's bin directory, and copy all the files from the Release folder into a zip file.
  4. Distribute the zip file.

MSI Installer Deployment

Create an installer project

  1. Open an existing ActiveReports project or create a new one.
  2. From the Visual Studio Build menu, select Build YourActiveReportsProjectName to build your report project.
  3. From the File menu, select Add, then New Project.
  4. In the Add a new project dialog, select Setup Project, rename the file if you want and click Create. The ProjectName that you enter determines the name that is displayed for the application in folder names.
  5. In the File System editor that appears, under File System on Target Machine, select the Application Folder.
    Note: To show the File System editor at any time, drop down the View menu and select Editor, then File System.
  6. Right-click Application Folder and from the context menu, select Add, then Project Output.
  7. In the Add Project Output Group dialog that appears, choose your ActiveReports project name from the drop-down list.
  8. In the list, select Primary output and click OK. This adds all of the existing package dependencies to your project.
    Note: If you would rather use the ActiveReports .msm file, please contact our technical support team.
  9. In the Select Component dialog that appears, select the components that you want to add and click the OK button.
  10. From the Visual Studio Build menu, select Build YourInstallerProjectName to build your Installer project.

Deploy the installer application

  1. Right-click the Installer project in the Solution Explorer and select Install.
  2. The Installer application runs and installs the project on your computer. The distributable exe and msi setup files appear in your installer project Debug folder.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy Web Application

Deploy Web Application
DevOps > Deployment > Deploy Web Application

Glossary Item Box

Follow this guide to deploy ActiveReports Web projects to your Web server. See the article from MSDN for more details.

To deploy ActiveReports Web projects, you must have access to the Microsoft .NET Framework version 4.7.2 or higher and the coordinating version of ASP.NET, or ASP.NET Core with .NET Core 3.1 and above. You must also have access to Internet Information Services version 8 or higher, and you need administrative access to the server.

It is also good to be sure that all of the packages you need for your reports are included.

Install prerequisites on the server

Follow Microsoft's instructions to install each of the following on your Web server:

  • The Microsoft .NET Framework version 4.7.2 or higher
  • ASP.NET version 4.7.2 or higher (must be the same version as the Framework)
  • ASP.NET Core with .NET Core 3.1 and above.
  • Internet Information Services (IIS) version 8

Map your application to a virtual directory

  1. Make sure your project is deployed to a virtual directory in IIS.
  2. To map requests from the page with the WebViewer control to your virtual directory, paste the <base> tag with a virtual directory name inside the <head> tag of the page containing the WebViewer control. In this case, all requests to back end assemblies will include the specified virtual directory name. For example,
        <head>
         <base href="/VirtDirName/">
        </head>

Set permissions on the server

Depending on your project, you may need to set permissions to allow ActiveReports access to data or folders.

Some examples of required permissions on the server:

  • If you are saving files (e.g. PDF or RDF exports) to a folder on Windows machines, the ASPNET user ID needs Write access to that folder.
  • Windows is user configurable, so use the name assigned to the ASPNET user instead.
  • If your application reads anything from any folder, assign Read access to it.
  • If your reports run on any networked data source (e.g. SQL, Access, etc.) assign Read access to it.

You can also deploy Report Parts by placing your Page and RDLX reports with report parts to the report items library. The path to this library is set in the ReportPartsDirectory property of the ActiveReports.config file; see Configure ActiveReports using Config File topic.

Report Parts is a Professional Edition feature that provides you with the possibility to reuse report parts (groups of controls with data and settings) from one report in other reports. For example, you can use Chart and Tablix data regions from Report1, and a Table data region from Report2 to create a new report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy Applications in Non-Windows Environment

Deploy Applications in Non-Windows Environment
See Also
DevOps > Deployment > Deploy Applications in Non-Windows Environment

Glossary Item Box

This page discusses on how to deploy applications across non-Windows environment such as Mac and Linux.

See Also

Mac
Linux

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Mac

Mac
DevOps > Deployment > Deploy Applications in Non-Windows Environment > Mac

Glossary Item Box

This page demonstrates how you can deploy your ActiveReports application on Mac locally.

Prerequisites

This tutorial uses the .Net 6 SDK to run and deploy the JSViewer_MVC_Core sample application locally. You can download the sample from our GitHub repository: https://github.com/activereports/WebSamples19/tree/main/JSViewer_MVC_Core

We will also be using some sample reports to that can downloaded from the following link:

https://github.com/activereports/WebSamples19/tree/main/JsViewerReports

Requirements

  • .Net .6 SDK (x64)
  • Visual Studio 2019 or later

Build and Run

  1. Open the JSViewer_MVC_Core project in Visual Studio.
  2. Restore NuGet packages.
    1. For this expand the Dependencies option in the Solution Explorer.
    2. Right-click on the NuGet and select Restore in the context menu.
  3. Add JsViewerReport folder that we have downloaded previously in your project.
    1. Right-click on the Project in Solution Explorer.
    2. Click on Add > Add Existing Folder
    3. Select the JSViewerReports.
  4. Build and run the application.

Publish the application

Once you have confirmed that the application is running on your system, we are ready to Publish the application. Here are the steps to publish the macOS application.

  1. In Visual Studio, right-click the project file of the JSViewer_MVC_Core and click Edit Project to edit the project file
  2. Now add a new Runtime Identifier to the file and save it, just as highlighted here:
    Copy Code
    <RuntimeIdentifiers>win10-x64;osx.10.12-x64</RuntimeIdentifiers>

    Add Runtime Identifiers
  3. Now right-click the project file again and click Publish>Publish to Folder…
  4. Set the publish location as “bin>release>6.0>publish” and click OK.

Running the applications on macOS

Now that we have published our application, we can run the application on macOS. The process is very similar as the process on Windows.
Now to run the self-contained app on macOS:

  1. To run the JSViewer_MVC_Core application, we need to grant the executable permissions to run.
    1. First, Go to the bin/release/6.0 folder.
    2. Right-click on the Publish Folder and Select Services in the context menu and select New Terminal at Folder.
  2. Type in sudo chmod +x JSViewer_MVC_Core and hit enter.
  3. Type in the password of your admin account and hit enter to grant the executable permission to run.
  4. Now type in open JSViewer_MVC_Core and hit enter
  5. The app now runs in a new terminal window and the following message is displayed:

    Add Runtime Identifiers

  6. Now you can open the application on following URL in your browser: http://localhost:5000

Add Runtime Identifiers

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Linux

Linux
DevOps > Deployment > Deploy Applications in Non-Windows Environment > Linux

Glossary Item Box

ActiveReports supports Linux environment with only .NET Core environment installed. WinForms and WPF controls are not supported.

Important: You should configure the Font Resolver (with config file or through code) to obtain consistent result. Check Troubleshooting to fix the missing fonts issue.

Publish your .Net Core application

Once you have created a .Net core application on Visual Studio, open the project and follow the steps to publish the application.

  1. Right-click on your project.
  2. Click on Publish button.
  3. Now create a new publish profile, and browse the folder where you want to publish your project dll.
  4. Click on Publish so it will create your dll in the folder.

Install required .Net Module on Linux

Now we have the web application dll and we need to host it on the Linux environment. .Net applications run on Kestrel servers and we run Apache or Nginx server in Linux environments, which acts as a proxy server and handles the traffic from outside the machine and redirects it to the Kestrel server so we will have Apache or Nginx server as the middle layer.

In this article, we will use Apache as a proxy server.

First, we would need to install the .Net core module in our Linux environment. For that run the following commands,

  • sudo apt-get update

  • sudo apt-get install apt-transport-https

  • sudo apt-get update

  • sudo apt-get install dotnet-sdk-3.1

  • sudo apt-get install dotnet-runtime-3.1

  • sudo apt-get install aspnetcore-runtime-3.1

This will install all the required .Net packages

Install and configure Apache Server

Install the Apache server

  • sudo apt-get install apache2

  • sudo a2enmod proxy proxy_http proxy_html proxy_wstunnel

  • sudo a2enmod rewrite

Next, we need to make a conf file to set up our proxy on Apache. Create the file by running the following command:

  • sudo nano /etc/apache2/conf-enabled/netcore.conf

Now copy the following configuration in that file:

netcore.conf Copy Code
<VirtualHost *:80>
   ServerName www.DOMAIN.COM
   ProxyPreserveHost On
   ProxyPass / http://127.0.0.1:5000/
   ProxyPassReverse / http://127.0.0.1:5000/
   RewriteEngine on
   RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
   RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
   RewriteRule /(.*) ws://127.0.0.1:5000$1 [P]
   ErrorLog /var/log/apache2/netcore-error.log
   CustomLog /var/log/apache2/netcore-access.log common
</VirtualHost>

The <VirtualHost *:80> tag defines the IP and port it will bind Apache so we will access our application from outside our Linux environment through this Ip:Port.

Now restart the Apache server using the following the commands:

  • sudo service apache2 restart

  • sudo apachectl configtest

Configure and Start Service

Move the dll to the defined path with the below command.

"sudo cp -a ~/release/ /var/netcore/"

Create a service file for our .Net application using the following command.

"sudo nano /etc/systemd/system/ServiceFile.service"

Copy the following configuration in that file and it will run our application,

Copy Code
[Unit]
Description=ASP .NET Web Application
[Service]
WorkingDirectory=/var/netcore
ExecStart=/usr/bin/dotnet /var/netcore/Application.dll
Restart=always
RestartSec=10
SyslogIdentifier=netcore-demo
User=www-data
Environment=ASPNETCORE_ENVIRONMENT=Production
[Install]
WantedBy=multi-user.target

In "ExecStart=/usr/bin/dotnet /var/netcore/Application.dll" line of code, replace Application.dll with your dll name that you want to run. For JSViewer MVC Core replace the Application.dll with JSViewer_MVC_Core.dll.

Now start the service. Instead of the service name in the below commands use the name of the file made above,

  • sudo systemctl enable {Service Name}

  • sudo systemctl start {Service Name}

Now your proxy server and kestrel server are running, and you can access your application through any ip with port 80.

To redeploy the code your need to replace the dll and stop and start your service again through the following commands,

  • sudo systemctl stop {Service Name}

  • sudo systemctl start {Service Name}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy Applications to Cloud Services

Deploy Applications to Cloud Services
See Also
DevOps > Deployment > Deploy Applications to Cloud Services

Glossary Item Box

Lets discuss ActiveReports deployment across cloud services such as Azure App Service, Amazon Web Services, and Google Cloud cloud services.

See Also

Azure App Service
Amazon Web Services
Google Cloud

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Azure App Service

Azure App Service
See Also
DevOps > Deployment > Deploy Applications to Cloud Services > Azure App Service

Glossary Item Box

ActiveReports can be deployed to Azure - it can be Virtual Machine, Azure Function, or Azure App Service. This page explains how to deploy (publish) a web project by using the Visual Studio. To deploy your web app, you must first create and configure a new App Service that you can publish your app to. See the MSDN documentation.

See Also

Deploy on Azure using a Windows Environment
Deploy on Azure using a Linux Environment

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on Azure using a Windows Environment

Deploy on Azure using a Windows Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Azure App Service > Deploy on Azure using a Windows Environment

Glossary Item Box

In this tutorial, we will be deploying the JSViewer_MVC_Core sample on Azure using a Windows environment.

  1. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.
  2. Open the application in Visual Studio and build and run the application.
  3. Remove the Reports folder containing links the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.

Follow these steps to create your App Service resources and publish your project. Let us use JSViewer_MVC_Core sample project for demonstration purpose.

  1. Open the JSViewer_MVC_Core sample project in Visual Studio 2022.
  2. In the Solution Explorer, right-click the on your project name, and select Publish.
    Select Publish in the Solution Explorer
  3. In Publish window, select Azure and then Next.
    Azure in the Publish window
  4. Choose the Specific target Azure App Service (Windows). Then, select Next.
    Choose Specific Target in the Publish window
  5. Your options depend on whether you're signed in to Azure already and whether you have a Visual Studio account linked to an Azure account. Select either Add an account or Sign in to sign in to your Azure subscription. If you're already signed in, select the account you want.
  6. To the right of App Service instances, select +.
    Create Azure Application Service
  7. For Subscription name, accept the subscription that is listed or select a new one from the drop-down list.
  8. For Resource group, select New. It will contain all of the Azure resources for the service.
  9. In New resource group name, enter JSViewerResourceGroup and select OK.
  10. For Hosting Plan, select New. It specifies the location, size, and features of the web server that hosts your app.
  11. In the Hosting Plan dialog, enter the appropriate values:

    Hosting Plan: JSViewerMVCCorePlan
    Location: Central US
    Size: S1
  12. In Name field, enter a unique app name that includes only the valid characters (a-z, A-Z, 0-9, and -). You can accept the automatically generated unique name. The URL of the web app is http://.azurewebsites.net, where <app-name> is your app name.
    Create New App Service dialog
  13. Select Create.
    Created App Service Instance
    Once the wizard completes, the Azure resources are created and the project is ready to be published.
  14. In the Publish dialog, ensure your new App Service app is selected in App Service instance, then select Finish. Visual Studio creates a publish profile for you for the selected App Service app.
    Ready to publish dialog
  15. In the Publish page, select Publish.
    Visual Studio builds, packages, and publishes the app to Azure, and then launches the app in the default browser.
    Once you have followed all the steps the website is deployed on Azure.
    Deployed Website on Azure

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on Azure using a Linux Environment

Deploy on Azure using a Linux Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Azure App Service > Deploy on Azure using a Linux Environment

Glossary Item Box

In this tutorial we will be deploying the JSViewer_MVC_Core sample on Azure using a Linux environment.

  1. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.
  2. Build and run the application.
  3. Remove the Reports folder containing links the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.
  6. Since the published docker might not contain the fonts used by reports we will add a custom font resolver in our ActiveReports application.
    1. Add a new folder Fonts in the project where we will the required fonts.
    2. Add a new .cs file 'CustomFontResolver.cs' and make sure to set the Build Action to 'Embedded Resource'.
    3. Add the following code in the .cs file to the add the script.
      CustomFontResolver.cs Copy Code
      using GrapeCity.Documents.Text.Windows;
public sealed class CustomFontResolver : GrapeCity.ActiveReports.IFontResolver
    {
        static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
        static CustomFontResolver()
        {
            _fonts.Clear();
            var assembly = Assembly.GetExecutingAssembly();
            var fontnames = assembly.GetManifestResourceNames().Where(str => str.EndsWith(".ttf"));
            foreach (var fontname in fontnames)
            {
                Stream stream = assembly.GetManifestResourceStream(fontname);
                _fonts.Add(GrapeCity.Documents.Text.Font.FromStream(stream));
            }
            _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
        }
        public static GrapeCity.ActiveReports.IFontResolver Instance = new CustomFontResolver();
        private CustomFontResolver() { }
        GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
        {
            var fonts = new GrapeCity.Documents.Text.FontCollection();
            var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
            if (font != null) fonts.Add(font);
            fonts.Add(_fonts.DefaultFont);
            return fonts;
        }
    }

    4. In Startup.cs, specify the UseFontResolver property in the JavaScript Viewers as in the following code example.
      Startup.cs Copy Code
      app.UseReportViewer(settings =>
            {
                settings.UseFontResolver = CustomFontResolver.Instance;
                settings.UseEmbeddedTemplates(EmbeddedReportsPrefix, Assembly.GetAssembly(app.GetType()));
                settings.UseCompression = true;
            });

Follow these steps to create your App Service resources and publish your project. Let us use JSViewer_MVC_Core sample project for demonstration purpose.

  1. Open the JSViewer_MVC_Core sample project in Visual Studio 2022.
  2. In the Solution Explorer, right-click the on your project name, and select Publish.
    Visual Studio Solution Explorer Publish Option
  3. In Publish window, select Azure and then Next.
    Select Azure as Target in the Publish window
  4. Choose the Specific target Azure App Service (Linux). Then, select Next.
    Select Azure App Service as Specific target
  5. Your options depend on whether you're signed in to Azure already and whether you have a Visual Studio account linked to an Azure account. Select either Add an account or Sign in to sign in to your Azure subscription. If you're already signed in, select the account you want.
  6. To the right of App Service instances, select +.
    Create an Azure App Service
  7. For Subscription name, accept the subscription that is listed or select a new one from the drop-down list.
  8. For Resource group, select New. It will contain all of the Azure resources for the service.
  9. In New resource group name, enter JSViewerResourceGroup and select OK.
  10. For Hosting Plan, select New. It specifies the location, size, and features of the web server that hosts your app.
  11. In the Hosting Plan dialog, enter the appropriate values:

    Hosting Plan: JSViewerMVCCorePlan
    Location: Central US
    Size: S1
  12. In Name field, enter a unique app name that includes only the valid characters (a-z, A-Z, 0-9, and -). You can accept the automatically generated unique name. The URL of the web app is http://.azurewebsites.net, where <app-name> is your app name.
    Create new Azure App Service dialog
  13. Select Create.
    Created Azure App Service instance
    Once the wizard completes, the Azure resources are created and the project is ready to be published.
  14. In the Publish dialog, ensure your new App Service app is selected in App Service instance, then select Finish. Visual Studio creates a publish profile for you for the selected App Service app.
    Ready to publish profile
  15. In the Publish page, select Publish.
    Visual Studio builds, packages, and publishes the app to Azure, and then launches the app in the default browser.
    Once you have followed all the steps the website is deployed on Azure.
    Deployed Website on Azure

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Amazon Web Services

Amazon Web Services
See Also
DevOps > Deployment > Deploy Applications to Cloud Services > Amazon Web Services

Glossary Item Box

We will be deploying the JSViewer_MVC_Core sample on cloud using AWS web service.

Prerequisites

This tutorial uses the .NET Core SDK to generate a basic .NET Core application, run it locally, and build a deployable package.

Requirements

  • NET Core SDK x64 for Windows 1.0.1, 2.0.0, or later
    Download .NET SDK from https://dotnet.microsoft.com/en-us/download and run the installer.
  • ActiveReports 19 or later
    See Install ActiveReports for more information.
  • AWS Toolkit for Visual Studio 2022
    1. In Visual Studio 2022, from Extensions > Manage Extensions, search online for 'AWS Toolkit for Visual Studio 2022'.
    2. Select Download. The extension is scheduled for install.
    3. Close all instances of Visual Studio and restart your .Net project once you have installed the extension.

See Also

Deploy on AWS using a Windows Environment
Deploy on AWS using a Linux Environment

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on AWS using a Windows Environment

Deploy on AWS using a Windows Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Amazon Web Services > Deploy on AWS using a Windows Environment

Glossary Item Box

This page demonstrates how you can deploy your ActiveReports application on AWS using a Windows Environment.

Setup your application

  1. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.
  2. Open the application in Visual Studio and build and run the application.
  3. Remove the Reports folder containing links the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.

Setup a user in AWS

Once you have set up everything the next step is to create a user in your AWS Account. You can also visit AWS Docs for more information.

  1. Open the Sign In Page.
    Note: If you are new to AWS then Sign Up to AWS and add MFA Authentication by logging-in as a Root User first.
  2. Select IAM user and enter your credentials.
  3. Now from the AWS Management Console under All Services, select IAM. This will open the IAM Dashboard.
  4. Select Users under the Access Management group
  5. Click Add users on the top right of your screen. This will open the Add user page.
  6. Set the User name. Here, for documentation purposes we are adding 'AR_Deployment_Agent' as the username.
  7. Select the Access key-Programmatic access that gives this user programmatic access. Then click Next: Permissions.
  8. Now we will add user to a group. Select an existing group or to create a new group:
    a. Click on Create a Group option.
    b. Enter the Group Name. Here we are using 'AR_Deployment_Agents' as the group name.
    c. In the policies option, check AdministratorAccess-AWSElasticBeanstalk and IAMFullAccess.
    d. Click Create group.
  9. Click Next: Tags. Here you can add the tags that can be used in your application for now we are going to skip this.
  10. Click Next: Review. Here, you can review the user properties and then select Create user.
  11. Now copy the Access key ID and Secret access key and save it.
    Note you can also download the CSV from this page.

Setup AWS Profile in Visual Studio

Now that we have setup everything on the AWS account, let us setup our application with AWS and deploy it on the cloud.

  1. Open the JSViewer_MVC_Core sample in Visual Studio.
  2. From View, go to AWS Explorer.
    Visual Studio View AWS Explorer option
  3. In the AWS Explorer window, click the “+” icon to create a new profile.
    AWS Explorer New Account Profile
  4. Enter a Profile Name (AR_Cloud_Deploy), the saved Access Key ID, and the Secret Access Key.

    Note that you can also import the CSV if you chose to download it while creating the user account.

Publish and deploy your application

To publish your application for AWS Elastic Beanstalk, follow these steps.

  1. Right-click on the project in the Solution Explorer and click Publish to AWS Elastic Beanstalk.. option in the context menu.

    Publish to AWS Elastic Beanstalk in Solution Explorer
  2. Now in the Publish to Amazon Web Services window, set the Region. Although AWS has many different regions for this sample, we are selecting the region as US East (N. Virginia).
  3. Select Create a new application environment option and then Next.
    New AWS Application Environment
  4. Set the Application Name and the Environment Name.
    A URL should be added automatically after the previous step. You can add some other URL as well.
  5. Check the URL availability by clicking the Check availability… button. If the URL is available, “The requested URL is available” message should appear on your screen. Now, click Next.
  6. Set the Container type to 64bit Windows Server Core 2019 v2.9.1 running IIS 10.0. Now, click Next.
    Now, we must configure all our AWS Options. For the sample purposes we are leaving most of the options as default.

    Container Type-Windows
  7. In the next Permissions window, we will select roles granting permissions to your deployed application for the service to monitor resources. Input the following values in the permissions options and then click Next.

    Deployment Application Permissions
    Role: aws-elasticbeanstalk-ec2-role

    Service Permissions
    Role: aws-elasticbeanstalk-service-role
    Service Permissions
  8. In the Application Options window, change the Project build configuration from Debug|Any CPU to Release|Any CPU.
  9. Set the Framework to net6.0.
  10. Check the Build self contained deployment bundle option and then click Next.
    Build self contained deployment bundle
  11. Go through the Review page to ensure you have selected all the required options as per your organization and application.
  12. Click Deploy.
    Once you click Deploy, it takes several minutes to create the environment and launch your ActiveReports application to the cloud.
    AWS Deploy
    Once your application is successfully launched, you will see the following Event statement in the Event’s tab in the Environment window:
    Successfully launched environment: JSViewerMVCCore-dev

    Also, the Status of the environment would be Environment is healthy.
    Successfully launched AWS
    Now your application has successfully launched to the cloud. Now you can open it using the URL given at the top of the Environment window.

Clean up

To avoid any incurring charges if you are done working with Elastic Beanstalk for now, you can terminate your .NET environment. To terminate your Elastic Beanstalk environment:

  1. Open the Elastic Beanstalk console, and in the Regions list, select your AWS Region
  2. In the navigation pane, choose Environments, and then choose the name of your environment from the list.
  3. Choose Environment actions and then choose Terminate environment.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on AWS using a Linux Environment

Deploy on AWS using a Linux Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Amazon Web Services > Deploy on AWS using a Linux Environment

Glossary Item Box

This page demonstrates how you can deploy your ActiveReports application on AWS using a Linux Environment.

Setup your application

  1. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.
  2. Open the application in Visual Studio and build and run the application.
  3. Remove the Reports folder containing links to the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.
  6. If you are planning to publish the application on a Linux container, it is possible that the container might not contain the fonts used by reports. We will add a custom font resolver in our ActiveReports application that we are creating. For this please refer to our documentation page Custom Font Resolver.
    1. Add a new folder Fonts in the project where we will add the required fonts.
    2. Add all the required fonts in the Fonts folder and then
      • make sure to set the Build Action of the font files to ‘Embedded Resource'.
        OR
      • add the following lines of code to the JSViewer_MVC_Core.csproj file to copy all the fonts to the build folder:
        JSViewer_MVC_Core.csproj Copy Code
        <ItemGroup>
     <Content Include="Fonts**\*.ttf**">
       <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
     </Content>
 </ItemGroup>
    3. Add the following code in the .cs file to the add the script.
      CustomFontResolver.cs Copy Code
      using GrapeCity.Documents.Text.Windows;

public sealed class CustomFontResolver : GrapeCity.ActiveReports.IFontResolver
    {
        static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
        static CustomFontResolver()
        {
            _fonts.Clear();
            var assembly = Assembly.GetExecutingAssembly();
            var fontnames = assembly.GetManifestResourceNames().Where(str => str.EndsWith(".ttf"));
            foreach (var fontname in fontnames)
            {
                Stream stream = assembly.GetManifestResourceStream(fontname);
                _fonts.Add(GrapeCity.Documents.Text.Font.FromStream(stream));
            }
            _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
        }
        public static GrapeCity.ActiveReports.IFontResolver Instance = new CustomFontResolver();
        private CustomFontResolver() { }
        GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
        {
            var fonts = new GrapeCity.Documents.Text.FontCollection();
            var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
            if (font != null) fonts.Add(font);
            fonts.Add(_fonts.DefaultFont);
            return fonts;
        }
    }

    4. In Startup.cs, specify the UseFontResolver property in the JavaScript Viewers as in the following code example.
      Startup.cs Copy Code
      app.UseReportViewer(settings =>
            {
                settings.UseFontResolver = CustomFontResolver.Instance;
                settings.UseEmbeddedTemplates(EmbeddedReportsPrefix, Assembly.GetAssembly(app.GetType()));
                settings.UseCompression = true;
            });

Setup a user in AWS

Once you have set up everything the next step is to create a user in your AWS Account. You can also visit AWS Docs for more information.

  1. Open the Sign In Page.
    Note: If you are new to AWS then Sign Up to AWS and add MFA Authentication by logging in as a Root User first.
  2. Select IAM user and enter your credentials.
  3. Now from the AWS Management Console under All Services, select IAM. This will open the IAM Dashboard.
  4. Select Users under the Access Management group
  5. Click Add users on the top right of your screen. This will open the Add user page.
  6. Set the User name. Here, for documentation purposes, we are adding 'AR_Deployment_Agent' as the username.
  7. Select the Access key-Programmatic access that gives this user programmatic access. Then click Next: Permissions.
  8. Now we will add a user to a group. Select an existing group or create a new group:
    a. Click on Create a Group option.
    b. Enter the Group Name. Here we are using 'AR_Deployment_Agents' as the group name.
    c. In the policies option, check AdministratorAccess-AWSElasticBeanstalk and IAMFullAccess.
    d. Click Create group.
  9. Click Next: Tags. Here you can add the tags that can be used in your application for now we are going to skip this.
  10. Click Next: Review. Here, you can review the user properties and then select Create user.
  11. Now copy the Access key ID and Secret access key and save it.
    Note you can also download the CSV from this page.

Setup AWS Profile in Visual Studio

Now that we have set up everything on the AWS account, let us set up our application with AWS and deploy it on the cloud.

  1. Open the JSViewer_MVC_Core sample in Visual Studio.
  2. From View, go to AWS Explorer.
    Visual Studio View AWS Explorer option
  3. In the AWS Explorer window, click the “+” icon to create a new profile.
    AWS Explorer New Account Profile
  4. Enter a Profile Name (AR_Cloud_Deploy), the saved Access Key ID, and the Secret Access Key.

    Note that you can also import the CSV if you chose to download it while creating the user account.

Publish and deploy your application

To publish your application for AWS Elastic Beanstalk, follow these steps.

  1. Right-click on the project in the Solution Explorer and click Publish to AWS Elastic Beanstalk.. option in the context menu.

    Publish to AWS Elastic Beanstalk
  2. Now in the Publish to Amazon Web Services window, set the Region. Although AWS has many different regions for this sample, we are selecting the region as US East (N. Virginia).
  3. Select Create a new application environment option and then Next.
    New AWS Application Environment
  4. Set the Application Name and the Environment Name.
    A URL should be added automatically after the previous step. You can add some other URL as well.
  5. Check the URL availability by clicking the Check availability… button. If the URL is available, “The requested URL is available” message should appear on your screen. Now, click Next.
  6. Set the Container type to 64bit Amazon Linux 2 v1.0.0 running NET Core. Now, click Next.
    Now, we must configure all our AWS Options. For the sample purposes, we are leaving most of the options as default.

    Container Type-Linux
  7. In the next Permissions window, we will select roles granting permissions to your deployed application for the service to monitor resources. Input the following values in the permissions options and then click Next.

    Deployment Application Permissions
    Role: aws-elasticbeanstalk-ec2-role

    Service Permissions
    Role: aws-elasticbeanstalk-service-role
    Service Permissions
  8. In the Application Options window, change the Project build configuration from Debug|Any CPU to Release|Any CPU.
  9. Set the Framework to net6.0.
  10. Check the Build self contained deployment bundle option and then click Next.
    Build self contained deployment bundle
  11. Go through the Review page to ensure you have selected all the required options as per your organization and application.
  12. Click Deploy.
    Once you click Deploy, it takes several minutes to create the environment and launch your ActiveReports application to the cloud.
    AWS Deploy
    Once your application is successfully launched, you will see the following Event statement in the Event’s tab in the Environment window:
    Successfully launched environment: JSViewerMVCCore-dev

    Also, the Status of the environment would be Environment is healthy.
    Successfully launched AWS
    Now your application has successfully launched to the cloud. Now you can open it using the URL given at the top of the Environment window.

Clean up

To avoid any incurring charges if you are done working with Elastic Beanstalk for now, you can terminate your .NET environment. To terminate your Elastic Beanstalk environment:

  1. Open the Elastic Beanstalk console, and in the Regions list, select your AWS Region
  2. In the navigation pane, choose Environments, and then choose the name of your environment from the list.
  3. Choose Environment actions and then choose Terminate environment.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Google Cloud

Google Cloud
See Also
DevOps > Deployment > Deploy Applications to Cloud Services > Google Cloud

Glossary Item Box

This section explains deploying on Google cloud.

Prerequisites

  • Google Cloud SDK
  • Google Cloud Tools for Visual Studio
  • .Net 8.0 SDK for Windows Environment or .Net 8.0 for Linux environment
  • Visual Studio 2022 or 2019, Visual Studio Code, or any other text editor
  • ActiveReports 19

It would also help to have basic familiarity with Google Cloud Platform (GCP), .NET Framework/.NET Core and Docker, with a GCP account to use.

See Also

Deploy on Google Cloud using a Windows Environment
Deploy on Google Cloud using a Linux Environment

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on Google Cloud using a Windows Environment

Deploy on Google Cloud using a Windows Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Google Cloud > Deploy on Google Cloud using a Windows Environment

Glossary Item Box

In this tutorial we will be deploying our JSViewer_MVC sample on Google Cloud platform using Google Compute Engine environment. The approach we are using to deploy the application is to create a VM Instance and then publish the application using Web Server (IIS).

Setup Google Cloud

  1. Sign in or create a new account on Google Cloud Platform.
  2. Go to the Project Selector in the Google Cloud Console and create a new Project.
    Here we are naming the project as JSViewer MVC.
  3. Make sure that billing is enabled for your Cloud project. Learn how to check if billing is enabled on a project.
  4. From Console, go to the API Library and enable the 'Compute Engine API'.

Setup Visual Studio

  1. Open Visual Studio 2019.
  2. Go to Extensions > Manage Extensions.
  3. Search online and install Google Cloud Tools for Visual Studio.

Setup your application

  1. Download the JSViewer_MVC sample from our WebSamples19 GitHub repository.
  2. Open the application in Visual Studio and build and run the application.
  3. Remove the Reports folder containing links the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.
  6. Run the application.

Create and configure a Compute Engine instance

  1. Navigate to Google Cloud Console from another browser tab or window, to https://console.cloud.google.com.
  2. In the Google Cloud console, go to the ASP.NET Framework Cloud Marketplace page.
  3. Click Launch.
  4. Leave the settings set to their default values and click Deploy.
    Wait for the Compute Engine instance to deploy. It usually takes about 5 minutes to deploy.
  5. Once finished, go to Compute Engine from the menu on the top left and select VM Instances. A new virtual machine should be added in the VM Instances list.
  6. Open the External IP in a new browser tab. You should also see the default IIS website served from the instance.
  7. Now we will create a Windows user and password to access the VM Instance in Visual Studio.
    1. Click on RDP >Set Windows password, then make note of the username.
    2. Copy the new Windows password and save it somewhere secure.
    3. Click Close.

Deploy the application

Now that we have configured our Compute Engine Instance, we are ready to deploy our application.

  1. In Visual Studio, go to Solution Explorer, right-click on your project and select Publish in the context menu.
    Visual Studio Solution Explorer Publish option
  2. Click on Web Server (IIS).
    Web Server (IIS)
  3. Select Web Deploy.
    Web Deploy
  4. Configure the Web Server with the following details.
    Configure Web Server (IIS) Connection
    Server | The external IP address of your Compute Engine instance. This address can be found on the VM instances page in the Cloud Console.
    Site Name Default Web Site
    Note: The site name you provide here must match the name that appears in IIS Manager on your Compute Engine instance.
    Username | The username of the Windows user account you created on your Compute Engine instance.
    Password | The password of the Windows user account you created on your Compute Engine instance.
    Destination URL | http://... . The destination URL is the address where your page will be accessible after it is deployed.
  5. Click Validate Connection.
    Because the Microsoft IIS installation in your deployment uses a self-signed certificate by default, you will see a Certificate Error during the validation process. Check the box to Save this certificate for future sessions of Visual Studio, and click Accept to accept the certificate.
  6. If your configuration is valid, click Settings. Click File Publish Options, and check Remove additional files at destination. This is important for later steps when you publish new web sites to the same Compute Engine instance.
    Publish Settings
  7. Click Publish to deploy the application.

Deploy on Google Cloud

Clean Up

To avoid incurring charges, you can delete the instances or simply stop them, although keep in mind that stopped instances can still incur costs related to storage.
You can also delete your Cloud project to stop billing for all the resources used within that project.

  1. In the Cloud console, go to the Manage resources page.
  2. In the project list, select the project that you want to delete, and then click Delete.
  3. In the dialog, type the project ID, and then click Shut down to delete the project.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy on Google Cloud using a Linux Environment

Deploy on Google Cloud using a Linux Environment
DevOps > Deployment > Deploy Applications to Cloud Services > Google Cloud > Deploy on Google Cloud using a Linux Environment

Glossary Item Box

In this tutorial we will be deploying our JSViewer_MVC_Core sample on Google Cloud platform using Google App Engine flexible environment. App Engine flexible environment is based on Linux, it is useful for .NET Core applications.

Setup Google Cloud

  1. Sign in or create a new account on Google Cloud Platform.
  2. Go to the Project Selector in the Google Cloud Console and create a new Project.
    Here we are naming the project as JSViewer MVC.
  3. Make sure that billing is enabled for your Cloud project. Learn how to check if billing is enabled on a project.
  4. From Console, go to the API Library and enable the following APIs.
    • Cloud Build API
    • Google App Engine Flexible Environment
    • App Engine Admin API
  5. Install and initialize the Google Cloud CLI.
  6. Initialize the Application in App Engine, which we can either do through the console or using the CLI:

    gcloud app create –JSViewer-MVC-Core

Setup Visual Studio

  1. Open Visual Studio 2019.
  2. Go to Extensions > Manage Extensions.
  3. Search online and install Google Cloud Tools for Visual Studio.

Setup your application

  1. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.
  2. Open the application in Visual Studio and build and run the application.
  3. Remove the Reports folder containing links the reports from the project since we will be embedding the reports in the application.
  4. Now add a new folder and name it 'Reports'.
  5. Add all the files from JSViewerReports in the Reports folder and set the Build Action as 'Embedded Resource'.
  6. Since the published docker might not contain the fonts used by reports we will add a custom font resolver in our ActiveReports application.
    1. Add a new folder Fonts in the project where we will the required fonts.
    2. Add a new .cs file 'CustomFontResolver.cs' and make sure to set the Build Action to 'Embedded Resource'.
    3. Add the following code in the .cs file to the add the script.
      CustomFontResolver.cs Copy Code
      using GrapeCity.Documents.Text.Windows;
public sealed class CustomFontResolver : GrapeCity.ActiveReports.IFontResolver
    {
        static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
        static CustomFontResolver()
        {
            _fonts.Clear();
            var assembly = Assembly.GetExecutingAssembly();
            var fontnames = assembly.GetManifestResourceNames().Where(str => str.EndsWith(".ttf"));
            foreach (var fontname in fontnames)
            {
                Stream stream = assembly.GetManifestResourceStream(fontname);
                _fonts.Add(GrapeCity.Documents.Text.Font.FromStream(stream));
            }
            _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
        }
        public static GrapeCity.ActiveReports.IFontResolver Instance = new CustomFontResolver();
        private CustomFontResolver() { }
        GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
        {
            var fonts = new GrapeCity.Documents.Text.FontCollection();
            var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
            if (font != null) fonts.Add(font);
            fonts.Add(_fonts.DefaultFont);
            return fonts;
        }
    }

    4. In Startup.cs, specify the UseFontResolver property in the JavaScript Viewers as in the following code example.
      Startup.cs Copy Code
      app.UseReportViewer(settings =>
            {
                settings.UseFontResolver = CustomFontResolver.Instance;
                settings.UseEmbeddedTemplates(EmbeddedReportsPrefix, Assembly.GetAssembly(app.GetType()));
                settings.UseCompression = true;
            });
  7. To push your application to Google App Engine, you need to specify which environment and runtime it’s going to use. To do that, you need to add an app.yaml and a dockerfile to your project file to your application.
    In a perfect world scenario, we would just need to specify that we are going to use the Flex environment and the AspNetCore runtime. However, as of now there are no images tagged for .Net 3.x or higher versions we will use an image from Microsoft Container Registry so that we can deploy our application with .Net 6.0. We will be using a docker file so we must set the runtime environment as custom in the .
    app.yaml Copy Code
    runtime: custom
env: flex

    Since we have installed the Google Cloud Tool for Visual studio extension in Visual studio 2019. This can be easily done by:

    a. Right Clicking on the project and then on Generate app.yaml and dockerfile.
    b. In the generated app.yaml change the runtime environment from aspnetcore to custom and add the following container configuration.

    app.yaml Copy Code
    runtime: custom
env: flex
manual_scaling:
     instances: 1
resources:
     cpu: 1
     memory_gb: 0.5
     disk_size_gb: 10
    Note: For testing purposes we have set the container specifications lower.

    c. Clear the dockerfile and add the following text in the docker file:

    Example Title Copy Code
    FROM mcr.microsoft.com/dotnet/sdk:6.0 AS build-env
WORKDIR /app
# Copy csproj and restore as distinct layers
COPY *.csproj ./
RUN dotnet restore
# Copy everything else and build
COPY . ./
RUN dotnet publish -c Release -o out
# Build runtime image
FROM mcr.microsoft.com/dotnet/aspnet:6.0
WORKDIR /app
COPY --from=build-env /app/out .
EXPOSE 8080
ENV ASPNETCORE_URLS=http://*:8080
ENTRYPOINT ["dotnet", "JSViewer_MVC_Core.dll"]

    On Window’s command prompt, you can create a new app.yaml in one line:

    app.yaml Copy Code
    (echo runtime: aspnetcore & echo env: flex) > app.yaml

    The app.yaml file will have to be copied over to the destination folder when you start the publishing process.
    You can include the file to the output through Visual Studio or editing the JsViewer_MVC_Core.csproj file:

    JsViewer_MVC_Core.csproj Copy Code
    <Project Sdk="Microsoft.NET.Sdk.Web">
<PropertyGroup>
    <TargetFramework>net6.0</TargetFramework>
</PropertyGroup>
<ItemGroup>
    <None Include="app.yaml" CopyToOutputDirectory="Always" />
</ItemGroup>
</Project>

Publish the Application

Now we can publish the release version our application either using Visual Studio or CLI. You can use the following command to publish the application using command prompt.

dotnet publish -c Release

To publish using Visual Studio:

  1. Right-click on the Project in Visual Studio and Click on Publish.
  2. Set the Target as 'Folder'.
  3. Set the Folder Location as: “bin\Release\net6.0\publish\”
  4. Click Finish and now Click Publish.

Deploy the application

Now that we have set up everything it is time to deploy the application.

  1. Open command prompt and set the directory as the project’s folder.
  2. Run the following command.

    gcloud app deploy

    gccloud command to deploy on Google Cloud
    It will take 10-20 minutes to deploy the application on Google Cloud.
    Once deployed you can open the deployed website using the following command:

    gcloud app browse
Deploy on Google Cloud

Clean Up

To avoid incurring charges, you can delete your Cloud project to stop billing for all the resources used within that project.

  1. In the Cloud console, go to the Manage resources page.
  2. In the project list, select the project that you want to delete, and then click Delete.
  3. In the dialog, type the project ID, and then click Shut down to delete the project.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Deploy Application Using Docker

Deploy Application Using Docker
DevOps > Deployment > Deploy Application Using Docker

Glossary Item Box

In this tutorial, we will be deploying the JSViewer_MVC_Core sample using Docker on Windows environment. Download the JSViewer_MVC_Core sample from our WebSamples19 GitHub repository.

Create Docker File

To create a docker file, follow the steps as described below:

  1. Create a file named 'Dockerfile' and add it to the above sample project (make sure no extension is added like .txt is added). See creating Dockerfile on Windows for more information.
  2. Use the .Net SDK image (Docker Official Image) and install dependencies like node.js in it.
    Copy Code
    FROM mcr.microsoft.com/dotnet/sdk:6.0 AS build
# installing node
RUN curl -sL https://deb.nodesource.com/setup_12.x | bash - \
 && apt update \
 && apt install -y nodejs
  3. Create a new working folder named 'src' and copy the files from our project in the local machine to 'src' folder. Also, install the required project dependencies and build the application using the dotnet restore and dotnet build commands, followed by dotnet publish to publish the same.
    Copy Code
    WORKDIR /src
COPY . .
ENV PATH="$PATH:/root/.dotnet/tools"
RUN dotnet restore "./JSViewer_MVC_Core.csproj"
RUN dotnet build "JSViewer_MVC_Core.csproj" -c Release -o /app/build
FROM build AS publish
RUN dotnet publish "JSViewer_MVC_Core.csproj" -c Release -o /app/publish
  4. Once done, create a working directory called 'app' and copy the contents of the published application from the layer having an alias name as 'publish' and run the application as follows.
    Copy Code
    WORKDIR /app
COPY --from=publish /app/publish .
ENTRYPOINT ["dotnet", "JSViewer_MVC_Core.dll"]

    Therefore, we now have a docker file with the following commands.

    Copy Code
    FROM mcr.microsoft.com/dotnet/sdk:6.0 AS build
# installing node
RUN curl -sL https://deb.nodesource.com/setup_12.x | bash - \
 && apt update \
 && apt install -y nodejs
WORKDIR /src
COPY . .
ENV PATH="$PATH:/root/.dotnet/tools"
RUN dotnet restore "./JSViewer_MVC_Core.csproj"
RUN dotnet build "JSViewer_MVC_Core.csproj" -c Release -o /app/build
FROM build AS publish
RUN dotnet publish "JSViewer_MVC_Core.csproj" -c Release -o /app/publish
# final stage/image
FROM mcr.microsoft.com/dotnet/aspnet:6.0-focal
RUN apt-get update; \

ENV ASPNETCORE_URLS="http://+:5000"
WORKDIR /app
COPY --from=publish /app/publish .
ENTRYPOINT ["dotnet", "JSViewer_MVC_Core.dll"]

Create an image using the above-created Docker File

Open the command prompt and build an image named 'viewerapp' from the above-created docker file and use the docker build command as follows.

Copy Code
docker build --pull -t viewerapp

The console screenshot on executing the above command is shown.

Console with the docker build command

For more information on the above command, please refer to the link: https://docs.docker.com/reference/cli/docker/buildx/build/.

Execute the above-created image inside the docker container

We will use the following docker run command and would bind the port 8090 of the host system to the container’s 5000 port where the above specified JSViewer application is running.

Copy Code
docker run -dp 8090:5000 viewerapp

The console screenshot on executing the above command is shown.

Console with the docker run command

For more information on the above command, please refer to the link: https://docs.docker.com/reference/cli/docker/container/run/

Now, try opening the localhost:8090 in the browser of the host system, the output should be as follows.

Deployed Application using Docker

Licensing the Application Deployed on Docker

You can activate the license with Pipeline License or with Standard Developer License as explained in the Licensing Build Agents/Pipelines using Command Line page.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Section 508 Compliance

Section 508 Compliance
DevOps > Section 508 Compliance

Glossary Item Box

Section 508 requires that when Federal agencies develop, procure, maintain, or use electronic and information technology, Federal employees with disabilities have access to and use of information and data that is comparable to the access and use by Federal employees without disabilities, unless an undue burden would be imposed on the agency. Section 508 also requires that individuals with disabilities seeking information or services from a Federal agency have access to and use of information and data that is comparable to that provided to the general public, unless an undue burden would be imposed on the agency.

Summary

Guideline |  | Applicable | ActiveReports Area
Section 1194.21 | Software Applications and Operating Systems | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML Viewer).
Section 1194.22 | Web-Based Intranet and Internet Information and Applications | Applicable | Web controls (HTML Viewer).
Section 1194.23 | Telecommunications Products | Not applicable | none
Section 1194.24 | Video and Multimedia Products | Not applicable | none
Section 1194.25 | Self-Contained, Closed Products | Not applicable | none
Section 1194.26 | Desktop and Portable Computers | Not applicable | none
Section 1194.31 | Functional Performance Criteria | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML Viewer).
Section 1194.41 | Information, Documentation and Support | Applicable | Documentation and Support.

Accessibility Summary:

All major features of ActiveReports software are accessible via keyboard navigation.

DISCLAIMER:

MESCIUS inc. MAKES NO WARRANTIES, EXPRESS OR IMPLIED, IN THIS DOCUMENT. The following information reflects the general accessibility features of MESCIUS inc. software components as related to the Section 508 standards. If you find that the information is not accurate, or if you have specific accessibility needs that our products do not meet, please contact us and we will attempt to rectify the problem, although we cannot guarantee that we will be able to do so in every case.

Software Applications and Operating Systems

Show Section 1194.21

Criteria | Status | Remarks
(a) When software is designed to run on a system that has a keyboard, product functions shall be executable from a keyboard where the function itself or the result of performing a function can be discerned textually. | Supported with exceptions | ActiveReports partially supports keyboard navigation. Users cannot execute report functions completely using the keyboard.
(b) Applications shall not disrupt or disable activated features of other products that are identified as accessibility features, where those features are developed and documented according to industry standards. Applications also shall not disrupt or disable activated features of any operating system that are identified as accessibility features where the application programming interface for those accessibility features has been documented by the manufacturer of the operating system and is available to the product developer. | Supported | The controls do not disrupt or disable industry standard accessibility features of other products.
(c) A well-defined on-screen indication of the current focus shall be provided that moves among interactive interface elements as the input focus changes. The focus shall be programmatically exposed so that Assistive Technology can track focus and focus changes. | Supported with exceptions | Some elements in ActiveReports cannot track focus. Focus is not exposed to screen readers like NVDA.
(d) Sufficient information about a user interface element including the identity, operation and state of the element shall be available to Assistive Technology. When an image represents a program element, the information conveyed by the image must also be available in text. | Supported with exceptions | The images representing program elements do not support alternative text. Partial support for Assistive Technology is provided for some interface elements.
(e) When bitmap images are used to identify controls, status indicators, or other programmatic elements, the meaning assigned to those images shall be consistent throughout an application's performance. | Supported | Any image used to identify a programmatic element has a consistent meaning throughout an application's performance.
(f) Textual information shall be provided through operating system functions for displaying text. The minimum information that shall be made available is text content, text input caret location, and text attributes. | Supported | Textual information such as text content, caret location, and any text attribute (i.e. bold, italic, size, color, etc.) is available for all the viewer elements.
(g) Applications shall not override user selected contrast and color selections and other individual display attributes. | Supported with exceptions | User selected contrast and color settings are not overridden, except for some minor exceptions in End User Designer.
(h) When animation is displayed, the information shall be displayable in at least one non-animated presentation mode at the option of the user. | Supported | Animated image is only used when a report is being loaded in the viewer. The users can provide a static text for the animation using the loadCompleted event of the Viewer.
(i) Color coding shall not be used as the only means of conveying information, indicating an action, prompting a response, or distinguishing a visual element. | Supported | Any interface element that uses color to indicate an action, prompt a response, or distinguish a visual element also provides a textual cue.
(j) When a product permits a user to adjust color and contrast settings, a variety of color selections capable of producing a range of contrast levels shall be provided. | Supported | ActiveReports supports a variety of colors, themes and styles that can be applied to controls in a report.
(k) Software shall not use flashing or blinking text, objects, or other elements having a flash or blink frequency greater than 2 Hz and lower than 55 Hz. | Supported | The controls do not use flashing or blinking text or objects.
(l) When electronic forms are used, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported | Any form-type dialogs or windows associated with the controls provide Assistive Technology with access to information on all directions, cues, field elements, and functionality required for completion.

Web-based Internet Information and Applications

Show Section 1194.22

Criteria | Status | Remarks
(a) A text equivalent for every non-text element shall be provided (e.g., via "alt", "longdesc", or in element content). | Supported | Each non-text element has a text equivalent.
(b) Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation. | Not applicable | ActiveReports web controls do not include multimedia.
(c) Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup. | Not applicable | ActiveReports web controls do not provide any information using color.
(d) Documents shall be organized so they are readable without requiring an associated style sheet. | Supported with exceptions | Toolbar icons in some web controls are not visible when the associated styles are disabled.
(e) Redundant text links shall be provided for each active region of a server-side image map. | Not applicable | There are no server-side image maps in ActiveReports web controls.
(f) Client-side image maps shall be provided instead of server-side image maps except where the regions cannot be defined with an available geometric shape. | Not applicable | ActiveReports does not use client-side image maps in ActiveReports web controls.
(g) Row and column headers shall be identified for data tables. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(h) Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(i) Frames shall be titled with text that facilitates frame identification and navigation. | Not applicable | By default, there are no frames associated with ActiveReports web controls.
(j) Pages shall be designed to avoid causing the screen to flicker with a frequency greater than 2 Hz and lower than 55 Hz. | Supported | ActiveReports Web controls do not contain any feature that causes page flickering.
(k) A text-only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of this part, when compliance cannot be accomplished in any other way. The content of the text-only page shall be updated whenever the primary page changes. | Not applicable | Text-only page is not available in ActiveReports WebViewer or Web controls.
(l) When a web page requires that an applet, plug-in or other application be present on the client system to interpret page content, the page must provide a link to a plug-in or applet that complies with §1194.21(a) through (l). | Not applicable | Not applicable
(m) When electronic forms are designed to be completed on-line, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported with exceptions | The components used in ActiveReports have been configured for maximum compliance. Some form controls may not support Assistive Technology.
(n) A method shall be provided that permits users to skip repetitive navigation links. | Not applicable | ActiveReports does not support repetitive navigation links.
(o) When a timed response is required, the user shall be alerted and given sufficient time to indicate more time is required. | Not applicable | Timed response is not required.

Performance Criteria

Show Section 1194.31

Criteria | Status | Remarks
(a) At least one mode of operation and information retrieval that does not require user vision shall be provided, or support for assistive technology used by people who are blind or visually impaired shall be provided. | Supported with exceptions | Partial support is provided for assistive technologies like screen readers.
(b) At least one mode of operation and information retrieval that does not require visual acuity greater than 20/70 shall be provided in audio and enlarged print output working together or independently, or support for assistive technology used by people who are visually impaired shall be provided. | Supported | ActiveReports does not require visual acuity greater than 20/70. It is exposed to magnification tools like the Screen Magnifier that can be used for magnifying the screen.
(c) At least one mode of operation and information retrieval that does not require user hearing shall be provided, or support for assistive technology used by people who are deaf or hard of hearing shall be provided. | Not applicable | ActiveReports does not use any sound output. Hearing is not necessary to use the product.
(d) Where audio information is important for the use of a product, at least one mode of operation and information retrieval shall be provided in an enhanced auditory fashion, or support for assistive hearing devices shall be provided. | Not applicable | ActiveReports does not provide functionalities that require audio or video aids.
(e) At least one mode of operation and information retrieval that does not require user speech shall be provided, or support for assistive technology used by people with disabilities shall be provided. | Not applicable | ActiveReports does not provide any functionality that make use of user speech.
(f) At least one mode of operation and information retrieval that does not require fine motor control or simultaneous actions and that is operable with limited reach and strength shall be provided. | Supported | ActiveReports does not provide any functionality that requires fine motor control or simultaneous action.

Information, Documentation and Support

Show Section 1194.41

Criteria | Status | Remarks
(a) Product support documentation provided to end-users shall be made available in alternate formats upon request, at no additional charge. | Supported | Documentation is available in four formats: HTML(Web), *.chm, *.PDF, and Help3(Visual Studio help content)
(b) End-users shall have access to a description of the accessibility and compatibility features of products in alternate formats or alternate methods upon request, at no additional charge. | Supported | ActiveReports provides information about accessibility and compatibility features in the documentation. The documentation is exposed to screen readers.
(c) Support services for products shall accommodate the communication needs of end-users with disabilities. | Supported | Support services such as telephone, email and forum support are provided to the customers.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Developers

Developers
See Also

Glossary Item Box

ActiveReports.NET is mainly a product for developers. The developers are responsible for most of the use-cases related to ActiveReports, including:

  • creating and storing reports, especially with Standard license and Code-Based Section reports.
  • binding data sources at runtime and the custom data providers the data sources.
  • creating and customizing the applications.
  • licensing the applications.
  • exporting reports applications.

Some reports creation can be delegated to independent Report Authors, otherwise this task is primarily for developers. Some customization, configuration, and deployment tasks can be delegated to DevOps too.

In this section, let's dive into the information required by developers to perform their tasks.

See Also

Report Readers
Report Readers

Report Authors
Report Authors

DevOps
DevOps

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Quick Start

Quick Start
Developers > Quick Start

Glossary Item Box

Quickly begin using ActiveReports by following the steps below.

Quick Start to ActiveReports

  1. Install ActiveReports.

  2. In Microsoft Visual Studio 2022 (version 17.0 or above), select ActiveReports 19 ASP.NET Core MVC Application template and click Next.
    Create new project in Visual Studio
    For complete list of built-in templates, see the Project Templates topic.

  3. Type a name for your project and click Create.
    Configure Visual Studio new project

  4. Select RDLX from report types and click Finish:
    • RDLX
    • RDLX Dashboard
    • Page
    • Section
      Check Report Types topic that will help you choose a report type.
  5. Open the default 'Report.rdlx' report from the 'Reports' folder and design. You can also choose to add report types from the context menu of the 'Reports' folder.
    • For information on designing a report, see Report Authors (Designer Components).
    • For information on viewing a report, see Report Readers (Viewer Components).
  6. Make sure to set the Build Action property of the report to 'Embedded resource'.

  7. Modify index.cshtml to provide the name of the report you want to preview in viewer.openReport() method:
    viewer.openReport("Report.rdlx");

    The complete index.cshtml looks as below.

    index.cshtml Copy Code
    <!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="~/jsViewer.min.css" rel="stylesheet">
    <link href="~/index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%; overflow-x: hidden">
        <div style="float:right;width:100%" id="viewerContainer">
        </div>
    </div>
    <script type="text/javascript" src="~/jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer'
            });
            viewer.openReport("Report.rdlx");
        }
    </script>
</body>
</html>

    In Startup.cs, the root directory containing the report is resolved using config.UseFileStore(rootDir). The complete Startup.cs looks like below.

    Startup.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using Microsoft.AspNetCore.Builder;
using Microsoft.AspNetCore.Hosting;
using Microsoft.Extensions.DependencyInjection;
using Microsoft.Extensions.Hosting;
using Microsoft.Extensions.Logging;
using System;
using System.IO;
namespace ActiveReportsCoreMVCApplication
{
    public class Startup
    {
        // This method gets called by the runtime. Use this method to add services to the container.
        public void ConfigureServices(IServiceCollection services)
        {
            services
                .AddLogging(config =>
                {
                    // Disable the default logging configuration
                    config.ClearProviders();
                    // Enable logging for debug mode only
                    if (Environment.GetEnvironmentVariable("ASPNETCORE_ENVIRONMENT") == Environments.Development)
                    {
                        config.AddConsole();
                    }
                })
                .AddReportViewer()
                .AddMvc(option => option.EnableEndpointRouting = false);
        }
        // This method gets called by the runtime. Use this method to configure the HTTP request pipeline.
        public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
        {
            if (env.IsDevelopment())
            {
                app.UseDeveloperExceptionPage();
            }
            app.UseReportViewer(settings =>
            {
                var reportsFolder = Path.Combine(env.ContentRootPath, "Reports");
                settings.UseFileStore(new DirectoryInfo(reportsFolder));
            });
            app.UseStaticFiles();
            app.UseMvc();
        }
    }
}
  8. Run the application. The report opens in the JSViewer.
    Default Run-Time Report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Breaking Changes

Breaking Changes
Developers > Breaking Changes

Glossary Item Box

Breaking changes from ActiveReports 18 to ActiveReports 19

Dropped Microsoft Visual Studio 2017 Support

ActiveReports 19 is not supported in Microsoft Visual Studio 2017. You should have Microsoft Visual Studio 2019 or 2022 installed.
Upgraded ActiveReports to use .NET Framework 4.7.2 from 4.6.2

Since .NET Framework 4.7.2 provides enhanced support for .NET Standard 2.0, we have upgraded ActiveReports to use 4.7.2 instead of 4.6.2. As a result, we removed implicit conversion between System.Drawing.Image and GrapeCity.ActiveReports.Document.Drawing.Image. If you work extensively with images, this change may lead to performance issues. Now the conversions should be done on the client’s side as shown in the following example:

Copy Code
public static Document.Drawing.Image ToInternalImage(this System.Drawing.Image image)
{
    using (var ms = new MemoryStream())
    {
        image.SaveToStream(ms);
        return GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(ms);
    }
}

public static System.Drawing.Image ToGdiImage(this GrapeCity.ActiveReports.Document.Drawing.Image image)
{
    using (var ms = new MemoryStream(image.Data)) return System.Drawing.Image.FromStream(ms);
}

To ensure you are not stuck, update projects to .NET Framework 4.7.2 or .NET (formerly .NET Core).

Dropped Excel 95 (BIFF7) from the supported export formats

Following changes have been made:

MESCIUS.ActiveReports.SpreadBuilder.dll

  • The obsolete FileVersion property in GrapeCity.SpreadBuilder.Workbook class is now internal.
  • Enum GrapeCity.SpreadBuilder.BiffVersion is now internal.
  • Removed Xls95 value from enum GrapeCity.SpreadBuilder.FileFormat.

MESCIUS.ActiveReports.Export.Excel.dll

Removed Xls95 value from enum GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.

MESCIUS.ActiveReports.Web.dll

Removed Xls95 value from enum GrapeCity.ActiveReports.Web.XlsExportSettings.FileFormats.

Since the Microsoft Excel 95 (BIFF7) export is no more supported, you should use Microsoft Excel 97 instead.

Removed DbConnectionAdapter class

GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.DbConnectionAdapter class from MESCIUS.ActiveReports.dll is converted from public to internal.

You should implement IDbConnectionAdapter and if necessary, any of IDbCommandParametersAdapter, IDbConnectionAdapterWithDataSource, and IDbCommandAdapterWithCache.

Renamed DataEngine assemblies and packages

Renamed following assemblies and corresponding packages:

  • MESCIUS.Data.DataEngine → MESCIUS.ActiveReports.Core.Data.DataEngine
  • MESCIUS.Data.ExpressionInfo → MESCIUS.ActiveReports.Core.Data.ExpressionInfo
  • MESCIUS.Data.VBFunctionLib → MESCIUS.ActiveReports.Core.Data.VBFunctionLib

Removed DataProviderInfo classes from the viewer and designer backends

Following classes have been removed:

  • GrapeCity.ActiveReports.Web.Designer
  • GrapeCity.ActiveReports.Web.Viewer

The corresponding methods' signatures that have been changed are:

GrapeCity.ActiveReports.Web.Viewer.ReportViewerConfiguration.UseDataProviders(GrapeCity.ActiveReports.Web.Viewer.DataProviderInfo[]) → GrapeCity.ActiveReports.Web.Viewer.ReportViewerConfiguration.UseDataProviders(GrapeCity.ActiveReports.Configuration.DataProviderInfo[])

GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration.UseDataProviders(GrapeCity.ActiveReports.Web.Designer.DataProviderInfo[]) → GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration.UseDataProviders(GrapeCity.ActiveReports.Configuration.DataProviderInfo[])

Ensure adding ‘using GrapeCity.ActiveReports.Configuration;’ directive in the web application setup class where the UseDataProviders method is used.
Changed Type of some properties in PageReportModel
The Type for following properties is changed from ExpressionInfoCollection to IList<ExpressionInfo>
  • Changed type of the GroupExpressions property in the GrapeCity.ActiveReports.PageReportModel.Grouping class
  • Changed type of the Values property in the GrapeCity.ActiveReports.PageReportModel.DefaultValue class
  • Changed type of FilterValues property in class GrapeCity.ActiveReports.PageReportModel.Filter
Example Copy Code
class GrapeCity.ActiveReports.PageReportModel.Filter
{
  //...
  ExpressionInfoCollection FilterValues {get;}
}
//changed to
class GrapeCity.ActiveReports.PageReportModel.Filter
{
  //...
  IList<ExpressionInfo> FilterValues {get;}
}
This change has no impact on our users.
Changed Themes API in JS Viewer and Web Designer

The Themes API for both WebDesigner and JS Viewer has been unified under ActiveReports.ColorThemes. You can use any module '@mescius/activereportsnet-designer' and ' @mescius/activereportsnet-viewer' to export theme object and apply it in the viewer and webdesigner.
You are required to update code to make older applications work in ActiveReports.NET 19.
Implemented new Chart model

The Chart API has been reworked in order to improve flexibility and configurability of charts.

The charts in the reports created from previous ActiveReports versions 18, 17, and 16, when opened in ActiveReports 19 Designer, are automatically converted to a new chart model. The results are usually the same; in rare scenarios, manual updates may be required.

If charts in the previous versions have been generated using the Chart API, they will require manual migration and code updation to give the same results in ActiveReports.NET 19.

For breaking changes upto previous version, see the documentation page of ActiveReports 18.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveReports Version Compatibility and Migration

ActiveReports Version Compatibility and Migration
See Also
Developers > ActiveReports Version Compatibility and Migration

Glossary Item Box

ActiveReports 19 supports the side-by-side installation with previous versions and allows to migrate from version to version.

We recommend that you follow certain rules for migrating from one version to another. In case of any question, please contact our Support Team by using any of these channels:

Web site | https://developer.mescius.com/support/contact
E-mail | activereports.sales@mescius.com
Note: As not all old versions of ActiveReports are supported, you should check migration possibilities without delay. This will help us fix problems that may appear.

Migration Rules

  • Perform migration in testing branches. Do not migrate in production without a possibility to roll back.
  • We recommend that you first use the ActiveReports Upgrade tool.
    Visual Studio Convert to ActiveReports Option
    This tool upgrades reports and links but it cannot process:
    • JS code/dependencies
    • Some breaking changes
    • Some problems in Web environments
  • Verify affected functions and breaking changes.
  • Contact our Support Team in case of any problem.

See Also

Compatibility of Visual Studio Integrated Designers
Upgrade Reports and References

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Compatibility of Visual Studio Integrated Designers

Compatibility of Visual Studio Integrated Designers
Developers > ActiveReports Version Compatibility and Migration > Compatibility of Visual Studio Integrated Designers

Glossary Item Box

ActiveReports 19 can be installed and used on the same machine in which other older versions of ActiveReports for .NET (except ActiveReports 13) have been installed.

Compatibility of ActiveReports Visual Studio Integrated Designers with Visual Studio

ActiveReports Visual Studio integrated designer of different versions can be used by integrating the designer with Visual Studio IDE (Integrated development environment). The following table shows the Visual Studio versions corresponding to the integrated designer versions that are supported.

 | VS 2013 | VS 2015 | VS 2017 | VS 2019 | VS 2022
ActiveReports 14 | ○ | ○ | ○ (VS SP2+) | ○ | ×
ActiveReports 15 | × | ○ | ○ (VS SP2+) | ○ | ×
ActiveReports 16 | × | × | ○ (VS SP2+) | ○ | ○
ActiveReports 17 | × | × | ○ (VS SP2+) | ○ | ○
ActiveReports 18 | × | × | ○ (VS SP2+) | ○ | ○
ActiveReports 19 | × | × | × | ○ | ○

To switch the designers of versions prior to ActiveReports 13, use the switcher tool. See ActiveReports 13 help file for more information.

Starting from ActiveReports 14, you should use the Visual Studio menu to enable/disable the ActiveReports integration.

Manage Visual Studio Integration

In case you want to disable or uninstall ActiveReports 19 Visual Studio integration, do the following.

  1. In Visual Studio, go to Extensions > Manage Extensions.
  2. Navigate to ActiveReports 19 VS2022 and click Disable or Uninstall.

Extensions and Update window

In case you want to install the integration again, follow these steps.

  1. Go to the installation folder - C:\Program Files\MESCIUS\ActiveReports 19\VisualStudio (C:\Program Files (x86)\MESCIUS\ActiveReports 19\VisualStudio on a 64-bit Windows operating system).
  2. Run the VSIX as per your Visual Studio Version.

Note:

  • It is not possible to use different versions of ActiveReports for .NET within a single Visual Studio project.
  • When using our Integrated Designer in Visual Studio 2022, you may observe invisible controls in our smart panels or tool windows (such as Report Explorer or Layers List). To solve this issue, navigate to Tools > Options > Environment > General and clear the 'Optimize rendering for screens with different pixel densities' checkbox.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Upgrade Reports and References

Upgrade Reports and References
See Also
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References

Glossary Item Box

Generally, there are just a few breaking changes between ActiveReports versions. However, advanced use cases often require manual upgrade. We recommend that you start by using the ActiveReports Upgrade tool that converts links and reports (see ActiveReports File Converter). After that, you should do the following:

  • Manually upgrade links if necessary.
  • Manually upgrade namespace/code changes.
  • Manually upgrade JS dependencies and JS code.
  • Contact the Support Team in case of any problem.

See Also

Migrate to ActiveReports 19
Reference Migration
Web Viewer Migration
Migrate to .NET Core
ActiveReports File Converter
ActiveX Viewer Migration
Migrate from ActiveReports 2 COM

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveReports File Converter

ActiveReports File Converter
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > ActiveReports File Converter

Glossary Item Box

The ActiveReports file converter allows you to upgrade your existing reports from previous versions of ActiveReports to the latest version.

To use the file converter

  1. In Visual Studio, open an existing ActiveReports project.
    Caution: If you are migrating a project from a different version of Visual Studio, a Visual Studio conversion wizard will run automatically to convert the project.
  2. From the Visual Studio Tools menu, select Convert to ActiveReports 19. In the ActiveReports 19 Upgrade tool window that appears, you can see a list of report files to be converted.

    Convert to ActiveReports 17 in the Tools menu

    Visual Studio Convert to ActiveReports option
    File Type | Extension
    Report file | *.rpx, *.vb, *.cs
    Form with a viewer | *.vb, *.cs, *.xaml
    ASP.NET Web Form with a WebViewer | *.aspx, *.aspx.vb, *.aspx.cs
    Project file | *.vbproj, *.csproj, Web.confg
    License file | licenses.licx
    Package.json file | package.json
    Packages.config file | packages.config
  3. Click OK to convert the files. After the files are successfully converted, all of the reference files are updated and the reports are converted to C# or Visual Basic class files. The old files are copied to ARConverterBackup folder generated under the root folder of the project. You can delete these files from the project if you do not need them.
    Caution: When converting from version 6 or below, you may observe the following warnings on migrating a form with the viewer control. These warnings are due to API modifications in ActiveReports 7 or above. You can ignore these warnings or delete them manually.
    • 'Public Property Text() As String' is an old format: 'Not used anymore'
    • 'Public Property TabTitleLength() As Integer' is an old format: 'Not used anymore'
    Note: In addition to the above conversions, you may also observe some formatting changes, such as code breaks, while using this converter tool.
  4. After running the converter, you need to manually update all the project references. For more details, see Upgrade Reports and References.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Migrate to ActiveReports 19

Migrate to ActiveReports 19
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > Migrate to ActiveReports 19

Glossary Item Box

ActiveReports 19 has several major breaking changes, so you should consider this information while migrating to ActiveReports 19.

If you are going to migrate from very old versions of ActiveReports, please see corresponding User Guides or contact our Support Team.

The following steps explain basic step to migrate previous ActiveReports versions to ActiveReports 19.

  1. From the Visual Studio Tools menu, select Convert to ActiveReports 19. For more details, see ActiveReports File Converter
    You will also need to manually update the references/dependencies. For more details, see Reference Migration.
    If the license information is not displayed correctly after running the converter, you need to manually update the license information. For more details, see License ActiveReports.
  2. See details below to migrate any of the following versions that contain specific classes or properties:

    ActiveReports 1

    If you export to PDF and use the Version property, you need to change the casing in the PdfVersion enumerated values as follows.

    Before migration: PDFVersion.PDF13
    After migration: PdfVersion.Pdf13

    If you are using the public variable 'ds' within the report, see ds Variable.
    If you are using the WebViewer control, see WebViewer Migration.
    If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    ActiveReports 2

    If you are using the public variable 'ds' within the report, see ds Variable.
    If you are using the WebViewer control, see WebViewer Migration.
    If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    ActiveReports 3

    If you are using the ActiveReport3 class in your project, you need to change ActiveReport3 class to SectionReport class.

    Before migration: DataDynamics.ActiveReports.ActiveReport3
    After migration: GrapeCity.ActiveReports.SectionReport

    If you are migrating from an initial version of ActiveReports 3 and use the Barcode control's Style and BackColor properties, then the size of the Barcode control may change on migration. You can set the BackColor property of the Barcode control to White, or manually change the size.

    Property | Value
    Style | QRCode, Code49, JapanesePostal, Pdf417, EAN128FNC1 (Any of these)
    BackColor | System.Drawing.Color.Transparent

    If you are using the public variable 'ds' within the report, see ds Variable.
    If you are using the WebViewer control, see WebViewer Migration.
    If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    From ActiveReports 6 to ActiveReports 19

    If you are using the WebViewer control, see WebViewer Migration.

  3. Update the package.json file.
  4. From the Build menu, select Rebuild Solution to rebuild the entire solution.
    Note: Between versions 1 and 18, we have updated several class names and package names. This may cause syntax errors on migration. To resolve these errors, see the Breaking Changes topic.

Migrating ds Variable

In ActiveReports 2 or below, when you create a data connection using the Report Data Source dialog, a public variable 'ds' is generated automatically by the report designer. This variable is not generated in ActiveReports 3 or above. If you use this variable in your code for making data connection settings of subreport, you need to change the code as follows.

To migrate code with public variable 'ds'

Before migration

Visual Basic Copy Code
Me.ds.ConnectionString

C# Copy Code
this.ds.ConnectionString;

After migration

Visual Basic Copy Code
CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString

C# Copy Code
((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Migrate from ActiveReports 2 COM

Migrate from ActiveReports 2 COM
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > Migrate from ActiveReports 2 COM

Glossary Item Box

The reports in ActiveReports 2 COM, which is ActiveX version of ActiveReports, are saved in DSR/DSX format unlike .NET versions which saves report layouts in the XML based RPX format. Therefore, to migrate from ActiveReports 2 COM to ActiveReports for .NET, you need to save reports in ActiveReports 2 COM as .rpx file and embed it in your .NET project. When you save the report layout as .rpx, ActiveReports only saves the code in the script editor. Any code behind the report is not saved to the RPX file, therefore, the code in the .cs or .vb file needs to be re-written.

Embedding an RPX file in a Visual Studio Project

Note: Adding an ActiveReports 2 COM report layout file (.rpx) directly to a project is not supported. Be sure to migrate using the following steps.
  1. From the Solution Explorer, select the project in which you want to add the item.
  2. From the Project menu, select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Section, and then Finish.
  4. From the Extensions menu > Report, select the Load Layout option.
  5. Navigate to the location of the .rpx file, select the .rpx file, and click Open.
    Note:
    • Script codes such as Visual Basic and C# are not imported properly.
    • The border shadow (Border.Shadow property) is not migrated.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Reference Migration

Reference Migration
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > Reference Migration

Glossary Item Box

ActiveReports uses NuGet/NPM to publish components since ActiveReports 14. We cannot manage all references without problems in our converter, so please remove extra NuGet packages and fix NPM references/dependencies.

If you are going to update references manually, please follow this plan:

  • Remove all ActiveReports NuGet/NPM references.
  • Add only important references (other references will be added automatically):
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports to use only .NET API and packages MESCIUS.ActiveReports.Export.[Excel/Word/Pdf/Xml/Html/Image] to use corresponding exports.
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Serializer or https://www.NuGet.org/packages/MESCIUS.ActiveReports.Serializer.VS2022 to design code-based Section reports under .NET Framework 4.7.2-4.8.1. Please note that it is better to remove such dependencies from the final application.
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Viewer.Win or https://www.NuGet.org/packages/MESCIUS.ActiveReports.Viewer.Wpf to use only the Desktop Viewer (without Designer).
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Design.Win to use the Desktop Designer.
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Aspnetcore.Viewer or https://www.NuGet.org/packages/MESCIUS.ActiveReports.Aspnet.Viewer to use Blazor/JS viewers, https://www.NuGet.org/packages/MESCIUS.ActiveReports.Blazor.Viewer or https://www.npmjs.com/package/@mescius/activereportsnet-viewer as client.
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Aspnetcore.Designer or https://www.NuGet.org/packages/MESCIUS.ActiveReports.Aspnet.Designer to use Blazor/JS designer + https://www.NuGet.org/packages/MESCIUS.ActiveReports.Blazor.Designer or https://www.npmjs.com/package/@mescius/activereportsnet-designer as client.
    • https://www.NuGet.org/packages/MESCIUS.ActiveReports.Web to use ASP.NET WebForms viewer + https://www.NuGet.org/packages/MESCIUS.ActiveReports.Web.Design or https://www.NuGet.org/packages/MESCIUS.ActiveReports.Web.Design.VS2022 to enable ASP.NET WebForms designer. Please note that it is better to remove design-time dependencies from the final application.
  • Check the JS code manually.
  • Update the license (“licenses.licx”, “.gclicx” and other places).
  • Try to fix other issues. In case you are unable to fix the issues, please contact our Support Team.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Web Viewer Migration

Web Viewer Migration
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > Web Viewer Migration

Glossary Item Box

This topic explains how to upgrade the WebViewer control.

The ASP.NET Web form or the Web.config file included in the WebViewer control is upgraded automatically on running the ActiveReports file converter. However, the converter does not upgrade the Flash viewer since flash viewer is obsolete.

The license file should also get updated while conversion, but in some cases due to the project configuration, you may need to manually update the license file. For more information on upgrading license, see License ActiveReports.

You may run into problems while migrating in Web due to the following reasons:

  • No more Flash application framework support
  • No more Silverlight application framework support
  • New Server API since ActiveReports 13
  • New JS API since ActiveReports 15

Hence, to perform the Web Viewer migration, ensure following:

  • Check for any web related breaking changes.
  • If you are using old technologies (like Silverlight), we suggest migrating to Blazor.
  • If JS API does not work, check the new JS Viewer API and Web Samples and restore functions.
  • Contact our Support Team for help.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ActiveX Viewer Migration

ActiveX Viewer Migration
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > ActiveX Viewer Migration

Glossary Item Box

This topic explains how to migrate the ActiveX viewer included in ActiveReports 3, 2, and 1.

Migration Requirements

In ActiveReports 6 or above, ActiveX viewer (ARVIEW2.CAB) is not provided with the product installer. You need to migrate a web application that includes ActiveX viewer on the Web form or contains the WebViewer with ViewerType property set to ActiveXViewer. In ActiveReports 19, you can use the PDF export feature instead of ActiveX Viewer.

To migrate project that uses ActiveXViewer as the ViewerType

If the ViewerType property is set to ActiveXViewer, you need to change it to AcrobatReader. For example, modify the code marked in red like the following code.

Before migration

Visual Basic Copy Code
' Set the type of the selected view in ViewerType property of the WebViewer.
Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
Select Case selection
  Case "AcrobatReader"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.AcrobatReader
  Case "ActiveX viewer"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.ActiveXViewer
  Case "HTML viewer"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.HtmlViewer
  Case "RawHtml"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.RawHtml
End Select

C# Copy Code
// Set the type of the selected view in ViewerType property of the WebViewer.
{
    string selection = this.cboViewerType.Items(this.cboViewerType.SelectedIndex).Text;
    switch (selection) {
        case "AcrobatReader":
            this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.AcrobatReader;
            break;
        case "ActiveX viewer":
            this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.ActiveXViewer;
            break;
        case "HTML viewer":
            this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.HtmlViewer;
            break;
        case "RawHtml":
            this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.RawHtml;
            break;
    }
}

After migration

Visual Basic Copy Code
' Set the type of the selected view in ViewerType property of the WebViewer.
 Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
 Select Case selection
  Case "AcrobatReader"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader
  Case "HTML viewer"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer
  Case "RawHtml"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml
 End Select

C# Copy Code
// Set the type of the selected view in ViewerType property of the WebViewer.
{
     string selection = this.cboViewerType.Items(this.cboViewerType.SelectedIndex).Text;
     switch (selection) {
         case "AcrobatReader":
             this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader;
             break;
         case "HTML viewer":
             this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer;
             break;
         case "RawHtml":
             this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml;
             break;
     }
 }

To migrate project that uses PDF Export

Re-create the application by referring the following basic operation or sample. Note that you don't need to re-create everything.
The basic difference between ActiveX viewer and PDF export is in the format of the data received from the web server to the client. An RDF file is generated on the Web server with ActiveX viewer and binary data of PDF format is created on the web server with PDF export. The other operations are common in ActiveX viewer and PDF export, there is no need to re-create the existing applications that are created using the ActiveX viewer. See CustomPreview sample for more information.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Migrate to .NET Core

Migrate to .NET Core
Developers > ActiveReports Version Compatibility and Migration > Upgrade Reports and References > Migrate to .NET Core

Glossary Item Box

An existing ActiveReports application can be migrated to a .NET Core version by following these simple steps provided on MSDN page. To migrate ActiveReports application to .NET 8/.NET 9, you need Visual Studio 2022 with .NET 8/.NET 9 installed.

The following steps consider an ActiveReports 15 WinViewer desktop application as a sample .NET Framework project that needs to be migrated to .NET 8/.NET 9 platform. The sample can be found on GitHub.

For more information, please refer to the following Microsoft documentation:

  • Overview of porting from .NET Framework to .NET Core

Upgrade the project to ActiveReports 19
(skip this if you are already in ActiveReports 19)

  1. Open the \Desktop\WinViewer\C#\WinViewer.sln file in Visual Studio 2022 v17.8+.
  2. Convert the project to ActiveReports 19 by running the 'Convert to ActiveReports 19' tool.
    Convert to ActiveReports 17

    Analyze Portability
    (this step is for the analysis purpose to see if the assemblies are portable to .NET Core; it can be skipped)

  3. Click on Extensions > Manage Extensions and in the Manage Extensions dialog, search for '.NET Portability Analyzer' and download it. You may need to reopen the project for VSIX installer to run.
  4. Right-click on the WinViewer solution and click 'Analyze Assembly Portability'.
    Analyze Assembly Portability
  5. Save the Analysis report on your system and open it to analyze the portability details of your project.
    Save analysis report

    Migrate to .NET 6/.NET 7/.NET 8 platform

  6. Right-click 'packages.config' in the project, click 'Migrate packages.config to PackageReference..' and press OK.
    Migrate config
    You will see a NuGet migration log page with details.
  7. Right-click the project and select 'Unload Project'. Double-click 'WinViewer' in the Solution Explorer to view WinViewer.csproj file.

  8. Remove the content of the WinViewer.csproj file and copy it in a text file so that the file appears blank and you have its backup in a text file.
  9. Add the following code to blank WinViewer.csproj file to change it to project SDK type.

    Note: The OutputType is "library" because the project is a class library project. Also, 'auto-generate assembly info' should be turned off.
    .csproj Copy Code
    <Project Sdk="Microsoft.NET.Sdk">
<PropertyGroup>
<OutputType>library</OutputType>
<TargetFramework>net8.0-windows</TargetFramework>
<GenerateAssemblyInfo>false</GenerateAssemblyInfo>
</PropertyGroup>
</Project>
  10. Find the text "PackageReference" in the backup text file and copy the whole <ItemGroup> inside <Project> to WinViewer.csproj file. The final WinViewer.csproj will look like below:
    .csproj Copy Code
    <Project Sdk="Microsoft.NET.Sdk">
  <PropertyGroup>
    <OutputType>library</OutputType>
    <TargetFramework>net8.0-windows</TargetFramework>
    <GenerateAssemblyInfo>false</GenerateAssemblyInfo>
    <ApplicationIcon />
    <StartupObject />
  </PropertyGroup>
<ItemGroup>
    <PackageReference Include="MESCIUS.ActiveReports.Chart.Win">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Rdf">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Excel">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Html">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Image">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Pdf">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Word">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Export.Xml">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Design.Win">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Core.DataProviders.Excel">
      <Version>1.0.0-alpha-114</Version>
    </PackageReference>
    <PackageReference Include="MESCIUS.ActiveReports.Viewer.Win">
      <Version>18.0.0-beta-2687</Version>
    </PackageReference>
    <PackageReference Include="System.Data.SQLite.Core">
      <Version>1.0.118</Version>
    </PackageReference>
    <PackageReference Include="System.Text.Encoding.CodePages">
      <Version>6.0.0</Version>
    </PackageReference>
    <PackageReference Include="System.Resources.Extensions">
      <Version>6.0.0</Version>
    </PackageReference>
  </ItemGroup></Project>
  11. Right-click the project in Solution Explorer and click on Reload project. You may see version errors for 'Compile Time Assemblies'. Resolve them by manually correcting the version as suggested in the window.
  12. Build the project to observe that the build is successful and the project has been successfully migrated to .NET 6/.NET 7/.NET 8 platform.
    Successful project migration

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


License ActiveReports

License ActiveReports
Developers > License ActiveReports

Glossary Item Box

Users can access the MESCIUS License Manager utility to license ActiveReports at the time of installation or if there is already a trial version installed.
To use ActiveReports development environments, you should buy a corresponding license. A common run-time license is embedded into the application with a general .NET mechanism - the licenses.licx file. You should update references in the file to use new ActiveReports versions.

Note: ActiveReports allows generating the embeddable license resource .gclicx that you should regenerate manually for any new ActiveReports version.
The following sub-topics give an overview of all aspects of the licensing procedure in ActiveReports.NET.
  • License Types
  • Upgrading License from Trial to Purchase
  • Licensing a Developer Machine
  • Licensing a Project
  • Licensing Compiled Code
  • Licensing Build Agents/Pipelines using Command Line
  • Offline Licensing with Command Line
  • Submitting a Reactivation Request
  • Fixing Licensing Errors
  • Contacting Support

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


License Types

License Types
See Also
Developers > License ActiveReports > License Types

Glossary Item Box

ActiveReports provides three licensing options to choose from. The ActiveReports Editions page elaborates on features exclusive to Standard and Professional Editions, so you should check which license best suits your needs.
License Type | Description
Evaluation | Trial key is required. Evaluation banners display on all reports and controls, and the product stops functioning after 30 days from the date of installation. The first key is already activated when you download the trial. If needed, you can request a new key from the Sales department for an additional 30 day trial.
Standard | Standard Edition product key is required. Evaluation banners appear only on features that are exclusive to the Professional Edition. You receive this key by email when you purchase ActiveReports Standard Edition or upgrade from a previous version of ActiveReports Standard Edition.
Professional | Professional Edition product key is required. All reporting functionality and controls appear without any evaluation banners. You receive this key by email when you purchase ActiveReports Professional Edition or upgrade from a previous version of ActiveReports Professional Edition.

If you cannot find your email with the product key, please contact activereports.sales@mescius.com to have it looked up.

See Also

DevOps
Compare ActiveReports Editions

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Upgrading License from Trial to Purchase

Upgrading License from Trial to Purchase
Developers > License ActiveReports > Upgrading License from Trial to Purchase

Glossary Item Box

ActiveReports.NET provides a trial version to test out and evaluate all features of the Professional Edition for a total of 30 days without a product key. To completely use the benefits of ActiveReports for production, you need to upgrade the license from trial to purchase, which can be done by purchasing a product key (Standard or Professional Edition). After purchasing the license, the user can activate the key using MESCIUS License Manager. For detailed steps, refer to the Licensing a Developer Machine topic.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Licensing a Developer Machine

Licensing a Developer Machine
See Also
Developers > License ActiveReports > Licensing a Developer Machine

Glossary Item Box

In order to open and effectively run ActiveReports.NET or compile ActiveReports projects in Visual Studio, the user needs to license the developer machine. In this topic, we'll cover licensing a machine (or multiple machines) with ActiveReports during installation, and deactivation of ActiveReports license. In this topic, we will be using MESCIUS License Manager tool (gclm). If ActiveReports or any MESCIUS inc. product is installed, then the gclm tool is already installed at C:\ProgramData\GrapeCity\gclm.

You can download the gclm deployment tool:

  • Windows: https://cdn.mescius.com/license/gclm_deploy.exe
  • Linux/MacOS: https://www.nuget.org/packages/GrapeCity.LicenseManagerTool/ or you may install the gclm tool from command line:

    dotnet tool install -g GrapeCity.LicenseManagerTool
Note: Always run the License Manager as an Administrator.

License ActiveReports during installation or Upgrade license from trial to purchase

  1. Go to the Start menu and select MESCIUS License Manager to open the licensing manager window. This window appears automatically during the product installation.
  2. In the MESCIUS License Manager window, click Activate.
  3. Enter the serial key you have received from MESCIUS (including all the capital letters and special characters), and click Activate.
    Online license activation
  4. An activation message appears on the window. Click OK to complete the licensing process.
    To see the license details, such as the license type (Trial or Product), edition (Professional or Standard), and date of activation and expiry, click Details in the licensing window.

License ActiveReports on a machine without an internet connection

  1. Go to the Start menu and select MESCIUS License Manager to open the licensing manager window. This window appears automatically during the product installation.
  2. In the MESCIUS License Manager window, if you try to enter the serial key and click Activate, a network error is shown on the window. So, in such a case, click Offline Activate to proceed further with the licensing process.
    Offline license manager activation
  3. Copy the Activation Key from the MESCIUS License Manager window.
    Offline Activation dialog box
  4. Visit the following website https://sa2.mescius.com on the other machine (with an internet connection), and click Activation to use offline Activation key to activate the license.
    Note: Do not close the activation dialog on your original machine until the activation process is completed.

    MESCIUS License Service Page
  5. Enter the Activation Key you have copied in step 3 on the website, and click Activate again.
    Entering the Activation Key
  6. After a successful activation on the website, copy the License Data from the website and paste it in the licensing window.
    Add License Data
  7. Click Activate and then OK to complete the licensing process.

    If you want to use the command line tool to license ActiveReports, see Offline Licensing with Command Line topic.

Activate a license for ActiveReports on multiple machines

You can activate a single developer license key for ActiveReports on three machines for use by one developer.

If you have used all three license activations and you wish to license a fourth machine, for example, a virtual machine for use by the same licensed developer, then you must deactivate the license key from one of the three machines. For more information on this, see the below section on deactivating the ActiveReports license.

After you have deactivated licensing on one of the machines, you can then activate ActiveReports on the other machine.

Deactivate ActiveReports license

When you have used all the three of your license activations and you still want to license an another machine for your own use. So, in such a case you can deactivate an ActiveReports license on any of three machines to license the fourth machine.

Follows these steps to deactivate an ActiveReports license on a machine:

  1. Go to the Start menu and select MESCIUS License Manager to open the licensing manager window.
  2. In the MESCIUS License Manager window, click Deactivate.
    Online license Deactivation
  3. On the Deactivation page, click Deactivate again to confirm the deactivation process.
  4. Click OK to complete the deactivation process.

Deactivate ActiveReports license on a machine without an internet connection

Sometimes, the developer using the MESCIUS license might need to switch to a new machine. In this case, if the new machine does not have an active internet connection or there is some network issue, then the steps described in this section should be followed to deactivate the license.

  1. Launch the MESCIUS License Manager tool (C:\ProgramData\GrapeCity\gclm\gclm.exe) and click Deactivate corresponding to the product version you want to deactivate.
    The license manager fails to deactivate the serial key due to no internet connection, and shows a network error.
  2. Click the Offline Deactivate button.
    Deactivation Network Error
  3. The Offline Deactivation window appears with instructions as shown in the following image.

    Deactivation Key

    The steps for proceeding with the deactivation process are demonstrated as follows:

  4. On a machine with an active internet connection, go to https://sa2.mescius.com/.
    MESCIUS License Service Page
  5. Copy the Deactivation key from the offline machine and send it via file transfer to another internet-connected system.
  6. On the https://sa2.mescius.com/ website, click the Deactivation option to see a Deactivation window. Copy the deactivation key from step 2 and paste it into the Deactivation Key box.
    MESCIUS License Deactivation

  7. On successful deactivation, the "Deactivated Successfully" message appears.

Determine whether a machine is licensed

  1. Open any Sample in Visual Studio from the included samples and click the Preview tab.
  2. Scroll to the bottom of the report and check for any red evaluation text. If there are any, it means your machine is not licensed.
Note: To check for Professional Edition licensing, open a sample from the Designer Pro folder, run it, and look for the evaluation messages.

See Also

Offline Licensing with Command Line
Submitting a Reactivation Request

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Licensing a Project

Licensing a Project
See Also
Developers > License ActiveReports > Licensing a Project

Glossary Item Box

Tips:

  • To deploy using XCOPY, you must include the DLLs for all of your ActiveReports references in your bin/debug folder. To do this, in the Visual Studio Solution Explorer, select each reference, and in the Properties window, set Copy Local to True and rebuild your solution.
  • To avoid having to change the version number each time you install an ActiveReports service pack. You need to select each reference in the Visual Studio Solution Explorer, and in the Properties window, set Specific Version to False.

License Windows Forms projects made on the trial version

These steps assume that you have an ActiveReports licensed edition installed on your system.

  1. Open the project in Microsoft Visual Studio.
    Note: If another application calls the one containing ActiveReports features, you must license the calling application to avoid evaluation banners after deployment.
  2. In Visual Studio, go to the Build menu and select Rebuild Solution.
  3. To verify that the application is licensed, open the licenses.licx file and compare it to the Required references section below.

The executable application is now licensed, and no nag screens or evaluation banners will appear when you run it. You can also distribute the application to the unlicensed machines without facing any nag screens or evaluation banners.

Required references in the licenses.licx file (for Standard and Professional Editions)

The licenses.licx file must contain the following references to ActiveReports if you are using both the Section and Page reports, and both the Windows and WPF viewers. See the table for the references to the ActiveReports version and the reference to the Viewer control.

Note: The Version, Culture, and PublicKeyToken information is added automatically, but they can be removed, and are preferred to be removed, if the version is wrong.

Paste INSIDE the licenses.licx file. Copy Code
GrapeCity.ActiveReports.SectionReport, MESCIUS.ActiveReports
GrapeCity.ActiveReports.PageReport, MESCIUS.ActiveReports
GrapeCity.ActiveReports.Viewer.Win.Viewer, MESCIUS.ActiveReports.Viewer.Win
GrapeCity.ActiveReports.Viewer.Wpf.Viewer, MESCIUS.ActiveReports.Viewer.Wpf

The below table lists all the license strings that you may need:

Component | License String
Section Report engine | GrapeCity.ActiveReports.SectionReport, MESCIUS.ActiveReports
Page and RDLX report engine | GrapeCity.ActiveReports.PageReport, MESCIUS.ActiveReports
WinForms viewer control | GrapeCity.ActiveReports.Viewer.Win.Viewer, MESCIUS.ActiveReports.Viewer.Win
WPF viewer control | GrapeCity.ActiveReports.Viewer.Wpf.Viewer, MESCIUS.ActiveReports.Viewer.Wpf
PRO (some features) PDF export | GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, MESCIUS.ActiveReports.Export.Pdf
WebViewer, HTTP handlers | GrapeCity.ActiveReports.Web.WebViewer, MESCIUS.ActiveReports.Web
PRO ONLY: End-user designer | GrapeCity.ActiveReports.Design.Designer, MESCIUS.ActiveReports.Design.Win
PRO ONLY: JSViewer | GrapeCity.ActiveReports.Aspnet.WebViewer, MESCIUS.ActiveReports.Aspnet.Viewer
PRO ONLY: WebDesigner | GrapeCity.ActiveReports.Aspnet.WebDesigner, MESCIUS.ActiveReports.Aspnet.Designer

Note: When using the PDF export filter in your project, make sure you check the licenses.licx file for reference to the PDF Export Assembly.

License Web Forms projects made on the trial version

Follow these steps after you have licensed ActiveReports on your machine:

  1. Open the Web Forms project in Microsoft Visual Studio.
  2. In Visual Studio, go to the Build menu and select Rebuild Solution.
  3. The web site application is now licensed. You can distribute the web site application to unlicensed machines and no evaluation banners will appear.

License Legacy Web Site applications

Follow these steps after you have licensed ActiveReports on your machine.

Note: These steps help you license application made using the legacy Visual Studio template 'Web Site Application'.
  1. License ActiveReports on your machine.
  2. Open the project in Visual Studio.
  3. In the Solution Explorer, right-click the licenses.licx file and select Build Runtime Licenses to create the App_Licenses.dll file.
  4. The web site application is now licensed. You can distribute the web site application to unlicensed machines without facing any evaluation banners.

License a class library project

Follow these steps after you have licensed ActiveReports on your machine.

  1. Open the project for the root-level calling application, that is, the executable that calls your class library, in Visual Studio.
  2. From the Project menu, select Add New Item, and select an ActiveReports report. (You can delete it later. This is only to add the references to the project.)
  3. In Visual Studio, go to the Build menu and select Rebuild Solution.
  4. Check the licenses.licx file and verify that ActiveReports licensing is added for all of the features used in your project.

Note:

  • If you use some other features of ActiveReports in your class library that are still showing an evaluation banner, for example, features exclusive to the Professional Edition, you can add those references manually and rebuild the solution.
  • The Web Key Generator and Application License Generator utilities have been removed in ActiveReports 15. You should use above steps to license the project.

License a project that use WebDesigner and JSViewer nuget packages

The WebDesigner and JSViewer nuget packages do not include a licenses.licx file, so the file needs to be added and configured manually in your project. Follow these steps to add license file in your Web Application in Visual Studio:

  1. Go to Project menu and select Add New Item.
  2. Select a new text file and rename it to licenses.licx.
  3. Open the blank licenses.licx file and populate the file with the following entries:
    Paste INSIDE the licenses.licx file. Copy Code
    GrapeCity.ActiveReports.SectionReport, MESCIUS.ActiveReports
GrapeCity.ActiveReports.PageReport, MESCIUS.ActiveReports
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, MESCIUS.ActiveReports.Export.Pdf
  4. Run the project.
    You should not face any licensing errors, assuming that you have a licensed ActiveReports Professional Edition.

See Also

Licensing a Developer Machine

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Licensing Compiled Code

Licensing Compiled Code
Developers > License ActiveReports > Licensing Compiled Code

Glossary Item Box

This section describes how to generate the license for the compiled code or specifically for the applications deployed on the Azure Functions application. By default, licensing is applied to your main application. In case ActiveReports is embedded in a custom library that is called by another application, a "license not found" error is shown. Therefore, you need to generate a license file for the target application.

For example, there is a 'UserControlLibrary' project with ActiveReports libraries embedded and a 'MainApp' project that references the 'UserControlLibrary'. To generate a license for the specified target application, follow these steps:

  1. Open the command line on Windows and change the working directory to:
    C:\ProgramData\GrapeCity\gclm
  2. Run the command as:
    gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391"  -lc [output dir].gclicx "[entry assembly name].[calling assembly name].dll"

    For example,
    C:\ProgramData\GrapeCity\gclm>gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -lc ./.gclicx "MainApp.UserControlLibrary.dll"

    To license an application on an Azure Functions application, run the following command:
    gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -lc .\.gclicx Microsoft.Azure.WebJobs.Script.WebHost.[assembly name].dll

    It generates a .gclicx file in the output directory.
    Note: You must specify the application name while generating a license. Also, the generated license can not be used in other applications with different names.

    To add embedded license files (.gclicx) for multiple entry applications, you need to create multiple .gclicx files having a unique name for each of them.
    For example, say you have two main apps 'MainApp1' and 'MainApp2' and one class library 'UserControlLibrary.dll', the user must create two license files using the following commands:

    C:\ProgramData\GrapeCity\gclm>gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -lc ./MainApp1License.gclicx "MainApp1.UserControlLibrary.dll"

    C:\ProgramData\GrapeCity\gclm>gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -lc ./MainApp2License.gclicx "MainApp2.UserControlLibrary.dll"

  3. Copy the .gclicx file and paste it into your application (in this case, UserControlLibrary) where ActiveReports assemblies are used, in any folder.
  4. Change the build action of .gclicx to Embedded Resource.
  5. Add the following line in the .csproj file:

    <PropertyGroup>
       <DisableGclm>true</DisableGclm>
    </PropertyGroup>
  6. Rebuild the solution and run the project.
    Our control will now be able to lookup license for the 'MainApp' from the 'UserControlLibrary' assembly.
    In case of licensing the application on Azure Functions application, deploy the application on Azure Function.
    • This licensing process requires an internet connection.
    • For the license to apply at runtime, you must call gclm.exe with the target name, for example, 'AppName.PluginLibraryName.dll'.
    • The build action of .gclicx file in the project must set to Embedded Resource.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Licensing Build Agents/Pipelines using Command Line

Licensing Build Agents/Pipelines using Command Line
Developers > License ActiveReports > Licensing Build Agents/Pipelines using Command Line

Glossary Item Box

MESCIUS licensing is based upon the development machine. However, in a pipeline environment, the license needs to be activated on a virtual machine or docker on the cloud. A pipeline license is designed for the build agent of DevOps pipelines like Azure, AWS, and Bitbucket. If your pipeline has a dynamic agent (for example, Azure pipeline with Microsoft-hosted agents) you must activate the license before each build and deactivate the license after each build and, depending on the type of license, you may need to deactivate the license after each build. See the instructions below for your type of license.

Activation with Pipeline License

This method of activation is the recommended one.

With a pipeline license you may build and deploy applications from a dynamic build agent with fewer limitations than a standard developer license. A pipeline license allows unlimited activations per day with no need to deactivate the key. The serial key must still be activated before each build, but it does not require network access and it cannot be used for design-time development.

You should contact our sales team at activereports.sales@mescius.com or call 1.800.858.2739 for issuing the pipeline license. A pipeline license includes three things:

  1. Serial Key
  2. Local Activation Package File
  3. Password

To activate your pipeline serial key on the build server follow these steps:

  1. Install the MESCIUS License Manager tool in the pipeline.
    1. If ActiveReports or any MESCIUS inc. product is installed, then the gclm tool is already installed at C:\ProgramData\GrapeCity\gclm
    2. If ActiveReports or any MESCIUS inc. product is not installed, you may download the gclm deployment tool:
      • Windows: https://cdn.mescius.com/license/gclm_deploy.exe
      • Linux/MacOS: https://www.nuget.org/packages/GrapeCity.LicenseManagerTool/ or you may install the gclm tool from command line:
        dotnet tool install -g GrapeCity.LicenseManagerTool

  2. Copy the Local Activation Package file to the gclm install location.
    • Windows: C:\ProgramData\GrapeCity\gclm
    • Linux/MacOS: ~/.local/share/GrapeCity/gclm

  3. Before the build, call the gclm tool to activate the license using your serial key and provided password.
    • Windows:
      C:\ProgramData\GrapeCity\gclm\gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -a "key" “password”
    • Linux/MacOS:
      gclm "437d0240-ba2c-4f9e-9a92-c2816f83d391" -a "key" “password”
Note: You may also perform the activation (step 3) using the MESCIUS License Manager GUI if command line interface is not required. See Licensing a Developer Machine and follow the steps for activating your pipeline key. It will prompt you to enter the password separately.

Activation with Standard Developer License

With a standard developer license you may build and deploy applications from a dynamic build agent with some limitations.

  1. Your serial key must be activated and deactivated for each build.
  2. You may only activate and deactivate a single key up to 3 times per day, 10 times per 10 days, and 25 times per 360 days. Reaching any of these limits will cause additional activation requests to fail.

To activate your serial key on the build server follow these steps:

  1. Install the MESCIUS License Manager tool (gclm) in the pipeline.
    1. If ActiveReports or any MESCIUS inc. product is installed, then the gclm tool is already installed at C:\ProgramData\GrapeCity\gclm
    2. If ActiveReports or any MESCIUS inc. product is not installed, you may download the gclm deployment tool:
      • Windows: https://cdn.mescius.com/license/gclm_deploy.exe
      • Linux/MacOS: https://www.nuget.org/packages/GrapeCity.LicenseManagerTool/ or you may install the gclm tool from command line:
        dotnet tool install -g GrapeCity.LicenseManagerTool

  2. Before the build, call the gclm tool to activate the license
    • Windows:
      C:\ProgramData\GrapeCity\gclm\gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -a "key"
    • Linux/MacOS:
      gclm "437d0240-ba2c-4f9e-9a92-c2816f83d391" -a "key"

  3. After the build, call the gclm tool to deactivate the license
    • Windows:
      C:\ProgramData\GrapeCity\gclm\gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -d
    • Linux/MacOS:
      gclm "437d0240-ba2c-4f9e-9a92-c2816f83d391" -d

Notes:

  • The key should be deactivated even if the build is failed, otherwise the license cannot be activated for next build agent. You may contact our support team to resolve the issue if a key cannot be deactivated. If deactivation may be a problem, we recommend upgrading to a pipeline license.
  • The environment should have the network to access https://sa2.grapecity.com/ website.

Check the License Status

To check whether the license is activated or not, follow these steps:

  1. Create a file, say 'info.txt' with the product name and GUID specified

    C:\ProgramData\GrapeCity\gclm>gclm "437d0240-ba2c-4f9e-9a92-c2816f83d391" > "info.txt"

  2. Check the license details: license status, license type, serial key, activation date, expiration date, and edition

    C:\ProgramData\GrapeCity\gclm>more info.txt

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Offline Licensing with Command Line

Offline Licensing with Command Line
Developers > License ActiveReports > Offline Licensing with Command Line

Glossary Item Box

MESCIUS licensing requires the build machine to be licensed. Licensing a build machine is included with any developer license and does not require purchasing additional keys. If your development or build machine has no internet connection, see License ActiveReports on a machine without an internet connection topic.

Offline activation is a manual process that can be tedious for many developers. Instead, you may implement a process to perform the offline activation by command. This process is somewhat automatic, but also requires a manual step in the middle that can be performed at once for all machines or for a single machine. The steps below detail this process:

Before offline activation by command line, install the MESCIUS License Manager tool (gclm) as follows. If ActiveReports or any MESCIUS inc. product is installed, then the gclm tool is already installed at C:\ProgramData\GrapeCity\gclm.

  1. Download the gclm deployment tool:
    • Windows: https://cdn.mescius.com/license/gclm_deploy.exe
    • Linux/MacOS: https://www.nuget.org/packages/GrapeCity.LicenseManagerTool/ or you may install the gclm tool from command line:
      dotnet tool install -g GrapeCity.LicenseManagerTool
  2. Write a bat file or program that runs on each offline machine and executes:
    1. Windows: C:\ProgramData\GrapeCity\gclm\gclm.exe "product id" -g "key" "activation file name"
    2. Linux/MacOS: gclm "product id" -g "key" "activation file name"
      • Windows:
        C:\ProgramData\GrapeCity\gclm\gclm.exe "437d0240-ba2c-4f9e-9a92-c2816f83d391" -g "key" “[file:/%3Cnetwork-location%3E%computername%-gcactivation.lic]\\<network-location>\%computername%-gcactivation.lic”
      • Linux/MacOS:
        gclm "437d0240-ba2c-4f9e-9a92-c2816f83d391" -g "key" “[file:/%3Cnetwork-location%3E%computername%-gcactivation.lic]\\<network-location>\%computername%-gcactivation.lic”
    Notes: This creates an "activation file name" (.lic) which includes the name of the machine (computer environment variable). This could be put on a network location such as [file:/%3Cnetwork-location%3E%computername%-gcactivation.lic]\\<network-location>\%computername%-gcactivation.lic.
  3. From an online machine, go to the https://sa2.mescius.com/activate website and manually generate the KeyFile for each machine using the activation file.
  4. Run a second bat file or command on each offline machine with:
    1. Windows: C:\ProgramData\GrapeCity\gclm\gclm.exe "product id" -i "keyfile"
    2. Linux/MacOS: gclm "product id" -i "keyfile"
    Notes:
    • You should name the KeyFile so that it identifies the machine the activation file came from.
    • All the KeyFiles will be different and tied to a specific machine.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Submitting a Reactivation Request

Submitting a Reactivation Request
Developers > License ActiveReports > Submitting a Reactivation Request

Glossary Item Box

If you get error messages during activation and cannot resolve it by yourself, you need to submit a reactivation request on license website using the following steps and wait for approval.

  1. Go to the license website. Click the Reactivation button.
    License Reactivation Website

  2. In the Reactivation Request page, input the serial key which has errors and click Next.
    Enter Serial Key to Reactivate

  3. In the next page, click the Create button to create a new request. However, in case you have submitted a reactivation request for this serial key before, the last reactivation request will appear on the page which might be in progress, done, or expired.
    Create Reactivation Request

  4. In the Create Reactivation Request page, fill all the answers and click the Submit button to submit your request.
    Fill Form to Create Reactivation Request

    This creates a new request. You can refresh the webpage later to view the updates.
    Reactivation Request List

View the request result

You can go back to the page after about 5~10 minutes to view the result.

  • If the web browser is closed, you can go to the reactivation link, and input the serial key again to navigate to the reactivation request page.

If the request may have been approved, you can use the serial key to activate the product this time.

Reactivation Request Approved

In some cases, you may see problems with the request displayed as a warning message. Then, you need contact MESCIUS sales or support by email or telephone, introduce the situation and describe how you want to use the product.

As a result, the sales or supports will approve or reject the reactivation request depending on the actual usage of the serial key.

If your request gets approved, then the updated page will look like the following:

License Reactivation Request Approved

If your request gets denied, then the updated page will look like the following:

License Request Denied

Also, the requests expire after 15 days so you need to contact us in time so that the request can be processed by our support team. If you still face any issues, please submit a new request.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Fixing Licensing Errors

Fixing Licensing Errors
See Also
Developers > License ActiveReports > Fixing Licensing Errors

Glossary Item Box

Here are some of the common licensing errors and their causes.

Error | Cause
Application cannot run because it was built with no license. | Licensing is not present in the application or the calling application. See below for information on how to license the calling application.
License for XXXX (control name) could not be found. | Extra lines for components that you do not use are in the licenses.licx file. Delete unnecessary information and Rebuild the project.
Licensing has not been correctly applied to the application. | Check the three key points below.
Exception (LicenseException) | Check the three key points below.
  1. Ensure that the license file is added to the appropriate project.

    The licenses.licx file is automatically generated in the project where ActiveReports is used. But if your application is composed of multiple projects and another project calls the reports defined in your class library, you need to register it in the calling project rather than just in your report project.

    When you add an ActiveReports web service to a Page report, RDLX report, or XML-based Section report project, the licenses.licx file is not created automatically, and the license strings are not added. You also need to manually add licensing to your application if you want to create a control at run time or use the HTTP handlers.

    To manually add licensing to the calling application:

    Note: In a C# Windows Forms project, the license file is in the Properties folder. In a Visual Basic project, it is in the My Project folder.

    1. In your application that contains ActiveReports components, check that the proper licensing strings are in the licenses.licx file. (See the table of license strings below.)

    2. Copy the ActiveReports strings from the file into the licenses.licx file in the calling application.
    a. If there is no license file, from the Project menu, select Add New Item.
    b. From the listed templates, select Text file and change the name to "licenses.licx."
    c. In the Solution Explorer, double-click the newly created licenses.licx file to open it, and paste in the licensing strings for all components you use.

    3. From the Build menu, select Rebuild Project to embed the licensing.

    ​Note: If your project is a web site, the bin folder has the licenses embedded in the App_Licenses.dll file.
  2. Ensure that the contents of the license file are correct.

    Depending on which features of ActiveReports you use in your application, the license file may need to contain multiple license strings.

    You will find a full list of license strings that you may need in the Required references in the licenses.licx file (for Standard and Professional Editions) section above.

  3. Ensure that the Build Action property is configured correctly for the license file.

    Properties panel window

    1. In the Solution Explorer, select licenses.licx (you may need to click the Show all files button to see it).

    2. In the Properties window, ensure that the Build Action property is set to Embedded Resource.

  4. Ensure that .NET Core applications are always run on Visual Studio 2019 or above

    .NET Core applications should be run only in Visual Studio 2019 or above.

In case you face issues with the serial key while activating a license, using the MESCIUS License Manage Tool application or command line tool, or anywhere on the website, on a developer, build agent, or any other machine, try Submitting a Reactivation Request.

To license a WebSite application

  1. In the Solution Explorer, right-click the licenses.licx file and select Build Runtime Licenses to create the App_Licenses.dll file.
  2. To generate the .gclicx file, using the GCLM, use one of these commands:
    C:\ProgramData\GrapeCity\gclm\gclm.exe "[AR GUID]" -lc "[output dir]/.gclicx" "[entry assembly name].dll"
    C:\ProgramData\GrapeCity\gclm\gclm.exe "[AR GUID]" -lc "[output dir]/.gclicx" "[executing assembly name].dll"
    C:\ProgramData\GrapeCity\gclm\gclm.exe "[AR GUID]" -lc "[output dir]/.gclicx" "[entry assembly name].[executing assembly name].dll"
  3. Copy the .gclicx file and paste it into your project, in any folder.
  4. Change the Build Action property for the .gclicx file to Embedded Resource.
  5. Rebuild the solution and run the project.

See Also

Submitting a Reactivation Request
ActiveReports.NET Licensing FAQ

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Contacting Support

Contacting Support
Developers > License ActiveReports > Contacting Support

Glossary Item Box

If you face problems licensing ActiveReports even after you have tried Fixing Licensing Errors and Submitting a Reactivation Request, please contact our Support Team using any of these channels:

Web site | https://developer.mescius.com/support/contact
E-mail | activereports.sales@mescius.com
Phone1 | (412) 681-4738

1Phone support is available for customers that have Platinum Support included with their purchased products or issues related to licensing or installation of a product. Monday through Friday during regular business hours (EST).

For information on Platinum Support, visit our website at https://developer.mescius.com/support/plans/.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure ActiveReports Using Code

Configure ActiveReports Using Code
See Also
Developers > Configure ActiveReports Using Code

Glossary Item Box

The configuration for the viewer and the designer can be set at runtime by using UseConfig(IConfigurationProvider) method in the Startup.cs file.

Startup.cs Copy Code
 app.UseReportViewer(settings =>
 {
     settings.UseFileStore(ReportsDirectory);
     settings.UseConfig(new ConfigurationProvider(Path.Combine(CurrentDir, "ActiveReports.config")));
 });

See Also

DevOps
Configure ActiveReports using Config File

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with Reports using Code

Work with Reports using Code
See Also
Developers > Work with Reports using Code

Glossary Item Box

ActiveReports.NET is a developer reporting tool to embed reports within web and desktop applications. This section provides information on the tasks performed by developers while creating comprehensive reports. The report creation utilizes the .NET's Visual Studio-Integrated Designer for data visualization within the Visual Studio IDE while Page/RDLX Reports and Section Reports

Before going through this section, we recommend that you read the Report Authors section to have a minimum basic knowledge, required for a report author.

See Also

Report Authors
Design Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Visual Studio Integrated Designer

Visual Studio Integrated Designer
Developers > Work with Reports using Code > Visual Studio Integrated Designer

Glossary Item Box

ActiveReports offers an integrated designer that lets you create report layouts in Visual Studio and edit them at design time, visually, and through code, script, or regular expressions. Like any form in Visual Studio, it includes a Properties panel with extensive properties for each element of the report, and also adds its own Toolbox filled with report controls, and a Report Explorer with a tree view of report controls.

Report Layouts in Visual Studio Integrated Designer

The designer supports these types of report layouts: rdlx layout, page layout, and section layout.

RDLX/RDLX Dashboard Report

This layout defines reports where controls grow vertically to accommodate data. Reports designed in this layout are saved in Rdlx format.

RDLX Report Layout

RDLX Dashboard Report Layout

Note that a theme you select for your Visual Studio, is automatically applied to the ActiveReports Designer. For example, if you select the Dark theme for your Visual Studio, this theme is applied automatically to the Designer. The Visual Studio theme is extended to such ActiveReports Designer elements as Reports Library, Layer List, Report Explorer, and Group Editor.

The theme integration works for all reports (Page, RDLX, RDLX Dashboard, and Section) opened in supported Visual Studio versions.

Visual Studio in dark theme

Page Report

This layout defines reports in pages where the same page layout can be used throughout the report or separate layout pages are designed for complex reports. Reports designed in this layout are saved in Rdlx format.

Page Report Layout

Section Report

This layout presents reports in three banded sections by default: page header, detail and page footer. You can remove the page header and footer, add a report header and footer, and add up to 32 group headers and footers. Drag controls onto these sections to display your report data. Reports designed in this layout are saved in RPX format.

Section Report Layout (RPX)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Design View

Design View
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Design View

Glossary Item Box

The report designer is fully integrated with the Microsoft Visual Studio IDE. In this topic, we introduce the main parts of the designer in Section Report, Page Report, and RDLX report to help you select the one to best suit your specific needs.

Report Designer in Section Reports

Report designer in section reports

Design Surface

The design surface offers a default report structure that contains a page header, a detail section, and a page footer along with some grey area below these sections. Drag report controls and fields onto these sections to display your data. Use section grab handles to drag a section's height up or down. Right click the report and select Insert to add other types of header and footer section pairs.

Data Source Icon

The Data Source icon is located in the band along the top of the detail section. Click this icon to open the Report Data Source dialog, where you can bind your report to any OLE DB, SQL, or XML data source.

Section Collapse Icon

A Section Collapse icon (-) appears on each band adjacent to the section header. When you click the collapse icon the section collapses and an expand icon (+) appears. Please note that section collapse is only available in the Designer tab. All sections of the report are visible in the Preview tab or when the report is rendered.

Tip: In order to make a section invisible, set the Height property of the section to 0 or the Visible property to False.

Rulers

Rulers are located at the top and left of the design view. They help a user visualize the placement of controls in the report layout and how they appear in print. Please note that you have to add the right and left margin widths to determine whether your report fits on the selected paper size. The left ruler includes a grab handle for each section to resize the section height. See Rulers for more information.

Grab Handles

Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Zoom Bar

The zoom bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information.

Report Designer in Page reports/RDLX reports

Report designer in Page reports/RDL reports

In a Page Report or an RDLX Report, the designer offers the following features that you can use to create, design and edit a report.

Design Surface

The design surface of a report appears initially as a blank page and grid lines. You can create your own layout and drag report controls and fields onto the design surface to display your data.

Rulers

Use the ruler to determine how your report will look on paper. Please note that you have to add the right and left margin widths to determine whether your report will fit on the selected paper size. See Rulers for more information.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Page Tabs(Page Report)

By default, the designer provides two page tabs, Page 1 and New, below the design surface. Each page tab represents a layout page of the report. Page 1 represents the first page of your report, and you can click New to add another page to your report. See Page Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Zoom Bar

The Zoom Bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information

Tip: ActiveReports provides some useful keyboard shortcuts for the controls placed on the design surface.

  • Arrow Keys: To move control by one grid line.
  • [Ctrl] + Arrow Keys: To move control by 1/100 inch (around 0.025 cms)
  • [Shift] + Arrow Keys: To increase or decrease the size of the control by one grid line.

See Also

ActiveReports Designer
Report Explorer
Properties Panel

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Menu

Report Menu
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Report Menu

Glossary Item Box

The Report menu provides access to common reporting operations. To show the Report Menu in the Visual Studio menu bar, select the Design View of the report in the ActiveReports Designer. This menu does not appear in the menu bar when the report is not selected.

The following drop-down sections describe the Report menu items. Menu items differ based on the type of report layout in use.

Note: The Report menu in Visual Studio 2019 and Visual Studio 2022 is available as submenu under Extensions.

Report Menu for Section Reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RPX file format.
Load Layout | Opens the Open dialog where you can navigate to any RPX file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Data Source | Opens the Report Data Source dialog to bind a data source to the report.
Settings | Opens the Report Settings dialog.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.

Report Menu for Page and RDLX reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RDLX file format.
Load Layout | Opens the Open dialog where you can navigate to any RDLX, RDLX, RDLX-master file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Convert to Master Report (RDLX Reports only)

Converts an RDLX Report to a Master Report.

It disappears from the Report menu when a master report is applied to the report through Set Master Report. See Master Report (RDLX Report) for more details.
Report Parameters | Opens the Report dialog to the Parameters page where you can manage, add and delete parameters.
Embedded Images | Opens the Report dialog to the Images page, where you can select images to embed in a report. Once you add images to the collection, they appear in the Report Explorer under the Embedded Images node.
Report Properties | Opens the Report dialog to the General page where you can set report properties such as the author, description, page header and footer properties, and grid spacing.
Stylesheet Editor | Opens the Stylesheet Editor dialog, where you can create, edit or remove styles. You can also embed these styles in a style sheet or save them externally in *.rdlx-styles format. Embedded style sheets appear under the Embedded Stylesheets node in the Report Explorer.
Report Parts | Opens the Exported Report Parts dialog, where you can add or remove report parts. You can also modify the added report part properties, exposed in the dialog. See Report Parts for details.
Set Master Report (RDLX Reports only)
  • Open Local File

Select Open Local File option to open the Open dialog, and then select a master report.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.
Page Header (RDLX Reports only) | Toggles the report Page Header on or off.
Page Footer (RDLX Reports only) | Toggles the report Page Footer on or off.

See Also

Report Explorer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Designer Tabs

Designer Tabs
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Designer Tabs

Glossary Item Box

The Designer has three tabs located at the bottom of the report design surface. Create a report layout in the Designer tab, write a script in the Script tab to implement .NET functionality and see the result in the Preview tab.

Designer Tab

The Designer tab appears by default on your designer. This tab is used to design your report layout visually. You can implement most of the design-time features here, drag controls from the toolbox to create a layout, bind data regions to data, and set properties for the report and controls through the context menu.

Tip: Layout-related features like designer buttons and zoom slider can be used in this tab to help you manage your report display efficiently.

Script Tab

The Script tab opens the script editor, where you can provide VB.NET or C# functionality to the reports without compiling the .vb or .cs files. You may use either Visual Basic or C# script in this tab with Section Reports, or Visual Basic with Page reports and RDLX reports.

The generated reports serve as standalone reports which you can load, run, and display in the viewer control without the designer. This feature is useful when distributing reports without recompiling.

In Page reports/RDLX reports, you can embed code blocks that you can reference in the expressions you use on report controls. See Add Code to Layouts Using Script for more information about using script.

In Section Reports, you can add code to object events. The two drop-down boxes in the script editor allow you to select any section of the ActiveReport and any events associated with that section, or the report itself and related events. When you select an event, the script editor generates a method stub for the event. See Add Code to Layouts Using Script for more information about scripting in Section Reports.

Preview Tab

The Preview tab allows you to view your report without the need to actually run your project. This makes it easy to quickly see the run-time impact of changes you make in the designer or the code.

This tab does not display data in the following conditions:

  • Code or script in the report class is incorrect.
  • Report class constructor has been changed.
  • Report data source has not been set correctly.
  • Settings have been implemented outside the report class
  • .mdb file is being copied in the project

When the report is inherited from a class other than ActiveReports, preview is possible only when the base class is in the same project. If the base class is not in the same project and is referencing an external class library, you will not get a preview in the Preview tab.

When adding a report directly to ASP.NET Web site, the Preview tab is not visible and thus you cannot preview.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Designer Buttons

Designer Buttons
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Designer Buttons

Glossary Item Box

Show All Show All
Hide All Hide All

Designer buttons are located to the right of the designer tabs along the bottom of the designer, and are enabled when you are on the Designer tab. They allow you to control settings for the design surface.

Grid Settings

Dimension Lines

Dimension lines appear during a drag operation, and run from the borders of the report control or data region being moved or resized to the edges of the report designer surface. Dimension lines let you track the location of the control as you move it by displaying the distance between the control and the edge of the writable area of the report.

Button Type | Behavior
Dimension Lines button | Dimension Lines example
Note: With Section Reports, you can change the number of grid columns and rows in the Report Settings dialog on the Global Settings tab. With Page reports and RDLX reports, you can change the grid spacing in the Report Properties dialog on the General tab.

Hide Grid

By default, grid lines and dots appear on the report design surface. You can click this button to hide the grid and design your report on a blank page. Lines or dots are also removed from the design surface when you hide the grid, but Snap to Lines or Snap to Grid settings remain unaffected.

Button Type | Behavior
Hide Grid button | Hide Grid example

Show Dots

You can click this button to have dots appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior
Show Dots button | Show Dots example

Show Lines

You can click this button to have faint grey lines appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior
Show Lines button | Show Lines example
Note: Only one option out of Hide Grid, Show Dots and Show Lines can be selected at one time.

Control Drag and Drop Settings

These settings allow you to specify how you want controls to behave when you drag and drop them on the design surface.

Tip: If you plan to export a report to Excel format, use Snap Lines or Snap to Grid to ensure that your controls are aligned in columns and rows as it prevents overlapping. This makes the export to excel closer to how a report looks at run or design time.

Snap Lines

This setting aligns the control you are dragging with other controls on the report design surface. When you drag the control around, snap lines appear when it is aligned with other controls or with the edges of the report, and when you drop it, it snaps into place in perfect alignment. See Snap Lines for more information.

Button Type | Behavior
Snap Lines button | Snap Lines example

Snap to Grid

This setting aligns the control you are dragging with grid lines on the report design surface. When you drop the control, it snaps into place in alignment with the nearest grid mark. To place your controls freely on the report design surface, turn this setting off.

Button Type | Behavior
Snap to Grid button | Snap to Grid example

Mouse Modes

These settings allow you to specify how you want the mouse to behave in the designer.

Select Mode

In Select mode, when you click items on the report designer surface, you select them. Use this mode for editing, data binding and styling in the Designer tab. An arrow cursor appears in the Select mode.

Button Type | Behavior
Select Mode button | Select Mode example

Pan Mode

Use the Pan mode to make navigation easier. In this mode, you cannot select, edit, add or delete a control from the design surface.In this mode, you cannot select, edit, or delete a control from the design surface. A hand cursor appears in Pan mode and you can navigate through your report by pressing the left mouse button and dragging the report to the desired position.

Tip: To enable Pan mode while you are in Select Mode, hold down the middle mouse button and move to the desired location with the hand cursor.
Button Type | Behavior
Pan Mode button | Pan Mode example

See Also

Designer Tabs

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Toolbar

Toolbar
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Toolbar

Glossary Item Box

ActiveReports provides a toolbar integrated with the Visual Studio IDE for quick access to report designing commands. This toolbar is composed of buttons and dropdown lists which offer functions for a number of commonly used commands.

Show or Hide the Toolbar in Visual Studio

  1. Create a new project or open an existing project in Visual Studio.
  2. Right click on the Visual Studio toolbar and from the context menu that appears, select ActiveReports.

The ActiveReports toolbar appears under the Visual Studio menu bar. The toolbar options may differ based on whether you have a Section Report, Page Report or an RDLX Report open.

See the description of each toolbar option in the tables below.

Note: Toolbar descriptions are grouped in a logical order for understanding. The buttons and dropdowns may appear in a different order in the ActiveReports toolbar.

Text Decoration

Command | Description
Style | Sets the style for the selected report control. For details on setting styles in Page and RDLX reports, see Working with Styles. For details on setting styles in Section Report, see Working with External Style Sheets.
Font | Sets the typeface of all the text in a control. In a Section Report, for the RichTextBox control, typeface of only the selected text changes. In a Page Report or an RDLX Report, in a data region like Tablix or Table, you can change the typeface of the entire data region or only the selected TextBox within the region.
Font Size Font Size pane | Sets the font size of all the text in a control. In a Section Report, for the RichTextBox control, font size of only the selected text changes. In a Page Report or an RDLX Report, for a data region like Tablix or Table, you can change the font size of the entire data region or only the selected TextBox within the region.
Fore Color Fore Color button | Opens a Choose Color dialog to set the text color of controls.
Back Color Back Color button | Opens a Choose Color dialog to set the background color of controls.
Bold | Sets or removes text emphasis from the entire text of the control. In Section Report, for the RichTextBox control, bold applies to the selected text only. In a Page Report or an RDLX Report, for a data region like Tablix or Table, you can change the emphasis of the entire text or only the text of the selected TextBox within the region.
Italic | Sets or removes text slant for the entire text of the control. In a Section Report, for the RichTextBox control, italic applies to the selected text only. In a Page Report or an RDLX Report, for a data region like Tablix or Table, you can italicize the entire text or only the text of the selected TextBox within the region.
Underline | Sets or removes the text underline for the entire text of the control. In a Section Report, for the RichTextBox control, underline applies to the selected text only. In a Page Report or an RDLX Report, for a data region like Tablix or Table, you can also underline the entire text or only the text of the selected TextBox within the region.

Text Alignment

Command | Description
Align Left Align to Left button | Aligns the text to the left in the control area.
Center Align to Center button | Aligns the text to the center in the control area.
Align Right Align to Center button | Aligns the text to the right in the control area.
Align Justify Align Justify button | Justifies the text in the control area.

Layout Editing

Command | Description
Zoom Out Zoom Out button | Reduces the magnification level of the design surface and any elements within it.
Zoom In Zoom In button | Increases the magnification level of the design surface and any elements within it.
Zoom Zoom dropdown list | Opens a dropdown list to set the magnification level of the design surface between 50% and 400%. Zoom percentage is set to 100% by default.

Control Alignment

Command | Description
Align to Grid Align to Grid button | Snaps the top left of the selected control to the closest gridline.
Align Lefts Align Lefts button | Aligns the selected controls with their left border coinciding with the left border of the primary control. The vertical space separating the controls remains the same.
Align Rights Align Rights button | Aligns the selected controls with their right border coinciding with the right border of the primary control. The vertical space separating the controls remains the same.
Align Tops Align Tops button | Aligns the selected controls with their top border coinciding with the top border of the primary control. The horizontal space separating the controls remains the same.
Align Middles Align Middles button | Aligns the selected controls vertically to the middle with respect to the primary control. The horizontal space separating the controls remains the same.
Align Bottoms Align Bottoms button | Aligns the selected controls with their bottom border coinciding with bottom border of the primary control. The horizontal space separating the controls remains the same.

Control Resizing

Command | Description
Make Same Width Make Same Width button | Resizes the width of the selected controls to the width of the primary control.
Make Same Height Make Same Height button | Resizes the height of the selected controls to the height of the primary control.
Make Same Size Make Same Size button | Resizes the size (width and height) of the selected controls to the size of the primary control.
Size to Grid Size to Grid button | Snaps the selected control to the closest gridline by resizing the control on all four sides.

Control Spacing

Command | Description
Make Horizontal Spacing Equal Make Horizontal Spacing Equal button | Creates equal space between the selected controls with respect to the primary control, using the outermost edges of the controls as end points.
Increase Horizontal Spacing Increase Horizontal Spacing button | Increases the horizontal spacing by one grid unit with respect to the primary control.
Decrease Horizontal Spacing Decrease Horizontal Spacing button | Decreases the horizontal spacing by one grid unit with respect to the primary control.
Remove Horizontal Spacing Remove Horizontal Spacing button | Removes the horizontal space so that the selected controls move to the nearest edge of the top-left control.
Make Vertical Spacing Equal Make Vertical Spacing Equal button | Creates equal space between the selected controls with respect to the primary control, using the top and bottom edges of the control as the end points.
Increase Vertical Spacing Increase Vertical Spacing button | Increases the vertical spacing by one grid unit with respect to the primary control.
Decrease Vertical Spacing Decrease Vertical Spacing button | Decreases the vertical spacing by one grid unit with respect to the primary control.
Remove Vertical Spacing Remove Vertical Spacing button | Removes the vertical spacing so that the selected controls move to the nearest edge of the top-left control.

Z-order Alignment

Command | Description
Bring to Front Bring to Front button | Moves the selected controls to the front of all other controls on the report.
Send to Back Send to Back button | Moves the selected controls behind all other controls on the report.

RichTextBox commands

Command | Description
Bullets | Adds or removes bullets from the selected text inside a RichTextBox control in a Section Report.
Increase Indent Increase Indent button | Increases the indent of selected text in the RichTextBox control area in a Section Report.
Decrease Indent Decrease Indent button | Decreases the indent of selected text in the RichTextBox control area in a Section Report.

Others

Command | Description
View ReportExplorer View ReportExplorer button | Shows or hides the Report Explorer window. See Report Explorer for further details.
Reorder Groups Reorder Groups button | Opens the Group Order dialog, where you can drag and drop groups to rearrange them. This button is enabled when you have multiple groups in a Section Report.
Layer List Layer List button | Opens the Layer List window to displays a list of Layers in the report along with their visibility and lock options. Layer List Explorer also allows you to add or remove Layers from your reports. See Layers for further details.
Note: Primary control is the control in a selected group of controls, to which you align all other controls. It is generally the first control selected in the group and has sizing handles (white boxes) which are different from the rest of the selected controls.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Toolbox

Toolbox
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Toolbox

Glossary Item Box

In ActiveReports, the Visual Studio integrated toolbox tabs display all of the controls specific to the type of report that has focus, or the ActiveReports controls that you can use on Web Forms or Windows Forms.

When a Section report has a focus, the ActiveReports 19 Section Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Section Report page.

When a Page report has a focus, the ActiveReports 19 Page Report toolbox becomes available.

When an RDLX report has a focus, the ActiveReports 19 RDLX Report toolbox becomes available.

When an RDLX Dashboard report has a focus, the ActiveReports 19 RDLX Dashboard Report toolbox becomes available.

For information about the report controls available in this toolbox, please see the Page/RDLX Report topic.

When a Windows Form has focus, the ActiveReports 19 toolbox group offers the following Windows Forms controls:

  • ReportExplorer
  • Toolbox
  • Designer
  • Viewer

When a Web Form has a focus, the ActiveReports 19 toolbox group offers WebViewer as a Web control.

See Also

Report Authors
Report Controls

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Page Tabs

Page Tabs
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Page Tabs

Glossary Item Box

Page tabs appear in an Excel-like bar below the report design surface. This feature is only available in Page Report, where report layouts are designed on separate pages and you can control the way each page appears. Using page tabs, you can select which page to view or edit, add new pages, remove existing pages, reorder pages, and create duplicate pages.

By default, a new report has a Page 1 tab and a New tab.

  • Page 1: This is the layout for the first page of the report. If no other page layouts exist, the layout on this page is applied to the entire report.
  • New: Click to add a new page where you can create a layout for pages displayed after the first page.

Right-click any page tab (except the New tab) to get a context menu that allows you to Insert a new page, Duplicate the page, or Delete the page.

Adding a new page

To add a new page, click the New tab.

A new page tab with an incremented page number appears to the right of any existing page tabs. This page has the same page size and margins as the previous page. The New tab moves to the right of the newly added page.

Inserting a page

To insert a page, right-click the page tab and select Insert. A page is inserted to the left of the selected page. It has the same page size and margins as the selected page.

Deleting a page

To delete a page, right-click the page tab that you want to remove and select Delete. This option is disabled if there is only one page in the report.

Creating a copy of a page

To create a copy of a page, right-click on the page tab that you want to copy and select Duplicate. A copy of the selected page appears to the right of the selected page.

Note: When the duplicate page contains a data region, ActiveReports replaces the data region with an OverflowPlaceHolder on the new page. Reset the GrapeCity.ActiveReports.PageReportModel.DataRegion.OverflowName property for the duplicated page to maintain the overflow data chain between page tabs.

Reordering pages

To change the order of page tabs, drag a tab and drop it at the desired location. The tab is inserted in the chosen location and the page number is updated according to its position. The page numbers of other tabs also change automatically.

You can cancel the move operation by pressing the [Esc] key while dragging the tab.

See Also

Report Authors
Overflow Placeholder (Page report only)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Explorer

Report Explorer
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Report Explorer

Glossary Item Box

The Report Explorer gives you a visual overview of the report elements in the form of a tree view where each node represents a report element.

Using the Report Explorer with any type of report, you can remove controls, add, edit or remove parameters, add a data source, add a dataset, and drag fields onto the report. You can also select the report or any element in the report to display in the Properties panel, where you can modify its properties.

Report Explorer in Visual Studio

ActiveReports supports four types of reports:

  • Section Report (in your choice of XML-based RPX or code-based CS or VB files)
  • Page Report (in XML-based RDLX files)
  • RDLX Report
  • RDLX Dashboard Report

These reports are composed of different types of report elements, so the Report Explorer shows different elements in the report tree depending on the type of report you have open.

Show or hide the Report Explorer in Visual Studio

Once you add the Report Explorer in Visual Studio, it appears every time you create a new Windows application. Use the steps below to hide it when you do not need it.

  1. Right-click on the Visual Studio toolbar and select ActiveReports to display the report designer toolbar. See Toolbar for further details.
  2. On the Designer toolbar, click the View ReportExplorer button. The Report Explorer window appears.
  3. To hide the Report Explorer, follow the steps above and toggle View ReportExplorer back off.

Tip: Another way to show the Report Explorer window in Visual Studio, is from the View menu, select Other Windows, then Report Explorer.

Change control properties

  1. In the Report Explorer, select the control for which properties are to be changed. In the Properties Panel, all of the properties for the item appear.
  2. Change property values by entering text or selecting values from drop-down lists. With some properties, for example, OutputFormat or Filters, when you click the property, an ellipsis button appears to the right. Click the ellipsis button to open a dialog where you can make changes.

Delete a control

  1. In the Report Explorer, expand the node that contains the control that you want to remove.
  2. Right-click the control and select Delete.
  3. In the dialog that appears, click Yes to confirm the deletion.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Properties Panel

Properties Panel
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Properties Panel

Glossary Item Box

The Visual Studio Properties window is an important tool when you design a report. Select any page, section, data region, control or the report itself to gain access to its properties in the Properties window. By default, this window is placed to the right of the report design area, or wherever you may have placed it in Visual Studio. You can show the list of properties by category or in alphabetical order by clicking the buttons at the top of the Properties window.

Select a property to reveal a description at the bottom of the window. Just above the description is a commands section that contains commands, links to dialogs that give you access to further properties for the item. You can resize the commands or description sections by dragging the top or bottom edges up or down.

Tip: If the commands or description section is missing in Visual Studio, you can toggle it back on by right-clicking anywhere in the Properties window and clicking Commands or Description.

In the image below, you can see a chart control selected on the designer surface, revealing its properties in the Properties window, along with any associated commands, and a description of the selected property.

Properties panel in ActiveReports Designer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Rulers

Rulers
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Rulers

Glossary Item Box

In ActiveReports, rulers appear to the top and left of the Design View to guide you in vertically and horizontally aligning items in the report. They have large tick marks to indicate half-inch points and smaller tick marks to indicate eighths of an inch.

Note: The numbers indicate the distance in inches from the left margin, not from the edge of the page.

Section Report

In Section reports, the white area on the ruler indicates the designable area of the report. The grey area at the bottom of the vertical ruler and at the right of the horizontal ruler indicates the report margins. Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

Using Ruler in Section Report

In a Section Report, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements at design- time.

To change ruler measurements at design-time in Section Report

At design time, you can change the ruler measurements from the Report Settings Dialog.

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Global Settings.
  3. From the Ruler Units dropdown select Centimeters or Inches.

    Report Settings dialog box

In Section Report, you can change the units of measure for the rulers.

Page Report/RDLX Report

In Page or RDLX reports, margin markers indicate the designable area of the report. The area inside the margin markers is designable, and the areas outside the markers are the margins. To change the margins, you can drag the margin markers to the desired locations.

Using margin markers in Page/RDL reports

In a page layout, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements in Page reports.

To change ruler measurements at design-time in Page Report

At design time, you can change the ruler measurements from the Report Dialog.

  1. In the Report Explorer, select the Report node.
  2. In the command section of the Properties Panel, click the Property dialog.
  3. In the dialog that appears, go to the General tab.
  4. From the Ruler Units dropdown select Centimeters or Inches.

    Report - General dialog box

See Also

Design View

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Scroll Bars

Scroll Bars
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Scroll Bars

Glossary Item Box

Scroll Bars appear automatically when controls or data regions do not fit the visible area of the report design surface. A scroll bar consists of a shaded column with a scroll arrow at each end and a scroll box (also called a thumb) between the arrows. You can scroll up, down, right or left using the scroll arrow buttons, scroll box or mouse wheel.

Auto Scrolling

When a user drags a control beyond the edge of the design surface and the mouse pointer reaches near the surface edge, scrolling starts automatically in the direction of the mouse movement. Auto scrolling works in all four directions. This feature is useful while designing reports with a magnified design view.

Note: In Section Layout and Report Definition Language (RDLX), when the mouse button is released during auto scrolling at a location outside the design surface, the surface extends to accommodate the control.

Scrolling stops in the following scenarios:

  • The user stops dragging the mouse (Mouse Up).
  • The user moves the mouse in the opposite direction.
  • The [Esc] key is pressed while dragging the mouse.
Tip: To enable auto scrolling for multiple controls, hold down the [Ctrl] or [Shift] key to select the controls. Drag them together to the edge of the design surface and enable auto scrolling.

See Also

Zoom Support
Design View

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Snap Lines

Snap Lines
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Snap Lines

Glossary Item Box

Snap lines assist in accurate positioning of elements on a report design surface while you drag report controls on it. These dynamic horizontal and vertical layout guidelines are similar to the ones found in Visual Studio. You can see snap lines on the Visual Studio Integrated Designer as well as the Standalone Designer application.

Snap lines in ActiveReports Designer

Snap lines appear on the design surface by default. In order to disable them, click the Snap Lines button below the design surface, or in Section reports, hold down the [Alt] key while dragging a control to temporarily hide the snap lines.

Snap Lines button

When you drag a control on the design surface, blue snap lines appear and the control slows down as it aligns with another control or a section edge. Unless you are also using the Snap to Grid setting, with Snap Lines, the control can move freely around the report and can be placed anywhere on the design surface.

Tip: If you plan to export a report to Excel format, use snap lines to ensure that your controls are aligned in columns and rows to avoid empty cells or overlapping of controls in the spreadsheet.

Snap Line Behavior

On dragging with a mouse

When you drag report controls across the design surface, they snap to other controls, report and section edges. Snap lines appear when the control you are dragging aligns with any edge of any of the following:

  • Any control inside any section of the report.

  • Another control inside the same data region.

  • Parts of a data region (bands in a Banded List, or columns and rows in a Table).

  • Report edges and section edges.

  • Other control edges while resizing with a mouse.

  • On selecting multiple items where all the items move as a single unit, snap lines appear for all items in the selection.

With keyboard actions

  • Use [Ctrl] + [Shift] + Arrow keys to resize the selected control from one snap line to the next.
  • Use [Ctrl] + Arrow keys to move the selected control to the next snap line.
  • Use [Ctrl] + Left mouse button to copy the control and see snap lines appear between the edges of the copied control being dragged and the original control.
Note: Snap lines do not appear when you move a control with arrow keys.

See Also

Designer Buttons

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Zoom Support

Zoom Support
See Also
Developers > Work with Reports using Code > Visual Studio Integrated Designer > Zoom Support

Glossary Item Box

ActiveReports allows you to zoom in or out on the report design surface for better control over your report layout. As you zoom in or out, the size of every item on the design surface changes.

In the designer, you can access the zoom feature from the Zoom bar below the report design surface where the slider thumb is set to 100% by default. The slider allows you to zoom in and out of the report designer surface. Using this slider you can magnify the layout from 50% to 400%. You can also use the zoom in (+) and zoom out (-) buttons at either end of the slider to change the zoom level.

Zoom settings are also available on the ActiveReports toolbar where you can change the zoom percentage or use the zoom in/zoom out buttons. See Toolbar for further information.

Keyboard Shortcuts

You can hold down the Ctrl key and use the mouse wheel to zoom in and zoom out of the design surface.

You can also use keyboard shortcuts for the following functions:

  • [Ctrl] + [+] : Zoom in
  • [Ctrl] + [-] : Zoom out
  • [Ctrl] + 0 : Return to 100%

See Also

Design View

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Page/RDLX Report

Page/RDLX Report
See Also
Developers > Work with Reports using Code > Page/RDLX Report

Glossary Item Box

Page/RDLX reports is the ActiveReports extensions of the MS RDLX specification. Developers should clearly understand the behavior of these reports because it can conflict with other requirements.

  • Imagine an RDLX report as an infinite canvas (as well as a multi-section report as many canvases tied together) that can grow in two directions, depending on data. The pagination in this type of report works according to predefined RDLX rules - a page break before/after, orphaned headers/footers and other.
  • A Page report is a set of predefined pages with static and dynamic data content. If data doesn’t fit to a page, the entire page (static content) is cloned and filled with new dynamic data content. A Page report has a special control - OverflowPlaceHolder, to keep place to dynamic data.

From the developer’s perspective, such difference makes sense only in case of requirements to exports or master reports because:

  • Word DOCX export works well only with RDLX reports.
  • Excel export in the single page mode works well only with RDLX reports.
  • Excel Data export is similar to the RDLX report template.
  • Master reports support only RDLX reports.
  • Galley (not paginated) mode is available in RDLX reports only.
  • Only RDLX reports support header/footer. Per page static content (not only on header/footer) can be implemented in Page reports.

See Also

Create a Report or Load an Existing Report
Bind a Page/RDLX Report to Data
Save Page/RDLX Report
Merge Multiple Reports
Add Code to Layouts Using Script
Create a Custom Report Item
Apply Styles through Code

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create a Report or Load an Existing Report

Create a Report or Load an Existing Report
See Also
Developers > Work with Reports using Code > Page/RDLX Report > Create a Report or Load an Existing Report

Glossary Item Box

This topic discusses about creating and loading a Page or an RDLX report in designer using code. We recommend you to create a new report directly from the standalone designer or using the built-in project templates from Visual Studio.

Create a Report

Use NewReport() method in the Designer class to initialize the designer with a new report layout, with specified type. Make sure to add MESCIUS.ActiveReports.Design.Win package to your project.

C#. Add using statements on the top of Form.cs Copy Code
using System.Windows.Forms;
using GrapeCity.ActiveReports.Design;
C# code. Paste INSIDE the Form Load event Copy Code
var _designer = new Designer() { Dock = DockStyle.Fill };
_designer.NewReport(DesignerReportType.RdlMultiSection);
Controls.Add(_designer);

For details on using additional Designer class methods, properties, and events, refer to the Use End-User Report Designer API topic.

Load an Existing Report

Use the DefaultResourceLocator class especially in case when you are dealing with master reports (RDLX reports). You can create a new report with the master report and load it in the designer as shown. Make sure to add MESCIUS.ActiveReports.Core.Rdl package to your project.

C#. Add using statements on the top of Form.cs Copy Code
using System.Windows.Forms;
using GrapeCity.ActiveReports.Design;
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form Load event Copy Code
var _designer = new Designer() { Dock = DockStyle.Fill };
_designer.ResourceLocator = new DefaultResourceLocator(new Uri(path to master));
_designer.LoadReport(new FileInfo(path to report));

Load an RDLX file at Design Time

  1. From the Visual Studio > Report menu, select Load Layout.
    Note: The Report menu in Visual Studio 2019 and above is available as submenu under Extensions. You should select the Design View of the report in the ActiveReports Designer first.
  2. In the Open dialog that appears, navigate to the location of the .rdlx file and select it.
  3. Click the Open button to load the report layout.

See Also

Developers
Load Reports in WinForms Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind a Page/RDLX Report to Data

Bind a Page/RDLX Report to Data
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data

Glossary Item Box

The following topics provide information on data binding scenarios with Page/RDLX reports:

Bind Page/RDLX Report to Entity Framework and Other Data Providers

Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers

Bind Page/RDLX Report to Custom Data Providers (Oracle, PostgreSQL, SQLite)

Bind Page/RDLX Report to CSV, JSON and XML Data

Bind Page/RDLX Report to Data at Runtime

Use Dynamic Connection String in Data Source

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Page/RDLX Report to Entity Framework and Other Data Providers

Bind Page/RDLX Report to Entity Framework and Other Data Providers
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to Entity Framework and Other Data Providers

Glossary Item Box

You can bind your Page/RDLX reports to a data provider like Entity Framework, NHibernate, etc.

To connect to the Entity Framework data source in ActiveRepors, follow these basic steps:

  1. Initialize a selected data provider.
  2. Сreate a data layer that uses the selected data provider.
  3. Bind the data that you want to link to the report, using the data binding mechanism with objects. For more information, see the Object Provider section below.

Below is the example that illustrates binding to the Entity Framework in details. The example assumes that you have a database with the Product entity, which has ProductName and ProductID fields. A tuple of data retrieved from the database needs to be mapped to a table in a report.

Note: The sample report has already pre-configured fields in the table to match the fields from the entities.
  1. Initialize Entity Framework as a data provider.
    Copy Code
    // Your binding model
private class Product
{
    // Key
    public int ProductID { get; set; }
    // Fields
    public string ProductName { get; set; }
}

// Your database context
private class ProductsDatabaseContext : DbContext
{
    public ProductsDatabaseContext(string connectionstring) : base(connectionstring) { }
    public DbSet<Product> Products { get; set; }
}
  2. Create a data layer.
    Copy Code
    // Your data layer
private class ProductDataLayer
{
    private ProductsDatabaseContext _context;
    internal ProductDataLayer()
    {
        _context = CreateDataProvider();
    }
    private ProductsDatabaseContext CreateDataProvider()
    {
        // Your connection string to database
        string connectionString = "";
        return new ProductsDatabaseContext(connectionString);
    }
    internal IEnumerable<Product> GetProducts() => _context?.Products;
}
  3. Bind data by the data binding mechanism that uses objects.
    Copy Code
    private PageReport LoadReport()
{
    // Your path to the report
    string path = "";

    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += OnLocateDataSource;

    return report;
}
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    ProductDataLayer dataLayer = new ProductDataLayer();
    args.Data = dataLayer.GetProducts();
}

This approach allows you to work with any data provider and gives you the flexibility to customize your applications when working with reports.

DataSet Provider

To bind your Page/RDLX report to a DataSet, you must subscribe to the event that occurs when a report needs to locate a data source from the calling application:

Copy Code
report.Document.LocateDataSource += new LocateDataSourceEventHandler(OnLocateDataSource);

To connect to an unbound data source at run time, you can use the DataSet provider with the LocateDataSource event. The reporting engine raises the LocateDataSource event when it needs input on the data to use.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += new LocateDataSourceEventHandler(OnLocateDataSource);

    return report;
}
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    DataTable dataTable = new DataTable("Example");

    // Add the desired data to the dataset
    //
    // dataTable.Columns.Add(...);
    // dataTable.Rows.Add(...);
    //

    args.Data = dataTable;
}
Note: We assume that the report has defined data fields and datasets, which can be done by various ways, e.g., in the Web or Windows Forms Designer.

The DataSet provider has the following limitations:

  • Relationship names with periods are not supported.
  • Fields in nested relationships only traverse parent relationships (e.g. FK_Order_Details_Orders.FK_Orders_Customers.CompanyName).

To request a field from a parent table, prefix the field name with the name of the relation(s) that must be traversed to navigate to the appropriate parent table. Separate field names and relations with periods.

For example, consider a main table named OrderDetails with a parent table named Orders. A relation named Orders_OrderDetails defines the relationship between the two tables. Use a field with the syntax below to access the OrderDate from the parent table: Orders_OrderDetails.OrderDate.

Use this same technique to traverse multiple levels of table relations. For example, consider that the Orders table, used in the example above, has a parent table named Customers and a relation, binding the two, called Customers_Orders. If the CommandText specifies the main table as OrderDetails, use the following syntax to get the CustomerName field from the parent table: Customers_Orders.Orders_OrderDetails.CustomerName.

Note: An ambiguity can occur if a field and a relation have the same name. This is not supported.

Object Provider

Use the API to bind a Page/RDLX report to the Object data source.

In the example below, the report calls the LocateDataSource event, used to set data into the report. To do this, we create the OnLocateDataSource event handler and pass in it the data that will be transmitted to the report. The data is added as a new data source in the LocateDataSource event handler.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += new LocateDataSourceEventHandler(OnLocateDataSource);
    return report;
}
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    ArrayList data = new ArrayList();

    // Add the desired data to the collection
    //
    // data.Add(...);
    //

    args.Data = data;
}

Note: We assume that the report has defined data fields and datasets, which can be done by various ways, e.g., in the Web or Windows Forms Designer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers

Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers

Glossary Item Box

Using a database as a data source is one of the most common scenarios when you work with reports. This topic explains how to bind your ActiveReports report to a SQL, OLEDB or ODBC data source.

The example below uses a SQL database as a data source.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateCredentials += OnLocateCredentials;

    string dataProviderName = "SQL"; // Or use "OLEDB" or "ODBC" if you need it

    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if(dataSource.ConnectionProperties.DataProvider == dataProviderName)
    {
        dataSource.ConnectionProperties.ConnectString = ConfigurationManager.ConnectionStrings["YourConnectionString"].ConnectionString;
    }

    return report;
}
private void OnLocateCredentials(object sender, LocateCredentialsEventArgs args)
{
    args.Password = ""; // Your password if you need it
    args.UserName = ""; // Your username if you need it
}

Use the following strings to connect to different data providers:

  • SQL - Use this if you connect using the MS SQL Server. An example of a connection string:
    Copy Code
    Data Source=[sourceName];Initial Catalog=[dbName];Integrated Security=True;Connect Timeout=30;Encrypt=False;
  • OLEDB - Use this if you connect using the OLEDB driver. An example of a connection string:
    Copy Code
    Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[dbname];
  • ODBC - se this if you connect using the ODBC driver. An example of a connection string:
    Copy Code
    DRIVER=SQLite3 ODBC Driver;Database=[dbname]; LongNames=0; Timeout=1000; NoTXN=0; SyncPragma=NORMAL; StepAPI=0;
Note: When you are using an ODBC/OLEDB data provider, make sure that the required driver is installed on your computer. Otherwise, you cannot use this data provider.

When working with a data provider, you may need to process user credentials to work with the target source. The LocateCredentials event is used for this purpose.

Copy Code
report.Document.LocateCredentials += OnLocateCredentials;

Assign a handler that specifies the password and username when they are requested.

Copy Code
private void OnLocateCredentials(object sender, LocateCredentialsEventArgs args)
{
    args.Password = ""; // Your password if you need it
    args.UserName = ""; // Your username if you need it
}

The event handler receives an argument of the LocateCredentialsEventArgs type that contains data, related to this event. The following LocateCredentialsEventArgs properties provide information, specific to this event.

  • Password - Gets ot sets the password of the credentials to be located.
  • PromptText - Gets ot sets the password of the credentials to be located.
  • ReportPath - Gets the text of prompt of the locate credentials request.
  • UserName - Gets ot sets the user name of the credentials to be located.

Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Page/RDLX Report to Custom Data Providers (Oracle, PostgreSQL, SQLite)

Bind Page/RDLX Report to Custom Data Providers (Oracle, PostgreSQL, SQLite)
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers > Bind Page/RDLX Report to Custom Data Providers (Oracle, PostgreSQL, SQLite)

Glossary Item Box

Note: When you bind a report to any custom data provider, you need to modify the ActiveReports configuration file. See Configure ActiveReports using Config File for more information.

This topic explains how to connect to the following data providers:

  • Oracle: Oracle Database RDBMS. This is not a built-in data source and requires an external provider. This data source has a built-in support to locate credentials.
  • PostgreSQL: PostgreSQL RDBMS. This is not a built-in data source and requires an external provider. This data source has a built-in support to locate credentials.
  • SQLite: Compact embedded RDBMS. This is not a built-in data source and requires an external provider.

When working with a custom data provider, you may need to process user credentials to work with the target source. The LocateCredentials event is used for this purpose.

The event handler receives an argument of the LocateCredentialsEventArgs type, containing related data. The following LocateCredentialsEventArgs properties provide information, specific to this event.

  • Password: Gets ot sets the password of the credentials to be located.
  • PromptText: Gets ot sets the password of the credentials to be located.
  • ReportPath: Gets the text of prompt of the locate credentials request.
  • UserName: Gets ot sets the user name of the credentials to be located.

Oracle Database

The Oracle database is not a built-in data source and requires an external provider. However, this data source has a built-in support to locate credentials.

The example below shows what code you should add to the configuration file.

Copy Code
<ReportingConfiguration>
    <Extensions>
        <Data>
             <Extension Name="ORACLE" Type="Oracle.ManagedDataAccess.Client.OracleClientFactory, Oracle.ManagedDataAccess" DisplayName="Oracle Provider" />
        </Data>
    </Extensions>
</ReportingConfiguration>
Note: To use the Oracle data, you must install the Oracle.ManagedDataAccess or Oracle.ManagedDataAccess.Core NuGet package.

Add the following code to connect to the Oracle Database as a new data source.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateCredentials += OnLocateCredentials;
    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if(dataSource.ConnectionProperties.DataProvider == "ORACLE")
    {
        dataSource.ConnectionProperties.ConnectString = ""; // Your connection string
    }

    return report;
}
private void OnLocateCredentials(object sender, LocateCredentialsEventArgs args)
{
    args.Password = ""; // Your password if you need it
    args.UserName = ""; // Your username if you need it
}
Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

See an example of a connection string below.

Copy Code
Data Source=[database];User Id=[username];Password=[password];Integrated Security=no;

To handle user credentials, you should subscribe to the LocateCredentials event as follows.

Copy Code
report.Document.LocateCredentials += OnLocateCredentials;

You should also add a handler to manage the data.

Copy Code
private void OnLocateCredentials(object sender, LocateCredentialsEventArgs args)
{
    args.Password = ""; // Your password if you need it
    args.UserName = ""; // Your username if you need it
}

PostgreSQL Database

The PostgreSQL database is not a built-in data source and requires an external provider. However, this data source has a built-in support to locate credentials.

The example below shows what code you should add to the configuration file.

Copy Code
<ReportingConfiguration>
    <Extensions>
        <Data>
            <Extension Name="POSTGRESQL" Type="Npgsql.NpgsqlFactory, Npgsql" DisplayName="PostgreSQL Provider" />
        </Data>
    </Extensions>
</ReportingConfiguration>
Note: You must install the Npgsql NuGet package to use the PostgreSQL data.

Add the following code to connect PostgreSQL as a new data source.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateCredentials += OnLocateCredentials;

    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if(dataSource.ConnectionProperties.DataProvider == "POSTGRESQL")
    {
        dataSource.ConnectionProperties.ConnectString = ""; // Your connection string
    }
    return report;
}
private void OnLocateCredentials(object sender, LocateCredentialsEventArgs args)
{
    args.Password = ""; // Your password if you need it
    args.UserName = ""; // Your username if you need it
}

Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

See an example of a connection string below.

Copy Code
Uid=[username];Pwd=[password];Host=[host];Port=[port];Database=[dbName];

The code example illustrates that you are adding a PostgtreSQL data provider as a custom data provider. Subscribing to the LocateCredentials event allows you to handle user credentials.

SQLite or MS SQLite Database

The example below shows what code you should add to the configuration file.

Copy Code
<ReportingConfiguration>
    <Extensions>
        <Data>
            <Extension Name="SQLITE" Type="System.Data.SQLite.SQLiteFactory, System.Data.SQLite" DisplayName="SQLite Provider" />
        </Data>
    </Extensions>
</ReportingConfiguration>

Note: System.Data.SQLite or System.Data.SQLite.Core NuGet package must be installed for using Sqlite data.

You can also use MS SQLite. Add the following to the configuration file.

Copy Code
<ReportingConfiguration>
    <Extensions>
        <Data>
            <Extension Name="MSSQLITE" Type="Microsoft.Data.Sqlite.SqliteFactory, Microsoft.Data.Sqlite” DisplayName="MS SQLite Provider" />
        </Data>
    </Extensions>
</ReportingConfiguration>
Note: You must install the Microsoft.Data.Sqlite or Microsoft.Data.Sqlite.Core NuGet packages for using the MS SQLite data.

Add the following code to connect to SQLite database as a new data source.

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));

    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if(dataSource.ConnectionProperties.DataProvider == "SQLITE") // Or "MSSQLITE" if you use it
    {
        dataSource.ConnectionProperties.ConnectString = ""; // Your connection string
    }
    return report;
}

See an example of a connection string below.

Copy Code
Data Source=[dbName];Version=3;

Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Page/RDLX Report to CSV, JSON, and XML Data

Bind Page/RDLX Report to CSV, JSON, and XML Data
See Also
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to CSV, JSON, and XML Data

Glossary Item Box

You can use common data formats such as CSV, JSON, XML to bind your Page/RDLX report to data. You can use a provider with the LocateDataSource event to connect to unbound data sources at runtime. The reporting engine calls the LocateDataSource event when it needs data. To do this, you need to add a handler for this event and set the data for the report in it.

When using the LocateDataSource event as a data binding method, the general approach is as follows:

Copy Code
string path = ""; // Your path to the report
PageReport report = new PageReport(new FileInfo(path));
report.Document.LocateDataSource += (sender, args) => { // Data binding  };

The event handler receives an argument of the LocateDataSourceEventArgs type with data, related to this event. The following LocateDataSourceEventArgs properties provide information, specific to this event.

  • Data - The data returned by the event handler.
  • DataSet - Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
  • Parameters - Gets the Parameters collection specified for a given report instance.
  • Report - Gets the Report that is trying to locate the data set.

CSV Data Source

To connect to the CSV data source, use the following code:

Copy Code
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += new LocateDataSourceEventHandler(OnLocateDataSource);

    return report;
}
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    string data = ""; // Your csv string
    args.Data = data;
}
Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

To interact with the CSV data source, you can specify a connection string that includes the following parameters:

  • Specify the path to the CSV file
  • Specify the encoding
  • Specify the rows separator
  • Specify the columns separator
  • Specify the text qualifier
  • Specify the columns

You can also use the LocateDataSource event to add new data. Data is added as a new data source in the OnLocateDataSource event handler. To control this, you previously subscribed to this event. The reporting engine raises the LocateDataSource event when it needs data.

The LocateDataSource event handler sets the data in the required format as you can see in the sample below.

Copy Code
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    string data = ""; // Your csv string
    args.Data = data;
}

JSON Data Source

To demonstrate how to bind to JSON data, let's pass a string in the target format as a data source. To do this, you need to subscribe to the LocateDataSource event.

Copy Code
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    string data = ""; // Your json  string
    args.Data = data;
}
private PageReport LoadReport()
{
    string path = ""; // Your path to the report
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += OnLocateDataSource;

    return report;
}
Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

Data in the JSON format is assigned when the application calls the LocateDataSource event. Data is added as a new data source in the OnLocateDataSource event handler. To control this, you previously subscribed to this event. The reporting engine raises the LocateDataSource event when it needs data. To do this, we create the OnLocateDataSource event handler.

XML Data Source

The example below shows how to bind a report to the XML data source by subscribing to the LocateDataSource event and assigning a handler to it.

Copy Code
private void OnLocateDataSource(object sender, LocateDataSourceEventArgs args)
{
    XmlTextReader xmlReader = new XmlTextReader(""); // Your path to the xml file
    args.Data = xmlReader;
}
private PageReport LoadReport()
{
    string path = ""; // Your path to the report file
    PageReport report = new PageReport(new FileInfo(path));
    report.Document.LocateDataSource += OnLocateDataSource;

    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if(dataSource.ConnectionProperties.DataProvider == "XML")
    {
        dataSource.ConnectionProperties.ConnectString = "xmldoc="; // Your connection string
    }

    return report;
}

In the event handler, an XML file is assigned as a data source by using one of the allowed binding methods. For an XML file, these methods include XmlReader, XmlDocument, IXPathNavigable.

The reporting mechanism calls the LocateDataSource event, which is used to set the data into the report. To do this, you create the OnLocateDataSource event handler and pass in it the data that will be transmitted to the report.

Note: We assume that the report has defined data fields and datasets, which can be done in various ways, e.g., in the Web or Windows Forms Designer.

See Also

Nested Datasets

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Nested Datasets

Nested Datasets
See Also
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to CSV, JSON, and XML Data > Nested Datasets

Glossary Item Box

A nested dataset represents JSON or XML data as an hierarchical structure. A nested JSON or XML dataset is most commonly used in a bound data region, where you can partially use the dataset nodes for different data regions of your report.

Follow these steps to create a report with a JSON nested dataset that contains data on Movies and the movie information on Roles, created from JSON With Nested Data.json file.
Report with Nested Dataset at Preview

  1. In Visual Studio 2022, create a new Windows Forms project.
  2. Right-click the project in the Solution Explorer and select Manage NuGet Packages for Solution.
  3. On the Browse tab of the opened NuGet - Solution window, search and install the MESCIUS.ActiveReports and MESCIUS.ActiveReports.Design.Win NuGet packages.
  4. On the Form.cs, double-click the title bar to create the Form1_Load event.
  5. At the top of the Form1 code view, add these using directives.
    Paste at the top of the Form1.cs Copy Code
    using GrapeCity.ActiveReports.Design.ReportExplorer;
using GrapeCity.ActiveReports.Design;
using GrapeCity.ActiveReports.PageReportModel;
using GrapeCity.ActiveReports;
using System.Xml;
using TextBox = GrapeCity.ActiveReports.PageReportModel.TextBox;
using DataSet = GrapeCity.ActiveReports.PageReportModel.DataSet;
using DataSource = GrapeCity.ActiveReports.PageReportModel.DataSource;
using Field = GrapeCity.ActiveReports.PageReportModel.Field;
  6. In the existing code, add the following code.
    Add to Form1.cs Copy Code
    namespace NestedDataSetSample
{
    public partial class Form1 : Form
    {
        Designer designer;
        PropertyGrid propertyGrid;
        ReportExplorer reportExplorer;
        PageReport report;
        ReportSection section;
        public Form1()
        {
            InitializeComponent();
        }
  7. Add the following code to the Form1_Load event.
    C# code. Paste INSIDE the Form1_Load event. Copy Code
    {
    CreateLayout();
    CreateReport();
    CreateDataRegions();
    CreateDataSource();
    designer.LoadReport(XmlReader.Create(new StringReader(report.ToRdlString())), DesignerReportType.Page);
}
  8. In the existing code, add the following code to create the Designer, PropertyGrid and ReportExplorer objects.
    C# code. Paste AFTER the Form1_Load event. Copy Code
    private void CreateLayout()
{
    designer = new Designer() { Dock = DockStyle.Fill };
    propertyGrid = new PropertyGrid() { Dock = DockStyle.Right };
    designer.PropertyGrid = propertyGrid;
    reportExplorer = new ReportExplorer()
    {
        Dock = DockStyle.Left,
        ReportDesigner = designer
    };
    Controls.Add(designer);
    Controls.Add(propertyGrid);
    Controls.Add(reportExplorer);
}
  9. Add the following code to create the PageReport and ReportSection objects.
    C# code. Paste AFTER CreateLayout() Copy Code
    private void CreateReport()
{
     report = new PageReport();
     section = new ReportSection();
     section.Name = "Section1";
     section.Width = "15cm";
     section.Body.Height = "20cm";
     report.Report.ReportSections.Add(section);
}
  10. Add the following code to create data regions that will contain report data.
    C# code. Paste AFTER CreateReport() Copy Code
    private void CreateDataRegions()
        {
            List listMovies = new List()
            {
                Name = "List_Movies",
                Top = "0.8cm",
                Left = "0.6cm",
                Width = "11cm",
                Height = "5cm",
                Style = new Style() { FontFamily = "Arial" },
                DataSetName = "Movies",
                ZIndex = 1
            };
            listMovies.ReportItems.Add(new TextBox()
            {
                Name = "TextBox_Title",
                Top = "0.6cm",
                Left = "1cm",
                Width = "2.5cm",
                Height = "0.75cm",
                Style = new Style()
                {
                    FontFamily = "Arial",
                    PaddingBottom = "2pt",
                    PaddingLeft = "2pt",
                    PaddingRight = "2pt",
                    PaddingTop = "2pt"
                },
                Value = "=Fields!Title.Value",
                DataElementName = "Title",
                ZIndex = 1
            });
            List listCast = new List()
            {
                Name = "List_Cast",
                Top = "1.8cm",
                Left = "1.4cm",
                Width = "5cm",
                Height = "2.2cm",
                Style = new Style() { FontFamily = "Arial" },
                ZIndex = 2,
                DataSetName = "Cast"
            };
            listCast.ReportItems.Add(new TextBox()
            {
                Name = "TextBox_Name",
                Top = "0.6cm",
                Left = "0.6cm",
                Width = "2.5cm",
                Height = "0.75cm",
                Style = new Style()
                {
                    FontFamily = "Arial",
                    PaddingBottom = "2pt",
                    PaddingLeft = "2pt",
                    PaddingRight = "2pt",
                    PaddingTop = "2pt"
                },
                DataElementName = "Name",
                Value = "=Fields!Name.Value",
            });
            listMovies.ReportItems.Add(listCast);
            section.Body.ReportItems.Add(listMovies);
        }
  11. Add the following code to create a JSON data source, add a dataset and a nested dataset, and add fields to both datasets.
    C# code. Paste AFTER CreateDataRegions() Copy Code
    private void CreateDataSource()
        {
            DataSource dataSource = new DataSource();
            dataSource.Name = "JSONDataSource";
            dataSource.ConnectionProperties = new ConnectionProperties()
            {
                DataProvider = "JSON",
                ConnectString = "jsondoc={path to file}\\JSON With Nested Data.json"
            };
            report.Report.DataSources.Add(dataSource);
            report.Report.DataSets.Add(CreateDataSet(dataSource));
            report.Report.DataSets.Add(CreateSecondDataSet());
        }
        private DataSet CreateDataSet(DataSource _DataSource)
        {
            Query query = new Query
            {
                Timeout = 30,
                CommandText = "$.Movie[*]",
                DataSourceName = _DataSource.Name,
            };
            DataSet dataSet = new DataSet
            {
                Query = query,
                Name = "Movies",
            };
            CreateFieldsToDataSet(dataSet);
            return dataSet;
        }
        private DataSet CreateSecondDataSet()
        {
            Query query = new Query
            {
                Timeout = 30,
                CommandText = "$",
                DataSourceName = "$dataset:Movies/Cast",
            };
            DataSet dataSet = new DataSet
            {
                Query = query,
                Name = "Cast",
            };
            CreateFieldsToSecondDataSet(dataSet);
            return dataSet;
        }
        private void CreateFieldsToDataSet(DataSet dataSet)
        {
            Field field = new Field
            {
                DataField = "Title",
                Name = "Title"
            };
            dataSet.Fields.Add(field);
        }
        private void CreateFieldsToSecondDataSet(DataSet dataSet)
        {
            Field field = new Field
            {
                DataField = "Name",
                Name = "Name"
            };
            dataSet.Fields.Add(field);
        }
  12. Add the following code to load the report to the Designer in Form1_Load event.
    C# code. Paste INSIDE the Form1_Load event. Copy Code
    designer.LoadReport(XmlReader.Create(new StringReader(report.ToRdlString())), DesignerReportType.Page);
  13. Run the project and preview the report.

See Also

Quick Start

Report Authors
Nested Datasets (JSON and XML)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Page/RDLX Report to Data at Run Time

Bind Page/RDLX Report to Data at Run Time
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report to Data at Run Time

Glossary Item Box

Create a data source

Before creating a data source, you must first decide what type of data source you need. ActiveReports supports all most common types of data sources, providing a flexible interface for interacting with them.

An example below demonstrates how to create your data source and add it to the report.

Copy Code
private PageReport LoadReport()
{
    // Your path to the report
    string path = "";

    PageReport report = new PageReport(new FileInfo(path));

    DataSource dataSource = CreateDataSource();
    report.Report.DataSources.Add(dataSource);
    return report;
}
private DataSource CreateDataSource()
{
    ConnectionProperties connectionProperties = new ConnectionProperties
    {
        ConnectString = "", // Your connection string to data source
        DataProvider = "", // Your data provider name
        IntegratedSecurity = true, // or set it to False if you don't need it
    };
    DataSource dataSource = new DataSource
    {
        Name = "", // Your data source name
        ConnectionProperties = connectionProperties,
    };
    return dataSource;
}

The CreateDataSource method returns an instance of the DataSource class. This method encapsulates the logic of creating a new data source.

There are two main steps in creating a data source.

1. Creating connection parameters.

Copy Code
ConnectionProperties connectionProperties = new ConnectionProperties
{
    ConnectString = "", // Your connection string to data source
    DataProvider = "", // Your data provider name
    IntegratedSecurity = true, // or set it to False if you don't need it
};

When creating a data source, you can use the following most common data provider names and your own data providers from the configuration file:

  • SQL - Connection with MS SQL Server.
  • OLEDB - Connection with OleDB drivers.
  • ODBC - Connection with ODBC drivers.
  • CSV - Connection with CSV data.
  • JSON - Connection with JSON data.
  • XML - Connection with XML data.

2. Creating a data source.

Copy Code
DataSource dataSource = new DataSource
{
    Name = "", // Your data source name
    ConnectionProperties = connectionProperties,
};

Note that creating your own data source may require additional settings for the report. If you need to modify an existing data source in the report, then use this series of articles.

  • Bind Page/RDLX Report to Entity Framework and Other Data Providers (Entity Framework, DataSet, Object data providers)
  • Bind Page/RDLX Report to SQL, OLEDB, and ODBC Data Providers
  • Bind Page/RDLX Report to CSV, JSON, and XML Data

Create a data set

Data sets are an integral part of almost any report you create in ActiveReports. An example below demonstrates how to create your data set and add it to the report.

Copy Code
private PageReport LoadReport()
{
    // Your path to the report
    string path = "";

    PageReport report = new PageReport(new FileInfo(path));
    // Create your own data source or use an existing one
    DataSource dataSource = new DataSource();
    report.Report.DataSources.Add(dataSource);
    DataSet dataSet = CreateDataSet(dataSource);
    report.Report.DataSets.Add(dataSet);
    return report;
}
private DataSet CreateDataSet(DataSource dataSource)
{
    // Your request for data
    Query query = new Query
    {
        Timeout = 30, // Your timeout
        CommandText = "", // Your SQL command
        DataSourceName = dataSource.Name,
    };
    // Your data set
    DataSet dataSet = new DataSet
    {
        Query = query,
        Name = "", // Your dataset name
    };
    // Adding fields to the created dataset
    CreateFieldsToDataSet(dataSet);
    return dataSet;
}
private void CreateFieldsToDataSet(DataSet dataSet)
{
    // Your field to add the data set
    Field field = new Field
    {
        DataField = "", // Your name of the field in the query
        Name = "", // Your name to use for the field within the report
    };
    dataSet.Fields.Add(field);
}

In this example, the creation of a data set is divided into the following steps:

  1. Create a data source that will be used to build a data set. See the Create a data source section above for details.
  2. Create a query instance that contains a description of the query that must be executed to retrieve the data.
    Copy Code
    // Your request for data
Query query = new Query
{
    Timeout = 30, // Your timeout
    CommandText = "", // Your SQL command
    DataSourceName = dataSource.Name,
};
  3. Create a data set instance and pass a previously created query instance into it.
    Copy Code
    // Your data set
DataSet dataSet = new DataSet
{
    Query = query,
    Name = "", // Your data set name
};
  4. Add fields to your previously created data set if you need them.
    Copy Code
    private void CreateFieldsToDataSet(DataSet dataSet)
{
    // Your field to add the data set
    Field field = new Field
    {
        DataField = "", // Your name of the field in the query
        Name = "", // Your name to use for the field within the report
    };
    dataSet.Fields.Add(field);
}

Note: The sample report must contain controls to work with the specified fields in the data set.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Use Dynamic Connection String in Data Source

Use Dynamic Connection String in Data Source
Developers > Work with Reports using Code > Page/RDLX Report > Bind a Page/RDLX Report to Data > Bind Page/RDLX Report at Run Time > Use Dynamic Connection String in Data Source

Glossary Item Box

Adding a dynamic connection string to a data source is a convenient tool that allows you to change the connection string during the report execution. This is achieved by using parameterized parameters in the connection string, or by using completely different connection strings for completely different databases.

This topic describes two basic ways of working with dynamic connection strings:

  1. The full connection string as a parameter.
  2. Individual elements of the connection string as a parameter.

Using the dynamic connection string as a parameter makes it much easier to manage the connection string at runtime. You can set the connection string as a parameter in several ways:

  1. Use a Windows or Web application to create a report and create parameters that the report will use.
  2. Create these parameters and connection strings, using the code.

Create a dynamic connection string in the Windows or Web application

Creating a dynamic connection string in a Windows or Web application is a common scenario when interacting with the parameters of your report. Follow these steps to create a dynamic connection string.

Note: The sample below uses the Windows Forms Designer.
  1. Create a report and go to the Report - Parameters dialog to specify the report settings.
    Report Parameters Dialog Available Values
  2. Click OK to close the Report - Parameters dialog and open the Report Data Source dialog. In the opened dialog, select the type of the database connection. The example below uses Microsoft Sql Client Provider.
    Report Data Source Dialog Connection string for Microsoft Sql Client Provider
Note: The value =Parameters!dbName.Value is the value from the Name field, specified in step 1.

By following these steps, you will use the created data source while designing a report in the Windows or Web application and also manage it, using the code as demonstrated below.

Copy Code
private PageReport LoadReport()
{
    // Your path to the report
    string path = "";
    // 0 - "Database1" from step 1
    // 1 - "Database2" from step 1
    int databaseIndex = 0;
    // If "true", you must choose which database to use, otherwise the one you specified will be automatically selected
    bool showDatabaseSelection = false;
    PageReport report = new PageReport(new FileInfo(path));
    ConfigureConnectionString(databaseIndex, report, showDatabaseSelection);
    return report;
}
private void ConfigureConnectionString(int databaseIndex, PageReport report, bool showDatabaseSelection=true)
{
    if (!showDatabaseSelection)
    {
        // Select the connection string from the previously created parameter
        string connectionString = report.Report.ReportParameters[0].ValidValues.ParameterValues[databaseIndex].Value.ToString();
        report.Report.ReportParameters.Clear();
        report.Report.DataSources[0].ConnectionProperties.ConnectString = connectionString;
    }
}

The ConfigureConnectionString method takes values as parameters, indicating what database to use from a previously created parameter.

Create a dynamic connection string in code

This code example shows how to create a string.

Copy Code
private PageReport LoadReport()
{
    // Your path to the report
    string path = "";

    PageReport report = new PageReport(new FileInfo(path));
    // Create dynamic connection strings
    report.Report.ReportParameters.Add(CreateDynamicConnectionString());

    DataSource dataSource = report.Report.DataSources[0]; // Your data source
    if (dataSource.ConnectionProperties.DataProvider == "SQL") // Use any other database
    {
        // Set a dynamic string to connect to the data source
        dataSource.ConnectionProperties.ConnectString = @"=Parameters!dbName.Value";
    }
    return report;
}
private ReportParameter CreateDynamicConnectionString()
{
    string database1 = ""; // Your first connection string
    string database2 = ""; // Your second connection string
    ValidValues validValues = CreateValidValues(database1, database2);
    ReportParameter dynamicString = new ReportParameter
    {
        AllowBlank = true,
        DataType = ReportParameterDataType.String,
        Name = "", // The name of your parameter. It is used in the connection string
        ValidValues = validValues,
        Nullable = false,
        Prompt = ""
    };
    return dynamicString;
}
private ValidValues CreateValidValues(string firstConnString, string secondConnString)
{
    // The label of your parameter is "Database1"
    ParameterValue firstParameter = CreateParameterValue("Database1", firstConnString);
    // The label of your parameter is "Database2"
    ParameterValue secondParameter = CreateParameterValue("Database2", secondConnString);
    ValidValues validValues = new ValidValues();
    validValues.ParameterValues.Add(firstParameter);
    validValues.ParameterValues.Add(secondParameter);
    return validValues;
}
private ParameterValue CreateParameterValue(string label, string value)
{
    return new ParameterValue()
    {
        Label = label,  // The Label of your parameter value
        Value = value,
    };
}

Looking at the code above, you can see that creating a dynamic connection string consists of 2 steps.

  1. Creating the dynamic string parameter.
    Copy Code
    report.Report.ReportParameters.Add(CreateDynamicConnectionString());
    It is important to create a report parameter because it stores information and connection strings. If this is not done or done incorrectly, nothing will work. This procedure is performed with the CreateDynamicConnectionString, CreateValidValues, and CreateParameterValue methods.
  2. Applying this parameter to the data source in the connection string.
    Copy Code
    DataSource dataSource = report.Report.DataSources[0]; // Your data source
if (dataSource.ConnectionProperties.DataProvider == "SQL")
{
    // Set a dynamic string to connect to the data source
    dataSource.ConnectionProperties.ConnectString = @"=Parameters!dbName.Value";
}
    In the example above you will notice that it uses a connection to the SQL provider. However, you can use a different database at this point. See Bind Page/RDLX Report at Run Time for the list of available database providers.
    Note that you need to specify a previously created parameter as a connection string, not the value of the connection string itself.
    Copy Code
    // Set a dynamic string to connect to the data source
dataSource.ConnectionProperties.ConnectString = @"=Parameters!dbName.Value";
    For example, a connection string that you can place in a parameter looks like this.
    Copy Code
    Data Source=[data source];Initial Catalog=[initial catalog];Integrated Security=True;Connect Timeout=30;Encrypt=False
    If you want to change only a part of the parameter, just change the connection string as follows.
    Copy Code
    // Set a dynamic string to connect to the data source
dataSource.ConnectionProperties.ConnectString = "=\"Data Source=[data source];Initial Catalog=\" & Parameters!dbName.Value & \";Integrated Security=True;Connect Timeout=30;Encrypt=False\"";
    In the CreateDynamicConnectionString method, you need to pass the names of the databases, not the full connection strings:
    Copy Code
    string database1 = "example1"; // Your first database name
string database2 = "example2"; // Your second database name
    Having done this, you will be asked, which database name is substituted in your connection string at the stage of thre report execution.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Save Page/RDLX Report

Save Page/RDLX Report
Developers > Work with Reports using Code > Page/RDLX Report > Save Page/RDLX Report

Glossary Item Box

The topic describes saving a Page/RDLX report.

Save a report as an RDLX file at design time

  1. From the Visual Studio Report menu, select Save Layout.
    Note: The Report menu in Visual Studio 2019 and above is available as submenu under Extensions. You should select the Design View of the report in the ActiveReports Designer first.
  2. In the Save As dialog that appears, set the file name and select the location where you want to save it. The file extension is *.rdlx.
  3. Click the Save button to save the report layout and close the dialog.

Save a report as an RDLX file at run time

Use the Save method to save your report layout at run time.

  1. Right-click the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the Form class to save the report.

    The following example shows what the code for the method looks like to save a Page or an RDLX report.

    VB# code. Paste INSIDE the Form class Copy Code
    Private Sub SaveButton_Click(ByVal sender As Object, ByVal e As EventArgs)
    Dim saveFileDialog As SaveFileDialog = New SaveFileDialog()
    saveFileDialog.Title = "Save Report"
    saveFileDialog.Filter = "Page Report Files|*.rdlx"
    saveFileDialog.ShowDialog()
    If saveFileDialog.FileName <> "" Then
        pageReport.Save(New FileInfo(saveFileDialog.FileName))
    End If
End Sub
    C# code. Paste INSIDE the Form class Copy Code
    private void SaveButton_Click(object sender, EventArgs e)
{

    SaveFileDialog saveFileDialog = new SaveFileDialog();
    saveFileDialog.Title = "Save Report";
    saveFileDialog.Filter = "Page Report Files|*.rdlx";
    saveFileDialog.ShowDialog();
    if (saveFileDialog.FileName != "")
        {
            //Save Report File
           pageReport.Save(new FileInfo(saveFileDialog.FileName));
        }
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Merge Multiple Reports

Merge Multiple Reports
Developers > Work with Reports using Code > Page/RDLX Report > Merge Multiple Reports

Glossary Item Box

Multiple RDLX and Page Reports can be merged or combined into one report. The ReportCombiner class is used for performing merging, which adds the reports as subreports or report sections. The ReportSections property (CombineMode enum) is a default property, indicating that the final multi-section report will contain each report as a section. With the SubReports property, marked as obsolete, a final report will have a single body, containing subreports for every merged report.

The reports are merged one after the another, in the order in which they are added. To combine the reports correctly, you should use reports with the same layouts. For Page reports, you need to set equal margins for all reports and for RDLX reports, you need to set equal margins and width for all reports. See Layout topic for more information.

Having access to BuildReport method, user can use full PageReport class functionality. You can add a page break or specify the gap between two reports.

You can use the BuildReport method to utilize all the features of the PageReport class. You can also insert page breaks and specify the gap between two reports when merging. By default, the gap of 1 inch is added between the reports.

The following code examples demonstrate merging reports in different scenarios. You need to add following packages to your project:

  • MESCIUS.ActiveReports
  • MESCIUS.ActiveReports.Viewer.Win
  • MESCIUS.ActiveReports.Export.Pdf (for exporting the merged report in PDF format)

Combine Three Reports

Visual Basic.NET. Paste inside Form1_Load event. Copy Code
Dim combiner = New GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner()

Dim r1 = New GrapeCity.ActiveReports.PageReport()
r1.Load(New System.IO.FileInfo("c:\temp\Report1.rdlx"))

Dim r2 = New GrapeCity.ActiveReports.PageReport()
r2.Load(New System.IO.FileInfo("c:\temp\Report2.rdlx"))

Dim r3 = New GrapeCity.ActiveReports.PageReport()
r3.Load(New System.IO.FileInfo("c:\temp\Report3.rdlx"))

combiner.SetMargin("0cm")
combiner.DefaultStep = "0cm"

'Set Combine Mode as ReportSections (default) Or as SubReports (obsolete)
combiner.Mode = GrapeCity.ActiveReports.ReportsCore.Tools.CombineMode.ReportSections

combiner.AddReport(r1)

Dim options = New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions
options.Gap = "5in" 'adds a 5 inch gap from the first report. By default this gap is 1 inch.
options.PageBreakBefore = True 'adds a page break.

combiner.AddReport(r2, options)
combiner.AddReport(r3)

'Create and Save Combined/Merged Report
combiner.BuildReport().Save(New System.IO.FileInfo("c:\temp\CombinedReport.rdlx"))

'Load Combined Report in viewer
Viewer1.LoadDocument(combiner.BuildReport().Document)

'PDF Rendering extension
Dim pdfRe = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim provider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(New System.IO.DirectoryInfo("c:\temp\"), "CombinedReport")

combiner.BuildReport().Document.Render(pdfRe, provider) 'export combined report in PDF format

C# code Copy Code
var combiner = new GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner();

var r1 = new GrapeCity.ActiveReports.PageReport();
r1.Load(new System.IO.FileInfo(@"c:\temp\Report1.rdlx"));

var r2 = new GrapeCity.ActiveReports.PageReport();
r2.Load(new System.IO.FileInfo(@"c:\temp\Report2.rdlx"));

var r3 = new GrapeCity.ActiveReports.PageReport();
r3.Load(new System.IO.FileInfo(@"c:\temp\Report3.rdlx"));

combiner.SetMargin("0cm");
combiner.DefaultStep = "0cm";

//Set Combine Mode as ReportSections (default) or as SubReports (obsolete)
combiner.Mode = GrapeCity.ActiveReports.ReportsCore.Tools.CombineMode.ReportSections;

combiner.AddReport(r1);
combiner.AddReport(r2, new LocationOptions() { PageBreakBefore = true, Gap = "5in" }); //adds second report after a page break and a 5 inch gap from the first report. By default this gap is 1 inch.
combiner.AddReport(r3);

//Create and Save Combined/Merged Report
combiner.BuildReport().Save(new System.IO.FileInfo(@"c:\temp\CombinedReport.rdlx"));

//Load Combined Report in Viewer
viewer1.LoadDocument(combiner.BuildReport().Document);

//PDF Rendering extension
var pdfRe = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
var provider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(new System.IO.DirectoryInfo(@"c:\temp\"), "CombinedReport");

combiner.BuildReport().Document.Render(pdfRe, provider); //export combined report in PDF format

The merged reports can be modified in many ways as described below.

Add reports at particular index

If you want to add a report r4 after the first report r1, use the following code with index '1':

C# Copy Code
combiner.Insert(1, r4, new LocationOptions());
report = combiner.BuildReport();
VB.NET Copy Code
combiner.Insert(1, r4, New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions())
report = combiner.BuildReport()

Add a list of reports

C# Copy Code
combiner.AddRange(new PageReport[] {r1, r2, r3, r4 }, new LocationOptions())
report = combiner.BuildReport();
VB.NET Copy Code
Dim reports As IEnumerable(Of GrapeCity.ActiveReports.PageReport) = {r1, r2, r3, r4}
combiner.AddRange(reports, New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions())
report = combiner.BuildReport()

Delete report(s)

If you want to delete a report in first position, use the following code with index '0':

C# Copy Code
combiner.RemoveAt(0);
report = combiner.BuildReport();
VB.NET Copy Code
combiner.RemoveAt(0)
report = combiner.BuildReport()

Similarly, if you want to delete report at second position, use index '1'.

If you want to delete all instances of report r2, use the following code:

C# Copy Code
combiner.RemoveAll(r2);
report = combiner.BuildReport();
VB.NET Copy Code
combiner.RemoveAll(r2)
report = combiner.BuildReport()

Note:

  • If the reports being merged are of different sizes, the page size of the first report is applied to all the pages of combined report.
  • If the reports being merged are of different paper orientations, the paper orientation of the first report is applied to all the pages of combined report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add Code to Layouts Using Script

Add Code to Layouts Using Script
Developers > Work with Reports using Code > Page/RDLX Report > Add Code to Layouts Using Script

Glossary Item Box

In a Page Report or an RDLX Report, you can create and maintain a custom assembly for code that you want to use in multiple reports and refer to its methods in expressions. The Script tab in Visual Studio Integrated Designer opens the script editor, where you can provide VB.NET functionality to the reports without compiling the .vb file.

Script Tab

Note:

  1. You should be aware that scripts allow you to execute different code and can create a security gap. Therefore, it is not recommended to use scripts in web/cloud environments.
  2. In WebDesigner, the Scripts are available for Section reports only.

Some of the simpler Page/RDLX report scripting capabilities are discussed in the Scripts topic.

To turn on or off scripts in End-User Report Designer,

  • set the EnableScripting property of the designer.
    Enable Scripting in Designer Tab

  • Or use the following code in Form1.Designer.cs:
    For WinForms Designer Copy Code
    _designer.EnableScripting = false;

Create custom assemblies

You can create custom assemblies in C# or Visual Basic .NET to make code available to multiple reports:

  1. Create or find the assembly you wish to use. The assemblies can be found at the installed location: C:\Program Files (x86)\MESCIUS\ActiveReports 19\NuGet\{Package name}\lib\net46\{Assembly}
  2. Make the assembly available to the report engine.
    • If you are embedding the designer or viewer controls in your own application, copy the assembly to the same location as your executable.
    • If you are using the included designer or viewer, copy the assembly into the ActiveReports assembly folder located at ...\MESCIUS\ActiveReports 19 by default.
      Note: To make the assembly available for use in your own application and for use in designing reports for your application, copy it to both locations listed above. Alternatively, you can place the assembly in the Global Assembly Cache (C:\Windows\assembly).
  3. Add an assembly reference to the report.
    1. From the Report Menu, choose Report Properties.
    2. In the Report dialog that appears, select References and click the Open icon above the assembly name list to add your own assembly.
    3. Go to the Class list below the assembly names and under Class name, enter the namespace and class name. Similarly, under Instance name, enter the name you want to use in your expressions.
      Add Assemby Reference - Custom Assemblies
  4. Access the assembly through expressions.
    • To access static members (member denoted as public static in C# assemblies, or as Public Shared in Visual Basic assemblies):
      =Namespace.Class.Member
    • To access class instances:
      =Code.InstanceName

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create a Custom Report Item

Create a Custom Report Item
Developers > Work with Reports using Code > Page/RDLX Report > Create a Custom Report Item

Glossary Item Box

Custom report items (CRIs) are supported in all Viewers and all types of exports. However, they are not currently supported in the WebDesigner component.

Note: Currently, you need to use some internal API to create a CRI, which we are planning to change in the future versions. In case of any problems that may occur during upgrade, contact our Support Team.

With a CRI, you can implement the following tasks:

  • Implement simple custom rendering, which may be useful for implementing a simple rendering like a custom SVG image, a custom barcode, etc.
  • Implement a custom layout, which may be useful in case of a custom content layout (if size is not defined, etc.).
  • Implement custom data processing, which is the most complicated scenario where a CRI requests data from a data set. We recommend that you first check these samples before you start the implementation - CustomChart and Calendar.

To implement a simple CRI, see the RadarChart.cs file in the CustomChart sample to have an idea of what your CRI implementation should look like. If you require access to data, then you should use the IDataRegion interface.

To implement the Designer, see the RadarDesigner.cs file in the CustomChart sample. Remember that the DataSet is required only in case of data binding (the IDataRegion interface). Otherwise, you can use just a simple property that is passed and obtained from a CRI as ReportItem.CustomProperties.

You should also remember to add a configuration file - you can find an example in the CustomChart sample.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Apply Styles through Code

Apply Styles through Code
See Also
Developers > Work with Reports using Code > Page/RDLX Report > Apply Styles through Code

Glossary Item Box

The following steps set a style sheet source and apply style to a TextBox control.

  1. In Visual Studio, create a new Page Report Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    'Path and Name of the loaded PageReport
Dim filePath As String = "C:\SampleReport.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(filePath))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)

' Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External
reportDocument.PageReport.Report.StyleSheetValue = "C:\ExternalStyle.rdlx-styles"

' Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1

' Add a Textbox control and apply style
Dim text As New GrapeCity.ActiveReports.PageReportModel.TextBox()
text.Value = "Sample Text"
text.Style.StyleName = "Style1"
pageReport.Report.Body.ReportItems.Add(text)
viewer1.LoadDocument(reportDocument)

    C# code. Paste INSIDE the Form Load event. Copy Code
    //Path and Name of the loaded PageReport
string filePath = @"C:\SampleReport.rdlx";
GrapeCity.ActiveReports.PageReport pageReport =
new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(filePath));
GrapeCity.ActiveReports.Document.PageDocument reportDocument =
new GrapeCity.ActiveReports.Document.PageDocument(pageReport);

// Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External;
reportDocument.PageReport.Report.StyleSheetValue = @"C:\ExternalStyle.rdlx-styles";

// Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded;
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1";

// Add a Textbox control and apply style
GrapeCity.ActiveReports.PageReportModel.TextBox text =
new GrapeCity.ActiveReports.PageReportModel.TextBox();
text.Value = "Sample Text";
text.Style.StyleName = "Style1";
pageReport.Report.Body.ReportItems.Add(text);
viewer1.LoadDocument(reportDocument);

See Also

Report Authors
Styles

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Section Report

Section Report
See Also
Developers > Work with Reports using Code > Section Report

Glossary Item Box

Section report is a format that is similar to the RDLX report type with the BandedList data region in the paginated mode. ActiveReports supports two kinds of Section reports:

  • Xml-based Section report (RPX) is an XML-based format that uses event handlers as restricted scripts. This is your best choice if you can write code scripts.
  • Code-based Section report (CodeDOM) best meets your needs if you are developer and can support the report along with the application. The Designer is available with Visual Studio only but you can perform many report operations using event handlers. In Visual Studio 2022, only .NET Framework 4.8 and .NET 8/.NET 9 are supported for code-based section reports.

See Also

Create a Report or Load an Existing Report
Bind a Section Report to Data
Save Section Reports
Modify Printer Settings
Insert or Add Report Pages
Save and Load RDF Files
Work with Subreports
Work with Code-based Section Reports
Optimize Section Reports
Custom Properties in Chart
Draw on the Canvas of Rendered Report
Change Ruler Measurements

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create a Report or Load an Existing Report

Create a Report or Load an Existing Report
See Also
Developers > Work with Reports using Code > Section Report > Create a Report or Load an Existing Report

Glossary Item Box

This topic discusses about creating and loading a Section Report (xml or code based) in designer using code. We recommend you to create a new report directly from the standalone designer or you using the built-in project templates from Visual Studio.

Create a Report

Use NewReport() method in the Designer class to initialize the designer with a new report layout, with specified type. Make sure to add MESCIUS.ActiveReports.Design.Win package to your project.

C#. Add using statements on the top of Form.cs Copy Code
using System.Windows.Forms;
using GrapeCity.ActiveReports.Design;
C# code. Paste INSIDE the Form Load event Copy Code
var _designer = new Designer() { Dock = DockStyle.Fill };
_designer.NewReport(DesignerReportType.Section);
Controls.Add(_designer);

Load an RPX file at Design Time

  1. From the Visual Studio > Report menu, select Load Layout.
    Note: The Report menu in Visual Studio 2019 and above is available as submenu under Extensions. You should select the Design View of the report in the ActiveReports Designer first.
  2. In the Open dialog that appears, navigate to the location of the .rpx file and select it.
  3. Click the Open button to load the report layout.

Load an RPX file into the ActiveReports Viewer at Run Time

Use the LoadLayout(XmlReader) method to load your report layout at run time.

  1. Right-click on the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the form class to load a report.

    The following examples show what the code for the method looks like.

    Visual Basic.NET code. Paste INSIDE the Form class. Copy Code
    Dim rpt As New GrapeCity.ActiveReports.SectionReport()
' For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
Viewer1.Document = rpt.Document
rpt.Run()
    C# code. Paste INSIDE the Form class. Copy Code
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
// For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
viewer1.Document = rpt.Document;
rpt.Run();

See Also

Draw on the Canvas of Rendered Report

Developers
Load Reports in WinForms Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind a Section Report to Data

Bind a Section Report to Data
Developers > Work with Reports using Code > Section Report > Bind a Section Report to Data

Glossary Item Box

You can use one of the following ways to bind a section report to data at run time:

  • You can bind a section report to a data source.
  • You can bind your section report to a dataset and unbound data.

A Section report also allows to locate data in scripts and can help locate credentials for some built-in data sources.

The LocateCredentials event can work with the following data source types:

  • SQL
  • OleDB
  • ODBC

The following topics provide information on the data binding scenarios with Section reports:

Bind a Section report to a Data Source at Run Time

Bind Data Set and Unbound Data to Section Report at Run Time

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind a Section Report to Data Source at Run Time

Bind a Section Report to Data Source at Run Time
Developers > Work with Reports using Code > Section Report > Bind a Section Report to Data > Bind a Section Report to Data Source at Run Time

Glossary Item Box

You can bind a section report to data by changing the data source at run time.

Create and Configure OLEDB Data Source

  1. Double-click in the gray area below rptModifyDS to create an event-handling method for the ReportStart event.
  2. Add code to the handler to change the data source at run time.
    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event Copy Code
    Dim conn As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
    Visual Basic.NET code. Paste INSIDE the ReportStart event Copy Code
    Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + "[User Folder]\Samples19\Data\NWIND.mdb"
conn = New System.Data.OleDb.OleDbConnection(connString)
Dim cmd As New System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn)
conn.Open()
reader = cmd.ExecuteReader()
Me.DataSource = reader
    C# code. Paste JUST ABOVE the ReportStart event Copy Code
    private static System.Data.OleDb.OleDbConnection conn;
private static System.Data.OleDb.OleDbDataReader reader;
    C# code. Paste INSIDE the ReportStart event Copy Code
    string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + @"[User Folder]\Samples19\Data\NWIND.mdb";
conn = new System.Data.OleDb.OleDbConnection(connString);
System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn);
conn.Open();
reader = cmd.ExecuteReader();
this.DataSource = reader;

Close the data connection (Visual Basic)

  1. In design view of rptModifyDS, drop down the field at the top left of the code view and select (rptModifyDS Events).
  2. Drop down the field at the top right of the code view and select ReportEnd. This creates an event-handling method for ReportEnd event.
  3. Add code to the handler to close the data connection.
    Visual Basic.NET code. Paste INSIDE the ReportEnd event Copy Code
    reader.Close()
conn.Close()

Close the data connection (CS)

  1. Click in the gray area below rptModifyDS to select the report.
  2. Click the events icon in the Properties Panel to display available events for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the ReportEnd event.
  4. Add code to the handler to close the data connection.
    C# code. Paste INSIDE the ReportEnd event Copy Code
    reader.Close();
conn.Close();

See the UnboundData sample for details on how to use the FetchData event to display the report unbound data.

Create and Configure JSON Data Source

You can bind a section report to a JSON data source at run time using code.

  1. Double-click in the gray area below SectionReport1 to create an event-handling method for the ReportStart event.
  2. Add code to the handler to change the data source at run time.
    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event Copy Code
    Dim jsonDS As GrapeCity.ActiveReports.Data.JsonDataSource = New GrapeCity.ActiveReports.Data.JsonDataSource()
jsonDS.ConnectionString = "jsondoc=https://demodata.mescius.io/northwind/odata/v1/Employees"
jsonDS.JsonPath = "$.value[*]"
Me.DataSource = jsonDS
    C# code Copy Code
    GrapeCity.ActiveReports.Data.JsonDataSource jsonDS = new GrapeCity.ActiveReports.Data.JsonDataSource();
jsonDS.ConnectionString = @"jsondoc=https://demodata.mescius.io/northwind/odata/v1/Employees";
jsonDS.JsonPath = "$.value[*]";
this.DataSource = jsonDS;

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Bind Data Set and Unbound Data to Section Report at Run Time

Bind Data Set and Unbound Data to Section Report at Run Time
Developers > Work with Reports using Code > Section Report > Bind a Section Report to Data > Bind Data Set and Unbound Data to Section Report at Run Time

Glossary Item Box

A Section report allows to specify a data set and unbound data, using a similar API. You need to just specify DataSet, DataTable, DataView, RowCollection as shown in the DataSource property. For DataSet, you should specify it as shown in the DataMember property.

In addition, a Section report allows to use any unbound data as a data source with the following script logic:

To use the IEnumerable data source

  1. Right-click the design surface and select View Code.
  2. Add the following code inside the class declaration of the report:
    Visual Basic.NET code. Paste inside the class declaration of the report. Copy Code
    Private datasource1 As IEnumerator(Of String) = Nothing
Dim list As List(Of String)= Nothing
    Visual Basic.NET code. Paste inside the class declaration of the report. Copy Code
    Private Function GetIEnumerableData() As IEnumerable(Of String)
    For i As Integer = 1 To 10
       list.Add(String.Format("TestData_{0}", i.ToString()))
    Next
    Return list
End Function
    C# code. Paste inside the class declaration of the report. Copy Code
    private IEnumerator<string> datasource = null;
    C# code. Paste inside the class declaration of the report. Copy Code
    private IEnumerable<string> GetIEnumerableData()
{
    for (int i = 1; i <= 10; i++)
    {
        yield return string.Format("TestData_{0}", i.ToString());
    }
}
  3. On the design surface, right-click the gray area around the design surface to select the report and select Properties.
  4. In the Properties window that appears, click the Events icon to view the available events for the report.
  5. Double-click the DataInitialize event. This creates an event-handling method for the report's DataInitialize event.
  6. Add the following code to the handler to add fields to the report's Fields collection.
    Visual Basic.NET code. Paste inside the DataInitialize event. Copy Code
    Me.Fields.Add("TestField")
Me.list = New List(Of String)
datasource1 = GetIEnumerableData().GetEnumerator()
    C# code. Paste inside the DataInitialize event. Copy Code
    this.Fields.Add("TestField");
datasource = GetIEnumerableData().GetEnumerator();
  7. Repeat steps 3 and 4 to open the events list in the property window.
  8. Double-click the FetchData event. This creates an event-handling method for the report's FetchData event.
  9. Add code to the handler to retrieve information to populate the report fields.
    Visual Basic.NET code. Paste inside the FetchData event. Copy Code
    If datasource1.MoveNext() Then
                                        Me.Fields("TestField").Value = datasource1.Current
                                        eArgs.EOF = False
Else
                                        eArgs.EOF = True
End If
    C# code. Paste inside the FetchData event. Copy Code
    if (datasource.MoveNext())
{
    this.Fields["TestField"].Value = datasource.Current;
    eArgs.EOF = false;
}
else
    eArgs.EOF = true;
Tip: In order to view the added data at run time, add controls to your report and assign their DataField property to the name of the fields you added in code while creating a field collection.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Save Section Reports

Save Section Reports
Developers > Work with Reports using Code > Section Report > Save Section Reports

Glossary Item Box

Although ActiveReports writes report layouts in either C# or Visual Basic.NET, you can save the layout of your report as a report XML (RPX) file for portability. If you make changes to the RPX file and load it back into an ActiveReport in Visual Studio, you can see the changes you made reflected in the C# or Visual Basic.NET code in the YourReportName.Designer.vb or YourReportName.Designer.cs file.

Caution: When you load an RPX layout into a report object, it overwrites everything in the report object. In order to avoid overwriting important layouts, add a new blank ActiveReport and load the RPX file onto it.

Save a report as an RPX file at design time

  1. From the Visual Studio Report menu, select Save Layout.
    Note: The Report menu in Visual Studio 2019 and above is available as submenu under Extensions. You should select the Design View of the report in the ActiveReports Designer first.
  2. In the Save As dialog that appears, set the file name and select the location where you want to save it. The file extension is *.rpx.
  3. Click the Save button to save the report layout and close the dialog.
Note: When you save a layout that contains a dataset, ActiveReports saves the data adapter and data connection in the component tray, but not the dataset itself. When the saved layout is loaded into another report, you can regenerate the dataset with the data adapter and data connection.

Save a report as an RPX file at run time

Use the SaveLayout(XmlWriter) method to save your report layout at run time.

Note: When you save a report layout, ActiveReports only saves the code in the script editor to the file. Any code behind the report in the .cs or .vb file is not saved to the RPX file.
  1. Right-click the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the Form class to save the report.

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste INSIDE the Form class. Copy Code
    Dim rpt As New SectionReport1()
 Dim xtw As New System.Xml.XmlTextWriter(Application.StartupPath + "\report.rpx", Nothing)
 rpt.SaveLayout(xtw)
 xtw.Close()
    C# code. Paste INSIDE the Form class. Copy Code
    SectionReport1 rpt = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter(Application.StartupPath + "\\report.rpx", null);
rpt.SaveLayout(xtw);
xtw.Close();

    Save report layouts before they run. If you save a layout after the report runs, you also save any dynamic changes made to properties or sections in the report. To avoid this when you call SaveLayout inside the report code, use the ReportStart event.

    Note: The SaveLayout method uses utf-16 encoding when you save to a stream, and utf-8 encoding when you save to a file.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Change Ruler Measurements

Change Ruler Measurements
Developers > Work with Reports using Code > Section Report > Change Ruler Measurements

Glossary Item Box

To change measurements, you need to call measurement conversion at run-time, for example, the CmToInch method or InchToCm method at run-time. For example, you can use the following code when you are working in centimeters and need to convert a Label's position measurements from centimeters to inches at run-time.

  1. On the design surface select the section containing a control like a Label.
  2. In the Properties Panel, click the Events button to get a list of report events.
  3. Select the Format event and double-click to create an event-handling method.
  4. Add code like the following to the handler to set the size of the control using centimeters to inches.
    Visual Basic.NET code. Paste inside the Format event. Copy Code
    Me.Label1.Left = SectionReport1.CmToInch(2)
Me.Label1.Top = SectionReport1.CmToInch(2)
    C# code. Paste inside the Format event. Copy Code
    this.label1.Left = SectionReport1.CmToInch(2);
this.label1.Top = SectionReport1.CmToInch(2);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Modify Printer Settings

Modify Printer Settings
Developers > Work with Reports using Code > Section Report > Modify Printer Settings

Glossary Item Box

Show All Show All
Hide All Hide All

In a Section Report, you can modify various printer settings or print multiple copies of a report at design time and at run time.

Printer Settings

Section reports depend on default printer settings may require some extra configuration.

C# code. Paste INSIDE the ReportStart event. Copy Code
var rpt = new SectionReport();
rpt.Document.Printer.Name = "";

Note: It is recommended to set the printer name as empty if you not sure about target environments.

At design time, you can set up duplex printing, page orientation, collation, and page size in the Printer Settings tab of the Report Settings Dialog.

Set up duplex printing in Printer Settings

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, next to Duplex, select one of the following options:
    • Printer Default: The report uses the default settings of the selected printer.
    • Simplex: Turns off duplex printing.
    • Horizontal: Prints horizontally on both sides of the paper.
    • Vertical: Prints vertically on both sides of the paper.
  4. Click OK to return to the report.

Use code to set up duplex printing

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set up duplexing.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.PageSettings.Duplex = GrapeCity.ActiveReports.Printing.Duplex.Horizontal

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.PageSettings.Duplex = GrapeCity.ActiveReports.Printing.Duplex.Horizontal;

Set page orientation on the Printer Settings page

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, in the Orientation section, select either Default, Portrait, or Landscape.
  4. Click OK to return to the report.

Use code to change page orientation

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to change the page orientation of the report for printing.
    Note: Page orientation can only be modified before the report runs. Otherwise, changes made to the page orientation are not used during printing.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;

Multiple Copies

You can print multiple copies using the Print dialog in the Preview tab or in the Viewer, or you can use code to set the number of copies to print.

Set multiple copies in the print dialog

  1. With a report displayed in the viewer or in the preview tab, click Print.
  2. In the Print dialog that appears, next to Number of copies, set the number of copies that you want to print.

Use code to set multiple copies

  1. Double-click in the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set multiple copies of the report for printing.

    The following example shows what the code for the method looks like for printing five copies.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.Document.Printer.PrinterSettings.Copies = 5
    Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
    Me.Document.Printer.Print()

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.Document.Printer.PrinterSettings.Copies = 5;
    C# code. Paste INSIDE the ReportEnd event. Copy Code
    this.Document.Printer.Print();

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Insert or Add Report Pages

Insert or Add Report Pages
Developers > Work with Reports using Code > Section Report > Insert or Add Report Pages

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can run multiple reports, merge their entire page collection or specific portions and view it as a single report. You can save the document containing merged reports to an RDF file or even export them.

Note: When you combine section reports into one document, you should always make sure that they have the same compatibility mode (CrossPlatform or GDI). Otherwise, you may get incorrect results.

These steps assume that you have already placed a Viewer control on a Windows Form and your Visual Studio project contains two section layout (code based) reports (rptOne and rptTwo). See Windows Forms Viewer for more information.

Add pages from one report to another

To add an entire report to another, use code like the one in the example below to iterate through the entire pages collection of a report and append it to the first report. The Add of the PagesCollection takes one parameter (value), which references a report document page.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to add the entire rptTwo page collection to rptOne.

    The following example shows what the code for the Add() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim i As Integer
Dim rpt As New rptOne()
rpt.Run()
Dim rpt2 As New rptTwo()
rpt2.Run()
For i = 0 To rpt2.Document.Pages.Count - 1
rpt1.Document.Pages.Add(rpt2.Document.Pages(i))
Next
Viewer1.LoadDocument(rpt1.Document)

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    int i;
rptOne rpt1 = new rptOne();
rpt1.Run();
rptTwo rpt2 = new rptTwo();
rpt2.Run();
for(i = 0; i < rpt2.Document.Pages.Count; i++)
{
rpt1.Document.Pages.Add(rpt2.Document.Pages[i]);

}
viewer1.LoadDocument(rpt1.Document);

Add a range of pages from one report to another

To add a range of pages from one report to another, use the AddRange. This method has two overloads, each with one parameter. The first overload takes an array of page objects which you can use to append only the specified pages from the second report onto the first (as in the example below).

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to use the AddRange() method to add pages from rptTwo to rptOne.

    The following example shows what the code for the AddRange() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()
    rpt1.Run()
    Dim rpt2 As New rptTwo()
    rpt2.Run()
    rpt1.Document.Pages.AddRange(New GrapeCity.ActiveReports.Document.Section.Page() {rpt2.Document.Pages(1), rpt2.Document.Pages(2)})
    Viewer1.LoadDocument(rpt1.Document)

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();
rpt1.Run();
rptTwo rpt2 = new rptTwo();
rpt2.Run();
rpt1.Document.Pages.AddRange(new GrapeCity.ActiveReports.Document.Section.Page[] {rpt2.Document.Pages[0],rpt2.Document.Pages[1]} );
viewer1.LoadDocument(rpt1.Document);

Insert pages from one report into another

To insert pages from one report to another, use the Insert that takes two parameters, an index, which determines where to insert the pages in the main report, and a value which references the report page to insert.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert page 1 of rptTwo at the beginning of rptOne.

    The following example shows what the code for the Insert() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()
    rpt1.Run()
    Dim rpt2 As New rptTwo()
    rpt2.Run()
    rpt1.Document.Pages.Insert(0, rpt2.Document.Pages(0))
    Viewer1.LoadDocument(rpt1.Document)

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    rpt1.Document.Pages.Insert(0, rpt2.Document.Pages[0]);
    viewer1.LoadDocument(rpt1.Document);

Insert a new page at a specific report location

To insert a new blank page at a specific location in the report, use the InsertNew which takes one parameter, index, which specifies the page after which you want to insert a new blank page.

  1. In the design view of the viewer form, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert a blank page at the beginning of rptOne.

    The following example shows what the code for the InsertNew() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()
    rpt1.Run()
    rpt1.Document.Pages.InsertNew(0)
    Viewer1.Document = rpt1.Document

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rpt1.Document.Pages.InsertNew(0);
    viewer1.Document = rpt1.Document;

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Save and Load RDF Files

Save and Load RDF Files
See Also
Developers > Work with Reports using Code > Section Report > Save and Load RDF Files

Glossary Item Box

ActiveReports allows reports to be saved in their own standard format called an RDF file (Report Document Format). In this format, the data is static. The saved report displays the data that is retrieved when you run the report. You can save a report to an RDF file and load it into the viewer control.

Section report can be stored as an RDF document using the SectionDocument class. It is the intermediate format and can be used in following scenarios:

  • to access data and parameters and export later as described in this topic
  • to work with annotations, see Add and Save Annotations.
  • to merge reports, see Insert or Add Report Pages.

Save a report as a static RDF file

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim rpt As New YourReportName()
    rpt.Run()
rpt.Document.Save(Application.StartupPath + \NewRDF.RDF)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    YourReportName rpt = new YourReportName();
    rpt.Run();
rpt.Document.Save(Application.StartupPath + \\NewRDF.RDF);

Load a saved RDF file into the ActiveReports viewer

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to load the saved report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Viewer1.Document.Load("Location of the .RDF File")

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    viewer1.Document.Load(@"Location of the .RDF File");
Note: The Windows Form Viewer can display RDF files made with any version of ActiveReports, including COM versions.

Save or load report files to a memory stream

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report to a memory stream and load the memory stream into the ActiveReports viewer.

    The following examples show what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim strm As New System.IO.MemoryStream()
Dim rpt As New YourReportName()
rpt.Run()
rpt.Document.Save(strm)
Dim theBytes(strm.Length) As Byte
strm.Read(theBytes, 0, Int(strm.Length))
strm.Position = 0
Viewer1.Document.Load(strm)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
YourReportName rpt = new YourReportName();
rpt.Run();
rpt.Document.Save(strm);
byte[] theBytes = new byte[strm.Length];
strm.Read(theBytes, 0, (int)strm.Length);
strm.Position =0;
viewer1.Document.Load(strm);

See Also

Report Readers
Windows Forms Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add and Save Annotations

Add and Save Annotations
See Also
Developers > Work with Reports using Code > Section Report > Save and Load RDF Files > Add and Save Annotations

Glossary Item Box

Show All Show All
Hide All Hide All

In a Section Report, you can save a report containing annotations along with the report data into an RDF file. You can also add annotations at run time. The following steps demonstrate how to accomplish these tasks in code.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project.

Save annotations

The following example shows how to add a Save Annotated Report button to the viewer and save a report with annotations in RDF.

  1. From the Visual Studio toolbox, drag a Button control onto the viewer.
  2. Set the Text property of the button to Save Annotated Report.
  3. Double-click the button. This creates an event-handling method for the button Click event.
  4. Add code to the click handler to save the document to an RDF file. See Save and Load RDF Files for more information on loading the saved RDF file into the viewer.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the button Click event. Copy Code
    Me.Viewer1.Document.Save("C:\UserAnnotations.rdf")

    Show To write the code in C#

    C# code. Paste INSIDE the button Click event. Copy Code
    this.viewer1.Document.Save("C:\\UserAnnotations.rdf");

Add annotations in code

The following example shows how to add annotations at run time and save the report data and annotations to an RDF file.

  1. Double-click the title bar of the Form in which you host the viewer. This creates an event-handling method for the Form_Load event.
  2. Add code to the handler to run the report, add annotations, display the report in the viewer, and save it into an RDF file.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste ABOVE the class. Copy Code
    Imports GrapeCity.ActiveReports.Document.Section.Annotations
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
       Dim rpt As New SectionReport1
   'Run the report first.
   rpt.Run()

   'Assign the viewer.
   Me.Viewer1.LoadDocument(rpt.Document)

   'Create an annotation and assign property values.
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation.
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\AnnotatedReport.rdf")

    Show To write the code in C#

    C# code. Paste ABOVE the class. Copy Code
    using GrapeCity.ActiveReports.Document.Section.Annotations;
    C# code. Paste INSIDE the Form Load event. Copy Code
       SectionReport1 rpt = new SectionReport1();
   //Run the report first.
   rpt.Run();

   //Assign the viewer
   this.viewer1.LoadDocument(rpt.Document);

   //Create an annotation and assign property values.
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation.
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\\AnnotatedReport.rdf");

See Also

Report Readers
Annotations

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with Subreports

Work with Subreports
Developers > Work with Reports using Code > Section Report > Work with Subreports

Glossary Item Box

This tutorial illustrates creating a subreport using scripts.
ActiveReports allows you to use scripting to permit reports saved to an XML file to contain code. By including scripting when reports are saved into XML, the reports later can be loaded, run, and displayed directly to the viewer control without needing to use the designer.

Note: We are using Visual Studio 2019 and will be connecting to Microsoft Jet 4.0 OLE DB Provider. Since Visual Studio 2022 runs in 64 bit, it does not show Microsoft Jet 4.0 OLE DB provider; you should use one of the compatible providers (e.g. Microsoft.ACE.OLEDB.12.0).

This walkthrough uses the Northwind database. The NWIND.mdb file can be downloaded from GitHub: ..\Samples19\Data\NWIND.mdb.

When you have finished this walkthrough, you will have main report that looks similar to the following.

Report Layout - Main Report with Subreport

Create Project and the Main Report

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Rename the default report as 'rptMain'.
  6. Double-click the rpx file to open the Section Report in the designer.

Connect the Main Report to Data

  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
    Note:
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code

    SELECT * FROM Orders INNER JOIN Customers ON Orders.CustomerID = Customers.CustomerID ORDER BY CompanyName, OrderDate
  7. Click OK to save the data source and return to the report design surface.

Add a Subreport

  1. Go to the Project Explorer, right-click the project and select Add > New Item.
  2. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  3. In the Name field, rename the file as rptSub.
  4. Click the Add button to open a new Section Report in the designer.
  5. Right-click the PageHeader or PageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  6. Click in the grey area below the report to select it, and in the Properties window, change the report's ShowParameterUI property to False. This prevents the subreport from requesting a parameter from the user.

Connect the Subreport to Data

  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM [order details] inner join products on [order details].productid = products.productid
  7. Click OK to save the data source and return to the report design surface.

Create Layout for Main Report

Report Layout -Main Report with Subreport

  1. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties Panel, make the following changes to the group header.
    Property Name | Property Value
    Name | ghCompanies
    BackColor | LemonChiffon
    CanShrink | True
    DataField | CompanyName
    GroupKeepTogether | All
    KeepTogether | True
  3. In the Report Explorer, expand the Fields node, then the Bound node. Drag the CompanyName field onto ghCompanies and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 4, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    Font Size | 12
  4. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add the second group header and footer sections to the report.
  5. In the Properties Panel, make the following changes to the second group header.
    Property Name | Property Value
    Name | ghOrders
    BackColor | LightYellow
    CanShrink | True
    DataField | OrderDate
    GroupKeepTogether | All
    KeepTogether | True
  6. From the toolbox, drag three TextBox controls onto ghOrders and set the properties for each control as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | OrderDate
    OutputFormat | MM/dd/yy

    Show TextBox2

    Property Name | Property Value
    DataField | RequiredDate
    OutputFormat | MM/dd/yy

    Show TextBox3

    Property Name | Property Value
    DataField | ShippedDate
    OutputFormat | MM/dd/yy
    Alignment | Right
  7. From the toolbox, drag three Label controls onto ghOrders and set the properties for each control as follows.

    Show Label1

    Property Name | Property Value
    Text | Ordered:
    Font | Bold:True

    Show Label2

    Property Name | Property Value
    Text | Required:
    Font | Bold:True

    Show Label3

    Property Name | Property Value
    Text | Shipped:
    Font | Bold:True
  8. Select the Detail section and in the Properties window, set the CanShrink property to True.
  9. From the toolbox, drag the Subreport control onto the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    ReportName | full project path\rptSub.rpx
    Name | SubReport1

Create a Layout for the SubReport

Subreport layout at design

  1. Right-click the design surface of rptSub and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties window, make the following changes to the group header.
    Property Name | Property Value
    Name | ghOrderDetails
    BackColor | LightSteelBlue
    CanShrink | True
    DataField | OrderID
  3. From the toolbox, drag four label controls to ghOrderDetails and set the properties for each label as follows.

    Show Label1

    Property Name | Property Value
    Text | Product Name
    Font | Bold:True
    Alignment | Left

    Show Label2

    Property Name | Property Value
    Text | Quantity
    Font | Bold:True
    Alignment | Right

    Show Label3

    Property Name | Property Value
    Text | Unit Price
    Font | Bold:True
    Alignment | Right

    Show Label4

    Property Name | Property Value
    Text | Discount
    Font | Bold:True
    Alignment | Right
  4. Click the Detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    BackColor | Gainsboro
    CanShrink | True
  5. From the toolbox, drag four TextBox controls onto the Detail section and set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Alignment | Left

    Show TextBox2

    Property Name | Property Value
    DataField | Quantity
    Alignment | Right

    Show TextBox3

    Property Name | Property Value
    DataField | Products.UnitPrice
    Alignment | Right
    OutputFormat | Currency

    Show TextBox4

    Property Name | Property Value
    DataField | Discount
    Alignment | Right
    OutputFormat | Percentage

Embed script in the main report (rptMain)

  1. Change the ScriptLanguage property for the report to the appropriate scripting language. The default setting is C#.
  2. Click the Script tab located below the report designer to access the scripting editor.
  3. Embed script to set the data source for the main report and pass data into the subreport.
Visual Basic.NET script. Paste in the script editor window. Copy Code
Dim rptSub As GrapeCity.ActiveReports.SectionReport
Sub ActiveReport_ReportStart
  'Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport()
  'Load the rpx file into the generic report
  rptSub.LoadLayout(me.SubReport1.ReportName)
  'Connect data to the main report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Folder]\Samples19\Data\NWIND.mdb;Persist Security Info=False"
  Dim sqlString As String = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate"
  Dim ds As new GrapeCity.ActiveReports.Data.OleDBDataSource()
  ds.ConnectionString = connString
  ds.SQL = sqlString
  rpt.DataSource = ds
End Sub
Sub Detail_Format
  Dim rptSubCtl As GrapeCity.ActiveReports.SubReport = me.SubReport1
  Dim childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()
  childDataSource.ConnectionString = CType(rpt.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
  'Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>"
  'Pass the data to the subreport
  rptSub.DataSource = childDataSource
  'Display rptSub in the subreport control
  rptSubCtl.Report = rptSub
End Sub
C# code. Paste in the script editor window. Copy Code
GrapeCity.ActiveReports.SectionReport rptSub;
public void Detail_Format()
{
  GrapeCity.ActiveReports.SectionReportModel.SubReport rptSubCtl = this.SubReport1;
  GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource) rpt.DataSource).ConnectionString;
  //Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>";
  //Pass the data to the subreport
  rptSub.DataSource = childDataSource;
  //Display rptSub in the subreport control
  rptSubCtl.Report = rptSub;
}
public void ActiveReport_ReportStart()
{
  //Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport();
  //Load the rpx file into the generic report
  rptSub.LoadLayout(this.SubReport1.ReportName);
  //Connect data to the main report
  string connString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Folder]\Samples19\Data\NWIND.mdb;Persist Security Info=False";
  string sqlString = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate";
  GrapeCity.ActiveReports.Data.OleDBDataSource ds = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  ds.ConnectionString = connString;
  ds.SQL = sqlString;
  rpt.DataSource = ds;
}

Preview report

Click the preview tab to view the report at design time.

OR
Open the report in the Viewer. See Save Section Reports for further information on how to load the xml-based Section Report onto the viewer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Draw on the Canvas of Rendered Report

Draw on the Canvas of Rendered Report
See Also
Developers > Work with Reports using Code > Section Report > Draw on the Canvas of Rendered Report

Glossary Item Box

At times, you may want some graphics (such as shapes, text, or images) to be rendered on top of your report, just like an overlay. A simple scenario is showing a warning about a limited or expired version of your application on top of the rendered report.

Draw a Rectangle and Text on Rendered Section Report Document Canvas

The following sample code demonstrates drawing a rectangular shape with the DrawRect() method and drawing a text with the DrawText() on a section report. Note that these methods must be called after the report.Run(), since you are drawing on the canvas of a rendered report.

C# code. Paste INSIDE the Form Load event Copy Code
var report = new SectionReport();
report.LoadLayout(XmlReader.Create(Application.StartupPath + "\\Report.rpx"));
report.Run();
report.Document.Pages[0].PenWidth = 3;
report.Document.Pages[0].ForeColor = Color.Maroon;
report.Document.Pages[0].DrawRect(2, 2, 4, 1);
report.Document.Pages[0].Font = new GrapeCity.ActiveReports.Document.Drawing.Font("Arial", 50);
report.Document.Pages[0].ForeColor=Color.Red;
report.Document.Pages[0].DrawText("Sample Text",2.1f, 2.1f,4 , 1f);
viewer1.LoadDocument(report.Document);

See Also

Create a Report or Load an Existing Report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with Code-based Section Reports

Work with Code-based Section Reports
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports

Glossary Item Box

This section covers the following features that are specific to Code-based Section Reports.

Inherit a Report Template

Design Code-based Sections Reports in .NET Core

Load an RTF or HTML File in RichTextBox at Runtime

Use Custom Controls on Reports

Add Code to Layouts Using Script

Subreport in Section Reports

Create Mail Merge with RichTextBox

Overlaying in Reports (Letterhead)

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Inherit a Report Template

Inherit a Report Template
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Inherit a Report Template

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can create a base report as a template from which other reports can inherit. This behavior is similar to creating a master report and is available in a Section Report (code-based) layout.

Inheriting reports is useful when multiple reports share common features, such as identical page headers and footers. Instead of recreating the look every time, create template headers and footers once and use inheritance to apply them to other reports.

Use the following instructions to create a base report and inherit it in other reports.

Caution: Base reports and the reports that inherit from them cannot contain controls with duplicate names. You can compile and run your project with duplicate control names, but you cannot save the layout until you change the duplicate names.

Create a base report

  1. From the Visual Studio File menu, select New, then Project.
  2. In the Create New Project dialog that appears, select Windows Forms App (.NET Framework) and click Next.
  3. In the Configure your new project dialog, type a name for your project, set Framework to .NET Framework 4.7 and click Create.
  4. Add a code-based Section Report by selecting ActiveReports 19 Code-Based Report in Project > Add New Item and naming it rptLetterhead.
    Add Code-based Report
  5. In the report template that appears, add the following controls from the Visual Studio toolbox to the indicated section of rptLetterhead and set the properties.
    Control Section Location Size Miscellaneous
    Picture PageHeader 0, 0 in 3, 0.65 in Image = (click ellipsis and navigate to the location of your image file)
    PictureAlignment = TopLeft
    Label PageHeader 1.16, 0.65 in 1.8, 0.25 in Text = Inheritance
    Font = Arial, 15pt, style=Bold
    Label PageFooter 0, 0 in 6.5, 0.19 in Text = https://developer.mescius.com/activereportsnet
    HyperLink = https://developer.mescius.com/activereportsnet
    Font/Bold = True
    Alignment = Center
  6. Right-click the gray area below the design surface and choose properties, to open the Properties window.
  7. In the Properties window, set the MasterReport property to True. Setting the MasterReport property to True locks the Detail section.
    Caution: Do not set the MasterReport property to True until you have finished designing or making changes to the report. Setting this property to True triggers major changes in the designer file of the report.

    Creating a base report

You can use the Page Header and Page Footer sections to design the base report. When you create reports that inherit the layout from this base report, only the detail section is available for editing.

Inherit layout from a base report

These steps assume that you have already added another Section Report (code-based) template. This report functions like a content report where you can create the layout of the Detail section.

  1. In a Visual Studio project, add a Section Report by selecting ActiveReports 19 Code-Based Report in Project > Add New Item and naming it rptLetter.
  2. In the Solution Explorer, right-click the new report and select the View Code option to open the code behind of the report.
  3. In the code view, modify the inheritance statement as shown below. The content report inherits from the base report instead of GrapeCity.ActiveReports.SectionReport.
    Caution: The existing report layout in the content report is lost once you inherit the base report. Even if you change it back to GrapeCity.ActiveReports.SectionReport, the original layout in content report will not be retrieved.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Copy Code
    Partial Public Class rptLetter Inherits YourProjectName.rptLetterhead

    Show To write the code in C#

    C# code. Copy Code
    public partial class rptLetter : YourProjectName.rptLetterhead
  4. Close the reports and from the Build menu on the Visual Studio menu bar, select Rebuild. When you reopen the report, the inherited sections and controls are disabled.
    Note: To apply further changes from the base report to the content report, you might have to rebuild the project again.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Design Code-based Section Reports in .NET Core

Design Code-based Section Reports in .NET Core
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Design Code-based Section Reports in .NET Core

Glossary Item Box

The existing limitation in .NET Core 3.1 and above does not allow the ActiveReports Integrated Designer to be used for designing Code-based Section Reports in WinForms applications in Visual Studio.
As a workaround, you need to use the Visual Studio's option to link report files from the .NET Core project into the .NET Framework project and use the .NET Framework WinForms Designer.

The steps to enable design-time report creation in .NET Core project for Code-Based Section Reports are as follows:

  1. Create a new Windows Forms .NET Core project.

    Create a new project window

    Configure your new project dialog
  2. Select the Target Framework as 'NET 8.0' and select Create.
    Solution Explorer

  3. Add a new .NET Framework project and the built-in Section Report (code-based) item template.

    1. In the Solution Explorer, right-click the solution node, go to Add > New Project, and configure the project for the target .NET Framework version.

      Add WinForms .Net FW Project
    2. Add the code-based Section Report item to the .NET Framework project. To do so, right-click the .NET Framework project and go to Add > New Item.

      Add new item to project
    3. Select the ActiveReports 19 Code-Based Report report item. All the required dependencies will be installed automatically for this project.

      Select code-based section report template
    4. Use cut-paste to move the report (SectionReport1.cs) from the .NET Framework project to .NET Core project. Ensure that the report from the .NET Framework project is deleted.

  4. Add a report from the .NET Core project to the .NET Framework project as a link.

    1. In the Solution Explorer, right-click the .NET Framework project, go to Add > Add Existing Item.
    2. Navigate to the .NET Core project and select report file: 'SectionReport1.cs'.
    3. Select the Add As Link option to add the report files as link.
      Solution Explorer

      added section report

  5. Double-click the linked SectionReport1.cs (in the .Net Framework project) to open the ActiveReports Integrated Designer for the report.

    added section report
  6. Now design the report. You will observe that the modification of a report in the .NET Framework project leads to the modification of a report in the .NET Core project.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Load an RTF or HTML File in RichTextBox at Runtime

Load an RTF or HTML File in RichTextBox at Runtime
See Also
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Load an RTF or HTML File in RichTextBox at Runtime

Glossary Item Box

In a section layout, you can load an RTF or an HTML file into the RichTextBox control both at design time and at run time. Following is a step-by-step process that helps you load these files into the RichTextBox control at run-time.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project and have placed a RichTextBox control inside its detail section.

Caution: Do not attempt to load a file into a RichTextBox in a section that repeats. After the first iteration of the section, the RTF or HTML file is already in use by that first iteration and returns "file in use" errors when that section is processed again.

Write an RTF file to load into a RichTextBox control

  1. Open WordPad, and paste a formatted text into it, for example:

    [Paste the following section into an RTF File]
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Customer List by Country

    Argentina

    • Rancho grande
    • Océano Atlántico Ltda.
    • Cactus Comidas para llevar

    Austria

    • Piccolo und mehr
    • Ernst Handel

    Belgium

    • Suprêmes délices
    • Maison Dewey

    Brazil

    • Familia Arquibaldo
    • Wellington Improtadora
    • Que Delícia
    • Tradição Hipermercados
    • Ricardo Adocicados
    • Hanari Carnes
    • Queen Cozinha
    • Comércio Mineiro
    • Gourmet Lanchonetes
      - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  2. Save the file as sample.rtf.
Note: The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control.

Load an RTF file into a RichTextBox control

Note: The RichTextBox control has limited support for advanced RTF features such as the ones supported by Microsoft Word. Therefore, use a WordPad for obtaining best results.

These steps assume that the RTF file (for example, sample.rtf) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add the following code to the handler to load the RTF file into the RichTextBox control.

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste INSIDE the Detail1_Format event. Copy Code
    Dim streamRTF As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.rtf", System.IO.FileMode.Open)
Me.RichTextBox1.Load(streamRTF, RichTextType.Rtf)

    C# code. Paste INSIDE the detail_Format event. Copy Code
    System.IO.FileStream streamRTF = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
 this.richTextBox1.Load(streamRTF, RichTextType.Rtf);

Write an HTML file to load into a RichTextBox control

  1. Open a Notepad, and paste an HTML code into it, for example:
    HTML code. Paste in a NotePad file. Copy Code
    <html>
<body>
<center><h1>Customer List by Country</h1></center>
<h1>Argentina</h1>
<ul>
<li>Rancho grande
<li>Océano Atlántico Ltda.
<li>Cactus Comidas para llevar
</ul>
<h1>Austria</h1>
<ul>
<li>Piccolo und mehr
<li>Ernst Handel
</ul>
<h1>Belgium</h1>
<ul>
<li>Suprêmes délices
<li>Maison Dewey
</ul>
<h1>Brazi1>
<ul>
<li>Familia Arquibaldo
<li>Wellington Improtadora
<li>Que Delícia
<li>Tradição Hipermercados
<li>Ricardo Adocicados
<li>Hanari Carnes
<li>Queen Cozinha
<li>Comércio Mineiro
<li>Gourmet Lanchonetes
</ul>
</body>
</html>
  2. Save the file as sample.html.

Load an HTML file into the RichTextBox control

These steps assume that the HTML file (for example, sample.html) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add code to the handler to load the HTML file into the RichText control.

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste INSIDE the Detail1_Format event. Copy Code
    Dim streamHTML As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.HTML", System.IO.FileMode.Open)
Me.RichTextBox1.Load(streamHTML, RichTextType.Html)

    C# code. Paste INSIDE the detail_Format event. Copy Code
    System.IO.FileStream streamHTML = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
 this.richTextBox1.Load(streamHTML, RichTextType.Html);

See Also

Create Mail Merge with RichTextBox

Report Authors
RichTextBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Use Custom Controls on Reports

Use Custom Controls on Reports
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Use Custom Controls on Reports

Glossary Item Box

Show All Show All
Hide All Hide All

In a Section Report, ActiveReports allows you to drop a third party control onto the report design surface where it is recognized as a custom control. You can access its properties using type casting.

In the following steps, we use hidden textbox controls to populate a Visual Studio TreeView control. These steps assume that you have already added a code-based Section Report template in a Visual Studio project.

Add the TreeView control to a report

  1. From the Visual Studio toolbox Common Controls tab, drag and drop a TreeView control onto the detail section of a report.
  2. Notice that in the Properties window, the control is called CustomControl1.

Add data and hidden TextBox controls to the report

  1. Connect the report to the JSON data Orders.
  2. From the Report Explorer, drag and drop the following fields onto the detail section of the report:
    • ShipCountry
    • ShipCity
    • CustomerId
    • EmployeeId
  3. On the design surface, select all four TextBox controls, and in the Properties window, change their Visible property to False.

Create a function to add nodes to the TreeView control

  1. Right-click the design surface and select View Code to see the code view for the report.
  2. Add the following code inside the report class to add a function to the report for adding nodes to the TreeView control.

    The following examples show what the code for the function looks like.

    Visual Basic.NET code. Paste INSIDE the report class. Copy Code
    Private Function AddNodeToTreeView(ByVal colNodes As TreeNodeCollection, ByVal sText As String) As TreeNode
   Dim objTreeNode As TreeNode
   objTreeNode = New TreeNode(sText)
   colNodes.Add(objTreeNode)
   Return objTreeNode
End Function
    To write the code in C#. Paste INSIDE the report class. Copy Code
    private TreeNode AddNodeToTreeView(TreeNodeCollection colNodes, string sText)
{
    TreeNode objTreeNode;
    objTreeNode = new TreeNode(sText);
    colNodes.Add(objTreeNode);
    return objTreeNode;
}

Access the TreeView control properties in code and assign data

  1. On the report design surface, double-click the detail section to create an event-handling method for the Detail_Format event.
  2. Add the following code to the handler to access the TreeView properties and assign data from the hidden TextBox controls.

    The following example shows what the code for the method looks like.

    To write the code in Visual Basic.NET Copy Code
    'Type cast the custom control as a TreeView
Dim TreeView1 As New TreeView
TreeView1 = CType(Me.CustomControl1.Control, TreeView)
'Create a tree node
Dim objCountryTreeNode As TreeNode
'Assign the text from a hidden textbox to the node
objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtShipCountry1.Text)
'Add a second-level node
AddNodeToTreeView(objCountryTreeNode.Nodes, Me.txtShipCity1.Text)
'Expand the top-level node so the second-level node is in view
objCountryTreeNode.Expand()
'Create a second top-level node
Dim objCustomerTreeNode As TreeNode
objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtCustomerId1.Text)
AddNodeToTreeView(objCustomerTreeNode.Nodes, Me.txtEmployeeId1.Text)
objCustomerTreeNode.Expand()
    To write the code in Visual Basic.NET Copy Code
    //Type cast the custom control as a TreeView TreeView TreeView1 = new TreeView();TreeView1 = (TreeView)this.customControl1.Control;
//Create a tree node TreeNode objCountryTreeNode;//Assign the text from a hidden textbox to the node objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtShipCountry1.Text);//Add a second-level node AddNodeToTreeView(objCountryTreeNode.Nodes, this.txtShipCity1.Text);//Expand the top-level node so the second-level node is in view objCountryTreeNode.Expand();
//Create a second top-level node TreeNode objCustomerTreeNode;objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtCustomerId1.Text);AddNodeToTreeView(objCustomerTreeNode.Nodes, this.txtEmployeeId1.Text);objCustomerTreeNode.Expand();

Load the report in the Viewer, change the Form Load event

Visual Basic.NET code. Paste INSIDE the Form Load event Copy Code
Dim ar = New SectionReport1()
 ar.Run(False)
 viewer1.LoadDocument(ar.Document)
C# code. Paste INSIDE the Form Load event Copy Code
var ar = new SectionReport1();
 ar.Run(false);
 viewer1.LoadDocument(ar.Document);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Custom Chart Control

Create Custom Chart Control
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Use Custom Controls on Reports > Create Custom Chart Control

Glossary Item Box

This is an internal control that allows using third-party WinForms controls inside a Section report (mainly, a code-based Section report). The main target area of this control is using scripts.

CustomControl is not supported in:

  • Section reports in the CrossPlatform compatibility mode
  • WebDesigner

Using a CustomControl to Create Chart Control

  1. In Microsoft Visual Studio 2022 (version 17.0 or above), create a Windows Forms App (.NET Framework) project and in Project > Add New Item.., select ActiveReports 19 Code-Based Report template and click Add.
  2. Add reference to System.Windows.Forms.DataVisualization.
  3. From the Visual Studio toolbox, drag and drop the Data > Chart item to the design surface.
  4. Add the following code to the code-based report constructor after the InitializeComponent method:
    VB code. Add this code after the InitializeComponent method Copy Code
    Dim chart = CType(Me.customControl1.Control, System.Windows.Forms.DataVisualization.Charting.Chart)
Dim chartArea = New System.Windows.Forms.DataVisualization.Charting.ChartArea("Main")
chart.ChartAreas.Add(chartArea)
Dim seriesColumns = New System.Windows.Forms.DataVisualization.Charting.Series("Columns")
For Each val In New Single() {6, 14, 3, 4, 2, 2, 1, 3}
    seriesColumns.Points.Add(Convert.ToDouble(val))
Next
seriesColumns.ChartType = System.Windows.Forms.DataVisualization.Charting.SeriesChartType.Radar
chart.Series.Add(seriesColumns)
    C# code. Add this code after the InitializeComponent method Copy Code
    var chart = (System.Windows.Forms.DataVisualization.Charting.Chart)this.customControl1.Control;
var chartArea = new System.Windows.Forms.DataVisualization.Charting.ChartArea("Main");

chart.ChartAreas.Add(chartArea);
var seriesColumns = new System.Windows.Forms.DataVisualization.Charting.Series("Columns");
foreach (var val in new float[] { 6, 14, 3, 4, 2, 2, 1, 3 })

    seriesColumns.Points.Add(Convert.ToDouble(val));
seriesColumns.ChartType = System.Windows.Forms.DataVisualization.Charting.SeriesChartType.Radar;
chart.Series.Add(seriesColumns);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Add Code to Layouts Using Script

Add Code to Layouts Using Script
See Also
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Add Code to Layouts Using Script

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can use script to access controls, functions in a class, namespaces, etc. You can also create classes inside the script to call methods or add code to a report's script from a Windows Form. The following sections illustrate simple scripting scenarios with examples.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project.

Access controls in script

To add script to a report to access a textbox named TextBox1 in the detail section and assign the text "Hello" to it:

  1. On the script tab of the report, drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  2. Drop down the Event list and select Format. This creates script stubs for the event.

    Show To access a textbox in the detail section in VB.NET script

    Visual Basic.NET script. Paste INSIDE the Detail Format event. Copy Code
    Me.TextBox1.Text = "Hello"

    Or

    Visual Basic.NET script. Paste INSIDE the Detail Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = "Hello"

    Show To access a textbox in the detail section in C# script

    C# script. Paste INSIDE the Detail Format event. Copy Code
    this.textBox1.Text = "Hello";

    Or

    C# script. Paste INSIDE the Detail Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["TextBox1"]).Text = "Hello";

Give a script access to functions in a class in your project

Using the AddNamedItem method, you can allow the script to access functions in a class file within your project. This allows you to keep secure information such as a database connection string or a SQL query string in the code instead of saving it in the RPX file.

  1. In the Code View of the Form, add a class to your project named clsMyItem.

    Show To add a class in Visual Basic.NET

    Visual Basic.NET code. Copy Code
    Public Class clsMyItem
End Class

    Show To add a class in C#

    C# code. Copy Code
    public partial class clsMyItem
{
}
  2. Add a public function to your class using code like the following:

    Show To create a public function in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the new class. Copy Code
    Public Function getMyItem() As String
    getMyItem = "Hello"
End Function

    Show To create a public function in C#

    C# code. Paste INSIDE the new class. Copy Code
    public string getMyItem()
{
    return "Hello";
}
  3. Go to the design view of the report and double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  4. Add the following code to the handler:

    Show To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste before or in the ReportStart event. Copy Code
    Me.AddNamedItem("myItem", new clsMyItem())

    Show To access the class in C#

    C# code. Paste before or in the ReportStart event. Copy Code

    this.AddNamedItem("myItem", new clsMyItem());
  5. From the Visual Studio toolbox, drag and drop a TextBox control onto the detail section of the report.
  6. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  7. Drop down the Event list and select Format. This creates script stubs for the event.
  8. Add the following script to the event to access a control on the report and populate it using the named item.

    Show To access the control in VB.NET script

    VB.NET script. Paste INSIDE the Detail Format event. Copy Code

    Me.TextBox1.Text = myItem.getMyItem()

    Or

    VB.NET script. Paste INSIDE the Detail Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = myItem.getMyItem()

    Show To access the control in C# script

    C# script. Paste INSIDE the Detail Format event. Copy Code

    this.textBox1.Text = myItem.getMyItem();

    Or

    C# script. Paste INSIDE the Detail Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = myItem.getMyItem();
  9. Go to the preview tab to view the result.

Access namespaces

By using the AddScriptReference method, you can gain access to .NET or custom namespaces. This is only necessary if you need a reference, such as System.Data.dll, that is not initialized in the project before the script runs.

Show To access a namespace in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
Private Sub runReport()
      Dim rpt as new YourReportName
      rpt.AddScriptReference("System.Data.dll")
      rpt.Run()
End Sub

Show To access a namespace in C#

C# code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
private void runReport()
{
      YourReportName rpt = new YourReportName;
      rpt.AddScriptReference("System.Data.dll");
      rpt.Run();
}

Note: If you are using the custom assemblies, they must have Strong Name and registered to GAC folder.

If you want to use custom assemblies in the Script section of the Designer, then you need to add the assembly reference to a report before loading it into the report designer. To do this, follow these steps:

  1. Create a custom assembly with the strong name and register it to GAC.
  2. Create a new sample with a section report (XML-based).
  3. Add the report designer to the form.
  4. Add the following code to the Form_Load event.

    Show To access a namespace in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
    Dim rpt As SectionReport = New SectionReport()
    Dim xtr As System.Xml.XmlTextReader = New System.Xml.XmlTextReader("..\..\SectionReport2.rpx")
       rpt.LoadLayout(xtr)
       xtr.Close()
       rpt.AddScriptReference("ClassLibrary1.dll")
       designer1.Report = rpt

    Show To access a namespace in C#

    C# code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
    SectionReport rpt = new SectionReport();
    System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\SectionReport2.rpx");
    rpt.LoadLayout(xtr);
    xtr.Close();
    rpt.AddScriptReference(@"ClassLibrary1.dll");
    designer1.Report = rpt;
  5. Run the sample.
  6. Open the Script section of the designer.

You can now use the custom assemblies reference in the Script section of the Desginer.

Add code to a report's script from a Windows Form

Using the AddCode method in the Code View of the Form, you can add code into the script. The AddCode method allows you to add actual code segments to the script at run time. This is useful for allowing secure information, such as a database connection string or SQL query string, to be used inside the script without saving it in the RPX file.

  1. Go to the Code View of your report and add a public function like the following:

    Show To add code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the report class. Copy Code
    Public Function addThisCode() As String
   Dim sCode As String = "Public Function ShowACMessage() As String" + Environment.NewLine + "ShowACMessage = ""my Added Code""" + Environment.NewLine + "End Function"
   addThisCode = sCode
End Function

    Show To add code in C#

    C# code. Paste INSIDE the report class. Copy Code
    public string addThisCode()
{
   string sCode = "public string ShowACMessage(){return \"my Added Code\";}";
   return sCode;
}
  2. In the design view of your report double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  3. Add the following code to the handler:

    Show To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.AddCode(addThisCode())

    Show To access the class in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.AddCode(addThisCode());
  4. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  5. Drop down the Event list and select Format. This creates script stubs for the event.
  6. Add the following script to the event:

    Show To write the script in Visual Basic.NET

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Me.TextBox1.Text = ShowACMessage()

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = ShowACMessage()

    Show To write the script in C#

    C# script. Paste INSIDE the detail_Format event. Copy Code
    this.textBox1.Text = ShowACMessage();

    Or

    C# script. Paste INSIDE the detail_Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = ShowACMessage();

Create classes inside the script to call methods

If the script requires a method to be called, you can construct a class inside the script.

  1. Go to the script tab and add the following code at the top:

    Show To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the script tab. Copy Code
    Public Class MyFuncs
   Public  Sub New()
   End Sub
   Public Function ShowMyString() As String
      Return "This is my string"
   End Function
End Class

    Show To create a class inside the script in C#

    C# script. Paste INSIDE the script tab. Copy Code
    public class MyFuncs
{
   public MyFuncs()
   {
   }
   public string ShowMyString()
   {
      return "This is my string";
   }
}
  2. On the script tab, now drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  3. Drop down the Event list and select Format. This creates script stubs for the event.
  4. Add the following script to the event:

    Show To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Dim f As MyFuncs =  New MyFuncs()
Me.TextBox1.Text = f.ShowMyString

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Dim f As MyFuncs =  New MyFuncs()
CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = f.ShowMyString

    Show To create a class inside the script in C#

    C# script. Paste INSIDE the detail_Format event. Copy Code
    MyFuncs f = new MyFuncs();
this.textBox1.Text = f.ShowMyString();

    Or

    C# script. Paste INSIDE the detail_Format event. Copy Code
    MyFuncs f = new MyFuncs();
((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = f.ShowMyString();
Note: Use the examples with the "this" (C#) and "Me"(Visual Basic.NET) keywords, as they are recommended rather than the ones with "rpt".

See Also

Report Authors
Scripts

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreport in Section Reports

Subreport in Section Reports
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Subreport in Section Reports

Glossary Item Box

This section discusses some common scenarios of using the subreports with code-based section reports.

Embed Subreports

Subreports with XML Data

Subreports with JSON Data

Subreports with Run-Time Data Sources

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Embed Subreports

Embed Subreports
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Subreport in Section Reports > Embed Subreports

Glossary Item Box

To embed a subreport into a parent report, you add two reports (one parent and one child report) to a Visual Studio project, and from the ActiveReports 19 Section Report toolbox, drag the SubReport control onto the parent report. The following steps take you through the process of adding a subreport in a Section Report.

These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project. Also refer this topic on Design Code-based Section Reports in .NET Core.

Add code to create an instance of the child report in the parent report

  1. Double-click the gray area around the parent report to create an event-handling method for the ReportStart event.
  2. Add code like the following to the handler to create a new instance of the child report.

    VB Code:
    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
    Dim rpt As rptYourChildReportName

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    rpt = New rptYourChildReportName()

    C# Code:

    C# code. Paste JUST ABOVE the ReportStart event. Copy Code
    private rptYourChildReportName rpt;
    C# code. Paste INSIDE the ReportStart event. Copy Code
    rpt = new rptYourChildReportName();
    Caution: It is recommended that you do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, using a lot of memory.

Add code to display the child report in a subreport control on a parent report

  1. Add the SubReport control onto the design surface of the parent report.
  2. Double-click the detail section of the report to create a detail_Format event.
  3. Add code like the following to the handler to display a report in the SubReport control.
    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Me.SubReport1.Report = rpt
    C# code. Paste INSIDE the Format event. Copy Code
    this.subReport1.Report = rpt;

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreports with XML Data

Subreports with XML Data
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Subreport in Section Reports > Subreports with XML Data

Glossary Item Box

Using XML data requires some setup that is different from other types of data. This walkthrough illustrates how to set up a subreport bound to the XML DataSource in the parent report.

When you complete this walkthrough you get a layout that looks similar to the following.

Subreport with XML data at design time

Create Report

  1. In Visual Studio, create a new Windows Forms App (.NET Framework) project and click Next.
  2. In the Configure your new project dialog, type a name for your project, set Framework to .NET Framework 4.7 and click Create.
  3. From the Project menu, select Add New Item.
  4. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptMain.
  5. Click the Add button to open a new Section Report in the designer.
  6. From the Project menu, select Add New Item.
  7. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptSub.
  8. Click the Add button to open a second new Section Report in the designer.

Connect the Parent Report (rptMain) to a Data Source

  1. On the detail section band, click the Data Source Icon.
    Data Source icon
  2. In the Report Data Source dialog, on the XML tab, click the ellipsis (...) button next to File URL field.
  3. In the Open File window that appears, navigate to Customer.xml and click the Open button.
  4. In the Recordset Pattern field, enter //CUSTOMER.
  5. Click OK to save the data source and return to the report design surface.

Design Report Layout for the Parent Report (rptMain)

Subreport with XML data at runtime time

  1. On the design surface, select the pageHeader section and in the Properties panel, set the Height property to 0.3.
  2. On the design surface, select the grey area outside the report and in the Properties panel, set the PrintWidth property to 6.5.
  3. On the design surface, select the detail section and in the Properties panel, set the CanShrink property to True to eliminate white space.
  4. From the toolbox, drag the Label control onto the pageHeader section and in the Properties panel, set the Text property to 'Orders by Customer'.
  5. From the toolbox, drag the controls onto the detail section and in the Properties panel, set the properties of each control as follows.
  6. From the toolbox, drag the following controls onto the detail section and in the Properties panel, set the properties of each control as follows.
    • TextBox1
      DataField: NAME
    • Label1
      Text: Customer Name:
    • Label2
      Text: Orders:
    • Subreport

Design Report Layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties panel, set the CanShrink property to 'True' and BackColor to 'LightSteelBlue'.
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete.
    Note: Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag the following controls to the detail section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    TextBox1
    DataField | TITLE
    Name | txtTitle
    TextBox2
    DataField | PRICE
    Name | txtPrice
    OutputFormat | $#,##0.00 (or select Currency in the dialog)

Add Code to Create a new instance of the Child Report (rptSub)

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

VB Code:

  1. Right-click the design surface of rptMain and select View Code.
  2. At the top left of the code view of the report, click the drop-down arrow and select (rptMain Events).
  3. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the ReportStart event.
  4. Add code to the handler to create an instance of rptSub.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Dim rpt As rptSub

Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
rpt = New rptSub()

C# Code:

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties panel to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of rptSub.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private rptSub rpt;
C# code. Paste INSIDE the ReportStart event. Copy Code
rpt = new rptSub();

Add Code to Pass a subset of the Parent Report's data to the Child Report

To add code to pass a subset of the parent report's data to the subreport

  1. Double-click in the detail section of the design surface of rptMain to create a detail_Format event.
  2. Add code to the handler to:
    • Create a new XMLDataSource
    • Type cast the new data source as rptMain's data source and set the NodeList to the ORDER/ITEM field.
    • Display rptSub in the subreport control
    • Pass the new data source to the subreport

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
Dim xmlDS As New GrapeCity.ActiveReports.Data.XMLDataSource
xmlDS.NodeList = CType(CType(Me.DataSource, GrapeCity.ActiveReports.Data.XMLDataSource).Field("ORDER/ITEM", True), System.Xml.XmlNodeList)
rpt.DataSource = xmlDS
SubReport1.Report = rpt
C# code. Paste INSIDE the Format event. Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xmlDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
xmlDS.NodeList = (System.Xml.XmlNodeList)((GrapeCity.ActiveReports.Data.XMLDataSource) this.DataSource).Field("ORDER/ITEM", true);
rpt.DataSource = xmlDS;
subReport1.Report = rpt;

Preview the report

Click the preview tab to view the report at design time.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreports with JSON Data

Subreports with JSON Data
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Subreport in Section Reports > Subreports with JSON Data

Glossary Item Box

Using JSON data requires some setup that is different from other types of data. This walkthrough illustrates how to set up a subreport bound to the JSON data source in the parent report.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Subreport with JSON data at runtime time

Create Report

  1. In Visual Studio, create a new Windows Forms App (.NET Framework) project and click Next.
  2. In the Configure your new project dialog, type a name for your project, set Framework to .NET Framework 4.7 and click Create.
  3. From the Project menu, select Add New Item.
  4. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptMain.
  5. Click the Add button to open a new Section Report in the designer.
  6. From the Project menu, select Add New Item.
  7. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptSub.
  8. Click the Add button to open a second new Section Report in the designer.

Connect the Parent Report (rptMain) to a Data Source

  1. On the detail section band, click the Data Source Icon.
    Data Source icon
  2. In the Report Data Source dialog, select the JSON tab.
  3. Click the Build button next to the Connection String section to open the Configure JSON Data Source dialog box.
  4. Specify the following JSON file URL in the Data Path field of the dialog box.
    JSON File URL Copy Code
    https://demodata.mescius.io/northwind/odata/v1/Categories?$expand=Products
    The Connection String section displays the generated connection string as shown below.
    Connection String Copy Code
    jsondoc=https://demodata.mescius.io/northwind/odata/v1/Categories?$expand=Products
  5. Click OK to proceed further.
  6. In the JSON Path field, enter the below query to fetch the required data from the JSON path defined above.
    Query Copy Code
    $.value[*]
  7. Click OK to save the data source and return to the report design surface.

Design Report Layout for the Parent Report (rptMain)

Subreport with JSON data at runtime time

  1. On the design surface, select the pageHeader section and in the Properties window, set the Height property to 0.3.
  2. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  3. From the toolbox, drag the Label control onto the pageHeader section and in the Properties window, set the Text property to 'Product Details'.
  4. From the toolbox, drag the following controls onto the detail section and in the Properties panel, set the properties of each control as follows.
    • TextBox1
      DataField: CategoryName
    • Label1
      Text: Category Name:
    • Label2
      Text: Products:
    • Subreport

Design Report Layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties panel, set the BackColor to 'White Smoke'
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag the following controls to the detail section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    TextBox1
    DataField | ProductName
    Name | txtProductName
    TextBox2
    DataField | UnitPrice
    Name | txtUnitPrice
    OutputFormat | $#,##0.00 (or select Currency in the dialog)

Add Code to Create a new instance of the Child Report (rptSub)

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

VB Code:

  1. Right-click the design surface of rptMain and select View Code.
  2. At the top left of the code view of the report, click the drop-down arrow and select (rptMain Events).
  3. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the ReportStart event.
  4. Add code to the handler to create an instance of rptSub.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Dim rpt As rptSub

Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
rpt = New rptSub()

C# Code:

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties panel to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of rptSub.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private rptSub rpt;
C# code. Paste INSIDE the ReportStart event. Copy Code
rpt = new rptSub();

Add Code to Pass a subset of the Parent Report's data to the Child Report

To add code to pass a subset of the parent report's data to the subreport

  1. Double-click in the detail section of the design surface of rptMain to create a detail_Format event.
  2. Add code to the handler to:
    • Create a new JSONDataSource.
    • Type cast the new data source as rptMain's data source.
    • Specify a valid JSONPath expression.
    • Pass the new data source to the subreport
    • Display rptSub in the subreport control

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
Dim jsonDS As New GrapeCity.ActiveReports.Data.JsonDataSource
jsonDS.JsonData = (CType(Me.DataSource, GrapeCity.ActiveReports.Data.JsonDataSource)).Field("Products").ToString()
jsonDS.JsonPath = "$.[*]"
rpt.DataSource = jsonDS
SubReport1.Report = rpt

C# code. Paste INSIDE the Format event. Copy Code
GrapeCity.ActiveReports.Data.JsonDataSource jsonDS = new GrapeCity.ActiveReports.Data.JsonDataSource();
jsonDS.JsonData = ((GrapeCity.ActiveReports.Data.JsonDataSource)this.DataSource).Field("Products").ToString();
jsonDS.JsonPath = "$.[*]";
rpt.DataSource = jsonDS;
subReport1.Report = rpt;

Preview the report

Click the preview tab to view the report at design time.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Subreports with Run-Time Data Sources

Subreports with Run-Time Data Sources
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Subreport in Section Reports > Subreports with Run-Time Data Sources

Glossary Item Box

ActiveReports allows Section Reports to contain any number of child reports using the Subreport control. Child reports, or subreports, are executed each time the parent section (i.e. the section in which the Subreport control is placed) is processed. This tutorial illustrates how to modify the subreport record source from the data in the parent report to retrieve the correct information.

Subreport with run-time data sources

Create Report

  1. In Visual Studio, create a new Windows Forms App (.NET Framework) project and click Next.
  2. In the Configure your new project dialog, type a name for your project, set Framework to .NET Framework 4.7 and click Create.
  3. From the Project menu, select Add New Item.
  4. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptMain.
  5. Click the Add button to open a new Section Report in the designer.
  6. From the Project menu, select Add New Item.
  7. In the Add New Item dialog that appears, select ActiveReports 19 Code-Based Report and in the Name field, rename the file as rptSub.
  8. Click the Add button to open a second new Section Report in the designer.

Connect the Parent Report (rptMain) to a Data Source

  1. On the detail section band, click the Data Source Icon.
    Data Source icon
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Categories
  4. Click OK to save the data source and return to the report design surface.

Design Report Layout for the Parent Report (rptMain)

Subreport with run-time data sources

  1. In the Report Explorer, select the report and in the Properties window, set the PrintWidth property to 5.75.
  2. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  3. From the toolbox, drag a Label control onto the pageHeader section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | lblProductsbyCategory
    Text | Products by Category
  4. From the toolbox, drag the following controls onto the detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    TextBox1
    Name | txtCategoryID1
    Data Field | CategoryID
    Visible | True
    TextBox2
    Name | txtCategoryName1
    Data Field | CategoryName
    Label1
    Name | lblCategoryName
    Text | CategoryName:
    Label2
    Name | lblProducts
    Text | Products:
    Subreport
    Name | SubReport1

Design Report Layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    CanShrink | True
    BackColor | AliceBlue
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag a TextBox control to the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name

Add Code to Create an Instance of the Subreport

Design Report Layout for the Child Report (rptSub)

  1. On the design surface, select the detail section section and in the Properties panel, set the BackColor to 'White Smoke'
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag the following controls to the detail section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    TextBox1
    DataField | ProductName
    Name | txtProductName
    TextBox2
    DataField | UnitPrice
    Name | txtUnitPrice
    OutputFormat | $#,##0.00 (or select Currency in the dialog)

Add Code to Create a new instance of the Child Report (rptSub)

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

VB Code:

  1. Right-click the design surface of rptMain and select View Code.
  2. At the top left of the code view of the report, click the drop-down arrow and select (rptMain Events).
  3. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the ReportStart event.
  4. Add code to the handler to create an instance of rptSub.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Private rpt As rptSub
Private childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()

Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
rpt = New rptSub()

C# Code:

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties panel to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of rptSub.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private rptSub rpt;
private GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
C# code. Paste INSIDE the ReportStart event. Copy Code
rpt = new rptSub();

Add Code to Assign a Data Source for the Child Report {rptSub)

  1. Back in design view of the Parent report (rptMain), double-click the detail section. This creates the Detail_Format event handler.
  2. Add code to the handler to:
    • Set the connection string for the OleDBDataSource for the subreport
    • Set the SQL query for the new data source and pass in the current record's CategoryID
    • Set the data source of the subreport to the data source
    • Assign rptSub to the SubReport control

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    childDataSource.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + Me.txtCategoryID1.Value.ToString
rpt.DataSource = childDataSource
SubReport1.Report = rpt

    C# code. Paste INSIDE the Format event. Copy Code
    childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)this.DataSource).ConnectionString;
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + this.txtCategoryID1.Value.ToString();
rpt.DataSource = childDataSource;
SubReport1.Report = rpt;

    Preview the report

    Click the preview tab to view the report at design time.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Mail Merge with RichTextBox

Create Mail Merge with RichTextBox
See Also
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Create Mail Merge with RichTextBox

Glossary Item Box

The RichText control can contain field place holders that can be replaced with values (merged) at run time. Let's create a mail merge report that uses the RichTextBox control.
When you complete this walkthrough you get a layout that looks similar to the .

Mail merge with RTB

Create a Report

  1. In Visual Studio, create a new Windows Forms App (.NET Framework) project and click Next.
  2. In the Configure your new project dialog, type a name for your project, set Framework to .NET Framework 4.7 and click Create.
  3. Select ActiveReports 19 Code-Based Report and click Next.
  4. Enter a Project name, select a Framework and click Create.
  5. Rename SectionReport1.cs and in the Name field, rename the file as OrderLetter.
  6. Double-click OrderLetter.cs to open the report in the Section Report designer.

Bind Report to Data

Connect to a Data Source

  1. On the detail section band, click the Data Source Icon.
    Data Source Icon
  2. In the Report Data Source dialog that appears, select the CSV tab to connect to a CSV data source. Let us connect to MyOrders.csv data available on GitHub. See CSV Provider page for details on binding with CSV data. The connection string for our data is as shown:
    Connection String Copy Code
    Path=data\\MyOrders.csv;Locale=en-IN;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;Columns=ID,Product,Customer,OrderNumber,Stock,Total,UnitPrice,City,ProductLine,Discount;HasHeaders=True
  3. Click OK to save the changes and return to the report design surface. The dataset is also automatically added.

Design Report

  1. On the design surface of the report, right-click and select Insert, then Group Header/Footer to add group header and footer sections.
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    DataField | OrderNumber
    KeepTogether | True
  4. On the design surface of the report, select the group footer section and in the Properties window, set the following properties.
    Property Name | Property Value
    KeepTogether | True
    NewPage | After
  5. On the design surface of the report, select the pageHeader section and in the Properties panel, set the following properties.
    Property Name | Property Value
    BackColor | Coral
  6. From the toolbox, drag the Label control to the pageHeader section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    Location | 0, 0 in
    Text | Company
    Font > Size | 20
    Font > Bold | True
  7. From the toolbox, drag three TextBox controls to the groupHeader section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    TextBox1
    Location | 0.8, 1.8 in
    Text | Product
    Font > Bold | True
    TextBox2
    Location | 2.80, 1.8 in
    Text | Unit Price
    Font > Bold | True
    TextBox3
    Location | 3.80, 1.8 in
    Text | Discount
    Font > Bold | True
  8. In the Report Explorer, expand the Fields node, then the Bound > Document node. Drag the Product field onto the detail section and in the Properties panel, set the following properties:
    Property Name | Property Value
    Product field
    Location | 0.8, 0 in
    Name | textProduct1
    UnitPrice field
    Location | 2.8, 0 in
    Name | txtUnitPrice1
    Discount field
    Location | 3.8, 0 in
    Name | txtDiscount1
  9. In the Report Explorer, expand the Fields node, then the Bound >Document node. Drag the Total field onto the groupFooter section and in the Properties panel, set the following properties.
    Property Name | Property Value
    Location | 3.8, 0 in
    Name | txtTotal
  10. From the toolbox, drag the TextBox control to the groupFooter section and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    Location | 0.8, 0 in
    Text | Total:
    Font > Bold | True
  11. From the tool bar drag two RichTextBox controls to the groupHeader and set the following properties:
    Property Name | Property Value
    RichTextBox1
    Location | 0, 0 in
    AutoReplaceFields | True
    Name | richTextBox1
    RichTextBox2
    Location | 0, 0.35 in
    AutoReplaceFields | True
    Name | richTextBox2

Add fields to the RichText control

  1. Double-click richTextBox1 control box, delete the default text, and add the following text to the richTextBox1 control box:
    Paste into the richTextBox1 control Copy Code
    OrderOrder ID: #[!OrderNumber],

 Hi [!Customer],

 Your order with order id #[!OrderNumber] has been shipped. The order will be delivered within 4-5 working days. Thank you for shopping with ACME Store.

 Order Detail:
  2. Similarly, add the following text to the richTextBox2 control box:
    Paste into the richTextBox2 control Copy Code
    Regards,
John Doe
(Sales Representative)
  3. Arrange the text and fields within the control as you would in any text editor.

    Note: You can add field to the RichTextBox control by

    1. Double click the control to open the edit mode.
      Insert Fields option in RTB
    2. Right-click and select Insert Field.
    3. Enter the field name and click OK.

Add code to update RichText fields

  1. On the design surface, double click the detail section band.
  2. Double-click in the group header section of the report to create an event-handling method for the group header's Format event.
  3. Add code to the handler to:
    • Replace the OrderNumber field in the RichText control with the current OrderNumber field value.
    • Replace the Customer field with the current Customer field value
      Example Title Copy Code
      //Use the OrderNumber Field Value
    richTextBox1.ReplaceField("OrderNumber", Fields["OrderNumber"].Value.ToString());
//Use the Customer Field Value
    richTextBox1.ReplaceField("Customer", Fields["Customer"].Value.ToString());

Improve the appearance of the report and preview.

Mail merge with RTB

  1. Select all the textBoxes in the detail section then, right-click on the text box and go to Format Border and select the 5th preset in the first column to have a border line on top of the textBox as shown in the image below:
    Format Border
  2. Select all the textBoxes in the groupFooter section then, right-click on the text box and go to Format Border and select the 4th preset in the 1st column also, select the 2nd preset in the 1st column to have two border lines on the textbox controls(top and bottom) as shown in the image below:

See Also

Report Authors
RichTextBox

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Overlaying in Reports (Letterhead)

Overlaying in Reports (Letterhead)
See Also
Developers > Work with Reports using Code > Section Report > Work with Code-based Section Reports > Overlaying in Reports (Letterhead)

Glossary Item Box

ActiveReports allows you to overlay static report formats over data reports.

These steps demonstrate how to overlay an ActiveReports report, displaying customers orders by country, with a static letterhead report.

Note: The report connects to NWIND.db that can be downloaded from GitHub.

The final report will look as shown.

Final report with overlaying

Create a report

  1. Open Visual Studio to create a new project.
  2. Follow topic Design Code-based Section Reports in .NET Core to create application with code-based section report in .NET Core.
  3. In the Project name field, rename SectionReport1.cs as rptData.
  4. Click Create.
  5. Double-click rptData.cs to open the report in the Section Report designer.

Bind Report to Data

  1. As you create a new report, the Report Data Source dialog appears for you to configure the report data connection. You can also access this dialog by clicking the DataSource Icon in the Detail section band.
  2. Choose Custom tab > SQLite Provider in the Report Data Source dialog, and bind the report to Sqlite data using the following connection string and query.
    Connection String Copy Code
    data source=c:\data\NWIND.db
    Query Copy Code
    Select * from Customers ORDER BY Country
  3. Click OK to close the Report Data Source dialog and return to the report design surface.

Design Report Layout (rptData)

Design layout for report with overlaying

  1. Select the PageHeader section and in the Properties Window, set the Height property to 0.65. (This will match the height of the page header in the template.)
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Right-click the report and select Insert > GroupHeader/Footer to add group header and group footer sections.
  4. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | ghCustomers
    BackColor | MediumSlateBlue
    CanShrink | True
    DataField | Country
    GroupKeepTogether | FirstDetail
    KeepTogether | True
  5. From the toolbox, drag the following controls to ghCustomers and in the Properties window, set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    DataField ="Customers in " + Country
    (DataField)
    Size | 2, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    ForeColor | White
    Font Size | 12

    Show Label1

    Property Name | Property Value
    Text | ID
    Size | 0.6, 0.2 in
    Location | 0, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label2

    Property Name | Property Value
    Text | Company Name
    Size | 1.1, 0.2 in
    Location | 0.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label3

    Property Name | Property Value
    Text | Address
    Size | 1, 0.2 in
    Location | 2.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label4

    Property Name | Property Value
    Text | City
    Size | 1, 0.2 in
    Location | 5.5, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue
  6. Click the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | LightGray
    CanShrink | True
  7. From the toolbox, drag four TextBox controls onto the Detail section and set the properties of each textbox as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | CustomerID
    Size | 0.6, 0.2 in
    Location | 0, 0 in

    Show TextBox2

    Property Name | Property Value
    DataField | CompanyName
    Size | 2, 0.2 in
    Location | 0.7, 0 in

    Show TextBox3

    Property Name | Property Value
    DataField | Address
    Size | 2.8, 0.2 in
    Location | 2.7, 0 in

    Show TextBox4

    Property Name | Property Value
    DataField | City
    Size | 1, 0.2 in
    Location | 5.5, 0 in
  8. Select the group footer and in the Properties window, set the Height property to 0.

Create a report and design Report Layout (rptLetterhead)

Letterhead design layout for report with overlaying

  1. Go to Project in the Visual Studio menu and select Add New Item...
  2. Select ActiveReports 19 Section Report (code-based).
  3. In the Project name field, rename SectionReport2.cs as rptLetterhead.
  4. Click Create.
  5. Double-click rptLetterhead.cs to open the report in the Section Report designer.
  6. Select the Page Header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | DarkSlateBlue
    Height | 0.65
  7. From the toolbox, drag a Label control onto the Page Header and in the Properties window, set the properties as follows.

    Show Label1

    Property Name | Property Value
    Size | 6.5, 0.65 in
    Location | 0, 0 in
    Font Size | 36
    Font Bold | True
    ForeColor | White
    Text | Mescius
  8. Select the Page Footer and in the Properties window, set the BackColor property to DarkSlateBlue.
  9. From the toolbox, drag a Label control onto the Page Footer and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 6.5, 0.2 in
    Location | 0, 0 in
    Alignment | Center
    Font Bold | True
    ForeColor | White
    Text 984-242-0700, https://developer.mescius.com/activereportsnet,
    activereports.sales@mescius.com

Add Code to Overlay Data Report Pages with Letterhead Report

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to set the viewer to display the rptData report document an to overlay rptLetterhead on rptData.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
       Dim rpt As New rptData()
   rpt.Run()
   Dim rpt2 As New rptLetterhead()
   rpt2.Run()
   Dim i As Integer
   For i = 0 To rpt.Document.Pages.Count - 1
      rpt.Document.Pages(i).Overlay(rpt2.Document.Pages(0))
   Next
   Viewer1.Document = rpt.Document
    C# code. Paste INSIDE the Form Load event. Copy Code
    rptData rpt = new rptData();
   rpt.Run();
   rptLetterhead rpt2 = new rptLetterhead();
   rpt2.Run();
   for(int i = 0; i < rpt.Document.Pages.Count; i++)
   {
      rpt.Document.Pages[i].Overlay(rpt2.Document.Pages[0]);
   }
   viewer1.Document = rpt.Document;
  3. Improve the appearance of the report and preview.

See Also

Developers
Design Code-based Section Reports in .NET Core

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Optimize Section Reports

Optimize Section Reports
Developers > Work with Reports using Code > Section Report > Optimize Section Reports

Glossary Item Box

Optimization can be crucial for large reports (i.e. over 100 pages). Here is some information which will help you to achieve the best possible results for such reports. To optimize ActiveReports for the web, please refer to the memory considerations section.

Memory Considerations

  • Images: Limit the use of large images when exporting to RTF and TIFF formats. Note that even one image uses a lot of memory if it's repeated on every page of a very long report exported to TIFF or RTF. If you are not exporting, or if you are exporting to Excel, PDF, or HTML, repeated images are stored only once to save memory, but the comparison necessary to detect duplicate images slows the processing time for the report.
  • SubReports: Limit the use of subreports in repeating sections because each subreport instance consumes memory. For example, consider that a subreport in the Detail section of a report in which the Detail section is repeated 2,000 times will have 2,000 instances of the subreport. Nested subreports will compound the number of instances. If you need to use subreports in repeating sections, instantiate them in the ReportStart event instead of the Format event of the repeating section so that they will be instantiated only once and use less memory.
  • CacheToDisk: Set the CacheToDisk property of the Document object to True. Although it slows down the processing time, this allows the document to be cached to disk instead of loading the whole report in memory. The PDF export also detects this setting and exports the cached report. Please note that only the PDF export is affected by the CacheToDisk property; other exports may run out of memory with very large reports. By default, CacheToDisk uses IsolatedStorage, which requires IsolatedStorageFilePermission.
    It is recommended that you use the CacheToDiskLocation property to specify the physical path instead of using isolated storage so that you do not run into the size limit.
  • Summary: Placing summaries (primarily page count and report totals) in header sections will have an adverse effect on memory as well as rendering speed with large reports using the CacheToDisk property. Since the rendering of the header is delayed until ActiveReports determines the total or page count of the following sections, CacheToDisk is unable to perform any optimization. The greater the number of affected sections, the longer rendering is delayed and the less optimization CacheToDisk will offer. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.

Speed Considerations

  • Image: An image repeated on every page of a very long report is stored only once to improve memory, but the comparison necessary to detect duplicate images slows performance. This is not only the case with the report document itself, but also with the Excel, PDF, and HTML exports as they perform their own comparisons.
  • Summaries: Placing summaries (primarily page count and report totals) in header sections will slow report processing. ActiveReports must determine the total or page count of the following sections before it can render the header section. The greater the number of affected sections, the longer rendering is delayed. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.
  • CacheToDisk: Be sure that the CacheToDisk property of the Document object is not set to True. Setting it to True increases the amount of time the report takes to load, and should only be used with very large reports that use a lot of memory. If this is used with smaller reports of less than 100 pages, it may actually cause more memory to be used.
  • SELECT *：Using the SELECT * statement is only recommended when you actually want to use all of the data returned by this statement. Contact your database administrator for other methods to speed up your queries.

Printing Considerations

  • Virtual Printer：We recommend use of virtual printer in case report generate environment differs from the environment in which the report is viewed or printed like in the case of Web applications.
  • Line：Please be careful as Line control has been used to draw borders within a report. An issue has been observed that spool size is increased (when comparing with Solid) during printing in case LineStyle property is set to an any value e.g. Dash or Dot etc. other than Solid that is the default value. As a result, time is taken for spooling by the report thus hindering the performance while printing. Same issue is observed when rendering a line using GDI+ in PrintDocument of .NET Framework.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Custom Properties in Chart

Custom Properties in Chart
See Also
Developers > Work with Reports using Code > Section Report > Custom Properties in Chart

Glossary Item Box

The topic explains how to set the custom properties in Section Reports charts. Each chart type in the ActiveReports Chart control contains specific properties that apply to it. You can set the chart type and the correlating series-specific properties in the Series Collection Editor dialog via the Series (Collection) property in the Properties Panel of Visual Studio and in the DataPoint Collection dialog box via the Points (Collection) property in the Series dialog.

Note that 2D Area Charts do not have any custom properties.

3D Area Chart

3D Area Chart

Custom Properties

The LineBackdrop property gets or sets the backdrop information for the 3D line.
The Thickness property gets or sets the thickness of the 3D line.
The Width property gets or sets the width of the 3D line.

Below is an example of how to set the custom chart properties at run time for a 3D area chart as shown for the first series in the image above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("LineBackdrop") = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.Red, CType(150, Byte))
Me.ChartControl1.Series(0).Properties("Thickness") = 5.0F
Me.ChartControl1.Series(0).Properties("Width") = 30.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["LineBackdrop"] = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Red, ((System.Byte)(150)));
this.ChartControl1.Series[0].Properties["Thickness"] = 5f;
this.ChartControl1.Series[0].Properties["Width"] = 30f;

Similarly, the for Stacked Area Chart and Stacked Area 100% Chart, the Width property is the custom property that gets or sets the width of the 3D stacked area.

2D Bar Charts

Simple Bar Chart

The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a bar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Gantt Chart

The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a Gantt chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Horizontal Bar Chart

The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a horizontal bar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties（"Gap") = 65.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 65f；

Stacked Bar Chart

The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a StackedBar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;

Stacked Bar Chart 100%

The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a StackedBAR110Pct chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;

3D Bar Chart

Simple Bar Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that is displayed.Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The RotationAngle propertygets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Gantt Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Horizontal Bar Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType propertygets or sets the type of bars that is displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a horizontal 3D bar chart as shown above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
 Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
 Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
 Me.ChartControl1.Series(0).Properties("PointBarDepth") = 100.0F
 Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
 Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C# Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 80f;
 this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
 this.ChartControl1.Series[0].Properties["Gap"] = 65f;
 this.ChartControl1.Series[0].Properties["PointBarDepth"] = 100.0f;
 this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
 this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;

Stacked Bar Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a StackedBar3D chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
 Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
 Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
 Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C# Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 100f;
 this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
 this.ChartControl1.Series[0].Properties["Gap"] = 65f;
 this.ChartControl1.Series[0].Properties["VertexNumber"] = 6

Bar/Cylinder Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Bar/Pyramid Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Clustered Bar Chart

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.
The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.
The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType.
The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a 3D clustered bar chart as shown above.

VB Copy Code
' set the custom properties for series 1.
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 50.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 300.0F
Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
' set the custom properties for series 2.
Me.ChartControl1.Series(1).Properties("BarTopPercent") = 20.0F
Me.ChartControl1.Series(1).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(1).Properties("Gap") = 300.0F
Me.ChartControl1.Series(1).Properties("RotationAngle") = 90.0F
Me.ChartControl1.Series(1).Properties("VertexNumber") = 3
C# Copy Code
// set the custom properties for series 1.
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 50f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;
// set the custom properties for series 2.
this.ChartControl1.Series[1].Properties["BarTopPercent"] = 20f;
this.ChartControl1.Series[1].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[1].Properties["Gap"] = 300f;
this.ChartControl1.Series[1].Properties["RotationAngle"] = 90f;
this.ChartControl1.Series[1].Properties["VertexNumber"] = 3;

2D Line Chart

Bezier Chart

Custom properties are as follows:

The Line property gets or sets the line element. Used to set color, thickness and shape of a line.
The Tension property gets or sets the tension of the curved lines.

Bezier XY

Custom properties are as follows:

The Line property gets or sets the line element. Used to set color, thickness and shape of a line.
The Tension property gets or sets the tension of the curved lines.

Simple 2D Line Chart and Line XY Chart

Custom properties are as follows:

The Line property gets or sets the line element. Used to set color, thickness and shape of a line.
The LineJoin property sets the type of join to draw when two lines connect.

Pie and Doughnut Charts

Doughnut

The Clockwise property gets or sets a value indicating whether to display the data in clockwise order.
The ExplodeFactor property gets or sets the amount of separation between data point values.
The HoleSize property gets or sets the inner radius of the chart.
The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart.
The StartAngle property gets or sets the horizontal start angle for the series.

Below is an example of how to set custom chart properties at run time for a doughnut chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.25F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 0.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.ChartControl1.Series[0].Properties["HoleSize"] = 0.25f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = false;
this.ChartControl1.Series[0].Properties["Radius"] = 2.0f;
this.ChartControl1.Series[0].Properties["StartAngle"] = 0f;

Funnel

The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.

C# Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["CalloutLine"] = new Line(Color.Black, 2, LineStyle.Dot);
this.ChartControl1.Series[0].Properties["FunnelStyle"] = FunnelStyle.YIsWidth;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["NeckWidth"] = 20f;
this.ChartControl1.Series[0].Properties["NeckHeight"] = 5f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Pyramid

The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.

3D Pie and Doughnut charts

Doughnut Chart

The Clockwise property gets or sets a value indicating whether to display the data in clockwise order.
The ExplodeFactor property gets or sets the amount of separation between data point values. The value must be less than or equal to 1. To explode one section of the doughnut chart, set ExplodeFactor to the data point instead of the series.
The HoleSize property gets or sets the inner radius of the chart. If set to 0, the chart looks like a pie chart. The value must be less than or equal to 1.
The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart.
The Radius property gets or sets the size of the doughnut within the chart area.
The StartAngle property gets or sets the horizontal start angle for the series data points.

Below is an example of how to set the custom chart properties at run time for a 3D doughnut chart as shown in the image above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.33F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 50.0F
C# Copy Code
this.chartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.chartControl1.Series[0].Properties["HoleSize"] = .33f;
this.chartControl1.Series[0].Properties["OutsideLabels"] = false;
this.chartControl1.Series[0].Properties["StartAngle"] = 50f;

Funnel Chart

The BaseStyle property gets or sets a circular or square base drawing style for the 3D funnel chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the funnel. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a 3D funnel chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BaseStyle") = BaseStyle.SquareBase
    .Properties("CalloutLine") = New Line(Color.Black, 2, LineStyle.Dot)
    .Properties("FunnelStyle") = FunnelStyle.YIsWidth
    .Properties("MinPointHeight") = 10.0F
    .Properties("NeckWidth") = 20.0F
    .Properties("NeckHeight") = 5.0F
    .Properties("OutsideLabels") = True
    .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right
    .Properties("PointGapPct") = 3.0F
    .Properties("RotationAngle") = 3.0F
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["CalloutLine"] = new Line(Color.Black, 2, LineStyle.Dot);
this.ChartControl1.Series[0].Properties["FunnelStyle"] = FunnelStyle.YIsWidth;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["NeckWidth"] = 20f;
this.ChartControl1.Series[0].Properties["NeckHeight"] = 5f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Pyramid Chart

The BaseStyle property gets or sets a circular or square base drawing style for the 3D pyramid chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the pyramid. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a Pyramid chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics

Visual Basic Copy Code
With Me.ChartControl1.Series(0)
.Properties("BaseStyle") = BaseStyle.SquareBase
.Properties("MinPointHeight") = 10.0F
.Properties("OutsideLabels") = True .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right .Properties("PointGapPct") = 3.0F
.Properties("RotationAngle") = 3.0F End With
C# Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Candle Stick Chart

The BodyDownswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is lower than the opening figure.
The BodyUpswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is higher than the opening figure.
The BodyWidth property gets or sets the width of the rectangle used to show upswing or downswing.
The WickLine property gets or sets the line information for the wick line.

Below is an example of how to set the custom chart properties at run time for a Pyramid chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics

Visual Basic Copy Code
With Me.ChartControl1.Series(0)
.Properties("BodyDownswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(255, 192, 255))
.Properties("BodyUpswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(192, 192, 255))
.Properties("WickLine") = New Chart.Graphics.Line(Color.Indigo)
.Properties("BodyWidth") = 7.0F
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"]= new Chart.Graphics.Backdrop
(Color.FromArgb(255, 192, 255));
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Chart.Graphics.Backdrop
(Color.FromArgb(192, 192, 255));
this.ChartControl1.Series(0).Properties("WickLine") = new Chart.Graphics.Line(Color.Indigo);
this.ChartControl1.Series[0].Properties["BodyWidth"] = 7f;

HiLo Chart

The HiloLine property gets or sets the line information for the HiLo line.

Below is an example of how to set the custom chart properties at run time for a HiLo chart as shown in the image above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("HiloLine") = New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4)
C# Copy Code
this.ChartControl1.Series[0].Properties["HiloLine"] = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4);

Point and Figure Chart

The BoxSize property gets or sets the amount a price must change in order to create another X or O.
The DownswingLine property gets or sets the style and color settings for the downswing O's.
The ReversalAmount property gets or sets the amount that a price must shift in order for a new column to be added.
The UpswingLine property gets or sets the style and color settings for the upswing X's.

Below is an example of how to set the custom chart properties at run time for a Point and Figure chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.Red)
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.Blue)
    .Properties("BoxSize") = 3.0F
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.Red);
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.Blue);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Renko Chart

The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing bricks.
The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing bricks.
The BoxSize property gets or sets the amount a price must change in order to create another brick.

Below is an example of how to set the custom chart properties at run time for a Renko chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.BlueViolet)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Navy)
    .Properties("BoxSize") = 3.0F
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.BlueViolet);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Navy);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Kagi Chart

The DownswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price decrease.
The ReversalAmount property gets or sets the amount that a price must shift in order for the Kagi line to change direction.
The UpswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price increase.

Below is an example of how to set the custom chart properties at run time for a Kagi chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.DarkRed)
    .Properties("ReversalAmount") = "25"
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.DarkBlue)
    .Properties("Width") = 50.0F
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.DarkRed);
this.ChartControl1.Series[0].Properties["ReversalAmount"] = "25";
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.DarkBlue);
this.ChartControl1.Series[0].Properties["Width"] = 50f;

Stock Chart

The CloseLine property gets or sets the information for the close value line.
The HiLoLine property gets or sets the line information for the HiLo line.
The OpenLine property property gets or sets the information for the open value line.
The TickLen property property gets or sets the tick length for the close value and open value lines.

Stock Close Only Chart

The CloseLine property gets or sets the information for the close value line.
The HiLoLine property gets or sets the line information for the HiLo line.
The OpenLine property property gets or sets the information for the open value line.
The TickLen property property gets or sets the tick length for the close value and open value lines.

Stock Open Only Chart

The CloseLine property gets or sets the information for the close value line.
The HiLoLine property gets or sets the line information for the HiLo line.
The OpenLine property property gets or sets the information for the open value line.
The TickLen property property gets or sets the tick length for the close value and open value lines.

Three Line Break Chart

The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing boxes.
The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing boxes.
The NewLineBreak property gets or sets the number of previous boxes/lines that must be compared before a new box/line is drawn. The default value is 3.

Below is an example of how to set the custom chart properties at run time for a Three Line Break chart.

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Black)
    .Properties("NewLineBreak") = 3
End With
C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Black);
this.ChartControl1.Series[0].Properties["NewLineBreak"] = 3;

See Also

Report Authors
Chart

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Report Parts

Report Parts
Developers > Report Parts

Glossary Item Box

Introduction

ActiveReports.NET includes the web designer component that you can integrate into your web-application to allow end-users to create and modify reports. The web designer covers most of the functionality of the VS.NET integrated designer and the standalone report designer; it allows configuring data binding, adding report items, and setting their properties. However, end-users of your application might not have extensive knowledge of data binding, report items, and surrounding topics. To streamline the user experience, ActiveReports.NET offers the Report Parts feature. Report Parts are basically pre-configured report items that end-users could drag-and-drop into a report body and customize further. The available customization properties are also defined in a report part.

Web Designer with part item added

Report Libraries

A Report Library is a report that contains one or more Report Parts. You can build multiple report libraries for different user groups. If an end-user adds a report part to a target report, then it includes a link to the corresponding report library. You can then modify report parts definitions within a report library, and modifications will be automatically picked up for all target reports that use these report parts. Note that the data sources, datasets, and parameters are copied to a target report. Hence, modifying these items in the report library won’t immediately affect the target reports.

Creating Report Libraries

To create a report library, you can create a new or open an existing RDLX Report in the standalone designer application, or in the VS.NET integrated designer. Once you decided which report items should be exposed as report parts, you can initialize a new report part using the following methods:

  • Select one or more report items, right-click the selection, and in the context menu, choose the Create Report Part menu.
    Create Report Part via Context Menu
  • Select the Report object by clicking anywhere outside the report body, and open the Report Parts collection from the Properties Panel.
    Create Report Part via Properties Panel
  • Open the Report Menu and click the Report Parts item.
    Create Report Part via Properties Panel
  • Right-click the Report node in the Report Explorer and select the Report Parts… item.
    Create Report Part via Properties Panel

As the result of these actions, the Exported Report Parts dialog appears.
Exported Report Parts Dialog Settings

If you open the Export Report Parts dialog via the context menu of an existing report item, the new report part linked to that report item will be automatically created. In all other cases, you can add report parts manually. Each report part exposes the following properties:

  • Description - the description of a report part that will be visible for end-users. You can use this property to provide additional information for them.
  • Display name - the name of a report part that will be visible for end-users.
  • Name - the unique, internal name of a report part. Note that it should be a CLI-compliant identification.
  • Properties - A collection of custom properties that should be available for end-users to customize a report part. The configuration of a custom property includes:
    • Category - the category under which a custom property appears in the property grid of the web designer. You can group custom properties by using categories.
    • Default value - the initial value of a custom property.
    • Description - the description of a custom property that will be visible for end-users in the web designer property grid.
    • Display Name - the name of a custom property that will be useful for end-users in the web designer property grid.
    • Name - the unique, internal name of a custom property. Note that it should be a CLI-compliant identification.
    • Property Type - identifies the editor of a custom property that will be available for end-users. For example, if you want to allow end-users to modify the background color of a report item, you can set the type of the corresponding custom property to 'Color' and the color editor will appear in the web designer property grid.
  • Report Item - the link to the report item that is represented by a report part.
  • Sizing - Identifies whether end-users could resize a report part after adding it to a report.

After defining a custom property, you can refer to its value by using the PartProperties collection. For example, if you have defined the 'BackColor' custom property in a report part, you can set the Background Color of a report item to the =PartProperties.BackColor.Value expression. The custom properties for all report parts are available via the expression editor.

Report Part Property in Expresstion Editor

Integrating Report Libraries

After creating a report library and saving it (it is just an RDLX report), you can save it within the resources of a web-application that uses the web designer. The recommended way is to keep the report libraries the same way you keep other reports – in the file system or a database. Then you can list the report libraries that should be available for end-users via the ReportPartsSettings API. Here is the sample of code:

Index.html Copy Code
<html lang="en">
<head>
    @*get these files from the installation location for the package: \node_modules\@mescius\activereportsnet-designer\dist*@
    <link rel="stylesheet" href="web-designer.css" />
    <script src="web-designer.js"></script>
</head>
<body>
    <div id="web-designer-host">
    </div>
<script>
        GrapeCity.ActiveReports.Designer.create('#web-designer-host', {
            rdlx: {
                reportParts: {
                    enabled: true,
                    libraries: [{
                        name: 'Sales',
                        path: 'Libraries/Lib_Sales.rdlx'
                    },
                    {
                        name: 'Marketing',
                        path: 'Libraries/Lib_Marketing.rdlx'
                    }]
                }
            }
        });
    </script>
</body>
</html>

After running the application, the web designer will have the Libraries' panel that lists available libraries and the report parts. End-users will be able to drag-and-drop the report parts, modify the custom properties. Upon previewing a report, the report parts will be rendered according to its definition with the customization applied.

Report Parts Sample

You can download the example of report parts usage from the ActiveReports GitHub repository.

Upon running the sample, you can see a customized web designer with almost all standard UI removed and the report libraries panel available and opened by default.

To observe how a library is created, go to the File menu > libraries and open 'Treadstone.rdlx' report. This is a multi-section report with three sections Cards, Tables, and Charts. All report parts that are available in this library can be viewed from the Report Parts property of the report.

The following image shows the report parts present in 'Treadstone' library in the Exported Report Parts dialog and the properties set for one of the report part in the Report Part Properties dialog, in desktop designer.

Report Parts in Desktop Designer

The 'Treadstone' library contains report parts as shown in the table below. The table describes the custom property of each report part, the original report item linked to the report part, and the expression used for referencing the report part properties into the report item's property.

Report Part Custom properties of the Report Part* Linked Original Report Item Corresponding Report Item property and the Expression (in WebDesigner)
Logo BorderColor Image Border > Color > Default
{PartProperties!BorderColor.Value}
BorderStyle
 Border > Style > Default
{PartProperties!BorderStyle.Value}
BorderWidth Border > Width > Default
{PartProperties!BorderWidth.Value}
Copyright Color
 TextBox Text > Color
{PartProperties!Color.Value}
FontFamily
 Text > Font Family
{PartProperties!FontFamily.Value}
FontSize
 Text > Font Size
{PartProperties!FontSize.Value}
FontStyle Text > Font Style
{PartProperties!FontStyle.Value}
Contacts Color
 Container. The properties are applied on the text boxes it contains. Text > Color
{PartProperties!Color.Value}
FontFamily
 Text > Font Family
{PartProperties!FontFamily.Value}
FontSize
 Text > Font Size
{PartProperties!FontSize.Value}
FontStyle Text > Font Style
{PartProperties!FontStyle.Value}
salesByMonth Title Chart Select Chart's Header > Caption
{PartProperties!Title.Value}
BackgroundColor Background >Color
{PartProperties!BackgroundColor.Value}
totalSales Caption FormattedText

The corresponding expressions are used in the 'Html' property as shown.

Copy Code
<html><body style='margin:0px'><center>
<p style='color:{PartProperties!ValueColor.Value};
font-family:"{PartProperties!ValueFont.Value}";font-size:{PartProperties!ValueFontSize.Value};
font-style:{PartProperties!ValueFontStyle.Value}'>{FormatCurrency(Sum(SALES))}</p>
<p style='color:{PartProperties!CaptionColor.Value};font-family:"{PartProperties!CaptionFont.Value}";
font-size:{PartProperties!CaptionFontSize.Value};font-style:{PartProperties!CaptionFontStyle.Value}'>{PartProperties!Caption.Value}</p>
</center></body></html>
ValueFont
ValueFontSize
ValueFontStyle
salesPerCategoryChart Title Chart Select Chart's Header > Caption
{PartProperties!Title.Value}
BackgroundColor Background > Color
{PartProperties!BackgroundColor.Value}
SalesTable HeaderTextColor Tablix Select Table Header's TextBox:
Text > Color
{PartProperties!HeaderTextColor.Value}
HeaderBgColor
 Background > Color
{PartProperties!HeaderBgColor.Value}
HeaderBorderColor Border > Color > Default
{PartProperties!HeaderBorderColor.Value}

*For complete list of custom properties in each report part, check the sample.

Try drag-and-dropping report parts from the Libraries panel to the report body, and modifying the custom properties, and previewing the result.

Report Parts in Web Designer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Designer and Viewer Applications

Create Designer and Viewer Applications
See Also
Developers > Create Designer and Viewer Applications

Glossary Item Box

This section provides some essential guidelines on how to create simple ActiveReports applications.

  • .NET Viewer Application
  • Web Viewer and Web Designer Middlewares
  • Js Viewer Application
  • ASP.NET WebViewer Application
  • Blazor Viewer Application
  • WebDesigner Application
  • Blazor WebDesigner Application
  • End User Report Designer in WinForms Application
  • Themes in WebDesigner and Js Viewer Components
  • Role Based Authorization with JWT

See Also

Samples
Samples

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WPF Viewer

WPF Viewer
See Also
Developers > Create Designer and Viewer Applications > .NET Viewer Application > WPF Viewer

Glossary Item Box

To add Viewer Control to your WPF application,

  1. In Visual Studio 2022, create a new WPF Application or open an existing one.
  2. Install NuGet package for 'MESCIUS.ActiveReports.Viewer.Wpf'. For more information on installing NuGet packages, see Manage ActiveReports Dependencies topic.
  3. Open XAML Designer (MainWindow.xaml) to verify the Viewer control showing up in the Visual Studio Toolbox under 'WPF Viewer' tab.
    Make sure that the XAML Hot Reload is enabled. See Troubleshooting for more information.
  4. From the Toolbox ActiveReports 19 tab, drag the Viewer control and drop it on the design view of MainWindow.xaml.
    Note: Dragging the Viewer control to the design view of MainWindow.xaml automatically adds the corresponding reference to the licenses.licx file.

On using the Page, RDLX, or Section report template, a new ActiveReports 19 tab is automatically added in the toolbox with the controls in sync with the references.

See Also

Load Reports
Customize the WPF Viewer

Report Readers
Windows Presentation Foundation Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Load Reports

Load Reports
Developers > Create Designer and Viewer Applications > .NET Viewer Application > WPF Viewer > Load Reports

Glossary Item Box

To load and display a report using the Viewer control in a WPF application,

  1. Create a new a WPF application in Visual Studio.
  2. From the Visual Studio toolbox, drag the Viewer control onto your XAML Form.
  3. Set the viewer's Dock property to Fill to show the complete Viewer control on the Form.
  4. In the Solution Explorer, select the report you have created and from the Properties window, set Copy to Output Directory to Copy Always.

    Note: If Page/RDLX report is selected from dropdown of Source property (containing relative path), 'Copy to Output Directory' for selected report should be set as 'Copy always/Copy if newer' otherwise error "Could not find file ... " appears on loading WPF Viewer.

    Caution: In WPF Viewer control, previewing code-based Section reports using Source and SourceFormat properties is not supported.
  5. On MainWindow.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  6. In the MainWindow code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. This code shows an .rdlx report being loaded, but you can use an .rpx report as well.
    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb. Copy Code
    Viewer1.LoadDocument("rptSingleLayout.rdlx")
    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs. Copy Code
    viewer1.LoadDocument("rptSingleLayout.rdlx");

Note:

  • Refer to the LoadDocument method to see other ways to load a report in WPF Viewer.
  • We can set report for WPFViewer directly on XAML file and load the report in WPF Viewer using Source and SourceFormat properties.
  • To avoid evaluation banners appearing at run time, license your ActiveReports WPF Application project. You can find information on licensing in License Your ActiveReports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize the WPF Viewer

Customize the WPF Viewer
Developers > Create Designer and Viewer Applications > .NET Viewer Application > WPF Viewer > Customize the WPF Viewer

Glossary Item Box

Let us see how we can customize different elements of WPF Viewer.

Add the Customization Template to the WPF Project

The ActiveReports WPF Viewer is a customizable control. You can easily change the look of the WPF Viewer and its elements, such as the error panel, search panel, sidebar and toolbar by modifying properties in the default WPF Viewer template (DefaultWPFiewerTemplates.xaml).

Once you copy the template, you can modify the default style and apply it to your viewer by creating the desired style and setting its Template property.

Note that while modifying the template, do not remove the required template parts. The required parts are usually marked with the prefix "PART_".

The template allows you to customize the appearance of viewer and take advantage of XAML-based styling.

  1. Open your WPF project.
  2. In Solution Explorer, select the YourProjectName node.
  3. On the Visual Studio Project menu, click Add Existing Item.
  4. In the dialog that appears, locate and select DefaultWPFViewerTemplates.xaml and click OK. You can find DefaultWPFViewerTemplates.xaml at C:\Program Files\MESCIUS\ActiveReports 19\Deployment\WPF\Templates folder (on a 64-bit Windows operating system, this file is located in C:\Program Files (x86)\MESCIUS\ActiveReports 19\Deployment\WPF\Templates.
  5. On MainWindow.xaml before the opening <Grid> tag, add the following code.
    Paste to the XAML view of MainWindow.xaml before the opening <Grid> tag Copy Code
    <Window.Resources>
<ResourceDictionary Source="DefaultWPFViewerTemplates.xaml" />
</Window.Resources>

Customize the WPF Viewer Sidebar

Modify Thumbnails

  1. In Solution Explorer, double-click DefaultWPFViewerTemplates.xaml.
  2. In the file that opens, search for "thumbnails tab".
  3. In the GroupBox Header property of <!-- thumbnails tab -->, remove "{Binding Sidebar.ThumbnailsPane.Text}" and type "THUMBNAILS".

    Modify Thumbnails in WPF Viewer

    Modify Background Color of the Sidebar
  4. Search for "TabControl x:Name="Sidebar".
  5. Add Background="Yellow" after TabControl x:Name="Sidebar".
    Modify Sidebar Background Color in WPF Viewer
  6. Press F5 to see the customized viewer sidebar.
    Customized WPF Viewer Sidebar

Add a customized button to the WPF Viewer toolbar

  1. In Solution Explorer, select the YourProjectName node.
  2. On the Visual Studio Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select Class, rename it to MyCommand and click Add.
  4. In the MyCommand.cs/vb that opens, add the following code to implement a command.
    Visual Basic.NET code. Add to MyCommand.vb Copy Code
    Implements ICommand
Public Function CanExecute(ByVal parameter As Object) As Boolean Implements System.Windows.Input.ICommand.CanExecute
    Return True
End Function
Public Event CanExecuteChanged(ByVal sender As Object, ByVal e As System.EventArgs) Implements System.Windows.Input.ICommand.CanExecuteChanged

Public Sub Execute(ByVal parameter As Object) Implements System.Windows.Input.ICommand.Execute
    MessageBox.Show("MESCIUS is the world's largest component vendor.", "About Us", MessageBoxButton.OK)
End Sub

    C# code. Add after the statement using System.Text Copy Code
    using System.Windows.Input;
using System.Windows;
    C# code. Add after the statement using System.Text Copy Code
    public class MyCommand : ICommand
    {
        public bool CanExecute(object parameter)
        {
            return true;
        }

        public void Execute(object parameter)
        {
            MessageBox.Show("MESCIUS is the world's largest component vendor.", "About Us", MessageBoxButton.OK);
        }

        public event EventHandler CanExecuteChanged;
    }
  5. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  6. In the file that opens, add the following code.
    XML code. Add to DefaultWpfViewerTemplates.xaml Copy Code
    <ResourceDictionary>
 ...
xmlns:YourProjectName="clr-namespace:YourProjectName">
<YourProjectName:MyCommand x:Key="MyCommand" />
...
</ResourceDictionary>

    Adding code to DefaultWpfViewerTemplates.xaml file

  7. In the same file, add the following code to add a button.
    XML code. Add to DefaultWpfViewerTemplates.xaml before the closing Toolbar tag
    Copy Code
    <Button Command="{StaticResource MyCommand}" Content="About Us" />
    Adding code to DefaultWpfViewerTemplates.xaml file
  8. Press F5 to see the new customized button About Us in the Viewer toolbar.

Remove the Refresh button from the WPF Viewer toolbar

  1. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  2. In the file that opens, search for "<!--Refresh btn-->".
  3. Replace the existing content in Visiblity="..." with the following.
    XML code. Add to DefaultWpfViewerTemplates.xaml
    Copy Code
    <Button Command=... Visibility="Collapsed">

    Customized WPF Viewer About Us

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Windows Forms Viewer

Windows Forms Viewer
See Also
Developers > Create Designer and Viewer Applications > .NET Viewer Application > Windows Forms Viewer

Glossary Item Box

On using the Page, RDLX, or Section report template, the Viewer control is already available on the Windows Form. The control is also available on the Toolbox under ActiveReports 19 tab, with the controls in sync with the references.

To add Viewer control to your WinForms Application,

  1. In Visual Studio 2022, create a new Windows Forms App or open an existing one.
  2. Install NuGet package for 'MESCIUS.ActiveReports.Viewer.Win'. For more information on installing NuGet packages, see Manage ActiveReports Dependencies topic.
  3. Open WinForms Designer (Form1.cs or Form1.vb) to verify the Viewer control showing up in the Visual Studio Toolbox under 'ActiveReports 19' tab.
    To show the Visual Studio Toolbox, navigate to View > Toolbox.

See Also

Load Reports
Customize the WinForms Viewer Control

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Load Reports

Load Reports
Developers > Create Designer and Viewer Applications > .NET Viewer Application > Windows Forms Viewer > Load Reports

Glossary Item Box

To load and display a Page, RDLX, and Section report output using the Viewer control in the Windows Forms application.

  1. Create a new Windows Forms application in Visual Studio.
  2. From the Visual Studio toolbox, drag the Viewer control onto your Windows Form Designer.
  3. Set the viewer's Dock property to Fill to show the complete Viewer control on the Form.
  4. Double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  5. In the Form_Load event, add the code as follows to run the report and display it in the viewer.

    Load Page/RDLX report

    C# Copy Code
    string file_name = @"..\..\ReportName.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

    VB.NET Copy Code
    Dim file_name As String = "..\..\ReportName.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
Viewer1.LoadDocument(pageDocument)

    Load Code-based Section Report

    C# Copy Code
    SectionReport1 sectionReport = new SectionReport1();
viewer1.LoadDocument(sectionReport);

    VB.NET Copy Code
    Dim sectionReport As New SectionReport1()
Viewer1.LoadDocument(sectionReport)

    Load Xml-based Section Report

    C# Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
xtr.Close();
viewer1.LoadDocument(sectionReport);

    VB.NET Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("..\..\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
xtr.Close()
Viewer1.LoadDocument(sectionReport)

Caution: Refresh button gets disabled when you load a section report in the Viewer control through any of the following:

  • Document Property
  • LoadDocument(SectionDocument) Method
  • LoadDocument(String) Method

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize the WinForms Viewer Control

Customize the WinForms Viewer Control
Developers > Create Designer and Viewer Applications > .NET Viewer Application > Windows Forms Viewer > Customize the WinForms Viewer Control

Glossary Item Box

There are a number of ways in which you can customize the Viewer control to make it a perfect fit for your Windows application. You can add and remove buttons from the toolbars, add and remove menu items, create custom dialogs, and call these dialogs from custom click events.

Customize Viewer Toolbar

You can use the methods listed in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN to customize each ToolStrip.

ToolStrip

The ToolStrip contains the following ToolStripItems by index number.

  • 0 Toggle sidebar
  • 1 Separator
  • 2 Print
  • 3 Galley mode
  • 4 Separator
  • 5 Copy
  • 6 Find
  • 7 Separator
  • 8 Zoom out
  • 9 Zoom In
  • 10 Current Zoom
  • 11 Separator
  • 12 Fit width
  • 13 Fit page
  • 14 Separator
  • 15 Single page
  • 16 Continuous mode
  • 17 Multipage mode
  • 18 Separator
  • 19 First page
  • 20 Previous page
  • 21 Current
  • 22 Next page
  • 23 Last page
  • 24 Separator
  • 25 History back
  • 26 History forward
  • 27 Separator
  • 28 Back to parent
  • 29 Separator
  • 30 Refresh
  • 31 Cancel button
  • 32 Separator
  • 33 Pan mode
  • 34 Copy select
  • 35 Snapshot
  • 36 Separator
  • 37 Annotations

You can access these ToolStripItems by index with the Insert and RemoveAt methods. Other methods, including Add and AddRange, are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

ToolStrip Implementation

When you add a new item to a ToolStrip, you need to add an ItemClicked event handler and an ItemClicked event for the ToolStrip with the new item. At run time, when a user clicks the new ToolStrip item, they raise the ItemClicked event of the ToolStrip containing the item

Add the event handler to the Load event of the Form that contains the Viewer control, and use the IntelliSense Generate Method Stub feature to create the related event. For example, of the code to create an event hander, as explained in the below section.

You can modify both viewer's mouse mode and touch mode toolbars by accessing the index number corresponding to the toolbar button and set custom commands. For example, in the following sample codes we show customization specific to mouse mode toolbar and touch mode toolbar.

Create a Viewer Form and Load Report in Viewer

See Load Reports topic to create a WinForms application and preview a report in the Viewer.

Customize the Mouse Mode Toolbar

Lets display a custom print button as shown in the following image on the WinForms Viewer toolbar (mouse mode):

  1. Add a second Windows Form (Form2.cs) to the project created above and name it frmPrintDlg.
  2. Add a label to frmPrintDlg and change the Text property to This is the custom print dialog.
  3. Add a button to frmPrintDlg and change the Text property to OK.
  4. Back on the viewer form, double-click the title bar of the form to go to the Form Load event.
  5. Add the following code to the Form Load event to remove the default print button and add your own.
    C# Copy Code
    //Remove the original print button.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(2);
//Remove the extra separator.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(1);
//Add a new button to the end of the tool strip with the caption "Print."
ToolStripButton tsbPrint = new ToolStripButton("Print");
viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint);
//Create a click event handler for the button.
tsbPrint.Click += new EventHandler(tsbPrint_Click);
    VB.NET Copy Code
    'Remove the print button.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(2)
'Remove the extra separator.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(1)
'Add a new button to the end of the tool strip with the caption "Print."
Dim tsbPrint As New ToolStripButton("Print")
Viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint)
'Create a click event handler for the button.
AddHandler tsbPrint.Click, AddressOf tsbPrint_Click
  6. Add the following code to the Form class below the Load event to display 'frmPrintDlg' when a user clicks the custom print button.
    C# Copy Code
    //Call the custom dialog from the new button's click event.
private void tsbPrint_Click(object sender, EventArgs e)
{
    this.CustomPrint();
}
//Call the custom print dialog.
private void CustomPrint()
{
    frmPrintDlg _printForm = new frmPrintDlg();
    _printForm.ShowDialog(this);
}

    VB.NET Copy Code
    'Call the custom dialog from the new button's click event.
Private Sub tsbPrint_Click(sender As Object, e As EventArgs)
    Me.CustomPrint()
End Sub
'Call the custom print dialog.
Private Sub CustomPrint()
    Dim _printForm As New frmPrintDlg()
    _printForm.ShowDialog(Me)
End Sub
  7. Press F5 to run the project and click on the print button of main viewer to view custom print dialog.

Customize the Touch Mode Toolbar

  1. Double-click in the title bar of the Viewer form to create a Form Load event.
  2. Add the following code to add a custom Zoom Out button.
    C# Copy Code
    viewer1.TouchMode = GrapeCity.Viewer.Common.Model.TouchMode.True;

var zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items[8];
zoomOutButton.Visible = true;

    VB.NET Copy Code
    viewer1.TouchMode = GrapeCity.Viewer.Common.Model.TouchMode.[True]

Dim zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items(8)
zoomOutButton.Visible = true
Caution: Any customization done in mouse mode does not apply to the touch mode and vice versa.

Customize Viewer Sidebar

The following code customizes the background of Thumbnail in Sidebar of the Viewer.

Customized WinForms Viewer Sidebar

In the Viewer Form Load event, add the code as follows:

C# Copy Code
 private void Form1_Load(object sender, EventArgs e)
        {
            Control o = GetControlByName(viewer1, "thumbnailViewer1");
            o.BackColor = System.Drawing.Color.Green;

            //write code to load report
        }
        public Control GetControlByName(Control ParentCntl, string NameToSearch)
        {
            if (ParentCntl.Name == NameToSearch)
                return ParentCntl;
            foreach (Control ChildCntl in ParentCntl.Controls)
            {
                Control ResultCntl = GetControlByName(ChildCntl, NameToSearch);
                if (ResultCntl != null)
                    return ResultCntl;
            }
            return null;
        }
VB.NET Copy Code
    Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
        Dim o As Control = GetControlByName(Viewer1, "thumbnailViewer1")
        o.BackColor = System.Drawing.Color.Green

        'write code to load report
    End Sub
    Public Function GetControlByName(ByVal ParentCntl As Control, ByVal NameToSearch As String) As Control
        If ParentCntl.Name = NameToSearch Then Return ParentCntl
        For Each ChildCntl As Control In ParentCntl.Controls
            Dim ResultCntl As Control = GetControlByName(ChildCntl, NameToSearch)
            If ResultCntl IsNot Nothing Then Return ResultCntl
        Next
        Return Nothing
    End Function

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Web Viewer and Web Designer Middlewares

Web Viewer and Web Designer Middlewares
Developers > Create Designer and Viewer Applications > Web Viewer and Web Designer Middlewares

Glossary Item Box

This section elaborates on the middlewares for web viewers and web designers in the ASP.NET Core MVC and Razor Pages applications.

  • Js Viewer ASP.NET Core Middleware
  • WebDesigner ASP.NET Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Js Viewer ASP.NET Core Middleware

Js Viewer ASP.NET Core Middleware
Developers > Create Designer and Viewer Applications > Web Viewer and Web Designer Middlewares > Js Viewer ASP.NET Core Middleware

Glossary Item Box

ASP.NET Core middleware is software to handle HTTP requests and responses. Each middleware component serves a specific purpose, one authenticates a user, and the other handles static files like Javascript or CSS files. These middleware components together set up a request processing pipeline.

The default code developed by the ASP.NET Core Web App template sets up the request processing pipeline for the application using a set of middlewares - UseDeveloperExceptionPage() and UseStaticFiles() of the IApplicationBuilder interface. The middlewares are executed in the order in which they are added to the pipeline.

To provide access to a report output from the browser, you need to configure ActiveReports JSViewer in ASP.NET Core middleware. It is done by adding the UseReportViewer() middleware, which configures middleware for ActiveReports API and handlers.

  1. Create an ASP.NET Core Project

  2. Open Microsoft Visual Studio 2022 and create a new ASP.NET Core Web App project which includes example Razor Pages.

    Configure your new project dialog

  3. Type a name for your project and click Next.
    Create app

  4. Fill-in the additional info like 'Framework' as .NET 8.0.

    Create a new ASP.Net Core Web Application dialog

  5. Uncheck the 'Configure for HTTPS' checkbox instruction and click Create.

    Configure ActiveReports in ASP.NET Core Middleware

  6. Right-click the project in the Solution Explorer and select Manage Nuget Packages.

  7. Add the following package to the project.

    MESCIUS.ActiveReports.Aspnetcore.Viewer

  8. In the License Acceptance dialog that appears, click I Accept.

  9. Add a new folder called 'Reports' in application's root and place the report you want to display in the viewer, in this folder.

  10. Make sure to set the Build Action property of the report to 'Embedded Resource'.

  11. Modify the content for the Program.cs file as follows to enable the application to use ActiveReports:

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using System.Reflection;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddRazorPages();
var app = builder.Build();
// Configure the HTTP request pipeline.
if (!app.Environment.IsDevelopment())
{
    app.UseExceptionHandler("/Error");

    app.UseHsts();
}
app.UseHttpsRedirection();
app.UseStaticFiles();
// Configure middleware for ActiveReports API and handlers.
app.UseReportViewer(settings =>
{
    settings.UseEmbeddedTemplates("WebApplication_JsViewer.Reports", System.Reflection.Assembly.GetAssembly(app.GetType()));
});
app.UseRouting();
app.UseAuthorization();
app.MapRazorPages();
app.Run();

    Make sure that the correct namespace is provided in the first argument of UseEmbeddedTemplates for the report.

Note: Instead of ‘UseEmbeddedTemplates', you can use either 'UseFileStore' or 'UseReportProvider’ method calls.

  • 'UseEmbeddedTemplates' stores reports as resources in dlls.
  • 'UseFileStore' stores reports in the file system.
  • 'UseReportProvider’ allows you to store reports in any user-defined location, like a custom database or any other type of location.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebDesigner ASP.NET Middleware

WebDesigner ASP.NET Middleware
Developers > Create Designer and Viewer Applications > Web Viewer and Web Designer Middlewares > WebDesigner ASP.NET Middleware

Glossary Item Box

ASP.NET Core middleware is software to handle HTTP requests and responses. Each middleware component serves a specific purpose, one authenticates a user, and the other handles static files like Javascript or CSS files. These middleware components together setup a request processing pipeline.

The default code developed by the ASP.NET Core Web App template sets up the request processing pipeline for the application using set of middlewares - UseDeveloperExceptionPage() and UseStaticFiles() of the IApplicationBuilder interface. The middlewares are executed in the order in which they are added in the pipeline.

To allow designing reports from a browser, you need to configure ActiveReports WebDesigner in ASP.NET Core middleware. It is done by adding the UseReportDesigner() middleware, which configures middleware for the ActiveReports API and handlers.

The following are the methods to define middleware settings for WebDesigner available in the ReportDesignerConfiguration class:

  • UseConfig : Sets the path to configuration file, ActiveReports.config.
  • UseReportsProvider: Sets the custom resource service to be used.
  • UseDataProviders: Adds custom data provider.
  • UseFileStore: Use directory as the source of resources.

Create an ASP.NET Core Project

The steps to create a WebDesigner sample using ASP.NET MVC Core application are as follows:

  1. Open Microsoft Visual Studio 2022 and create a new ASP.NET Core Web App project which includes example Razor Pages.

    Configure your new project dialog

  2. Type a name for your project and click Next.

    Create a new ASP.NET core web application dialog

  3. Fill-in the additional info like 'Framework' as .NET 8.0 and click Create.

    Create a new ASP.NET core web application dialog

    Configure ActiveReports in ASP.NET Core Middleware

  4. Right-click the project under the Solution Explorer and select Manage Nuget Packages.

  5. In the window that appears, go to Browse and input Microsoft.AspNetCore.StaticFiles, select the latest version, and click Install.

  6. Similarly, browse the following package and install it.

    MESCIUS.ActiveReports.Aspnetcore.Designer

  7. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.

  8. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  9. Modify the content for the Program.cs file as follows to enable the application to use ActiveReports:

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Configuration;

DirectoryInfo ResourcesRootDirectory = new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources" + Path.DirectorySeparatorChar));
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
 builder.Services.AddControllersWithViews();
 builder.Services.AddReportDesigner();
var app = builder.Build();

 app.UseHttpsRedirection();
if (!app.Environment.IsDevelopment())
 {
    app.UseDeveloperExceptionPage();
 }
// Configure middleware for ActiveReports API and handlers.
app.UseReportDesigner(config =>
            config.UseFileStore(ResourcesRootDirectory, null, FileStoreOptions.NestedFoldersLookup));
app.UseDefaultFiles();
app.UseStaticFiles();
app.Run();

In case you create the application targeting below .Net 6.0, update the Startup.cs as follows:

Startup.cs Copy Code
using System.IO;
using Microsoft.AspNetCore.Builder;
using Microsoft.AspNetCore.Hosting;
using Microsoft.Extensions.DependencyInjection;
using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports.Configuration;
namespace WebDesignerSample
{
        public class Startup
        {
                // resources (reports, themes, images) location
                private static readonly DirectoryInfo ResourcesRootDirectory = new DirectoryInfo(".\\resources\\");
                public void ConfigureServices(IServiceCollection services)
                {
                        // web designer services
                        services.AddReportDesigner();
                }
                public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
                {
                        // web designer middleware
                        app.UseReportDesigner(config =>
                                    config.UseFileStore(ResourcesRootDirectory, null, FileStoreOptions.NestedFoldersLookup));
                        // static files middlewares
                        app.UseDefaultFiles();
                        app.UseStaticFiles();
                }
        }
}

Using Js Viewer with WebDesigner

You already get the basic previewing ability of the Js Viewer if you have already configured the designer middleware, so you do not need to configure the middleware for the viewer (UseReportViewer()) separately.
If you wish to configure the middleware for the viewer separately, you need to pass the OmitViewerConfiguration parameter to the designer that removes the default viewer configuration:

.cs Copy Code
app.UseReportDesigner(config =>
{
  ...
  config.OmitViewerConfiguration = true;
});

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Js Viewer Application

Js Viewer Application
Developers > Create Designer and Viewer Applications > Js Viewer Application

Glossary Item Box

The Js Viewer is a Javascript component that you can easily customize and use in web applications to preview all types of reports - Page, Rdlx, and Section reports. The Js Viewer works on modern web application frameworks - ASP.NET MVC, ASP.NET Core MVC, and major JavaScript Frameworks such as Angular, React, and Vue.js. The Viewer supports all the major browsers as well as rendering on mobile devices.

Create Js Viewer Application

This section covers some most popular scenarios of modern Web applications using different frameworks:

  • ASP.NET MVC Core Integration
  • Integration to Angular Application
  • Integration to React Application
  • Integration to VueJS Application

For special situations, we recommend that you read these topics:

  • Js Viewer ASP.NET Core Middleware
  • Load Reports
  • Switch Between Render Formats
  • Update Security Token in Report Service
  • Caching Reports
  • Prevent Cross-Site Scripting Attacks
  • Customize UI
  • Customize Page View
  • Animation
  • View Reports from Different Domains using CORS
  • Predefined Export Settings
  • Js Viewer API

Note: For some reports, you may need to configure a fonts factory or a resource locator. For details, see Custom Resource Locator and Custom Font Resolver.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ASP.NET MVC Core Integration

ASP.NET MVC Core Integration
Developers > Create Designer and Viewer Applications > Js Viewer Application > ASP.NET MVC Core Integration

Glossary Item Box

Let us create an ASP.NET Core application using ActiveReports and render the reports in the Js Viewer.

  1. Create an ASP.NET Core Web Application which includes example Razor Pages and configure ActiveReports in ASP.NET Core Middleware as illustrated in Js Viewer ASP.NET Middleware topic.

  2. Add Js Viewer to the application.

    1. Open the Tools menu > NuGet Package Manager > Package Manager Console and run the following command:
      npm install @mescius/activereportsnet-viewer

    2. Copy the 'jsViewer.min.js' and 'jsViewer.min.css' files installed in the node_modules folder to the wwwroot\js and wwwroot\css folder in the application, respectively.

  3. Replace the complete code in the 'Index.cshtml' with the following content:

    Index.cshtml Copy Code
    @page
@model IndexModel
@{
    ViewData["Title"] = "Home page";
}
<!DOCTYPE html>
<html lang="en">
<head>
    <title>ActiveReports JSViewer</title>
    <link rel="stylesheet" href="css/jsViewer.min.css" />
</head>
<body>
    <div id="viewer-id" style="width: 100%; height: 100%;">
    </div>
    <!--reference to js file-->
    <script src="js/jsViewer.min.js"></script>
    <script type="text/javascript">
        GrapeCity.ActiveReports.JSViewer.create({
            element: '#viewer-id',
            reportService: {
                url: 'api/reporting',
            },
            reportID: 'DemoReport.rdlx',
            settings: {
                zoomType: 'FitPage'
            }
        });
    </script>
</body>
</html>

  4. Modify the 'Startup.cs' class by adding the Reporting service in the 'Startup.cs' class as follows:

    Startup.cs Copy Code
    public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
        {
            if (env.IsDevelopment())
            {
                app.UseDeveloperExceptionPage();
            }
            else
            {
                app.UseExceptionHandler("/Error");
                // The default HSTS value is 30 days. You may want to change this for production scenarios, see https://aka.ms/aspnetcore-hsts.
                app.UseHsts();
            }
            app.UseHttpsRedirection();
            app.UseStaticFiles();
            app.UseReportViewer(settings =>
            {
                settings.UseFileStore(new System.IO.DirectoryInfo(env.ContentRootPath + @"\Reports\"));
            });
            app.UseRouting();
            app.UseAuthorization();
            app.UseEndpoints(endpoints =>
            {
                endpoints.MapRazorPages();
            });
        }

  5. Run the application.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to Angular Application

Integration to Angular Application
See Also
Developers > Create Designer and Viewer Applications > Js Viewer Application > Integration to Angular Application

Glossary Item Box

This page explains how you can embed the Js Viewer component in your Angular application. To run the Angular Application Server, you will require the node.js JavaScript runtime and Angular CLI. Use the following command in the terminal or command prompt to install the Angular CLI:

npm install -g @angular/cli

  1. Open Microsoft Visual Studio 2022 and create a new Angular and ASP.NET Core project.

    Create a New Project Dialog

  2. Type a name for your project and click Next.

  3. Select the Framework to a latest version and uncheck other options.

  4. Right-click the '.Server' project in the Solution Explorer and select Manage NuGet Packages.

  5. Add the following packages to the project.

MESCIUS.ActiveReports.Aspnetcore.Viewer

  6. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.

  7. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  8. Open 'Program.cs' file and update the file to include the 'using' statements at the top, and specify the resource folder and add services to container, so that the complete file looks like below.

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddControllers();
var app = builder.Build();
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseRouting();
app.UseDefaultFiles();
app.UseStaticFiles();
app.UseRouting();
app.UseReportViewer(config => config.UseFileStore(ResourcesRootDirectory));

// Configure the HTTP request pipeline.
app.UseHttpsRedirection();
app.UseAuthorization();
app.MapControllers();
app.MapFallbackToFile("/index.html");
app.Run();

  9. In the '.client' project, open 'package.json' file and add the following packages under 'dependencies':

"@mescius/activereportsnet-viewer": "^18.x.x"

  10. Open the '.client' project in the command prompt or terminal window and run the following command to install the npm packages.

npm install
    The viewer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-viewer\dist.
  11. Expand the 'src\app' folder in the '.client' project, open 'app.component.ts' file, and replace the existing code with the following code to initialize the Js Viewer instance.
    app.component.ts Copy Code
    import { Component, OnInit } from '@angular/core';
import { createViewer } from '@mescius/activereportsnet-viewer';
import '@mescius/activereportsnet-viewer/dist/jsViewer.min.css';
@Component({
  selector: 'app-root',
  templateUrl: './app.component.html',
  styleUrl: './app.component.css'
})
export class AppComponent implements OnInit {
  title = "app";

  ngOnInit() {
    this.viewer = createViewer({
      element: '#viewer-host'
    });
    this.viewer.openReport("DemoReport.rdlx");
  }
  }

  12. Open the 'app.component.html' file and replace the existing content with the following markup for hosting the element.

    app.component.html Copy Code
    <body>
  <div id="viewer-host"></div>
</body>
  13. Open the '\src\styles.css' file and add the following content.
    styles.css Copy Code
    #viewer-host {
  width: 100%;
  height: 100vh;
}

  14. Open 'proxy.conf.js' file and update the 'context' section of code as follows.

    proxy.conf.js Copy Code
    context: [
      "/weatherforecast",
      "/api"
   ],

  15. Press Ctrl + Shift + B to build your application and then press F5 to run it.
    On running the application, you can find the report placed in the resource folder by navigating to File menu > Open.

See Also

Js Viewer ASP.NET Core Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to React Application

Integration to React Application
See Also
Developers > Create Designer and Viewer Applications > Js Viewer Application > Integration to React Application

Glossary Item Box

This page explains how you can embed the Js Viewer component in your React application (ASP.NET Core). To run the React Application Server, you will require the node.js JavaScript runtime.

  1. Open Microsoft Visual Studio 2022 and create a new React and ASP.NET Core project.

    Create a New Project Dialog

  2. Type a name for your project and click Next.

    Configure your New Project Dialog

  3. Select the Framework to a latest version and uncheck other options.

    Create a New Project Dialog

  4. Right-click the project in the Solution Explorer and select Manage NuGet Packages.

  5. Add the following package to the project.

MESCIUS.ActiveReports.Aspnetcore.Viewer

  6. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.
  7. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  8. Open 'Program.cs' file and update the file to include the 'using' statements at the top, and specify the resource folder, and add services to container, so that the complete file looks like below.

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddControllers();
var app = builder.Build();
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseReportViewer(config => config.UseFileStore(ResourcesRootDirectory));
app.UseDefaultFiles();
app.UseStaticFiles();
// Configure the HTTP request pipeline.
app.UseHttpsRedirection();
app.UseAuthorization();
app.MapControllers();
app.MapFallbackToFile("/index.html");
app.Run();

  9. In the '.client' project, open 'package.json' file and add the following package under 'dependencies':

"@mescius/activereportsnet-viewer": "^18.x.x"

  10. Open the '.client' project in the command prompt or terminal window and run the following command to install the npm packages.

npm install

    The viewer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-viewer\dist.
  11. Open 'App.css' to update the 'root' selector, and add style for the 'viewer-host' element as follows.
    App.css Copy Code
    #root {
    height: 100%;
    width: 100%;
}
tr:nth-child(even) {
    background: #F2F2F2;
}
tr:nth-child(odd) {
    background: #FFF;
}
th, td {
    padding-left: 1rem;
    padding-right: 1rem;
}
.viewer-host {
    height: 100vh;
    width: 100%;
}
  12. Open 'App.jsx' file and replace the existing code with the following code.
    App.jsx Copy Code
    import { useEffect } from 'react';
import './App.css';
import { createViewer } from '@mescius/activereportsnet-viewer';
import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
function App() {
    useEffect(() => {
        const viewer = createViewer({
            element: '#viewer-host',
            reportID: "DemoReport.rdlx"
        });
        return () => {
            viewer.destroy();
        };
    }, []);
    return (
        <div id="viewer-host" className="viewer-host" />
    );
}
export default App;

  13. Open 'vite.config.js' file and update the 'proxy' setting as follows.

    vite.config.js Copy Code
    proxy: {
    '/api':{
        target: 'http://localhost:5267',
        secure: false
    }
}

  14. Open 'main.jsx' file and remove import React from 'react' statement if using React 17 or higher, and the outer statements <React.StrictMode> and </React.StrictMode> to disable strict mode. The final main.jsx is as shown.

    main.jsx Copy Code
    import ReactDOM from 'react-dom/client'
import App from './App.jsx'
import './index.css'
ReactDOM.createRoot(document.getElementById('root')).render(
    <App />
)

  15. Build the application and then press F5 to run it.

See Also

Js Viewer ASP.NET Core Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to VueJS Application

Integration to VueJS Application
See Also
Developers > Create Designer and Viewer Applications > Js Viewer Application > Integration to VueJS Application

Glossary Item Box

This page explains how you can embed the Js Viewer component in your VueJS application (ASP.NET Core). To run the Vue Application Server, you will require the node.js JavaScript runtime.

  1. Open Microsoft Visual Studio 2022 and create a new Vue and ASP.NET Core project.

    Create a New Project Dialog

  2. Type a name for your project and click Next.

    Configure your New Project Dialog

  3. Select the Framework to a latest version and uncheck other options.

    Create a New Project Dialog

  4. Right-click the project in the Solution Explorer and select Manage NuGet Packages.

  5. Add the following package to the project.

MESCIUS.ActiveReports.Aspnetcore.Viewer

  6. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.
  7. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  8. Open 'Program.cs' file and update the file to include the 'using' statements at the top, and specify the resource folder, and add services to container, so that the complete file looks like below.

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddControllers();
var app = builder.Build();
app.UseCors(options => options
    .WithOrigins("http://localhost:5173")
    .AllowAnyHeader()
    .AllowAnyMethod()
    .AllowCredentials()
);
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseReportViewer(config => {
    config.UseFileStore(ResourcesRootDirectory);
});
app.UseDefaultFiles();
app.UseStaticFiles();
app.UseHttpsRedirection();
app.UseAuthorization();
app.MapControllers();
app.MapFallbackToFile("/index.html");
app.Run();

  9. In the '.client' project, open 'package.json' file and add the following package under 'dependencies':

"@mescius/activereportsnet-viewer": "^18.x.x"

  10. Open the '.client' project in the command prompt or terminal window and run the following command to install the npm packages.

    npm install

    The viewer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-viewer\dist.
  11. Open 'App.vue' inside the 'src' folder and replace its default content with the following code.
    App.vue Copy Code
    <template>
    <div id="viewer-host">
    </div>
</template>
<script>
    import { createViewer } from '@mescius/activereportsnet-viewer';
    import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
    export default {
        name: 'app',
        mounted() {
            let serverUrl = 'http://localhost:5151';

            this.viewer = createViewer({
                element: '#viewer-host',
                reportService: {
                    url: serverUrl + '/api/reporting'
                }
            });
            this.viewer.openReport("DemoReport.rdlx");
        }
    }
</script>
<style>
    #viewer-host {
        background-color: #e5e5e5;
        height: 100vh;
        float: right;
        width: 100%;
    }
</style>

  12. Open 'vite.config.js' file and update the 'server' setting as follows.

    vite.config.js Copy Code
    server: {
     proxy: {
         '/api': {
             target: 'http://localhost:5001/' // Update the target to use HTTP
         }
     },
     port: 5173,
     https: false // Set https to false to run on HTTP
 }
  13. To disable browser launch, set the 'launchBrowser' to 'false' in 'launchSettings.json' (in .Server project\Properties).
  14. Run the application by pressing F5.

See Also

Js Viewer ASP.NET Core Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Load Reports

Load Reports
Developers > Create Designer and Viewer Applications > Js Viewer Application > Load Reports

Glossary Item Box

This topic provides you with the code examples for loading a report in Js Viewer in different JavaScript frameworks.

JS

Index.cshtml Copy Code
var viewer = new GrapeCity.ActiveReports.JSViewer.create({
    element: '#viewer-host'
});
viewer.openReport("DemoReport.rdlx");

Angular
app.component.ts Copy Code
import { Component, OnInit } from '@angular/core';
import { createViewer } from '@mescius/activereportsnet-viewer';
import '@mescius/activereportsnet-viewer/dist/jsViewer.min.css';
@Component({
   selector: 'app-root',
   templateUrl: './app.component.html',
   styleUrl: './app.component.css'
 })
 export class AppComponent implements OnInit {
   title = "app";

   ngOnInit() {
     this.viewer = createViewer({
       element: '#viewer-host'
     });
     this.viewer.openReport("DemoReport.rdlx");
   }
   }

React
App.jsx Copy Code
import { useEffect } from 'react';
 import './App.css';
 import { createViewer } from '@mescius/activereportsnet-viewer';
 import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
function App() {
    useEffect(() => {
         const viewer = createViewer({
             element: '#viewer-host',
             reportID: "DemoReport.rdlx"
         });
        return () => {
             viewer.destroy();
         };
     }, []);
    return (
         <div id="viewer-host" className="viewer-host" />
     );
 }
export default App;

VueJS
App.vue Copy Code
<script>
     import { createViewer } from '@mescius/activereportsnet-viewer';
     import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
     export default {
         name: 'app',
         mounted() {
             let serverUrl = 'http://localhost:5151';

             this.viewer = createViewer({
                 element: '#viewer-host',
                 reportService: {
                     url: serverUrl + '/api/reporting'
                 }
             });
             this.viewer.openReport("DemoReport.rdlx");
         }
     }
 </script>
 <style>
     #viewer-host {
         background-color: #e5e5e5;
         height: 100vh;
         float: right;
         width: 100%;
     }
 </style>

To load the most updated version of the report in the viewer, use the Refresh button.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Switch Between Render Formats

Switch Between Render Formats
Developers > Create Designer and Viewer Applications > Js Viewer Application > Switch Between Render Formats

Glossary Item Box

It is required to specify the render format in Js Viewer in the following scenarios:

  • Rounding issues in HTML output. It is not always possible to fix this in HTML, especially in Galley mode.
  • The output is not WYSIWYG sometimes.

The Js Viewer supports three render formats - 'auto' (default), 'html', and 'svg'. For a Page or an RDLX report, set the value to 'html'. For a Section report, set the value to 'svg'

To switch the mode, you should specify the renderFormat setting through the JS Viewer API:

Index.cshtml Copy Code
viewer = GrapeCity.ActiveReports.JSViewer.create({
    element: '#viewer-host',
    renderFormat: 'svg'
});

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Update Security Token in Report Service

Update Security Token in Report Service
Developers > Create Designer and Viewer Applications > Js Viewer Application > Update Security Token in Report Service

Glossary Item Box

The Js Viewer allows to specify a security token during creation. However, sometimes you may need to change a security token at run time. To do so, you should use the onRequest handler as demonstrated in the example below:

Index.cshtml Copy Code
const viewer = GrapeCity.ActiveReports.JSViewer.create({
  element: '#root',
  reportService: {
    onRequest: (init) => alert(init.credentials),
  },
});

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Caching Reports

Caching Reports
Developers > Create Designer and Viewer Applications > Js Viewer Application > Caching Reports

Glossary Item Box

Caching reports is a great technique to improve the performance of report rendering and is extremely beneficial for large reports with an infrequent change of data, like periodic reports that generate monthly or weekly.

The Js Viewer backends read a report as many times as required. However, sometimes you may need to cache the report as demonstrated in the example below.

Startup.cs Copy Code
app.UseReportViewer(settings =>
{
    settings.UseReportProvider(new ReportProvider());
});
ReportProvider.cs Copy Code
public class ReportProvider : IReportProvider
  {
      public Stream GetReport(string reportId)
      {
          PageReport report = new PageReport();
          var cache = new MemoryCache(new MemoryCacheOptions { SizeLimit = 10000 });
          cache.GetOrCreate(reportId, entry =>
          {
              entry.SetSlidingExpiration(TimeSpan.FromSeconds(30));
              report = new PageReport(new FileInfo(Path.Combine(@"C:\Reports", reportId)));
              return new MemoryStream(Encoding.ASCII.GetBytes(report.ToRdlString()));
          });

          return new MemoryStream(Encoding.ASCII.GetBytes(report.ToRdlString()));
      }

      public ReportDescriptor GetReportDescriptor(string reportId)
      {
          switch (Path.GetExtension(reportId))
          {
              case ".rdlx": return new ReportDescriptor(ReportType.RdlXml);
              case ".rdf": return new ReportDescriptor(ReportType.Rdf);
              case ".rdlx-master": return new ReportDescriptor(ReportType.RdlMasterXml);
              case ".rpx": return new ReportDescriptor(ReportType.RpxXml);
              default: return null;
          }
      }
  }

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Prevent Cross-Site Scripting Attacks

Prevent Cross-Site Scripting Attacks
Developers > Create Designer and Viewer Applications > Js Viewer Application > Prevent Cross-Site Scripting Attacks

Glossary Item Box

ActiveReports allows pre-processing of all links from reports. To prevent possible attacks and if you do not trust report authors, we recommend that you add processing of hyperlinks as demonstrated in the code example below:

Startup.cs Copy Code
app.UseReportViewer(settings =>
    {
        settings.UseFileStore(ReportsDirectory);
        settings.ProcessHyperlink = link =>
        {
            if (!Uri.TryCreate(link, UriKind.RelativeOrAbsolute, out Uri uri))
                return string.Empty;
            if (uri.IsAbsoluteUri)
            {
                if (uri.Scheme.ToLowerInvariant() == "javascript")
                    return string.Empty;
                return uri.AbsoluteUri;
            }
            return uri.ToString();
        };
    })

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize UI

Customize UI
Developers > Create Designer and Viewer Applications > Js Viewer Application > Customize UI

Glossary Item Box

The Js Viewer API lets developers completely overwrite the toolbar's default user interface and the viewer component's sidebar.

Setting the toolbar layout

Js Viewer has three built-in layouts for the toolbar:

  • desktop - the default layout

  • full-screen - displayed when the full-screen mode of the Viewer is on

  • mobile - displayed on narrow screens

By default, each of these layouts contains the following items.

Internal ID | Description
$navigation | Go to the 1st page, go to the previous page, page number/page total, go to the next page, go to the last page buttons
$split | Separator
$refresh | Refresh report button
$history | Go to the parent report, go back in history, go forward in history buttons
$zoom | Zoom mode drop-down
$fullscreen | Toggle full-screen mode button
$print | Print button
$singlepagemode | Switch to the single page mode button
$continuouspagemode | Switch to the continuous page mode button
$galleymode | Switch to the galley page mode button

You can use the layout method to display only specified items in the toolbar for each layout mode. Here is the example of using this approach in an Angular application for showing 'Zoom', 'Toggle Full Screen', and 'Print' items for the regular layout - 'Toggle Full Screen' and 'Print' items for the full-screen layout, and displaying 'Navigation' item only for the mobile layout.

app.component.ts Copy Code
import { Component, AfterViewInit } from '@angular/core';
import { createViewer} from '@mescius/activereportsnet-viewer';
@Component({
  selector: 'app-root',
  templateUrl: './app.component.html',
  styleUrl: './app.component.css'
})
export class AppComponent implements AfterViewInit {
  title = "app";

  ngAfterViewInit() {
    this.viewer = createViewer({
      element: '#viewer-host'
    });
    this.viewer.toolbar.desktop.layout(["$zoom", "$split", "$fullscreen", "$print"]);
    this.viewer.toolbar.fullscreen.layout(["$fullscreen", "$print"]);
    this.viewer.toolbar.mobile.layout(["$navigation"]);
    this.viewer.openReport("DemoReport.rdlx");
  }
}

Similarly, you can customize the layout of the viewer for React, Vue, and Pure JavaScript applications.

Adding and removing a toolbar item

The addItem and removeItem methods of all three layout modes of the viewer.toolbar property can be used to add and remove custom elements in the toolbar. Below is an example that inserts the 'About' button in the toolbar for Angular application. You can use the same approach in React, Vue, and ASP.NET MVC applications.

app.component.ts Copy Code
import { Component, AfterViewInit } from '@angular/core';
 import { createViewer} from '@mescius/activereportsnet-viewer';
@Component({
    selector: 'app-root',
    templateUrl: './app.component.html'
  })
  export class AppComponent implements AfterViewInit {
    title = "app";
  ngAfterViewInit() {
      this.viewer = createViewer({
        element: '#viewer-host'
      });
    var self = this;
    var options = { filename: "DemoReport" };
    var pdfExportButton = {
        key: '$pdfExportButtonKey',
        iconCssClass: 'mdi mdi-file-pdf',
        text: "Pdf",
        enabled: true,
        action: function (item) {
          console.log('Export to PDF function works here');
          self.viewer.export('Pdf', null, true, options);
        },
        onUpdate: function (arg, item) {
          console.log('Something in viewer was updated, check/update button state here');
        }
      };
     this.viewer.toolbar.desktop.addItem(pdfExportButton);
    this.viewer.openReport("DemoReport.rdlx");
    }
  }

Replacing toolbar and sidebar

Finally, the default toolbar and sidebar components of the Js Viewer can be hidden using the toolbar.toggle and sidebar.toggle methods. This approach can help if you decide to use custom UI to invoke viewer functions by using the public API. Here is an example of customizing Js Viewer toolbar and sidebar in an Angular application.

app.component.ts Copy Code
import { Component, AfterViewInit } from '@angular/core';
import { createViewer} from '@mescius/activereportsnet-viewer';
@Component({
   selector: 'app-root',
   templateUrl: './app.component.html'
 })
 export class AppComponent implements AfterViewInit {
   title = "app";
  ngAfterViewInit() {
    this.viewer = new createViewer({
       element: '#viewer-host'
     });
    this.viewer.toolbar.toggle(false);
    this.viewer.sidebar.toggle(false);
    this.viewer.openReport("DemoReport.rdlx");
   }

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize Page View

Customize Page View
Developers > Create Designer and Viewer Applications > Js Viewer Application > Customize Page View

Glossary Item Box

You can set the horizontal alignment of the report on previewing a report on JS Viewer, and also set the report to appear as a page or a web page element using the Js Viewer API.

Horizontal Alignment

The horizontal alignment of the report page relative to the viewer frame can be set to center, left, or right. The following image shows the report page aligned to left.

Customize Report Page Alignment

The code to obtain the above preview is as shown below.

index.html Copy Code
pageView: {
     horizontalAlignment: "left",
     viewMode: "standard"
          }

View Modes

View Mode as 'standard'

The report is displayed as a page.

Change the View Mode for the Report Page

The code to obtain the above preview is as shown below.

index.html Copy Code
pageView: {
     horizontalAlignment: "center",
     viewMode: "standard"
          }

View Mode as 'noPaper'

The report is displayed as an element of a web page. In this mode, the viewer's background color is set to transparent.

Change the View Mode to 'noPaper'

The code to obtain the above preview is as shown below.

index.html Copy Code
pageView: {
     horizontalAlignment: "center",
     viewMode: "noPaper"
          }

Complete Code Implementation

The following code snippet shows the complete code for customizing the page view in JS Viewer.

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                displayMode: "Continuous",
                pageView: {
                    horizontalAlignment: "center",
                    viewMode: "standard"
                }
            });

            console.dir(viewer)
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Animation

Animation
Developers > Create Designer and Viewer Applications > Js Viewer Application > Animation

Glossary Item Box

The Js Viewer (and WebViewer control) provides the API for users to add animations to charts and tables. You can enable the animation feature on charts when the chart is loaded and when the user hovers over a chart or a table.

Note: For the chart animations, you need to add the jsViewer.chart.min.js and jsVIewer.chart.min.css files from the NPM packages to your project and link them on your page.

Load Animation on Charts

Load Animation Effect in Charts

Load animation occurs when the chart first loads, or when the chart is forced to reload. To enable load animation in charts, use the following code:

index.html Copy Code
animation: {
    loadChart: {
        enabled: true
               }
           }

Hover Animation

Hover animation occurs when the user hovers the mouse over a data point.

Hover Animation on Charts

The hover animation in the case of charts scales the data point. The data point is enlarged when the user hovers the mouse over the data and is shrunk back to the original size when the user hovers away from the data point. Depending on the Tooltip template set on the chart while designing a chart, the hover labels can also be displayed over the data points.

Chart Hover Effect in Charts

Chart Hover Effect in Charts

Chart Hover Effect in Charts

Chart Hover Effect in Charts

index.html Copy Code
animation: {
    hoverChart: {
        enabled: true
                },
           }

Hover Animation on Tables

The hover animation in the case of tables highlights the table row by coloring the row background and the text on the hover.

Table Hover Effect in Charts

index.html Copy Code
animation: {
    hoverTable: {
        enabled: true,
        backgroundColor: 'LightGray',
        textColor: 'DarkGray'
                }
            }

Complete Code Implementation

The complete working code is provided below for implementing the chart load, and the chart and table hover animations.

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="jsViewer.chart.min.css" rel="stylesheet" />
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript" src="jsViewer.chart.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                displayMode: "Continuous",
                pageView: {
                    horizontalAlignment: "center",
                    viewMode: "standard" // default : noPaper
                },
                animation: {
                    hoverTable: {
                        enabled: true,
                        backgroundColor: 'LightGray',
                        textColor: 'DarkGray'
                    },
                    loadChart: {
                        enabled: true
                    },
                    hoverChart: {
                        enabled: true
                    }
                }
            });

            console.dir(viewer)
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


View Reports from Different Domains using CORS

View Reports from Different Domains using CORS
Developers > Create Designer and Viewer Applications > Js Viewer Application > View Reports from Different Domains using CORS

Glossary Item Box

Cross-Origin Resource Sharing is a technology for the web that provides async web operations to directly access reports from different domains. CORS works by adding a special header to responses from a server to the client. If a response contains the Access-Control-Allow-Origin header, then you can directly access the reports from another domain.

Cross-Origin Resource Sharing

The following viewers require CORS:

  1. Js Viewer
  2. HTMLViewer (WebViewer control)
  3. RawHTML (WebViewer control)

.NET Framework

If Server is an ASP.NET application, then following markup should be added to the web.config file:

web.config Copy Code
<customHeaders>
     <add name="Access-Control-Allow-Origin" value="http://localhost:44362" />
     <add name="Access-Control-Allow-Methods" value="GET, POST, OPTIONS" />
     <add name="Access-Control-Allow-Credentials" value="true"/>
     <add name="Access-Control-Allow-Headers" value="pragma,cache-control,expires,content-type"/>
     <add name="Access-Control-Expose-Headers" value="Content-Disposition"/>
 </customHeaders>

Replace the "http://localhost:44362" with the actual client url.

.NET Core

If Server is an ASP.NET Core application,

1. Add the following code to the Startup.ConfigureServices method in Startup.cs file:

Startup.cs Copy Code
public void ConfigureServices(IServiceCollection services)
{
    services
        .AddLogging(config =>
        {
            config.ClearProviders();
            if (Environment.GetEnvironmentVariable("ASPNETCORE_ENVIRONMENT") == Environments.Development)
            {
                config.AddConsole();
            }
        })
        .AddCors(options =>
        {
            options.AddPolicy("AllowAll", builder =>
            {
                builder.SetIsOriginAllowed(origin => new Uri(origin).Host == "XXXX")
                .AllowCredentials()
                .AllowAnyMethod()
                .AllowAnyHeader()
                .WithExposedHeaders("Content-Disposition");
            });
        })
        .AddReportViewer()
        .AddMvc(option => option.EnableEndpointRouting = false);
}

2. Add the following code to the Startup.Configure method in Startup.cs file:

Startup.cs Copy Code
public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
{
    if (env.IsDevelopment())
    {
        app.UseDeveloperExceptionPage();
    }
    app.UseCors("AllowAll");
    app.UseReportViewer(settings =>
    {
        settings.UseEmbeddedTemplates(EmbeddedReportsPrefix, Assembly.GetAssembly(app.GetType()));
        settings.UseCompression = true;
    });
    app.UseMvc();
}
Note: If you get error 404 or 500 on the report preview, please make sure that your browser supports CORS.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Predefined Export Settings

Predefined Export Settings
Developers > Create Designer and Viewer Applications > Js Viewer Application > Predefined Export Settings

Glossary Item Box

The Export dialog with the export settings is build-in into the Js Viewer UI. You can easy configure the settings for a report reader to use as predefined export settings.

Enable/Disable Exports

Not all exports are available by default, some exports are hidden. To enable/disable exports, you should use the availableExports setting as demonstrated below:

index.html Copy Code
const viewer = GrapeCity.ActiveReports.JSViewer.create({
    element: '#root',
    availableExports: ['Pdf', 'XlsxData'],
    // other properties
});

The following exports are available.

  • WYSIWYG exports
  • Pdf - available for Page/RDLX and Section reports.
  • Tiff - available for Page/RDLX and Section reports.
  • Excel exports
  • Xls - available for Page/RDLX and Section reports.
  • Xlsx - available for Page/RDLX and Section reports.
  • XlsxData - available for Page/RDLX reports. This export is hidden by default because it exports only tabular data.
  • Word exports
  • Doc - available for Page/RDLX reports.
  • Docx - available for Page/RDLX reports.
  • Rtf - available for Section reports.
  • Mht - available for Page/RDLX and Section reports.
  • Text exports
  • Csv - available for Page/RDLX reports.
  • CsvData - available for Page/RDLX reports. This export is hidden by default because it exports only tabular data.
  • TXT - available for Section reports.
  • JSON - available for Page/RDLX reports.
  • XML - available for Page/RDLX reports.
  • TextPrint - available for Page/RDLX reports. This export is hidden by default because it is a replacement for a special generic/text only printer driver from Windows.

Pre-initialized Settings

To specify export settings, you should use the defaultExportSettings as demonstrated below:

index.html Copy Code
const viewer = GrapeCity.ActiveReports.JSViewer.create({
    element: '#root',
    defaultExportSettings: {
    xls: {
      enableToggles: {
        value: true,
        visible: false
      },
      sheetName: {
        value: ‘report’
      }
    }
  },
    // other properties
});

Customizing Export Settings

Excel 2003 (.xls)

Name | Type | Description
Both rdlx and rpx
MultiSheet Boolean

Indicate whether to generate single-sheet or multi-sheet Excel document. Default for rpx is 'false' and rdlx is 'true'.
SheetName | String | The name of the Excel sheet. Default is 'Sheet'.
UseDefaultPalette Boolean

Indicate whether to export the Excel document with Excel default palette.

Remark:

Setting this value to true, the application will use the color which is in default palette and is closest to pre-defined custom color of the control's fore color and back color. Default is 'false'.
Orientation | Default|Portrait|Landscape | The orientation of the Excel document pages, to be printed in portrait or landscape.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal|Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		Size of the Excel document.
Password | String | The password required to open the Excel document.
ProtectedBy | String | User Name responsible to password protect the Excel document.
ReadOnlyRecommended Boolean

Indicate if the Excel document was saved as read only recommended. Default is 'false'.
WritePassword | String | The password required to edit the document.
FileName | String | Name of the Excel document.
Only rpx
FileFormat | Xls97Plus | The file format version the exported Excel document should support. .
AutoRowHeight | Boolean | Indicate whether to set the row heights in the Excel document according to the content in the rows. Choose carefully since it may affect pagination. Default is 'false'.
DisplayGridLines | Boolean | Indicate whether to display grid lines in the Excel document. Default is 'true'.
Pagination | Boolean | Indicate if pagination should be used for the resulting Excel document. Default is 'true'.
Only rdlx
EnableToggles | Boolean | Indicate whether to export toggles from table details or groups to collapsible rows. Default is 'false'. This setting is applicable when Pagination is set to 'false'.
LayoutMode | Galley|Paginated | The layout mode to use for the exported Excel document.
RightToLeft | Boolean | Indicate whether to show the mirror image of sheets, that is, if sheets should be exported right to left. Note that content is not mirrored. Default is 'false'.

Customizing .xls Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {

                    xls: {
                        /* only rdlx */
                        EnableToggles: { value: true },
                        LayoutMode: { value: 'Galley' },
                        RightToLeft: { value: true },
                        /* only rpx */
                        FileFormat: { value: 'Xls97Plus' },
                        AutoRowHeight: { value: true },
                        DisplayGridLines: { value: true },
                        Pagination: { value: false },
                        /* both (rdlx and rpx) */
                        MultiSheet: { value: false },
                        SheetName: { value: 'Sheet_xls' },
                        UseDefaultPalette: { value: true },
                        Orientation: { value: 'Landscape' },
                        PaperSize: { value: 'A5' },
                        Password: { value: '123456' },
                        ProtectedBy: { value: 'USER' },
                        ReadOnlyRecommended: { value: true },
                        WritePassword: { value: '123456' },
                        FileName: { value: "ar" }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Excel (.xlsx)

Name | Type | Description
Both rdlx and rpx
MultiSheet | Boolean | Indicate whether to generate single-sheet or multi-sheet Excel document. Default for rpx is 'false' and rdlx is 'true'.
SheetName | String | The name of the Excel sheet. Default is 'Sheet'.
UseDefaultPalette Boolean

Indicate whether to export the Excel document with Excel default palette.

Remark:

Setting this value to true, application will use the color which is in default palette and is closest to the predefined custom color of the control's fore color and back color. Default is 'false'.
OutputFormat | Transitional|Strict
UseCompression | Boolean | Indicate whether to use compression on exporting with Xlsx file format. Default is 'true'.
Orientation | Default|Portrait|Landscape | The orientation of the Excel document pages, to be printed in portrait or landscape.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal|Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		Size of the Excel document.
Password | String | The password required to open the Excel document.
ProtectedBy | String | User Name responsible to password protect the Excel document.
ReadOnlyRecommended | Boolean | Indicate if the Excel document was saved as read-only recommended. Default is 'false'.
WritePassword | String | The password required to edit the document.
FileName | String | The name of the Excel document.
Only rpx
AutoRowHeight | Boolean | Indicate whether to set the row heights in the Excel document according to the content in the rows. Choose carefully since it may affect pagination. Default is 'false'
DisplayGridLines | Boolean | Indicate whether to display grid lines in the Excel document. Default is 'true'.
Pagination | Boolean | Indicate if pagination should be used for resulting Excel document. Default is 'true'.
OpenXmlStandard | Transitional (default)|Strict | The level of Open XML document conformance on exporting in Xlsx file format. The Excel document generated using Strict cannot be viewed on iOS devices.
Only rdlx
EnableToggles | Boolean | Indicate whether to export toggles from table details or groups to collapsible rows. Default is 'false'.
LayoutMode | Galley|Paginated | The layout mode to use for the exported Excel document.
RightToLeft | Boolean | Show sheets right to left to show mirror image of sheets. Note that content is not mirrored. Default is 'false'.

Customizing .xlsx Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {

                  xlsx: {
                      /* only rdlx */
                      EnableToggles: { value: true },
                      LayoutMode: { value: 'Galley' },
                      RightToLeft: { value: true },
                      OutputFormat: { value: 'Strict' },
                      /* only rpx */
                      AutoRowHeight: { value: true },
                      DisplayGridLines: { value: false },
                      Pagination: { value: false },
                      OpenXmlStandard: { value: 'Strict' },
                      /* both (rdlx and rpx) */
                      MultiSheet: { value: false },
                      SheetName: { value: 'Sheet_xls' },
                      UseDefaultPalette: { value: true },
                      OutputFormat: { value: 'Strict' },
                      UseCompression: { value: false },
                      Orientation: { value: 'Landscape' },
                      PaperSize: { value: 'A5' },
                      Password: { value: '123456' },
                      ProtectedBy: { value: 'USER' },
                      ReadOnlyRecommended: { value: true },
                      WritePassword: { value: '123456' },
                      FileName: { value: "ar" }
                  },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Word 2003 (.doc)

Export to Word 2003 is available for Page and RDLX reports only.

Name | Type | Description
Author | String | The name of the author of the Word document.
BaseHref | String | The Base Url for the relative hyperlinks used in the Word document.
Generator | String | The identity of the generator of the Word document.
PageHeight | Integer | The height of the page of the Word document.
PageWidth | Integer | The width of the page of the Word document
Title | String | The title of the Word document.
FileName | String | The name of the Word document.

Customizing .doc Export Settings

index.html Copy Code
<!DOCTYPE html>
 <html lang="en">
<head>
     <meta charset="utf-8">
     <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
     <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
     <meta name="theme-color" content="#000000">
     <title>JS Viewer</title>
     <link href="jsViewer.min.css" rel="stylesheet">
     <link href="index.css" rel="stylesheet">
 </head>
<body onload="loadViewer()">
     <div style="width: 100%">
         <div id="viewerContainer"></div>
     </div>
     <script type="text/javascript" src="jsViewer.min.js"></script>
     <script type="text/javascript">
         let viewer;
        function loadViewer() {
             viewer = GrapeCity.ActiveReports.JSViewer.create({
                 element: '#viewerContainer',
                defaultExportSettings: {

                  doc: {
                      Author: { value: 'USER', visible: true },
                      BaseHref: { value: 'www.com' },
                      Generator: { value: 'Created by USER' },
                      PageHeight: { value: '10' },
                      PageWidth: { value: '5' },
                      Title: { value: 'TITLE_01' },
                      FileName: { value: 'ar_doc', visible: true }
                  },
                }
            });
             viewer.openReport("DemoReport.rdlx");
         }
     </script>
 </body>
 </html>

Word (.docx)

Export to Word is available for Page and RDLX reports only.

Name | Type | Description
Author | String | The name of the author of the Word document that appears in Word document properties.
CompanyName | String | The name of the company to appear in the Word document properties.
DocumentCompatibilityVersion | Word2007|Word2010|Word2013 (default) | The version in which the Word document should open.
DpiX | Integer | The horizontal resolution of the custom report items. Default is '96'.
DpiY | Integer | The vertical resolution of the custom report items. Default is '96'.
Title | String | The title of the Word document that appears in the Word document properties.
TOCAutoUpdate | Boolean | Indicate whether macros are inserted in the document to automatically update the TOC control on opening the Word document. Default is 'false'.
Orientation | Default|Portrait|Landscape | The orientation of the Word document.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal| Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		The size of the Word document.
Password | String | The password required to open the document.
ReadOnlyRecommended | Boolean | Indicate if the Word document was saved as read only recommended. Default is 'false'.
WritePassword | String | The password required to edit the Word document.
FileName | String | The name of the Word document.

Customizing .docx Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    docx: {
                        Author: { value: 'USER' },
                        CompanyName: { value: 'USER_COMPANY' },
                        DocumentCompatibilityVersion: { value: 'Word2010' },
                        DpiX: { value: 80 },
                        DpiY: { value: 80 },
                        Title: { value: 'TITLE_01' },
                        TOCAutoUpdate: { value: true },
                        Orientation: { value: 'Portrait' },
                        PaperSize: { value: 'B4' },
                        Password: { value: '123456' },
                        ReadOnlyRecommended: { value: true },
                        WritePassword: { value: '123456' },
                        FileName: { value: 'ar_doc' }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

PDF (.pdf)

Name | Type | Description
Both rdlx and rpx
Title | String | The title of the PDF document that appears in the document meta data.
Author | String | The name of the author of the PDF document that appears in the document meta data.
Subject | String | The subject of the PDF document displayed that appears in the document meta data.
Keywords | String | The keywords associated with the document that appear as the document meta data.
Application | String | The string value for the 'Application' field that appears in the document meta data.
EmbedFonts | Partial (default)|All|None | Indicate how the fonts used in the report should be embedded in the PDF document.
Version

Pdf12|Pdf13|Pdf14 (default)|Pdf15|
Pdf16|Pdf17|Pdf20|PdfA1a|PdfA1b|PdfA2a|
PdfA2b|PdfA2u|PdfA3a|PdfA3b|PdfA3u|PdfUA1

 The version of the PDF format the exported document is saved in.
UserPassword | String | The password required to open the document.
OwnerPassword | String | The owner password to be entered in the PDF reader that permits full access to the document regardless of the specified user permissions
Encrypt | Boolean | The value indicating whether the document is encrypted or not. Default is 'false'.
FileName | String | The name of the PDF document.
Only rpx
ConvertMetaToPng | Boolean | Indicate whether Windows metafiles are converted to PNG files in the exported PDF document. Default is 'false'.
ExportBookmarks | Boolean | Indicate whether bookmarks are exported to the PDF document. Default is 'true'.
ImageInterpolation | None (default)| Auto | The image interpolation value.
ImageQuality | Medium (default)|Lowest|Highest | The quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will affect.

Customizing .pdf Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    pdf: {
                        /*only for rpx*/
                        ConvertMetaToPng: { value: true },
                        ExportBookmarks: { value: false },
                        ImageInterpolation: { value: 'Auto' },
                        ImageQuality: { value: 'Highest' },
                        /*both (rdlx and rpx)*/
                        Title: { value: 'Document' },
                        Author: { value: 'USER' },
                        Subject: { value: 'PDF' },
                        Keywords: { value: 'PDF export' },
                        Application: { value: 'AR' },
                        EmbedFonts: { value: 'All' },
                        Version: { value: 'Pdf15' },
                        UserPassword: { value: 'user_pwd' },
                        OwnerPassword: { value: 'owner_pwd' },
                        Encrypt: { value: true },
                        FileName: { value: 'ar_pdf', visible: true }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

CSV (.csv)

Export to CSV is available for Page and RDLX reports only.

Name | Type | Description
ColumnsDelimiter | , (default)|. | The text to be placed between fields in data row.
Encoding | Unicode (UTF-8)(default)|US-ASCII|Unicode | The encoding schema for the output.
NoHeader | Boolean | Indicate whether CSV Header should be omitted. Default is 'false'.
QuotationMode | Auto quote (default)|Always quote | The quotations to be added on the exported values, whether to quote only simple values or all exported values.
QuotationSymbol | " (default)|\ | The quotation symbol or the qualifier character to put around the results.
RowsDelimiter | \r\n (default)|\\r\\n\\r\\n | The string to be placed between data rows.
DateTimeFormat | String | Default format for date time values, for example 'MM/dd/yyyy H:mm'.
NumericFormat | String | Default format for numeric values, for example '0.####'.
FileName | String | The name of the CSV document.

Customizing .csv Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    csv: {
                        ColumnsDelimiter: { value: '.' },
                        Encoding: { value: 'Unicode' },
                        NoHeader: { value: true },
                        QuotationMode: { value: "Always quote", visible: true },
                        QuotationSymbol: { value: '\'' },
                        RowsDelimiter: { value: '\\r\\n\\r\\n' },
                        DateTimeFormat: { value: 'MM/dd/yyyy H:mm' },
                        NumericFormat: { value: 'money' },
                        FileName: { value: 'ar_csv' }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

JSON (.json)

Export to JSON is available for Page and RDLX reports only.

Name | Type | Description
Formatted | Boolean | Indicate if the file name should be formatted with tabs and spaces for readability. Default is 'true'.
QuotePropertyNames | Boolean | Indicate if the property names should be enclosed in quotation marks. Default is 'false'.
FileName | String | The name of the JSON document.

Customizing .json Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    json: {
                        Formatted: { value: false },
                        QuotePropertyNames: { value: true },
                        FileName: { value: 'ar_json' }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

XML (.xml)

Export to XML is available for Page and RDLX reports only.

Name | Type | Description
Encoding | UTF-8 (default)|ASCII|Unicode | The encoding schema for the output.
FileName | String | The name of the XML document.

Customizing .xml Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    xml: {
                        Encoding: { value: 'Unicode' },
                        FileName: { value: 'ar_xml' }
                    },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Tagged Image (.tiff)

Name | Type | Description
Both rpx and rdlx
Dither | Boolean | The encoding schema for the output. Default is 'false'.
DpiX | Integer | The horizontal resolution of the rendered images. Default is '200'.
DpiY | Integer | The vertical resolution of the rendered images. Default is '196'.
FileName | String | The name of the TIFF image.
Only rpx
Pagination | Boolean | Indicate if pagination should be used, that is, whether to render the entire report as a single image or each page of the report as separate images. Default is 'true'.
CompressionScheme | Ccitt3 (default)| None | Rle | Ccitt4 | Lzw | The type of compression scheme to use for the reports rendered as TIFF images.
Only rdlx
Compression | Ccitt3 (default)| None | Rle | Ccitt4 | Lzw | The type of compression to use for the reports rendered as TIFF images.

Customizing .tiff Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                  tiff: {
                      /* only for rpx */
                      Pagination: { value: false },
                      CompressionScheme: { value: 'None' },
                      /* only for rdlx */
                      Compression: { value: 'None' },
                      /*both (rdlx and rpx)*/
                      Dither: { value: true },
                      DpiX: { value: 150 },
                      DpiY: { value: 140 },
                      FileName: { value: 'ar_tiff' }
                   },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

RTF (.rtf)

Export to RTF is available for Section Report only.

Name | Type | Description
EnableShapes | Boolean | Indicate whether to export the Shapes and Lines to RTF format. You will require Microsoft Word to view them correctly. Default is 'false'.
Pagination | Boolean | Indicate if the property names should be enclosed in quotation marks. Default is 'true'.
FileName | String | The name of the RTF document.

Customizing .rtf Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                    rtf: {
                        EnableShapes: { value: true },
                        Pagination: { value: false },
                        FileName: {
                            value: 'ar_mht'
                        }
                    },
                }
            });
            viewer.openReport("Invoice.rpx");
        }
    </script>
</body>
</html>

Web Archive (.mht)

Name | Type | Description
Both rpx and rdlx
FileName | String | The name of the MHT document.
Only rpx
BookmarkStyle Html (default) | None

Specify Html to generate bookmarks if the report has the bookmarks.
CharacterSet UnicodeUtf8 (default) | Big5 | EucJp | HzGb2312 | Ibm850 | Iso2022Jp |
Iso8859_1 | Iso8859_2 | Iso8859_5 | Iso8859_6 | Koi8r | ShiftJis | UnicodeUtf16 		The character set encoding to use for the outputted HTML pages. This property only takes effect if the IncludeHtmlHeader property is set to 'true'
CreateFramesetPage | Boolean | Indicate whether to generate a set of frames that display a page of bookmarks (if available) in the left frame and the report document in the right frame. The HTML output uses the specified filename with the extension .frame.html. Default is 'false'.
IncludeHtmlHeader | Boolean | Indicate whether to embed the HTML output in another HTML document. Otherwise, the HTML output includes the usual HTML, HEAD, and BODY elements. Default is 'true'.
IncludePageMargins | Boolean | Indicate whether to include the report margins in the HTML output. Default is 'false'.
MultiPage | Boolean | Indicate whether to generate multiple HTML pages for the document. Default is 'false'.
OutputType | DynamicHtml (default) | LegacyHtml | The type of HTML output.
Pagination | Indicate whether to use pagination in the HTML output. Default is 'true'.

RemoveVerticalSpace

 Indicate whether to remove empty vertical space from the output. Default is 'false'.
Title | The tile used in the HEAD of the HTML pages.
Only rdlx
Fragment | Indicate whether to return only the contents inside the body tags so that you can embed it on the Web page. False returns the full HTML text.
OutputTOC | Indicate if the table of contents should be included in the output if it is available in the report. Default is 'true'.
LinkTarget _blank (default) | [window_name]: _self | _parent | _top

The value for a target for hyperlinks contained inside the report. A value of

  • _blank opens a new window
  • _self opens the same window
  • _top opens the new page to load in the full body of the window
  • _parent similar to '_top' but refers to the immediate parent of a frame in case of nested frames
Mode Paginated (default) | Galley

The layout mode to use for the exported document.

  • Paginated renders each page as a section inside the HTML document with Page headers and footers.
  • Galley renders one page with a single page header and footer.

Customizing .mht Export Settings

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
         let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
                  mht: {
                      /* only for rdlx */
                      Fragment: { value: true },
                      OutputTOC: { value: false },
                      LinkTarget: { value: '_top' },
                      Mode: { value: 'Galley' },
                      /* only for rpx */
                      BookmarkStyle: { value: 'None' },
                      CharacterSet: { value: 'Big5' },
                      CreateFramesetPage: { value: true },
                      IncludeHtmlHeader: { value: false },
                      IncludePageMargins: { value: true },
                      MultiPage: { value: true },
                      OutputType: { value: 'LegacyHtml' },
                      Pagination: { value: false },
                      RemoveVerticalSpace: { value: true },
                      Title: { value: 'TITLE_01' },
                      /*both (rdlx and rpx)*/
                      FileName: { value: 'ar_mht' }
                  },
                 }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Hide Export Settings

To hide an export setting, you need to specify the visible property as 'false' along with the value property.

For example. the following code hides all the .doc export settings.

index.html Copy Code
<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <link rel='shortcut icon' type='image/x-icon' href='favicon.ico' />
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="theme-color" content="#000000">
    <title>JS Viewer</title>
    <link href="jsViewer.min.css" rel="stylesheet">
    <link href="index.css" rel="stylesheet">
</head>
<body onload="loadViewer()">
    <div style="width: 100%">
        <div id="viewerContainer"></div>
    </div>
    <script type="text/javascript" src="jsViewer.min.js"></script>
    <script type="text/javascript">
        let viewer;
        function loadViewer() {
            viewer = GrapeCity.ActiveReports.JSViewer.create({
                element: '#viewerContainer',
                defaultExportSettings: {
/*hide all doc export settings*/
                  doc: {
                      Author: { value: 'USER', visible: false },
                      BaseHref: { value: 'www.com', visible: false },
                      Generator: { value: 'Created by USER', visible: false },
                      PageHeight: { value: '10', visible: false },
                      PageWidth: { value: '5', visible: false },
                      Title: { value: 'TITLE_01', visible: false },
                      FileName: { value: 'ar_doc', visible: false }
                  },
                }
            });
            viewer.openReport("DemoReport.rdlx");
        }
    </script>
</body>
</html>

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Js Viewer API

Js Viewer API
Developers > Create Designer and Viewer Applications > Js Viewer Application > Js Viewer API

Glossary Item Box

Click here to navigate to the API documentation for using the Js Viewer component. The documentation contains Universal Module Definition (UMD) and ECMAScript Module (ESM) APIs.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ASP.NET WebViewer Application

ASP.NET WebViewer Application
See Also
Developers > Create Designer and Viewer Applications > ASP.NET WebViewer Application

Glossary Item Box

You can use the ASP.NET WebForms Viewer control with .NET Framework 4.7.2 - 4.8.1. only.

The WebViewer control allows you to quickly display reports in Web applications. Once you drop the control onto a Web Form, you can look in the Visual Studio Properties grid and select the ViewerType that you want to use.

The WebViewer control supports the following types:

  • HTMLViewer (default): Provides a scrollable view of a single page of the report at a time. Downloads only HTML and java script to the client browser. Not recommended for printable output.
  • RawHTML: Shows all pages in the report document as one continuous HTML page. Provides a static view of the entire report document, and generally printable output, although under some circumstances pagination is not preserved.
  • AcrobatReader: Returns output as a PDF document viewable in Acrobat Reader.
    Client requirements: Adobe Acrobat Reader

In a WebViewer, an RDLX report can be rendered in two modes - Paginated and Galley. Using galley mode, you can view the contents of the RDLX report in a single and scrollable page. You can set Galley mode through UI of the WebViewer or through code by setting RenderMode property to Galley.

You should use the ReportName property to specify a report for the viewer to display. Also, you must add the api/reporting/* HTTP handler to your 'web.config' file and corresponding UseReporting call to 'Global.asax' for this ViewerType to work properly.

Note: The WebViewer and JSViewer are supported only in the Integrated pipeline mode. You will get PlatformNotSupportedException on using these Viewers in Classic pipeline mode.

Use the WebViewer control

  1. In Visual Studio, create a new ASP.NET Web Forms Application.
  2. Go to Tools > NuGet Package Manager > Manage NuGet Packages for Solution..., browse the following packages, and click Install:
    • MESCIUS.ActiveReports.Web
    • MESCIUS.ActiveReports.Web.Design/MESCIUS.ActiveReports.Web.Design.VS2022 (corresponding to the Visual Studio version you are using)
  3. In Solution Explorer, right-click the project and select Add > New Item.
  4. Select WebForm and click Add.
  5. Go to the Design tab of the newly added WebForm and drag and drop the WebViewer control to the WebForm designer.
    Note: If you get an error on adding the WebViewer control, you should install or upgrade the Microsoft.CodeDom.Providers.DotNetCompilerPlatform NuGet package. See Troubleshooting for details.

Preview Code-Based Section Reports in WebViewer control

You need to update the Global.asax file as follows, assuming that you have added 'SectionReport1.cs' in the project's root:

Global.asax.cs Copy Code
public class Global : System.Web.HttpApplication
    {
        protected void Application_Start(object sender, EventArgs e)
        {
            this.UseReporting(settings =>
            {
                settings.UseFileStore(new DirectoryInfo(Server.MapPath("~")));
                settings.UseCompression = true;
                settings.UseCustomStore(GetReport);
            });
        }
        public object GetReport(string reportName = "SectionReport")
        {
            SectionReport1 rpt = new SectionReport1();
            return rpt;
        }
    }
Global.asax.vb Copy Code
Public Class _Global
    Inherits System.Web.HttpApplication
    Protected Sub Application_Start(ByVal sender As Object, ByVal e As EventArgs)
        Me.UseReporting(Sub(settings)
                            settings.UseFileStore(New DirectoryInfo(Server.MapPath("~")))
                            settings.UseCompression = True
                            settings.UseCustomStore(AddressOf GetReport)
                        End Sub)
    End Sub
    Public Function GetReport(ByVal Optional reportName As String = "SectionReport") As Object
        Dim rpt As SectionReport1 = New SectionReport1()
        Return rpt
    End Function
End Class

Note: Instead of ‘UseEmbeddedTemplates', you can use either 'UseFileStore' or 'UseCustomStore’ method calls.
  • 'UseEmbeddedTemplates' stores reports as resources in dlls.
  • 'UseFileStore' stores reports in the file system.
  • 'UseCustomStore’ allows you to store reports in any user-defined location, like a custom database or any other type of location.

See Also

Reference
WebViewer Class

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customizing the WebViewer UI

Customizing the WebViewer UI
Developers > Create Designer and Viewer Applications > ASP.NET WebViewer Application > Customizing the WebViewer UI

Glossary Item Box

You can customize the WebViewer interface using JQuery methods. WebViewer control adds JQuery library in page scripts. Use the code in this walkthrough to add a button on the toolbar and add a client side PDF export implementation.

When you complete this walkthrough you get a WebViewer that looks similar to the following at run time.

Load an ActiveReport to the Web application

  1. Create a new Visual Studio ASP.NET Web Forms application.
  2. Install MESCIUS.ActiveReports.Web package. Go to Tools > NuGet Package Manager > Manage NuGet Packages for Solution..., browse for the package and click Install.
  3. In Solution Explorer, right-click the project and select Add > New Item.
  4. Select WebForm and click Add.
  5. Go to the Design view of the newly added WebForm.aspx and drag and drop the WebViewer control to the WebForm designer. The default viewer type is HTMLViewer.
  6. Load a report in the WebViewer by setting the ReportName property.
    Note: You may load any report, section or page in the HTMLViewer viewer type of WebViewer. See ASP.NET WebViewer Application for information on loading a report.

Add the jQuery library to the Web application project

In the Source view of the WebForm.aspx file, add the following code.

Add this code after the <head> tag Copy Code
<script src="https://code.jquery.com/jquery-2.1.4.min.js"></script>

Access the WebViewer view model

The HTML WebViewer is created using the MVVM pattern that provides a view model which does not depend on the UI. The code can access the Viewer's view model and bind the custom UI to it by using well-documented properties and methods. For MVVM support, the code can use knockout.js which is the standard MVVM library for JavaScript. Knockout.js provides declarative bindings, observable objects and collections in HTML markup.

Follow the steps below to access the ViewModel.

  1. In the Source view of the WebForm.aspx file, add a <script> tag.
  2. Add the following Javascript code for document's Onload event handler and WebViewer's Loaded event handler that gets fired when the UI is rendered on the Html Page:
    Paste the code into .aspx source Copy Code
    <script>
function viewer_loaded()
  {
  };
function document_onload()
  {
  };
</script>
...
<body onload="document_onload()">
  3. Add the following Javascript code inside the viewer_loaded event handler to access WebViewer's view model:
    Paste the code into .aspx source Copy Code
    function viewer_loaded()
{
   var viewModel = GetWebViewer('ArWebViewerDiv_WebViewer1');
};
  4. Add the following Javascript code inside the document_onload event handler to bind WebViewer's Loaded event to client side viewer_loaded event:
    Paste the code into .aspx source Copy Code
    function document_onload()
{
    $('#WebViewer1').ready(viewer_loaded);
};

Add a button to the WebViewer toolbar

In the Source view of the WebForms.aspx file, add the following Javascript code inside the viewer_loaded event handler to access the WebViewer toolbar. Lets add the custom button in the toolbar - an export button and add PDF export functionality to it.

Paste the code into .aspx source Copy Code
function viewer_loaded()
{
    var viewModel = GetWebViewer('ArWebViewerDiv_WebViewer1');
    var pdfExportButton = {
        key: '$pdfExportButtonKey',
        text: 'To PDF',
    iconCssClass: 'mdi mdi-file-pdf',
        enabled: true,
        action: function (item) {
            console.log('Export to PDF function works here');
        },
        onUpdate: function (arg, item) {
            console.log(The Viewer UI was updated, check/update button state here');
        }
    };
    viewModel.toolbar.desktop.addItem(pdfExportButton);
};

The complete code for WebForm1.aspx in the Source view is as shown:

Paste the code into .aspx source Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>

<!DOCTYPE html>
<html xmlns="https://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body onload="document_onload()">
    <form id="form1" runat="server">
        <div>
            <ActiveReportsWeb:WebViewer ID="WebViewer1" runat="server" height="466px" width="667px" ReportName="AllCustomers.rdlx">
            </ActiveReportsWeb:WebViewer>
        </div>

    </form>
    <script src="https://code.jquery.com/jquery-2.1.4.min.js">
    </script>
    <script>
        function viewer_loaded() {
            var viewModel = GetWebViewer('ArWebViewerDiv_WebViewer1');

            var pdfExportButton = {
                key: '$pdfExportButtonKey',
                text: 'To PDF',
                iconCssClass: 'mdi mdi-file-pdf',
                enabled: true,
                action: function (item) {
                    console.log('Export to PDF function works here');
                },
                onUpdate: function (arg, item) {
                    console.log('Something in viewer was updated, check/update button state here');
                }
            };

            viewModel.toolbar.desktop.addItem(pdfExportButton);
        };

        function document_onload() {
            $('#WebViewer1').ready(viewer_loaded);
        };
    </script>
</body>
</html>

To remove a button from the viewer's UI

Paste the code into .aspx source Copy Code
function viewer_loaded()
{
    var viewModel = GetWebViewer('ArWebViewerDiv_WebViewer1');
    ...

    viewModel.toolbar.desktop.removeItem($newButtonKey); //(key of the button)
};

Note:

  • Replace 'WebViewer1' in the code snippets above, with the actual ID of the WebViewer control in your application.
  • When trying to get access of a WebViewer using GetWebViewer method, we should add 'ArWebViewerDiv_' prefix before the WebViewer ID.
  • In case you provide report name which contains special symbols (like backslash '\'), e.g. webViewer.ReportName="Folder\Report.rdlx", you need to update the web.config file to allow such characters. Otherwise, "Report not found" error occurs. Please see Troubleshooting on resolving this issue.
  • If your report has parameters, you can choose to set the parameters pane position to the top of the viewer using the ParametersPanelLocation to 'Top'.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize Export Settings

Customize Export Settings
Developers > Create Designer and Viewer Applications > ASP.NET WebViewer Application > Customize Export Settings

Glossary Item Box

The export settings in the export panel of WebViewer (HTML) can now be preset via code as well as from the Properties panel in the design view of the viewer. The topic provides a complete description of the properties and the code sample of each of these. Along with presetting the export panel, the export settings can also be selectively opted to be hidden from the panel.

Excel 2003 (.xls)

Name | Type | Description
Both rdlx and rpx
MultiSheet Boolean

Indicate whether to generate single-sheet or multi-sheet Excel document. Default for rpx is 'False' and rdlx is 'True'.
SheetName | String | The name of the Excel sheet. Default is 'Sheet'.
UseDefaultPalette Boolean

Indicate whether to export the Excel document with Excel default palette.

Remark:

Setting this value to 'True', the application will use the color which is in default palette and is closest to pre-defined custom color of the control's fore color and back color. Default is 'False'.
Orientation | Default|Portrait|Landscape | The orientation of the Excel document pages, to be printed in portrait or landscape.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal|Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		Size of the Excel document.
Password | String | The password required to open the Excel document.
ProtectedBy | String | User Name responsible to password protect the Excel document.
ReadOnlyRecommended Boolean

Indicate if the Excel document was saved as read only recommended. Default is 'False'.
WritePassword | String | The password required to edit the document.
FileName | String | Name of the Excel document.
Only rpx
FileFormat | Xls97Plus | The file format version the exported Excel document should support.
AutoRowHeight | Boolean | Indicate whether to set the row heights in the Excel document according to the content in the rows. Choose carefully since it may affect pagination. Default is 'False'.
DisplayGridLines | Boolean | Indicate whether to display grid lines in the Excel document. Default is 'True'.
Pagination | Boolean | Indicate if pagination should be used for the resulting Excel document. Default is 'True'.
Only rdlx
EnableToggles | Boolean | Indicate whether to export toggles from table details or groups to collapsible rows. Default is 'False'.
LayoutMode | Galley (default)|Paginated | The layout mode to use for the exported Excel document.
RightToLeft | Boolean | Indicate whether to show the mirror image of sheets, that is, if sheets should be exported right to left. Note that content is not mirrored. Default is 'False'.

Customizing .xls Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication4.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <XlsExportSettings>
                    <%-- only rdlx --%>
                    <FileFormat Value="Xls97Plus" />
                    <EnableToggles Value="True" />
                    <LayoutMode Value="Galley" />
                    <%-- only rpx --%>
                     <%-- both (rdlx and rpx) --%>
                    <MultiSheet Value="False" />
                    <SheetName Value="Sheet_xls" />
                    <UseDefaultPalette Value="True" />
                    <Orientation Value="Landscape" />
                    <PaperSize Value="A5" />
                    <AutoRowHeight Value="True" />
                    <DisplayGridLines Value="True" />
                    <Pagination Value="False" />
                    <RightToLeft Value="False" />
                    <Password Value="123456" />
                    <ProtectedBy Value="USER" />
                    <ReadOnlyRecommended Value="True" />
                    <WritePassword Value="1234567" />
                    <FileName Value="ar" />
                </XlsExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Excel (.xlsx)

Name | Type | Description
Both rdlx and rpx
MultiSheet | Boolean | Indicate whether to generate single-sheet or multi-sheet Excel document. Default for rpx is 'False' and rdlx is 'True'.
SheetName | String | The name of the Excel sheet. Default is 'Sheet'.
UseDefaultPalette Boolean

Indicate whether to export the Excel document with Excel default palette.

Remark:

Setting this value to 'True', application will use the color which is in default palette and is closest to the predefined custom color of the control's fore color and back color. Default is 'False'.
OutputFormat | Transitional|Strict
UseCompression | Boolean | Indicate whether to use compression on exporting with Xlsx file format. Default is 'True'.
Orientation | Default|Portrait|Landscape | The orientation of the Excel document pages, to be printed in portrait or landscape.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal|Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		Size of the Excel document.
Password | String | The password required to open the Excel document.
ProtectedBy | String | User Name responsible to password protect the Excel document.
ReadOnlyRecommended | Boolean | Indicate if the Excel document was saved as read-only recommended. Default is 'False'.
WritePassword | String | The password required to edit the document.
FileName | String | The name of the Excel document.
Only rpx
AutoRowHeight | Boolean | Indicate whether to set the row heights in the Excel document according to the content in the rows. Choose carefully since it may affect pagination. Default is 'False'
DisplayGridLines | Boolean | Indicate whether to display grid lines in the Excel document. Default is 'True'.
Pagination | Boolean | Indicate if pagination should be used for resulting Excel document. Default is 'True'.
OpenXmlStandard | Transitional (default)|Strict | The level of Open XML document conformance on exporting in Xlsx file format. The Excel document generated using Strict cannot be viewed on iOS devices.
Only rdlx
EnableToggles | Boolean | Indicate whether to export toggles from table details or groups to collapsible rows. Default is 'False'.
LayoutMode | Galley|Paginated | The layout mode to use for the exported Excel document.
RightToLeft | Boolean | Show sheets right to left to show mirror image of sheets. Note that content is not mirrored. Default is 'False'.

Customizing .xlsx Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <XlsxExportSettings>
                    <OutputFormat Value="OpenXmlStrict" />
                    <UseCompression Value="False" />
                    <OpenXmlStandard Value="Strict" />
                    <EnableToggles Value="True" />
                    <MultiSheet Value="True" />
                    <LayoutMode Value="Galley" />
                    <SheetName Value="Sheet_xlsx" />
                    <UseDefaultPalette Value="True" />
                    <Orientation Value="Landscape" />
                    <PaperSize Value="A5" />
                    <AutoRowHeight Value="True" />
                    <DisplayGridLines Value="False" />
                    <Pagination Value="False" />
                    <RightToLeft Value="True" />
                    <Password Value="123456" />
                    <ProtectedBy Value="USER" />
                    <ReadOnlyRecommended Value="True" />
                    <WritePassword Value="123456" />
                    <FileName Value="ar_xlsx" />
                </XlsxExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Word 2003 (.doc)

Export to Word 2003 is available for Page and RDLX reports only.

Name | Type | Description
Author | String | The name of the author of the Word document.
BaseHref | String | The Base Url for the relative hyperlinks used in the Word document.
Generator | String | The identity of the generator of the Word document.
PageHeight | Integer | The height of the page of the Word document.
PageWidth | Integer | The width of the page of the Word document
Title | String | The title of the Word document.
FileName | String | The name of the Word document.

Customizing .doc Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <DocExportSettings>
                    <Author Value="USER" Visible="True" />
                    <BaseHref Value="www.com" Visible="True" />
                    <Generator Value="Created by USER" Visible="True" />
                    <PageHeight Value="10" Visible="True" />
                    <PageWidth Value="5" Visible="True" />
                    <Title Value="TITLE_01" Visible="True"></Title>
                    <FileName Value="ar_doc" Visible="True" />
                </DocExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Word (.docx)

Export to Word is available for Page and RDLX reports only.

Name | Type | Description
Author | String | The name of the author of the Word document that appears in Word document properties.
CompanyName | String | The name of the company to appear in the Word document properties.
DocumentCompatibilityVersion | Word2007|Word2010|Word2013 (default) | The version in which the Word document should open.
DpiX | Integer | The horizontal resolution of the custom report items. Default is '96'.
DpiY | Integer | The vertical resolution of the custom report items. Default is '96'.
Title | String | The title of the Word document that appears in the Word document properties.
TOCAutoUpdate | Boolean | Indicate whether macros are inserted in the document to automatically update the TOC control on opening the Word document. Default is 'False'.
Orientation | Default|Portrait|Landscape | The orientation of the Word document.
PaperSize Default|Letter|LetterSmall|Tabloid|
Ledger|Legal| Statement|Executive|
A3|A4|A4Small|A5|B4|B5 		The size of the Word document.
Password | String | The password required to open the document.
ReadOnlyRecommended | Boolean | Indicate if the Word document was saved as read only recommended. Default is 'False'.
WritePassword | String | The password required to edit the Word document.
FileName | String | The name of the Word document.

Customizing .docx Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <DocxExportSettings>
                    <Author Value="USER" />
                    <CompanyName Value="USER_COMPANY" />
                    <DocumentCompatibilityVersion Value="Word2010" />
                    <DpiX Value="80" />
                    <DpiY Value="80" />
                    <Orientation Value="Landscape" />
                    <PaperSize Value="A5" />
                    <Password Value="123456"  />
                    <ReadOnlyRecommended Value="True" />
                    <WritePassword Value="123456" />
                    <Title Value="TITLE_01" Visible="True"></Title>
                    <TOCAutoUpdate Value="True" />
                    <FileName Value="ar_docx" />
                </DocxExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

PDF (.pdf)

Name | Type | Description
Both rdlx and rpx
Title | String | The title of the PDF document that appears in the document meta data.
Author | String | The name of the author of the PDF document that appears in the document meta data.
Subject | String | The subject of the PDF document displayed that appears in the document meta data.
Keywords | String | The keywords associated with the document that appear as the document meta data.
Application | String | The string value for the 'Application' field that appears in the document meta data.
EmbedFonts | Partial (default)|All|None | Indicate how the fonts used in the report should be embedded in the PDF document.
Version

PDF-1.2|PDF-1.3|PDF-1.4 (default)|PDF-1.5|
PDF-1.6|PDF-1.7|PDF-2.0|PDF/A-1a|PDF/A-1b|PDF/A-2a|
PDF/A-2b|PDF/A-2u|PDF/A-3a|PDF/A-3b|PDF/A-3u|PDF/UA-1

 The version of the PDF format the exported document is saved in.
UserPassword | String | The password required to open the document.
OwnerPassword | String | The owner password to be entered in the PDF reader that permits full access to the document regardless of the specified user permissions
Encrypt | Boolean | The value indicating whether the document is encrypted or not. Default is 'False'.
FileName | String | The name of the PDF document.
Only rpx
ConvertMetaToPng | Boolean | Indicate whether Windows metafiles are converted to PNG files in the exported PDF document. Default is 'False'.
ExportBookmarks | Boolean | Indicate whether bookmarks are exported to the PDF document. Default is 'True'.
ImageInterpolation | None (default)| Auto | The image interpolation value.
ImageQuality | Medium (default)|Lowest|Highest | The quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will affect.

Customizing .pdf Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <PdfExportSettings>
                    <Title Value="Document"></Title>
                    <Author Value="USER" />
                    <Subject Value="PDF1" />
                    <Keywords Value="PDF export" />
                    <Application Value="AR" />
                    <EmbedFonts Value="All" />
                    <Version Value="Pdf15" />
                    <UserPassword Value="userpsswd" />
                    <OwnerPassword Value="ownerpsswd" />
                    <Encrypt Value="True" />
                    <ConvertMetaToPng Value="True" />
                    <ExportBookmarks Value="False" />
                    <ImageInterpolation Value="Auto" />
                    <ImageQuality Value="Highest" Visible="False"/>
                    <FileName Value="ar_pdf" Visible="False"/>
                </PdfExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

CSV (.csv)

Export to CSV is available for Page and RDLX reports only.

Name | Type | Description
ColumnsDelimiter | , (default)|. | The text to be placed between fields in data row.
Encoding | Unicode (UTF-8) (default)|US-ASCII|Unicode | The encoding schema for the output.
NoHeader | Boolean | Indicate whether CSV Header should be omitted. Default is 'False'.
QuotationMode | Auto quote (default)|Always quote | The quotations to be added on the exported values, whether to quote only simple values or all exported values.
QuotationSymbol | " (default)|\ | The quotation symbol or the qualifier character to put around the results.
RowsDelimiter | \r\n (default)|\\r\\n\\r\\n | The string to be placed between data rows.
DateTimeFormat | String | Default format for date time values, for example 'MM/dd/yyyy H:mm'.
NumericFormat | String | Default format for numeric values, for example '0.####'.
FileName | String | The name of the CSV document.

Customizing .csv Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <CsvExportSettings>
                    <DateTimeFormat Value="MM/dd/yyyy H:mm" Visible="True" />
                    <NumericFormat Value="money" Visible="True" />
                    <ColumnsDelimiter Value="." Visible="True" />
                    <Encoding Value="us_ascii" Visible="True" />
                    <NoHeader Value="True" Visible="True" />
                    <QuotationSymbol Value="\'" Visible="True" />
                    <QuotationMode Value="AlwaysQuote" Visible="True" />
                    <RowsDelimiter Value="\\r\\n\\r\\n" Visible="True" />
                    <FileName Value="ar_CSV" Visible="True" />
                </CsvExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

JSON (.json)

Export to JSON is available for Page and RDLX reports only.

Name | Type | Description
Formatted | Boolean | Indicate if the file name should be formatted with tabs and spaces for readability. Default is 'True'.
QuotePropertyNames | Boolean | Indicate if the property names should be enclosed in quotation marks. Default is 'False'.
FileName | String | The name of the JSON document.

Customizing .json Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <JsonExportSettings>
                    <Formatted Value="False" Visible="True" />
                    <QuotePropertyNames Value="True" Visible="True" />
                    <FileName Value="ar_json" Visible="True" />
                </JsonExportSettings
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

XML (.xml)

Export to XML is available for Page and RDLX reports only.

Name | Type | Description
Encoding | UTF-8 (default)|ASCII|Unicode | The encoding schema for the output.
FileName | String | The name of the XML document.

Customizing .xml Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <XmlExportSettings>
                    <Encoding Value="ASCII" Visible="True" />
                    <FileName Value="ar_xml" Visible="True" />
                </XmlExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Tagged Image (.tiff)

Name | Type | Description
Both rpx and rdlx
Dither | Boolean | The encoding schema for the output. Default is 'False'.
DpiX | Integer | The horizontal resolution of the rendered images. Default is '200'.
DpiY | Integer | The vertical resolution of the rendered images. Default is '196'.
FileName | String | The name of the TIFF image.
Only rpx
Pagination | Boolean | Indicate if pagination should be used, that is, whether to render the entire report as a single image or each page of the report as separate images. Default is 'True'.
CompressionScheme | Ccitt3 (default)| None | Rle | Ccitt4 | Lzw | The type of compression scheme to use for the reports rendered as TIFF images.
Only rdlx
Compression | Ccitt3 (default)| None | Rle | Ccitt4 | Lzw | The type of compression to use for the reports rendered as TIFF images.

Customizing .tiff Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <TiffExportSettings>
                    <Compression Value="None" Visible="True" />
                    <Dither Value="True" Visible="True" />
                    <DpiX Value="150" Visible="True" />
                    <DpiY Value="140" Visible="True" />
                    <Pagination Value="False" Visible="True" />
                    <CompressionScheme Value="None" Visible="True" />
                    <FileName Value="ar_tiff" Visible="True" />
                </TiffExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

RTF (.rtf)

Export to RTF is available for Section Report only.

Name | Type | Description
EnableShapes | Boolean | Indicate whether to export the Shapes and Lines to RTF format. You will require Microsoft Word to view them correctly. Default is 'False'.
Pagination | Boolean | Indicate if the property names should be enclosed in quotation marks. Default is 'True'.
FileName | String | The name of the RTF document.

Customizing .rtf Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rpx">
                <DefaultExportSettings>
                <RtfExportSettings>
                    <EnableShapes Value="True" Visible="True"/>
                    <Pagination Value="False" Visible="True"/>
                    <FileName Value="ar_rtf" Visible="True"/>
                </RtfExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Web Archive (.mht)

Name | Type | Description
Both rpx and rdlx
FileName | String | The name of the MHT document.
Only rpx
BookmarkStyle Html (default) | None

Specify Html to generate bookmarks if the report has the bookmarks.
CharacterSet | UnicodeUtf8 (default) | Big5 | EucJp | HzGb2312 | Ibm850 | Iso2022Jp | Iso8859_1 | Iso8859_2 | Iso8859_5 | Iso8859_6 | Koi8r | ShiftJis | UnicodeUtf16 | The character set encoding to use for the outputted HTML pages. This property only takes effect if the IncludeHtmlHeader property is set to 'True'
CreateFramesetPage | Boolean | Indicate whether to generate a set of frames that display a page of bookmarks (if available) in the left frame and the report document in the right frame. The HTML output uses the specified filename with the extension .frame.html. Default is 'False'.
IncludeHtmlHeader | Boolean | Indicate whether to embed the HTML output in another HTML document. Otherwise, the HTML output includes the usual HTML, HEAD, and BODY elements. Default is 'True'.
IncludePageMargins | Boolean | Indicate whether to include the report margins in the HTML output. Default is 'False'.
MultiPage | Boolean | Indicate whether to generate multiple HTML pages for the document. Default is 'False'.
OutputType | DynamicHtml (default) | LegacyHtml | The type of HTML output.
Pagination | Boolean | Indicate whether to use pagination in the HTML output. Default is 'True'.

RemoveVerticalSpace

 Boolean Indicate whether to remove empty vertical space from the output. Default is 'False'.
Title | String | The tile used in the HEAD of the HTML pages.
Only rdlx
Fragment | Boolean | Indicate whether to return only the contents inside the body tags so that you can embed it on the Web page. 'False' returns the full HTML text.
OutputTOC | Boolean | Indicate if the table of contents should be included in the output if it is available in the report. Default is 'True'.
LinkTarget _blank (default) | [window_name]: _self | _parent | _top

The value for a target for hyperlinks contained inside the report. A value of

  • _blank opens a new window
  • _self opens the same window
  • _top opens the new page to load in the full body of the window
  • _parent similar to '_top' but refers to the immediate parent of a frame in case of nested frames
Mode Paginated (default) | Galley The layout mode to use for the exported document. Paginated renders each page as a section inside the HTML document with Page headers and footers.
Galley renders one page with a single page header and footer.

Customizing .mht Export Settings

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
                <MhtExportSettings>
                    <Fragment Value="True" Visible="True" />
                    <OutputTOC Value="False" Visible="True" />
                    <LinkTarget Value="_top" Visible="True" />
                    <Mode Value="Galley" Visible="True" />
                    <BookmarkStyle Value="None" Visible="True" />
                    <CharacterSet Value="Big5" Visible="True" />
                    <CreateFramesetPage Value="True" Visible="True" />
                    <IncludeHtmlHeader Value="False" Visible="True" />
                    <IncludePageMargins Value="True" Visible="True" />
                    <MultiPage Value="True" Visible="True" />
                    <OutputType Value="LegacyHtml" Visible="True" />
                    <Pagination Value="False" Visible="True" />
                    <RemoveVerticalSpace Value="True" Visible="True" />
                    <Title Value="TITLE_01" Visible="True"></Title>
                    <FileName Value="ar_mht" Visible="True" />
                </MhtExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Hide Export Settings

To hide an export setting, you need to specify the Visible property as 'False' along with the Value property.

For example. the following code hides all the .doc export settings.

WebForm1.aspx Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="WebApplication1.WebForm1" %>
<%@ Register Assembly="MESCIUS.ActiveReports.Web" namespace="GrapeCity.ActiveReports.Web" tagprefix="ActiveReportsWeb" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body style="height: 219px">
    <form id="form1" runat="server">
        <div>
            <activeReportsweb:WebViewer ID="WebViewer1" runat="server" Style="z-index: 102; left: 9px; position: absolute; top: 33px; height: calc(100%)" Width="95%" ReportName="Report.rdlx">
                <DefaultExportSettings>
<%--hide all doc export settings--%>
                <DocExportSettings>
                    <Author Value="USER" Visible="False" />
                    <BaseHref Value="www.com" Visible="False" />
                    <Generator Value="Created by USER" Visible="False" />
                    <PageHeight Value="10" Visible="False" />
                    <PageWidth Value="5" Visible="False" />
                    <Title Value="TITLE_01" Visible="False"></Title>
                    <FileName Value="ar_doc" Visible="False" />
                </DocExportSettings>
            </DefaultExportSettings>
            </activeReportsweb:WebViewer>
        </div>
    </form>
</body>
</html>

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Viewer Application

Blazor Viewer Application
Developers > Create Designer and Viewer Applications > Blazor Viewer Application

Glossary Item Box

A Blazor Viewer application uses the same client-server model as the JS Viewer, so all details on the server-side configurations like Custom Font Resolver or Prevent Cross-Site Scripting Attacks are relevant for a Blazor Viewer as well.

This topic describes how to create a web application that embeds Blazor Viewer.

NuGet Packages

The following packages are required to be included in the application:

  • MESCIUS.ActiveReports.Aspnetcore.Viewer
  • MESCIUS.ActiveReports.Blazor.Viewer

Initialize Blazor Viewer Component

BlazorViewer.razor Copy Code
<div class="main">
    <div id="viewerContainer">
        <ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer" DocumentLoaded="@DocumentLoaded"/>
    </div>
</div>

Create ActiveReports Blazor Viewer Server Application

Let us create a Blazor server application with ActiveReports Blazor Viewer using local report service.

Using built-in ActiveReports application template

  1. Open Microsoft Visual Studio 2022.
  2. Select ActiveReports 19 Blazor Server Application template and click Next.
    Blazor Viewer
  3. Type a name for your project and click Create.
  4. From the New Report dialog, choose a report type, and click Finish to skip the data binding at this stage or choose Next to bind the data to the report.

    The following required packages are automatically added to project:
    • MESCIUS.ActiveReports.Aspnetcore.Viewer
    • MESCIUS.ActiveReports.Blazor.Viewer
  5. Open the report from the 'Reports' folder and design.
  6. Make sure to set the Build Action property of the report to 'Embedded Resource'.
  7. Run the application.

Using Visual Studio Template

  1. Open Microsoft Visual Studio 2022.
  2. Create a new project and choose the template Blazor Server App.
    Blazor Viewer
  3. Type a name for your project (say, BlazorApp1) and click Next.
  4. Select a target framework and uncheck 'Configure for HTTPS' option, and then click Create.
  5. Add the following packages:
    • MESCIUS.ActiveReports.Aspnetcore.Viewer
    • MESCIUS.ActiveReports.Blazor.Viewer

  6. Add a new folder called 'Reports' in application's root and place the report (say, Report.rdlx) you want to display in the viewer, in this folder.

  7. Make sure to set the Build Action property of the report to 'Embedded Resource'.

  8. Add a Razor component to the folder Pages (right-click Pages > Add - Razor component). Set a name for it, for example, BlazorViewer.razor.

  9. Write the following code in BlazorViewer.razor page:
    BlazorViewer.razor Copy Code
    @page "/blazorviewer"

<h3>BlazorViewerTest</h3>
<div style="width:100%; height: 100vh">
    <GrapeCity.ActiveReports.Blazor.Viewer.ReportViewer ReportName="Report.rdlx"></GrapeCity.ActiveReports.Blazor.Viewer.ReportViewer>
</div>

@code {

}
  10. In the Shared folder > NavMenu.razor page, add the following code:
    NavMenu.razor Copy Code
    <li class="nav-item px-3">
            <NavLink class="nav-link" href="blazorviewer">
                <span class="oi oi-list-rich" aria-hidden="true"></span> Blazor Viewer
            </NavLink>
</li>
  11. In the Data folder, add ReportService.cs class:
    ReportService.cs Copy Code
    namespace BlazorApp1.Data
{
    public class ReportsService
    {
        public static string EmbeddedReportsPrefix = "BlazorApp1.Reports";
        public IEnumerable<string> GetReports()
        {
            string[] validExtensions = { ".rdl", ".rdlx", ".rdlx-master", ".rpx" };
            return GetEmbeddedReports(validExtensions);
        }

        private static string[] GetEmbeddedReports(string[] validExtensions) =>
            typeof(ReportsService).Assembly.GetManifestResourceNames()
                .Where(x => x.StartsWith(EmbeddedReportsPrefix))
                .Where(x => validExtensions.Any(x.EndsWith))
                .Select(x => x.Substring(EmbeddedReportsPrefix.Length + 1))
                .ToArray();

    }
}
  12. Update Program.cs file:
    • add following directives:
      • using GrapeCity.ActiveReports.Aspnetcore.Viewer;
      • using System.Reflection;
    • add service to the application
    • provide access to a report output from the browser by adding the UseReportViewer() middleware
      Program.cs Copy Code
      builder.Services.AddSingleton<ReportsService>();

app.UseReportViewer(settings =>
{
    settings.UseEmbeddedTemplates(ReportsService.EmbeddedReportsPrefix, Assembly.GetAssembly(typeof(ReportsService)));
});
      Note: Instead of ‘UseEmbeddedTemplates', you can use either 'UseFileStore' or 'UseReportProvider’ method calls.
      • 'UseEmbeddedTemplates' stores reports as resources in dlls.
      • 'UseFileStore' stores reports in the file system.
      • 'UseReportProvider’ allows you to store reports in any user-defined location, like a custom database or any other type of location.
  13. Run the application.

Create ActiveReports Blazor Viewer WebAssembly Application

Here we describe creating the application using built-in ActiveReports application template. This application uses remote report service.

Using built-in ActiveReports application template

  1. Open Microsoft Visual Studio 2022.
  2. Select ActiveReports 19 Blazor WebAssembly Application template and click Next.
    Blazor Viewer
  3. Type a name for your project and click Create.
  4. From the New Report dialog, choose a report type, and click Finish to skip the data binding at this stage or choose Next to bind the data to the report.

    The following required packages are automatically added to the project:

    • MESCIUS.ActiveReports.Blazor.Viewer

  5. Open the report from the 'Reports' folder and design.

  6. Make sure to set the Build Action property of the report to 'Embedded Resource'.

  7. Make sure to set multiple startup projects:

    1. In the Solution Explorer, select the solution (the top node).
    2. Choose the solution node's context (right-click) menu and then choose Properties.
    3. In the Solution Property Pages dialog box, expand the Common Properties node, and choose Startup Project.
    4. Choose the Multiple Startup Projects option and set the actions of both projects to Start.
  8. Make sure that the URL is the same in launchSettings.json file of the ReportService project and index.razor file of BlazorViewerWebAssembly project.
  9. Run the application.

Using Visual Studio Template

  1. Open Microsoft Visual Studio 2022.
  2. Create a new project and choose the template Blazor WebAssembly Standalone App.
    Blazor Viewer
  3. Type a name for your project and click Next.
  4. Select a target framework and uncheck 'Configure for HTTPS' option, and then click Create.
  5. Add the following package:
    • MESCIUS.ActiveReports.Blazor.Viewer

  6. Add a new folder called 'Reports' in application's root and place the report (say, Report.rdlx) you want to display in the viewer, in this folder.

  7. Make sure to set the Build Action property of the report to 'Embedded Resource'.

  8. Update the existing Index.razor page as follows:

    BlazorViewer.razor Copy Code
    @page "/"
@using MESCIUS.ActiveReports.Blazor.Viewer
<PageTitle>Index</PageTitle><div style="width:100%; height: 100vh">
 <ReportViewer ReportName="Report.rdlx" ReportService="@_reportService"></ReportViewer></div>
@code{
    private ReportServiceSettings _reportService = new ReportServiceSettings()
    {
        Url = "http://localhost:58865/",
    };
}
  9. Run the application.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Progressive Web Application

Progressive Web Application
Developers > Create Designer and Viewer Applications > Blazor Viewer Application > Progressive Web Application

Glossary Item Box

To create a Progressive Web Application (PWA), use our Blazor Viewer and following common Microsoft guidelines:

  • ASP.NET Core Blazor Progressive Web Application (PWA)
  • Building a Progressive Web App with Blazor

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


UI Customization

UI Customization
Developers > Create Designer and Viewer Applications > Blazor Viewer Application > UI Customization

Glossary Item Box

The Blazor Viewer API lets developers completely overwrite the toolbar's default user interface and the viewer component's sidebar.

Update layout

Update the toolbar layout to Desktop, Fullscreen, or Mobile as shown.

BlazorViewer.razor Copy Code
@page "/"
@using BlazorViewerServer.Data
@inject ReportsService ReportsService

<div class="main">

    @* Used to render list of Reports on the page *@
    <ReportList ReportsList="@reportsList" CurrentReport="@_currentReport" OnClickCallback="OnClick"></ReportList>

    <div id="viewerContainer">
        <ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer"/>
    </div>
</div>

@code{

    private ReportViewer _viewer;
    private List<string> reportsList;
    private string _currentReport = null;
    private bool _documentLoaded = false;

    protected override void OnInitialized()
    {

        reportsList = ReportsService.GetReports().ToList();
        _currentReport = reportsList.FirstOrDefault();
        //Sets the first report as the value of _currentReport
    }

    //click event handler to reinitialize the _currentReport value and open the new report in the viewer
    private async void OnClick(string res)
    {
        _currentReport = res;
        await _viewer.OpenReport(_currentReport);

    }

    private void InitializedViewer()
    {
        _viewer.Toolbar.Desktop.Layout(new string[] { "$zoom", "$split", "$fullscreen", "$split", "$print" });
        //_viewer.Toolbar.Fullscreen.Layout(new string[] { "$fullscreen", "$print" });
        //_viewer.Toolbar.Mobile.Layout(new string[] { "$navigation"});
    }
}

Add custom toolbar item

The following example adds two export buttons - pdf export and excel export.

BlazorViewer.razor Copy Code
@page "/"
@using BlazorViewerServer.Data
@inject ReportsService ReportsService

<div class="main">

    @* Used to render list of Reports on the page *@
    <ReportList ReportsList="@reportsList" CurrentReport="@_currentReport" OnClickCallback="OnClick"></ReportList>

    <div id="viewerContainer">
        <ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer" DocumentLoaded="@DocumentLoaded" Locale="ja-JP"/>
    </div>
</div>

@code{

    private ReportViewer _viewer;
    private List<string> reportsList;
    private string _currentReport = null;
    private bool _documentLoaded = false;

    protected override void OnInitialized()
    {

        reportsList = ReportsService.GetReports().ToList();
        _currentReport = reportsList.FirstOrDefault();
        //Sets the first report as the value of _currentReport
    }

    //click event handler to reinitialize the _currentReport value and open the new report in the viewer
    private async void OnClick(string res)
    {
        _currentReport = res;
        _documentLoaded = false;
        await _viewer.OpenReport(_currentReport);

    }

    private async void DocumentLoaded()
    {
        _documentLoaded = true;
    }

    private void InitializedViewer()
    {

        // To add a new item in the ToolBar (it is to be performed before the report is opened)

        _viewer.Toolbar.Desktop.AddItem(new ToolbarItem()
        {
            Text = "Export to PDF",
            Key = "$ExportPDF",
            Enabled = true,
            Title = "Export to PDF",
            Action = async () =>
            {
                // you can perform export only after the document is loaded.
                if (_documentLoaded)
                {
                    await _viewer.Export(ExportTypes.Pdf,
                    //Sets the export type
                    (uri) =>
                    {
                        //callback Function that is invoked once the export result is available (the Url is passed in the callback)
                    },
                    true, // Indicates whether the save as dialog should be shown immediately once the result is ready
                    new Dictionary<string, string>() { { "Title", "Some Title" } },
                    //Export setting for Rendering Extensions
                    () =>
                    {
                        //сhecking export cancellation
                        return false;
                    });
                }
            }
        });

        _viewer.Toolbar.Desktop.AddItem(new ToolbarItem()
        {
            Text = "Export to Xlsx",
            Key = "$ExportExcel",
            Enabled = true,
            Title = "Export to Xlsx",
            Action = async () =>
            {
                // you can perform export only after the document is loaded.
                if (_documentLoaded)
                {
                    await _viewer.Export(ExportTypes.Xlsx,
                    //Sets the export type
                    (uri) =>
                    {
                        //   callback Function that is invoked once the export result is available (the Url is passed in the callback)
                    },
                    true, // Indicates whether the save as dialog should be shown immediately once the result is ready
                    new Dictionary<string, string>() { { "Title", "Some Title" } },         //Export setting for Rendering Extensions
                    () =>
                    {
                        //сhecking export cancellation
                        return false;
                    });
                }
            }
        });

    }
}

Show/hide toolbar

In the InitializedViewer() method, use the Toggle method to set the toolbar visibility.

BlazorViewer.razor Copy Code
private void InitializedViewer()
 {
   _viewer.Toolbar.Toggle(false);
 }

Customize sidebar - Show/hide sidebar

In the InitializedViewer() method, use the Toggle method to set the sidebar visibility.

BlazorViewer.razor Copy Code
private void InitializedViewer()
 {
   _viewer.Sidebar.Toggle(false);
 }

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Viewer API

Blazor Viewer API
See Also
Developers > Create Designer and Viewer Applications > Blazor Viewer Application > Blazor Viewer API

Glossary Item Box

Show All Show All
Hide All Hide All

The page describes the Blazor Viewer API that can be used for initialization or at run time while working with the viewer.

Show RenderMode

Description: The initial render mode - 'Paginated' or 'Galley'. The default value is 'Paginated'.

Type: Enum: RenderMode

Accepted values: 'RenderMode.Paginated', 'RenderMode.Galley'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" RenderMode="RenderMode.Paginated"/>

Show DefaultExportSettings

Description: The object containing custom default export settings. Use to preset the export settings' default value and its visibility in the export panel.

Type: Dictionary<string, Dictionary<string, ExportSetting>>

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" DefaultExportSettings="@defaultExportSettings"/>
@code{
  Dictionary<string, Dictionary<string, ExportSetting>> defaultExportSettings = new Dictionary<string, Dictionary<string, ExportSetting>>()
    {
          {
              "xls", new Dictionary<string, ExportSetting>(){
                  {
                      "FileName",  new ExportSetting() {Value = "ar", Visible = true}
                  },
                  {
                      "EnableToggles",  new ExportSetting() {Value = false}
                  }
              }
          }
    };
}

Show AutoBackgroundColor

Description: When set to 'true', the background color of the viewing area is filled with the report's body color. This property is available only for RDLX Dashboard reports.

Type: bool

Accepted values: 'true', 'false'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" AutoBackgroundColor="true" />

Show AvailableExports

Description: The array of export types available via export functionality of the viewer.

Type: ExportTypes[]

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" AvailableExports="availableExportArr"/>
@code{
    ExportTypes[] availableExportArr = new ExportTypes[] {
            ExportTypes.Pdf, ExportTypes.Xlsx, ExportTypes.Xls, ExportTypes.Json
        };
}

Show Locale

Description: The locale used for displaying the viewer.

Type: String

Accepted values: 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for Chinese)

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Locale="ja-JP"/>

Show LocaleData

Description: The JSON containing the localization strings.

Type: String

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" LocaleData="@_localeData" >
@code{
    string _localeData = "{\"viewer\": {\"toolbar\": {\"refresh\": \"更新\"} } }";
}

Show LocaleUri

Description: The url of the file containing the localization strings.

Type: String

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" LocaleUri="localization.json"/>

Show PanelsLocation

Description: The location of the panels or panes (search pane, parameters pane, etc.) to the left side ('toolbar') or the right side ('sidebar') of the viewer. The default value is 'toolbar'.

Type: Enum: PanelsLocation

Accepted values: 'PanelsLocation.sidebar', 'PanelsLocation.toolbar'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" PanelsLocation="PanelsLocation.toolbar" />

Show DisplayMode

Description: Set the single page or continuous page mode for the viewer.

Type: Enum: ViewMode

Accepted values: 'ViewMode.Single', 'ViewMode.Continous'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" DisplayMode="ViewMode.Single" />

Show Action

Description: The callback that is invoked before the viewer opens the hyperlink, bookmark link, drill-down report, or toggles the report control visibility.

Type: Method (string, object[])

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Action="actionMethod" />
@code{
    public void actionMethod(string actionType , object[] actionParams)
    {
        System.Diagnostics.Debug.WriteLine(actionType);
        foreach(var obj in actionParams)
        {
            System.Diagnostics.Debug.WriteLine(obj);
        }
                }
}

Show Error

Description: The callback that is invoked when an error occurs in the process of displaying the report.

Type: Method(ErrorInfo obj)

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Error="errorMethod" />
@code{
    public void errorMethod(ErrorInfo obj)
    {
        System.Diagnostics.Debug.WriteLine("Error Message :" + obj.Message);
                   }
}

Show HideErrors

Description: Specify whether to show errors in the viewer ('false' by default).

Type: bool

Accepted values: 'true', 'false'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" HideErrors="true" />

Show InitialZoomMode

Description: Set the zoom mode at which the report should open in the viewer.

Type: String

Accepted values: 'FitToPage', 'FitToWidth'

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" InitialZoomMode="@ZoomMode.FitToWidth"/>

Show InitialZoomPercentage

Description: Set the zoom level in percentage at which the report should open in the viewer. If you set this property to, for example, 100, then the InitialZoomMode is ignored.

Type: Integer

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" InitialZoomPercentage="50"/>

The percentage value can range from 25 to 300.

Show DocumentLoaded

Description: The callback that is invoked when a document is loaded entirely on the server.

Type: Method()

Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" DocumentLoaded="DocumentLoaded"/>
@code{
    public void DocumentLoaded()
    {
        System.Diagnostics.Debug.WriteLine("Document Loaded");
    }
}

Show ReportService

Description: Set up the settings to connect the Web API.

Type: ReportServiceSettings object

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ReportService="setting" />
@{
    ReportServiceSettings setting = new ReportServiceSettings()
    {
        Url = "http:example.com/api/reporting",
        SecurityToken = "security_Token",
        OnRequest = (OnRequestInfo obj) =>
        {
            obj.Headers.Add("Authorization", "security_Token");
        }
    };
}

Show ViewerInitialized

Description: The callback that is invoked when the viewer is initialized

Type: Method()

Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer"/>
@code{
    private void InitializedViewer()
    {
        System.Diagnostics.Debug.WriteLine("Viewer is initailized now");
                 }
}

Show ReportLoaded

Description: The callback that is invoked when the viewer obtains the information about the requested report.

Type: Method(ReportInfo obj)

Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ReportLoaded="ReportLoaded"/>
@code{
    public void ReportLoaded(ReportInfo obj)
    {
        System.Diagnostics.Debug.WriteLine("The report " + obj.Name + " was successfully loaded!");
                   }
}

Show ParametersPanelSettings

Description: Set up the parameters panel or pane settings.

Type: ParametersPanelSettings object
Enums:

  • ParameterPanelLocation: Adjusts the position of the parameters pane.
    Accepted Value: 'Default', 'Top'
  • ParameterPanelOpen: Sets the parameters pane to be available by default, irrespective of whether a parameter is set to a default value or requires user input.
  • Accepted Value: 'Auto', 'Always'
Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ParametersPanelSettings="parametersPanelSetting"/>
@code{
    ParametersPanelSettings parametersPanelSetting = new ParametersPanelSettings()
    {
        Location = ParameterPanelLocation.Default,
        Open = ParameterPanelOpen.Always
               };
}

Show Sidebar

Description: The viewer's sidebar instance. Use it to toggle the sidebar visibility.

Returns: Sidebar object

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer"/>
@{
private ReportViewer _viewer;

   private void InitializedViewer()
   {
Sidebar obj = _viewer.Sidebar;
   }
}

Show Parameters

Description: The array of the {name, value} pairs that describe the values of the parameters used to run the report.

Type: Parameter[]

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Parameters="parameterArray"/>
@code{
    Parameter[] parameterArray = new Parameter[]
    {
        new Parameter
        {
            Name = "Category",
            Values = new string[]{"Business" }
        }
                  };
}

Show ReportName

Description: The name of the report to be shown by the viewer.

Type: String

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" />
@code{
private ReportViewer _viewer;
private string _currentReport = null;
    protected override void OnInitialized()
    {
reportsList = ReportsService.GetReports().ToList();
_currentReport = reportsList.FirstOrDefault();
    }
}

Show Width

Description: The width of the viewer, by default 100%.

Type: String

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Width="50%"/>

Show Height

Description: The width of the viewer, by default 100%.

Type: String

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Height="50%"/>

Show Toolbar

Description: The viewer's toolbar instance. Use it to add the custom elements or remove the existing ones.

Returns: Toolbar object

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer"/>
@{
private ReportViewer _viewer;

   private void InitializedViewer()
   {
Toolbar obj = _viewer.Toolbar;
   }
}

Show Themes

Description: Sets the theme on the viewer. The theme can be set to a custom theme or a default theme.

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" Themes="@_themes"/>
@code{
    private static readonly ColorTheme _theme = new ColorTheme()
    {
        Name = "testTheme",
        BackgroundPanels = "#fdf7f1",
        BackgroundMain = "#fdf7f1",
        Primary = "blue",
        Secondary = "green",
        Neutral = "grey",
        Error = "red",
        Warning = "yellow",
        FontFamily = "'Open Sans', 'Segoe UI', Tahoma, Geneva, Verdana, sans-serif",
        Type = ColorThemeType.light
    };

    private readonly ThemeSettings _themes = new ThemeSettings()
    {
        InitialTheme = "testTheme",
        ThemeSelector = new ThemeSelector()
        {
            Enabled = true,
            AvailableThemes = new []{ ColorThemes.ActiveReportsDark, _theme, "default" }
        }
    };

}

Show BackToParrent

Description: Makes the viewer to display the parent report of the drill-down report.

Type: Method

Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport" ViewerInitialized="InitializedViewer"/>
@code{
private ReportViewer _viewer;
    private void InitializedViewer()
    {
await  _viewer.BackToParrent();
    }
}

Show CurrentPage

Description: The currently displayed page number.

Type: Method

Returns: ValueTask<int>

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
     var currentPage = await _viewer.CurrentPage();
     System.Diagnostics.Debug.WriteLine(currentPage);
    }
}

Show Export

Description: Exports the currently displayed report.
Parameters:

  • exportType: Specifies the export format.
  • callback: Function that is invoked once the export result is available (its Url is passed in the callback)
  • saveAsDialog: Indicates whether the save as dialog should be shown immediately once the export result is ready
  • settings: The export settings are available for RenderingExtensions
  • isCancelRequested: The function is periodically called with a check to cancel the export task

Type: Method(ExportTypes, Action<string> callback = null, bool = false, Dictionary<string, string> settings = null, Func<bool> isCancelRequested = null, )

Returns: Void

Sample code Copy Code
<GrapeCity.ActiveReports.Blazor.ReportViewer @ref="_viewer" ReportName="@reportId" DocumentLoaded="
@DocumentLoaded"/>
@code {
 private ReportViewer _viewer;
 private string reportId = "User defined report columns.rdlx";
 private async void DocumentLoaded()
    {
 await _viewer.Export(ExportTypes.Pdf,
 (uri) =>
    {
    //uri to export result
    },
 false,
 new Dictionary<string, string>() { { "Title", "Some Title" } },
 () =>
    {
   //hecking export cancellation
   return false;
    }
 );
    }
}

Show GetToc

Description: Obtains the report TOC.

Type: Method

Returns: ValueTask<BookmarkInfo>

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
        var toc = await _viewer.GetToc();
    }
}

Show GoToPage

Description: Makes the viewer display the specific page. Page numeration starts with 1.
Type: int
Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
                      await _viewer.GoToPage(2);
    }
}

Show OpenReport

Description: Makes the viewer to display the parent report of the drill-down report.
Type: Method(string, Parameter[] = null)
Returns: Void

Sample code Copy Code
_viewer.OpenReport("TestReport.rdlx");
OR
    Parameter[] parameterArray = new Parameter[]
   {
        new Parameter
        {
            Name = "Category",
            Values = new string[]{"Business" }
        }
   };
_viewer.OpenReport("TestReport.rdlx", parameterArray);

Show PageCount

Description: Gets the page count of the currently displayed report.
Type: Method
Returns: ValueTask<int>

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
         var countPage = await _viewer.PageCount();
        System.Diagnostics.Debug.WriteLine(countPage);
    }
}

Show Print

Description: Prints the currently displayed report if any.
Type: Method()
Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
         await _viewer.Print();
    }
}

Show Refresh

Description: Refreshes the report preview.
Type: Method()
Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
         await _viewer.Refresh();
    }
}

Show Search

Description: Performs the search of a specific term with specific search options (match case, whole word) and invokes the specific callback with the search result passed.
Parameters:

  • searchTerm: String to find.
  • searchOptions: The object optionally defines the search options.
  • callback: The function to call after performing the search.

Type: Method(string, SearchOptions = null, Action<List<SearchResult>> = null)

Returns: Void

Sample code Copy Code
<ReportViewer @ref="_viewer" ReportName="@_currentReport"  DocumentLoaded="@DocumentLoaded"/>
@code{
private async void DocumentLoaded()
    {
        //Searching ALFKI keyword in the report
        await _viewer.Search("ALFKI", new SearchOptions()
        {
            MatchCase = true,
            WholePhrase = false
        },
        (List<SearchResult> results) =>
        {
            if (results != null && results.Count > 0)
            {
                foreach (var res in results)
                {
                    System.Diagnostics.Debug.WriteLine(res.DisplayText);
                }

            }
        });
    }

See Also

Reference
ReportViewer Class

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebDesigner Application

WebDesigner Application
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application

Glossary Item Box

The ActiveReports WebDesigner is a report designer, optimized to be embedded in web applications. It brings all functionality of ActiveReports to the web that includes such features as:

  • Intuitive drag-and-drop functionality to add controls, fields, or report items to the design surface. Intuitive and simple, even the most non-technical user can quickly design reports. The design surface is optimized with page layout, margins, snap-to-grid alignment, and built-in preview to help you create the ultimate WYSIWYG reports.
  • Support of all classic and modern data sources, including SQL, JSON, XML, CSV, and more. You can customize the designer to prevent users from creating new datasets, or to allow them access to one group of datasets (but not others).
  • Use of predefined datasets for new reports by implementing and then registering the IDataSetsService interface.
  • Support of all ActiveReports controls.
  • Full support of RPX Section Reports. This includes pre-existing reports created in the Desktop Designer or Visual Studio Integrated Designer.

WebDesigner Application is a powerful JS component, which allows creating reports directly in the Web. However, it requires a server-side component with REST API, similar to the Js Viewer and Blazor Viewer.

Create WebDesigner Application

These topics provide details on how to use WebDesigner with some popular web frameworks:

  • ASP.NET MVC Core Integration
  • Angular Application Integration
  • React Application Integration
  • VueJS Application Integration

These topics provide information on the WebDesigner configuration:

  • WebDesigner ASP.NET Middleware
  • Load Reports
  • Configure and Use Shared Data Sources
  • Save Reports
  • Preview Reports
  • Update Security Token in Designer Service
  • WebDesigner API

See Also

Role Based Authorization with JWT

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ASP.NET MVC Core Integration

ASP.NET MVC Core Integration
Developers > Create Designer and Viewer Applications > WebDesigner Application > ASP.NET MVC Core Integration

Glossary Item Box

Let us create an ASP.NET Core application using ActiveReports and render the reports in the WebDesigner.

  1. Follow the steps from step 1 to step 8 in WebDesigner ASP.NET Middleware topic to create an ASP.NET Core Web Application with ASP.NET Core Web App template and configure the ActiveReports in ASP.NET Core Middleware.
  2. Add the following additional package to the project:

    MESCIUS.ActiveReports.Aspnetcore.Viewer
  3. To use npm packages, your project must contain a package.json file. Open the Tools menu > NuGet Package Manager > Package Manager Console and run the following command in the Package Manager before installing any code dependencies:

    npm init -y
  4. Add WebDesigner to the application.
    1. Open the Tools menu > NuGet Package Manager and run the following command in the Package Manager Console to download and install the WebDesigner-related files and folders from NPM

      npm install @mescius/activereportsnet-designer

      The designer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-designer\dist
    2. Similarly, run the following command in the Package Manager Console, to download and install the Web Viewer-related files and folders from NPM

      npm install @mescius/activereportsnet-viewer

  5. Copy the following designer and viewer files/folder installed in the node_modules to the wwwroot\js and wwwroot\css folder in the application, respectively.

    • web-designer.css
    • web-designer.js
    • vendor folder
    • jsViewer.min.js
  6. In Solution Explorer, right-click 'wwwroot' folder and select Add > New Item.
  7. Select HTML Page item type, input index.html and click Add.
  8. In Solution Explorer, find newly-added index.html and modify its content as follows:
    index.html Copy Code
    <!DOCTYPE html>
<html>
<head>
    <title>ActiveReports WebDesigner</title>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="x-ua-compatible" content="ie=edge">
    <style>
        body, html {
            width: 100%;
            height: 100%;
            margin: 0;
            padding: 0
        }
        @@keyframes arwd-loader {
            from {
                color: #fff
            }
            to {
                color: #205f78
            }
        }
        .ar-web-designer {
            width: 100%;
            height: 100%
        }
        .ar-web-designer__loader {
            display: flex;
            width: 100%;
            height: 100%;
            background-color: #205f78;
            color: #fff;
            font-size: 18px;
            animation-name: arwd-loader;
            animation-duration: .62s;
            animation-timing-function: ease-in-out;
            animation-iteration-count: infinite;
            animation-direction: alternate;
            justify-content: center;
            align-items: center
        }
    </style>
    <link rel="stylesheet" href="vendor/css/fonts-googleapis.css" type="text/css" />
    <link rel="stylesheet" href="css/jsViewer.min.css" />
    <link rel="stylesheet" href="css/web-designer.css" />
</head>
<body>
    <!-- Required for the ActiveReports Web Viewer -->
    <script src="js/jsViewer.min.js"></script>
    <!-- designer-related js -->
    <script src="js/web-designer.js"></script>
    <!-- Designer root div -->
    <div id="ar-web-designer" class="ar-web-designer">
        <span class="ar-web-designer__loader"><b>AR WebDesigner</b></span>
    </div>
    <script>
       var viewer = null;
       GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            appBar: {
                openButton: { visible: true },
                saveButton: { visible: true },
                saveAsButton: { visible: true }
            },
            editor: { showGrid: false },
            data: {
                dataSets: { canModify: true },
                dataSources: { canModify: true }
            },
            preview: {
                openViewer: (options) => {
                    if (viewer) {
                        viewer.openReport(options.documentInfo.id);
                        return;
                    }
                    viewer = GrapeCity.ActiveReports.JSViewer.create({
                        element: '#' + options.element,
                        renderFormat: 'svg',
                        reportService: {
                            url: 'api/reporting',
                        },
                        reportID: options.documentInfo.id,
                        settings: {
                            zoomType: 'FitPage'
                        }
                    });
                }
            }
        });
    </script>
</body>
</html>
  9. Modify the content for the Program.cs file as follows to enable the application to use ActiveReports:
    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Aspnetcore.Designer;
DirectoryInfo ResourcesRootDirectory = new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources" + Path.DirectorySeparatorChar));
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddControllersWithViews();
builder.Services.AddReportDesigner();
var app = builder.Build();
app.UseHttpsRedirection();
if (!app.Environment.IsDevelopment())
{
    app.UseDeveloperExceptionPage();
}
// Configure middleware for ActiveReports API and handlers.
app.UseReportDesigner(config => config.UseFileStore(ResourcesRootDirectory));
app.UseReportViewer(config => config.UseFileStore(ResourcesRootDirectory));
app.UseDefaultFiles();
app.UseStaticFiles();
app.Run();
  10. Build your solution (Build > Build Solution) and run it. WebDesigner with a blank RDLX report opens in your browser.

    Web Designer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to Angular Application

Integration to Angular Application
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Integration to Angular Application

Glossary Item Box

This page explains how you can embed the ActiveReports WebDesigner component in your Angular application. To run the Angular Application Server, you will require the node.js JavaScript runtime and Angular CLI. Use the following command in the terminal or command prompt to install the Angular CLI:

npm install -g @angular/cli

  1. Open Microsoft Visual Studio 2022 and create a new Angular and ASP.NET Core project.

    Create a New Project Dialog

  2. Type a name for your project and click Next.

    Configure your New Project Dialog

  3. Select the Framework to a latest version and uncheck other options.

    Create a New Project Dialog

  4. Right-click the '.Server' project in the Solution Explorer and select Manage NuGet Packages.

  5. Add the following packages to the project.

MESCIUS.ActiveReports.Aspnetcore.Designer
MESCIUS.ActiveReports.Aspnetcore.Viewer

  6. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.

  7. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  8. Open 'Program.cs' file and update the file to include the 'using' statements at the top, and specify the resource folder and add services to container, so that the complete file looks like below.

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Web.Designer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddControllers();
builder.Services.AddReportViewer();
builder.Services.AddReportDesigner();
var app = builder.Build();
app.UseDefaultFiles();
app.UseStaticFiles();
// Configure the HTTP request pipeline.
app.UseHttpsRedirection();
app.UseAuthorization();
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseReportDesigner(config => config.UseFileStore(ResourcesRootDirectory, null, FileStoreOptions.NestedFoldersLookup));

app.MapControllers();
app.MapFallbackToFile("/index.html");
app.Run();

  9. In the '.client' project, open 'package.json' file and add the following packages under 'dependencies':

"@mescius/activereportsnet-designer": "^18.x.x",
"@mescius/activereportsnet-viewer": "^18.x.x"

  10. Open the '.client' project in the command prompt or terminal window and run the following command to install the npm packages.
    npm install

    The designer and viewer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-designer\dist and .\node_modules\@mescius\activereportsnet-viewer\dist.
  11. Expand the 'src\app' folder in the '.client' project, open 'app.component.ts' file, and replace the existing code with the following code to initialize the Designer instance.
    app.component.ts Copy Code
    import { HttpClient } from '@angular/common/http';
import { Component, OnInit, ViewEncapsulation } from '@angular/core';
import { arWebDesigner } from '@mescius/activereportsnet-designer';
import { JSViewer, createViewer } from '@mescius/activereportsnet-viewer';
import '@mescius/activereportsnet-designer/dist/web-designer.css';
import '@mescius/activereportsnet-viewer/dist/jsViewer.min.css';
@Component({
  selector: 'app-root',
  templateUrl: './app.component.html',
  styleUrl: './app.component.css',
})
export class AppComponent implements OnInit {
  forecasts: any;
  private viewer: JSViewer | null = null;
  constructor(private http: HttpClient) { }
  ngOnInit() {
    arWebDesigner.create('#ar-web-designer', {
      rpx: { enabled: true },
      appBar: { openButton: { visible: true } },
      data: { dataSets: { visible: true, canModify: true }, dataSources: { canModify: true } },
      preview: {
        openViewer: (options: any) => {
          if (this.viewer) {
            this.viewer.openReport(options.documentInfo.id);
            return;
          }
          this.viewer = createViewer({
            element: '#' + options.element,
            reportService: {
              url: 'api/reporting',
            },
            reportID: options.documentInfo.id
          });
        }
      }
    });
  }
  ngOnDestroy() {
    this.viewer?.destroy();
    arWebDesigner.destroy('#ar-web-designer');
  }
  title = 'webdesigner_angular.client';
}

  12. Open the 'app.component.html' file and replace the existing content with the following markup for hosting the element.

    app.component.html Copy Code
    <body>
  <div id="ar-web-designer" class="ar-web-designer">
    <span class="ar-web-designer__loader"><b>AR WebDesigner</b></span>
  </div>
</body>
  13. Open the 'app.component.css' file and modify its content as follows.
    app.component.css Copy Code
    @keyframes arwd-loader {
  from {
    color: #fff
  }
  to {
    color: #205f78
  }
}
.ar-web-designer {
  width: 100%;
  height: 100%
}
.ar-web-designer__loader {
  display: flex;
  width: 100%;
  height: 100%;
  background-color: #205f78;
  color: #fff;
  font-size: 18px;
  animation-name: arwd-loader;
  animation-duration: .62s;
  animation-timing-function: ease-in-out;
  animation-iteration-count: infinite;
  animation-direction: alternate;
  justify-content: center;
  align-items: center
}
  14. Open the '\src\styles.css' file and add the following content.
    styles.css Copy Code
    body, html {
  width: 100%;
  height: 100%;
  margin: 0;
  padding: 0
}

  15. Open 'proxy.conf.js' file and update the 'context' section of code as follows.

    proxy.conf.js Copy Code
    context: [
      "/weatherforecast",
      "/api"
   ],

  16. Press Ctrl + Shift + B to build your application and then press F5 to run it.
    On running the application, you can find the report placed in the resource folder by navigating to File menu > Open.

See Also

WebDesigner ASP.NET Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to React Application

Integration to React Application
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Integration to React Application

Glossary Item Box

This page explains how you can embed the ActiveReports WebDesigner component in your React application (ASP.NET Core). To run the React Application Server, you will require the node.js JavaScript runtime.

  1. Open Microsoft Visual Studio 2022 and create a new React and ASP.NET Core project.

    Create a New Project Dialog

  2. Type a name for your project and click Next.

    Configure your New Project Dialog

  3. Select the Framework to a latest version and uncheck other options.

    Create a New Project Dialog

  4. Right-click the project in the Solution Explorer and select Manage NuGet Packages.

  5. Add the following packages to the project.

    MESCIUS.ActiveReports.Aspnetcore.Designer
MESCIUS.ActiveReports.Aspnetcore.Viewer

  6. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.
  7. Make sure to set the Build Action property of the resources to 'Embedded Resource'.

  8. Open 'Program.cs' file and update the file to include the 'using' statements at the top, and specify the resource folder, and add services to container, so that the complete file looks like below.

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Web.Designer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddReportDesigner();
builder.Services.AddMvc(options => options.EnableEndpointRouting = false);
var app = builder.Build();
app.UseHttpsRedirection();
if (!app.Environment.IsDevelopment())
{
    app.UseDeveloperExceptionPage();
}
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseReportViewer(config => config.UseFileStore(ResourcesRootDirectory));
app.UseReportDesigner(config => config.UseFileStore(ResourcesRootDirectory, null, FileStoreOptions.NestedFoldersLookup));
app.UseDefaultFiles();
app.UseStaticFiles();
app.Run();

  9. In the '.client' project, open 'package.json' file and add the following packages under 'dependencies':

    "@mescius/activereportsnet-designer": "^18.x.x",
"@mescius/activereportsnet-viewer": "^18.x.x"

  10. Open the '.client' project in the command prompt or terminal window and run the following command to install the npm packages.

    npm install

    The designer and viewer files/folders will be downloaded in your current directory: .\node_modules\@mescius\activereportsnet-designer\dist and .\node_modules\@mescius\activereportsnet-viewer\dist.
  11. Expand the 'src' folder in the '.client' project, and add 'custom.css' to set the designer's host element size to 100%.
    custom.css Copy Code
    /* Provide sufficient contrast against white background */
a {
   color: #0366d6;
 }
code {
   color: #E01A76;
 }
 .ar-web-designer{
     height:100vh;
     width:100%
 }
 .ar-web-designer__loader {
     display: flex;
     width: 100%;
     height: 100%;
     background-color: #205f78;
     color: #fff;
     font-size: 18px;
     animation-name: arwd-loader;
     animation-duration: .62s;
     animation-timing-function: ease-in-out;
     animation-iteration-count: infinite;
     animation-direction: alternate;
     justify-content: center;
     align-items: center
 }
 .btn-primary {
     color: #fff;
     background-color: #1b6ec2;
     border-color: #1861ac;
 }
  12. Update the 'root' selector in existing 'App.css' as follows.
    App.css Copy Code
    #root {
    width: 100%;
}
  13. Open 'App.jsx' file and replace the existing code with the following code.
    App.jsx Copy Code
     import { Component } from 'react';
 import { arWebDesigner } from '@mescius/activereportsnet-designer';
 import { createViewer } from '@mescius/activereportsnet-viewer';
 import "@mescius/activereportsnet-designer/dist/web-designer.css";
 import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
 import './custom.css';
 import './App.css';
 export default class App extends Component {
     constructor() {
         super();
     }
     componentDidMount() {
         console.log("componentDidMount");
             arWebDesigner.create('#ar-web-designer', {
                 rpx: { enabled: true },
                 appBar: { openButton: { visible: true } },
                 data: { dataSets: { visible: true, canModify: true }, dataSources: { canModify: true } },
                 preview: {
                     openViewer: (options) => {
                         if (this.viewer) {
                             this.viewer.openReport(options.documentInfo.id);
                             return;
                         }
                         this.viewer = createViewer({
                             element: '#' + options.element,
                             reportService: {
                                 url: 'api/reporting',
                             },
                             reportID: options.documentInfo.id
                         });
                     }
                 }
             })
     }
     componentWillUnmount() {
         console.log("componentWillUnmount");
         this.viewer?.destroy();
         arWebDesigner.destroy('#ar-web-designer');
     }
     render() {
         return (
             <div id="ar-web-designer" className="ar-web-designer"><span className="ar-web-designer__loader"><b>AR WebDesigner</b></span></div>
         );
     }
 }

  14. Open 'vite.config.js' file and update the 'proxy' setting as follows.

    vite.config.js Copy Code
    proxy: {
    '/api':{
        target: 'http://localhost:5267',
        secure: false
    }
}

  15. Open 'main.jsx' file and remove import React from 'react' statement if using React 17 or higher, and the outer statements <React.StrictMode> and </React.StrictMode> to disable strict mode. The final main.jsx is as shown.

    main.jsx Copy Code
    import ReactDOM from 'react-dom/client'
import App from './App.jsx'
import './index.css'
ReactDOM.createRoot(document.getElementById('root')).render(
    <App />
)

  16. Press Ctrl + Shift + B to build your application and then press F5 to run it.

See Also

WebDesigner ASP.NET Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Integration to VueJS Application

Integration to VueJS Application
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Integration to VueJS Application

Glossary Item Box

This page explains how you can embed the ActiveReports WebDesigner component in your VueJS application (ASP.NET Core). We will use Vue and ASP.NET Core with the JavaScript template to create the application.

  1. Open Microsoft Visual Studio 2022 and create a new project, Vue and ASP.NET Core with JavaScript.

    Create a New Project Dialog

  2. Type a name for your project and click Create.

    Configure your New Project Dialog

  3. In the Solution Explorer, right-click the '.Server' project and select Manage NuGet Packages.

  4. Add the following packages to the project.

MESCIUS.ActiveReports.Aspnetcore.Designer
MESCIUS.ActiveReports.Aspnetcore.Viewer

  5. Add a new folder called 'resources' in the application's root and place the report you want to display in viewer, in this folder. The report you create in WebDesigner, on saving, is saved at this location.

  6. Update the 'Program.cs' file as follows:

    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Web.Designer;
var builder = WebApplication.CreateBuilder(args);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddReportDesigner();
builder.Services.AddMvc(options => options.EnableEndpointRouting = false);
var app = builder.Build();
app.UseHttpsRedirection();
if (!app.Environment.IsDevelopment())
{
    app.UseDeveloperExceptionPage();
}
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
app.UseReportViewer(config => config.UseFileStore(ResourcesRootDirectory));
app.UseReportDesigner(config => config.UseFileStore(ResourcesRootDirectory, null, FileStoreOptions.NestedFoldersLookup));
app.UseDefaultFiles();
app.UseStaticFiles();
app.Run();

  7. Open the 'package.json' file and add the following packages for ActiveReports' Viewer and Designer under 'Dependencies':

"@mescius/activereportsnet-designer": "^18.x.x",
"@mescius/activereportsnet-viewer": "^18.x.x"

  8. Add a new 'WebDesigner.vue' file in the src\components folder and add the following code.
    WebDesigner.vue Copy Code
    <template>
    <div id="ar-web-designer"></div>
</template>
<script>
    import { arWebDesigner } from '@mescius/activereportsnet-designer';
    import { createViewer } from '@mescius/activereportsnet-viewer';
    export default {
        mounted() {
            let serverUrl = 'https://localhost:7226';
            arWebDesigner.create('#ar-web-designer', {
                rpx: { enabled: true },
                appBar: { openButton: { visible: true } },
                editor: { showGrid: false },
                data: { dataSets: { visible: true, canModify: true }, dataSources: { canModify: true } },
                server: {
                    url: serverUrl + '/api'
                },
                preview: {
                    openViewer: (options) => {
                        if (this.viewer) {
                            this.viewer.openReport(options.documentInfo.id);
                            return;
                        }
                        this.viewer = createViewer({
                            element: '#' + options.element,
                            renderFormat: 'svg',
                            reportService: {
                                url: serverUrl + '/api/reporting',
                            },
                            reportID: options.documentInfo.id
                        });
                    }
                }
            });
        }
    }
</script>
<style>
    #ar-web-designer {
        height: 100vh;
        float: right;
        width: 100%;
    }
</style>

  9. Open 'App.vue' inside the src folder and replace its default content with the following code.

    App.vue Copy Code
    <template>
    <div class="main">
        <WebDesigner />
    </div>
</template>
<script>
    import "@mescius/activereportsnet-viewer/dist/jsViewer.min.css";
    import "@mescius/activereportsnet-designer/dist/web-designer.css";
    import WebDesigner from './components/WebDesigner.vue';
    export default {
        name: 'app',
        components: {
            WebDesigner
        },
        methods: {
        }
    }
</script>
<style>
    .main {
        width: 100%;
        overflow-x: hidden
    }
</style>

  10. To disable browser launch, set the 'launchBrowser' to 'false' in 'launchSettings.json' (in .Server project\Properties).

  11. Press Ctrl + Shift + B to build your project and then press F5 to run it.

See Also

WebDesigner ASP.NET Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Load Reports

Load Reports
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Load Reports

Glossary Item Box

By default, the instance of the WebDesigner component displays the blank RDLX report.
To load an existing report in the designer, say a section report, use the code as shown below.

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    document: {
        id: 'RPX/Invoice.rpx',
        type: { platform: 'rpx', type: 'report' },
    }

To open a report kept on your machine, you need to enable the 'Open' button as shown below.

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     appBar: {
         openButton: { visible: true }
}

See Also

WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure and Use Shared Data Sources

Configure and Use Shared Data Sources
Developers > Create Designer and Viewer Applications > WebDesigner Application > Configure and Use Shared Data Sources

Glossary Item Box

The shared data sources contain connection properties that allow binding multiple reports to same data. The shared data sources can be created and edited only in Standalone Designer or VS Integrated Designer. In WebDesigner, however, you can only reference an existing data source.

Following are the scenarios for using shared data sources in web designer:

  • a developer wants to prevent the connection string information from being displayed on the client-side
  • a developer wants users to be able to select a pre-defined data sources/data sets

The shared data source solves this problem because the report definition contains only the reference to the data source definition, which is resolved on the server-side when a report is previewed.

Note: Shared data sources are disabled by default.

You must create a shared data source (.rdsx) in Standalone Designer or Visual Studio Integrated Designer. See Work with Local Shared Data Sources for more information.

The steps to use shared data sources are elaborated below. You should first create a WebDesigner-integrated ASP.NET MVC Core application. See the following pages for the information on:

  • WebDesigner ASP.NET Middleware
  • ASP.NET MVC Core Integration

We will be adding shared data source functionality in an already available sample: WebDesigner_MVC_Core.

  1. Open the WebDesigner_MVC_Core application.
  2. Place the shared reference, a .rdsx file, in the ‘resources’ folder of the project.
  3. In the script.js where web designer is initialized, use shared property to enable shared data sources. The complete script.js code is as shown.
    script.js Copy Code
    import { arWebDesigner } from './web-designer.js';
import { createViewer } from './jsViewer.min.js';
let viewer = null;
let serverUrl = getServerUrl();
function getServerUrl() {
    let baseUrl = 'api';
    let virtualDirName = document.getElementById('virtualDir');
    if (virtualDirName && virtualDirName.href != window.location.origin + '/') {
        return virtualDirName.href + baseUrl;
    }
    return baseUrl;
}
arWebDesigner.create('#ar-web-designer', {
    server: {
        url: serverUrl
    },
    appBar: { openButton: { visible: true } },
    data: { dataSets: { canModify: true }, dataSources: { canModify: true, shared: { enabled: true } } },
    preview: {
        openViewer: (options) => {
            if (viewer) {
                viewer.theme = options.theme;
                viewer.openReport(options.documentInfo.id);
                return;
            }
            viewer = createViewer({
                element: '#' + options.element,
                reportService: {
                    url: 'api/reporting',
                },
                reportID: options.documentInfo.id,
                settings: {
                    zoomType: 'FitPage',
                },
                theme: options.theme
            });
        }
    }
});

    Implement the IReportStore

  4. Create 'Implementation' folder.

  5. To the 'Implementation' folder, add ‘ReportStore.cs’ class which will contain implementation for IReportStore.

    ReportStore.cs Copy Code
    using System.Xml.Linq;
using System.Xml.XPath;
using GrapeCity.ActiveReports.Rendering.Tools;
using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports.Web.Viewer;
using ReportNotFoundException = GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException;
namespace WebDesigner_MVC_Core.Implementation;
public class ReportStore : IReportStore
{
    private static readonly string[] ReportExtensions =
    {
        ".rdl",
        ".rdlx",
        ".rdlx-master",
        ".rpx"
    };
    private readonly Dictionary<string, byte[]> _tempStorage = new Dictionary<string, byte[]>();
    private readonly DirectoryInfo _rootDirectory;
    public ReportStore (DirectoryInfo rootDirectory)
    {
        _rootDirectory = rootDirectory;
    }
    public ReportDescriptor GetReportDescriptor(string reportId)
    {
        if (_tempStorage.ContainsKey(reportId))
            return new ReportDescriptor(GetReportTypeByExtension(Path.GetExtension(reportId)));

        var fileInfo = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));
        return new ReportDescriptor(GetReportTypeByExtension(fileInfo.Extension));
    }
    public Stream LoadReport(string reportId)
    {
        if (_tempStorage.TryGetValue(reportId, out var tempReport))
            return new MemoryStream(tempReport);

        var file = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));

        if (!file.Exists)
            throw new ReportNotFoundException(reportId);
        return file.OpenRead();
    }
    public string SaveReport(ReportType reportType, string reportId, Stream reportData, SaveSettings settings = SaveSettings.None)
    {
        if ((settings & SaveSettings.IsTemporary) != 0)
        {
            var tempName = Guid.NewGuid() + GetReportExtension(reportType);
            _tempStorage.Add(tempName, reportData.ToArray());
            return tempName;
        }

        var reportFullPath = Path.Combine(_rootDirectory.FullName, reportId);
        using var fileStream = new FileStream(reportFullPath, FileMode.Create, FileAccess.Write);
        reportData.CopyTo(fileStream);
        return reportId;
    }
    public string UpdateReport(ReportType reportType, string reportId, Stream reportData)
    {
        return SaveReport(reportType, reportId, reportData);
    }
    public ReportInfo[] ListReports()
    {
        var reports = _rootDirectory
            .EnumerateFiles("*.*")
            .Where(fileInfo => ReportExtensions.Any(ext =>
                fileInfo.Extension.EndsWith(ext, StringComparison.InvariantCultureIgnoreCase)))
            .Select(fileInfo =>
            {
                var reportType = GetReportTypeByExtension(fileInfo.Extension);
                var rdlSubType = reportType != ReportType.RpxXml ? GetRdlSubType(fileInfo) : null;
                return new ReportInfo()
                {
                    Id = fileInfo.Name,
                    Name = fileInfo.Name,
                    ReportType = reportType,
                    RdlSubtype = rdlSubType
                };
            }).ToArray();
        return reports;
    }
    private RdlSubtype? GetRdlSubType(FileInfo report)
    {
        XElement rootElement = GetReportContent(report.FullName);

        if (HasElement(rootElement, "Body/ReportItems/FixedPage"))
            return RdlSubtype.FixedPage;

        if (HasElement(rootElement, "ReportSections/ReportSection"))
        {
            var customProps = GetElement(rootElement, "CustomProperties")?.Nodes();
            if (customProps?.Count() > 0 && customProps.Where(node => node.ToString().Contains("Dashboard")).Any())
                return RdlSubtype.Dashboard;
        }
        return RdlSubtype.MultiSection;
    }
    private static XElement GetElement(XElement rootElement, string path)
    {
        var xPath = string.Join("/", path.Split('/').Select(e => $"*[local-name() = '{e}']"));
        var targetElement = rootElement.XPathSelectElement(xPath);
        return targetElement;
    }
    private static bool HasElement(XElement rootElement, string valuePath)
    {
        var targetElement = GetElement(rootElement, valuePath);
        return targetElement != null;
    }
    private static XElement GetReportContent(string reportName)
    {
        try
        {
            using (var streamReader = File.OpenText(reportName))
            {
                return XElement.Load(streamReader);
            }
        }
        catch
        {
            throw new InvalidReportContentException($"Report '{reportName}' XML content is invalid");
        }
    }

    private static ReportType GetReportTypeByExtension(string extension)
    {
        switch (extension)
        {
            case ".rdl":
            case ".rdlx":
                return ReportType.RdlXml;
            case ".rdlx-master":
                return ReportType.RdlMasterXml;
            case ".rpx":
                return ReportType.RpxXml;
            default:
                throw new ArgumentOutOfRangeException(nameof(extension), extension, null);
        }
    }
    private static string GetReportExtension(ReportType type)
    {
        return type switch
        {
            ReportType.RdlXml => ".rdlx",
            ReportType.RdlMasterXml => ".rdlx-master",
            ReportType.RpxXml => ".rpx",
            _ => throw new ArgumentOutOfRangeException(nameof(type), type, null)
        };
    }
    public void DeleteReport(string reportId)
    {
        if (_tempStorage.ContainsKey(reportId))
        {
            _tempStorage.Remove(reportId);
            return;
        }
        var file = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));
        if(file.Exists)
            file.Delete();;
    }
}

    Implement the IResourceRepositoryProvider

  6. Add 'ResourceProvider.cs' to the 'Implementation' folder to add implementation for IResourceRepositoryProvider.

    ResourceProvider.cs Copy Code
    using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Rendering.Tools;
using GrapeCity.ActiveReports.Web.Designer;
namespace WebDesigner_MVC_Core.Implementation
{
    public class ResourceProvider : IResourceRepositoryProvider
    {
        private const string SharedDataSourceExtension = ".rdsx";
        private readonly DirectoryInfo _rootDirectory;
        public ResourceProvider(DirectoryInfo rootDirectory)
        {
            _rootDirectory = rootDirectory;
        }
        public Stream GetResource(ResourceInfo resource)
        {
            string absolutePath = Path.Combine(_rootDirectory.FullName, resource.Name);
            var file = new FileInfo(absolutePath);
            if (!file.Exists)
                return null;
            return file.OpenRead();
        }
        public ResourceDescriptor[] ListResources(ResourceType resourceType)
        {
            if (resourceType == ResourceType.SharedDataSource)
            {
                var sharedDataSources = _rootDirectory
                    .EnumerateFiles("*" + SharedDataSourceExtension).Select(fileInfo =>
                    {
                        using var stream = fileInfo.OpenRead();
                        var dataSource = DataSourceTools.LoadSharedDataSource(stream);
                        return new SharedDataSourceResourceDescriptor()
                        {
                            Id = fileInfo.Name,
                            Name = fileInfo.Name,
                            Type = dataSource.ConnectionProperties.DataProvider
                        };
                    }).ToArray();
                return sharedDataSources;
            }
            return Enumerable.Empty<ResourceDescriptor>().ToArray();
        }
        public ResourceDescriptor[] DescribeResources(ResourceInfo[] resources)
        {
            return Enumerable.Empty<ResourceDescriptor>().ToArray();
        }
    }
}

    Configure and register services

  7. Open Startup.cs and update the file as shown below. The Startup.cs file does the following:

    1. configures the services and middleware used by the application
    2. registers the 'IReportStore' and 'IResourceRepositoryProvider' as singleton services
    3. adds reporting and designer services
    4. sets the path to the ActiveReports.config file where the SQLite provider is added
    5. configures the reporting and designer middleware
    6. serves static files
      Startup.cs Copy Code
      using System.IO;
using Microsoft.AspNetCore.Builder;
using Microsoft.AspNetCore.Hosting;
using Microsoft.Extensions.Hosting;
using Microsoft.Extensions.Configuration;
using Microsoft.Extensions.DependencyInjection;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Aspnetcore.Designer;
using System.Text;
using GrapeCity.ActiveReports.Web.Designer;
using WebDesigner_MVC_Core.Implementation;
using System;
namespace WebDesignerMvcCore
{
    public class Startup
    {
        private static readonly DirectoryInfo ResourcesRootDirectory =
            new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources" + Path.DirectorySeparatorChar));
        public Startup(IConfiguration configuration)
        {
            Configuration = configuration;
        }
        public IConfiguration Configuration { get; }
        // This method gets called by the runtime. Use this method to add services to the container.
        public void ConfigureServices(IServiceCollection services)
        {
            Encoding.RegisterProvider(CodePagesEncodingProvider.Instance);
            services
                .AddReportViewer()
                .AddReportDesigner()
                .AddSingleton<IReportStore>(new ReportStore(ResourcesRootDirectory))
                .AddSingleton<IResourceRepositoryProvider>(new ResourceProvider(ResourcesRootDirectory))
                .AddMvc(options => options.EnableEndpointRouting = false)
                .AddJsonOptions(options => options.JsonSerializerOptions.PropertyNamingPolicy = null);
        }
        // This method gets called by the runtime. Use this method to configure the HTTP request pipeline.

            public void Configure(IApplicationBuilder app,
            IWebHostEnvironment env,
            IReportStore reportStore,
            IResourceRepositoryProvider resourceProvider
            )
        {
            if (env.IsDevelopment())
            {
                app.UseDeveloperExceptionPage();
            }
            var pathToConfig = Path.Combine(Environment.CurrentDirectory, "ActiveReports.config");
            app.UseReportDesigner(config =>
            {
                config.UseReportsProvider(reportStore);
                config.UseResourcesProvider(resourceProvider);
                config.UseConfig(pathToConfig);
            });
            app.UseFileServer();
            app.UseMvc();
        }
    }
}

  8. Add 'ActiveReports.config' with following content.

    ActiveReports.config Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <Data>
            <Extension Name="SQLITE" Type="System.Data.SQLite.SQLiteFactory, System.Data.SQLite"
                       DisplayName="Sqlite Provider" />
        </Data>
    </Extensions>
</Configuration>
  9. Run the application.

  10. Go to the Data tab to add the data source.

  11. In the Data Source Editor dialog, select ‘Shared Reference’ as Provider and then the ‘.rdsx’ file as Reference. Shared Reference configuration in Data Source Editor dialog

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Save Reports

Save Reports
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Save Reports

Glossary Item Box

The WebDesigner component contains the Save and Save As buttons on the toolbar. However, they are hidden by default.

To enable the Save and SaveAs buttons of Web Designer's toolbar, you should use the code as shown in the example below:

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            appBar: {
                saveButton: { visible: true },
                saveAsButton: { visible: true }
            }
        });

The process of saving the report is performed by the UseReportDesigner() middleware:

Startup.cs Copy Code
app.UseReportDesigner(config => config.UseFileStore(ResourcesRootDirectory, false));

The report is saved in the Resources folder of the project.

The saving process is performed on the server side and you can customize it with the custom store. See the WebDesigner_CustomStore sample for details.

See Also

WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Preview Reports

Preview Reports
See Also
Developers > Create Designer and Viewer Applications > WebDesigner Application > Preview Reports

Glossary Item Box

You need to configure JS Viewer for preview since preview is part of JS Viewer and not WebDesigner. See JS Viewer Applications for more details.

It is suggested to use our JS Viewer in SVG mode; although this makes previewing slower, you see almost WYSIWYG preview. To configure JS Viewer for preview, use the following code.

Copy Code
var viewer = null;
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    preview: {
                openViewer: (options) => {
                    if (viewer) {
                        viewer.openReport(options.documentInfo.id);
                        return;
                    }
                    viewer = GrapeCity.ActiveReports.JSViewer.create({
                        element: '#' + options.element,
                        renderFormat: 'svg',
                        reportService: {
                            url: 'api/reporting',
                        },
                        reportID: options.documentInfo.id,
                        settings: {
                            zoomType: 'FitPage'
                        }
                    });
                }
            }
       });

See Also

WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Update Security Token in Designer Service

Update Security Token in Designer Service
Developers > Create Designer and Viewer Applications > WebDesigner Application > Update Security Token in Designer Service

Glossary Item Box

A site with the WebDesigner application may require to specify tokens. In this case, you should use the code as demonstrated below:

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        onBeforeRequest: (init) => alert(init.credentials),
    }

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


WebDesigner API

WebDesigner API
Developers > Create Designer and Viewer Applications > WebDesigner Application > WebDesigner API

Glossary Item Box

ActiveReports provides a rich API for integrating the web designer components into your web application. Use this API to embed the WebDesigner component in your project. It lets you create, design, and save reports with added capabilities that include - defining the locale for the designer, customizing the default settings of the report items, managing the Data and Properties tab, modifying the application info, and much more. You will find the usage examples for ES, UMD, and TypeScript modules.

export const arWebDesigner

The main object exported by WebDesigner ES Module is described below.

create()

Description: Renders the WebDesigner component to the <div> element with given selector using the specified DesignerSettings object.

Parameter (Type):

selector: string
settings: DesignerSettings

Return Type: Promise<DesignerAPI>

Required: Yes

Sample Code Copy Code
import { arWebDesigner } from './web-designer.js';
import { createViewer } from './jsViewer.min.js';
let viewer = null;
arWebDesigner.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } },
    data: { dataSets: { canModify: true }, dataSources: { canModify: true } },
    preview: {
        openViewer: (options) => {
            if (viewer) {
                viewer.openReport(options.documentInfo.id);
                return;
            }
            viewer = createViewer({
                element: '#' + options.element,
                reportService: {
                    url: 'api/reporting',
                },
                reportID: options.documentInfo.id,
                settings: {
                    zoomType: 'FitPage'
                }
            });
        }
    }
});

apiof()

Description: Returns the DesignerAPI of the previously created instance of the WebDesigner component.

Parameter (Type):

instanceId: string

Return Type: DesignerAPI

Required: Yes

Sample code Copy Code
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');

addLanguage()

Description: Adds language resources for all instances of WebDesigner.

Parameter (Type):

lng: string
resources: ResourceBundle[]

Return Type: void

Required: Yes

Sample code Copy Code
import { arWebDesigner } from './web-designer.js';
arWebDesigner.addLanguage('en', [
             {
                "ns": "app",
                "lng": "en",
                "resources": {
                        "textAppTitleCompact": "",
                }
            },
]);

destroy()

Description: Destroys Designer application.

Parameter (Type):

selector: string (the Designer container selector)
instanceId: string (use only if Designer was created using DesignerSettings.instanceId)

Return Type: void

Required: Yes

Sample Code Copy Code
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#container-1', { ...settings, instanceId: 'instance-1' });
arWebDesigner.destroy('#container-1', 'instance-1');

export const ColorThemes: ColorThemesType

Description: The predefined themes object exported by WebDesigner ESM module.

ColorThemesType

Description: The type of predefined themes object, with keys as theme names.

Copy Code
type ColorThemesType = {
 default: ColorTheme,
 defaultDark: ColorTheme,
 darkOled: ColorTheme,
 highContrast: ColorTheme,
 highContrastDark: ColorTheme
};

Shades

Description: Type Shades definition.

Copy Code
 type Shades = {
  veryLight: string;
  light: string;
  lighter: string;
  lightMedium: string;
  medium: string;
  base: string;
  darkMedium: string;
  darker: string;
  dark: string;
  veryDark: string;
};

Color

Description: Type Color definition.

Copy Code
type Color = string | Shades;

ColorTheme

Description: Type ColorTheme definition.

Copy Code
 export type ColorTheme = {
  name: string;
  type: 'light' | 'dark';
  backgroundMain: string;
  backgroundPanels: string;
  primary: Color;
  secondary: Color;
  neutral: Color;
  error: Color;
  warning: Color;
  fontFamily: string
};

GlobalDesignerAPI

Type of GrapeCity.ActiveReports.Designer object exported by the web-designer.js module.

create()

Description: Renders the WebDesigner component to the <div> element with given selector using the specified DesignerSettings object.

Parameter (Type):

selector: string
settings: DesignerSettings

Return Type: Promise<DesignerAPI>

Required: Yes

Sample Code Copy Code
<html>
 <head>
     <title>ActiveReports WebDesigner</title>
     <meta charset="utf-8">
     <meta name="viewport" content="width=device-width, initial-scale=1">
     <meta http-equiv="x-ua-compatible" content="ie=edge">
    <link rel="stylesheet" href="vendor/css/bootstrap.css" />
    <link rel="stylesheet" href="vendor/css/fonts-googleapis.css" type="text/css">
    <!-- Optional. Resets the browser's default style, which allows the web designer to occupy the whole page. -->
     <style>
         html, body { width: 100%; height: 100%; margin: 0; padding: 0 }
     </style>
    <!-- Required for the ActiveReports Web Viewer -->
     <link rel="stylesheet" href="jsViewer.min.css" />
     <link rel="stylesheet" href="web-designer.css" />
 </head>
 <body>
     <!-- Required for the ActiveReports Web Viewer -->
     <script src="jsViewer.min.js"></script>
     <script src="web-designer.js"></script>
    <!-- Important! Designer requires a defined size or a container to fill -->
     <div id="ar-web-designer" style="width: 100%; height: 100%;"></div>
    <script>
         /* Required for the ActiveReports Web Viewer */
         var viewer = null;
         GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
             appBar: {

                 saveButton: { visible: false },
                 saveAsButton: { visible: false }
             },
            data: {
                 dataSets: { canModify: true },
                 dataSources: { canModify: true }
             },
            server: {
                 url: 'api'
             },
            preview: {
                 /* Required for the ActiveReports Web Viewer */
                 openViewer: ({ element, documentInfo: { id: documentId } }) => {
                     if (viewer) {
                         viewer.openReport(documentId);
                         return;
                     }
                    viewer = GrapeCity.ActiveReports.JSViewer.create({
                         element: '#' + element,
                         reportID: documentId,
                         renderFormat: options.preferredFormat || 'html',
                         reportService: {
                             url: 'api/reporting'
                         },
                         settings: {
                             zoomType: 'FitPage'
                         }
                     });
                 }
             }
         });
     </script>
 </body>
 </html>

apiof()

Description: Returns the DesignerAPI of the previously created instance of the WebDesigner component.

Parameter (Type):

instanceId: string

Return Type: DesignerAPI | undefined

Required: Yes

Sample code Copy Code
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');

addLanguage()

Description: Adds language resources for all instances of WebDesigner.

Parameter (Type):

lng: string
resources: ResourceBundle[]

Return Type: void

Required: Yes

Sample code Copy Code
GrapeCity.ActiveReports.Designer.addLanguage('en', [
            {
                "ns": "app",
                "lng": "en",
                "resources": {
                        "textAppTitleCompact": "",
                }
            },
]);

destroy()

Description: Destroys Designer application.

Parameter (Type):

selector: string (the Designer container selector)
instanceId: string (Optional, use only if Designer was created using DesignerSettings.instanceId)

Return Type: void

Required: Yes

Sample Code with instanceId Copy Code
GrapeCity.ActiveReports.Designer.create('#container-1', { settings, instanceId: 'instance-1' });
GrapeCity.ActiveReports.Designer.destroy('#container-1', 'instance-1');
Sample Code without instanceId Copy Code
GrapeCity.ActiveReports.Designer.create('#container-2', settings);
GrapeCity.ActiveReports.Designer.destroy('#container-2');

ResourceBundle

Localization resource for a specific locale.

lng

Description: Refers to the bundle language.

Return Type: string

Required: Yes

ns

Description: Refers to the bundle namespace.

Return Type: string

Required: Yes

resources

Description: Refers to the localization resources.

Return Type: Record<string, any>

Required: Yes

DesignerAPI

Type of object returned by functions from the GlobalDesignerAPI.

app

Description: Contains application-related information.

Required: Yes

about

Description: Contains documentation links and application-related information.

Required: Yes

»help

Description: Contains designer-related documentation links.

Required: Yes

general

Description: Refers to the general documentation.

Return Type: { text: string; url: string }

Required: Yes

transformation

Description: Refers to the report items transformation information.

Return Type: { text (optional): string; url: string }

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     rpx: { enabled: true },
     appBar: { openButton: { visible: true } }
             }).then((designer) => {
     designer.app.about.help.general.text = 'help text';
     designer.app.about.help.general.url = 'http://myurl';
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rpx: { enabled: true },
     appBar: { openButton: { visible: true } }
             }).then((designer) => {
     designer.app.about.help.general.text = 'help text';
     designer.app.about.help.general.url = 'http://myurl';
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rpx: { enabled: true },
     appBar: { openButton: { visible: true } }
             }).then((designer: DesignerAPI) => {
     designer.app.about.help.general.text = 'help text';
     designer.app.about.help.general.url = 'http://myurl';
});

»applicationTitle

Description: Specifies the application title for the WebDesigner component.

Return Type: string

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.applicationTitle = 'Title text';
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.applicationTitle = 'Title text';
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer: DesignerAPI) => {
    designer.app.about.applicationTitle = 'Title text';
});

»applicationTitleCompact

Description: Specifies the compact version of the application title for the WebDesigner component.

Return Type: string

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.applicationTitleCompact = 'Example text';
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.applicationTitleCompact = 'Example text';
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer: DesignerAPI) => {
    designer.app.about.applicationTitleCompact = 'Example text';
});

»applicationVersion

Description: Specifies the application version for the WebDesigner component.

Return Type: string

Required: Yes

»coreVersion

Description: Refers to the WebDesigner Core version an application is based on.

Return Type: string

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.coreVersion = '1.2.3';
    designer.app.about.applicationVersion = '3.4.5';
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.about.coreVersion = '1.2.3';
    designer.app.about.applicationVersion = '3.4.5';
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer: DesignerAPI) => {
    designer.app.about.coreVersion = '1.2.3';
    designer.app.about.applicationVersion = '3.4.5';
});

focus()

Description: Returns focus to the WebDesigner component. Focus may be lost when plugged-in or external components are opened or closed. Returning focus is essential to continue using designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.focus();
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer) => {
    designer.app.focus();
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: { enabled: true },
    appBar: { openButton: { visible: true } }
}).then((designer: DesignerAPI) => {
    designer.app.focus();
});

editor()

Description: Information about the availability of common actions with the report and selected items

Required: Yes

The flags indicate whether the editor is able to perform the corresponding action. The Return Type of these flags is 'boolean'. The actions indicate action associated with the flag. The Return Type of these actions is 'void'.

Flag | Action
canUndo() | undo()
canRedo() | Redo()
canCut() | Cut()
canPaste() | Paste()
canCopy() | Copy()
canDelete() | Delete()

See the following section for sample usage of setting flags and the corresponding action to take.

»canUndo()/undo()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canUndo) designer.app.editor.undo();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canUndo) designer.app.editor.undo();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canUndo) designer.app.editor.undo();

»canRedo()/redo()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canRedo) designer.app.editor.redo();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canRedo) designer.app.editor.redo();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canRedo) designer.app.editor.redo();

»canCut()/cut()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canCut) designer.app.editor.cut();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canCut) designer.app.editor.cut();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canCut) designer.app.editor.cut();

»canCopy()/copy()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canCopy) designer.app.editor.copy();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canCopy) designer.app.editor.copy();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canCopy) designer.app.editor.copy();

»canPaste()/paste()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canPaste) designer.app.editor.paste();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canPaste) designer.app.editor.paste();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canPaste) designer.app.editor.paste();

»canDelete()/delete()

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
if (designer.app.editor.canDelete) designer.app.editor.delete();
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canDelete) designer.app.editor.delete();
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
if (designer.app.editor.canDelete) designer.app.editor.delete();

panels

Description: Contains access to the menu and sidebar panels. It contains following objects: menu and sidebar.

menu

Description: Menu API.

»open()

Parameter Type:
id: string

Return Type: void

»pin

Return Type: void

»close

Return Type: void

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
designer.app.panels.menu.open('document-explorer');
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.app.panels.menu.open('document-explorer');
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.app.panels.menu.open('document-explorer');

sidebar

Description: Sidebar API.

»open()

Parameter Type:
id: string

Return Type: void

»close

Return Type: void

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
designer.app.panels.sidebar.open('propsTab');
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.app.panels.sidebar.open('propsTab');
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.app.panels.sidebar.open('propsTab');

documents

Description: This object includes functions allowing you to create, open, save reports, and more.

Return Type: DocumentsAPI

Required: Yes

notifications

Description: Allows to utilize the built-in notifications system in the WebDesigner component.

Return Type: NotificationsAPI

Required: Yes

DocumentsAPI

API to create, edit, open, or save report, to fetch information on unsaved reports, and more.

hasUnsavedChanges()

Description: Indicates whether the report has unsaved changes.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
const val = designer.documents.hasUnsavedChanges(); if (val) console.log('Currently edited report has unsaved changes.');
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
const val = designer.documents.hasUnsavedChanges();
if (val) console.log('Currently edited report has unsaved changes.');
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
const val = designer.documents.hasUnsavedChanges();
if (val) console.log('Currently edited report has unsaved changes.');

isNew()

Description: Indicates whether the report was saved at least once.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
const val = designer.documents.isNew();
if (val) console.log('New document');
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
const val = designer.documents.isNew();
if (val) console.log('New document');
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
const val = designer.documents.isNew();
if (val) console.log('New document');

info()

Description: Returns information about the currently edited report in the WebDesigner component.

Return Type: CurrentDocumentInfo

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
var reportInfo = designer.documents.info();
console.log(`Report "${reportInfo.name}" is currently edited.`);
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
var reportInfo = designer.documents.info();
console.log(`Report "${reportInfo.name}" is currently edited.`);
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
var reportInfo = designer.documents.info();
console.log(`Report "${reportInfo.name}" is currently edited.`);

create()

Description: Creates a new report to be edited in the WebDesigner component using the specified CreateReportOptions object.

Parameter (Type):

  1. options (optional): CreateDocumentOptions

Return Type: Promise<CreateDocumentInfo>

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
const designer = arWebDesigner.apiOf('ar-web-designer');
var reportInfo = designer.documents.create().then(function() {
console.log('An empty RDLX report is created.'); });
UMD Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
var reportInfo = designer.documents.create().then(function() {
console.log('An empty RDLX report is created.');
});
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
var reportInfo = designer.documents.create().then(() => {
console.log('An empty RDLX report is created.');
});

open()

Description: Shows the Open Report dialog box in the WebDesigner component.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.open();
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.open();
TypeScript Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.open();

openById()

Description: Opens an existing report to be edited in the WebDesigner component with a specified id. Optionally, you can pass the report name and content, else it will be loaded from the server.

Parameter (Type):

id: string
type: SupportedDocumentType
name (optional): string
content (optional): any

Return Type: Promise<OpenDocumentInfo>

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.openById('MyReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}).then(() => {
console.log('An existing report "MyReport.rdlx" is opened.');
});
var reportContent = { Width: '6.5in', ReportSections: [{ Type: 'Continuous' as any, Name: 'ContinuousSection1', Body: { ReportItems: [ {Type: 'textbox', Name: 'TextBox1', Width: '5in', Height: '1in' } ] }}]};
api.documents.openById('NewReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}, 'NewReport', reportContent).then(() => {
console.log('New report with one textbox created and opened.');
});
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.openById('MyReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}).then(() => {
console.log('An existing report "MyReport.rdlx" is opened.');
});
var reportContent = { Width: '6.5in', ReportSections: [{ Type: 'Continuous' as any, Name: 'ContinuousSection1', Body: { ReportItems: [ {Type: 'textbox', Name: 'TextBox1', Width: '5in', Height: '1in' } ] }}]};
api.documents.openById('NewReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}, 'NewReport', reportContent).then(() => {
console.log('New report with one textbox created and opened.');
});
TypeScript Module
const api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.openById('MyReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}).then(() => {
console.log('An existing report "MyReport.rdlx" is opened.');
});
const reportContent = { Width: '6.5in', ReportSections: [{ Type: 'Continuous' as any, Name: 'ContinuousSection1', Body: { ReportItems: [ {Type: 'textbox', Name: 'TextBox1', Width: '5in', Height: '1in' } ] }}]};
api.documents.openById('NewReport.rdlx', { platform: 'rdlx', type: 'report', subType: 'msl'}, 'NewReport', reportContent).then(() => {
console.log('New report with one textbox created and opened.');
});

save()

Description: Saves the currently edited report in the WebDesigner component. If the report is new, then the Save As dialog box will be opened.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.save();
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.save();
TypeScript Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.save();

saveAs()

Description: Opens the Save As dialog box in the WebDesigner component.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.saveAs();
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveAs();
TypeScript Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveAs();

saveById()

Description: Saves the currently edited report in the WebDesigner component using the specified id.

Parameter (Type):

  • id (optional): string
  • name (optional): string

Return Type: Promise<SaveDocumentInfo>

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.saveById('MyReport.rdlx');
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveById('MyReport.rdlx');
TypeScript Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveById('MyReport.rdlx');

saveByName()

Description: Saves the report currently edited in the WebDesigner component using the specified name.

Parameter (Type):

name: string

Return Type: Promise<SaveDocumentInfo>

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
var api = arWebDesigner.apiOf('designer-id');
api.documents.saveByName('MyReport.rdlx');
UMD Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveByName('MyReport.rdlx');
TypeScript Module
var api = GrapeCity.ActiveReports.Designer.apiOf('designer-id');
api.documents.saveByName('MyReport.rdlx');

RpxReportDocumentType

Section Report (.rpx) document type.

type RpxReportDocumentType = { platform: 'rpx'; type: 'report' };

RdlxFplReportDocumentType

Page Report (.rdlx) document type.

type RdlxFplReportDocumentType = { platform: 'rdlx'; type: 'report'; subType: 'fpl'};

RdlxMslReportDocumentType

RDLX Multi-Section (.rdlx) document type.

type RdlxMslReportDocumentType = { platform: 'rdlx'; type: 'report'; subType: 'msl'};

RdlxMslDashboardDocumentType

RDLX Dashboard (.rdlx) document type.

type RdlxMslDashboardDocumentType = { platform: 'rdlx'; type: 'report'; subType: 'msl'};

RdlxMasterMultiReportDocumentType

RDLX report (.rdlx) document type.

type RdlxMasterMultiReportDocumentType = { platform: 'rdlx'; type: 'master'; subType: 'msl'};

RdlxReportDocumentType

RDLX, Page, RDLX Multi-Section, or RDLX Dashboard document type.

Acceptable Values Copy Code
RdlxFplReportDocumentType | RdlxMslReportDocumentType | RdlxMslDashboardDocumentType | RdlxMasterMultiReportDocumentType;

SupportedDocumentType

Type of documents supported by the WebDesigner component.

Acceptable Values Copy Code
RpxReportDocumentType | RdlxReportDocumentType;

NotificationsAPI

API for notifications for a user action, error, warning, and more.

send()

Description: Sends a notification of the specified level, including caption and content.

Parameter (Type):

level: 'info' | 'warning' | 'error'
caption: string
content (optional): string
  1. level refers to notification level. It determines the color and icons used for the notifications.
  2. caption refers to notification caption. It is displayed when the notification pops up by default, then used as a title in Notification Details view.
  3. content refers to notification content. It is only visible when the Notification Details are open.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.send('info', 'My information');
});
UMD Module
const designer = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.send('info', 'My information');
});
TypeScript Module
var designer: DesignerAPI = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
 }).then((api: DesignerAPI) => {
     api.notifications.send('info', 'My information');
});

info()

Description: Sends a general notification, which can be used to notify when any user-initiated action is complete.

Parameter (Type):

caption: string
text (optional): string

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.info('Notification');
});
UMD Module
const designer = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.info('Notification');
});
TypeScript Module
var designer: DesignerAPI = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
 }).then((api: DesignerAPI) => {
     api.notifications.info('Notification');
});

error()

Description: Sends an error notification.

Parameter (Type):

caption: string
errorText (optional): string

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.error("Application error");
});
UMD Module
const designer = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.error("Application error");
});
TypeScript Module
var designer: DesignerAPI = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api: DesignerAPI) => {
     api.notifications.error("Application error");
});

warning()

Description: Sends a warning notification.

Parameter (Type):

caption: string
warningText (optional): string

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.warning('Warning');
});
UMD Module
const designer = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.warning('Warning');
});
TypeScript Module
var designer: DesignerAPI = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api: DesignerAPI) => {
     api.notifications.warning('Warning');
});

dismissAll()

Description: Dismisses all notifications.

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.dismissAll();
});
UMD Module
const designer = GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     storeUnsavedReport: false
}).then((api) => {
     api.notifications.dismissAll();
});
TypeScript Module
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.notifications.dismissAll();

Font

label

Return Type: string

Required: Yes

value

Return Type: string

Required: Yes

FontHeader

header

Return Type: string

Required: Yes

Locale

Locale object from date-fns.

code

Return Type: string

Required: Yes

formatDistance

Return Type: any

Required: Yes

formatRelative

Return Type: any

Required: Yes

localize

Return Type: any

Required: Yes

formatLong

Return Type: any

Required: Yes

match

Return Type: any

Required: Yes

options

Return Type: any

Required: Optional

MenuCssIcon

type

Return Type: css

Required: Yes

class

Return Type: string

Required: Yes

MenuIcon

Menu Icon of the WebDesigner component.

Acceptable Value Copy Code
MenuCssIcon

DesignerSettings

API for designer settings.

instanceId

Description: Indicates the unique identifier for the WebDesigner instance. This is required if there are multiple instances of the WebDesigner on the same page.

Return Type: string

Required: Yes

Sample Code Copy Code
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');

language

Description: Specifies the language to use for the WebDesigner component. If language is not specified, browser preferences are used. The localization is available in following languages:
'en-US’, ‘ja-JP’, and 'zh-CN'. The default value for this property is set to 'en-US'.

Sample Code Copy Code
designerSettings.language = 'zh-CN';

Return Type: string

Required: Yes

fonts

Description: Specifies the list of fonts displayed in the Font editors all over the WebDesigner component, and supports plain strings, label-value pairs, headers, and splitters. If fonts are not specified explicitly here, the default list of fonts is used:
'Arial', 'Arial Black', 'Comic Sans MS', 'Courier New', 'Geneva', 'Georgia', 'Helvetica', 'Impact', 'Lucida Console', 'Meiryo', 'Meiryo UI', 'MingLiU', 'MingLiU-ExtB', 'MS Gothic', 'MS Mincho', 'MS PGothic', 'MS PMincho', 'MS Song', 'MS UI Gothic', 'NSimSun', 'Osaka', 'PMingLiU', 'PMingLiU-ExtB', 'SimSun', 'SimSun-ExtB', 'Song', 'Tahoma', 'Times New Roman', 'Trebuchet MS', 'Verdana', and 'Yu Gothic'.

Return Type: (string | Font | FontHeader)[]

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   fonts: [{ header: 'Questionable Choice' }, { label: 'Pretty Font', value: 'Comic Sans MS' }, { header: '' }, 'Arial', 'Courier New', 'Times New Roman']
});

themes

initialTheme

Description: The initial theme to be applied.

Return Type: string

themeSelector

enabled

Description: Shows Theme Picker in the UI, which lists all the available themes. By default, this setting is set to 'true'.

Return Type: boolean

availableThemes

Description: An array of available themes that can be picked by the user. You can use either built-in theme names, or pass the theme object. These themes can be either built-in themes or custom ones. The default theme can be set from any of these: default, defaultDark, darkOled, highContrast, highContrastDark.

Return Type: (string | ColorTheme)[];

ES Module
//using custom theme
arWebDesigner.create('#ar-web-designer', {
    themes: {
        initialTheme: 'testTheme',
        themeSelector: {
            enabled: false,
            availableThemes: ['Default', theme]
        }
    },
});
//using built-in themes
arWebDesigner.create('#ar-web-designer', {
    themes: {
      initialTheme: 'defaultDark',
      themeSelector: { enabled: false }
    },
});
UMD Module
//using custom theme
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'testTheme',
        themeSelector: {
            enabled: false,
            availableThemes: ['Default', theme]
        }
    }
});
//using built-in themes
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'defaultDark',
        themeSelector: { enabled: false }
    },
});
TypeScript Module
//using custom theme
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'testTheme',
        themeSelector: {
            enabled: false,
            availableThemes: ['Default', theme]
        }
    }
});
//using built-in themes
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'defaultDark',
        themeSelector: { enabled: false }
    },
});

dateFormats

Description: Specifies the list of supported date formats. See Microsoft Documentation for more information on custom date and time format strings.

Return Type: string[]

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   dateFormats = ['yyyy/MM/dd HH:mm:ss', 'yyyy/MM/dd', 'HH:mm:ss', 'tt hh:mm:ss']
});

dateTimeLocale

Description: Specifies the additional locale object from 'date-fns'. Pass it, if you use other locale except en, fr, ja, ko, pl, zhCN, and zhTW.

Return Type: Locale

Required: Optional

imageMimeTypes

Description: Specifies the list of supported image mime-types in the WebDesigner component.

Return Type: string[]

Required: Yes

units

Description: Specifies the default measurement units for the WebDesigner component. The default unit is inches.

Return Type: 'in' | 'cm'

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  storeUserPreferences: false,
  units: 'cm'
});

lockLayout

Description: By default, the lockLayout property is set to 'false'. However, when you set this property to 'true', it enables you to modify the properties of existing report items. Operations that can modify the report layout structure are not possible, such as adding a new report item or deleting an existing one, and others.

Return Type: boolean

Required: Yes

Sample Code Copy Code
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.lockLayout = 'true';

document

Return Type: { id: string; type: SupportedDocumentType; };

Required: Optional

storeUnsavedReport

Description: By default, the storeUnsavedReport property is set to 'true'. In this case, the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed. However, if the storeUnsavedReport property is set to 'false', the aforementioned functionality is not available.

Return Type: boolean

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            storeUnsavedReport: false
});

storeUserPreferences

Description: By default, the storeUserPreferences property is set to 'true'. In this case, the user preferences will be saved to the browser storage. However, if the storeUnsavedReport property is set to 'false', the aforementioned functionality is not available.

Return Type: boolean

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            storeUserPreferences: false
});

disableFocusTimer

Description: By default, the disableFocusTimer property is set to 'true'. In such a case, the focused elements (like buttons) are highlighted only for a short period after the Tab key is pressed. However, if the disableFocusTimer property is set to 'false', the focus highlighting timer on the buttons is disabled for better accessibility.

Return Type: boolean

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            disableFocusTimer: true
});

disableSystemClipboard

Description: Disable the usage of the system clipboard. Copy-paste between designer instances will work only in the same browser in the same domain.

Return Type: boolean

Required: Yes

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
            disableSystemClipboard: true
});

filterProperties

Description: Return filtered array of descriptors in the order in which descriptors should be rearranged.

Parameter (Type):

descriptors: PropertyDescriptor[]

item: Record<string, any>

platform: 'rdlx' | 'rpx'

Return Type: PropertyDescriptor[]

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  filterProperties: (descriptors, item, platform) => platform === 'rpx' ? [] : descriptors,
});

editor

Description: Settings available for the Editors in the Web designer component.

Required: Yes

rulers

Description: Specifies the ruler settings for the WebDesigner component.

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   editor: {
       rulers: {
           visible: true
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       rulers: {
           visible: true
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       rulers: {
           visible: true
       }
   }
});

»visible

Description: Specifies whether rulers need to be shown in the WebDesigner component, by default.

Return Type: boolean

Required: Yes

»snapStep

Description: Specifies the snapStep value. The default value is { in: 0.25, cm: 0.5 }.

Return Type: { in: number; cm: number; };

Required: Optional

gridSize

Description: Specifies the size of the Grid Size editor. By default, 'in' is used.

Return Type: string

Required: Optional

showGrid

Description: Specifies whether the grids must be shown or hidden in the WebDesigner component.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   editor: {
       showGrid: true
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       showGrid: true
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       showGrid: true
   }
});

snapToGrid

Description: Specifies whether to display the Snap To Grid option in the WebDesigner component. The default value is 'false'.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   editor: {
       snapToGrid: true
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       snapToGrid: true
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       snapToGrid: true
   }
});

snapToGuides

Description: Specifies whether to display the Snap To Guides option in the WebDesigner component. The default value is 'false'.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer',
   editor: {
       snapToGuides: true
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       snapToGuides: true
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   editor: {
       snapToGuides: true
   }
});

appBar

Description: Settings for the App bar in the WebDesigner component.

Required: Yes

visible

Description: Specifies whether the App bar needs to be shown in the WebDesigner component. By default, the App bar is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        appBar: {
            visible: false
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        appBar: {
            visible: false
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        appBar: {
            visible: false
        }
});

saveButton

Description: Settings for the Save button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Save button needs to be shown in the WebDesigner component. By default, the Save button is hidden.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        saveButton: { visible: true }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        saveButton: { visible: true }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        saveButton: { visible: true }
    }
});

saveAsButton

Description: Settings for the Save As button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the SaveAs button needs to be shown in the WebDesigner component. By default, the SaveAs button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        appBar: {
           saveAsButton: { visible: false}
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        saveAsButton: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        saveAsButton: { visible: false}
    }
});

openButton

Description: Settings for the Open button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Open button needs to be shown in the WebDesigner component. By default, the Open button is hidden.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        openButton: { visible: true }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        openButton: { visible: true }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        openButton: { visible: true }
    }
});

insertTab

Description: Settings for the Insert tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Insert tab needs to be shown in the Web Designer's application bar. The ToolBox and Insert tab are interchangeable. By default, this tab is hidden.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        insertTab: { visible: false}
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        insertTab: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        insertTab: { visible: false}
    }
});

homeTab

Description: Settings for the Home tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Home tab needs to be shown in the Web Designer's application bar. By default, this tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        homeTab: { visible: false}
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        homeTab: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        homeTab: { visible: false}
    }
});

contextActionsTab

Description: Settings for the Context Actions tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Context Actions tab needs to be shown in the Web Designer's application bar. By default, the this tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        contextActionsTab: { visible: false}
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        contextActionsTab: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        contextActionsTab: { visible: false}
    }
});

parametersTab

Description: Settings for the Parameters tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Parameters tab needs to be shown in the Web Designer's application bar. By default, this tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        parametersTab: { visible: false}
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        parametersTab: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        parametersTab: { visible: false}
    }
});

scriptTab

Description: Settings for the Script tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Script tab needs to be shown in the Web Designer's application bar. By default, this tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    appBar: {
        scriptTab: { visible: false}
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        scriptTab: { visible: false}
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    appBar: {
        scriptTab: { visible: false}
    }
});

toolBar

Description: Settings for the Tool Bar.

Required: Yes

visible

Description: Specifies whether the Tool Bar needs to be shown in the WebDesigner component. By default, the Tool Bar is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    toolBar: { visible: false }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    toolBar: { visible: false }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    toolBar: { visible: false }
});

menu

Description: Settings for menus in the WebDesigner component.

Required: Yes

visible

Description: Specifies whether the Main menu needs to be shown in the WebDesigner component. By default, the Main menu is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    menu: { visible: false }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    menu: { visible: false }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    menu: { visible: false }
});

logo

Description: Specifies the settings for the custom logo in the menu of WebDesigner.

Required: Optional

»visible

Description: Specifies whether the logo needs to be shown in the menu.

Required: Optional

Return Type: Boolean

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    menu: {
        logo: { visible: false }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   menu: {
       logo: { visible: false }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   menu: {
       logo: { visible: false }
   }
});

»custom

Description: Sets a custom logo to be shown in the menu.

Required: Optional

Return Type: MenuIcon

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    menu: {
       logo: { custom: { type: 'css', class: 'my-custom-icon' }; }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   menu: {
      logo: { custom: { type: 'css', class: 'my-custom-icon' }; }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   menu: {
      logo: { custom: { type: 'css', class: 'my-custom-icon' }; }
   }
});

toolBox

Description: Settings for the ToolBox menu in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the ToolBox menu needs to be shown in the WebDesigner component. By default, the ToolBox menu is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
  menu: {
     toolBox: { visible: false }
  }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
     toolBox: { visible: false }
  }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
     toolBox: { visible: false }
  }
});

documentExplorer

Description: Settings for the Document Explorer button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Document Explorer button needs to be shown in the WebDesigner component. By default, the Document Explorer button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
  menu: {
      documentExplorer: { visible: false }
  }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
      documentExplorer: { visible: false }
  }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
      documentExplorer: { visible: false }
  }
});

groupEditor

Description: Settings for the Group Editor button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Group Editor button needs to be shown in the WebDesigner component. By default, the Group Editor button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    menu: {
       groupEditor: { visible: false }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   menu: {
      groupEditor: { visible: false }
  }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    menu: {
      groupEditor: { visible: false }
   }
});

layerEditor

Description: Settings for the Layer Editor button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Layer Editor button needs to be shown in the WebDesigner component. By default, the Layer Editor button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
  menu: {
      layerEditor: { visible: false }
  }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
      layerEditor: { visible: false }
  }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  menu: {
      layerEditor: { visible: false }
  }
});

statusBar

Description: Settings for the Status bar in the WebDesigner component.

Required: Yes

visible

Description: Specifies whether the Status Bar needs to be shown. By default, the Status Bar is visible.

Return Type: boolean

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
  statusBar: { visible: false }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
  statusBar: { visible: false }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   statusBar: { visible: false }
});

toggleUnitsButton

Description: Settings for the Units button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Units button needs to be shown in the WebDesigner component. By default, the Units button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    statusBar: {
        toggleUnitsButton: {
            visible: true
           }
       }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        toggleUnitsButton: {
            visible: true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        toggleUnitsButton: {
            visible: true
        }
    }
});

toggleGridButton

Description: Settings for the Show Grid button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Show Grid button needs to be shown in the WebDesigner component. By default, the Show Grid button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    statusBar: {
        toggleGridButton: {
            visible: true
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        toggleGridButton: {
            visible: true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        toggleGridButton: {
            visible: true
        }
    }
});

gridSizeEditor

Description: Settings for the Grid Size editor in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Grid Size editor needs to be shown in the WebDesigner component. By default, the Grid Size editor is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    statusBar: {
        gridSizeEditor: {
            visible: true
           }
       }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        gridSizeEditor: {
            visible: true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        gridSizeEditor: {
            visible: true
        }
    }
});

rulersButton

Description: Settings for the Show Rulers button in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Show Rulers button needs to be shown in the WebDesigner component. By default, the Show Rulers button is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    statusBar: {
        rulersButton: {
            visible: true
           }
       }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        rulersButton: {
            visible: true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        rulersButton: {
            visible: true
        }
    }
});

propertiesModeButton

Description: Settings for the Properties Mode drop-down in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Properties Mode drop-down needs to be shown in the WebDesigner component. By default, the Properties Mode drop-down is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    statusBar: {
        propertiesModeButton: {
            visible: true
           }
       }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        propertiesModeButton: {
            visible: true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    statusBar: {
        propertiesModeButton: {
            visible: true
        }
    }
});

propertyGrid

Description: Settings for the Property grid in the WebDesigner component.

Required: Yes

propertiesTab

Description: Settings for the Properties tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Properties tab needs to be shown in the WebDesigner component. By default, the Properties tab is visible.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           visible: true
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           visible: true
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           visible: true
       }
   }
});

mode

Description: Specifies the available property modes in the WebDesigner component.

Return Type: 'Basic' | 'Advanced'

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           mode: 'Basic'
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           mode: 'Basic'
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           mode: 'Basic'
       }
   }
});

sort

Description: Specifies the available properties sort modes in the WebDesigner component.

Return Type: 'categorized' | 'alphabetical'

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           sort: 'alphabetical'
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           sort: 'alphabetical'
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           sort: 'alphabetical'
       }
   }
});

collapsibleCategories

Description: Settings for the collapsibleCategories in the WebDesigner component.

Required: Optional

»enabled

Description: When set to true, Property grid categories becomes collapsible and app memorizes categories' and editor's expand/collapse states.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
           collapsibleCategories: {
               enabled: false
           }
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
            collapsibleCategories: {
                enabled: false
            }
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       collapsibleCategories: {
           enabled: false
       }
   }
});

saveExpandEditorsState

Description: Settings for the saveExpandEditorsState in the WebDesigner component.

Required: Optional

»enabled

Description: When set to true, app memorizes editor's expand/collapse states.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
            saveExpandEditorsState: {
                enabled: false
            }
       }
   }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
            saveExpandEditorsState: {
                enabled: false
            }
       }
   }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
   propertyGrid: {
       propertiesTab: {
            saveExpandEditorsState: {
                enabled: false
            }
       }
   }
});

documents

Description: Settings for the Document API in the WebDesigner component.

Required: Yes

fileView

Description: Settings for the File View tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the File View tab needs to be shown in the WebDesigner component. By default, the File View tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        documents: {
            fileView: {
                visible: false,
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        documents: {
            fileView: {
                visible: false,
            }
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        documents: {
            fileView: {
                visible: false,
            }
        }
   }
});

handlers

Required: Yes

»onBeforeSave()

Description: An async handler, cancels saving process if returned false.

Parameter (Type):

  1. info: SaveDocumentInfo

Return Type: Promise<boolean>

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        documents: {
            fileView: {
        handlers: {
            onBeforeSave: (info) => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
        handlers: {
            onBeforeSave: (info) => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
        handlers: {
            onBeforeSave: (info: SaveDocumentInfo) => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
        }
    }
});

»onAfterSave()

Description: A handler that is called when the save process is completed.

Parameter (Type):

  1. info: SaveDocumentInfo

Return Type: void

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
        handlers: {
            onAfterSave: (info) => {
                if (!info.success) throw new Error(`Report saving error`);
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
        handlers: {
            onAfterSave: (info) => {
                if (!info.success) throw new Error(`Report saving error`);
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
        handlers: {
            onAfterSave: (info) => {
                if (!info.success) throw new Error(`Report saving error`);
            }
        }
    }
});

»onBeforeOpen()

Description: Async handler, cancels opening process if returned false.

Return Type: Promise<boolean>

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
       handlers: {
            onBeforeOpen: () => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
       }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
            onBeforeOpen: () => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
       }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
            onBeforeOpen: () => {
                return new Promise((resolve, reject) => {
                    resolve(false);
                });
            }
       }
    }
});

»onAfterOpen()

Description: A handler that is called when the open process is completed.

Return Type: void

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
       handlers: {
           onAfterOpen: () => {
                console.log('New report opened successful.')
            }
       }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
           onAfterOpen: () => {
                console.log('New report opened successful.')
            }
       }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
           onAfterOpen: () => {
                console.log('New report opened successful.')
            }
       }
    }
});

»onBeforeCreate()

Description: A async handler, cancels the create process if returned false.

Return Type: Promise<boolean>

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
       handlers: {
           onBeforeCreate: () => {return false}
       }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
           onBeforeCreate: () => {return false}
       }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
           onBeforeCreate: () => {return false}
       }
    }
});

»onAfterCreate()

Description: A handler that is called when the 'create' process is complete.

Return Type: void

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
       handlers: {
          onAfterCreate: () => {
                console.log('New report created successful.')
            }
      }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
          onAfterCreate: () => {
                console.log('New report created successful.')
            }
      }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
       handlers: {
          onAfterCreate: () => {
                console.log('New report created successful.')
            }
      }
    }
});

»onInfoUpdate()

Description: A handler that is triggered when report name/id is updated.

Return Type: void

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
      handlers: {
          onInfoUpdate: (options) => {
                console.log(`name changed ${options.name}`);
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
      handlers: {
          onInfoUpdate: (options) => {
                console.log(`name changed ${options.name}`);
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
      handlers: {
          onInfoUpdate: (options:
               {
                   name: string,
                   id?: string,
                   type: SupportedDocumentType['type'],
                   platform: SupportedDocumentType['platform']
               }) =>
                    {console.log(`name changed ${options.name}`);}
        }
    }
});

»onDocumentChanged()

Description: A handler that is triggered when report content is changed.
This function takes an object as an argument that contains two properties:

  • document: The document property contains the updated version of the document that was changed
  • hasUnsavedChanges: The hasUnsavedChanges is a boolean value that indicates whether there are any unsaved changes in the document.

Return Type: void

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    documents: {
      handlers: {
            onDocumentChanged: (options) => {
                if (options.hasUnsavedChanges) console.log('Currently edited report has unsaved changes.');
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
      handlers: {
            onDocumentChanged: (options) => {
                if (options.hasUnsavedChanges) console.log('Currently edited report has unsaved changes.');
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    documents: {
      handlers: {
          onInfoUpdate: (options:
               {
                   name: string,
                   id?: string,
                   type: SupportedDocumentType['type'],
                   platform: SupportedDocumentType['platform']
               }) =>
                    {console.log(`name changed ${options.name}`);}
        }
    }
});

data

dataTab

Description: Settings related to data in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the Data tab needs to be shown in the WebDesigner component. By default, the Data tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataTab: {
            visible:false
            }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataTab: {
            visible:false
            }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataTab: {
            visible:false
        }
    }
});

dataSources

Description: Settings for the Data Sources section in the Data tab.

Required: Yes

»visible

Description: Specifies whether the Data Sources section in the Data tab needs to be shown in the WebDesigner component. By default, the Data Sources section is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            visible:false
            }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            visible:false
            }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            visible:false
        }
    }
});

»canModify

Description: Specifies whether it is possible to modify (i.e. add, edit, or delete) the data sources in the Data Sources section. By default, this feature is disabled.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            canModify: true
            }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            canModify: true
            }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            canModify: true
        }
    }
});

»shared

Description: Specifies whether the shared data sources should be enabled in the WebDesigner. The shared data sources are available under the ‘Shared Reference’ option as a Provider.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
             shared: {
                  enabled: true
             }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
              shared: {
                  enabled: true
             }
        }
     }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
              shared: {
                  enabled: true
             }
        }
     }
});

»options

predefinedProviders

Description: Specifies the list of predefined data providers available in the Data Source editor. By default, all the predefined providers are available.

Return Type: ('SQL' | 'OLEDB' | 'ODBC' | 'JSON' | 'CSV' | 'XML')[]

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                predefinedProviders: ['SQL', 'JSON']
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                predefinedProviders: ['SQL', 'JSON']
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                predefinedProviders: ['SQL', 'JSON']
            }
         }
     }
});

oleDbProviders

Description: Specifies the list of OLE DB providers available in the Data Source editor. By default, 'Microsoft.Jet.OLEDB.4.0', 'SQLOLEDB.1', 'MSDataShape.1', and 'MSDASQL.1' are available.

Return Type: string[]

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                oleDbProviders: ['Microsoft.Jet.OLEDB.4.0', 'SQLOLEDB.1']
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                oleDbProviders: ['Microsoft.Jet.OLEDB.4.0', 'SQLOLEDB.1']
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                oleDbProviders: ['Microsoft.Jet.OLEDB.4.0', 'SQLOLEDB.1']
            }
        }
    }
});

customProviders

Description: Specifies the list of custom data providers available in the Data Source editor. By default, there are no custom data providers available.

Return Type: {key: string; name: string;}[]

  1. where,
    key refers to the data provider identifier. This value is used for 'DataSource.ConnectionProperties.DataProvider' property.
    name refers to the data provider label. This value is used as a friendly data provider label in UI.

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});

dataSets

Description: Settings for the Datasets section in the Data tab.

Required: Yes

»visible

Description: Specifies whether the Datasets section needs to be shown in the WebDesigner component. By default, the Datasets section is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSources: {
            options: {
                customProviders:[{ key: 'CDP', name: 'Custom Data Provider' }]
            }
        }
    }
});

»canModify

Description: Specifies whether it is possible to modify (including add/edit/remove) datasets in the WebDesigner component. The default value for this property is 'false'.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        dataSets: {
            canModify:true
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSets: {
            canModify:true
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        dataSets: {
            canModify:true
        }
    }
});

parameters

Description: Settings for the Parameters section in the Data tab.

Required: Yes

»visible

Description: Specifies whether the Parameters section needs to be shown in the WebDesigner component. By default, the Parameters section is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        parameters: {
            visible: false
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        parameters: {
            visible: false
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        parameters: {
            visible: false
        }
    }
});

»canModify

Description: Specifies whether it is possible to modify (i.e. add, edit, or delete) the report parameters in the Parameters section. The default value for this property is set to 'true'.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        parameters: {
            canModify: false
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        parameters: {
            canModify: false
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        parameters: {
            canModify: false
        }
    }
});

commonValues

Description: Settings for the Common Values section in the Data tab.

Required: Yes

»visible

Description: Specifies whether the Common Values section needs to be shown in the WebDesigner component. By default, the Common Values section is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    data: {
        commonValues: {
            visible: false
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        commonValues: {
            visible: false
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    data: {
        commonValues: {
            visible: false
        }
    }
});

styles

Description: Style settings for Section Reports in the WebDesigner component.

Required: Yes

stylesTab

Description: Settings for the Styles Tab in the WebDesigner component.

Required: Yes

»visible

Description: Specifies whether the stylesheet for the Section Reports (.rpx) can be modified. By default, the Styles tab is visible.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            visible:false
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            visible:false
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            visible:false
        }
    }
});

stylesheet

Description: Stylesheet settings in the WebDesigner component.

Required: Yes

»canModify

Description: Specifies whether it is possible to modify the Section Report (.rpx) in the WebDesigner component. The default value for this property is 'true'.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            canModify:false
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            canModify:false
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    styles: {
        stylesTab: {
            canModify:false
        }
    }
});

server

Description: Backend-related settings for the WebDesigner component.

Required: Yes

url

Description: Specifies the base URL for the Designer Server API. The default value of the property is 'api'.

Return Type: string

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});

onBeforeRequest()

Description: A special handler to modify requests in the WebDesigner component.

Parameter (Type):

init: RequestInit

Return Type: RequestInit

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    server: {
        onBeforeRequest: (init) => alert(init.credentials),
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        onBeforeRequest: (init) => alert(init.credentials),
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        onBeforeRequest: (init) => alert(init.credentials),
    }
});

onBeforeRequestAsync()

Description: Async version of onBeforeRequest. Use either this or normal version.

Parameter (Type):

init: RequestInit

Return Type: Promise<RequestInit>

Required: Optional

title

Description: Settings for document title in the WebDesigner component.

Required: Yes

onUpdate()

Description: It is possible to implement custom logic for updating the browser tab's title when the edited document gets updated in the WebDesigner component.

Parameter (Type):

init: TitleInfo

Return Type: string

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
      title: {
          onUpdate: (info) =>
                `${info.name}${info.hasUnsavedChanges ? ' - Has Unsaved Changes!' : info.name}`
      }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
      title: {
          onUpdate: (info) =>
                `${info.name}${info.hasUnsavedChanges ? ' - Has Unsaved Changes!' : info.name}`
      }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
      title: {
          onUpdate: (info: TitleInfo) =>
                `${info.name}${info.hasUnsavedChanges ? ' - Has Unsaved Changes!' : info.name}`
      }
});

disabled

Description: Specifies whether the browser tab title can be updated in the WebDesigner component. The default value of the property is 'false'.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     title: {
            disabled: true
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     title: {
            disabled: true
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     title: {
            disabled: true
        }
});

preview

Description: Preview settings for the document in the WebDesigner component.

Required: Yes

canPreview

Description: Specifies whether the Preview button needs to be shown in the WebDesigner component. The default value of the property is 'false'.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    server: {
        url: 'api/designer'
    }
});

openViewer

Description: You can plug in the Viewer component by providing the openViewer() method.

Parameter (Type):

  1. settings: ViewerSettings

Return Type: void

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
 preview: {
     openViewer: (info) =>
         console.log(info.applicationTitle)
  }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
 preview: {
     openViewer: (info) =>
         console.log(info.applicationTitle)
  }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
 preview: {
     openViewer: (info: ViewerSettings) =>
         console.log(info.applicationTitle)
  }
});

rpx

Description: RPX platform-specific settings in the WebDesigner component. Must exist for the Section Reports (.rpx) to work.

Required: Yes

enabled

Description: Set to true to enable RPX support.

Return Type: Boolean

Required: Optional

initTemplates

Return Type: {imperialTemplates (optional): string[]; metricTemplates (optional): string[];};

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: {
            enabled: true,
            metricTemplates: ['{"Name":"Report","Width":"10cm","Layers":[{"Name":"default1"}],"CustomProperties":[{"Name":"DisplayType","Value":"Page"},{"Name":"SizeType","Value":"Default"},{"Name":"PaperOrientation","Value":"Portrait"}],"Page":{"PageWidth":"8.5in","PageHeight":"11in","RightMargin":"1in","LeftMargin":"1in","TopMargin":"1in","BottomMargin":"1in","Columns":1,"ColumnSpacing":"0in"},"Body":{"Height":"0.75cm","ReportItems":[{"Type":"textbox","Name":"TextBox1","CustomProperties":[],"CanGrow":true,"KeepTogether":true,"Style":{"PaddingLeft":"2pt","PaddingRight":"2pt","PaddingTop":"2pt","PaddingBottom":"2pt"},"Left":"0cm","Top":"0cm","Width":"10cm","Height":"5cm"}]}}'],
        }
    );
     var designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
    designer.documents.create({
    name: 'MyReport.rpx',
    type:
        {
            platform: 'rpx',
            type: 'report'
        }
    });
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: {
            enabled: true,
            metricTemplates: ['{"Name":"Report","Width":"10cm","Layers":[{"Name":"default1"}],"CustomProperties":[{"Name":"DisplayType","Value":"Page"},{"Name":"SizeType","Value":"Default"},{"Name":"PaperOrientation","Value":"Portrait"}],"Page":{"PageWidth":"8.5in","PageHeight":"11in","RightMargin":"1in","LeftMargin":"1in","TopMargin":"1in","BottomMargin":"1in","Columns":1,"ColumnSpacing":"0in"},"Body":{"Height":"0.75cm","ReportItems":[{"Type":"textbox","Name":"TextBox1","CustomProperties":[],"CanGrow":true,"KeepTogether":true,"Style":{"PaddingLeft":"2pt","PaddingRight":"2pt","PaddingTop":"2pt","PaddingBottom":"2pt"},"Left":"0cm","Top":"0cm","Width":"10cm","Height":"5cm"}]}}'],
        }
    );
     var designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
    designer.documents.create({
    name: 'MyReport.rpx',
    type:
        {
            platform: 'rpx',
            type: 'report'
        }
    });
TypeScript Module
rpx: {
        enabled: true,
        metricTemplates: ['{"Name":"Report","Width":"10cm","Layers":[{"Name":"default1"}],"CustomProperties":[{"Name":"DisplayType","Value":"Page"},{"Name":"SizeType","Value":"Default"},{"Name":"PaperOrientation","Value":"Portrait"}],"Page":{"PageWidth":"8.5in","PageHeight":"11in","RightMargin":"1in","LeftMargin":"1in","TopMargin":"1in","BottomMargin":"1in","Columns":1,"ColumnSpacing":"0in"},"Body":{"Height":"0.75cm","ReportItems":[{"Type":"textbox","Name":"TextBox1","CustomProperties":[],"CanGrow":true,"KeepTogether":true,"Style":{"PaddingLeft":"2pt","PaddingRight":"2pt","PaddingTop":"2pt","PaddingBottom":"2pt"},"Left":"0cm","Top":"0cm","Width":"10cm","Height":"5cm"}]}}'],
    }
);
const designer = GrapeCity.ActiveReports.Designer.apiOf('ar-web-designer');
designer.documents.create({
name: 'MyReport.rpx',
type:
        {
            platform: 'rpx',
            type: 'report'
        }
});

styles

RPX Styles-related settings.

stylesTab

enabled

Description: Specifies whether Styles tab needs to be shown for RPX reports.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: {
         styles: {
              stylesTab: {
                   enabled:false
                   }
              }
         }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rpx: {
          styles: {
               stylesTab: {
                    enabled:false
               }
          }
     }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rpx: {
          styles: {
               stylesTab: {
                    enabled:false
               }
          }
     }
});

stylesheet

canModify

Description: Specifies whether RPX report Stylesheet can be modified.

Return Type: boolean

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rpx: {
         styles: {
              stylesTab: {
                   canModify:false
                   }
              }
         }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rpx: {
          styles: {
               stylesTab: {
                    canModify:false
               }
          }
     }
});
TypeScript Module

toolBoxContent

Description: Specifies the report items and their display order in the toolbox of Section report.

Return Type: RpxToolBoxItem[]

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     rpx: {
             enabled: true,
             toolBoxContent:['Label', 'TextBox']
    });
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: {
            enabled: true,
            toolBoxContent:['Label', 'TextBox']
    });
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rpx: {
            enabled: true,
            toolBoxContent:['Label', 'TextBox']
    });

rdlx

Required: Yes

expressionSyntax

Description: Specifies which Expression syntax will be used in the WebDesigner component: 'i11n' - interpolation syntax or 'rdl' - old rdl expression syntax. By default, the interpolation syntax is used for expressions.

Return Type: 'i11n' | 'rdl'

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
     rdlx: {
         expressionSyntax: 'rdl'
     }
 });
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         expressionSyntax: 'rdl'
     }
 });
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         expressionSyntax: 'rdl'
     }
 });

msl

»enabled

Description: Set to true to enable RDLX report(a multi-section layout (MSL)) support.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        rdlx: {
            msl: {
                enabled: true
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            msl: {
                enabled: true
            }
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            msl: {
                enabled: true
            }
        }
});

fpl

»enabled

Description: Set to true to enable Fixed Page Layout support.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        rdlx: {
            fpl: {
                enabled: true
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            fpl: {
                enabled: true
            }
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            fpl: {
                enabled: true
            }
        }
});

dashboard

»enabled

Description: Set to true to enable Dashboard report support.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        rdlx: {
            dashboard: {
                enabled: true
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            dashboard: {
                enabled: true
            }
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            dashboard: {
                enabled: true
            }
        }
});

reportParts

Description: Report Parts feature related settings.

Return Type: ReportPartsSettings

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rdlx: {
         reportParts: {
             enabled: true,
             libraries: [{
                 name: 'Sales',
                 path: 'Libraries/Lib_Sales.rdlx'
             }]
         }
     }
 });
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
         reportParts: {
             enabled: true,
             libraries: [{
                 name: 'Sales',
                 path: 'Libraries/Lib_Sales.rdlx'
             }]
         }
     }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
         reportParts: {
             enabled: true,
             libraries: [{
                 name: 'Sales',
                 path: 'Libraries/Lib_Sales.rdlx'
             }]
         }
     }
});

masterReports

»enabled

Description: Set to true to enable master reports support.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
        rdlx: {
            masterReports: {
                enabled: true
            }
        }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            masterReports: {
                enabled: true
            }
        }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
            masterReports: {
                enabled: true
            }
        }
});

expressionEditorNodesFilter()

Description: Filters the Expression Editor nodes in the WebDesigner component.

Parameter (Type):

  1. key: string

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    designerSettings.rdlx.expressionEditorNodesFilter = (key) => {
        if (key.includes('commonValues')) return false;
        if (key.includes('aggregate.aggregateIfWithScope')) return false;
        return true;
UMD Module
designerSettings.rdlx.expressionEditorNodesFilter = (key) => {
    if (key.includes('commonValues')) return false;
    if (key.includes('aggregate.aggregateIfWithScope')) return false;
    return true;
}
TypeScript Module
designerSettings.rdlx.expressionEditorNodesFilter = (key: string) => {
    if (key.includes('commonValues')) return false;
    if (key.includes('aggregate.aggregateIfWithScope')) return false;
    return true;
}

toolBoxContent

Description: Specifies the report items and their display order in the toolbox. By default, the available report items for Page Report (fpl) are TextBox, CheckBox, Container, Line, Shape, TableOfContents, Image, List, Table, Tablix, Chart, Bullet, Barcode, FormattedText, RichText, Sparkline, SubReport, BandedList, and InputField.

For RDLX reports, these are the default available report items - TextBox, CheckBox, Container, Line, Shape, TableOfContents, Image, List, Table, Tablix, Chart, Bullet, Barcode, FormattedText, RichText, Sparkline, SubReport, OverflowPlaceholder, BandedList, and InputField.

Return Type: {cpl: RdlxToolBoxItem[]; fpl: RdlxToolBoxItem[]; };

Required: Optional

Sample Code Copy Code
designerSettings.rdlx.toolBoxContent = {
   cpl: [ 'checkbox', 'container', 'textbox' ],
   fpl: [ 'image', 'list', 'table', 'tablix', 'chart', 'bullet', 'barcode', 'formattedtext' ]
}

initTemplates

Description: Use Page reports to set custom templates for specific Page report items, for example, 'OverflowPlaceHolder'. It is preferable to use an RDLX report for setting custom templates for all other report items, as well as for pageHeader and pageFooter. In case of Reports, set ConsumeContainerWhitespace and Page-properties: BottomMargin, LeftMargin, RightMargin, TopMargin, PageHeight, PageWidth, and ColumnSpacing.

For the rest of the report items, all properties are set, including, for example, the number of columns in the table or barcode default symbology. Note that if there is a same report item as in the previous one within a subsequent report in an array. Then, in such a case only the last template for this report item will be set. Furthermore, you can also set multiple init templates for some report items. For this, you should add a report with more than one report item of the same type. Templates with the same names will be replaced. Use the 'TemplateName' custom property of each report item to set a localized name of the template. Use the 'AllowWizard' custom property of a chart report item to allow the use of chart wizard when this report item is created. For example: ... ,"CustomProperties":[{"Name":"TemplateName","Value":"Doughnut Chart"}, {"Name":"AllowWizard","Value":"true"},...],...

Return Type: {imperialTemplates?: string[]; metricTemplates?: string[];};

Required: Optional

Sample Code Copy Code
imperialTemplates: ['{"Name":"Report","Width":"5in","Layers":[{"Name":"default"}],"CustomProperties":[{"Name":"DisplayType","Value":"Page"},{"Name":"SizeType","Value":"Default"},{"Name":"PaperOrientation","Value":"Portrait"}],"Page":{"PageWidth":"8.5in","PageHeight":"11in","RightMargin":"1in","LeftMargin":"1in","TopMargin":"1in","BottomMargin":"1in","Columns":1,"ColumnSpacing":"0in"},"Body":{"Height":"0.25in","ReportItems":[{"Type":"textbox","Name":"TextBox1","CustomProperties":[],"CanGrow":true,"KeepTogether":true,"Style":{"PaddingLeft":"2pt","PaddingRight":"2pt","PaddingTop":"2pt","PaddingBottom":"2pt"},"Width":"5in","Height":"0.25in"}]}}'],
metricTemplates: ['{"Name":"Report","Width":"10cm","Layers":[{"Name":"default"}],"CustomProperties":[{"Name":"DisplayType","Value":"Page"},{"Name":"SizeType","Value":"Default"},{"Name":"PaperOrientation","Value":"Portrait"}],"Page":{"PageWidth":"8.5in","PageHeight":"11in","RightMargin":"1in","LeftMargin":"1in","TopMargin":"1in","BottomMargin":"1in","Columns":1,"ColumnSpacing":"0in"},"Body":{"Height":"0.75cm","ReportItems":[{"Type":"textbox","Name":"TextBox1","CustomProperties":[],"CanGrow":true,"KeepTogether":true,"Style":{"PaddingLeft":"2pt","PaddingRight":"2pt","PaddingTop":"2pt","PaddingBottom":"2pt"},"Left":"0cm","Top":"0cm","Width":"10cm","Height":"0.75cm"}]}}'],
};

reportItemsFeatures

Description: Refers to customizable report item features in the WebDesigner component.

Return Type: RdlxReportItemsSettings

Required: Yes

reportStyles

Description: Specifies additional styles to add to report item styles in the WebDesigner component.

Return Type: ReportStyles[]

Required: Yes

Sample Code Copy Code
designerSettings.rdlx.reportStyles
    {
        Bullet: [{
                id: 'c8aa4403-83ef-402b-a7da-032063cf625a',
                name: 'additionalBulletStyle1',
                content: {
                    ValueColor: 'red',
                    LabelFontColor: '=Theme.Colors!Dark1',
                    LabelFontFamily: '=Theme.Fonts!MinorFont.Family',
                    LabelFontSize: '=Theme.Fonts!MinorFont.Size',
                    LabelFontStyle: '=Theme.Fonts!MinorFont.Style',
                    TicksLineColor: '=Theme.Colors(1,0)'
                }
            },
        ],
        List: [
            {    id: '3d2c3781-4eea-4ac3-8d50-636edd9328d5',
                name: 'additionalListStyle1',
                content: {},
            },
            {    id: '5b7b4e73-22e5-42ed-99c4-62840bdde79d',
                name: 'additionalListStyle2',
                content: {
                    BackgroundColor: '=Theme.Colors!Accent1',
                    Border: {
                        Color: '=Theme.Colors(4,4)',
                        Width: '1pt',
                        Style: 'Solid',
                    }
                }
            }]
    },
    {    ChartPalette: [{
                id: 'c8aa4403-83ef-402b-a7da-0320444',
                name: 'additionalChartPalette',
                content: ['red', '=Theme.Colors!Accent2', '=Theme.Colors!Accent3', '=Theme.Colors!Accent4', '=Theme.Colors!Accent5', '=Theme.Colors!Accent6', '=Theme.Colors(5,4)', '=Theme.Colors(5,5)', '=Theme.Colors(5,6)', '=Theme.Colors(5,7)', '=Theme.Colors(5,8)', '=Theme.Colors(5,9)']
            }]
    },
];

stylesheets

»enabled

Description: Stylesheets feature related settings. Set it to true to enable stylesheet settings.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
rdlx: {
     stylesheets: {
        enabled:true
     }
}
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
             stylesheets: {
                enabled:true
             }
       }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        rdlx: {
             stylesheets: {
                enabled:false
             }
       }
});

TitleInfo

Information on browser tab title.

name

Description: Refers to the document name.

Return Type: string

Required: Yes

hasUnsavedChanges

Description: Indicates whether the document has unsaved changes or not in the WebDesigner component.

Return Type: boolean

Required: Yes

RdlxToolBoxItem

Report items available in the toolbox.

Acceptable Values

Copy Code
'textbox' | 'checkbox' | 'container' | 'line' | 'shape' | 'tableofcontents' |
'image' | 'list' | 'table' | 'tablix' | 'chart' | 'bullet' | 'barcode' | 'formattedtext' |
'richtext' | 'sparkline' | 'subreport' | 'overflowplaceholder' | 'bandedlist' | 'inputfield'

RpxToolBoxItem

Report items available in the toolbox.

Acceptable Values

Copy Code
'Label' | 'TextBox' | 'CheckBox' | 'RichTextBox' | 'Shape' | 'Picture' | 'Line' | 'PageBreak' |
'Barcode' | 'SubReport' | 'ReportInfo' | 'CrossSectionLine' | 'CrossSectionBox' | 'InputFieldText' | 'InputFieldCheckBox'

DvChartPlotType

Chart types available.

Acceptable Values

Copy Code
'Custom'| 'Bar' | 'Line' | 'Area' | 'Scatter' | 'HighLowOpenClose' | 'Candlestick' | 'Column' |'Pie' | 'Pyramid' | 'Funnel' | 'Bubble' | 'Gantt' | 'HighLowClose' | 'PolarColumn' | 'PolarBar'|'RadarArea' | 'RadarBubble' | 'RadarScatter' | 'RadarLine' | 'RangeArea' | 'RangeBar' | 'RangeColumn' | 'Gauge'

DvChartEncodingType

The encoding type. Following are the encodings from the adorner panel only.

Acceptable Values

Copy Code
'Details' | 'Color' | 'Shape' | 'Size' | 'Text'

RdlxReportItemsSettings

Settings for the report items.

barcode

Description: Settings for barcodes in the WebDesigner component.

symbologies

Description: Limits the list of barcode symbologies available for creation. By default, all barcode symbologies supported by ActiveReports are available.

Return Type: RdlxBarcodeSymbology[]

Required: Optional

ES Module
 import { arWebDesigner } from './web-designer.js';
 arWebDesigner.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                symbologies: ['Code_128_A', 'Code_128_B', 'Code_128_C']
             }
         }
     }
 });
UMD Module
 GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                symbologies: ['Code_128_A', 'Code_128_B', 'Code_128_C']
             }
         }
     }
 });
TypeScript Module
 GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                symbologies: ['Code_128_A', 'Code_128_B', 'Code_128_C']
             }
         }
     }
 });

hideUnsupportedBarcodeJSProperties

Description: Hides some unsupported barcode JS properties.

Return Type: boolean

Required: Optional

ES Module
 import { arWebDesigner } from './web-designer.js';
 arWebDesigner.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                hideUnsupportedBarcodeJSProperties: true
             }
         }
     }
 });
UMD Module
 GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                hideUnsupportedBarcodeJSProperties: true
             }
         }
     }
 });
TypeScript Module
 GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
             barcode: {
                hideUnsupportedBarcodeJSProperties: true
             }
         }
     }
 });

chart

Description: Settings for the chart features.

canUseWizard

Description: Specifies whether the Chart Wizard is available for creating a Chart.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
           chart: {
               canUseWizard: false
           }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
            chart: {
                canUseWizard: false
            }
         }
     }
 });
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
     rdlx: {
         reportItemsFeatures: {
            chart: {
                canUseWizard: false
            }
         }
     }
 });

plotChartTypes

Description: Specifies the plot chart types available for creation.

Return Type: boolean

Required: Optional

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
           chart: {
               plotChartTypes: ['Column', 'Bar', 'Line']
           }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            chart: {
                plotChartTypes: ['Column', 'Bar', 'Line']
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            chart: {
                plotChartTypes: ['Column', 'Bar', 'Line']
            }
        }
    }
});

hiddenEncodings

Description: Excludes given encodings from encoding panel in chart adorner.

Return Type: DvChartEncodingType[]

Required: Yes

ES Module
import { arWebDesigner } from './web-designer.js';
arWebDesigner.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            chart: {
                hiddenEncodings: ['Color', 'Text']
            }
        }
    }
});
UMD Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            chart: {
                hiddenEncodings: ['Color', 'Text']
            }
        }
    }
});
TypeScript Module
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            chart: {
                hiddenEncodings: ['Color', 'Text']
            }
        }
    }
});

table

Description: Settings for tables in the WebDesigner component.

autoFillHeader

Description: Specifies whether the Table Header needs to be auto-filled when a field is dropped to the Table Details section. For example, if the ProductName field is dropped to the Details section, the Product Name value is set to the Header. By default, this feature is enabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
designerSettings.rdlx.reportItemsFeatures.table.autoFillHeader = false;

autoFillFooter

Description: Specifies whether Table Footer needs to be auto-filled when a field is dropped to the Table Details section. For example, if the ProductName field is dropped to the Details section, =Count([ProductName]) value is set to the Footer. By default, this feature is disabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
designerSettings.rdlx.reportItemsFeatures.table.autoFillFooter = true;

canMergeCellsVertically

Description: Specifies whether vertical merge of cells is enabled within the Table Header, Details, and Footer sections. By default, this feature is enabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
designerSettings.rdlx.reportItemsFeatures.table.canMergeCellsVertically = false;

hideFrozenRowsColumns

Description: Specifies whether to hide FrozenRows or FrozenColumns properties from the Property grid. By default, hideFrozenRowsColumns is set to 'false'.

Return Type: boolean

Required: Optional

Sample Code Copy Code
designerSettings.rdlx.reportItemsFeatures.table.hideFrozenRowsColumns = true;

preventOrphanedHeader

enabled

Description: Specifies whether to show PreventOrphanedHeader property in Properties panel for table and table group.

Return Type: boolean

Required: Optional

Sample Code Copy Code
designerOptions.rdlx.reportItemsFeatures.table.preventOrphanedHeader.enabled = true;

tablix

Description: Settings for Tablix data region in the WebDesigner component.

crossAggregates

Description: Specifies whether the Tablix Wizard should hide the cross-aggregates functionality. By default, this feature is enabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
        reportItemsFeatures: {
            tablix: {
                 crossAggregates: false
            }
        }
    }
});

autoFillCorner

Description: Specifies whether the Tablix Corner cell needs to be auto-filled when a field is dropped to the Tablix Row Group cell. For example, if the ProductName field is dropped to the Row Group cell, the Product Name value is set to the Corner cell. By default, this feature is enabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
             reportItemsFeatures: {
                tablix: {
                 autoFillCorner: false
                }
             }
    }
});

canUseWizard

Description: Specifies whether the Tablix Wizard is available for creating or editing the Tablix control in the WebDesigner component. By default, this feature is enabled.

Return Type: boolean

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
             reportItemsFeatures: {
                tablix: {
                 canUseWizard: false
                }
             }
    }
});

hideFrozenRowsColumns

Description: Specifies whether to hide FrozenRows or FrozenColumns properties from the Property grid and Tablix wizard. By default, hideFrozenRowsColumns is set to 'false'.

Return Type: boolean

Required: Optional

Sample Code Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    rdlx: {
             reportItemsFeatures: {
                tablix: {
         hideFrozenRowsColumns: true
            }
        }
    }
});

RdlxBarcodeSymbology

Supported barcode symbologies.

Acceptable Values

Copy Code
'Ansi39' | 'Ansi39x' | 'BC412' | 'Codabar' | 'Code_11' | 'Code_128_A' | 'Code_128_B' | 'Code_128_C' | 'Code_128auto' |
'Code_2_of_5' | 'Code_93' | 'Code25intlv' | 'Code39' | 'Code39x' | 'Code49' | 'Code93x' | 'DataMatrix' | 'EAN_13' | 'EAN_8' | 'EAN128FNC1' |
'GS1QRCode' | 'HIBCCode128' | 'HIBCCode39' | 'IATA_2_of_5' | 'IntelligentMail' | 'IntelligentMailPackage' | 'ISBN' | 'ISMN' | 'ISSN' |
'ITF14' | 'JapanesePostal' | 'Matrix_2_of_5' | 'MaxiCode' | 'MicroPDF417' | 'MicroQRCode' | 'MSI' | 'Pdf417' | 'Pharmacode' | 'Plessey' |
'PostNet' | 'PZN' | 'QRCode' | 'RM4SCC' | 'RSS14' | 'RSS14Stacked' | 'RSS14StackedOmnidirectional' | 'RSS14Truncated' | 'RSSExpanded' |
'RSSExpandedStacked' | 'RSSLimited' | 'SSCC_18' | 'Telepen' | 'UCCEAN128' | 'UPC_A' | 'UPC_E0' | 'UPC_E1' |

ReportItemStyle<T>

Report item style.

id

Return Type: string

Required: Yes

name

Return Type: string

Required: Yes

content

Return Type: T

Required: Yes

BorderStyle

Border style.

Color

Return Type: string

Required: Optional

Style

Return Type: string

Required: Optional

Width

Return Type: string

Required: Optional

CellStyleContent

Styles for Table cell.

TextBoxStyleContent with the following:

LeftBorder

Return Type: BorderStyle

Required: Optional

TopBorder

Return Type: BorderStyle

Required: Optional

BottomBorder

Return Type: BorderStyle

Required: Optional

RightBorder

Return Type: BorderStyle

Required: Optional

TextAlign

Return Type: string

Required: Optional

BottomBorder

Return Type: string

Required: Optional

TextBoxStyleContent

Styles for TextBox control.

Color

Return Type: string

Required: Optional

BackgroundColor

Return Type: string

Required: Optional

FontFamily

Return Type: string

Required: Optional

FontSize

Return Type: string

Required: Optional

FontStyle

Return Type: string

Required: Optional

FontWeight

Return Type: string

Required: Optional

ContainerStyleContent

Styles for Container control.

BackgroundColor

Return Type: string

Required: Optional

Border

Return Type: string

Required: Optional

BulletStyleContent

Styles for Bullet data region.

ValueColor

Return Type: string

Required: Optional

TargetLineColor

Return Type: string

Required: Optional

LabelFontColor

Return Type: string

Required: Optional

LabelFontFamily

Return Type: string

Required: Optional

LabelFontSize

Return Type: string

Required: Optional

LabelFontStyle

Return Type: string

Required: Optional

TicksLineColor

Return Type: string

Required: Optional

SparklineStyleContent

Styles for Sparkline control.

LineColor

Return Type: string

Required: Optional

FillColor

Return Type: string

Required: Optional

GradientEndColor

Return Type: string

Required: Optional

MarkerColor

Return Type: string

Required: Optional

RangeFillColor

Return Type: string

Required: Optional

RangeGradientEndColor

Return Type: string

Required: Optional

TableStyleContent

Styles for Table data region.

Header

Return Type: { Rows: CellStyleContent[] };

Required: Yes

Details

Return Type: { Rows: CellStyleContent[]; AlternatingExpression: string };

Required: Yes

Footer

Return Type: { Rows: CellStyleContent[] };

Required: Yes

TableGroups

Styles

Return Type: { Header: { Rows: CellStyleContent[] }; Footer: { Rows: CellStyleContent[] };}[];

Required: Yes

Border

Return Type: BorderStyle

Required: Optional

TableOfContentsStyleContent

Styles for Table of Contents data region.

BackgroundColor

Return Type: string

Required: Optional

Border

Return Type: BorderStyle

Required: Optional

Levels

Required: Yes

Color

Return Type: string

Required: Optional

PaddingLeft

Return Type: string

Required: Optional

FontFamily

Return Type: string

Required: Optional

FontSize

Return Type: string

Required: Optional

FontStyle

Return Type: string

Required: Optional

FontWeight

Return Type: string

Required: Optional

ChartPaletteContent

Chart palette.

Acceptable Values

Copy Code
string[]

ReportStyles

Styles for toolbox items or report controls.

Bullet

Return Type: ReportItemStyle<BulletStyleContent>

Required: Yes

CheckBox

Return Type: ReportItemStyle<TextBoxStyleContent>

Required: Yes

FormattedText

Return Type: ReportItemStyle<ContainerStyleContent>

Required: Yes

InputField

Return Type: ReportItemStyle<TextBoxStyleContent>

Required: Yes

List

Return Type: ReportItemStyle<ContainerStyleContent>

Required: Yes

Rectangle

Return Type: ReportItemStyle<ContainerStyleContent>

Required: Yes

RichText

Return Type: ReportItemStyle<TextBoxStyleContent>

Required: Yes

Shape

Return Type: ReportItemStyle<ContainerStyleContent>

Required: Yes

Sparkline

Return Type: ReportItemStyle<SparklineStyleContent>

Required: Yes

Table

Return Type: ReportItemStyle<TableStyleContent>

Required: Yes

TableOfContents

Tablix

Return Type: ReportItemStyle<TableStyleContent>

Required: Yes

TextBox

Return Type: ReportItemStyle<TextBoxStyleContent>

Required: Yes

ChartPalette

Return Type: ReportItemStyle<ChartPaletteContent>

Required: Yes

Show Table

Return Type: ReportItemStyle<TableStyleContent>

Required: Yes

Show TableOfContents

Return Type: ReportItemStyle<TableOfContentsStyleContent>

Required: Yes

Show Tablix

Show TextBox

Show ChartPalette

ViewerSettings

Viewer settings.

element

Description: Refers to the host element's id where to render the Viewer.

Return Type: string

Required: Yes

applicationTitle

Description: Refers to the application title passed by the WebDesigner component.

Return Type: string

Required: Yes

documentInfo

Description: Information on the document to be previewed.

Required: Yes

id

Description: Refers to the document id.

Return Type: string

Required: Yes

content

Description: Refers to the document content in JSON format that can be useful for viewers with in-browser rendering.

Return Type: unknown

Required: Yes

name

Description: Refers to the document name.

Return Type: string

Required: Yes

temporary

Description: Specifies whether the document to be previewed is an existing report saved on the server-side.

Return Type: boolean

Required: Yes

preferredFormat

Description: Specifies preferred rendering format for the document.

Return Type: 'html' | 'svg'

Required: Yes

CreateDocumentOptions

Define what kind of document must be created.

name

Description: Refers to the name of the document. If this property is not specified, the default 'Untitled' name will be used.

Return Type: string

Required: Optional

type

Description: Refers to the document type to create in the WebDesigner component. If this property is not specified, an RDLX report will be created.

Return Type: SupportedDocumentType

Required: Optional

template

Description: Refers to the template to use for the document.

Return Type: DocumentTemplate

Required: Optional

dataSetsInfo

Description: Refers to the list of RDLX Data Sets to use with the template in the WebDesigner component. Note that these datasets won't work with Section Reports (.rpx).

Return Type: { id: string;, name: string;}[];

  1. where,
    id refers to the dataset id.
    name refers to the dataset name.

Required: Optional

CreateDocumentInfo

Information about the created document (if it was successfully created).

type

Description: Refers to the document type in the WebDesigner component.

Return Type: SupportedDocumentType

Required: Yes

name

Description: Refers to the document name in the WebDesigner component.

Return Type: string

Required: Yes

template

Description: Refers to the document template in the WebDesigner component.

Return Type: DocumentTemplate

Required: Optional

success

Description: Undefined in onBeforeCreate handler. Defined in onAfterCreate handler.

Return Type: boolean

Required: Optional

CurrentDocumentInfo

Information about the current document.

id

Description: Refers to the document id. If an existing report is edited, id is defined. Otherwise, if a new report is edited, id is 'null'.

Return Type: string | null

Required: Yes

name

Description: Refers to the document name in the WebDesigner component.

Return Type: string

Required: Yes

type

Description: Refers to the document type in the WebDesigner component.

Return Type: SupportedDocumentType

Required: Yes

DocumentTemplate

Template to use for the document.

id

Description: Refers to the document template id.

Return Type: string

Required: Optional

content

Description: Refers to the document template content in JSON format that can be useful in case you would like to create a non-empty new report.

Return Type: unknown

Required: Optional

OpenDocumentOptions

Define options for opening a document.

templateInfo

Description: Refers to the template information. If it is specified for report creation, either templateInfo.id or templateinfo.content needs to be defined.

Return Type: DocumentTemplate

Required: Optional

dataSetsInfo

Description: Refers to the list of RDLX datasets to use with the template. Note that these datasets won't work with Section Reports (.rpx).

Return Type: {id: string; name: string;}[];

  1. where,
    id refers to the dataset id.
    name refers to the dataset name.

Required: Optional

name

Description: Refers to the new report name. If you do not specify the name, the report name is set to 'Untitled'.

Return Type: string

Required: Optional

type

Description: Refers to the report type. If not specified RDLX report will be created.

Return Type: SupportedDocumentType

Required: Optional

SaveDocumentInfo

Information about the saving the document.

type

Description: Refers to the type of document.

Return Type: SupportedDocumentType

Required: Yes

id

Description: If an existing document is to be overwritten on saving, the correct id should be specified explicitly.

Return Type: string

Required: Optional

name

Description: The correct name needs to be always specified explicitly.

Return Type: string

Required: Yes

isFirstSave

Description: Indicates that a new document is being saved for the first time.

Return Type: boolean

Required: Yes

success

Description: Undefined in onBefore handler. Defined in onAfter handler.

Return Type: boolean

Required: Optional

OpenDocumentInfo

Information about an open document.

type

Description: Refers to the type of document.

Return Type: SupportedDocumentType

Required: Yes

id

Description: Refers to the document id.

Return Type: string

Required: Yes

name

Description: Refers to the document name.

Return Type: string

Required: Yes

success

Description: Undefined in onBefore handler. Defined in onAfter handler.

Return Type: boolean

Required: Optional

ReportPartsSettings

API for settings related to Report Parts.

enabled

Description: Specifies whether the report parts should be enabled in the WebDesigner for the end users to be able to use libraries.

Return Type: SupportedDocumentType

Required: Optional

libraries

Description: List of report items initially available for user libraries.

Return Type:

Array<{
          name: string,
          path: string
         }>

Required: Optional

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor WebDesigner Application

Blazor WebDesigner Application
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application

Glossary Item Box

The ASP.NET Core Blazor designer component, provided by ActiveReports, is quite similar to the WebDesigner component. It also requires both server and client parts.

Create Blazor WebDesigner Application

Blazor allows using the client and server parts differently, please see the topics of this section for details:

  • Blazor Server Application
  • Blazor Web Assembly
  • Configure and Use Shared Data Sources
  • Configure Preview
  • Blazor WebDesigner API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Server Application

Blazor Server Application
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application > Blazor Server Application

Glossary Item Box

This topic describes how to add the Blazor Designer component to your Blazor Server Application.

  1. Open Microsoft Visual Studio 2022.
  2. Create a new project and select the Blazor Server App Empty template.
  3. Type a name for your project and click Next.
  4. Select a target framework and uncheck 'Configure for HTTPS' option, and then click Create.
  5. Add the following NuGet packages:
    MESCIUS.ActiveReports.Aspnetcore.Designer
    MESCIUS.ActiveReports.Blazor.Designer
  6. Add a new folder called Resources to the project.
  7. Add a report to the Resources folder.
  8. Make sure to set the Build Action property of the report to Embedded Resource.
  9. Update Program.cs with the code as demonstrated in the example below.
    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
var resourcesRootDirectory = new DirectoryInfo(".\\resources\\");
var builder = WebApplication.CreateBuilder(args);
builder.Services.AddRazorPages();
builder.Services.AddServerSideBlazor();
builder.Services
     .AddReportDesigner()
     .AddMvc(options => options.EnableEndpointRouting = false)
     .AddJsonOptions(options => options.JsonSerializerOptions.PropertyNamingPolicy =
null);
var app = builder.Build();
if (!app.Environment.IsDevelopment())
{
    // The default HSTS value is 30 days. You may want to change this for production scenarios, see https://aka.ms/aspnetcore-hsts.
    app.UseHsts();
}
app.UseHttpsRedirection();
app.UseReportDesigner(config => config.UseFileStore(resourcesRootDirectory, false));
app.UseStaticFiles();
app.UseRouting();
app.MapBlazorHub();
app.MapFallbackToPage("/_Host");
app.Run();
  10. Add the WebDesigner Blazor component to 'Pages/Index.razor'.
    Copy Code
    @page "/"
@using GrapeCity.ActiveReports.Blazor.Designer;
@inject IJSRuntime JSRuntime
<div style="height:100vh;width:100%"
    <ReportDesigner @ref="_designer" Document="@_document" />
</div>
@code {
    private ReportDesigner _designer;
    private Document _document = new Document()
      {
            Id = "report.rdlx",
            Type = SupportedDocumentType.cpl
      };
}
  11. Build and run the solution.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor Web Assembly

Blazor Web Assembly
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application > Blazor Web Assembly

Glossary Item Box

This topic describes how to add the Blazor Designer component to your Blazor Web Assembly Application. This project uses the Report Server.

  1. Open Microsoft Visual Studio 2022.
  2. Create a new project and select the Blazor WebAssembly App Empty template.
  3. Type a name for your project and click Next.
  4. Select a target framework and uncheck 'Configure for HTTPS' option, and then click Create.
  5. Add the MESCIUS.ActiveReports.Blazor.Designer NuGet package.
  6. Add the Blazor WebDesigner component to 'Pages/Index.razor'.
    Pages/Index.razor Copy Code
    @page "/"
@using GrapeCity.ActiveReports.Blazor.Designer;
@inject IJSRuntime JSRuntime
<div style="height:100vh;width:100%"
    <ReportDesigner @ref="_designer" Server="@_server" Document="@_document" />
</div>
@code {
    private ReportDesigner _designer;
    private Server _server = new Server()
    {
        Url = "http://localhost:5098"
    };
    private Document _document = new Document()
        {
            Id = "Report.rdlx",
            Type = SupportedDocumentType.cpl
        };
}
  7. Run the Report Server.
  8. Build and run the application.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure and Use Shared Data Sources

Configure and Use Shared Data Sources
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application > Configure and Use Shared Data Sources

Glossary Item Box

The shared data sources contain connection properties that allow binding multiple reports to the same data. The shared data sources can be created and edited only in Standalone Designer or VS integrated designer. In WebDesigner, however, you can only reference an existing data source.

Following are the scenarios for using shared data sources in web designer:

  • a developer wants to prevent the connection string information from being displayed on the client-side
  • a developer wants users to be able to select a pre-defined data sources/data sets

The shared data source solves this problem because the report definition contains only the reference to the data source definition, which is resolved on the server-side when a report is previewed.

Note: Shared data sources are disabled by default.

You must create a shared data source (.rdsx) in Standalone Designer or Visual Studio Integrated Designer. See Work with Local Shared Data Sources for more information.

We will be adding shared data source functionality in an already available Blazor Designer Server Application sample

  1. Open the Blazor Designer Server Application.
  2. Place the shared reference, a .rdsx file, in the ‘resources’ folder of the project.
  3. In the Index.razor where web designer is initialized, use Shared property to enable shared data sources. The complete Index.razor code is as shown.
    Index.razor Copy Code
    @page "/"
@inject IJSRuntime JSRuntime
<PageTitle>Index</PageTitle>
<link href="_content/@(typeof(ReportViewer).Assembly.GetName().Name)/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner @ref="_designer" RpxSettings="@_rpx" AppBarSettings="@_appBar" DataSettings="@_data" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private ReportViewer _viewer;
    private RpxSettings _rpx;
    private AppBarSettings _appBar;
    private DataSettings _data;
    private PreviewSettings _preview;
    public Index()
    {
        _rpx = new RpxSettings
        {
            Enabled = true
        };
        _appBar = new AppBarSettings
        {
            OpenButton = new OpenButton { Visible = true }
        };
        _data = new DataSettings
        {
            DataSets = new DataSets { CanModify = true },
            DataSources = new DataSources
            {
                CanModify = true,
                Shared = new SharedDataSourceOptions()
                {
                    Enabled = true
                }
            }
        };
        _preview = new PreviewSettings
        {
            OpenViewer = OpenViewer
        };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if(_viewer != null)
        {
            await _viewer.SetTheme(settings.Theme);
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        _viewer = new ReportViewer();
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        initOptions.Theme = settings.Theme;
        initOptions.ReportLoaded = (reportInfo) =>
        {
        };
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}

    Implement the IReportStore

  4. Create 'Implementation' folder.

  5. To the 'Implementation' folder, add ‘ReportStore.cs’ class which will contain implementation for IReportStore.

    ReportStore.cs Copy Code
    using GrapeCity.ActiveReports.Rendering.Tools;
using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports.Web.Viewer;
namespace BlazorDesignerServer.Implementation
{
    public class ReportStore : IReportStore
    {
        private static readonly string[] ReportExtensions =
        {
        ".rdl",
        ".rdlx",
        ".rdlx-master",
        ".rpx"
    };
        private readonly Dictionary<string, byte[]> _tempStorage = new Dictionary<string, byte[]>();
        private readonly DirectoryInfo _rootDirectory;
        public ReportStore(DirectoryInfo rootDirectory)
        {
            _rootDirectory = rootDirectory;
        }
        public ReportDescriptor GetReportDescriptor(string reportId)
        {
            if (_tempStorage.ContainsKey(reportId))
                return new ReportDescriptor(GetReportTypeByExtension(Path.GetExtension(reportId)));
            var fileInfo = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));
            return new ReportDescriptor(GetReportTypeByExtension(fileInfo.Extension));
        }
        public Stream LoadReport(string reportId)
        {
            if (_tempStorage.TryGetValue(reportId, out var tempReport))
                return new MemoryStream(tempReport);
            var file = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));
            //if (!file.Exists)
            //    throw new ReportNotFoundException();
            return file.OpenRead();
        }
        public string SaveReport(ReportType reportType, string reportId, Stream reportData, SaveSettings settings = SaveSettings.None)
        {
            if ((settings & SaveSettings.IsTemporary) != 0)
            {
                var tempName = Guid.NewGuid() + GetReportExtension(reportType);
                _tempStorage.Add(tempName, reportData.ToArray());
                return tempName;
            }
            var reportFullPath = Path.Combine(_rootDirectory.FullName, reportId);
            using var fileStream = new FileStream(reportFullPath, FileMode.Create, FileAccess.Write);
            reportData.CopyTo(fileStream);
            return reportId;
        }
        public string UpdateReport(ReportType reportType, string reportId, Stream reportData)
        {
            return SaveReport(reportType, reportId, reportData);
        }
        public ReportInfo[] ListReports()
        {
            var reports = _rootDirectory
                .EnumerateFiles("*.*")
                .Where(fileInfo => ReportExtensions.Any(ext =>
                    fileInfo.Extension.EndsWith(ext, StringComparison.InvariantCultureIgnoreCase)))
                .Select(fileInfo => new ReportInfo()
                {
                    Id = fileInfo.Name,
                    Name = fileInfo.Name,
                    ReportType = GetReportTypeByExtension(fileInfo.Extension),
                }).ToArray();
            return reports;
        }
        private static ReportType GetReportTypeByExtension(string extension)
        {
            switch (extension)
            {
                case ".rdl":
                case ".rdlx":
                    return ReportType.RdlXml;
                case ".rdlx-master":
                    return ReportType.RdlMasterXml;
                case ".rpx":
                    return ReportType.RpxXml;
                default:
                    throw new ArgumentOutOfRangeException(nameof(extension), extension, null);
            }
        }
        private static string GetReportExtension(ReportType type)
        {
            return type switch
            {
                ReportType.RdlXml => ".rdlx",
                ReportType.RdlMasterXml => ".rdlx-master",
                ReportType.RpxXml => ".rpx",
                _ => throw new ArgumentOutOfRangeException(nameof(type), type, null)
            };
        }
        public void DeleteReport(string reportId)
        {
            if (_tempStorage.ContainsKey(reportId))
            {
                _tempStorage.Remove(reportId);
                return;
            }
            var file = new FileInfo(Path.Combine(_rootDirectory.FullName, reportId));
            if (file.Exists)
                file.Delete(); ;
        }
    }
}

    Implement the IResourceRepositoryProvider

  6. Add 'ResourceProvider.cs' to the 'Implementation' folder to add implementation for IResourceRepositoryProvider.

    ResourceProvider.cs Copy Code
    using GrapeCity.ActiveReports.Rendering.Tools;
using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports;
namespace BlazorDesignerServer.Implementation
{
    public class ResourceProvider : IResourceRepositoryProvider
    {
        private const string SharedDataSourceExtension = ".rdsx";
        private readonly DirectoryInfo _rootDirectory;
        public ResourceProvider(DirectoryInfo rootDirectory)
        {
            _rootDirectory = rootDirectory;
        }
        public Stream GetResource(ResourceInfo resource)
        {
            string absolutePath = Path.Combine(_rootDirectory.FullName, resource.Name);
            var file = new FileInfo(absolutePath);
            if (!file.Exists)
                return null;
            return file.OpenRead();
        }
        public ResourceDescriptor[] ListResources(ResourceType resourceType)
        {
            if (resourceType == ResourceType.SharedDataSource)
            {
                var sharedDataSources = _rootDirectory
                    .EnumerateFiles("*" + SharedDataSourceExtension).Select(fileInfo =>
                    {
                        using var stream = fileInfo.OpenRead();
                        var dataSource = DataSourceTools.LoadSharedDataSource(stream);
                        return new SharedDataSourceResourceDescriptor()
                        {
                            Id = fileInfo.Name,
                            Name = fileInfo.Name,
                            Type = dataSource.ConnectionProperties.DataProvider
                        };
                    }).ToArray();
                return sharedDataSources;
            }
            return Enumerable.Empty<ResourceDescriptor>().ToArray();
        }
        public ResourceDescriptor[] DescribeResources(ResourceInfo[] resources)
        {
            return Enumerable.Empty<ResourceDescriptor>().ToArray();
        }
    }
}

    Configure and register services

  7. Open Program.cs and update the file as shown below. The Program.cs file does the following:

    1. configures the services and middleware used by the application
    2. registers the 'IReportStore' and 'IResourceRepositoryProvider' as singleton services
    3. adds reporting and designer services
    4. sets the path to the ActiveReports.config file where the SQLite provider is added
    5. configures the reporting and designer middleware
    6. serves static files
      The complete Program.cs is as shown.
      Program.cs Copy Code
      using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using Microsoft.AspNetCore.SignalR;
using System.Text;
using GrapeCity.ActiveReports.Web.Designer;
using BlazorDesignerServer.Implementation;
var builder = WebApplication.CreateBuilder(args);
var ResourcesRootDirectory =
    new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));
Encoding.RegisterProvider(CodePagesEncodingProvider.Instance);
// Add services to the container.
builder.Services.AddReportViewer();
builder.Services.AddReportDesigner();
builder.Services.AddSingleton<IReportStore>(new ReportStore(ResourcesRootDirectory));
builder.Services.AddSingleton<IResourceRepositoryProvider>(new ResourceProvider(ResourcesRootDirectory));
builder.Services.AddRazorPages().AddJsonOptions(options => options.JsonSerializerOptions.PropertyNamingPolicy = null);
builder.Services.AddServerSideBlazor();
builder.Services.Configure<HubOptions>(options =>
{
    options.MaximumReceiveMessageSize = 524288000; //500MB
});
builder.Services.AddCors();
var app = builder.Build();
// Configure the HTTP request pipeline.
if (!app.Environment.IsDevelopment())
{
    app.UseExceptionHandler("/Error");
}
// For use as a server for BlazorWebAssembly
app.UseCors(cors => cors.SetIsOriginAllowed(origin => new Uri(origin).Host == "localhost")
    .AllowAnyMethod()
    .AllowAnyHeader()
    .AllowCredentials()
    .WithExposedHeaders("Content-Disposition"));
var reportStore = app.Services.GetService<IReportStore>();
var resourceProvider = app.Services.GetService<IResourceRepositoryProvider>();
app.UseReportDesigner(config =>
{
    config.UseReportsProvider(reportStore);
    config.UseResourcesProvider(resourceProvider);
});
app.UseStaticFiles();
app.UseRouting();
app.MapControllers();
app.MapBlazorHub();
app.MapFallbackToPage("/_Host");
app.Run();
  8. Run the application.

  9. Go to the Data tab to add the data source.

  10. In the Data Source Editor dialog, select ‘Shared Reference’ as Provider and then the ‘.rdsx’ file as Reference. Shared Reference configuration in Data Source Editor dialog

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Configure Preview

Configure Preview
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application > Configure Preview

Glossary Item Box

This topic describes how to use the Blazor Viewer inside the Blazor Designer.

  1. In Microsoft Visual Studio 2022, open your Blazor Designer Application project.
  2. Add the following NuGet packages for the Blazor Viewer.
    MESCIUS.ActiveReports.Aspnetcore.Viewer (for Blazor Server only)
    MESCIUS.ActiveReports.Blazor.Viewer
  3. [For Blazor Server only] Update Program.cs as demonstrated in the code example below.
    Program.cs Copy Code
    using GrapeCity.ActiveReports.Aspnetcore.Designer;
using GrapeCity.ActiveReports.Aspnetcore.Viewer;
var resourcesRootDirectory = new DirectoryInfo(".\\resources\\");
var builder = WebApplication.CreateBuilder(args);
builder.Services.AddRazorPages();
builder.Services.AddServerSideBlazor();
builder.Services
     .AddReportViewer()
     .AddReportDesigner()
     .AddMvc(options => options.EnableEndpointRouting = false)
     .AddJsonOptions(options => options.JsonSerializerOptions.PropertyNamingPolicy =
null);
var app = builder.Build();
if (!app.Environment.IsDevelopment())
{
    // The default HSTS value is 30 days. You may want to change this for production
scenarios, see https://aka.ms/aspnetcore-hsts.
    app.UseHsts();
}
app.UseHttpsRedirection();
app.UseReportViewer(config => config.UseFileStore(resourcesRootDirectory));
app.UseReportDesigner(config => config.UseFileStore(resourcesRootDirectory, false));
app.UseStaticFiles();
app.UseRouting();
app.MapBlazorHub();
app.MapFallbackToPage("/_Host");
app.Run();
  4. Update 'Pages/Index.razor' as demonstrated in the code example below.
    Pages/Index.razor Copy Code
    @page "/"
@using GrapeCity.ActiveReports.Blazor.Designer;
@using GrapeCity.ActiveReports.Blazor.Viewer
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css"
rel="stylesheet" />
<div style="height:100vh;width:100%">
     <ReportDesigner @ref="_designer" Document="@_document" Preview="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private ReportViewer _viewer;
    private Document _document = new Document() { Id = "report.rdlx", Type =
SupportedDocumentType.cpl };
    private Preview _preview;
    public Index()
    {
        _preview = new Preview()
            {
                CanPreview = true,
                OpenViewer = OpenViewer
            };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if (_viewer != null)
        {
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        _viewer = new ReportViewer();
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}
  5. Build and run the application.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Blazor WebDesigner API

Blazor WebDesigner API
See Also
Developers > Create Designer and Viewer Applications > Blazor WebDesigner Application > Blazor WebDesigner API

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides a rich API for integrating the Blazor web designer components into your web application. To embed the Blazor WebDesigner component in your project, use the Blazor WebDesigner API. It lets you create, design, and save reports with added capabilities that include defining the locale for the designer, customizing the default settings of the report items, managing the Data and Properties tab, modifying the application info, and much more.

GlobalDesignerAPI

Type of GrapeCity.ActiveReports.Blazor.Designer.ReportDesigner object exported by the GrapeCity.ActiveReports.Blazor.Designer library.

ReportDesigner

Renders the ReportDesigner component to the <div> element. Use the following example for "*.razor" pages.

Parameter (Type):

PreviewSettings: PreviewSettings

Return: Renders the ReportDesigner component for the user interface.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

AppBarSettings

Gets or sets the settings for the application bar component.

Parameter (Type):

AppBarSettings: AppBarSettings
  • OpenButton: OpenButton

    Description: Gets or sets the OpenButton button settings.
    Return: Returns the OpenButton object representing the Open button settings.

  • AboutButton: AboutButton

    Description: Gets or sets the AboutButton button settings.
    Return: Returns the AboutButton object representing the About button settings.

  • ContextActionsTab: ContextActionsTab

    Description: Gets or sets the Context Actions tab settings.
    Return: Returns the ContextActionsTab object representing the Context Actions tab settings.

  • HomeTab: HomeTab

    Description: Gets or sets the Home tab settings.
    Return: Returns the HomeTab object representing the Home tab settings.

  • InsertTab: InsertTab

    Description: Gets or sets the Insert tab settings.
    Return: Returns the InsertTab object representing the Insert tab settings.

  • ParametersTab: ParametersTab

    Description: Gets or sets the Parameters tab settings.
    Return: Returns the ParametersTab object representing the Parameters tab settings.

  • SaveAsButton: SaveAsButton

    Description: Gets or sets the SaveAs button settings.
    Return: Returns the SaveAsButton object representing the SaveAs button settings.

  • SaveButton: SaveButton

    Description: Gets or sets the Save button settings.
    Return: Returns the SaveButton object representing the Save button settings.

  • ScriptTab: ScriptTab

    Description: Gets or sets the Script tab settings.
    Return: Returns the ScriptTab object representing the Script tab settings.

  • Visible: bool?

    Description: Gets or sets whether to show the Application bar.
    Return: Returns a value representing whether the application bar should be displayed.

Return: Returns an AppBarSettings object containing the settings for the Application bar.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner AppBarSettings="@_appBar" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private AppBarSettings _appBar = new AppBarSettings
    {
        OpenButton = new OpenButton { Visible = true },
        AboutButton = new AboutButton { Visible = false },
        ContextActionsTab = new ContextActionsTab { Visible = true },
        HomeTab = new HomeTab { Visible = true },
        InsertTab = new InsertTab { Visible = false },
        ParametersTab = new ParametersTab { Visible = true },
        SaveAsButton = new SaveAsButton { Visible = false },
        SaveButton = new SaveButton { Visible = false },
        ScriptTab = new ScriptTab { Visible = false },
        Visible = false
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

App

Gets the application API.

Parameter (Type):

App: GrapeCity.ActiveReports.Blazor.Designer.App
  • Panels: Panels

    Description: Contains access to the Menu and Sidebar panels.
    Return: Returns the Panels object representing the menu and sidebar panels.

  • Focus(): Task

    Description: Returns focus to the Designer. Focus may be lost when plug-in components are opened/closed. Returning focus is essential to continue using Designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.
    Return: The Task object represents an asynchronous operation.

  • GetAbout(): ValueTask<About>

    Description: Returns documentation links and application information.
    Return: The ValueTask<About> object representing references to documentation and information about the application.

Return: Returns the application API.

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = true,
            OpenViewer = OpenViewer
        };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if (_viewer != null)
        {
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        _viewer = new ReportViewer();
        GrapeCity.ActiveReports.Blazor.Designer.App api = _designer.App;
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        initOptions.ReportLoaded = (reportInfo) => { };
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}

DataSettings

Sets the data settings for the report designer component.

Parameter (Type):

DataSettings: DataSettings
  • CommonValues: CommonValues

    Description: Gets or sets the Common Values' section settings.
    Return: Returns the Common Values' section settings.

  • DataSets: DataSets

    Description: Gets or sets the Data Sets' section settings.
    Return: Returns the Data Sets' section settings.

  • DataSources: DataSources

    Description: Gets or sets the Data Sources' section settings.
    Return: Returns the Data Sources' section settings.

  • DataTab: DataTab

    Description: Gets or sets the Data Tab's section settings.
    Return: Returns the Data Tab's section settings.

  • Parameters: Parameters

    Description: Gets or sets the Parameters' section settings.
    Return: Returns the Parameters' section settings.

Return: Returns a DataSettings object containing the settings for the data.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DataSettings="@_dataSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private DataSettings _dataSettings = new DataSettings
    {
        DataSets = new DataSets { CanModify = true },
        DataSources = new DataSources { CanModify = true },
        DataSources = new DataSources { CanModify = true,
             Shared = new SharedDataSourceOptions()
             {
                Enabled = true
             }
        },
        DataTab = new DataTab { Visible = true },
        Parameters = new Parameters() { CanModify = true },
        CommonValues = new CommonValues() { Visible = false }
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

DesignerInitialized

Gets or sets the callback that is invoked when a Designer is initialized.

Parameter (Type):

DesignerInitialized: Action

Return: Returns an Action object containing the action that is called after the initialization of the designer.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DesignerInitialized="@DesignerInitializedCallback" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private void DesignerInitializedCallback() { }
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

DisableFocusTimer

Disables the focus timer. By default, focused elements (like buttons) are highlighted only for a short period of time after the Tab key is pressed. This setting makes focused elements permanently highlighted.

Parameter (Type):

DisableFocusTimer: Boolean

Return: Returns the current state of an item's focus.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DisableFocusTimer="true" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

DisableSystemClipboard

Disables the usage of the system clipboard.

Parameter (Type):

DisableSystemClipboard: Boolean

Return: Returns the current state of disabling the use of the system clipboard.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DisableSystemClipboard="true" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Document

Opens the specified document.

Parameter (Type):

Document: Document
  • Type: SupportedDocumentType

    Description: Gets or sets the supported report type. The available values are SupportedDocumentType.fpl, SupportedDocumentType.rpx, SupportedDocumentType.dashboard, SupportedDocumentType.msl, and SupportedDocumentType.cpl.
    Return: Returns the supported report type.

  • Id: String

    Description: Gets or sets the report identifier.
    Return: Returns the report identifier.

Return: Returns the specified document.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Document="@_doc" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private Document _doc = new Document()
    {
        Type = SupportedDocumentType.cpl,
        Id = "Example.rdlx"
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Documents

Gets the document API.

Parameter (Type):

Documents: Documents
  • Create(CreateDocumentOptions options): ValueTask<CreateDocumentInfo>

    Description: Creates a new report to be edited in a designer using the specified CreateReportOptions object.
    Return: Returns the ValueTask<CreateDocumentInfo> object representing the information about the created document.

  • HasUnsavedChanges(): ValueTask<bool>

    Description: Indicates whether the report has unsaved changes.
    Return: Returns the ValueTask<bool> representing the presence of unsaved changes.

  • Info(): ValueTask<CurrentDocumentInfo>

    Description: Returns information about the currently edited report.
    Return: Returns the ValueTask<CurrentDocumentInfo> object representing the document information.

  • IsNew(): ValueTask<bool>

    Description: Indicates whether report was saved before at least once.
    Return: Returns the ValueTask<bool> object representing whether the report was saved at least once.

  • Open(): Task

    Description: Shows open report dialog.
    Return: The Task object represents an asynchronous operation.

  • OpenById(string id, SupportedDocumentType type, string name = null, string content = null): ValueTask<OpenDocumentInfo>

    Description: Opens an existing report to be edited in the Designer with the specified id. Optionally, you can pass the name and the content, else, the report is loaded from the server.
    Return: The ValueTask<OpenDocumentInfo>object representing information about the opened document.

  • Save(): Task

    Description: Saves the report currently edited in Designer. If the report is new, then the "Save As" dialog is opened.
    Return: The Task object representing an asynchronous operation.

  • SaveAs(): Task

    Description: Opens 'Save As' dialog.
    Return: The Task object represents an asynchronous operation.

  • SaveById(string id, string name = null) : ValueTask<SaveDocumentInfo>

    Description: Saves the report currently edited in Designer using the specified id.
    Return: The ValueTask<SaveDocumentInfo> object representing a saved document information.

  • SaveByName(string name): ValueTask<SaveDocumentInfo>

    Description: Saves the report currently edited in Designer using the specified name.
    Return: The ValueTask<SaveDocumentInfo> object representing a saved document information.

Return: Returns the document API.

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner @ref="_designer" Document="@_doc" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    private Document _doc = new Document
    {
        Id = "Example.rdlx",
        Type = SupportedDocumentType.cpl
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = true,
            OpenViewer = OpenViewer
        };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if(_viewer != null)
        {
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        Documents api = _designer.Documents;
        _viewer = new ReportViewer();
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        initOptions.ReportLoaded = (reportInfo) => { };
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}

DocumentsSettings

Gets or sets the API settings for documents.

Parameter (Type):

DocumentsSettings: DocumentsSettings
  • FileView: FileView

    Description: Gets or sets the file view settings.
    Return: Returns the current value of the file view settings.

  • Handlers: Handlers

    Description: Gets or sets the handlers.
    Return: Returns the current value of the handlers.

    • OnDocumentChanged: A handler that is triggered when report content is changed.
      This function takes an object as an argument that contains two properties:
      • document: The document property contains the updated version of the document that was changed
      • hasUnsavedChanges: The hasUnsavedChanges is a boolean value that indicates whether there are any unsaved changes in the document.

Return: Returns the specified settings for documents API.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DocumentsSettings="@_documentsSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private DocumentsSettings _documentsSettings = new DocumentsSettings
    {
        FileView = new FileView { Visible = true },
        Handlers = new Handlers()
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}
Sample Code for OnDocumentChanged handler Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DocumentsSettings="_documentsSettings"/>
</div>
@code {
    private DocumentsSettings _documentsSettings;
    public Index()
    {
        _documentsSettings = new DocumentsSettings()
        {
            Handlers = new Handlers()
            {
                OnDocumentChanged = (options) =>
                {
                    ...
                }
            }
        };
    }
}

EditorSettings

Gets or sets the editor settings.

Parameter (Type):

EditorSettings: EditorSettings
  • ShowGrid: bool?

    Description: Specifies if the Grid must be shown or hidden by default.
    Return: Returns the current value of the grid display.

  • SnapToGrid: bool?

    Description: Specifies the default value for the snapToGrid option.
    Return: Returns the current snapToGrid option value.

  • SnapToGuides: bool?

    Description: Specifies the default value for the snapToGuides option.
    Return: Returns the current snapToGuides option value.

  • GridSize: String

    Description: Specifies the default Grid Size. If units = 'cm', value = 0.5cm by default. Else, value = 0.25in by default.
    Return: Returns the current Grid Size.

  • Rulers: Rulers

    Description: Gets or sets the Ruler's settings.
    Return: Returns the current Ruler's settings.

Return: Returns the set editor settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner EditorSettings="@_editorSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private EditorSettings _editorSettings = new EditorSettings
    {
        ShowGrid = true,
        SnapToGrid = true,
        SnapToGuides = true,
        Rulers = new Rulers(),
        GridSize = "0.5cm"
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Fonts

Gets or sets the list of allowed fonts for controls.

Parameter (Type):

Fonts: Object[]

Return: Returns the set list of allowed fonts for controls.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Fonts="@_fonts" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private string[] _fonts = new string[1] { "Arial" };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Height

Gets or sets the height of the designer.

Parameter (Type):

Height: String

Return: Returns the height of the designer.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Height="20%" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

ImageMimeTypes

Gets or sets the list of allowed image mime types for controls.

Parameter (Type):

ImageMimeTypes: String[]

Return: Returns the set list of allowed image mime types for controls.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner ImageMimeTypes="@_imageMimeTypes" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private string[] _imageMimeTypes = new string[3] { "image/gif", "image/jpeg", "image/png" };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Language

Gets or sets the language of the report designer. Use 'en-US' (for English), 'ja-JP' (for Japanese), and 'zh-CN' (for simplified Chinese).

Parameter (Type):

Language: String

Return: Returns the specified language.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Language="ja-JP" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

LocalizationResources

Gets or sets a custom resource localization.

Parameter (Type):

LocalizationResources: LocalizationResources[]
  • Language: String

    Description: Gets or sets the Language.
    Return: Returns the specified language.

  • Resources: String

    Description: Gets or sets the localization resources in json array.
    Return: Returns the specified localization resources represented in the json array.

Return: Returns an array of custom localization resources.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner LocalizationResources="@_localizationResources" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private LocalizationResources[] _localizationResources =
    {
        new LocalizationResources()
        {
            Language = "en",
            Resources = "[ { \"ns\": \"common\", \"lng\": \"en\", \"resources\": { \"units\": { \"cm\": { \"textShortName\": \"CustomName_cm\", \"textFullName\": \"CustomName_Centimeters\" } } } } ]"
        }
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

LockLayout

Manages the interaction with the Layout. When LockLayout is enabled, it is only possible to modify the properties of existing report items, i.e., operations such as adding a new report item or deleting an existing one, and modifying the report layout structure is not possible.

Parameter (Type):

LockLayout: Boolean

Return: Returns the current state of the lock layout.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner LockLayout="true" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

MenuSettings

Get or sets the menu settings.

Parameter (Type):

MenuSettings: MenuSettings
  • DocumentExplorer: DocumentExplorer

    Description: Document/Report Explorer settings.
    Return: Returns an object representing the Document/Report Explorer settings.

  • GroupEditor: GroupEditor

    Description: Group Editor settings.
    Return: Returns an object representing the Group Editor settings.

  • LayerEditor: LayerEditor

    Description: Layer Editor settings.
    Return: Returns an object representing the Layer Editor settings.

  • Logo: Logo

    Description: Logo settings.
    Return: Returns an object representing the Logo settings.

  • ToolBox: ToolBox

    Description: ToolBox settings.
    Return: Returns an object representing the ToolBox settings.

  • Visible: bool?

    Description: Specifies whether Main Menu needs to be shown.
    Return: Returns a value representing the current visibility state.

Return: Returns the current settings of the menu.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner MenuSettings="@_menuSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private MenuSettings _menuSettings = new MenuSettings
    {
        DocumentExplorer = new DocumentExplorer { Visible = true },
        GroupEditor = new GroupEditor { Visible = true },
        LayerEditor = new LayerEditor { Visible = true },
        Logo = new Logo { Visible = true },
        ToolBox = new ToolBox { Visible = true },
        Visible = true
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

Notifications

Gets the notifications API.

Parameter (Type):

Notifications: Notifications
  • Send(): Task

    Description: Sends a notification of specified level, caption, and content.
    Return: The Task object representing an asynchronous operation.

  • Warning(): Task

    Description: Sends a warning notification.
    Return: The Task object representing an asynchronous operation.

  • Info(): Task

    Description: Sends a general notification. It can be used to notify when any user-initiated action is completed.
    Return: The Task object representing an asynchronous operation.

  • Error(): Task

    Description: Sends an error notification.
    Return: The Task object representing an asynchronous operation.

  • DismissAll(): Task

    Description: Dismisses all notifications.
    Return: The Task object representing an asynchronous operation.

Return: Returns the notifications API.

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = true,
            OpenViewer = OpenViewer
        };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if (_viewer != null)
        {
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        Notifications api = _designer.Notifications;
        _viewer = new ReportViewer();
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        initOptions.ReportLoaded = (reportInfo) => { };
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}

PreviewSettings

Gets or sets the preview settings.

Parameter (Type):

PreviewSettings: PreviewSettings
  • CanPreview(): Boolean

    Description: Sets or gets whether to show the Preview button.

  • OpenViewer(): Action<ViewerSettings>

    Description: You can plug-in Viewer component by providing OpenViewer function.

Return: Returns the preview settings.

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = true,
             OpenViewer = OpenViewer
         };
    }
    private async void OpenViewer(ViewerSettings settings)
    {
        if (_viewer != null)
        {
            await _viewer.OpenReport(settings.DocumentInfo.Id);
            return;
        }
        _viewer = new ReportViewer();
        var initOptions = new InitializationOptions();
        initOptions.ReportID = settings.DocumentInfo.Id;
        initOptions.PanelsLocation = PanelsLocation.toolbar;
        initOptions.ReportLoaded = (reportInfo) => { };
        await _viewer.Render(JSRuntime, settings.Element, initOptions);
    }
}

PropertyGridSettings

Gets or sets the property grid settings.

Parameter (Type):

PropertyGridSettings: PropertyGridSettings
  • PropertiesTab: PropertiesTab

    Description: Sets or gets properties tab settings.
    Return: The PropertiesTab object representing the current settings of properties tab.

  • Mode(): Mode?

    Description: Specifies default properties mode. The available values are Mode.Basic and Courier New Mode.Advanced.
    Return: The current mode of the properties tab settings.

  • Sort(): Sort?

    Description: Specifies default properties sort mode. The available values are Sort.categorized and Sort.alphabetical.
    Return: The current sort of the properties tab settings

Return: The PropertyGridSettings representing the current settings for the property grid.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner PropertyGridSettings="@_propertyGridSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private PropertyGridSettings _propertyGridSettings = new PropertyGridSettings
    {
        Mode = Mode.Advanced,
        Sort = Sort.categorized,
        PropertiesTab = new PropertiesTab { Visible = false }
    };
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

RdlxSettings

Gets or sets the RDLX platform-specific settings.

Parameter (Type):

RdlxSettings: RdlxSettings
  • ExpressionSyntax: ExpressionSyntax?

    Description: Gets or sets the expression syntax used in Designer. The available values are ExpressionSyntax.i11n and ExpressionSyntax.rdl.
    Return: The object representing the current expression syntax settings.

  • ToolBoxContent: ToolBoxContent

    Description: Gets or sets the report items available and their order.
    Return: The ToolBoxContent object representing the available report elements with the current settings and their order.

  • InitTemplates: InitTemplates

    Description: Gets or sets the reports as rdlx-json strings. Report items from these reports are used as templates for creating new items.
    Return: The InitTemplates object representing the current templates settings.

  • ReportItemsFeatures: RdlxReportItemsSettings

    Description: Gets or sets the customizable report item features.
    Return: The RdlxReportItemsSettings object representing the current customizable report item features.

  • ReportStyles: ReportStyles[]

    Description: Gets or sets the additional styles to add to report item styles.
    Return: The array of ReportStyles objects representing the current additional styles to add to the report element styles.

  • Msl: Msl

    Description: Gets or sets the RDLX Multi-Section report settings.
    Return: The Msl object representing the current RDLX Multi-Section report settings.

  • Dashboard: Dashboard

    Description: Gets or sets the RDLX Dashboard reports settings.
    Return: The Dashboard object representing the current RDLX Dashboard report settings.

Return: The RdlxSettings object representing the current rdlx report settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner RdlxSettings="@_rdlxSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private RdlxSettings _rdlxSettings = new RdlxSettings
    {
        Dashboard = new Dashboard { Enabled = true },
        Msl = new Msl { Enabled = true },
        ExpressionSyntax = ExpressionSyntax.rdl,
        InitTemplates = new InitTemplates(),
        ReportItemsFeatures = new RdlxReportItemsSettings(),
        ReportStyles = { },
        ToolBoxContent = new ToolBoxContent { Cpl = new[] { RdlxToolBoxItem.formattedtext } }
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

RpxSettings

Gets or sets the RPX platform-specific settings. To set these settings, an RPX report must exist.

Parameter (Type):

RpxSettings: RpxSettings
  • Enabled: bool?

    Description: Gets or sets the activation value of RPX reports.
    Return: The object represents the current activation value of RPX reports.

  • InitTemplates: InitTemplates

    Description: Gets or sets the reports as json strings. Report items from these reports are used as templates for creating new items.
    Return: The InitTemplates object representing the current templates settings.

Return: The RpxSettings object representing the current rpx reports settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner RpxSettings="@_rpxSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private RpxSettings _rpxSettings = new RpxSettings
    {
        Enabled = true,
        InitTemplates = new InitTemplates()
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

ServerSettings

Gets or sets the back end-related settings.

Parameter (Type):

ServerSettings: ServerSettings
  • Url: String

    Description: Gets or sets the base URL for Designer Server API.
    Return: The string representing the current base URL for Designer Server API.

  • OnBeforeRequest: Func<RequestInit, RequestInit>

    Description: Gets or sets the handler to modify requests.
    Return: The Func<RequestInit, RequestInit> object representing the current handler to modify requests.

Return: The ServerSettings object representing the current back end-related settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner ServerSettings="@_serverSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private ServerSettings _serverSettings = new ServerSettings
    {
        OnBeforeRequest = delegate (RequestInit requestInit)
        {
            return requestInit;
        },
        Url = "http://localhost:5098/"
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

StatusBarSettings

Gets or sets the status bar settings.

Parameter (Type):

StatusBarSettings: StatusBarSettings
  • ToggleUnitsButton: ToggleUnitsButton

    Description: Gets or sets the toggle units button settings.
    Return: The ToggleUnitsButton object representing the current toggle units button settings.

  • GridSizeEditor: GridSizeEditor

    Description: Gets or sets the grid size editor settings.
    Return: The GridSizeEditor object representing the current grid size editor settings.

  • RulersButton: RulersButton

    Description: Gets or sets the rulers button settings.
    Return: The RulersButton object representing the current rulers button settings.

  • Visible: bool?

    Description: Gets or sets the visibility of the status bar.
    Return: The value representing the current visibility of the status bar settings.

Return: The StatusBarSettings object represented the current status bar settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner StatusBarSettings="@_statusBarSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private StatusBarSettings _statusBarSettings = new StatusBarSettings
    {
        GridSizeEditor = new GridSizeEditor { Visible = true },
        PropertiesModeButton = new PropertiesModeButton { Visible = true },
        RulersButton = new RulersButton { Visible = true },
        ToggleGridButton = new ToggleGridButton { Visible = true },
        ToggleUnitsButton = new ToggleUnitsButton { Visible = true },
        Visible = true
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

StoreUnsavedReport

Manages the report retention. When StoreUnsavedReport is enabled, the last unsaved report can be restored if a browser tab or the browser itself gets accidentally closed.

Parameter (Type):

StoreUnsavedReport: Bool

Return: The value representing the current state of the StoreUnsavedReport.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner StoreUnsavedReport="false" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

StoreUserPreferences

Manages the user preferences. When StoreUserPreferences is enabled, user preferences are saved to a browser storage.

Parameter (Type):

StoreUserPreferences: Bool

Return: The value representing the current state of the StoreUserPreferences.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner StoreUserPreferences="false" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

StylesSettings

Gets or sets the RPX Styles-related settings.

Parameter (Type):

StylesSettings: StylesSettings
  • StylesTab: StylesTab

    Description: Gets or sets the styles tab settings.
    Return: The StylesTab object representing the current styles tab settings.

  • Stylesheet: Stylesheet

    Description: Gets or sets the Stylesheet settings.
    Return: The Stylesheet object representing the current Stylesheet settings.

Return: The StylesSettings object representing the current RPX styles-related settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner StylesSettings="@_styleSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private StylesSettings _styleSettings = new StylesSettings
    {
        Stylesheet = new Stylesheet { CanModify = true },
        StylesTab = new StylesTab { Visible = true }
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

TitleSettings

Gets or sets the document title settings.

Parameter (Type):

TitleSettings: TitleSettings
  • Disabled: bool?

    Description: Gets or sets whether the document title is disabled.
    Return: The value representing whether the document title is disabled.

Return: The TitleSettings object representing the current document title settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner TitleSettings="@_titleSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private TitleSettings _titleSettings = new TitleSettings
    {
        Disabled = false
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

ToolBarSettings

Gets or sets the ToolBar settings.

Parameter (Type):

ToolBarSettings: ToolBarSettings
  • Visible: bool?

    Description: Gets or sets the visibility of ToolBar.
    Return: The value represented the visibility of ToolBar.

Return: The ToolBarSettings object represented the current ToolBar settings.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner ToolBarSettings="@_toolbarSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private ToolBarSettings _toolbarSettings = new ToolBarSettings
    {
        Visible = true
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

Units

Gets or sets the default measurement units of the report designer. The available values are Units.In and Units.Cm

Parameter (Type):

Units: Units

Return: The current value of default measurement units of the report designer.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Units="Units.Cm" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

Width

Gets or sets the width of the designer.

Parameter (Type):

Width: String

Return: Returns the width of the designer.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner Width="20%" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

OpenDocumentExplorer

Manages the panels of the Designer API. To manage panels from the Blazor Designer API, use the following example for "*.razor" pages.

In this example, the explorer panel is called for a report using the Blazor Designer API.

  • Add the call button code.
    Copy Code
    <button @onclick="OpenDocumentExplorer">Open document explorer</button>
  • Add the button click handler code.
    Copy Code
    private async void OpenDocumentExplorer()
{
    await _designer.App.Panels.Menu.Open("document-explorer");
}

The complete code is as follows:

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<button @onclick="OpenDocumentExplorer">Open document explorer</button>
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    private async void OpenDocumentExplorer()
    {
        await _designer.App.Panels.Menu.Open("document-explorer");
    }
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

UndoLastOperation

Manages the clipboard and state selectors of the application API. To manage the clipboard and state selectors of the application API, use the following example for "*.razor" pages.

This example implements undoing the last operation in the designer using the custom button.

  • Add the call button code.
    Copy Code
    <button @onclick="UndoLastOperation">Undo the last operation</button>
  • Add the button click handler code.
    Copy Code
    private async void UndoLastOperation()
{
    await _designer.App.Editor.Undo();
}

The complete code is as follows:

Sample Code Copy Code
@page "/"
@inject IJSRuntime JSRuntime
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<button @onclick="UndoLastOperation">Undo the last operation</button>
<div id="designerContainer">
    <ReportDesigner @ref="_designer" PreviewSettings="@_preview" />
</div>
@code {
    private ReportDesigner _designer;
    private PreviewSettings _preview;
    private ReportViewer _viewer;
    private async void UndoLastOperation()
    {
        await _designer.App.Editor.Undo();
    }
    public Index()
    {
        _preview = new PreviewSettings
        {
            CanPreview = false
        };
    }
}

ReportDesigner

Renders the ReportDesigner component to the <div> element. Use the following example for "*.razor" pages.

Parameter (Type):

PreviewSettings: PreviewSettings

Return: Renders

DateFormats

Gets or sets the list of supported date formats. These settings are only used during the initialization and cannot be changed afterward.

Parameter(Type):

DateFormats: String[]

Return: Returns the list of supported date formats.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner DateFormats="@_dateFormats" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private string[] _dateFormats = { /* Your date formats. */ };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

ThemesSettings

Represents the settings for themes, allowing configuration of the default theme, detection of dark mode, available themes for user selection, and settings for the theme picker.

Parameter(Type):

  • Default: string
    Description: Gets or sets the default theme to be applied. Predefined themes: "default", "activeReports", "activeReportsDark", "defaultDark", "darkOled", "highContrast", "highContrastDark".
  • List: string[] or GrapeCity.ActiveReports.Blazor.Viewer.UITheme[]
    Description: Gets ot sets the array of available themes that can be picked by the user. Can be a string or a GrapeCity.ActiveReports.Blazor.Viewer.UITheme.
  • Picker: PickerSettings
    Description: Represents the settings for the theme picker in the UI.
    • Enabled: bool?
      Description: Indicates whether the theme picker should be shown in the UI.

Return: Returns the settings for themes.

Sample Code Copy Code
@page "/"
<link href="_content/GrapeCity.ActiveReports.Blazor.Viewer/jsViewer.min.css" rel="stylesheet" />
<div id="designerContainer">
    <ReportDesigner ThemesSettings="@_themesSettings" PreviewSettings="@_preview" />
</div>
@code {
    private PreviewSettings _preview;
    private ThemesSettings _themesSettings = new ThemesSettings
    {
        Default = "default",

        List = new string[] { /* Your themes. */ },
        Picker = new PickerSettings
        {
            Enabled = true
        }
    };
    public Index()
    {
         _preview = new PreviewSettings
         {
             CanPreview = false
         };
    }
}

Default Constructor

Initializes a new instance of the class ReportDesigner.

Sample Code Copy Code
ReportDesigner _designer = new ReportDesigner();

See Also

Reference
MESCIUS.ActiveReports.Blazor.Designer Assembly

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


End User Report Designer in WinForms Application

End User Report Designer in WinForms Application
See Also
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application

Glossary Item Box

Note: This is a Professional Edition feature. See ActiveReports Editions for details.

The End User Report Designer control is a run-time designer that may be distributed royalty-free. It allows the ActiveReports designer to be hosted in an application and provides end-user report editing capabilities. The control's methods and properties provide easy access for saving and loading report layouts, monitoring and controlling the design environment, and customizing the look and feel to the needs of end users.

See Also

Create Basic End User Report Designer
Set High DPI Support
Use End-User Report Designer API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Basic End User Report Designer

Create Basic End User Report Designer
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Create Basic End User Report Designer

Glossary Item Box

This topic demonstrates how to set up a basic End-User Report Designer on a Windows Forms application in the Professional Edition of ActiveReports.

End User Report Designer

Add the Designer control to the Form

You will add the Designer that could only edit and preview a report file.

  1. Create a new Windows Forms App project in Visual Studio 2022.
  2. In the Name field, rename the file to 'CustomEUD' and click Next.
  3. In the Additional Information screen, select a Framework and click Create.
  4. Install following two packages to make ActiveReports 19 toolbox and the Designer control available in Visual Studio:
    • MESCIUS.ActiveReports
    • MESCIUS.ActiveReports.Design.Win
  5. Select a Form and go to the Properties Panel to change the Name property to frmMain and the Text property to ActiveReports.
  6. Resize the Form so that you can accommodate the controls listed further.
  7. From the Visual Studio toolbox, drag the Designer control onto the Form and rename it to '_designer'.
  8. From the Visual Studio toolbox, drag the Toolbox control onto the Form and rename it to 'toolbox'.
  9. To attach the toolbox control to the designer control, in the Solution Explorer, right-click Form1.cs and select View Code.
  10. Add the following code (marked in bold) after the InitializeComponent method.
    C# code. Paste AFTER the InitializeComponent method Copy Code
    public frmMain()
    {
    InitializeComponent();
    _designer.Toolbox = toolbox;
    }
  11. At the top of the code view, add a using directive.
    C# code. Paste at the top of the Form1 code view Copy Code
    using GrapeCity.ActiveReports.Design;

Load and/or save the report file

  1. From the Visual Studio Menus & Toolbars toolbox group, drag the MenuStrip control onto the Form.
  2. Create the following structure for the MenuStrip control: File > Open, File > Save As.

  3. On the Form, double-click the Open menu item and paste the following code (marked in bold) into the openToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the openToolStripMenuItem_Click handler Copy Code
    private void openToolStripMenuItem_Click(object sender, EventArgs e)
    {
    OpenFileDialog openFileDialog = new OpenFileDialog();
    var dialogResult = openFileDialog.ShowDialog();
    if (dialogResult == System.Windows.Forms.DialogResult.OK)
    {
    _designer.LoadReport(new System.IO.FileInfo(openFileDialog.FileName));
    }
    }
  4. On the Form, double-click the Save As menu item and paste the following code (marked in bold) into the saveAsToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the openToolStripMenuItem_Click handler Copy Code
    private void saveAsToolStripMenuItem_Click(object sender, EventArgs e)
    {
    SaveFileDialog saveFileDialog = new SaveFileDialog();
    saveFileDialog.Filter = GetSaveFilter();
    var dialogResult = saveFileDialog.ShowDialog();
    if (dialogResult == System.Windows.Forms.DialogResult.OK)
    {
    _designer.SaveReport(new System.IO.FileInfo(saveFileDialog.FileName));
    }
    }
  5. After the saveAsToolStripMenuItem_Click handler code, add the code for the GetSaveFilter method as follows.
    C# code. Paste AFTER the saveAsToolStripMenuItem_Click handler Copy Code
    private string GetSaveFilter()
    {
    switch (_designer.ReportType)
    {
    case DesignerReportType.Section:
    return "Section Report Files (*.rpx)|*.rpx";
    case DesignerReportType.Page:
    return "Page Report Files (*.rdlx)|*.rdlx";
    case DesignerReportType.RdlMultiSection|DesignerReportType.RdlDashboard:
    return "RDLX Report Files (*.rdlx)|*.rdlx";
    default:
    return "RDLX Report Files (*.rdlx)|*.rdlx";
    }
    }

Create a new report based on a chosen type

  1. Create the following structure for the MenuStrip control: File > New report > RDLX, RDLX Dashboard, Page, Section.

  2. Double-click the RDLX MenuStrip item and add the following code (marked in bold) into the rdlxToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the rdlxToolStripMenuItem_Click handler Copy Code

    private void rdlxToolStripMenuItem_Click(object sender, EventArgs e)
    {
    _designer.NewReport(DesignerReportType.RdlMultiSection);

    }

  3. Double-click the RDLX Dashboard MenuStrip item and add the following code (marked in bold) into the rdlxdashboardToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the rdlxdashboardToolStripMenuItem_Click handler Copy Code

    private void rdlxdashboardToolStripMenuItem_Click(object sender, EventArgs e)
    {
    _designer.NewReport(DesignerReportType.RdlDashboard);

    }

  4. Double-click the Page MenuStrip item and add the following code (marked in bold) into the pageToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the pageToolStripMenuItem_Click handler Copy Code
    private void pageToolStripMenuItem_Click(object sender, EventArgs e)
    {
    _designer.NewReport(DesignerReportType.Page);
     }
  5. Double-click the Section MenuStrip item and add the following code (marked in bold) into the sectionToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the sectionToolStripMenuItem_Click handler Copy Code
    private void sectionToolStripMenuItem_Click(object sender, EventArgs e)
    {
    _designer.NewReport(DesignerReportType.Section);
    }

Add the Export option

  1. Install packages from NuGet as follows:
    i) Go to Tools > NuGet Package Manager > Manage NuGet Packages for Solution...
    ii) Browse the following package and click Install.

    Copy Code
    MESCIUS.ActiveReports.Export.Pdf
  2. At the top of the code view, add using statements.
    C# code. Paste at the top of the Form1 code view Copy Code
    using GrapeCity.ActiveReports.Export.Pdf.Page;
using GrapeCity.ActiveReports.Rendering.IO;
using GrapeCity.ActiveReports;
using System.IO;
  3. In the MenuStrip control, add the Export menu item to the File menu.

  4. In the Properties Panel, set the Enabled property to False. This enables the Export menu item to be displayed in the Preview mode only.
  5. To enable the Export menu item to be displayed for all report types, except Section report, add the following code (marked in bold) after the InitializeComponent method.
    C# code. Paste AFTER the InitializeComponent method Copy Code
    public frmMain()
    {
    InitializeComponent();
    _designer.Toolbox = toolbox;
    _designer.ActiveTabChanged += designer_ActiveTabChanged;
    }
    void designer_ActiveTabChanged(object sender, EventArgs e)
    {
    exportToolStripMenuItem.Enabled = _designer.ActiveTab == DesignerTab.Preview && _designer.ReportType != DesignerReportType.Section;
     }

  6. On the Form, double-click the Export item and add the following code (marked in bold) to the exportToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the exportToolStripMenuItem_Click handler Copy Code

    private void exportToolStripMenuItem_Click(object sender, EventArgs e)
    {
    SaveFileDialog saveFileDialog = new SaveFileDialog();
    saveFileDialog.Filter = "Pdf (*.pdf)|*.pdf";
    var dialogResult = saveFileDialog.ShowDialog();
    if (dialogResult == System.Windows.Forms.DialogResult.OK)
    {
    var pdfRe = new PdfRenderingExtension();
    var msp = new MemoryStreamProvider();
    (_designer.Report as PageReport).Document.Render(pdfRe, msp);
    using (var stream = msp.GetPrimaryStream().OpenStream())
    using (var fileStream = new FileStream(saveFileDialog.FileName, FileMode.Create, FileAccess.Write))
    {
    stream.CopyTo(fileStream);
    }
    MessageBox.Show("Export is done");
    }

    }

For more information on export filters, rendering extensions and their settings, see Export Reports.

Add other controls to the Form

  1. From the Visual Studio toolbox, drag the following controls onto the Form.
    Control/Container | Name | Property Value
    ReportExplorer arReportExplorer

    ReportDesigner = _designer
    This binds the ActiveReports Designer to the ReportExplorer control.
    Resize and move as necessary.
    LayerList arLayerList

    ReportDesigner = _designer
    This binds the ActiveReports Designer to the LayerList control.
    Resize and move as necessary.
    PropertyGrid | arPropertyGrid | Resize and move as necessary.
    GroupEditor
    (under Containers)     		arGroupEditor

    ReportDesigner = _designer
    This binds the ActiveReports Designer to the GroupEditor control.
    Resize and move as necessary.
    ReportsLibrary arReportsLibrary

    ReportDesigner = _designer
    This binds the ActiveReports Designer to the ReportsLibrary control.
    Resize and move as necessary.
  2. On the Form, select the Designer control.
  3. In the Properties Panel, set the PropertyGrid property of the Designer control to arPropertyGrid. This binds the ActiveReports Designer to the Property Grid control.

View the End User Report Designer

Press F5 to run the project. The End User Report Designer opens with an RDLX report.

For information on how you can customize the End User Report Designer and more, refer to the End User Designer sample.

Call Designer

You need to call the NewReport designer action in GrapeCity.ActiveReports.Design.DesignerAction.

C# code. Paste AFTER the InitializeComponent method Copy Code

public frmMain()
{
InitializeComponent();
_designer.ExecuteAction(DesignerAction.NewReport);
}

The New Report dialog shows the choice of reports to open.
Data Source Wizard

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set High DPI Support

Set High DPI Support
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Set High DPI Support

Glossary Item Box

The End User Report Designer application requires specifying the SetHighDpiMode configuration to support the high DPI displays. To enable high DPI displays in a .NET6 application, use the following code.

C# Copy Code
Application.SetHighDpiMode(HighDpiMode.DpiUnawareGdiScaled);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Use End-User Report Designer API

Use End-User Report Designer API
See Also
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API

Glossary Item Box

The following set of topics give information on the End-User Report Designer API that allows you to perform many operations with the report itself and the report designer surface.

See Also

Work with a Report
Customize the Design View
Manage the Report Explorer
Customize the Toolbox
Work with Report Parts

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with a Report

Work with a Report
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API > Work with a Report

Glossary Item Box

The End User Designer API for WinForms allows you to perform common operations with a report using the Designer class.

Initialize Designer with a new report

Use Designer.NewReport method to create a new empty report and initialize the Designer as shown in the code example.

C#. Add using statements on the top of Form.cs Copy Code
using System.Windows.Forms;
using GrapeCity.ActiveReports.Design;
C# code. Paste INSIDE the Form Load event Copy Code
var _designer = new Designer() { Dock = DockStyle.Fill };
_designer.NewReport(DesignerReportType.RdlMultiSection);
Controls.Add(_designer);

Note: You should use the Report property only if you want to get the current state information. Please do not use this property if you need to change the report state or assign a new report.

Initialize Designer with a specified report

Use the Designer.LoadReport method to initialize the Designer by loading a report created in code, as demonstrated in the code example.

Copy Code
var report = new PageReport {
      Report = {
        DataSources = {
              new DataSource {
                  Name = "MainDataSource",
                  ConnectionProperties = {
                      ConnectString = "<your_connection_string>",
                      DataProvider = "MSSQL",
                  }
              }
          }
      }
  };
//Serialize and load report into the designer
_designer.LoadReport(XmlReader.Create(new StringReader(report.ToRdlString())), DesignerReportType.Rdl);

Save a report

Save a report to any storage by passing the XmlWriter object to the Designer.SaveReport method. See the example code for details.

C#. Add using statements on the top of Form.cs Copy Code
using System.IO;
using System.Xml;
using GrapeCity.ActiveReports.Design;
C#. Copy Code
private void SaveReport(Stream outStream)
{
  using(var writer = XmlWriter.Create(outStream))
  {
    _designer.SaveReport(writer);
  }
}

Define a font resolver

Using the Designer.FontResolver property, you can provide your own fonts to be used for the report design and preview. For that, you must first define your own font resolver and then attach it to the Designer instance. See the code example for details.

C#. Add using statements on the top of Form.cs Copy Code
using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Design;
C#. Define a custom font resolver Copy Code
public sealed class DirectoryFontResolver : IFontResolver
{
    GrapeCity.Documents.Text.FontCollection _fonts;

    public DirectoryFontResolver(string fontsDirectory)
    {
        _fonts = new GrapeCity.Documents.Text.FontCollection();
        // load standard Windows fonts
        _fonts.RegisterDirectory(Environment.GetFolderPath(Environment.SpecialFolder.Fonts));
        // load fonts from custom directory
        _fonts.RegisterDirectory(fontsDirectory);
        _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
    }
    GrapeCity.Documents.Text.FontCollection IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
    {
        var fonts = new GrapeCity.Documents.Text.FontCollection();
        fonts.Add(_fonts.FindFamilyName(familyName, isBold, isItalic) ?? _fonts.DefaultFont);
        return fonts;
    }
}
C#. Attach a custom font resolver to the Designer instance Copy Code
class MyDesignerForm : Form
{
  public MyDesignerForm()
  {
    InitializeComponent();
    //The designer must be added to the form with the name '_designer'.
    _designer.FontResolver = new DirectoryFontResolver("c:\\Fonts");
  }
}

Specify a custom resource locator

Using the Designer.ResourceLocator property, you can define a custom resource locator to get the resources (like images, subreports) from the custom storage or at a specific disk location. First, define the custom resource locator and then use it in the Designer. See the code example for details.

C#. Add using statements on the top of Form.cs Copy Code
using System;
using System.IO;
using System.Drawing;
using GrapeCity.ActiveReports;
C#. Define a custom resource locator Copy Code
class MyResourceLocator : ResourceLocator
{
    public override Resource GetResource(ResourceInfo resourceInfo)
    {
        if (resourceInfo.Name == "redSquare.png")
        {
            //Here we draw the image with the red square in the center.
            //You can load the image from file system, or from data base, or from assembly resources.
            var img = new Bitmap(100, 100);
            var graphics = Graphics.FromImage(img);
            var redBrush = new SolidBrush(Color.Red);
            graphics.FillRectangle(redBrush, 10, 10, 80, 80);
            var tmpStream = new MemoryStream();
            img.Save(tmpStream, System.Drawing.Imaging.ImageFormat.Png);
            tmpStream.Position = 0;
            return new Resource(tmpStream, new Uri("redSquare.png", UriKind.Relative));
        }
        return new Resource();
    }
}
C#. Attach a custom resource locator to the Designer instance Copy Code
class MyDesignerForm : Form
{
  public MyDesignerForm()
  {
    InitializeComponent();
    //The designer must be added to the form with the name '_designer'.
    _designer.ResourceLocator = new MyResourceLocator();
  }

Execute specific Designer actions

With the Designer.ExecuteAction(DesignerAction) method, you can execute some specified designer action. Most Designer APIs related to reports are encapsulated into the ExecuteAction method. The code example below demonstrates how you can remove all selected items.

C# Copy Code
private void RemoveSelectedItems()
{
  _designer.ExecuteAction(DesignerAction.EditDelete);
}

The code example below demonstrates how you can select all items and remove them.

C# Copy Code
private void Clear()
{
  _designer.ExecuteAction(DesignerAction.SelectAll);
  _designer.ExecuteAction(DesignerAction.EditDelete);
}

Supply credentials for a data provider

Use the Designer.LocateCredentials event to provide credentials for data providers as demonstrated in the code example.

C#. Add using statements on the top of Form.cs Copy Code
using System.Windows.Forms;
using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Design;
C# Copy Code
_designer.LocateCredentials += (sender, args) => {
  args.UserName = "sa";
  args.Password = "12345";
}

Provide data for a page report

Use the Designer.LocateDataSource event to provide data for previewing a page report as demonstrated in the code example.

C# Copy Code
_designer.LocateDataSource += (sender, args) => {
  var dataSourceName = args.DataSet.Query.DataSourceName;
  var dataSource = ((PageReport)designer.Report).Report.DataSources.First(x => x.Name == dataSourceName);
  if(dataSource.ConnectionProperties.DataProvider == "OBJECT")
  {
    args.Data = new[] { new { CustomerName = "Gc Inc." } };
  }
};

Get the selected items collection

Use the Designer.Selection property or the Designer.SelectionChanged event to react to selection changes. Using the Designer.Selection property, you can get the selected items collection. The code example below demonstrates changing the 'remove' button state, which must be enabled only when there are selected items.

C# Copy Code
_designer.SelectionChanged += () {
  removeButton.Enabled =
    _designer.Selection.OfType<ReportItem>().Count() > 0
    || designer.Selection.OfType<ARControl>().Count() > 0;
}

Get the changed undo history

The UndoManager.Changed event occurs when the report was changed and therefore the undo history was changed as well. You can use this event in the conjunction with the UndoManager.UndoCount and UndoManager.RedoCount properties to set the Undo/Redo buttons state as shown in the code example.

C# Copy Code
_designer.UndoManager.Changed += (sender, e) => {
  _undoButton.Enabled = _designer.UndoManager.UndoCount > 0;
  _redoButton.Enabled = _designer.UndoManager.RedoCount > 0;
};

Handle actions after changing the report layout

With the Designer.LayoutChanged event, you can execute some actions right after the layout has been changed as in the code example below.

C# Copy Code
_designer.LayoutChanged += (sender, args) => {
  //do some work here
};

Handle report layout changes

The Designer.LayoutChanging event allows to handle the report layout changes. The example below deprecates adding a new control without a dataset.

C# Copy Code
_designer.LayoutChanging += (sender, args) => {
      if (args.Type == LayoutChangeType.ControlAdd
      && designer.Report is PageReport pageReport
      && pageReport.Report.DataSets.Count == 0)
      {
        ((IUIService)designer).ShowError("Add data set first.");
        args.AllowChange = false;
      }
  };

Check if a Designer action is enabled

With the Designer.QueryActionEnabled(DesignerAction) method, you can check if a specific action in the Designer is enabled.

C# Copy Code
var canConvert = designer.QueryActionEnabled(DesignerAction.ConvertToMaster);
//canConvert value will be 'false' for master reports and 'true' for rdl reports.

Return a currently opened report

The Designer.Report property returns a currently opened report, which can be a Page report or a Section report.

To set a report, you should use the Designer.LoadReport method.
C# Copy Code
var extension = switch designer.Report {
  PageReport => ".rdlx",
  SectionReport => ".rpx",
  _ => throw new Exception("Unknown report type.")
};

Update some button states after the report changes

The Designer.ReportChanged event occurs when any change to a report has been applied (layout changes or data layer changes). You can use this event to update some button states as in the example below.

C# Copy Code
_designer.ReportChanged += (sender, args) => {
  saveButton.Enabled = true;
};

Show the Data Source creation wizard

The Designer.RunDataWizard event opens the data source creation wizard.

C# Copy Code
private void RunDataWizardButtonClick(object sender, EventArgs e)
{
    _designer.RunDataWizard();
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize the Design View

Customize the Design View
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API > Customize the Design View

Glossary Item Box

Get a currently active tab

By using Designer.ActiveTabChanged event, you can add a reaction to switching between the Script, Design, and Preview tabs. By using this event, you can get a currently active tab.

The example code is as follows.

C# Copy Code
public partial class Form1 : Form
{
  public Form1()
  {
    InitializeComponent();
    _designer = new Designer() { Dock = DockStyle.Fill };
    _designer.ActiveTabChanged += (sender, args) => {
        //Get the currently editing report name.
        var reportName = designer.Report switch {
            PageReport pageReport => pageReport.Report.Name,
            SectionReport sectionReport => sectionReport.Name,
            _ => "Report"
        };
        //Set the form title to reflect the current designer state
        this.Text = designer.ActiveTab switch {
            DesignerTab.Script => $"{reportName} - Script",
            DesignerTab.Preview => $"{reportName} - Preview",
            _ => $"{reportName} - Edit"
        };
    };
    Controls.Add(designer);
  }
}

Add or remove a grid on the Designer surface

The Designer.DrawGrid property adds or removes the grid on the design surface. You can setup this property at the designer initialization or any time later.

Note: You can control the grid visibility by using the buttons on the Tool Panel. You can deprecate it by using the Designer.ToolPanel property.

The code example below demonstrates how you can add your own button to switch the grid off.

Switch off the grid

C# Copy Code
void Button_OnClick(object sender, EventArgs e)
{
    _designer.DrawGrid = false;
}

The code example below demonstrates how you can add your own button to switch the grid on.

Switch on the grid

C# Copy Code
void Button_OnClick(object sender, EventArgs e)
 {
     _designer.DrawGrid = true;
 }

Switch between the grid types

If the Designer.DrawGrid property is set to True, there are two possible grid types - Lines or Dots. You can switch between them by using the Designer.GridMode property.

This code example demonstrates how you can switch to the Dots grid mode.
Switch on the Dots Grid Mode

C# Copy Code
_designer.GridMode = GridMode.Dots;

Specify a number of grid dots or lines per unit

Note: This is for Section Report designer only.

The Designer.GridX and Designer.GridY properties specify how many dots (or lines) of grid per unit need to be drawn on the design surface. If you specify a similar code as in the example below, you will get the following result.
Drid dots or lines per unit

C# Copy Code
_designer.GridX = 8;
_designer.GridY = 2;

Show or hide the Preview tab

The Designer.EnablePreview property controls the visibility of the Preview tab on the Tool panel of the design surface.

Show Preview tab

C# Copy Code
_designer.EnablePreview = true;

Hide Preview tab

C# Copy Code
_designer.EnablePreview = false;

Show or hide the Script tab

The Designer.EnableScripting property controls the visibility of the Script tab on the Tool panel of the design surface.

Show Script tab

C# Copy Code
_designer.EnableScripting = true;

Hide Script tab

C# Copy Code
_designer.EnableScripting = false;

Change the layout mode of items

The Designer.LayoutMode property changes the items layout mode and is currently available for Section reports only.

C# Copy Code
private void ButtonSnapGrid_Click(object sender, EventArgs args)
{
  _designer.LayoutMode = designer.LayoutMode ^ LayoutMode.SnapGrid;
}
private void ButtonSnapLines_Click(object sender, EventArgs args)
{
  _designer.LayoutMode = designer.LayoutMode ^ LayoutMode.SnapLines;
}

Lock the position or size of report items

The Designer.LockControls property makes it impossible to change the position or size of report items.

The code example below opens the Windows Form with the designer with a pre-built report. You can change some properties of the existing controls but it is impossible to change the report layout.

C# Copy Code
class TweakSalesReportForm : Form
{
  public TweakSalesReportForm()
  {
    var _designer = new Designer {Dock = DockStyle.Fill};
    var _propertyGrid = new PropertyGrid(){Dock = DockStyle.Right};
    _designer.LoadReport(new FileInfo("c:\\reports\\Sales.rdlx"));
    _designer.PropertyGrid = propertyGrid;
    _designer.LockControls = false;
    Controls.Add(designer);
    Contorls.Add(propertyGrid);
  }
}

Deprecate pages in a Page report

With the Designer.PageReportDesignerActions property, you can deprecate some actions under pages in page reports.

C# Copy Code
//Deprecate new page creation.
_designer.PageReportDesignerActions = PageReportDesignerActions.All ^ PageReportDesignerActions.AddPage

Show or hide the Designer, Script, and Preview tabs

The Designer.ReportTabsVisible property controls the visibility of the Designer, Script, and Preview tabs.

Show or hide the Designer, Script, and Preview tabs

C# Copy Code
_designer.ReportTabsVisible = false;

Show or hide the Tool panel

The Designer.ReportTabsPanelVisible property specifies whether the Tool panel is visible.

C# Copy Code
_designer.ReportTabsPanelVisible = false;

Specify a scrolling mode for the Viewer

The Designer.ScrollingMode property specifies the scrolling mode for the embedded report Viewer.

C# Copy Code
_designer.ScrollingMode = ScrollingMode.Paged;

Control the visibility of the Designer tools

The Designer.ToolPanel property controls the visibility of some items in the Tool panel, which is located next to the Preview tab of the Design surface.

The code example below demonstrates how to remove the zoom slider.

C# Copy Code
_designer.ToolPanel = ToolPanelButton.All ^ ToolPanelButton.ZoomSlider;

The Tool panel includes these items that you can remove:

  • DimensionLines
  • GridMode
  • SnapGrid
  • SnapLines
  • MouseMode
  • ZoomSlider

Show or hide the data source icon in the Detail section of Section report

The Designer.ShowDataSourceIcon property is used for Section reports and allows to control the visibility of the data source icon in the Detail section.

C# Copy Code
public partial class Form1 : Form
{
  Designer designer;
  public Form1()
  {
    InitializeComponent();
    _designer = new Designer() { Dock = DockStyle.Fill };
    _designer.NewReport(DesignerReportType.Section);
    _designer.ShowDataSourceIcon = false;
  }
}

Undo the latest operation

You can call the Designer.Undo() method of the object returned by UndoManager property to undo the latest operation. Just add the button you want and assign the Click event handler like in this sample code.

C# Copy Code
private void UndoButton_Click(object sender, EventArgs args)
{
  _designer.UndoManager.Undo();
}

Redo the undone operation

To redo the undone operation, you can call the Designer.Redo() method of the object returned by UndoManager property. Just add the button you want and assign the Click event handler like in this sample code.

C# Copy Code
private void RedoButton_Click(object sender, EventArgs args)
{
  _designer.UndoManager.Redo();
}

Specify zoom as scale factor

The Designer.Zoom property specifies zoom as scale factor.

C# Copy Code
private void ResetZoom_Click(object sender, EventArgs e)
{
  _designer.Zoom = 1;
}

Add the PropertyGrid to the Designer

You can add the PropertyGrid component that allows you to set the properties of a selected report item.

Use WinForms Designer

  1. From the ActiveReports 19 Toolbox, drag and drop the Designer component on the form.
  2. Drag and drop the PropertyGrid component from the All Windows Forms Toolbox group onto the surface of your form or the Designer component.
  3. Select the Designer component and from properties pane, set the PropertyGrid property to the name of the PropertyGrid component.

Use code

The code example below demonstrates adding the PropertyGrid component using the Designer.PropertyGrid property.

C# Copy Code
using GrapeCity.ActiveReports.Design;
using GrapeCity.ActiveReports.Design.ReportExplorer;
class MyForm : Form
{
  MyForm()
  {
    var _designer = new Designer() { Dock = DockStyle.Fill };
    var _propertyGrid = new PropertyGrid { Dock = DockStyle.Right };
    _designer.PropertyGrid = _propertyGrid;
    Controls.Add(_designer);
    Controls.Add(_propertyGrid);
  }
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Manage the Report Explorer

Manage the Report Explorer
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API > Manage the Report Explorer

Glossary Item Box

Report Explorer is a component that displays the structure of the current report opened in the designer as a tree. It also allows you to change the report, add or remove entities from it, affects the selection.

Attach Report Explorer to the existing Designer instance

Use WinForms Designer

  1. From the ActiveReports 19 Toolbox, drag and drop the Designer component on the form.
  2. Drag and drop the ReportExplorer component onto the surface of your form or the Designer component.
  3. Select the ReportExplorer component and from properties pane, set the ReportDesigner property to the name of the designer component.

Use code

The code example below demonstrates how to attach Report Explorer to the Designer programmatically, using the ReportExplorerInternal.ReportDesigner property in GrapeCity.ActiveReports.Design.ReportExplorer namespace.

C#. Paste the code in Form.cs Copy Code
using GrapeCity.ActiveReports.Design;
using GrapeCity.ActiveReports.Design.ReportExplorer;

class MyForm : Form
{
  MyForm()
  {
    var _designer = new Designer() { Dock = DockStyle.Fill };
    var reportExplorer = new ReportExplorer  {
        Dock = DockStyle.Left,
        //now the reportExplorer instance will reflect the state of the report opened
        //in the designer control represented by '_designer' variable.
        ReportDesigner = _designer
    };
    Controls.Add(_designer);
    Controls.Add(reportExplorer);
  }
}

Control the visibility of nodes in Report Explorer

All nodes in the Report Explorer are visible by default. However there are specific nodes that you can hide from the Report Explorer. These specific nodes are:

  • Data Sources
  • Parameters
  • Settings
  • CommonValues

The code example below demonstrates how to make the Report Explorer display the two nodes: Data Sources (including DataSet node) and Parameters.

Nodes in the Report Explorer

C# Copy Code
reportExplorer.VisibleNodes = ReportExplorerNodes.DataSourceAndFields | ReportExplorerNodes.Parameters;

Control the visibility of the Report Explorer content

All report changes are reflected in the Report Explorer, which may look unattractive in case of multiple operations.

With the ReportExplorerInternal.ContentsVisible property in GrapeCity.ActiveReports.Design.ReportExplorer namespace, you can hide the Report Explorer content for some time and then show it again as demonstrated in the code example below.

C# Copy Code
reportExplorer.ContentsVisible = false;
BulkUpdate();//performs some bulk update operation
reportExplorer.ContentsVisible = true;

Set the Report Explorer enabled nodes

You can set enabled nodes to control actions to be performed to a report. For example, you can deprecate modifying the Parameters list from the ReportExplorer using the ReportExplorerInternal.EnabledNodes property in GrapeCity.ActiveReports.Design.ReportExplorer namespace. In this case, existing report parameters will be visible in the Report Explorer but a user will not be able to edit them.

C# Copy Code
reportExplorer.EnabledNodes = ReportExplorerEnabledNodes.All ^ ReportExplorerEnabledNodes.Parameters;

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Customize the Toolbox

Customize the Toolbox
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API > Customize the Toolbox

Glossary Item Box

You can change the Designer toolbox items to show specific controls or remove a control from the toolbox.

Add Toolbox panel

The code example below demonstrates adding a Toolbox panel to the Designer using the Designer.Toolbox property.

C#. Paste the code in Form.cs Copy Code
using GrapeCity.ActiveReports.Design;
using GrapeCity.ActiveReports.Design.ReportExplorer;
class MyForm : Form
{
  MyForm()
  {
    var _designer = new Designer() { Dock = DockStyle.Fill };
    var toolbox = new Toolbox { Dock = DockStyle.Right };
    _designer.Toolbox = toolbox;
    Controls.Add(_designer);
    Controls.Add(toolbox);
  }
}

Control the Toolbox items

With the Toolbox.ConfigureToolboxItems method, you can control items that are available in the Toolbox.

You first need to define a state provider as demonstrated in the sample below.

C# Copy Code
class ToolboxStateProvider : IToolboxUser
{
   public bool GetToolSupported(ToolboxItem tool)
    {
        if (tool.TypeName == "GrapeCity.ActiveReports.Design.DdrDesigner.Designers.BandedList.BandedListDesigner")
            return true;
        return false;
    }
    public void ToolPicked(ToolboxItem tool)  { }
}

After the state provider is configured, you need to configure the Toolbox with it as demonstrated in the sample below.

C# Copy Code
toolbox.ConfigureToolboxItems(new ToolboxStateProvider());

Remove an item from the Toolbox

You can use the Toolbox.RemoveToolboxItem method together with the Toolbox.GetToolboxItems method to remove an item from the Toolbox.

C# Copy Code
private static void RemoveBandedListFromToolBox(Toolbox toolbox)
{
  //Find the item to be removed.
  var bandedList = toolbox.GetToolboxItems()
      .OfType<ToolboxItem>()
      .Single(items => items.TypeName.EndsWith("BandedListDesigner"));
  //Remove the banded list item from the toolbox.
  toolbox.RemoveToolboxItem(items);
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Work with Report Parts

Work with Report Parts
Developers > Create Designer and Viewer Applications > End User Report Designer in WinForms Application > Use End-User Report Designer API > Work with Report Parts

Glossary Item Box

Report parts are groups of items in a report that you can reuse in other reports. The report parts can be added and managed in the Reports Library.

Specify a directory for the reports library

With the Designer.ReportPartsDirectory property, you can specify the directory for loading the report items in the report library.

C# Copy Code
_designer.ReportPartsDirectory = "c:\\Data\Reports Library\\";

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Themes in WebDesigner and Js Viewer Components

Themes in WebDesigner and Js Viewer Components
See Also
Developers > Create Designer and Viewer Applications > Themes in WebDesigner and Js Viewer Components

Glossary Item Box

The creation of custom themes and applying them on Web Designer and Js Viewer is now simpler.

The modules '@mescius/activereportsnet-designer' and ' @mescius/activereportsnet-viewer' provide 'ColorTheme' and 'ColorThemes' objects, which can be used in both designer and viewer components to customize their appearance. Using the respective APIs, you can modify the color scheme of all interface elements within the Designer and Viewer to align with specific use case requirements. Let's explore some quick use cases and update the Script.js file in our WebSamples for WebDesigner and Js Viewer.

ESM Copy Code
import { createViewer, ColorTheme, ColorThemes } from '@mescius/activereportsnet-viewer';
import { arWebDesigner} from '@mescius/activereportsnet-designer';

Create Custom Theme

Use the following code to create a custom theme:

Copy Code
var theme = {
    name: 'testTheme',
    backgroundMain: '#f0f0f0',
    backgroundPanels: '#ffffff',
    primary: 'blue',
    secondary: 'green',
    neutral: 'grey',
    error: 'red',
    warning: 'yellow',
    fontFamily: 'Arial'
};

Create Custom Theme based on Built-in Theme

Use the following code to create a custom theme based on built-in theme:

Copy Code
var theme = {
    ...ActiveReports.ColorThemes.default
    name: 'testTheme',
    primary: 'blue',
    secondary: 'green'
});

Themes in WebDesigner

Apply Theme using the Application's UI

Use Theme Picker to select from the pre-defined themes in the application.

Theme Picker
Manage Themes using WebDesigner API

Use the initialTheme API to apply an initial or default theme to the WebDesigner component.

Apply a Custom Theme

The following code sets a custom theme as the initial theme of the WebDesigner.

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'testTheme',
        themeSelector: {
            enabled: false,
            availableThemes: ['Default', theme]
        }
    }
});

Apply a Built-in Theme

The following code sets a built-in theme as the initial theme of the WebDesigner. Here are the built-in themes you can choose from: default, defaultDark, darkOled, highContrast, and highContrastDark.

Copy Code
GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
    themes: {
        initialTheme: 'defaultDark',
        themeSelector: { enabled: false }
    },
});

Themes in Js Viewer

Use the initialTheme API to apply an initial or default theme to the Js Viewer component.

Apply Theme using the Application's UI

Use Theme Picker to select from the pre-defined themes in the application.

Theme Picker in Js Viewer

Apply a Custom Theme

The following code sets a custom theme as the initial theme of the Js Viewer.

Copy Code
GrapeCity.ActiveReports.JSViewer.create({
    element: '#root',
    themes: {
        initialTheme: 'testTheme',
        themeSelector: {
            enabled: false,
            availableThemes: ['Default', theme]
        }
    }
});

Apply Built-in Theme

The following code sets a built-in theme as the initial theme of the Js Viewer. Here are the built-in themes you can choose from: activeReports, activeReportsDark, darkOled, default, defaultDark, highContrast, and highContrastDark.

Copy Code
GrapeCity.ActiveReports.JSViewer.create({
    element: '#root',
    themes: {
        initialTheme: 'defaultDark',
        themeSelector: { enabled: false }
    },
});

See Also

WebDesigner API
Blazor WebDesigner API
Js Viewer API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Role Based Authorization with JWT

Role Based Authorization with JWT
See Also
Developers > Create Designer and Viewer Applications > Role Based Authorization with JWT

Glossary Item Box

You may want to grant permission to a user based on their role for designing and viewing reports (role-based reporting). To do so, you can add tokens to the WebDesigner and Viewer APIs, fetch these tokens, and use them with the report store. This topic explains fetching and using tokens with the JSON Web Token (JWT) authentication method for the ASP.NET Core application, using Microsoft.AspNetCore.Authentication.JwtBearer NuGet package. We recommend that you first read the Microsoft Documentation on the Dependency injection in ASP.NET Core.

Web Designer Role Based Login using JWT

  1. Create an ASP.Net Core Web App (Model-View-Controller) project, e.g. 'WebDesigner_Authorization'.
  2. Add the Microsoft.AspNetCore.Authentication.JwtBearer NuGet package to the project to be able to generate and validate JWT.
  3. Add the following designer and viewer packages to the project.

    MESCIUS.ActiveReports.Aspnetcore.Designer
    MESCIUS.ActiveReports.Aspnetcore.Viewer

  4. Follow Step 3 to Step 5 from the ASP.NET MVC Core Integration topic to use npm packages of designer and viewer.

  5. Create the 'Implementation' folder. In this folder, add the ‘ReportStore.cs’ class file that will contain the IReportStore interface implementation.
    ReportStore.cs Copy Code
    using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports.Web.Viewer;
using WebDesigner_Authorization.Models;
using GrapeCity.ActiveReports.Rendering.Tools;

namespace WebDesigner_Authorization.Implementation
{
    public class ReportStore : IReportStore
    {
        private static readonly string[] ReportExtensions =
        {
            ".rdl",
            ".rdlx",
            ".rdlx-master",
            ".rpx"
        };

        private readonly Dictionary<string, byte[]> _tempStorage = new Dictionary<string, byte[]>();
        private readonly string _userReportsPath;
        private readonly string _adminReportsPath;
        private readonly IHttpContextAccessor _httpContextAccessor;
        private string userRole { get{return LoginViewModel.GetUserRole(_httpContextAccessor); } }

        public ReportStore(DirectoryInfo rootDirectory, IHttpContextAccessor httpContextAccessor)
        {
            _userReportsPath = rootDirectory.FullName;
            _adminReportsPath = Path.Combine(rootDirectory.FullName, "Admin");
            _httpContextAccessor = httpContextAccessor;
        }
        private FileInfo GetReportFile(string reportId)
        {
            var reportFullPath = Path.Combine(_userReportsPath, reportId);
            var fileInfo = new FileInfo(reportFullPath);

            if (fileInfo.Exists)
                return fileInfo;

            if (userRole == "Admin")
            {
                reportFullPath = Path.Combine(_adminReportsPath, reportId);
                fileInfo = new FileInfo(reportFullPath);

                if (fileInfo.Exists)
                    return fileInfo;
            }

            return null;
        }

        public ReportDescriptor GetReportDescriptor(string reportId)
        {
            if (_tempStorage.ContainsKey(reportId))
                return new ReportDescriptor(GetReportTypeByExtension(Path.GetExtension(reportId)));

            var fileInfo = GetReportFile(reportId);
            if (fileInfo == null)
                throw new GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException();

            return new ReportDescriptor(GetReportTypeByExtension(fileInfo.Extension));
        }

        public Stream LoadReport(string reportId)
        {
            if (_tempStorage.TryGetValue(reportId, out var tempReport))
                return new MemoryStream(tempReport);

            var file = GetReportFile(reportId);
            if (file == null)
                throw new GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException();

            return file.OpenRead();
        }

        public string SaveReport(ReportType reportType, string reportId, Stream reportData, SaveSettings settings = SaveSettings.None)
        {
            string reportPath;
            string folderPath;

            if ((settings & SaveSettings.IsTemporary) != 0)
            {
                var tempName = Guid.NewGuid() + GetReportExtension(reportType);
                _tempStorage.Add(tempName, reportData.ToArray());
                return tempName;
            }

            if (userRole == "Admin")
            {
                folderPath = _adminReportsPath;
                reportPath = Path.Combine(folderPath, reportId);
            }
            else
            {
                folderPath = _userReportsPath;
                reportPath = Path.Combine(folderPath, reportId);
            }
            Directory.CreateDirectory(folderPath);

            using (var fileStream = new FileStream(reportPath, FileMode.Create, FileAccess.Write))
            {
                reportData.CopyTo(fileStream);
            }

            return reportId;
        }

        public string UpdateReport(ReportType reportType, string reportId, Stream reportData)
        {
            return SaveReport(reportType, reportId, reportData);
        }

        public ReportInfo[] ListReports()
        {
            var reports = new List<ReportInfo>();

            var userReports = new DirectoryInfo(_userReportsPath)
                .EnumerateFiles("*.*")
                .Where(fileInfo => ReportExtensions.Any(ext =>
                    fileInfo.Extension.EndsWith(ext, StringComparison.InvariantCultureIgnoreCase)))
                .Select(fileInfo => new ReportInfo()
                {
                    Id = fileInfo.Name,
                    Name = fileInfo.Name,
                    ReportType = GetReportTypeByExtension(fileInfo.Extension),
                }).ToList();

            reports.AddRange(userReports);

            if (userRole == "Admin")
            {
                var adminReports = new DirectoryInfo(_adminReportsPath)
                    .EnumerateFiles("*.*")
                    .Where(fileInfo => ReportExtensions.Any(ext =>
                        fileInfo.Extension.EndsWith(ext, StringComparison.InvariantCultureIgnoreCase)))
                    .Select(fileInfo => new ReportInfo()
                    {
                        Id = fileInfo.Name,
                        Name = fileInfo.Name,
                        ReportType = GetReportTypeByExtension(fileInfo.Extension),
                    }).ToList();

                reports.AddRange(adminReports);
            }

            return reports.ToArray();
        }

        private static ReportType GetReportTypeByExtension(string extension)
        {
            return extension switch
            {
                ".rdl" => ReportType.RdlXml,
                ".rdlx" => ReportType.RdlXml,
                ".rdlx-master" => ReportType.RdlMasterXml,
                ".rpx" => ReportType.RpxXml,
                _ => throw new ArgumentOutOfRangeException(nameof(extension), extension, null)
            };
        }

        private static string GetReportExtension(ReportType type)
        {
            return type switch
            {
                ReportType.RdlXml => ".rdlx",
                ReportType.RdlMasterXml => ".rdlx-master",
                ReportType.RpxXml => ".rpx",
                _ => throw new ArgumentOutOfRangeException(nameof(type), type, null)
            };
        }

        public void DeleteReport(string reportId)
        {
            if (_tempStorage.ContainsKey(reportId))
            {
                _tempStorage.Remove(reportId);
                return;
            }
            var file = GetReportFile(reportId);
            if (file != null && file.Exists)
                file.Delete();
        }
    }
}

  6. In the 'Implementation' folder, add the ‘ResourceProvider.cs’ class file that will contain the IResourceRepositoryProvider interface implementation.

    ResourceProvider.cs Copy Code
    using GrapeCity.ActiveReports.Web.Designer;
using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Rendering.Tools;
using WebDesigner_Authorization.Models;

namespace WebDesigner_Authorization.Implementation
{
    public class ResourceProvider : IResourceRepositoryProvider
    {
        private const string SharedDataSourceExtension = ".rdsx";

        private readonly DirectoryInfo _userResourcesPath;
        private readonly DirectoryInfo _adminResourcesPath;
        private readonly IHttpContextAccessor _httpContextAccessor;
        private string userRole { get { return LoginViewModel.GetUserRole(_httpContextAccessor); } }

        public ResourceProvider(DirectoryInfo rootDirectory, IHttpContextAccessor httpContextAccessor)
        {
            _userResourcesPath = rootDirectory;
            _adminResourcesPath = new DirectoryInfo(Path.Combine(rootDirectory.FullName, "Admin"));
            _httpContextAccessor = httpContextAccessor;
        }

        public Stream GetResource(ResourceInfo resource)
        {
            var role = userRole;
            var filePath = Path.Combine(_userResourcesPath.FullName, resource.Name);
            var file = new FileInfo(filePath);

            if (!file.Exists && role == "Admin")
            {
                filePath = Path.Combine(_adminResourcesPath.FullName, resource.Name);
                file = new FileInfo(filePath);
            }

            if (!file.Exists)
                return null;

            return file.OpenRead();
        }

        public ResourceDescriptor[] ListResources(ResourceType resourceType)
        {
            var role = userRole;
            var resources = new List<ResourceDescriptor>();

            if (resourceType == ResourceType.SharedDataSource)
            {
                var userResources = _userResourcesPath
                    .EnumerateFiles("*" + SharedDataSourceExtension)
                    .Select(fileInfo => CreateResourceDescriptor(fileInfo))
                    .ToList();

                resources.AddRange(userResources);

                if (role == "Admin")
                {
                    var adminResources = _adminResourcesPath
                        .EnumerateFiles("*" + SharedDataSourceExtension)
                        .Select(fileInfo => CreateResourceDescriptor(fileInfo))
                        .ToList();

                    resources.AddRange(adminResources);
                }
            }

            return resources.ToArray();
        }

        private SharedDataSourceResourceDescriptor CreateResourceDescriptor(FileInfo fileInfo)
        {
            using var stream = fileInfo.OpenRead();
            var dataSource = DataSourceTools.LoadSharedDataSource(stream);

            return new SharedDataSourceResourceDescriptor()
            {
                Id = fileInfo.Name,
                Name = fileInfo.Name,
                Type = dataSource.ConnectionProperties.DataProvider
            };
        }

        public ResourceDescriptor[] DescribeResources(ResourceInfo[] resources)
        {
            return Enumerable.Empty<ResourceDescriptor>().ToArray();
        }
    }
}

  7. In the 'Models' folder, add the following two class files, 'User.cs' and 'LoginViewModel.cs', to contain the data for a user and role-based login.

    User.cs Copy Code
    namespace WebDesigner_Authorization.Models
{
    public class User
    {
        public string Login { get; set; }
        public string Password { get; set; }
        public string Role { get; set; }

        public User(string login, string password, string role)
        {
            Login = login;
            Password = password;
            Role = role;
        }
    }
}
    LoginViewModel.cs Copy Code
    namespace WebDesigner_Authorization.Models
{
    public class LoginViewModel
    {
        public string Username { get; set; }
        public string Password { get; set; }

        public static string GetUserRole(IHttpContextAccessor httpContextAccessor)
        {
            return httpContextAccessor?.HttpContext?.Session.GetString("Role");
        }
    }
}

  8. Create the 'Services' folder. In this folder, add the 'AuthService.cs' class file to store the login credentials, define roles for users, such as "admin" and "manager. The 'AuthService' class generates JWT using JwtSecurityTokenHandler.

    AuthService.cs Copy Code
    using Microsoft.IdentityModel.Tokens;
using System.IdentityModel.Tokens.Jwt;
using System.Security.Claims;
using System.Text;
using WebDesigner_Authorization.Models;

namespace WebDesigner_Authorization.Services
{
    public class AuthService
    {
        public class AuthOptions
        {
            public const string ISSUER = "MyAuthServer";
            public const string AUDIENCE = "MyAuthClient";
            public const string KEY = "mysupersecret_secretkey_12345678";
            public const int LIFETIME = 2;

            public static SymmetricSecurityKey GetSymmetricSecurityKey() =>
                new SymmetricSecurityKey(Encoding.UTF8.GetBytes(KEY));
        }
        private readonly List<User> _users = new List<User>
        {
            new User("test1", "12345", "Admin"),
            new User("test2", "53421", "Manager")
        };

        public async Task<string> Login(string username, string password)
        {
            var user = _users.FirstOrDefault(u => u.Login == username && u.Password == password);

            if (user == null)
                return null;

            return GenerateToken(user.Login, user.Role);
        }

        public string GenerateToken(string username, string role)
        {
            var tokenHandler = new JwtSecurityTokenHandler();
            var key = Encoding.ASCII.GetBytes(AuthOptions.KEY);
            var tokenDescriptor = new SecurityTokenDescriptor
            {
                Subject = new ClaimsIdentity(new Claim[]
                {
                    new Claim(ClaimTypes.Name, username),
                    new Claim(ClaimTypes.Role, role)
                }),
                Expires = DateTime.UtcNow.AddMinutes(AuthOptions.LIFETIME),
                SigningCredentials = new SigningCredentials(new SymmetricSecurityKey(key), SecurityAlgorithms.HmacSha256Signature)
            };
            var token = tokenHandler.CreateToken(tokenDescriptor);
             var tokenString = tokenHandler.WriteToken(token);
            return tokenString;
        }

        public string GetRoleFromToken(string token)
        {
            var tokenHandler = new JwtSecurityTokenHandler();
            var jwtToken = tokenHandler.ReadToken(token) as JwtSecurityToken;
            if (jwtToken == null)
            {
                Console.WriteLine("Invalid JWT Token");
                return null;
            }
            var roleClaim = jwtToken.Claims.FirstOrDefault(claim => claim.Type == "role").Value;
            return roleClaim;
        }
    }
}

  9. In the 'Controllers' folder, update 'HomeController.cs'.

    HomeController.cs Copy Code
    using Microsoft.AspNetCore.Mvc;

namespace WebDesigner_Authorization.Controllers
{

    public class HomeController : Controller
    {
        public IActionResult Index()
        {
            ViewData["UserRole"] = HttpContext.Session.GetString("Role");
            ViewData["Token"] = HttpContext.Session.GetString("Token");
            return View();
        }
    }
}

  10. In the 'Controllers' folder, add 'LoginController.cs'.

    LoginController.cs Copy Code
    using Microsoft.AspNetCore.Mvc;
using WebDesigner_Authorization.Models;
using WebDesigner_Authorization.Services;
using Microsoft.AspNetCore.Http;
using System.Threading.Tasks;

namespace WebDesigner_Authorization.Controllers
{
    public class LoginController : Controller
    {
        private readonly AuthService _authService;

        public LoginController(AuthService authService)
        {
            _authService = authService;
        }

        public IActionResult Index()
        {
            return View(new LoginViewModel());
        }

        [HttpPost]
        public async Task<IActionResult> Login(LoginViewModel model)
        {
            if (!ModelState.IsValid)
            {
                return View("Index", model);
            }

            var token = await _authService.Login(model.Username, model.Password);
            if (token == null)
            {
                ModelState.AddModelError(string.Empty, "Invalid username or password");
                return View("Index", model);
            }
            var role = _authService.GetRoleFromToken(token);
            HttpContext.Session.SetString("Token", token);
            HttpContext.Session.SetString("Role", role);
            return RedirectToAction("Index", "Home");
        }

        [HttpPost]
        [ValidateAntiForgeryToken]
        public IActionResult Logout()
        {
            HttpContext.Session.Clear();
            return RedirectToAction("Index", "Login");
        }
    }
}

  11. Update the Views\Home\Index.cshtml page.

    Index.cshtml Copy Code
    @using Microsoft.AspNetCore.Http
@using WebDesigner_Authorization.Services
@inject AuthService _authService
@{
    ViewData["Title"] = "Home";
    var userRole = ViewData["UserRole"]?.ToString();
    var token = ViewData["Token"]?.ToString();
}

@if (!string.IsNullOrEmpty(userRole))
{
    <h2>Welcome, @userRole</h2>
}

<!-- Logout button -->
<form id="logoutForm" method="post" action="/Login/Logout">
    <button type="submit">Logout</button>
    @Html.AntiForgeryToken()
</form>

<link rel="stylesheet" href="~/css/web-designer.css">
<link rel="stylesheet" href="~/css/jsViewer.min.css">
<div>
    <div id="ar-web-designer" class="ar-web-designer">
        <span class="ar-web-designer__loader"><b>AR Web Designer</b></span>
    </div>
</div>

<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<script src="~/js/web-designer.js"></script>
<script src="~/js/jsViewer.min.js"></script>
<script>
    let viewer = null;
    let serverUrl = getServerUrl();

    function getServerUrl() {
        let baseUrl = 'api';
        let virtualDirName = document.getElementById('virtualDir');

        if (virtualDirName && virtualDirName.href != window.location.origin + '/') {
            return virtualDirName.href + baseUrl;
        }

        return baseUrl;
    }

    GrapeCity.ActiveReports.Designer.create('#ar-web-designer', {
        server: {
            url: serverUrl
        },
        storeUnsavedReport: false,
        rpx: { enabled: true },
        appBar: { openButton: { visible: true } },
        data: { dataSets: { canModify: true }, dataSources: { canModify: true, shared: { enabled: true } } },
        preview: {
            openViewer: (options) => {
                if (viewer) {
                    viewer.openReport(options.documentInfo.id);
                    return;
                }
                viewer = GrapeCity.ActiveReports.JSViewer.create({
                    element: '#' + options.element,
                    reportService: {
                        url: 'api/reporting',
                    },
                    reportID: options.documentInfo.id,
                    settings: {
                        zoomType: 'FitPage',
                    },
                    theme: options.theme
                });
            }
        },
        server: {
            onBeforeRequest: (init) => {
                const headers = {
                    'Authorization': "Bearer: " + '@token',
                };
                init.headers = {
                    ...init.headers,
                    ...headers
                };
                return init;
            }
        }
    });
</script>

  12. Create the 'resources' folder in your sample project root. You can store your existing reports, themes, and images in this folder.

  13. Update the 'Program.cs' file as follows to implement the JWT authentication.

    • Configure AuthenticationMiddleware (app.UseAuthentication) and AuthorizationMiddleware (app.UseAuthorization).
    • Validate the JWT using AddJWTBearer and extract the data hidden in that token.
    • Store the user's roles in the JWT claims when generating the token at login.
      Program.cs Copy Code
      using GrapeCity.ActiveReports.Aspnetcore.Viewer;
using GrapeCity.ActiveReports.Aspnetcore.Designer;
using Microsoft.AspNetCore.Authentication.JwtBearer;
using WebDesigner_Authorization.Services;
using Microsoft.IdentityModel.Tokens;
using Microsoft.Extensions.FileProviders;
using static WebDesigner_Authorization.Services.AuthService;
using GrapeCity.ActiveReports.Web.Designer;
using WebDesigner_Authorization.Implementation;

DirectoryInfo resourcesRootDirectory = new DirectoryInfo(Path.Combine(Directory.GetCurrentDirectory(), "resources"));

var builder = WebApplication.CreateBuilder(args);
builder.Services.AddControllersWithViews();
builder.Services.AddHttpContextAccessor();
builder.Services.AddSession();
builder.Services.AddScoped<AuthService>();

builder.Services.AddAuthorization();

builder.Services.AddAuthentication(JwtBearerDefaults.AuthenticationScheme).AddJwtBearer(options =>
{
    options.RequireHttpsMetadata = false;
    options.TokenValidationParameters = new TokenValidationParameters
    {
        ValidateIssuer = true,
        ValidIssuer = AuthOptions.ISSUER,
        ValidateAudience = true,
        ValidAudience = AuthOptions.AUDIENCE,
        ValidateLifetime = true,
        IssuerSigningKey = AuthOptions.GetSymmetricSecurityKey(),
        ValidateIssuerSigningKey = true,
    };
});
builder.Services.AddReportViewer();
builder.Services.AddReportDesigner();

//dependency injection
builder.Services.AddSingleton<IReportStore>(sp => new ReportStore(resourcesRootDirectory, sp.GetRequiredService<IHttpContextAccessor>()));
builder.Services.AddSingleton<IResourceRepositoryProvider>(sp => new ResourceProvider(resourcesRootDirectory, sp.GetRequiredService<IHttpContextAccessor>()));

var app = builder.Build();
if (!app.Environment.IsDevelopment())
{
    app.UseExceptionHandler("/Home/Error");
    app.UseHsts();
}
app.UseHttpsRedirection();
app.UseStaticFiles();
app.UseRouting();
app.UseAuthentication();
app.UseAuthorization();
app.UseSession();
app.MapControllerRoute(
    name: "default",
    pattern: "{controller=Login}/{action=Index}/{id?}");
app.UseReportDesigner(config =>
{
    var reportStore = app.Services.GetRequiredService<IReportStore>();
    var resourceProvider = app.Services.GetRequiredService<IResourceRepositoryProvider>();
    config.UseReportsProvider(reportStore);
    config.UseResourcesProvider(resourceProvider);
});

app.UseDefaultFiles(new DefaultFilesOptions
{
    FileProvider = new PhysicalFileProvider(
        Path.Combine(Directory.GetCurrentDirectory(), "wwwroot")),
    DefaultFileNames = new List<string> { "index.html" }
});
app.UseStaticFiles();
app.Run();
  14. Build and run the application. You will see a login page where you should enter the login details as defined in AuthService.cs.

See Also

WebDesigner API
WebDesigner ASP.NET Middleware

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Extensibility in ActiveReports

Extensibility in ActiveReports
Developers > Extensibility in ActiveReports

Glossary Item Box

This section covers some common developers tasks related to using our API to extend or add ActiveReports functions at various levels:

  • Customization of report behavior
    • Fonts customization (see Fonts Customization)
    • Resources customization (see Resources Customization)
    • Report item customization (see Create a Custom Report Item)
    • Map tile provider customization (see Map Tile Provider Customization)
  • Create a new data provider (see Data Provider Customization)
  • Customize Viewers and Designers (see Customization Options)
  • Create a custom export (see Custom PDF Export sample)

If you still have questions or doubts, please contact our Support Team.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Fonts Customization

Fonts Customization
Developers > Extensibility in ActiveReports > Fonts Customization

Glossary Item Box

You can run reports on different platforms, and it is important to ensure that a report uses the same fonts. With the ActiveReports' custom font resolver, you can configure fonts for Page, RDLX, and Section reports (in the CrossPlatform compatibility mode) on different platforms.

Note: Custom font settings have higher priority over fonts from the config file or the system font settings.

To learn about how to configure custom fonts in the ActiveReports.config file, see Configure ActiveReports using Config File.

Use the Custom Font Resolver in Preview

In some situations, you can use the custom fonts resolver through code by specifying the PageReport.FontResolver property in the Windows Forms Viewer and UseFontResolver in the JavaScript Viewer, as shown in the following code examples.

C# Code for Windows Forms Viewer Copy Code
var report = new PageReport(…);
report.FontResolver = DirectoryFontResolver.Instance;
viewer1.LoadDocument(report.Document);
C# Code for JavaScript Viewer Copy Code
app.UseReportViewer(settings => {
  settings.UseFontResolver(DirectoryFontResolver.Instance);
  settings.UseFileStore(ResourcesRootDirectory)
});

Configure Fonts for Preview and Export

You can configure fonts for preview and export on all platforms without installation as in the following examples.

Example 1

Copy Code
public sealed class WindowsFontResolver : GrapeCity.ActiveReports.IFontResolver
{
   static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
   static WindowsFontResolver()
   {
        GrapeCity.Documents.Text.Windows.FontLinkHelper.UpdateFontLinks(_fonts, true);
        _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
   }
   public static GrapeCity.ActiveReports.IFontResolver Instance = new WindowsFontResolver();
   private WindowsFontResolver() { }
   GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
   {
        var fonts = new GrapeCity.Documents.Text.FontCollection();
        fonts.Add(_fonts.FindFamilyName(familyName, isBold, isItalic) ?? _fonts.DefaultFont);
        GrapeCity.Documents.Text.Windows.FontLinkHelper.UpdateEudcLinks(fonts);
        return fonts;
   }
}

Example 2

Copy Code
public sealed class DirectoryFontResolver : GrapeCity.ActiveReports.IFontResolver
{
   static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
   static DirectoryFontResolver()
   {
      // see https://developers.redhat.com/blog/2018/11/07/dotnet-special-folder-api-linux/
      _fonts.RegisterDirectory(System.Environment.GetFolderPath(System.Environment.SpecialFolder.Fonts));
      _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
   }
   public static GrapeCity.ActiveReports.IFontResolver Instance = new DirectoryFontResolver();
   private DirectoryFontResolver() { }
   GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
   {
      var fonts = new GrapeCity.Documents.Text.FontCollection();
      var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
      if (font != null) fonts.Add(font);
      fonts.Add(_fonts.DefaultFont);
      return fonts;
   }
}

See the FontResolver sample for more details.

Link one Font to Another

If you need to link just one font to another (for example, link an EUDC font to an installed font), you can do it with DsPdf and DsImaging APIs, using the following code.

C# Code. PASTE to the beginning of the Main function Copy Code
GrapeCity.Documents.Text.Windows.FontLinkHelper.UpdateFontLinks(null, true);
var fonts = new System.Collections.Generic.List();
GrapeCity.Documents.Text.FontCollection.SystemFonts.SelectByFamilyName("MS UI Gothic", fonts);
if (fonts.Count > 0)
 {

    var eudcFonts = new GrapeCity.Documents.Text.FontCollection();
    using (var stream = new System.IO.FileStream(@"C:\EudcFonts\DFHSG3J.tte", System.IO.FileMode.Open, System.IO.FileAccess.Read, System.IO.FileShare.Read))
    eudcFonts.LoadFonts(stream);
    foreach (var font in fonts)
      {

        font.ClearEudcFontLinks();
        foreach (var eudcFont in eudcFonts) font.AddEudcFont(eudcFont);
      }
  }

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Resources Customization

Resources Customization
See Also
Developers > Extensibility in ActiveReports > Resources Customization

Glossary Item Box

Reports can depend on external resources. ActiveReports provides the possibilities to resolve reporting tasks, related to using any resources that your report may require. With the ActiveReports custom resource locator, you can place any resources - themes, image files, subreports, CSS, etc, to any location in your file system.

In ActiveReports, you can place resources such as themes, image files, subreports, CSS, to any location with some exceptions:

  • Section report requires using scripts to bind subreports.
  • Some data source types require using connection strings with absolute paths.

Page and RDLX reports can resolve resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With RDLX report, you can create a custom resource locator to read any resources that might be required by your reports from any type of location. You can use it for resources such as images and theme files, or for reports to use in drillthrough links, subreports, or master reports.

The Custom Resource Locator sample demonstrates a custom resource locator that looks for files in the current user’s My Pictures folder by looking for a special MyPictures protocol. The custom resource locator in the sample is implemented by deriving from GrapeCity.ActiveReports.ResourceLocator class and overriding the GetResource method. The GetResource method returns ParentUri and Value properties. The Value property contains the located resource as a memory stream. The ParentUri property contains the string URI of the parent of the resource within the resource hierarchy.

You can customize the resource locator for all report types in the following ActiveReports components:

  • Windows Forms Designer and Windows Forms Viewer
  • WPF Viewer
  • all ASP.NET viewer backends
  • all exports

See the ResourceLocator property for details.

Note: The WebDesigner uses a completely different mechanism to access resources. See the WebDesigner_CustomStore sample for details.

Load Pictures from My Pictures directory

Page reports can get resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With Page reports, you can create a custom resource locator to read any resources that might be required by your reports from any location.

The following steps illustrate how to load pictures from the user's My Pictures or Pictures directory based on the Custom Resource Locator sample.

Note: Although these steps use Page reports, you can also implement this using RDLX reports.

When you complete these steps, you get a layout that looks similar to the following at run time.

Custom Resource Locator

Add an ActiveReports to the Visual Studio project

  1. Create a new Visual Studio Windows Forms Application project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, Page report and then click Finish.
  4. In the Name field, rename the file as DemoReport.rdlx.
  5. Click the Add button to open a new Page Report.

Create a layout for the report

  1. From the toolbox, drag an Image control onto the design surface and in the Properties panel, set the following properties.
    Property Name | Property Value
    Name | Image1
    Location | 0.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Penguins.jpg
  2. From the toolbox, drag another Image control onto the design surface and in the Properties panel, set the following properties.
    Property Name | Property Value
    Name | Image2
    Location | 3.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Desert.jpg
  3. In the Solution Explorer, select DemoReport.rdlx and in the Properties panel, set Build Action to Embedded Resource.

Add the new MyPicturesLocator class

  1. In the Solution Explorer window, right-click on your project name and select Add and then New Item.
  2. In the Add New Item dialog that appears, select Class.
  3. Change the name of the class to MyPicturesLocator and click the Add button.
  4. Replace the existing code with the following code to the new class.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System
Imports System.Drawing
Imports GrapeCity.ActiveReports.Extensibility
Imports System.Globalization
Imports System.IO
Imports System.Runtime.InteropServices
    VB code. Paste INSIDE the class Copy Code
     Inherits ResourceLocator

    Private Const UriSchemeMyImages As String = "MyPictures:"

    ' Obtain and return the resource.
    Public Overrides Function GetResource(resourceInfo As ResourceInfo) As Resource
        Dim name As String = resourceInfo.Name
        If name Is Nothing OrElse name.Length = 0 Then
            Throw New ArgumentException("The name of resource to be obtained should be non-empty string.", "name")
        End If
        Dim uri As New Uri(name)
        Dim stream As Stream = GetPictureFromSpecialFolder(name)
        If stream Is Nothing Then
            stream = New MemoryStream()
        End If
        Return New Resource(stream, uri)
    End Function

    ' Returns the specified image from Public Pictures folder.
    Private Shared Function GetPictureFromSpecialFolder(path As String) As Stream
        Dim startPathPos As Integer = UriSchemeMyImages.Length
        If startPathPos >= path.Length Then
            Return Nothing
        End If
        Dim pictureName As String = path.Substring(startPathPos)
        Dim myPicturesPath As String = Environment.GetEnvironmentVariable("public") & "\Pictures"
        If Not myPicturesPath.EndsWith("\") Then
            myPicturesPath += "\"
        End If
        Dim picturePath As String = System.IO.Path.Combine(myPicturesPath, pictureName)
        If Not File.Exists(picturePath) Then
            Return Nothing
        End If
        Dim stream As New MemoryStream()
        Try
            Dim picture As Image = Image.FromFile(picturePath)
            picture.Save(stream, picture.RawFormat)
            stream.Position = 0
        Catch generatedExceptionName As OutOfMemoryException
            ' The file is not valid image, or GDI+ doesn't support such images.
            Return Nothing
        Catch generatedExceptionName As ExternalException
            Return Nothing
    End Try
    Return stream
End Function

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System;
using System.Drawing;
using System.Globalization;
using System.IO;
using System.Runtime.InteropServices;
using System.Windows.Forms;
using GrapeCity.ActiveReports.Extensibility;
using your_project_name.Properties;
    C# code. Paste BELOW the Using statements Copy Code
    namespace your_project_name
{
    // Look for the resources in My Pictures folder.
    internal sealed class MyPicturesLocator : ResourceLocator
    {
        private const string UriSchemeMyImages = "MyPictures:";
        // Obtain and return the resource.
        public override Resource GetResource(ResourceInfo resourceInfo)
        {
            string name = resourceInfo.Name;
            if (name == null || name.Length == 0)
            {
                throw new ArgumentException("The name of resource to be obtained should be non-empty string.", "name");
            }
            Uri uri = new Uri(name);
            Stream stream = GetPictureFromSpecialFolder(name);
            if (stream == null)
            {
               stream = new MemoryStream();
            }
            return new Resource(stream, uri);
        }
        // Returns the specified image from Public Pictures folder.
        private static Stream GetPictureFromSpecialFolder(string path)
        {
            int startPathPos = UriSchemeMyImages.Length;
            if (startPathPos >= path.ToString().Length)
            {
                return null;
            }
            string pictureName = path.ToString().Substring(startPathPos);
            string myPicturesPath = Environment.GetEnvironmentVariable("public") + \\Pictures;
            if (!myPicturesPath.EndsWith("\\")) myPicturesPath += "\\";
            string picturePath = Path.Combine(myPicturesPath, pictureName);
                        if (!File.Exists(picturePath)) return null;
            MemoryStream stream = new MemoryStream();
            try
            {
                Image picture = Image.FromFile(picturePath);
                picture.Save(stream, picture.RawFormat);
                stream.Position = 0;
            }
            catch (OutOfMemoryException) // The file is not valid image, or GDI+ doesn't support such images.
            {
                return null;
            }
            catch (ExternalException)
            {
                return null;
            }
            return stream;
        }
    }
}

Create the PreviewForm

  1. In the Solution Explorer, select the Form1 in the Design view and in the Properties panel, set the properties as follows.
    Property Name | Property Value
    Name | PreviewForm
    Text | Preview Form
    Size | 1015, 770
  2. From the Visual Studio toolbox, drag the Viewer control onto the PreviewForm and in the Properties panel, set the following properties.
    Property Name | Property Value
    Name | reportPreview1
    Dock | Fill
  3. Double-click the PreviewForm to create an instance for the Load event and add the following code.

    Show To write the code in Visual Basic.NET

    VB code. Paste BELOW the Import statements Copy Code
    Imports GrapeCity.ActiveReports.Document
Imports System.IO
Imports GrapeCity.ActiveReports
    VB code. Paste INSIDE the Load event Copy Code
    Dim myPicturesPath As String = Environment.GetEnvironmentVariable("public") + _Pictures
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx")
reportData.Position = 0
Dim reader As New StreamReader(reportData)
Dim def As New PageReport(reader)
def.ResourceLocator = New MyPicturesLocator()
Dim runtime As New PageDocument(def)
reportPreview1.ReportViewer.LoadDocument(runtime)

    Show To write the code in C#

    C# code. Paste BELOW the Using statements Copy Code
    using GrapeCity.ActiveReports.Document;
using System.IO;
using GrapeCity.ActiveReports;
    C# code. Paste INSIDE the Load event Copy Code
    string myPicturesPath = Environment.GetEnvironmentVariable("public") + \\Pictures;
Stream reportData = GetType().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx");
reportData.Position = 0;
StreamReader reader = new StreamReader(reportData);
PageReport def = new PageReport(reader);
def.ResourceLocator = new MyPicturesLocator();
PageDocument runtime = new PageDocument(def);
reportPreview1.ReportViewer.LoadDocument(runtime);
  4. Press F5 to run the project.

See Also

Caching Reports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Map Tile Provider Customization

Map Tile Provider Customization
Developers > Extensibility in ActiveReports > Map Tile Provider Customization

Glossary Item Box

Show All Show All
Hide All Hide All

You can add and configure a Custom Tile Provider in the Map control using the IMapTileProvider and IMapTile interfaces.

The IMapTileProvider interface contains detailed settings that are required to communicate with the tile server, whereas the IMapTile interface represents a single tile of a Map's tile layer that fetches the tile image based on the configurations in the IMapTileProvider interface.

Set a Custom Tile Provider

Adding a custom tile provider also requires making some modifications in the ActiveReports.config file. Follow these steps to learn how to set a custom tile provider:

  1. Create a Class Library Project, for example MyClassLib, in Visual Studio.
  2. Add a new Class to the project and name the class, for example, MyTileProvider. You may add functions and features to this class for getting the Tile images based on your tile server settings and details. This class serves as the interface between your Map control and your custom tile server. Replace the existing code with the following in the MyTileProvider class to implement the IMapTileProvider interface.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
   Public Class MyTileProvider Implements IMapTileProvider
        ' Tile provider settings, like ApiKey, Language, Style and etc.
        Public Property Settings() As NameValueCollection
        ' Add your code here.
        End Property
        ' Get instance of tile by specifying tile coordinates and details.
        Public Sub GetTile(key As MapTileKey, success As Action(Of IMapTile),
     [error] As Action(Of Exception))
        ' Add your code here.
        End Sub
    End Class

    End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
{
    public Class MyTileProvider :IMapTileProvider
    {// Tile provider settings, like ApiKey, Language, Style and etc.
    public NameValueCollection Settings { get; private set;}
    // Get instance of tile by specifying tile coordinates and details.
    public void GetTile(MapTileKey key, Action<IMapTile> success, Action<Exception> error);
    // Add your code here.
    }
}

  3. Add a new Class to the project and name the class, for example, MyMapTile. Replace the existing code with the following in the MyMapTile class to implement the IMapTile interface.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
   Public Class MyMapTile Implements IMapTile
       ' Gets the tile identifier
       Public Property Id() As MapTileKey
       ' Add your code here
       End Property
       ' Gets the tile image stream.
       Public Property Image() As Stream
       ' Add your code here.
       End Property
   End Class
End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System.IO;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
   public class MyMapTile : IMapTile
   {   // Gets the tile identifier.
       public MapTileKey Id { get; private set; }
       // Gets the tile image stream.
       public Stream Image { get; private set; }
       // Add your code here.
    }
}
  4. Add another Class to the project and name the class, for example, WebRequestHelper. Replace the existing code with the following in the WebRequestHelper class to implement the loading of raw website data into the System.IO.MemoryStream class.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System.IO
Imports System.Net
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
    Module StringExtensions
        Public Sub CopyTo(ByVal input As Stream, ByVal output As Stream)
        'Add your code here
        End Sub
        Private Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Module
    Friend NotInheritable Class WebRequestHelper
        Private Sub New()
        End Sub
        ' Load raw data into MemoryStream from specified Url.
        Public Shared Function DownloadData(url As String, timeoutMilliseconds As Integer) As Stream
        'Add your code here
        End Function
        'Load raw data into MemoryStream from specified Url.
        Public Shared Sub DownloadDataAsync(url As String, timeoutMilliseconds As Integer,
     success As Action(Of MemoryStream), [error] As Action(Of Exception))
        'Add your code here
        End Sub
        Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Class
End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System.IO;
using System.Net;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
{
    internal static class WebRequestHelper
    {   // Load raw data into MemoryStream from specified Url.
        public static Stream DownloadData(string url, int timeoutMilliseconds)
        {//Add your code here  }
        public static void DownloadDataAsync(string url, int timeoutMilliseconds,
     Action<MemoryStream> success, Action<Exception> error)
        {//Add your code here  }
        public static void CopyTo(this Stream input, Stream output)
        {//Add your code here  }
    }
}
  5. Save and build your class library project and locate the new .dll file in its Bin>Debug folder. This file has the same name as your class library project, with a .dll extension.
  6. Create a Basic End User Designer in a new solution following the steps in Creating a Basic End User Designer.
  7. Run your Basic End User Designer project to create a EndUserDesigner.exe in your projects Bin>Debug folder.
  8. Copy the ActiveReports.config file from the C:\Program Files (x86)\MESCIUS\ActiveReports 19\ location and paste it into your End User Designer project's Bin>Debug folder.
    Caution: ActiveReports.config file should always be placed inside the same folder as the EndUserDesigner.exe file for displaying a tile layer on a Map.
  9. Right-click on the ActiveReports.config file and select Include in this Project to make changes in the config file.
  10. Double-click to open the ActiveReports.config file and paste the following code between the <Configuration> and </Configuration> tags:
    Paste between the <Configuration></Configuration> tags. Copy Code
    <!-- Register and configure custom tile provider. -->
<MapTileProvider Name="Custom" DisplayName="Custom Provider" type="YourTileProvider, AssemblyName,
     Version = x.x.x.x">
    <Settings>
      <add key="ApiKey" value="API Key" />
    </Settings>
</MapTileProvider>
    Note: Replace YourTileProvider with fully qualified class name and AssemblyName with the name of the assembly created after implementing IMapTileProvider and IMapTile interfaces.
  11. Add the Class Library project created in step 5 to your Basic End User Designer project.
  12. Copy the YourProjectName.dll created in step 5 and paste it to the current project's Bin > Debug folder together with the EndUserDesigner.exe.
  13. Save and Run the project.
  14. Create a Report containing a Map control in the Basic End User Designer. See Map Data Region for more information.
  15. Add a Tile layer to the Map control. Right click the Tile layer and select Edit to view the custom tile provider added in the Provider drop-down. See Tile Layer for more information.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Data Provider Customization

Data Provider Customization
Developers > Extensibility in ActiveReports > Data Provider Customization

Glossary Item Box

Data sources customization in ActiveReports is one of the most popular demands. Our Oracle Data Provider sample demonstrates the custom data providers implementation details.

Note: Our built-in Visual Query Designer supports only a limited number of data providers or the SQL dialect. Thus, in most cases you need to use a plain data provider without any additional schema and other implementations.

To support a custom data provider in Web, you need to perform some additional steps:

  • Specify configuration with the UseConfig method. See Configure ActiveReports Using Code topic for details.
  • Specify new data providers on both server and client sides for the WebDesigner. See our Custom Data Providers sample for details.

Create a Custom Data Provider

A custom data provider allows you to use non-traditional data sources in your Page reports, both at run time and at design time. Let us learn how to create a solution with projects that create a custom data provider and demonstrate how it pulls data from a comma separated values (CSV) file.

When you complete these steps, you will have a designer pre-loaded with a report that pulls data from a CSV file and looks like the following.

Custom Data Provider

Create a Designer project to demonstrate the custom data provider

  1. In Visual Studio, create a Windows Forms project and name it CustomDataProviderDemo.
  2. From the Visual Studio toolbox ActiveReports 19 tab, drag a ReportExplorer and drop it onto the default Windows form, resizing the form to a comfortable working area.
  3. In the Properties window, set the Dock property of the ReportExplorer control to Left.
  4. From the toolbox Common Controls tab, drag a RichTextBox control onto the form and set the Dock property to Top.
  5. Add the following text to the Text property.
    Text. Paste in the Text property of the RichTextBox. Copy Code
    1. In the Report Explorer, right-click the Data Sources node and select Add Data Source.
2. In the Report Data Source dialog that appears, on the General tab, drop down the Type box, select CSV Data Provider, and click OK.
3. In the Report Explorer, right-click DataSource1 and select Add Data Set.
4. In the dialog that appears, select the Query page.
5. Drop down the Query String box to display the custom query editor.
6. Click the Select CSV File button and open the Categories.csv file in this project.
7. Click OK to save the changes and close the dialog.
8. Click Preview to see the report with data from the csv file.
  6. From the toolbox ActiveReports 19 tab, drag a Designer control and drop it on the empty part of the form.
  7. Set the Dock property to Fill, then right-click the Designer control on the form and select Bring to front.
  8. Select the ReportExplorer control and in the Properties window, drop down the ReportDesigner property and select Designer1.
  9. Double-click on the form's title bar to create a form Load event, and add code like the following above the class.
    Visual Basic.NET code. Paste above the class. Copy Code
    Imports System.Xml
Imports System.IO
Imports GrapeCity.ActiveReports.Design
    C# code. Paste above the class. Copy Code
    using System.Xml;
using System.IO;
using GrapeCity.ActiveReports.Design;
  10. Add the following code to the form Load event.
    Visual Basic.NET code. Paste inside the form Load event. Copy Code
    Using reportStream = File.OpenRead("DemoReport.rdlx")
        Using reader = XmlReader.Create(reportStream)
                Designer1.LoadReport(reader, DesignerReportType.Page)
        End Using
End Using
    C# code. Paste inside the form Load event. Copy Code
    using (var reportStream = File.OpenRead("DemoReport.rdlx"))
 {
     using (var reader = XmlReader.Create(reportStream))
      {
         designer1.LoadReport(reader, DesignerReportType.Page);
      }
 }

Configure the project to use a custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select Text File, name it ActiveReports.config, and click Add.
  3. In the Solution Explorer, select the new file and in the Properties window, set its Copy to Output Directory property to Copy always.
  4. Paste the following text into the file and save it. (You can safely ignore the warning that the 'Configuration' element is not declared.)
    Paste into the config file. Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Configuration>
  <Extensions>
    <Data>
      <Extension Name="CSV" DisplayName="CSV Data Provider"
        Type="CustomDataProvider.CsvDataProvider.CsvDataProviderFactory,
          CustomDataProvider"
          CommandTextEditorType="CustomDataProvider.CSVDataProvider.QueryEditor,
        CustomDataProvider"/>
    </Data>
     </Extensions>
</Configuration>
  5. In the Solution Explorer, right-click the project and select Add, then New Item.
  6. In the dialog that appears, select Text File, name it Categories.csv, and click Add.
  7. In the Solution Explorer, click to select the file, and in the Properties window, change the Copy to Output Directory property to Copy always.
  8. Paste the following text into the file and save it.
    Paste into the text file. Copy Code
    EmployeeID(int32),LastName,FirstName,Role,City
1,James,Yolanda,Owner,Columbus
7,Reed,Marvin,Manager,Newton
9,Figg,Murray,Cashier,Columbus
12,Snead,Lance,Store Keeper,Columbus
15,Halm,Jeffry,Store Keeper,Columbus
17,Hames,Alma,Store Keeper,Oak Bay
18,Nicki,Aubrey,Store Keeper,Columbus
24,Cliett,Vikki,Store Keeper,Newton

Add a report to show the data from the custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select ActiveReports 19 RDLX report, name it DemoReport, and click Add.
  3. In the Solution Explorer, click to select the report, and in the Properties window, change the Copy to Output Directory property to Copy always.
  4. From the ActiveReports 19 RDLX report Toolbox, drag a Table report control onto the report.
    Note: In case you are still working on Page Report layout, set the FixedSize property of the Table control to display all data on one page.
  5. Click inside the table to reveal the table adorners, then right-click the table adorner to the left of the footer row and select Delete Rows. The footer row is removed from the table.
  6. In the Report Explorer, select each of the textboxes in turn and set the properties as in the following table. (If you do not see the Report Explorer, from the View menu, select Other Windows, then Report Explorer.)
    TextBox Name | Value Property | BackgroundColor Property
    TextBox1 | Name | MediumSlateBlue
    TextBox2 | Role | MediumSlateBlue
    TextBox3 | City | MediumSlateBlue
    TextBox4 | =Fields!FirstName.Value & " " & Fields!LastName.Value
    TextBox5 | =Fields!Role.Value
    TextBox6 | =Fields!City.Value
  7. In the Report Explorer, select the Table1 node and in the Properties window, set the Location property to 0in, 1in and the Size property to 6in, 0.5in to make the table wide enough to see all of the data.
  8. With Table1 still selected in the Properties window, in the DataSetName property, enter the text DataSet1.

Add a class library project to the solution to contain the custom data provider

  1. From the File menu, select Add, then New Project.
  2. In the Add New Project dialog, select Class Library, and name the project CustomDataProvider.
  3. In the Solution Explorer, right-click the default class and select Delete. (We will add our classes to a folder below.)
  4. Install packages from nuget as follows:
    i) Go to Tools > Nuget Package Manager > Manage Nuget Packages for Solution...
    ii) Browse the following packages one by one and click Install.
    MESCIUS.ActiveReports
    MESCIUS.ActiveReports.Extensibility
  5. Right-click the CustomDataProvider project and select Add, then New Folder, and name the folder CSVDataProvider.
  6. Right-click the folder and select Add, then Class, then name the class CsvColumn and add code like the following to replace the default stub in the class.
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Namespace CSVDataProvider
        ' Represents information about fields in the data source.
        Friend Structure CsvColumn
                Private ReadOnly _fieldName As String
                Private ReadOnly _dataType As Type
                ' Creates a new instance of the CsvColumn class.
                ' The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                ' The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                Public Sub New(fieldName As String, dataType As Type)
                        If fieldName Is Nothing Then
                                Throw New ArgumentNullException("fieldName")
                        End If
                        If dataType Is Nothing Then
                                Throw New ArgumentNullException("dataType")
                        End If
                        _fieldName = fieldName
                        _dataType = dataType
                End Sub

                ' Gets the name of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property FieldName() As String
                        Get
                                Return _fieldName
                        End Get
                End Property

                ' Gets the the Type of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property DataType() As Type
                        Get
                                Return _dataType
                        End Get
                End Property

                ' Returns a String that represents this instance of the CsvColumn.
                Public Overrides Function ToString() As String
                        Return [String].Concat(New String() {FieldName, "(", DataType.ToString(), ")"})
                End Function

                ' Determines whether two CsvColumn instances are equal.
                ' The obj represents the CsvColumn to compare with the current CsvColumn.
                ' Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                Public Overrides Function Equals(obj As Object) As Boolean
                        Dim flag As Boolean
                        If TypeOf obj Is CsvColumn Then
                                flag = Equals(CType(obj, CsvColumn))
                        Else
                                flag = False
                        End If
                        Return flag
                End Function
                Private Overloads Function Equals(column As CsvColumn) As Boolean
                        Return column.FieldName = FieldName
                End Function

                ' Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
                ' Returns a hash code for the current CsvColumn instance.
                Public Overrides Function GetHashCode() As Integer
                        Return (FieldName.GetHashCode() + DataType.GetHashCode())
                End Function
        End Structure
End Namespace
    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
namespace CustomDataProvider.CSVDataProvider
{
        // Represents information about fields in the data source.
        internal struct CsvColumn
        {
                private readonly string _fieldName;
                private readonly Type _dataType;
                // Creates a new instance of the CsvColumn class.
                // The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                // The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                public CsvColumn(string fieldName, Type dataType)
                {
                        if (fieldName == null)
                                throw new ArgumentNullException("fieldName");
                        if (dataType == null)
                                throw new ArgumentNullException("dataType");
                        _fieldName = fieldName;
                        _dataType = dataType;
                }

                // Gets the name of the field represented by this instance of the CsvColumn.
                public string FieldName
                {
                        get { return _fieldName; }
                }

                // Gets the the Type of the field represented by this instance of the CsvColumn.
                public Type DataType
                {
                        get { return _dataType; }
                }

               // Returns a String that represents this instance of the CsvColumn.
                public override string ToString()
                {
                        return String.Concat(new string[] {FieldName, "(", DataType.ToString(), ")"});
                }

                // Determines whether two CsvColumn instances are equal.
                // The obj represents the CsvColumn to compare with the current CsvColumn.
                // Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                public override bool Equals(object obj)
                {
                        bool flag;
                        if (obj is CsvColumn)
                        {
                                flag = Equals((CsvColumn) obj);
                        }
                        else
                        {
                                flag = false;
                        }
                        return flag;
                }
                private bool Equals(CsvColumn column)
                {
                        return column.FieldName == FieldName;
                }

                // Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
               // Returns a hash code for the current CsvColumn instance.
                public override int GetHashCode()
                {
                        return (FieldName.GetHashCode() + DataType.GetHashCode());
                }
        }
}
  7. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataReader and add code like the following to replace the default stub in the class.
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.Collections
Imports System.Globalization
Imports System.IO
Imports System.Text.RegularExpressions
Imports GrapeCity.ActiveReports.Extensibility.Data
Namespace CSVDataProvider
    ' Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
    Friend Class CsvDataReader
        Implements IDataReader
        'NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
        'Otherwise data types end up as strings when using Int32 vs int32.
        Private _typeLookup As New Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, False))
        Private _columnLookup As New Hashtable()
        Private _columns As Object()
        Private _textReader As TextReader
        Private _currentRow As Object()

        'The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
        'multi-threading, we made the properties read-only so no one can change any properties on these objects.
        Private Shared ReadOnly _rxDataRow As New Regex(",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled)
        'Used to parse the data rows.
        Private Shared ReadOnly _rxHeaderRow As New Regex("(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled)
        'Used to parse the header rows.

        ' Creates a new instance of the CsvDataReader class.
        ' The textReader parameter represents the TextReader to use to read the data.
        Public Sub New(textReader As TextReader)
            _textReader = textReader
            ParseCommandText()
        End Sub

        ' Parses the passed-in command text.
        Private Sub ParseCommandText()
            If _textReader.Peek() = -1 Then
                Return
            End If
            'Command text is empty or at the end already.
            FillTypeLookup()
            Dim header As String = _textReader.ReadLine()
            header = AddDefaultTypeToHeader(header)
            If Not ParseHeader(header) Then
                Throw New InvalidOperationException( _
                "Field names and types are not defined. " & _
                "The first line in the CommandText must contain the field names and data types. e.g FirstName(string)")
            End If
        End Sub
        'A hashtable is used to return a type for the string value used in the header text.
        Private Sub FillTypeLookup()
            _typeLookup.Add("string", GetType([String]))
            _typeLookup.Add("byte", GetType([Byte]))
            _typeLookup.Add("boolean", GetType([Boolean]))
            _typeLookup.Add("datetime", GetType(DateTime))
            _typeLookup.Add("decimal", GetType([Decimal]))
            _typeLookup.Add("double", GetType([Double]))
            _typeLookup.Add("int16", GetType(Int16))
            _typeLookup.Add("int32", GetType(Int32))
            _typeLookup.Add("int", GetType(Int32))
            _typeLookup.Add("integer", GetType(Int32))
            _typeLookup.Add("int64", GetType(Int64))
            _typeLookup.Add("sbyte", GetType([SByte]))
            _typeLookup.Add("single", GetType([Single]))
            _typeLookup.Add("time", GetType(DateTime))
            _typeLookup.Add("date", GetType(DateTime))
            _typeLookup.Add("uint16", GetType(UInt16))
            _typeLookup.Add("uint32", GetType(UInt32))
            _typeLookup.Add("uint64", GetType(UInt64))
        End Sub

        ' Returns a type based on the string value passed in from the header text string. If no match is found,
        ' a string type is returned.
        ' The fieldType parameter represents the String value from the header command text string.
        Private Function GetFieldTypeFromString(fieldType As String) As Type
            If _typeLookup.Contains(fieldType) Then
                Return TryCast(_typeLookup(fieldType), Type)
            End If
            Return GetType([String])
        End Function

        ' Parses the first line in the passed-in command text string to create the field names and field data types.
        ' The field information is stored in a CsvColumn struct, and these column info items are stored
        ' in an ArrayList. The column name is also added to a hashtable for easy lookup later.
        ' The header parameter represents the header string that contains all the fields.
        ' Returns True if it can parse the header string; otherwise False.
        Private Function ParseHeader(header As String) As Boolean
            Dim fieldName As String
            Dim index As Integer = 0
            If header.IndexOf("(") = -1 Then
                Return False
            End If
            Dim matches As MatchCollection = _rxHeaderRow.Matches(header)
            _columns = New Object(matches.Count - 1) {}
            For Each match As Match In matches
                fieldName = match.Groups("fieldName").Value
                Dim fieldType As Type = GetFieldTypeFromString(match.Groups("fieldType").Value)
                _columns.SetValue(New CsvColumn(fieldName, fieldType), index)
                _columnLookup.Add(fieldName, index)
                index += 1
            Next
            Return True
        End Function

        ' Ensures that the header contains columns in the form of name(type)
        ' The line parameter represents the raw header line from the file to fix up.
        ' Returns a modified header with default types appended to column names.
        Private Shared Function AddDefaultTypeToHeader(line As String) As String
            Const ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
            Dim columns As String() = line.Split(New String() {","}, StringSplitOptions.None)
            Dim ret As String = Nothing
            For Each column As String In columns
                If Not String.IsNullOrEmpty(ret) Then
                    ret += ","
                End If
                If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
                    ret += column + "(string)"
                Else
                    ret += column
                End If
            Next
            Return ret
        End Function

        ' Parses a row of data using a regular expression and stores the information inside an object
        ' array that is the current row of data.
        ' If the row does not have the correct number of fields, an exception is raised.
        ' The dataRow parameter represents the String value representing a comma delimited data row.
        ' Returns True if it can parse the data string; otherwise False.
        Private Function ParseDataRow(dataRow As String) As Boolean
            Dim index As Integer = 0
            Dim tempData As String() = _rxDataRow.Split(dataRow)
            _currentRow = New Object(tempData.Length - 1) {}
            If tempData.Length <> _columns.Length Then
                Dim [error] As String = String.Format(CultureInfo.InvariantCulture, _
                                "Invalid row ""{0}"". The row does not contain the same number of data columns as the table header definition.", dataRow)
                Throw New InvalidOperationException([error])
            End If
            For i As Integer = 0 To tempData.Length - 1
                Dim value As String = tempData(i)
                If value.Length > 1 Then
                    If value.IndexOf(""""c, 0) = 0 AndAlso value.IndexOf(""""c, 1) = value.Length - 1 Then
                        value = value.Substring(1, value.Length - 2)
                    End If
                End If
                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index)
                index += 1
            Next
            Return True
        End Function

        ' Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
        ' This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
        ' The type parameter represents the Type of the current column the data belongs to.
        ' The originalValue parameter represents the String value coming from the command text.
        ' Returns the object resulting from the converted string, based on the type.
        Private Function ConvertValue(type As Type, originalValue As String) As Object
            Dim fieldType As Type = type
            Dim invariantCulture As CultureInfo = CultureInfo.InvariantCulture
            Try
                If originalValue = """""" OrElse originalValue = " " Then
                    Return String.Empty
                End If
                If originalValue = "" Then
                    Return DBNull.Value
                End If
                If originalValue = "DBNull" Then
                    Return DBNull.Value
                End If
                If fieldType.Equals(GetType([String])) Then
                    Return originalValue.Trim()
                End If
                If fieldType.Equals(GetType(Int32)) Then
                    Return Convert.ToInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Boolean])) Then
                    Return Convert.ToBoolean(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(DateTime)) Then
                    Return Convert.ToDateTime(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Decimal])) Then
                    Return Convert.ToDecimal(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Double])) Then
                    Return Convert.ToDouble(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int16)) Then
                    Return Convert.ToInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int64)) Then
                    Return Convert.ToInt64(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Single])) Then
                    Return Convert.ToSingle(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Byte])) Then
                    Return Convert.ToByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([SByte])) Then
                    Return Convert.ToSByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt16)) Then
                    Return Convert.ToUInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt32)) Then
                    Return Convert.ToUInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt64)) Then
                    Return Convert.ToUInt64(originalValue, invariantCulture)
                End If
            Catch e As Exception
                Throw New InvalidOperationException(String.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e)
            End Try
            'If no match is found return DBNull instead.
            Return DBNull.Value
        End Function
#Region "IDataReader Members"

       ' Advances the CsvDataReader to the next record.
        ' Returns True if there are more rows; otherwise, False.
        Public Function Read() As Boolean Implements IDataReader.Read
            If _textReader.Peek() > -1 Then
                ParseDataRow(_textReader.ReadLine())
            Else
                Return False
            End If
            Return True
        End Function
#End Region
#Region "IDisposable Members"

        ' Releases the resources used by the CsvDataReader.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub
        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _textReader IsNot Nothing Then
                    _textReader.Close()
                End If
            End If
            _typeLookup = Nothing
            _columnLookup = Nothing
            _columns = Nothing
            _currentRow = Nothing
        End Sub

        ' Allows an Object to attempt to free resources and perform
        ' other cleanup operations before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub
#End Region
#Region "IDataRecord Members"

        ' Gets the number of columns in the current row.
        Public ReadOnly Property FieldCount() As Integer Implements IDataRecord.FieldCount
            Get
                Return _columns.Length
            End Get
        End Property

        ' The i parameter represents the index of the field to find.
        ' Returns the Type information corresponding to the type of Object that would be returned from GetValue.
        Public Function GetFieldType(i As Integer) As Type Implements IDataReader.GetFieldType
            If i > _columns.Length - 1 Then
                Return Nothing
            End If
            Return DirectCast(_columns.GetValue(i), CsvColumn).DataType
        End Function

        ' Gets the name for the field to find.
        ' The i parameter represents the index of the field to find.
        ' Returns the name of the field or an empty string (""), if there is no value to return.
        Public Function GetName(i As Integer) As String Implements IDataRecord.GetName
            If i > _columns.Length - 1 Then
                Return String.Empty
            End If

            Return DirectCast(_columns.GetValue(i), CsvColumn).FieldName
        End Function

        ' The name parameter represents the name of the field to find.
        ' Returns the index of the named field.
        Public Function GetOrdinal(name As String) As Integer Implements IDataRecord.GetOrdinal
            Dim value As Object = _columnLookup(name)
            If value Is Nothing Then
                Throw New IndexOutOfRangeException("name")
            End If
            Return CInt(value)
        End Function

        ' The i parameter represents the index of the field to find.
        ' Returns the Object which contains the value of the specified field.
        Public Function GetValue(i As Integer) As Object Implements IDataRecord.GetValue
            If i > _columns.Length - 1 Then
                Return Nothing
            End If
            Return _currentRow.GetValue(i)
        End Function
        Public Overridable Function GetData(fieldIndex As Integer) As IDataReader Implements IDataReader.GetData
            Throw New NotSupportedException()
        End Function
#End Region
    End Class
End Namespace
    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
using System.Collections;
using System.Globalization;
using System.IO;
using System.Text.RegularExpressions;
using GrapeCity.ActiveReports.Extensibility.Data;
namespace CustomDataProvider.CSVDataProvider
{
        // Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
        internal class CsvDataReader : IDataReader
        {
                //NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
                                //Otherwise data types end up as strings when using Int32 vs int32.
                private Hashtable _typeLookup =
                        new Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, false));
                private Hashtable _columnLookup = new Hashtable();
                private object[] _columns;
                private TextReader _textReader;
                private object[] _currentRow;

                //The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
                //multi-threading, we made the properties read-only so no one can change any properties on these objects.
                private static readonly Regex _rxDataRow = new Regex(@",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled);
                        //Used to parse the data rows.
                private static readonly Regex _rxHeaderRow =
                        new Regex(@"(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled);
                        //Used to parse the header rows.

                // Creates a new instance of the CsvDataReader class.
                // The textReader parameter represents the TextReader to use to read the data.
                public CsvDataReader(TextReader textReader)
                {
                        _textReader = textReader;
                        ParseCommandText();
                }

                // Parses the passed-in command text.
                private void ParseCommandText()
                {
                        if (_textReader.Peek() == -1)
                                return; //Command text is empty or at the end already.
                        FillTypeLookup();
                        string header = _textReader.ReadLine();
                        header = AddDefaultTypeToHeader(header);
                        if (!ParseHeader(header))
                                throw new InvalidOperationException(
                                        "Field names and types are not defined. The first line in the CommandText must contain the field names and data types. e.g FirstName(string)");
                }
                //A hashtable is used to return a type for the string value used in the header text.
                private void FillTypeLookup()
                {
                        _typeLookup.Add("string", typeof (String));
                        _typeLookup.Add("byte", typeof (Byte));
                        _typeLookup.Add("boolean", typeof (Boolean));
                        _typeLookup.Add("datetime", typeof (DateTime));
                        _typeLookup.Add("decimal", typeof (Decimal));
                        _typeLookup.Add("double", typeof (Double));
                        _typeLookup.Add("int16", typeof (Int16));
                        _typeLookup.Add("int32", typeof (Int32));
                        _typeLookup.Add("int", typeof (Int32));
                        _typeLookup.Add("integer", typeof (Int32));
                        _typeLookup.Add("int64", typeof (Int64));
                        _typeLookup.Add("sbyte", typeof (SByte));
                        _typeLookup.Add("single", typeof (Single));
                        _typeLookup.Add("time", typeof (DateTime));
                        _typeLookup.Add("date", typeof (DateTime));
                        _typeLookup.Add("uint16", typeof (UInt16));
                        _typeLookup.Add("uint32", typeof (UInt32));
                        _typeLookup.Add("uint64", typeof (UInt64));
                }

                // Returns a type based on the string value passed in from the header text string. If no match is found, a string type is returned.
                // The fieldType parameter represents the String value from the header command text string.
                private Type GetFieldTypeFromString(string fieldType)
                {
                        if (_typeLookup.Contains(fieldType))
                                return _typeLookup[fieldType] as Type;
                        return typeof (String);
                }

                // Parses the first line in the passed-in command text string to create the field names and field data types. The field information
                // is stored in a CsvColumn struct, and these column info items are stored in an ArrayList. The column name is also added
                // to a hashtable for easy lookup later.

                // The header parameter represents the header string that contains all the fields.
                // Returns True if it can parse the header string; otherwise False.
                private bool ParseHeader(string header)
                {
                        string fieldName;
                        int index = 0;
                        if (header.IndexOf("(") == -1)
                                return false;
                        MatchCollection matches = _rxHeaderRow.Matches(header);
                        _columns = new object[matches.Count];
                        foreach (Match match in matches)
                        {
                                fieldName = match.Groups["fieldName"].Value;
                                Type fieldType = GetFieldTypeFromString(match.Groups["fieldType"].Value);
                                _columns.SetValue(new CsvColumn(fieldName, fieldType), index);
                                _columnLookup.Add(fieldName, index);
                                index++;
                        }
                        return true;
                }

                // Ensures that the header contains columns in the form of name(type)
                // The line parameter represents the raw header line from the file to fix up.
                // Returns a modified header with default types appended to column names.
                private static string AddDefaultTypeToHeader(string line)
                {
                        const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
                        string[] columns = line.Split(new string[] { "," }, StringSplitOptions.None);
                        string ret = null;
                        foreach (string column in columns)
                        {
                                if (!string.IsNullOrEmpty(ret))
                                        ret += ",";
                                if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
                                {
                                        ret += column + "(string)";
                                }
                                else
                                {
                                        ret += column;
                                }
                        }
                        return ret;
                }

                // Parses a row of data using a regular expression and stores the information inside an object array that is the current row of data.
                // If the row does not have the correct number of fields, an exception is raised.
                // The dataRow parameter represents the String value representing a comma delimited data row.
                // Returns True if it can parse the data string; otherwise False.
                private bool ParseDataRow(string dataRow)
                {
                        int index = 0;
                        string[] tempData = _rxDataRow.Split(dataRow);
                        _currentRow = new object[tempData.Length];
                        if (tempData.Length != _columns.Length)
                        {
                                string error =
                                        string.Format(CultureInfo.InvariantCulture,
                                                      "Invalid row \"{0}\". The row does not contain the same number of data columns as the table header definition.",
                                                      dataRow);
                                throw new InvalidOperationException(error);
                        }
                        for (int i = 0; i < tempData.Length; i++)
                        {
                                string value = tempData[i];
                                if (value.Length > 1)
                                {
                                        if (value.IndexOf('"', 0) == 0 && value.IndexOf('"', 1) == value.Length - 1)
                                                value = value.Substring(1, value.Length - 2);
                                }
                                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index);
                                index++;
                        }
                        return true;
                }

                // Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
                // This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
                // The type parameter represents the Type of the current column the data belongs to.
                // The originalValue parameter represents the String value coming from the command text.
                // Returns the object resulting from the converted string, based on the type.
                private object ConvertValue(Type type, string originalValue)
                {
                        Type fieldType = type;
                        CultureInfo invariantCulture = CultureInfo.InvariantCulture;
                        try
                        {
                                if (originalValue == "\"\"" || originalValue == " ")
                                        return string.Empty;
                                if (originalValue == "")
                                        return DBNull.Value;
                                if (originalValue == "DBNull")
                                        return DBNull.Value;
                                if (fieldType.Equals(typeof (String)))
                                        return originalValue.Trim();
                                if (fieldType.Equals(typeof (Int32)))
                                        return Convert.ToInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Boolean)))
                                        return Convert.ToBoolean(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (DateTime)))
                                        return Convert.ToDateTime(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Decimal)))
                                        return Convert.ToDecimal(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Double)))
                                        return Convert.ToDouble(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int16)))
                                        return Convert.ToInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int64)))
                                        return Convert.ToInt64(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Single)))
                                        return Convert.ToSingle(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Byte)))
                                        return Convert.ToByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (SByte)))
                                        return Convert.ToSByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt16)))
                                        return Convert.ToUInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt32)))
                                        return Convert.ToUInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt64)))
                                        return Convert.ToUInt64(originalValue, invariantCulture);
                        }
                        catch (Exception e)
                        {
                                throw new InvalidOperationException(
                                        string.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e);
                        }
                        //If no match is found return DBNull instead.
                        return DBNull.Value;
                }
                #region IDataReader Members

                // Advances the CsvDataReader to the next record.
                // Returns True if there are more rows; otherwise, False.
                public bool Read()
                {
                        if (_textReader.Peek() > -1)
                                ParseDataRow(_textReader.ReadLine());
                        else
                                return false;
                        return true;
                }
                #endregion
                #region IDisposable Members

                // Releases the resources used by the CsvDataReader.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }
                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_textReader != null)
                                        _textReader.Close();
                        }
                        _typeLookup = null;
                        _columnLookup = null;
                        _columns = null;
                        _currentRow = null;
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvDataReader()
                {
                        Dispose(false);
                }
                #endregion
                #region IDataRecord Members

                // Gets the number of columns in the current row.
                public int FieldCount
                {
                        get { return _columns.Length; }
                }

                // The i parameter represents the index of the field to find.
                // Returns the Type information corresponding to the type of Object that would be returned from GetValue.
                public Type GetFieldType(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;
                        return ((CsvColumn) _columns.GetValue(i)).DataType;
                }

                // Gets the name for the field to find.
                // The i parameter represents the index of the field to find.
                // Returns the name of the field or an empty string (""), if there is no value to return.
                public string GetName(int i)
                {
                        if (i > _columns.Length - 1)
                                return string.Empty;

                        return ((CsvColumn) _columns.GetValue(i)).FieldName;
                }

                // The name parameter represents the name of the field to find.
                // Returns the index of the named field.
                public int GetOrdinal(string name)
                {
                        object value = _columnLookup[name];
                        if (value == null)
                                throw new IndexOutOfRangeException("name");
                        return (int) value;
                }

                // The i parameter represents the index of the field to find.
                // Returns the Object which contains the value of the specified field.
                public object GetValue(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;
                        return _currentRow.GetValue(i);
                }
                public virtual IDataReader GetData(int fieldIndex)
                {
                        throw new NotSupportedException();
                }
                #endregion
        }
}
  8. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvCommand and add code like the following to replace the default stub in the class.
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Data
Namespace CSVDataProvider
    ' Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvCommand
        Implements IDbCommand
        Private _commandText As String
        Private _connection As IDbConnection
        Private _commandTimeout As Integer
        Private _commandType As CommandType

        ' Creates a new instance of the CsvCommand class.
        Public Sub New()
            Me.New(String.Empty)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text.
        ' The commandText parameter represents the command text.
        Public Sub New(commandText As String)
            Me.New(commandText, Nothing)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text and a CsvConnection.
        ' The commandText parameter represents the command text.
        ' The connection parameter represents a CsvConnection to a data source.
        Public Sub New(commandText As String, connection As CsvConnection)
            _commandText = commandText
            _connection = connection
        End Sub

        ' Gets or sets the command to execute at the data source.
        Public Property CommandText() As String Implements IDbCommand.CommandText
            Get
                Return _commandText
            End Get
            Set(value As String)
                _commandText = value
            End Set
        End Property

        ' Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
        Public Property CommandTimeout() As Integer Implements IDbCommand.CommandTimeout
            Get
                Return _commandTimeout
            End Get
            Set(value As Integer)
                _commandTimeout = value
            End Set
        End Property

        ' Gets or sets a value indicating how the CommandText property is interpreted.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property CommandType() As CommandType Implements IDbCommand.CommandType
            Get
                Return _commandType
            End Get
            Set(value As CommandType)
                _commandType = value
            End Set
        End Property

        ' Gets or sets the CsvConnection used by this instance of the CsvCommand.
        Public Property Connection() As IDbConnection
            Get
                Return _connection
            End Get
            Set(value As IDbConnection)
                _connection = value
            End Set
        End Property

       ' Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
        ' The behavior parameter represents a CommandBehavior value.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader(behavior As CommandBehavior) As IDataReader Implements IDbCommand.ExecuteReader
            Return New CsvDataReader(New StringReader(_commandText))
        End Function

        ' Returns a string that represents the command text with the parameters expanded into constants.
        Public Function GenerateRewrittenCommandText() As String Implements IDbCommand.GenerateRewrittenCommandText
            Return _commandText
        End Function

        ' Sends the CommandText to the CsvConnection and builds a CsvDataReader.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader() As IDataReader Implements IDbCommand.ExecuteReader
            Return ExecuteReader(CommandBehavior.SchemaOnly)
        End Function
#Region "Non implemented IDbCommand Members"
        Public ReadOnly Property Parameters() As IDataParameterCollection Implements IDbCommand.Parameters
            Get
                Throw New NotImplementedException()
            End Get
        End Property
        Public Property Transaction() As IDbTransaction Implements IDbCommand.Transaction
            Get
                Throw New NotImplementedException()
            End Get
            Set(value As IDbTransaction)
                Throw New NotImplementedException()
            End Set
        End Property
        Public Sub Cancel() Implements IDbCommand.Cancel
        End Sub
        Public Function CreateParameter() As IDataParameter Implements IDbCommand.CreateParameter
            Throw New NotImplementedException()
        End Function
#End Region
#Region "IDisposable Members"

        ' Releases the resources used by the CsvCommand.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _connection IsNot Nothing Then
                    _connection.Dispose()
                    _connection = Nothing
                End If
            End If
        End Sub
#End Region
    End Class
End Namespace
    C# code. Paste it to replace the default stub in the class Copy Code
    using System;
using System.IO;
using GrapeCity.ActiveReports.Extensibility.Data;
namespace CustomDataProvider.CSVDataProvider
{
       // Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
        public sealed class CsvCommand : IDbCommand
        {
                private string _commandText;
                private IDbConnection _connection;
                private int _commandTimeout;
                private CommandType _commandType;

                /// Creates a new instance of the CsvCommand class.
                public CsvCommand()
                        : this(string.Empty)
                {
                }

                // Creates a new instance of the CsvCommand class with command text.
                // The commandText parameter represents the command text.
                public CsvCommand(string commandText)
                        : this(commandText, null)
                {
                }

                // Creates a new instance of the CsvCommand class with command text and a CsvConnection.
                // The commandText parameter represents the command text.
                // The connection parameter represents a CsvConnection to a data source.?
                public CsvCommand(string commandText, CsvConnection connection)
                {
                        _commandText = commandText;
                        _connection = connection;
                }

                // Gets or sets the command to execute at the data source.
                public string CommandText
                {
                        get { return _commandText; }
                        set { _commandText = value; }
                }

                // Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
                public int CommandTimeout
                {
                        get { return _commandTimeout; }
                        set { _commandTimeout = value; }
                }

                // Gets or sets a value indicating how the CommandText property is interpreted.
               // Remarks: We don't use this one for the Csv Data Provider.
                public CommandType CommandType
                {
                        get { return _commandType; }
                        set { _commandType = value; }
                }

               // Gets or sets the CsvConnection used by this instance of the CsvCommand.
                public IDbConnection Connection
                {
                        get { return _connection; }
                        set { _connection = value; }
                }

                // Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
                // The behavior parameter represents a CommandBehavior value.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader(CommandBehavior behavior)
                {
                        return new CsvDataReader(new StringReader(_commandText));
                }

               // Returns a string that represents the command text with the parameters expanded into constants.
                public string GenerateRewrittenCommandText()
                {
                        return _commandText;
                }

                // Sends the CommandText to the CsvConnection and builds a CsvDataReader.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader()
                {
                        return ExecuteReader(CommandBehavior.SchemaOnly);
                }
                #region Non implemented IDbCommand Members
                public IDataParameterCollection Parameters
                {
                        get { throw new NotImplementedException(); }
                }
                public IDbTransaction Transaction
                {
                        get { throw new NotImplementedException(); }
                        set { throw new NotImplementedException(); }
                }
                public void Cancel()
                {

                }
                public IDataParameter CreateParameter()
                {
                        throw new NotImplementedException();
                }
                #endregion
                #region IDisposable Members

                // Releases the resources used by the CsvCommand.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_connection != null)
                                {
                                        _connection.Dispose();
                                        _connection = null;
                                }
                        }
                }
                #endregion
        }
}
  9. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvConnection and add code like the following to replace the default stub in the class. (You can safely ignore the errors, as they will go away when you add the CsvConnection class.)
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Data
Namespace CSVDataProvider
    ' Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvConnection
        Implements IDbConnection
        Private _localizedName As String
        ' Creates a new instance of the CsvConnection class.
        Public Sub New()
            _localizedName = "Csv"
        End Sub
       ' Creates a new instance of the CsvConnection class.
       ' The localizedName parameter represents the localized name for the CsvConnection instance.
        Public Sub New(localizeName As String)
            _localizedName = localizeName
        End Sub
#Region "IDbConnection Members"
        ' Gets or sets the string used to open the connection to the data source.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property ConnectionString() As String Implements IDbConnection.ConnectionString
            Get
                Return String.Empty
            End Get
            Set(value As String)

            End Set
        End Property
        ' Gets the amount of time to wait while trying to establish a connection before terminating
        ' the attempt and generating an error.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public ReadOnly Property ConnectionTimeout() As Integer Implements IDbConnection.ConnectionTimeout
            Get
                Throw New NotImplementedException()
            End Get
        End Property
        ' Begins a data source transaction.
        ' Returns an object representing the new transaction.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Function BeginTransaction() As IDbTransaction Implements IDbConnection.BeginTransaction
            Return Nothing
        End Function
        ' Opens a data source connection.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Sub Open() Implements IDbConnection.Open

        End Sub
        ' Closes the connection to the data source. This is the preferred method of closing any open connection.
        Public Sub Close() Implements IDbConnection.Close
            Dispose()
        End Sub
        ' Creates and returns a CsvCommand object associated with the CsvConnection.
        Public Function CreateCommand() As IDbCommand Implements IDbConnection.CreateCommand
            Return New CsvCommand(String.Empty)
        End Function
        Public Property DataProviderService() As IDataProviderService Implements IDbConnection.DataProviderService
            Get
                Return Nothing
            End Get
            Set(value As IDataProviderService)
            End Set
        End Property
#End Region
#Region "IDisposable Members"
        ' Releases the resources used by the CsvConnection.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub
        Private Sub Dispose(disposing As Boolean)
        End Sub
       ' Allows an Object to attempt to free resources and perform other cleanup operations
        ' before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub
#End Region
#Region "IExtension Members"
       ' Gets the localized name of the CsvConnection.
        Public ReadOnly Property LocalizedName() As String Implements IDbConnection.LocalizedName
            Get
                Return _localizedName
            End Get
        End Property
       ' Specifies any configuration information for this extension.
       ' The configurationSettings parameter represents a NameValueCollection of the settings.
        Public Sub SetConfiguration(configurationSettings As NameValueCollection) Implements IDbConnection.SetConfiguration
        End Sub
#End Region
    End Class
End Namespace
    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Data;
namespace CustomDataProvider.CSVDataProvider
{
        // Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
        public sealed class CsvConnection : IDbConnection
        {
                private string _localizedName;

                // Creates a new instance of the CsvConnection class.
                public CsvConnection()
                {
                        _localizedName = "Csv";
                }

                // Creates a new instance of the CsvConnection class.
                // The localizedName parameter represents the localized name for the CsvConnection instance.
                public CsvConnection(string localizeName)
                {
                        _localizedName = localizeName;
                }
                #region IDbConnection Members

               // Gets or sets the string used to open the connection to the data source.
               // Remarks: We don't use this one for the Csv Data Provider.
                public string ConnectionString
                {
                        get { return string.Empty; }
                        set { ; }
                }

                // Gets the amount of time to wait while trying to establish a connection before terminating the attempt and generating an error.
                // Remarks: We don't use this one for the Csv Data Provider.
                public int ConnectionTimeout
                {
                        get { throw new NotImplementedException(); }
                }

               // Begins a data source transaction.
               // Returns an object representing the new transaction.
               // Remarks: We don't use this one for the Csv Data Provider.
                public IDbTransaction BeginTransaction()
                {
                        return null;
                }

               // Opens a data source connection.
               // Remarks: We don't use this one for the Csv Data Provider.
                public void Open()
                {
                        ;
                }

                // Closes the connection to the data source. This is the preferred method of closing any open connection.
                public void Close()
                {
                        Dispose();
                }

               // Creates and returns a CsvCommand object associated with the CsvConnection.
                public IDbCommand CreateCommand()
                {
                        return new CsvCommand(string.Empty);
                }
                public IDataProviderService DataProviderService
                {
                        get { return null; }
                        set { }
                }
                #endregion
                #region IDisposable Members

               // Releases the resources used by the CsvConnection.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }
                private void Dispose(bool disposing)
                {
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvConnection()
                {
                        Dispose(false);
                }
                #endregion
                #region IExtension Members

                // Gets the localized name of the CsvConnection.
                public string LocalizedName
                {
                        get { return _localizedName; }
                }

                // Specifies any configuration information for this extension.
                // The configurationSettings parameter represents a NameValueCollection of the settings.
                public void SetConfiguration(NameValueCollection configurationSettings)
                {
                }
                #endregion
        }
}
  10. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataProviderFactory and add code like the following to replace the default stub in the class.
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Imports GrapeCity.ActiveReports.Extensibility.Data
Imports GrapeCity.BI.Data.DataProviders
Namespace CSVDataProvider
       ' Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        Public Class CsvDataProviderFactory
                Inherits DataProviderFactory
                ' Creates new instance of the CsvDataProviderFactory class.
                Public Sub New()
                End Sub
               ' Returns a new instance of the the CsvCommand.
                Public Overrides Function CreateCommand() As IDbCommand
                        Return New CsvCommand()
                End Function
                ' Returns a new instance of the the CsvConnection.
                Public Overrides Function CreateConnection() As IDbConnection
                        Return New CsvConnection()
                End Function
        End Class
End Namespace
    C# code. Paste it to replace the default stub in the class. Copy Code
    using GrapeCity.ActiveReports.Extensibility.Data;
using GrapeCity.BI.Data.DataProviders;
namespace CustomDataProvider.CSVDataProvider
{
       // Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        public class CsvDataProviderFactory : DataProviderFactory
        {

                // Creates new instance of the CsvDataProviderFactory class.
                public CsvDataProviderFactory()
                {
                }

               // Returns a new instance of the the CsvCommand.
                public override IDbCommand CreateCommand()
                {
                        return new CsvCommand();
                }

               // Returns a new instance of the the CsvConnection.
                public override IDbConnection CreateConnection()
                {
                        return new CsvConnection();
                }
        }
}

Add a button to the query editor

  1. In the Solution Explorer, right-click the CSVDataProvider folder and select Add, then Class, then name the class QueryEditor and add code like the following to replace the default stub in the class.
    Visual Basic.NET code. Paste it to replace the default stub in the class. Copy Code
    Imports System.Collections.Generic
 Imports System.Drawing.Design
 Imports System.IO
 Imports System.Linq
 Imports System.Text
 Imports System.Text.RegularExpressions
 Imports System.Windows.Forms
 Imports System.Windows.Forms.Design

 Namespace CustomDataProvider.CSVDataProvider
     Public NotInheritable Class QueryEditor
         Inherits UITypeEditor
         Public Overrides Function GetEditStyle(context As System.ComponentModel.ITypeDescriptorContext) As UITypeEditorEditStyle
             Return UITypeEditorEditStyle.DropDown
         End Function
         Public Overrides Function EditValue(context As System.ComponentModel.ITypeDescriptorContext, provider As System.IServiceProvider, value As Object) As Object
             Dim edSvc As IWindowsFormsEditorService = DirectCast(provider.GetService(GetType(IWindowsFormsEditorService)), IWindowsFormsEditorService)
             Dim path = ""
             Dim btn = New Button()
             btn.Text = "Select CSV File..."
             Dim pdg = btn.Padding
             pdg.Bottom += 2
             btn.Padding = pdg
             btn.Click += Sub() Using openDlg = New OpenFileDialog()
                 openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*"
                 If openDlg.ShowDialog() <> DialogResult.OK Then
                     path = ""
                 Else
                     path = openDlg.FileName
                 End If
             End Using
             edSvc.DropDownControl(btn)
             If String.IsNullOrEmpty(path) Then
                 Return String.Empty
             End If
             If Not File.Exists(path) Then
                 Return String.Empty
             End If
             Return GetCSVQuery(path)
         End Function
        Private Function GetCSVQuery(path As String) As Object
             Dim sr As StreamReader = Nothing
             Try
                 sr = New StreamReader(path)
                 Dim ret As String = String.Empty
                 Dim currentLine As String
                 Dim line As Integer = 0
                 While (InlineAssignHelper(currentLine, sr.ReadLine())) IsNot Nothing
                     If line = 0 Then
                         ret += ProcessColumnsDefinition(currentLine) & Convert.ToString(vbCr & vbLf)
                     Else
                         ret += currentLine & Convert.ToString(vbCr & vbLf)
                     End If
                     line += 1
                 End While
                 Return ret
             Catch generatedExceptionName As IOException
                 Return String.Empty
             Finally
                 If sr IsNot Nothing Then
                     sr.Close()
                 End If
             End Try
         End Function
         Private Function ProcessColumnsDefinition(currentLine As String) As String
             Const  ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
             Dim columns As String() = currentLine.Split(New String() {","}, StringSplitOptions.None)
             Dim ret As String = Nothing
             For Each column As String In columns
                 If Not String.IsNullOrEmpty(ret) Then
                     ret += ","
                 End If
                 If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
                     ret += column & Convert.ToString("(string)")
                 Else
                     ret += column
                 End If
             Next
             Return ret
         End Function
         Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
             target = value
             Return value
         End Function
     End Class
 End Namespace
    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
 using System.Collections.Generic;
 using System.Drawing.Design;
 using System.IO;
 using System.Linq;
 using System.Text;
 using System.Text.RegularExpressions;
 using System.Windows.Forms;
 using System.Windows.Forms.Design;
 namespace CustomDataProvider.CSVDataProvider
 {
     public sealed class QueryEditor : UITypeEditor
     {
         public override UITypeEditorEditStyle GetEditStyle(System.ComponentModel.ITypeDescriptorContext context)
         {
             return UITypeEditorEditStyle.DropDown;
         }
        public override object EditValue(System.ComponentModel.ITypeDescriptorContext context, System.IServiceProvider provider, object value)
         {
             IWindowsFormsEditorService edSvc = (IWindowsFormsEditorService)provider.GetService(typeof(IWindowsFormsEditorService));
             var path = "";
             var btn = new Button();
             btn.Text = "Select CSV File...";
             var pdg = btn.Padding;
             pdg.Bottom += 2;
             btn.Padding = pdg;
             btn.Click += delegate
             {
                 using (var openDlg = new OpenFileDialog())
                 {
                     openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*";
                     if (openDlg.ShowDialog() != DialogResult.OK)
                         path = "";
                     else
                         path = openDlg.FileName;
                 }
             };
             edSvc.DropDownControl(btn);
             if (string.IsNullOrEmpty(path)) return string.Empty;
             if (!File.Exists(path)) return string.Empty;
             return GetCSVQuery(path);
         }
         private object GetCSVQuery(string path)
         {
             StreamReader sr = null;
             try
             {
                 sr = new StreamReader(path);
                 string ret = string.Empty;
                 string currentLine;
                 int line = 0;
                 while ((currentLine = sr.ReadLine()) != null)
                 {
                     if (line == 0)
                         ret += ProcessColumnsDefinition(currentLine) + "\r\n";
                     else
                         ret += currentLine + "\r\n";
                     line++;
                 }
                 return ret;
             }
             catch (IOException)
             {
                 return string.Empty;
             }
             finally
             {
                 if (sr != null)
                     sr.Close();
             }
         }
         private string ProcessColumnsDefinition(string currentLine)
        {
             const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
             string[] columns = currentLine.Split(new string[] { "," }, StringSplitOptions.None);
             string ret = null;
             foreach (string column in columns)
             {
                 if (!string.IsNullOrEmpty(ret))
                     ret += ",";
                 if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
                 {
                    ret += column + "(string)";
                 }
                 else
                 {
                     ret += column;
                 }
             }
             return ret;
         }
     }
 }
  2. In the Solution Explorer, right-click the CustomDataProviderDemo project and select Add Reference. In the Reference Manager dialog that appears, on the Projects tab, select CustomDataProvider and click OK.
  3. Run the project, and follow the instructions in the RichTextBox to see the custom data provider in action.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


External Customizations in ActiveReports

External Customizations in ActiveReports
See Also
Developers > External Customizations in ActiveReports

Glossary Item Box

This article discusses the possibilities to use ActiveReports.NET with other technologies.

ActiveReports gives you opportunity to customize reports, viewers, and exports if you are looking for customization at different levels of using the product.

Reports

ActiveReports provides the following extension possibilities for reports:

  • Scripts or external assemblies
  • Custom report items
  • Сustom data providers
  • Сustom map tile providers

ActiveReports provides many reports-related features. If you are looking for more possibilities, you can try the following extensions:

  • Customize with scripts or external assemblies

    To have custom assemblies load in restricted domains, you should add a configuration file with the name of yourApp.exe.config file as follows.

    yourApp.exe.config file Copy Code
    <configuration>
    <runtime>
       <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <probing privatePath="PrivateBin"/>
       </assemblyBinding>
    </runtime>
 </configuration>
    Limitation: Private assemblies are deployed in the same directory structure as the application. If the directories, specified in the privatePath setting are not under ApplicationBase, they are ignored.
  • Customize with custom report items

    ActiveReports delivers a number of samples demonstrating how to use custom report items. See the Samples page for details.

  • Customize with custom data providers

    To learn about possible options, see Custom Data Providers in Configure ActiveReports using Config File.

  • Customize with custom map tile providers

    To learn about possible options, see Custom Map Tile Providers in Configure ActiveReports using Config File.

Viewers

ActiveReports provides various ways to create your own preview control, including different platforms for custom viewers based on the JS Viewer component and the Blazor Viewer control.

The Custom Preview sample demonstrates how to create your own preview control and show report output in a custom preview form. You can find the Custom Preview sample here. You can modify both viewer's mouse mode and touch mode toolbars and set custom commands. You can also customize the Viewer control to make it a perfect fit for your Windows application by adding and removing toolbar buttons, adding and removing menu items, creating custom dialogs, and calling them from custom click events. For more information, see Customize the WinForms Viewer Control.

With the JS Viewer component and the Blazor Viewer control, you can implement your own preview control on many different platforms like:

  • PWAs
  • .NET MAUI (WebView)
  • .NET MAUI Blazor (BlazorWebView)

Exports

You can create custom exports in your ActiveReports applications. ActiveReports provides a lot of various powerful exports that cover most situations.

However, you can write your own exports as demonstrated in the CustomPdfExport sample. It shows how to write custom exports for non-embedded fonts. Such tasks have some limitations because they are dependent on the internal API.

However, the simplest way is to write custom export to graphics-like formats: PDF, SVG, DrawingML, XPS, etc. More complex formats may require a lot of work.

Environment

ActiveReports delivers implementation solutions that can work in different environments. We recommend that you consider this logic when making a decision on what option to choose:

  • Use Page/RDLX reports, Section report requires some knowledge on writing scripts and is intended mainly for developers.
  • Use custom font resolving (and distribute fonts together with your application).
  • Use the new Blazor viewer for the cross-platform UI. See following articles from Visual Studio
    • https://visualstudiomagazine.com/articles/2021/02/17/net-6-preview-1.aspx
    • https://visualstudiomagazine.com/articles/2021/04/09/blazorwebview.aspx

See Also

Extensibility in ActiveReports

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Export Reports

Export Reports
Developers > Export Reports

Glossary Item Box

In this section, learn about the independent ways to export a report to different formats, and some export implementations.

  • Rendering Extensions:

Use the Render method in Rendering Extensions of the PageDocument class to render Page report and RDLX report to Image, Html, Pdf, Xml, Word, and Excel and other formats. For more information, see Export Page/RDLX Reports.

  • Export Filters:

Use the Export method of the corresponding ExportFilter class to export a Section report, Page report, and RDLX report. Exporting in Section Report is only possible through Export Filters. For more information about Export Filters in Section Reports, see Export Section Reports.

  • Set PDF Print Presets

Use the PrintPresets class to export a Section report, Page report, and RDLX Report. The print preset properties are only available with the Professional Edition license. For more information about Export Filters in Section Reports, see Print Reports.

.

Note: In ASP.NET Core applications, supported export formats are - Excel (.xlsx), Word (.docx), PDF, CSV, JSON, and TIFF.

For more information on the supported export formats, see Exports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Export Page/RDLX Reports

Export Page/RDLX Reports
Developers > Export Reports > Export Page/RDLX Reports

Glossary Item Box

To export Page/RDLX reports, use the Render method in the rendering extensions of the PageDocument class. Each export format provides its own set of properties to control how the report is rendered. Explore the following export abilities available in Page/RDLX reports.

To export Page/RDLX reports to RTF format, use MESCIUS.ActiveReports.Export.Rdf package. See Section report's RTF Export topic.
  • HTML Export
  • PDF Export
  • Image Export
  • XML Export
  • Excel Export
  • Word Export
  • CSV Export
  • JSON Export
  • Excel Data Export
  • Text Print Export

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


HTML Export

HTML Export
Developers > Export Reports > Export Page/RDLX Reports > HTML Export

Glossary Item Box

HTML, or hypertext markup language, is a format that opens in a Web browser. You can export your reports to HTML. It is a good format for delivering content because virtually all users have an HTML browser. The HTMLRenderingExtension renders your report in this format with improved table border rendering and high-quality SVG output for charts. If you do not want to use SVG in charts, set the RenderingEngine property to Html.

HTML Rendering Properties

ActiveReports offers several options to control how reports render to HTML.

Property | Description
EmbedImages | Set to true to embed image in the html file.
Fragment | Determine whether or not the full HTML text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be returned. The default is false.
OutputTOC | Indicates whether the report's existing TOC should be added to the output.
RenderingEngine | The RenderingEngine property is set to Mixed by default for improved quality output. The choices are Html or Mixed, where Mixed uses SVG to render charts.
StyleStream | Set the StyleStream to True to create an external .css file containing style information from your report controls' style properties. If you prefer to have style information embedded in the HTML file, set the StyleStream property to False.
LinkTarget | Specify a link target to control whether drill-down reports and other links open in a new window or reuse the current window. By default, no value is set and links open in the same window. A value of _blank opens the link in a new window, or you can specify a window using window_name. By default, this value is not set.
Mode | Galley mode renders the report in one HTML stream. Select Paginated mode to render each page as a section inside the HTML document.

Interactivity

Reports rendered in HTML support a number of interactive features. Hyperlinks, Bookmarks, and Drill through links can be rendered to HTML. However, Document Maps are not available in this format. For a drill-down report, make sure that the data you want to display is expanded before rendering, otherwise, it renders in the hidden state.

Limitations

  • HTML is not the best format for printing. Use the PDF rendering extension instead.
  • Diagonal lines, Page margins, Border/Line styles (like DashedDotDot, DashDot, WindowInset) are not supported.
  • CheckBox color does not affect the color of the square.
  • TextIndent and FillCharacter properties of the TableOfContents control's Level setting are not supported.

Export Report using HTML Rendering Extension

The following steps provide an example of rendering a report in HTML format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Html package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the high-quality title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.
Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyHTML")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim htmlSetting As New GrapeCity.ActiveReports.Export.Html.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = htmlSetting

' Set the rendering extension and render the report.
Dim htmlRenderingExtension As New GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(htmlRenderingExtension, outputProvider, htmlSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.

System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyHTML");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Html.Page.Settings htmlSetting = new GrapeCity.ActiveReports.Export.Html.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = htmlSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension htmlRenderingExtension = new GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(htmlRenderingExtension, outputProvider, htmlSetting);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


PDF Export

PDF Export
Developers > Export Reports > Export Page/RDLX Reports > PDF Export

Glossary Item Box

Portable Document Format (PDF), is a format recommended for printing and for preserving formatting. You can use the PDFRenderingExtension to render your report in this format. With the PDF rendering extension, you can use features such as font linking, digital signatures, and end user-defined characters (EUDC). These features are only available in the Professional Edition of ActiveReports.

PDF Rendering Properties

ActiveReports offers a number of options to control how reports render to PDF.

Property | Description
Application | Set the value that appears for application in the Document Properties dialog of the PDF viewer application.
Author | Enter the name of the author to appear in the Document Properties dialog of the PDF viewer application.
CenterWindow | Set to True to position the document's window in the center of the screen.
DisplayMode | Specifies how the document is displayed when opened. FullScreen mode displays the document with no menu bar, window controls, or any other window visible.
DisplayTitle | Set to True to display text you enter in the Title property. When set to False it displays the name of the PDF file.
DocumentToAddAfterReport | Indicates the path of the PDF document to be inserted at the end of the rendering output.
DocumentToAddBeforeReport | Indicates the path of the PDF document to be inserted at the beginning of the rendering output.
DpiX | Set the horizontal resolution of the rendered PDF file.
DpiY | Set the vertical resolution of the rendered PDF file.
EmbedFonts | Select how the fonts used in the report should be embedded in the PDF document. Note: By default, all fonts get embedded in the exported PDF document.
Encrypt | Determines whether the document is encrypted or not. Note: If Encrypt is set to False, permissions and passwords have no effect.
EndPage | The last page of the report to render. The default value is the value for StartPage,that is,0.
FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
ImageInterpolation | Interpolation value of images. Allows enabling and disabling image interpolation, when exporting the file to PDF.
Keywords | Keywords associated with the document.
NeverEmbedFonts | Gets or sets the semicolon-delimited string of the font families to be embedded in the PDF document.
OwnerPassword | The owner password that can be entered in the reader, which permits full access to the document regardless of the specified user permissions.
PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Pagination | Gets or sets the value that indicates whether to use pagination in the exported PDF document.
Permissions | Specifies the user permissions for the document. Permissions can be combined using a comma between values.
PrintLayoutMode | Specifies layout mode to be used for PDF documents.
PrintOnOpen | Gets or sets the value indicating whether the document should be printed after it is open.
PrintPresets | Gets or sets the PDF print preset dialog.
SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered.
Subject | The subject of the document.
Title | The title of the document.
UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however, the user will be restricted by the specified permissions.
Version | Set the output PDF version. The supported versions are: PDF-1.2 | PDF-1.3 | PDF-1.4(default) | PDF-1.5 | PDF-1.6 | PDF-1.7 | PDF-2.0 | PDF/A-1a | PDF/A-1b | PDF/A-2a | PDF/A-2b | PDF/A-2u | PDF/A-3a | PDF/A-3b | PDF/A-3u | PDF/UA-1
WatermarkAngle | Specify the degree of angle for the watermark text on the PDF document. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the PDF document. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFontName | Set the font to use for the watermark on the PDF document.
WatermarkFontSize | Set the font size to use for the watermark on the PDF document.
WatermarkFontStyle | Set the font style to use for the watermark on the PDF document.
WatermarkPrintOnly | Specify whether to print a report with a watermark on it via a printer or a Microsoft print to PDF. The default value is False.
WatermarkTitle | Enter text (i.e. CONFIDENTIAL) to use as the watermark on the PDF document.

PDF Print Presets Properties

ActiveReports allows you to preset the printing properties for PDF report exports using the PrintPresets class. This prepopulates the print settings in the Print dialog box. Please see Use PDF Printing Presets for more information.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.
Property | Description
PageScaling | Specify scaling for the printable area. You can select Default to shrink to the printable area, or you can select None for the actual size.
DuplexMode

Specify the duplex mode of the printer. For the best results with the duplex option, the selected printer should support duplex printing. You can choose from the following values,

  • Simplex: Prints on one side of the paper. This is the default value.
  • Duplex (Flip on long edge): Prints on both sides of the paper with paper flip on the long edge.
  • Duplex (Flip on short edge): Prints on both sides of the paper with paper flip on the short edge.
PaperSourceByPageSize | Determines the output tray based on PDF page size, rather than page setting options. This option is useful when printing PDFs with multiple page sizes, where different sized output trays are available. By default, this option is set to False.
PrintPageRange | Specify the range of page numbers 1-3 or 1, 2, 3.
NumberOfCopies | Specify the number of copies to print. You can select any number of copies from 2 to 5, or select Default to specify a single copy.
Note: These properties are available in PDF version 1.7 or higher. The PageScaling property is supported in PDF version 1.6.

PDF Features

Interactivity

PDF is considered the best format for printing and it also supports interactive features like Document Map, Bookmarks, and Hyperlinks. However, in case you have any data hidden (like in a drill-down report) at the time of rendering, it does not show up in the output. Therefore, it is recommended to expand all toggle items prior to rendering.

Editable PDF: InputField Control

In Page and RDLX reports, you can use the InputField report control. This control provides support for editable fields in an exported PDF report file where the InputField’s value can be modified.

There are two types of InputField - Text and Checkbox, which you can set in the InputType property. Each type has its own set of properties: the Text type of the InputField control gets the set of properties of the TextBox control. If the Checkbox type is selected, then the new control inherits the set of properties of the CheckBox control.

Tagged PDF

You can generate PDFs with tagging on the report content by setting the AccessibleDescription property of the report controls: Bullet, Barcode, Chart, Image, Line, Map, Shape, Sparkline, and FormattedText controls; and all custom report items. The PDF versions that support tagged PDFs conforming with the PDF/UA standard are PDF/A-1a, PDF/A-2a, PDF/A-2u, PDF/A-3a, PDF/A-3u, and PDF/UA-1.

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • The DocumentToAddBeforeReport and DocumentToAddAfterReport properties of the PDF Rendering Extension settings are ignored.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Export Report using PDF Rendering Extension

The following steps provide an example of rendering a report in PDF format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Pdf package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
VB code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.
Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")
Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyPDF")

outputDirectory.Create()

' Provide settings for your rendering output.
Dim pdfSetting As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory,System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyPDF");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Pdf.Page.Settings pdfSetting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new
        GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();

GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory,
        System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


ZUGFeRD/Factur-X Invoices

ZUGFeRD/Factur-X Invoices
Developers > Export Reports > Export Page/RDLX Reports > PDF Export > ZUGFeRD/Factur-X Invoices

Glossary Item Box

ActiveReports provides a special API for performing additional manual steps, required for creating ZUGFeRD reports. For details about this extension, see FeRD website.

You should note the information below when working with a ZUGFeRD report:

  • It should have the PDF/A-3 format.
  • It should have the ZUGFeRD-invoice.xml attachment. We suggest to use the Data Excel export or CSV/XML/JSON exports to obtain data. We also suggest to use this library to generate ZUGFeRD-invoice.xml (for ZUGFeRD 1.0) or zugferd-invoice.xml (for ZUGFeRD 2.0) or factur-x.xml (for ZUGFeRD 2.1 and Factur-X).
  • It should have additional XMP metadata.

Adding Metadata in PDFs

An example of adding metadescriptions

Metadata such as keywords, descriptions are used by the search engines to narrow down the searches. You can add a number of predefined accessors, such as title, contributors, creators, copyright, description, etc. using AdditionalMetadata property. The allowed namespaces are:

  • Dublin Core Properties
  • XMP Core Properties
  • PDF Properties
VB code. Paste INSIDE the Form Load event. Copy Code
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\PageReport1.rdlx")
Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)
Dim outputDirectory As System.IO.DirectoryInfo = New System.IO.DirectoryInfo("C:\MyPDF")
outputDirectory.Create()
Dim pdfSetting = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
'Imports GrapeCity.ActiveReports.Export.Pdf
pdfSetting.AdditionalMetadata.Add(New AdditionalMetadataInfo With {
        .[Namespace] = AdditionalMetadataNamespace.PurlOrg,
        .Key = "title",
        .Value = "Invoice"
    })

Dim pdfRenderingExtension As GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\PageReport1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyPDF");
outputDirectory.Create();

// Add meta data.
var pdfSetting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();

// using GrapeCity.ActiveReports.Export.Pdf;
pdfSetting.AdditionalMetadata.Add(new AdditionalMetadataInfo
{
    Namespace = AdditionalMetadataNamespace.PurlOrg, // Dublin Core Properties
    Key = "title",
    Value = "Invoice"
});
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting);

Adding Attachment

An example of adding metadescriptions

You can include an attachment as metadata (such as invoices) to exported PDFs using Attachments property. This property allows attaching files such as a .xml or a .txt file in PDF. Below is the code example to export RDLX and Page reports to PDF and attach a file to the exported PDF.

VB code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\PageReport1.rdlx")
Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As System.IO.DirectoryInfo = New System.IO.DirectoryInfo("C:\MyPDF")
outputDirectory.Create()

' Add attachment.
Dim pdfSetting = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
pdfSetting.Attachments.Add(New AttachmentInfo With {
   .Name = "file.txt",
   .Content = System.IO.File.ReadAllBytes("D:\Reports\file.txt"),
   .Description = "attachment description" ' optional
})
Dim pdfRenderingExtension As GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
outputProvider.OverwriteOutputFile = True
pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\PageReport1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyPDF");
outputDirectory.Create();

// Add attachment.
var pdfSetting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
// using GrapeCity.ActiveReports.Export.Pdf;
pdfSetting.Attachments.Add(new AttachmentInfo
{
    Name = "file.txt",
    Content = System.IO.File.ReadAllBytes(@"D:\Reports\file.txt"),
    Description = "attachment description" // optional
});
// or
//{
//   Name = "file.xml",
//   Content = File.ReadAllBytes(Application.StartupPath + "\\file.xml")
//};
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting);

Open the exported PDF and you should see the attachment. Check the left sidebar in Adobe Acrobat Reader DC.

Note: Metadata in PDFs is part of the Professional Edition. It is supported with the PDF version PDF/A-3b (or higher).

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Image Export

Image Export
Developers > Export Reports > Export Page/RDLX Reports > Image Export

Glossary Item Box

Image is the format that converts your report to an image file. You can use the ImageRenderingExtension to render your report in this format. Make sure that you select an ImageType to any of the six different image formats available: BMP, GIF, JPEG, TIFF, and PNG.

Note: By default, the image rendering extension creates a separate file for each page in a report and adds an index to each corresponding file name (for example, image001.PNG, image002.PNG, etc).

To render the entire report as a single image, set the Pagination setting to False.

Image Rendering Properties

ActiveReports offers several options to control how reports render to Image.

Property | Description
Compression | Sets or returns a value which specifies the compression to be used when exporting.
Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
DpiX | Adjust the horizontal resolution of rendered images. The default value is 96.
DpiY | Adjust the vertical resolution of rendered images.
ImageType | Select the type of image to which you want to render the report. Supported types are BMP, GIF, JPEG, TIFF, and PNG.
Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Quality | Gets or sets the quality of the report to be rendered as a JPEG image.

Export Report using Image Rendering Extension

Reports rendered as images do not support any of the interactive features of Active Reports. Any data hidden at the time of export is hidden in the image. To display all data in a drill-down report, expand all toggle items prior to exporting.

The following steps provide an example of rendering a report in Image format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Image package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.

Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyImage")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim imageSetting As New GrapeCity.ActiveReports.Export.Image.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = imageSetting

' Set the rendering extension and render the report.
Dim imageRenderingExtension As New GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(imageRenderingExtension, outputProvider, imageSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyImage");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Image.Page.Settings imageSetting = new GrapeCity.ActiveReports.Export.Image.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = imageSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension imageRenderingExtension = new GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(imageRenderingExtension, outputProvider, imageSetting);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


XML Export

XML Export
Developers > Export Reports > Export Page/RDLX Reports > XML Export

Glossary Item Box

XML is a useful format for delivering data to other applications as the resulting XML file opens in an internet browser. You can use the XmlRenderingExtension to render your report in this format. XML is a good format for delivering data to other applications. The resulting XML file opens in an internet browser.

Xml Rendering Properties

ActiveReports offers several options to control how reports render to XML.

Property | Description
Encoding | Select the encoding schema to use in the XML transformation.
XslStylesheet | Select the existing XSL Stylesheet file to use to transform the resulting XML file. Note: When using the XslStylesheet option, be sure to save the file in the correct file format, such as HTML.

Controlling XML Output

You can also control XML output through properties on the individual report controls. These properties are:

  • DataElementName Indicates the name to use for the data element or attribute.
  • DataElementOutput Indicates whether the report controls render in the XML output.
  • DataElementStyle Indicates whether a text box renders as an element or an attribute.
  • DetailDataCollectionName Indicates the name to use for the collection of all instances of the detail group in the XML output.
  • DetailDataElementName Indicates the name to use for instances of the detail group in the XML output.
  • DetailDataElementOutput Indicates whether the details appear in the XML output.
  • DataInstanceElementOutput Indicates whether a list appears in the XML output. (This property is ignored if there is a grouping in the list.)
  • DataInstanceName Indicates the name to use for instances of the list in the XML output.

Interactivity

XML format does not support interactive features except that when rendering a report to XML, complete drill-down data is shown regardless of whether the data is rendered in an expanded state or not.

Export Report using XML Rendering Extension

The following steps provide an example of rendering a report in XML format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Xml package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.

Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyXml")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim xmlSetting As New GrapeCity.ActiveReports.Export.Xml.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = xmlSetting

' Set the rendering extension and render the report.
Dim xmlRenderingExtension As New GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension()

Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(xmlRenderingExtension, outputProvider, xmlSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyXml");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Xml.Page.Settings xmlSetting = new GrapeCity.ActiveReports.Export.Xml.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = xmlSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension xmlRenderingExtension = new GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(xmlRenderingExtension, outputProvider, xmlSetting);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Excel Export

Excel Export
Developers > Export Reports > Export Page/RDLX Reports > Excel Export

Glossary Item Box

Microsoft Excel is one of the formats to which you can render your report using ExcelRenderingExtension. You can export Excel files in two formats, i.e. Xls and Xlsx.

Excel Rendering Properties

ActiveReports offers several options to control how reports render to Microsoft Excel.

Property | Description
Author | Gets or sets the name of the author of the document.
Categories | Sets the name of the categories that appears in the Categories field in the Properties of the exported Excel document.
FileFormat | Specifies the output format of the Excel document, i.e. Xls or Xlsx.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Strict: The default value.
  • Transitional: The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices.
PageSettings | Returns an ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Pagination | Forces pagination or galley report layout mode.
RightToLeft

Shows direction of sheets from right to left.
Security | Returns an ExcelRenderingExtensionSecurity object for initializing document security.
SheetMode

Indicates how to split the report pages into the excel sheets. You can choose from the following modes:

  • PagePerSheet: Each report page is exported to a separate Excel sheet
  • SectionPerSheet: Each report section is exported to a separate Excel sheet
  • SingleSheet: Entire report is exported to a single Excel sheet
SheetName | Indicates the name of the sheet.
Title | Gets or sets the title of the document.
UseCompression | Indicates whether to use compression when exporting document to an Xlsx file.
UseDefaultPalette | Indicates whether to export the document with the default Excel palette.

Interactivity

Reports rendered in Excel support a number of interactive features like Bookmarks and Hyperlinks. However, in case you have any data hidden at the time of rendering (like in a drill-down report), it does not show up in the output. It is recommended that you expand all toggle items prior to rendering.

Limitations

  • BackgroundImage and rounded corners (for Shape and Container) are not exported.
  • Overlapping controls are not supported and an incorrect result will be obtained in the case of export.
  • LineSpacing is not retained after export.
  • Exported FormattedText control does not preserve styles and formatting. It exports FormattedText as TextBox with plain text without any tags.
  • Barcodes are exported as an image object so scanning of barcode images may fail in some cases. It depends on printer settings and the scanner quality. Barcodes may be blurred on export and the caption may get truncated in case of physical printing.
  • Exported Boolean values are displayed in uppercase in both Xls and Xlsx files.
  • TextIndent and FillCharacter properties of the TableOfContents control's Level setting are not supported.
  • Text decoration (Underline and LineThrough) gets applied to the indented area when left padding is applied to the TableOfControl's levels.
  • When a report is exported to Excel, CharWrap mode is ignored.
  • The following properties of ActiveReports are not exported to Excel, since Excel does not have such settings:
    • CharacterSpacing
    • BorderWidth
    • MinCondenseRate

Export Report using Excel Rendering Extension

The following steps provide an example of rendering a report in Microsoft Excel format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Excel package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the Page report you want to render.

Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyExcel")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim excelSetting As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings()
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = excelSetting

' Set the rendering extension and render the report.
Dim excelRenderingExtension As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(excelRenderingExtension, outputProvider, setting.GetSettings())
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyExcel");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings excelSetting = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings();
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls;
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = excelSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension excelRenderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(excelRenderingExtension, outputProvider, setting.GetSettings());

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Word Export

Word Export
Developers > Export Reports > Export Page/RDLX Reports > Word Export

Glossary Item Box

The WordRenderingExtension class renders your reports to the native Microsoft Word file formats. You can export Page reports and RDLX reports to Microsoft Office Open XML (OOXML) format (.Docx) or Word HTML format (.Doc) using the FileFormat property.

The Word HTML format (.Doc) provides greater layout accuracy for Page and RDLX Reports in Microsoft Word, on the other hand, OOXML format (.Docx) provides excellent editing experience for the exported reports.

The OOXML format (.Docx) is recommended in the following scenarios:

  • Open exported reports in a wide range of applications: Users can open and modify the exported Word document in any of the following applications.
    • Microsoft Office 2013+
    • Microsoft Office for Mac 2016+
    • iWork and Pages for OS X (all supported versions)
    • LibreOffice
    • Google Quickoffice for Android
    • Documents Free (Mobile Office Suite) by SavySoda for iOS
      Note: Besides the applications listed above, .Docx files exported through ActiveReports WordRenderingExtension class might work in other applications that support the .Docx format.
  • Customize reports after exporting: Positioning and arrangement of report elements in the exported document is implemented using the OOXML format (.Docx) which provides a natural document flow for editing the exported documents.
  • Use Word automation features: With support for automation features in the OOXML format (.Docx), tasks that previously required manual adjustments in the exported Word document are now handled automatically. Report elements such as page header and footer, expressions, heading levels, and table of contents are automatically transformed to the OOXML format (.Docx).
  • Set compatibility mode: You can render a report as a Word document that is compatible with Microsoft Word 2007, 2010, or 2013 using the DocumentCompatibleVersion property from the export settings.
  • Retain page orientation and size when exporting RDLX report: When exporting an RDLX report, the .Docx export retains the PageSize and PaperOrientation of each page in the report.

Word Rendering Extension Properties

ActiveReports offers several options to control how reports render to Microsoft Word.

Common properties (HTML and OOXML)

Property | Description
Author | Sets the name of the author that appears in the Author field of the Properties dialog in the rendered Word document.
Categories | Sets the name of the categories that appears in the Categories field in the Properties of the exported Word document.
FileFormat | Sets the output file format to HTML (.Doc) or OOXML (.Docx). By default, the file format is set to HTML format.
Title | Sets the title for a document that appears in the Title field of properties dialog in the rendered Word document.

HTML format

Property | Description
BaseUrl | Sets the base URL for any relative hyperlinks that appear in the Hyperlink base field of the Properties dialog in the rendered Word document.
Generator | Sets the identity of the document generator in the rendered Word document.
PageHeight | Sets the height of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
PageWidth | Sets the width of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.

OOXML format

Property | Description
CompanyName | Sets the name of the organization or company that appears in the Company field of Properties dialog in the rendered Word document.
DocumentCompatibilityVersion | Sets the compatibility mode of the document to previous versions (Microsoft Word 2007 - 2013) of Word. By default, the compatibility version is set to Word2013.
DpiX | Sets the horizontal resolution of the images in the rendered Word document. By default, DpiX is set to 96.
DpiY | Sets the vertical resolution of the images in the rendered Word document. By default, DpiY is set to 96.
PageOrientation | Sets a value that specifies whether the document pages should be printed in portrait or landscape in the rendered Word document.
PaperSize | Sets the paper size for the page.
Password | Sets a password that must be provided to open the rendered Word document.
ReadOnlyRecommended | Sets a value that indicates whether Microsoft Office Word displays a message whenever a user opens the document, suggesting that the document is read-only.
WritePassword | Sets the write password that is required for saving changes in the rendered Word document.
TOCAutoUpdate | Automatically updates the TableOfContents control while opening the Word document. By default, TOCAutoUpdate is set to False.

Interactivity

HTML format

Reports rendered in a Word format supports both Bookmarks and Hyperlinks. However, if visibility toggling (like in a drill-down report) is essential to your report, it is recommended to use the HTML rendering extension. If a Document map is essential to your report, it is recommended to use the PDF rendering extension.

OOXML format

  • Hyperlinks - Hyperlinks on TextBox and Image controls are rendered as hyperlinks in Microsoft Word.
  • Bookmarks - Bookmarks in the report are rendered as Microsoft Word bookmarks. Bookmark links are rendered as hyperlinks that link to the bookmark labels within the document.
  • TOC AutoUpdate - TableofContents control in the report is rendered as a Microsoft Word table of contents.

Limitations

HTML format

  • Although background colors for controls export to Word documents, background colors for sections such as Body and Page Header or Footer do not.
  • The BackgroundImage is not supported when used in TextBox and CheckBox controls embedded in data regions such as Table and Tablix.
  • The BackgroundImage is not supported for reports, and for List, Container, Shape, FormattedText, Table, and Tablix report controls.
  • KeepTogether property of Table/Tablix is not supported.
  • Some FormattedText tags, for example <b>bi</b> and <s>es</s>, are not exported to Word.
  • Image alignments other than the defaults (HorizontalAlignment: Left and VerticalAlignment: Top) are not supported.
  • Checkbox color does not affect the color of the square.

OOXML format

Report properties

  • The LineSpacing property of a report's style sheet, StartPageNumber property of the report, PrintOnLastPage property of the PageHeader and PageFooter are not supported.
  • For Page reports, some of the NumberingStyle property (DocumentMap settings) options are not supported. The supported NumberingStyle options are Decimal, DecimalZero, LowerLetter, UpperLetter, LowerRoman, UpperRoman.
  • Background image is not supported for report item except Shape.
  • The BackgroundRepeat property of the BackgroundImage is not supported in Page (Page reports) and Body (RDLX reports).
  • For RDLX reports, Background and Border properties of Page Header or Page Footer are not supported.
  • Microsoft Word calculates the width of the columns by the document width. an RDLX report calculates the width of the columns based on the body width, therefore, the width of columns in an exported RDLX report may differ from an original RDLX report.
  • In Microsoft Word, the maximum supported page size is 22 inches (55.87 cm) wide and 22 inches (55.87 cm) high. If an exported report exceeds the maximum size, some data may be lost during export.
  • In Microsoft Word, a table can have a maximum of 63 columns. If an exported report table has more than 63 columns, then the table is split and therefore an exported document may differ from an original report.
  • A repeated Table Footer (the RepeatOnNewPage property of Table Footer) or multiple repeated headers on a single page are not supported.
  • The OverflowPlaceHolder control is not supported.
  • If the PrintOnFirstPage property of PageHeader or PageFooter is set to False, then both PageHeader and PageFooter will not be available on the first page of the exported document.
  • The report data gets rendered only in the first theme if a Page report containing multiple themes is exported to Docx format.

Report controls

  • The Inset, Outset, and Windowsinset border styles (in BorderStyle property) are not supported.
  • The Map, Chart, Image, Barcode, SparkLine, Bullet, and CustomControl report controls are exported as an image. If a report control uses the BorderColor, BorderStyle or BorderWidth properties, a report is exported as a table.
  • The BorderWidth property of report controls is not exported as-is and may differ from the original BorderWidth value.
  • PageBreaks are not fully supported. The report contents exported to the Word's table or cell items do not support the page breaks.
  • For Shape report control, if the BorderStyle property is set to Double, it is exported as Solid.
  • For Line control, if LineStyle property is set to Double/Transparent, it is exported as Solid.
  • For BandedList data region, only the BandedList Header is repeated on each page. The BandedList Footer, GroupHeaders and GroupFooters are not supported.
  • Tablix data region is exported as a single table without horizontal split.
  • For Image control, Border properties and Padding properties are not supported if the Sizing property is set to Clip.
  • For Container report control, rounding corners (the RoundingRadius property) are not supported.
  • RepeatToFill property for Table and Tablix is not supported.
  • Images embedded in a Table data region are not properly supported.
  • Pagination is not supported due to difference in the layouts of ActiveReports and Word.
  • Page Number in Section (Page N of M(Section)) is not supported.
  • KeepTogether property of Table/Tablix is not supported.
  • Horizontal aligned images may overlap in iWord.
  • The properties set to the 'Body' region of a Subreport are not exported.
  • If a report contains overlapped report controls, these controls appear side by side in an exported Word document and not overlapped as in the Designer’s preview.

FormattedText

    • FormattedText is exported as it is. It does not support all HTML and CSS features.
    • The <a> tag without a href attribute, <abbr> and <q> tags are exported as simple text.
    • For Border Styles - Inset and Outset, the <ul> tags are not exported.
    • The BackgroundColor, BackgroundImage, BorderColor, BorderStyle and BorderWidth properties are not supported.
    • Anchors with an href attribute are exported as hyperlinks.
    • Headers like h1, h2, etc. are exported as corresponding Microsoft Word built-in header styles.

    TableOfContents

    • The TextAlign, DisplayPageNumber, TextIndent, and Overline TextDecoration properties are not supported.
    • The Source property of the Document Map settings is not fully supported. Only the Headings Only option of the Source property is supported.
    • If a report uses more than one TableOfContents controls, the properties of the first TableOfContents are applied to the other TableOfContents controls in the exported document.
    • The FillCharacter property is exported as dots.
    • The background of TOC control appears black on opening the exported file in LibreOffice.

    TextBox/CheckBox

    • If the Format property is set to Numeric or Date, the exported TextBox has the right alignment. Other Format values are exported with the left alignment.
    • The Transparent color for text is exported as white.
    • The Underline for numbered lists, Right-To-Left (RTL) option of the Direction, Angle, ShrinkToFit, and Overline TextDecoration properties are not supported.
    • The action Jump to report is not supported.
    • The tb-rl (vertical text) option of the WritingMode property is not supported. TextBoxes with the WritingMode property set to tb-rl are exported as lr-tb.
    • The NoWrap option of the WrapMode property is exported as WordWrap.
    • The LineSpacing property of an exported document will differ from the original report. This is because, in Microsoft Word, the line spacing is calculated by the font size value of a report control plus the line spacing value of a report control.
    • For CheckBox control, the CheckAlignment property is exported as MiddleRight for TopRight, MiddleRight, and BottomRight options. Other CheckAlignment options are exported as MiddleLeft.
    • Paddings exceeding 31 inches is exported as border spaces.
    • Right-To-Left text direction does not work in the LibreOffice.
    • On exporting to Word 2013, when the background (shading) and padding are applied to a paragraph, the padding is also applied to the background, so a gap between the border and the background appears on the left side of the paragraph.
    • CharWrap property is not supported.
    • The fields in a TextBox control are evaluated as follows:
      • PageNumber and TotalPages expressions are exported as special fields, evaluated by a text editor (Word or other).
      • The fields placed in Header or Footer are automatically evaluated.
      • The fields placed in the Body should be re-evaluated manually by clicking 'Update field' from the context menu.

Export Report using Word Rendering Extension

The following steps provide an example of rendering a report in Word format (.doc or .docx).

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Word package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event to render your report in .OOXML or .HTML file format.
Note: To export your report in Word HTML format (.Doc), change the FileFormat property option from OOXML to HTML format as shown.
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.HTML

To export a report in .Docx file format

VB code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.

Dim rptPath As New IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath))

' Create an output directory.

Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyWord")
outputDirectory.Create()

' Provide settings for your rendering output.

Dim wordSetting As New GrapeCity.ActiveReports.Export.Word.Page.Settings()

' Set the FileFormat property to .OOXML.

wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML

' Set the rendering extension and render the report.

Dim wordRenderingExtension As New GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.

outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(wordRenderingExtension, outputProvider, wordSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.

System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

 // Create an output directory.

System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyWord");
outputDirectory.Create();

// Provide settings for your rendering output.

GrapeCity.ActiveReports.Export.Word.Page.Settings wordSetting = new GrapeCity.ActiveReports.Export.Word.Page.Settings();

// Set the FileFormat property to .OOXML.

wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML;

// Set the rendering extension and render the report.

GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension wordRenderingExtension = new GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.

outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(wordRenderingExtension, outputProvider, wordSetting);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CSV Export

CSV Export
Developers > Export Reports > Export Page/RDLX Reports > CSV Export

Glossary Item Box

Comma-Separated Values (CSV) is a form of structured data in plain text. The text in a CSV file is saved as series of values separated by commas. You can use the CsvRenderingExtension to render your report in this format.

CSV Rendering Properties

ActiveReports offers several options to control how reports render to CSV.

Property | Description
ColumnsDelimiter | Sets or returns the text inserted between columns.
DateTimeFormat | Specifies the default format for date values, for example, 'yyyy-MM-dd'.
Encoding | Specifies the encoding schema for output.
NoHeader | Specifies whether to omit the CSV Header.
NumericFormat | Specifies the format for numeric values, for example, '0.####'.
QuotationSymbol | Sets or returns the qualifier character to put around results.
RowsDelimiter | Sets or returns the text inserted between rows.

Export Report using CSV Rendering Extension

The following steps provide an example of rendering a report in the Csv format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Xml package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.

VB code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.

Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\..\Report1.rdlx")
Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyCSV")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim csvSettings As New GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings()

csvSettings.ColumnsDelimiter = ","
csvSettings.Encoding = System.Text.Encoding.UTF8
csvSettings.NoHeader = True
csvSettings.QuotationMode = GrapeCity.ActiveReports.Export.Text.Page.QuotationMode.AlwaysQuote
csvSettings.QuotationSymbol = """"c
csvSettings.RowsDelimiter = vbCr & vbLf

' Set the rendering extension and render the report.
Dim csvRenderingExtension As New GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(csvRenderingExtension, outputProvider, csvSettings)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyCSV");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings csvSettings = new GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings();
csvSettings.ColumnsDelimiter = ",";
csvSettings.Encoding = Encoding.UTF8;
csvSettings.NoHeader = true;
csvSettings.QuotationMode = GrapeCity.ActiveReports.Export.Text.Page.QuotationMode.AlwaysQuote;
csvSettings.QuotationSymbol = '"';
csvSettings.RowsDelimiter = "\r\n";

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension csvRenderingExtension = new GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(csvRenderingExtension, outputProvider, csvSettings);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


JSON Export

JSON Export
Developers > Export Reports > Export Page/RDLX Reports > JSON Export

Glossary Item Box

JavaScript Object Notation (JSON) is a text-based data format in which the data is stored in the hierarchical form. You can use the JsonRenderingExtension to render your report in this format.

JSON Rendering Properties

ActiveReports offers several options to control how reports render to JSON.

Property | Description
Formatted | Specifies whether to format the file with tabs and spaces for readability.
QuotePropertyNames | Specifies whether to enclose property names in quotation marks.

Export Report using JSON Rendering Extension

The following steps provide an example of rendering a report in JSON format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add a reference to MESCIUS.ActiveReports.Export.Xml package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.

VB code. Paste INSIDE the Form Load event. Copy Code
' Provide the Page report you want to render.
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\..\Report1.rdlx")
Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyJSON")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim jsonSettings As New GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings()
jsonSettings.Formatted = True

' Set the rendering extension and render the report.
Dim jsonRenderingExtension As New GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension()

Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(jsonRenderingExtension, outputProvider, jsonSettings)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the Page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyJSON");
outputDirectory.Create();

// Provide settings for your rendering output.
eReports.Export.Text.Page.JsonRenderingExtension.Settings jsonSettings = new
        GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings();

jsonSettings.Formatted = true;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension jsonRenderingExtension = new
        GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory,
        System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(jsonRenderingExtension, outputProvider, jsonSettings);

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Excel Data Export

Excel Data Export
Developers > Export Reports > Export Page/RDLX Reports > Excel Data Export

Glossary Item Box

Excel Data is one of the formats to which you can render your report using ExcelTransformationDevice. You can export excel files in two formats, Xlsx and Csv.

Excel Data exports only data from Tablix, Table, and Matrix data regions, preserving the data region structure and ignoring layout-related features (page break, cumulative total, etc). Other controls and data regions of the original report are ignored at this export. The FrozenRows and FrozenColumns settings of Table and Tablix are handled at the report export and can be applied in the exported file.

Note: If a report does not contain any data region (Table or Tablix), a Csv file is not generated.

For the Xlsx format, when a report has multiple data regions, each data region is exported to a separate excel sheet.

For the Csv format, a separate CSV file is created for each data region, available in the report.

The following steps provide an example of rendering a report in the Microsoft Excel format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add MESCIUS.ActiveReports.Export.Excel package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.

    Csv Data

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the Page Report you want to render.
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyCsvData")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim settings = New GrapeCity.ActiveReports.Export.Excel.Page.Settings()

settings.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.ExcelDataFileFormat.Csv
settings.Csv.ColumnsDelimiter = ","
settings.Csv.Encoding = System.Text.Encoding.UTF8
settings.Csv.NoHeader = False
settings.Csv.QuotationSymbol = """"c
settings.Csv.RowsDelimiter = vbCrLf

' Set the rendering extension and render the report.
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True
pageReport.Document.Render(New GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice(), outputProvider, settings)
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the Page Report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyCsvData");
outputDirectory.Create();

// Provide settings for your rendering output.
var settings = new GrapeCity.ActiveReports.Export.Excel.Page.Settings();

settings.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.ExcelDataFileFormat.Csv;
settings.Csv.ColumnsDelimiter = ",";
settings.Csv.Encoding = Encoding.UTF8;
settings.Csv.NoHeader = false;
settings.Csv.QuotationSymbol = '"';
settings.Csv.RowsDelimiter = "\r\n";

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(new GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice(), outputProvider, settings);

    Excel Data

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the Page Report you want to render.
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyExcelData")
outputDirectory.Create()

' Provide settings for your rendering output.

Dim settings = New GrapeCity.ActiveReports.Export.Excel.Page.Settings()

settings.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.ExcelDataFileFormat.Xlsx
settings.Xlsx.AllowImages = True
settings.Xlsx.UseCompression = True
settings.Xlsx.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard.Transitional
settings.Xlsx.Security.ReadOnlyRecommended = True

' Set the rendering extension and render the report.
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True
pageReport.Document.Render(New GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice(), outputProvider, settings)
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the Page Report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyExcelData");
outputDirectory.Create();

// Provide settings for your renderidng output.
var settings = new GrapeCity.ActiveReports.Export.Excel.Page.Settings();

settings.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.ExcelDataFileFormat.Xlsx;
settings.Xlsx.AllowImages = true;
settings.Xlsx.UseCompression = true;
settings.Xlsx.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard.Transitional;
settings.Xlsx.Security.ReadOnlyRecommended = true;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(new GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice(), outputProvider, settings);

Excel Data Rendering Properties

ActiveReports offers several options to control how reports render to Excel Data.

Property | Description
Csv | Csv related properties. See Csv Rendering Properties below.
FileFormat | Indicates whether to use Csv or OpenXml format for the output file.
Xlsx | OpenXml related properties. See Xlsx Rendering Properties below.

Csv Rendering Properties

Property | Description
ColumnsDelimiter | Sets or returns the text inserted between columns.
DateTimeFormat | Specifies the default format for date values, for example, 'yyyy-MM-dd'.
Encoding | Specifies the encoding schema for output.
NoHeader | Specifies whether to omit the CSV Header.
NumericFormat | Specifies the format for numeric values, for example, '0.####'.
QuotationSymbol | Sets or returns the qualifier character to put around results.
RowsDelimiter | Sets or returns the text inserted between rows.

Xlsx Rendering Properties

Property | Description
AllowImages | Indicates whether to allow images or just plain data content.
Author | Sets the name of the author that appears in the Author field in the Properties of the exported Excel document.
AutoRowsHeight | Indicates whether to export rows height or specify auto height.
Categories | Sets the name of the categories that appears in the Categories field in the Properties of the exported Excel document.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Transitional: The default value.
  • Strict: The Excel file generated using Strict cannot be viewed on iOS devices.
RightToLeft

Shows direction of sheets from right to left.
Security | Initializes the document security.
Title | Sets the name of the title for a document that appears in the Title field in the Properties of the exported Excel document.
UseCompression | Indicates whether to use compression on exporting to an Xlsx file.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Text Print Export

Text Print Export
Developers > Export Reports > Export Page/RDLX Reports > Text Print Export

Glossary Item Box

The Text Print is a format recommended for printing the RDLX reports with Table and Tablix data regions in the tabular format, preserving the grouping, layout, and formatting. The export is a cross-platform replacement for Text Only printers and is suitable for printing reports in ASCII format, especially on the Dot Matrix printers.

Use the TxtRenderingExtension to render your report in Text Print format.

The following steps provide an example of rendering a report in the Text Print format.

  1. Create a new or open an existing Windows Forms App in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose a report type, RDLX, RDLX Dashboard, or Page report and then click Finish.
  4. Add reference to MESCIUS.ActiveReports.Export.Xml package in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the Page Report you want to render.
Dim rptPath As System.IO.FileInfo = New System.IO.FileInfo("..\..\..\Report1.rdlx")

Dim pageReport As GrapeCity.ActiveReports.PageReport = New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyTextPrint")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim txtSettings = New GrapeCity.ActiveReports.Export.Text.Page.Settings()
txtSettings.HorizontalPaddings = GrapeCity.ActiveReports.Export.Text.Page.PaddingsType.Keep
txtSettings.LineEnding = "\r\n"
txtSettings.CharHeight = 13
txtSettings.CharWidth = 7

' Set the rendering extension and render the report.

Dim txtRenderingExtension As GrapeCity.ActiveReports.Export.Text.Page.TxtRenderingExtension = New GrapeCity.ActiveReports.Export.Text.Page.TxtRenderingExtension()

Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True
pageReport.Document.Render(txtRenderingExtension, outputProvider, txtSettings)
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the Page Report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\..\Report1.rdlx");

GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyTextPrint");
outputDirectory.Create();

// Provide settings for your rendering output.
var txtSettings = new GrapeCity.ActiveReports.Export.Text.Page.Settings();
txtSettings.HorizontalPaddings = GrapeCity.ActiveReports.Export.Text.Page.PaddingsType.Keep;
txtSettings.LineEnding = "\r\n";
txtSettings.CharHeight = 13;
txtSettings.CharWidth = 7;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Text.Page.TxtRenderingExtension txtRenderingExtension = new GrapeCity.ActiveReports.Export.Text.Page.TxtRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;
pageReport.Document.Render(txtRenderingExtension, outputProvider, txtSettings);

Text Print Rendering Properties

The following options are available while rendering to Text Print format.

Property | Description
CharHeight | Specifies the character height in points.
CharWidth | Specifies the character width in points.
FontFamily

Specifies the monospace font family. The available options are:

  • Consolas
  • Courier New
  • Lucida Console
FontSize

Specifies the font height in points. Recommended values are Consolas 11, Courier New 10, or Lucida Console 10.
HorizontalPaddings

Specifies the horizontal padding:

  • Keep: Retain the original padding
  • Adjust: Adjust the padding
  • Remove: Remove the padding
LineEnding | Specifies the end of a line.

Limitations

  • Ignores graphics; the output is only plain text.
  • Pagination is not preserved, the output is rendered on a single page

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Export Section Reports

Export Section Reports
Developers > Export Reports > Export Section Reports

Glossary Item Box

ActiveReports provides custom components for exporting Page/RDLX and Section reports into different formats. Each export format has special features, however, not all formats support all the features that you can use in your reports. Exporting in Section Report is only possible through Export Filters. Explore the following export formats to export the Section reports using export filters:

  • HTML Export
  • PDF Export
  • Text Export
  • RTF Export
  • Excel Export
  • TIFF Export

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


HTML Export

HTML Export
Developers > Export Reports > Export Section Reports > HTML Export

Glossary Item Box

HTML, or hypertext markup language, is a format that opens in a Web browser. The HTML export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the HTMLExport object after adding reference to MESCIUS.ActiveReports.Export.Html package in your project.

HTML Export Filter Properties

Property | Valid Values | Description
BookmarkStyle | Html (default) or None | Set to Html to generate a page of bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored.
CharacterSet | Big5, EucJp, HzGb2312, Ibm850, Iso2022Jp, Iso2022Kr, Iso8859_1, Iso8859_2, Iso8859_5, Iso8859_6, Koi8r, Ksc5601, ShiftJis, UnicodeUtf16, UnicodeUtf8 (default) | Select the IANA character set that you want to use in the meta tag in the header section of the HTML output. This property only takes effect if the IncludeHtmlHeader property is set to True.
CreateFramesetPage | True or False (default) | Set to True to generate a set of frames that display a page of bookmarks (if available) in the left frame and the report document in the right frame. The HTML output uses the specified filename with the extension .frame.html.
IncludeHtmlHeader | True (default) or False | Set to False if you want to embed the HTML output in another HTML document. Otherwise, the HTML output includes the usual HTML, HEAD, and BODY elements.
IncludePageMargins | True or False (default) | Set to True to include the report's margins in the HTML output.
MultiPage | True or False (default) | Set to True to create a separate HTML page for each page of the report. Otherwise, the HTML output is a single page.
OutputType | DynamicHtml (default) or LegacyHtml | Set to LegacyHtml to use tables for positioning and avoid the use of cascading style sheets (CSS). Otherwise, positioning of controls is handled in the CSS.
Pagination | True (default) or False | Gets or sets the value, that indicates whether to use pagination for the resultant html document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
RemoveVerticalSpace | True or False (default) | Set to True if the OutputType property is set to LegacyHtml and you plan to print the output from a browser. This removes white space from the report to help improve pagination. Otherwise, vertical white space is kept intact.
Title | Any String | Enter the text to use in the header section's title. This is displayed in the title bar of the browser.

Additional Information on Output Types

By default, the report is exported as DynamicHtml (DHTML), with cascading style sheets (CSS). Using the OutputType property, you can change the output to LegacyHtml (HTML). Neither of the output types creates a report that looks exactly like the one you display in the viewer because of differences in formats. Following is the usage of each output type and controls to avoid in each.

DynamicHtml (DHTML) usage and limitations

Usage:

  • Create Web reports with Cascading Style Sheets (CSS)
  • Open in Web browsers

Does not support:

  • Diagonal line control
  • Control borders

LegacyHtml (HTML) usage and limitations

Usage:

  • Create archival reports
  • Open in Web browsers

Does not support:

  • Line control
  • Control borders
  • CrossSectionLine controls
  • Overlapping controls
  • MinCondenseRate property

HTML Export Filter Limitations

  • Line spacing in exported HTML can be different from the line spacing in Viewer.
  • There may be space between the borders of each control in exported file.
  • Text in RichTextBox may appear overlapped.
  • Vertical Text and Bookmarks are not supported.
  • Any text may appear overlapped.
  • Borders are not supported.

Export Report using HTML Export Filter

Use the following steps to export reports through HTML export filter.

  1. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  2. Go to the Project Explorer, right-click the project and select Add > New Item.
  3. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  4. Add a reference to MESCIUS.ActiveReports.Export.Html package in the project. See Manage ActiveReports Dependencies for more information.
  5. In your project's Bin>Debug folder, place the report.rpx (Section Report).
  6. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  7. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.

Dim rpt As New GrapeCity.ActiveReports.SectionReport()
' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in HTML format.
Dim HtmlExport1 As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport()
HtmlExport1.Export(rpt.Document, Application.StartupPath + "\HTMLExpt.html")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in HTML format.
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport HtmlExport1 = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
HtmlExport1.Export(rpt.Document, Application.StartupPath + "\\HTMLExpt.html");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


PDF Export

PDF Export
Developers > Export Reports > Export Section Reports > PDF Export

Glossary Item Box

PDF, or portable document format, opens in the Adobe Reader. The PDF export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the PDFExport object after adding reference to MESCIUS.ActiveReports.Export.Pdf package in your project

Note: PDF export and font linking features are only available in the Professional Edition of ActiveReports.

PDF Export Properties

Property | Valid Values | Description
ConvertMetaToPng | True or False (default) | Set to True to change any Windows metafile images to PNG format to keep the file size down. If the report has no metafiles, this setting is ignored.
ExportBookmarks | True (default) or False | Set to True to generate bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored. To control how the exported bookmarks are displayed, use Options.DisplayMode detailed below.
FontFallback | String of font families | Set a comma-delimited string of font families to be used to lookup glyphs missing in the original font.
ImageInterpolation | None (default) or Auto | Specifies the images interpolation value. Allows to enable/disable image interpolation, when exporting the file to PDF.
ImageQuality | Lowest, Medium (default), or Highest | Set to Highest in combination with a high value in the ImageResolution property to yield the best printing results when converting Windows metafiles (.wmf). Set to Lowest to keep the file size down. If the report has no metafiles, this setting is ignored.
ImageResolution | 75 - 2400 dpi | Set to 75 dpi to save space, 150 dpi for normal screen viewing, and 300 dpi or higher for print quality. Use this property in combination with ImageQuality (highest) to yield the best results when the report contains metafiles or the Page.DrawPicture API is used. Neither property has any effect on other image types.
NeverEmbedFonts | A semicolon-delimited string of font names | List all of the fonts that you do not want to embed in the PDF file to keep the file size down. This can make a big difference if you use a lot of fonts in your reports.
Options | See below | Expand this property to see a group of sub properties. These settings control how the Adobe Reader displays the output PDF file when it is first opened. See the table below for details.
Pagination | True or False (default) | Gets or sets the value that indicates whether to use pagination in the exported PDF document. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
PrintPresets | See below | Returns an object allowing you to specify the print presets.
Security | See below | Expand this property to see a group of sub properties. These settings control encryption and permissions on the output PDF file. See the table below for details.
Version | Pdf11, Pdf12, Pdf13, Pdf14, Pdf15, Pdf16, Pdf17, Pdf20, PdfA1a, PdfA1b, PdfA2a, PdfA2b, PdfA2u, PdfA3a, PdfA3b, PdfA3u, and PdfUA1 | Sets the version of the PDF format the exported document is saved in.
Watermark | See below. For CrossPlatform compatibility mode only. | Expand this property to see a group of sub properties. These settings control whether a report is exported to PDF with a watermark on it. See the table below for details.

PDF Export usage and limitations

Usage:

  • Create printable reports whose formats do not change from machine to machine.
  • Open in Adobe Reader.
  • WYSWYG in both compatibility modes - a legacy GDI and a new CrossPlatform mode (section report).

Does not support:

  • Multiple lines of vertical text is not supported in Page and RDLX reports (GDI compatibility mode).
  • Transparent background-color in charts is not supported in the GDI compatibility mode if ConvertMetaToPng is set to True.

Options, Security, and Watermark

When you expand the Options, Security, or Watermark properties in the Properties window, the following sub properties are revealed.

PDF Options Properties

Property | Valid Values | Description
Application | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Application field.
Author | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Author field.
CenterWindow | True or False (default) | Set to True to position the Adobe Reader window in the center of the screen when the document is first opened.
DisplayMode None (default), Outlines, Thumbs, or FullScreen

Select how to display bookmarks when the document is first opened.

  • None (default) bookmarks are not displayed until opened by the user.
  • Outlines shows bookmarks in outline format.
  • Thumbs shows bookmarks as thumbnails.
  • FullScreen shows the document in full screen, and bookmarks are not displayed.
DisplayTitle | True or False (default) | Set to True to use the Title string entered in the Title property below. Otherwise, the file name is used.
FitWindow | True or False (default) | Set to True to expand the window to fit the size of the first displayed page.
HideMenubar | True or False (default) | Set to True to hide the menu in the Adobe Reader when the document is first opened.
HideToolbar | True or False (default) | Set to True to hide the toolbars in the Adobe Reader when the document is first opened.
HideWindowUi | True or False (default) | Set to True to hide the scrollbars and navigation controls in the Adobe Reader when the document is first opened, displaying only the document.
Keywords | String | Enter keywords to display in the Adobe Document Properties dialog, Description tab, Keywords field.
OnlyForPrint | True or False (default) | Set to indicate whether the PDF is only for print.
Subject | String | Enter a subject to display in the Adobe Document Properties dialog, Description tab, Subject field.
Title String

Enter a title to display in the Adobe Document Properties dialog, Description tab, Title field.

Set DisplayTitle to True to display this text in the title bar of the Adobe Reader when the document is opened.

PDF Security Properties

Property | Valid Values | Description
Encrypt | True or False (default) | Sets or returns a value indicating whether the document is encrypted.
OwnerPassword | String | Enter the string to use as a password that unlocks the document regardless of specified permissions.
Permissions | None, AllowPrint, AllowModifyContents, AllowCopy, AllowModifyAnnotations, AllowFillIn, AllowAccessibleReaders, or AllowAssembly | Combine multiple values by dropping down the selector and selecting the check boxes of any permissions you want to grant. By default, all of the permissions are granted.
UserPassword | String | Enter the string to use as a password that unlocks the document using the specified permissions. Leave this value blank to allow anyone to open the document using the specified permissions.

PDF Watermark Properties (CrossPlatform Compatibility Mode only)

Property | Valid Values | Description
Angle | String | Specify the degree of angle for the watermark text on the PDF document. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Color | String | Select a color for the watermark text of the PDF document.
FontName | String | Specify the font of the PDF document watermark text.
FontSize | String | Specify the font size of the PDF document watermark text.
FontStyle | Regular, Bold, Italic, Underline, or Strikeout. | Select the font style of the PDF document watermark text.
PrintOnly | True or False (default) | Specify whether the watermark should appear on printed pages only.
Text | String | Enter text to be used as the watermark on the PDF document.

PDF Print Presets Properties

ActiveReports allows you to preset the printing properties for PDF report exports using the PrintPresets class. This pre-populates the print settings in the Print dialog box. Please see Print Presets for more information.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.

Property | Description
PageScaling | Specify scaling for the printable area.You can select Default to shrink to the printable area, or you can select None for the actual size.
DuplexMode

Specify the duplex mode of the printer. For the best results with the duplex option, the selected printer should support duplex printing. You can choose from the following values,

  • Simplex: Prints on one side of the paper. This is the default value.
  • Duplex (Flip on long edge): Prints on both sides of the paper with paper flip on the long edge.
  • Duplex (Flip on short edge): Prints on both sides of the paper with paper flip on the short edge.
PaperSourceByPageSize | Determines the output tray based on PDF page size, rather than page setting options. This option is useful when printing PDFs with multiple page sizes, where different sized output trays are available. By default, this option is set to False.
PrintPageRange | Specify the range of page numbers as 1-3 or 1, 2, 3.
NumberOfCopies | Specify the number of copies to print. You can select any number of copies from 2 to 5, or select Default to specify a single copy.

Note: These properties are available in PDF version 1.7 or higher. The PageScaling property is supported in PDF version 1.6.

Metadata in PDFs

Adding Metadata

Metadata such as keywords, descriptions are used by the search engines to narrow down the searches. You can add a number of predefined accessors, such as title, contributors, creators, copyright, description, etc. using AdditionalMetadata property. The allowed namespaces are:

  • Dublin Core Properties
  • XMP Core Properties
  • PDF Properties
VB code. Paste INSIDE the Form Load event. Copy Code
Dim sectionReport As GrapeCity.ActiveReports.SectionReport = New GrapeCity.ActiveReports.SectionReport()
Dim xtr As XmlReader = XmlReader.Create(Application.StartupPath & "\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
sectionReport.Run()
Dim pdfExport As GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport = New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
Dim metadata1 = New AdditionalMetadataInfo With {
    .[Namespace] = AdditionalMetadataNamespace.PurlOrg, ' Dublin Core Properties
    .Key = "title",
    .Value = "Invoice"
}
pdfExport.Options.AdditionalMetadata.Add(metadata1)
pdfExport.Export(sectionReport.Document, Application.StartupPath & "\MyPDF.pdf")
C# code. Paste INSIDE the Form Load event. Copy Code
GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
XmlReader xtr = XmlReader.Create(Application.StartupPath + "\\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
sectionReport.Run();
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport pdfExport = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
// Add meta data
var metadata1 = new AdditionalMetadataInfo
{
    Namespace = AdditionalMetadataNamespace.PurlOrg, //Dublin Core Properties
    Key = "title",
    Value = "Invoice"
 };

pdfExport.Options.AdditionalMetadata.Add(metadata1);
pdfExport.Export(sectionReport.Document, Application.StartupPath + "\\MyPDF.pdf");

Adding Attachment

Adding an attachment

You can include an attachment as metadata (such as invoices) to exported PDFs using Attachments property. This property allows to attach files such as a .xml or a .txt file in PDF. Below is example to export Section reports to PDF and attach a file to the exported PDF.

VB code. Paste INSIDE the Form Load event. Copy Code
Dim sectionReport As GrapeCity.ActiveReports.SectionReport = New GrapeCity.ActiveReports.SectionReport()
Dim xtr As XmlReader = XmlReader.Create(Application.StartupPath + _, SectionReport1.rpx)
sectionReport.LoadLayout(xtr)
sectionReport.Run()
Dim pdfExport As GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport = New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
Dim attachment = New GrapeCity.ActiveReports.Export.Pdf.AttachmentInfo With {
    .Name = "file.txt",
    .Content = System.IO.File.ReadAllBytes("D:\Reports\file.txt"),
    .Description = "attachment description"
}
pdfExport.Options.Attachments.Add(attachment)
pdfExport.Export(sectionReport.Document, Application.StartupPath & "\MyPDF.pdf")
C# code. Paste INSIDE the Form Load event. Copy Code
GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
XmlReader xtr = XmlReader.Create(Application.StartupPath + \\SectionReport1.rpx);
sectionReport.LoadLayout(xtr);
sectionReport.Run();
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport pdfExport = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
// Add attachment
var attachment = new GrapeCity.ActiveReports.Export.Pdf.AttachmentInfo
    {
          Name = "file.txt",
          Content = System.IO.File.ReadAllBytes(@"D:\Reports\file.txt"),
          Description = "attachment description" //optional
    };
pdfExport.Options.Attachments.Add(attachment);
pdfExport.Export(sectionReport.Document, Application.StartupPath + "\\MyPDF.pdf");

Open the exported PDF and you should see the attachment. Check the left sidebar in Adobe Acrobat Reader DC.

Note: Metadata in PDFs is part of the Professional Edition. It is supported with the PDF version PDF/A-3b (or higher).

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Export Report using PDF Export Filter

Use the following steps to export reports through PDF export filters.

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Add a reference to MESCIUS.ActiveReports.Export.Pdf package in the project. See Manage ActiveReports Dependencies for more information.
  6. In your project's Bin>Debug folder, place the report.rpx (Section Report).
  7. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  8. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.

Dim rpt As New GrapeCity.ActiveReports.SectionReport()
' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in HTML format.
Dim PdfExport1 As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
PdfExport1.Export(rpt.Document, Application.StartupPath + "\PDFExpt.pdf")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in PDF format.
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport PdfExport1 = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
PdfExport1.Export(rpt.Document, Application.StartupPath + "\\PDFExpt.pdf");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Text Export

Text Export
Developers > Export Reports > Export Section Reports > Text Export

Glossary Item Box

Plain Text is a format that opens in Notepad or Microsoft Excel depending on the file extension you use in the filePath parameter of the Export method. Use the extension .txt to open files in Notepad, or use .csv to open comma separated value files in Excel. The Text export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the TextExport object after adding reference to MESCIUS.ActiveReports.Export.Xml package in your project.

Text Export Properties

Property | Valid Values | Description
Encoding | System.Text.ASCIIEncoding (default), System.Text.UnicodeEncoding, System.Text.UTF7Encoding, or System.Text.UTF8Encoding | This property can only be set in code. Enter an enumerated system encoding value to use for character encoding.
PageDelimiter | String | Enter a character or sequence of characters to mark the end of each page.
QuotationMode
Specifies whether to add double quotes to the exported data.
  • AutoQuote – Simple values are exported without quotes. The quotes are added only when the data contains column or row delimiters. This is the default export behavior.
  • AlwaysQuote – Exported values are always quoted.

QuotationSymbol

 Char Enter a character to use as quotation mark in the exported text file. Only fields with delimiter characters are quoted.
SuppressEmptyLines | True (default) or False | Set to False if you want to keep empty lines in the exported text file. Otherwise, white space is removed.
TextDelimiter | String | Enter a character or sequence of characters to mark the end of each text field. This is mainly for use with CSV files that you open in Excel.

Text Export usage and limitations

Usage:

  • Create plain text files
  • Create comma (or other character) delimited text files
  • Feed raw data to spreadsheets or databases
  • Open in Notepad or Excel (comma delimited)

Does not support anything but plain fields and labels:

  • Supports plain text only with no formatting other than simple delimiters
  • Supports encoding for foreign language support

Export Report using Text Export Filter

Use the following steps to export reports through Text export filters.

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Add a reference to MESCIUS.ActiveReports.Export.Xml package in the project. See Manage ActiveReports Dependencies for more information.
  6. In your project's Bin > Debug folder, place the report.rpx (Section Report).
  7. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  8. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.
Dim rpt As New GrapeCity.ActiveReports.SectionReport()

' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in Text format.
Dim TextExport1 As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport()
TextExport1.Export(rpt.Document, Application.StartupPath + "\TextExpt.txt")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in Text format.
GrapeCity.ActiveReports.Export.Xml.Section.TextExport TextExport1 = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
TextExport1.Export(rpt.Document, Application.StartupPath + "\\TextExpt.txt");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


RTF Export

RTF Export
Developers > Export Reports > Export Section Reports > RTF Export

Glossary Item Box

RTF, or RichText format, opens in Microsoft Word, and is native to WordPad. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats. You can set the property either in code using the RTFExport object after adding reference to MESCIUS.ActiveReports.Export.Word package in your project.

The RTF export now supports the CrossPlatform compatibility mode.

RTF Export usage and limitations

Usage:

  • Create word-processing files
  • Open in Word or WordPad

Does not support:

  • Section or Page back colors
  • Angled text
  • This export is not WYSIWYG and thus does not support many features

RTF Export Properties

Property | Valid Values | Description
EnableShapes | True or False (default) | Indicates whether to export the Shapes and Lines to the RTF format if set to True. Microsoft Word is required to view it correctly.
Pagination | True (default)or False | Indicates whether to use pagination for the output RTF document.

Export Report using RTF Export Filter

Use the following steps to export reports through RTF export filters.

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Add a reference to MESCIUS.ActiveReports.Export.Word package in the project. See Manage ActiveReports Dependencies for more information.
  6. In your project's Bin>Debug folder, place the report.rpx (Section Report).
  7. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  8. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.
Dim rpt As New GrapeCity.ActiveReports.SectionReport()

' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in RTF format.
Dim RtfExport1 As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport()
RtfExport1.Export(rpt.Document, Application.StartupPath + "\RTFExpt.rtf")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in RTF format.
GrapeCity.ActiveReports.Export.Word.Section.RtfExport RtfExport1 = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
RtfExport1.Export(rpt.Document, Application.StartupPath + "\\RTFExpt.rtf");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Excel Export

Excel Export
Developers > Export Reports > Export Section Reports > Excel Export

Glossary Item Box

XLSX is a format that opens in Microsoft Excel as a spreadsheet. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats. The XLSX export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the XLSExport object after adding reference to MESCIUS.ActiveReports.Export.Excel package in your project.

The Excel export now supports the CrossPlatform compatibility mode.

Excel Export Properties

Property | Valid Values | Description
AutoRowHeight | True or False (default) | Set to True to have Excel set the height of rows based on the contents. Otherwise XlsExport calculates the height of rows. In some cases this may make the output look better inside Excel. However, a value of True may adversely affect pagination when printing, as it may stretch the height of the page.
DisplayGridLines | True (default) or False | Set to False to hide grid lines in Excel.
FileFormat Xls97Plus (default) or Xlsx

Set to use Microsoft Excel 97 and Xlsx to use Microsoft Excel 2007 or newer.
MinColumnWidth Single (VB) or float (C#)

Set the number of inches that is the smallest width for a column in the exported spreadsheet.

Tip: Larger values reduce the number of empty columns in a sheet. Set this value to 1 inch or more to get rid of small empty columns.
MinRowHeight Single (VB) or float (C#)

Set the number of inches that is the smallest height for a row in the exported spreadsheet.

Tip: Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space. Set this value to .25 inches or more to get rid of small empty rows.
MultiSheet True or False (default)

Set to True to export each page of your report to a separate sheet within the Excel file. This can increase performance and output quality at the cost of memory consumption for reports with complex pages and a lot of deviation between page layouts.

In general, use False for reports with more than 30 pages.
OpenXmlStandard Strict or Transitional (default)

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values:

  • Strict: The default value.
  • Transitional: The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices.

PageSettings

 Set a print orientation and paper size of Excel sheet.

Pagination

 True (default) or False Forces pagination or galley report layout mode. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.
RemoveVerticalSpace | True or False (default) | Set to True to remove vertical empty spaces from the spreadsheet. This may improve pagination for printing.
Security | Set a password and username to protect the excel spreadsheet.
SheetName | Specifies the name of the sheet.
UseCellMerging | True or False (default) | Set to True to merge cells where applicable.
UseCompression | True or False (default) | Indicates whether to use compression on exporting an Xlsx file.
UseDefaultPalette | True or False (default) | Set to True to export document with Excel default palette.

Excel Export usage and limitations

Usage:

  • Create spreadsheets
  • Open in Microsoft Excel

Does not support:

  • Line control
  • Shapes (other than filled rectangles)
  • CrossSectionBox and CrossSectionLine controls
  • Overlapping controls
  • Borders on controls with angled text
  • Angled text
  • CheckBox control (only its text element is exported)

Export Report using Excel Export Filter

Use the following steps to export reports through Excel export filters.

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Add a reference to MESCIUS.ActiveReports.Export.Excel package in the project. See Manage ActiveReports Dependencies for more information.
  6. In your project's Bin>Debug folder, place the report.rpx (Section Report).
  7. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  8. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.
Dim rpt As New GrapeCity.ActiveReports.SectionReport()

' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in Excel format.
Dim XlsExport1 As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()

' Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx
XlsExport1.Export(rpt.Document, Application.StartupPath + "\XLSExpt.xlsx")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in XLSX format.
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport XlsExport1 = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();

// Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx;
XlsExport1.Export(rpt.Document, Application.StartupPath + "\\XLSExpt.xlsx");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


TIFF Export

TIFF Export
Developers > Export Reports > Export Section Reports > TIFF Export

Glossary Item Box

Show All Show All
Hide All Hide All

TIFF, or tagged image file format, opens in the Windows Picture and Fax Viewer or any TIFF viewer. This export looks very much like the report as it displays in the viewer, but it is a multi-page image, so the text cannot be edited. The TIFF export filter has a couple of useful properties that allow you to control your output. You can set the properties either in code using the TIFFExport object after adding reference to MESCIUS.ActiveReports.Export.Image package in your projet.

TIFF Export Properties

Property | Valid Values | Description
CompressionScheme None, Rle, Ccitt3 (default), Ccitt4 or Lzw

Select an enumerated value to use for color output control:

  • None delivers color output with no compression.
  • Rle (run-length encoding) is for 1, 4, and 8 bit color depths.
  • Ccitt3 and Ccitt4 are for 1 color depth, and are used in old standard faxes.
  • Lzw (based on Unisys patent) is for 1, 4, and 8 bit color depths with lossless compression.
Dither | True or False (default) | Set to True to dither the image when you save it to a black and white format (Ccitt3, Ccitt4 or Rle). This property has no effect if the CompressionScheme is set to Lzw or None.
DpiX Integer (VB) or int (C#) greater than 0

Set the horizontal resolution of a report when exporting to TIFF format. The default value is 200.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.
DpiY Integer (VB) or int (C#) greater than 0

Set the vertical resolution of a report when exporting to TIFF format. The default value is 196.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.
Pagination | True (default) or False | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image. This property is only useful for Page/RDLX reports exports through RDF and does not affect a section report.

TIFF Export usage:

  • Create optical archive reports
  • Send reports via fax machines
  • Open in image viewers
  • Generates an image of each page. 100% WYSIWYG. For section report, WYSWYG in both compatibility modes - a legacy GDI and a new CrossPlatform mode.

Export Report using TIFF Export Filter

Use the following steps to export reports through TIFF export filters.

  2. Create a new or open an existing Windows Forms App (.NET Framework or .NET) in Visual Studio project.
  3. Go to the Project Explorer, right-click the project and select Add > New Item.
  4. Select ActiveReports 19 Standalone Report > Add and choose Section report type, and then click Finish.
    The xml-based Section report (report.rpx) is added.
  5. Add a reference to MESCIUS.ActiveReports.Export.Image package in the project. See Manage ActiveReports Dependencies for more information.
  6. In your project's Bin>Debug folder, place the report.rpx (Section Report).
  7. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  8. In Form_Load event, add the following code to export Section Reports .
    Visual Basic.NETcode. Paste INSIDE the Form_Load event Copy Code
    ' Create a Section report.
Dim rpt As New GrapeCity.ActiveReports.SectionReport()

' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
rpt.Run()

' Export the report in TIFF format.
Dim TiffExport1 As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport()
TiffExport1.Export(rpt.Document, Application.StartupPath + "\TIFFExpt.tiff")

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section Report
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();

// Export the report in TIFF format.
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport TiffExport1 = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
TiffExport1.Export(rpt.Document, Application.StartupPath + "\\TIFFExpt.tiff");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Set PDF Print Presets

Set PDF Print Presets
See Also
Developers > Export Reports > Set PDF Print Presets

Glossary Item Box

The page demonstrates presetting basic print options when exporting a Section Report or a Page/RDLX report in PDF format.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.
  1. From the Visual Studio File menu, select New, then Project.
  2. In the Create New Project dialog that appears, select any of the ActiveReports 19 templates and click Next.
  3. Type a name for your project and click Create.
  4. Select the type of report that you want to add and click Finish:
    • RDLX
    • RDLX Dashboard
    • Page
    • Section
  5. In the Design view, double-click the Form title bar to create the Form_Load event.
  6. Add the following code to invoke the Export methods and set print presets in the Form_Load event.

    Section Report

    Visual Basic.NET code. Paste INSIDE the Form_Load event Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\..\..\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
sectionReport.Run()

'Define settings for PDF
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf17

'Set default print settings using PrintPresets class
p.PrintPresets.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None
p.PrintPresets.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge
p.PrintPresets.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two
p.PrintPresets.PaperSourceByPageSize = True
p.PrintPresets.PrintPageRange = "1-3"
p.Export(sectionReport.Document, Application.StartupPath + "\PrintPresets.pdf")

    C# code. Paste INSIDE the Form_Load event Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + @"\..\..\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
sectionReport.Run();

//Define settings for PDF
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf17;

//Set default print settings using PrintPresets class
p.PrintPresets.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None;
p.PrintPresets.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge;
p.PrintPresets.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two;
p.PrintPresets.PaperSourceByPageSize = true;
p.PrintPresets.PrintPageRange = "1-3";
p.Export(sectionReport.Document, Application.StartupPath + "\\PrintPresets.pdf");

    Page/RDLX Report

    Visual Basic.NET code. Paste INSIDE the Form_Load event Copy Code
    'Set the rendering extension and render the report.
Dim pdfExport = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()

'Define settings for PDF
Dim pdfSettings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
pdfSettings.Version = GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion.Pdf17
pdfSettings.PrintOnOpen = True

'Set default print settings using PrintPresets class
Dim pdfPresetsSetting As New GrapeCity.ActiveReports.Export.Pdf.PrintPresets()
pdfPresetsSetting.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None
pdfPresetsSetting.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge
pdfPresetsSetting.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two
pdfPresetsSetting.PaperSourceByPageSize = True
pdfPresetsSetting.PrintPageRange = "1-3"

pdfSettings.PrintPresets = pdfPresetsSetting

Dim outputFile = New IO.FileInfo("..\..\PrintPresets.pdf")
Dim reportFile = New IO.FileInfo("..\..\PageReport1.rdlx")

Dim fileStreamProvider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputFile.Directory, Path.GetFileNameWithoutExtension(outputFile.FullName))

Using pageDocument = New GrapeCity.ActiveReports.PageReport(reportFile).Document
    pageDocument.Render(pdfExport, fileStreamProvider, pdfSettings)
End Using
    C# code. Paste INSIDE the Form_Load event Copy Code
    //Set the rendering extension and render the report.
var pdfExport = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();

//Define settings for PDF
GrapeCity.ActiveReports.Export.Pdf.Page.Settings pdfSettings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
pdfSettings.Version = GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion.Pdf17;
pdfSettings.PrintOnOpen = true;

//Set default print settings using PrintPresets class
GrapeCity.ActiveReports.Export.Pdf.PrintPresets pdfPresetsSetting = new GrapeCity.ActiveReports.Export.Pdf.PrintPresets();
pdfPresetsSetting.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None;
pdfPresetsSetting.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge;
pdfPresetsSetting.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two;
pdfPresetsSetting.PaperSourceByPageSize = true;
pdfPresetsSetting.PrintPageRange = "1-3";

pdfSettings.PrintPresets = pdfPresetsSetting;

var outputFile = new System.IO.FileInfo(@"..\..\PrintPresets.pdf");
var reportFile = new System.IO.FileInfo(@"..\..\PageReport1.rdlx");

var fileStreamProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputFile.Directory,
System.IO.Path.GetFileNameWithoutExtension(outputFile.FullName));

using (var pageDocument = new GrapeCity.ActiveReports.PageReport(reportFile).Document)
{
    pageDocument.Render(pdfExport, fileStreamProvider, pdfSettings);
}

See Also

Report Readers
Print Presets

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Manage Asynchronous Report Rendering

Manage Asynchronous Report Rendering
Developers > Export Reports > Manage Asynchronous Report Rendering

Glossary Item Box

ActiveReports provides a number of possibilities to control the export process, which can help you create more responsive applications. In this topic, we discuss common use cases of asynchronous or long-running report rendering:

  • Display export progress in a number of pages (ActiveReports can display a total number of pages only once the rendering is complete).
  • Create an Export dialog with the Cancel option.
  • Log information on the report execution.

Display Progress Information

Let's see how you can have displayed the export rendering progress information, using a WinForms Viewer application. As an example, we will take the Export sample that you can access by following this link - https://github.com/activereports/Samples19/tree/main/API/PageAndRDLX/Export.

The rendering progress information can be displayed for PDF, Image, HTML, and Excel exports at the report rendering.

Note: The progress information is not shown if the report is exported with the Pagination property set to False (Image, Excel Rendering Extensions) or with the Mode property set to Galley (HTML Rendering Extension).
  1. Open the Export sample project.
  2. From the Visual Studio toolbox, drag the Label control onto the Form.
  3. Add this code into the Form.
    Visual Basic.NET code Copy Code
    Private Async Sub ExportAsync(ByVal report As PageReport, ByVal renderingExtension As IRenderingExtension, ByVal outputProvider As StreamProvider, ByVal settings As NameValueCollection)
   labelExport.Text = "Export started..."
   Dim control = Me
   Dim progress = New Progress(Of ProgressInfo)(Sub(progressInfo)
      control.BeginInvoke(New MethodInvoker(Sub()
         labelExport.Text = If(progressInfo.IsLast = True, "Export is finished." , $"Exported {progressInfo.PageNumber} pages.")
      End Sub))
   End Sub)

   await Task.Run(Sub()
      Try
         report.Document.Render(renderingExtension, outputProvider, settings, False, False, CancellationToken.None, progress)
      Catch e as Exception
      End Try
   End Sub)
End Sub
    C# code Copy Code
    private async void ExportAsync(PageReport report, IRenderingExtension renderingExtension, StreamProvider outputProvider, NameValueCollection settings)
{
   labelExport.Text = "Export started...";
   var control = this;
   var progress = new Progress<ProgressInfo>(progressInfo =>
   {
      control.BeginInvoke(new MethodInvoker(() =>
      {
         labelExport.Text = progressInfo.IsLast ? "Export is finished." : $"Exported {progressInfo.PageNumber} pages.";

      }));
   });
   await Task.Run(() =>
   {
      try
      {
         report.Document.Render(renderingExtension, outputProvider, settings, false, false, CancellationToken.None, progress);
      }
      catch
      {
         // ignored
      }
   });
}
  4. Run the project.
  5. In the Export form, select PDF, Image, HTML, or Excel export type.
  6. Click the Export button and see the progress information in the new label.
    Click the Export button in Export Sample Report

Cancel Report Rendering

You can cancel the report rendering or export by using the following code.

Visual Basic.NET code Copy Code
Dim _cancellationTokenSource

Private Async Sub ExportAsync(ByVal report As PageReport, ByVal renderingExtension As IRenderingExtension, ByVal outputProvider As FileStreamProvider, ByVal settings As NameValueCollection)
   _cancellationTokenSource = New CancellationTokenSource()
   exportButton.Text = "Cancel"
   RemoveHandler exportButton.Click, AddressOf exportButton_Click
   AddHandler exportButton.Click, AddressOf CancelExport
   Await Task.Run(Sub()
      Try
         report.Document.Render(renderingExtension, outputProvider, settings, False, False, _cancellationTokenSource.Token)
      Catch unusedOperationCanceledException As OperationCanceledException
      End Try
   End Sub)
   If _cancellationTokenSource.IsCancellationRequested Then MessageBox.Show("Export was cancelled", "Export", MessageBoxButtons.OK, MessageBoxIcon.Information)
   _cancellationTokenSource.Dispose()
   _cancellationTokenSource = Nothing
   RemoveHandler exportButton.Click, AddressOf CancelExport
   AddHandler exportButton.Click, AddressOf exportButton_Click
   exportButton.Text = "Export"
End Sub

Private Sub CancelExport(ByVal sender As Object, ByVal e As EventArgs)
   _cancellationTokenSource?.Cancel()
End Sub
C# code Copy Code
private CancellationTokenSource _cancellationTokenSource;
private async void ExportAsync(PageReport report, IRenderingExtension renderingExtension, FileStreamProvider outputProvider, NameValueCollection settings)
{
   _cancellationTokenSource = new CancellationTokenSource();
   exportButton.Text = "Cancel";
   exportButton.Click -= exportButton_Click;
   exportButton.Click += cancelExport;

   await Task.Run(() =>
   {
      try
      {
         report.Document.Render(renderingExtension, outputProvider, settings, false, false, _cancellationTokenSource.Token);
      }
      catch (OperationCanceledException)
      {
      }
   });

   if (_cancellationTokenSource.IsCancellationRequested)
       MessageBox.Show("Export was cancelled", "Export", MessageBoxButtons.OK, MessageBoxIcon.Information);
   _cancellationTokenSource.Dispose();
   _cancellationTokenSource = null;
   exportButton.Click -= cancelExport;
   exportButton.Click += exportButton_Click;
   exportButton.Text = "Export";
}

private void cancelExport(object sender, EventArgs e)
{
   _cancellationTokenSource?.Cancel();
}

Information Logging

To log information on the report rendering, add Trace Listeners. As an example, modify the ExportAsync function as follows.

Visual Basic.NET code Copy Code
Private Async Sub ExportAsync(ByVal report As PageReport, ByVal renderingExtension As IRenderingExtension, ByVal outputProvider As StreamProvider, ByVal settings As NameValueCollection)
   labelExport.Text = "Export started..."
   Dim control = Me
   Dim progress = New Progress(Of ProgressInfo)(Sub(progressInfo)
      control.BeginInvoke(New MethodInvoker(Function()
         labelExport.Text = If(progressInfo.IsLast = True, "Export is finished." , $"Exported {progressInfo.PageNumber} pages.")
         Trace.TraceInformation($"Exported {progressInfo.PageNumber} pages.")
      End Function))
   End Sub)
   await Task.Run(Sub()
      Try
         Dim traceWriter = New TextWriterTraceListener("TextWriterOutput.log", "myListener")
         Trace.Listeners.Clear()
         Trace.Listeners.Add(traceWriter)
         report.Document.Render(renderingExtension, outputProvider, settings, False, False, CancellationToken.None, progress)
         Trace.Flush()
         Trace.Listeners.Clear()
      Catch e as Exception
      End Try
   End Sub)
End Sub
C# code Copy Code
private async void ExportAsync(PageReport report, IRenderingExtension renderingExtension, StreamProvider outputProvider, NameValueCollection settings)
{
   labelExport.Text = "Export started...";
   var control = this;
   var progress = new Progress<ProgressInfo>(progressInfo =>
   {
      control.BeginInvoke(new MethodInvoker(() =>
      {
         labelExport.Text = progressInfo.IsLast ? "Export is finished." : $"Exported {progressInfo.PageNumber} pages.";
         Trace.TraceInformation($"Exported {progressInfo.PageNumber} pages.");
      }));
   });
   await Task.Run(() =>
   {
      try
      {
         var traceWriter = new TextWriterTraceListener("TextWriterOutput.log", "myListener");
         Trace.Listeners.Clear();
         Trace.Listeners.Add(traceWriter);
         report.Document.Render(renderingExtension, outputProvider, settings, false, false, CancellationToken.None, progress);
         Trace.Flush();
         Trace.Listeners.Clear();
      }
      catch
      {
         // ignored
      }
   });
}

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print Reports

Print Reports
See Also
Developers > Print Reports

Glossary Item Box

When you print a report, the report data is first sent to the report generator and then to the printer. You can also preview the report before you actually print it.

This section describes using print methods in desktop viewers, how to print reports on single page, and different scenarios of printing in JSViewer.

ActiveReports provides you with rich Page/RDLX and Section report printing options and settings. In this section, we will look at the basic printing options for each report type, with sample codes.

Printing is implemented using PrintDocument Class (System.Drawing.Printing), so this functionality will only be available for Windows.

Note: It is important to specify the MESCIUS.ActiveReports.Viewer.Common assembly for printing to work correctly.

See Also

Print using Print Methods
Print Reports on a Single Page
Print in Js Viewer

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print using Print Methods

Print using Print Methods
See Also
Developers > Print Reports > Print using Print Methods

Glossary Item Box

ActiveReports provides access to Print methods to enable printing of Page and Section Reports. You can access Print methods in any of the following ways:

  • Viewer.Print method (using the Viewer control)
  • Print methods in SectionDocument or PageDocument
  • Print methods in the PrintExtension class

Viewer.Print method

The code sample illustrates how to access the print method using the Viewer control.

You can use the Print method of the Viewer class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before Print is executed.

Visual Basic.NET code. Add this code INSIDE the LoadCompleted event of the Viewer Copy Code
Viewer1.Print(True, True, True)

C# code. Add this code INSIDE the LoadCompleted event of the Viewer Copy Code
viewer1.Print(true, true, true);

Print methods in SectionDocument or PageDocument

SectionDocument and PageDocument types have Print methods that can be used directly on the document object. The following code samples illustrate how to access the print methods that can be used directly on the document object.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in the GrapeCity.ActiveReports namespace of GrapeCity.ActiveReports.Viewer.Common assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add GrapeCity.ActiveReports.Viewer.Common reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste at the top of the code view. Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
Dim rpt = New SectionReport1()
rpt.Run(False)
Dim sectionDocument = rpt.Document
sectionDocument.Print(True, True, False)

C# code. Paste at the top of the code view. Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event. Copy Code
var rpt = new SectionReport1();
rpt.Run(false);
var sectionDocument = rpt.Document;
sectionDocument.Print(true, true, false);

Page Report

Visual Basic.NET code. Paste at the top of the code view. Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
Dim file_name As String = "..\..\PageReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
pageDocument.Print(True, True, False)

C# code. Paste at the top of the code view. Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event. Copy Code
string file_name = @"..\..\PageReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
pageDocument.Print(true, true, false);

Print methods in the PrintExtension class

You can use the Print method of the PrintExtension class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before print is executed. The following code samples illustrate how to access the print method of the PrintExtension class.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in the GrapeCity.ActiveReports namespace of GrapeCity.ActiveReports.Viewer.Common assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add MESCIUS.ActiveReports.Viewer.Common reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, True, True)

C# code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, true, true);

Page Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, True, True)

C# code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, true, true);

See Also

Page/RDLX Report
Section Report

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print Reports on a Single Page

Print Reports on a Single Page
Developers > Print Reports > Print Reports on a Single Page

Glossary Item Box

You can set the printing options for an RDLX report to print it on a single page, despite the report page height. This is useful for printing receipts, bills menu, recharge ticket, etc. where all data is printed in one page.

  1. Open an RDLX report in the Designer. This sample uses a report with a Table data region, based on the Customers dataset.
  2. With a report selected, go to Properties and set the PageSize > Height property to Auto. Note that if the PaperOrientation property is set to Portrait, this property gets disabled when you set PageSize.Height to Auto.

    Inserting a new page
  3. Click Preview to see that now the report has one page.
  4. Click Print.
  5. In the Print dialog that opens, click Properties, and select a page size.
  6. Click OK to print a report on a single page.

Note:

  • If your report has page breaks, then printing on a single page for the report will not work.
  • The user should set the correct Paper Size in Printing Preferences before sending the Print command.
  • This feature is available in the Visual Studio Integrated Designer and Standalone Report Designer.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Print in Js Viewer

Print in Js Viewer
See Also
Developers > Print Reports > Print in Js Viewer

Glossary Item Box

Js Viewer provides several options for printing a report. This topic describes several ways in which a report can be printed in Js Viewer.

Print with Preview

Print report when the report is completely loaded in the viewer, using print() method.

index.html Copy Code
var viewer;
function loadViewer() {
    viewer = GrapeCity.ActiveReports.JSViewer.create({
        element: '#viewerContainer',
        reportID: 'Report.rdlx',
        documentLoaded: () => viewer.print()
    });
}

Print without Preview

Print report without previewing using 'global' print() method. This is same as the default button in Js Viewer, but without showing report preview.
index.html Copy Code
GrapeCity.ActiveReports.JSViewer.print({ reportID:'Report.rdlx'});

Preview Report and Print to PDF

Open the report and export it to PDF with PrintOnOpen parameter set to 'true'. In this case, the exported PDF opens in new window of the browser, and the print dialog is displayed.

index.html Copy Code
var viewer;
function loadViewer() {
    viewer = GrapeCity.ActiveReports.JSViewer.create({
        element: '#viewerContainer',
        reportID: 'Report.rdlx',
        documentLoaded: () => viewer.export('Pdf', null, true, { PrintOnOpen: 'true' })
    });
}

Print to PDF

Export the report to PDF using 'global' export() method and enable the PrintOnOpen option. In this case, the report is not opened.
index.html Copy Code
GrapeCity.ActiveReports.JSViewer.export({
    reportID: 'Report.rdlx', exportType: 'Pdf', settings: { PrintOnOpen: 'true' },
    callback: (args) => { window.open(args) }
})

Note:

  • For Section Reports, use OnlyForPrint instead of PrintOnOpen (for backward compatibility). For Page and RDLX reports (.rdlx), anyone of PrintOnOpen or OnlyForPrint can be used.
  • Use latest versions of Chrome, Firefox, and Chrome-based Edge for the described print features to work correctly.

See Also

Js Viewer API

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Plugins Development

Plugins Development
See Also
Developers > Plugins Development

Glossary Item Box

ActiveReports components can be used as plugins for third-party applications.

A sample of creating a new application domain, where you can load ActiveReports is shown below:

Copy Code
string appDir = Path.GetDirectoryName(GetType().Assembly.CodeBase.Substring(8));
     //grant permission to the untrusted application
     var pset = new PermissionSet(PermissionState.Unrestricted);
     var sandBoxSetup = new AppDomainSetup
          {
               //set the ApplicationBase to a folder
               ApplicationBase = appDir,
               ConfigurationFile = appDir + "....dll.config"
          };
         //create sandboxed application domain
         AppDomain domain = AppDomain.CreateDomain("Sandboxed Domain", null, sandBoxSetup, pset);

Note: Partial/Medium Trust is obsolete. ActiveReports does not support it anymore.

See Also

Introduction
Product Requirements

DevOps
Azure and Medium Trust

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Samples

Glossary Item Box

The ActiveReports 19 samples are available on GitHub. These samples are categorized under two folders - Samples and WebSamples, and further based on features.

Note: You need to install .NET SDK to run any sample in Visual Studio 2019 and Visual Studio 2022.

Samples

Sample |  | Description
Advanced | Page and RDLX reports
 | Calendar | This sample demonstrates using Calendar data region in reports.
 | Custom Chart | This sample demonstrates using custom report item - Radar chart in a report.
 | Custom data Provider | This sample demonstrates how to create a project using custom data provider and how to pull data from a comma separated value (CSV) file.
 | Custom Pdf Export | This sample demonstrates exporting reports to PDF format using third-party assemblies.
 | Custom Resource Locator | This sample showcases a custom implementation of the resource locator to load pictures from the user's "My Pictures" directory.
 | Custom Tile Provider | This sample demonstrates how to create a custom tile provider.
 | Oracle Data Provider | This sample illustrates using Oracle Data Provider as data source for designing Page/RDLX reports.
 | Section Reports
 | Custom Drill Through | This sample demonstrates using hyperlinks and the viewer hyperlink event to simulate drill-down from one report to another.
API | Page and RDLX reports
 | Create Report | This sample demonstrates how to create a Page Report layout in code. It further shows creating a table control, adding table rows and table columns inside it, adding cells inside the table rows and columns and adding text boxes inside the cells.
 | Digital Signature Pro | This sample demonstrates how to add digital signatures when exporting to PDF format.
 | Export | This sample demonstrates how to export Page and RDLX reports to different export formats.
 | FontResolver | This sample demonstrates implementing custom fonts.
 | Layers | This sample demonstrates how to use Layers in a report.
 | Report Wizard | This sample demonstrates how to create a custom Report Wizard that allows you to select a report from the list of multiple reports and then allows you to select the data that you want to display in the selected report.
 | Stylesheets | This sample demonstrates how to work with embedded and external style sheets in Page and RDLX reports.
 | Section Reports
 | Charting | This sample demonstrates chart types used in different scenarios, in both bound and unbound modes.
 | Cross Section Controls | This sample demonstrates the use of the cross section lines and boxes.
 | Cross Tab Report | This sample demonstrates using unbound data, conditional highlighting and distributing data across columns to create a cross-tab view and data aggregation.
 | Custom Annotation | This sample demonstrates adding the Custom Annotation button to the report Viewer toolbar and adding a new annotation to the report.
 | Digital Signature Pro | This sample demonstrates adding the Custom Annotation button to the report Viewer toolbar and adding a new annotation to the report.
 | Export | This sample demonstrates how to export to different export formats using code.
 | Inheritance | This sample demonstrates using the method that inherits a report at run time and design time.
 | Print Multiple Pages per Sheet | This sample demonstrates printing a document with multiple pages per sheet by using the common PrintDocument class of the NET.Framework.
 | Style Sheets | This sample demonstrates changing styles at run time to provide a different look to a same report.
 | Sub Report | This sample demonstrates using subreports in an ActiveReports report.
 | Summary | This sample demonstrates how to display summarized data in a Section Report.
Data Binding | Page and RDLX reports
 | CSV Data Source | This sample demonstrates how to connect to a CSV data source.
 | DataSet DataSource | This sample demonstrates how to use a dataset as a data source for a report.
 | Json Data Source | This sample demonstrates how to use the Json data provider at run time and add a web service for authentication.
 | Object Data Source | This sample demonstrates how to use Object provider for binding a report.
 | OData Data Source | This sample demonstrates how to use OData EndPoint for binding a report.
 | OleDb Data Source | This sample demonstrates how to connect to an OleDb data source at run time and pass data to the report using LocateDataSource event.
 | Xml Data Source | This sample demonstrates how to connect to a XML data source at run time and pass data to the report using LocateDataSource event.
 | Section Reports
 | Bound Data | This sample demonstrates binding to ADO.NET Data objects.
 | IList Binding | This sample demonstrates creating a custom collection that stores data from the database in the List. The custom collection is displayed by binding data to the DataGridView control by using the DataSource property of this control.
 | LINQ | This sample demonstrates how to use LINQ in an ActiveReports report.
 | Unbound Data | This sample demonstrates how to create a dataset for a Section Report and use the FetchData event to populate the Fields collection to display the report unbound data.
 | XML | This sample demonstrates how to create a report with XML data, using a SubReport or using the XML hierarchical structure.
Designer Pro | Map | This sample demonstrates how to work with Map control in ActiveReports.
 | End User Designer | This sample demonstrates a custom end-user report designer that can be integrated in your applications to allow users to modify report layouts.
 | FlatEndUserDesigner | This sample demonstrates building the designer using DesignerForm class.
 | Reports Gallery | This sample demonstrates customizing End User Designer application to display a list of categorized reports.
 | Table of Contents | This sample demonstrates how to use TableofContents control in ActiveReports.
Desktop | WPF Viewer | This sample demonstrates using WPF Viewer in a WPF application.
 | Win Viewer | This sample demonstrates using Win Viewer in a Windows Form application.
Web | Custom Preview | The sample demonstrates exporting an ActiveReports report to the HTML or PDF format in your Web application.

Web Samples

Sample | Description
WebDesigner Samples
Blazor Designer | The samples on Blazor Designer demonstrate the use of ActiveReports Blazor Designer with Server application, WebAssembly application, and remote report service.
WebDesigner MVC(Core) | This sample demonstrates WebDesigner with an ASP.NET MVC Core back end.
WebDesigner Angular(Core) | This sample demonstrates the ActiveReports WebDesigner with an Angular 8 app and ASP.NET Core back end.
WebDesigner Blazor | This sample demonstrates the ActiveReports WebDesigner with Blazor framework.
WebDesigner Custom Data Providers | The sample demonstrates the method to use custom data providers (such as SQLite and OData) for supplying data to the report in the ActiveReports WebDesigner.
WebDesigner Custom Store | The sample demonstrates the use of custom resources service for ActiveReports WebDesigner with an ASP.NET Core back end.
JSViewer Samples
BlazorViewer | The samples on Blazor Viewer demonstrate the use of ActiveReports Blazor Viewer with Server application, WebAssembly application, and remote report service.
JSViewer Angular(Core) | This sample demonstrates the use of the ActiveReports JSViewer with an Angular 8 app and ASP.NET Core back end.
JSViewer CORS | This sample demonstrates the use of ActiveReports JSViewer with an ASP.NET MVC 5 back end when the server is hosted elsewhere using CORS.
JSViewer MVC CORS(Core) | This sample demonstrates the use of ActiveReports JSViewer with an ASP.NET MVC 5 Core back end when the server is hosted elsewhere using CORS.
JSViewer MVC | This sample demonstrates the use of ActiveReports JSViewer with an ASP.NET MVC 5 back end.
JSViewer MVC(Core) | This sample demonstrates the use of ActiveReports JSViewer with an ASP.NET MVC Core back end.
JSViewer React(Core) | This sample demonstrates the use of ActiveReports JSViewer with an ReactJS app and ASP.NET Core back end.
JSViewer Vue(Core) | This sample demonstrates the use of ActiveReports JSViewer with an VueJS app and ASP.NET Core back end.
WebViewer ASP.NET | This sample demonstrates the ActiveReports web control feature and generating a parameterized report.

Silent Print

The SilentPrint sample project consists of three samples - JSViewerBatchPrint_MVC_Core, JSViewerSilentPrint_MVC_Core, and PrintAgent.

The JSViewerBatchPrint_MVC_Core sample demonstrates how to print many reports by clicking the Print button,
without showing the Print Preview dialog for every report. Silent printing is implemented through a print agent that needs to be started.

The JSViewerSilentPrint_MVC_Core sample demonstrates how to print a report by clicking once the JSViewer Print button, without showing the Print Preview dialog. Silent printing is implemented through a print agent that needs to be started.

The PrintAgent sample contains a Windows service, hosting an ASP.NET Core API that allows printing PDF files. The
print agent uses the GrapeCity.Documents.Pdf library.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Class Library

Class Library

Glossary Item Box

The Class Library section provides the API reference for ActiveReports.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


CSSDeclaration Class

[image]
ActiveReports 19 .NET Edition
CSSDeclaration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDeclaration Class

Glossary Item Box

CSSDeclaration represents the declaration block of a CSS rule. Provides a programmatic interface directly to the CSS declarations.

Object Model

CSSDeclaration Class

Syntax

Visual Basic (Declaration)
Public Class CSSDeclaration
C#
public class CSSDeclaration

Remarks

Use the publicly accessable m_pXxxx structs to retrieve known property values. Unknown properties and their text values are available in the publicly accessable m_unknownPropTable variable. Use AppendValue to append values to this CSSDeclaration.

Inheritance Hierarchy

System.Object
DDCssLib.CSSDeclaration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Members
DDCssLib Namespace

Copyright © MESCIUS inc. All rights reserved.

© 2025 All Rights Reserved.


CSSDeclaration Class Members

[image]
ActiveReports 19 .NET Edition
CSSDeclaration Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDeclaration Class

Glossary Item Box

The following tables list the members exposed by CSSDeclaration.

Public Constructors

 | Name | Description
Public Constructor | CSSDeclaration Constructor | The default constructor for CSSDeclaration.
Top

Public Fields

 | Name | Description
Public Field | m_pAural | Gets any text aural declarations in this CSSDeclaration.
Public Field | m_pBreaks | Gets any text breaks declarations in this CSSDeclaration.
Public Field | m_pColor | Gets any color related declarations in this CSSDeclaration.
Public Field | m_pContent | Gets any text content declarations in this CSSDeclaration.
Public Field | m_pDisplay | Gets any text display declarations in this CSSDeclaration.
Public Field | m_pFont | Gets any font property declarations in this CSSDeclaration.
Public Field | m_pLine | Gets any text line declarations in this CSSDeclaration.
Public Field | m_pList | Gets any text list declarations in this CSSDeclaration.
Public Field | m_pMargin | Gets any text margin declarations in this CSSDeclaration.
Public Field | m_pMisc | Gets any text misc declarations in this CSSDeclaration.
Public Field | m_pPage | Gets any text page declarations in this CSSDeclaration.
Public Field | m_pPosition | Gets any text positional declarations (spacing, decoration, alignment) in this CSSDeclaration.
Public Field | m_pTable | Gets any text table declarations in this CSSDeclaration.
Public Field | m_pText | Gets any text related declarations (spacing, decoration, alignment) in this CSSDeclaration.
Public Field | m_pUserInterface | Gets any text user interface declarations in this CSSDeclaration.
Public Field | m_unknownPropTable | The unknown property table
Top

Public Methods

 | Name | Description
Public Method | AppendUnknownValue | Used to append unknown properties to this declaration. The unknown name and value will be used only when rebuilding the CSS string again.
Public Method | AppendValue | Adds the specified value for the specified property to this CSSDeclaration.
Public Method | Clone | Creates copy of this instance and places it in the specified variable.
Public Method | Count | Returns the number of declarations stored by this CSSDeclaration instance (that were added with AppendValue).
Public Method | GetImportantValues | Returns all of the property/values in this CSSDeclaration instance that were marked with the !important declaration.
Public Method | GetProperty | Returns the eCSSProperty at the specified index in the property order array.
Public Method | GetValue | Overloaded. Returns the value of the specified property as a CSSValue object.
Public Method | GetValueIsImportant | Overloaded. Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.
Public Method | Reset | Resets all CSSValues contained in this declaration.
Public Method | SetValueImportant | Sets the value important.
Public Method | ToString | Returns the propery/value pair(s) contained in this CSSDeclaration in standards based CSS declaration block syntax.
Top

See Also

Reference

CSSDeclaration Class
DDCssLib Namespace


CSSDeclaration Constructor

[image]
ActiveReports 19 .NET Edition
CSSDeclaration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : CSSDeclaration Constructor

Glossary Item Box

The default constructor for CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CSSDeclaration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


CSSDeclaration Class Methods

[image]
ActiveReports 19 .NET Edition
CSSDeclaration Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDeclaration Class

Glossary Item Box

For a list of all members of this type, see CSSDeclaration members.

Public Methods

 | Name | Description
Public Method | AppendUnknownValue | Used to append unknown properties to this declaration. The unknown name and value will be used only when rebuilding the CSS string again.
Public Method | AppendValue | Adds the specified value for the specified property to this CSSDeclaration.
Public Method | Clone | Creates copy of this instance and places it in the specified variable.
Public Method | Count | Returns the number of declarations stored by this CSSDeclaration instance (that were added with AppendValue).
Public Method | GetImportantValues | Returns all of the property/values in this CSSDeclaration instance that were marked with the !important declaration.
Public Method | GetProperty | Returns the eCSSProperty at the specified index in the property order array.
Public Method | GetValue | Overloaded. Returns the value of the specified property as a CSSValue object.
Public Method | GetValueIsImportant | Overloaded. Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.
Public Method | Reset | Resets all CSSValues contained in this declaration.
Public Method | SetValueImportant | Sets the value important.
Public Method | ToString | Returns the propery/value pair(s) contained in this CSSDeclaration in standards based CSS declaration block syntax.
Top

See Also

Reference

CSSDeclaration Class
DDCssLib Namespace


AppendUnknownValue Method

[image]
ActiveReports 19 .NET Edition
AppendUnknownValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : AppendUnknownValue Method

sPropertyName
The unchanged name of the CSS property parsed.
sPropertyValue
The unchanged value for the CSS property.

Glossary Item Box

Used to append unknown properties to this declaration. The unknown name and value will be used only when rebuilding the CSS string again.

Syntax

Visual Basic (Declaration)
Public Sub AppendUnknownValue( _
   ByVal sPropertyName As String, _
   ByVal sPropertyValue As String _
)
C#
public void AppendUnknownValue(
   string sPropertyName,
   string sPropertyValue
)

Parameters

sPropertyName
The unchanged name of the CSS property parsed.
sPropertyValue
The unchanged value for the CSS property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


AppendValue Method

[image]
ActiveReports 19 .NET Edition
AppendValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : AppendValue Method

aProperty
The property the value should be used for.
aValue
The value of the property.

Glossary Item Box

Adds the specified value for the specified property to this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public Sub AppendValue( _
   ByVal aProperty As eCSSProperty, _
   ByVal aValue As CSSValue _
)
C#
public void AppendValue(
   eCSSProperty aProperty,
   CSSValue aValue
)

Parameters

aProperty
The property the value should be used for.
aValue
The value of the property.

Remarks

This method will keep track of the order that the properties are added in so that when the CSS string is recreated, you have the capability to list the properties in the same order as they were originally specified in the declaration block.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : Clone Method

pClone
The variable to contain a copy of the instance of CSSDeclaration the Clone method is called on.

Glossary Item Box

Creates copy of this instance and places it in the specified variable.

Syntax

Visual Basic (Declaration)
Public Sub Clone( _
   ByRef pClone As CSSDeclaration _
)
C#
public void Clone(
   ref CSSDeclaration pClone
)

Parameters

pClone
The variable to contain a copy of the instance of CSSDeclaration the Clone method is called on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


Count Method

[image]
ActiveReports 19 .NET Edition
Count Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : Count Method

Glossary Item Box

Returns the number of declarations stored by this CSSDeclaration instance (that were added with AppendValue).

Syntax

Visual Basic (Declaration)
Public Function Count() As Integer
C#
public int Count()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


GetImportantValues Method

[image]
ActiveReports 19 .NET Edition
GetImportantValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : GetImportantValues Method

pResult

Glossary Item Box

Returns all of the property/values in this CSSDeclaration instance that were marked with the !important declaration.

Syntax

Visual Basic (Declaration)
Public Sub GetImportantValues( _
   ByRef pResult As CSSDeclaration _
)
C#
public void GetImportantValues(
   ref CSSDeclaration pResult
)

Parameters

pResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


GetProperty Method

[image]
ActiveReports 19 .NET Edition
GetProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : GetProperty Method

nIndex
The index within the order array to retrieve the element at.

Glossary Item Box

Returns the eCSSProperty at the specified index in the property order array.

Syntax

Visual Basic (Declaration)
Public Function GetProperty( _
   ByVal nIndex As Integer _
) As eCSSProperty
C#
public eCSSProperty GetProperty(
   int nIndex
)

Parameters

nIndex
The index within the order array to retrieve the element at.

Return Value

The eCSSProperty value at the specified index within the order array.

Remarks

The "order array" keeps track of what order the properties were added to the declaration in, so that when the CSS string is recreated the properties are in the original order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


GetValue Method

[image]
ActiveReports 19 .NET Edition
GetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : GetValue Method

Glossary Item Box

Returns the value of the specified property as a CSSValue object.

Overload List

Overload | Description
GetValue(eCSSProperty) | Returns the value of the specified property as a CSSValue object.
GetValue(eCSSProperty,String) | Retrieves the value for the specified CSS property from this declaration instance and places the value into sValue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


GetValue(eCSSProperty) Method

[image]
ActiveReports 19 .NET Edition
GetValue(eCSSProperty) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class > GetValue Method : GetValue(eCSSProperty) Method

aProperty
The property to get the value of.

Glossary Item Box

Returns the value of the specified property as a CSSValue object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetValue( _
   ByVal aProperty As eCSSProperty _
) As CSSValue
C#
public CSSValue GetValue(
   eCSSProperty aProperty
)

Parameters

aProperty
The property to get the value of.

Return Value

The CSSValue object containing the specified property's value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members
Overload List


GetValue(eCSSProperty,String) Method

[image]
ActiveReports 19 .NET Edition
GetValue(eCSSProperty,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class > GetValue Method : GetValue(eCSSProperty,String) Method

aProperty
The CSS property to retrieve the value for.
sValue
The string variable to set to the string representation of the specified property's value.

Glossary Item Box

Retrieves the value for the specified CSS property from this declaration instance and places the value into sValue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetValue( _
   ByVal aProperty As eCSSProperty, _
   ByRef sValue As String _
)
C#
public void GetValue(
   eCSSProperty aProperty,
   ref string sValue
)

Parameters

aProperty
The CSS property to retrieve the value for.
sValue
The string variable to set to the string representation of the specified property's value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members
Overload List


GetValueIsImportant Method

[image]
ActiveReports 19 .NET Edition
GetValueIsImportant Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : GetValueIsImportant Method

Glossary Item Box

Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.

Overload List

Overload | Description
GetValueIsImportant(eCSSProperty,Boolean) | Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.
GetValueIsImportant(String,Boolean) | Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


GetValueIsImportant(eCSSProperty,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetValueIsImportant(eCSSProperty,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class > GetValueIsImportant Method : GetValueIsImportant(eCSSProperty,Boolean) Method

aProperty
The property to check for important.
bImportant
The boolean variable who's value will be True if the specified property is marked as important, or false if the specified property is not marked as important.

Glossary Item Box

Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetValueIsImportant( _
   ByVal aProperty As eCSSProperty, _
   ByRef bImportant As Boolean _
)
C#
public void GetValueIsImportant(
   eCSSProperty aProperty,
   ref bool bImportant
)

Parameters

aProperty
The property to check for important.
bImportant
The boolean variable who's value will be True if the specified property is marked as important, or false if the specified property is not marked as important.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members
Overload List


GetValueIsImportant(String,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetValueIsImportant(String,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class > GetValueIsImportant Method : GetValueIsImportant(String,Boolean) Method

aProperty
The string name of the property to check for important.
aIsImportant
The boolean variable who's value will be True if the specified property is marked as important, or false if the specified property is not marked as important.

Glossary Item Box

Determines if the specified property stored in this CSSDeclaration instance was marked with the !important declaration.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetValueIsImportant( _
   ByVal aProperty As String, _
   ByRef aIsImportant As Boolean _
)
C#
public void GetValueIsImportant(
   string aProperty,
   ref bool aIsImportant
)

Parameters

aProperty
The string name of the property to check for important.
aIsImportant
The boolean variable who's value will be True if the specified property is marked as important, or false if the specified property is not marked as important.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members
Overload List


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : Reset Method

Glossary Item Box

Resets all CSSValues contained in this declaration.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


SetValueImportant Method

[image]
ActiveReports 19 .NET Edition
SetValueImportant Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : SetValueImportant Method

aProperty

Glossary Item Box

Sets the value important.

Syntax

Visual Basic (Declaration)
Public Sub SetValueImportant( _
   ByVal aProperty As eCSSProperty _
)
C#
public void SetValueImportant(
   eCSSProperty aProperty
)

Parameters

aProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : ToString Method

Glossary Item Box

Returns the propery/value pair(s) contained in this CSSDeclaration in standards based CSS declaration block syntax.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The CSS text string. If there are not any properties stored by this CSSDeclaration, an empty string will be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


CSSDeclaration Class Fields

[image]
ActiveReports 19 .NET Edition
CSSDeclaration Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDeclaration Class

Glossary Item Box

For a list of all members of this type, see CSSDeclaration members.

Public Fields

 | Name | Description
Public Field | m_pAural | Gets any text aural declarations in this CSSDeclaration.
Public Field | m_pBreaks | Gets any text breaks declarations in this CSSDeclaration.
Public Field | m_pColor | Gets any color related declarations in this CSSDeclaration.
Public Field | m_pContent | Gets any text content declarations in this CSSDeclaration.
Public Field | m_pDisplay | Gets any text display declarations in this CSSDeclaration.
Public Field | m_pFont | Gets any font property declarations in this CSSDeclaration.
Public Field | m_pLine | Gets any text line declarations in this CSSDeclaration.
Public Field | m_pList | Gets any text list declarations in this CSSDeclaration.
Public Field | m_pMargin | Gets any text margin declarations in this CSSDeclaration.
Public Field | m_pMisc | Gets any text misc declarations in this CSSDeclaration.
Public Field | m_pPage | Gets any text page declarations in this CSSDeclaration.
Public Field | m_pPosition | Gets any text positional declarations (spacing, decoration, alignment) in this CSSDeclaration.
Public Field | m_pTable | Gets any text table declarations in this CSSDeclaration.
Public Field | m_pText | Gets any text related declarations (spacing, decoration, alignment) in this CSSDeclaration.
Public Field | m_pUserInterface | Gets any text user interface declarations in this CSSDeclaration.
Public Field | m_unknownPropTable | The unknown property table
Top

See Also

Reference

CSSDeclaration Class
DDCssLib Namespace


m_pAural Field

[image]
ActiveReports 19 .NET Edition
m_pAural Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pAural Field

Glossary Item Box

Gets any text aural declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pAural As CSSAural
C#
public CSSAural m_pAural

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pBreaks Field

[image]
ActiveReports 19 .NET Edition
m_pBreaks Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pBreaks Field

Glossary Item Box

Gets any text breaks declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pBreaks As CSSBreaks
C#
public CSSBreaks m_pBreaks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pColor Field

[image]
ActiveReports 19 .NET Edition
m_pColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pColor Field

Glossary Item Box

Gets any color related declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pColor As CSSColor
C#
public CSSColor m_pColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pContent Field

[image]
ActiveReports 19 .NET Edition
m_pContent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pContent Field

Glossary Item Box

Gets any text content declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pContent As CSSContent
C#
public CSSContent m_pContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pDisplay Field

[image]
ActiveReports 19 .NET Edition
m_pDisplay Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pDisplay Field

Glossary Item Box

Gets any text display declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pDisplay As CSSDisplay
C#
public CSSDisplay m_pDisplay

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pFont Field

[image]
ActiveReports 19 .NET Edition
m_pFont Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pFont Field

Glossary Item Box

Gets any font property declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pFont As CSSFont
C#
public CSSFont m_pFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pLine Field

[image]
ActiveReports 19 .NET Edition
m_pLine Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pLine Field

Glossary Item Box

Gets any text line declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pLine As CSSLine
C#
public CSSLine m_pLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pList Field

[image]
ActiveReports 19 .NET Edition
m_pList Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pList Field

Glossary Item Box

Gets any text list declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pList As CSSList
C#
public CSSList m_pList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pMargin Field

[image]
ActiveReports 19 .NET Edition
m_pMargin Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pMargin Field

Glossary Item Box

Gets any text margin declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pMargin As CSSMargin
C#
public CSSMargin m_pMargin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pMisc Field

[image]
ActiveReports 19 .NET Edition
m_pMisc Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pMisc Field

Glossary Item Box

Gets any text misc declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pMisc As CSSMisc
C#
public CSSMisc m_pMisc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pPage Field

[image]
ActiveReports 19 .NET Edition
m_pPage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pPage Field

Glossary Item Box

Gets any text page declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pPage As CSSPage
C#
public CSSPage m_pPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pPosition Field

[image]
ActiveReports 19 .NET Edition
m_pPosition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pPosition Field

Glossary Item Box

Gets any text positional declarations (spacing, decoration, alignment) in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pPosition As CSSPosition
C#
public CSSPosition m_pPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pTable Field

[image]
ActiveReports 19 .NET Edition
m_pTable Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pTable Field

Glossary Item Box

Gets any text table declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pTable As CSSTable
C#
public CSSTable m_pTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pText Field

[image]
ActiveReports 19 .NET Edition
m_pText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pText Field

Glossary Item Box

Gets any text related declarations (spacing, decoration, alignment) in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pText As CSSText
C#
public CSSText m_pText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_pUserInterface Field

[image]
ActiveReports 19 .NET Edition
m_pUserInterface Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_pUserInterface Field

Glossary Item Box

Gets any text user interface declarations in this CSSDeclaration.

Syntax

Visual Basic (Declaration)
Public m_pUserInterface As CSSUserInterface
C#
public CSSUserInterface m_pUserInterface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


m_unknownPropTable Field

[image]
ActiveReports 19 .NET Edition
m_unknownPropTable Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDeclaration Class : m_unknownPropTable Field

Glossary Item Box

The unknown property table

Syntax

Visual Basic (Declaration)
Public m_unknownPropTable As Hashtable
C#
public Hashtable m_unknownPropTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDeclaration Class
CSSDeclaration Members


StyleSheet Class

[image]
ActiveReports 19 .NET Edition
StyleSheet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheet Class

Glossary Item Box

Summary description for StyleSheet.

Object Model

StyleSheet Class

Syntax

Visual Basic (Declaration)
Public Class StyleSheet
C#
public class StyleSheet

Inheritance Hierarchy

System.Object
DDCssLib.StyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Members
DDCssLib Namespace


StyleSheet Class Members

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheet Class

Glossary Item Box

The following tables list the members exposed by StyleSheet.

Public Constructors

 | Name | Description
Public Constructor | StyleSheet Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ICollection.
Public Property | IsFixedSize | Gets a value indicating whether the System.Collections.IList has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the System.Collections.IList is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).
Public Property | Item | Gets or sets the element at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the System.Collections.ICollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a StyleSheetRule object from the specified information.
Public Method | Clear | Removes all rules in this stylesheet.
Public Method | Contains | Determines whether the System.Collections.IList contains a specific value.
Public Method | CopyTo | Copies the elements of the System.Collections.ICollection to an System.Array, starting at a particular System.Array index.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | GetRuleByClassName | Returns the rule with the specified class name. If the rule is not in this stylesheet, Normal stylesheet will be returned as default
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.IList.
Public Method | Insert | Inserts an item to the System.Collections.IList at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the System.Collections.IList.
Public Method | RemoveAt | Removes the System.Collections.IList item at the specified index.
Public Method | RemoveRule | Removes the rule with the specified classname from this stylesheet.
Top

See Also

Reference

StyleSheet Class
DDCssLib Namespace


StyleSheet Constructor

[image]
ActiveReports 19 .NET Edition
StyleSheet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : StyleSheet Constructor

Glossary Item Box

Overload List

Overload | Description
StyleSheet Constructor() | Initializes a new instance of the StyleSheet class.
StyleSheet Constructor(Boolean) | Initializes a new instance of the StyleSheet class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Constructor()

[image]
ActiveReports 19 .NET Edition
StyleSheet Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class > StyleSheet Constructor : StyleSheet Constructor()

Glossary Item Box

Initializes a new instance of the StyleSheet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StyleSheet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


StyleSheet Constructor(Boolean)

[image]
ActiveReports 19 .NET Edition
StyleSheet Constructor(Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class > StyleSheet Constructor : StyleSheet Constructor(Boolean)

CreateDefault

Glossary Item Box

Initializes a new instance of the StyleSheet class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal CreateDefault As Boolean _
)
C#
public StyleSheet(
   bool CreateDefault
)

Parameters

CreateDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


StyleSheet Class Methods

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a StyleSheetRule object from the specified information.
Public Method | Clear | Removes all rules in this stylesheet.
Public Method | Contains | Determines whether the System.Collections.IList contains a specific value.
Public Method | CopyTo | Copies the elements of the System.Collections.ICollection to an System.Array, starting at a particular System.Array index.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | GetRuleByClassName | Returns the rule with the specified class name. If the rule is not in this stylesheet, Normal stylesheet will be returned as default
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.IList.
Public Method | Insert | Inserts an item to the System.Collections.IList at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the System.Collections.IList.
Public Method | RemoveAt | Removes the System.Collections.IList item at the specified index.
Public Method | RemoveRule | Removes the rule with the specified classname from this stylesheet.
Top

See Also

Reference

StyleSheet Class
DDCssLib Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Add Method

Glossary Item Box

Creates a StyleSheetRule object from the specified information.

Overload List

Overload | Description
Add(String,String) | Creates a StyleSheetRule object from the specified information.
Add(String,String,String) | Creates a StyleSheetRule object from the specified information.
Add(Object) | Adds an item to the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Add(String,String) Method

[image]
ActiveReports 19 .NET Edition
Add(String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class > Add Method : Add(String,String) Method

className
The ClassName to identify this stylesheet rule by.
cssText
The CSS declartaion block string that the returned StyleSheetRule object will represent.

Glossary Item Box

Creates a StyleSheetRule object from the specified information.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal className As String, _
   ByVal cssText As String _
) As StyleSheetRule
C#
public StyleSheetRule Add(
   string className,
   string cssText
)

Parameters

className
The ClassName to identify this stylesheet rule by.
cssText
The CSS declartaion block string that the returned StyleSheetRule object will represent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Add(String,String,String) Method

[image]
ActiveReports 19 .NET Edition
Add(String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class > Add Method : Add(String,String,String) Method

className
The ClassName to identify this stylesheet rule by.
cssText
The CSS declartaion block string that the returned StyleSheetRule object will represent.
parentStyle
The parent StyleSheetRule that this

Glossary Item Box

Creates a StyleSheetRule object from the specified information.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal className As String, _
   ByVal cssText As String, _
   ByVal parentStyle As String _
) As StyleSheetRule
C#
public StyleSheetRule Add(
   string className,
   string cssText,
   string parentStyle
)

Parameters

className
The ClassName to identify this stylesheet rule by.
cssText
The CSS declartaion block string that the returned StyleSheetRule object will represent.
parentStyle
The parent StyleSheetRule that this

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Add(Object) Method

[image]
ActiveReports 19 .NET Edition
Add(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class > Add Method : Add(Object) Method

value
The System.Object to add to the System.Collections.IList.

Glossary Item Box

Adds an item to the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As Object _
) As Integer
C#
public int Add(
   object value
)

Parameters

value
The System.Object to add to the System.Collections.IList.

Return Value

The position into which the new element was inserted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Clear Method

Glossary Item Box

Removes all rules in this stylesheet.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Contains Method

value
The System.Object to locate in the System.Collections.IList.

Glossary Item Box

Determines whether the System.Collections.IList contains a specific value.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
The System.Object to locate in the System.Collections.IList.

Return Value

true if the System.Object is found in the System.Collections.IList; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the elements of the System.Collections.ICollection to an System.Array, starting at a particular System.Array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


GetRuleByClassName Method

[image]
ActiveReports 19 .NET Edition
GetRuleByClassName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : GetRuleByClassName Method

className
The case insensitive class name

Glossary Item Box

Returns the rule with the specified class name. If the rule is not in this stylesheet, Normal stylesheet will be returned as default

Syntax

Visual Basic (Declaration)
Public Function GetRuleByClassName( _
   ByVal className As String _
) As StyleSheetRule
C#
public StyleSheetRule GetRuleByClassName(
   string className
)

Parameters

className
The case insensitive class name

Return Value

The stylesheet rule with the specified class name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : IndexOf Method

value
The System.Object to locate in the System.Collections.IList.

Glossary Item Box

Determines the index of a specific item in the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value
The System.Object to locate in the System.Collections.IList.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Insert Method

index
The zero-based index at which value should be inserted.
value
The System.Object to insert into the System.Collections.IList.

Glossary Item Box

Inserts an item to the System.Collections.IList at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index at which value should be inserted.
value
The System.Object to insert into the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Remove Method

value
The System.Object to remove from the System.Collections.IList.

Glossary Item Box

Removes the first occurrence of a specific object from the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
C#
public void Remove(
   object value
)

Parameters

value
The System.Object to remove from the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : RemoveAt Method

index
The zero-based index of the item to remove.

Glossary Item Box

Removes the System.Collections.IList item at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


RemoveRule Method

[image]
ActiveReports 19 .NET Edition
RemoveRule Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : RemoveRule Method

className

Glossary Item Box

Removes the rule with the specified classname from this stylesheet.

Syntax

Visual Basic (Declaration)
Public Sub RemoveRule( _
   ByVal className As String _
)
C#
public void RemoveRule(
   string className
)

Parameters

className

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ICollection.
Public Property | IsFixedSize | Gets a value indicating whether the System.Collections.IList has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the System.Collections.IList is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).
Public Property | Item | Gets or sets the element at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the System.Collections.ICollection.
Top

See Also

Reference

StyleSheet Class
DDCssLib Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IsFixedSize Property

[image]
ActiveReports 19 .NET Edition
IsFixedSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : IsFixedSize Property

Glossary Item Box

Gets a value indicating whether the System.Collections.IList has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

true if this instance is fixed size; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the System.Collections.IList is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if this instance is read only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

true if this instance is synchronized; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : Item Property

index

Glossary Item Box

Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As StyleSheetRule
C#
public StyleSheetRule this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheet Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

The synchronize root.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheetRule Class

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheetRule Class

Glossary Item Box

StyleSheetRule encapsulates the CSSDeclaration class to provide .NET compatible translations to and from the CSS styles.

Object Model

StyleSheetRule Class

Syntax

Visual Basic (Declaration)
Public Class StyleSheetRule
   Implements IStyleSheetRule
C#
public class StyleSheetRule : IStyleSheetRule

Inheritance Hierarchy

System.Object
DDCssLib.StyleSheetRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Members
DDCssLib Namespace


StyleSheetRule Class Members

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheetRule Class

Glossary Item Box

The following tables list the members exposed by StyleSheetRule.

Public Constructors

 | Name | Description
Public Constructor | StyleSheetRule Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BackColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the background-color CSS property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.
Public Property | ClassName | Gets/sets the ClassName of this StyleSheetRule. This value can be used to retrieve the stylesheet rule from it's parent stylesheet.
Public Property | CSSText | Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).
Public Property | DdCharset | Implementation of IStyleSheetRule.DdCharset. DdCharset is the charset/script for the font.
Public Property | DdVerticalFont | Gets or sets the dd vertical font CSS property.
Public Property | Declaration | Gets/sets the CSSDeclaration object used by this style.
Public Property | Font | Returns a System.Drawing.Font object from the current font related CSS style information. If a font is specified it's properties will be turned into it's CSS equivelent.
Public Property | FontFamily | Gets/sets the FontFamily value. If this StyleSheetRule's declaration does not contain the value, or the value is indicated as null, it will be returned from it's parent. When the property is set the value will only be set to this StyleSheetRule's declaration instance (not the parent's).
Public Property | FontSize | Returns font size in points.
Public Property | FontStyle | Returns the font-style declaration value. If a value cannot be found from neither this declaration, nor the parent style, then ddFontStyleTypes.Inherit will be returned to allow the caller to determine how to handle the condition.
Public Property | FontUnit | Gets or sets the font unit.
Public Property | FontWeight | Gets/sets the 'font-weight' property of the style.
Public Property | ForeColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.
Public Property | InheritsBackColor | Gets a value indicating whether current stylesheet rule inherits background color value.
Public Property | InheritsFontFamily | Gets a value indicating whether current stylesheet rule inherits font family value.
Public Property | InheritsFontSize | Gets a value indicating whether current stylesheet rule inherits font size value.
Public Property | InheritsFontStyle | Gets a value indicating whether current stylesheet rule inherits font style value.
Public Property | InheritsFontVertical | Gets a value indicating whether current stylesheet rule inherits font vertical value.
Public Property | InheritsFontWeight | Gets a value indicating whether current stylesheet rule inherits font wighth value.
Public Property | InheritsForeColor | Gets a value indicating whether current stylesheet rule inherits foreground color value.
Public Property | InheritsTextAlign | Gets a value indicating whether current stylesheet rule inherits text alignment value.
Public Property | InheritsTextDecoration | Gets a value indicating whether current stylesheet rule inherits text decoration value.
Public Property | InheritsVerticalAlign | Gets a value indicating whether current stylesheet rule inherits vertical alignment value.
Public Property | Kinsoku | Gets/sets the 'ddo-enable-kinsoku' CSS property.
Public Property | ParentStyleSheet | Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.
Public Property | ParentStyleSheetRule | Sets/Returns this instances parent StyleSheetRule.
Public Property | ShrinkToFit | When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.
Public Property | TextAlign | Gets/sets the 'text-align' CSS property.
Public Property | TextDecoration | Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked (the Inherit, nor None value should not be masked).
Public Property | TextJustify | Gets/sets 'text-justify' CSS property
Public Property | VerticalAlign | Gets/sets the 'vertical-align' CSS property.
Public Property | WhiteSpace | Gets/sets the 'white-space' CSS property.
Public Property | WrapMode | Gets/sets the 'ddo-wrap-mode' CSS property.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top

See Also

Reference

StyleSheetRule Class
DDCssLib Namespace


StyleSheetRule Constructor

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : StyleSheetRule Constructor

Glossary Item Box

Overload List

Overload | Description
StyleSheetRule Constructor() | The default constructor for StyleSheetRule. A new empty CSSDeclaration will be used, the parent StyleSheetRule and ParentStyleSheet will be null. The ClassName will be String.Empty.
StyleSheetRule Constructor(String,String,StyleSheet) | Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.
StyleSheetRule Constructor(String,String,String) | Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.
StyleSheetRule Constructor(String,String) | Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


StyleSheetRule Constructor()

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class > StyleSheetRule Constructor : StyleSheetRule Constructor()

Glossary Item Box

The default constructor for StyleSheetRule. A new empty CSSDeclaration will be used, the parent StyleSheetRule and ParentStyleSheet will be null. The ClassName will be String.Empty.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StyleSheetRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members
Overload List


StyleSheetRule Constructor(String,String,StyleSheet)

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Constructor(String,String,StyleSheet)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class > StyleSheetRule Constructor : StyleSheetRule Constructor(String,String,StyleSheet)

cssText
className
parentStyleSheet

Glossary Item Box

Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cssText As String, _
   ByVal className As String, _
   ByVal parentStyleSheet As StyleSheet _
)
C#
public StyleSheetRule(
   string cssText,
   string className,
   StyleSheet parentStyleSheet
)

Parameters

cssText
className
parentStyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members
Overload List


StyleSheetRule Constructor(String,String,String)

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Constructor(String,String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class > StyleSheetRule Constructor : StyleSheetRule Constructor(String,String,String)

cssText
className
parentStyleName

Glossary Item Box

Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cssText As String, _
   ByVal className As String, _
   ByVal parentStyleName As String _
)
C#
public StyleSheetRule(
   string cssText,
   string className,
   string parentStyleName
)

Parameters

cssText
className
parentStyleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members
Overload List


StyleSheetRule Constructor(String,String)

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Constructor(String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class > StyleSheetRule Constructor : StyleSheetRule Constructor(String,String)

cssText
className

Glossary Item Box

Creates an instance of StyleSheetRule that will use the specified ClassName, CSSText, and ParentStyleSheet.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cssText As String, _
   ByVal className As String _
)
C#
public StyleSheetRule(
   string cssText,
   string className
)

Parameters

cssText
className

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members
Overload List


StyleSheetRule Class Methods

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheetRule Class

Glossary Item Box

For a list of all members of this type, see StyleSheetRule members.

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top

See Also

Reference

StyleSheetRule Class
DDCssLib Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


StyleSheetRule Class Properties

[image]
ActiveReports 19 .NET Edition
StyleSheetRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : StyleSheetRule Class

Glossary Item Box

For a list of all members of this type, see StyleSheetRule members.

Public Properties

 | Name | Description
Public Property | BackColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the background-color CSS property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.
Public Property | ClassName | Gets/sets the ClassName of this StyleSheetRule. This value can be used to retrieve the stylesheet rule from it's parent stylesheet.
Public Property | CSSText | Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).
Public Property | DdCharset | Implementation of IStyleSheetRule.DdCharset. DdCharset is the charset/script for the font.
Public Property | DdVerticalFont | Gets or sets the dd vertical font CSS property.
Public Property | Declaration | Gets/sets the CSSDeclaration object used by this style.
Public Property | Font | Returns a System.Drawing.Font object from the current font related CSS style information. If a font is specified it's properties will be turned into it's CSS equivelent.
Public Property | FontFamily | Gets/sets the FontFamily value. If this StyleSheetRule's declaration does not contain the value, or the value is indicated as null, it will be returned from it's parent. When the property is set the value will only be set to this StyleSheetRule's declaration instance (not the parent's).
Public Property | FontSize | Returns font size in points.
Public Property | FontStyle | Returns the font-style declaration value. If a value cannot be found from neither this declaration, nor the parent style, then ddFontStyleTypes.Inherit will be returned to allow the caller to determine how to handle the condition.
Public Property | FontUnit | Gets or sets the font unit.
Public Property | FontWeight | Gets/sets the 'font-weight' property of the style.
Public Property | ForeColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.
Public Property | InheritsBackColor | Gets a value indicating whether current stylesheet rule inherits background color value.
Public Property | InheritsFontFamily | Gets a value indicating whether current stylesheet rule inherits font family value.
Public Property | InheritsFontSize | Gets a value indicating whether current stylesheet rule inherits font size value.
Public Property | InheritsFontStyle | Gets a value indicating whether current stylesheet rule inherits font style value.
Public Property | InheritsFontVertical | Gets a value indicating whether current stylesheet rule inherits font vertical value.
Public Property | InheritsFontWeight | Gets a value indicating whether current stylesheet rule inherits font wighth value.
Public Property | InheritsForeColor | Gets a value indicating whether current stylesheet rule inherits foreground color value.
Public Property | InheritsTextAlign | Gets a value indicating whether current stylesheet rule inherits text alignment value.
Public Property | InheritsTextDecoration | Gets a value indicating whether current stylesheet rule inherits text decoration value.
Public Property | InheritsVerticalAlign | Gets a value indicating whether current stylesheet rule inherits vertical alignment value.
Public Property | Kinsoku | Gets/sets the 'ddo-enable-kinsoku' CSS property.
Public Property | ParentStyleSheet | Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.
Public Property | ParentStyleSheetRule | Sets/Returns this instances parent StyleSheetRule.
Public Property | ShrinkToFit | When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.
Public Property | TextAlign | Gets/sets the 'text-align' CSS property.
Public Property | TextDecoration | Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked (the Inherit, nor None value should not be masked).
Public Property | TextJustify | Gets/sets 'text-justify' CSS property
Public Property | VerticalAlign | Gets/sets the 'vertical-align' CSS property.
Public Property | WhiteSpace | Gets/sets the 'white-space' CSS property.
Public Property | WrapMode | Gets/sets the 'ddo-wrap-mode' CSS property.
Top

See Also

Reference

StyleSheetRule Class
DDCssLib Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : BackColor Property

Glossary Item Box

When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the background-color CSS property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : ClassName Property

Glossary Item Box

Gets/sets the ClassName of this StyleSheetRule. This value can be used to retrieve the stylesheet rule from it's parent stylesheet.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


CSSText Property

[image]
ActiveReports 19 .NET Edition
CSSText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : CSSText Property

Glossary Item Box

Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).

Syntax

Visual Basic (Declaration)
Public Property CSSText As String
C#
public string CSSText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


DdCharset Property

[image]
ActiveReports 19 .NET Edition
DdCharset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : DdCharset Property

Glossary Item Box

Implementation of IStyleSheetRule.DdCharset. DdCharset is the charset/script for the font.

Syntax

Visual Basic (Declaration)
Public Property DdCharset As String
C#
public string DdCharset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


DdVerticalFont Property

[image]
ActiveReports 19 .NET Edition
DdVerticalFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : DdVerticalFont Property

Glossary Item Box

Gets or sets the dd vertical font CSS property.

Syntax

Visual Basic (Declaration)
Public Property DdVerticalFont As ddVerticalFontStyles
C#
public ddVerticalFontStyles DdVerticalFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


Declaration Property

[image]
ActiveReports 19 .NET Edition
Declaration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : Declaration Property

Glossary Item Box

Gets/sets the CSSDeclaration object used by this style.

Syntax

Visual Basic (Declaration)
Public Property Declaration As CSSDeclaration
C#
public CSSDeclaration Declaration {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : Font Property

Glossary Item Box

Returns a System.Drawing.Font object from the current font related CSS style information. If a font is specified it's properties will be turned into it's CSS equivelent.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : FontFamily Property

Glossary Item Box

Gets/sets the FontFamily value. If this StyleSheetRule's declaration does not contain the value, or the value is indicated as null, it will be returned from it's parent. When the property is set the value will only be set to this StyleSheetRule's declaration instance (not the parent's).

Syntax

Visual Basic (Declaration)
Public Property FontFamily As String
C#
public string FontFamily {get; set;}

Remarks

Multiple families seperated by commas may be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : FontSize Property

Glossary Item Box

Returns font size in points.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Single
C#
public float FontSize {get; set;}

Exceptions

Exception | Description
System.ApplicationException | Sometimes font-size is specified (in the CSS style string) in a value that cannot be converted to points. For example a size relative to the parent, and there is no parent. Or Font XHeight (the height of the letter x) where this not enough data to perform a conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : FontStyle Property

Glossary Item Box

Returns the font-style declaration value. If a value cannot be found from neither this declaration, nor the parent style, then ddFontStyleTypes.Inherit will be returned to allow the caller to determine how to handle the condition.

Syntax

Visual Basic (Declaration)
Public Property FontStyle As ddFontStyleTypes
C#
public ddFontStyleTypes FontStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


FontUnit Property

[image]
ActiveReports 19 .NET Edition
FontUnit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : FontUnit Property

Glossary Item Box

Gets or sets the font unit.

Syntax

Visual Basic (Declaration)
Public Property FontUnit As GraphicsUnit
C#
public GraphicsUnit FontUnit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : FontWeight Property

Glossary Item Box

Gets/sets the 'font-weight' property of the style.

Syntax

Visual Basic (Declaration)
Public Property FontWeight As ddFontWeightTypes
C#
public ddFontWeightTypes FontWeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : ForeColor Property

Glossary Item Box

When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsBackColor Property

[image]
ActiveReports 19 .NET Edition
InheritsBackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsBackColor Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits background color value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsBackColor As Boolean
C#
public bool InheritsBackColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsFontFamily Property

[image]
ActiveReports 19 .NET Edition
InheritsFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsFontFamily Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits font family value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsFontFamily As Boolean
C#
public bool InheritsFontFamily {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsFontSize Property

[image]
ActiveReports 19 .NET Edition
InheritsFontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsFontSize Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits font size value.

Syntax

Visual Basic (Declaration)
Public Property InheritsFontSize As Boolean
C#
public bool InheritsFontSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsFontStyle Property

[image]
ActiveReports 19 .NET Edition
InheritsFontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsFontStyle Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits font style value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsFontStyle As Boolean
C#
public bool InheritsFontStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsFontVertical Property

[image]
ActiveReports 19 .NET Edition
InheritsFontVertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsFontVertical Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits font vertical value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsFontVertical As Boolean
C#
public bool InheritsFontVertical {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsFontWeight Property

[image]
ActiveReports 19 .NET Edition
InheritsFontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsFontWeight Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits font wighth value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsFontWeight As Boolean
C#
public bool InheritsFontWeight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsForeColor Property

[image]
ActiveReports 19 .NET Edition
InheritsForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsForeColor Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits foreground color value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsForeColor As Boolean
C#
public bool InheritsForeColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsTextAlign Property

[image]
ActiveReports 19 .NET Edition
InheritsTextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsTextAlign Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits text alignment value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsTextAlign As Boolean
C#
public bool InheritsTextAlign {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsTextDecoration Property

[image]
ActiveReports 19 .NET Edition
InheritsTextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsTextDecoration Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits text decoration value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsTextDecoration As Boolean
C#
public bool InheritsTextDecoration {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


InheritsVerticalAlign Property

[image]
ActiveReports 19 .NET Edition
InheritsVerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : InheritsVerticalAlign Property

Glossary Item Box

Gets a value indicating whether current stylesheet rule inherits vertical alignment value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InheritsVerticalAlign As Boolean
C#
public bool InheritsVerticalAlign {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


Kinsoku Property

[image]
ActiveReports 19 .NET Edition
Kinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : Kinsoku Property

Glossary Item Box

Gets/sets the 'ddo-enable-kinsoku' CSS property.

Syntax

Visual Basic (Declaration)
Public Property Kinsoku As ddKinsokuTypes
C#
public ddKinsokuTypes Kinsoku {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ParentStyleSheet Property

[image]
ActiveReports 19 .NET Edition
ParentStyleSheet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : ParentStyleSheet Property

Glossary Item Box

Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.

Syntax

Visual Basic (Declaration)
Public Property ParentStyleSheet As StyleSheet
C#
public StyleSheet ParentStyleSheet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ParentStyleSheetRule Property

[image]
ActiveReports 19 .NET Edition
ParentStyleSheetRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : ParentStyleSheetRule Property

Glossary Item Box

Sets/Returns this instances parent StyleSheetRule.

Syntax

Visual Basic (Declaration)
Public Property ParentStyleSheetRule As IStyleSheetRule
C#
public IStyleSheetRule ParentStyleSheetRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : ShrinkToFit Property

Glossary Item Box

When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As ddShrinkToFitTypes
C#
public ddShrinkToFitTypes ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : TextAlign Property

Glossary Item Box

Gets/sets the 'text-align' CSS property.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As ddTextAlignTypes
C#
public ddTextAlignTypes TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


TextDecoration Property

[image]
ActiveReports 19 .NET Edition
TextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : TextDecoration Property

Glossary Item Box

Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked (the Inherit, nor None value should not be masked).

Syntax

Visual Basic (Declaration)
Public Property TextDecoration As ddTextDecorationTypes
C#
public ddTextDecorationTypes TextDecoration {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : TextJustify Property

Glossary Item Box

Gets/sets 'text-justify' CSS property

Syntax

Visual Basic (Declaration)
Public Property TextJustify As ddTextJustifyTypes
C#
public ddTextJustifyTypes TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : VerticalAlign Property

Glossary Item Box

Gets/sets the 'vertical-align' CSS property.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As ddVerticalAlignTypes
C#
public ddVerticalAlignTypes VerticalAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


WhiteSpace Property

[image]
ActiveReports 19 .NET Edition
WhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : WhiteSpace Property

Glossary Item Box

Gets/sets the 'white-space' CSS property.

Syntax

Visual Basic (Declaration)
Public Property WhiteSpace As ddWhiteSpaceTypes
C#
public ddWhiteSpaceTypes WhiteSpace {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > StyleSheetRule Class : WrapMode Property

Glossary Item Box

Gets/sets the 'ddo-wrap-mode' CSS property.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As ddWrapModeTypes
C#
public ddWrapModeTypes WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetRule Class
StyleSheetRule Members


ddFontStyleTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddFontStyleTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddFontStyleTypes Enumeration

Glossary Item Box

Enum values for the StyleSheetRule.FontStyle property.

Syntax

Visual Basic (Declaration)
Public Enum ddFontStyleTypes
   Inherits System.Enum
C#
public enum ddFontStyleTypes : System.Enum

Members

Member | Description
Inherit | Inherit
Italic | Italic
Normal | Normal
Oblique | Oblique

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddFontStyleTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddFontWeightTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddFontWeightTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddFontWeightTypes Enumeration

Glossary Item Box

Possible values for the StyleSheetRule.FontWeight property.

Syntax

Visual Basic (Declaration)
Public Enum ddFontWeightTypes
   Inherits System.Enum
C#
public enum ddFontWeightTypes : System.Enum

Members

Member | Description
Bold | Bold
Bolder | Bolder
dd100 | DD100
dd200 | DD200
dd300 | DD300
dd400 | DD400
dd500 | DD500
dd600 | DD600
dd700 | DD700
dd800 | DD800
dd900 | DD900
Inherit | Inherit
Lighter | Lighter
Normal | Normal

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddFontWeightTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddKinsokuTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddKinsokuTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddKinsokuTypes Enumeration

Glossary Item Box

Enum ddKinsokuTypes

Syntax

Visual Basic (Declaration)
Public Enum ddKinsokuTypes
   Inherits System.Enum
C#
public enum ddKinsokuTypes : System.Enum

Members

Member | Description
Auto | Automatic
None | None
True | True

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddKinsokuTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddShrinkToFitTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddShrinkToFitTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddShrinkToFitTypes Enumeration

Glossary Item Box

Enum ddShrinkToFitTypes

Syntax

Visual Basic (Declaration)
Public Enum ddShrinkToFitTypes
   Inherits System.Enum
C#
public enum ddShrinkToFitTypes : System.Enum

Members

Member | Description
None | None
True | True

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddShrinkToFitTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddTextAlignTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddTextAlignTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddTextAlignTypes Enumeration

Glossary Item Box

Enum values for the StyleSheetRule.TextAlign property.

Syntax

Visual Basic (Declaration)
Public Enum ddTextAlignTypes
   Inherits System.Enum
C#
public enum ddTextAlignTypes : System.Enum

Members

Member | Description
Center | Center
Inherit | Inherit
Justify | Justify
Left | Left
Right | Right

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddTextAlignTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddTextDecorationTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddTextDecorationTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddTextDecorationTypes Enumeration

Glossary Item Box

Possible values for the StyleSheetRule.TextDecoration property.

Syntax

Visual Basic (Declaration)
Public Enum ddTextDecorationTypes
   Inherits System.Enum
C#
public enum ddTextDecorationTypes : System.Enum

Members

Member | Description
Blink | Blink
Blink_Linethrough | Blink linethrough
Blink_Linethrough_Overline | Blink linethrough overline
Blink_Linethrough_Underline | Blink linethrough underline
Blink_Overline | Blink overline
Blink_Overline_Linethrough | Blink overline linethrough
Blink_Overline_Linethrough_Underline | Blink overline linethrough underline
Blink_Overline_Underline | Blink overline underline
Blink_Underline | Blink underline
Inherit | Inherit
Linethrough | Linethrough
Linethrough_Overline | Linethrough overline
Linethrough_Overline_Underline | Linethrough overline underline
Linethrough_Underline | Linethrough underline
None | None
Overline | Overline
Overline_Underline | Overline underline
Underline | Underline

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddTextDecorationTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddTextJustifyTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddTextJustifyTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddTextJustifyTypes Enumeration

Glossary Item Box

Enum values for the StyleSheetRule.TextJustify property.

Syntax

Visual Basic (Declaration)
Public Enum ddTextJustifyTypes
   Inherits System.Enum
C#
public enum ddTextJustifyTypes : System.Enum

Members

Member | Description
Auto | Automatic
Distribute | Distribute
Distribute_all_lines | Distribute_all_lines
Inter_ideograph | Inter_ideograph
Inter_word | Inter_word
Newspaper | Newspaper

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddTextJustifyTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddVerticalAlignTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddVerticalAlignTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddVerticalAlignTypes Enumeration

Glossary Item Box

Enum values for the StyleSheetRule.VerticalAlign property.

Syntax

Visual Basic (Declaration)
Public Enum ddVerticalAlignTypes
   Inherits System.Enum
C#
public enum ddVerticalAlignTypes : System.Enum

Members

Member | Description
BaseLine | Base line
Bottom | Bottom
Inherit | Inherit
Middle | Middle
Sub | Sub
Super | Super
TextBottom | Text bottom
TextTop | Text top
Top | Top

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddVerticalAlignTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddVerticalFontStyles Enumeration

[image]
ActiveReports 19 .NET Edition
ddVerticalFontStyles Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddVerticalFontStyles Enumeration

Glossary Item Box

Enum ddVerticalFontStyles

Syntax

Visual Basic (Declaration)
Public Enum ddVerticalFontStyles
   Inherits System.Enum
C#
public enum ddVerticalFontStyles : System.Enum

Members

Member | Description
Inherit | Inherit
None | None
True | True

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddVerticalFontStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddWhiteSpaceTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddWhiteSpaceTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddWhiteSpaceTypes Enumeration

Glossary Item Box

Enum ddWhiteSpaceTypes

Syntax

Visual Basic (Declaration)
Public Enum ddWhiteSpaceTypes
   Inherits System.Enum
C#
public enum ddWhiteSpaceTypes : System.Enum

Members

Member | Description
Inherit | Inherit
Normal | Normal
NoWrap | No wrap
Pre | Pre

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddWhiteSpaceTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


ddWrapModeTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ddWrapModeTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : ddWrapModeTypes Enumeration

Glossary Item Box

Enum ddWrapModeTypes

Syntax

Visual Basic (Declaration)
Public Enum ddWrapModeTypes
   Inherits System.Enum
C#
public enum ddWrapModeTypes : System.Enum

Members

Member | Description
CharWrap | Character wrap
Inherit | Inherit
NoWrap | No wrap
WordWrap | Word wrap

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.ddWrapModeTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


eCSSProperty Enumeration

[image]
ActiveReports 19 .NET Edition
eCSSProperty Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : eCSSProperty Enumeration

Glossary Item Box

An enum of CSS property name numeric identifiers.

Syntax

Visual Basic (Declaration)
Public Enum eCSSProperty
   Inherits System.Enum
C#
public enum eCSSProperty : System.Enum

Members

Member | Description
Azimuth | Azimuth
Background | Background
Background_attachment | Background attachment
Background_color | Background color
Background_image | Background image
Background_position | Background position
Background_repeat | Background repeat
Background_x_position | Background x position
Background_y_position | Background y position
Behavior | Behavior
Border | Border
Border_bottom | Border bottom
Border_bottom_color | Border bottom color
Border_bottom_style | Border bottom style
Border_bottom_width | Border bottom width
Border_collapse | Border collapse
Border_color | Border color
Border_left | Border left
Border_left_color | Border left color
Border_left_style | Border left style
Border_left_width | Border left width
border_radius | Border radius
border_radius_bottomLeft | Border radius bottom left
border_radius_bottomRight | Border radius bottom right
border_radius_topLeft | Border radius top left
border_radius_topRight | Border radius top right
Border_right | Border right
Border_right_color | Border right color
Border_right_style | Border right style
Border_right_width | Border right width
Border_spacing | Border spacing
Border_style | Border style
Border_top | Border top
Border_top_color | Border top color
Border_top_style | Border top style
Border_top_width | Border top width
Border_width | Border width
Border_x_spacing | Border x spacing
Border_y_spacing | Border y spacing
Bottom | Bottom
Box_sizing | Box sizing
Caption_side | Caption side
Clear | Clear
Clip | Clip
Clip_bottom | Clip bottom
Clip_left | Clip left
Clip_right | Clip right
Clip_top | Clip top
Color | Color
Content | Content
Count | Count
Counter_increment | Counter increment
Counter_reset | Counter reset
Cue | Cue
Cue_after | Cue after
Cue_before | Cue before
Cursor | Cursor
Ddo_can_grow | Ddo can grow
Ddo_can_shrink | Ddo can shrink
Ddo_char_set | Ddo char set
Ddo_font_vertical | Ddo font vertical
Ddo_line_color | Ddo line color
Ddo_line_style | Ddo line style
Ddo_line_weight | Ddo line weight
Ddo_multi_line | Ddo multi line
Direction | Direction
Display | Display
Elevation | Elevation
Empty_cells | Empty cells
Float | Float
Float_edge | Float edge
Font | Font
Font_family | Font family
Font_size | Font size
Font_size_adjust | Font size adjust
Font_stretch | Font stretch
Font_style | Font style
Font_variant | Font variant
Font_weight | Font weight
Height | Height
Key_equivalent | Key equivalent
Left | Left
Letter_spacing | Letter spacing
Line_height | Line height
List_style | List style
List_style_image | List style image
List_style_position | List style position
List_style_type | List style type
Margin | Margin
Margin_bottom | Margin bottom
Margin_left | Margin left
Margin_right | Margin right
Margin_top | Margin top
Marker_offset | Marker offset
Marks | Marks
Max_height | Max height
Max_width | Max width
Min_height | Min height
Min_width | Min width
Opacity | Opacity
Orphans | Orphans
Outline | Outline
Outline_color | Outline color
outline_radius | Outline radius
outline_radius_bottomLeft | Outline radius bottom left
outline_radius_bottomRight | Outline radius bottom right
outline_radius_topLeft | Outline radius top left
outline_radius_topRight | Outline radius top right
Outline_style | Outline style
Outline_width | Outline width
Overflow | Overflow
Padding | Padding
Padding_bottom | Padding bottom
Padding_left | Padding left
Padding_right | Padding right
Padding_top | Padding top
Page | Page
Page_break_after | Page break after
Page_break_before | Page break before
Page_break_inside | Page break inside
Pause | Pause
Pause_after | Pause after
Pause_before | Pause before
Pitch | Pitch
Pitch_range | Pitch range
Play_during | Play during
Play_during_flags | Play during flags
Position | Position
Quotes | Quotes
Quotes_close | Quotes close
Quotes_open | Quotes open
Resizer | Resizer
Richness | Richness
Right | Right
Size | Size
Size_height | Size height
Size_width | Size width
Speak | Speak
Speak_header | Speak header
Speak_numeral | Speak numeral
Speak_punctuation | Speak punctuation
Speech_rate | Speech rate
Stress | Stress
Table_layout | Table layout
Text_align | Text align
Text_decoration | Text decoration
Text_enable_kinsoku | Text enable kinsoku
Text_indent | Text indent
Text_justify | Text justify
Text_shadow | Text shadow
Text_shadow_color | Text shadow color
Text_shadow_radius | Text shadow radius
Text_shadow_x | Text shadow x
Text_shadow_y | Text shadow y
Text_shrink_to_fit | Text shrink to fit
Text_transform | Text transform
Text_wrap_mode | Text wrap mode
Top | Top
Unicode_bidi | Unicode bidi
Unknown | Unknown
User_focus | User focus
User_input | User input
User_modify | User modify
User_select | User select
Vertical_align | Vertical align
Visibility | Visibility
Voice_family | Voice family
Volume | Volume
White_space | White space
Widows | Widows
Width | Width
Word_spacing | Word spacing
Z_index | Z index

Remarks

The values of the eCSSProperty enum can be used as indexes to the s_kCSSRawProperties array to return the coorisponding property name as a string.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.eCSSProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


eCSSUnit Enumeration

[image]
ActiveReports 19 .NET Edition
eCSSUnit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : eCSSUnit Enumeration

Glossary Item Box

The available types of CSSUnits.

Syntax

Visual Basic (Declaration)
Public Enum eCSSUnit
   Inherits System.Enum
C#
public enum eCSSUnit : System.Enum

Members

Member | Description
Attr |
Auto |
CapHeight |
Centimeter |
Char |
Cicero |
Color_Hex |
Color_Name |
Color_RGBFunc |
Color_System |
Counter |
Counters |
Degree |
Didot |
EM |
EN |
Enumerated |
Foot |
Grad |
Hertz |
Inch |
Inherit |
Integer |
Kilohertz |
Kilometer |
Meter |
Mile |
Millimeter |
Milliseconds |
None |
Normal |
Null |
Number |
Percent |
Pica |
Pixel |
Point |
Radian |
Seconds |
String |
URL |
XHeight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
DDCssLib.eCSSUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCssLib Namespace


CSSAural Structure

[image]
ActiveReports 19 .NET Edition
CSSAural Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSAural Structure

Glossary Item Box

Struct CSSAural

Object Model

CSSAural Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSAural
   Inherits System.ValueType
C#
public struct CSSAural : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSAural

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Members
DDCssLib Namespace


CSSAural Structure Members

[image]
ActiveReports 19 .NET Edition
CSSAural Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSAural Structure

Glossary Item Box

The following tables list the members exposed by CSSAural.

Public Constructors

 | Name | Description
Public Constructor | CSSAural Constructor | Initializes a new instance of the CSSAural struct.
Top

Public Fields

 | Name | Description
Public Field | m_vAzimuth | Azimuth
Public Field | m_vCueAfter | Cue after
Public Field | m_vCueBefore | Cue before
Public Field | m_vElevation | Elevation
Public Field | m_vPauseAfter | Pause after
Public Field | m_vPauseBefore | Pause before
Public Field | m_vPitch | Pitch
Public Field | m_vPitchRange | Pitch range
Public Field | m_vPlayDuring | Play during
Public Field | m_vPlayDuringFlags | Play during flags
Public Field | m_vRichness | Richness
Public Field | m_vSpeak | Speak
Public Field | m_vSpeakHeader | Speak header
Public Field | m_vSpeakNumeral | Speak numeral
Public Field | m_vSpeakPunctuation | Speak punctuation
Public Field | m_vSpeechRate | Speech rate
Public Field | m_vStress | Stress
Public Field | m_vVoiceFamily | Voice family
Public Field | m_vVolume | Volume
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSAural Structure
DDCssLib Namespace


CSSAural Constructor

[image]
ActiveReports 19 .NET Edition
CSSAural Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : CSSAural Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSAural struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSAural _
)
C#
public CSSAural(
   CSSAural aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


CSSAural Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSAural Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSAural Structure

Glossary Item Box

For a list of all members of this type, see CSSAural members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSAural Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


CSSAural Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSAural Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSAural Structure

Glossary Item Box

For a list of all members of this type, see CSSAural members.

Public Fields

 | Name | Description
Public Field | m_vAzimuth | Azimuth
Public Field | m_vCueAfter | Cue after
Public Field | m_vCueBefore | Cue before
Public Field | m_vElevation | Elevation
Public Field | m_vPauseAfter | Pause after
Public Field | m_vPauseBefore | Pause before
Public Field | m_vPitch | Pitch
Public Field | m_vPitchRange | Pitch range
Public Field | m_vPlayDuring | Play during
Public Field | m_vPlayDuringFlags | Play during flags
Public Field | m_vRichness | Richness
Public Field | m_vSpeak | Speak
Public Field | m_vSpeakHeader | Speak header
Public Field | m_vSpeakNumeral | Speak numeral
Public Field | m_vSpeakPunctuation | Speak punctuation
Public Field | m_vSpeechRate | Speech rate
Public Field | m_vStress | Stress
Public Field | m_vVoiceFamily | Voice family
Public Field | m_vVolume | Volume
Top

See Also

Reference

CSSAural Structure
DDCssLib Namespace


m_vAzimuth Field

[image]
ActiveReports 19 .NET Edition
m_vAzimuth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vAzimuth Field

Glossary Item Box

Azimuth

Syntax

Visual Basic (Declaration)
Public m_vAzimuth As CSSValue
C#
public CSSValue m_vAzimuth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vCueAfter Field

[image]
ActiveReports 19 .NET Edition
m_vCueAfter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vCueAfter Field

Glossary Item Box

Cue after

Syntax

Visual Basic (Declaration)
Public m_vCueAfter As CSSValue
C#
public CSSValue m_vCueAfter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vCueBefore Field

[image]
ActiveReports 19 .NET Edition
m_vCueBefore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vCueBefore Field

Glossary Item Box

Cue before

Syntax

Visual Basic (Declaration)
Public m_vCueBefore As CSSValue
C#
public CSSValue m_vCueBefore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vElevation Field

[image]
ActiveReports 19 .NET Edition
m_vElevation Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vElevation Field

Glossary Item Box

Elevation

Syntax

Visual Basic (Declaration)
Public m_vElevation As CSSValue
C#
public CSSValue m_vElevation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPauseAfter Field

[image]
ActiveReports 19 .NET Edition
m_vPauseAfter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPauseAfter Field

Glossary Item Box

Pause after

Syntax

Visual Basic (Declaration)
Public m_vPauseAfter As CSSValue
C#
public CSSValue m_vPauseAfter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPauseBefore Field

[image]
ActiveReports 19 .NET Edition
m_vPauseBefore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPauseBefore Field

Glossary Item Box

Pause before

Syntax

Visual Basic (Declaration)
Public m_vPauseBefore As CSSValue
C#
public CSSValue m_vPauseBefore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPitch Field

[image]
ActiveReports 19 .NET Edition
m_vPitch Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPitch Field

Glossary Item Box

Pitch

Syntax

Visual Basic (Declaration)
Public m_vPitch As CSSValue
C#
public CSSValue m_vPitch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPitchRange Field

[image]
ActiveReports 19 .NET Edition
m_vPitchRange Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPitchRange Field

Glossary Item Box

Pitch range

Syntax

Visual Basic (Declaration)
Public m_vPitchRange As CSSValue
C#
public CSSValue m_vPitchRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPlayDuring Field

[image]
ActiveReports 19 .NET Edition
m_vPlayDuring Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPlayDuring Field

Glossary Item Box

Play during

Syntax

Visual Basic (Declaration)
Public m_vPlayDuring As CSSValue
C#
public CSSValue m_vPlayDuring

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vPlayDuringFlags Field

[image]
ActiveReports 19 .NET Edition
m_vPlayDuringFlags Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vPlayDuringFlags Field

Glossary Item Box

Play during flags

Syntax

Visual Basic (Declaration)
Public m_vPlayDuringFlags As CSSValue
C#
public CSSValue m_vPlayDuringFlags

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vRichness Field

[image]
ActiveReports 19 .NET Edition
m_vRichness Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vRichness Field

Glossary Item Box

Richness

Syntax

Visual Basic (Declaration)
Public m_vRichness As CSSValue
C#
public CSSValue m_vRichness

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vSpeak Field

[image]
ActiveReports 19 .NET Edition
m_vSpeak Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vSpeak Field

Glossary Item Box

Speak

Syntax

Visual Basic (Declaration)
Public m_vSpeak As CSSValue
C#
public CSSValue m_vSpeak

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vSpeakHeader Field

[image]
ActiveReports 19 .NET Edition
m_vSpeakHeader Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vSpeakHeader Field

Glossary Item Box

Speak header

Syntax

Visual Basic (Declaration)
Public m_vSpeakHeader As CSSValue
C#
public CSSValue m_vSpeakHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vSpeakNumeral Field

[image]
ActiveReports 19 .NET Edition
m_vSpeakNumeral Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vSpeakNumeral Field

Glossary Item Box

Speak numeral

Syntax

Visual Basic (Declaration)
Public m_vSpeakNumeral As CSSValue
C#
public CSSValue m_vSpeakNumeral

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vSpeakPunctuation Field

[image]
ActiveReports 19 .NET Edition
m_vSpeakPunctuation Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vSpeakPunctuation Field

Glossary Item Box

Speak punctuation

Syntax

Visual Basic (Declaration)
Public m_vSpeakPunctuation As CSSValue
C#
public CSSValue m_vSpeakPunctuation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vSpeechRate Field

[image]
ActiveReports 19 .NET Edition
m_vSpeechRate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vSpeechRate Field

Glossary Item Box

Speech rate

Syntax

Visual Basic (Declaration)
Public m_vSpeechRate As CSSValue
C#
public CSSValue m_vSpeechRate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vStress Field

[image]
ActiveReports 19 .NET Edition
m_vStress Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vStress Field

Glossary Item Box

Stress

Syntax

Visual Basic (Declaration)
Public m_vStress As CSSValue
C#
public CSSValue m_vStress

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vVoiceFamily Field

[image]
ActiveReports 19 .NET Edition
m_vVoiceFamily Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vVoiceFamily Field

Glossary Item Box

Voice family

Syntax

Visual Basic (Declaration)
Public m_vVoiceFamily As CSSValue
C#
public CSSValue m_vVoiceFamily

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


m_vVolume Field

[image]
ActiveReports 19 .NET Edition
m_vVolume Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSAural Structure : m_vVolume Field

Glossary Item Box

Volume

Syntax

Visual Basic (Declaration)
Public m_vVolume As CSSValue
C#
public CSSValue m_vVolume

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSAural Structure
CSSAural Members


CSSBreaks Structure

[image]
ActiveReports 19 .NET Edition
CSSBreaks Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSBreaks Structure

Glossary Item Box

Struct CSSBreaks

Object Model

CSSBreaks Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSBreaks
   Inherits System.ValueType
C#
public struct CSSBreaks : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSBreaks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Members
DDCssLib Namespace


CSSBreaks Structure Members

[image]
ActiveReports 19 .NET Edition
CSSBreaks Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSBreaks Structure

Glossary Item Box

The following tables list the members exposed by CSSBreaks.

Public Constructors

 | Name | Description
Public Constructor | CSSBreaks Constructor | Initializes a new instance of the CSSBreaks struct.
Top

Public Fields

 | Name | Description
Public Field | m_vOrphans | Orphans
Public Field | m_vPage | Page
Public Field | m_vPageBreakAfter | Page break after
Public Field | m_vPageBreakBefore | Page break before
Public Field | m_vPageBreakInside | Page break inside
Public Field | m_vWidows | Widows
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSBreaks Structure
DDCssLib Namespace


CSSBreaks Constructor

[image]
ActiveReports 19 .NET Edition
CSSBreaks Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : CSSBreaks Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSBreaks struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSBreaks _
)
C#
public CSSBreaks(
   CSSBreaks aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


CSSBreaks Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSBreaks Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSBreaks Structure

Glossary Item Box

For a list of all members of this type, see CSSBreaks members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSBreaks Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


CSSBreaks Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSBreaks Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSBreaks Structure

Glossary Item Box

For a list of all members of this type, see CSSBreaks members.

Public Fields

 | Name | Description
Public Field | m_vOrphans | Orphans
Public Field | m_vPage | Page
Public Field | m_vPageBreakAfter | Page break after
Public Field | m_vPageBreakBefore | Page break before
Public Field | m_vPageBreakInside | Page break inside
Public Field | m_vWidows | Widows
Top

See Also

Reference

CSSBreaks Structure
DDCssLib Namespace


m_vOrphans Field

[image]
ActiveReports 19 .NET Edition
m_vOrphans Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vOrphans Field

Glossary Item Box

Orphans

Syntax

Visual Basic (Declaration)
Public m_vOrphans As CSSValue
C#
public CSSValue m_vOrphans

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


m_vPage Field

[image]
ActiveReports 19 .NET Edition
m_vPage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vPage Field

Glossary Item Box

Page

Syntax

Visual Basic (Declaration)
Public m_vPage As CSSValue
C#
public CSSValue m_vPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


m_vPageBreakAfter Field

[image]
ActiveReports 19 .NET Edition
m_vPageBreakAfter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vPageBreakAfter Field

Glossary Item Box

Page break after

Syntax

Visual Basic (Declaration)
Public m_vPageBreakAfter As CSSValue
C#
public CSSValue m_vPageBreakAfter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


m_vPageBreakBefore Field

[image]
ActiveReports 19 .NET Edition
m_vPageBreakBefore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vPageBreakBefore Field

Glossary Item Box

Page break before

Syntax

Visual Basic (Declaration)
Public m_vPageBreakBefore As CSSValue
C#
public CSSValue m_vPageBreakBefore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


m_vPageBreakInside Field

[image]
ActiveReports 19 .NET Edition
m_vPageBreakInside Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vPageBreakInside Field

Glossary Item Box

Page break inside

Syntax

Visual Basic (Declaration)
Public m_vPageBreakInside As CSSValue
C#
public CSSValue m_vPageBreakInside

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


m_vWidows Field

[image]
ActiveReports 19 .NET Edition
m_vWidows Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSBreaks Structure : m_vWidows Field

Glossary Item Box

Widows

Syntax

Visual Basic (Declaration)
Public m_vWidows As CSSValue
C#
public CSSValue m_vWidows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSBreaks Structure
CSSBreaks Members


CSSColor Structure

[image]
ActiveReports 19 .NET Edition
CSSColor Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSColor Structure

Glossary Item Box

Struct CSSColor

Object Model

CSSColor Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSColor
   Inherits System.ValueType
C#
public struct CSSColor : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Members
DDCssLib Namespace


CSSColor Structure Members

[image]
ActiveReports 19 .NET Edition
CSSColor Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSColor Structure

Glossary Item Box

The following tables list the members exposed by CSSColor.

Public Constructors

 | Name | Description
Public Constructor | CSSColor Constructor | Initializes a new instance of the CSSColor struct.
Top

Public Fields

 | Name | Description
Public Field | m_vBackAttachment | Back attachment
Public Field | m_vBackColor | Back color
Public Field | m_vBackImage | Back image
Public Field | m_vBackPositionX | Back position x
Public Field | m_vBackPositionY | Back position y
Public Field | m_vBackRepeat | Back repeat
Public Field | m_vBackStyle | Back style
Public Field | m_vColor | Color
Public Field | m_vlCursor | Cursor
Public Field | m_vOpacity | Opacity
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSColor Structure
DDCssLib Namespace


CSSColor Constructor

[image]
ActiveReports 19 .NET Edition
CSSColor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : CSSColor Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSColor struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSColor _
)
C#
public CSSColor(
   CSSColor aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


CSSColor Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSColor Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSColor Structure

Glossary Item Box

For a list of all members of this type, see CSSColor members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSColor Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


CSSColor Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSColor Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSColor Structure

Glossary Item Box

For a list of all members of this type, see CSSColor members.

Public Fields

 | Name | Description
Public Field | m_vBackAttachment | Back attachment
Public Field | m_vBackColor | Back color
Public Field | m_vBackImage | Back image
Public Field | m_vBackPositionX | Back position x
Public Field | m_vBackPositionY | Back position y
Public Field | m_vBackRepeat | Back repeat
Public Field | m_vBackStyle | Back style
Public Field | m_vColor | Color
Public Field | m_vlCursor | Cursor
Public Field | m_vOpacity | Opacity
Top

See Also

Reference

CSSColor Structure
DDCssLib Namespace


m_vBackAttachment Field

[image]
ActiveReports 19 .NET Edition
m_vBackAttachment Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackAttachment Field

Glossary Item Box

Back attachment

Syntax

Visual Basic (Declaration)
Public m_vBackAttachment As CSSValue
C#
public CSSValue m_vBackAttachment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackColor Field

[image]
ActiveReports 19 .NET Edition
m_vBackColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackColor Field

Glossary Item Box

Back color

Syntax

Visual Basic (Declaration)
Public m_vBackColor As CSSValue
C#
public CSSValue m_vBackColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackImage Field

[image]
ActiveReports 19 .NET Edition
m_vBackImage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackImage Field

Glossary Item Box

Back image

Syntax

Visual Basic (Declaration)
Public m_vBackImage As CSSValue
C#
public CSSValue m_vBackImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackPositionX Field

[image]
ActiveReports 19 .NET Edition
m_vBackPositionX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackPositionX Field

Glossary Item Box

Back position x

Syntax

Visual Basic (Declaration)
Public m_vBackPositionX As CSSValue
C#
public CSSValue m_vBackPositionX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackPositionY Field

[image]
ActiveReports 19 .NET Edition
m_vBackPositionY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackPositionY Field

Glossary Item Box

Back position y

Syntax

Visual Basic (Declaration)
Public m_vBackPositionY As CSSValue
C#
public CSSValue m_vBackPositionY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackRepeat Field

[image]
ActiveReports 19 .NET Edition
m_vBackRepeat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackRepeat Field

Glossary Item Box

Back repeat

Syntax

Visual Basic (Declaration)
Public m_vBackRepeat As CSSValue
C#
public CSSValue m_vBackRepeat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vBackStyle Field

[image]
ActiveReports 19 .NET Edition
m_vBackStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vBackStyle Field

Glossary Item Box

Back style

Syntax

Visual Basic (Declaration)
Public m_vBackStyle As CSSValue
C#
public CSSValue m_vBackStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vColor Field

[image]
ActiveReports 19 .NET Edition
m_vColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vColor Field

Glossary Item Box

Color

Syntax

Visual Basic (Declaration)
Public m_vColor As CSSValue
C#
public CSSValue m_vColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vlCursor Field

[image]
ActiveReports 19 .NET Edition
m_vlCursor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vlCursor Field

Glossary Item Box

Cursor

Syntax

Visual Basic (Declaration)
Public m_vlCursor As CSSValueList
C#
public CSSValueList m_vlCursor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


m_vOpacity Field

[image]
ActiveReports 19 .NET Edition
m_vOpacity Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSColor Structure : m_vOpacity Field

Glossary Item Box

Opacity

Syntax

Visual Basic (Declaration)
Public m_vOpacity As CSSValue
C#
public CSSValue m_vOpacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSColor Structure
CSSColor Members


CSSContent Structure

[image]
ActiveReports 19 .NET Edition
CSSContent Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSContent Structure

Glossary Item Box

Struct CSSContent

Object Model

CSSContent Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSContent
   Inherits System.ValueType
C#
public struct CSSContent : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Members
DDCssLib Namespace


CSSContent Structure Members

[image]
ActiveReports 19 .NET Edition
CSSContent Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSContent Structure

Glossary Item Box

The following tables list the members exposed by CSSContent.

Public Constructors

 | Name | Description
Public Constructor | CSSContent Constructor | Initializes a new instance of the CSSContent struct.
Top

Public Fields

 | Name | Description
Public Field | m_cdCounterIncrement | Counter increment
Public Field | m_cdCounterReset | Counter reset
Public Field | m_Quotes | Quotes
Public Field | m_vlContent | Content
Public Field | m_vMarkerOffset | Marker offset
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSContent Structure
DDCssLib Namespace


CSSContent Constructor

[image]
ActiveReports 19 .NET Edition
CSSContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : CSSContent Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSContent struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSContent _
)
C#
public CSSContent(
   CSSContent aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


CSSContent Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSContent Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSContent Structure

Glossary Item Box

For a list of all members of this type, see CSSContent members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSContent Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


CSSContent Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSContent Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSContent Structure

Glossary Item Box

For a list of all members of this type, see CSSContent members.

Public Fields

 | Name | Description
Public Field | m_cdCounterIncrement | Counter increment
Public Field | m_cdCounterReset | Counter reset
Public Field | m_Quotes | Quotes
Public Field | m_vlContent | Content
Public Field | m_vMarkerOffset | Marker offset
Top

See Also

Reference

CSSContent Structure
DDCssLib Namespace


m_cdCounterIncrement Field

[image]
ActiveReports 19 .NET Edition
m_cdCounterIncrement Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : m_cdCounterIncrement Field

Glossary Item Box

Counter increment

Syntax

Visual Basic (Declaration)
Public m_cdCounterIncrement As CSSCounterData
C#
public CSSCounterData m_cdCounterIncrement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


m_cdCounterReset Field

[image]
ActiveReports 19 .NET Edition
m_cdCounterReset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : m_cdCounterReset Field

Glossary Item Box

Counter reset

Syntax

Visual Basic (Declaration)
Public m_cdCounterReset As CSSCounterData
C#
public CSSCounterData m_cdCounterReset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


m_Quotes Field

[image]
ActiveReports 19 .NET Edition
m_Quotes Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : m_Quotes Field

Glossary Item Box

Quotes

Syntax

Visual Basic (Declaration)
Public m_Quotes As CSSQuotes
C#
public CSSQuotes m_Quotes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


m_vlContent Field

[image]
ActiveReports 19 .NET Edition
m_vlContent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : m_vlContent Field

Glossary Item Box

Content

Syntax

Visual Basic (Declaration)
Public m_vlContent As CSSValueList
C#
public CSSValueList m_vlContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


m_vMarkerOffset Field

[image]
ActiveReports 19 .NET Edition
m_vMarkerOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSContent Structure : m_vMarkerOffset Field

Glossary Item Box

Marker offset

Syntax

Visual Basic (Declaration)
Public m_vMarkerOffset As CSSValue
C#
public CSSValue m_vMarkerOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSContent Structure
CSSContent Members


CSSCounterData Structure

[image]
ActiveReports 19 .NET Edition
CSSCounterData Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSCounterData Structure

Glossary Item Box

Struct CSSCounterData

Object Model

CSSCounterData Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSCounterData
   Inherits System.ValueType
C#
public struct CSSCounterData : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSCounterData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Members
DDCssLib Namespace


CSSCounterData Structure Members

[image]
ActiveReports 19 .NET Edition
CSSCounterData Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSCounterData Structure

Glossary Item Box

The following tables list the members exposed by CSSCounterData.

Public Constructors

 | Name | Description
Public Constructor | CSSCounterData Constructor | Initializes a new instance of the CSSCounterData struct.
Top

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vCounter | Counter
Public Field | m_vValue | Value
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSCounterData Structure
DDCssLib Namespace


CSSCounterData Constructor

[image]
ActiveReports 19 .NET Edition
CSSCounterData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSCounterData Structure : CSSCounterData Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSCounterData struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSCounterData _
)
C#
public CSSCounterData(
   CSSCounterData aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Structure
CSSCounterData Members


CSSCounterData Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSCounterData Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSCounterData Structure

Glossary Item Box

For a list of all members of this type, see CSSCounterData members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSCounterData Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSCounterData Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Structure
CSSCounterData Members


CSSCounterData Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSCounterData Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSCounterData Structure

Glossary Item Box

For a list of all members of this type, see CSSCounterData members.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vCounter | Counter
Public Field | m_vValue | Value
Top

See Also

Reference

CSSCounterData Structure
DDCssLib Namespace


m_oNext Field

[image]
ActiveReports 19 .NET Edition
m_oNext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSCounterData Structure : m_oNext Field

Glossary Item Box

Next

Syntax

Visual Basic (Declaration)
Public m_oNext As Object
C#
public object m_oNext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Structure
CSSCounterData Members


m_vCounter Field

[image]
ActiveReports 19 .NET Edition
m_vCounter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSCounterData Structure : m_vCounter Field

Glossary Item Box

Counter

Syntax

Visual Basic (Declaration)
Public m_vCounter As CSSValue
C#
public CSSValue m_vCounter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Structure
CSSCounterData Members


m_vValue Field

[image]
ActiveReports 19 .NET Edition
m_vValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSCounterData Structure : m_vValue Field

Glossary Item Box

Value

Syntax

Visual Basic (Declaration)
Public m_vValue As CSSValue
C#
public CSSValue m_vValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSCounterData Structure
CSSCounterData Members


CSSDisplay Structure

[image]
ActiveReports 19 .NET Edition
CSSDisplay Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDisplay Structure

Glossary Item Box

Struct CSSDisplay

Object Model

CSSDisplay Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSDisplay
   Inherits System.ValueType
C#
public struct CSSDisplay : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSDisplay

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Members
DDCssLib Namespace


CSSDisplay Structure Members

[image]
ActiveReports 19 .NET Edition
CSSDisplay Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDisplay Structure

Glossary Item Box

The following tables list the members exposed by CSSDisplay.

Public Constructors

 | Name | Description
Public Constructor | CSSDisplay Constructor | Initializes a new instance of the CSSDisplay struct.
Top

Public Fields

 | Name | Description
Public Field | m_rcClip | Clip
Public Field | m_vClear | Clear
Public Field | m_vDirection | Direction
Public Field | m_vDisplay | Display
Public Field | m_vFloat | Float
Public Field | m_vOverflow | Overflow
Public Field | m_vVisibility | Visibility
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSDisplay Structure
DDCssLib Namespace


CSSDisplay Constructor

[image]
ActiveReports 19 .NET Edition
CSSDisplay Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : CSSDisplay Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSDisplay struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSDisplay _
)
C#
public CSSDisplay(
   CSSDisplay aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


CSSDisplay Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSDisplay Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDisplay Structure

Glossary Item Box

For a list of all members of this type, see CSSDisplay members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSDisplay Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


CSSDisplay Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSDisplay Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSDisplay Structure

Glossary Item Box

For a list of all members of this type, see CSSDisplay members.

Public Fields

 | Name | Description
Public Field | m_rcClip | Clip
Public Field | m_vClear | Clear
Public Field | m_vDirection | Direction
Public Field | m_vDisplay | Display
Public Field | m_vFloat | Float
Public Field | m_vOverflow | Overflow
Public Field | m_vVisibility | Visibility
Top

See Also

Reference

CSSDisplay Structure
DDCssLib Namespace


m_rcClip Field

[image]
ActiveReports 19 .NET Edition
m_rcClip Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_rcClip Field

Glossary Item Box

Clip

Syntax

Visual Basic (Declaration)
Public m_rcClip As CSSRect
C#
public CSSRect m_rcClip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vClear Field

[image]
ActiveReports 19 .NET Edition
m_vClear Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vClear Field

Glossary Item Box

Clear

Syntax

Visual Basic (Declaration)
Public m_vClear As CSSValue
C#
public CSSValue m_vClear

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vDirection Field

[image]
ActiveReports 19 .NET Edition
m_vDirection Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vDirection Field

Glossary Item Box

Direction

Syntax

Visual Basic (Declaration)
Public m_vDirection As CSSValue
C#
public CSSValue m_vDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vDisplay Field

[image]
ActiveReports 19 .NET Edition
m_vDisplay Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vDisplay Field

Glossary Item Box

Display

Syntax

Visual Basic (Declaration)
Public m_vDisplay As CSSValue
C#
public CSSValue m_vDisplay

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vFloat Field

[image]
ActiveReports 19 .NET Edition
m_vFloat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vFloat Field

Glossary Item Box

Float

Syntax

Visual Basic (Declaration)
Public m_vFloat As CSSValue
C#
public CSSValue m_vFloat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vOverflow Field

[image]
ActiveReports 19 .NET Edition
m_vOverflow Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vOverflow Field

Glossary Item Box

Overflow

Syntax

Visual Basic (Declaration)
Public m_vOverflow As CSSValue
C#
public CSSValue m_vOverflow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


m_vVisibility Field

[image]
ActiveReports 19 .NET Edition
m_vVisibility Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSDisplay Structure : m_vVisibility Field

Glossary Item Box

Visibility

Syntax

Visual Basic (Declaration)
Public m_vVisibility As CSSValue
C#
public CSSValue m_vVisibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSDisplay Structure
CSSDisplay Members


CSSFont Structure

[image]
ActiveReports 19 .NET Edition
CSSFont Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSFont Structure

Glossary Item Box

Struct CSSFont

Object Model

CSSFont Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSFont
   Inherits System.ValueType
C#
public struct CSSFont : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Members
DDCssLib Namespace


CSSFont Structure Members

[image]
ActiveReports 19 .NET Edition
CSSFont Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSFont Structure

Glossary Item Box

The following tables list the members exposed by CSSFont.

Public Constructors

 | Name | Description
Public Constructor | CSSFont Constructor | Initializes a new instance of the CSSFont struct.
Top

Public Fields

 | Name | Description
Public Field | m_vFamily | Family
Public Field | m_vSize | Size
Public Field | m_vSizeAdjust | Size adjust
Public Field | m_vStretch | Stretch
Public Field | m_vStyle | Style
Public Field | m_vVariant | Variant
Public Field | m_vVerticalFont | Vertical font
Public Field | m_vWeight | Weight
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSFont Structure
DDCssLib Namespace


CSSFont Constructor

[image]
ActiveReports 19 .NET Edition
CSSFont Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : CSSFont Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSFont struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSFont _
)
C#
public CSSFont(
   CSSFont aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


CSSFont Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSFont Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSFont Structure

Glossary Item Box

For a list of all members of this type, see CSSFont members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSFont Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


CSSFont Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSFont Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSFont Structure

Glossary Item Box

For a list of all members of this type, see CSSFont members.

Public Fields

 | Name | Description
Public Field | m_vFamily | Family
Public Field | m_vSize | Size
Public Field | m_vSizeAdjust | Size adjust
Public Field | m_vStretch | Stretch
Public Field | m_vStyle | Style
Public Field | m_vVariant | Variant
Public Field | m_vVerticalFont | Vertical font
Public Field | m_vWeight | Weight
Top

See Also

Reference

CSSFont Structure
DDCssLib Namespace


m_vFamily Field

[image]
ActiveReports 19 .NET Edition
m_vFamily Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vFamily Field

Glossary Item Box

Family

Syntax

Visual Basic (Declaration)
Public m_vFamily As CSSValue
C#
public CSSValue m_vFamily

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vSize Field

[image]
ActiveReports 19 .NET Edition
m_vSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vSize Field

Glossary Item Box

Size

Syntax

Visual Basic (Declaration)
Public m_vSize As CSSValue
C#
public CSSValue m_vSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vSizeAdjust Field

[image]
ActiveReports 19 .NET Edition
m_vSizeAdjust Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vSizeAdjust Field

Glossary Item Box

Size adjust

Syntax

Visual Basic (Declaration)
Public m_vSizeAdjust As CSSValue
C#
public CSSValue m_vSizeAdjust

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vStretch Field

[image]
ActiveReports 19 .NET Edition
m_vStretch Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vStretch Field

Glossary Item Box

Stretch

Syntax

Visual Basic (Declaration)
Public m_vStretch As CSSValue
C#
public CSSValue m_vStretch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vStyle Field

[image]
ActiveReports 19 .NET Edition
m_vStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vStyle Field

Glossary Item Box

Style

Syntax

Visual Basic (Declaration)
Public m_vStyle As CSSValue
C#
public CSSValue m_vStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vVariant Field

[image]
ActiveReports 19 .NET Edition
m_vVariant Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vVariant Field

Glossary Item Box

Variant

Syntax

Visual Basic (Declaration)
Public m_vVariant As CSSValue
C#
public CSSValue m_vVariant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vVerticalFont Field

[image]
ActiveReports 19 .NET Edition
m_vVerticalFont Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vVerticalFont Field

Glossary Item Box

Vertical font

Syntax

Visual Basic (Declaration)
Public m_vVerticalFont As CSSValue
C#
public CSSValue m_vVerticalFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


m_vWeight Field

[image]
ActiveReports 19 .NET Edition
m_vWeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSFont Structure : m_vWeight Field

Glossary Item Box

Weight

Syntax

Visual Basic (Declaration)
Public m_vWeight As CSSValue
C#
public CSSValue m_vWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSFont Structure
CSSFont Members


CSSLine Structure

[image]
ActiveReports 19 .NET Edition
CSSLine Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSLine Structure

Glossary Item Box

Struct CSSLine

Object Model

CSSLine Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSLine
   Inherits System.ValueType
C#
public struct CSSLine : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Members
DDCssLib Namespace


CSSLine Structure Members

[image]
ActiveReports 19 .NET Edition
CSSLine Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSLine Structure

Glossary Item Box

The following tables list the members exposed by CSSLine.

Public Constructors

 | Name | Description
Public Constructor | CSSLine Constructor | Initializes a new instance of the CSSLine struct.
Top

Public Fields

 | Name | Description
Public Field | m_vColor | Color
Public Field | m_vMulti | Multi
Public Field | m_vStyle | Style
Public Field | m_vWeight | Weight
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSLine Structure
DDCssLib Namespace


CSSLine Constructor

[image]
ActiveReports 19 .NET Edition
CSSLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : CSSLine Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSLine struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSLine _
)
C#
public CSSLine(
   CSSLine aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


CSSLine Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSLine Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSLine Structure

Glossary Item Box

For a list of all members of this type, see CSSLine members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSLine Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


CSSLine Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSLine Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSLine Structure

Glossary Item Box

For a list of all members of this type, see CSSLine members.

Public Fields

 | Name | Description
Public Field | m_vColor | Color
Public Field | m_vMulti | Multi
Public Field | m_vStyle | Style
Public Field | m_vWeight | Weight
Top

See Also

Reference

CSSLine Structure
DDCssLib Namespace


m_vColor Field

[image]
ActiveReports 19 .NET Edition
m_vColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : m_vColor Field

Glossary Item Box

Color

Syntax

Visual Basic (Declaration)
Public m_vColor As CSSValue
C#
public CSSValue m_vColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


m_vMulti Field

[image]
ActiveReports 19 .NET Edition
m_vMulti Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : m_vMulti Field

Glossary Item Box

Multi

Syntax

Visual Basic (Declaration)
Public m_vMulti As CSSValue
C#
public CSSValue m_vMulti

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


m_vStyle Field

[image]
ActiveReports 19 .NET Edition
m_vStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : m_vStyle Field

Glossary Item Box

Style

Syntax

Visual Basic (Declaration)
Public m_vStyle As CSSValue
C#
public CSSValue m_vStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


m_vWeight Field

[image]
ActiveReports 19 .NET Edition
m_vWeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSLine Structure : m_vWeight Field

Glossary Item Box

Weight

Syntax

Visual Basic (Declaration)
Public m_vWeight As CSSValue
C#
public CSSValue m_vWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSLine Structure
CSSLine Members


CSSList Structure

[image]
ActiveReports 19 .NET Edition
CSSList Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSList Structure

Glossary Item Box

Struct CSSList

Object Model

CSSList Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSList
   Inherits System.ValueType
C#
public struct CSSList : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Members
DDCssLib Namespace


CSSList Structure Members

[image]
ActiveReports 19 .NET Edition
CSSList Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSList Structure

Glossary Item Box

The following tables list the members exposed by CSSList.

Public Constructors

 | Name | Description
Public Constructor | CSSList Constructor | Initializes a new instance of the CSSList struct.
Top

Public Fields

 | Name | Description
Public Field | m_vImage | Image
Public Field | m_vPosition | Position
Public Field | m_vType | Type
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSList Structure
DDCssLib Namespace


CSSList Constructor

[image]
ActiveReports 19 .NET Edition
CSSList Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSList Structure : CSSList Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSList struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSList _
)
C#
public CSSList(
   CSSList aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Structure
CSSList Members


CSSList Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSList Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSList Structure

Glossary Item Box

For a list of all members of this type, see CSSList members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSList Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSList Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Structure
CSSList Members


CSSList Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSList Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSList Structure

Glossary Item Box

For a list of all members of this type, see CSSList members.

Public Fields

 | Name | Description
Public Field | m_vImage | Image
Public Field | m_vPosition | Position
Public Field | m_vType | Type
Top

See Also

Reference

CSSList Structure
DDCssLib Namespace


m_vImage Field

[image]
ActiveReports 19 .NET Edition
m_vImage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSList Structure : m_vImage Field

Glossary Item Box

Image

Syntax

Visual Basic (Declaration)
Public m_vImage As CSSValue
C#
public CSSValue m_vImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Structure
CSSList Members


m_vPosition Field

[image]
ActiveReports 19 .NET Edition
m_vPosition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSList Structure : m_vPosition Field

Glossary Item Box

Position

Syntax

Visual Basic (Declaration)
Public m_vPosition As CSSValue
C#
public CSSValue m_vPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Structure
CSSList Members


m_vType Field

[image]
ActiveReports 19 .NET Edition
m_vType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSList Structure : m_vType Field

Glossary Item Box

Type

Syntax

Visual Basic (Declaration)
Public m_vType As CSSValue
C#
public CSSValue m_vType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSList Structure
CSSList Members


CSSMargin Structure

[image]
ActiveReports 19 .NET Edition
CSSMargin Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMargin Structure

Glossary Item Box

Struct CSSMargin

Object Model

CSSMargin Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSMargin
   Inherits System.ValueType
C#
public struct CSSMargin : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSMargin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Members
DDCssLib Namespace


CSSMargin Structure Members

[image]
ActiveReports 19 .NET Edition
CSSMargin Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMargin Structure

Glossary Item Box

The following tables list the members exposed by CSSMargin.

Public Constructors

 | Name | Description
Public Constructor | CSSMargin Constructor | Initializes a new instance of the CSSMargin struct.
Top

Public Fields

 | Name | Description
Public Field | m_rcBorderColor | Border color
Public Field | m_rcBorderRadius | Border radius
Public Field | m_rcBorderStyle | Border style
Public Field | m_rcBorderWidth | Border width
Public Field | m_rcMargin | Margin
Public Field | m_rcOutlineRadius | Outline radius
Public Field | m_rcPadding | Padding
Public Field | m_vFloatEdge | Float edge
Public Field | m_vOutlineColor | Outline color
Public Field | m_vOutlineStyle | Outline style
Public Field | m_vOutlineWidth | Outline width
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSMargin Structure
DDCssLib Namespace


CSSMargin Constructor

[image]
ActiveReports 19 .NET Edition
CSSMargin Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : CSSMargin Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSMargin struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSMargin _
)
C#
public CSSMargin(
   CSSMargin aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


CSSMargin Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSMargin Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMargin Structure

Glossary Item Box

For a list of all members of this type, see CSSMargin members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSMargin Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


CSSMargin Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSMargin Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMargin Structure

Glossary Item Box

For a list of all members of this type, see CSSMargin members.

Public Fields

 | Name | Description
Public Field | m_rcBorderColor | Border color
Public Field | m_rcBorderRadius | Border radius
Public Field | m_rcBorderStyle | Border style
Public Field | m_rcBorderWidth | Border width
Public Field | m_rcMargin | Margin
Public Field | m_rcOutlineRadius | Outline radius
Public Field | m_rcPadding | Padding
Public Field | m_vFloatEdge | Float edge
Public Field | m_vOutlineColor | Outline color
Public Field | m_vOutlineStyle | Outline style
Public Field | m_vOutlineWidth | Outline width
Top

See Also

Reference

CSSMargin Structure
DDCssLib Namespace


m_rcBorderColor Field

[image]
ActiveReports 19 .NET Edition
m_rcBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcBorderColor Field

Glossary Item Box

Border color

Syntax

Visual Basic (Declaration)
Public m_rcBorderColor As CSSRect
C#
public CSSRect m_rcBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcBorderRadius Field

[image]
ActiveReports 19 .NET Edition
m_rcBorderRadius Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcBorderRadius Field

Glossary Item Box

Border radius

Syntax

Visual Basic (Declaration)
Public m_rcBorderRadius As CSSRect
C#
public CSSRect m_rcBorderRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcBorderStyle Field

[image]
ActiveReports 19 .NET Edition
m_rcBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcBorderStyle Field

Glossary Item Box

Border style

Syntax

Visual Basic (Declaration)
Public m_rcBorderStyle As CSSRect
C#
public CSSRect m_rcBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcBorderWidth Field

[image]
ActiveReports 19 .NET Edition
m_rcBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcBorderWidth Field

Glossary Item Box

Border width

Syntax

Visual Basic (Declaration)
Public m_rcBorderWidth As CSSRect
C#
public CSSRect m_rcBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcMargin Field

[image]
ActiveReports 19 .NET Edition
m_rcMargin Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcMargin Field

Glossary Item Box

Margin

Syntax

Visual Basic (Declaration)
Public m_rcMargin As CSSRect
C#
public CSSRect m_rcMargin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcOutlineRadius Field

[image]
ActiveReports 19 .NET Edition
m_rcOutlineRadius Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcOutlineRadius Field

Glossary Item Box

Outline radius

Syntax

Visual Basic (Declaration)
Public m_rcOutlineRadius As CSSRect
C#
public CSSRect m_rcOutlineRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_rcPadding Field

[image]
ActiveReports 19 .NET Edition
m_rcPadding Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_rcPadding Field

Glossary Item Box

Padding

Syntax

Visual Basic (Declaration)
Public m_rcPadding As CSSRect
C#
public CSSRect m_rcPadding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_vFloatEdge Field

[image]
ActiveReports 19 .NET Edition
m_vFloatEdge Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_vFloatEdge Field

Glossary Item Box

Float edge

Syntax

Visual Basic (Declaration)
Public m_vFloatEdge As CSSValue
C#
public CSSValue m_vFloatEdge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_vOutlineColor Field

[image]
ActiveReports 19 .NET Edition
m_vOutlineColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_vOutlineColor Field

Glossary Item Box

Outline color

Syntax

Visual Basic (Declaration)
Public m_vOutlineColor As CSSValue
C#
public CSSValue m_vOutlineColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_vOutlineStyle Field

[image]
ActiveReports 19 .NET Edition
m_vOutlineStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_vOutlineStyle Field

Glossary Item Box

Outline style

Syntax

Visual Basic (Declaration)
Public m_vOutlineStyle As CSSValue
C#
public CSSValue m_vOutlineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


m_vOutlineWidth Field

[image]
ActiveReports 19 .NET Edition
m_vOutlineWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMargin Structure : m_vOutlineWidth Field

Glossary Item Box

Outline width

Syntax

Visual Basic (Declaration)
Public m_vOutlineWidth As CSSValue
C#
public CSSValue m_vOutlineWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMargin Structure
CSSMargin Members


CSSMisc Structure

[image]
ActiveReports 19 .NET Edition
CSSMisc Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMisc Structure

Glossary Item Box

Struct CSSMisc

Object Model

CSSMisc Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSMisc
   Inherits System.ValueType
C#
public struct CSSMisc : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSMisc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Members
DDCssLib Namespace


CSSMisc Structure Members

[image]
ActiveReports 19 .NET Edition
CSSMisc Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMisc Structure

Glossary Item Box

The following tables list the members exposed by CSSMisc.

Public Constructors

 | Name | Description
Public Constructor | CSSMisc Constructor | Initializes a new instance of the CSSMisc struct.
Top

Public Fields

 | Name | Description
Public Field | m_vCanGrow | Can grow
Public Field | m_vCanShrink | Can shrink
Public Field | m_vCharset | Charset
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSMisc Structure
DDCssLib Namespace


CSSMisc Constructor

[image]
ActiveReports 19 .NET Edition
CSSMisc Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMisc Structure : CSSMisc Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSMisc struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSMisc _
)
C#
public CSSMisc(
   CSSMisc aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Structure
CSSMisc Members


CSSMisc Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSMisc Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMisc Structure

Glossary Item Box

For a list of all members of this type, see CSSMisc members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSMisc Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMisc Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Structure
CSSMisc Members


CSSMisc Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSMisc Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSMisc Structure

Glossary Item Box

For a list of all members of this type, see CSSMisc members.

Public Fields

 | Name | Description
Public Field | m_vCanGrow | Can grow
Public Field | m_vCanShrink | Can shrink
Public Field | m_vCharset | Charset
Top

See Also

Reference

CSSMisc Structure
DDCssLib Namespace


m_vCanGrow Field

[image]
ActiveReports 19 .NET Edition
m_vCanGrow Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMisc Structure : m_vCanGrow Field

Glossary Item Box

Can grow

Syntax

Visual Basic (Declaration)
Public m_vCanGrow As CSSValue
C#
public CSSValue m_vCanGrow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Structure
CSSMisc Members


m_vCanShrink Field

[image]
ActiveReports 19 .NET Edition
m_vCanShrink Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMisc Structure : m_vCanShrink Field

Glossary Item Box

Can shrink

Syntax

Visual Basic (Declaration)
Public m_vCanShrink As CSSValue
C#
public CSSValue m_vCanShrink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Structure
CSSMisc Members


m_vCharset Field

[image]
ActiveReports 19 .NET Edition
m_vCharset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSMisc Structure : m_vCharset Field

Glossary Item Box

Charset

Syntax

Visual Basic (Declaration)
Public m_vCharset As CSSValue
C#
public CSSValue m_vCharset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSMisc Structure
CSSMisc Members


CSSPage Structure

[image]
ActiveReports 19 .NET Edition
CSSPage Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPage Structure

Glossary Item Box

Struct CSSPage

Object Model

CSSPage Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSPage
   Inherits System.ValueType
C#
public struct CSSPage : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Members
DDCssLib Namespace


CSSPage Structure Members

[image]
ActiveReports 19 .NET Edition
CSSPage Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPage Structure

Glossary Item Box

The following tables list the members exposed by CSSPage.

Public Constructors

 | Name | Description
Public Constructor | CSSPage Constructor | Initializes a new instance of the CSSPage struct.
Top

Public Fields

 | Name | Description
Public Field | m_vMarks | Marks
Public Field | m_vSizeHeight | Size height
Public Field | m_vSizeWidth | Size width
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSPage Structure
DDCssLib Namespace


CSSPage Constructor

[image]
ActiveReports 19 .NET Edition
CSSPage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPage Structure : CSSPage Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSPage struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSPage _
)
C#
public CSSPage(
   CSSPage aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Structure
CSSPage Members


CSSPage Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSPage Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPage Structure

Glossary Item Box

For a list of all members of this type, see CSSPage members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSPage Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPage Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Structure
CSSPage Members


CSSPage Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSPage Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPage Structure

Glossary Item Box

For a list of all members of this type, see CSSPage members.

Public Fields

 | Name | Description
Public Field | m_vMarks | Marks
Public Field | m_vSizeHeight | Size height
Public Field | m_vSizeWidth | Size width
Top

See Also

Reference

CSSPage Structure
DDCssLib Namespace


m_vMarks Field

[image]
ActiveReports 19 .NET Edition
m_vMarks Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPage Structure : m_vMarks Field

Glossary Item Box

Marks

Syntax

Visual Basic (Declaration)
Public m_vMarks As CSSValue
C#
public CSSValue m_vMarks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Structure
CSSPage Members


m_vSizeHeight Field

[image]
ActiveReports 19 .NET Edition
m_vSizeHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPage Structure : m_vSizeHeight Field

Glossary Item Box

Size height

Syntax

Visual Basic (Declaration)
Public m_vSizeHeight As CSSValue
C#
public CSSValue m_vSizeHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Structure
CSSPage Members


m_vSizeWidth Field

[image]
ActiveReports 19 .NET Edition
m_vSizeWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPage Structure : m_vSizeWidth Field

Glossary Item Box

Size width

Syntax

Visual Basic (Declaration)
Public m_vSizeWidth As CSSValue
C#
public CSSValue m_vSizeWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPage Structure
CSSPage Members


CSSPosition Structure

[image]
ActiveReports 19 .NET Edition
CSSPosition Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPosition Structure

Glossary Item Box

Struct CSSPosition

Object Model

CSSPosition Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSPosition
   Inherits System.ValueType
C#
public struct CSSPosition : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Members
DDCssLib Namespace


CSSPosition Structure Members

[image]
ActiveReports 19 .NET Edition
CSSPosition Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPosition Structure

Glossary Item Box

The following tables list the members exposed by CSSPosition.

Public Constructors

 | Name | Description
Public Constructor | CSSPosition Constructor | Initializes a new instance of the CSSPosition struct.
Top

Public Fields

 | Name | Description
Public Field | m_rcOffset | Offset
Public Field | m_vBoxSizing | Box sizing
Public Field | m_vHeight | Height
Public Field | m_vMaxHeight | Maximum height
Public Field | m_vMaxWidth | Maximum width
Public Field | m_vMinHeight | Minimum height
Public Field | m_vMinWidth | Minimum width
Public Field | m_vPosition | Position
Public Field | m_vWidth | Width
Public Field | m_vZIndex | Z index
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSPosition Structure
DDCssLib Namespace


CSSPosition Constructor

[image]
ActiveReports 19 .NET Edition
CSSPosition Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : CSSPosition Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSPosition struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSPosition _
)
C#
public CSSPosition(
   CSSPosition aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


CSSPosition Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSPosition Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPosition Structure

Glossary Item Box

For a list of all members of this type, see CSSPosition members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSPosition Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


CSSPosition Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSPosition Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSPosition Structure

Glossary Item Box

For a list of all members of this type, see CSSPosition members.

Public Fields

 | Name | Description
Public Field | m_rcOffset | Offset
Public Field | m_vBoxSizing | Box sizing
Public Field | m_vHeight | Height
Public Field | m_vMaxHeight | Maximum height
Public Field | m_vMaxWidth | Maximum width
Public Field | m_vMinHeight | Minimum height
Public Field | m_vMinWidth | Minimum width
Public Field | m_vPosition | Position
Public Field | m_vWidth | Width
Public Field | m_vZIndex | Z index
Top

See Also

Reference

CSSPosition Structure
DDCssLib Namespace


m_rcOffset Field

[image]
ActiveReports 19 .NET Edition
m_rcOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_rcOffset Field

Glossary Item Box

Offset

Syntax

Visual Basic (Declaration)
Public m_rcOffset As CSSRect
C#
public CSSRect m_rcOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vBoxSizing Field

[image]
ActiveReports 19 .NET Edition
m_vBoxSizing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vBoxSizing Field

Glossary Item Box

Box sizing

Syntax

Visual Basic (Declaration)
Public m_vBoxSizing As CSSValue
C#
public CSSValue m_vBoxSizing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vHeight Field

[image]
ActiveReports 19 .NET Edition
m_vHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vHeight Field

Glossary Item Box

Height

Syntax

Visual Basic (Declaration)
Public m_vHeight As CSSValue
C#
public CSSValue m_vHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vMaxHeight Field

[image]
ActiveReports 19 .NET Edition
m_vMaxHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vMaxHeight Field

Glossary Item Box

Maximum height

Syntax

Visual Basic (Declaration)
Public m_vMaxHeight As CSSValue
C#
public CSSValue m_vMaxHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vMaxWidth Field

[image]
ActiveReports 19 .NET Edition
m_vMaxWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vMaxWidth Field

Glossary Item Box

Maximum width

Syntax

Visual Basic (Declaration)
Public m_vMaxWidth As CSSValue
C#
public CSSValue m_vMaxWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vMinHeight Field

[image]
ActiveReports 19 .NET Edition
m_vMinHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vMinHeight Field

Glossary Item Box

Minimum height

Syntax

Visual Basic (Declaration)
Public m_vMinHeight As CSSValue
C#
public CSSValue m_vMinHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vMinWidth Field

[image]
ActiveReports 19 .NET Edition
m_vMinWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vMinWidth Field

Glossary Item Box

Minimum width

Syntax

Visual Basic (Declaration)
Public m_vMinWidth As CSSValue
C#
public CSSValue m_vMinWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vPosition Field

[image]
ActiveReports 19 .NET Edition
m_vPosition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vPosition Field

Glossary Item Box

Position

Syntax

Visual Basic (Declaration)
Public m_vPosition As CSSValue
C#
public CSSValue m_vPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vWidth Field

[image]
ActiveReports 19 .NET Edition
m_vWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vWidth Field

Glossary Item Box

Width

Syntax

Visual Basic (Declaration)
Public m_vWidth As CSSValue
C#
public CSSValue m_vWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


m_vZIndex Field

[image]
ActiveReports 19 .NET Edition
m_vZIndex Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSPosition Structure : m_vZIndex Field

Glossary Item Box

Z index

Syntax

Visual Basic (Declaration)
Public m_vZIndex As CSSValue
C#
public CSSValue m_vZIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSPosition Structure
CSSPosition Members


CSSQuotes Structure

[image]
ActiveReports 19 .NET Edition
CSSQuotes Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSQuotes Structure

Glossary Item Box

Struct CSSQuotes

Object Model

CSSQuotes Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSQuotes
   Inherits System.ValueType
C#
public struct CSSQuotes : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSQuotes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSQuotes Members
DDCssLib Namespace


CSSQuotes Structure Members

[image]
ActiveReports 19 .NET Edition
CSSQuotes Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSQuotes Structure

Glossary Item Box

The following tables list the members exposed by CSSQuotes.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vClose | Close
Public Field | m_vOpen | Open
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSQuotes Structure
DDCssLib Namespace


CSSQuotes Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSQuotes Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSQuotes Structure

Glossary Item Box

For a list of all members of this type, see CSSQuotes members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSQuotes Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSQuotes Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSQuotes Structure
CSSQuotes Members


CSSQuotes Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSQuotes Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSQuotes Structure

Glossary Item Box

For a list of all members of this type, see CSSQuotes members.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vClose | Close
Public Field | m_vOpen | Open
Top

See Also

Reference

CSSQuotes Structure
DDCssLib Namespace


m_oNext Field

[image]
ActiveReports 19 .NET Edition
m_oNext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSQuotes Structure : m_oNext Field

Glossary Item Box

Next

Syntax

Visual Basic (Declaration)
Public m_oNext As Object
C#
public object m_oNext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSQuotes Structure
CSSQuotes Members


m_vClose Field

[image]
ActiveReports 19 .NET Edition
m_vClose Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSQuotes Structure : m_vClose Field

Glossary Item Box

Close

Syntax

Visual Basic (Declaration)
Public m_vClose As CSSValue
C#
public CSSValue m_vClose

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSQuotes Structure
CSSQuotes Members


m_vOpen Field

[image]
ActiveReports 19 .NET Edition
m_vOpen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSQuotes Structure : m_vOpen Field

Glossary Item Box

Open

Syntax

Visual Basic (Declaration)
Public m_vOpen As CSSValue
C#
public CSSValue m_vOpen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSQuotes Structure
CSSQuotes Members


CSSRect Structure

[image]
ActiveReports 19 .NET Edition
CSSRect Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSRect Structure

Glossary Item Box

Struct CSSRect

Object Model

CSSRect Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSRect
   Inherits System.ValueType
C#
public struct CSSRect : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Members
DDCssLib Namespace


CSSRect Structure Members

[image]
ActiveReports 19 .NET Edition
CSSRect Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSRect Structure

Glossary Item Box

The following tables list the members exposed by CSSRect.

Public Constructors

 | Name | Description
Public Constructor | CSSRect Constructor | Creates a new CSSRect instance that copies top, right, bottom, left members' values of the specified CSSRect object.
Top

Public Fields

 | Name | Description
Public Field | m_vBottom | Bottom
Public Field | m_vLeft | Left
Public Field | m_vRight | Right
Public Field | m_vTop | Top
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets each of the CSSValue objects contained by this struct.
Top

See Also

Reference

CSSRect Structure
DDCssLib Namespace


CSSRect Constructor

[image]
ActiveReports 19 .NET Edition
CSSRect Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : CSSRect Constructor

aCopy

Glossary Item Box

Creates a new CSSRect instance that copies top, right, bottom, left members' values of the specified CSSRect object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSRect _
)
C#
public CSSRect(
   CSSRect aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


CSSRect Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSRect Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSRect Structure

Glossary Item Box

For a list of all members of this type, see CSSRect members.

Public Methods

 | Name | Description
Public Method | Reset | Resets each of the CSSValue objects contained by this struct.
Top

See Also

Reference

CSSRect Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : Reset Method

Glossary Item Box

Resets each of the CSSValue objects contained by this struct.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


CSSRect Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSRect Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSRect Structure

Glossary Item Box

For a list of all members of this type, see CSSRect members.

Public Fields

 | Name | Description
Public Field | m_vBottom | Bottom
Public Field | m_vLeft | Left
Public Field | m_vRight | Right
Public Field | m_vTop | Top
Top

See Also

Reference

CSSRect Structure
DDCssLib Namespace


m_vBottom Field

[image]
ActiveReports 19 .NET Edition
m_vBottom Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : m_vBottom Field

Glossary Item Box

Bottom

Syntax

Visual Basic (Declaration)
Public m_vBottom As CSSValue
C#
public CSSValue m_vBottom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


m_vLeft Field

[image]
ActiveReports 19 .NET Edition
m_vLeft Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : m_vLeft Field

Glossary Item Box

Left

Syntax

Visual Basic (Declaration)
Public m_vLeft As CSSValue
C#
public CSSValue m_vLeft

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


m_vRight Field

[image]
ActiveReports 19 .NET Edition
m_vRight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : m_vRight Field

Glossary Item Box

Right

Syntax

Visual Basic (Declaration)
Public m_vRight As CSSValue
C#
public CSSValue m_vRight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


m_vTop Field

[image]
ActiveReports 19 .NET Edition
m_vTop Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSRect Structure : m_vTop Field

Glossary Item Box

Top

Syntax

Visual Basic (Declaration)
Public m_vTop As CSSValue
C#
public CSSValue m_vTop

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSRect Structure
CSSRect Members


CSSShadow Structure

[image]
ActiveReports 19 .NET Edition
CSSShadow Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSShadow Structure

Glossary Item Box

Struct CSSShadow

Object Model

CSSShadow Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSShadow
   Inherits System.ValueType
C#
public struct CSSShadow : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSShadow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Members
DDCssLib Namespace


CSSShadow Structure Members

[image]
ActiveReports 19 .NET Edition
CSSShadow Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSShadow Structure

Glossary Item Box

The following tables list the members exposed by CSSShadow.

Public Constructors

 | Name | Description
Public Constructor | CSSShadow Constructor | Initializes a new instance of the CSSShadow struct.
Top

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vColor | Color
Public Field | m_vRadius | Radius
Public Field | m_vXOffset | X offset
Public Field | m_vYOffset | Y offset
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSShadow Structure
DDCssLib Namespace


CSSShadow Constructor

[image]
ActiveReports 19 .NET Edition
CSSShadow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : CSSShadow Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSShadow struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSShadow _
)
C#
public CSSShadow(
   CSSShadow aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


CSSShadow Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSShadow Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSShadow Structure

Glossary Item Box

For a list of all members of this type, see CSSShadow members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSShadow Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


CSSShadow Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSShadow Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSShadow Structure

Glossary Item Box

For a list of all members of this type, see CSSShadow members.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vColor | Color
Public Field | m_vRadius | Radius
Public Field | m_vXOffset | X offset
Public Field | m_vYOffset | Y offset
Top

See Also

Reference

CSSShadow Structure
DDCssLib Namespace


m_oNext Field

[image]
ActiveReports 19 .NET Edition
m_oNext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : m_oNext Field

Glossary Item Box

Next

Syntax

Visual Basic (Declaration)
Public m_oNext As Object
C#
public object m_oNext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


m_vColor Field

[image]
ActiveReports 19 .NET Edition
m_vColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : m_vColor Field

Glossary Item Box

Color

Syntax

Visual Basic (Declaration)
Public m_vColor As CSSValue
C#
public CSSValue m_vColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


m_vRadius Field

[image]
ActiveReports 19 .NET Edition
m_vRadius Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : m_vRadius Field

Glossary Item Box

Radius

Syntax

Visual Basic (Declaration)
Public m_vRadius As CSSValue
C#
public CSSValue m_vRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


m_vXOffset Field

[image]
ActiveReports 19 .NET Edition
m_vXOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : m_vXOffset Field

Glossary Item Box

X offset

Syntax

Visual Basic (Declaration)
Public m_vXOffset As CSSValue
C#
public CSSValue m_vXOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


m_vYOffset Field

[image]
ActiveReports 19 .NET Edition
m_vYOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSShadow Structure : m_vYOffset Field

Glossary Item Box

Y offset

Syntax

Visual Basic (Declaration)
Public m_vYOffset As CSSValue
C#
public CSSValue m_vYOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSShadow Structure
CSSShadow Members


CSSTable Structure

[image]
ActiveReports 19 .NET Edition
CSSTable Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSTable Structure

Glossary Item Box

Struct CSSTable

Object Model

CSSTable Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSTable
   Inherits System.ValueType
C#
public struct CSSTable : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Members
DDCssLib Namespace


CSSTable Structure Members

[image]
ActiveReports 19 .NET Edition
CSSTable Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSTable Structure

Glossary Item Box

The following tables list the members exposed by CSSTable.

Public Constructors

 | Name | Description
Public Constructor | CSSTable Constructor | Initializes a new instance of the CSSTable struct.
Top

Public Fields

 | Name | Description
Public Field | m_vBorderCollapse | Border collapse
Public Field | m_vBorderSpacingX | Border spacing x
Public Field | m_vBorderSpacingY | Border spacing y
Public Field | m_vCaptionSide | Caption side
Public Field | m_vEmptyCells | Empty cells
Public Field | m_vLayout | Layout
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSTable Structure
DDCssLib Namespace


CSSTable Constructor

[image]
ActiveReports 19 .NET Edition
CSSTable Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : CSSTable Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSTable struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSTable _
)
C#
public CSSTable(
   CSSTable aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


CSSTable Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSTable Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSTable Structure

Glossary Item Box

For a list of all members of this type, see CSSTable members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSTable Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


CSSTable Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSTable Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSTable Structure

Glossary Item Box

For a list of all members of this type, see CSSTable members.

Public Fields

 | Name | Description
Public Field | m_vBorderCollapse | Border collapse
Public Field | m_vBorderSpacingX | Border spacing x
Public Field | m_vBorderSpacingY | Border spacing y
Public Field | m_vCaptionSide | Caption side
Public Field | m_vEmptyCells | Empty cells
Public Field | m_vLayout | Layout
Top

See Also

Reference

CSSTable Structure
DDCssLib Namespace


m_vBorderCollapse Field

[image]
ActiveReports 19 .NET Edition
m_vBorderCollapse Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vBorderCollapse Field

Glossary Item Box

Border collapse

Syntax

Visual Basic (Declaration)
Public m_vBorderCollapse As CSSValue
C#
public CSSValue m_vBorderCollapse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


m_vBorderSpacingX Field

[image]
ActiveReports 19 .NET Edition
m_vBorderSpacingX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vBorderSpacingX Field

Glossary Item Box

Border spacing x

Syntax

Visual Basic (Declaration)
Public m_vBorderSpacingX As CSSValue
C#
public CSSValue m_vBorderSpacingX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


m_vBorderSpacingY Field

[image]
ActiveReports 19 .NET Edition
m_vBorderSpacingY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vBorderSpacingY Field

Glossary Item Box

Border spacing y

Syntax

Visual Basic (Declaration)
Public m_vBorderSpacingY As CSSValue
C#
public CSSValue m_vBorderSpacingY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


m_vCaptionSide Field

[image]
ActiveReports 19 .NET Edition
m_vCaptionSide Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vCaptionSide Field

Glossary Item Box

Caption side

Syntax

Visual Basic (Declaration)
Public m_vCaptionSide As CSSValue
C#
public CSSValue m_vCaptionSide

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


m_vEmptyCells Field

[image]
ActiveReports 19 .NET Edition
m_vEmptyCells Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vEmptyCells Field

Glossary Item Box

Empty cells

Syntax

Visual Basic (Declaration)
Public m_vEmptyCells As CSSValue
C#
public CSSValue m_vEmptyCells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


m_vLayout Field

[image]
ActiveReports 19 .NET Edition
m_vLayout Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSTable Structure : m_vLayout Field

Glossary Item Box

Layout

Syntax

Visual Basic (Declaration)
Public m_vLayout As CSSValue
C#
public CSSValue m_vLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSTable Structure
CSSTable Members


CSSText Structure

[image]
ActiveReports 19 .NET Edition
CSSText Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSText Structure

Glossary Item Box

Struct CSSText

Object Model

CSSText Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSText
   Inherits System.ValueType
C#
public struct CSSText : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Members
DDCssLib Namespace


CSSText Structure Members

[image]
ActiveReports 19 .NET Edition
CSSText Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSText Structure

Glossary Item Box

The following tables list the members exposed by CSSText.

Public Constructors

 | Name | Description
Public Constructor | CSSText Constructor | Initializes a new instance of the CSSText struct.
Top

Public Fields

 | Name | Description
Public Field | m_pTextShadow | Text shadow
Public Field | m_vDecoration | Decoration
Public Field | m_vEnableKinsoku | Enable kinsoku
Public Field | m_vLetterSpacing | Letter spacing
Public Field | m_vLineHeight | Line height
Public Field | m_vShrinkToFit | Shrink to fit
Public Field | m_vTextAlign | Text align
Public Field | m_vTextIndent | Text indent
Public Field | m_vTextJustify | Text justify
Public Field | m_vTextTransform | Text transform
Public Field | m_vUnicodeBidi | Unicode bidi
Public Field | m_vVerticalAlign | Vertical align
Public Field | m_vWhiteSpace | White space
Public Field | m_vWordSpacing | Word spacing
Public Field | m_vWrapMode | Wrap mode
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSText Structure
DDCssLib Namespace


CSSText Constructor

[image]
ActiveReports 19 .NET Edition
CSSText Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : CSSText Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSText struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSText _
)
C#
public CSSText(
   CSSText aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


CSSText Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSText Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSText Structure

Glossary Item Box

For a list of all members of this type, see CSSText members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSText Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


CSSText Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSText Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSText Structure

Glossary Item Box

For a list of all members of this type, see CSSText members.

Public Fields

 | Name | Description
Public Field | m_pTextShadow | Text shadow
Public Field | m_vDecoration | Decoration
Public Field | m_vEnableKinsoku | Enable kinsoku
Public Field | m_vLetterSpacing | Letter spacing
Public Field | m_vLineHeight | Line height
Public Field | m_vShrinkToFit | Shrink to fit
Public Field | m_vTextAlign | Text align
Public Field | m_vTextIndent | Text indent
Public Field | m_vTextJustify | Text justify
Public Field | m_vTextTransform | Text transform
Public Field | m_vUnicodeBidi | Unicode bidi
Public Field | m_vVerticalAlign | Vertical align
Public Field | m_vWhiteSpace | White space
Public Field | m_vWordSpacing | Word spacing
Public Field | m_vWrapMode | Wrap mode
Top

See Also

Reference

CSSText Structure
DDCssLib Namespace


m_pTextShadow Field

[image]
ActiveReports 19 .NET Edition
m_pTextShadow Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_pTextShadow Field

Glossary Item Box

Text shadow

Syntax

Visual Basic (Declaration)
Public m_pTextShadow As CSSShadow
C#
public CSSShadow m_pTextShadow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vDecoration Field

[image]
ActiveReports 19 .NET Edition
m_vDecoration Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vDecoration Field

Glossary Item Box

Decoration

Syntax

Visual Basic (Declaration)
Public m_vDecoration As CSSValue
C#
public CSSValue m_vDecoration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vEnableKinsoku Field

[image]
ActiveReports 19 .NET Edition
m_vEnableKinsoku Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vEnableKinsoku Field

Glossary Item Box

Enable kinsoku

Syntax

Visual Basic (Declaration)
Public m_vEnableKinsoku As CSSValue
C#
public CSSValue m_vEnableKinsoku

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vLetterSpacing Field

[image]
ActiveReports 19 .NET Edition
m_vLetterSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vLetterSpacing Field

Glossary Item Box

Letter spacing

Syntax

Visual Basic (Declaration)
Public m_vLetterSpacing As CSSValue
C#
public CSSValue m_vLetterSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vLineHeight Field

[image]
ActiveReports 19 .NET Edition
m_vLineHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vLineHeight Field

Glossary Item Box

Line height

Syntax

Visual Basic (Declaration)
Public m_vLineHeight As CSSValue
C#
public CSSValue m_vLineHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vShrinkToFit Field

[image]
ActiveReports 19 .NET Edition
m_vShrinkToFit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vShrinkToFit Field

Glossary Item Box

Shrink to fit

Syntax

Visual Basic (Declaration)
Public m_vShrinkToFit As CSSValue
C#
public CSSValue m_vShrinkToFit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vTextAlign Field

[image]
ActiveReports 19 .NET Edition
m_vTextAlign Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vTextAlign Field

Glossary Item Box

Text align

Syntax

Visual Basic (Declaration)
Public m_vTextAlign As CSSValue
C#
public CSSValue m_vTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vTextIndent Field

[image]
ActiveReports 19 .NET Edition
m_vTextIndent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vTextIndent Field

Glossary Item Box

Text indent

Syntax

Visual Basic (Declaration)
Public m_vTextIndent As CSSValue
C#
public CSSValue m_vTextIndent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vTextJustify Field

[image]
ActiveReports 19 .NET Edition
m_vTextJustify Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vTextJustify Field

Glossary Item Box

Text justify

Syntax

Visual Basic (Declaration)
Public m_vTextJustify As CSSValue
C#
public CSSValue m_vTextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vTextTransform Field

[image]
ActiveReports 19 .NET Edition
m_vTextTransform Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vTextTransform Field

Glossary Item Box

Text transform

Syntax

Visual Basic (Declaration)
Public m_vTextTransform As CSSValue
C#
public CSSValue m_vTextTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vUnicodeBidi Field

[image]
ActiveReports 19 .NET Edition
m_vUnicodeBidi Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vUnicodeBidi Field

Glossary Item Box

Unicode bidi

Syntax

Visual Basic (Declaration)
Public m_vUnicodeBidi As CSSValue
C#
public CSSValue m_vUnicodeBidi

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vVerticalAlign Field

[image]
ActiveReports 19 .NET Edition
m_vVerticalAlign Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vVerticalAlign Field

Glossary Item Box

Vertical align

Syntax

Visual Basic (Declaration)
Public m_vVerticalAlign As CSSValue
C#
public CSSValue m_vVerticalAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vWhiteSpace Field

[image]
ActiveReports 19 .NET Edition
m_vWhiteSpace Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vWhiteSpace Field

Glossary Item Box

White space

Syntax

Visual Basic (Declaration)
Public m_vWhiteSpace As CSSValue
C#
public CSSValue m_vWhiteSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vWordSpacing Field

[image]
ActiveReports 19 .NET Edition
m_vWordSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vWordSpacing Field

Glossary Item Box

Word spacing

Syntax

Visual Basic (Declaration)
Public m_vWordSpacing As CSSValue
C#
public CSSValue m_vWordSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


m_vWrapMode Field

[image]
ActiveReports 19 .NET Edition
m_vWrapMode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSText Structure : m_vWrapMode Field

Glossary Item Box

Wrap mode

Syntax

Visual Basic (Declaration)
Public m_vWrapMode As CSSValue
C#
public CSSValue m_vWrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSText Structure
CSSText Members


CSSUserInterface Structure

[image]
ActiveReports 19 .NET Edition
CSSUserInterface Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSUserInterface Structure

Glossary Item Box

Struct CSSUserInterface

Object Model

CSSUserInterface Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSUserInterface
   Inherits System.ValueType
C#
public struct CSSUserInterface : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSUserInterface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Members
DDCssLib Namespace


CSSUserInterface Structure Members

[image]
ActiveReports 19 .NET Edition
CSSUserInterface Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSUserInterface Structure

Glossary Item Box

The following tables list the members exposed by CSSUserInterface.

Public Constructors

 | Name | Description
Public Constructor | CSSUserInterface Constructor | Initializes a new instance of the CSSUserInterface struct.
Top

Public Fields

 | Name | Description
Public Field | m_vBehavior | Behavior
Public Field | m_vlKeyEquivalent | Key equivalent
Public Field | m_vResizer | Resizer
Public Field | m_vUserFocus | User focus
Public Field | m_vUserInput | User input
Public Field | m_vUserModify | User modify
Public Field | m_vUserSelect | User select
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSUserInterface Structure
DDCssLib Namespace


CSSUserInterface Constructor

[image]
ActiveReports 19 .NET Edition
CSSUserInterface Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : CSSUserInterface Constructor

aCopy

Glossary Item Box

Initializes a new instance of the CSSUserInterface struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCopy As CSSUserInterface _
)
C#
public CSSUserInterface(
   CSSUserInterface aCopy
)

Parameters

aCopy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


CSSUserInterface Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSUserInterface Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSUserInterface Structure

Glossary Item Box

For a list of all members of this type, see CSSUserInterface members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSUserInterface Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


CSSUserInterface Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSUserInterface Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSUserInterface Structure

Glossary Item Box

For a list of all members of this type, see CSSUserInterface members.

Public Fields

 | Name | Description
Public Field | m_vBehavior | Behavior
Public Field | m_vlKeyEquivalent | Key equivalent
Public Field | m_vResizer | Resizer
Public Field | m_vUserFocus | User focus
Public Field | m_vUserInput | User input
Public Field | m_vUserModify | User modify
Public Field | m_vUserSelect | User select
Top

See Also

Reference

CSSUserInterface Structure
DDCssLib Namespace


m_vBehavior Field

[image]
ActiveReports 19 .NET Edition
m_vBehavior Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vBehavior Field

Glossary Item Box

Behavior

Syntax

Visual Basic (Declaration)
Public m_vBehavior As CSSValue
C#
public CSSValue m_vBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vlKeyEquivalent Field

[image]
ActiveReports 19 .NET Edition
m_vlKeyEquivalent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vlKeyEquivalent Field

Glossary Item Box

Key equivalent

Syntax

Visual Basic (Declaration)
Public m_vlKeyEquivalent As CSSValueList
C#
public CSSValueList m_vlKeyEquivalent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vResizer Field

[image]
ActiveReports 19 .NET Edition
m_vResizer Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vResizer Field

Glossary Item Box

Resizer

Syntax

Visual Basic (Declaration)
Public m_vResizer As CSSValue
C#
public CSSValue m_vResizer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vUserFocus Field

[image]
ActiveReports 19 .NET Edition
m_vUserFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vUserFocus Field

Glossary Item Box

User focus

Syntax

Visual Basic (Declaration)
Public m_vUserFocus As CSSValue
C#
public CSSValue m_vUserFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vUserInput Field

[image]
ActiveReports 19 .NET Edition
m_vUserInput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vUserInput Field

Glossary Item Box

User input

Syntax

Visual Basic (Declaration)
Public m_vUserInput As CSSValue
C#
public CSSValue m_vUserInput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vUserModify Field

[image]
ActiveReports 19 .NET Edition
m_vUserModify Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vUserModify Field

Glossary Item Box

User modify

Syntax

Visual Basic (Declaration)
Public m_vUserModify As CSSValue
C#
public CSSValue m_vUserModify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


m_vUserSelect Field

[image]
ActiveReports 19 .NET Edition
m_vUserSelect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSUserInterface Structure : m_vUserSelect Field

Glossary Item Box

User select

Syntax

Visual Basic (Declaration)
Public m_vUserSelect As CSSValue
C#
public CSSValue m_vUserSelect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSUserInterface Structure
CSSUserInterface Members


CSSValue Structure

[image]
ActiveReports 19 .NET Edition
CSSValue Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValue Structure

Glossary Item Box

Encapsulates a value for a CSSProperty.

Object Model

CSSValue Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSValue
   Inherits System.ValueType
C#
public struct CSSValue : System.ValueType

Remarks

When callign any of the Get...Value() properties the current unit type must be valid. Ensure the unit type is valid using CSSValue.Unit.

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Members
DDCssLib Namespace


CSSValue Structure Members

[image]
ActiveReports 19 .NET Edition
CSSValue Structure Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValue Structure

Glossary Item Box

The following tables list the members exposed by CSSValue.

Public Constructors

 | Name | Description
Public Constructor | CSSValue Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Unit | Gets/sets the Unit value.
Top

Public Methods

 | Name | Description
Public Method | CopyFrom | Performs a "deep copy" (memebers and child memebers) the specified CSSValue to this CSSValue instance.
Public Method | Equals | Override of System.Object.Equals(). Checks for value equality of the Unit and actual Value contained in this object.
Public Method | GetColorValue | Returns the current color value as a Color object. If the current unit type is string it will be converted using ColorTranslator.FromHtml(). If the current value is a Color it is returned directly.
Public Method | GetFloatValue | Returns a value as a float.
Public Method | GetHashCode | Provides a hashcode by XORing the Unit.GetHashCode() and {value}.GetHashCode().
Public Method | GetIntValue | Returns an integer value.
Public Method | GetLengthPixels | Returns a length value in pixel units.
Public Method | GetLengthTwips | Returns a length value in twip units.
Public Method | GetPercentValue | Returns the current percent value as a float.
Public Method | GetStringValue | Returns the current string value.
Public Method | IsAngularUnit | Returns true if the unit type is currently a valid Angle unit.
Public Method | IsColorUnit | Returns true if the unit type is current a valid color unit (eCSSUnit.Color_Hex or eCSSUnit.Color_Name or eCSSUnit.Color_RGBFunc or eCSSUnit.Color_System).
Public Method | IsFixedLengthUnit | Returns true if the unit type is currently a valid fixed length unit.
Public Method | IsFrequencyUnit | Returns true if the current unit type is a valid Frequency unit.
Public Method | IsLengthUnit | Returns true if the unit type is currently a valid length unit (fixed or relative).
Public Method | IsRelativeLengthUnit | Returns true if the unit type is currently a valid relative length unit.
Public Method | IsTimeUnit | Returns true if the current unit type is a valid time unit.
Public Method | Reset | Resets this current value. Sets all value members to their appropriate empty equivelent (numbers are set to 0), and sets the current Unit type to eCSSUnit.Null.
Public Method | SetAutoValue | Specifies that this CSSValue's value is the CSS keyword 'auto'.
Public Method | SetColorValue | Specifies this class's current value as a System.Drawing.Color object. Will set the Unit value to eCSSUnit.Color.
Public Method | SetFloatValue | Specifies this current value as a float.
Public Method | SetInheritValue | Indicates that this value is not null, not none, but should be inherited from the parent object of the object who's style this value is applied to. In CSS this is the default value for many *child* elements's (but certainly not all) style properties who's style is not specified.
Public Method | SetIntValue | Specifies the value as an integer.
Public Method | SetNoneValue | Sets this class's value to the special CSS value 'none' (e.g. border properties, background-image, display, etc...).
Public Method | SetNormalValue | Sets this class'es value to the special CSS value 'normal'. (e.g. font-style, font-variant, font-weight, word-spacing, letter-spacing, line-height).
Public Method | SetPercentValue | Specifies the value as a percent.
Public Method | SetStringValue | Specifies this class's current value as a string.
Public Method | ToDebugString | Writes out the current unit type and value in a string formatted appropriately for debugging purposes.
Public Method | ToString | Writes out this class's current value in string form.
Top

Public Operators

public Operator Equality | After checking arguments for null, uses valA.Equals(valB). If either argument is null, the return will be false.
public Operator Inequality | After checking both arguments for null, uses !valA.Equals(valB). If either argument is null, true will be returned.
Top

See Also

Reference

CSSValue Structure
DDCssLib Namespace


CSSValue Constructor

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : CSSValue Constructor

Glossary Item Box

Overload List

Overload | Description
CSSValue Constructor(eCSSUnit) | Constructs the class with the specified unit type.
CSSValue Constructor(Int32,eCSSUnit) | Constructs the class with the specified unit type, and integer value.
CSSValue Constructor(Single,eCSSUnit) | Constructs the class with the specified unit type, and value.
CSSValue Constructor(String,eCSSUnit) | Constructs the class with the specified unit type, and string value.
CSSValue Constructor(eCSSUnit,Color,String) | Constructs the class with the specified color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


CSSValue Constructor(eCSSUnit)

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor(eCSSUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure > CSSValue Constructor : CSSValue Constructor(eCSSUnit)

aUnit

Glossary Item Box

Constructs the class with the specified unit type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aUnit As eCSSUnit _
)
C#
public CSSValue(
   eCSSUnit aUnit
)

Parameters

aUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members
Overload List


CSSValue Constructor(Int32,eCSSUnit)

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor(Int32,eCSSUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure > CSSValue Constructor : CSSValue Constructor(Int32,eCSSUnit)

aValue
The integer value to construct the class with.
aUnit
The unit type to construct the class with. Shold be Integer or Enumerated.

Glossary Item Box

Constructs the class with the specified unit type, and integer value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aValue As Integer, _
   ByVal aUnit As eCSSUnit _
)
C#
public CSSValue(
   int aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The integer value to construct the class with.
aUnit
The unit type to construct the class with. Shold be Integer or Enumerated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members
Overload List


CSSValue Constructor(Single,eCSSUnit)

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor(Single,eCSSUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure > CSSValue Constructor : CSSValue Constructor(Single,eCSSUnit)

aValue
The value to construct the class with.
aUnit
The unit type to construct the class with. Should be eCSSUnit.Percent.

Glossary Item Box

Constructs the class with the specified unit type, and value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aValue As Single, _
   ByVal aUnit As eCSSUnit _
)
C#
public CSSValue(
   float aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The value to construct the class with.
aUnit
The unit type to construct the class with. Should be eCSSUnit.Percent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members
Overload List


CSSValue Constructor(String,eCSSUnit)

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor(String,eCSSUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure > CSSValue Constructor : CSSValue Constructor(String,eCSSUnit)

aValue
The string value to construct the class with.
aUnit
The unit type to construct the class with. Should be eCSSUnit.String, or eCSSUnit.Counters

Glossary Item Box

Constructs the class with the specified unit type, and string value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aValue As String, _
   ByVal aUnit As eCSSUnit _
)
C#
public CSSValue(
   string aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The string value to construct the class with.
aUnit
The unit type to construct the class with. Should be eCSSUnit.String, or eCSSUnit.Counters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members
Overload List


CSSValue Constructor(eCSSUnit,Color,String)

[image]
ActiveReports 19 .NET Edition
CSSValue Constructor(eCSSUnit,Color,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure > CSSValue Constructor : CSSValue Constructor(eCSSUnit,Color,String)

eColorUnit
The type of color being stored.
aValue
The Color value to construct the class with.
sOriginalSyntax
The way that the color value should be outputed when outputed as a string.

Glossary Item Box

Constructs the class with the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal eColorUnit As eCSSUnit, _
   ByVal aValue As Color, _
   ByVal sOriginalSyntax As String _
)
C#
public CSSValue(
   eCSSUnit eColorUnit,
   Color aValue,
   string sOriginalSyntax
)

Parameters

eColorUnit
The type of color being stored.
aValue
The Color value to construct the class with.
sOriginalSyntax
The way that the color value should be outputed when outputed as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members
Overload List


CSSValue Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSValue Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValue Structure

Glossary Item Box

For a list of all members of this type, see CSSValue members.

Public Methods

 | Name | Description
Public Method | CopyFrom | Performs a "deep copy" (memebers and child memebers) the specified CSSValue to this CSSValue instance.
Public Method | Equals | Override of System.Object.Equals(). Checks for value equality of the Unit and actual Value contained in this object.
Public Method | GetColorValue | Returns the current color value as a Color object. If the current unit type is string it will be converted using ColorTranslator.FromHtml(). If the current value is a Color it is returned directly.
Public Method | GetFloatValue | Returns a value as a float.
Public Method | GetHashCode | Provides a hashcode by XORing the Unit.GetHashCode() and {value}.GetHashCode().
Public Method | GetIntValue | Returns an integer value.
Public Method | GetLengthPixels | Returns a length value in pixel units.
Public Method | GetLengthTwips | Returns a length value in twip units.
Public Method | GetPercentValue | Returns the current percent value as a float.
Public Method | GetStringValue | Returns the current string value.
Public Method | IsAngularUnit | Returns true if the unit type is currently a valid Angle unit.
Public Method | IsColorUnit | Returns true if the unit type is current a valid color unit (eCSSUnit.Color_Hex or eCSSUnit.Color_Name or eCSSUnit.Color_RGBFunc or eCSSUnit.Color_System).
Public Method | IsFixedLengthUnit | Returns true if the unit type is currently a valid fixed length unit.
Public Method | IsFrequencyUnit | Returns true if the current unit type is a valid Frequency unit.
Public Method | IsLengthUnit | Returns true if the unit type is currently a valid length unit (fixed or relative).
Public Method | IsRelativeLengthUnit | Returns true if the unit type is currently a valid relative length unit.
Public Method | IsTimeUnit | Returns true if the current unit type is a valid time unit.
Public Method | Reset | Resets this current value. Sets all value members to their appropriate empty equivelent (numbers are set to 0), and sets the current Unit type to eCSSUnit.Null.
Public Method | SetAutoValue | Specifies that this CSSValue's value is the CSS keyword 'auto'.
Public Method | SetColorValue | Specifies this class's current value as a System.Drawing.Color object. Will set the Unit value to eCSSUnit.Color.
Public Method | SetFloatValue | Specifies this current value as a float.
Public Method | SetInheritValue | Indicates that this value is not null, not none, but should be inherited from the parent object of the object who's style this value is applied to. In CSS this is the default value for many *child* elements's (but certainly not all) style properties who's style is not specified.
Public Method | SetIntValue | Specifies the value as an integer.
Public Method | SetNoneValue | Sets this class's value to the special CSS value 'none' (e.g. border properties, background-image, display, etc...).
Public Method | SetNormalValue | Sets this class'es value to the special CSS value 'normal'. (e.g. font-style, font-variant, font-weight, word-spacing, letter-spacing, line-height).
Public Method | SetPercentValue | Specifies the value as a percent.
Public Method | SetStringValue | Specifies this class's current value as a string.
Public Method | ToDebugString | Writes out the current unit type and value in a string formatted appropriately for debugging purposes.
Public Method | ToString | Writes out this class's current value in string form.
Top

See Also

Reference

CSSValue Structure
DDCssLib Namespace


CopyFrom Method

[image]
ActiveReports 19 .NET Edition
CopyFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : CopyFrom Method

aSource

Glossary Item Box

Performs a "deep copy" (memebers and child memebers) the specified CSSValue to this CSSValue instance.

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal aSource As CSSValue _
)
C#
public void CopyFrom(
   CSSValue aSource
)

Parameters

aSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : Equals Method

obj

Glossary Item Box

Override of System.Object.Equals(). Checks for value equality of the Unit and actual Value contained in this object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetColorValue Method

[image]
ActiveReports 19 .NET Edition
GetColorValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetColorValue Method

Glossary Item Box

Returns the current color value as a Color object. If the current unit type is string it will be converted using ColorTranslator.FromHtml(). If the current value is a Color it is returned directly.

Syntax

Visual Basic (Declaration)
Public Function GetColorValue() As Color
C#
public Color GetColorValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetFloatValue Method

[image]
ActiveReports 19 .NET Edition
GetFloatValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetFloatValue Method

Glossary Item Box

Returns a value as a float.

Syntax

Visual Basic (Declaration)
Public Function GetFloatValue() As Single
C#
public float GetFloatValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetHashCode Method

Glossary Item Box

Provides a hashcode by XORing the Unit.GetHashCode() and {value}.GetHashCode().

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetIntValue Method

[image]
ActiveReports 19 .NET Edition
GetIntValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetIntValue Method

Glossary Item Box

Returns an integer value.

Syntax

Visual Basic (Declaration)
Public Function GetIntValue() As Integer
C#
public int GetIntValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetLengthPixels Method

[image]
ActiveReports 19 .NET Edition
GetLengthPixels Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetLengthPixels Method

aPixelsPerTwip
The number of pixels per twip. This value will be used if a conversion from a device independent length unit (mm, cm, pica, etc...) is necessary. If the length value was originally specified as pixels, then this value will not be used.

Glossary Item Box

Returns a length value in pixel units.

Syntax

Visual Basic (Declaration)
Public Function GetLengthPixels( _
   ByVal aPixelsPerTwip As Single _
) As Single
C#
public float GetLengthPixels(
   float aPixelsPerTwip
)

Parameters

aPixelsPerTwip
The number of pixels per twip. This value will be used if a conversion from a device independent length unit (mm, cm, pica, etc...) is necessary. If the length value was originally specified as pixels, then this value will not be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetLengthTwips Method

[image]
ActiveReports 19 .NET Edition
GetLengthTwips Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetLengthTwips Method

aTwipsPerPixel
This value is necessary to convert a device independent length unit (mm, cm, inch, etc...) from the device dependent unit pixels. If the value was specified in a device independent unit, then this value will not be used.

Glossary Item Box

Returns a length value in twip units.

Syntax

Visual Basic (Declaration)
Public Function GetLengthTwips( _
   ByVal aTwipsPerPixel As Single _
) As Single
C#
public float GetLengthTwips(
   float aTwipsPerPixel
)

Parameters

aTwipsPerPixel
This value is necessary to convert a device independent length unit (mm, cm, inch, etc...) from the device dependent unit pixels. If the value was specified in a device independent unit, then this value will not be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetPercentValue Method

[image]
ActiveReports 19 .NET Edition
GetPercentValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetPercentValue Method

Glossary Item Box

Returns the current percent value as a float.

Syntax

Visual Basic (Declaration)
Public Function GetPercentValue() As Single
C#
public float GetPercentValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


GetStringValue Method

[image]
ActiveReports 19 .NET Edition
GetStringValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : GetStringValue Method

Glossary Item Box

Returns the current string value.

Syntax

Visual Basic (Declaration)
Public Function GetStringValue() As String
C#
public string GetStringValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsAngularUnit Method

[image]
ActiveReports 19 .NET Edition
IsAngularUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsAngularUnit Method

Glossary Item Box

Returns true if the unit type is currently a valid Angle unit.

Syntax

Visual Basic (Declaration)
Public Function IsAngularUnit() As Boolean
C#
public bool IsAngularUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsColorUnit Method

[image]
ActiveReports 19 .NET Edition
IsColorUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsColorUnit Method

Glossary Item Box

Returns true if the unit type is current a valid color unit (eCSSUnit.Color_Hex or eCSSUnit.Color_Name or eCSSUnit.Color_RGBFunc or eCSSUnit.Color_System).

Syntax

Visual Basic (Declaration)
Public Function IsColorUnit() As Boolean
C#
public bool IsColorUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsFixedLengthUnit Method

[image]
ActiveReports 19 .NET Edition
IsFixedLengthUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsFixedLengthUnit Method

Glossary Item Box

Returns true if the unit type is currently a valid fixed length unit.

Syntax

Visual Basic (Declaration)
Public Function IsFixedLengthUnit() As Boolean
C#
public bool IsFixedLengthUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsFrequencyUnit Method

[image]
ActiveReports 19 .NET Edition
IsFrequencyUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsFrequencyUnit Method

Glossary Item Box

Returns true if the current unit type is a valid Frequency unit.

Syntax

Visual Basic (Declaration)
Public Function IsFrequencyUnit() As Boolean
C#
public bool IsFrequencyUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsLengthUnit Method

[image]
ActiveReports 19 .NET Edition
IsLengthUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsLengthUnit Method

Glossary Item Box

Returns true if the unit type is currently a valid length unit (fixed or relative).

Syntax

Visual Basic (Declaration)
Public Function IsLengthUnit() As Boolean
C#
public bool IsLengthUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsRelativeLengthUnit Method

[image]
ActiveReports 19 .NET Edition
IsRelativeLengthUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsRelativeLengthUnit Method

Glossary Item Box

Returns true if the unit type is currently a valid relative length unit.

Syntax

Visual Basic (Declaration)
Public Function IsRelativeLengthUnit() As Boolean
C#
public bool IsRelativeLengthUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


IsTimeUnit Method

[image]
ActiveReports 19 .NET Edition
IsTimeUnit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : IsTimeUnit Method

Glossary Item Box

Returns true if the current unit type is a valid time unit.

Syntax

Visual Basic (Declaration)
Public Function IsTimeUnit() As Boolean
C#
public bool IsTimeUnit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : Reset Method

Glossary Item Box

Resets this current value. Sets all value members to their appropriate empty equivelent (numbers are set to 0), and sets the current Unit type to eCSSUnit.Null.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetAutoValue Method

[image]
ActiveReports 19 .NET Edition
SetAutoValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetAutoValue Method

Glossary Item Box

Specifies that this CSSValue's value is the CSS keyword 'auto'.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoValue()
C#
public void SetAutoValue()

Remarks

Used for margin-top, margin-right, margin-bottom, margin-left, margin, width, and height values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetColorValue Method

[image]
ActiveReports 19 .NET Edition
SetColorValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetColorValue Method

eColorUnit
aValue
The actual color value in System.Drawing.Color.
sOriginalSyntax
The way that the color value should be outputed when the CSS string is rebuilt.

Glossary Item Box

Specifies this class's current value as a System.Drawing.Color object. Will set the Unit value to eCSSUnit.Color.

Syntax

Visual Basic (Declaration)
Public Sub SetColorValue( _
   ByVal eColorUnit As eCSSUnit, _
   ByVal aValue As Color, _
   ByVal sOriginalSyntax As String _
)
C#
public void SetColorValue(
   eCSSUnit eColorUnit,
   Color aValue,
   string sOriginalSyntax
)

Parameters

eColorUnit
aValue
The actual color value in System.Drawing.Color.
sOriginalSyntax
The way that the color value should be outputed when the CSS string is rebuilt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetFloatValue Method

[image]
ActiveReports 19 .NET Edition
SetFloatValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetFloatValue Method

aValue
The value to store.
aUnit
The CSS unit type the value is in.

Glossary Item Box

Specifies this current value as a float.

Syntax

Visual Basic (Declaration)
Public Sub SetFloatValue( _
   ByVal aValue As Single, _
   ByVal aUnit As eCSSUnit _
)
C#
public void SetFloatValue(
   float aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The value to store.
aUnit
The CSS unit type the value is in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetInheritValue Method

[image]
ActiveReports 19 .NET Edition
SetInheritValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetInheritValue Method

Glossary Item Box

Indicates that this value is not null, not none, but should be inherited from the parent object of the object who's style this value is applied to. In CSS this is the default value for many *child* elements's (but certainly not all) style properties who's style is not specified.

Syntax

Visual Basic (Declaration)
Public Sub SetInheritValue()
C#
public void SetInheritValue()

Remarks

See CSS Level 1 Recomendation Section 1.3 Inheritance: http://www.w3.org/TR/REC-CSS1#inheritance An important statement in this section is the following: "Some style properties are not inherited from the parent element to the child element. Most often it is intuitive why this is not the case. E.g., the 'background' property does not inherit, but the parent element's background will shine through by default."

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetIntValue Method

[image]
ActiveReports 19 .NET Edition
SetIntValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetIntValue Method

aValue
The integer value to store.
aUnit
The CSS unit type the value is.

Glossary Item Box

Specifies the value as an integer.

Syntax

Visual Basic (Declaration)
Public Sub SetIntValue( _
   ByVal aValue As Integer, _
   ByVal aUnit As eCSSUnit _
)
C#
public void SetIntValue(
   int aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The integer value to store.
aUnit
The CSS unit type the value is.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetNoneValue Method

[image]
ActiveReports 19 .NET Edition
SetNoneValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetNoneValue Method

Glossary Item Box

Sets this class's value to the special CSS value 'none' (e.g. border properties, background-image, display, etc...).

Syntax

Visual Basic (Declaration)
Public Sub SetNoneValue()
C#
public void SetNoneValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetNormalValue Method

[image]
ActiveReports 19 .NET Edition
SetNormalValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetNormalValue Method

Glossary Item Box

Sets this class'es value to the special CSS value 'normal'. (e.g. font-style, font-variant, font-weight, word-spacing, letter-spacing, line-height).

Syntax

Visual Basic (Declaration)
Public Sub SetNormalValue()
C#
public void SetNormalValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetPercentValue Method

[image]
ActiveReports 19 .NET Edition
SetPercentValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetPercentValue Method

aValue
A percentage (0-100) value. According to CSS this value could range from negative to greater than 100.

Glossary Item Box

Specifies the value as a percent.

Syntax

Visual Basic (Declaration)
Public Sub SetPercentValue( _
   ByVal aValue As Single _
)
C#
public void SetPercentValue(
   float aValue
)

Parameters

aValue
A percentage (0-100) value. According to CSS this value could range from negative to greater than 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


SetStringValue Method

[image]
ActiveReports 19 .NET Edition
SetStringValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : SetStringValue Method

aValue
The string value to store.
aUnit
The CSS unit type of the value.

Glossary Item Box

Specifies this class's current value as a string.

Syntax

Visual Basic (Declaration)
Public Sub SetStringValue( _
   ByVal aValue As String, _
   ByVal aUnit As eCSSUnit _
)
C#
public void SetStringValue(
   string aValue,
   eCSSUnit aUnit
)

Parameters

aValue
The string value to store.
aUnit
The CSS unit type of the value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


ToDebugString Method

[image]
ActiveReports 19 .NET Edition
ToDebugString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : ToDebugString Method

Glossary Item Box

Writes out the current unit type and value in a string formatted appropriately for debugging purposes.

Syntax

Visual Basic (Declaration)
Public Function ToDebugString() As String
C#
public string ToDebugString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : ToString Method

Glossary Item Box

Writes out this class's current value in string form.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


CSSValue Structure Properties

[image]
ActiveReports 19 .NET Edition
CSSValue Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValue Structure

Glossary Item Box

For a list of all members of this type, see CSSValue members.

Public Properties

 | Name | Description
Public Property | Unit | Gets/sets the Unit value.
Top

See Also

Reference

CSSValue Structure
DDCssLib Namespace


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : Unit Property

Glossary Item Box

Gets/sets the Unit value.

Syntax

Visual Basic (Declaration)
Public Property Unit As eCSSUnit
C#
public eCSSUnit Unit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : Equality Operator

valA
valB

Glossary Item Box

After checking arguments for null, uses valA.Equals(valB). If either argument is null, the return will be false.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal valA As CSSValue, _
   ByVal valB As CSSValue _
) As Boolean
C#
public bool operator ==(
   CSSValue valA,
   CSSValue valB
)

Parameters

valA
valB

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValue Structure : Inequality Operator

valA
valB

Glossary Item Box

After checking both arguments for null, uses !valA.Equals(valB). If either argument is null, true will be returned.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal valA As CSSValue, _
   ByVal valB As CSSValue _
) As Boolean
C#
public bool operator !=(
   CSSValue valA,
   CSSValue valB
)

Parameters

valA
valB

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValue Structure
CSSValue Members


CSSValueList Structure

[image]
ActiveReports 19 .NET Edition
CSSValueList Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValueList Structure

Glossary Item Box

Used for making a linked list of CSSValue objects.

Object Model

CSSValueList Structure

Syntax

Visual Basic (Declaration)
Public Structure CSSValueList
   Inherits System.ValueType
C#
public struct CSSValueList : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
DDCssLib.CSSValueList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValueList Members
DDCssLib Namespace


CSSValueList Structure Members

[image]
ActiveReports 19 .NET Edition
CSSValueList Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValueList Structure

Glossary Item Box

The following tables list the members exposed by CSSValueList.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vValue | Value
Top

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSValueList Structure
DDCssLib Namespace


CSSValueList Structure Methods

[image]
ActiveReports 19 .NET Edition
CSSValueList Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValueList Structure

Glossary Item Box

For a list of all members of this type, see CSSValueList members.

Public Methods

 | Name | Description
Public Method | Reset | Resets this instance.
Top

See Also

Reference

CSSValueList Structure
DDCssLib Namespace


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValueList Structure : Reset Method

Glossary Item Box

Resets this instance.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValueList Structure
CSSValueList Members


CSSValueList Structure Fields

[image]
ActiveReports 19 .NET Edition
CSSValueList Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : CSSValueList Structure

Glossary Item Box

For a list of all members of this type, see CSSValueList members.

Public Fields

 | Name | Description
Public Field | m_oNext | Next
Public Field | m_vValue | Value
Top

See Also

Reference

CSSValueList Structure
DDCssLib Namespace


m_oNext Field

[image]
ActiveReports 19 .NET Edition
m_oNext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValueList Structure : m_oNext Field

Glossary Item Box

Next

Syntax

Visual Basic (Declaration)
Public m_oNext As Object
C#
public object m_oNext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValueList Structure
CSSValueList Members


m_vValue Field

[image]
ActiveReports 19 .NET Edition
m_vValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > CSSValueList Structure : m_vValue Field

Glossary Item Box

Value

Syntax

Visual Basic (Declaration)
Public m_vValue As CSSValue
C#
public CSSValue m_vValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CSSValueList Structure
CSSValueList Members


IStyleSheetRule Interface

[image]
ActiveReports 19 .NET Edition
IStyleSheetRule Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : IStyleSheetRule Interface

Glossary Item Box

Interface IStyleSheetRule

Syntax

Visual Basic (Declaration)
Public Interface IStyleSheetRule
C#
public interface IStyleSheetRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Members
DDCssLib Namespace


IStyleSheetRule Interface Members

[image]
ActiveReports 19 .NET Edition
IStyleSheetRule Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : IStyleSheetRule Interface

Glossary Item Box

The following tables list the members exposed by IStyleSheetRule.

Public Properties

 | Name | Description
Property | BackColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the CSS background-color property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.
Property | ClassName | Returns the classname this StyleSheetRule is identified by.
Property | CSSText | Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).
Property | DdCharset | Gets/sets the "ddo-char-set" value. This value seams to always be an integer, but old code used a string to store it.
Property | DdVerticalFont | Gets or sets the dd vertical font CSS property.
Property | Declaration | Gets/sets the CSSDeclaration object used by this style.
Property | Font | When get, it returns a System.Drawing.Font object based on the current font related CSS information. When set, it sets the font related CSS information based on the specified font.
Property | FontFamily | Sets/gets the font's family name as a string.
Property | FontSize | Sets/gets font size.
Property | FontStyle | Gets/sets the 'font-style' property of the style.
Property | FontUnit | Sets/gets font units.
Property | FontWeight | Gets/sets the 'font-weight' property of the style.
Property | ForeColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.
Property | Kinsoku | Gets/sets the 'ddo-enable-kinsoku' CSS property.
Property | ParentStyleSheet | Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.
Property | ParentStyleSheetRule | Gets or sets the parent style sheet rule.
Property | ShrinkToFit | When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.
Property | TextAlign | Gets/sets the 'text-align' CSS property.
Property | TextDecoration | Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked.
Property | TextJustify | Gets/sets 'text-justify' CSS property
Property | VerticalAlign | Gets/sets the 'vertical-align' CSS property.
Property | WhiteSpace | Gets/sets the 'white-space' CSS property.
Property | WrapMode | Gets/sets the 'ddo-wrap-mode' CSS property.
Top

See Also

Reference

IStyleSheetRule Interface
DDCssLib Namespace


IStyleSheetRule Interface Properties

[image]
ActiveReports 19 .NET Edition
IStyleSheetRule Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace : IStyleSheetRule Interface

Glossary Item Box

For a list of all members of this type, see IStyleSheetRule members.

Public Properties

 | Name | Description
Property | BackColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the CSS background-color property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.
Property | ClassName | Returns the classname this StyleSheetRule is identified by.
Property | CSSText | Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).
Property | DdCharset | Gets/sets the "ddo-char-set" value. This value seams to always be an integer, but old code used a string to store it.
Property | DdVerticalFont | Gets or sets the dd vertical font CSS property.
Property | Declaration | Gets/sets the CSSDeclaration object used by this style.
Property | Font | When get, it returns a System.Drawing.Font object based on the current font related CSS information. When set, it sets the font related CSS information based on the specified font.
Property | FontFamily | Sets/gets the font's family name as a string.
Property | FontSize | Sets/gets font size.
Property | FontStyle | Gets/sets the 'font-style' property of the style.
Property | FontUnit | Sets/gets font units.
Property | FontWeight | Gets/sets the 'font-weight' property of the style.
Property | ForeColor | When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.
Property | Kinsoku | Gets/sets the 'ddo-enable-kinsoku' CSS property.
Property | ParentStyleSheet | Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.
Property | ParentStyleSheetRule | Gets or sets the parent style sheet rule.
Property | ShrinkToFit | When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.
Property | TextAlign | Gets/sets the 'text-align' CSS property.
Property | TextDecoration | Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked.
Property | TextJustify | Gets/sets 'text-justify' CSS property
Property | VerticalAlign | Gets/sets the 'vertical-align' CSS property.
Property | WhiteSpace | Gets/sets the 'white-space' CSS property.
Property | WrapMode | Gets/sets the 'ddo-wrap-mode' CSS property.
Top

See Also

Reference

IStyleSheetRule Interface
DDCssLib Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : BackColor Property

Glossary Item Box

When get, it returns a System.Drawing.Color object based on the curren CSS 'background-color' property. It may return Color.Empty if the CSS background-color property was not specified in the CSS string. When set, it sets the CSS 'background-color' property based on the supplied color object.

Syntax

Visual Basic (Declaration)
Property BackColor As Color
C#
Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : ClassName Property

Glossary Item Box

Returns the classname this StyleSheetRule is identified by.

Syntax

Visual Basic (Declaration)
Property ClassName As String
C#
string ClassName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


CSSText Property

[image]
ActiveReports 19 .NET Edition
CSSText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : CSSText Property

Glossary Item Box

Sets/gets the CSSText string. When set any current declarations (style properties) will be cleared/reset, and the string will be parsed to form a new set of declarations (style properties).

Syntax

Visual Basic (Declaration)
Property CSSText As String
C#
string CSSText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


DdCharset Property

[image]
ActiveReports 19 .NET Edition
DdCharset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : DdCharset Property

Glossary Item Box

Gets/sets the "ddo-char-set" value. This value seams to always be an integer, but old code used a string to store it.

Syntax

Visual Basic (Declaration)
Property DdCharset As String
C#
string DdCharset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


DdVerticalFont Property

[image]
ActiveReports 19 .NET Edition
DdVerticalFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : DdVerticalFont Property

Glossary Item Box

Gets or sets the dd vertical font CSS property.

Syntax

Visual Basic (Declaration)
Property DdVerticalFont As ddVerticalFontStyles
C#
ddVerticalFontStyles DdVerticalFont {get; set;}

Property Value

The dd vertical font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


Declaration Property

[image]
ActiveReports 19 .NET Edition
Declaration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : Declaration Property

Glossary Item Box

Gets/sets the CSSDeclaration object used by this style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Declaration As CSSDeclaration
C#
CSSDeclaration Declaration {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : Font Property

Glossary Item Box

When get, it returns a System.Drawing.Font object based on the current font related CSS information. When set, it sets the font related CSS information based on the specified font.

Syntax

Visual Basic (Declaration)
Property Font As Font
C#
Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : FontFamily Property

Glossary Item Box

Sets/gets the font's family name as a string.

Syntax

Visual Basic (Declaration)
Property FontFamily As String
C#
string FontFamily {get; set;}

Remarks

Multiple comma seperated values can be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : FontSize Property

Glossary Item Box

Sets/gets font size.

Syntax

Visual Basic (Declaration)
Property FontSize As Single
C#
float FontSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : FontStyle Property

Glossary Item Box

Gets/sets the 'font-style' property of the style.

Syntax

Visual Basic (Declaration)
Property FontStyle As ddFontStyleTypes
C#
ddFontStyleTypes FontStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


FontUnit Property

[image]
ActiveReports 19 .NET Edition
FontUnit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : FontUnit Property

Glossary Item Box

Sets/gets font units.

Syntax

Visual Basic (Declaration)
Property FontUnit As GraphicsUnit
C#
GraphicsUnit FontUnit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : FontWeight Property

Glossary Item Box

Gets/sets the 'font-weight' property of the style.

Syntax

Visual Basic (Declaration)
Property FontWeight As ddFontWeightTypes
C#
ddFontWeightTypes FontWeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : ForeColor Property

Glossary Item Box

When get, it returns a System.Drawing.Color object based on the curren CSS 'color' property. It may return Color.Empty if the CSS color property was not specified in the CSS string. When set, it sets the CSS 'color' property based on the supplied color object.

Syntax

Visual Basic (Declaration)
Property ForeColor As Color
C#
Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


Kinsoku Property

[image]
ActiveReports 19 .NET Edition
Kinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : Kinsoku Property

Glossary Item Box

Gets/sets the 'ddo-enable-kinsoku' CSS property.

Syntax

Visual Basic (Declaration)
Property Kinsoku As ddKinsokuTypes
C#
ddKinsokuTypes Kinsoku {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


ParentStyleSheet Property

[image]
ActiveReports 19 .NET Edition
ParentStyleSheet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : ParentStyleSheet Property

Glossary Item Box

Returns the parent StyleSheet. The StyleSheet should be specified on creation of the instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property ParentStyleSheet As StyleSheet
C#
StyleSheet ParentStyleSheet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


ParentStyleSheetRule Property

[image]
ActiveReports 19 .NET Edition
ParentStyleSheetRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : ParentStyleSheetRule Property

Glossary Item Box

Gets or sets the parent style sheet rule.

Syntax

Visual Basic (Declaration)
Property ParentStyleSheetRule As IStyleSheetRule
C#
IStyleSheetRule ParentStyleSheetRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : ShrinkToFit Property

Glossary Item Box

When get, it returns a System.Boolean object based on the curren CSS property. When set, it sets the CSS property.

Syntax

Visual Basic (Declaration)
Property ShrinkToFit As ddShrinkToFitTypes
C#
ddShrinkToFitTypes ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : TextAlign Property

Glossary Item Box

Gets/sets the 'text-align' CSS property.

Syntax

Visual Basic (Declaration)
Property TextAlign As ddTextAlignTypes
C#
ddTextAlignTypes TextAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


TextDecoration Property

[image]
ActiveReports 19 .NET Edition
TextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : TextDecoration Property

Glossary Item Box

Gets/sets the 'text-decoration' property of the style. The Blink, Linethrough, Overline, and Underline values can be masked.

Syntax

Visual Basic (Declaration)
Property TextDecoration As ddTextDecorationTypes
C#
ddTextDecorationTypes TextDecoration {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : TextJustify Property

Glossary Item Box

Gets/sets 'text-justify' CSS property

Syntax

Visual Basic (Declaration)
Property TextJustify As ddTextJustifyTypes
C#
ddTextJustifyTypes TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : VerticalAlign Property

Glossary Item Box

Gets/sets the 'vertical-align' CSS property.

Syntax

Visual Basic (Declaration)
Property VerticalAlign As ddVerticalAlignTypes
C#
ddVerticalAlignTypes VerticalAlign {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


WhiteSpace Property

[image]
ActiveReports 19 .NET Edition
WhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : WhiteSpace Property

Glossary Item Box

Gets/sets the 'white-space' CSS property.

Syntax

Visual Basic (Declaration)
Property WhiteSpace As ddWhiteSpaceTypes
C#
ddWhiteSpaceTypes WhiteSpace {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > DDCssLib Namespace > IStyleSheetRule Interface : WrapMode Property

Glossary Item Box

Gets/sets the 'ddo-wrap-mode' CSS property.

Syntax

Visual Basic (Declaration)
Property WrapMode As ddWrapModeTypes
C#
ddWrapModeTypes WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetRule Interface
IStyleSheetRule Members


LocateCredentialsEventArgs Class

[image]
ActiveReports 19 .NET Edition
LocateCredentialsEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

Provides data for LocateCredentials event.

Object Model

LocateCredentialsEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateCredentialsEventArgs
   Inherits System.EventArgs
C#
public sealed class LocateCredentialsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateCredentialsEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Members
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
LocateCredentialsEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

The following tables list the members exposed by LocateCredentialsEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LocateCredentialsEventArgs Constructor | Initializes new instance of LocateCredentialsEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | DataSource | Gets the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top

See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
LocateCredentialsEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : LocateCredentialsEventArgs Constructor

dataSource
The data source to locate credentials for.
reportPath
The name of the report to locate credentials for.
promptText
The text of prompt of the locate credentials request.

Glossary Item Box

Initializes new instance of LocateCredentialsEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As DataSource, _
   ByVal reportPath As String, _
   ByVal promptText As String _
)
C#
public LocateCredentialsEventArgs(
   DataSource dataSource,
   string reportPath,
   string promptText
)

Parameters

dataSource
The data source to locate credentials for.
reportPath
The name of the report to locate credentials for.
promptText
The text of prompt of the locate credentials request.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateCredentialsEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LocateCredentialsEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

For a list of all members of this type, see LocateCredentialsEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource | Gets the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top

See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : DataSource Property

Glossary Item Box

Gets the data source to locate credentials for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As DataSource
C#
public DataSource DataSource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : Password Property

Glossary Item Box

Gets ot sets the password of the credentials to be located.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


PromptText Property

[image]
ActiveReports 19 .NET Edition
PromptText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : PromptText Property

Glossary Item Box

Gets the text of prompt of the locate credentials request.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PromptText As String
C#
public string PromptText {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


ReportPath Property

[image]
ActiveReports 19 .NET Edition
ReportPath Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : ReportPath Property

Glossary Item Box

Gets the name of the report to locate credentials for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportPath As String
C#
public string ReportPath {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


UserName Property

[image]
ActiveReports 19 .NET Edition
UserName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : UserName Property

Glossary Item Box

Gets ot sets the user name of the credentials to be located.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateDataSourceEventArgs Class

[image]
ActiveReports 19 .NET Edition
LocateDataSourceEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

Provides data for the LocateDataSource event.

Object Model

LocateDataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateDataSourceEventArgs
   Inherits System.EventArgs
C#
public sealed class LocateDataSourceEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateDataSourceEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
LocateDataSourceEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

The following tables list the members exposed by LocateDataSourceEventArgs.

Public Properties

 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LocateDataSourceEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

For a list of all members of this type, see LocateDataSourceEventArgs members.

Public Properties

 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Data Property

Glossary Item Box

The data returned by the event handler.

Syntax

Visual Basic (Declaration)
Public Property Data As Object
C#
public object Data {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


DataSet Property

[image]
ActiveReports 19 .NET Edition
DataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : DataSet Property

Glossary Item Box

Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSet As IDataSet
C#
public IDataSet DataSet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Parameters Property

Glossary Item Box

Gets the Parameters collection specified for a given report instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IReadOnlyList(Of DataParameter)
C#
public IReadOnlyList<DataParameter> Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Report Property

Glossary Item Box

Gets the Report that is trying to locate the data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


PageReport Class

[image]
ActiveReports 19 .NET Edition
PageReport Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

Represents the type of report on a page where none of the report controls can grow or shrink at run time.

Object Model

PageReport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageReport
   Inherits System.ComponentModel.Component
   Implements IReportComponentFactory
C#
public sealed class PageReport : System.ComponentModel.Component, IReportComponentFactory

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Members
GrapeCity.ActiveReports Namespace


PageReport Class Members

[image]
ActiveReports 19 .NET Edition
PageReport Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

The following tables list the members exposed by PageReport.

Public Constructors

 | Name | Description
Public Constructor | PageReport Constructor | Overloaded. Initializes a new instance of PageReport class.
Top

Public Properties

 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Document | Gets the instance of GrapeCity.ActiveReports.Document.PageDocument, which provides the necessary functions for the processing of a report.
Public Property | FontResolver | Gets or sets the font resolver.
Public Property | Report | Gets the current report definition object.
Public Property | ResourceLocator | Gets or sets the object responsible for resolving report resources.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the report definition language (RDLX) as a System.String in the report definition.
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


PageReport Constructor

[image]
ActiveReports 19 .NET Edition
PageReport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : PageReport Constructor

Glossary Item Box

Initializes a new instance of PageReport class.

Overload List

Overload | Description
PageReport Constructor() | Initializes a new instance of PageReport class.
PageReport Constructor(FileInfo) | Initializes a new instance of PageReport class using the specified report definition file.
PageReport Constructor(TextReader) | Initializes a new instance of PageReport class using the specified report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageReport Constructor()

[image]
ActiveReports 19 .NET Edition
PageReport Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor()

Glossary Item Box

Initializes a new instance of PageReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(FileInfo)

[image]
ActiveReports 19 .NET Edition
PageReport Constructor(FileInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(FileInfo)

reportDefinitionFile
The report definition (*.rdlx) file to load.

Glossary Item Box

Initializes a new instance of PageReport class using the specified report definition file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportDefinitionFile As FileInfo _
)
C#
public PageReport(
   FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.

Exceptions

Exception | Description
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceException | Thrown if the report definition cannot be loaded.
ReportException | Thrown if the specified file does not appear to be a properly formatted RDLX file, or if the report definition has the wrong xmlns specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(TextReader)

[image]
ActiveReports 19 .NET Edition
PageReport Constructor(TextReader)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(TextReader)

reportDefinitionReader
The report definition (*.rdlx) file to load.

Glossary Item Box

Initializes a new instance of PageReport class using the specified report definition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportDefinitionReader As TextReader _
)
C#
public PageReport(
   TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Class Methods

[image]
ActiveReports 19 .NET Edition
PageReport Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

For a list of all members of this type, see PageReport members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the report definition language (RDLX) as a System.String in the report definition.
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


CreateFromMaster Method

[image]
ActiveReports 19 .NET Edition
CreateFromMaster Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : CreateFromMaster Method

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Overload List

Overload | Description
CreateFromMaster(Uri) | Creates blank report with all of the content placeholders from specified master report.
CreateFromMaster(String,ResourceLocator) | Creates blank report with all of the content placeholders from specified master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


CreateFromMaster(Uri) Method

[image]
ActiveReports 19 .NET Edition
CreateFromMaster(Uri) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(Uri) Method

masterUri
The Uri to the master report.

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateFromMaster( _
   ByVal masterUri As Uri _
) As PageReport
C#
public static PageReport CreateFromMaster(
   Uri masterUri
)

Parameters

masterUri
The Uri to the master report.

Return Value

An object of PageReport that has been created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


CreateFromMaster(String,ResourceLocator) Method

[image]
ActiveReports 19 .NET Edition
CreateFromMaster(String,ResourceLocator) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(String,ResourceLocator) Method

masterName
The master report name.
resourceLocator
The resource locator.

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateFromMaster( _
   ByVal masterName As String, _
   ByVal resourceLocator As ResourceLocator _
) As PageReport
C#
public static PageReport CreateFromMaster(
   string masterName,
   ResourceLocator resourceLocator
)

Parameters

masterName
The master report name.
resourceLocator
The resource locator.

Return Value

An object of PageReport that has been created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Initialize Method

[image]
ActiveReports 19 .NET Edition
Initialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Initialize Method

Glossary Item Box

Allows post-initialization of the PageReport instance.

Syntax

Visual Basic (Declaration)
Public Sub Initialize()
C#
public void Initialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Load Method

Glossary Item Box

Loads the specified report definition file.

Overload List

Overload | Description
Load(FileInfo) | Loads the report definition file.
Load(TextReader) | Loads the report definition file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Load(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
Load(FileInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(FileInfo) Method

reportDefinitionFile
The report definition (*.rdlx) file to load.

Glossary Item Box

Loads the report definition file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal reportDefinitionFile As FileInfo _
)
C#
public void Load(
   FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.

Exceptions

Exception | Description
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceException | Thrown if the report definition cannot be loaded.
ReportException | Thrown if the specified file does not appear to be a properly formatted RDLX file, or if the report definition has the wrong xmlns specified.

Example

C# Copy Code
PageReport pr = new PageReport();
FileInfo fInfo = new FileInfo("AnnualReport.rdlx");
pr.Load(fInfo);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Load(TextReader) Method

[image]
ActiveReports 19 .NET Edition
Load(TextReader) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(TextReader) Method

reportDefinitionReader
The report definition (*.rdlx) file to load.

Glossary Item Box

Loads the report definition file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal reportDefinitionReader As TextReader _
)
C#
public void Load(
   TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.

Exceptions

Exception | Description
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceException | Thrown if the report definition cannot be loaded.
ReportException | Thrown if the specified file does not appear to be a properly formatted RDLX file, or if the report definition has the wrong xmlns specified.

Example

C# Copy Code
using (StreamReader sr = new StreamReader(path))
{
PageReport report = new PageReport();
report.Load(sr);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Run Method

[image]
ActiveReports 19 .NET Edition
Run Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Run Method

Glossary Item Box

Runs the specified report definition file.

Syntax

Visual Basic (Declaration)
Public Sub Run()
C#
public void Run()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Save Method

Glossary Item Box

Saves the report definition to the specified file.

Overload List

Overload | Description
Save(FileInfo) | Saves the report definition to the specified file.
Save(XmlWriter) | Saves the report definition to the XmlWriter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Save(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
Save(FileInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(FileInfo) Method

file
A System.IO.FileInfo value indicating the save path.

Glossary Item Box

Saves the report definition to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal file As FileInfo _
)
C#
public void Save(
   FileInfo file
)

Parameters

file
A System.IO.FileInfo value indicating the save path.

Example

C# Copy Code
private void SaveReport(FileInfo fInfo, PageReport pageReport)
{
    pageReport.Save(fInfo);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Save(XmlWriter) Method

[image]
ActiveReports 19 .NET Edition
Save(XmlWriter) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(XmlWriter) Method

xmlWriter
A System.Xml.XmlWriter value contains the serialized report.

Glossary Item Box

Saves the report definition to the XmlWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal xmlWriter As XmlWriter _
)
C#
public void Save(
   XmlWriter xmlWriter
)

Parameters

xmlWriter
A System.Xml.XmlWriter value contains the serialized report.

Example

C# Copy Code
private void SaveReport(Stream outStream, PageReport pageReport)
{
    using (var writer = XmlWriter.Create(outStream))
    {
        pageReport.Save(writer);
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


ToRdlString Method

[image]
ActiveReports 19 .NET Edition
ToRdlString Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ToRdlString Method

Glossary Item Box

Returns the report definition language (RDLX) as a System.String in the report definition.

Syntax

Visual Basic (Declaration)
Public Function ToRdlString() As String
C#
public string ToRdlString()

Return Value

A System.String value of the report in RDL format.

Example

C# Copy Code
string rdlReport = report.ToRdlString();
var reader = new StringReader(rdlReport);
_designer.LoadReport(XmlReader.Create(reader), DesignerReportType.Rdl);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageReport Class Properties

[image]
ActiveReports 19 .NET Edition
PageReport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

For a list of all members of this type, see PageReport members.

Public Properties

 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Document | Gets the instance of GrapeCity.ActiveReports.Document.PageDocument, which provides the necessary functions for the processing of a report.
Public Property | FontResolver | Gets or sets the font resolver.
Public Property | Report | Gets the current report definition object.
Public Property | ResourceLocator | Gets or sets the object responsible for resolving report resources.
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


ConfigurationProvider Property

[image]
ActiveReports 19 .NET Edition
ConfigurationProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ConfigurationProvider Property

Glossary Item Box

Gets or sets the IConfigurationProvider associated with this ReportDefinition.

Syntax

Visual Basic (Declaration)
Public Property ConfigurationProvider As IConfigurationProvider
C#
public IConfigurationProvider ConfigurationProvider {get; set;}

Property Value

A GrapeCity.ActiveReports.Configuration.IConfigurationProvider associated with this report definition.

Remarks

The default value is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Document Property

Glossary Item Box

Gets the instance of GrapeCity.ActiveReports.Document.PageDocument, which provides the necessary functions for the processing of a report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PageDocument
C#
public PageDocument Document {get;}

Property Value

A GrapeCity.ActiveReports.Document.PageDocument instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


FontResolver Property

[image]
ActiveReports 19 .NET Edition
FontResolver Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : FontResolver Property

Glossary Item Box

Gets or sets the font resolver.

Syntax

Visual Basic (Declaration)
Public Property FontResolver As IFontResolver
C#
public IFontResolver FontResolver {get; set;}

Property Value

An object implementing IFontResolver.

Remarks

null means the default resolver.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Report Property

Glossary Item Box

Gets the current report definition object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report {get;}

Property Value

The current object of Report.

Remarks

The value is set in the constructor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ResourceLocator Property

Glossary Item Box

Gets or sets the object responsible for resolving report resources.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As ResourceLocator
C#
public ResourceLocator ResourceLocator {get; set;}

Property Value

A ResourceLocator object.

Remarks

The default value is an instance of a DefaultResourceLocator.

Example

VB.NET Copy Code
Private Sub ShowReport()
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx")
    reportData.Position = 0
    Dim reader As New StreamReader(reportData)
    Dim def As New PageReport(reader)
    def.ResourceLocator = New MyPicturesLocator()
    Dim runtime As New PageDocument(def)
    runtime.Parameters("PictureName").CurrentValue = listView.SelectedItems(0).Text
    runtime.Parameters("MimeType").CurrentValue = String.Format("image/{0}", listView.SelectedItems(0).Tag)
End Sub
C# Copy Code
private void ShowReport()
{
    Stream reportData = GetType().Assembly.GetManifestResourceStream(
            "GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx");
    reportData.Position = 0;
    StreamReader reader = new StreamReader(reportData);
    PageReport def = new PageReport(reader);
    def.ResourceLocator = new MyPicturesLocator();
    PageDocument runtime = new PageDocument(def);
    runtime.Parameters["PictureName"].CurrentValue = listView.SelectedItems[0].Text;
    runtime.Parameters["MimeType"].CurrentValue = string.Format("image/{0}", listView.SelectedItems[0].Tag);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageSettings Class

[image]
ActiveReports 19 .NET Edition
PageSettings Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

Specifies the page settings used to print the report document pages.

Object Model

PageSettings Class

Syntax

Visual Basic (Declaration)
Public Class PageSettings
C#
public class PageSettings

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
    this.PageSettings.DefaultPaperSize = true;
    this.PageSettings.DefaultPaperSource = true;
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
    this.PageSettings.Gutter = 1.0f;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = false;
    this.PageSettings.Orientation = PageOrientation.Default;
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
   Me.PageSettings.DefaultPaperSize = True
   Me.PageSettings.DefaultPaperSource = True
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
   Me.PageSettings.Gutter = 1.0F
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = False
   Me.PageSettings.Orientation = PageOrientation.Default
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Members
GrapeCity.ActiveReports Namespace


PageSettings Class Members

[image]
ActiveReports 19 .NET Edition
PageSettings Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

The following tables list the members exposed by PageSettings.

Public Constructors

 | Name | Description
Public Constructor | PageSettings Constructor | Initializes a new instance of the PageSettings class.
Top

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


PageSettings Constructor

[image]
ActiveReports 19 .NET Edition
PageSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PageSettings Constructor

Glossary Item Box

Initializes a new instance of the PageSettings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Methods

[image]
ActiveReports 19 .NET Edition
PageSettings Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Dispose() Method

Glossary Item Box

Releases the PageSettings object from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Properties

[image]
ActiveReports 19 .NET Edition
PageSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Collate Property

[image]
ActiveReports 19 .NET Edition
Collate Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Collate Property

Glossary Item Box

Gets or sets a value indicating whether the report document is collated.

Syntax

Visual Basic (Declaration)
Public Property Collate As PageSettings.PrinterCollate
C#
public PageSettings.PrinterCollate Collate {get; set;}

Property Value

A PrinterCollate enumeration value. Default is PrinterCollate.Default.

Remarks

Collating is performed only when the number of copies is greater than 1.

Setting the property to PrinterCollate.Collate will print a complete copy of the document before the first page of the next copy is printed. PrinterCollate.DontCollate will print each page by the number of copies specified before printing the next page. PrinterCollate.Default will use the printer's collate setting.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


DefaultPaperSize Property

[image]
ActiveReports 19 .NET Edition
DefaultPaperSize Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSize Property

Glossary Item Box

Gets or sets a value that specifies whether the report document should print to the printer's default paper size.

Syntax

Visual Basic (Declaration)
Public Property DefaultPaperSize As Boolean
C#
public bool DefaultPaperSize {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper size; otherwise, False. The default value is False.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSize = true;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSize = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


DefaultPaperSource Property

[image]
ActiveReports 19 .NET Edition
DefaultPaperSource Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSource Property

Glossary Item Box

Gets or sets a value that specifies whether the report document should print to the printer's default paper source.

Syntax

Visual Basic (Declaration)
Public Property DefaultPaperSource As Boolean
C#
public bool DefaultPaperSource {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper source; otherwise, False. The default value is False.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSource = true;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSource = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperSource Property


Duplex Property

[image]
ActiveReports 19 .NET Edition
Duplex Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Duplex Property

Glossary Item Box

Gets or sets the report document setting for double-sided printing.

Syntax

Visual Basic (Declaration)
Public Property Duplex As Duplex
C#
public Duplex Duplex {get; set;}

Property Value

A System.Drawing.Duplex enumeration value. The default value is determined by the value of System.Drawing.Printing.Duplex.Default.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Gutter Property

[image]
ActiveReports 19 .NET Edition
Gutter Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Gutter Property

Glossary Item Box

Gets or sets the amount of space between columns in inches.

Syntax

Visual Basic (Declaration)
Public Property Gutter As Single
C#
public float Gutter {get; set;}

Property Value

A float or Single value in inches used to determine the gutter width.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Gutter = 1.0f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Gutter = 1.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Margins Property

[image]
ActiveReports 19 .NET Edition
Margins Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Margins Property

Glossary Item Box

Gets or sets the default page margins of the report document.

Syntax

Visual Basic (Declaration)
Public Property Margins As Margins
C#
public Margins Margins {get; set;}

Property Value

A Margins object that specifies the top, bottom, left and right margin settings in inches.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
Margins Class


MirrorMargins Property

[image]
ActiveReports 19 .NET Edition
MirrorMargins Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : MirrorMargins Property

Glossary Item Box

Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.

Syntax

Visual Basic (Declaration)
Public Property MirrorMargins As Boolean
C#
public bool MirrorMargins {get; set;}

Property Value

Boolean. True if margins should be mirrored; otherwise, False. The default value is False.

Remarks

Use this property when printing in duplex and the left and right margins are not equal. This would alternate the margins between odd and even pages.

Example

Visual Basic Copy Code
Private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.5f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = True;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.5F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Orientation Property

[image]
ActiveReports 19 .NET Edition
Orientation Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Orientation Property

Glossary Item Box

Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Property Value

A GrapeCity.ActiveReports.Document.Section.PageOrientation enumeration value that specifies the orientation of the document pages.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Orientation = PageOrientation.Default;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Orientation = PageOrientation.Default
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PageOrientation Enumeration


PaperHeight Property

[image]
ActiveReports 19 .NET Edition
PaperHeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperHeight Property

Glossary Item Box

Gets or sets a value that specifies the height of a custom paper size.

Syntax

Visual Basic (Declaration)
Public Property PaperHeight As Single
C#
public float PaperHeight {get; set;}

Property Value

A float value that specifies the custom paper height in inches.

Remarks

Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperWidth Property


PaperKind Property

[image]
ActiveReports 19 .NET Edition
PaperKind Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperKind Property

Glossary Item Box

Gets or sets the kind of paper to be used to print the report.

Syntax

Visual Basic (Declaration)
Public Property PaperKind As PaperKind
C#
public PaperKind PaperKind {get; set;}

Property Value

A System.Drawing.Printing.PaperKind enumeration value that determines the paper size to use.

Remarks

To use custom paper sizes, you must set the PaperKind property to Custom and the PaperName property to a unique string.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperName = "My Paper";
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperName = "My Paper"
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PaperName Property

[image]
ActiveReports 19 .NET Edition
PaperName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperName Property

Glossary Item Box

Gets or sets the name of the type of paper.

Syntax

Visual Basic (Declaration)
Public Property PaperName As String
C#
public string PaperName {get; set;}

Property Value

String. The name of the type of custom paper.

Remarks

You can set the paper name only if the PaperKind property is set to Custom. To use custom paper sizes, you must set the PaperKind property to Custom and set the PaperName property to a unique string.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperHeight = 3;
    this.PageSettings.PaperName = "Logo Labels";
    this.PageSettings.PaperWidth = 5;

}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.PageSettings.PaperKind = Printing.PaperKind.Custom
    Me.PageSettings.PaperHeight = 3
    Me.PageSettings.PaperName = "Logo Labels"
    Me.PageSettings.PaperWidth = 5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


PaperSource Property

[image]
ActiveReports 19 .NET Edition
PaperSource Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSource Property

Glossary Item Box

Gets or sets the paper source used to print the report document pages.

Syntax

Visual Basic (Declaration)
Public Property PaperSource As PaperSourceKind
C#
public PaperSourceKind PaperSource {get; set;}

Property Value

A System.Drawing.Printing.PaperSourceKind enumeration value that specifies the paper source.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PaperSourceName Property

[image]
ActiveReports 19 .NET Edition
PaperSourceName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSourceName Property

Glossary Item Box

Gets the name of the paper source.

Syntax

Visual Basic (Declaration)
Public Property PaperSourceName As String
C#
public string PaperSourceName {get; set;}

Property Value

String. The name of the paper source.

Remarks

Call this property when the paper source needs to be displayed. The name of the paper source is generated based upon the PaperKind property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperSource Property


PaperWidth Property

[image]
ActiveReports 19 .NET Edition
PaperWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperWidth Property

Glossary Item Box

Gets or sets a value that specifies the width, in inches, of a custom paper size.

Syntax

Visual Basic (Declaration)
Public Property PaperWidth As Single
C#
public float PaperWidth {get; set;}

Property Value

A float value that specifies the custom paper width in inches.

Remarks

Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperHeight Property


PageSettings Class Events

[image]
ActiveReports 19 .NET Edition
PageSettings Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Changed Event

Glossary Item Box

Occurs when any of the PageSettings properties are changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


ReportDataException Class

[image]
ActiveReports 19 .NET Edition
ReportDataException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

This exception is thrown when an error occurs while connecting to the report's data source.

Object Model

ReportDataException Class

Syntax

Visual Basic (Declaration)
Public Class ReportDataException
   Inherits ReportException
C#
public class ReportDataException : ReportException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Members
GrapeCity.ActiveReports Namespace


ReportDataException Class Members

[image]
ActiveReports 19 .NET Edition
ReportDataException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

The following tables list the members exposed by ReportDataException.

Public Constructors

 | Name | Description
Public Constructor | ReportDataException Constructor | Overloaded. Initializes a new instance of the ReportDataException class.
Top

See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


ReportDataException Constructor

[image]
ActiveReports 19 .NET Edition
ReportDataException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : ReportDataException Constructor

Glossary Item Box

Initializes a new instance of the ReportDataException class.

Overload List

Overload | Description
ReportDataException Constructor() | Initializes a new instance of the ReportDataException class.
ReportDataException Constructor(String) | Initializes a new instance of the ReportDataException with the specified message.
ReportDataException Constructor(String,Exception) | Initializes a new instance of the ReportDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


ReportDataException Constructor()

[image]
ActiveReports 19 .NET Edition
ReportDataException Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor()

Glossary Item Box

Initializes a new instance of the ReportDataException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDataException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportDataException Constructor(String)

[image]
ActiveReports 19 .NET Edition
ReportDataException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor(String)

message

The message to display when the exception is thrown.

Glossary Item Box

Initializes a new instance of the ReportDataException with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public ReportDataException(
   string message
)

Parameters

message

The message to display when the exception is thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportDataException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
ReportDataException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor(String,Exception)

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the ReportDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public ReportDataException(
   string message,
   Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportException Class

[image]
ActiveReports 19 .NET Edition
ReportException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

This exception or one of its descendent classes is thrown when an error occurs while running the report.

Object Model

ReportException Class

Syntax

Visual Basic (Declaration)
Public Class ReportException
   Inherits System.ApplicationException
C#
public class ReportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException
GrapeCity.ActiveReports.ReportScriptException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Members
GrapeCity.ActiveReports Namespace


ReportException Class Members

[image]
ActiveReports 19 .NET Edition
ReportException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

The following tables list the members exposed by ReportException.

Public Constructors

 | Name | Description
Public Constructor | ReportException Constructor | Overloaded. Initializes a new instance of the ReportException class.
Top

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Top

See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ReportException Constructor

[image]
ActiveReports 19 .NET Edition
ReportException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ReportException Constructor

Glossary Item Box

Initializes a new instance of the ReportException class.

Overload List

Overload | Description
ReportException Constructor() | Initializes a new instance of the ReportException class.
ReportException Constructor(String) | Initializes a new instance of the ReportException with the specified message.
ReportException Constructor(String,Exception) | Initializes a new instance of the ReportException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ReportException Constructor()

[image]
ActiveReports 19 .NET Edition
ReportException Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor()

Glossary Item Box

Initializes a new instance of the ReportException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Constructor(String)

[image]
ActiveReports 19 .NET Edition
ReportException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor(String)

message

The message to display when the exception is thrown.

Glossary Item Box

Initializes a new instance of the ReportException with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public ReportException(
   string message
)

Parameters

message

The message to display when the exception is thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
ReportException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor(String,Exception)

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the ReportException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public ReportException(
   string message,
   Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

For a list of all members of this type, see ReportException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Top

See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorCode Property

Glossary Item Box

Error code for future detail processing.

Syntax

Visual Basic (Declaration)
Public Property ErrorCode As ReportProcessingError
C#
public ReportProcessingError ErrorCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ErrorData Property

[image]
ActiveReports 19 .NET Edition
ErrorData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorData Property

Glossary Item Box

Error data, depends on error code.

Syntax

Visual Basic (Declaration)
Public Property ErrorData As String()
C#
public string[] ErrorData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ReportScriptException Class

[image]
ActiveReports 19 .NET Edition
ReportScriptException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

The ReportScriptException is thrown when an error occurs in the report scripting code or any of the report's calculated DataField expressions.

Object Model

ReportScriptException Class

Syntax

Visual Basic (Declaration)
Public Class ReportScriptException
   Inherits ReportException
C#
public class ReportScriptException : ReportException

Remarks

You should catch this exception and inspect the InnerException property to diagnose the location and type of the error that caused the exception.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportScriptException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Members
GrapeCity.ActiveReports Namespace
MESCIUS.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Class Members

[image]
ActiveReports 19 .NET Edition
ReportScriptException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

The following tables list the members exposed by ReportScriptException.

Public Constructors

 | Name | Description
Public Constructor | ReportScriptException Constructor | Overloaded. Initializes a new instance of the ReportScriptException class.
Top

See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
MESCIUS.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Constructor

[image]
ActiveReports 19 .NET Edition
ReportScriptException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : ReportScriptException Constructor

Glossary Item Box

Initializes a new instance of the ReportScriptException class.

Overload List

Overload | Description
ReportScriptException Constructor() | Initializes a new instance of the ReportScriptException class.
ReportScriptException Constructor(String) | Initializes a new instance of the ReportScriptException with the specified message.
ReportScriptException Constructor(String,Exception) | Initializes a new instance of the ReportScriptException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


ReportScriptException Constructor()

[image]
ActiveReports 19 .NET Edition
ReportScriptException Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor()

Glossary Item Box

Initializes a new instance of the ReportScriptException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportScriptException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


ReportScriptException Constructor(String)

[image]
ActiveReports 19 .NET Edition
ReportScriptException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor(String)

message

The message to display when the exception is thrown.

Glossary Item Box

Initializes a new instance of the ReportScriptException with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public ReportScriptException(
   string message
)

Parameters

message

The message to display when the exception is thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


ReportScriptException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
ReportScriptException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor(String,Exception)

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the ReportScriptException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public ReportScriptException(
   string message,
   Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


SectionCollection Class

[image]
ActiveReports 19 .NET Edition
SectionCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

Represents a collection of all sections (Section objects) in the report layout.

Object Model

SectionCollection Class

Syntax

Visual Basic (Declaration)
Public Class SectionCollection
   Inherits System.Collections.CollectionBase
C#
public class SectionCollection : System.Collections.CollectionBase

Remarks

The collection provides access to the removal or addition of sections, as well as access to the individual sections within the report. You can use the collection to create dynamic reports at run time.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Members
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Members

[image]
ActiveReports 19 .NET Edition
SectionCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

The following tables list the members exposed by SectionCollection.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified GrapeCity.ActiveReports.Extensibility.Layout. ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Methods

[image]
ActiveReports 19 .NET Edition
SectionCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified GrapeCity.ActiveReports.Extensibility.Layout. ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Add Method

Glossary Item Box

Adds the specified GrapeCity.ActiveReports.Extensibility.Layout.
ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) to the SectionCollection.

Overload List

Overload | Description
Add(SectionType,String) | Adds the specified GrapeCity.ActiveReports.Extensibility.Layout. ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) to the SectionCollection.
Add(Section) | Adds the specified section to the SectionCollection.

Remarks

When modifying the layout of a report, the Insert methods are easier to use for header/footer section pairs.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
GrapeCity.ActiveReports.Extensibility~GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection~SectionType


Add(SectionType,String) Method

[image]
ActiveReports 19 .NET Edition
Add(SectionType,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(SectionType,String) Method

type
GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) of the new section.
name
Name of the new section, must be unique within the report.

Glossary Item Box

Adds the specified GrapeCity.ActiveReports.Extensibility.Layout.
ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) to the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal type As SectionType, _
   ByVal name As String _
) As Section
C#
public Section Add(
   SectionType type,
   string name
)

Parameters

type
GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) of the new section.
name
Name of the new section, must be unique within the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Add(Section) Method

[image]
ActiveReports 19 .NET Edition
Add(Section) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(Section) Method

section

Specifies the Section object to be added in the collection.

Glossary Item Box

Adds the specified section to the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal section As Section _
) As Integer
C#
public int Add(
   Section section
)

Parameters

section

Specifies the Section object to be added in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Clear Method

Glossary Item Box

Remove all sections from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Contains Method

section

Specifies the Section object to be searched for in the collection.

Glossary Item Box

Determines whether the specified section object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal section As Section _
) As Boolean
C#
public bool Contains(
   Section section
)

Parameters

section

Specifies the Section object to be searched for in the collection.

Return Value

Boolean. Returns True if the section exists in the collection; otherwise, False.

Example

C# Copy Code
private void rpt_ReportEnd(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show(this.Sections.Contains(this.Sections["detail"]).ToString());
}
Visual Basic Copy Code
Private Sub rpt_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    MsgBox(Me.Sections.Contains(Me.Sections("Detail1")).ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : CopyTo Method

sections
The array containing the copied Sections.
index

The insertion index in the collection.

Glossary Item Box

Copies the Sections collection from the specified report to a Sections collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal sections() As Section, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Section[] sections,
   int index
)

Parameters

sections
The array containing the copied Sections.
index

The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Dispose Method

Glossary Item Box

Releases the section collection from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


IndexOf(Section) Method

[image]
ActiveReports 19 .NET Edition
IndexOf(Section) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : IndexOf(Section) Method

section

Specifies the Section object.

Glossary Item Box

Determines the specific index of the specified section in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal section As Section _
) As Integer
C#
public int IndexOf(
   Section section
)

Parameters

section

Specifies the Section object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Insert Method

Glossary Item Box

Inserts a section into the collection at the specified index.

Overload List

Overload | Description
Insert(Int32,Section) | Inserts a section at the specified index in the collection.
Insert(Int32,SectionType,String) | Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.

Example

C# Copy Code
GrapeCity.ActiveReports.ActiveReport rpt = New GrapeCity.ActiveReports.ActiveReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.ActiveReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Insert(Int32,Section) Method

[image]
ActiveReports 19 .NET Edition
Insert(Int32,Section) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,Section) Method

index
The zero-based index where the specified section should be inserted.
section
The Section to be inserted.

Glossary Item Box

Inserts a section at the specified index in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal section As Section _
)
C#
public void Insert(
   int index,
   Section section
)

Parameters

index
The zero-based index where the specified section should be inserted.
section
The Section to be inserted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Insert(Int32,SectionType,String) Method

[image]
ActiveReports 19 .NET Edition
Insert(Int32,SectionType,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,SectionType,String) Method

index
The zero-based index where the new section should be inserted.
type
GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) of the new section.of the section to insert.
name
Unique name of the new section.

Glossary Item Box

Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal type As SectionType, _
   ByVal name As String _
) As Section
C#
public Section Insert(
   int index,
   SectionType type,
   string name
)

Parameters

index
The zero-based index where the new section should be inserted.
type
GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection.SectionType (in GrapeCity.ActiveReports.Core.Rendering.dll) of the new section.of the section to insert.
name
Unique name of the new section.

Return Value

A section that was created and added into the collection.

Remarks

Report, Page and Group sections must be added in a header/footer pair. The InsertReportHF, InsertPageHF and InsertGroupHF ensure proper pairing of the header/footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List
InsertReportHF Method
InsertPageHF Method
InsertGroupHF Method


InsertGroupHF Method

[image]
ActiveReports 19 .NET Edition
InsertGroupHF Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertGroupHF Method

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number. Inserts a group header and a matching group footer into the SectionCollection.

Overload List

Overload | Description
InsertGroupHF() | Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
InsertGroupHF(String,String) | Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.

Remarks

The new sections are added at the inner level of the groups, immediately before and after the Detail section in the report layout.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertGroupHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertGroupHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
GroupHeader Class
GroupFooter Class
Section Class


InsertGroupHF() Method

[image]
ActiveReports 19 .NET Edition
InsertGroupHF() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF() Method

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertGroupHF()
C#
public void InsertGroupHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertGroupHF(String,String) Method

[image]
ActiveReports 19 .NET Edition
InsertGroupHF(String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF(String,String) Method

grHeaderName
Specifies the name of the Group Header section.
grFooterName
Specifies the name of the Page Footer section.

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertGroupHF( _
   ByVal grHeaderName As String, _
   ByVal grFooterName As String _
)
C#
public void InsertGroupHF(
   string grHeaderName,
   string grFooterName
)

Parameters

grHeaderName
Specifies the name of the Group Header section.
grFooterName
Specifies the name of the Page Footer section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertPageHF() Method

[image]
ActiveReports 19 .NET Edition
InsertPageHF() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertPageHF() Method

Glossary Item Box

Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.

Syntax

Visual Basic (Declaration)
Public Sub InsertPageHF()
C#
public void InsertPageHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


InsertReportHF() Method

[image]
ActiveReports 19 .NET Edition
InsertReportHF() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertReportHF() Method

Glossary Item Box

Inserts a report header and a matching report footer into the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Sub InsertReportHF()
C#
public void InsertReportHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Remove Method

Glossary Item Box

Removes the specified Section from the SectionCollection if it exists.

Overload List

Overload | Description
Remove(Section) | Removes the specified Section from the SectionCollection if it exists.
Remove(Int32) | Removes the Section at the specified index from the SectionCollection.

Remarks

You should always remove the matching header/footer section when removing either a header or a footer section. The Detail section cannot be removed from the collection.

Removing a section from the collection adjusts the index of the remaining sections.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections.Remove(0);
    rpt.Sections.Remove(3);
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections.Remove(0)
    rpt.Sections.Remove(3)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Remove(Section) Method

[image]
ActiveReports 19 .NET Edition
Remove(Section) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Section) Method

section
Section to be removed from the collection.

Glossary Item Box

Removes the specified Section from the SectionCollection if it exists.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal section As Section _
)
C#
public void Remove(
   Section section
)

Parameters

section
Section to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Remove(Int32) Method

[image]
ActiveReports 19 .NET Edition
Remove(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Int32) Method

index
Index of the Section to be removed.

Glossary Item Box

Removes the Section at the specified index from the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index
Index of the Section to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Properties

[image]
ActiveReports 19 .NET Edition
SectionCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Item Property

Glossary Item Box

Returns a reference to a Section in the SectionCollection using its index or unique name.

Overload List

Overload | Description
Item(Int32) | Gets the Section object at the specified indexed location in the SectionCollection.
Item(String) | Gets the Section object with the specified name in the SectionCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(Int32) Property

index
Index of the section to be returned.

Glossary Item Box

Gets the Section object at the specified indexed location in the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Section
C#
public Section Item(
   int index
) {get;}

Parameters

index
Index of the section to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(String) Property

name
Unique name of the Section to be returned.

Glossary Item Box

Gets the Section object with the specified name in the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Section
C#
public Section Item(
   string name
) {get;}

Parameters

name
Unique name of the Section to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Events

[image]
ActiveReports 19 .NET Edition
SectionCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Changed Event

Glossary Item Box

Occurs when the members of the SectionCollection have changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


SectionReport Class

[image]
ActiveReports 19 .NET Edition
SectionReport Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

The SectionReport class is the base class for all section reports. It is used to execute and render the report.

Object Model

SectionReport Class

Syntax

Visual Basic (Declaration)
Public Class SectionReport
   Inherits System.MarshalByRefObject
C#
public class SectionReport : System.MarshalByRefObject

Remarks

SectionReport can be customized using code/scripts in the report events.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.LoadLayout(System.Xml.XmlReader.Create("Report.rpx"));
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.SectionReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Members
GrapeCity.ActiveReports Namespace


SectionReport Class Members

[image]
ActiveReports 19 .NET Edition
SectionReport Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

The following tables list the members exposed by SectionReport.

Public Constructors

 | Name | Description
Public Constructor | SectionReport Constructor | Initialises a new instance of the SectionReport class.
Top

Public Properties

 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | CompatibilityMode | Gets or sets a value indicating whether the engine should use the legacy GDI/GDI+ rendering or the new cross-platform based rendering implementation.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~DataSource.html to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | FontResolver | Gets or sets the font resolver.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ResourceLocator | Gets or sets a value representing the implementation of the resource locator.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top

Public Methods

 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | Dispose | Releases the report instance from memory.
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddNamedItem.html method or code added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddCode.html method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top

Public Events

 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


SectionReport Constructor

[image]
ActiveReports 19 .NET Edition
SectionReport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SectionReport Constructor

Glossary Item Box

Initialises a new instance of the SectionReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SectionReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SectionReport Class Methods

[image]
ActiveReports 19 .NET Edition
SectionReport Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Methods

 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | Dispose | Releases the report instance from memory.
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddNamedItem.html method or code added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddCode.html method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


AddCode Method

[image]
ActiveReports 19 .NET Edition
AddCode Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddCode Method

script
Script code written in the specified report scripting language.

Glossary Item Box

Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.

Syntax

Visual Basic (Declaration)
Public Sub AddCode( _
   ByVal script As String _
)
C#
public void AddCode(
   string script
)

Parameters

script
Script code written in the specified report scripting language.

Remarks

This method is typically used when executing stand-alone reports that are not compiled into the application. Injected code allows the report to access features such as custom calculation functions and data access modules in the calling application.

Example

C# Copy Code
public string addThisCode()
{
    string sCode = "public string ShowACMessage()\"{return \"my Added Code\";}";
    return sCode;
}

private void rptAddCode_ReportStart(object sender, System.EventArgs eArgs)
{
    this.AddCode(addThisCode());
}
Visual Basic Copy Code
Public Function addThisCode() As String
    Dim sCode As String = "public string ShowACMessage()""{return ""my Added Code"";}"
    Return sCode
End Function

Private Sub rptAddCode_ReportStart(sender As Object, eArgs As System.EventArgs)
    Me.AddCode(addThisCode())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method


AddControlLicense Method

[image]
ActiveReports 19 .NET Edition
AddControlLicense Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddControlLicense Method

className
Licensed control's class name.
license
String containing the licensed control's license.

Glossary Item Box

Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.

Syntax

Visual Basic (Declaration)
Public Sub AddControlLicense( _
   ByVal className As String, _
   ByVal license As String _
)
C#
public void AddControlLicense(
   string className,
   string license
)

Parameters

className
Licensed control's class name.
license
String containing the licensed control's license.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


AddNamedItem Method

[image]
ActiveReports 19 .NET Edition
AddNamedItem Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddNamedItem Method

objectName
The name of the new object.
objectReference
The value of the new object.

Glossary Item Box

Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.

Syntax

Visual Basic (Declaration)
Public Sub AddNamedItem( _
   ByVal objectName As String, _
   ByVal objectReference As Object _
)
C#
public void AddNamedItem(
   string objectName,
   object objectReference
)

Parameters

objectName
The name of the new object.
objectReference
The value of the new object.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the objectName or objectReference is null.

Remarks

This method allows you to add objects such as data layer or business objects from the calling application into the report scripting context. For example, you might have an Order class that contains a method for computing sales tax. When you print the order you can pass an Order class instance to the report to allow you to call that method from the report script.

This method is typically used when running reports in stand-alone mode and not compiled into the application.

Example

C# Copy Code
//Add this code to the Class File
public class clsMyItem
{
      public clsMyItem()
      {
      }
      public string getMyItem()
      {
            return "Hello";
      }
}

//Add this code to the report
private void rptAddNamedItem_ReportStart(object sender, System.EventArgs eArgs)
{
      this.AddNamedItem("myItem", new clsMyItem());
}
Visual Basic Copy Code
'Add this code to the Class File
Public Class clsMyItem
      Public Function getMyItem() As String
            getMyItem = "Hello"
      End Function
End Class

'Add this code to the report
Private Sub rptAddNamedItem_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
      Me.AddNamedItem("myItem", New clsMyItem())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddCode Method


AddScriptReference Method

[image]
ActiveReports 19 .NET Edition
AddScriptReference Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddScriptReference Method

scriptRef
Name of the assembly to be added to the scripting run-time context.

Glossary Item Box

Adds a reference to the specified assembly to be loaded into the scripting run-time context.

Syntax

Visual Basic (Declaration)
Public Sub AddScriptReference( _
   ByVal scriptRef As String _
)
C#
public void AddScriptReference(
   string scriptRef
)

Parameters

scriptRef
Name of the assembly to be added to the scripting run-time context.

Remarks

ActiveReports loads assemblies that are referenced in the application. You can use this method to add additional assemblies to be used in scripting that are not part of the application running the report.

Example

C# Copy Code
private void runReport()
{
      SectionReport1 rpt = new SectionReport1();
      rpt.AddScriptReference("System.Data.dll");
      rpt.Run();
      this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub runReport()
      Dim rpt As New SectionReport1()
      rpt.AddScriptReference("System.Data.dll")
      rpt.Run()
      Me.viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method
AddCode Method


Cancel Method

[image]
ActiveReports 19 .NET Edition
Cancel Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Cancel Method

Glossary Item Box

Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.

Syntax

Visual Basic (Declaration)
Public Sub Cancel()
C#
public void Cancel()

Remarks

You can call this method based on a user's request or in a report event such as ReportStart to prevent printing a blank report if their data source did not return any records.

Example

C# Copy Code
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    if (this.DataSource==null)
    {
        this.Cancel();
    }
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    If Me.DataSource Is Nothing Then
        Me.Cancel()
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Stop Method


CmToInch Method

[image]
ActiveReports 19 .NET Edition
CmToInch Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CmToInch Method

value
The measurement in centimeters to be converted to inches.

Glossary Item Box

Converts value from centimeters to inches.

Syntax

Visual Basic (Declaration)
Public Shared Function CmToInch( _
   ByVal value As Single _
) As Single
C#
public static float CmToInch(
   float value
)

Parameters

value
The measurement in centimeters to be converted to inches.

Return Value

Single value representing the specified centimeters value in inches.

Remarks

ActiveReports uses inches for all coordinate and dimension properties. This method helps convert centimeter values to inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Left = SectionReport1.CmToInch(2);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.CmToInch(2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
InchToCm Method


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Dispose() Method

Glossary Item Box

Releases the report instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


InchToCm Method

[image]
ActiveReports 19 .NET Edition
InchToCm Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : InchToCm Method

value
Inches value to be converted to centimeters .

Glossary Item Box

Converts value from inches to centimeters.

Syntax

Visual Basic (Declaration)
Public Shared Function InchToCm( _
   ByVal value As Single _
) As Single
C#
public static float InchToCm(
   float value
)

Parameters

value
Inches value to be converted to centimeters .

Return Value

Single value representing the inches value in centimeters.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Label1.Left = SectionReport1.InchToCm(2);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.InchToCm(2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
CmToInch Method


LoadLayout Method

[image]
ActiveReports 19 .NET Edition
LoadLayout Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadLayout Method

Glossary Item Box

Retrieves a report XML layout (RPX) from a file, stream or resource.

Overload List

Overload | Description
LoadLayout(Type,String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(XmlReader) | Retrieves a report XML layout from an XmlReader and loads it into a report object.
LoadLayout(String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream,ArrayList) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport report = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
    report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
    report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
    report.LoadLayout(reader);
}
Visual Basic Copy Code
Dim report As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>...  ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
SaveLayout Method

Concepts

Scripting


LoadLayout(Type,String) Method

[image]
ActiveReports 19 .NET Edition
LoadLayout(Type,String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Type,String) Method

type
Type of stored resource.
resourceName
Name of the resource entry that contains the report XML layout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal type As Type, _
   ByVal resourceName As String _
)
C#
public void LoadLayout(
   Type type,
   string resourceName
)

Parameters

type
Type of stored resource.
resourceName
Name of the resource entry that contains the report XML layout.

Exceptions

Exception | Description
ReportException | Thrown if resourceName cannot loaded.

Remarks

Use LoadLayout(Stream) or LoadLayout(String) instead.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.LoadLayout(typeof(SectionReport), "resourceName");
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


LoadLayout(XmlReader) Method

[image]
ActiveReports 19 .NET Edition
LoadLayout(XmlReader) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(XmlReader) Method

reader
XmlReader object from which to retrieve the report's layout.

Glossary Item Box

Retrieves a report XML layout from an XmlReader and loads it into a report object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal reader As XmlReader _
)
C#
public void LoadLayout(
   XmlReader reader
)

Parameters

reader
XmlReader object from which to retrieve the report's layout.

Exceptions

Exception | Description
ReportException | Thrown if the reader is null.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
GrapeCity.ActiveReports.ActiveReport report = new GrapeCity.ActiveReports.ActiveReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
   report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
   report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
   report.LoadLayout(reader);
}
Visual Basic Copy Code
Dim report As New GrapeCity.ActiveReports.ActiveReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>... ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(String) Method

[image]
ActiveReports 19 .NET Edition
LoadLayout(String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(String) Method

fileName
Report layout (RPX) file name.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal fileName As String _
)
C#
public void LoadLayout(
   string fileName
)

Parameters

fileName
Report layout (RPX) file name.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.LoadLayout("Report.rpx");
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream) Method

[image]
ActiveReports 19 .NET Edition
LoadLayout(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream) Method

stream

A stream that contains a valid report XML layout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal stream As Stream _
)
C#
public void LoadLayout(
   Stream stream
)

Parameters

stream

A stream that contains a valid report XML layout.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
SectionReport sectionReport = new SectionReport();
using (XmlTextReader reader = new XmlTextReader("Report.rpx"))
{
    sectionReport.LoadLayout(reader);
}
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream,ArrayList) Method

[image]
ActiveReports 19 .NET Edition
LoadLayout(Stream,ArrayList) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream,ArrayList) Method

stream

A stream that contains a valid report XML layout.

errors

An array containing any errors that occur during LoadLayout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal stream As Stream, _
   ByRef errors As ArrayList _
)
C#
public void LoadLayout(
   Stream stream,
   out ArrayList errors
)

Parameters

stream

A stream that contains a valid report XML layout.

errors

An array containing any errors that occur during LoadLayout.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
SectionReport sectionReport = new SectionReport();
using (XmlTextReader reader = new XmlTextReader("Report.rpx"))
{
    sectionReport.LoadLayout(reader, out System.Collections.ArrayList error);
}
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles Method

[image]
ActiveReports 19 .NET Edition
LoadStyles Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadStyles Method

Glossary Item Box

Loads an external stylesheet to use with the report.

Overload List

Overload | Description
LoadStyles(String) | Loads an external stylesheet to use with the report.
LoadStyles(Stream) | Loads an external stylesheet to use with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members

How To

Use External Style Sheets


LoadStyles(String) Method

[image]
ActiveReports 19 .NET Edition
LoadStyles(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(String) Method

fileName
The name of the file that loads the style sheet.

Glossary Item Box

Loads an external stylesheet to use with the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStyles( _
   ByVal fileName As String _
)
C#
public void LoadStyles(
   string fileName
)

Parameters

fileName
The name of the file that loads the style sheet.

Exceptions

Exception | Description
System.Exception | Throws an error if no styles are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles(Stream) Method

[image]
ActiveReports 19 .NET Edition
LoadStyles(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(Stream) Method

inStream
The stream from which the external stylesheet is loaded.

Glossary Item Box

Loads an external stylesheet to use with the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStyles( _
   ByVal inStream As Stream _
)
C#
public void LoadStyles(
   Stream inStream
)

Parameters

inStream
The stream from which the external stylesheet is loaded.

Exceptions

Exception | Description
System.Exception | Throws an error if no styles are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


ResetScripts Method

[image]
ActiveReports 19 .NET Edition
ResetScripts Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetScripts Method

Glossary Item Box

Clears the script of any items added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddNamedItem.html method or code added using the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~AddCode.html method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.

Syntax

Visual Basic (Declaration)
Public Sub ResetScripts()
C#
public void ResetScripts()

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.LoadLayout(Application.StartupPath + "\\rptAddNamedItem.rpx");
    clsAddNamedItem m = new clsAddNamedItem();
    rpt.AddNamedItem("x", m);
    rpt.Run();
    this.arv.Document=rpt.Document;
    rpt.ResetScripts();
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.LoadLayout(Application.StartupPath & "\rptAddNamedItem.rpx")
    Dim m As New clsAddNamedItem
    rpt.AddNamedItem("x", m)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    rpt.ResetScripts()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddCode
AddNamedItem
AddScriptReference


ResetWatermark Method

[image]
ActiveReports 19 .NET Edition
ResetWatermark Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetWatermark Method

Glossary Item Box

Resets the watermark to its default value.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetWatermark()
C#
public virtual void ResetWatermark()

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ResetWatermark();
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ResetWatermark()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Restart Method

[image]
ActiveReports 19 .NET Edition
Restart Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Restart Method

Glossary Item Box

Resets the report data source and clears the pages collection.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
C#
public void Restart()

Remarks

This method is used to reset an existing report instance after modifying its data source or page settings so that it can be run again. Note that in order to run the report with the new settings, you must call the Run method after calling Restart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Run Method


Run Method

[image]
ActiveReports 19 .NET Edition
Run Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Run Method

Glossary Item Box

Starts the report processing.

Overload List

Overload | Description
Run() | Starts the report processing in blocked mode.
Run(Boolean) | Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.

Remarks

Once the report is completed, the Document property is set to the report output Document. You can use the Document to Print, Preview or Export the output.

Example

C# Copy Code
private void formReport_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.LoadDocument(rpt.Document);
}
Visual Basic Copy Code
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.LoadDocument(rpt.Document)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Document Property
Cancel Method
Stop Method


Run() Method

[image]
ActiveReports 19 .NET Edition
Run() Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run() Method

Glossary Item Box

Starts the report processing in blocked mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Run()
C#
public void Run()

Exceptions

Exception | Description
System.ComponentModel.LicenseException | Thrown if a component cannot be licensed.
ReportException | Thrown if something is wrong with the report structure.

Remarks

This method does not synchronize a viewer control's linked document until the report has finished processing.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.LoadDocument(rpt.Document);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.LoadDocument(rpt.Document)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List
Document Property


Run(Boolean) Method

[image]
ActiveReports 19 .NET Edition
Run(Boolean) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run(Boolean) Method

syncDocument
Set to True to synchronize a linked viewer control document with the report processing.

Glossary Item Box

Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Run( _
   ByVal syncDocument As Boolean _
)
C#
public void Run(
   bool syncDocument
)

Parameters

syncDocument
Set to True to synchronize a linked viewer control document with the report processing.

Exceptions

Exception | Description
System.ComponentModel.LicenseException | Thrown if a component cannot be licensed.
ReportException | Thrown if something is wrong with the report structure.

Remarks

If the report document is linked to a viewer control the report will synchronize the viewer display and load pages as soon as they have completed rendering.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run(True);
    viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run(True)
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveLayout Method

[image]
ActiveReports 19 .NET Edition
SaveLayout Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveLayout Method

Glossary Item Box

Saves a report's XML layout to a stream or file.

Overload List

Overload | Description
SaveLayout(XmlWriter) | Saves a report's XML layout to the specified XmlWriter.
SaveLayout(String) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.
SaveLayout(Stream) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Remarks

The SaveLayout(String) method uses the UTF-8 encoding, and the SaveLayout(Stream) method uses the UTF-16 encoding for saving.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
    ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
    ar.SaveLayout(writer);
}
Visual Basic Copy Code
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
    ar.SaveLayout(writer)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
LoadLayout Method

Concepts

Scripting


SaveLayout(XmlWriter) Method

[image]
ActiveReports 19 .NET Edition
SaveLayout(XmlWriter) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(XmlWriter) Method

writer
XmlWriter object where the report's layout is saved.

Glossary Item Box

Saves a report's XML layout to the specified XmlWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal writer As XmlWriter _
)
C#
public void SaveLayout(
   XmlWriter writer
)

Parameters

writer
XmlWriter object where the report's layout is saved.

Exceptions

Exception | Description
ReportException | Thrown if the writer is null.
System.Exception | Thrown if duplicate names are found in the report structure.

Remarks

You can use this method to save the report's layout to an XmlWriter object, then store it in a database or a resource file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
  ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
  ar.SaveLayout(writer);
}
Visual Basic Copy Code
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
   ar.SaveLayout(writer)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveLayout(String) Method

[image]
ActiveReports 19 .NET Edition
SaveLayout(String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(String) Method

fileName
Name of the file where the report's layout will be saved.

Glossary Item Box

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal fileName As String _
)
C#
public void SaveLayout(
   string fileName
)

Parameters

fileName
Name of the file where the report's layout will be saved.

Remarks

The SaveLayout(String) method uses the UTF-8 encoding when you save to a file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
private void saveRPX()
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX");
}
VB.NET Copy Code
Dim rpt As New SectionReport1()
Private Sub saveRPX()
    rpt.Run()
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


SaveLayout(Stream) Method

[image]
ActiveReports 19 .NET Edition
SaveLayout(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(Stream) Method

stream
Stream object where the report's layout will be saved.

Glossary Item Box

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal stream As Stream _
)
C#
public void SaveLayout(
   Stream stream
)

Parameters

stream
Stream object where the report's layout will be saved.

Remarks

You can use this method to save the report's layout as a stream, then store it in a database or a resource file.

The SaveLayout(Stream) method uses the UTF-16 encoding when you save to a stream.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
private void mnuPrintPreview_Click(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
    this.designer1.Report.SaveLayout(m_stream);
    m_stream.Position = 0;
    rpt.LoadLayout(m_stream);
    m_stream.Close();
    frmViewer frm = new frmViewer();
    frm.SetReport(rpt);
    frm.ShowDialog(this);
}
VB.NET Copy Code
Private Sub mnuPrintPreview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
    Handles mnuPrintPreview.Click
        Dim rpt As New GrapeCity.ActiveReports.SectionReport()
        Dim m_stream As New System.IO.MemoryStream()
        Me.Designer1.Report.SaveLayout(m_stream)
        m_stream.Position = 0
        rpt.LoadLayout(m_stream)
        m_stream.Close()
        Dim frm As New frmViewer()
        frm.SetReport(rpt)
        frm.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles Method

[image]
ActiveReports 19 .NET Edition
SaveStyles Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveStyles Method

Glossary Item Box

Saves a reports styles to an external stylesheet.

Overload List

Overload | Description
SaveStyles(String) | Saves a reports styles to an external stylesheet.
SaveStyles(Stream) | Saves a reports styles to an external stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SaveStyles(String) Method

[image]
ActiveReports 19 .NET Edition
SaveStyles(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(String) Method

fileName
The file name to save the report's Style Sheet to.

Glossary Item Box

Saves a reports styles to an external stylesheet.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveStyles( _
   ByVal fileName As String _
)
C#
public void SaveStyles(
   string fileName
)

Parameters

fileName
The file name to save the report's Style Sheet to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles(Stream) Method

[image]
ActiveReports 19 .NET Edition
SaveStyles(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(Stream) Method

outStream
The stream to which the external stylesheet is saved.

Glossary Item Box

Saves a reports styles to an external stylesheet.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveStyles( _
   ByVal outStream As Stream _
)
C#
public void SaveStyles(
   Stream outStream
)

Parameters

outStream
The stream to which the external stylesheet is saved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


Stop Method

[image]
ActiveReports 19 .NET Edition
Stop Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Stop Method

Glossary Item Box

Stops processing the report.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
C#
public void Stop()

Remarks

All rendered pages are retained in the report's Document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Cancel Method


SectionReport Class Properties

[image]
ActiveReports 19 .NET Edition
SectionReport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Properties

 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | CompatibilityMode | Gets or sets a value indicating whether the engine should use the legacy GDI/GDI+ rendering or the new cross-platform based rendering implementation.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~DataSource.html to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | FontResolver | Gets or sets the font resolver.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ResourceLocator | Gets or sets a value representing the implementation of the resource locator.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


CalculatedFields Property

[image]
ActiveReports 19 .NET Edition
CalculatedFields Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CalculatedFields Property

Glossary Item Box

Gets a FieldCollection object containing all of the calculated fields in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CalculatedFields As FieldCollection
C#
public FieldCollection CalculatedFields {get;}

Property Value

A GrapeCity.ActiveReports.Data.FieldCollection value, with calculated fields.

Remarks

SectionReport can calculate simple arithmetic formulas.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.LoadLayout(reportFilePath);
sectionReport.Document.Printer.PrinterName = String.Empty;
var calculated = new GrapeCity.ActiveReports.Data.Field();
calculated.DefaultValue = null;
calculated.FieldType = FieldTypeEnum.None;
calculated.Formula = "=number*2";
calculated.Name = "DoubleNumber";
calculated.Tag = null;
sectionReport.CalculatedFields.Add(calculated);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


CompatibilityMode Property

[image]
ActiveReports 19 .NET Edition
CompatibilityMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CompatibilityMode Property

Glossary Item Box

Gets or sets a value indicating whether the engine should use the legacy GDI/GDI+ rendering or the new cross-platform based rendering implementation.

Syntax

Visual Basic (Declaration)
Public Property CompatibilityMode As CompatibilityModes
C#
public CompatibilityModes CompatibilityMode {get; set;}

Property Value

A GrapeCity.ActiveReports.Document.CompatibilityModes value. Set the CompatibilityModes.CrossPlatform for cross-platform text/image rendering. Set the CompatibilityModes.GDI for GDI/GDI+ text/image rendering.

Remarks

The default value for the NET Framework is CompatibilityModes.GDI, while for other frameworks it is CompatibilityModes.CrossPlatform. The CompatibilityModes.GDI parameter is only compatible with the Windows operating system and is not suitable for ASP.NET Core. The CompatibilityModes.CrossPlatform setting is designed for cross-platform rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Culture Property

Glossary Item Box

Provides information on a specific culture, including its names and the writing system.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Property Value

A System.Globalization.CultureInfo value representing the information about a particular culture.

Remarks

The default value is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


CurrentPage Property

[image]
ActiveReports 19 .NET Edition
CurrentPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CurrentPage Property

Glossary Item Box

Returns the current page instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Page
C#
public Page CurrentPage {get;}

Property Value

A GrapeCity.ActiveReports.Document.Section.Page value that represents the current page instance.

Remarks

This property allows you to use primitive drawing methods or apply templates to report pages while the report is processing.

Example

C# Copy Code
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
Visual Basic Copy Code
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


DataMember Property

[image]
ActiveReports 19 .NET Edition
DataMember Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataMember Property

Glossary Item Box

Gets or sets the specified list in an GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReport~DataSource.html to which the report will bind.

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
C#
public string DataMember {get; set;}

Property Value

Unbound data source member name.

Remarks

Default is an empty string.

If a data source, such as a dataset, contains multiple lists, you must set the DataMember to a list contained in the data source. The ActiveReports built-in data sources always contain a single data source, hence do not require that this property be set.

Example

C# Copy Code
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
Visual Basic Copy Code
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSource Property

Glossary Item Box

Gets or sets the data source from which the report will retrieve data.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
C#
public object DataSource {get; set;}

Property Value

An object that functions as a data source.

Remarks

The data source can be set to any of the ActiveReports built-in data sources or to any of the following:

  • DataSet
  • DataTable
  • DataView
  • RowCollection

You cannot change the data source property settings after the report starts processing.

Example

C# Copy Code
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
Visual Basic Copy Code
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataMember Property


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Document Property

Glossary Item Box

Gets a reference to the report output Document object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As SectionDocument
C#
public SectionDocument Document {get;}

Property Value

Generated Document object, null if the report has not been executed.

Remarks

The SectionDocument class is in the GrapeCity.ActiveReports.Document assembly in the GrapeCity.ActiveReports.Document namespace.

Example

C# Copy Code
private void formReport_Load(object sender, System.EventArgs e)
{
    rptMain rpt = new rptMain();
    this.viewer1.Document = rpt.Document;
    rpt.Run();
}
Visual Basic Copy Code
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    Viewer1.Document = rpt.Document
    rpt.Run()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
GrapeCity.ActiveReports.Document~GrapeCity.ActiveReports.Document.SectionDocument


EnableScriptDebugging Property

[image]
ActiveReports 19 .NET Edition
EnableScriptDebugging Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : EnableScriptDebugging Property

Glossary Item Box

Allows to catch script exceptions in the debugger. The default value is False.

Syntax

Visual Basic (Declaration)
Public Property EnableScriptDebugging As Boolean
C#
public bool EnableScriptDebugging {get; set;}

Property Value

A System.Boolean value. true if the script exceptions should be caught in the debugger, otherwise false.

Remarks

The EnableScriptDebugging property should be set to True before the script code compilation, which is similar to setting it before calling the Run method in ActiveReports.

If EnableScriptDebugging is set to True, then the compiled code is stored to a .dll file in the temporary folder.

Note: Visual Studio does not support script debugging at design time preview of a report.

Example

C# Copy Code
public void SectionReport_ReportStart()
{
    // the following line of script code attaches the debugger to the script
    System.Diagnostics.Debugger.Launch();
}
Visual Basic Copy Code
Public Sub SectionReport_ReportStart()
   'the following line of script code attaches the debugger to the script
   System.Diagnostics.Debugger.Launch()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ExpressionErrorMessage Property

[image]
ActiveReports 19 .NET Edition
ExpressionErrorMessage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ExpressionErrorMessage Property

Glossary Item Box

Stops the reporting engine from throwing exceptions and instead displays the provided string.

Syntax

Visual Basic (Declaration)
Public Property ExpressionErrorMessage As String
C#
public string ExpressionErrorMessage {get; set;}

Property Value

String. The default value is null.

Remarks

If this property is not set and an expression can't be parsed, or if you get a divide-by-zero type exception, ActiveReports will throw a ReportScriptException and stop the report from running.

When this property is set to a valid string, the engine stops throwing exceptions and instead displays the specified string (like Excel). Set it to ### and try Sales/0 to test.

Persistence: There is a new attribute called "ExprError" in .rpx files.

Example

C# Copy Code
private void arViewer_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.ExpressionErrorMessage = "oops";
    rpt.Run();
    this.arViewer.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub arViewer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arViewer.Load
    Dim rpt As New SectionReport1()
    rpt.ExpressionErrorMessage = "oops"
    rpt.Run()
    Me.arViewer.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Fields Property

[image]
ActiveReports 19 .NET Edition
Fields Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Fields Property

Glossary Item Box

Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
C#
public FieldCollection Fields {get;}

Property Value

A GrapeCity.ActiveReports.Data.FieldCollection value, with data binding fields.

Remarks

ActiveReports initializes the collection with all the fields in the DataSource if any. You can add custom unbound fields to the collection in the DataInitialize event. This allows you to create custom calculated fields and bind the report sections and controls to fields not available through the data source but provided at run time in the FetchData event. This allows the report to bind to collections, arrays or any other custom data structure that your application handles.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
Visual Basic Copy Code
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event
FetchData Event


FontResolver Property

[image]
ActiveReports 19 .NET Edition
FontResolver Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : FontResolver Property

Glossary Item Box

Gets or sets the font resolver.

Syntax

Visual Basic (Declaration)
Public Property FontResolver As IFontResolver
C#
public IFontResolver FontResolver {get; set;}

Property Value

An object that implements IFontResolver.

Remarks

The null value represents the default resolver.

Example

C# Copy Code
public sealed class DirectoryFontResolver : GrapeCity.ActiveReports.IFontResolver
{
    static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
    static DirectoryFontResolver()
    {
        _fonts.RegisterDirectory(System.Environment.GetFolderPath(System.Environment.SpecialFolder.Fonts));
        _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
    }
    public static GrapeCity.ActiveReports.IFontResolver Instance = new DirectoryFontResolver();

    private DirectoryFontResolver() { }
    GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
    {
        var fonts = new GrapeCity.Documents.Text.FontCollection();
        var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
        if (font != null) fonts.Add(font);
        fonts.Add(_fonts.DefaultFont);
        return fonts;
    }
}
void InitReport()
{
    var sectionReport = new GrapeCity.ActiveReports.SectionReport();
    sectionReport.LoadLayout(reportFilePath);
    sectionReport.Document.Printer.PrinterName = String.Empty;
    sectionReport.FontResolver = new DirectoryFontResolver();
    viewer.LoadDocument(sectionReport);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


IsDirty Property

[image]
ActiveReports 19 .NET Edition
IsDirty Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : IsDirty Property

Glossary Item Box

Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.

Syntax

Visual Basic (Declaration)
Public Property IsDirty As Boolean
C#
public bool IsDirty {get; set;}

Property Value

A System.Boolean value. true if any changes have been made to the report layout since it was last saved; otherwise, false.

Remarks

This property is typically used by the End-User Report Designer control to determine whether the current report layout needs to be saved.

Example

NOTE: The following is incomplete code. You would need to add your own code to handle the user's answer via the MessageBox.
C# Copy Code
private void mnuExit_Click(object sender, System.EventArgs e)
{
    if (((GrapeCity.ActiveReports.SectionReport)this.reportdesigner.Report).IsDirty == true)
    {
        MessageBox.Show("Do you want to save your report?");
    }
    else
    {
        this.Close();
    }
}
Visual Basic Copy Code
Private Sub mnuExit_Click(sender As Object, e As System.EventArgs)
    If DirectCast(Me.reportdesigner.Report, GrapeCity.ActiveReports.SectionReport).IsDirty = True Then
        MessageBox.Show("Do you want to save your report?")
    Else
        Me.Close()
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


LayoutAction Property

[image]
ActiveReports 19 .NET Edition
LayoutAction Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LayoutAction Property

Glossary Item Box

Sets or returns a custom action following the rendering of the current record.

Syntax

Visual Basic (Declaration)
Public Property LayoutAction As LayoutAction
C#
public LayoutAction LayoutAction {get; set;}

Property Value

Current layout action. The default is LayoutAction.MoveLayout | LayoutAction.NextRecord | LayoutAction.PrintSection, which returns a value of 7.

  • PrintSection has a value of 1.
  • MoveLayout has a value of 2.
  • NextRecord has a value of 4.

Remarks

ActiveReports automatically performs the following actions for each record in the data source after each Detail section format:

  1. Prints the section.
  2. Moves the layout (sets the next print position for the rest of the report).
  3. Moves to the next record.

The LayoutAction property allows you to control which of these steps should be performed or omitted. Using a combination of layout actions when the report is executed can change a report's layout.

This property can be used only in the Detail section's Format event.

The following table shows the results of different combinations of LayoutActions

Value | Print | Layout | NextR | Description
7 | True | True | True | (Default) Move to next print location, get next record, and print data.
3 | True | True | False | Move to the next print location, don't advance to the next record, but print the data.
4 | False | False | True | Skip a record without leaving a blank space on the page.
6 | False | True | True | Skip a record and leave a blank space on the page.
2 | False | True | False | Leave a blank space without skipping a record.
5 | True | False | True | Print the next record on top of the current record (UnderlayNext).

Example

C# Copy Code
int counter=0;
private void detail_Format(object sender, System.EventArgs eArgs)
{
    //repeat each row five times
    counter = counter + 1;
    if (counter <= 4)
    {
        this.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
    }
    else
    {
        this.LayoutAction = GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.NextRecord|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
        counter = 0;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    'repeat each row five times
    Static counter As Integer
    counter = counter + 1
    If counter <= 4 Then
        Me.LayoutAction = 3
    Else
        Me.LayoutAction = 7
        counter = 0
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Format Event
LayoutAction Enumeration


MaxPages Property

[image]
ActiveReports 19 .NET Edition
MaxPages Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : MaxPages Property

Glossary Item Box

Sets or returns the maximum number of pages that the report will create.

Syntax

Visual Basic (Declaration)
Public Property MaxPages As Long
C#
public long MaxPages {get; set;}

Property Value

Maximum number of pages. The default value is 0, which specifies no page limit.

Exceptions

Exception | Description
System.ArgumentException | Throws if set value is out of range.

Remarks

ActiveReports will stop the report execution once the report Document reaches the set number of pages.

This property can be used to limit the number of output pages when running large reports and distributing the results over a slow connection. It can also be used to present a quick preview of a few pages in a long report.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.MaxPages = 2;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.MaxPages = 2
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Name Property

Glossary Item Box

Gets or sets the name of the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value representing the name of the report.

Exceptions

Exception | Description
System.Exception | Thrown if the set value is not a valid.

Remarks

Default value is empty string. It appears in several error messages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageNumber Property

Glossary Item Box

Returns the number of the current page being processed when a report is running.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Property Value

A System.Int32 value, representing the number of the current page.

Remarks

The default value is 0.

Example

C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Text=this.PageNumber.ToString();
}
Visual Basic Copy Code
Private Sub detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.textBox1.Text = Me.PageNumber
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageSettings Property

[image]
ActiveReports 19 .NET Edition
PageSettings Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageSettings Property

Glossary Item Box

Returns a reference to the current report's page settings.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As PageSettings
C#
public PageSettings PageSettings {get; set;}

Property Value

Default PageSettings object.

Remarks

Used to specify settings that modify the way the report's pages will be printed.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1()
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Parameters Property

Glossary Item Box

Returns a reference to the data source query parameters collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Property Value

An initialized Parameters collection.

Remarks

The parameters collection is automatically populated when the report is started. If parameters are specified in the report's DataSource, they will be added to the collection.

For example, setting your RecordSource to the following SQL adds "Order Date" and "Order ID" to the parameters collection.

"SELECT * FROM orders WHERE OrderDate >= #<%OrderDate|Enter Order date|1/1/1995%># AND OrderID > <%OrderID|OrderID%>"

You can set the parameter values before the report starts or allow ActiveReports to collect the values from the user at run time.

Note: Depending on your data source, you may need to add pound signs around the parameter syntax for dates (as in the "Order Date" example above) or apostrophes around the parameter syntax for strings, i.e. "SELECT * FROM Customers CustomerID = '<%CustomerID%>'"

Example

A GrapeCity.ActiveReports.SectionReportModel.ParameterCollection value that represents the reference to the collection of data source query parameters.
Paste into the Viewer Hyperlink event.
C# Copy Code
private void arv_HyperLink(object sender, GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs e)
    {
     SectionReport1 rpt = new SectionReport1();
     Form1 frm = new Form1();
     rpt.Parameters["customerID"].Value = e.HyperLink.ToString();
     rpt.Run();
     frm.arv.Document = rpt.Document;
     frm.ShowDialog(this);
 }
Paste into the Viewer Hyperlink event.
Visual Basic Copy Code
Private Sub arv_HyperLink(sender As Object, e As GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs) Handles arv.HyperLink
Dim rpt As New SectionReport1()
Dim frm As New Form1()
rpt.Parameters("customerID").Value = e.HyperLink.ToString()
rpt.Run()
frm.arv.Document = rpt.Document
frm.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


ParentReport Property

[image]
ActiveReports 19 .NET Edition
ParentReport Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParentReport Property

Glossary Item Box

Gets a reference to the parent report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentReport As SectionReport
C#
public SectionReport ParentReport {get;}

Property Value

ActiveReport (Reference to the parent report object).

Remarks

This property is available when the report is running as a subreport of another report.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark(((TextBox)(this.ParentReport.Sections["detail"].Controls["txtCategoryName"])).
        Text + "\\" + this.txtProductName.Text);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark(CType(Me.ParentReport.Sections("Detail1").Controls("txtCategoryName"),  _
        TextBox).Text + "\" + Me.txtProductName.Text)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PrintWidth Property

[image]
ActiveReports 19 .NET Edition
PrintWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintWidth Property

Glossary Item Box

Sets or returns the report's printable width in inches.

Syntax

Visual Basic (Declaration)
Public Property PrintWidth As Single
C#
public float PrintWidth {get; set;}

Property Value

The amount of physical space to which a report can print. The default value is 6.5 inches.

Remarks

If the margin widths are not taken into consideration when setting the print width, the report may become wider than the paper size. When this happens, a blank page will be printed out after each page in the report, or in the viewer, a vertical red dotted line will appear on the right-hand side of the page.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PageSettings Property


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResourceLocator Property

Glossary Item Box

Gets or sets a value representing the implementation of the resource locator.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As ResourceLocator
C#
public ResourceLocator ResourceLocator {get; set;}

Property Value

A ResourceLocator object.

Remarks

The default value is an instance of a DefaultResourceLocator.

Example

Resource locator implementation Resource locator assigning
C# Copy Code
internal sealed class MyPicturesLocator : GrapeCity.ActiveReports.ResourceLocator
{
    private const string UriSchemeMyImages = "MyPictures:";
    public override Resource GetResource(ResourceInfo resourceInfo)
    {
        Resource resource;
        Uri uri = new Uri(resourceInfo.Name);
        string picturePath = GetPath(resourceInfo.Name);
        MemoryStream stream = new MemoryStream();
        using (FileStream source = File.Open(picturePath, FileMode.Open))
        {
            source.CopyTo(stream);
        }
        stream.Position = 0;
        return new Resource(stream, uri);
    }

    private string GetPath(string resourceName)
    {
        string name = resourceName.Substring(UriSchemeMyImages.Length);
        string myPicturesPath = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures);
        return Path.Combine(myPicturesPath, name);
    }
}
C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.ResourceLocator = new MyPicturesLocator();
var xtr = new System.Xml.XmlTextReader(filePath);
sectionReport.LoadLayout(xtr);
sectionReport.Document.Printer.PrinterName = String.Empty;
sectionReport.Run();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Script Property

[image]
ActiveReports 19 .NET Edition
Script Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Script Property

Glossary Item Box

Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.

Syntax

Visual Basic (Declaration)
Public Property Script As String
C#
public string Script {get; set;}

Property Value

The current script code. The default value is an empty string.

Remarks

The Script property can be used to make modifications to the report outside the code written in the report's events. The script events run immediately after their matching ActiveReports code-behind events and take precedence over the code inside the project.

If reports with scripts are saved to XML, the scripts (unlike code-behind) are incorporated into the XML file. Changes can be made to the XML file scripts and then loaded back into a report project to show the changes. This allows reports to be modified without requiring the project to be recompiled.

When referencing the report in the script, use rpt instead of the report's name or "Me" or "this".

In order to reference a member of the report class using the "rpt" named object, the member has to be a public member. You can use a control's modifier property to change the generated code for a control from private to public.

If you plan to run the report from a stand-alone RPX file without the compiled code-behind class, your scripting code would have to reference the report class controls using the Controls collection instead of by name.

Scripts are compiled at run time using the language specified in the ScriptLanguage property.

Example

This snippet assumes that you have html in the RichTextBox, and that the Modifiers property of the RichTextBox is set to Public.
C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
{
    string sScript = string.Empty;
    SectionReport1 rpt = new SectionReport1();

    sScript += "public void ReportHeader_Format()";
    sScript += "{";
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;";
    sScript += "}";

    rpt.Script = sScript;
    rpt.Run();
    arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnScript.Click
    Dim sScript As String = String.Empty
    Dim rpt As New SectionReport1

    sScript += "public void ReportHeader_Format()"
    sScript += "{"
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;"
    sScript += "}"

    rpt.Script = sScript
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ScriptLanguage Property


ScriptLanguage Property

[image]
ActiveReports 19 .NET Edition
ScriptLanguage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ScriptLanguage Property

Glossary Item Box

Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.

Syntax

Visual Basic (Declaration)
Public Property ScriptLanguage As String
C#
public string ScriptLanguage {get; set;}

Property Value

String value that is the current scripting language. The default value is C#.

Remarks

When the ScriptLanguage is set, the script editor will use the specified scripting language. ActiveReports supports C# and VB.NET for run-time scripting.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.Document.Printer.PrinterName = String.Empty;
sectionReport.ScriptLanguage = "C#";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Script Property


Sections Property

[image]
ActiveReports 19 .NET Edition
Sections Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Sections Property

Glossary Item Box

Returns a reference to the report's sections collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sections As SectionCollection
C#
public SectionCollection Sections {get;}

Property Value

Sections collection.

Remarks

This property can be used to add or remove report sections at run time.

Example

C# Copy Code
float m_defaultHeight = .2f;
float m_defaultWidth = 4f;
float m_currentY = 0f;

private void constructReport()
{
    try
    {
        this.detail.CanGrow = true;
        this.detail.CanShrink = true;
        this.detail.KeepTogether = true;

        if(m_useGroups)
        {
            this.Sections.InsertGroupHF();
            ((GroupHeader)this.Sections["groupHeader1"]).DataField = "Country";
            this.Sections["groupHeader1"].BackColor = System.Drawing.Color.SlateBlue;
            this.Sections["groupHeader1"].CanGrow = true;
            this.Sections["groupHeader1"].CanShrink = true;
            ((GroupHeader)this.Sections["groupHeader1"]).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail;
            this.Sections["groupFooter1"].Height = 0;

            TextBox txt = new TextBox();
            txt.DataField = "Country";
            txt.Location = new System.Drawing.PointF(0f,0);
            txt.Width =2f;
            txt.Height = .3f;
            txt.Style = "font-weight: bold; font-size: 16pt;";
            this.Sections["groupHeader1"].Controls.Add(txt);

        }

        for(int i=0;i<m_arrayFields.Count;i++)
        {
            if(!m_useGroups || (m_useGroups && m_arrayFields[i].ToString() != "Country"))
            {
                Label lbl = new Label();
                lbl.Text = m_arrayFields[i].ToString() + ":";
                lbl.Location = new System.Drawing.PointF(0f,m_currentY);
                lbl.Width =.9f;
                lbl.Height = m_defaultHeight;
                this.detail.Controls.Add(lbl);

                TextBox txt = new TextBox();
                txt.DataField = m_arrayFields[i].ToString();
                txt.Location = new System.Drawing.PointF(1f,m_currentY);
                txt.Width =m_defaultWidth;
                txt.Height = m_defaultHeight;
                this.detail.Controls.Add(txt);

                m_currentY = m_currentY + m_defaultHeight;
            }
        }
    }
    catch(Exception ex)
    {
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message,"Project Error",System.Windows.Forms.MessageBoxButtons.OK,System.Windows.Forms.MessageBoxIcon.Error);
    }
}
Visual Basic Copy Code
Private Sub constructReport()
    Try
        Me.Detail1.CanGrow = True
        Me.Detail1.CanShrink = True
        Me.Detail1.KeepTogether = True
        If m_useGroups = True Then
            Me.Sections.InsertGroupHF()

            CType(Me.Sections("GroupHeader1"), GroupHeader).DataField = "CategoryID"
            Me.Sections("GroupHeader1").BackColor = System.Drawing.Color.SlateBlue
            Me.Sections("GroupHeader1").CanGrow = True
            Me.Sections("GroupHeader1").CanShrink = True
            CType(Me.Sections("GroupHeader1"), GroupHeader).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
            Me.Sections("GroupHeader1").Height = 0

            Dim txt As New TextBox()
            txt.DataField = "CatagoryID"
            txt.Location = New System.Drawing.PointF(0.0F, 0)
            txt.Width = 2.0F
            txt.Height = 0.3F
            txt.Style = "font-weight: bold; font-size: 16pt"
            Me.Sections("GroupHeader1").Controls.Add(txt)
        End If
        For i = 0 To m_arrayFields.Count - 1
           If (m_useGroups = False) Or (m_useGroups AndAlso m_arrayFields(i).ToString <> "CategoryID") Then

                Dim lbl As New Label()
                lbl.Text = m_arrayFields(i) + ":"
                lbl.Location() = New System.Drawing.PointF(0.0F, m_currentY)
                lbl.Width() = 0.9F
                lbl.Height = m_defaultHeight
                Me.Detail1.Controls.Add(lbl)

                Dim txt As New TextBox()
                txt.DataField = m_arrayFields(i)
                txt.Location = New System.Drawing.PointF(1.0F, m_currentY)
                txt.Width = m_defaultWidth
                txt.Height = m_defaultHeight
                Me.Detail1.Controls.Add(txt)
                If m_arrayFields(i) = "UnitPrice" Then
                    txt.OutputFormat = "$#.00"
                End If
                m_currentY = m_currentY + m_defaultHeight
            End If
        Next
    Catch ex As Exception
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message, "Project Error", System.Windows.Forms.MessageBoxButtons.OK, System.Windows.Forms.MessageBoxIcon.Error)
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members

Walkthroughs

Run Time Layouts


ShowParameterUI Property

[image]
ActiveReports 19 .NET Edition
ShowParameterUI Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ShowParameterUI Property

Glossary Item Box

Sets or returns whether or not the query parameters dialog box will appear when the report is run.

Syntax

Visual Basic (Declaration)
Public Property ShowParameterUI As Boolean
C#
public bool ShowParameterUI {get; set;}

Property Value

A System.Boolean value. true if the query parameters dialog is displayed when the report is run, otherwise false.

Remarks

Set this property to False if the report is a subreport that will take its parameter values from the parent report.

Example

C# Copy Code
private void rptChild_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ShowParameterUI = false;
}
Visual Basic Copy Code
Private Sub rptChild_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ShowParameterUI = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ParameterUIClosed Event


State Property

[image]
ActiveReports 19 .NET Edition
State Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : State Property

Glossary Item Box

Returns the current state of the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As SectionReport.ReportState
C#
public SectionReport.ReportState State {get;}

Property Value

Current ReportState.

Remarks

The possible values for this property are Running, Idle, or Completed.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    rpt.Run();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    rpt.Run()
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


StyleSheet Property

[image]
ActiveReports 19 .NET Edition
StyleSheet Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : StyleSheet Property

Glossary Item Box

Returns a collection of formatting styles used to format controls in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StyleSheet As StyleSheet
C#
public StyleSheet StyleSheet {get;}

Property Value

Predefined default styles collection.

Remarks

A collection of predefined standard styles.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


UserData Property

[image]
ActiveReports 19 .NET Edition
UserData Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : UserData Property

Glossary Item Box

Sets or returns a user-defined value.

Syntax

Visual Basic (Declaration)
Public Property UserData As Object
C#
public object UserData {get; set;}

Property Value

A System.Object value that refers to user string data.

Remarks

Values specified in this property are saved and loaded as part of the report layout. You can use this property to store information beyond what the report properties offer, much like the Tag property in Visual Basic. This property is only persisted as a string if the RPX is saved or loaded to file.

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.Document.Printer.PrinterName = String.Empty;
sectionReport.CompatibilityMode = GrapeCity.ActiveReports.Document.CompatibilityModes.CrossPlatform;
var ctl = new GrapeCity.ActiveReports.SectionReportModel.TextBox{Name = "text1"};
sectionReport.Sections.Add(new GrapeCity.ActiveReports.SectionReportModel.Detail{Name = "Details"});
sectionReport.Sections[0].Controls.Add(ctl);
sectionReport.ScriptLanguage = "C#";
sectionReport.Script = @"public void Detail_Format(){text1.Text = (string)rpt.UserData;}";
sectionReport.UserData = "Hello World!";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Version Property

[image]
ActiveReports 19 .NET Edition
Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Version Property

Glossary Item Box

Returns the product's version number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version {get;}

Property Value

A System.String value representing the version number of the product.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Watermark Property

[image]
ActiveReports 19 .NET Edition
Watermark Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Watermark Property

Glossary Item Box

Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.

Syntax

Visual Basic (Declaration)
Public Property Watermark As Image
C#
public Image Watermark {get; set;}

Property Value

Watermark image object. Default is null.

Remarks

Watermark properties must be specified before the report starts executing, preferably in the ReportStart event. The watermark will be clipped and centered on the page unless the WatermarkSizeMode and WatermarkAlignment are specified.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("C:\\DSCF2183.JPG").OpenRead());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("c:\DSCF2183.JPG").OpenRead())
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
WatermarkAlignment Property
WatermarkPrintOnPages Property
WatermarkSizeMode Property


WatermarkAlignment Property

[image]
ActiveReports 19 .NET Edition
WatermarkAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkAlignment Property

Glossary Item Box

Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.

Syntax

Visual Basic (Declaration)
Public Property WatermarkAlignment As PictureAlignment
C#
public PictureAlignment WatermarkAlignment {get; set;}

Property Value

PictureAlignment enumeration. The default value is PictureAlignment.Center.

Remarks

The watermark properties should be specified in or before the ReportStart event.

Example

Paste into the Viewer Load event.
C# Copy Code
SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("C:\\DSCF2183.JPG").OpenRead());
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight;
    rpt.Run();
    this.arv.Document = rpt.Document;
Paste into the Viewer Load event.
Visual Basic Copy Code
Dim rpt As New SectionReport1
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("c:\DSCF2183.JPG").OpenRead())
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkPrintOnPages Property

[image]
ActiveReports 19 .NET Edition
WatermarkPrintOnPages Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkPrintOnPages Property

Glossary Item Box

Sets or returns a value indicating the specific pages to which the watermark should be added.

Syntax

Visual Basic (Declaration)
Public Property WatermarkPrintOnPages As String
C#
public string WatermarkPrintOnPages {get; set;}

Property Value

String representing page or page range on which the watermark will be printed. Default is an empty string (all pages).

Remarks

The syntax can include a single page, page range or a combination of both. For example: 1, 5-8, 9, 10-12.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("C:\\DSCF2183.JPG").OpenRead());
    rpt.WatermarkPrintOnPages = "1,3-5,7";
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("c:\DSCF2183.JPG").OpenRead())
    rpt.WatermarkPrintOnPages = "1,3-5,7"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkSizeMode Property

[image]
ActiveReports 19 .NET Edition
WatermarkSizeMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkSizeMode Property

Glossary Item Box

Sets or returns how the watermark will be sized when the image is rendered on the page.

Syntax

Visual Basic (Declaration)
Public Property WatermarkSizeMode As SizeModes
C#
public SizeModes WatermarkSizeMode {get; set;}

Property Value

SizeModes enumeration. The default value is SizeModes.Clip.

Remarks

Watermark properties should be specified in the ReportStart event.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo(""C:\\DSCF2183.JPG"").OpenRead());
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("c:\DSCF2183.JPG").OpenRead()))
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SectionReport Class Events

[image]
ActiveReports 19 .NET Edition
SectionReport Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Events

 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


DataInitialize Event

[image]
ActiveReports 19 .NET Edition
DataInitialize Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataInitialize Event

Glossary Item Box

Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.

Syntax

Visual Basic (Declaration)
Public Event DataInitialize As EventHandler
C#
public event EventHandler DataInitialize

Remarks

Custom fields can be added to a bound report (one that uses the built-in data source to retrieve records) or an unbound report (one that does not depend on the data source to get its records).

In a bound report, the report's data source is initialized, opened and its fields are added to the Fields collection before the DataInitialize event is raised.

The DataInitialize event is raised only once unless you call the Restart() method.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
Visual Basic Copy Code
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
FetchData Event
Fields Property
DataSource Property
ReportStart Event

Concepts

Unbound Reporting
Sequence of Events


DataSourceChanged Event

[image]
ActiveReports 19 .NET Edition
DataSourceChanged Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSourceChanged Event

Glossary Item Box

Raised when the properties of the report's data source are modified.

Syntax

Visual Basic (Declaration)
Public Event DataSourceChanged As EventHandler
C#
public event EventHandler DataSourceChanged

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.Document.Printer.PrinterName = String.Empty;
sectionReport.DataSourceChanged += (sender, e) =>	label.Text = rpt.DataMember;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


FetchData Event

[image]
ActiveReports 19 .NET Edition
FetchData Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : FetchData Event

Glossary Item Box

Raised every time a new record is processed.

Syntax

Visual Basic (Declaration)
Public Event FetchData As SectionReport.FetchEventHandler
C#
public event SectionReport.FetchEventHandler FetchData

Event Data

The event handler receives an argument of type SectionReport.FetchEventArgs containing data related to this event. The following SectionReport.FetchEventArgs properties provide information specific to this event.

Property | Description
EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.

Remarks

This event is used to set the values of custom unbound fields that were added in the DataInitialize event.

ActiveReports does not null unbound field values before firing this event. The unbound field value is carried over so you should always set the values of all unbound fields in this event.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event

Concepts

Unbound Reporting
Sequence of Events


LocateCredentials Event

[image]
ActiveReports 19 .NET Edition
LocateCredentials Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LocateCredentials Event

Glossary Item Box

Occurs when the report needs to obtain data source credentials from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.LoadLayout(reportFilePath);
sectionReport.Document.Printer.PrinterName = String.Empty;
sectionReport.LocateCredentials += (s, args) =>
{
    if (args.Name == "MyDB")
    {
        args.UserName = "guest";
        args.Password = "12345";
    }
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


NoData Event

[image]
ActiveReports 19 .NET Edition
NoData Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : NoData Event

Glossary Item Box

Raised if the report's data source does not return any records and there is no data to be processed.

Syntax

Visual Basic (Declaration)
Public Event NoData As EventHandler
C#
public event EventHandler NoData

Remarks

This event is used either to cancel the report or to print a page with a message informing the user that the report did not return any records to print.

Example

C# Copy Code
private void SectionReport1_NoData(object sender, System.EventArgs eArgs)
{
    this.Cancel();
}
Visual Basic Copy Code
Private Sub SectionReport1_NoData(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.NoData
    Me.Cancel()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageEnd Event

[image]
ActiveReports 19 .NET Edition
PageEnd Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageEnd Event

Glossary Item Box

Raised after the report finishes rendering each page.

Syntax

Visual Basic (Declaration)
Public Event PageEnd As EventHandler
C#
public event EventHandler PageEnd

Remarks

This event is used to update any page level variables when running an unbound report.

Example

C# Copy Code
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
Visual Basic Copy Code
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageStart Event

[image]
ActiveReports 19 .NET Edition
PageStart Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageStart Event

Glossary Item Box

Raised before the report renders any output to a new page.

Syntax

Visual Basic (Declaration)
Public Event PageStart As EventHandler
C#
public event EventHandler PageStart

Remarks

This event is used to initialize any page-level variables when running an unbound report.

Example

C# Copy Code
bool bSwitch;
private void SectionReport1_PageStart(object sender, System.EventArgs eArgs)
{
    if (bSwitch == true)
    {
        this.PrintWidth = 6.5F;
        this.Document.Printer.Landscape = false;
    }
}
Visual Basic Copy Code
' boolean to keep track of which orientation to use
Dim bSwitch As Boolean

Private Sub rptMain_PageStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageStart
    If bSwitch = True Then
        Me.PrintWidth = 6.5
        Me.Document.Printer.Landscape = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ParameterUIClosed Event

[image]
ActiveReports 19 .NET Edition
ParameterUIClosed Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParameterUIClosed Event

Glossary Item Box

Raised after the user closes the query parameters dialog.

Syntax

Visual Basic (Declaration)
Public Event ParameterUIClosed As SectionReport.ParameterUIClosedHandler
C#
public event SectionReport.ParameterUIClosedHandler ParameterUIClosed

Example

C# Copy Code
private void SectionReport1_ParameterUIClosed(object sender, bool Cancelled)
{
    System.Windows.Forms.MessageBox.Show ("Parameters sent.");
}
Visual Basic Copy Code
Private Sub SectionReport1_ParameterUIClosed(ByVal sender As Object, ByVal cancelled As Boolean) Handles MyBase.ParameterUIClosed
    MessageBox.Show("Parameters set.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


PrintAborted Event

[image]
ActiveReports 19 .NET Edition
PrintAborted Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintAborted Event

Glossary Item Box

Raised when the user cancels a print job.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As EventHandler
C#
public event EventHandler PrintAborted

Example

C# Copy Code
private void SectionReport1_PrintAborted(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show("Printing has been aborted.");
}
Visual Basic Copy Code
Private Sub SectionReport1_PrintAborted(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintAborted
    MessageBox.Show("Printing has been aborted.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PrintProgress Event


PrintProgress Event

[image]
ActiveReports 19 .NET Edition
PrintProgress Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintProgress Event

Glossary Item Box

Raised for each page while printing the report document.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As EventHandler
C#
public event EventHandler PrintProgress

Example

This sample assumes that you have created a public property in the report and passed in a reference to the calling form. You can also use this technique to set the title bar text on the form window.
C# Copy Code
private int x = 0;
private void testLA_PrintProgress(object sender, System.EventArgs eArgs)
{
    //Print Progress is triggered once per page printed.
    myWinForm.Label1.Text = "Now Printing Page " + x;
    x++;
}
Visual Basic Copy Code
Private x As Integer = 0
Private Sub SectionReport1_PrintProgress(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintProgress
    myWinForm.Label1.Text = "Now Printing Page " + x
    x = x + 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PrintAborted Event


ReportEnd Event

[image]
ActiveReports 19 .NET Edition
ReportEnd Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportEnd Event

Glossary Item Box

Raised after the report finishes processing all pages.

Syntax

Visual Basic (Declaration)
Public Event ReportEnd As EventHandler
C#
public event EventHandler ReportEnd

Remarks

This event can be used to close or free any objects that you were using while running a report in unbound mode, or to display an information message to the end user.

Example

C# Copy Code
private void rptMain_ReportEnd(object sender, System.EventArgs eArgs)
{
    rptBookmarks rpt = new rptBookmarks();
    rpt.pBM = this.Document.Bookmarks;
    rpt.Run();
    this.Document.Pages.InsertRange(this.Document.Pages.Count, rpt.Document.Pages);
}
Visual Basic Copy Code
Private Sub rptMain_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
        Dim rpt As New rptBookmarks()
        rpt.pBM = Me.Document.Bookmarks
        rpt.Run()
        Me.Document.Pages.InsertRange(Me.Document.Pages.Count, rpt.Document.Pages)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ReportStart Event

[image]
ActiveReports 19 .NET Edition
ReportStart Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportStart Event

Glossary Item Box

Raised before a report starts processing.

Syntax

Visual Basic (Declaration)
Public Event ReportStart As EventHandler
C#
public event EventHandler ReportStart

Remarks

This event can be used to initialize any objects or variables that are needed while running a report.

Note: Printer values are set after this event is raised. The values that will be applied to the Printer object are in the PageSettings object. ReportStart is the event in which you can modify these values in the PageSettings object before they are applied to the Printer object.

Example

C# Copy Code
private void rptUnbound_ReportStart(object sender, System.EventArgs eArgs)
{
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False";
    string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid";
    m_cnn = new OleDbConnection(m_cnnString);
    OleDbCommand m_Cmd = new OleDbCommand(sqlString,m_cnn);
    if(m_cnn.State == ConnectionState.Closed)
    {
        m_cnn.Open();
    }
        m_reader = m_Cmd.ExecuteReader();
}
Visual Basic Copy Code
Dim m_cnnString As String
Dim sqlString As String
Dim m_reader As OleDbDataReader
Dim m_cnn As OleDbConnection
Private Sub rptUnbound_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) _
    Handles MyBase.ReportStart
    m_cnnString =  "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False"
    sqlString = "Select * FROM categories INNER JOIN products On categories.categoryid _
        = products.categoryid ORDER BY products.categoryid, products.productid"
    m_cnn = New OleDb.OleDbConnection(m_cnnString)
    Dim m_Cmd As New OleDb.OleDbCommand(sqlString, m_cnn)
    If m_cnn.State = ConnectionState.Closed Then
        m_cnn.Open()
    End If
    m_reader = m_Cmd.ExecuteReader()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SectionReport.FetchEventArgs Class

[image]
ActiveReports 19 .NET Edition
SectionReport.FetchEventArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

FetchEventArgs class provides data required for the FetchData Event.

Object Model

SectionReport.FetchEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SectionReport.FetchEventArgs
   Inherits System.EventArgs
C#
public class SectionReport.FetchEventArgs : System.EventArgs

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.SectionReport.FetchEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Members
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
SectionReport.FetchEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

The following tables list the members exposed by SectionReport.FetchEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SectionReport.FetchEventArgs Constructor | Creates a new SectionReport.FetchEventArgs instance.
Top

Public Properties

 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top

See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
SectionReport.FetchEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : SectionReport.FetchEventArgs Constructor

eof
End Of Fields as a Boolean value.

Glossary Item Box

Creates a new SectionReport.FetchEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal eof As Boolean _
)
C#
public SectionReport.FetchEventArgs(
   bool eof
)

Parameters

eof
End Of Fields as a Boolean value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


SectionReport.FetchEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
SectionReport.FetchEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

For a list of all members of this type, see SectionReport.FetchEventArgs members.

Public Properties

 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top

See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


EOF Property

[image]
ActiveReports 19 .NET Edition
EOF Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : EOF Property

Glossary Item Box

This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.

Syntax

Visual Basic (Declaration)
Public Property EOF As Boolean
C#
public bool EOF {get; set;}

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


LayoutAction Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutAction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LayoutAction Enumeration

Glossary Item Box

Specifies the action to be performed after a section is formatted.

Syntax

Visual Basic (Declaration)
Public Enum LayoutAction
   Inherits System.Enum
C#
public enum LayoutAction : System.Enum

Members

Member | Description
MoveLayout | The layout position will move to the next printing location on the page.
NextRecord | The data navigation will advance to the next record.
PrintSection | The section will be printed.

Remarks

The following table shows the results for setting different LayoutAction combinations.

PrintSection | MoveLayout | NextRecord | (Default) Move to the next print location, get the next record, and print data.
PrintSection | MoveLayout | Move to the next print location, don't advance to the next record, but print the data (repeats the same record).
NextRecord | Skip a record without leaving a blank space on the page.
MoveLayout | NextRecord | Skip a record and leave a blank space on the page.
MoveLayout | Leave a blank space without skipping a record.
PrintSection | NextRecord | Print the next record on top of the current record (UnderlayNext).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.LayoutAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
MESCIUS.ActiveReports~GrapeCity.ActiveReports~LayoutAction


PageSettings.PrinterCollate Enumeration

[image]
ActiveReports 19 .NET Edition
PageSettings.PrinterCollate Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings.PrinterCollate Enumeration

Glossary Item Box

Determines the collation order when printing multiple copies of a report.

Syntax

Visual Basic (Declaration)
Public Enum PageSettings.PrinterCollate
   Inherits System.Enum
C#
public enum PageSettings.PrinterCollate : System.Enum

Members

Member | Description
Collate | Print a complete copy of the document before starting another copy.
Default | Use the current printer collate settings.
DontCollate | Prints each page by the number of the copies specified before printing the next page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageSettings.PrinterCollate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
Collate Property


ReportProcessingError Enumeration

[image]
ActiveReports 19 .NET Edition
ReportProcessingError Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportProcessingError Enumeration

Glossary Item Box

Describe possible error codes for future detail processing of the error.

Syntax

Visual Basic (Declaration)
Public Enum ReportProcessingError
   Inherits System.Enum
C#
public enum ReportProcessingError : System.Enum

Members

Member | Description
BlankValueAssignedToNonBlankParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
CommandTextNotBeenSet | Command is empty.
CyclicParameter | Cyclic dependencies in parameters: ReportException.ErrorData provides name of the parameter.
CyclicSubreportReferences |
DataSetNotFound | Specified data set is not found.
DataSetNotSpecified | Not specified shared data set.
InfinitePages | Internal loop in pages processing observed.
InvalidData | Invalid data or cannot access to date with current configuration.
InvalidDataTypeForParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
InvalidKeyInConnectionString | Invalid key in connection string
InvalidLibrary | Something wrong in library.
InvalidQueryParameters | Cannot parse/process data set query parameters.
InvalidReport | Something wrong in report structure.
InvalidSharedDataSource | No assess to shared data source: ReportException.ErrorData provides name of the data source.
InvalidTheme | Invalid theme was specified.
JsonSchemaNotAvailableOrInvalid | Json schema specified in connection string of JSON data provider is not available or invalid.
NoDataSets | Not specified shared data set.
NoMasterReport | No master report was found.
NoPermission | DB assess error.
NullValueAssignedToNonNullableParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ParameterNotValidated | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ParameterValueIsNotValid | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ScriptCompilationFailed | Describe script compilation problem: ReportException.ErrorData provides errors array.
ScriptError | Describe script execution problem.
SubreportNotFound | No subreport was found.
UnableToCreateConnection | Can not connect to data source.
UnexpectedCharacterWhileParsingPath | Unexpected character while parsing path.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportProcessingError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


SectionReport.ReportState Enumeration

[image]
ActiveReports 19 .NET Edition
SectionReport.ReportState Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ReportState Enumeration

Glossary Item Box

Determines the current state of the report engine.

Syntax

Visual Basic (Declaration)
Public Enum SectionReport.ReportState
   Inherits System.Enum
C#
public enum SectionReport.ReportState : System.Enum

Members

Member | Description
Completed | The report processing is complete.
Idle | The report processing is idle.
InProgress | The report is currently being processed to create a document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.ReportState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
MESCIUS.ActiveReports~GrapeCity.ActiveReports.SectionReportModel~State


SectionReport.RpxFormat Enumeration

[image]
ActiveReports 19 .NET Edition
SectionReport.RpxFormat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.RpxFormat Enumeration

Glossary Item Box

Specifies the format in which the report is to be saved.

Syntax

Visual Basic (Declaration)
Public Enum SectionReport.RpxFormat
   Inherits System.Enum
C#
public enum SectionReport.RpxFormat : System.Enum

Members

Member | Description
Arnet | Saves the layout as a standard RPX file. Items in the component tray are not saved.
Arnet3 | Allows for the components in the component tray to be saved in the RPX file.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.RpxFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


IFontResolver Interface

[image]
ActiveReports 19 .NET Edition
IFontResolver Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : IFontResolver Interface

Glossary Item Box

Font resolver interface. Allows to customer to specify fonts for report (and obtain the same output on all platforms).

Syntax

Visual Basic (Declaration)
Public Interface IFontResolver
C#
public interface IFontResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFontResolver Members
GrapeCity.ActiveReports Namespace


IFontResolver Interface Members

[image]
ActiveReports 19 .NET Edition
IFontResolver Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : IFontResolver Interface

Glossary Item Box

The following tables list the members exposed by IFontResolver.

Public Methods

 | Name | Description
Method | GetFonts | Gets fonts for requested font family name.
Top

See Also

Reference

IFontResolver Interface
GrapeCity.ActiveReports Namespace


IFontResolver Interface Methods

[image]
ActiveReports 19 .NET Edition
IFontResolver Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : IFontResolver Interface

Glossary Item Box

For a list of all members of this type, see IFontResolver members.

Public Methods

 | Name | Description
Method | GetFonts | Gets fonts for requested font family name.
Top

See Also

Reference

IFontResolver Interface
GrapeCity.ActiveReports Namespace


GetFonts Method

[image]
ActiveReports 19 .NET Edition
GetFonts Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > IFontResolver Interface : GetFonts Method

familyName
isBold
isItalic

Glossary Item Box

Gets fonts for requested font family name.

Syntax

Visual Basic (Declaration)
Function GetFonts( _
   ByVal familyName As String, _
   ByVal isBold As Boolean, _
   ByVal isItalic As Boolean _
) As GrapeCity.Documents.Text.FontCollection
C#
GrapeCity.Documents.Text.FontCollection GetFonts(
   string familyName,
   bool isBold,
   bool isItalic
)

Parameters

familyName
isBold
isItalic

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFontResolver Interface
IFontResolver Members


LocateCredentialsEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
LocateCredentialsEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventHandler Delegate

sender
The source of the event.
args
LocateCredentials object that contains event data.

Glossary Item Box

Represents method that handles LocateCredentials event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LocateCredentialsEventHandler( _
   ByVal sender As Object, _
   ByVal args As LocateCredentialsEventArgs _
)
C#
public delegate void LocateCredentialsEventHandler(
   object sender,
   LocateCredentialsEventArgs args
)

Parameters

sender
The source of the event.
args
LocateCredentials object that contains event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventHandler Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
LocateDataSourceEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventHandler Delegate

sender
The sender of the event.
args
The LocateDataSourceEventArgs that contains the LocateDataSource event class.

Glossary Item Box

Represents the method that will handle the LocateDataSource event

Syntax

Visual Basic (Declaration)
Public Delegate Sub LocateDataSourceEventHandler( _
   ByVal sender As Object, _
   ByVal args As LocateDataSourceEventArgs _
)
C#
public delegate void LocateDataSourceEventHandler(
   object sender,
   LocateDataSourceEventArgs args
)

Parameters

sender
The sender of the event.
args
The LocateDataSourceEventArgs that contains the LocateDataSource event class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.FetchEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
SectionReport.FetchEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventHandler Delegate

sender
The source of the event.
eArgs
FetchEventArgs that contains the event data

Glossary Item Box

Represents the method that handles the FetchData event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SectionReport.FetchEventHandler( _
   ByVal sender As Object, _
   ByVal eArgs As SectionReport.FetchEventArgs _
)
C#
public delegate void SectionReport.FetchEventHandler(
   object sender,
   SectionReport.FetchEventArgs eArgs
)

Parameters

sender
The source of the event.
eArgs
FetchEventArgs that contains the event data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.ParameterUIClosedHandler Delegate

[image]
ActiveReports 19 .NET Edition
SectionReport.ParameterUIClosedHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ParameterUIClosedHandler Delegate

sender
The source of the event.
cancelled
Value indicates whether the parameters dialog was closed by using Cancel button.

Glossary Item Box

Represents a method that handles the ParameterUIClosed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SectionReport.ParameterUIClosedHandler( _
   ByVal sender As Object, _
   ByVal cancelled As Boolean _
)
C#
public delegate void SectionReport.ParameterUIClosedHandler(
   object sender,
   bool cancelled
)

Parameters

sender
The source of the event.
cancelled
Value indicates whether the parameters dialog was closed by using Cancel button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.ParameterUIClosedHandler Members
GrapeCity.ActiveReports Namespace


DataSourceException Class

[image]
ActiveReports 19 .NET Edition
DataSourceException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace : DataSourceException Class

Glossary Item Box

Specialized exception for data source actions.

Object Model

DataSourceException Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceException
   Inherits System.Exception
C#
public class DataSourceException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.AR.Data.DataSourceException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Members
GrapeCity.ActiveReports.AR.Data Namespace


DataSourceException Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace : DataSourceException Class

Glossary Item Box

The following tables list the members exposed by DataSourceException.

Public Constructors

 | Name | Description
Public Constructor | DataSourceException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Code | Gets the code.
Top

See Also

Reference

DataSourceException Class
GrapeCity.ActiveReports.AR.Data Namespace


DataSourceException Constructor

[image]
ActiveReports 19 .NET Edition
DataSourceException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class : DataSourceException Constructor

Glossary Item Box

Overload List

Overload | Description
DataSourceException Constructor(String) | Initializes a new instance of the DataSourceException class with a specified error message.
DataSourceException Constructor(Codes) | Initializes a new instance of the DataSourceException class.
DataSourceException Constructor(Codes,String) | Initializes a new instance of the DataSourceException class.
DataSourceException Constructor(Codes,Exception) | Initializes a new instance of the DataSourceException class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


DataSourceException Constructor(String)

[image]
ActiveReports 19 .NET Edition
DataSourceException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(String)

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the DataSourceException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public DataSourceException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes)

[image]
ActiveReports 19 .NET Edition
DataSourceException Constructor(Codes)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes)

code
The code.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes _
)
C#
public DataSourceException(
   DataSourceException.Codes code
)

Parameters

code
The code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes,String)

[image]
ActiveReports 19 .NET Edition
DataSourceException Constructor(Codes,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes,String)

code
The code.
message
The message.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes, _
   ByVal message As String _
)
C#
public DataSourceException(
   DataSourceException.Codes code,
   string message
)

Parameters

code
The code.
message
The message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes,Exception)

[image]
ActiveReports 19 .NET Edition
DataSourceException Constructor(Codes,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes,Exception)

code
The code.
innerException
The inner exception.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes, _
   ByVal innerException As Exception _
)
C#
public DataSourceException(
   DataSourceException.Codes code,
   Exception innerException
)

Parameters

code
The code.
innerException
The inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourceException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace : DataSourceException Class

Glossary Item Box

For a list of all members of this type, see DataSourceException members.

Public Properties

 | Name | Description
Public Property | Code | Gets the code.
Top

See Also

Reference

DataSourceException Class
GrapeCity.ActiveReports.AR.Data Namespace


Code Property

[image]
ActiveReports 19 .NET Edition
Code Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace > DataSourceException Class : Code Property

Glossary Item Box

Gets the code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As DataSourceException.Codes
C#
public DataSourceException.Codes Code {get;}

Property Value

The code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


DataSourceException.Codes Enumeration

[image]
ActiveReports 19 .NET Edition
DataSourceException.Codes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.AR.Data Namespace : DataSourceException.Codes Enumeration

Glossary Item Box

Codes of the exception for data source actions.

Syntax

Visual Basic (Declaration)
Public Enum DataSourceException.Codes
   Inherits System.Enum
C#
public enum DataSourceException.Codes : System.Enum

Members

Member | Description
ExecuteQueryError | Error appeared while query execution.
General | General exception.
InvalidConnectionString | Provided connection string is invalid.
SchemaProviderUnavaliable | Schema provider is unavaliable.
UnableToCreateCommand | Unable to create command.
UnableToCreateConnection | Unable to create connection.
UnableToOpenConnection | Unable to open connection.
UnableToRetreiveSchema | Unable to retreive schema.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.AR.Data.DataSourceException.Codes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.AR.Data Namespace


PageDrawingDevice Class

[image]
ActiveReports 19 .NET Edition
PageDrawingDevice Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace : PageDrawingDevice Class

Glossary Item Box

Page drawing device

Object Model

PageDrawingDevice Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageDrawingDevice
   Inherits GrapeCity.ActiveReports.BarCodes.DrawingDeviceBase
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.IDrawingDevice, GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.ITextMeasurer
C#
public sealed class PageDrawingDevice : GrapeCity.ActiveReports.BarCodes.DrawingDeviceBase, GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.IDrawingDevice, GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.ITextMeasurer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.BarCodes.DrawingDeviceBase
GrapeCity.ActiveReports.BarCodes.Drawing.PageDrawingDevice

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Members
GrapeCity.ActiveReports.BarCodes.Drawing Namespace


PageDrawingDevice Class Members

[image]
ActiveReports 19 .NET Edition
PageDrawingDevice Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace : PageDrawingDevice Class

Glossary Item Box

The following tables list the members exposed by PageDrawingDevice.

Public Constructors

 | Name | Description
Public Constructor | PageDrawingDevice Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overridden.
Public Method | DrawEllipse |
Public Method | DrawString |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | MeasureString |
Top

See Also

Reference

PageDrawingDevice Class
GrapeCity.ActiveReports.BarCodes.Drawing Namespace


PageDrawingDevice Constructor

[image]
ActiveReports 19 .NET Edition
PageDrawingDevice Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : PageDrawingDevice Constructor

textLayout
page
captionAlignment
font
color
direction
bounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textLayout As ITextLayoutService, _
   ByVal page As DrawCanvas, _
   ByVal captionAlignment As TextAlignment, _
   ByVal font As Font, _
   ByVal color As Color, _
   ByVal direction As Direction, _
   ByVal bounds As RectangleF _
)
C#
public PageDrawingDevice(
   ITextLayoutService textLayout,
   DrawCanvas page,
   TextAlignment captionAlignment,
   Font font,
   Color color,
   Direction direction,
   RectangleF bounds
)

Parameters

textLayout
page
captionAlignment
font
color
direction
bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


PageDrawingDevice Class Methods

[image]
ActiveReports 19 .NET Edition
PageDrawingDevice Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace : PageDrawingDevice Class

Glossary Item Box

For a list of all members of this type, see PageDrawingDevice members.

Public Methods

 | Name | Description
Public Method | Dispose | Overridden.
Public Method | DrawEllipse |
Public Method | DrawString |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | MeasureString |
Top

See Also

Reference

PageDrawingDevice Class
GrapeCity.ActiveReports.BarCodes.Drawing Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : DrawEllipse Method

center
rx
ry
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal center As PointF, _
   ByVal rx As Single, _
   ByVal ry As Single, _
   ByVal width As Single _
)
C#
public void DrawEllipse(
   PointF center,
   float rx,
   float ry,
   float width
)

Parameters

center
rx
ry
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : DrawString Method

text
bounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawString( _
   ByVal text As String, _
   ByVal bounds As RectangleF _
)
C#
public void DrawString(
   string text,
   RectangleF bounds
)

Parameters

text
bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : FillPolygon Method

points

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillPolygon( _
   ByVal points() As PointF _
)
C#
public void FillPolygon(
   PointF[] points
)

Parameters

points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : FillRectangle Method

bounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillRectangle( _
   ByVal bounds As RectangleF _
)
C#
public void FillRectangle(
   RectangleF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


MeasureString Method

[image]
ActiveReports 19 .NET Edition
MeasureString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.BarCodes.Drawing Namespace > PageDrawingDevice Class : MeasureString Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MeasureString( _
   ByVal text As String _
) As SizeF
C#
public SizeF MeasureString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDrawingDevice Class
PageDrawingDevice Members


CustomDesignerConfigurationDictionary Class

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

Represents a dictionary of custom designers configured for components.

Object Model

CustomDesignerConfigurationDictionary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomDesignerConfigurationDictionary
C#
public sealed class CustomDesignerConfigurationDictionary

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.CustomDesignerConfigurationDictionary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Class Members

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

The following tables list the members exposed by CustomDesignerConfigurationDictionary.

Public Constructors

 | Name | Description
Public Constructor | CustomDesignerConfigurationDictionary Constructor | Overloaded. Initializes a new instance of CustomDesignerConfigurationDictionary class.
Top

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the System.String value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top

See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Constructor

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : CustomDesignerConfigurationDictionary Constructor

Glossary Item Box

Initializes a new instance of CustomDesignerConfigurationDictionary class.

Overload List

Overload | Description
CustomDesignerConfigurationDictionary Constructor() | Initializes a new instance of CustomDesignerConfigurationDictionary class.
CustomDesignerConfigurationDictionary Constructor(IEnumerable<CustomDesignerConfig>) | Initializes a new instance with a predefined custom designers configurations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


CustomDesignerConfigurationDictionary Constructor()

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class > CustomDesignerConfigurationDictionary Constructor : CustomDesignerConfigurationDictionary Constructor()

Glossary Item Box

Initializes a new instance of CustomDesignerConfigurationDictionary class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomDesignerConfigurationDictionary()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members
Overload List


CustomDesignerConfigurationDictionary Constructor(IEnumerable<CustomDesignerConfig>)

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Constructor(IEnumerable<CustomDesignerConfig>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class > CustomDesignerConfigurationDictionary Constructor : CustomDesignerConfigurationDictionary Constructor(IEnumerable<CustomDesignerConfig>)

configs

Glossary Item Box

Initializes a new instance with a predefined custom designers configurations.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configs As IEnumerable(Of CustomDesignerConfig) _
)
C#
public CustomDesignerConfigurationDictionary(
   IEnumerable<CustomDesignerConfig> configs
)

Parameters

configs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members
Overload List


CustomDesignerConfigurationDictionary Class Methods

[image]
ActiveReports 19 .NET Edition
CustomDesignerConfigurationDictionary Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

For a list of all members of this type, see CustomDesignerConfigurationDictionary members.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the System.String value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top

See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForDesigner Method

[image]
ActiveReports 19 .NET Edition
GetCustomTypeNameForDesigner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetCustomTypeNameForDesigner Method

designerType
The System.Type for the designer the caller wants a custom report item type name for.

Glossary Item Box

Gets the System.String value associated with the specified designer.

Syntax

Visual Basic (Declaration)
Public Function GetCustomTypeNameForDesigner( _
   ByVal designerType As Type _
) As String
C#
public string GetCustomTypeNameForDesigner(
   Type designerType
)

Parameters

designerType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


GetDesignerForCustomTypeName Method

[image]
ActiveReports 19 .NET Edition
GetDesignerForCustomTypeName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetDesignerForCustomTypeName Method

customTypeName
The value of System.Type for which a configured designer is sought for.

Glossary Item Box

Returns the System.Type of the custom designer configured for the specified component type or null.

Syntax

Visual Basic (Declaration)
Public Function GetDesignerForCustomTypeName( _
   ByVal customTypeName As String _
) As Type
C#
public Type GetDesignerForCustomTypeName(
   string customTypeName
)

Parameters

customTypeName
The value of System.Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


DefaultConfigurationProvider Class

[image]
ActiveReports 19 .NET Edition
DefaultConfigurationProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

Implements an IConfigurationProvider that gets configuration information from a file in the executable directory or in the installation directory.

Object Model

DefaultConfigurationProvider Class

Syntax

Visual Basic (Declaration)
Public Class DefaultConfigurationProvider
   Implements IConfigurationProvider
C#
public class DefaultConfigurationProvider : IConfigurationProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.DefaultConfigurationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Class Members

[image]
ActiveReports 19 .NET Edition
DefaultConfigurationProvider Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

The following tables list the members exposed by DefaultConfigurationProvider.

Public Constructors

 | Name | Description
Public Constructor | DefaultConfigurationProvider Constructor | Creates a new instance of DefaultConfigurationProvider.
Top

Public Properties

 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top

See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Constructor

[image]
ActiveReports 19 .NET Edition
DefaultConfigurationProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : DefaultConfigurationProvider Constructor

Glossary Item Box

Creates a new instance of DefaultConfigurationProvider.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DefaultConfigurationProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


DefaultConfigurationProvider Class Properties

[image]
ActiveReports 19 .NET Edition
DefaultConfigurationProvider Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

For a list of all members of this type, see DefaultConfigurationProvider members.

Public Properties

 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top

See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : Content Property

Glossary Item Box

Returns the xml content of the configuration information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Content As String
C#
public string Content {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


PropertyElement Class

[image]
ActiveReports 19 .NET Edition
PropertyElement Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

Represents a property configuration option for the associated export extension.

Object Model

PropertyElement Class

Syntax

Visual Basic (Declaration)
Public Class PropertyElement
C#
public class PropertyElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.PropertyElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Members
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Class Members

[image]
ActiveReports 19 .NET Edition
PropertyElement Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

The following tables list the members exposed by PropertyElement.

Public Constructors

 | Name | Description
Public Constructor | PropertyElement Constructor | Initializes a new instance of the System.Object class with the specified property, value and value type.
Top

Public Properties

 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top

See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Constructor

[image]
ActiveReports 19 .NET Edition
PropertyElement Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : PropertyElement Constructor

property
The property to assign value to.
value
The value for the property.
type
The type of the value to convert the string value to.

Glossary Item Box

Initializes a new instance of the System.Object class with the specified property, value and value type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal property As String, _
   ByVal value As String, _
   ByVal type As String _
)
C#
public PropertyElement(
   string property,
   string value,
   string type
)

Parameters

property
The property to assign value to.
value
The value for the property.
type
The type of the value to convert the string value to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


PropertyElement Class Properties

[image]
ActiveReports 19 .NET Edition
PropertyElement Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

For a list of all members of this type, see PropertyElement members.

Public Properties

 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top

See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


Property Property

[image]
ActiveReports 19 .NET Edition
Property Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Property Property

Glossary Item Box

Gets the property to assign value to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Property As String
C#
public string Property {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Type Property

Glossary Item Box

Gets the type of the value to convert the value to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
C#
public string Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Value Property

Glossary Item Box

Gets the string value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
C#
public string Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


RenderingExtensionInfo Class

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

Class containing rendering extension information.

Object Model

RenderingExtensionInfo Class

Syntax

Visual Basic (Declaration)
Public Class RenderingExtensionInfo
C#
public class RenderingExtensionInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Members

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

The following tables list the members exposed by RenderingExtensionInfo.

Public Properties

 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top

See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfo members.

Public Properties

 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top

See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


AssemblyName Property

[image]
ActiveReports 19 .NET Edition
AssemblyName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : AssemblyName Property

Glossary Item Box

Fully qualified name of the assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String
C#
public string AssemblyName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


MenuName Property

[image]
ActiveReports 19 .NET Edition
MenuName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : MenuName Property

Glossary Item Box

Export menu item name for this rendering extension name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuName As String
C#
public string MenuName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


Settings Property

[image]
ActiveReports 19 .NET Edition
Settings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : Settings Property

Glossary Item Box

Gets the configuration.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Settings As ReadOnlyCollection(Of PropertyElement)
C#
public ReadOnlyCollection<PropertyElement> Settings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


TypeName Property

[image]
ActiveReports 19 .NET Edition
TypeName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : TypeName Property

Glossary Item Box

Rendering extension implementation class name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


RenderingExtensionInfoCollection Class

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

Represents a collection of RenderingExtensionInfo.

Object Model

RenderingExtensionInfoCollection Class

Syntax

Visual Basic (Declaration)
Public Class RenderingExtensionInfoCollection
   Inherits System.Collections.CollectionBase
C#
public class RenderingExtensionInfoCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfoCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Class Members

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

The following tables list the members exposed by RenderingExtensionInfoCollection.

Public Constructors

 | Name | Description
Public Constructor | RenderingExtensionInfoCollection Constructor | Creates an instance of RenderingExtensionInfoCollection.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Top

Public Events

 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Constructor

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : RenderingExtensionInfoCollection Constructor

Glossary Item Box

Creates an instance of RenderingExtensionInfoCollection.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderingExtensionInfoCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Methods

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Add Method

value
The RenderingExtensionInfo info to be added.

Glossary Item Box

Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As RenderingExtensionInfo _
) As Integer
C#
public int Add(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo info to be added.

Return Value

The index of added item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Contains Method

value
The RenderingExtensionInfo to search.

Glossary Item Box

Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As RenderingExtensionInfo _
) As Boolean
C#
public bool Contains(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to search.

Return Value

True if specified RenderingExtensionInfo is presented in the collection, False othervise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : IndexOf Method

value
The RenderingExtensionInfo to looking for.

Glossary Item Box

Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As RenderingExtensionInfo _
) As Integer
C#
public int IndexOf(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to looking for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Remove Method

value
The RenderingExtensionInfo to remvoe.

Glossary Item Box

Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As RenderingExtensionInfo _
)
C#
public void Remove(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to remvoe.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Properties

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Item Property

index
The index of the item to get or set.

Glossary Item Box

Gets or sets the RenderingExtensionInfo at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As RenderingExtensionInfo
C#
public RenderingExtensionInfo this[
   int index
]; {get; set;}

Parameters

index
The index of the item to get or set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Events

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Events

 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


ContentChanged Event

[image]
ActiveReports 19 .NET Edition
ContentChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : ContentChanged Event

Glossary Item Box

Occurs when the content has changed.

Syntax

Visual Basic (Declaration)
Public Event ContentChanged As RenderingExtensionInfoCollection.ContentChangedEventHandler
C#
public event RenderingExtensionInfoCollection.ContentChangedEventHandler ContentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


ReportItemsConfigurationDictionary Class

[image]
ActiveReports 19 .NET Edition
ReportItemsConfigurationDictionary Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

A dictionary of CustomReportItem type names and their corresponding System.Type.

Object Model

ReportItemsConfigurationDictionary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportItemsConfigurationDictionary
C#
public sealed class ReportItemsConfigurationDictionary

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ReportItemsConfigurationDictionary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemsConfigurationDictionary Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

The following tables list the members exposed by ReportItemsConfigurationDictionary.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top

See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemsConfigurationDictionary Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

For a list of all members of this type, see ReportItemsConfigurationDictionary members.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top

See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForReportItem Method

[image]
ActiveReports 19 .NET Edition
GetCustomTypeNameForReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetCustomTypeNameForReportItem Method

reportItemType
The System.Type for the designer the caller wants a custom report item type name for.

Glossary Item Box

Gets the Type value associated with the specified ReportItem.

Syntax

Visual Basic (Declaration)
Public Function GetCustomTypeNameForReportItem( _
   ByVal reportItemType As Type _
) As String
C#
public string GetCustomTypeNameForReportItem(
   Type reportItemType
)

Parameters

reportItemType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's Type attribute value.

Remarks

The specified ReportItem Type should implement the interface IReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


GetReportItemForCustomTypeName Method

[image]
ActiveReports 19 .NET Edition
GetReportItemForCustomTypeName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetReportItemForCustomTypeName Method

customReportItemTypeName
The value of Type for which a configured designer is sought for.

Glossary Item Box

Returns the System.Type of the custom report item configured for the specified component type or null.

Syntax

Visual Basic (Declaration)
Public Function GetReportItemForCustomTypeName( _
   ByVal customReportItemTypeName As String _
) As Type
C#
public Type GetReportItemForCustomTypeName(
   string customReportItemTypeName
)

Parameters

customReportItemTypeName
The value of Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.

Remarks

The returned type should implement the interface IReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


ToolboxItemConfig Class

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfig Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

Represents an entry for a toolbox configuration item.

Object Model

ToolboxItemConfig Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolboxItemConfig
C#
public sealed class ToolboxItemConfig

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ToolboxItemConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Members
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Class Members

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfig Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

The following tables list the members exposed by ToolboxItemConfig.

Public Constructors

 | Name | Description
Public Constructor | ToolboxItemConfig Constructor |
Top

Public Properties

 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top

See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Constructor

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfig Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ToolboxItemConfig Constructor

reportItemDesignerType
bitmapResource
clearItems

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportItemDesignerType As String, _
   ByVal bitmapResource As String, _
   ByVal clearItems As Boolean _
)
C#
public ToolboxItemConfig(
   string reportItemDesignerType,
   string bitmapResource,
   bool clearItems
)

Parameters

reportItemDesignerType
bitmapResource
clearItems

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ToolboxItemConfig Class Properties

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfig Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

For a list of all members of this type, see ToolboxItemConfig members.

Public Properties

 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top

See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


BitmapResource Property

[image]
ActiveReports 19 .NET Edition
BitmapResource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : BitmapResource Property

Glossary Item Box

Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BitmapResource As String
C#
public string BitmapResource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ClearItems Property

[image]
ActiveReports 19 .NET Edition
ClearItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ClearItems Property

Glossary Item Box

Gets a value that indicates if all existing items should be cleared.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClearItems As Boolean
C#
public bool ClearItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ReportItemDesignerType Property

[image]
ActiveReports 19 .NET Edition
ReportItemDesignerType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ReportItemDesignerType Property

Glossary Item Box

Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItemDesignerType As String
C#
public string ReportItemDesignerType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ToolboxItemConfigCollection Class

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfigCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfigCollection Class

Glossary Item Box

Object Model

ToolboxItemConfigCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolboxItemConfigCollection
   Inherits System.Collections.ReadOnlyCollectionBase
C#
public sealed class ToolboxItemConfigCollection : System.Collections.ReadOnlyCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
GrapeCity.ActiveReports.Configuration.ToolboxItemConfigCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfigCollection Members
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfigCollection Class Members

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfigCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfigCollection Class

Glossary Item Box

The following tables list the members exposed by ToolboxItemConfigCollection.

Public Constructors

 | Name | Description
Public Constructor | ToolboxItemConfigCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

ToolboxItemConfigCollection Class
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfigCollection Constructor

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfigCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfigCollection Class : ToolboxItemConfigCollection Constructor

items

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As ToolboxItemConfig _
)
C#
public ToolboxItemConfigCollection(
   ToolboxItemConfig[] items
)

Parameters

items

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfigCollection Class
ToolboxItemConfigCollection Members


ToolboxItemConfigCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ToolboxItemConfigCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfigCollection Class

Glossary Item Box

For a list of all members of this type, see ToolboxItemConfigCollection members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

ToolboxItemConfigCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfigCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ToolboxItemConfig
C#
public ToolboxItemConfig this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfigCollection Class
ToolboxItemConfigCollection Members


DataProviderInfo Structure

[image]
ActiveReports 19 .NET Edition
DataProviderInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DataProviderInfo Structure

Glossary Item Box

Specifies the information about a configured data provider.

Object Model

DataProviderInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure DataProviderInfo
   Inherits System.ValueType
C#
public struct DataProviderInfo : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Configuration.DataProviderInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Members
GrapeCity.ActiveReports.Configuration Namespace


DataProviderInfo Structure Members

[image]
ActiveReports 19 .NET Edition
DataProviderInfo Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DataProviderInfo Structure

Glossary Item Box

The following tables list the members exposed by DataProviderInfo.

Public Constructors

 | Name | Description
Public Constructor | DataProviderInfo Constructor | Initializes a new instance of the DataProviderInfo struct.
Top

Public Properties

 | Name | Description
Public Property | AdapterAssemblyQualifiedName | Fully assembly-qualified name of the class that implements additional features like setting of multi-value parameters and others.
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements System.Data.Common.DbProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | IsCustom | True if data provider is specified through configuration
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Public Property | SchemaProviderAssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.
Top

See Also

Reference

DataProviderInfo Structure
GrapeCity.ActiveReports.Configuration Namespace


DataProviderInfo Constructor

[image]
ActiveReports 19 .NET Edition
DataProviderInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : DataProviderInfo Constructor

invariantName
The name that can be used to refer to the data provider in reports.
assemblyQualifiedName
The fully assembly-qualified name of the class that implements System.Data.Common.DbProviderFactory for this provider.
adapterAssemblyQualifiedName
The fully assembly-qualified name of the class that implements additional features like setting of multivalue parameters and others.

Glossary Item Box

Initializes a new instance of the DataProviderInfo struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal invariantName As String, _
   ByVal assemblyQualifiedName As String, _
   ByVal adapterAssemblyQualifiedName As String _
)
C#
public DataProviderInfo(
   string invariantName,
   string assemblyQualifiedName,
   string adapterAssemblyQualifiedName
)

Parameters

invariantName
The name that can be used to refer to the data provider in reports.
assemblyQualifiedName
The fully assembly-qualified name of the class that implements System.Data.Common.DbProviderFactory for this provider.
adapterAssemblyQualifiedName
The fully assembly-qualified name of the class that implements additional features like setting of multivalue parameters and others.

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


DataProviderInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
DataProviderInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DataProviderInfo Structure

Glossary Item Box

For a list of all members of this type, see DataProviderInfo members.

Public Properties

 | Name | Description
Public Property | AdapterAssemblyQualifiedName | Fully assembly-qualified name of the class that implements additional features like setting of multi-value parameters and others.
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements System.Data.Common.DbProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | IsCustom | True if data provider is specified through configuration
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Public Property | SchemaProviderAssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.
Top

See Also

Reference

DataProviderInfo Structure
GrapeCity.ActiveReports.Configuration Namespace


AdapterAssemblyQualifiedName Property

[image]
ActiveReports 19 .NET Edition
AdapterAssemblyQualifiedName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : AdapterAssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements additional features like setting of multi-value parameters and others.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdapterAssemblyQualifiedName As String
C#
public string AdapterAssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


AssemblyQualifiedName Property

[image]
ActiveReports 19 .NET Edition
AssemblyQualifiedName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : AssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements System.Data.Common.DbProviderFactory for this provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyQualifiedName As String
C#
public string AssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


HumanReadableName Property

[image]
ActiveReports 19 .NET Edition
HumanReadableName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : HumanReadableName Property

Glossary Item Box

A human-readable name for the data provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HumanReadableName As String
C#
public string HumanReadableName {get;}

Remarks

An empty human readable name will prevent it from being displayed in UI.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


InvariantName Property

[image]
ActiveReports 19 .NET Edition
InvariantName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : InvariantName Property

Glossary Item Box

The name that can be used to refer to the data provider in reports.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvariantName As String
C#
public string InvariantName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


IsCustom Property

[image]
ActiveReports 19 .NET Edition
IsCustom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : IsCustom Property

Glossary Item Box

True if data provider is specified through configuration

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCustom As Boolean
C#
public bool IsCustom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


QueryDesignerSupported Property

[image]
ActiveReports 19 .NET Edition
QueryDesignerSupported Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : QueryDesignerSupported Property

Glossary Item Box

True if query designer supports this data provider

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryDesignerSupported As Boolean
C#
public bool QueryDesignerSupported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


SchemaProviderAssemblyQualifiedName Property

[image]
ActiveReports 19 .NET Edition
SchemaProviderAssemblyQualifiedName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DataProviderInfo Structure : SchemaProviderAssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaProviderAssemblyQualifiedName As String
C#
public string SchemaProviderAssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


IConfigurationManager Interface

[image]
ActiveReports 19 .NET Edition
IConfigurationManager Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

Defines an interface to allow access to configuration information.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurationManager
C#
public interface IConfigurationManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Members

[image]
ActiveReports 19 .NET Edition
IConfigurationManager Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

The following tables list the members exposed by IConfigurationManager.

Public Properties

 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | FontFactory | Returns fonts factory.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions | Returns the rendering extensions defined by the provider.
Property | ReportItems | Provides the mapping between CustomReportItem type names and their corresponding System.Type.
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top

See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Properties

[image]
ActiveReports 19 .NET Edition
IConfigurationManager Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

For a list of all members of this type, see IConfigurationManager members.

Public Properties

 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | FontFactory | Returns fonts factory.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions | Returns the rendering extensions defined by the provider.
Property | ReportItems | Provides the mapping between CustomReportItem type names and their corresponding System.Type.
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top

See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


CustomItemDesigners Property

[image]
ActiveReports 19 .NET Edition
CustomItemDesigners Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : CustomItemDesigners Property

Glossary Item Box

Returns a map for the custom report items with the custom designers.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomItemDesigners As CustomDesignerConfigurationDictionary
C#
CustomDesignerConfigurationDictionary CustomItemDesigners {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


DataProviders Property

[image]
ActiveReports 19 .NET Edition
DataProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : DataProviders Property

Glossary Item Box

Returns a collection of custom data providers.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataProviders As DataProviderInfoCollection
C#
DataProviderInfoCollection DataProviders {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


FontFactory Property

[image]
ActiveReports 19 .NET Edition
FontFactory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : FontFactory Property

Glossary Item Box

Returns fonts factory.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontFactory As FontsConfiguration
C#
FontsConfiguration FontFactory {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


MapTileServerConfiguration Property

[image]
ActiveReports 19 .NET Edition
MapTileServerConfiguration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : MapTileServerConfiguration Property

Glossary Item Box

Returns a configuration for communication with map tile server.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapTileServerConfiguration As MapTileServerConfiguration
C#
MapTileServerConfiguration MapTileServerConfiguration {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


RenderingExtensions Property

[image]
ActiveReports 19 .NET Edition
RenderingExtensions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : RenderingExtensions Property

Glossary Item Box

Returns the rendering extensions defined by the provider.

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderingExtensions As RenderingExtensionInfoCollection
C#
RenderingExtensionInfoCollection RenderingExtensions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ReportItems Property

Glossary Item Box

Provides the mapping between CustomReportItem type names and their corresponding System.Type.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItems As ReportItemsConfigurationDictionary
C#
ReportItemsConfigurationDictionary ReportItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


Settings Property

[image]
ActiveReports 19 .NET Edition
Settings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : Settings Property

Glossary Item Box

Returns a collection of configuration settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Settings As NameValueCollection
C#
NameValueCollection Settings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


TileProviders Property

[image]
ActiveReports 19 .NET Edition
TileProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : TileProviders Property

Glossary Item Box

Returns map tile providers.

Syntax

Visual Basic (Declaration)
ReadOnly Property TileProviders As IEnumerable(Of TileProviderInfo)
C#
IEnumerable<TileProviderInfo> TileProviders {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ToolboxItems Property

[image]
ActiveReports 19 .NET Edition
ToolboxItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ToolboxItems Property

Glossary Item Box

Returns the toolbox item configuration entries.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolboxItems As ICollection
C#
ICollection ToolboxItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


IConfigurationProvider Interface

[image]
ActiveReports 19 .NET Edition
IConfigurationProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

Defines interface for providing raw configuration information.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurationProvider
C#
public interface IConfigurationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IConfigurationProvider Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

The following tables list the members exposed by IConfigurationProvider.

Public Properties

 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top

See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Properties

[image]
ActiveReports 19 .NET Edition
IConfigurationProvider Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

For a list of all members of this type, see IConfigurationProvider members.

Public Properties

 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top

See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationProvider Interface : Content Property

Glossary Item Box

Gets the xml representing the configuration.

Syntax

Visual Basic (Declaration)
ReadOnly Property Content As String
C#
string Content {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationProvider Interface
IConfigurationProvider Members


RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

sender
The source of the event.
e
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.

Glossary Item Box

Represents the method that processes the ContentChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RenderingExtensionInfoCollection.ContentChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void RenderingExtensionInfoCollection.ContentChangedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
The source of the event.
e
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection.ContentChangedEventHandler Members
GrapeCity.ActiveReports.Configuration Namespace


CornersRadius Structure

[image]
ActiveReports 19 .NET Edition
CornersRadius Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace : CornersRadius Structure

Glossary Item Box

This structure represents radiuses of rectangle's corners in percents.

Object Model

CornersRadius Structure

Syntax

Visual Basic (Declaration)
Public Structure CornersRadius
   Inherits System.ValueType
C#
public struct CornersRadius : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Controls.CornersRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Members
GrapeCity.ActiveReports.Controls Namespace


CornersRadius Structure Members

[image]
ActiveReports 19 .NET Edition
CornersRadius Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace : CornersRadius Structure

Glossary Item Box

The following tables list the members exposed by CornersRadius.

Public Constructors

 | Name | Description
Public Constructor | CornersRadius Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BottomLeft | Radius of the bottom left corner
Public Property | BottomRight | Radius of the bottom right corner
Public Property | Default | Default corner radius, if radius of a specified corner doesn't set, this value will be used instead.
Public Property | TopLeft | Radius of the top left corner
Public Property | TopRight | Radius of the top right corner
Top

Public Operators

public Operator Implicit Type Conversion | Overloaded. Convert float to new corner type.
public Operator Multiplication | Overloaded. Implements the *.
Top

See Also

Reference

CornersRadius Structure
GrapeCity.ActiveReports.Controls Namespace


CornersRadius Constructor

[image]
ActiveReports 19 .NET Edition
CornersRadius Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : CornersRadius Constructor

Glossary Item Box

Overload List

Overload | Description
CornersRadius Constructor(Nullable<Single>) | Creates new structure initialized with specified values.
CornersRadius Constructor(Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>) | Creates new structure initialized with specified values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


CornersRadius Constructor(Nullable<Single>)

[image]
ActiveReports 19 .NET Edition
CornersRadius Constructor(Nullable<Single>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure > CornersRadius Constructor : CornersRadius Constructor(Nullable<Single>)

defaultRadius

Glossary Item Box

Creates new structure initialized with specified values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal defaultRadius As Nullable(Of Single) _
)
C#
public CornersRadius(
   Nullable<float> defaultRadius
)

Parameters

defaultRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members
Overload List


CornersRadius Constructor(Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>)

[image]
ActiveReports 19 .NET Edition
CornersRadius Constructor(Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure > CornersRadius Constructor : CornersRadius Constructor(Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>,Nullable<Single>)

defaultRadius
topLeft
topRight
bottomLeft
bottomRight

Glossary Item Box

Creates new structure initialized with specified values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal defaultRadius As Nullable(Of Single), _
   ByVal topLeft As Nullable(Of Single), _
   ByVal topRight As Nullable(Of Single), _
   ByVal bottomLeft As Nullable(Of Single), _
   ByVal bottomRight As Nullable(Of Single) _
)
C#
public CornersRadius(
   Nullable<float> defaultRadius,
   Nullable<float> topLeft,
   Nullable<float> topRight,
   Nullable<float> bottomLeft,
   Nullable<float> bottomRight
)

Parameters

defaultRadius
topLeft
topRight
bottomLeft
bottomRight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members
Overload List


CornersRadius Structure Properties

[image]
ActiveReports 19 .NET Edition
CornersRadius Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace : CornersRadius Structure

Glossary Item Box

For a list of all members of this type, see CornersRadius members.

Public Properties

 | Name | Description
Public Property | BottomLeft | Radius of the bottom left corner
Public Property | BottomRight | Radius of the bottom right corner
Public Property | Default | Default corner radius, if radius of a specified corner doesn't set, this value will be used instead.
Public Property | TopLeft | Radius of the top left corner
Public Property | TopRight | Radius of the top right corner
Top

See Also

Reference

CornersRadius Structure
GrapeCity.ActiveReports.Controls Namespace


BottomLeft Property

[image]
ActiveReports 19 .NET Edition
BottomLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : BottomLeft Property

Glossary Item Box

Radius of the bottom left corner

Syntax

Visual Basic (Declaration)
Public Property BottomLeft As Nullable(Of Single)
C#
public Nullable<float> BottomLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


BottomRight Property

[image]
ActiveReports 19 .NET Edition
BottomRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : BottomRight Property

Glossary Item Box

Radius of the bottom right corner

Syntax

Visual Basic (Declaration)
Public Property BottomRight As Nullable(Of Single)
C#
public Nullable<float> BottomRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : Default Property

Glossary Item Box

Default corner radius, if radius of a specified corner doesn't set, this value will be used instead.

Syntax

Visual Basic (Declaration)
Public Property Default As Nullable(Of Single)
C#
public Nullable<float> Default {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


TopLeft Property

[image]
ActiveReports 19 .NET Edition
TopLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : TopLeft Property

Glossary Item Box

Radius of the top left corner

Syntax

Visual Basic (Declaration)
Public Property TopLeft As Nullable(Of Single)
C#
public Nullable<float> TopLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


TopRight Property

[image]
ActiveReports 19 .NET Edition
TopRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : TopRight Property

Glossary Item Box

Radius of the top right corner

Syntax

Visual Basic (Declaration)
Public Property TopRight As Nullable(Of Single)
C#
public Nullable<float> TopRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : Implicit Type Conversion Operator

Glossary Item Box

Convert float to new corner type.

Overload List

Overload | Description
Implicit Type Conversion(CornersRadius,Single) | Convert float to new corner type.
Implicit Type Conversion(CornersRadius,Int32) | Convert int to new corner type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


Multiplication Operator

[image]
ActiveReports 19 .NET Edition
Multiplication Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls Namespace > CornersRadius Structure : Multiplication Operator

Glossary Item Box

Implements the *.

Overload List

Overload | Description
Multiplication(Single,CornersRadius) | Implements the *.
Multiplication(CornersRadius,Single) | Implements the *.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CornersRadius Structure
CornersRadius Members


DefaultSizeAttribute Class

[image]
ActiveReports 19 .NET Edition
DefaultSizeAttribute Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : DefaultSizeAttribute Class

Glossary Item Box

Represents the default size attribute.

Object Model

DefaultSizeAttribute Class

Syntax

Visual Basic (Declaration)
Public Class DefaultSizeAttribute
   Inherits System.Attribute
C#
public class DefaultSizeAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Controls.Design.DefaultSizeAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSizeAttribute Members
GrapeCity.ActiveReports.Controls.Design Namespace


DefaultSizeAttribute Class Members

[image]
ActiveReports 19 .NET Edition
DefaultSizeAttribute Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : DefaultSizeAttribute Class

Glossary Item Box

The following tables list the members exposed by DefaultSizeAttribute.

Public Constructors

 | Name | Description
Public Constructor | DefaultSizeAttribute Constructor | Initializes a new instance of the DefaultSizeAttribute class.
Top

Public Properties

 | Name | Description
Public Property | Size | Gets or sets the size value.
Top

See Also

Reference

DefaultSizeAttribute Class
GrapeCity.ActiveReports.Controls.Design Namespace


DefaultSizeAttribute Constructor

[image]
ActiveReports 19 .NET Edition
DefaultSizeAttribute Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > DefaultSizeAttribute Class : DefaultSizeAttribute Constructor

width
The width.
height
The height.

Glossary Item Box

Initializes a new instance of the DefaultSizeAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public DefaultSizeAttribute(
   float width,
   float height
)

Parameters

width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSizeAttribute Class
DefaultSizeAttribute Members


DefaultSizeAttribute Class Properties

[image]
ActiveReports 19 .NET Edition
DefaultSizeAttribute Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : DefaultSizeAttribute Class

Glossary Item Box

For a list of all members of this type, see DefaultSizeAttribute members.

Public Properties

 | Name | Description
Public Property | Size | Gets or sets the size value.
Top

See Also

Reference

DefaultSizeAttribute Class
GrapeCity.ActiveReports.Controls.Design Namespace


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > DefaultSizeAttribute Class : Size Property

Glossary Item Box

Gets or sets the size value.

Syntax

Visual Basic (Declaration)
Public Property Size As SizeF
C#
public SizeF Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSizeAttribute Class
DefaultSizeAttribute Members


IARControlSite Interface

[image]
ActiveReports 19 .NET Edition
IARControlSite Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IARControlSite Interface

Glossary Item Box

Used for design time painting, coordinate translation

Syntax

Visual Basic (Declaration)
Public Interface IARControlSite
C#
public interface IARControlSite

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IARControlSite Members
GrapeCity.ActiveReports.Controls.Design Namespace


IARControlSite Interface Members

[image]
ActiveReports 19 .NET Edition
IARControlSite Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IARControlSite Interface

Glossary Item Box

The following tables list the members exposed by IARControlSite.

Public Methods

 | Name | Description
Method | ToDevice | Transforms the control's coordinates and size
Method | ToDeviceF | Overloaded. Transforms the control coordinates
Top

See Also

Reference

IARControlSite Interface
GrapeCity.ActiveReports.Controls.Design Namespace


IARControlSite Interface Methods

[image]
ActiveReports 19 .NET Edition
IARControlSite Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IARControlSite Interface

Glossary Item Box

For a list of all members of this type, see IARControlSite members.

Public Methods

 | Name | Description
Method | ToDevice | Transforms the control's coordinates and size
Method | ToDeviceF | Overloaded. Transforms the control coordinates
Top

See Also

Reference

IARControlSite Interface
GrapeCity.ActiveReports.Controls.Design Namespace


ToDevice Method

[image]
ActiveReports 19 .NET Edition
ToDevice Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IARControlSite Interface : ToDevice Method

r

Glossary Item Box

Transforms the control's coordinates and size

Syntax

Visual Basic (Declaration)
Function ToDevice( _
   ByVal r As RectangleF _
) As Rectangle
C#
Rectangle ToDevice(
   RectangleF r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IARControlSite Interface
IARControlSite Members


ToDeviceF Method

[image]
ActiveReports 19 .NET Edition
ToDeviceF Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IARControlSite Interface : ToDeviceF Method

Glossary Item Box

Transforms the control coordinates

Overload List

Overload | Description
ToDeviceF(SizeF) | Transforms the control coordinates
ToDeviceF(RectangleF) | Transforms the control's coordinates and size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IARControlSite Interface
IARControlSite Members


ToDeviceF(SizeF) Method

[image]
ActiveReports 19 .NET Edition
ToDeviceF(SizeF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IARControlSite Interface > ToDeviceF Method : ToDeviceF(SizeF) Method

size

Glossary Item Box

Transforms the control coordinates

Syntax

Visual Basic (Declaration)
Overloads Function ToDeviceF( _
   ByVal size As SizeF _
) As SizeF
C#
SizeF ToDeviceF(
   SizeF size
)

Parameters

size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IARControlSite Interface
IARControlSite Members
Overload List


ToDeviceF(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
ToDeviceF(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IARControlSite Interface > ToDeviceF Method : ToDeviceF(RectangleF) Method

r

Glossary Item Box

Transforms the control's coordinates and size

Syntax

Visual Basic (Declaration)
Overloads Function ToDeviceF( _
   ByVal r As RectangleF _
) As RectangleF
C#
RectangleF ToDeviceF(
   RectangleF r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IARControlSite Interface
IARControlSite Members
Overload List


IAvailabilityInfo Interface

[image]
ActiveReports 19 .NET Edition
IAvailabilityInfo Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IAvailabilityInfo Interface

Glossary Item Box

Used to check the availability of a property value for the control

Syntax

Visual Basic (Declaration)
Public Interface IAvailabilityInfo
C#
public interface IAvailabilityInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAvailabilityInfo Members
GrapeCity.ActiveReports.Controls.Design Namespace


IAvailabilityInfo Interface Members

[image]
ActiveReports 19 .NET Edition
IAvailabilityInfo Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IAvailabilityInfo Interface

Glossary Item Box

The following tables list the members exposed by IAvailabilityInfo.

Public Methods

 | Name | Description
Method | IsPropertyValueAvailable |
Top

See Also

Reference

IAvailabilityInfo Interface
GrapeCity.ActiveReports.Controls.Design Namespace


IAvailabilityInfo Interface Methods

[image]
ActiveReports 19 .NET Edition
IAvailabilityInfo Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IAvailabilityInfo Interface

Glossary Item Box

For a list of all members of this type, see IAvailabilityInfo members.

Public Methods

 | Name | Description
Method | IsPropertyValueAvailable |
Top

See Also

Reference

IAvailabilityInfo Interface
GrapeCity.ActiveReports.Controls.Design Namespace


IsPropertyValueAvailable Method

[image]
ActiveReports 19 .NET Edition
IsPropertyValueAvailable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IAvailabilityInfo Interface : IsPropertyValueAvailable Method

propertyName
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function IsPropertyValueAvailable( _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Boolean
C#
bool IsPropertyValueAvailable(
   string propertyName,
   object value
)

Parameters

propertyName
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAvailabilityInfo Interface
IAvailabilityInfo Members


IPersistControl Interface

[image]
ActiveReports 19 .NET Edition
IPersistControl Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IPersistControl Interface

Glossary Item Box

Interface IPersistControl

Syntax

Visual Basic (Declaration)
Public Interface IPersistControl
C#
public interface IPersistControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPersistControl Members
GrapeCity.ActiveReports.Controls.Design Namespace


IPersistControl Interface Members

[image]
ActiveReports 19 .NET Edition
IPersistControl Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IPersistControl Interface

Glossary Item Box

The following tables list the members exposed by IPersistControl.

Public Methods

 | Name | Description
Method | ReadXml | Reads the control from specified XML node.
Method | WriteXml | Writes the control as XML to specified XML node.
Top

See Also

Reference

IPersistControl Interface
GrapeCity.ActiveReports.Controls.Design Namespace


IPersistControl Interface Methods

[image]
ActiveReports 19 .NET Edition
IPersistControl Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IPersistControl Interface

Glossary Item Box

For a list of all members of this type, see IPersistControl members.

Public Methods

 | Name | Description
Method | ReadXml | Reads the control from specified XML node.
Method | WriteXml | Writes the control as XML to specified XML node.
Top

See Also

Reference

IPersistControl Interface
GrapeCity.ActiveReports.Controls.Design Namespace


ReadXml Method

[image]
ActiveReports 19 .NET Edition
ReadXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IPersistControl Interface : ReadXml Method

controlNode

Glossary Item Box

Reads the control from specified XML node.

Syntax

Visual Basic (Declaration)
Function ReadXml( _
   ByVal controlNode As XmlNode _
) As Boolean
C#
bool ReadXml(
   XmlNode controlNode
)

Parameters

controlNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPersistControl Interface
IPersistControl Members


WriteXml Method

[image]
ActiveReports 19 .NET Edition
WriteXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IPersistControl Interface : WriteXml Method

controlNode

Glossary Item Box

Writes the control as XML to specified XML node.

Syntax

Visual Basic (Declaration)
Function WriteXml( _
   ByVal controlNode As XmlElement _
) As Boolean
C#
bool WriteXml(
   XmlElement controlNode
)

Parameters

controlNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPersistControl Interface
IPersistControl Members


IRichEditDesignTarget Interface

[image]
ActiveReports 19 .NET Edition
IRichEditDesignTarget Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IRichEditDesignTarget Interface

Glossary Item Box

IRichEditDesignTarget to bind with designer.

Syntax

Visual Basic (Declaration)
Public Interface IRichEditDesignTarget
C#
public interface IRichEditDesignTarget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Members
GrapeCity.ActiveReports.Controls.Design Namespace


IRichEditDesignTarget Interface Members

[image]
ActiveReports 19 .NET Edition
IRichEditDesignTarget Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IRichEditDesignTarget Interface

Glossary Item Box

The following tables list the members exposed by IRichEditDesignTarget.

Public Properties

 | Name | Description
Property | BackColor | Gets or sets the control's background color or fill color.
Property | ForeColor | Gets or returns the foreground (font) color of the control.
Property | Html | Gets or sets the HTML content of the control.
Property | RTF | Gets or sets the rich text content of the control.
Property | SelectedText | Gets or sets the current selected text in the control.
Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Property | SelectionFont | Gets or sets the font of the current text selection.
Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph.
Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection.
Property | SelectionLength | Gets or sets the number of characters selected in control.
Property | SelectionProtected | True if selection is protected.
Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Property | SelectionStart | Gets or sets the starting point of text selected in the control.
Property | Text | Gets or sets the current text in the control.
Top

Public Methods

 | Name | Description
Method | Clear | Clears the control's content.
Method | LoadFile | Loads the file from specified stream.
Top

See Also

Reference

IRichEditDesignTarget Interface
GrapeCity.ActiveReports.Controls.Design Namespace


IRichEditDesignTarget Interface Methods

[image]
ActiveReports 19 .NET Edition
IRichEditDesignTarget Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IRichEditDesignTarget Interface

Glossary Item Box

For a list of all members of this type, see IRichEditDesignTarget members.

Public Methods

 | Name | Description
Method | Clear | Clears the control's content.
Method | LoadFile | Loads the file from specified stream.
Top

See Also

Reference

IRichEditDesignTarget Interface
GrapeCity.ActiveReports.Controls.Design Namespace


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : Clear Method

Glossary Item Box

Clears the control's content.

Syntax

Visual Basic (Declaration)
Sub Clear()
C#
void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


LoadFile Method

[image]
ActiveReports 19 .NET Edition
LoadFile Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : LoadFile Method

stream
type

Glossary Item Box

Loads the file from specified stream.

Syntax

Visual Basic (Declaration)
Sub LoadFile( _
   ByVal stream As Stream, _
   ByVal type As RichTextType _
)
C#
void LoadFile(
   Stream stream,
   RichTextType type
)

Parameters

stream
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


IRichEditDesignTarget Interface Properties

[image]
ActiveReports 19 .NET Edition
IRichEditDesignTarget Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace : IRichEditDesignTarget Interface

Glossary Item Box

For a list of all members of this type, see IRichEditDesignTarget members.

Public Properties

 | Name | Description
Property | BackColor | Gets or sets the control's background color or fill color.
Property | ForeColor | Gets or returns the foreground (font) color of the control.
Property | Html | Gets or sets the HTML content of the control.
Property | RTF | Gets or sets the rich text content of the control.
Property | SelectedText | Gets or sets the current selected text in the control.
Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Property | SelectionFont | Gets or sets the font of the current text selection.
Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph.
Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection.
Property | SelectionLength | Gets or sets the number of characters selected in control.
Property | SelectionProtected | True if selection is protected.
Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Property | SelectionStart | Gets or sets the starting point of text selected in the control.
Property | Text | Gets or sets the current text in the control.
Top

See Also

Reference

IRichEditDesignTarget Interface
GrapeCity.ActiveReports.Controls.Design Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Property BackColor As Color
C#
Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Property ForeColor As Color
C#
Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


Html Property

[image]
ActiveReports 19 .NET Edition
Html Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : Html Property

Glossary Item Box

Gets or sets the HTML content of the control.

Syntax

Visual Basic (Declaration)
Property Html As String
C#
string Html {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


RTF Property

[image]
ActiveReports 19 .NET Edition
RTF Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : RTF Property

Glossary Item Box

Gets or sets the rich text content of the control.

Syntax

Visual Basic (Declaration)
Property RTF As String
C#
string RTF {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectedText Property

[image]
ActiveReports 19 .NET Edition
SelectedText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectedText Property

Glossary Item Box

Gets or sets the current selected text in the control.

Syntax

Visual Basic (Declaration)
Property SelectedText As String
C#
string SelectedText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionAlignment Property

[image]
ActiveReports 19 .NET Edition
SelectionAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionAlignment Property

Glossary Item Box

Gets or sets the alignment to apply to the current selection or insertion point.

Syntax

Visual Basic (Declaration)
Property SelectionAlignment As TextAlignment
C#
TextAlignment SelectionAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionBackColor Property

[image]
ActiveReports 19 .NET Edition
SelectionBackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionBackColor Property

Glossary Item Box

Gets or sets the background color of the current text selection.

Syntax

Visual Basic (Declaration)
Property SelectionBackColor As Color
C#
Color SelectionBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionBullet Property

[image]
ActiveReports 19 .NET Edition
SelectionBullet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionBullet Property

Glossary Item Box

Gets or sets a value indicating whether the bullet style is applied to the current selection.

Syntax

Visual Basic (Declaration)
Property SelectionBullet As Boolean
C#
bool SelectionBullet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionCharOffset Property

[image]
ActiveReports 19 .NET Edition
SelectionCharOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionCharOffset Property

Glossary Item Box

Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.

Syntax

Visual Basic (Declaration)
Property SelectionCharOffset As Single
C#
float SelectionCharOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionFont Property

[image]
ActiveReports 19 .NET Edition
SelectionFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionFont Property

Glossary Item Box

Gets or sets the font of the current text selection.

Syntax

Visual Basic (Declaration)
Property SelectionFont As Font
C#
Font SelectionFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionHangingIndent Property

[image]
ActiveReports 19 .NET Edition
SelectionHangingIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionHangingIndent Property

Glossary Item Box

Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph.

Syntax

Visual Basic (Declaration)
Property SelectionHangingIndent As Single
C#
float SelectionHangingIndent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionIndent Property

[image]
ActiveReports 19 .NET Edition
SelectionIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionIndent Property

Glossary Item Box

Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection.

Syntax

Visual Basic (Declaration)
Property SelectionIndent As Single
C#
float SelectionIndent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionLength Property

[image]
ActiveReports 19 .NET Edition
SelectionLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionLength Property

Glossary Item Box

Gets or sets the number of characters selected in control.

Syntax

Visual Basic (Declaration)
Property SelectionLength As Integer
C#
int SelectionLength {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionProtected Property

[image]
ActiveReports 19 .NET Edition
SelectionProtected Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionProtected Property

Glossary Item Box

True if selection is protected.

Syntax

Visual Basic (Declaration)
Property SelectionProtected As Boolean
C#
bool SelectionProtected {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionRightIndent Property

[image]
ActiveReports 19 .NET Edition
SelectionRightIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionRightIndent Property

Glossary Item Box

The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.

Syntax

Visual Basic (Declaration)
Property SelectionRightIndent As Single
C#
float SelectionRightIndent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


SelectionStart Property

[image]
ActiveReports 19 .NET Edition
SelectionStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : SelectionStart Property

Glossary Item Box

Gets or sets the starting point of text selected in the control.

Syntax

Visual Basic (Declaration)
Property SelectionStart As Integer
C#
int SelectionStart {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Controls.Design Namespace > IRichEditDesignTarget Interface : Text Property

Glossary Item Box

Gets or sets the current text in the control.

Syntax

Visual Basic (Declaration)
Property Text As String
C#
string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRichEditDesignTarget Interface
IRichEditDesignTarget Members


CsvDataSource Class

[image]
ActiveReports 19 .NET Edition
CsvDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

Represents a section report data source based on an CSV document.

Object Model

CsvDataSource Class

Syntax

Visual Basic (Declaration)
Public Class CsvDataSource
C#
public class CsvDataSource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.CsvDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Members
GrapeCity.ActiveReports.Data Namespace


CsvDataSource Class Members

[image]
ActiveReports 19 .NET Edition
CsvDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

The following tables list the members exposed by CsvDataSource.

Public Constructors

 | Name | Description
Public Constructor | CsvDataSource Constructor | Initializes a new instance of CsvDataSource class.
Top

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the csv file.
Public Property | CredentialsMode |
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the CsvDataSource.
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the csv columns names.
Public Method | Load | Loads the csv data from the source specified in connection string.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


CsvDataSource Constructor

[image]
ActiveReports 19 .NET Edition
CsvDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : CsvDataSource Constructor

Glossary Item Box

Initializes a new instance of CsvDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CsvDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


CsvDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
CsvDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

For a list of all members of this type, see CsvDataSource members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the CsvDataSource.
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the csv columns names.
Public Method | Load | Loads the csv data from the source specified in connection string.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : Dispose() Method

Glossary Item Box

Releases the resources used by the CsvDataSource.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


Field Method

[image]
ActiveReports 19 .NET Edition
Field Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : Field Method

name
The name of the field.

Glossary Item Box

Returns the value of the field with the specified name.

Syntax

Visual Basic (Declaration)
Public Function Field( _
   ByVal name As String _
) As Object
C#
public object Field(
   string name
)

Parameters

name
The name of the field.

Return Value

The value of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


GetColumns Method

[image]
ActiveReports 19 .NET Edition
GetColumns Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : GetColumns Method

Glossary Item Box

Returns the list of the csv columns names.

Syntax

Visual Basic (Declaration)
Public Function GetColumns() As List(Of String)
C#
public List<string> GetColumns()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : Load Method

getStream
The stream getter.

Glossary Item Box

Loads the csv data from the source specified in connection string.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   Optional ByVal getStream As Func(Of String,Stream) _
)
C#
public void Load(
   Func<string,Stream> getStream
)

Parameters

getStream
The stream getter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


MoveFirst Method

[image]
ActiveReports 19 .NET Edition
MoveFirst Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : MoveFirst Method

resourceLocator

Glossary Item Box

Moves the current position to the first data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst( _
   Optional ByVal resourceLocator As ResourceLocator _
)
C#
public void MoveFirst(
   ResourceLocator resourceLocator
)

Parameters

resourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


MoveNext Method

[image]
ActiveReports 19 .NET Edition
MoveNext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : MoveNext Method

Glossary Item Box

Moves the current position to the next data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


CsvDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
CsvDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

For a list of all members of this type, see CsvDataSource members.

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the csv file.
Public Property | CredentialsMode |
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


ConnectionString Property

[image]
ActiveReports 19 .NET Edition
ConnectionString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to load the data from the csv file.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members
8b2ee12b-264b-403f-aa50-aafadcf8c1cb


CredentialsMode Property

[image]
ActiveReports 19 .NET Edition
CredentialsMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : CredentialsMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CredentialsMode As CredentialsMode
C#
public CredentialsMode CredentialsMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


EOF Property

[image]
ActiveReports 19 .NET Edition
EOF Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : EOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the end of the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF As Boolean
C#
public bool EOF {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : ResourceLocator Property

Glossary Item Box

Gets or sets the function that returns resource stream for a given name.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As Func(Of String,Stream)
C#
public Func<string,Stream> ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


DbDataSource Class

[image]
ActiveReports 19 .NET Edition
DbDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : DbDataSource Class

Glossary Item Box

DB data source - allows to connect through custom database providers.

Object Model

DbDataSource Class

Syntax

Visual Basic (Declaration)
Public Class DbDataSource
   Implements IDbConnectionProperties
C#
public class DbDataSource : IDbConnectionProperties

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.DbDataSource
GrapeCity.ActiveReports.Data.OdbcDataSource
GrapeCity.ActiveReports.Data.OleDBDataSource
GrapeCity.ActiveReports.Data.SqlDBDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Members
GrapeCity.ActiveReports.Data Namespace


DbDataSource Class Members

[image]
ActiveReports 19 .NET Edition
DbDataSource Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : DbDataSource Class

Glossary Item Box

The following tables list the members exposed by DbDataSource.

Public Constructors

 | Name | Description
Public Constructor | DbDataSource Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultTimeout | The number of seconds to wait for a connection to open, before cancelling an attempt and generate an error.
Top

Public Properties

 | Name | Description
Public Property | CommandText | Specifies a valid SQL statement used to retrieve records from the data source.
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source.
Public Property | CredentialsMode | Get or sets the value indicating whether the credentials dialog should be called or not.
Public Property | Factory | Gets data source's DbProviderFactory.
Public Property | ParamQuery |
Public Property | ProviderName | Returns provider's invariant name
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

Public Methods

 | Name | Description
Public Method | CreateConnection |
Public Method | SetCredentials |
Public Method | XmlRead |
Public Method | XmlWrite |
Top

See Also

Reference

DbDataSource Class
GrapeCity.ActiveReports.Data Namespace


DbDataSource Constructor

[image]
ActiveReports 19 .NET Edition
DbDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : DbDataSource Constructor

Glossary Item Box

Overload List

Overload | Description
DbDataSource Constructor(DataProviderInfo) | Creates new DbDataSource out of DataProviderInfo
DbDataSource Constructor(DbProviderFactory) | Creates new DbDataSource out of DbProviderFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


DbDataSource Constructor(DataProviderInfo)

[image]
ActiveReports 19 .NET Edition
DbDataSource Constructor(DataProviderInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class > DbDataSource Constructor : DbDataSource Constructor(DataProviderInfo)

dataProvider
Data provider information

Glossary Item Box

Creates new DbDataSource out of DataProviderInfo

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataProvider As DataProviderInfo _
)
C#
public DbDataSource(
   DataProviderInfo dataProvider
)

Parameters

dataProvider
Data provider information

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members
Overload List


DbDataSource Constructor(DbProviderFactory)

[image]
ActiveReports 19 .NET Edition
DbDataSource Constructor(DbProviderFactory)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class > DbDataSource Constructor : DbDataSource Constructor(DbProviderFactory)

factory
DbProviderFactory to be used

Glossary Item Box

Creates new DbDataSource out of DbProviderFactory

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal factory As DbProviderFactory _
)
C#
public DbDataSource(
   DbProviderFactory factory
)

Parameters

factory
DbProviderFactory to be used

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members
Overload List


DbDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
DbDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : DbDataSource Class

Glossary Item Box

For a list of all members of this type, see DbDataSource members.

Public Methods

 | Name | Description
Public Method | CreateConnection |
Public Method | SetCredentials |
Public Method | XmlRead |
Public Method | XmlWrite |
Top

See Also

Reference

DbDataSource Class
GrapeCity.ActiveReports.Data Namespace


CreateConnection Method

[image]
ActiveReports 19 .NET Edition
CreateConnection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : CreateConnection Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateConnection() As IDbConnection
C#
public IDbConnection CreateConnection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : SetCredentials Method

userName
password

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function SetCredentials( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
public virtual string SetCredentials(
   string userName,
   string password
)

Parameters

userName
password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


XmlRead Method

[image]
ActiveReports 19 .NET Edition
XmlRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : XmlRead Method

node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub XmlRead( _
   ByVal node As XmlNode _
)
C#
public void XmlRead(
   XmlNode node
)

Parameters

node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


XmlWrite Method

[image]
ActiveReports 19 .NET Edition
XmlWrite Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : XmlWrite Method

layoutDoc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub XmlWrite( _
   ByVal layoutDoc As XmlDocument, _
   ByVal node As XmlElement _
)
C#
public void XmlWrite(
   XmlDocument layoutDoc,
   XmlElement node
)

Parameters

layoutDoc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


DbDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
DbDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : DbDataSource Class

Glossary Item Box

For a list of all members of this type, see DbDataSource members.

Public Properties

 | Name | Description
Public Property | CommandText | Specifies a valid SQL statement used to retrieve records from the data source.
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source.
Public Property | CredentialsMode | Get or sets the value indicating whether the credentials dialog should be called or not.
Public Property | Factory | Gets data source's DbProviderFactory.
Public Property | ParamQuery |
Public Property | ProviderName | Returns provider's invariant name
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

See Also

Reference

DbDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandText Property

[image]
ActiveReports 19 .NET Edition
CommandText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : CommandText Property

Glossary Item Box

Specifies a valid SQL statement used to retrieve records from the data source.

Syntax

Visual Basic (Declaration)
Public Property CommandText As String
C#
public string CommandText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


CommandTimeout Property

[image]
ActiveReports 19 .NET Edition
CommandTimeout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : CommandTimeout Property

Glossary Item Box

Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


ConnectionString Property

[image]
ActiveReports 19 .NET Edition
ConnectionString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to open a connection to the data source.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


CredentialsMode Property

[image]
ActiveReports 19 .NET Edition
CredentialsMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : CredentialsMode Property

Glossary Item Box

Get or sets the value indicating whether the credentials dialog should be called or not.

Syntax

Visual Basic (Declaration)
Public Property CredentialsMode As CredentialsMode
C#
public CredentialsMode CredentialsMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


Factory Property

[image]
ActiveReports 19 .NET Edition
Factory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : Factory Property

Glossary Item Box

Gets data source's DbProviderFactory.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Factory As DbProviderFactory
C#
public DbProviderFactory Factory {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


ParamQuery Property

[image]
ActiveReports 19 .NET Edition
ParamQuery Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : ParamQuery Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParamQuery As String
C#
public string ParamQuery {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


ProviderName Property

[image]
ActiveReports 19 .NET Edition
ProviderName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : ProviderName Property

Glossary Item Box

Returns provider's invariant name

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ProviderName As String
C#
public virtual string ProviderName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


SQL Property

[image]
ActiveReports 19 .NET Edition
SQL Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : SQL Property

Glossary Item Box

Specifies a valid SQL statement used to retrieve records from the data source.

Syntax

Visual Basic (Declaration)
Public Property SQL As String
C#
public string SQL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


DbDataSource Class Fields

[image]
ActiveReports 19 .NET Edition
DbDataSource Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : DbDataSource Class

Glossary Item Box

For a list of all members of this type, see DbDataSource members.

Public Fields

 | Name | Description
Public Field | DefaultTimeout | The number of seconds to wait for a connection to open, before cancelling an attempt and generate an error.
Top

See Also

Reference

DbDataSource Class
GrapeCity.ActiveReports.Data Namespace


DefaultTimeout Field

[image]
ActiveReports 19 .NET Edition
DefaultTimeout Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > DbDataSource Class : DefaultTimeout Field

Glossary Item Box

The number of seconds to wait for a connection to open, before cancelling an attempt and generate an error.

Syntax

Visual Basic (Declaration)
Public Const DefaultTimeout As Integer
C#
public const int DefaultTimeout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbDataSource Class
DbDataSource Members


Field Class

[image]
ActiveReports 19 .NET Edition
Field Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

The Field class represents any data field available for data binding in section reports.

Object Model

Field Class

Syntax

Visual Basic (Declaration)
Public Class Field
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public class Field : GrapeCity.ActiveReports.Controls.Design.IPersistControl

Remarks

Field objects are created automatically for all fields in the bound data source. This class allows you to inspect the value of each field. You can create additional custom fields and add them to the Fields collection in the DataIntialize event. Custom field values should be set in the FetchData event.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.Field

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Members
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Class Members

[image]
ActiveReports 19 .NET Edition
Field Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

The following tables list the members exposed by Field.

Public Constructors

 | Name | Description
Public Constructor | Field Constructor | Initializes a new instance of the Field class.
Top

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Release the instance of the Field object from memory.
Public Method | ToString | Returns a string that represents the current Field object.
Top

Public Events

 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Constructor

[image]
ActiveReports 19 .NET Edition
Field Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Field Constructor

Glossary Item Box

Initializes a new instance of the Field class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Field()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Methods

[image]
ActiveReports 19 .NET Edition
Field Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Methods

 | Name | Description
Public Method | Dispose | Release the instance of the Field object from memory.
Public Method | ToString | Returns a string that represents the current Field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Dispose() Method

Glossary Item Box

Release the instance of the Field object from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : ToString Method

Glossary Item Box

Returns a string that represents the current Field object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Properties

[image]
ActiveReports 19 .NET Edition
Field Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : DefaultValue Property

Glossary Item Box

Gets or sets the user-defined default value of the field, which is used if the formula or value is null.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue {get; set;}

Example

C# Copy Code
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
Visual Basic Copy Code
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


FieldType Property

[image]
ActiveReports 19 .NET Edition
FieldType Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : FieldType Property

Glossary Item Box

Gets or sets the type associated with the field.

Syntax

Visual Basic (Declaration)
Public Property FieldType As FieldTypeEnum
C#
public FieldTypeEnum FieldType {get; set;}

Remarks

If the output of a field does not match the setting of the FieldType property, Field.DefaultValue takes precedence.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[1].FieldType = FieldTypeEnum.String;
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(1).FieldType = FieldTypeEnum.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Formula Property

[image]
ActiveReports 19 .NET Edition
Formula Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Formula Property

Glossary Item Box

Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.

Syntax

Visual Basic (Declaration)
Public Property Formula As String
C#
public string Formula {get; set;}

Example

C# Copy Code
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
Visual Basic Copy Code
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Name Property

Glossary Item Box

Gets or sets the name of the field.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

String value representing the name of the field.

Remarks

The name must be unique within the collection and is used as a key of the field in the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Name = "FirstField";
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Name = "FirstField"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Tag Property

[image]
ActiveReports 19 .NET Edition
Tag Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Tag Property

Glossary Item Box

Gets or sets a user-defined value associated with the field object.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An object user-defined value.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Tag = "Some extra data";
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Tag = "Some extra data"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Value Property

Glossary Item Box

Gets or sets the current value of the field object.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Events

[image]
ActiveReports 19 .NET Edition
Field Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Events

 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Disposed Event

Glossary Item Box

Raised when the Field object is released from memory.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


FieldCollection Class

[image]
ActiveReports 19 .NET Edition
FieldCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

The FieldCollection class manages the data binding fields used in the section report.

Object Model

FieldCollection Class

Syntax

Visual Basic (Declaration)
Public Class FieldCollection
   Inherits System.Collections.CollectionBase
C#
public class FieldCollection : System.Collections.CollectionBase

Remarks

ActiveReports populates this collection with fields from the data source and updates the values with each record in the data source. In addition, you can add your own custom fields in the DataInitialize event to create unbound calculated fields. Custom field values can be set in the FetchData event.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Data.FieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Members
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Class Members

[image]
ActiveReports 19 .NET Edition
FieldCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

The following tables list the members exposed by FieldCollection.

Public Constructors

 | Name | Description
Public Constructor | FieldCollection Constructor | Initializes a new instance of the FieldCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the fields collection from memory.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Constructor

[image]
ActiveReports 19 .NET Edition
FieldCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : FieldCollection Constructor

parent
The parent object of the field collection.

Glossary Item Box

Initializes a new instance of the FieldCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As IComponent _
)
C#
public FieldCollection(
   IComponent parent
)

Parameters

parent
The parent object of the field collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


FieldCollection Class Methods

[image]
ActiveReports 19 .NET Edition
FieldCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

For a list of all members of this type, see FieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the fields collection from memory.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Add Method

Glossary Item Box

Adds a new field to the collection. Adds a new field to the collection.

Overload List

Overload | Description
Add(String) | Adds a new field to the collection.
Add(Field) | Adds a new field to the collection.

Remarks

The Add method should be used in the DataInitialize event.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Add(String) Method

[image]
ActiveReports 19 .NET Edition
Add(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(String) Method

fieldName

Name of the field to be added to the collection.

Glossary Item Box

Adds a new field to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal fieldName As String _
) As Integer
C#
public int Add(
   string fieldName
)

Parameters

fieldName

Name of the field to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Add(Field) Method

[image]
ActiveReports 19 .NET Edition
Add(Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(Field) Method

field
The field to be added to the collection.

Glossary Item Box

Adds a new field to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal field As Field _
) As Integer
C#
public int Add(
   Field field
)

Parameters

field
The field to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Contains Method

Glossary Item Box

Returns a value indicating whether the field collection contains a field with the specified name.

Overload List

Overload | Description
Contains(String) | Returns whether the field collection contains a field with the specified name.
Contains(Field) | Returns whether the field collection contains the specified field.

Example

C# Copy Code
private void UnboundGrp_ReportEnd(object sender, System.EventArgs eArgs)
{
    if (this.Fields.Contains("DiscountTotal"))
    {
        System.Windows.Forms.MessageBox.Show ("Contains Discount Total");
    }
}
Visual Basic Copy Code
Private Sub UnboundGrp_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    If Me.Fields.Contains("DiscountTotal") Then
        MsgBox("contains discount total")
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Contains(String) Method

[image]
ActiveReports 19 .NET Edition
Contains(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(String) Method

fieldName
Specifies the field name to look for in the collection.

Glossary Item Box

Returns whether the field collection contains a field with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal fieldName As String _
) As Boolean
C#
public bool Contains(
   string fieldName
)

Parameters

fieldName
Specifies the field name to look for in the collection.

Return Value

A Boolean value that indicates whether the specified fieldname was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains(Field) Method

[image]
ActiveReports 19 .NET Edition
Contains(Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(Field) Method

field
Specifies the field to look for in the collection.

Glossary Item Box

Returns whether the field collection contains the specified field.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal field As Field _
) As Boolean
C#
public bool Contains(
   Field field
)

Parameters

field
Specifies the field to look for in the collection.

Return Value

A Boolean value indicating whether the specified field was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : CopyTo Method

fields
The array containing the copied fields.
index
The insertion index in the collection.

Glossary Item Box

Copies fields from the collection to an array, starting at a particular array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal fields() As Field, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Field[] fields,
   int index
)

Parameters

fields
The array containing the copied fields.
index
The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Dispose() Method

Glossary Item Box

Releases the fields collection from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf(Field) Method

[image]
ActiveReports 19 .NET Edition
IndexOf(Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : IndexOf(Field) Method

field
The field to find the index of in the collection.

Glossary Item Box

Finds the index number of the specified field in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal field As Field _
) As Integer
C#
public int IndexOf(
   Field field
)

Parameters

field
The field to find the index of in the collection.

Return Value

An integer indicating the position of the field within the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Insert Method

index
The indexed location within the fields collection in which to insert the new field.
field
The field to insert.

Glossary Item Box

Inserts an existing field in the fields collection at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal field As Field _
)
C#
public void Insert(
   int index,
   Field field
)

Parameters

index
The indexed location within the fields collection in which to insert the new field.
field
The field to insert.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Insert(0,Fields[1]);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Remove Method

Glossary Item Box

Removes the specified field from the collection.

Overload List

Overload | Description
Remove(Field) | Removes the specified field from the collection.
Remove(String) | Removes the field with specified name from the collection.
Remove(Int32) | Removes the field at the specified index from the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Remove(Field) Method

[image]
ActiveReports 19 .NET Edition
Remove(Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Field) Method

value
The field to remove.

Glossary Item Box

Removes the specified field from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal value As Field _
)
C#
public void Remove(
   Field value
)

Parameters

value
The field to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(String) Method

[image]
ActiveReports 19 .NET Edition
Remove(String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(String) Method

fieldName
Specifies the field name to remove from the collection.

Glossary Item Box

Removes the field with specified name from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal fieldName As String _
)
C#
public void Remove(
   string fieldName
)

Parameters

fieldName
Specifies the field name to remove from the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(Int32) Method

[image]
ActiveReports 19 .NET Edition
Remove(Int32) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Int32) Method

index

Specifies the index of the field to be removed.

Glossary Item Box

Removes the field at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index

Specifies the index of the field to be removed.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove(4);
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove(4)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


FieldCollection Class Properties

[image]
ActiveReports 19 .NET Edition
FieldCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

For a list of all members of this type, see FieldCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Item Property

Glossary Item Box

Gets the element at the specified index. Gets the specified field object from the collection.

Overload List

Overload | Description
Item(Int32) | Gets the Field object at the specified indexed location in the FieldCollection.
Item(String) | Gets the Field object with the specified name in the FieldCollection.

Remarks

This is the default property for the FieldCollection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MessageBox.Show(Me.Fields.Item(1).Name.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(Int32) Property

index
The indexed location of the Field in the collection.

Glossary Item Box

Gets the Field object at the specified indexed location in the FieldCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Field
C#
public Field Item(
   int index
) {get;}

Parameters

index
The indexed location of the Field in the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MsgBox(Me.Fields.Item(1).Name.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(String) Property

fieldName
The name of the Field in the collection.

Glossary Item Box

Gets the Field object with the specified name in the FieldCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal fieldName As String _
) As Field
C#
public Field Item(
   string fieldName
) {get;}

Parameters

fieldName
The name of the Field in the collection.

Example

C# Copy Code
private void UnboundGrp_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryID"].Value = m_reader["categories.CategoryID"].ToString();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        Fields["TotalLabel"].Value = "Total Number of " + m_reader["CategoryName"].ToString() + ":";
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
    //Item is the default property for Fields
    System.Windows.Forms.MessageBox.Show (this.Fields["Description"].Value.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport. _
    FetchEventArgs) Handles MyBase.FetchData
  Try    m_reader.Read()
    Me.Fields("CategoryID").Value = m_reader("categories.CategoryID")
    Me.Fields("CategoryName").Value = m_reader("CategoryName")
    Me.Fields("ProductName").Value = m_reader("ProductName")
    Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    Me.Fields("Description").Value = m_reader("Description")
    Me.Fields("TotalLabel").Value = "Total Number of " + m_reader("CategoryName") + ":"
    eArgs.EOF = False
  Catch ex As Exception
    System.Windows.Forms.MessageBox.Show(ex.ToString())
    eArgs.EOF = True
  End Try
  MsgBox(Me.Fields.Item("Description").Value.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


JsonDataSource Class

[image]
ActiveReports 19 .NET Edition
JsonDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : JsonDataSource Class

Glossary Item Box

Represents a section report data source based on a JSON document.

Object Model

JsonDataSource Class

Syntax

Visual Basic (Declaration)
Public Class JsonDataSource
C#
public class JsonDataSource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.JsonDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Members
GrapeCity.ActiveReports.Data Namespace


JsonDataSource Class Members

[image]
ActiveReports 19 .NET Edition
JsonDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : JsonDataSource Class

Glossary Item Box

The following tables list the members exposed by JsonDataSource.

Public Constructors

 | Name | Description
Public Constructor | JsonDataSource Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the json.
Public Property | CredentialsMode |
Public Property | EOF | Determines whether the CurrentPosition is at the end of data.
Public Property | JsonData | Specifies the json data string.
Public Property | JsonPath | Specifies the string used to select the data from json.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the JsonDataSource.
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the json columns names.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

JsonDataSource Class
GrapeCity.ActiveReports.Data Namespace


JsonDataSource Constructor

[image]
ActiveReports 19 .NET Edition
JsonDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : JsonDataSource Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public JsonDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


JsonDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
JsonDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : JsonDataSource Class

Glossary Item Box

For a list of all members of this type, see JsonDataSource members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the JsonDataSource.
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the json columns names.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

JsonDataSource Class
GrapeCity.ActiveReports.Data Namespace


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : Dispose() Method

Glossary Item Box

Releases the resources used by the JsonDataSource.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


Field Method

[image]
ActiveReports 19 .NET Edition
Field Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : Field Method

name
The name of the field.

Glossary Item Box

Returns the value of the field with the specified name.

Syntax

Visual Basic (Declaration)
Public Function Field( _
   ByVal name As String _
) As Object
C#
public object Field(
   string name
)

Parameters

name
The name of the field.

Return Value

The value of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


GetColumns Method

[image]
ActiveReports 19 .NET Edition
GetColumns Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : GetColumns Method

Glossary Item Box

Returns the list of the json columns names.

Syntax

Visual Basic (Declaration)
Public Function GetColumns() As List(Of String)
C#
public List<string> GetColumns()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


MoveFirst Method

[image]
ActiveReports 19 .NET Edition
MoveFirst Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : MoveFirst Method

resourceLocator

Glossary Item Box

Moves the current position to the first data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst( _
   Optional ByVal resourceLocator As ResourceLocator _
)
C#
public void MoveFirst(
   ResourceLocator resourceLocator
)

Parameters

resourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


MoveNext Method

[image]
ActiveReports 19 .NET Edition
MoveNext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : MoveNext Method

Glossary Item Box

Moves the current position to the next data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


JsonDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
JsonDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : JsonDataSource Class

Glossary Item Box

For a list of all members of this type, see JsonDataSource members.

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the json.
Public Property | CredentialsMode |
Public Property | EOF | Determines whether the CurrentPosition is at the end of data.
Public Property | JsonData | Specifies the json data string.
Public Property | JsonPath | Specifies the string used to select the data from json.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Top

See Also

Reference

JsonDataSource Class
GrapeCity.ActiveReports.Data Namespace


ConnectionString Property

[image]
ActiveReports 19 .NET Edition
ConnectionString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to load the data from the json.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


CredentialsMode Property

[image]
ActiveReports 19 .NET Edition
CredentialsMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : CredentialsMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CredentialsMode As CredentialsMode
C#
public CredentialsMode CredentialsMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


EOF Property

[image]
ActiveReports 19 .NET Edition
EOF Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : EOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the end of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF As Boolean
C#
public bool EOF {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


JsonData Property

[image]
ActiveReports 19 .NET Edition
JsonData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : JsonData Property

Glossary Item Box

Specifies the json data string.

Syntax

Visual Basic (Declaration)
Public Property JsonData As String
C#
public string JsonData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


JsonPath Property

[image]
ActiveReports 19 .NET Edition
JsonPath Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : JsonPath Property

Glossary Item Box

Specifies the string used to select the data from json.

Syntax

Visual Basic (Declaration)
Public Property JsonPath As String
C#
public string JsonPath {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > JsonDataSource Class : ResourceLocator Property

Glossary Item Box

Gets or sets the function that returns resource stream for a given name.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As Func(Of String,Stream)
C#
public Func<string,Stream> ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDataSource Class
JsonDataSource Members


ListDataSource Class

[image]
ActiveReports 19 .NET Edition
ListDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

Glossary Item Box

Represents a section report data source based on the IDataRecord and IDataReader members of the .NET Framework.

Object Model

ListDataSource Class

Syntax

Visual Basic (Declaration)
Public Class ListDataSource
   Implements IListDataSource
C#
public class ListDataSource : IListDataSource

Remarks

This class uses the IList interface to bind data from a custom object or a RowCollection to the report. The interface determines the structure of the data, so that the user needs no additional code to structure it.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.ListDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListDataSource Members
GrapeCity.ActiveReports.Data Namespace


ListDataSource Class Members

[image]
ActiveReports 19 .NET Edition
ListDataSource Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

Glossary Item Box

The following tables list the members exposed by ListDataSource.

Public Constructors

 | Name | Description
Public Constructor | ListDataSource Constructor | Initializes a new instance of the ListDataSource class.
Top

Public Properties

 | Name | Description
Public Property | DataReader |
Top

See Also

Reference

ListDataSource Class
GrapeCity.ActiveReports.Data Namespace


ListDataSource Constructor

[image]
ActiveReports 19 .NET Edition
ListDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > ListDataSource Class : ListDataSource Constructor

list
System.Collections.IList

Glossary Item Box

Initializes a new instance of the ListDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal list As IList _
)
C#
public ListDataSource(
   IList list
)

Parameters

list
System.Collections.IList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListDataSource Class
ListDataSource Members


ListDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
ListDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

Glossary Item Box

For a list of all members of this type, see ListDataSource members.

Public Properties

 | Name | Description
Public Property | DataReader |
Top

See Also

Reference

ListDataSource Class
GrapeCity.ActiveReports.Data Namespace


DataReader Property

[image]
ActiveReports 19 .NET Edition
DataReader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > ListDataSource Class : DataReader Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataReader As IDataReader
C#
public IDataReader DataReader {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListDataSource Class
ListDataSource Members


OdbcDataSource Class

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

ODBC data source - allows to connect through ODBC driver.

Object Model

OdbcDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OdbcDataSource
   Inherits DbDataSource
   Implements IDbConnectionProperties
C#
public sealed class OdbcDataSource : DbDataSource, IDbConnectionProperties

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.DbDataSource
GrapeCity.ActiveReports.Data.OdbcDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Members
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Class Members

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

The following tables list the members exposed by OdbcDataSource.

Public Constructors

 | Name | Description
Public Constructor | OdbcDataSource Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Constructor

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : OdbcDataSource Constructor

Glossary Item Box

Overload List

Overload | Description
OdbcDataSource Constructor() | Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout
OdbcDataSource Constructor(String,String,Int32) | Initializes a new instance of the OdbcDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OdbcDataSource Constructor()

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor()

Glossary Item Box

Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OdbcDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Constructor(String,String,Int32)

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Constructor(String,String,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor(String,String,Int32)

connectionString
The connection string.
sql
The current command text.
timeout
The command timeout.

Glossary Item Box

Initializes a new instance of the OdbcDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public OdbcDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
The connection string.
sql
The current command text.
timeout
The command timeout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

For a list of all members of this type, see OdbcDataSource members.

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : SetCredentials Method

userName
password

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function SetCredentials( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
public override string SetCredentials(
   string userName,
   string password
)

Parameters

userName
password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OdbcDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
OdbcDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

For a list of all members of this type, see OdbcDataSource members.

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


ProviderName Property

[image]
ActiveReports 19 .NET Edition
ProviderName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : ProviderName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ProviderName As String
C#
public override string ProviderName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OleDBDataSource Class

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

Represents a section report data source based on the OleDb ADO.NET data provider.

Object Model

OleDBDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OleDBDataSource
   Inherits DbDataSource
   Implements IDbConnectionProperties
C#
public sealed class OleDBDataSource : DbDataSource, IDbConnectionProperties

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    rptSub rpt = New rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.DbDataSource
GrapeCity.ActiveReports.Data.OleDBDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Class Members

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

The following tables list the members exposed by OleDBDataSource.

Public Constructors

 | Name | Description
Public Constructor | OleDBDataSource Constructor | Overloaded. Initializes a new instance of the OleDBDataSource class.
Top

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Constructor

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : OleDBDataSource Constructor

Glossary Item Box

Initializes a new instance of the OleDBDataSource class. Initializes a new instance of the OleDbDataSource class.

Overload List

Overload | Description
OleDBDataSource Constructor() | Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.
OleDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the OleDbDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


OleDBDataSource Constructor()

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor()

Glossary Item Box

Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OleDBDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Constructor(String,String,Int32)

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Constructor(String,String,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor(String,String,Int32)

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Glossary Item Box

Initializes a new instance of the OleDbDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public OleDBDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

For a list of all members of this type, see OleDBDataSource members.

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : SetCredentials Method

userName
password

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function SetCredentials( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
public override string SetCredentials(
   string userName,
   string password
)

Parameters

userName
password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


OleDBDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
OleDBDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

For a list of all members of this type, see OleDBDataSource members.

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


ProviderName Property

[image]
ActiveReports 19 .NET Edition
ProviderName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : ProviderName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ProviderName As String
C#
public override string ProviderName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


SqlDBDataSource Class

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

Represents a section report data source based on the SqlDB ADO.NET data provider.

Object Model

SqlDBDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlDBDataSource
   Inherits DbDataSource
   Implements IDbConnectionProperties
C#
public sealed class SqlDBDataSource : DbDataSource, IDbConnectionProperties

Example

C# Copy Code
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.DbDataSource
GrapeCity.ActiveReports.Data.SqlDBDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Class Members

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

The following tables list the members exposed by SqlDBDataSource.

Public Constructors

 | Name | Description
Public Constructor | SqlDBDataSource Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Constructor

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SqlDBDataSource Constructor

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class.

Overload List

Overload | Description
SqlDBDataSource Constructor() | Initializes a new instance of the SqlDBDataSource class.
SqlDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the SqlDBDataSource class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SqlDBDataSource Constructor()

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor()

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SqlDBDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Constructor(String,String,Int32)

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Constructor(String,String,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor(String,String,Int32)

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public SqlDBDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

For a list of all members of this type, see SqlDBDataSource members.

Public Methods

 | Name | Description
Public Method | SetCredentials | Overridden.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SetCredentials Method

userName
password

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function SetCredentials( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
public override string SetCredentials(
   string userName,
   string password
)

Parameters

userName
password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SqlDBDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
SqlDBDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

For a list of all members of this type, see SqlDBDataSource members.

Public Properties

 | Name | Description
Public Property | ProviderName | Overridden.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


ProviderName Property

[image]
ActiveReports 19 .NET Edition
ProviderName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : ProviderName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ProviderName As String
C#
public override string ProviderName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


XMLDataSource Class

[image]
ActiveReports 19 .NET Edition
XMLDataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

Represents a section report data source based on an XML document and an XPath pattern to select the XML nodes used as records in the data source.

Object Model

XMLDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XMLDataSource
C#
public sealed class XMLDataSource

Remarks

ActiveReports supports a DataType attribute for nodes in the XML file. This attribute helps ActiveReports determine the data type of bound fields. Valid values include: double, datetime and string.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.XMLDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Members
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Class Members

[image]
ActiveReports 19 .NET Edition
XMLDataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

The following tables list the members exposed by XMLDataSource.

Public Constructors

 | Name | Description
Public Constructor | XMLDataSource Constructor | Overloaded. Initializes a new instance of the XMLDataSource class.
Top

Public Properties

 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CredentialsMode |
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top

Public Methods

 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Constructor

[image]
ActiveReports 19 .NET Edition
XMLDataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : XMLDataSource Constructor

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Overload List

Overload | Description
XMLDataSource Constructor() | Initializes a new instance of the XMLDataSource class.
XMLDataSource Constructor(String,String) | Initializes a new instance of the XMLDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Constructor()

[image]
ActiveReports 19 .NET Edition
XMLDataSource Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor()

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public XMLDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Constructor(String,String)

[image]
ActiveReports 19 .NET Edition
XMLDataSource Constructor(String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor(String,String)

fileUrl
The path to the XML file.
recordsetPattern
The Xpath expression that specifies the record pattern.

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileUrl As String, _
   ByVal recordsetPattern As String _
)
C#
public XMLDataSource(
   string fileUrl,
   string recordsetPattern
)

Parameters

fileUrl
The path to the XML file.
recordsetPattern
The Xpath expression that specifies the record pattern.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Class Methods

[image]
ActiveReports 19 .NET Edition
XMLDataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

For a list of all members of this type, see XMLDataSource members.

Public Methods

 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


Field Method

[image]
ActiveReports 19 .NET Edition
Field Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Field Method

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).

Overload List

Overload | Description
Field(String,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node.
Field(String,Boolean,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)xDS.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Field(String,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Field(String,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean) Method

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node.

Syntax

Visual Basic (Declaration)
Public Overloads Function Field( _
   ByVal name As String, _
   ByVal asNodeList As Boolean _
) As Object
C#
public object Field(
   string name,
   bool asNodeList
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


Field(String,Boolean,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Field(String,Boolean,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean,Boolean) Method

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
isOutputformatNull
Specifies whether to use the text of the current node.

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.

Syntax

Visual Basic (Declaration)
Public Overloads Function Field( _
   ByVal name As String, _
   ByVal asNodeList As Boolean, _
   ByVal isOutputformatNull As Boolean _
) As Object
C#
public object Field(
   string name,
   bool asNodeList,
   bool isOutputformatNull
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
isOutputformatNull
Specifies whether to use the text of the current node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


LoadXML Method

[image]
ActiveReports 19 .NET Edition
LoadXML Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : LoadXML Method

xmlFragment
Specifies a valid XML fragment string to be loaded into the XML document.

Glossary Item Box

Loads an XML fragment from a string.

Syntax

Visual Basic (Declaration)
Public Sub LoadXML( _
   ByVal xmlFragment As String _
)
C#
public void LoadXML(
   string xmlFragment
)

Parameters

xmlFragment
Specifies a valid XML fragment string to be loaded into the XML document.

Remarks

The XML is parsed and used as the XML document source.

Example

Paste into the ReportStart event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource ds = new GrapeCity.ActiveReports.Data.XMLDataSource();
    ds.ValidateOnParse = true;
    ds.FileURL = null;
    ds.RecordsetPattern = "//Customer";
    ds.LoadXML("<Order><Customer><Name>John Doe</Name><Cardnum>131 131 131 131</Cardnum><Manifest><Item><ID>204</ID><Title>Advanced VB</Title><Quantity>1</Quantity><UnitPrice>$10.75</UnitPrice></Item></Manifest><Receipt><Subtotal>$23.75</Subtotal><Tax>$2.43</Tax></Receipt></Customer></Order>");
Paste into the ReportStart event.
Visual Basic Copy Code
Dim ds As New GrapeCity.ActiveReports.Data.XMLDataSource
    ds.FileURL = Nothing
    ds.ValidateOnParse = True
    ds.RecordsetPattern = "//Customer"
    ds.LoadXML("<Order>" & _
        "<Customer>" & _
        "<Name>John Doe</Name>" & _
        "<Cardnum>131 131 131 131</Cardnum>" & _
        "<Manifest>" & _
        "<Item>" & _
        "<ID>204</ID>" & _
        "<Title>Advanced VB</Title>" & _
        "<Quantity>1</Quantity>" & _
        "<UnitPrice>$10.75</UnitPrice>" & _
        "</Item>" & _
        "</Manifest>" & _
        "<Receipt>" & _
        "<Subtotal>$23.75</Subtotal>" & _
        "<Tax>$2.43</Tax>" & _
        "</Receipt>" & _
        "</Customer>" & _
        "</Order>")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveFirst Method

[image]
ActiveReports 19 .NET Edition
MoveFirst Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveFirst Method

Glossary Item Box

Moves the current position to the first node in the NodeList.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst()
C#
public void MoveFirst()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveNext Method

[image]
ActiveReports 19 .NET Edition
MoveNext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveNext Method

Glossary Item Box

Moves the CurrentPosition to the next node in the NodeList.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Class Properties

[image]
ActiveReports 19 .NET Edition
XMLDataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

For a list of all members of this type, see XMLDataSource members.

Public Properties

 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CredentialsMode |
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ResourceLocator | Gets or sets the function that returns resource stream for a given name.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


BOF Property

[image]
ActiveReports 19 .NET Edition
BOF Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : BOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the first node in the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BOF As Boolean
C#
public bool BOF {get;}

Property Value

Boolean. True if the CurrentPostion is at the first node in the NodeList; otherwise, False.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Count Property

Glossary Item Box

Gets the number of nodes (records) in the node list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

Integer.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


CredentialsMode Property

[image]
ActiveReports 19 .NET Edition
CredentialsMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : CredentialsMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CredentialsMode As CredentialsMode
C#
public CredentialsMode CredentialsMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


CurrentPosition Property

[image]
ActiveReports 19 .NET Edition
CurrentPosition Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : CurrentPosition Property

Glossary Item Box

Gets the index of the current node in the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPosition As Integer
C#
public int CurrentPosition {get;}

Property Value

A long value that represents the current node in the NodeList.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Document Property

Glossary Item Box

Returns a reference to the loaded XmlDocument that is used as the data source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As XmlDocument
C#
public XmlDocument Document {get;}

Example

C# Copy Code
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.ds.Document.BaseURI.ToString());
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MsgBox(Me.ds.Document.BaseURI.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


EOF Property

[image]
ActiveReports 19 .NET Edition
EOF Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : EOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the end of the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF As Boolean
C#
public bool EOF {get;}

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


FileURL Property

[image]
ActiveReports 19 .NET Edition
FileURL Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : FileURL Property

Glossary Item Box

Gets or sets the file name or url used to retrieve the XML document to be used as a data source.

Syntax

Visual Basic (Declaration)
Public Property FileURL As String
C#
public string FileURL {get; set;}

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


NodeList Property

[image]
ActiveReports 19 .NET Edition
NodeList Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : NodeList Property

Glossary Item Box

Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.

Syntax

Visual Basic (Declaration)
Public Property NodeList As XmlNodeList
C#
public XmlNodeList NodeList {get; set;}

Property Value

An XmlNodeList object.

Remarks

You can set the NodeList property to your own XmlNodeList object without setting the FileURL or RecordsetPattern. This can be useful in subreports where the parent report sets the NodeList of the subreport data source from one of its fields (returned from the Field method as an XmlNodeList).

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


RecordsetPattern Property

[image]
ActiveReports 19 .NET Edition
RecordsetPattern Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : RecordsetPattern Property

Glossary Item Box

Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.

Syntax

Visual Basic (Declaration)
Public Property RecordsetPattern As String
C#
public string RecordsetPattern {get; set;}

Remarks

The report uses each node selected in the RecordSetPattern to create a detail section.

Note: XSL patterns are case sensitive and must use valid XSL syntax. XSL and XPath documentation can be found on MSDN at https://learn.microsoft.com/en-us/previous-versions/dotnet/netframework-4.0/ms256172(v=vs.100)?redirectedfrom=MSDN and https://learn.microsoft.com/en-us/previous-versions/dotnet/netframework-4.0/ms256471(v=vs.100)?redirectedfrom=MSDN.

Typical XSL patterns:

Pattern Description

//* All Nodes
//ITEM All ITEM Nodes
/ Root item
/LAYOUT/ITEM/* All child nodes of /LAYOUT/ITEM
//ITEM[@type] All item nodes that contain the type attribute
//ITEM[@id="1"] All item nodes that have an id attribute value of "1"

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : ResourceLocator Property

Glossary Item Box

Gets or sets the function that returns resource stream for a given name.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As Func(Of String,Stream)
C#
public Func<string,Stream> ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


ValidateOnParse Property

[image]
ActiveReports 19 .NET Edition
ValidateOnParse Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : ValidateOnParse Property

Glossary Item Box

Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.

Syntax

Visual Basic (Declaration)
Public Property ValidateOnParse As Boolean
C#
public bool ValidateOnParse {get; set;}

Property Value

Boolean.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


FieldTypeEnum Enumeration

[image]
ActiveReports 19 .NET Edition
FieldTypeEnum Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldTypeEnum Enumeration

Glossary Item Box

Provides a set of values for use with the FieldType property of the Field class.

Syntax

Visual Basic (Declaration)
Public Enum FieldTypeEnum
   Inherits System.Enum
C#
public enum FieldTypeEnum : System.Enum

Members

Member | Description
Boolean | Specifies that the field contains a Boolean value.
Date | Specifies that the field contains a date value.
Double | Specifies that the field contains a double value.
Float | Specifies that the field contains a float value.
Int32 | Specifies that the field contains an integer value.
None | No type is specified for the data value.
String | Specifies that the field contains a string value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Data.FieldTypeEnum

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Data Namespace


IDbConnectionProperties Interface

[image]
ActiveReports 19 .NET Edition
IDbConnectionProperties Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IDbConnectionProperties Interface

Glossary Item Box

Interface to access base connection properties

Syntax

Visual Basic (Declaration)
Public Interface IDbConnectionProperties
C#
public interface IDbConnectionProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionProperties Members
GrapeCity.ActiveReports.Data Namespace


IDbConnectionProperties Interface Members

[image]
ActiveReports 19 .NET Edition
IDbConnectionProperties Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IDbConnectionProperties Interface

Glossary Item Box

The following tables list the members exposed by IDbConnectionProperties.

Public Properties

 | Name | Description
Property | ConnectionString | Gets connection string.
Property | ProviderName | Gets provider name string.
Top

Public Methods

 | Name | Description
Method | SetCredentials | Sets credentials.
Top

See Also

Reference

IDbConnectionProperties Interface
GrapeCity.ActiveReports.Data Namespace


IDbConnectionProperties Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbConnectionProperties Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IDbConnectionProperties Interface

Glossary Item Box

For a list of all members of this type, see IDbConnectionProperties members.

Public Methods

 | Name | Description
Method | SetCredentials | Sets credentials.
Top

See Also

Reference

IDbConnectionProperties Interface
GrapeCity.ActiveReports.Data Namespace


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IDbConnectionProperties Interface : SetCredentials Method

userName
password

Glossary Item Box

Sets credentials.

Syntax

Visual Basic (Declaration)
Function SetCredentials( _
   ByVal userName As String, _
   ByVal password As String _
) As String
C#
string SetCredentials(
   string userName,
   string password
)

Parameters

userName
password

Return Value

Connection string with credentials.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionProperties Interface
IDbConnectionProperties Members


IDbConnectionProperties Interface Properties

[image]
ActiveReports 19 .NET Edition
IDbConnectionProperties Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IDbConnectionProperties Interface

Glossary Item Box

For a list of all members of this type, see IDbConnectionProperties members.

Public Properties

 | Name | Description
Property | ConnectionString | Gets connection string.
Property | ProviderName | Gets provider name string.
Top

See Also

Reference

IDbConnectionProperties Interface
GrapeCity.ActiveReports.Data Namespace


ConnectionString Property

[image]
ActiveReports 19 .NET Edition
ConnectionString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IDbConnectionProperties Interface : ConnectionString Property

Glossary Item Box

Gets connection string.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConnectionString As String
C#
string ConnectionString {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionProperties Interface
IDbConnectionProperties Members


ProviderName Property

[image]
ActiveReports 19 .NET Edition
ProviderName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IDbConnectionProperties Interface : ProviderName Property

Glossary Item Box

Gets provider name string.

Syntax

Visual Basic (Declaration)
ReadOnly Property ProviderName As String
C#
string ProviderName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionProperties Interface
IDbConnectionProperties Members


IListDataSource Interface

[image]
ActiveReports 19 .NET Edition
IListDataSource Interface
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IListDataSource Interface

Glossary Item Box

Wrapper over System.Collections.IList interface to use it as data source: GrapeCity.ActiveReports.SectionReport.DataSource. This should be used only if performance of current implementation is not enough. This snippet shows how to implement the interface with https://www.nuget.org/packages/FastMember.Signed/1.5.0 Note: Product here is custom business object. class Product { public int ProductID { get; set; } public string ProductName { get; set; } } class FastListDataSource : IListDataSource { private readonly System.Collections.Generic.IList < Product > _list; private readonly System.Data.IDataReader _reader; public FastListDataSource(System.Collections.Generic.IList < Product > list) { _list = list; _reader = FastMember.ObjectReader.Create(_list); } public object GetValue(string fieldName, int ordinal) { var index = fieldName.IndexOf('.'); if (index == -1) return _reader.GetValue(ordinal); var fields = fieldName.Split('.'); var target = _reader.GetValue(ordinal); for (int i = 1; i != fields.Length; i++) target = FastMember.ObjectAccessor.Create(target)[fields[i]]; return target; } public int GetOrdinal(string fieldName) { var index = fieldName.IndexOf('.'); if (index == -1) return _reader.GetOrdinal(fieldName); return _reader.GetOrdinal(fieldName.Substring(0, index)); } public System.Collections.IList List => (System.Collections.IList)_list; public System.Data.IDataReader DataReader => _reader; }

Syntax

Visual Basic (Declaration)
Public Interface IListDataSource
C#
public interface IListDataSource

Example

This snippet shows how to implement the interface with https://www.nuget.org/packages/FastMember.Signed/1.5.0 Note: Product here is custom business object.
C# Copy Code
class Product
{
    public int ProductID { get; set; }
    public string ProductName { get; set; }
}
class FastListDataSource : IListDataSource
{
    private readonly System.Collections.Generic.IList < Product > _list;
    private readonly System.Data.IDataReader _reader;
    public FastListDataSource(System.Collections.Generic.IList < Product > list)
    {
        _list = list;
        _reader = FastMember.ObjectReader.Create(_list);
    }
    public object GetValue(string fieldName, int ordinal)
    {
        var index = fieldName.IndexOf('.');
        if (index == -1)
            return _reader.GetValue(ordinal);
        var fields = fieldName.Split('.');
        var target = _reader.GetValue(ordinal);
        for (int i = 1; i != fields.Length; i++)
            target = FastMember.ObjectAccessor.Create(target)[fields[i]];
        return target;
    }
    public int GetOrdinal(string fieldName)
    {
        var index = fieldName.IndexOf('.');
        if (index == -1)
            return _reader.GetOrdinal(fieldName);
        return _reader.GetOrdinal(fieldName.Substring(0, index));
    }
    public System.Collections.IList List => (System.Collections.IList)_list;
    public System.Data.IDataReader DataReader => _reader;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListDataSource Members
GrapeCity.ActiveReports.Data Namespace


IListDataSource Interface Members

[image]
ActiveReports 19 .NET Edition
IListDataSource Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IListDataSource Interface

Glossary Item Box

The following tables list the members exposed by IListDataSource.

Public Properties

 | Name | Description
Property | DataReader | System.Data.IDataReader to read the data.
Property | List | Wrapped System.Collections.IList instance.
Top

Public Methods

 | Name | Description
Method | GetOrdinal | Allows to cache ordinal. Suggested to return 0 or any valid value for GetValue method implementation.
Method | GetValue | Access to value.
Top

See Also

Reference

IListDataSource Interface
GrapeCity.ActiveReports.Data Namespace


IListDataSource Interface Methods

[image]
ActiveReports 19 .NET Edition
IListDataSource Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IListDataSource Interface

Glossary Item Box

For a list of all members of this type, see IListDataSource members.

Public Methods

 | Name | Description
Method | GetOrdinal | Allows to cache ordinal. Suggested to return 0 or any valid value for GetValue method implementation.
Method | GetValue | Access to value.
Top

See Also

Reference

IListDataSource Interface
GrapeCity.ActiveReports.Data Namespace


GetOrdinal Method

[image]
ActiveReports 19 .NET Edition
GetOrdinal Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IListDataSource Interface : GetOrdinal Method

fieldName

Glossary Item Box

Allows to cache ordinal. Suggested to return 0 or any valid value for GetValue method implementation.

Syntax

Visual Basic (Declaration)
Function GetOrdinal( _
   ByVal fieldName As String _
) As Integer
C#
int GetOrdinal(
   string fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListDataSource Interface
IListDataSource Members


GetValue Method

[image]
ActiveReports 19 .NET Edition
GetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IListDataSource Interface : GetValue Method

fieldName
Field name. Nested names separated with by '.' symbol.
ordinal
Value from GetOrdinal.

Glossary Item Box

Access to value.

Syntax

Visual Basic (Declaration)
Function GetValue( _
   ByVal fieldName As String, _
   ByVal ordinal As Integer _
) As Object
C#
object GetValue(
   string fieldName,
   int ordinal
)

Parameters

fieldName
Field name. Nested names separated with by '.' symbol.
ordinal
Value from GetOrdinal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListDataSource Interface
IListDataSource Members


IListDataSource Interface Properties

[image]
ActiveReports 19 .NET Edition
IListDataSource Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : IListDataSource Interface

Glossary Item Box

For a list of all members of this type, see IListDataSource members.

Public Properties

 | Name | Description
Property | DataReader | System.Data.IDataReader to read the data.
Property | List | Wrapped System.Collections.IList instance.
Top

See Also

Reference

IListDataSource Interface
GrapeCity.ActiveReports.Data Namespace


DataReader Property

[image]
ActiveReports 19 .NET Edition
DataReader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IListDataSource Interface : DataReader Property

Glossary Item Box

System.Data.IDataReader to read the data.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataReader As IDataReader
C#
IDataReader DataReader {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListDataSource Interface
IListDataSource Members


List Property

[image]
ActiveReports 19 .NET Edition
List Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > IListDataSource Interface : List Property

Glossary Item Box

Wrapped System.Collections.IList instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property List As IList
C#
IList List {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListDataSource Interface
IListDataSource Members


PageDocument Class

[image]
ActiveReports 19 .NET Edition
PageDocument Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

Represents the report processing capabilities. Represents the report processing capabilities.

Object Model

PageDocument Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageDocument
C#
public sealed class PageDocument

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.PageDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Members
GrapeCity.ActiveReports.Document Namespace


PageDocument Class Members

[image]
ActiveReports 19 .NET Edition
PageDocument Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

The following tables list the members exposed by PageDocument.

Public Constructors

 | Name | Description
Public Constructor | PageDocument Constructor | Initializes a new instance of PageDocument Class.
Top

Public Properties

 | Name | Description
Public Property | IsEmpty | Gets the value indicating whether the report contains any data.
Public Property | LocateDataSourceFn | Gets a delegate that can be used to retrieve data from a data source.
Public Property | PageReport | Gets the current report instance.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Public Property | ResolveCredentialsFn | Gets a delegate that can be used to retrieve credentials.
Top

Public Methods

 | Name | Description
Public Method | ApplyInteractivity | Applies interactive actions to the report instance the next time it is rendered.
Public Method | Dispose | Performs tasks associated with the freeing and releasing of resources.
Public Method | InitializeReportHandlers | Sets the default event handlers for LocateDataSource and LocateCredentials.
static (Shared in Visual Basic) | LoadSnapshot | Overloaded. Loads a page document from the snapshot file.
Public Method | Render | Overloaded. Renders a report using the specified rendering extension and output configuration.
Public Method | ResetPrinter | Resets the printer properties.
Public Method | SaveSnapshot | Overloaded. Saves document snapshot to the specified file.
Top

Public Events

 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


PageDocument Constructor

[image]
ActiveReports 19 .NET Edition
PageDocument Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageDocument Constructor

pageReport
An instance of PageReport

Glossary Item Box

Initializes a new instance of PageDocument Class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageReport As PageReport _
)
C#
public PageDocument(
   PageReport pageReport
)

Parameters

pageReport
An instance of PageReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Methods

[image]
ActiveReports 19 .NET Edition
PageDocument Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Methods

 | Name | Description
Public Method | ApplyInteractivity | Applies interactive actions to the report instance the next time it is rendered.
Public Method | Dispose | Performs tasks associated with the freeing and releasing of resources.
Public Method | InitializeReportHandlers | Sets the default event handlers for LocateDataSource and LocateCredentials.
static (Shared in Visual Basic) | LoadSnapshot | Overloaded. Loads a page document from the snapshot file.
Public Method | Render | Overloaded. Renders a report using the specified rendering extension and output configuration.
Public Method | ResetPrinter | Resets the printer properties.
Public Method | SaveSnapshot | Overloaded. Saves document snapshot to the specified file.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


ApplyInteractivity Method

[image]
ActiveReports 19 .NET Edition
ApplyInteractivity Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ApplyInteractivity Method

actions
The interactive actions to be applied.

Glossary Item Box

Applies interactive actions to the report instance the next time it is rendered.

Syntax

Visual Basic (Declaration)
Public Sub ApplyInteractivity( _
   ByVal actions As InteractiveActions _
)
C#
public void ApplyInteractivity(
   InteractiveActions actions
)

Parameters

actions
The interactive actions to be applied.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Dispose Method

Glossary Item Box

Performs tasks associated with the freeing and releasing of resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


InitializeReportHandlers Method

[image]
ActiveReports 19 .NET Edition
InitializeReportHandlers Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : InitializeReportHandlers Method

document
A PageDocument instance contains LocateDataSourceFn and ResolveCredentialsFn delegates for LocateDataSource and LocateCredentials handles respectively.

Glossary Item Box

Sets the default event handlers for LocateDataSource and LocateCredentials.

Syntax

Visual Basic (Declaration)
Public Sub InitializeReportHandlers( _
   ByVal document As PageDocument _
)
C#
public void InitializeReportHandlers(
   PageDocument document
)

Parameters

document
A PageDocument instance contains LocateDataSourceFn and ResolveCredentialsFn delegates for LocateDataSource and LocateCredentials handles respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LoadSnapshot Method

[image]
ActiveReports 19 .NET Edition
LoadSnapshot Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LoadSnapshot Method

Glossary Item Box

Loads a page document from the snapshot file.

Overload List

Overload | Description
LoadSnapshot(FileInfo) | Loads a page document from the snapshot file.
LoadSnapshot(Stream,ResourceLocator) | Loads a page document from the stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LoadSnapshot(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
LoadSnapshot(FileInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > LoadSnapshot Method : LoadSnapshot(FileInfo) Method

snapshotFile

Glossary Item Box

Loads a page document from the snapshot file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LoadSnapshot( _
   ByVal snapshotFile As FileInfo _
) As PageDocument
C#
public static PageDocument LoadSnapshot(
   FileInfo snapshotFile
)

Parameters

snapshotFile

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


LoadSnapshot(Stream,ResourceLocator) Method

[image]
ActiveReports 19 .NET Edition
LoadSnapshot(Stream,ResourceLocator) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > LoadSnapshot Method : LoadSnapshot(Stream,ResourceLocator) Method

snapshotStream
resourceLocator

Glossary Item Box

Loads a page document from the stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LoadSnapshot( _
   ByVal snapshotStream As Stream, _
   Optional ByVal resourceLocator As ResourceLocator _
) As PageDocument
C#
public static PageDocument LoadSnapshot(
   Stream snapshotStream,
   ResourceLocator resourceLocator
)

Parameters

snapshotStream
resourceLocator

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Render Method

Glossary Item Box

Renders a report using the specified rendering extension and output configuration.

Overload List

Overload | Description
Render(IRenderingExtension,StreamProvider) | Renders a report using the specified rendering extension and output configuration.
Render(IRenderingExtension,StreamProvider,NameValueCollection) | Renders a report using the specified rendering extension with the specified values.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) | Renders a report using the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) | Renders a report using the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) | Renders a report using the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken,IProgress<ProgressInfo>) | Renders a report using the specified rendering extension with the specified values and refreshed data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Render(IRenderingExtension,StreamProvider) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.

Glossary Item Box

Renders a report using the specified rendering extension and output configuration.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if a report-specific error occured.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
var renderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
DirectoryInfo di = new DirectoryInfo(@"D:\Report");
FileStreamProvider stream = new FileStreamProvider(di, "MyReport");
pageReport.Document.Render(renderingExtension, stream);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider,NameValueCollection) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.

Glossary Item Box

Renders a report using the specified rendering extension with the specified values.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   NameValueCollection settings
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if a report-specific error occured.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
Settings settings = new Settings();
settings.HideToolbar = true;
settings.HideMenubar = true;
settings.HideWindowUI = true;
settings.Author = "Joe Smith";
PdfRenderingExtension renderingExtension = new PdfRenderingExtension();
DirectoryInfo di = new DirectoryInfo(@"D:\Report");
FileStreamProvider exportfile = new FileStreamProvider(di, "MyReport");
pageReport.Document.Render(renderingExtension, exportfile, settings);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.

Glossary Item Box

Renders a report using the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if a report-specific error occured.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
Settings settings = new Settings();
settings.HideToolbar = true;
settings.HideMenubar = true;
settings.HideWindowUI = true;
settings.Author = "Joe Smith";
PdfRenderingExtension renderingExtension = new PdfRenderingExtension();
DirectoryInfo di = new DirectoryInfo(@"D:\Report");
FileStreamProvider exportfile = new FileStreamProvider(di, "MyReport");
pageReport.Document.Render(renderingExtension, exportfile, settings, true);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

renderingExtension
The GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension used to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.

Glossary Item Box

Renders a report using the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh,
   bool forceParameterDataRefresh
)

Parameters

renderingExtension
The GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension used to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if a report-specific error occured.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
Settings settings = new Settings();
settings.HideToolbar = true;
settings.HideMenubar = true;
settings.HideWindowUI = true;
settings.Author = "Joe Smith";
PdfRenderingExtension renderingExtension = new PdfRenderingExtension();
DirectoryInfo di = new DirectoryInfo(@"D:\Report");
FileStreamProvider exportfile = new FileStreamProvider(di, "MyReport");
pageReport.Document.Render(renderingExtension, exportfile, settings, true, true);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.
token
Allows to stop rendering

Glossary Item Box

Renders a report using the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean, _
   ByVal token As CancellationToken _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh,
   bool forceParameterDataRefresh,
   CancellationToken token
)

Parameters

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.
token
Allows to stop rendering

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if a report-specific error occured.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
private CancellationTokenSource _cancellationTokenSource;
private async void ExportAsync(PageReport report, IRenderingExtension renderingExtension, FileStreamProvider outputProvider, NameValueCollection settings)
{
    _cancellationTokenSource = new CancellationTokenSource();
    cancelButton.Text = "Cancel";
    await Task.Run(() =>
    {
        try
        {
            report.Document.Render(renderingExtension, outputProvider, settings, false, false, _cancellationTokenSource.Token);
        }
        catch (OperationCanceledException)
        {
        }
    });
    if (_cancellationTokenSource.IsCancellationRequested)
    MessageBox.Show("Export was cancelled", "Export", MessageBoxButtons.OK, MessageBoxIcon.Information);
    _cancellationTokenSource.Dispose();
}
private void cancelExport(object sender, EventArgs e)
{
    _cancellationTokenSource?.Cancel();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken,IProgress<ProgressInfo>) Method

[image]
ActiveReports 19 .NET Edition
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken,IProgress<ProgressInfo>) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken,IProgress<ProgressInfo>) Method

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.
token
Allows to stop rendering
progress
The IProgress of type GrapeCity.ActiveReports.Rendering.Export.ProgressInfo provides progress updates.

Glossary Item Box

Renders a report using the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean, _
   ByVal token As CancellationToken, _
   ByVal progress As IProgress(Of ProgressInfo) _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh,
   bool forceParameterDataRefresh,
   CancellationToken token,
   IProgress<ProgressInfo> progress
)

Parameters

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or query of the data even if the DataMap has already retrieved the required data.
forceParameterDataRefresh
Set to True to force a refresh or query of the parameter data.
token
Allows to stop rendering
progress
The IProgress of type GrapeCity.ActiveReports.Rendering.Export.ProgressInfo provides progress updates.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | Thrown if something is wrong with the structure of the report.
System.ComponentModel.LicenseException | Thrown when a component cannot be granted a license.
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException | Thrown if validation problems occurred.
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException | Thrown when an error related to a report's parameter occurs.
System.OperationCanceledException | Thrown in a thread upon cancellation of an operation that the thread was executing.

Example

C# Copy Code
labelExport.Text = "Export started";
var control = this;
var progress = new Progress<ProgressInfo>(progressInfo =>
{
    control.BeginInvoke(new MethodInvoker(() =>
    {
        labelExport.Text = progressInfo.IsLast ? "Export is finished." : $"Exported {progressInfo.PageNumber} pages.";
    }));
});
await Task.Run(() =>
{
    report.Document.Render(renderingExtension, outputProvider, settings, false, false, CancellationToken.None, progress);
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


ResetPrinter Method

[image]
ActiveReports 19 .NET Edition
ResetPrinter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ResetPrinter Method

Glossary Item Box

Resets the printer properties.

Syntax

Visual Basic (Declaration)
Public Sub ResetPrinter()
C#
public void ResetPrinter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


SaveSnapshot Method

[image]
ActiveReports 19 .NET Edition
SaveSnapshot Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : SaveSnapshot Method

Glossary Item Box

Saves document snapshot to the specified file.

Overload List

Overload | Description
SaveSnapshot(FileInfo,Boolean) | Saves document snapshot to the specified file.
SaveSnapshot(Stream,Boolean) | Saves a document snapshot to the specified stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


SaveSnapshot(FileInfo,Boolean) Method

[image]
ActiveReports 19 .NET Edition
SaveSnapshot(FileInfo,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > SaveSnapshot Method : SaveSnapshot(FileInfo,Boolean) Method

snapshotFile
isInteractive

Glossary Item Box

Saves document snapshot to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveSnapshot( _
   ByVal snapshotFile As FileInfo, _
   Optional ByVal isInteractive As Boolean _
)
C#
public void SaveSnapshot(
   FileInfo snapshotFile,
   bool isInteractive
)

Parameters

snapshotFile
isInteractive

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


SaveSnapshot(Stream,Boolean) Method

[image]
ActiveReports 19 .NET Edition
SaveSnapshot(Stream,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > SaveSnapshot Method : SaveSnapshot(Stream,Boolean) Method

snapshotStream
isInteractive

Glossary Item Box

Saves a document snapshot to the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveSnapshot( _
   ByVal snapshotStream As Stream, _
   Optional ByVal isInteractive As Boolean _
)
C#
public void SaveSnapshot(
   Stream snapshotStream,
   bool isInteractive
)

Parameters

snapshotStream
isInteractive

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


PageDocument Class Properties

[image]
ActiveReports 19 .NET Edition
PageDocument Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Properties

 | Name | Description
Public Property | IsEmpty | Gets the value indicating whether the report contains any data.
Public Property | LocateDataSourceFn | Gets a delegate that can be used to retrieve data from a data source.
Public Property | PageReport | Gets the current report instance.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Public Property | ResolveCredentialsFn | Gets a delegate that can be used to retrieve credentials.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : IsEmpty Property

Glossary Item Box

Gets the value indicating whether the report contains any data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Property Value

A System.Boolean value. true if the report contains no data; otherwise, false.

Remarks

true if the report contains no data; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LocateDataSourceFn Property

[image]
ActiveReports 19 .NET Edition
LocateDataSourceFn Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateDataSourceFn Property

Glossary Item Box

Gets a delegate that can be used to retrieve data from a data source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocateDataSourceFn As Func(Of LocateDataSourceArgs,Object)
C#
public Func<LocateDataSourceArgs,object> LocateDataSourceFn {get;}

Property Value

A delegate, that can be called with an argument of type GrapeCity.ActiveReports.Core.Rendering.Data.LocateDataSourceArgs and returns System.Object. null if there is no LocateDataSource event handler.

Remarks

Property is used by JsViewer backend. This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageReport Property

[image]
ActiveReports 19 .NET Edition
PageReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageReport Property

Glossary Item Box

Gets the current report instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageReport As PageReport
C#
public PageReport PageReport {get;}

Property Value

A PageReport instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Parameters Property

Glossary Item Box

Gets the parameters for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Property Value

A GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterCollection value representing parameters for the report.

Example

C# Copy Code
PageReport pageReport = new PageReport(file);
var parameter = pageReport.Document.Parameters["Parameter1"];
parameter.Values.Clear();
parameter.Values.AddRange(new[]
{
    new ParameterValue { Value = "TestValue1" },
    new ParameterValue { Value = "TestValue2" }
});
parameter.CurrentValue = "TestValue1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Printer Property

[image]
ActiveReports 19 .NET Edition
Printer Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Printer Property

Glossary Item Box

Gets a reference to the document's printer settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Printer As Printer
C#
public Printer Printer {get;}

Remarks

Use this property to set the printer options before displaying a print dialog or directly printing the document to the printer with the specified options.

Example

C# Copy Code
pageReport.Document.Printer.PrinterName = "TheNetworkPrinterName";
pageReport.Document.Printer.Landscape = true;
To call the Print method, add a reference to Viewer.Win or Viewer.WPF.
pageReport.Document.Print();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintOptions Property

[image]
ActiveReports 19 .NET Edition
PrintOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintOptions Property

Glossary Item Box

Gets a reference to the document's print options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintOptions
C#
public PrintOptions PrintOptions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


ResolveCredentialsFn Property

[image]
ActiveReports 19 .NET Edition
ResolveCredentialsFn Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ResolveCredentialsFn Property

Glossary Item Box

Gets a delegate that can be used to retrieve credentials.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolveCredentialsFn As ResolveCredentials
C#
public ResolveCredentials ResolveCredentialsFn {get;}

Property Value

A delegate GrapeCity.ActiveReports.Rendering.ResolveCredentials that can be called with a data source argument of type GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DataSource and a report name argument of type System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Events

[image]
ActiveReports 19 .NET Edition
PageDocument Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Events

 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


LocateCredentials Event

[image]
ActiveReports 19 .NET Edition
LocateCredentials Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateCredentials Event

Glossary Item Box

Occurs when the report needs to obtain data source credentials from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSource | Gets the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.

Example

C# Copy Code
PageReport pageReport = new PageReport(reportFilePath);
pageReport.Document.LocateCredentials += (sender, args) =>
{
    if (args.DataSource.Name == "TestDB")
    {
        args.UserName = "qatester";
        args.Password = "qatesting";
    }
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LocateDataSource Event

[image]
ActiveReports 19 .NET Edition
LocateDataSource Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateDataSource Event

Glossary Item Box

Occurs when the report needs to locate a data source from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateDataSource As LocateDataSourceEventHandler
C#
public event LocateDataSourceEventHandler LocateDataSource

Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Parameters | Gets the Parameters collection specified for a given report instance.
Report | Gets the Report that is trying to locate the data set.

Example

C# Copy Code
PageReport pageReport = new PageReport(reportFilePath);
pageReport.Document.LocateDataSource  += (sender, args) =>
{
    if (args.DataSet.Name == "Catalog")
    {
        DataSet ds = new DataSet();
        ds.ReadXml("XML_Schema_and_Data.xml");
        args.Data = ds.Tables[0];
    }
};
reportPreview.LoadDocument(pageReport.Document);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintAborted Event

[image]
ActiveReports 19 .NET Edition
PrintAborted Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintAborted Event

Glossary Item Box

Occurs if the user clicks the Abort button on the status dialog.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintingThreadErrorEvent Event

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEvent Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintingThreadErrorEvent Event

Glossary Item Box

Occurs when an exception is thrown by the printing thread.

Syntax

Visual Basic (Declaration)
Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
C#
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent

Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the printing thread exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintProgress Event

[image]
ActiveReports 19 .NET Edition
PrintProgress Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintProgress Event

Glossary Item Box

Occurs when the document pages are printing.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageRangeParser Class

[image]
ActiveReports 19 .NET Edition
PageRangeParser Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageRangeParser Class

Glossary Item Box

Extension parser.

Object Model

PageRangeParser Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PageRangeParser
C#
public static class PageRangeParser

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.PageRangeParser

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRangeParser Members
GrapeCity.ActiveReports.Document Namespace


PageRangeParser Class Members

[image]
ActiveReports 19 .NET Edition
PageRangeParser Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageRangeParser Class

Glossary Item Box

The following tables list the members exposed by PageRangeParser.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FilterByRange | Parses the ActiveReports style comma delimited "page range" string.
Top

See Also

Reference

PageRangeParser Class
GrapeCity.ActiveReports.Document Namespace


PageRangeParser Class Methods

[image]
ActiveReports 19 .NET Edition
PageRangeParser Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageRangeParser Class

Glossary Item Box

For a list of all members of this type, see PageRangeParser members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FilterByRange | Parses the ActiveReports style comma delimited "page range" string.
Top

See Also

Reference

PageRangeParser Class
GrapeCity.ActiveReports.Document Namespace


FilterByRange Method

[image]
ActiveReports 19 .NET Edition
FilterByRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageRangeParser Class : FilterByRange Method

pages
range
pagesMap

Glossary Item Box

Parses the ActiveReports style comma delimited "page range" string.

Syntax

Visual Basic (Declaration)
Public Shared Function FilterByRange( _
   ByVal pages As IPagesCollection(Of Page), _
   ByVal range As String, _
   Optional ByVal pagesMap As IDictionary(Of Integer,Integer) _
) As IEnumerable(Of Page)
C#
public static IEnumerable<Page> FilterByRange(
   IPagesCollection<Page> pages,
   string range,
   IDictionary<int,int> pagesMap
)

Parameters

pages
range
pagesMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRangeParser Class
PageRangeParser Members


SectionDocument Class

[image]
ActiveReports 19 .NET Edition
SectionDocument Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

Represents a section document section in ActiveReports, encapsulating pages and their collection. This class extends the generic document structure to provide specific functionalities for handling pages within a section-based report document. It includes features such as compatibility mode settings for rendering, font resolution for cross-platform rendering, document content management, printer settings, print options, and event handling for print progress, print abortion, and printing errors.

Object Model

SectionDocument Class

Syntax

Visual Basic (Declaration)
Public Class SectionDocument
   Inherits GrapeCity.ActiveReports.Core.Document.GenericDocument(Of Page,PagesCollection)
   Implements GrapeCity.ActiveReports.Core.Document.IDocument(Of Page)
C#
public class SectionDocument : GrapeCity.ActiveReports.Core.Document.GenericDocument<Page,PagesCollection>, GrapeCity.ActiveReports.Core.Document.IDocument<Page>

Example

C# Copy Code
GrapeCity.ActiveReports.Document.SectionDocument document = new GrapeCity.ActiveReports.Document.SectionDocument("MyReport");
document.Load("Document.rdf");
document.Printer.PrinterName = "TheNetworkPrinterName";
document.Printer.Landscape = true;
try
{
   document.Printer.Print();
}
catch (Exception ex)
{
   Console.WriteLine($"Printing failed: {ex.Message}");
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DocumentBase<PageType>
GrapeCity.ActiveReports.Core.Document.GenericDocument<PageType,PagesCollectionType>
GrapeCity.ActiveReports.Document.SectionDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Members
GrapeCity.ActiveReports.Document Namespace


SectionDocument Class Members

[image]
ActiveReports 19 .NET Edition
SectionDocument Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

The following tables list the members exposed by SectionDocument.

Public Constructors

 | Name | Description
Public Constructor | SectionDocument Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CacheToDisk | Gets or sets whether indicating whether a document should use memory cache exclusively or be able to cache pages on disk.
Public Property | CompatibilityMode | Gets or sets a value indicating whether the new cross-platform based rendering implementation or the legacy GDI/GDI+ rendering should be used by the document.
Public Property | Content | Gets or sets a value representing the document content.
Public Property | FontResolver | Gets or sets a value representing the implementation of the resolution of the font resources required to render a document in the CompatibilityModes.CrossPlatform compatibility mode.
Public Property | ImageConverterService | Gets the image converter service.
Public Property | Name | Overridden. Gets or sets a value indicating the document name.
Public Property | Printer | Gets a value reprsenting the printer properties for report printing.
Public Property | PrintOptions | Gets a value representing the options for report printing.
Public Property | TextLayoutService | Gets the text layout service.
Top

Public Methods

 | Name | Description
Public Method | Load | Overloaded. Loads the document from the specified stream.
Public Method | ResetPrinter | Resets the printer properties.
Top

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs when the printing of the document pages is canceled.
Public Event | PrintingThreadErrorEvent | Occurs when the printing error occurs.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


SectionDocument Constructor

[image]
ActiveReports 19 .NET Edition
SectionDocument Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : SectionDocument Constructor

Glossary Item Box

Overload List

Overload | Description
SectionDocument Constructor() | Initializes a new instance of the SectionDocument class.
SectionDocument Constructor(String) | Initializes a new instance of the SectionDocument class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Constructor()

[image]
ActiveReports 19 .NET Edition
SectionDocument Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > SectionDocument Constructor : SectionDocument Constructor()

Glossary Item Box

Initializes a new instance of the SectionDocument class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SectionDocument()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


SectionDocument Constructor(String)

[image]
ActiveReports 19 .NET Edition
SectionDocument Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > SectionDocument Constructor : SectionDocument Constructor(String)

name
A System.String value representing the name of the document.

Glossary Item Box

Initializes a new instance of the SectionDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public SectionDocument(
   string name
)

Parameters

name
A System.String value representing the name of the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


SectionDocument Class Methods

[image]
ActiveReports 19 .NET Edition
SectionDocument Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Methods

 | Name | Description
Public Method | Load | Overloaded. Loads the document from the specified stream.
Public Method | ResetPrinter | Resets the printer properties.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Load Method

Glossary Item Box

Loads the document from the specified stream.

Overload List

Overload | Description
Load(Stream) | Loads the document from the specified stream.
Load(String) | Loads the document from the specified RDF file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Load(Stream) Method

[image]
ActiveReports 19 .NET Edition
Load(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(Stream) Method

stream
The stream used to load the document.

Glossary Item Box

Loads the document from the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal stream As Stream _
)
C#
public void Load(
   Stream stream
)

Parameters

stream
The stream used to load the document.

Example

C# Copy Code
using (var stream = File.Open("Document.rdf", FileMode.Open, FileAccess.Read, FileShare.None))
{
    var document = new GrapeCity.ActiveReports.Document.SectionDocument();
    document.Load(stream);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Load(String) Method

[image]
ActiveReports 19 .NET Edition
Load(String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(String) Method

fileName
The RDF file used to load the document.

Glossary Item Box

Loads the document from the specified RDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal fileName As String _
)
C#
public void Load(
   string fileName
)

Parameters

fileName
The RDF file used to load the document.

Example

C# Copy Code
var document = new GrapeCity.ActiveReports.Document.SectionDocument();
document.Load("Document.rdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


ResetPrinter Method

[image]
ActiveReports 19 .NET Edition
ResetPrinter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : ResetPrinter Method

Glossary Item Box

Resets the printer properties.

Syntax

Visual Basic (Declaration)
Public Sub ResetPrinter()
C#
public void ResetPrinter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Class Properties

[image]
ActiveReports 19 .NET Edition
SectionDocument Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Properties

 | Name | Description
Public Property | CacheToDisk | Gets or sets whether indicating whether a document should use memory cache exclusively or be able to cache pages on disk.
Public Property | CompatibilityMode | Gets or sets a value indicating whether the new cross-platform based rendering implementation or the legacy GDI/GDI+ rendering should be used by the document.
Public Property | Content | Gets or sets a value representing the document content.
Public Property | FontResolver | Gets or sets a value representing the implementation of the resolution of the font resources required to render a document in the CompatibilityModes.CrossPlatform compatibility mode.
Public Property | ImageConverterService | Gets the image converter service.
Public Property | Name | Overridden. Gets or sets a value indicating the document name.
Public Property | Printer | Gets a value reprsenting the printer properties for report printing.
Public Property | PrintOptions | Gets a value representing the options for report printing.
Public Property | TextLayoutService | Gets the text layout service.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


CacheToDisk Property

[image]
ActiveReports 19 .NET Edition
CacheToDisk Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CacheToDisk Property

Glossary Item Box

Gets or sets whether indicating whether a document should use memory cache exclusively or be able to cache pages on disk.

Syntax

Visual Basic (Declaration)
Public Property CacheToDisk As Boolean
C#
public bool CacheToDisk {get; set;}

Property Value

A System.Boolean value. A true value means that the pages collection will use a temporary file for the canvas item streams, otherwise, false.

Remarks

If you are not experiencing issues, kindly do not modify this property. To prevent performance degradations, only make changes for really large documents in conjunction with GrapeCity.ActiveReports.Core.Document.DocumentBase<PageType>.CacheToDiskLocation.

Example

C# Copy Code
var sectionDocument = new GrapeCity.ActiveReports.Document.SectionDocument();
sectionDocument.CacheToDisk = true;
sectionDocument.CacheToDiskLocation = System.IO.Path.GetTempPath();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


CompatibilityMode Property

[image]
ActiveReports 19 .NET Edition
CompatibilityMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CompatibilityMode Property

Glossary Item Box

Gets or sets a value indicating whether the new cross-platform based rendering implementation or the legacy GDI/GDI+ rendering should be used by the document.

Syntax

Visual Basic (Declaration)
Public Property CompatibilityMode As CompatibilityModes
C#
public CompatibilityModes CompatibilityMode {get; set;}

Property Value

A CompatibilityModes value. Set the CompatibilityModes.CrossPlatform value for cross-platform text/image rendering. Set the CompatibilityModes.GDI for GDI/GDI+ text/image rendering.

Remarks

The default value for the NET Framework is CompatibilityModes.GDI, while for other frameworks it is CompatibilityModes.CrossPlatform. The CompatibilityModes.GDI setting is only compatible with the Windows operating system and is not suitable for use with ASP.NET Core. The CompatibilityModes.CrossPlatform setting is designed for cross-platform rendering.

Example

C# Copy Code
var sectionDocument = new GrapeCity.ActiveReports.Document.SectionDocument();
sectionDocument.CompatibilityMode = GrapeCity.ActiveReports.Document.CompatibilityModes.CrossPlatform;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Content Property

Glossary Item Box

Gets or sets a value representing the document content.

Syntax

Visual Basic (Declaration)
Public Property Content As Byte()
C#
public byte[] Content {get; set;}

Property Value

A System.Byte[] value representing the content of the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


FontResolver Property

[image]
ActiveReports 19 .NET Edition
FontResolver Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : FontResolver Property

Glossary Item Box

Gets or sets a value representing the implementation of the resolution of the font resources required to render a document in the CompatibilityModes.CrossPlatform compatibility mode.

Syntax

Visual Basic (Declaration)
Public Property FontResolver As IFontResolver
C#
public IFontResolver FontResolver {get; set;}

Property Value

An object that implements GrapeCity.ActiveReports.IFontResolver.

Remarks

A value of null indicates that the default resolver is used.

Example

Custom font resolver implementation Set font resolver
C# Copy Code
public sealed class CustomFontResolver : GrapeCity.ActiveReports.IFontResolver
{
    static readonly GrapeCity.Documents.Text.FontCollection _fonts = new GrapeCity.Documents.Text.FontCollection();
    static CustomFontResolver()
    {
        _fonts.RegisterDirectory(System.Environment.GetFolderPath(System.Environment.SpecialFolder.Fonts));
        _fonts.RegisterDirectory(System.IO.Path.Combine(System.Environment.GetFolderPath(System.Environment.SpecialFolder.LocalApplicationData), "Microsoft/Windows/Fonts"));
        // required reference to DS.Documents.Imaging.Windows
        GrapeCity.Documents.Text.Windows.FontLinkHelper.UpdateFontLinks(_fonts, true);
        _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
    }
    public static readonly GrapeCity.ActiveReports.IFontResolver Instance = new CustomFontResolver();
    private CustomFontResolver() { }
    GrapeCity.Documents.Text.FontCollection GrapeCity.ActiveReports.IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
    {
        // suggested to cache values
        var fonts = new GrapeCity.Documents.Text.FontCollection();
        var font = _fonts.FindFamilyName(familyName, isBold, isItalic);
        if (font != null) fonts.Add(font);
        fonts.Add(_fonts.DefaultFont);
        return fonts;
    }
}
C# Copy Code
var sectionDocument = new GrapeCity.ActiveReports.Document.SectionDocument();
sectionDocument.Load("Document.rdf");
sectionDocument.CompatibilityMode = GrapeCity.ActiveReports.Document.CompatibilityModes.CrossPlatform;
sectionDocument.FontResolver = CustomFontResolver.Instance;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


ImageConverterService Property

[image]
ActiveReports 19 .NET Edition
ImageConverterService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : ImageConverterService Property

Glossary Item Box

Gets the image converter service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageConverterService As IImageConverterService
C#
public IImageConverterService ImageConverterService {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Name Property

Glossary Item Box

Gets or sets a value indicating the document name.

Syntax

Visual Basic (Declaration)
Public Overrides Property Name As String
C#
public override string Name {get; set;}

Property Value

A System.String value that representing the value of the document name.

Remarks

We utilize this property to send the document name to the printer. Default value is "ActiveReports Document".

Example

C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
sectionReport.Document.Name = "Name";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Printer Property

[image]
ActiveReports 19 .NET Edition
Printer Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Printer Property

Glossary Item Box

Gets a value reprsenting the printer properties for report printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Printer As Printer
C#
public Printer Printer {get;}

Property Value

A Printer value that represents settings for a printer.

Remarks

Setting the Printer.PrinterName to the string.Empty value does not depend on the settings of the particular printer.

Example

Set a specific printer Set default printer
C# Copy Code
var sectionDocument = new GrapeCity.ActiveReports.Document.SectionDocument();
sectionDocument.Load("Document.rdf");
sectionDocument.Printer.PrinterName = "TheNetworkPrinterName";
sectionDocument.Printer.Landscape = true;
//To call the Print method, add a reference to Viewer.Win or Viewer.WPF
sectionDocument.Print();
C# Copy Code
var sectionReport = new GrapeCity.ActiveReports.SectionReport();
using (var reader = new System.Xml.XmlTextReader("Report.rpx"))
{
    sectionReport.LoadLayout(reader, out System.Collections.ArrayList error);
}
sectionReport.Document.Printer.PrinterName = String.Empty;
viewer.LoadDocument(sectionReport);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


PrintOptions Property

[image]
ActiveReports 19 .NET Edition
PrintOptions Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintOptions Property

Glossary Item Box

Gets a value representing the options for report printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintOptions
C#
public PrintOptions PrintOptions {get;}

Property Value

A PrintOptions value that represents the print options.

Example

C# Copy Code
var sectionDocument = new GrapeCity.ActiveReports.Document.SectionDocument();
sectionDocument.Load("Document.rdf");
sectionDocument.PrintOptions.PageScaling = GrapeCity.ActiveReports.Printing.PageScaling.MultiplePages;
sectionDocument.PrintOptions.PagesPerSheet = 2;
sectionDocument.PrintOptions.AutoRotate = true;
sectionDocument.PrintOptions.PrintPageBorder = true;
//To call the Print method, add a reference to Viewer.Win or Viewer.WPF
sectionDocument.Print();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


TextLayoutService Property

[image]
ActiveReports 19 .NET Edition
TextLayoutService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : TextLayoutService Property

Glossary Item Box

Gets the text layout service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextLayoutService As ITextLayoutService
C#
public ITextLayoutService TextLayoutService {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Class Events

[image]
ActiveReports 19 .NET Edition
SectionDocument Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs when the printing of the document pages is canceled.
Public Event | PrintingThreadErrorEvent | Occurs when the printing error occurs.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


PrintAborted Event

[image]
ActiveReports 19 .NET Edition
PrintAborted Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintAborted Event

Glossary Item Box

Occurs when the printing of the document pages is canceled.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Example

C# Copy Code
private GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
private bool isCancelled = false;
private void button_Click(object sender, RoutedEventArgs e)
{
    sectionReport.Document.PrintAborted  += (sender, e) =>
    {
        isCancelled = true;
    };
    //To call the Print method, add a reference to Viewer.Win or Viewer.WPF
    sectionReport.Document.Print();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


PrintingThreadErrorEvent Event

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEvent Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintingThreadErrorEvent Event

Glossary Item Box

Occurs when the printing error occurs.

Syntax

Visual Basic (Declaration)
Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
C#
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent

Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the printing thread exception.

Example

C# Copy Code
private GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
private void button_Click(object sender, RoutedEventArgs e)
{
    sectionReport.Document.PrintingThreadErrorEvent  += (sender, e) =>
    {
        label1.Text = "Error: " e.Exception.Message;
    };
    sectionReport.Document.Print();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


PrintProgress Event

[image]
ActiveReports 19 .NET Edition
PrintProgress Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintProgress Event

Glossary Item Box

Occurs when the document pages are printing.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Example

C# Copy Code
private GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
private int pageNum = 0;
private void button_Click(object sender, RoutedEventArgs e)
{
    sectionReport.Document.PrintProgress  += (sender, e) =>
    {
        label1.Text = "Printing page: " + pageNum;
        pageNum++;
    };
    sectionReport.Document.Print();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


CompatibilityModes Enumeration

[image]
ActiveReports 19 .NET Edition
CompatibilityModes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : CompatibilityModes Enumeration

Glossary Item Box

Specify if the engine or the document should use legacy GDI/GDI+ rendering or new cross-platform based rendering implementation.

Syntax

Visual Basic (Declaration)
Public Enum CompatibilityModes
   Inherits System.Enum
C#
public enum CompatibilityModes : System.Enum

Members

Member | Description
CrossPlatform | Cross-platform text/images rendering.
GDI | Legacy GDI/GDI+ text/images rendering. Works only under Windows. Doesn't work under ASP.NET Core.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.CompatibilityModes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document Namespace


Page Class

[image]
ActiveReports 19 .NET Edition
Page Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

Object Model

Page Class

Syntax

Visual Basic (Declaration)
Public Class Page
   Inherits GrapeCity.ActiveReports.Core.Document.Page
   Implements ICanvasItemsModifier
C#
public class Page : GrapeCity.ActiveReports.Core.Document.Page, ICanvasItemsModifier

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Page
GrapeCity.ActiveReports.Document.Section.Page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Members
GrapeCity.ActiveReports.Document.Section Namespace


Page Class Members

[image]
ActiveReports 19 .NET Edition
Page Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

The following tables list the members exposed by Page.

Public Constructors

 | Name | Description
Public Constructor | Page Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the backcolor.
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the forecolor.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Padding | Gets or sets the padding.
Public Property | PenStyle | Gets or sets the pen style.
Public Property | PenWidth | Gets or sets the width of the pen.
Public Property | RightToLeft | Gets or sets a value indicating whether [right to left].
Public Property | ScaleX | Gets or sets the minimal character condensed rate.
Public Property | TabStops | Custom tab stops collection
Public Property | TextAlignment | Gets or sets the text alignment.
Public Property | TextAngle | Gets or sets the text angle.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | TextRenderHint | Gets or sets the text render hint.
Public Property | VerticalText | Gets or sets a value indicating whether [vertical text].
Public Property | VerticalTextAlignment | Gets or sets the vertical text alignment.
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | DrawBorder | Overloaded. Draws the border.
Public Method | DrawCheckBoxInputField | Draw the checkBox input field
Public Method | DrawDoubleLine | Draws the double line.
Public Method | DrawEllipse | Draws the ellipse.
Public Method | DrawEllipseDoubleLine | Draws the double line ellipse.
Public Method | DrawImage | Overloaded. Draws the image.
Public Method | DrawLine | Draws the line.
Public Method | DrawRect | Overloaded. Draws the rect.
Public Method | DrawRoundRect | Overloaded. Draws the round rect.
Public Method | DrawRoundRectDoubleLine | Draws the double line round rect.
Public Method | DrawTable | Draws the table.
Public Method | DrawText | Overloaded. Draws the text.
Public Method | DrawTextFallback | Overloaded. Draws the text fallback.
Public Method | DrawTextInputField | Draw the text input field
Public Method | FillRect | Overloaded. Fills the rect.
Public Method | IntersectClip | Overloaded. Intersects the clip.
Public Method | Load | Overloaded. Load
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Measures the text string with the currently selected font.
Public Method | RestoreClip | Restores the clip.
Public Method | SaveClip | Saves the clip.
Public Method | SetTextBoundsRange | Sets text top/bottom bounds.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Page Constructor

[image]
ActiveReports 19 .NET Edition
Page Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Page Constructor

Glossary Item Box

Overload List

Overload | Description
Page Constructor() |
Page Constructor(Page) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Constructor()

[image]
ActiveReports 19 .NET Edition
Page Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Page Constructor : Page Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Page()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Page Constructor(Page)

[image]
ActiveReports 19 .NET Edition
Page Constructor(Page)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Page Constructor : Page Constructor(Page)

corePage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal corePage As Page _
)
C#
public Page(
   Page corePage
)

Parameters

corePage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Page Class Methods

[image]
ActiveReports 19 .NET Edition
Page Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | DrawBorder | Overloaded. Draws the border.
Public Method | DrawCheckBoxInputField | Draw the checkBox input field
Public Method | DrawDoubleLine | Draws the double line.
Public Method | DrawEllipse | Draws the ellipse.
Public Method | DrawEllipseDoubleLine | Draws the double line ellipse.
Public Method | DrawImage | Overloaded. Draws the image.
Public Method | DrawLine | Draws the line.
Public Method | DrawRect | Overloaded. Draws the rect.
Public Method | DrawRoundRect | Overloaded. Draws the round rect.
Public Method | DrawRoundRectDoubleLine | Draws the double line round rect.
Public Method | DrawTable | Draws the table.
Public Method | DrawText | Overloaded. Draws the text.
Public Method | DrawTextFallback | Overloaded. Draws the text fallback.
Public Method | DrawTextInputField | Draw the text input field
Public Method | FillRect | Overloaded. Fills the rect.
Public Method | IntersectClip | Overloaded. Intersects the clip.
Public Method | Load | Overloaded. Load
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Measures the text string with the currently selected font.
Public Method | RestoreClip | Restores the clip.
Public Method | SaveClip | Saves the clip.
Public Method | SetTextBoundsRange | Sets text top/bottom bounds.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawBorder Method

[image]
ActiveReports 19 .NET Edition
DrawBorder Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawBorder Method

Glossary Item Box

Draws the border.

Overload List

Overload | Description
DrawBorder(Border,Single,Single,Single,Single) | Draws the border.
DrawBorder(Border,RectangleF) | Draws the border.
DrawBorder(Border,RectangleF,Single,Single,Single,Single) | Draws the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawBorder(Border,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawBorder(Border,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,Single,Single,Single,Single) Method

border
The border.
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the border.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawBorder(
   Border border,
   float left,
   float top,
   float width,
   float height
)

Parameters

border
The border.
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawBorder(Border,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawBorder(Border,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,RectangleF) Method

border
The border.
bounds
The bounds.

Glossary Item Box

Draws the border.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal bounds As RectangleF _
)
C#
public void DrawBorder(
   Border border,
   RectangleF bounds
)

Parameters

border
The border.
bounds
The bounds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawBorder(Border,RectangleF,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawBorder(Border,RectangleF,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,RectangleF,Single,Single,Single,Single) Method

border
The border.
bounds
The bounds.
bWidthT
bWidthL
bWidthB
bWidthR

Glossary Item Box

Draws the border.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal bounds As RectangleF, _
   ByVal bWidthT As Single, _
   ByVal bWidthL As Single, _
   ByVal bWidthB As Single, _
   ByVal bWidthR As Single _
)
C#
public void DrawBorder(
   Border border,
   RectangleF bounds,
   float bWidthT,
   float bWidthL,
   float bWidthB,
   float bWidthR
)

Parameters

border
The border.
bounds
The bounds.
bWidthT
bWidthL
bWidthB
bWidthR

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawCheckBoxInputField Method

[image]
ActiveReports 19 .NET Edition
DrawCheckBoxInputField Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawCheckBoxInputField Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle

Glossary Item Box

Draw the checkBox input field

Syntax

Visual Basic (Declaration)
Public Sub DrawCheckBoxInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal checked As Boolean, _
   ByVal checkSize As Single, _
   ByVal checkStyle As InputCheckStyle _
)
C#
public void DrawCheckBoxInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   bool checked,
   float checkSize,
   InputCheckStyle checkStyle
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawDoubleLine Method

x1
y1
x2
y2

Glossary Item Box

Draws the double line.

Syntax

Visual Basic (Declaration)
Public Sub DrawDoubleLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public void DrawDoubleLine(
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

x1
y1
x2
y2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawEllipse Method

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the ellipse.

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawEllipse(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawEllipseDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawEllipseDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawEllipseDoubleLine Method

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the double line ellipse.

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipseDoubleLine( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawEllipseDoubleLine(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawImage Method

Glossary Item Box

Draws the image.

Overload List

Overload | Description
DrawImage(Image,Single,Single,Single,Single) | Draws the image.
DrawImage(Image,Single,Single,Single,Single,String,String) | Draws the image.
DrawImage(Image,Boolean,Single,Single,Single,Single) | Draws the image.
DrawImage(Image,RectangleF) | Draws the image.
DrawImage(Image,Boolean,RectangleF) | Draws the image.
DrawImage(Image,Single,Single,Single,Single,String) | Draws the image.
DrawImage(Image,Single,Single,Single,Single,String,String,String) | Draws the image.
DrawImage(Image,Boolean,Single,Single,Single,Single,String) | Draws the image.
DrawImage(Image,RectangleF,String) | Draws the image.
DrawImage(Image,Boolean,RectangleF,String) | Draws the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawImage(Image,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single) Method

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height
)

Parameters

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Single,Single,Single,Single,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String) Method

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
title
The title.
description
The description.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal title As String, _
   ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string title,
   string description
)

Parameters

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
title
The title.
description
The description.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Boolean,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,Single,Single,Single,Single) Method

image
The image.
managedImage
if set to true [managed image].
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal managedImage As Boolean, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawImage(
   Image image,
   bool managedImage,
   float left,
   float top,
   float width,
   float height
)

Parameters

image
The image.
managedImage
if set to true [managed image].
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF) Method

image
The image.
bounds
The bounds.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF _
)
C#
public void DrawImage(
   Image image,
   RectangleF bounds
)

Parameters

image
The image.
bounds
The bounds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Boolean,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,RectangleF) Method

image
The image.
managedImage
if set to true [managed image].
bounds
The bounds.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal managedImage As Boolean, _
   ByVal bounds As RectangleF _
)
C#
public void DrawImage(
   Image image,
   bool managedImage,
   RectangleF bounds
)

Parameters

image
The image.
managedImage
if set to true [managed image].
bounds
The bounds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String) Method

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Single,Single,Single,Single,String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.
title
The title.
description
The description.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String, _
   ByVal title As String, _
   ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string strLink,
   string title,
   string description
)

Parameters

image
The image.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.
title
The title.
description
The description.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Boolean,Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,Single,Single,Single,Single,String) Method

image
The image.
managedImage
if set to true [managed image].
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal managedImage As Boolean, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   bool managedImage,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

image
The image.
managedImage
if set to true [managed image].
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF,String) Method

image
The image.
bounds
The bounds.
strLink
The string link.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   RectangleF bounds,
   string strLink
)

Parameters

image
The image.
bounds
The bounds.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Boolean,RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,RectangleF,String) Method

image
The image.
imageChanged
if set to true [image changed].
text
The text.
strLink
The string link.

Glossary Item Box

Draws the image.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal imageChanged As Boolean, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   bool imageChanged,
   RectangleF text,
   string strLink
)

Parameters

image
The image.
imageChanged
if set to true [image changed].
text
The text.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawLine Method

x1
y1
x2
y2

Glossary Item Box

Draws the line.

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

x1
y1
x2
y2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawRect Method

[image]
ActiveReports 19 .NET Edition
DrawRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRect Method

Glossary Item Box

Draws the rect.

Overload List

Overload | Description
DrawRect(Single,Single,Single,Single) | Draws the rect.
DrawRect(RectangleF) | Draws the rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawRect(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRect(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(Single,Single,Single,Single) Method

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawRect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(RectangleF) Method

rc
The rc.

Glossary Item Box

Draws the rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal rc As RectangleF _
)
C#
public void DrawRect(
   RectangleF rc
)

Parameters

rc
The rc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRoundRect Method

Glossary Item Box

Draws the round rect.

Overload List

Overload | Description
DrawRoundRect(Single,Single,Single,Single,Single,Single) | Draws the round rect.
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) | Renders rounded rect with different corner radiuses.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(Single,Single,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Glossary Item Box

Draws the round rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal edgeWidth As Single, _
   ByVal edgeHeight As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float edgeWidth,
   float edgeHeight
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Renders rounded rect with different corner radiuses.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRectDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRectDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRoundRectDoubleLine Method

left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
Top Left edge.
topRightEdge
Top Right edge.
bottomLeftEdge
Bottom Left edge.
bottomRightEdge
Bottom Right Edge.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Draws the double line round rect.

Syntax

Visual Basic (Declaration)
Public Sub DrawRoundRectDoubleLine( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public void DrawRoundRectDoubleLine(
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
Top Left edge.
topRightEdge
Top Right edge.
bottomLeftEdge
Bottom Left edge.
bottomRightEdge
Bottom Right Edge.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawTable Method

[image]
ActiveReports 19 .NET Edition
DrawTable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawTable Method

bounds
The bounds.

Glossary Item Box

Draws the table.

Syntax

Visual Basic (Declaration)
Public Function DrawTable( _
   ByVal bounds As RectangleF _
) As PageTable
C#
public PageTable DrawTable(
   RectangleF bounds
)

Parameters

bounds
The bounds.

Return Value

PageTable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawText Method

[image]
ActiveReports 19 .NET Edition
DrawText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawText Method

Glossary Item Box

Draws the text.

Overload List

Overload | Description
DrawText(String,Single,Single,Single,Single) | Draws the text.
DrawText(String,RectangleF) | Draws the text.
DrawText(String[],Single,Single,Single,Single) | Draws the text.
DrawText(String[],RectangleF) | Draws the text.
DrawText(String,Single,Single,Single,Single,String) | Draws the text.
DrawText(String,RectangleF,String) | Draws the text.
DrawText(String[],Single,Single,Single,Single,String) | Draws the text.
DrawText(String[],RectangleF,String) | Draws the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawText(String,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single) Method

strText
The string text.
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height
)

Parameters

strText
The string text.
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF) Method

strText
The string text.
text
The text.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string strText,
   RectangleF text
)

Parameters

strText
The string text.
text
The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single) Method

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height
)

Parameters

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF) Method

astrText
The astr text.
text
The text.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text
)

Parameters

astrText
The astr text.
text
The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single,String) Method

strText
The string text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

strText
The string text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF,String) Method

strText
The string text.
text
The text.
strLink
The string link.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   RectangleF text,
   string strLink
)

Parameters

strText
The string text.
text
The text.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single,String) Method

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF,String) Method

astrText
The astr text.
text
The text.
strLink
The string link.

Glossary Item Box

Draws the text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text,
   string strLink
)

Parameters

astrText
The astr text.
text
The text.
strLink
The string link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawTextFallback Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawTextFallback Method

Glossary Item Box

Draws the text fallback.

Overload List

Overload | Description
DrawTextFallback(String[],Single,Single,Single,Single,String[]) | Draws the text fallback.
DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) | Draws the text fallback.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawTextFallback Method : DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
astrTextFallback
The astr text fallback.

Glossary Item Box

Draws the text fallback.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextFallback( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal astrTextFallback() As String _
)
C#
public void DrawTextFallback(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string[] astrTextFallback
)

Parameters

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
astrTextFallback
The astr text fallback.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawTextFallback Method : DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.
astrTextFallback
The astr text fallback.

Glossary Item Box

Draws the text fallback.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextFallback( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String, _
   ByVal astrTextFallback() As String _
)
C#
public void DrawTextFallback(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string strLink,
   string[] astrTextFallback
)

Parameters

astrText
The astr text.
left
The left.
top
The top.
width
The width.
height
The height.
strLink
The string link.
astrTextFallback
The astr text fallback.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawTextInputField Method

[image]
ActiveReports 19 .NET Edition
DrawTextInputField Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawTextInputField Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray

Glossary Item Box

Draw the text input field

Syntax

Visual Basic (Declaration)
Public Sub DrawTextInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal maxLength As Integer, _
   ByVal multiline As Boolean, _
   ByVal password As Boolean, _
   ByVal spellCheck As Boolean, _
   ByVal alignment As InputTextAlign, _
   ByVal textArray() As String _
)
C#
public void DrawTextInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   int maxLength,
   bool multiline,
   bool password,
   bool spellCheck,
   InputTextAlign alignment,
   string[] textArray
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


FillRect Method

[image]
ActiveReports 19 .NET Edition
FillRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : FillRect Method

Glossary Item Box

Fills the rect.

Overload List

Overload | Description
FillRect(Single,Single,Single,Single) | Fills the rect.
FillRect(RectangleF) | Fills the rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


FillRect(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
FillRect(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(Single,Single,Single,Single) Method

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Fills the rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void FillRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


FillRect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
FillRect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(RectangleF) Method

rc
The rc.

Glossary Item Box

Fills the rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal rc As RectangleF _
)
C#
public void FillRect(
   RectangleF rc
)

Parameters

rc
The rc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : IntersectClip Method

Glossary Item Box

Intersects the clip.

Overload List

Overload | Description
IntersectClip(RectangleF) | Intersects the clip.
IntersectClip(Single,Single,Single,Single) | Intersects the clip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


IntersectClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > IntersectClip Method : IntersectClip(RectangleF) Method

clip
The clip.

Glossary Item Box

Intersects the clip.

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal clip As RectangleF _
)
C#
public void IntersectClip(
   RectangleF clip
)

Parameters

clip
The clip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


IntersectClip(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > IntersectClip Method : IntersectClip(Single,Single,Single,Single) Method

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Intersects the clip.

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void IntersectClip(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Load Method

Glossary Item Box

Load

Overload List

Overload | Description
Load(String) | Load
Load(Stream) | Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Load(String) Method

[image]
ActiveReports 19 .NET Edition
Load(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(String) Method

strFileName

Glossary Item Box

Load

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal strFileName As String _
) As Boolean
C#
public bool Load(
   string strFileName
)

Parameters

strFileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Load(Stream) Method

[image]
ActiveReports 19 .NET Edition
Load(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(Stream) Method

stm

Glossary Item Box

Load

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal stm As Stream _
) As Boolean
C#
public bool Load(
   Stream stm
)

Parameters

stm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight Method

[image]
ActiveReports 19 .NET Edition
MeasureParagraphHeight Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureParagraphHeight Method

Glossary Item Box

Measures the height of the specified text if rendered using the current page settings with the specified width.

Overload List

Overload | Description
MeasureParagraphHeight(String,Single) | Measures the height of the specified text if rendered using the current page settings with the specified width.
MeasureParagraphHeight(String,Single,Font) | Measures the height of the specified text if rendered using the current page settings with the specified width.Measures the height of the specified text if rendered using the current page settings with the specified width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


MeasureParagraphHeight(String,Single) Method

[image]
ActiveReports 19 .NET Edition
MeasureParagraphHeight(String,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single) Method

strText
width

Glossary Item Box

Measures the height of the specified text if rendered using the current page settings with the specified width.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As String, _
   ByVal width As Single _
) As SizeF
C#
public SizeF MeasureParagraphHeight(
   string strText,
   float width
)

Parameters

strText
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight(String,Single,Font) Method

[image]
ActiveReports 19 .NET Edition
MeasureParagraphHeight(String,Single,Font) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single,Font) Method

strText
width
textFont

Glossary Item Box

Measures the height of the specified text if rendered using the current page settings with the specified width.Measures the height of the specified text if rendered using the current page settings with the specified width.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As String, _
   ByVal width As Single, _
   ByVal textFont As Font _
) As SizeF
C#
public SizeF MeasureParagraphHeight(
   string strText,
   float width,
   Font textFont
)

Parameters

strText
width
textFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureText Method

[image]
ActiveReports 19 .NET Edition
MeasureText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureText Method

Glossary Item Box

Measures the text string with the currently selected font.

Overload List

Overload | Description
MeasureText(String) | Measures the text string with the currently selected font.
MeasureText(String,Font) | Measures the text string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


MeasureText(String) Method

[image]
ActiveReports 19 .NET Edition
MeasureText(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String) Method

strText
The text string to measure.

Glossary Item Box

Measures the text string with the currently selected font.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureText( _
   ByVal strText As String _
) As SizeF
C#
public SizeF MeasureText(
   string strText
)

Parameters

strText
The text string to measure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureText(String,Font) Method

[image]
ActiveReports 19 .NET Edition
MeasureText(String,Font) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String,Font) Method

strText
The text to measure.
font

Glossary Item Box

Measures the text string.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureText( _
   ByVal strText As String, _
   ByVal font As Font _
) As SizeF
C#
public SizeF MeasureText(
   string strText,
   Font font
)

Parameters

strText
The text to measure.
font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


RestoreClip Method

[image]
ActiveReports 19 .NET Edition
RestoreClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : RestoreClip Method

Glossary Item Box

Restores the clip.

Syntax

Visual Basic (Declaration)
Public Sub RestoreClip()
C#
public void RestoreClip()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


SaveClip Method

[image]
ActiveReports 19 .NET Edition
SaveClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : SaveClip Method

Glossary Item Box

Saves the clip.

Syntax

Visual Basic (Declaration)
Public Sub SaveClip()
C#
public void SaveClip()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


SetTextBoundsRange Method

[image]
ActiveReports 19 .NET Edition
SetTextBoundsRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : SetTextBoundsRange Method

startPos
endPos

Glossary Item Box

Sets text top/bottom bounds.

Syntax

Visual Basic (Declaration)
Public Sub SetTextBoundsRange( _
   ByVal startPos As Single, _
   ByVal endPos As Single _
)
C#
public void SetTextBoundsRange(
   float startPos,
   float endPos
)

Parameters

startPos
endPos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Properties

[image]
ActiveReports 19 .NET Edition
Page Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the backcolor.
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the forecolor.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Padding | Gets or sets the padding.
Public Property | PenStyle | Gets or sets the pen style.
Public Property | PenWidth | Gets or sets the width of the pen.
Public Property | RightToLeft | Gets or sets a value indicating whether [right to left].
Public Property | ScaleX | Gets or sets the minimal character condensed rate.
Public Property | TabStops | Custom tab stops collection
Public Property | TextAlignment | Gets or sets the text alignment.
Public Property | TextAngle | Gets or sets the text angle.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | TextRenderHint | Gets or sets the text render hint.
Public Property | VerticalText | Gets or sets a value indicating whether [vertical text].
Public Property | VerticalTextAlignment | Gets or sets the vertical text alignment.
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : BackColor Property

Glossary Item Box

Gets or sets the backcolor.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

The color of the back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the character spacing.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Property Value

The character spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Font Property

Glossary Item Box

Gets or sets the font.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ForeColor Property

Glossary Item Box

Gets or sets the forecolor.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

The color of the fore.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : LineSpacing Property

Glossary Item Box

Gets or sets the line spacing.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Property Value

The line spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Padding Property

Glossary Item Box

Gets or sets the padding.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Property Value

The padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PenStyle Property

[image]
ActiveReports 19 .NET Edition
PenStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenStyle Property

Glossary Item Box

Gets or sets the pen style.

Syntax

Visual Basic (Declaration)
Public Property PenStyle As PenStyles
C#
public PenStyles PenStyle {get; set;}

Property Value

The pen style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PenWidth Property

[image]
ActiveReports 19 .NET Edition
PenWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenWidth Property

Glossary Item Box

Gets or sets the width of the pen.

Syntax

Visual Basic (Declaration)
Public Property PenWidth As Short
C#
public short PenWidth {get; set;}

Property Value

The width of the pen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether [right to left].

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Property Value

true if [right to left]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ScaleX Property

[image]
ActiveReports 19 .NET Edition
ScaleX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ScaleX Property

Glossary Item Box

Gets or sets the minimal character condensed rate.

Syntax

Visual Basic (Declaration)
Public Property ScaleX As Single
C#
public float ScaleX {get; set;}

Property Value

The minimal character condensed rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TabStops Property

Glossary Item Box

Custom tab stops collection

Syntax

Visual Basic (Declaration)
Public Property TabStops As TabStopsItem.TabStop()
C#
public TabStopsItem.TabStop[] TabStops {get; set;}

Property Value

The tab stops.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextAlignment Property

[image]
ActiveReports 19 .NET Edition
TextAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAlignment Property

Glossary Item Box

Gets or sets the text alignment.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Property Value

The text alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextAngle Property

[image]
ActiveReports 19 .NET Edition
TextAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAngle Property

Glossary Item Box

Gets or sets the text angle.

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Integer
C#
public int TextAngle {get; set;}

Property Value

The text angle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextJustify Property

Glossary Item Box

Gets or sets the text justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Property Value

The text justify.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextRenderHint Property

[image]
ActiveReports 19 .NET Edition
TextRenderHint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextRenderHint Property

Glossary Item Box

Gets or sets the text render hint.

Syntax

Visual Basic (Declaration)
Public Property TextRenderHint As TextRenderHint
C#
public TextRenderHint TextRenderHint {get; set;}

Property Value

The text render hint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


VerticalText Property

[image]
ActiveReports 19 .NET Edition
VerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalText Property

Glossary Item Box

Gets or sets a value indicating whether [vertical text].

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Property Value

true if [vertical text]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


VerticalTextAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalTextAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalTextAlignment Property

Glossary Item Box

Gets or sets the vertical text alignment.

Syntax

Visual Basic (Declaration)
Public Property VerticalTextAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalTextAlignment {get; set;}

Property Value

The vertical text alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : WrapMode Property

Glossary Item Box

Gets or sets the wrap mode for rendering text.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PagesCollection Class

[image]
ActiveReports 19 .NET Edition
PagesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

Contains a collection of Page objects.

Object Model

PagesCollection Class

Syntax

Visual Basic (Declaration)
Public Class PagesCollection
   Inherits GrapeCity.ActiveReports.Core.Document.PagesCollection(Of Page)
   Implements GrapeCity.ActiveReports.Core.Document.IPagesCollection(Of Page)
C#
public class PagesCollection : GrapeCity.ActiveReports.Core.Document.PagesCollection<Page>, GrapeCity.ActiveReports.Core.Document.IPagesCollection<Page>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.PagesCollection<T>
GrapeCity.ActiveReports.Document.Section.PagesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Class Members

[image]
ActiveReports 19 .NET Edition
PagesCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

The following tables list the members exposed by PagesCollection.

Public Constructors

 | Name | Description
Public Constructor | PagesCollection Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | GetRange | Returns the count of Page objects in a Pagescollection starting at the specified index.
Top

See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Constructor

[image]
ActiveReports 19 .NET Edition
PagesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : PagesCollection Constructor

Glossary Item Box

Overload List

Overload | Description
PagesCollection Constructor() | Initializes a new instance of the PagesCollection class.
PagesCollection Constructor(SectionDocument) | Initializes a new instance of the PagesCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


PagesCollection Constructor()

[image]
ActiveReports 19 .NET Edition
PagesCollection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor()

Glossary Item Box

Initializes a new instance of the PagesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PagesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Constructor(SectionDocument)

[image]
ActiveReports 19 .NET Edition
PagesCollection Constructor(SectionDocument)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor(SectionDocument)

document
The document.

Glossary Item Box

Initializes a new instance of the PagesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal document As SectionDocument _
)
C#
public PagesCollection(
   SectionDocument document
)

Parameters

document
The document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
PagesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

For a list of all members of this type, see PagesCollection members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | GetRange | Returns the count of Page objects in a Pagescollection starting at the specified index.
Top

See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


GetRange Method

[image]
ActiveReports 19 .NET Edition
GetRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : GetRange Method

index
count

Glossary Item Box

Returns the count of Page objects in a Pagescollection starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Function GetRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
) As PagesCollection
C#
public PagesCollection GetRange(
   int index,
   int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


FilteredDocumentFactory Class

[image]
ActiveReports 19 .NET Edition
FilteredDocumentFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : FilteredDocumentFactory Class

Glossary Item Box

Factory for ISectionDocumentExportSurrogate and IPageExportSurrogate

Object Model

FilteredDocumentFactory Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FilteredDocumentFactory
C#
public static class FilteredDocumentFactory

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Document.Filters.FilteredDocumentFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Members
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


FilteredDocumentFactory Class Members

[image]
ActiveReports 19 .NET Edition
FilteredDocumentFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : FilteredDocumentFactory Class

Glossary Item Box

The following tables list the members exposed by FilteredDocumentFactory.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertToFilteredDocument | Converts to filtered document.
static (Shared in Visual Basic) | ConvertToFilteredPage | Converts to filtered page.
static (Shared in Visual Basic) | FilterByPageRange | Overloaded. Filters the by page range.
Top

See Also

Reference

FilteredDocumentFactory Class
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


FilteredDocumentFactory Class Methods

[image]
ActiveReports 19 .NET Edition
FilteredDocumentFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : FilteredDocumentFactory Class

Glossary Item Box

For a list of all members of this type, see FilteredDocumentFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertToFilteredDocument | Converts to filtered document.
static (Shared in Visual Basic) | ConvertToFilteredPage | Converts to filtered page.
static (Shared in Visual Basic) | FilterByPageRange | Overloaded. Filters the by page range.
Top

See Also

Reference

FilteredDocumentFactory Class
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


ConvertToFilteredDocument Method

[image]
ActiveReports 19 .NET Edition
ConvertToFilteredDocument Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > FilteredDocumentFactory Class : ConvertToFilteredDocument Method

document
The document.

Glossary Item Box

Converts to filtered document.

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToFilteredDocument( _
   ByVal document As SectionDocument _
) As IFilteredDocument
C#
public static IFilteredDocument ConvertToFilteredDocument(
   SectionDocument document
)

Parameters

document
The document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Class
FilteredDocumentFactory Members


ConvertToFilteredPage Method

[image]
ActiveReports 19 .NET Edition
ConvertToFilteredPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > FilteredDocumentFactory Class : ConvertToFilteredPage Method

page
The page.

Glossary Item Box

Converts to filtered page.

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToFilteredPage( _
   ByVal page As Page _
) As IFilteredPage
C#
public static IFilteredPage ConvertToFilteredPage(
   Page page
)

Parameters

page
The page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Class
FilteredDocumentFactory Members


FilterByPageRange Method

[image]
ActiveReports 19 .NET Edition
FilterByPageRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > FilteredDocumentFactory Class : FilterByPageRange Method

Glossary Item Box

Filters the by page range.

Overload List

Overload | Description
FilterByPageRange(IFilteredDocument,String) | Filters the by page range.
FilterByPageRange(IFilteredDocument,String,IDictionary<Int32,Int32>) | Get filtered document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Class
FilteredDocumentFactory Members


FilterByPageRange(IFilteredDocument,String) Method

[image]
ActiveReports 19 .NET Edition
FilterByPageRange(IFilteredDocument,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > FilteredDocumentFactory Class > FilterByPageRange Method : FilterByPageRange(IFilteredDocument,String) Method

document
The document.
range
The range.

Glossary Item Box

Filters the by page range.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FilterByPageRange( _
   ByVal document As IFilteredDocument, _
   ByVal range As String _
) As IFilteredDocument
C#
public static IFilteredDocument FilterByPageRange(
   IFilteredDocument document,
   string range
)

Parameters

document
The document.
range
The range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Class
FilteredDocumentFactory Members
Overload List


FilterByPageRange(IFilteredDocument,String,IDictionary<Int32,Int32>) Method

[image]
ActiveReports 19 .NET Edition
FilterByPageRange(IFilteredDocument,String,IDictionary<Int32,Int32>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > FilteredDocumentFactory Class > FilterByPageRange Method : FilterByPageRange(IFilteredDocument,String,IDictionary<Int32,Int32>) Method

document
range
pagesMap
The map to fill with the pages map which point the source page number to the page index in the filtered collection.

Glossary Item Box

Get filtered document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FilterByPageRange( _
   ByVal document As IFilteredDocument, _
   ByVal range As String, _
   ByVal pagesMap As IDictionary(Of Integer,Integer) _
) As IFilteredDocument
C#
public static IFilteredDocument FilterByPageRange(
   IFilteredDocument document,
   string range,
   IDictionary<int,int> pagesMap
)

Parameters

document
range
pagesMap
The map to fill with the pages map which point the source page number to the page index in the filtered collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredDocumentFactory Class
FilteredDocumentFactory Members
Overload List


IFilteredDocument Interface

[image]
ActiveReports 19 .NET Edition
IFilteredDocument Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredDocument Interface

Glossary Item Box

Provides SectionDocument filtering

Syntax

Visual Basic (Declaration)
Public Interface IFilteredDocument
C#
public interface IFilteredDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredDocument Members
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


IFilteredDocument Interface Members

[image]
ActiveReports 19 .NET Edition
IFilteredDocument Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredDocument Interface

Glossary Item Box

The following tables list the members exposed by IFilteredDocument.

Public Properties

 | Name | Description
Property | Pages | Get pages.
Property | PagesCount | Get pages count.
Top

See Also

Reference

IFilteredDocument Interface
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


IFilteredDocument Interface Properties

[image]
ActiveReports 19 .NET Edition
IFilteredDocument Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredDocument Interface

Glossary Item Box

For a list of all members of this type, see IFilteredDocument members.

Public Properties

 | Name | Description
Property | Pages | Get pages.
Property | PagesCount | Get pages count.
Top

See Also

Reference

IFilteredDocument Interface
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredDocument Interface : Pages Property

Glossary Item Box

Get pages.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pages As IEnumerable(Of IFilteredPage)
C#
IEnumerable<IFilteredPage> Pages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredDocument Interface
IFilteredDocument Members


PagesCount Property

[image]
ActiveReports 19 .NET Edition
PagesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredDocument Interface : PagesCount Property

Glossary Item Box

Get pages count.

Syntax

Visual Basic (Declaration)
ReadOnly Property PagesCount As Integer
C#
int PagesCount {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredDocument Interface
IFilteredDocument Members


IFilteredPage Interface

[image]
ActiveReports 19 .NET Edition
IFilteredPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredPage Interface

Glossary Item Box

Provides Page surrogate for exports

Syntax

Visual Basic (Declaration)
Public Interface IFilteredPage
C#
public interface IFilteredPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Members
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


IFilteredPage Interface Members

[image]
ActiveReports 19 .NET Edition
IFilteredPage Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredPage Interface

Glossary Item Box

The following tables list the members exposed by IFilteredPage.

Public Properties

 | Name | Description
Property | Bookmarks | Bookmarks
Property | CanvasItems | CanvasItems
Property | EvaluationBounds | EvaluationBounds
Property | EvaluationMessage | EvaluationMessage
Property | Fonts | Fonts
Property | Height | Height
Property | IsEval | IsEval
Property | Margins | Margins
Property | Orientation | Orientation
Property | PageIdentifier | The owner page.
Property | Size | Returns the size of the page in *inches*.
Property | Units | Units
Property | Width | Width
Top

See Also

Reference

IFilteredPage Interface
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


IFilteredPage Interface Properties

[image]
ActiveReports 19 .NET Edition
IFilteredPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace : IFilteredPage Interface

Glossary Item Box

For a list of all members of this type, see IFilteredPage members.

Public Properties

 | Name | Description
Property | Bookmarks | Bookmarks
Property | CanvasItems | CanvasItems
Property | EvaluationBounds | EvaluationBounds
Property | EvaluationMessage | EvaluationMessage
Property | Fonts | Fonts
Property | Height | Height
Property | IsEval | IsEval
Property | Margins | Margins
Property | Orientation | Orientation
Property | PageIdentifier | The owner page.
Property | Size | Returns the size of the page in *inches*.
Property | Units | Units
Property | Width | Width
Top

See Also

Reference

IFilteredPage Interface
GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace


Bookmarks Property

[image]
ActiveReports 19 .NET Edition
Bookmarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Bookmarks Property

Glossary Item Box

Bookmarks

Syntax

Visual Basic (Declaration)
ReadOnly Property Bookmarks As IList
C#
IList Bookmarks {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


CanvasItems Property

[image]
ActiveReports 19 .NET Edition
CanvasItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : CanvasItems Property

Glossary Item Box

CanvasItems

Syntax

Visual Basic (Declaration)
ReadOnly Property CanvasItems As IList(Of CanvasItem)
C#
IList<CanvasItem> CanvasItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


EvaluationBounds Property

[image]
ActiveReports 19 .NET Edition
EvaluationBounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : EvaluationBounds Property

Glossary Item Box

EvaluationBounds

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationBounds As RectangleF
C#
RectangleF EvaluationBounds {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


EvaluationMessage Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : EvaluationMessage Property

Glossary Item Box

EvaluationMessage

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationMessage As String()
C#
string[] EvaluationMessage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Fonts Property

Glossary Item Box

Fonts

Syntax

Visual Basic (Declaration)
ReadOnly Property Fonts As FontsCollection
C#
FontsCollection Fonts {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Height Property

Glossary Item Box

Height

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Single
C#
float Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


IsEval Property

[image]
ActiveReports 19 .NET Edition
IsEval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : IsEval Property

Glossary Item Box

IsEval

Syntax

Visual Basic (Declaration)
ReadOnly Property IsEval As Boolean
C#
bool IsEval {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Margins Property

[image]
ActiveReports 19 .NET Edition
Margins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Margins Property

Glossary Item Box

Margins

Syntax

Visual Basic (Declaration)
ReadOnly Property Margins As Margins
C#
Margins Margins {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Orientation Property

[image]
ActiveReports 19 .NET Edition
Orientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Orientation Property

Glossary Item Box

Orientation

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As PageOrientation
C#
PageOrientation Orientation {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


PageIdentifier Property

[image]
ActiveReports 19 .NET Edition
PageIdentifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : PageIdentifier Property

Glossary Item Box

The owner page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageIdentifier As Guid
C#
Guid PageIdentifier {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Size Property

Glossary Item Box

Returns the size of the page in *inches*.

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As SizeF
C#
SizeF Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Units Property

[image]
ActiveReports 19 .NET Edition
Units Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Units Property

Glossary Item Box

Units

Syntax

Visual Basic (Declaration)
ReadOnly Property Units As Units
C#
Units Units {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Document.Section.Document.Filters Namespace > IFilteredPage Interface : Width Property

Glossary Item Box

Width

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Single
C#
float Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFilteredPage Interface
IFilteredPage Members


FontNameResolver Class

[image]
ActiveReports 19 .NET Edition
FontNameResolver Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : FontNameResolver Class

Glossary Item Box

This is a font name resolver for resolving font names using IFontResolver.

Object Model

FontNameResolver Class

Syntax

Visual Basic (Declaration)
Public Class FontNameResolver
   Implements GrapeCity.ActiveReports.Drawing.IFontNameResolver
C#
public class FontNameResolver : GrapeCity.ActiveReports.Drawing.IFontNameResolver

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.FontNameResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontNameResolver Members
GrapeCity.ActiveReports.Export Namespace


FontNameResolver Class Members

[image]
ActiveReports 19 .NET Edition
FontNameResolver Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : FontNameResolver Class

Glossary Item Box

The following tables list the members exposed by FontNameResolver.

Public Constructors

 | Name | Description
Public Constructor | FontNameResolver Constructor | Initializes the font name resolver to resolve font names using IFontResolver
Top

Public Methods

 | Name | Description
Public Method | GetFontFamily | Resolves font name by original font name
Top

See Also

Reference

FontNameResolver Class
GrapeCity.ActiveReports.Export Namespace


FontNameResolver Constructor

[image]
ActiveReports 19 .NET Edition
FontNameResolver Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > FontNameResolver Class : FontNameResolver Constructor

fontResolver
compatibilityMode

Glossary Item Box

Initializes the font name resolver to resolve font names using IFontResolver

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fontResolver As IFontResolver, _
   ByVal compatibilityMode As CompatibilityModes _
)
C#
public FontNameResolver(
   IFontResolver fontResolver,
   CompatibilityModes compatibilityMode
)

Parameters

fontResolver
compatibilityMode

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontNameResolver Class
FontNameResolver Members


FontNameResolver Class Methods

[image]
ActiveReports 19 .NET Edition
FontNameResolver Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : FontNameResolver Class

Glossary Item Box

For a list of all members of this type, see FontNameResolver members.

Public Methods

 | Name | Description
Public Method | GetFontFamily | Resolves font name by original font name
Top

See Also

Reference

FontNameResolver Class
GrapeCity.ActiveReports.Export Namespace


GetFontFamily Method

[image]
ActiveReports 19 .NET Edition
GetFontFamily Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > FontNameResolver Class : GetFontFamily Method

fontFamily

Glossary Item Box

Resolves font name by original font name

Syntax

Visual Basic (Declaration)
Public Function GetFontFamily( _
   ByVal fontFamily As String _
) As String
C#
public string GetFontFamily(
   string fontFamily
)

Parameters

fontFamily

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontNameResolver Class
FontNameResolver Members


IDocumentExport Interface

[image]
ActiveReports 19 .NET Edition
IDocumentExport Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

Provides a common interface for all the export filters.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentExport
C#
public interface IDocumentExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Members

[image]
ActiveReports 19 .NET Edition
IDocumentExport Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

The following tables list the members exposed by IDocumentExport.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified document.
Top

See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Methods

[image]
ActiveReports 19 .NET Edition
IDocumentExport Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

For a list of all members of this type, see IDocumentExport members.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified document.
Top

See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


Export Method

[image]
ActiveReports 19 .NET Edition
Export Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface : Export Method

Glossary Item Box

Exports the specified document.

Overload List

Overload | Description
Export(SectionDocument,String,String) | Exports the specified document.
Export(SectionDocument,String) | Exports the specified document.
Export(SectionDocument,Stream) | Exports the specified document.
Export(SectionDocument,Stream,String) | Exports the specified document.
Export(SectionDocument,IOutputHtml,String) | Exports the specified document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members


Export(SectionDocument,String,String) Method

[image]
ActiveReports 19 .NET Edition
Export(SectionDocument,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String,String) Method

document
The document.
filePath
The file path.
pageRange
The page range.

Glossary Item Box

Exports the specified document.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The document.
filePath
The file path.
pageRange
The page range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 19 .NET Edition
Export(SectionDocument,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String) Method

document
The document.
filePath
The file path.

Glossary Item Box

Exports the specified document.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The document.
filePath
The file path.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 19 .NET Edition
Export(SectionDocument,Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream) Method

document
The document.
outputStream
The output stream.

Glossary Item Box

Exports the specified document.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The document.
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 19 .NET Edition
Export(SectionDocument,Stream,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream,String) Method

document
The document.
outputStream
The output stream.
pageRange
The page range.

Glossary Item Box

Exports the specified document.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The document.
outputStream
The output stream.
pageRange
The page range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,IOutputHtml,String) Method

[image]
ActiveReports 19 .NET Edition
Export(SectionDocument,IOutputHtml,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,IOutputHtml,String) Method

document
The document.
outputHandler
The output handler.
pageRange
The page range.

Glossary Item Box

Exports the specified document.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   IOutputHtml outputHandler,
   string pageRange
)

Parameters

document
The document.
outputHandler
The output handler.
pageRange
The page range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


IDocumentExportEx Interface

[image]
ActiveReports 19 .NET Edition
IDocumentExportEx Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface IDocumentExportEx
C#
public interface IDocumentExportEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExportEx Interface Members

[image]
ActiveReports 19 .NET Edition
IDocumentExportEx Interface Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

Glossary Item Box

The following tables list the members exposed by IDocumentExportEx.

See Also

Reference

IDocumentExportEx Interface
GrapeCity.ActiveReports.Export Namespace


HtmlOutputInfoArgs Class

[image]
ActiveReports 19 .NET Edition
HtmlOutputInfoArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

Used as an argument to the IOutputHtml interface's OutputHtmlData function.

Object Model

HtmlOutputInfoArgs Class

Syntax

Visual Basic (Declaration)
Public Class HtmlOutputInfoArgs
C#
public class HtmlOutputInfoArgs

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.HtmlOutputInfoArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Members
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Class Members

[image]
ActiveReports 19 .NET Edition
HtmlOutputInfoArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

The following tables list the members exposed by HtmlOutputInfoArgs.

Public Constructors

 | Name | Description
Public Constructor | HtmlOutputInfoArgs Constructor | Initializes an instance of the HtmlOutputInfoArg class.
Top

Public Properties

 | Name | Description
Public Property | OutputKind | Returns the kind of output data contained in the OutputStream property.
Public Property | OutputStream | The actual data that is being outputted.
Top

See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Constructor

[image]
ActiveReports 19 .NET Edition
HtmlOutputInfoArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : HtmlOutputInfoArgs Constructor

outputKind
outputStream

Glossary Item Box

Initializes an instance of the HtmlOutputInfoArg class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal outputKind As HtmlOutputKind, _
   ByVal outputStream As Stream _
)
C#
public HtmlOutputInfoArgs(
   HtmlOutputKind outputKind,
   Stream outputStream
)

Parameters

outputKind
outputStream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputInfoArgs Class Properties

[image]
ActiveReports 19 .NET Edition
HtmlOutputInfoArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

For a list of all members of this type, see HtmlOutputInfoArgs members.

Public Properties

 | Name | Description
Public Property | OutputKind | Returns the kind of output data contained in the OutputStream property.
Public Property | OutputStream | The actual data that is being outputted.
Top

See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


OutputKind Property

[image]
ActiveReports 19 .NET Edition
OutputKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputKind Property

Glossary Item Box

Returns the kind of output data contained in the OutputStream property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputKind As HtmlOutputKind
C#
public HtmlOutputKind OutputKind {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


OutputStream Property

[image]
ActiveReports 19 .NET Edition
OutputStream Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputStream Property

Glossary Item Box

The actual data that is being outputted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputStream As Stream
C#
public Stream OutputStream {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputKind Enumeration

[image]
ActiveReports 19 .NET Edition
HtmlOutputKind Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputKind Enumeration

Glossary Item Box

The different possible kinds of output from HTML.

Syntax

Visual Basic (Declaration)
Public Enum HtmlOutputKind
   Inherits System.Enum
C#
public enum HtmlOutputKind : System.Enum

Members

Member | Description
BookmarksHtml | The output is an HTML page containing a list of bookmarks for the main HTML page(s).
FramesetHtml | The output is an html page containing a Frameset declaration for a TOC page or navigation page if TOC not availalbe, and the "target" document pages on the right.
HtmlPage | The output is the HTML page.
ImageJpg | The output is a JPG image.
ImagePng | The output is a PNG image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.HtmlOutputKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface

[image]
ActiveReports 19 .NET Edition
IOutputHtml Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

Summary description for IHandleHtmlOutput.

Syntax

Visual Basic (Declaration)
Public Interface IOutputHtml
C#
public interface IOutputHtml

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Members
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Members

[image]
ActiveReports 19 .NET Edition
IOutputHtml Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

The following tables list the members exposed by IOutputHtml.

Public Methods

 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementor to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | OutputHtmlData will be called by the HtmlExport class to output data.
Top

See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Methods

[image]
ActiveReports 19 .NET Edition
IOutputHtml Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

For a list of all members of this type, see IOutputHtml members.

Public Methods

 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementor to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | OutputHtmlData will be called by the HtmlExport class to output data.
Top

See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


Finish Method

[image]
ActiveReports 19 .NET Edition
Finish Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : Finish Method

Glossary Item Box

Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementor to flush any remaining output, or to write out a frame set page for the previously exported document.

Syntax

Visual Basic (Declaration)
Sub Finish()
C#
void Finish()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Interface
IOutputHtml Members


OutputHtmlData Method

[image]
ActiveReports 19 .NET Edition
OutputHtmlData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : OutputHtmlData Method

info
Information about the output

Glossary Item Box

OutputHtmlData will be called by the HtmlExport class to output data.

Syntax

Visual Basic (Declaration)
Function OutputHtmlData( _
   ByVal info As HtmlOutputInfoArgs _
) As String
C#
string OutputHtmlData(
   HtmlOutputInfoArgs info
)

Parameters

info
Information about the output

Return Value

The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implentator requires. The return value should be a "file name" that the calling HtmlExport class can use to place links in the main HTML page to the data. For example, as an HTML page is being created and an image is encountered that will be outputed as an HTML img the HtmlExport object will call this method to provide the data to the implentor, and the return value from OutputHtmlData (i.e. the filename) will be used as the src attribute's value. When the HTML page is ready, OutputHtmlData will be called again to pass the actual HTML page's data, in this case the filename returned by the OutputHtmlData implementation will not be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Interface
IOutputHtml Members


DataRow Class

[image]
ActiveReports 19 .NET Edition
DataRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

Data row.

Object Model

DataRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataRow
C#
public sealed class DataRow

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Class Members

[image]
ActiveReports 19 .NET Edition
DataRow Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

The following tables list the members exposed by DataRow.

Public Constructors

 | Name | Description
Public Constructor | DataRow Constructor | Creates new instance of DataRow.
Top

Public Fields

 | Name | Description
Public Field | Values | The row data.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Constructor

[image]
ActiveReports 19 .NET Edition
DataRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : DataRow Constructor

values
The row data.

Glossary Item Box

Creates new instance of DataRow.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values() As Object _
)
C#
public DataRow(
   object[] values
)

Parameters

values
The row data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataRow Class Fields

[image]
ActiveReports 19 .NET Edition
DataRow Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

For a list of all members of this type, see DataRow members.

Public Fields

 | Name | Description
Public Field | Values | The row data.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Values Field

[image]
ActiveReports 19 .NET Edition
Values Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : Values Field

Glossary Item Box

The row data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Values As Object()
C#
public readonly object[] Values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataTable Class

[image]
ActiveReports 19 .NET Edition
DataTable Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

Represents result set of query execution.

Object Model

DataTable Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTable
C#
public sealed class DataTable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Class Members

[image]
ActiveReports 19 .NET Edition
DataTable Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

The following tables list the members exposed by DataTable.

Public Constructors

 | Name | Description
Public Constructor | DataTable Constructor | Creates new instance of DataTable.
Top

Public Properties

 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top

See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Constructor

[image]
ActiveReports 19 .NET Edition
DataTable Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : DataTable Constructor

columns
The table columns.
rows
The table rows.

Glossary Item Box

Creates new instance of DataTable.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columns As IEnumerable(Of DataColumn), _
   ByVal rows As IEnumerable(Of DataRow) _
)
C#
public DataTable(
   IEnumerable<DataColumn> columns,
   IEnumerable<DataRow> rows
)

Parameters

columns
The table columns.
rows
The table rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


DataTable Class Properties

[image]
ActiveReports 19 .NET Edition
DataTable Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

For a list of all members of this type, see DataTable members.

Public Properties

 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top

See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Columns Property

Glossary Item Box

Gets table columns.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As IItemCollection(Of DataColumn)
C#
public IItemCollection<DataColumn> Columns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Rows Property

Glossary Item Box

Gets table rows.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As IItemCollection(Of DataRow)
C#
public IItemCollection<DataRow> Rows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


DataColumn Structure

[image]
ActiveReports 19 .NET Edition
DataColumn Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

Data column.

Object Model

DataColumn Structure

Syntax

Visual Basic (Declaration)
Public Structure DataColumn
   Inherits System.ValueType
C#
public struct DataColumn : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.DataColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Structure Members

[image]
ActiveReports 19 .NET Edition
DataColumn Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

The following tables list the members exposed by DataColumn.

Public Constructors

 | Name | Description
Public Constructor | DataColumn Constructor | Creates new instance of DataColumn.
Top

Public Fields

 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top

See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Constructor

[image]
ActiveReports 19 .NET Edition
DataColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataColumn Constructor

name
The column name.
dataType
The column type.

Glossary Item Box

Creates new instance of DataColumn.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dataType As String _
)
C#
public DataColumn(
   string name,
   string dataType
)

Parameters

name
The column name.
dataType
The column type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


DataColumn Structure Fields

[image]
ActiveReports 19 .NET Edition
DataColumn Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

For a list of all members of this type, see DataColumn members.

Public Fields

 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top

See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataType Field

[image]
ActiveReports 19 .NET Edition
DataType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataType Field

Glossary Item Box

Specifies data type of the column.

Syntax

Visual Basic (Declaration)
Public ReadOnly DataType As String
C#
public readonly string DataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : Name Field

Glossary Item Box

Specifies column name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


IDataParameter Interface

[image]
ActiveReports 19 .NET Edition
IDataParameter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

Represents a parameter used with a System.Data.IDbCommand.

Syntax

Visual Basic (Declaration)
Public Interface IDataParameter
C#
public interface IDataParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Members

[image]
ActiveReports 19 .NET Edition
IDataParameter Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

The following tables list the members exposed by IDataParameter.

Public Properties

 | Name | Description
Property | ParameterName | Gets or sets the name of the parameter.
Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Properties

[image]
ActiveReports 19 .NET Edition
IDataParameter Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

For a list of all members of this type, see IDataParameter members.

Public Properties

 | Name | Description
Property | ParameterName | Gets or sets the name of the parameter.
Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ParameterName Property

[image]
ActiveReports 19 .NET Edition
ParameterName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : ParameterName Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Property ParameterName As String
C#
string ParameterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Interface
IDataParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : Value Property

Glossary Item Box

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Property Value As Object
C#
object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Interface
IDataParameter Members


IDataParameterCollection Interface

[image]
ActiveReports 19 .NET Edition
IDataParameterCollection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

Represents a collection of IDataParameter objects.

Syntax

Visual Basic (Declaration)
Public Interface IDataParameterCollection
C#
public interface IDataParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameterCollection Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Members

[image]
ActiveReports 19 .NET Edition
IDataParameterCollection Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

The following tables list the members exposed by IDataParameterCollection.

Public Methods

 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top

See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Methods

[image]
ActiveReports 19 .NET Edition
IDataParameterCollection Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

For a list of all members of this type, see IDataParameterCollection members.

Public Methods

 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top

See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameterCollection Interface : Add Method

parameter

Glossary Item Box

Adds the specified IDataParameter object to the collection.

Syntax

Visual Basic (Declaration)
Function Add( _
   ByVal parameter As IDataParameter _
) As Integer
C#
int Add(
   IDataParameter parameter
)

Parameters

parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameterCollection Interface
IDataParameterCollection Members


IDbSchemaProvider Interface

[image]
ActiveReports 19 .NET Edition
IDbSchemaProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

Specifies the schema provider.

Syntax

Visual Basic (Declaration)
Public Interface IDbSchemaProvider
C#
public interface IDbSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbSchemaProvider Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IDbSchemaProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

The following tables list the members exposed by IDbSchemaProvider.

Public Methods

 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top

See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbSchemaProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

For a list of all members of this type, see IDbSchemaProvider members.

Public Methods

 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top

See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbSchemaProvider Interface : GetSchema Method

connection
A connection to get schema for.

Glossary Item Box

Gets the schema of the specified db connection if it's of the same data provider.

Syntax

Visual Basic (Declaration)
Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection
A connection to get schema for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbSchemaProvider Interface
IDbSchemaProvider Members


Column Class

[image]
ActiveReports 19 .NET Edition
Column Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

Defines a column.

Object Model

Column Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Column
C#
public sealed class Column

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Column

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Column Class Members

[image]
ActiveReports 19 .NET Edition
Column Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

The following tables list the members exposed by Column.

Public Constructors

 | Name | Description
Public Constructor | Column Constructor | Initializes a new instance of the Column class.
Top

Public Properties

 | Name | Description
Public Property | DataType | The column data type.
Public Property | IsPrimaryKey | Whether the column is included to primary key.
Public Property | Name | The column name.
Top

See Also

Reference

Column Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Column Constructor

[image]
ActiveReports 19 .NET Edition
Column Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : Column Constructor

name
The column name.
dataType
The column data type.
isPrimaryKey
Whether the column is included to primary key.

Glossary Item Box

Initializes a new instance of the Column class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dataType As Type, _
   ByVal isPrimaryKey As Boolean _
)
C#
public Column(
   string name,
   Type dataType,
   bool isPrimaryKey
)

Parameters

name
The column name.
dataType
The column data type.
isPrimaryKey
Whether the column is included to primary key.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


Column Class Properties

[image]
ActiveReports 19 .NET Edition
Column Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

For a list of all members of this type, see Column members.

Public Properties

 | Name | Description
Public Property | DataType | The column data type.
Public Property | IsPrimaryKey | Whether the column is included to primary key.
Public Property | Name | The column name.
Top

See Also

Reference

Column Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataType Property

[image]
ActiveReports 19 .NET Edition
DataType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : DataType Property

Glossary Item Box

The column data type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataType As Type
C#
public Type DataType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


IsPrimaryKey Property

[image]
ActiveReports 19 .NET Edition
IsPrimaryKey Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : IsPrimaryKey Property

Glossary Item Box

Whether the column is included to primary key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrimaryKey As Boolean
C#
public bool IsPrimaryKey {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : Name Property

Glossary Item Box

The column name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


DataSchema Class

[image]
ActiveReports 19 .NET Edition
DataSchema Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

Defines the data schema of database.

Object Model

DataSchema Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSchema
C#
public sealed class DataSchema

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DataSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataSchema Class Members

[image]
ActiveReports 19 .NET Edition
DataSchema Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

The following tables list the members exposed by DataSchema.

Public Constructors

 | Name | Description
Public Constructor | DataSchema Constructor | Initializes a new instance of the DataSchema class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents the empty data schema.
Top

Public Properties

 | Name | Description
Public Property | ForeignKeys | The foreight keys collection which has this table as source.
Public Property | Tables | The tables collection
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataSchema Constructor

[image]
ActiveReports 19 .NET Edition
DataSchema Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : DataSchema Constructor

tables
The tables collection.
foreighKeys
The foreigh keys collection.

Glossary Item Box

Initializes a new instance of the DataSchema class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tables As IEnumerable(Of Table), _
   ByVal foreighKeys As IEnumerable(Of ForeignKey) _
)
C#
public DataSchema(
   IEnumerable<Table> tables,
   IEnumerable<ForeignKey> foreighKeys
)

Parameters

tables
The tables collection.
foreighKeys
The foreigh keys collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DataSchema Class Properties

[image]
ActiveReports 19 .NET Edition
DataSchema Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

For a list of all members of this type, see DataSchema members.

Public Properties

 | Name | Description
Public Property | ForeignKeys | The foreight keys collection which has this table as source.
Public Property | Tables | The tables collection
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKeys Property

[image]
ActiveReports 19 .NET Edition
ForeignKeys Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : ForeignKeys Property

Glossary Item Box

The foreight keys collection which has this table as source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForeignKeys As IItemCollection(Of ForeignKey)
C#
public IItemCollection<ForeignKey> ForeignKeys {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


Tables Property

[image]
ActiveReports 19 .NET Edition
Tables Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : Tables Property

Glossary Item Box

The tables collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As IItemCollection(Of Table)
C#
public IItemCollection<Table> Tables {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DataSchema Class Fields

[image]
ActiveReports 19 .NET Edition
DataSchema Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

For a list of all members of this type, see DataSchema members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents the empty data schema.
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : Empty Field

Glossary Item Box

Represents the empty data schema.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As DataSchema
C#
public static readonly DataSchema Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DbName Class

[image]
ActiveReports 19 .NET Edition
DbName Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

Defines the name of table.

Object Model

DbName Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DbName
C#
public sealed class DbName

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DbName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DbName Class Members

[image]
ActiveReports 19 .NET Edition
DbName Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

The following tables list the members exposed by DbName.

Public Constructors

 | Name | Description
Public Constructor | DbName Constructor | Initializes a new instance of the DbName class.
Top

Public Properties

 | Name | Description
Public Property | Name | The name of table.
Public Property | Schema | The schema name.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DbName Constructor

[image]
ActiveReports 19 .NET Edition
DbName Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : DbName Constructor

name
The name of table.
schema
The schema name.

Glossary Item Box

Initializes a new instance of the DbName class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal schema As String _
)
C#
public DbName(
   string name,
   string schema
)

Parameters

name
The name of table.
schema
The schema name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


DbName Class Methods

[image]
ActiveReports 19 .NET Edition
DbName Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

For a list of all members of this type, see DbName members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Equals(Object) Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


DbName Class Properties

[image]
ActiveReports 19 .NET Edition
DbName Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

For a list of all members of this type, see DbName members.

Public Properties

 | Name | Description
Public Property | Name | The name of table.
Public Property | Schema | The schema name.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Name Property

Glossary Item Box

The name of table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


Schema Property

[image]
ActiveReports 19 .NET Edition
Schema Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Schema Property

Glossary Item Box

The schema name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As String
C#
public string Schema {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


ForeignKey Class

[image]
ActiveReports 19 .NET Edition
ForeignKey Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

Defines the foreigh key.

Object Model

ForeignKey Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKey
C#
public sealed class ForeignKey

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.ForeignKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKey Class Members

[image]
ActiveReports 19 .NET Edition
ForeignKey Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

The following tables list the members exposed by ForeignKey.

Public Constructors

 | Name | Description
Public Constructor | ForeignKey Constructor | Initializes a new instance of the ForeignKey class.
Top

Public Properties

 | Name | Description
Public Property | Destination | The destination table.
Public Property | DestinationColumns | The columnts that defines a destination.
Public Property | Source | The source table.
Public Property | SourceColumns | The columns that defines a source.
Top

See Also

Reference

ForeignKey Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKey Constructor

[image]
ActiveReports 19 .NET Edition
ForeignKey Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : ForeignKey Constructor

source
The source table.
destination
The destination table.
sourceColumns
The columns that defines a source.
destinationColumns
The columnts that defines a destination.

Glossary Item Box

Initializes a new instance of the ForeignKey class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As Table, _
   ByVal destination As Table, _
   ByVal sourceColumns As IEnumerable(Of Column), _
   ByVal destinationColumns As IEnumerable(Of Column) _
)
C#
public ForeignKey(
   Table source,
   Table destination,
   IEnumerable<Column> sourceColumns,
   IEnumerable<Column> destinationColumns
)

Parameters

source
The source table.
destination
The destination table.
sourceColumns
The columns that defines a source.
destinationColumns
The columnts that defines a destination.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


ForeignKey Class Properties

[image]
ActiveReports 19 .NET Edition
ForeignKey Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

For a list of all members of this type, see ForeignKey members.

Public Properties

 | Name | Description
Public Property | Destination | The destination table.
Public Property | DestinationColumns | The columnts that defines a destination.
Public Property | Source | The source table.
Public Property | SourceColumns | The columns that defines a source.
Top

See Also

Reference

ForeignKey Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Destination Property

[image]
ActiveReports 19 .NET Edition
Destination Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : Destination Property

Glossary Item Box

The destination table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Table
C#
public Table Destination {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


DestinationColumns Property

[image]
ActiveReports 19 .NET Edition
DestinationColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : DestinationColumns Property

Glossary Item Box

The columnts that defines a destination.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DestinationColumns As IItemCollection(Of Column)
C#
public IItemCollection<Column> DestinationColumns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : Source Property

Glossary Item Box

The source table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Table
C#
public Table Source {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


SourceColumns Property

[image]
ActiveReports 19 .NET Edition
SourceColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : SourceColumns Property

Glossary Item Box

The columns that defines a source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceColumns As IItemCollection(Of Column)
C#
public IItemCollection<Column> SourceColumns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


Table Class

[image]
ActiveReports 19 .NET Edition
Table Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

Defines a table.

Object Model

Table Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Table
C#
public sealed class Table

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Table Class Members

[image]
ActiveReports 19 .NET Edition
Table Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

The following tables list the members exposed by Table.

Public Constructors

 | Name | Description
Public Constructor | Table Constructor | Initializes a new instance of the Table class.
Top

Public Properties

 | Name | Description
Public Property | Columns | The table colums collection.
Public Property | Name | The name of table
Public Property | TableType | The table type.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Public Method | GetHashCode | Returns a System.Int32 that represents a hash code for the current object.
Public Method | ToString | Returns a System.String that represents this instance.
Top

Public Operators

public Operator Equality | Returns a System.Boolean. This is true if the first Table is equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.
public Operator Inequality | Returns a System.Boolean. This is true if the first Table is not equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Table Constructor

[image]
ActiveReports 19 .NET Edition
Table Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Table Constructor

name
The name of the table.
tableType
The table type.
columns
The table colums collection.

Glossary Item Box

Initializes a new instance of the Table class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As DbName, _
   ByVal tableType As TableType, _
   ByVal columns As IEnumerable(Of Column) _
)
C#
public Table(
   DbName name,
   TableType tableType,
   IEnumerable<Column> columns
)

Parameters

name
The name of the table.
tableType
The table type.
columns
The table colums collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Methods

[image]
ActiveReports 19 .NET Edition
Table Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Public Method | GetHashCode | Returns a System.Int32 that represents a hash code for the current object.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Equals Method

Glossary Item Box

Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.

Overload List

Overload | Description
Equals(Table) | Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Equals(Object) | Returns a System.Boolean. This is true if the specified Object is equal to the current Table; otherwise, false. The object for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Equals(Table) Method

[image]
ActiveReports 19 .NET Edition
Equals(Table) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class > Equals Method : Equals(Table) Method

anotherTable
The table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal anotherTable As Table _
) As Boolean
C#
public bool Equals(
   Table anotherTable
)

Parameters

anotherTable
The table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class > Equals Method : Equals(Object) Method

obj
The object for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the specified Object is equal to the current Table; otherwise, false. The object for comparison.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : GetHashCode Method

Glossary Item Box

Returns a System.Int32 that represents a hash code for the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Properties

[image]
ActiveReports 19 .NET Edition
Table Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Properties

 | Name | Description
Public Property | Columns | The table colums collection.
Public Property | Name | The name of table
Public Property | TableType | The table type.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Columns Property

Glossary Item Box

The table colums collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As IItemCollection(Of Column)
C#
public IItemCollection<Column> Columns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Name Property

Glossary Item Box

The name of table

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As DbName
C#
public DbName Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableType Property

[image]
ActiveReports 19 .NET Edition
TableType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : TableType Property

Glossary Item Box

The table type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableType As TableType
C#
public TableType TableType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Equality Operator

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the first Table is equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal firstTable As Table, _
   ByVal secondTable As Table _
) As Boolean
C#
public bool operator ==(
   Table firstTable,
   Table secondTable
)

Parameters

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Inequality Operator

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the first Table is not equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal firstTable As Table, _
   ByVal secondTable As Table _
) As Boolean
C#
public bool operator !=(
   Table firstTable,
   Table secondTable
)

Parameters

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableType Enumeration

[image]
ActiveReports 19 .NET Edition
TableType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : TableType Enumeration

Glossary Item Box

Defines enumeration of table types.

Syntax

Visual Basic (Declaration)
Public Enum TableType
   Inherits System.Enum
C#
public enum TableType : System.Enum

Members

Member | Description
Table | Table
View | View

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.TableType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


IConfigurable Interface

[image]
ActiveReports 19 .NET Edition
IConfigurable Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

Interface for configurable components.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurable
C#
public interface IConfigurable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Members

[image]
ActiveReports 19 .NET Edition
IConfigurable Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

The following tables list the members exposed by IConfigurable.

Public Methods

 | Name | Description
Method | GetSupportedSettings | Overloaded. Returns the settings supported by a rendering extension.
Top

See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Methods

[image]
ActiveReports 19 .NET Edition
IConfigurable Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

For a list of all members of this type, see IConfigurable members.

Public Methods

 | Name | Description
Method | GetSupportedSettings | Overloaded. Returns the settings supported by a rendering extension.
Top

See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetSupportedSettings Method

[image]
ActiveReports 19 .NET Edition
GetSupportedSettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface : GetSupportedSettings Method

Glossary Item Box

Returns the settings supported by a rendering extension.

Overload List

Overload | Description
GetSupportedSettings() | Returns the settings supported by a rendering extension.
GetSupportedSettings(Boolean) | Returns the settings supported by a rendering extension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members


GetSupportedSettings() Method

[image]
ActiveReports 19 .NET Edition
GetSupportedSettings() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Returns the settings supported by a rendering extension.

Syntax

Visual Basic (Declaration)
Overloads Function GetSupportedSettings() As ISettings
C#
ISettings GetSupportedSettings()

Return Value

A ISettings to provide access to the rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetSupportedSettings(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Indicates that this is a fixed page layout

Glossary Item Box

Returns the settings supported by a rendering extension.

Syntax

Visual Basic (Declaration)
Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As ISettings
C#
ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Indicates that this is a fixed page layout

Return Value

A ISettings to provide access to the rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members
Overload List


IRenderingExtension Interface

[image]
ActiveReports 19 .NET Edition
IRenderingExtension Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

Interface for rendering extension objects.

Syntax

Visual Basic (Declaration)
Public Interface IRenderingExtension
C#
public interface IRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Members

[image]
ActiveReports 19 .NET Edition
IRenderingExtension Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

The following tables list the members exposed by IRenderingExtension.

Public Methods

 | Name | Description
Method | Render | Overloaded. Renders the report.
Top

See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Methods

[image]
ActiveReports 19 .NET Edition
IRenderingExtension Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

For a list of all members of this type, see IRenderingExtension members.

Public Methods

 | Name | Description
Method | Render | Overloaded. Renders the report.
Top

See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface : Render Method

Glossary Item Box

Renders the report.

Overload List

Overload | Description
Render(IReport,StreamProvider) | Renders the report.
Render(IReport,StreamProvider,NameValueCollection) | Renders the report.
Render(IReport,StreamProvider,NameValueCollection,CancellationToken) | Renders the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members


Render(IReport,StreamProvider) Method

[image]
ActiveReports 19 .NET Edition
Render(IReport,StreamProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider) Method

report
The report to render.
streams
Stream for output.

Glossary Item Box

Renders the report.

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider _
)
C#
void Render(
   IReport report,
   StreamProvider streams
)

Parameters

report
The report to render.
streams
Stream for output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 19 .NET Edition
Render(IReport,StreamProvider,NameValueCollection) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider,NameValueCollection) Method

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.

Glossary Item Box

Renders the report.

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
void Render(
   IReport report,
   StreamProvider streams,
   NameValueCollection settings
)

Parameters

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection,CancellationToken) Method

[image]
ActiveReports 19 .NET Edition
Render(IReport,StreamProvider,NameValueCollection,CancellationToken) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider,NameValueCollection,CancellationToken) Method

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.
cancel
The System.Threading.CancellationToken object that allows to interrupt rendering.

Glossary Item Box

Renders the report.

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal cancel As CancellationToken _
)
C#
void Render(
   IReport report,
   StreamProvider streams,
   NameValueCollection settings,
   CancellationToken cancel
)

Parameters

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.
cancel
The System.Threading.CancellationToken object that allows to interrupt rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


ITrackableRenderingExtension Interface

[image]
ActiveReports 19 .NET Edition
ITrackableRenderingExtension Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITrackableRenderingExtension Interface

Glossary Item Box

Interface for rendering extension objects with rendering progress.

Syntax

Visual Basic (Declaration)
Public Interface ITrackableRenderingExtension
   Inherits IRenderingExtension
C#
public interface ITrackableRenderingExtension : IRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackableRenderingExtension Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ITrackableRenderingExtension Interface Members

[image]
ActiveReports 19 .NET Edition
ITrackableRenderingExtension Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITrackableRenderingExtension Interface

Glossary Item Box

The following tables list the members exposed by ITrackableRenderingExtension.

Public Methods

 | Name | Description
Method | Render | Renders the report and track render progress.
Top

See Also

Reference

ITrackableRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ITrackableRenderingExtension Interface Methods

[image]
ActiveReports 19 .NET Edition
ITrackableRenderingExtension Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITrackableRenderingExtension Interface

Glossary Item Box

For a list of all members of this type, see ITrackableRenderingExtension members.

Public Methods

 | Name | Description
Method | Render | Renders the report and track render progress.
Top

See Also

Reference

ITrackableRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ITrackableRenderingExtension Interface : Render Method

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.
cancel
The System.Threading.CancellationToken object that allows to interrupt rendering.
progress
The IProgress is a provider for progress updates.

Glossary Item Box

Renders the report and track render progress.

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal cancel As CancellationToken, _
   ByVal progress As IProgress(Of ProgressInfo) _
)
C#
void Render(
   IReport report,
   StreamProvider streams,
   NameValueCollection settings,
   CancellationToken cancel,
   IProgress<ProgressInfo> progress
)

Parameters

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.
cancel
The System.Threading.CancellationToken object that allows to interrupt rendering.
progress
The IProgress is a provider for progress updates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackableRenderingExtension Interface
ITrackableRenderingExtension Members


StreamInfo Class

[image]
ActiveReports 19 .NET Edition
StreamInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

Glossary Item Box

Wraps info about streams. Used with StreamProvider to access streams.

Object Model

StreamInfo Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class StreamInfo
C#
public abstract class StreamInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamInfo Class Members

[image]
ActiveReports 19 .NET Edition
StreamInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

Glossary Item Box

The following tables list the members exposed by StreamInfo.

Public Properties

 | Name | Description
Public Property | MimeType | Returns MimeType of the underlying stream
Public Property | Uri | Returns System.Uri of the underlying stream
Top

Public Methods

 | Name | Description
Public Method | OpenStream | Returns instance to the underlying System.IO.Stream
Top

See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamInfo Class Methods

[image]
ActiveReports 19 .NET Edition
StreamInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

Glossary Item Box

For a list of all members of this type, see StreamInfo members.

Public Methods

 | Name | Description
Public Method | OpenStream | Returns instance to the underlying System.IO.Stream
Top

See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


OpenStream Method

[image]
ActiveReports 19 .NET Edition
OpenStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : OpenStream Method

Glossary Item Box

Returns instance to the underlying System.IO.Stream

Syntax

Visual Basic (Declaration)
Public MustOverride Function OpenStream() As Stream
C#
public abstract Stream OpenStream()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamInfo Class
StreamInfo Members


StreamInfo Class Properties

[image]
ActiveReports 19 .NET Edition
StreamInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

Glossary Item Box

For a list of all members of this type, see StreamInfo members.

Public Properties

 | Name | Description
Public Property | MimeType | Returns MimeType of the underlying stream
Public Property | Uri | Returns System.Uri of the underlying stream
Top

See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


MimeType Property

[image]
ActiveReports 19 .NET Edition
MimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : MimeType Property

Glossary Item Box

Returns MimeType of the underlying stream

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
C#
public string MimeType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamInfo Class
StreamInfo Members


Uri Property

[image]
ActiveReports 19 .NET Edition
Uri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : Uri Property

Glossary Item Box

Returns System.Uri of the underlying stream

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Uri As Uri
C#
public Uri Uri {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamInfo Class
StreamInfo Members


StreamProvider Class

[image]
ActiveReports 19 .NET Edition
StreamProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class

Glossary Item Box

Base class for stream provider for rendering report extension outputs to a file.

Object Model

StreamProvider Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class StreamProvider
C#
public abstract class StreamProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider
GrapeCity.ActiveReports.Rendering.IO.Mht.MhtStreamProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Members
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamProvider Class Members

[image]
ActiveReports 19 .NET Edition
StreamProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class

Glossary Item Box

The following tables list the members exposed by StreamProvider.

Public Methods

 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | CreateSecondaryStream | Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | GetPrimaryStream | Returns a GrapeCity.ActiveReports.Extensibility.IO.StreamInfo providing access to the primary stream.
Public Method | GetSecondaryStreams | Returns an array of GrapeCity.ActiveReports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).
Top

See Also

Reference

StreamProvider Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamProvider Class Methods

[image]
ActiveReports 19 .NET Edition
StreamProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class

Glossary Item Box

For a list of all members of this type, see StreamProvider members.

Public Methods

 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | CreateSecondaryStream | Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | GetPrimaryStream | Returns a GrapeCity.ActiveReports.Extensibility.IO.StreamInfo providing access to the primary stream.
Public Method | GetSecondaryStreams | Returns an array of GrapeCity.ActiveReports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).
Top

See Also

Reference

StreamProvider Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


CleanUpOnError Method

[image]
ActiveReports 19 .NET Edition
CleanUpOnError Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CleanUpOnError Method

Glossary Item Box

Performs the required clean up in case of a rendering error.

Syntax

Visual Basic (Declaration)
Public Overridable Sub CleanUpOnError()
C#
public virtual void CleanUpOnError()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Class
StreamProvider Members


CreatePrimaryStream Method

[image]
ActiveReports 19 .NET Edition
CreatePrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CreatePrimaryStream Method

mimeType
mime type of the primary stream
suggestedFileExtension
suggested file extension

Glossary Item Box

Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.

Syntax

Visual Basic (Declaration)
Public MustOverride Function CreatePrimaryStream( _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public abstract StreamInfo CreatePrimaryStream(
   string mimeType,
   string suggestedFileExtension
)

Parameters

mimeType
mime type of the primary stream
suggestedFileExtension
suggested file extension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Class
StreamProvider Members


CreateSecondaryStream Method

[image]
ActiveReports 19 .NET Edition
CreateSecondaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CreateSecondaryStream Method

relativeName
relative name
mimeType
mime type of the primary stream
suggestedFileExtension
suggested file extension

Glossary Item Box

Returns GrapeCity.ActiveReports.Extensibility.IO.StreamInfo of the primary stream.

Syntax

Visual Basic (Declaration)
Public MustOverride Function CreateSecondaryStream( _
   ByVal relativeName As String, _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public abstract StreamInfo CreateSecondaryStream(
   string relativeName,
   string mimeType,
   string suggestedFileExtension
)

Parameters

relativeName
relative name
mimeType
mime type of the primary stream
suggestedFileExtension
suggested file extension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Class
StreamProvider Members


GetPrimaryStream Method

[image]
ActiveReports 19 .NET Edition
GetPrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : GetPrimaryStream Method

Glossary Item Box

Returns a GrapeCity.ActiveReports.Extensibility.IO.StreamInfo providing access to the primary stream.

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetPrimaryStream() As StreamInfo
C#
public abstract StreamInfo GetPrimaryStream()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Class
StreamProvider Members


GetSecondaryStreams Method

[image]
ActiveReports 19 .NET Edition
GetSecondaryStreams Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : GetSecondaryStreams Method

Glossary Item Box

Returns an array of GrapeCity.ActiveReports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetSecondaryStreams() As StreamInfo()
C#
public abstract StreamInfo[] GetSecondaryStreams()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamProvider Class
StreamProvider Members


CultureInfoExtension Class

[image]
ActiveReports 19 .NET Edition
CultureInfoExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.JpCalendar Namespace : CultureInfoExtension Class

Glossary Item Box

Object Model

CultureInfoExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CultureInfoExtension
C#
public static class CultureInfoExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.JpCalendar.CultureInfoExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CultureInfoExtension Members
GrapeCity.ActiveReports.JpCalendar Namespace


CultureInfoExtension Class Members

[image]
ActiveReports 19 .NET Edition
CultureInfoExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.JpCalendar Namespace : CultureInfoExtension Class

Glossary Item Box

The following tables list the members exposed by CultureInfoExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FormatJpDate | Formats date as general for not JP and with era settings and custom format "ggYY" support for JP.
static (Shared in Visual Basic) | InitJpCalendar | Initialize static jp calendar.
Top

See Also

Reference

CultureInfoExtension Class
GrapeCity.ActiveReports.JpCalendar Namespace


CultureInfoExtension Class Methods

[image]
ActiveReports 19 .NET Edition
CultureInfoExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.JpCalendar Namespace : CultureInfoExtension Class

Glossary Item Box

For a list of all members of this type, see CultureInfoExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FormatJpDate | Formats date as general for not JP and with era settings and custom format "ggYY" support for JP.
static (Shared in Visual Basic) | InitJpCalendar | Initialize static jp calendar.
Top

See Also

Reference

CultureInfoExtension Class
GrapeCity.ActiveReports.JpCalendar Namespace


FormatJpDate Method

[image]
ActiveReports 19 .NET Edition
FormatJpDate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.JpCalendar Namespace > CultureInfoExtension Class : FormatJpDate Method

culture
date
format

Glossary Item Box

Formats date as general for not JP and with era settings and custom format "ggYY" support for JP.

Syntax

Visual Basic (Declaration)
Public Shared Function FormatJpDate( _
   ByVal culture As CultureInfo, _
   ByVal date As Date, _
   ByVal format As String _
) As String
C#
public static string FormatJpDate(
   CultureInfo culture,
   DateTime date,
   string format
)

Parameters

culture
date
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CultureInfoExtension Class
CultureInfoExtension Members


InitJpCalendar Method

[image]
ActiveReports 19 .NET Edition
InitJpCalendar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.JpCalendar Namespace > CultureInfoExtension Class : InitJpCalendar Method

Glossary Item Box

Initialize static jp calendar.

Syntax

Visual Basic (Declaration)
Public Shared Sub InitJpCalendar()
C#
public static void InitJpCalendar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CultureInfoExtension Class
CultureInfoExtension Members


Margin Class

[image]
ActiveReports 19 .NET Edition
Margin Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margin Class

Glossary Item Box

Page margins

Object Model

Margin Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Margin
C#
public sealed class Margin

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.Margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Members
GrapeCity.ActiveReports.Printing Namespace


Margin Class Members

[image]
ActiveReports 19 .NET Edition
Margin Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margin Class

Glossary Item Box

The following tables list the members exposed by Margin.

Public Constructors

 | Name | Description
Public Constructor | Margin Constructor | Initializes a new instance of the Margin class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty margins
Top

Public Properties

 | Name | Description
Public Property | Bottom | Bottom margin.
Public Property | Left | Left margin.
Public Property | Right | Right margin.
Public Property | Top | Top margin.
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Printing Namespace


Margin Constructor

[image]
ActiveReports 19 .NET Edition
Margin Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Margin Constructor

left
The left margin.
right
The right margin.
top
The top margin.
bottom
The bottom margin.

Glossary Item Box

Initializes a new instance of the Margin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal right As Single, _
   ByVal top As Single, _
   ByVal bottom As Single _
)
C#
public Margin(
   float left,
   float right,
   float top,
   float bottom
)

Parameters

left
The left margin.
right
The right margin.
top
The top margin.
bottom
The bottom margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Margin Class Properties

[image]
ActiveReports 19 .NET Edition
Margin Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margin Class

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Properties

 | Name | Description
Public Property | Bottom | Bottom margin.
Public Property | Left | Left margin.
Public Property | Right | Right margin.
Public Property | Top | Top margin.
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Printing Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Bottom Property

Glossary Item Box

Bottom margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Single
C#
public float Bottom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Left Property

Glossary Item Box

Left margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Right Property

Glossary Item Box

Right margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Single
C#
public float Right {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Top Property

Glossary Item Box

Top margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Margin Class Fields

[image]
ActiveReports 19 .NET Edition
Margin Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margin Class

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty margins
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Printing Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margin Class : Empty Field

Glossary Item Box

The empty margins

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Margin
C#
public static readonly Margin Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Margins Class

[image]
ActiveReports 19 .NET Edition
Margins Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margins Class

Glossary Item Box

Specifies the dimensions of the margins of a printed page. This is a cross-platform version of System.Drawing.Printing.Margins.

Object Model

Margins Class

Syntax

Visual Basic (Declaration)
Public Class Margins
C#
public class Margins

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.Margins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Members
GrapeCity.ActiveReports.Printing Namespace


Margins Class Members

[image]
ActiveReports 19 .NET Edition
Margins Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margins Class

Glossary Item Box

The following tables list the members exposed by Margins.

Public Constructors

 | Name | Description
Public Constructor | Margins Constructor | Initializes a new instance of the Margins class with the specified left, right, top, and bottom margins.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin, in hundredths of an inch.
Public Property | Left | Gets or sets the left margin width, in hundredths of an inch.
Public Property | Right | Gets or sets the right margin width, in hundredths of an inch.
Public Property | Top | Gets or sets the top margin width, in hundredths of an inch.
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

Public Operators

public Operator Equality
public Operator Inequality
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Printing Namespace


Margins Constructor

[image]
ActiveReports 19 .NET Edition
Margins Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Margins Constructor

left
The left margin, in hundredths of an inch.
right
The right margin, in hundredths of an inch.
top
The top margin, in hundredths of an inch.
bottom
The bottom margin, in hundredths of an inch.

Glossary Item Box

Initializes a new instance of the Margins class with the specified left, right, top, and bottom margins.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal right As Integer, _
   ByVal top As Integer, _
   ByVal bottom As Integer _
)
C#
public Margins(
   int left,
   int right,
   int top,
   int bottom
)

Parameters

left
The left margin, in hundredths of an inch.
right
The right margin, in hundredths of an inch.
top
The top margin, in hundredths of an inch.
bottom
The bottom margin, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Methods

[image]
ActiveReports 19 .NET Edition
Margins Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Printing Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Properties

[image]
ActiveReports 19 .NET Edition
Margins Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin, in hundredths of an inch.
Public Property | Left | Gets or sets the left margin width, in hundredths of an inch.
Public Property | Right | Gets or sets the right margin width, in hundredths of an inch.
Public Property | Top | Gets or sets the top margin width, in hundredths of an inch.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Printing Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Bottom Property

Glossary Item Box

Gets or sets the bottom margin, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Integer
C#
public int Bottom {get; set;}

Property Value

The bottom margin, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Left Property

Glossary Item Box

Gets or sets the left margin width, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

The left margin width, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Right Property

Glossary Item Box

Gets or sets the right margin width, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Right As Integer
C#
public int Right {get; set;}

Property Value

The right margin width, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Top Property

Glossary Item Box

Gets or sets the top margin width, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

The top margin width, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Equality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal x As Margins, _
   ByVal y As Margins _
) As Boolean
C#
public bool operator ==(
   Margins x,
   Margins y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Margins Class : Inequality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal x As Margins, _
   ByVal y As Margins _
) As Boolean
C#
public bool operator !=(
   Margins x,
   Margins y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


PaperSize Class

[image]
ActiveReports 19 .NET Edition
PaperSize Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSize Class

Glossary Item Box

Specifies the size of a piece of paper in hundredths of an inch. This is a cross-platform version of System.Drawing.Printing.PaperSize.

Object Model

PaperSize Class

Syntax

Visual Basic (Declaration)
Public Class PaperSize
C#
public class PaperSize

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.PaperSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Members
GrapeCity.ActiveReports.Printing Namespace


PaperSize Class Members

[image]
ActiveReports 19 .NET Edition
PaperSize Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSize Class

Glossary Item Box

The following tables list the members exposed by PaperSize.

Public Constructors

 | Name | Description
Public Constructor | PaperSize Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the paper, in hundredths of an inch.
Public Property | Kind | Gets the type of paper.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | RawKind | Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value.
Public Property | Width | Gets or sets the width of the paper, in hundredths of an inch.
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

Public Operators

public Operator Equality
public Operator Inequality
Top

See Also

Reference

PaperSize Class
GrapeCity.ActiveReports.Printing Namespace


PaperSize Constructor

[image]
ActiveReports 19 .NET Edition
PaperSize Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : PaperSize Constructor

Glossary Item Box

Overload List

Overload | Description
PaperSize Constructor(PaperKind,String,Int32,Int32) |
PaperSize Constructor(String,Int32,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


PaperSize Constructor(PaperKind,String,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
PaperSize Constructor(PaperKind,String,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class > PaperSize Constructor : PaperSize Constructor(PaperKind,String,Int32,Int32)

kind
name
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal kind As PaperKind, _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public PaperSize(
   PaperKind kind,
   string name,
   int width,
   int height
)

Parameters

kind
name
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members
Overload List


PaperSize Constructor(String,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
PaperSize Constructor(String,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class > PaperSize Constructor : PaperSize Constructor(String,Int32,Int32)

name
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public PaperSize(
   string name,
   int width,
   int height
)

Parameters

name
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members
Overload List


PaperSize Class Methods

[image]
ActiveReports 19 .NET Edition
PaperSize Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSize Class

Glossary Item Box

For a list of all members of this type, see PaperSize members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

PaperSize Class
GrapeCity.ActiveReports.Printing Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


PaperSize Class Properties

[image]
ActiveReports 19 .NET Edition
PaperSize Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSize Class

Glossary Item Box

For a list of all members of this type, see PaperSize members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the paper, in hundredths of an inch.
Public Property | Kind | Gets the type of paper.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | RawKind | Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value.
Public Property | Width | Gets or sets the width of the paper, in hundredths of an inch.
Top

See Also

Reference

PaperSize Class
GrapeCity.ActiveReports.Printing Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Height Property

Glossary Item Box

Gets or sets the height of the paper, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the paper, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


Kind Property

[image]
ActiveReports 19 .NET Edition
Kind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Kind Property

Glossary Item Box

Gets the type of paper.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Kind As PaperKind
C#
public PaperKind Kind {get;}

Property Value

One of the GrapeCity.Documents.Common.PaperKind values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


PaperName Property

[image]
ActiveReports 19 .NET Edition
PaperName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : PaperName Property

Glossary Item Box

Gets or sets the name of the type of paper.

Syntax

Visual Basic (Declaration)
Public Property PaperName As String
C#
public string PaperName {get; set;}

Property Value

The name of the type of paper.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


RawKind Property

[image]
ActiveReports 19 .NET Edition
RawKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : RawKind Property

Glossary Item Box

Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value.

Syntax

Visual Basic (Declaration)
Public Property RawKind As Integer
C#
public int RawKind {get; set;}

Property Value

An integer representing one of the System.Drawing.Printing.PaperSize values, or a custom value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Width Property

Glossary Item Box

Gets or sets the width of the paper, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the paper, in hundredths of an inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Equality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal x As PaperSize, _
   ByVal y As PaperSize _
) As Boolean
C#
public bool operator ==(
   PaperSize x,
   PaperSize y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSize Class : Inequality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal x As PaperSize, _
   ByVal y As PaperSize _
) As Boolean
C#
public bool operator !=(
   PaperSize x,
   PaperSize y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSize Class
PaperSize Members


PaperSource Class

[image]
ActiveReports 19 .NET Edition
PaperSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSource Class

Glossary Item Box

Specifies the paper tray from which the printer gets paper.

Object Model

PaperSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PaperSource
C#
public sealed class PaperSource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.PaperSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Members
GrapeCity.ActiveReports.Printing Namespace


PaperSource Class Members

[image]
ActiveReports 19 .NET Edition
PaperSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSource Class

Glossary Item Box

The following tables list the members exposed by PaperSource.

Public Constructors

 | Name | Description
Public Constructor | PaperSource Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Kind | Gets the paper source.
Public Property | RawKind | Gets or sets the integer representing one of the PaperSourceKind values or a custom value.
Public Property | SourceName | Gets or sets the name of the paper source.
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

Public Operators

public Operator Equality
public Operator Inequality
Top

See Also

Reference

PaperSource Class
GrapeCity.ActiveReports.Printing Namespace


PaperSource Constructor

[image]
ActiveReports 19 .NET Edition
PaperSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : PaperSource Constructor

Glossary Item Box

Overload List

Overload | Description
PaperSource Constructor() | Initializes a new instance of the PaperSource class.
PaperSource Constructor(PaperSourceKind,String) | Initializes a new instance of the PaperSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


PaperSource Constructor()

[image]
ActiveReports 19 .NET Edition
PaperSource Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class > PaperSource Constructor : PaperSource Constructor()

Glossary Item Box

Initializes a new instance of the PaperSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PaperSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members
Overload List


PaperSource Constructor(PaperSourceKind,String)

[image]
ActiveReports 19 .NET Edition
PaperSource Constructor(PaperSourceKind,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class > PaperSource Constructor : PaperSource Constructor(PaperSourceKind,String)

kind
name

Glossary Item Box

Initializes a new instance of the PaperSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal kind As PaperSourceKind, _
   ByVal name As String _
)
C#
public PaperSource(
   PaperSourceKind kind,
   string name
)

Parameters

kind
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members
Overload List


PaperSource Class Methods

[image]
ActiveReports 19 .NET Edition
PaperSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSource Class

Glossary Item Box

For a list of all members of this type, see PaperSource members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

PaperSource Class
GrapeCity.ActiveReports.Printing Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


PaperSource Class Properties

[image]
ActiveReports 19 .NET Edition
PaperSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSource Class

Glossary Item Box

For a list of all members of this type, see PaperSource members.

Public Properties

 | Name | Description
Public Property | Kind | Gets the paper source.
Public Property | RawKind | Gets or sets the integer representing one of the PaperSourceKind values or a custom value.
Public Property | SourceName | Gets or sets the name of the paper source.
Top

See Also

Reference

PaperSource Class
GrapeCity.ActiveReports.Printing Namespace


Kind Property

[image]
ActiveReports 19 .NET Edition
Kind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : Kind Property

Glossary Item Box

Gets the paper source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Kind As PaperSourceKind
C#
public PaperSourceKind Kind {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


RawKind Property

[image]
ActiveReports 19 .NET Edition
RawKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : RawKind Property

Glossary Item Box

Gets or sets the integer representing one of the PaperSourceKind values or a custom value.

Syntax

Visual Basic (Declaration)
Public Property RawKind As Integer
C#
public int RawKind {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


SourceName Property

[image]
ActiveReports 19 .NET Edition
SourceName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : SourceName Property

Glossary Item Box

Gets or sets the name of the paper source.

Syntax

Visual Basic (Declaration)
Public Property SourceName As String
C#
public string SourceName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : Equality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal x As PaperSource, _
   ByVal y As PaperSource _
) As Boolean
C#
public bool operator ==(
   PaperSource x,
   PaperSource y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSource Class : Inequality Operator

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal x As PaperSource, _
   ByVal y As PaperSource _
) As Boolean
C#
public bool operator !=(
   PaperSource x,
   PaperSource y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSource Class
PaperSource Members


PaperSourceCollection Class

[image]
ActiveReports 19 .NET Edition
PaperSourceCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSourceCollection Class

Glossary Item Box

Object Model

PaperSourceCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PaperSourceCollection
C#
public sealed class PaperSourceCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.PaperSourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Members
GrapeCity.ActiveReports.Printing Namespace


PaperSourceCollection Class Members

[image]
ActiveReports 19 .NET Edition
PaperSourceCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSourceCollection Class

Glossary Item Box

The following tables list the members exposed by PaperSourceCollection.

Public Constructors

 | Name | Description
Public Constructor | PaperSourceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | CopyTo |
Top

See Also

Reference

PaperSourceCollection Class
GrapeCity.ActiveReports.Printing Namespace


PaperSourceCollection Constructor

[image]
ActiveReports 19 .NET Edition
PaperSourceCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : PaperSourceCollection Constructor

array

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal array() As PaperSource _
)
C#
public PaperSourceCollection(
   PaperSource[] array
)

Parameters

array

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


PaperSourceCollection Class Methods

[image]
ActiveReports 19 .NET Edition
PaperSourceCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSourceCollection Class

Glossary Item Box

For a list of all members of this type, see PaperSourceCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo |
Top

See Also

Reference

PaperSourceCollection Class
GrapeCity.ActiveReports.Printing Namespace


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


PaperSourceCollection Class Properties

[image]
ActiveReports 19 .NET Edition
PaperSourceCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSourceCollection Class

Glossary Item Box

For a list of all members of this type, see PaperSourceCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

See Also

Reference

PaperSourceCollection Class
GrapeCity.ActiveReports.Printing Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : IsSynchronized Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PaperSource
C#
public PaperSource this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PaperSourceCollection Class : SyncRoot Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSourceCollection Class
PaperSourceCollection Members


Printer Class

[image]
ActiveReports 19 .NET Edition
Printer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Printer Class

Glossary Item Box

This is a cross-platform wrapper around GDI+ Printer.

Object Model

Printer Class

Syntax

Visual Basic (Declaration)
Public Class Printer
C#
public class Printer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.Printer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Members
GrapeCity.ActiveReports.Printing Namespace


Printer Class Members

[image]
ActiveReports 19 .NET Edition
Printer Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Printer Class

Glossary Item Box

The following tables list the members exposed by Printer.

Public Properties

 | Name | Description
Public Property | DefaultPageSettings | Gets page settings that are used as defaults for all pages to be printed.
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Public Property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page.
Public Property | PaperHeight | Page height in inches.
Public Property | PaperKind | Gets the type of paper.
Public Property | PaperSize | Gets or sets the paper size for the page. The size is specified in hundredths of an inch.
Public Property | PaperWidth | Page width in inches.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterSettings | Gets a PrinterSettings that specifies where and how the document is printed.
Top

Public Methods

 | Name | Description
Public Method | Print | Starts the document's printing process.
Top

Public Events

 | Name | Description
Public Event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints.
Public Event | EndPrint | Occurs when the last page of the document has printed.
Public Event | PrintPage | Occurs when the output to print for the current page is needed.
Public Event | QueryPageSettings | Occurs immediately before each PrintPage event.
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Printing Namespace


Printer Class Methods

[image]
ActiveReports 19 .NET Edition
Printer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Methods

 | Name | Description
Public Method | Print | Starts the document's printing process.
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Printing Namespace


Print Method

[image]
ActiveReports 19 .NET Edition
Print Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : Print Method

Glossary Item Box

Starts the document's printing process.

Syntax

Visual Basic (Declaration)
Public Sub Print()
C#
public void Print()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Printer Class Properties

[image]
ActiveReports 19 .NET Edition
Printer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Properties

 | Name | Description
Public Property | DefaultPageSettings | Gets page settings that are used as defaults for all pages to be printed.
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Public Property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page.
Public Property | PaperHeight | Page height in inches.
Public Property | PaperKind | Gets the type of paper.
Public Property | PaperSize | Gets or sets the paper size for the page. The size is specified in hundredths of an inch.
Public Property | PaperWidth | Page width in inches.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterSettings | Gets a PrinterSettings that specifies where and how the document is printed.
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Printing Namespace


DefaultPageSettings Property

[image]
ActiveReports 19 .NET Edition
DefaultPageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : DefaultPageSettings Property

Glossary Item Box

Gets page settings that are used as defaults for all pages to be printed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultPageSettings As IPageSettings
C#
public IPageSettings DefaultPageSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


DocumentName Property

[image]
ActiveReports 19 .NET Edition
DocumentName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : DocumentName Property

Glossary Item Box

Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.

Syntax

Visual Basic (Declaration)
Public Property DocumentName As String
C#
public string DocumentName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Landscape Property

[image]
ActiveReports 19 .NET Edition
Landscape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : Landscape Property

Glossary Item Box

Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Syntax

Visual Basic (Declaration)
Public Property Landscape As Boolean
C#
public bool Landscape {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


OriginAtMargins Property

[image]
ActiveReports 19 .NET Edition
OriginAtMargins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : OriginAtMargins Property

Glossary Item Box

Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page.

Syntax

Visual Basic (Declaration)
Public Property OriginAtMargins As Boolean
C#
public bool OriginAtMargins {get; set;}

Property Value

true if the graphics origin starts at the page margins; false if the graphics origin is at the top-left corner of the printable page. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperHeight Property

[image]
ActiveReports 19 .NET Edition
PaperHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PaperHeight Property

Glossary Item Box

Page height in inches.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperHeight As Single
C#
public float PaperHeight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperKind Property

[image]
ActiveReports 19 .NET Edition
PaperKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PaperKind Property

Glossary Item Box

Gets the type of paper.

Syntax

Visual Basic (Declaration)
Public Property PaperKind As PaperKind
C#
public PaperKind PaperKind {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperSize Property

[image]
ActiveReports 19 .NET Edition
PaperSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PaperSize Property

Glossary Item Box

Gets or sets the paper size for the page. The size is specified in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSize
C#
public PaperSize PaperSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperWidth Property

[image]
ActiveReports 19 .NET Edition
PaperWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PaperWidth Property

Glossary Item Box

Page width in inches.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperWidth As Single
C#
public float PaperWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrinterName Property

[image]
ActiveReports 19 .NET Edition
PrinterName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PrinterName Property

Glossary Item Box

Gets or sets the name of the printer to use.

Syntax

Visual Basic (Declaration)
Public Property PrinterName As String
C#
public string PrinterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrinterSettings Property

[image]
ActiveReports 19 .NET Edition
PrinterSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PrinterSettings Property

Glossary Item Box

Gets a PrinterSettings that specifies where and how the document is printed.

Syntax

Visual Basic (Declaration)
Public Property PrinterSettings As IPrinterSettings
C#
public IPrinterSettings PrinterSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Printer Class Events

[image]
ActiveReports 19 .NET Edition
Printer Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Events

 | Name | Description
Public Event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints.
Public Event | EndPrint | Occurs when the last page of the document has printed.
Public Event | PrintPage | Occurs when the output to print for the current page is needed.
Public Event | QueryPageSettings | Occurs immediately before each PrintPage event.
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Printing Namespace


BeginPrint Event

[image]
ActiveReports 19 .NET Edition
BeginPrint Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : BeginPrint Event

Glossary Item Box

Occurs when the Print method is called and before the first page of the document prints.

Syntax

Visual Basic (Declaration)
Public Event BeginPrint As PrintEventHandler
C#
public event PrintEventHandler BeginPrint

Event Data

The event handler receives an argument of type PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
PrintAction | Returns PrintAction.PrintToFile in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


EndPrint Event

[image]
ActiveReports 19 .NET Edition
EndPrint Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : EndPrint Event

Glossary Item Box

Occurs when the last page of the document has printed.

Syntax

Visual Basic (Declaration)
Public Event EndPrint As PrintEventHandler
C#
public event PrintEventHandler EndPrint

Event Data

The event handler receives an argument of type PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
PrintAction | Returns PrintAction.PrintToFile in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrintPage Event

[image]
ActiveReports 19 .NET Edition
PrintPage Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : PrintPage Event

Glossary Item Box

Occurs when the output to print for the current page is needed.

Syntax

Visual Basic (Declaration)
Public Event PrintPage As PrintPageEventHandler
C#
public event PrintPageEventHandler PrintPage

Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


QueryPageSettings Event

[image]
ActiveReports 19 .NET Edition
QueryPageSettings Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > Printer Class : QueryPageSettings Event

Glossary Item Box

Occurs immediately before each PrintPage event.

Syntax

Visual Basic (Declaration)
Public Event QueryPageSettings As QueryPageSettingsEventHandler
C#
public event QueryPageSettingsEventHandler QueryPageSettings

Event Data

The event handler receives an argument of type QueryPageSettingsEventArgs containing data related to this event. The following QueryPageSettingsEventArgs properties provide information specific to this event.

Property | Description
PageSettings | Gets or sets the page settings for the page to be printed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrintEventArgs Class

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintEventArgs Class

Glossary Item Box

Provides data for the Printer.BeginPrint and Printer.EndPrint events.

Object Model

PrintEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PrintEventArgs
   Inherits System.ComponentModel.CancelEventArgs
C#
public class PrintEventArgs : System.ComponentModel.CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Printing.PrintEventArgs
GrapeCity.ActiveReports.Printing.QueryPageSettingsEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventArgs Members
GrapeCity.ActiveReports.Printing Namespace


PrintEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | PrintAction | Returns PrintAction.PrintToFile in all cases.
Top

See Also

Reference

PrintEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PrintEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintEventArgs Class : PrintEventArgs Constructor

Glossary Item Box

Overload List

Overload | Description
PrintEventArgs Constructor() |
PrintEventArgs Constructor(PrintAction) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventArgs Class
PrintEventArgs Members


PrintEventArgs Constructor()

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintEventArgs Class > PrintEventArgs Constructor : PrintEventArgs Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PrintEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventArgs Class
PrintEventArgs Members
Overload List


PrintEventArgs Constructor(PrintAction)

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Constructor(PrintAction)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintEventArgs Class > PrintEventArgs Constructor : PrintEventArgs Constructor(PrintAction)

printAction

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printAction As PrintAction _
)
C#
public PrintEventArgs(
   PrintAction printAction
)

Parameters

printAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventArgs Class
PrintEventArgs Members
Overload List


PrintEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
PrintEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintEventArgs members.

Public Properties

 | Name | Description
Public Property | PrintAction | Returns PrintAction.PrintToFile in all cases.
Top

See Also

Reference

PrintEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PrintAction Property

[image]
ActiveReports 19 .NET Edition
PrintAction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintEventArgs Class : PrintAction Property

Glossary Item Box

Returns PrintAction.PrintToFile in all cases.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintAction As PrintAction
C#
public PrintAction PrintAction {get;}

Property Value

PrintAction.PrintToFile in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventArgs Class
PrintEventArgs Members


PrintingThreadErrorEventArgs Class

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

Summary description for PrintingThreadErrorEventArgs.

Object Model

PrintingThreadErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PrintingThreadErrorEventArgs
   Inherits System.EventArgs
C#
public class PrintingThreadErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Printing.PrintingThreadErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Members
GrapeCity.ActiveReports.Printing Namespace


PrintingThreadErrorEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintingThreadErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintingThreadErrorEventArgs Constructor | Initializes a new instance of the PrintingThreadErrorEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets the printing thread exception.
Top

See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PrintingThreadErrorEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintingThreadErrorEventArgs Class : PrintingThreadErrorEventArgs Constructor

exception
The printing thread exception.

Glossary Item Box

Initializes a new instance of the PrintingThreadErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
C#
public PrintingThreadErrorEventArgs(
   Exception exception
)

Parameters

exception
The printing thread exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintingThreadErrorEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintingThreadErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the printing thread exception.
Top

See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


Exception Property

[image]
ActiveReports 19 .NET Edition
Exception Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintingThreadErrorEventArgs Class : Exception Property

Glossary Item Box

Gets the printing thread exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintOptions Class

[image]
ActiveReports 19 .NET Edition
PrintOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintOptions Class

Glossary Item Box

Print options

Object Model

PrintOptions Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PrintOptions
C#
public sealed class PrintOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.PrintOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Members
GrapeCity.ActiveReports.Printing Namespace


PrintOptions Class Members

[image]
ActiveReports 19 .NET Edition
PrintOptions Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintOptions Class

Glossary Item Box

The following tables list the members exposed by PrintOptions.

Public Properties

 | Name | Description
Public Property | AutoRotate | Auto-rotate
Public Property | IsMarginExist | Check for margin.
Public Property | Margin | Gets or sets page margins
Public Property | PageOrder | Page order
Public Property | PageScaling | Page scaling
Public Property | PagesPerSheet | Pages per sheet
Public Property | PrintPageBorder | Print page border
Public Property | Watermark | Watermark options
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates the default print options.
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Printing Namespace


PrintOptions Class Methods

[image]
ActiveReports 19 .NET Edition
PrintOptions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintOptions Class

Glossary Item Box

For a list of all members of this type, see PrintOptions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates the default print options.
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Printing Namespace


CreateDefault Method

[image]
ActiveReports 19 .NET Edition
CreateDefault Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : CreateDefault Method

Glossary Item Box

Creates the default print options.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefault() As PrintOptions
C#
public static PrintOptions CreateDefault()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintOptions Class Properties

[image]
ActiveReports 19 .NET Edition
PrintOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintOptions Class

Glossary Item Box

For a list of all members of this type, see PrintOptions members.

Public Properties

 | Name | Description
Public Property | AutoRotate | Auto-rotate
Public Property | IsMarginExist | Check for margin.
Public Property | Margin | Gets or sets page margins
Public Property | PageOrder | Page order
Public Property | PageScaling | Page scaling
Public Property | PagesPerSheet | Pages per sheet
Public Property | PrintPageBorder | Print page border
Public Property | Watermark | Watermark options
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Printing Namespace


AutoRotate Property

[image]
ActiveReports 19 .NET Edition
AutoRotate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : AutoRotate Property

Glossary Item Box

Auto-rotate

Syntax

Visual Basic (Declaration)
Public Property AutoRotate As Boolean
C#
public bool AutoRotate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


IsMarginExist Property

[image]
ActiveReports 19 .NET Edition
IsMarginExist Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : IsMarginExist Property

Glossary Item Box

Check for margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMarginExist As Boolean
C#
public bool IsMarginExist {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


Margin Property

[image]
ActiveReports 19 .NET Edition
Margin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : Margin Property

Glossary Item Box

Gets or sets page margins

Syntax

Visual Basic (Declaration)
Public Property Margin As Margin
C#
public Margin Margin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PageOrder Property

[image]
ActiveReports 19 .NET Edition
PageOrder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : PageOrder Property

Glossary Item Box

Page order

Syntax

Visual Basic (Declaration)
Public Property PageOrder As PageOrder
C#
public PageOrder PageOrder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PageScaling Property

[image]
ActiveReports 19 .NET Edition
PageScaling Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : PageScaling Property

Glossary Item Box

Page scaling

Syntax

Visual Basic (Declaration)
Public Property PageScaling As PageScaling
C#
public PageScaling PageScaling {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PagesPerSheet Property

[image]
ActiveReports 19 .NET Edition
PagesPerSheet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : PagesPerSheet Property

Glossary Item Box

Pages per sheet

Syntax

Visual Basic (Declaration)
Public Property PagesPerSheet As Integer
C#
public int PagesPerSheet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintPageBorder Property

[image]
ActiveReports 19 .NET Edition
PrintPageBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : PrintPageBorder Property

Glossary Item Box

Print page border

Syntax

Visual Basic (Declaration)
Public Property PrintPageBorder As Boolean
C#
public bool PrintPageBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


Watermark Property

[image]
ActiveReports 19 .NET Edition
Watermark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintOptions Class : Watermark Property

Glossary Item Box

Watermark options

Syntax

Visual Basic (Declaration)
Public Property Watermark As WatermarkOptions
C#
public WatermarkOptions Watermark {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintPageEventArgs Class

[image]
ActiveReports 19 .NET Edition
PrintPageEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintPageEventArgs Class

Glossary Item Box

Provides data for the PrintPage event.

Object Model

PrintPageEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PrintPageEventArgs
   Inherits System.EventArgs
C#
public class PrintPageEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Printing.PrintPageEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Members
GrapeCity.ActiveReports.Printing Namespace


PrintPageEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
PrintPageEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintPageEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintPageEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintPageEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the print job should be canceled.
Public Property | Graphics | Gets the System.Drawing.Graphics used to paint the page.
Public Property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
Public Property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
Public Property | PageBounds | Gets the rectangular area that represents the total area of the page.
Public Property | PageSettings | Gets the page settings for the current page.
Top

See Also

Reference

PrintPageEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PrintPageEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
PrintPageEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : PrintPageEventArgs Constructor

graphics
marginBounds
pageBounds
pageSettings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graphics As Object, _
   ByVal marginBounds As Rectangle, _
   ByVal pageBounds As Rectangle, _
   ByVal pageSettings As IPageSettings _
)
C#
public PrintPageEventArgs(
   object graphics,
   Rectangle marginBounds,
   Rectangle pageBounds,
   IPageSettings pageSettings
)

Parameters

graphics
marginBounds
pageBounds
pageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


PrintPageEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
PrintPageEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintPageEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintPageEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the print job should be canceled.
Public Property | Graphics | Gets the System.Drawing.Graphics used to paint the page.
Public Property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
Public Property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
Public Property | PageBounds | Gets the rectangular area that represents the total area of the page.
Public Property | PageSettings | Gets the page settings for the current page.
Top

See Also

Reference

PrintPageEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : Cancel Property

Glossary Item Box

Gets or sets a value indicating whether the print job should be canceled.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Property Value

true if the print job should be canceled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


Graphics Property

[image]
ActiveReports 19 .NET Edition
Graphics Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : Graphics Property

Glossary Item Box

Gets the System.Drawing.Graphics used to paint the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Graphics As Object
C#
public object Graphics {get;}

Property Value

The System.Drawing.Graphics used to paint the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


HasMorePages Property

[image]
ActiveReports 19 .NET Edition
HasMorePages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : HasMorePages Property

Glossary Item Box

Gets or sets a value indicating whether an additional page should be printed.

Syntax

Visual Basic (Declaration)
Public Property HasMorePages As Boolean
C#
public bool HasMorePages {get; set;}

Property Value

true if an additional page should be printed; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


MarginBounds Property

[image]
ActiveReports 19 .NET Edition
MarginBounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : MarginBounds Property

Glossary Item Box

Gets the rectangular area that represents the portion of the page inside the margins.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MarginBounds As Rectangle
C#
public Rectangle MarginBounds {get;}

Property Value

The rectangular area, measured in hundredths of an inch, that represents the portion of the page inside the margins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


PageBounds Property

[image]
ActiveReports 19 .NET Edition
PageBounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : PageBounds Property

Glossary Item Box

Gets the rectangular area that represents the total area of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageBounds As Rectangle
C#
public Rectangle PageBounds {get;}

Property Value

The rectangular area that represents the total area of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


PageSettings Property

[image]
ActiveReports 19 .NET Edition
PageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintPageEventArgs Class : PageSettings Property

Glossary Item Box

Gets the page settings for the current page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSettings As IPageSettings
C#
public IPageSettings PageSettings {get;}

Property Value

The page settings for the current page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventArgs Class
PrintPageEventArgs Members


PrintProgressEventArgs Class

[image]
ActiveReports 19 .NET Edition
PrintProgressEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

PrintProgressEventArgs

Object Model

PrintProgressEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PrintProgressEventArgs
   Inherits System.EventArgs
C#
public sealed class PrintProgressEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Printing.PrintProgressEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Members
GrapeCity.ActiveReports.Printing Namespace


PrintProgressEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
PrintProgressEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintProgressEventArgs Constructor | Initializes a new instance of the PrintProgressEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CurrentPage | Gets the current printing page number.
Top

See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PrintProgressEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
PrintProgressEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintProgressEventArgs Class : PrintProgressEventArgs Constructor

currentPage
The current ptinting page number.

Glossary Item Box

Initializes a new instance of the PrintProgressEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal currentPage As Integer _
)
C#
public PrintProgressEventArgs(
   int currentPage
)

Parameters

currentPage
The current ptinting page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


PrintProgressEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
PrintProgressEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | CurrentPage | Gets the current printing page number.
Top

See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


CurrentPage Property

[image]
ActiveReports 19 .NET Edition
CurrentPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > PrintProgressEventArgs Class : CurrentPage Property

Glossary Item Box

Gets the current printing page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Integer
C#
public int CurrentPage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


QueryPageSettingsEventArgs Class

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : QueryPageSettingsEventArgs Class

Glossary Item Box

Provides data for the Printer.QueryPageSettings event.

Object Model

QueryPageSettingsEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class QueryPageSettingsEventArgs
   Inherits PrintEventArgs
C#
public class QueryPageSettingsEventArgs : PrintEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Printing.PrintEventArgs
GrapeCity.ActiveReports.Printing.QueryPageSettingsEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventArgs Members
GrapeCity.ActiveReports.Printing Namespace


QueryPageSettingsEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : QueryPageSettingsEventArgs Class

Glossary Item Box

The following tables list the members exposed by QueryPageSettingsEventArgs.

Public Constructors

 | Name | Description
Public Constructor | QueryPageSettingsEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | PageSettings | Gets or sets the page settings for the page to be printed.
Top

See Also

Reference

QueryPageSettingsEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


QueryPageSettingsEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > QueryPageSettingsEventArgs Class : QueryPageSettingsEventArgs Constructor

Glossary Item Box

Overload List

Overload | Description
QueryPageSettingsEventArgs Constructor(IPageSettings) |
QueryPageSettingsEventArgs Constructor(IPageSettings,PrintAction) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventArgs Class
QueryPageSettingsEventArgs Members


QueryPageSettingsEventArgs Constructor(IPageSettings)

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Constructor(IPageSettings)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > QueryPageSettingsEventArgs Class > QueryPageSettingsEventArgs Constructor : QueryPageSettingsEventArgs Constructor(IPageSettings)

pageSettings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageSettings As IPageSettings _
)
C#
public QueryPageSettingsEventArgs(
   IPageSettings pageSettings
)

Parameters

pageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventArgs Class
QueryPageSettingsEventArgs Members
Overload List


QueryPageSettingsEventArgs Constructor(IPageSettings,PrintAction)

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Constructor(IPageSettings,PrintAction)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > QueryPageSettingsEventArgs Class > QueryPageSettingsEventArgs Constructor : QueryPageSettingsEventArgs Constructor(IPageSettings,PrintAction)

pageSettings
printAction

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageSettings As IPageSettings, _
   ByVal printAction As PrintAction _
)
C#
public QueryPageSettingsEventArgs(
   IPageSettings pageSettings,
   PrintAction printAction
)

Parameters

pageSettings
printAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventArgs Class
QueryPageSettingsEventArgs Members
Overload List


QueryPageSettingsEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : QueryPageSettingsEventArgs Class

Glossary Item Box

For a list of all members of this type, see QueryPageSettingsEventArgs members.

Public Properties

 | Name | Description
Public Property | PageSettings | Gets or sets the page settings for the page to be printed.
Top

See Also

Reference

QueryPageSettingsEventArgs Class
GrapeCity.ActiveReports.Printing Namespace


PageSettings Property

[image]
ActiveReports 19 .NET Edition
PageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > QueryPageSettingsEventArgs Class : PageSettings Property

Glossary Item Box

Gets or sets the page settings for the page to be printed.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As IPageSettings
C#
public IPageSettings PageSettings {get; set;}

Property Value

The page settings for the page to be printed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventArgs Class
QueryPageSettingsEventArgs Members


WatermarkOptions Class

[image]
ActiveReports 19 .NET Edition
WatermarkOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : WatermarkOptions Class

Glossary Item Box

Watermark options

Object Model

WatermarkOptions Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WatermarkOptions
C#
public sealed class WatermarkOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Printing.WatermarkOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Members
GrapeCity.ActiveReports.Printing Namespace


WatermarkOptions Class Members

[image]
ActiveReports 19 .NET Edition
WatermarkOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : WatermarkOptions Class

Glossary Item Box

The following tables list the members exposed by WatermarkOptions.

Public Constructors

 | Name | Description
Public Constructor | WatermarkOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Font
Public Property | Title | Watermark text
Top

See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Printing Namespace


WatermarkOptions Constructor

[image]
ActiveReports 19 .NET Edition
WatermarkOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : WatermarkOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WatermarkOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


WatermarkOptions Class Properties

[image]
ActiveReports 19 .NET Edition
WatermarkOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : WatermarkOptions Class

Glossary Item Box

For a list of all members of this type, see WatermarkOptions members.

Public Properties

 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Font
Public Property | Title | Watermark text
Top

See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Printing Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : Angle Property

Glossary Item Box

Test rotation angle, degrees, counter-clockwise

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : Color Property

Glossary Item Box

Color

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


DrawOver Property

[image]
ActiveReports 19 .NET Edition
DrawOver Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : DrawOver Property

Glossary Item Box

If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content

Syntax

Visual Basic (Declaration)
Public Property DrawOver As Boolean
C#
public bool DrawOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : Font Property

Glossary Item Box

Font

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > WatermarkOptions Class : Title Property

Glossary Item Box

Watermark text

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Duplex Enumeration

[image]
ActiveReports 19 .NET Edition
Duplex Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : Duplex Enumeration

Glossary Item Box

Specifies the printer's duplex setting. This is a cross-platform version of System.Drawing.Printing.Duplex.

Syntax

Visual Basic (Declaration)
Public Enum Duplex
   Inherits System.Enum
C#
public enum Duplex : System.Enum

Members

Member | Description
Default | The printer's default duplex setting.
Horizontal | Double-sided, horizontal printing.
Simplex | Single-sided printing.
Vertical | Double-sided, vertical printing.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.Duplex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PageOrder Enumeration

[image]
ActiveReports 19 .NET Edition
PageOrder Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PageOrder Enumeration

Glossary Item Box

Specifies page printing order

Syntax

Visual Basic (Declaration)
Public Enum PageOrder
   Inherits System.Enum
C#
public enum PageOrder : System.Enum

Members

Member | Description
Horizontal | Horizontal order.
HorizontalReversed | Reversed horizontal order.
Vertical | Vertical order.
VerticalReversed | Vertical reversed order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PageOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PageScaling Enumeration

[image]
ActiveReports 19 .NET Edition
PageScaling Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PageScaling Enumeration

Glossary Item Box

Specifies page scaling

Syntax

Visual Basic (Declaration)
Public Enum PageScaling
   Inherits System.Enum
C#
public enum PageScaling : System.Enum

Members

Member | Description
Booklet | Booklet mode.
FitToPrintableArea | Mode that scales small pages up and large pages down to fit the paper.
MultiplePages | Multiple pages per sheet mode.
None | No scaling mode.
ShrinkToPrintableArea | Mode that resizes only large pages to fit the paper and prints small pages as they are.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PageScaling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PaperKind Enumeration

[image]
ActiveReports 19 .NET Edition
PaperKind Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperKind Enumeration

Glossary Item Box

Specifies the standard paper sizes. This is a cross-platform version of System.Drawing.Printing.

Syntax

Visual Basic (Declaration)
Public Enum PaperKind
   Inherits System.Enum
C#
public enum PaperKind : System.Enum

Members

Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm). Requires Windows 98, Windows NT 4.0, or later.
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm). Requires Windows 98, Windows NT 4.0, or later.
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm). Requires Windows 98, Windows NT 4.0, or later.
A6Rotated | A6 rotated paper (148 mm by 105 mm). Requires Windows 98, Windows NT 4.0, or later.
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm). Requires Windows 98, Windows NT 4.0, or later.
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm). Requires Windows 98, Windows NT 4.0, or later.
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm). Requires Windows 98, Windows NT 4.0, or later.
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm). Requires Windows 98, Windows NT 4.0, or later.
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Custom | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm). Requires Windows 98, Windows NT 4.0, or later.
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm). Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope. Requires Windows 98, Windows NT 4.0, or later.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope. Requires Windows 98, Windows NT 4.0, or later.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm). Requires Windows 98, Windows NT 4.0, or later.
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.).
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm). Requires Windows 98, Windows NT 4.0, or later.
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm). Requires Windows 98, Windows NT 4.0, or later.
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm). Requires Windows 98, Windows NT 4.0, or later.
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm). Requires Windows 98, Windows NT 4.0, or later.
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.). Requires Windows 98, Windows NT 4.0, or later.
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PaperKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PaperSourceKind Enumeration

[image]
ActiveReports 19 .NET Edition
PaperSourceKind Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PaperSourceKind Enumeration

Glossary Item Box

Standard paper sources. This is a cross-platform version of System.Drawing.Printing.PaperSourceKind.

Syntax

Visual Basic (Declaration)
Public Enum PaperSourceKind
   Inherits System.Enum
C#
public enum PaperSourceKind : System.Enum

Members

Member | Description
AutomaticFeed |
Cassette |
Custom |
Envelope |
FormSource |
LargeCapacity |
LargeFormat |
Lower |
Manual |
ManualFeed |
Middle |
SmallFormat |
TractorFeed |
Upper |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PaperSourceKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PrintAction Enumeration

[image]
ActiveReports 19 .NET Edition
PrintAction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintAction Enumeration

Glossary Item Box

Specifies the type of print operation occurring.

Syntax

Visual Basic (Declaration)
Public Enum PrintAction
   Inherits System.Enum
C#
public enum PrintAction : System.Enum

Members

Member | Description
PrintToFile | The print operation is printing to a file.
PrintToPreview | The print operation is a print preview.
PrintToPrinter | The print operation is printing to a printer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PrintAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


PrintRange Enumeration

[image]
ActiveReports 19 .NET Edition
PrintRange Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintRange Enumeration

Glossary Item Box

Specifies the part of the document to print. This is a cross-platform version of System.Drawing.Printing.PrintRange.

Syntax

Visual Basic (Declaration)
Public Enum PrintRange
   Inherits System.Enum
C#
public enum PrintRange : System.Enum

Members

Member | Description
AllPages | All pages are printed.
CurrentPage | The currently displayed page is printed.
Selection | The selected pages are printed.
SomePages | The pages between FromPage and ToPage are printed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Printing.PrintRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Printing Namespace


IPageSettings Interface

[image]
ActiveReports 19 .NET Edition
IPageSettings Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPageSettings Interface

Glossary Item Box

Specifies settings that apply to a single, printed page. This interface is used instead of System.Drawing.Printing.PageSettings.

Syntax

Visual Basic (Declaration)
Public Interface IPageSettings
C#
public interface IPageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Members
GrapeCity.ActiveReports.Printing Namespace


IPageSettings Interface Members

[image]
ActiveReports 19 .NET Edition
IPageSettings Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPageSettings Interface

Glossary Item Box

The following tables list the members exposed by IPageSettings.

Public Properties

 | Name | Description
Property | Bounds | Gets the size of the page, taking into account the page orientation specified by the System.Drawing.Printing.PageSettings.Landscape property.
Property | Color | Gets or sets a value indicating whether the page should be printed in color.
Property | HardMarginX | Gets the x-coordinate, in hundredths of an inch, of the hard margin at the left of the page.
Property | HardMarginY | Gets the y-coordinate, in hundredths of an inch, of the hard margin at the top of the page.
Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Property | Margins | Gets or sets the margins for this page.
Property | PaperSize | Gets or sets the paper size for the page.
Property | PaperSource | Gets or sets the page's paper source; for example, the printer's upper tray.
Property | PrintableArea | Gets the bounds of the printable area of the page for the printer.
Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Top

See Also

Reference

IPageSettings Interface
GrapeCity.ActiveReports.Printing Namespace


IPageSettings Interface Properties

[image]
ActiveReports 19 .NET Edition
IPageSettings Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPageSettings Interface

Glossary Item Box

For a list of all members of this type, see IPageSettings members.

Public Properties

 | Name | Description
Property | Bounds | Gets the size of the page, taking into account the page orientation specified by the System.Drawing.Printing.PageSettings.Landscape property.
Property | Color | Gets or sets a value indicating whether the page should be printed in color.
Property | HardMarginX | Gets the x-coordinate, in hundredths of an inch, of the hard margin at the left of the page.
Property | HardMarginY | Gets the y-coordinate, in hundredths of an inch, of the hard margin at the top of the page.
Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Property | Margins | Gets or sets the margins for this page.
Property | PaperSize | Gets or sets the paper size for the page.
Property | PaperSource | Gets or sets the page's paper source; for example, the printer's upper tray.
Property | PrintableArea | Gets the bounds of the printable area of the page for the printer.
Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Top

See Also

Reference

IPageSettings Interface
GrapeCity.ActiveReports.Printing Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : Bounds Property

Glossary Item Box

Gets the size of the page, taking into account the page orientation specified by the System.Drawing.Printing.PageSettings.Landscape property.

Syntax

Visual Basic (Declaration)
ReadOnly Property Bounds As Rectangle
C#
Rectangle Bounds {get;}

Property Value

A System.Drawing.Rectangle that represents the length and width, in hundredths of an inch, of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : Color Property

Glossary Item Box

Gets or sets a value indicating whether the page should be printed in color.

Syntax

Visual Basic (Declaration)
Property Color As Boolean
C#
bool Color {get; set;}

Property Value

true if the page should be printed in color; otherwise, false. The default is determined by the printer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


HardMarginX Property

[image]
ActiveReports 19 .NET Edition
HardMarginX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : HardMarginX Property

Glossary Item Box

Gets the x-coordinate, in hundredths of an inch, of the hard margin at the left of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property HardMarginX As Single
C#
float HardMarginX {get;}

Property Value

The x-coordinate, in hundredths of an inch, of the left-hand hard margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


HardMarginY Property

[image]
ActiveReports 19 .NET Edition
HardMarginY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : HardMarginY Property

Glossary Item Box

Gets the y-coordinate, in hundredths of an inch, of the hard margin at the top of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property HardMarginY As Single
C#
float HardMarginY {get;}

Property Value

The y-coordinate, in hundredths of an inch, of the hard margin at the top of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


Landscape Property

[image]
ActiveReports 19 .NET Edition
Landscape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : Landscape Property

Glossary Item Box

Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Syntax

Visual Basic (Declaration)
Property Landscape As Boolean
C#
bool Landscape {get; set;}

Property Value

true if the page should be printed in landscape orientation; otherwise, false. The default is determined by the printer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


Margins Property

[image]
ActiveReports 19 .NET Edition
Margins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : Margins Property

Glossary Item Box

Gets or sets the margins for this page.

Syntax

Visual Basic (Declaration)
Property Margins As Margins
C#
Margins Margins {get; set;}

Property Value

A Margins that represents the margins, in hundredths of an inch, for the page. The default is 1-inch margins on all sides.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


PaperSize Property

[image]
ActiveReports 19 .NET Edition
PaperSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : PaperSize Property

Glossary Item Box

Gets or sets the paper size for the page.

Syntax

Visual Basic (Declaration)
Property PaperSize As PaperSize
C#
PaperSize PaperSize {get; set;}

Property Value

A PaperSize that represents the size of the paper. The default is the printer's default paper size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


PaperSource Property

[image]
ActiveReports 19 .NET Edition
PaperSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : PaperSource Property

Glossary Item Box

Gets or sets the page's paper source; for example, the printer's upper tray.

Syntax

Visual Basic (Declaration)
Property PaperSource As PaperSource
C#
PaperSource PaperSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


PrintableArea Property

[image]
ActiveReports 19 .NET Edition
PrintableArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : PrintableArea Property

Glossary Item Box

Gets the bounds of the printable area of the page for the printer.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintableArea As RectangleF
C#
RectangleF PrintableArea {get;}

Property Value

A System.Drawing.RectangleF representing the length and width, in hundredths of an inch, of the area the printer is capable of printing in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


PrinterSettings Property

[image]
ActiveReports 19 .NET Edition
PrinterSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPageSettings Interface : PrinterSettings Property

Glossary Item Box

Gets or sets the printer settings associated with the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrinterSettings As IPrinterSettings
C#
IPrinterSettings PrinterSettings {get;}

Property Value

A IPrinterSettings that represents the printer settings associated with the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSettings Interface
IPageSettings Members


IPrinterSettings Interface

[image]
ActiveReports 19 .NET Edition
IPrinterSettings Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPrinterSettings Interface

Glossary Item Box

Specifies information about how a document is printed, including the printer that prints it. This interface is used instead of System.Drawing.Printing.PrinterSettings.

Syntax

Visual Basic (Declaration)
Public Interface IPrinterSettings
C#
public interface IPrinterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Members
GrapeCity.ActiveReports.Printing Namespace


IPrinterSettings Interface Members

[image]
ActiveReports 19 .NET Edition
IPrinterSettings Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPrinterSettings Interface

Glossary Item Box

The following tables list the members exposed by IPrinterSettings.

Public Properties

 | Name | Description
Property | CanDuplex | Gets a value indicating whether the printer supports double-sided printing.
Property | Collate | Gets or sets a value indicating whether the printed document is collated.
Property | Copies | Gets or sets the number of copies of the document to print.
Property | DefaultPageSettings | Gets the default page settings for this printer.
Property | Duplex | Gets or sets the printer setting for double-sided printing.
Property | FromPage | Gets or sets the page number of the first page to print.
Property | IsDefaultPrinter | Gets a value indicating whether the PrinterName property designates the default printer, except when the user explicitly sets PrinterName.
Property | IsPlotter | Gets a value indicating whether the printer is a plotter.
Property | IsValid | Gets a value indicating whether the PrinterName property designates a valid printer.
Property | LandscapeAngle | Gets the angle, in degrees, that the portrait orientation is rotated to produce the landscape orientation.
Property | MaximumCopies | Gets the maximum number of copies that the printer enables the user to print at a time.
Property | MaximumPage | Gets or sets the maximum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.
Property | MinimumPage | Gets or sets the minimum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.
Property | PaperSizes | Gets the paper sizes that are supported by this printer.
Property | PaperSources | Gets the paper source trays that are available on the printer.
Property | PrinterName | Gets or sets the name of the printer to use.
Property | PrintFileName | Gets or sets the file name, when printing to a file.
Property | PrintRange | Gets or sets the page numbers that the user has specified to be printed.
Property | PrintToFile | Gets or sets a value indicating whether the printing output is sent to a file instead of a port.
Property | SupportsColor | Gets a value indicating whether this printer supports color printing.
Property | ToPage | Gets or sets the number of the last page to print.
Top

See Also

Reference

IPrinterSettings Interface
GrapeCity.ActiveReports.Printing Namespace


IPrinterSettings Interface Properties

[image]
ActiveReports 19 .NET Edition
IPrinterSettings Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : IPrinterSettings Interface

Glossary Item Box

For a list of all members of this type, see IPrinterSettings members.

Public Properties

 | Name | Description
Property | CanDuplex | Gets a value indicating whether the printer supports double-sided printing.
Property | Collate | Gets or sets a value indicating whether the printed document is collated.
Property | Copies | Gets or sets the number of copies of the document to print.
Property | DefaultPageSettings | Gets the default page settings for this printer.
Property | Duplex | Gets or sets the printer setting for double-sided printing.
Property | FromPage | Gets or sets the page number of the first page to print.
Property | IsDefaultPrinter | Gets a value indicating whether the PrinterName property designates the default printer, except when the user explicitly sets PrinterName.
Property | IsPlotter | Gets a value indicating whether the printer is a plotter.
Property | IsValid | Gets a value indicating whether the PrinterName property designates a valid printer.
Property | LandscapeAngle | Gets the angle, in degrees, that the portrait orientation is rotated to produce the landscape orientation.
Property | MaximumCopies | Gets the maximum number of copies that the printer enables the user to print at a time.
Property | MaximumPage | Gets or sets the maximum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.
Property | MinimumPage | Gets or sets the minimum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.
Property | PaperSizes | Gets the paper sizes that are supported by this printer.
Property | PaperSources | Gets the paper source trays that are available on the printer.
Property | PrinterName | Gets or sets the name of the printer to use.
Property | PrintFileName | Gets or sets the file name, when printing to a file.
Property | PrintRange | Gets or sets the page numbers that the user has specified to be printed.
Property | PrintToFile | Gets or sets a value indicating whether the printing output is sent to a file instead of a port.
Property | SupportsColor | Gets a value indicating whether this printer supports color printing.
Property | ToPage | Gets or sets the number of the last page to print.
Top

See Also

Reference

IPrinterSettings Interface
GrapeCity.ActiveReports.Printing Namespace


CanDuplex Property

[image]
ActiveReports 19 .NET Edition
CanDuplex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : CanDuplex Property

Glossary Item Box

Gets a value indicating whether the printer supports double-sided printing.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanDuplex As Boolean
C#
bool CanDuplex {get;}

Property Value

true if the printer supports double-sided printing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


Collate Property

[image]
ActiveReports 19 .NET Edition
Collate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : Collate Property

Glossary Item Box

Gets or sets a value indicating whether the printed document is collated.

Syntax

Visual Basic (Declaration)
Property Collate As Boolean
C#
bool Collate {get; set;}

Property Value

true if the printed document is collated; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


Copies Property

[image]
ActiveReports 19 .NET Edition
Copies Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : Copies Property

Glossary Item Box

Gets or sets the number of copies of the document to print.

Syntax

Visual Basic (Declaration)
Property Copies As Short
C#
short Copies {get; set;}

Property Value

The number of copies to print. The default is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


DefaultPageSettings Property

[image]
ActiveReports 19 .NET Edition
DefaultPageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : DefaultPageSettings Property

Glossary Item Box

Gets the default page settings for this printer.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultPageSettings As IPageSettings
C#
IPageSettings DefaultPageSettings {get;}

Property Value

A IPageSettings that represents the default page settings for this printer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


Duplex Property

[image]
ActiveReports 19 .NET Edition
Duplex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : Duplex Property

Glossary Item Box

Gets or sets the printer setting for double-sided printing.

Syntax

Visual Basic (Declaration)
Property Duplex As Duplex
C#
Duplex Duplex {get; set;}

Property Value

One of the Duplex values. The default is determined by the printer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


FromPage Property

[image]
ActiveReports 19 .NET Edition
FromPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : FromPage Property

Glossary Item Box

Gets or sets the page number of the first page to print.

Syntax

Visual Basic (Declaration)
Property FromPage As Integer
C#
int FromPage {get; set;}

Property Value

The page number of the first page to print.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


IsDefaultPrinter Property

[image]
ActiveReports 19 .NET Edition
IsDefaultPrinter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : IsDefaultPrinter Property

Glossary Item Box

Gets a value indicating whether the PrinterName property designates the default printer, except when the user explicitly sets PrinterName.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDefaultPrinter As Boolean
C#
bool IsDefaultPrinter {get;}

Property Value

true if PrinterName designates the default printer; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


IsPlotter Property

[image]
ActiveReports 19 .NET Edition
IsPlotter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : IsPlotter Property

Glossary Item Box

Gets a value indicating whether the printer is a plotter.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPlotter As Boolean
C#
bool IsPlotter {get;}

Property Value

true if the printer is a plotter; false if the printer is a raster.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


IsValid Property

[image]
ActiveReports 19 .NET Edition
IsValid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : IsValid Property

Glossary Item Box

Gets a value indicating whether the PrinterName property designates a valid printer.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsValid As Boolean
C#
bool IsValid {get;}

Property Value

true if the PrinterName property designates a valid printer; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


LandscapeAngle Property

[image]
ActiveReports 19 .NET Edition
LandscapeAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : LandscapeAngle Property

Glossary Item Box

Gets the angle, in degrees, that the portrait orientation is rotated to produce the landscape orientation.

Syntax

Visual Basic (Declaration)
ReadOnly Property LandscapeAngle As Integer
C#
int LandscapeAngle {get;}

Property Value

The angle, in degrees, that the portrait orientation is rotated to produce the landscape orientation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


MaximumCopies Property

[image]
ActiveReports 19 .NET Edition
MaximumCopies Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : MaximumCopies Property

Glossary Item Box

Gets the maximum number of copies that the printer enables the user to print at a time.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumCopies As Integer
C#
int MaximumCopies {get;}

Property Value

The maximum number of copies that the printer enables the user to print at a time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


MaximumPage Property

[image]
ActiveReports 19 .NET Edition
MaximumPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : MaximumPage Property

Glossary Item Box

Gets or sets the maximum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.

Syntax

Visual Basic (Declaration)
Property MaximumPage As Integer
C#
int MaximumPage {get; set;}

Property Value

The maximum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


MinimumPage Property

[image]
ActiveReports 19 .NET Edition
MinimumPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : MinimumPage Property

Glossary Item Box

Gets or sets the minimum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.

Syntax

Visual Basic (Declaration)
Property MinimumPage As Integer
C#
int MinimumPage {get; set;}

Property Value

The minimum FromPage or ToPage that can be selected in a System.Windows.Forms.PrintDialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PaperSizes Property

[image]
ActiveReports 19 .NET Edition
PaperSizes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PaperSizes Property

Glossary Item Box

Gets the paper sizes that are supported by this printer.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaperSizes As PaperSize()
C#
PaperSize[] PaperSizes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PaperSources Property

[image]
ActiveReports 19 .NET Edition
PaperSources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PaperSources Property

Glossary Item Box

Gets the paper source trays that are available on the printer.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaperSources As PaperSourceCollection
C#
PaperSourceCollection PaperSources {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PrinterName Property

[image]
ActiveReports 19 .NET Edition
PrinterName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PrinterName Property

Glossary Item Box

Gets or sets the name of the printer to use.

Syntax

Visual Basic (Declaration)
Property PrinterName As String
C#
string PrinterName {get; set;}

Property Value

The name of the printer to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PrintFileName Property

[image]
ActiveReports 19 .NET Edition
PrintFileName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PrintFileName Property

Glossary Item Box

Gets or sets the file name, when printing to a file.

Syntax

Visual Basic (Declaration)
Property PrintFileName As String
C#
string PrintFileName {get; set;}

Property Value

The file name, when printing to a file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PrintRange Property

[image]
ActiveReports 19 .NET Edition
PrintRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PrintRange Property

Glossary Item Box

Gets or sets the page numbers that the user has specified to be printed.

Syntax

Visual Basic (Declaration)
Property PrintRange As PrintRange
C#
PrintRange PrintRange {get; set;}

Property Value

One of the PrintRange values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PrintToFile Property

[image]
ActiveReports 19 .NET Edition
PrintToFile Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : PrintToFile Property

Glossary Item Box

Gets or sets a value indicating whether the printing output is sent to a file instead of a port.

Syntax

Visual Basic (Declaration)
Property PrintToFile As Boolean
C#
bool PrintToFile {get; set;}

Property Value

true if the printing output is sent to a file; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


SupportsColor Property

[image]
ActiveReports 19 .NET Edition
SupportsColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : SupportsColor Property

Glossary Item Box

Gets a value indicating whether this printer supports color printing.

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsColor As Boolean
C#
bool SupportsColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


ToPage Property

[image]
ActiveReports 19 .NET Edition
ToPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace > IPrinterSettings Interface : ToPage Property

Glossary Item Box

Gets or sets the number of the last page to print.

Syntax

Visual Basic (Declaration)
Property ToPage As Integer
C#
int ToPage {get; set;}

Property Value

The number of the last page to print.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrinterSettings Interface
IPrinterSettings Members


PrintAbortedEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PrintAbortedEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintAbortedEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintAbortedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void PrintAbortedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintAbortedEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


PrintEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PrintEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintEventHandler Delegate

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

Glossary Item Box

Represents the method that will handle the Printer.BeginPrint or Printer.EndPrint event of a Printer.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
C#
public delegate void PrintEventHandler(
   object sender,
   PrintEventArgs e
)

Parameters

sender
The source of the event.
e
A PrintEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


PrintingThreadErrorEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PrintingThreadErrorEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintingThreadErrorEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintingThreadErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintingThreadErrorEventArgs _
)
C#
public delegate void PrintingThreadErrorEventHandler(
   object sender,
   PrintingThreadErrorEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


PrintPageEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PrintPageEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintPageEventHandler Delegate

sender
The source of the event.
e
A PrintPageEventArgs that contains the event data.

Glossary Item Box

Represents the method that will handle the PrintPage event of a Printer.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintPageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintPageEventArgs _
)
C#
public delegate void PrintPageEventHandler(
   object sender,
   PrintPageEventArgs e
)

Parameters

sender
The source of the event.
e
A PrintPageEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPageEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


PrintProgressEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PrintProgressEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : PrintProgressEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintProgressEventArgs _
)
C#
public delegate void PrintProgressEventHandler(
   object sender,
   PrintProgressEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


QueryPageSettingsEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
QueryPageSettingsEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Printing Namespace : QueryPageSettingsEventHandler Delegate

sender
The source of the event.
e
A QueryPageSettingsEventArgs that contains the event data.

Glossary Item Box

Represents the method that handles the Printer.QueryPageSettings event of a Printer.

Syntax

Visual Basic (Declaration)
Public Delegate Sub QueryPageSettingsEventHandler( _
   ByVal sender As Object, _
   ByVal e As QueryPageSettingsEventArgs _
)
C#
public delegate void QueryPageSettingsEventHandler(
   object sender,
   QueryPageSettingsEventArgs e
)

Parameters

sender
The source of the event.
e
A QueryPageSettingsEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryPageSettingsEventHandler Members
GrapeCity.ActiveReports.Printing Namespace


EraConfigurationException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
EraConfigurationException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace : EraConfigurationException.ErrorCodes Enumeration

Glossary Item Box

Error codes.

Syntax

Visual Basic (Declaration)
Public Enum EraConfigurationException.ErrorCodes
   Inherits System.Enum
C#
public enum EraConfigurationException.ErrorCodes : System.Enum

Members

Member | Description
DuplicateStartDates |
EmptyShortcutKey |
InvalidStartDateFormat |
ValueNotMatchPattern |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.EraConfigurationException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering Namespace


FileStreamProvider Class

[image]
ActiveReports 19 .NET Edition
FileStreamProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

Glossary Item Box

Stream provider for rendering report extension outputs to a file.

Object Model

FileStreamProvider Class

Syntax

Visual Basic (Declaration)
Public Class FileStreamProvider
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
C#
public class FileStreamProvider : GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Members
GrapeCity.ActiveReports.Rendering.IO Namespace


FileStreamProvider Class Members

[image]
ActiveReports 19 .NET Edition
FileStreamProvider Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

Glossary Item Box

The following tables list the members exposed by FileStreamProvider.

Public Constructors

 | Name | Description
Public Constructor | FileStreamProvider Constructor | Initializes a new instance of the FileStreamProvider class.
Top

Public Properties

 | Name | Description
Public Property | OverwriteOutputFile | Specifies that the FileStreamProvider should overwrite a file if exists; otherwise, a new file with unique name should be created.
Top

Public Methods

 | Name | Description
Public Method | CleanUpOnError | Overridden. Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top

See Also

Reference

FileStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


FileStreamProvider Constructor

[image]
ActiveReports 19 .NET Edition
FileStreamProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : FileStreamProvider Constructor

baseOutputDirectory
a System.IO.DirectoryInfo to save the file streams to.
outputFileNamePrefix
a string value indicating the name to place at the beginning of the files created.

Glossary Item Box

Initializes a new instance of the FileStreamProvider class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal baseOutputDirectory As DirectoryInfo, _
   ByVal outputFileNamePrefix As String _
)
C#
public FileStreamProvider(
   DirectoryInfo baseOutputDirectory,
   string outputFileNamePrefix
)

Parameters

baseOutputDirectory
a System.IO.DirectoryInfo to save the file streams to.
outputFileNamePrefix
a string value indicating the name to place at the beginning of the files created.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the base output directory argument is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


FileStreamProvider Class Methods

[image]
ActiveReports 19 .NET Edition
FileStreamProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

Glossary Item Box

For a list of all members of this type, see FileStreamProvider members.

Public Methods

 | Name | Description
Public Method | CleanUpOnError | Overridden. Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top

See Also

Reference

FileStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


CleanUpOnError Method

[image]
ActiveReports 19 .NET Edition
CleanUpOnError Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CleanUpOnError Method

Glossary Item Box

Performs the required clean up in case of a rendering error.

Syntax

Visual Basic (Declaration)
Public Overrides Sub CleanUpOnError()
C#
public override void CleanUpOnError()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


CreatePrimaryStream Method

[image]
ActiveReports 19 .NET Edition
CreatePrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CreatePrimaryStream Method

mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Glossary Item Box

Creates the primary working stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreatePrimaryStream( _
   ByVal mimeType As String, _
   ByVal fileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreatePrimaryStream(
   string mimeType,
   string fileExtension
)

Parameters

mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the primary stream.

Exceptions

Exception | Description
System.InvalidOperationException | Thrown if the primary stream has already been created.
System.InvalidOperationException | Thrown if the file extension is not specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


CreateSecondaryStream Method

[image]
ActiveReports 19 .NET Edition
CreateSecondaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CreateSecondaryStream Method

relativeName
a string value in the name for the secondary stream. The relative name is appended to the file name prefix
mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Glossary Item Box

Creates a secondary stream in the stream provider.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateSecondaryStream( _
   ByVal relativeName As String, _
   ByVal mimeType As String, _
   ByVal fileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreateSecondaryStream(
   string relativeName,
   string mimeType,
   string fileExtension
)

Parameters

relativeName
a string value in the name for the secondary stream. The relative name is appended to the file name prefix
mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the secondary stream.

Exceptions

Exception | Description
System.InvalidOperationException | Thrown if the file extension is not specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


GetPrimaryStream Method

[image]
ActiveReports 19 .NET Edition
GetPrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : GetPrimaryStream Method

Glossary Item Box

Gets the primary stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPrimaryStream() As StreamInfo
C#
public override StreamInfo GetPrimaryStream()

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the primary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


GetSecondaryStreams Method

[image]
ActiveReports 19 .NET Edition
GetSecondaryStreams Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : GetSecondaryStreams Method

Glossary Item Box

Gets the array of secondary streams

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSecondaryStreams() As StreamInfo()
C#
public override StreamInfo[] GetSecondaryStreams()

Return Value

an array of GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo containing the secondary streams.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


FileStreamProvider Class Properties

[image]
ActiveReports 19 .NET Edition
FileStreamProvider Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

Glossary Item Box

For a list of all members of this type, see FileStreamProvider members.

Public Properties

 | Name | Description
Public Property | OverwriteOutputFile | Specifies that the FileStreamProvider should overwrite a file if exists; otherwise, a new file with unique name should be created.
Top

See Also

Reference

FileStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


OverwriteOutputFile Property

[image]
ActiveReports 19 .NET Edition
OverwriteOutputFile Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : OverwriteOutputFile Property

Glossary Item Box

Specifies that the FileStreamProvider should overwrite a file if exists; otherwise, a new file with unique name should be created.

Syntax

Visual Basic (Declaration)
Public Property OverwriteOutputFile As Boolean
C#
public bool OverwriteOutputFile {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


MemoryStreamProvider Class

[image]
ActiveReports 19 .NET Edition
MemoryStreamProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class

Glossary Item Box

The provider for rendering report rendering extension outputs to a stream.

Object Model

MemoryStreamProvider Class

Syntax

Visual Basic (Declaration)
Public Class MemoryStreamProvider
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
C#
public class MemoryStreamProvider : GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Members
GrapeCity.ActiveReports.Rendering.IO Namespace


MemoryStreamProvider Class Members

[image]
ActiveReports 19 .NET Edition
MemoryStreamProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class

Glossary Item Box

The following tables list the members exposed by MemoryStreamProvider.

Public Constructors

 | Name | Description
Public Constructor | MemoryStreamProvider Constructor | Initializes a new instance of the MemoryStreamProvider class.
Top

Public Methods

 | Name | Description
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top

See Also

Reference

MemoryStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


MemoryStreamProvider Constructor

[image]
ActiveReports 19 .NET Edition
MemoryStreamProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : MemoryStreamProvider Constructor

Glossary Item Box

Initializes a new instance of the MemoryStreamProvider class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MemoryStreamProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


MemoryStreamProvider Class Methods

[image]
ActiveReports 19 .NET Edition
MemoryStreamProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class

Glossary Item Box

For a list of all members of this type, see MemoryStreamProvider members.

Public Methods

 | Name | Description
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top

See Also

Reference

MemoryStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


CreatePrimaryStream Method

[image]
ActiveReports 19 .NET Edition
CreatePrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : CreatePrimaryStream Method

mimeType
a string value indicating the mime type for the primary stream.
suggestedFileExtension
a string value indicating the file extension to use for the primary stream.

Glossary Item Box

Creates the primary working stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreatePrimaryStream( _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreatePrimaryStream(
   string mimeType,
   string suggestedFileExtension
)

Parameters

mimeType
a string value indicating the mime type for the primary stream.
suggestedFileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

StreamInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


CreateSecondaryStream Method

[image]
ActiveReports 19 .NET Edition
CreateSecondaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : CreateSecondaryStream Method

relativeName
A string value in the name for the secondary stream. The relative name is appended to the MemoryStreamProvider name prefix
mimeType
A string value indicating the mime type for the primary stream.
suggestedFileExtension
A string value indicating the file extension to use for the secondary stream.

Glossary Item Box

Creates a secondary stream in the stream provider.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateSecondaryStream( _
   ByVal relativeName As String, _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreateSecondaryStream(
   string relativeName,
   string mimeType,
   string suggestedFileExtension
)

Parameters

relativeName
A string value in the name for the secondary stream. The relative name is appended to the MemoryStreamProvider name prefix
mimeType
A string value indicating the mime type for the primary stream.
suggestedFileExtension
A string value indicating the file extension to use for the secondary stream.

Return Value

StreamInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


GetPrimaryStream Method

[image]
ActiveReports 19 .NET Edition
GetPrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : GetPrimaryStream Method

Glossary Item Box

Gets the primary stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPrimaryStream() As StreamInfo
C#
public override StreamInfo GetPrimaryStream()

Return Value

StreamInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


GetSecondaryStreams Method

[image]
ActiveReports 19 .NET Edition
GetSecondaryStreams Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : GetSecondaryStreams Method

Glossary Item Box

Gets the array of secondary streams

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSecondaryStreams() As StreamInfo()
C#
public override StreamInfo[] GetSecondaryStreams()

Return Value

StreamInfo[].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


MhtStreamProvider Class

[image]
ActiveReports 19 .NET Edition
MhtStreamProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace : MhtStreamProvider Class

Glossary Item Box

This class severs as the stream provider when rendering to MHT. The class holds all the information for the different parts and writes it out to the stream provider used by the user.

Object Model

MhtStreamProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MhtStreamProvider
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
C#
public sealed class MhtStreamProvider : GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.Mht.MhtStreamProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Members
GrapeCity.ActiveReports.Rendering.IO.Mht Namespace


MhtStreamProvider Class Members

[image]
ActiveReports 19 .NET Edition
MhtStreamProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace : MhtStreamProvider Class

Glossary Item Box

The following tables list the members exposed by MhtStreamProvider.

Public Constructors

 | Name | Description
Public Constructor | MhtStreamProvider Constructor | Creates a new instance of the MhtStreamProvider
Top

Public Methods

 | Name | Description
Public Method | CreatePrimaryStream | Overridden. Creates the primary stream for the stream provider. This is the main working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream to add to the stream provider's secondary stream array.
Public Method | Finish | Combines all the mime parts of the primary and secondary streams into the GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider provided by the customer.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams.
Public Method | WriteTo |
Top

See Also

Reference

MhtStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO.Mht Namespace


MhtStreamProvider Constructor

[image]
ActiveReports 19 .NET Edition
MhtStreamProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : MhtStreamProvider Constructor

outputFileNamePrefix
the prefix to use for the output file names.

Glossary Item Box

Creates a new instance of the MhtStreamProvider

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal outputFileNamePrefix As String _
)
C#
public MhtStreamProvider(
   string outputFileNamePrefix
)

Parameters

outputFileNamePrefix
the prefix to use for the output file names.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


MhtStreamProvider Class Methods

[image]
ActiveReports 19 .NET Edition
MhtStreamProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace : MhtStreamProvider Class

Glossary Item Box

For a list of all members of this type, see MhtStreamProvider members.

Public Methods

 | Name | Description
Public Method | CreatePrimaryStream | Overridden. Creates the primary stream for the stream provider. This is the main working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream to add to the stream provider's secondary stream array.
Public Method | Finish | Combines all the mime parts of the primary and secondary streams into the GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider provided by the customer.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams.
Public Method | WriteTo |
Top

See Also

Reference

MhtStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO.Mht Namespace


CreatePrimaryStream Method

[image]
ActiveReports 19 .NET Edition
CreatePrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : CreatePrimaryStream Method

mimeType
A string value indicating the mime type ('image/png', 'text/html', etc).
suggestedFileExtension
A string value with the suggested file extension to appended to the end of the file name.

Glossary Item Box

Creates the primary stream for the stream provider. This is the main working stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function CreatePrimaryStream( _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreatePrimaryStream(
   string mimeType,
   string suggestedFileExtension
)

Parameters

mimeType
A string value indicating the mime type ('image/png', 'text/html', etc).
suggestedFileExtension
A string value with the suggested file extension to appended to the end of the file name.

Return Value

A GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the created primary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


CreateSecondaryStream Method

[image]
ActiveReports 19 .NET Edition
CreateSecondaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : CreateSecondaryStream Method

relativeName
A string value indicating the name to give the secondary stream. The outputFileNamePrefix will be added to the beginning of this name.
mimeType
A string value indicating the mime type ('image/png', 'text/html', etc).
suggestedFileExtension
A string value with the suggested file extension to appended to the end of the file name.

Glossary Item Box

Creates a secondary stream to add to the stream provider's secondary stream array.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function CreateSecondaryStream( _
   ByVal relativeName As String, _
   ByVal mimeType As String, _
   ByVal suggestedFileExtension As String _
) As StreamInfo
C#
public override StreamInfo CreateSecondaryStream(
   string relativeName,
   string mimeType,
   string suggestedFileExtension
)

Parameters

relativeName
A string value indicating the name to give the secondary stream. The outputFileNamePrefix will be added to the beginning of this name.
mimeType
A string value indicating the mime type ('image/png', 'text/html', etc).
suggestedFileExtension
A string value with the suggested file extension to appended to the end of the file name.

Return Value

A GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the created primary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


Finish Method

[image]
ActiveReports 19 .NET Edition
Finish Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : Finish Method

streamProvider
The customers GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to create the mht output file in.
mimeType
Mime type to set for the stream.
fileExtension
Suggested file extension to set for the stream.

Glossary Item Box

Combines all the mime parts of the primary and secondary streams into the GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider provided by the customer.

Syntax

Visual Basic (Declaration)
Public Sub Finish( _
   ByVal streamProvider As StreamProvider, _
   Optional ByVal mimeType As String, _
   Optional ByVal fileExtension As String _
)
C#
public void Finish(
   StreamProvider streamProvider,
   string mimeType,
   string fileExtension
)

Parameters

streamProvider
The customers GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider to create the mht output file in.
mimeType
Mime type to set for the stream.
fileExtension
Suggested file extension to set for the stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


GetPrimaryStream Method

[image]
ActiveReports 19 .NET Edition
GetPrimaryStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : GetPrimaryStream Method

Glossary Item Box

Gets the primary stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetPrimaryStream() As StreamInfo
C#
public override StreamInfo GetPrimaryStream()

Return Value

A GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo representing the primary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


GetSecondaryStreams Method

[image]
ActiveReports 19 .NET Edition
GetSecondaryStreams Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : GetSecondaryStreams Method

Glossary Item Box

Gets the array of secondary streams.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetSecondaryStreams() As StreamInfo()
C#
public override StreamInfo[] GetSecondaryStreams()

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo array containing all the secondary streams.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


WriteTo Method

[image]
ActiveReports 19 .NET Edition
WriteTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering.IO.Mht Namespace > MhtStreamProvider Class : WriteTo Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function WriteTo( _
   ByVal stream As Stream _
) As StreamWriter
C#
public StreamWriter WriteTo(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MhtStreamProvider Class
MhtStreamProvider Members


DataSourceTypesConfiguration Class

[image]
ActiveReports 19 .NET Edition
DataSourceTypesConfiguration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : DataSourceTypesConfiguration Class

Glossary Item Box

Represents configuration settings for data source types.

Object Model

DataSourceTypesConfiguration Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceTypesConfiguration
C#
public class DataSourceTypesConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.DataSourceTypesConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTypesConfiguration Members
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


DataSourceTypesConfiguration Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceTypesConfiguration Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : DataSourceTypesConfiguration Class

Glossary Item Box

The following tables list the members exposed by DataSourceTypesConfiguration.

Public Constructors

 | Name | Description
Public Constructor | DataSourceTypesConfiguration Constructor | Creates a new instance of DataSourceTypesConfiguration
Top

Public Properties

 | Name | Description
Public Property | DataSourceTypes | Gets or sets the sequence of data source types.
Top

See Also

Reference

DataSourceTypesConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


DataSourceTypesConfiguration Constructor

[image]
ActiveReports 19 .NET Edition
DataSourceTypesConfiguration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > DataSourceTypesConfiguration Class : DataSourceTypesConfiguration Constructor

Glossary Item Box

Creates a new instance of DataSourceTypesConfiguration

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSourceTypesConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTypesConfiguration Class
DataSourceTypesConfiguration Members


DataSourceTypesConfiguration Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourceTypesConfiguration Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : DataSourceTypesConfiguration Class

Glossary Item Box

For a list of all members of this type, see DataSourceTypesConfiguration members.

Public Properties

 | Name | Description
Public Property | DataSourceTypes | Gets or sets the sequence of data source types.
Top

See Also

Reference

DataSourceTypesConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


DataSourceTypes Property

[image]
ActiveReports 19 .NET Edition
DataSourceTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > DataSourceTypesConfiguration Class : DataSourceTypes Property

Glossary Item Box

Gets or sets the sequence of data source types.

Syntax

Visual Basic (Declaration)
Public Property DataSourceTypes As IEnumerable(Of DataSourceType)
C#
public IEnumerable<DataSourceType> DataSourceTypes {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTypesConfiguration Class
DataSourceTypesConfiguration Members


MapTileServerConfiguration Class

[image]
ActiveReports 19 .NET Edition
MapTileServerConfiguration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

Represents configuration settings for communication with map tile server.

Object Model

MapTileServerConfiguration Class

Syntax

Visual Basic (Declaration)
Public Class MapTileServerConfiguration
C#
public class MapTileServerConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.MapTileServerConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Members
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Class Members

[image]
ActiveReports 19 .NET Edition
MapTileServerConfiguration Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

The following tables list the members exposed by MapTileServerConfiguration.

Public Constructors

 | Name | Description
Public Constructor | MapTileServerConfiguration Constructor | Initializes a new instance of the MapTileServerConfiguration class.
Top

Public Properties

 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top

See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Constructor

[image]
ActiveReports 19 .NET Edition
MapTileServerConfiguration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MapTileServerConfiguration Constructor

Glossary Item Box

Initializes a new instance of the MapTileServerConfiguration class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapTileServerConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MapTileServerConfiguration Class Properties

[image]
ActiveReports 19 .NET Edition
MapTileServerConfiguration Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

For a list of all members of this type, see MapTileServerConfiguration members.

Public Properties

 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top

See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


AppID Property

[image]
ActiveReports 19 .NET Edition
AppID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : AppID Property

Glossary Item Box

Gets or sets bing application id.

Syntax

Visual Basic (Declaration)
Public Property AppID As String
C#
public string AppID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MaxConnections Property

[image]
ActiveReports 19 .NET Edition
MaxConnections Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MaxConnections Property

Glossary Item Box

Gets or sets the number of maximum connections.

Syntax

Visual Basic (Declaration)
Public Property MaxConnections As Integer
C#
public int MaxConnections {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


Timeout Property

[image]
ActiveReports 19 .NET Edition
Timeout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : Timeout Property

Glossary Item Box

Gets or sets the timeout in seconds.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


ReportTypesConfiguration Class

[image]
ActiveReports 19 .NET Edition
ReportTypesConfiguration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : ReportTypesConfiguration Class

Glossary Item Box

Represents configuration settings for report types.

Object Model

ReportTypesConfiguration Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportTypesConfiguration
C#
public sealed class ReportTypesConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.ReportTypesConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportTypesConfiguration Members
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


ReportTypesConfiguration Class Members

[image]
ActiveReports 19 .NET Edition
ReportTypesConfiguration Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : ReportTypesConfiguration Class

Glossary Item Box

The following tables list the members exposed by ReportTypesConfiguration.

Public Constructors

 | Name | Description
Public Constructor | ReportTypesConfiguration Constructor | Creates a new instance of ReportTypesConfiguration
Top

Public Properties

 | Name | Description
Public Property | ReportTypes | Gets or sets the sequence of report types.
Top

See Also

Reference

ReportTypesConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


ReportTypesConfiguration Constructor

[image]
ActiveReports 19 .NET Edition
ReportTypesConfiguration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > ReportTypesConfiguration Class : ReportTypesConfiguration Constructor

Glossary Item Box

Creates a new instance of ReportTypesConfiguration

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportTypesConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportTypesConfiguration Class
ReportTypesConfiguration Members


ReportTypesConfiguration Class Properties

[image]
ActiveReports 19 .NET Edition
ReportTypesConfiguration Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : ReportTypesConfiguration Class

Glossary Item Box

For a list of all members of this type, see ReportTypesConfiguration members.

Public Properties

 | Name | Description
Public Property | ReportTypes | Gets or sets the sequence of report types.
Top

See Also

Reference

ReportTypesConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


ReportTypes Property

[image]
ActiveReports 19 .NET Edition
ReportTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > ReportTypesConfiguration Class : ReportTypes Property

Glossary Item Box

Gets or sets the sequence of report types.

Syntax

Visual Basic (Declaration)
Public Property ReportTypes As IEnumerable(Of ReportTypes)
C#
public IEnumerable<ReportTypes> ReportTypes {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportTypesConfiguration Class
ReportTypesConfiguration Members


DataSourceType Enumeration

[image]
ActiveReports 19 .NET Edition
DataSourceType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : DataSourceType Enumeration

Glossary Item Box

Available data source types.

Syntax

Visual Basic (Declaration)
Public Enum DataSourceType
   Inherits System.Enum
C#
public enum DataSourceType : System.Enum

Members

Member | Description
Custom |
DataBase |
File |
Programmatic |
WebAPI |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportsCore.Configuration.DataSourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


ReportTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ReportTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : ReportTypes Enumeration

Glossary Item Box

Available report types.

Syntax

Visual Basic (Declaration)
Public Enum ReportTypes
   Inherits System.Enum
C#
public enum ReportTypes : System.Enum

Members

Member | Description
Page | Page report type.
Rdl | Rdl report type.
RdlDashboard | Rdl Dashboard type.
RdlMultiSection | Rdl Multi-Section type.
Section | Section report type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportsCore.Configuration.ReportTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


DataParameter Class

[image]
ActiveReports 19 .NET Edition
DataParameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataParameter Class

Glossary Item Box

Represents a parameter used with a System.Data.IDbCommand.

Object Model

DataParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataParameter
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDataParameter
C#
public sealed class DataParameter : GrapeCity.ActiveReports.Extensibility.Data.IDataParameter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.DataParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


DataParameter Class Members

[image]
ActiveReports 19 .NET Edition
DataParameter Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataParameter Class

Glossary Item Box

The following tables list the members exposed by DataParameter.

Public Constructors

 | Name | Description
Public Constructor | DataParameter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ParameterName | Gets or sets the name of the parameter.
Public Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

DataParameter Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


DataParameter Constructor

[image]
ActiveReports 19 .NET Edition
DataParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataParameter Class : DataParameter Constructor

Glossary Item Box

Overload List

Overload | Description
DataParameter Constructor() | Initializes a new instance of the DataParameter class.
DataParameter Constructor(String,Object) | Initializes a new instance of the DataParameter class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Class
DataParameter Members


DataParameter Constructor()

[image]
ActiveReports 19 .NET Edition
DataParameter Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataParameter Class > DataParameter Constructor : DataParameter Constructor()

Glossary Item Box

Initializes a new instance of the DataParameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataParameter()

Remarks

Parameterless constructor required for JSON deserialization (in VQD).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Class
DataParameter Members
Overload List


DataParameter Constructor(String,Object)

[image]
ActiveReports 19 .NET Edition
DataParameter Constructor(String,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataParameter Class > DataParameter Constructor : DataParameter Constructor(String,Object)

parameterName
The name of the parameter
value
The value of the parameter

Glossary Item Box

Initializes a new instance of the DataParameter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal value As Object _
)
C#
public DataParameter(
   string parameterName,
   object value
)

Parameters

parameterName
The name of the parameter
value
The value of the parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Class
DataParameter Members
Overload List


DataParameter Class Properties

[image]
ActiveReports 19 .NET Edition
DataParameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataParameter Class

Glossary Item Box

For a list of all members of this type, see DataParameter members.

Public Properties

 | Name | Description
Public Property | ParameterName | Gets or sets the name of the parameter.
Public Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

DataParameter Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


ParameterName Property

[image]
ActiveReports 19 .NET Edition
ParameterName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataParameter Class : ParameterName Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property ParameterName As String
C#
public string ParameterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Class
DataParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataParameter Class : Value Property

Glossary Item Box

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Class
DataParameter Members


DataProviderFactories Class

[image]
ActiveReports 19 .NET Edition
DataProviderFactories Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataProviderFactories Class

Glossary Item Box

Supports dynamic configuration of the data providers.

Object Model

DataProviderFactories Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataProviderFactories
C#
public static class DataProviderFactories

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.DataProviderFactories

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderFactories Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


DataProviderFactories Class Members

[image]
ActiveReports 19 .NET Edition
DataProviderFactories Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataProviderFactories Class

Glossary Item Box

The following tables list the members exposed by DataProviderFactories.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Get |
static (Shared in Visual Basic) | GetFactory | Returns an instance of the specified data provider.
Top

See Also

Reference

DataProviderFactories Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


DataProviderFactories Class Methods

[image]
ActiveReports 19 .NET Edition
DataProviderFactories Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : DataProviderFactories Class

Glossary Item Box

For a list of all members of this type, see DataProviderFactories members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Get |
static (Shared in Visual Basic) | GetFactory | Returns an instance of the specified data provider.
Top

See Also

Reference

DataProviderFactories Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


Get Method

[image]
ActiveReports 19 .NET Edition
Get Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataProviderFactories Class : Get Method

dataProviders
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Get( _
   ByVal dataProviders As IEnumerable(Of DataProviderInfo), _
   ByVal name As String _
) As DataProviderInfo
C#
public static DataProviderInfo Get(
   IEnumerable<DataProviderInfo> dataProviders,
   string name
)

Parameters

dataProviders
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderFactories Class
DataProviderFactories Members


GetFactory Method

[image]
ActiveReports 19 .NET Edition
GetFactory Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > DataProviderFactories Class : GetFactory Method

providerName
The name, as configured for the desired data provider.
dataProviders
resourceLocator

Glossary Item Box

Returns an instance of the specified data provider.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFactory( _
   ByVal providerName As String, _
   ByVal dataProviders() As DataProviderInfo, _
   Optional ByVal resourceLocator As ResourceLocator _
) As DbProviderFactory
C#
public static DbProviderFactory GetFactory(
   string providerName,
   DataProviderInfo[] dataProviders,
   ResourceLocator resourceLocator
)

Parameters

providerName
The name, as configured for the desired data provider.
dataProviders
resourceLocator

Return Value

The System.Data.Common.DbProviderFactory associated with the specified data provider name or NULL if it is not configured or it cannot be initialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderFactories Class
DataProviderFactories Members


ExcelSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
ExcelSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : ExcelSchemaProvider Class

Glossary Item Box

Object Model

ExcelSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public Class ExcelSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public class ExcelSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.ExcelSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


ExcelSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
ExcelSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : ExcelSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by ExcelSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | ExcelSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Db Schema provider for Excel data provider
Top

See Also

Reference

ExcelSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


ExcelSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
ExcelSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > ExcelSchemaProvider Class : ExcelSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExcelSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelSchemaProvider Class
ExcelSchemaProvider Members


ExcelSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
ExcelSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : ExcelSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see ExcelSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Db Schema provider for Excel data provider
Top

See Also

Reference

ExcelSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > ExcelSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Db Schema provider for Excel data provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelSchemaProvider Class
ExcelSchemaProvider Members


MssqlSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
MssqlSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

Db Schema provider for Microsoft Sql Client data provider

Object Model

MssqlSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public Class MssqlSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public class MssqlSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.MssqlSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


MssqlSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
MssqlSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by MssqlSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | MssqlSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for Microsoft Sql Client data provider
Top

See Also

Reference

MssqlSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


MssqlSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
MssqlSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > MssqlSchemaProvider Class : MssqlSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MssqlSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Class
MssqlSchemaProvider Members


MssqlSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
MssqlSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see MssqlSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for Microsoft Sql Client data provider
Top

See Also

Reference

MssqlSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > MssqlSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Returns DataSchema for Microsoft Sql Client data provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Class
MssqlSchemaProvider Members


MySQLSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
MySQLSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MySQLSchemaProvider Class

Glossary Item Box

Db Schema provider for MySQL data provider

Object Model

MySQLSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MySQLSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public sealed class MySQLSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.MySQLSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MySQLSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


MySQLSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
MySQLSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MySQLSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by MySQLSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | MySQLSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for MySQL data provider
Top

See Also

Reference

MySQLSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


MySQLSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
MySQLSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > MySQLSchemaProvider Class : MySQLSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MySQLSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MySQLSchemaProvider Class
MySQLSchemaProvider Members


MySQLSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
MySQLSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : MySQLSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see MySQLSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for MySQL data provider
Top

See Also

Reference

MySQLSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > MySQLSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Returns DataSchema for MySQL data provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MySQLSchemaProvider Class
MySQLSchemaProvider Members


OleDbSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
OleDbSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OleDbSchemaProvider Class

Glossary Item Box

Schema for Microsoft Oledb provider

Object Model

OleDbSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public Class OleDbSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public class OleDbSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.OleDbSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDbSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


OleDbSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
OleDbSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OleDbSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by OleDbSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | OleDbSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema |
Top

See Also

Reference

OleDbSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


OleDbSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
OleDbSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > OleDbSchemaProvider Class : OleDbSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OleDbSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDbSchemaProvider Class
OleDbSchemaProvider Members


OleDbSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
OleDbSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OleDbSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see OleDbSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema |
Top

See Also

Reference

OleDbSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > OleDbSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDbSchemaProvider Class
OleDbSchemaProvider Members


OracleSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
OracleSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OracleSchemaProvider Class

Glossary Item Box

Db Schema provider for Oracle Provider data provider

Object Model

OracleSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public sealed class OracleSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.OracleSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


OracleSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
OracleSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OracleSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by OracleSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | OracleSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for Oracle Provider
Top

See Also

Reference

OracleSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


OracleSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
OracleSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > OracleSchemaProvider Class : OracleSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleSchemaProvider Class
OracleSchemaProvider Members


OracleSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
OracleSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : OracleSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see OracleSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for Oracle Provider
Top

See Also

Reference

OracleSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > OracleSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Returns DataSchema for Oracle Provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleSchemaProvider Class
OracleSchemaProvider Members


PostgreSQLSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
PostgreSQLSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : PostgreSQLSchemaProvider Class

Glossary Item Box

Db Schema provider for PostgreSql data provider

Object Model

PostgreSQLSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PostgreSQLSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public sealed class PostgreSQLSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.PostgreSQLSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostgreSQLSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


PostgreSQLSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
PostgreSQLSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : PostgreSQLSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by PostgreSQLSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | PostgreSQLSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for PostgreSql data provider
Top

See Also

Reference

PostgreSQLSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


PostgreSQLSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
PostgreSQLSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > PostgreSQLSchemaProvider Class : PostgreSQLSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PostgreSQLSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostgreSQLSchemaProvider Class
PostgreSQLSchemaProvider Members


PostgreSQLSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
PostgreSQLSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : PostgreSQLSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see PostgreSQLSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for PostgreSql data provider
Top

See Also

Reference

PostgreSQLSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > PostgreSQLSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Returns DataSchema for PostgreSql data provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostgreSQLSchemaProvider Class
PostgreSQLSchemaProvider Members


SQLiteSchemaProvider Class

[image]
ActiveReports 19 .NET Edition
SQLiteSchemaProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : SQLiteSchemaProvider Class

Glossary Item Box

Db Schema provider for SQLite data provider

Object Model

SQLiteSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLiteSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public sealed class SQLiteSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders.SQLiteSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SQLiteSchemaProvider Members
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


SQLiteSchemaProvider Class Members

[image]
ActiveReports 19 .NET Edition
SQLiteSchemaProvider Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : SQLiteSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by SQLiteSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | SQLiteSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for SQLite Provider
Top

See Also

Reference

SQLiteSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


SQLiteSchemaProvider Constructor

[image]
ActiveReports 19 .NET Edition
SQLiteSchemaProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > SQLiteSchemaProvider Class : SQLiteSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SQLiteSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SQLiteSchemaProvider Class
SQLiteSchemaProvider Members


SQLiteSchemaProvider Class Methods

[image]
ActiveReports 19 .NET Edition
SQLiteSchemaProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace : SQLiteSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see SQLiteSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema | Returns DataSchema for SQLite Provider
Top

See Also

Reference

SQLiteSchemaProvider Class
GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 19 .NET Edition
GetSchema Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data.DataProviders Namespace > SQLiteSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Returns DataSchema for SQLite Provider

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SQLiteSchemaProvider Class
SQLiteSchemaProvider Members


ConfigurableTileProvidersManager Class

[image]
ActiveReports 19 .NET Edition
ConfigurableTileProvidersManager Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

Providers ability to create tile providers applying settings from config file.

Object Model

ConfigurableTileProvidersManager Class

Syntax

Visual Basic (Declaration)
Public Class ConfigurableTileProvidersManager
   Inherits GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
   Implements GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.ITileProvidersManager
C#
public class ConfigurableTileProvidersManager : GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.ITileProvidersManager

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.ConfigurableTileProvidersManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Members
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ConfigurableTileProvidersManager Class Members

[image]
ActiveReports 19 .NET Edition
ConfigurableTileProvidersManager Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

The following tables list the members exposed by ConfigurableTileProvidersManager.

Public Constructors

 | Name | Description
Public Constructor | ConfigurableTileProvidersManager Constructor | Gets the descriptors for map tile providers. Initializes a new instance of the GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager class.
Top

See Also

Reference

ConfigurableTileProvidersManager Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ConfigurableTileProvidersManager Constructor

[image]
ActiveReports 19 .NET Edition
ConfigurableTileProvidersManager Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ConfigurableTileProvidersManager Class : ConfigurableTileProvidersManager Constructor

configurationManager
Configuration information.

Glossary Item Box

Gets the descriptors for map tile providers. Initializes a new instance of the GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configurationManager As IConfigurationManager _
)
C#
public ConfigurableTileProvidersManager(
   IConfigurationManager configurationManager
)

Parameters

configurationManager
Configuration information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Class
ConfigurableTileProvidersManager Members


DataVisualizerInfoExtensions Class

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfoExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

Usefull extensions.

Object Model

DataVisualizerInfoExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataVisualizerInfoExtensions
C#
public static class DataVisualizerInfoExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.DataVisualizerInfoExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfoExtensions Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataVisualizerInfoExtensions Class Members

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfoExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerInfoExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImage | Gets as PNG image.
Top

See Also

Reference

DataVisualizerInfoExtensions Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataVisualizerInfoExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfoExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerInfoExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImage | Gets as PNG image.
Top

See Also

Reference

DataVisualizerInfoExtensions Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


GetImage Method

[image]
ActiveReports 19 .NET Edition
GetImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataVisualizerInfoExtensions Class : GetImage Method

buffer
Visualizer info.
width
Width in pixels.
height
Height in pixels.
dpiX
Horizontal resolution.
dpiY
Vertical resolution.
repeatOption
Background rendering mode.
fonts

Glossary Item Box

Gets as PNG image.

Syntax

Visual Basic (Declaration)
Public Shared Function GetImage( _
   ByVal buffer As DataVisualizerInfo, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal dpiX As Single, _
   ByVal dpiY As Single, _
   Optional ByVal repeatOption As Nullable(Of BackgroundRepeatOption), _
   Optional ByVal fonts As IFontsFactory _
) As ImageInfo
C#
public static ImageInfo GetImage(
   DataVisualizerInfo buffer,
   int width,
   int height,
   float dpiX,
   float dpiY,
   Nullable<BackgroundRepeatOption> repeatOption,
   IFontsFactory fonts
)

Parameters

buffer
Visualizer info.
width
Width in pixels.
height
Height in pixels.
dpiX
Horizontal resolution.
dpiY
Vertical resolution.
repeatOption
Background rendering mode.
fonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfoExtensions Class
DataVisualizerInfoExtensions Members


ParametersHelper Class

[image]
ActiveReports 19 .NET Edition
ParametersHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ParametersHelper Class

Glossary Item Box

Auxiliary class for working with report parameters

Object Model

ParametersHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ParametersHelper
C#
public static class ParametersHelper

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.ParametersHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersHelper Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ParametersHelper Class Members

[image]
ActiveReports 19 .NET Edition
ParametersHelper Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ParametersHelper Class

Glossary Item Box

The following tables list the members exposed by ParametersHelper.

See Also

Reference

ParametersHelper Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ReportCombiner Class

[image]
ActiveReports 19 .NET Edition
ReportCombiner Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

Allows to create report combining existing reports by adding them as subreports or report sections

Object Model

ReportCombiner Class

Syntax

Visual Basic (Declaration)
Public Class ReportCombiner
C#
public class ReportCombiner

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ReportCombiner Class Members

[image]
ActiveReports 19 .NET Edition
ReportCombiner Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

The following tables list the members exposed by ReportCombiner.

Public Constructors

 | Name | Description
Public Constructor | ReportCombiner Constructor | Creates instance of ReportCombiner
Top

Public Properties

 | Name | Description
Public Property | DefaultStep | Gets or sets the default gap between two adjacent subreports.
Public Property | Mode | Gets or sets the report combine mode.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Add a collection of reports with specified options in the reports list.
Public Method | AddReport | Add the report with specified options in the reports list.
Public Method | BuildReport | Returns a new PageReport instance
Public Method | Clear | Clears all the items from current instance of report combiner.
Public Method | Insert | Insert a report to the specified position in reports list.
Public Method | RemoveAll | Remove all the occurrences of the specified report.
Public Method | RemoveAt | Remove the report from the specified position in the reports list.
Public Method | SetMargin | Overloaded. Sets the margins of the report.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ReportCombiner Constructor

[image]
ActiveReports 19 .NET Edition
ReportCombiner Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : ReportCombiner Constructor

Glossary Item Box

Creates instance of ReportCombiner

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportCombiner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


ReportCombiner Class Methods

[image]
ActiveReports 19 .NET Edition
ReportCombiner Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

For a list of all members of this type, see ReportCombiner members.

Public Methods

 | Name | Description
Public Method | AddRange | Add a collection of reports with specified options in the reports list.
Public Method | AddReport | Add the report with specified options in the reports list.
Public Method | BuildReport | Returns a new PageReport instance
Public Method | Clear | Clears all the items from current instance of report combiner.
Public Method | Insert | Insert a report to the specified position in reports list.
Public Method | RemoveAll | Remove all the occurrences of the specified report.
Public Method | RemoveAt | Remove the report from the specified position in the reports list.
Public Method | SetMargin | Overloaded. Sets the margins of the report.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : AddRange Method

reports
Reports to be added.
options
The options to be applied to each report.

Glossary Item Box

Add a collection of reports with specified options in the reports list.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal reports As IEnumerable(Of PageReport), _
   Optional ByVal options As LocationOptions _
)
C#
public void AddRange(
   IEnumerable<PageReport> reports,
   LocationOptions options
)

Parameters

reports
Reports to be added.
options
The options to be applied to each report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


AddReport Method

[image]
ActiveReports 19 .NET Edition
AddReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : AddReport Method

report
The report to be added.
options
The options to report be added with.

Glossary Item Box

Add the report with specified options in the reports list.

Syntax

Visual Basic (Declaration)
Public Sub AddReport( _
   ByVal report As PageReport, _
   Optional ByVal options As LocationOptions _
)
C#
public void AddReport(
   PageReport report,
   LocationOptions options
)

Parameters

report
The report to be added.
options
The options to report be added with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


BuildReport Method

[image]
ActiveReports 19 .NET Edition
BuildReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : BuildReport Method

Glossary Item Box

Returns a new PageReport instance

Syntax

Visual Basic (Declaration)
Public Function BuildReport() As PageReport
C#
public PageReport BuildReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : Clear Method

Glossary Item Box

Clears all the items from current instance of report combiner.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : Insert Method

index
The position of the report to be added.
report
The report to be added.
options
The options to report be added with.

Glossary Item Box

Insert a report to the specified position in reports list.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal report As PageReport, _
   Optional ByVal options As LocationOptions _
)
C#
public void Insert(
   int index,
   PageReport report,
   LocationOptions options
)

Parameters

index
The position of the report to be added.
report
The report to be added.
options
The options to report be added with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


RemoveAll Method

[image]
ActiveReports 19 .NET Edition
RemoveAll Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : RemoveAll Method

report
The report to be removed

Glossary Item Box

Remove all the occurrences of the specified report.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal report As PageReport _
) As Integer
C#
public int RemoveAll(
   PageReport report
)

Parameters

report
The report to be removed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : RemoveAt Method

index
The index of the report to be removed.

Glossary Item Box

Remove the report from the specified position in the reports list.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the report to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


SetMargin Method

[image]
ActiveReports 19 .NET Edition
SetMargin Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : SetMargin Method

Glossary Item Box

Sets the margins of the report.

Overload List

Overload | Description
SetMargin(Length,Length,Length,Length) | Sets the margins of the report.
SetMargin(Length,Length) | Sets the margins of the report.
SetMargin(Length) | Sets the margins of the report to the specified value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


SetMargin(Length,Length,Length,Length) Method

[image]
ActiveReports 19 .NET Edition
SetMargin(Length,Length,Length,Length) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length,Length,Length,Length) Method

top
Top margin
right
Right Margin
bottom
Bottom Margin
left
Left Margin

Glossary Item Box

Sets the margins of the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal top As Length, _
   ByVal right As Length, _
   ByVal bottom As Length, _
   ByVal left As Length _
)
C#
public void SetMargin(
   Length top,
   Length right,
   Length bottom,
   Length left
)

Parameters

top
Top margin
right
Right Margin
bottom
Bottom Margin
left
Left Margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


SetMargin(Length,Length) Method

[image]
ActiveReports 19 .NET Edition
SetMargin(Length,Length) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length,Length) Method

topAndBottom
Top and bottom margins
rightAndLeft
Right and left margins

Glossary Item Box

Sets the margins of the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal topAndBottom As Length, _
   ByVal rightAndLeft As Length _
)
C#
public void SetMargin(
   Length topAndBottom,
   Length rightAndLeft
)

Parameters

topAndBottom
Top and bottom margins
rightAndLeft
Right and left margins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


SetMargin(Length) Method

[image]
ActiveReports 19 .NET Edition
SetMargin(Length) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length) Method

all
Margin length

Glossary Item Box

Sets the margins of the report to the specified value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal all As Length _
)
C#
public void SetMargin(
   Length all
)

Parameters

all
Margin length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


ReportCombiner Class Properties

[image]
ActiveReports 19 .NET Edition
ReportCombiner Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

For a list of all members of this type, see ReportCombiner members.

Public Properties

 | Name | Description
Public Property | DefaultStep | Gets or sets the default gap between two adjacent subreports.
Public Property | Mode | Gets or sets the report combine mode.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DefaultStep Property

[image]
ActiveReports 19 .NET Edition
DefaultStep Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : DefaultStep Property

Glossary Item Box

Gets or sets the default gap between two adjacent subreports.

Syntax

Visual Basic (Declaration)
Public Property DefaultStep As Length
C#
public Length DefaultStep {get; set;}

Property Value

The default is 1 inch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


Mode Property

[image]
ActiveReports 19 .NET Edition
Mode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : Mode Property

Glossary Item Box

Gets or sets the report combine mode.

Syntax

Visual Basic (Declaration)
Public Property Mode As CombineMode
C#
public CombineMode Mode {get; set;}

Property Value

One of the CombineMode values that defines the report combination logic. The default is CombineMode.ReportSections.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


CombineMode Enumeration

[image]
ActiveReports 19 .NET Edition
CombineMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : CombineMode Enumeration

Glossary Item Box

Defines the report combine mode.

Syntax

Visual Basic (Declaration)
Public Enum CombineMode
   Inherits System.Enum
C#
public enum CombineMode : System.Enum

Members

Member | Description
ReportSections | Each report will be represented as a section (or multiple sections) in the final multi-section RDLX report.
SubReports | Produces the RDLX report with a single body containing subreports for every report combined.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportsCore.Tools.CombineMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure

[image]
ActiveReports 19 .NET Edition
LocationOptions Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

Additional options to control report location when using ReportCombiner

Object Model

LocationOptions Structure

Syntax

Visual Basic (Declaration)
Public Structure LocationOptions
   Inherits System.ValueType
C#
public struct LocationOptions : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure Members

[image]
ActiveReports 19 .NET Edition
LocationOptions Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

The following tables list the members exposed by LocationOptions.

Public Fields

 | Name | Description
Public Field | Gap | Adds extra space between previous and added report
Public Field | PageBreakBefore | Adds a pagebreak before added report
Top

See Also

Reference

LocationOptions Structure
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure Fields

[image]
ActiveReports 19 .NET Edition
LocationOptions Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

For a list of all members of this type, see LocationOptions members.

Public Fields

 | Name | Description
Public Field | Gap | Adds extra space between previous and added report
Public Field | PageBreakBefore | Adds a pagebreak before added report
Top

See Also

Reference

LocationOptions Structure
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


Gap Field

[image]
ActiveReports 19 .NET Edition
Gap Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > LocationOptions Structure : Gap Field

Glossary Item Box

Adds extra space between previous and added report

Syntax

Visual Basic (Declaration)
Public Gap As Length
C#
public Length Gap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Structure
LocationOptions Members


PageBreakBefore Field

[image]
ActiveReports 19 .NET Edition
PageBreakBefore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > LocationOptions Structure : PageBreakBefore Field

Glossary Item Box

Adds a pagebreak before added report

Syntax

Visual Basic (Declaration)
Public PageBreakBefore As Boolean
C#
public bool PageBreakBefore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Structure
LocationOptions Members


ARControl Class

[image]
ActiveReports 19 .NET Edition
ARControl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

ARControl is the base class for ActiveReports controls. You should not need to use this class in your application.

Object Model

ARControl Class

Syntax

Visual Basic (Declaration)
Public Class ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public class ARControl : GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode
GrapeCity.ActiveReports.SectionReportModel.ChartControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl
GrapeCity.ActiveReports.SectionReportModel.InputField
GrapeCity.ActiveReports.SectionReportModel.Label
GrapeCity.ActiveReports.SectionReportModel.Line
GrapeCity.ActiveReports.SectionReportModel.OleObject
GrapeCity.ActiveReports.SectionReportModel.PageBreak
GrapeCity.ActiveReports.SectionReportModel.Picture
GrapeCity.ActiveReports.SectionReportModel.ReportInfo
GrapeCity.ActiveReports.SectionReportModel.RichTextBox
GrapeCity.ActiveReports.SectionReportModel.Shape
GrapeCity.ActiveReports.SectionReportModel.SubReport
GrapeCity.ActiveReports.SectionReportModel.TextBox

Requirements

See Also

Reference

ARControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Members

[image]
ActiveReports 19 .NET Edition
ARControl Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

The following tables list the members exposed by ARControl.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Dispose | Releases the control instance from memory.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Methods

[image]
ActiveReports 19 .NET Edition
ARControl Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

For a list of all members of this type, see ARControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Dispose | Releases the control instance from memory.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BringToFront Method

[image]
ActiveReports 19 .NET Edition
BringToFront Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BringToFront();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BringToFront()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Dispose() Method

Glossary Item Box

Releases the control instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


SendToBack Method

[image]
ActiveReports 19 .NET Edition
SendToBack Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Example

C# Copy Code
private void detail_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.barcode1.SendToBack();
}
Visual Basic Copy Code
Private Sub Detail1_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.SendToBack()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


SetBounds Method

[image]
ActiveReports 19 .NET Edition
SetBounds Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SetBounds Method

bounds
Rectangle that defines the location and size of the control.

Glossary Item Box

Sets the bounds of the control to the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Sub SetBounds( _
   ByVal bounds As RectangleF _
)
C#
public void SetBounds(
   RectangleF bounds
)

Parameters

bounds
Rectangle that defines the location and size of the control.

Return Value

The rectangle is defined using float or Single values in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.RectangleF b = new System.Drawing.RectangleF();
    b.X=2;
    b.Y=1;
    b.Width=2;
    b.Height=1;
    this.barcode2.SetBounds(b);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New System.Drawing.RectangleF
    With b
        .X = 2
        .Y = 1
        .Width = 2
        .Height = 0.5
    End With
    Me.Barcode2.SetBounds(b)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


ARControl Class Properties

[image]
ActiveReports 19 .NET Edition
ARControl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

For a list of all members of this type, see ARControl members.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Border Property

Glossary Item Box

Gets a border object that defines the border style for each edge of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As Border
C#
public virtual Border Border {get;}

Property Value

Default border object.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    this.textBox1.Border.BottomStyle = BorderLineStyle.ThickDash;
    this.textBox1.Border.TopStyle = BorderLineStyle.ThickDash;
    b = this.textBox1.Border.Clone();
    this.textBox2.Border.BottomStyle = b.BottomStyle;
    this.textBox2.Border.TopStyle = b.TopStyle;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New GrapeCity.ActiveReports.Border
    Me.TextBox1.Border.BottomStyle = BorderLineStyle.ThickDash
    Me.TextBox1.Border.TopStyle = BorderLineStyle.ThickDash
    b = Me.TextBox1.Border.Clone()
    Me.TextBox2.Border.BottomStyle = b.BottomStyle
    Me.TextBox2.Border.TopStyle = b.TopStyle
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Bounds Property

Glossary Item Box

Sets or returns a rectangle that defines the location and size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Property Value

A RectangleF object defined using Float or Single values in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


DataField Property

[image]
ActiveReports 19 .NET Edition
DataField Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : DataField Property

Glossary Item Box

Gets or sets the field name from the data source to bind to the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property DataField As String
C#
public virtual string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.

Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.textBox2.DataField = "CustomerID";
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.TextBox2.DataField = "CustomerID"
End Sub

Requirements

See Also

Reference

ARControl Class
ARControl Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Height Property

Glossary Item Box

Gets or sets the height of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Left Property

Glossary Item Box

Gets or sets the left position of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overridable Property Location As PointF
C#
public virtual PointF Location {get; set;}

Property Value

System.Drawing.PointF defined by X and Y float or Single values in inches.

Remarks

Note: Be sure that the section containing the control is sized to accommodate the location; otherwise the control may render in a hidden area.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.textBox1.Location = p;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.TextBox1.Location = p
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Remarks

Requires a unique name within the report class. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Name = "txtCustID";
    this.Sections["detail"].Controls["txtCustID"].Width = 4;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.TextBox1.Name = "txtCustID"
    Me.Sections("Detail1").Controls("txtCustID").Width = 4
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Parent Property

Glossary Item Box

Gets a reference to the parent section of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
C#
public object Parent {get;}

Property Value

Object - Reference to the parent section.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.textBox2.Parent.ToString());
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MessageBox.Show(Me.TextBox1.Parent.ToString())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Size Property

Glossary Item Box

Gets or sets the size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overridable Property Size As SizeF
C#
public virtual SizeF Size {get; set;}

Property Value

System.Drawing.SizeF.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.SizeF s = new System.Drawing.SizeF();
    s.Width = 2;
    s.Height = 1;
    this.textBox1.Size = s;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim s As System.Drawing.SizeF
    s.Width = 2
    s.Height = 1
    Me.TextBox1.Size = s
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Tag Property

[image]
ActiveReports 19 .NET Edition
Tag Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Tag Property

Glossary Item Box

Gets or sets user-defined information to be persisted with the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReportModel.ARControl arcontrol = new GrapeCity.ActiveReports.SectionReportModel.ARControl();
arcontrol.Tag = new TextBox();
Visual Basic Copy Code
Dim arcontrol As New GrapeCity.ActiveReports.SectionReportModel.ARControl()
arcontrol.Tag = New TextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Top Property

Glossary Item Box

Gets or sets, in inches, the top position of the control relative to the section that contains it.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
C#
public float Top {get; set;}

Property Value

A float or Single value in inches.

Remarks

Note: Be sure that the section containing the control is sized to accommodate the location. Otherwise the control may render in a hidden area.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Visible Property

Glossary Item Box

Sets or returns a value indicating whether the control will be printed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A Boolean value. Default is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.textBox2.Value.ToString() == "ALFKI")
    {
        this.textBox2.Visible = false;
    }
    else
    {
        this.textBox2.Visible = true;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Me.TextBox1.Value = "ALFKI" Then
        Me.TextBox1.Visible = False
    Else
        Me.TextBox1.Visible = True
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Width Property

Glossary Item Box

Gets or sets the width of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Barcode Class

[image]
ActiveReports 19 .NET Edition
Barcode Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

The Barcode control is used to print barcode symbology in the report.

Object Model

Barcode Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Barcode
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class Barcode : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Remarks

The Barcode control can be bound to data fields or unbound.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Center;
    this.barcode1.AutoSize = true;
    this.barcode1.BackColor = System.Drawing.Color.White;
    this.barcode1.BarHeight = 0.0f;
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
    this.barcode1.CheckSumEnabled = true;
    this.barcode1.ForeColor = System.Drawing.Color.Green;
    this.barcode1.Style = BarCodeStyle.Code49;
    this.barcode1.Text = "Barcode";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
    Me.Barcode1.AutoSize = True
    Me.Barcode1.BackColor = System.Drawing.Color.White
    Me.Barcode1.BarHeight = 0.0F
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
    Me.Barcode1.CheckSumEnabled = True
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
    Me.Barcode1.Style = BarCodeStyle.Code49
    Me.Barcode1.Text = "Barcode"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Class Members

[image]
ActiveReports 19 .NET Edition
Barcode Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor | Initializes a new instance of the Barcode class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | Aztec | Aztec options.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | MaxiCode | MaxiCode options.
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | MicroQRCode | Gets or sets the MicroQRCodeOptions for the barcode control.
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Top

See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Constructor

[image]
ActiveReports 19 .NET Edition
Barcode Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Barcode Constructor

Glossary Item Box

Initializes a new instance of the Barcode class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Barcode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

[image]
ActiveReports 19 .NET Edition
Barcode Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | Aztec | Aztec options.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | MaxiCode | MaxiCode options.
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | MicroQRCode | Gets or sets the MicroQRCodeOptions for the barcode control.
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Top

See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Alignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the caption in the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignment
C#
public StringAlignment Alignment {get; set;}

Property Value

StringAlignment enum. The default value is StringAlignment.Center.

The possible values are StringAlignment.Near, StringAlignment.Center and StringAlignment.Far.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Near;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


AutoSize Property

[image]
ActiveReports 19 .NET Edition
AutoSize Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : AutoSize Property

Glossary Item Box

Gets or sets whether the barcode automatically stretches to fit the control.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

Boolean. The default value is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.AutoSize = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.AutoSize = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Aztec Property

[image]
ActiveReports 19 .NET Edition
Aztec Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Aztec Property

Glossary Item Box

Aztec options.

Syntax

Visual Basic (Declaration)
Public Property Aztec As AztecOptions
C#
public AztecOptions Aztec {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BackColor Property

Glossary Item Box

Gets or sets the barcode's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BackColor = System.Drawing.Color.White;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BackColor = System.Drawing.Color.White
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


BarHeight Property

[image]
ActiveReports 19 .NET Edition
BarHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BarHeight Property

Glossary Item Box

Gets or sets the height of the bars in inches.

Syntax

Visual Basic (Declaration)
Public Property BarHeight As Single
C#
public float BarHeight {get; set;}

Remarks

If the bar height exceeds the height of the control, this property is ignored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


CaptionGrouping Property

[image]
ActiveReports 19 .NET Edition
CaptionGrouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionGrouping Property

Glossary Item Box

Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.

Syntax

Visual Basic (Declaration)
Public Property CaptionGrouping As Boolean
C#
public bool CaptionGrouping {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


CaptionPosition Property

[image]
ActiveReports 19 .NET Edition
CaptionPosition Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionPosition Property

Glossary Item Box

Gets or sets the caption's vertical position relative to the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Property CaptionPosition As BarCodeCaptionPosition
C#
public BarCodeCaptionPosition CaptionPosition {get; set;}

Property Value

Current position of the caption. Default is BarCodeCaptionPosition.None.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


CheckSumEnabled Property

[image]
ActiveReports 19 .NET Edition
CheckSumEnabled Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CheckSumEnabled Property

Glossary Item Box

Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.

Syntax

Visual Basic (Declaration)
Public Property CheckSumEnabled As Boolean
C#
public bool CheckSumEnabled {get; set;}

Property Value

Boolean. Default is true.

Remarks

  • Property is valid for the following barcodes:

Ansi39
Ansi39x
Code39
Code39x
Code_128_A
Code_128_B
Code_128_C
Code_128auto
Code_93
Code93x
MSI
PostNet
EAN_8
UPC_A
RM4SCC
UCCEAN128

  • Property is not valid for the following barcodes:

Codabar(NW-7)
EAN_13(JAN13)
Code_2_of_5
Code25intlv
Matrix_2_of_5
UPC_E0
UPC_E1
QRCode
Code49
DataMatrix
Pdf417
microPdf417
IntelligentMail
JapanesePostal (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
EAN128FNC1 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Truncated (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Stacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14StackedOmnidirectional (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpanded (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpandedStacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSLimited (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)

CheckSumEnabled has no effect if the style is EAN-13 and the result is based on the length of the string as follows:

Under 12 digits | Barcode symbol is not generated. Error message appears on the control.
12 digits | Check digit is calculated automatically (modulus 10/ weight 3). The barcode symbol is generated once the 13th digit is added.
13 digits or above | Strings with 13 digits or above are ignored and check digit is calculated automatically till the 12th digit. The barcode symbol is generated once the 13th digit is added.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CheckSumEnabled = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CheckSumEnabled = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Code128 Property

[image]
ActiveReports 19 .NET Edition
Code128 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code128 Property

Glossary Item Box

Gets or sets the Code128Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property Code128 As Code128Options
C#
public Code128Options Code128 {get; set;}

Example

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
    this.barcode1.Style = BarCodeStyle.EAN128FNC1;
    // "\n" is encoded as FNC1 character and displayed none in caption.
    this.barcode1.Text = "12\n3456\n78";
    this.barcode1.Code128.Dpi = 300;
    this.barcode1.Code128.BarAdjust = +1;
    this.barcode1.Code128.ModuleSize = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.EAN128FNC1
    ' vbLf is encoded as FNC1 character and displayed none in caption.
    Me.Barcode1.Text="12” & vbLf & "3456" & vbLf &"78"
    Me.Barcode1.Code128.Dpi = 300
    Me.Barcode1.Code128.BarAdjust = +1
    Me.Barcode1.Code128.ModuleSize = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Code49 Property

[image]
ActiveReports 19 .NET Edition
Code49 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code49 Property

Glossary Item Box

Gets or sets the Code49Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property Code49 As Code49Options
C#
public Code49Options Code49 {get; set;}

Remarks

Code 49 is a high-density stacked symbology containing two to eight rows of eight characters each. Each row has a start code and a stop code.

Code49 Options include Grouping and Group. If Grouping is set to True, the Group property may be set to a number between 0 and 8. The default values are False and 0, respectively.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Code49.Grouping = true;
    this.barcode1.Code49.Group = 4;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Code49.Grouping = True
    Me.Barcode1.Code49.Group = 4
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


DataField Property

[image]
ActiveReports 19 .NET Edition
DataField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataField Property

Glossary Item Box

Gets or sets the name of the field used to　bind the data source records.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property DataField As String
C#
public override string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.

Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Requirements

See Also

Reference

Barcode Class
Barcode Members


DataMatrix Property

[image]
ActiveReports 19 .NET Edition
DataMatrix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataMatrix Property

Glossary Item Box

DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.

Syntax

Visual Basic (Declaration)
Public Property DataMatrix As DataMatrixOptions
C#
public DataMatrixOptions DataMatrix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control's caption.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Example

Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Font = New System.Drawing.Font(Me.TextBox2.Font, FontStyle.Bold)
End Sub
C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Font = new System.Drawing.Font(this.TextBox2.Font, System.Drawing.FontStyle.Bold);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color

Remarks

This color applies to both the barcode symbol and any caption.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.ForeColor = System.Drawing.Color.Green;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


GS1Composite Property

[image]
ActiveReports 19 .NET Edition
GS1Composite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : GS1Composite Property

Glossary Item Box

Gets or sets the GS1CompositeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property GS1Composite As GS1CompositeOptions
C#
public GS1CompositeOptions GS1Composite {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MaxiCode Property

[image]
ActiveReports 19 .NET Edition
MaxiCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MaxiCode Property

Glossary Item Box

MaxiCode options.

Syntax

Visual Basic (Declaration)
Public Property MaxiCode As MaxiCodeOptions
C#
public MaxiCodeOptions MaxiCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MicroPDF417 Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MicroPDF417 Property

Glossary Item Box

Gets or sets the MicroPDF417Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417 As MicroPDF417Options
C#
public MicroPDF417Options MicroPDF417 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MicroQRCode Property

[image]
ActiveReports 19 .NET Edition
MicroQRCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MicroQRCode Property

Glossary Item Box

Gets or sets the MicroQRCodeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property MicroQRCode As MicroQRCodeOptions
C#
public MicroQRCodeOptions MicroQRCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


NarrowBarWidth Property

[image]
ActiveReports 19 .NET Edition
NarrowBarWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NarrowBarWidth Property

Glossary Item Box

Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

This value is in pixel for SectionReports and in point/inch/cm for PageReports.

Syntax

Visual Basic (Declaration)
Public Property NarrowBarWidth As Single
C#
public float NarrowBarWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


NWRatio Property

[image]
ActiveReports 19 .NET Edition
NWRatio Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NWRatio Property

Glossary Item Box

Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.

Syntax

Visual Basic (Declaration)
Public Property NWRatio As Single
C#
public float NWRatio {get; set;}

Remarks

Commonly used values are 2, 2.5, 2.75, and 3.

Some barcodes that use only two bar widths are Code39, Code25intlv, and MSI.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


PDF417 Property

[image]
ActiveReports 19 .NET Edition
PDF417 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : PDF417 Property

Glossary Item Box

Gets or sets the PDF417Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property PDF417 As PDF417Options
C#
public PDF417Options PDF417 {get; set;}

Remarks

PDF417 is a multi-row variable-length symbology that has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.

PDF417 Options include Column, ErrorLevel, Row, and Type.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.PDF417.Column = 2;
    this.barcode1.PDF417.Row = -1;
    this.barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.PDF417.Column = 2
    Me.Barcode1.PDF417.Row = -1
    Me.Barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QRCode Property

[image]
ActiveReports 19 .NET Edition
QRCode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QRCode Property

Glossary Item Box

Gets or sets the QRCodeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property QRCode As QRCodeOptions
C#
public QRCodeOptions QRCode {get; set;}

Remarks

QRCode is a two-dimensional symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.

Example

Paste into the Detail Format event.
C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.QRCode.Connection = false;
    this.barcode1.QRCode.ConnectionNumber = 0;
    this.barcode1.QRCode.ErrorLevel = GrapeCity.GrapeCity.ActiveReports.Options.QRCodeErrorLevel.Q;
    this.barcode1.QRCode.Mask = GrapeCity.GrapeCity.ActiveReports.Options.QRCodeMask.Mask111;
    this.barcode1.QRCode.Model = GrapeCity.GrapeCity.ActiveReports.Options.QRCodeModel.Model2;
    this.barcode1.QRCode.Version = 3;
}
Paste into the Detail Format event.
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.QRCode.Connection = False
    Me.Barcode1.QRCode.ConnectionNumber = 0
    Me.Barcode1.QRCode.ErrorLevel = Options.QRCodeErrorLevel.Q
    Me.Barcode1.QRCode.Mask = Options.QRCodeMask.Mask111
    Me.Barcode1.QRCode.Model = Options.QRCodeModel.Model2
    Me.Barcode1.QRCode.Version = 3
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneBottom Property

[image]
ActiveReports 19 .NET Edition
QuietZoneBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneBottom Property

Glossary Item Box

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property QuietZoneBottom As Single
C#
public float QuietZoneBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneLeft Property

[image]
ActiveReports 19 .NET Edition
QuietZoneLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneLeft Property

Glossary Item Box

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property QuietZoneLeft As Single
C#
public float QuietZoneLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneRight Property

[image]
ActiveReports 19 .NET Edition
QuietZoneRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneRight Property

Glossary Item Box

Gets or sets the right quiet zone of the barcode

Syntax

Visual Basic (Declaration)
Public Property QuietZoneRight As Single
C#
public float QuietZoneRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneTop Property

[image]
ActiveReports 19 .NET Edition
QuietZoneTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneTop Property

Glossary Item Box

Gets or sets the top quiet zone of the barcode

Syntax

Visual Basic (Declaration)
Public Property QuietZoneTop As Single
C#
public float QuietZoneTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Rotation Property

Glossary Item Box

Gets or sets the angle the barcode should be rotated to.

Syntax

Visual Basic (Declaration)
Public Property Rotation As Rotation
C#
public Rotation Rotation {get; set;}

Property Value

The rotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


RssExpandedStacked Property

[image]
ActiveReports 19 .NET Edition
RssExpandedStacked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : RssExpandedStacked Property

Glossary Item Box

When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.

Syntax

Visual Basic (Declaration)
Public Property RssExpandedStacked As RssExpandedStackedOptions
C#
public RssExpandedStackedOptions RssExpandedStacked {get; set;}

Remarks

If the RowCount property is set to 1, the RSS Expanded Stacked barcode style becomes the same symbol as the RSS Expanded barcode style.

There is a relation between the RowCount property and the Text property of an RSS Expanded Stacked barcode. This means that a barcode symbol is displayed using the number of rows that is determined, based on the value in the Text property against the value in the RowCount property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Style Property

Glossary Item Box

Gets or sets the barcode symbology used to render the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Style As BarCodeStyle
C#
public BarCodeStyle Style {get; set;}

Property Value

Current barcode symbology. Default is BarCodeStyle.Ansi39

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Style = BarCodeStyle.Code49;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.Code49
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementBarHeight Property

[image]
ActiveReports 19 .NET Edition
SupplementBarHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementBarHeight Property

Glossary Item Box

The height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementBarHeight As Single
C#
public float SupplementBarHeight {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementCaptionPosition Property

[image]
ActiveReports 19 .NET Edition
SupplementCaptionPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementCaptionPosition Property

Glossary Item Box

Defines how to display the barcode caption.

Syntax

Visual Basic (Declaration)
Public Property SupplementCaptionPosition As BarCodeCaptionPosition
C#
public BarCodeCaptionPosition SupplementCaptionPosition {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementDataField Property

[image]
ActiveReports 19 .NET Edition
SupplementDataField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementDataField Property

Glossary Item Box

The supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property SupplementDataField As String
C#
public string SupplementDataField {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementSpacing Property

[image]
ActiveReports 19 .NET Edition
SupplementSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementSpacing Property

Glossary Item Box

The spacing between main and supplement barcodes.

Syntax

Visual Basic (Declaration)
Public Property SupplementSpacing As Single
C#
public float SupplementSpacing {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementText Property

[image]
ActiveReports 19 .NET Edition
SupplementText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementText Property

Glossary Item Box

The supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property SupplementText As String
C#
public string SupplementText {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Text Property

Glossary Item Box

Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

Current text string. Default is an empty string.

Remarks

ActiveReports fills this value from the bound data field if the control is bound to the data source.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Text = "Barcode";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Text = "Barcode"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ValueBinary Property

[image]
ActiveReports 19 .NET Edition
ValueBinary Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ValueBinary Property

Glossary Item Box

Special property to pass binary data to barcode. Exists primary for QR Code barcode.

Syntax

Visual Basic (Declaration)
Public Property ValueBinary As Byte()
C#
public byte[] ValueBinary {get; set;}

Example

C# Copy Code
private void Detail_Format(object sender, EventArgs e)
{
    Byte[] bytesData;
    bytesData = System.Text.Encoding.GetEncoding(932).GetBytes("0123456789");
    this.Barcode1.ValueBinary = bytesData;
}
VB.NET Copy Code
Private Sub Detail_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim bytesData As Byte()
    bytesData = System.Text.Encoding.GetEncoding(932).GetBytes("0123456789")
    Me.Barcode1.ValueBinary = bytesData
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ChartControl Class

[image]
ActiveReports 19 .NET Edition
ChartControl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

Renders a chart on the report.

Object Model

ChartControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartControl
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class ChartControl : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ChartControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Class Members

[image]
ActiveReports 19 .NET Edition
ChartControl Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

The following tables list the members exposed by ChartControl.

Public Constructors

 | Name | Description
Public Constructor | ChartControl Constructor | Initializes a new instance of the ChartControl class.
Top

Public Properties

 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the control instance from memory.
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | RenderCrossPlatform |
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Constructor

[image]
ActiveReports 19 .NET Edition
ChartControl Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartControl Constructor

Glossary Item Box

Initializes a new instance of the ChartControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Methods

[image]
ActiveReports 19 .NET Edition
ChartControl Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

For a list of all members of this type, see ChartControl members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the control instance from memory.
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | RenderCrossPlatform |
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Dispose() Method

Glossary Item Box

Releases the control instance from memory.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Dispose()
C#
public new void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Load Method

filename
The name of the file from which to load the chart.

Glossary Item Box

Reconstructs a chart object from the specified file.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   ByVal filename As String _
)
C#
public void Load(
   string filename
)

Parameters

filename
The name of the file from which to load the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


RenderCrossPlatform Method

[image]
ActiveReports 19 .NET Edition
RenderCrossPlatform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : RenderCrossPlatform Method

page
boundsRect
pageOffset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RenderCrossPlatform( _
   ByVal page As DrawCanvas, _
   ByVal boundsRect As Rectangle, _
   ByVal pageOffset As PointF _
)
C#
public void RenderCrossPlatform(
   DrawCanvas page,
   Rectangle boundsRect,
   PointF pageOffset
)

Parameters

page
boundsRect
pageOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Restart Method

[image]
ActiveReports 19 .NET Edition
Restart Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Restart Method

Glossary Item Box

Resets the chart data source and restarts chart processing.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
C#
public void Restart()

Remarks

This method is obsolete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Save Method

filename
The name of the file to which the chart is to be saved.

Glossary Item Box

Creates an XML encoding of the chart object and its current state (without data).

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal filename As String _
)
C#
public void Save(
   string filename
)

Parameters

filename
The name of the file to which the chart is to be saved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Properties

[image]
ActiveReports 19 .NET Edition
ChartControl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

For a list of all members of this type, see ChartControl members.

Public Properties

 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoRefresh Property

[image]
ActiveReports 19 .NET Edition
AutoRefresh Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : AutoRefresh Property

Glossary Item Box

Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.

Syntax

Visual Basic (Declaration)
Public Property AutoRefresh As Boolean
C#
public bool AutoRefresh {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Backdrop Property

Glossary Item Box

Gets or sets the BackdropItem used for the background of the chart control.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


BlackAndWhiteMode Property

[image]
ActiveReports 19 .NET Edition
BlackAndWhiteMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : BlackAndWhiteMode Property

Glossary Item Box

Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.

Syntax

Visual Basic (Declaration)
Public Property BlackAndWhiteMode As Boolean
C#
public bool BlackAndWhiteMode {get; set;}

Property Value

A Boolean value. The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartAreas Property

[image]
ActiveReports 19 .NET Edition
ChartAreas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartAreas Property

Glossary Item Box

A collection of ChartArea objects drawn in the chart control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartAreas As ChartAreasCollection
C#
public ChartAreasCollection ChartAreas {get;}

Property Value

The chart areas.

Remarks

By default, one ChartArea is included in the ChartAreas collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartBorder Property

[image]
ActiveReports 19 .NET Edition
ChartBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartBorder Property

Glossary Item Box

Gets or sets the border used to draw around the chart.

Syntax

Visual Basic (Declaration)
Public Property ChartBorder As Border
C#
public Border ChartBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ColorPalette Property

[image]
ActiveReports 19 .NET Edition
ColorPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ColorPalette Property

Glossary Item Box

Gets or sets the color palette enumeration used for the series.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As ColorPalette
C#
public ColorPalette ColorPalette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members
ColorPalette Enumeration


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Culture Property

Glossary Item Box

Gets or sets the culture for the chart control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : DataSource Property

Glossary Item Box

Gets or sets the global data source for the chart.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


GridLayout Property

[image]
ActiveReports 19 .NET Edition
GridLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : GridLayout Property

Glossary Item Box

Gets or sets the GridLayout object for the chart.

Syntax

Visual Basic (Declaration)
Public Property GridLayout As GridLayout
C#
public GridLayout GridLayout {get; set;}

Property Value

The grid layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ImageType Property

[image]
ActiveReports 19 .NET Edition
ImageType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ImageType Property

Glossary Item Box

Sets or returns the type of image to which the chart will be rendered on the report.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageTypes
C#
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.

Remarks

Some images can be a problem when exported as a metafile due to some graphic commands which are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Legends Property

[image]
ActiveReports 19 .NET Edition
Legends Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Legends Property

Glossary Item Box

Gets or sets the legend object for the chart control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legends As LegendsCollection
C#
public LegendsCollection Legends {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Series Property

[image]
ActiveReports 19 .NET Edition
Series Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Series Property

Glossary Item Box

Gets the series collection for the chart object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Series As SeriesCollection
C#
public SeriesCollection Series {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Titles Property

[image]
ActiveReports 19 .NET Edition
Titles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Titles Property

Glossary Item Box

Gets the titles collection for the SharpGraph object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Titles As TitlesCollection
C#
public TitlesCollection Titles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


UIOptions Property

[image]
ActiveReports 19 .NET Edition
UIOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : UIOptions Property

Glossary Item Box

Gets or sets specific user interface features for the chart.

Syntax

Visual Basic (Declaration)
Public Property UIOptions As UIOptions
C#
public UIOptions UIOptions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


CheckBox Class

[image]
ActiveReports 19 .NET Edition
CheckBox Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

Checkbox is used to print Boolean values as checked or unchecked.

Object Model

CheckBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckBox
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class CheckBox : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
   Me.CheckBox1.Checked = True
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   Me.CheckBox1.Text = "CheckBox"
   Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Class Members

[image]
ActiveReports 19 .NET Edition
CheckBox Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor | Initializes a new instance of the CheckBox class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Constructor

[image]
ActiveReports 19 .NET Edition
CheckBox Constructor
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckBox Constructor

Glossary Item Box

Initializes a new instance of the CheckBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CheckBox()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
    Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
    Me.CheckBox1.Checked = True
    Me.CheckBox1.ClassName = "Normal"
    Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
    Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
    Me.CheckBox1.Text = "CheckBox"
    Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
    'With the properties above set, the Style string would be:
    'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

[image]
ActiveReports 19 .NET Edition
CheckBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckAlignment Property

[image]
ActiveReports 19 .NET Edition
CheckAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckAlignment Property

Glossary Item Box

Gets or sets the alignment of the checkbox text within the control drawing area.

Syntax

Visual Basic (Declaration)
Public Property CheckAlignment As ContentAlignment
C#
public ContentAlignment CheckAlignment {get; set;}

Property Value

Current alignment setting. Default is System.Drawing.ContentAlignment.MiddleLeft.

Possible values are:

  • System.Drawing.ContentAlignment.BottomCenter
  • System.Drawing.ContentAlignment.BottomLeft
  • System.Drawing.ContentAlignment.BottomRight
  • System.Drawing.ContentAlignment.MiddleCenter
  • System.Drawing.ContentAlignment.MiddleLeft
  • System.Drawing.ContentAlignment.MiddleRight
  • System.Drawing.ContentAlignment.TopCenter
  • System.Drawing.ContentAlignment.TopLeft
  • System.Drawing.ContentAlignment.TopRight

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Checked Property

Glossary Item Box

Gets or sets a value indicating the state of the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
C#
public bool Checked {get; set;}

Property Value

Boolean. True if the check box is in the checked state; otherwise, False. The default value is False.

Remarks

When the value is True, the check box portion of the control displays a check mark.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Checked = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Checked = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".

Remarks

Style classes are defined in the report's Stylesheet.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members
StyleSheet Property


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control's text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

System.Drawing.Font

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color

Remarks

This property sets the color for both the text and the checkbox in the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Padding Property

Glossary Item Box

Gets or sets the number of points of padding to use on each side of the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Style Property

Glossary Item Box

Gets or sets a style string for the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Text Property

Glossary Item Box

Gets or sets the printed caption of the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

String. Current caption of the checkbox.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Text = "CheckBox";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Text = "CheckBox"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ControlCollection Class

[image]
ActiveReports 19 .NET Edition
ControlCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

Represents a collection of ARControl objects.

Object Model

ControlCollection Class

Syntax

Visual Basic (Declaration)
Public Class ControlCollection
   Inherits System.Collections.CollectionBase
C#
public class ControlCollection : System.Collections.CollectionBase

Remarks

The GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection~Add.html and GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection~Remove.html methods enable you to add or remove controls from the collection. You can also use the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection~AddRange.html or GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection~Clear methods to add or remove all controls from the collection.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ControlCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Class Members

[image]
ActiveReports 19 .NET Edition
ControlCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

The following tables list the members exposed by ControlCollection.

Public Constructors

 | Name | Description
Public Constructor | ControlCollection Constructor | Initializes a new instance of the ControlCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | Dispose | Releases an instance of the control from the memory.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top

Public Events

 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Constructor

[image]
ActiveReports 19 .NET Edition
ControlCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : ControlCollection Constructor

section
The report section in which the control collection resides.

Glossary Item Box

Initializes a new instance of the ControlCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal section As Section _
)
C#
public ControlCollection(
   Section section
)

Parameters

section
The report section in which the control collection resides.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ControlCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | Dispose | Releases an instance of the control from the memory.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Add Method

control
The GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ARControl.html to add to the collection.

Glossary Item Box

Adds the specified control to the control collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal control As ARControl _
)
C#
public void Add(
   ARControl control
)

Parameters

control
The GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ARControl.html to add to the collection.

Remarks

The Add method adds the control to the end of the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : AddRange Method

controls
An array of GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ARControl.html objects to add to the collection.

Glossary Item Box

Adds an array of ARControl objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal controls() As ARControl _
)
C#
public void AddRange(
   ARControl[] controls
)

Parameters

controls
An array of GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ARControl.html objects to add to the collection.

Remarks

The GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ARControl.html objects in the array are appended to the end of the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    //array initialization is one-based, while array access is zero-based
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Clear Method

Glossary Item Box

Removes all controls which were added to the collection using the Add method.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Remarks

To remove individual controls from the collection, use the GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection~Remove.html method.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Sections[0].Controls.Clear();
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Sections(0).Controls.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Contains Method

control
The control to locate in the collection.

Glossary Item Box

Determines whether the specified control is a member of the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal control As ARControl _
) As Boolean
C#
public bool Contains(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

Boolean. Returns True if the control is a member of the collection; otherwise, False.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);

    if (this.Sections[0].Controls.Contains(t))
    {
        System.Windows.Forms.MessageBox.Show("t");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    If Me.Sections(0).Controls.Contains(t) Then
        MessageBox.Show("t")
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : CopyTo Method

values
The array containing the copied controls.
index

The insertion index in the collection.

Glossary Item Box

Copies the controls collection from the specified report to a controls collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal values() As ARControl, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   ARControl[] values,
   int index
)

Parameters

values
The array containing the copied controls.
index

The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Dispose() Method

Glossary Item Box

Releases an instance of the control from the memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : IndexOf Method

control
The control to locate in the collection.

Glossary Item Box

Retrieves the index of the specified control in the control collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal control As ARControl _
) As Integer
C#
public int IndexOf(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

A zero-based value that represents the position of the specified control in the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
    System.Windows.Forms.MessageBox.Show (this.Sections[0].Controls.IndexOf(t).ToString());
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    MessageBox.Show(Me.Sections(0).Controls.IndexOf(t))
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Insert Method

index
Index to which the control should be inserted.
control
Control to be inserted.

Glossary Item Box

Inserts the control specified in the value parameter at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal control As ARControl _
)
C#
public void Insert(
   int index,
   ARControl control
)

Parameters

index
Index to which the control should be inserted.
control
Control to be inserted.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t2 = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    t2.Text="Insert some more text here.";
    t2.Left=1;
    this.Sections[0].Controls.Add (t);
    this.Sections[0].Controls.Insert(1,t2);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    Dim t2 As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    t2.Text = "Insert some more text here."
    t2.Left = 1
    Me.Sections(0).Controls.Add(t)
    Me.Sections(0).Controls.Insert(0, t2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Remove Method

control
The control to be removed from the collection.

Glossary Item Box

Removes the specified control from the control collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal control As ARControl _
)
C#
public void Remove(
   ARControl control
)

Parameters

control
The control to be removed from the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove the checkbox
    this.Sections[0].Controls.Remove(arr[0]);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove the specified control
    Me.Sections(0).Controls.Remove(c)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : RemoveAt Method

index
The index of the control to be removed.

Glossary Item Box

Removes the control from the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public new void RemoveAt(
   int index
)

Parameters

index
The index of the control to be removed.

Example

C# Copy Code
private void arReport_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove a control from a specified location
    this.Sections[0].Controls.RemoveAt(1);
}
Visual Basic Copy Code
Private Sub rptReport_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove a control from the specified location
    Me.Sections(0).Controls.RemoveAt(1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ControlCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Item Property

Glossary Item Box

Returns a control in the collection at the specified index or with a specified name.

Overload List

Overload | Description
Item(Int32) | Gets the Control object at the specified indexed location in the ControlCollection.
Item(String) | Gets the Control object with the specified name in the ControlCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(Int32) Property

index
The indexed location of the Control in the collection.

Glossary Item Box

Gets the Control object at the specified indexed location in the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ARControl
C#
public ARControl Item(
   int index
) {get;}

Parameters

index
The indexed location of the Control in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(String) Property

name
The name of the Control in the collection.

Glossary Item Box

Gets the Control object with the specified name in the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ARControl
C#
public ARControl Item(
   string name
) {get;}

Parameters

name
The name of the Control in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


ControlCollection Class Events

[image]
ActiveReports 19 .NET Edition
ControlCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Events

 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Changed Event

Glossary Item Box

Raised when an ARControl is added to or removed from the collection.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


CrossSectionBox Class

[image]
ActiveReports 19 .NET Edition
CrossSectionBox Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

The CrossSectionBox control renders a rectangular outline with its corners where you place them in the header and footer sections, and its vertical lines growing with intervening sections.

Object Model

CrossSectionBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CrossSectionBox
   Inherits CrossSectionControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class CrossSectionBox : CrossSectionControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Class Members

[image]
ActiveReports 19 .NET Edition
CrossSectionBox Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

The following tables list the members exposed by CrossSectionBox.

Public Constructors

 | Name | Description
Public Constructor | CrossSectionBox Constructor | Initializes a new instance of the CrossSectionBox class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | CloseBorder | Sets or Gets the state borders
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Top

Public Methods

 | Name | Description
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Constructor

[image]
ActiveReports 19 .NET Edition
CrossSectionBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : CrossSectionBox Constructor

Glossary Item Box

Initializes a new instance of the CrossSectionBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CrossSectionBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Methods

[image]
ActiveReports 19 .NET Edition
CrossSectionBox Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

For a list of all members of this type, see CrossSectionBox members.

Public Methods

 | Name | Description
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GetDoubleRadius Method

[image]
ActiveReports 19 .NET Edition
GetDoubleRadius Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : GetDoubleRadius Method

Glossary Item Box

Gets the run-time value of the radius property.

Syntax

Visual Basic (Declaration)
Public Function GetDoubleRadius() As Single
C#
public float GetDoubleRadius()

Return Value

A Single or float value in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Properties

[image]
ActiveReports 19 .NET Edition
CrossSectionBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

For a list of all members of this type, see CrossSectionBox members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | CloseBorder | Sets or Gets the state borders
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CloseBorder Property

[image]
ActiveReports 19 .NET Edition
CloseBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : CloseBorder Property

Glossary Item Box

Sets or Gets the state borders

Syntax

Visual Basic (Declaration)
Public Property CloseBorder As Boolean
C#
public bool CloseBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


Radius Property

[image]
ActiveReports 19 .NET Edition
Radius Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : Radius Property

Glossary Item Box

Set the Radius property to control the degree of rounding on the corners of the box.

Syntax

Visual Basic (Declaration)
Public Property Radius As CornersRadius
C#
public CornersRadius Radius {get; set;}

Property Value

An integer value in points.

Requirements

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionControl Class

[image]
ActiveReports 19 .NET Edition
CrossSectionControl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

ARControl is the base class for ActiveReports CrossSection controls. You should not need to use this class in your application.

Object Model

CrossSectionControl Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class CrossSectionControl
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public abstract class CrossSectionControl : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Members

[image]
ActiveReports 19 .NET Edition
CrossSectionControl Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

The following tables list the members exposed by CrossSectionControl.

Public Properties

 | Name | Description
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Width | Gets or sets the width of the control in inches.
Top

See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Properties

[image]
ActiveReports 19 .NET Edition
CrossSectionControl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

For a list of all members of this type, see CrossSectionControl members.

Public Properties

 | Name | Description
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Width | Gets or sets the width of the control in inches.
Top

See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


End Property

[image]
ActiveReports 19 .NET Edition
End Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : End Property

Glossary Item Box

The ending position of the cross section control in the footer section.

Syntax

Visual Basic (Declaration)
Public Property End As PointF
C#
public PointF End {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Left Property

Glossary Item Box

Gets or sets the left position of the control in inches.

Syntax

Visual Basic (Declaration)
Public Shadows Property Left As Single
C#
public new float Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineColor Property

Glossary Item Box

Gets or sets the color of the control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineStyle Property

[image]
ActiveReports 19 .NET Edition
LineStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineWeight Property

[image]
ActiveReports 19 .NET Edition
LineWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Start Property

[image]
ActiveReports 19 .NET Edition
Start Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Start Property

Glossary Item Box

Gets or sets the starting position of the cross section control in the header section.

Syntax

Visual Basic (Declaration)
Public Property Start As PointF
C#
public PointF Start {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Top Property

Glossary Item Box

Gets or sets, in inches, the top position of the control relative to the section that contains it.

Syntax

Visual Basic (Declaration)
Public Shadows Property Top As Single
C#
public new float Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Width Property

Glossary Item Box

Gets or sets the width of the control in inches.

Syntax

Visual Basic (Declaration)
Public Shadows Property Width As Single
C#
public new float Width {get; set;}

Property Value

A float or Single value in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


CrossSectionLine Class

[image]
ActiveReports 19 .NET Edition
CrossSectionLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

The CrossSectionLine control renders a vertical line that begins where you place it in a header section, grows with any intervening sections, and ends where you place it in the related footer section.

Object Model

CrossSectionLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CrossSectionLine
   Inherits CrossSectionControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class CrossSectionLine : CrossSectionControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionLine Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Members

[image]
ActiveReports 19 .NET Edition
CrossSectionLine Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

The following tables list the members exposed by CrossSectionLine.

Public Constructors

 | Name | Description
Public Constructor | CrossSectionLine Constructor | Initializes a new instance of the CrossSectionLine class.
Top

See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Constructor

[image]
ActiveReports 19 .NET Edition
CrossSectionLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionLine Class : CrossSectionLine Constructor

Glossary Item Box

Initializes a new instance of the CrossSectionLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CrossSectionLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionLine Class
CrossSectionLine Members


CustomControl Class

[image]
ActiveReports 19 .NET Edition
CustomControl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

CustomControl is a wrapper class that allows you to print .NET controls that inherit from System.Windows.Forms.Control

Object Model

CustomControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomControl
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class CustomControl : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Class Members

[image]
ActiveReports 19 .NET Edition
CustomControl Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

The following tables list the members exposed by CustomControl.

Public Constructors

 | Name | Description
Public Constructor | CustomControl Constructor | Overloaded. Initializes a new instance of the CustomControl class.
Top

Public Properties

 | Name | Description
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Type | Sets or returns the type of the custom control.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SetProperty |
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Constructor

[image]
ActiveReports 19 .NET Edition
CustomControl Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : CustomControl Constructor

Glossary Item Box

Initializes a new instance of the CustomControl class.

Overload List

Overload | Description
CustomControl Constructor(Type) | Initializes a new instance of the specified type of CustomControl class.
CustomControl Constructor() | Initializes a new instance of the CustomControl class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


CustomControl Constructor(Type)

[image]
ActiveReports 19 .NET Edition
CustomControl Constructor(Type)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor(Type)

type
Specifies the type of the control to be created.

Glossary Item Box

Initializes a new instance of the specified type of CustomControl class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type _
)
C#
public CustomControl(
   Type type
)

Parameters

type
Specifies the type of the control to be created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Constructor()

[image]
ActiveReports 19 .NET Edition
CustomControl Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor()

Glossary Item Box

Initializes a new instance of the CustomControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Class Methods

[image]
ActiveReports 19 .NET Edition
CustomControl Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

For a list of all members of this type, see CustomControl members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SetProperty |
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SetProperty Method

[image]
ActiveReports 19 .NET Edition
SetProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : SetProperty Method

obj
propertyName
val

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub SetProperty( _
   ByVal obj As Object, _
   ByVal propertyName As String, _
   ByVal val As Object _
)
C#
public static void SetProperty(
   object obj,
   string propertyName,
   object val
)

Parameters

obj
propertyName
val

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


CustomControl Class Properties

[image]
ActiveReports 19 .NET Edition
CustomControl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

For a list of all members of this type, see CustomControl members.

Public Properties

 | Name | Description
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Type | Sets or returns the type of the custom control.
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Control Property

[image]
ActiveReports 19 .NET Edition
Control Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Control Property

Glossary Item Box

Gets or sets a reference to the hosted control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Object
C#
public object Control {get;}

Example

C# Copy Code
private void Detail1_Format(object sender,System.EventArgs e)
{
 DataTable dt = new DataTable();
 dt.Columns.Add("Name", typeof(string));
 dt.Columns.Add("Age", typeof(int));
 dt.Rows.Add("Name1", 23);
 dt.Rows.Add("Name2", 34);
 System.Windows.Forms.DataGridView gridView = ((System.Windows.Forms.DataGridView)this.customControl1.Control);
 gridView.DataSource = dt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
Dim dt As New DataTable()
dt.Columns.Add("Name", GetType(String))
dt.Columns.Add("Age", GetType(Integer))
dt.Rows.Add("Name1", 23)
dt.Rows.Add("Name2", 34)
Dim gridView As System.Windows.Forms.DataGridView = DirectCast(Me.customControl1.Control, System.Windows.Forms.DataGridView)
gridView.DataSource = dt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members

How To

Use Custom Controls on Reports (TreeView)


ImageType Property

[image]
ActiveReports 19 .NET Edition
ImageType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : ImageType Property

Glossary Item Box

Sets or returns the type of image to which the chart will be rendered on the report.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageTypes
C#
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.

Remarks

Some images can be a problem when exported as a metafile due to some graphic commands that are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Type Property

Glossary Item Box

Sets or returns the type of the custom control.

Syntax

Visual Basic (Declaration)
Public Property Type As Type
C#
public Type Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


Detail Class

[image]
ActiveReports 19 .NET Edition
Detail Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

Detail section is the main section in a report. It is printed once for each record in the data source.

Object Model

Detail Class

Syntax

Visual Basic (Declaration)
Public Class Detail
   Inherits Section
C#
public class Detail : Section

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.After;
    this.detail.NewPage = NewPage.Before;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 1
   Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
   Me.Detail1.ColumnSpacing = 1
   Me.Detail1.KeepTogether = True
   Me.Detail1.NewColumn = NewColumn.After
   Me.Detail1.NewPage = NewPage.Before
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Members

[image]
ActiveReports 19 .NET Edition
Detail Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

The following tables list the members exposed by Detail.

Public Constructors

 | Name | Description
Public Constructor | Detail Constructor | Initializes a new instance of the Detail class.
Top

Public Properties

Name | Description
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Constructor

[image]
ActiveReports 19 .NET Edition
Detail Constructor
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : Detail Constructor

Glossary Item Box

Initializes a new instance of the Detail class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Detail()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.None;
    this.detail.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.ColumnCount = 1
    Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
    Me.Detail1.ColumnSpacing = 1
    Me.Detail1.KeepTogether = True
    Me.Detail1.NewColumn = NewColumn.None
    Me.Detail1.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


Detail Class Properties

[image]
ActiveReports 19 .NET Edition
Detail Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

For a list of all members of this type, see Detail members.

Public Properties

Name | Description
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnCount Property

[image]
ActiveReports 19 .NET Edition
ColumnCount Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnCount Property

Glossary Item Box

Gets or sets a value that specifies the number of newspaper columns in the report.

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
C#
public int ColumnCount {get; set;}

Property Value

Integer value that represents the current number of columns in the report; default is 1.

Remarks

This property can be used to print labels or phonebook-style listings. The width of each column equals the PrintWidth of the report divided by the number of columns.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail.ColumnCount = 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


ColumnDirection Property

[image]
ActiveReports 19 .NET Edition
ColumnDirection Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnDirection Property

Glossary Item Box

Determines how ActiveReports should print the detail section in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Property ColumnDirection As ColumnDirection
C#
public ColumnDirection ColumnDirection {get; set;}

Property Value

ColumnDirection enumeration value that specifies whether the report will be printed across or down; default is ColumnDirection.DownAcross.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnDirection = ColumnDirection.AcrossDown;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnDirection = ColumnDirection.AcrossDown
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


ColumnSpacing Property

[image]
ActiveReports 19 .NET Edition
ColumnSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnSpacing Property

Glossary Item Box

Sets or returns the space between columns in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Property ColumnSpacing As Single
C#
public float ColumnSpacing {get; set;}

Property Value

A single value that represents the space between columns.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnSpacing = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnSpacing = 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


NewColumn Property

[image]
ActiveReports 19 .NET Edition
NewColumn Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewColumn = NewColumn.BeforeAfter;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewColumn = NewColumn.BeforeAfter
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewPage = NewPage.BeforeAfter;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewPage = NewPage.BeforeAfter
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


RepeatToFill Property

[image]
ActiveReports 19 .NET Edition
RepeatToFill Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : RepeatToFill Property

Glossary Item Box

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Syntax

Visual Basic (Declaration)
Public Property RepeatToFill As Boolean
C#
public bool RepeatToFill {get; set;}

Property Value

A Boolean value. True if the section will print formatting to fill the page if its contents permit; otherwise, False.

Remarks

Note: The RepeatToFill property cannot be used if the PageBreak or SubReport control is used in the Detail section, or if the NewPage or NewColumn property is set to any value other than None.

When you use this property when two groups are present, the second GroupFooter section is always on the next page. It processes correctly only with a single grouping. The ReportFooter section also prints on the next page when you set this property to True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


GroupFooter Class

[image]
ActiveReports 19 .NET Edition
GroupFooter Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

The GroupFooter section is directly related to the Detail section and its matching group header. It prints once each time a group of similar records (as defined in the GroupHeader.DataField property) ends. A GroupFooter section cannot exist without a matching GroupHeader section.

Object Model

GroupFooter Class

Syntax

Visual Basic (Declaration)
Public Class GroupFooter
   Inherits Section
C#
public class GroupFooter : Section

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.KeepTogether = True
   Me.GroupFooter1.NewColumn = NewColumn.None
   Me.GroupFooter1.NewPage = NewPage.None
   Me.GroupFooter1.PrintAtBottom = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Members

[image]
ActiveReports 19 .NET Edition
GroupFooter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

The following tables list the members exposed by GroupFooter.

Public Constructors

 | Name | Description
Public Constructor | GroupFooter Constructor | Initializes a new instance of the GroupFooter class.
Top

Public Properties

 | Name | Description
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Constructor

[image]
ActiveReports 19 .NET Edition
GroupFooter Constructor
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : GroupFooter Constructor

Glossary Item Box

Initializes a new instance of the GroupFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GroupFooter()

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.GroupFooter1.ColumnLayout = True
    Me.GroupFooter1.KeepTogether = True
    Me.GroupFooter1.NewColumn = NewColumn.None
    Me.GroupFooter1.NewPage = NewPage.None
    Me.GroupFooter1.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


GroupFooter Class Properties

[image]
ActiveReports 19 .NET Edition
GroupFooter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

For a list of all members of this type, see GroupFooter members.

Public Properties

 | Name | Description
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnLayout Property

[image]
ActiveReports 19 .NET Edition
ColumnLayout Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : ColumnLayout Property

Glossary Item Box

Gets or sets a value to determine whether the section should use the same column layout of its detail section.

Syntax

Visual Basic (Declaration)
Public Property ColumnLayout As Boolean
C#
public bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : Height Property

Glossary Item Box

Gets or sets the height of the group footer.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


NewColumn Property

[image]
ActiveReports 19 .NET Edition
NewColumn Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.NewColumn = NewColumn.After;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.NewColumn = NewColumn.After
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.NewPage = NewPage.Before;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.NewPage = NewPage.Before
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True if the footer section will be printed at the bottom of the page; otherwise, False.

Remarks

Setting more than one group footer section in a report layout to print at the bottom of the page will cause subsequent group footer sections to print on separate pages.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


GroupHeader Class

[image]
ActiveReports 19 .NET Edition
GroupHeader Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

The GroupHeader section prints once for every data group defined using the field specified in DataField property. A GroupHeader section requires a matching GroupFooter section.

Object Model

GroupHeader Class

Syntax

Visual Basic (Declaration)
Public Class GroupHeader
   Inherits Section
C#
public class GroupHeader : Section

Remarks

Since ActiveReports does not sort the data before grouping it, your data source should be sorted on all the data fields that you have specified in group header sections. For example, for a report to properly create two groups on Country and City data fields you must sort the data by those data fields in the specified order. If your data is not sorted you end up with the same group appearing multiple times in the report at different locations (i.e. the report is NOT grouped).

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
   Me.GroupHeader1.KeepTogether = True
   Me.GroupHeader1.NewColumn = NewColumn.None
   Me.GroupHeader1.NewPage = NewPage.None
   Me.GroupHeader1.RepeatStyle = RepeatStyle.None
   Me.GroupHeader1.UnderlayNext = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Members

[image]
ActiveReports 19 .NET Edition
GroupHeader Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

The following tables list the members exposed by GroupHeader.

Public Constructors

 | Name | Description
Public Constructor | GroupHeader Constructor | Initializes a new instance of the GroupHeader class.
Top

Public Properties

 | Name | Description
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Constructor

[image]
ActiveReports 19 .NET Edition
GroupHeader Constructor
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupHeader Constructor

Glossary Item Box

Initializes a new instance of the GroupHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GroupHeader()

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.DataField = "Country";
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    Me.GroupHeader1.ColumnLayout = True
    Me.GroupHeader1.DataField = "Country"
    Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
    Me.GroupHeader1.KeepTogether = True
    Me.GroupHeader1.NewColumn = NewColumn.None
    Me.GroupHeader1.NewPage = NewPage.None
    Me.GroupHeader1.RepeatStyle = RepeatStyle.None
    Me.GroupHeader1.UnderlayNext = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


GroupHeader Class Properties

[image]
ActiveReports 19 .NET Edition
GroupHeader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

For a list of all members of this type, see GroupHeader members.

Public Properties

 | Name | Description
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnGroupKeepTogether Property

[image]
ActiveReports 19 .NET Edition
ColumnGroupKeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnGroupKeepTogether Property

Glossary Item Box

Gets or sets a value that specifies whether the group will print as a single block in the same column.

Syntax

Visual Basic (Declaration)
Public Property ColumnGroupKeepTogether As Boolean
C#
public bool ColumnGroupKeepTogether {get; set;}

Property Value

Boolean.

Remarks

The Boolean ColumnGroupKeepTogether property will only be implemented when the GroupHeader's GroupKeepTogether property is set to All.

The purpose of this property is to prevent a group from splitting across columns. If the group will not fit in the current column, ActiveReports will attempt to render the full group in the next column. If the group is too large to fit in a single column, this property will be ignored.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.All;
    this.groupHeader1.ColumnGroupKeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.All
   Me.GroupHeader1.ColumnGroupKeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


ColumnLayout Property

[image]
ActiveReports 19 .NET Edition
ColumnLayout Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnLayout Property

Glossary Item Box

Gets or sets a value to determine whether the section should use the same column layout as its detail section.

Syntax

Visual Basic (Declaration)
Public Property ColumnLayout As Boolean
C#
public bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


DataField Property

[image]
ActiveReports 19 .NET Edition
DataField Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : DataField Property

Glossary Item Box

Gets or sets the name of the field used to group the data source records.

Syntax

Visual Basic (Declaration)
Public Property DataField As String
C#
public string DataField {get; set;}

Property Value

A string value that represents the name of the field to be grouped.

Remarks

ActiveReports checks for any changes in the value of the specified field and starts a new group when the value changes. Current groups are ended (i.e. the group footer section is printed) before the new group is started.

The specified field can originate from the data source or an unbound field added to the Fields collection in the DataInitialize event.

Example

C# Copy Code
private void rptSection_ReportStart(object sender, System.EventArgs eArgs)
{
  this.groupHeader1.DataField = "Country";
}
Visual Basic Copy Code
Private Sub rptSection_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
 Me.GroupHeader1.DataField = "Country"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


GroupKeepTogether Property

[image]
ActiveReports 19 .NET Edition
GroupKeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupKeepTogether Property

Glossary Item Box

Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.

Syntax

Visual Basic (Declaration)
Public Property GroupKeepTogether As GroupKeepTogether
C#
public GroupKeepTogether GroupKeepTogether {get; set;}

Property Value

GroupKeepTogether enumeration. Default is GroupKeepTogether.None. Possible values are:

  • GroupKeepTogether.All
  • GroupKeepTogether.FirstDetail
  • GroupKeepTogether.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : Height Property

Glossary Item Box

Gets or sets the height of the group header.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


NewColumn Property

[image]
ActiveReports 19 .NET Edition
NewColumn Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

A NewColumn enumeration value that determines the behavior of column breaks before or after printing the section. The default value is NewColumn.None. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.NewColumn = NewColumn.None;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.NewColumn = NewColumn.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


RepeatStyle Property

[image]
ActiveReports 19 .NET Edition
RepeatStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : RepeatStyle Property

Glossary Item Box

Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.

Syntax

Visual Basic (Declaration)
Public Property RepeatStyle As RepeatStyle
C#
public RepeatStyle RepeatStyle {get; set;}

Property Value

A RepeatStyle enumeration. The default value is RepeatStyle.None. Possible values are:

  • RepeatStyle.All
  • RepeatStyle.None
  • RepeatStyle.OnColumn
  • RepeatStyle.OnPage
  • RepeatStyle.OnPageIncludeNoDetail (prevents orphaned footers)

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.RepeatStyle =  RepeatStyle.OnPageIncludeNoDetail;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


UnderlayNext Property

[image]
ActiveReports 19 .NET Edition
UnderlayNext Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : UnderlayNext Property

Glossary Item Box

Gets or sets a value that specifies whether the section should print underneath the following section.

Syntax

Visual Basic (Declaration)
Public Property UnderlayNext As Boolean
C#
public bool UnderlayNext {get; set;}

Property Value

A Boolean value. True if the following section will start rendering at the top of this section; otherwise, False.

Remarks

If this property is set to True, be sure that the next section's BackColor is set to System.Drawing.Color.Transparent. Otherwise, the GroupHeader will be hidden behind the next section.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.UnderlayNext = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


InputField Class

[image]
ActiveReports 19 .NET Edition
InputField Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputField Class

Glossary Item Box

Base input field component

Object Model

InputField Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class InputField
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public abstract class InputField : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.InputField
GrapeCity.ActiveReports.SectionReportModel.InputFieldCheckBox
GrapeCity.ActiveReports.SectionReportModel.InputFieldText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Members
GrapeCity.ActiveReports.SectionReportModel Namespace


InputField Class Members

[image]
ActiveReports 19 .NET Edition
InputField Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputField Class

Glossary Item Box

The following tables list the members exposed by InputField.

Public Properties

 | Name | Description
Public Property | BackColor | Background color
Public Property | BorderColor | Border color
Public Property | BorderStyle | Border style
Public Property | BorderWidth | Border width
Public Property | FieldName | Specifies the unique name of the field.
Public Property | ForeColor | Font color
Public Property | ReadOnly | Prevents the user from changing the form field content.
Public Property | Required | Forces the user to fill in the selected field.
Public Property | TabIndex | Specifies the tab index.
Top

See Also

Reference

InputField Class
GrapeCity.ActiveReports.SectionReportModel Namespace


InputField Class Properties

[image]
ActiveReports 19 .NET Edition
InputField Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputField Class

Glossary Item Box

For a list of all members of this type, see InputField members.

Public Properties

 | Name | Description
Public Property | BackColor | Background color
Public Property | BorderColor | Border color
Public Property | BorderStyle | Border style
Public Property | BorderWidth | Border width
Public Property | FieldName | Specifies the unique name of the field.
Public Property | ForeColor | Font color
Public Property | ReadOnly | Prevents the user from changing the form field content.
Public Property | Required | Forces the user to fill in the selected field.
Public Property | TabIndex | Specifies the tab index.
Top

See Also

Reference

InputField Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : BackColor Property

Glossary Item Box

Background color

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


BorderColor Property

[image]
ActiveReports 19 .NET Edition
BorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : BorderColor Property

Glossary Item Box

Border color

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
C#
public Color BorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


BorderStyle Property

[image]
ActiveReports 19 .NET Edition
BorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : BorderStyle Property

Glossary Item Box

Border style

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As InputBorderStyle
C#
public InputBorderStyle BorderStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


BorderWidth Property

[image]
ActiveReports 19 .NET Edition
BorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : BorderWidth Property

Glossary Item Box

Border width

Syntax

Visual Basic (Declaration)
Public Property BorderWidth As Single
C#
public float BorderWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


FieldName Property

[image]
ActiveReports 19 .NET Edition
FieldName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : FieldName Property

Glossary Item Box

Specifies the unique name of the field.

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
C#
public string FieldName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : ForeColor Property

Glossary Item Box

Font color

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


ReadOnly Property

[image]
ActiveReports 19 .NET Edition
ReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : ReadOnly Property

Glossary Item Box

Prevents the user from changing the form field content.

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


Required Property

[image]
ActiveReports 19 .NET Edition
Required Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : Required Property

Glossary Item Box

Forces the user to fill in the selected field.

Syntax

Visual Basic (Declaration)
Public Property Required As Boolean
C#
public bool Required {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


TabIndex Property

[image]
ActiveReports 19 .NET Edition
TabIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputField Class : TabIndex Property

Glossary Item Box

Specifies the tab index.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputField Class
InputField Members


InputFieldCheckBox Class

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBox Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldCheckBox Class

Glossary Item Box

CheckBox input field component

Object Model

InputFieldCheckBox Class

Syntax

Visual Basic (Declaration)
Public Class InputFieldCheckBox
   Inherits InputField
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public class InputFieldCheckBox : InputField, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.InputField
GrapeCity.ActiveReports.SectionReportModel.InputFieldCheckBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


InputFieldCheckBox Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBox Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldCheckBox Class

Glossary Item Box

The following tables list the members exposed by InputFieldCheckBox.

Public Constructors

 | Name | Description
Public Constructor | InputFieldCheckBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | Checked | Shows the check box selected unless the user deselects it.
Public Property | CheckSize | Sets the size of check symbol inside the CheckBox
Public Property | CheckStyle | Sets the size of check symbol inside the CheckBox
Top

See Also

Reference

InputFieldCheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


InputFieldCheckBox Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldCheckBox Class : InputFieldCheckBox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InputFieldCheckBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBox Class
InputFieldCheckBox Members


InputFieldCheckBox Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldCheckBox Class

Glossary Item Box

For a list of all members of this type, see InputFieldCheckBox members.

Public Properties

 | Name | Description
Public Property | Checked | Shows the check box selected unless the user deselects it.
Public Property | CheckSize | Sets the size of check symbol inside the CheckBox
Public Property | CheckStyle | Sets the size of check symbol inside the CheckBox
Top

See Also

Reference

InputFieldCheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldCheckBox Class : Checked Property

Glossary Item Box

Shows the check box selected unless the user deselects it.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
C#
public bool Checked {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBox Class
InputFieldCheckBox Members


CheckSize Property

[image]
ActiveReports 19 .NET Edition
CheckSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldCheckBox Class : CheckSize Property

Glossary Item Box

Sets the size of check symbol inside the CheckBox

Syntax

Visual Basic (Declaration)
Public Property CheckSize As Single
C#
public float CheckSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBox Class
InputFieldCheckBox Members


CheckStyle Property

[image]
ActiveReports 19 .NET Edition
CheckStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldCheckBox Class : CheckStyle Property

Glossary Item Box

Sets the size of check symbol inside the CheckBox

Syntax

Visual Basic (Declaration)
Public Property CheckStyle As InputCheckStyle
C#
public InputCheckStyle CheckStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBox Class
InputFieldCheckBox Members


InputFieldText Class

[image]
ActiveReports 19 .NET Edition
InputFieldText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldText Class

Glossary Item Box

Text input field component

Object Model

InputFieldText Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InputFieldText
   Inherits InputField
   Implements GrapeCity.ActiveReports.Controls.Design.IAvailabilityInfo, GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class InputFieldText : InputField, GrapeCity.ActiveReports.Controls.Design.IAvailabilityInfo, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.InputField
GrapeCity.ActiveReports.SectionReportModel.InputFieldText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Members
GrapeCity.ActiveReports.SectionReportModel Namespace


InputFieldText Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldText Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldText Class

Glossary Item Box

The following tables list the members exposed by InputFieldText.

Public Constructors

 | Name | Description
Public Constructor | InputFieldText Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment | Text alignment
Public Property | Font | Sets/gets control's font.
Public Property | MaxLength | Specifies the maximum length of the text entered. When null, the text is not restricted to any specified length.
Public Property | MultiLine | Allows more than a single-line entry in the text field.
Public Property | OutputFormat | Used for format the Text property value
Public Property | Password | Displays the user-entered text as a series of asterisks (*)
Public Property | SpellCheck | Indicates whether the text should be spell checked during its input or not.
Public Property | Text | A field, constant or expression whose value is displayed
Top

Public Methods

 | Name | Description
Public Method | IsPropertyValueAvailable | Checks if the property value is available for this control
Top

See Also

Reference

InputFieldText Class
GrapeCity.ActiveReports.SectionReportModel Namespace


InputFieldText Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldText Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : InputFieldText Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InputFieldText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


InputFieldText Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldText Class

Glossary Item Box

For a list of all members of this type, see InputFieldText members.

Public Methods

 | Name | Description
Public Method | IsPropertyValueAvailable | Checks if the property value is available for this control
Top

See Also

Reference

InputFieldText Class
GrapeCity.ActiveReports.SectionReportModel Namespace


IsPropertyValueAvailable Method

[image]
ActiveReports 19 .NET Edition
IsPropertyValueAvailable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : IsPropertyValueAvailable Method

propertyName
value

Glossary Item Box

Checks if the property value is available for this control

Syntax

Visual Basic (Declaration)
Public Function IsPropertyValueAvailable( _
   ByVal propertyName As String, _
   ByVal value As Object _
) As Boolean
C#
public bool IsPropertyValueAvailable(
   string propertyName,
   object value
)

Parameters

propertyName
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


InputFieldText Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldText Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : InputFieldText Class

Glossary Item Box

For a list of all members of this type, see InputFieldText members.

Public Properties

 | Name | Description
Public Property | Alignment | Text alignment
Public Property | Font | Sets/gets control's font.
Public Property | MaxLength | Specifies the maximum length of the text entered. When null, the text is not restricted to any specified length.
Public Property | MultiLine | Allows more than a single-line entry in the text field.
Public Property | OutputFormat | Used for format the Text property value
Public Property | Password | Displays the user-entered text as a series of asterisks (*)
Public Property | SpellCheck | Indicates whether the text should be spell checked during its input or not.
Public Property | Text | A field, constant or expression whose value is displayed
Top

See Also

Reference

InputFieldText Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : Alignment Property

Glossary Item Box

Text alignment

Syntax

Visual Basic (Declaration)
Public Property Alignment As InputTextAlign
C#
public InputTextAlign Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : Font Property

Glossary Item Box

Sets/gets control's font.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


MaxLength Property

[image]
ActiveReports 19 .NET Edition
MaxLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : MaxLength Property

Glossary Item Box

Specifies the maximum length of the text entered. When null, the text is not restricted to any specified length.

Syntax

Visual Basic (Declaration)
Public Property MaxLength As Integer
C#
public int MaxLength {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : MultiLine Property

Glossary Item Box

Allows more than a single-line entry in the text field.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


OutputFormat Property

[image]
ActiveReports 19 .NET Edition
OutputFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : OutputFormat Property

Glossary Item Box

Used for format the Text property value

Syntax

Visual Basic (Declaration)
Public Property OutputFormat As String
C#
public string OutputFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : Password Property

Glossary Item Box

Displays the user-entered text as a series of asterisks (*)

Syntax

Visual Basic (Declaration)
Public Property Password As Boolean
C#
public bool Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


SpellCheck Property

[image]
ActiveReports 19 .NET Edition
SpellCheck Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : SpellCheck Property

Glossary Item Box

Indicates whether the text should be spell checked during its input or not.

Syntax

Visual Basic (Declaration)
Public Property SpellCheck As Boolean
C#
public bool SpellCheck {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > InputFieldText Class : Text Property

Glossary Item Box

A field, constant or expression whose value is displayed

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldText Class
InputFieldText Members


Label Class

[image]
ActiveReports 19 .NET Edition
Label Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

Prints static text on the report.

Object Model

Label Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Label
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class Label : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
    this.label1.Angle = 0;
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.ClassName = "Normal";
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    this.label1.HyperLink = "mailto:support@company.com";
    this.label1.MultiLine = false;
    this.label1.Text = "Label";
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
    this.label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
   Me.Label1.Angle = 0
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.ClassName = "Normal"
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   Me.Label1.HyperLink = "mailto:support@company.com"
   Me.Label1.MultiLine = False
   Me.Label1.Text = "Label"
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
   Me.Label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Label

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Class Members

[image]
ActiveReports 19 .NET Edition
Label Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

The following tables list the members exposed by Label.

Public Constructors

 | Name | Description
Public Constructor | Label Constructor | Initializes a new instance of the Label class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Padding | Gets or sets padding within the control.
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Style | Gets or sets a style string for the label.
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Constructor

[image]
ActiveReports 19 .NET Edition
Label Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Label Constructor

Glossary Item Box

Initializes a new instance of the Label class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Label()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Label Class Properties

[image]
ActiveReports 19 .NET Edition
Label Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

For a list of all members of this type, see Label members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Padding | Gets or sets padding within the control.
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Style | Gets or sets a style string for the label.
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As TextAlignment
C#
public TextAlignment Alignment {get; set;}

Property Value

TextAlignment enum. The default value is TextAlignment.Left. Possible values are:

  • TextAlignment.Center
  • TextAlignment.Justify
  • TextAlignment.Left
  • TextAlignment.Right

Remarks

The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
TextAlignment Property


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Angle Property

Glossary Item Box

Gets or sets the angle (slope) of the text within the control area.

Syntax

Visual Basic (Declaration)
Public Property Angle As Integer
C#
public int Angle {get; set;}

Property Value

Angle value in 1/10 of a degree. Default value is 0.

Remarks

To set a label's angle to 90 degrees, set the Angle property to 900, and be sure the height of the control will accommodate the text, as labels do not grow automatically.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Angle = 900;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Angle = 900
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the distance in points between individual characters in the label control.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Remarks

The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.

Example

C# Copy Code
private void detail1_Format(object sender, EventArgs e)
{
   this.label1.MultiLine = true;
   this.label1.CharacterSpacing = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.label1.MultiLine = True
   Me.label1.CharacterSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.

Remarks

You can use predefined styles in the report's stylesheet or add new ones to it.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

System.Drawing.Font. Current Font object used to render the control's text.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color. Default is Color.Black.

Example

C# Copy Code
private void dDetail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ForeColor = System.Drawing.Color.Brown;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ForeColor = System.Drawing.Color.Brown
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


HyperLink Property

[image]
ActiveReports 19 .NET Edition
HyperLink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Remarks

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "https://developer.mescius.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.HyperLink = "mailto:support@company.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.HyperLink = "mailto:support@company.com"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
HyperLinkEventArgs


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : LineSpacing Property

Glossary Item Box

Gets or sets the spacing in points between the lines of text within the label control.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.lblInfo.MultiLine = true;
   this.lblInfo.LineSpacing = 2;
}
VB.NET Copy Code
Private Sub detail_Format(sender As Object, e As EventArgs)
    Me.lblInfo.MultiLine = True
    Me.lblInfo.LineSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


MinCondenseRate Property

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : MinCondenseRate Property

Glossary Item Box

Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property MinCondenseRate As Integer
C#
public int MinCondenseRate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether this is a multi-line label control.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Property Value

A Boolean value. True if the label control is multiline; otherwise, False.

Remarks

A multi-line label control renders the label's text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a new line character is encountered.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.MultiLine = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.MultiLine = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Remarks

This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : RightToLeft Property

Glossary Item Box

Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ShrinkToFit Property

Glossary Item Box

Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Style Property

Glossary Item Box

Gets or sets a style string for the label.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Text Property

Glossary Item Box

Gets or sets the text of the label to be printed.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Text = "Label";
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Label1.Text = "Label"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : TextJustify Property

Glossary Item Box

Gets or sets the type of justification to use when the Alignment property is set to Justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines

Remarks

When you set the Alignment property to Justify, this property extends your justification options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Value Property

Glossary Item Box

Gets or sets the current Value of the Label control.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

Object.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Value="Title";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Value = "Title"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the label's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

Current vertical alignment of the label's text. Default is VerticalTextAlignment.Top. Possible values are:

  • VerticalTextAlignment.Bottom
  • VerticalTextAlignment.Middle
  • VerticalTextAlignment.Top

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


VerticalText Property

[image]
ActiveReports 19 .NET Edition
VerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalText Property

Glossary Item Box

Gets or sets whether the control's text is rendered according to the vertical layout rules.

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Remarks

In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Line Class

[image]
ActiveReports 19 .NET Edition
Line Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

Prints a line on the report.

Object Model

Line Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Line
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class Line : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.LineColor = System.Drawing.Color.Blue;
    this.line1.LineStyle = LineStyle.DashDot;
    this.line1.LineWeight = 2.0f;
    this.line1.X1 = 1.0f;
    this.line1.X2 = 4.0f;
    this.line1.Y1 = 0.5f;
    this.line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
    Me.Line1.LineStyle = LineStyle.DashDot
    Me.Line1.LineWeight = 2.0F
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Class Members

[image]
ActiveReports 19 .NET Edition
Line Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

The following tables list the members exposed by Line.

Public Constructors

 | Name | Description
Public Constructor | Line Constructor | Initializes a new instance of the Line class.
Top

Public Properties

 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Constructor

[image]
ActiveReports 19 .NET Edition
Line Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Line Constructor

Glossary Item Box

Initializes a new instance of the Line class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line Class Properties

[image]
ActiveReports 19 .NET Edition
Line Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Properties

 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AnchorBottom Property

[image]
ActiveReports 19 .NET Edition
AnchorBottom Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : AnchorBottom Property

Glossary Item Box

Anchors the line to the bottom of the containing section.

Syntax

Visual Basic (Declaration)
Public Property AnchorBottom As Boolean
C#
public bool AnchorBottom {get; set;}

Property Value

Boolean.

Remarks

When set to True, this property will create a continuous line from line controls in adjacent sections.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.AnchorBottom = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.AnchorBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineColor Property

Glossary Item Box

Gets or sets the color of the line control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


LineStyle Property

[image]
ActiveReports 19 .NET Edition
LineStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineStyle = LineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineStyle = LineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


LineWeight Property

[image]
ActiveReports 19 .NET Edition
LineWeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Location As PointF
C#
public override PointF Location {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.line1.Location = p;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.Line1.Location = p
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Size Property

Glossary Item Box

Gets or sets the size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Size As SizeF
C#
public override SizeF Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


X1 Property

[image]
ActiveReports 19 .NET Edition
X1 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X1 Property

Glossary Item Box

Gets or sets the horizontal coordinate of the line's starting point.

Syntax

Visual Basic (Declaration)
Public Property X1 As Single
C#
public float X1 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


X2 Property

[image]
ActiveReports 19 .NET Edition
X2 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X2 Property

Glossary Item Box

Gets or sets the horizontal coordinate of the line's end point.

Syntax

Visual Basic (Declaration)
Public Property X2 As Single
C#
public float X2 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Y1 Property

[image]
ActiveReports 19 .NET Edition
Y1 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y1 Property

Glossary Item Box

Gets or sets the vertical coordinate of the line's starting point.

Syntax

Visual Basic (Declaration)
Public Property Y1 As Single
C#
public float Y1 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Y2 Property

[image]
ActiveReports 19 .NET Edition
Y2 Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y2 Property

Glossary Item Box

Gets or sets the vertical coordinate of the line's end point.

Syntax

Visual Basic (Declaration)
Public Property Y2 As Single
C#
public float Y2 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


OleObject Class

[image]
ActiveReports 19 .NET Edition
OleObject Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

OleObject is a wrapper class for printing OLE objects.

Object Model

OleObject Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OleObject
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class OleObject : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.OleObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Members
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Class Members

[image]
ActiveReports 19 .NET Edition
OleObject Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

The following tables list the members exposed by OleObject.

Public Constructors

 | Name | Description
Public Constructor | OleObject Constructor | Initializes a new instance of the OleObject class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Class | Specifies the class name of the Ole object.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Top

Public Methods

 | Name | Description
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Constructor

[image]
ActiveReports 19 .NET Edition
OleObject Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : OleObject Constructor

Glossary Item Box

Initializes a new instance of the OleObject class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OleObject()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


OleObject Class Methods

[image]
ActiveReports 19 .NET Edition
OleObject Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

For a list of all members of this type, see OleObject members.

Public Methods

 | Name | Description
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CreateFrom Method

[image]
ActiveReports 19 .NET Edition
CreateFrom Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : CreateFrom Method

fileName
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.

Glossary Item Box

Creates an Ole Object to embed in the control from the specified file.

Syntax

Visual Basic (Declaration)
Public Sub CreateFrom( _
   ByVal fileName As String _
)
C#
public void CreateFrom(
   string fileName
)

Parameters

fileName
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


Edit Method

[image]
ActiveReports 19 .NET Edition
Edit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Edit Method

parentWindow
Specifies the parent window of the Ole object instance.

Glossary Item Box

Invokes the Ole server to edit the current embedded instance.

Syntax

Visual Basic (Declaration)
Public Sub Edit( _
   ByVal parentWindow As Object _
)
C#
public void Edit(
   object parentWindow
)

Parameters

parentWindow
Specifies the parent window of the Ole object instance.

Remarks

End user report designer use only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


OleObject Class Properties

[image]
ActiveReports 19 .NET Edition
OleObject Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

For a list of all members of this type, see OleObject members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Class | Specifies the class name of the Ole object.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.BackColor=System.Drawing.Color.OrangeRed;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.BackColor = System.Drawing.Color.CornflowerBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


Class Property

[image]
ActiveReports 19 .NET Edition
Class Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Class Property

Glossary Item Box

Specifies the class name of the Ole object.

Syntax

Visual Basic (Declaration)
Public Property Class As String
C#
public string Class {get; set;}

Property Value

String.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    System.Windows.Forms.MessageBox.Show(this.OleObject1.Class.ToString());
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    MessageBox.Show(Me.OleObject1.Class.ToString())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


HyperLink Property

[image]
ActiveReports 19 .NET Edition
HyperLink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Remarks

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "https://developer.mescius.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.HyperLink = "www.grapecity.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.HyperLink = "www.grapecity.com"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


PictureAlignment Property

[image]
ActiveReports 19 .NET Edition
PictureAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : PictureAlignment Property

Glossary Item Box

Gets or sets the position of the object's content within the control area.

Syntax

Visual Basic (Declaration)
Public Property PictureAlignment As PictureAlignment
C#
public PictureAlignment PictureAlignment {get; set;}

Remarks

A GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.html enumeration member that specifies the alignment of the content.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.PictureAlignment = PictureAlignment.BottomLeft;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.PictureAlignment = PictureAlignment.BottomLeft
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


SizeMode Property

[image]
ActiveReports 19 .NET Edition
SizeMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : SizeMode Property

Glossary Item Box

Gets or sets a value that determines how the image is sized to fit the OleObject control area.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeModes
C#
public SizeModes SizeMode {get; set;}

Property Value

A SizeModes enumeration value. The default value is SizeModes.Clip.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.SizeMode = SizeModes.Zoom;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.SizeMode = SizeModes.Zoom
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


PageBreak Class

[image]
ActiveReports 19 .NET Edition
PageBreak Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

PageBreak ends the current page and starts a new page at the control's location on the page.

Object Model

PageBreak Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageBreak
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class PageBreak : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.PageBreak

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Class Members

[image]
ActiveReports 19 .NET Edition
PageBreak Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

The following tables list the members exposed by PageBreak.

Public Constructors

 | Name | Description
Public Constructor | PageBreak Constructor | Initializes a new instance of the PageBreak class.
Top

Public Properties

 | Name | Description
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Constructor

[image]
ActiveReports 19 .NET Edition
PageBreak Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : PageBreak Constructor

Glossary Item Box

Initializes a new instance of the PageBreak class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageBreak()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageBreak Class Properties

[image]
ActiveReports 19 .NET Edition
PageBreak Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

For a list of all members of this type, see PageBreak members.

Public Properties

 | Name | Description
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Enabled Property

Glossary Item Box

Determines whether the PageBreak is currently enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

Boolean. True if the control is enabled and should create a page break at the specified position; otherwise False.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.pageBreak1.Enabled = false;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.PageBreak1.Enabled = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Location As PointF
C#
public override PointF Location {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0f;
    p.Y = 5f;

    if(this.detail.Height > 5)
    {
        this.pageBreak1.Enabled = true;
        this.pageBreak1.Location = p;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Dim p As System.Drawing.PointF
   p.X = 0
   p.Y = 5
   If Me.Detail1.Height > 5 Then
      Me.PageBreak1.Enabled = True
      Me.PageBreak1.Location = p
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageFooter Class

[image]
ActiveReports 19 .NET Edition
PageFooter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

The PageFooter section prints once at the bottom of every page in the report.

Object Model

PageFooter Class

Syntax

Visual Basic (Declaration)
Public Class PageFooter
   Inherits Section
C#
public class PageFooter : Section

Remarks

The PageFooter section is rendered last on each page after all content has been rendered, thus, unlike other sections, its height cannot be changed in the Format event.

Bound controls are not supported in this section, or in the PageHeader section. The data displayed in a bound control in one of these sections may not be in synch with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Members

[image]
ActiveReports 19 .NET Edition
PageFooter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

The following tables list the members exposed by PageFooter.

Public Constructors

 | Name | Description
Public Constructor | PageFooter Constructor | Initializes a new instance of the PageFooter class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the page footer.
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Constructor

[image]
ActiveReports 19 .NET Edition
PageFooter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : PageFooter Constructor

Glossary Item Box

Initializes a new instance of the PageFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageFooter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Class
PageFooter Members


PageFooter Class Properties

[image]
ActiveReports 19 .NET Edition
PageFooter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

For a list of all members of this type, see PageFooter members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the page footer.
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : Height Property

Glossary Item Box

Gets or sets the height of the page footer.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Class
PageFooter Members


PageHeader Class

[image]
ActiveReports 19 .NET Edition
PageHeader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

The PageHeader section prints once at the top of every page in the report.

Object Model

PageHeader Class

Syntax

Visual Basic (Declaration)
Public Class PageHeader
   Inherits Section
C#
public class PageHeader : Section

Remarks

Bound controls are not supported in this section, or in the PageFooter section. The data displayed in a bound control in one of these sections may not be in sync with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Members

[image]
ActiveReports 19 .NET Edition
PageHeader Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

The following tables list the members exposed by PageHeader.

Public Constructors

 | Name | Description
Public Constructor | PageHeader Constructor | Initializes a new instance of the PageHeader class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the page header.
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Constructor

[image]
ActiveReports 19 .NET Edition
PageHeader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : PageHeader Constructor

Glossary Item Box

Initializes a new instance of the PageHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Class
PageHeader Members


PageHeader Class Properties

[image]
ActiveReports 19 .NET Edition
PageHeader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

For a list of all members of this type, see PageHeader members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the page header.
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : Height Property

Glossary Item Box

Gets or sets the height of the page header.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Class
PageHeader Members


Parameter Class

[image]
ActiveReports 19 .NET Edition
Parameter Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

A Parameter is used to substitute values for parameter placeholders in the report's data source SQL query text.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public Class Parameter
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public class Parameter : GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Parameter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor | Initializes a new instance of the Parameter class.
Top

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | DisplayFormat | Parameter display format.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | Dispose | Releases the parameter from memory.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Parameter Constructor

[image]
ActiveReports 19 .NET Edition
Parameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Parameter Constructor

Glossary Item Box

Initializes a new instance of the Parameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Parameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

[image]
ActiveReports 19 .NET Edition
Parameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | Dispose | Releases the parameter from memory.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Clone Method

Glossary Item Box

Creates a clone of the Parameter object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Parameter
C#
public Parameter Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Dispose() Method

Glossary Item Box

Releases the parameter from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ReadXml Method

[image]
ActiveReports 19 .NET Edition
ReadXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ReadXml Method

baseNode
The base node of the XML element.

Glossary Item Box

Reads the parameter from an XmlElement.

Syntax

Visual Basic (Declaration)
Public Function ReadXml( _
   ByVal baseNode As XmlNode _
) As Boolean
C#
public bool ReadXml(
   XmlNode baseNode
)

Parameters

baseNode
The base node of the XML element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ToString Method

Glossary Item Box

Returns a string that represents the Parameter object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


WriteXml Method

[image]
ActiveReports 19 .NET Edition
WriteXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : WriteXml Method

baseNode
The base node of the XML element.

Glossary Item Box

Writes the parameter from an XmlElement.

Syntax

Visual Basic (Declaration)
Public Function WriteXml( _
   ByVal baseNode As XmlElement _
) As Boolean
C#
public bool WriteXml(
   XmlElement baseNode
)

Parameters

baseNode
The base node of the XML element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

[image]
ActiveReports 19 .NET Edition
Parameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | DisplayFormat | Parameter display format.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : DefaultValue Property

Glossary Item Box

Gets or sets a value to be used as the default value in the parameters input dialog.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue {get; set;}

Property Value

A string value specifying the default value of the parameter.

Remarks

If the user does not specify a value, the DefaultValue will be used.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DisplayFormat Property

[image]
ActiveReports 19 .NET Edition
DisplayFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : DisplayFormat Property

Glossary Item Box

Parameter display format.

Syntax

Visual Basic (Declaration)
Public Property DisplayFormat As String
C#
public string DisplayFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Key Property

Glossary Item Box

Unique name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Property Value

A string value that represents the unique name of the parameter.

Remarks

Used to reference the parameter in the parameters collection and to locate the different placeholder locations in the SQL query where the parameter value will be inserted.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Prompt Property

Glossary Item Box

Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt {get; set;}

Property Value

A string value used to prompt the user for a parameter value.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


PromptUser Property

[image]
ActiveReports 19 .NET Edition
PromptUser Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : PromptUser Property

Glossary Item Box

Determines whether to prompt the user to input a parameter value.

Syntax

Visual Basic (Declaration)
Public Property PromptUser As Boolean
C#
public bool PromptUser {get; set;}

Remarks

The default value is True. If the value is set to False, the Prompt property is ignored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


QueryCreated Property

[image]
ActiveReports 19 .NET Edition
QueryCreated Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : QueryCreated Property

Glossary Item Box

Determines whether the query is created from the data source query string or user created.

Syntax

Visual Basic (Declaration)
Public Property QueryCreated As Boolean
C#
public bool QueryCreated {get; set;}

Property Value

True if created from the data source SQL query string; False if user created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Tag Property

[image]
ActiveReports 19 .NET Edition
Tag Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Tag Property

Glossary Item Box

User-defined value.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Remarks

Use for your own purposes.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Type Property

Glossary Item Box

Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.

Syntax

Visual Basic (Declaration)
Public Property Type As Parameter.DataType
C#
public Parameter.DataType Type {get; set;}

Property Value

A DataType enumeration value that determines the type of control to be created for the parameters input dialog.

Remarks

ActiveReports creates the parameters intput dialog for the user dynamically based on the number of parameters and their type. By default, all parameters are considered strings. You can specify a Boolean control (checkbox) or a Date (calendar) control instead of a standard textbox.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Value Property

Glossary Item Box

Gets or sets the value of the parameter to be used in parameter placeholder substitution.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

A string value that is used to replace the parameter placeholder text in the report's data source SQL query.

Example

C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Parameters["country"].Value = "Germany";
    rpt.Run();
    arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    Dim rpt As New SectionReport1
    rpt.Parameters("country").Value = "Germany"
    rpt.Run()
    arv.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Events

[image]
ActiveReports 19 .NET Edition
Parameter Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Disposed Event

Glossary Item Box

Adds an event handler to listen to the Disposed event on the component.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

Represents the collection of parameters that ActiveReports parses from the parameter placeholders in the data source SQL query.

Object Model

ParameterCollection Class

Syntax

Visual Basic (Declaration)
Public Class ParameterCollection
   Inherits System.Collections.CollectionBase
C#
public class ParameterCollection : System.Collections.CollectionBase

Remarks

ActiveReports parses the data source SQL query for the following parameters placeholder syntax, and it uses that syntax to create the parameters collection before the data source is accessed. Only the Name is required.

<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Class Members

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor | Initializes a new instance of the ParameterCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | Dispose | Releases the ParameterCollection from memory.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Top

Public Events

 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Constructor

[image]
ActiveReports 19 .NET Edition
ParameterCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParameterCollection Constructor

parent
The parent object of the parameter collection.

Glossary Item Box

Initializes a new instance of the ParameterCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As IComponent _
)
C#
public ParameterCollection(
   IComponent parent
)

Parameters

parent
The parent object of the parameter collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | Dispose | Releases the ParameterCollection from memory.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Add Method

parameter
The parameter object to be added to the collection.

Glossary Item Box

Adds a Parameter object to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal parameter As Parameter _
) As Integer
C#
public int Add(
   Parameter parameter
)

Parameters

parameter
The parameter object to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AddRange Method

Glossary Item Box

Adds a range of Parameter objects to the Parameter collection. Adds a range of Parameter objects to the Parameter collection.

Overload List

Overload | Description
AddRange(Parameter[]) | Adds a range of Parameter objects to the Parameter collection.
AddRange(ParameterCollection) | Adds a ParameterCollection object to the Parameter collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange(Parameter[]) Method

[image]
ActiveReports 19 .NET Edition
AddRange(Parameter[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(Parameter[]) Method

parameters
The range of parameters to add.

Glossary Item Box

Adds a range of Parameter objects to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal parameters() As Parameter _
)
C#
public void AddRange(
   Parameter[] parameters
)

Parameters

parameters
The range of parameters to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AddRange(ParameterCollection) Method

[image]
ActiveReports 19 .NET Edition
AddRange(ParameterCollection) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(ParameterCollection) Method

parameters
The ParameterCollection object to add.

Glossary Item Box

Adds a ParameterCollection object to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal parameters As ParameterCollection _
)
C#
public void AddRange(
   ParameterCollection parameters
)

Parameters

parameters
The ParameterCollection object to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AtLeastOneNeedsPrompt Method

[image]
ActiveReports 19 .NET Edition
AtLeastOneNeedsPrompt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneNeedsPrompt Method

Glossary Item Box

Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.

Syntax

Visual Basic (Declaration)
Public Function AtLeastOneNeedsPrompt() As Boolean
C#
public bool AtLeastOneNeedsPrompt()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AtLeastOneQueryCreated Method

[image]
ActiveReports 19 .NET Edition
AtLeastOneQueryCreated Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneQueryCreated Method

Glossary Item Box

Determines whether a query for the parameters in the collection has been created.

Syntax

Visual Basic (Declaration)
Public Function AtLeastOneQueryCreated() As Boolean
C#
public bool AtLeastOneQueryCreated()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Contains Method

parameter
The parameter to find in the collection.

Glossary Item Box

Determines whether the collection contains the specified parameter.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal parameter As Parameter _
) As Boolean
C#
public bool Contains(
   Parameter parameter
)

Parameters

parameter
The parameter to find in the collection.

Return Value

True if the collection contains the parameter; otherwise, False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Dispose() Method

Glossary Item Box

Releases the ParameterCollection from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : IndexOf Method

parameter
Specifies the Parameter object for which to search.

Glossary Item Box

Returns the index of the specified Parameter object in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal parameter As Parameter _
) As Integer
C#
public int IndexOf(
   Parameter parameter
)

Parameters

parameter
Specifies the Parameter object for which to search.

Return Value

An integer specifying the index of the specified Parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Insert Method

index
The index at which the parameter is inserted
parameter
The parameter to insert.

Glossary Item Box

Inserts a Parameter object into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal parameter As Parameter _
)
C#
public void Insert(
   int index,
   Parameter parameter
)

Parameters

index
The index at which the parameter is inserted
parameter
The parameter to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Remove Method

parameter
The parameter to be removed.

Glossary Item Box

Removes a parameter from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal parameter As Parameter _
)
C#
public void Remove(
   Parameter parameter
)

Parameters

parameter
The parameter to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Item Property

Glossary Item Box

Returns a reference to the specified Parameter.

Overload List

Overload | Description
Item(Int32) | Gets the Parameters object at the specified indexed location in the Parameters collection.
Item(String) | Gets the Parameter object with the specified key in the Parameters collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(Int32) Property

index
Specifies the index of the requested parameter in the collection.

Glossary Item Box

Gets the Parameters object at the specified indexed location in the Parameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Parameter
C#
public Parameter Item(
   int index
) {get;}

Parameters

index
Specifies the index of the requested parameter in the collection.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters[0].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item(0).Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(String) Property

key
Specifies the key of the requested parameter.

Glossary Item Box

Gets the Parameter object with the specified key in the Parameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal key As String _
) As Parameter
C#
public Parameter Item(
   string key
) {get;}

Parameters

key
Specifies the key of the requested parameter.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters["country"].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item("country").Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParseResult Property

[image]
ActiveReports 19 .NET Edition
ParseResult Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParseResult Property

Glossary Item Box

Returns the results of parsing the report's parameter values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParseResult As ParameterCollection.ParseResultCode
C#
public ParameterCollection.ParseResultCode ParseResult {get;}

Property Value

Parameters.ParseResultCode enumeration.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.Success)
    {
        System.Windows.Forms.MessageBox.Show("success!");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingCloseParam)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParam");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingParamName)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParamName");
    }
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    If rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.Success Then
        MessageBox.Show("success!")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingCloseParam Then
        MessageBox.Show("missingCloseParam")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingParamName Then
        MessageBox.Show("missingCloseParamName")
    End If
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Events

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Events

 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Modified Event

[image]
ActiveReports 19 .NET Edition
Modified Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Modified Event

Glossary Item Box

Is raised when the Parameter collection is modified.

Syntax

Visual Basic (Declaration)
Public Event Modified As EventHandler
C#
public event EventHandler Modified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Picture Class

[image]
ActiveReports 19 .NET Edition
Picture Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

Prints an image on the report.

Object Model

Picture Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Picture
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class Picture : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
    this.picture1.HyperLink = "mailto:support@company.com";
    this.picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("\\mycompany.gif").OpenRead());
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
    this.picture1.PictureAlignment = PictureAlignment.Center;
    this.picture1.SizeMode = SizeModes.Clip;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
   Me.Picture1.HyperLink = "mailto:support@company.com"
   Me.Picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("\mycompany.gif").OpenRead())
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
   Me.Picture1.PictureAlignment = PictureAlignment.Center
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Picture

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Class Members

[image]
ActiveReports 19 .NET Edition
Picture Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

The following tables list the members exposed by Picture.

Public Constructors

 | Name | Description
Public Constructor | Picture Constructor | Initializes a new instance of the Picture class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | ImageBytes | Gets or sets the Image to be printed in the Picture control. This snippet shows how to load data in script into Picture instance with name "Picture1". public void Detail_Format() { this.Picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); } This snippet shows how to load data in code-based reports into Picture instance with name "picture1". Subscribe to event Section.Format of Detail of your report. private void detail_Format(object sender, System.EventArgs eArgs) { this.picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); }
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Top

Public Methods

 | Name | Description
Public Method | ResetImage | Sets the current image to null.
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Constructor

[image]
ActiveReports 19 .NET Edition
Picture Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Picture Constructor

Glossary Item Box

Initializes a new instance of the Picture class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Picture()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Picture Class Methods

[image]
ActiveReports 19 .NET Edition
Picture Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

For a list of all members of this type, see Picture members.

Public Methods

 | Name | Description
Public Method | ResetImage | Sets the current image to null.
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ResetImage Method

[image]
ActiveReports 19 .NET Edition
ResetImage Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : ResetImage Method

Glossary Item Box

Sets the current image to null.

Syntax

Visual Basic (Declaration)
Public Sub ResetImage()
C#
public void ResetImage()

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    if (this.txtCountry.Value.ToString() == "France")
    {
        this.picture1.ResetImage();
    }
    else
    {
        this.picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("c:\\DSCF2183.JPG").OpenRead());
    }
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    If Me.txtCountry.Value.ToString = "France" Then
        Me.Picture1.ResetImage()
    Else
        Me.Picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("c:\DSCF2183.JPG").OpenRead())
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Picture Class Properties

[image]
ActiveReports 19 .NET Edition
Picture Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

For a list of all members of this type, see Picture members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | ImageBytes | Gets or sets the Image to be printed in the Picture control. This snippet shows how to load data in script into Picture instance with name "Picture1". public void Detail_Format() { this.Picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); } This snippet shows how to load data in code-based reports into Picture instance with name "picture1". Subscribe to event Section.Format of Detail of your report. private void detail_Format(object sender, System.EventArgs eArgs) { this.picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); }
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Description Property

Glossary Item Box

Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


HyperLink Property

[image]
ActiveReports 19 .NET Edition
HyperLink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.HyperLink = "mailto:support@company.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.HyperLink = "mailto:support@company.com"
End Sub

Requirements

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "https://developer.mescius.com") for this property.

See Also

Reference

Picture Class
Picture Members
HyperLinkEventArgs


Image Property

[image]
ActiveReports 19 .NET Edition
Image Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Image Property

Glossary Item Box

Gets or sets the Image to be printed in the Picture control.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
C#
public Image Image {get; set;}

Property Value

A GrapeCity.ActiveReports.Document.Drawing.Image value that represents the image to be printed in the Picture control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
   this.picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(new FileInfo("\\mycompany.gif").OpenRead());
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.picture1.Image = GrapeCity.ActiveReports.Document.Drawing.Image.FromStream(New FileInfo("\mycompany.gif").OpenRead())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


ImageBytes Property

[image]
ActiveReports 19 .NET Edition
ImageBytes Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : ImageBytes Property

Glossary Item Box

Gets or sets the Image to be printed in the Picture control. This snippet shows how to load data in script into Picture instance with name "Picture1". public void Detail_Format() { this.Picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); } This snippet shows how to load data in code-based reports into Picture instance with name "picture1". Subscribe to event Section.Format of Detail of your report. private void detail_Format(object sender, System.EventArgs eArgs) { this.picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif"); }

Syntax

Visual Basic (Declaration)
Public Property ImageBytes As Byte()
C#
public byte[] ImageBytes {get; set;}

Example

This snippet shows how to load data in script into Picture instance with name "Picture1".This snippet shows how to load data in code-based reports into Picture instance with name "picture1". Subscribe to event Section.Format of Detail of your report.
C# Copy Code
public void Detail_Format()
{
    this.Picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif");
}
C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.ImageBytes = System.IO.File.ReadAllBytes("\\mycompany.gif");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineColor Property

Glossary Item Box

Gets or sets the border line color around the picture control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to paint the picture border. Default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detai1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


LineStyle Property

[image]
ActiveReports 19 .NET Edition
LineStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to paint the border around the picture control.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

A LineStyle enumeration value. Default is LineStyle.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


LineWeight Property

[image]
ActiveReports 19 .NET Edition
LineWeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current width of the line in pixels.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


PictureAlignment Property

[image]
ActiveReports 19 .NET Edition
PictureAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : PictureAlignment Property

Glossary Item Box

Gets or sets the position of the image within the control area.

Syntax

Visual Basic (Declaration)
Public Property PictureAlignment As PictureAlignment
C#
public PictureAlignment PictureAlignment {get; set;}

Property Value

A GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.html enumeration member that specifies the alignment of the picture.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.PictureAlignment = PictureAlignment.Center;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.PictureAlignment = PictureAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


SizeMode Property

[image]
ActiveReports 19 .NET Edition
SizeMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : SizeMode Property

Glossary Item Box

Gets or sets a value that determines how the image is sized to fit the Picture control area.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeModes
C#
public SizeModes SizeMode {get; set;}

Property Value

A GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.SizeModes enumeration value. The default value is SizeModes.Clip

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.SizeMode = SizeModes.Clip;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Title Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


ReportFooter Class

[image]
ActiveReports 19 .NET Edition
ReportFooter Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

The ReportFooter section prints once at the end of the report.

Object Model

ReportFooter Class

Syntax

Visual Basic (Declaration)
Public Class ReportFooter
   Inherits Section
C#
public class ReportFooter : Section

Remarks

Use this section to print the summary of the report and include any grand summary calculations.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
    this.reportFooter1.NewPage = NewPage.None;
    this.reportFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
    Me.ReportFooter.NewPage = NewPage.None
    Me.ReportFooter.PrintAtBottom = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Class Members

[image]
ActiveReports 19 .NET Edition
ReportFooter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

The following tables list the members exposed by ReportFooter.

Public Constructors

 | Name | Description
Public Constructor | ReportFooter Constructor | Initializes a new instance of the ReportFooter class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Constructor

[image]
ActiveReports 19 .NET Edition
ReportFooter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : ReportFooter Constructor

Glossary Item Box

Initializes a new instance of the ReportFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportFooter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


ReportFooter Class Properties

[image]
ActiveReports 19 .NET Edition
ReportFooter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

For a list of all members of this type, see ReportFooter members.

Public Properties

 | Name | Description
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : Height Property

Glossary Item Box

Gets ot sets the height of the report footer section.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True--if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the its original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True-- if the footer section will be printed at the bottom of the page; otherwise, False.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


ReportHeader Class

[image]
ActiveReports 19 .NET Edition
ReportHeader Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

The ReportHeader section is printed once at the beginning of the report.

Object Model

ReportHeader Class

Syntax

Visual Basic (Declaration)
Public Class ReportHeader
   Inherits Section
C#
public class ReportHeader : Section

Example

C# Copy Code
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Members

[image]
ActiveReports 19 .NET Edition
ReportHeader Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

The following tables list the members exposed by ReportHeader.

Public Constructors

 | Name | Description
Public Constructor | ReportHeader Constructor | Initializes a new instance of the ReportHeader class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Constructor

[image]
ActiveReports 19 .NET Edition
ReportHeader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : ReportHeader Constructor

Glossary Item Box

Initializes a new instance of the ReportHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


ReportHeader Class Properties

[image]
ActiveReports 19 .NET Edition
ReportHeader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

For a list of all members of this type, see ReportHeader members.

Public Properties

 | Name | Description
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : Height Property

Glossary Item Box

Gets ot sets the height of the report header section.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


ReportInfo Class

[image]
ActiveReports 19 .NET Edition
ReportInfo Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

The ReportInfo control displays the information specified in the FormatString property.

Object Model

ReportInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportInfo
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class ReportInfo : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Remarks

Included format strings supply Page N of M and report run date information.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Class Members

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

The following tables list the members exposed by ReportInfo.

Public Constructors

 | Name | Description
Public Constructor | ReportInfo Constructor | Initializes a new instance of the ReportInfo class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Constructor

[image]
ActiveReports 19 .NET Edition
ReportInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ReportInfo Constructor

Glossary Item Box

Initializes a new instance of the ReportInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As TextAlignment
C#
public TextAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Calendar Property

[image]
ActiveReports 19 .NET Edition
Calendar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Calendar Property

Glossary Item Box

Gets or sets calendar to use for formatting dates

Syntax

Visual Basic (Declaration)
Public Property Calendar As String
C#
public string Calendar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
    this.reportInfo1.CanShrink = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
   Me.ReportInfo1.CanShrink = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".

Remarks

Style classes are defined in the report's Stylesheet.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Culture Property

Glossary Item Box

Gets or sets the culture for the text control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ForeColor = System.Drawing.Color.Firebrick;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.ForeColor = System.Drawing.Color.Firebrick
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


FormatString Property

[image]
ActiveReports 19 .NET Edition
FormatString Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : FormatString Property

Glossary Item Box

Gets or sets the mask string used to format the text property before placing it in the Text property.

Syntax

Visual Basic (Declaration)
Public Property FormatString As String
C#
public string FormatString {get; set;}

Remarks

The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings. The ReportInfo control will display variations of report Page and RunDateTime information.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = New System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether the ReportInfo control is multiline enabled.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}";
    this.reportInfo1.MultiLine = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}"
    Me.ReportInfo1.MultiLine = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : RightToLeft Property

Glossary Item Box

Determines whether text will be displayed in right-to-left order for this control.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.RightToLeft = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.RightToLeft = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Style Property

Glossary Item Box

Gets or sets a style string for the ReportInfo control.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Style = "color: Firebrick; text-align: center;";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Style = "color: FireBrick; text-align: center;"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryGroup Property

[image]
ActiveReports 19 .NET Edition
SummaryGroup Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryGroup Property

Glossary Item Box

Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.

Syntax

Visual Basic (Declaration)
Public Property SummaryGroup As String
C#
public string SummaryGroup {get; set;}

Property Value

The summary group.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryRunning Property

[image]
ActiveReports 19 .NET Edition
SummaryRunning Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryRunning Property

Glossary Item Box

Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).

Syntax

Visual Basic (Declaration)
Public Property SummaryRunning As SummaryRunning
C#
public SummaryRunning SummaryRunning {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Text Property

Glossary Item Box

Returns the FormatString format associated with the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the control's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RichTextBox Class

[image]
ActiveReports 19 .NET Edition
RichTextBox Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

Prints text formatted as Rich Text (RTF) on the report.

Object Model

RichTextBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RichTextBox
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class RichTextBox : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.BackColor = System.Drawing.Color.RosyBrown;
    this.rtf.BulletIndent = 0.5f;
    this.rtf.CanGrow = true;
    this.rtf.CanShrink = false;
    this.rtf.Clear(); //Clears the content of the RichTextBox;
    this.rtf.Find("Germany");
    this.rtf.ForeColor = System.Drawing.Color.Black;
    this.rtf.InsertField("Phone");
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf"); //Loads the specified file into the RTF control
    this.rtf.MaxLength = 0;
    this.rtf.Multiline = true;
    this.rtf.RTF = "RTF Contents";
    this.rtf.SelectedText.ToString();
    this.rtf.SelectionAlignment = TextAlignment.Left;
    this.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown;
    this.rtf.SelectionBullet = false;
    this.rtf.SelectionCharOffset = 0;
    this.rtf.SelectionColor = System.Drawing.Color.Blue;
    this.rtf.SelectionFont.ToString();
    this.rtf.SelectionHangingIndent = 3;
    this.rtf.SelectionIndent = 0;
    this.rtf.SelectionLength.ToString();
    this.rtf.SelectionRightIndent = 3;
    this.rtf.SelectionStart = 5;
    this.rtf.Text = "RTF Text";
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.BackColor = System.Drawing.Color.RosyBrown
    Me.rtf.BulletIndent = 0.5
    Me.rtf.CanGrow = True
    Me.rtf.CanShrink = False
    Me.rtf.Clear() 'Clears the content of the RichTextBox
    Me.rtf.Find("Germany")
    Me.rtf.ForeColor = System.Drawing.Color.Black
    Me.rtf.InsertField("Phone")
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf") 'Loads the specified file into the RTF control
    Me.rtf.MaxLength = 0
    Me.rtf.Multiline = True
    Me.rtf.RTF = "RTF Contents"
    Me.rtf.SelectedText.ToString()
    Me.rtf.SelectionAlignment = TextAlignment.Left
    Me.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown
    Me.rtf.SelectionBullet = False
    Me.rtf.SelectionCharOffset = 0
    Me.rtf.SelectionColor = System.Drawing.Color.Blue
    Me.rtf.SelectionFont.ToString()
    Me.rtf.SelectionHangingIndent = 3
    Me.rtf.SelectionIndent = 0
    Me.rtf.SelectionLength.ToString()
    Me.rtf.SelectionRightIndent = 3
    Me.rtf.SelectionStart = 5
    Me.rtf.Text = "RTF Text"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.RichTextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Class Members

[image]
ActiveReports 19 .NET Edition
RichTextBox Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

The following tables list the members exposed by RichTextBox.

Public Constructors

 | Name | Description
Public Constructor | RichTextBox Constructor | Initializes a new instance of the RichTextBox class.
Top

Public Properties

 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | HtmlItem |
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | RenderRtfAsContinuousImage | If set to true, then the content will be rendered as one continuous image and then split across the pages. This property is actual only if RtfRenderingType is set to either Metafile or PNG.
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | RtfRenderingType | Gets or sets target rendering type of RTF (not HTML). As legacy RTF or as WordPad-like image (metafile or raster image).
Public Property | Text | Gets or sets the current text in the RichTextBox.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Load | Loads the contents of a stream into the RichTextBox control.
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Constructor

[image]
ActiveReports 19 .NET Edition
RichTextBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RichTextBox Constructor

Glossary Item Box

Initializes a new instance of the RichTextBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RichTextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Methods

[image]
ActiveReports 19 .NET Edition
RichTextBox Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

For a list of all members of this type, see RichTextBox members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Load | Loads the contents of a stream into the RichTextBox control.
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Clear Method

Glossary Item Box

Clears the content of the RichTextBox control.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    //Clears the content of the RichTextBox
    this.rtf.Clear();
    //Loads the specified file into the RTF control
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf");
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    'Clears the content of the RichTextBox
    Me.rtf.Clear()
    'Loads the specified file into the RTF control
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Load Method

stream
Stream with content
type
RichText type; one of rtf, html or text

Glossary Item Box

Loads the contents of a stream into the RichTextBox control.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   ByVal stream As Stream, _
   ByVal type As RichTextType _
)
C#
public void Load(
   Stream stream,
   RichTextType type
)

Parameters

stream
Stream with content
type
RichText type; one of rtf, html or text

Remarks

The data loaded from the stream replaces the existing text in the RichTextBox.

Example

To use this sample code, you will need a sample.rtf file and a sample.html file as well as two RichTextBox controls on an ActiveReport.
C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    System.IO.FileStream streamR = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
    rtfRTF.Load(streamR, RichTextType.Rtf);

    System.IO.FileStream streamH = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
    rtfHTML.Load(streamH, RichTextType.Html);
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim streamR As New System.IO.FileStream(Application.StartupPath & "\sample.rtf", IO.FileMode.Open)
    rtfRTF.Load(streamR, RichTextType.Rtf)
    Dim streamH As New System.IO.FileStream(Application.StartupPath & "\sample.html", IO.FileMode.Open)
    rtfHTML.Load(streamH, RichTextType.Html)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Properties

[image]
ActiveReports 19 .NET Edition
RichTextBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

For a list of all members of this type, see RichTextBox members.

Public Properties

 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | HtmlItem |
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | RenderRtfAsContinuousImage | If set to true, then the content will be rendered as one continuous image and then split across the pages. This property is actual only if RtfRenderingType is set to either Metafile or PNG.
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | RtfRenderingType | Gets or sets target rendering type of RTF (not HTML). As legacy RTF or as WordPad-like image (metafile or raster image).
Public Property | Text | Gets or sets the current text in the RichTextBox.
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoReplaceFields Property

[image]
ActiveReports 19 .NET Edition
AutoReplaceFields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : AutoReplaceFields Property

Glossary Item Box

Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.

Syntax

Visual Basic (Declaration)
Public Property AutoReplaceFields As Boolean
C#
public bool AutoReplaceFields {get; set;}

Property Value

Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


BulletIndent Property

[image]
ActiveReports 19 .NET Edition
BulletIndent Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BulletIndent Property

Glossary Item Box

Gets or sets the indentation used in the control when the bullet style is applied to the text.

Syntax

Visual Basic (Declaration)
Public Property BulletIndent As Single
C#
public float BulletIndent {get; set;}

Property Value

Float value that is the current bullet indent value in inches. Default is 0.5 inch.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BulletIndent = .25f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BulletIndent = 0.25
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should also be set to True to avoid clipping the section.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanGrow = false;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.rtbActiveReport.CanGrow = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are no intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanShrink = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.CanShrink = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

Current font System.Drawing.Color. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Html Property

[image]
ActiveReports 19 .NET Edition
Html Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Html Property

Glossary Item Box

Sets or returns the hypertext to be rendered in the control.

Syntax

Visual Basic (Declaration)
Public Property Html As String
C#
public string Html {get; set;}

Property Value

Valid hypertext with tags which will be rendered in the control.

Remarks

\n" + this.RichTextBox1.Text;}

Example

C# Copy Code
private void reportHeader1_Format(object sender, System.EventArgs e)
{
    RichTextBox1.Html = RichTextBox1.Text;
}
Visual Basic Copy Code
Private Sub ReportHeader1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportHeader1.Format
    RichTextBox1.Html = RichTextBox1.Text
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


HtmlItem Property

[image]
ActiveReports 19 .NET Edition
HtmlItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : HtmlItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HtmlItem As IContainingBlock
C#
public IContainingBlock HtmlItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


MaxLength Property

[image]
ActiveReports 19 .NET Edition
MaxLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : MaxLength Property

Glossary Item Box

Gets or sets the maximum number of characters in the control for the End-User Report Designer.

Syntax

Visual Basic (Declaration)
Public Property MaxLength As Integer
C#
public int MaxLength {get; set;}

Property Value

An integer value that specifies the maximum number of characters. The default value is 0, which allows an unlimited number of characters.

Remarks

This property can only be used with the End-User Report Designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RenderRtfAsContinuousImage Property

[image]
ActiveReports 19 .NET Edition
RenderRtfAsContinuousImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RenderRtfAsContinuousImage Property

Glossary Item Box

If set to true, then the content will be rendered as one continuous image and then split across the pages. This property is actual only if RtfRenderingType is set to either Metafile or PNG.

Syntax

Visual Basic (Declaration)
Public Property RenderRtfAsContinuousImage As Boolean
C#
public bool RenderRtfAsContinuousImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RTF Property

[image]
ActiveReports 19 .NET Edition
RTF Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RTF Property

Glossary Item Box

Gets or sets the rich text content of the control.

Syntax

Visual Basic (Declaration)
Public Property RTF As String
C#
public string RTF {get; set;}

Property Value

A string value. Contents of the RichTextBox control.

Remarks

The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control. Tables are now supported as well.

Example

The following example sets the contents of the RichTextBox to a formatted Rich Text string.
C# Copy Code
this.RichTextBox1.RTF = @"{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }";
Visual Basic Copy Code
Me.RichTextBox1.RTF = "{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RtfRenderingType Property

[image]
ActiveReports 19 .NET Edition
RtfRenderingType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RtfRenderingType Property

Glossary Item Box

Gets or sets target rendering type of RTF (not HTML). As legacy RTF or as WordPad-like image (metafile or raster image).

Syntax

Visual Basic (Declaration)
Public Property RtfRenderingType As RichTextRenderingType
C#
public RichTextRenderingType RtfRenderingType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Text Property

Glossary Item Box

Gets or sets the current text in the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The text displayed in the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.Text = "Confidential";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.Text = "Confidential"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Section Class

[image]
ActiveReports 19 .NET Edition
Section Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

Section is the base class of all ActiveReports section types.

Object Model

Section Class

Syntax

Visual Basic (Declaration)
Public Class Section
C#
public class Section

Remarks

Use this class to access, add or modify section controls and set section properties. You can add sections to a report using the Sections property of the report object and the SectionCollection class.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail
GrapeCity.ActiveReports.SectionReportModel.GroupFooter
GrapeCity.ActiveReports.SectionReportModel.GroupHeader
GrapeCity.ActiveReports.SectionReportModel.PageFooter
GrapeCity.ActiveReports.SectionReportModel.PageHeader
GrapeCity.ActiveReports.SectionReportModel.ReportFooter
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Class Members

[image]
ActiveReports 19 .NET Edition
Section Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

The following tables list the members exposed by Section.

Public Constructors

 | Name | Description
Public Constructor | Section Constructor | Initializes a new instance of the Section class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | Dispose | Releases the section instance from memory.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Constructor

[image]
ActiveReports 19 .NET Edition
Section Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Section Constructor

Glossary Item Box

Initializes a new instance of the Section class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Section()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Section Class Methods

[image]
ActiveReports 19 .NET Edition
Section Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | Dispose | Releases the section instance from memory.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AddBookmark(String) Method

[image]
ActiveReports 19 .NET Edition
AddBookmark(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AddBookmark(String) Method

text
The bookmark text.

Glossary Item Box

Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.

Syntax

Visual Basic (Declaration)
Public Sub AddBookmark( _
   ByVal text As String _
)
C#
public void AddBookmark(
   string text
)

Parameters

text
The bookmark text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Dispose() Method

Glossary Item Box

Releases the section instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


SizeToFit Method

[image]
ActiveReports 19 .NET Edition
SizeToFit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : SizeToFit Method

Glossary Item Box

The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.

Overload List

Overload | Description
SizeToFit() | Sizes the section to fit the contained controls.
SizeToFit(Boolean) | Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.

Remarks

Using this method, a user could add several controls to a section at run time and then size the section to the proper height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


SizeToFit() Method

[image]
ActiveReports 19 .NET Edition
SizeToFit() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit() Method

Glossary Item Box

Sizes the section to fit the contained controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SizeToFit()
C#
public void SizeToFit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
Overload List


SizeToFit(Boolean) Method

[image]
ActiveReports 19 .NET Edition
SizeToFit(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit(Boolean) Method

bAllowShrink
Set to True to allow the section to shrink to fit the contained controls.

Glossary Item Box

Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SizeToFit( _
   ByVal bAllowShrink As Boolean _
)
C#
public void SizeToFit(
   bool bAllowShrink
)

Parameters

bAllowShrink
Set to True to allow the section to shrink to fit the contained controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
Overload List


Section Class Properties

[image]
ActiveReports 19 .NET Edition
Section Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the section.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color value used to paint the section background. Default is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Detail.BackColor = System.Drawing.Color.Transparent;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.BackColor = System.Drawing.Color.Transparent
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanGrow Property

Glossary Item Box

Indicates whether the section height should grow when its controls extend beyond its original height.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

Boolean. True if the section should grow to fit its controls, False if the controls should be clipped to the section's height. Default is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanShrink Property

Glossary Item Box

Indicates whether the section height should be adjusted to the exact total height of its controls.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

Boolean. True if the section should shrink to fit its controls; False, otherwise. Default is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Controls Property

[image]
ActiveReports 19 .NET Edition
Controls Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Controls Property

Glossary Item Box

Gets a collection of all controls contained in the section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As ControlCollection
C#
public ControlCollection Controls {get;}

Property Value

A GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ControlCollection.html object representing all controls contained within the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Controls.Clear();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Controls.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Height Property

Glossary Item Box

Gets or sets the height of the section.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Property Value

Height of the section in inches. Default is 2 inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Height = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Height = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Name Property

Glossary Item Box

Gets or sets the name of the section.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

String. Unique name of the section.

Remarks

The section name is used as a key in the report Sections collection.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Name = "Products";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Name = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Tag Property

[image]
ActiveReports 19 .NET Edition
Tag Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Tag Property

Glossary Item Box

Gets or sets user-defined information to be persisted with the section.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Type Property

Glossary Item Box

Gets the section's type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As SectionType
C#
public SectionType Type {get;}

Property Value

SectionType enumeration specifying the type of the section. Default is SectionType.Detail.

Remarks

ActiveReports has seven section types that determine how the section is processed and rendered. Report header and footer sections print at the beginning and end of the report. Page header and footer sections print at the top and bottom of each page. Group header and footer sections print at the beginning and end of each data grouping. A Detail section is printed for each data record in the data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Visible Property

Glossary Item Box

Specifies whether the section should be printed or not.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

Boolean value that specifies whether the section will be printed or not. Default is true.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Visible = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.Visible = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Section Class Events

[image]
ActiveReports 19 .NET Edition
Section Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AfterPrint Event

[image]
ActiveReports 19 .NET Edition
AfterPrint Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AfterPrint Event

Glossary Item Box

Occurs after the section has been rendered to the page.

Syntax

Visual Basic (Declaration)
Public Event AfterPrint As EventHandler
C#
public event EventHandler AfterPrint

Remarks

This event allows you to draw directly to the canvas after the section has been rendered. It is not recommended to use this event to manage any data or variables because the sequence of the event relative to the other section events is not guaranteed.

Example

C# Copy Code
Private void reportHeader1_AfterPrint(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawRect(1,1,3,1);
}
Visual Basic Copy Code
Private Sub ReportHeader1_AfterPrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader1.AfterPrint
    Me.CurrentPage.DrawRect(1, 1, 3, 1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


BeforePrint Event

[image]
ActiveReports 19 .NET Edition
BeforePrint Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BeforePrint Event

Glossary Item Box

Occurs immediately before the section is rendered to the page.

Syntax

Visual Basic (Declaration)
Public Event BeforePrint As EventHandler
C#
public event EventHandler BeforePrint

Remarks

When this event occurs the section layout has been finalized and is ready to render. Any changes that might affect the size of the section (such as changing the section Height property) will be ignored.

Example

C# Copy Code
private void ghCustomerID_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("TotalOrders",this.txtTotalOrders.Text);
}
Visual Basic Copy Code
Private Sub ghCustomerID_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles _    ghCustomerID.BeforePrint
        Me.rtf.ReplaceField("TotalOrders", Me.txtTotalOrders.Text)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Format Event

[image]
ActiveReports 19 .NET Edition
Format Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Format Event

Glossary Item Box

Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.

Syntax

Visual Basic (Declaration)
Public Event Format As EventHandler
C#
public event EventHandler Format

Remarks

The format event is the only event where the section's height may be changed. This event may be used to set or change the properties of any controls, or load subreport controls with subreports.

If the CanGrow or CanShrink property of any child control or the section itself is set to True, all of the growing and shrinking of child controls and the section itself takes place in this event. Because of this, information about a control or section's height would not be accurate since ActiveReports might modify the value immediately after the event to account for any layout or data changes.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Shape Class

[image]
ActiveReports 19 .NET Edition
Shape Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

Prints a rectangular or oval shape on the report.

Object Model

Shape Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Shape
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class Shape : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.Ellipse;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.Ellipse
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Shape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Class Members

[image]
ActiveReports 19 .NET Edition
Shape Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

The following tables list the members exposed by Shape.

Public Constructors

 | Name | Description
Public Constructor | Shape Constructor | Initializes a new instance of the Shape class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | BackColor2 | Gets or sets the background color of the control area.
Public Property | BackgroundPattern | Gets or sets the background pattern to hatch style
Public Property | BackgroundStyle | Gets or sets the background style.
Public Property | GradientStyle | Gets or sets the gradient style.
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Style | Gets or sets the shape type to be printed.
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Constructor

[image]
ActiveReports 19 .NET Edition
Shape Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Shape Constructor

Glossary Item Box

Initializes a new instance of the Shape class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Shape()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Shape Class Properties

[image]
ActiveReports 19 .NET Edition
Shape Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | BackColor2 | Gets or sets the background color of the control area.
Public Property | BackgroundPattern | Gets or sets the background pattern to hatch style
Public Property | BackgroundStyle | Gets or sets the background style.
Public Property | GradientStyle | Gets or sets the gradient style.
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Style | Gets or sets the shape type to be printed.
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackColor2 Property

[image]
ActiveReports 19 .NET Edition
BackColor2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackColor2 Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor2 As Color
C#
public Color BackColor2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackgroundPattern Property

[image]
ActiveReports 19 .NET Edition
BackgroundPattern Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackgroundPattern Property

Glossary Item Box

Gets or sets the background pattern to hatch style

Syntax

Visual Basic (Declaration)
Public Property BackgroundPattern As HatchStyle
C#
public HatchStyle BackgroundPattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackgroundStyle Property

[image]
ActiveReports 19 .NET Edition
BackgroundStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackgroundStyle Property

Glossary Item Box

Gets or sets the background style.

Syntax

Visual Basic (Declaration)
Public Property BackgroundStyle As BackgroundStyle
C#
public BackgroundStyle BackgroundStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


GradientStyle Property

[image]
ActiveReports 19 .NET Edition
GradientStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : GradientStyle Property

Glossary Item Box

Gets or sets the gradient style.

Syntax

Visual Basic (Declaration)
Public Property GradientStyle As GradientStyle
C#
public GradientStyle GradientStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineColor Property

Glossary Item Box

Gets or sets the color of the shape's lines.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the shape's lines. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineColor = System.Drawing.Color.Navy;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineColor = System.Drawing.Color.Navy
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


LineStyle Property

[image]
ActiveReports 19 .NET Edition
LineStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

Current LineStyle value. Default is LineStyle.Solid.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineStyle = LineStyle.Solid;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineStyle = LineStyle.Solid
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


LineWeight Property

[image]
ActiveReports 19 .NET Edition
LineWeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width in pixels used to draw the shape.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current pen width in pixels. Default is 1.0f.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


RoundingRadius Property

[image]
ActiveReports 19 .NET Edition
RoundingRadius Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : RoundingRadius Property

Glossary Item Box

Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.

Syntax

Visual Basic (Declaration)
Public Property RoundingRadius As CornersRadius
C#
public CornersRadius RoundingRadius {get; set;}

Remarks

The default value is 10%; valid values range from 0% to 100%.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.RoundRect;
    this.shape1.RoundingRadius = 20f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.RoundRect
   Me.Shape1.RoundingRadius = 20F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Style Property

Glossary Item Box

Gets or sets the shape type to be printed.

Syntax

Visual Basic (Declaration)
Public Property Style As ShapeType
C#
public ShapeType Style {get; set;}

Property Value

A GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel.ShapeType.html enumeration value that determines the shape to be printed.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.Style = ShapeType.Ellipse;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.Style = ShapeType.Ellipse
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Style Class

[image]
ActiveReports 19 .NET Edition
Style Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

Represents the formatting properties of a control.

Object Model

Style Class

Syntax

Visual Basic (Declaration)
Public Class Style
C#
public class Style

Remarks

The Style class encapsulates the properties that control the appearance of a control and can be applied to multiple controls to provide a common appearance.

Style properties can be cascaded using inheritance. When creating a new style you can set the values of unset properties to inherit from a parent style. For example, if you have a style named "Normal", you can create a new style named "NormalBold" and set only the Parent property to "Normal" and the FontBold property to true. The remaining properties will be set the same as the parent style.

ActiveReports has a set of built-in styles that are defined in the StyleSheet class.

Example

Paste inside the ReportStart event.
C# Copy Code
private void rptGrapeCity_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Members
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Style Class Members

[image]
ActiveReports 19 .NET Edition
Style Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

The following tables list the members exposed by Style.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Style Class Properties

[image]
ActiveReports 19 .NET Edition
Style Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

For a list of all members of this type, see Style members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Alignment Property

Glossary Item Box

Gets or sets the horizontal text alignment of the control to which the style is applied.

Syntax

Visual Basic (Declaration)
Public Property Alignment As Object
C#
public object Alignment {get; set;}

Property Value

An enumeration value that specifies the horizontal text alignment.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Object
C#
public object BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


CharacterSet Property

[image]
ActiveReports 19 .NET Edition
CharacterSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : CharacterSet Property

Glossary Item Box

Gets or sets the CharacterSet of the control. The value must be cast as a byte.

Syntax

Visual Basic (Declaration)
Public Property CharacterSet As Object
C#
public object CharacterSet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontBold Property

[image]
ActiveReports 19 .NET Edition
FontBold Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontBold Property

Glossary Item Box

Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontBold As Object
C#
public object FontBold {get; set;}

Property Value

A Boolean value. True if the control font should be set to bold; False otherwise.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontItalic Property

[image]
ActiveReports 19 .NET Edition
FontItalic Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontItalic Property

Glossary Item Box

Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontItalic As Object
C#
public object FontItalic {get; set;}

Property Value

A Boolean value. True if the control font should be set to italic; False otherwise.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontName Property

[image]
ActiveReports 19 .NET Edition
FontName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontName Property

Glossary Item Box

Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontName As Object
C#
public object FontName {get; set;}

Property Value

The name of the font that should be used to render the control text.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontSize Property

Glossary Item Box

Gets or sets the size of the font used to render the control.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Object
C#
public object FontSize {get; set;}

Property Value

Float font size in points or null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontStrikeThrough Property

[image]
ActiveReports 19 .NET Edition
FontStrikeThrough Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontStrikeThrough Property

Glossary Item Box

Gets or sets the Font.StrikeThrough property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontStrikeThrough As Object
C#
public object FontStrikeThrough {get; set;}

Property Value

A Boolean value. True if the control font should be set to strikethrough; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontUnderline Property

[image]
ActiveReports 19 .NET Edition
FontUnderline Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontUnderline Property

Glossary Item Box

Gets or sets the Font.Underline property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontUnderline As Object
C#
public object FontUnderline {get; set;}

Property Value

A Boolean value. True if the control font should be set to underline; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontVertical Property

[image]
ActiveReports 19 .NET Edition
FontVertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontVertical Property

Glossary Item Box

Gets or sets the Font.Vertical property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontVertical As Object
C#
public object FontVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : ForeColor Property

Glossary Item Box

Gets or sets the text color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Object
C#
public object ForeColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to render the control text. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Name Property

Glossary Item Box

Gets or sets the unique name of the style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A string name of the style.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Parent Property

Glossary Item Box

Gets or sets the name of the parent style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Style
C#
public Style Parent {get;}

Property Value

A string name of the Style from which this Style object inherits its properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Value Property

Glossary Item Box

Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the vertical alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As Object
C#
public object VerticalAlignment {get; set;}

Property Value

A VerticalTextAlignment value that represents the alignment to be applied to the control's content. Null if the property is inherited from the Style parent.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


StyleSheet Class

[image]
ActiveReports 19 .NET Edition
StyleSheet Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

Represents the collection of Style objects used to format controls.

Object Model

StyleSheet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StyleSheet
C#
public sealed class StyleSheet

Remarks

You can use this collection to add or modify the styles used in the report and globally modify the formatting of controls in your report.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.StyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Members
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


StyleSheet Class Members

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

The following tables list the members exposed by StyleSheet.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


StyleSheet Class Methods

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Add Method

Glossary Item Box

Adds a new Style object to the collection.

Overload List

Overload | Description
Add(String) | Adds a new Style object with the specified name to the collection.
Add(String,String) | Adds a new Style object to the collection and sets its parent style to the specified parent Style.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Add(String) Method

[image]
ActiveReports 19 .NET Edition
Add(String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String) Method

name
Specifies the name of the new style. Used as a key to access the style.

Glossary Item Box

Adds a new Style object with the specified name to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal name As String _
)
C#
public void Add(
   string name
)

Parameters

name
Specifies the name of the new style. Used as a key to access the style.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Add(String,String) Method

[image]
ActiveReports 19 .NET Edition
Add(String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String,String) Method

name
Specifies the name of the new Style object.
nameOfParent
Specifies the parent Style whose properties will be inherited by the new Style.

Glossary Item Box

Adds a new Style object to the collection and sets its parent style to the specified parent Style.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal name As String, _
   ByVal nameOfParent As String _
)
C#
public void Add(
   string name,
   string nameOfParent
)

Parameters

name
Specifies the name of the new Style object.
nameOfParent
Specifies the parent Style whose properties will be inherited by the new Style.

Remarks

Styles are cascaded. Any properties not specified in the child Style are inherited from the parent Style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Clear Method

Glossary Item Box

Removes the SytleSheet object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Contains Method

value
The value to check.

Glossary Item Box

Determines whether the StyleSheet object contains the specified object.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
The value to check.

Return Value

Boolean. Returns True if the collection contains the value; otherwise False

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : CopyTo Method

array
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the Style object to the indicated location.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : IndexOf Method

value

The StyleSheet object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value

The StyleSheet object to locate in the collection.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Insert Method

index
The index at which to insert the StyleSheet object.
value
The StyleSheet to insert.

Glossary Item Box

Inserts the specified StyleSheet into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The index at which to insert the StyleSheet object.
value
The StyleSheet to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Remove Method

Glossary Item Box

Removes a style from the collection. Removes the Style object from the collection.

Overload List

Overload | Description
Remove(Int32) | Removes the Style object at the specified index.
Remove(String) | Removes the Style object with the specified name.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Remove(Int32) Method

[image]
ActiveReports 19 .NET Edition
Remove(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(Int32) Method

index
Specifies the index of the Style object to be removed from the collection.

Glossary Item Box

Removes the Style object at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index
Specifies the index of the Style object to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Remove(String) Method

[image]
ActiveReports 19 .NET Edition
Remove(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(String) Method

name
Specified the name of the Style to be removed from the collection.

Glossary Item Box

Removes the Style object with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal name As String _
)
C#
public void Remove(
   string name
)

Parameters

name
Specified the name of the Style to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : RemoveAt Method

index
The index of the StyleSheet to remove.

Glossary Item Box

Removes the StyleSheet object at the specified location from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the StyleSheet to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Count Property

Glossary Item Box

Returns the number of Style objects in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An integer value that represents the total number of styles in the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Console.WriteLine("contains " & Me.StyleSheet.Count.ToString & " stylesheets")
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Item Property

Glossary Item Box

Returns a reference to a Style object in the collection.

Overload List

Overload | Description
Item(Int32) | Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.
Item(String) | Gets the StyleSheet object with the specified name in the StyleSheetCollection.

Example

C# Copy Code
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(Int32) Property

index
Specifies the index of the Style to be returned.

Glossary Item Box

Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Style
C#
public Style Item(
   int index
) {get;}

Parameters

index
Specifies the index of the Style to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(String) Property

name
Specifies the name of the Style object to be returned.

Glossary Item Box

Gets the StyleSheet object with the specified name in the StyleSheetCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Style
C#
public Style Item(
   string name
) {get;}

Parameters

name
Specifies the name of the Style object to be returned.

Example

C# Copy Code
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


StyleSheet Class Events

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace

How To

Use External Style Sheets


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Changed Event

Glossary Item Box

Occurs when the members of the StyleSheet have changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


SubReport Class

[image]
ActiveReports 19 .NET Edition
SubReport Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

Prints a linked report object as part of the current report. Subreports are linked using the Report property.

Object Model

SubReport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SubReport
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class SubReport : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.SubReport1.CanGrow = true;
    this.SubReport1.CanShrink = false;
    this.SubReport1.ReportName = "Subreport1";

    SectionReport1 rpt = new SectionReport1();
    this.SubReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.SubReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Members
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Class Members

[image]
ActiveReports 19 .NET Edition
SubReport Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

The following tables list the members exposed by SubReport.

Public Constructors

 | Name | Description
Public Constructor | SubReport Constructor | Initializes a new instance of the SubReport class.
Top

Public Properties

 | Name | Description
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Top

See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Constructor

[image]
ActiveReports 19 .NET Edition
SubReport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : SubReport Constructor

Glossary Item Box

Initializes a new instance of the SubReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SubReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

[image]
ActiveReports 19 .NET Edition
SubReport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

For a list of all members of this type, see SubReport members.

Public Properties

 | Name | Description
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Top

See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


CloseBorder Property

[image]
ActiveReports 19 .NET Edition
CloseBorder Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CloseBorder Property

Glossary Item Box

Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.

Syntax

Visual Basic (Declaration)
Public Property CloseBorder As Boolean
C#
public bool CloseBorder {get; set;}

Property Value

A Boolean value. If True, the subreport borders will be closed on every page on which the subreport is rendered. The default value is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.CloseBorder = true;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.CloseBorder = True
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : Report Property

Glossary Item Box

Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.

Syntax

Visual Basic (Declaration)
Public Property Report As SectionReport
C#
public SectionReport Report {get; set;}

Remarks

You should set this property to a new instance of the report you want to render in the ReportStart event of the parent report.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : ReportName Property

Glossary Item Box

Specifies the name of the subreport.

Syntax

Visual Basic (Declaration)
Public Property ReportName As String
C#
public string ReportName {get; set;}

Remarks

This property has no effect. It is informational only. You can use it for your own purposes.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


TextBox Class

[image]
ActiveReports 19 .NET Edition
TextBox Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

Prints a formatted text value, bound or unbound.

Object Model

TextBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextBox
   Inherits ARControl
   Implements GrapeCity.ActiveReports.Controls.Design.IPersistControl
C#
public sealed class TextBox : ARControl, GrapeCity.ActiveReports.Controls.Design.IPersistControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.ClassName = "Normal";
    this.textBox1.DistinctField = null;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.MultiLine = true;
    this.textBox1.OutputFormat = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
    this.textBox1.Text = "TextBox";
    this.textBox1.VerticalAlignment = VerticalTextAlignment.Top;
    this.textBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.MultiLine = True
   Me.TextBox1.OutputFormat = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
   Me.TextBox1.Text = "TextBox"
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
   Me.TextBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.TextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Class Members

[image]
ActiveReports 19 .NET Edition
TextBox Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor | Initializes a new instance of the TextBox class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Constructor

[image]
ActiveReports 19 .NET Edition
TextBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextBox Constructor

Glossary Item Box

Initializes a new instance of the TextBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

[image]
ActiveReports 19 .NET Edition
TextBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As TextAlignment
C#
public TextAlignment Alignment {get; set;}

Property Value

TextAlignment enumeration. The default value is TextAlignment.Left.

Remarks

The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Calendar Property

[image]
ActiveReports 19 .NET Edition
Calendar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Calendar Property

Glossary Item Box

Gets or sets calendar to use for formatting dates

Syntax

Visual Basic (Declaration)
Public Property Calendar As String
C#
public string Calendar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the distance in points between individual characters in the textbox control.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Remarks

The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = true;
   this.textBox1.MultiLine = true;
   this.textBox1.CharacterSpacing = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.CharacterSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.

Remarks

You can use predefined styles in the report's stylesheet or add new ones to it.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CountNullValues Property

[image]
ActiveReports 19 .NET Edition
CountNullValues Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CountNullValues Property

Glossary Item Box

Determines whether DBNull values should be included as zeroes in summary fields.

Syntax

Visual Basic (Declaration)
Public Property CountNullValues As Boolean
C#
public bool CountNullValues {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
    this.textBox1.CountNullValues = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
   TextBox1.CountNullValues = True;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Culture Property

Glossary Item Box

Gets or sets the culture for the text control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


DistinctField Property

[image]
ActiveReports 19 .NET Edition
DistinctField Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : DistinctField Property

Glossary Item Box

Gets or sets the name of the data field used in a distinct summary function.

Syntax

Visual Basic (Declaration)
Public Property DistinctField As String
C#
public string DistinctField {get; set;}

Property Value

A string value that represents the field name to be used as a distinct field in the summary calculation.

Remarks

The summary function will process DataField values based on the distinct value of this field.

This property is used only when the SummaryFunc value is one of Distinct Summary Functions. When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.DistinctField = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

Current Font object used to render the control's text.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Font = new System.Drawing.Font("Times New Roman", 14, System.Drawing.FontStyle.Bold);
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.TextBox1.Font = New System.Drawing.Font("Times New Roman", 14, FontStyle.Bold)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

Current font color. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


HyperLink Property

[image]
ActiveReports 19 .NET Edition
HyperLink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : HyperLink Property

Glossary Item Box

Gets or sets a hyperlink for the text control.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Property Value

A string value that specifies the target of the hyperlink.

Remarks

Hyperlinks can be used in the viewer control to allow users to link to a bookmark in the report "toc://bookmark" or to a properly formatted internet target location (http, ftp, etc).

Clicking a hyperlink in the viewer control raises the HyperLink event.

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "https://developer.mescius.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.Text = "Email support.";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.Text = "Email support."
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : LineSpacing Property

Glossary Item Box

Gets or sets the spacing in points between the lines of text within the textbox.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = True;
   this.textBox1.MultiLine = True;
   this.textBox1.LineSpacing = 5;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.LineSpacing = 5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


MinCondenseRate Property

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : MinCondenseRate Property

Glossary Item Box

Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property MinCondenseRate As Integer
C#
public int MinCondenseRate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether this is a multiline textbox control.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Property Value

A Boolean value. True if the textbox control is multi-line; otherwise, False.

Remarks

A multiline textbox control renders its text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a newline character is encountered.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.CanGrow = true;
    this.TextBox1.CanShrink = false;
    this.TextBox1.MultiLine = true;
    this.TextBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


OutputFormat Property

[image]
ActiveReports 19 .NET Edition
OutputFormat Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : OutputFormat Property

Glossary Item Box

Gets or sets the mask string used to format the Value property before placing it in the Text property.

Syntax

Visual Basic (Declaration)
Public Property OutputFormat As String
C#
public string OutputFormat {get; set;}

Remarks

The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings.

Setting the OutputFormat in the Format event of a control's section does not catch the first record. The reason for this behaviour is that the database values are applied to the the control BEFORE the Format event. If you change the OutputFormat in the Format event, set Control.Value=Control.Value so that the OutputFormat gets reapplied.

Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.

The OutputFormat property of the TextBox control includes four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.OutputFormat = "MMMM";
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.OutputFormat = "MMMM"
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members

Concepts

Date, Time, and Number Formatting


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Remarks

This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : RightToLeft Property

Glossary Item Box

Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Property Value

true if [right to left]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ShrinkToFit Property

Glossary Item Box

Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Style Property

Glossary Item Box

Gets or sets a style string for the textbox.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


SummaryFunc Property

[image]
ActiveReports 19 .NET Edition
SummaryFunc Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryFunc Property

Glossary Item Box

Gets or sets the summary function type used to process the DataField values.

Syntax

Visual Basic (Declaration)
Public Property SummaryFunc As SummaryFunc
C#
public SummaryFunc SummaryFunc {get; set;}

Property Value

SummaryFunc enumeration value that specifies the type of summarization to be performed on the field. Default is SummaryFunc.Sum

Remarks

You can use this function to create subtotals, grand totals and other summary values. SummaryFunc has no effect unless the SummaryType property is set to either SubTotal or GrandTotal.

Note: When a summary function is used on a control, the CanGrow and CanShrink properties will have no effect since the summary is calculated after the control height has been determined and finalized.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


SummaryGroup Property

[image]
ActiveReports 19 .NET Edition
SummaryGroup Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryGroup Property

Glossary Item Box

Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.

Syntax

Visual Basic (Declaration)
Public Property SummaryGroup As String
C#
public string SummaryGroup {get; set;}

Remarks

For example, setting a sum of Price for an Order group header will reset the sum to zero for each order group. The property is only used when SummaryType is set to SummaryType.SubTotal

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


SummaryRunning Property

[image]
ActiveReports 19 .NET Edition
SummaryRunning Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryRunning Property

Glossary Item Box

Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).

Syntax

Visual Basic (Declaration)
Public Property SummaryRunning As SummaryRunning
C#
public SummaryRunning SummaryRunning {get; set;}

Property Value

SummaryRunning enumeration that determines the summarization behavior. Default is SummaryRunning.None.

Remarks

Setting this property to Group or All will make ActiveReports print a running summary of the field at the group or report level.

When used with Groups this property should only be set when SummaryType is GrandTotal or PageTotal, otherwise it should be set to None.

Example

C# Copy Code
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


SummaryType Property

[image]
ActiveReports 19 .NET Edition
SummaryType Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryType Property

Glossary Item Box

Gets or sets a value that determines the summary type to be performed.

Syntax

Visual Basic (Declaration)
Public Property SummaryType As SummaryType
C#
public SummaryType SummaryType {get; set;}

Property Value

A SummaryType enumeration value that determines the type of summary to be performed. Default is SummaryType.None.

Remarks

ActiveReports can summarize the field as:

  • Subtotal (group level; reset for each group),
  • Grand total (report level; do not reset until all records are processed),
  • Page total (page level; reset for each page),
  • or a page count, which is the total number of pages printed.

If the summarized field is placed ahead of its summary level, (for example, placing a page total in the page header or a report grand total in the report header), the containing section and the following sections will not be printed until the summary value is resolved (calculated). When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example

C# Copy Code
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Text Property

Glossary Item Box

Gets or sets the formatted text value to be rendered in the control.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

String value that represents the text to be rendered in the control.

Remarks

Use the Value property to modify the control's content, the Value will be formatted using OutputFormat into the Text property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Text = "TextBox";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Text = "TextBox"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextJustify Property

Glossary Item Box

Gets or sets the type of justification to use when the Alignment property is set to Justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines

Remarks

When you set the Alignment property to Justify, this property extends your justification options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Value Property

Glossary Item Box

Gets or sets the value of the control before formatting.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

An object that represents the current value of the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.TextBox1.Value.ToString() == "10249")
    {
        this.txtShippedDate.OutputFormat = "MMMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Crimson;
    }
    else
    {
        this.txtShippedDate.OutputFormat = "MMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Black;
    }
    //use the following lines to be sure that the OutputFormat
    //is applied to every record
    this.TextBox1.Value = this.TextBox1.Value;
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
Visual Basic Copy Code
Private Sub detail_Format(sender As Object, eArgs As System.EventArgs)
    If Me.TextBox1.Value.ToString() = "10249" Then
        Me.txtShippedDate.OutputFormat = "MMMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Crimson
    Else
        Me.txtShippedDate.OutputFormat = "MMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Black
    End If
    'use the following lines to be sure that the OutputFormat
    'is applied to every record
    Me.TextBox1.Value = Me.TextBox1.Value
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the control's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


VerticalText Property

[image]
ActiveReports 19 .NET Edition
VerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalText Property

Glossary Item Box

Gets or sets whether the control's text is rendered according to the vertical layout rules.

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Remarks

In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : WrapMode Property

Glossary Item Box

Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


BackgroundStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BackgroundStyle Enumeration

Glossary Item Box

Specifies the style used to draw the background of an object.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundStyle
   Inherits System.Enum
C#
public enum BackgroundStyle : System.Enum

Members

Member | Description
Gradient | A gradient fill is used for the background.
Pattern | A pattern fill is used for the background.
Solid | A solid fill is used for the background.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BackgroundStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


BarCodeCaptionPosition Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeCaptionPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeCaptionPosition Enumeration

Glossary Item Box

Specifies the barcode caption position relative to the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeCaptionPosition
   Inherits System.Enum
C#
public enum BarCodeCaptionPosition : System.Enum

Members

Member | Description
Above | Caption is printed above the barcode symbol.
Below | Caption is printed below the barcode symbol.
None | Caption is not printed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeCaptionPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


BarCodeDirection Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeDirection Enumeration

Glossary Item Box

Specifies the print direction of the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeDirection
   Inherits System.Enum
C#
public enum BarCodeDirection : System.Enum

Members

Member | Description
BottomToTop | The barcode symbol is printed bottom to top.
LeftToRight | The barcode symbol is printed left to right (default).
RightToLeft | The barcode symbol is printed right to left.
TopToBottom | The barcode symbol is printed top to bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


BarCodeStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeStyle Enumeration

Glossary Item Box

Type of code, or symbology, the barcode control will use to generate the barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeStyle
   Inherits System.Enum
C#
public enum BarCodeStyle : System.Enum

Members

Member | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Aztec | Aztec Code
BC412 | Data BC412 uses 35 characters, 0 - 9 and A - Z. It is designed for semiconductor wafer identification.
Codabar | Codabar uses A B C D + - : , / and numbers.
Code_11 | Encodes the numbers 0 through 9, the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). If there are only 12 numbers in the string, it calculates a checksum and adds it to the thirteenth position. If there are 13, it validates the checksum and throws an error if it is incorrect.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1

EAN-128 is an alphanumeric one-dimensional representation of Application Identifier data. It is not meant for point-of-sales use, but for marking containers in the shipping industry.

This type of bar code contains the following sections:

  • Leading quiet zone (blank area)
  • Code 128 start character
    • A allows standard alphanumeric plus control and special characters
    • B allows standard alphanumeric plus lower case alpha and special characters
    • C allows a set of 100 digit pairs from 00 to 99
  • FNC (function) 1 character which allows scanners to identify this as an EAN-128 barcode
  • Data (AI or Application Identifier plus data field)
  • Symbol check character (Start code value plus product of each character position plus value of each character divided by 103. The checksum is the remainder value.)
  • Stop character
  • Trailing quiet zone (blank area)

The AI or Application Identifier in the Data section sets the type of the data to follow (i.e. ID, dates, quantity, measurements, etc.). There is a specific data structure for each type of data. This AI is what distinguishes the EAN-128 code from Code 128.

Multiple AIs (along with their data) can be combined into a single bar code.

EAN128FNC1 is a UCC/EAN-128 (EAN128) type barcode that allows you to insert FNC1 character at any place and adjust the bar size etc, which is not available in UCC/EAN-128.

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.

GS1DataMatrix | GS1 Data Matrix
GS1QRCode | GS1 QRCode
HIBCCode128 | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
HIBCCode39 | HIBCCode39 barcode uses the Code39 symbology, with Code39OptionalCheckDigit property set to True. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numbers with a check digit.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | Interleaved Two of Five. This code is used to mark cartons and palettes that are including goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars. Matrix_2_of_5 uses only numbers.
MaxiCode | MaxiCode is special polar barcode.
MicroPDF417 | MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.
MicroQRCode | Micro QR Code is a variant of QR Code, with reduced barcode size. It has only one position detection pattern.
MSI | MSI Code uses only numbers.
None | None.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. Capable of encoding as many as 2725 data characters.
Pharmacode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet uses only numbers with a check digit.
PZN | PZN Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification for use with omnidirectional point-of-sale scanners.
RSS14Stacked | RSS14Stacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14Truncated, but stacked in two rows when RSS14Truncated is too wide.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14, but stacked in two rows when RSS14 is too wide.
RSS14Truncated | RSS14Truncated is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus Indicator digits for use on small items, not for point-of-sale scanners.
RSSExpanded | RSSExpanded is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus AI element strings (expiration date, weight, etc.) for use with omnidirectional point-of-sale scanners.
RSSExpandedStacked | RSSExpandedStacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSSExpanded, but stacked in two rows when RSSExpanded is too wide.
RSSLimited | RSS Limited is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification with indicator digits of 0 or 1 in a small symbol that is not scanned by point-of-sale scanners.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be 0 (zero)) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeStyle

Requirements

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnDirection Enumeration

[image]
ActiveReports 19 .NET Edition
ColumnDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ColumnDirection Enumeration

Glossary Item Box

Specifies the direction of columns in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Enum ColumnDirection
   Inherits System.Enum
C#
public enum ColumnDirection : System.Enum

Members

Member | Description
AcrossDown | Print a row of details across all the columns before beginning a second row below it, and so on.
DownAcross | Prints a column of details down the first column before moving on to the next column to its right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ColumnDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


ContentAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
ContentAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ContentAlignment Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ContentAlignment
   Inherits System.Enum
C#
public enum ContentAlignment : System.Enum

Members

Member | Description
BottomCenter |
BottomLeft |
BottomRight |
MiddleCenter |
MiddleLeft |
MiddleRight |
TopCenter |
TopLeft |
TopRight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ContentAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


GradientStyle Enumeration

[image]
ActiveReports 19 .NET Edition
GradientStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GradientStyle Enumeration

Glossary Item Box

Specifies the type of gradient to draw.

Syntax

Visual Basic (Declaration)
Public Enum GradientStyle
   Inherits System.Enum
C#
public enum GradientStyle : System.Enum

Members

Member | Description
DiagonalDown | The gradient is drawn from top left to bottom right.
DiagonalUp | The gradient is drawn from bottom left to top right.
FromCenter | A radial gradient is drawn from the center.
FromCorner | A radial gradient is drawn to the center.
Horizontal | A horizontal gradient is drawn.
Vertical | A vertical gradient is drawn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.GradientStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


GroupKeepTogether Enumeration

[image]
ActiveReports 19 .NET Edition
GroupKeepTogether Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupKeepTogether Enumeration

Glossary Item Box

Specifies whether a group header and footer pair with associated details will print as a single block on the same page.

Syntax

Visual Basic (Declaration)
Public Enum GroupKeepTogether
   Inherits System.Enum
C#
public enum GroupKeepTogether : System.Enum

Members

Member | Description
All | The group header, detail and group footer sections will print together on the same page.
FirstDetail | The group header will print with at least the first detail section on the same page or column.
None | A page can be broken immediately after a group header.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.GroupKeepTogether

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


HatchStyle Enumeration

[image]
ActiveReports 19 .NET Edition
HatchStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : HatchStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HatchStyle
   Inherits System.Enum
C#
public enum HatchStyle : System.Enum

Members

Member | Description
BackwardDiagonal |
Cross |
DarkDownwardDiagonal |
DarkHorizontal |
DarkUpwardDiagonal |
DarkVertical |
DashedDownwardDiagonal |
DashedHorizontal |
DashedUpwardDiagonal |
DashedVertical |
DiagonalBrick |
DiagonalCross |
Divot |
DottedDiamond |
DottedGrid |
ForwardDiagonal |
Horizontal |
HorizontalBrick |
LargeCheckerBoard |
LargeConfetti |
LargeGrid |
LightDownwardDiagonal |
LightHorizontal |
LightUpwardDiagonal |
LightVertical |
Max |
Min |
NarrowHorizontal |
NarrowVertical |
OutlinedDiamond |
Percent05 |
Percent10 |
Percent20 |
Percent25 |
Percent30 |
Percent40 |
Percent50 |
Percent60 |
Percent70 |
Percent75 |
Percent80 |
Percent90 |
Plaid |
Shingle |
SmallCheckerBoard |
SmallConfetti |
SmallGrid |
SolidDiamond |
Sphere |
Trellis |
Vertical |
Wave |
Weave |
WideDownwardDiagonal |
WideUpwardDiagonal |
ZigZag |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.HatchStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


ImageTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ImageTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ImageTypes Enumeration

Glossary Item Box

Specifies the type of image to be used for a chart.

Syntax

Visual Basic (Declaration)
Public Enum ImageTypes
   Inherits System.Enum
C#
public enum ImageTypes : System.Enum

Members

Member | Description
Metafile | This is the default value. A metafile is used.
PNG | A PNG file is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ImageTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


LineStyle Enumeration

[image]
ActiveReports 19 .NET Edition
LineStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : LineStyle Enumeration

Glossary Item Box

Specifies the pen style used to draw a line.

Syntax

Visual Basic (Declaration)
Public Enum LineStyle
   Inherits System.Enum
C#
public enum LineStyle : System.Enum

Members

Member | Description
Dash | Dashes.
DashDot | Alternating dashes and dots.
DashDotDot | Alternating dashes and two dots.
Dot | Dots.
Double | Double line.
Solid | Solid line.
Transparent | No line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.LineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


NewColumn Enumeration

[image]
ActiveReports 19 .NET Edition
NewColumn Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewColumn Enumeration

Glossary Item Box

Specifies whether a new column will be started before or after a section.

Syntax

Visual Basic (Declaration)
Public Enum NewColumn
   Inherits System.Enum
C#
public enum NewColumn : System.Enum

Members

Member | Description
After | The report will break to a new column after each instance of the section.
Before | The report will break to a new column before each instance of the section.
BeforeAfter | The report will break to a new column before and after each instance of the section.
None | Sections will continue printing in the same column until they've run out of space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


NewPage Enumeration

[image]
ActiveReports 19 .NET Edition
NewPage Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewPage Enumeration

Glossary Item Box

Specifies whether a new page will be started before or after a section.

Syntax

Visual Basic (Declaration)
Public Enum NewPage
   Inherits System.Enum
C#
public enum NewPage : System.Enum

Members

Member | Description
After | The report will break to a new page after each instance of the section.
Before | The report will break to a new page before each instance of the section.
BeforeAfter | The report will break to a new page before and after each instance of the section.
None | Sections will continue printing on the same page until they've run out of space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


Parameter.DataType Enumeration

[image]
ActiveReports 19 .NET Edition
Parameter.DataType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter.DataType Enumeration

Glossary Item Box

Specifies the data type used to create the input control for collection of report parameter values.

Syntax

Visual Basic (Declaration)
Public Enum Parameter.DataType
   Inherits System.Enum
C#
public enum Parameter.DataType : System.Enum

Members

Member | Description
Boolean | Create a checkbox to collect the parameter value as a Boolean.
Date | Create a month calendar drop-down dialog to collect the parameter value as a date.
String | Create a textbox to collect the parameter value as a string.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


ParameterCollection.ParseResultCode Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterCollection.ParseResultCode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection.ParseResultCode Enumeration

Glossary Item Box

Specifies the results of parsing the report's parameter values.

Syntax

Visual Basic (Declaration)
Public Enum ParameterCollection.ParseResultCode
   Inherits System.Enum
C#
public enum ParameterCollection.ParseResultCode : System.Enum

Members

Member | Description
MissingCloseParam | Indicates that the Parameter value is missing the parameter close.
MissingParamName | Indicates that the Parameter value is missing the parameter name.
Success | Indicates that the Parameter value is successful.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


PictureAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
PictureAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PictureAlignment Enumeration

Glossary Item Box

Determines the position of the picture within the control area.

Syntax

Visual Basic (Declaration)
Public Enum PictureAlignment
   Inherits System.Enum
C#
public enum PictureAlignment : System.Enum

Members

Member | Description
BottomLeft | The picture will print in the bottom left corner of the control.
BottomRight | The picture will print in the bottom right corner of the control.
Center | The picture will be centered within the control.
TopLeft | The picture will print in the top left corner of the control.
TopRight | The picture will print in the top right corner of the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.PictureAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
MESCIUS.ActiveReports~GrapeCity.ActiveReports.SectionReportModel~WatermarkAlignment


RepeatStyle Enumeration

[image]
ActiveReports 19 .NET Edition
RepeatStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RepeatStyle Enumeration

Glossary Item Box

Specifies whether a group header section will be repeated with subsequent detail pages.

Syntax

Visual Basic (Declaration)
Public Enum RepeatStyle
   Inherits System.Enum
C#
public enum RepeatStyle : System.Enum

Members

Member | Description
All | Repeat the group header section on every page or column.
None | The group header will not be repeated when the associated detail sections print on a new page.
OnColumn | Repeat the group header section with every new column.
OnPage | Repeat the group header section with every new page.
OnPageIncludeNoDetail | Repeat the group header section on every page that includes an associated detail section or a group footer section. This setting prevents orphaned group footer sections.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RepeatStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox.FindOptions Enumeration

[image]
ActiveReports 19 .NET Edition
RichTextBox.FindOptions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.FindOptions Enumeration

Glossary Item Box

Specifies how a text search is carried out in a RichTextBox control.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
Public Enum RichTextBox.FindOptions
   Inherits System.Enum
C#
public enum RichTextBox.FindOptions : System.Enum

Members

Member | Description
MatchCase | Locate only instances of the search text that have the exact casing.
None | Locate all instances of the search text to determine whether the instances found in the search are whole words or not.
Reverse | Starts the search at the end of the control's document and searches to the beginning of the document.
WholeWord | Locate only instances of the search text that are whole words.

Remarks

An application locates text in the RichTextBox control by calling the Find method of the RichTextBox control. This enumeration enables you to specify how the search is performed when the Find method is called. You can combine one or more values from this enumeration to specify more than one search option when calling the Find method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.FindOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox.RichTextStreamType Enumeration

[image]
ActiveReports 19 .NET Edition
RichTextBox.RichTextStreamType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.RichTextStreamType Enumeration

Glossary Item Box

Determines the RichText control's content type.

Syntax

Visual Basic (Declaration)
Public Enum RichTextBox.RichTextStreamType
   Inherits System.Enum
C#
public enum RichTextBox.RichTextStreamType : System.Enum

Members

Member | Description
PlainText | The RichText control contains a plain text stream that includes spaces in place of Object Linking and Embedding (OLE) objects.
RichText | The RichText control contains a Rich Text Format (RTF) stream.
UnicodePlainText | The RichText control contains a text stream that contains spaces in place of Object Linking and Embedding (OLE) objects. The text is encoded in Unicode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.RichTextStreamType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextRenderingType Enumeration

[image]
ActiveReports 19 .NET Edition
RichTextRenderingType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextRenderingType Enumeration

Glossary Item Box

Enum for RichTextRenderingType.

Syntax

Visual Basic (Declaration)
Public Enum RichTextRenderingType
   Inherits System.Enum
C#
public enum RichTextRenderingType : System.Enum

Members

Member | Description
Metafile | HTML
PNG | Text
RTF | RTF
TransparentPNG | PNG With Transparent Background

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextRenderingType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextType Enumeration

[image]
ActiveReports 19 .NET Edition
RichTextType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextType Enumeration

Glossary Item Box

Determines the type of stream to load into the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Enum RichTextType
   Inherits System.Enum
C#
public enum RichTextType : System.Enum

Members

Member | Description
Html | Loads an html stream into the RichTextBox control.
Rtf | Loads an rtf stream into the RichTextBox control.
Text | Loads a plain text stream into the RichTextBox control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


ShapeType Enumeration

[image]
ActiveReports 19 .NET Edition
ShapeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ShapeType Enumeration

Glossary Item Box

Specifies the type of shape that the shape control should print.

Syntax

Visual Basic (Declaration)
Public Enum ShapeType
   Inherits System.Enum
C#
public enum ShapeType : System.Enum

Members

Member | Description
Ellipse | Print an elliptical shape.
Rectangle | Print a rectangular shape.
RoundRect | Print a rounded rectangular shape.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ShapeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


SizeModes Enumeration

[image]
ActiveReports 19 .NET Edition
SizeModes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SizeModes Enumeration

Glossary Item Box

Determines how a picture should be sized within the control area.

Syntax

Visual Basic (Declaration)
Public Enum SizeModes
   Inherits System.Enum
C#
public enum SizeModes : System.Enum

Members

Member | Description
Clip | The image is clipped to fit within the control area.
Stretch | The image is stretched to fit the control area.
Zoom | The image is scaled until it fits horizontally and vertically within the control area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SizeModes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


StringAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
StringAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StringAlignment Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringAlignment
   Inherits System.Enum
C#
public enum StringAlignment : System.Enum

Members

Member | Description
Center |
Far |
Near |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.StringAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


SummaryFunc Enumeration

[image]
ActiveReports 19 .NET Edition
SummaryFunc Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryFunc Enumeration

Glossary Item Box

Determines the summary calculation function performed on the field value.

Syntax

Visual Basic (Declaration)
Public Enum SummaryFunc
   Inherits System.Enum
C#
public enum SummaryFunc : System.Enum

Members

Member | Description
Avg | Calculates the average of all values within the specified summary region (group, page or report).
Count | Calculates the count of all values within the specified summary region (group, page or report).
DAvg | Calculates the average based on the distinct values of another field within the specified summary region (group, page or report).
DCount | Calculates the distinct count based on the distinct values of another field within the specified summary region (group, page or report).
DStdDev | Calculates the standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DStdDevP | Calculates the population standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DSum | Calculates the total based on the distinct values of another field within the specified summary region (group, page or report).
DVar | Calculates the variance based on the distinct values of another field within the specified summary region (group, page or report).
DVarP | Calculates the population distinct variance based on the distinct values of another field within the specified summary region (group, page or report).
Max | Calculates the maximum of all values within the specified summary region (group, page or report).
Min | Calculates the minimum of all values within the specified summary region (group, page or report).
StdDev | Calculates the standard deviation of all values within the specified summary region (group, page or report).
StdDevP | Calculates the population standard deviation of all values within the specified summary region (group, page or report).
Sum | Calculates the total of all values within the specified summary region (group, page or report).
Var | Calculates the variance of all values within the specified summary region (group, page or report).
VarP | Calculates the population variance of all values within the specified summary region (group, page or report).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryFunc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


SummaryRunning Enumeration

[image]
ActiveReports 19 .NET Edition
SummaryRunning Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryRunning Enumeration

Glossary Item Box

Determines whether summary values will be accumulated or reset based on the specified level.

Syntax

Visual Basic (Declaration)
Public Enum SummaryRunning
   Inherits System.Enum
C#
public enum SummaryRunning : System.Enum

Members

Member | Description
All | Calculates a running summary for all values.
Group | Calculates a running summary (each value is the sum of the current value and all preceding values) within the same group level.
None | Summary values are not accumulated.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryRunning

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


SummaryType Enumeration

[image]
ActiveReports 19 .NET Edition
SummaryType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryType Enumeration

Glossary Item Box

Determines the type of field summary.

Syntax

Visual Basic (Declaration)
Public Enum SummaryType
   Inherits System.Enum
C#
public enum SummaryType : System.Enum

Members

Member | Description
GrandTotal | Evaluate the specified summary function for all records in the report.
None | No summarization.
PageCount | Print the page count or page number. Use with SummaryRunning set to All to print the page number.
PageTotal | Evaluate the specified summary function for all records on each page.
SubTotal | Evaluate the specified summary function for all records in each group level.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


WebDesigner Class

[image]
ActiveReports 19 .NET Edition
WebDesigner Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet Namespace : WebDesigner Class

Glossary Item Box

Dummy class for obtaining a license.

Object Model

WebDesigner Class

Syntax

Visual Basic (Declaration)
Public Class WebDesigner
C#
public class WebDesigner

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.WebDesigner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesigner Members
GrapeCity.ActiveReports.Aspnet Namespace


WebDesigner Class Members

[image]
ActiveReports 19 .NET Edition
WebDesigner Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet Namespace : WebDesigner Class

Glossary Item Box

The following tables list the members exposed by WebDesigner.

Public Constructors

 | Name | Description
Public Constructor | WebDesigner Constructor |
Top

See Also

Reference

WebDesigner Class
GrapeCity.ActiveReports.Aspnet Namespace


WebDesigner Constructor

[image]
ActiveReports 19 .NET Edition
WebDesigner Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet Namespace > WebDesigner Class : WebDesigner Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WebDesigner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebDesigner Class
WebDesigner Members


ConfigureExtensions Class

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

Represents methods for configuring the web host application.

Object Model

ConfigureExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ConfigureExtensions
C#
public static class ConfigureExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.ConfigureExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ConfigureExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

The following tables list the members exposed by ConfigureExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReportDesigner | Overloaded. Configures middleware for the ActiveReports designer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ConfigureExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

For a list of all members of this type, see ConfigureExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReportDesigner | Overloaded. Configures middleware for the ActiveReports designer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


UseReportDesigner Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ConfigureExtensions Class : UseReportDesigner Method

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Overload List

Overload | Description
UseReportDesigner(IAppBuilder,Action<ReportDesignerConfiguration>) | Configures middleware for the ActiveReports designer API.
UseReportDesigner(IAppBuilder,IReportDesignerBackendApi) | Configures middleware for the ActiveReports designer API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportDesigner(IAppBuilder,Action<ReportDesignerConfiguration>) Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner(IAppBuilder,Action<ReportDesignerConfiguration>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ConfigureExtensions Class > UseReportDesigner Method : UseReportDesigner(IAppBuilder,Action<ReportDesignerConfiguration>) Method

app
The Owin.IAppBuilder to configure.
configAction
An Action to configure the report designer.

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportDesigner( _
   ByVal app As Owin.IAppBuilder, _
   ByVal configAction As Action(Of ReportDesignerConfiguration) _
)
C#
public static void UseReportDesigner(
   Owin.IAppBuilder app,
   Action<ReportDesignerConfiguration> configAction
)

Parameters

app
The Owin.IAppBuilder to configure.
configAction
An Action to configure the report designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


UseReportDesigner(IAppBuilder,IReportDesignerBackendApi) Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner(IAppBuilder,IReportDesignerBackendApi) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ConfigureExtensions Class > UseReportDesigner Method : UseReportDesigner(IAppBuilder,IReportDesignerBackendApi) Method

app
The Owin.IAppBuilder to configure.
api
The GrapeCity.ActiveReports.Web.Designer.IReportDesignerBackendApi to use for configuring the middleware.

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportDesigner( _
   ByVal app As Owin.IAppBuilder, _
   ByVal api As IReportDesignerBackendApi _
)
C#
public static void UseReportDesigner(
   Owin.IAppBuilder app,
   IReportDesignerBackendApi api
)

Parameters

app
The Owin.IAppBuilder to configure.
api
The GrapeCity.ActiveReports.Web.Designer.IReportDesignerBackendApi to use for configuring the middleware.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


ReportConverter Class

[image]
ActiveReports 19 .NET Edition
ReportConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

Represents methods for converting report content.

Object Model

ReportConverter Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportConverter
C#
public static class ReportConverter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Utilities.ReportConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Members
GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace


ReportConverter Class Members

[image]
ActiveReports 19 .NET Edition
ReportConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

The following tables list the members exposed by ReportConverter.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromJson | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.
static (Shared in Visual Basic) | FromXML | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.
static (Shared in Visual Basic) | ToJson | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.
static (Shared in Visual Basic) | ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.
Top

See Also

Reference

ReportConverter Class
GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace


ReportConverter Class Methods

[image]
ActiveReports 19 .NET Edition
ReportConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

For a list of all members of this type, see ReportConverter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromJson | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.
static (Shared in Visual Basic) | FromXML | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.
static (Shared in Visual Basic) | ToJson | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.
static (Shared in Visual Basic) | ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.
Top

See Also

Reference

ReportConverter Class
GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace


FromJson Method

[image]
ActiveReports 19 .NET Edition
FromJson Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace > ReportConverter Class : FromJson Method

content
A byte array containing the JSON report content.

Glossary Item Box

Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.

Syntax

Visual Basic (Declaration)
Public Shared Function FromJson( _
   ByVal content() As Byte _
) As Report
C#
public static Report FromJson(
   byte[] content
)

Parameters

content
A byte array containing the JSON report content.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


FromXML Method

[image]
ActiveReports 19 .NET Edition
FromXML Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace > ReportConverter Class : FromXML Method

content
A byte array containing the XML report content.
resourceLocator
An optional resource locator for resolving resources referenced in the report.

Glossary Item Box

Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.

Syntax

Visual Basic (Declaration)
Public Shared Function FromXML( _
   ByVal content() As Byte, _
   Optional ByVal resourceLocator As ResourceLocator _
) As Report
C#
public static Report FromXML(
   byte[] content,
   ResourceLocator resourceLocator
)

Parameters

content
A byte array containing the XML report content.
resourceLocator
An optional resource locator for resolving resources referenced in the report.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


ToJson Method

[image]
ActiveReports 19 .NET Edition
ToJson Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace > ReportConverter Class : ToJson Method

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.

Syntax

Visual Basic (Declaration)
Public Shared Function ToJson( _
   ByVal report As Report _
) As Byte()
C#
public static byte[] ToJson(
   Report report
)

Parameters

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Return Value

A byte array containing the JSON report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


ToXml(Report) Method

[image]
ActiveReports 19 .NET Edition
ToXml(Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace > ReportConverter Class : ToXml(Report) Method

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Syntax

Visual Basic (Declaration)
Public Shared Function ToXml( _
   ByVal report As Report _
) As Byte()
C#
public static byte[] ToXml(
   Report report
)

Parameters

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Return Value

A byte array containing the XML report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


DataSetTemplate Class

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

Represents a dataset template.

Object Model

DataSetTemplate Class

Syntax

Visual Basic (Declaration)
Public Class DataSetTemplate
C#
public class DataSetTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Members
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplate Class Members

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

The following tables list the members exposed by DataSetTemplate.

Public Constructors

 | Name | Description
Public Constructor | DataSetTemplate Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSet | Gets or sets the information about the dataset.
Public Property | DataSource | Gets or sets the information about the data source.
Top

See Also

Reference

DataSetTemplate Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplate Constructor

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSetTemplate Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSetTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSetTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

For a list of all members of this type, see DataSetTemplate members.

Public Properties

 | Name | Description
Public Property | DataSet | Gets or sets the information about the dataset.
Public Property | DataSource | Gets or sets the information about the data source.
Top

See Also

Reference

DataSetTemplate Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSet Property

[image]
ActiveReports 19 .NET Edition
DataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSet Property

Glossary Item Box

Gets or sets the information about the dataset.

Syntax

Visual Basic (Declaration)
Public Property DataSet As DataSet
C#
public DataSet DataSet {get; set;}

Property Value

An instance of DataSet containing the dataset information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSource Property

Glossary Item Box

Gets or sets the information about the data source.

Syntax

Visual Basic (Declaration)
Public Property DataSource As DataSource
C#
public DataSource DataSource {get; set;}

Property Value

An instance of DataSource containing the data source information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSetTemplateExtensions Class

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

Represents an extension methods for DataSetTemplate.

Object Model

DataSetTemplateExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataSetTemplateExtensions
C#
public static class DataSetTemplateExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplateExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplateExtensions Members
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplateExtensions Class Members

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

The following tables list the members exposed by DataSetTemplateExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToJsonStream | Converts the DataSetTemplate to a JSON stream.
Top

See Also

Reference

DataSetTemplateExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplateExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

For a list of all members of this type, see DataSetTemplateExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToJsonStream | Converts the DataSetTemplate to a JSON stream.
Top

See Also

Reference

DataSetTemplateExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ToJsonStream Method

[image]
ActiveReports 19 .NET Edition
ToJsonStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplateExtensions Class : ToJsonStream Method

dataSetTemplate
The DataSetTemplate to convert.

Glossary Item Box

Converts the DataSetTemplate to a JSON stream.

Syntax

Visual Basic (Declaration)
Public Shared Function ToJsonStream( _
   ByVal dataSetTemplate As DataSetTemplate _
) As Stream
C#
public static Stream ToJsonStream(
   DataSetTemplate dataSetTemplate
)

Parameters

dataSetTemplate
The DataSetTemplate to convert.

Return Value

A stream containing the JSON representation of the DataSetTemplate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplateExtensions Class
DataSetTemplateExtensions Members


ImageNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when an image cannot be found.

Object Model

ImageNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ImageNotFoundException
   Inherits System.Exception
C#
public class ImageNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.ImageNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ImageNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ImageNotFoundException Constructor |
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : ImageNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ImageResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

Represents a descriptor for an image resource.

Object Model

ImageResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ImageResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ImageResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ImageResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ImageResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ImageResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the image.
Public Property | Thumbnail | Gets or sets the thumbnail image.
Top

See Also

Reference

ImageResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : ImageResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


ImageResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ImageResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the image.
Public Property | Thumbnail | Gets or sets the thumbnail image.
Top

See Also

Reference

ImageResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ContentType Property

[image]
ActiveReports 19 .NET Edition
ContentType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : ContentType Property

Glossary Item Box

Gets or sets the content type of the image.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType {get; set;}

Property Value

A System.String representing the content type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


Thumbnail Property

[image]
ActiveReports 19 .NET Edition
Thumbnail Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : Thumbnail Property

Glossary Item Box

Gets or sets the thumbnail image.

Syntax

Visual Basic (Declaration)
Public Property Thumbnail As Thumbnail
C#
public Thumbnail Thumbnail {get; set;}

Property Value

A Thumbnail representing the thumbnail image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


InvalidReportContentException Class

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

Represents the exception that is thrown when a report contains invalid content.

Object Model

InvalidReportContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidReportContentException
   Inherits System.Exception
C#
public class InvalidReportContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.InvalidReportContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Members
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidReportContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidReportContentException Constructor | Initializes a new instance of the InvalidReportContentException class with a specified error message.
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : InvalidReportContentException Constructor

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the InvalidReportContentException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidReportContentException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

Represents the exception that is thrown when a theme contains invalid content.

Object Model

InvalidThemeContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidThemeContentException
   Inherits System.Exception
C#
public class InvalidThemeContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.InvalidThemeContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Members
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidThemeContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidThemeContentException Constructor | Initializes a new instance of the InvalidThemeContentException class with a specified error message.
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : InvalidThemeContentException Constructor

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the InvalidThemeContentException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidThemeContentException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportDesignerConfiguration Class

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

Represents configuration options for the report designer.

Object Model

ReportDesignerConfiguration Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportDesignerConfiguration
C#
public sealed class ReportDesignerConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerConfiguration Class Members

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

The following tables list the members exposed by ReportDesignerConfiguration.

Public Constructors

 | Name | Description
Public Constructor | ReportDesignerConfiguration Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Public Property | LocateDataSource | Gets or sets the function to locate the data source.
Public Property | OmitViewerConfiguration | Gets or sets a value that instructs the designer to omit the built-in viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

Public Methods

 | Name | Description
Public Method | UseConfig | Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.
Public Method | UseDataProviders | Adds custom data providers.
Public Method | UseFileStore | Uses the built-in file store for report files and resources.
Public Method | UseReportsProvider | Uses a custom report store provider.
Public Method | UseReportViewer | Configures middleware for the ActiveReports viewer API.
Public Method | UseResourcesProvider | Uses a custom resource store provider.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerConfiguration Constructor

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : ReportDesignerConfiguration Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDesignerConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerConfiguration Class Methods

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerConfiguration members.

Public Methods

 | Name | Description
Public Method | UseConfig | Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.
Public Method | UseDataProviders | Adds custom data providers.
Public Method | UseFileStore | Uses the built-in file store for report files and resources.
Public Method | UseReportsProvider | Uses a custom report store provider.
Public Method | UseReportViewer | Configures middleware for the ActiveReports viewer API.
Public Method | UseResourcesProvider | Uses a custom resource store provider.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


UseConfig Method

[image]
ActiveReports 19 .NET Edition
UseConfig Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseConfig Method

path
The path to the configuration file.

Glossary Item Box

Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.

Syntax

Visual Basic (Declaration)
Public Function UseConfig( _
   ByVal path As String _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseConfig(
   string path
)

Parameters

path
The path to the configuration file.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    config.UseConfig("/path/to/ActiveReports.config");
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseDataProviders Method

[image]
ActiveReports 19 .NET Edition
UseDataProviders Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseDataProviders Method

dataProviderInfos
An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo objects representing the data providers.

Glossary Item Box

Adds custom data providers.

Syntax

Visual Basic (Declaration)
Public Function UseDataProviders( _
   ByVal dataProviderInfos() As DataProviderInfo _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseDataProviders(
   DataProviderInfo[] dataProviderInfos
)

Parameters

dataProviderInfos
An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo objects representing the data providers.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    config.UseDataProviders(new DataProviderInfo[] { new DataProviderInfo("SQLProvider", "SQLProvider.Assembly") });
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseFileStore Method

[image]
ActiveReports 19 .NET Edition
UseFileStore Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseFileStore Method

baseDir
The base directory for the file store.
folderPerResource
A dictionary mapping resource types to directories.
options
The file store options.

Glossary Item Box

Uses the built-in file store for report files and resources.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal baseDir As DirectoryInfo, _
   Optional ByVal folderPerResource As IDictionary(Of ResourceType,DirectoryInfo), _
   Optional ByVal options As FileStoreOptions _
)
C#
public void UseFileStore(
   DirectoryInfo baseDir,
   IDictionary<ResourceType,DirectoryInfo> folderPerResource,
   FileStoreOptions options
)

Parameters

baseDir
The base directory for the file store.
folderPerResource
A dictionary mapping resource types to directories.
options
The file store options.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
   config.UseFileStore(new DirectoryInfo("/path/to/dir"));
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseReportsProvider Method

[image]
ActiveReports 19 .NET Edition
UseReportsProvider Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseReportsProvider Method

reportStore
The custom report store provider.

Glossary Item Box

Uses a custom report store provider.

Syntax

Visual Basic (Declaration)
Public Function UseReportsProvider( _
   ByVal reportStore As IReportStore _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseReportsProvider(
   IReportStore reportStore
)

Parameters

reportStore
The custom report store provider.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // Your implementation of IReportStore.
    config.UseReportsProvider(reportStore);
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseReportViewer Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseReportViewer Method

configAction
An Action to configure the report viewer.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Sub UseReportViewer( _
   ByVal configAction As Action(Of ReportViewerConfiguration) _
)
C#
public void UseReportViewer(
   Action<ReportViewerConfiguration> configAction
)

Parameters

configAction
An Action to configure the report viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseResourcesProvider Method

[image]
ActiveReports 19 .NET Edition
UseResourcesProvider Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseResourcesProvider Method

resourcesProvider
The custom resource store provider.

Glossary Item Box

Uses a custom resource store provider.

Syntax

Visual Basic (Declaration)
Public Function UseResourcesProvider( _
   ByVal resourcesProvider As IResourceRepositoryProvider _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseResourcesProvider(
   IResourceRepositoryProvider resourcesProvider
)

Parameters

resourcesProvider
The custom resource store provider.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // Your implementation of IResourceRepositoryProvider.
    config.UseResourcesProvider(resourceProvider);
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerConfiguration Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerConfiguration members.

Public Properties

 | Name | Description
Public Property | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Public Property | LocateDataSource | Gets or sets the function to locate the data source.
Public Property | OmitViewerConfiguration | Gets or sets a value that instructs the designer to omit the built-in viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


EnabledDataApi Property

[image]
ActiveReports 19 .NET Edition
EnabledDataApi Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : EnabledDataApi Property

Glossary Item Box

Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.

Syntax

Visual Basic (Declaration)
Public Property EnabledDataApi As Boolean
C#
public bool EnabledDataApi {get; set;}

Property Value

A System.Boolean indicating the enabled state of the data API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


LocateDataSource Property

[image]
ActiveReports 19 .NET Edition
LocateDataSource Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : LocateDataSource Property

Glossary Item Box

Gets or sets the function to locate the data source.

Syntax

Visual Basic (Declaration)
Public Property LocateDataSource As Func(Of Object)
C#
public Func<object> LocateDataSource {get; set;}

Property Value

A Func that returns the data source object.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // An example for JSON provider.
    config.LocateDataSource = () => "[{\"id\":1,\"name\":\"A\"},{\"id\":2,\"name\":\"B\"}]";
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


OmitViewerConfiguration Property

[image]
ActiveReports 19 .NET Edition
OmitViewerConfiguration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : OmitViewerConfiguration Property

Glossary Item Box

Gets or sets a value that instructs the designer to omit the built-in viewer configuration.

Syntax

Visual Basic (Declaration)
Public Property OmitViewerConfiguration As Boolean
C#
public bool OmitViewerConfiguration {get; set;}

Property Value

A System.Boolean indicating whether to omit the viewer configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


Prefix Property

[image]
ActiveReports 19 .NET Edition
Prefix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : Prefix Property

Glossary Item Box

Gets or sets the web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Property Value

A System.String representing the web API endpoint prefix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerSettings Class

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

Represents the settings for the report designer.

Object Model

ReportDesignerSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportDesignerSettings
C#
public class ReportDesignerSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportDesignerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerSettings Class Members

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

The following tables list the members exposed by ReportDesignerSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportDesignerSettings Constructor |
Top

Public Fields

 | Name | Description
Public Field | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Top

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the custom data providers.
Public Property | OmitViewerConfiguration | Gets or sets a value indicating whether to omit the embedded viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerSettings Constructor

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : ReportDesignerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDesignerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportDesignerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerSettings members.

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the custom data providers.
Public Property | OmitViewerConfiguration | Gets or sets a value indicating whether to omit the embedded viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataProviders Property

[image]
ActiveReports 19 .NET Edition
DataProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : DataProviders Property

Glossary Item Box

Gets or sets the custom data providers.

Syntax

Visual Basic (Declaration)
Public Property DataProviders As DataProviderInfo()
C#
public DataProviderInfo[] DataProviders {get; set;}

Property Value

An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo representing the custom data providers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


OmitViewerConfiguration Property

[image]
ActiveReports 19 .NET Edition
OmitViewerConfiguration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : OmitViewerConfiguration Property

Glossary Item Box

Gets or sets a value indicating whether to omit the embedded viewer configuration.

Syntax

Visual Basic (Declaration)
Public Property OmitViewerConfiguration As Boolean
C#
public bool OmitViewerConfiguration {get; set;}

Property Value

A System.Boolean indicating whether to omit the viewer configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


Prefix Property

[image]
ActiveReports 19 .NET Edition
Prefix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : Prefix Property

Glossary Item Box

Gets or sets the web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Property Value

A System.String representing the web API endpoint prefix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportDesignerSettings Class Fields

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerSettings members.

Public Fields

 | Name | Description
Public Field | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


EnabledDataApi Field

[image]
ActiveReports 19 .NET Edition
EnabledDataApi Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : EnabledDataApi Field

Glossary Item Box

Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.

Syntax

Visual Basic (Declaration)
Public EnabledDataApi As Boolean
C#
public bool EnabledDataApi

Field Value

A System.Boolean indicating the enabled state of the data API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

Represents extension methods for working with reports.

Object Model

ReportExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportExtensions
C#
public static class ReportExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToXmlStream | Overloaded. Saves the report to a stream in XML format.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToXmlStream | Overloaded. Saves the report to a stream in XML format.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ToXmlStream Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class : ToXmlStream Method

Glossary Item Box

Saves the report to a stream in XML format.

Overload List

Overload | Description
ToXmlStream(Report) | Saves the report to a stream in XML format.
ToXmlStream(SectionReport) | Saves the SectionReport to a stream in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


ToXmlStream(Report) Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream(Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class > ToXmlStream Method : ToXmlStream(Report) Method

report
The report to be saved.

Glossary Item Box

Saves the report to a stream in XML format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToXmlStream( _
   ByVal report As Report _
) As Stream
C#
public static Stream ToXmlStream(
   Report report
)

Parameters

report
The report to be saved.

Return Value

A stream containing the report in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members
Overload List


ToXmlStream(SectionReport) Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream(SectionReport) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class > ToXmlStream Method : ToXmlStream(SectionReport) Method

report
The SectionReport to be saved.

Glossary Item Box

Saves the SectionReport to a stream in XML format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToXmlStream( _
   ByVal report As SectionReport _
) As Stream
C#
public static Stream ToXmlStream(
   SectionReport report
)

Parameters

report
The SectionReport to be saved.

Return Value

A stream containing the SectionReport in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members
Overload List


ReportInfo Class

[image]
ActiveReports 19 .NET Edition
ReportInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

Represents information about a report.

Object Model

ReportInfo Class

Syntax

Visual Basic (Declaration)
Public Class ReportInfo
C#
public class ReportInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportInfo Class Members

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

The following tables list the members exposed by ReportInfo.

Public Constructors

 | Name | Description
Public Constructor | ReportInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | RdlSubtype | Gets or sets the RDL report subtype.
Public Property | ReportType | Gets or sets the report type with persistent format.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportInfo Constructor

[image]
ActiveReports 19 .NET Edition
ReportInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : ReportInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | RdlSubtype | Gets or sets the RDL report subtype.
Public Property | ReportType | Gets or sets the report type with persistent format.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Web.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : Id Property

Glossary Item Box

Gets or sets the report ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

A System.String representing the ID of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : Name Property

Glossary Item Box

Gets or sets the report name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String representing the name of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RdlSubtype Property

[image]
ActiveReports 19 .NET Edition
RdlSubtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : RdlSubtype Property

Glossary Item Box

Gets or sets the RDL report subtype.

Syntax

Visual Basic (Declaration)
Public Property RdlSubtype As Nullable(Of RdlSubtype)
C#
public Nullable<RdlSubtype> RdlSubtype {get; set;}

Property Value

A nullable RdlSubtype representing the subtype of the RDL report.

Remarks

Used for displaying a report type icon in the web designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportType Property

[image]
ActiveReports 19 .NET Edition
ReportType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : ReportType Property

Glossary Item Box

Gets or sets the report type with persistent format.

Syntax

Visual Basic (Declaration)
Public Property ReportType As ReportType
C#
public ReportType ReportType {get; set;}

Property Value

A ReportType representing the type of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when a report cannot be found.

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
C#
public class ReportNotFoundException : GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor | Overloaded.
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
ReportNotFoundException Constructor(String) |
ReportNotFoundException Constructor(String,Exception) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ReportNotFoundException Constructor(String)

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class > ReportNotFoundException Constructor : ReportNotFoundException Constructor(String)

report

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As String _
)
C#
public ReportNotFoundException(
   string report
)

Parameters

report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members
Overload List


ReportNotFoundException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class > ReportNotFoundException Constructor : ReportNotFoundException Constructor(String,Exception)

report
innerException

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As String, _
   ByVal innerException As Exception _
)
C#
public ReportNotFoundException(
   string report,
   Exception innerException
)

Parameters

report
innerException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members
Overload List


ReportResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a report resource.

Object Model

ReportResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ReportResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ReportResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ReportResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ReportResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReportType | Gets or sets the report type with persistent format.
Public Property | Thumbnail | Gets or sets the thumbnail, used for report templates in the web designer.
Top

See Also

Reference

ReportResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : ReportResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


ReportResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ReportResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | ReportType | Gets or sets the report type with persistent format.
Public Property | Thumbnail | Gets or sets the thumbnail, used for report templates in the web designer.
Top

See Also

Reference

ReportResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportType Property

[image]
ActiveReports 19 .NET Edition
ReportType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : ReportType Property

Glossary Item Box

Gets or sets the report type with persistent format.

Syntax

Visual Basic (Declaration)
Public Property ReportType As ReportType
C#
public ReportType ReportType {get; set;}

Property Value

A ReportType representing the report type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


Thumbnail Property

[image]
ActiveReports 19 .NET Edition
Thumbnail Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : Thumbnail Property

Glossary Item Box

Gets or sets the thumbnail, used for report templates in the web designer.

Syntax

Visual Basic (Declaration)
Public Property Thumbnail As Thumbnail
C#
public Thumbnail Thumbnail {get; set;}

Property Value

A Thumbnail representing the thumbnail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


ResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a resource.

Object Model

ResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ResourceDescriptor
C#
public class ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the description of the resource.
Public Property | Id | Gets or sets the unique identifier of the resource.
Public Property | Name | Gets or sets the name of the resource.
Top

See Also

Reference

ResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : ResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


ResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the description of the resource.
Public Property | Id | Gets or sets the unique identifier of the resource.
Public Property | Name | Gets or sets the name of the resource.
Top

See Also

Reference

ResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Description Property

Glossary Item Box

Gets or sets the description of the resource.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Property Value

A System.String representing the description.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Id Property

Glossary Item Box

Gets or sets the unique identifier of the resource.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

A System.String representing the unique identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Name Property

Glossary Item Box

Gets or sets the name of the resource.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String representing the name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


SharedDataSourceResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a shared data source resource.

Object Model

SharedDataSourceResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class SharedDataSourceResourceDescriptor
   Inherits ResourceDescriptor
C#
public class SharedDataSourceResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


SharedDataSourceResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by SharedDataSourceResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | SharedDataSourceResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of the shared data source.
Top

See Also

Reference

SharedDataSourceResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


SharedDataSourceResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > SharedDataSourceResourceDescriptor Class : SharedDataSourceResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SharedDataSourceResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Class
SharedDataSourceResourceDescriptor Members


SharedDataSourceResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see SharedDataSourceResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of the shared data source.
Top

See Also

Reference

SharedDataSourceResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > SharedDataSourceResourceDescriptor Class : Type Property

Glossary Item Box

Gets or sets the type of the shared data source.

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type {get; set;}

Property Value

A System.String representing the type of the shared data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Class
SharedDataSourceResourceDescriptor Members


ThemeNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when a theme cannot be found.

Object Model

ThemeNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ThemeNotFoundException
   Inherits System.Exception
C#
public class ThemeNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.ThemeNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ThemeNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ThemeNotFoundException Constructor |
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : ThemeNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ThemeResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a theme resource.

Object Model

ThemeResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ThemeResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ThemeResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ThemeResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ThemeResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the value of the Accent1 color.
Public Property | Accent2 | Gets or sets the value of the Accent2 color.
Public Property | Accent3 | Gets or sets the value of the Accent3 color.
Public Property | Accent4 | Gets or sets the value of the Accent4 color.
Public Property | Accent5 | Gets or sets the value of the Accent5 color.
Public Property | Accent6 | Gets or sets the value of the Accent6 color.
Public Property | Dark1 | Gets or sets the value of the Dark1 color.
Public Property | Dark2 | Gets or sets the value of the Dark2 color.
Public Property | Light1 | Gets or sets the value of the Light1 color.
Public Property | Light2 | Gets or sets the value of the Light2 color.
Public Property | MajorFontFamily | Gets or sets the family name of the major font.
Public Property | MinorFontFamily | Gets or sets the family name of the minor font.
Public Property | Title | Gets or sets the title of the theme.
Top

See Also

Reference

ThemeResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : ThemeResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


ThemeResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ThemeResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the value of the Accent1 color.
Public Property | Accent2 | Gets or sets the value of the Accent2 color.
Public Property | Accent3 | Gets or sets the value of the Accent3 color.
Public Property | Accent4 | Gets or sets the value of the Accent4 color.
Public Property | Accent5 | Gets or sets the value of the Accent5 color.
Public Property | Accent6 | Gets or sets the value of the Accent6 color.
Public Property | Dark1 | Gets or sets the value of the Dark1 color.
Public Property | Dark2 | Gets or sets the value of the Dark2 color.
Public Property | Light1 | Gets or sets the value of the Light1 color.
Public Property | Light2 | Gets or sets the value of the Light2 color.
Public Property | MajorFontFamily | Gets or sets the family name of the major font.
Public Property | MinorFontFamily | Gets or sets the family name of the minor font.
Public Property | Title | Gets or sets the title of the theme.
Top

See Also

Reference

ThemeResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Accent1 Property

[image]
ActiveReports 19 .NET Edition
Accent1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent1 Property

Glossary Item Box

Gets or sets the value of the Accent1 color.

Syntax

Visual Basic (Declaration)
Public Property Accent1 As String
C#
public string Accent1 {get; set;}

Property Value

A System.String representing the value of the Accent1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent2 Property

[image]
ActiveReports 19 .NET Edition
Accent2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent2 Property

Glossary Item Box

Gets or sets the value of the Accent2 color.

Syntax

Visual Basic (Declaration)
Public Property Accent2 As String
C#
public string Accent2 {get; set;}

Property Value

A System.String representing the value of the Accent2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent3 Property

[image]
ActiveReports 19 .NET Edition
Accent3 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent3 Property

Glossary Item Box

Gets or sets the value of the Accent3 color.

Syntax

Visual Basic (Declaration)
Public Property Accent3 As String
C#
public string Accent3 {get; set;}

Property Value

A System.String representing the value of the Accent3 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent4 Property

[image]
ActiveReports 19 .NET Edition
Accent4 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent4 Property

Glossary Item Box

Gets or sets the value of the Accent4 color.

Syntax

Visual Basic (Declaration)
Public Property Accent4 As String
C#
public string Accent4 {get; set;}

Property Value

A System.String representing the value of the Accent4 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent5 Property

[image]
ActiveReports 19 .NET Edition
Accent5 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent5 Property

Glossary Item Box

Gets or sets the value of the Accent5 color.

Syntax

Visual Basic (Declaration)
Public Property Accent5 As String
C#
public string Accent5 {get; set;}

Property Value

A System.String representing the value of the Accent5 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent6 Property

[image]
ActiveReports 19 .NET Edition
Accent6 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent6 Property

Glossary Item Box

Gets or sets the value of the Accent6 color.

Syntax

Visual Basic (Declaration)
Public Property Accent6 As String
C#
public string Accent6 {get; set;}

Property Value

A System.String representing the value of the Accent6 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Dark1 Property

[image]
ActiveReports 19 .NET Edition
Dark1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Dark1 Property

Glossary Item Box

Gets or sets the value of the Dark1 color.

Syntax

Visual Basic (Declaration)
Public Property Dark1 As String
C#
public string Dark1 {get; set;}

Property Value

A System.String representing the value of the Dark1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Dark2 Property

[image]
ActiveReports 19 .NET Edition
Dark2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Dark2 Property

Glossary Item Box

Gets or sets the value of the Dark2 color.

Syntax

Visual Basic (Declaration)
Public Property Dark2 As String
C#
public string Dark2 {get; set;}

Property Value

A System.String representing the value of the Dark2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Light1 Property

[image]
ActiveReports 19 .NET Edition
Light1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Light1 Property

Glossary Item Box

Gets or sets the value of the Light1 color.

Syntax

Visual Basic (Declaration)
Public Property Light1 As String
C#
public string Light1 {get; set;}

Property Value

A System.String representing the value of the Light1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Light2 Property

[image]
ActiveReports 19 .NET Edition
Light2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Light2 Property

Glossary Item Box

Gets or sets the value of the Light2 color.

Syntax

Visual Basic (Declaration)
Public Property Light2 As String
C#
public string Light2 {get; set;}

Property Value

A System.String representing the value of the Light2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


MajorFontFamily Property

[image]
ActiveReports 19 .NET Edition
MajorFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : MajorFontFamily Property

Glossary Item Box

Gets or sets the family name of the major font.

Syntax

Visual Basic (Declaration)
Public Property MajorFontFamily As String
C#
public string MajorFontFamily {get; set;}

Property Value

A System.String representing the family name of the major font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


MinorFontFamily Property

[image]
ActiveReports 19 .NET Edition
MinorFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : MinorFontFamily Property

Glossary Item Box

Gets or sets the family name of the minor font.

Syntax

Visual Basic (Declaration)
Public Property MinorFontFamily As String
C#
public string MinorFontFamily {get; set;}

Property Value

A System.String representing the family name of the minor font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Title Property

Glossary Item Box

Gets or sets the title of the theme.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Property Value

A System.String representing the title of the theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Thumbnail Class

[image]
ActiveReports 19 .NET Edition
Thumbnail Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

Represents a thumbnail image.

Object Model

Thumbnail Class

Syntax

Visual Basic (Declaration)
Public Class Thumbnail
C#
public class Thumbnail

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.Thumbnail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Members
GrapeCity.ActiveReports.Web.Designer Namespace


Thumbnail Class Members

[image]
ActiveReports 19 .NET Edition
Thumbnail Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

The following tables list the members exposed by Thumbnail.

Public Constructors

 | Name | Description
Public Constructor | Thumbnail Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the thumbnail.
Public Property | Data | Gets or sets the raw binary data of the thumbnail image.
Top

See Also

Reference

Thumbnail Class
GrapeCity.ActiveReports.Web.Designer Namespace


Thumbnail Constructor

[image]
ActiveReports 19 .NET Edition
Thumbnail Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : Thumbnail Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Thumbnail()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


Thumbnail Class Properties

[image]
ActiveReports 19 .NET Edition
Thumbnail Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

For a list of all members of this type, see Thumbnail members.

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the thumbnail.
Public Property | Data | Gets or sets the raw binary data of the thumbnail image.
Top

See Also

Reference

Thumbnail Class
GrapeCity.ActiveReports.Web.Designer Namespace


ContentType Property

[image]
ActiveReports 19 .NET Edition
ContentType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : ContentType Property

Glossary Item Box

Gets or sets the content type of the thumbnail.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType {get; set;}

Property Value

A System.String representing the content type of the thumbnail.

Remarks

Supported formats:
  • .bmp - image/bmp
  • .jpg - image/jpeg
  • .jpeg - image/jpeg
  • .png - image/png
  • .gif - image/gif
  • .tiff - image/tiff
  • .emf - image/x-emf
  • .wmf - image/x-wmf
  • .svg - image/svg+xml

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : Data Property

Glossary Item Box

Gets or sets the raw binary data of the thumbnail image.

Syntax

Visual Basic (Declaration)
Public Property Data As Byte()
C#
public byte[] Data {get; set;}

Property Value

An array of System.Byte representing the raw binary content of the thumbnail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


FileStoreOptions Enumeration

[image]
ActiveReports 19 .NET Edition
FileStoreOptions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : FileStoreOptions Enumeration

Glossary Item Box

Specifies the options for file storage.

Syntax

Visual Basic (Declaration)
Public Enum FileStoreOptions
   Inherits System.Enum
C#
public enum FileStoreOptions : System.Enum

Members

Member | Description
NestedFoldersLookup | Instructs to search for resources in nested folders.
None | No special options.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.FileStoreOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


RdlSubtype Enumeration

[image]
ActiveReports 19 .NET Edition
RdlSubtype Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : RdlSubtype Enumeration

Glossary Item Box

Specifies the RDL subtypes.

Syntax

Visual Basic (Declaration)
Public Enum RdlSubtype
   Inherits System.Enum
C#
public enum RdlSubtype : System.Enum

Members

Member | Description
ContinuousPage | Represents a continuous page report.
Dashboard | Represents a dashboard report.
FixedPage | Represents a fixed page report.
GenericRdl | Represents any RDL report.
MultiSection | Represents a multi-section report.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.RdlSubtype

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


SaveSettings Enumeration

[image]
ActiveReports 19 .NET Edition
SaveSettings Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SaveSettings Enumeration

Glossary Item Box

Represents the save settings for a report.

Syntax

Visual Basic (Declaration)
Public Enum SaveSettings
   Inherits System.Enum
C#
public enum SaveSettings : System.Enum

Members

Member | Description
IsTemporary | Indicates that the report is temporary.
None | No special save settings.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.SaveSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

Represents the full configuration for the report designer.

Syntax

Visual Basic (Declaration)
Public Interface IReportDesignerBackendApi
   Inherits IReportStore, IResourceRepositoryProvider
C#
public interface IReportDesignerBackendApi : IReportStore, IResourceRepositoryProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Members
GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface Members

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

The following tables list the members exposed by IReportDesignerBackendApi.

Public Properties

 | Name | Description
Property | ConfigurationProvider | Gets or sets the custom configuration provider.
Property | LocateDataSource | Gets or sets the function to locate the data source.
Property | Settings | Gets or sets the settings for the report designer.
Top

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

For a list of all members of this type, see IReportDesignerBackendApi members.

Public Properties

 | Name | Description
Property | ConfigurationProvider | Gets or sets the custom configuration provider.
Property | LocateDataSource | Gets or sets the function to locate the data source.
Property | Settings | Gets or sets the settings for the report designer.
Top

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


ConfigurationProvider Property

[image]
ActiveReports 19 .NET Edition
ConfigurationProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : ConfigurationProvider Property

Glossary Item Box

Gets or sets the custom configuration provider.

Syntax

Visual Basic (Declaration)
Property ConfigurationProvider As IConfigurationProvider
C#
IConfigurationProvider ConfigurationProvider {get; set;}

Property Value

An GrapeCity.ActiveReports.Configuration.IConfigurationProvider instance used for custom configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


LocateDataSource Property

[image]
ActiveReports 19 .NET Edition
LocateDataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : LocateDataSource Property

Glossary Item Box

Gets or sets the function to locate the data source.

Syntax

Visual Basic (Declaration)
Property LocateDataSource As Func(Of Object)
C#
Func<object> LocateDataSource {get; set;}

Property Value

A Func that returns the data source object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


Settings Property

[image]
ActiveReports 19 .NET Edition
Settings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : Settings Property

Glossary Item Box

Gets or sets the settings for the report designer.

Syntax

Visual Basic (Declaration)
Property Settings As ReportDesignerSettings
C#
ReportDesignerSettings Settings {get; set;}

Property Value

A ReportDesignerSettings instance that contains the settings for the report designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


IReportStore Interface

[image]
ActiveReports 19 .NET Edition
IReportStore Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

Represents methods for storing and managing reports.

Syntax

Visual Basic (Declaration)
Public Interface IReportStore
C#
public interface IReportStore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Members
GrapeCity.ActiveReports.Web.Designer Namespace


IReportStore Interface Members

[image]
ActiveReports 19 .NET Edition
IReportStore Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

The following tables list the members exposed by IReportStore.

Public Methods

 | Name | Description
Method | DeleteReport | Deletes the report by ID.
Method | GetReportDescriptor | Gets the report descriptor by ID.
Method | ListReports | Gets the list of report information.
Method | LoadReport | Loads the report content by ID.
Method | SaveReport | Saves the report.
Method | UpdateReport | Updates the report.
Top

See Also

Reference

IReportStore Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IReportStore Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportStore Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

For a list of all members of this type, see IReportStore members.

Public Methods

 | Name | Description
Method | DeleteReport | Deletes the report by ID.
Method | GetReportDescriptor | Gets the report descriptor by ID.
Method | ListReports | Gets the list of report information.
Method | LoadReport | Loads the report content by ID.
Method | SaveReport | Saves the report.
Method | UpdateReport | Updates the report.
Top

See Also

Reference

IReportStore Interface
GrapeCity.ActiveReports.Web.Designer Namespace


DeleteReport Method

[image]
ActiveReports 19 .NET Edition
DeleteReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : DeleteReport Method

reportId
The ID of the report to delete.

Glossary Item Box

Deletes the report by ID.

Syntax

Visual Basic (Declaration)
Sub DeleteReport( _
   ByVal reportId As String _
)
C#
void DeleteReport(
   string reportId
)

Parameters

reportId
The ID of the report to delete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


GetReportDescriptor Method

[image]
ActiveReports 19 .NET Edition
GetReportDescriptor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : GetReportDescriptor Method

reportId
The ID of the report to retrieve.

Glossary Item Box

Gets the report descriptor by ID.

Syntax

Visual Basic (Declaration)
Function GetReportDescriptor( _
   ByVal reportId As String _
) As ReportDescriptor
C#
ReportDescriptor GetReportDescriptor(
   string reportId
)

Parameters

reportId
The ID of the report to retrieve.

Return Value

The GrapeCity.ActiveReports.Web.Viewer.ReportDescriptor of the specified report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


ListReports Method

[image]
ActiveReports 19 .NET Edition
ListReports Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : ListReports Method

Glossary Item Box

Gets the list of report information.

Syntax

Visual Basic (Declaration)
Function ListReports() As ReportInfo()
C#
ReportInfo[] ListReports()

Return Value

An array of ReportInfo objects representing the reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


LoadReport Method

[image]
ActiveReports 19 .NET Edition
LoadReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : LoadReport Method

reportId
The ID of the report to load.

Glossary Item Box

Loads the report content by ID.

Syntax

Visual Basic (Declaration)
Function LoadReport( _
   ByVal reportId As String _
) As Stream
C#
Stream LoadReport(
   string reportId
)

Parameters

reportId
The ID of the report to load.

Return Value

A stream containing the report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


SaveReport Method

[image]
ActiveReports 19 .NET Edition
SaveReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : SaveReport Method

reportType
The type of the report.
reportId
The ID of the report to save.
reportData
The data of the report to save.
settings
The save settings to apply. Default is SaveSettings.None.

Glossary Item Box

Saves the report.

Syntax

Visual Basic (Declaration)
Function SaveReport( _
   ByVal reportType As ReportType, _
   ByVal reportId As String, _
   ByVal reportData As Stream, _
   Optional ByVal settings As SaveSettings _
) As String
C#
string SaveReport(
   ReportType reportType,
   string reportId,
   Stream reportData,
   SaveSettings settings
)

Parameters

reportType
The type of the report.
reportId
The ID of the report to save.
reportData
The data of the report to save.
settings
The save settings to apply. Default is SaveSettings.None.

Return Value

The ID of the saved report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


UpdateReport Method

[image]
ActiveReports 19 .NET Edition
UpdateReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : UpdateReport Method

reportType
The type of the report.
reportId
The ID of the report to update.
reportData
The data of the report to update.

Glossary Item Box

Updates the report.

Syntax

Visual Basic (Declaration)
Function UpdateReport( _
   ByVal reportType As ReportType, _
   ByVal reportId As String, _
   ByVal reportData As Stream _
) As String
C#
string UpdateReport(
   ReportType reportType,
   string reportId,
   Stream reportData
)

Parameters

reportType
The type of the report.
reportId
The ID of the report to update.
reportData
The data of the report to update.

Return Value

The ID of the updated report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


IResourceRepositoryProvider Interface

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

Represents methods for accessing and managing report resources.

Syntax

Visual Basic (Declaration)
Public Interface IResourceRepositoryProvider
C#
public interface IResourceRepositoryProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Members
GrapeCity.ActiveReports.Web.Designer Namespace


IResourceRepositoryProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

The following tables list the members exposed by IResourceRepositoryProvider.

Public Methods

 | Name | Description
Method | DescribeResources | Gets descriptors of the specified resources.
Method | GetResource | Gets the resource in a format compatible with the backend.
Method | ListResources | Gets the list of resources available for a particular report.
Top

See Also

Reference

IResourceRepositoryProvider Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IResourceRepositoryProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

For a list of all members of this type, see IResourceRepositoryProvider members.

Public Methods

 | Name | Description
Method | DescribeResources | Gets descriptors of the specified resources.
Method | GetResource | Gets the resource in a format compatible with the backend.
Method | ListResources | Gets the list of resources available for a particular report.
Top

See Also

Reference

IResourceRepositoryProvider Interface
GrapeCity.ActiveReports.Web.Designer Namespace


DescribeResources Method

[image]
ActiveReports 19 .NET Edition
DescribeResources Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : DescribeResources Method

resources
An array of GrapeCity.ActiveReports.ResourceInfo objects representing the resources to describe.

Glossary Item Box

Gets descriptors of the specified resources.

Syntax

Visual Basic (Declaration)
Function DescribeResources( _
   ByVal resources() As ResourceInfo _
) As ResourceDescriptor()
C#
ResourceDescriptor[] DescribeResources(
   ResourceInfo[] resources
)

Parameters

resources
An array of GrapeCity.ActiveReports.ResourceInfo objects representing the resources to describe.

Return Value

An array of ResourceDescriptor objects representing the descriptors of the requested resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


GetResource Method

[image]
ActiveReports 19 .NET Edition
GetResource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : GetResource Method

resource
The information about the resource to retrieve.

Glossary Item Box

Gets the resource in a format compatible with the backend.

Syntax

Visual Basic (Declaration)
Function GetResource( _
   ByVal resource As ResourceInfo _
) As Stream
C#
Stream GetResource(
   ResourceInfo resource
)

Parameters

resource
The information about the resource to retrieve.

Return Value

A stream containing the resource data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


ListResources Method

[image]
ActiveReports 19 .NET Edition
ListResources Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : ListResources Method

resourceType
The type of resources to list.

Glossary Item Box

Gets the list of resources available for a particular report.

Syntax

Visual Basic (Declaration)
Function ListResources( _
   ByVal resourceType As ResourceType _
) As ResourceDescriptor()
C#
ResourceDescriptor[] ListResources(
   ResourceType resourceType
)

Parameters

resourceType
The type of resources to list.

Return Value

An array of ResourceDescriptor objects representing the available resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


WebViewer Class

[image]
ActiveReports 19 .NET Edition
WebViewer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet Namespace : WebViewer Class

Glossary Item Box

Represents the dummy class for obtaining a license.

Object Model

WebViewer Class

Syntax

Visual Basic (Declaration)
Public Class WebViewer
C#
public class WebViewer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.WebViewer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Members
GrapeCity.ActiveReports.Aspnet Namespace


WebViewer Class Members

[image]
ActiveReports 19 .NET Edition
WebViewer Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet Namespace : WebViewer Class

Glossary Item Box

The following tables list the members exposed by WebViewer.

Public Constructors

 | Name | Description
Public Constructor | WebViewer Constructor |
Top

See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Aspnet Namespace


WebViewer Constructor

[image]
ActiveReports 19 .NET Edition
WebViewer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet Namespace > WebViewer Class : WebViewer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WebViewer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ConfigureExtensions Class

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

Represents a set of methods for configuring the web host application.

Object Model

ConfigureExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ConfigureExtensions
C#
public static class ConfigureExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Viewer.ConfigureExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Members
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


ConfigureExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

The following tables list the members exposed by ConfigureExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReportViewer | Overloaded. Configures middleware for the ActiveReports viewer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


ConfigureExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

For a list of all members of this type, see ConfigureExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReportViewer | Overloaded. Configures middleware for the ActiveReports viewer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


UseReportViewer Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace > ConfigureExtensions Class : UseReportViewer Method

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Overload List

Overload | Description
UseReportViewer(IAppBuilder,Action<ReportViewerConfiguration>) | Configures middleware for the ActiveReports viewer API.
UseReportViewer(IAppBuilder,IReportViewerBackendApi) | Configures middleware for the ActiveReports viewer API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportViewer(IAppBuilder,Action<ReportViewerConfiguration>) Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer(IAppBuilder,Action<ReportViewerConfiguration>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace > ConfigureExtensions Class > UseReportViewer Method : UseReportViewer(IAppBuilder,Action<ReportViewerConfiguration>) Method

app
A Owin.IAppBuilder object to configure.
configAction
An Action to configure the report viewer.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportViewer( _
   ByVal app As Owin.IAppBuilder, _
   ByVal configAction As Action(Of ReportViewerConfiguration) _
)
C#
public static void UseReportViewer(
   Owin.IAppBuilder app,
   Action<ReportViewerConfiguration> configAction
)

Parameters

app
A Owin.IAppBuilder object to configure.
configAction
An Action to configure the report viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


UseReportViewer(IAppBuilder,IReportViewerBackendApi) Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer(IAppBuilder,IReportViewerBackendApi) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace > ConfigureExtensions Class > UseReportViewer Method : UseReportViewer(IAppBuilder,IReportViewerBackendApi) Method

app
A Owin.IAppBuilder object to configure.
customApi
A GrapeCity.ActiveReports.Web.Viewer.IReportViewerBackendApi object to use for configuring the middleware.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportViewer( _
   ByVal app As Owin.IAppBuilder, _
   ByVal customApi As IReportViewerBackendApi _
)
C#
public static void UseReportViewer(
   Owin.IAppBuilder app,
   IReportViewerBackendApi customApi
)

Parameters

app
A Owin.IAppBuilder object to configure.
customApi
A GrapeCity.ActiveReports.Web.Viewer.IReportViewerBackendApi object to use for configuring the middleware.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


ConfigureExtensions Class

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

Represents methods for configuring the web host application.

Object Model

ConfigureExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ConfigureExtensions
C#
public static class ConfigureExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.ConfigureExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ConfigureExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

The following tables list the members exposed by ConfigureExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReportDesigner | Adds services required for the report designer.
static (Shared in Visual Basic) | UseReportDesigner | Overloaded. Configures middleware for the ActiveReports designer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ConfigureExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ConfigureExtensions Class

Glossary Item Box

For a list of all members of this type, see ConfigureExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReportDesigner | Adds services required for the report designer.
static (Shared in Visual Basic) | UseReportDesigner | Overloaded. Configures middleware for the ActiveReports designer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


AddReportDesigner Method

[image]
ActiveReports 19 .NET Edition
AddReportDesigner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ConfigureExtensions Class : AddReportDesigner Method

services
The Microsoft.Extensions.DependencyInjection.IServiceCollection to add the services to.

Glossary Item Box

Adds services required for the report designer.

Syntax

Visual Basic (Declaration)
Public Shared Function AddReportDesigner( _
   ByVal services As IServiceCollection _
) As IServiceCollection
C#
public static IServiceCollection AddReportDesigner(
   IServiceCollection services
)

Parameters

services
The Microsoft.Extensions.DependencyInjection.IServiceCollection to add the services to.

Return Value

The Microsoft.Extensions.DependencyInjection.IServiceCollection so that additional calls can be chained.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportDesigner Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ConfigureExtensions Class : UseReportDesigner Method

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Overload List

Overload | Description
UseReportDesigner(IApplicationBuilder,Action<ReportDesignerConfiguration>) | Configures middleware for the ActiveReports designer API.
UseReportDesigner(IApplicationBuilder,IReportDesignerBackendApi) | Configures middleware for the ActiveReports designer API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportDesigner(IApplicationBuilder,Action<ReportDesignerConfiguration>) Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner(IApplicationBuilder,Action<ReportDesignerConfiguration>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ConfigureExtensions Class > UseReportDesigner Method : UseReportDesigner(IApplicationBuilder,Action<ReportDesignerConfiguration>) Method

app
The Microsoft.AspNetCore.Builder.IApplicationBuilder to configure.
configAction
An Action to configure the report designer.

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportDesigner( _
   ByVal app As IApplicationBuilder, _
   ByVal configAction As Action(Of ReportDesignerConfiguration) _
)
C#
public static void UseReportDesigner(
   IApplicationBuilder app,
   Action<ReportDesignerConfiguration> configAction
)

Parameters

app
The Microsoft.AspNetCore.Builder.IApplicationBuilder to configure.
configAction
An Action to configure the report designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


UseReportDesigner(IApplicationBuilder,IReportDesignerBackendApi) Method

[image]
ActiveReports 19 .NET Edition
UseReportDesigner(IApplicationBuilder,IReportDesignerBackendApi) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ConfigureExtensions Class > UseReportDesigner Method : UseReportDesigner(IApplicationBuilder,IReportDesignerBackendApi) Method

app
The Microsoft.AspNetCore.Builder.IApplicationBuilder to configure.
api
The GrapeCity.ActiveReports.Web.Designer.IReportDesignerBackendApi to use for configuring the middleware.

Glossary Item Box

Configures middleware for the ActiveReports designer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportDesigner( _
   ByVal app As IApplicationBuilder, _
   ByVal api As IReportDesignerBackendApi _
)
C#
public static void UseReportDesigner(
   IApplicationBuilder app,
   IReportDesignerBackendApi api
)

Parameters

app
The Microsoft.AspNetCore.Builder.IApplicationBuilder to configure.
api
The GrapeCity.ActiveReports.Web.Designer.IReportDesignerBackendApi to use for configuring the middleware.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


ReportConverter Class

[image]
ActiveReports 19 .NET Edition
ReportConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

Represents methods for converting report content.

Object Model

ReportConverter Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportConverter
C#
public static class ReportConverter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities.ReportConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace


ReportConverter Class Members

[image]
ActiveReports 19 .NET Edition
ReportConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

The following tables list the members exposed by ReportConverter.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromJson | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.
static (Shared in Visual Basic) | FromXML | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.
static (Shared in Visual Basic) | ToJson | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.
static (Shared in Visual Basic) | ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.
Top

See Also

Reference

ReportConverter Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace


ReportConverter Class Methods

[image]
ActiveReports 19 .NET Edition
ReportConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace : ReportConverter Class

Glossary Item Box

For a list of all members of this type, see ReportConverter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromJson | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.
static (Shared in Visual Basic) | FromXML | Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.
static (Shared in Visual Basic) | ToJson | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.
static (Shared in Visual Basic) | ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.
Top

See Also

Reference

ReportConverter Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace


FromJson Method

[image]
ActiveReports 19 .NET Edition
FromJson Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace > ReportConverter Class : FromJson Method

content
A byte array containing the JSON report content.

Glossary Item Box

Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from JSON content.

Syntax

Visual Basic (Declaration)
Public Shared Function FromJson( _
   ByVal content() As Byte _
) As Report
C#
public static Report FromJson(
   byte[] content
)

Parameters

content
A byte array containing the JSON report content.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


FromXML Method

[image]
ActiveReports 19 .NET Edition
FromXML Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace > ReportConverter Class : FromXML Method

content
A byte array containing the XML report content.
resourceLocator
An optional resource locator for resolving resources referenced in the report.

Glossary Item Box

Deserializes a GrapeCity.ActiveReports.PageReportModel.Report from XML content.

Syntax

Visual Basic (Declaration)
Public Shared Function FromXML( _
   ByVal content() As Byte, _
   Optional ByVal resourceLocator As ResourceLocator _
) As Report
C#
public static Report FromXML(
   byte[] content,
   ResourceLocator resourceLocator
)

Parameters

content
A byte array containing the XML report content.
resourceLocator
An optional resource locator for resolving resources referenced in the report.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


ToJson Method

[image]
ActiveReports 19 .NET Edition
ToJson Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace > ReportConverter Class : ToJson Method

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to JSON content.

Syntax

Visual Basic (Declaration)
Public Shared Function ToJson( _
   ByVal report As Report _
) As Byte()
C#
public static byte[] ToJson(
   Report report
)

Parameters

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Return Value

A byte array containing the JSON report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


ToXml(Report) Method

[image]
ActiveReports 19 .NET Edition
ToXml(Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace > ReportConverter Class : ToXml(Report) Method

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Syntax

Visual Basic (Declaration)
Public Shared Function ToXml( _
   ByVal report As Report _
) As Byte()
C#
public static byte[] ToXml(
   Report report
)

Parameters

report
The GrapeCity.ActiveReports.PageReportModel.Report to serialize.

Return Value

A byte array containing the XML report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


DataSetTemplate Class

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

Represents a dataset template.

Object Model

DataSetTemplate Class

Syntax

Visual Basic (Declaration)
Public Class DataSetTemplate
C#
public class DataSetTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Members
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplate Class Members

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

The following tables list the members exposed by DataSetTemplate.

Public Constructors

 | Name | Description
Public Constructor | DataSetTemplate Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSet | Gets or sets the information about the dataset.
Public Property | DataSource | Gets or sets the information about the data source.
Top

See Also

Reference

DataSetTemplate Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplate Constructor

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSetTemplate Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSetTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSetTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
DataSetTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplate Class

Glossary Item Box

For a list of all members of this type, see DataSetTemplate members.

Public Properties

 | Name | Description
Public Property | DataSet | Gets or sets the information about the dataset.
Public Property | DataSource | Gets or sets the information about the data source.
Top

See Also

Reference

DataSetTemplate Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSet Property

[image]
ActiveReports 19 .NET Edition
DataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSet Property

Glossary Item Box

Gets or sets the information about the dataset.

Syntax

Visual Basic (Declaration)
Public Property DataSet As DataSet
C#
public DataSet DataSet {get; set;}

Property Value

An instance of DataSet containing the dataset information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplate Class : DataSource Property

Glossary Item Box

Gets or sets the information about the data source.

Syntax

Visual Basic (Declaration)
Public Property DataSource As DataSource
C#
public DataSource DataSource {get; set;}

Property Value

An instance of DataSource containing the data source information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplate Class
DataSetTemplate Members


DataSetTemplateExtensions Class

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

Represents an extension methods for DataSetTemplate.

Object Model

DataSetTemplateExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataSetTemplateExtensions
C#
public static class DataSetTemplateExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplateExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplateExtensions Members
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplateExtensions Class Members

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

The following tables list the members exposed by DataSetTemplateExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToJsonStream | Converts the DataSetTemplate to a JSON stream.
Top

See Also

Reference

DataSetTemplateExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataSetTemplateExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
DataSetTemplateExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : DataSetTemplateExtensions Class

Glossary Item Box

For a list of all members of this type, see DataSetTemplateExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToJsonStream | Converts the DataSetTemplate to a JSON stream.
Top

See Also

Reference

DataSetTemplateExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ToJsonStream Method

[image]
ActiveReports 19 .NET Edition
ToJsonStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > DataSetTemplateExtensions Class : ToJsonStream Method

dataSetTemplate
The DataSetTemplate to convert.

Glossary Item Box

Converts the DataSetTemplate to a JSON stream.

Syntax

Visual Basic (Declaration)
Public Shared Function ToJsonStream( _
   ByVal dataSetTemplate As DataSetTemplate _
) As Stream
C#
public static Stream ToJsonStream(
   DataSetTemplate dataSetTemplate
)

Parameters

dataSetTemplate
The DataSetTemplate to convert.

Return Value

A stream containing the JSON representation of the DataSetTemplate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetTemplateExtensions Class
DataSetTemplateExtensions Members


ImageNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when an image cannot be found.

Object Model

ImageNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ImageNotFoundException
   Inherits System.Exception
C#
public class ImageNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.ImageNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ImageNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ImageNotFoundException Constructor |
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : ImageNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ImageResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

Represents a descriptor for an image resource.

Object Model

ImageResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ImageResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ImageResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ImageResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ImageResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ImageResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the image.
Public Property | Thumbnail | Gets or sets the thumbnail image.
Top

See Also

Reference

ImageResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : ImageResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


ImageResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ImageResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ImageResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the image.
Public Property | Thumbnail | Gets or sets the thumbnail image.
Top

See Also

Reference

ImageResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ContentType Property

[image]
ActiveReports 19 .NET Edition
ContentType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : ContentType Property

Glossary Item Box

Gets or sets the content type of the image.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType {get; set;}

Property Value

A System.String representing the content type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


Thumbnail Property

[image]
ActiveReports 19 .NET Edition
Thumbnail Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageResourceDescriptor Class : Thumbnail Property

Glossary Item Box

Gets or sets the thumbnail image.

Syntax

Visual Basic (Declaration)
Public Property Thumbnail As Thumbnail
C#
public Thumbnail Thumbnail {get; set;}

Property Value

A Thumbnail representing the thumbnail image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageResourceDescriptor Class
ImageResourceDescriptor Members


InvalidReportContentException Class

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

Represents the exception that is thrown when a report contains invalid content.

Object Model

InvalidReportContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidReportContentException
   Inherits System.Exception
C#
public class InvalidReportContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.InvalidReportContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Members
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidReportContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidReportContentException Constructor | Initializes a new instance of the InvalidReportContentException class with a specified error message.
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : InvalidReportContentException Constructor

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the InvalidReportContentException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidReportContentException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

Represents the exception that is thrown when a theme contains invalid content.

Object Model

InvalidThemeContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidThemeContentException
   Inherits System.Exception
C#
public class InvalidThemeContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.InvalidThemeContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Members
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidThemeContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidThemeContentException Constructor | Initializes a new instance of the InvalidThemeContentException class with a specified error message.
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : InvalidThemeContentException Constructor

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the InvalidThemeContentException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidThemeContentException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportDesignerConfiguration Class

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

Represents configuration options for the report designer.

Object Model

ReportDesignerConfiguration Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportDesignerConfiguration
C#
public sealed class ReportDesignerConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerConfiguration Class Members

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

The following tables list the members exposed by ReportDesignerConfiguration.

Public Constructors

 | Name | Description
Public Constructor | ReportDesignerConfiguration Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Public Property | LocateDataSource | Gets or sets the function to locate the data source.
Public Property | OmitViewerConfiguration | Gets or sets a value that instructs the designer to omit the built-in viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

Public Methods

 | Name | Description
Public Method | UseConfig | Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.
Public Method | UseDataProviders | Adds custom data providers.
Public Method | UseFileStore | Uses the built-in file store for report files and resources.
Public Method | UseReportsProvider | Uses a custom report store provider.
Public Method | UseReportViewer | Configures middleware for the ActiveReports viewer API.
Public Method | UseResourcesProvider | Uses a custom resource store provider.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerConfiguration Constructor

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : ReportDesignerConfiguration Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDesignerConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerConfiguration Class Methods

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerConfiguration members.

Public Methods

 | Name | Description
Public Method | UseConfig | Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.
Public Method | UseDataProviders | Adds custom data providers.
Public Method | UseFileStore | Uses the built-in file store for report files and resources.
Public Method | UseReportsProvider | Uses a custom report store provider.
Public Method | UseReportViewer | Configures middleware for the ActiveReports viewer API.
Public Method | UseResourcesProvider | Uses a custom resource store provider.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


UseConfig Method

[image]
ActiveReports 19 .NET Edition
UseConfig Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseConfig Method

path
The path to the configuration file.

Glossary Item Box

Specifies the path to the ActiveReports.config or GrapeCity.ActiveReports.config file.

Syntax

Visual Basic (Declaration)
Public Function UseConfig( _
   ByVal path As String _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseConfig(
   string path
)

Parameters

path
The path to the configuration file.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    config.UseConfig("/path/to/ActiveReports.config");
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseDataProviders Method

[image]
ActiveReports 19 .NET Edition
UseDataProviders Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseDataProviders Method

dataProviderInfos
An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo objects representing the data providers.

Glossary Item Box

Adds custom data providers.

Syntax

Visual Basic (Declaration)
Public Function UseDataProviders( _
   ByVal dataProviderInfos() As DataProviderInfo _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseDataProviders(
   DataProviderInfo[] dataProviderInfos
)

Parameters

dataProviderInfos
An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo objects representing the data providers.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    config.UseDataProviders(new DataProviderInfo[] { new DataProviderInfo("SQLProvider", "SQLProvider.Assembly") });
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseFileStore Method

[image]
ActiveReports 19 .NET Edition
UseFileStore Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseFileStore Method

baseDir
The base directory for the file store.
folderPerResource
A dictionary mapping resource types to directories.
options
The file store options.

Glossary Item Box

Uses the built-in file store for report files and resources.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal baseDir As DirectoryInfo, _
   Optional ByVal folderPerResource As IDictionary(Of ResourceType,DirectoryInfo), _
   Optional ByVal options As FileStoreOptions _
)
C#
public void UseFileStore(
   DirectoryInfo baseDir,
   IDictionary<ResourceType,DirectoryInfo> folderPerResource,
   FileStoreOptions options
)

Parameters

baseDir
The base directory for the file store.
folderPerResource
A dictionary mapping resource types to directories.
options
The file store options.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
   config.UseFileStore(new DirectoryInfo("/path/to/dir"));
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseReportsProvider Method

[image]
ActiveReports 19 .NET Edition
UseReportsProvider Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseReportsProvider Method

reportStore
The custom report store provider.

Glossary Item Box

Uses a custom report store provider.

Syntax

Visual Basic (Declaration)
Public Function UseReportsProvider( _
   ByVal reportStore As IReportStore _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseReportsProvider(
   IReportStore reportStore
)

Parameters

reportStore
The custom report store provider.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // Your implementation of IReportStore.
    config.UseReportsProvider(reportStore);
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseReportViewer Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseReportViewer Method

configAction
An Action to configure the report viewer.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Sub UseReportViewer( _
   ByVal configAction As Action(Of ReportViewerConfiguration) _
)
C#
public void UseReportViewer(
   Action<ReportViewerConfiguration> configAction
)

Parameters

configAction
An Action to configure the report viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


UseResourcesProvider Method

[image]
ActiveReports 19 .NET Edition
UseResourcesProvider Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : UseResourcesProvider Method

resourcesProvider
The custom resource store provider.

Glossary Item Box

Uses a custom resource store provider.

Syntax

Visual Basic (Declaration)
Public Function UseResourcesProvider( _
   ByVal resourcesProvider As IResourceRepositoryProvider _
) As ReportDesignerConfiguration
C#
public ReportDesignerConfiguration UseResourcesProvider(
   IResourceRepositoryProvider resourcesProvider
)

Parameters

resourcesProvider
The custom resource store provider.

Return Value

The current ReportDesignerConfiguration instance.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // Your implementation of IResourceRepositoryProvider.
    config.UseResourcesProvider(resourceProvider);
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerConfiguration Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDesignerConfiguration Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerConfiguration Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerConfiguration members.

Public Properties

 | Name | Description
Public Property | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Public Property | LocateDataSource | Gets or sets the function to locate the data source.
Public Property | OmitViewerConfiguration | Gets or sets a value that instructs the designer to omit the built-in viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerConfiguration Class
GrapeCity.ActiveReports.Web.Designer Namespace


EnabledDataApi Property

[image]
ActiveReports 19 .NET Edition
EnabledDataApi Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : EnabledDataApi Property

Glossary Item Box

Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.

Syntax

Visual Basic (Declaration)
Public Property EnabledDataApi As Boolean
C#
public bool EnabledDataApi {get; set;}

Property Value

A System.Boolean indicating the enabled state of the data API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


LocateDataSource Property

[image]
ActiveReports 19 .NET Edition
LocateDataSource Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : LocateDataSource Property

Glossary Item Box

Gets or sets the function to locate the data source.

Syntax

Visual Basic (Declaration)
Public Property LocateDataSource As Func(Of Object)
C#
public Func<object> LocateDataSource {get; set;}

Property Value

A Func that returns the data source object.

Example

C# Copy Code
app.UseReportDesigner(config =>
{
    // An example for JSON provider.
    config.LocateDataSource = () => "[{\"id\":1,\"name\":\"A\"},{\"id\":2,\"name\":\"B\"}]";
});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


OmitViewerConfiguration Property

[image]
ActiveReports 19 .NET Edition
OmitViewerConfiguration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : OmitViewerConfiguration Property

Glossary Item Box

Gets or sets a value that instructs the designer to omit the built-in viewer configuration.

Syntax

Visual Basic (Declaration)
Public Property OmitViewerConfiguration As Boolean
C#
public bool OmitViewerConfiguration {get; set;}

Property Value

A System.Boolean indicating whether to omit the viewer configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


Prefix Property

[image]
ActiveReports 19 .NET Edition
Prefix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerConfiguration Class : Prefix Property

Glossary Item Box

Gets or sets the web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Property Value

A System.String representing the web API endpoint prefix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerConfiguration Class
ReportDesignerConfiguration Members


ReportDesignerSettings Class

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

Represents the settings for the report designer.

Object Model

ReportDesignerSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportDesignerSettings
C#
public class ReportDesignerSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportDesignerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerSettings Class Members

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

The following tables list the members exposed by ReportDesignerSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportDesignerSettings Constructor |
Top

Public Fields

 | Name | Description
Public Field | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Top

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the custom data providers.
Public Property | OmitViewerConfiguration | Gets or sets a value indicating whether to omit the embedded viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportDesignerSettings Constructor

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : ReportDesignerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDesignerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportDesignerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerSettings members.

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the custom data providers.
Public Property | OmitViewerConfiguration | Gets or sets a value indicating whether to omit the embedded viewer configuration.
Public Property | Prefix | Gets or sets the web API endpoint prefix.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


DataProviders Property

[image]
ActiveReports 19 .NET Edition
DataProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : DataProviders Property

Glossary Item Box

Gets or sets the custom data providers.

Syntax

Visual Basic (Declaration)
Public Property DataProviders As DataProviderInfo()
C#
public DataProviderInfo[] DataProviders {get; set;}

Property Value

An array of GrapeCity.ActiveReports.Configuration.DataProviderInfo representing the custom data providers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


OmitViewerConfiguration Property

[image]
ActiveReports 19 .NET Edition
OmitViewerConfiguration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : OmitViewerConfiguration Property

Glossary Item Box

Gets or sets a value indicating whether to omit the embedded viewer configuration.

Syntax

Visual Basic (Declaration)
Public Property OmitViewerConfiguration As Boolean
C#
public bool OmitViewerConfiguration {get; set;}

Property Value

A System.Boolean indicating whether to omit the viewer configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


Prefix Property

[image]
ActiveReports 19 .NET Edition
Prefix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : Prefix Property

Glossary Item Box

Gets or sets the web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Property Value

A System.String representing the web API endpoint prefix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportDesignerSettings Class Fields

[image]
ActiveReports 19 .NET Edition
ReportDesignerSettings Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportDesignerSettings Class

Glossary Item Box

For a list of all members of this type, see ReportDesignerSettings members.

Public Fields

 | Name | Description
Public Field | EnabledDataApi | Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.
Top

See Also

Reference

ReportDesignerSettings Class
GrapeCity.ActiveReports.Web.Designer Namespace


EnabledDataApi Field

[image]
ActiveReports 19 .NET Edition
EnabledDataApi Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportDesignerSettings Class : EnabledDataApi Field

Glossary Item Box

Gets or sets a value indicating whether the server API for the data source and data set editors is enabled.

Syntax

Visual Basic (Declaration)
Public EnabledDataApi As Boolean
C#
public bool EnabledDataApi

Field Value

A System.Boolean indicating the enabled state of the data API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesignerSettings Class
ReportDesignerSettings Members


ReportExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

Represents extension methods for working with reports.

Object Model

ReportExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportExtensions
C#
public static class ReportExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToXmlStream | Overloaded. Saves the report to a stream in XML format.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToXmlStream | Overloaded. Saves the report to a stream in XML format.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Web.Designer Namespace


ToXmlStream Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class : ToXmlStream Method

Glossary Item Box

Saves the report to a stream in XML format.

Overload List

Overload | Description
ToXmlStream(Report) | Saves the report to a stream in XML format.
ToXmlStream(SectionReport) | Saves the SectionReport to a stream in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


ToXmlStream(Report) Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream(Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class > ToXmlStream Method : ToXmlStream(Report) Method

report
The report to be saved.

Glossary Item Box

Saves the report to a stream in XML format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToXmlStream( _
   ByVal report As Report _
) As Stream
C#
public static Stream ToXmlStream(
   Report report
)

Parameters

report
The report to be saved.

Return Value

A stream containing the report in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members
Overload List


ToXmlStream(SectionReport) Method

[image]
ActiveReports 19 .NET Edition
ToXmlStream(SectionReport) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportExtensions Class > ToXmlStream Method : ToXmlStream(SectionReport) Method

report
The SectionReport to be saved.

Glossary Item Box

Saves the SectionReport to a stream in XML format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToXmlStream( _
   ByVal report As SectionReport _
) As Stream
C#
public static Stream ToXmlStream(
   SectionReport report
)

Parameters

report
The SectionReport to be saved.

Return Value

A stream containing the SectionReport in XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members
Overload List


ReportInfo Class

[image]
ActiveReports 19 .NET Edition
ReportInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

Represents information about a report.

Object Model

ReportInfo Class

Syntax

Visual Basic (Declaration)
Public Class ReportInfo
C#
public class ReportInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportInfo Class Members

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

The following tables list the members exposed by ReportInfo.

Public Constructors

 | Name | Description
Public Constructor | ReportInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | RdlSubtype | Gets or sets the RDL report subtype.
Public Property | ReportType | Gets or sets the report type with persistent format.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportInfo Constructor

[image]
ActiveReports 19 .NET Edition
ReportInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : ReportInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | RdlSubtype | Gets or sets the RDL report subtype.
Public Property | ReportType | Gets or sets the report type with persistent format.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Web.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : Id Property

Glossary Item Box

Gets or sets the report ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

A System.String representing the ID of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : Name Property

Glossary Item Box

Gets or sets the report name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String representing the name of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RdlSubtype Property

[image]
ActiveReports 19 .NET Edition
RdlSubtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : RdlSubtype Property

Glossary Item Box

Gets or sets the RDL report subtype.

Syntax

Visual Basic (Declaration)
Public Property RdlSubtype As Nullable(Of RdlSubtype)
C#
public Nullable<RdlSubtype> RdlSubtype {get; set;}

Property Value

A nullable RdlSubtype representing the subtype of the RDL report.

Remarks

Used for displaying a report type icon in the web designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportType Property

[image]
ActiveReports 19 .NET Edition
ReportType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportInfo Class : ReportType Property

Glossary Item Box

Gets or sets the report type with persistent format.

Syntax

Visual Basic (Declaration)
Public Property ReportType As ReportType
C#
public ReportType ReportType {get; set;}

Property Value

A ReportType representing the type of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when a report cannot be found.

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
C#
public class ReportNotFoundException : GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor | Overloaded.
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
ReportNotFoundException Constructor(String) |
ReportNotFoundException Constructor(String,Exception) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ReportNotFoundException Constructor(String)

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class > ReportNotFoundException Constructor : ReportNotFoundException Constructor(String)

report

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As String _
)
C#
public ReportNotFoundException(
   string report
)

Parameters

report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members
Overload List


ReportNotFoundException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class > ReportNotFoundException Constructor : ReportNotFoundException Constructor(String,Exception)

report
innerException

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As String, _
   ByVal innerException As Exception _
)
C#
public ReportNotFoundException(
   string report,
   Exception innerException
)

Parameters

report
innerException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members
Overload List


ReportResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a report resource.

Object Model

ReportResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ReportResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ReportResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ReportResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ReportResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ReportResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReportType | Gets or sets the report type with persistent format.
Public Property | Thumbnail | Gets or sets the thumbnail, used for report templates in the web designer.
Top

See Also

Reference

ReportResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : ReportResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


ReportResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ReportResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ReportResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | ReportType | Gets or sets the report type with persistent format.
Public Property | Thumbnail | Gets or sets the thumbnail, used for report templates in the web designer.
Top

See Also

Reference

ReportResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportType Property

[image]
ActiveReports 19 .NET Edition
ReportType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : ReportType Property

Glossary Item Box

Gets or sets the report type with persistent format.

Syntax

Visual Basic (Declaration)
Public Property ReportType As ReportType
C#
public ReportType ReportType {get; set;}

Property Value

A ReportType representing the report type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


Thumbnail Property

[image]
ActiveReports 19 .NET Edition
Thumbnail Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportResourceDescriptor Class : Thumbnail Property

Glossary Item Box

Gets or sets the thumbnail, used for report templates in the web designer.

Syntax

Visual Basic (Declaration)
Public Property Thumbnail As Thumbnail
C#
public Thumbnail Thumbnail {get; set;}

Property Value

A Thumbnail representing the thumbnail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportResourceDescriptor Class
ReportResourceDescriptor Members


ResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a resource.

Object Model

ResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ResourceDescriptor
C#
public class ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the description of the resource.
Public Property | Id | Gets or sets the unique identifier of the resource.
Public Property | Name | Gets or sets the name of the resource.
Top

See Also

Reference

ResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : ResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


ResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the description of the resource.
Public Property | Id | Gets or sets the unique identifier of the resource.
Public Property | Name | Gets or sets the name of the resource.
Top

See Also

Reference

ResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Description Property

Glossary Item Box

Gets or sets the description of the resource.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Property Value

A System.String representing the description.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Id Property

Glossary Item Box

Gets or sets the unique identifier of the resource.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

A System.String representing the unique identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ResourceDescriptor Class : Name Property

Glossary Item Box

Gets or sets the name of the resource.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String representing the name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescriptor Class
ResourceDescriptor Members


SharedDataSourceResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a shared data source resource.

Object Model

SharedDataSourceResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class SharedDataSourceResourceDescriptor
   Inherits ResourceDescriptor
C#
public class SharedDataSourceResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


SharedDataSourceResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by SharedDataSourceResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | SharedDataSourceResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of the shared data source.
Top

See Also

Reference

SharedDataSourceResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


SharedDataSourceResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > SharedDataSourceResourceDescriptor Class : SharedDataSourceResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SharedDataSourceResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Class
SharedDataSourceResourceDescriptor Members


SharedDataSourceResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
SharedDataSourceResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SharedDataSourceResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see SharedDataSourceResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of the shared data source.
Top

See Also

Reference

SharedDataSourceResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > SharedDataSourceResourceDescriptor Class : Type Property

Glossary Item Box

Gets or sets the type of the shared data source.

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type {get; set;}

Property Value

A System.String representing the type of the shared data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceResourceDescriptor Class
SharedDataSourceResourceDescriptor Members


ThemeNotFoundException Class

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

Represents the exception that is thrown when a theme cannot be found.

Object Model

ThemeNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ThemeNotFoundException
   Inherits System.Exception
C#
public class ThemeNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Web.Designer.ThemeNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Members
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ThemeNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ThemeNotFoundException Constructor |
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : ThemeNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ThemeResourceDescriptor Class

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

Represents a descriptor for a theme resource.

Object Model

ThemeResourceDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ThemeResourceDescriptor
   Inherits ResourceDescriptor
C#
public class ThemeResourceDescriptor : ResourceDescriptor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Members
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeResourceDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

The following tables list the members exposed by ThemeResourceDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ThemeResourceDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the value of the Accent1 color.
Public Property | Accent2 | Gets or sets the value of the Accent2 color.
Public Property | Accent3 | Gets or sets the value of the Accent3 color.
Public Property | Accent4 | Gets or sets the value of the Accent4 color.
Public Property | Accent5 | Gets or sets the value of the Accent5 color.
Public Property | Accent6 | Gets or sets the value of the Accent6 color.
Public Property | Dark1 | Gets or sets the value of the Dark1 color.
Public Property | Dark2 | Gets or sets the value of the Dark2 color.
Public Property | Light1 | Gets or sets the value of the Light1 color.
Public Property | Light2 | Gets or sets the value of the Light2 color.
Public Property | MajorFontFamily | Gets or sets the family name of the major font.
Public Property | MinorFontFamily | Gets or sets the family name of the minor font.
Public Property | Title | Gets or sets the title of the theme.
Top

See Also

Reference

ThemeResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeResourceDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : ThemeResourceDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeResourceDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


ThemeResourceDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeResourceDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeResourceDescriptor Class

Glossary Item Box

For a list of all members of this type, see ThemeResourceDescriptor members.

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the value of the Accent1 color.
Public Property | Accent2 | Gets or sets the value of the Accent2 color.
Public Property | Accent3 | Gets or sets the value of the Accent3 color.
Public Property | Accent4 | Gets or sets the value of the Accent4 color.
Public Property | Accent5 | Gets or sets the value of the Accent5 color.
Public Property | Accent6 | Gets or sets the value of the Accent6 color.
Public Property | Dark1 | Gets or sets the value of the Dark1 color.
Public Property | Dark2 | Gets or sets the value of the Dark2 color.
Public Property | Light1 | Gets or sets the value of the Light1 color.
Public Property | Light2 | Gets or sets the value of the Light2 color.
Public Property | MajorFontFamily | Gets or sets the family name of the major font.
Public Property | MinorFontFamily | Gets or sets the family name of the minor font.
Public Property | Title | Gets or sets the title of the theme.
Top

See Also

Reference

ThemeResourceDescriptor Class
GrapeCity.ActiveReports.Web.Designer Namespace


Accent1 Property

[image]
ActiveReports 19 .NET Edition
Accent1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent1 Property

Glossary Item Box

Gets or sets the value of the Accent1 color.

Syntax

Visual Basic (Declaration)
Public Property Accent1 As String
C#
public string Accent1 {get; set;}

Property Value

A System.String representing the value of the Accent1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent2 Property

[image]
ActiveReports 19 .NET Edition
Accent2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent2 Property

Glossary Item Box

Gets or sets the value of the Accent2 color.

Syntax

Visual Basic (Declaration)
Public Property Accent2 As String
C#
public string Accent2 {get; set;}

Property Value

A System.String representing the value of the Accent2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent3 Property

[image]
ActiveReports 19 .NET Edition
Accent3 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent3 Property

Glossary Item Box

Gets or sets the value of the Accent3 color.

Syntax

Visual Basic (Declaration)
Public Property Accent3 As String
C#
public string Accent3 {get; set;}

Property Value

A System.String representing the value of the Accent3 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent4 Property

[image]
ActiveReports 19 .NET Edition
Accent4 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent4 Property

Glossary Item Box

Gets or sets the value of the Accent4 color.

Syntax

Visual Basic (Declaration)
Public Property Accent4 As String
C#
public string Accent4 {get; set;}

Property Value

A System.String representing the value of the Accent4 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent5 Property

[image]
ActiveReports 19 .NET Edition
Accent5 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent5 Property

Glossary Item Box

Gets or sets the value of the Accent5 color.

Syntax

Visual Basic (Declaration)
Public Property Accent5 As String
C#
public string Accent5 {get; set;}

Property Value

A System.String representing the value of the Accent5 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Accent6 Property

[image]
ActiveReports 19 .NET Edition
Accent6 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Accent6 Property

Glossary Item Box

Gets or sets the value of the Accent6 color.

Syntax

Visual Basic (Declaration)
Public Property Accent6 As String
C#
public string Accent6 {get; set;}

Property Value

A System.String representing the value of the Accent6 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Dark1 Property

[image]
ActiveReports 19 .NET Edition
Dark1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Dark1 Property

Glossary Item Box

Gets or sets the value of the Dark1 color.

Syntax

Visual Basic (Declaration)
Public Property Dark1 As String
C#
public string Dark1 {get; set;}

Property Value

A System.String representing the value of the Dark1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Dark2 Property

[image]
ActiveReports 19 .NET Edition
Dark2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Dark2 Property

Glossary Item Box

Gets or sets the value of the Dark2 color.

Syntax

Visual Basic (Declaration)
Public Property Dark2 As String
C#
public string Dark2 {get; set;}

Property Value

A System.String representing the value of the Dark2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Light1 Property

[image]
ActiveReports 19 .NET Edition
Light1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Light1 Property

Glossary Item Box

Gets or sets the value of the Light1 color.

Syntax

Visual Basic (Declaration)
Public Property Light1 As String
C#
public string Light1 {get; set;}

Property Value

A System.String representing the value of the Light1 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Light2 Property

[image]
ActiveReports 19 .NET Edition
Light2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Light2 Property

Glossary Item Box

Gets or sets the value of the Light2 color.

Syntax

Visual Basic (Declaration)
Public Property Light2 As String
C#
public string Light2 {get; set;}

Property Value

A System.String representing the value of the Light2 color.

Remarks

Accepted values are in HEX format (e.g., "#000000" for black) or named colors (e.g., "Black").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


MajorFontFamily Property

[image]
ActiveReports 19 .NET Edition
MajorFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : MajorFontFamily Property

Glossary Item Box

Gets or sets the family name of the major font.

Syntax

Visual Basic (Declaration)
Public Property MajorFontFamily As String
C#
public string MajorFontFamily {get; set;}

Property Value

A System.String representing the family name of the major font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


MinorFontFamily Property

[image]
ActiveReports 19 .NET Edition
MinorFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : MinorFontFamily Property

Glossary Item Box

Gets or sets the family name of the minor font.

Syntax

Visual Basic (Declaration)
Public Property MinorFontFamily As String
C#
public string MinorFontFamily {get; set;}

Property Value

A System.String representing the family name of the minor font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeResourceDescriptor Class : Title Property

Glossary Item Box

Gets or sets the title of the theme.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Property Value

A System.String representing the title of the theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeResourceDescriptor Class
ThemeResourceDescriptor Members


Thumbnail Class

[image]
ActiveReports 19 .NET Edition
Thumbnail Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

Represents a thumbnail image.

Object Model

Thumbnail Class

Syntax

Visual Basic (Declaration)
Public Class Thumbnail
C#
public class Thumbnail

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.Thumbnail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Members
GrapeCity.ActiveReports.Web.Designer Namespace


Thumbnail Class Members

[image]
ActiveReports 19 .NET Edition
Thumbnail Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

The following tables list the members exposed by Thumbnail.

Public Constructors

 | Name | Description
Public Constructor | Thumbnail Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the thumbnail.
Public Property | Data | Gets or sets the raw binary data of the thumbnail image.
Top

See Also

Reference

Thumbnail Class
GrapeCity.ActiveReports.Web.Designer Namespace


Thumbnail Constructor

[image]
ActiveReports 19 .NET Edition
Thumbnail Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : Thumbnail Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Thumbnail()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


Thumbnail Class Properties

[image]
ActiveReports 19 .NET Edition
Thumbnail Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : Thumbnail Class

Glossary Item Box

For a list of all members of this type, see Thumbnail members.

Public Properties

 | Name | Description
Public Property | ContentType | Gets or sets the content type of the thumbnail.
Public Property | Data | Gets or sets the raw binary data of the thumbnail image.
Top

See Also

Reference

Thumbnail Class
GrapeCity.ActiveReports.Web.Designer Namespace


ContentType Property

[image]
ActiveReports 19 .NET Edition
ContentType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : ContentType Property

Glossary Item Box

Gets or sets the content type of the thumbnail.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType {get; set;}

Property Value

A System.String representing the content type of the thumbnail.

Remarks

Supported formats:
  • .bmp - image/bmp
  • .jpg - image/jpeg
  • .jpeg - image/jpeg
  • .png - image/png
  • .gif - image/gif
  • .tiff - image/tiff
  • .emf - image/x-emf
  • .wmf - image/x-wmf
  • .svg - image/svg+xml

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > Thumbnail Class : Data Property

Glossary Item Box

Gets or sets the raw binary data of the thumbnail image.

Syntax

Visual Basic (Declaration)
Public Property Data As Byte()
C#
public byte[] Data {get; set;}

Property Value

An array of System.Byte representing the raw binary content of the thumbnail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Thumbnail Class
Thumbnail Members


FileStoreOptions Enumeration

[image]
ActiveReports 19 .NET Edition
FileStoreOptions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : FileStoreOptions Enumeration

Glossary Item Box

Specifies the options for file storage.

Syntax

Visual Basic (Declaration)
Public Enum FileStoreOptions
   Inherits System.Enum
C#
public enum FileStoreOptions : System.Enum

Members

Member | Description
NestedFoldersLookup | Instructs to search for resources in nested folders.
None | No special options.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.FileStoreOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


RdlSubtype Enumeration

[image]
ActiveReports 19 .NET Edition
RdlSubtype Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : RdlSubtype Enumeration

Glossary Item Box

Specifies the RDL subtypes.

Syntax

Visual Basic (Declaration)
Public Enum RdlSubtype
   Inherits System.Enum
C#
public enum RdlSubtype : System.Enum

Members

Member | Description
ContinuousPage | Represents a continuous page report.
Dashboard | Represents a dashboard report.
FixedPage | Represents a fixed page report.
GenericRdl | Represents any RDL report.
MultiSection | Represents a multi-section report.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.RdlSubtype

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


SaveSettings Enumeration

[image]
ActiveReports 19 .NET Edition
SaveSettings Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : SaveSettings Enumeration

Glossary Item Box

Represents the save settings for a report.

Syntax

Visual Basic (Declaration)
Public Enum SaveSettings
   Inherits System.Enum
C#
public enum SaveSettings : System.Enum

Members

Member | Description
IsTemporary | Indicates that the report is temporary.
None | No special save settings.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Designer.SaveSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

Represents the full configuration for the report designer.

Syntax

Visual Basic (Declaration)
Public Interface IReportDesignerBackendApi
   Inherits IReportStore, IResourceRepositoryProvider
C#
public interface IReportDesignerBackendApi : IReportStore, IResourceRepositoryProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Members
GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface Members

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

The following tables list the members exposed by IReportDesignerBackendApi.

Public Properties

 | Name | Description
Property | ConfigurationProvider | Gets or sets the custom configuration provider.
Property | LocateDataSource | Gets or sets the function to locate the data source.
Property | Settings | Gets or sets the settings for the report designer.
Top

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IReportDesignerBackendApi Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

For a list of all members of this type, see IReportDesignerBackendApi members.

Public Properties

 | Name | Description
Property | ConfigurationProvider | Gets or sets the custom configuration provider.
Property | LocateDataSource | Gets or sets the function to locate the data source.
Property | Settings | Gets or sets the settings for the report designer.
Top

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


ConfigurationProvider Property

[image]
ActiveReports 19 .NET Edition
ConfigurationProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : ConfigurationProvider Property

Glossary Item Box

Gets or sets the custom configuration provider.

Syntax

Visual Basic (Declaration)
Property ConfigurationProvider As IConfigurationProvider
C#
IConfigurationProvider ConfigurationProvider {get; set;}

Property Value

An GrapeCity.ActiveReports.Configuration.IConfigurationProvider instance used for custom configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


LocateDataSource Property

[image]
ActiveReports 19 .NET Edition
LocateDataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : LocateDataSource Property

Glossary Item Box

Gets or sets the function to locate the data source.

Syntax

Visual Basic (Declaration)
Property LocateDataSource As Func(Of Object)
C#
Func<object> LocateDataSource {get; set;}

Property Value

A Func that returns the data source object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


Settings Property

[image]
ActiveReports 19 .NET Edition
Settings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportDesignerBackendApi Interface : Settings Property

Glossary Item Box

Gets or sets the settings for the report designer.

Syntax

Visual Basic (Declaration)
Property Settings As ReportDesignerSettings
C#
ReportDesignerSettings Settings {get; set;}

Property Value

A ReportDesignerSettings instance that contains the settings for the report designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDesignerBackendApi Interface
IReportDesignerBackendApi Members


IReportStore Interface

[image]
ActiveReports 19 .NET Edition
IReportStore Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

Represents methods for storing and managing reports.

Syntax

Visual Basic (Declaration)
Public Interface IReportStore
C#
public interface IReportStore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Members
GrapeCity.ActiveReports.Web.Designer Namespace


IReportStore Interface Members

[image]
ActiveReports 19 .NET Edition
IReportStore Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

The following tables list the members exposed by IReportStore.

Public Methods

 | Name | Description
Method | DeleteReport | Deletes the report by ID.
Method | GetReportDescriptor | Gets the report descriptor by ID.
Method | ListReports | Gets the list of report information.
Method | LoadReport | Loads the report content by ID.
Method | SaveReport | Saves the report.
Method | UpdateReport | Updates the report.
Top

See Also

Reference

IReportStore Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IReportStore Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportStore Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportStore Interface

Glossary Item Box

For a list of all members of this type, see IReportStore members.

Public Methods

 | Name | Description
Method | DeleteReport | Deletes the report by ID.
Method | GetReportDescriptor | Gets the report descriptor by ID.
Method | ListReports | Gets the list of report information.
Method | LoadReport | Loads the report content by ID.
Method | SaveReport | Saves the report.
Method | UpdateReport | Updates the report.
Top

See Also

Reference

IReportStore Interface
GrapeCity.ActiveReports.Web.Designer Namespace


DeleteReport Method

[image]
ActiveReports 19 .NET Edition
DeleteReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : DeleteReport Method

reportId
The ID of the report to delete.

Glossary Item Box

Deletes the report by ID.

Syntax

Visual Basic (Declaration)
Sub DeleteReport( _
   ByVal reportId As String _
)
C#
void DeleteReport(
   string reportId
)

Parameters

reportId
The ID of the report to delete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


GetReportDescriptor Method

[image]
ActiveReports 19 .NET Edition
GetReportDescriptor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : GetReportDescriptor Method

reportId
The ID of the report to retrieve.

Glossary Item Box

Gets the report descriptor by ID.

Syntax

Visual Basic (Declaration)
Function GetReportDescriptor( _
   ByVal reportId As String _
) As ReportDescriptor
C#
ReportDescriptor GetReportDescriptor(
   string reportId
)

Parameters

reportId
The ID of the report to retrieve.

Return Value

The GrapeCity.ActiveReports.Web.Viewer.ReportDescriptor of the specified report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


ListReports Method

[image]
ActiveReports 19 .NET Edition
ListReports Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : ListReports Method

Glossary Item Box

Gets the list of report information.

Syntax

Visual Basic (Declaration)
Function ListReports() As ReportInfo()
C#
ReportInfo[] ListReports()

Return Value

An array of ReportInfo objects representing the reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


LoadReport Method

[image]
ActiveReports 19 .NET Edition
LoadReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : LoadReport Method

reportId
The ID of the report to load.

Glossary Item Box

Loads the report content by ID.

Syntax

Visual Basic (Declaration)
Function LoadReport( _
   ByVal reportId As String _
) As Stream
C#
Stream LoadReport(
   string reportId
)

Parameters

reportId
The ID of the report to load.

Return Value

A stream containing the report content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


SaveReport Method

[image]
ActiveReports 19 .NET Edition
SaveReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : SaveReport Method

reportType
The type of the report.
reportId
The ID of the report to save.
reportData
The data of the report to save.
settings
The save settings to apply. Default is SaveSettings.None.

Glossary Item Box

Saves the report.

Syntax

Visual Basic (Declaration)
Function SaveReport( _
   ByVal reportType As ReportType, _
   ByVal reportId As String, _
   ByVal reportData As Stream, _
   Optional ByVal settings As SaveSettings _
) As String
C#
string SaveReport(
   ReportType reportType,
   string reportId,
   Stream reportData,
   SaveSettings settings
)

Parameters

reportType
The type of the report.
reportId
The ID of the report to save.
reportData
The data of the report to save.
settings
The save settings to apply. Default is SaveSettings.None.

Return Value

The ID of the saved report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


UpdateReport Method

[image]
ActiveReports 19 .NET Edition
UpdateReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IReportStore Interface : UpdateReport Method

reportType
The type of the report.
reportId
The ID of the report to update.
reportData
The data of the report to update.

Glossary Item Box

Updates the report.

Syntax

Visual Basic (Declaration)
Function UpdateReport( _
   ByVal reportType As ReportType, _
   ByVal reportId As String, _
   ByVal reportData As Stream _
) As String
C#
string UpdateReport(
   ReportType reportType,
   string reportId,
   Stream reportData
)

Parameters

reportType
The type of the report.
reportId
The ID of the report to update.
reportData
The data of the report to update.

Return Value

The ID of the updated report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportStore Interface
IReportStore Members


IResourceRepositoryProvider Interface

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

Represents methods for accessing and managing report resources.

Syntax

Visual Basic (Declaration)
Public Interface IResourceRepositoryProvider
C#
public interface IResourceRepositoryProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Members
GrapeCity.ActiveReports.Web.Designer Namespace


IResourceRepositoryProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

The following tables list the members exposed by IResourceRepositoryProvider.

Public Methods

 | Name | Description
Method | DescribeResources | Gets descriptors of the specified resources.
Method | GetResource | Gets the resource in a format compatible with the backend.
Method | ListResources | Gets the list of resources available for a particular report.
Top

See Also

Reference

IResourceRepositoryProvider Interface
GrapeCity.ActiveReports.Web.Designer Namespace


IResourceRepositoryProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IResourceRepositoryProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IResourceRepositoryProvider Interface

Glossary Item Box

For a list of all members of this type, see IResourceRepositoryProvider members.

Public Methods

 | Name | Description
Method | DescribeResources | Gets descriptors of the specified resources.
Method | GetResource | Gets the resource in a format compatible with the backend.
Method | ListResources | Gets the list of resources available for a particular report.
Top

See Also

Reference

IResourceRepositoryProvider Interface
GrapeCity.ActiveReports.Web.Designer Namespace


DescribeResources Method

[image]
ActiveReports 19 .NET Edition
DescribeResources Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : DescribeResources Method

resources
An array of GrapeCity.ActiveReports.ResourceInfo objects representing the resources to describe.

Glossary Item Box

Gets descriptors of the specified resources.

Syntax

Visual Basic (Declaration)
Function DescribeResources( _
   ByVal resources() As ResourceInfo _
) As ResourceDescriptor()
C#
ResourceDescriptor[] DescribeResources(
   ResourceInfo[] resources
)

Parameters

resources
An array of GrapeCity.ActiveReports.ResourceInfo objects representing the resources to describe.

Return Value

An array of ResourceDescriptor objects representing the descriptors of the requested resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


GetResource Method

[image]
ActiveReports 19 .NET Edition
GetResource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : GetResource Method

resource
The information about the resource to retrieve.

Glossary Item Box

Gets the resource in a format compatible with the backend.

Syntax

Visual Basic (Declaration)
Function GetResource( _
   ByVal resource As ResourceInfo _
) As Stream
C#
Stream GetResource(
   ResourceInfo resource
)

Parameters

resource
The information about the resource to retrieve.

Return Value

A stream containing the resource data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


ListResources Method

[image]
ActiveReports 19 .NET Edition
ListResources Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > IResourceRepositoryProvider Interface : ListResources Method

resourceType
The type of resources to list.

Glossary Item Box

Gets the list of resources available for a particular report.

Syntax

Visual Basic (Declaration)
Function ListResources( _
   ByVal resourceType As ResourceType _
) As ResourceDescriptor()
C#
ResourceDescriptor[] ListResources(
   ResourceType resourceType
)

Parameters

resourceType
The type of resources to list.

Return Value

An array of ResourceDescriptor objects representing the available resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourceRepositoryProvider Interface
IResourceRepositoryProvider Members


ConfigureExtensions Class

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

Represents a set of methods for configuring the web host application.

Object Model

ConfigureExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ConfigureExtensions
C#
public static class ConfigureExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ConfigureExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ConfigureExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

The following tables list the members exposed by ConfigureExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReportViewer | Adds services required for the report designer.
static (Shared in Visual Basic) | UseReportViewer | Overloaded. Configures middleware for the ActiveReports viewer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ConfigureExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ConfigureExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ConfigureExtensions Class

Glossary Item Box

For a list of all members of this type, see ConfigureExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReportViewer | Adds services required for the report designer.
static (Shared in Visual Basic) | UseReportViewer | Overloaded. Configures middleware for the ActiveReports viewer API.
Top

See Also

Reference

ConfigureExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


AddReportViewer Method

[image]
ActiveReports 19 .NET Edition
AddReportViewer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ConfigureExtensions Class : AddReportViewer Method

services
A Microsoft.Extensions.DependencyInjection.IServiceCollection object to add the services to.

Glossary Item Box

Adds services required for the report designer.

Syntax

Visual Basic (Declaration)
Public Shared Function AddReportViewer( _
   ByVal services As IServiceCollection _
) As IServiceCollection
C#
public static IServiceCollection AddReportViewer(
   IServiceCollection services
)

Parameters

services
A Microsoft.Extensions.DependencyInjection.IServiceCollection object to add the services to.

Return Value

A Microsoft.Extensions.DependencyInjection.IServiceCollection object so that additional calls can be chained.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportViewer Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ConfigureExtensions Class : UseReportViewer Method

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Overload List

Overload | Description
UseReportViewer(IApplicationBuilder,Action<ReportViewerConfiguration>) | Configures middleware for the ActiveReports viewer API.
UseReportViewer(IApplicationBuilder,IReportViewerBackendApi) | Configures middleware for the ActiveReports viewer API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members


UseReportViewer(IApplicationBuilder,Action<ReportViewerConfiguration>) Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer(IApplicationBuilder,Action<ReportViewerConfiguration>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ConfigureExtensions Class > UseReportViewer Method : UseReportViewer(IApplicationBuilder,Action<ReportViewerConfiguration>) Method

app
A Microsoft.AspNetCore.Builder.IApplicationBuilder object to configure.
configAction
An Action to configure the report viewer.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportViewer( _
   ByVal app As IApplicationBuilder, _
   ByVal configAction As Action(Of ReportViewerConfiguration) _
)
C#
public static void UseReportViewer(
   IApplicationBuilder app,
   Action<ReportViewerConfiguration> configAction
)

Parameters

app
A Microsoft.AspNetCore.Builder.IApplicationBuilder object to configure.
configAction
An Action to configure the report viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


UseReportViewer(IApplicationBuilder,IReportViewerBackendApi) Method

[image]
ActiveReports 19 .NET Edition
UseReportViewer(IApplicationBuilder,IReportViewerBackendApi) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ConfigureExtensions Class > UseReportViewer Method : UseReportViewer(IApplicationBuilder,IReportViewerBackendApi) Method

app
A Microsoft.AspNetCore.Builder.IApplicationBuilder object to configure.
customApi
A GrapeCity.ActiveReports.Web.Viewer.IReportViewerBackendApi object to use for configuring the middleware.

Glossary Item Box

Configures middleware for the ActiveReports viewer API.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub UseReportViewer( _
   ByVal app As IApplicationBuilder, _
   ByVal customApi As IReportViewerBackendApi _
)
C#
public static void UseReportViewer(
   IApplicationBuilder app,
   IReportViewerBackendApi customApi
)

Parameters

app
A Microsoft.AspNetCore.Builder.IApplicationBuilder object to configure.
customApi
A GrapeCity.ActiveReports.Web.Viewer.IReportViewerBackendApi object to use for configuring the middleware.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigureExtensions Class
ConfigureExtensions Members
Overload List


_Imports Class

[image]
ActiveReports 19 .NET Edition
_Imports Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : _Imports Class

Glossary Item Box

Object Model

_Imports Class

Syntax

Visual Basic (Declaration)
Public Class _Imports
   Inherits Microsoft.AspNetCore.Components.ComponentBase
   Implements Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent
C#
public class _Imports : Microsoft.AspNetCore.Components.ComponentBase, Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent

Inheritance Hierarchy

System.Object
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Designer._Imports

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


_Imports Class Members

[image]
ActiveReports 19 .NET Edition
_Imports Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : _Imports Class

Glossary Item Box

The following tables list the members exposed by _Imports.

Public Constructors

 | Name | Description
Public Constructor | _Imports Constructor |
Top

See Also

Reference

_Imports Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


_Imports Constructor

[image]
ActiveReports 19 .NET Edition
_Imports Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > _Imports Class : _Imports Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public _Imports()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Class
_Imports Members


About Class

[image]
ActiveReports 19 .NET Edition
About Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : About Class

Glossary Item Box

Represents the documentation links and application info.

Object Model

About Class

Syntax

Visual Basic (Declaration)
Public Class About
C#
public class About

Remarks

The About class provides properties to store information about the application and links to relevant documentation.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.About

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


About Class Members

[image]
ActiveReports 19 .NET Edition
About Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : About Class

Glossary Item Box

The following tables list the members exposed by About.

Public Constructors

 | Name | Description
Public Constructor | About Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplicationTitle | Gets or sets the application title.
Public Property | ApplicationTitleCompact | Gets or sets a compact version of the application title.
Public Property | ApplicationVersion | Gets or sets the application version.
Public Property | CoreVersion | Gets or sets the Designer Core version the application is based on.
Public Property | Help | Gets or sets designer-related documentation links.
Top

See Also

Reference

About Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


About Constructor

[image]
ActiveReports 19 .NET Edition
About Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : About Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public About()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


About Class Properties

[image]
ActiveReports 19 .NET Edition
About Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : About Class

Glossary Item Box

For a list of all members of this type, see About members.

Public Properties

 | Name | Description
Public Property | ApplicationTitle | Gets or sets the application title.
Public Property | ApplicationTitleCompact | Gets or sets a compact version of the application title.
Public Property | ApplicationVersion | Gets or sets the application version.
Public Property | CoreVersion | Gets or sets the Designer Core version the application is based on.
Public Property | Help | Gets or sets designer-related documentation links.
Top

See Also

Reference

About Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ApplicationTitle Property

[image]
ActiveReports 19 .NET Edition
ApplicationTitle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : ApplicationTitle Property

Glossary Item Box

Gets or sets the application title.

Syntax

Visual Basic (Declaration)
Public Property ApplicationTitle As String
C#
public string ApplicationTitle {get; set;}

Property Value

The title of the application as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


ApplicationTitleCompact Property

[image]
ActiveReports 19 .NET Edition
ApplicationTitleCompact Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : ApplicationTitleCompact Property

Glossary Item Box

Gets or sets a compact version of the application title.

Syntax

Visual Basic (Declaration)
Public Property ApplicationTitleCompact As String
C#
public string ApplicationTitleCompact {get; set;}

Property Value

The compact version of the application title as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


ApplicationVersion Property

[image]
ActiveReports 19 .NET Edition
ApplicationVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : ApplicationVersion Property

Glossary Item Box

Gets or sets the application version.

Syntax

Visual Basic (Declaration)
Public Property ApplicationVersion As String
C#
public string ApplicationVersion {get; set;}

Property Value

The version of the application as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


CoreVersion Property

[image]
ActiveReports 19 .NET Edition
CoreVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : CoreVersion Property

Glossary Item Box

Gets or sets the Designer Core version the application is based on.

Syntax

Visual Basic (Declaration)
Public Property CoreVersion As String
C#
public string CoreVersion {get; set;}

Property Value

The core version of the designer as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


Help Property

[image]
ActiveReports 19 .NET Edition
Help Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > About Class : Help Property

Glossary Item Box

Gets or sets designer-related documentation links.

Syntax

Visual Basic (Declaration)
Public Property Help As Help
C#
public Help Help {get; set;}

Property Value

An instance of Help that contains links to designer-related documentation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

About Class
About Members


AboutButton Class

[image]
ActiveReports 19 .NET Edition
AboutButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AboutButton Class

Glossary Item Box

Represents the settings for the About button.

Object Model

AboutButton Class

Syntax

Visual Basic (Declaration)
Public Class AboutButton
C#
public class AboutButton

Remarks

The AboutButton class provides a property to configure the visibility of the About button in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.AboutButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AboutButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


AboutButton Class Members

[image]
ActiveReports 19 .NET Edition
AboutButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AboutButton Class

Glossary Item Box

The following tables list the members exposed by AboutButton.

Public Constructors

 | Name | Description
Public Constructor | AboutButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the About button should be visible.
Top

See Also

Reference

AboutButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AboutButton Constructor

[image]
ActiveReports 19 .NET Edition
AboutButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AboutButton Class : AboutButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AboutButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AboutButton Class
AboutButton Members


AboutButton Class Properties

[image]
ActiveReports 19 .NET Edition
AboutButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AboutButton Class

Glossary Item Box

For a list of all members of this type, see AboutButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the About button should be visible.
Top

See Also

Reference

AboutButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AboutButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the About button should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the About button should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AboutButton Class
AboutButton Members


App Class

[image]
ActiveReports 19 .NET Edition
App Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : App Class

Glossary Item Box

Represents the main application class, providing access to application-level functionalities.

Object Model

App Class

Syntax

Visual Basic (Declaration)
Public Class App
C#
public class App

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.App

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

App Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


App Class Members

[image]
ActiveReports 19 .NET Edition
App Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : App Class

Glossary Item Box

The following tables list the members exposed by App.

Public Properties

 | Name | Description
Public Property | Panels | Gets the object providing access to the menu and sidebar panels.
Top

Public Methods

 | Name | Description
Public Method | Focus | Returns focus to Designer. Focus may be lost when plug-in components are opened/closed. Returning focus is essential to continue using Designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.
Public Method | GetAbout | Retrieves the application about information including documentation links and application details.
Top

See Also

Reference

App Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


App Class Methods

[image]
ActiveReports 19 .NET Edition
App Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : App Class

Glossary Item Box

For a list of all members of this type, see App members.

Public Methods

 | Name | Description
Public Method | Focus | Returns focus to Designer. Focus may be lost when plug-in components are opened/closed. Returning focus is essential to continue using Designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.
Public Method | GetAbout | Retrieves the application about information including documentation links and application details.
Top

See Also

Reference

App Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Focus Method

[image]
ActiveReports 19 .NET Edition
Focus Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > App Class : Focus Method

Glossary Item Box

Returns focus to Designer. Focus may be lost when plug-in components are opened/closed. Returning focus is essential to continue using Designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Task
C#
public Task Focus()

Return Value

A System.Threading.Tasks.Task that represents the asynchronous operation of restoring focus to the Designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

App Class
App Members


GetAbout Method

[image]
ActiveReports 19 .NET Edition
GetAbout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > App Class : GetAbout Method

Glossary Item Box

Retrieves the application about information including documentation links and application details.

Syntax

Visual Basic (Declaration)
Public Function GetAbout() As ValueTask(Of About)
C#
public ValueTask<About> GetAbout()

Return Value

An About object containing documentation links and application info.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

App Class
App Members


App Class Properties

[image]
ActiveReports 19 .NET Edition
App Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : App Class

Glossary Item Box

For a list of all members of this type, see App members.

Public Properties

 | Name | Description
Public Property | Panels | Gets the object providing access to the menu and sidebar panels.
Top

See Also

Reference

App Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Panels Property

[image]
ActiveReports 19 .NET Edition
Panels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > App Class : Panels Property

Glossary Item Box

Gets the object providing access to the menu and sidebar panels.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Panels As Panels
C#
public Panels Panels {get;}

Property Value

An instance of Panels that provides methods to interact with the menu and sidebar.

Remarks

Use this property to interact with the menu and sidebar panels of the application.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

App Class
App Members


AppBarSettings Class

[image]
ActiveReports 19 .NET Edition
AppBarSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AppBarSettings Class

Glossary Item Box

Represents the settings for the App Bar, providing quick access to common actions and controls.

Object Model

AppBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class AppBarSettings
C#
public class AppBarSettings

Remarks

The AppBarSettings class provides properties to configure the visibility and settings of various buttons and tabs within the application's App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.AppBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


AppBarSettings Class Members

[image]
ActiveReports 19 .NET Edition
AppBarSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AppBarSettings Class

Glossary Item Box

The following tables list the members exposed by AppBarSettings.

Public Constructors

 | Name | Description
Public Constructor | AppBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AboutButton | Gets or sets the About button settings.
Public Property | ContextActionsTab | Gets or sets the Context Actions tab settings.
Public Property | HomeTab | Gets or sets the Home tab settings.
Public Property | InsertTab | Gets or sets the Insert tab settings.
Public Property | OpenButton | Gets or sets the Open button settings.
Public Property | ParametersTab | Gets or sets the Parameters tab settings.
Public Property | SaveAsButton | Gets or sets the Save As button settings.
Public Property | SaveButton | Gets or sets the Save button settings.
Public Property | ScriptTab | Gets or sets the Script tab settings.
Public Property | Visible | Gets or sets a value indicating whether the App Bar should be shown.
Top

See Also

Reference

AppBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AppBarSettings Constructor

[image]
ActiveReports 19 .NET Edition
AppBarSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : AppBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AppBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


AppBarSettings Class Properties

[image]
ActiveReports 19 .NET Edition
AppBarSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : AppBarSettings Class

Glossary Item Box

For a list of all members of this type, see AppBarSettings members.

Public Properties

 | Name | Description
Public Property | AboutButton | Gets or sets the About button settings.
Public Property | ContextActionsTab | Gets or sets the Context Actions tab settings.
Public Property | HomeTab | Gets or sets the Home tab settings.
Public Property | InsertTab | Gets or sets the Insert tab settings.
Public Property | OpenButton | Gets or sets the Open button settings.
Public Property | ParametersTab | Gets or sets the Parameters tab settings.
Public Property | SaveAsButton | Gets or sets the Save As button settings.
Public Property | SaveButton | Gets or sets the Save button settings.
Public Property | ScriptTab | Gets or sets the Script tab settings.
Public Property | Visible | Gets or sets a value indicating whether the App Bar should be shown.
Top

See Also

Reference

AppBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AboutButton Property

[image]
ActiveReports 19 .NET Edition
AboutButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : AboutButton Property

Glossary Item Box

Gets or sets the About button settings.

Syntax

Visual Basic (Declaration)
Public Property AboutButton As AboutButton
C#
public AboutButton AboutButton {get; set;}

Property Value

An instance of AboutButton that contains the settings for the About button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


ContextActionsTab Property

[image]
ActiveReports 19 .NET Edition
ContextActionsTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : ContextActionsTab Property

Glossary Item Box

Gets or sets the Context Actions tab settings.

Syntax

Visual Basic (Declaration)
Public Property ContextActionsTab As ContextActionsTab
C#
public ContextActionsTab ContextActionsTab {get; set;}

Property Value

An instance of ContextActionsTab that contains the settings for the Context Actions tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


HomeTab Property

[image]
ActiveReports 19 .NET Edition
HomeTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : HomeTab Property

Glossary Item Box

Gets or sets the Home tab settings.

Syntax

Visual Basic (Declaration)
Public Property HomeTab As HomeTab
C#
public HomeTab HomeTab {get; set;}

Property Value

An instance of HomeTab that contains the settings for the Home tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


InsertTab Property

[image]
ActiveReports 19 .NET Edition
InsertTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : InsertTab Property

Glossary Item Box

Gets or sets the Insert tab settings.

Syntax

Visual Basic (Declaration)
Public Property InsertTab As InsertTab
C#
public InsertTab InsertTab {get; set;}

Property Value

An instance of InsertTab that contains the settings for the Insert tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


OpenButton Property

[image]
ActiveReports 19 .NET Edition
OpenButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : OpenButton Property

Glossary Item Box

Gets or sets the Open button settings.

Syntax

Visual Basic (Declaration)
Public Property OpenButton As OpenButton
C#
public OpenButton OpenButton {get; set;}

Property Value

An instance of OpenButton that contains the settings for the Open button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


ParametersTab Property

[image]
ActiveReports 19 .NET Edition
ParametersTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : ParametersTab Property

Glossary Item Box

Gets or sets the Parameters tab settings.

Syntax

Visual Basic (Declaration)
Public Property ParametersTab As ParametersTab
C#
public ParametersTab ParametersTab {get; set;}

Property Value

An instance of ParametersTab that contains the settings for the Parameters tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


SaveAsButton Property

[image]
ActiveReports 19 .NET Edition
SaveAsButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : SaveAsButton Property

Glossary Item Box

Gets or sets the Save As button settings.

Syntax

Visual Basic (Declaration)
Public Property SaveAsButton As SaveAsButton
C#
public SaveAsButton SaveAsButton {get; set;}

Property Value

An instance of SaveAsButton that contains the settings for the Save As button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


SaveButton Property

[image]
ActiveReports 19 .NET Edition
SaveButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : SaveButton Property

Glossary Item Box

Gets or sets the Save button settings.

Syntax

Visual Basic (Declaration)
Public Property SaveButton As SaveButton
C#
public SaveButton SaveButton {get; set;}

Property Value

An instance of SaveButton that contains the settings for the Save button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


ScriptTab Property

[image]
ActiveReports 19 .NET Edition
ScriptTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : ScriptTab Property

Glossary Item Box

Gets or sets the Script tab settings.

Syntax

Visual Basic (Declaration)
Public Property ScriptTab As ScriptTab
C#
public ScriptTab ScriptTab {get; set;}

Property Value

An instance of ScriptTab that contains the settings for the Script tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > AppBarSettings Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the App Bar should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the App Bar should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AppBarSettings Class
AppBarSettings Members


Barcore Class

[image]
ActiveReports 19 .NET Edition
Barcore Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Barcore Class

Glossary Item Box

Represents the features for barcode items.

Object Model

Barcore Class

Syntax

Visual Basic (Declaration)
Public Class Barcore
C#
public class Barcore

Remarks

The Barcore class provides properties to configure the available symbologies and visibility of unsupported BarcodeJS properties for barcode items.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Barcore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcore Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Barcore Class Members

[image]
ActiveReports 19 .NET Edition
Barcore Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Barcore Class

Glossary Item Box

The following tables list the members exposed by Barcore.

Public Constructors

 | Name | Description
Public Constructor | Barcore Constructor |
Top

Public Properties

 | Name | Description
Public Property | HideUnsupportedBarcodeJSProperties | Gets or sets a value indicating whether to hide some unsupported BarcodeJS properties.
Public Property | Symbologies | Gets or sets the list of barcode symbologies available for creation.
Top

See Also

Reference

Barcore Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Barcore Constructor

[image]
ActiveReports 19 .NET Edition
Barcore Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Barcore Class : Barcore Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Barcore()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcore Class
Barcore Members


Barcore Class Properties

[image]
ActiveReports 19 .NET Edition
Barcore Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Barcore Class

Glossary Item Box

For a list of all members of this type, see Barcore members.

Public Properties

 | Name | Description
Public Property | HideUnsupportedBarcodeJSProperties | Gets or sets a value indicating whether to hide some unsupported BarcodeJS properties.
Public Property | Symbologies | Gets or sets the list of barcode symbologies available for creation.
Top

See Also

Reference

Barcore Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


HideUnsupportedBarcodeJSProperties Property

[image]
ActiveReports 19 .NET Edition
HideUnsupportedBarcodeJSProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Barcore Class : HideUnsupportedBarcodeJSProperties Property

Glossary Item Box

Gets or sets a value indicating whether to hide some unsupported BarcodeJS properties.

Syntax

Visual Basic (Declaration)
Public Property HideUnsupportedBarcodeJSProperties As Nullable(Of Boolean)
C#
public Nullable<bool> HideUnsupportedBarcodeJSProperties {get; set;}

Property Value

true if unsupported BarcodeJS properties should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcore Class
Barcore Members


Symbologies Property

[image]
ActiveReports 19 .NET Edition
Symbologies Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Barcore Class : Symbologies Property

Glossary Item Box

Gets or sets the list of barcode symbologies available for creation.

Syntax

Visual Basic (Declaration)
Public Property Symbologies As RdlxBarcodeSymbology()
C#
public RdlxBarcodeSymbology[] Symbologies {get; set;}

Property Value

An array of RdlxBarcodeSymbology that contains the available symbologies for barcode items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcore Class
Barcore Members


BorderStyle Class

[image]
ActiveReports 19 .NET Edition
BorderStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BorderStyle Class

Glossary Item Box

Represents the border style for a report item.

Object Model

BorderStyle Class

Syntax

Visual Basic (Declaration)
Public Class BorderStyle
C#
public class BorderStyle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.BorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


BorderStyle Class Members

[image]
ActiveReports 19 .NET Edition
BorderStyle Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BorderStyle Class

Glossary Item Box

The following tables list the members exposed by BorderStyle.

Public Constructors

 | Name | Description
Public Constructor | BorderStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the border.
Public Property | Style | Gets or sets the style of the border.
Public Property | Width | Gets or sets the width of the border.
Top

See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BorderStyle Constructor

[image]
ActiveReports 19 .NET Edition
BorderStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BorderStyle Class : BorderStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


BorderStyle Class Properties

[image]
ActiveReports 19 .NET Edition
BorderStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BorderStyle Class

Glossary Item Box

For a list of all members of this type, see BorderStyle members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the border.
Public Property | Style | Gets or sets the style of the border.
Public Property | Width | Gets or sets the width of the border.
Top

See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BorderStyle Class : Color Property

Glossary Item Box

Gets or sets the color of the border.

Syntax

Visual Basic (Declaration)
Public Property Color As String
C#
public string Color {get; set;}

Property Value

The color of the border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BorderStyle Class : Style Property

Glossary Item Box

Gets or sets the style of the border.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

The style of the border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BorderStyle Class : Width Property

Glossary Item Box

Gets or sets the width of the border.

Syntax

Visual Basic (Declaration)
Public Property Width As String
C#
public string Width {get; set;}

Property Value

The width of the border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


BulletStyleContent Class

[image]
ActiveReports 19 .NET Edition
BulletStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BulletStyleContent Class

Glossary Item Box

Represents the style content for a bullet report item.

Object Model

BulletStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class BulletStyleContent
C#
public class BulletStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.BulletStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


BulletStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
BulletStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BulletStyleContent Class

Glossary Item Box

The following tables list the members exposed by BulletStyleContent.

Public Constructors

 | Name | Description
Public Constructor | BulletStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | LabelFontColor | Gets or sets the font color of the label in the bullet.
Public Property | LabelFontFamily | Gets or sets the font family of the label in the bullet.
Public Property | LabelFontSize | Gets or sets the font size of the label in the bullet.
Public Property | LabelFontStyle | Gets or sets the font style of the label in the bullet.
Public Property | TargetLineColor | Gets or sets the color of the target line in the bullet.
Public Property | TicksLineColor | Gets or sets the color of the ticks line in the bullet.
Public Property | ValueColor | Gets or sets the color of the value in the bullet.
Top

See Also

Reference

BulletStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BulletStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
BulletStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : BulletStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BulletStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


BulletStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
BulletStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : BulletStyleContent Class

Glossary Item Box

For a list of all members of this type, see BulletStyleContent members.

Public Properties

 | Name | Description
Public Property | LabelFontColor | Gets or sets the font color of the label in the bullet.
Public Property | LabelFontFamily | Gets or sets the font family of the label in the bullet.
Public Property | LabelFontSize | Gets or sets the font size of the label in the bullet.
Public Property | LabelFontStyle | Gets or sets the font style of the label in the bullet.
Public Property | TargetLineColor | Gets or sets the color of the target line in the bullet.
Public Property | TicksLineColor | Gets or sets the color of the ticks line in the bullet.
Public Property | ValueColor | Gets or sets the color of the value in the bullet.
Top

See Also

Reference

BulletStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


LabelFontColor Property

[image]
ActiveReports 19 .NET Edition
LabelFontColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : LabelFontColor Property

Glossary Item Box

Gets or sets the font color of the label in the bullet.

Syntax

Visual Basic (Declaration)
Public Property LabelFontColor As String
C#
public string LabelFontColor {get; set;}

Property Value

The font color of the label as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


LabelFontFamily Property

[image]
ActiveReports 19 .NET Edition
LabelFontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : LabelFontFamily Property

Glossary Item Box

Gets or sets the font family of the label in the bullet.

Syntax

Visual Basic (Declaration)
Public Property LabelFontFamily As String
C#
public string LabelFontFamily {get; set;}

Property Value

The font family of the label as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


LabelFontSize Property

[image]
ActiveReports 19 .NET Edition
LabelFontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : LabelFontSize Property

Glossary Item Box

Gets or sets the font size of the label in the bullet.

Syntax

Visual Basic (Declaration)
Public Property LabelFontSize As String
C#
public string LabelFontSize {get; set;}

Property Value

The font size of the label as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


LabelFontStyle Property

[image]
ActiveReports 19 .NET Edition
LabelFontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : LabelFontStyle Property

Glossary Item Box

Gets or sets the font style of the label in the bullet.

Syntax

Visual Basic (Declaration)
Public Property LabelFontStyle As String
C#
public string LabelFontStyle {get; set;}

Property Value

The font style of the label as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


TargetLineColor Property

[image]
ActiveReports 19 .NET Edition
TargetLineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : TargetLineColor Property

Glossary Item Box

Gets or sets the color of the target line in the bullet.

Syntax

Visual Basic (Declaration)
Public Property TargetLineColor As String
C#
public string TargetLineColor {get; set;}

Property Value

The color of the target line as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


TicksLineColor Property

[image]
ActiveReports 19 .NET Edition
TicksLineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : TicksLineColor Property

Glossary Item Box

Gets or sets the color of the ticks line in the bullet.

Syntax

Visual Basic (Declaration)
Public Property TicksLineColor As String
C#
public string TicksLineColor {get; set;}

Property Value

The color of the ticks line as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


ValueColor Property

[image]
ActiveReports 19 .NET Edition
ValueColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > BulletStyleContent Class : ValueColor Property

Glossary Item Box

Gets or sets the color of the value in the bullet.

Syntax

Visual Basic (Declaration)
Public Property ValueColor As String
C#
public string ValueColor {get; set;}

Property Value

The color of the value as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletStyleContent Class
BulletStyleContent Members


CellStyleContent Class

[image]
ActiveReports 19 .NET Edition
CellStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CellStyleContent Class

Glossary Item Box

Represents the style content for a cell in a table report item.

Object Model

CellStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class CellStyleContent
   Inherits TextBoxStyleContent
C#
public class CellStyleContent : TextBoxStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TextBoxStyleContent
GrapeCity.ActiveReports.Blazor.Designer.CellStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


CellStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
CellStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CellStyleContent Class

Glossary Item Box

The following tables list the members exposed by CellStyleContent.

Public Constructors

 | Name | Description
Public Constructor | CellStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | BottomBorder | Gets or sets the bottom border style of the cell.
Public Property | LeftBorder | Gets or sets the left border style of the cell.
Public Property | RightBorder | Gets or sets the right border style of the cell.
Public Property | TextAlign | Gets or sets the text alignment of the cell.
Public Property | TopBorder | Gets or sets the top border style of the cell.
Public Property | VerticalAlign | Gets or sets the vertical alignment of the cell.
Top

See Also

Reference

CellStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CellStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
CellStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : CellStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CellStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


CellStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
CellStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CellStyleContent Class

Glossary Item Box

For a list of all members of this type, see CellStyleContent members.

Public Properties

 | Name | Description
Public Property | BottomBorder | Gets or sets the bottom border style of the cell.
Public Property | LeftBorder | Gets or sets the left border style of the cell.
Public Property | RightBorder | Gets or sets the right border style of the cell.
Public Property | TextAlign | Gets or sets the text alignment of the cell.
Public Property | TopBorder | Gets or sets the top border style of the cell.
Public Property | VerticalAlign | Gets or sets the vertical alignment of the cell.
Top

See Also

Reference

CellStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BottomBorder Property

[image]
ActiveReports 19 .NET Edition
BottomBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : BottomBorder Property

Glossary Item Box

Gets or sets the bottom border style of the cell.

Syntax

Visual Basic (Declaration)
Public Property BottomBorder As BorderStyle
C#
public BorderStyle BottomBorder {get; set;}

Property Value

The bottom border style as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


LeftBorder Property

[image]
ActiveReports 19 .NET Edition
LeftBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : LeftBorder Property

Glossary Item Box

Gets or sets the left border style of the cell.

Syntax

Visual Basic (Declaration)
Public Property LeftBorder As BorderStyle
C#
public BorderStyle LeftBorder {get; set;}

Property Value

The left border style as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


RightBorder Property

[image]
ActiveReports 19 .NET Edition
RightBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : RightBorder Property

Glossary Item Box

Gets or sets the right border style of the cell.

Syntax

Visual Basic (Declaration)
Public Property RightBorder As BorderStyle
C#
public BorderStyle RightBorder {get; set;}

Property Value

The right border style as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : TextAlign Property

Glossary Item Box

Gets or sets the text alignment of the cell.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As String
C#
public string TextAlign {get; set;}

Property Value

The text alignment of the cell as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


TopBorder Property

[image]
ActiveReports 19 .NET Edition
TopBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : TopBorder Property

Glossary Item Box

Gets or sets the top border style of the cell.

Syntax

Visual Basic (Declaration)
Public Property TopBorder As BorderStyle
C#
public BorderStyle TopBorder {get; set;}

Property Value

The top border style as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CellStyleContent Class : VerticalAlign Property

Glossary Item Box

Gets or sets the vertical alignment of the cell.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As String
C#
public string VerticalAlign {get; set;}

Property Value

The vertical alignment of the cell as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellStyleContent Class
CellStyleContent Members


ChangedDocumentOptions Class

[image]
ActiveReports 19 .NET Edition
ChangedDocumentOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ChangedDocumentOptions Class

Glossary Item Box

Represents the options for changed document information.

Object Model

ChangedDocumentOptions Class

Syntax

Visual Basic (Declaration)
Public Class ChangedDocumentOptions
C#
public class ChangedDocumentOptions

Remarks

The ChangedDocumentOptions class provides properties to configure the document content and its unsaved changes status.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ChangedDocumentOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangedDocumentOptions Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ChangedDocumentOptions Class Members

[image]
ActiveReports 19 .NET Edition
ChangedDocumentOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ChangedDocumentOptions Class

Glossary Item Box

The following tables list the members exposed by ChangedDocumentOptions.

Public Constructors

 | Name | Description
Public Constructor | ChangedDocumentOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Document | Gets or sets the document content.
Public Property | HasUnsavedChanges | Gets or sets a value indicating whether the document has unsaved changes.
Top

See Also

Reference

ChangedDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ChangedDocumentOptions Constructor

[image]
ActiveReports 19 .NET Edition
ChangedDocumentOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ChangedDocumentOptions Class : ChangedDocumentOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChangedDocumentOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangedDocumentOptions Class
ChangedDocumentOptions Members


ChangedDocumentOptions Class Properties

[image]
ActiveReports 19 .NET Edition
ChangedDocumentOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ChangedDocumentOptions Class

Glossary Item Box

For a list of all members of this type, see ChangedDocumentOptions members.

Public Properties

 | Name | Description
Public Property | Document | Gets or sets the document content.
Public Property | HasUnsavedChanges | Gets or sets a value indicating whether the document has unsaved changes.
Top

See Also

Reference

ChangedDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ChangedDocumentOptions Class : Document Property

Glossary Item Box

Gets or sets the document content.

Syntax

Visual Basic (Declaration)
Public Property Document As Object
C#
public object Document {get; set;}

Property Value

The document content as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangedDocumentOptions Class
ChangedDocumentOptions Members


HasUnsavedChanges Property

[image]
ActiveReports 19 .NET Edition
HasUnsavedChanges Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ChangedDocumentOptions Class : HasUnsavedChanges Property

Glossary Item Box

Gets or sets a value indicating whether the document has unsaved changes.

Syntax

Visual Basic (Declaration)
Public Property HasUnsavedChanges As Boolean
C#
public bool HasUnsavedChanges {get; set;}

Property Value

true if the document has unsaved changes; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangedDocumentOptions Class
ChangedDocumentOptions Members


CommonValues Class

[image]
ActiveReports 19 .NET Edition
CommonValues Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CommonValues Class

Glossary Item Box

Represents the settings for the common values section.

Object Model

CommonValues Class

Syntax

Visual Basic (Declaration)
Public Class CommonValues
C#
public class CommonValues

Remarks

The CommonValues class provides a property to configure the visibility of the common values section within the application.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.CommonValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommonValues Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


CommonValues Class Members

[image]
ActiveReports 19 .NET Edition
CommonValues Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CommonValues Class

Glossary Item Box

The following tables list the members exposed by CommonValues.

Public Constructors

 | Name | Description
Public Constructor | CommonValues Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the common values section.
Top

See Also

Reference

CommonValues Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CommonValues Constructor

[image]
ActiveReports 19 .NET Edition
CommonValues Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CommonValues Class : CommonValues Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CommonValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommonValues Class
CommonValues Members


CommonValues Class Properties

[image]
ActiveReports 19 .NET Edition
CommonValues Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CommonValues Class

Glossary Item Box

For a list of all members of this type, see CommonValues members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the common values section.
Top

See Also

Reference

CommonValues Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CommonValues Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the common values section.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the common values section should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommonValues Class
CommonValues Members


ContainerStyleContent Class

[image]
ActiveReports 19 .NET Edition
ContainerStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContainerStyleContent Class

Glossary Item Box

Represents the style content for a container report item.

Object Model

ContainerStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class ContainerStyleContent
C#
public class ContainerStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ContainerStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContainerStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ContainerStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
ContainerStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContainerStyleContent Class

Glossary Item Box

The following tables list the members exposed by ContainerStyleContent.

Public Constructors

 | Name | Description
Public Constructor | ContainerStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the container.
Public Property | Border | Gets or sets the border style of the container.
Top

See Also

Reference

ContainerStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ContainerStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
ContainerStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ContainerStyleContent Class : ContainerStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ContainerStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContainerStyleContent Class
ContainerStyleContent Members


ContainerStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
ContainerStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContainerStyleContent Class

Glossary Item Box

For a list of all members of this type, see ContainerStyleContent members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the container.
Public Property | Border | Gets or sets the border style of the container.
Top

See Also

Reference

ContainerStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ContainerStyleContent Class : BackgroundColor Property

Glossary Item Box

Gets or sets the background color of the container.

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As String
C#
public string BackgroundColor {get; set;}

Property Value

The background color of the container as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContainerStyleContent Class
ContainerStyleContent Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ContainerStyleContent Class : Border Property

Glossary Item Box

Gets or sets the border style of the container.

Syntax

Visual Basic (Declaration)
Public Property Border As BorderStyle
C#
public BorderStyle Border {get; set;}

Property Value

The border style of the container as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContainerStyleContent Class
ContainerStyleContent Members


ContextActionsTab Class

[image]
ActiveReports 19 .NET Edition
ContextActionsTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContextActionsTab Class

Glossary Item Box

Represents the settings for the Context Actions tab.

Object Model

ContextActionsTab Class

Syntax

Visual Basic (Declaration)
Public Class ContextActionsTab
C#
public class ContextActionsTab

Remarks

The ContextActionsTab class provides a property to configure the visibility of the Context Actions tab in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ContextActionsTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextActionsTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ContextActionsTab Class Members

[image]
ActiveReports 19 .NET Edition
ContextActionsTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContextActionsTab Class

Glossary Item Box

The following tables list the members exposed by ContextActionsTab.

Public Constructors

 | Name | Description
Public Constructor | ContextActionsTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Context Actions tab should be visible.
Top

See Also

Reference

ContextActionsTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ContextActionsTab Constructor

[image]
ActiveReports 19 .NET Edition
ContextActionsTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ContextActionsTab Class : ContextActionsTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ContextActionsTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextActionsTab Class
ContextActionsTab Members


ContextActionsTab Class Properties

[image]
ActiveReports 19 .NET Edition
ContextActionsTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ContextActionsTab Class

Glossary Item Box

For a list of all members of this type, see ContextActionsTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Context Actions tab should be visible.
Top

See Also

Reference

ContextActionsTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ContextActionsTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Context Actions tab should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Context Actions tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextActionsTab Class
ContextActionsTab Members


CreateDocumentInfo Class

[image]
ActiveReports 19 .NET Edition
CreateDocumentInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentInfo Class

Glossary Item Box

Represents the information about a created document.

Object Model

CreateDocumentInfo Class

Syntax

Visual Basic (Declaration)
Public Class CreateDocumentInfo
C#
public class CreateDocumentInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.CreateDocumentInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


CreateDocumentInfo Class Members

[image]
ActiveReports 19 .NET Edition
CreateDocumentInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentInfo Class

Glossary Item Box

The following tables list the members exposed by CreateDocumentInfo.

Public Constructors

 | Name | Description
Public Constructor | CreateDocumentInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the document.
Public Property | Success | Gets or sets a value indicating whether the creation was successful.
Public Property | Template | Gets or sets the document template.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

CreateDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CreateDocumentInfo Constructor

[image]
ActiveReports 19 .NET Edition
CreateDocumentInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentInfo Class : CreateDocumentInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CreateDocumentInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Class
CreateDocumentInfo Members


CreateDocumentInfo Class Properties

[image]
ActiveReports 19 .NET Edition
CreateDocumentInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentInfo Class

Glossary Item Box

For a list of all members of this type, see CreateDocumentInfo members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the document.
Public Property | Success | Gets or sets a value indicating whether the creation was successful.
Public Property | Template | Gets or sets the document template.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

CreateDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentInfo Class : Name Property

Glossary Item Box

Gets or sets the name of the document.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Class
CreateDocumentInfo Members


Success Property

[image]
ActiveReports 19 .NET Edition
Success Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentInfo Class : Success Property

Glossary Item Box

Gets or sets a value indicating whether the creation was successful.

Syntax

Visual Basic (Declaration)
Public Property Success As Nullable(Of Boolean)
C#
public Nullable<bool> Success {get; set;}

Remarks

Null in OnBefore handlers should be defined in OnAfter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Class
CreateDocumentInfo Members


Template Property

[image]
ActiveReports 19 .NET Edition
Template Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentInfo Class : Template Property

Glossary Item Box

Gets or sets the document template.

Syntax

Visual Basic (Declaration)
Public Property Template As DocumentTemplate
C#
public DocumentTemplate Template {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Class
CreateDocumentInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentInfo Class : Type Property

Glossary Item Box

Gets or sets the document type.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentInfo Class
CreateDocumentInfo Members


CreateDocumentOptions Class

[image]
ActiveReports 19 .NET Edition
CreateDocumentOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentOptions Class

Glossary Item Box

Represents an options for creating a new document.

Object Model

CreateDocumentOptions Class

Syntax

Visual Basic (Declaration)
Public Class CreateDocumentOptions
C#
public class CreateDocumentOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.CreateDocumentOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


CreateDocumentOptions Class Members

[image]
ActiveReports 19 .NET Edition
CreateDocumentOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentOptions Class

Glossary Item Box

The following tables list the members exposed by CreateDocumentOptions.

Public Constructors

 | Name | Description
Public Constructor | CreateDocumentOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSetsInfo | Gets or sets a list of RDL Data Sets to use with the template.
Public Property | Name | Gets or sets the name of the document.
Public Property | Template | Gets or sets the template to use for the document.
Public Property | Type | Gets or sets the type of the document to create.
Top

See Also

Reference

CreateDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CreateDocumentOptions Constructor

[image]
ActiveReports 19 .NET Edition
CreateDocumentOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentOptions Class : CreateDocumentOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CreateDocumentOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Class
CreateDocumentOptions Members


CreateDocumentOptions Class Properties

[image]
ActiveReports 19 .NET Edition
CreateDocumentOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CreateDocumentOptions Class

Glossary Item Box

For a list of all members of this type, see CreateDocumentOptions members.

Public Properties

 | Name | Description
Public Property | DataSetsInfo | Gets or sets a list of RDL Data Sets to use with the template.
Public Property | Name | Gets or sets the name of the document.
Public Property | Template | Gets or sets the template to use for the document.
Public Property | Type | Gets or sets the type of the document to create.
Top

See Also

Reference

CreateDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSetsInfo Property

[image]
ActiveReports 19 .NET Edition
DataSetsInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentOptions Class : DataSetsInfo Property

Glossary Item Box

Gets or sets a list of RDL Data Sets to use with the template.

Syntax

Visual Basic (Declaration)
Public Property DataSetsInfo As DataSetsInfo()
C#
public DataSetsInfo[] DataSetsInfo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Class
CreateDocumentOptions Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentOptions Class : Name Property

Glossary Item Box

Gets or sets the name of the document.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Remarks

If not specified, the default 'Untitled' name will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Class
CreateDocumentOptions Members


Template Property

[image]
ActiveReports 19 .NET Edition
Template Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentOptions Class : Template Property

Glossary Item Box

Gets or sets the template to use for the document.

Syntax

Visual Basic (Declaration)
Public Property Template As DocumentTemplate
C#
public DocumentTemplate Template {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Class
CreateDocumentOptions Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CreateDocumentOptions Class : Type Property

Glossary Item Box

Gets or sets the type of the document to create.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Remarks

If not specified, an RDL report will be created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CreateDocumentOptions Class
CreateDocumentOptions Members


CurrentDocumentInfo Class

[image]
ActiveReports 19 .NET Edition
CurrentDocumentInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CurrentDocumentInfo Class

Glossary Item Box

Represents the information about the currently open document.

Object Model

CurrentDocumentInfo Class

Syntax

Visual Basic (Declaration)
Public Class CurrentDocumentInfo
C#
public class CurrentDocumentInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.CurrentDocumentInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CurrentDocumentInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


CurrentDocumentInfo Class Members

[image]
ActiveReports 19 .NET Edition
CurrentDocumentInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CurrentDocumentInfo Class

Glossary Item Box

The following tables list the members exposed by CurrentDocumentInfo.

Public Constructors

 | Name | Description
Public Constructor | CurrentDocumentInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

CurrentDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CurrentDocumentInfo Constructor

[image]
ActiveReports 19 .NET Edition
CurrentDocumentInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CurrentDocumentInfo Class : CurrentDocumentInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CurrentDocumentInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CurrentDocumentInfo Class
CurrentDocumentInfo Members


CurrentDocumentInfo Class Properties

[image]
ActiveReports 19 .NET Edition
CurrentDocumentInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : CurrentDocumentInfo Class

Glossary Item Box

For a list of all members of this type, see CurrentDocumentInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the report ID.
Public Property | Name | Gets or sets the report name.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

CurrentDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CurrentDocumentInfo Class : Id Property

Glossary Item Box

Gets or sets the report ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CurrentDocumentInfo Class
CurrentDocumentInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CurrentDocumentInfo Class : Name Property

Glossary Item Box

Gets or sets the report name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CurrentDocumentInfo Class
CurrentDocumentInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > CurrentDocumentInfo Class : Type Property

Glossary Item Box

Gets or sets the document type.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CurrentDocumentInfo Class
CurrentDocumentInfo Members


Dashboard Class

[image]
ActiveReports 19 .NET Edition
Dashboard Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Dashboard Class

Glossary Item Box

Represents the settings for RDL Dashboard.

Object Model

Dashboard Class

Syntax

Visual Basic (Declaration)
Public Class Dashboard
C#
public class Dashboard

Remarks

The Dashboard class provides a property to configure the enabling of RDL Dashboard support.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Dashboard

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Dashboard Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Dashboard Class Members

[image]
ActiveReports 19 .NET Edition
Dashboard Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Dashboard Class

Glossary Item Box

The following tables list the members exposed by Dashboard.

Public Constructors

 | Name | Description
Public Constructor | Dashboard Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL Dashboard support is enabled.
Top

See Also

Reference

Dashboard Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Dashboard Constructor

[image]
ActiveReports 19 .NET Edition
Dashboard Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Dashboard Class : Dashboard Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Dashboard()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Dashboard Class
Dashboard Members


Dashboard Class Properties

[image]
ActiveReports 19 .NET Edition
Dashboard Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Dashboard Class

Glossary Item Box

For a list of all members of this type, see Dashboard members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL Dashboard support is enabled.
Top

See Also

Reference

Dashboard Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Dashboard Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether RDL Dashboard support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if RDL Dashboard support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Dashboard Class
Dashboard Members


DataSets Class

[image]
ActiveReports 19 .NET Edition
DataSets Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSets Class

Glossary Item Box

Represents the settings for the data sets section.

Object Model

DataSets Class

Syntax

Visual Basic (Declaration)
Public Class DataSets
C#
public class DataSets

Remarks

The DataSets class provides properties to configure the visibility and modification capability of data sets.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataSets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSets Class Members

[image]
ActiveReports 19 .NET Edition
DataSets Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSets Class

Glossary Item Box

The following tables list the members exposed by DataSets.

Public Constructors

 | Name | Description
Public Constructor | DataSets Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sets.
Public Property | Visible | Gets or sets a value indicating whether the Data Sets section should be shown.
Top

See Also

Reference

DataSets Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSets Constructor

[image]
ActiveReports 19 .NET Edition
DataSets Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSets Class : DataSets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSets()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Class
DataSets Members


DataSets Class Properties

[image]
ActiveReports 19 .NET Edition
DataSets Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSets Class

Glossary Item Box

For a list of all members of this type, see DataSets members.

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sets.
Public Property | Visible | Gets or sets a value indicating whether the Data Sets section should be shown.
Top

See Also

Reference

DataSets Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CanModify Property

[image]
ActiveReports 19 .NET Edition
CanModify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSets Class : CanModify Property

Glossary Item Box

Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sets.

Syntax

Visual Basic (Declaration)
Public Property CanModify As Nullable(Of Boolean)
C#
public Nullable<bool> CanModify {get; set;}

Property Value

true if data sets can be modified; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Class
DataSets Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSets Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Data Sets section should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Data Sets section should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Class
DataSets Members


DataSetsInfo Class

[image]
ActiveReports 19 .NET Edition
DataSetsInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSetsInfo Class

Glossary Item Box

Represents the information about data sets.

Object Model

DataSetsInfo Class

Syntax

Visual Basic (Declaration)
Public Class DataSetsInfo
C#
public class DataSetsInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataSetsInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetsInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSetsInfo Class Members

[image]
ActiveReports 19 .NET Edition
DataSetsInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSetsInfo Class

Glossary Item Box

The following tables list the members exposed by DataSetsInfo.

Public Constructors

 | Name | Description
Public Constructor | DataSetsInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the data set ID.
Public Property | Name | Gets or sets the data set name.
Top

See Also

Reference

DataSetsInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSetsInfo Constructor

[image]
ActiveReports 19 .NET Edition
DataSetsInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSetsInfo Class : DataSetsInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSetsInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetsInfo Class
DataSetsInfo Members


DataSetsInfo Class Properties

[image]
ActiveReports 19 .NET Edition
DataSetsInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSetsInfo Class

Glossary Item Box

For a list of all members of this type, see DataSetsInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the data set ID.
Public Property | Name | Gets or sets the data set name.
Top

See Also

Reference

DataSetsInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSetsInfo Class : Id Property

Glossary Item Box

Gets or sets the data set ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetsInfo Class
DataSetsInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSetsInfo Class : Name Property

Glossary Item Box

Gets or sets the data set name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetsInfo Class
DataSetsInfo Members


DataSettings Class

[image]
ActiveReports 19 .NET Edition
DataSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSettings Class

Glossary Item Box

Represents the settings related to data management.

Object Model

DataSettings Class

Syntax

Visual Basic (Declaration)
Public Class DataSettings
C#
public class DataSettings

Remarks

The DataSettings class provides properties to configure various aspects of data management within the application, such as data sources, data sets, parameters, and common values.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSettings Class Members

[image]
ActiveReports 19 .NET Edition
DataSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSettings Class

Glossary Item Box

The following tables list the members exposed by DataSettings.

Public Constructors

 | Name | Description
Public Constructor | DataSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CommonValues | Gets or sets the settings for the common values.
Public Property | DataSets | Gets or sets the settings for the data sets.
Public Property | DataSources | Gets or sets the settings for the data sources.
Public Property | DataTab | Gets or sets the settings for the data tab.
Public Property | Parameters | Gets or sets the settings for the parameters.
Top

See Also

Reference

DataSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSettings Constructor

[image]
ActiveReports 19 .NET Edition
DataSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : DataSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


DataSettings Class Properties

[image]
ActiveReports 19 .NET Edition
DataSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSettings Class

Glossary Item Box

For a list of all members of this type, see DataSettings members.

Public Properties

 | Name | Description
Public Property | CommonValues | Gets or sets the settings for the common values.
Public Property | DataSets | Gets or sets the settings for the data sets.
Public Property | DataSources | Gets or sets the settings for the data sources.
Public Property | DataTab | Gets or sets the settings for the data tab.
Public Property | Parameters | Gets or sets the settings for the parameters.
Top

See Also

Reference

DataSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CommonValues Property

[image]
ActiveReports 19 .NET Edition
CommonValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : CommonValues Property

Glossary Item Box

Gets or sets the settings for the common values.

Syntax

Visual Basic (Declaration)
Public Property CommonValues As CommonValues
C#
public CommonValues CommonValues {get; set;}

Property Value

An instance of CommonValues that contains the settings for the common values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


DataSets Property

[image]
ActiveReports 19 .NET Edition
DataSets Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : DataSets Property

Glossary Item Box

Gets or sets the settings for the data sets.

Syntax

Visual Basic (Declaration)
Public Property DataSets As DataSets
C#
public DataSets DataSets {get; set;}

Property Value

An instance of DataSets that contains the settings for the data sets.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


DataSources Property

[image]
ActiveReports 19 .NET Edition
DataSources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : DataSources Property

Glossary Item Box

Gets or sets the settings for the data sources.

Syntax

Visual Basic (Declaration)
Public Property DataSources As DataSources
C#
public DataSources DataSources {get; set;}

Property Value

An instance of DataSources that contains the settings for the data sources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


DataTab Property

[image]
ActiveReports 19 .NET Edition
DataTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : DataTab Property

Glossary Item Box

Gets or sets the settings for the data tab.

Syntax

Visual Basic (Declaration)
Public Property DataTab As DataTab
C#
public DataTab DataTab {get; set;}

Property Value

An instance of DataTab that contains the settings for the data tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSettings Class : Parameters Property

Glossary Item Box

Gets or sets the settings for the parameters.

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameters
C#
public Parameters Parameters {get; set;}

Property Value

An instance of Parameters that contains the settings for the parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSettings Class
DataSettings Members


DataSources Class

[image]
ActiveReports 19 .NET Edition
DataSources Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSources Class

Glossary Item Box

Represents the settings for the data sources.

Object Model

DataSources Class

Syntax

Visual Basic (Declaration)
Public Class DataSources
C#
public class DataSources

Remarks

The DataSources class provides properties to configure the visibility, modification capability, and options for data sources.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataSources

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSources Class Members

[image]
ActiveReports 19 .NET Edition
DataSources Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSources Class

Glossary Item Box

The following tables list the members exposed by DataSources.

Public Constructors

 | Name | Description
Public Constructor | DataSources Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sources.
Public Property | Options | Gets or sets the options for data sources and the data source editor.
Public Property | Shared | Gets or sets the options for shared data sources.
Public Property | Visible | Gets or sets a value indicating whether the Data Sources section should be shown.
Top

See Also

Reference

DataSources Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSources Constructor

[image]
ActiveReports 19 .NET Edition
DataSources Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSources Class : DataSources Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


DataSources Class Properties

[image]
ActiveReports 19 .NET Edition
DataSources Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSources Class

Glossary Item Box

For a list of all members of this type, see DataSources members.

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sources.
Public Property | Options | Gets or sets the options for data sources and the data source editor.
Public Property | Shared | Gets or sets the options for shared data sources.
Public Property | Visible | Gets or sets a value indicating whether the Data Sources section should be shown.
Top

See Also

Reference

DataSources Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CanModify Property

[image]
ActiveReports 19 .NET Edition
CanModify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSources Class : CanModify Property

Glossary Item Box

Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) data sources.

Syntax

Visual Basic (Declaration)
Public Property CanModify As Nullable(Of Boolean)
C#
public Nullable<bool> CanModify {get; set;}

Property Value

true if data sources can be modified; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


Options Property

[image]
ActiveReports 19 .NET Edition
Options Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSources Class : Options Property

Glossary Item Box

Gets or sets the options for data sources and the data source editor.

Syntax

Visual Basic (Declaration)
Public Property Options As DataSourcesOptions
C#
public DataSourcesOptions Options {get; set;}

Property Value

An instance of DataSourcesOptions that contains the options for data sources and the data source editor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


Shared Property

[image]
ActiveReports 19 .NET Edition
Shared Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSources Class : Shared Property

Glossary Item Box

Gets or sets the options for shared data sources.

Syntax

Visual Basic (Declaration)
Public Property Shared As SharedDataSourceOptions
C#
public SharedDataSourceOptions Shared {get; set;}

Property Value

An instance of SharedDataSourceOptions that contains the options for shared data sources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSources Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Data Sources section should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Data Sources section should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


DataSourcesOptions Class

[image]
ActiveReports 19 .NET Edition
DataSourcesOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSourcesOptions Class

Glossary Item Box

Represents the options for data sources and the data source editor.

Object Model

DataSourcesOptions Class

Syntax

Visual Basic (Declaration)
Public Class DataSourcesOptions
C#
public class DataSourcesOptions

Remarks

The DataSourcesOptions class provides properties to configure the predefined providers, OLE DB providers, and custom providers available in the data source editor.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataSourcesOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcesOptions Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSourcesOptions Class Members

[image]
ActiveReports 19 .NET Edition
DataSourcesOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSourcesOptions Class

Glossary Item Box

The following tables list the members exposed by DataSourcesOptions.

Public Constructors

 | Name | Description
Public Constructor | DataSourcesOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | CustomProviders | Gets or sets the list of custom data providers available in the data source editor.
Public Property | OleDbProviders | Gets or sets the list of OLE DB providers available in the data source editor.
Public Property | PredefinedProviders | Gets or sets the list of predefined data providers available in the data source editor.
Top

See Also

Reference

DataSourcesOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataSourcesOptions Constructor

[image]
ActiveReports 19 .NET Edition
DataSourcesOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSourcesOptions Class : DataSourcesOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSourcesOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcesOptions Class
DataSourcesOptions Members


DataSourcesOptions Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourcesOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataSourcesOptions Class

Glossary Item Box

For a list of all members of this type, see DataSourcesOptions members.

Public Properties

 | Name | Description
Public Property | CustomProviders | Gets or sets the list of custom data providers available in the data source editor.
Public Property | OleDbProviders | Gets or sets the list of OLE DB providers available in the data source editor.
Public Property | PredefinedProviders | Gets or sets the list of predefined data providers available in the data source editor.
Top

See Also

Reference

DataSourcesOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CustomProviders Property

[image]
ActiveReports 19 .NET Edition
CustomProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSourcesOptions Class : CustomProviders Property

Glossary Item Box

Gets or sets the list of custom data providers available in the data source editor.

Syntax

Visual Basic (Declaration)
Public Property CustomProviders As Dictionary(Of String,String)
C#
public Dictionary<string,string> CustomProviders {get; set;}

Property Value

A dictionary where keys are data provider identifiers and values are data provider labels.

Remarks

The key - data provider identifier. The value - data provider label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcesOptions Class
DataSourcesOptions Members


OleDbProviders Property

[image]
ActiveReports 19 .NET Edition
OleDbProviders Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSourcesOptions Class : OleDbProviders Property

Glossary Item Box

Gets or sets the list of OLE DB providers available in the data source editor.

Syntax

Visual Basic (Declaration)
Public Property OleDbProviders As String()
C#
public string[] OleDbProviders {get; set;}

Property Value

An array of System.String representing the OLE DB providers.

Example

C# Copy Code
new[] {"SQLOLEDB.1", "Microsoft.Jet.OLEDB.4.0"},

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcesOptions Class
DataSourcesOptions Members


PredefinedProviders Property

[image]
ActiveReports 19 .NET Edition
PredefinedProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataSourcesOptions Class : PredefinedProviders Property

Glossary Item Box

Gets or sets the list of predefined data providers available in the data source editor.

Syntax

Visual Basic (Declaration)
Public Property PredefinedProviders As Providers()
C#
public Providers[] PredefinedProviders {get; set;}

Property Value

An array of Providers representing the predefined data providers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcesOptions Class
DataSourcesOptions Members


DataTab Class

[image]
ActiveReports 19 .NET Edition
DataTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataTab Class

Glossary Item Box

Represents the settings for the data tab.

Object Model

DataTab Class

Syntax

Visual Basic (Declaration)
Public Class DataTab
C#
public class DataTab

Remarks

The DataTab class provides a property to configure the visibility of the data tab.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DataTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataTab Class Members

[image]
ActiveReports 19 .NET Edition
DataTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataTab Class

Glossary Item Box

The following tables list the members exposed by DataTab.

Public Constructors

 | Name | Description
Public Constructor | DataTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the data tab should be shown.
Top

See Also

Reference

DataTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DataTab Constructor

[image]
ActiveReports 19 .NET Edition
DataTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataTab Class : DataTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTab Class
DataTab Members


DataTab Class Properties

[image]
ActiveReports 19 .NET Edition
DataTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DataTab Class

Glossary Item Box

For a list of all members of this type, see DataTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the data tab should be shown.
Top

See Also

Reference

DataTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DataTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the data tab should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the data tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTab Class
DataTab Members


DesignerSettings Class

[image]
ActiveReports 19 .NET Edition
DesignerSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DesignerSettings Class

Glossary Item Box

Represents the initialization settings for the Designer.

Object Model

DesignerSettings Class

Syntax

Visual Basic (Declaration)
Public Class DesignerSettings
C#
public class DesignerSettings

Remarks

The DesignerSettings class provides properties to configure various aspects of the Designer's appearance and behavior.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DesignerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DesignerSettings Class Members

[image]
ActiveReports 19 .NET Edition
DesignerSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DesignerSettings Class

Glossary Item Box

The following tables list the members exposed by DesignerSettings.

Public Constructors

 | Name | Description
Public Constructor | DesignerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppBar | Gets or sets the settings for the App Bar, providing quick access to common actions and controls.
Public Property | Data | Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.
Public Property | DateFormats | Gets or sets the list of supported date formats.
Public Property | DisableFocusTimer | Gets or sets a value indicating whether focused elements (like buttons) are permanently highlighted.
Public Property | DisableSystemClipboard | Gets or sets a value indicating whether to disable the usage of the system clipboard.
Public Property | Document | Gets or sets the document to open on app startup. If not set, a new empty document will be created.
Public Property | Documents | Gets or sets the settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.
Public Property | Fonts | Gets or sets the list of fonts displayed in Font property editors all over Designer.
Public Property | ImageMimeTypes | Gets or sets the list of supported image mime-types.
Public Property | Language | Gets or sets the language to use for the Designer.
Public Property | LockLayout | Gets or sets a value indicating whether LockLayout is enabled, which restricts modifications to the properties of existing report items only.
Public Property | Menu | Gets or sets the settings for the Main Menu, providing access to various features and tools.
Public Property | Preview | Gets or sets the settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.
Public Property | PropertyGrid | Gets or sets the settings for the Property Grid, allowing users to view and edit properties of selected objects.
Public Property | Rdlx | Gets or sets the RDLX platform-specific settings.
Public Property | Rpx | Gets or sets the RPX platform-specific settings.
Public Property | Server | Gets or sets the settings related to the backend server, including the base URL and request modification handlers.
Public Property | StatusBar | Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.
Public Property | StoreUnsavedReport | Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.
Public Property | StoreUserPreferences | Gets or sets a value indicating whether user preferences will be saved to browser storage.
Public Property | Styles | Gets or sets the RPX Styles-related settings.
Public Property | Themes | Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.
Public Property | Title | Gets or sets the settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.
Public Property | ToolBar | Gets or sets the settings for the Tool Bar.
Public Property | Units | Gets or sets the default measurement units.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DesignerSettings Constructor

[image]
ActiveReports 19 .NET Edition
DesignerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : DesignerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DesignerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DesignerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
DesignerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DesignerSettings Class

Glossary Item Box

For a list of all members of this type, see DesignerSettings members.

Public Properties

 | Name | Description
Public Property | AppBar | Gets or sets the settings for the App Bar, providing quick access to common actions and controls.
Public Property | Data | Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.
Public Property | DateFormats | Gets or sets the list of supported date formats.
Public Property | DisableFocusTimer | Gets or sets a value indicating whether focused elements (like buttons) are permanently highlighted.
Public Property | DisableSystemClipboard | Gets or sets a value indicating whether to disable the usage of the system clipboard.
Public Property | Document | Gets or sets the document to open on app startup. If not set, a new empty document will be created.
Public Property | Documents | Gets or sets the settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.
Public Property | Fonts | Gets or sets the list of fonts displayed in Font property editors all over Designer.
Public Property | ImageMimeTypes | Gets or sets the list of supported image mime-types.
Public Property | Language | Gets or sets the language to use for the Designer.
Public Property | LockLayout | Gets or sets a value indicating whether LockLayout is enabled, which restricts modifications to the properties of existing report items only.
Public Property | Menu | Gets or sets the settings for the Main Menu, providing access to various features and tools.
Public Property | Preview | Gets or sets the settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.
Public Property | PropertyGrid | Gets or sets the settings for the Property Grid, allowing users to view and edit properties of selected objects.
Public Property | Rdlx | Gets or sets the RDLX platform-specific settings.
Public Property | Rpx | Gets or sets the RPX platform-specific settings.
Public Property | Server | Gets or sets the settings related to the backend server, including the base URL and request modification handlers.
Public Property | StatusBar | Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.
Public Property | StoreUnsavedReport | Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.
Public Property | StoreUserPreferences | Gets or sets a value indicating whether user preferences will be saved to browser storage.
Public Property | Styles | Gets or sets the RPX Styles-related settings.
Public Property | Themes | Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.
Public Property | Title | Gets or sets the settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.
Public Property | ToolBar | Gets or sets the settings for the Tool Bar.
Public Property | Units | Gets or sets the default measurement units.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AppBar Property

[image]
ActiveReports 19 .NET Edition
AppBar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : AppBar Property

Glossary Item Box

Gets or sets the settings for the App Bar, providing quick access to common actions and controls.

Syntax

Visual Basic (Declaration)
Public Property AppBar As AppBarSettings
C#
public AppBarSettings AppBar {get; set;}

Property Value

An instance of AppBarSettings representing the App Bar settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Data Property

Glossary Item Box

Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.

Syntax

Visual Basic (Declaration)
Public Property Data As DataSettings
C#
public DataSettings Data {get; set;}

Property Value

An instance of DataSettings representing the data management settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DateFormats Property

[image]
ActiveReports 19 .NET Edition
DateFormats Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : DateFormats Property

Glossary Item Box

Gets or sets the list of supported date formats.

Syntax

Visual Basic (Declaration)
Public Property DateFormats As String()
C#
public string[] DateFormats {get; set;}

Property Value

An array of System.String representing supported date formats.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DisableFocusTimer Property

[image]
ActiveReports 19 .NET Edition
DisableFocusTimer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : DisableFocusTimer Property

Glossary Item Box

Gets or sets a value indicating whether focused elements (like buttons) are permanently highlighted.

Syntax

Visual Basic (Declaration)
Public Property DisableFocusTimer As Nullable(Of Boolean)
C#
public Nullable<bool> DisableFocusTimer {get; set;}

Property Value

true if focused elements should be permanently highlighted; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DisableSystemClipboard Property

[image]
ActiveReports 19 .NET Edition
DisableSystemClipboard Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : DisableSystemClipboard Property

Glossary Item Box

Gets or sets a value indicating whether to disable the usage of the system clipboard.

Syntax

Visual Basic (Declaration)
Public Property DisableSystemClipboard As Nullable(Of Boolean)
C#
public Nullable<bool> DisableSystemClipboard {get; set;}

Property Value

true if the system clipboard usage should be disabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Document Property

Glossary Item Box

Gets or sets the document to open on app startup. If not set, a new empty document will be created.

Syntax

Visual Basic (Declaration)
Public Property Document As Document
C#
public Document Document {get; set;}

Property Value

An instance of Document representing the document to open on app startup.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Documents Property

[image]
ActiveReports 19 .NET Edition
Documents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Documents Property

Glossary Item Box

Gets or sets the settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.

Syntax

Visual Basic (Declaration)
Public Property Documents As DocumentsSettings
C#
public DocumentsSettings Documents {get; set;}

Property Value

An instance of DocumentsSettings representing the documents settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Fonts Property

Glossary Item Box

Gets or sets the list of fonts displayed in Font property editors all over Designer.

Syntax

Visual Basic (Declaration)
Public Property Fonts As Object()
C#
public object[] Fonts {get; set;}

Property Value

An array of objects representing fonts or font headers.

Remarks

It should be Font or FontHeader.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


ImageMimeTypes Property

[image]
ActiveReports 19 .NET Edition
ImageMimeTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : ImageMimeTypes Property

Glossary Item Box

Gets or sets the list of supported image mime-types.

Syntax

Visual Basic (Declaration)
Public Property ImageMimeTypes As String()
C#
public string[] ImageMimeTypes {get; set;}

Property Value

An array of System.String representing supported image mime-types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Language Property

Glossary Item Box

Gets or sets the language to use for the Designer.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Property Value

The language as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


LockLayout Property

[image]
ActiveReports 19 .NET Edition
LockLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : LockLayout Property

Glossary Item Box

Gets or sets a value indicating whether LockLayout is enabled, which restricts modifications to the properties of existing report items only.

Syntax

Visual Basic (Declaration)
Public Property LockLayout As Nullable(Of Boolean)
C#
public Nullable<bool> LockLayout {get; set;}

Property Value

true if LockLayout is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Menu Property

[image]
ActiveReports 19 .NET Edition
Menu Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Menu Property

Glossary Item Box

Gets or sets the settings for the Main Menu, providing access to various features and tools.

Syntax

Visual Basic (Declaration)
Public Property Menu As MenuSettings
C#
public MenuSettings Menu {get; set;}

Property Value

An instance of MenuSettings representing the Main Menu settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Preview Property

[image]
ActiveReports 19 .NET Edition
Preview Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Preview Property

Glossary Item Box

Gets or sets the settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.

Syntax

Visual Basic (Declaration)
Public Property Preview As PreviewSettings
C#
public PreviewSettings Preview {get; set;}

Property Value

An instance of PreviewSettings representing the preview settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


PropertyGrid Property

[image]
ActiveReports 19 .NET Edition
PropertyGrid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : PropertyGrid Property

Glossary Item Box

Gets or sets the settings for the Property Grid, allowing users to view and edit properties of selected objects.

Syntax

Visual Basic (Declaration)
Public Property PropertyGrid As PropertyGridSettings
C#
public PropertyGridSettings PropertyGrid {get; set;}

Property Value

An instance of PropertyGridSettings representing the Property Grid settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Rdlx Property

[image]
ActiveReports 19 .NET Edition
Rdlx Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Rdlx Property

Glossary Item Box

Gets or sets the RDLX platform-specific settings.

Syntax

Visual Basic (Declaration)
Public Property Rdlx As RdlxSettings
C#
public RdlxSettings Rdlx {get; set;}

Property Value

An instance of RdlxSettings representing the RDLX platform-specific settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Rpx Property

[image]
ActiveReports 19 .NET Edition
Rpx Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Rpx Property

Glossary Item Box

Gets or sets the RPX platform-specific settings.

Syntax

Visual Basic (Declaration)
Public Property Rpx As RpxSettings
C#
public RpxSettings Rpx {get; set;}

Property Value

An instance of RpxSettings representing the RPX platform-specific settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Server Property

[image]
ActiveReports 19 .NET Edition
Server Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Server Property

Glossary Item Box

Gets or sets the settings related to the backend server, including the base URL and request modification handlers.

Syntax

Visual Basic (Declaration)
Public Property Server As ServerSettings
C#
public ServerSettings Server {get; set;}

Property Value

An instance of ServerSettings representing the server settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


StatusBar Property

[image]
ActiveReports 19 .NET Edition
StatusBar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : StatusBar Property

Glossary Item Box

Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.

Syntax

Visual Basic (Declaration)
Public Property StatusBar As StatusBarSettings
C#
public StatusBarSettings StatusBar {get; set;}

Property Value

An instance of StatusBarSettings representing the Status Bar settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


StoreUnsavedReport Property

[image]
ActiveReports 19 .NET Edition
StoreUnsavedReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : StoreUnsavedReport Property

Glossary Item Box

Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.

Syntax

Visual Basic (Declaration)
Public Property StoreUnsavedReport As Nullable(Of Boolean)
C#
public Nullable<bool> StoreUnsavedReport {get; set;}

Property Value

true if the last unsaved report can be restored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


StoreUserPreferences Property

[image]
ActiveReports 19 .NET Edition
StoreUserPreferences Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : StoreUserPreferences Property

Glossary Item Box

Gets or sets a value indicating whether user preferences will be saved to browser storage.

Syntax

Visual Basic (Declaration)
Public Property StoreUserPreferences As Nullable(Of Boolean)
C#
public Nullable<bool> StoreUserPreferences {get; set;}

Property Value

true if user preferences should be saved; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Styles Property

[image]
ActiveReports 19 .NET Edition
Styles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Styles Property

Glossary Item Box

Gets or sets the RPX Styles-related settings.

Syntax

Visual Basic (Declaration)
Public Property Styles As StylesSettings
C#
public StylesSettings Styles {get; set;}

Property Value

An instance of StylesSettings representing the RPX styles settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Themes Property

Glossary Item Box

Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.

Syntax

Visual Basic (Declaration)
Public Property Themes As ThemeSettings
C#
public ThemeSettings Themes {get; set;}

Property Value

An instance of GrapeCity.ActiveReports.Blazor.Viewer.ThemeSettings that contains the theme settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Title Property

Glossary Item Box

Gets or sets the settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.

Syntax

Visual Basic (Declaration)
Public Property Title As TitleSettings
C#
public TitleSettings Title {get; set;}

Property Value

An instance of TitleSettings representing the title settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


ToolBar Property

[image]
ActiveReports 19 .NET Edition
ToolBar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : ToolBar Property

Glossary Item Box

Gets or sets the settings for the Tool Bar.

Syntax

Visual Basic (Declaration)
Public Property ToolBar As ToolBarSettings
C#
public ToolBarSettings ToolBar {get; set;}

Property Value

An instance of ToolBarSettings representing the Tool Bar settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Units Property

[image]
ActiveReports 19 .NET Edition
Units Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DesignerSettings Class : Units Property

Glossary Item Box

Gets or sets the default measurement units.

Syntax

Visual Basic (Declaration)
Public Property Units As Nullable(Of Units)
C#
public Nullable<Units> Units {get; set;}

Property Value

The measurement units as a nullable Units.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


Details Class

[image]
ActiveReports 19 .NET Edition
Details Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Details Class

Glossary Item Box

Represents the style content for the details section of a table report item.

Object Model

Details Class

Syntax

Visual Basic (Declaration)
Public Class Details
C#
public class Details

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Details

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Details Class Members

[image]
ActiveReports 19 .NET Edition
Details Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Details Class

Glossary Item Box

The following tables list the members exposed by Details.

Public Constructors

 | Name | Description
Public Constructor | Details Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlternatingExpression | Gets or sets the alternating expression for the details section.
Public Property | Rows | Gets or sets the rows style content of the details section.
Top

See Also

Reference

Details Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Details Constructor

[image]
ActiveReports 19 .NET Edition
Details Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Details Class : Details Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Details()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Details Class Properties

[image]
ActiveReports 19 .NET Edition
Details Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Details Class

Glossary Item Box

For a list of all members of this type, see Details members.

Public Properties

 | Name | Description
Public Property | AlternatingExpression | Gets or sets the alternating expression for the details section.
Public Property | Rows | Gets or sets the rows style content of the details section.
Top

See Also

Reference

Details Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AlternatingExpression Property

[image]
ActiveReports 19 .NET Edition
AlternatingExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Details Class : AlternatingExpression Property

Glossary Item Box

Gets or sets the alternating expression for the details section.

Syntax

Visual Basic (Declaration)
Public Property AlternatingExpression As String
C#
public string AlternatingExpression {get; set;}

Property Value

The alternating expression as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Details Class : Rows Property

Glossary Item Box

Gets or sets the rows style content of the details section.

Syntax

Visual Basic (Declaration)
Public Property Rows As CellStyleContent()
C#
public CellStyleContent[] Rows {get; set;}

Property Value

An array of CellStyleContent representing the rows style content of the details section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Document Class

[image]
ActiveReports 19 .NET Edition
Document Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Document Class

Glossary Item Box

Represents a document to open on app startup.

Object Model

Document Class

Syntax

Visual Basic (Declaration)
Public Class Document
C#
public class Document

Remarks

The Document class provides properties to configure the ID and type of the document to open on app startup. If not set, a new empty document will be created.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Document Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Document Class Members

[image]
ActiveReports 19 .NET Edition
Document Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Document Class

Glossary Item Box

The following tables list the members exposed by Document.

Public Constructors

 | Name | Description
Public Constructor | Document Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the document.
Public Property | Type | Gets or sets the type of documents supported by the AR Web Designer.
Top

See Also

Reference

Document Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Document Constructor

[image]
ActiveReports 19 .NET Edition
Document Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Document Class : Document Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Document()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Document Class
Document Members


Document Class Properties

[image]
ActiveReports 19 .NET Edition
Document Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Document Class

Glossary Item Box

For a list of all members of this type, see Document members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the document.
Public Property | Type | Gets or sets the type of documents supported by the AR Web Designer.
Top

See Also

Reference

Document Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Document Class : Id Property

Glossary Item Box

Gets or sets the ID of the document.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

The ID of the document as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Document Class
Document Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Document Class : Type Property

Glossary Item Box

Gets or sets the type of documents supported by the AR Web Designer.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Property Value

The type of the document as a nullable SupportedDocumentType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Document Class
Document Members


DocumentExplorer Class

[image]
ActiveReports 19 .NET Edition
DocumentExplorer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentExplorer Class

Glossary Item Box

Represents the Document Explorer settings.

Object Model

DocumentExplorer Class

Syntax

Visual Basic (Declaration)
Public Class DocumentExplorer
C#
public class DocumentExplorer

Remarks

The DocumentExplorer class provides a property to configure the visibility of the Document Explorer button.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DocumentExplorer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentExplorer Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentExplorer Class Members

[image]
ActiveReports 19 .NET Edition
DocumentExplorer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentExplorer Class

Glossary Item Box

The following tables list the members exposed by DocumentExplorer.

Public Constructors

 | Name | Description
Public Constructor | DocumentExplorer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Document Explorer button should be shown.
Top

See Also

Reference

DocumentExplorer Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentExplorer Constructor

[image]
ActiveReports 19 .NET Edition
DocumentExplorer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentExplorer Class : DocumentExplorer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentExplorer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentExplorer Class
DocumentExplorer Members


DocumentExplorer Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentExplorer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentExplorer Class

Glossary Item Box

For a list of all members of this type, see DocumentExplorer members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Document Explorer button should be shown.
Top

See Also

Reference

DocumentExplorer Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentExplorer Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Document Explorer button should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Document Explorer button should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentExplorer Class
DocumentExplorer Members


Documents Class

[image]
ActiveReports 19 .NET Edition
Documents Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Documents Class

Glossary Item Box

Represents methods for managing documents, allowing the creation, opening, saving, and status checking of reports being edited.

Object Model

Documents Class

Syntax

Visual Basic (Declaration)
Public Class Documents
C#
public class Documents

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Documents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Documents Class Members

[image]
ActiveReports 19 .NET Edition
Documents Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Documents Class

Glossary Item Box

The following tables list the members exposed by Documents.

Public Methods

 | Name | Description
Public Method | Create | Creates a new report to be edited in Designer using the specified CreateDocumentOptions object.
Public Method | HasUnsavedChanges | Indicates whether the report has unsaved changes.
Public Method | Info | Returns information about the currently edited report.
Public Method | IsNew | Indicates whether the report was saved at least once before.
Public Method | Open | Shows the open report dialog.
Public Method | OpenById | Opens an existing report to be edited in Designer with the specified id. Optionally, pass name and content; otherwise, it will be loaded from the server.
Public Method | Save | Saves the report currently edited in Designer. If the report is new, the "Save As" dialog will be opened.
Public Method | SaveAs | Opens the "Save As" dialog.
Public Method | SaveById | Saves the report currently edited in Designer using the specified id.
Public Method | SaveByName | Saves the report currently edited in Designer using the specified name.
Top

See Also

Reference

Documents Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Documents Class Methods

[image]
ActiveReports 19 .NET Edition
Documents Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Documents Class

Glossary Item Box

For a list of all members of this type, see Documents members.

Public Methods

 | Name | Description
Public Method | Create | Creates a new report to be edited in Designer using the specified CreateDocumentOptions object.
Public Method | HasUnsavedChanges | Indicates whether the report has unsaved changes.
Public Method | Info | Returns information about the currently edited report.
Public Method | IsNew | Indicates whether the report was saved at least once before.
Public Method | Open | Shows the open report dialog.
Public Method | OpenById | Opens an existing report to be edited in Designer with the specified id. Optionally, pass name and content; otherwise, it will be loaded from the server.
Public Method | Save | Saves the report currently edited in Designer. If the report is new, the "Save As" dialog will be opened.
Public Method | SaveAs | Opens the "Save As" dialog.
Public Method | SaveById | Saves the report currently edited in Designer using the specified id.
Public Method | SaveByName | Saves the report currently edited in Designer using the specified name.
Top

See Also

Reference

Documents Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : Create Method

options
Options for creating the document.

Glossary Item Box

Creates a new report to be edited in Designer using the specified CreateDocumentOptions object.

Syntax

Visual Basic (Declaration)
Public Function Create( _
   ByVal options As CreateDocumentOptions _
) As ValueTask(Of CreateDocumentInfo)
C#
public ValueTask<CreateDocumentInfo> Create(
   CreateDocumentOptions options
)

Parameters

options
Options for creating the document.

Return Value

A ValueTask representing the asynchronous operation of creating the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


HasUnsavedChanges Method

[image]
ActiveReports 19 .NET Edition
HasUnsavedChanges Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : HasUnsavedChanges Method

Glossary Item Box

Indicates whether the report has unsaved changes.

Syntax

Visual Basic (Declaration)
Public Function HasUnsavedChanges() As ValueTask(Of Boolean)
C#
public ValueTask<bool> HasUnsavedChanges()

Return Value

A ValueTask representing the asynchronous operation of checking if there are unsaved changes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


Info Method

[image]
ActiveReports 19 .NET Edition
Info Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : Info Method

Glossary Item Box

Returns information about the currently edited report.

Syntax

Visual Basic (Declaration)
Public Function Info() As ValueTask(Of CurrentDocumentInfo)
C#
public ValueTask<CurrentDocumentInfo> Info()

Return Value

A ValueTask representing the asynchronous operation of retrieving the current document info.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


IsNew Method

[image]
ActiveReports 19 .NET Edition
IsNew Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : IsNew Method

Glossary Item Box

Indicates whether the report was saved at least once before.

Syntax

Visual Basic (Declaration)
Public Function IsNew() As ValueTask(Of Boolean)
C#
public ValueTask<bool> IsNew()

Return Value

A ValueTask representing the asynchronous operation of checking if the report is new.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


Open Method

[image]
ActiveReports 19 .NET Edition
Open Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : Open Method

Glossary Item Box

Shows the open report dialog.

Syntax

Visual Basic (Declaration)
Public Function Open() As Task
C#
public Task Open()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of opening the report dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


OpenById Method

[image]
ActiveReports 19 .NET Edition
OpenById Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : OpenById Method

id
The report ID.
type
The document type.
name
The report name (optional).
content
The report content (optional).

Glossary Item Box

Opens an existing report to be edited in Designer with the specified id. Optionally, pass name and content; otherwise, it will be loaded from the server.

Syntax

Visual Basic (Declaration)
Public Function OpenById( _
   ByVal id As String, _
   ByVal type As SupportedDocumentType, _
   Optional ByVal name As String, _
   Optional ByVal content As String _
) As ValueTask(Of OpenDocumentInfo)
C#
public ValueTask<OpenDocumentInfo> OpenById(
   string id,
   SupportedDocumentType type,
   string name,
   string content
)

Parameters

id
The report ID.
type
The document type.
name
The report name (optional).
content
The report content (optional).

Return Value

A ValueTask representing the asynchronous operation of opening the document by ID.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : Save Method

Glossary Item Box

Saves the report currently edited in Designer. If the report is new, the "Save As" dialog will be opened.

Syntax

Visual Basic (Declaration)
Public Function Save() As Task
C#
public Task Save()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of saving the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


SaveAs Method

[image]
ActiveReports 19 .NET Edition
SaveAs Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : SaveAs Method

Glossary Item Box

Opens the "Save As" dialog.

Syntax

Visual Basic (Declaration)
Public Function SaveAs() As Task
C#
public Task SaveAs()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of opening the "Save As" dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


SaveById Method

[image]
ActiveReports 19 .NET Edition
SaveById Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : SaveById Method

id
The report ID.
name
The report name (optional).

Glossary Item Box

Saves the report currently edited in Designer using the specified id.

Syntax

Visual Basic (Declaration)
Public Function SaveById( _
   ByVal id As String, _
   Optional ByVal name As String _
) As ValueTask(Of SaveDocumentInfo)
C#
public ValueTask<SaveDocumentInfo> SaveById(
   string id,
   string name
)

Parameters

id
The report ID.
name
The report name (optional).

Return Value

A ValueTask representing the asynchronous operation of saving the document by ID.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


SaveByName Method

[image]
ActiveReports 19 .NET Edition
SaveByName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Documents Class : SaveByName Method

name
The report name.

Glossary Item Box

Saves the report currently edited in Designer using the specified name.

Syntax

Visual Basic (Declaration)
Public Function SaveByName( _
   ByVal name As String _
) As ValueTask(Of SaveDocumentInfo)
C#
public ValueTask<SaveDocumentInfo> SaveByName(
   string name
)

Parameters

name
The report name.

Return Value

A ValueTask representing the asynchronous operation of saving the document by name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Documents Class
Documents Members


DocumentsSettings Class

[image]
ActiveReports 19 .NET Edition
DocumentsSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentsSettings Class

Glossary Item Box

Contains settings and handlers for managing documents.

Object Model

DocumentsSettings Class

Syntax

Visual Basic (Declaration)
Public Class DocumentsSettings
C#
public class DocumentsSettings

Remarks

The DocumentsSettings class provides properties to configure the file view settings and handlers for various document events.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DocumentsSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentsSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentsSettings Class Members

[image]
ActiveReports 19 .NET Edition
DocumentsSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentsSettings Class

Glossary Item Box

The following tables list the members exposed by DocumentsSettings.

Public Constructors

 | Name | Description
Public Constructor | DocumentsSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | FileView | Gets or sets the settings for the file view.
Public Property | Handlers | Gets or sets the handlers for various document events.
Top

See Also

Reference

DocumentsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentsSettings Constructor

[image]
ActiveReports 19 .NET Edition
DocumentsSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentsSettings Class : DocumentsSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentsSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentsSettings Class
DocumentsSettings Members


DocumentsSettings Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentsSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentsSettings Class

Glossary Item Box

For a list of all members of this type, see DocumentsSettings members.

Public Properties

 | Name | Description
Public Property | FileView | Gets or sets the settings for the file view.
Public Property | Handlers | Gets or sets the handlers for various document events.
Top

See Also

Reference

DocumentsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


FileView Property

[image]
ActiveReports 19 .NET Edition
FileView Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentsSettings Class : FileView Property

Glossary Item Box

Gets or sets the settings for the file view.

Syntax

Visual Basic (Declaration)
Public Property FileView As FileView
C#
public FileView FileView {get; set;}

Property Value

An instance of FileView that contains the settings for the file view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentsSettings Class
DocumentsSettings Members


Handlers Property

[image]
ActiveReports 19 .NET Edition
Handlers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentsSettings Class : Handlers Property

Glossary Item Box

Gets or sets the handlers for various document events.

Syntax

Visual Basic (Declaration)
Public Property Handlers As Handlers
C#
public Handlers Handlers {get; set;}

Property Value

An instance of Handlers that contains the handlers for various document events.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentsSettings Class
DocumentsSettings Members


DocumentTemplate Class

[image]
ActiveReports 19 .NET Edition
DocumentTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentTemplate Class

Glossary Item Box

Represents the information about a document template.

Object Model

DocumentTemplate Class

Syntax

Visual Basic (Declaration)
Public Class DocumentTemplate
C#
public class DocumentTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.DocumentTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentTemplate Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentTemplate Class Members

[image]
ActiveReports 19 .NET Edition
DocumentTemplate Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentTemplate Class

Glossary Item Box

The following tables list the members exposed by DocumentTemplate.

Public Constructors

 | Name | Description
Public Constructor | DocumentTemplate Constructor |
Top

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the document template content in JSON format that can be useful in case you would like to create a non-empty new report.
Public Property | Id | Gets or sets the document template ID.
Top

See Also

Reference

DocumentTemplate Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentTemplate Constructor

[image]
ActiveReports 19 .NET Edition
DocumentTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentTemplate Class : DocumentTemplate Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentTemplate Class
DocumentTemplate Members


DocumentTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentTemplate Class

Glossary Item Box

For a list of all members of this type, see DocumentTemplate members.

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the document template content in JSON format that can be useful in case you would like to create a non-empty new report.
Public Property | Id | Gets or sets the document template ID.
Top

See Also

Reference

DocumentTemplate Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentTemplate Class : Content Property

Glossary Item Box

Gets or sets the document template content in JSON format that can be useful in case you would like to create a non-empty new report.

Syntax

Visual Basic (Declaration)
Public Property Content As Object
C#
public object Content {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentTemplate Class
DocumentTemplate Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > DocumentTemplate Class : Id Property

Glossary Item Box

Gets or sets the document template ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentTemplate Class
DocumentTemplate Members


FileView Class

[image]
ActiveReports 19 .NET Edition
FileView Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FileView Class

Glossary Item Box

Represents the settings for the File View.

Object Model

FileView Class

Syntax

Visual Basic (Declaration)
Public Class FileView
C#
public class FileView

Remarks

The FileView class provides a property to configure the visibility of the File View tab.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.FileView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileView Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


FileView Class Members

[image]
ActiveReports 19 .NET Edition
FileView Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FileView Class

Glossary Item Box

The following tables list the members exposed by FileView.

Public Constructors

 | Name | Description
Public Constructor | FileView Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the File View tab should be shown.
Top

See Also

Reference

FileView Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


FileView Constructor

[image]
ActiveReports 19 .NET Edition
FileView Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > FileView Class : FileView Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FileView()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileView Class
FileView Members


FileView Class Properties

[image]
ActiveReports 19 .NET Edition
FileView Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FileView Class

Glossary Item Box

For a list of all members of this type, see FileView members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the File View tab should be shown.
Top

See Also

Reference

FileView Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > FileView Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the File View tab should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the File View tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileView Class
FileView Members


Font Class

[image]
ActiveReports 19 .NET Edition
Font Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Font Class

Glossary Item Box

Represents the configuration for a font.

Object Model

Font Class

Syntax

Visual Basic (Declaration)
Public Class Font
C#
public class Font

Remarks

The Font class provides properties to configure the label and value of a font.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Font Class Members

[image]
ActiveReports 19 .NET Edition
Font Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Font Class

Glossary Item Box

The following tables list the members exposed by Font.

Public Constructors

 | Name | Description
Public Constructor | Font Constructor |
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label of the font.
Public Property | Value | Gets or sets the value of the font.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Font Constructor

[image]
ActiveReports 19 .NET Edition
Font Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Font Class : Font Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Font()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Font Class Properties

[image]
ActiveReports 19 .NET Edition
Font Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label of the font.
Public Property | Value | Gets or sets the value of the font.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Font Class : Label Property

Glossary Item Box

Gets or sets the label of the font.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Property Value

The label of the font as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Font Class : Value Property

Glossary Item Box

Gets or sets the value of the font.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

The value of the font as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


FontHeader Class

[image]
ActiveReports 19 .NET Edition
FontHeader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FontHeader Class

Glossary Item Box

Represents the configuration for a font header.

Object Model

FontHeader Class

Syntax

Visual Basic (Declaration)
Public Class FontHeader
C#
public class FontHeader

Remarks

The FontHeader class provides a property to configure the header of a font section.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.FontHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontHeader Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


FontHeader Class Members

[image]
ActiveReports 19 .NET Edition
FontHeader Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FontHeader Class

Glossary Item Box

The following tables list the members exposed by FontHeader.

Public Constructors

 | Name | Description
Public Constructor | FontHeader Constructor |
Top

Public Properties

 | Name | Description
Public Property | Header | Gets or sets the header of the font section.
Top

See Also

Reference

FontHeader Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


FontHeader Constructor

[image]
ActiveReports 19 .NET Edition
FontHeader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > FontHeader Class : FontHeader Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FontHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontHeader Class
FontHeader Members


FontHeader Class Properties

[image]
ActiveReports 19 .NET Edition
FontHeader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : FontHeader Class

Glossary Item Box

For a list of all members of this type, see FontHeader members.

Public Properties

 | Name | Description
Public Property | Header | Gets or sets the header of the font section.
Top

See Also

Reference

FontHeader Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > FontHeader Class : Header Property

Glossary Item Box

Gets or sets the header of the font section.

Syntax

Visual Basic (Declaration)
Public Property Header As String
C#
public string Header {get; set;}

Property Value

The header of the font section as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontHeader Class
FontHeader Members


Footer Class

[image]
ActiveReports 19 .NET Edition
Footer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Footer Class

Glossary Item Box

Represents the style content for the footer of a table report item.

Object Model

Footer Class

Syntax

Visual Basic (Declaration)
Public Class Footer
C#
public class Footer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Footer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Footer Class Members

[image]
ActiveReports 19 .NET Edition
Footer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Footer Class

Glossary Item Box

The following tables list the members exposed by Footer.

Public Constructors

 | Name | Description
Public Constructor | Footer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Rows | Gets or sets the rows style content of the footer.
Top

See Also

Reference

Footer Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Footer Constructor

[image]
ActiveReports 19 .NET Edition
Footer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Footer Class : Footer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Footer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Class
Footer Members


Footer Class Properties

[image]
ActiveReports 19 .NET Edition
Footer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Footer Class

Glossary Item Box

For a list of all members of this type, see Footer members.

Public Properties

 | Name | Description
Public Property | Rows | Gets or sets the rows style content of the footer.
Top

See Also

Reference

Footer Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Footer Class : Rows Property

Glossary Item Box

Gets or sets the rows style content of the footer.

Syntax

Visual Basic (Declaration)
Public Property Rows As CellStyleContent()
C#
public CellStyleContent[] Rows {get; set;}

Property Value

An array of CellStyleContent representing the rows style content of the footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Class
Footer Members


Fpl Class

[image]
ActiveReports 19 .NET Edition
Fpl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Fpl Class

Glossary Item Box

Represents the settings for FPL.

Object Model

Fpl Class

Syntax

Visual Basic (Declaration)
Public Class Fpl
C#
public class Fpl

Remarks

The Fpl class provides a property to configure the enabling of FPL support.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Fpl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fpl Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Fpl Class Members

[image]
ActiveReports 19 .NET Edition
Fpl Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Fpl Class

Glossary Item Box

The following tables list the members exposed by Fpl.

Public Constructors

 | Name | Description
Public Constructor | Fpl Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether FPL support is enabled.
Top

See Also

Reference

Fpl Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Fpl Constructor

[image]
ActiveReports 19 .NET Edition
Fpl Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Fpl Class : Fpl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Fpl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fpl Class
Fpl Members


Fpl Class Properties

[image]
ActiveReports 19 .NET Edition
Fpl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Fpl Class

Glossary Item Box

For a list of all members of this type, see Fpl members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether FPL support is enabled.
Top

See Also

Reference

Fpl Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Fpl Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether FPL support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if FPL support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fpl Class
Fpl Members


Handlers Class

[image]
ActiveReports 19 .NET Edition
Handlers Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Handlers Class

Glossary Item Box

Represents handlers for various document events.

Object Model

Handlers Class

Syntax

Visual Basic (Declaration)
Public Class Handlers
C#
public class Handlers

Remarks

The Handlers class provides properties to configure handlers for various document-related events.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Handlers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Handlers Class Members

[image]
ActiveReports 19 .NET Edition
Handlers Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Handlers Class

Glossary Item Box

The following tables list the members exposed by Handlers.

Public Constructors

 | Name | Description
Public Constructor | Handlers Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterCreate | Gets or sets a handler that is called when creation is complete.
Public Property | OnAfterOpen | Gets or sets a handler that is called when opening is complete.
Public Property | OnAfterSave | Gets or sets a handler that is called when saving is complete.
Public Property | OnBeforeCreate | Gets or sets a handler that cancels the creation process if it returns false.
Public Property | OnBeforeOpen | Gets or sets a handler that cancels the opening process if it returns false.
Public Property | OnBeforeSave | Gets or sets a handler that cancels the saving process if it returns false.
Public Property | OnDocumentChanged | Gets or sets a handler that is triggered when the report content is changed.
Public Property | OnInfoUpdate | Gets or sets a handler that is triggered when the report name or ID is updated.
Top

See Also

Reference

Handlers Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Handlers Constructor

[image]
ActiveReports 19 .NET Edition
Handlers Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : Handlers Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Handlers()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


Handlers Class Properties

[image]
ActiveReports 19 .NET Edition
Handlers Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Handlers Class

Glossary Item Box

For a list of all members of this type, see Handlers members.

Public Properties

 | Name | Description
Public Property | OnAfterCreate | Gets or sets a handler that is called when creation is complete.
Public Property | OnAfterOpen | Gets or sets a handler that is called when opening is complete.
Public Property | OnAfterSave | Gets or sets a handler that is called when saving is complete.
Public Property | OnBeforeCreate | Gets or sets a handler that cancels the creation process if it returns false.
Public Property | OnBeforeOpen | Gets or sets a handler that cancels the opening process if it returns false.
Public Property | OnBeforeSave | Gets or sets a handler that cancels the saving process if it returns false.
Public Property | OnDocumentChanged | Gets or sets a handler that is triggered when the report content is changed.
Public Property | OnInfoUpdate | Gets or sets a handler that is triggered when the report name or ID is updated.
Top

See Also

Reference

Handlers Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


OnAfterCreate Property

[image]
ActiveReports 19 .NET Edition
OnAfterCreate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnAfterCreate Property

Glossary Item Box

Gets or sets a handler that is called when creation is complete.

Syntax

Visual Basic (Declaration)
Public Property OnAfterCreate As Action
C#
public Action OnAfterCreate {get; set;}

Property Value

An action that is called when creation is complete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnAfterOpen Property

[image]
ActiveReports 19 .NET Edition
OnAfterOpen Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnAfterOpen Property

Glossary Item Box

Gets or sets a handler that is called when opening is complete.

Syntax

Visual Basic (Declaration)
Public Property OnAfterOpen As Action
C#
public Action OnAfterOpen {get; set;}

Property Value

An action that is called when opening is complete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnAfterSave Property

[image]
ActiveReports 19 .NET Edition
OnAfterSave Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnAfterSave Property

Glossary Item Box

Gets or sets a handler that is called when saving is complete.

Syntax

Visual Basic (Declaration)
Public Property OnAfterSave As Action(Of SaveDocumentInfo)
C#
public Action<SaveDocumentInfo> OnAfterSave {get; set;}

Property Value

An action that takes a SaveDocumentInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnBeforeCreate Property

[image]
ActiveReports 19 .NET Edition
OnBeforeCreate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnBeforeCreate Property

Glossary Item Box

Gets or sets a handler that cancels the creation process if it returns false.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeCreate As Func(Of Boolean)
C#
public Func<bool> OnBeforeCreate {get; set;}

Property Value

A function that returns a System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnBeforeOpen Property

[image]
ActiveReports 19 .NET Edition
OnBeforeOpen Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnBeforeOpen Property

Glossary Item Box

Gets or sets a handler that cancels the opening process if it returns false.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeOpen As Func(Of Boolean)
C#
public Func<bool> OnBeforeOpen {get; set;}

Property Value

A function that returns a System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnBeforeSave Property

[image]
ActiveReports 19 .NET Edition
OnBeforeSave Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnBeforeSave Property

Glossary Item Box

Gets or sets a handler that cancels the saving process if it returns false.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeSave As Func(Of SaveDocumentInfo,Boolean)
C#
public Func<SaveDocumentInfo,bool> OnBeforeSave {get; set;}

Property Value

A function that takes a SaveDocumentInfo and returns a System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnDocumentChanged Property

[image]
ActiveReports 19 .NET Edition
OnDocumentChanged Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnDocumentChanged Property

Glossary Item Box

Gets or sets a handler that is triggered when the report content is changed.

Syntax

Visual Basic (Declaration)
Public Property OnDocumentChanged As Action(Of ChangedDocumentOptions)
C#
public Action<ChangedDocumentOptions> OnDocumentChanged {get; set;}

Property Value

An action that takes a ChangedDocumentOptions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


OnInfoUpdate Property

[image]
ActiveReports 19 .NET Edition
OnInfoUpdate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Handlers Class : OnInfoUpdate Property

Glossary Item Box

Gets or sets a handler that is triggered when the report name or ID is updated.

Syntax

Visual Basic (Declaration)
Public Property OnInfoUpdate As Action(Of UpdateDocumentOptions)
C#
public Action<UpdateDocumentOptions> OnInfoUpdate {get; set;}

Property Value

An action that takes an UpdateDocumentOptions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Handlers Class
Handlers Members


Header Class

[image]
ActiveReports 19 .NET Edition
Header Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Header Class

Glossary Item Box

Represents the style content for the header of a table report item.

Object Model

Header Class

Syntax

Visual Basic (Declaration)
Public Class Header
C#
public class Header

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Header

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Header Class Members

[image]
ActiveReports 19 .NET Edition
Header Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Header Class

Glossary Item Box

The following tables list the members exposed by Header.

Public Constructors

 | Name | Description
Public Constructor | Header Constructor |
Top

Public Properties

 | Name | Description
Public Property | Rows | Gets or sets the rows style content of the header.
Top

See Also

Reference

Header Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Header Constructor

[image]
ActiveReports 19 .NET Edition
Header Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Header Class : Header Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Header()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Class
Header Members


Header Class Properties

[image]
ActiveReports 19 .NET Edition
Header Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Header Class

Glossary Item Box

For a list of all members of this type, see Header members.

Public Properties

 | Name | Description
Public Property | Rows | Gets or sets the rows style content of the header.
Top

See Also

Reference

Header Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Header Class : Rows Property

Glossary Item Box

Gets or sets the rows style content of the header.

Syntax

Visual Basic (Declaration)
Public Property Rows As CellStyleContent()
C#
public CellStyleContent[] Rows {get; set;}

Property Value

An array of CellStyleContent representing the rows style content of the header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Class
Header Members


Help Class

[image]
ActiveReports 19 .NET Edition
Help Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Help Class

Glossary Item Box

Represents the designer-related documentation links.

Object Model

Help Class

Syntax

Visual Basic (Declaration)
Public Class Help
C#
public class Help

Remarks

The Help class provides properties to store links to general documentation and report items transformation info.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Help

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Help Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Help Class Members

[image]
ActiveReports 19 .NET Edition
Help Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Help Class

Glossary Item Box

The following tables list the members exposed by Help.

Public Constructors

 | Name | Description
Public Constructor | Help Constructor |
Top

Public Properties

 | Name | Description
Public Property | General | Gets or sets the general documentation link.
Public Property | Transformation | Gets or sets the report items transformation info link.
Top

See Also

Reference

Help Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Help Constructor

[image]
ActiveReports 19 .NET Edition
Help Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Help Class : Help Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Help()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Help Class
Help Members


Help Class Properties

[image]
ActiveReports 19 .NET Edition
Help Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Help Class

Glossary Item Box

For a list of all members of this type, see Help members.

Public Properties

 | Name | Description
Public Property | General | Gets or sets the general documentation link.
Public Property | Transformation | Gets or sets the report items transformation info link.
Top

See Also

Reference

Help Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


General Property

[image]
ActiveReports 19 .NET Edition
General Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Help Class : General Property

Glossary Item Box

Gets or sets the general documentation link.

Syntax

Visual Basic (Declaration)
Public Property General As Link
C#
public Link General {get; set;}

Property Value

An instance of Link representing the general documentation link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Help Class
Help Members


Transformation Property

[image]
ActiveReports 19 .NET Edition
Transformation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Help Class : Transformation Property

Glossary Item Box

Gets or sets the report items transformation info link.

Syntax

Visual Basic (Declaration)
Public Property Transformation As Link
C#
public Link Transformation {get; set;}

Property Value

An instance of Link representing the report items transformation info link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Help Class
Help Members


HomeTab Class

[image]
ActiveReports 19 .NET Edition
HomeTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : HomeTab Class

Glossary Item Box

Represents the settings for the Home tab.

Object Model

HomeTab Class

Syntax

Visual Basic (Declaration)
Public Class HomeTab
C#
public class HomeTab

Remarks

The HomeTab class provides a property to configure the visibility of the Home tab in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.HomeTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HomeTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


HomeTab Class Members

[image]
ActiveReports 19 .NET Edition
HomeTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : HomeTab Class

Glossary Item Box

The following tables list the members exposed by HomeTab.

Public Constructors

 | Name | Description
Public Constructor | HomeTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Home tab should be visible.
Top

See Also

Reference

HomeTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


HomeTab Constructor

[image]
ActiveReports 19 .NET Edition
HomeTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > HomeTab Class : HomeTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public HomeTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HomeTab Class
HomeTab Members


HomeTab Class Properties

[image]
ActiveReports 19 .NET Edition
HomeTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : HomeTab Class

Glossary Item Box

For a list of all members of this type, see HomeTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Home tab should be visible.
Top

See Also

Reference

HomeTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > HomeTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Home tab should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Home tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HomeTab Class
HomeTab Members


InitTemplates Class

[image]
ActiveReports 19 .NET Edition
InitTemplates Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InitTemplates Class

Glossary Item Box

Represents the templates for creating new items from RDLX-JSON strings.

Object Model

InitTemplates Class

Syntax

Visual Basic (Declaration)
Public Class InitTemplates
C#
public class InitTemplates

Remarks

The InitTemplates class provides properties to configure the imperial and metric templates used for creating new items.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.InitTemplates

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitTemplates Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


InitTemplates Class Members

[image]
ActiveReports 19 .NET Edition
InitTemplates Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InitTemplates Class

Glossary Item Box

The following tables list the members exposed by InitTemplates.

Public Constructors

 | Name | Description
Public Constructor | InitTemplates Constructor |
Top

Public Properties

 | Name | Description
Public Property | ImperialTemplates | Gets or sets the imperial templates that should include reports with units set to 'in'.
Public Property | MetricTemplates | Gets or sets the metric templates that should include reports with units set to 'cm'.
Top

See Also

Reference

InitTemplates Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


InitTemplates Constructor

[image]
ActiveReports 19 .NET Edition
InitTemplates Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > InitTemplates Class : InitTemplates Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InitTemplates()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitTemplates Class
InitTemplates Members


InitTemplates Class Properties

[image]
ActiveReports 19 .NET Edition
InitTemplates Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InitTemplates Class

Glossary Item Box

For a list of all members of this type, see InitTemplates members.

Public Properties

 | Name | Description
Public Property | ImperialTemplates | Gets or sets the imperial templates that should include reports with units set to 'in'.
Public Property | MetricTemplates | Gets or sets the metric templates that should include reports with units set to 'cm'.
Top

See Also

Reference

InitTemplates Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ImperialTemplates Property

[image]
ActiveReports 19 .NET Edition
ImperialTemplates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > InitTemplates Class : ImperialTemplates Property

Glossary Item Box

Gets or sets the imperial templates that should include reports with units set to 'in'.

Syntax

Visual Basic (Declaration)
Public Property ImperialTemplates As String()
C#
public string[] ImperialTemplates {get; set;}

Property Value

An array of System.String that contains the imperial templates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitTemplates Class
InitTemplates Members


MetricTemplates Property

[image]
ActiveReports 19 .NET Edition
MetricTemplates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > InitTemplates Class : MetricTemplates Property

Glossary Item Box

Gets or sets the metric templates that should include reports with units set to 'cm'.

Syntax

Visual Basic (Declaration)
Public Property MetricTemplates As String()
C#
public string[] MetricTemplates {get; set;}

Property Value

An array of System.String that contains the metric templates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitTemplates Class
InitTemplates Members


InsertTab Class

[image]
ActiveReports 19 .NET Edition
InsertTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InsertTab Class

Glossary Item Box

Represents the settings for the Insert tab.

Object Model

InsertTab Class

Syntax

Visual Basic (Declaration)
Public Class InsertTab
C#
public class InsertTab

Remarks

The InsertTab class provides a property to configure the visibility of the Insert tab in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.InsertTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InsertTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


InsertTab Class Members

[image]
ActiveReports 19 .NET Edition
InsertTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InsertTab Class

Glossary Item Box

The following tables list the members exposed by InsertTab.

Public Constructors

 | Name | Description
Public Constructor | InsertTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Insert tab should be visible.
Top

See Also

Reference

InsertTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


InsertTab Constructor

[image]
ActiveReports 19 .NET Edition
InsertTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > InsertTab Class : InsertTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InsertTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InsertTab Class
InsertTab Members


InsertTab Class Properties

[image]
ActiveReports 19 .NET Edition
InsertTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : InsertTab Class

Glossary Item Box

For a list of all members of this type, see InsertTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Insert tab should be visible.
Top

See Also

Reference

InsertTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > InsertTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Insert tab should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Insert tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InsertTab Class
InsertTab Members


Levels Class

[image]
ActiveReports 19 .NET Edition
Levels Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Levels Class

Glossary Item Box

Represents the style content for the levels of a table of contents report item.

Object Model

Levels Class

Syntax

Visual Basic (Declaration)
Public Class Levels
C#
public class Levels

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Levels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Levels Class Members

[image]
ActiveReports 19 .NET Edition
Levels Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Levels Class

Glossary Item Box

The following tables list the members exposed by Levels.

Public Constructors

 | Name | Description
Public Constructor | Levels Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the text in the levels.
Public Property | FontFamily | Gets or sets the font family of the text in the levels.
Public Property | FontSize | Gets or sets the font size of the text in the levels.
Public Property | FontStyle | Gets or sets the font style of the text in the levels.
Public Property | FontWeight | Gets or sets the font weight of the text in the levels.
Public Property | PaddingLeft | Gets or sets the padding on the left side of the levels.
Top

See Also

Reference

Levels Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Levels Constructor

[image]
ActiveReports 19 .NET Edition
Levels Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : Levels Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Levels()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


Levels Class Properties

[image]
ActiveReports 19 .NET Edition
Levels Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Levels Class

Glossary Item Box

For a list of all members of this type, see Levels members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the text in the levels.
Public Property | FontFamily | Gets or sets the font family of the text in the levels.
Public Property | FontSize | Gets or sets the font size of the text in the levels.
Public Property | FontStyle | Gets or sets the font style of the text in the levels.
Public Property | FontWeight | Gets or sets the font weight of the text in the levels.
Public Property | PaddingLeft | Gets or sets the padding on the left side of the levels.
Top

See Also

Reference

Levels Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : Color Property

Glossary Item Box

Gets or sets the color of the text in the levels.

Syntax

Visual Basic (Declaration)
Public Property Color As String
C#
public string Color {get; set;}

Property Value

The color of the text in the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : FontFamily Property

Glossary Item Box

Gets or sets the font family of the text in the levels.

Syntax

Visual Basic (Declaration)
Public Property FontFamily As String
C#
public string FontFamily {get; set;}

Property Value

The font family of the text in the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : FontSize Property

Glossary Item Box

Gets or sets the font size of the text in the levels.

Syntax

Visual Basic (Declaration)
Public Property FontSize As String
C#
public string FontSize {get; set;}

Property Value

The font size of the text in the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : FontStyle Property

Glossary Item Box

Gets or sets the font style of the text in the levels.

Syntax

Visual Basic (Declaration)
Public Property FontStyle As String
C#
public string FontStyle {get; set;}

Property Value

The font style of the text in the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : FontWeight Property

Glossary Item Box

Gets or sets the font weight of the text in the levels.

Syntax

Visual Basic (Declaration)
Public Property FontWeight As String
C#
public string FontWeight {get; set;}

Property Value

The font weight of the text in the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


PaddingLeft Property

[image]
ActiveReports 19 .NET Edition
PaddingLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Levels Class : PaddingLeft Property

Glossary Item Box

Gets or sets the padding on the left side of the levels.

Syntax

Visual Basic (Declaration)
Public Property PaddingLeft As String
C#
public string PaddingLeft {get; set;}

Property Value

The padding on the left side of the levels as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Levels Class
Levels Members


Library Class

[image]
ActiveReports 19 .NET Edition
Library Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Library Class

Glossary Item Box

Represents a library for report parts.

Object Model

Library Class

Syntax

Visual Basic (Declaration)
Public Class Library
C#
public class Library

Remarks

The Library class provides properties to configure the name and path of a library for report parts.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Library

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Library Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Library Class Members

[image]
ActiveReports 19 .NET Edition
Library Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Library Class

Glossary Item Box

The following tables list the members exposed by Library.

Public Constructors

 | Name | Description
Public Constructor | Library Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the library.
Public Property | Path | Gets or sets the path to the library.
Top

See Also

Reference

Library Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Library Constructor

[image]
ActiveReports 19 .NET Edition
Library Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Library Class : Library Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Library()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Library Class
Library Members


Library Class Properties

[image]
ActiveReports 19 .NET Edition
Library Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Library Class

Glossary Item Box

For a list of all members of this type, see Library members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the library.
Public Property | Path | Gets or sets the path to the library.
Top

See Also

Reference

Library Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Library Class : Name Property

Glossary Item Box

Gets or sets the name of the library.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the library as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Library Class
Library Members


Path Property

[image]
ActiveReports 19 .NET Edition
Path Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Library Class : Path Property

Glossary Item Box

Gets or sets the path to the library.

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path {get; set;}

Property Value

The path to the library as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Library Class
Library Members


Link Class

[image]
ActiveReports 19 .NET Edition
Link Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Link Class

Glossary Item Box

Represents the link.

Object Model

Link Class

Syntax

Visual Basic (Declaration)
Public Class Link
C#
public class Link

Remarks

The Link class provides properties to store the display text and URL for a documentation link.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Link

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Link Class Members

[image]
ActiveReports 19 .NET Edition
Link Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Link Class

Glossary Item Box

The following tables list the members exposed by Link.

Public Constructors

 | Name | Description
Public Constructor | Link Constructor |
Top

Public Properties

 | Name | Description
Public Property | Text | Gets or sets the general documentation link.
Public Property | Url | Gets or sets the report items transformation info link.
Top

See Also

Reference

Link Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Link Constructor

[image]
ActiveReports 19 .NET Edition
Link Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Link Class : Link Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Link()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Link Class Properties

[image]
ActiveReports 19 .NET Edition
Link Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Link Class

Glossary Item Box

For a list of all members of this type, see Link members.

Public Properties

 | Name | Description
Public Property | Text | Gets or sets the general documentation link.
Public Property | Url | Gets or sets the report items transformation info link.
Top

See Also

Reference

Link Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Link Class : Text Property

Glossary Item Box

Gets or sets the general documentation link.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The display text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Url Property

[image]
ActiveReports 19 .NET Edition
Url Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Link Class : Url Property

Glossary Item Box

Gets or sets the report items transformation info link.

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url {get; set;}

Property Value

The URL as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


LocalizationResources Class

[image]
ActiveReports 19 .NET Edition
LocalizationResources Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : LocalizationResources Class

Glossary Item Box

Represents localization resources for a specific language.

Object Model

LocalizationResources Class

Syntax

Visual Basic (Declaration)
Public Class LocalizationResources
C#
public class LocalizationResources

Example

C# Copy Code
new LocalizationResources()
{
    Language = "en",

    //See file from assets "custom-full-resources.json" for more information.
    Resources = "[" +
        "{" +
        "\"ns\": \"components\", " +
        "\"lng\": \"en\", " +
        "\"resources\": { " +
        "\"appBar\": { " +
        "\"btnPreview\": \"Preview\"," +
        "\"btnFile\": \"File\"," +
        "\"btnHome\": \"Home\"" +
        "}" +
        "}" +
        "}" +
    "]"
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.LocalizationResources

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResources Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


LocalizationResources Class Members

[image]
ActiveReports 19 .NET Edition
LocalizationResources Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : LocalizationResources Class

Glossary Item Box

The following tables list the members exposed by LocalizationResources.

Public Constructors

 | Name | Description
Public Constructor | LocalizationResources Constructor |
Top

Public Properties

 | Name | Description
Public Property | Language | Gets or sets the language code (e.g., "en", "ja").
Public Property | Resources | Gets or sets the localization resources as a JSON array string.
Top

See Also

Reference

LocalizationResources Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


LocalizationResources Constructor

[image]
ActiveReports 19 .NET Edition
LocalizationResources Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > LocalizationResources Class : LocalizationResources Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LocalizationResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResources Class
LocalizationResources Members


LocalizationResources Class Properties

[image]
ActiveReports 19 .NET Edition
LocalizationResources Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : LocalizationResources Class

Glossary Item Box

For a list of all members of this type, see LocalizationResources members.

Public Properties

 | Name | Description
Public Property | Language | Gets or sets the language code (e.g., "en", "ja").
Public Property | Resources | Gets or sets the localization resources as a JSON array string.
Top

See Also

Reference

LocalizationResources Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > LocalizationResources Class : Language Property

Glossary Item Box

Gets or sets the language code (e.g., "en", "ja").

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Property Value

The language code as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResources Class
LocalizationResources Members


Resources Property

[image]
ActiveReports 19 .NET Edition
Resources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > LocalizationResources Class : Resources Property

Glossary Item Box

Gets or sets the localization resources as a JSON array string.

Syntax

Visual Basic (Declaration)
Public Property Resources As String
C#
public string Resources {get; set;}

Property Value

The localization resources as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResources Class
LocalizationResources Members


Logo Class

[image]
ActiveReports 19 .NET Edition
Logo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Logo Class

Glossary Item Box

Represents the logo settings.

Object Model

Logo Class

Syntax

Visual Basic (Declaration)
Public Class Logo
C#
public class Logo

Remarks

The Logo class provides properties to configure the visibility and custom settings of the logo in the menu.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Logo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Logo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Logo Class Members

[image]
ActiveReports 19 .NET Edition
Logo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Logo Class

Glossary Item Box

The following tables list the members exposed by Logo.

Public Constructors

 | Name | Description
Public Constructor | Logo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom logo to be shown in the menu.
Public Property | Visible | Gets or sets a value indicating whether the logo should be shown in the menu.
Top

See Also

Reference

Logo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Logo Constructor

[image]
ActiveReports 19 .NET Edition
Logo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Logo Class : Logo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Logo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Logo Class
Logo Members


Logo Class Properties

[image]
ActiveReports 19 .NET Edition
Logo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Logo Class

Glossary Item Box

For a list of all members of this type, see Logo members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets a custom logo to be shown in the menu.
Public Property | Visible | Gets or sets a value indicating whether the logo should be shown in the menu.
Top

See Also

Reference

Logo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Custom Property

[image]
ActiveReports 19 .NET Edition
Custom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Logo Class : Custom Property

Glossary Item Box

Gets or sets a custom logo to be shown in the menu.

Syntax

Visual Basic (Declaration)
Public Property Custom As MenuIcon
C#
public MenuIcon Custom {get; set;}

Property Value

An instance of MenuIcon that contains the custom logo settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Logo Class
Logo Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Logo Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the logo should be shown in the menu.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the logo should be shown in the menu; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Logo Class
Logo Members


MasterReport Class

[image]
ActiveReports 19 .NET Edition
MasterReport Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MasterReport Class

Glossary Item Box

Represents the settings for RDL MasterReport.

Object Model

MasterReport Class

Syntax

Visual Basic (Declaration)
Public Class MasterReport
C#
public class MasterReport

Remarks

The MasterReport class provides a property to configure the enabling of RDL MasterReport support.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.MasterReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterReport Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


MasterReport Class Members

[image]
ActiveReports 19 .NET Edition
MasterReport Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MasterReport Class

Glossary Item Box

The following tables list the members exposed by MasterReport.

Public Constructors

 | Name | Description
Public Constructor | MasterReport Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL MasterReport support is enabled.
Top

See Also

Reference

MasterReport Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


MasterReport Constructor

[image]
ActiveReports 19 .NET Edition
MasterReport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MasterReport Class : MasterReport Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MasterReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterReport Class
MasterReport Members


MasterReport Class Properties

[image]
ActiveReports 19 .NET Edition
MasterReport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MasterReport Class

Glossary Item Box

For a list of all members of this type, see MasterReport members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL MasterReport support is enabled.
Top

See Also

Reference

MasterReport Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MasterReport Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether RDL MasterReport support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if RDL MasterReport support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterReport Class
MasterReport Members


Menu Class

[image]
ActiveReports 19 .NET Edition
Menu Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Menu Class

Glossary Item Box

Represents methods to interact with the menu in the UI.

Object Model

Menu Class

Syntax

Visual Basic (Declaration)
Public Class Menu
C#
public class Menu

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Menu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Menu Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Menu Class Members

[image]
ActiveReports 19 .NET Edition
Menu Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Menu Class

Glossary Item Box

The following tables list the members exposed by Menu.

Public Methods

 | Name | Description
Public Method | Close | Closes the currently open menu.
Public Method | Open | Opens the menu with the specified ID.
Public Method | Pin | Pins the menu, keeping it open.
Top

See Also

Reference

Menu Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Menu Class Methods

[image]
ActiveReports 19 .NET Edition
Menu Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Menu Class

Glossary Item Box

For a list of all members of this type, see Menu members.

Public Methods

 | Name | Description
Public Method | Close | Closes the currently open menu.
Public Method | Open | Opens the menu with the specified ID.
Public Method | Pin | Pins the menu, keeping it open.
Top

See Also

Reference

Menu Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Close Method

[image]
ActiveReports 19 .NET Edition
Close Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Menu Class : Close Method

Glossary Item Box

Closes the currently open menu.

Syntax

Visual Basic (Declaration)
Public Function Close() As Task
C#
public Task Close()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of closing the menu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Menu Class
Menu Members


Open Method

[image]
ActiveReports 19 .NET Edition
Open Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Menu Class : Open Method

id
The ID of the menu to open.

Glossary Item Box

Opens the menu with the specified ID.

Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal id As String _
) As Task
C#
public Task Open(
   string id
)

Parameters

id
The ID of the menu to open.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of opening the specified menu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Menu Class
Menu Members


Pin Method

[image]
ActiveReports 19 .NET Edition
Pin Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Menu Class : Pin Method

Glossary Item Box

Pins the menu, keeping it open.

Syntax

Visual Basic (Declaration)
Public Function Pin() As Task
C#
public Task Pin()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of pinning the menu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Menu Class
Menu Members


MenuIcon Class

[image]
ActiveReports 19 .NET Edition
MenuIcon Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuIcon Class

Glossary Item Box

Represents a custom menu icon.

Object Model

MenuIcon Class

Syntax

Visual Basic (Declaration)
Public Class MenuIcon
C#
public class MenuIcon

Remarks

The MenuIcon class provides properties to configure the type and CSS class of a custom logo.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.MenuIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuIcon Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


MenuIcon Class Members

[image]
ActiveReports 19 .NET Edition
MenuIcon Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuIcon Class

Glossary Item Box

The following tables list the members exposed by MenuIcon.

Public Constructors

 | Name | Description
Public Constructor | MenuIcon Constructor |
Top

Public Properties

 | Name | Description
Public Property | Class | Gets or sets the CSS class for the custom logo.
Public Property | Type | Gets or sets the type of the custom logo (e.g., "css").
Top

See Also

Reference

MenuIcon Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


MenuIcon Constructor

[image]
ActiveReports 19 .NET Edition
MenuIcon Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuIcon Class : MenuIcon Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MenuIcon()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuIcon Class
MenuIcon Members


MenuIcon Class Properties

[image]
ActiveReports 19 .NET Edition
MenuIcon Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuIcon Class

Glossary Item Box

For a list of all members of this type, see MenuIcon members.

Public Properties

 | Name | Description
Public Property | Class | Gets or sets the CSS class for the custom logo.
Public Property | Type | Gets or sets the type of the custom logo (e.g., "css").
Top

See Also

Reference

MenuIcon Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Class Property

[image]
ActiveReports 19 .NET Edition
Class Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuIcon Class : Class Property

Glossary Item Box

Gets or sets the CSS class for the custom logo.

Syntax

Visual Basic (Declaration)
Public Property Class As String
C#
public string Class {get; set;}

Property Value

The CSS class for the custom logo as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuIcon Class
MenuIcon Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuIcon Class : Type Property

Glossary Item Box

Gets or sets the type of the custom logo (e.g., "css").

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type {get; set;}

Property Value

The type of the custom logo as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuIcon Class
MenuIcon Members


MenuSettings Class

[image]
ActiveReports 19 .NET Edition
MenuSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuSettings Class

Glossary Item Box

Represents the settings for the Main Menu, providing access to various features and tools.

Object Model

MenuSettings Class

Syntax

Visual Basic (Declaration)
Public Class MenuSettings
C#
public class MenuSettings

Remarks

The MenuSettings class provides properties to configure the visibility and settings for various components of the main menu, including the logo, tool box, document explorer, group editor, and layer editor.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.MenuSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


MenuSettings Class Members

[image]
ActiveReports 19 .NET Edition
MenuSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuSettings Class

Glossary Item Box

The following tables list the members exposed by MenuSettings.

Public Constructors

 | Name | Description
Public Constructor | MenuSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DocumentExplorer | Gets or sets the Document Explorer settings.
Public Property | Logo | Gets or sets the logo settings.
Public Property | ToolBox | Gets or sets the Tool Box settings.
Public Property | Visible | Gets or sets a value indicating whether the Main Menu should be shown.
Top

See Also

Reference

MenuSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


MenuSettings Constructor

[image]
ActiveReports 19 .NET Edition
MenuSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuSettings Class : MenuSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MenuSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Class
MenuSettings Members


MenuSettings Class Properties

[image]
ActiveReports 19 .NET Edition
MenuSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : MenuSettings Class

Glossary Item Box

For a list of all members of this type, see MenuSettings members.

Public Properties

 | Name | Description
Public Property | DocumentExplorer | Gets or sets the Document Explorer settings.
Public Property | Logo | Gets or sets the logo settings.
Public Property | ToolBox | Gets or sets the Tool Box settings.
Public Property | Visible | Gets or sets a value indicating whether the Main Menu should be shown.
Top

See Also

Reference

MenuSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DocumentExplorer Property

[image]
ActiveReports 19 .NET Edition
DocumentExplorer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuSettings Class : DocumentExplorer Property

Glossary Item Box

Gets or sets the Document Explorer settings.

Syntax

Visual Basic (Declaration)
Public Property DocumentExplorer As DocumentExplorer
C#
public DocumentExplorer DocumentExplorer {get; set;}

Property Value

An instance of DocumentExplorer that contains the Document Explorer settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Class
MenuSettings Members


Logo Property

[image]
ActiveReports 19 .NET Edition
Logo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuSettings Class : Logo Property

Glossary Item Box

Gets or sets the logo settings.

Syntax

Visual Basic (Declaration)
Public Property Logo As Logo
C#
public Logo Logo {get; set;}

Property Value

An instance of Logo that contains the logo settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Class
MenuSettings Members


ToolBox Property

[image]
ActiveReports 19 .NET Edition
ToolBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuSettings Class : ToolBox Property

Glossary Item Box

Gets or sets the Tool Box settings.

Syntax

Visual Basic (Declaration)
Public Property ToolBox As ToolBox
C#
public ToolBox ToolBox {get; set;}

Property Value

An instance of ToolBox that contains the Tool Box settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Class
MenuSettings Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > MenuSettings Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Main Menu should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Main Menu should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MenuSettings Class
MenuSettings Members


Msl Class

[image]
ActiveReports 19 .NET Edition
Msl Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Msl Class

Glossary Item Box

Represents the settings for RDL Multi-Section (MSL).

Object Model

Msl Class

Syntax

Visual Basic (Declaration)
Public Class Msl
C#
public class Msl

Remarks

The Msl class provides a property to configure the enabling of RDL Multi-Section support.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Msl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Msl Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Msl Class Members

[image]
ActiveReports 19 .NET Edition
Msl Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Msl Class

Glossary Item Box

The following tables list the members exposed by Msl.

Public Constructors

 | Name | Description
Public Constructor | Msl Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL Multi-Section support is enabled.
Top

See Also

Reference

Msl Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Msl Constructor

[image]
ActiveReports 19 .NET Edition
Msl Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Msl Class : Msl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Msl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Msl Class
Msl Members


Msl Class Properties

[image]
ActiveReports 19 .NET Edition
Msl Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Msl Class

Glossary Item Box

For a list of all members of this type, see Msl members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RDL Multi-Section support is enabled.
Top

See Also

Reference

Msl Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Msl Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether RDL Multi-Section support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if RDL Multi-Section support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Msl Class
Msl Members


Notifications Class

[image]
ActiveReports 19 .NET Edition
Notifications Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Notifications Class

Glossary Item Box

Represents methods for sending and managing notifications, allowing the sending of notifications of various levels (info, warning, error) and managing their display and dismissal.

Object Model

Notifications Class

Syntax

Visual Basic (Declaration)
Public Class Notifications
C#
public class Notifications

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Notifications

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Notifications Class Members

[image]
ActiveReports 19 .NET Edition
Notifications Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Notifications Class

Glossary Item Box

The following tables list the members exposed by Notifications.

Public Methods

 | Name | Description
Public Method | DismissAll | Dismisses all the notifications.
Public Method | Error | Sends an error notification.
Public Method | Info | Sends a general notification. Can be used to notify when any user-initiated action is complete.
Public Method | Send | Sends a notification with the specified level, caption, and content.
Public Method | Warning | Sends a warning notification.
Top

See Also

Reference

Notifications Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Notifications Class Methods

[image]
ActiveReports 19 .NET Edition
Notifications Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Notifications Class

Glossary Item Box

For a list of all members of this type, see Notifications members.

Public Methods

 | Name | Description
Public Method | DismissAll | Dismisses all the notifications.
Public Method | Error | Sends an error notification.
Public Method | Info | Sends a general notification. Can be used to notify when any user-initiated action is complete.
Public Method | Send | Sends a notification with the specified level, caption, and content.
Public Method | Warning | Sends a warning notification.
Top

See Also

Reference

Notifications Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


DismissAll Method

[image]
ActiveReports 19 .NET Edition
DismissAll Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Notifications Class : DismissAll Method

Glossary Item Box

Dismisses all the notifications.

Syntax

Visual Basic (Declaration)
Public Function DismissAll() As Task
C#
public Task DismissAll()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of dismissing all notifications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Class
Notifications Members


Error Method

[image]
ActiveReports 19 .NET Edition
Error Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Notifications Class : Error Method

caption
The error caption.
errorText
Optional error details.

Glossary Item Box

Sends an error notification.

Syntax

Visual Basic (Declaration)
Public Function Error( _
   ByVal caption As String, _
   ByVal errorText As String _
) As Task
C#
public Task Error(
   string caption,
   string errorText
)

Parameters

caption
The error caption.
errorText
Optional error details.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of sending an error notification.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Class
Notifications Members


Info Method

[image]
ActiveReports 19 .NET Edition
Info Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Notifications Class : Info Method

caption
The notification caption.
text
Optional notification content.

Glossary Item Box

Sends a general notification. Can be used to notify when any user-initiated action is complete.

Syntax

Visual Basic (Declaration)
Public Function Info( _
   ByVal caption As String, _
   ByVal text As String _
) As Task
C#
public Task Info(
   string caption,
   string text
)

Parameters

caption
The notification caption.
text
Optional notification content.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of sending a general notification.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Class
Notifications Members


Send Method

[image]
ActiveReports 19 .NET Edition
Send Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Notifications Class : Send Method

level
The notification level. Determines color and icons used for the notifications.
caption
The notification caption. Shown by default when notification pops up, then used as a title in Notification Details view.
content
The notification content. Only visible when Notification Details are open.

Glossary Item Box

Sends a notification with the specified level, caption, and content.

Syntax

Visual Basic (Declaration)
Public Function Send( _
   ByVal level As Level, _
   ByVal caption As String, _
   ByVal content As String _
) As Task
C#
public Task Send(
   Level level,
   string caption,
   string content
)

Parameters

level
The notification level. Determines color and icons used for the notifications.
caption
The notification caption. Shown by default when notification pops up, then used as a title in Notification Details view.
content
The notification content. Only visible when Notification Details are open.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of sending the notification.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Class
Notifications Members


Warning Method

[image]
ActiveReports 19 .NET Edition
Warning Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Notifications Class : Warning Method

caption
The warning caption.
warningText
Optional warning details.

Glossary Item Box

Sends a warning notification.

Syntax

Visual Basic (Declaration)
Public Function Warning( _
   ByVal caption As String, _
   ByVal warningText As String _
) As Task
C#
public Task Warning(
   string caption,
   string warningText
)

Parameters

caption
The warning caption.
warningText
Optional warning details.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of sending a warning notification.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Notifications Class
Notifications Members


OpenButton Class

[image]
ActiveReports 19 .NET Edition
OpenButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenButton Class

Glossary Item Box

Represents the settings for the Open button.

Object Model

OpenButton Class

Syntax

Visual Basic (Declaration)
Public Class OpenButton
C#
public class OpenButton

Remarks

The OpenButton class provides a property to configure the visibility of the Open button in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.OpenButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


OpenButton Class Members

[image]
ActiveReports 19 .NET Edition
OpenButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenButton Class

Glossary Item Box

The following tables list the members exposed by OpenButton.

Public Constructors

 | Name | Description
Public Constructor | OpenButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Open button should be visible.
Top

See Also

Reference

OpenButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


OpenButton Constructor

[image]
ActiveReports 19 .NET Edition
OpenButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenButton Class : OpenButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OpenButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenButton Class
OpenButton Members


OpenButton Class Properties

[image]
ActiveReports 19 .NET Edition
OpenButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenButton Class

Glossary Item Box

For a list of all members of this type, see OpenButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Open button should be visible.
Top

See Also

Reference

OpenButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Open button should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Open button should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenButton Class
OpenButton Members


OpenDocumentInfo Class

[image]
ActiveReports 19 .NET Edition
OpenDocumentInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenDocumentInfo Class

Glossary Item Box

Represents the information about an opened document.

Object Model

OpenDocumentInfo Class

Syntax

Visual Basic (Declaration)
Public Class OpenDocumentInfo
C#
public class OpenDocumentInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.OpenDocumentInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


OpenDocumentInfo Class Members

[image]
ActiveReports 19 .NET Edition
OpenDocumentInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenDocumentInfo Class

Glossary Item Box

The following tables list the members exposed by OpenDocumentInfo.

Public Constructors

 | Name | Description
Public Constructor | OpenDocumentInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the document ID.
Public Property | Name | Gets or sets the document name.
Public Property | Success | Gets or sets a value indicating whether the opening was successful.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

OpenDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


OpenDocumentInfo Constructor

[image]
ActiveReports 19 .NET Edition
OpenDocumentInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenDocumentInfo Class : OpenDocumentInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OpenDocumentInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Class
OpenDocumentInfo Members


OpenDocumentInfo Class Properties

[image]
ActiveReports 19 .NET Edition
OpenDocumentInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : OpenDocumentInfo Class

Glossary Item Box

For a list of all members of this type, see OpenDocumentInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the document ID.
Public Property | Name | Gets or sets the document name.
Public Property | Success | Gets or sets a value indicating whether the opening was successful.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

OpenDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenDocumentInfo Class : Id Property

Glossary Item Box

Gets or sets the document ID.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Class
OpenDocumentInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenDocumentInfo Class : Name Property

Glossary Item Box

Gets or sets the document name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Class
OpenDocumentInfo Members


Success Property

[image]
ActiveReports 19 .NET Edition
Success Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenDocumentInfo Class : Success Property

Glossary Item Box

Gets or sets a value indicating whether the opening was successful.

Syntax

Visual Basic (Declaration)
Public Property Success As Nullable(Of Boolean)
C#
public Nullable<bool> Success {get; set;}

Remarks

Null in OnBefore handlers should be defined in OnAfter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Class
OpenDocumentInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > OpenDocumentInfo Class : Type Property

Glossary Item Box

Gets or sets the document type.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OpenDocumentInfo Class
OpenDocumentInfo Members


Panels Class

[image]
ActiveReports 19 .NET Edition
Panels Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Panels Class

Glossary Item Box

Represents access to the menu and sidebar panels.

Object Model

Panels Class

Syntax

Visual Basic (Declaration)
Public Class Panels
C#
public class Panels

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Panels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Panels Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Panels Class Members

[image]
ActiveReports 19 .NET Edition
Panels Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Panels Class

Glossary Item Box

The following tables list the members exposed by Panels.

Public Properties

 | Name | Description
Public Property | Menu | Gets the menu, providing methods to interact with it.
Public Property | Sidebar | Gets the sidebar, providing methods to interact with it.
Top

See Also

Reference

Panels Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Panels Class Properties

[image]
ActiveReports 19 .NET Edition
Panels Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Panels Class

Glossary Item Box

For a list of all members of this type, see Panels members.

Public Properties

 | Name | Description
Public Property | Menu | Gets the menu, providing methods to interact with it.
Public Property | Sidebar | Gets the sidebar, providing methods to interact with it.
Top

See Also

Reference

Panels Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Menu Property

[image]
ActiveReports 19 .NET Edition
Menu Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Panels Class : Menu Property

Glossary Item Box

Gets the menu, providing methods to interact with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Menu As Menu
C#
public Menu Menu {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Panels Class
Panels Members


Sidebar Property

[image]
ActiveReports 19 .NET Edition
Sidebar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Panels Class : Sidebar Property

Glossary Item Box

Gets the sidebar, providing methods to interact with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sidebar As Sidebar
C#
public Sidebar Sidebar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Panels Class
Panels Members


Parameters Class

[image]
ActiveReports 19 .NET Edition
Parameters Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Parameters Class

Glossary Item Box

Represents the settings for the Parameters section.

Object Model

Parameters Class

Syntax

Visual Basic (Declaration)
Public Class Parameters
C#
public class Parameters

Remarks

The Parameters class provides properties to configure the visibility and modification capability of report parameters within the application.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Parameters Class Members

[image]
ActiveReports 19 .NET Edition
Parameters Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Parameters Class

Glossary Item Box

The following tables list the members exposed by Parameters.

Public Constructors

 | Name | Description
Public Constructor | Parameters Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) report parameters.
Public Property | Visible | Gets or sets a value indicating whether the Parameters section should be shown.
Top

See Also

Reference

Parameters Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Parameters Constructor

[image]
ActiveReports 19 .NET Edition
Parameters Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Parameters Class : Parameters Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Parameters()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Parameters Class Properties

[image]
ActiveReports 19 .NET Edition
Parameters Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Parameters Class

Glossary Item Box

For a list of all members of this type, see Parameters members.

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) report parameters.
Public Property | Visible | Gets or sets a value indicating whether the Parameters section should be shown.
Top

See Also

Reference

Parameters Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CanModify Property

[image]
ActiveReports 19 .NET Edition
CanModify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Parameters Class : CanModify Property

Glossary Item Box

Gets or sets a value indicating whether it is possible to modify (including add, edit, or remove) report parameters.

Syntax

Visual Basic (Declaration)
Public Property CanModify As Nullable(Of Boolean)
C#
public Nullable<bool> CanModify {get; set;}

Property Value

true if report parameters can be modified; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Parameters Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Parameters section should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Parameters section should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


ParametersTab Class

[image]
ActiveReports 19 .NET Edition
ParametersTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ParametersTab Class

Glossary Item Box

Represents the settings for the Parameters tab.

Object Model

ParametersTab Class

Syntax

Visual Basic (Declaration)
Public Class ParametersTab
C#
public class ParametersTab

Remarks

The ParametersTab class provides a property to configure the visibility of the Parameters tab in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ParametersTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ParametersTab Class Members

[image]
ActiveReports 19 .NET Edition
ParametersTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ParametersTab Class

Glossary Item Box

The following tables list the members exposed by ParametersTab.

Public Constructors

 | Name | Description
Public Constructor | ParametersTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Parameters tab should be visible.
Top

See Also

Reference

ParametersTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ParametersTab Constructor

[image]
ActiveReports 19 .NET Edition
ParametersTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ParametersTab Class : ParametersTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParametersTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersTab Class
ParametersTab Members


ParametersTab Class Properties

[image]
ActiveReports 19 .NET Edition
ParametersTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ParametersTab Class

Glossary Item Box

For a list of all members of this type, see ParametersTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Parameters tab should be visible.
Top

See Also

Reference

ParametersTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ParametersTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Parameters tab should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Parameters tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersTab Class
ParametersTab Members


PreviewSettings Class

[image]
ActiveReports 19 .NET Edition
PreviewSettings Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PreviewSettings Class

Glossary Item Box

Represents settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.

Object Model

PreviewSettings Class

Syntax

Visual Basic (Declaration)
Public Class PreviewSettings
C#
public class PreviewSettings

Example

C# Copy Code
private PreviewSettings _preview;
public Index()
{
    _preview = new PreviewSettings()
    {
        CanPreview = true,
        OpenViewer = OpenViewer
    };
}

private async void OpenViewer(ViewerSettings settings)
{
    if (_viewer != null)
    {
        await _viewer.OpenReport(settings.DocumentInfo.Id);
        return;
    }
    _viewer = new ReportViewer();
    var initOptions = new InitializationOptions();
    initOptions.ReportID = settings.DocumentInfo.Id;
    await _viewer.Render(JSRuntime, settings.Element, initOptions);
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.PreviewSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


PreviewSettings Class Members

[image]
ActiveReports 19 .NET Edition
PreviewSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PreviewSettings Class

Glossary Item Box

The following tables list the members exposed by PreviewSettings.

Public Constructors

 | Name | Description
Public Constructor | PreviewSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanPreview | Gets or sets a value indicating whether the Preview button should be shown.
Public Property | OpenViewer | Gets or sets a function to plug in a viewer component, which will be called when the preview is opened.
Top

See Also

Reference

PreviewSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


PreviewSettings Constructor

[image]
ActiveReports 19 .NET Edition
PreviewSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PreviewSettings Class : PreviewSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PreviewSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewSettings Class
PreviewSettings Members


PreviewSettings Class Properties

[image]
ActiveReports 19 .NET Edition
PreviewSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PreviewSettings Class

Glossary Item Box

For a list of all members of this type, see PreviewSettings members.

Public Properties

 | Name | Description
Public Property | CanPreview | Gets or sets a value indicating whether the Preview button should be shown.
Public Property | OpenViewer | Gets or sets a function to plug in a viewer component, which will be called when the preview is opened.
Top

See Also

Reference

PreviewSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CanPreview Property

[image]
ActiveReports 19 .NET Edition
CanPreview Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PreviewSettings Class : CanPreview Property

Glossary Item Box

Gets or sets a value indicating whether the Preview button should be shown.

Syntax

Visual Basic (Declaration)
Public Property CanPreview As Nullable(Of Boolean)
C#
public Nullable<bool> CanPreview {get; set;}

Property Value

If set to true, the preview button will be displayed, allowing users to preview the document. If set to false or null, the preview button will be hidden.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewSettings Class
PreviewSettings Members


OpenViewer Property

[image]
ActiveReports 19 .NET Edition
OpenViewer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PreviewSettings Class : OpenViewer Property

Glossary Item Box

Gets or sets a function to plug in a viewer component, which will be called when the preview is opened.

Syntax

Visual Basic (Declaration)
Public Property OpenViewer As Action(Of ViewerSettings)
C#
public Action<ViewerSettings> OpenViewer {get; set;}

Property Value

This function receives a ViewerSettings object containing information about the viewer configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewSettings Class
PreviewSettings Members


PropertiesModeButton Class

[image]
ActiveReports 19 .NET Edition
PropertiesModeButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesModeButton Class

Glossary Item Box

Represents the settings for the properties mode button.

Object Model

PropertiesModeButton Class

Syntax

Visual Basic (Declaration)
Public Class PropertiesModeButton
C#
public class PropertiesModeButton

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.PropertiesModeButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesModeButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertiesModeButton Class Members

[image]
ActiveReports 19 .NET Edition
PropertiesModeButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesModeButton Class

Glossary Item Box

The following tables list the members exposed by PropertiesModeButton.

Public Constructors

 | Name | Description
Public Constructor | PropertiesModeButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the properties mode dropdown should be shown.
Top

See Also

Reference

PropertiesModeButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertiesModeButton Constructor

[image]
ActiveReports 19 .NET Edition
PropertiesModeButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertiesModeButton Class : PropertiesModeButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PropertiesModeButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesModeButton Class
PropertiesModeButton Members


PropertiesModeButton Class Properties

[image]
ActiveReports 19 .NET Edition
PropertiesModeButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesModeButton Class

Glossary Item Box

For a list of all members of this type, see PropertiesModeButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the properties mode dropdown should be shown.
Top

See Also

Reference

PropertiesModeButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertiesModeButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the properties mode dropdown should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the properties mode dropdown should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesModeButton Class
PropertiesModeButton Members


PropertiesTab Class

[image]
ActiveReports 19 .NET Edition
PropertiesTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesTab Class

Glossary Item Box

Represents the settings for the Properties tab.

Object Model

PropertiesTab Class

Syntax

Visual Basic (Declaration)
Public Class PropertiesTab
C#
public class PropertiesTab

Remarks

The PropertiesTab class provides a property to configure the visibility of the Properties tab.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.PropertiesTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertiesTab Class Members

[image]
ActiveReports 19 .NET Edition
PropertiesTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesTab Class

Glossary Item Box

The following tables list the members exposed by PropertiesTab.

Public Constructors

 | Name | Description
Public Constructor | PropertiesTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Properties tab should be shown.
Top

See Also

Reference

PropertiesTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertiesTab Constructor

[image]
ActiveReports 19 .NET Edition
PropertiesTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertiesTab Class : PropertiesTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PropertiesTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesTab Class
PropertiesTab Members


PropertiesTab Class Properties

[image]
ActiveReports 19 .NET Edition
PropertiesTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertiesTab Class

Glossary Item Box

For a list of all members of this type, see PropertiesTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Properties tab should be shown.
Top

See Also

Reference

PropertiesTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertiesTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Properties tab should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Properties tab should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertiesTab Class
PropertiesTab Members


PropertyGridSettings Class

[image]
ActiveReports 19 .NET Edition
PropertyGridSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertyGridSettings Class

Glossary Item Box

Represents the settings for the Property Grid, allowing the viewing and editing of properties of selected objects.

Object Model

PropertyGridSettings Class

Syntax

Visual Basic (Declaration)
Public Class PropertyGridSettings
C#
public class PropertyGridSettings

Remarks

The PropertyGridSettings class provides properties to configure the visibility of the Properties tab, the default properties mode, and the properties sort mode.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.PropertyGridSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyGridSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertyGridSettings Class Members

[image]
ActiveReports 19 .NET Edition
PropertyGridSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertyGridSettings Class

Glossary Item Box

The following tables list the members exposed by PropertyGridSettings.

Public Constructors

 | Name | Description
Public Constructor | PropertyGridSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Mode | Gets or sets the default properties mode.
Public Property | PropertiesTab | Gets or sets the Properties tab settings.
Public Property | Sort | Gets or sets the default properties sort mode.
Top

See Also

Reference

PropertyGridSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertyGridSettings Constructor

[image]
ActiveReports 19 .NET Edition
PropertyGridSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertyGridSettings Class : PropertyGridSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PropertyGridSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyGridSettings Class
PropertyGridSettings Members


PropertyGridSettings Class Properties

[image]
ActiveReports 19 .NET Edition
PropertyGridSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PropertyGridSettings Class

Glossary Item Box

For a list of all members of this type, see PropertyGridSettings members.

Public Properties

 | Name | Description
Public Property | Mode | Gets or sets the default properties mode.
Public Property | PropertiesTab | Gets or sets the Properties tab settings.
Public Property | Sort | Gets or sets the default properties sort mode.
Top

See Also

Reference

PropertyGridSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Mode Property

[image]
ActiveReports 19 .NET Edition
Mode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertyGridSettings Class : Mode Property

Glossary Item Box

Gets or sets the default properties mode.

Syntax

Visual Basic (Declaration)
Public Property Mode As Nullable(Of Mode)
C#
public Nullable<Mode> Mode {get; set;}

Property Value

A nullable Mode value that specifies the default properties mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyGridSettings Class
PropertyGridSettings Members


PropertiesTab Property

[image]
ActiveReports 19 .NET Edition
PropertiesTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertyGridSettings Class : PropertiesTab Property

Glossary Item Box

Gets or sets the Properties tab settings.

Syntax

Visual Basic (Declaration)
Public Property PropertiesTab As PropertiesTab
C#
public PropertiesTab PropertiesTab {get; set;}

Property Value

An instance of PropertiesTab that contains the settings for the Properties tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyGridSettings Class
PropertyGridSettings Members


Sort Property

[image]
ActiveReports 19 .NET Edition
Sort Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > PropertyGridSettings Class : Sort Property

Glossary Item Box

Gets or sets the default properties sort mode.

Syntax

Visual Basic (Declaration)
Public Property Sort As Nullable(Of Sort)
C#
public Nullable<Sort> Sort {get; set;}

Property Value

A nullable Sort value that specifies the default properties sort mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyGridSettings Class
PropertyGridSettings Members


RdlxReportItemsSettings Class

[image]
ActiveReports 19 .NET Edition
RdlxReportItemsSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxReportItemsSettings Class

Glossary Item Box

Represents the customizable features for various report items in RDLX.

Object Model

RdlxReportItemsSettings Class

Syntax

Visual Basic (Declaration)
Public Class RdlxReportItemsSettings
C#
public class RdlxReportItemsSettings

Remarks

The RdlxReportItemsSettings class provides properties to configure the features for barcode, table, and tablix items in RDLX.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.RdlxReportItemsSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxReportItemsSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxReportItemsSettings Class Members

[image]
ActiveReports 19 .NET Edition
RdlxReportItemsSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxReportItemsSettings Class

Glossary Item Box

The following tables list the members exposed by RdlxReportItemsSettings.

Public Constructors

 | Name | Description
Public Constructor | RdlxReportItemsSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Barcode | Gets or sets the features for barcode items.
Public Property | Table | Gets or sets the features for table items.
Public Property | Tablix | Gets or sets the features for tablix items.
Top

See Also

Reference

RdlxReportItemsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxReportItemsSettings Constructor

[image]
ActiveReports 19 .NET Edition
RdlxReportItemsSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxReportItemsSettings Class : RdlxReportItemsSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RdlxReportItemsSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxReportItemsSettings Class
RdlxReportItemsSettings Members


RdlxReportItemsSettings Class Properties

[image]
ActiveReports 19 .NET Edition
RdlxReportItemsSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxReportItemsSettings Class

Glossary Item Box

For a list of all members of this type, see RdlxReportItemsSettings members.

Public Properties

 | Name | Description
Public Property | Barcode | Gets or sets the features for barcode items.
Public Property | Table | Gets or sets the features for table items.
Public Property | Tablix | Gets or sets the features for tablix items.
Top

See Also

Reference

RdlxReportItemsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Barcode Property

[image]
ActiveReports 19 .NET Edition
Barcode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxReportItemsSettings Class : Barcode Property

Glossary Item Box

Gets or sets the features for barcode items.

Syntax

Visual Basic (Declaration)
Public Property Barcode As Barcore
C#
public Barcore Barcode {get; set;}

Property Value

An instance of Barcore that contains the features for barcode items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxReportItemsSettings Class
RdlxReportItemsSettings Members


Table Property

[image]
ActiveReports 19 .NET Edition
Table Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxReportItemsSettings Class : Table Property

Glossary Item Box

Gets or sets the features for table items.

Syntax

Visual Basic (Declaration)
Public Property Table As Table
C#
public Table Table {get; set;}

Property Value

An instance of Table that contains the features for table items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxReportItemsSettings Class
RdlxReportItemsSettings Members


Tablix Property

[image]
ActiveReports 19 .NET Edition
Tablix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxReportItemsSettings Class : Tablix Property

Glossary Item Box

Gets or sets the features for tablix items.

Syntax

Visual Basic (Declaration)
Public Property Tablix As Tablix
C#
public Tablix Tablix {get; set;}

Property Value

An instance of Tablix that contains the features for tablix items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxReportItemsSettings Class
RdlxReportItemsSettings Members


RdlxSettings Class

[image]
ActiveReports 19 .NET Edition
RdlxSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxSettings Class

Glossary Item Box

Represents the settings specific to the RDLX platform.

Object Model

RdlxSettings Class

Syntax

Visual Basic (Declaration)
Public Class RdlxSettings
C#
public class RdlxSettings

Remarks

The RdlxSettings class provides properties to configure various settings for the RDLX platform, including expression syntax, toolbox content, templates, report item features, styles, and specific report settings.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.RdlxSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxSettings Class Members

[image]
ActiveReports 19 .NET Edition
RdlxSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxSettings Class

Glossary Item Box

The following tables list the members exposed by RdlxSettings.

Public Constructors

 | Name | Description
Public Constructor | RdlxSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Dashboard | Gets or sets the RDL Dashboard settings.
Public Property | ExpressionSyntax | Gets or sets the expression syntax used in Designer.
Public Property | Fpl | Gets or sets the FPL settings.
Public Property | InitTemplates | Gets or sets the reports as RDLX-JSON strings, with report items from these reports used as templates for creating new items.
Public Property | MasterReports | Gets or sets the RDL MasterReport settings.
Public Property | Msl | Gets or sets the RDL Multi-Section (MSL) settings.
Public Property | ReportItemsFeatures | Gets or sets the customizable report item features.
Public Property | ReportParts | Gets or sets the Report Parts settings.
Public Property | ReportStyles | Gets or sets the additional styles to add to report item styles.
Public Property | ToolBoxContent | Gets or sets the report items available and their order.
Top

See Also

Reference

RdlxSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxSettings Constructor

[image]
ActiveReports 19 .NET Edition
RdlxSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : RdlxSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RdlxSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


RdlxSettings Class Properties

[image]
ActiveReports 19 .NET Edition
RdlxSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxSettings Class

Glossary Item Box

For a list of all members of this type, see RdlxSettings members.

Public Properties

 | Name | Description
Public Property | Dashboard | Gets or sets the RDL Dashboard settings.
Public Property | ExpressionSyntax | Gets or sets the expression syntax used in Designer.
Public Property | Fpl | Gets or sets the FPL settings.
Public Property | InitTemplates | Gets or sets the reports as RDLX-JSON strings, with report items from these reports used as templates for creating new items.
Public Property | MasterReports | Gets or sets the RDL MasterReport settings.
Public Property | Msl | Gets or sets the RDL Multi-Section (MSL) settings.
Public Property | ReportItemsFeatures | Gets or sets the customizable report item features.
Public Property | ReportParts | Gets or sets the Report Parts settings.
Public Property | ReportStyles | Gets or sets the additional styles to add to report item styles.
Public Property | ToolBoxContent | Gets or sets the report items available and their order.
Top

See Also

Reference

RdlxSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Dashboard Property

[image]
ActiveReports 19 .NET Edition
Dashboard Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : Dashboard Property

Glossary Item Box

Gets or sets the RDL Dashboard settings.

Syntax

Visual Basic (Declaration)
Public Property Dashboard As Dashboard
C#
public Dashboard Dashboard {get; set;}

Property Value

An instance of Dashboard that contains the Dashboard settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ExpressionSyntax Property

[image]
ActiveReports 19 .NET Edition
ExpressionSyntax Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : ExpressionSyntax Property

Glossary Item Box

Gets or sets the expression syntax used in Designer.

Syntax

Visual Basic (Declaration)
Public Property ExpressionSyntax As Nullable(Of ExpressionSyntax)
C#
public Nullable<ExpressionSyntax> ExpressionSyntax {get; set;}

Property Value

A nullable ExpressionSyntax value that specifies the expression syntax.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


Fpl Property

[image]
ActiveReports 19 .NET Edition
Fpl Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : Fpl Property

Glossary Item Box

Gets or sets the FPL settings.

Syntax

Visual Basic (Declaration)
Public Property Fpl As Fpl
C#
public Fpl Fpl {get; set;}

Property Value

An instance of Fpl that contains the FPL settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


InitTemplates Property

[image]
ActiveReports 19 .NET Edition
InitTemplates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : InitTemplates Property

Glossary Item Box

Gets or sets the reports as RDLX-JSON strings, with report items from these reports used as templates for creating new items.

Syntax

Visual Basic (Declaration)
Public Property InitTemplates As InitTemplates
C#
public InitTemplates InitTemplates {get; set;}

Property Value

An instance of InitTemplates that contains the RDLX-JSON strings for templates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


MasterReports Property

[image]
ActiveReports 19 .NET Edition
MasterReports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : MasterReports Property

Glossary Item Box

Gets or sets the RDL MasterReport settings.

Syntax

Visual Basic (Declaration)
Public Property MasterReports As MasterReport
C#
public MasterReport MasterReports {get; set;}

Property Value

An instance of MasterReport that contains the MasterReport settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


Msl Property

[image]
ActiveReports 19 .NET Edition
Msl Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : Msl Property

Glossary Item Box

Gets or sets the RDL Multi-Section (MSL) settings.

Syntax

Visual Basic (Declaration)
Public Property Msl As Msl
C#
public Msl Msl {get; set;}

Property Value

An instance of Msl that contains the MSL settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ReportItemsFeatures Property

[image]
ActiveReports 19 .NET Edition
ReportItemsFeatures Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : ReportItemsFeatures Property

Glossary Item Box

Gets or sets the customizable report item features.

Syntax

Visual Basic (Declaration)
Public Property ReportItemsFeatures As RdlxReportItemsSettings
C#
public RdlxReportItemsSettings ReportItemsFeatures {get; set;}

Property Value

An instance of RdlxReportItemsSettings that contains the customizable report item features.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ReportParts Property

[image]
ActiveReports 19 .NET Edition
ReportParts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : ReportParts Property

Glossary Item Box

Gets or sets the Report Parts settings.

Syntax

Visual Basic (Declaration)
Public Property ReportParts As ReportPartsSettings
C#
public ReportPartsSettings ReportParts {get; set;}

Property Value

An instance of ReportPartsSettings that contains the Report Parts settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ReportStyles Property

[image]
ActiveReports 19 .NET Edition
ReportStyles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : ReportStyles Property

Glossary Item Box

Gets or sets the additional styles to add to report item styles.

Syntax

Visual Basic (Declaration)
Public Property ReportStyles As ReportStyles()
C#
public ReportStyles[] ReportStyles {get; set;}

Property Value

An array of ReportStyles that contains the additional styles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ToolBoxContent Property

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RdlxSettings Class : ToolBoxContent Property

Glossary Item Box

Gets or sets the report items available and their order.

Syntax

Visual Basic (Declaration)
Public Property ToolBoxContent As ToolBoxContent
C#
public ToolBoxContent ToolBoxContent {get; set;}

Property Value

An instance of ToolBoxContent that contains the report items and their order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxSettings Class
RdlxSettings Members


ReportDesigner Class

[image]
ActiveReports 19 .NET Edition
ReportDesigner Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportDesigner Class

Glossary Item Box

Object Model

ReportDesigner Class

Syntax

Visual Basic (Declaration)
Public Class ReportDesigner
   Inherits Microsoft.AspNetCore.Components.ComponentBase
   Implements Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent
C#
public class ReportDesigner : Microsoft.AspNetCore.Components.ComponentBase, Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent

Inheritance Hierarchy

System.Object
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Designer.ReportDesigner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportDesigner Class Members

[image]
ActiveReports 19 .NET Edition
ReportDesigner Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportDesigner Class

Glossary Item Box

The following tables list the members exposed by ReportDesigner.

Public Constructors

 | Name | Description
Public Constructor | ReportDesigner Constructor |
Top

Public Properties

 | Name | Description
Public Property | App | Gets the application-level functionalities, allowing interaction with various aspects such as documentation, focus management, menu panels, and editor actions.
Public Property | AppBarSettings | Gets or sets the settings for the App Bar, providing quick access to common actions and controls.
Public Property | DataSettings | Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.
Public Property | DateFormats | Gets or sets the list of supported date formats.
Public Property | DesignerInitialized | Gets or sets the callback that is invoked when a Designer is initialized.
Public Property | DisableFocusTimer | Gets or sets a value indicating whether focused elements are permanently highlighted.
Public Property | DisableSystemClipboard | Gets or sets a value indicating whether to disable usage of the system clipboard.
Public Property | Document | Gets or sets the document to open on app startup.
Public Property | Documents | Gets the methods for managing documents, allowing the creation, opening, saving, and status checking of reports being edited.
Public Property | DocumentsSettings | Gets or sets settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.
Public Property | Fonts | Gets or sets the list of fonts displayed in Font property editors all over Designer.
Public Property | Height | Gets or sets the height of the Designer component.
Public Property | ImageMimeTypes | Gets or sets the list of supported image mime-types.
Public Property | Language | Gets or sets the language to use for the Designer.
Public Property | LocalizationResources | Gets or sets localization resources for a specific language.
Public Property | LockLayout | Gets or sets a value indicating whether LockLayout is enabled
Public Property | MenuSettings | Gets or sets the settings for the Main Menu, providing access to various features and tools.
Public Property | Notifications | Gets the methods for sending and managing notifications, allowing the sending of notifications of various levels (info, warning, error) and managing their display and dismissal.
Public Property | PreviewSettings | Gets or sets settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.
Public Property | PropertyGridSettings | Gets or sets the settings for the Property Grid, allowing the viewing and editing of properties of selected objects.
Public Property | RdlxSettings | Gets or sets settings specific to the RDLX platform.
Public Property | RpxSettings | Gets or sets settings specific to the RPX platform.
Public Property | ServerSettings | Gets or sets settings related to the backend server, including the base URL and request modification handlers.
Public Property | StatusBarSettings | Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.
Public Property | StoreUnsavedReport | Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.
Public Property | StoreUserPreferences | Gets or sets a value indicating whether user preferences will be saved to browser storage.
Public Property | StylesSettings | Gets or sets settings related to RPX Styles.
Public Property | Themes | Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.
Public Property | TitleSettings | Gets or sets settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.
Public Property | ToolBarSettings | Gets or sets settings for the Tool Bar
Public Property | Units | Gets or sets the default measurement units.
Public Property | Width | Gets or sets the width of the Designer component.
Top

See Also

Reference

ReportDesigner Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportDesigner Constructor

[image]
ActiveReports 19 .NET Edition
ReportDesigner Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : ReportDesigner Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportDesigner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


ReportDesigner Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDesigner Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportDesigner Class

Glossary Item Box

For a list of all members of this type, see ReportDesigner members.

Public Properties

 | Name | Description
Public Property | App | Gets the application-level functionalities, allowing interaction with various aspects such as documentation, focus management, menu panels, and editor actions.
Public Property | AppBarSettings | Gets or sets the settings for the App Bar, providing quick access to common actions and controls.
Public Property | DataSettings | Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.
Public Property | DateFormats | Gets or sets the list of supported date formats.
Public Property | DesignerInitialized | Gets or sets the callback that is invoked when a Designer is initialized.
Public Property | DisableFocusTimer | Gets or sets a value indicating whether focused elements are permanently highlighted.
Public Property | DisableSystemClipboard | Gets or sets a value indicating whether to disable usage of the system clipboard.
Public Property | Document | Gets or sets the document to open on app startup.
Public Property | Documents | Gets the methods for managing documents, allowing the creation, opening, saving, and status checking of reports being edited.
Public Property | DocumentsSettings | Gets or sets settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.
Public Property | Fonts | Gets or sets the list of fonts displayed in Font property editors all over Designer.
Public Property | Height | Gets or sets the height of the Designer component.
Public Property | ImageMimeTypes | Gets or sets the list of supported image mime-types.
Public Property | Language | Gets or sets the language to use for the Designer.
Public Property | LocalizationResources | Gets or sets localization resources for a specific language.
Public Property | LockLayout | Gets or sets a value indicating whether LockLayout is enabled
Public Property | MenuSettings | Gets or sets the settings for the Main Menu, providing access to various features and tools.
Public Property | Notifications | Gets the methods for sending and managing notifications, allowing the sending of notifications of various levels (info, warning, error) and managing their display and dismissal.
Public Property | PreviewSettings | Gets or sets settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.
Public Property | PropertyGridSettings | Gets or sets the settings for the Property Grid, allowing the viewing and editing of properties of selected objects.
Public Property | RdlxSettings | Gets or sets settings specific to the RDLX platform.
Public Property | RpxSettings | Gets or sets settings specific to the RPX platform.
Public Property | ServerSettings | Gets or sets settings related to the backend server, including the base URL and request modification handlers.
Public Property | StatusBarSettings | Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.
Public Property | StoreUnsavedReport | Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.
Public Property | StoreUserPreferences | Gets or sets a value indicating whether user preferences will be saved to browser storage.
Public Property | StylesSettings | Gets or sets settings related to RPX Styles.
Public Property | Themes | Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.
Public Property | TitleSettings | Gets or sets settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.
Public Property | ToolBarSettings | Gets or sets settings for the Tool Bar
Public Property | Units | Gets or sets the default measurement units.
Public Property | Width | Gets or sets the width of the Designer component.
Top

See Also

Reference

ReportDesigner Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


App Property

[image]
ActiveReports 19 .NET Edition
App Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : App Property

Glossary Item Box

Gets the application-level functionalities, allowing interaction with various aspects such as documentation, focus management, menu panels, and editor actions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property App As App
C#
public App App {get;}

Remarks

These properties can only be accessed after the Designer has been initialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


AppBarSettings Property

[image]
ActiveReports 19 .NET Edition
AppBarSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : AppBarSettings Property

Glossary Item Box

Gets or sets the settings for the App Bar, providing quick access to common actions and controls.

Syntax

Visual Basic (Declaration)
Public Property AppBarSettings As AppBarSettings
C#
public AppBarSettings AppBarSettings {get; set;}

Property Value

An AppBarSettings object representing the settings for the App Bar.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DataSettings Property

[image]
ActiveReports 19 .NET Edition
DataSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DataSettings Property

Glossary Item Box

Gets or sets the settings related to data management, including configurations for data sources, data sets, parameters, and common values.

Syntax

Visual Basic (Declaration)
Public Property DataSettings As DataSettings
C#
public DataSettings DataSettings {get; set;}

Property Value

An DataSettings object representing the settings related to data management.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DateFormats Property

[image]
ActiveReports 19 .NET Edition
DateFormats Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DateFormats Property

Glossary Item Box

Gets or sets the list of supported date formats.

Syntax

Visual Basic (Declaration)
Public Property DateFormats As String()
C#
public string[] DateFormats {get; set;}

Property Value

An array of System.String representing the supported date formats.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DesignerInitialized Property

[image]
ActiveReports 19 .NET Edition
DesignerInitialized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DesignerInitialized Property

Glossary Item Box

Gets or sets the callback that is invoked when a Designer is initialized.

Syntax

Visual Basic (Declaration)
Public Property DesignerInitialized As Action
C#
public Action DesignerInitialized {get; set;}

Property Value

An System.Action representing the callback that is invoked when a Designer is initialized.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DisableFocusTimer Property

[image]
ActiveReports 19 .NET Edition
DisableFocusTimer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DisableFocusTimer Property

Glossary Item Box

Gets or sets a value indicating whether focused elements are permanently highlighted.

Syntax

Visual Basic (Declaration)
Public Property DisableFocusTimer As Boolean
C#
public bool DisableFocusTimer {get; set;}

Property Value

A System.Boolean indicating if focused elements are permanently highlighted.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. By default, focused elements (like buttons) are highlighted only for a small period of time after the Tab key was pressed. This setting makes focused elements permanently highlighted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DisableSystemClipboard Property

[image]
ActiveReports 19 .NET Edition
DisableSystemClipboard Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DisableSystemClipboard Property

Glossary Item Box

Gets or sets a value indicating whether to disable usage of the system clipboard.

Syntax

Visual Basic (Declaration)
Public Property DisableSystemClipboard As Boolean
C#
public bool DisableSystemClipboard {get; set;}

Property Value

A System.Boolean indicating if the system clipboard usage is disabled.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. Copy-paste between designer instances will work only in the same browser in the same domain.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Document Property

Glossary Item Box

Gets or sets the document to open on app startup.

Syntax

Visual Basic (Declaration)
Public Property Document As Document
C#
public Document Document {get; set;}

Property Value

A Document representing the document to open on app startup.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. If not set, a new empty document will be created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Documents Property

[image]
ActiveReports 19 .NET Edition
Documents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Documents Property

Glossary Item Box

Gets the methods for managing documents, allowing the creation, opening, saving, and status checking of reports being edited.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Documents As Documents
C#
public Documents Documents {get;}

Remarks

These properties can only be accessed after the Designer has been initialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


DocumentsSettings Property

[image]
ActiveReports 19 .NET Edition
DocumentsSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : DocumentsSettings Property

Glossary Item Box

Gets or sets settings and handlers for managing documents, including settings for the File View tab and event handlers for document-related actions.

Syntax

Visual Basic (Declaration)
Public Property DocumentsSettings As DocumentsSettings
C#
public DocumentsSettings DocumentsSettings {get; set;}

Property Value

An DocumentsSettings object representing the settings and handlers for managing documents.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Fonts Property

Glossary Item Box

Gets or sets the list of fonts displayed in Font property editors all over Designer.

Syntax

Visual Basic (Declaration)
Public Property Fonts As Object()
C#
public object[] Fonts {get; set;}

Property Value

An array of System.Object representing the fonts.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Height Property

Glossary Item Box

Gets or sets the height of the Designer component.

Syntax

Visual Basic (Declaration)
Public Property Height As String
C#
public string Height {get; set;}

Property Value

A System.String representing the height of the Designer. Accepts CSS units such as "px", "%", "em", etc.

Remarks

The default value is "100%".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


ImageMimeTypes Property

[image]
ActiveReports 19 .NET Edition
ImageMimeTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : ImageMimeTypes Property

Glossary Item Box

Gets or sets the list of supported image mime-types.

Syntax

Visual Basic (Declaration)
Public Property ImageMimeTypes As String()
C#
public string[] ImageMimeTypes {get; set;}

Property Value

An array of System.String representing the supported image mime-types.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Language Property

Glossary Item Box

Gets or sets the language to use for the Designer.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Property Value

A System.String representing the language code (e.g., "en", "ja").

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


LocalizationResources Property

[image]
ActiveReports 19 .NET Edition
LocalizationResources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : LocalizationResources Property

Glossary Item Box

Gets or sets localization resources for a specific language.

Syntax

Visual Basic (Declaration)
Public Property LocalizationResources As LocalizationResources()
C#
public LocalizationResources[] LocalizationResources {get; set;}

Property Value

An array of LocalizationResources objects representing the localization resources.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


LockLayout Property

[image]
ActiveReports 19 .NET Edition
LockLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : LockLayout Property

Glossary Item Box

Gets or sets a value indicating whether LockLayout is enabled

Syntax

Visual Basic (Declaration)
Public Property LockLayout As Boolean
C#
public bool LockLayout {get; set;}

Property Value

A System.Boolean indicating if LockLayout is enabled.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. When LockLayout is enabled, it is only possible to modify properties of existing report items. I.e., adding a new report item or deleting of an existing one is not possible as well as other operations that modify report layout structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


MenuSettings Property

[image]
ActiveReports 19 .NET Edition
MenuSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : MenuSettings Property

Glossary Item Box

Gets or sets the settings for the Main Menu, providing access to various features and tools.

Syntax

Visual Basic (Declaration)
Public Property MenuSettings As MenuSettings
C#
public MenuSettings MenuSettings {get; set;}

Property Value

An MenuSettings object representing the settings for the Main Menu.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Notifications Property

[image]
ActiveReports 19 .NET Edition
Notifications Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Notifications Property

Glossary Item Box

Gets the methods for sending and managing notifications, allowing the sending of notifications of various levels (info, warning, error) and managing their display and dismissal.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Notifications As Notifications
C#
public Notifications Notifications {get;}

Remarks

These properties can only be accessed after the Designer has been initialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


PreviewSettings Property

[image]
ActiveReports 19 .NET Edition
PreviewSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : PreviewSettings Property

Glossary Item Box

Gets or sets settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.

Syntax

Visual Basic (Declaration)
Public Property PreviewSettings As PreviewSettings
C#
public PreviewSettings PreviewSettings {get; set;}

Property Value

A PreviewSettings object representing the settings related to the document preview functionality.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


PropertyGridSettings Property

[image]
ActiveReports 19 .NET Edition
PropertyGridSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : PropertyGridSettings Property

Glossary Item Box

Gets or sets the settings for the Property Grid, allowing the viewing and editing of properties of selected objects.

Syntax

Visual Basic (Declaration)
Public Property PropertyGridSettings As PropertyGridSettings
C#
public PropertyGridSettings PropertyGridSettings {get; set;}

Property Value

An PropertyGridSettings object representing the settings for the Property Grid.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


RdlxSettings Property

[image]
ActiveReports 19 .NET Edition
RdlxSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : RdlxSettings Property

Glossary Item Box

Gets or sets settings specific to the RDLX platform.

Syntax

Visual Basic (Declaration)
Public Property RdlxSettings As RdlxSettings
C#
public RdlxSettings RdlxSettings {get; set;}

Property Value

A RdlxSettings object representing the settings specific to the RDLX platform.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


RpxSettings Property

[image]
ActiveReports 19 .NET Edition
RpxSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : RpxSettings Property

Glossary Item Box

Gets or sets settings specific to the RPX platform.

Syntax

Visual Basic (Declaration)
Public Property RpxSettings As RpxSettings
C#
public RpxSettings RpxSettings {get; set;}

Property Value

A RpxSettings object representing the settings specific to the RPX platform.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


ServerSettings Property

[image]
ActiveReports 19 .NET Edition
ServerSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : ServerSettings Property

Glossary Item Box

Gets or sets settings related to the backend server, including the base URL and request modification handlers.

Syntax

Visual Basic (Declaration)
Public Property ServerSettings As ServerSettings
C#
public ServerSettings ServerSettings {get; set;}

Property Value

A ServerSettings object representing the settings related to the backend server.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


StatusBarSettings Property

[image]
ActiveReports 19 .NET Edition
StatusBarSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : StatusBarSettings Property

Glossary Item Box

Gets or sets the settings for the Status Bar, providing various controls and information at the bottom of the designer.

Syntax

Visual Basic (Declaration)
Public Property StatusBarSettings As StatusBarSettings
C#
public StatusBarSettings StatusBarSettings {get; set;}

Property Value

An StatusBarSettings object representing the settings for the Status Bar.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


StoreUnsavedReport Property

[image]
ActiveReports 19 .NET Edition
StoreUnsavedReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : StoreUnsavedReport Property

Glossary Item Box

Gets or sets a value indicating whether the last unsaved report can be restored if the browser tab or browser itself gets accidentally closed.

Syntax

Visual Basic (Declaration)
Public Property StoreUnsavedReport As Boolean
C#
public bool StoreUnsavedReport {get; set;}

Property Value

A System.Boolean indicating if the last unsaved report can be restored.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


StoreUserPreferences Property

[image]
ActiveReports 19 .NET Edition
StoreUserPreferences Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : StoreUserPreferences Property

Glossary Item Box

Gets or sets a value indicating whether user preferences will be saved to browser storage.

Syntax

Visual Basic (Declaration)
Public Property StoreUserPreferences As Boolean
C#
public bool StoreUserPreferences {get; set;}

Property Value

A System.Boolean indicating if user preferences will be saved to browser storage.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


StylesSettings Property

[image]
ActiveReports 19 .NET Edition
StylesSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : StylesSettings Property

Glossary Item Box

Gets or sets settings related to RPX Styles.

Syntax

Visual Basic (Declaration)
Public Property StylesSettings As StylesSettings
C#
public StylesSettings StylesSettings {get; set;}

Property Value

An StylesSettings object representing the settings related to RPX Styles.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Themes Property

Glossary Item Box

Gets or sets the settings for themes, allowing configuration of the default theme, available themes for user selection, and settings for the theme selector.

Syntax

Visual Basic (Declaration)
Public Property Themes As ThemeSettings
C#
public ThemeSettings Themes {get; set;}

Property Value

A GrapeCity.ActiveReports.Blazor.Viewer.ThemeSettings object representing the settings for themes.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


TitleSettings Property

[image]
ActiveReports 19 .NET Edition
TitleSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : TitleSettings Property

Glossary Item Box

Gets or sets settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.

Syntax

Visual Basic (Declaration)
Public Property TitleSettings As TitleSettings
C#
public TitleSettings TitleSettings {get; set;}

Property Value

A TitleSettings object representing the settings related to the document title.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


ToolBarSettings Property

[image]
ActiveReports 19 .NET Edition
ToolBarSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : ToolBarSettings Property

Glossary Item Box

Gets or sets settings for the Tool Bar

Syntax

Visual Basic (Declaration)
Public Property ToolBarSettings As ToolBarSettings
C#
public ToolBarSettings ToolBarSettings {get; set;}

Property Value

A ToolBarSettings object representing the settings for the Tool Bar.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Units Property

[image]
ActiveReports 19 .NET Edition
Units Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Units Property

Glossary Item Box

Gets or sets the default measurement units.

Syntax

Visual Basic (Declaration)
Public Property Units As Units
C#
public Units Units {get; set;}

Property Value

An Units enum representing the default measurement units.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : Width Property

Glossary Item Box

Gets or sets the width of the Designer component.

Syntax

Visual Basic (Declaration)
Public Property Width As String
C#
public string Width {get; set;}

Property Value

A System.String representing the width of the Designer. Accepts CSS units such as "px", "%", "em", etc.

Remarks

The default value is "100%".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


ReportItemStyle<T> Class

T
The type of the content for the style.
[image]
ActiveReports 19 .NET Edition
ReportItemStyle<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportItemStyle<T> Class

Glossary Item Box

Represents a style for a report item.

Object Model

ReportItemStyle<T> Class

Syntax

Visual Basic (Declaration)
Public Class ReportItemStyle(Of T)
C#
public class ReportItemStyle<T>

Type Parameters

T
The type of the content for the style.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ReportItemStyle<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemStyle<T> Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportItemStyle<T> Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemStyle<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportItemStyle<T> Class

Glossary Item Box

The following tables list the members exposed by ReportItemStyle<T>.

Public Constructors

 | Name | Description
Public Constructor | ReportItemStyle<T> Constructor |
Top

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the content of the style.
Public Property | Id | Gets or sets the identifier of the style.
Public Property | Name | Gets or sets the name of the style.
Top

See Also

Reference

ReportItemStyle<T> Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportItemStyle<T> Constructor

[image]
ActiveReports 19 .NET Edition
ReportItemStyle<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportItemStyle<T> Class : ReportItemStyle<T> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportItemStyle<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemStyle<T> Class
ReportItemStyle<T> Members


ReportItemStyle<T> Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItemStyle<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportItemStyle<T> Class

Glossary Item Box

For a list of all members of this type, see ReportItemStyle<T> members.

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the content of the style.
Public Property | Id | Gets or sets the identifier of the style.
Public Property | Name | Gets or sets the name of the style.
Top

See Also

Reference

ReportItemStyle<T> Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportItemStyle<T> Class : Content Property

Glossary Item Box

Gets or sets the content of the style.

Syntax

Visual Basic (Declaration)
Public Property Content As T
C#
public T Content {get; set;}

Property Value

The content of the style of type T.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemStyle<T> Class
ReportItemStyle<T> Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportItemStyle<T> Class : Id Property

Glossary Item Box

Gets or sets the identifier of the style.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

The identifier of the style as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemStyle<T> Class
ReportItemStyle<T> Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportItemStyle<T> Class : Name Property

Glossary Item Box

Gets or sets the name of the style.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the style as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemStyle<T> Class
ReportItemStyle<T> Members


ReportPartsSettings Class

[image]
ActiveReports 19 .NET Edition
ReportPartsSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportPartsSettings Class

Glossary Item Box

Represents the settings related to the Report Parts feature.

Object Model

ReportPartsSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportPartsSettings
C#
public class ReportPartsSettings

Remarks

The ReportPartsSettings class provides properties to configure the enabling of Report Parts support and the list of available user libraries.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ReportPartsSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportPartsSettings Class Members

[image]
ActiveReports 19 .NET Edition
ReportPartsSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportPartsSettings Class

Glossary Item Box

The following tables list the members exposed by ReportPartsSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportPartsSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether Report Parts support is enabled.
Public Property | Libraries | Gets or sets the list of initially available user libraries.
Top

See Also

Reference

ReportPartsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportPartsSettings Constructor

[image]
ActiveReports 19 .NET Edition
ReportPartsSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportPartsSettings Class : ReportPartsSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportPartsSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsSettings Class
ReportPartsSettings Members


ReportPartsSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ReportPartsSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportPartsSettings Class

Glossary Item Box

For a list of all members of this type, see ReportPartsSettings members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether Report Parts support is enabled.
Public Property | Libraries | Gets or sets the list of initially available user libraries.
Top

See Also

Reference

ReportPartsSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportPartsSettings Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether Report Parts support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if Report Parts support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsSettings Class
ReportPartsSettings Members


Libraries Property

[image]
ActiveReports 19 .NET Edition
Libraries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportPartsSettings Class : Libraries Property

Glossary Item Box

Gets or sets the list of initially available user libraries.

Syntax

Visual Basic (Declaration)
Public Property Libraries As Library()
C#
public Library[] Libraries {get; set;}

Property Value

An array of Library that contains the available user libraries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsSettings Class
ReportPartsSettings Members


ReportStyles Class

[image]
ActiveReports 19 .NET Edition
ReportStyles Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportStyles Class

Glossary Item Box

Represents the styles for various report items.

Object Model

ReportStyles Class

Syntax

Visual Basic (Declaration)
Public Class ReportStyles
C#
public class ReportStyles

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ReportStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportStyles Class Members

[image]
ActiveReports 19 .NET Edition
ReportStyles Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportStyles Class

Glossary Item Box

The following tables list the members exposed by ReportStyles.

Public Constructors

 | Name | Description
Public Constructor | ReportStyles Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bullet | Gets or sets styles for bullet report items.
Public Property | ChartPalette | Gets or sets styles for chart palette report items.
Public Property | CheckBox | Gets or sets styles for checkbox report items.
Public Property | FormattedText | Gets or sets styles for formatted text report items.
Public Property | InputField | Gets or sets styles for input field report items.
Public Property | List | Gets or sets styles for list report items.
Public Property | Rectangle | Gets or sets styles for rectangle report items.
Public Property | RichText | Gets or sets styles for rich text report items.
Public Property | Shape | Gets or sets styles for shape report items.
Public Property | Sparkline | Gets or sets styles for sparkline report items.
Public Property | Table | Gets or sets styles for table report items.
Public Property | TableOfContents | Gets or sets styles for table of contents report items.
Public Property | Tablix | Gets or sets styles for tablix report items.
Public Property | TextBox | Gets or sets styles for text box report items.
Top

See Also

Reference

ReportStyles Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ReportStyles Constructor

[image]
ActiveReports 19 .NET Edition
ReportStyles Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : ReportStyles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportStyles()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


ReportStyles Class Properties

[image]
ActiveReports 19 .NET Edition
ReportStyles Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportStyles Class

Glossary Item Box

For a list of all members of this type, see ReportStyles members.

Public Properties

 | Name | Description
Public Property | Bullet | Gets or sets styles for bullet report items.
Public Property | ChartPalette | Gets or sets styles for chart palette report items.
Public Property | CheckBox | Gets or sets styles for checkbox report items.
Public Property | FormattedText | Gets or sets styles for formatted text report items.
Public Property | InputField | Gets or sets styles for input field report items.
Public Property | List | Gets or sets styles for list report items.
Public Property | Rectangle | Gets or sets styles for rectangle report items.
Public Property | RichText | Gets or sets styles for rich text report items.
Public Property | Shape | Gets or sets styles for shape report items.
Public Property | Sparkline | Gets or sets styles for sparkline report items.
Public Property | Table | Gets or sets styles for table report items.
Public Property | TableOfContents | Gets or sets styles for table of contents report items.
Public Property | Tablix | Gets or sets styles for tablix report items.
Public Property | TextBox | Gets or sets styles for text box report items.
Top

See Also

Reference

ReportStyles Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Bullet Property

[image]
ActiveReports 19 .NET Edition
Bullet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Bullet Property

Glossary Item Box

Gets or sets styles for bullet report items.

Syntax

Visual Basic (Declaration)
Public Property Bullet As ReportItemStyle(Of BulletStyleContent)()
C#
public ReportItemStyle<BulletStyleContent>[] Bullet {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for bullet report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


ChartPalette Property

[image]
ActiveReports 19 .NET Edition
ChartPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : ChartPalette Property

Glossary Item Box

Gets or sets styles for chart palette report items.

Syntax

Visual Basic (Declaration)
Public Property ChartPalette As ReportItemStyle(Of String())()
C#
public ReportItemStyle<string[]>[] ChartPalette {get; set;}

Property Value

An array of ReportItemStyle<T> of System.String[] type that contains styles for chart palette report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


CheckBox Property

[image]
ActiveReports 19 .NET Edition
CheckBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : CheckBox Property

Glossary Item Box

Gets or sets styles for checkbox report items.

Syntax

Visual Basic (Declaration)
Public Property CheckBox As ReportItemStyle(Of TextBoxStyleContent)()
C#
public ReportItemStyle<TextBoxStyleContent>[] CheckBox {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for checkbox report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


FormattedText Property

[image]
ActiveReports 19 .NET Edition
FormattedText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : FormattedText Property

Glossary Item Box

Gets or sets styles for formatted text report items.

Syntax

Visual Basic (Declaration)
Public Property FormattedText As ReportItemStyle(Of ContainerStyleContent)()
C#
public ReportItemStyle<ContainerStyleContent>[] FormattedText {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for formatted text report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


InputField Property

[image]
ActiveReports 19 .NET Edition
InputField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : InputField Property

Glossary Item Box

Gets or sets styles for input field report items.

Syntax

Visual Basic (Declaration)
Public Property InputField As ReportItemStyle(Of TextBoxStyleContent)()
C#
public ReportItemStyle<TextBoxStyleContent>[] InputField {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for input field report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


List Property

[image]
ActiveReports 19 .NET Edition
List Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : List Property

Glossary Item Box

Gets or sets styles for list report items.

Syntax

Visual Basic (Declaration)
Public Property List As ReportItemStyle(Of ContainerStyleContent)()
C#
public ReportItemStyle<ContainerStyleContent>[] List {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for list report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


Rectangle Property

[image]
ActiveReports 19 .NET Edition
Rectangle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Rectangle Property

Glossary Item Box

Gets or sets styles for rectangle report items.

Syntax

Visual Basic (Declaration)
Public Property Rectangle As ReportItemStyle(Of ContainerStyleContent)()
C#
public ReportItemStyle<ContainerStyleContent>[] Rectangle {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for rectangle report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


RichText Property

[image]
ActiveReports 19 .NET Edition
RichText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : RichText Property

Glossary Item Box

Gets or sets styles for rich text report items.

Syntax

Visual Basic (Declaration)
Public Property RichText As ReportItemStyle(Of TextBoxStyleContent)()
C#
public ReportItemStyle<TextBoxStyleContent>[] RichText {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for rich text report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


Shape Property

[image]
ActiveReports 19 .NET Edition
Shape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Shape Property

Glossary Item Box

Gets or sets styles for shape report items.

Syntax

Visual Basic (Declaration)
Public Property Shape As ReportItemStyle(Of ContainerStyleContent)()
C#
public ReportItemStyle<ContainerStyleContent>[] Shape {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for shape report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


Sparkline Property

[image]
ActiveReports 19 .NET Edition
Sparkline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Sparkline Property

Glossary Item Box

Gets or sets styles for sparkline report items.

Syntax

Visual Basic (Declaration)
Public Property Sparkline As ReportItemStyle(Of SparklineStyleContent)()
C#
public ReportItemStyle<SparklineStyleContent>[] Sparkline {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for sparkline report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


Table Property

[image]
ActiveReports 19 .NET Edition
Table Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Table Property

Glossary Item Box

Gets or sets styles for table report items.

Syntax

Visual Basic (Declaration)
Public Property Table As ReportItemStyle(Of TableStyleContent)()
C#
public ReportItemStyle<TableStyleContent>[] Table {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for table report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


TableOfContents Property

[image]
ActiveReports 19 .NET Edition
TableOfContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : TableOfContents Property

Glossary Item Box

Gets or sets styles for table of contents report items.

Syntax

Visual Basic (Declaration)
Public Property TableOfContents As ReportItemStyle(Of TableOfContentsStyleContent)()
C#
public ReportItemStyle<TableOfContentsStyleContent>[] TableOfContents {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for table of contents report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


Tablix Property

[image]
ActiveReports 19 .NET Edition
Tablix Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : Tablix Property

Glossary Item Box

Gets or sets styles for tablix report items.

Syntax

Visual Basic (Declaration)
Public Property Tablix As ReportItemStyle(Of TableStyleContent)()
C#
public ReportItemStyle<TableStyleContent>[] Tablix {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for tablix report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


TextBox Property

[image]
ActiveReports 19 .NET Edition
TextBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportStyles Class : TextBox Property

Glossary Item Box

Gets or sets styles for text box report items.

Syntax

Visual Basic (Declaration)
Public Property TextBox As ReportItemStyle(Of TextBoxStyleContent)()
C#
public ReportItemStyle<TextBoxStyleContent>[] TextBox {get; set;}

Property Value

An array of ReportItemStyle<T> that contains styles for text box report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStyles Class
ReportStyles Members


RequestInit Class

[image]
ActiveReports 19 .NET Edition
RequestInit Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RequestInit Class

Glossary Item Box

Represents the initialization settings for a request.

Object Model

RequestInit Class

Syntax

Visual Basic (Declaration)
Public Class RequestInit
C#
public class RequestInit

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.RequestInit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInit Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


RequestInit Class Members

[image]
ActiveReports 19 .NET Edition
RequestInit Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RequestInit Class

Glossary Item Box

The following tables list the members exposed by RequestInit.

Public Constructors

 | Name | Description
Public Constructor | RequestInit Constructor |
Top

Public Properties

 | Name | Description
Public Property | Credentials | Gets or sets the credentials for the request.
Public Property | Headers | Gets or sets the headers to be included in the request.
Top

See Also

Reference

RequestInit Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


RequestInit Constructor

[image]
ActiveReports 19 .NET Edition
RequestInit Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RequestInit Class : RequestInit Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RequestInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInit Class
RequestInit Members


RequestInit Class Properties

[image]
ActiveReports 19 .NET Edition
RequestInit Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RequestInit Class

Glossary Item Box

For a list of all members of this type, see RequestInit members.

Public Properties

 | Name | Description
Public Property | Credentials | Gets or sets the credentials for the request.
Public Property | Headers | Gets or sets the headers to be included in the request.
Top

See Also

Reference

RequestInit Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Credentials Property

[image]
ActiveReports 19 .NET Edition
Credentials Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RequestInit Class : Credentials Property

Glossary Item Box

Gets or sets the credentials for the request.

Syntax

Visual Basic (Declaration)
Public Property Credentials As String
C#
public string Credentials {get; set;}

Property Value

The credentials as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInit Class
RequestInit Members


Headers Property

[image]
ActiveReports 19 .NET Edition
Headers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RequestInit Class : Headers Property

Glossary Item Box

Gets or sets the headers to be included in the request.

Syntax

Visual Basic (Declaration)
Public Property Headers As Dictionary(Of String,String)
C#
public Dictionary<string,string> Headers {get; set;}

Property Value

A Dictionary representing the headers, where the key is the header name and the value is the header value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInit Class
RequestInit Members


RpxSettings Class

[image]
ActiveReports 19 .NET Edition
RpxSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RpxSettings Class

Glossary Item Box

Represents the settings specific to the RPX platform.

Object Model

RpxSettings Class

Syntax

Visual Basic (Declaration)
Public Class RpxSettings
C#
public class RpxSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.RpxSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


RpxSettings Class Members

[image]
ActiveReports 19 .NET Edition
RpxSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RpxSettings Class

Glossary Item Box

The following tables list the members exposed by RpxSettings.

Public Constructors

 | Name | Description
Public Constructor | RpxSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RPX support is enabled.
Public Property | InitTemplates | Gets or sets the settings for initializing templates.
Public Property | Styles | Gets or sets the settings related to RPX styles.
Public Property | ToolBoxContent | Gets or sets the report items on the toolBox and their order for RPX reports.
Top

See Also

Reference

RpxSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


RpxSettings Constructor

[image]
ActiveReports 19 .NET Edition
RpxSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RpxSettings Class : RpxSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RpxSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Class
RpxSettings Members


RpxSettings Class Properties

[image]
ActiveReports 19 .NET Edition
RpxSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RpxSettings Class

Glossary Item Box

For a list of all members of this type, see RpxSettings members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether RPX support is enabled.
Public Property | InitTemplates | Gets or sets the settings for initializing templates.
Public Property | Styles | Gets or sets the settings related to RPX styles.
Public Property | ToolBoxContent | Gets or sets the report items on the toolBox and their order for RPX reports.
Top

See Also

Reference

RpxSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RpxSettings Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether RPX support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if RPX support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Class
RpxSettings Members


InitTemplates Property

[image]
ActiveReports 19 .NET Edition
InitTemplates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RpxSettings Class : InitTemplates Property

Glossary Item Box

Gets or sets the settings for initializing templates.

Syntax

Visual Basic (Declaration)
Public Property InitTemplates As InitTemplates
C#
public InitTemplates InitTemplates {get; set;}

Property Value

The initialization templates settings as InitTemplates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Class
RpxSettings Members


Styles Property

[image]
ActiveReports 19 .NET Edition
Styles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RpxSettings Class : Styles Property

Glossary Item Box

Gets or sets the settings related to RPX styles.

Syntax

Visual Basic (Declaration)
Public Property Styles As StylesSettings
C#
public StylesSettings Styles {get; set;}

Property Value

The RPX styles settings as StylesSettings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Class
RpxSettings Members


ToolBoxContent Property

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RpxSettings Class : ToolBoxContent Property

Glossary Item Box

Gets or sets the report items on the toolBox and their order for RPX reports.

Syntax

Visual Basic (Declaration)
Public Property ToolBoxContent As RpxToolBoxItem()
C#
public RpxToolBoxItem[] ToolBoxContent {get; set;}

Property Value

An array of RpxToolBoxItem representing the report items and their order for RPX reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxSettings Class
RpxSettings Members


Rulers Class

[image]
ActiveReports 19 .NET Edition
Rulers Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Rulers Class

Glossary Item Box

Represents the settings for rulers.

Object Model

Rulers Class

Syntax

Visual Basic (Declaration)
Public Class Rulers
C#
public class Rulers

Remarks

The Rulers class provides properties to configure the visibility of rulers and the snap step values.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Rulers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rulers Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Rulers Class Members

[image]
ActiveReports 19 .NET Edition
Rulers Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Rulers Class

Glossary Item Box

The following tables list the members exposed by Rulers.

Public Constructors

 | Name | Description
Public Constructor | Rulers Constructor |
Top

Public Properties

 | Name | Description
Public Property | SnapStep | Gets or sets the snap step value.
Public Property | Visible | Gets or sets a value indicating whether the rulers should be shown by default.
Top

See Also

Reference

Rulers Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Rulers Constructor

[image]
ActiveReports 19 .NET Edition
Rulers Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Rulers Class : Rulers Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Rulers()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rulers Class
Rulers Members


Rulers Class Properties

[image]
ActiveReports 19 .NET Edition
Rulers Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Rulers Class

Glossary Item Box

For a list of all members of this type, see Rulers members.

Public Properties

 | Name | Description
Public Property | SnapStep | Gets or sets the snap step value.
Public Property | Visible | Gets or sets a value indicating whether the rulers should be shown by default.
Top

See Also

Reference

Rulers Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SnapStep Property

[image]
ActiveReports 19 .NET Edition
SnapStep Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Rulers Class : SnapStep Property

Glossary Item Box

Gets or sets the snap step value.

Syntax

Visual Basic (Declaration)
Public Property SnapStep As SnapStep
C#
public SnapStep SnapStep {get; set;}

Property Value

An instance of SnapStep that contains the snap step values. By default, snap step is { in: 0.25, cm: 0.5 }.

Remarks

By default, snap step is { in: 0.25, cm: 0.5 }

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rulers Class
Rulers Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Rulers Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the rulers should be shown by default.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the rulers should be shown by default; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rulers Class
Rulers Members


RulersButton Class

[image]
ActiveReports 19 .NET Edition
RulersButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RulersButton Class

Glossary Item Box

Represents the settings for the rulers button.

Object Model

RulersButton Class

Syntax

Visual Basic (Declaration)
Public Class RulersButton
C#
public class RulersButton

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.RulersButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RulersButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


RulersButton Class Members

[image]
ActiveReports 19 .NET Edition
RulersButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RulersButton Class

Glossary Item Box

The following tables list the members exposed by RulersButton.

Public Constructors

 | Name | Description
Public Constructor | RulersButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the rulers toggle button should be shown.
Top

See Also

Reference

RulersButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


RulersButton Constructor

[image]
ActiveReports 19 .NET Edition
RulersButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RulersButton Class : RulersButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RulersButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RulersButton Class
RulersButton Members


RulersButton Class Properties

[image]
ActiveReports 19 .NET Edition
RulersButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RulersButton Class

Glossary Item Box

For a list of all members of this type, see RulersButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the rulers toggle button should be shown.
Top

See Also

Reference

RulersButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > RulersButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the rulers toggle button should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the rulers toggle button should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RulersButton Class
RulersButton Members


SaveAsButton Class

[image]
ActiveReports 19 .NET Edition
SaveAsButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveAsButton Class

Glossary Item Box

Represents the settings for the Save As button.

Object Model

SaveAsButton Class

Syntax

Visual Basic (Declaration)
Public Class SaveAsButton
C#
public class SaveAsButton

Remarks

The SaveAsButton class provides a property to configure the visibility of the Save As button in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SaveAsButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveAsButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveAsButton Class Members

[image]
ActiveReports 19 .NET Edition
SaveAsButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveAsButton Class

Glossary Item Box

The following tables list the members exposed by SaveAsButton.

Public Constructors

 | Name | Description
Public Constructor | SaveAsButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Save As button should be visible.
Top

See Also

Reference

SaveAsButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveAsButton Constructor

[image]
ActiveReports 19 .NET Edition
SaveAsButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveAsButton Class : SaveAsButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SaveAsButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveAsButton Class
SaveAsButton Members


SaveAsButton Class Properties

[image]
ActiveReports 19 .NET Edition
SaveAsButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveAsButton Class

Glossary Item Box

For a list of all members of this type, see SaveAsButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Save As button should be visible.
Top

See Also

Reference

SaveAsButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveAsButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Save As button should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Save As button should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveAsButton Class
SaveAsButton Members


SaveButton Class

[image]
ActiveReports 19 .NET Edition
SaveButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveButton Class

Glossary Item Box

Represents the settings for the Save button.

Object Model

SaveButton Class

Syntax

Visual Basic (Declaration)
Public Class SaveButton
C#
public class SaveButton

Remarks

The SaveButton class provides a property to configure the visibility of the Save button in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SaveButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveButton Class Members

[image]
ActiveReports 19 .NET Edition
SaveButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveButton Class

Glossary Item Box

The following tables list the members exposed by SaveButton.

Public Constructors

 | Name | Description
Public Constructor | SaveButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Save button should be visible.
Top

See Also

Reference

SaveButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveButton Constructor

[image]
ActiveReports 19 .NET Edition
SaveButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveButton Class : SaveButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SaveButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveButton Class
SaveButton Members


SaveButton Class Properties

[image]
ActiveReports 19 .NET Edition
SaveButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveButton Class

Glossary Item Box

For a list of all members of this type, see SaveButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Save button should be visible.
Top

See Also

Reference

SaveButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Save button should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Save button should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveButton Class
SaveButton Members


SaveDocumentInfo Class

[image]
ActiveReports 19 .NET Edition
SaveDocumentInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveDocumentInfo Class

Glossary Item Box

Represents the information about a saved document.

Object Model

SaveDocumentInfo Class

Syntax

Visual Basic (Declaration)
Public Class SaveDocumentInfo
C#
public class SaveDocumentInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SaveDocumentInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveDocumentInfo Class Members

[image]
ActiveReports 19 .NET Edition
SaveDocumentInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveDocumentInfo Class

Glossary Item Box

The following tables list the members exposed by SaveDocumentInfo.

Public Constructors

 | Name | Description
Public Constructor | SaveDocumentInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the existing report to be overwritten on saving.
Public Property | IsFirstSave | Gets or sets a value indicating that a new report is being saved for the first time.
Public Property | Name | Gets or sets the name of the document.
Public Property | Success | Gets or sets a value indicating whether the saving was successful.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

SaveDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SaveDocumentInfo Constructor

[image]
ActiveReports 19 .NET Edition
SaveDocumentInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : SaveDocumentInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SaveDocumentInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


SaveDocumentInfo Class Properties

[image]
ActiveReports 19 .NET Edition
SaveDocumentInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SaveDocumentInfo Class

Glossary Item Box

For a list of all members of this type, see SaveDocumentInfo members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the existing report to be overwritten on saving.
Public Property | IsFirstSave | Gets or sets a value indicating that a new report is being saved for the first time.
Public Property | Name | Gets or sets the name of the document.
Public Property | Success | Gets or sets a value indicating whether the saving was successful.
Public Property | Type | Gets or sets the document type.
Top

See Also

Reference

SaveDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : Id Property

Glossary Item Box

Gets or sets the ID of the existing report to be overwritten on saving.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


IsFirstSave Property

[image]
ActiveReports 19 .NET Edition
IsFirstSave Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : IsFirstSave Property

Glossary Item Box

Gets or sets a value indicating that a new report is being saved for the first time.

Syntax

Visual Basic (Declaration)
Public Property IsFirstSave As Nullable(Of Boolean)
C#
public Nullable<bool> IsFirstSave {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : Name Property

Glossary Item Box

Gets or sets the name of the document.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


Success Property

[image]
ActiveReports 19 .NET Edition
Success Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : Success Property

Glossary Item Box

Gets or sets a value indicating whether the saving was successful.

Syntax

Visual Basic (Declaration)
Public Property Success As Nullable(Of Boolean)
C#
public Nullable<bool> Success {get; set;}

Remarks

Null in OnBefore handlers should be defined in OnAfter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SaveDocumentInfo Class : Type Property

Glossary Item Box

Gets or sets the document type.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of SupportedDocumentType)
C#
public Nullable<SupportedDocumentType> Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveDocumentInfo Class
SaveDocumentInfo Members


ScriptTab Class

[image]
ActiveReports 19 .NET Edition
ScriptTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ScriptTab Class

Glossary Item Box

Represents the settings for the Script tab.

Object Model

ScriptTab Class

Syntax

Visual Basic (Declaration)
Public Class ScriptTab
C#
public class ScriptTab

Remarks

The ScriptTab class provides a property to configure the visibility of the Script tab in the App Bar.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ScriptTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScriptTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ScriptTab Class Members

[image]
ActiveReports 19 .NET Edition
ScriptTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ScriptTab Class

Glossary Item Box

The following tables list the members exposed by ScriptTab.

Public Constructors

 | Name | Description
Public Constructor | ScriptTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Script tab should be visible.
Top

See Also

Reference

ScriptTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ScriptTab Constructor

[image]
ActiveReports 19 .NET Edition
ScriptTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ScriptTab Class : ScriptTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ScriptTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScriptTab Class
ScriptTab Members


ScriptTab Class Properties

[image]
ActiveReports 19 .NET Edition
ScriptTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ScriptTab Class

Glossary Item Box

For a list of all members of this type, see ScriptTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Script tab should be visible.
Top

See Also

Reference

ScriptTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ScriptTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Script tab should be visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Script tab should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScriptTab Class
ScriptTab Members


ServerSettings Class

[image]
ActiveReports 19 .NET Edition
ServerSettings Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ServerSettings Class

Glossary Item Box

Represents the settings related to the backend server, including the base URL and request modification handlers.

Object Model

ServerSettings Class

Syntax

Visual Basic (Declaration)
Public Class ServerSettings
C#
public class ServerSettings

Example

C# Copy Code
new ServerSettings
{
    Url = "https://api.example.com",
    OnBeforeRequest = request =>
    {
        request.Headers.Add("Authorization", "Bearer token");
        return request;
    }
};

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ServerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ServerSettings Class Members

[image]
ActiveReports 19 .NET Edition
ServerSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ServerSettings Class

Glossary Item Box

The following tables list the members exposed by ServerSettings.

Public Constructors

 | Name | Description
Public Constructor | ServerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnBeforeRequest | Gets or sets a special handler to modify requests before they are sent.
Public Property | Url | Gets or sets the base URL for Designer Server API..
Top

See Also

Reference

ServerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ServerSettings Constructor

[image]
ActiveReports 19 .NET Edition
ServerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ServerSettings Class : ServerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ServerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerSettings Class
ServerSettings Members


ServerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ServerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ServerSettings Class

Glossary Item Box

For a list of all members of this type, see ServerSettings members.

Public Properties

 | Name | Description
Public Property | OnBeforeRequest | Gets or sets a special handler to modify requests before they are sent.
Public Property | Url | Gets or sets the base URL for Designer Server API..
Top

See Also

Reference

ServerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


OnBeforeRequest Property

[image]
ActiveReports 19 .NET Edition
OnBeforeRequest Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ServerSettings Class : OnBeforeRequest Property

Glossary Item Box

Gets or sets a special handler to modify requests before they are sent.

Syntax

Visual Basic (Declaration)
Public Property OnBeforeRequest As Func(Of RequestInit,RequestInit)
C#
public Func<RequestInit,RequestInit> OnBeforeRequest {get; set;}

Property Value

A function that takes a RequestInit object and returns a modified RequestInit object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerSettings Class
ServerSettings Members


Url Property

[image]
ActiveReports 19 .NET Edition
Url Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ServerSettings Class : Url Property

Glossary Item Box

Gets or sets the base URL for Designer Server API..

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url {get; set;}

Property Value

The base URL as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerSettings Class
ServerSettings Members


SharedDataSourceOptions Class

[image]
ActiveReports 19 .NET Edition
SharedDataSourceOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SharedDataSourceOptions Class

Glossary Item Box

Represents the options for shared data sources.

Object Model

SharedDataSourceOptions Class

Syntax

Visual Basic (Declaration)
Public Class SharedDataSourceOptions
C#
public class SharedDataSourceOptions

Remarks

The SharedDataSourceOptions that contains the options for shared data sources.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SharedDataSourceOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceOptions Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SharedDataSourceOptions Class Members

[image]
ActiveReports 19 .NET Edition
SharedDataSourceOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SharedDataSourceOptions Class

Glossary Item Box

The following tables list the members exposed by SharedDataSourceOptions.

Public Constructors

 | Name | Description
Public Constructor | SharedDataSourceOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether shared data source support is enabled.
Top

See Also

Reference

SharedDataSourceOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SharedDataSourceOptions Constructor

[image]
ActiveReports 19 .NET Edition
SharedDataSourceOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SharedDataSourceOptions Class : SharedDataSourceOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SharedDataSourceOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceOptions Class
SharedDataSourceOptions Members


SharedDataSourceOptions Class Properties

[image]
ActiveReports 19 .NET Edition
SharedDataSourceOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SharedDataSourceOptions Class

Glossary Item Box

For a list of all members of this type, see SharedDataSourceOptions members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether shared data source support is enabled.
Top

See Also

Reference

SharedDataSourceOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SharedDataSourceOptions Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether shared data source support is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

true if shared data source support is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceOptions Class
SharedDataSourceOptions Members


Sidebar Class

[image]
ActiveReports 19 .NET Edition
Sidebar Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Sidebar Class

Glossary Item Box

Represents methods to interact with the sidebar in the UI.

Object Model

Sidebar Class

Syntax

Visual Basic (Declaration)
Public Class Sidebar
C#
public class Sidebar

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Sidebar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Sidebar Class Members

[image]
ActiveReports 19 .NET Edition
Sidebar Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Sidebar Class

Glossary Item Box

The following tables list the members exposed by Sidebar.

Public Methods

 | Name | Description
Public Method | Close | Closes the currently opened sidebar.
Public Method | Open | Opens the sidebar with the specified ID.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Sidebar Class Methods

[image]
ActiveReports 19 .NET Edition
Sidebar Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Methods

 | Name | Description
Public Method | Close | Closes the currently opened sidebar.
Public Method | Open | Opens the sidebar with the specified ID.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Close Method

[image]
ActiveReports 19 .NET Edition
Close Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Sidebar Class : Close Method

Glossary Item Box

Closes the currently opened sidebar.

Syntax

Visual Basic (Declaration)
Public Function Close() As Task
C#
public Task Close()

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of closing the sidebar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Open Method

[image]
ActiveReports 19 .NET Edition
Open Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Sidebar Class : Open Method

id
The ID of the sidebar to open.

Glossary Item Box

Opens the sidebar with the specified ID.

Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal id As String _
) As Task
C#
public Task Open(
   string id
)

Parameters

id
The ID of the sidebar to open.

Return Value

A System.Threading.Tasks.Task representing the asynchronous operation of opening the sidebar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SnapStep Class

[image]
ActiveReports 19 .NET Edition
SnapStep Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SnapStep Class

Glossary Item Box

Represents the snap step value.

Object Model

SnapStep Class

Syntax

Visual Basic (Declaration)
Public Class SnapStep
C#
public class SnapStep

Remarks

The SnapStep class provides properties to configure the snap step values in inches and centimeters.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SnapStep

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapStep Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SnapStep Class Members

[image]
ActiveReports 19 .NET Edition
SnapStep Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SnapStep Class

Glossary Item Box

The following tables list the members exposed by SnapStep.

Public Constructors

 | Name | Description
Public Constructor | SnapStep Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cm | Gets or sets the snap step value in centimeters.
Public Property | In | Gets or sets the snap step value in inches.
Top

See Also

Reference

SnapStep Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SnapStep Constructor

[image]
ActiveReports 19 .NET Edition
SnapStep Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SnapStep Class : SnapStep Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SnapStep()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapStep Class
SnapStep Members


SnapStep Class Properties

[image]
ActiveReports 19 .NET Edition
SnapStep Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SnapStep Class

Glossary Item Box

For a list of all members of this type, see SnapStep members.

Public Properties

 | Name | Description
Public Property | Cm | Gets or sets the snap step value in centimeters.
Public Property | In | Gets or sets the snap step value in inches.
Top

See Also

Reference

SnapStep Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Cm Property

[image]
ActiveReports 19 .NET Edition
Cm Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SnapStep Class : Cm Property

Glossary Item Box

Gets or sets the snap step value in centimeters.

Syntax

Visual Basic (Declaration)
Public Property Cm As Nullable(Of Double)
C#
public Nullable<double> Cm {get; set;}

Property Value

The snap step value in centimeters as a nullable System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapStep Class
SnapStep Members


In Property

[image]
ActiveReports 19 .NET Edition
In Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SnapStep Class : In Property

Glossary Item Box

Gets or sets the snap step value in inches.

Syntax

Visual Basic (Declaration)
Public Property In As Nullable(Of Double)
C#
public Nullable<double> In {get; set;}

Property Value

The snap step value in inches as a nullable System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapStep Class
SnapStep Members


SparklineStyleContent Class

[image]
ActiveReports 19 .NET Edition
SparklineStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SparklineStyleContent Class

Glossary Item Box

Represents the style content for a sparkline report item.

Object Model

SparklineStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class SparklineStyleContent
C#
public class SparklineStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.SparklineStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


SparklineStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
SparklineStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SparklineStyleContent Class

Glossary Item Box

The following tables list the members exposed by SparklineStyleContent.

Public Constructors

 | Name | Description
Public Constructor | SparklineStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillColor | Gets or sets the fill color of the sparkline.
Public Property | GradientEndColor | Gets or sets the gradient end color of the sparkline.
Public Property | LineColor | Gets or sets the line color of the sparkline.
Public Property | MarkerColor | Gets or sets the marker color of the sparkline.
Public Property | RangeFillColor | Gets or sets the range fill color of the sparkline.
Public Property | RangeGradientEndColor | Gets or sets the range gradient end color of the sparkline.
Top

See Also

Reference

SparklineStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SparklineStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
SparklineStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : SparklineStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SparklineStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


SparklineStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
SparklineStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SparklineStyleContent Class

Glossary Item Box

For a list of all members of this type, see SparklineStyleContent members.

Public Properties

 | Name | Description
Public Property | FillColor | Gets or sets the fill color of the sparkline.
Public Property | GradientEndColor | Gets or sets the gradient end color of the sparkline.
Public Property | LineColor | Gets or sets the line color of the sparkline.
Public Property | MarkerColor | Gets or sets the marker color of the sparkline.
Public Property | RangeFillColor | Gets or sets the range fill color of the sparkline.
Public Property | RangeGradientEndColor | Gets or sets the range gradient end color of the sparkline.
Top

See Also

Reference

SparklineStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


FillColor Property

[image]
ActiveReports 19 .NET Edition
FillColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : FillColor Property

Glossary Item Box

Gets or sets the fill color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property FillColor As String
C#
public string FillColor {get; set;}

Property Value

The fill color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


GradientEndColor Property

[image]
ActiveReports 19 .NET Edition
GradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : GradientEndColor Property

Glossary Item Box

Gets or sets the gradient end color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property GradientEndColor As String
C#
public string GradientEndColor {get; set;}

Property Value

The gradient end color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : LineColor Property

Glossary Item Box

Gets or sets the line color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property LineColor As String
C#
public string LineColor {get; set;}

Property Value

The line color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


MarkerColor Property

[image]
ActiveReports 19 .NET Edition
MarkerColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : MarkerColor Property

Glossary Item Box

Gets or sets the marker color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property MarkerColor As String
C#
public string MarkerColor {get; set;}

Property Value

The marker color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


RangeFillColor Property

[image]
ActiveReports 19 .NET Edition
RangeFillColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : RangeFillColor Property

Glossary Item Box

Gets or sets the range fill color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property RangeFillColor As String
C#
public string RangeFillColor {get; set;}

Property Value

The range fill color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


RangeGradientEndColor Property

[image]
ActiveReports 19 .NET Edition
RangeGradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > SparklineStyleContent Class : RangeGradientEndColor Property

Glossary Item Box

Gets or sets the range gradient end color of the sparkline.

Syntax

Visual Basic (Declaration)
Public Property RangeGradientEndColor As String
C#
public string RangeGradientEndColor {get; set;}

Property Value

The range gradient end color of the sparkline as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineStyleContent Class
SparklineStyleContent Members


StatusBarSettings Class

[image]
ActiveReports 19 .NET Edition
StatusBarSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StatusBarSettings Class

Glossary Item Box

Represents the settings for the Status Bar, providing various controls and information at the bottom of the designer.

Object Model

StatusBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class StatusBarSettings
C#
public class StatusBarSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.StatusBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


StatusBarSettings Class Members

[image]
ActiveReports 19 .NET Edition
StatusBarSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StatusBarSettings Class

Glossary Item Box

The following tables list the members exposed by StatusBarSettings.

Public Constructors

 | Name | Description
Public Constructor | StatusBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | PropertiesModeButton | Gets or sets the settings for the properties mode button.
Public Property | RulersButton | Gets or sets the settings for the rulers button.
Public Property | ToggleGridButton | Gets or sets the settings for the toggle grid button.
Public Property | ToggleUnitsButton | Gets or sets the settings for the toggle units button.
Public Property | Visible | Gets or sets a value indicating whether the status bar should be shown.
Top

See Also

Reference

StatusBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


StatusBarSettings Constructor

[image]
ActiveReports 19 .NET Edition
StatusBarSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : StatusBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StatusBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


StatusBarSettings Class Properties

[image]
ActiveReports 19 .NET Edition
StatusBarSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StatusBarSettings Class

Glossary Item Box

For a list of all members of this type, see StatusBarSettings members.

Public Properties

 | Name | Description
Public Property | PropertiesModeButton | Gets or sets the settings for the properties mode button.
Public Property | RulersButton | Gets or sets the settings for the rulers button.
Public Property | ToggleGridButton | Gets or sets the settings for the toggle grid button.
Public Property | ToggleUnitsButton | Gets or sets the settings for the toggle units button.
Public Property | Visible | Gets or sets a value indicating whether the status bar should be shown.
Top

See Also

Reference

StatusBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


PropertiesModeButton Property

[image]
ActiveReports 19 .NET Edition
PropertiesModeButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : PropertiesModeButton Property

Glossary Item Box

Gets or sets the settings for the properties mode button.

Syntax

Visual Basic (Declaration)
Public Property PropertiesModeButton As PropertiesModeButton
C#
public PropertiesModeButton PropertiesModeButton {get; set;}

Property Value

An instance of PropertiesModeButton that defines the settings for the properties mode button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


RulersButton Property

[image]
ActiveReports 19 .NET Edition
RulersButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : RulersButton Property

Glossary Item Box

Gets or sets the settings for the rulers button.

Syntax

Visual Basic (Declaration)
Public Property RulersButton As RulersButton
C#
public RulersButton RulersButton {get; set;}

Property Value

An instance of RulersButton that defines the settings for the rulers button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


ToggleGridButton Property

[image]
ActiveReports 19 .NET Edition
ToggleGridButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : ToggleGridButton Property

Glossary Item Box

Gets or sets the settings for the toggle grid button.

Syntax

Visual Basic (Declaration)
Public Property ToggleGridButton As ToggleGridButton
C#
public ToggleGridButton ToggleGridButton {get; set;}

Property Value

An instance of ToggleGridButton that defines the settings for the toggle grid button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


ToggleUnitsButton Property

[image]
ActiveReports 19 .NET Edition
ToggleUnitsButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : ToggleUnitsButton Property

Glossary Item Box

Gets or sets the settings for the toggle units button.

Syntax

Visual Basic (Declaration)
Public Property ToggleUnitsButton As ToggleUnitsButton
C#
public ToggleUnitsButton ToggleUnitsButton {get; set;}

Property Value

An instance of ToggleUnitsButton that defines the settings for the toggle units button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StatusBarSettings Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the status bar should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the status bar should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusBarSettings Class
StatusBarSettings Members


Stylesheet Class

[image]
ActiveReports 19 .NET Edition
Stylesheet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Stylesheet Class

Glossary Item Box

Represents settings for the RPX report stylesheet.

Object Model

Stylesheet Class

Syntax

Visual Basic (Declaration)
Public Class Stylesheet
C#
public class Stylesheet

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Stylesheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Stylesheet Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Stylesheet Class Members

[image]
ActiveReports 19 .NET Edition
Stylesheet Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Stylesheet Class

Glossary Item Box

The following tables list the members exposed by Stylesheet.

Public Constructors

 | Name | Description
Public Constructor | Stylesheet Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether the RPX report stylesheet can be modified.
Top

See Also

Reference

Stylesheet Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Stylesheet Constructor

[image]
ActiveReports 19 .NET Edition
Stylesheet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Stylesheet Class : Stylesheet Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Stylesheet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Stylesheet Class
Stylesheet Members


Stylesheet Class Properties

[image]
ActiveReports 19 .NET Edition
Stylesheet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Stylesheet Class

Glossary Item Box

For a list of all members of this type, see Stylesheet members.

Public Properties

 | Name | Description
Public Property | CanModify | Gets or sets a value indicating whether the RPX report stylesheet can be modified.
Top

See Also

Reference

Stylesheet Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


CanModify Property

[image]
ActiveReports 19 .NET Edition
CanModify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Stylesheet Class : CanModify Property

Glossary Item Box

Gets or sets a value indicating whether the RPX report stylesheet can be modified.

Syntax

Visual Basic (Declaration)
Public Property CanModify As Nullable(Of Boolean)
C#
public Nullable<bool> CanModify {get; set;}

Property Value

true if the RPX report stylesheet can be modified; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Stylesheet Class
Stylesheet Members


StylesSettings Class

[image]
ActiveReports 19 .NET Edition
StylesSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesSettings Class

Glossary Item Box

Represents settings related to RPX Styles.

Object Model

StylesSettings Class

Syntax

Visual Basic (Declaration)
Public Class StylesSettings
C#
public class StylesSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.StylesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


StylesSettings Class Members

[image]
ActiveReports 19 .NET Edition
StylesSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesSettings Class

Glossary Item Box

The following tables list the members exposed by StylesSettings.

Public Constructors

 | Name | Description
Public Constructor | StylesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Stylesheet | Gets or sets the settings for the RPX report stylesheet.
Public Property | StylesTab | Gets or sets the settings for the Styles tab.
Top

See Also

Reference

StylesSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


StylesSettings Constructor

[image]
ActiveReports 19 .NET Edition
StylesSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StylesSettings Class : StylesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StylesSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesSettings Class
StylesSettings Members


StylesSettings Class Properties

[image]
ActiveReports 19 .NET Edition
StylesSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesSettings Class

Glossary Item Box

For a list of all members of this type, see StylesSettings members.

Public Properties

 | Name | Description
Public Property | Stylesheet | Gets or sets the settings for the RPX report stylesheet.
Public Property | StylesTab | Gets or sets the settings for the Styles tab.
Top

See Also

Reference

StylesSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Stylesheet Property

[image]
ActiveReports 19 .NET Edition
Stylesheet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StylesSettings Class : Stylesheet Property

Glossary Item Box

Gets or sets the settings for the RPX report stylesheet.

Syntax

Visual Basic (Declaration)
Public Property Stylesheet As Stylesheet
C#
public Stylesheet Stylesheet {get; set;}

Property Value

An instance of Stylesheet that defines the settings for the RPX report stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesSettings Class
StylesSettings Members


StylesTab Property

[image]
ActiveReports 19 .NET Edition
StylesTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StylesSettings Class : StylesTab Property

Glossary Item Box

Gets or sets the settings for the Styles tab.

Syntax

Visual Basic (Declaration)
Public Property StylesTab As StylesTab
C#
public StylesTab StylesTab {get; set;}

Property Value

An instance of StylesTab that defines the settings for the Styles tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesSettings Class
StylesSettings Members


StylesTab Class

[image]
ActiveReports 19 .NET Edition
StylesTab Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesTab Class

Glossary Item Box

Represents settings for the Styles tab in RPX reports.

Object Model

StylesTab Class

Syntax

Visual Basic (Declaration)
Public Class StylesTab
C#
public class StylesTab

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.StylesTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesTab Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


StylesTab Class Members

[image]
ActiveReports 19 .NET Edition
StylesTab Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesTab Class

Glossary Item Box

The following tables list the members exposed by StylesTab.

Public Constructors

 | Name | Description
Public Constructor | StylesTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Styles tab should be shown for RPX reports.
Top

See Also

Reference

StylesTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


StylesTab Constructor

[image]
ActiveReports 19 .NET Edition
StylesTab Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StylesTab Class : StylesTab Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StylesTab()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesTab Class
StylesTab Members


StylesTab Class Properties

[image]
ActiveReports 19 .NET Edition
StylesTab Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : StylesTab Class

Glossary Item Box

For a list of all members of this type, see StylesTab members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Styles tab should be shown for RPX reports.
Top

See Also

Reference

StylesTab Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > StylesTab Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Styles tab should be shown for RPX reports.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Styles tab should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StylesTab Class
StylesTab Members


Table Class

[image]
ActiveReports 19 .NET Edition
Table Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Table Class

Glossary Item Box

Represents the features for table items.

Object Model

Table Class

Syntax

Visual Basic (Declaration)
Public Class Table
C#
public class Table

Remarks

The Table class provides properties to configure the features for table items, such as auto-filling headers and footers, merging cells, and visibility of frozen rows and columns.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Table Class Members

[image]
ActiveReports 19 .NET Edition
Table Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Table Class

Glossary Item Box

The following tables list the members exposed by Table.

Public Constructors

 | Name | Description
Public Constructor | Table Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoFillFooter | Gets or sets a value indicating whether the Table Footer needs to be auto-filled when a field is dropped to the Table Details.
Public Property | AutoFillHeader | Gets or sets a value indicating whether the Table Header needs to be auto-filled when a field is dropped to the Table Details.
Public Property | CanMergeCellsVertically | Gets or sets a value indicating whether the vertical merge of cells is enabled within the Table Header, Details, and Footer.
Public Property | HideFrozenRowsColumns | Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Table Constructor

[image]
ActiveReports 19 .NET Edition
Table Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Table Class : Table Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Table()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Properties

[image]
ActiveReports 19 .NET Edition
Table Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Properties

 | Name | Description
Public Property | AutoFillFooter | Gets or sets a value indicating whether the Table Footer needs to be auto-filled when a field is dropped to the Table Details.
Public Property | AutoFillHeader | Gets or sets a value indicating whether the Table Header needs to be auto-filled when a field is dropped to the Table Details.
Public Property | CanMergeCellsVertically | Gets or sets a value indicating whether the vertical merge of cells is enabled within the Table Header, Details, and Footer.
Public Property | HideFrozenRowsColumns | Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AutoFillFooter Property

[image]
ActiveReports 19 .NET Edition
AutoFillFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Table Class : AutoFillFooter Property

Glossary Item Box

Gets or sets a value indicating whether the Table Footer needs to be auto-filled when a field is dropped to the Table Details.

Syntax

Visual Basic (Declaration)
Public Property AutoFillFooter As Nullable(Of Boolean)
C#
public Nullable<bool> AutoFillFooter {get; set;}

Property Value

true if the Table Footer should be auto-filled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


AutoFillHeader Property

[image]
ActiveReports 19 .NET Edition
AutoFillHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Table Class : AutoFillHeader Property

Glossary Item Box

Gets or sets a value indicating whether the Table Header needs to be auto-filled when a field is dropped to the Table Details.

Syntax

Visual Basic (Declaration)
Public Property AutoFillHeader As Nullable(Of Boolean)
C#
public Nullable<bool> AutoFillHeader {get; set;}

Property Value

true if the Table Header should be auto-filled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


CanMergeCellsVertically Property

[image]
ActiveReports 19 .NET Edition
CanMergeCellsVertically Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Table Class : CanMergeCellsVertically Property

Glossary Item Box

Gets or sets a value indicating whether the vertical merge of cells is enabled within the Table Header, Details, and Footer.

Syntax

Visual Basic (Declaration)
Public Property CanMergeCellsVertically As Nullable(Of Boolean)
C#
public Nullable<bool> CanMergeCellsVertically {get; set;}

Property Value

true if vertical merging of cells is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


HideFrozenRowsColumns Property

[image]
ActiveReports 19 .NET Edition
HideFrozenRowsColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Table Class : HideFrozenRowsColumns Property

Glossary Item Box

Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Property HideFrozenRowsColumns As Nullable(Of Boolean)
C#
public Nullable<bool> HideFrozenRowsColumns {get; set;}

Property Value

true if FrozenRows/FrozenColumns properties should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableGroups Class

[image]
ActiveReports 19 .NET Edition
TableGroups Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableGroups Class

Glossary Item Box

Represents the style content for the groups of a table report item.

Object Model

TableGroups Class

Syntax

Visual Basic (Declaration)
Public Class TableGroups
C#
public class TableGroups

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TableGroups

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroups Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableGroups Class Members

[image]
ActiveReports 19 .NET Edition
TableGroups Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableGroups Class

Glossary Item Box

The following tables list the members exposed by TableGroups.

Public Constructors

 | Name | Description
Public Constructor | TableGroups Constructor |
Top

Public Properties

 | Name | Description
Public Property | Styles | Gets or sets the styles for the table groups.
Top

See Also

Reference

TableGroups Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableGroups Constructor

[image]
ActiveReports 19 .NET Edition
TableGroups Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableGroups Class : TableGroups Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableGroups()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroups Class
TableGroups Members


TableGroups Class Properties

[image]
ActiveReports 19 .NET Edition
TableGroups Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableGroups Class

Glossary Item Box

For a list of all members of this type, see TableGroups members.

Public Properties

 | Name | Description
Public Property | Styles | Gets or sets the styles for the table groups.
Top

See Also

Reference

TableGroups Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Styles Property

[image]
ActiveReports 19 .NET Edition
Styles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableGroups Class : Styles Property

Glossary Item Box

Gets or sets the styles for the table groups.

Syntax

Visual Basic (Declaration)
Public Property Styles As TableStyles()
C#
public TableStyles[] Styles {get; set;}

Property Value

An array of TableStyles representing the styles for the table groups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroups Class
TableGroups Members


TableOfContentsStyleContent Class

[image]
ActiveReports 19 .NET Edition
TableOfContentsStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableOfContentsStyleContent Class

Glossary Item Box

Represents the style content for a table of contents report item.

Object Model

TableOfContentsStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class TableOfContentsStyleContent
C#
public class TableOfContentsStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TableOfContentsStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableOfContentsStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
TableOfContentsStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableOfContentsStyleContent Class

Glossary Item Box

The following tables list the members exposed by TableOfContentsStyleContent.

Public Constructors

 | Name | Description
Public Constructor | TableOfContentsStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the table of contents.
Public Property | Border | Gets or sets the border style of the table of contents.
Public Property | Levels | Gets or sets the levels style content of the table of contents.
Top

See Also

Reference

TableOfContentsStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableOfContentsStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
TableOfContentsStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableOfContentsStyleContent Class : TableOfContentsStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableOfContentsStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsStyleContent Class
TableOfContentsStyleContent Members


TableOfContentsStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
TableOfContentsStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableOfContentsStyleContent Class

Glossary Item Box

For a list of all members of this type, see TableOfContentsStyleContent members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the table of contents.
Public Property | Border | Gets or sets the border style of the table of contents.
Public Property | Levels | Gets or sets the levels style content of the table of contents.
Top

See Also

Reference

TableOfContentsStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableOfContentsStyleContent Class : BackgroundColor Property

Glossary Item Box

Gets or sets the background color of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As String
C#
public string BackgroundColor {get; set;}

Property Value

The background color of the table of contents as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsStyleContent Class
TableOfContentsStyleContent Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableOfContentsStyleContent Class : Border Property

Glossary Item Box

Gets or sets the border style of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property Border As BorderStyle
C#
public BorderStyle Border {get; set;}

Property Value

The border style of the table of contents as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsStyleContent Class
TableOfContentsStyleContent Members


Levels Property

[image]
ActiveReports 19 .NET Edition
Levels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableOfContentsStyleContent Class : Levels Property

Glossary Item Box

Gets or sets the levels style content of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property Levels As Levels
C#
public Levels Levels {get; set;}

Property Value

The levels style content as a Levels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsStyleContent Class
TableOfContentsStyleContent Members


TableStyleContent Class

[image]
ActiveReports 19 .NET Edition
TableStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyleContent Class

Glossary Item Box

Represents the style content for a table report item.

Object Model

TableStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class TableStyleContent
C#
public class TableStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TableStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
TableStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyleContent Class

Glossary Item Box

The following tables list the members exposed by TableStyleContent.

Public Constructors

 | Name | Description
Public Constructor | TableStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border style of the table.
Public Property | Details | Gets or sets the details style content of the table.
Public Property | Footer | Gets or sets the footer style content of the table.
Public Property | Header | Gets or sets the header style content of the table.
Public Property | TableGroups | Gets or sets the table groups style content.
Top

See Also

Reference

TableStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
TableStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : TableStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


TableStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
TableStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyleContent Class

Glossary Item Box

For a list of all members of this type, see TableStyleContent members.

Public Properties

 | Name | Description
Public Property | Border | Gets or sets the border style of the table.
Public Property | Details | Gets or sets the details style content of the table.
Public Property | Footer | Gets or sets the footer style content of the table.
Public Property | Header | Gets or sets the header style content of the table.
Public Property | TableGroups | Gets or sets the table groups style content.
Top

See Also

Reference

TableStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : Border Property

Glossary Item Box

Gets or sets the border style of the table.

Syntax

Visual Basic (Declaration)
Public Property Border As BorderStyle
C#
public BorderStyle Border {get; set;}

Property Value

The border style as a BorderStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : Details Property

Glossary Item Box

Gets or sets the details style content of the table.

Syntax

Visual Basic (Declaration)
Public Property Details As Details
C#
public Details Details {get; set;}

Property Value

The details style content as a Details.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : Footer Property

Glossary Item Box

Gets or sets the footer style content of the table.

Syntax

Visual Basic (Declaration)
Public Property Footer As Footer
C#
public Footer Footer {get; set;}

Property Value

The footer style content as a Footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : Header Property

Glossary Item Box

Gets or sets the header style content of the table.

Syntax

Visual Basic (Declaration)
Public Property Header As Header
C#
public Header Header {get; set;}

Property Value

The header style content as a Header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


TableGroups Property

[image]
ActiveReports 19 .NET Edition
TableGroups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyleContent Class : TableGroups Property

Glossary Item Box

Gets or sets the table groups style content.

Syntax

Visual Basic (Declaration)
Public Property TableGroups As TableGroups
C#
public TableGroups TableGroups {get; set;}

Property Value

The table groups style content as a TableGroups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyleContent Class
TableStyleContent Members


TableStyles Class

[image]
ActiveReports 19 .NET Edition
TableStyles Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyles Class

Glossary Item Box

Represents the style content for the table styles of a table report item.

Object Model

TableStyles Class

Syntax

Visual Basic (Declaration)
Public Class TableStyles
C#
public class TableStyles

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TableStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyles Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableStyles Class Members

[image]
ActiveReports 19 .NET Edition
TableStyles Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyles Class

Glossary Item Box

The following tables list the members exposed by TableStyles.

Public Constructors

 | Name | Description
Public Constructor | TableStyles Constructor |
Top

Public Properties

 | Name | Description
Public Property | Footer | Gets or sets the footer style content for the table styles.
Public Property | Header | Gets or sets the header style content for the table styles.
Top

See Also

Reference

TableStyles Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TableStyles Constructor

[image]
ActiveReports 19 .NET Edition
TableStyles Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyles Class : TableStyles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableStyles()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyles Class
TableStyles Members


TableStyles Class Properties

[image]
ActiveReports 19 .NET Edition
TableStyles Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TableStyles Class

Glossary Item Box

For a list of all members of this type, see TableStyles members.

Public Properties

 | Name | Description
Public Property | Footer | Gets or sets the footer style content for the table styles.
Public Property | Header | Gets or sets the header style content for the table styles.
Top

See Also

Reference

TableStyles Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyles Class : Footer Property

Glossary Item Box

Gets or sets the footer style content for the table styles.

Syntax

Visual Basic (Declaration)
Public Property Footer As Footer
C#
public Footer Footer {get; set;}

Property Value

The footer style content as a Footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyles Class
TableStyles Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TableStyles Class : Header Property

Glossary Item Box

Gets or sets the header style content for the table styles.

Syntax

Visual Basic (Declaration)
Public Property Header As Header
C#
public Header Header {get; set;}

Property Value

The header style content as a Header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableStyles Class
TableStyles Members


Tablix Class

[image]
ActiveReports 19 .NET Edition
Tablix Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Tablix Class

Glossary Item Box

Represents the features for tablix items.

Object Model

Tablix Class

Syntax

Visual Basic (Declaration)
Public Class Tablix
C#
public class Tablix

Remarks

The Tablix class provides properties to configure the features for tablix items, such as hiding cross-aggregates functionality, auto-filling corner cells, and visibility of frozen rows and columns.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.Tablix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


Tablix Class Members

[image]
ActiveReports 19 .NET Edition
Tablix Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Tablix Class

Glossary Item Box

The following tables list the members exposed by Tablix.

Public Constructors

 | Name | Description
Public Constructor | Tablix Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoFillCorner | Gets or sets a value indicating whether the Tablix Corner Cell needs to be auto-filled when a field is dropped to the Tablix Row Group Cell.
Public Property | CanUseWizard | Gets or sets a value indicating whether the Tablix Wizard is available for creating/editing Tablix.
Public Property | CrossAggregates | Gets or sets a value indicating whether the Tablix Wizard should hide cross-aggregates functionality.
Public Property | HideFrozenRowsColumns | Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid and TablixWizard.
Top

See Also

Reference

Tablix Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Tablix Constructor

[image]
ActiveReports 19 .NET Edition
Tablix Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Tablix Class : Tablix Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Tablix()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


Tablix Class Properties

[image]
ActiveReports 19 .NET Edition
Tablix Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Tablix Class

Glossary Item Box

For a list of all members of this type, see Tablix members.

Public Properties

 | Name | Description
Public Property | AutoFillCorner | Gets or sets a value indicating whether the Tablix Corner Cell needs to be auto-filled when a field is dropped to the Tablix Row Group Cell.
Public Property | CanUseWizard | Gets or sets a value indicating whether the Tablix Wizard is available for creating/editing Tablix.
Public Property | CrossAggregates | Gets or sets a value indicating whether the Tablix Wizard should hide cross-aggregates functionality.
Public Property | HideFrozenRowsColumns | Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid and TablixWizard.
Top

See Also

Reference

Tablix Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


AutoFillCorner Property

[image]
ActiveReports 19 .NET Edition
AutoFillCorner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Tablix Class : AutoFillCorner Property

Glossary Item Box

Gets or sets a value indicating whether the Tablix Corner Cell needs to be auto-filled when a field is dropped to the Tablix Row Group Cell.

Syntax

Visual Basic (Declaration)
Public Property AutoFillCorner As Nullable(Of Boolean)
C#
public Nullable<bool> AutoFillCorner {get; set;}

Property Value

true if the Tablix Corner Cell should be auto-filled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


CanUseWizard Property

[image]
ActiveReports 19 .NET Edition
CanUseWizard Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Tablix Class : CanUseWizard Property

Glossary Item Box

Gets or sets a value indicating whether the Tablix Wizard is available for creating/editing Tablix.

Syntax

Visual Basic (Declaration)
Public Property CanUseWizard As Nullable(Of Boolean)
C#
public Nullable<bool> CanUseWizard {get; set;}

Property Value

true if the Tablix Wizard is available; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


CrossAggregates Property

[image]
ActiveReports 19 .NET Edition
CrossAggregates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Tablix Class : CrossAggregates Property

Glossary Item Box

Gets or sets a value indicating whether the Tablix Wizard should hide cross-aggregates functionality.

Syntax

Visual Basic (Declaration)
Public Property CrossAggregates As Nullable(Of Boolean)
C#
public Nullable<bool> CrossAggregates {get; set;}

Property Value

true if cross-aggregates functionality should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


HideFrozenRowsColumns Property

[image]
ActiveReports 19 .NET Edition
HideFrozenRowsColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > Tablix Class : HideFrozenRowsColumns Property

Glossary Item Box

Gets or sets a value indicating whether to hide FrozenRows/FrozenColumns properties from the PropertyGrid and TablixWizard.

Syntax

Visual Basic (Declaration)
Public Property HideFrozenRowsColumns As Nullable(Of Boolean)
C#
public Nullable<bool> HideFrozenRowsColumns {get; set;}

Property Value

true if FrozenRows/FrozenColumns properties should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TextBoxStyleContent Class

[image]
ActiveReports 19 .NET Edition
TextBoxStyleContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TextBoxStyleContent Class

Glossary Item Box

Represents the style content for a text box report item.

Object Model

TextBoxStyleContent Class

Syntax

Visual Basic (Declaration)
Public Class TextBoxStyleContent
C#
public class TextBoxStyleContent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TextBoxStyleContent
GrapeCity.ActiveReports.Blazor.Designer.CellStyleContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TextBoxStyleContent Class Members

[image]
ActiveReports 19 .NET Edition
TextBoxStyleContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TextBoxStyleContent Class

Glossary Item Box

The following tables list the members exposed by TextBoxStyleContent.

Public Constructors

 | Name | Description
Public Constructor | TextBoxStyleContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the text box.
Public Property | Color | Gets or sets the color of the text.
Public Property | FontFamily | Gets or sets the font family of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyle | Gets or sets the font style of the text.
Public Property | FontWeight | Gets or sets the font weight of the text.
Top

See Also

Reference

TextBoxStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TextBoxStyleContent Constructor

[image]
ActiveReports 19 .NET Edition
TextBoxStyleContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : TextBoxStyleContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextBoxStyleContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


TextBoxStyleContent Class Properties

[image]
ActiveReports 19 .NET Edition
TextBoxStyleContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TextBoxStyleContent Class

Glossary Item Box

For a list of all members of this type, see TextBoxStyleContent members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the text box.
Public Property | Color | Gets or sets the color of the text.
Public Property | FontFamily | Gets or sets the font family of the text.
Public Property | FontSize | Gets or sets the font size of the text.
Public Property | FontStyle | Gets or sets the font style of the text.
Public Property | FontWeight | Gets or sets the font weight of the text.
Top

See Also

Reference

TextBoxStyleContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : BackgroundColor Property

Glossary Item Box

Gets or sets the background color of the text box.

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As String
C#
public string BackgroundColor {get; set;}

Property Value

The background color of the text box as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : Color Property

Glossary Item Box

Gets or sets the color of the text.

Syntax

Visual Basic (Declaration)
Public Property Color As String
C#
public string Color {get; set;}

Property Value

The color of the text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : FontFamily Property

Glossary Item Box

Gets or sets the font family of the text.

Syntax

Visual Basic (Declaration)
Public Property FontFamily As String
C#
public string FontFamily {get; set;}

Property Value

The font family of the text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : FontSize Property

Glossary Item Box

Gets or sets the font size of the text.

Syntax

Visual Basic (Declaration)
Public Property FontSize As String
C#
public string FontSize {get; set;}

Property Value

The font size of the text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : FontStyle Property

Glossary Item Box

Gets or sets the font style of the text.

Syntax

Visual Basic (Declaration)
Public Property FontStyle As String
C#
public string FontStyle {get; set;}

Property Value

The font style of the text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TextBoxStyleContent Class : FontWeight Property

Glossary Item Box

Gets or sets the font weight of the text.

Syntax

Visual Basic (Declaration)
Public Property FontWeight As String
C#
public string FontWeight {get; set;}

Property Value

The font weight of the text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxStyleContent Class
TextBoxStyleContent Members


TitleSettings Class

[image]
ActiveReports 19 .NET Edition
TitleSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TitleSettings Class

Glossary Item Box

Represents a settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.

Object Model

TitleSettings Class

Syntax

Visual Basic (Declaration)
Public Class TitleSettings
C#
public class TitleSettings

Remarks

The TitleSettings class provides a property to configure whether the browser tab title can be updated.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.TitleSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitleSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


TitleSettings Class Members

[image]
ActiveReports 19 .NET Edition
TitleSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TitleSettings Class

Glossary Item Box

The following tables list the members exposed by TitleSettings.

Public Constructors

 | Name | Description
Public Constructor | TitleSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Disabled | Gets or sets a value indicating whether the browser tab title can be updated.
Top

See Also

Reference

TitleSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


TitleSettings Constructor

[image]
ActiveReports 19 .NET Edition
TitleSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TitleSettings Class : TitleSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TitleSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitleSettings Class
TitleSettings Members


TitleSettings Class Properties

[image]
ActiveReports 19 .NET Edition
TitleSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : TitleSettings Class

Glossary Item Box

For a list of all members of this type, see TitleSettings members.

Public Properties

 | Name | Description
Public Property | Disabled | Gets or sets a value indicating whether the browser tab title can be updated.
Top

See Also

Reference

TitleSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Disabled Property

[image]
ActiveReports 19 .NET Edition
Disabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > TitleSettings Class : Disabled Property

Glossary Item Box

Gets or sets a value indicating whether the browser tab title can be updated.

Syntax

Visual Basic (Declaration)
Public Property Disabled As Nullable(Of Boolean)
C#
public Nullable<bool> Disabled {get; set;}

Property Value

true if the browser tab title can be updated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitleSettings Class
TitleSettings Members


ToggleGridButton Class

[image]
ActiveReports 19 .NET Edition
ToggleGridButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleGridButton Class

Glossary Item Box

Represents the settings for the toggle grid button.

Object Model

ToggleGridButton Class

Syntax

Visual Basic (Declaration)
Public Class ToggleGridButton
C#
public class ToggleGridButton

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ToggleGridButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGridButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToggleGridButton Class Members

[image]
ActiveReports 19 .NET Edition
ToggleGridButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleGridButton Class

Glossary Item Box

The following tables list the members exposed by ToggleGridButton.

Public Constructors

 | Name | Description
Public Constructor | ToggleGridButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the grid toggle button should be shown.
Top

See Also

Reference

ToggleGridButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToggleGridButton Constructor

[image]
ActiveReports 19 .NET Edition
ToggleGridButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToggleGridButton Class : ToggleGridButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToggleGridButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGridButton Class
ToggleGridButton Members


ToggleGridButton Class Properties

[image]
ActiveReports 19 .NET Edition
ToggleGridButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleGridButton Class

Glossary Item Box

For a list of all members of this type, see ToggleGridButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the grid toggle button should be shown.
Top

See Also

Reference

ToggleGridButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToggleGridButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the grid toggle button should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the grid toggle button should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleGridButton Class
ToggleGridButton Members


ToggleUnitsButton Class

[image]
ActiveReports 19 .NET Edition
ToggleUnitsButton Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleUnitsButton Class

Glossary Item Box

Represents the settings for the toggle units button.

Object Model

ToggleUnitsButton Class

Syntax

Visual Basic (Declaration)
Public Class ToggleUnitsButton
C#
public class ToggleUnitsButton

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ToggleUnitsButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleUnitsButton Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToggleUnitsButton Class Members

[image]
ActiveReports 19 .NET Edition
ToggleUnitsButton Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleUnitsButton Class

Glossary Item Box

The following tables list the members exposed by ToggleUnitsButton.

Public Constructors

 | Name | Description
Public Constructor | ToggleUnitsButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the units button should be shown.
Top

See Also

Reference

ToggleUnitsButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToggleUnitsButton Constructor

[image]
ActiveReports 19 .NET Edition
ToggleUnitsButton Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToggleUnitsButton Class : ToggleUnitsButton Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToggleUnitsButton()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleUnitsButton Class
ToggleUnitsButton Members


ToggleUnitsButton Class Properties

[image]
ActiveReports 19 .NET Edition
ToggleUnitsButton Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToggleUnitsButton Class

Glossary Item Box

For a list of all members of this type, see ToggleUnitsButton members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the units button should be shown.
Top

See Also

Reference

ToggleUnitsButton Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToggleUnitsButton Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the units button should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the units button should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleUnitsButton Class
ToggleUnitsButton Members


ToolBarSettings Class

[image]
ActiveReports 19 .NET Edition
ToolBarSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBarSettings Class

Glossary Item Box

Represents a settings for the Tool Bar.

Object Model

ToolBarSettings Class

Syntax

Visual Basic (Declaration)
Public Class ToolBarSettings
C#
public class ToolBarSettings

Remarks

The ToolBarSettings class provides a property to configure the visibility of the Tool Bar in the Designer's UI.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ToolBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBarSettings Class Members

[image]
ActiveReports 19 .NET Edition
ToolBarSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBarSettings Class

Glossary Item Box

The following tables list the members exposed by ToolBarSettings.

Public Constructors

 | Name | Description
Public Constructor | ToolBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Tool Bar should be shown.
Top

See Also

Reference

ToolBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBarSettings Constructor

[image]
ActiveReports 19 .NET Edition
ToolBarSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBarSettings Class : ToolBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolBarSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarSettings Class
ToolBarSettings Members


ToolBarSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ToolBarSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBarSettings Class

Glossary Item Box

For a list of all members of this type, see ToolBarSettings members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the Tool Bar should be shown.
Top

See Also

Reference

ToolBarSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBarSettings Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Tool Bar should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Tool Bar should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarSettings Class
ToolBarSettings Members


ToolBox Class

[image]
ActiveReports 19 .NET Edition
ToolBox Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBox Class

Glossary Item Box

Represents the Tool Box settings.

Object Model

ToolBox Class

Syntax

Visual Basic (Declaration)
Public Class ToolBox
C#
public class ToolBox

Remarks

The ToolBox class provides a property to configure the visibility of the Tool Box in the left-side menu.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ToolBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBox Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBox Class Members

[image]
ActiveReports 19 .NET Edition
ToolBox Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBox Class

Glossary Item Box

The following tables list the members exposed by ToolBox.

Public Constructors

 | Name | Description
Public Constructor | ToolBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the left-side menu Tool Box should be shown.
Top

See Also

Reference

ToolBox Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBox Constructor

[image]
ActiveReports 19 .NET Edition
ToolBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBox Class : ToolBox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBox Class
ToolBox Members


ToolBox Class Properties

[image]
ActiveReports 19 .NET Edition
ToolBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBox Class

Glossary Item Box

For a list of all members of this type, see ToolBox members.

Public Properties

 | Name | Description
Public Property | Visible | Gets or sets a value indicating whether the left-side menu Tool Box should be shown.
Top

See Also

Reference

ToolBox Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBox Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the left-side menu Tool Box should be shown.

Syntax

Visual Basic (Declaration)
Public Property Visible As Nullable(Of Boolean)
C#
public Nullable<bool> Visible {get; set;}

Property Value

true if the Tool Box should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBox Class
ToolBox Members


ToolBoxContent Class

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBoxContent Class

Glossary Item Box

Represents report items on toolBox and their order.

Object Model

ToolBoxContent Class

Syntax

Visual Basic (Declaration)
Public Class ToolBoxContent
C#
public class ToolBoxContent

Remarks

The ToolBoxContent class provides properties to configure the report items and their order for CPL and FPL reports.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ToolBoxContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBoxContent Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBoxContent Class Members

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBoxContent Class

Glossary Item Box

The following tables list the members exposed by ToolBoxContent.

Public Constructors

 | Name | Description
Public Constructor | ToolBoxContent Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cpl | Gets or sets the report items on the ToolBox and their order for CPL reports.
Public Property | Fpl | Gets or sets the report items on the ToolBox and their order for FPL reports.
Top

See Also

Reference

ToolBoxContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ToolBoxContent Constructor

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBoxContent Class : ToolBoxContent Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolBoxContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBoxContent Class
ToolBoxContent Members


ToolBoxContent Class Properties

[image]
ActiveReports 19 .NET Edition
ToolBoxContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ToolBoxContent Class

Glossary Item Box

For a list of all members of this type, see ToolBoxContent members.

Public Properties

 | Name | Description
Public Property | Cpl | Gets or sets the report items on the ToolBox and their order for CPL reports.
Public Property | Fpl | Gets or sets the report items on the ToolBox and their order for FPL reports.
Top

See Also

Reference

ToolBoxContent Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Cpl Property

[image]
ActiveReports 19 .NET Edition
Cpl Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBoxContent Class : Cpl Property

Glossary Item Box

Gets or sets the report items on the ToolBox and their order for CPL reports.

Syntax

Visual Basic (Declaration)
Public Property Cpl As RdlxToolBoxItem()
C#
public RdlxToolBoxItem[] Cpl {get; set;}

Property Value

An array of RdlxToolBoxItem that contains the report items and their order for CPL reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBoxContent Class
ToolBoxContent Members


Fpl Property

[image]
ActiveReports 19 .NET Edition
Fpl Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ToolBoxContent Class : Fpl Property

Glossary Item Box

Gets or sets the report items on the ToolBox and their order for FPL reports.

Syntax

Visual Basic (Declaration)
Public Property Fpl As RdlxToolBoxItem()
C#
public RdlxToolBoxItem[] Fpl {get; set;}

Property Value

An array of RdlxToolBoxItem that contains the report items and their order for FPL reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBoxContent Class
ToolBoxContent Members


UpdateDocumentOptions Class

[image]
ActiveReports 19 .NET Edition
UpdateDocumentOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : UpdateDocumentOptions Class

Glossary Item Box

Represents the options for updating document information.

Object Model

UpdateDocumentOptions Class

Syntax

Visual Basic (Declaration)
Public Class UpdateDocumentOptions
C#
public class UpdateDocumentOptions

Remarks

The UpdateDocumentOptions class provides properties to configure the name, ID, type, and platform of the document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.UpdateDocumentOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


UpdateDocumentOptions Class Members

[image]
ActiveReports 19 .NET Edition
UpdateDocumentOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : UpdateDocumentOptions Class

Glossary Item Box

The following tables list the members exposed by UpdateDocumentOptions.

Public Constructors

 | Name | Description
Public Constructor | UpdateDocumentOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the document.
Public Property | Name | Gets or sets the name of the document.
Public Property | Platform | Gets or sets the platform type of the document.
Public Property | Type | Gets or sets the type of the document.
Top

See Also

Reference

UpdateDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


UpdateDocumentOptions Constructor

[image]
ActiveReports 19 .NET Edition
UpdateDocumentOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > UpdateDocumentOptions Class : UpdateDocumentOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UpdateDocumentOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Class
UpdateDocumentOptions Members


UpdateDocumentOptions Class Properties

[image]
ActiveReports 19 .NET Edition
UpdateDocumentOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : UpdateDocumentOptions Class

Glossary Item Box

For a list of all members of this type, see UpdateDocumentOptions members.

Public Properties

 | Name | Description
Public Property | Id | Gets or sets the ID of the document.
Public Property | Name | Gets or sets the name of the document.
Public Property | Platform | Gets or sets the platform type of the document.
Public Property | Type | Gets or sets the type of the document.
Top

See Also

Reference

UpdateDocumentOptions Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > UpdateDocumentOptions Class : Id Property

Glossary Item Box

Gets or sets the ID of the document.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

The ID of the document as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Class
UpdateDocumentOptions Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > UpdateDocumentOptions Class : Name Property

Glossary Item Box

Gets or sets the name of the document.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the document as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Class
UpdateDocumentOptions Members


Platform Property

[image]
ActiveReports 19 .NET Edition
Platform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > UpdateDocumentOptions Class : Platform Property

Glossary Item Box

Gets or sets the platform type of the document.

Syntax

Visual Basic (Declaration)
Public Property Platform As Nullable(Of PlatformType)
C#
public Nullable<PlatformType> Platform {get; set;}

Property Value

The platform type of the document as a nullable PlatformType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Class
UpdateDocumentOptions Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > UpdateDocumentOptions Class : Type Property

Glossary Item Box

Gets or sets the type of the document.

Syntax

Visual Basic (Declaration)
Public Property Type As Nullable(Of DocumentType)
C#
public Nullable<DocumentType> Type {get; set;}

Property Value

The type of the document as a nullable DocumentType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateDocumentOptions Class
UpdateDocumentOptions Members


ViewerSettings Class

[image]
ActiveReports 19 .NET Edition
ViewerSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings Class

Glossary Item Box

Represents the settings for the viewer.

Object Model

ViewerSettings Class

Syntax

Visual Basic (Declaration)
Public Class ViewerSettings
C#
public class ViewerSettings

Remarks

The ViewerSettings class provides properties to configure the element ID, application title, document information, and UI theme for the viewer.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ViewerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ViewerSettings Class Members

[image]
ActiveReports 19 .NET Edition
ViewerSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings Class

Glossary Item Box

The following tables list the members exposed by ViewerSettings.

Public Constructors

 | Name | Description
Public Constructor | ViewerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplicationTitle | Gets or sets the application title passed by the Designer.
Public Property | DocumentInfo | Gets or sets the information on the report to be previewed.
Public Property | Element | Gets or sets the ID of the element where the viewer should be rendered.
Public Property | Theme | Gets or sets the UI theme for the viewer.
Top

See Also

Reference

ViewerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ViewerSettings Constructor

[image]
ActiveReports 19 .NET Edition
ViewerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings Class : ViewerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ViewerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Class
ViewerSettings Members


ViewerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ViewerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings Class

Glossary Item Box

For a list of all members of this type, see ViewerSettings members.

Public Properties

 | Name | Description
Public Property | ApplicationTitle | Gets or sets the application title passed by the Designer.
Public Property | DocumentInfo | Gets or sets the information on the report to be previewed.
Public Property | Element | Gets or sets the ID of the element where the viewer should be rendered.
Public Property | Theme | Gets or sets the UI theme for the viewer.
Top

See Also

Reference

ViewerSettings Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ApplicationTitle Property

[image]
ActiveReports 19 .NET Edition
ApplicationTitle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings Class : ApplicationTitle Property

Glossary Item Box

Gets or sets the application title passed by the Designer.

Syntax

Visual Basic (Declaration)
Public Property ApplicationTitle As String
C#
public string ApplicationTitle {get; set;}

Property Value

The application title as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Class
ViewerSettings Members


DocumentInfo Property

[image]
ActiveReports 19 .NET Edition
DocumentInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings Class : DocumentInfo Property

Glossary Item Box

Gets or sets the information on the report to be previewed.

Syntax

Visual Basic (Declaration)
Public Property DocumentInfo As ViewerSettings.ViewerDocumentInfo
C#
public ViewerSettings.ViewerDocumentInfo DocumentInfo {get; set;}

Property Value

An instance of ViewerSettings.ViewerDocumentInfo that contains the report information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Class
ViewerSettings Members


Element Property

[image]
ActiveReports 19 .NET Edition
Element Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings Class : Element Property

Glossary Item Box

Gets or sets the ID of the element where the viewer should be rendered.

Syntax

Visual Basic (Declaration)
Public Property Element As String
C#
public string Element {get; set;}

Property Value

The ID of the element as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Class
ViewerSettings Members


Theme Property

[image]
ActiveReports 19 .NET Edition
Theme Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings Class : Theme Property

Glossary Item Box

Gets or sets the UI theme for the viewer.

Syntax

Visual Basic (Declaration)
Public Property Theme As ColorTheme
C#
public ColorTheme Theme {get; set;}

Property Value

An instance of GrapeCity.ActiveReports.Blazor.Viewer.ColorTheme that contains the UI theme settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings Class
ViewerSettings Members


ViewerSettings.ViewerDocumentInfo Class

[image]
ActiveReports 19 .NET Edition
ViewerSettings.ViewerDocumentInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings.ViewerDocumentInfo Class

Glossary Item Box

Represents information about the document to be previewed in the viewer.

Object Model

ViewerSettings.ViewerDocumentInfo Class

Syntax

Visual Basic (Declaration)
Public Class ViewerSettings.ViewerDocumentInfo
C#
public class ViewerSettings.ViewerDocumentInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.ViewerSettings.ViewerDocumentInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Members
GrapeCity.ActiveReports.Blazor.Designer Namespace


ViewerSettings.ViewerDocumentInfo Class Members

[image]
ActiveReports 19 .NET Edition
ViewerSettings.ViewerDocumentInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings.ViewerDocumentInfo Class

Glossary Item Box

The following tables list the members exposed by ViewerSettings.ViewerDocumentInfo.

Public Constructors

 | Name | Description
Public Constructor | ViewerSettings.ViewerDocumentInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the report content in JSON format, useful for report viewers with in-browser rendering.
Public Property | Id | Gets or sets the ID of the report.
Public Property | Name | Gets or sets the name of the report.
Public Property | PreferredFormat | Gets or sets the preferred rendering format for the document.
Public Property | Temporary | Gets or sets a value indicating whether the report to be previewed is a temporary report saved on the server side.
Top

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


ViewerSettings.ViewerDocumentInfo Constructor

[image]
ActiveReports 19 .NET Edition
ViewerSettings.ViewerDocumentInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : ViewerSettings.ViewerDocumentInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ViewerSettings.ViewerDocumentInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


ViewerSettings.ViewerDocumentInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ViewerSettings.ViewerDocumentInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings.ViewerDocumentInfo Class

Glossary Item Box

For a list of all members of this type, see ViewerSettings.ViewerDocumentInfo members.

Public Properties

 | Name | Description
Public Property | Content | Gets or sets the report content in JSON format, useful for report viewers with in-browser rendering.
Public Property | Id | Gets or sets the ID of the report.
Public Property | Name | Gets or sets the name of the report.
Public Property | PreferredFormat | Gets or sets the preferred rendering format for the document.
Public Property | Temporary | Gets or sets a value indicating whether the report to be previewed is a temporary report saved on the server side.
Top

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : Content Property

Glossary Item Box

Gets or sets the report content in JSON format, useful for report viewers with in-browser rendering.

Syntax

Visual Basic (Declaration)
Public Property Content As Object
C#
public object Content {get; set;}

Property Value

The report content as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : Id Property

Glossary Item Box

Gets or sets the ID of the report.

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id {get; set;}

Property Value

The ID of the report as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : Name Property

Glossary Item Box

Gets or sets the name of the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the report as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


PreferredFormat Property

[image]
ActiveReports 19 .NET Edition
PreferredFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : PreferredFormat Property

Glossary Item Box

Gets or sets the preferred rendering format for the document.

Syntax

Visual Basic (Declaration)
Public Property PreferredFormat As Nullable(Of ViewerSettings.PreferredFormat)
C#
public Nullable<ViewerSettings.PreferredFormat> PreferredFormat {get; set;}

Property Value

A nullable PreferredFormat value that specifies the preferred rendering format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


Temporary Property

[image]
ActiveReports 19 .NET Edition
Temporary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ViewerSettings.ViewerDocumentInfo Class : Temporary Property

Glossary Item Box

Gets or sets a value indicating whether the report to be previewed is a temporary report saved on the server side.

Syntax

Visual Basic (Declaration)
Public Property Temporary As Nullable(Of Boolean)
C#
public Nullable<bool> Temporary {get; set;}

Property Value

true if the report is temporary; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ViewerSettings.ViewerDocumentInfo Class
ViewerSettings.ViewerDocumentInfo Members


DocumentType Enumeration

[image]
ActiveReports 19 .NET Edition
DocumentType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : DocumentType Enumeration

Glossary Item Box

Represents the document type.

Syntax

Visual Basic (Declaration)
Public Enum DocumentType
   Inherits System.Enum
C#
public enum DocumentType : System.Enum

Members

Member | Description
dashboard | Dashboard document type.
report | Report document type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.DocumentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


ExpressionSyntax Enumeration

[image]
ActiveReports 19 .NET Edition
ExpressionSyntax Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ExpressionSyntax Enumeration

Glossary Item Box

Specifies the expression syntax used in Designer.

Syntax

Visual Basic (Declaration)
Public Enum ExpressionSyntax
   Inherits System.Enum
C#
public enum ExpressionSyntax : System.Enum

Members

Member | Description
i11n | Interpolation syntax
rdl | "old" rdl expression syntax

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.ExpressionSyntax

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


Level Enumeration

[image]
ActiveReports 19 .NET Edition
Level Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Level Enumeration

Glossary Item Box

Notification level. Determines the color and icons used for the notifications.

Syntax

Visual Basic (Declaration)
Public Enum Level
   Inherits System.Enum
C#
public enum Level : System.Enum

Members

Member | Description
error | Error notification.
info | Informational notification.
warning | Warning notification.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.Level

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


Mode Enumeration

[image]
ActiveReports 19 .NET Edition
Mode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Mode Enumeration

Glossary Item Box

Specifies the default properties mode.

Syntax

Visual Basic (Declaration)
Public Enum Mode
   Inherits System.Enum
C#
public enum Mode : System.Enum

Members

Member | Description
Advanced | Advanced properties mode.
Basic | Basic properties mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.Mode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


PlatformType Enumeration

[image]
ActiveReports 19 .NET Edition
PlatformType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : PlatformType Enumeration

Glossary Item Box

Represents the platform type.

Syntax

Visual Basic (Declaration)
Public Enum PlatformType
   Inherits System.Enum
C#
public enum PlatformType : System.Enum

Members

Member | Description
rdlx | RDLX platform type.
rpx | RPX platform type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.PlatformType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


Providers Enumeration

[image]
ActiveReports 19 .NET Edition
Providers Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Providers Enumeration

Glossary Item Box

Specifies the various data providers.

Syntax

Visual Basic (Declaration)
Public Enum Providers
   Inherits System.Enum
C#
public enum Providers : System.Enum

Members

Member | Description
CSV | CSV data provider.
JSON | JSON data provider.
ODBC | ODBC data provider.
OLEDB | OLEDB data provider.
SQL | SQL data provider.
XML | XML data provider.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.Providers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxBarcodeSymbology Enumeration

[image]
ActiveReports 19 .NET Edition
RdlxBarcodeSymbology Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxBarcodeSymbology Enumeration

Glossary Item Box

Represents the barcode symbology types available for RDLX.

Syntax

Visual Basic (Declaration)
Public Enum RdlxBarcodeSymbology
   Inherits System.Enum
C#
public enum RdlxBarcodeSymbology : System.Enum

Members

Member | Description
Ansi39 | ANSI 39 barcode symbology.
Ansi39x | ANSI 39 Extended barcode symbology.
Aztec | Aztec barcode symbology.
BC412 | BC 412 barcode symbology.
Codabar | Codabar barcode symbology.
Code_11 | Code 11 barcode symbology.
Code_128_A | Code 128A barcode symbology.
Code_128_B | Code 128B barcode symbology.
Code_128_C | Code 128C barcode symbology.
Code_128auto | Code 128 Auto barcode symbology.
Code_2_of_5 | Code 2 of 5 barcode symbology.
Code_93 | Code 93 barcode symbology.
Code25intlv | Code 25 Interleaved barcode symbology.
Code39 | Code 39 barcode symbology.
Code39x | Code 39 Extended barcode symbology.
Code49 | Code 49 barcode symbology.
Code93x | Code 93 Extended barcode symbology.
DataMatrix | Data Matrix barcode symbology.
EAN_13 | EAN-13 barcode symbology.
EAN_8 | EAN-8 barcode symbology.
EAN128FNC1 | EAN 128 FNC1 barcode symbology.
GS1QRCode | GS1 QR Code barcode symbology.
HIBCCode128 | HIBC Code 128 barcode symbology.
HIBCCode39 | HIBC Code 39 barcode symbology.
IATA_2_of_5 | IATA 2 of 5 barcode symbology.
IntelligentMail | Intelligent Mail barcode symbology.
IntelligentMailPackage | Intelligent Mail Package barcode symbology.
ISBN | ISBN barcode symbology.
ISMN | ISMN barcode symbology.
ISSN | ISSN barcode symbology.
ITF14 | ITF-14 barcode symbology.
JapanesePostal | Japanese Postal barcode symbology.
Matrix_2_of_5 | Matrix 2 of 5 barcode symbology.
MaxiCode | MaxiCode barcode symbology.
MicroPDF417 | Micro PDF417 barcode symbology.
MicroQRCode | Micro QR Code barcode symbology.
MSI | MSI barcode symbology.
Pdf417 | PDF417 barcode symbology.
Pharmacode | Pharmacode barcode symbology.
Plessey | Plessey barcode symbology.
PostNet | PostNet barcode symbology.
PZN | PZN barcode symbology.
QRCode | QR Code barcode symbology.
RM4SCC | RM4SCC barcode symbology.
RSS14 | RSS14 barcode symbology.
RSS14Stacked | RSS14 Stacked barcode symbology.
RSS14StackedOmnidirectional | RSS14 Stacked Omnidirectional barcode symbology.
RSS14Truncated | RSS14 Truncated barcode symbology.
RSSExpanded | RSS Expanded barcode symbology.
RSSExpandedStacked | RSS Expanded Stacked barcode symbology.
RSSLimited | RSS Limited barcode symbology.
SSCC_18 | SSCC-18 barcode symbology.
Telepen | Telepen barcode symbology.
UCCEAN128 | UCC/EAN-128 barcode symbology.
UPC_A | UPC-A barcode symbology.
UPC_E0 | UPC-E0 barcode symbology.
UPC_E1 | UPC-E1 barcode symbology.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.RdlxBarcodeSymbology

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


RdlxToolBoxItem Enumeration

[image]
ActiveReports 19 .NET Edition
RdlxToolBoxItem Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RdlxToolBoxItem Enumeration

Glossary Item Box

Specifies the RDLX toolbox item types.

Syntax

Visual Basic (Declaration)
Public Enum RdlxToolBoxItem
   Inherits System.Enum
C#
public enum RdlxToolBoxItem : System.Enum

Members

Member | Description
bandedlist | BandedList item.
barcode | Barcode item.
bullet | Bullet item.
chart | Chart item.
checkbox | CheckBox item.
container | Container item.
formattedtext | FormattedText item.
image | Image item.
inputfield | InputField item.
line | Line item.
list | List item.
overflowplaceholder | OverflowPlaceholder item.
shape | Shape item.
sparkline | Sparkline item.
subreport | SubReport item.
table | Table item.
tableofcontents | Table of Contents item.
tablix | Tablix item.
textbox | TextBox item.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.RdlxToolBoxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


RpxToolBoxItem Enumeration

[image]
ActiveReports 19 .NET Edition
RpxToolBoxItem Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : RpxToolBoxItem Enumeration

Glossary Item Box

Represents the RPX toolbox item types.

Syntax

Visual Basic (Declaration)
Public Enum RpxToolBoxItem
   Inherits System.Enum
C#
public enum RpxToolBoxItem : System.Enum

Members

Member | Description
Barcode | Barcode item.
CheckBox | CheckBox item.
CrossSectionBox | CrossSectionBox item.
CrossSectionLine | CrossSectionLine item.
InputFieldCheckBox | InputFieldCheckBox item.
InputFieldText | InputFieldText item.
Label | Label item.
Line | Line item.
PageBreak | PageBreak item.
Picture | Picture item.
ReportInfo | ReportInfo item.
RichTextBox | RichTextBox item.
Shape | Shape item.
SubReport | SubReport item.
TextBox | TextBox item.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.RpxToolBoxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


Sort Enumeration

[image]
ActiveReports 19 .NET Edition
Sort Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Sort Enumeration

Glossary Item Box

Specifies the default properties sort mode.

Syntax

Visual Basic (Declaration)
Public Enum Sort
   Inherits System.Enum
C#
public enum Sort : System.Enum

Members

Member | Description
alphabetical | Sort properties alphabetically.
categorized | Sort properties by category.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.Sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


SupportedDocumentType Enumeration

[image]
ActiveReports 19 .NET Edition
SupportedDocumentType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : SupportedDocumentType Enumeration

Glossary Item Box

Specifies the type of documents supported by the AR Web Designer.

Syntax

Visual Basic (Declaration)
Public Enum SupportedDocumentType
   Inherits System.Enum
C#
public enum SupportedDocumentType : System.Enum

Members

Member | Description
cpl | RDL Report.
dashboard | RDL Dashboard Report.
fpl | Page Report.
msl | RDL Multi-Section Report.
rpx | Section Report.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.SupportedDocumentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


Units Enumeration

[image]
ActiveReports 19 .NET Edition
Units Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : Units Enumeration

Glossary Item Box

Specifies the measurement units used in the Designer.

Syntax

Visual Basic (Declaration)
Public Enum Units
   Inherits System.Enum
C#
public enum Units : System.Enum

Members

Member | Description
Cm | Centimeters.
In | Inches.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.Units

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


ViewerSettings.PreferredFormat Enumeration

[image]
ActiveReports 19 .NET Edition
ViewerSettings.PreferredFormat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ViewerSettings.PreferredFormat Enumeration

Glossary Item Box

Enum representing preferred rendering formats.

Syntax

Visual Basic (Declaration)
Public Enum ViewerSettings.PreferredFormat
   Inherits System.Enum
C#
public enum ViewerSettings.PreferredFormat : System.Enum

Members

Member | Description
html | Render the document in HTML format.
svg | Render the document in SVG format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Designer.ViewerSettings.PreferredFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Designer Namespace


_Imports Class

[image]
ActiveReports 19 .NET Edition
_Imports Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : _Imports Class

Glossary Item Box

Object Model

_Imports Class

Syntax

Visual Basic (Declaration)
Public Class _Imports
   Inherits Microsoft.AspNetCore.Components.ComponentBase
   Implements Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent
C#
public class _Imports : Microsoft.AspNetCore.Components.ComponentBase, Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent

Inheritance Hierarchy

System.Object
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Viewer._Imports

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


_Imports Class Members

[image]
ActiveReports 19 .NET Edition
_Imports Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : _Imports Class

Glossary Item Box

The following tables list the members exposed by _Imports.

Public Constructors

 | Name | Description
Public Constructor | _Imports Constructor |
Top

See Also

Reference

_Imports Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


_Imports Constructor

[image]
ActiveReports 19 .NET Edition
_Imports Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > _Imports Class : _Imports Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public _Imports()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Class
_Imports Members


Area Class

[image]
ActiveReports 19 .NET Edition
Area Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Area Class

Glossary Item Box

Represents a rectangular area defined by its position and dimensions.

Object Model

Area Class

Syntax

Visual Basic (Declaration)
Public Class Area
C#
public class Area

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Area

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Area Class Members

[image]
ActiveReports 19 .NET Edition
Area Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Area Class

Glossary Item Box

The following tables list the members exposed by Area.

Public Constructors

 | Name | Description
Public Constructor | Area Constructor |
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the area.
Public Property | Left | Gets or sets the left position of the area.
Public Property | Top | Gets or sets the top position of the area.
Public Property | Width | Gets or sets the width of the area.
Top

See Also

Reference

Area Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Area Constructor

[image]
ActiveReports 19 .NET Edition
Area Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Area Class : Area Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Area()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Class
Area Members


Area Class Properties

[image]
ActiveReports 19 .NET Edition
Area Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Area Class

Glossary Item Box

For a list of all members of this type, see Area members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the area.
Public Property | Left | Gets or sets the left position of the area.
Public Property | Top | Gets or sets the top position of the area.
Public Property | Width | Gets or sets the width of the area.
Top

See Also

Reference

Area Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Area Class : Height Property

Glossary Item Box

Gets or sets the height of the area.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the area, measured in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Class
Area Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Area Class : Left Property

Glossary Item Box

Gets or sets the left position of the area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

The horizontal position of the left boundary of the area, measured in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Class
Area Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Area Class : Top Property

Glossary Item Box

Gets or sets the top position of the area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

The vertical position of the top boundary of the area, measured in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Class
Area Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Area Class : Width Property

Glossary Item Box

Gets or sets the width of the area.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the area, measured in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Area Class
Area Members


BookmarkInfo Class

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : BookmarkInfo Class

Glossary Item Box

Represents information about a bookmark in a document.

Object Model

BookmarkInfo Class

Syntax

Visual Basic (Declaration)
Public Class BookmarkInfo
C#
public class BookmarkInfo

Remarks

The BookmarkInfo class contains properties that provide details about a bookmark, including its unique identifier, name, page number, and any child bookmarks.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.BookmarkInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


BookmarkInfo Class Members

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : BookmarkInfo Class

Glossary Item Box

The following tables list the members exposed by BookmarkInfo.

Public Constructors

 | Name | Description
Public Constructor | BookmarkInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bookmark | Gets or sets the unique identifier or reference for the bookmark.
Public Property | IsLeaf | Gets or sets a value indicating whether this bookmark is a leaf node, meaning it has no child bookmarks.
Public Property | Kids | Gets or sets an array of child bookmarks, representing the hierarchical structure of bookmarks.
Public Property | Name | Gets or sets the name of the bookmark.
Public Property | Page | Gets or sets the page number where the bookmark is located.
Top

See Also

Reference

BookmarkInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


BookmarkInfo Constructor

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : BookmarkInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BookmarkInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


BookmarkInfo Class Properties

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : BookmarkInfo Class

Glossary Item Box

For a list of all members of this type, see BookmarkInfo members.

Public Properties

 | Name | Description
Public Property | Bookmark | Gets or sets the unique identifier or reference for the bookmark.
Public Property | IsLeaf | Gets or sets a value indicating whether this bookmark is a leaf node, meaning it has no child bookmarks.
Public Property | Kids | Gets or sets an array of child bookmarks, representing the hierarchical structure of bookmarks.
Public Property | Name | Gets or sets the name of the bookmark.
Public Property | Page | Gets or sets the page number where the bookmark is located.
Top

See Also

Reference

BookmarkInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : Bookmark Property

Glossary Item Box

Gets or sets the unique identifier or reference for the bookmark.

Syntax

Visual Basic (Declaration)
Public Property Bookmark As String
C#
public string Bookmark {get; set;}

Property Value

The unique identifier of the bookmark as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


IsLeaf Property

[image]
ActiveReports 19 .NET Edition
IsLeaf Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : IsLeaf Property

Glossary Item Box

Gets or sets a value indicating whether this bookmark is a leaf node, meaning it has no child bookmarks.

Syntax

Visual Basic (Declaration)
Public Property IsLeaf As Boolean
C#
public bool IsLeaf {get; set;}

Property Value

true if this bookmark is a leaf node; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


Kids Property

[image]
ActiveReports 19 .NET Edition
Kids Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : Kids Property

Glossary Item Box

Gets or sets an array of child bookmarks, representing the hierarchical structure of bookmarks.

Syntax

Visual Basic (Declaration)
Public Property Kids As BookmarkInfo()
C#
public BookmarkInfo[] Kids {get; set;}

Property Value

An array of BookmarkInfo objects representing child bookmarks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : Name Property

Glossary Item Box

Gets or sets the name of the bookmark.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the bookmark as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > BookmarkInfo Class : Page Property

Glossary Item Box

Gets or sets the page number where the bookmark is located.

Syntax

Visual Basic (Declaration)
Public Property Page As Integer
C#
public int Page {get; set;}

Property Value

The page number as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


ColorTheme Class

[image]
ActiveReports 19 .NET Edition
ColorTheme Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorTheme Class

Glossary Item Box

Represents a color theme.

Object Model

ColorTheme Class

Syntax

Visual Basic (Declaration)
Public Class ColorTheme
C#
public class ColorTheme

Remarks

The ColorTheme class allows for the customization of appearance through primary, secondary, neutral, and other color properties.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ColorTheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ColorTheme Class Members

[image]
ActiveReports 19 .NET Edition
ColorTheme Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorTheme Class

Glossary Item Box

The following tables list the members exposed by ColorTheme.

Public Constructors

 | Name | Description
Public Constructor | ColorTheme Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundMain | Gets or sets the main background color of the theme.
Public Property | BackgroundPanels | Gets or sets the background color of panels in the theme.
Public Property | Error | Gets or sets the error color of the theme.
Public Property | FontFamily | Gets or sets the font family used in the theme.
Public Property | Name | Gets or sets the name of the theme.
Public Property | Neutral | Gets or sets the neutral color of the theme.
Public Property | Primary | Gets or sets the primary color of the theme.
Public Property | Secondary | Gets or sets the secondary color of the theme.
Public Property | Type | Gets or sets the type of the theme (light or dark).
Public Property | Warning | Gets or sets the warning color of the theme.
Top

Public Operators

public Operator Implicit Type Conversion
Top

See Also

Reference

ColorTheme Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ColorTheme Constructor

[image]
ActiveReports 19 .NET Edition
ColorTheme Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : ColorTheme Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ColorTheme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


ColorTheme Class Properties

[image]
ActiveReports 19 .NET Edition
ColorTheme Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorTheme Class

Glossary Item Box

For a list of all members of this type, see ColorTheme members.

Public Properties

 | Name | Description
Public Property | BackgroundMain | Gets or sets the main background color of the theme.
Public Property | BackgroundPanels | Gets or sets the background color of panels in the theme.
Public Property | Error | Gets or sets the error color of the theme.
Public Property | FontFamily | Gets or sets the font family used in the theme.
Public Property | Name | Gets or sets the name of the theme.
Public Property | Neutral | Gets or sets the neutral color of the theme.
Public Property | Primary | Gets or sets the primary color of the theme.
Public Property | Secondary | Gets or sets the secondary color of the theme.
Public Property | Type | Gets or sets the type of the theme (light or dark).
Public Property | Warning | Gets or sets the warning color of the theme.
Top

See Also

Reference

ColorTheme Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


BackgroundMain Property

[image]
ActiveReports 19 .NET Edition
BackgroundMain Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : BackgroundMain Property

Glossary Item Box

Gets or sets the main background color of the theme.

Syntax

Visual Basic (Declaration)
Public Property BackgroundMain As String
C#
public string BackgroundMain {get; set;}

Property Value

A System.String representing the main background color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


BackgroundPanels Property

[image]
ActiveReports 19 .NET Edition
BackgroundPanels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : BackgroundPanels Property

Glossary Item Box

Gets or sets the background color of panels in the theme.

Syntax

Visual Basic (Declaration)
Public Property BackgroundPanels As String
C#
public string BackgroundPanels {get; set;}

Property Value

A System.String representing the background color of panels.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Error Property

[image]
ActiveReports 19 .NET Edition
Error Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Error Property

Glossary Item Box

Gets or sets the error color of the theme.

Syntax

Visual Basic (Declaration)
Public Property Error As ColorThemeItem
C#
public ColorThemeItem Error {get; set;}

Property Value

A ColorThemeItem representing the error color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : FontFamily Property

Glossary Item Box

Gets or sets the font family used in the theme.

Syntax

Visual Basic (Declaration)
Public Property FontFamily As String
C#
public string FontFamily {get; set;}

Property Value

A System.String representing the font family.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Name Property

Glossary Item Box

Gets or sets the name of the theme.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the theme as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Neutral Property

[image]
ActiveReports 19 .NET Edition
Neutral Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Neutral Property

Glossary Item Box

Gets or sets the neutral color of the theme.

Syntax

Visual Basic (Declaration)
Public Property Neutral As ColorThemeItem
C#
public ColorThemeItem Neutral {get; set;}

Property Value

A ColorThemeItem representing the neutral color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Primary Property

[image]
ActiveReports 19 .NET Edition
Primary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Primary Property

Glossary Item Box

Gets or sets the primary color of the theme.

Syntax

Visual Basic (Declaration)
Public Property Primary As ColorThemeItem
C#
public ColorThemeItem Primary {get; set;}

Property Value

A ColorThemeItem representing the primary color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Secondary Property

[image]
ActiveReports 19 .NET Edition
Secondary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Secondary Property

Glossary Item Box

Gets or sets the secondary color of the theme.

Syntax

Visual Basic (Declaration)
Public Property Secondary As ColorThemeItem
C#
public ColorThemeItem Secondary {get; set;}

Property Value

A ColorThemeItem representing the secondary color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Type Property

Glossary Item Box

Gets or sets the type of the theme (light or dark).

Syntax

Visual Basic (Declaration)
Public Property Type As ColorThemeType
C#
public ColorThemeType Type {get; set;}

Property Value

A ColorThemeType value specifying the theme type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Warning Property

[image]
ActiveReports 19 .NET Edition
Warning Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Warning Property

Glossary Item Box

Gets or sets the warning color of the theme.

Syntax

Visual Basic (Declaration)
Public Property Warning As ColorThemeItem
C#
public ColorThemeItem Warning {get; set;}

Property Value

A ColorThemeItem representing the warning color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorTheme Class : Implicit Type Conversion Operator

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal name As String _
) As ColorTheme
C#
public ColorTheme operator implicit(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTheme Class
ColorTheme Members


ColorThemeItem Class

[image]
ActiveReports 19 .NET Edition
ColorThemeItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemeItem Class

Glossary Item Box

Represents a base class for color theme items.

Object Model

ColorThemeItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ColorThemeItem
C#
public abstract class ColorThemeItem

Remarks

The ColorThemeItem class serves as a base class for different types of color representations, such as single colors or shades.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemeItem
GrapeCity.ActiveReports.Blazor.Viewer.ShadesColorItem
GrapeCity.ActiveReports.Blazor.Viewer.SingleColorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemeItem Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ColorThemeItem Class Members

[image]
ActiveReports 19 .NET Edition
ColorThemeItem Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemeItem Class

Glossary Item Box

The following tables list the members exposed by ColorThemeItem.

Public Operators

public Operator Implicit Type Conversion
Top

See Also

Reference

ColorThemeItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemeItem Class : Implicit Type Conversion Operator

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal color As String _
) As ColorThemeItem
C#
public ColorThemeItem operator implicit(
   string color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemeItem Class
ColorThemeItem Members


ColorThemes Class

[image]
ActiveReports 19 .NET Edition
ColorThemes Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemes Class

Glossary Item Box

Predefined color themes.

Object Model

ColorThemes Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ColorThemes
C#
public static class ColorThemes

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ColorThemes Class Members

[image]
ActiveReports 19 .NET Edition
ColorThemes Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemes Class

Glossary Item Box

The following tables list the members exposed by ColorThemes.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActiveReports |
static (Shared in Visual Basic) | ActiveReportsDark |
static (Shared in Visual Basic) | DarkOled |
static (Shared in Visual Basic) | Default |
static (Shared in Visual Basic) | DefaultDark |
static (Shared in Visual Basic) | HighContrast |
static (Shared in Visual Basic) | HighContrastDark |
Top

See Also

Reference

ColorThemes Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ColorThemes Class Fields

[image]
ActiveReports 19 .NET Edition
ColorThemes Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemes Class

Glossary Item Box

For a list of all members of this type, see ColorThemes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActiveReports |
static (Shared in Visual Basic) | ActiveReportsDark |
static (Shared in Visual Basic) | DarkOled |
static (Shared in Visual Basic) | Default |
static (Shared in Visual Basic) | DefaultDark |
static (Shared in Visual Basic) | HighContrast |
static (Shared in Visual Basic) | HighContrastDark |
Top

See Also

Reference

ColorThemes Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ActiveReports Field

[image]
ActiveReports 19 .NET Edition
ActiveReports Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : ActiveReports Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ActiveReports As ColorTheme
C#
public static readonly ColorTheme ActiveReports

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


ActiveReportsDark Field

[image]
ActiveReports 19 .NET Edition
ActiveReportsDark Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : ActiveReportsDark Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ActiveReportsDark As ColorTheme
C#
public static readonly ColorTheme ActiveReportsDark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


DarkOled Field

[image]
ActiveReports 19 .NET Edition
DarkOled Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : DarkOled Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DarkOled As ColorTheme
C#
public static readonly ColorTheme DarkOled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


Default Field

[image]
ActiveReports 19 .NET Edition
Default Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : Default Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As ColorTheme
C#
public static readonly ColorTheme Default

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


DefaultDark Field

[image]
ActiveReports 19 .NET Edition
DefaultDark Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : DefaultDark Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultDark As ColorTheme
C#
public static readonly ColorTheme DefaultDark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


HighContrast Field

[image]
ActiveReports 19 .NET Edition
HighContrast Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : HighContrast Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HighContrast As ColorTheme
C#
public static readonly ColorTheme HighContrast

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


HighContrastDark Field

[image]
ActiveReports 19 .NET Edition
HighContrastDark Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ColorThemes Class : HighContrastDark Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HighContrastDark As ColorTheme
C#
public static readonly ColorTheme HighContrastDark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorThemes Class
ColorThemes Members


ErrorInfo Class

[image]
ActiveReports 19 .NET Edition
ErrorInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ErrorInfo Class

Glossary Item Box

Represents detailed information about an error.

Object Model

ErrorInfo Class

Syntax

Visual Basic (Declaration)
Public Class ErrorInfo
C#
public class ErrorInfo

Remarks

The ErrorInfo class provides properties to describe an error, including a brief message, detailed information, and the severity level of the error.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ErrorInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorInfo Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ErrorInfo Class Members

[image]
ActiveReports 19 .NET Edition
ErrorInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ErrorInfo Class

Glossary Item Box

The following tables list the members exposed by ErrorInfo.

Public Constructors

 | Name | Description
Public Constructor | ErrorInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Details | Gets or sets detailed information about the error.
Public Property | Message | Gets or sets the main message describing the error.
Public Property | Severity | Gets or sets the severity level of the error.
Top

See Also

Reference

ErrorInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ErrorInfo Constructor

[image]
ActiveReports 19 .NET Edition
ErrorInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ErrorInfo Class : ErrorInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ErrorInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorInfo Class
ErrorInfo Members


ErrorInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ErrorInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ErrorInfo Class

Glossary Item Box

For a list of all members of this type, see ErrorInfo members.

Public Properties

 | Name | Description
Public Property | Details | Gets or sets detailed information about the error.
Public Property | Message | Gets or sets the main message describing the error.
Public Property | Severity | Gets or sets the severity level of the error.
Top

See Also

Reference

ErrorInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ErrorInfo Class : Details Property

Glossary Item Box

Gets or sets detailed information about the error.

Syntax

Visual Basic (Declaration)
Public Property Details As String
C#
public string Details {get; set;}

Property Value

Extended details about the error as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorInfo Class
ErrorInfo Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ErrorInfo Class : Message Property

Glossary Item Box

Gets or sets the main message describing the error.

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message {get; set;}

Property Value

A brief description of the error as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorInfo Class
ErrorInfo Members


Severity Property

[image]
ActiveReports 19 .NET Edition
Severity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ErrorInfo Class : Severity Property

Glossary Item Box

Gets or sets the severity level of the error.

Syntax

Visual Basic (Declaration)
Public Property Severity As ErrorSeverity
C#
public ErrorSeverity Severity {get; set;}

Property Value

The severity of the error, represented as an enum of type ErrorSeverity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorInfo Class
ErrorInfo Members


ExportSetting Class

[image]
ActiveReports 19 .NET Edition
ExportSetting Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ExportSetting Class

Glossary Item Box

Represents a single setting used in the configuration of report export operations.

Object Model

ExportSetting Class

Syntax

Visual Basic (Declaration)
Public Class ExportSetting
C#
public class ExportSetting

Remarks

The ExportSetting class defines a setting that can be used to configure various aspects of report export operations, including its value and visibility.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ExportSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportSetting Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ExportSetting Class Members

[image]
ActiveReports 19 .NET Edition
ExportSetting Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ExportSetting Class

Glossary Item Box

The following tables list the members exposed by ExportSetting.

Public Constructors

 | Name | Description
Public Constructor | ExportSetting Constructor |
Top

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the value of the export setting.
Public Property | Visible | Gets or sets a value indicating whether the export setting is visible.
Top

See Also

Reference

ExportSetting Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ExportSetting Constructor

[image]
ActiveReports 19 .NET Edition
ExportSetting Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ExportSetting Class : ExportSetting Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExportSetting()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportSetting Class
ExportSetting Members


ExportSetting Class Properties

[image]
ActiveReports 19 .NET Edition
ExportSetting Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ExportSetting Class

Glossary Item Box

For a list of all members of this type, see ExportSetting members.

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the value of the export setting.
Public Property | Visible | Gets or sets a value indicating whether the export setting is visible.
Top

See Also

Reference

ExportSetting Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ExportSetting Class : Value Property

Glossary Item Box

Gets or sets the value of the export setting.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

The value of the setting as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportSetting Class
ExportSetting Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ExportSetting Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the export setting is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the setting should be visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportSetting Class
ExportSetting Members


InitializationOptions Class

[image]
ActiveReports 19 .NET Edition
InitializationOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitializationOptions Class

Glossary Item Box

Represents an options can be set during initialization.

Object Model

InitializationOptions Class

Syntax

Visual Basic (Declaration)
Public Class InitializationOptions
C#
public class InitializationOptions

Remarks

The InitializationOptions class provides various properties to configure the initial settings for the viewer, including report ID, parameters, zoom settings, and localization.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.InitializationOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


InitializationOptions Class Members

[image]
ActiveReports 19 .NET Edition
InitializationOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitializationOptions Class

Glossary Item Box

The following tables list the members exposed by InitializationOptions.

Public Constructors

 | Name | Description
Public Constructor | InitializationOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.
Public Property | AutoBackgroundColor | Gets or sets a value indicating whether the view area background color is filled with the report body color.
Public Property | AvailableExports | Gets or sets custom default settings for exports, formatted by export type and setting name.
Public Property | DefaultExportSettings | Gets or sets custom default settings for exports, formatted by export type and setting name.
Public Property | DisplayMode | Gets or sets the initial display mode of the Viewer.
Public Property | DocumentLoaded | Gets or sets the callback invoked when a document is fully loaded on the server.
Public Property | Error | Gets or sets the callback invoked when an error occurs during the process of displaying the report.
Public Property | HideErrors | Gets or sets whether to show errors in the Viewer.
Public Property | InitialZoomMode | Gets or sets the initial zoom mode settings, providing control over how content is scaled on initial display.
Public Property | Locale | Gets or sets the locale used for displaying UI elements in the Viewer.
Public Property | LocaleData | Gets or sets the JSON string containing localization strings for the Viewer.
Public Property | LocaleUri | Gets or sets the URL of the file containing localization strings.
Public Property | PanelsLocation | Gets or sets the position of various panels (search, parameters, etc.) within the Viewer. Default is 'toolbar'.
Public Property | ParametersPanel | Gets or sets the settings for the parameters panel, allowing customization of its behavior and appearance.
Public Property | RenderFormat | Gets or sets the report render mode.
Public Property | RenderMode | Gets or sets the initial rendering mode of the Viewer.
Public Property | ReportID | Gets or sets the identifier of the report to be displayed by the Viewer.
Public Property | ReportLoaded | Gets or sets the callback invoked when the Viewer has fully loaded the report's information.
Public Property | ReportParameters | Gets or sets the array of name-value pairs that describe the parameter values used to run the report.
Public Property | ReportService | Gets or sets the settings for connecting to the Web API used by the Viewer.
Public Property | Themes | Gets or sets the UI theme for the Viewer.
Top

See Also

Reference

InitializationOptions Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


InitializationOptions Constructor

[image]
ActiveReports 19 .NET Edition
InitializationOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : InitializationOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InitializationOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


InitializationOptions Class Properties

[image]
ActiveReports 19 .NET Edition
InitializationOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitializationOptions Class

Glossary Item Box

For a list of all members of this type, see InitializationOptions members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.
Public Property | AutoBackgroundColor | Gets or sets a value indicating whether the view area background color is filled with the report body color.
Public Property | AvailableExports | Gets or sets custom default settings for exports, formatted by export type and setting name.
Public Property | DefaultExportSettings | Gets or sets custom default settings for exports, formatted by export type and setting name.
Public Property | DisplayMode | Gets or sets the initial display mode of the Viewer.
Public Property | DocumentLoaded | Gets or sets the callback invoked when a document is fully loaded on the server.
Public Property | Error | Gets or sets the callback invoked when an error occurs during the process of displaying the report.
Public Property | HideErrors | Gets or sets whether to show errors in the Viewer.
Public Property | InitialZoomMode | Gets or sets the initial zoom mode settings, providing control over how content is scaled on initial display.
Public Property | Locale | Gets or sets the locale used for displaying UI elements in the Viewer.
Public Property | LocaleData | Gets or sets the JSON string containing localization strings for the Viewer.
Public Property | LocaleUri | Gets or sets the URL of the file containing localization strings.
Public Property | PanelsLocation | Gets or sets the position of various panels (search, parameters, etc.) within the Viewer. Default is 'toolbar'.
Public Property | ParametersPanel | Gets or sets the settings for the parameters panel, allowing customization of its behavior and appearance.
Public Property | RenderFormat | Gets or sets the report render mode.
Public Property | RenderMode | Gets or sets the initial rendering mode of the Viewer.
Public Property | ReportID | Gets or sets the identifier of the report to be displayed by the Viewer.
Public Property | ReportLoaded | Gets or sets the callback invoked when the Viewer has fully loaded the report's information.
Public Property | ReportParameters | Gets or sets the array of name-value pairs that describe the parameter values used to run the report.
Public Property | ReportService | Gets or sets the settings for connecting to the Web API used by the Viewer.
Public Property | Themes | Gets or sets the UI theme for the Viewer.
Top

See Also

Reference

InitializationOptions Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : Action Property

Glossary Item Box

Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.

Syntax

Visual Basic (Declaration)
Public Property Action As Action(Of String,Object())
C#
public Action<string,object[]> Action {get; set;}

Property Value

An action that takes a System.String and an array of System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


AutoBackgroundColor Property

[image]
ActiveReports 19 .NET Edition
AutoBackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : AutoBackgroundColor Property

Glossary Item Box

Gets or sets a value indicating whether the view area background color is filled with the report body color.

Syntax

Visual Basic (Declaration)
Public Property AutoBackgroundColor As Boolean
C#
public bool AutoBackgroundColor {get; set;}

Property Value

true if the view area background color is filled with the report body color; otherwise, false.

Remarks

Available only for Dashboard reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


AvailableExports Property

[image]
ActiveReports 19 .NET Edition
AvailableExports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : AvailableExports Property

Glossary Item Box

Gets or sets custom default settings for exports, formatted by export type and setting name.

Syntax

Visual Basic (Declaration)
Public Property AvailableExports As ExportTypes()
C#
public ExportTypes[] AvailableExports {get; set;}

Property Value

An array of ExportTypes that define the available export options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


DefaultExportSettings Property

[image]
ActiveReports 19 .NET Edition
DefaultExportSettings Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : DefaultExportSettings Property

Glossary Item Box

Gets or sets custom default settings for exports, formatted by export type and setting name.

Syntax

Visual Basic (Declaration)
Public Property DefaultExportSettings As Dictionary(Of String,Dictionary(Of String,ExportSetting))
C#
public Dictionary<string,Dictionary<string,ExportSetting>> DefaultExportSettings {get; set;}

Property Value

A dictionary where keys are export types and values are dictionaries of export settings.

Remarks

Format keys are mht, pdf, tiff, xls, xlsx, csv, doc, docx, json, xml, xlsxData, csvData, rtf and txt. Settings keys are the export settings which are available for RenderingExtensions.

Example

Format keys are mht, pdf, tiff, xls, xlsx, csv, doc, docx, json, xml, xlsxData, csvData, rtf and txt. Settings keys are the export settings which are available for RenderingExtensions.
C# Copy Code
new Dictionary<string, Dictionary<string, ExportSetting>>()
{
   {
       "xls",
       new Dictionary<string, ExportSetting>()
       {
           {
               "FileName", new ExportSetting()
               {
                   Value = "test",
                   Visible = false
               }
           }
       }
   }
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


DisplayMode Property

[image]
ActiveReports 19 .NET Edition
DisplayMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : DisplayMode Property

Glossary Item Box

Gets or sets the initial display mode of the Viewer.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As ViewMode
C#
public ViewMode DisplayMode {get; set;}

Property Value

An instance of ViewMode that defines the initial display mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


DocumentLoaded Property

[image]
ActiveReports 19 .NET Edition
DocumentLoaded Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : DocumentLoaded Property

Glossary Item Box

Gets or sets the callback invoked when a document is fully loaded on the server.

Syntax

Visual Basic (Declaration)
Public Property DocumentLoaded As Action
C#
public Action DocumentLoaded {get; set;}

Property Value

An action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


Error Property

[image]
ActiveReports 19 .NET Edition
Error Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : Error Property

Glossary Item Box

Gets or sets the callback invoked when an error occurs during the process of displaying the report.

Syntax

Visual Basic (Declaration)
Public Property Error As Action(Of ErrorInfo)
C#
public Action<ErrorInfo> Error {get; set;}

Property Value

An action that takes an ErrorInfo object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


HideErrors Property

[image]
ActiveReports 19 .NET Edition
HideErrors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : HideErrors Property

Glossary Item Box

Gets or sets whether to show errors in the Viewer.

Syntax

Visual Basic (Declaration)
Public Property HideErrors As Boolean
C#
public bool HideErrors {get; set;}

Property Value

true if errors should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


InitialZoomMode Property

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : InitialZoomMode Property

Glossary Item Box

Gets or sets the initial zoom mode settings, providing control over how content is scaled on initial display.

Syntax

Visual Basic (Declaration)
Public Property InitialZoomMode As InitialZoomMode
C#
public InitialZoomMode InitialZoomMode {get; set;}

Property Value

An instance of InitialZoomMode that defines the zoom settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


Locale Property

[image]
ActiveReports 19 .NET Edition
Locale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : Locale Property

Glossary Item Box

Gets or sets the locale used for displaying UI elements in the Viewer.

Syntax

Visual Basic (Declaration)
Public Property Locale As String
C#
public string Locale {get; set;}

Property Value

The locale as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


LocaleData Property

[image]
ActiveReports 19 .NET Edition
LocaleData Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : LocaleData Property

Glossary Item Box

Gets or sets the JSON string containing localization strings for the Viewer.

Syntax

Visual Basic (Declaration)
Public Property LocaleData As String
C#
public string LocaleData {get; set;}

Property Value

A JSON string representing the localization data.

Example

C# Copy Code
//See file from assets "ar-blazor-viewer-locale.json" for more information.
@"{
     ""export"": {
         ""boolTextFalse"": ""Yes"",
         ""boolTextTrue"": ""No""
     },
     ""viewer"": {
         ""toolbar"": {
             ""refresh"": ""Update""
         }
     }
}";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


LocaleUri Property

[image]
ActiveReports 19 .NET Edition
LocaleUri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : LocaleUri Property

Glossary Item Box

Gets or sets the URL of the file containing localization strings.

Syntax

Visual Basic (Declaration)
Public Property LocaleUri As String
C#
public string LocaleUri {get; set;}

Property Value

The URL as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


PanelsLocation Property

[image]
ActiveReports 19 .NET Edition
PanelsLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : PanelsLocation Property

Glossary Item Box

Gets or sets the position of various panels (search, parameters, etc.) within the Viewer. Default is 'toolbar'.

Syntax

Visual Basic (Declaration)
Public Property PanelsLocation As PanelsLocation
C#
public PanelsLocation PanelsLocation {get; set;}

Property Value

An instance of PanelsLocation that defines the panel positions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


ParametersPanel Property

[image]
ActiveReports 19 .NET Edition
ParametersPanel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : ParametersPanel Property

Glossary Item Box

Gets or sets the settings for the parameters panel, allowing customization of its behavior and appearance.

Syntax

Visual Basic (Declaration)
Public Property ParametersPanel As ParametersPanelSettings
C#
public ParametersPanelSettings ParametersPanel {get; set;}

Property Value

An instance of ParametersPanelSettings that defines the panel settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


RenderFormat Property

[image]
ActiveReports 19 .NET Edition
RenderFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : RenderFormat Property

Glossary Item Box

Gets or sets the report render mode.

Syntax

Visual Basic (Declaration)
Public Property RenderFormat As RenderFormat
C#
public RenderFormat RenderFormat {get; set;}

Property Value

An instance of RenderFormat that defines the render mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


RenderMode Property

[image]
ActiveReports 19 .NET Edition
RenderMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : RenderMode Property

Glossary Item Box

Gets or sets the initial rendering mode of the Viewer.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As RenderMode
C#
public RenderMode RenderMode {get; set;}

Property Value

An instance of RenderMode that defines the rendering mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


ReportID Property

[image]
ActiveReports 19 .NET Edition
ReportID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : ReportID Property

Glossary Item Box

Gets or sets the identifier of the report to be displayed by the Viewer.

Syntax

Visual Basic (Declaration)
Public Property ReportID As String
C#
public string ReportID {get; set;}

Property Value

The report ID as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


ReportLoaded Property

[image]
ActiveReports 19 .NET Edition
ReportLoaded Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : ReportLoaded Property

Glossary Item Box

Gets or sets the callback invoked when the Viewer has fully loaded the report's information.

Syntax

Visual Basic (Declaration)
Public Property ReportLoaded As Action(Of ReportInfo)
C#
public Action<ReportInfo> ReportLoaded {get; set;}

Property Value

An action that takes a ReportInfo object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


ReportParameters Property

[image]
ActiveReports 19 .NET Edition
ReportParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : ReportParameters Property

Glossary Item Box

Gets or sets the array of name-value pairs that describe the parameter values used to run the report.

Syntax

Visual Basic (Declaration)
Public Property ReportParameters As Parameter()
C#
public Parameter[] ReportParameters {get; set;}

Property Value

An array of Parameter objects representing the parameter values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


ReportService Property

[image]
ActiveReports 19 .NET Edition
ReportService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : ReportService Property

Glossary Item Box

Gets or sets the settings for connecting to the Web API used by the Viewer.

Syntax

Visual Basic (Declaration)
Public Property ReportService As ReportServiceSettings
C#
public ReportServiceSettings ReportService {get; set;}

Property Value

An instance of ReportServiceSettings that defines the API connection settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitializationOptions Class : Themes Property

Glossary Item Box

Gets or sets the UI theme for the Viewer.

Syntax

Visual Basic (Declaration)
Public Property Themes As ThemeSettings
C#
public ThemeSettings Themes {get; set;}

Property Value

An instance of ThemeSettings that defines the theme settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializationOptions Class
InitializationOptions Members


InitialZoomMode Class

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitialZoomMode Class

Glossary Item Box

Represents the settings for the initial zoom level.

Object Model

InitialZoomMode Class

Syntax

Visual Basic (Declaration)
Public Class InitialZoomMode
C#
public class InitialZoomMode

Remarks

The InitialZoomMode class provides properties to define how the initial zoom level should be applied in the viewer, including the zoom mode and a specific zoom percentage.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.InitialZoomMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitialZoomMode Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


InitialZoomMode Class Members

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitialZoomMode Class

Glossary Item Box

The following tables list the members exposed by InitialZoomMode.

Public Constructors

 | Name | Description
Public Constructor | InitialZoomMode Constructor |
Top

Public Properties

 | Name | Description
Public Property | Mode | Gets or sets the zoom mode, which defines how zoom should be applied.
Public Property | Percentage | Gets or sets the zoom value in percentage, specifying the exact zoom level to be applied.
Top

See Also

Reference

InitialZoomMode Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


InitialZoomMode Constructor

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitialZoomMode Class : InitialZoomMode Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InitialZoomMode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitialZoomMode Class
InitialZoomMode Members


InitialZoomMode Class Properties

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : InitialZoomMode Class

Glossary Item Box

For a list of all members of this type, see InitialZoomMode members.

Public Properties

 | Name | Description
Public Property | Mode | Gets or sets the zoom mode, which defines how zoom should be applied.
Public Property | Percentage | Gets or sets the zoom value in percentage, specifying the exact zoom level to be applied.
Top

See Also

Reference

InitialZoomMode Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Mode Property

[image]
ActiveReports 19 .NET Edition
Mode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitialZoomMode Class : Mode Property

Glossary Item Box

Gets or sets the zoom mode, which defines how zoom should be applied.

Syntax

Visual Basic (Declaration)
Public Property Mode As Nullable(Of ZoomMode)
C#
public Nullable<ZoomMode> Mode {get; set;}

Property Value

A nullable ZoomMode value that specifies the mode of zoom, such as full page, page width, or a custom setting. Null if no mode is specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitialZoomMode Class
InitialZoomMode Members


Percentage Property

[image]
ActiveReports 19 .NET Edition
Percentage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > InitialZoomMode Class : Percentage Property

Glossary Item Box

Gets or sets the zoom value in percentage, specifying the exact zoom level to be applied.

Syntax

Visual Basic (Declaration)
Public Property Percentage As Nullable(Of Integer)
C#
public Nullable<int> Percentage {get; set;}

Property Value

The zoom level as an integer percentage. This value is optional and nullable, used only when a specific zoom level is required, independent of the mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitialZoomMode Class
InitialZoomMode Members


OnRequestInfo Class

[image]
ActiveReports 19 .NET Edition
OnRequestInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : OnRequestInfo Class

Glossary Item Box

Represents the information that can be used to modify or provide additional details for a web request, such as credentials and headers.

Object Model

OnRequestInfo Class

Syntax

Visual Basic (Declaration)
Public Class OnRequestInfo
C#
public class OnRequestInfo

Remarks

The OnRequestInfo class allows you to specify authentication credentials and HTTP headers that should be included in a web request.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.OnRequestInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnRequestInfo Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


OnRequestInfo Class Members

[image]
ActiveReports 19 .NET Edition
OnRequestInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : OnRequestInfo Class

Glossary Item Box

The following tables list the members exposed by OnRequestInfo.

Public Constructors

 | Name | Description
Public Constructor | OnRequestInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Credentials | Gets or sets the credentials used for authentication in the request.
Public Property | Headers | Gets or sets a dictionary containing headers that should be included with the request.
Top

See Also

Reference

OnRequestInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


OnRequestInfo Constructor

[image]
ActiveReports 19 .NET Edition
OnRequestInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > OnRequestInfo Class : OnRequestInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OnRequestInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnRequestInfo Class
OnRequestInfo Members


OnRequestInfo Class Properties

[image]
ActiveReports 19 .NET Edition
OnRequestInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : OnRequestInfo Class

Glossary Item Box

For a list of all members of this type, see OnRequestInfo members.

Public Properties

 | Name | Description
Public Property | Credentials | Gets or sets the credentials used for authentication in the request.
Public Property | Headers | Gets or sets a dictionary containing headers that should be included with the request.
Top

See Also

Reference

OnRequestInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Credentials Property

[image]
ActiveReports 19 .NET Edition
Credentials Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > OnRequestInfo Class : Credentials Property

Glossary Item Box

Gets or sets the credentials used for authentication in the request.

Syntax

Visual Basic (Declaration)
Public Property Credentials As String
C#
public string Credentials {get; set;}

Property Value

The credentials as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnRequestInfo Class
OnRequestInfo Members


Headers Property

[image]
ActiveReports 19 .NET Edition
Headers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > OnRequestInfo Class : Headers Property

Glossary Item Box

Gets or sets a dictionary containing headers that should be included with the request.

Syntax

Visual Basic (Declaration)
Public Property Headers As Dictionary(Of String,String)
C#
public Dictionary<string,string> Headers {get; set;}

Property Value

A Dictionary representing HTTP headers. Each key-value pair represents a header field and its value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnRequestInfo Class
OnRequestInfo Members


Parameter Class

[image]
ActiveReports 19 .NET Edition
Parameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Parameter Class

Glossary Item Box

Represents a parameter used to run the report.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public Class Parameter
C#
public class Parameter

Remarks

The Parameter class encapsulates the properties needed to define a report parameter, including its name and values.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Parameter Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Values | Gets or sets the values for the parameter.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Parameter Constructor

[image]
ActiveReports 19 .NET Edition
Parameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Parameter Class : Parameter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Parameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

[image]
ActiveReports 19 .NET Edition
Parameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Values | Gets or sets the values for the parameter.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Parameter Class : Name Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the parameter as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Parameter Class : Values Property

Glossary Item Box

Gets or sets the values for the parameter.

Syntax

Visual Basic (Declaration)
Public Property Values As String()
C#
public string[] Values {get; set;}

Property Value

An array of System.String that represent the values assigned to the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ParameterDescriptor Class

[image]
ActiveReports 19 .NET Edition
ParameterDescriptor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterDescriptor Class

Glossary Item Box

Represents the descriptor of a report parameter.

Object Model

ParameterDescriptor Class

Syntax

Visual Basic (Declaration)
Public Class ParameterDescriptor
C#
public class ParameterDescriptor

Remarks

The ParameterDescriptor class provides detailed information about a report parameter, including its name, prompt, data type, and various settings related to its behavior and usage.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ParameterDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterDescriptor Class Members

[image]
ActiveReports 19 .NET Edition
ParameterDescriptor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterDescriptor Class

Glossary Item Box

The following tables list the members exposed by ParameterDescriptor.

Public Constructors

 | Name | Description
Public Constructor | ParameterDescriptor Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the parameter allows blank values.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DateOnly | Gets or sets a value indicating whether the parameter should only accept date values.
Public Property | DefaultValue | Gets or sets the default value for the parameter.
Public Property | DependsOn | Gets or sets the parameters this parameter depends on.
Public Property | Hidden | Gets or sets a value indicating whether the parameter is hidden.
Public Property | Multiline | Gets or sets a value indicating whether the parameter supports multiline input.
Public Property | MultiValue | Gets or sets a value indicating whether the parameter supports multiple values.
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Nullable | Gets or sets a value indicating whether the parameter can accept null values.
Public Property | Prompt | Gets or sets the prompt message that appears for the parameter.
Public Property | SelectAllValue | Gets or sets the value used to represent the selection of all possible items in a multi-value parameter.
Public Property | UsedInQuery | Gets or sets a value that indicates whether the parameter is used directly in a query.
Public Property | ValidValues | Gets or sets the valid values for the parameter.
Top

See Also

Reference

ParameterDescriptor Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
ParameterDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : ParameterDescriptor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterDescriptor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


ParameterDescriptor Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterDescriptor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterDescriptor Class

Glossary Item Box

For a list of all members of this type, see ParameterDescriptor members.

Public Properties

 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the parameter allows blank values.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DateOnly | Gets or sets a value indicating whether the parameter should only accept date values.
Public Property | DefaultValue | Gets or sets the default value for the parameter.
Public Property | DependsOn | Gets or sets the parameters this parameter depends on.
Public Property | Hidden | Gets or sets a value indicating whether the parameter is hidden.
Public Property | Multiline | Gets or sets a value indicating whether the parameter supports multiline input.
Public Property | MultiValue | Gets or sets a value indicating whether the parameter supports multiple values.
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Nullable | Gets or sets a value indicating whether the parameter can accept null values.
Public Property | Prompt | Gets or sets the prompt message that appears for the parameter.
Public Property | SelectAllValue | Gets or sets the value used to represent the selection of all possible items in a multi-value parameter.
Public Property | UsedInQuery | Gets or sets a value that indicates whether the parameter is used directly in a query.
Public Property | ValidValues | Gets or sets the valid values for the parameter.
Top

See Also

Reference

ParameterDescriptor Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


AllowBlank Property

[image]
ActiveReports 19 .NET Edition
AllowBlank Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : AllowBlank Property

Glossary Item Box

Gets or sets a value indicating whether the parameter allows blank values.

Syntax

Visual Basic (Declaration)
Public Property AllowBlank As Boolean
C#
public bool AllowBlank {get; set;}

Property Value

true if blank values are allowed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


DataType Property

[image]
ActiveReports 19 .NET Edition
DataType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : DataType Property

Glossary Item Box

Gets or sets the data type of the parameter.

Syntax

Visual Basic (Declaration)
Public Property DataType As Object
C#
public object DataType {get; set;}

Property Value

An System.Object that specifies the type of data the parameter accepts, such as string, number, date, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


DateOnly Property

[image]
ActiveReports 19 .NET Edition
DateOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : DateOnly Property

Glossary Item Box

Gets or sets a value indicating whether the parameter should only accept date values.

Syntax

Visual Basic (Declaration)
Public Property DateOnly As Boolean
C#
public bool DateOnly {get; set;}

Property Value

true if the parameter should only include dates; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : DefaultValue Property

Glossary Item Box

Gets or sets the default value for the parameter.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As ParameterValue
C#
public ParameterValue DefaultValue {get; set;}

Property Value

A ParameterValue that specifies the default value for the parameter when the report is run.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


DependsOn Property

[image]
ActiveReports 19 .NET Edition
DependsOn Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : DependsOn Property

Glossary Item Box

Gets or sets the parameters this parameter depends on.

Syntax

Visual Basic (Declaration)
Public Property DependsOn As String()
C#
public string[] DependsOn {get; set;}

Property Value

An array of System.String names representing other parameters that this parameter's value depends upon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : Hidden Property

Glossary Item Box

Gets or sets a value indicating whether the parameter is hidden.

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden {get; set;}

Property Value

true if the parameter should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


Multiline Property

[image]
ActiveReports 19 .NET Edition
Multiline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : Multiline Property

Glossary Item Box

Gets or sets a value indicating whether the parameter supports multiline input.

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
C#
public bool Multiline {get; set;}

Property Value

true if the parameter supports multiline text input; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


MultiValue Property

[image]
ActiveReports 19 .NET Edition
MultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : MultiValue Property

Glossary Item Box

Gets or sets a value indicating whether the parameter supports multiple values.

Syntax

Visual Basic (Declaration)
Public Property MultiValue As Boolean
C#
public bool MultiValue {get; set;}

Property Value

true if the parameter can take multiple values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : Name Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name as a System.String that identifies the parameter uniquely within a report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


Nullable Property

[image]
ActiveReports 19 .NET Edition
Nullable Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : Nullable Property

Glossary Item Box

Gets or sets a value indicating whether the parameter can accept null values.

Syntax

Visual Basic (Declaration)
Public Property Nullable As Boolean
C#
public bool Nullable {get; set;}

Property Value

true if null values are permissible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : Prompt Property

Glossary Item Box

Gets or sets the prompt message that appears for the parameter.

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt {get; set;}

Property Value

A System.String that is displayed as a prompt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


SelectAllValue Property

[image]
ActiveReports 19 .NET Edition
SelectAllValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : SelectAllValue Property

Glossary Item Box

Gets or sets the value used to represent the selection of all possible items in a multi-value parameter.

Syntax

Visual Basic (Declaration)
Public Property SelectAllValue As Object
C#
public object SelectAllValue {get; set;}

Property Value

An System.Object that represents the "Select All" option in multi-value parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


UsedInQuery Property

[image]
ActiveReports 19 .NET Edition
UsedInQuery Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : UsedInQuery Property

Glossary Item Box

Gets or sets a value that indicates whether the parameter is used directly in a query.

Syntax

Visual Basic (Declaration)
Public Property UsedInQuery As Boolean
C#
public bool UsedInQuery {get; set;}

Property Value

The optional optimization about usage of the parameter in queries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


ValidValues Property

[image]
ActiveReports 19 .NET Edition
ValidValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterDescriptor Class : ValidValues Property

Glossary Item Box

Gets or sets the valid values for the parameter.

Syntax

Visual Basic (Declaration)
Public Property ValidValues As ParameterValue
C#
public ParameterValue ValidValues {get; set;}

Property Value

A ParameterValue that contains all allowable values that this parameter can accept.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Members


ParametersPanelSettings Class

[image]
ActiveReports 19 .NET Edition
ParametersPanelSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParametersPanelSettings Class

Glossary Item Box

Represents the settings for a parameters panel.

Object Model

ParametersPanelSettings Class

Syntax

Visual Basic (Declaration)
Public Class ParametersPanelSettings
C#
public class ParametersPanelSettings

Remarks

The ParametersPanelSettings class provides properties to configure the location and opening behavior of a parameters panel within the viewer.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ParametersPanelSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanelSettings Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParametersPanelSettings Class Members

[image]
ActiveReports 19 .NET Edition
ParametersPanelSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParametersPanelSettings Class

Glossary Item Box

The following tables list the members exposed by ParametersPanelSettings.

Public Constructors

 | Name | Description
Public Constructor | ParametersPanelSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Location | Gets or sets the position of the parameters panel.
Public Property | Open | Gets or sets the opening behavior of the parameters panel.
Top

See Also

Reference

ParametersPanelSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParametersPanelSettings Constructor

[image]
ActiveReports 19 .NET Edition
ParametersPanelSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParametersPanelSettings Class : ParametersPanelSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParametersPanelSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanelSettings Class
ParametersPanelSettings Members


ParametersPanelSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ParametersPanelSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParametersPanelSettings Class

Glossary Item Box

For a list of all members of this type, see ParametersPanelSettings members.

Public Properties

 | Name | Description
Public Property | Location | Gets or sets the position of the parameters panel.
Public Property | Open | Gets or sets the opening behavior of the parameters panel.
Top

See Also

Reference

ParametersPanelSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParametersPanelSettings Class : Location Property

Glossary Item Box

Gets or sets the position of the parameters panel.

Syntax

Visual Basic (Declaration)
Public Property Location As ParameterPanelLocation
C#
public ParameterPanelLocation Location {get; set;}

Property Value

The location setting, represented by an instance of ParameterPanelLocation, which determines where the panel is placed (e.g., left, right, top, bottom).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanelSettings Class
ParametersPanelSettings Members


Open Property

[image]
ActiveReports 19 .NET Edition
Open Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParametersPanelSettings Class : Open Property

Glossary Item Box

Gets or sets the opening behavior of the parameters panel.

Syntax

Visual Basic (Declaration)
Public Property Open As ParameterPanelOpen
C#
public ParameterPanelOpen Open {get; set;}

Property Value

The opening behavior, defined by an instance of ParameterPanelOpen, which controls how the panel is accessed (e.g., auto-open, manual).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanelSettings Class
ParametersPanelSettings Members


ParameterValue Class

[image]
ActiveReports 19 .NET Edition
ParameterValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterValue Class

Glossary Item Box

Represents a specific value for a report parameter.

Object Model

ParameterValue Class

Syntax

Visual Basic (Declaration)
Public Class ParameterValue
C#
public class ParameterValue

Remarks

The ParameterValue class defines a value that can be assigned to a report parameter, including a label and the actual value.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ParameterValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterValue Class Members

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterValue Class

Glossary Item Box

The following tables list the members exposed by ParameterValue.

Public Constructors

 | Name | Description
Public Constructor | ParameterValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label associated with the parameter value.
Public Property | Value | Gets or sets the actual value of the parameter.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterValue Constructor

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterValue Class : ParameterValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterValue Class

Glossary Item Box

For a list of all members of this type, see ParameterValue members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label associated with the parameter value.
Public Property | Value | Gets or sets the actual value of the parameter.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterValue Class : Label Property

Glossary Item Box

Gets or sets the label associated with the parameter value.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Property Value

A System.String representing the label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ParameterValue Class : Value Property

Glossary Item Box

Gets or sets the actual value of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

An System.Object that can be any type required by the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


Range Class

[image]
ActiveReports 19 .NET Edition
Range Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Range Class

Glossary Item Box

Represents a specific range of text, defined by a starting position and the number of characters it encompasses.

Object Model

Range Class

Syntax

Visual Basic (Declaration)
Public Class Range
C#
public class Range

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Range

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Range Class Members

[image]
ActiveReports 19 .NET Edition
Range Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Range Class

Glossary Item Box

The following tables list the members exposed by Range.

Public Constructors

 | Name | Description
Public Constructor | Range Constructor |
Top

Public Properties

 | Name | Description
Public Property | Length | Gets or sets the number of characters within the range.
Public Property | Start | Gets or sets the starting position of the range in the text.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Range Constructor

[image]
ActiveReports 19 .NET Edition
Range Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Range Class : Range Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Range()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Range Class Properties

[image]
ActiveReports 19 .NET Edition
Range Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Range Class

Glossary Item Box

For a list of all members of this type, see Range members.

Public Properties

 | Name | Description
Public Property | Length | Gets or sets the number of characters within the range.
Public Property | Start | Gets or sets the starting position of the range in the text.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Length Property

[image]
ActiveReports 19 .NET Edition
Length Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Range Class : Length Property

Glossary Item Box

Gets or sets the number of characters within the range.

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length {get; set;}

Property Value

The number of characters as an integer. It indicates how many characters are included in the range starting from the Start position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Start Property

[image]
ActiveReports 19 .NET Edition
Start Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Range Class : Start Property

Glossary Item Box

Gets or sets the starting position of the range in the text.

Syntax

Visual Basic (Declaration)
Public Property Start As Integer
C#
public int Start {get; set;}

Property Value

The zero-based index indicating the starting position of the range in the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


ReportInfo Class

[image]
ActiveReports 19 .NET Edition
ReportInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportInfo Class

Glossary Item Box

Represents detailed information about a report.

Object Model

ReportInfo Class

Syntax

Visual Basic (Declaration)
Public Class ReportInfo
C#
public class ReportInfo

Remarks

The ReportInfo class contains properties that provide comprehensive details about a report, including its name, parameters, layout, and export options.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportInfo Class Members

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportInfo Class

Glossary Item Box

The following tables list the members exposed by ReportInfo.

Public Constructors

 | Name | Description
Public Constructor | ReportInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | DisplayType | Gets or sets the display mode of the report, which defines how the report is rendered on screen.
Public Property | Exports | Gets or sets the export types available for the report.
Public Property | GalleyModeAllowed | Gets or sets a value indicating whether the report supports Galley Mode, a specific layout or viewing mode.
Public Property | Name | Gets or sets the name of the report.
Public Property | Parameters | Gets or sets the descriptors for all parameters required or available for the report.
Public Property | ParametersView | Gets or sets the custom layout for the parameters panel.
Public Property | SizeType | Gets or sets the size type of the report, which influences how the report handles overflow and scaling.
Public Property | Type | Gets or sets the type of the report.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportInfo Constructor

[image]
ActiveReports 19 .NET Edition
ReportInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : ReportInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ReportInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Properties

 | Name | Description
Public Property | DisplayType | Gets or sets the display mode of the report, which defines how the report is rendered on screen.
Public Property | Exports | Gets or sets the export types available for the report.
Public Property | GalleyModeAllowed | Gets or sets a value indicating whether the report supports Galley Mode, a specific layout or viewing mode.
Public Property | Name | Gets or sets the name of the report.
Public Property | Parameters | Gets or sets the descriptors for all parameters required or available for the report.
Public Property | ParametersView | Gets or sets the custom layout for the parameters panel.
Public Property | SizeType | Gets or sets the size type of the report, which influences how the report handles overflow and scaling.
Public Property | Type | Gets or sets the type of the report.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


DisplayType Property

[image]
ActiveReports 19 .NET Edition
DisplayType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : DisplayType Property

Glossary Item Box

Gets or sets the display mode of the report, which defines how the report is rendered on screen.

Syntax

Visual Basic (Declaration)
Public Property DisplayType As Nullable(Of ViewMode)
C#
public Nullable<ViewMode> DisplayType {get; set;}

Property Value

A nullable ViewMode value that indicates the preferred viewing mode for the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Exports Property

[image]
ActiveReports 19 .NET Edition
Exports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : Exports Property

Glossary Item Box

Gets or sets the export types available for the report.

Syntax

Visual Basic (Declaration)
Public Property Exports As ExportTypes()
C#
public ExportTypes[] Exports {get; set;}

Property Value

An array of ExportTypes that specifies the formats in which the report can be exported.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


GalleyModeAllowed Property

[image]
ActiveReports 19 .NET Edition
GalleyModeAllowed Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : GalleyModeAllowed Property

Glossary Item Box

Gets or sets a value indicating whether the report supports Galley Mode, a specific layout or viewing mode.

Syntax

Visual Basic (Declaration)
Public Property GalleyModeAllowed As Boolean
C#
public bool GalleyModeAllowed {get; set;}

Property Value

true if Galley Mode is allowed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : Name Property

Glossary Item Box

Gets or sets the name of the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name as a System.String that uniquely identifies the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : Parameters Property

Glossary Item Box

Gets or sets the descriptors for all parameters required or available for the report.

Syntax

Visual Basic (Declaration)
Public Property Parameters As ParameterDescriptor()
C#
public ParameterDescriptor[] Parameters {get; set;}

Property Value

An array of ParameterDescriptor objects that describe the parameters this report can accept.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ParametersView Property

[image]
ActiveReports 19 .NET Edition
ParametersView Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : ParametersView Property

Glossary Item Box

Gets or sets the custom layout for the parameters panel.

Syntax

Visual Basic (Declaration)
Public Property ParametersView As String
C#
public string ParametersView {get; set;}

Property Value

A System.String that defines the visual layout of the parameters panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


SizeType Property

[image]
ActiveReports 19 .NET Edition
SizeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : SizeType Property

Glossary Item Box

Gets or sets the size type of the report, which influences how the report handles overflow and scaling.

Syntax

Visual Basic (Declaration)
Public Property SizeType As Nullable(Of SizeType)
C#
public Nullable<SizeType> SizeType {get; set;}

Property Value

A nullable SizeType value that specifies how the report's size should be managed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportInfo Class : Type Property

Glossary Item Box

Gets or sets the type of the report.

Syntax

Visual Basic (Declaration)
Public Property Type As ReportType
C#
public ReportType Type {get; set;}

Property Value

A ReportType value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportServiceSettings Class

[image]
ActiveReports 19 .NET Edition
ReportServiceSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportServiceSettings Class

Glossary Item Box

Represents the settings necessary for establishing a connection to a Web API.

Object Model

ReportServiceSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportServiceSettings
C#
public class ReportServiceSettings

Remarks

The ReportServiceSettings class contains the configuration required to connect to a Web API, including the base URL, security token, and a callback function for request customization.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ReportServiceSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportServiceSettings Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportServiceSettings Class Members

[image]
ActiveReports 19 .NET Edition
ReportServiceSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportServiceSettings Class

Glossary Item Box

The following tables list the members exposed by ReportServiceSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportServiceSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnRequest | Gets or sets a callback function that is invoked before any request is made to the Web API.
Public Property | SecurityToken | Gets or sets the security token required to access the Web API securely.
Public Property | Url | Gets or sets the URL used to connect to the Web API.
Top

See Also

Reference

ReportServiceSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportServiceSettings Constructor

[image]
ActiveReports 19 .NET Edition
ReportServiceSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportServiceSettings Class : ReportServiceSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportServiceSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportServiceSettings Class
ReportServiceSettings Members


ReportServiceSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ReportServiceSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportServiceSettings Class

Glossary Item Box

For a list of all members of this type, see ReportServiceSettings members.

Public Properties

 | Name | Description
Public Property | OnRequest | Gets or sets a callback function that is invoked before any request is made to the Web API.
Public Property | SecurityToken | Gets or sets the security token required to access the Web API securely.
Public Property | Url | Gets or sets the URL used to connect to the Web API.
Top

See Also

Reference

ReportServiceSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


OnRequest Property

[image]
ActiveReports 19 .NET Edition
OnRequest Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportServiceSettings Class : OnRequest Property

Glossary Item Box

Gets or sets a callback function that is invoked before any request is made to the Web API.

Syntax

Visual Basic (Declaration)
Public Property OnRequest As Func(Of OnRequestInfo,OnRequestInfo)
C#
public Func<OnRequestInfo,OnRequestInfo> OnRequest {get; set;}

Property Value

A function taking and returning an OnRequestInfo object.

Remarks

The OnRequest callback allows you to customize the request information before it is sent to the Web API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportServiceSettings Class
ReportServiceSettings Members


SecurityToken Property

[image]
ActiveReports 19 .NET Edition
SecurityToken Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportServiceSettings Class : SecurityToken Property

Glossary Item Box

Gets or sets the security token required to access the Web API securely.

Syntax

Visual Basic (Declaration)
Public Property SecurityToken As String
C#
public string SecurityToken {get; set;}

Property Value

The security token as a System.String used for authenticating requests to the API.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportServiceSettings Class
ReportServiceSettings Members


Url Property

[image]
ActiveReports 19 .NET Edition
Url Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportServiceSettings Class : Url Property

Glossary Item Box

Gets or sets the URL used to connect to the Web API.

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url {get; set;}

Property Value

The base URL of the Web API as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportServiceSettings Class
ReportServiceSettings Members


ReportViewer Class

[image]
ActiveReports 19 .NET Edition
ReportViewer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportViewer Class

Glossary Item Box

Object Model

ReportViewer Class

Syntax

Visual Basic (Declaration)
Public Class ReportViewer
   Inherits Microsoft.AspNetCore.Components.ComponentBase
   Implements Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent
C#
public class ReportViewer : Microsoft.AspNetCore.Components.ComponentBase, Microsoft.AspNetCore.Components.IComponent, Microsoft.AspNetCore.Components.IHandleAfterRender, Microsoft.AspNetCore.Components.IHandleEvent

Inheritance Hierarchy

System.Object
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Viewer.ReportViewer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportViewer Class Members

[image]
ActiveReports 19 .NET Edition
ReportViewer Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportViewer Class

Glossary Item Box

The following tables list the members exposed by ReportViewer.

Public Constructors

 | Name | Description
Public Constructor | ReportViewer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.
Public Property | AutoBackgroundColor | Gets a value indicating whether the view area background color is filled with the report body color.
Public Property | AvailableExports | Gets or sets the array of export types available via the Export functionality of the Viewer.
Public Property | DefaultExportSettings | Gets or sets the object containing custom default export settings. Use to set default value and visibility of any field in the export panel.
Public Property | DisplayMode | Gets or sets the page display mode.
Public Property | DocumentLoaded | Gets or sets the сallback invoked when a document is fully loaded on the server.
Public Property | Error | Gets or sets the callback invoked when an error occurs during the process of displaying the report.
Public Property | Height | Gets or sets the height of the Viewer component.
Public Property | HideErrors | Gets or sets whether to show errors in the Viewer.
Public Property | InitialZoomMode | Gets or sets the initial zoom mode.
Public Property | InitialZoomPercentage | Gets or sets the initial zoom value in percentage.
Public Property | Locale | Gets or sets the locale used for displaying the Viewer.
Public Property | LocaleData | Gets or sets the JSON containing the localization strings.
Public Property | LocaleUri | Gets or sets the URL of the file containing the localization strings.
Public Property | PanelsLocation | Gets or sets the position of panels (search, parameters etc.): 'toolbar' or 'sidebar'.
Public Property | Parameters | Gets or sets the array of name-value pairs that describe the parameters values used to run the report.
Public Property | ParametersPanelSettings | Gets or sets the parameters panel settings.
Public Property | RenderFormat | Gets or sets the report render mode.
Public Property | RenderMode | Gets or sets the initial render mode: 'Paginated' or 'Galley'.
Public Property | ReportLoaded | Gets or sets the callback invoked when the Viewer obtains information about the requested report.
Public Property | ReportName | Gets or sets the name of the report to be shown by the Viewer.
Public Property | ReportService | Gets or sets the settings for connecting to the Web API.
Public Property | Sidebar | Gets the viewer's sidebar, used to toggle its visibility.
Public Property | Themes | Gets or sets the UI theme settings for customizing the appearance of the viewer.
Public Property | Toolbar | Gets the viewer's toolbar, used to add custom toolbar elements or remove existing ones.
Public Property | ViewerInitialized | Gets or sets the callback that is invoked when the Viewer is initialized.
Public Property | Width | Gets or sets the width of the Viewer component.
Top

Public Methods

 | Name | Description
Public Method | BackToParent | Makes the viewer display the parent report of the drill-down report.
Public Method | CurrentPage | Gets the currently displayed page number.
Public Method | Export | Exports the currently displayed report.
Public Method | GetTheme | Gets the current UI theme of the viewer.
Public Method | GetToc | Gets the report table of contents (TOC).
Public Method | GoToPage | Makes the viewer to display the specific page. Page numeration starts with 1.
Public Method | OpenReport | Opens a report.
Public Method | PageCount | Gets the page count of the currently displayed report.
Public Method | Print | Prints the currently displayed report, if any.
Public Method | Refresh | Refreshes the report.
Public Method | Render | Renders the viewer to an element.
Public Method | Search | Performs a search of a specific term with specific search options (match case, whole word) and invokes the callback with the search result passed.
Public Method | SetTheme | Sets the UI theme for the viewer.
Top

See Also

Reference

ReportViewer Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportViewer Constructor

[image]
ActiveReports 19 .NET Edition
ReportViewer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ReportViewer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportViewer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Methods

[image]
ActiveReports 19 .NET Edition
ReportViewer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportViewer Class

Glossary Item Box

For a list of all members of this type, see ReportViewer members.

Public Methods

 | Name | Description
Public Method | BackToParent | Makes the viewer display the parent report of the drill-down report.
Public Method | CurrentPage | Gets the currently displayed page number.
Public Method | Export | Exports the currently displayed report.
Public Method | GetTheme | Gets the current UI theme of the viewer.
Public Method | GetToc | Gets the report table of contents (TOC).
Public Method | GoToPage | Makes the viewer to display the specific page. Page numeration starts with 1.
Public Method | OpenReport | Opens a report.
Public Method | PageCount | Gets the page count of the currently displayed report.
Public Method | Print | Prints the currently displayed report, if any.
Public Method | Refresh | Refreshes the report.
Public Method | Render | Renders the viewer to an element.
Public Method | Search | Performs a search of a specific term with specific search options (match case, whole word) and invokes the callback with the search result passed.
Public Method | SetTheme | Sets the UI theme for the viewer.
Top

See Also

Reference

ReportViewer Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


BackToParent Method

[image]
ActiveReports 19 .NET Edition
BackToParent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : BackToParent Method

Glossary Item Box

Makes the viewer display the parent report of the drill-down report.

Syntax

Visual Basic (Declaration)
Public Function BackToParent() As Task
C#
public Task BackToParent()

Return Value

A task that represents the asynchronous operation of returning to the parent report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


CurrentPage Method

[image]
ActiveReports 19 .NET Edition
CurrentPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : CurrentPage Method

Glossary Item Box

Gets the currently displayed page number.

Syntax

Visual Basic (Declaration)
Public Function CurrentPage() As ValueTask(Of Integer)
C#
public ValueTask<int> CurrentPage()

Return Value

The current page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Export Method

[image]
ActiveReports 19 .NET Edition
Export Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Export Method

exportType
Specifies export format.
callback
Function invoked once the export result is available (its URL is passed in the callback).
saveAsDialog
Indicates whether the save as dialog should be shown immediately once the export result is ready.
settings
The export settings available for RenderingExtensions.
isCancelRequested
The function periodically called to check if the export task should be canceled.

Glossary Item Box

Exports the currently displayed report.

Syntax

Visual Basic (Declaration)
Public Function Export( _
   ByVal exportType As ExportTypes, _
   Optional ByVal callback As Action(Of String), _
   Optional ByVal saveAsDialog As Boolean, _
   Optional ByVal settings As Dictionary(Of String,String), _
   Optional ByVal isCancelRequested As Func(Of Boolean) _
) As Task
C#
public Task Export(
   ExportTypes exportType,
   Action<string> callback,
   bool saveAsDialog,
   Dictionary<string,string> settings,
   Func<bool> isCancelRequested
)

Parameters

exportType
Specifies export format.
callback
Function invoked once the export result is available (its URL is passed in the callback).
saveAsDialog
Indicates whether the save as dialog should be shown immediately once the export result is ready.
settings
The export settings available for RenderingExtensions.
isCancelRequested
The function periodically called to check if the export task should be canceled.

Return Value

A task that represents the asynchronous operation of exporting the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


GetTheme Method

[image]
ActiveReports 19 .NET Edition
GetTheme Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : GetTheme Method

Glossary Item Box

Gets the current UI theme of the viewer.

Syntax

Visual Basic (Declaration)
Public Function GetTheme() As ValueTask(Of ColorTheme)
C#
public ValueTask<ColorTheme> GetTheme()

Return Value

The current UI theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


GetToc Method

[image]
ActiveReports 19 .NET Edition
GetToc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : GetToc Method

Glossary Item Box

Gets the report table of contents (TOC).

Syntax

Visual Basic (Declaration)
Public Function GetToc() As ValueTask(Of BookmarkInfo)
C#
public ValueTask<BookmarkInfo> GetToc()

Return Value

The TOC tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


GoToPage Method

[image]
ActiveReports 19 .NET Edition
GoToPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : GoToPage Method

pageIndex
The number of the page to go to.

Glossary Item Box

Makes the viewer to display the specific page. Page numeration starts with 1.

Syntax

Visual Basic (Declaration)
Public Function GoToPage( _
   ByVal pageIndex As Integer _
) As Task
C#
public Task GoToPage(
   int pageIndex
)

Parameters

pageIndex
The number of the page to go to.

Return Value

A task that represents the asynchronous operation of navigating to the specified page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


OpenReport Method

[image]
ActiveReports 19 .NET Edition
OpenReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : OpenReport Method

reportID
The id of the report.
parameters
An array of parameter values for the report (optional).

Glossary Item Box

Opens a report.

Syntax

Visual Basic (Declaration)
Public Function OpenReport( _
   ByVal reportID As String, _
   Optional ByVal parameters() As Parameter _
) As Task
C#
public Task OpenReport(
   string reportID,
   Parameter[] parameters
)

Parameters

reportID
The id of the report.
parameters
An array of parameter values for the report (optional).

Return Value

A task that represents the asynchronous operation of opening the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


PageCount Method

[image]
ActiveReports 19 .NET Edition
PageCount Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : PageCount Method

Glossary Item Box

Gets the page count of the currently displayed report.

Syntax

Visual Basic (Declaration)
Public Function PageCount() As ValueTask(Of Integer)
C#
public ValueTask<int> PageCount()

Return Value

The page count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Print Method

[image]
ActiveReports 19 .NET Edition
Print Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Print Method

Glossary Item Box

Prints the currently displayed report, if any.

Syntax

Visual Basic (Declaration)
Public Function Print() As Task
C#
public Task Print()

Return Value

A task that represents the asynchronous operation of printing the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Refresh Method

[image]
ActiveReports 19 .NET Edition
Refresh Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Refresh Method

Glossary Item Box

Refreshes the report.

Syntax

Visual Basic (Declaration)
Public Function Refresh() As Task
C#
public Task Refresh()

Return Value

A task that represents the asynchronous operation of refreshing the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Render Method

jSRuntime
The JavaScript runtime instance used to interact with JavaScript functions.
element
The ID of the HTML element where the viewer will be rendered.
options
The initialization options used to configure the viewer.

Glossary Item Box

Renders the viewer to an element.

Syntax

Visual Basic (Declaration)
Public Function Render( _
   ByVal jSRuntime As IJSRuntime, _
   ByVal element As String, _
   ByVal options As InitializationOptions _
) As Task
C#
public Task Render(
   IJSRuntime jSRuntime,
   string element,
   InitializationOptions options
)

Parameters

jSRuntime
The JavaScript runtime instance used to interact with JavaScript functions.
element
The ID of the HTML element where the viewer will be rendered.
options
The initialization options used to configure the viewer.

Return Value

A task that represents the asynchronous operation of rendering the viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Search Method

[image]
ActiveReports 19 .NET Edition
Search Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Search Method

searchTerm
String to find.
searchOptions
The object optionally defines the search options.
callback
The function to call after performing search.

Glossary Item Box

Performs a search of a specific term with specific search options (match case, whole word) and invokes the callback with the search result passed.

Syntax

Visual Basic (Declaration)
Public Function Search( _
   ByVal searchTerm As String, _
   Optional ByVal searchOptions As SearchOptions, _
   Optional ByVal callback As Action(Of List(Of SearchResult)) _
) As Task
C#
public Task Search(
   string searchTerm,
   SearchOptions searchOptions,
   Action<List<SearchResult>> callback
)

Parameters

searchTerm
String to find.
searchOptions
The object optionally defines the search options.
callback
The function to call after performing search.

Return Value

A task that represents the asynchronous operation of performing the search.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


SetTheme Method

[image]
ActiveReports 19 .NET Edition
SetTheme Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : SetTheme Method

theme
The UI theme to apply to the viewer.

Glossary Item Box

Sets the UI theme for the viewer.

Syntax

Visual Basic (Declaration)
Public Function SetTheme( _
   ByVal theme As ColorTheme _
) As Task
C#
public Task SetTheme(
   ColorTheme theme
)

Parameters

theme
The UI theme to apply to the viewer.

Return Value

A task that represents the asynchronous operation of setting the viewer's theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Properties

[image]
ActiveReports 19 .NET Edition
ReportViewer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportViewer Class

Glossary Item Box

For a list of all members of this type, see ReportViewer members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.
Public Property | AutoBackgroundColor | Gets a value indicating whether the view area background color is filled with the report body color.
Public Property | AvailableExports | Gets or sets the array of export types available via the Export functionality of the Viewer.
Public Property | DefaultExportSettings | Gets or sets the object containing custom default export settings. Use to set default value and visibility of any field in the export panel.
Public Property | DisplayMode | Gets or sets the page display mode.
Public Property | DocumentLoaded | Gets or sets the сallback invoked when a document is fully loaded on the server.
Public Property | Error | Gets or sets the callback invoked when an error occurs during the process of displaying the report.
Public Property | Height | Gets or sets the height of the Viewer component.
Public Property | HideErrors | Gets or sets whether to show errors in the Viewer.
Public Property | InitialZoomMode | Gets or sets the initial zoom mode.
Public Property | InitialZoomPercentage | Gets or sets the initial zoom value in percentage.
Public Property | Locale | Gets or sets the locale used for displaying the Viewer.
Public Property | LocaleData | Gets or sets the JSON containing the localization strings.
Public Property | LocaleUri | Gets or sets the URL of the file containing the localization strings.
Public Property | PanelsLocation | Gets or sets the position of panels (search, parameters etc.): 'toolbar' or 'sidebar'.
Public Property | Parameters | Gets or sets the array of name-value pairs that describe the parameters values used to run the report.
Public Property | ParametersPanelSettings | Gets or sets the parameters panel settings.
Public Property | RenderFormat | Gets or sets the report render mode.
Public Property | RenderMode | Gets or sets the initial render mode: 'Paginated' or 'Galley'.
Public Property | ReportLoaded | Gets or sets the callback invoked when the Viewer obtains information about the requested report.
Public Property | ReportName | Gets or sets the name of the report to be shown by the Viewer.
Public Property | ReportService | Gets or sets the settings for connecting to the Web API.
Public Property | Sidebar | Gets the viewer's sidebar, used to toggle its visibility.
Public Property | Themes | Gets or sets the UI theme settings for customizing the appearance of the viewer.
Public Property | Toolbar | Gets the viewer's toolbar, used to add custom toolbar elements or remove existing ones.
Public Property | ViewerInitialized | Gets or sets the callback that is invoked when the Viewer is initialized.
Public Property | Width | Gets or sets the width of the Viewer component.
Top

See Also

Reference

ReportViewer Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Action Property

Glossary Item Box

Gets or sets the callback invoked before the Viewer opens a hyperlink, bookmark link, drill down report, or toggles report control visibility.

Syntax

Visual Basic (Declaration)
Public Property Action As Action(Of String,Object())
C#
public Action<string,object[]> Action {get; set;}

Property Value

A callback function that takes a System.String and an array of System.Object.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


AutoBackgroundColor Property

[image]
ActiveReports 19 .NET Edition
AutoBackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : AutoBackgroundColor Property

Glossary Item Box

Gets a value indicating whether the view area background color is filled with the report body color.

Syntax

Visual Basic (Declaration)
Public Property AutoBackgroundColor As Boolean
C#
public bool AutoBackgroundColor {get; set;}

Property Value

When true, the view area background color is filled with the report body color.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. Available only for Dashboard reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


AvailableExports Property

[image]
ActiveReports 19 .NET Edition
AvailableExports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : AvailableExports Property

Glossary Item Box

Gets or sets the array of export types available via the Export functionality of the Viewer.

Syntax

Visual Basic (Declaration)
Public Property AvailableExports As ExportTypes()
C#
public ExportTypes[] AvailableExports {get; set;}

Property Value

An array of ExportTypes that specifies the formats in which the report can be exported.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


DefaultExportSettings Property

[image]
ActiveReports 19 .NET Edition
DefaultExportSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : DefaultExportSettings Property

Glossary Item Box

Gets or sets the object containing custom default export settings. Use to set default value and visibility of any field in the export panel.

Syntax

Visual Basic (Declaration)
Public Property DefaultExportSettings As Dictionary(Of String,Dictionary(Of String,ExportSetting))
C#
public Dictionary<string,Dictionary<string,ExportSetting>> DefaultExportSettings {get; set;}

Property Value

A dictionary where keys are export types and values are dictionaries of export settings.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


DisplayMode Property

[image]
ActiveReports 19 .NET Edition
DisplayMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : DisplayMode Property

Glossary Item Box

Gets or sets the page display mode.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As ViewMode
C#
public ViewMode DisplayMode {get; set;}

Property Value

The display mode as a ViewMode.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


DocumentLoaded Property

[image]
ActiveReports 19 .NET Edition
DocumentLoaded Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : DocumentLoaded Property

Glossary Item Box

Gets or sets the сallback invoked when a document is fully loaded on the server.

Syntax

Visual Basic (Declaration)
Public Property DocumentLoaded As Action
C#
public Action DocumentLoaded {get; set;}

Property Value

A callback function.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Error Property

[image]
ActiveReports 19 .NET Edition
Error Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Error Property

Glossary Item Box

Gets or sets the callback invoked when an error occurs during the process of displaying the report.

Syntax

Visual Basic (Declaration)
Public Property Error As Action(Of ErrorInfo)
C#
public Action<ErrorInfo> Error {get; set;}

Property Value

A callback function that takes an ErrorInfo object.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Height Property

Glossary Item Box

Gets or sets the height of the Viewer component.

Syntax

Visual Basic (Declaration)
Public Property Height As String
C#
public string Height {get; set;}

Property Value

A System.String representing the height of the Viewer. Accepts CSS units such as "px", "%", "em", etc.

Remarks

The default value is "100%".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


HideErrors Property

[image]
ActiveReports 19 .NET Edition
HideErrors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : HideErrors Property

Glossary Item Box

Gets or sets whether to show errors in the Viewer.

Syntax

Visual Basic (Declaration)
Public Property HideErrors As Boolean
C#
public bool HideErrors {get; set;}

Property Value

true if errors should be hidden; otherwise, false.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


InitialZoomMode Property

[image]
ActiveReports 19 .NET Edition
InitialZoomMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : InitialZoomMode Property

Glossary Item Box

Gets or sets the initial zoom mode.

Syntax

Visual Basic (Declaration)
Public Property InitialZoomMode As Nullable(Of ZoomMode)
C#
public Nullable<ZoomMode> InitialZoomMode {get; set;}

Property Value

The initial zoom mode as a nullable ZoomMode.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


InitialZoomPercentage Property

[image]
ActiveReports 19 .NET Edition
InitialZoomPercentage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : InitialZoomPercentage Property

Glossary Item Box

Gets or sets the initial zoom value in percentage.

Syntax

Visual Basic (Declaration)
Public Property InitialZoomPercentage As Nullable(Of Integer)
C#
public Nullable<int> InitialZoomPercentage {get; set;}

Property Value

The initial zoom value as a nullable System.Int32.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Locale Property

[image]
ActiveReports 19 .NET Edition
Locale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Locale Property

Glossary Item Box

Gets or sets the locale used for displaying the Viewer.

Syntax

Visual Basic (Declaration)
Public Property Locale As String
C#
public string Locale {get; set;}

Property Value

The locale as a System.String.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


LocaleData Property

[image]
ActiveReports 19 .NET Edition
LocaleData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : LocaleData Property

Glossary Item Box

Gets or sets the JSON containing the localization strings.

Syntax

Visual Basic (Declaration)
Public Property LocaleData As String
C#
public string LocaleData {get; set;}

Property Value

A JSON string representing the localization data.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


LocaleUri Property

[image]
ActiveReports 19 .NET Edition
LocaleUri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : LocaleUri Property

Glossary Item Box

Gets or sets the URL of the file containing the localization strings.

Syntax

Visual Basic (Declaration)
Public Property LocaleUri As String
C#
public string LocaleUri {get; set;}

Property Value

The URL of the file as a System.String.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


PanelsLocation Property

[image]
ActiveReports 19 .NET Edition
PanelsLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : PanelsLocation Property

Glossary Item Box

Gets or sets the position of panels (search, parameters etc.): 'toolbar' or 'sidebar'.

Syntax

Visual Basic (Declaration)
Public Property PanelsLocation As PanelsLocation
C#
public PanelsLocation PanelsLocation {get; set;}

Property Value

The position of panels as a PanelsLocation.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. Default value is 'toolbar'.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Parameters Property

Glossary Item Box

Gets or sets the array of name-value pairs that describe the parameters values used to run the report.

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameter()
C#
public Parameter[] Parameters {get; set;}

Property Value

An array of Parameter objects.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ParametersPanelSettings Property

[image]
ActiveReports 19 .NET Edition
ParametersPanelSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ParametersPanelSettings Property

Glossary Item Box

Gets or sets the parameters panel settings.

Syntax

Visual Basic (Declaration)
Public Property ParametersPanelSettings As ParametersPanelSettings
C#
public ParametersPanelSettings ParametersPanelSettings {get; set;}

Property Value

An instance of ParametersPanelSettings that defines the parameters panel settings.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


RenderFormat Property

[image]
ActiveReports 19 .NET Edition
RenderFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : RenderFormat Property

Glossary Item Box

Gets or sets the report render mode.

Syntax

Visual Basic (Declaration)
Public Property RenderFormat As RenderFormat
C#
public RenderFormat RenderFormat {get; set;}

Property Value

The render mode as a RenderFormat.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


RenderMode Property

[image]
ActiveReports 19 .NET Edition
RenderMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : RenderMode Property

Glossary Item Box

Gets or sets the initial render mode: 'Paginated' or 'Galley'.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As RenderMode
C#
public RenderMode RenderMode {get; set;}

Property Value

The initial render mode as a RenderMode.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards. Default value is 'Paginated'.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportLoaded Property

[image]
ActiveReports 19 .NET Edition
ReportLoaded Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ReportLoaded Property

Glossary Item Box

Gets or sets the callback invoked when the Viewer obtains information about the requested report.

Syntax

Visual Basic (Declaration)
Public Property ReportLoaded As Action(Of ReportInfo)
C#
public Action<ReportInfo> ReportLoaded {get; set;}

Property Value

A callback function that takes a ReportInfo object.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ReportName Property

Glossary Item Box

Gets or sets the name of the report to be shown by the Viewer.

Syntax

Visual Basic (Declaration)
Public Property ReportName As String
C#
public string ReportName {get; set;}

Property Value

The name of the report as a System.String.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportService Property

[image]
ActiveReports 19 .NET Edition
ReportService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ReportService Property

Glossary Item Box

Gets or sets the settings for connecting to the Web API.

Syntax

Visual Basic (Declaration)
Public Property ReportService As ReportServiceSettings
C#
public ReportServiceSettings ReportService {get; set;}

Property Value

An instance of ReportServiceSettings that defines the API connection settings.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Sidebar Property

[image]
ActiveReports 19 .NET Edition
Sidebar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Sidebar Property

Glossary Item Box

Gets the viewer's sidebar, used to toggle its visibility.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sidebar As Sidebar
C#
public Sidebar Sidebar {get;}

Property Value

An instance of Sidebar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Themes Property

Glossary Item Box

Gets or sets the UI theme settings for customizing the appearance of the viewer.

Syntax

Visual Basic (Declaration)
Public Property Themes As ThemeSettings
C#
public ThemeSettings Themes {get; set;}

Property Value

An instance of ThemeSettings that defines the theme settings.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Toolbar Property

[image]
ActiveReports 19 .NET Edition
Toolbar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Toolbar Property

Glossary Item Box

Gets the viewer's toolbar, used to add custom toolbar elements or remove existing ones.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Toolbar As Toolbar
C#
public Toolbar Toolbar {get;}

Property Value

An instance of Toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


ViewerInitialized Property

[image]
ActiveReports 19 .NET Edition
ViewerInitialized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : ViewerInitialized Property

Glossary Item Box

Gets or sets the callback that is invoked when the Viewer is initialized.

Syntax

Visual Basic (Declaration)
Public Property ViewerInitialized As Action
C#
public Action ViewerInitialized {get; set;}

Property Value

A callback function.

Remarks

This property can only be set once during object initialization and cannot be changed afterwards.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : Width Property

Glossary Item Box

Gets or sets the width of the Viewer component.

Syntax

Visual Basic (Declaration)
Public Property Width As String
C#
public string Width {get; set;}

Property Value

A System.String representing the width of the Viewer. Accepts CSS units such as "px", "%", "em", etc.

Remarks

The default value is "100%".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


SearchOptions Class

[image]
ActiveReports 19 .NET Edition
SearchOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchOptions Class

Glossary Item Box

Represents the configuration options for performing text searches.

Object Model

SearchOptions Class

Syntax

Visual Basic (Declaration)
Public Class SearchOptions
C#
public class SearchOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.SearchOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchOptions Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SearchOptions Class Members

[image]
ActiveReports 19 .NET Edition
SearchOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchOptions Class

Glossary Item Box

The following tables list the members exposed by SearchOptions.

Public Constructors

 | Name | Description
Public Constructor | SearchOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | MatchCase | Gets or sets a value indicating whether the search should be case-sensitive.
Public Property | WholePhrase | Gets or sets a value indicating whether the search should match the whole phrase exactly as it appears.
Top

See Also

Reference

SearchOptions Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SearchOptions Constructor

[image]
ActiveReports 19 .NET Edition
SearchOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchOptions Class : SearchOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SearchOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchOptions Class
SearchOptions Members


SearchOptions Class Properties

[image]
ActiveReports 19 .NET Edition
SearchOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchOptions Class

Glossary Item Box

For a list of all members of this type, see SearchOptions members.

Public Properties

 | Name | Description
Public Property | MatchCase | Gets or sets a value indicating whether the search should be case-sensitive.
Public Property | WholePhrase | Gets or sets a value indicating whether the search should match the whole phrase exactly as it appears.
Top

See Also

Reference

SearchOptions Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


MatchCase Property

[image]
ActiveReports 19 .NET Edition
MatchCase Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchOptions Class : MatchCase Property

Glossary Item Box

Gets or sets a value indicating whether the search should be case-sensitive.

Syntax

Visual Basic (Declaration)
Public Property MatchCase As Boolean
C#
public bool MatchCase {get; set;}

Property Value

true if the search should consider the case of the text (e.g., 'apple' is different from 'Apple'); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchOptions Class
SearchOptions Members


WholePhrase Property

[image]
ActiveReports 19 .NET Edition
WholePhrase Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchOptions Class : WholePhrase Property

Glossary Item Box

Gets or sets a value indicating whether the search should match the whole phrase exactly as it appears.

Syntax

Visual Basic (Declaration)
Public Property WholePhrase As Boolean
C#
public bool WholePhrase {get; set;}

Property Value

true if the search should match the entire phrase exactly; otherwise, false if partial matches are acceptable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchOptions Class
SearchOptions Members


SearchResult Class

[image]
ActiveReports 19 .NET Edition
SearchResult Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchResult Class

Glossary Item Box

Represents a search result, including details about the text appearance, its location, and its context.

Object Model

SearchResult Class

Syntax

Visual Basic (Declaration)
Public Class SearchResult
C#
public class SearchResult

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.SearchResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SearchResult Class Members

[image]
ActiveReports 19 .NET Edition
SearchResult Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchResult Class

Glossary Item Box

The following tables list the members exposed by SearchResult.

Public Constructors

 | Name | Description
Public Constructor | SearchResult Constructor |
Top

Public Properties

 | Name | Description
Public Property | DisplayText | Gets or sets the text to be displayed as part of the search result.
Public Property | ItemArea | Gets or sets the area coordinates where the text item is located within its page.
Public Property | ItemIndex | Gets or sets the logical index of the item within the search results list.
Public Property | PageIndex | Gets or sets the index of the page where the occurrence of the search result is found.
Public Property | Range | Gets or sets the range of the text selected as part of the search result.
Top

See Also

Reference

SearchResult Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SearchResult Constructor

[image]
ActiveReports 19 .NET Edition
SearchResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : SearchResult Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SearchResult()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


SearchResult Class Properties

[image]
ActiveReports 19 .NET Edition
SearchResult Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SearchResult Class

Glossary Item Box

For a list of all members of this type, see SearchResult members.

Public Properties

 | Name | Description
Public Property | DisplayText | Gets or sets the text to be displayed as part of the search result.
Public Property | ItemArea | Gets or sets the area coordinates where the text item is located within its page.
Public Property | ItemIndex | Gets or sets the logical index of the item within the search results list.
Public Property | PageIndex | Gets or sets the index of the page where the occurrence of the search result is found.
Public Property | Range | Gets or sets the range of the text selected as part of the search result.
Top

See Also

Reference

SearchResult Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


DisplayText Property

[image]
ActiveReports 19 .NET Edition
DisplayText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : DisplayText Property

Glossary Item Box

Gets or sets the text to be displayed as part of the search result.

Syntax

Visual Basic (Declaration)
Public Property DisplayText As String
C#
public string DisplayText {get; set;}

Property Value

The display text associated with this search result.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


ItemArea Property

[image]
ActiveReports 19 .NET Edition
ItemArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : ItemArea Property

Glossary Item Box

Gets or sets the area coordinates where the text item is located within its page.

Syntax

Visual Basic (Declaration)
Public Property ItemArea As Area
C#
public Area ItemArea {get; set;}

Property Value

The area of the document where the text item is found, defined by its dimensions and position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


ItemIndex Property

[image]
ActiveReports 19 .NET Edition
ItemIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : ItemIndex Property

Glossary Item Box

Gets or sets the logical index of the item within the search results list.

Syntax

Visual Basic (Declaration)
Public Property ItemIndex As Integer
C#
public int ItemIndex {get; set;}

Property Value

The ordered index of the item among other search results.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


PageIndex Property

[image]
ActiveReports 19 .NET Edition
PageIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : PageIndex Property

Glossary Item Box

Gets or sets the index of the page where the occurrence of the search result is found.

Syntax

Visual Basic (Declaration)
Public Property PageIndex As Integer
C#
public int PageIndex {get; set;}

Property Value

The zero-based page index indicating where the text item is located within the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


Range Property

[image]
ActiveReports 19 .NET Edition
Range Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SearchResult Class : Range Property

Glossary Item Box

Gets or sets the range of the text selected as part of the search result.

Syntax

Visual Basic (Declaration)
Public Property Range As Range
C#
public Range Range {get; set;}

Property Value

The text range that highlights the specific text found by the search.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchResult Class
SearchResult Members


ShadesColorItem Class

[image]
ActiveReports 19 .NET Edition
ShadesColorItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ShadesColorItem Class

Glossary Item Box

Represents a color item with multiple shades.

Object Model

ShadesColorItem Class

Syntax

Visual Basic (Declaration)
Public Class ShadesColorItem
   Inherits ColorThemeItem
C#
public class ShadesColorItem : ColorThemeItem

Remarks

This class extends ColorThemeItem and provides multiple shade variations of a color, ranging from very light to very dark.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemeItem
GrapeCity.ActiveReports.Blazor.Viewer.ShadesColorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ShadesColorItem Class Members

[image]
ActiveReports 19 .NET Edition
ShadesColorItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ShadesColorItem Class

Glossary Item Box

The following tables list the members exposed by ShadesColorItem.

Public Constructors

 | Name | Description
Public Constructor | ShadesColorItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Base | Gets or sets the base shade of the color.
Public Property | Dark | Gets or sets the dark shade of the color.
Public Property | Darker | Gets or sets the darker shade of the color.
Public Property | DarkMedium | Gets or sets the dark-medium shade of the color.
Public Property | Light | Gets or sets the light shade of the color.
Public Property | Lighter | Gets or sets the lighter shade of the color.
Public Property | LightMedium | Gets or sets the light-medium shade of the color.
Public Property | Medium | Gets or sets the medium shade of the color.
Public Property | VeryDark | Gets or sets the very dark shade of the color.
Public Property | VeryLight | Gets or sets the very light shade of the color.
Top

See Also

Reference

ShadesColorItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ShadesColorItem Constructor

[image]
ActiveReports 19 .NET Edition
ShadesColorItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : ShadesColorItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ShadesColorItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


ShadesColorItem Class Properties

[image]
ActiveReports 19 .NET Edition
ShadesColorItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ShadesColorItem Class

Glossary Item Box

For a list of all members of this type, see ShadesColorItem members.

Public Properties

 | Name | Description
Public Property | Base | Gets or sets the base shade of the color.
Public Property | Dark | Gets or sets the dark shade of the color.
Public Property | Darker | Gets or sets the darker shade of the color.
Public Property | DarkMedium | Gets or sets the dark-medium shade of the color.
Public Property | Light | Gets or sets the light shade of the color.
Public Property | Lighter | Gets or sets the lighter shade of the color.
Public Property | LightMedium | Gets or sets the light-medium shade of the color.
Public Property | Medium | Gets or sets the medium shade of the color.
Public Property | VeryDark | Gets or sets the very dark shade of the color.
Public Property | VeryLight | Gets or sets the very light shade of the color.
Top

See Also

Reference

ShadesColorItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Base Property

[image]
ActiveReports 19 .NET Edition
Base Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Base Property

Glossary Item Box

Gets or sets the base shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Base As String
C#
public string Base {get; set;}

Property Value

A System.String representing the base shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Dark Property

[image]
ActiveReports 19 .NET Edition
Dark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Dark Property

Glossary Item Box

Gets or sets the dark shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Dark As String
C#
public string Dark {get; set;}

Property Value

A System.String representing the dark shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Darker Property

[image]
ActiveReports 19 .NET Edition
Darker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Darker Property

Glossary Item Box

Gets or sets the darker shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Darker As String
C#
public string Darker {get; set;}

Property Value

A System.String representing the darker shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


DarkMedium Property

[image]
ActiveReports 19 .NET Edition
DarkMedium Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : DarkMedium Property

Glossary Item Box

Gets or sets the dark-medium shade of the color.

Syntax

Visual Basic (Declaration)
Public Property DarkMedium As String
C#
public string DarkMedium {get; set;}

Property Value

A System.String representing the dark-medium shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Light Property

[image]
ActiveReports 19 .NET Edition
Light Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Light Property

Glossary Item Box

Gets or sets the light shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Light As String
C#
public string Light {get; set;}

Property Value

A System.String representing the light shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Lighter Property

[image]
ActiveReports 19 .NET Edition
Lighter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Lighter Property

Glossary Item Box

Gets or sets the lighter shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Lighter As String
C#
public string Lighter {get; set;}

Property Value

A System.String representing the lighter shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


LightMedium Property

[image]
ActiveReports 19 .NET Edition
LightMedium Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : LightMedium Property

Glossary Item Box

Gets or sets the light-medium shade of the color.

Syntax

Visual Basic (Declaration)
Public Property LightMedium As String
C#
public string LightMedium {get; set;}

Property Value

A System.String representing the light-medium shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Medium Property

[image]
ActiveReports 19 .NET Edition
Medium Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : Medium Property

Glossary Item Box

Gets or sets the medium shade of the color.

Syntax

Visual Basic (Declaration)
Public Property Medium As String
C#
public string Medium {get; set;}

Property Value

A System.String representing the medium shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


VeryDark Property

[image]
ActiveReports 19 .NET Edition
VeryDark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : VeryDark Property

Glossary Item Box

Gets or sets the very dark shade of the color.

Syntax

Visual Basic (Declaration)
Public Property VeryDark As String
C#
public string VeryDark {get; set;}

Property Value

A System.String representing the very dark shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


VeryLight Property

[image]
ActiveReports 19 .NET Edition
VeryLight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ShadesColorItem Class : VeryLight Property

Glossary Item Box

Gets or sets the very light shade of the color.

Syntax

Visual Basic (Declaration)
Public Property VeryLight As String
C#
public string VeryLight {get; set;}

Property Value

A System.String representing the very light shade of the color.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShadesColorItem Class
ShadesColorItem Members


Sidebar Class

[image]
ActiveReports 19 .NET Edition
Sidebar Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Sidebar Class

Glossary Item Box

The viewer's sidebar, used to toggle its visibility.

Object Model

Sidebar Class

Syntax

Visual Basic (Declaration)
Public Class Sidebar
C#
public class Sidebar

Remarks

The Sidebar class provides a method to toggle the visibility of the sidebar in the viewer.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Sidebar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Sidebar Class Members

[image]
ActiveReports 19 .NET Edition
Sidebar Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Sidebar Class

Glossary Item Box

The following tables list the members exposed by Sidebar.

Public Methods

 | Name | Description
Public Method | Toggle | Toggles the sidebar visibility.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Sidebar Class Methods

[image]
ActiveReports 19 .NET Edition
Sidebar Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Methods

 | Name | Description
Public Method | Toggle | Toggles the sidebar visibility.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Toggle Method

[image]
ActiveReports 19 .NET Edition
Toggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Sidebar Class : Toggle Method

show
Pass true to switch sidebar ON, and vise-versa.

Glossary Item Box

Toggles the sidebar visibility.

Syntax

Visual Basic (Declaration)
Public Function Toggle( _
   ByVal show As Boolean _
) As Task
C#
public Task Toggle(
   bool show
)

Parameters

show
Pass true to switch sidebar ON, and vise-versa.

Return Value

A task that represents the asynchronous operation of toggling the sidebar visibility.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SingleColorItem Class

[image]
ActiveReports 19 .NET Edition
SingleColorItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SingleColorItem Class

Glossary Item Box

Represents a single color item in a color theme.

Object Model

SingleColorItem Class

Syntax

Visual Basic (Declaration)
Public Class SingleColorItem
   Inherits ColorThemeItem
C#
public class SingleColorItem : ColorThemeItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemeItem
GrapeCity.ActiveReports.Blazor.Viewer.SingleColorItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleColorItem Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SingleColorItem Class Members

[image]
ActiveReports 19 .NET Edition
SingleColorItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SingleColorItem Class

Glossary Item Box

The following tables list the members exposed by SingleColorItem.

Public Constructors

 | Name | Description
Public Constructor | SingleColorItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color value.
Top

See Also

Reference

SingleColorItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SingleColorItem Constructor

[image]
ActiveReports 19 .NET Edition
SingleColorItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SingleColorItem Class : SingleColorItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SingleColorItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleColorItem Class
SingleColorItem Members


SingleColorItem Class Properties

[image]
ActiveReports 19 .NET Edition
SingleColorItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SingleColorItem Class

Glossary Item Box

For a list of all members of this type, see SingleColorItem members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color value.
Top

See Also

Reference

SingleColorItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > SingleColorItem Class : Color Property

Glossary Item Box

Gets or sets the color value.

Syntax

Visual Basic (Declaration)
Public Property Color As String
C#
public string Color {get; set;}

Property Value

A System.String representing the color value.

Remarks

The color value can be specified in the following formats: WebColor, HEX8, RGBA, and HSLA.

Examples:

  • WebColor: Red
  • HEX8: #ff0000
  • RGBA: rgba(255, 0, 0, 1)
  • HSLA: hsla(0, 100%, 50%, 1)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleColorItem Class
SingleColorItem Members


ThemeSelector Class

[image]
ActiveReports 19 .NET Edition
ThemeSelector Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSelector Class

Glossary Item Box

Represents theme selector settings.

Object Model

ThemeSelector Class

Syntax

Visual Basic (Declaration)
Public Class ThemeSelector
C#
public class ThemeSelector

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ThemeSelector

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSelector Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ThemeSelector Class Members

[image]
ActiveReports 19 .NET Edition
ThemeSelector Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSelector Class

Glossary Item Box

The following tables list the members exposed by ThemeSelector.

Public Constructors

 | Name | Description
Public Constructor | ThemeSelector Constructor |
Top

Public Properties

 | Name | Description
Public Property | AvailableThemes | Gets or sets the collection of available themes.
Public Property | Enabled | Gets or sets a value indicating whether the theme selector is enabled.
Top

See Also

Reference

ThemeSelector Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ThemeSelector Constructor

[image]
ActiveReports 19 .NET Edition
ThemeSelector Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSelector Class : ThemeSelector Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeSelector()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSelector Class
ThemeSelector Members


ThemeSelector Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeSelector Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSelector Class

Glossary Item Box

For a list of all members of this type, see ThemeSelector members.

Public Properties

 | Name | Description
Public Property | AvailableThemes | Gets or sets the collection of available themes.
Public Property | Enabled | Gets or sets a value indicating whether the theme selector is enabled.
Top

See Also

Reference

ThemeSelector Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


AvailableThemes Property

[image]
ActiveReports 19 .NET Edition
AvailableThemes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSelector Class : AvailableThemes Property

Glossary Item Box

Gets or sets the collection of available themes.

Syntax

Visual Basic (Declaration)
Public Property AvailableThemes As ColorTheme()
C#
public ColorTheme[] AvailableThemes {get; set;}

Property Value

An array of ColorTheme objects representing the themes available for selection.

Remarks

Predefined themes: "default", "activeReports", "activeReportsDark", "defaultDark", "darkOled", "highContrast", "highContrastDark".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSelector Class
ThemeSelector Members


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSelector Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the theme selector is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

A System.Boolean value. true if the theme selector is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSelector Class
ThemeSelector Members


ThemeSettings Class

[image]
ActiveReports 19 .NET Edition
ThemeSettings Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSettings Class

Glossary Item Box

Represents the UI theme settings for customizing the appearance.

Object Model

ThemeSettings Class

Syntax

Visual Basic (Declaration)
Public Class ThemeSettings
C#
public class ThemeSettings

Example

C# Copy Code
private static readonly ColorTheme _theme = new ColorTheme()
{
    Name = "testTheme",
    BackgroundPanels = "#fdf7f1",
    BackgroundMain = "#fdf7f1",
    Primary = "blue",
    Secondary = "green",
    Neutral = "grey",
    Error = "red",
    Warning = "yellow",
    FontFamily = "'Open Sans', 'Segoe UI', Tahoma, Geneva, Verdana, sans-serif",
    Type = ColorThemeType.light
};

private readonly ThemeSettings _themes = new ThemeSettings()
{
    InitialTheme = "testTheme",
    ThemeSelector = new ThemeSelector()
    {
        Enabled = true,
        AvailableThemes = new []{ColorThemes.ActiveReportsDark, _theme, "default"}
    }
};

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ThemeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSettings Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ThemeSettings Class Members

[image]
ActiveReports 19 .NET Edition
ThemeSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSettings Class

Glossary Item Box

The following tables list the members exposed by ThemeSettings.

Public Constructors

 | Name | Description
Public Constructor | ThemeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | InitialTheme | Gets or sets the initial theme to be applied.
Public Property | ThemeSelector | Gets or sets the theme selector used to manage available themes.
Top

See Also

Reference

ThemeSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ThemeSettings Constructor

[image]
ActiveReports 19 .NET Edition
ThemeSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSettings Class : ThemeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSettings Class
ThemeSettings Members


ThemeSettings Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ThemeSettings Class

Glossary Item Box

For a list of all members of this type, see ThemeSettings members.

Public Properties

 | Name | Description
Public Property | InitialTheme | Gets or sets the initial theme to be applied.
Public Property | ThemeSelector | Gets or sets the theme selector used to manage available themes.
Top

See Also

Reference

ThemeSettings Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


InitialTheme Property

[image]
ActiveReports 19 .NET Edition
InitialTheme Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSettings Class : InitialTheme Property

Glossary Item Box

Gets or sets the initial theme to be applied.

Syntax

Visual Basic (Declaration)
Public Property InitialTheme As String
C#
public string InitialTheme {get; set;}

Property Value

A System.String representing the name of the initial theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSettings Class
ThemeSettings Members


ThemeSelector Property

[image]
ActiveReports 19 .NET Edition
ThemeSelector Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ThemeSettings Class : ThemeSelector Property

Glossary Item Box

Gets or sets the theme selector used to manage available themes.

Syntax

Visual Basic (Declaration)
Public Property ThemeSelector As ThemeSelector
C#
public ThemeSelector ThemeSelector {get; set;}

Property Value

A ThemeSelector instance responsible for handling theme selection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeSettings Class
ThemeSettings Members


Toolbar Class

[image]
ActiveReports 19 .NET Edition
Toolbar Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Toolbar Class

Glossary Item Box

Represents the viewer's toolbar.

Object Model

Toolbar Class

Syntax

Visual Basic (Declaration)
Public Class Toolbar
C#
public class Toolbar

Remarks

The Toolbar class allows you to manipulate the toolbar elements for different layouts such as desktop, mobile, and fullscreen.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Toolbar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Toolbar Class Members

[image]
ActiveReports 19 .NET Edition
Toolbar Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Toolbar Class

Glossary Item Box

The following tables list the members exposed by Toolbar.

Public Properties

 | Name | Description
Public Property | Desktop | Gets the toolbar items configured for the desktop layout.
Public Property | Fullscreen | Gets the toolbar items configured for fullscreen mode.
Public Property | Mobile | Gets the toolbar items configured for the mobile layout.
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Toggle | Toggles the toolbar visibility.
Top

See Also

Reference

Toolbar Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Toolbar Class Methods

[image]
ActiveReports 19 .NET Edition
Toolbar Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Toolbar Class

Glossary Item Box

For a list of all members of this type, see Toolbar members.

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Toggle | Toggles the toolbar visibility.
Top

See Also

Reference

Toolbar Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Toolbar Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Class
Toolbar Members


Toggle Method

[image]
ActiveReports 19 .NET Edition
Toggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Toolbar Class : Toggle Method

show
Pass true to switch sidebar ON, and vise-versa.

Glossary Item Box

Toggles the toolbar visibility.

Syntax

Visual Basic (Declaration)
Public Function Toggle( _
   ByVal show As Boolean _
) As Task
C#
public Task Toggle(
   bool show
)

Parameters

show
Pass true to switch sidebar ON, and vise-versa.

Return Value

A System.Threading.Tasks.Task that represents the asynchronous operation of toggling the toolbar visibility.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Class
Toolbar Members


Toolbar Class Properties

[image]
ActiveReports 19 .NET Edition
Toolbar Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : Toolbar Class

Glossary Item Box

For a list of all members of this type, see Toolbar members.

Public Properties

 | Name | Description
Public Property | Desktop | Gets the toolbar items configured for the desktop layout.
Public Property | Fullscreen | Gets the toolbar items configured for fullscreen mode.
Public Property | Mobile | Gets the toolbar items configured for the mobile layout.
Top

See Also

Reference

Toolbar Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Desktop Property

[image]
ActiveReports 19 .NET Edition
Desktop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Toolbar Class : Desktop Property

Glossary Item Box

Gets the toolbar items configured for the desktop layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Desktop As ToolbarItems
C#
public ToolbarItems Desktop {get;}

Property Value

The ToolbarItems collection of toolbar items for the desktop layout.

Remarks

The Desktop property provides access to the toolbar items configured for the desktop layout, allowing customization of the toolbar elements for desktop usage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Class
Toolbar Members


Fullscreen Property

[image]
ActiveReports 19 .NET Edition
Fullscreen Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Toolbar Class : Fullscreen Property

Glossary Item Box

Gets the toolbar items configured for fullscreen mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fullscreen As ToolbarItems
C#
public ToolbarItems Fullscreen {get;}

Property Value

The ToolbarItems collection of toolbar items for the fullscreen layout.

Remarks

The Fullscreen property provides access to the toolbar items configured for fullscreen mode, allowing customization of the toolbar elements for fullscreen usage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Class
Toolbar Members


Mobile Property

[image]
ActiveReports 19 .NET Edition
Mobile Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > Toolbar Class : Mobile Property

Glossary Item Box

Gets the toolbar items configured for the mobile layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mobile As ToolbarItems
C#
public ToolbarItems Mobile {get;}

Property Value

The ToolbarItems collection of toolbar items for the mobile layout.

Remarks

The Mobile property provides access to the toolbar items configured for the mobile layout, allowing customization of the toolbar elements for mobile usage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbar Class
Toolbar Members


ToolbarItem Class

[image]
ActiveReports 19 .NET Edition
ToolbarItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItem Class

Glossary Item Box

Represents a toolbar item in a viewer's toolbar.

Object Model

ToolbarItem Class

Syntax

Visual Basic (Declaration)
Public Class ToolbarItem
C#
public class ToolbarItem

Remarks

The ToolbarItem class allows you to define and control individual items within a viewer's toolbar. Each toolbar item can have its own unique identifier, state, display text, icon, and actions.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ToolbarItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ToolbarItem Class Members

[image]
ActiveReports 19 .NET Edition
ToolbarItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItem Class

Glossary Item Box

The following tables list the members exposed by ToolbarItem.

Public Constructors

 | Name | Description
Public Constructor | ToolbarItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action handler for the toolbar item. This handler is invoked when the item is activated.
Public Property | Checked | Gets or sets a value indicating whether the toolbar item is checked.
Public Property | Enabled | Gets or sets a value indicating whether the toolbar item is enabled.
Public Property | IconCssClass | Gets or sets the CSS class for the icon of the toolbar item.
Public Property | Key | Gets or sets the unique identifier for the toolbar item.
Public Property | OnUpdate | Gets or sets the function that is called to update the state of the toolbar item.
Public Property | Text | Gets or sets the display text for the toolbar item.
Public Property | Title | Gets or sets the tooltip text for the toolbar item.
Top

See Also

Reference

ToolbarItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ToolbarItem Constructor

[image]
ActiveReports 19 .NET Edition
ToolbarItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : ToolbarItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolbarItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


ToolbarItem Class Properties

[image]
ActiveReports 19 .NET Edition
ToolbarItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItem Class

Glossary Item Box

For a list of all members of this type, see ToolbarItem members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action handler for the toolbar item. This handler is invoked when the item is activated.
Public Property | Checked | Gets or sets a value indicating whether the toolbar item is checked.
Public Property | Enabled | Gets or sets a value indicating whether the toolbar item is enabled.
Public Property | IconCssClass | Gets or sets the CSS class for the icon of the toolbar item.
Public Property | Key | Gets or sets the unique identifier for the toolbar item.
Public Property | OnUpdate | Gets or sets the function that is called to update the state of the toolbar item.
Public Property | Text | Gets or sets the display text for the toolbar item.
Public Property | Title | Gets or sets the tooltip text for the toolbar item.
Top

See Also

Reference

ToolbarItem Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Action Property

Glossary Item Box

Gets or sets the action handler for the toolbar item. This handler is invoked when the item is activated.

Syntax

Visual Basic (Declaration)
Public Property Action As Action
C#
public Action Action {get; set;}

Remarks

The Action property allows you to define the action that should be executed when the toolbar item is clicked or activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Checked Property

Glossary Item Box

Gets or sets a value indicating whether the toolbar item is checked.

Syntax

Visual Basic (Declaration)
Public Property Checked As Nullable(Of Boolean)
C#
public Nullable<bool> Checked {get; set;}

Property Value

A nullable System.Boolean value. true if checked; otherwise, false.

Remarks

The Checked property is useful for items like checkboxes or toggle buttons within the toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the toolbar item is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Nullable(Of Boolean)
C#
public Nullable<bool> Enabled {get; set;}

Property Value

A nullable System.Boolean value. true if the item is enabled; otherwise, false.

Remarks

The Enabled property determines whether the toolbar item is interactive or disabled.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


IconCssClass Property

[image]
ActiveReports 19 .NET Edition
IconCssClass Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : IconCssClass Property

Glossary Item Box

Gets or sets the CSS class for the icon of the toolbar item.

Syntax

Visual Basic (Declaration)
Public Property IconCssClass As String
C#
public string IconCssClass {get; set;}

Property Value

The CSS class as a System.String used for the icon representation.

Remarks

This property allows you to specify a CSS class for the toolbar item's icon, enabling custom styling and use of icon libraries like FontAwesome.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Key Property

Glossary Item Box

Gets or sets the unique identifier for the toolbar item.

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Property Value

The unique key as a System.String.

Remarks

This property is used to identify the toolbar item uniquely within the toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


OnUpdate Property

[image]
ActiveReports 19 .NET Edition
OnUpdate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : OnUpdate Property

Glossary Item Box

Gets or sets the function that is called to update the state of the toolbar item.

Syntax

Visual Basic (Declaration)
Public Property OnUpdate As Action
C#
public Action OnUpdate {get; set;}

Remarks

The OnUpdate property allows you to specify a function that updates the state of the toolbar item, typically used for dynamic state changes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Text Property

Glossary Item Box

Gets or sets the display text for the toolbar item.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The display text as a System.String.

Remarks

The Text property defines the text that is displayed on the toolbar item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItem Class : Title Property

Glossary Item Box

Gets or sets the tooltip text for the toolbar item.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Property Value

The tooltip text as a System.String.

Remarks

The Title property sets the text that appears as a tooltip when the user hovers over the toolbar item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItem Class
ToolbarItem Members


ToolbarItems Class

[image]
ActiveReports 19 .NET Edition
ToolbarItems Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItems Class

Glossary Item Box

Represents a collection of toolbar items in the viewer's toolbar.

Object Model

ToolbarItems Class

Syntax

Visual Basic (Declaration)
Public Class ToolbarItems
C#
public class ToolbarItems

Remarks

The ToolbarItems class provides methods to add, update, and remove items from the toolbar, as well as manage the order and visibility of these items.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.ToolbarItems

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Members
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ToolbarItems Class Members

[image]
ActiveReports 19 .NET Edition
ToolbarItems Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItems Class

Glossary Item Box

The following tables list the members exposed by ToolbarItems.

Public Methods

 | Name | Description
Public Method | AddItem | Adds a new item to the toolbar.
Public Method | Dispose |
Public Method | GetKeys | Returns identifiers of default and added buttons in the order in which they will be displayed in the toolbar.
Public Method | Layout | Sets the keys of the visible toolbar items and their order.
Public Method | RemoveItem | Removes existing item from the toolbar.
Public Method | UpdateItem | Updates a previously added toolbar item.
Top

See Also

Reference

ToolbarItems Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


ToolbarItems Class Methods

[image]
ActiveReports 19 .NET Edition
ToolbarItems Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ToolbarItems Class

Glossary Item Box

For a list of all members of this type, see ToolbarItems members.

Public Methods

 | Name | Description
Public Method | AddItem | Adds a new item to the toolbar.
Public Method | Dispose |
Public Method | GetKeys | Returns identifiers of default and added buttons in the order in which they will be displayed in the toolbar.
Public Method | Layout | Sets the keys of the visible toolbar items and their order.
Public Method | RemoveItem | Removes existing item from the toolbar.
Public Method | UpdateItem | Updates a previously added toolbar item.
Top

See Also

Reference

ToolbarItems Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


AddItem Method

[image]
ActiveReports 19 .NET Edition
AddItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : AddItem Method

item
An item to be added.

Glossary Item Box

Adds a new item to the toolbar.

Syntax

Visual Basic (Declaration)
Public Function AddItem( _
   ByVal item As ToolbarItem _
) As Task
C#
public Task AddItem(
   ToolbarItem item
)

Parameters

item
An item to be added.

Return Value

A task that represents the asynchronous operation of adding an item to the toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


GetKeys Method

[image]
ActiveReports 19 .NET Edition
GetKeys Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : GetKeys Method

Glossary Item Box

Returns identifiers of default and added buttons in the order in which they will be displayed in the toolbar.

Syntax

Visual Basic (Declaration)
Public Function GetKeys() As ValueTask(Of String())
C#
public ValueTask<string[]> GetKeys()

Return Value

A value task that returns an array of strings representing the keys of all toolbar items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


Layout Method

[image]
ActiveReports 19 .NET Edition
Layout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : Layout Method

keys
An array of strings representing the keys of the toolbar items. The order in this array determines the display order of the items in the toolbar. Only the items included in this array will be visible after this operation.

Glossary Item Box

Sets the keys of the visible toolbar items and their order.

Syntax

Visual Basic (Declaration)
Public Sub Layout( _
   ByVal keys() As String _
)
C#
public void Layout(
   string[] keys
)

Parameters

keys
An array of strings representing the keys of the toolbar items. The order in this array determines the display order of the items in the toolbar. Only the items included in this array will be visible after this operation.

Return Value

A task representing the asynchronous operation of updating the toolbar layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


RemoveItem Method

[image]
ActiveReports 19 .NET Edition
RemoveItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : RemoveItem Method

key
The key of the toolbar item to be removed. This key should match the one specified when the item was added.

Glossary Item Box

Removes existing item from the toolbar.

Syntax

Visual Basic (Declaration)
Public Function RemoveItem( _
   ByVal key As String _
) As Task
C#
public Task RemoveItem(
   string key
)

Parameters

key
The key of the toolbar item to be removed. This key should match the one specified when the item was added.

Return Value

A task that represents the asynchronous operation of removing the toolbar item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


UpdateItem Method

[image]
ActiveReports 19 .NET Edition
UpdateItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ToolbarItems Class : UpdateItem Method

key
The key of the toolbar item to update. This key should match the one used when the item was added.
itemUpdate
New settings for the toolbar item, which can include changes to its action, icon, text, and other properties.

Glossary Item Box

Updates a previously added toolbar item.

Syntax

Visual Basic (Declaration)
Public Function UpdateItem( _
   ByVal key As String, _
   ByVal itemUpdate As ToolbarItem _
) As Task
C#
public Task UpdateItem(
   string key,
   ToolbarItem itemUpdate
)

Parameters

key
The key of the toolbar item to update. This key should match the one used when the item was added.
itemUpdate
New settings for the toolbar item, which can include changes to its action, icon, text, and other properties.

Return Value

A task that represents the asynchronous operation of updating the toolbar item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolbarItems Class
ToolbarItems Members


ColorThemeType Enumeration

[image]
ActiveReports 19 .NET Edition
ColorThemeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ColorThemeType Enumeration

Glossary Item Box

Specifies the type of the color theme.

Syntax

Visual Basic (Declaration)
Public Enum ColorThemeType
   Inherits System.Enum
C#
public enum ColorThemeType : System.Enum

Members

Member | Description
dark | Specifies a dark color theme.
light | Specifies a light color theme.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ErrorSeverity Enumeration

[image]
ActiveReports 19 .NET Edition
ErrorSeverity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ErrorSeverity Enumeration

Glossary Item Box

Describes the error severity levels.

Syntax

Visual Basic (Declaration)
Public Enum ErrorSeverity
   Inherits System.Enum
C#
public enum ErrorSeverity : System.Enum

Members

Member | Description
debug | Indicates a debug message.
error | Indicates an error.
info | Indicates an informational message.
warn | Indicates a warning.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ErrorSeverity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ExportTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ExportTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ExportTypes Enumeration

Glossary Item Box

Defines the export types.

Syntax

Visual Basic (Declaration)
Public Enum ExportTypes
   Inherits System.Enum
C#
public enum ExportTypes : System.Enum

Members

Member | Description
Csv | CSV format.
CsvData | CSV data format.
Doc | Word format (DOC).
Docx | Word format (DOCX).
Json | JSON format.
Mht | MHT format.
Pdf | PDF format.
Rtf | Rich Text Format (RTF).
TextPrint | Text Print format.
Tiff | TIFF format.
Txt | Text format.
Xls | Excel format (XLS).
Xlsx | Excel format (XLSX).
XlsxData | Excel data format.
Xml | XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ExportTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


PanelsLocation Enumeration

[image]
ActiveReports 19 .NET Edition
PanelsLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : PanelsLocation Enumeration

Glossary Item Box

Defines the position of panels (search, parameters etc.).

Syntax

Visual Basic (Declaration)
Public Enum PanelsLocation
   Inherits System.Enum
C#
public enum PanelsLocation : System.Enum

Members

Member | Description
sidebar | Positions the panels in the sidebar.
toolbar | Positions the panels in the toolbar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.PanelsLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterPanelLocation Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterPanelLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterPanelLocation Enumeration

Glossary Item Box

Defines the parameters panel location settings.

Syntax

Visual Basic (Declaration)
Public Enum ParameterPanelLocation
   Inherits System.Enum
C#
public enum ParameterPanelLocation : System.Enum

Members

Member | Description
Default | Uses the default location for the parameters panel.
Top | Positions the parameters panel at the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ParameterPanelLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ParameterPanelOpen Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterPanelOpen Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ParameterPanelOpen Enumeration

Glossary Item Box

Defines the parameters panel opening behavior.

Syntax

Visual Basic (Declaration)
Public Enum ParameterPanelOpen
   Inherits System.Enum
C#
public enum ParameterPanelOpen : System.Enum

Members

Member | Description
Always | Always keeps the parameters panel open.
Auto | Automatically opens the parameters panel.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ParameterPanelOpen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


RenderFormat Enumeration

[image]
ActiveReports 19 .NET Edition
RenderFormat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : RenderFormat Enumeration

Glossary Item Box

Specifies the render format for the report.

Syntax

Visual Basic (Declaration)
Public Enum RenderFormat
   Inherits System.Enum
C#
public enum RenderFormat : System.Enum

Members

Member | Description
auto | Automatically selects the render format.
html | Renders the report in HTML format.
svg | Renders the report in SVG format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.RenderFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


RenderMode Enumeration

[image]
ActiveReports 19 .NET Edition
RenderMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : RenderMode Enumeration

Glossary Item Box

Defines the report render modes.

Syntax

Visual Basic (Declaration)
Public Enum RenderMode
   Inherits System.Enum
C#
public enum RenderMode : System.Enum

Members

Member | Description
Galley | Renders the report in a galley mode.
Paginated | Renders the report in a paginated mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.RenderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ReportType Enumeration

[image]
ActiveReports 19 .NET Edition
ReportType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ReportType Enumeration

Glossary Item Box

Defines the report types.

Syntax

Visual Basic (Declaration)
Public Enum ReportType
   Inherits System.Enum
C#
public enum ReportType : System.Enum

Members

Member | Description
Page | Page Report.
Rdl | RDL Report.
Section | Section Report.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ReportType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


SizeType Enumeration

[image]
ActiveReports 19 .NET Edition
SizeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : SizeType Enumeration

Glossary Item Box

Defines the size types.

Syntax

Visual Basic (Declaration)
Public Enum SizeType
   Inherits System.Enum
C#
public enum SizeType : System.Enum

Members

Member | Description
Default | Default size type.
FitToPage | Fits the content to the size of the page.
FitToWidth | Fits the content to the width of the container.
Stretch | Stretches the content to fill the container.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.SizeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ViewMode Enumeration

[image]
ActiveReports 19 .NET Edition
ViewMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ViewMode Enumeration

Glossary Item Box

Defines the different paging modes.

Syntax

Visual Basic (Declaration)
Public Enum ViewMode
   Inherits System.Enum
C#
public enum ViewMode : System.Enum

Members

Member | Description
Continuous | Displays pages in a continuous scroll.
Page | Displays pages in a traditional paginated format.
Single | Displays one page at a time.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


ZoomMode Enumeration

[image]
ActiveReports 19 .NET Edition
ZoomMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : ZoomMode Enumeration

Glossary Item Box

Defines the different zoom modes.

Syntax

Visual Basic (Declaration)
Public Enum ZoomMode
   Inherits System.Enum
C#
public enum ZoomMode : System.Enum

Members

Member | Description
FitToPage | Fits the content to the entire page.
FitToWidth | Fits the content to the width of the page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Blazor.Viewer.ZoomMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Blazor.Viewer Namespace


AxesCollection Class

[image]
ActiveReports 19 .NET Edition
AxesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

Glossary Item Box

Represents a collection of axis.

Object Model

AxesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AxesCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class AxesCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.AxesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Members
GrapeCity.ActiveReports.Chart Namespace


AxesCollection Class Members

[image]
ActiveReports 19 .NET Edition
AxesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

Glossary Item Box

The following tables list the members exposed by AxesCollection.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified axis in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an axis to the collection.
Public Method | AddRange | Adds a set of axes to the collection.
Public Method | Clone | Creates a clone of the axes collection.
Public Method | Contains | Determines whether the collection contains the specified AxisBase.
Public Method | Dispose | Releases from memory resources associated with AxisCollection object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified axis into the collection at the specified index.
Public Method | Remove | Removes the specified axis from the collection.
Public Method | ToArray | Copies the elements of the axis collection to a new array.
Top

See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


AxesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
AxesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

Glossary Item Box

For a list of all members of this type, see AxesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an axis to the collection.
Public Method | AddRange | Adds a set of axes to the collection.
Public Method | Clone | Creates a clone of the axes collection.
Public Method | Contains | Determines whether the collection contains the specified AxisBase.
Public Method | Dispose | Releases from memory resources associated with AxisCollection object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified axis into the collection at the specified index.
Public Method | Remove | Removes the specified axis from the collection.
Public Method | ToArray | Copies the elements of the axis collection to a new array.
Top

See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Add Method

value
The axis to add.

Glossary Item Box

Adds an axis to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As AxisBase _
) As Integer
C#
public int Add(
   AxisBase value
)

Parameters

value
The axis to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : AddRange Method

value
The axes to add to the collection.

Glossary Item Box

Adds a set of axes to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As AxisBase _
)
C#
public void AddRange(
   AxisBase[] value
)

Parameters

value
The axes to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Clone Method

Glossary Item Box

Creates a clone of the axes collection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Contains Method

value

The AxisBase to find in the collection.

Glossary Item Box

Determines whether the collection contains the specified AxisBase.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As AxisBase _
) As Boolean
C#
public bool Contains(
   AxisBase value
)

Parameters

value

The AxisBase to find in the collection.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise, False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Dispose Method

Glossary Item Box

Releases from memory resources associated with AxisCollection object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Return Value

Releases resources associated with this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : IndexOf Method

value

The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As AxisBase _
) As Integer
C#
public int IndexOf(
   AxisBase value
)

Parameters

value

The object to locate in the collection.

Return Value

Returns the index of the first occurrence of a value in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Insert Method

index
Index of the axis.
value
The axis to be inserted

Glossary Item Box

Inserts the specified axis into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As AxisBase _
)
C#
public void Insert(
   int index,
   AxisBase value
)

Parameters

index
Index of the axis.
value
The axis to be inserted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Remove Method

value
The axis to remove.

Glossary Item Box

Removes the specified axis from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As AxisBase _
)
C#
public void Remove(
   AxisBase value
)

Parameters

value
The axis to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : ToArray Method

Glossary Item Box

Copies the elements of the axis collection to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As AxisBase()
C#
public AxisBase[] ToArray()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


AxesCollection Class Properties

[image]
ActiveReports 19 .NET Edition
AxesCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

Glossary Item Box

For a list of all members of this type, see AxesCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified axis in the collection.
Top

See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Item Property

Glossary Item Box

Gets or sets the specified axis in the collection.

Overload List

Overload | Description
Item(Int32) | Gets or sets the axis at the specified index.
Item(String) | Gets the index of the axis with the specified name in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class > Item Property : Item(Int32) Property

index

The index of the axis.

Glossary Item Box

Gets or sets the axis at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As AxisBase
C#
public AxisBase Item(
   int index
) {get; set;}

Parameters

index

The index of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class > Item Property : Item(String) Property

axisName
The name of the axis.

Glossary Item Box

Gets the index of the axis with the specified name in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal axisName As String _
) As AxisBase
C#
public AxisBase Item(
   string axisName
) {get;}

Parameters

axisName
The name of the axis.

Property Value

AxisBase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members
Overload List


Axis Class

[image]
ActiveReports 19 .NET Edition
Axis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

Glossary Item Box

Represents the axis of the chart.

Object Model

Axis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Axis
   Inherits AxisBase
C#
public sealed class Axis : AxisBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Members
GrapeCity.ActiveReports.Chart Namespace


Axis Class Members

[image]
ActiveReports 19 .NET Edition
Axis Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

Glossary Item Box

The following tables list the members exposed by Axis.

Public Constructors

 | Name | Description
Public Constructor | Axis Constructor | Creates default (numerical) axis
Top

Public Properties

 | Name | Description
Public Property | Name | Overridden. Gets or sets the name of the axis as string.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Axis Constructor()

[image]
ActiveReports 19 .NET Edition
Axis Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class > Axis Constructor : Axis Constructor()

Glossary Item Box

Creates default (numerical) axis

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Axis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


Axis Class Methods

[image]
ActiveReports 19 .NET Edition
Axis Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

Glossary Item Box

For a list of all members of this type, see Axis members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Clone Method

Glossary Item Box

Creates a clone of the axis.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Axis Class Properties

[image]
ActiveReports 19 .NET Edition
Axis Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

Glossary Item Box

For a list of all members of this type, see Axis members.

Public Properties

 | Name | Description
Public Property | Name | Overridden. Gets or sets the name of the axis as string.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Name Property

Glossary Item Box

Gets or sets the name of the axis as string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Name As String
C#
public override string Name {get; set;}

Property Value

The name.

Exceptions

Exception | Description
System.InvalidOperationException | Can't change name for standard axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


AxisBase Class

[image]
ActiveReports 19 .NET Edition
AxisBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class

Glossary Item Box

Represents the set of properties of an axis.

Object Model

AxisBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class AxisBase
   Inherits MouseEnabledComponent
C#
public abstract class AxisBase : MouseEnabledComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis
GrapeCity.ActiveReports.Chart.CustomAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Members
GrapeCity.ActiveReports.Chart Namespace


AxisBase Class Members

[image]
ActiveReports 19 .NET Edition
AxisBase Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class

Glossary Item Box

The following tables list the members exposed by AxisBase.

Public Properties

 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis.
Public Property | AxisType | Gets or sets the axis type.
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis.
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis.
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels.
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes.
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis.
Public Property | LabelsInside | Gets or sets the position of labels against the axis line.
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis.
Public Property | Line | Gets or sets the line used to draw the axis.
Public Property | MajorTick | Gets or sets the major tick of the axis.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis.
Public Property | Position | Gets or sets the position along the adjacent axis.
Public Property | Scale | Gets or sets the scale value used to draw labels.
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis.
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered.
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis.
Public Property | Title | Gets or sets the text string for the title of the axis.
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis is visible.
Top

See Also

Reference

AxisBase Class
GrapeCity.ActiveReports.Chart Namespace


AxisBase Class Properties

[image]
ActiveReports 19 .NET Edition
AxisBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class

Glossary Item Box

For a list of all members of this type, see AxisBase members.

Public Properties

 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis.
Public Property | AxisType | Gets or sets the axis type.
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis.
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis.
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels.
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes.
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis.
Public Property | LabelsInside | Gets or sets the position of labels against the axis line.
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis.
Public Property | Line | Gets or sets the line used to draw the axis.
Public Property | MajorTick | Gets or sets the major tick of the axis.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis.
Public Property | Position | Gets or sets the position along the adjacent axis.
Public Property | Scale | Gets or sets the scale value used to draw labels.
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis.
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered.
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis.
Public Property | Title | Gets or sets the text string for the title of the axis.
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis is visible.
Top

See Also

Reference

AxisBase Class
GrapeCity.ActiveReports.Chart Namespace


Arrow Property

[image]
ActiveReports 19 .NET Edition
Arrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Arrow Property

Glossary Item Box

Gets or sets the arrow type on the axis.

Syntax

Visual Basic (Declaration)
Public Property Arrow As ArrowType
C#
public ArrowType Arrow {get; set;}

Property Value

A valid ArrowType enumeration value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Arrow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


AxisType Property

[image]
ActiveReports 19 .NET Edition
AxisType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : AxisType Property

Glossary Item Box

Gets or sets the axis type.

Syntax

Visual Basic (Declaration)
Public Property AxisType As AxisType
C#
public AxisType AxisType {get; set;}

Property Value

A valid AxisType enumeration value, either numerical or categorical.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


DisplayScale Property

[image]
ActiveReports 19 .NET Edition
DisplayScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : DisplayScale Property

Glossary Item Box

Gets or sets a value indicating whether to display the scale value on the title of the axis.

Syntax

Visual Basic (Declaration)
Public Property DisplayScale As Boolean
C#
public bool DisplayScale {get; set;}

Property Value

Boolean. True if the scale value on the title of the axis is displayed; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelFont Property

[image]
ActiveReports 19 .NET Edition
LabelFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelFont Property

Glossary Item Box

Gets or sets the font info used to draw the labels of the axis.

Syntax

Visual Basic (Declaration)
Public Property LabelFont As FontInfo
C#
public FontInfo LabelFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelFormat Property

[image]
ActiveReports 19 .NET Edition
LabelFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelFormat Property

Glossary Item Box

Gets or sets the format used to output the values of the labels.

Syntax

Visual Basic (Declaration)
Public Property LabelFormat As String
C#
public string LabelFormat {get; set;}

Remarks

The ActiveReports chart control uses standard Visual Studio .NET formatting syntax. The format is {Tag : Format}. For example, {Value:C} formats the text as currency. {Value:D} formats the text as a date.

Example

Tag（variable） | Explanation | Example
Index | Index of points. |
Value | Data value. Same as Value0 of the renderer of category base, Value2 of BubbleXY chart etc. | {Value}
Value# [1] | Variable that represents the data set value(zero base). | {Value0}
Total | The total of the data set（the total sum of all the points of this data set）. |
Pct | Corresponds to Value/Total. |
Pct[#] | Corresponds to Value#/Total. |
Xvalue | X value of point. X value of the XY chart. Same as the point instance of category base chart. |
PTotal | Sum Total of all the data set values of this point, and on this layer. |
PPct | Corresponds to Value/PointTotal. |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Labels Property

[image]
ActiveReports 19 .NET Edition
Labels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Labels Property

Glossary Item Box

Gets the contents of the labels collection, used for categorical axes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Labels As LabelsCollection
C#
public LabelsCollection Labels {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelsAtBottom Property

[image]
ActiveReports 19 .NET Edition
LabelsAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsAtBottom Property

Glossary Item Box

Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.

Syntax

Visual Basic (Declaration)
Public Property LabelsAtBottom As Boolean
C#
public bool LabelsAtBottom {get; set;}

Property Value

true if [labels at bottom]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelsGap Property

[image]
ActiveReports 19 .NET Edition
LabelsGap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsGap Property

Glossary Item Box

Gets or sets a value indicating how many labels to skip on the axis.

Syntax

Visual Basic (Declaration)
Public Property LabelsGap As Integer
C#
public int LabelsGap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelsInside Property

[image]
ActiveReports 19 .NET Edition
LabelsInside Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsInside Property

Glossary Item Box

Gets or sets the position of labels against the axis line.

Syntax

Visual Basic (Declaration)
Public Property LabelsInside As Boolean
C#
public bool LabelsInside {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


LabelsVisible Property

[image]
ActiveReports 19 .NET Edition
LabelsVisible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsVisible Property

Glossary Item Box

Gets or sets a value indicating whether axis labels will be drawn on the axis.

Syntax

Visual Basic (Declaration)
Public Property LabelsVisible As Boolean
C#
public bool LabelsVisible {get; set;}

Property Value

Boolean. True if axis labels will be drawn on the axis; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Line Property

Glossary Item Box

Gets or sets the line used to draw the axis.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


MajorTick Property

[image]
ActiveReports 19 .NET Edition
MajorTick Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : MajorTick Property

Glossary Item Box

Gets or sets the major tick of the axis.

Syntax

Visual Basic (Declaration)
Public Property MajorTick As Tick
C#
public Tick MajorTick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Max Property

[image]
ActiveReports 19 .NET Edition
Max Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Max Property

Glossary Item Box

Gets or sets the maximum value for the axis.

Syntax

Visual Basic (Declaration)
Public Property Max As Double
C#
public double Max {get; set;}

Remarks

The Max and Min properties do not work with a DateTime axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Min Property

[image]
ActiveReports 19 .NET Edition
Min Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Min Property

Glossary Item Box

Gets or sets the minimum value for the axis.

Syntax

Visual Basic (Declaration)
Public Property Min As Double
C#
public double Min {get; set;}

Remarks

The Max and Min properties do not work with a DateTime axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


MinorTick Property

[image]
ActiveReports 19 .NET Edition
MinorTick Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : MinorTick Property

Glossary Item Box

Gets or sets the minor tick of the axis.

Syntax

Visual Basic (Declaration)
Public Property MinorTick As Tick
C#
public Tick MinorTick {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Position Property

Glossary Item Box

Gets or sets the position along the adjacent axis.

Syntax

Visual Basic (Declaration)
Public Property Position As Double
C#
public double Position {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Scale Property

[image]
ActiveReports 19 .NET Edition
Scale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Scale Property

Glossary Item Box

Gets or sets the scale value used to draw labels.

Syntax

Visual Basic (Declaration)
Public Property Scale As Double
C#
public double Scale {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


SmartLabels Property

[image]
ActiveReports 19 .NET Edition
SmartLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : SmartLabels Property

Glossary Item Box

Gets or sets a value indicating whether smart labels are enabled on the axis.

Syntax

Visual Basic (Declaration)
Public Property SmartLabels As Boolean
C#
public bool SmartLabels {get; set;}

Property Value

Boolean. True if smart labels are enabled on the axis; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


StaggerLabels Property

[image]
ActiveReports 19 .NET Edition
StaggerLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : StaggerLabels Property

Glossary Item Box

Gets or sets a value indicating whether labels on the axis are staggered.

Syntax

Visual Basic (Declaration)
Public Property StaggerLabels As Boolean
C#
public bool StaggerLabels {get; set;}

Property Value

Boolean. True if labels on the axis are staggered; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


TickOffset Property

[image]
ActiveReports 19 .NET Edition
TickOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : TickOffset Property

Glossary Item Box

Gets or sets the offset of the first tick from the Min value of the axis.

Syntax

Visual Basic (Declaration)
Public Property TickOffset As Double
C#
public double TickOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Title Property

Glossary Item Box

Gets or sets the text string for the title of the axis.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


TitleFont Property

[image]
ActiveReports 19 .NET Edition
TitleFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : TitleFont Property

Glossary Item Box

Gets or sets the font information used to draw the title of the axis.

Syntax

Visual Basic (Declaration)
Public Property TitleFont As FontInfo
C#
public FontInfo TitleFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the axis is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisBase Class
AxisBase Members


AxisScroll Class

[image]
ActiveReports 19 .NET Edition
AxisScroll Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

Glossary Item Box

Represents the scroll bar on an axis.

Object Model

AxisScroll Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AxisScroll
   Inherits ItemComponent
C#
public sealed class AxisScroll : ItemComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisScroll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Members
GrapeCity.ActiveReports.Chart Namespace


AxisScroll Class Members

[image]
ActiveReports 19 .NET Edition
AxisScroll Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

Glossary Item Box

The following tables list the members exposed by AxisScroll.

Public Constructors

 | Name | Description
Public Constructor | AxisScroll Constructor | Initializes a new instance of the AxisScroll class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the backcolor of the scroll bar.
Public Property | ButtonColor | Gets or sets the button color of the scroll bar.
Public Property | Enabled | Gets or sets a value indicating whether the axis scroll bar is enabled.
Public Property | Name | Gets or sets the name of the axis scroll bar as string.
Public Property | OutlineColor | Gets or sets the outline color of the axis scroll bar.
Public Property | ScrollLength | Gets or sets the scroll length of the axis scroll bar.
Public Property | ScrollPosition | Gets or sets the scroll position of the axis scroll bar.
Public Property | ScrollStepSize | Gets or sets the scroll step size of the axis scroll bar.
Public Property | Visible | Gets or sets a value indicating whether the axis scroll bar is visible.
Public Property | Width | Gets or sets the width of the axis scroll bar.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis scroll bar.
Top

See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


AxisScroll Constructor()

[image]
ActiveReports 19 .NET Edition
AxisScroll Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class > AxisScroll Constructor : AxisScroll Constructor()

Glossary Item Box

Initializes a new instance of the AxisScroll class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AxisScroll()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members
Overload List


AxisScroll Class Methods

[image]
ActiveReports 19 .NET Edition
AxisScroll Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

Glossary Item Box

For a list of all members of this type, see AxisScroll members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis scroll bar.
Top

See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Clone Method

Glossary Item Box

Creates a clone of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


AxisScroll Class Properties

[image]
ActiveReports 19 .NET Edition
AxisScroll Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

Glossary Item Box

For a list of all members of this type, see AxisScroll members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the backcolor of the scroll bar.
Public Property | ButtonColor | Gets or sets the button color of the scroll bar.
Public Property | Enabled | Gets or sets a value indicating whether the axis scroll bar is enabled.
Public Property | Name | Gets or sets the name of the axis scroll bar as string.
Public Property | OutlineColor | Gets or sets the outline color of the axis scroll bar.
Public Property | ScrollLength | Gets or sets the scroll length of the axis scroll bar.
Public Property | ScrollPosition | Gets or sets the scroll position of the axis scroll bar.
Public Property | ScrollStepSize | Gets or sets the scroll step size of the axis scroll bar.
Public Property | Visible | Gets or sets a value indicating whether the axis scroll bar is visible.
Public Property | Width | Gets or sets the width of the axis scroll bar.
Top

See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : BackColor Property

Glossary Item Box

Gets or sets the backcolor of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


ButtonColor Property

[image]
ActiveReports 19 .NET Edition
ButtonColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ButtonColor Property

Glossary Item Box

Gets or sets the button color of the scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ButtonColor As Color
C#
public Color ButtonColor {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the axis scroll bar is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

Boolean. True if the axis scroll bar is enabled; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Name Property

Glossary Item Box

Gets or sets the name of the axis scroll bar as string.

Syntax

Visual Basic (Declaration)
Public Shadows Property Name As String
C#
public new string Name {get; set;}

Property Value

The name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


OutlineColor Property

[image]
ActiveReports 19 .NET Edition
OutlineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : OutlineColor Property

Glossary Item Box

Gets or sets the outline color of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Property OutlineColor As Color
C#
public Color OutlineColor {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollLength Property

[image]
ActiveReports 19 .NET Edition
ScrollLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollLength Property

Glossary Item Box

Gets or sets the scroll length of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ScrollLength As Double
C#
public double ScrollLength {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollPosition Property

[image]
ActiveReports 19 .NET Edition
ScrollPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollPosition Property

Glossary Item Box

Gets or sets the scroll position of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ScrollPosition As Double
C#
public double ScrollPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollStepSize Property

[image]
ActiveReports 19 .NET Edition
ScrollStepSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollStepSize Property

Glossary Item Box

Gets or sets the scroll step size of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Property ScrollStepSize As Double
C#
public double ScrollStepSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the axis scroll bar is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

Boolean. True if the axis scroll bar is visible; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Width Property

Glossary Item Box

Gets or sets the width of the axis scroll bar.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


BackdropItem Class

[image]
ActiveReports 19 .NET Edition
BackdropItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

Glossary Item Box

Represents the backdrop that acts as a separate item and handles mouse events.

Object Model

BackdropItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackdropItem
   Inherits GrapeCity.ActiveReports.Chart.Graphics.Backdrop
C#
public sealed class BackdropItem : GrapeCity.ActiveReports.Chart.Graphics.Backdrop

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Members
GrapeCity.ActiveReports.Chart Namespace


BackdropItem Class Members

[image]
ActiveReports 19 .NET Edition
BackdropItem Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

Glossary Item Box

The following tables list the members exposed by BackdropItem.

Public Constructors

 | Name | Description
Public Constructor | BackdropItem Constructor | Overloaded. Initializes a new instance of the BackdropItem class.
Top

Public Properties

 | Name | Description
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Compares the BackdropItem object to another System.Object to see if they are equal.
Public Method | OnMouseDown | Raises the MouseDown event.
Public Method | OnMouseEnter | Raises the MouseEnter event.
Public Method | OnMouseHover | Raises the MouseHover event.
Public Method | OnMouseLeave | Raises the MouseLeave event.
Public Method | OnMouseMove | Raises the MouseMove event.
Public Method | OnMouseUp | Raises the MouseUp event.
Public Method | OnMouseWheel | Raises the MouseWheel event.
Top

Public Events

 | Name | Description
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event | MouseEnter | Occurs when the mouse pointer enters the control.
Public Event | MouseHover | Occurs when the mouse pointer hovers over the control.
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control.
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control.
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus.
Top

See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


BackdropItem Constructor

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : BackdropItem Constructor

Glossary Item Box

Initializes a new instance of the BackdropItem class.

Overload List

Overload | Description
BackdropItem Constructor() | Initializes a new instance of the BackdropItem class.
BackdropItem Constructor(AntiAliasMode) | Initializes a new instance of the BackdropItem class with the AntiAliasMode specified.
BackdropItem Constructor(Color) | Initializes a new instance of the BackdropItem class with the specified color.
BackdropItem Constructor(Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Color,Byte) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Color,Byte,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(GradientType,Color,Color) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(HatchStyle,Color,Color) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Image,PicturePutStyle) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,Object) | Initializes a new instance of the BackdropItem class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Constructor()

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor()

Glossary Item Box

Initializes a new instance of the BackdropItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BackdropItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(AntiAliasMode)

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the AntiAliasMode specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color)

color
Specifies the primary color.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
C#
public BackdropItem(
   Color color
)

Parameters

color
Specifies the primary color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,AntiAliasMode)

color
Specifies the primary color.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   Color color,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,Byte)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Color,Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,Byte)

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal alpha As Byte _
)
C#
public BackdropItem(
   Color color,
   byte alpha
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,Byte,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Color,Byte,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,Byte,AntiAliasMode)

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal alpha As Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   Color color,
   byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(GradientType,Color,Color)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(GradientType,Color,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(GradientType,Color,Color)

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
C#
public BackdropItem(
   GradientType gradient,
   Color color,
   Color color2
)

Parameters

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   GradientType gradient,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(HatchStyle,Color,Color)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(HatchStyle,Color,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(HatchStyle,Color,Color)

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pattern As HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
C#
public BackdropItem(
   HatchStyle pattern,
   Color color,
   Color color2
)

Parameters

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pattern As HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   HatchStyle pattern,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Image,PicturePutStyle)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Image,PicturePutStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Image,PicturePutStyle)

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
C#
public BackdropItem(
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
C#
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As Byte _
)
C#
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   byte alpha
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the BackdropItem class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,Object)

[image]
ActiveReports 19 .NET Edition
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,Object)

style
color
color2
gradient
pattern
picture
pictureAlignment
alpha
antiAliasMode
contextMenu

Glossary Item Box

Initializes a new instance of the BackdropItem class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As Byte, _
   ByVal antiAliasMode As AntiAliasMode, _
   ByVal contextMenu As Object _
)
C#
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   byte alpha,
   AntiAliasMode antiAliasMode,
   object contextMenu
)

Parameters

style
color
color2
gradient
pattern
picture
pictureAlignment
alpha
antiAliasMode
contextMenu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Class Methods

[image]
ActiveReports 19 .NET Edition
BackdropItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

Glossary Item Box

For a list of all members of this type, see BackdropItem members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Compares the BackdropItem object to another System.Object to see if they are equal.
Public Method | OnMouseDown | Raises the MouseDown event.
Public Method | OnMouseEnter | Raises the MouseEnter event.
Public Method | OnMouseHover | Raises the MouseHover event.
Public Method | OnMouseLeave | Raises the MouseLeave event.
Public Method | OnMouseMove | Raises the MouseMove event.
Public Method | OnMouseUp | Raises the MouseUp event.
Public Method | OnMouseWheel | Raises the MouseWheel event.
Top

See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : Equals Method

obj
The System.Object to which the BackdropItem object is being compared.

Glossary Item Box

Compares the BackdropItem object to another System.Object to see if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the BackdropItem object is being compared.

Return Value

Boolean. Returns True if the BackdropItem object is equal to the System.Object; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseDown Method

[image]
ActiveReports 19 .NET Edition
OnMouseDown Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseDown Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseDown event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseDown( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseDown(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseEnter Method

[image]
ActiveReports 19 .NET Edition
OnMouseEnter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseEnter Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseEnter event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseEnter( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseEnter(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseHover Method

[image]
ActiveReports 19 .NET Edition
OnMouseHover Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseHover Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseHover event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseHover( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseHover(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseLeave Method

[image]
ActiveReports 19 .NET Edition
OnMouseLeave Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseLeave Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseLeave event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseLeave( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseLeave(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseMove Method

[image]
ActiveReports 19 .NET Edition
OnMouseMove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseMove Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseMove event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseMove( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseMove(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseUp Method

[image]
ActiveReports 19 .NET Edition
OnMouseUp Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseUp Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseUp event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseUp( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseUp(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseWheel Method

[image]
ActiveReports 19 .NET Edition
OnMouseWheel Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseWheel Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseWheel event.

Syntax

Visual Basic (Declaration)
Public Sub OnMouseWheel( _
   ByVal e As GraphMouseEventArgs _
)
C#
public void OnMouseWheel(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Class Properties

[image]
ActiveReports 19 .NET Edition
BackdropItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

Glossary Item Box

For a list of all members of this type, see BackdropItem members.

Public Properties

 | Name | Description
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control.
Top

See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


ContextMenu Property

[image]
ActiveReports 19 .NET Edition
ContextMenu Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As Object
C#
public object ContextMenu {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Class Events

[image]
ActiveReports 19 .NET Edition
BackdropItem Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

Glossary Item Box

For a list of all members of this type, see BackdropItem members.

Public Events

 | Name | Description
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event | MouseEnter | Occurs when the mouse pointer enters the control.
Public Event | MouseHover | Occurs when the mouse pointer hovers over the control.
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control.
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control.
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus.
Top

See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


MouseDown Event

[image]
ActiveReports 19 .NET Edition
MouseDown Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseDown

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseEnter Event

[image]
ActiveReports 19 .NET Edition
MouseEnter Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseEnter

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseHover Event

[image]
ActiveReports 19 .NET Edition
MouseHover Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer hovers over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseHover

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseLeave Event

[image]
ActiveReports 19 .NET Edition
MouseLeave Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseLeave

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseMove Event

[image]
ActiveReports 19 .NET Edition
MouseMove Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseMove

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseUp Event

[image]
ActiveReports 19 .NET Edition
MouseUp Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseUp

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


MouseWheel Event

[image]
ActiveReports 19 .NET Edition
MouseWheel Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As GraphMouseEventHandler
C#
public event GraphMouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Graph | Gets the graph
IsLeftMouseButton | Gets mouse event button state
PointIndex | Gets a count of the number of times the item was clicked.
ShapeArea | Gets Shape Area on which mouse event occured on
SourcePoint | Gets source point on which mouse event occured on
UserPoint | Gets user point on which mouse event occured on

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackdropItem Class
BackdropItem Members


Border Class

[image]
ActiveReports 19 .NET Edition
Border Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

Glossary Item Box

Represents the information required to draw the borders of the graph.

Object Model

Border Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Border
   Inherits Item
C#
public sealed class Border : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Border

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Members
GrapeCity.ActiveReports.Chart Namespace


Border Class Members

[image]
ActiveReports 19 .NET Edition
Border Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

Glossary Item Box

The following tables list the members exposed by Border.

Public Constructors

 | Name | Description
Public Constructor | Border Constructor | Overloaded. Initializes a new instance of the Border class.
Top

Public Properties

 | Name | Description
Public Property | Line | Gets or sets the line style used to draw the border of the graph.
Public Property | ShadowColor | Gets or sets the color of the shadow outlining the border.
Public Property | ShadowWeight | Gets or sets the width of the shadow outlining the border.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the border.
Public Method | Equals | Compares the Border object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Border Constructor

[image]
ActiveReports 19 .NET Edition
Border Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Border Constructor

Glossary Item Box

Initializes a new instance of the Border class.

Overload List

Overload | Description
Border Constructor() | Initializes a new instance of the Border class.
Border Constructor(Line) | Initializes a new instance of the Border class with the Line info specified.
Border Constructor(Line,Int32) | Initializes a new instance of the Border class with the parameters specified.
Border Constructor(Line,Int32,Color) | Initializes a new instance of the Border class with the parameters specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Constructor()

[image]
ActiveReports 19 .NET Edition
Border Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor()

Glossary Item Box

Initializes a new instance of the Border class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Border()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line)

[image]
ActiveReports 19 .NET Edition
Border Constructor(Line)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line)

line
Specifies the Line info for the border.

Glossary Item Box

Initializes a new instance of the Border class with the Line info specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal line As Line _
)
C#
public Border(
   Line line
)

Parameters

line
Specifies the Line info for the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line,Int32)

[image]
ActiveReports 19 .NET Edition
Border Constructor(Line,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line,Int32)

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.

Glossary Item Box

Initializes a new instance of the Border class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal line As Line, _
   ByVal shadowWeight As Integer _
)
C#
public Border(
   Line line,
   int shadowWeight
)

Parameters

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line,Int32,Color)

[image]
ActiveReports 19 .NET Edition
Border Constructor(Line,Int32,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line,Int32,Color)

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.
shadowColor
Specifies the shadow color of the border.

Glossary Item Box

Initializes a new instance of the Border class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal line As Line, _
   ByVal shadowWeight As Integer, _
   ByVal shadowColor As Color _
)
C#
public Border(
   Line line,
   int shadowWeight,
   Color shadowColor
)

Parameters

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.
shadowColor
Specifies the shadow color of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Class Methods

[image]
ActiveReports 19 .NET Edition
Border Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the border.
Public Method | Equals | Compares the Border object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Clone Method

Glossary Item Box

Creates a clone of the border.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Equals Method

obj
The System.Object to which the Border object is being compared.

Glossary Item Box

Compares the Border object to another System.Object to see if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Border object is being compared.

Return Value

Boolean. True if the Border object is equal to the System.Object; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Properties

[image]
ActiveReports 19 .NET Edition
Border Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Properties

 | Name | Description
Public Property | Line | Gets or sets the line style used to draw the border of the graph.
Public Property | ShadowColor | Gets or sets the color of the shadow outlining the border.
Public Property | ShadowWeight | Gets or sets the width of the shadow outlining the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Line Property

Glossary Item Box

Gets or sets the line style used to draw the border of the graph.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


ShadowColor Property

[image]
ActiveReports 19 .NET Edition
ShadowColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : ShadowColor Property

Glossary Item Box

Gets or sets the color of the shadow outlining the border.

Syntax

Visual Basic (Declaration)
Public Property ShadowColor As Color
C#
public Color ShadowColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


ShadowWeight Property

[image]
ActiveReports 19 .NET Edition
ShadowWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : ShadowWeight Property

Glossary Item Box

Gets or sets the width of the shadow outlining the border.

Syntax

Visual Basic (Declaration)
Public Property ShadowWeight As Integer
C#
public int ShadowWeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


BorderSizes Class

[image]
ActiveReports 19 .NET Edition
BorderSizes Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class

Glossary Item Box

Describes the size of the border around the rectangular area.

Object Model

BorderSizes Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BorderSizes
C#
public sealed class BorderSizes

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.BorderSizes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Members
GrapeCity.ActiveReports.Chart Namespace


BorderSizes Class Members

[image]
ActiveReports 19 .NET Edition
BorderSizes Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class

Glossary Item Box

The following tables list the members exposed by BorderSizes.

Public Constructors

 | Name | Description
Public Constructor | BorderSizes Constructor | Overloaded. Initializes a new instance of the BorderSizes class.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the margin between the inner and outer edges on the bottom side of a border.
Public Property | Left | Gets or sets the margin between the inner and outer edges on the left side of a border.
Public Property | Right | Gets or sets the margin between the inner and outer edges on the right side of a border.
Public Property | Top | Gets or sets the margin between the inner and outer edges on the top side of a border.
Top

See Also

Reference

BorderSizes Class
GrapeCity.ActiveReports.Chart Namespace


BorderSizes Constructor

[image]
ActiveReports 19 .NET Edition
BorderSizes Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : BorderSizes Constructor

Glossary Item Box

Initializes a new instance of the BorderSizes class.

Overload List

Overload | Description
BorderSizes Constructor() | Initializes a new instance of the BorderSizes class.
BorderSizes Constructor(Single,Single,Single,Single) | Initializes a new instance of the BorderSizes class with the border margins specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members


BorderSizes Constructor()

[image]
ActiveReports 19 .NET Edition
BorderSizes Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class > BorderSizes Constructor : BorderSizes Constructor()

Glossary Item Box

Initializes a new instance of the BorderSizes class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderSizes()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members
Overload List


BorderSizes Constructor(Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
BorderSizes Constructor(Single,Single,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class > BorderSizes Constructor : BorderSizes Constructor(Single,Single,Single,Single)

left
Specifies the left border margin.
right
Specifies the right border margin.
top
Specifies the top border margin.
bottom
Specifies the bottom border margin.

Glossary Item Box

Initializes a new instance of the BorderSizes class with the border margins specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal right As Single, _
   ByVal top As Single, _
   ByVal bottom As Single _
)
C#
public BorderSizes(
   float left,
   float right,
   float top,
   float bottom
)

Parameters

left
Specifies the left border margin.
right
Specifies the right border margin.
top
Specifies the top border margin.
bottom
Specifies the bottom border margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members
Overload List


BorderSizes Class Properties

[image]
ActiveReports 19 .NET Edition
BorderSizes Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class

Glossary Item Box

For a list of all members of this type, see BorderSizes members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the margin between the inner and outer edges on the bottom side of a border.
Public Property | Left | Gets or sets the margin between the inner and outer edges on the left side of a border.
Public Property | Right | Gets or sets the margin between the inner and outer edges on the right side of a border.
Public Property | Top | Gets or sets the margin between the inner and outer edges on the top side of a border.
Top

See Also

Reference

BorderSizes Class
GrapeCity.ActiveReports.Chart Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Bottom Property

Glossary Item Box

Gets or sets the margin between the inner and outer edges on the bottom side of a border.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
C#
public float Bottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Left Property

Glossary Item Box

Gets or sets the margin between the inner and outer edges on the left side of a border.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Right Property

Glossary Item Box

Gets or sets the margin between the inner and outer edges on the right side of a border.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
C#
public float Right {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Top Property

Glossary Item Box

Gets or sets the margin between the inner and outer edges on the top side of a border.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
C#
public float Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderSizes Class
BorderSizes Members


ChartArea Class

[image]
ActiveReports 19 .NET Edition
ChartArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

Glossary Item Box

Specifies the properties of the chart area.

Object Model

ChartArea Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartArea
   Inherits DrawCustomizableComponent
C#
public sealed class ChartArea : DrawCustomizableComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.ChartArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Members
GrapeCity.ActiveReports.Chart Namespace


ChartArea Class Members

[image]
ActiveReports 19 .NET Edition
ChartArea Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

Glossary Item Box

The following tables list the members exposed by ChartArea.

Public Constructors

 | Name | Description
Public Constructor | ChartArea Constructor | Overloaded. Initializes a new instance of the ChartArea class.
Top

Public Properties

 | Name | Description
Public Property | Axes | Gets the user-defined custom axes.
Public Property | Backdrop | Gets or sets the backdrop information used to draw the chart area.
Public Property | Border | Gets or sets the border information for the chart area.
Public Property | Light | Gets or sets the lighting information for the chart area.
Public Property | Padding | Gets or sets chart area's padding information.
Public Property | Projection | Gets or sets the geometric projection details for the chart area.
Public Property | SeriesLine | Series line
Public Property | SwapAxesDirection | Determines whether the chart axes are inverted. The default is false.
Public Property | ViewPoint | Gets or sets the point from which the chart is seen.
Public Property | WallRanges | Gets the wall ranges (strip lines) for the chart area.
Public Property | WallXY | Gets or sets the XY wall settings for the chart area.
Public Property | WallXZ | Gets or sets the XZ wall settings for the chart area.
Public Property | WallYZ | Gets or sets the YZ wall settings for the chart area.
Public Property | ZDepthRatio | Gets or sets the chart area depth, specified as the ratio of z to x.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the chart area.
Top

See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


ChartArea Constructor

[image]
ActiveReports 19 .NET Edition
ChartArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ChartArea Constructor

Glossary Item Box

Initializes a new instance of the ChartArea class.

Overload List

Overload | Description
ChartArea Constructor() | Initializes a new instance of the ChartArea class without axes.
ChartArea Constructor(Boolean) | Initializes a new instance of the ChartArea class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Constructor()

[image]
ActiveReports 19 .NET Edition
ChartArea Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor()

Glossary Item Box

Initializes a new instance of the ChartArea class without axes.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartArea()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


ChartArea Constructor(Boolean)

[image]
ActiveReports 19 .NET Edition
ChartArea Constructor(Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(Boolean)

initializeAxes
Specifies whether or not the axes should be initialized.

Glossary Item Box

Initializes a new instance of the ChartArea class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal initializeAxes As Boolean _
)
C#
public ChartArea(
   bool initializeAxes
)

Parameters

initializeAxes
Specifies whether or not the axes should be initialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


ChartArea Class Methods

[image]
ActiveReports 19 .NET Edition
ChartArea Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

Glossary Item Box

For a list of all members of this type, see ChartArea members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the chart area.
Top

See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Clone Method

Glossary Item Box

Creates a clone of the chart area.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the ChartArea object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Class Properties

[image]
ActiveReports 19 .NET Edition
ChartArea Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

Glossary Item Box

For a list of all members of this type, see ChartArea members.

Public Properties

 | Name | Description
Public Property | Axes | Gets the user-defined custom axes.
Public Property | Backdrop | Gets or sets the backdrop information used to draw the chart area.
Public Property | Border | Gets or sets the border information for the chart area.
Public Property | Light | Gets or sets the lighting information for the chart area.
Public Property | Padding | Gets or sets chart area's padding information.
Public Property | Projection | Gets or sets the geometric projection details for the chart area.
Public Property | SeriesLine | Series line
Public Property | SwapAxesDirection | Determines whether the chart axes are inverted. The default is false.
Public Property | ViewPoint | Gets or sets the point from which the chart is seen.
Public Property | WallRanges | Gets the wall ranges (strip lines) for the chart area.
Public Property | WallXY | Gets or sets the XY wall settings for the chart area.
Public Property | WallXZ | Gets or sets the XZ wall settings for the chart area.
Public Property | WallYZ | Gets or sets the YZ wall settings for the chart area.
Public Property | ZDepthRatio | Gets or sets the chart area depth, specified as the ratio of z to x.
Top

See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


Axes Property

[image]
ActiveReports 19 .NET Edition
Axes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Axes Property

Glossary Item Box

Gets the user-defined custom axes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Axes As AxesCollection
C#
public AxesCollection Axes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information used to draw the chart area.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As BackdropItem
C#
public BackdropItem Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Border Property

Glossary Item Box

Gets or sets the border information for the chart area.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Light Property

[image]
ActiveReports 19 .NET Edition
Light Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Light Property

Glossary Item Box

Gets or sets the lighting information for the chart area.

Syntax

Visual Basic (Declaration)
Public Property Light As Light
C#
public Light Light {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Padding Property

Glossary Item Box

Gets or sets chart area's padding information.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Projection Property

[image]
ActiveReports 19 .NET Edition
Projection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Projection Property

Glossary Item Box

Gets or sets the geometric projection details for the chart area.

Syntax

Visual Basic (Declaration)
Public Property Projection As Projection
C#
public Projection Projection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


SeriesLine Property

[image]
ActiveReports 19 .NET Edition
SeriesLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : SeriesLine Property

Glossary Item Box

Series line

Syntax

Visual Basic (Declaration)
Public Property SeriesLine As Line
C#
public Line SeriesLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


SwapAxesDirection Property

[image]
ActiveReports 19 .NET Edition
SwapAxesDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : SwapAxesDirection Property

Glossary Item Box

Determines whether the chart axes are inverted. The default is false.

Syntax

Visual Basic (Declaration)
Public Property SwapAxesDirection As Boolean
C#
public bool SwapAxesDirection {get; set;}

Property Value

Boolean. False if the chart is rendered with horizontal X and vertical Y axes; otherwise True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ViewPoint Property

[image]
ActiveReports 19 .NET Edition
ViewPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ViewPoint Property

Glossary Item Box

Gets or sets the point from which the chart is seen.

Syntax

Visual Basic (Declaration)
Public Property ViewPoint As Point3d
C#
public Point3d ViewPoint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


WallRanges Property

[image]
ActiveReports 19 .NET Edition
WallRanges Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallRanges Property

Glossary Item Box

Gets the wall ranges (strip lines) for the chart area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WallRanges As WallRangesCollection
C#
public WallRangesCollection WallRanges {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


WallXY Property

[image]
ActiveReports 19 .NET Edition
WallXY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallXY Property

Glossary Item Box

Gets or sets the XY wall settings for the chart area.

Syntax

Visual Basic (Declaration)
Public Property WallXY As PlaneItem
C#
public PlaneItem WallXY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


WallXZ Property

[image]
ActiveReports 19 .NET Edition
WallXZ Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallXZ Property

Glossary Item Box

Gets or sets the XZ wall settings for the chart area.

Syntax

Visual Basic (Declaration)
Public Property WallXZ As PlaneItem
C#
public PlaneItem WallXZ {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


WallYZ Property

[image]
ActiveReports 19 .NET Edition
WallYZ Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallYZ Property

Glossary Item Box

Gets or sets the YZ wall settings for the chart area.

Syntax

Visual Basic (Declaration)
Public Property WallYZ As PlaneItem
C#
public PlaneItem WallYZ {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ZDepthRatio Property

[image]
ActiveReports 19 .NET Edition
ZDepthRatio Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ZDepthRatio Property

Glossary Item Box

Gets or sets the chart area depth, specified as the ratio of z to x.

Syntax

Visual Basic (Declaration)
Public Property ZDepthRatio As Single
C#
public float ZDepthRatio {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ChartAreasCollection Class

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

Glossary Item Box

Specifies the settings for the chart areas collection.

Object Model

ChartAreasCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartAreasCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class ChartAreasCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.ChartAreasCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Members
GrapeCity.ActiveReports.Chart Namespace


ChartAreasCollection Class Members

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

Glossary Item Box

The following tables list the members exposed by ChartAreasCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartAreasCollection Constructor | Initializes a new instance of the ChartAreasCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified chart area in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a chart area to the collection.
Public Method | AddRange | Adds a set of chart areas to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the chart areas collection.
Public Method | Contains | Determines whether the collection contains the specified ChartArea.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified chart area into the collection at the specified index.
Public Method | Remove | Removes the specified chart area from the collection.
Top

Public Events

 | Name | Description
Public Event | Change | Raised when the collection changes.
Top

See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


ChartAreasCollection Constructor

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : ChartAreasCollection Constructor

Glossary Item Box

Initializes a new instance of the ChartAreasCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartAreasCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


ChartAreasCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

Glossary Item Box

For a list of all members of this type, see ChartAreasCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a chart area to the collection.
Public Method | AddRange | Adds a set of chart areas to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the chart areas collection.
Public Method | Contains | Determines whether the collection contains the specified ChartArea.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified chart area into the collection at the specified index.
Public Method | Remove | Removes the specified chart area from the collection.
Top

See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Add Method

value
The chart area to add.

Glossary Item Box

Adds a chart area to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As ChartArea _
) As Integer
C#
public int Add(
   ChartArea value
)

Parameters

value
The chart area to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : AddRange Method

areas
The chart areas to add to the collection.

Glossary Item Box

Adds a set of chart areas to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal areas() As ChartArea _
)
C#
public void AddRange(
   ChartArea[] areas
)

Parameters

areas
The chart areas to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Clear Method

Glossary Item Box

Clears all items from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Clone Method

Glossary Item Box

Creates a clone of the chart areas collection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Contains Method

value
The chart area to find in the collection.

Glossary Item Box

Determines whether the collection contains the specified ChartArea.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ChartArea _
) As Boolean
C#
public bool Contains(
   ChartArea value
)

Parameters

value
The chart area to find in the collection.

Return Value

Boolean. True if the collection contains the specified ChartArea; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the collection to an array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ChartArea, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   ChartArea[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Dispose Method

Glossary Item Box

Releases resources associated with this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As ChartArea _
) As Integer
C#
public int IndexOf(
   ChartArea value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Insert Method

index
The index at which to insert the chart area.
value
The ChartArea to insert.

Glossary Item Box

Inserts the specified chart area into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ChartArea _
)
C#
public void Insert(
   int index,
   ChartArea value
)

Parameters

index
The index at which to insert the chart area.
value
The ChartArea to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Remove Method

value
The chart area to remove.

Glossary Item Box

Removes the specified chart area from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As ChartArea _
)
C#
public void Remove(
   ChartArea value
)

Parameters

value
The chart area to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


ChartAreasCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

Glossary Item Box

For a list of all members of this type, see ChartAreasCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified chart area in the collection.
Top

See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Item Property

Glossary Item Box

Gets or sets the specified chart area in the collection.

Overload List

Overload | Description
Item(Int32) | Gets or sets the chart area at the specified index.
Item(String) | Gets the index of the chart area with the specified name in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class > Item Property : Item(Int32) Property

index
The index of the chart area.

Glossary Item Box

Gets or sets the chart area at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As ChartArea
C#
public ChartArea Item(
   int index
) {get; set;}

Parameters

index
The index of the chart area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class > Item Property : Item(String) Property

chartAreaName
The name of the ChartArea.

Glossary Item Box

Gets the index of the chart area with the specified name in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal chartAreaName As String _
) As ChartArea
C#
public ChartArea Item(
   string chartAreaName
) {get;}

Parameters

chartAreaName
The name of the ChartArea.

Property Value

ChartArea.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members
Overload List


ChartAreasCollection Class Events

[image]
ActiveReports 19 .NET Edition
ChartAreasCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

Glossary Item Box

For a list of all members of this type, see ChartAreasCollection members.

Public Events

 | Name | Description
Public Event | Change | Raised when the collection changes.
Top

See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


Change Event

[image]
ActiveReports 19 .NET Edition
Change Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Change Event

Glossary Item Box

Raised when the collection changes.

Syntax

Visual Basic (Declaration)
Public Event Change As EventHandler
C#
public event EventHandler Change

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


ChartTypeConfig Class

[image]
ActiveReports 19 .NET Edition
ChartTypeConfig Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class

Glossary Item Box

Represents the settings for the ChartTypeConfig object.

Object Model

ChartTypeConfig Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartTypeConfig
C#
public sealed class ChartTypeConfig

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.ChartTypeConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Members
GrapeCity.ActiveReports.Chart Namespace


ChartTypeConfig Class Members

[image]
ActiveReports 19 .NET Edition
ChartTypeConfig Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class

Glossary Item Box

The following tables list the members exposed by ChartTypeConfig.

Public Properties

 | Name | Description
Public Property | ApplyColorPaletteOnDataPoint | Gets a value indicating whether the color palette is applied to the data point.
Public Property | CoreRendererType | Gets the core renderer type for the chart.
Public Property | CoreStyleType | Gets the core style type for the chart.
Public Property | IsCategorical | Gets a value indicating whether the chart is categorical.
Public Property | IsXY | Gets a value indicating whether the chart is an XY chart.
Public Property | PropertiesTypes | Gets the property types for the chart.
Public Property | RequiredSeriesCount | Gets the count of required series for the chart.
Top

See Also

Reference

ChartTypeConfig Class
GrapeCity.ActiveReports.Chart Namespace


ChartTypeConfig Class Properties

[image]
ActiveReports 19 .NET Edition
ChartTypeConfig Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class

Glossary Item Box

For a list of all members of this type, see ChartTypeConfig members.

Public Properties

 | Name | Description
Public Property | ApplyColorPaletteOnDataPoint | Gets a value indicating whether the color palette is applied to the data point.
Public Property | CoreRendererType | Gets the core renderer type for the chart.
Public Property | CoreStyleType | Gets the core style type for the chart.
Public Property | IsCategorical | Gets a value indicating whether the chart is categorical.
Public Property | IsXY | Gets a value indicating whether the chart is an XY chart.
Public Property | PropertiesTypes | Gets the property types for the chart.
Public Property | RequiredSeriesCount | Gets the count of required series for the chart.
Top

See Also

Reference

ChartTypeConfig Class
GrapeCity.ActiveReports.Chart Namespace


ApplyColorPaletteOnDataPoint Property

[image]
ActiveReports 19 .NET Edition
ApplyColorPaletteOnDataPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : ApplyColorPaletteOnDataPoint Property

Glossary Item Box

Gets a value indicating whether the color palette is applied to the data point.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ApplyColorPaletteOnDataPoint As Boolean
C#
public bool ApplyColorPaletteOnDataPoint {get;}

Property Value

Boolean. True if the color palette is applied to the data point; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CoreRendererType Property

[image]
ActiveReports 19 .NET Edition
CoreRendererType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : CoreRendererType Property

Glossary Item Box

Gets the core renderer type for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CoreRendererType As Type
C#
public Type CoreRendererType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CoreStyleType Property

[image]
ActiveReports 19 .NET Edition
CoreStyleType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : CoreStyleType Property

Glossary Item Box

Gets the core style type for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CoreStyleType As Type
C#
public Type CoreStyleType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


IsCategorical Property

[image]
ActiveReports 19 .NET Edition
IsCategorical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : IsCategorical Property

Glossary Item Box

Gets a value indicating whether the chart is categorical.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCategorical As Boolean
C#
public bool IsCategorical {get;}

Property Value

Boolean. True if the chart is categorical; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


IsXY Property

[image]
ActiveReports 19 .NET Edition
IsXY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : IsXY Property

Glossary Item Box

Gets a value indicating whether the chart is an XY chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsXY As Boolean
C#
public bool IsXY {get;}

Property Value

Boolean. True if the chart is an XY chart; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


PropertiesTypes Property

[image]
ActiveReports 19 .NET Edition
PropertiesTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : PropertiesTypes Property

Glossary Item Box

Gets the property types for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PropertiesTypes As KeyValuePair()
C#
public KeyValuePair[] PropertiesTypes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


RequiredSeriesCount Property

[image]
ActiveReports 19 .NET Edition
RequiredSeriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : RequiredSeriesCount Property

Glossary Item Box

Gets the count of required series for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RequiredSeriesCount As Integer
C#
public int RequiredSeriesCount {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CustomAxis Class

[image]
ActiveReports 19 .NET Edition
CustomAxis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

Glossary Item Box

Represents the properties of a custom axis.

Object Model

CustomAxis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomAxis
   Inherits AxisBase
C#
public sealed class CustomAxis : AxisBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.CustomAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Members
GrapeCity.ActiveReports.Chart Namespace


CustomAxis Class Members

[image]
ActiveReports 19 .NET Edition
CustomAxis Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

Glossary Item Box

The following tables list the members exposed by CustomAxis.

Public Constructors

 | Name | Description
Public Constructor | CustomAxis Constructor | Creates default axis
Top

Public Properties

 | Name | Description
Public Property | MaxDerived | Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.
Public Property | MinDerived | Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.
Public Property | Parent | Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.
Public Property | PlacementLength | Gets or sets the length of the custom axis in terms of its parent axis.
Public Property | PlacementLocation | Gets or sets the position of the origin of the custom axis in terms of its parent axis.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom axis.
Top

See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


CustomAxis Constructor()

[image]
ActiveReports 19 .NET Edition
CustomAxis Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class > CustomAxis Constructor : CustomAxis Constructor()

Glossary Item Box

Creates default axis

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomAxis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members
Overload List


CustomAxis Class Methods

[image]
ActiveReports 19 .NET Edition
CustomAxis Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

Glossary Item Box

For a list of all members of this type, see CustomAxis members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom axis.
Top

See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : Clone Method

Glossary Item Box

Creates a clone of the custom axis.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the CustomAxis object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


CustomAxis Class Properties

[image]
ActiveReports 19 .NET Edition
CustomAxis Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

Glossary Item Box

For a list of all members of this type, see CustomAxis members.

Public Properties

 | Name | Description
Public Property | MaxDerived | Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.
Public Property | MinDerived | Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.
Public Property | Parent | Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.
Public Property | PlacementLength | Gets or sets the length of the custom axis in terms of its parent axis.
Public Property | PlacementLocation | Gets or sets the position of the origin of the custom axis in terms of its parent axis.
Top

See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


MaxDerived Property

[image]
ActiveReports 19 .NET Edition
MaxDerived Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : MaxDerived Property

Glossary Item Box

Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.

Syntax

Visual Basic (Declaration)
Public Property MaxDerived As Boolean
C#
public bool MaxDerived {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


MinDerived Property

[image]
ActiveReports 19 .NET Edition
MinDerived Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : MinDerived Property

Glossary Item Box

Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.

Syntax

Visual Basic (Declaration)
Public Property MinDerived As Boolean
C#
public bool MinDerived {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : Parent Property

Glossary Item Box

Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.

Syntax

Visual Basic (Declaration)
Public Shadows Property Parent As Axis
C#
public new Axis Parent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


PlacementLength Property

[image]
ActiveReports 19 .NET Edition
PlacementLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : PlacementLength Property

Glossary Item Box

Gets or sets the length of the custom axis in terms of its parent axis.

Syntax

Visual Basic (Declaration)
Public Property PlacementLength As Double
C#
public double PlacementLength {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


PlacementLocation Property

[image]
ActiveReports 19 .NET Edition
PlacementLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : PlacementLocation Property

Glossary Item Box

Gets or sets the position of the origin of the custom axis in terms of its parent axis.

Syntax

Visual Basic (Declaration)
Public Property PlacementLocation As Double
C#
public double PlacementLocation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


CustomDrawEventArgs Class

[image]
ActiveReports 19 .NET Edition
CustomDrawEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventArgs Class

Glossary Item Box

Represents the properties of the custom draw event arguments for the chart.

Object Model

CustomDrawEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomDrawEventArgs
   Inherits System.EventArgs
C#
public sealed class CustomDrawEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Chart.CustomDrawEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDrawEventArgs Members
GrapeCity.ActiveReports.Chart Namespace


CustomDrawEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
CustomDrawEventArgs Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventArgs Class

Glossary Item Box

The following tables list the members exposed by CustomDrawEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CustomDrawEventArgs Constructor | Initializes a new instance of the CustomDrawEventArgs class.
Top

See Also

Reference

CustomDrawEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


CustomDrawEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
CustomDrawEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomDrawEventArgs Class : CustomDrawEventArgs Constructor

Glossary Item Box

Initializes a new instance of the CustomDrawEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomDrawEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDrawEventArgs Class
CustomDrawEventArgs Members


CustomProperties Class

[image]
ActiveReports 19 .NET Edition
CustomProperties Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

Glossary Item Box

Represents the set of custom properties for the chart.

Object Model

CustomProperties Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomProperties
   Inherits Item
C#
public sealed class CustomProperties : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.CustomProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Members
GrapeCity.ActiveReports.Chart Namespace


CustomProperties Class Members

[image]
ActiveReports 19 .NET Edition
CustomProperties Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

Glossary Item Box

The following tables list the members exposed by CustomProperties.

Public Constructors

 | Name | Description
Public Constructor | CustomProperties Constructor | Overloaded. Initializes a new instance of the CustomProperties class.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the specified item as a custom attribute.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom attributes.
Public Method | Equals | Compares the CustomAttributes object to another System.Object to see if they are equal.
Public Method | GetAttributes | Gets the attributes collection of the custom properties object.
Public Method | GetClassName | Gets the class name as string of the custom attributes object.
Public Method | GetComponentName | Gets the component name as string of the custom attributes object.
Public Method | GetConverter | Gets the type converter of the custom attributes object.
Public Method | GetDefaultEvent | Returns the default event for this object.
Public Method | GetDefaultProperty | Returns the default property for this object.
Public Method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current attributes.
Public Method | GetProperties | Overloaded. Gets the properties for this instance of a component.
Public Method | GetPropertyOwner | Returns the object of which this value is a member.
Top

See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


CustomProperties Constructor

[image]
ActiveReports 19 .NET Edition
CustomProperties Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : CustomProperties Constructor

Glossary Item Box

Initializes a new instance of the CustomProperties class.

Overload List

Overload | Description
CustomProperties Constructor() | Initializes a new instance of the CustomProperties class.
CustomProperties Constructor(KeyValuePair[]) | Initializes a new instance of the CustomProperties class with the KeyValuePair array specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


CustomProperties Constructor()

[image]
ActiveReports 19 .NET Edition
CustomProperties Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > CustomProperties Constructor : CustomProperties Constructor()

Glossary Item Box

Initializes a new instance of the CustomProperties class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomProperties()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


CustomProperties Constructor(KeyValuePair[])

[image]
ActiveReports 19 .NET Edition
CustomProperties Constructor(KeyValuePair[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > CustomProperties Constructor : CustomProperties Constructor(KeyValuePair[])

initialValues
The array of string attribute values.

Glossary Item Box

Initializes a new instance of the CustomProperties class with the KeyValuePair array specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal initialValues() As KeyValuePair _
)
C#
public CustomProperties(
   KeyValuePair[] initialValues
)

Parameters

initialValues
The array of string attribute values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


CustomProperties Class Methods

[image]
ActiveReports 19 .NET Edition
CustomProperties Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

Glossary Item Box

For a list of all members of this type, see CustomProperties members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom attributes.
Public Method | Equals | Compares the CustomAttributes object to another System.Object to see if they are equal.
Public Method | GetAttributes | Gets the attributes collection of the custom properties object.
Public Method | GetClassName | Gets the class name as string of the custom attributes object.
Public Method | GetComponentName | Gets the component name as string of the custom attributes object.
Public Method | GetConverter | Gets the type converter of the custom attributes object.
Public Method | GetDefaultEvent | Returns the default event for this object.
Public Method | GetDefaultProperty | Returns the default property for this object.
Public Method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current attributes.
Public Method | GetProperties | Overloaded. Gets the properties for this instance of a component.
Public Method | GetPropertyOwner | Returns the object of which this value is a member.
Top

See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Clone Method

Glossary Item Box

Creates a clone of the custom attributes.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Equals Method

obj
The System.Object to which the CustomAttributes object is being compared.

Glossary Item Box

Compares the CustomAttributes object to another System.Object to see if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the CustomAttributes object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetAttributes Method

[image]
ActiveReports 19 .NET Edition
GetAttributes Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetAttributes Method

Glossary Item Box

Gets the attributes collection of the custom properties object.

Syntax

Visual Basic (Declaration)
Public Function GetAttributes() As AttributeCollection
C#
public AttributeCollection GetAttributes()

Return Value

An System.ComponentModel.AttributeCollection containing the attributes for this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetClassName Method

[image]
ActiveReports 19 .NET Edition
GetClassName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetClassName Method

Glossary Item Box

Gets the class name as string of the custom attributes object.

Syntax

Visual Basic (Declaration)
Public Function GetClassName() As String
C#
public string GetClassName()

Return Value

The class name of the object, or null if the class does not have a name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetComponentName Method

[image]
ActiveReports 19 .NET Edition
GetComponentName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetComponentName Method

Glossary Item Box

Gets the component name as string of the custom attributes object.

Syntax

Visual Basic (Declaration)
Public Function GetComponentName() As String
C#
public string GetComponentName()

Return Value

The name of the object, or null if the object does not have a name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetConverter Method

[image]
ActiveReports 19 .NET Edition
GetConverter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetConverter Method

Glossary Item Box

Gets the type converter of the custom attributes object.

Syntax

Visual Basic (Declaration)
Public Function GetConverter() As TypeConverter
C#
public TypeConverter GetConverter()

Return Value

A System.ComponentModel.TypeConverter that is the converter for this object, or null if there is no System.ComponentModel.TypeConverter for this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetDefaultEvent Method

[image]
ActiveReports 19 .NET Edition
GetDefaultEvent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetDefaultEvent Method

Glossary Item Box

Returns the default event for this object.

Syntax

Visual Basic (Declaration)
Public Function GetDefaultEvent() As EventDescriptor
C#
public EventDescriptor GetDefaultEvent()

Return Value

An System.ComponentModel.EventDescriptor that represents the default event for this object, or null if this object does not have events.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetDefaultProperty Method

[image]
ActiveReports 19 .NET Edition
GetDefaultProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetDefaultProperty Method

Glossary Item Box

Returns the default property for this object.

Syntax

Visual Basic (Declaration)
Public Function GetDefaultProperty() As PropertyDescriptor
C#
public PropertyDescriptor GetDefaultProperty()

Return Value

A System.ComponentModel.PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetEvents Method

[image]
ActiveReports 19 .NET Edition
GetEvents Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetEvents Method

Glossary Item Box

Gets the events that are declared or inherited by the current attributes.

Overload List

Overload | Description
GetEvents(Attribute[]) | Gets the event descriptor collection for the specified custom attributes array.
GetEvents() | Gets the event descriptor collection of the custom attributes object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetEvents(Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetEvents(Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetEvents Method : GetEvents(Attribute[]) Method

attributes
The attributes array.

Glossary Item Box

Gets the event descriptor collection for the specified custom attributes array.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetEvents( _
   ByVal attributes() As Attribute _
) As EventDescriptorCollection
C#
public EventDescriptorCollection GetEvents(
   Attribute[] attributes
)

Parameters

attributes
The attributes array.

Return Value

An System.ComponentModel.EventDescriptorCollection that represents the filtered events for this component instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetEvents() Method

[image]
ActiveReports 19 .NET Edition
GetEvents() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetEvents Method : GetEvents() Method

Glossary Item Box

Gets the event descriptor collection of the custom attributes object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetEvents() As EventDescriptorCollection
C#
public EventDescriptorCollection GetEvents()

Return Value

An System.ComponentModel.EventDescriptorCollection that represents the events for this component instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetProperties Method

Glossary Item Box

Gets the properties for this instance of a component.

Overload List

Overload | Description
GetProperties(Attribute[]) | Gets the properties for this instance of a component.
GetProperties() | Gets the properties for this instance of a component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


GetProperties(Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetProperties Method : GetProperties(Attribute[]) Method

attributes
The attributes array.

Glossary Item Box

Gets the properties for this instance of a component.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   Attribute[] attributes
)

Parameters

attributes
The attributes array.

Return Value

A System.ComponentModel.PropertyDescriptorCollection that represents the filtered properties for this component instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetProperties() Method

[image]
ActiveReports 19 .NET Edition
GetProperties() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetProperties Method : GetProperties() Method

Glossary Item Box

Gets the properties for this instance of a component.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties() As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties()

Return Value

A System.ComponentModel.PropertyDescriptorCollection that represents the properties for this component instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetPropertyOwner Method

[image]
ActiveReports 19 .NET Edition
GetPropertyOwner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetPropertyOwner Method

pd

A property descriptor that represents the property whose owner is to be found.

Glossary Item Box

Returns the object of which this value is a member.

Syntax

Visual Basic (Declaration)
Public Function GetPropertyOwner( _
   ByVal pd As PropertyDescriptor _
) As Object
C#
public object GetPropertyOwner(
   PropertyDescriptor pd
)

Parameters

pd

A property descriptor that represents the property whose owner is to be found.

Return Value

An System.Object that represents the owner of the specified property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


CustomProperties Class Properties

[image]
ActiveReports 19 .NET Edition
CustomProperties Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

Glossary Item Box

For a list of all members of this type, see CustomProperties members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the specified item as a custom attribute.
Top

See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Item Property

propertyName
The property name as string.

Glossary Item Box

Gets or sets the specified item as a custom attribute.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal propertyName As String _
) As Object
C#
public object this[
   string propertyName
]; {get; set;}

Parameters

propertyName
The property name as string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperties Class
CustomProperties Members


DataPoint Class

[image]
ActiveReports 19 .NET Edition
DataPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

Glossary Item Box

Represents the set of properties for a data point.

Object Model

DataPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPoint
   Inherits Item
C#
public sealed class DataPoint : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.DataPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Members
GrapeCity.ActiveReports.Chart Namespace


DataPoint Class Members

[image]
ActiveReports 19 .NET Edition
DataPoint Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

Glossary Item Box

The following tables list the members exposed by DataPoint.

Public Constructors

 | Name | Description
Public Constructor | DataPoint Constructor | Overloaded. Initializes a new instance of the DataPoint class.
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the DataPoint.
Public Property | BorderLine | Gets or sets the line information for the border line of the DataPoint.
Public Property | DisplayInLegend | Gets or sets a value indicating whether to display the data point in the legend.
Public Property | IsEmpty | Gets or sets a value indicating whether the DataPoint is empty.
Public Property | LegendText | Gets or sets the text as string to display for the DataPoint in the legend.
Public Property | Line | Gets or sets the line information for the line of the DataPoint.
Public Property | Marker | Gets or sets the marker information for the DataPoint.
Public Property | Properties | Gets or sets the custom properties for the DataPoint.
Public Property | Tooltip | Gets or sets the tooltip text as string for the DataPoint.
Public Property | XValue | Gets or sets the X value for the DataPoint.
Public Property | YValues | Gets or sets the Y values for the DataPoint.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the DataPoint.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


DataPoint Constructor

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : DataPoint Constructor

Glossary Item Box

Initializes a new instance of the DataPoint class.

Overload List

Overload | Description
DataPoint Constructor() | Initializes a new instance of the DataPoint class.
DataPoint Constructor(Int32) | Initializes a new instance of the DataPoint class.
DataPoint Constructor(Object,DoubleArray,Boolean) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String) | Initializes a new instance of the DataPoint class with the parameters specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor()

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor()

Glossary Item Box

Initializes a new instance of the DataPoint class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPoint()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Int32)

yValuesCount

Glossary Item Box

Initializes a new instance of the DataPoint class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal yValuesCount As Integer _
)
C#
public DataPoint(
   int yValuesCount
)

Parameters

yValuesCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean)

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor(Object,DoubleArray,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean)

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.

Glossary Item Box

Initializes a new instance of the DataPoint class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xValue As Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As Boolean _
)
C#
public DataPoint(
   object xValue,
   DoubleArray yValues,
   bool isEmpty
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

Glossary Item Box

Initializes a new instance of the DataPoint class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xValue As Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As Boolean, _
   ByVal displayInLegend As Boolean, _
   ByVal legendText As String _
)
C#
public DataPoint(
   object xValue,
   DoubleArray yValues,
   bool isEmpty,
   bool displayInLegend,
   string legendText
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.

Glossary Item Box

Initializes a new instance of the DataPoint class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xValue As Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As Boolean, _
   ByVal properties As CustomProperties _
)
C#
public DataPoint(
   object xValue,
   DoubleArray yValues,
   bool isEmpty,
   CustomProperties properties
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

Glossary Item Box

Initializes a new instance of the DataPoint class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xValue As Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As Boolean, _
   ByVal properties As CustomProperties, _
   ByVal displayInLegend As Boolean, _
   ByVal legendText As String _
)
C#
public DataPoint(
   object xValue,
   DoubleArray yValues,
   bool isEmpty,
   CustomProperties properties,
   bool displayInLegend,
   string legendText
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Class Methods

[image]
ActiveReports 19 .NET Edition
DataPoint Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

Glossary Item Box

For a list of all members of this type, see DataPoint members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the DataPoint.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Clone Method

Glossary Item Box

Creates a clone of the DataPoint.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Properties

[image]
ActiveReports 19 .NET Edition
DataPoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

Glossary Item Box

For a list of all members of this type, see DataPoint members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the DataPoint.
Public Property | BorderLine | Gets or sets the line information for the border line of the DataPoint.
Public Property | DisplayInLegend | Gets or sets a value indicating whether to display the data point in the legend.
Public Property | IsEmpty | Gets or sets a value indicating whether the DataPoint is empty.
Public Property | LegendText | Gets or sets the text as string to display for the DataPoint in the legend.
Public Property | Line | Gets or sets the line information for the line of the DataPoint.
Public Property | Marker | Gets or sets the marker information for the DataPoint.
Public Property | Properties | Gets or sets the custom properties for the DataPoint.
Public Property | Tooltip | Gets or sets the tooltip text as string for the DataPoint.
Public Property | XValue | Gets or sets the X value for the DataPoint.
Public Property | YValues | Gets or sets the Y values for the DataPoint.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Property Value

The backdrop.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


BorderLine Property

[image]
ActiveReports 19 .NET Edition
BorderLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : BorderLine Property

Glossary Item Box

Gets or sets the line information for the border line of the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property BorderLine As Line
C#
public Line BorderLine {get; set;}

Property Value

The border line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DisplayInLegend Property

[image]
ActiveReports 19 .NET Edition
DisplayInLegend Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : DisplayInLegend Property

Glossary Item Box

Gets or sets a value indicating whether to display the data point in the legend.

Syntax

Visual Basic (Declaration)
Public Property DisplayInLegend As NullableBoolean
C#
public NullableBoolean DisplayInLegend {get; set;}

Remarks

The DisplayInLegend property applies to both the Series and DataPoint objects. When set to Auto for a one figure chart (e.g., funnel, pyramid, or doughnut) the property equals False for the Series object and True for the DataPoint object. When set to Auto for all other chart types, the property equals True for the Series object and False for the DataPoints object.

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.chartControl1.Series[1].Points[3].DisplayInLegend = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ChartControl1.Series[1].Points[3].DisplayInLegend = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : IsEmpty Property

Glossary Item Box

Gets or sets a value indicating whether the DataPoint is empty.

Syntax

Visual Basic (Declaration)
Public Property IsEmpty As Boolean
C#
public bool IsEmpty {get; set;}

Property Value

true if this instance is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


LegendText Property

[image]
ActiveReports 19 .NET Edition
LegendText Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : LegendText Property

Glossary Item Box

Gets or sets the text as string to display for the DataPoint in the legend.

Syntax

Visual Basic (Declaration)
Public Property LegendText As String
C#
public string LegendText {get; set;}

Property Value

The legend text.

Remarks

The LegendText property applies to both the Series and DataPoint objects. The LegendText property is treated as a {Value} by default when the data point appears in the legend and the LegendText property is set to an empty string. The {Value} is the original point value of the data point.

To render the x value for the data points in the legend for a one figure chart (i.e., funnel, pyramid, or doughnut), the LegendText property must be set to {Name}.

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   if(checkBoxSales.Checked)
   {
      this.chartControl1.Series["Sales"].Points[0].LegendText = "";
   }
   else
   {
      this.chartControl1.Series["Sales"].Points[0].LegendText = "Twenty";
   }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   If (CheckBoxSales.Checked) Then
       Me.ChartControl1.Series("Sales").Points(0).LegendText = ""
   Else
       Me.ChartControl1.Series("Sales").Points(0).LegendText = "Twenty"
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Line Property

Glossary Item Box

Gets or sets the line information for the line of the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Marker Property

Glossary Item Box

Gets or sets the marker information for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property Marker As Marker
C#
public Marker Marker {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Properties Property

Glossary Item Box

Gets or sets the custom properties for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property Properties As CustomProperties
C#
public CustomProperties Properties {get; set;}

Property Value

The properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Tooltip Property

Glossary Item Box

Gets or sets the tooltip text as string for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property Tooltip As LabelInfo
C#
public LabelInfo Tooltip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


XValue Property

[image]
ActiveReports 19 .NET Edition
XValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : XValue Property

Glossary Item Box

Gets or sets the X value for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property XValue As Object
C#
public object XValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


YValues Property

[image]
ActiveReports 19 .NET Edition
YValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : YValues Property

Glossary Item Box

Gets or sets the Y values for the DataPoint.

Syntax

Visual Basic (Declaration)
Public Property YValues As DoubleArray
C#
public DoubleArray YValues {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPointsCollection Class

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

Glossary Item Box

Specifies the settings for the DataPoints collection.

Object Model

DataPointsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPointsCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class DataPointsCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.DataPointsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Members
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

Glossary Item Box

The following tables list the members exposed by DataPointsCollection.

Public Constructors

 | Name | Description
Public Constructor | DataPointsCollection Constructor | Initializes a new instance of the DataPointsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the DataPoint at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a DataPoint to the collection.
Public Method | AddRange | Adds a set of DataPoints to the collection.
Public Method | AddXY | Adds a DataPoint with the specified parameters to the DataPointsCollection.
Public Method | AddY | Adds a DataPoint with the specified y value to the DataPointsCollection.
Public Method | Clone | Creates a clone of the DataPointsCollection.
Public Method | Contains | Determines whether the collection contains the specified DataPoint.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | DataBindXY | Overloaded. Binds the X value and Y values of the collection's DataPoints to a specified data source.
Public Method | DataBindY | Overloaded. Binds the Y value(s) of the collection's DataPoints to a specified data source.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified DataPoint into the collection at the specified index.
Public Method | Remove | Removes the specified DataPoint from the collection.
Top

Public Events

 | Name | Description
Public Event | Change | Occurs when the content of the DataPointsCollection changes.
Top

See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataPointsCollection Constructor

Glossary Item Box

Initializes a new instance of the DataPointsCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPointsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

Glossary Item Box

For a list of all members of this type, see DataPointsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a DataPoint to the collection.
Public Method | AddRange | Adds a set of DataPoints to the collection.
Public Method | AddXY | Adds a DataPoint with the specified parameters to the DataPointsCollection.
Public Method | AddY | Adds a DataPoint with the specified y value to the DataPointsCollection.
Public Method | Clone | Creates a clone of the DataPointsCollection.
Public Method | Contains | Determines whether the collection contains the specified DataPoint.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | DataBindXY | Overloaded. Binds the X value and Y values of the collection's DataPoints to a specified data source.
Public Method | DataBindY | Overloaded. Binds the Y value(s) of the collection's DataPoints to a specified data source.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified DataPoint into the collection at the specified index.
Public Method | Remove | Removes the specified DataPoint from the collection.
Top

See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Add Method

value
The DataPoint to add.

Glossary Item Box

Adds a DataPoint to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As DataPoint _
) As Integer
C#
public int Add(
   DataPoint value
)

Parameters

value
The DataPoint to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddRange Method

value
The DataPoints to add to the collection.

Glossary Item Box

Adds a set of DataPoints to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As DataPoint _
)
C#
public void AddRange(
   DataPoint[] value
)

Parameters

value
The DataPoints to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddXY Method

[image]
ActiveReports 19 .NET Edition
AddXY Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddXY Method

xValue
Specifies the X value.
yValue

Specifies the Y values.

Glossary Item Box

Adds a DataPoint with the specified parameters to the DataPointsCollection.

Syntax

Visual Basic (Declaration)
Public Function AddXY( _
   ByVal xValue As Object, _
   ByVal ParamArray yValue() As Double _
) As Integer
C#
public int AddXY(
   object xValue,
   params double[] yValue
)

Parameters

xValue
Specifies the X value.
yValue

Specifies the Y values.

Return Value

System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddY Method

[image]
ActiveReports 19 .NET Edition
AddY Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddY Method

yValue
Specifies the Y value.

Glossary Item Box

Adds a DataPoint with the specified y value to the DataPointsCollection.

Syntax

Visual Basic (Declaration)
Public Function AddY( _
   ByVal ParamArray yValue() As Double _
) As Integer
C#
public int AddY(
   params double[] yValue
)

Parameters

yValue
Specifies the Y value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Clone Method

Glossary Item Box

Creates a clone of the DataPointsCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A clone of the DataPointsCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Contains Method

value
The DataPoint to find in the collection.

Glossary Item Box

Determines whether the collection contains the specified DataPoint.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As DataPoint _
) As Boolean
C#
public bool Contains(
   DataPoint value
)

Parameters

value
The DataPoint to find in the collection.

Return Value

True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the collection to an array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As DataPoint, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   DataPoint[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindXY Method

[image]
ActiveReports 19 .NET Edition
DataBindXY Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataBindXY Method

Glossary Item Box

Binds the X value and Y values of the collection's DataPoints to a specified data source.

Overload List

Overload | Description
DataBindXY(Object,String,Object,String) | Binds the X value and Y values of the collection's DataPoints to the specified columns of the specified data sources.
DataBindXY(IEnumerable,IEnumerable[]) | Binds the X value and Y values of the collection's DataPoints to the first column(s) of the specified data source(s).
DataBindXY(Object[],Double[]) | Binds the X value and Y values of the collection's DataPoints to a specified data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindXY(Object,String,Object,String) Method

[image]
ActiveReports 19 .NET Edition
DataBindXY(Object,String,Object,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(Object,String,Object,String) Method

xDataSource
Specifies the data source that will supply the X values for the DataPoints.
xField
Specifies the name as string of the column that will supply the X values for the DataPoints.
yDataSource
Specifes the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
yFields
Specifies the comma-separated column name(s) that will supply the Y value(s) for the DataPoints.

Glossary Item Box

Binds the X value and Y values of the collection's DataPoints to the specified columns of the specified data sources.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindXY( _
   ByVal xDataSource As Object, _
   ByVal xField As String, _
   ByVal yDataSource As Object, _
   ByVal yFields As String _
)
C#
public void DataBindXY(
   object xDataSource,
   string xField,
   object yDataSource,
   string yFields
)

Parameters

xDataSource
Specifies the data source that will supply the X values for the DataPoints.
xField
Specifies the name as string of the column that will supply the X values for the DataPoints.
yDataSource
Specifes the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
yFields
Specifies the comma-separated column name(s) that will supply the Y value(s) for the DataPoints.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindXY(IEnumerable,IEnumerable[]) Method

[image]
ActiveReports 19 .NET Edition
DataBindXY(IEnumerable,IEnumerable[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(IEnumerable,IEnumerable[]) Method

xValueEnumerable
Specifies the data source that will supply the X values for the DataPoints. The first available column will be used.
yEnumerableValues
Specifies the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).

Glossary Item Box

Binds the X value and Y values of the collection's DataPoints to the first column(s) of the specified data source(s).

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindXY( _
   ByVal xValueEnumerable As IEnumerable, _
   ByVal ParamArray yEnumerableValues() As IEnumerable _
)
C#
public void DataBindXY(
   IEnumerable xValueEnumerable,
   params IEnumerable[] yEnumerableValues
)

Parameters

xValueEnumerable
Specifies the data source that will supply the X values for the DataPoints. The first available column will be used.
yEnumerableValues
Specifies the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindXY(Object[],Double[]) Method

[image]
ActiveReports 19 .NET Edition
DataBindXY(Object[],Double[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(Object[],Double[]) Method

xValues
Specifies the array of X values of the DataPoint object added to the collection.
yValues
Specifies the array of Y values of the doubles added to the collection.

Glossary Item Box

Binds the X value and Y values of the collection's DataPoints to a specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindXY( _
   ByVal xValues() As Object, _
   ByVal ParamArray yValues() As Double _
)
C#
public void DataBindXY(
   object[] xValues,
   params double[] yValues
)

Parameters

xValues
Specifies the array of X values of the DataPoint object added to the collection.
yValues
Specifies the array of Y values of the doubles added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY Method

[image]
ActiveReports 19 .NET Edition
DataBindY Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataBindY Method

Glossary Item Box

Binds the Y value(s) of the collection's DataPoints to a specified data source.

Overload List

Overload | Description
DataBindY(Object,String) | Binds the Y value(s) of the collection's DataPoints to the specified column(s) of the specified data source.
DataBindY(IEnumerable[]) | Binds the Y value(s) of the collection's DataPoints to the first column of the specified data source(s).
DataBindY(Double[]) | Binds the Y values of the collection's DataPoints to a specified data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindY(Object,String) Method

[image]
ActiveReports 19 .NET Edition
DataBindY(Object,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(Object,String) Method

yDataSource
Specifies the data source object that provides the Y value(s).
yFields
Specifies the data souce field(s) to which to bind DataPoints.

Glossary Item Box

Binds the Y value(s) of the collection's DataPoints to the specified column(s) of the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindY( _
   ByVal yDataSource As Object, _
   ByVal yFields As String _
)
C#
public void DataBindY(
   object yDataSource,
   string yFields
)

Parameters

yDataSource
Specifies the data source object that provides the Y value(s).
yFields
Specifies the data souce field(s) to which to bind DataPoints.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY(IEnumerable[]) Method

[image]
ActiveReports 19 .NET Edition
DataBindY(IEnumerable[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(IEnumerable[]) Method

yEnumerableValues
Specifies one or more comma-separated IEnumerable data sources.

Glossary Item Box

Binds the Y value(s) of the collection's DataPoints to the first column of the specified data source(s).

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindY( _
   ByVal ParamArray yEnumerableValues() As IEnumerable _
)
C#
public void DataBindY(
   params IEnumerable[] yEnumerableValues
)

Parameters

yEnumerableValues
Specifies one or more comma-separated IEnumerable data sources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY(Double[]) Method

[image]
ActiveReports 19 .NET Edition
DataBindY(Double[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(Double[]) Method

yValues

Glossary Item Box

Binds the Y values of the collection's DataPoints to a specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DataBindY( _
   ByVal ParamArray yValues() As Double _
)
C#
public void DataBindY(
   params double[] yValues
)

Parameters

yValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : IndexOf Method

value

The data point to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As DataPoint _
) As Integer
C#
public int IndexOf(
   DataPoint value
)

Parameters

value

The data point to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Insert Method

index
The index at which to insert the DataPoint.
value
The DataPoint to insert.

Glossary Item Box

Inserts the specified DataPoint into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As DataPoint _
)
C#
public void Insert(
   int index,
   DataPoint value
)

Parameters

index
The index at which to insert the DataPoint.
value
The DataPoint to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Remove Method

value

The DataPoint to remove.

Glossary Item Box

Removes the specified DataPoint from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As DataPoint _
)
C#
public void Remove(
   DataPoint value
)

Parameters

value

The DataPoint to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

Glossary Item Box

For a list of all members of this type, see DataPointsCollection members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the DataPoint at the specified index.
Top

See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Item Property

index
The index of the DataPoint.

Glossary Item Box

Gets or sets the DataPoint at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As DataPoint
C#
public DataPoint this[
   int index
]; {get; set;}

Parameters

index
The index of the DataPoint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Events

[image]
ActiveReports 19 .NET Edition
DataPointsCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

Glossary Item Box

For a list of all members of this type, see DataPointsCollection members.

Public Events

 | Name | Description
Public Event | Change | Occurs when the content of the DataPointsCollection changes.
Top

See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Change Event

[image]
ActiveReports 19 .NET Edition
Change Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Change Event

Glossary Item Box

Occurs when the content of the DataPointsCollection changes.

Syntax

Visual Basic (Declaration)
Public Event Change As EventHandler
C#
public event EventHandler Change

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection.Converter Class

[image]
ActiveReports 19 .NET Edition
DataPointsCollection.Converter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection.Converter Class

Glossary Item Box

Provides a way to process converting of instances ot DataPointsCollection class.

Object Model

DataPointsCollection.Converter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPointsCollection.Converter
   Inherits System.ComponentModel.ExpandableObjectConverter
C#
public sealed class DataPointsCollection.Converter : System.ComponentModel.ExpandableObjectConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
GrapeCity.ActiveReports.Chart.DataPointsCollection.Converter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Members
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection.Converter Class Members

[image]
ActiveReports 19 .NET Edition
DataPointsCollection.Converter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection.Converter Class

Glossary Item Box

The following tables list the members exposed by DataPointsCollection.Converter.

Public Constructors

 | Name | Description
Public Constructor | DataPointsCollection.Converter Constructor |
Top

Public Methods

 | Name | Description
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

DataPointsCollection.Converter Class
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection.Converter Constructor

[image]
ActiveReports 19 .NET Edition
DataPointsCollection.Converter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : DataPointsCollection.Converter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPointsCollection.Converter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


DataPointsCollection.Converter Class Methods

[image]
ActiveReports 19 .NET Edition
DataPointsCollection.Converter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection.Converter Class

Glossary Item Box

For a list of all members of this type, see DataPointsCollection.Converter members.

Public Methods

 | Name | Description
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

DataPointsCollection.Converter Class
GrapeCity.ActiveReports.Chart Namespace


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


DoubleArray Class

[image]
ActiveReports 19 .NET Edition
DoubleArray Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

Glossary Item Box

Represents the settings for the DoubleArray class.

Object Model

DoubleArray Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DoubleArray
   Inherits Item
C#
public sealed class DoubleArray : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.DoubleArray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Members
GrapeCity.ActiveReports.Chart Namespace


DoubleArray Class Members

[image]
ActiveReports 19 .NET Edition
DoubleArray Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

Glossary Item Box

The following tables list the members exposed by DoubleArray.

Public Constructors

 | Name | Description
Public Constructor | DoubleArray Constructor | Overloaded. Initializes a new instance of the DoubleArray class.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value at the index specified.
Public Property | Length | Gets the length of the double array.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the double array.
Public Method | IsDateTime | Gets a value indicating whether the double array is a DateTime array.
Public Method | SetIsDateTime | Sets the specified value at the specified index as a DateTime value.
Public Method | ToString | Overloaded. Converts the value of the current instance to its string representation.
Top

See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


DoubleArray Constructor

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : DoubleArray Constructor

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Overload List

Overload | Description
DoubleArray Constructor(Double[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(DateTime[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(Double[],Boolean[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(String,IFormatProvider) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(String) | Initializes a new instance of the DoubleArray class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


DoubleArray Constructor(Double[])

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor(Double[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(Double[])

data
Specifies the data for the array.

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Double _
)
C#
public DoubleArray(
   double[] data
)

Parameters

data
Specifies the data for the array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(DateTime[])

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor(DateTime[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(DateTime[])

data
Specifies the date time data for the array.

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Date _
)
C#
public DoubleArray(
   DateTime[] data
)

Parameters

data
Specifies the date time data for the array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(Double[],Boolean[])

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor(Double[],Boolean[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(Double[],Boolean[])

data

Specifies the data for the array.

isDateTime
Specifies whether the array values are DateTime values.

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Double, _
   ByVal isDateTime() As Boolean _
)
C#
public DoubleArray(
   double[] data,
   bool[] isDateTime
)

Parameters

data

Specifies the data for the array.

isDateTime
Specifies whether the array values are DateTime values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(String,IFormatProvider)

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor(String,IFormatProvider)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(String,IFormatProvider)

data
Specifies the data as string.
culture
Specifies the culture of the data.

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal culture As IFormatProvider _
)
C#
public DoubleArray(
   string data,
   IFormatProvider culture
)

Parameters

data
Specifies the data as string.
culture
Specifies the culture of the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(String)

[image]
ActiveReports 19 .NET Edition
DoubleArray Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(String)

data
Specifies the data as string.

Glossary Item Box

Initializes a new instance of the DoubleArray class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
C#
public DoubleArray(
   string data
)

Parameters

data
Specifies the data as string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleArray Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

Glossary Item Box

For a list of all members of this type, see DoubleArray members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the double array.
Public Method | IsDateTime | Gets a value indicating whether the double array is a DateTime array.
Public Method | SetIsDateTime | Sets the specified value at the specified index as a DateTime value.
Public Method | ToString | Overloaded. Converts the value of the current instance to its string representation.
Top

See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Clone Method

Glossary Item Box

Creates a clone of the double array.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


IsDateTime Method

[image]
ActiveReports 19 .NET Edition
IsDateTime Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : IsDateTime Method

index

Specifies the index of the double array.

Glossary Item Box

Gets a value indicating whether the double array is a DateTime array.

Syntax

Visual Basic (Declaration)
Public Function IsDateTime( _
   ByVal index As Integer _
) As Boolean
C#
public bool IsDateTime(
   int index
)

Parameters

index

Specifies the index of the double array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


SetIsDateTime Method

[image]
ActiveReports 19 .NET Edition
SetIsDateTime Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : SetIsDateTime Method

index

Specifies the index of the value to set.

value

Specifies the value.

Glossary Item Box

Sets the specified value at the specified index as a DateTime value.

Syntax

Visual Basic (Declaration)
Public Sub SetIsDateTime( _
   ByVal index As Integer, _
   ByVal value As Boolean _
)
C#
public void SetIsDateTime(
   int index,
   bool value
)

Parameters

index

Specifies the index of the value to set.

value

Specifies the value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Overload List

Overload | Description
ToString(IFormatProvider) | Converts the value of the current instance to its string representation according to the specified culture.
ToString() | Converts the value of the current instance to its string representation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


ToString(IFormatProvider) Method

[image]
ActiveReports 19 .NET Edition
ToString(IFormatProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > ToString Method : ToString(IFormatProvider) Method

culture
Specifies the culture to use.

Glossary Item Box

Converts the value of the current instance to its string representation according to the specified culture.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal culture As IFormatProvider _
) As String
C#
public string ToString(
   IFormatProvider culture
)

Parameters

culture
Specifies the culture to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


ToString() Method

[image]
ActiveReports 19 .NET Edition
ToString() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > ToString Method : ToString() Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Class Properties

[image]
ActiveReports 19 .NET Edition
DoubleArray Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

Glossary Item Box

For a list of all members of this type, see DoubleArray members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value at the index specified.
Public Property | Length | Gets the length of the double array.
Top

See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Item Property

i

Specifies the index of the value to get or set.

Glossary Item Box

Gets or sets the value at the index specified.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal i As Integer _
) As Double
C#
public double this[
   int i
]; {get; set;}

Parameters

i

Specifies the index of the value to get or set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


Length Property

[image]
ActiveReports 19 .NET Edition
Length Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Length Property

Glossary Item Box

Gets the length of the double array.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray Class
DoubleArray Members


DoubleArray.Converter Class

[image]
ActiveReports 19 .NET Edition
DoubleArray.Converter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray.Converter Class

Glossary Item Box

Provides a way to process converting of instances ot DoubleArray class.

Object Model

DoubleArray.Converter Class

Syntax

Visual Basic (Declaration)
Public Class DoubleArray.Converter
   Inherits System.ComponentModel.TypeConverter
C#
public class DoubleArray.Converter : System.ComponentModel.TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.Chart.DoubleArray.Converter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Members
GrapeCity.ActiveReports.Chart Namespace


DoubleArray.Converter Class Members

[image]
ActiveReports 19 .NET Edition
DoubleArray.Converter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray.Converter Class

Glossary Item Box

The following tables list the members exposed by DoubleArray.Converter.

Public Constructors

 | Name | Description
Public Constructor | DoubleArray.Converter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Top

See Also

Reference

DoubleArray.Converter Class
GrapeCity.ActiveReports.Chart Namespace


DoubleArray.Converter Constructor

[image]
ActiveReports 19 .NET Edition
DoubleArray.Converter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : DoubleArray.Converter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleArray.Converter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


DoubleArray.Converter Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleArray.Converter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray.Converter Class

Glossary Item Box

For a list of all members of this type, see DoubleArray.Converter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Top

See Also

Reference

DoubleArray.Converter Class
GrapeCity.ActiveReports.Chart Namespace


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : CanConvertFrom Method

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : CanConvertTo Method

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertTo Method

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
value
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
value
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


DoubleConverter Class

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverter Class

Glossary Item Box

this class is created to fix error of visualization in vs.net property grid values like 0.2 of double

Object Model

DoubleConverter Class

Syntax

Visual Basic (Declaration)
Public Class DoubleConverter
   Inherits System.ComponentModel.TypeConverter
C#
public class DoubleConverter : System.ComponentModel.TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.Chart.DoubleConverter
GrapeCity.ActiveReports.Chart.DoubleConverterWithAuto

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Members
GrapeCity.ActiveReports.Chart Namespace


DoubleConverter Class Members

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverter Class

Glossary Item Box

The following tables list the members exposed by DoubleConverter.

Public Constructors

 | Name | Description
Public Constructor | DoubleConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

DoubleConverter Class
GrapeCity.ActiveReports.Chart Namespace


DoubleConverter Constructor

[image]
ActiveReports 19 .NET Edition
DoubleConverter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : DoubleConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleConverter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


DoubleConverter Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverter Class

Glossary Item Box

For a list of all members of this type, see DoubleConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

DoubleConverter Class
GrapeCity.ActiveReports.Chart Namespace


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : CanConvertFrom Method

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : CanConvertTo Method

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


DoubleConverterWithAuto Class

[image]
ActiveReports 19 .NET Edition
DoubleConverterWithAuto Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverterWithAuto Class

Glossary Item Box

Converter for double with "automatic calculate" values support.

Object Model

DoubleConverterWithAuto Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DoubleConverterWithAuto
   Inherits DoubleConverter
C#
public sealed class DoubleConverterWithAuto : DoubleConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.Chart.DoubleConverter
GrapeCity.ActiveReports.Chart.DoubleConverterWithAuto

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Members
GrapeCity.ActiveReports.Chart Namespace


DoubleConverterWithAuto Class Members

[image]
ActiveReports 19 .NET Edition
DoubleConverterWithAuto Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverterWithAuto Class

Glossary Item Box

The following tables list the members exposed by DoubleConverterWithAuto.

Public Constructors

 | Name | Description
Public Constructor | DoubleConverterWithAuto Constructor |
Top

Public Methods

 | Name | Description
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetStandardValues | Overloaded. Overridden. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
Public Method | GetStandardValuesExclusive | Overloaded. Overridden. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
Top

See Also

Reference

DoubleConverterWithAuto Class
GrapeCity.ActiveReports.Chart Namespace


DoubleConverterWithAuto Constructor

[image]
ActiveReports 19 .NET Edition
DoubleConverterWithAuto Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : DoubleConverterWithAuto Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleConverterWithAuto()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


DoubleConverterWithAuto Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleConverterWithAuto Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleConverterWithAuto Class

Glossary Item Box

For a list of all members of this type, see DoubleConverterWithAuto members.

Public Methods

 | Name | Description
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetStandardValues | Overloaded. Overridden. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
Public Method | GetStandardValuesExclusive | Overloaded. Overridden. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
Top

See Also

Reference

DoubleConverterWithAuto Class
GrapeCity.ActiveReports.Chart Namespace


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetStandardValues Method

Glossary Item Box

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Overload List

Overload | Description
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context that can be used to extract additional information about the environment from which this converter is invoked. This parameter or properties of this parameter can be null.

Glossary Item Box

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public override TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context that can be used to extract additional information about the environment from which this converter is invoked. This parameter or properties of this parameter can be null.

Return Value

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetStandardValuesExclusive Method

Glossary Item Box

Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Overload List

Overload | Description
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Glossary Item Box

Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true if the TypeConverter.StandardValuesCollection returned from GetStandardValues is an exhaustive list of possible values; false if other values are possible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetStandardValuesSupported Method

Glossary Item Box

Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Overload List

Overload | Description
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Glossary Item Box

Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true if GetStandardValues should be called to find a common set of values the object supports; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


FontInfo Class

[image]
ActiveReports 19 .NET Edition
FontInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

Glossary Item Box

Represents the settings for the FontInfo class.

Object Model

FontInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FontInfo
   Inherits Item
C#
public sealed class FontInfo : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.FontInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Members
GrapeCity.ActiveReports.Chart Namespace


FontInfo Class Members

[image]
ActiveReports 19 .NET Edition
FontInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

Glossary Item Box

The following tables list the members exposed by FontInfo.

Public Constructors

 | Name | Description
Public Constructor | FontInfo Constructor | Overloaded. Initializes a new instance of the FontInfo class.
Top

Public Properties

 | Name | Description
Public Property | Angle | Gets or sets the clockwise rotation angle of the text in degrees.
Public Property | Color | Gets or sets the color of the text.
Public Property | Font | Gets or sets the font to use.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the FontInfo object.
Public Method | Equals | Compares the FontInfo object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


FontInfo Constructor

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : FontInfo Constructor

Glossary Item Box

Initializes a new instance of the FontInfo class.

Overload List

Overload | Description
FontInfo Constructor(Color,Font,Single) | Initializes a new instance of the FontInfo class with the parameters specified.
FontInfo Constructor(Color,Font) | Initializes a new instance of the FontInfo class with the parameters specified.
FontInfo Constructor() | Initializes a new instance of the FontInfo class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Constructor(Color,Font,Single)

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor(Color,Font,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(Color,Font,Single)

color

Specifies the text color to use.

font
Specifies the System font to use.
angle
Specifies the text angle in degrees.

Glossary Item Box

Initializes a new instance of the FontInfo class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal font As Font, _
   ByVal angle As Single _
)
C#
public FontInfo(
   Color color,
   Font font,
   float angle
)

Parameters

color

Specifies the text color to use.

font
Specifies the System font to use.
angle
Specifies the text angle in degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor(Color,Font)

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor(Color,Font)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(Color,Font)

color

Specifies the text color to use.

font
Specifies the System font to use.

Glossary Item Box

Initializes a new instance of the FontInfo class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal font As Font _
)
C#
public FontInfo(
   Color color,
   Font font
)

Parameters

color

Specifies the text color to use.

font
Specifies the System font to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor()

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor()

Glossary Item Box

Initializes a new instance of the FontInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FontInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Class Methods

[image]
ActiveReports 19 .NET Edition
FontInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

Glossary Item Box

For a list of all members of this type, see FontInfo members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the FontInfo object.
Public Method | Equals | Compares the FontInfo object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Clone Method

Glossary Item Box

Creates a clone of the FontInfo object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the FontInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Equals Method

obj
The System.Object to which the FontInfo object is being compared

Glossary Item Box

Compares the FontInfo object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the FontInfo object is being compared

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Class Properties

[image]
ActiveReports 19 .NET Edition
FontInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

Glossary Item Box

For a list of all members of this type, see FontInfo members.

Public Properties

 | Name | Description
Public Property | Angle | Gets or sets the clockwise rotation angle of the text in degrees.
Public Property | Color | Gets or sets the color of the text.
Public Property | Font | Gets or sets the font to use.
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Angle Property

Glossary Item Box

Gets or sets the clockwise rotation angle of the text in degrees.

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Color Property

Glossary Item Box

Gets or sets the color of the text.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Font Property

Glossary Item Box

Gets or sets the font to use.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


GraphMouseEventArgs Class

[image]
ActiveReports 19 .NET Edition
GraphMouseEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class

Glossary Item Box

Represents the properties of the mouse event arguments for the chart.

Object Model

GraphMouseEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GraphMouseEventArgs
   Inherits System.EventArgs
C#
public sealed class GraphMouseEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Chart.GraphMouseEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Members
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
GraphMouseEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class

Glossary Item Box

The following tables list the members exposed by GraphMouseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | GraphMouseEventArgs Constructor | Initializes a new instance of the GraphMouseEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Graph | Gets the graph
Public Property | IsLeftMouseButton | Gets mouse event button state
Public Property | PointIndex | Gets a count of the number of times the item was clicked.
Public Property | ShapeArea | Gets Shape Area on which mouse event occured on
Public Property | SourcePoint | Gets source point on which mouse event occured on
Public Property | UserPoint | Gets user point on which mouse event occured on
Top

See Also

Reference

GraphMouseEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
GraphMouseEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : GraphMouseEventArgs Constructor

graph
shapeArea
sourcePoint
isLeftMouseButton
pointIndex

Glossary Item Box

Initializes a new instance of the GraphMouseEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graph As ISharpGraph, _
   ByVal shapeArea As ShapeArea, _
   ByVal sourcePoint As Point, _
   ByVal isLeftMouseButton As Boolean, _
   Optional ByVal pointIndex As Integer _
)
C#
public GraphMouseEventArgs(
   ISharpGraph graph,
   ShapeArea shapeArea,
   Point sourcePoint,
   bool isLeftMouseButton,
   int pointIndex
)

Parameters

graph
shapeArea
sourcePoint
isLeftMouseButton
pointIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


GraphMouseEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
GraphMouseEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class

Glossary Item Box

For a list of all members of this type, see GraphMouseEventArgs members.

Public Properties

 | Name | Description
Public Property | Graph | Gets the graph
Public Property | IsLeftMouseButton | Gets mouse event button state
Public Property | PointIndex | Gets a count of the number of times the item was clicked.
Public Property | ShapeArea | Gets Shape Area on which mouse event occured on
Public Property | SourcePoint | Gets source point on which mouse event occured on
Public Property | UserPoint | Gets user point on which mouse event occured on
Top

See Also

Reference

GraphMouseEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


Graph Property

[image]
ActiveReports 19 .NET Edition
Graph Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Graph Property

Glossary Item Box

Gets the graph

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Graph As ISharpGraph
C#
public ISharpGraph Graph {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


IsLeftMouseButton Property

[image]
ActiveReports 19 .NET Edition
IsLeftMouseButton Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : IsLeftMouseButton Property

Glossary Item Box

Gets mouse event button state

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLeftMouseButton As Boolean
C#
public bool IsLeftMouseButton {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


PointIndex Property

[image]
ActiveReports 19 .NET Edition
PointIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : PointIndex Property

Glossary Item Box

Gets a count of the number of times the item was clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PointIndex As Integer
C#
public int PointIndex {get;}

Remarks

This property was previously called ItemCount. ItemCount is now an obsolete property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


ShapeArea Property

[image]
ActiveReports 19 .NET Edition
ShapeArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : ShapeArea Property

Glossary Item Box

Gets Shape Area on which mouse event occured on

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShapeArea As ShapeArea
C#
public ShapeArea ShapeArea {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


SourcePoint Property

[image]
ActiveReports 19 .NET Edition
SourcePoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : SourcePoint Property

Glossary Item Box

Gets source point on which mouse event occured on

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourcePoint As Point
C#
public Point SourcePoint {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


UserPoint Property

[image]
ActiveReports 19 .NET Edition
UserPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : UserPoint Property

Glossary Item Box

Gets user point on which mouse event occured on

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserPoint As PointF
C#
public PointF UserPoint {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


GraphReferenceConverter Class

[image]
ActiveReports 19 .NET Edition
GraphReferenceConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphReferenceConverter Class

Glossary Item Box

Provides a unified way to process converting.

Object Model

GraphReferenceConverter Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GraphReferenceConverter
   Inherits System.ComponentModel.TypeConverter
C#
public abstract class GraphReferenceConverter : System.ComponentModel.TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.Chart.GraphReferenceConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Members
GrapeCity.ActiveReports.Chart Namespace


GraphReferenceConverter Class Members

[image]
ActiveReports 19 .NET Edition
GraphReferenceConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphReferenceConverter Class

Glossary Item Box

The following tables list the members exposed by GraphReferenceConverter.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetStandardValues | Overloaded. Overridden. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
Public Method | GetStandardValuesExclusive | Overloaded. Overridden. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
Top

See Also

Reference

GraphReferenceConverter Class
GrapeCity.ActiveReports.Chart Namespace


GraphReferenceConverter Class Methods

[image]
ActiveReports 19 .NET Edition
GraphReferenceConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphReferenceConverter Class

Glossary Item Box

For a list of all members of this type, see GraphReferenceConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetStandardValues | Overloaded. Overridden. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
Public Method | GetStandardValuesExclusive | Overloaded. Overridden. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
Top

See Also

Reference

GraphReferenceConverter Class
GrapeCity.ActiveReports.Chart Namespace


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : CanConvertFrom Method

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Typethat represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : CanConvertTo Method

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetStandardValues Method

Glossary Item Box

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Overload List

Overload | Description
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context that can be used to extract additional information about the environment from which this converter is invoked. This parameter or properties of this parameter can be null.

Glossary Item Box

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public override TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context that can be used to extract additional information about the environment from which this converter is invoked. This parameter or properties of this parameter can be null.

Return Value

Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetStandardValuesExclusive Method

Glossary Item Box

Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Overload List

Overload | Description
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Glossary Item Box

Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true if the TypeConverter.StandardValuesCollection returned from GetStandardValues is an exhaustive list of possible values; false if other values are possible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetStandardValuesSupported Method

Glossary Item Box

Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Overload List

Overload | Description
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Glossary Item Box

Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true if GetStandardValues should be called to find a common set of values the object supports; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GraphXmlNonSerializableAttribute Class

[image]
ActiveReports 19 .NET Edition
GraphXmlNonSerializableAttribute Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlNonSerializableAttribute Class

Glossary Item Box

Object Model

GraphXmlNonSerializableAttribute Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GraphXmlNonSerializableAttribute
   Inherits System.Attribute
C#
public sealed class GraphXmlNonSerializableAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Chart.GraphXmlNonSerializableAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Members
GrapeCity.ActiveReports.Chart Namespace


GraphXmlNonSerializableAttribute Class Members

[image]
ActiveReports 19 .NET Edition
GraphXmlNonSerializableAttribute Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlNonSerializableAttribute Class

Glossary Item Box

The following tables list the members exposed by GraphXmlNonSerializableAttribute.

Public Constructors

 | Name | Description
Public Constructor | GraphXmlNonSerializableAttribute Constructor |
Top

See Also

Reference

GraphXmlNonSerializableAttribute Class
GrapeCity.ActiveReports.Chart Namespace


GraphXmlNonSerializableAttribute Constructor

[image]
ActiveReports 19 .NET Edition
GraphXmlNonSerializableAttribute Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : GraphXmlNonSerializableAttribute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GraphXmlNonSerializableAttribute()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


GraphXmlSerializationContext Class

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlSerializationContext Class

Glossary Item Box

Represents contextual information about a serialization, such as its DirectionType, document and other.

Object Model

GraphXmlSerializationContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GraphXmlSerializationContext
C#
public sealed class GraphXmlSerializationContext

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.GraphXmlSerializationContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlSerializationContext Members
GrapeCity.ActiveReports.Chart Namespace


GraphXmlSerializationContext Class Members

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlSerializationContext Class

Glossary Item Box

The following tables list the members exposed by GraphXmlSerializationContext.

Public Constructors

 | Name | Description
Public Constructor | GraphXmlSerializationContext Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Fonts |
Top

See Also

Reference

GraphXmlSerializationContext Class
GrapeCity.ActiveReports.Chart Namespace


GraphXmlSerializationContext Constructor

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlSerializationContext Class : GraphXmlSerializationContext Constructor

Glossary Item Box

For internal use only.

Overload List

Overload | Description
GraphXmlSerializationContext Constructor(ISharpGraph,DirectionType,XmlDocument,Boolean) | Initializes a new instance of the GraphXmlSerializationContext class.
GraphXmlSerializationContext Constructor(DirectionType,XmlDocument,Boolean,Boolean) | Initializes a new instance of the GraphXmlSerializationContext Class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlSerializationContext Class
GraphXmlSerializationContext Members


GraphXmlSerializationContext Constructor(ISharpGraph,DirectionType,XmlDocument,Boolean)

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Constructor(ISharpGraph,DirectionType,XmlDocument,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlSerializationContext Class > GraphXmlSerializationContext Constructor : GraphXmlSerializationContext Constructor(ISharpGraph,DirectionType,XmlDocument,Boolean)

sharpGraph
A SharpGraph control
direction
Direction to serialize - from xml or to xml
doc
An XmlDocument
includeData

Glossary Item Box

Initializes a new instance of the GraphXmlSerializationContext class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sharpGraph As ISharpGraph, _
   ByVal direction As GraphXmlSerializationContext.DirectionType, _
   ByVal doc As XmlDocument, _
   ByVal includeData As Boolean _
)
C#
public GraphXmlSerializationContext(
   ISharpGraph sharpGraph,
   GraphXmlSerializationContext.DirectionType direction,
   XmlDocument doc,
   bool includeData
)

Parameters

sharpGraph
A SharpGraph control
direction
Direction to serialize - from xml or to xml
doc
An XmlDocument
includeData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlSerializationContext Class
GraphXmlSerializationContext Members
Overload List


GraphXmlSerializationContext Constructor(DirectionType,XmlDocument,Boolean,Boolean)

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Constructor(DirectionType,XmlDocument,Boolean,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlSerializationContext Class > GraphXmlSerializationContext Constructor : GraphXmlSerializationContext Constructor(DirectionType,XmlDocument,Boolean,Boolean)

direction
Direction to serialize - from xml or to xml
doc
An XmlDocument
includeData
useComponentReferences

Glossary Item Box

Initializes a new instance of the GraphXmlSerializationContext Class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal direction As GraphXmlSerializationContext.DirectionType, _
   ByVal doc As XmlDocument, _
   ByVal includeData As Boolean, _
   ByVal useComponentReferences As Boolean _
)
C#
public GraphXmlSerializationContext(
   GraphXmlSerializationContext.DirectionType direction,
   XmlDocument doc,
   bool includeData,
   bool useComponentReferences
)

Parameters

direction
Direction to serialize - from xml or to xml
doc
An XmlDocument
includeData
useComponentReferences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlSerializationContext Class
GraphXmlSerializationContext Members
Overload List


GraphXmlSerializationContext Class Properties

[image]
ActiveReports 19 .NET Edition
GraphXmlSerializationContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlSerializationContext Class

Glossary Item Box

For a list of all members of this type, see GraphXmlSerializationContext members.

Public Properties

 | Name | Description
Public Property | Fonts |
Top

See Also

Reference

GraphXmlSerializationContext Class
GrapeCity.ActiveReports.Chart Namespace


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlSerializationContext Class : Fonts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fonts As IDictionary(Of String,Font)
C#
public IDictionary<string,Font> Fonts {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlSerializationContext Class
GraphXmlSerializationContext Members


GridLayout Class

[image]
ActiveReports 19 .NET Edition
GridLayout Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

Glossary Item Box

Represents the settings for the GridLayout object.

Object Model

GridLayout Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridLayout
   Inherits Item
C#
public sealed class GridLayout : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.GridLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Members
GrapeCity.ActiveReports.Chart Namespace


GridLayout Class Members

[image]
ActiveReports 19 .NET Edition
GridLayout Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

Glossary Item Box

The following tables list the members exposed by GridLayout.

Public Constructors

 | Name | Description
Public Constructor | GridLayout Constructor | Overloaded. Initializes a new instance of the GridLayout class.
Top

Public Properties

 | Name | Description
Public Property | Columns | Gets or sets the number of columns for the GridLayout.
Public Property | Rows | Gets or sets the number of rows for the GridLayout.
Public Property | Size | Gets the size of the GridLayout.
Top

Public Methods

 | Name | Description
Public Method | DecreaseSize | Decreases the grid layout size by one column or one row at a time.
Public Method | Equals | Compares the GridLayout object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IncreaseSize | Increases the grid layout size by one column or one row at a time.
Top

See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


GridLayout Constructor

[image]
ActiveReports 19 .NET Edition
GridLayout Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : GridLayout Constructor

Glossary Item Box

Initializes a new instance of the GridLayout class.

Overload List

Overload | Description
GridLayout Constructor() | Initializes a new instance of the GridLayout class.
GridLayout Constructor(Int32,Int32) | Initializes a new instance of the GridLayout class with the specified number of rows and columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


GridLayout Constructor()

[image]
ActiveReports 19 .NET Edition
GridLayout Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class > GridLayout Constructor : GridLayout Constructor()

Glossary Item Box

Initializes a new instance of the GridLayout class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members
Overload List


GridLayout Constructor(Int32,Int32)

[image]
ActiveReports 19 .NET Edition
GridLayout Constructor(Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class > GridLayout Constructor : GridLayout Constructor(Int32,Int32)

rows

Specifies the number of rows.

columns
Specifies the number of columns.

Glossary Item Box

Initializes a new instance of the GridLayout class with the specified number of rows and columns.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rows As Integer, _
   ByVal columns As Integer _
)
C#
public GridLayout(
   int rows,
   int columns
)

Parameters

rows

Specifies the number of rows.

columns
Specifies the number of columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members
Overload List


GridLayout Class Methods

[image]
ActiveReports 19 .NET Edition
GridLayout Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

Glossary Item Box

For a list of all members of this type, see GridLayout members.

Public Methods

 | Name | Description
Public Method | DecreaseSize | Decreases the grid layout size by one column or one row at a time.
Public Method | Equals | Compares the GridLayout object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IncreaseSize | Increases the grid layout size by one column or one row at a time.
Top

See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


DecreaseSize Method

[image]
ActiveReports 19 .NET Edition
DecreaseSize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : DecreaseSize Method

Glossary Item Box

Decreases the grid layout size by one column or one row at a time.

Syntax

Visual Basic (Declaration)
Public Sub DecreaseSize()
C#
public void DecreaseSize()

Remarks

For example, if a GridLayout has two rows and two columns, the first call to the DecreaseSize method will subtract one column, and the second call will subtract one row. If a GridLayout has two rows and three columns, the first call to the DecreaseSize method will subtract one column, and the second call will subtract one row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Equals Method

obj

The System.Object to which the GridLayout object is being compared.

Glossary Item Box

Compares the GridLayout object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

The System.Object to which the GridLayout object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


IncreaseSize Method

[image]
ActiveReports 19 .NET Edition
IncreaseSize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : IncreaseSize Method

Glossary Item Box

Increases the grid layout size by one column or one row at a time.

Syntax

Visual Basic (Declaration)
Public Sub IncreaseSize()
C#
public void IncreaseSize()

Remarks

For example, if a GridLayout has one row and one column, the first call to the IncreaseSize method will add one column, and the second call will add one row. If a GridLayout has one row and two columns, the first call to the IncreaseSize method will add one row, and the second call will add one column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


GridLayout Class Properties

[image]
ActiveReports 19 .NET Edition
GridLayout Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

Glossary Item Box

For a list of all members of this type, see GridLayout members.

Public Properties

 | Name | Description
Public Property | Columns | Gets or sets the number of columns for the GridLayout.
Public Property | Rows | Gets or sets the number of rows for the GridLayout.
Public Property | Size | Gets the size of the GridLayout.
Top

See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Columns Property

Glossary Item Box

Gets or sets the number of columns for the GridLayout.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
C#
public int Columns {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Rows Property

Glossary Item Box

Gets or sets the number of rows for the GridLayout.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
C#
public int Rows {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Size Property

Glossary Item Box

Gets the size of the GridLayout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
C#
public int Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLayout Class
GridLayout Members


HitTest Class

[image]
ActiveReports 19 .NET Edition
HitTest Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class

Glossary Item Box

Represents the properties of the HitTest object.

Object Model

HitTest Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class HitTest
C#
public sealed class HitTest

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.HitTest

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTest Members
GrapeCity.ActiveReports.Chart Namespace


HitTest Class Members

[image]
ActiveReports 19 .NET Edition
HitTest Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class

Glossary Item Box

The following tables list the members exposed by HitTest.

Public Properties

 | Name | Description
Public Property | Item | Gets the chart item that is located at specified coordinates.
Public Property | ItemCount | Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).
Top

See Also

Reference

HitTest Class
GrapeCity.ActiveReports.Chart Namespace


HitTest Class Properties

[image]
ActiveReports 19 .NET Edition
HitTest Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class

Glossary Item Box

For a list of all members of this type, see HitTest members.

Public Properties

 | Name | Description
Public Property | Item | Gets the chart item that is located at specified coordinates.
Public Property | ItemCount | Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).
Top

See Also

Reference

HitTest Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > HitTest Class : Item Property

Glossary Item Box

Gets the chart item that is located at specified coordinates.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As Item
C#
public Item Item {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTest Class
HitTest Members


ItemCount Property

[image]
ActiveReports 19 .NET Edition
ItemCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > HitTest Class : ItemCount Property

Glossary Item Box

Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
C#
public int ItemCount {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTest Class
HitTest Members


KeyValuePair Class

[image]
ActiveReports 19 .NET Edition
KeyValuePair Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class

Glossary Item Box

Represents the settings for the KeyValuePair object.

Object Model

KeyValuePair Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class KeyValuePair
C#
public sealed class KeyValuePair

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.KeyValuePair

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Members
GrapeCity.ActiveReports.Chart Namespace


KeyValuePair Class Members

[image]
ActiveReports 19 .NET Edition
KeyValuePair Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class

Glossary Item Box

The following tables list the members exposed by KeyValuePair.

Public Constructors

 | Name | Description
Public Constructor | KeyValuePair Constructor | Overloaded. Initializes a new instance of the KeyValuePair class.
Top

Public Properties

 | Name | Description
Public Property | IsPointOverridable | Gets a value indicating whether the point can be overriden.
Public Property | Key | Gets the name of the custom property as string.
Public Property | Validator | Gets the property validator.
Public Property | Value | Gets the value of the object.
Top

See Also

Reference

KeyValuePair Class
GrapeCity.ActiveReports.Chart Namespace


KeyValuePair Constructor

[image]
ActiveReports 19 .NET Edition
KeyValuePair Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : KeyValuePair Constructor

Glossary Item Box

Initializes a new instance of the KeyValuePair class.

Overload List

Overload | Description
KeyValuePair Constructor(String,Object) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,Boolean) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean) | Initializes a new instance of the KeyValuePair class with the parameters specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members


KeyValuePair Constructor(String,Object)

[image]
ActiveReports 19 .NET Edition
KeyValuePair Constructor(String,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object)

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.

Glossary Item Box

Initializes a new instance of the KeyValuePair class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal value As Object _
)
C#
public KeyValuePair(
   string key,
   object value
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,Boolean)

[image]
ActiveReports 19 .NET Edition
KeyValuePair Constructor(String,Object,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,Boolean)

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
isPointOverridable
Specifies whether the point is overridable.

Glossary Item Box

Initializes a new instance of the KeyValuePair class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal value As Object, _
   ByVal isPointOverridable As Boolean _
)
C#
public KeyValuePair(
   string key,
   object value,
   bool isPointOverridable
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
isPointOverridable
Specifies whether the point is overridable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)

[image]
ActiveReports 19 .NET Edition
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.

Glossary Item Box

Initializes a new instance of the KeyValuePair class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal value As Object, _
   ByVal validator As ICustomPropertyValueValidator _
)
C#
public KeyValuePair(
   string key,
   object value,
   ICustomPropertyValueValidator validator
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)

[image]
ActiveReports 19 .NET Edition
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.
isPointOverridable
Specifies whether the point is overridable.

Glossary Item Box

Initializes a new instance of the KeyValuePair class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal value As Object, _
   ByVal validator As ICustomPropertyValueValidator, _
   ByVal isPointOverridable As Boolean _
)
C#
public KeyValuePair(
   string key,
   object value,
   ICustomPropertyValueValidator validator,
   bool isPointOverridable
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.
isPointOverridable
Specifies whether the point is overridable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Class Properties

[image]
ActiveReports 19 .NET Edition
KeyValuePair Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class

Glossary Item Box

For a list of all members of this type, see KeyValuePair members.

Public Properties

 | Name | Description
Public Property | IsPointOverridable | Gets a value indicating whether the point can be overriden.
Public Property | Key | Gets the name of the custom property as string.
Public Property | Validator | Gets the property validator.
Public Property | Value | Gets the value of the object.
Top

See Also

Reference

KeyValuePair Class
GrapeCity.ActiveReports.Chart Namespace


IsPointOverridable Property

[image]
ActiveReports 19 .NET Edition
IsPointOverridable Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : IsPointOverridable Property

Glossary Item Box

Gets a value indicating whether the point can be overriden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPointOverridable As Boolean
C#
public bool IsPointOverridable {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Key Property

Glossary Item Box

Gets the name of the custom property as string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Key As String
C#
public string Key {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members


Validator Property

[image]
ActiveReports 19 .NET Edition
Validator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Validator Property

Glossary Item Box

Gets the property validator.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Validator As ICustomPropertyValueValidator
C#
public ICustomPropertyValueValidator Validator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Value Property

Glossary Item Box

Gets the value of the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePair Class
KeyValuePair Members


LabelInfo Class

[image]
ActiveReports 19 .NET Edition
LabelInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

Glossary Item Box

Represents the settings for the LabelInfo class.

Object Model

LabelInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LabelInfo
   Inherits DrawCustomizableItem
C#
public sealed class LabelInfo : DrawCustomizableItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LabelInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Members
GrapeCity.ActiveReports.Chart Namespace


LabelInfo Class Members

[image]
ActiveReports 19 .NET Edition
LabelInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

Glossary Item Box

The following tables list the members exposed by LabelInfo.

Public Constructors

 | Name | Description
Public Constructor | LabelInfo Constructor | Overloaded. Initializes a new instance of the LabelInfo class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the label alignment around the anchor point.
Public Property | Backdrop | Gets or sets the backdrop information to be used for the label.
Public Property | Border | Gets or sets the border information used to outline the label.
Public Property | Font | Gets or sets the FontInfo information used to draw the text of the label.
Public Property | Format | Gets or sets the format string used to draw the label.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LabelInfo object.
Public Method | Equals | Compares the LabelInfo object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


LabelInfo Constructor

[image]
ActiveReports 19 .NET Edition
LabelInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : LabelInfo Constructor

Glossary Item Box

Initializes a new instance of the LabelInfo class.

Overload List

Overload | Description
LabelInfo Constructor() | Initializes a new instance of the LabelInfo class.
LabelInfo Constructor(AntiAliasMode) | Initializes a new instance of the LabelInfo class with the AntiAliasMode specified.
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment) | Initializes a new instance of the LabelInfo class with the parameters specified.
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode) | Initializes a new instance of the LabelInfo class with the parameters specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


LabelInfo Constructor()

[image]
ActiveReports 19 .NET Edition
LabelInfo Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor()

Glossary Item Box

Initializes a new instance of the LabelInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LabelInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
LabelInfo Constructor(AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(AntiAliasMode)

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the LabelInfo class with the AntiAliasMode specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public LabelInfo(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)

[image]
ActiveReports 19 .NET Edition
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

Glossary Item Box

Initializes a new instance of the LabelInfo class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal border As Line, _
   ByVal backdrop As Backdrop, _
   ByVal font As FontInfo, _
   ByVal format As String, _
   ByVal alignment As Alignment _
)
C#
public LabelInfo(
   Line border,
   Backdrop backdrop,
   FontInfo font,
   string format,
   Alignment alignment
)

Parameters

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the LabelInfo class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal border As Line, _
   ByVal backdrop As Backdrop, _
   ByVal font As FontInfo, _
   ByVal format As String, _
   ByVal alignment As Alignment, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public LabelInfo(
   Line border,
   Backdrop backdrop,
   FontInfo font,
   string format,
   Alignment alignment,
   AntiAliasMode antiAliasMode
)

Parameters

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Class Methods

[image]
ActiveReports 19 .NET Edition
LabelInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

Glossary Item Box

For a list of all members of this type, see LabelInfo members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LabelInfo object.
Public Method | Equals | Compares the LabelInfo object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Clone Method

Glossary Item Box

Creates a clone of the LabelInfo object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the LabelInfo object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Equals Method

obj
The System.Object to which the LabelInfo object is being compared.

Glossary Item Box

Compares the LabelInfo object to another System.Object to see if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the LabelInfo object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


LabelInfo Class Properties

[image]
ActiveReports 19 .NET Edition
LabelInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

Glossary Item Box

For a list of all members of this type, see LabelInfo members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the label alignment around the anchor point.
Public Property | Backdrop | Gets or sets the backdrop information to be used for the label.
Public Property | Border | Gets or sets the border information used to outline the label.
Public Property | Font | Gets or sets the FontInfo information used to draw the text of the label.
Public Property | Format | Gets or sets the format string used to draw the label.
Top

See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Alignment Property

Glossary Item Box

Gets or sets the label alignment around the anchor point.

Syntax

Visual Basic (Declaration)
Public Property Alignment As Alignment
C#
public Alignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members
Alignment Enumeration


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information to be used for the label.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Border Property

Glossary Item Box

Gets or sets the border information used to outline the label.

Syntax

Visual Basic (Declaration)
Public Property Border As Line
C#
public Line Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Font Property

Glossary Item Box

Gets or sets the FontInfo information used to draw the text of the label.

Syntax

Visual Basic (Declaration)
Public Property Font As FontInfo
C#
public FontInfo Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Format Property

Glossary Item Box

Gets or sets the format string used to draw the label.

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format {get; set;}

Remarks

The ActiveReports chart control use standard Visual Studio .NET formatting syntax. The format is {Tag : Format}. For example, {Value:C} would format the text as currency. {Value:D} would format the text as a date.

Tag (variable) | Description | Example
Index | Point's index |
Value | Data value. The same as Value0 for category-based renderers, Value2 - for BubbleXY graphs, etc. | {Value}
Value# [1] | Zero-based integer indicating series value. | {Value0}
Total | Series total (sum of all points in this series) |
Pct | Is equal to Value/Total |
Pct[#] | Is equal to Value#/Total |
Xvalue | Point's X-value. X-value for XY-charts. The same as point index for category based charts. |
PTotal | Sum of all series values on this layer for this point |
PPct | Is equal to Value/PointTotal |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelInfo Class
LabelInfo Members


LabelsCollection Class

[image]
ActiveReports 19 .NET Edition
LabelsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

Glossary Item Box

Specifies the settings for the labels collection.

Object Model

LabelsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LabelsCollection
C#
public sealed class LabelsCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LabelsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LabelsCollection Class Members

[image]
ActiveReports 19 .NET Edition
LabelsCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

Glossary Item Box

The following tables list the members exposed by LabelsCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of labels in the collection.
Public Property | Item | Gets or sets the specified label in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a label to the collection.
Public Method | AddRange | Adds a set of labels to the collection.
Public Method | Clear | Clears all labels from the collection.
Public Method | Clone | Creates a clone of the labels collection.
Public Method | Contains | Determines whether the collection contains the specified label.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | GetLabels | Gets a string array of the labels in the collection.
Public Method | IndexOf | Returns the index of the first occurrence of a label in the collection.
Public Method | Insert | Inserts the specified label into the collection at the specified index.
Public Method | Remove | Removes the specified label from the collection.
Public Method | RemoveAt | Removes the label at the specified location from the collection.
Top

See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LabelsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
LabelsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

Glossary Item Box

For a list of all members of this type, see LabelsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a label to the collection.
Public Method | AddRange | Adds a set of labels to the collection.
Public Method | Clear | Clears all labels from the collection.
Public Method | Clone | Creates a clone of the labels collection.
Public Method | Contains | Determines whether the collection contains the specified label.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | GetLabels | Gets a string array of the labels in the collection.
Public Method | IndexOf | Returns the index of the first occurrence of a label in the collection.
Public Method | Insert | Inserts the specified label into the collection at the specified index.
Public Method | Remove | Removes the specified label from the collection.
Public Method | RemoveAt | Removes the label at the specified location from the collection.
Top

See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Add Method

value
The label to add to the collection.

Glossary Item Box

Adds a label to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As String _
) As Integer
C#
public int Add(
   string value
)

Parameters

value
The label to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : AddRange Method

value
The labels to add to the collection.

Glossary Item Box

Adds a set of labels to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As String _
)
C#
public void AddRange(
   string[] value
)

Parameters

value
The labels to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Clear Method

Glossary Item Box

Clears all labels from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Clone Method

Glossary Item Box

Creates a clone of the labels collection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Contains Method

value

The label for which to check.

Glossary Item Box

Determines whether the collection contains the specified label.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As String _
) As Boolean
C#
public bool Contains(
   string value
)

Parameters

value

The label for which to check.

Return Value

True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the collection to an array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As CustomAxis, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   CustomAxis[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


GetLabels Method

[image]
ActiveReports 19 .NET Edition
GetLabels Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : GetLabels Method

Glossary Item Box

Gets a string array of the labels in the collection.

Syntax

Visual Basic (Declaration)
Public Function GetLabels() As String()
C#
public string[] GetLabels()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : IndexOf Method

value
The label to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a label in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As String _
) As Integer
C#
public int IndexOf(
   string value
)

Parameters

value
The label to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Insert Method

index
The index at which to insert the label.
value
The label to insert.

Glossary Item Box

Inserts the specified label into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As String _
)
C#
public void Insert(
   int index,
   string value
)

Parameters

index
The index at which to insert the label.
value
The label to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Remove Method

value
The label to remove

Glossary Item Box

Removes the specified label from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As String _
)
C#
public void Remove(
   string value
)

Parameters

value
The label to remove

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : RemoveAt Method

index
The index of the label to remove.

Glossary Item Box

Removes the label at the specified location from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the label to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


LabelsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
LabelsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

Glossary Item Box

For a list of all members of this type, see LabelsCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of labels in the collection.
Public Property | Item | Gets or sets the specified label in the collection.
Top

See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Count Property

Glossary Item Box

Gets the count of labels in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Item Property

index
Specifies the index of the label.

Glossary Item Box

Gets or sets the specified label in the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As String
C#
public string this[
   int index
]; {get; set;}

Parameters

index
Specifies the index of the label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Legend Class

[image]
ActiveReports 19 .NET Edition
Legend Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

Glossary Item Box

Represents the settings for the Legend object.

Object Model

Legend Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Legend
   Inherits DrawCustomizableComponent
C#
public sealed class Legend : DrawCustomizableComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Legend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Members
GrapeCity.ActiveReports.Chart Namespace


Legend Class Members

[image]
ActiveReports 19 .NET Edition
Legend Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

Glossary Item Box

The following tables list the members exposed by Legend.

Public Constructors

 | Name | Description
Public Constructor | Legend Constructor | Initializes new instance of the LegendItem object with the default properties set
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the floating legend alignment within the chart area.
Public Property | Backdrop | Gets or sets the backdrop information with which to fill the legend box.
Public Property | Border | Gets or sets the border information with which to outline the legend box.
Public Property | CustomBorderDrawer | Gets or sets the custom draw object.
Public Property | DockArea | Gets or sets the chart area to which the legend is docked.
Public Property | DockInsideArea | Gets or sets a value indicating whether the legend will be docked inside the containing area.
Public Property | Footer | Gets or sets the footer title for the Legend.
Public Property | GridLayout | Gets or sets the grid layout for the Legend.
Public Property | Header | Gets or sets the header title for the legend.
Public Property | LabelsFont | Gets or sets the label font information used for the Legend.
Public Property | LegendItems | Gets the custom legend items collection.
Public Property | MarginX | Gets or sets the floating legend horizontal margin.
Public Property | MarginY | Gets or sets the floating legend vertical margin.
Public Property | Visible | Gets or sets a value indicating whether the legend is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Legend object.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Legend Constructor()

[image]
ActiveReports 19 .NET Edition
Legend Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class > Legend Constructor : Legend Constructor()

Glossary Item Box

Initializes new instance of the LegendItem object with the default properties set

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Legend()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members
Overload List


Legend Class Methods

[image]
ActiveReports 19 .NET Edition
Legend Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

Glossary Item Box

For a list of all members of this type, see Legend members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Legend object.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Clone Method

Glossary Item Box

Creates a clone of the Legend object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Legend object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Legend Class Properties

[image]
ActiveReports 19 .NET Edition
Legend Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

Glossary Item Box

For a list of all members of this type, see Legend members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the floating legend alignment within the chart area.
Public Property | Backdrop | Gets or sets the backdrop information with which to fill the legend box.
Public Property | Border | Gets or sets the border information with which to outline the legend box.
Public Property | CustomBorderDrawer | Gets or sets the custom draw object.
Public Property | DockArea | Gets or sets the chart area to which the legend is docked.
Public Property | DockInsideArea | Gets or sets a value indicating whether the legend will be docked inside the containing area.
Public Property | Footer | Gets or sets the footer title for the Legend.
Public Property | GridLayout | Gets or sets the grid layout for the Legend.
Public Property | Header | Gets or sets the header title for the legend.
Public Property | LabelsFont | Gets or sets the label font information used for the Legend.
Public Property | LegendItems | Gets the custom legend items collection.
Public Property | MarginX | Gets or sets the floating legend horizontal margin.
Public Property | MarginY | Gets or sets the floating legend vertical margin.
Public Property | Visible | Gets or sets a value indicating whether the legend is visible.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Alignment Property

Glossary Item Box

Gets or sets the floating legend alignment within the chart area.

Syntax

Visual Basic (Declaration)
Public Property Alignment As Alignment
C#
public Alignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members
Alignment Enumeration


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information with which to fill the legend box.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As BackdropItem
C#
public BackdropItem Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Border Property

Glossary Item Box

Gets or sets the border information with which to outline the legend box.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


CustomBorderDrawer Property

[image]
ActiveReports 19 .NET Edition
CustomBorderDrawer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : CustomBorderDrawer Property

Glossary Item Box

Gets or sets the custom draw object.

Syntax

Visual Basic (Declaration)
Public Property CustomBorderDrawer As ICustomBorderDrawer
C#
public ICustomBorderDrawer CustomBorderDrawer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


DockArea Property

[image]
ActiveReports 19 .NET Edition
DockArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : DockArea Property

Glossary Item Box

Gets or sets the chart area to which the legend is docked.

Syntax

Visual Basic (Declaration)
Public Property DockArea As ChartArea
C#
public ChartArea DockArea {get; set;}

Property Value

The dock area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


DockInsideArea Property

[image]
ActiveReports 19 .NET Edition
DockInsideArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : DockInsideArea Property

Glossary Item Box

Gets or sets a value indicating whether the legend will be docked inside the containing area.

Syntax

Visual Basic (Declaration)
Public Property DockInsideArea As Boolean
C#
public bool DockInsideArea {get; set;}

Property Value

Boolean. True if the legend will be docked inside the containing area; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Footer Property

Glossary Item Box

Gets or sets the footer title for the Legend.

Syntax

Visual Basic (Declaration)
Public Property Footer As Title
C#
public Title Footer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


GridLayout Property

[image]
ActiveReports 19 .NET Edition
GridLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : GridLayout Property

Glossary Item Box

Gets or sets the grid layout for the Legend.

Syntax

Visual Basic (Declaration)
Public Property GridLayout As GridLayout
C#
public GridLayout GridLayout {get; set;}

Property Value

The grid layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Header Property

Glossary Item Box

Gets or sets the header title for the legend.

Syntax

Visual Basic (Declaration)
Public Property Header As Title
C#
public Title Header {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


LabelsFont Property

[image]
ActiveReports 19 .NET Edition
LabelsFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : LabelsFont Property

Glossary Item Box

Gets or sets the label font information used for the Legend.

Syntax

Visual Basic (Declaration)
Public Property LabelsFont As FontInfo
C#
public FontInfo LabelsFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


LegendItems Property

[image]
ActiveReports 19 .NET Edition
LegendItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : LegendItems Property

Glossary Item Box

Gets the custom legend items collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LegendItems As LegendItemsCollection
C#
public LegendItemsCollection LegendItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


MarginX Property

[image]
ActiveReports 19 .NET Edition
MarginX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : MarginX Property

Glossary Item Box

Gets or sets the floating legend horizontal margin.

Syntax

Visual Basic (Declaration)
Public Property MarginX As Integer
C#
public int MarginX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


MarginY Property

[image]
ActiveReports 19 .NET Edition
MarginY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : MarginY Property

Glossary Item Box

Gets or sets the floating legend vertical margin.

Syntax

Visual Basic (Declaration)
Public Property MarginY As Integer
C#
public int MarginY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the legend is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


LegendItem Class

[image]
ActiveReports 19 .NET Edition
LegendItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

Glossary Item Box

Represents the settings for the LegendItem object.

Object Model

LegendItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LegendItem
   Inherits ItemComponent
C#
public sealed class LegendItem : ItemComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LegendItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Members
GrapeCity.ActiveReports.Chart Namespace


LegendItem Class Members

[image]
ActiveReports 19 .NET Edition
LegendItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

Glossary Item Box

The following tables list the members exposed by LegendItem.

Public Constructors

 | Name | Description
Public Constructor | LegendItem Constructor | Initializes new instance of the LegendItem class
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information to draw under the legend marker shape.
Public Property | Border | Gets or sets the border to draw around the legend item.
Public Property | Line | Gets or sets the line information to display.
Public Property | Marker | Gets or sets the series marker information to draw inside the legend marker.
Public Property | Style | Gets or sets the marker style.
Public Property | Text | Gets or sets the text as string to display in the legend.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LegendItem.
Public Method | ToString | Overridden. Returns a string that represents the LegendItem object.
Top

See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


LegendItem Constructor()

[image]
ActiveReports 19 .NET Edition
LegendItem Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class > LegendItem Constructor : LegendItem Constructor()

Glossary Item Box

Initializes new instance of the LegendItem class

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LegendItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members
Overload List


LegendItem Class Methods

[image]
ActiveReports 19 .NET Edition
LegendItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

Glossary Item Box

For a list of all members of this type, see LegendItem members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LegendItem.
Public Method | ToString | Overridden. Returns a string that represents the LegendItem object.
Top

See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Clone Method

Glossary Item Box

Creates a clone of the LegendItem.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the LegendItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : ToString Method

Glossary Item Box

Returns a string that represents the LegendItem object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Class Properties

[image]
ActiveReports 19 .NET Edition
LegendItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

Glossary Item Box

For a list of all members of this type, see LegendItem members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information to draw under the legend marker shape.
Public Property | Border | Gets or sets the border to draw around the legend item.
Public Property | Line | Gets or sets the line information to display.
Public Property | Marker | Gets or sets the series marker information to draw inside the legend marker.
Public Property | Style | Gets or sets the marker style.
Public Property | Text | Gets or sets the text as string to display in the legend.
Top

See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information to draw under the legend marker shape.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Border Property

Glossary Item Box

Gets or sets the border to draw around the legend item.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Line Property

Glossary Item Box

Gets or sets the line information to display.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Marker Property

Glossary Item Box

Gets or sets the series marker information to draw inside the legend marker.

Syntax

Visual Basic (Declaration)
Public Property Marker As Marker
C#
public Marker Marker {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Style Property

Glossary Item Box

Gets or sets the marker style.

Syntax

Visual Basic (Declaration)
Public Property Style As StdLegendMarker
C#
public StdLegendMarker Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Text Property

Glossary Item Box

Gets or sets the text as string to display in the legend.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Remarks

To display the X value in the legend, set the LegendText property on the Series to "{Name}."

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


LegendItemsCollection Class

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

Glossary Item Box

Represents the settings for the LegendItemsCollection class.

Object Model

LegendItemsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LegendItemsCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class LegendItemsCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.LegendItemsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LegendItemsCollection Class Members

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

Glossary Item Box

The following tables list the members exposed by LegendItemsCollection.

Public Constructors

 | Name | Description
Public Constructor | LegendItemsCollection Constructor | Initializes new instance of the LegendItemsCollection class
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Get or sets the custom LegendItem at the given index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a legend item to the collection.
Public Method | AddRange | Adds an array of legend items to the collection.
Public Method | Clone | Creates a clone of the LegendItems collection.
Public Method | Contains | Determines whether the collection contains the specified LegendItem.
Public Method | CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendItemsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a LegendItem into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Top

See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LegendItemsCollection Constructor

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : LegendItemsCollection Constructor

itemsArray
The array whose elements are copied in the new collection.

Glossary Item Box

Initializes new instance of the LegendItemsCollection class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemsArray() As LegendItem _
)
C#
public LegendItemsCollection(
   LegendItem[] itemsArray
)

Parameters

itemsArray
The array whose elements are copied in the new collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

Glossary Item Box

For a list of all members of this type, see LegendItemsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a legend item to the collection.
Public Method | AddRange | Adds an array of legend items to the collection.
Public Method | Clone | Creates a clone of the LegendItems collection.
Public Method | Contains | Determines whether the collection contains the specified LegendItem.
Public Method | CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendItemsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a LegendItem into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Top

See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Add Method

item
The legend item to add to the collection.

Glossary Item Box

Adds a legend item to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As LegendItem _
) As Integer
C#
public int Add(
   LegendItem item
)

Parameters

item
The legend item to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : AddRange Method

items
The legend items to add.

Glossary Item Box

Adds an array of legend items to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As LegendItem _
)
C#
public void AddRange(
   LegendItem[] items
)

Parameters

items
The legend items to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Clone Method

Glossary Item Box

Creates a clone of the LegendItems collection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Contains Method

value
The legend item to check.

Glossary Item Box

Determines whether the collection contains the specified LegendItem.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As LegendItem _
) As Boolean
C#
public bool Contains(
   LegendItem value
)

Parameters

value
The legend item to check.

Return Value

True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : CopyTo Method

array
The one-dimensional array that is the destination of the LegendItems copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Glossary Item Box

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As LegendItem, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   LegendItem[] array,
   int index
)

Parameters

array
The one-dimensional array that is the destination of the LegendItems copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Return Value

`

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Equals Method

obj
The System.Object to which the LegendItemsCollection object is being compared.

Glossary Item Box

Compares the LegendItemsCollection object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the LegendItemsCollection object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : IndexOf Method

value
The object to locate in the array.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As LegendItem _
) As Integer
C#
public int IndexOf(
   LegendItem value
)

Parameters

value
The object to locate in the array.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Insert Method

index
The zero-based index at which the LegendItem should be inserted.
item
The LegendItem to insert.

Glossary Item Box

Inserts a LegendItem into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As LegendItem _
)
C#
public void Insert(
   int index,
   LegendItem item
)

Parameters

index
The zero-based index at which the LegendItem should be inserted.
item
The LegendItem to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Remove Method

item
The LegendItem to remove from the collection.

Glossary Item Box

Removes the first occurrence of a specific object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As LegendItem _
)
C#
public void Remove(
   LegendItem item
)

Parameters

item
The LegendItem to remove from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

Glossary Item Box

For a list of all members of this type, see LegendItemsCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Get or sets the custom LegendItem at the given index.
Top

See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Item Property

Glossary Item Box

Get or sets the custom LegendItem at the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the legend item in the collection.
Item(String) | Gets or sets the collection item by the given legend item name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class > Item Property : Item(Int32) Property

index
Index of the item.

Glossary Item Box

Gets or sets the legend item in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As LegendItem
C#
public LegendItem Item(
   int index
) {get; set;}

Parameters

index
Index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class > Item Property : Item(String) Property

legendItemName
Name of the item.

Glossary Item Box

Gets or sets the collection item by the given legend item name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal legendItemName As String _
) As LegendItem
C#
public LegendItem Item(
   string legendItemName
) {get;}

Parameters

legendItemName
Name of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
Overload List


LegendsCollection Class

[image]
ActiveReports 19 .NET Edition
LegendsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

Glossary Item Box

Represents the settings for the LegendsCollection class.

Object Model

LegendsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LegendsCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class LegendsCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.LegendsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LegendsCollection Class Members

[image]
ActiveReports 19 .NET Edition
LegendsCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

Glossary Item Box

The following tables list the members exposed by LegendsCollection.

Public Constructors

 | Name | Description
Public Constructor | LegendsCollection Constructor | Initializes a new instance of the LegendsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the LegendsCollection item by the specified parameter.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Legend to the collection.
Public Method | AddRange | Adds an array of Legends to the collection.
Public Method | Clear | Releases the LegendsCollection object from memory.
Public Method | Clone | Creates a clone of the LegendsCollection.
Public Method | Contains | Determines whether the collection contains the specified legend.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a legend into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Legend from the collection.
Top

Public Events

 | Name | Description
Public Event | Change | Raised when an item in the collection changes.
Top

See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LegendsCollection Constructor

[image]
ActiveReports 19 .NET Edition
LegendsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : LegendsCollection Constructor

Glossary Item Box

Initializes a new instance of the LegendsCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LegendsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


LegendsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
LegendsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

Glossary Item Box

For a list of all members of this type, see LegendsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Legend to the collection.
Public Method | AddRange | Adds an array of Legends to the collection.
Public Method | Clear | Releases the LegendsCollection object from memory.
Public Method | Clone | Creates a clone of the LegendsCollection.
Public Method | Contains | Determines whether the collection contains the specified legend.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a legend into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Legend from the collection.
Top

See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Add Method

value
The Legend to add to the collection.

Glossary Item Box

Adds a Legend to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Legend _
) As Integer
C#
public int Add(
   Legend value
)

Parameters

value
The Legend to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : AddRange Method

range
The Legends to add.

Glossary Item Box

Adds an array of Legends to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal range() As Legend _
)
C#
public void AddRange(
   Legend[] range
)

Parameters

range
The Legends to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Clear Method

Glossary Item Box

Releases the LegendsCollection object from memory.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Clone Method

Glossary Item Box

Creates a clone of the LegendsCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Contains Method

value
The legend to check.

Glossary Item Box

Determines whether the collection contains the specified legend.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Legend _
) As Boolean
C#
public bool Contains(
   Legend value
)

Parameters

value
The legend to check.

Return Value

True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start copying.

Glossary Item Box

Copies the entire collection to an array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Legend, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Legend[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start copying.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Equals Method

obj
The System.Object to which the LegendsCollection object is being compared.

Glossary Item Box

Compares the LegendsCollection object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the LegendsCollection object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Legend _
) As Integer
C#
public int IndexOf(
   Legend value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Insert Method

index
The index at which the legend is inserted.
value
The legend to insert.

Glossary Item Box

Inserts a legend into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Legend _
)
C#
public void Insert(
   int index,
   Legend value
)

Parameters

index
The index at which the legend is inserted.
value
The legend to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Remove Method

value
The legend to remove.

Glossary Item Box

Removes the first occurrence of a specific Legend from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Legend _
)
C#
public void Remove(
   Legend value
)

Parameters

value
The legend to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


LegendsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
LegendsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

Glossary Item Box

For a list of all members of this type, see LegendsCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the LegendsCollection item by the specified parameter.
Top

See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Item Property

Glossary Item Box

Gets or sets the LegendsCollection item by the specified parameter.

Overload List

Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given legend name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class > Item Property : Item(Int32) Property

index
The index of the item.

Glossary Item Box

Gets or sets the collection item by the given index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Legend
C#
public Legend Item(
   int index
) {get; set;}

Parameters

index
The index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class > Item Property : Item(String) Property

legendName
The name of the legend.

Glossary Item Box

Gets or sets the collection item by the given legend name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal legendName As String _
) As Legend
C#
public Legend Item(
   string legendName
) {get;}

Parameters

legendName
The name of the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members
Overload List


LegendsCollection Class Events

[image]
ActiveReports 19 .NET Edition
LegendsCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

Glossary Item Box

For a list of all members of this type, see LegendsCollection members.

Public Events

 | Name | Description
Public Event | Change | Raised when an item in the collection changes.
Top

See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Change Event

[image]
ActiveReports 19 .NET Edition
Change Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Change Event

Glossary Item Box

Raised when an item in the collection changes.

Syntax

Visual Basic (Declaration)
Public Event Change As EventHandler
C#
public event EventHandler Change

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Light Class

[image]
ActiveReports 19 .NET Edition
Light Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

Glossary Item Box

Represents the settings of the Light object.

Object Model

Light Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Light
   Inherits Item
C#
public sealed class Light : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Light

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Members
GrapeCity.ActiveReports.Chart Namespace


Light Class Members

[image]
ActiveReports 19 .NET Edition
Light Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

Glossary Item Box

The following tables list the members exposed by Light.

Public Constructors

 | Name | Description
Public Constructor | Light Constructor | Overloaded. Initializes a new instance of the Light class.
Top

Public Properties

 | Name | Description
Public Property | DirectionalRatio | Gets or sets the directional/ambient intensity ratio.
Public Property | Source | Gets or sets the position of the light source (direction for infinite source).
Public Property | Type | Gets or sets the type of light source.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Light object.
Public Method | Equals | Compares the Light object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


Light Constructor

[image]
ActiveReports 19 .NET Edition
Light Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Light Constructor

Glossary Item Box

Initializes a new instance of the Light class.

Overload List

Overload | Description
Light Constructor() | Initializes a new instance of the Light class.
Light Constructor(Point3d,LightType,Single) | Initializes a new instance of the Light class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Light Constructor()

[image]
ActiveReports 19 .NET Edition
Light Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class > Light Constructor : Light Constructor()

Glossary Item Box

Initializes a new instance of the Light class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Light()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members
Overload List


Light Constructor(Point3d,LightType,Single)

[image]
ActiveReports 19 .NET Edition
Light Constructor(Point3d,LightType,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class > Light Constructor : Light Constructor(Point3d,LightType,Single)

source
Specifies the position of the light source.
type
Specifies the type of light source.
directionalRatio
Specifies the directional/ambient intensity ratio.

Glossary Item Box

Initializes a new instance of the Light class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As Point3d, _
   ByVal type As LightType, _
   ByVal directionalRatio As Single _
)
C#
public Light(
   Point3d source,
   LightType type,
   float directionalRatio
)

Parameters

source
Specifies the position of the light source.
type
Specifies the type of light source.
directionalRatio
Specifies the directional/ambient intensity ratio.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members
Overload List


Light Class Methods

[image]
ActiveReports 19 .NET Edition
Light Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

Glossary Item Box

For a list of all members of this type, see Light members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Light object.
Public Method | Equals | Compares the Light object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Clone Method

Glossary Item Box

Creates a clone of the Light object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Light object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Equals Method

obj
The System.Object to which the Light object is being compared.

Glossary Item Box

Compares the Light object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Light object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Light Class Properties

[image]
ActiveReports 19 .NET Edition
Light Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

Glossary Item Box

For a list of all members of this type, see Light members.

Public Properties

 | Name | Description
Public Property | DirectionalRatio | Gets or sets the directional/ambient intensity ratio.
Public Property | Source | Gets or sets the position of the light source (direction for infinite source).
Public Property | Type | Gets or sets the type of light source.
Top

See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


DirectionalRatio Property

[image]
ActiveReports 19 .NET Edition
DirectionalRatio Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : DirectionalRatio Property

Glossary Item Box

Gets or sets the directional/ambient intensity ratio.

Syntax

Visual Basic (Declaration)
Public Property DirectionalRatio As Single
C#
public float DirectionalRatio {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Source Property

Glossary Item Box

Gets or sets the position of the light source (direction for infinite source).

Syntax

Visual Basic (Declaration)
Public Property Source As Point3d
C#
public Point3d Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Type Property

Glossary Item Box

Gets or sets the type of light source.

Syntax

Visual Basic (Declaration)
Public Property Type As LightType
C#
public LightType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Light Class
Light Members


Marker Class

[image]
ActiveReports 19 .NET Edition
Marker Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

Glossary Item Box

Represents the settings for the Marker object.

Object Model

Marker Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Marker
   Inherits MouseEnabledItem
C#
public sealed class Marker : MouseEnabledItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Marker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Members
GrapeCity.ActiveReports.Chart Namespace


Marker Class Members

[image]
ActiveReports 19 .NET Edition
Marker Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

Glossary Item Box

The following tables list the members exposed by Marker.

Public Constructors

 | Name | Description
Public Constructor | Marker Constructor | Overloaded. Initializes a new instance of the Marker class.
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Marker.
Public Property | Label | Gets or sets the label information for the Marker.
Public Property | LabelDistanceFactor | Gets or sets the value to set the distance of the label of the marker from the graph.
Public Property | Line | Gets or sets the line information used to draw the outline of the Marker.
Public Property | Size | Gets or sets the size of the Marker, in pixels.
Public Property | Style | Gets or sets the shape of the Marker.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Marker object.
Public Method | Equals | Compares the Marker object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Marker Constructor

[image]
ActiveReports 19 .NET Edition
Marker Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Marker Constructor

Glossary Item Box

Initializes a new instance of the Marker class.

Overload List

Overload | Description
Marker Constructor() | Initializes a new instance of the Marker class.
Marker Constructor(AntiAliasMode) | Initializes a new instance of the Marker class with the specified AntiAliasMode.
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo) | Initializes a new instance of the Marker class with the specified parameters.
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single) | Initializes new instance of the MarkerInfo class
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode) | Initializes a new instance of the Marker class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Marker Constructor()

[image]
ActiveReports 19 .NET Edition
Marker Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor()

Glossary Item Box

Initializes a new instance of the Marker class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Marker()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Marker Constructor(AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(AntiAliasMode)

antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the Marker class with the specified AntiAliasMode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Marker(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)

[image]
ActiveReports 19 .NET Edition
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.

Glossary Item Box

Initializes a new instance of the Marker class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo _
)
C#
public Marker(
   int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)

[image]
ActiveReports 19 .NET Edition
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
labelDistanceFactor
Label distance factor.

Glossary Item Box

Initializes new instance of the MarkerInfo class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo, _
   ByVal labelDistanceFactor As Single _
)
C#
public Marker(
   int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label,
   float labelDistanceFactor
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
labelDistanceFactor
Label distance factor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the Marker class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Marker(
   int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label,
   AntiAliasMode antiAliasMode
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members
Overload List


Marker Class Methods

[image]
ActiveReports 19 .NET Edition
Marker Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

Glossary Item Box

For a list of all members of this type, see Marker members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Marker object.
Public Method | Equals | Compares the Marker object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Clone Method

Glossary Item Box

Creates a clone of the Marker object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Marker object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Equals Method

obj
The System.Object to which the Marker object is being compared.

Glossary Item Box

Compares the Marker object to another System.Object to see if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Marker object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Marker Class Properties

[image]
ActiveReports 19 .NET Edition
Marker Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

Glossary Item Box

For a list of all members of this type, see Marker members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Marker.
Public Property | Label | Gets or sets the label information for the Marker.
Public Property | LabelDistanceFactor | Gets or sets the value to set the distance of the label of the marker from the graph.
Public Property | Line | Gets or sets the line information used to draw the outline of the Marker.
Public Property | Size | Gets or sets the size of the Marker, in pixels.
Public Property | Style | Gets or sets the shape of the Marker.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information used to fill the Marker.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Label Property

Glossary Item Box

Gets or sets the label information for the Marker.

Syntax

Visual Basic (Declaration)
Public Property Label As LabelInfo
C#
public LabelInfo Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


LabelDistanceFactor Property

[image]
ActiveReports 19 .NET Edition
LabelDistanceFactor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : LabelDistanceFactor Property

Glossary Item Box

Gets or sets the value to set the distance of the label of the marker from the graph.

Syntax

Visual Basic (Declaration)
Public Property LabelDistanceFactor As Single
C#
public float LabelDistanceFactor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Line Property

Glossary Item Box

Gets or sets the line information used to draw the outline of the Marker.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Size Property

Glossary Item Box

Gets or sets the size of the Marker, in pixels.

Syntax

Visual Basic (Declaration)
Public Property Size As Integer
C#
public int Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Style Property

Glossary Item Box

Gets or sets the shape of the Marker.

Syntax

Visual Basic (Declaration)
Public Property Style As MarkerStyle
C#
public MarkerStyle Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


PlaneItem Class

[image]
ActiveReports 19 .NET Edition
PlaneItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

Glossary Item Box

Represents the settings for the PlaneItem object used for the chart walls.

Object Model

PlaneItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PlaneItem
   Inherits MouseEnabledItem
C#
public sealed class PlaneItem : MouseEnabledItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.PlaneItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Members
GrapeCity.ActiveReports.Chart Namespace


PlaneItem Class Members

[image]
ActiveReports 19 .NET Edition
PlaneItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

Glossary Item Box

The following tables list the members exposed by PlaneItem.

Public Constructors

 | Name | Description
Public Constructor | PlaneItem Constructor | Overloaded. Initializes a new instance of the PlaneItem class.
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the chart wall.
Public Property | Visible | Gets or sets a value indicating whether the chart wall is visible.
Public Property | Width | Gets or sets the width (thickness) of the chart wall.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the PlaneItem object.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


PlaneItem Constructor

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : PlaneItem Constructor

Glossary Item Box

Initializes a new instance of the PlaneItem class.

Overload List

Overload | Description
PlaneItem Constructor() | Initializes a new instance of the PlaneItem class.
PlaneItem Constructor(AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified AntiAliasMode.
PlaneItem Constructor(Backdrop) | Initializes a new instance of the PlaneItem class with the specified backdrop info.
PlaneItem Constructor(Backdrop,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Single) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Single,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Boolean,Single) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,Object) | Initializes a new instance of the PlaneItem class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


PlaneItem Constructor()

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor()

Glossary Item Box

Initializes a new instance of the PlaneItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PlaneItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(AntiAliasMode)

antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified AntiAliasMode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public PlaneItem(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop)

backdrop
Specifies the backdrop information used to fill the wall rectangle.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified backdrop info.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop _
)
C#
public PlaneItem(
   Backdrop backdrop
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,AntiAliasMode)

backdrop
Specifies the backdrop information used to fill the wall rectangle.
antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public PlaneItem(
   Backdrop backdrop,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Single)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Single)

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal width As Single _
)
C#
public PlaneItem(
   Backdrop backdrop,
   float width
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Single,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop,Single,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Single,AntiAliasMode)

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal width As Single, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public PlaneItem(
   Backdrop backdrop,
   float width,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Boolean,Single)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop,Boolean,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Boolean,Single)

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal visible As Boolean, _
   ByVal width As Single _
)
C#
public PlaneItem(
   Backdrop backdrop,
   bool visible,
   float width
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.

Glossary Item Box

Initializes a new instance of the PlaneItem class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal visible As Boolean, _
   ByVal width As Single, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public PlaneItem(
   Backdrop backdrop,
   bool visible,
   float width,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,Object)

[image]
ActiveReports 19 .NET Edition
PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,Object)

antiAliasMode
backdrop
visible
width
contextMenu

Glossary Item Box

Initializes a new instance of the PlaneItem class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode, _
   ByVal backdrop As Backdrop, _
   ByVal visible As Boolean, _
   ByVal width As Single, _
   ByVal contextMenu As Object _
)
C#
public PlaneItem(
   AntiAliasMode antiAliasMode,
   Backdrop backdrop,
   bool visible,
   float width,
   object contextMenu
)

Parameters

antiAliasMode
backdrop
visible
width
contextMenu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Class Methods

[image]
ActiveReports 19 .NET Edition
PlaneItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

Glossary Item Box

For a list of all members of this type, see PlaneItem members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the PlaneItem object.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Clone Method

Glossary Item Box

Creates a clone of the PlaneItem object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the PlaneItem object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Equals Method

obj

The System.Object to which the PlaneItem object is being compared.

Glossary Item Box

Overridden.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

The System.Object to which the PlaneItem object is being compared.

Return Value

Compares the PlaneItem object to another System.Object to see whether they are equal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


PlaneItem Class Properties

[image]
ActiveReports 19 .NET Edition
PlaneItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

Glossary Item Box

For a list of all members of this type, see PlaneItem members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the chart wall.
Public Property | Visible | Gets or sets a value indicating whether the chart wall is visible.
Public Property | Width | Gets or sets the width (thickness) of the chart wall.
Top

See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information for the chart wall.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the chart wall is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Width Property

Glossary Item Box

Gets or sets the width (thickness) of the chart wall.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlaneItem Class
PlaneItem Members


Projection Class

[image]
ActiveReports 19 .NET Edition
Projection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

Glossary Item Box

Represents the settings of the geometric Projection object.

Object Model

Projection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Projection
   Inherits Item
C#
public sealed class Projection : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Projection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Members
GrapeCity.ActiveReports.Chart Namespace


Projection Class Members

[image]
ActiveReports 19 .NET Edition
Projection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

Glossary Item Box

The following tables list the members exposed by Projection.

Public Constructors

 | Name | Description
Public Constructor | Projection Constructor | Overloaded. Initializes a new instance of the Projection class.
Top

Public Properties

 | Name | Description
Public Property | HorizontalRotation | Gets or sets the horizontal rotation from which the chart is viewed.
Public Property | PerspectiveRatioPct | Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.
Public Property | ProjectionDX | Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.
Public Property | ProjectionDY | Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.
Public Property | ProjectionType | Gets or sets the type of projection.
Public Property | VerticalRotation | Gets or sets the vertical rotation from which the chart is viewed.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Projection object.
Public Method | Equals | Compares the Projection object with another System.Object, and checks whether they both are equal.
Top

See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


Projection Constructor

[image]
ActiveReports 19 .NET Edition
Projection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Projection Constructor

Glossary Item Box

Initializes a new instance of the Projection class.

Overload List

Overload | Description
Projection Constructor() | Initializes a new instance of the Projection class.
Projection Constructor(ProjectionType,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.
Projection Constructor(ProjectionType,Single,Single,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.
Projection Constructor(ProjectionType,Single,Single,Single,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


Projection Constructor()

[image]
ActiveReports 19 .NET Edition
Projection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor()

Glossary Item Box

Initializes a new instance of the Projection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Projection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single)

[image]
ActiveReports 19 .NET Edition
Projection Constructor(ProjectionType,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single)

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.

Glossary Item Box

Initializes a new instance of the Projection class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As Single, _
   ByVal projectionDY As Single _
)
C#
public Projection(
   ProjectionType projectionType,
   float projectionDX,
   float projectionDY
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
Projection Constructor(ProjectionType,Single,Single,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single,Single,Single)

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.

Glossary Item Box

Initializes a new instance of the Projection class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As Single, _
   ByVal projectionDY As Single, _
   ByVal horizontalRotation As Single, _
   ByVal verticalRotation As Single _
)
C#
public Projection(
   ProjectionType projectionType,
   float projectionDX,
   float projectionDY,
   float horizontalRotation,
   float verticalRotation
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.
perspectiveRatio
The perspective ratio of the perspective projection type.

Glossary Item Box

Initializes a new instance of the Projection class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As Single, _
   ByVal projectionDY As Single, _
   ByVal horizontalRotation As Single, _
   ByVal verticalRotation As Single, _
   ByVal perspectiveRatio As Single _
)
C#
public Projection(
   ProjectionType projectionType,
   float projectionDX,
   float projectionDY,
   float horizontalRotation,
   float verticalRotation,
   float perspectiveRatio
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.
perspectiveRatio
The perspective ratio of the perspective projection type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
Overload List


Projection Class Methods

[image]
ActiveReports 19 .NET Edition
Projection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

Glossary Item Box

For a list of all members of this type, see Projection members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Projection object.
Public Method | Equals | Compares the Projection object with another System.Object, and checks whether they both are equal.
Top

See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Clone Method

Glossary Item Box

Creates a clone of the Projection object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Projection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Equals Method

obj
The System.Object to which the Projection object is being compared.

Glossary Item Box

Compares the Projection object with another System.Object, and checks whether they both are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Projection object is being compared.

Return Value

Compares the Projection object to another System.Object to see whether they are equal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


Projection Class Properties

[image]
ActiveReports 19 .NET Edition
Projection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

Glossary Item Box

For a list of all members of this type, see Projection members.

Public Properties

 | Name | Description
Public Property | HorizontalRotation | Gets or sets the horizontal rotation from which the chart is viewed.
Public Property | PerspectiveRatioPct | Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.
Public Property | ProjectionDX | Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.
Public Property | ProjectionDY | Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.
Public Property | ProjectionType | Gets or sets the type of projection.
Public Property | VerticalRotation | Gets or sets the vertical rotation from which the chart is viewed.
Top

See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


HorizontalRotation Property

[image]
ActiveReports 19 .NET Edition
HorizontalRotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : HorizontalRotation Property

Glossary Item Box

Gets or sets the horizontal rotation from which the chart is viewed.

Syntax

Visual Basic (Declaration)
Public Property HorizontalRotation As Single
C#
public float HorizontalRotation {get; set;}

Remarks

Use this property in conjunction with the VerticalRotation property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
VerticalRotation Property


PerspectiveRatioPct Property

[image]
ActiveReports 19 .NET Edition
PerspectiveRatioPct Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : PerspectiveRatioPct Property

Glossary Item Box

Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.

Syntax

Visual Basic (Declaration)
Public Property PerspectiveRatioPct As Single
C#
public float PerspectiveRatioPct {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


ProjectionDX Property

[image]
ActiveReports 19 .NET Edition
ProjectionDX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionDX Property

Glossary Item Box

Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.

Syntax

Visual Basic (Declaration)
Public Property ProjectionDX As Single
C#
public float ProjectionDX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


ProjectionDY Property

[image]
ActiveReports 19 .NET Edition
ProjectionDY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionDY Property

Glossary Item Box

Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.

Syntax

Visual Basic (Declaration)
Public Property ProjectionDY As Single
C#
public float ProjectionDY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


ProjectionType Property

[image]
ActiveReports 19 .NET Edition
ProjectionType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionType Property

Glossary Item Box

Gets or sets the type of projection.

Syntax

Visual Basic (Declaration)
Public Property ProjectionType As ProjectionType
C#
public ProjectionType ProjectionType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


VerticalRotation Property

[image]
ActiveReports 19 .NET Edition
VerticalRotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : VerticalRotation Property

Glossary Item Box

Gets or sets the vertical rotation from which the chart is viewed.

Syntax

Visual Basic (Declaration)
Public Property VerticalRotation As Single
C#
public float VerticalRotation {get; set;}

Remarks

Use this property in conjunction with the VerticalRotation property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members
HorizontalRotation Property


Series Class

[image]
ActiveReports 19 .NET Edition
Series Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

Glossary Item Box

Represents the settings for the Series object.

Object Model

Series Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Series
   Inherits MouseEnabledComponent
C#
public sealed class Series : MouseEnabledComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Series

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Members
GrapeCity.ActiveReports.Chart Namespace


Series Class Members

[image]
ActiveReports 19 .NET Edition
Series Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

Glossary Item Box

The following tables list the members exposed by Series.

Public Constructors

 | Name | Description
Public Constructor | Series Constructor | Creates default series
Top

Public Properties

 | Name | Description
Public Property | Annotations | Returns the collection of Annotations which is used with the Series.
Public Property | AxisX | Sets or returns the axis the Layer will be based on horizontally.
Public Property | AxisY | Sets or returns the axis the Layer will be based on vertically.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Series.
Public Property | BorderLine | Gets or sets the line information used for the border line of the Series.
Public Property | ChartArea | Sets or returns the ChartArea for the Series.
Public Property | ChartConfig | Returns the ChartTypeConfig for the Series.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | DisplayInLegend | Gets or sets a value indicating whether the Series is displayed in the graph legend.
Public Property | Legend | Gets or sets the Legend object for the series.
Public Property | LegendItemsMode | Gets or sets the mode used to display legend items.
Public Property | LegendText | Gets or sets the text that will be displayed for the series in the legend.
Public Property | Line | Gets or sets the line information used for the series.
Public Property | Marker | Gets or sets the marker information used for the series.
Public Property | Name | Overridden. Gets or sets the name of the series as a string.
Public Property | Points | Gets a DataPointsCollection object.
Public Property | Properties | Gets or sets the CustomProperties settings for the series.
Public Property | Tooltip | Gets or sets the tooltip text for the series.
Public Property | Type | Gets or sets the chart type for the series.
Public Property | ValueMembersY | Gets or sets the binding formula for the Y values in the series.
Public Property | ValueMemberX | Gets or sets the binding formula for the X values in the series.
Public Property | Visible | Sets or returns a value indicating whether the series is visible.
Public Property | ZOrder | Gets or sets the Z position of the series on the chart.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Series object.
Public Method | OnMouseHover | Overridden. Fires the MouseHover event.
Public Method | OnMouseLeave | Overridden. Raises the MouseLeave event.
Public Method | OnMouseMove | Overridden. Raises the MouseMove event.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Series Constructor()

[image]
ActiveReports 19 .NET Edition
Series Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class > Series Constructor : Series Constructor()

Glossary Item Box

Creates default series

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Series()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


Series Class Methods

[image]
ActiveReports 19 .NET Edition
Series Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Series object.
Public Method | OnMouseHover | Overridden. Fires the MouseHover event.
Public Method | OnMouseLeave | Overridden. Raises the MouseLeave event.
Public Method | OnMouseMove | Overridden. Raises the MouseMove event.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Clone Method

Glossary Item Box

Creates a clone of the Series object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Series object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


OnMouseHover Method

[image]
ActiveReports 19 .NET Edition
OnMouseHover Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseHover Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Fires the MouseHover event.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub OnMouseHover( _
   ByVal e As GraphMouseEventArgs _
)
C#
public override void OnMouseHover(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Return Value

Raises the MouseHover event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


OnMouseLeave Method

[image]
ActiveReports 19 .NET Edition
OnMouseLeave Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseLeave Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseLeave event.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub OnMouseLeave( _
   ByVal e As GraphMouseEventArgs _
)
C#
public override void OnMouseLeave(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


OnMouseMove Method

[image]
ActiveReports 19 .NET Edition
OnMouseMove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseMove Method

e
A GraphMouseEventArgs that contains the event data.

Glossary Item Box

Raises the MouseMove event.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub OnMouseMove( _
   ByVal e As GraphMouseEventArgs _
)
C#
public override void OnMouseMove(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Series Class Properties

[image]
ActiveReports 19 .NET Edition
Series Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Properties

 | Name | Description
Public Property | Annotations | Returns the collection of Annotations which is used with the Series.
Public Property | AxisX | Sets or returns the axis the Layer will be based on horizontally.
Public Property | AxisY | Sets or returns the axis the Layer will be based on vertically.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Series.
Public Property | BorderLine | Gets or sets the line information used for the border line of the Series.
Public Property | ChartArea | Sets or returns the ChartArea for the Series.
Public Property | ChartConfig | Returns the ChartTypeConfig for the Series.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | DisplayInLegend | Gets or sets a value indicating whether the Series is displayed in the graph legend.
Public Property | Legend | Gets or sets the Legend object for the series.
Public Property | LegendItemsMode | Gets or sets the mode used to display legend items.
Public Property | LegendText | Gets or sets the text that will be displayed for the series in the legend.
Public Property | Line | Gets or sets the line information used for the series.
Public Property | Marker | Gets or sets the marker information used for the series.
Public Property | Name | Overridden. Gets or sets the name of the series as a string.
Public Property | Points | Gets a DataPointsCollection object.
Public Property | Properties | Gets or sets the CustomProperties settings for the series.
Public Property | Tooltip | Gets or sets the tooltip text for the series.
Public Property | Type | Gets or sets the chart type for the series.
Public Property | ValueMembersY | Gets or sets the binding formula for the Y values in the series.
Public Property | ValueMemberX | Gets or sets the binding formula for the X values in the series.
Public Property | Visible | Sets or returns a value indicating whether the series is visible.
Public Property | ZOrder | Gets or sets the Z position of the series on the chart.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Annotations Property

[image]
ActiveReports 19 .NET Edition
Annotations Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Annotations Property

Glossary Item Box

Returns the collection of Annotations which is used with the Series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Annotations As AnnotationsCollection
C#
public AnnotationsCollection Annotations {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


AxisX Property

[image]
ActiveReports 19 .NET Edition
AxisX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : AxisX Property

Glossary Item Box

Sets or returns the axis the Layer will be based on horizontally.

Syntax

Visual Basic (Declaration)
Public Property AxisX As AxisBase
C#
public AxisBase AxisX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


AxisY Property

[image]
ActiveReports 19 .NET Edition
AxisY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : AxisY Property

Glossary Item Box

Sets or returns the axis the Layer will be based on vertically.

Syntax

Visual Basic (Declaration)
Public Property AxisY As AxisBase
C#
public AxisBase AxisY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information used to fill the Series.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


BorderLine Property

[image]
ActiveReports 19 .NET Edition
BorderLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : BorderLine Property

Glossary Item Box

Gets or sets the line information used for the border line of the Series.

Syntax

Visual Basic (Declaration)
Public Property BorderLine As Line
C#
public Line BorderLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ChartArea Property

[image]
ActiveReports 19 .NET Edition
ChartArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ChartArea Property

Glossary Item Box

Sets or returns the ChartArea for the Series.

Syntax

Visual Basic (Declaration)
Public Property ChartArea As ChartArea
C#
public ChartArea ChartArea {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ChartConfig Property

[image]
ActiveReports 19 .NET Edition
ChartConfig Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ChartConfig Property

Glossary Item Box

Returns the ChartTypeConfig for the Series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartConfig As ChartTypeConfig
C#
public ChartTypeConfig ChartConfig {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ColorPalette Property

[image]
ActiveReports 19 .NET Edition
ColorPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ColorPalette Property

Glossary Item Box

Gets or sets the color palette enumeration used for the series.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As ColorPalette
C#
public ColorPalette ColorPalette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
ColorPalette Enumeration


DisplayInLegend Property

[image]
ActiveReports 19 .NET Edition
DisplayInLegend Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : DisplayInLegend Property

Glossary Item Box

Gets or sets a value indicating whether the Series is displayed in the graph legend.

Syntax

Visual Basic (Declaration)
Public Property DisplayInLegend As Boolean
C#
public bool DisplayInLegend {get; set;}

Property Value

Boolean. True if the Series is displayed in the graph legend; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Legend Property

[image]
ActiveReports 19 .NET Edition
Legend Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Legend Property

Glossary Item Box

Gets or sets the Legend object for the series.

Syntax

Visual Basic (Declaration)
Public Property Legend As Legend
C#
public Legend Legend {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


LegendItemsMode Property

[image]
ActiveReports 19 .NET Edition
LegendItemsMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : LegendItemsMode Property

Glossary Item Box

Gets or sets the mode used to display legend items.

Syntax

Visual Basic (Declaration)
Public Property LegendItemsMode As LegendMode
C#
public LegendMode LegendItemsMode {get; set;}

Remarks

The default value is Auto, which specifies that legend items be displayed as points for one figure charts (e.g., doughnut, pyramid, and funnel) and series for all others.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


LegendText Property

[image]
ActiveReports 19 .NET Edition
LegendText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : LegendText Property

Glossary Item Box

Gets or sets the text that will be displayed for the series in the legend.

Syntax

Visual Basic (Declaration)
Public Property LegendText As String
C#
public string LegendText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Line Property

Glossary Item Box

Gets or sets the line information used for the series.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Marker Property

Glossary Item Box

Gets or sets the marker information used for the series.

Syntax

Visual Basic (Declaration)
Public Property Marker As Marker
C#
public Marker Marker {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Name Property

Glossary Item Box

Gets or sets the name of the series as a string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Name As String
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Points Property

[image]
ActiveReports 19 .NET Edition
Points Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Points Property

Glossary Item Box

Gets a DataPointsCollection object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As DataPointsCollection
C#
public DataPointsCollection Points {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Properties Property

Glossary Item Box

Gets or sets the CustomProperties settings for the series.

Syntax

Visual Basic (Declaration)
Public Property Properties As CustomProperties
C#
public CustomProperties Properties {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Tooltip Property

Glossary Item Box

Gets or sets the tooltip text for the series.

Syntax

Visual Basic (Declaration)
Public Property Tooltip As LabelInfo
C#
public LabelInfo Tooltip {get; set;}

Remarks

Tooltip property does not work for Chart control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Type Property

Glossary Item Box

Gets or sets the chart type for the series.

Syntax

Visual Basic (Declaration)
Public Property Type As ChartType
C#
public ChartType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ValueMembersY Property

[image]
ActiveReports 19 .NET Edition
ValueMembersY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ValueMembersY Property

Glossary Item Box

Gets or sets the binding formula for the Y values in the series.

Syntax

Visual Basic (Declaration)
Public Property ValueMembersY As String
C#
public string ValueMembersY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ValueMemberX Property

[image]
ActiveReports 19 .NET Edition
ValueMemberX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ValueMemberX Property

Glossary Item Box

Gets or sets the binding formula for the X values in the series.

Syntax

Visual Basic (Declaration)
Public Property ValueMemberX As String
C#
public string ValueMemberX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Visible Property

Glossary Item Box

Sets or returns a value indicating whether the series is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ZOrder Property

[image]
ActiveReports 19 .NET Edition
ZOrder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ZOrder Property

Glossary Item Box

Gets or sets the Z position of the series on the chart.

Syntax

Visual Basic (Declaration)
Public Property ZOrder As Single
C#
public float ZOrder {get; set;}

Remarks

The LayersSchemeManager may modify this property automatically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


SeriesCollection Class

[image]
ActiveReports 19 .NET Edition
SeriesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

Glossary Item Box

Represents the settings for the SeriesCollection class.

Object Model

SeriesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SeriesCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class SeriesCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.SeriesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Members
GrapeCity.ActiveReports.Chart Namespace


SeriesCollection Class Members

[image]
ActiveReports 19 .NET Edition
SeriesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

Glossary Item Box

The following tables list the members exposed by SeriesCollection.

Public Constructors

 | Name | Description
Public Constructor | SeriesCollection Constructor | Initializes a new instance of the SeriesCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item based on the specified parameter.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a series to the collection.
Public Method | AddRange | Adds an array of Series objects to the collection.
Public Method | Clone | Creates a clone of the SeriesCollection.
Public Method | Contains | Determines whether the collection contains the specified series.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | Equals | Compares the SeriesCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a series into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific series from the collection.
Top

See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


SeriesCollection Constructor

[image]
ActiveReports 19 .NET Edition
SeriesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : SeriesCollection Constructor

Glossary Item Box

Initializes a new instance of the SeriesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SeriesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
SeriesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

Glossary Item Box

For a list of all members of this type, see SeriesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a series to the collection.
Public Method | AddRange | Adds an array of Series objects to the collection.
Public Method | Clone | Creates a clone of the SeriesCollection.
Public Method | Contains | Determines whether the collection contains the specified series.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | Equals | Compares the SeriesCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a series into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific series from the collection.
Top

See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Add Method

value
The series to add to the collection.

Glossary Item Box

Adds a series to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Series _
) As Integer
C#
public int Add(
   Series value
)

Parameters

value
The series to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : AddRange Method

value
The set of Series objects to add to the collection.

Glossary Item Box

Adds an array of Series objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As Series _
)
C#
public void AddRange(
   Series[] value
)

Parameters

value
The set of Series objects to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Clone Method

Glossary Item Box

Creates a clone of the SeriesCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A clone of the SeriesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Contains Method

value

The series to check.

Glossary Item Box

Determines whether the collection contains the specified series.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Series _
) As Boolean
C#
public bool Contains(
   Series value
)

Parameters

value

The series to check.

Return Value

True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the entire collection to an array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Series, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Series[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Return Value

`

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Dispose Method

Glossary Item Box

Releases resources associated with this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Equals Method

obj
The System.Object to which the SeriesCollection object is being compared.

Glossary Item Box

Compares the SeriesCollection object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the SeriesCollection object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Series _
) As Integer
C#
public int IndexOf(
   Series value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Insert Method

index
The index at which the series should be inserted.
value
The series to insert.

Glossary Item Box

Inserts a series into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Series _
)
C#
public void Insert(
   int index,
   Series value
)

Parameters

index
The index at which the series should be inserted.
value
The series to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Remove Method

value
The series to remove.

Glossary Item Box

Removes the first occurrence of a specific series from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Series _
)
C#
public void Remove(
   Series value
)

Parameters

value
The series to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection Class Properties

[image]
ActiveReports 19 .NET Edition
SeriesCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

Glossary Item Box

For a list of all members of this type, see SeriesCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item based on the specified parameter.
Top

See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Item Property

Glossary Item Box

Gets or sets the collection item based on the specified parameter.

Overload List

Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given series name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class > Item Property : Item(Int32) Property

index
The index of the item.

Glossary Item Box

Gets or sets the collection item by the given index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Series
C#
public Series Item(
   int index
) {get; set;}

Parameters

index
The index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class > Item Property : Item(String) Property

seriesName
The name of the series.

Glossary Item Box

Gets or sets the collection item by the given series name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal seriesName As String _
) As Series
C#
public Series Item(
   string seriesName
) {get;}

Parameters

seriesName
The name of the series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


SharpGraphCore Class

[image]
ActiveReports 19 .NET Edition
SharpGraphCore Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraphCore Class

Glossary Item Box

Object Model

SharpGraphCore Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SharpGraphCore
   Implements ISharpGraph
C#
public sealed class SharpGraphCore : ISharpGraph

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.SharpGraphCore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Members
GrapeCity.ActiveReports.Chart Namespace


SharpGraphCore Class Members

[image]
ActiveReports 19 .NET Edition
SharpGraphCore Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraphCore Class

Glossary Item Box

The following tables list the members exposed by SharpGraphCore.

Public Constructors

 | Name | Description
Public Constructor | SharpGraphCore Constructor | Initializes new instance of the SharpGraph control
Top

Public Properties

 | Name | Description
Public Property | AreaCustomBorderDrawer | Gets or sets custom border drawer object for chart areas
Public Property | AutoRefresh | If true chart will be automatically refreshed(redrawn) on each property change
Public Property | Backdrop | Main chart's backdrop, spans all chart control area
Public Property | Border | Main chart's border, spans all chart control area
Public Property | ChartAreas | Chart Areas
Public Property | ChartCustomBorderDrawer | Gets or sets custom border drawer object for entire control
Public Property | ColorPalette | Global color palette. May be overrided on series level
Public Property | DataSource | Global graph's data source
Public Property | DeviceMode | Gets or sets graphics device specific options
Public Property | GridLayout | Chart Areas Columns
Public Property | IsDesignMode | Gets or sets a value indicating whether this instance is design mode.
Public Property | IsDirty |
Public Property | Legends | Gets control's Legend object
Public Property | Series | Where chart gets it's data to display
Public Property | SqlDbFactory | The sql data provider factory. Used to recreate the connection with a given credentials.
Public Property | Titles | Gets control's Titles collection
Public Property | UIOptions | Enables specific UI features
Top

Public Methods

 | Name | Description
Public Method | BeginInit | Signals the object that initialization is starting.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Public Method | DrawContent | DrawContent is provided primary for usage with ARNet2. However, by providing this function, it also allows some other usages to non-display canvases. OnPaint now calls this.
Public Method | EndInit | Signals the object that initialization is complete.
Public Method | FixReferences | Fixes the references between chart object. This method is used when chart is partially deserialized.
Public Method | GetCultureInfo |
Public Method | Invalidate |
Public Method | QuickLoad | Deserialize the data from XMl format.
Public Method | QuickSave | Serialize this object to binary writer in XML format.
Public Method | ReadXml | Reads the XML.
Public Method | RefreshData | Clears internal caches, so that chart will load all that data when it will be drawn next time
Public Method | ResetContent |
Public Method | SetCultureProvider | Sets the culture provider.
Public Method | SetDirty |
Public Method | SetTooltipText |
Public Method | TransferToCore |
Public Method | WriteXml | Writes the XML.
Top

See Also

Reference

SharpGraphCore Class
GrapeCity.ActiveReports.Chart Namespace


SharpGraphCore Constructor

[image]
ActiveReports 19 .NET Edition
SharpGraphCore Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : SharpGraphCore Constructor

Glossary Item Box

Initializes new instance of the SharpGraph control

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SharpGraphCore()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SharpGraphCore Class Methods

[image]
ActiveReports 19 .NET Edition
SharpGraphCore Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraphCore Class

Glossary Item Box

For a list of all members of this type, see SharpGraphCore members.

Public Methods

 | Name | Description
Public Method | BeginInit | Signals the object that initialization is starting.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Public Method | DrawContent | DrawContent is provided primary for usage with ARNet2. However, by providing this function, it also allows some other usages to non-display canvases. OnPaint now calls this.
Public Method | EndInit | Signals the object that initialization is complete.
Public Method | FixReferences | Fixes the references between chart object. This method is used when chart is partially deserialized.
Public Method | GetCultureInfo |
Public Method | Invalidate |
Public Method | QuickLoad | Deserialize the data from XMl format.
Public Method | QuickSave | Serialize this object to binary writer in XML format.
Public Method | ReadXml | Reads the XML.
Public Method | RefreshData | Clears internal caches, so that chart will load all that data when it will be drawn next time
Public Method | ResetContent |
Public Method | SetCultureProvider | Sets the culture provider.
Public Method | SetDirty |
Public Method | SetTooltipText |
Public Method | TransferToCore |
Public Method | WriteXml | Writes the XML.
Top

See Also

Reference

SharpGraphCore Class
GrapeCity.ActiveReports.Chart Namespace


BeginInit Method

[image]
ActiveReports 19 .NET Edition
BeginInit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : BeginInit Method

Glossary Item Box

Signals the object that initialization is starting.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
C#
public void BeginInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Dispose Method

Glossary Item Box

Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Dispose() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Dispose(Boolean) Method

[image]
ActiveReports 19 .NET Edition
Dispose(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Glossary Item Box

Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
public void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members
Overload List


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class > Dispose Method : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members
Overload List


DrawContent Method

[image]
ActiveReports 19 .NET Edition
DrawContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : DrawContent Method

canvas
rectangle

Glossary Item Box

DrawContent is provided primary for usage with ARNet2. However, by providing this function, it also allows some other usages to non-display canvases. OnPaint now calls this.

Syntax

Visual Basic (Declaration)
Public Sub DrawContent( _
   ByVal canvas As Canvas, _
   ByVal rectangle As Rectangle _
)
C#
public void DrawContent(
   Canvas canvas,
   Rectangle rectangle
)

Parameters

canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


EndInit Method

[image]
ActiveReports 19 .NET Edition
EndInit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : EndInit Method

Glossary Item Box

Signals the object that initialization is complete.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
C#
public void EndInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


FixReferences Method

[image]
ActiveReports 19 .NET Edition
FixReferences Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : FixReferences Method

Glossary Item Box

Fixes the references between chart object. This method is used when chart is partially deserialized.

Syntax

Visual Basic (Declaration)
Public Sub FixReferences()
C#
public void FixReferences()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


GetCultureInfo Method

[image]
ActiveReports 19 .NET Edition
GetCultureInfo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : GetCultureInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCultureInfo() As CultureInfo
C#
public CultureInfo GetCultureInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Invalidate Method

[image]
ActiveReports 19 .NET Edition
Invalidate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Invalidate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


QuickLoad Method

[image]
ActiveReports 19 .NET Edition
QuickLoad Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : QuickLoad Method

binReader
The bin reader.

Glossary Item Box

Deserialize the data from XMl format.

Syntax

Visual Basic (Declaration)
Public Sub QuickLoad( _
   ByVal binReader As BinaryReader _
)
C#
public void QuickLoad(
   BinaryReader binReader
)

Parameters

binReader
The bin reader.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


QuickSave Method

[image]
ActiveReports 19 .NET Edition
QuickSave Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : QuickSave Method

binWriter

Glossary Item Box

Serialize this object to binary writer in XML format.

Syntax

Visual Basic (Declaration)
Public Sub QuickSave( _
   ByVal binWriter As BinaryWriter _
)
C#
public void QuickSave(
   BinaryWriter binWriter
)

Parameters

binWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


ReadXml Method

[image]
ActiveReports 19 .NET Edition
ReadXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : ReadXml Method

controlNode

Glossary Item Box

Reads the XML.

Syntax

Visual Basic (Declaration)
Public Sub ReadXml( _
   ByVal controlNode As XmlElement _
)
C#
public void ReadXml(
   XmlElement controlNode
)

Parameters

controlNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


RefreshData Method

[image]
ActiveReports 19 .NET Edition
RefreshData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : RefreshData Method

Glossary Item Box

Clears internal caches, so that chart will load all that data when it will be drawn next time

Syntax

Visual Basic (Declaration)
Public Sub RefreshData()
C#
public void RefreshData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


ResetContent Method

[image]
ActiveReports 19 .NET Edition
ResetContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : ResetContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetContent()
C#
public void ResetContent()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SetCultureProvider Method

[image]
ActiveReports 19 .NET Edition
SetCultureProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : SetCultureProvider Method

provider

Glossary Item Box

Sets the culture provider.

Syntax

Visual Basic (Declaration)
Public Sub SetCultureProvider( _
   ByVal provider As Func(Of CultureInfo) _
)
C#
public void SetCultureProvider(
   Func<CultureInfo> provider
)

Parameters

provider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SetDirty Method

[image]
ActiveReports 19 .NET Edition
SetDirty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : SetDirty Method

f

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty( _
   ByVal f As Boolean _
)
C#
public void SetDirty(
   bool f
)

Parameters

f

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SetTooltipText Method

[image]
ActiveReports 19 .NET Edition
SetTooltipText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : SetTooltipText Method

tooltipText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetTooltipText( _
   ByVal tooltipText As String _
)
C#
public void SetTooltipText(
   string tooltipText
)

Parameters

tooltipText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


TransferToCore Method

[image]
ActiveReports 19 .NET Edition
TransferToCore Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : TransferToCore Method

engine

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub TransferToCore( _
   ByVal engine As Object _
)
C#
public void TransferToCore(
   object engine
)

Parameters

engine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


WriteXml Method

[image]
ActiveReports 19 .NET Edition
WriteXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : WriteXml Method

controlNode
The control node.

Glossary Item Box

Writes the XML.

Syntax

Visual Basic (Declaration)
Public Sub WriteXml( _
   ByVal controlNode As XmlElement _
)
C#
public void WriteXml(
   XmlElement controlNode
)

Parameters

controlNode
The control node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SharpGraphCore Class Properties

[image]
ActiveReports 19 .NET Edition
SharpGraphCore Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraphCore Class

Glossary Item Box

For a list of all members of this type, see SharpGraphCore members.

Public Properties

 | Name | Description
Public Property | AreaCustomBorderDrawer | Gets or sets custom border drawer object for chart areas
Public Property | AutoRefresh | If true chart will be automatically refreshed(redrawn) on each property change
Public Property | Backdrop | Main chart's backdrop, spans all chart control area
Public Property | Border | Main chart's border, spans all chart control area
Public Property | ChartAreas | Chart Areas
Public Property | ChartCustomBorderDrawer | Gets or sets custom border drawer object for entire control
Public Property | ColorPalette | Global color palette. May be overrided on series level
Public Property | DataSource | Global graph's data source
Public Property | DeviceMode | Gets or sets graphics device specific options
Public Property | GridLayout | Chart Areas Columns
Public Property | IsDesignMode | Gets or sets a value indicating whether this instance is design mode.
Public Property | IsDirty |
Public Property | Legends | Gets control's Legend object
Public Property | Series | Where chart gets it's data to display
Public Property | SqlDbFactory | The sql data provider factory. Used to recreate the connection with a given credentials.
Public Property | Titles | Gets control's Titles collection
Public Property | UIOptions | Enables specific UI features
Top

See Also

Reference

SharpGraphCore Class
GrapeCity.ActiveReports.Chart Namespace


AreaCustomBorderDrawer Property

[image]
ActiveReports 19 .NET Edition
AreaCustomBorderDrawer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : AreaCustomBorderDrawer Property

Glossary Item Box

Gets or sets custom border drawer object for chart areas

Syntax

Visual Basic (Declaration)
Public Property AreaCustomBorderDrawer As ICustomBorderDrawer
C#
public ICustomBorderDrawer AreaCustomBorderDrawer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


AutoRefresh Property

[image]
ActiveReports 19 .NET Edition
AutoRefresh Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : AutoRefresh Property

Glossary Item Box

If true chart will be automatically refreshed(redrawn) on each property change

Syntax

Visual Basic (Declaration)
Public Property AutoRefresh As Boolean
C#
public bool AutoRefresh {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Backdrop Property

Glossary Item Box

Main chart's backdrop, spans all chart control area

Syntax

Visual Basic (Declaration)
Public Property Backdrop As BackdropItem
C#
public BackdropItem Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Border Property

Glossary Item Box

Main chart's border, spans all chart control area

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


ChartAreas Property

[image]
ActiveReports 19 .NET Edition
ChartAreas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : ChartAreas Property

Glossary Item Box

Chart Areas

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartAreas As ChartAreasCollection
C#
public ChartAreasCollection ChartAreas {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


ChartCustomBorderDrawer Property

[image]
ActiveReports 19 .NET Edition
ChartCustomBorderDrawer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : ChartCustomBorderDrawer Property

Glossary Item Box

Gets or sets custom border drawer object for entire control

Syntax

Visual Basic (Declaration)
Public Property ChartCustomBorderDrawer As ICustomBorderDrawer
C#
public ICustomBorderDrawer ChartCustomBorderDrawer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


ColorPalette Property

[image]
ActiveReports 19 .NET Edition
ColorPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : ColorPalette Property

Glossary Item Box

Global color palette. May be overrided on series level

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As ColorPalette
C#
public ColorPalette ColorPalette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : DataSource Property

Glossary Item Box

Global graph's data source

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


DeviceMode Property

[image]
ActiveReports 19 .NET Edition
DeviceMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : DeviceMode Property

Glossary Item Box

Gets or sets graphics device specific options

Syntax

Visual Basic (Declaration)
Public Property DeviceMode As DeviceModes
C#
public DeviceModes DeviceMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


GridLayout Property

[image]
ActiveReports 19 .NET Edition
GridLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : GridLayout Property

Glossary Item Box

Chart Areas Columns

Syntax

Visual Basic (Declaration)
Public Property GridLayout As GridLayout
C#
public GridLayout GridLayout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


IsDesignMode Property

[image]
ActiveReports 19 .NET Edition
IsDesignMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : IsDesignMode Property

Glossary Item Box

Gets or sets a value indicating whether this instance is design mode.

Syntax

Visual Basic (Declaration)
Public Property IsDesignMode As Boolean
C#
public bool IsDesignMode {get; set;}

Property Value

true if this instance is design mode; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


IsDirty Property

[image]
ActiveReports 19 .NET Edition
IsDirty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : IsDirty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsDirty As Boolean
C#
public bool IsDirty {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Legends Property

[image]
ActiveReports 19 .NET Edition
Legends Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Legends Property

Glossary Item Box

Gets control's Legend object

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legends As LegendsCollection
C#
public LegendsCollection Legends {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Series Property

[image]
ActiveReports 19 .NET Edition
Series Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Series Property

Glossary Item Box

Where chart gets it's data to display

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Series As SeriesCollection
C#
public SeriesCollection Series {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


SqlDbFactory Property

[image]
ActiveReports 19 .NET Edition
SqlDbFactory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : SqlDbFactory Property

Glossary Item Box

The sql data provider factory. Used to recreate the connection with a given credentials.

Syntax

Visual Basic (Declaration)
Public Property SqlDbFactory As DbProviderFactory
C#
public DbProviderFactory SqlDbFactory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Titles Property

[image]
ActiveReports 19 .NET Edition
Titles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : Titles Property

Glossary Item Box

Gets control's Titles collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Titles As TitlesCollection
C#
public TitlesCollection Titles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


UIOptions Property

[image]
ActiveReports 19 .NET Edition
UIOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraphCore Class : UIOptions Property

Glossary Item Box

Enables specific UI features

Syntax

Visual Basic (Declaration)
Public Property UIOptions As UIOptions
C#
public UIOptions UIOptions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharpGraphCore Class
SharpGraphCore Members


Tick Class

[image]
ActiveReports 19 .NET Edition
Tick Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

Glossary Item Box

Represents the settings of the Tick object.

Object Model

Tick Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Tick
   Inherits Item
C#
public sealed class Tick : Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Tick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Members
GrapeCity.ActiveReports.Chart Namespace


Tick Class Members

[image]
ActiveReports 19 .NET Edition
Tick Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

Glossary Item Box

The following tables list the members exposed by Tick.

Public Constructors

 | Name | Description
Public Constructor | Tick Constructor | Overloaded. Initializes a new instance of the Tick class.
Top

Public Properties

 | Name | Description
Public Property | GridLine | Gets or sets the line used to draw the grid on the chart walls.
Public Property | Length | Gets or sets the length of the line used to draw the tick.
Public Property | Line | Gets or sets the line used to draw the tick.
Public Property | Step | Gets or sets the step between two subsequent ticks in the units of measure of the axis.
Public Property | Visible | Gets or sets a value indicating whether the tick is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Tick object.
Public Method | Equals | Compares the Tick object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


Tick Constructor

[image]
ActiveReports 19 .NET Edition
Tick Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Tick Constructor

Glossary Item Box

Initializes a new instance of the Tick class.

Overload List

Overload | Description
Tick Constructor() | Initializes a new instance of the Tick class.
Tick Constructor(Double) | Initializes a new instance of the Tick class with the step parameter specified.
Tick Constructor(Line,Double,Single) | Initializes a new instance of the Tick class with the parameters specified.
Tick Constructor(Line,Line,Double,Single,Boolean) | Initializes a new instance of the Tick class with the parameters specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Tick Constructor()

[image]
ActiveReports 19 .NET Edition
Tick Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor()

Glossary Item Box

Initializes a new instance of the Tick class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Tick()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Double)

[image]
ActiveReports 19 .NET Edition
Tick Constructor(Double)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Double)

step
Specifies the tick step.

Glossary Item Box

Initializes a new instance of the Tick class with the step parameter specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal step As Double _
)
C#
public Tick(
   double step
)

Parameters

step
Specifies the tick step.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Line,Double,Single)

[image]
ActiveReports 19 .NET Edition
Tick Constructor(Line,Double,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Line,Double,Single)

line
Specifies the line information used to draw the tick line.
step
Specifies the tick step.
length
Specifies the tick length.

Glossary Item Box

Initializes a new instance of the Tick class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal line As Line, _
   ByVal step As Double, _
   ByVal length As Single _
)
C#
public Tick(
   Line line,
   double step,
   float length
)

Parameters

line
Specifies the line information used to draw the tick line.
step
Specifies the tick step.
length
Specifies the tick length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Line,Line,Double,Single,Boolean)

[image]
ActiveReports 19 .NET Edition
Tick Constructor(Line,Line,Double,Single,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Line,Line,Double,Single,Boolean)

line
Specifies the line information used to draw the tick line.
gridLine
Specifies the line information used to draw the grid line.
step
Specifies the tick step.
length
Specifies the tick length.
visible
Specifies whether the tick and grid lines are visible.

Glossary Item Box

Initializes a new instance of the Tick class with the parameters specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal line As Line, _
   ByVal gridLine As Line, _
   ByVal step As Double, _
   ByVal length As Single, _
   ByVal visible As Boolean _
)
C#
public Tick(
   Line line,
   Line gridLine,
   double step,
   float length,
   bool visible
)

Parameters

line
Specifies the line information used to draw the tick line.
gridLine
Specifies the line information used to draw the grid line.
step
Specifies the tick step.
length
Specifies the tick length.
visible
Specifies whether the tick and grid lines are visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members
Overload List


Tick Class Methods

[image]
ActiveReports 19 .NET Edition
Tick Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

Glossary Item Box

For a list of all members of this type, see Tick members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Tick object.
Public Method | Equals | Compares the Tick object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Clone Method

Glossary Item Box

Creates a clone of the Tick object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Tick object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Equals Method

obj
The System.Object to which the Tick object is being compared.

Glossary Item Box

Compares the Tick object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Tick object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Tick Class Properties

[image]
ActiveReports 19 .NET Edition
Tick Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

Glossary Item Box

For a list of all members of this type, see Tick members.

Public Properties

 | Name | Description
Public Property | GridLine | Gets or sets the line used to draw the grid on the chart walls.
Public Property | Length | Gets or sets the length of the line used to draw the tick.
Public Property | Line | Gets or sets the line used to draw the tick.
Public Property | Step | Gets or sets the step between two subsequent ticks in the units of measure of the axis.
Public Property | Visible | Gets or sets a value indicating whether the tick is visible.
Top

See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


GridLine Property

[image]
ActiveReports 19 .NET Edition
GridLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : GridLine Property

Glossary Item Box

Gets or sets the line used to draw the grid on the chart walls.

Syntax

Visual Basic (Declaration)
Public Property GridLine As Line
C#
public Line GridLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Length Property

[image]
ActiveReports 19 .NET Edition
Length Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Length Property

Glossary Item Box

Gets or sets the length of the line used to draw the tick.

Syntax

Visual Basic (Declaration)
Public Property Length As Single
C#
public float Length {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Line Property

Glossary Item Box

Gets or sets the line used to draw the tick.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Step Property

[image]
ActiveReports 19 .NET Edition
Step Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Step Property

Glossary Item Box

Gets or sets the step between two subsequent ticks in the units of measure of the axis.

Syntax

Visual Basic (Declaration)
Public Property Step As Double
C#
public double Step {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the tick is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tick Class
Tick Members


Title Class

[image]
ActiveReports 19 .NET Edition
Title Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

Glossary Item Box

Represents the settings for the Title object.

Object Model

Title Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Title
   Inherits MouseEnabledComponent
C#
public sealed class Title : MouseEnabledComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Members
GrapeCity.ActiveReports.Chart Namespace


Title Class Members

[image]
ActiveReports 19 .NET Edition
Title Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

Glossary Item Box

The following tables list the members exposed by Title.

Public Constructors

 | Name | Description
Public Constructor | Title Constructor | Initializes new instance of the Title object.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the title object.
Public Property | Backdrop | Gets or sets the Backdrop object for the title.
Public Property | Border | Gets or sets the border to draw around the title object.
Public Property | CustomBorderDrawer | Gets or sets the custom border draw implementation class.
Public Property | DockArea | Gets or sets the chart area to which the title will be docked.
Public Property | Docking | Gets or sets the enumerated dock type value for the title.
Public Property | Font | Gets or sets the font information used to draw the title text.
Public Property | Name | Overridden. Gets or sets the name of the Title object as string.
Public Property | Text | Gets or sets the text to display for the Title object.
Public Property | Visible | Gets or sets a value indicating whether the Title object is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Title object.
Public Method | ToString | Overridden. Returns a string that represents the current Title object.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Title Constructor()

[image]
ActiveReports 19 .NET Edition
Title Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class > Title Constructor : Title Constructor()

Glossary Item Box

Initializes new instance of the Title object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Title()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members
Overload List


Title Class Methods

[image]
ActiveReports 19 .NET Edition
Title Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

Glossary Item Box

For a list of all members of this type, see Title members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Title object.
Public Method | ToString | Overridden. Returns a string that represents the current Title object.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Clone Method

Glossary Item Box

Creates a clone of the Title object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Title object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : ToString Method

Glossary Item Box

Returns a string that represents the current Title object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Title Class Properties

[image]
ActiveReports 19 .NET Edition
Title Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

Glossary Item Box

For a list of all members of this type, see Title members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the title object.
Public Property | Backdrop | Gets or sets the Backdrop object for the title.
Public Property | Border | Gets or sets the border to draw around the title object.
Public Property | CustomBorderDrawer | Gets or sets the custom border draw implementation class.
Public Property | DockArea | Gets or sets the chart area to which the title will be docked.
Public Property | Docking | Gets or sets the enumerated dock type value for the title.
Public Property | Font | Gets or sets the font information used to draw the title text.
Public Property | Name | Overridden. Gets or sets the name of the Title object as string.
Public Property | Text | Gets or sets the text to display for the Title object.
Public Property | Visible | Gets or sets a value indicating whether the Title object is visible.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Alignment Property

Glossary Item Box

Gets or sets the text alignment for the title object.

Syntax

Visual Basic (Declaration)
Public Property Alignment As Alignment
C#
public Alignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members
Alignment Enumeration


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Backdrop Property

Glossary Item Box

Gets or sets the Backdrop object for the title.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Border Property

Glossary Item Box

Gets or sets the border to draw around the title object.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


CustomBorderDrawer Property

[image]
ActiveReports 19 .NET Edition
CustomBorderDrawer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : CustomBorderDrawer Property

Glossary Item Box

Gets or sets the custom border draw implementation class.

Syntax

Visual Basic (Declaration)
Public Property CustomBorderDrawer As ICustomBorderDrawer
C#
public ICustomBorderDrawer CustomBorderDrawer {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


DockArea Property

[image]
ActiveReports 19 .NET Edition
DockArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : DockArea Property

Glossary Item Box

Gets or sets the chart area to which the title will be docked.

Syntax

Visual Basic (Declaration)
Public Property DockArea As ChartArea
C#
public ChartArea DockArea {get; set;}

Property Value

The dock area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Docking Property

[image]
ActiveReports 19 .NET Edition
Docking Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Docking Property

Glossary Item Box

Gets or sets the enumerated dock type value for the title.

Syntax

Visual Basic (Declaration)
Public Property Docking As DockType
C#
public DockType Docking {get; set;}

Property Value

The docking.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members
DockType Enumeration


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Font Property

Glossary Item Box

Gets or sets the font information used to draw the title text.

Syntax

Visual Basic (Declaration)
Public Property Font As FontInfo
C#
public FontInfo Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Name Property

Glossary Item Box

Gets or sets the name of the Title object as string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Name As String
C#
public override string Name {get; set;}

Property Value

The name.

Exceptions

Exception | Description
System.ArgumentException | Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Text Property

Glossary Item Box

Gets or sets the text to display for the Title object.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the Title object is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


TitlesCollection Class

[image]
ActiveReports 19 .NET Edition
TitlesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

Glossary Item Box

Represents the settings for the TitlesCollection object.

Object Model

TitlesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TitlesCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class TitlesCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.TitlesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Members
GrapeCity.ActiveReports.Chart Namespace


TitlesCollection Class Members

[image]
ActiveReports 19 .NET Edition
TitlesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

Glossary Item Box

The following tables list the members exposed by TitlesCollection.

Public Constructors

 | Name | Description
Public Constructor | TitlesCollection Constructor | Initializes a new instance of the TitlesCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a title to the collection.
Public Method | AddRange | Adds an array of titles to the collection.
Public Method | Clone | Creates a clone of the TitlesCollection.
Public Method | Contains | Determines whether the collection contains the specified title.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a title into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific title from the collection.
Top

See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


TitlesCollection Constructor

[image]
ActiveReports 19 .NET Edition
TitlesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : TitlesCollection Constructor

Glossary Item Box

Initializes a new instance of the TitlesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TitlesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


TitlesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
TitlesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

Glossary Item Box

For a list of all members of this type, see TitlesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a title to the collection.
Public Method | AddRange | Adds an array of titles to the collection.
Public Method | Clone | Creates a clone of the TitlesCollection.
Public Method | Contains | Determines whether the collection contains the specified title.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a title into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific title from the collection.
Top

See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Add Method

value
Specifies the title to add to the collection.

Glossary Item Box

Adds a title to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Title _
) As Integer
C#
public int Add(
   Title value
)

Parameters

value
Specifies the title to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : AddRange Method

value
The set of titles to add to the collection.

Glossary Item Box

Adds an array of titles to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As Title _
)
C#
public void AddRange(
   Title[] value
)

Parameters

value
The set of titles to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Clone Method

Glossary Item Box

Creates a clone of the TitlesCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A clone of the TitlesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Contains Method

value
The title to check.

Glossary Item Box

Determines whether the collection contains the specified title.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Title _
) As Boolean
C#
public bool Contains(
   Title value
)

Parameters

value
The title to check.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the entire collection to an array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Title, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Title[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Title _
) As Integer
C#
public int IndexOf(
   Title value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Insert Method

index
The index at which the title should be inserted.
value
The title to insert.

Glossary Item Box

Inserts a title into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Title _
)
C#
public void Insert(
   int index,
   Title value
)

Parameters

index
The index at which the title should be inserted.
value
The title to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Remove Method

value
The title to remove.

Glossary Item Box

Removes the first occurrence of a specific title from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Title _
)
C#
public void Remove(
   Title value
)

Parameters

value
The title to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


TitlesCollection Class Properties

[image]
ActiveReports 19 .NET Edition
TitlesCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

Glossary Item Box

For a list of all members of this type, see TitlesCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top

See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Item Property

Glossary Item Box

Gets or sets the collection item by the specified parameter.

Overload List

Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given title name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class > Item Property : Item(Int32) Property

index
The index of the item.

Glossary Item Box

Gets or sets the collection item by the given index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Title
C#
public Title Item(
   int index
) {get; set;}

Parameters

index
The index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class > Item Property : Item(String) Property

titleName
The name of the title.

Glossary Item Box

Gets or sets the collection item by the given title name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal titleName As String _
) As Title
C#
public Title Item(
   string titleName
) {get;}

Parameters

titleName
The name of the title.

Property Value

Title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members
Overload List


WallRange Class

[image]
ActiveReports 19 .NET Edition
WallRange Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

Glossary Item Box

Represents the settings of the WallRange object.

Object Model

WallRange Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WallRange
   Inherits MouseEnabledComponent
C#
public sealed class WallRange : MouseEnabledComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.WallRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Members
GrapeCity.ActiveReports.Chart Namespace


WallRange Class Members

[image]
ActiveReports 19 .NET Edition
WallRange Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

Glossary Item Box

The following tables list the members exposed by WallRange.

Public Constructors

 | Name | Description
Public Constructor | WallRange Constructor | Initializes new instance of the WallRange class.
Top

Public Properties

 | Name | Description
Public Property | AdjacentAxes | Gets or sets the adjacent axes collection.
Public Property | Backdrop | Gets or sets the Backdrop information with which to fill the wall range.
Public Property | Border | Gets or sets the border information used to outline the WallRange.
Public Property | DrawOnTopOfGridLines | Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.
Public Property | EndValue | Gets or sets the end value of the wall range.
Public Property | PrimaryAxis | Gets or sets the primary axis for the WallRange.
Public Property | StartValue | Gets or sets the start value of the wall range.
Public Property | Visible | Gets or sets a value indicating whether the wall range is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the WallRange object.
Top

See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


WallRange Constructor()

[image]
ActiveReports 19 .NET Edition
WallRange Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class > WallRange Constructor : WallRange Constructor()

Glossary Item Box

Initializes new instance of the WallRange class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WallRange()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members
Overload List


WallRange Class Methods

[image]
ActiveReports 19 .NET Edition
WallRange Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

Glossary Item Box

For a list of all members of this type, see WallRange members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the WallRange object.
Top

See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Clone Method

Glossary Item Box

Creates a clone of the WallRange object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the WallRange object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


WallRange Class Properties

[image]
ActiveReports 19 .NET Edition
WallRange Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

Glossary Item Box

For a list of all members of this type, see WallRange members.

Public Properties

 | Name | Description
Public Property | AdjacentAxes | Gets or sets the adjacent axes collection.
Public Property | Backdrop | Gets or sets the Backdrop information with which to fill the wall range.
Public Property | Border | Gets or sets the border information used to outline the WallRange.
Public Property | DrawOnTopOfGridLines | Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.
Public Property | EndValue | Gets or sets the end value of the wall range.
Public Property | PrimaryAxis | Gets or sets the primary axis for the WallRange.
Public Property | StartValue | Gets or sets the start value of the wall range.
Public Property | Visible | Gets or sets a value indicating whether the wall range is visible.
Top

See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


AdjacentAxes Property

[image]
ActiveReports 19 .NET Edition
AdjacentAxes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : AdjacentAxes Property

Glossary Item Box

Gets or sets the adjacent axes collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdjacentAxes As AxesCollection
C#
public AxesCollection AdjacentAxes {get;}

Remarks

The WallRange is displayed on the visible walls based on primary and adjacent axes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Backdrop Property

Glossary Item Box

Gets or sets the Backdrop information with which to fill the wall range.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Border Property

Glossary Item Box

Gets or sets the border information used to outline the WallRange.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


DrawOnTopOfGridLines Property

[image]
ActiveReports 19 .NET Edition
DrawOnTopOfGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : DrawOnTopOfGridLines Property

Glossary Item Box

Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.

Syntax

Visual Basic (Declaration)
Public Property DrawOnTopOfGridLines As Boolean
C#
public bool DrawOnTopOfGridLines {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


EndValue Property

[image]
ActiveReports 19 .NET Edition
EndValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : EndValue Property

Glossary Item Box

Gets or sets the end value of the wall range.

Syntax

Visual Basic (Declaration)
Public Property EndValue As Double
C#
public double EndValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


PrimaryAxis Property

[image]
ActiveReports 19 .NET Edition
PrimaryAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : PrimaryAxis Property

Glossary Item Box

Gets or sets the primary axis for the WallRange.

Syntax

Visual Basic (Declaration)
Public Property PrimaryAxis As AxisBase
C#
public AxisBase PrimaryAxis {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


StartValue Property

[image]
ActiveReports 19 .NET Edition
StartValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : StartValue Property

Glossary Item Box

Gets or sets the start value of the wall range.

Syntax

Visual Basic (Declaration)
Public Property StartValue As Double
C#
public double StartValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the wall range is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


WallRangesCollection Class

[image]
ActiveReports 19 .NET Edition
WallRangesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

Glossary Item Box

Represents the settings of the WallRangesCollection object.

Object Model

WallRangesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WallRangesCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class WallRangesCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.WallRangesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Members
GrapeCity.ActiveReports.Chart Namespace


WallRangesCollection Class Members

[image]
ActiveReports 19 .NET Edition
WallRangesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

Glossary Item Box

The following tables list the members exposed by WallRangesCollection.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a WallRange to the collection.
Public Method | AddRange | Adds an array of WallRanges to the collection.
Public Method | Clone | Creates a clone of the WallRanges collection.
Public Method | Contains | Determines whether the collection contains the specified WallRange.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a WallRange into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific WallRange from the collection.
Top

See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


WallRangesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
WallRangesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

Glossary Item Box

For a list of all members of this type, see WallRangesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a WallRange to the collection.
Public Method | AddRange | Adds an array of WallRanges to the collection.
Public Method | Clone | Creates a clone of the WallRanges collection.
Public Method | Contains | Determines whether the collection contains the specified WallRange.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a WallRange into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific WallRange from the collection.
Top

See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Add Method

value
The WallRange to add.

Glossary Item Box

Adds a WallRange to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As WallRange _
) As Integer
C#
public int Add(
   WallRange value
)

Parameters

value
The WallRange to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : AddRange Method

value
The set of WallRanges to add to the collection.

Glossary Item Box

Adds an array of WallRanges to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As WallRange _
)
C#
public void AddRange(
   WallRange[] value
)

Parameters

value
The set of WallRanges to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Clone Method

Glossary Item Box

Creates a clone of the WallRanges collection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A clone of the WallRanges collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Contains Method

value
The wall range to check.

Glossary Item Box

Determines whether the collection contains the specified WallRange.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As WallRange _
) As Boolean
C#
public bool Contains(
   WallRange value
)

Parameters

value
The wall range to check.

Return Value

Boolean. True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the entire collection to an array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As WallRange, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   WallRange[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As WallRange _
) As Integer
C#
public int IndexOf(
   WallRange value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Insert Method

index
The index at which the WallRange should be inserted.
value
The WallRange to insert.

Glossary Item Box

Inserts a WallRange into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As WallRange _
)
C#
public void Insert(
   int index,
   WallRange value
)

Parameters

index
The index at which the WallRange should be inserted.
value
The WallRange to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Remove Method

value
The WallRange to remove.

Glossary Item Box

Removes the first occurrence of a specific WallRange from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As WallRange _
)
C#
public void Remove(
   WallRange value
)

Parameters

value
The WallRange to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


WallRangesCollection Class Properties

[image]
ActiveReports 19 .NET Edition
WallRangesCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

Glossary Item Box

For a list of all members of this type, see WallRangesCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top

See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Item Property

Glossary Item Box

Gets or sets the collection item by the specified parameter.

Overload List

Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given wall range name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class > Item Property : Item(Int32) Property

index
The index of the item.

Glossary Item Box

Gets or sets the collection item by the given index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As WallRange
C#
public WallRange Item(
   int index
) {get; set;}

Parameters

index
The index of the item.

Property Value

WallRange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class > Item Property : Item(String) Property

wallRangeName
The name of the WallRange.

Glossary Item Box

Gets or sets the collection item by the given wall range name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal wallRangeName As String _
) As WallRange
C#
public WallRange Item(
   string wallRangeName
) {get;}

Parameters

wallRangeName
The name of the WallRange.

Property Value

WallRange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members
Overload List


XmlDataProvider Class

[image]
ActiveReports 19 .NET Edition
XmlDataProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class

Glossary Item Box

Provides access to XML data.

Object Model

XmlDataProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlDataProvider
C#
public sealed class XmlDataProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.XmlDataProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlDataProvider Members
GrapeCity.ActiveReports.Chart Namespace


XmlDataProvider Class Members

[image]
ActiveReports 19 .NET Edition
XmlDataProvider Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class

Glossary Item Box

The following tables list the members exposed by XmlDataProvider.

Public Constructors

 | Name | Description
Public Constructor | XmlDataProvider Constructor | Initializes a new instance of the XMLDataProvider class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of data values.
Public Property | Item | Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.
Top

See Also

Reference

XmlDataProvider Class
GrapeCity.ActiveReports.Chart Namespace


XmlDataProvider Constructor

[image]
ActiveReports 19 .NET Edition
XmlDataProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : XmlDataProvider Constructor

dataSource
The data source object.
columnName
The name of the column to read the rows of the data from.

Glossary Item Box

Initializes a new instance of the XMLDataProvider class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As Object, _
   ByVal columnName As String _
)
C#
public XmlDataProvider(
   object dataSource,
   string columnName
)

Parameters

dataSource
The data source object.
columnName
The name of the column to read the rows of the data from.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


XmlDataProvider Class Properties

[image]
ActiveReports 19 .NET Edition
XmlDataProvider Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class

Glossary Item Box

For a list of all members of this type, see XmlDataProvider members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of data values.
Public Property | Item | Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.
Top

See Also

Reference

XmlDataProvider Class
GrapeCity.ActiveReports.Chart Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : Count Property

Glossary Item Box

Gets the number of data values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : Item Property

index
The index of the item.

Glossary Item Box

Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Object
C#
public object this[
   int index
]; {get;}

Parameters

index
The index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


Alignment Enumeration

[image]
ActiveReports 19 .NET Edition
Alignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Alignment Enumeration

Glossary Item Box

Specifies how the text item anchors to its position.

Syntax

Visual Basic (Declaration)
Public Enum Alignment
   Inherits System.Enum
C#
public enum Alignment : System.Enum

Members

Member | Description
Bottom | The text item anchors to the bottom.
BottomLeft | The text item anchors to the bottom left.
BottomRight | The text item anchors to the bottom right.
Center | The text item anchors to the center.
Left | The text item anchors to the left.
Right | The text item anchors to the right.
Top | The text item anchors to the top.
TopLeft | The text item anchors to the top left.
TopRight | The text item anchors to the top right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ArrowType Enumeration

[image]
ActiveReports 19 .NET Edition
ArrowType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ArrowType Enumeration

Glossary Item Box

Specifies the arrow type used for the axis line.

Syntax

Visual Basic (Declaration)
Public Enum ArrowType
   Inherits System.Enum
C#
public enum ArrowType : System.Enum

Members

Member | Description
Lines | Lines are used to create an arrow.
None | No arrow type is used.
Triangle | A triangle is used as the arrow.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ArrowType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


AxisType Enumeration

[image]
ActiveReports 19 .NET Edition
AxisType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisType Enumeration

Glossary Item Box

Specifies the axis type.

Syntax

Visual Basic (Declaration)
Public Enum AxisType
   Inherits System.Enum
C#
public enum AxisType : System.Enum

Members

Member | Description
Categorical | The axis is used to place categories.
Logarithmic | A logarithmic axis is used.
Numerical | A numerical axis is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.AxisType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


BarType Enumeration

[image]
ActiveReports 19 .NET Edition
BarType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BarType Enumeration

Glossary Item Box

Specifies the type of bars to use.

Syntax

Visual Basic (Declaration)
Public Enum BarType
   Inherits System.Enum
C#
public enum BarType : System.Enum

Members

Member | Description
Bar | A filled rectangular shape is used.
Cone | A cone shape is used.
Custom | A custom shape is used.
Cylinder | A cylindrical shape is used.
Pyramid | A pyramidal shape is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.BarType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


BaseStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BaseStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : BaseStyle Enumeration

Glossary Item Box

Gets or sets a circular or square base drawing style for the 3D funnel chart or 3D pyramid chart.

Syntax

Visual Basic (Declaration)
Public Enum BaseStyle
   Inherits System.Enum
C#
public enum BaseStyle : System.Enum

Members

Member | Description
CircularBase | Renders the base of the funnel or pyramid in a circular shape.
SquareBase | Renders the base of the funnel or pyramid in a square shape.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.BaseStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ChartType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartType Enumeration

Glossary Item Box

Specifies the ChartType used for the Series.

Syntax

Visual Basic (Declaration)
Public Enum ChartType
   Inherits System.Enum
C#
public enum ChartType : System.Enum

Members

Member | Description
Area | An area chart is drawn.
Area3D | A 3D area chart is drawn.
Bar2D | A bar chart is drawn.
Bar3D | A 3D bar chart is drawn.
Bezier | A bezier chart is drawn.
Bezier3D | A bezier 3D chart is drawn.
BezierXY | A bezier XY chart is drawn.
BezierXY3D | A bezier XY 3D chart is drawn.
Bubble | A bubble chart is drawn.
BubbleXY | A bubble XY chart is drawn.
Candle | A candle chart is drawn.
ClusteredBar | A clustered bar chart is drawn.
Doughnut | A doughnut chart is drawn.
Doughnut3D | A 3D doughnut chart is drawn.
Funnel | A funnel chart is drawn.
Funnel3D | A funnel 3D chart is drawn.
Gantt | A Gantt chart is drawn.
Gantt3D | A Gantt 3D chart is drawn.
HiLo | A HiLo chart is drawn.
HiLoOpenClose | A HiLoOpenClose chart is drawn.
HorizontalBar | A HorizontalBar chart is drawn.
HorizontalBar3D | A HorizontalBar3D chart is drawn.
Kagi | A Kagi chart is drawn.
Kagi3D | A Kagi 3D chart is drawn.
Line | A line chart is drawn.
Line3D | A 3D line chart is drawn.
LineXY | A line XY chart is drawn.
LineXY3D | A line XY 3D chart is drawn.
PlotXY | A plot XY chart is drawn.
PointAndFigure | A point and figure chart is drawn.
Pyramid | A pyramid chart is drawn.
Pyramid3D | A pyramid 3D chart is drawn.
Renko | A Renko chart is drawn.
Renko3D | A Renko 3D chart is drawn.
Scatter | A scatter chart is drawn.
StackedArea | A stacked area chart is drawn.
StackedArea100Pct | A stacked area chart filling 100% of the chart area is drawn.
StackedArea3D | A stacked area 3D chart is drawn.
StackedArea3D100Pct | A stacked area 3D 100% chart is drawn.
StackedBar | A stacked bar chart is drawn.
StackedBar100Pct | A stacked bar chart filling 100% of the chart area is drawn.
StackedBar3D | A 3D stacked bar chart is drawn.
StackedBar3D100Pct | A 3D stacked bar chart filling 100% of the chart area is drawn.
ThreeLineBreak | A three line break chart is drawn.
ThreeLineBreak3D | A three line break 3D chart is drawn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ChartType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ColorPalette Enumeration

[image]
ActiveReports 19 .NET Edition
ColorPalette Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ColorPalette Enumeration

Glossary Item Box

Specifies what color palette is used.

Syntax

Visual Basic (Declaration)
Public Enum ColorPalette
   Inherits System.Enum
C#
public enum ColorPalette : System.Enum

Members

Member | Description
Autumn | The rich browns and golds of autumn.
Berries | A range of colors from blueberry through raspberry.
Cascade | A cascade of eight cool colors ranging from deep teal down through pale orchid.
Confetti | A sprinkling of bright and pastel colors.
Default | The same color scheme as Cascade.
Greens | A medley of greens from 70's refrigerator green through evergreen.
Iceberg | A range of the soft blues and greys found in an iceberg.
Murphy | Muted greens, rusts and beiges.
None | All data is drawn using the same teal color.
Springtime | The colors of spring, in deep green, two vivid colors and five pastels.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ColorPalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


DeviceModes Enumeration

[image]
ActiveReports 19 .NET Edition
DeviceModes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DeviceModes Enumeration

Glossary Item Box

Specifies the device drawing mode used to render the chart.

Syntax

Visual Basic (Declaration)
Public Enum DeviceModes
   Inherits System.Enum
C#
public enum DeviceModes : System.Enum

Members

Member | Description
BlackWhite | Hatch patterns and dashed lines are used to designate colors.
None | The standard mode, in which colors are used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.DeviceModes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


DockType Enumeration

[image]
ActiveReports 19 .NET Edition
DockType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : DockType Enumeration

Glossary Item Box

Specifies the docking area.

Syntax

Visual Basic (Declaration)
Public Enum DockType
   Inherits System.Enum
C#
public enum DockType : System.Enum

Members

Member | Description
Bottom | Bottom docking is used.
Left | Left docking is used.
Right | Right docking is used.
Top | Top docking is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.DockType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


FunnelStyle Enumeration

[image]
ActiveReports 19 .NET Edition
FunnelStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : FunnelStyle Enumeration

Glossary Item Box

Specifies whether the Y value for the series points to the width or the height of the funnel. The default value is YIsHeight.

Syntax

Visual Basic (Declaration)
Public Enum FunnelStyle
   Inherits System.Enum
C#
public enum FunnelStyle : System.Enum

Members

Member | Description
YIsHeight | The Y value of the series points determines the Height of the funnel.
YIsWidth | The Y value of the series points determines the Width of the funnel.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.FunnelStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LabelsPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
LabelsPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsPlacement Enumeration

Glossary Item Box

Specifies whether the data point labels appear on the left or right side of the funnel or pyramid chart.

Syntax

Visual Basic (Declaration)
Public Enum LabelsPlacement
   Inherits System.Enum
C#
public enum LabelsPlacement : System.Enum

Members

Member | Description
Left | Labels appear to the left of the funnel or pyramid.
Right | Labels appear to the right of the funnel or pyramid.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LabelsPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LegendMode Enumeration

[image]
ActiveReports 19 .NET Edition
LegendMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendMode Enumeration

Glossary Item Box

Specifies the mode used to render legend items.

Syntax

Visual Basic (Declaration)
Public Enum LegendMode
   Inherits System.Enum
C#
public enum LegendMode : System.Enum

Members

Member | Description
Auto | Renders legend items for each data point for one figure charts (e.g., doughnut, funnel, and pyramid) and legend items for each series for all other chart types.
Points | Renders legend items for each data point in the series.
Series | Renders legend items for each series.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LegendMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LightType Enumeration

[image]
ActiveReports 19 .NET Edition
LightType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : LightType Enumeration

Glossary Item Box

Specifies the type of light source used.

Syntax

Visual Basic (Declaration)
Public Enum LightType
   Inherits System.Enum
C#
public enum LightType : System.Enum

Members

Member | Description
Ambient | An ambient light source is used. It is equal to DirectionalLightRatio = 0.
FiniteDirectional | A point light source is used.
InfiniteDirectional | An infinite directional light source (like the sun) is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LightType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


MarkerStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MarkerStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : MarkerStyle Enumeration

Glossary Item Box

Specifies the shape of the marker.

Syntax

Visual Basic (Declaration)
Public Enum MarkerStyle
   Inherits System.Enum
C#
public enum MarkerStyle : System.Enum

Members

Member | Description
Circle | A circle shape is displayed.
Cross | An X-like cross shape is displayed.
Diamond | A diamond shape is displayed.
InvTriangle | An inverted triangle shape is displayed.
None | No shape is displayed.
Point | A dot shape is displayed.
Pyramid | A pyramid shape is displayed.
Square | A square shape is displayed.
Triangle | A triangle shape is displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.MarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


StandardAxis Enumeration

[image]
ActiveReports 19 .NET Edition
StandardAxis Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : StandardAxis Enumeration

Glossary Item Box

Specifies which axis is the standard axis.

Syntax

Visual Basic (Declaration)
Public Enum StandardAxis
   Inherits System.Enum
C#
public enum StandardAxis : System.Enum

Members

Member | Description
AxisX | The X axis is the standard axis.
AxisX2 | The secondary X axis is the standard axis.
AxisY | The Y axis is the standard axis.
AxisY2 | The secondary Y axis is the standard axis.
AxisZ | The Z axis is the standard axis.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.StandardAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


StdLegendMarker Enumeration

[image]
ActiveReports 19 .NET Edition
StdLegendMarker Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : StdLegendMarker Enumeration

Glossary Item Box

Specifies the standard legend marker shape to use.

Syntax

Visual Basic (Declaration)
Public Enum StdLegendMarker
   Inherits System.Enum
C#
public enum StdLegendMarker : System.Enum

Members

Member | Description
Area | A filled area shape is used.
Bar | A filled rectangular shape is used.
Line | A line is used.
None | No shape is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.StdLegendMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


UICommand Enumeration

[image]
ActiveReports 19 .NET Edition
UICommand Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : UICommand Enumeration

Glossary Item Box

Specifies the command to be used for the DoCommand method of the Chart control.

Syntax

Visual Basic (Declaration)
Public Enum UICommand
   Inherits System.Enum
C#
public enum UICommand : System.Enum

Members

Member | Description
Clear | The chart reverts to an empty state.
Copy | Copies the chart to the clipboard.
Customize | Displays the Chart Designer dialog.
Designer | Displays the Chart Designer dialog.
New | Creates a new chart.
OpenXml | Displays the Open File dialog to load a chart from an XML file.
PrintPreview | Displays a chart print preview.
RefreshData | Refreshes the chart data.
SaveXml | Displays the Save File dialog to save a chart to an XML file.
Wizard | Displays the chart wizard.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.UICommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


UIOptions Enumeration

[image]
ActiveReports 19 .NET Edition
UIOptions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : UIOptions Enumeration

Glossary Item Box

Specifies the user interface settings for the Chart control.

Syntax

Visual Basic (Declaration)
Public Enum UIOptions
   Inherits System.Enum
C#
public enum UIOptions : System.Enum

Members

Member | Description
ContextCustomize | Adds a "Customize" menu under the context menu.
ForceHitTesting | Allows the HitTest function to be used. By default the control applies optimization so that only objects that have mouse event handlers (or context menus or tooltips) attached are visible through hit testing.
None | No UI options are used.
UseCustomTooltips | Allows the drawn tooltips of the control to be used instead of System.Windows.Forms.Tooltip.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.UIOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


Padding Structure

[image]
ActiveReports 19 .NET Edition
Padding Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

Glossary Item Box

Provides the settings used to set a margin (four edges) inside a control.

Object Model

Padding Structure

Syntax

Visual Basic (Declaration)
Public Structure Padding
   Inherits System.ValueType
C#
public struct Padding : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Chart.Padding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Members
GrapeCity.ActiveReports.Chart Namespace


Padding Structure Members

[image]
ActiveReports 19 .NET Edition
Padding Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

Glossary Item Box

The following tables list the members exposed by Padding.

Public Constructors

 | Name | Description
Public Constructor | Padding Constructor | Overloaded. Initializes a new instance of the Padding structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a Padding object with no padding.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified Padding object equals the current Padding object.
Public Method | GetHashCode | Generates a hash code for the Padding object.
Top

Public Operators

public Operator Equality | Tests whether two Padding objects are equivalent.
public Operator Inequality | Tests whether two Padding objects are not equivalent.
Top

See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Padding Constructor

[image]
ActiveReports 19 .NET Edition
Padding Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Padding Constructor

Glossary Item Box

Initializes a new instance of the Padding structure.

Overload List

Overload | Description
Padding Constructor(Int32) | Initializes a new instance of the Padding structure using the same value for all edges.
Padding Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the Padding structure using the specified value for each edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Padding Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
Padding Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32)

all
Applies the same value to all four edges of the control.

Glossary Item Box

Initializes a new instance of the Padding structure using the same value for all edges.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal all As Integer _
)
C#
public Padding(
   int all
)

Parameters

all
Applies the same value to all four edges of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Constructor(Int32,Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
Padding Constructor(Int32,Int32,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32,Int32,Int32,Int32)

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.

Glossary Item Box

Initializes a new instance of the Padding structure using the specified value for each edge.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
C#
public Padding(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Structure Methods

[image]
ActiveReports 19 .NET Edition
Padding Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

Glossary Item Box

For a list of all members of this type, see Padding members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified Padding object equals the current Padding object.
Public Method | GetHashCode | Generates a hash code for the Padding object.
Top

See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Equals Method

Glossary Item Box

Determines whether the value of the specified Padding object equals the current Padding object.

Overload List

Overload | Description
Equals(Padding) | Determines whether the value of the specified Padding object equals the current Padding object.
Equals(Object) | Determines whether the value of the specified object equals the current Padding object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Equals(Padding) Method

[image]
ActiveReports 19 .NET Edition
Equals(Padding) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Equals Method : Equals(Padding) Method

padding
The Padding object to compare to the current Padding object.

Glossary Item Box

Determines whether the value of the specified Padding object equals the current Padding object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal padding As Padding _
) As Boolean
C#
public bool Equals(
   Padding padding
)

Parameters

padding
The Padding object to compare to the current Padding object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Equals Method : Equals(Object) Method

obj
The object to compare to the current Padding object.

Glossary Item Box

Determines whether the value of the specified object equals the current Padding object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare to the current Padding object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : GetHashCode Method

Glossary Item Box

Generates a hash code for the Padding object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Padding Structure Properties

[image]
ActiveReports 19 .NET Edition
Padding Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

Glossary Item Box

For a list of all members of this type, see Padding members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top

See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


All Property

[image]
ActiveReports 19 .NET Edition
All Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : All Property

Glossary Item Box

Gets or sets the padding value for all of the edges.

Syntax

Visual Basic (Declaration)
Public Property All As Integer
C#
public int All {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Bottom Property

Glossary Item Box

Gets or sets the padding value for the bottom edge.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Integer
C#
public int Bottom {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Horizontal Property

[image]
ActiveReports 19 .NET Edition
Horizontal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Horizontal Property

Glossary Item Box

Gets or sets the combined padding value for the left and right edges.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Horizontal As Integer
C#
public int Horizontal {get;}

Property Value

An integer value in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Left Property

Glossary Item Box

Gets or sets the padding value for the left edge.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Right Property

Glossary Item Box

Gets or sets the padding value for the right edge.

Syntax

Visual Basic (Declaration)
Public Property Right As Integer
C#
public int Right {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Size Property

Glossary Item Box

Gets the padding information for the control as a System.Drawing.Size structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Property Value

A System.Drawing.Size structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Top Property

Glossary Item Box

Gets or sets the padding value for the top edge.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Vertical Property

[image]
ActiveReports 19 .NET Edition
Vertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Vertical Property

Glossary Item Box

Gets or sets the combined padding value for the top and bottom edges.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertical As Integer
C#
public int Vertical {get;}

Property Value

An integer value in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Padding Structure Fields

[image]
ActiveReports 19 .NET Edition
Padding Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

Glossary Item Box

For a list of all members of this type, see Padding members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a Padding object with no padding.
Top

See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Empty Field

Glossary Item Box

Returns a Padding object with no padding.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Padding
C#
public static readonly Padding Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Equality Operator

p1
The first Padding object to compare.
p2
The second Padding object to compare.

Glossary Item Box

Tests whether two Padding objects are equivalent.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As Boolean
C#
public bool operator ==(
   Padding p1,
   Padding p2
)

Parameters

p1
The first Padding object to compare.
p2
The second Padding object to compare.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Inequality Operator

p1
The first Padding object to compare.
p2
The second Padding object to compare.

Glossary Item Box

Tests whether two Padding objects are not equivalent.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As Boolean
C#
public bool operator !=(
   Padding p1,
   Padding p2
)

Parameters

p1
The first Padding object to compare.
p2
The second Padding object to compare.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Padding Structure
Padding Members


IChartMemberNameProvider Interface

[image]
ActiveReports 19 .NET Edition
IChartMemberNameProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface

Glossary Item Box

Provides a name for the chart member name provider.

Syntax

Visual Basic (Declaration)
Public Interface IChartMemberNameProvider
C#
public interface IChartMemberNameProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMemberNameProvider Members
GrapeCity.ActiveReports.Chart Namespace


IChartMemberNameProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IChartMemberNameProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface

Glossary Item Box

The following tables list the members exposed by IChartMemberNameProvider.

Public Methods

 | Name | Description
Method | GetName | Gets the name for the field that should be found.
Top

See Also

Reference

IChartMemberNameProvider Interface
GrapeCity.ActiveReports.Chart Namespace


IChartMemberNameProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IChartMemberNameProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface

Glossary Item Box

For a list of all members of this type, see IChartMemberNameProvider members.

Public Methods

 | Name | Description
Method | GetName | Gets the name for the field that should be found.
Top

See Also

Reference

IChartMemberNameProvider Interface
GrapeCity.ActiveReports.Chart Namespace


GetName Method

[image]
ActiveReports 19 .NET Edition
GetName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > IChartMemberNameProvider Interface : GetName Method

i
The index of the field to find.

Glossary Item Box

Gets the name for the field that should be found.

Syntax

Visual Basic (Declaration)
Function GetName( _
   ByVal i As Integer _
) As String
C#
string GetName(
   int i
)

Parameters

i
The index of the field to find.

Return Value

The name of the field or the empty string (""), if there is no value to return.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMemberNameProvider Interface
IChartMemberNameProvider Members


ISharpGraph Interface

[image]
ActiveReports 19 .NET Edition
ISharpGraph Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ISharpGraph Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISharpGraph
C#
public interface ISharpGraph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Members
GrapeCity.ActiveReports.Chart Namespace


ISharpGraph Interface Members

[image]
ActiveReports 19 .NET Edition
ISharpGraph Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ISharpGraph Interface

Glossary Item Box

The following tables list the members exposed by ISharpGraph.

Public Properties

 | Name | Description
Property | AutoRefresh |
Property | Backdrop |
Property | Border |
Property | ChartAreas |
Property | ColorPalette |
Property | DataSource |
Property | DeviceMode |
Property | GridLayout |
Property | IsDesignMode |
Property | Legends |
Property | RegisteredComponents |
Property | Series |
Property | Titles |
Property | UIOptions |
Top

Public Methods

 | Name | Description
Method | FixReferences |
Method | GetCultureInfo |
Method | Invalidate |
Method | QuickLoad |
Method | QuickSave |
Method | ReadXml |
Method | SetDirty |
Method | SetTooltipText |
Method | TransferToCore |
Method | WriteXml |
Top

See Also

Reference

ISharpGraph Interface
GrapeCity.ActiveReports.Chart Namespace


ISharpGraph Interface Methods

[image]
ActiveReports 19 .NET Edition
ISharpGraph Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ISharpGraph Interface

Glossary Item Box

For a list of all members of this type, see ISharpGraph members.

Public Methods

 | Name | Description
Method | FixReferences |
Method | GetCultureInfo |
Method | Invalidate |
Method | QuickLoad |
Method | QuickSave |
Method | ReadXml |
Method | SetDirty |
Method | SetTooltipText |
Method | TransferToCore |
Method | WriteXml |
Top

See Also

Reference

ISharpGraph Interface
GrapeCity.ActiveReports.Chart Namespace


FixReferences Method

[image]
ActiveReports 19 .NET Edition
FixReferences Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : FixReferences Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub FixReferences()
C#
void FixReferences()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


GetCultureInfo Method

[image]
ActiveReports 19 .NET Edition
GetCultureInfo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : GetCultureInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetCultureInfo() As CultureInfo
C#
CultureInfo GetCultureInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Invalidate Method

[image]
ActiveReports 19 .NET Edition
Invalidate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Invalidate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub Invalidate()
C#
void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


QuickLoad Method

[image]
ActiveReports 19 .NET Edition
QuickLoad Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : QuickLoad Method

binReader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub QuickLoad( _
   ByVal binReader As BinaryReader _
)
C#
void QuickLoad(
   BinaryReader binReader
)

Parameters

binReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


QuickSave Method

[image]
ActiveReports 19 .NET Edition
QuickSave Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : QuickSave Method

binWriter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub QuickSave( _
   ByVal binWriter As BinaryWriter _
)
C#
void QuickSave(
   BinaryWriter binWriter
)

Parameters

binWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


ReadXml Method

[image]
ActiveReports 19 .NET Edition
ReadXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : ReadXml Method

controlNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub ReadXml( _
   ByVal controlNode As XmlElement _
)
C#
void ReadXml(
   XmlElement controlNode
)

Parameters

controlNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


SetDirty Method

[image]
ActiveReports 19 .NET Edition
SetDirty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : SetDirty Method

f

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SetDirty( _
   ByVal f As Boolean _
)
C#
void SetDirty(
   bool f
)

Parameters

f

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


SetTooltipText Method

[image]
ActiveReports 19 .NET Edition
SetTooltipText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : SetTooltipText Method

tooltipText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub SetTooltipText( _
   ByVal tooltipText As String _
)
C#
void SetTooltipText(
   string tooltipText
)

Parameters

tooltipText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


TransferToCore Method

[image]
ActiveReports 19 .NET Edition
TransferToCore Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : TransferToCore Method

engine

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub TransferToCore( _
   ByVal engine As Object _
)
C#
void TransferToCore(
   object engine
)

Parameters

engine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


WriteXml Method

[image]
ActiveReports 19 .NET Edition
WriteXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : WriteXml Method

controlNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub WriteXml( _
   ByVal controlNode As XmlElement _
)
C#
void WriteXml(
   XmlElement controlNode
)

Parameters

controlNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


ISharpGraph Interface Properties

[image]
ActiveReports 19 .NET Edition
ISharpGraph Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : ISharpGraph Interface

Glossary Item Box

For a list of all members of this type, see ISharpGraph members.

Public Properties

 | Name | Description
Property | AutoRefresh |
Property | Backdrop |
Property | Border |
Property | ChartAreas |
Property | ColorPalette |
Property | DataSource |
Property | DeviceMode |
Property | GridLayout |
Property | IsDesignMode |
Property | Legends |
Property | RegisteredComponents |
Property | Series |
Property | Titles |
Property | UIOptions |
Top

See Also

Reference

ISharpGraph Interface
GrapeCity.ActiveReports.Chart Namespace


AutoRefresh Property

[image]
ActiveReports 19 .NET Edition
AutoRefresh Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : AutoRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property AutoRefresh As Boolean
C#
bool AutoRefresh {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Backdrop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Backdrop As BackdropItem
C#
BackdropItem Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Border Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Border As Border
C#
Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


ChartAreas Property

[image]
ActiveReports 19 .NET Edition
ChartAreas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : ChartAreas Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ChartAreas As ChartAreasCollection
C#
ChartAreasCollection ChartAreas {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


ColorPalette Property

[image]
ActiveReports 19 .NET Edition
ColorPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : ColorPalette Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property ColorPalette As ColorPalette
C#
ColorPalette ColorPalette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


DataSource Property

[image]
ActiveReports 19 .NET Edition
DataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DataSource As Object
C#
object DataSource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


DeviceMode Property

[image]
ActiveReports 19 .NET Edition
DeviceMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : DeviceMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property DeviceMode As DeviceModes
C#
DeviceModes DeviceMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


GridLayout Property

[image]
ActiveReports 19 .NET Edition
GridLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : GridLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property GridLayout As GridLayout
C#
GridLayout GridLayout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


IsDesignMode Property

[image]
ActiveReports 19 .NET Edition
IsDesignMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : IsDesignMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsDesignMode As Boolean
C#
bool IsDesignMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Legends Property

[image]
ActiveReports 19 .NET Edition
Legends Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Legends Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Legends As LegendsCollection
C#
LegendsCollection Legends {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


RegisteredComponents Property

[image]
ActiveReports 19 .NET Edition
RegisteredComponents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : RegisteredComponents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RegisteredComponents As IDictionary(Of Object,String)
C#
IDictionary<object,string> RegisteredComponents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Series Property

[image]
ActiveReports 19 .NET Edition
Series Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Series Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Series As SeriesCollection
C#
SeriesCollection Series {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Titles Property

[image]
ActiveReports 19 .NET Edition
Titles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Titles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Titles As TitlesCollection
C#
TitlesCollection Titles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


UIOptions Property

[image]
ActiveReports 19 .NET Edition
UIOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : UIOptions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property UIOptions As UIOptions
C#
UIOptions UIOptions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


CustomDrawEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
CustomDrawEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventHandler Delegate

sender
Source of the event
e
CustomDrawEventArgs class which contains the event data.

Glossary Item Box

Represents the method that handles the CustomDraw event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub CustomDrawEventHandler( _
   ByVal sender As Object, _
   ByVal e As CustomDrawEventArgs _
)
C#
public delegate void CustomDrawEventHandler(
   object sender,
   CustomDrawEventArgs e
)

Parameters

sender
Source of the event
e
CustomDrawEventArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDrawEventHandler Members
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
GraphMouseEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventHandler Delegate

sender
Source of the event.
e
GraphMouseEventArgs class which contains the event data.

Glossary Item Box

Represents the method that handles the GraphMouse event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub GraphMouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As GraphMouseEventArgs _
)
C#
public delegate void GraphMouseEventHandler(
   object sender,
   GraphMouseEventArgs e
)

Parameters

sender
Source of the event.
e
GraphMouseEventArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphMouseEventHandler Members
GrapeCity.ActiveReports.Chart Namespace


Annotation Class

[image]
ActiveReports 19 .NET Edition
Annotation Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class

Glossary Item Box

Represents the base class for all of the annotation classes.

Object Model

Annotation Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Annotation
   Inherits GrapeCity.ActiveReports.Chart.MouseEnabledComponent
C#
public abstract class Annotation : GrapeCity.ActiveReports.Chart.MouseEnabledComponent

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


Annotation Class Members

[image]
ActiveReports 19 .NET Edition
Annotation Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class

Glossary Item Box

The following tables list the members exposed by Annotation.

Public Properties

 | Name | Description
Public Property | AnnotationClass | Gets the name of the annotation type.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Annotation Class Properties

[image]
ActiveReports 19 .NET Edition
Annotation Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Properties

 | Name | Description
Public Property | AnnotationClass | Gets the name of the annotation type.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationClass Property

[image]
ActiveReports 19 .NET Edition
AnnotationClass Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > Annotation Class : AnnotationClass Property

Glossary Item Box

Gets the name of the annotation type.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property AnnotationClass As String
C#
public abstract string AnnotationClass {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


AnnotationLine Class

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

Glossary Item Box

Represents the settings for the AnnotationLine class.

Object Model

AnnotationLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationLine
   Inherits Annotation
C#
public sealed class AnnotationLine : Annotation

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationLine Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

Glossary Item Box

The following tables list the members exposed by AnnotationLine.

Public Constructors

 | Name | Description
Public Constructor | AnnotationLine Constructor | Initializes a new instance of the AnnotationLine class.
Top

Public Properties

 | Name | Description
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | EndConnection | Gets or sets the object to which to connect the end point of the annotation line.
Public Property | EndConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | Line | Get or sets the line information used to draw this annotation.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationLine as string.
Public Property | StartConnection | Gets or sets the object to which to connect the start point of the annotation line.
Public Property | StartConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.
Public Property | StartPoint | Get or sets start point of the line.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationLine object.
Public Method | ToString | Overridden. Converts the value of the current instance to its string representation.
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationLine Constructor()

[image]
ActiveReports 19 .NET Edition
AnnotationLine Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class > AnnotationLine Constructor : AnnotationLine Constructor()

Glossary Item Box

Initializes a new instance of the AnnotationLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members
Overload List


AnnotationLine Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationLine object.
Public Method | ToString | Overridden. Converts the value of the current instance to its string representation.
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Clone Method

Glossary Item Box

Creates a clone of the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the AnnotationLine object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Properties

 | Name | Description
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | EndConnection | Gets or sets the object to which to connect the end point of the annotation line.
Public Property | EndConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | Line | Get or sets the line information used to draw this annotation.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationLine as string.
Public Property | StartConnection | Gets or sets the object to which to connect the start point of the annotation line.
Public Property | StartConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.
Public Property | StartPoint | Get or sets start point of the line.
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationClass Property

[image]
ActiveReports 19 .NET Edition
AnnotationClass Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : AnnotationClass Property

Glossary Item Box

Gets the name of the annotation type.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AnnotationClass As String
C#
public override string AnnotationClass {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndConnection Property

[image]
ActiveReports 19 .NET Edition
EndConnection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndConnection Property

Glossary Item Box

Gets or sets the object to which to connect the end point of the annotation line.

Syntax

Visual Basic (Declaration)
Public Property EndConnection As AnnotationTextBar
C#
public AnnotationTextBar EndConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndConnectionIndex Property

[image]
ActiveReports 19 .NET Edition
EndConnectionIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndConnectionIndex Property

Glossary Item Box

Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.

Syntax

Visual Basic (Declaration)
Public Property EndConnectionIndex As Integer
C#
public int EndConnectionIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndPoint Property

[image]
ActiveReports 19 .NET Edition
EndPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndPoint Property

Glossary Item Box

Gets or sets the end point of the line.

Syntax

Visual Basic (Declaration)
Public Property EndPoint As Point2d
C#
public Point2d EndPoint {get; set;}

Remarks

The EndPoint value is not used if the end of the line is connected to another annotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Line Property

Glossary Item Box

Get or sets the line information used to draw this annotation.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Name Property

Glossary Item Box

Gets or sets the name of the AnnotationLine as string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Name As String
C#
public override string Name {get; set;}

Property Value

The name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartConnection Property

[image]
ActiveReports 19 .NET Edition
StartConnection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartConnection Property

Glossary Item Box

Gets or sets the object to which to connect the start point of the annotation line.

Syntax

Visual Basic (Declaration)
Public Property StartConnection As AnnotationTextBar
C#
public AnnotationTextBar StartConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartConnectionIndex Property

[image]
ActiveReports 19 .NET Edition
StartConnectionIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartConnectionIndex Property

Glossary Item Box

Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.

Syntax

Visual Basic (Declaration)
Public Property StartConnectionIndex As Integer
C#
public int StartConnectionIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartPoint Property

[image]
ActiveReports 19 .NET Edition
StartPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartPoint Property

Glossary Item Box

Get or sets start point of the line.

Syntax

Visual Basic (Declaration)
Public Property StartPoint As Point2d
C#
public Point2d StartPoint {get; set;}

Remarks

The StartPoint value is not used if the beginning of the line is connected to another annotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationsCollection Class

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

Glossary Item Box

Represents the settings of the AnnotationsCollection class.

Object Model

AnnotationsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationsCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class AnnotationsCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.Annotations.AnnotationsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationsCollection Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

Glossary Item Box

The following tables list the members exposed by AnnotationsCollection.

Public Constructors

 | Name | Description
Public Constructor | AnnotationsCollection Constructor | Overloaded. Initializes a new instance of the AnnotationsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the given index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an Annotation to the collection.
Public Method | AddRange | Adds an array of annotations to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the AnnotationsCollection.
Public Method | Contains | Determines whether the collection contains the specified annotation.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts an Annotation into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Annotation from the collection.
Public Method | RemoveAt | Removes the specified annotation from the collection.
Public Method | ToArray | Copies the elements of the AnnotationsCollection to a new array.
Top

Public Events

 | Name | Description
Public Event | Change | Occurs when the content of the collection changes.
Top

See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationsCollection Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : AnnotationsCollection Constructor

Glossary Item Box

Initializes a new instance of the AnnotationsCollection class.

Overload List

Overload | Description
AnnotationsCollection Constructor() | Initializes a new instance of the AnnotationsCollection class.
AnnotationsCollection Constructor(Annotation[]) | Initializes a new instance of the AnnotationsCollection class with the specified array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationsCollection Constructor()

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > AnnotationsCollection Constructor : AnnotationsCollection Constructor()

Glossary Item Box

Initializes a new instance of the AnnotationsCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Constructor(Annotation[])

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Constructor(Annotation[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > AnnotationsCollection Constructor : AnnotationsCollection Constructor(Annotation[])

annArray

Specifies the array of annotations to use.

Glossary Item Box

Initializes a new instance of the AnnotationsCollection class with the specified array.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal annArray() As Annotation _
)
C#
public AnnotationsCollection(
   Annotation[] annArray
)

Parameters

annArray

Specifies the array of annotations to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an Annotation to the collection.
Public Method | AddRange | Adds an array of annotations to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the AnnotationsCollection.
Public Method | Contains | Determines whether the collection contains the specified annotation.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts an Annotation into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Annotation from the collection.
Public Method | RemoveAt | Removes the specified annotation from the collection.
Public Method | ToArray | Copies the elements of the AnnotationsCollection to a new array.
Top

See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Add Method

value
The annotation to add.

Glossary Item Box

Adds an Annotation to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Annotation _
) As Integer
C#
public int Add(
   Annotation value
)

Parameters

value
The annotation to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : AddRange Method

value
The set of annotations to add to the collection.

Glossary Item Box

Adds an array of annotations to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal value() As Annotation _
)
C#
public void AddRange(
   Annotation[] value
)

Parameters

value
The set of annotations to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Clear Method

Glossary Item Box

Clears all items from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Clone Method

Glossary Item Box

Creates a clone of the AnnotationsCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A clone of the AnnotationsCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Contains Method

value
The annotation to check.

Glossary Item Box

Determines whether the collection contains the specified annotation.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Annotation _
) As Boolean
C#
public bool Contains(
   Annotation value
)

Parameters

value
The annotation to check.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : CopyTo Method

array
The array to which to copy the collection.
index
The index from which to start.

Glossary Item Box

Copies the entire collection to an array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Annotation, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Annotation[] array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Dispose Method

Glossary Item Box

Releases resources associated with this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : IndexOf Method

value
The object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Annotation _
) As Integer
C#
public int IndexOf(
   Annotation value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Insert Method

index
The index at which the Annotation is inserted.
value
The Annotation to insert.

Glossary Item Box

Inserts an Annotation into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Annotation _
)
C#
public void Insert(
   int index,
   Annotation value
)

Parameters

index
The index at which the Annotation is inserted.
value
The Annotation to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Remove Method

value
The Annotation to remove.

Glossary Item Box

Removes the first occurrence of a specific Annotation from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Annotation _
)
C#
public void Remove(
   Annotation value
)

Parameters

value
The Annotation to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : RemoveAt Method

index
The index of the Annotation to remove.

Glossary Item Box

Removes the specified annotation from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public new void RemoveAt(
   int index
)

Parameters

index
The index of the Annotation to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : ToArray Method

Glossary Item Box

Copies the elements of the AnnotationsCollection to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As Annotation()
C#
public Annotation[] ToArray()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationsCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the given index.
Top

See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Item Property

Glossary Item Box

Gets or sets the collection item by the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the collection item by the specified index.
Item(String) | Gets or sets the collection item by the specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > Item Property : Item(Int32) Property

index
The index of the item.

Glossary Item Box

Gets or sets the collection item by the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As Annotation
C#
public Annotation Item(
   int index
) {get; set;}

Parameters

index
The index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > Item Property : Item(String) Property

annotationName
Name of the annotation.

Glossary Item Box

Gets or sets the collection item by the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal annotationName As String _
) As Annotation
C#
public Annotation Item(
   string annotationName
) {get;}

Parameters

annotationName
Name of the annotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationsCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationsCollection members.

Public Events

 | Name | Description
Public Event | Change | Occurs when the content of the collection changes.
Top

See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Change Event

[image]
ActiveReports 19 .NET Edition
Change Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Change Event

Glossary Item Box

Occurs when the content of the collection changes.

Syntax

Visual Basic (Declaration)
Public Event Change As EventHandler
C#
public event EventHandler Change

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationTextBar Class

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

Glossary Item Box

Represents the settings for the AnnotationTextBar class.

Object Model

AnnotationTextBar Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationTextBar
   Inherits Annotation
C#
public sealed class AnnotationTextBar : Annotation

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationTextBar Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

Glossary Item Box

The following tables list the members exposed by AnnotationTextBar.

Public Constructors

 | Name | Description
Public Constructor | AnnotationTextBar Constructor | Initializes new instance of AnnotationTextBar object with all properties set to its defaults.
Top

Public Properties

 | Name | Description
Public Property | AnchorPlacement | Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.
Public Property | AnchorPoint | Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the AnnotationTextBar.
Public Property | Font | Gets or sets the font information used to display text for the AnnotationTextBar.
Public Property | Height | Gets or sets the height of the text bar.
Public Property | Line | Gets or sets the line information used to draw the border for the text bar.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationTextBar as string.
Public Property | RotationAngle | Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.
Public Property | Text | Gets or sets the text string that is displayed in the text bar.
Public Property | Width | Gets or sets the width of the AnnotationTextBar.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationTextBar object.
Top

See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationTextBar Constructor()

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class > AnnotationTextBar Constructor : AnnotationTextBar Constructor()

Glossary Item Box

Initializes new instance of AnnotationTextBar object with all properties set to its defaults.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationTextBar()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members
Overload List


AnnotationTextBar Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

Glossary Item Box

For a list of all members of this type, see AnnotationTextBar members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationTextBar object.
Top

See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Clone Method

Glossary Item Box

Creates a clone of the AnnotationTextBar object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the AnnotationTextBar object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnnotationTextBar Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

Glossary Item Box

For a list of all members of this type, see AnnotationTextBar members.

Public Properties

 | Name | Description
Public Property | AnchorPlacement | Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.
Public Property | AnchorPoint | Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the AnnotationTextBar.
Public Property | Font | Gets or sets the font information used to display text for the AnnotationTextBar.
Public Property | Height | Gets or sets the height of the text bar.
Public Property | Line | Gets or sets the line information used to draw the border for the text bar.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationTextBar as string.
Public Property | RotationAngle | Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.
Public Property | Text | Gets or sets the text string that is displayed in the text bar.
Public Property | Width | Gets or sets the width of the AnnotationTextBar.
Top

See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnchorPlacement Property

[image]
ActiveReports 19 .NET Edition
AnchorPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnchorPlacement Property

Glossary Item Box

Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.

Syntax

Visual Basic (Declaration)
Public Property AnchorPlacement As AnchorPlacementType
C#
public AnchorPlacementType AnchorPlacement {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnchorPoint Property

[image]
ActiveReports 19 .NET Edition
AnchorPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnchorPoint Property

Glossary Item Box

Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.

Syntax

Visual Basic (Declaration)
Public Property AnchorPoint As Point2d
C#
public Point2d AnchorPoint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnnotationClass Property

[image]
ActiveReports 19 .NET Edition
AnnotationClass Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnnotationClass Property

Glossary Item Box

Gets the name of the annotation type.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AnnotationClass As String
C#
public override string AnnotationClass {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Backdrop Property

Glossary Item Box

Gets or sets the backdrop information used to fill the AnnotationTextBar.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As Backdrop
C#
public Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Font Property

Glossary Item Box

Gets or sets the font information used to display text for the AnnotationTextBar.

Syntax

Visual Basic (Declaration)
Public Property Font As FontInfo
C#
public FontInfo Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Height Property

Glossary Item Box

Gets or sets the height of the text bar.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Line Property

Glossary Item Box

Gets or sets the line information used to draw the border for the text bar.

Syntax

Visual Basic (Declaration)
Public Property Line As Line
C#
public Line Line {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Name Property

Glossary Item Box

Gets or sets the name of the AnnotationTextBar as string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Name As String
C#
public override string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


RotationAngle Property

[image]
ActiveReports 19 .NET Edition
RotationAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : RotationAngle Property

Glossary Item Box

Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.

Syntax

Visual Basic (Declaration)
Public Property RotationAngle As Single
C#
public float RotationAngle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Text Property

Glossary Item Box

Gets or sets the text string that is displayed in the text bar.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Width Property

Glossary Item Box

Gets or sets the width of the AnnotationTextBar.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnchorPlacementType Enumeration

[image]
ActiveReports 19 .NET Edition
AnchorPlacementType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnchorPlacementType Enumeration

Glossary Item Box

Specifies how an annotation bar anchors to the position of an Annotation.

Syntax

Visual Basic (Declaration)
Public Enum AnchorPlacementType
   Inherits System.Enum
C#
public enum AnchorPlacementType : System.Enum

Members

Member | Description
Bottom | The bar is anchored by its bottom side.
BottomLeft | The bar is anchored by its bottom left corner.
BottomRight | The bar is anchored by its bottom right corner.
Center | The bar is anchored by its center.
Left | The bar is anchored by its left side.
Right | The bar is anchored by its top right side.
Top | The bar is anchored by its top side.
TopLeft | The bar is anchored by its top left corner.
TopRight | The bar is anchored by its top right corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Annotations Namespace


Font Class

[image]
ActiveReports 19 .NET Edition
Font Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Font Class

Glossary Item Box

GDI-like font descriptor.

Object Model

Font Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Font
C#
public sealed class Font

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Members
GrapeCity.ActiveReports.Chart.Drawing Namespace


Font Class Members

[image]
ActiveReports 19 .NET Edition
Font Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Font Class

Glossary Item Box

The following tables list the members exposed by Font.

Public Constructors

 | Name | Description
Public Constructor | Font Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bold |
Public Property | GdiCharSet |
Public Property | GdiVerticalFont |
Public Property | Italic |
Public Property | Name |
Public Property | OriginalFontName |
Public Property | Size |
Public Property | SizeInPoints |
Public Property | Strikeout |
Public Property | Style |
Public Property | Underline |
Public Property | Unit |
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Font Constructor

[image]
ActiveReports 19 .NET Edition
Font Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Font Constructor

Glossary Item Box

Overload List

Overload | Description
Font Constructor(String,Single) |
Font Constructor(String,Single,FontStyle) |
Font Constructor(String,Single,GraphicsUnit) |
Font Constructor(String,Single,FontStyle,GraphicsUnit) |
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Font Constructor(String,Single)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single)

familyName
emSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single _
)
C#
public Font(
   string familyName,
   float emSize
)

Parameters

familyName
emSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle)

familyName
emSize
style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style
)

Parameters

familyName
emSize
style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,GraphicsUnit)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,GraphicsUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,GraphicsUnit)

familyName
emSize
unit

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal unit As GraphicsUnit _
)
C#
public Font(
   string familyName,
   float emSize,
   GraphicsUnit unit
)

Parameters

familyName
emSize
unit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle,GraphicsUnit)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle,GraphicsUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle,GraphicsUnit)

familyName
emSize
style
unit

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
)

Parameters

familyName
emSize
style
unit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)

familyName
emSize
style
unit
gdiCharSet
gdiVerticalFont

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit, _
   ByVal gdiCharSet As Byte, _
   ByVal gdiVerticalFont As Boolean _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit,
   byte gdiCharSet,
   bool gdiVerticalFont
)

Parameters

familyName
emSize
style
unit
gdiCharSet
gdiVerticalFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Class Methods

[image]
ActiveReports 19 .NET Edition
Font Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Font Class Properties

[image]
ActiveReports 19 .NET Edition
Font Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Properties

 | Name | Description
Public Property | Bold |
Public Property | GdiCharSet |
Public Property | GdiVerticalFont |
Public Property | Italic |
Public Property | Name |
Public Property | OriginalFontName |
Public Property | Size |
Public Property | SizeInPoints |
Public Property | Strikeout |
Public Property | Style |
Public Property | Underline |
Public Property | Unit |
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Bold Property

[image]
ActiveReports 19 .NET Edition
Bold Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Bold Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bold As Boolean
C#
public bool Bold {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GdiCharSet Property

[image]
ActiveReports 19 .NET Edition
GdiCharSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : GdiCharSet Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GdiCharSet As Byte
C#
public byte GdiCharSet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GdiVerticalFont Property

[image]
ActiveReports 19 .NET Edition
GdiVerticalFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : GdiVerticalFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GdiVerticalFont As Boolean
C#
public bool GdiVerticalFont {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Italic Property

[image]
ActiveReports 19 .NET Edition
Italic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Italic Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Italic As Boolean
C#
public bool Italic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


OriginalFontName Property

[image]
ActiveReports 19 .NET Edition
OriginalFontName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : OriginalFontName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginalFontName As String
C#
public string OriginalFontName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Single
C#
public float Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


SizeInPoints Property

[image]
ActiveReports 19 .NET Edition
SizeInPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : SizeInPoints Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SizeInPoints As Single
C#
public float SizeInPoints {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Strikeout Property

[image]
ActiveReports 19 .NET Edition
Strikeout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Strikeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Strikeout As Boolean
C#
public bool Strikeout {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As FontStyle
C#
public FontStyle Style {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Underline Property

[image]
ActiveReports 19 .NET Edition
Underline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Underline Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Underline As Boolean
C#
public bool Underline {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Font Class : Unit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unit As GraphicsUnit
C#
public GraphicsUnit Unit {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Image Class

[image]
ActiveReports 19 .NET Edition
Image Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Image Class

Glossary Item Box

GDI-like image descriptor.

Object Model

Image Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Image
C#
public sealed class Image

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Members
GrapeCity.ActiveReports.Chart.Drawing Namespace


Image Class Members

[image]
ActiveReports 19 .NET Edition
Image Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Image Class

Glossary Item Box

The following tables list the members exposed by Image.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Height | Gets the height of this Image.
Public Property | HorizontalResolution | Gets the horizontal resolution, in pixels-per-inch, of this Image.
Public Property | RawFormat | Gets the format of this Image.
Public Property | Size | Gets the width and height of this Image.
Public Property | VerticalResolution | Gets the vertical resolution, in pixels-per-inch, of this Image.
Public Property | Width | Gets the width of this Image.
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
static (Shared in Visual Basic) | FromStream | Creates an Image from the specified data stream.
Public Method | Save | Saves this Image to the specified stream in the specified format.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Image Class Methods

[image]
ActiveReports 19 .NET Edition
Image Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
static (Shared in Visual Basic) | FromStream | Creates an Image from the specified data stream.
Public Method | Save | Saves this Image to the specified stream in the specified format.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


FromStream Method

[image]
ActiveReports 19 .NET Edition
FromStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : FromStream Method

stream

Glossary Item Box

Creates an Image from the specified data stream.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As Image
C#
public static Image FromStream(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Save Method

stream
format

Glossary Item Box

Saves this Image to the specified stream in the specified format.

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal stream As Stream, _
   ByVal format As ImageFormat _
)
C#
public void Save(
   Stream stream,
   ImageFormat format
)

Parameters

stream
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Image Class Properties

[image]
ActiveReports 19 .NET Edition
Image Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Height | Gets the height of this Image.
Public Property | HorizontalResolution | Gets the horizontal resolution, in pixels-per-inch, of this Image.
Public Property | RawFormat | Gets the format of this Image.
Public Property | Size | Gets the width and height of this Image.
Public Property | VerticalResolution | Gets the vertical resolution, in pixels-per-inch, of this Image.
Public Property | Width | Gets the width of this Image.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
C#
public byte[] Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Height Property

Glossary Item Box

Gets the height of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


HorizontalResolution Property

[image]
ActiveReports 19 .NET Edition
HorizontalResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : HorizontalResolution Property

Glossary Item Box

Gets the horizontal resolution, in pixels-per-inch, of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalResolution As Single
C#
public float HorizontalResolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


RawFormat Property

[image]
ActiveReports 19 .NET Edition
RawFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : RawFormat Property

Glossary Item Box

Gets the format of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RawFormat As ImageFormat
C#
public ImageFormat RawFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Size Property

Glossary Item Box

Gets the width and height of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


VerticalResolution Property

[image]
ActiveReports 19 .NET Edition
VerticalResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : VerticalResolution Property

Glossary Item Box

Gets the vertical resolution, in pixels-per-inch, of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalResolution As Single
C#
public float VerticalResolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Image Class : Width Property

Glossary Item Box

Gets the width of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Region Class

[image]
ActiveReports 19 .NET Edition
Region Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Region Class

Glossary Item Box

Cross-platform range implementation. Describes the interior of a graphics shape composed of rectangles and paths.

Object Model

Region Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Region
C#
public sealed class Region

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Members
GrapeCity.ActiveReports.Chart.Drawing Namespace


Region Class Members

[image]
ActiveReports 19 .NET Edition
Region Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Region Class

Glossary Item Box

The following tables list the members exposed by Region.

Public Constructors

 | Name | Description
Public Constructor | Region Constructor | Initializes a new Region.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this Region.
static (Shared in Visual Basic) | CreateRegion | Creates new Region that consists from path.
Public Method | Dispose |
Public Method | GetBounds | Gets a RectangleF structure that represents a rectangle that bounds this Region
Public Method | IsVisible | Overloaded.
Public Method | MakeEmpty | Initializes this Region to an empty interior.
Public Method | Union | Updates this Region to the union of itself and the specified GraphicsPath.
Top

See Also

Reference

Region Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Region Constructor

[image]
ActiveReports 19 .NET Edition
Region Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : Region Constructor

Glossary Item Box

Initializes a new Region.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Region()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


Region Class Methods

[image]
ActiveReports 19 .NET Edition
Region Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : Region Class

Glossary Item Box

For a list of all members of this type, see Region members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this Region.
static (Shared in Visual Basic) | CreateRegion | Creates new Region that consists from path.
Public Method | Dispose |
Public Method | GetBounds | Gets a RectangleF structure that represents a rectangle that bounds this Region
Public Method | IsVisible | Overloaded.
Public Method | MakeEmpty | Initializes this Region to an empty interior.
Public Method | Union | Updates this Region to the union of itself and the specified GraphicsPath.
Top

See Also

Reference

Region Class
GrapeCity.ActiveReports.Chart.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : Clone Method

Glossary Item Box

Creates an exact copy of this Region.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Region
C#
public Region Clone()

Return Value

The Region that this method creates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


CreateRegion Method

[image]
ActiveReports 19 .NET Edition
CreateRegion Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : CreateRegion Method

path

Glossary Item Box

Creates new Region that consists from path.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRegion( _
   ByVal path As GraphicsPath _
) As Region
C#
public static Region CreateRegion(
   GraphicsPath path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


GetBounds Method

[image]
ActiveReports 19 .NET Edition
GetBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : GetBounds Method

Glossary Item Box

Gets a RectangleF structure that represents a rectangle that bounds this Region

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As RectangleF
C#
public RectangleF GetBounds()

Return Value

A RectangleF structure that represents the bounding rectangle for this Region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : IsVisible Method

Glossary Item Box

Overload List

Overload | Description
IsVisible(Single,Single) |
IsVisible(PointF) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


IsVisible(Single,Single) Method

[image]
ActiveReports 19 .NET Edition
IsVisible(Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class > IsVisible Method : IsVisible(Single,Single) Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsVisible( _
   ByVal x As Single, _
   ByVal y As Single _
) As Boolean
C#
public bool IsVisible(
   float x,
   float y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members
Overload List


IsVisible(PointF) Method

[image]
ActiveReports 19 .NET Edition
IsVisible(PointF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class > IsVisible Method : IsVisible(PointF) Method

point

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsVisible( _
   ByVal point As PointF _
) As Boolean
C#
public bool IsVisible(
   PointF point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members
Overload List


MakeEmpty Method

[image]
ActiveReports 19 .NET Edition
MakeEmpty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : MakeEmpty Method

Glossary Item Box

Initializes this Region to an empty interior.

Syntax

Visual Basic (Declaration)
Public Sub MakeEmpty()
C#
public void MakeEmpty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


Union Method

[image]
ActiveReports 19 .NET Edition
Union Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : Union Method

path
The GraphicsPath to unite with this Region.

Glossary Item Box

Updates this Region to the union of itself and the specified GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Sub Union( _
   ByVal path As GraphicsPath _
)
C#
public void Union(
   GraphicsPath path
)

Parameters

path
The GraphicsPath to unite with this Region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


FontStyle Enumeration

[image]
ActiveReports 19 .NET Edition
FontStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : FontStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum FontStyle
   Inherits System.Enum
C#
public enum FontStyle : System.Enum

Members

Member | Description
Bold |
Italic |
Regular |
Strikeout |
Underline |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Drawing.FontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Drawing Namespace


GraphicsUnit Enumeration

[image]
ActiveReports 19 .NET Edition
GraphicsUnit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace : GraphicsUnit Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GraphicsUnit
   Inherits System.Enum
C#
public enum GraphicsUnit : System.Enum

Members

Member | Description
Display |
Document |
Inch |
Millimeter |
Pixel |
Point |
World |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Drawing.GraphicsUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Drawing Namespace


GraphicsPath Class

[image]
ActiveReports 19 .NET Edition
GraphicsPath Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace : GraphicsPath Class

Glossary Item Box

Cross-platform graphics path implementation. Represents a series of connected lines and curves.

Object Model

GraphicsPath Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GraphicsPath
C#
public sealed class GraphicsPath

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D.GraphicsPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Members
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace


GraphicsPath Class Members

[image]
ActiveReports 19 .NET Edition
GraphicsPath Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace : GraphicsPath Class

Glossary Item Box

The following tables list the members exposed by GraphicsPath.

Public Constructors

 | Name | Description
Public Constructor | GraphicsPath Constructor |
Top

Public Properties

 | Name | Description
Public Property | PathPoints | Gets the points in the path.
Public Property | PathTypes |
Top

Public Methods

 | Name | Description
Public Method | AddArc | Appends an elliptical arc to the current figure.
Public Method | AddBeziers | Adds a sequence of connected cubic Bézier curves to the current figure.
Public Method | AddCurve | Adds a spline curve to the current figure. A cardinal spline curve is used because the curve travels through each of the points in the array.
Public Method | AddEllipse | Adds an ellipse to the current path.
Public Method | AddLine | Overloaded. Appends a line segment to this GraphicsPath.
Public Method | AddLines | Appends a series of connected line segments to the end of this GraphicsPath.
Public Method | AddPath | Appends the specified GraphicsPath to this path.
Public Method | AddPolygon | Adds a polygon to this path.
Public Method | AddRectangle | Adds a rectangle to this path and closes the figure.
Public Method | Clone | Creates an exact copy of this path.
Public Method | CloseAllFigures | Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.
Public Method | CloseFigure | Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.
Public Method | Dispose |
Public Method | Flatten | Converts each curve in this path into a sequence of connected line segments.
Public Method | GetBounds | Returns a rectangle that bounds this GraphicsPath.
Public Method | GetLastPoint | Gets the last point in the PathPoints array of this GraphicsPath.
Public Method | IsVisible | Indicates whether the specified point is contained within this GraphicsPath.
Public Method | Reverse | Reverses the order of points in the PathPoints array of this GraphicsPath.
Public Method | Transform | Applies a transform matrix to this GraphicsPath.
Public Method | Widen | Replaces this path with sequence of connected line segments that enclose the area.
Top

See Also

Reference

GraphicsPath Class
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace


GraphicsPath Constructor

[image]
ActiveReports 19 .NET Edition
GraphicsPath Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : GraphicsPath Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GraphicsPath()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


GraphicsPath Class Methods

[image]
ActiveReports 19 .NET Edition
GraphicsPath Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace : GraphicsPath Class

Glossary Item Box

For a list of all members of this type, see GraphicsPath members.

Public Methods

 | Name | Description
Public Method | AddArc | Appends an elliptical arc to the current figure.
Public Method | AddBeziers | Adds a sequence of connected cubic Bézier curves to the current figure.
Public Method | AddCurve | Adds a spline curve to the current figure. A cardinal spline curve is used because the curve travels through each of the points in the array.
Public Method | AddEllipse | Adds an ellipse to the current path.
Public Method | AddLine | Overloaded. Appends a line segment to this GraphicsPath.
Public Method | AddLines | Appends a series of connected line segments to the end of this GraphicsPath.
Public Method | AddPath | Appends the specified GraphicsPath to this path.
Public Method | AddPolygon | Adds a polygon to this path.
Public Method | AddRectangle | Adds a rectangle to this path and closes the figure.
Public Method | Clone | Creates an exact copy of this path.
Public Method | CloseAllFigures | Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.
Public Method | CloseFigure | Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.
Public Method | Dispose |
Public Method | Flatten | Converts each curve in this path into a sequence of connected line segments.
Public Method | GetBounds | Returns a rectangle that bounds this GraphicsPath.
Public Method | GetLastPoint | Gets the last point in the PathPoints array of this GraphicsPath.
Public Method | IsVisible | Indicates whether the specified point is contained within this GraphicsPath.
Public Method | Reverse | Reverses the order of points in the PathPoints array of this GraphicsPath.
Public Method | Transform | Applies a transform matrix to this GraphicsPath.
Public Method | Widen | Replaces this path with sequence of connected line segments that enclose the area.
Top

See Also

Reference

GraphicsPath Class
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace


AddArc Method

[image]
ActiveReports 19 .NET Edition
AddArc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddArc Method

x
The x-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
y
The y-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
width
The width of the rectangular region that defines the ellipse from which the arc is drawn.
height
The height of the rectangular region that defines the ellipse from which the arc is drawn.
startAngle
The starting angle of the arc, measured in degrees clockwise from the x-axis.
sweepAngle
The angle between startAngle and the end of the arc.

Glossary Item Box

Appends an elliptical arc to the current figure.

Syntax

Visual Basic (Declaration)
Public Sub AddArc( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
C#
public void AddArc(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
y
The y-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
width
The width of the rectangular region that defines the ellipse from which the arc is drawn.
height
The height of the rectangular region that defines the ellipse from which the arc is drawn.
startAngle
The starting angle of the arc, measured in degrees clockwise from the x-axis.
sweepAngle
The angle between startAngle and the end of the arc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddBeziers Method

[image]
ActiveReports 19 .NET Edition
AddBeziers Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddBeziers Method

points
An array of Point structures that represents the points that define the curves.

Glossary Item Box

Adds a sequence of connected cubic Bézier curves to the current figure.

Syntax

Visual Basic (Declaration)
Public Sub AddBeziers( _
   ByVal points() As PointF _
)
C#
public void AddBeziers(
   PointF[] points
)

Parameters

points
An array of Point structures that represents the points that define the curves.

Exceptions

Exception | Description
System.ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddCurve Method

[image]
ActiveReports 19 .NET Edition
AddCurve Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddCurve Method

points
An array of PointF structures that represents the points that define the curve.
tension
A value that specifies the amount that the curve bends between control points.

Glossary Item Box

Adds a spline curve to the current figure. A cardinal spline curve is used because the curve travels through each of the points in the array.

Syntax

Visual Basic (Declaration)
Public Sub AddCurve( _
   ByVal points() As PointF, _
   ByVal tension As Single _
)
C#
public void AddCurve(
   PointF[] points,
   float tension
)

Parameters

points
An array of PointF structures that represents the points that define the curve.
tension
A value that specifies the amount that the curve bends between control points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddEllipse Method

[image]
ActiveReports 19 .NET Edition
AddEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddEllipse Method

x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

Glossary Item Box

Adds an ellipse to the current path.

Syntax

Visual Basic (Declaration)
Public Sub AddEllipse( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void AddEllipse(
   float x,
   float y,
   float width,
   float height
)

Parameters

x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddLine Method

[image]
ActiveReports 19 .NET Edition
AddLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddLine Method

Glossary Item Box

Appends a line segment to this GraphicsPath.

Overload List

Overload | Description
AddLine(Single,Single,Single,Single) | Appends a line segment to this GraphicsPath.
AddLine(PointF,PointF) | Appends a line segment to this GraphicsPath.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddLine(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
AddLine(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class > AddLine Method : AddLine(Single,Single,Single,Single) Method

x1
The x-coordinate of the starting point of the line.
y1
The y-coordinate of the starting point of the line.
x2
The x-coordinate of the endpoint of the line.
y2
The y-coordinate of the endpoint of the line.

Glossary Item Box

Appends a line segment to this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public void AddLine(
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

x1
The x-coordinate of the starting point of the line.
y1
The y-coordinate of the starting point of the line.
x2
The x-coordinate of the endpoint of the line.
y2
The y-coordinate of the endpoint of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members
Overload List


AddLine(PointF,PointF) Method

[image]
ActiveReports 19 .NET Edition
AddLine(PointF,PointF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class > AddLine Method : AddLine(PointF,PointF) Method

point1
A PointF that represents the starting point of the line.
point2
A PointF that represents the endpoint of the line.

Glossary Item Box

Appends a line segment to this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddLine( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
)
C#
public void AddLine(
   PointF point1,
   PointF point2
)

Parameters

point1
A PointF that represents the starting point of the line.
point2
A PointF that represents the endpoint of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members
Overload List


AddLines Method

[image]
ActiveReports 19 .NET Edition
AddLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddLines Method

points
An array of PointF structures that represents the points that define the line segments to add.

Glossary Item Box

Appends a series of connected line segments to the end of this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Sub AddLines( _
   ByVal points() As PointF _
)
C#
public void AddLines(
   PointF[] points
)

Parameters

points
An array of PointF structures that represents the points that define the line segments to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddPath Method

[image]
ActiveReports 19 .NET Edition
AddPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddPath Method

addingPath
The GraphicsPath to add.
connect
A Boolean value that specifies whether the first figure in the added path is part of the last figure in this path. A value of true specifies that (if possible) the first figure in the added path is part of the last figure in this path. A value of false specifies that the first figure in the added path is separate from the last figure in this path.

Glossary Item Box

Appends the specified GraphicsPath to this path.

Syntax

Visual Basic (Declaration)
Public Sub AddPath( _
   ByVal addingPath As GraphicsPath, _
   ByVal connect As Boolean _
)
C#
public void AddPath(
   GraphicsPath addingPath,
   bool connect
)

Parameters

addingPath
The GraphicsPath to add.
connect
A Boolean value that specifies whether the first figure in the added path is part of the last figure in this path. A value of true specifies that (if possible) the first figure in the added path is part of the last figure in this path. A value of false specifies that the first figure in the added path is separate from the last figure in this path.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddPolygon Method

[image]
ActiveReports 19 .NET Edition
AddPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddPolygon Method

points
An array of Point structures that defines the polygon to add.

Glossary Item Box

Adds a polygon to this path.

Syntax

Visual Basic (Declaration)
Public Sub AddPolygon( _
   ByVal points() As PointF _
)
C#
public void AddPolygon(
   PointF[] points
)

Parameters

points
An array of Point structures that defines the polygon to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


AddRectangle Method

[image]
ActiveReports 19 .NET Edition
AddRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : AddRectangle Method

rectangle
A Rectangle that represents the rectangle to add.

Glossary Item Box

Adds a rectangle to this path and closes the figure.

Syntax

Visual Basic (Declaration)
Public Sub AddRectangle( _
   ByVal rectangle As RectangleF _
)
C#
public void AddRectangle(
   RectangleF rectangle
)

Parameters

rectangle
A Rectangle that represents the rectangle to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Clone Method

Glossary Item Box

Creates an exact copy of this path.

Syntax

Visual Basic (Declaration)
Public Function Clone() As GraphicsPath
C#
public GraphicsPath Clone()

Return Value

The GraphicsPath this method creates, cast as an object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


CloseAllFigures Method

[image]
ActiveReports 19 .NET Edition
CloseAllFigures Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : CloseAllFigures Method

Glossary Item Box

Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.

Syntax

Visual Basic (Declaration)
Public Sub CloseAllFigures()
C#
public void CloseAllFigures()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


CloseFigure Method

[image]
ActiveReports 19 .NET Edition
CloseFigure Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : CloseFigure Method

Glossary Item Box

Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.

Syntax

Visual Basic (Declaration)
Public Sub CloseFigure()
C#
public void CloseFigure()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Flatten Method

[image]
ActiveReports 19 .NET Edition
Flatten Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Flatten Method

splineApproximatePrecision
Specifies the maximum permitted error between the curve and its flattened approximation.

Glossary Item Box

Converts each curve in this path into a sequence of connected line segments.

Syntax

Visual Basic (Declaration)
Public Sub Flatten( _
   ByVal splineApproximatePrecision As Single _
)
C#
public void Flatten(
   float splineApproximatePrecision
)

Parameters

splineApproximatePrecision
Specifies the maximum permitted error between the curve and its flattened approximation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


GetBounds Method

[image]
ActiveReports 19 .NET Edition
GetBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : GetBounds Method

Glossary Item Box

Returns a rectangle that bounds this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As RectangleF
C#
public RectangleF GetBounds()

Return Value

A RectangleF that represents a rectangle that bounds this GraphicsPath.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


GetLastPoint Method

[image]
ActiveReports 19 .NET Edition
GetLastPoint Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : GetLastPoint Method

Glossary Item Box

Gets the last point in the PathPoints array of this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Function GetLastPoint() As PointF
C#
public PointF GetLastPoint()

Return Value

A PointF that represents the last point in this GraphicsPath.

Exceptions

Exception | Description
System.NotImplementedException | The exception that is thrown when a requested method or operation is not implemented.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : IsVisible Method

point
A Point that represents the point to test.

Glossary Item Box

Indicates whether the specified point is contained within this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Function IsVisible( _
   ByVal point As PointF _
) As Boolean
C#
public bool IsVisible(
   PointF point
)

Parameters

point
A Point that represents the point to test.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Reverse Method

[image]
ActiveReports 19 .NET Edition
Reverse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Reverse Method

Glossary Item Box

Reverses the order of points in the PathPoints array of this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Transform Method

[image]
ActiveReports 19 .NET Edition
Transform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Transform Method

matrix
A Matrix3x2 that represents the transformation to apply.

Glossary Item Box

Applies a transform matrix to this GraphicsPath.

Syntax

Visual Basic (Declaration)
Public Sub Transform( _
   ByVal matrix As Matrix3x2 _
)
C#
public void Transform(
   Matrix3x2 matrix
)

Parameters

matrix
A Matrix3x2 that represents the transformation to apply.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


Widen Method

[image]
ActiveReports 19 .NET Edition
Widen Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : Widen Method

width
Specifies the maximum permitted error between the curve and its flattened approximation.

Glossary Item Box

Replaces this path with sequence of connected line segments that enclose the area.

Syntax

Visual Basic (Declaration)
Public Sub Widen( _
   ByVal width As Single _
)
C#
public void Widen(
   float width
)

Parameters

width
Specifies the maximum permitted error between the curve and its flattened approximation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


GraphicsPath Class Properties

[image]
ActiveReports 19 .NET Edition
GraphicsPath Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace : GraphicsPath Class

Glossary Item Box

For a list of all members of this type, see GraphicsPath members.

Public Properties

 | Name | Description
Public Property | PathPoints | Gets the points in the path.
Public Property | PathTypes |
Top

See Also

Reference

GraphicsPath Class
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace


PathPoints Property

[image]
ActiveReports 19 .NET Edition
PathPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : PathPoints Property

Glossary Item Box

Gets the points in the path.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PathPoints As PointF()
C#
public PointF[] PathPoints {get;}

Property Value

An array of PointF objects that represent the path.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


PathTypes Property

[image]
ActiveReports 19 .NET Edition
PathTypes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : PathTypes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PathTypes As Byte()
C#
public byte[] PathTypes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


HatchStyle Enumeration

[image]
ActiveReports 19 .NET Edition
HatchStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace : HatchStyle Enumeration

Glossary Item Box

See System.Drawing.Drawing2D.HatchStyle

Syntax

Visual Basic (Declaration)
Public Enum HatchStyle
   Inherits System.Enum
C#
public enum HatchStyle : System.Enum

Members

Member | Description
BackwardDiagonal |
Cross |
DarkDownwardDiagonal |
DarkHorizontal |
DarkUpwardDiagonal |
DarkVertical |
DashedDownwardDiagonal |
DashedHorizontal |
DashedUpwardDiagonal |
DashedVertical |
DiagonalBrick |
DiagonalCross |
Divot |
DottedDiamond |
DottedGrid |
ForwardDiagonal |
Horizontal |
HorizontalBrick |
LargeCheckerBoard |
LargeConfetti |
LargeGrid |
LightDownwardDiagonal |
LightHorizontal |
LightUpwardDiagonal |
LightVertical |
Max |
Min |
NarrowHorizontal |
NarrowVertical |
OutlinedDiamond |
Percent05 |
Percent10 |
Percent20 |
Percent25 |
Percent30 |
Percent40 |
Percent50 |
Percent60 |
Percent70 |
Percent75 |
Percent80 |
Percent90 |
Plaid |
Shingle |
SmallCheckerBoard |
SmallConfetti |
SmallGrid |
SolidDiamond |
Sphere |
Trellis |
Vertical |
Wave |
Weave |
WideDownwardDiagonal |
WideUpwardDiagonal |
ZigZag |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D.HatchStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace


ImageFormat Class

[image]
ActiveReports 19 .NET Edition
ImageFormat Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

Object Model

ImageFormat Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ImageFormat
C#
public sealed class ImageFormat

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Imaging.ImageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Members
GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace


ImageFormat Class Members

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

The following tables list the members exposed by ImageFormat.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Bmp | Specifies the bitmap image format.
static (Shared in Visual Basic) | Emf | Specifies the enhanced Windows metafile image format.
static (Shared in Visual Basic) | Exif | Specifies the Exchangeable Image Format (EXIF).
static (Shared in Visual Basic) | Gif | Specifies the GIF image format.
Public Property | Guid | Specifies a global unique identifier (GUID) that represents this ImageFormat.
static (Shared in Visual Basic) | Icon | Specifies the Windows icon image format.
static (Shared in Visual Basic) | Jpeg | Specifies the JPEG image format.
static (Shared in Visual Basic) | MemoryBmp | Specifies a memory bitmap image format.
static (Shared in Visual Basic) | Png | Specifies the W3C PNG image format.
static (Shared in Visual Basic) | Tiff | Specifies the Tag Image File Format (TIFF) image format.
static (Shared in Visual Basic) | Wmf | Specifies the Windows metafile image format.
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value indicating whether the specified object is an ImageFormat equivalent to this ImageFormat.
Public Method | GetHashCode | Returns a hash code.
Public Method | ToString | Converts this ImageFormat to a human-readable string.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace


ImageFormat Class Methods

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

For a list of all members of this type, see ImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value indicating whether the specified object is an ImageFormat equivalent to this ImageFormat.
Public Method | GetHashCode | Returns a hash code.
Public Method | ToString | Converts this ImageFormat to a human-readable string.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Equals Method

o

Glossary Item Box

Returns a value indicating whether the specified object is an ImageFormat equivalent to this ImageFormat.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal o As Object _
) As Boolean
C#
public override bool Equals(
   object o
)

Parameters

o

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : GetHashCode Method

Glossary Item Box

Returns a hash code.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : ToString Method

Glossary Item Box

Converts this ImageFormat to a human-readable string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


ImageFormat Class Properties

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

For a list of all members of this type, see ImageFormat members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Bmp | Specifies the bitmap image format.
static (Shared in Visual Basic) | Emf | Specifies the enhanced Windows metafile image format.
static (Shared in Visual Basic) | Exif | Specifies the Exchangeable Image Format (EXIF).
static (Shared in Visual Basic) | Gif | Specifies the GIF image format.
Public Property | Guid | Specifies a global unique identifier (GUID) that represents this ImageFormat.
static (Shared in Visual Basic) | Icon | Specifies the Windows icon image format.
static (Shared in Visual Basic) | Jpeg | Specifies the JPEG image format.
static (Shared in Visual Basic) | MemoryBmp | Specifies a memory bitmap image format.
static (Shared in Visual Basic) | Png | Specifies the W3C PNG image format.
static (Shared in Visual Basic) | Tiff | Specifies the Tag Image File Format (TIFF) image format.
static (Shared in Visual Basic) | Wmf | Specifies the Windows metafile image format.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace


Bmp Property

[image]
ActiveReports 19 .NET Edition
Bmp Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Bmp Property

Glossary Item Box

Specifies the bitmap image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Bmp As ImageFormat
C#
public static ImageFormat Bmp {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Emf Property

[image]
ActiveReports 19 .NET Edition
Emf Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Emf Property

Glossary Item Box

Specifies the enhanced Windows metafile image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Emf As ImageFormat
C#
public static ImageFormat Emf {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Exif Property

[image]
ActiveReports 19 .NET Edition
Exif Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Exif Property

Glossary Item Box

Specifies the Exchangeable Image Format (EXIF).

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Exif As ImageFormat
C#
public static ImageFormat Exif {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Gif Property

[image]
ActiveReports 19 .NET Edition
Gif Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Gif Property

Glossary Item Box

Specifies the GIF image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Gif As ImageFormat
C#
public static ImageFormat Gif {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Guid Property

[image]
ActiveReports 19 .NET Edition
Guid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Guid Property

Glossary Item Box

Specifies a global unique identifier (GUID) that represents this ImageFormat.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Guid As Guid
C#
public Guid Guid {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Icon Property

[image]
ActiveReports 19 .NET Edition
Icon Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Icon Property

Glossary Item Box

Specifies the Windows icon image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Icon As ImageFormat
C#
public static ImageFormat Icon {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Jpeg Property

[image]
ActiveReports 19 .NET Edition
Jpeg Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Jpeg Property

Glossary Item Box

Specifies the JPEG image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Jpeg As ImageFormat
C#
public static ImageFormat Jpeg {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


MemoryBmp Property

[image]
ActiveReports 19 .NET Edition
MemoryBmp Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : MemoryBmp Property

Glossary Item Box

Specifies a memory bitmap image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MemoryBmp As ImageFormat
C#
public static ImageFormat MemoryBmp {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Png Property

[image]
ActiveReports 19 .NET Edition
Png Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Png Property

Glossary Item Box

Specifies the W3C PNG image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Png As ImageFormat
C#
public static ImageFormat Png {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Tiff Property

[image]
ActiveReports 19 .NET Edition
Tiff Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Tiff Property

Glossary Item Box

Specifies the Tag Image File Format (TIFF) image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Tiff As ImageFormat
C#
public static ImageFormat Tiff {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Wmf Property

[image]
ActiveReports 19 .NET Edition
Wmf Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace > ImageFormat Class : Wmf Property

Glossary Item Box

Specifies the Windows metafile image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Wmf As ImageFormat
C#
public static ImageFormat Wmf {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Backdrop Class

[image]
ActiveReports 19 .NET Edition
Backdrop Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

Glossary Item Box

Specifies the settings used to draw the background of the Chart object.

Object Model

Backdrop Class

Syntax

Visual Basic (Declaration)
Public Class Backdrop
   Inherits GrapeCity.ActiveReports.Chart.DrawCustomizableItem
C#
public class Backdrop : GrapeCity.ActiveReports.Chart.DrawCustomizableItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Backdrop Class Members

[image]
ActiveReports 19 .NET Edition
Backdrop Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

Glossary Item Box

The following tables list the members exposed by Backdrop.

Public Constructors

 | Name | Description
Public Constructor | Backdrop Constructor | Overloaded. Initializes a new instance of the Backdrop class.
Top

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency).
Public Property | Color | Gets or sets the primary color used to fill the backdrop.
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop.
Public Property | HasTransparency | Returns true if backdrop is transparent or most likely transparent
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern.
Public Property | Picture | Gets or sets the image used for the Backdrop.
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop.
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Backdrop.
Public Method | CopyFrom | Initializes the specified Backdrop object with settings.
Public Method | Dispose | Releases the Backdrop instance from memory.
Public Method | Equals | Compares the Backdrop object to another System.Object to see whether they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.
Top

See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Backdrop Constructor

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Backdrop Constructor

Glossary Item Box

Initializes a new instance of the Backdrop class.

Overload List

Overload | Description
Backdrop Constructor() | Initializes a new instance of the Backdrop class.
Backdrop Constructor(AntiAliasMode) | Initializes a new instance of the Backdrop class with the AntiAliasMode value specified.
Backdrop Constructor(Color) | Initializes a new instance of the Backdrop class with the specified color.
Backdrop Constructor(Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Color,Byte) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Color,Byte,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(GradientType,Color,Color) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(GradientType,Color,Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(HatchStyle,Color,Color) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Image,PicturePutStyle) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Backdrop Constructor()

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor()

Glossary Item Box

Initializes a new instance of the Backdrop class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Backdrop()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(AntiAliasMode)

antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the AntiAliasMode value specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color)

color
Specifies the primary color.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
C#
public Backdrop(
   Color color
)

Parameters

color
Specifies the primary color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,AntiAliasMode)

color
Specifies the primary color.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   Color color,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,Byte)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Color,Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,Byte)

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal alpha As Byte _
)
C#
public Backdrop(
   Color color,
   byte alpha
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,Byte,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Color,Byte,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,Byte,AntiAliasMode)

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal alpha As Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   Color color,
   byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(GradientType,Color,Color)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(GradientType,Color,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(GradientType,Color,Color)

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
C#
public Backdrop(
   GradientType gradient,
   Color color,
   Color color2
)

Parameters

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   GradientType gradient,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(HatchStyle,Color,Color)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(HatchStyle,Color,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(HatchStyle,Color,Color)

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pattern As HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
C#
public Backdrop(
   HatchStyle pattern,
   Color color,
   Color color2
)

Parameters

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pattern As HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   HatchStyle pattern,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Image,PicturePutStyle)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Image,PicturePutStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Image,PicturePutStyle)

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
C#
public Backdrop(
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
C#
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) used.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As Byte _
)
C#
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   byte alpha
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

[image]
ActiveReports 19 .NET Edition
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used with image style.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Glossary Item Box

Initializes a new instance of the Backdrop class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
C#
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used with image style.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Class Methods

[image]
ActiveReports 19 .NET Edition
Backdrop Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

Glossary Item Box

For a list of all members of this type, see Backdrop members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Backdrop.
Public Method | CopyFrom | Initializes the specified Backdrop object with settings.
Public Method | Dispose | Releases the Backdrop instance from memory.
Public Method | Equals | Compares the Backdrop object to another System.Object to see whether they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.
Top

See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Clone Method

Glossary Item Box

Creates a clone of the Backdrop.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Backdrop.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


CopyFrom Method

[image]
ActiveReports 19 .NET Edition
CopyFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : CopyFrom Method

backdrop
The Backdrop object from which to copy settings.

Glossary Item Box

Initializes the specified Backdrop object with settings.

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal backdrop As Backdrop _
)
C#
public void CopyFrom(
   Backdrop backdrop
)

Parameters

backdrop
The Backdrop object from which to copy settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Dispose Method

Glossary Item Box

Releases the Backdrop instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Equals Method

obj
The System.Object to which the Backdrop object is being compared.

Glossary Item Box

Compares the Backdrop object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Backdrop object is being compared.

Return Value

Boolean. Returns True if the objects are equal; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


FitToRectangle Method

[image]
ActiveReports 19 .NET Edition
FitToRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : FitToRectangle Method

Glossary Item Box

Sets the bounding rectangle of the Backdrop.

Overload List

Overload | Description
FitToRectangle(RectangleF) | Sets the bounding rectangle of the Backdrop.
FitToRectangle(PointF[]) | Sets the bounding rectangle of the Backdrop.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


FitToRectangle(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
FitToRectangle(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > FitToRectangle Method : FitToRectangle(RectangleF) Method

rectangle
A rectangle to fit.

Glossary Item Box

Sets the bounding rectangle of the Backdrop.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FitToRectangle( _
   ByVal rectangle As RectangleF _
)
C#
public void FitToRectangle(
   RectangleF rectangle
)

Parameters

rectangle
A rectangle to fit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


FitToRectangle(PointF[]) Method

[image]
ActiveReports 19 .NET Edition
FitToRectangle(PointF[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > FitToRectangle Method : FitToRectangle(PointF[]) Method

points

The array contains the top left, top right, bottom right and bottom left points of the rectangle.

Glossary Item Box

Sets the bounding rectangle of the Backdrop.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FitToRectangle( _
   ByVal points() As PointF _
)
C#
public void FitToRectangle(
   PointF[] points
)

Parameters

points

The array contains the top left, top right, bottom right and bottom left points of the rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Serialize Method

[image]
ActiveReports 19 .NET Edition
Serialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Serialize Method

info
Specifies the data needed to serialize or deserialize the Backdrop object.
isLoading
Specifies whether to reconstruct the object (True) or create XML encoding (False).

Glossary Item Box

Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.

Syntax

Visual Basic (Declaration)
Public Sub Serialize( _
   ByVal info As SerializationInfo, _
   ByVal isLoading As Boolean _
)
C#
public void Serialize(
   SerializationInfo info,
   bool isLoading
)

Parameters

info
Specifies the data needed to serialize or deserialize the Backdrop object.
isLoading
Specifies whether to reconstruct the object (True) or create XML encoding (False).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Backdrop Class Properties

[image]
ActiveReports 19 .NET Edition
Backdrop Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

Glossary Item Box

For a list of all members of this type, see Backdrop members.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency).
Public Property | Color | Gets or sets the primary color used to fill the backdrop.
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop.
Public Property | HasTransparency | Returns true if backdrop is transparent or most likely transparent
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern.
Public Property | Picture | Gets or sets the image used for the Backdrop.
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop.
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).
Top

See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Alpha Property

[image]
ActiveReports 19 .NET Edition
Alpha Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Alpha Property

Glossary Item Box

Gets or sets the alpha level (transparency).

Syntax

Visual Basic (Declaration)
Public Property Alpha As Byte
C#
public byte Alpha {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Color Property

Glossary Item Box

Gets or sets the primary color used to fill the backdrop.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Color2 Property

[image]
ActiveReports 19 .NET Edition
Color2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Color2 Property

Glossary Item Box

Gets or sets the secondary color used for gradient effects and patterns.

Syntax

Visual Basic (Declaration)
Public Property Color2 As Color
C#
public Color Color2 {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Gradient Property

[image]
ActiveReports 19 .NET Edition
Gradient Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Gradient Property

Glossary Item Box

Gets or sets the enumerated GradientType used for the Backdrop.

Syntax

Visual Basic (Declaration)
Public Property Gradient As GradientType
C#
public GradientType Gradient {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
GradientType Enumeration


HasTransparency Property

[image]
ActiveReports 19 .NET Edition
HasTransparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : HasTransparency Property

Glossary Item Box

Returns true if backdrop is transparent or most likely transparent

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasTransparency As Boolean
C#
public bool HasTransparency {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Pattern Property

[image]
ActiveReports 19 .NET Edition
Pattern Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Pattern Property

Glossary Item Box

Gets or sets the HatchStyle used for the Backdrop pattern.

Syntax

Visual Basic (Declaration)
Public Property Pattern As HatchStyle
C#
public HatchStyle Pattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


Picture Property

[image]
ActiveReports 19 .NET Edition
Picture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Picture Property

Glossary Item Box

Gets or sets the image used for the Backdrop.

Syntax

Visual Basic (Declaration)
Public Property Picture As Image
C#
public Image Picture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members


PictureAlignment Property

[image]
ActiveReports 19 .NET Edition
PictureAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : PictureAlignment Property

Glossary Item Box

Gets or sets the image alignment for the Backdrop.

Syntax

Visual Basic (Declaration)
Public Property PictureAlignment As PicturePutStyle
C#
public PicturePutStyle PictureAlignment {get; set;}

Property Value

A valid PicturePutStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
PicturePutStyle Enumeration


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Style Property

Glossary Item Box

Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).

Syntax

Visual Basic (Declaration)
Public Property Style As BackdropStyle
C#
public BackdropStyle Style {get; set;}

Property Value

A valid BackdropStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Backdrop Class
Backdrop Members
BackdropStyle Enumeration


DrawParams Class

[image]
ActiveReports 19 .NET Edition
DrawParams Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : DrawParams Class

Glossary Item Box

Object Model

DrawParams Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DrawParams
C#
public sealed class DrawParams

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.DrawParams

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawParams Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


DrawParams Class Members

[image]
ActiveReports 19 .NET Edition
DrawParams Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : DrawParams Class

Glossary Item Box

The following tables list the members exposed by DrawParams.

Public Fields

 | Name | Description
Public Field | ItemIndex |
Top

See Also

Reference

DrawParams Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


DrawParams Class Fields

[image]
ActiveReports 19 .NET Edition
DrawParams Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : DrawParams Class

Glossary Item Box

For a list of all members of this type, see DrawParams members.

Public Fields

 | Name | Description
Public Field | ItemIndex |
Top

See Also

Reference

DrawParams Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


ItemIndex Field

[image]
ActiveReports 19 .NET Edition
ItemIndex Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > DrawParams Class : ItemIndex Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ItemIndex As Integer
C#
public readonly int ItemIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawParams Class
DrawParams Members


ImageMap Class

[image]
ActiveReports 19 .NET Edition
ImageMap Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ImageMap Class

Glossary Item Box

ImageMap class provides mapping from image coordinates to Shapes

Object Model

ImageMap Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ImageMap
C#
public sealed class ImageMap

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.ImageMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMap Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


ImageMap Class Members

[image]
ActiveReports 19 .NET Edition
ImageMap Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ImageMap Class

Glossary Item Box

The following tables list the members exposed by ImageMap.

Public Constructors

 | Name | Description
Public Constructor | ImageMap Constructor |
Top

Public Methods

 | Name | Description
Public Method | AddArea | Adds area to the map
Public Method | Clear | Clears the map
Public Method | FindArea | Finds the area at coordinate given
Top

See Also

Reference

ImageMap Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


ImageMap Constructor

[image]
ActiveReports 19 .NET Edition
ImageMap Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ImageMap Class : ImageMap Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageMap()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMap Class
ImageMap Members


ImageMap Class Methods

[image]
ActiveReports 19 .NET Edition
ImageMap Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ImageMap Class

Glossary Item Box

For a list of all members of this type, see ImageMap members.

Public Methods

 | Name | Description
Public Method | AddArea | Adds area to the map
Public Method | Clear | Clears the map
Public Method | FindArea | Finds the area at coordinate given
Top

See Also

Reference

ImageMap Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


AddArea Method

[image]
ActiveReports 19 .NET Edition
AddArea Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ImageMap Class : AddArea Method

area

Glossary Item Box

Adds area to the map

Syntax

Visual Basic (Declaration)
Public Sub AddArea( _
   ByVal area As ShapeArea _
)
C#
public void AddArea(
   ShapeArea area
)

Parameters

area

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMap Class
ImageMap Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ImageMap Class : Clear Method

Glossary Item Box

Clears the map

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMap Class
ImageMap Members


FindArea Method

[image]
ActiveReports 19 .NET Edition
FindArea Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ImageMap Class : FindArea Method

x
y

Glossary Item Box

Finds the area at coordinate given

Syntax

Visual Basic (Declaration)
Public Function FindArea( _
   ByVal x As Single, _
   ByVal y As Single _
) As ShapeArea
C#
public ShapeArea FindArea(
   float x,
   float y
)

Parameters

x
y

Return Value

Found area or null if no area found

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMap Class
ImageMap Members


Line Class

[image]
ActiveReports 19 .NET Edition
Line Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

Glossary Item Box

Holds all of the visual attributes of a Line object.

Object Model

Line Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Line
   Inherits GrapeCity.ActiveReports.Chart.Item
C#
public sealed class Line : GrapeCity.ActiveReports.Chart.Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line Class Members

[image]
ActiveReports 19 .NET Edition
Line Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

Glossary Item Box

The following tables list the members exposed by Line.

Public Constructors

 | Name | Description
Public Constructor | Line Constructor | Overloaded. Initializes a new instance of the Line class.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the line.
Public Property | Style | Gets or sets the style used to draw the line.
Public Property | Weight | Gets or sets the line thickness in points.
Top

Public Methods

 | Name | Description
Public Method | Equals | Compares the Line object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line Constructor

[image]
ActiveReports 19 .NET Edition
Line Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Line Constructor

Glossary Item Box

Initializes a new instance of the Line class.

Overload List

Overload | Description
Line Constructor() | Initializes a new instance of the Line class.
Line Constructor(Color) | Initializes a new instance of the Line class with a solid, 1 pt line, and the color specified.
Line Constructor(Color,Int32) | Initializes a new instance of the Line class with a solid line of the weight and color specified.
Line Constructor(Color,LineStyle) | Initializes a new instance of the Line class with a 1 pt line of the color and style specified.
Line Constructor(Color,Int32,LineStyle) | Initializes a new instance of the Line class with the color, weight, and style specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line Constructor()

[image]
ActiveReports 19 .NET Edition
Line Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor()

Glossary Item Box

Initializes a new instance of the Line class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color)

[image]
ActiveReports 19 .NET Edition
Line Constructor(Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color)

color
Specifies the line color.

Glossary Item Box

Initializes a new instance of the Line class with a solid, 1 pt line, and the color specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
C#
public Line(
   Color color
)

Parameters

color
Specifies the line color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,Int32)

[image]
ActiveReports 19 .NET Edition
Line Constructor(Color,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32)

color
Specifies the line color.
weight
Specifies the line weight.

Glossary Item Box

Initializes a new instance of the Line class with a solid line of the weight and color specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal weight As Integer _
)
C#
public Line(
   Color color,
   int weight
)

Parameters

color
Specifies the line color.
weight
Specifies the line weight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,LineStyle)

[image]
ActiveReports 19 .NET Edition
Line Constructor(Color,LineStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,LineStyle)

color
Specifies the line color.
style
Specifies the LineStyle.

Glossary Item Box

Initializes a new instance of the Line class with a 1 pt line of the color and style specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal style As LineStyle _
)
C#
public Line(
   Color color,
   LineStyle style
)

Parameters

color
Specifies the line color.
style
Specifies the LineStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,Int32,LineStyle)

[image]
ActiveReports 19 .NET Edition
Line Constructor(Color,Int32,LineStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32,LineStyle)

color
Specifies the line color.
weight
Specifies the line weight.
style
Specifies the LineStyle.

Glossary Item Box

Initializes a new instance of the Line class with the color, weight, and style specified.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal weight As Integer, _
   ByVal style As LineStyle _
)
C#
public Line(
   Color color,
   int weight,
   LineStyle style
)

Parameters

color
Specifies the line color.
weight
Specifies the line weight.
style
Specifies the LineStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


Line Class Methods

[image]
ActiveReports 19 .NET Edition
Line Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Methods

 | Name | Description
Public Method | Equals | Compares the Line object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Equals Method

obj
The System.Object to which the Line object is being compared.

Glossary Item Box

Compares the Line object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Line object is being compared.

Return Value

Boolean. Returns True if they are equal; otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line Class Properties

[image]
ActiveReports 19 .NET Edition
Line Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the line.
Public Property | Style | Gets or sets the style used to draw the line.
Public Property | Weight | Gets or sets the line thickness in points.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Color Property

Glossary Item Box

Gets or sets the color of the line.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Property Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Style Property

Glossary Item Box

Gets or sets the style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property Style As LineStyle
C#
public LineStyle Style {get; set;}

Property Value

A valid LineStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
LineStyle Enumeration


Weight Property

[image]
ActiveReports 19 .NET Edition
Weight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Weight Property

Glossary Item Box

Gets or sets the line thickness in points.

Syntax

Visual Basic (Declaration)
Public Property Weight As Integer
C#
public int Weight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line.Converter Class

[image]
ActiveReports 19 .NET Edition
Line.Converter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.Converter Class

Glossary Item Box

The type converter for Line.

Object Model

Line.Converter Class

Syntax

Visual Basic (Declaration)
Public Class Line.Converter
   Inherits GrapeCity.ActiveReports.Chart.TxExpandableObjectConverter
C#
public class Line.Converter : GrapeCity.ActiveReports.Chart.TxExpandableObjectConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
GrapeCity.ActiveReports.Chart.Graphics.Line.Converter
GrapeCity.ActiveReports.Chart.Graphics.Line.SeriesLineConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line.Converter Class Members

[image]
ActiveReports 19 .NET Edition
Line.Converter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.Converter Class

Glossary Item Box

The following tables list the members exposed by Line.Converter.

Public Constructors

 | Name | Description
Public Constructor | Line.Converter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Top

See Also

Reference

Line.Converter Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line.Converter Constructor

[image]
ActiveReports 19 .NET Edition
Line.Converter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : Line.Converter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line.Converter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


Line.Converter Class Methods

[image]
ActiveReports 19 .NET Edition
Line.Converter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.Converter Class

Glossary Item Box

For a list of all members of this type, see Line.Converter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Top

See Also

Reference

Line.Converter Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : CanConvertFrom Method

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Type that represents the type you want to convert from.

Glossary Item Box

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : CanConvertTo Method

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetProperties Method

Glossary Item Box

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
value
An System.Object that specifies the type of object to get the properties for.
attributes
An array of type System.Attribute that will be used as a filter.

Glossary Item Box

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
value
An System.Object that specifies the type of object to get the properties for.
attributes
An array of type System.Attribute that will be used as a filter.

Return Value

A System.ComponentModel.PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


Line.SeriesLineConverter Class

[image]
ActiveReports 19 .NET Edition
Line.SeriesLineConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.SeriesLineConverter Class

Glossary Item Box

The type converter for series lines.

Object Model

Line.SeriesLineConverter Class

Syntax

Visual Basic (Declaration)
Public Class Line.SeriesLineConverter
   Inherits Line.Converter
C#
public class Line.SeriesLineConverter : Line.Converter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
GrapeCity.ActiveReports.Chart.Graphics.Line.Converter
GrapeCity.ActiveReports.Chart.Graphics.Line.SeriesLineConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line.SeriesLineConverter Class Members

[image]
ActiveReports 19 .NET Edition
Line.SeriesLineConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.SeriesLineConverter Class

Glossary Item Box

The following tables list the members exposed by Line.SeriesLineConverter.

Public Constructors

 | Name | Description
Public Constructor | Line.SeriesLineConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

Line.SeriesLineConverter Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line.SeriesLineConverter Constructor

[image]
ActiveReports 19 .NET Edition
Line.SeriesLineConverter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : Line.SeriesLineConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line.SeriesLineConverter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


Line.SeriesLineConverter Class Methods

[image]
ActiveReports 19 .NET Edition
Line.SeriesLineConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line.SeriesLineConverter Class

Glossary Item Box

For a list of all members of this type, see Line.SeriesLineConverter members.

Public Methods

 | Name | Description
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given object to the type of this converter, using the specified context and culture information.
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Top

See Also

Reference

Line.SeriesLineConverter Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertFrom Method

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Glossary Item Box

Converts the given object to the type of this converter, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertTo Method

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Glossary Item Box

Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


Point2d Class

[image]
ActiveReports 19 .NET Edition
Point2d Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

Glossary Item Box

Specifies a point in two dimensions.

Object Model

Point2d Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Point2d
   Inherits GrapeCity.ActiveReports.Chart.Item
C#
public sealed class Point2d : GrapeCity.ActiveReports.Chart.Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Point2d

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point2d Class Members

[image]
ActiveReports 19 .NET Edition
Point2d Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

Glossary Item Box

The following tables list the members exposed by Point2d.

Public Constructors

 | Name | Description
Public Constructor | Point2d Constructor | Overloaded. Initializes a new instance of the Point2d class.
Top

Public Properties

 | Name | Description
Public Property | Length | Gets the vector length of the Point2d object.
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point2d object.
Public Method | Equals | Compares the Point2d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point2d Constructor

[image]
ActiveReports 19 .NET Edition
Point2d Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Point2d Constructor

Glossary Item Box

Initializes a new instance of the Point2d class.

Overload List

Overload | Description
Point2d Constructor() | Initializes a new instance of the Point2d class.
Point2d Constructor(Single,Single) | Initializes a new instance of the Point2d class.
Point2d Constructor(PointF) | Initializes a new instance of the Point2d class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


Point2d Constructor()

[image]
ActiveReports 19 .NET Edition
Point2d Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor()

Glossary Item Box

Initializes a new instance of the Point2d class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Point2d()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Constructor(Single,Single)

[image]
ActiveReports 19 .NET Edition
Point2d Constructor(Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor(Single,Single)

x
The x coordinate of a point in a two-dimensional plane.
y
The y coordinate of a point in a two-dimensional plane.

Glossary Item Box

Initializes a new instance of the Point2d class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single _
)
C#
public Point2d(
   float x,
   float y
)

Parameters

x
The x coordinate of a point in a two-dimensional plane.
y
The y coordinate of a point in a two-dimensional plane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Constructor(PointF)

[image]
ActiveReports 19 .NET Edition
Point2d Constructor(PointF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor(PointF)

p
An ordered pair of floating point x and y coordinates that defines a point in a two-dimensional plane.

Glossary Item Box

Initializes a new instance of the Point2d class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As PointF _
)
C#
public Point2d(
   PointF p
)

Parameters

p
An ordered pair of floating point x and y coordinates that defines a point in a two-dimensional plane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Class Methods

[image]
ActiveReports 19 .NET Edition
Point2d Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

Glossary Item Box

For a list of all members of this type, see Point2d members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point2d object.
Public Method | Equals | Compares the Point2d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Clone Method

Glossary Item Box

Creates a clone of the Point2d object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Point2d object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Equals Method

obj
The System.Object to which the Point2d object is being compared.

Glossary Item Box

Compares the Point2d object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Point2d object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


Point2d Class Properties

[image]
ActiveReports 19 .NET Edition
Point2d Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

Glossary Item Box

For a list of all members of this type, see Point2d members.

Public Properties

 | Name | Description
Public Property | Length | Gets the vector length of the Point2d object.
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Top

See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Length Property

[image]
ActiveReports 19 .NET Edition
Length Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Length Property

Glossary Item Box

Gets the vector length of the Point2d object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Single
C#
public float Length {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : X Property

Glossary Item Box

Gets or sets the point's x coordinate

Syntax

Visual Basic (Declaration)
Public Property X As Single
C#
public float X {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Y Property

Glossary Item Box

Gets or sets the point's y coordinate

Syntax

Visual Basic (Declaration)
Public Property Y As Single
C#
public float Y {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point2d Class
Point2d Members


Point3d Class

[image]
ActiveReports 19 .NET Edition
Point3d Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

Glossary Item Box

Specifies a point in 3 dimensional geometric space.

Object Model

Point3d Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Point3d
   Inherits GrapeCity.ActiveReports.Chart.Item
C#
public sealed class Point3d : GrapeCity.ActiveReports.Chart.Item

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Point3d

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point3d Class Members

[image]
ActiveReports 19 .NET Edition
Point3d Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

Glossary Item Box

The following tables list the members exposed by Point3d.

Public Constructors

 | Name | Description
Public Constructor | Point3d Constructor | Overloaded. Initializes a new instance of the Point3d class.
Top

Public Properties

 | Name | Description
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Public Property | Z | Gets or sets the point's z coordinate
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point3d object.
Public Method | Equals | Compares the Point3d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point3d Constructor

[image]
ActiveReports 19 .NET Edition
Point3d Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Point3d Constructor

Glossary Item Box

Initializes a new instance of the Point3d class.

Overload List

Overload | Description
Point3d Constructor() | Initializes a new instance of the Point3d class.
Point3d Constructor(Single,Single,Single) | Initializes a new instance of the Point3d class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


Point3d Constructor()

[image]
ActiveReports 19 .NET Edition
Point3d Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class > Point3d Constructor : Point3d Constructor()

Glossary Item Box

Initializes a new instance of the Point3d class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Point3d()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members
Overload List


Point3d Constructor(Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
Point3d Constructor(Single,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class > Point3d Constructor : Point3d Constructor(Single,Single,Single)

x
The x coordinate of a point in a three-dimensional plane.
y
The y coordinate of a point in a three-dimensional plane.
z
The z coordinate of a point in a three-dimensional plane.

Glossary Item Box

Initializes a new instance of the Point3d class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal z As Single _
)
C#
public Point3d(
   float x,
   float y,
   float z
)

Parameters

x
The x coordinate of a point in a three-dimensional plane.
y
The y coordinate of a point in a three-dimensional plane.
z
The z coordinate of a point in a three-dimensional plane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members
Overload List


Point3d Class Methods

[image]
ActiveReports 19 .NET Edition
Point3d Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

Glossary Item Box

For a list of all members of this type, see Point3d members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point3d object.
Public Method | Equals | Compares the Point3d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Clone Method

Glossary Item Box

Creates a clone of the Point3d object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A clone of the Point3d object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Equals Method

obj
The System.Object to which the Point3d object is being compared.

Glossary Item Box

Compares the Point3d object to another System.Object to see whether they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to which the Point3d object is being compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


Point3d Class Properties

[image]
ActiveReports 19 .NET Edition
Point3d Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

Glossary Item Box

For a list of all members of this type, see Point3d members.

Public Properties

 | Name | Description
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Public Property | Z | Gets or sets the point's z coordinate
Top

See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : X Property

Glossary Item Box

Gets or sets the point's x coordinate

Syntax

Visual Basic (Declaration)
Public Property X As Single
C#
public float X {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Y Property

Glossary Item Box

Gets or sets the point's y coordinate

Syntax

Visual Basic (Declaration)
Public Property Y As Single
C#
public float Y {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


Z Property

[image]
ActiveReports 19 .NET Edition
Z Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Z Property

Glossary Item Box

Gets or sets the point's z coordinate

Syntax

Visual Basic (Declaration)
Public Property Z As Single
C#
public float Z {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point3d Class
Point3d Members


ShapeArea Class

[image]
ActiveReports 19 .NET Edition
ShapeArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ShapeArea Class

Glossary Item Box

ImageMap entry

Object Model

ShapeArea Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ShapeArea
C#
public sealed class ShapeArea

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.ShapeArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


ShapeArea Class Members

[image]
ActiveReports 19 .NET Edition
ShapeArea Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ShapeArea Class

Glossary Item Box

The following tables list the members exposed by ShapeArea.

Public Constructors

 | Name | Description
Public Constructor | ShapeArea Constructor |
Top

Public Fields

 | Name | Description
Public Field | Bounds |
Public Field | DrawParams |
Public Field | Handler |
Public Field | InvertedTransform |
Public Field | Region |
Top

See Also

Reference

ShapeArea Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


ShapeArea Constructor

[image]
ActiveReports 19 .NET Edition
ShapeArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : ShapeArea Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ShapeArea()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


ShapeArea Class Fields

[image]
ActiveReports 19 .NET Edition
ShapeArea Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ShapeArea Class

Glossary Item Box

For a list of all members of this type, see ShapeArea members.

Public Fields

 | Name | Description
Public Field | Bounds |
Public Field | DrawParams |
Public Field | Handler |
Public Field | InvertedTransform |
Public Field | Region |
Top

See Also

Reference

ShapeArea Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Bounds Field

[image]
ActiveReports 19 .NET Edition
Bounds Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : Bounds Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Bounds As RectangleF
C#
public RectangleF Bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


DrawParams Field

[image]
ActiveReports 19 .NET Edition
DrawParams Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : DrawParams Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DrawParams As DrawParams
C#
public DrawParams DrawParams

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


Handler Field

[image]
ActiveReports 19 .NET Edition
Handler Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : Handler Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Handler As IMouseHandler
C#
public IMouseHandler Handler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


InvertedTransform Field

[image]
ActiveReports 19 .NET Edition
InvertedTransform Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : InvertedTransform Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public InvertedTransform As Matrix3x2
C#
public Matrix3x2 InvertedTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


Region Field

[image]
ActiveReports 19 .NET Edition
Region Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > ShapeArea Class : Region Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Region As Region
C#
public Region Region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeArea Class
ShapeArea Members


TextStyle Class

[image]
ActiveReports 19 .NET Edition
TextStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextStyle Class

Glossary Item Box

Specified text output settings

Object Model

TextStyle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextStyle
C#
public sealed class TextStyle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.TextStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


TextStyle Class Members

[image]
ActiveReports 19 .NET Edition
TextStyle Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextStyle Class

Glossary Item Box

The following tables list the members exposed by TextStyle.

Public Constructors

 | Name | Description
Public Constructor | TextStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets text string alignment within its rectangle.
Public Property | Anchor | Gets or sets how text box anchors to its position.
Public Property | Angle | Gets or sets text output angle.
Public Property | Color | Gets or sets the color to draw text string.
Public Property | Font | Gets or sets font info to draw text.
Public Property | IsVertical | Gets or sets whether draw text vertically.
Public Property | MaxHeight | Gets or sets maximal bounding rectangle height.
Public Property | MaxWidth | Gets or sets maximal bounding rectangle width.
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


TextStyle Constructor

[image]
ActiveReports 19 .NET Edition
TextStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : TextStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Class Methods

[image]
ActiveReports 19 .NET Edition
TextStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextStyle Class

Glossary Item Box

For a list of all members of this type, see TextStyle members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose |
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Class Properties

[image]
ActiveReports 19 .NET Edition
TextStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextStyle Class

Glossary Item Box

For a list of all members of this type, see TextStyle members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets text string alignment within its rectangle.
Public Property | Anchor | Gets or sets how text box anchors to its position.
Public Property | Angle | Gets or sets text output angle.
Public Property | Color | Gets or sets the color to draw text string.
Public Property | Font | Gets or sets font info to draw text.
Public Property | IsVertical | Gets or sets whether draw text vertically.
Public Property | MaxHeight | Gets or sets maximal bounding rectangle height.
Public Property | MaxWidth | Gets or sets maximal bounding rectangle width.
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Align Property

[image]
ActiveReports 19 .NET Edition
Align Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Align Property

Glossary Item Box

Gets or sets text string alignment within its rectangle.

Syntax

Visual Basic (Declaration)
Public Property Align As TextAlign
C#
public TextAlign Align {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


Anchor Property

[image]
ActiveReports 19 .NET Edition
Anchor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Anchor Property

Glossary Item Box

Gets or sets how text box anchors to its position.

Syntax

Visual Basic (Declaration)
Public Property Anchor As TextAnchor
C#
public TextAnchor Anchor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Angle Property

Glossary Item Box

Gets or sets text output angle.

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Color Property

Glossary Item Box

Gets or sets the color to draw text string.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : Font Property

Glossary Item Box

Gets or sets font info to draw text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


IsVertical Property

[image]
ActiveReports 19 .NET Edition
IsVertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : IsVertical Property

Glossary Item Box

Gets or sets whether draw text vertically.

Syntax

Visual Basic (Declaration)
Public Property IsVertical As Boolean
C#
public bool IsVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


MaxHeight Property

[image]
ActiveReports 19 .NET Edition
MaxHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : MaxHeight Property

Glossary Item Box

Gets or sets maximal bounding rectangle height.

Syntax

Visual Basic (Declaration)
Public Property MaxHeight As Integer
C#
public int MaxHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


MaxWidth Property

[image]
ActiveReports 19 .NET Edition
MaxWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > TextStyle Class : MaxWidth Property

Glossary Item Box

Gets or sets maximal bounding rectangle width.

Syntax

Visual Basic (Declaration)
Public Property MaxWidth As Integer
C#
public int MaxWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


AntiAliasMode Enumeration

[image]
ActiveReports 19 .NET Edition
AntiAliasMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : AntiAliasMode Enumeration

Glossary Item Box

Specifies the antialiasing settings used to draw the object.

Syntax

Visual Basic (Declaration)
Public Enum AntiAliasMode
   Inherits System.Enum
C#
public enum AntiAliasMode : System.Enum

Members

Member | Description
Auto | The antialiasing settings of the parent object are used.
Both | Both graphics and text are antialiased.
Graphics | Only graphics are antialiased.
None | No antialiasing settings are used.
Text | Only text is antialiased.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


BackdropStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BackdropStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : BackdropStyle Enumeration

Glossary Item Box

Specifies the style used to draw the backdrop of an object.

Syntax

Visual Basic (Declaration)
Public Enum BackdropStyle
   Inherits System.Enum
C#
public enum BackdropStyle : System.Enum

Members

Member | Description
Gradient | A gradient fill is used for the backdrop.
Pattern | A pattern fill is used for the backdrop.
Picture |
Solid | A solid fill is used for the backdrop.
Transparent | The backdrop is transparent.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


GradientType Enumeration

[image]
ActiveReports 19 .NET Edition
GradientType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : GradientType Enumeration

Glossary Item Box

Specifies the type of gradient to draw.

Syntax

Visual Basic (Declaration)
Public Enum GradientType
   Inherits System.Enum
C#
public enum GradientType : System.Enum

Members

Member | Description
DiagonalDown | The gradient is drawn from top left to bottom right.
DiagonalUp | The gradient is drawn from bottom left to top right.
FromCenter | A radial gradient is drawn from the center.
FromCorner | A radial gradient is drawn to the center.
Horizontal | A horizontal gradient is drawn.
Vertical | A vertical gradient is drawn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.GradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


LineStyle Enumeration

[image]
ActiveReports 19 .NET Edition
LineStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : LineStyle Enumeration

Glossary Item Box

Specifies the line style to use.

Syntax

Visual Basic (Declaration)
Public Enum LineStyle
   Inherits System.Enum
C#
public enum LineStyle : System.Enum

Members

Member | Description
Dash | A dashed line is drawn.
DashDot | A line of alternating dashes and dots is drawn.
DashDotDot | A line of dashes alternated with two dots is drawn.
Dot | A dotted line is drawn.
None | No line style is used.
Solid | A solid line is drawn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.LineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


PicturePutStyle Enumeration

[image]
ActiveReports 19 .NET Edition
PicturePutStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : PicturePutStyle Enumeration

Glossary Item Box

Specifies how the image is aligned inside the backdrop.

Syntax

Visual Basic (Declaration)
Public Enum PicturePutStyle
   Inherits System.Enum
C#
public enum PicturePutStyle : System.Enum

Members

Member | Description
Bottom | The image is aligned to the bottom.
Centered | The image is centered.
Left | The image is aligned to the left.
Right | The image is aligned to the right.
Stretched | The image is stretched to fill the backdrop.
Tiled | The image is tiled.
Top | The image is aligned to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


ProjectionType Enumeration

[image]
ActiveReports 19 .NET Edition
ProjectionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ProjectionType Enumeration

Glossary Item Box

Specifies the projection type used.

Syntax

Visual Basic (Declaration)
Public Enum ProjectionType
   Inherits System.Enum
C#
public enum ProjectionType : System.Enum

Members

Member | Description
Identical | Flat projection is used (i.e. the z coordinate is ignored).
Orthogonal | Orthogonal projection is used.
Perspective | Perspective projection is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.ProjectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


TextAlign Enumeration

[image]
ActiveReports 19 .NET Edition
TextAlign Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextAlign Enumeration

Glossary Item Box

Specifies how text is aligned within its rectangle.

Syntax

Visual Basic (Declaration)
Public Enum TextAlign
   Inherits System.Enum
C#
public enum TextAlign : System.Enum

Members

Member | Description
Center | The text is centered.
Left | The text is aligned left.
Right | The text is aligned right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.TextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


TextAnchor Enumeration

[image]
ActiveReports 19 .NET Edition
TextAnchor Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextAnchor Enumeration

Glossary Item Box

Specifies how the text shape anchors to its position.

Syntax

Visual Basic (Declaration)
Public Enum TextAnchor
   Inherits System.Enum
C#
public enum TextAnchor : System.Enum

Members

Member | Description
BottomLeft | The text anchors by the bottom left corner.
BottomMiddle | The text anchors by the center of the bottom.
BottomRight | The text anchors by the bottom right corner.
Center | The text anchors by the center.
MiddleLeft | The text anchors by the center of the left side.
MiddleRight | The text anchors by the center of the right side.
TopLeft | The text anchors by the top left corner.
TopMiddle | The text anchors by the center of the top.
TopRight | The text anchors by the top right corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.TextAnchor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Structure

[image]
ActiveReports 19 .NET Edition
Bar Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

Glossary Item Box

Stores the location and size of the Bar area.

Object Model

Bar Structure

Syntax

Visual Basic (Declaration)
Public Structure Bar
   Inherits System.ValueType
C#
public struct Bar : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Chart.Graphics.Bar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Structure Members

[image]
ActiveReports 19 .NET Edition
Bar Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

Glossary Item Box

The following tables list the members exposed by Bar.

Public Constructors

 | Name | Description
Public Constructor | Bar Constructor | Initializes a new instance of the Bar class with the specified parameters.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the bar structure with its properties uninitialized.
Top

Public Properties

 | Name | Description
Public Property | Depth | Gets the depth of the bar.
Public Property | Height | Gets the height of the bar.
Public Property | IsEmpty | Gets or sets a value indicating whether the bar is empty.
Public Property | Width | Gets the width of the bar.
Top

See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Constructor

[image]
ActiveReports 19 .NET Edition
Bar Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Bar Constructor

width
Width of the bar.
height
Height of the bar.
depth
Depth of the bar.

Glossary Item Box

Initializes a new instance of the Bar class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal depth As Integer _
)
C#
public Bar(
   int width,
   int height,
   int depth
)

Parameters

width
Width of the bar.
height
Height of the bar.
depth
Depth of the bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


Bar Structure Properties

[image]
ActiveReports 19 .NET Edition
Bar Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

Glossary Item Box

For a list of all members of this type, see Bar members.

Public Properties

 | Name | Description
Public Property | Depth | Gets the depth of the bar.
Public Property | Height | Gets the height of the bar.
Public Property | IsEmpty | Gets or sets a value indicating whether the bar is empty.
Public Property | Width | Gets the width of the bar.
Top

See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Depth Property

[image]
ActiveReports 19 .NET Edition
Depth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Depth Property

Glossary Item Box

Gets the depth of the bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Depth As Integer
C#
public int Depth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Height Property

Glossary Item Box

Gets the height of the bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : IsEmpty Property

Glossary Item Box

Gets or sets a value indicating whether the bar is empty.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Width Property

Glossary Item Box

Gets the width of the bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


Bar Structure Fields

[image]
ActiveReports 19 .NET Edition
Bar Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

Glossary Item Box

For a list of all members of this type, see Bar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the bar structure with its properties uninitialized.
Top

See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Empty Field

Glossary Item Box

Represents an instance of the bar structure with its properties uninitialized.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Bar
C#
public static readonly Bar Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bar Structure
Bar Members


DataEngineException Class

[image]
ActiveReports 19 .NET Edition
DataEngineException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataEngineException Class

Glossary Item Box

Base class for data engine exceptions.

Object Model

DataEngineException Class

Syntax

Visual Basic (Declaration)
Public Class DataEngineException
   Inherits System.Exception
C#
public class DataEngineException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.Enterprise.Data.DataEngine.DataEngineException
GrapeCity.Enterprise.Data.DataEngine.InvalidDefinitionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataEngineException Class Members

[image]
ActiveReports 19 .NET Edition
DataEngineException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataEngineException Class

Glossary Item Box

The following tables list the members exposed by DataEngineException.

See Also

Reference

DataEngineException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataProcessor Class

[image]
ActiveReports 19 .NET Edition
DataProcessor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor Class

Glossary Item Box

Represents the data tree building and transformation functions.

Object Model

DataProcessor Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataProcessor
C#
public static class DataProcessor

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataProcessor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataProcessor Class Members

[image]
ActiveReports 19 .NET Edition
DataProcessor Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor Class

Glossary Item Box

The following tables list the members exposed by DataProcessor.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Run | Executes specified report.
static (Shared in Visual Basic) | Transform |
Top

See Also

Reference

DataProcessor Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataProcessor Class Methods

[image]
ActiveReports 19 .NET Edition
DataProcessor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor Class

Glossary Item Box

For a list of all members of this type, see DataProcessor members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Run | Executes specified report.
static (Shared in Visual Basic) | Transform |
Top

See Also

Reference

DataProcessor Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Run(Report,ReportContextFn,InteractiveState) Method

[image]
ActiveReports 19 .NET Edition
Run(Report,ReportContextFn,InteractiveState) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor Class > Run Method : Run(Report,ReportContextFn,InteractiveState) Method

report
The data query definition for entire report.
makeContext
The function to make report context.
interactiveState
The interactive sort state.

Glossary Item Box

Executes specified report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Run( _
   ByVal report As Def.Report, _
   ByVal makeContext As ReportContextFn, _
   Optional ByVal interactiveState As InteractiveState _
) As DataProcessor.Result
C#
public static DataProcessor.Result Run(
   Def.Report report,
   ReportContextFn makeContext,
   InteractiveState interactiveState
)

Parameters

report
The data query definition for entire report.
makeContext
The function to make report context.
interactiveState
The interactive sort state.

Return Value

The DataProcessor.Result object which represents the pair of aggregate and result trees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor Class
DataProcessor Members
Overload List


Transform Method

[image]
ActiveReports 19 .NET Edition
Transform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor Class : Transform Method

aggregateTree
query
interactiveState
makeContext

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Transform( _
   ByVal aggregateTree As DataTree.Snapshot(Of Aggregate), _
   ByVal query As Def.Report, _
   ByVal interactiveState As InteractiveState, _
   Optional ByVal makeContext As ReportContextFn _
) As DataTree.Snapshot(Of Object)
C#
public static DataTree.Snapshot<object> Transform(
   DataTree.Snapshot<Aggregate> aggregateTree,
   Def.Report query,
   InteractiveState interactiveState,
   ReportContextFn makeContext
)

Parameters

aggregateTree
query
interactiveState
makeContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor Class
DataProcessor Members


DataTree<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree<T> Class

Glossary Item Box

Defines data tree result structures.

Object Model

DataTree<T> Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataTree(Of T)
C#
public static class DataTree<T>

Type Parameters

T

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree<T> Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree<T>.

See Also

Reference

DataTree<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.DataRegion<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.DataRegion<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.DataRegion<T> Class

Glossary Item Box

Base class for data regions.

Object Model

DataTree.DataRegion<T> Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataTree.DataRegion(Of T)
C#
public abstract class DataTree.DataRegion<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.DataRegion<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.List<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Tablix<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.DataRegion<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.DataRegion<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.DataRegion<T> Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.DataRegion<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.DataRegion<T>.

Public Fields

 | Name | Description
Public Field | Name | DataRegion's name. For debugging purposes.
Public Field | Scope | DataRegion's scope.
Top

See Also

Reference

DataTree.DataRegion<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.DataRegion<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.DataRegion<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.DataRegion<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.DataRegion<T> members.

Public Fields

 | Name | Description
Public Field | Name | DataRegion's name. For debugging purposes.
Public Field | Scope | DataRegion's scope.
Top

See Also

Reference

DataTree.DataRegion<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.DataRegion<T> Class : Name Field

Glossary Item Box

DataRegion's name. For debugging purposes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.DataRegion<T> Class
DataTree.DataRegion<T> Members


Scope Field

[image]
ActiveReports 19 .NET Edition
Scope Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.DataRegion<T> Class : Scope Field

Glossary Item Box

DataRegion's scope.

Syntax

Visual Basic (Declaration)
Public ReadOnly Scope As DataTree.Scope(Of T)
C#
public readonly DataTree.Scope<T> Scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.DataRegion<T> Class
DataTree.DataRegion<T> Members


DataTree.List<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.List<T> Class

Glossary Item Box

List data region.

Object Model

DataTree.List<T> Class

Syntax

Visual Basic (Declaration)
Public Class DataTree.List(Of T)
   Inherits DataTree.DataRegion(Of T)
C#
public class DataTree.List<T> : DataTree.DataRegion<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.DataRegion<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.List<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.List<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.List<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.List<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.List<T> Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty list instance.
Top

Public Properties

 | Name | Description
Public Property | Groups | List data region groups.
Top

See Also

Reference

DataTree.List<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.List<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.List<T> Class : DataTree.List<T> Constructor

Glossary Item Box

Overload List

Overload | Description
DataTree.List<T> Constructor(Scope<T>,Scope<T>[],String) |
DataTree.List<T> Constructor(Scope<T>,Func<IReadOnlyList<Scope<T>>>,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Class
DataTree.List<T> Members


DataTree.List<T> Constructor(Scope<T>,Scope<T>[],String)

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Constructor(Scope<T>,Scope<T>[],String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.List<T> Class > DataTree.List<T> Constructor : DataTree.List<T> Constructor(Scope<T>,Scope<T>[],String)

scope
groups
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scope As DataTree.Scope(Of T), _
   ByVal groups() As DataTree.Scope(Of T), _
   Optional ByVal name As String _
)
C#
public DataTree.List<T>(
   DataTree.Scope<T> scope,
   DataTree.Scope<T>[] groups,
   string name
)

Parameters

scope
groups
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Class
DataTree.List<T> Members
Overload List


DataTree.List<T> Constructor(Scope<T>,Func<IReadOnlyList<Scope<T>>>,String)

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Constructor(Scope<T>,Func<IReadOnlyList<Scope<T>>>,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.List<T> Class > DataTree.List<T> Constructor : DataTree.List<T> Constructor(Scope<T>,Func<IReadOnlyList<Scope<T>>>,String)

scope
makeGroups
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scope As DataTree.Scope(Of T), _
   ByVal makeGroups As Func(Of IReadOnlyList(Of DataTree.Scope(Of T))), _
   Optional ByVal name As String _
)
C#
public DataTree.List<T>(
   DataTree.Scope<T> scope,
   Func<IReadOnlyList<DataTree.Scope<T>>> makeGroups,
   string name
)

Parameters

scope
makeGroups
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Class
DataTree.List<T> Members
Overload List


DataTree.List<T> Class Properties

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.List<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.List<T> members.

Public Properties

 | Name | Description
Public Property | Groups | List data region groups.
Top

See Also

Reference

DataTree.List<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Groups Property

[image]
ActiveReports 19 .NET Edition
Groups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.List<T> Class : Groups Property

Glossary Item Box

List data region groups.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groups As IReadOnlyList(Of DataTree.Scope(Of T))
C#
public IReadOnlyList<DataTree.Scope<T>> Groups {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Class
DataTree.List<T> Members


DataTree.List<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.List<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.List<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.List<T> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty list instance.
Top

See Also

Reference

DataTree.List<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.List<T> Class : Empty Field

Glossary Item Box

Empty list instance.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As DataTree.List(Of T)
C#
public static readonly DataTree.List<T> Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.List<T> Class
DataTree.List<T> Members


DataTree.Scope<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Scope<T> Class

Glossary Item Box

Data scope.

Object Model

DataTree.Scope<T> Class

Syntax

Visual Basic (Declaration)
Public Class DataTree.Scope(Of T)
C#
public class DataTree.Scope<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Scope<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Scope<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Scope<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.Scope<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.Scope<T> Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Empty data scope.
Top

Public Properties

 | Name | Description
Public Property | Id | Gets unique id of this scope. For non-interactive reports it could be zero valued.
Public Property | IsEmpty | Gets true if this instance represents scope without any data.
Public Property | IsNull | Gets true if this instance represents null scope.
Public Property | Regions | Scope child regions.
Public Property | Values | Scope values.
Top

See Also

Reference

DataTree.Scope<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Scope<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : DataTree.Scope<T> Constructor

Glossary Item Box

Overload List

Overload | Description
DataTree.Scope<T> Constructor(T[],Int32) | Creates new DataTree.Scope<T> instance.
DataTree.Scope<T> Constructor(T[],DataRegion<T>[],Int32) |
DataTree.Scope<T> Constructor(T[],Func<DataRegion<T>[]>,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


DataTree.Scope<T> Constructor(T[],Int32)

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Constructor(T[],Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class > DataTree.Scope<T> Constructor : DataTree.Scope<T> Constructor(T[],Int32)

values
id

Glossary Item Box

Creates new DataTree.Scope<T> instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values() As T, _
   Optional ByVal id As Integer _
)
C#
public DataTree.Scope<T>(
   T[] values,
   int id
)

Parameters

values
id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members
Overload List


DataTree.Scope<T> Constructor(T[],DataRegion<T>[],Int32)

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Constructor(T[],DataRegion<T>[],Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class > DataTree.Scope<T> Constructor : DataTree.Scope<T> Constructor(T[],DataRegion<T>[],Int32)

values
regions
id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values() As T, _
   ByVal regions() As DataTree.DataRegion(Of T), _
   Optional ByVal id As Integer _
)
C#
public DataTree.Scope<T>(
   T[] values,
   DataTree.DataRegion<T>[] regions,
   int id
)

Parameters

values
regions
id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members
Overload List


DataTree.Scope<T> Constructor(T[],Func<DataRegion<T>[]>,Int32)

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Constructor(T[],Func<DataRegion<T>[]>,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class > DataTree.Scope<T> Constructor : DataTree.Scope<T> Constructor(T[],Func<DataRegion<T>[]>,Int32)

values
makeRegions
id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values() As T, _
   ByVal makeRegions As Func(Of DataTree.DataRegion(Of T)()), _
   Optional ByVal id As Integer _
)
C#
public DataTree.Scope<T>(
   T[] values,
   Func<DataTree.DataRegion<T>[]> makeRegions,
   int id
)

Parameters

values
makeRegions
id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members
Overload List


DataTree.Scope<T> Class Properties

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Scope<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.Scope<T> members.

Public Properties

 | Name | Description
Public Property | Id | Gets unique id of this scope. For non-interactive reports it could be zero valued.
Public Property | IsEmpty | Gets true if this instance represents scope without any data.
Public Property | IsNull | Gets true if this instance represents null scope.
Public Property | Regions | Scope child regions.
Public Property | Values | Scope values.
Top

See Also

Reference

DataTree.Scope<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : Id Property

Glossary Item Box

Gets unique id of this scope. For non-interactive reports it could be zero valued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As Integer
C#
public int Id {get;}

Remarks

This property is added primarily to simplify implementation of interactivity features.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : IsEmpty Property

Glossary Item Box

Gets true if this instance represents scope without any data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


IsNull Property

[image]
ActiveReports 19 .NET Edition
IsNull Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : IsNull Property

Glossary Item Box

Gets true if this instance represents null scope.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


Regions Property

[image]
ActiveReports 19 .NET Edition
Regions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : Regions Property

Glossary Item Box

Scope child regions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Regions As DataTree.DataRegion(Of T)()
C#
public DataTree.DataRegion<T>[] Regions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : Values Property

Glossary Item Box

Scope values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As T()
C#
public T[] Values {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


DataTree.Scope<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.Scope<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Scope<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.Scope<T> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Empty data scope.
Top

See Also

Reference

DataTree.Scope<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Null Field

[image]
ActiveReports 19 .NET Edition
Null Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Scope<T> Class : Null Field

Glossary Item Box

Empty data scope.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As DataTree.Scope(Of T)
C#
public static readonly DataTree.Scope<T> Null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Scope<T> Class
DataTree.Scope<T> Members


DataTree.Snapshot<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.Snapshot<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Snapshot<T> Class

Glossary Item Box

Defines data tree with its definition.

Object Model

DataTree.Snapshot<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTree.Snapshot(Of T)
C#
public sealed class DataTree.Snapshot<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Snapshot<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Snapshot<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Snapshot<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.Snapshot<T> Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Snapshot<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.Snapshot<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.Snapshot<T> Constructor |
Top

Public Fields

 | Name | Description
Public Field | Data | The data.
Public Field | Definition | Initial Query definition.
Top

See Also

Reference

DataTree.Snapshot<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Snapshot<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.Snapshot<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Snapshot<T> Class : DataTree.Snapshot<T> Constructor

definition
data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal definition As Def.Report, _
   ByVal data As DataTree.Scope(Of T) _
)
C#
public DataTree.Snapshot<T>(
   Def.Report definition,
   DataTree.Scope<T> data
)

Parameters

definition
data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Snapshot<T> Class
DataTree.Snapshot<T> Members


DataTree.Snapshot<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.Snapshot<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Snapshot<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.Snapshot<T> members.

Public Fields

 | Name | Description
Public Field | Data | The data.
Public Field | Definition | Initial Query definition.
Top

See Also

Reference

DataTree.Snapshot<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Data Field

[image]
ActiveReports 19 .NET Edition
Data Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Snapshot<T> Class : Data Field

Glossary Item Box

The data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Data As DataTree.Scope(Of T)
C#
public readonly DataTree.Scope<T> Data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Snapshot<T> Class
DataTree.Snapshot<T> Members


Definition Field

[image]
ActiveReports 19 .NET Edition
Definition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Snapshot<T> Class : Definition Field

Glossary Item Box

Initial Query definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Definition As Def.Report
C#
public readonly Def.Report Definition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Snapshot<T> Class
DataTree.Snapshot<T> Members


DataTree.Tablix<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Tablix<T> Class

Glossary Item Box

Tablix data.

Object Model

DataTree.Tablix<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTree.Tablix(Of T)
   Inherits DataTree.DataRegion(Of T)
C#
public sealed class DataTree.Tablix<T> : DataTree.DataRegion<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.DataRegion<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Tablix<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Tablix<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Tablix<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.Tablix<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.Tablix<T> Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | ColumnMembers | Tablix column members.
static (Shared in Visual Basic) | Empty | Empty Tablix instance.
Public Field | RowMembers | Tablix row members.
Top

Public Properties

 | Name | Description
Public Property | Body | Tablix body (rows).
Top

See Also

Reference

DataTree.Tablix<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.Tablix<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class : DataTree.Tablix<T> Constructor

Glossary Item Box

Overload List

Overload | Description
DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],TablixRow<T>[],String) |
DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],Func<IEnumerable<TablixRow<T>>>,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members


DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],TablixRow<T>[],String)

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],TablixRow<T>[],String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class > DataTree.Tablix<T> Constructor : DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],TablixRow<T>[],String)

corner
columnMembers
rowMembers
body
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal corner As DataTree.Scope(Of T), _
   ByVal columnMembers() As DataTree.TablixMember(Of T), _
   ByVal rowMembers() As DataTree.TablixMember(Of T), _
   ByVal body() As DataTree.TablixRow(Of T), _
   Optional ByVal name As String _
)
C#
public DataTree.Tablix<T>(
   DataTree.Scope<T> corner,
   DataTree.TablixMember<T>[] columnMembers,
   DataTree.TablixMember<T>[] rowMembers,
   DataTree.TablixRow<T>[] body,
   string name
)

Parameters

corner
columnMembers
rowMembers
body
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members
Overload List


DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],Func<IEnumerable<TablixRow<T>>>,String)

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],Func<IEnumerable<TablixRow<T>>>,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class > DataTree.Tablix<T> Constructor : DataTree.Tablix<T> Constructor(Scope<T>,TablixMember<T>[],TablixMember<T>[],Func<IEnumerable<TablixRow<T>>>,String)

corner
columnMembers
rowMembers
makeBody
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal corner As DataTree.Scope(Of T), _
   ByVal columnMembers() As DataTree.TablixMember(Of T), _
   ByVal rowMembers() As DataTree.TablixMember(Of T), _
   ByVal makeBody As Func(Of IEnumerable(Of DataTree.TablixRow(Of T))), _
   Optional ByVal name As String _
)
C#
public DataTree.Tablix<T>(
   DataTree.Scope<T> corner,
   DataTree.TablixMember<T>[] columnMembers,
   DataTree.TablixMember<T>[] rowMembers,
   Func<IEnumerable<DataTree.TablixRow<T>>> makeBody,
   string name
)

Parameters

corner
columnMembers
rowMembers
makeBody
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members
Overload List


DataTree.Tablix<T> Class Properties

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Tablix<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.Tablix<T> members.

Public Properties

 | Name | Description
Public Property | Body | Tablix body (rows).
Top

See Also

Reference

DataTree.Tablix<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class : Body Property

Glossary Item Box

Tablix body (rows).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Body As IReadOnlyList(Of DataTree.TablixRow(Of T))
C#
public IReadOnlyList<DataTree.TablixRow<T>> Body {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members


DataTree.Tablix<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.Tablix<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.Tablix<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.Tablix<T> members.

Public Fields

 | Name | Description
Public Field | ColumnMembers | Tablix column members.
static (Shared in Visual Basic) | Empty | Empty Tablix instance.
Public Field | RowMembers | Tablix row members.
Top

See Also

Reference

DataTree.Tablix<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


ColumnMembers Field

[image]
ActiveReports 19 .NET Edition
ColumnMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class : ColumnMembers Field

Glossary Item Box

Tablix column members.

Syntax

Visual Basic (Declaration)
Public ReadOnly ColumnMembers As DataTree.TablixMember(Of T)()
C#
public readonly DataTree.TablixMember<T>[] ColumnMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class : Empty Field

Glossary Item Box

Empty Tablix instance.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As DataTree.Tablix(Of T)
C#
public static readonly DataTree.Tablix<T> Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members


RowMembers Field

[image]
ActiveReports 19 .NET Edition
RowMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.Tablix<T> Class : RowMembers Field

Glossary Item Box

Tablix row members.

Syntax

Visual Basic (Declaration)
Public ReadOnly RowMembers As DataTree.TablixMember(Of T)()
C#
public readonly DataTree.TablixMember<T>[] RowMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.Tablix<T> Class
DataTree.Tablix<T> Members


DataTree.TablixMember<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixMember<T> Class

Glossary Item Box

Tablix member data.

Object Model

DataTree.TablixMember<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTree.TablixMember(Of T)
C#
public sealed class DataTree.TablixMember<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.TablixMember<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.TablixMember<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixMember<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.TablixMember<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.TablixMember<T> Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Header | Tablix header data.
Public Field | Id | Member identifier.-1 for non-leaf members, zero-based for leaf members
Public Field | IsCollection | True if the member is collection.
Top

Public Properties

 | Name | Description
Public Property | Members | Tablix members.
Top

See Also

Reference

DataTree.TablixMember<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.TablixMember<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class : DataTree.TablixMember<T> Constructor

Glossary Item Box

Overload List

Overload | Description
DataTree.TablixMember<T> Constructor(Scope<T>,TablixMember<T>[],Boolean,Int32) |
DataTree.TablixMember<T> Constructor(Scope<T>,Boolean,Int32,Func<IReadOnlyList<TablixMember<T>>>) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members


DataTree.TablixMember<T> Constructor(Scope<T>,TablixMember<T>[],Boolean,Int32)

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Constructor(Scope<T>,TablixMember<T>[],Boolean,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class > DataTree.TablixMember<T> Constructor : DataTree.TablixMember<T> Constructor(Scope<T>,TablixMember<T>[],Boolean,Int32)

header
members
isCollection
id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal header As DataTree.Scope(Of T), _
   ByVal members() As DataTree.TablixMember(Of T), _
   ByVal isCollection As Boolean, _
   ByVal id As Integer _
)
C#
public DataTree.TablixMember<T>(
   DataTree.Scope<T> header,
   DataTree.TablixMember<T>[] members,
   bool isCollection,
   int id
)

Parameters

header
members
isCollection
id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members
Overload List


DataTree.TablixMember<T> Constructor(Scope<T>,Boolean,Int32,Func<IReadOnlyList<TablixMember<T>>>)

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Constructor(Scope<T>,Boolean,Int32,Func<IReadOnlyList<TablixMember<T>>>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class > DataTree.TablixMember<T> Constructor : DataTree.TablixMember<T> Constructor(Scope<T>,Boolean,Int32,Func<IReadOnlyList<TablixMember<T>>>)

header
isCollection
id
makeMembers

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal header As DataTree.Scope(Of T), _
   ByVal isCollection As Boolean, _
   ByVal id As Integer, _
   ByVal makeMembers As Func(Of IReadOnlyList(Of DataTree.TablixMember(Of T))) _
)
C#
public DataTree.TablixMember<T>(
   DataTree.Scope<T> header,
   bool isCollection,
   int id,
   Func<IReadOnlyList<DataTree.TablixMember<T>>> makeMembers
)

Parameters

header
isCollection
id
makeMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members
Overload List


DataTree.TablixMember<T> Class Properties

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixMember<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.TablixMember<T> members.

Public Properties

 | Name | Description
Public Property | Members | Tablix members.
Top

See Also

Reference

DataTree.TablixMember<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Members Property

[image]
ActiveReports 19 .NET Edition
Members Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class : Members Property

Glossary Item Box

Tablix members.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Members As IReadOnlyList(Of DataTree.TablixMember(Of T))
C#
public IReadOnlyList<DataTree.TablixMember<T>> Members {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members


DataTree.TablixMember<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.TablixMember<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixMember<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.TablixMember<T> members.

Public Fields

 | Name | Description
Public Field | Header | Tablix header data.
Public Field | Id | Member identifier.-1 for non-leaf members, zero-based for leaf members
Public Field | IsCollection | True if the member is collection.
Top

See Also

Reference

DataTree.TablixMember<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Header Field

[image]
ActiveReports 19 .NET Edition
Header Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class : Header Field

Glossary Item Box

Tablix header data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Header As DataTree.Scope(Of T)
C#
public readonly DataTree.Scope<T> Header

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members


Id Field

[image]
ActiveReports 19 .NET Edition
Id Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class : Id Field

Glossary Item Box

Member identifier.-1 for non-leaf members, zero-based for leaf members

Syntax

Visual Basic (Declaration)
Public ReadOnly Id As Integer
C#
public readonly int Id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members


IsCollection Field

[image]
ActiveReports 19 .NET Edition
IsCollection Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixMember<T> Class : IsCollection Field

Glossary Item Box

True if the member is collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly IsCollection As Boolean
C#
public readonly bool IsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixMember<T> Class
DataTree.TablixMember<T> Members


DataTree.TablixRow<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataTree.TablixRow<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixRow<T> Class

Glossary Item Box

Tablix row data

Object Model

DataTree.TablixRow<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTree.TablixRow(Of T)
C#
public sealed class DataTree.TablixRow<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.TablixRow<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixRow<T> Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.TablixRow<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataTree.TablixRow<T> Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixRow<T> Class

Glossary Item Box

The following tables list the members exposed by DataTree.TablixRow<T>.

Public Constructors

 | Name | Description
Public Constructor | DataTree.TablixRow<T> Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cells | Row cells scopes.
Top

See Also

Reference

DataTree.TablixRow<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataTree.TablixRow<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataTree.TablixRow<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixRow<T> Class : DataTree.TablixRow<T> Constructor

cells

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cells() As DataTree.Scope(Of T) _
)
C#
public DataTree.TablixRow<T>(
   DataTree.Scope<T>[] cells
)

Parameters

cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixRow<T> Class
DataTree.TablixRow<T> Members


DataTree.TablixRow<T> Class Fields

[image]
ActiveReports 19 .NET Edition
DataTree.TablixRow<T> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataTree.TablixRow<T> Class

Glossary Item Box

For a list of all members of this type, see DataTree.TablixRow<T> members.

Public Fields

 | Name | Description
Public Field | Cells | Row cells scopes.
Top

See Also

Reference

DataTree.TablixRow<T> Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Cells Field

[image]
ActiveReports 19 .NET Edition
Cells Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataTree.TablixRow<T> Class : Cells Field

Glossary Item Box

Row cells scopes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Cells As DataTree.Scope(Of T)()
C#
public readonly DataTree.Scope<T>[] Cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTree.TablixRow<T> Class
DataTree.TablixRow<T> Members


Def Class

[image]
ActiveReports 19 .NET Edition
Def Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def Class

Glossary Item Box

Defines data query definition classes.

Object Model

Def Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Def
C#
public static class Def

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def Class Members

[image]
ActiveReports 19 .NET Edition
Def Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def Class

Glossary Item Box

The following tables list the members exposed by Def.

See Also

Reference

Def Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Content Class

[image]
ActiveReports 19 .NET Edition
Def.Content Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Content Class

Glossary Item Box

Content definition

Object Model

Def.Content Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Content
C#
public sealed class Def.Content

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Content Class Members

[image]
ActiveReports 19 .NET Edition
Def.Content Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Content Class

Glossary Item Box

The following tables list the members exposed by Def.Content.

Public Constructors

 | Name | Description
Public Constructor | Def.Content Constructor | Initializes a new instance of the Def.Content class
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty instance of class Def.Content
Public Field | Fields | A set expressions for content
Public Field | Regions | A set the regions for content
Top

Public Properties

 | Name | Description
Public Property | IsEmpty | Indicates that the content does not contain expressions and regions
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified Def.Content is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance
Top

See Also

Reference

Def.Content Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Content Constructor

[image]
ActiveReports 19 .NET Edition
Def.Content Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : Def.Content Constructor

fields
A set expressions for content.
regions
A set the regions for content.

Glossary Item Box

Initializes a new instance of the Def.Content class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fields As IEnumerable(Of ExpressionInfo), _
   Optional ByVal regions As IEnumerable(Of Def.Region) _
)
C#
public Def.Content(
   IEnumerable<ExpressionInfo> fields,
   IEnumerable<Def.Region> regions
)

Parameters

fields
A set expressions for content.
regions
A set the regions for content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Def.Content Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Content Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Content Class

Glossary Item Box

For a list of all members of this type, see Def.Content members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified Def.Content is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance
Top

See Also

Reference

Def.Content Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : Equals Method

Glossary Item Box

Determines whether the specified Def.Content is equal to this instance.

Overload List

Overload | Description
Equals(Content) | Determines whether the specified Def.Content is equal to this instance.
Equals(Object) | Determines whether the specified System.Object is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Equals(Content) Method

[image]
ActiveReports 19 .NET Edition
Equals(Content) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class > Equals Method : Equals(Content) Method

other
The Def.Content to compare with the current Def.Content.

Glossary Item Box

Determines whether the specified Def.Content is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Content _
) As Boolean
C#
public bool Equals(
   Def.Content other
)

Parameters

other
The Def.Content to compare with the current Def.Content.

Return Value

true if the specified Def.Content is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class > Equals Method : Equals(Object) Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Def.Content Class Properties

[image]
ActiveReports 19 .NET Edition
Def.Content Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Content Class

Glossary Item Box

For a list of all members of this type, see Def.Content members.

Public Properties

 | Name | Description
Public Property | IsEmpty | Indicates that the content does not contain expressions and regions
Top

See Also

Reference

Def.Content Class
GrapeCity.Enterprise.Data.DataEngine Namespace


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : IsEmpty Property

Glossary Item Box

Indicates that the content does not contain expressions and regions

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Def.Content Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Content Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Content Class

Glossary Item Box

For a list of all members of this type, see Def.Content members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty instance of class Def.Content
Public Field | Fields | A set expressions for content
Public Field | Regions | A set the regions for content
Top

See Also

Reference

Def.Content Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : Empty Field

Glossary Item Box

Empty instance of class Def.Content

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Def.Content
C#
public static readonly Def.Content Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Fields Field

[image]
ActiveReports 19 .NET Edition
Fields Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : Fields Field

Glossary Item Box

A set expressions for content

Syntax

Visual Basic (Declaration)
Public ReadOnly Fields As ExpressionInfo()
C#
public readonly ExpressionInfo[] Fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Regions Field

[image]
ActiveReports 19 .NET Edition
Regions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Content Class : Regions Field

Glossary Item Box

A set the regions for content

Syntax

Visual Basic (Declaration)
Public ReadOnly Regions As Def.Region()
C#
public readonly Def.Region[] Regions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Content Class
Def.Content Members


Def.DataSet Class

[image]
ActiveReports 19 .NET Edition
Def.DataSet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.DataSet Class

Glossary Item Box

DataSet region definition

Object Model

Def.DataSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.DataSet
   Inherits Def.Region
C#
public sealed class Def.DataSet : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.DataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.DataSet Class Members

[image]
ActiveReports 19 .NET Edition
Def.DataSet Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.DataSet Class

Glossary Item Box

The following tables list the members exposed by Def.DataSet.

Public Constructors

 | Name | Description
Public Constructor | Def.DataSet Constructor | Initializes dataset fields.
Top

Public Fields

 | Name | Description
Public Field | FieldNames | Dataset's fields names collection.
Public Field | Parameters | Dataset's parameters collection.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified DataSet object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.DataSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.DataSet Constructor

[image]
ActiveReports 19 .NET Edition
Def.DataSet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class : Def.DataSet Constructor

name
filters
content
fieldNames
parameters

Glossary Item Box

Initializes dataset fields.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal filters As IEnumerable(Of Def.Filter), _
   ByVal content As Def.Content, _
   Optional ByVal fieldNames() As String, _
   Optional ByVal parameters As IEnumerable(Of Def.Parameter) _
)
C#
public Def.DataSet(
   string name,
   IEnumerable<Def.Filter> filters,
   Def.Content content,
   string[] fieldNames,
   IEnumerable<Def.Parameter> parameters
)

Parameters

name
filters
content
fieldNames
parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members


Def.DataSet Class Methods

[image]
ActiveReports 19 .NET Edition
Def.DataSet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.DataSet Class

Glossary Item Box

For a list of all members of this type, see Def.DataSet members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified DataSet object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.DataSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class : Equals Method

Glossary Item Box

Determines whether the specified DataSet object is equal to the current object.

Overload List

Overload | Description
Equals(DataSet) | Determines whether the specified DataSet object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members


Equals(DataSet) Method

[image]
ActiveReports 19 .NET Edition
Equals(DataSet) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class > Equals Method : Equals(DataSet) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified DataSet object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.DataSet _
) As Boolean
C#
public bool Equals(
   Def.DataSet other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members


Def.DataSet Class Fields

[image]
ActiveReports 19 .NET Edition
Def.DataSet Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.DataSet Class

Glossary Item Box

For a list of all members of this type, see Def.DataSet members.

Public Fields

 | Name | Description
Public Field | FieldNames | Dataset's fields names collection.
Public Field | Parameters | Dataset's parameters collection.
Top

See Also

Reference

Def.DataSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


FieldNames Field

[image]
ActiveReports 19 .NET Edition
FieldNames Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class : FieldNames Field

Glossary Item Box

Dataset's fields names collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly FieldNames As String()
C#
public readonly string[] FieldNames

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members


Parameters Field

[image]
ActiveReports 19 .NET Edition
Parameters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.DataSet Class : Parameters Field

Glossary Item Box

Dataset's parameters collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Parameters As Def.Parameter()
C#
public readonly Def.Parameter[] Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.DataSet Class
Def.DataSet Members


Def.Filter Class

[image]
ActiveReports 19 .NET Edition
Def.Filter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Filter Class

Glossary Item Box

Defines filter.

Object Model

Def.Filter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Filter
C#
public sealed class Def.Filter

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Filter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Filter Class Members

[image]
ActiveReports 19 .NET Edition
Def.Filter Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Filter Class

Glossary Item Box

The following tables list the members exposed by Def.Filter.

Public Constructors

 | Name | Description
Public Constructor | Def.Filter Constructor | Initializes a new instance of the Def.Filter class with the specified expression, operator, and values.
Top

Public Fields

 | Name | Description
Public Field | Expression | Filter expression.
Public Field | Op | Filter operator.
Public Field | Values | Filter values.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Filter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Filter Constructor

[image]
ActiveReports 19 .NET Edition
Def.Filter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : Def.Filter Constructor

expression
The expression on the left side of the filter condition.
op
The operator that defines the type of comparison to be performed between the left expression and the right values.
values
An array of expressions on the right side of the filter condition.

Glossary Item Box

Initializes a new instance of the Def.Filter class with the specified expression, operator, and values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As ExpressionInfo, _
   ByVal op As Def.FilterOperator, _
   ByVal values() As ExpressionInfo _
)
C#
public Def.Filter(
   ExpressionInfo expression,
   Def.FilterOperator op,
   ExpressionInfo[] values
)

Parameters

expression
The expression on the left side of the filter condition.
op
The operator that defines the type of comparison to be performed between the left expression and the right values.
values
An array of expressions on the right side of the filter condition.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when expression is null or values is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Def.Filter Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Filter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Filter Class

Glossary Item Box

For a list of all members of this type, see Def.Filter members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Filter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Filter) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Equals(Filter) Method

[image]
ActiveReports 19 .NET Edition
Equals(Filter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class > Equals Method : Equals(Filter) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Filter _
) As Boolean
C#
public bool Equals(
   Def.Filter other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class > Equals Method : Equals(Object) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
C#
public override bool Equals(
   object other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Def.Filter Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Filter Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Filter Class

Glossary Item Box

For a list of all members of this type, see Def.Filter members.

Public Fields

 | Name | Description
Public Field | Expression | Filter expression.
Public Field | Op | Filter operator.
Public Field | Values | Filter values.
Top

See Also

Reference

Def.Filter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Expression Field

[image]
ActiveReports 19 .NET Edition
Expression Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : Expression Field

Glossary Item Box

Filter expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Expression As ExpressionInfo
C#
public readonly ExpressionInfo Expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Op Field

[image]
ActiveReports 19 .NET Edition
Op Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : Op Field

Glossary Item Box

Filter operator.

Syntax

Visual Basic (Declaration)
Public ReadOnly Op As Def.FilterOperator
C#
public readonly Def.FilterOperator Op

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Values Field

[image]
ActiveReports 19 .NET Edition
Values Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Filter Class : Values Field

Glossary Item Box

Filter values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Values As ExpressionInfo()
C#
public readonly ExpressionInfo[] Values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Filter Class
Def.Filter Members


Def.Group Class

[image]
ActiveReports 19 .NET Edition
Def.Group Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Group Class

Glossary Item Box

Group definition

Object Model

Def.Group Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Group
C#
public sealed class Def.Group

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Group

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Group Class Members

[image]
ActiveReports 19 .NET Edition
Def.Group Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Group Class

Glossary Item Box

The following tables list the members exposed by Def.Group.

Public Constructors

 | Name | Description
Public Constructor | Def.Group Constructor | Initializes a new instance of the Def.Group class
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty instance of class Def.Group
Public Field | Filters | A set filters for group
Public Field | GroupExpressions | A set expressions for group
Public Field | Name | Group name
Public Field | Parent | An expression that identifies the parent group in a recursive hierarchy.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance
Top

See Also

Reference

Def.Group Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Group Constructor

[image]
ActiveReports 19 .NET Edition
Def.Group Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Def.Group Constructor

name
Group name.
groupExpressions
A set expressions for group
filters
A set filters for group
parent
An expression that identifies the parent group in a recursive hierarchy.

Glossary Item Box

Initializes a new instance of the Def.Group class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal groupExpressions() As ExpressionInfo, _
   ByVal filters() As Def.Filter, _
   Optional ByVal parent As ExpressionInfo _
)
C#
public Def.Group(
   string name,
   ExpressionInfo[] groupExpressions,
   Def.Filter[] filters,
   ExpressionInfo parent
)

Parameters

name
Group name.
groupExpressions
A set expressions for group
filters
A set filters for group
parent
An expression that identifies the parent group in a recursive hierarchy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Def.Group Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Group Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Group Class

Glossary Item Box

For a list of all members of this type, see Def.Group members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance
Top

See Also

Reference

Def.Group Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Equals Method

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Overload List

Overload | Description
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
Equals(Group) | Determines whether the specified Def.Group is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class > Equals Method : Equals(Object) Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members
Overload List


Equals(Group) Method

[image]
ActiveReports 19 .NET Edition
Equals(Group) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class > Equals Method : Equals(Group) Method

other
The Def.Group to compare with the current Def.Group.

Glossary Item Box

Determines whether the specified Def.Group is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Group _
) As Boolean
C#
public bool Equals(
   Def.Group other
)

Parameters

other
The Def.Group to compare with the current Def.Group.

Return Value

true if the specified Def.Group is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Def.Group Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Group Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Group Class

Glossary Item Box

For a list of all members of this type, see Def.Group members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Empty instance of class Def.Group
Public Field | Filters | A set filters for group
Public Field | GroupExpressions | A set expressions for group
Public Field | Name | Group name
Public Field | Parent | An expression that identifies the parent group in a recursive hierarchy.
Top

See Also

Reference

Def.Group Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Empty Field

Glossary Item Box

Empty instance of class Def.Group

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Def.Group
C#
public static readonly Def.Group Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Filters Field

[image]
ActiveReports 19 .NET Edition
Filters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Filters Field

Glossary Item Box

A set filters for group

Syntax

Visual Basic (Declaration)
Public ReadOnly Filters As Def.Filter()
C#
public readonly Def.Filter[] Filters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


GroupExpressions Field

[image]
ActiveReports 19 .NET Edition
GroupExpressions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : GroupExpressions Field

Glossary Item Box

A set expressions for group

Syntax

Visual Basic (Declaration)
Public ReadOnly GroupExpressions As ExpressionInfo()
C#
public readonly ExpressionInfo[] GroupExpressions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Name Field

Glossary Item Box

Group name

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Parent Field

[image]
ActiveReports 19 .NET Edition
Parent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Group Class : Parent Field

Glossary Item Box

An expression that identifies the parent group in a recursive hierarchy.

Syntax

Visual Basic (Declaration)
Public ReadOnly Parent As ExpressionInfo
C#
public readonly ExpressionInfo Parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Group Class
Def.Group Members


Def.List Class

[image]
ActiveReports 19 .NET Edition
Def.List Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.List Class

Glossary Item Box

List region definition

Object Model

Def.List Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.List
   Inherits Def.Region
C#
public sealed class Def.List : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.List

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.List Class Members

[image]
ActiveReports 19 .NET Edition
Def.List Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.List Class

Glossary Item Box

The following tables list the members exposed by Def.List.

Public Constructors

 | Name | Description
Public Constructor | Def.List Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Group | Group definition.
Public Field | GroupContent | Content definition.
Public Field | HandleEmptyGroups | Specifies whether the empty groups should be handled.
Public Field | Sort | Sorting definitions.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified List object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.List Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.List Constructor

[image]
ActiveReports 19 .NET Edition
Def.List Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : Def.List Constructor

Glossary Item Box

Overload List

Overload | Description
Def.List Constructor(String,Content,IEnumerable<Filter>,Group,IEnumerable<Sort>,Content,Boolean) | Initializes list fields.Initializes list fields.
Def.List Constructor(String,Content,IEnumerable<Filter>) | Creates a list without groupings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


Def.List Constructor(String,Content,IEnumerable<Filter>,Group,IEnumerable<Sort>,Content,Boolean)

[image]
ActiveReports 19 .NET Edition
Def.List Constructor(String,Content,IEnumerable<Filter>,Group,IEnumerable<Sort>,Content,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class > Def.List Constructor : Def.List Constructor(String,Content,IEnumerable<Filter>,Group,IEnumerable<Sort>,Content,Boolean)

name
list name
content
list content
filters
list filters
group
list group
sort
list sorts
groupContent
list group's content
handleEmptyGroups
true to handle empty groups. False by default.

Glossary Item Box

Initializes list fields.Initializes list fields.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal content As Def.Content, _
   ByVal filters As IEnumerable(Of Def.Filter), _
   ByVal group As Def.Group, _
   ByVal sort As IEnumerable(Of Def.Sort), _
   ByVal groupContent As Def.Content, _
   Optional ByVal handleEmptyGroups As Boolean _
)
C#
public Def.List(
   string name,
   Def.Content content,
   IEnumerable<Def.Filter> filters,
   Def.Group group,
   IEnumerable<Def.Sort> sort,
   Def.Content groupContent,
   bool handleEmptyGroups
)

Parameters

name
list name
content
list content
filters
list filters
group
list group
sort
list sorts
groupContent
list group's content
handleEmptyGroups
true to handle empty groups. False by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members
Overload List


Def.List Constructor(String,Content,IEnumerable<Filter>)

[image]
ActiveReports 19 .NET Edition
Def.List Constructor(String,Content,IEnumerable<Filter>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class > Def.List Constructor : Def.List Constructor(String,Content,IEnumerable<Filter>)

name
List name
content
content
filters
filters

Glossary Item Box

Creates a list without groupings

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal content As Def.Content, _
   ByVal filters As IEnumerable(Of Def.Filter) _
)
C#
public Def.List(
   string name,
   Def.Content content,
   IEnumerable<Def.Filter> filters
)

Parameters

name
List name
content
content
filters
filters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members
Overload List


Def.List Class Methods

[image]
ActiveReports 19 .NET Edition
Def.List Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.List Class

Glossary Item Box

For a list of all members of this type, see Def.List members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified List object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.List Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : Equals Method

Glossary Item Box

Determines whether the specified List object is equal to the current object.

Overload List

Overload | Description
Equals(List) | Determines whether the specified List object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


Equals(List) Method

[image]
ActiveReports 19 .NET Edition
Equals(List) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class > Equals Method : Equals(List) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified List object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.List _
) As Boolean
C#
public bool Equals(
   Def.List other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


Def.List Class Fields

[image]
ActiveReports 19 .NET Edition
Def.List Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.List Class

Glossary Item Box

For a list of all members of this type, see Def.List members.

Public Fields

 | Name | Description
Public Field | Group | Group definition.
Public Field | GroupContent | Content definition.
Public Field | HandleEmptyGroups | Specifies whether the empty groups should be handled.
Public Field | Sort | Sorting definitions.
Top

See Also

Reference

Def.List Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Group Field

[image]
ActiveReports 19 .NET Edition
Group Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : Group Field

Glossary Item Box

Group definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Group As Def.Group
C#
public readonly Def.Group Group

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


GroupContent Field

[image]
ActiveReports 19 .NET Edition
GroupContent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : GroupContent Field

Glossary Item Box

Content definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly GroupContent As Def.Content
C#
public readonly Def.Content GroupContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


HandleEmptyGroups Field

[image]
ActiveReports 19 .NET Edition
HandleEmptyGroups Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : HandleEmptyGroups Field

Glossary Item Box

Specifies whether the empty groups should be handled.

Syntax

Visual Basic (Declaration)
Public ReadOnly HandleEmptyGroups As Boolean
C#
public readonly bool HandleEmptyGroups

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


Sort Field

[image]
ActiveReports 19 .NET Edition
Sort Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.List Class : Sort Field

Glossary Item Box

Sorting definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Sort As Def.Sort()
C#
public readonly Def.Sort[] Sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.List Class
Def.List Members


Def.Parameter Class

[image]
ActiveReports 19 .NET Edition
Def.Parameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Parameter Class

Glossary Item Box

Parameter definition

Object Model

Def.Parameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Parameter
C#
public sealed class Def.Parameter

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Def.Parameter Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Parameter Class

Glossary Item Box

The following tables list the members exposed by Def.Parameter.

Public Constructors

 | Name | Description
Public Constructor | Def.Parameter Constructor | Initializes new Def.Parameter instance.
Top

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value expression.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Parameter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Parameter Constructor

[image]
ActiveReports 19 .NET Edition
Def.Parameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class : Def.Parameter Constructor

name
value

Glossary Item Box

Initializes new Def.Parameter instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As ExpressionInfo _
)
C#
public Def.Parameter(
   string name,
   ExpressionInfo value
)

Parameters

name
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members


Def.Parameter Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Parameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Parameter Class

Glossary Item Box

For a list of all members of this type, see Def.Parameter members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Parameter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Parameter) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members


Equals(Parameter) Method

[image]
ActiveReports 19 .NET Edition
Equals(Parameter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class > Equals Method : Equals(Parameter) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Parameter _
) As Boolean
C#
public bool Equals(
   Def.Parameter other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class > Equals Method : Equals(Object) Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members


Def.Parameter Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Parameter Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Parameter Class

Glossary Item Box

For a list of all members of this type, see Def.Parameter members.

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value expression.
Top

See Also

Reference

Def.Parameter Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class : Name Field

Glossary Item Box

Parameter name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Parameter Class : Value Field

Glossary Item Box

Parameter value expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As ExpressionInfo
C#
public readonly ExpressionInfo Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Parameter Class
Def.Parameter Members


Def.Region Class

[image]
ActiveReports 19 .NET Edition
Def.Region Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Region Class

Glossary Item Box

Base class for regions definitions

Object Model

Def.Region Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Def.Region
C#
public abstract class Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.DataSet
GrapeCity.Enterprise.Data.DataEngine.Def.List
GrapeCity.Enterprise.Data.DataEngine.Def.Report
GrapeCity.Enterprise.Data.DataEngine.Def.SimpleRegion
GrapeCity.Enterprise.Data.DataEngine.Def.Subreport
GrapeCity.Enterprise.Data.DataEngine.Def.Tablix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Region Class Members

[image]
ActiveReports 19 .NET Edition
Def.Region Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Region Class

Glossary Item Box

The following tables list the members exposed by Def.Region.

Public Fields

 | Name | Description
Public Field | Content | The content of the region.
Public Field | Filters | The filters defined for the region.
Public Field | Name | The name of the region.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | IsApplicable | Check if the region is applicable to the other region.
Top

See Also

Reference

Def.Region Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Region Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Region Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Region Class

Glossary Item Box

For a list of all members of this type, see Def.Region members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | IsApplicable | Check if the region is applicable to the other region.
Top

See Also

Reference

Def.Region Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Region) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


Equals(Region) Method

[image]
ActiveReports 19 .NET Edition
Equals(Region) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class > Equals Method : Equals(Region) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Region _
) As Boolean
C#
public bool Equals(
   Def.Region other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class > Equals Method : Equals(Object) Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


IsApplicable Method

[image]
ActiveReports 19 .NET Edition
IsApplicable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : IsApplicable Method

other

Glossary Item Box

Check if the region is applicable to the other region.

Syntax

Visual Basic (Declaration)
Public Function IsApplicable( _
   ByVal other As Def.Region _
) As Boolean
C#
public bool IsApplicable(
   Def.Region other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


Def.Region Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Region Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Region Class

Glossary Item Box

For a list of all members of this type, see Def.Region members.

Public Fields

 | Name | Description
Public Field | Content | The content of the region.
Public Field | Filters | The filters defined for the region.
Public Field | Name | The name of the region.
Top

See Also

Reference

Def.Region Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Content Field

[image]
ActiveReports 19 .NET Edition
Content Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : Content Field

Glossary Item Box

The content of the region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Content As Def.Content
C#
public readonly Def.Content Content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


Filters Field

[image]
ActiveReports 19 .NET Edition
Filters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : Filters Field

Glossary Item Box

The filters defined for the region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Filters As Def.Filter()
C#
public readonly Def.Filter[] Filters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Region Class : Name Field

Glossary Item Box

The name of the region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Region Class
Def.Region Members


Def.Report Class

[image]
ActiveReports 19 .NET Edition
Def.Report Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Report Class

Glossary Item Box

Report data region definition

Object Model

Def.Report Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Report
   Inherits Def.Region
C#
public sealed class Def.Report : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.Report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Report Class Members

[image]
ActiveReports 19 .NET Edition
Def.Report Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Report Class

Glossary Item Box

The following tables list the members exposed by Def.Report.

Public Constructors

 | Name | Description
Public Constructor | Def.Report Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Top

See Also

Reference

Def.Report Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Report Constructor

[image]
ActiveReports 19 .NET Edition
Def.Report Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Report Class : Def.Report Constructor

Glossary Item Box

Overload List

Overload | Description
Def.Report Constructor(String,Content) | Creates new data query instance.
Def.Report Constructor(Content) | Creates new data query instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Class
Def.Report Members


Def.Report Constructor(String,Content)

[image]
ActiveReports 19 .NET Edition
Def.Report Constructor(String,Content)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Report Class > Def.Report Constructor : Def.Report Constructor(String,Content)

name
content

Glossary Item Box

Creates new data query instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal content As Def.Content _
)
C#
public Def.Report(
   string name,
   Def.Content content
)

Parameters

name
content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Class
Def.Report Members
Overload List


Def.Report Constructor(Content)

[image]
ActiveReports 19 .NET Edition
Def.Report Constructor(Content)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Report Class > Def.Report Constructor : Def.Report Constructor(Content)

content

Glossary Item Box

Creates new data query instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal content As Def.Content _
)
C#
public Def.Report(
   Def.Content content
)

Parameters

content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Class
Def.Report Members
Overload List


Def.Report Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Report Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Report Class

Glossary Item Box

For a list of all members of this type, see Def.Report members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Top

See Also

Reference

Def.Report Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Report Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Report) | Indicates whether the current object is equal to another object of the same type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Class
Def.Report Members


Equals(Report) Method

[image]
ActiveReports 19 .NET Edition
Equals(Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Report Class > Equals Method : Equals(Report) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Report _
) As Boolean
C#
public bool Equals(
   Def.Report other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Report Class
Def.Report Members
Overload List


Def.SimpleRegion Class

[image]
ActiveReports 19 .NET Edition
Def.SimpleRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.SimpleRegion Class

Glossary Item Box

Simple data region definition

Object Model

Def.SimpleRegion Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.SimpleRegion
   Inherits Def.Region
C#
public sealed class Def.SimpleRegion : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.SimpleRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.SimpleRegion Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.SimpleRegion Class Members

[image]
ActiveReports 19 .NET Edition
Def.SimpleRegion Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.SimpleRegion Class

Glossary Item Box

The following tables list the members exposed by Def.SimpleRegion.

Public Constructors

 | Name | Description
Public Constructor | Def.SimpleRegion Constructor | Initializes base region fields.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified SimpleRegion object is equal to the current object.
Top

See Also

Reference

Def.SimpleRegion Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.SimpleRegion Constructor

[image]
ActiveReports 19 .NET Edition
Def.SimpleRegion Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.SimpleRegion Class : Def.SimpleRegion Constructor

name
filters
content

Glossary Item Box

Initializes base region fields.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal filters As IEnumerable(Of Def.Filter), _
   ByVal content As Def.Content _
)
C#
public Def.SimpleRegion(
   string name,
   IEnumerable<Def.Filter> filters,
   Def.Content content
)

Parameters

name
filters
content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.SimpleRegion Class
Def.SimpleRegion Members


Def.SimpleRegion Class Methods

[image]
ActiveReports 19 .NET Edition
Def.SimpleRegion Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.SimpleRegion Class

Glossary Item Box

For a list of all members of this type, see Def.SimpleRegion members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified SimpleRegion object is equal to the current object.
Top

See Also

Reference

Def.SimpleRegion Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.SimpleRegion Class : Equals Method

Glossary Item Box

Determines whether the specified SimpleRegion object is equal to the current object.

Overload List

Overload | Description
Equals(SimpleRegion) | Determines whether the specified SimpleRegion object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.SimpleRegion Class
Def.SimpleRegion Members


Equals(SimpleRegion) Method

[image]
ActiveReports 19 .NET Edition
Equals(SimpleRegion) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.SimpleRegion Class > Equals Method : Equals(SimpleRegion) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified SimpleRegion object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.SimpleRegion _
) As Boolean
C#
public bool Equals(
   Def.SimpleRegion other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.SimpleRegion Class
Def.SimpleRegion Members
Overload List


Def.Sort Class

[image]
ActiveReports 19 .NET Edition
Def.Sort Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Sort Class

Glossary Item Box

Specifies how to sort members.

Object Model

Def.Sort Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Sort
C#
public sealed class Def.Sort

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Sort Class Members

[image]
ActiveReports 19 .NET Edition
Def.Sort Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Sort Class

Glossary Item Box

The following tables list the members exposed by Def.Sort.

Public Constructors

 | Name | Description
Public Constructor | Def.Sort Constructor | Initializes a new instance of the Def.Sort class.
Top

Public Properties

 | Name | Description
Public Property | Direction | Returns a value that is used to determine which direction data should be sorted by according to this object's sort expression.
Public Property | Expression | Gets the sort expression.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Sort Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Sort Constructor

[image]
ActiveReports 19 .NET Edition
Def.Sort Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class : Def.Sort Constructor

expression
The sort expression.
direction
The sort direction.

Glossary Item Box

Initializes a new instance of the Def.Sort class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As ExpressionInfo, _
   ByVal direction As Def.SortDirection _
)
C#
public Def.Sort(
   ExpressionInfo expression,
   Def.SortDirection direction
)

Parameters

expression
The sort expression.
direction
The sort direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members


Def.Sort Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Sort Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Sort Class

Glossary Item Box

For a list of all members of this type, see Def.Sort members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

Def.Sort Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Sort) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members


Equals(Sort) Method

[image]
ActiveReports 19 .NET Edition
Equals(Sort) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class > Equals Method : Equals(Sort) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Sort _
) As Boolean
C#
public bool Equals(
   Def.Sort other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class > Equals Method : Equals(Object) Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members


Def.Sort Class Properties

[image]
ActiveReports 19 .NET Edition
Def.Sort Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Sort Class

Glossary Item Box

For a list of all members of this type, see Def.Sort members.

Public Properties

 | Name | Description
Public Property | Direction | Returns a value that is used to determine which direction data should be sorted by according to this object's sort expression.
Public Property | Expression | Gets the sort expression.
Top

See Also

Reference

Def.Sort Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class : Direction Property

Glossary Item Box

Returns a value that is used to determine which direction data should be sorted by according to this object's sort expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Direction As Def.SortDirection
C#
public Def.SortDirection Direction {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members


Expression Property

[image]
ActiveReports 19 .NET Edition
Expression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Sort Class : Expression Property

Glossary Item Box

Gets the sort expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Expression As ExpressionInfo
C#
public ExpressionInfo Expression {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Sort Class
Def.Sort Members


Def.Subreport Class

[image]
ActiveReports 19 .NET Edition
Def.Subreport Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Subreport Class

Glossary Item Box

Subreport definition

Object Model

Def.Subreport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Subreport
   Inherits Def.Region
C#
public sealed class Def.Subreport : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.Subreport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Subreport Class Members

[image]
ActiveReports 19 .NET Edition
Def.Subreport Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Subreport Class

Glossary Item Box

The following tables list the members exposed by Def.Subreport.

Public Constructors

 | Name | Description
Public Constructor | Def.Subreport Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Parameters | Sub-query parameters.
Public Field | Report | Query definition.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Overridden. Serves as the default hash function.
Top

See Also

Reference

Def.Subreport Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Subreport Constructor

[image]
ActiveReports 19 .NET Edition
Def.Subreport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class : Def.Subreport Constructor

Glossary Item Box

Overload List

Overload | Description
Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,IEnumerable<ExpressionInfo>) | Initializes new sub-query (Def.Subreport) instance.
Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,Content) | Initializes new sub-query (Def.Subreport) instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members


Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,IEnumerable<ExpressionInfo>)

[image]
ActiveReports 19 .NET Edition
Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,IEnumerable<ExpressionInfo>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class > Def.Subreport Constructor : Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,IEnumerable<ExpressionInfo>)

name
report
parameters
fields

Glossary Item Box

Initializes new sub-query (Def.Subreport) instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal report As Def.Report, _
   ByVal parameters As IEnumerable(Of Def.Parameter), _
   ByVal fields As IEnumerable(Of ExpressionInfo) _
)
C#
public Def.Subreport(
   string name,
   Def.Report report,
   IEnumerable<Def.Parameter> parameters,
   IEnumerable<ExpressionInfo> fields
)

Parameters

name
report
parameters
fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members
Overload List


Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,Content)

[image]
ActiveReports 19 .NET Edition
Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,Content)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class > Def.Subreport Constructor : Def.Subreport Constructor(String,Report,IEnumerable<Parameter>,Content)

name
report
parameters
content

Glossary Item Box

Initializes new sub-query (Def.Subreport) instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal report As Def.Report, _
   ByVal parameters As IEnumerable(Of Def.Parameter), _
   ByVal content As Def.Content _
)
C#
public Def.Subreport(
   string name,
   Def.Report report,
   IEnumerable<Def.Parameter> parameters,
   Def.Content content
)

Parameters

name
report
parameters
content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members
Overload List


Def.Subreport Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Subreport Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Subreport Class

Glossary Item Box

For a list of all members of this type, see Def.Subreport members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Overridden. Serves as the default hash function.
Top

See Also

Reference

Def.Subreport Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(Subreport) | Indicates whether the current object is equal to another object of the same type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members


Equals(Subreport) Method

[image]
ActiveReports 19 .NET Edition
Equals(Subreport) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class > Equals Method : Equals(Subreport) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Subreport _
) As Boolean
C#
public bool Equals(
   Def.Subreport other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members


Def.Subreport Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Subreport Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Subreport Class

Glossary Item Box

For a list of all members of this type, see Def.Subreport members.

Public Fields

 | Name | Description
Public Field | Parameters | Sub-query parameters.
Public Field | Report | Query definition.
Top

See Also

Reference

Def.Subreport Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Parameters Field

[image]
ActiveReports 19 .NET Edition
Parameters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class : Parameters Field

Glossary Item Box

Sub-query parameters.

Syntax

Visual Basic (Declaration)
Public ReadOnly Parameters As Def.Parameter()
C#
public readonly Def.Parameter[] Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members


Report Field

[image]
ActiveReports 19 .NET Edition
Report Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Subreport Class : Report Field

Glossary Item Box

Query definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Report As Def.Report
C#
public readonly Def.Report Report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Subreport Class
Def.Subreport Members


Def.Tablix Class

[image]
ActiveReports 19 .NET Edition
Def.Tablix Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Tablix Class

Glossary Item Box

Tablix data region definition

Object Model

Def.Tablix Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.Tablix
   Inherits Def.Region
C#
public sealed class Def.Tablix : Def.Region

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.Tablix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Tablix Class Members

[image]
ActiveReports 19 .NET Edition
Def.Tablix Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Tablix Class

Glossary Item Box

The following tables list the members exposed by Def.Tablix.

Public Constructors

 | Name | Description
Public Constructor | Def.Tablix Constructor | Tablix constructor
Top

Public Fields

 | Name | Description
Public Field | Body | Body
Public Field | ColumnMembers | Column Members
Public Field | RowMembers | Row Members
Public Field | Sorts | Sorting definitions.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified Tablix object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.Tablix Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.Tablix Constructor

[image]
ActiveReports 19 .NET Edition
Def.Tablix Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : Def.Tablix Constructor

name
filters
columnMembers
rowMembers
content
body
sorts

Glossary Item Box

Tablix constructor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal filters As IEnumerable(Of Def.Filter), _
   ByVal columnMembers As IEnumerable(Of Def.TablixMember), _
   ByVal rowMembers As IEnumerable(Of Def.TablixMember), _
   ByVal content As Def.Content, _
   ByVal body As IEnumerable(Of Def.TablixRow), _
   Optional ByVal sorts As IEnumerable(Of Def.Sort) _
)
C#
public Def.Tablix(
   string name,
   IEnumerable<Def.Filter> filters,
   IEnumerable<Def.TablixMember> columnMembers,
   IEnumerable<Def.TablixMember> rowMembers,
   Def.Content content,
   IEnumerable<Def.TablixRow> body,
   IEnumerable<Def.Sort> sorts
)

Parameters

name
filters
columnMembers
rowMembers
content
body
sorts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


Def.Tablix Class Methods

[image]
ActiveReports 19 .NET Edition
Def.Tablix Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Tablix Class

Glossary Item Box

For a list of all members of this type, see Def.Tablix members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified Tablix object is equal to the current object.
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

Def.Tablix Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : Equals Method

Glossary Item Box

Determines whether the specified Tablix object is equal to the current object.

Overload List

Overload | Description
Equals(Tablix) | Determines whether the specified Tablix object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


Equals(Tablix) Method

[image]
ActiveReports 19 .NET Edition
Equals(Tablix) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class > Equals Method : Equals(Tablix) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified Tablix object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.Tablix _
) As Boolean
C#
public bool Equals(
   Def.Tablix other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


Def.Tablix Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Tablix Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Tablix Class

Glossary Item Box

For a list of all members of this type, see Def.Tablix members.

Public Fields

 | Name | Description
Public Field | Body | Body
Public Field | ColumnMembers | Column Members
Public Field | RowMembers | Row Members
Public Field | Sorts | Sorting definitions.
Top

See Also

Reference

Def.Tablix Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Body Field

[image]
ActiveReports 19 .NET Edition
Body Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : Body Field

Glossary Item Box

Body

Syntax

Visual Basic (Declaration)
Public ReadOnly Body As Def.TablixRow()
C#
public readonly Def.TablixRow[] Body

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


ColumnMembers Field

[image]
ActiveReports 19 .NET Edition
ColumnMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : ColumnMembers Field

Glossary Item Box

Column Members

Syntax

Visual Basic (Declaration)
Public ReadOnly ColumnMembers As Def.TablixMember()
C#
public readonly Def.TablixMember[] ColumnMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


RowMembers Field

[image]
ActiveReports 19 .NET Edition
RowMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : RowMembers Field

Glossary Item Box

Row Members

Syntax

Visual Basic (Declaration)
Public ReadOnly RowMembers As Def.TablixMember()
C#
public readonly Def.TablixMember[] RowMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


Sorts Field

[image]
ActiveReports 19 .NET Edition
Sorts Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.Tablix Class : Sorts Field

Glossary Item Box

Sorting definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Sorts As Def.Sort()
C#
public readonly Def.Sort[] Sorts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.Tablix Class
Def.Tablix Members


Def.TablixMember Class

[image]
ActiveReports 19 .NET Edition
Def.TablixMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixMember Class

Glossary Item Box

Tablix member data definition

Object Model

Def.TablixMember Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.TablixMember
C#
public sealed class Def.TablixMember

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.TablixMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.TablixMember Class Members

[image]
ActiveReports 19 .NET Edition
Def.TablixMember Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixMember Class

Glossary Item Box

The following tables list the members exposed by Def.TablixMember.

Public Constructors

 | Name | Description
Public Constructor | Def.TablixMember Constructor | Initializes a new instance of the Def.TablixMember class with the specified group, sorts, header and members
Top

Public Fields

 | Name | Description
Public Field | Group | Grouping defintion
Public Field | Header | Header
Public Field | Members | Members
Public Field | Sort | Sorting definitions.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified TablixMember object is equal to the current object.
Public Method | GetHashCode | Generates a HashCode for this expression.
Top

See Also

Reference

Def.TablixMember Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.TablixMember Constructor

[image]
ActiveReports 19 .NET Edition
Def.TablixMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Def.TablixMember Constructor

group
group
sort
sorts
header
header
members
members

Glossary Item Box

Initializes a new instance of the Def.TablixMember class with the specified group, sorts, header and members

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal group As Def.Group, _
   ByVal sort As IEnumerable(Of Def.Sort), _
   ByVal header As Def.Content, _
   ByVal members As IEnumerable(Of Def.TablixMember) _
)
C#
public Def.TablixMember(
   Def.Group group,
   IEnumerable<Def.Sort> sort,
   Def.Content header,
   IEnumerable<Def.TablixMember> members
)

Parameters

group
group
sort
sorts
header
header
members
members

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Def.TablixMember Class Methods

[image]
ActiveReports 19 .NET Edition
Def.TablixMember Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixMember Class

Glossary Item Box

For a list of all members of this type, see Def.TablixMember members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified TablixMember object is equal to the current object.
Public Method | GetHashCode | Generates a HashCode for this expression.
Top

See Also

Reference

Def.TablixMember Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Equals Method

Glossary Item Box

Determines whether the specified TablixMember object is equal to the current object.

Overload List

Overload | Description
Equals(TablixMember) | Determines whether the specified TablixMember object is equal to the current object.
Equals(Object) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Equals(TablixMember) Method

[image]
ActiveReports 19 .NET Edition
Equals(TablixMember) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class > Equals Method : Equals(TablixMember) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified TablixMember object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.TablixMember _
) As Boolean
C#
public bool Equals(
   Def.TablixMember other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class > Equals Method : Equals(Object) Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Def.TablixMember Class Fields

[image]
ActiveReports 19 .NET Edition
Def.TablixMember Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixMember Class

Glossary Item Box

For a list of all members of this type, see Def.TablixMember members.

Public Fields

 | Name | Description
Public Field | Group | Grouping defintion
Public Field | Header | Header
Public Field | Members | Members
Public Field | Sort | Sorting definitions.
Top

See Also

Reference

Def.TablixMember Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Group Field

[image]
ActiveReports 19 .NET Edition
Group Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Group Field

Glossary Item Box

Grouping defintion

Syntax

Visual Basic (Declaration)
Public ReadOnly Group As Def.Group
C#
public readonly Def.Group Group

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Header Field

[image]
ActiveReports 19 .NET Edition
Header Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Header Field

Glossary Item Box

Header

Syntax

Visual Basic (Declaration)
Public ReadOnly Header As Def.Content
C#
public readonly Def.Content Header

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Members Field

[image]
ActiveReports 19 .NET Edition
Members Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Members Field

Glossary Item Box

Members

Syntax

Visual Basic (Declaration)
Public ReadOnly Members As Def.TablixMember()
C#
public readonly Def.TablixMember[] Members

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Sort Field

[image]
ActiveReports 19 .NET Edition
Sort Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixMember Class : Sort Field

Glossary Item Box

Sorting definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Sort As Def.Sort()
C#
public readonly Def.Sort[] Sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixMember Class
Def.TablixMember Members


Def.TablixRow Class

[image]
ActiveReports 19 .NET Edition
Def.TablixRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixRow Class

Glossary Item Box

Tablix row data definition

Object Model

Def.TablixRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Def.TablixRow
C#
public sealed class Def.TablixRow

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Def.TablixRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.TablixRow Class Members

[image]
ActiveReports 19 .NET Edition
Def.TablixRow Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixRow Class

Glossary Item Box

The following tables list the members exposed by Def.TablixRow.

Public Constructors

 | Name | Description
Public Constructor | Def.TablixRow Constructor | Initializes a new instance of the Def.TablixRow class with the specified cells
Top

Public Fields

 | Name | Description
Public Field | Cells | Row cells definitions.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified TablixRow object is equal to the current object.
Public Method | GetHashCode | Generates a HashCode for this expression.
Top

See Also

Reference

Def.TablixRow Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.TablixRow Constructor

[image]
ActiveReports 19 .NET Edition
Def.TablixRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class : Def.TablixRow Constructor

cells
cells

Glossary Item Box

Initializes a new instance of the Def.TablixRow class with the specified cells

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cells As IEnumerable(Of Def.Content) _
)
C#
public Def.TablixRow(
   IEnumerable<Def.Content> cells
)

Parameters

cells
cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members


Def.TablixRow Class Methods

[image]
ActiveReports 19 .NET Edition
Def.TablixRow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixRow Class

Glossary Item Box

For a list of all members of this type, see Def.TablixRow members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified TablixRow object is equal to the current object.
Public Method | GetHashCode | Generates a HashCode for this expression.
Top

See Also

Reference

Def.TablixRow Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class : Equals Method

Glossary Item Box

Determines whether the specified TablixRow object is equal to the current object.

Overload List

Overload | Description
Equals(TablixRow) | Determines whether the specified TablixRow object is equal to the current object.
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members


Equals(TablixRow) Method

[image]
ActiveReports 19 .NET Edition
Equals(TablixRow) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class > Equals Method : Equals(TablixRow) Method

other
The object to compare with the current object.

Glossary Item Box

Determines whether the specified TablixRow object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Def.TablixRow _
) As Boolean
C#
public bool Equals(
   Def.TablixRow other
)

Parameters

other
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class > Equals Method : Equals(Object) Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members


Def.TablixRow Class Fields

[image]
ActiveReports 19 .NET Edition
Def.TablixRow Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.TablixRow Class

Glossary Item Box

For a list of all members of this type, see Def.TablixRow members.

Public Fields

 | Name | Description
Public Field | Cells | Row cells definitions.
Top

See Also

Reference

Def.TablixRow Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Cells Field

[image]
ActiveReports 19 .NET Edition
Cells Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Def.TablixRow Class : Cells Field

Glossary Item Box

Row cells definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Cells As Def.Content()
C#
public readonly Def.Content[] Cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Def.TablixRow Class
Def.TablixRow Members


GetAggregateDataProviderArgs Class

[image]
ActiveReports 19 .NET Edition
GetAggregateDataProviderArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetAggregateDataProviderArgs Class

Glossary Item Box

Contains information which is necessary to get the IAggregateDataProvider object.

Object Model

GetAggregateDataProviderArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GetAggregateDataProviderArgs
C#
public sealed class GetAggregateDataProviderArgs

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.GetAggregateDataProviderArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetAggregateDataProviderArgs Members
GrapeCity.Enterprise.Data.DataEngine Namespace


GetAggregateDataProviderArgs Class Members

[image]
ActiveReports 19 .NET Edition
GetAggregateDataProviderArgs Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetAggregateDataProviderArgs Class

Glossary Item Box

The following tables list the members exposed by GetAggregateDataProviderArgs.

Public Fields

 | Name | Description
Public Field | Name | The data set name for which aggregate data provider is requested.
Top

See Also

Reference

GetAggregateDataProviderArgs Class
GrapeCity.Enterprise.Data.DataEngine Namespace


GetAggregateDataProviderArgs Class Fields

[image]
ActiveReports 19 .NET Edition
GetAggregateDataProviderArgs Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetAggregateDataProviderArgs Class

Glossary Item Box

For a list of all members of this type, see GetAggregateDataProviderArgs members.

Public Fields

 | Name | Description
Public Field | Name | The data set name for which aggregate data provider is requested.
Top

See Also

Reference

GetAggregateDataProviderArgs Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetAggregateDataProviderArgs Class : Name Field

Glossary Item Box

The data set name for which aggregate data provider is requested.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetAggregateDataProviderArgs Class
GetAggregateDataProviderArgs Members


GetRecordSetArgs Class

[image]
ActiveReports 19 .NET Edition
GetRecordSetArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetRecordSetArgs Class

Glossary Item Box

Contains information which is necessary to provide appropriate data set.

Object Model

GetRecordSetArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GetRecordSetArgs
C#
public sealed class GetRecordSetArgs

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.GetRecordSetArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Members
GrapeCity.Enterprise.Data.DataEngine Namespace


GetRecordSetArgs Class Members

[image]
ActiveReports 19 .NET Edition
GetRecordSetArgs Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetRecordSetArgs Class

Glossary Item Box

The following tables list the members exposed by GetRecordSetArgs.

Public Constructors

 | Name | Description
Public Constructor | GetRecordSetArgs Constructor | Creates new GetRecordSetArgs object.
Top

Public Fields

 | Name | Description
Public Field | Name | The name of the requested data set.
Public Field | Parameters | Evaluated parameters of the requested data set.
Public Field | ParentDataSetName | Current data set name.
Public Field | ParentRecordSet | Current record set (which is parent for the requested data set).
Top

See Also

Reference

GetRecordSetArgs Class
GrapeCity.Enterprise.Data.DataEngine Namespace


GetRecordSetArgs Constructor

[image]
ActiveReports 19 .NET Edition
GetRecordSetArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetRecordSetArgs Class : GetRecordSetArgs Constructor

name
parameters
parentRecordSet
parentDataSetName

Glossary Item Box

Creates new GetRecordSetArgs object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal parameters() As DataParameter, _
   ByVal parentRecordSet As RecordSet, _
   ByVal parentDataSetName As String _
)
C#
public GetRecordSetArgs(
   string name,
   DataParameter[] parameters,
   RecordSet parentRecordSet,
   string parentDataSetName
)

Parameters

name
parameters
parentRecordSet
parentDataSetName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Class
GetRecordSetArgs Members


GetRecordSetArgs Class Fields

[image]
ActiveReports 19 .NET Edition
GetRecordSetArgs Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : GetRecordSetArgs Class

Glossary Item Box

For a list of all members of this type, see GetRecordSetArgs members.

Public Fields

 | Name | Description
Public Field | Name | The name of the requested data set.
Public Field | Parameters | Evaluated parameters of the requested data set.
Public Field | ParentDataSetName | Current data set name.
Public Field | ParentRecordSet | Current record set (which is parent for the requested data set).
Top

See Also

Reference

GetRecordSetArgs Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetRecordSetArgs Class : Name Field

Glossary Item Box

The name of the requested data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Class
GetRecordSetArgs Members


Parameters Field

[image]
ActiveReports 19 .NET Edition
Parameters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetRecordSetArgs Class : Parameters Field

Glossary Item Box

Evaluated parameters of the requested data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Parameters As DataParameter()
C#
public readonly DataParameter[] Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Class
GetRecordSetArgs Members


ParentDataSetName Field

[image]
ActiveReports 19 .NET Edition
ParentDataSetName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetRecordSetArgs Class : ParentDataSetName Field

Glossary Item Box

Current data set name.

Syntax

Visual Basic (Declaration)
Public ReadOnly ParentDataSetName As String
C#
public readonly string ParentDataSetName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Class
GetRecordSetArgs Members


ParentRecordSet Field

[image]
ActiveReports 19 .NET Edition
ParentRecordSet Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > GetRecordSetArgs Class : ParentRecordSet Field

Glossary Item Box

Current record set (which is parent for the requested data set).

Syntax

Visual Basic (Declaration)
Public ReadOnly ParentRecordSet As RecordSet
C#
public readonly RecordSet ParentRecordSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetRecordSetArgs Class
GetRecordSetArgs Members


InteractiveSortState Class

[image]
ActiveReports 19 .NET Edition
InteractiveSortState Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSortState Class

Glossary Item Box

Dictionary with state of all interactive sorts.

Object Model

InteractiveSortState Class

Syntax

Visual Basic (Declaration)
Public Class InteractiveSortState
   Inherits System.Collections.Generic.Dictionary(Of Integer,InteractiveSort())
C#
public class InteractiveSortState : System.Collections.Generic.Dictionary<int,InteractiveSort[]>

Inheritance Hierarchy

System.Object
System.Collections.Generic.Dictionary<TKey,TValue>
GrapeCity.Enterprise.Data.DataEngine.InteractiveSortState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Members
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveSortState Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveSortState Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSortState Class

Glossary Item Box

The following tables list the members exposed by InteractiveSortState.

Public Constructors

 | Name | Description
Public Constructor | InteractiveSortState Constructor |
Top

Public Methods

 | Name | Description
Public Method | Get | Gets array InteractiveSort by key
Public Method | Set | Overloaded. Adds an array InteractiveSort to the dictionary by key
Top

See Also

Reference

InteractiveSortState Class
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveSortState Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveSortState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : InteractiveSortState Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InteractiveSortState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


InteractiveSortState Class Methods

[image]
ActiveReports 19 .NET Edition
InteractiveSortState Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSortState Class

Glossary Item Box

For a list of all members of this type, see InteractiveSortState members.

Public Methods

 | Name | Description
Public Method | Get | Gets array InteractiveSort by key
Public Method | Set | Overloaded. Adds an array InteractiveSort to the dictionary by key
Top

See Also

Reference

InteractiveSortState Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Get Method

[image]
ActiveReports 19 .NET Edition
Get Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Get Method

scopeId

Glossary Item Box

Gets array InteractiveSort by key

Syntax

Visual Basic (Declaration)
Public Function Get( _
   ByVal scopeId As Integer _
) As InteractiveSort()
C#
public InteractiveSort[] Get(
   int scopeId
)

Parameters

scopeId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Set Method

[image]
ActiveReports 19 .NET Edition
Set Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Set Method

Glossary Item Box

Adds an array InteractiveSort to the dictionary by key

Overload List

Overload | Description
Set(Int32,InteractiveSort[]) | Adds an array InteractiveSort to the dictionary by key
Set(Int32,InteractiveSort) | Adds an object InteractiveSort to the dictionary by key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Set(Int32,InteractiveSort[]) Method

[image]
ActiveReports 19 .NET Edition
Set(Int32,InteractiveSort[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class > Set Method : Set(Int32,InteractiveSort[]) Method

scopeId
sort

Glossary Item Box

Adds an array InteractiveSort to the dictionary by key

Syntax

Visual Basic (Declaration)
Public Overloads Sub Set( _
   ByVal scopeId As Integer, _
   ByVal sort() As InteractiveSort _
)
C#
public void Set(
   int scopeId,
   InteractiveSort[] sort
)

Parameters

scopeId
sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members
Overload List


Set(Int32,InteractiveSort) Method

[image]
ActiveReports 19 .NET Edition
Set(Int32,InteractiveSort) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class > Set Method : Set(Int32,InteractiveSort) Method

scopeId
sort

Glossary Item Box

Adds an object InteractiveSort to the dictionary by key

Syntax

Visual Basic (Declaration)
Public Overloads Sub Set( _
   ByVal scopeId As Integer, _
   ByVal sort As InteractiveSort _
)
C#
public void Set(
   int scopeId,
   InteractiveSort sort
)

Parameters

scopeId
sort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members
Overload List


InteractiveState Class

[image]
ActiveReports 19 .NET Edition
InteractiveState Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveState Class

Glossary Item Box

Represents the state of the interactive levers.

Object Model

InteractiveState Class

Syntax

Visual Basic (Declaration)
Public Class InteractiveState
C#
public class InteractiveState

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.InteractiveState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveState Members
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveState Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveState Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveState Class

Glossary Item Box

The following tables list the members exposed by InteractiveState.

Public Constructors

 | Name | Description
Public Constructor | InteractiveState Constructor |
Top

Public Properties

 | Name | Description
Public Property | Slicers | Slicers state.
Public Property | Sorting | Sorting state.
Top

See Also

Reference

InteractiveState Class
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveState Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveState Class : InteractiveState Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InteractiveState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveState Class
InteractiveState Members


InteractiveState Class Properties

[image]
ActiveReports 19 .NET Edition
InteractiveState Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveState Class

Glossary Item Box

For a list of all members of this type, see InteractiveState members.

Public Properties

 | Name | Description
Public Property | Slicers | Slicers state.
Public Property | Sorting | Sorting state.
Top

See Also

Reference

InteractiveState Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Slicers Property

[image]
ActiveReports 19 .NET Edition
Slicers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveState Class : Slicers Property

Glossary Item Box

Slicers state.

Syntax

Visual Basic (Declaration)
Public Property Slicers As SlicerState()
C#
public SlicerState[] Slicers {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveState Class
InteractiveState Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveState Class : Sorting Property

Glossary Item Box

Sorting state.

Syntax

Visual Basic (Declaration)
Public Property Sorting As InteractiveSortState
C#
public InteractiveSortState Sorting {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveState Class
InteractiveState Members


InvalidDefinitionException Class

[image]
ActiveReports 19 .NET Edition
InvalidDefinitionException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InvalidDefinitionException Class

Glossary Item Box

Raised when data query definition (filters, sorting, etc.) is not valid in specific scope.

Object Model

InvalidDefinitionException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidDefinitionException
   Inherits DataEngineException
C#
public class InvalidDefinitionException : DataEngineException

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.Enterprise.Data.DataEngine.DataEngineException
GrapeCity.Enterprise.Data.DataEngine.InvalidDefinitionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Members
GrapeCity.Enterprise.Data.DataEngine Namespace


InvalidDefinitionException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidDefinitionException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InvalidDefinitionException Class

Glossary Item Box

The following tables list the members exposed by InvalidDefinitionException.

See Also

Reference

InvalidDefinitionException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Record Class

[image]
ActiveReports 19 .NET Edition
Record Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Record Class

Glossary Item Box

Defines single data record.

Object Model

Record Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Record
C#
public sealed class Record

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Record

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Members
GrapeCity.Enterprise.Data.DataEngine Namespace


Record Class Members

[image]
ActiveReports 19 .NET Edition
Record Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Record Class

Glossary Item Box

The following tables list the members exposed by Record.

Public Constructors

 | Name | Description
Public Constructor | Record Constructor | Initializes a new instance of the Record.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The Empty record instance.
Public Field | Index | The index of the record.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the record's fields count.
Public Property | Item | Overloaded. Gets the value of field specified by index.
Top

See Also

Reference

Record Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Record Constructor

[image]
ActiveReports 19 .NET Edition
Record Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Record Constructor

index
The index of the record.
fieldNames
The dictionary which maps field names to field indexes.
data
The list of record's fields values

Glossary Item Box

Initializes a new instance of the Record.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal index As Integer, _
   ByVal fieldNames As IDictionary(Of String,Integer), _
   ByVal data As IList(Of Variant) _
)
C#
public Record(
   int index,
   IDictionary<string,int> fieldNames,
   IList<Variant> data
)

Parameters

index
The index of the record.
fieldNames
The dictionary which maps field names to field indexes.
data
The list of record's fields values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


Record Class Properties

[image]
ActiveReports 19 .NET Edition
Record Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Record Class

Glossary Item Box

For a list of all members of this type, see Record members.

Public Properties

 | Name | Description
Public Property | Count | Gets the record's fields count.
Public Property | Item | Overloaded. Gets the value of field specified by index.
Top

See Also

Reference

Record Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Count Property

Glossary Item Box

Gets the record's fields count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Item Property

Glossary Item Box

Gets the value of field specified by index.

Overload List

Overload | Description
Item(Int32) | Gets the value of field specified by index.
Item(String) | Gets the value of field specified by name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class > Item Property : Item(Int32) Property

index
Index of field.

Glossary Item Box

Gets the value of field specified by index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Variant
C#
public Variant Item(
   int index
) {get;}

Parameters

index
Index of field.

Property Value

A GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant object representing record's field value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class > Item Property : Item(String) Property

name
Name of field.

Glossary Item Box

Gets the value of field specified by name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Variant
C#
public Variant Item(
   string name
) {get;}

Parameters

name
Name of field.

Property Value

A GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant object representing record's field value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members
Overload List


Record Class Fields

[image]
ActiveReports 19 .NET Edition
Record Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Record Class

Glossary Item Box

For a list of all members of this type, see Record members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The Empty record instance.
Public Field | Index | The index of the record.
Top

See Also

Reference

Record Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Empty Field

Glossary Item Box

The Empty record instance.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Record
C#
public static readonly Record Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


Index Field

[image]
ActiveReports 19 .NET Edition
Index Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Index Field

Glossary Item Box

The index of the record.

Syntax

Visual Basic (Declaration)
Public ReadOnly Index As Integer
C#
public readonly int Index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


RecordSet Class

[image]
ActiveReports 19 .NET Edition
RecordSet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSet Class

Glossary Item Box

Defines the source records collection.

Object Model

RecordSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RecordSet
C#
public sealed class RecordSet

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.RecordSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Members
GrapeCity.Enterprise.Data.DataEngine Namespace


RecordSet Class Members

[image]
ActiveReports 19 .NET Edition
RecordSet Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSet Class

Glossary Item Box

The following tables list the members exposed by RecordSet.

Public Constructors

 | Name | Description
Public Constructor | RecordSet Constructor | Initializes a new instance of the RecordSet class
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents empty record set
Top

Public Properties

 | Name | Description
Public Property | AggregateDataProvider | Gets AggregateDataProvider connected with the record set (semantic reports).
Public Property | Records | Gets record collection
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the RecordSet.
Top

See Also

Reference

RecordSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


RecordSet Constructor

[image]
ActiveReports 19 .NET Edition
RecordSet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSet Class : RecordSet Constructor

records
The records collection.
getAggregateDataProvider
function returning AggregateDataProvider

Glossary Item Box

Initializes a new instance of the RecordSet class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal records As IEnumerable(Of Record), _
   Optional ByVal getAggregateDataProvider As Func(Of IAggregateDataProvider) _
)
C#
public RecordSet(
   IEnumerable<Record> records,
   Func<IAggregateDataProvider> getAggregateDataProvider
)

Parameters

records
The records collection.
getAggregateDataProvider
function returning AggregateDataProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Class
RecordSet Members


RecordSet Class Methods

[image]
ActiveReports 19 .NET Edition
RecordSet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSet Class

Glossary Item Box

For a list of all members of this type, see RecordSet members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the resources used by the RecordSet.
Top

See Also

Reference

RecordSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSet Class : Dispose Method

Glossary Item Box

Releases the resources used by the RecordSet.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Class
RecordSet Members


RecordSet Class Properties

[image]
ActiveReports 19 .NET Edition
RecordSet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSet Class

Glossary Item Box

For a list of all members of this type, see RecordSet members.

Public Properties

 | Name | Description
Public Property | AggregateDataProvider | Gets AggregateDataProvider connected with the record set (semantic reports).
Public Property | Records | Gets record collection
Top

See Also

Reference

RecordSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


AggregateDataProvider Property

[image]
ActiveReports 19 .NET Edition
AggregateDataProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSet Class : AggregateDataProvider Property

Glossary Item Box

Gets AggregateDataProvider connected with the record set (semantic reports).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AggregateDataProvider As IAggregateDataProvider
C#
public IAggregateDataProvider AggregateDataProvider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Class
RecordSet Members


Records Property

[image]
ActiveReports 19 .NET Edition
Records Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSet Class : Records Property

Glossary Item Box

Gets record collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Records As IEnumerable(Of Record)
C#
public IEnumerable<Record> Records {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Class
RecordSet Members


RecordSet Class Fields

[image]
ActiveReports 19 .NET Edition
RecordSet Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSet Class

Glossary Item Box

For a list of all members of this type, see RecordSet members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents empty record set
Top

See Also

Reference

RecordSet Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSet Class : Empty Field

Glossary Item Box

Represents empty record set

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As RecordSet
C#
public static readonly RecordSet Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSet Class
RecordSet Members


RecordSetProvider Class

[image]
ActiveReports 19 .NET Edition
RecordSetProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSetProvider Class

Glossary Item Box

Defines report scope.

Object Model

RecordSetProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RecordSetProvider
C#
public sealed class RecordSetProvider

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.RecordSetProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSetProvider Members
GrapeCity.Enterprise.Data.DataEngine Namespace


RecordSetProvider Class Members

[image]
ActiveReports 19 .NET Edition
RecordSetProvider Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSetProvider Class

Glossary Item Box

The following tables list the members exposed by RecordSetProvider.

Public Properties

 | Name | Description
Public Property | Data | Gets a recordset
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new instance of the RecordSetProvider class
Public Method | Dispose | Releases the resources used by the RecordSetProvider.
Public Method | GetAggregateDataProvider | Returns GrapeCity.Enterprise.Data.DataEngine.Aggregates.IAggregateDataProvider object which describes data set fields of semantic data provider.
Top

See Also

Reference

RecordSetProvider Class
GrapeCity.Enterprise.Data.DataEngine Namespace


RecordSetProvider Class Methods

[image]
ActiveReports 19 .NET Edition
RecordSetProvider Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSetProvider Class

Glossary Item Box

For a list of all members of this type, see RecordSetProvider members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new instance of the RecordSetProvider class
Public Method | Dispose | Releases the resources used by the RecordSetProvider.
Public Method | GetAggregateDataProvider | Returns GrapeCity.Enterprise.Data.DataEngine.Aggregates.IAggregateDataProvider object which describes data set fields of semantic data provider.
Top

See Also

Reference

RecordSetProvider Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSetProvider Class : Create Method

getDataSet
A function that returns a recordset for the specified dataset.
rootData
An RecordSet object represents set of records of the dataset.
agg
The function that returns aggregate data provider for the specified data set.

Glossary Item Box

Creates a new instance of the RecordSetProvider class

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal getDataSet As Func(Of GetRecordSetArgs,RecordSet), _
   Optional ByVal rootData As RecordSet, _
   Optional ByVal agg As Func(Of GetAggregateDataProviderArgs,IAggregateDataProvider) _
) As RecordSetProvider
C#
public static RecordSetProvider Create(
   Func<GetRecordSetArgs,RecordSet> getDataSet,
   RecordSet rootData,
   Func<GetAggregateDataProviderArgs,IAggregateDataProvider> agg
)

Parameters

getDataSet
A function that returns a recordset for the specified dataset.
rootData
An RecordSet object represents set of records of the dataset.
agg
The function that returns aggregate data provider for the specified data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSetProvider Class
RecordSetProvider Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSetProvider Class : Dispose Method

Glossary Item Box

Releases the resources used by the RecordSetProvider.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSetProvider Class
RecordSetProvider Members


GetAggregateDataProvider Method

[image]
ActiveReports 19 .NET Edition
GetAggregateDataProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSetProvider Class : GetAggregateDataProvider Method

dataSetName

Glossary Item Box

Returns GrapeCity.Enterprise.Data.DataEngine.Aggregates.IAggregateDataProvider object which describes data set fields of semantic data provider.

Syntax

Visual Basic (Declaration)
Public Function GetAggregateDataProvider( _
   ByVal dataSetName As String _
) As IAggregateDataProvider
C#
public IAggregateDataProvider GetAggregateDataProvider(
   string dataSetName
)

Parameters

dataSetName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSetProvider Class
RecordSetProvider Members


RecordSetProvider Class Properties

[image]
ActiveReports 19 .NET Edition
RecordSetProvider Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : RecordSetProvider Class

Glossary Item Box

For a list of all members of this type, see RecordSetProvider members.

Public Properties

 | Name | Description
Public Property | Data | Gets a recordset
Top

See Also

Reference

RecordSetProvider Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > RecordSetProvider Class : Data Property

Glossary Item Box

Gets a recordset

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As RecordSet
C#
public RecordSet Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordSetProvider Class
RecordSetProvider Members


ReportContext Class

[image]
ActiveReports 19 .NET Edition
ReportContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : ReportContext Class

Glossary Item Box

Represents the context for the data query execution.

Object Model

ReportContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportContext
C#
public sealed class ReportContext

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.ReportContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportContext Members
GrapeCity.Enterprise.Data.DataEngine Namespace


ReportContext Class Members

[image]
ActiveReports 19 .NET Edition
ReportContext Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : ReportContext Class

Glossary Item Box

The following tables list the members exposed by ReportContext.

Public Constructors

 | Name | Description
Public Constructor | ReportContext Constructor | Creates new instance if ReportContext
Top

Public Fields

 | Name | Description
Public Field | DataSets | Data set provider.
Public Field | ExpressionContext | Expression evaluation context.
Top

See Also

Reference

ReportContext Class
GrapeCity.Enterprise.Data.DataEngine Namespace


ReportContext Constructor

[image]
ActiveReports 19 .NET Edition
ReportContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > ReportContext Class : ReportContext Constructor

dataSets
expressionContext

Glossary Item Box

Creates new instance if ReportContext

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSets As RecordSetProvider, _
   Optional ByVal expressionContext As IExpressionContext _
)
C#
public ReportContext(
   RecordSetProvider dataSets,
   IExpressionContext expressionContext
)

Parameters

dataSets
expressionContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportContext Class
ReportContext Members


ReportContext Class Fields

[image]
ActiveReports 19 .NET Edition
ReportContext Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : ReportContext Class

Glossary Item Box

For a list of all members of this type, see ReportContext members.

Public Fields

 | Name | Description
Public Field | DataSets | Data set provider.
Public Field | ExpressionContext | Expression evaluation context.
Top

See Also

Reference

ReportContext Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataSets Field

[image]
ActiveReports 19 .NET Edition
DataSets Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > ReportContext Class : DataSets Field

Glossary Item Box

Data set provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly DataSets As RecordSetProvider
C#
public readonly RecordSetProvider DataSets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportContext Class
ReportContext Members


ExpressionContext Field

[image]
ActiveReports 19 .NET Edition
ExpressionContext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > ReportContext Class : ExpressionContext Field

Glossary Item Box

Expression evaluation context.

Syntax

Visual Basic (Declaration)
Public ReadOnly ExpressionContext As IExpressionContext
C#
public readonly IExpressionContext ExpressionContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportContext Class
ReportContext Members


Def.FilterOperator Enumeration

[image]
ActiveReports 19 .NET Edition
Def.FilterOperator Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.FilterOperator Enumeration

Glossary Item Box

Specifies the available filter operators.

Syntax

Visual Basic (Declaration)
Public Enum Def.FilterOperator
   Inherits System.Enum
C#
public enum Def.FilterOperator : System.Enum

Members

Member | Description
Between | Checks if the value falls in a given range.
BetweenExclusive | Checks if the value does not fall in a given range, begin and end values are excluded.
BottomN | Last N items.
BottomPercent | Last % items.
Equal | Equality operator.
GreaterThan | '$gt;' comparison operator.
GreaterThanOrEqual | '$gt;=' comparison operator.
In | Checks for occurrences in the set operator.
LessThan | '$lt;' comparison operator.
LessThanOrEqual | '$lt;=' comparison operator.
Like | Wild-card comparison operator.
NotBetween | Checks if the value does not fall in a given range, begin and end values are included.
NotEqual | Non-equality operator.
NotLike | Wild-card comparison operator.
TopN | First N items.
TopPercent | First % items.

Remarks

See RDL specification for details.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.DataEngine.Def.FilterOperator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.DataEngine Namespace


Def.SortDirection Enumeration

[image]
ActiveReports 19 .NET Edition
Def.SortDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.SortDirection Enumeration

Glossary Item Box

Defines the directions in which data can be sorted.

Syntax

Visual Basic (Declaration)
Public Enum Def.SortDirection
   Inherits System.Enum
C#
public enum Def.SortDirection : System.Enum

Members

Member | Description
Ascending | Sorting should be in ascending order.
Descending | Sorting should be in descending order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.DataEngine.Def.SortDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.DataEngine Namespace


DataParameter Structure

[image]
ActiveReports 19 .NET Edition
DataParameter Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataParameter Structure

Glossary Item Box

Represents the data query parameter.

Object Model

DataParameter Structure

Syntax

Visual Basic (Declaration)
Public Structure DataParameter
   Inherits System.ValueType
C#
public struct DataParameter : System.ValueType

Remarks

This struct should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.DataParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataParameter Structure Members

[image]
ActiveReports 19 .NET Edition
DataParameter Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataParameter Structure

Glossary Item Box

The following tables list the members exposed by DataParameter.

Public Constructors

 | Name | Description
Public Constructor | DataParameter Constructor | Creates new DataParameter instance.
Top

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Returns the hash code for this instance.
Top

See Also

Reference

DataParameter Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


DataParameter Constructor

[image]
ActiveReports 19 .NET Edition
DataParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure : DataParameter Constructor

name
value

Glossary Item Box

Creates new DataParameter instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public DataParameter(
   string name,
   object value
)

Parameters

name
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members


DataParameter Structure Methods

[image]
ActiveReports 19 .NET Edition
DataParameter Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataParameter Structure

Glossary Item Box

For a list of all members of this type, see DataParameter members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Returns the hash code for this instance.
Top

See Also

Reference

DataParameter Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure : Equals Method

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Overload List

Overload | Description
Equals(DataParameter) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Indicates whether this instance and a specified object are equal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members


Equals(DataParameter) Method

[image]
ActiveReports 19 .NET Edition
Equals(DataParameter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure > Equals Method : Equals(DataParameter) Method

other
An object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As DataParameter _
) As Boolean
C#
public bool Equals(
   DataParameter other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure > Equals Method : Equals(Object) Method

obj
The object to compare with the current instance.

Glossary Item Box

Indicates whether this instance and a specified object are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current instance.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure : GetHashCode Method

Glossary Item Box

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members


DataParameter Structure Fields

[image]
ActiveReports 19 .NET Edition
DataParameter Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataParameter Structure

Glossary Item Box

For a list of all members of this type, see DataParameter members.

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value.
Top

See Also

Reference

DataParameter Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure : Name Field

Glossary Item Box

Parameter name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataParameter Structure : Value Field

Glossary Item Box

Parameter value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As Object
C#
public readonly object Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataParameter Structure
DataParameter Members


DataProcessor.Result Structure

[image]
ActiveReports 19 .NET Edition
DataProcessor.Result Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor.Result Structure

Glossary Item Box

Represents the result of data processing.

Object Model

DataProcessor.Result Structure

Syntax

Visual Basic (Declaration)
Public Structure DataProcessor.Result
   Inherits System.ValueType
C#
public struct DataProcessor.Result : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.DataProcessor.Result

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor.Result Members
GrapeCity.Enterprise.Data.DataEngine Namespace


DataProcessor.Result Structure Members

[image]
ActiveReports 19 .NET Edition
DataProcessor.Result Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor.Result Structure

Glossary Item Box

The following tables list the members exposed by DataProcessor.Result.

Public Constructors

 | Name | Description
Public Constructor | DataProcessor.Result Constructor |
Top

Public Fields

 | Name | Description
Public Field | AggregateTree | An intermediate tree that contains the states of the aggregation functions and is used to construct the resulting tree applying filters and sorts.
Public Field | DataTree | The actual result data tree.
Top

See Also

Reference

DataProcessor.Result Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


DataProcessor.Result Constructor

[image]
ActiveReports 19 .NET Edition
DataProcessor.Result Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor.Result Structure : DataProcessor.Result Constructor

aggregateTree
dataTree

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aggregateTree As DataTree.Snapshot(Of Aggregate), _
   ByVal dataTree As DataTree.Snapshot(Of Object) _
)
C#
public DataProcessor.Result(
   DataTree.Snapshot<Aggregate> aggregateTree,
   DataTree.Snapshot<object> dataTree
)

Parameters

aggregateTree
dataTree

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor.Result Structure
DataProcessor.Result Members


DataProcessor.Result Structure Fields

[image]
ActiveReports 19 .NET Edition
DataProcessor.Result Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataProcessor.Result Structure

Glossary Item Box

For a list of all members of this type, see DataProcessor.Result members.

Public Fields

 | Name | Description
Public Field | AggregateTree | An intermediate tree that contains the states of the aggregation functions and is used to construct the resulting tree applying filters and sorts.
Public Field | DataTree | The actual result data tree.
Top

See Also

Reference

DataProcessor.Result Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


AggregateTree Field

[image]
ActiveReports 19 .NET Edition
AggregateTree Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor.Result Structure : AggregateTree Field

Glossary Item Box

An intermediate tree that contains the states of the aggregation functions and is used to construct the resulting tree applying filters and sorts.

Syntax

Visual Basic (Declaration)
Public ReadOnly AggregateTree As DataTree.Snapshot(Of Aggregate)
C#
public readonly DataTree.Snapshot<Aggregate> AggregateTree

Remarks

Using this tree you can build the result data tree multiple times applying interactive state. See GrapeCity.Enterprise.Data.DataEngine.DataProcessor.Transform(GrapeCity.Enterprise.Data.DataEngine.DataTree{GrapeCity.Enterprise.Data.DataEngine.Aggregates.Aggregate}.Snapshot,GrapeCity.Enterprise.Data.DataEngine.Def.Report,GrapeCity.Enterprise.Data.DataEngine.InteractiveState,GrapeCity.Enterprise.Data.DataEngine.ReportContextFn) method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor.Result Structure
DataProcessor.Result Members


DataTree Field

[image]
ActiveReports 19 .NET Edition
DataTree Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor.Result Structure : DataTree Field

Glossary Item Box

The actual result data tree.

Syntax

Visual Basic (Declaration)
Public ReadOnly DataTree As DataTree.Snapshot(Of Object)
C#
public readonly DataTree.Snapshot<object> DataTree

Remarks

This tree is based on the AggregateTree and contains filtered and sorted data with the final expressions values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor.Result Structure
DataProcessor.Result Members


InteractiveSort Structure

[image]
ActiveReports 19 .NET Edition
InteractiveSort Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSort Structure

Glossary Item Box

Defines interactive sorting. Represents a single interactive sorting operation, including the sort expression, its scope, and the direction of sorting.

Object Model

InteractiveSort Structure

Syntax

Visual Basic (Declaration)
Public Structure InteractiveSort
   Inherits System.ValueType
C#
public struct InteractiveSort : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.InteractiveSort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSort Members
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveSort Structure Members

[image]
ActiveReports 19 .NET Edition
InteractiveSort Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSort Structure

Glossary Item Box

The following tables list the members exposed by InteractiveSort.

Public Constructors

 | Name | Description
Public Constructor | InteractiveSort Constructor | Initializes a new instance of the InteractiveSort structure with the specified sort expression, scope, and direction.
Top

Public Fields

 | Name | Description
Public Field | Direction | Gets the direction of the sort operation.
Public Field | SortExpression | Gets the expression used for sorting.
Public Field | SortExpressionScope | Gets the name of the data region, grouping, or scope within which the sort expression is evaluated.
Top

See Also

Reference

InteractiveSort Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


InteractiveSort Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveSort Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSort Structure : InteractiveSort Constructor

sortExpression
The expression to sort on.
sortExpressionScope
The name of the data region, grouping, or scope to evaluate the expression in.
direction
The direction of the sort.

Glossary Item Box

Initializes a new instance of the InteractiveSort structure with the specified sort expression, scope, and direction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sortExpression As ExpressionInfo, _
   ByVal sortExpressionScope As String, _
   ByVal direction As Def.SortDirection _
)
C#
public InteractiveSort(
   ExpressionInfo sortExpression,
   string sortExpressionScope,
   Def.SortDirection direction
)

Parameters

sortExpression
The expression to sort on.
sortExpressionScope
The name of the data region, grouping, or scope to evaluate the expression in.
direction
The direction of the sort.

Remarks

This constructor creates a new InteractiveSort instance that encapsulates all the information needed to perform an interactive sorting operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSort Structure
InteractiveSort Members


InteractiveSort Structure Fields

[image]
ActiveReports 19 .NET Edition
InteractiveSort Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSort Structure

Glossary Item Box

For a list of all members of this type, see InteractiveSort members.

Public Fields

 | Name | Description
Public Field | Direction | Gets the direction of the sort operation.
Public Field | SortExpression | Gets the expression used for sorting.
Public Field | SortExpressionScope | Gets the name of the data region, grouping, or scope within which the sort expression is evaluated.
Top

See Also

Reference

InteractiveSort Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


Direction Field

[image]
ActiveReports 19 .NET Edition
Direction Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSort Structure : Direction Field

Glossary Item Box

Gets the direction of the sort operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Direction As Def.SortDirection
C#
public readonly Def.SortDirection Direction

Field Value

The direction in which the data should be sorted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSort Structure
InteractiveSort Members


SortExpression Field

[image]
ActiveReports 19 .NET Edition
SortExpression Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSort Structure : SortExpression Field

Glossary Item Box

Gets the expression used for sorting.

Syntax

Visual Basic (Declaration)
Public ReadOnly SortExpression As ExpressionInfo
C#
public readonly ExpressionInfo SortExpression

Field Value

The expression that determines the values to sort by.

Remarks

The sort expression is evaluated within the context defined by SortExpressionScope to produce the values that are used for sorting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSort Structure
InteractiveSort Members


SortExpressionScope Field

[image]
ActiveReports 19 .NET Edition
SortExpressionScope Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSort Structure : SortExpressionScope Field

Glossary Item Box

Gets the name of the data region, grouping, or scope within which the sort expression is evaluated.

Syntax

Visual Basic (Declaration)
Public ReadOnly SortExpressionScope As String
C#
public readonly string SortExpressionScope

Field Value

The name of the scope for evaluating the sort expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSort Structure
InteractiveSort Members


SlicerKey Structure

[image]
ActiveReports 19 .NET Edition
SlicerKey Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerKey Structure

Glossary Item Box

Represents a unique identifier for a slicer within a data tree.

Object Model

SlicerKey Structure

Syntax

Visual Basic (Declaration)
Public Structure SlicerKey
   Inherits System.ValueType
C#
public struct SlicerKey : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.SlicerKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerKey Members
GrapeCity.Enterprise.Data.DataEngine Namespace


SlicerKey Structure Members

[image]
ActiveReports 19 .NET Edition
SlicerKey Structure Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerKey Structure

Glossary Item Box

The following tables list the members exposed by SlicerKey.

Public Constructors

 | Name | Description
Public Constructor | SlicerKey Constructor | Represents a unique identifier for a slicer within a data tree.
Top

Public Properties

 | Name | Description
Public Property | Name | The name of the slicer.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns the fully qualified type name of this instance.
Top

Public Operators

public Operator Implicit Type Conversion Implicitly creates a new SlicerKey instance from a string.
Top

See Also

Reference

SlicerKey Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


SlicerKey Constructor

[image]
ActiveReports 19 .NET Edition
SlicerKey Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerKey Structure : SlicerKey Constructor

Name
The name of the slicer.

Glossary Item Box

Represents a unique identifier for a slicer within a data tree.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Name As String _
)
C#
public SlicerKey(
   string Name
)

Parameters

Name
The name of the slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerKey Structure
SlicerKey Members


SlicerKey Structure Methods

[image]
ActiveReports 19 .NET Edition
SlicerKey Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerKey Structure

Glossary Item Box

For a list of all members of this type, see SlicerKey members.

Public Methods

 | Name | Description
Public Method | ToString | Returns the fully qualified type name of this instance.
Top

See Also

Reference

SlicerKey Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerKey Structure : ToString Method

Glossary Item Box

Returns the fully qualified type name of this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The fully qualified type name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerKey Structure
SlicerKey Members


SlicerKey Structure Properties

[image]
ActiveReports 19 .NET Edition
SlicerKey Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerKey Structure

Glossary Item Box

For a list of all members of this type, see SlicerKey members.

Public Properties

 | Name | Description
Public Property | Name | The name of the slicer.
Top

See Also

Reference

SlicerKey Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerKey Structure : Name Property

Glossary Item Box

The name of the slicer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerKey Structure
SlicerKey Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerKey Structure : Implicit Type Conversion Operator

slicerString
The string representation of the slicer key.

Glossary Item Box

Implicitly creates a new SlicerKey instance from a string.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal slicerString As String _
) As SlicerKey
C#
public SlicerKey operator implicit(
   string slicerString
)

Parameters

slicerString
The string representation of the slicer key.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerKey Structure
SlicerKey Members


SlicerState Structure

[image]
ActiveReports 19 .NET Edition
SlicerState Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerState Structure

Glossary Item Box

Describes state of the specific slicer.

Object Model

SlicerState Structure

Syntax

Visual Basic (Declaration)
Public Structure SlicerState
   Inherits System.ValueType
C#
public struct SlicerState : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.SlicerState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerState Members
GrapeCity.Enterprise.Data.DataEngine Namespace


SlicerState Structure Members

[image]
ActiveReports 19 .NET Edition
SlicerState Structure Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerState Structure

Glossary Item Box

The following tables list the members exposed by SlicerState.

Public Constructors

 | Name | Description
Public Constructor | SlicerState Constructor | Describes state of the specific slicer.
Top

Public Properties

 | Name | Description
Public Property | Key | Slicer identifier.
Public Property | Value | Slicer value.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns the fully qualified type name of this instance.
Top

See Also

Reference

SlicerState Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


SlicerState Constructor

[image]
ActiveReports 19 .NET Edition
SlicerState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerState Structure : SlicerState Constructor

Key
Value

Glossary Item Box

Describes state of the specific slicer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Key As SlicerKey, _
   ByVal Value As Variant _
)
C#
public SlicerState(
   SlicerKey Key,
   Variant Value
)

Parameters

Key
Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerState Structure
SlicerState Members


SlicerState Structure Methods

[image]
ActiveReports 19 .NET Edition
SlicerState Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerState Structure

Glossary Item Box

For a list of all members of this type, see SlicerState members.

Public Methods

 | Name | Description
Public Method | ToString | Returns the fully qualified type name of this instance.
Top

See Also

Reference

SlicerState Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerState Structure : ToString Method

Glossary Item Box

Returns the fully qualified type name of this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The fully qualified type name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerState Structure
SlicerState Members


SlicerState Structure Properties

[image]
ActiveReports 19 .NET Edition
SlicerState Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : SlicerState Structure

Glossary Item Box

For a list of all members of this type, see SlicerState members.

Public Properties

 | Name | Description
Public Property | Key | Slicer identifier.
Public Property | Value | Slicer value.
Top

See Also

Reference

SlicerState Structure
GrapeCity.Enterprise.Data.DataEngine Namespace


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerState Structure : Key Property

Glossary Item Box

Slicer identifier.

Syntax

Visual Basic (Declaration)
Public Property Key As SlicerKey
C#
public SlicerKey Key {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerState Structure
SlicerState Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > SlicerState Structure : Value Property

Glossary Item Box

Slicer value.

Syntax

Visual Basic (Declaration)
Public Property Value As Variant
C#
public Variant Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerState Structure
SlicerState Members


ReportContextFn Delegate

[image]
ActiveReports 19 .NET Edition
ReportContextFn Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : ReportContextFn Delegate

report
parameters

Glossary Item Box

Declares the function type ofr the ReportContext creation during the data processing.

Syntax

Visual Basic (Declaration)
Public Delegate Function ReportContextFn( _
   ByVal report As Def.Report, _
   ByVal parameters() As DataParameter _
) As ReportContext
C#
public delegate ReportContext ReportContextFn(
   Def.Report report,
   DataParameter[] parameters
)

Parameters

report
parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportContextFn Members
GrapeCity.Enterprise.Data.DataEngine Namespace


AggregateDataProviderExtension Class

[image]
ActiveReports 19 .NET Edition
AggregateDataProviderExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateDataProviderExtension Class

Glossary Item Box

Contains operations over IAggregateDataProvider

Object Model

AggregateDataProviderExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class AggregateDataProviderExtension
C#
public static class AggregateDataProviderExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateDataProviderExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateDataProviderExtension Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateDataProviderExtension Class Members

[image]
ActiveReports 19 .NET Edition
AggregateDataProviderExtension Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateDataProviderExtension Class

Glossary Item Box

The following tables list the members exposed by AggregateDataProviderExtension.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NoAggregate | Represents Aggregate function with no aggregate
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ResolveAggregateFunction | Gets aggregate function by its name
Top

See Also

Reference

AggregateDataProviderExtension Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateDataProviderExtension Class Methods

[image]
ActiveReports 19 .NET Edition
AggregateDataProviderExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateDataProviderExtension Class

Glossary Item Box

For a list of all members of this type, see AggregateDataProviderExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ResolveAggregateFunction | Gets aggregate function by its name
Top

See Also

Reference

AggregateDataProviderExtension Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


ResolveAggregateFunction Method

[image]
ActiveReports 19 .NET Edition
ResolveAggregateFunction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateDataProviderExtension Class : ResolveAggregateFunction Method

provider
aggregate data provider
expr
expression

Glossary Item Box

Gets aggregate function by its name

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveAggregateFunction( _
   ByVal provider As IAggregateDataProvider, _
   ByVal expr As ExpressionInfo _
) As AggregateFunction
C#
public static AggregateFunction ResolveAggregateFunction(
   IAggregateDataProvider provider,
   ExpressionInfo expr
)

Parameters

provider
aggregate data provider
expr
expression

Return Value

Aggregate function type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateDataProviderExtension Class
AggregateDataProviderExtension Members


AggregateDataProviderExtension Class Fields

[image]
ActiveReports 19 .NET Edition
AggregateDataProviderExtension Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateDataProviderExtension Class

Glossary Item Box

For a list of all members of this type, see AggregateDataProviderExtension members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NoAggregate | Represents Aggregate function with no aggregate
Top

See Also

Reference

AggregateDataProviderExtension Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


NoAggregate Field

[image]
ActiveReports 19 .NET Edition
NoAggregate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateDataProviderExtension Class : NoAggregate Field

Glossary Item Box

Represents Aggregate function with no aggregate

Syntax

Visual Basic (Declaration)
Public Shared NoAggregate As AggregateFunction
C#
public static AggregateFunction NoAggregate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateDataProviderExtension Class
AggregateDataProviderExtension Members


AggregateFunctions Class

[image]
ActiveReports 19 .NET Edition
AggregateFunctions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateFunctions Class

Glossary Item Box

Mapper for aggregate functions names.

Object Model

AggregateFunctions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class AggregateFunctions
C#
public static class AggregateFunctions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunctions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateFunctions Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateFunctions Class Members

[image]
ActiveReports 19 .NET Edition
AggregateFunctions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateFunctions Class

Glossary Item Box

The following tables list the members exposed by AggregateFunctions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Name | Gets name of the given AggregateFunction
static (Shared in Visual Basic) | Parse | Gets AggregateFunction by name
Top

See Also

Reference

AggregateFunctions Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateFunctions Class Methods

[image]
ActiveReports 19 .NET Edition
AggregateFunctions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateFunctions Class

Glossary Item Box

For a list of all members of this type, see AggregateFunctions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Name | Gets name of the given AggregateFunction
static (Shared in Visual Basic) | Parse | Gets AggregateFunction by name
Top

See Also

Reference

AggregateFunctions Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Name Method

[image]
ActiveReports 19 .NET Edition
Name Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateFunctions Class : Name Method

f
Aggregate function

Glossary Item Box

Gets name of the given AggregateFunction

Syntax

Visual Basic (Declaration)
Public Shared Function Name( _
   ByVal f As AggregateFunction _
) As String
C#
public static string Name(
   AggregateFunction f
)

Parameters

f
Aggregate function

Return Value

name of the given AggregateFunction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateFunctions Class
AggregateFunctions Members


Parse Method

[image]
ActiveReports 19 .NET Edition
Parse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateFunctions Class : Parse Method

name
Aggregate function name

Glossary Item Box

Gets AggregateFunction by name

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal name As String _
) As AggregateFunction
C#
public static AggregateFunction Parse(
   string name
)

Parameters

name
Aggregate function name

Return Value

AggregateFunction by name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateFunctions Class
AggregateFunctions Members


AggregateHelper Class

[image]
ActiveReports 19 .NET Edition
AggregateHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateHelper Class

Glossary Item Box

Provides utility methods for working with aggregate functions in conjunction with the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo instances.

Object Model

AggregateHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class AggregateHelper
C#
public static class AggregateHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateHelper Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateHelper Class Members

[image]
ActiveReports 19 .NET Edition
AggregateHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateHelper Class

Glossary Item Box

The following tables list the members exposed by AggregateHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAggregates | Gets aggregates from a given expression
static (Shared in Visual Basic) | IsAggregate | Checks if the given expression is a known aggregate function.
Top

See Also

Reference

AggregateHelper Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateHelper Class Methods

[image]
ActiveReports 19 .NET Edition
AggregateHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateHelper Class

Glossary Item Box

For a list of all members of this type, see AggregateHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAggregates | Gets aggregates from a given expression
static (Shared in Visual Basic) | IsAggregate | Checks if the given expression is a known aggregate function.
Top

See Also

Reference

AggregateHelper Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


GetAggregates Method

[image]
ActiveReports 19 .NET Edition
GetAggregates Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateHelper Class : GetAggregates Method

e
expression
withFieldRefs
if field references should be resolved

Glossary Item Box

Gets aggregates from a given expression

Syntax

Visual Basic (Declaration)
Public Shared Function GetAggregates( _
   ByVal e As ExpressionInfo, _
   Optional ByVal withFieldRefs As Boolean _
) As IEnumerable(Of AggregateInfo)
C#
public static IEnumerable<AggregateInfo> GetAggregates(
   ExpressionInfo e,
   bool withFieldRefs
)

Parameters

e
expression
withFieldRefs
if field references should be resolved

Return Value

aggregates taken from a given expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateHelper Class
AggregateHelper Members


IsAggregate Method

[image]
ActiveReports 19 .NET Edition
IsAggregate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateHelper Class : IsAggregate Method

e

Glossary Item Box

Checks if the given expression is a known aggregate function.

Syntax

Visual Basic (Declaration)
Public Shared Function IsAggregate( _
   ByVal e As ExpressionInfo _
) As Boolean
C#
public static bool IsAggregate(
   ExpressionInfo e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateHelper Class
AggregateHelper Members


AggregateInfo Class

[image]
ActiveReports 19 .NET Edition
AggregateInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateInfo Class

Glossary Item Box

Represents an aggregate function in an expression.

Object Model

AggregateInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AggregateInfo
C#
public sealed class AggregateInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateInfo Class Members

[image]
ActiveReports 19 .NET Edition
AggregateInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateInfo Class

Glossary Item Box

The following tables list the members exposed by AggregateInfo.

Public Properties

 | Name | Description
Public Property | Arguments | Returns a new GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that represents the portion of the expression that is aggregated by the aggregate function.
Public Property | Func | Gets the aggregate function.
Public Property | IsNothingScope | Gets an indication that the aggregate function scope is not limited.
Public Property | IsRecursive | Gets an indication that an aggregate is calculated recursively in recursive hierarchies (aka parent-child hierarchies).
Public Property | IsScopeSpecified | Gets an indication that an aggregate function scope is specified.
Public Property | ScopeName | Gets the aggregate function scope name.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified AggregateInfo object represents the same aggregation as this one.
Public Method | GetHashCode | Generates a HashCode for this expression.
Public Method | ToString | Converts the aggregate to the string representation.
Top

Public Operators

public Operator Equality | Performs equality operation.
public Operator Inequality | Performs inequality operation.
Top

See Also

Reference

AggregateInfo Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


AggregateInfo Class Methods

[image]
ActiveReports 19 .NET Edition
AggregateInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateInfo Class

Glossary Item Box

For a list of all members of this type, see AggregateInfo members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified AggregateInfo object represents the same aggregation as this one.
Public Method | GetHashCode | Generates a HashCode for this expression.
Public Method | ToString | Converts the aggregate to the string representation.
Top

See Also

Reference

AggregateInfo Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : Equals Method

Glossary Item Box

Determines whether the specified AggregateInfo object represents the same aggregation as this one.

Overload List

Overload | Description
Equals(AggregateInfo) | Determines whether the specified AggregateInfo object represents the same aggregation as this one.
Equals(Object) | Determines whether the specified object represents the same aggregation as this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


Equals(AggregateInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(AggregateInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class > Equals Method : Equals(AggregateInfo) Method

peer

Glossary Item Box

Determines whether the specified AggregateInfo object represents the same aggregation as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal peer As AggregateInfo _
) As Boolean
C#
public bool Equals(
   AggregateInfo peer
)

Parameters

peer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class > Equals Method : Equals(Object) Method

obj

Glossary Item Box

Determines whether the specified object represents the same aggregation as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : ToString Method

Glossary Item Box

Converts the aggregate to the string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String value representing aggregate expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


AggregateInfo Class Properties

[image]
ActiveReports 19 .NET Edition
AggregateInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateInfo Class

Glossary Item Box

For a list of all members of this type, see AggregateInfo members.

Public Properties

 | Name | Description
Public Property | Arguments | Returns a new GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that represents the portion of the expression that is aggregated by the aggregate function.
Public Property | Func | Gets the aggregate function.
Public Property | IsNothingScope | Gets an indication that the aggregate function scope is not limited.
Public Property | IsRecursive | Gets an indication that an aggregate is calculated recursively in recursive hierarchies (aka parent-child hierarchies).
Public Property | IsScopeSpecified | Gets an indication that an aggregate function scope is specified.
Public Property | ScopeName | Gets the aggregate function scope name.
Top

See Also

Reference

AggregateInfo Class
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Arguments Property

[image]
ActiveReports 19 .NET Edition
Arguments Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : Arguments Property

Glossary Item Box

Returns a new GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that represents the portion of the expression that is aggregated by the aggregate function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As ExpressionInfo()
C#
public ExpressionInfo[] Arguments {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


Func Property

[image]
ActiveReports 19 .NET Edition
Func Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : Func Property

Glossary Item Box

Gets the aggregate function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Func As AggregateFunction
C#
public AggregateFunction Func {get;}

Property Value

An AggregateFunction item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


IsNothingScope Property

[image]
ActiveReports 19 .NET Edition
IsNothingScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : IsNothingScope Property

Glossary Item Box

Gets an indication that the aggregate function scope is not limited.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNothingScope As Boolean
C#
public bool IsNothingScope {get;}

Property Value

True if the scope name is not specified for the aggregate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


IsRecursive Property

[image]
ActiveReports 19 .NET Edition
IsRecursive Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : IsRecursive Property

Glossary Item Box

Gets an indication that an aggregate is calculated recursively in recursive hierarchies (aka parent-child hierarchies).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRecursive As Boolean
C#
public bool IsRecursive {get;}

Property Value

True if the aggregate is calculated recursively, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


IsScopeSpecified Property

[image]
ActiveReports 19 .NET Edition
IsScopeSpecified Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : IsScopeSpecified Property

Glossary Item Box

Gets an indication that an aggregate function scope is specified.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsScopeSpecified As Boolean
C#
public bool IsScopeSpecified {get;}

Property Value

True if the scope argument is specified for the aggregate function and it is not empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


ScopeName Property

[image]
ActiveReports 19 .NET Edition
ScopeName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : ScopeName Property

Glossary Item Box

Gets the aggregate function scope name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScopeName As String
C#
public string ScopeName {get;}

Property Value

A System.String value represents the name of the scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : Equality Operator

right
The left operand to be compared.
left
The right operand to be compared.

Glossary Item Box

Performs equality operation.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal right As AggregateInfo, _
   ByVal left As AggregateInfo _
) As Boolean
C#
public bool operator ==(
   AggregateInfo right,
   AggregateInfo left
)

Parameters

right
The left operand to be compared.
left
The right operand to be compared.

Return Value

A System.Boolean value indicates if the AggregateInfo instances are equal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > AggregateInfo Class : Inequality Operator

left
The left operand.
right
The right operand.

Glossary Item Box

Performs inequality operation.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal left As AggregateInfo, _
   ByVal right As AggregateInfo _
) As Boolean
C#
public bool operator !=(
   AggregateInfo left,
   AggregateInfo right
)

Parameters

left
The left operand.
right
The right operand.

Return Value

A System.Boolean value of inequality operation result.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AggregateInfo Class
AggregateInfo Members


AggregateFunction Enumeration

[image]
ActiveReports 19 .NET Edition
AggregateFunction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : AggregateFunction Enumeration

Glossary Item Box

Specifies the available intrinsic aggregate function names

Syntax

Visual Basic (Declaration)
Public Enum AggregateFunction
   Inherits System.Enum
C#
public enum AggregateFunction : System.Enum

Members

Member | Description
Aggregate | Returns an aggregate defined by the data provider
AggregateIf | Determines the AggregateIf value for a list of facts
Avg | Uses Sum+Count to calculate average
Count | Counts non-null values for each record in a list of facts
CountDistinct | Counts based on distinct values of an expression for each record in a list of Facts
CountRows | Counts all records
DistinctSum | Determines the DistinctSum value for a list of facts
Empty | Represents an undefined aggregate function. This value is used to indicate the absence of a function.
First | Determines the first value of a list of facts
Last | Determines the last value of a list of facts
Max | Max of all values in a list of facts
Median | Determines the median value for a list of facts
Min | Min of all values in a list of facts
Mode | Determines the mode value for a list of facts
StDev | Borrows from Var (Square Root of Var)
StDevP | Borrows from VarP (Square Root of VarP)
Sum | Calculates sum of non-null values for each record in a list of facts
ToArray | Returns records as array
Var | Borrows from SumSquare, Sum, & Count
VarP | Borrows from SumSquare, Sum, & Count

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Aggregate Structure

[image]
ActiveReports 19 .NET Edition
Aggregate Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : Aggregate Structure

Glossary Item Box

Represents the state of the aggregate function.

Object Model

Aggregate Structure

Syntax

Visual Basic (Declaration)
Public Structure Aggregate
   Inherits System.ValueType
C#
public struct Aggregate : System.ValueType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.Aggregates.Aggregate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Aggregate Structure Members

[image]
ActiveReports 19 .NET Edition
Aggregate Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : Aggregate Structure

Glossary Item Box

The following tables list the members exposed by Aggregate.

Public Fields

 | Name | Description
Public Field | Function | Aggregate function.
Top

Public Properties

 | Name | Description
Public Property | IsSingleArgument | Returns True if the aggregate function requires single argument.
Public Property | State | Variant-based aggregate state representation. This state can be used with Create(AggregateFunction,Variant[]) method.
Top

Public Methods

 | Name | Description
Public Method | Accumulate | Accumulates value into aggregate state.
Public Method | Combine | Combines two aggregates into one.
static (Shared in Visual Basic) | Create | Overloaded. Creates aggregate with a given state.
Public Method | GetValue | Gets the aggregate function result.
Top

See Also

Reference

Aggregate Structure
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Aggregate Structure Methods

[image]
ActiveReports 19 .NET Edition
Aggregate Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : Aggregate Structure

Glossary Item Box

For a list of all members of this type, see Aggregate members.

Public Methods

 | Name | Description
Public Method | Accumulate | Accumulates value into aggregate state.
Public Method | Combine | Combines two aggregates into one.
static (Shared in Visual Basic) | Create | Overloaded. Creates aggregate with a given state.
Public Method | GetValue | Gets the aggregate function result.
Top

See Also

Reference

Aggregate Structure
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Accumulate(Variant) Method

[image]
ActiveReports 19 .NET Edition
Accumulate(Variant) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : Accumulate(Variant) Method

variants

Glossary Item Box

Accumulates value into aggregate state.

Syntax

Visual Basic (Declaration)
Public Sub Accumulate( _
   ByVal variants As Variant _
)
C#
public void Accumulate(
   Variant variants
)

Parameters

variants

Remarks

Used by ar.core for cumulative totals evaluation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


Combine Method

[image]
ActiveReports 19 .NET Edition
Combine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : Combine Method

arg2

Glossary Item Box

Combines two aggregates into one.

Syntax

Visual Basic (Declaration)
Public Function Combine( _
   ByRef arg2 As Aggregate _
) As Aggregate
C#
public Aggregate Combine(
   ref Aggregate arg2
)

Parameters

arg2

Remarks

Used by ar.core for cumulative totals evaluation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : Create Method

Glossary Item Box

Creates aggregate with a given state.

Overload List

Overload | Description
Create(AggregateFunction,Variant[]) | Creates aggregate with a given state.
Create(AggregateFunction) | Creates aggregate for the specified function type with initial state.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


Create(AggregateFunction,Variant[]) Method

[image]
ActiveReports 19 .NET Edition
Create(AggregateFunction,Variant[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure > Create Method : Create(AggregateFunction,Variant[]) Method

function
Aggregate function.
state
Initial aggregate state.

Glossary Item Box

Creates aggregate with a given state.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal function As AggregateFunction, _
   ByVal state() As Variant _
) As Aggregate
C#
public static Aggregate Create(
   AggregateFunction function,
   Variant[] state
)

Parameters

function
Aggregate function.
state
Initial aggregate state.

Remarks

Used by 'Lancer' (data provider for the semantic reports) and by ar.core in snapshot serializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members
Overload List


Create(AggregateFunction) Method

[image]
ActiveReports 19 .NET Edition
Create(AggregateFunction) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure > Create Method : Create(AggregateFunction) Method

function
Aggregate function.

Glossary Item Box

Creates aggregate for the specified function type with initial state.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal function As AggregateFunction _
) As Aggregate
C#
public static Aggregate Create(
   AggregateFunction function
)

Parameters

function
Aggregate function.

Remarks

Used in ar.core for cumulative totals evaluation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members
Overload List


GetValue Method

[image]
ActiveReports 19 .NET Edition
GetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : GetValue Method

Glossary Item Box

Gets the aggregate function result.

Syntax

Visual Basic (Declaration)
Public Function GetValue() As Variant
C#
public Variant GetValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


Aggregate Structure Properties

[image]
ActiveReports 19 .NET Edition
Aggregate Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : Aggregate Structure

Glossary Item Box

For a list of all members of this type, see Aggregate members.

Public Properties

 | Name | Description
Public Property | IsSingleArgument | Returns True if the aggregate function requires single argument.
Public Property | State | Variant-based aggregate state representation. This state can be used with Create(AggregateFunction,Variant[]) method.
Top

See Also

Reference

Aggregate Structure
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


IsSingleArgument Property

[image]
ActiveReports 19 .NET Edition
IsSingleArgument Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : IsSingleArgument Property

Glossary Item Box

Returns True if the aggregate function requires single argument.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSingleArgument As Boolean
C#
public bool IsSingleArgument {get;}

Remarks

This getter is used in CumulativeTotalImp in ar.core

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


State Property

[image]
ActiveReports 19 .NET Edition
State Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : State Property

Glossary Item Box

Variant-based aggregate state representation. This state can be used with Create(AggregateFunction,Variant[]) method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As Variant()
C#
public Variant[] State {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


Aggregate Structure Fields

[image]
ActiveReports 19 .NET Edition
Aggregate Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : Aggregate Structure

Glossary Item Box

For a list of all members of this type, see Aggregate members.

Public Fields

 | Name | Description
Public Field | Function | Aggregate function.
Top

See Also

Reference

Aggregate Structure
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


Function Field

[image]
ActiveReports 19 .NET Edition
Function Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : Function Field

Glossary Item Box

Aggregate function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Function As AggregateFunction
C#
public readonly AggregateFunction Function

Remarks

It is public to be used in ar.core for snapshot serialization.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


IAggregateDataProvider Interface

[image]
ActiveReports 19 .NET Edition
IAggregateDataProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : IAggregateDataProvider Interface

Glossary Item Box

Contract for the describing ot the aggregate fields in semantic data provider.

Syntax

Visual Basic (Declaration)
Public Interface IAggregateDataProvider
C#
public interface IAggregateDataProvider

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAggregateDataProvider Members
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


IAggregateDataProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IAggregateDataProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : IAggregateDataProvider Interface

Glossary Item Box

The following tables list the members exposed by IAggregateDataProvider.

Public Methods

 | Name | Description
Method | GetAggregateFunction | Gets aggregate function type for the specified field.
Top

See Also

Reference

IAggregateDataProvider Interface
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


IAggregateDataProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IAggregateDataProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace : IAggregateDataProvider Interface

Glossary Item Box

For a list of all members of this type, see IAggregateDataProvider members.

Public Methods

 | Name | Description
Method | GetAggregateFunction | Gets aggregate function type for the specified field.
Top

See Also

Reference

IAggregateDataProvider Interface
GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace


GetAggregateFunction Method

[image]
ActiveReports 19 .NET Edition
GetAggregateFunction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > IAggregateDataProvider Interface : GetAggregateFunction Method

fieldName

Glossary Item Box

Gets aggregate function type for the specified field.

Syntax

Visual Basic (Declaration)
Function GetAggregateFunction( _
   ByVal fieldName As String _
) As AggregateFunction
C#
AggregateFunction GetAggregateFunction(
   string fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAggregateDataProvider Interface
IAggregateDataProvider Members


TablixExtensions Class

[image]
ActiveReports 19 .NET Edition
TablixExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace : TablixExtensions Class

Glossary Item Box

Helper methods for tablix members hierarchy.

Object Model

TablixExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class TablixExtensions
C#
public static class TablixExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataProcessing.TablixExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixExtensions Members
GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace


TablixExtensions Class Members

[image]
ActiveReports 19 .NET Edition
TablixExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace : TablixExtensions Class

Glossary Item Box

The following tables list the members exposed by TablixExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CollectLeafNodes<T> | Returns a set of leaves for tablix member.
Top

See Also

Reference

TablixExtensions Class
GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace


TablixExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
TablixExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace : TablixExtensions Class

Glossary Item Box

For a list of all members of this type, see TablixExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CollectLeafNodes<T> | Returns a set of leaves for tablix member.
Top

See Also

Reference

TablixExtensions Class
GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace


CollectLeafNodes<T> Method

T
[image]
ActiveReports 19 .NET Edition
CollectLeafNodes<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace > TablixExtensions Class : CollectLeafNodes<T> Method

members
members
isLeaf
function that checks whether the current tablix member is a leaf.
getChildren
function that gets the children of the current tablix member.
leavesFirst
if true, returns leaves first to speed first page loading.

Glossary Item Box

Returns a set of leaves for tablix member.

Syntax

Visual Basic (Declaration)
Public Shared Function CollectLeafNodes(Of T)( _
   ByVal members As IEnumerable(Of T), _
   ByVal isLeaf As Func(Of T,Boolean), _
   ByVal getChildren As Func(Of T,IEnumerable(Of T)), _
   Optional ByVal leavesFirst As Boolean _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> CollectLeafNodes<T>(
   IEnumerable<T> members,
   Func<T,bool> isLeaf,
   Func<T,IEnumerable<T>> getChildren,
   bool leavesFirst
)

Parameters

members
members
isLeaf
function that checks whether the current tablix member is a leaf.
getChildren
function that gets the children of the current tablix member.
leavesFirst
if true, returns leaves first to speed first page loading.

Type Parameters

T

Return Value

A set of leaves for tablix member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixExtensions Class
TablixExtensions Members


Eval Class

[image]
ActiveReports 19 .NET Edition
Eval Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval Class

Glossary Item Box

Expression evaluation facility based on compilation of expression to lambda function.

Object Model

Eval Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Eval
C#
public static class Eval

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Eval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval Class Members

[image]
ActiveReports 19 .NET Edition
Eval Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval Class

Glossary Item Box

The following tables list the members exposed by Eval.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | GlobalContext | Represents empty context.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compile | Compiles given expression to be evaluated within Eval.Context.
static (Shared in Visual Basic) | CreateContext | Overloaded. Creates no-data expression evaluation context.
Top

See Also

Reference

Eval Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval Class Methods

[image]
ActiveReports 19 .NET Edition
Eval Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval Class

Glossary Item Box

For a list of all members of this type, see Eval members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compile | Compiles given expression to be evaluated within Eval.Context.
static (Shared in Visual Basic) | CreateContext | Overloaded. Creates no-data expression evaluation context.
Top

See Also

Reference

Eval Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Compile(ExpressionInfo,CompileContext) Method

[image]
ActiveReports 19 .NET Edition
Compile(ExpressionInfo,CompileContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class : Compile(ExpressionInfo,CompileContext) Method

expression
The expression to compile.
context
The compile context.

Glossary Item Box

Compiles given expression to be evaluated within Eval.Context.

Syntax

Visual Basic (Declaration)
Public Shared Function Compile( _
   ByVal expression As ExpressionInfo, _
   Optional ByVal context As Eval.CompileContext _
) As Eval.EvalFn
C#
public static Eval.EvalFn Compile(
   ExpressionInfo expression,
   Eval.CompileContext context
)

Parameters

expression
The expression to compile.
context
The compile context.

Return Value

Evaluation function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members


CreateContext Method

[image]
ActiveReports 19 .NET Edition
CreateContext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class : CreateContext Method

Glossary Item Box

Creates no-data expression evaluation context.

Overload List

Overload | Description
CreateContext(IExpressionContext) | Creates no-data expression evaluation context.
CreateContext(Record,IExpressionContext) | Creates single-record based expression evaluation context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members


CreateContext(IExpressionContext) Method

[image]
ActiveReports 19 .NET Edition
CreateContext(IExpressionContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class > CreateContext Method : CreateContext(IExpressionContext) Method

app

Glossary Item Box

Creates no-data expression evaluation context.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateContext( _
   ByVal app As IExpressionContext _
) As Eval.IContext
C#
public static Eval.IContext CreateContext(
   IExpressionContext app
)

Parameters

app

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members
Overload List


CreateContext(Record,IExpressionContext) Method

[image]
ActiveReports 19 .NET Edition
CreateContext(Record,IExpressionContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class > CreateContext Method : CreateContext(Record,IExpressionContext) Method

record
The data record on which to evaluate expression.
expressionContext
Additional variables.

Glossary Item Box

Creates single-record based expression evaluation context.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateContext( _
   ByVal record As Record, _
   ByVal expressionContext As IExpressionContext _
) As Eval.IContext
C#
public static Eval.IContext CreateContext(
   Record record,
   IExpressionContext expressionContext
)

Parameters

record
The data record on which to evaluate expression.
expressionContext
Additional variables.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members
Overload List


Eval Class Fields

[image]
ActiveReports 19 .NET Edition
Eval Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval Class

Glossary Item Box

For a list of all members of this type, see Eval members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | GlobalContext | Represents empty context.
Top

See Also

Reference

Eval Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


GlobalContext Field

[image]
ActiveReports 19 .NET Edition
GlobalContext Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class : GlobalContext Field

Glossary Item Box

Represents empty context.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GlobalContext As Eval.IContext
C#
public static readonly Eval.IContext GlobalContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members


Eval.CompileContext Class

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.CompileContext Class

Glossary Item Box

Defines expression compilation context.

Object Model

Eval.CompileContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Eval.CompileContext
   Implements GrapeCity.Enterprise.Data.DataEngine.Aggregates.IAggregateDataProvider
C#
public sealed class Eval.CompileContext : GrapeCity.Enterprise.Data.DataEngine.Aggregates.IAggregateDataProvider

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Eval.CompileContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.CompileContext Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval.CompileContext Class Members

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.CompileContext Class

Glossary Item Box

The following tables list the members exposed by Eval.CompileContext.

Public Constructors

 | Name | Description
Public Constructor | Eval.CompileContext Constructor | Creates new instance on CompileContext
Top

Public Properties

 | Name | Description
Public Property | FieldNameIndex | Index of fields.
Top

Public Methods

 | Name | Description
Public Method | GetAggregateFunction | Gets aggregate function for semantic field.
Top

See Also

Reference

Eval.CompileContext Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval.CompileContext Constructor

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.CompileContext Class : Eval.CompileContext Constructor

Glossary Item Box

Creates new instance on CompileContext

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Eval.CompileContext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.CompileContext Class
Eval.CompileContext Members


Eval.CompileContext Class Methods

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.CompileContext Class

Glossary Item Box

For a list of all members of this type, see Eval.CompileContext members.

Public Methods

 | Name | Description
Public Method | GetAggregateFunction | Gets aggregate function for semantic field.
Top

See Also

Reference

Eval.CompileContext Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


GetAggregateFunction Method

[image]
ActiveReports 19 .NET Edition
GetAggregateFunction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.CompileContext Class : GetAggregateFunction Method

fieldName

Glossary Item Box

Gets aggregate function for semantic field.

Syntax

Visual Basic (Declaration)
Public Function GetAggregateFunction( _
   ByVal fieldName As String _
) As AggregateFunction
C#
public AggregateFunction GetAggregateFunction(
   string fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.CompileContext Class
Eval.CompileContext Members


Eval.CompileContext Class Properties

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.CompileContext Class

Glossary Item Box

For a list of all members of this type, see Eval.CompileContext members.

Public Properties

 | Name | Description
Public Property | FieldNameIndex | Index of fields.
Top

See Also

Reference

Eval.CompileContext Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


FieldNameIndex Property

[image]
ActiveReports 19 .NET Edition
FieldNameIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.CompileContext Class : FieldNameIndex Property

Glossary Item Box

Index of fields.

Syntax

Visual Basic (Declaration)
Public Property FieldNameIndex As IDictionary(Of String,Integer)
C#
public IDictionary<string,int> FieldNameIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.CompileContext Class
Eval.CompileContext Members


Field Class

[image]
ActiveReports 19 .NET Edition
Field Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Field Class

Glossary Item Box

Defines field proxy class to be used in the expression computation process.

Object Model

Field Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Field
C#
public sealed class Field

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Field

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Field Class Members

[image]
ActiveReports 19 .NET Edition
Field Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Field Class

Glossary Item Box

The following tables list the members exposed by Field.

Public Constructors

 | Name | Description
Public Constructor | Field Constructor | Constructs new field from given name and value.
Top

Public Properties

 | Name | Description
Public Property | Name | Field name.
Public Property | Properties | Allows to acces Name and Value by case-insensitive key (name and value respectively).
Public Property | Value | Field value.
Top

See Also

Reference

Field Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Field Constructor

[image]
ActiveReports 19 .NET Edition
Field Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Field Class : Field Constructor

name
The name of the field.
value
The value of the field.

Glossary Item Box

Constructs new field from given name and value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public Field(
   string name,
   object value
)

Parameters

name
The name of the field.
value
The value of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Properties

[image]
ActiveReports 19 .NET Edition
Field Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Properties

 | Name | Description
Public Property | Name | Field name.
Public Property | Properties | Allows to acces Name and Value by case-insensitive key (name and value respectively).
Public Property | Value | Field value.
Top

See Also

Reference

Field Class
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Field Class : Name Property

Glossary Item Box

Field name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Field Class : Properties Property

property

Glossary Item Box

Allows to acces Name and Value by case-insensitive key (name and value respectively).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal property As String _
) As Object
C#
public object this[
   string property
]; {get;}

Parameters

property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Field Class : Value Property

Glossary Item Box

Field value.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Eval.IContext Interface

[image]
ActiveReports 19 .NET Edition
Eval.IContext Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.IContext Interface

Glossary Item Box

Defines expression evaluation context.

Syntax

Visual Basic (Declaration)
Public Interface Eval.IContext
C#
public interface Eval.IContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.IContext Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval.IContext Interface Members

[image]
ActiveReports 19 .NET Edition
Eval.IContext Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.IContext Interface

Glossary Item Box

The following tables list the members exposed by Eval.IContext.

Public Properties

 | Name | Description
Property | App | Application context.
Property | Data | Gets a data over which the expression is to be evaluated.
Top

See Also

Reference

Eval.IContext Interface
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Eval.IContext Interface Properties

[image]
ActiveReports 19 .NET Edition
Eval.IContext Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.IContext Interface

Glossary Item Box

For a list of all members of this type, see Eval.IContext members.

Public Properties

 | Name | Description
Property | App | Application context.
Property | Data | Gets a data over which the expression is to be evaluated.
Top

See Also

Reference

Eval.IContext Interface
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


App Property

[image]
ActiveReports 19 .NET Edition
App Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.IContext Interface : App Property

Glossary Item Box

Application context.

Syntax

Visual Basic (Declaration)
ReadOnly Property App As IExpressionContext
C#
IExpressionContext App {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.IContext Interface
Eval.IContext Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.IContext Interface : Data Property

Glossary Item Box

Gets a data over which the expression is to be evaluated.

Syntax

Visual Basic (Declaration)
ReadOnly Property Data As RecordSet
C#
RecordSet Data {get;}

Property Value

The data as a GrapeCity.Enterprise.Data.DataEngine.RecordSet, which can represent a collection of records or a single record.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.IContext Interface
Eval.IContext Members


IExpressionContext Interface

[image]
ActiveReports 19 .NET Edition
IExpressionContext Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : IExpressionContext Interface

Glossary Item Box

Defines application context used to extend expression evaluation context.

Syntax

Visual Basic (Declaration)
Public Interface IExpressionContext
   Inherits GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject
C#
public interface IExpressionContext : GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpressionContext Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


IExpressionContext Interface Members

[image]
ActiveReports 19 .NET Edition
IExpressionContext Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : IExpressionContext Interface

Glossary Item Box

The following tables list the members exposed by IExpressionContext.

Public Properties

 | Name | Description
Property | Culture | Gets application culture.
Top

See Also

Reference

IExpressionContext Interface
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


IExpressionContext Interface Properties

[image]
ActiveReports 19 .NET Edition
IExpressionContext Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : IExpressionContext Interface

Glossary Item Box

For a list of all members of this type, see IExpressionContext members.

Public Properties

 | Name | Description
Property | Culture | Gets application culture.
Top

See Also

Reference

IExpressionContext Interface
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > IExpressionContext Interface : Culture Property

Glossary Item Box

Gets application culture.

Syntax

Visual Basic (Declaration)
ReadOnly Property Culture As CultureInfo
C#
CultureInfo Culture {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpressionContext Interface
IExpressionContext Members


Eval.EvalFn Delegate

[image]
ActiveReports 19 .NET Edition
Eval.EvalFn Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : Eval.EvalFn Delegate

context
The function context.

Glossary Item Box

Signature of eval function.

Syntax

Visual Basic (Declaration)
Public Delegate Function Eval.EvalFn( _
   ByVal context As Eval.IContext _
) As Variant
C#
public delegate Variant Eval.EvalFn(
   Eval.IContext context
)

Parameters

context
The function context.

Return Value

evaluation result

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.EvalFn Members
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


ExpressionExtensions Class

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

Provides additional methods to work with expressions

Object Model

ExpressionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ExpressionExtensions
C#
public static class ExpressionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Expressions.ExpressionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Members
GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace


ExpressionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

The following tables list the members exposed by ExpressionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAggregateFunction | Returns the GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction enum value describing the root expression's function or ('GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction.Empty' if a given expression is not a function).
static (Shared in Visual Basic) | GetFieldName | Extracts field name from the expression which looks like Fields!SomeField.Value.
static (Shared in Visual Basic) | HasFieldRefs | Indicates whether the expression contains fields
static (Shared in Visual Basic) | ResolveFieldReference | Resolves name of referenced field in given expression.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace


ExpressionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

For a list of all members of this type, see ExpressionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAggregateFunction | Returns the GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction enum value describing the root expression's function or ('GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction.Empty' if a given expression is not a function).
static (Shared in Visual Basic) | GetFieldName | Extracts field name from the expression which looks like Fields!SomeField.Value.
static (Shared in Visual Basic) | HasFieldRefs | Indicates whether the expression contains fields
static (Shared in Visual Basic) | ResolveFieldReference | Resolves name of referenced field in given expression.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace


GetAggregateFunction Method

[image]
ActiveReports 19 .NET Edition
GetAggregateFunction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace > ExpressionExtensions Class : GetAggregateFunction Method

expr

Glossary Item Box

Returns the GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction enum value describing the root expression's function or ('GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunction.Empty' if a given expression is not a function).

Syntax

Visual Basic (Declaration)
Public Shared Function GetAggregateFunction( _
   ByVal expr As ExpressionInfo _
) As AggregateFunction
C#
public static AggregateFunction GetAggregateFunction(
   ExpressionInfo expr
)

Parameters

expr

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


GetFieldName Method

[image]
ActiveReports 19 .NET Edition
GetFieldName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace > ExpressionExtensions Class : GetFieldName Method

expr

Glossary Item Box

Extracts field name from the expression which looks like Fields!SomeField.Value.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFieldName( _
   ByVal expr As ExpressionInfo _
) As String
C#
public static string GetFieldName(
   ExpressionInfo expr
)

Parameters

expr

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


HasFieldRefs Method

[image]
ActiveReports 19 .NET Edition
HasFieldRefs Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace > ExpressionExtensions Class : HasFieldRefs Method

e
expression

Glossary Item Box

Indicates whether the expression contains fields

Syntax

Visual Basic (Declaration)
Public Shared Function HasFieldRefs( _
   ByVal e As ExpressionInfo _
) As Boolean
C#
public static bool HasFieldRefs(
   ExpressionInfo e
)

Parameters

e
expression

Return Value

true, if expression contains fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


ResolveFieldReference Method

[image]
ActiveReports 19 .NET Edition
ResolveFieldReference Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace > ExpressionExtensions Class : ResolveFieldReference Method

expression
The expression to search for reference.

Glossary Item Box

Resolves name of referenced field in given expression.

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveFieldReference( _
   ByVal expression As ExpressionInfo _
) As ExpressionInfo
C#
public static ExpressionInfo ResolveFieldReference(
   ExpressionInfo expression
)

Parameters

expression
The expression to search for reference.

Return Value

expression that contains Fields reference

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


MemoizeEnumerableExtensions Class

[image]
ActiveReports 19 .NET Edition
MemoizeEnumerableExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : MemoizeEnumerableExtensions Class

Glossary Item Box

Represents Memoize methods to work with collection buffers

Object Model

MemoizeEnumerableExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MemoizeEnumerableExtensions
C#
public static class MemoizeEnumerableExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Extensions.MemoizeEnumerableExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoizeEnumerableExtensions Members
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


MemoizeEnumerableExtensions Class Members

[image]
ActiveReports 19 .NET Edition
MemoizeEnumerableExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : MemoizeEnumerableExtensions Class

Glossary Item Box

The following tables list the members exposed by MemoizeEnumerableExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Memoize<TSource> | Creates a buffer with a view over the source sequence, causing each enumerator to obtain access to all of the sequence's elements without causing multiple enumerations over the source.
Top

See Also

Reference

MemoizeEnumerableExtensions Class
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


MemoizeEnumerableExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
MemoizeEnumerableExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : MemoizeEnumerableExtensions Class

Glossary Item Box

For a list of all members of this type, see MemoizeEnumerableExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Memoize<TSource> | Creates a buffer with a view over the source sequence, causing each enumerator to obtain access to all of the sequence's elements without causing multiple enumerations over the source.
Top

See Also

Reference

MemoizeEnumerableExtensions Class
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


Memoize<TSource> Method

TSource
Source sequence element type.
[image]
ActiveReports 19 .NET Edition
Memoize<TSource> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace > MemoizeEnumerableExtensions Class : Memoize<TSource> Method

source
Source sequence.

Glossary Item Box

Creates a buffer with a view over the source sequence, causing each enumerator to obtain access to all of the sequence's elements without causing multiple enumerations over the source.

Syntax

Visual Basic (Declaration)
Public Shared Function Memoize(Of TSource)( _
   ByVal source As IEnumerable(Of TSource) _
) As IBuffer(Of TSource)
C#
public static IBuffer<TSource> Memoize<TSource>(
   IEnumerable<TSource> source
)

Parameters

source
Source sequence.

Type Parameters

TSource
Source sequence element type.

Return Value

Buffer enabling each enumerator to retrieve all elements from the shared source sequence, without duplicating source enumeration side-effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoizeEnumerableExtensions Class
MemoizeEnumerableExtensions Members


IBuffer<T> Interface

T
Element type.
[image]
ActiveReports 19 .NET Edition
IBuffer<T> Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : IBuffer<T> Interface

Glossary Item Box

Represents a buffer exposing a shared view over an underlying enumerable sequence.

Syntax

Visual Basic (Declaration)
Public Interface IBuffer(Of T)
C#
public interface IBuffer<T>

Type Parameters

T
Element type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuffer<T> Members
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


IBuffer<T> Interface Members

[image]
ActiveReports 19 .NET Edition
IBuffer<T> Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : IBuffer<T> Interface

Glossary Item Box

The following tables list the members exposed by IBuffer<T>.

Public Methods

 | Name | Description
Method | BufferizeAll | Puts all underlying data to the buffer
Top

See Also

Reference

IBuffer<T> Interface
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


IBuffer<T> Interface Methods

[image]
ActiveReports 19 .NET Edition
IBuffer<T> Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : IBuffer<T> Interface

Glossary Item Box

For a list of all members of this type, see IBuffer<T> members.

Public Methods

 | Name | Description
Method | BufferizeAll | Puts all underlying data to the buffer
Top

See Also

Reference

IBuffer<T> Interface
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


BufferizeAll Method

[image]
ActiveReports 19 .NET Edition
BufferizeAll Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace > IBuffer<T> Interface : BufferizeAll Method

Glossary Item Box

Puts all underlying data to the buffer

Syntax

Visual Basic (Declaration)
Sub BufferizeAll()
C#
void BufferizeAll()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuffer<T> Interface
IBuffer<T> Members


CompoundExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
CompoundExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : CompoundExpressionInfo Class

Glossary Item Box

Represents unary or binary expression.

Object Model

CompoundExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CompoundExpressionInfo
   Inherits ExpressionInfo
C#
public sealed class CompoundExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.CompoundExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


CompoundExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
CompoundExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : CompoundExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by CompoundExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | CompoundExpressionInfo Constructor | Initializes a new instance of the CompoundExpressionInfo class with the specified parameters
Top

Public Properties

 | Name | Description
Public Property | InfoLeft | Left expression. Null for unary expressions.
Public Property | InfoRight | Right expression
Public Property | IsConstant | Overridden. Gets if this ExpressionInfo contains only constant values.
Public Property | OperatorType | Expression operator.
Top

Public Methods

 | Name | Description
Public Method | Children | Overridden. Returns ExpressionInfo Children
Public Method | Equals | Overloaded. Overridden. Implements Equals method
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Implements GetHashCode method
Top

See Also

Reference

CompoundExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


CompoundExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
CompoundExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : CompoundExpressionInfo Constructor

expression
The string representation of the compound expression. If null or empty, it will be generated automatically.
resultType
The expected result type of the expression evaluation.
infoLeft
The ExpressionInfo for the left side of the expression. This is null for unary expressions.
infoRight
The ExpressionInfo for the right side of the expression.
operatorType
The type of operator that defines the relationship between infoLeft and infoRight.

Glossary Item Box

Initializes a new instance of the CompoundExpressionInfo class with the specified parameters

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal resultType As ExpressionResultType, _
   ByVal infoLeft As ExpressionInfo, _
   ByVal infoRight As ExpressionInfo, _
   ByVal operatorType As OperatorType _
)
C#
public CompoundExpressionInfo(
   string expression,
   ExpressionResultType resultType,
   ExpressionInfo infoLeft,
   ExpressionInfo infoRight,
   OperatorType operatorType
)

Parameters

expression
The string representation of the compound expression. If null or empty, it will be generated automatically.
resultType
The expected result type of the expression evaluation.
infoLeft
The ExpressionInfo for the left side of the expression. This is null for unary expressions.
infoRight
The ExpressionInfo for the right side of the expression.
operatorType
The type of operator that defines the relationship between infoLeft and infoRight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


CompoundExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
CompoundExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : CompoundExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see CompoundExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Overridden. Returns ExpressionInfo Children
Public Method | Equals | Overloaded. Overridden. Implements Equals method
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Implements GetHashCode method
Top

See Also

Reference

CompoundExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : Children Method

Glossary Item Box

Returns ExpressionInfo Children

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Children() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> Children()

Return Value

ExpressionInfo children

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : Equals Method

Glossary Item Box

Implements Equals method

Overload List

Overload | Description
Equals(ExpressionInfo) | Implements Equals method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression
expression to compare with

Glossary Item Box

Implements Equals method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression
expression to compare with

Return Value

True if expressions are equal, false otherwise

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

expression string

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : GetHashCode Method

Glossary Item Box

Implements GetHashCode method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

Hash code

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


CompoundExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
CompoundExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : CompoundExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see CompoundExpressionInfo members.

Public Properties

 | Name | Description
Public Property | InfoLeft | Left expression. Null for unary expressions.
Public Property | InfoRight | Right expression
Public Property | IsConstant | Overridden. Gets if this ExpressionInfo contains only constant values.
Public Property | OperatorType | Expression operator.
Top

See Also

Reference

CompoundExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


InfoLeft Property

[image]
ActiveReports 19 .NET Edition
InfoLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : InfoLeft Property

Glossary Item Box

Left expression. Null for unary expressions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InfoLeft As ExpressionInfo
C#
public ExpressionInfo InfoLeft {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


InfoRight Property

[image]
ActiveReports 19 .NET Edition
InfoRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : InfoRight Property

Glossary Item Box

Right expression

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InfoRight As ExpressionInfo
C#
public ExpressionInfo InfoRight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


IsConstant Property

[image]
ActiveReports 19 .NET Edition
IsConstant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : IsConstant Property

Glossary Item Box

Gets if this ExpressionInfo contains only constant values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsConstant As Boolean
C#
public override bool IsConstant {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


OperatorType Property

[image]
ActiveReports 19 .NET Edition
OperatorType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > CompoundExpressionInfo Class : OperatorType Property

Glossary Item Box

Expression operator.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperatorType As OperatorType
C#
public OperatorType OperatorType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompoundExpressionInfo Class
CompoundExpressionInfo Members


ConstantExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
ConstantExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ConstantExpressionInfo Class

Glossary Item Box

Represents an expression that is a constant value.

Object Model

ConstantExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConstantExpressionInfo
   Inherits ExpressionInfo
C#
public sealed class ConstantExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.ConstantExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


ConstantExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
ConstantExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ConstantExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by ConstantExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | ConstantExpressionInfo Constructor | Initializes a new instance of the ConstantExpressionInfo class.
Top

Public Properties

 | Name | Description
Public Property | IsConstant | Overridden. Gets if this ExpressionInfo contains only constant values.
Public Property | IsExpression | Overridden. See ExpressionInfo.IsExpression.
Public Property | Value | Gets ConstantExpressionInfo result value
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Overridden. Implements Equals operator
Public Method | GenerateExpressionString | Overridden. Generates string for the expression
Public Method | GetHashCode | Overridden. Implement GetHashCode operator
Top

See Also

Reference

ConstantExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


ConstantExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
ConstantExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : ConstantExpressionInfo Constructor

expression
A string containing the expression this object represents.
constantResult
The constant resulting value for this expression when GetConstantResult is called. This may be the same as the expression (e.g. \"1\"=="1") or not (\"hello world\"==hello world).
resultType
The data type of this expression's resulting value.
isExpression
True if this object represents an actual expression, or false if it represents a literal string, not to be interpreted as an expression (this value will be used as the value of ExpressionInfo.IsExpression.

Glossary Item Box

Initializes a new instance of the ConstantExpressionInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal constantResult As Object, _
   ByVal resultType As ExpressionResultType, _
   ByVal isExpression As Boolean _
)
C#
public ConstantExpressionInfo(
   string expression,
   object constantResult,
   ExpressionResultType resultType,
   bool isExpression
)

Parameters

expression
A string containing the expression this object represents.
constantResult
The constant resulting value for this expression when GetConstantResult is called. This may be the same as the expression (e.g. \"1\"=="1") or not (\"hello world\"==hello world).
resultType
The data type of this expression's resulting value.
isExpression
True if this object represents an actual expression, or false if it represents a literal string, not to be interpreted as an expression (this value will be used as the value of ExpressionInfo.IsExpression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


ConstantExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
ConstantExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ConstantExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see ConstantExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Overridden. Implements Equals operator
Public Method | GenerateExpressionString | Overridden. Generates string for the expression
Public Method | GetHashCode | Overridden. Implement GetHashCode operator
Top

See Also

Reference

ConstantExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : Equals Method

Glossary Item Box

Implements Equals operator

Overload List

Overload | Description
Equals(ExpressionInfo) | Implements Equals operator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression
expression to compare with

Glossary Item Box

Implements Equals operator

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression
expression to compare with

Return Value

True if expressions are equal, false otherwise

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates string for the expression

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

string representation of expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : GetHashCode Method

Glossary Item Box

Implement GetHashCode operator

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

hash code

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


ConstantExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ConstantExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ConstantExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see ConstantExpressionInfo members.

Public Properties

 | Name | Description
Public Property | IsConstant | Overridden. Gets if this ExpressionInfo contains only constant values.
Public Property | IsExpression | Overridden. See ExpressionInfo.IsExpression.
Public Property | Value | Gets ConstantExpressionInfo result value
Top

See Also

Reference

ConstantExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


IsConstant Property

[image]
ActiveReports 19 .NET Edition
IsConstant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : IsConstant Property

Glossary Item Box

Gets if this ExpressionInfo contains only constant values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsConstant As Boolean
C#
public override bool IsConstant {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


IsExpression Property

[image]
ActiveReports 19 .NET Edition
IsExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : IsExpression Property

Glossary Item Box

See ExpressionInfo.IsExpression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsExpression As Boolean
C#
public override bool IsExpression {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ConstantExpressionInfo Class : Value Property

Glossary Item Box

Gets ConstantExpressionInfo result value

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantExpressionInfo Class
ConstantExpressionInfo Members


ExpressionExtensions Class

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

Provides additional methods to work with ExpressionInfo instances.

Object Model

ExpressionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ExpressionExtensions
C#
public static class ExpressionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Members
GrapeCity.Enterprise.Data.Expressions Namespace


ExpressionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

The following tables list the members exposed by ExpressionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FindReference | Searches for the specified reference type (Identifier or MethodName).
static (Shared in Visual Basic) | HasRefsToId | Checks if a given expression is Identifier with a given name or complex expression that contains Identifier with a given name.
static (Shared in Visual Basic) | IsFunc | Checks if given expression is function from a given list.
static (Shared in Visual Basic) | IsId | Checks if a given expression is Identifier with a given name.
static (Shared in Visual Basic) | IsNullOrEmpty | Сhecks whether the given expression is empty.
static (Shared in Visual Basic) | IsValid | Returns a value that indicates whether the given expression is valid.
static (Shared in Visual Basic) | Not | Returns the inverse of this expression.
static (Shared in Visual Basic) | Replace | Re-creates new expression tree with renamed identifier.
static (Shared in Visual Basic) | ReplaceIdentifier | Replaces all occurrences of the identifier in current expression, using provided function.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.Expressions Namespace


ExpressionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionExtensions Class

Glossary Item Box

For a list of all members of this type, see ExpressionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FindReference | Searches for the specified reference type (Identifier or MethodName).
static (Shared in Visual Basic) | HasRefsToId | Checks if a given expression is Identifier with a given name or complex expression that contains Identifier with a given name.
static (Shared in Visual Basic) | IsFunc | Checks if given expression is function from a given list.
static (Shared in Visual Basic) | IsId | Checks if a given expression is Identifier with a given name.
static (Shared in Visual Basic) | IsNullOrEmpty | Сhecks whether the given expression is empty.
static (Shared in Visual Basic) | IsValid | Returns a value that indicates whether the given expression is valid.
static (Shared in Visual Basic) | Not | Returns the inverse of this expression.
static (Shared in Visual Basic) | Replace | Re-creates new expression tree with renamed identifier.
static (Shared in Visual Basic) | ReplaceIdentifier | Replaces all occurrences of the identifier in current expression, using provided function.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.Expressions Namespace


FindReference Method

[image]
ActiveReports 19 .NET Edition
FindReference Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : FindReference Method

e
Expression to search reference in.
refName
Name to search.

Glossary Item Box

Searches for the specified reference type (Identifier or MethodName).

Syntax

Visual Basic (Declaration)
Public Shared Function FindReference( _
   ByVal e As ExpressionInfo, _
   ByVal refName As String _
) As ExpressionInfo
C#
public static ExpressionInfo FindReference(
   ExpressionInfo e,
   string refName
)

Parameters

e
Expression to search reference in.
refName
Name to search.

Return Value

Finds expression that contains specified reference or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


HasRefsToId Method

[image]
ActiveReports 19 .NET Edition
HasRefsToId Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : HasRefsToId Method

expr
name

Glossary Item Box

Checks if a given expression is Identifier with a given name or complex expression that contains Identifier with a given name.

Syntax

Visual Basic (Declaration)
Public Shared Function HasRefsToId( _
   ByVal expr As ExpressionInfo, _
   ByVal name As String _
) As Boolean
C#
public static bool HasRefsToId(
   ExpressionInfo expr,
   string name
)

Parameters

expr
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


IsFunc Method

[image]
ActiveReports 19 .NET Edition
IsFunc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : IsFunc Method

t
Expression to check.
names
Function names to search.

Glossary Item Box

Checks if given expression is function from a given list.

Syntax

Visual Basic (Declaration)
Public Shared Function IsFunc( _
   ByVal t As ExpressionInfo, _
   ByVal ParamArray names() As String _
) As Boolean
C#
public static bool IsFunc(
   ExpressionInfo t,
   params string[] names
)

Parameters

t
Expression to check.
names
Function names to search.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


IsId Method

[image]
ActiveReports 19 .NET Edition
IsId Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : IsId Method

e
name

Glossary Item Box

Checks if a given expression is Identifier with a given name.

Syntax

Visual Basic (Declaration)
Public Shared Function IsId( _
   ByVal e As ExpressionInfo, _
   ByVal name As String _
) As Boolean
C#
public static bool IsId(
   ExpressionInfo e,
   string name
)

Parameters

e
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


IsNullOrEmpty Method

[image]
ActiveReports 19 .NET Edition
IsNullOrEmpty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : IsNullOrEmpty Method

expression

Glossary Item Box

Сhecks whether the given expression is empty.

Syntax

Visual Basic (Declaration)
Public Shared Function IsNullOrEmpty( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public static bool IsNullOrEmpty(
   ExpressionInfo expression
)

Parameters

expression

Return Value

True if the given expression is empty, false otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : IsValid Method

expression
The ExpressionInfo instance to be validated.

Glossary Item Box

Returns a value that indicates whether the given expression is valid.

Syntax

Visual Basic (Declaration)
Public Shared Function IsValid( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public static bool IsValid(
   ExpressionInfo expression
)

Parameters

expression
The ExpressionInfo instance to be validated.

Return Value

True if the given expression is valid, false otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


Not Method

[image]
ActiveReports 19 .NET Edition
Not Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : Not Method

originalExpression
Original expression.

Glossary Item Box

Returns the inverse of this expression.

Syntax

Visual Basic (Declaration)
Public Shared Function Not( _
   ByVal originalExpression As ExpressionInfo _
) As ExpressionInfo
C#
public static ExpressionInfo Not(
   ExpressionInfo originalExpression
)

Parameters

originalExpression
Original expression.

Return Value

The inverse of this expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


Replace(ExpressionInfo,Func<ExpressionInfo,ExpressionInfo>) Method

[image]
ActiveReports 19 .NET Edition
Replace(ExpressionInfo,Func<ExpressionInfo,ExpressionInfo>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : Replace(ExpressionInfo,Func<ExpressionInfo,ExpressionInfo>) Method

e
Expression.
replacer
Replacer function.

Glossary Item Box

Re-creates new expression tree with renamed identifier.

Syntax

Visual Basic (Declaration)
Public Shared Function Replace( _
   ByVal e As ExpressionInfo, _
   ByVal replacer As Func(Of ExpressionInfo,ExpressionInfo) _
) As ExpressionInfo
C#
public static ExpressionInfo Replace(
   ExpressionInfo e,
   Func<ExpressionInfo,ExpressionInfo> replacer
)

Parameters

e
Expression.
replacer
Replacer function.

Return Value

New expression tree with renamed identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


ReplaceIdentifier Method

[image]
ActiveReports 19 .NET Edition
ReplaceIdentifier Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : ReplaceIdentifier Method

originalExpression
Original expression.
replacer
Replacing function.

Glossary Item Box

Replaces all occurrences of the identifier in current expression, using provided function.

Syntax

Visual Basic (Declaration)
Public Shared Function ReplaceIdentifier( _
   ByVal originalExpression As ExpressionInfo, _
   ByVal replacer As Func(Of String,String) _
) As ExpressionInfo
C#
public static ExpressionInfo ReplaceIdentifier(
   ExpressionInfo originalExpression,
   Func<string,string> replacer
)

Parameters

originalExpression
Original expression.
replacer
Replacing function.

Return Value

New ExpressionInfo instance with replaced identifier or exact instance if no changes were made.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


ExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
ExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionInfo Class

Glossary Item Box

The ExpressionInfo class stores, parses, and provides information about an expression. ExpressionInfo provides aggregates, global collections, etc., as well as information about the expected data type of the expression's result.

Object Model

ExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ExpressionInfo
C#
public abstract class ExpressionInfo

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.CompoundExpressionInfo
GrapeCity.Enterprise.Data.Expressions.ConstantExpressionInfo
GrapeCity.Enterprise.Data.Expressions.FunctionExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IdentifierExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IntrinsicCastExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NewExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NothingExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


ExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionInfo Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by ExpressionInfo.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EmptyString | Returns a reference to an ExpressionInfo object representing a constant empty string expression.
Top

Public Properties

 | Name | Description
Public Property | Expression | Gets the original expression string.
Public Property | IsConstant | Gets a value indicating whether the ExpressionInfo object represents a constant value.
Public Property | IsEmptyString | Get the value indicating if the expression represents an empty string.
Public Property | IsExpression | Gets a value indicating whether the ExpressionInfo object represents a dynamic expression.
Public Property | ResultType | Gets the expected data type of the expression evaluation result.
Top

Public Methods

 | Name | Description
Public Method | Children | Returns the subexpressions that make up the given expression.
Public Method | CompareTo | Compares this instance to a specified object and returns an integer that indicates their relationship to one another.
Public Method | Equals | Overloaded. Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
static (Shared in Visual Basic) | FromString | Creates an ExpressionInfo object from a string expression representation.
Public Method | GenerateExpressionString | Generates the expression string.
Public Method | GetHashCode | Serves as the default hash function.
static (Shared in Visual Basic) | Parse | Overloaded. Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Public Method | ToString | Returns the string representation of this ExpressionInfo object.
Public Method | Validate | Checks if the expression contains any errors.
Top

Public Operators

public Operator Equality | Determines whether the two ExpressionInfo objects represent the same expression.
public Operator Implicit Type Conversion | Overloaded. Defines an operator that allows implicit conversion from an ExpressionInfo to a System.String.
public Operator Inequality | Determines whether the specified ExpressionInfo objects represent different expressions.
Top

See Also

Reference

ExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


ExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Returns the subexpressions that make up the given expression.
Public Method | CompareTo | Compares this instance to a specified object and returns an integer that indicates their relationship to one another.
Public Method | Equals | Overloaded. Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
static (Shared in Visual Basic) | FromString | Creates an ExpressionInfo object from a string expression representation.
Public Method | GenerateExpressionString | Generates the expression string.
Public Method | GetHashCode | Serves as the default hash function.
static (Shared in Visual Basic) | Parse | Overloaded. Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Public Method | ToString | Returns the string representation of this ExpressionInfo object.
Public Method | Validate | Checks if the expression contains any errors.
Top

See Also

Reference

ExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Children Method

Glossary Item Box

Returns the subexpressions that make up the given expression.

Syntax

Visual Basic (Declaration)
Public Overridable Function Children() As IEnumerable(Of ExpressionInfo)
C#
public virtual IEnumerable<ExpressionInfo> Children()

Remarks

In most cases, if an expression is not a constant, it is composed of other smaller expressions. These could be the left and right operands for a binary expression, arguments to a function, etc. Subexpressions, in turn, can also consist of expressions. This function returns only expressions at the first level of nesting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


CompareTo Method

[image]
ActiveReports 19 .NET Edition
CompareTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : CompareTo Method

obj
A System.Boolean object to compare to this instance.

Glossary Item Box

Compares this instance to a specified object and returns an integer that indicates their relationship to one another.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
A System.Boolean object to compare to this instance.

Return Value

A signed integer that indicates the relative values of this instance and obj.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Equals Method

Glossary Item Box

Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.

Overload List

Overload | Description
Equals(Object) | Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Equals(ExpressionInfo) | Determines whether the specified ExpressionInfo object represents the same expression as this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Equals Method : Equals(Object) Method

expression

Glossary Item Box

Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal expression As Object _
) As Boolean
C#
public override bool Equals(
   object expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public virtual bool Equals(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


FromString(String,ExpressionResultType) Method

[image]
ActiveReports 19 .NET Edition
FromString(String,ExpressionResultType) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > FromString Method : FromString(String,ExpressionResultType) Method

expressionString
The expression string.
type
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.

Glossary Item Box

Creates an ExpressionInfo object from a string expression representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromString( _
   ByVal expressionString As String, _
   ByVal type As ExpressionResultType _
) As ExpressionInfo
C#
public static ExpressionInfo FromString(
   string expressionString,
   ExpressionResultType type
)

Parameters

expressionString
The expression string.
type
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.

Return Value

an ExpressionInfo object that represents the specified expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates the expression string.

Syntax

Visual Basic (Declaration)
Public Overridable Function GenerateExpressionString() As String
C#
public virtual string GenerateExpressionString()

Return Value

A System.String value representing this expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Parse Method

[image]
ActiveReports 19 .NET Edition
Parse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Parse Method

Glossary Item Box

Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.

Overload List

Overload | Description
Parse(String) | Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Parse(String,ExpressionResultType) | Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Parse(String) Method

[image]
ActiveReports 19 .NET Edition
Parse(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Parse Method : Parse(String) Method

expressionString
String to parse

Glossary Item Box

Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal expressionString As String _
) As ExpressionInfo
C#
public static ExpressionInfo Parse(
   string expressionString
)

Parameters

expressionString
String to parse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Parse(String,ExpressionResultType) Method

[image]
ActiveReports 19 .NET Edition
Parse(String,ExpressionResultType) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Parse Method : Parse(String,ExpressionResultType) Method

expressionString
The string to parse
subType
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.

Glossary Item Box

Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal expressionString As String, _
   ByVal subType As ExpressionResultType _
) As ExpressionInfo
C#
public static ExpressionInfo Parse(
   string expressionString,
   ExpressionResultType subType
)

Parameters

expressionString
The string to parse
subType
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.

Return Value

An ExpressionInfo object that represents the specified expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : ToString Method

Glossary Item Box

Returns the string representation of this ExpressionInfo object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Remarks

The resulting System.String value can be used for the serialization and deserialization with further parsing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Validate Method

Glossary Item Box

Checks if the expression contains any errors.

Syntax

Visual Basic (Declaration)
Public Function Validate() As ValidationResults
C#
public ValidationResults Validate()

Return Value

ValidationResults object which represents the validation errors list.

Remarks

Validation is performed once for a specific ExpressionInfo instance, the result is cached and can be obtained by calling this method again.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfo members.

Public Properties

 | Name | Description
Public Property | Expression | Gets the original expression string.
Public Property | IsConstant | Gets a value indicating whether the ExpressionInfo object represents a constant value.
Public Property | IsEmptyString | Get the value indicating if the expression represents an empty string.
Public Property | IsExpression | Gets a value indicating whether the ExpressionInfo object represents a dynamic expression.
Public Property | ResultType | Gets the expected data type of the expression evaluation result.
Top

See Also

Reference

ExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Expression Property

[image]
ActiveReports 19 .NET Edition
Expression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Expression Property

Glossary Item Box

Gets the original expression string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Expression As String
C#
public string Expression {get;}

Property Value

A System.String representing original expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


IsConstant Property

[image]
ActiveReports 19 .NET Edition
IsConstant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : IsConstant Property

Glossary Item Box

Gets a value indicating whether the ExpressionInfo object represents a constant value.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsConstant As Boolean
C#
public virtual bool IsConstant {get;}

Property Value

A System.Boolean value. true if the ExpressionInfo object represents constant value, otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


IsEmptyString Property

[image]
ActiveReports 19 .NET Edition
IsEmptyString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : IsEmptyString Property

Glossary Item Box

Get the value indicating if the expression represents an empty string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmptyString As Boolean
C#
public bool IsEmptyString {get;}

Property Value

A System.Boolean value. true if the expression is empty string; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


IsExpression Property

[image]
ActiveReports 19 .NET Edition
IsExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : IsExpression Property

Glossary Item Box

Gets a value indicating whether the ExpressionInfo object represents a dynamic expression.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsExpression As Boolean
C#
public virtual bool IsExpression {get;}

Property Value

A System.Boolean value. true if this object represents an actual dynamic expression. false if the expression should be taken as a literal string value.

Remarks

Essentially if the expression was prefixed with an equal sign, it would be determined to be an expression. Otherwise, it would NOT be considered an expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ResultType Property

[image]
ActiveReports 19 .NET Edition
ResultType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : ResultType Property

Glossary Item Box

Gets the expected data type of the expression evaluation result.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultType As ExpressionResultType
C#
public ExpressionResultType ResultType {get;}

Property Value

The one of the ExpressionResultType enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ExpressionInfo Class Fields

[image]
ActiveReports 19 .NET Edition
ExpressionInfo Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfo members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EmptyString | Returns a reference to an ExpressionInfo object representing a constant empty string expression.
Top

See Also

Reference

ExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


EmptyString Field

[image]
ActiveReports 19 .NET Edition
EmptyString Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : EmptyString Field

Glossary Item Box

Returns a reference to an ExpressionInfo object representing a constant empty string expression.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EmptyString As ExpressionInfo
C#
public static readonly ExpressionInfo EmptyString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Equality Operator

expression1
expression2

Glossary Item Box

Determines whether the two ExpressionInfo objects represent the same expression.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal expression1 As ExpressionInfo, _
   ByVal expression2 As ExpressionInfo _
) As Boolean
C#
public bool operator ==(
   ExpressionInfo expression1,
   ExpressionInfo expression2
)

Parameters

expression1
expression2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Implicit Type Conversion Operator

Glossary Item Box

Defines an operator that allows implicit conversion from an ExpressionInfo to a System.String.

Overload List

Overload | Description
Implicit Type Conversion(String,ExpressionInfo) | Defines an operator that allows implicit conversion from an ExpressionInfo to a System.String.
Implicit Type Conversion(ExpressionInfo,String) | Defines an operator that allows implicit conversion from a System.String to an ExpressionInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : Inequality Operator

expression1
expression2

Glossary Item Box

Determines whether the specified ExpressionInfo objects represent different expressions.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal expression1 As ExpressionInfo, _
   ByVal expression2 As ExpressionInfo _
) As Boolean
C#
public bool operator !=(
   ExpressionInfo expression1,
   ExpressionInfo expression2
)

Parameters

expression1
expression2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


FunctionExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
FunctionExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : FunctionExpressionInfo Class

Glossary Item Box

Represents an expression that is a constant value.

Object Model

FunctionExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FunctionExpressionInfo
   Inherits ExpressionInfo
C#
public sealed class FunctionExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.FunctionExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


FunctionExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
FunctionExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : FunctionExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by FunctionExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | FunctionExpressionInfo Constructor | Initializes a new instance of the FunctionExpressionInfo.
Top

Public Properties

 | Name | Description
Public Property | Arguments | Gets call arguments.
Public Property | MethodName | Gets name of method to be called.
Public Property | Qualifier | Gets call target.
Top

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

FunctionExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


FunctionExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
FunctionExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : FunctionExpressionInfo Constructor

expression
resultType
qualifier
method
arguments

Glossary Item Box

Initializes a new instance of the FunctionExpressionInfo.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal resultType As ExpressionResultType, _
   ByVal qualifier As ExpressionInfo, _
   ByVal method As String, _
   ByVal arguments() As ExpressionInfo _
)
C#
public FunctionExpressionInfo(
   string expression,
   ExpressionResultType resultType,
   ExpressionInfo qualifier,
   string method,
   ExpressionInfo[] arguments
)

Parameters

expression
resultType
qualifier
method
arguments

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


FunctionExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
FunctionExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : FunctionExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see FunctionExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

FunctionExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : Children Method

Glossary Item Box

Gets child sub-expressions.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Children() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> Children()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : Equals Method

Glossary Item Box

Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.

Overload List

Overload | Description
Equals(ExpressionInfo) | Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression

Glossary Item Box

Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

expression string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


FunctionExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
FunctionExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : FunctionExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see FunctionExpressionInfo members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets call arguments.
Public Property | MethodName | Gets name of method to be called.
Public Property | Qualifier | Gets call target.
Top

See Also

Reference

FunctionExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Arguments Property

[image]
ActiveReports 19 .NET Edition
Arguments Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : Arguments Property

Glossary Item Box

Gets call arguments.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As ExpressionInfo()
C#
public ExpressionInfo[] Arguments {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


MethodName Property

[image]
ActiveReports 19 .NET Edition
MethodName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : MethodName Property

Glossary Item Box

Gets name of method to be called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MethodName As String
C#
public string MethodName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


Qualifier Property

[image]
ActiveReports 19 .NET Edition
Qualifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > FunctionExpressionInfo Class : Qualifier Property

Glossary Item Box

Gets call target.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Qualifier As ExpressionInfo
C#
public ExpressionInfo Qualifier {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FunctionExpressionInfo Class
FunctionExpressionInfo Members


IdentifierExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IdentifierExpressionInfo Class

Glossary Item Box

Represents an identifier in an expression, such as constants or enums.

Object Model

IdentifierExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public Class IdentifierExpressionInfo
   Inherits ExpressionInfo
C#
public class IdentifierExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IdentifierExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


IdentifierExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IdentifierExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by IdentifierExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | IdentifierExpressionInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Identifier | Gets identifier name referenced by this expression.
Public Property | Qualifier | Gets expression qualifier
Top

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

IdentifierExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


IdentifierExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : IdentifierExpressionInfo Constructor

Glossary Item Box

Overload List

Overload | Description
IdentifierExpressionInfo Constructor(String,ExpressionResultType,ExpressionInfo,String) | Initializes a new instance of the ExpressionInfo class.
IdentifierExpressionInfo Constructor(String,ExpressionResultType,String) | Initializes a new instance of the ExpressionInfo class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


IdentifierExpressionInfo Constructor(String,ExpressionResultType,ExpressionInfo,String)

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Constructor(String,ExpressionResultType,ExpressionInfo,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class > IdentifierExpressionInfo Constructor : IdentifierExpressionInfo Constructor(String,ExpressionResultType,ExpressionInfo,String)

expression
The string representation of the expression. If null or empty, it will be generated based on the identifier and optional qualifier.
resultType
The type of result expected from evaluating the expression.
qualifier
An ExpressionInfo that qualifies the identifier.
identifier
The name of the identifier represented by this expression.

Glossary Item Box

Initializes a new instance of the ExpressionInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal resultType As ExpressionResultType, _
   ByVal qualifier As ExpressionInfo, _
   ByVal identifier As String _
)
C#
public IdentifierExpressionInfo(
   string expression,
   ExpressionResultType resultType,
   ExpressionInfo qualifier,
   string identifier
)

Parameters

expression
The string representation of the expression. If null or empty, it will be generated based on the identifier and optional qualifier.
resultType
The type of result expected from evaluating the expression.
qualifier
An ExpressionInfo that qualifies the identifier.
identifier
The name of the identifier represented by this expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members
Overload List


IdentifierExpressionInfo Constructor(String,ExpressionResultType,String)

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Constructor(String,ExpressionResultType,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class > IdentifierExpressionInfo Constructor : IdentifierExpressionInfo Constructor(String,ExpressionResultType,String)

expression
The string representation of the expression. If null or empty, it will be generated based on the identifier.
resultType
The type of result expected from evaluating the expression.
identifier
The name of the identifier represented by this expression.

Glossary Item Box

Initializes a new instance of the ExpressionInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal resultType As ExpressionResultType, _
   ByVal identifier As String _
)
C#
public IdentifierExpressionInfo(
   string expression,
   ExpressionResultType resultType,
   string identifier
)

Parameters

expression
The string representation of the expression. If null or empty, it will be generated based on the identifier.
resultType
The type of result expected from evaluating the expression.
identifier
The name of the identifier represented by this expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members
Overload List


IdentifierExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IdentifierExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see IdentifierExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

IdentifierExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : Children Method

Glossary Item Box

Gets child sub-expressions.

Syntax

Visual Basic (Declaration)
Public Overrides Function Children() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> Children()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : Equals Method

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as this one.

Overload List

Overload | Description
Equals(ExpressionInfo) | Determines whether the specified ExpressionInfo object represents the same expression as this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

expression string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


IdentifierExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
IdentifierExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IdentifierExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see IdentifierExpressionInfo members.

Public Properties

 | Name | Description
Public Property | Identifier | Gets identifier name referenced by this expression.
Public Property | Qualifier | Gets expression qualifier
Top

See Also

Reference

IdentifierExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Identifier Property

[image]
ActiveReports 19 .NET Edition
Identifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : Identifier Property

Glossary Item Box

Gets identifier name referenced by this expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Identifier As String
C#
public string Identifier {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


Qualifier Property

[image]
ActiveReports 19 .NET Edition
Qualifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IdentifierExpressionInfo Class : Qualifier Property

Glossary Item Box

Gets expression qualifier

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Qualifier As ExpressionInfo
C#
public ExpressionInfo Qualifier {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IdentifierExpressionInfo Class
IdentifierExpressionInfo Members


IntrinsicCastExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
IntrinsicCastExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IntrinsicCastExpressionInfo Class

Glossary Item Box

Represents type cast expression.

Object Model

IntrinsicCastExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IntrinsicCastExpressionInfo
   Inherits ExpressionInfo
C#
public sealed class IntrinsicCastExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IntrinsicCastExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


IntrinsicCastExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
IntrinsicCastExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IntrinsicCastExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by IntrinsicCastExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | IntrinsicCastExpressionInfo Constructor | Creates a new ExpressionInfo that has a sub-expression that is cast based on the Intrinsic type.
Top

Public Properties

 | Name | Description
Public Property | IntrinsicType | Gets IntrinsicType
Public Property | IsExpression | Overridden. Returns true if this object represents an actual dynamic expression. Returns false if the expression should be taken as a literal string value.
Public Property | Value | Gets value as ExpressionInfo
Top

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Implements Equals method
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Implements GetHashCode()
Top

See Also

Reference

IntrinsicCastExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


IntrinsicCastExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
IntrinsicCastExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : IntrinsicCastExpressionInfo Constructor

expression
castedExpression
resultType
intrinsicType

Glossary Item Box

Creates a new ExpressionInfo that has a sub-expression that is cast based on the Intrinsic type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal castedExpression As ExpressionInfo, _
   ByVal resultType As ExpressionResultType, _
   ByVal intrinsicType As IntrinsicType _
)
C#
public IntrinsicCastExpressionInfo(
   string expression,
   ExpressionInfo castedExpression,
   ExpressionResultType resultType,
   IntrinsicType intrinsicType
)

Parameters

expression
castedExpression
resultType
intrinsicType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


IntrinsicCastExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
IntrinsicCastExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IntrinsicCastExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see IntrinsicCastExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Implements Equals method
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Implements GetHashCode()
Top

See Also

Reference

IntrinsicCastExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : Children Method

Glossary Item Box

Gets child sub-expressions.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Children() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> Children()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : Equals Method

Glossary Item Box

Implements Equals method

Overload List

Overload | Description
Equals(ExpressionInfo) | Implements Equals method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression
expressions

Glossary Item Box

Implements Equals method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression
expressions

Return Value

if expressions are equal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

expression string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : GetHashCode Method

Glossary Item Box

Implements GetHashCode()

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

Hash code

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


IntrinsicCastExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
IntrinsicCastExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : IntrinsicCastExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see IntrinsicCastExpressionInfo members.

Public Properties

 | Name | Description
Public Property | IntrinsicType | Gets IntrinsicType
Public Property | IsExpression | Overridden. Returns true if this object represents an actual dynamic expression. Returns false if the expression should be taken as a literal string value.
Public Property | Value | Gets value as ExpressionInfo
Top

See Also

Reference

IntrinsicCastExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


IntrinsicType Property

[image]
ActiveReports 19 .NET Edition
IntrinsicType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : IntrinsicType Property

Glossary Item Box

Gets IntrinsicType

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IntrinsicType As IntrinsicType
C#
public IntrinsicType IntrinsicType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


IsExpression Property

[image]
ActiveReports 19 .NET Edition
IsExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : IsExpression Property

Glossary Item Box

Returns true if this object represents an actual dynamic expression. Returns false if the expression should be taken as a literal string value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsExpression As Boolean
C#
public override bool IsExpression {get;}

Remarks

Essentially if the expression was prefixed with an equal sign, it would be determined to be an expression. Otherwise it would NOT be considered an expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > IntrinsicCastExpressionInfo Class : Value Property

Glossary Item Box

Gets value as ExpressionInfo

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntrinsicCastExpressionInfo Class
IntrinsicCastExpressionInfo Members


NewExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
NewExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NewExpressionInfo Class

Glossary Item Box

Represents a constructor in an expression, such as new.

Object Model

NewExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public Class NewExpressionInfo
   Inherits ExpressionInfo
C#
public class NewExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NewExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


NewExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
NewExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NewExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by NewExpressionInfo.

Public Constructors

 | Name | Description
Public Constructor | NewExpressionInfo Constructor | Initializes a new instance of the NewExpressionInfo class
Top

Public Properties

 | Name | Description
Public Property | Arguments | Gets call arguments.
Public Property | QualifierName | Gets qualifier name
Top

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

NewExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


NewExpressionInfo Constructor

[image]
ActiveReports 19 .NET Edition
NewExpressionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : NewExpressionInfo Constructor

expression
expression
resultType
result type
qualifierName
qualifier name
arguments
arguments

Glossary Item Box

Initializes a new instance of the NewExpressionInfo class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal resultType As ExpressionResultType, _
   ByVal qualifierName As String, _
   ByVal arguments() As ExpressionInfo _
)
C#
public NewExpressionInfo(
   string expression,
   ExpressionResultType resultType,
   string qualifierName,
   ExpressionInfo[] arguments
)

Parameters

expression
expression
resultType
result type
qualifierName
qualifier name
arguments
arguments

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


NewExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
NewExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NewExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see NewExpressionInfo members.

Public Methods

 | Name | Description
Public Method | Children | Overridden. Gets child sub-expressions.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

NewExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Children Method

[image]
ActiveReports 19 .NET Edition
Children Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : Children Method

Glossary Item Box

Gets child sub-expressions.

Syntax

Visual Basic (Declaration)
Public Overrides Function Children() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> Children()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : Equals Method

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as this one.

Overload List

Overload | Description
Equals(ExpressionInfo) | Determines whether the specified ExpressionInfo object represents the same expression as this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as this one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

expression string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


NewExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
NewExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NewExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see NewExpressionInfo members.

Public Properties

 | Name | Description
Public Property | Arguments | Gets call arguments.
Public Property | QualifierName | Gets qualifier name
Top

See Also

Reference

NewExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Arguments Property

[image]
ActiveReports 19 .NET Edition
Arguments Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : Arguments Property

Glossary Item Box

Gets call arguments.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As ExpressionInfo()
C#
public ExpressionInfo[] Arguments {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


QualifierName Property

[image]
ActiveReports 19 .NET Edition
QualifierName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NewExpressionInfo Class : QualifierName Property

Glossary Item Box

Gets qualifier name

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QualifierName As String
C#
public string QualifierName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewExpressionInfo Class
NewExpressionInfo Members


NothingExpressionInfo Class

[image]
ActiveReports 19 .NET Edition
NothingExpressionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NothingExpressionInfo Class

Glossary Item Box

Represents the value "Nothing" in the ExpressionInfo.

Object Model

NothingExpressionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NothingExpressionInfo
   Inherits ExpressionInfo
C#
public sealed class NothingExpressionInfo : ExpressionInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NothingExpressionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Members
GrapeCity.Enterprise.Data.Expressions Namespace


NothingExpressionInfo Class Members

[image]
ActiveReports 19 .NET Edition
NothingExpressionInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NothingExpressionInfo Class

Glossary Item Box

The following tables list the members exposed by NothingExpressionInfo.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Returns an instance of NothingExpressionInfo.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as the given one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

NothingExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


NothingExpressionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
NothingExpressionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NothingExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see NothingExpressionInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Returns an instance of NothingExpressionInfo.
Public Method | Equals | Overloaded. Overridden. Determines whether the specified ExpressionInfo object represents the same expression as the given one.
Public Method | GenerateExpressionString | Overridden. Generates expression string
Public Method | GetHashCode | Overridden. Generates a HashCode for this expression.
Top

See Also

Reference

NothingExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NothingExpressionInfo Class : Create Method

Glossary Item Box

Returns an instance of NothingExpressionInfo.

Syntax

Visual Basic (Declaration)
Public Shared Function Create() As NothingExpressionInfo
C#
public static NothingExpressionInfo Create()

Return Value

an instance of NothingExpressionInfo

Remarks

This class is using a Create method to permit using a singleton instance. If it becomes necessary to not use a singleton, it will only be necessary to change this function's implementation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Class
NothingExpressionInfo Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NothingExpressionInfo Class : Equals Method

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as the given one.

Overload List

Overload | Description
Equals(ExpressionInfo) | Determines whether the specified ExpressionInfo object represents the same expression as the given one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Class
NothingExpressionInfo Members


Equals(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NothingExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method

expression

Glossary Item Box

Determines whether the specified ExpressionInfo object represents the same expression as the given one.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Equals( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public override bool Equals(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Class
NothingExpressionInfo Members
Overload List


GenerateExpressionString Method

[image]
ActiveReports 19 .NET Edition
GenerateExpressionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NothingExpressionInfo Class : GenerateExpressionString Method

Glossary Item Box

Generates expression string

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GenerateExpressionString() As String
C#
public override string GenerateExpressionString()

Return Value

System.String represents the expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Class
NothingExpressionInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > NothingExpressionInfo Class : GetHashCode Method

Glossary Item Box

Generates a HashCode for this expression.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NothingExpressionInfo Class
NothingExpressionInfo Members


ValidationResults Class

[image]
ActiveReports 19 .NET Edition
ValidationResults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults Class

Glossary Item Box

Represents the results of ExpressionInfo validation.

Object Model

ValidationResults Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationResults
C#
public sealed class ValidationResults

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ValidationResults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults Members
GrapeCity.Enterprise.Data.Expressions Namespace


ValidationResults Class Members

[image]
ActiveReports 19 .NET Edition
ValidationResults Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults Class

Glossary Item Box

The following tables list the members exposed by ValidationResults.

Public Properties

 | Name | Description
Public Property | ErrorDetails | Gets an array of error information (messages and locations).
Public Property | IsValid | Gets whether this expression is valid.
Top

See Also

Reference

ValidationResults Class
GrapeCity.Enterprise.Data.Expressions Namespace


ValidationResults Class Properties

[image]
ActiveReports 19 .NET Edition
ValidationResults Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults Class

Glossary Item Box

For a list of all members of this type, see ValidationResults members.

Public Properties

 | Name | Description
Public Property | ErrorDetails | Gets an array of error information (messages and locations).
Public Property | IsValid | Gets whether this expression is valid.
Top

See Also

Reference

ValidationResults Class
GrapeCity.Enterprise.Data.Expressions Namespace


ErrorDetails Property

[image]
ActiveReports 19 .NET Edition
ErrorDetails Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ValidationResults Class : ErrorDetails Property

Glossary Item Box

Gets an array of error information (messages and locations).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorDetails As ValidationResults.ErrorInformation()
C#
public ValidationResults.ErrorInformation[] ErrorDetails {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults Class
ValidationResults Members


IsValid Property

[image]
ActiveReports 19 .NET Edition
IsValid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ValidationResults Class : IsValid Property

Glossary Item Box

Gets whether this expression is valid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid {get;}

Property Value

True if the expression contains no errors, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults Class
ValidationResults Members


ValidationResults.ErrorInformation Class

[image]
ActiveReports 19 .NET Edition
ValidationResults.ErrorInformation Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults.ErrorInformation Class

Glossary Item Box

Represents the information about an error (message and location).

Object Model

ValidationResults.ErrorInformation Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationResults.ErrorInformation
C#
public sealed class ValidationResults.ErrorInformation

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ValidationResults.ErrorInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults.ErrorInformation Members
GrapeCity.Enterprise.Data.Expressions Namespace


ValidationResults.ErrorInformation Class Members

[image]
ActiveReports 19 .NET Edition
ValidationResults.ErrorInformation Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults.ErrorInformation Class

Glossary Item Box

The following tables list the members exposed by ValidationResults.ErrorInformation.

Public Properties

 | Name | Description
Public Property | ErrorMessage | Gets the error message associated with an expression.
Public Property | ErrorSpan | Gets the GrapeCity.Enterprise.Data.Expressions.Parser.Span defining the locations of the errors associated with an expression.
Top

See Also

Reference

ValidationResults.ErrorInformation Class
GrapeCity.Enterprise.Data.Expressions Namespace


ValidationResults.ErrorInformation Class Properties

[image]
ActiveReports 19 .NET Edition
ValidationResults.ErrorInformation Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ValidationResults.ErrorInformation Class

Glossary Item Box

For a list of all members of this type, see ValidationResults.ErrorInformation members.

Public Properties

 | Name | Description
Public Property | ErrorMessage | Gets the error message associated with an expression.
Public Property | ErrorSpan | Gets the GrapeCity.Enterprise.Data.Expressions.Parser.Span defining the locations of the errors associated with an expression.
Top

See Also

Reference

ValidationResults.ErrorInformation Class
GrapeCity.Enterprise.Data.Expressions Namespace


ErrorMessage Property

[image]
ActiveReports 19 .NET Edition
ErrorMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ValidationResults.ErrorInformation Class : ErrorMessage Property

Glossary Item Box

Gets the error message associated with an expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorMessage As String
C#
public string ErrorMessage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults.ErrorInformation Class
ValidationResults.ErrorInformation Members


ErrorSpan Property

[image]
ActiveReports 19 .NET Edition
ErrorSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ValidationResults.ErrorInformation Class : ErrorSpan Property

Glossary Item Box

Gets the GrapeCity.Enterprise.Data.Expressions.Parser.Span defining the locations of the errors associated with an expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorSpan As Span
C#
public Span ErrorSpan {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationResults.ErrorInformation Class
ValidationResults.ErrorInformation Members


ExpressionResultType Enumeration

[image]
ActiveReports 19 .NET Edition
ExpressionResultType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : ExpressionResultType Enumeration

Glossary Item Box

Specifies the type of the evaluation result of an ExpressionInfo object.

Syntax

Visual Basic (Declaration)
Public Enum ExpressionResultType
   Inherits System.Enum
C#
public enum ExpressionResultType : System.Enum

Members

Member | Description
Binary | Expression results in a Binary type.
Boolean | Expression results in a Boolean type.
DateTime | Expression results in a DateTime type.
Error | Expression results in an Error.
Float | Expression results in a Float type.
Integer | Expression results in an Integer type.
String | Expression results in a String type.
Variant | Expression results in a Variant type.
VariantArray | Expression results in a Variant Array type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.Expressions.ExpressionResultType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.Expressions Namespace


DynamicDispatch Class

[image]
ActiveReports 19 .NET Edition
DynamicDispatch Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : DynamicDispatch Class

Glossary Item Box

Module containing implementation of simple dynamic dispatch.

Object Model

DynamicDispatch Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DynamicDispatch
C#
public static class DynamicDispatch

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Evaluation.DynamicDispatch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicDispatch Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


DynamicDispatch Class Members

[image]
ActiveReports 19 .NET Edition
DynamicDispatch Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : DynamicDispatch Class

Glossary Item Box

The following tables list the members exposed by DynamicDispatch.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Invoke | Invokes an instance method on a given object using dynamic dispatch.
static (Shared in Visual Basic) | InvokeStatic | Invokes static method.
static (Shared in Visual Basic) | IsPrimitive | Checks if a given type is a primitive type
Top

See Also

Reference

DynamicDispatch Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


DynamicDispatch Class Methods

[image]
ActiveReports 19 .NET Edition
DynamicDispatch Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : DynamicDispatch Class

Glossary Item Box

For a list of all members of this type, see DynamicDispatch members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Invoke | Invokes an instance method on a given object using dynamic dispatch.
static (Shared in Visual Basic) | InvokeStatic | Invokes static method.
static (Shared in Visual Basic) | IsPrimitive | Checks if a given type is a primitive type
Top

See Also

Reference

DynamicDispatch Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Invoke Method

[image]
ActiveReports 19 .NET Edition
Invoke Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > DynamicDispatch Class : Invoke Method

methodName
The name of the method to invoke.
target
The object on which to invoke the method. Must not be null.
args
An array of arguments to pass to the method. If no arguments are needed, pass null or an empty array.

Glossary Item Box

Invokes an instance method on a given object using dynamic dispatch.

Syntax

Visual Basic (Declaration)
Public Shared Function Invoke( _
   ByVal methodName As String, _
   ByVal target As Object, _
   ByVal args() As Object _
) As Object
C#
public static object Invoke(
   string methodName,
   object target,
   object[] args
)

Parameters

methodName
The name of the method to invoke.
target
The object on which to invoke the method. Must not be null.
args
An array of arguments to pass to the method. If no arguments are needed, pass null or an empty array.

Return Value

The value returned by the invoked method, if any. If the method has no return value, null is returned.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if target is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicDispatch Class
DynamicDispatch Members


InvokeStatic Method

[image]
ActiveReports 19 .NET Edition
InvokeStatic Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > DynamicDispatch Class : InvokeStatic Method

methodName
The name of method to invoke.
type
The type to find method in.
args
The method arguments.

Glossary Item Box

Invokes static method.

Syntax

Visual Basic (Declaration)
Public Shared Function InvokeStatic( _
   ByVal methodName As String, _
   ByVal type As Type, _
   ByVal args() As Object _
) As Object
C#
public static object InvokeStatic(
   string methodName,
   Type type,
   object[] args
)

Parameters

methodName
The name of method to invoke.
type
The type to find method in.
args
The method arguments.

Return Value

value returned by the method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicDispatch Class
DynamicDispatch Members


IsPrimitive Method

[image]
ActiveReports 19 .NET Edition
IsPrimitive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > DynamicDispatch Class : IsPrimitive Method

type
type

Glossary Item Box

Checks if a given type is a primitive type

Syntax

Visual Basic (Declaration)
Public Shared Function IsPrimitive( _
   ByVal type As Type _
) As Boolean
C#
public static bool IsPrimitive(
   Type type
)

Parameters

type
type

Return Value

True if a given type is a primitive type, false otherwise

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicDispatch Class
DynamicDispatch Members


ExpressionExtensions Class

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : ExpressionExtensions Class

Glossary Item Box

Provides additional methods to work with expressions

Object Model

ExpressionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ExpressionExtensions
C#
public static class ExpressionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Evaluation.ExpressionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


ExpressionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : ExpressionExtensions Class

Glossary Item Box

The following tables list the members exposed by ExpressionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | EvalConst | Evaluates expression in global context (i.e. without any report context).
static (Shared in Visual Basic) | EvalConstString | Evaluates expression in global context (i.e. without any report context).
static (Shared in Visual Basic) | Evaluate | Evaluates expression in a given context.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


ExpressionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : ExpressionExtensions Class

Glossary Item Box

For a list of all members of this type, see ExpressionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | EvalConst | Evaluates expression in global context (i.e. without any report context).
static (Shared in Visual Basic) | EvalConstString | Evaluates expression in global context (i.e. without any report context).
static (Shared in Visual Basic) | Evaluate | Evaluates expression in a given context.
Top

See Also

Reference

ExpressionExtensions Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


EvalConst Method

[image]
ActiveReports 19 .NET Edition
EvalConst Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > ExpressionExtensions Class : EvalConst Method

expression
The expression to evaluate.
takeTypeFromExpression
If 'true' than the ResultType property value of source expression will be used to parse constant.

Glossary Item Box

Evaluates expression in global context (i.e. without any report context).

Syntax

Visual Basic (Declaration)
Public Shared Function EvalConst( _
   ByVal expression As ExpressionInfo, _
   Optional ByVal takeTypeFromExpression As Boolean _
) As Object
C#
public static object EvalConst(
   ExpressionInfo expression,
   bool takeTypeFromExpression
)

Parameters

expression
The expression to evaluate.
takeTypeFromExpression
If 'true' than the ResultType property value of source expression will be used to parse constant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


EvalConstString Method

[image]
ActiveReports 19 .NET Edition
EvalConstString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > ExpressionExtensions Class : EvalConstString Method

expression
The expression to evaluate.

Glossary Item Box

Evaluates expression in global context (i.e. without any report context).

Syntax

Visual Basic (Declaration)
Public Shared Function EvalConstString( _
   ByVal expression As ExpressionInfo _
) As String
C#
public static string EvalConstString(
   ExpressionInfo expression
)

Parameters

expression
The expression to evaluate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > ExpressionExtensions Class : Evaluate Method

expression
Expression to be evaluated.
context
Object which provides values and function to be used for evaluation.

Glossary Item Box

Evaluates expression in a given context.

Syntax

Visual Basic (Declaration)
Public Shared Function Evaluate( _
   ByVal expression As ExpressionInfo, _
   ByVal context As IDynamicObject _
) As Variant
C#
public static Variant Evaluate(
   ExpressionInfo expression,
   IDynamicObject context
)

Parameters

expression
Expression to be evaluated.
context
Object which provides values and function to be used for evaluation.

Return Value

Evaluation result.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


FrameworkInvoke Class

[image]
ActiveReports 19 .NET Edition
FrameworkInvoke Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : FrameworkInvoke Class

Glossary Item Box

Represents methods for .NET API late bindings.

Object Model

FrameworkInvoke Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FrameworkInvoke
C#
public static class FrameworkInvoke

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Evaluation.FrameworkInvoke

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FrameworkInvoke Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


FrameworkInvoke Class Members

[image]
ActiveReports 19 .NET Edition
FrameworkInvoke Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : FrameworkInvoke Class

Glossary Item Box

The following tables list the members exposed by FrameworkInvoke.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadModule | Loads module
static (Shared in Visual Basic) | ResolveType | Gets type by type name
static (Shared in Visual Basic) | TryGetValue | Gets a value from a given object by name
Top

See Also

Reference

FrameworkInvoke Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


FrameworkInvoke Class Methods

[image]
ActiveReports 19 .NET Edition
FrameworkInvoke Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : FrameworkInvoke Class

Glossary Item Box

For a list of all members of this type, see FrameworkInvoke members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadModule | Loads module
static (Shared in Visual Basic) | ResolveType | Gets type by type name
static (Shared in Visual Basic) | TryGetValue | Gets a value from a given object by name
Top

See Also

Reference

FrameworkInvoke Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


LoadModule Method

[image]
ActiveReports 19 .NET Edition
LoadModule Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > FrameworkInvoke Class : LoadModule Method

assemblies

Glossary Item Box

Loads module

Syntax

Visual Basic (Declaration)
Public Shared Function LoadModule( _
   ByVal assemblies As IEnumerable(Of Assembly) _
) As IDynamicObject
C#
public static IDynamicObject LoadModule(
   IEnumerable<Assembly> assemblies
)

Parameters

assemblies

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FrameworkInvoke Class
FrameworkInvoke Members


ResolveType Method

[image]
ActiveReports 19 .NET Edition
ResolveType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > FrameworkInvoke Class : ResolveType Method

name

Glossary Item Box

Gets type by type name

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveType( _
   ByVal name As String _
) As Type
C#
public static Type ResolveType(
   string name
)

Parameters

name

Return Value

type by type name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FrameworkInvoke Class
FrameworkInvoke Members


TryGetValue Method

[image]
ActiveReports 19 .NET Edition
TryGetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > FrameworkInvoke Class : TryGetValue Method

name
value name
value
value

Glossary Item Box

Gets a value from a given object by name

Syntax

Visual Basic (Declaration)
Public Shared Function TryGetValue( _
   ByVal name As String, _
   ByRef value As IDynamicObject _
) As Boolean
C#
public static bool TryGetValue(
   string name,
   out IDynamicObject value
)

Parameters

name
value name
value
value

Return Value

a value from a given object by name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FrameworkInvoke Class
FrameworkInvoke Members


InvalidVariantOperationException Class

[image]
ActiveReports 19 .NET Edition
InvalidVariantOperationException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : InvalidVariantOperationException Class

Glossary Item Box

Raised when an evaluation operation is not applicable to the given arguments.

Object Model

InvalidVariantOperationException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InvalidVariantOperationException
   Inherits System.InvalidOperationException
C#
public sealed class InvalidVariantOperationException : System.InvalidOperationException

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.InvalidOperationException
GrapeCity.Enterprise.Data.Expressions.Evaluation.InvalidVariantOperationException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


InvalidVariantOperationException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidVariantOperationException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : InvalidVariantOperationException Class

Glossary Item Box

The following tables list the members exposed by InvalidVariantOperationException.

Public Properties

 | Name | Description
Public Property | Operands | Parameter(s) of the failed operation.
Public Property | OperationName | Name of the failed operation.
Top

See Also

Reference

InvalidVariantOperationException Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


InvalidVariantOperationException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidVariantOperationException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : InvalidVariantOperationException Class

Glossary Item Box

For a list of all members of this type, see InvalidVariantOperationException members.

Public Properties

 | Name | Description
Public Property | Operands | Parameter(s) of the failed operation.
Public Property | OperationName | Name of the failed operation.
Top

See Also

Reference

InvalidVariantOperationException Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Operands Property

[image]
ActiveReports 19 .NET Edition
Operands Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : Operands Property

Glossary Item Box

Parameter(s) of the failed operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operands As List(Of Variant)
C#
public List<Variant> Operands {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


OperationName Property

[image]
ActiveReports 19 .NET Edition
OperationName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : OperationName Property

Glossary Item Box

Name of the failed operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperationName As String
C#
public string OperationName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


Variant.VariantComparer Class

[image]
ActiveReports 19 .NET Edition
Variant.VariantComparer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant.VariantComparer Class

Glossary Item Box

Comparer for the Variant type.

Object Model

Variant.VariantComparer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Variant.VariantComparer
C#
public sealed class Variant.VariantComparer

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant.VariantComparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Variant.VariantComparer Class Members

[image]
ActiveReports 19 .NET Edition
Variant.VariantComparer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant.VariantComparer Class

Glossary Item Box

The following tables list the members exposed by Variant.VariantComparer.

Public Constructors

 | Name | Description
Public Constructor | Variant.VariantComparer Constructor | Initializes a new instance of VariantComparer class.
Top

Public Methods

 | Name | Description
Public Method | Compare | Compares two Variants.
Public Method | Equals | Overloaded. Checks whether the specified Variants are equal.
Public Method | GetHashCode | Overloaded. Gets hashcode of the given Variant.
Top

See Also

Reference

Variant.VariantComparer Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Variant.VariantComparer Constructor

[image]
ActiveReports 19 .NET Edition
Variant.VariantComparer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class : Variant.VariantComparer Constructor

Glossary Item Box

Initializes a new instance of VariantComparer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Variant.VariantComparer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members


Variant.VariantComparer Class Methods

[image]
ActiveReports 19 .NET Edition
Variant.VariantComparer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant.VariantComparer Class

Glossary Item Box

For a list of all members of this type, see Variant.VariantComparer members.

Public Methods

 | Name | Description
Public Method | Compare | Compares two Variants.
Public Method | Equals | Overloaded. Checks whether the specified Variants are equal.
Public Method | GetHashCode | Overloaded. Gets hashcode of the given Variant.
Top

See Also

Reference

Variant.VariantComparer Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Compare Method

[image]
ActiveReports 19 .NET Edition
Compare Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class : Compare Method

x
The first Variant to be compared.
y
The second Variant to be compared.

Glossary Item Box

Compares two Variants.

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal x As Variant, _
   ByVal y As Variant _
) As Integer
C#
public int Compare(
   Variant x,
   Variant y
)

Parameters

x
The first Variant to be compared.
y
The second Variant to be compared.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class : Equals Method

Glossary Item Box

Checks whether the specified Variants are equal.

Overload List

Overload | Description
Equals(Variant,Variant) | Checks whether the specified Variants are equal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members


Equals(Variant,Variant) Method

[image]
ActiveReports 19 .NET Edition
Equals(Variant,Variant) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class > Equals Method : Equals(Variant,Variant) Method

x
The first Variant to check.
y
The second Variant to check.

Glossary Item Box

Checks whether the specified Variants are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal x As Variant, _
   ByVal y As Variant _
) As Boolean
C#
public bool Equals(
   Variant x,
   Variant y
)

Parameters

x
The first Variant to check.
y
The second Variant to check.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class : GetHashCode Method

Glossary Item Box

Gets hashcode of the given Variant.

Overload List

Overload | Description
GetHashCode(Variant) | Gets hashcode of the given Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members


GetHashCode(Variant) Method

[image]
ActiveReports 19 .NET Edition
GetHashCode(Variant) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant.VariantComparer Class > GetHashCode Method : GetHashCode(Variant) Method

obj
The Variant to get hashcode for.

Glossary Item Box

Gets hashcode of the given Variant.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHashCode( _
   ByVal obj As Variant _
) As Integer
C#
public int GetHashCode(
   Variant obj
)

Parameters

obj
The Variant to get hashcode for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant.VariantComparer Class
Variant.VariantComparer Members
Overload List


VariantType Enumeration

[image]
ActiveReports 19 .NET Edition
VariantType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : VariantType Enumeration

Glossary Item Box

Defines variant types.

Syntax

Visual Basic (Declaration)
Public Enum VariantType
   Inherits System.Enum
C#
public enum VariantType : System.Enum

Members

Member | Description
Array | Specifies array type that can be used in aggregate functions.
Bool | Specifies boolean value type.
Date | Specifies Date value type.
Decimal | Specifies decimal value type.
Double | Specifies double value type.
Enum | Specifies enum value type.
Float | Specifies float value type.
Int32 | Specifies Int32 value type.
Int64 | Specifies Int64 value type.
Null | Specifies untyped 'null' value.
Object | Specifies object type.
String | Specifies string type.
TimeSpan | Specifies TimeSpan value type.
UInt64 | Specifies UInt64 value type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.Expressions.Evaluation.VariantType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Variant Structure

[image]
ActiveReports 19 .NET Edition
Variant Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant Structure

Glossary Item Box

Defines a variant type.

Object Model

Variant Structure

Syntax

Visual Basic (Declaration)
Public Structure Variant
   Inherits System.ValueType
C#
public struct Variant : System.ValueType

Remarks

The size of structure is 24b.This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Variant Structure Members

[image]
ActiveReports 19 .NET Edition
Variant Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant Structure

Glossary Item Box

The following tables list the members exposed by Variant.

Public Constructors

 | Name | Description
Public Constructor | Variant Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Comparer | A Variant.VariantComparer instance.
static (Shared in Visual Basic) | False | Predefined boolean 'False'.
static (Shared in Visual Basic) | Null | Predefined 'Null' value.
static (Shared in Visual Basic) | True | Predefined boolean 'True'.
static (Shared in Visual Basic) | Zero | Predefined 'Zero' value.
Top

Public Properties

 | Name | Description
Public Property | IsNull | Checks if the variant value is null.
Public Property | IsNullOrEmptyString | Checks if the variant value is null or empty string.
Public Property | Type | The type of value represented with the Variant.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | And | Applies boolean '&&' to booleans and bitwise '&' to numeric.
static (Shared in Visual Basic) | Array | Initializes a new instance of the Variant with Array type.
Public Method | CompareTo | Overloaded. Compares the Variant with the specified object.
Public Method | ConvertTo | Converts the variant to the specified type.
static (Shared in Visual Basic) | DateToString | Converts date to string.
Public Method | Equals | Overloaded. Checks whether the Variant equals to the specified object.
static (Shared in Visual Basic) | FromObject | Initializes a new instance of the Variant from the value specified as object. The type of variant will be inferred from the specified value.
Public Method | GetHashCode | Gets hash code for the variant.
static (Shared in Visual Basic) | Or | Applies boolean '||' to booleans and bitwise '|' to numeric.
static (Shared in Visual Basic) | Pow | Returns a specified Variant raised to the specified power.
Public Method | ToObject | Converts the Variant to the object.
Public Method | ToString | Overloaded. Converts Variant to the string representation with given format provider.
static (Shared in Visual Basic) | Xor | Applies boolean '!=' to booleans and bitwise '^' to numeric.
Top

Public Operators

public Operator Addition | Overloaded. Sums two variants.
public Operator Division | Overloaded. Divides one variant by another.
public Operator Equality | Checks whether two given Variants are equal.
public Operator Explicit Type Conversion | Overloaded. Converts given Variant to boolean.
public Operator Greater Than | Checks whether the one variant is greater than another.
public Operator Greater Than or Equal | Checks whether the one variant is greater or equal to another.
public Operator Inequality | Checks whether two given Variants are different.
public Operator Left-shift | Bitwise shift to the left.
public Operator Less Than | Checks whether the one variant is less than another.
public Operator Less Than or Equal | Checks whether the one variant is less or equal to another.
public Operator Logical Not | Performs a logical negation on a Variant value if it is of boolean type, or a bitwise negation if it is of a numeric type.
public Operator Modulus | Computes the remainder after dividing its first operand by its second.
public Operator Multiplication | Multiplies two variants.
public Operator Right-shift | Bitwise shift to the right.
public Operator Subtraction | Subtracts one Variant from another.
public Operator Unary Negation | Negates the given numerical variant.
public Operator Unary Plus | Tries to convert string variant to numeric, raises expceptions for other non-numeric types, does nothing for all numeric types.
Top

See Also

Reference

Variant Structure
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Variant Constructor

[image]
ActiveReports 19 .NET Edition
Variant Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Variant Constructor

Glossary Item Box

Overload List

Overload | Description
Variant Constructor(Boolean) | Initializes a new instance of the Variant with the specified boolean value.
Variant Constructor(Int32) | Initializes a new instance of the Variant with the specified integer value.
Variant Constructor(Int64) | Initializes a new instance of the Variant with the specified long integer value.
Variant Constructor(UInt64) | Initializes a new instance of the Variant with the specified unsigned long integer value.
Variant Constructor(Double) | Initializes a new instance of the Variant with the specified double value.
Variant Constructor(Single) | Initializes a new instance of the Variant with the specified float value.
Variant Constructor(Decimal) | Initializes a new instance of the Variant with the specified decimal value.
Variant Constructor(Char) | Initializes a new instance of the Variant with the specified System.Char value.
Variant Constructor(String) | Initializes a new instance of the Variant with the System.String value.
Variant Constructor(TimeSpan) | Initializes a new instance of the Variant with the System.TimeSpan value.
Variant Constructor(DateTime) | Initializes a new instance of the Variant with the System.DateTime value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Variant Constructor(Boolean)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Boolean)

value
The boolean value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified boolean value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Boolean _
)
C#
public Variant(
   bool value
)

Parameters

value
The boolean value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Int32)

value
The integer value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified integer value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer _
)
C#
public Variant(
   int value
)

Parameters

value
The integer value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Int64)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Int64)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Int64)

value
The long integer value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified long integer value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
C#
public Variant(
   long value
)

Parameters

value
The long integer value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(UInt64)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(UInt64)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(UInt64)

value
The unsigned long integer value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified unsigned long integer value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
C#
public Variant(
   ulong value
)

Parameters

value
The unsigned long integer value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Double)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Double)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Double)

value
The System.Double value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified double value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
C#
public Variant(
   double value
)

Parameters

value
The System.Double value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Single)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Single)

value
The System.Single value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified float value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single _
)
C#
public Variant(
   float value
)

Parameters

value
The System.Single value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Decimal)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Decimal)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Decimal)

value
The System.Decimal value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified decimal value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Decimal _
)
C#
public Variant(
   decimal value
)

Parameters

value
The System.Decimal value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(Char)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(Char)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(Char)

value
The System.Char value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the specified System.Char value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Char _
)
C#
public Variant(
   char value
)

Parameters

value
The System.Char value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(String)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(String)

value
The System.String value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the System.String value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
C#
public Variant(
   string value
)

Parameters

value
The System.String value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(TimeSpan)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(TimeSpan)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(TimeSpan)

value
The System.TimeSpan value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the System.TimeSpan value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As TimeSpan _
)
C#
public Variant(
   TimeSpan value
)

Parameters

value
The System.TimeSpan value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Constructor(DateTime)

[image]
ActiveReports 19 .NET Edition
Variant Constructor(DateTime)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Variant Constructor : Variant Constructor(DateTime)

value
The System.DateTime value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant with the System.DateTime value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Date _
)
C#
public Variant(
   DateTime value
)

Parameters

value
The System.DateTime value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Variant Structure Methods

[image]
ActiveReports 19 .NET Edition
Variant Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant Structure

Glossary Item Box

For a list of all members of this type, see Variant members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | And | Applies boolean '&&' to booleans and bitwise '&' to numeric.
static (Shared in Visual Basic) | Array | Initializes a new instance of the Variant with Array type.
Public Method | CompareTo | Overloaded. Compares the Variant with the specified object.
Public Method | ConvertTo | Converts the variant to the specified type.
static (Shared in Visual Basic) | DateToString | Converts date to string.
Public Method | Equals | Overloaded. Checks whether the Variant equals to the specified object.
static (Shared in Visual Basic) | FromObject | Initializes a new instance of the Variant from the value specified as object. The type of variant will be inferred from the specified value.
Public Method | GetHashCode | Gets hash code for the variant.
static (Shared in Visual Basic) | Or | Applies boolean '||' to booleans and bitwise '|' to numeric.
static (Shared in Visual Basic) | Pow | Returns a specified Variant raised to the specified power.
Public Method | ToObject | Converts the Variant to the object.
Public Method | ToString | Overloaded. Converts Variant to the string representation with given format provider.
static (Shared in Visual Basic) | Xor | Applies boolean '!=' to booleans and bitwise '^' to numeric.
Top

See Also

Reference

Variant Structure
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


And Method

[image]
ActiveReports 19 .NET Edition
And Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : And Method

a
The first operand.
b
The second operand.

Glossary Item Box

Applies boolean '&&' to booleans and bitwise '&' to numeric.

Syntax

Visual Basic (Declaration)
Public Shared Function And( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public static Variant And(
   Variant a,
   Variant b
)

Parameters

a
The first operand.
b
The second operand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Array Method

[image]
ActiveReports 19 .NET Edition
Array Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Array Method

arr

Glossary Item Box

Initializes a new instance of the Variant with Array type.

Syntax

Visual Basic (Declaration)
Public Shared Function Array( _
   ByVal arr As Object _
) As Variant
C#
public static Variant Array(
   object arr
)

Parameters

arr

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


CompareTo Method

[image]
ActiveReports 19 .NET Edition
CompareTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : CompareTo Method

Glossary Item Box

Compares the Variant with the specified object.

Overload List

Overload | Description
CompareTo(Object) | Compares the Variant with the specified object.
CompareTo(Variant) | Compares the Variant with the specified one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


CompareTo(Object) Method

[image]
ActiveReports 19 .NET Edition
CompareTo(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > CompareTo Method : CompareTo(Object) Method

obj
The object to be compared with.

Glossary Item Box

Compares the Variant with the specified object.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


CompareTo(Variant) Method

[image]
ActiveReports 19 .NET Edition
CompareTo(Variant) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > CompareTo Method : CompareTo(Variant) Method

b
The Variant to be compared with.

Glossary Item Box

Compares the Variant with the specified one.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal b As Variant _
) As Integer
C#
public int CompareTo(
   Variant b
)

Parameters

b
The Variant to be compared with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : ConvertTo Method

newType
The new type of the variant.

Glossary Item Box

Converts the variant to the specified type.

Syntax

Visual Basic (Declaration)
Public Function ConvertTo( _
   ByVal newType As VariantType _
) As Variant
C#
public Variant ConvertTo(
   VariantType newType
)

Parameters

newType
The new type of the variant.

Return Value

Variant value with the new type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


DateToString Method

[image]
ActiveReports 19 .NET Edition
DateToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : DateToString Method

variant
The date to convert.
culture
The culture.

Glossary Item Box

Converts date to string.

Syntax

Visual Basic (Declaration)
Public Shared Function DateToString( _
   ByVal variant As Variant, _
   Optional ByVal culture As CultureInfo _
) As String
C#
public static string DateToString(
   Variant variant,
   CultureInfo culture
)

Parameters

variant
The date to convert.
culture
The culture.

Return Value

The string representation of a date.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Equals Method

Glossary Item Box

Checks whether the Variant equals to the specified object.

Overload List

Overload | Description
Equals(Object) | Checks whether the Variant equals to the specified object.
Equals(Variant) | Checks whether the Variant equals to the specified one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Equals Method : Equals(Object) Method

other
The object to be converted to the Variant and compared with it.

Glossary Item Box

Checks whether the Variant equals to the specified object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
C#
public override bool Equals(
   object other
)

Parameters

other
The object to be converted to the Variant and compared with it.

Return Value

True if the variants are equal, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Equals(Variant) Method

[image]
ActiveReports 19 .NET Edition
Equals(Variant) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Equals Method : Equals(Variant) Method

b
Variant to check with.

Glossary Item Box

Checks whether the Variant equals to the specified one.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal b As Variant _
) As Boolean
C#
public bool Equals(
   Variant b
)

Parameters

b
Variant to check with.

Return Value

True if the variants are equal, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : FromObject Method

value
The value of the Variant.

Glossary Item Box

Initializes a new instance of the Variant from the value specified as object. The type of variant will be inferred from the specified value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Variant
C#
public static Variant FromObject(
   object value
)

Parameters

value
The value of the Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : GetHashCode Method

Glossary Item Box

Gets hash code for the variant.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Or Method

[image]
ActiveReports 19 .NET Edition
Or Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Or Method

a
The first operand.
b
The second operand.

Glossary Item Box

Applies boolean '||' to booleans and bitwise '|' to numeric.

Syntax

Visual Basic (Declaration)
Public Shared Function Or( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public static Variant Or(
   Variant a,
   Variant b
)

Parameters

a
The first operand.
b
The second operand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Pow Method

[image]
ActiveReports 19 .NET Edition
Pow Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Pow Method

a
The variant to be raised.
b
The power.

Glossary Item Box

Returns a specified Variant raised to the specified power.

Syntax

Visual Basic (Declaration)
Public Shared Function Pow( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public static Variant Pow(
   Variant a,
   Variant b
)

Parameters

a
The variant to be raised.
b
The power.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


ToObject Method

[image]
ActiveReports 19 .NET Edition
ToObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : ToObject Method

Glossary Item Box

Converts the Variant to the object.

Syntax

Visual Basic (Declaration)
Public Function ToObject() As Object
C#
public object ToObject()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : ToString Method

Glossary Item Box

Converts Variant to the string representation with given format provider.

Overload List

Overload | Description
ToString(IFormatProvider) | Converts Variant to the string representation with given format provider.
ToString() | Converts Variant to the string representation.
ToString(String,IFormatProvider) | Converts Variant to the string representation with specified format and format provider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


ToString(IFormatProvider) Method

[image]
ActiveReports 19 .NET Edition
ToString(IFormatProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > ToString Method : ToString(IFormatProvider) Method

formatProvider
System.IFormatProvider to be used in conversion.

Glossary Item Box

Converts Variant to the string representation with given format provider.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal formatProvider As IFormatProvider _
) As String
C#
public string ToString(
   IFormatProvider formatProvider
)

Parameters

formatProvider
System.IFormatProvider to be used in conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


ToString() Method

[image]
ActiveReports 19 .NET Edition
ToString() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > ToString Method : ToString() Method

Glossary Item Box

Converts Variant to the string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


ToString(String,IFormatProvider) Method

[image]
ActiveReports 19 .NET Edition
ToString(String,IFormatProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > ToString Method : ToString(String,IFormatProvider) Method

format
String format.
formatProvider
System.IFormatProvider to be used in conversion.

Glossary Item Box

Converts Variant to the string representation with specified format and format provider.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String, _
   ByVal formatProvider As IFormatProvider _
) As String
C#
public string ToString(
   string format,
   IFormatProvider formatProvider
)

Parameters

format
String format.
formatProvider
System.IFormatProvider to be used in conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Xor Method

[image]
ActiveReports 19 .NET Edition
Xor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Xor Method

a
The first operand.
b
The second operand.

Glossary Item Box

Applies boolean '!=' to booleans and bitwise '^' to numeric.

Syntax

Visual Basic (Declaration)
Public Shared Function Xor( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public static Variant Xor(
   Variant a,
   Variant b
)

Parameters

a
The first operand.
b
The second operand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Variant Structure Properties

[image]
ActiveReports 19 .NET Edition
Variant Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant Structure

Glossary Item Box

For a list of all members of this type, see Variant members.

Public Properties

 | Name | Description
Public Property | IsNull | Checks if the variant value is null.
Public Property | IsNullOrEmptyString | Checks if the variant value is null or empty string.
Public Property | Type | The type of value represented with the Variant.
Top

See Also

Reference

Variant Structure
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


IsNull Property

[image]
ActiveReports 19 .NET Edition
IsNull Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : IsNull Property

Glossary Item Box

Checks if the variant value is null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

True if the variant value is Null, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


IsNullOrEmptyString Property

[image]
ActiveReports 19 .NET Edition
IsNullOrEmptyString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : IsNullOrEmptyString Property

Glossary Item Box

Checks if the variant value is null or empty string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNullOrEmptyString As Boolean
C#
public bool IsNullOrEmptyString {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Type Property

Glossary Item Box

The type of value represented with the Variant.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As VariantType
C#
public VariantType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Variant Structure Fields

[image]
ActiveReports 19 .NET Edition
Variant Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : Variant Structure

Glossary Item Box

For a list of all members of this type, see Variant members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Comparer | A Variant.VariantComparer instance.
static (Shared in Visual Basic) | False | Predefined boolean 'False'.
static (Shared in Visual Basic) | Null | Predefined 'Null' value.
static (Shared in Visual Basic) | True | Predefined boolean 'True'.
static (Shared in Visual Basic) | Zero | Predefined 'Zero' value.
Top

See Also

Reference

Variant Structure
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Comparer Field

[image]
ActiveReports 19 .NET Edition
Comparer Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Comparer Field

Glossary Item Box

A Variant.VariantComparer instance.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Comparer As Variant.VariantComparer
C#
public static readonly Variant.VariantComparer Comparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


False Field

[image]
ActiveReports 19 .NET Edition
False Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : False Field

Glossary Item Box

Predefined boolean 'False'.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly False As Variant
C#
public static readonly Variant False

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Null Field

[image]
ActiveReports 19 .NET Edition
Null Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Null Field

Glossary Item Box

Predefined 'Null' value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As Variant
C#
public static readonly Variant Null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


True Field

[image]
ActiveReports 19 .NET Edition
True Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : True Field

Glossary Item Box

Predefined boolean 'True'.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly True As Variant
C#
public static readonly Variant True

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Zero Field

[image]
ActiveReports 19 .NET Edition
Zero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Zero Field

Glossary Item Box

Predefined 'Zero' value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As Variant
C#
public static readonly Variant Zero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Addition Operator

[image]
ActiveReports 19 .NET Edition
Addition Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Addition Operator

Glossary Item Box

Sums two variants.

Overload List

Overload | Description
Addition(Variant,Variant) | Sums two variants.
Addition(Variant,Int64) | Sums the Variant and long value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Division Operator

[image]
ActiveReports 19 .NET Edition
Division Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Division Operator

Glossary Item Box

Divides one variant by another.

Overload List

Overload | Description
Division(Variant,Variant) | Divides one variant by another.
Division(Variant,Double) | Divides Variant by double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Equality Operator

a
First Variant to check.
b
Second Variant to check.

Glossary Item Box

Checks whether two given Variants are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator ==(
   Variant a,
   Variant b
)

Parameters

a
First Variant to check.
b
Second Variant to check.

Return Value

True if the variants are equal, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Explicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Explicit Type Conversion Operator

Glossary Item Box

Converts given Variant to boolean.

Overload List

Overload | Description
Explicit Type Conversion(Boolean,Variant) | Converts given Variant to boolean.
Explicit Type Conversion(Int32,Variant) | Converts Variant value to System.Int32.
Explicit Type Conversion(Int64,Variant) | Converts Variant value to System.Int64.
Explicit Type Conversion(UInt64,Variant) | Converts Variant value to System.UInt64.
Explicit Type Conversion(Double,Variant) | Converts Variant value to System.Double.
Explicit Type Conversion(Single,Variant) | Converts Variant value to System.Single.
Explicit Type Conversion(Decimal,Variant) | Converts Variant value to System.Decimal.
Explicit Type Conversion(String,Variant) | Converts Variant value to System.String.
Explicit Type Conversion(DateTime,Variant) | Converts Variant value to System.DateTime.
Explicit Type Conversion(TimeSpan,Variant) | Converts Variant value to TimeSpan.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Greater Than Operator

[image]
ActiveReports 19 .NET Edition
Greater Than Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Greater Than Operator

a
The Variant to be to the left of the 'greater' operator.
b
The Variant to be to the right of the 'greater' operator.

Glossary Item Box

Checks whether the one variant is greater than another.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator >(
   Variant a,
   Variant b
)

Parameters

a
The Variant to be to the left of the 'greater' operator.
b
The Variant to be to the right of the 'greater' operator.

Return Value

True if the 'a' is greater than 'b', False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Greater Than or Equal Operator

[image]
ActiveReports 19 .NET Edition
Greater Than or Equal Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Greater Than or Equal Operator

a
The Variant to be to the left of the comparison operator.
b
The Variant to be to the right of the comparison operator.

Glossary Item Box

Checks whether the one variant is greater or equal to another.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator >=(
   Variant a,
   Variant b
)

Parameters

a
The Variant to be to the left of the comparison operator.
b
The Variant to be to the right of the comparison operator.

Return Value

True if the 'a' is greater or equal to 'b', False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Inequality Operator

a
First Variant to check.
b
Second Variant to check.

Glossary Item Box

Checks whether two given Variants are different.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator !=(
   Variant a,
   Variant b
)

Parameters

a
First Variant to check.
b
Second Variant to check.

Return Value

True if the variants are different, False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Left-shift Operator

[image]
ActiveReports 19 .NET Edition
Left-shift Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Left-shift Operator

a
The variant to be shifted.
shift
The shift value.

Glossary Item Box

Bitwise shift to the left.

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal a As Variant, _
   ByVal shift As Integer _
) As Variant
C#
public Variant operator <<(
   Variant a,
   int shift
)

Parameters

a
The variant to be shifted.
shift
The shift value.

Return Value

The result of bitwise shifting.

Exceptions

Exception | Description
InvalidVariantOperationException | Thrown if the Variant is of a non-numeric, non-boolean type that does not support bitwise operations, such as TimeSpan, Date, or Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Less Than Operator

[image]
ActiveReports 19 .NET Edition
Less Than Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Less Than Operator

a
The Variant to be to the left of the 'less' operator.
b
The Variant to be to the right of the 'less' operator.

Glossary Item Box

Checks whether the one variant is less than another.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator <(
   Variant a,
   Variant b
)

Parameters

a
The Variant to be to the left of the 'less' operator.
b
The Variant to be to the right of the 'less' operator.

Return Value

True if the 'a' is less than 'b', False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Less Than or Equal Operator

[image]
ActiveReports 19 .NET Edition
Less Than or Equal Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Less Than or Equal Operator

a
The Variant to be to the left of the comparison operator.
b
The Variant to be to the right of the comparison operator.

Glossary Item Box

Checks whether the one variant is less or equal to another.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Boolean
C#
public bool operator <=(
   Variant a,
   Variant b
)

Parameters

a
The Variant to be to the left of the comparison operator.
b
The Variant to be to the right of the comparison operator.

Return Value

True if the 'a' is less or equal to 'b', False otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Logical Not Operator

[image]
ActiveReports 19 .NET Edition
Logical Not Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Logical Not Operator

v
Variant to be inverted.

Glossary Item Box

Performs a logical negation on a Variant value if it is of boolean type, or a bitwise negation if it is of a numeric type.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public Variant operator !(
   Variant v
)

Parameters

v
Variant to be inverted.

Return Value

Variant.True if the given variant is False, False otherwise for boolean varian type . Bitwise 'not' for numeric variants (int, long, ulong, float, double, decimal) and for string which can be parsed as numeric.

Exceptions

Exception | Description
InvalidVariantOperationException | Thrown if the Variant is of a non-numeric, non-boolean type that does not support negation, such as TimeSpan, Date, or Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Modulus Operator

[image]
ActiveReports 19 .NET Edition
Modulus Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Modulus Operator

a
The first operand.
b
The second operand.

Glossary Item Box

Computes the remainder after dividing its first operand by its second.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public Variant operator %(
   Variant a,
   Variant b
)

Parameters

a
The first operand.
b
The second operand.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Multiplication Operator

[image]
ActiveReports 19 .NET Edition
Multiplication Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Multiplication Operator

a
The first variant.
b
The second variant.

Glossary Item Box

Multiplies two variants.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public Variant operator *(
   Variant a,
   Variant b
)

Parameters

a
The first variant.
b
The second variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Right-shift Operator

[image]
ActiveReports 19 .NET Edition
Right-shift Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Right-shift Operator

a
The variant to be shifted.
shift
The shift value.

Glossary Item Box

Bitwise shift to the right.

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal a As Variant, _
   ByVal shift As Integer _
) As Variant
C#
public Variant operator >>(
   Variant a,
   int shift
)

Parameters

a
The variant to be shifted.
shift
The shift value.

Return Value

The result of bitwise shifting.

Exceptions

Exception | Description
InvalidVariantOperationException | Thrown if the Variant is of a non-numeric, non-boolean type that does not support bitwise operations, such as TimeSpan, Date, or Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Subtraction Operator

[image]
ActiveReports 19 .NET Edition
Subtraction Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Subtraction Operator

a
The source Variant.
b
The Variant to be subtracted.

Glossary Item Box

Subtracts one Variant from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public Variant operator -(
   Variant a,
   Variant b
)

Parameters

a
The source Variant.
b
The Variant to be subtracted.

Return Value

The result of subtraction b from a.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Unary Negation Operator

[image]
ActiveReports 19 .NET Edition
Unary Negation Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Unary Negation Operator

a
The variant to be negated.

Glossary Item Box

Negates the given numerical variant.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal a As Variant _
) As Variant
C#
public Variant operator -(
   Variant a
)

Parameters

a
The variant to be negated.

Exceptions

Exception | Description
InvalidVariantOperationException | Thrown if the Variant is of a non-numeric, non-boolean type that does not support negation, such as TimeSpan, Date, or Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


Unary Plus Operator

[image]
ActiveReports 19 .NET Edition
Unary Plus Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure : Unary Plus Operator

a
The variant.

Glossary Item Box

Tries to convert string variant to numeric, raises expceptions for other non-numeric types, does nothing for all numeric types.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal a As Variant _
) As Variant
C#
public Variant operator +(
   Variant a
)

Parameters

a
The variant.

Exceptions

Exception | Description
InvalidVariantOperationException | Thrown if the Variant is of a non-numeric, non-boolean type that does not support negation, such as TimeSpan, Date, or Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members


IDynamicObject Interface

[image]
ActiveReports 19 .NET Edition
IDynamicObject Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : IDynamicObject Interface

Glossary Item Box

Represents an object with late binding mechanism.

Syntax

Visual Basic (Declaration)
Public Interface IDynamicObject
C#
public interface IDynamicObject

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDynamicObject Members
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


IDynamicObject Interface Members

[image]
ActiveReports 19 .NET Edition
IDynamicObject Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : IDynamicObject Interface

Glossary Item Box

The following tables list the members exposed by IDynamicObject.

Public Methods

 | Name | Description
Method | GetValue | Gets value of specified property.
Method | Invoke | Invokes specified function.
Top

See Also

Reference

IDynamicObject Interface
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


IDynamicObject Interface Methods

[image]
ActiveReports 19 .NET Edition
IDynamicObject Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : IDynamicObject Interface

Glossary Item Box

For a list of all members of this type, see IDynamicObject members.

Public Methods

 | Name | Description
Method | GetValue | Gets value of specified property.
Method | Invoke | Invokes specified function.
Top

See Also

Reference

IDynamicObject Interface
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


GetValue Method

[image]
ActiveReports 19 .NET Edition
GetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > IDynamicObject Interface : GetValue Method

name
property name

Glossary Item Box

Gets value of specified property.

Syntax

Visual Basic (Declaration)
Function GetValue( _
   ByVal name As String _
) As Object
C#
object GetValue(
   string name
)

Parameters

name
property name

Return Value

property value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDynamicObject Interface
IDynamicObject Members


Invoke Method

[image]
ActiveReports 19 .NET Edition
Invoke Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > IDynamicObject Interface : Invoke Method

name
function name
args
function arguments

Glossary Item Box

Invokes specified function.

Syntax

Visual Basic (Declaration)
Function Invoke( _
   ByVal name As String, _
   ByVal args() As Object _
) As Object
C#
object Invoke(
   string name,
   object[] args
)

Parameters

name
function name
args
function arguments

Return Value

function result

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDynamicObject Interface
IDynamicObject Members


Location Structure

[image]
ActiveReports 19 .NET Edition
Location Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Location Structure

Glossary Item Box

Represents a location in text.

Object Model

Location Structure

Syntax

Visual Basic (Declaration)
Public Structure Location
   Inherits System.ValueType
C#
public struct Location : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Parser.Location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Members
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Location Structure Members

[image]
ActiveReports 19 .NET Edition
Location Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Location Structure

Glossary Item Box

The following tables list the members exposed by Location.

Public Constructors

 | Name | Description
Public Constructor | Location Constructor | Initializes a new instance of the Location structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an uninitialized Location object.
Top

Public Properties

 | Name | Description
Public Property | Column | The one based column number.
Public Property | Index | The zero based index into the stream of text.
Public Property | IsValid | Determines if this object describes a valid location.
Public Property | Line | The one based line number.
Top

Public Methods

 | Name | Description
Public Method | Before | Determines if the specified location occurs before this location in the text stream.
Public Method | Equals | Overloaded. Determines if the specified object is equal to this object.
Public Method | GetHashCode | See System.Object.GetHashCode
Public Method | ToString | Returns a string representation of this object.
Top

See Also

Reference

Location Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Location Constructor

[image]
ActiveReports 19 .NET Edition
Location Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Location Constructor

index
The initial value for Index.
line
The initial value for Line.
column
The initial value for Column.

Glossary Item Box

Initializes a new instance of the Location structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal index As Long, _
   ByVal line As Long, _
   ByVal column As Long _
)
C#
public Location(
   long index,
   long line,
   long column
)

Parameters

index
The initial value for Index.
line
The initial value for Line.
column
The initial value for Column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Location Structure Methods

[image]
ActiveReports 19 .NET Edition
Location Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Location Structure

Glossary Item Box

For a list of all members of this type, see Location members.

Public Methods

 | Name | Description
Public Method | Before | Determines if the specified location occurs before this location in the text stream.
Public Method | Equals | Overloaded. Determines if the specified object is equal to this object.
Public Method | GetHashCode | See System.Object.GetHashCode
Public Method | ToString | Returns a string representation of this object.
Top

See Also

Reference

Location Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Before Method

[image]
ActiveReports 19 .NET Edition
Before Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Before Method

otherLocation
The location to compare this location to.

Glossary Item Box

Determines if the specified location occurs before this location in the text stream.

Syntax

Visual Basic (Declaration)
Public Function Before( _
   ByVal otherLocation As Location _
) As Boolean
C#
public bool Before(
   Location otherLocation
)

Parameters

otherLocation
The location to compare this location to.

Return Value

true if the specified location occurs before this location; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Equals Method

Glossary Item Box

Determines if the specified object is equal to this object.

Overload List

Overload | Description
Equals(Object) | Determines if the specified object is equal to this object.
Equals(Location) | Determines if the specified Location is equal to this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure > Equals Method : Equals(Object) Method

obj
The object to compare this object to.

Glossary Item Box

Determines if the specified object is equal to this object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare this object to.

Return Value

True if the specified object is equal to this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members
Overload List


Equals(Location) Method

[image]
ActiveReports 19 .NET Edition
Equals(Location) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure > Equals Method : Equals(Location) Method

location
The object to compare this object to.

Glossary Item Box

Determines if the specified Location is equal to this object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal location As Location _
) As Boolean
C#
public bool Equals(
   Location location
)

Parameters

location
The object to compare this object to.

Return Value

True if the specified Location is equal to this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : GetHashCode Method

Glossary Item Box

See System.Object.GetHashCode

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : ToString Method

Glossary Item Box

Returns a string representation of this object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Location Structure Properties

[image]
ActiveReports 19 .NET Edition
Location Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Location Structure

Glossary Item Box

For a list of all members of this type, see Location members.

Public Properties

 | Name | Description
Public Property | Column | The one based column number.
Public Property | Index | The zero based index into the stream of text.
Public Property | IsValid | Determines if this object describes a valid location.
Public Property | Line | The one based line number.
Top

See Also

Reference

Location Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Column Property

[image]
ActiveReports 19 .NET Edition
Column Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Column Property

Glossary Item Box

The one based column number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Long
C#
public long Column {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Index Property

Glossary Item Box

The zero based index into the stream of text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Long
C#
public long Index {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


IsValid Property

[image]
ActiveReports 19 .NET Edition
IsValid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : IsValid Property

Glossary Item Box

Determines if this object describes a valid location.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Line Property

[image]
ActiveReports 19 .NET Edition
Line Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Line Property

Glossary Item Box

The one based line number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Line As Long
C#
public long Line {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Location Structure Fields

[image]
ActiveReports 19 .NET Edition
Location Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Location Structure

Glossary Item Box

For a list of all members of this type, see Location members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an uninitialized Location object.
Top

See Also

Reference

Location Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Location Structure : Empty Field

Glossary Item Box

Represents an uninitialized Location object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Location
C#
public static readonly Location Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Location Structure
Location Members


Span Structure

[image]
ActiveReports 19 .NET Edition
Span Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Span Structure

Glossary Item Box

Represents the location of a span of text within original GrapeCity.Enterprise.Data.Expressions.ExpressionInfo string.

Object Model

Span Structure

Syntax

Visual Basic (Declaration)
Public Structure Span
   Inherits System.ValueType
C#
public struct Span : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Parser.Span

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Members
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Span Structure Members

[image]
ActiveReports 19 .NET Edition
Span Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Span Structure

Glossary Item Box

The following tables list the members exposed by Span.

Public Constructors

 | Name | Description
Public Constructor | Span Constructor | Initializes a new instance of the Span structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an uninitialized Span object.
Top

Public Properties

 | Name | Description
Public Property | Finish | The ending location of the text.
Public Property | IsValid | Determines if this object describes a valid location.
Public Property | Start | The starting location of the text.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines if the specified object is equal to this object.
Public Method | GetHashCode | See System.Object.GetHashCode
Public Method | ToString | Returns a string representation of this object.
Top

See Also

Reference

Span Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Span Constructor

[image]
ActiveReports 19 .NET Edition
Span Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : Span Constructor

start
The value for Start.
finish
The value for Finish.

Glossary Item Box

Initializes a new instance of the Span structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal start As Location, _
   ByVal finish As Location _
)
C#
public Span(
   Location start,
   Location finish
)

Parameters

start
The value for Start.
finish
The value for Finish.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


Span Structure Methods

[image]
ActiveReports 19 .NET Edition
Span Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Span Structure

Glossary Item Box

For a list of all members of this type, see Span members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines if the specified object is equal to this object.
Public Method | GetHashCode | See System.Object.GetHashCode
Public Method | ToString | Returns a string representation of this object.
Top

See Also

Reference

Span Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : Equals Method

Glossary Item Box

Determines if the specified object is equal to this object.

Overload List

Overload | Description
Equals(Object) | Determines if the specified object is equal to this object.
Equals(Span) | Determines if the specified Span is equal to this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure > Equals Method : Equals(Object) Method

obj
The object to compare this object to.

Glossary Item Box

Determines if the specified object is equal to this object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare this object to.

Return Value

True if the specified object is equal to this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members
Overload List


Equals(Span) Method

[image]
ActiveReports 19 .NET Edition
Equals(Span) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure > Equals Method : Equals(Span) Method

span
The object to compare this object to.

Glossary Item Box

Determines if the specified Span is equal to this object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal span As Span _
) As Boolean
C#
public bool Equals(
   Span span
)

Parameters

span
The object to compare this object to.

Return Value

True if the specified Span is equal to this one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : GetHashCode Method

Glossary Item Box

See System.Object.GetHashCode

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : ToString Method

Glossary Item Box

Returns a string representation of this object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents this object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


Span Structure Properties

[image]
ActiveReports 19 .NET Edition
Span Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Span Structure

Glossary Item Box

For a list of all members of this type, see Span members.

Public Properties

 | Name | Description
Public Property | Finish | The ending location of the text.
Public Property | IsValid | Determines if this object describes a valid location.
Public Property | Start | The starting location of the text.
Top

See Also

Reference

Span Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Finish Property

[image]
ActiveReports 19 .NET Edition
Finish Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : Finish Property

Glossary Item Box

The ending location of the text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Finish As Location
C#
public Location Finish {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


IsValid Property

[image]
ActiveReports 19 .NET Edition
IsValid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : IsValid Property

Glossary Item Box

Determines if this object describes a valid location.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


Start Property

[image]
ActiveReports 19 .NET Edition
Start Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : Start Property

Glossary Item Box

The starting location of the text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Start As Location
C#
public Location Start {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


Span Structure Fields

[image]
ActiveReports 19 .NET Edition
Span Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace : Span Structure

Glossary Item Box

For a list of all members of this type, see Span members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an uninitialized Span object.
Top

See Also

Reference

Span Structure
GrapeCity.Enterprise.Data.Expressions.Parser Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser Namespace > Span Structure : Empty Field

Glossary Item Box

Represents an uninitialized Span object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Span
C#
public static readonly Span Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Span Structure
Span Members


IntrinsicType Enumeration

[image]
ActiveReports 19 .NET Edition
IntrinsicType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace : IntrinsicType Enumeration

Glossary Item Box

Represents Intrinsic types

Syntax

Visual Basic (Declaration)
Public Enum IntrinsicType
   Inherits System.Enum
C#
public enum IntrinsicType : System.Enum

Members

Member | Description
Boolean | Boolean
Byte | Byte
Char | Char
Date | Date
Decimal | Decimal
Double | Double
Integer | Integer
Long | Long
Object | Object
Short | Short
Single | Single
String | String

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.Expressions.Parser.Trees.IntrinsicType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace


OperatorType Enumeration

[image]
ActiveReports 19 .NET Edition
OperatorType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace : OperatorType Enumeration

Glossary Item Box

Represents operator types

Syntax

Visual Basic (Declaration)
Public Enum OperatorType
   Inherits System.Enum
C#
public enum OperatorType : System.Enum

Members

Member | Description
And | And operator
AndAlso | AndAlso operator
Concatenate | Concatenate operator
Divide | Divide operator
Equals | Equals operator
GreaterThan | GreaterThan operator
GreaterThanEquals | GreaterThanEquals operator
IntegralDivide | IntegralDivide operator
Is | Is operator
LessThan | LessThan operator
LessThanEquals | LessThanEquals operator
Like | Like operator
Minus | Minus operator
Modulus | Modulus operator
Multiply | Multiply operator
Negate | Negate operator
None | None operator
Not | Not operator
NotEquals | NotEquals operator
Or | Or operator
OrElse | OrElse operator
Plus | Plus operator
Power | Power operator
ShiftLeft | ShiftLeft operator
ShiftRight | ShiftRight operator
UnaryPlus | UnaryPlus operator
Xor | Xor operator

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions.OperatorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace


EnumerableExtensions Class

[image]
ActiveReports 19 .NET Edition
EnumerableExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : EnumerableExtensions Class

Glossary Item Box

Provides additional LINQ extensions.

Object Model

EnumerableExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EnumerableExtensions
C#
public static class EnumerableExtensions

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Tools.EnumerableExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Members
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


EnumerableExtensions Class Members

[image]
ActiveReports 19 .NET Edition
EnumerableExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : EnumerableExtensions Class

Glossary Item Box

The following tables list the members exposed by EnumerableExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AsIndexed<T> | This method extends the LINQ methods to add index for each item
static (Shared in Visual Basic) | Flatten | Overloaded. This method extends the LINQ methods to flatten a collection of items that have a property of children of the same type.
static (Shared in Visual Basic) | Repeat<T> | Generates a sequence that contains one repeated value.
static (Shared in Visual Basic) | Select<T,TR> | Projection of given sequence with first, last markers.
static (Shared in Visual Basic) | SelectWithNext<TSource,TResult> | Proceeds each item in enumerable with its follower.
static (Shared in Visual Basic) | WithIndex<T> | Wraps an item of type T into type OrderedItem<T>, adding the specified index
static (Shared in Visual Basic) | ZipEx | Overloaded. Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results
Top

See Also

Reference

EnumerableExtensions Class
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


EnumerableExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
EnumerableExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : EnumerableExtensions Class

Glossary Item Box

For a list of all members of this type, see EnumerableExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AsIndexed<T> | This method extends the LINQ methods to add index for each item
static (Shared in Visual Basic) | Flatten | Overloaded. This method extends the LINQ methods to flatten a collection of items that have a property of children of the same type.
static (Shared in Visual Basic) | Repeat<T> | Generates a sequence that contains one repeated value.
static (Shared in Visual Basic) | Select<T,TR> | Projection of given sequence with first, last markers.
static (Shared in Visual Basic) | SelectWithNext<TSource,TResult> | Proceeds each item in enumerable with its follower.
static (Shared in Visual Basic) | WithIndex<T> | Wraps an item of type T into type OrderedItem<T>, adding the specified index
static (Shared in Visual Basic) | ZipEx | Overloaded. Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results
Top

See Also

Reference

EnumerableExtensions Class
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


AsIndexed<T> Method

T
Item type
[image]
ActiveReports 19 .NET Edition
AsIndexed<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : AsIndexed<T> Method

items
Initial sequence.

Glossary Item Box

This method extends the LINQ methods to add index for each item

Syntax

Visual Basic (Declaration)
Public Shared Function AsIndexed(Of T)( _
   ByVal items As IEnumerable(Of T) _
) As IEnumerable(Of OrderedItem(Of T))
C#
public static IEnumerable<OrderedItem<T>> AsIndexed<T>(
   IEnumerable<T> items
)

Parameters

items
Initial sequence.

Type Parameters

T
Item type

Return Value

Returns IEnumerable that represents sequence with indeses for items

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


Flatten Method

[image]
ActiveReports 19 .NET Edition
Flatten Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : Flatten Method

Glossary Item Box

This method extends the LINQ methods to flatten a collection of items that have a property of children of the same type.

Overload List

Overload | Description
Flatten<T>(IEnumerable<T>,Func<T,IEnumerable<T>>) | This method extends the LINQ methods to flatten a collection of items that have a property of children of the same type.
Flatten<T>(T,Func<T,IEnumerable<T>>) | This method extends the LINQ methods to obtain a single-level collection of descendants(is a collections) of an object of type T
Flatten<T>(T,Func<T,T>) | This method extends the LINQ methods to obtain a single-level collection of descendants(is an object) of an object of type T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


Flatten<T>(IEnumerable<T>,Func<T,IEnumerable<T>>) Method

T
Item type
[image]
ActiveReports 19 .NET Edition
Flatten<T>(IEnumerable<T>,Func<T,IEnumerable<T>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class > Flatten Method : Flatten<T>(IEnumerable<T>,Func<T,IEnumerable<T>>) Method

source
Source collection.
childSelector
function that returns a collection of children for each item

Glossary Item Box

This method extends the LINQ methods to flatten a collection of items that have a property of children of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Flatten(Of T)( _
   ByVal source As IEnumerable(Of T), _
   ByVal childSelector As Func(Of T,IEnumerable(Of T)) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Flatten<T>(
   IEnumerable<T> source,
   Func<T,IEnumerable<T>> childSelector
)

Parameters

source
Source collection.
childSelector
function that returns a collection of children for each item

Type Parameters

T
Item type

Return Value

Returns a one level list of elements of type T.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members
Overload List


Flatten<T>(T,Func<T,IEnumerable<T>>) Method

T
Item type.
[image]
ActiveReports 19 .NET Edition
Flatten<T>(T,Func<T,IEnumerable<T>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class > Flatten Method : Flatten<T>(T,Func<T,IEnumerable<T>>) Method

source
The object of type T.
childSelector
function that returns a collection of children

Glossary Item Box

This method extends the LINQ methods to obtain a single-level collection of descendants(is a collections) of an object of type T

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Flatten(Of T)( _
   ByVal source As T, _
   ByVal childSelector As Func(Of T,IEnumerable(Of T)) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Flatten<T>(
   T source,
   Func<T,IEnumerable<T>> childSelector
)

Parameters

source
The object of type T.
childSelector
function that returns a collection of children

Type Parameters

T
Item type.

Return Value

Returns a one level list of elements of type T.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members
Overload List


Flatten<T>(T,Func<T,T>) Method

T
Item type.
[image]
ActiveReports 19 .NET Edition
Flatten<T>(T,Func<T,T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class > Flatten Method : Flatten<T>(T,Func<T,T>) Method

source
The object of type T.
childSelector
function that returns of children object of type T.

Glossary Item Box

This method extends the LINQ methods to obtain a single-level collection of descendants(is an object) of an object of type T

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Flatten(Of T)( _
   ByVal source As T, _
   ByVal childSelector As Func(Of T,T) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Flatten<T>(
   T source,
   Func<T,T> childSelector
)

Parameters

source
The object of type T.
childSelector
function that returns of children object of type T.

Type Parameters

T
Item type.

Return Value

Returns a one level list of elements of type T.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members
Overload List


Repeat<T> Method

T
The type of the value to be repeated in the result sequence.
[image]
ActiveReports 19 .NET Edition
Repeat<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : Repeat<T> Method

item
The value to be repeated.
times
The number of times to repeat the value in the generated sequence

Glossary Item Box

Generates a sequence that contains one repeated value.

Syntax

Visual Basic (Declaration)
Public Shared Function Repeat(Of T)( _
   ByVal item As T, _
   ByVal times As Integer _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Repeat<T>(
   T item,
   int times
)

Parameters

item
The value to be repeated.
times
The number of times to repeat the value in the generated sequence

Type Parameters

T
The type of the value to be repeated in the result sequence.

Return Value

An IEnumerable that contains a repeated value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


Select<T,TR> Method

T
The type of the elements of the input sequence.
TR
The type of the elements of the result sequence.
[image]
ActiveReports 19 .NET Edition
Select<T,TR> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : Select<T,TR> Method

items
The sequence of elements to project.
selector
A transform function to apply to each element; the second and third parameters of the function represent whether the element is the first and last in the sequence, respectively.

Glossary Item Box

Projection of given sequence with first, last markers.

Syntax

Visual Basic (Declaration)
Public Shared Function Select
    (Of T,TR)( _
   ByVal items As IEnumerable(Of T), _
   ByVal selector As Func(Of T,Boolean,Boolean,TR) _
) As IEnumerable(Of TR)
C#
public static IEnumerable<TR> Select<T,TR>(
   IEnumerable<T> items,
   Func<T,bool,bool,TR> selector
)

Parameters

items
The sequence of elements to project.
selector
A transform function to apply to each element; the second and third parameters of the function represent whether the element is the first and last in the sequence, respectively.

Type Parameters

T
The type of the elements of the input sequence.
TR
The type of the elements of the result sequence.

Return Value

returns sequence from first to last marker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


SelectWithNext<TSource,TResult> Method

TSource
Type of collection item.
TResult
Type of result collection item.
[image]
ActiveReports 19 .NET Edition
SelectWithNext<TSource,TResult> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : SelectWithNext<TSource,TResult> Method

source
Source collection.
projection
Projection function (x,y) -> z, where x is current item and y is next.

Glossary Item Box

Proceeds each item in enumerable with its follower.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWithNext
    (Of TSource,TResult)( _
   ByVal source As IEnumerable(Of TSource), _
   ByVal projection As Func(Of TSource,TSource,TResult) _
) As IEnumerable(Of TResult)
C#
public static IEnumerable<TResult> SelectWithNext<TSource,TResult>(
   IEnumerable<TSource> source,
   Func<TSource,TSource,TResult> projection
)

Parameters

source
Source collection.
projection
Projection function (x,y) -> z, where x is current item and y is next.

Type Parameters

TSource
Type of collection item.
TResult
Type of result collection item.

Return Value

result of application of a projection function to source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


WithIndex<T> Method

T
Item type
[image]
ActiveReports 19 .NET Edition
WithIndex<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : WithIndex<T> Method

item
The item
index
Index for item

Glossary Item Box

Wraps an item of type T into type OrderedItem<T>, adding the specified index

Syntax

Visual Basic (Declaration)
Public Shared Function WithIndex(Of T)( _
   ByVal item As T, _
   ByVal index As Integer _
) As OrderedItem(Of T)
C#
public static OrderedItem<T> WithIndex<T>(
   T item,
   int index
)

Parameters

item
The item
index
Index for item

Type Parameters

T
Item type

Return Value

Returns new instance OrderedItem<T> with the specified index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


ZipEx Method

[image]
ActiveReports 19 .NET Edition
ZipEx Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class : ZipEx Method

Glossary Item Box

Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results

Overload List

Overload | Description
ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<T1,T2,TR>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results
ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<Int32,T1,T2,TR>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<T1,T2,TR>) Method

T1
The type of the elements of the first input sequence
T2
The type of the elements of the second input sequence
TR
The type of the elements of the result sequence
[image]
ActiveReports 19 .NET Edition
ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<T1,T2,TR>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class > ZipEx Method : ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<T1,T2,TR>) Method

first
The first sequence to merge
second
The second sequence to merge
selector
A function that specifies how to merge the elements from the two sequences

Glossary Item Box

Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ZipEx
    (Of T1,T2,TR)( _
   ByVal first As IEnumerable(Of T1), _
   ByVal second As IEnumerable(Of T2), _
   ByVal selector As Func(Of T1,T2,TR) _
) As IEnumerable(Of TR)
C#
public static IEnumerable<TR> ZipEx<T1,T2,TR>(
   IEnumerable<T1> first,
   IEnumerable<T2> second,
   Func<T1,T2,TR> selector
)

Parameters

first
The first sequence to merge
second
The second sequence to merge
selector
A function that specifies how to merge the elements from the two sequences

Type Parameters

T1
The type of the elements of the first input sequence
T2
The type of the elements of the second input sequence
TR
The type of the elements of the result sequence

Return Value

An IEnumerable that contains merged elements of two input sequences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members
Overload List


ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<Int32,T1,T2,TR>) Method

T1
The type of the elements of the first input sequence
T2
The type of the elements of the second input sequence
TR
The type of the elements of the result sequence
[image]
ActiveReports 19 .NET Edition
ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<Int32,T1,T2,TR>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > EnumerableExtensions Class > ZipEx Method : ZipEx<T1,T2,TR>(IEnumerable<T1>,IEnumerable<T2>,Func<Int32,T1,T2,TR>) Method

first
The first sequence to merge
second
The second sequence to merge
selector
A function that specifies how to merge the elements from the two sequences

Glossary Item Box

Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ZipEx
    (Of T1,T2,TR)( _
   ByVal first As IEnumerable(Of T1), _
   ByVal second As IEnumerable(Of T2), _
   ByVal selector As Func(Of Integer,T1,T2,TR) _
) As IEnumerable(Of TR)
C#
public static IEnumerable<TR> ZipEx<T1,T2,TR>(
   IEnumerable<T1> first,
   IEnumerable<T2> second,
   Func<int,T1,T2,TR> selector
)

Parameters

first
The first sequence to merge
second
The second sequence to merge
selector
A function that specifies how to merge the elements from the two sequences

Type Parameters

T1
The type of the elements of the first input sequence
T2
The type of the elements of the second input sequence
TR
The type of the elements of the result sequence

Return Value

An IEnumerable that contains merged elements of two input sequences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members
Overload List


OrderedItem<T> Structure

T
Item type.
[image]
ActiveReports 19 .NET Edition
OrderedItem<T> Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : OrderedItem<T> Structure

Glossary Item Box

Representation of item with index.

Object Model

OrderedItem<T> Structure

Syntax

Visual Basic (Declaration)
Public Structure OrderedItem(Of T)
   Inherits System.ValueType
C#
public struct OrderedItem<T> : System.ValueType

Type Parameters

T
Item type.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Tools.OrderedItem<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderedItem<T> Members
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


OrderedItem<T> Structure Members

[image]
ActiveReports 19 .NET Edition
OrderedItem<T> Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : OrderedItem<T> Structure

Glossary Item Box

The following tables list the members exposed by OrderedItem<T>.

Public Constructors

 | Name | Description
Public Constructor | OrderedItem<T> Constructor | Initializes a new instance of the OrderedItem struct
Top

Public Fields

 | Name | Description
Public Field | Index | Index of the item in collection.
Public Field | Item | Item itself.
Top

See Also

Reference

OrderedItem<T> Structure
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


OrderedItem<T> Constructor

[image]
ActiveReports 19 .NET Edition
OrderedItem<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > OrderedItem<T> Structure : OrderedItem<T> Constructor

index
index
item
item

Glossary Item Box

Initializes a new instance of the OrderedItem struct

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal index As Integer, _
   ByVal item As T _
)
C#
public OrderedItem<T>(
   int index,
   T item
)

Parameters

index
index
item
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderedItem<T> Structure
OrderedItem<T> Members


OrderedItem<T> Structure Fields

[image]
ActiveReports 19 .NET Edition
OrderedItem<T> Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace : OrderedItem<T> Structure

Glossary Item Box

For a list of all members of this type, see OrderedItem<T> members.

Public Fields

 | Name | Description
Public Field | Index | Index of the item in collection.
Public Field | Item | Item itself.
Top

See Also

Reference

OrderedItem<T> Structure
GrapeCity.Enterprise.Data.Expressions.Tools Namespace


Index Field

[image]
ActiveReports 19 .NET Edition
Index Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > OrderedItem<T> Structure : Index Field

Glossary Item Box

Index of the item in collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Index As Integer
C#
public readonly int Index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderedItem<T> Structure
OrderedItem<T> Members


Item Field

[image]
ActiveReports 19 .NET Edition
Item Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Tools Namespace > OrderedItem<T> Structure : Item Field

Glossary Item Box

Item itself.

Syntax

Visual Basic (Declaration)
Public ReadOnly Item As T
C#
public readonly T Item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderedItem<T> Structure
OrderedItem<T> Members


BooleanType Class

[image]
ActiveReports 19 .NET Edition
BooleanType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : BooleanType Class

Glossary Item Box

Represents conversions to Boolean

Object Model

BooleanType Class

Syntax

Visual Basic (Declaration)
Public Class BooleanType
C#
public class BooleanType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.BooleanType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BooleanType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


BooleanType Class Members

[image]
ActiveReports 19 .NET Edition
BooleanType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : BooleanType Class

Glossary Item Box

The following tables list the members exposed by BooleanType.

Public Constructors

 | Name | Description
Public Constructor | BooleanType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Boolean value.
Top

See Also

Reference

BooleanType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


BooleanType Constructor

[image]
ActiveReports 19 .NET Edition
BooleanType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > BooleanType Class : BooleanType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BooleanType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BooleanType Class
BooleanType Members


BooleanType Class Methods

[image]
ActiveReports 19 .NET Edition
BooleanType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : BooleanType Class

Glossary Item Box

For a list of all members of this type, see BooleanType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Boolean value.
Top

See Also

Reference

BooleanType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > BooleanType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a System.Boolean value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Boolean
C#
public static bool FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

A Boolean value. Returns False if the object is null; otherwise, True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BooleanType Class
BooleanType Members


ByteType Class

[image]
ActiveReports 19 .NET Edition
ByteType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ByteType Class

Glossary Item Box

Represents conversions to Byte

Object Model

ByteType Class

Syntax

Visual Basic (Declaration)
Public Class ByteType
C#
public class ByteType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.ByteType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ByteType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ByteType Class Members

[image]
ActiveReports 19 .NET Edition
ByteType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ByteType Class

Glossary Item Box

The following tables list the members exposed by ByteType.

Public Constructors

 | Name | Description
Public Constructor | ByteType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Byte value.
Top

See Also

Reference

ByteType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ByteType Constructor

[image]
ActiveReports 19 .NET Edition
ByteType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ByteType Class : ByteType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ByteType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ByteType Class
ByteType Members


ByteType Class Methods

[image]
ActiveReports 19 .NET Edition
ByteType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ByteType Class

Glossary Item Box

For a list of all members of this type, see ByteType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Byte value.
Top

See Also

Reference

ByteType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ByteType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a System.Byte value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Byte
C#
public static byte FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Byte value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ByteType Class
ByteType Members


CharType Class

[image]
ActiveReports 19 .NET Edition
CharType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : CharType Class

Glossary Item Box

Represents conversions to Char

Object Model

CharType Class

Syntax

Visual Basic (Declaration)
Public Class CharType
C#
public class CharType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.CharType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


CharType Class Members

[image]
ActiveReports 19 .NET Edition
CharType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : CharType Class

Glossary Item Box

The following tables list the members exposed by CharType.

Public Constructors

 | Name | Description
Public Constructor | CharType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromString | Converts a string to a System.Char value.
Top

See Also

Reference

CharType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


CharType Constructor

[image]
ActiveReports 19 .NET Edition
CharType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > CharType Class : CharType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CharType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Class
CharType Members


CharType Class Methods

[image]
ActiveReports 19 .NET Edition
CharType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : CharType Class

Glossary Item Box

For a list of all members of this type, see CharType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromString | Converts a string to a System.Char value.
Top

See Also

Reference

CharType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > CharType Class : FromString Method

value
The string to convert.

Glossary Item Box

Converts a string to a System.Char value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String _
) As Char
C#
public static char FromString(
   string value
)

Parameters

value
The string to convert.

Return Value

The Char value of the string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Class
CharType Members


Constants Class

[image]
ActiveReports 19 .NET Edition
Constants Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Constants Class

Glossary Item Box

The Constants module contains miscellaneous constants. These constants can be used anywhere in your code.

Object Model

Constants Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Constants
C#
public sealed class Constants

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Constants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Constants Class Members

[image]
ActiveReports 19 .NET Edition
Constants Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Constants Class

Glossary Item Box

The following tables list the members exposed by Constants.

Public Constructors

 | Name | Description
Public Constructor | Constants Constructor |
Top

Public Fields

 | Name | Description
Public Field | vbAbort | Represents the Abort button on a message box. This constant is returned by the MsgBox function to indicate that the Abort button was pressed.
Public Field | vbAbortRetryIgnore | Specifies that the message box should display Abort, Retry, and Ignore buttons, providing options for error handling.
Public Field | vbApplicationModal | Specifies that the message box is application modal, meaning it will stay on top of the application and require user interaction before the user can continue with the application. This style makes the message box block input to all windows in the application until the user responds.
Public Field | vbArchive | Specifies the archive file attribute. This attribute indicates that the file has been modified since it was last backed up. It is used by backup programs to mark files for backup.
Public Field | vbArray | Represents an array variant type, indicating that the variant contains an array. This value is used for variables that store arrays of any type.
Public Field | vbBack | Represents a backspace character for print and display functions.
Public Field | vbBinaryCompare | Specifies that string comparisons should be performed using a binary comparison.
Public Field | vbBoolean | Represents a boolean variant type, equivalent to the Visual Basic Boolean keyword. This value is used for variables that store True or False values.
Public Field | vbByte | Represents a byte variant type, equivalent to the Visual Basic Byte keyword. This value is used for variables that store byte values.
Public Field | vbCancel | Represents the Cancel button on a message box. This constant is returned by the MsgBox function to indicate that the Cancel button was pressed.
Public Field | vbCr | Represents a carriage-return character for print and display functions.
Public Field | vbCritical | Specifies that the message box should be displayed with a Critical Message icon, indicating an error message or serious warning.
Public Field | vbCrLf | Represents a carriage-return character combined with a linefeed character for print and display functions.
Public Field | vbCurrency | Represents a currency variant type, equivalent to the Visual Basic Currency keyword. This value is used for variables that store monetary values with high precision.
Public Field | vbDate | Represents a date variant type, equivalent to the Visual Basic Date keyword. This value is used for variables that store dates and times.
Public Field | vbDecimal | Represents a decimal variant type, equivalent to the Visual Basic Decimal keyword. This value is used for variables that store decimal numbers with high precision.
Public Field | vbDefaultButton1 | Specifies that the message box should display only the OK button. This constant is used to set the default button to OK.
Public Field | vbDefaultButton2 | Specifies that the second button on the message box should be set as the default button.
Public Field | vbDefaultButton3 | Specifies that the third button on the message box should be set as the default button.
Public Field | vbDirectory | Specifies the directory attribute. This attribute indicates that the file is a directory.
Public Field | vbDouble | Represents a double-precision floating-point variant type, equivalent to the Visual Basic Double keyword. This value is used for variables that store double-precision floating-point numbers.
Public Field | vbEmpty | Represents an uninitialized variant, equivalent to the Visual Basic Empty keyword. This value is used to indicate that a variable has not yet been initialized.
Public Field | vbExclamation | Specifies that the message box should be displayed with an Exclamation icon, indicating a warning message.
Public Field | vbFalse | Represents a Boolean false value when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbFirstFourDays | Specifies that the first week of the year is considered to be the first week that has at least four days in the new year for date-related functions.
Public Field | vbFirstFullWeek | Specifies that the first week of the year is considered to be the first full week of the year for date-related functions.
Public Field | vbFirstJan1 | Specifies that the first week of the year is considered to be the week containing January 1st for date-related functions.
Public Field | vbFormFeed | Represents a form-feed character for print functions.
Public Field | vbFriday | Specifies Friday as the first day of the week for date-related functions.
Public Field | vbGeneralDate | Specifies the general date format option for the FormatDateTime function, which includes both the date and time.
Public Field | vbGet | Specifies that the property being accessed when calling the CallByName function is to retrieve its value.
Public Field | vbHidden | Specifies the hidden file attribute. This attribute indicates that the file is not visible in an ordinary directory listing.
Public Field | vbHide | Specifies that the window of the invoked program should be hidden when calling the Shell function.
Public Field | vbHiragana | Specifies the Hiragana conversion type for the StrConv function, converting Katakana characters in a string to Hiragana.
Public Field | vbIgnore | Represents the Ignore button on a message box. This constant is returned by the MsgBox function to indicate that the Ignore button was pressed.
Public Field | vbInformation | Specifies that the message box should be displayed with an Information icon, indicating a message that conveys information.
Public Field | vbInteger | Represents an integer variant type, equivalent to the Visual Basic Integer keyword. This value is used for variables that store integer values.
Public Field | vbKatakana | Specifies the Katakana conversion type for the StrConv function, converting Hiragana characters in a string to Katakana.
Public Field | vbLet | Specifies that the property being accessed when calling the CallByName function is to assign a value to a simple property or to an element of an array property.
Public Field | vbLf | Represents a linefeed character for print and display functions.
Public Field | vbLinguisticCasing | Specifies the linguistic casing conversion type for the StrConv function, applying the current culture's casing rules to the string.
Public Field | vbLong | Represents a long integer variant type, equivalent to the Visual Basic Long keyword. This value is used for variables that store long integer values.
Public Field | vbLongDate | Specifies the long date format option for the FormatDateTime function, which presents the date in a full textual representation.
Public Field | vbLongTime | Specifies the long time format option for the FormatDateTime function, which includes the hour, minute, second, and AM/PM designation in a 12-hour format.
Public Field | vbLowerCase | Specifies the lowercase conversion type for the StrConv function, converting characters in a string to lowercase.
Public Field | vbMaximizedFocus | Specifies that the window of the invoked program should be maximized and receive focus when calling the Shell function.
Public Field | vbMethod | Specifies that the method being invoked when calling the CallByName function is a regular method.
Public Field | vbMinimizedFocus | Specifies that the window of the invoked program should be minimized and receive focus when calling the Shell function.
Public Field | vbMinimizedNoFocus | Specifies that the window of the invoked program should be minimized but not receive focus when calling the Shell function.
Public Field | vbMonday | Specifies Monday as the first day of the week for date-related functions.
Public Field | vbMsgBoxHelp | Specifies that the message box should display a Help button. This style is used to add a Help button to the message box, which can be linked to a Help file or Help context.
Public Field | vbMsgBoxRight | Specifies that the text in the message box should be right-aligned. This style is useful in certain locales or with specific text layouts.
Public Field | vbMsgBoxRtlReading | Specifies that the message box text should be displayed with right-to-left reading order. This style is used for languages that are read from right to left, such as Arabic or Hebrew.
Public Field | vbMsgBoxSetForeground | Specifies that the message box should appear in the foreground. This style ensures that the message box is displayed in the foreground, making it immediately visible to the user.
Public Field | vbNarrow | Specifies the narrow (half-width) characters conversion type for the StrConv function, converting characters in a string to their half-width equivalents.
Public Field | vbNewLine | Represents a newline character for print and display functions.
Public Field | vbNo | Represents the No button on a message box. This constant is returned by the MsgBox function to indicate that the No button was pressed.
Public Field | vbNormal | Specifies the normal file attribute. This attribute indicates that the file does not have other attributes set. This is the default attribute for most files.
Public Field | vbNormalFocus | Specifies that the window of the invoked program should be displayed in its normal size and position, and receive focus when calling the Shell function.
Public Field | vbNormalNoFocus | Specifies that the window of the invoked program should be displayed in its normal size and position but not receive focus when calling the Shell function.
Public Field | vbNull | Represents a variant with no valid data, equivalent to the Visual Basic Null keyword. This value is used to indicate the absence of a value or a null state.
Public Field | vbNullChar | Represents a null character for print and display functions.
Public Field | vbNullString | Represents a zero-length string for print and display functions, and for calling external procedures.
Public Field | vbObject | Represents an object variant type, equivalent to the Visual Basic Object keyword. This value is used for variables that store references to objects.
Public Field | vbObjectError | Represents the object error number. User-defined error numbers should be greater than this value.
Public Field | vbOK | Represents the OK button on a message box. This constant is returned by the MsgBox function to indicate that the OK button was pressed.
Public Field | vbOKCancel | Specifies that the message box should display both the OK and Cancel buttons, allowing the user to cancel the operation.
Public Field | vbOKOnly | Specifies that the message box should display only the OK button. This is the default button configuration.
Public Field | vbProperCase | Specifies the proper case conversion type for the StrConv function, converting the first character of each word in a string to uppercase and the remaining characters to lowercase.
Public Field | vbQuestion | Specifies that the message box should be displayed with a Question icon, indicating a query requiring a user response.
Public Field | vbReadOnly | Specifies the read-only file attribute. This attribute indicates that the file cannot be written to.
Public Field | vbRetry | Represents the Retry button on a message box. This constant is returned by the MsgBox function to indicate that the Retry button was pressed.
Public Field | vbRetryCancel | Specifies that the message box should display Retry and Cancel buttons, offering the option to retry an operation or cancel it.
Public Field | vbSaturday | Specifies Saturday as the first day of the week for date-related functions.
Public Field | vbSet | Specifies that the property being accessed when calling the CallByName function is to assign an object reference to a property.
Public Field | vbShortDate | Specifies the short date format option for the FormatDateTime function, which presents the date in a numerical format.
Public Field | vbShortTime | Specifies the short time format option for the FormatDateTime function, which includes the hour and minute in a 24-hour format.
Public Field | vbSimplifiedChinese | Specifies the simplified Chinese characters conversion type for the StrConv function, converting traditional Chinese characters in a string to simplified Chinese characters.
Public Field | vbSingle | Represents a single-precision floating-point variant type, equivalent to the Visual Basic Single keyword. This value is used for variables that store single-precision floating-point numbers.
Public Field | vbString | Represents a string variant type, equivalent to the Visual Basic String keyword. This value is used for variables that store text.
Public Field | vbSunday | Specifies Sunday as the first day of the week for date-related functions.
Public Field | vbSystem | Specifies the system file attribute. This attribute indicates that the file is part of the operating system or is used exclusively by the operating system.
Public Field | vbSystemModal | Specifies that the message box is system modal, meaning it will stay on top of all applications and require user interaction before the user can continue with any application on the system. This style makes the message box block input to all windows on the system.
Public Field | vbTab | Represents a tab character for print and display functions.
Public Field | vbTextCompare | Specifies that string comparisons should be performed using a textual comparison.
Public Field | vbThursday | Specifies Thursday as the first day of the week for date-related functions.
Public Field | vbTraditionalChinese | Specifies the traditional Chinese characters conversion type for the StrConv function, converting simplified Chinese characters in a string to traditional Chinese characters.
Public Field | vbTrue | Represents a Boolean true value when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbTuesday | Specifies Tuesday as the first day of the week for date-related functions.
Public Field | vbUpperCase | Specifies the uppercase conversion type for the StrConv function, converting characters in a string to uppercase.
Public Field | vbUseDefault | Represents the default behavior (as determined by the system) when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbUserDefinedType | Represents a user-defined type variant type, equivalent to the Visual Basic structure types. This value is used for variables that store user-defined types.
Public Field | vbUseSystem | Specifies that the system's setting should be used to determine the first week of the year for date-related functions.
Public Field | vbUseSystemDayOfWeek | Specifies the system's default as the first day of the week for date-related functions.
Public Field | vbVariant | Represents a variant type that can contain any type of data, equivalent to the Visual Basic Variant keyword. This value is used for variables that can store data of any type.
Public Field | vbVerticalTab | Represents a carriage-return character for print functions.
Public Field | vbVolume | Specifies the volume label attribute. This attribute is used to mark a disk volume and is not valid on files.
Public Field | vbWednesday | Specifies Wednesday as the first day of the week for date-related functions.
Public Field | vbWide | Specifies the wide (full-width) characters conversion type for the StrConv function, converting characters in a string to their full-width equivalents.
Public Field | vbYes | Represents the Yes button on a message box. This constant is returned by the MsgBox function to indicate that the Yes button was pressed.
Public Field | vbYesNo | Specifies that the message box should display Yes and No buttons, allowing a choice between two actions without the option to cancel.
Public Field | vbYesNoCancel | Specifies that the message box should display Yes, No, and Cancel buttons, offering a choice between two actions or the option to cancel.
Top

See Also

Reference

Constants Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Constants Constructor

[image]
ActiveReports 19 .NET Edition
Constants Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : Constants Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Constants()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


Constants Class Fields

[image]
ActiveReports 19 .NET Edition
Constants Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Constants Class

Glossary Item Box

For a list of all members of this type, see Constants members.

Public Fields

 | Name | Description
Public Field | vbAbort | Represents the Abort button on a message box. This constant is returned by the MsgBox function to indicate that the Abort button was pressed.
Public Field | vbAbortRetryIgnore | Specifies that the message box should display Abort, Retry, and Ignore buttons, providing options for error handling.
Public Field | vbApplicationModal | Specifies that the message box is application modal, meaning it will stay on top of the application and require user interaction before the user can continue with the application. This style makes the message box block input to all windows in the application until the user responds.
Public Field | vbArchive | Specifies the archive file attribute. This attribute indicates that the file has been modified since it was last backed up. It is used by backup programs to mark files for backup.
Public Field | vbArray | Represents an array variant type, indicating that the variant contains an array. This value is used for variables that store arrays of any type.
Public Field | vbBack | Represents a backspace character for print and display functions.
Public Field | vbBinaryCompare | Specifies that string comparisons should be performed using a binary comparison.
Public Field | vbBoolean | Represents a boolean variant type, equivalent to the Visual Basic Boolean keyword. This value is used for variables that store True or False values.
Public Field | vbByte | Represents a byte variant type, equivalent to the Visual Basic Byte keyword. This value is used for variables that store byte values.
Public Field | vbCancel | Represents the Cancel button on a message box. This constant is returned by the MsgBox function to indicate that the Cancel button was pressed.
Public Field | vbCr | Represents a carriage-return character for print and display functions.
Public Field | vbCritical | Specifies that the message box should be displayed with a Critical Message icon, indicating an error message or serious warning.
Public Field | vbCrLf | Represents a carriage-return character combined with a linefeed character for print and display functions.
Public Field | vbCurrency | Represents a currency variant type, equivalent to the Visual Basic Currency keyword. This value is used for variables that store monetary values with high precision.
Public Field | vbDate | Represents a date variant type, equivalent to the Visual Basic Date keyword. This value is used for variables that store dates and times.
Public Field | vbDecimal | Represents a decimal variant type, equivalent to the Visual Basic Decimal keyword. This value is used for variables that store decimal numbers with high precision.
Public Field | vbDefaultButton1 | Specifies that the message box should display only the OK button. This constant is used to set the default button to OK.
Public Field | vbDefaultButton2 | Specifies that the second button on the message box should be set as the default button.
Public Field | vbDefaultButton3 | Specifies that the third button on the message box should be set as the default button.
Public Field | vbDirectory | Specifies the directory attribute. This attribute indicates that the file is a directory.
Public Field | vbDouble | Represents a double-precision floating-point variant type, equivalent to the Visual Basic Double keyword. This value is used for variables that store double-precision floating-point numbers.
Public Field | vbEmpty | Represents an uninitialized variant, equivalent to the Visual Basic Empty keyword. This value is used to indicate that a variable has not yet been initialized.
Public Field | vbExclamation | Specifies that the message box should be displayed with an Exclamation icon, indicating a warning message.
Public Field | vbFalse | Represents a Boolean false value when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbFirstFourDays | Specifies that the first week of the year is considered to be the first week that has at least four days in the new year for date-related functions.
Public Field | vbFirstFullWeek | Specifies that the first week of the year is considered to be the first full week of the year for date-related functions.
Public Field | vbFirstJan1 | Specifies that the first week of the year is considered to be the week containing January 1st for date-related functions.
Public Field | vbFormFeed | Represents a form-feed character for print functions.
Public Field | vbFriday | Specifies Friday as the first day of the week for date-related functions.
Public Field | vbGeneralDate | Specifies the general date format option for the FormatDateTime function, which includes both the date and time.
Public Field | vbGet | Specifies that the property being accessed when calling the CallByName function is to retrieve its value.
Public Field | vbHidden | Specifies the hidden file attribute. This attribute indicates that the file is not visible in an ordinary directory listing.
Public Field | vbHide | Specifies that the window of the invoked program should be hidden when calling the Shell function.
Public Field | vbHiragana | Specifies the Hiragana conversion type for the StrConv function, converting Katakana characters in a string to Hiragana.
Public Field | vbIgnore | Represents the Ignore button on a message box. This constant is returned by the MsgBox function to indicate that the Ignore button was pressed.
Public Field | vbInformation | Specifies that the message box should be displayed with an Information icon, indicating a message that conveys information.
Public Field | vbInteger | Represents an integer variant type, equivalent to the Visual Basic Integer keyword. This value is used for variables that store integer values.
Public Field | vbKatakana | Specifies the Katakana conversion type for the StrConv function, converting Hiragana characters in a string to Katakana.
Public Field | vbLet | Specifies that the property being accessed when calling the CallByName function is to assign a value to a simple property or to an element of an array property.
Public Field | vbLf | Represents a linefeed character for print and display functions.
Public Field | vbLinguisticCasing | Specifies the linguistic casing conversion type for the StrConv function, applying the current culture's casing rules to the string.
Public Field | vbLong | Represents a long integer variant type, equivalent to the Visual Basic Long keyword. This value is used for variables that store long integer values.
Public Field | vbLongDate | Specifies the long date format option for the FormatDateTime function, which presents the date in a full textual representation.
Public Field | vbLongTime | Specifies the long time format option for the FormatDateTime function, which includes the hour, minute, second, and AM/PM designation in a 12-hour format.
Public Field | vbLowerCase | Specifies the lowercase conversion type for the StrConv function, converting characters in a string to lowercase.
Public Field | vbMaximizedFocus | Specifies that the window of the invoked program should be maximized and receive focus when calling the Shell function.
Public Field | vbMethod | Specifies that the method being invoked when calling the CallByName function is a regular method.
Public Field | vbMinimizedFocus | Specifies that the window of the invoked program should be minimized and receive focus when calling the Shell function.
Public Field | vbMinimizedNoFocus | Specifies that the window of the invoked program should be minimized but not receive focus when calling the Shell function.
Public Field | vbMonday | Specifies Monday as the first day of the week for date-related functions.
Public Field | vbMsgBoxHelp | Specifies that the message box should display a Help button. This style is used to add a Help button to the message box, which can be linked to a Help file or Help context.
Public Field | vbMsgBoxRight | Specifies that the text in the message box should be right-aligned. This style is useful in certain locales or with specific text layouts.
Public Field | vbMsgBoxRtlReading | Specifies that the message box text should be displayed with right-to-left reading order. This style is used for languages that are read from right to left, such as Arabic or Hebrew.
Public Field | vbMsgBoxSetForeground | Specifies that the message box should appear in the foreground. This style ensures that the message box is displayed in the foreground, making it immediately visible to the user.
Public Field | vbNarrow | Specifies the narrow (half-width) characters conversion type for the StrConv function, converting characters in a string to their half-width equivalents.
Public Field | vbNewLine | Represents a newline character for print and display functions.
Public Field | vbNo | Represents the No button on a message box. This constant is returned by the MsgBox function to indicate that the No button was pressed.
Public Field | vbNormal | Specifies the normal file attribute. This attribute indicates that the file does not have other attributes set. This is the default attribute for most files.
Public Field | vbNormalFocus | Specifies that the window of the invoked program should be displayed in its normal size and position, and receive focus when calling the Shell function.
Public Field | vbNormalNoFocus | Specifies that the window of the invoked program should be displayed in its normal size and position but not receive focus when calling the Shell function.
Public Field | vbNull | Represents a variant with no valid data, equivalent to the Visual Basic Null keyword. This value is used to indicate the absence of a value or a null state.
Public Field | vbNullChar | Represents a null character for print and display functions.
Public Field | vbNullString | Represents a zero-length string for print and display functions, and for calling external procedures.
Public Field | vbObject | Represents an object variant type, equivalent to the Visual Basic Object keyword. This value is used for variables that store references to objects.
Public Field | vbObjectError | Represents the object error number. User-defined error numbers should be greater than this value.
Public Field | vbOK | Represents the OK button on a message box. This constant is returned by the MsgBox function to indicate that the OK button was pressed.
Public Field | vbOKCancel | Specifies that the message box should display both the OK and Cancel buttons, allowing the user to cancel the operation.
Public Field | vbOKOnly | Specifies that the message box should display only the OK button. This is the default button configuration.
Public Field | vbProperCase | Specifies the proper case conversion type for the StrConv function, converting the first character of each word in a string to uppercase and the remaining characters to lowercase.
Public Field | vbQuestion | Specifies that the message box should be displayed with a Question icon, indicating a query requiring a user response.
Public Field | vbReadOnly | Specifies the read-only file attribute. This attribute indicates that the file cannot be written to.
Public Field | vbRetry | Represents the Retry button on a message box. This constant is returned by the MsgBox function to indicate that the Retry button was pressed.
Public Field | vbRetryCancel | Specifies that the message box should display Retry and Cancel buttons, offering the option to retry an operation or cancel it.
Public Field | vbSaturday | Specifies Saturday as the first day of the week for date-related functions.
Public Field | vbSet | Specifies that the property being accessed when calling the CallByName function is to assign an object reference to a property.
Public Field | vbShortDate | Specifies the short date format option for the FormatDateTime function, which presents the date in a numerical format.
Public Field | vbShortTime | Specifies the short time format option for the FormatDateTime function, which includes the hour and minute in a 24-hour format.
Public Field | vbSimplifiedChinese | Specifies the simplified Chinese characters conversion type for the StrConv function, converting traditional Chinese characters in a string to simplified Chinese characters.
Public Field | vbSingle | Represents a single-precision floating-point variant type, equivalent to the Visual Basic Single keyword. This value is used for variables that store single-precision floating-point numbers.
Public Field | vbString | Represents a string variant type, equivalent to the Visual Basic String keyword. This value is used for variables that store text.
Public Field | vbSunday | Specifies Sunday as the first day of the week for date-related functions.
Public Field | vbSystem | Specifies the system file attribute. This attribute indicates that the file is part of the operating system or is used exclusively by the operating system.
Public Field | vbSystemModal | Specifies that the message box is system modal, meaning it will stay on top of all applications and require user interaction before the user can continue with any application on the system. This style makes the message box block input to all windows on the system.
Public Field | vbTab | Represents a tab character for print and display functions.
Public Field | vbTextCompare | Specifies that string comparisons should be performed using a textual comparison.
Public Field | vbThursday | Specifies Thursday as the first day of the week for date-related functions.
Public Field | vbTraditionalChinese | Specifies the traditional Chinese characters conversion type for the StrConv function, converting simplified Chinese characters in a string to traditional Chinese characters.
Public Field | vbTrue | Represents a Boolean true value when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbTuesday | Specifies Tuesday as the first day of the week for date-related functions.
Public Field | vbUpperCase | Specifies the uppercase conversion type for the StrConv function, converting characters in a string to uppercase.
Public Field | vbUseDefault | Represents the default behavior (as determined by the system) when calling number-formatting and other functions that accept a TriState parameter.
Public Field | vbUserDefinedType | Represents a user-defined type variant type, equivalent to the Visual Basic structure types. This value is used for variables that store user-defined types.
Public Field | vbUseSystem | Specifies that the system's setting should be used to determine the first week of the year for date-related functions.
Public Field | vbUseSystemDayOfWeek | Specifies the system's default as the first day of the week for date-related functions.
Public Field | vbVariant | Represents a variant type that can contain any type of data, equivalent to the Visual Basic Variant keyword. This value is used for variables that can store data of any type.
Public Field | vbVerticalTab | Represents a carriage-return character for print functions.
Public Field | vbVolume | Specifies the volume label attribute. This attribute is used to mark a disk volume and is not valid on files.
Public Field | vbWednesday | Specifies Wednesday as the first day of the week for date-related functions.
Public Field | vbWide | Specifies the wide (full-width) characters conversion type for the StrConv function, converting characters in a string to their full-width equivalents.
Public Field | vbYes | Represents the Yes button on a message box. This constant is returned by the MsgBox function to indicate that the Yes button was pressed.
Public Field | vbYesNo | Specifies that the message box should display Yes and No buttons, allowing a choice between two actions without the option to cancel.
Public Field | vbYesNoCancel | Specifies that the message box should display Yes, No, and Cancel buttons, offering a choice between two actions or the option to cancel.
Top

See Also

Reference

Constants Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


vbAbort Field

[image]
ActiveReports 19 .NET Edition
vbAbort Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbAbort Field

Glossary Item Box

Represents the Abort button on a message box. This constant is returned by the MsgBox function to indicate that the Abort button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbAbort As MsgBoxResult
C#
public const MsgBoxResult vbAbort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbAbortRetryIgnore Field

[image]
ActiveReports 19 .NET Edition
vbAbortRetryIgnore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbAbortRetryIgnore Field

Glossary Item Box

Specifies that the message box should display Abort, Retry, and Ignore buttons, providing options for error handling.

Syntax

Visual Basic (Declaration)
Public Const vbAbortRetryIgnore As MsgBoxStyle
C#
public const MsgBoxStyle vbAbortRetryIgnore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbApplicationModal Field

[image]
ActiveReports 19 .NET Edition
vbApplicationModal Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbApplicationModal Field

Glossary Item Box

Specifies that the message box is application modal, meaning it will stay on top of the application and require user interaction before the user can continue with the application. This style makes the message box block input to all windows in the application until the user responds.

Syntax

Visual Basic (Declaration)
Public Const vbApplicationModal As MsgBoxStyle
C#
public const MsgBoxStyle vbApplicationModal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbArchive Field

[image]
ActiveReports 19 .NET Edition
vbArchive Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbArchive Field

Glossary Item Box

Specifies the archive file attribute. This attribute indicates that the file has been modified since it was last backed up. It is used by backup programs to mark files for backup.

Syntax

Visual Basic (Declaration)
Public Const vbArchive As FileAttribute
C#
public const FileAttribute vbArchive

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbArray Field

[image]
ActiveReports 19 .NET Edition
vbArray Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbArray Field

Glossary Item Box

Represents an array variant type, indicating that the variant contains an array. This value is used for variables that store arrays of any type.

Syntax

Visual Basic (Declaration)
Public Const vbArray As VariantType
C#
public const VariantType vbArray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbBack Field

[image]
ActiveReports 19 .NET Edition
vbBack Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbBack Field

Glossary Item Box

Represents a backspace character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbBack As String
C#
public const string vbBack

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbBinaryCompare Field

[image]
ActiveReports 19 .NET Edition
vbBinaryCompare Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbBinaryCompare Field

Glossary Item Box

Specifies that string comparisons should be performed using a binary comparison.

Syntax

Visual Basic (Declaration)
Public Const vbBinaryCompare As CompareMethod
C#
public const CompareMethod vbBinaryCompare

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbBoolean Field

[image]
ActiveReports 19 .NET Edition
vbBoolean Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbBoolean Field

Glossary Item Box

Represents a boolean variant type, equivalent to the Visual Basic Boolean keyword. This value is used for variables that store True or False values.

Syntax

Visual Basic (Declaration)
Public Const vbBoolean As VariantType
C#
public const VariantType vbBoolean

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbByte Field

[image]
ActiveReports 19 .NET Edition
vbByte Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbByte Field

Glossary Item Box

Represents a byte variant type, equivalent to the Visual Basic Byte keyword. This value is used for variables that store byte values.

Syntax

Visual Basic (Declaration)
Public Const vbByte As VariantType
C#
public const VariantType vbByte

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbCancel Field

[image]
ActiveReports 19 .NET Edition
vbCancel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbCancel Field

Glossary Item Box

Represents the Cancel button on a message box. This constant is returned by the MsgBox function to indicate that the Cancel button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbCancel As MsgBoxResult
C#
public const MsgBoxResult vbCancel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbCr Field

[image]
ActiveReports 19 .NET Edition
vbCr Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbCr Field

Glossary Item Box

Represents a carriage-return character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbCr As String
C#
public const string vbCr

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbCritical Field

[image]
ActiveReports 19 .NET Edition
vbCritical Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbCritical Field

Glossary Item Box

Specifies that the message box should be displayed with a Critical Message icon, indicating an error message or serious warning.

Syntax

Visual Basic (Declaration)
Public Const vbCritical As MsgBoxStyle
C#
public const MsgBoxStyle vbCritical

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbCrLf Field

[image]
ActiveReports 19 .NET Edition
vbCrLf Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbCrLf Field

Glossary Item Box

Represents a carriage-return character combined with a linefeed character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbCrLf As String
C#
public const string vbCrLf

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbCurrency Field

[image]
ActiveReports 19 .NET Edition
vbCurrency Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbCurrency Field

Glossary Item Box

Represents a currency variant type, equivalent to the Visual Basic Currency keyword. This value is used for variables that store monetary values with high precision.

Syntax

Visual Basic (Declaration)
Public Const vbCurrency As VariantType
C#
public const VariantType vbCurrency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDate Field

[image]
ActiveReports 19 .NET Edition
vbDate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDate Field

Glossary Item Box

Represents a date variant type, equivalent to the Visual Basic Date keyword. This value is used for variables that store dates and times.

Syntax

Visual Basic (Declaration)
Public Const vbDate As VariantType
C#
public const VariantType vbDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDecimal Field

[image]
ActiveReports 19 .NET Edition
vbDecimal Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDecimal Field

Glossary Item Box

Represents a decimal variant type, equivalent to the Visual Basic Decimal keyword. This value is used for variables that store decimal numbers with high precision.

Syntax

Visual Basic (Declaration)
Public Const vbDecimal As VariantType
C#
public const VariantType vbDecimal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDefaultButton1 Field

[image]
ActiveReports 19 .NET Edition
vbDefaultButton1 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDefaultButton1 Field

Glossary Item Box

Specifies that the message box should display only the OK button. This constant is used to set the default button to OK.

Syntax

Visual Basic (Declaration)
Public Const vbDefaultButton1 As MsgBoxStyle
C#
public const MsgBoxStyle vbDefaultButton1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDefaultButton2 Field

[image]
ActiveReports 19 .NET Edition
vbDefaultButton2 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDefaultButton2 Field

Glossary Item Box

Specifies that the second button on the message box should be set as the default button.

Syntax

Visual Basic (Declaration)
Public Const vbDefaultButton2 As MsgBoxStyle
C#
public const MsgBoxStyle vbDefaultButton2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDefaultButton3 Field

[image]
ActiveReports 19 .NET Edition
vbDefaultButton3 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDefaultButton3 Field

Glossary Item Box

Specifies that the third button on the message box should be set as the default button.

Syntax

Visual Basic (Declaration)
Public Const vbDefaultButton3 As MsgBoxStyle
C#
public const MsgBoxStyle vbDefaultButton3

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDirectory Field

[image]
ActiveReports 19 .NET Edition
vbDirectory Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDirectory Field

Glossary Item Box

Specifies the directory attribute. This attribute indicates that the file is a directory.

Syntax

Visual Basic (Declaration)
Public Const vbDirectory As FileAttribute
C#
public const FileAttribute vbDirectory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbDouble Field

[image]
ActiveReports 19 .NET Edition
vbDouble Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbDouble Field

Glossary Item Box

Represents a double-precision floating-point variant type, equivalent to the Visual Basic Double keyword. This value is used for variables that store double-precision floating-point numbers.

Syntax

Visual Basic (Declaration)
Public Const vbDouble As VariantType
C#
public const VariantType vbDouble

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbEmpty Field

[image]
ActiveReports 19 .NET Edition
vbEmpty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbEmpty Field

Glossary Item Box

Represents an uninitialized variant, equivalent to the Visual Basic Empty keyword. This value is used to indicate that a variable has not yet been initialized.

Syntax

Visual Basic (Declaration)
Public Const vbEmpty As VariantType
C#
public const VariantType vbEmpty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbExclamation Field

[image]
ActiveReports 19 .NET Edition
vbExclamation Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbExclamation Field

Glossary Item Box

Specifies that the message box should be displayed with an Exclamation icon, indicating a warning message.

Syntax

Visual Basic (Declaration)
Public Const vbExclamation As MsgBoxStyle
C#
public const MsgBoxStyle vbExclamation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFalse Field

[image]
ActiveReports 19 .NET Edition
vbFalse Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFalse Field

Glossary Item Box

Represents a Boolean false value when calling number-formatting and other functions that accept a TriState parameter.

Syntax

Visual Basic (Declaration)
Public Const vbFalse As TriState
C#
public const TriState vbFalse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFirstFourDays Field

[image]
ActiveReports 19 .NET Edition
vbFirstFourDays Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFirstFourDays Field

Glossary Item Box

Specifies that the first week of the year is considered to be the first week that has at least four days in the new year for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbFirstFourDays As FirstWeekOfYear
C#
public const FirstWeekOfYear vbFirstFourDays

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFirstFullWeek Field

[image]
ActiveReports 19 .NET Edition
vbFirstFullWeek Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFirstFullWeek Field

Glossary Item Box

Specifies that the first week of the year is considered to be the first full week of the year for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbFirstFullWeek As FirstWeekOfYear
C#
public const FirstWeekOfYear vbFirstFullWeek

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFirstJan1 Field

[image]
ActiveReports 19 .NET Edition
vbFirstJan1 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFirstJan1 Field

Glossary Item Box

Specifies that the first week of the year is considered to be the week containing January 1st for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbFirstJan1 As FirstWeekOfYear
C#
public const FirstWeekOfYear vbFirstJan1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFormFeed Field

[image]
ActiveReports 19 .NET Edition
vbFormFeed Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFormFeed Field

Glossary Item Box

Represents a form-feed character for print functions.

Syntax

Visual Basic (Declaration)
Public Const vbFormFeed As String
C#
public const string vbFormFeed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbFriday Field

[image]
ActiveReports 19 .NET Edition
vbFriday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbFriday Field

Glossary Item Box

Specifies Friday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbFriday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbFriday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbGeneralDate Field

[image]
ActiveReports 19 .NET Edition
vbGeneralDate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbGeneralDate Field

Glossary Item Box

Specifies the general date format option for the FormatDateTime function, which includes both the date and time.

Syntax

Visual Basic (Declaration)
Public Const vbGeneralDate As DateFormat
C#
public const DateFormat vbGeneralDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbGet Field

[image]
ActiveReports 19 .NET Edition
vbGet Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbGet Field

Glossary Item Box

Specifies that the property being accessed when calling the CallByName function is to retrieve its value.

Syntax

Visual Basic (Declaration)
Public Const vbGet As CallType
C#
public const CallType vbGet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbHidden Field

[image]
ActiveReports 19 .NET Edition
vbHidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbHidden Field

Glossary Item Box

Specifies the hidden file attribute. This attribute indicates that the file is not visible in an ordinary directory listing.

Syntax

Visual Basic (Declaration)
Public Const vbHidden As FileAttribute
C#
public const FileAttribute vbHidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbHide Field

[image]
ActiveReports 19 .NET Edition
vbHide Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbHide Field

Glossary Item Box

Specifies that the window of the invoked program should be hidden when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbHide As AppWinStyle
C#
public const AppWinStyle vbHide

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbHiragana Field

[image]
ActiveReports 19 .NET Edition
vbHiragana Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbHiragana Field

Glossary Item Box

Specifies the Hiragana conversion type for the StrConv function, converting Katakana characters in a string to Hiragana.

Syntax

Visual Basic (Declaration)
Public Const vbHiragana As VbStrConv
C#
public const VbStrConv vbHiragana

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbIgnore Field

[image]
ActiveReports 19 .NET Edition
vbIgnore Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbIgnore Field

Glossary Item Box

Represents the Ignore button on a message box. This constant is returned by the MsgBox function to indicate that the Ignore button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbIgnore As MsgBoxResult
C#
public const MsgBoxResult vbIgnore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbInformation Field

[image]
ActiveReports 19 .NET Edition
vbInformation Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbInformation Field

Glossary Item Box

Specifies that the message box should be displayed with an Information icon, indicating a message that conveys information.

Syntax

Visual Basic (Declaration)
Public Const vbInformation As MsgBoxStyle
C#
public const MsgBoxStyle vbInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbInteger Field

[image]
ActiveReports 19 .NET Edition
vbInteger Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbInteger Field

Glossary Item Box

Represents an integer variant type, equivalent to the Visual Basic Integer keyword. This value is used for variables that store integer values.

Syntax

Visual Basic (Declaration)
Public Const vbInteger As VariantType
C#
public const VariantType vbInteger

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbKatakana Field

[image]
ActiveReports 19 .NET Edition
vbKatakana Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbKatakana Field

Glossary Item Box

Specifies the Katakana conversion type for the StrConv function, converting Hiragana characters in a string to Katakana.

Syntax

Visual Basic (Declaration)
Public Const vbKatakana As VbStrConv
C#
public const VbStrConv vbKatakana

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLet Field

[image]
ActiveReports 19 .NET Edition
vbLet Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLet Field

Glossary Item Box

Specifies that the property being accessed when calling the CallByName function is to assign a value to a simple property or to an element of an array property.

Syntax

Visual Basic (Declaration)
Public Const vbLet As CallType
C#
public const CallType vbLet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLf Field

[image]
ActiveReports 19 .NET Edition
vbLf Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLf Field

Glossary Item Box

Represents a linefeed character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbLf As String
C#
public const string vbLf

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLinguisticCasing Field

[image]
ActiveReports 19 .NET Edition
vbLinguisticCasing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLinguisticCasing Field

Glossary Item Box

Specifies the linguistic casing conversion type for the StrConv function, applying the current culture's casing rules to the string.

Syntax

Visual Basic (Declaration)
Public Const vbLinguisticCasing As VbStrConv
C#
public const VbStrConv vbLinguisticCasing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLong Field

[image]
ActiveReports 19 .NET Edition
vbLong Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLong Field

Glossary Item Box

Represents a long integer variant type, equivalent to the Visual Basic Long keyword. This value is used for variables that store long integer values.

Syntax

Visual Basic (Declaration)
Public Const vbLong As VariantType
C#
public const VariantType vbLong

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLongDate Field

[image]
ActiveReports 19 .NET Edition
vbLongDate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLongDate Field

Glossary Item Box

Specifies the long date format option for the FormatDateTime function, which presents the date in a full textual representation.

Syntax

Visual Basic (Declaration)
Public Const vbLongDate As DateFormat
C#
public const DateFormat vbLongDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLongTime Field

[image]
ActiveReports 19 .NET Edition
vbLongTime Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLongTime Field

Glossary Item Box

Specifies the long time format option for the FormatDateTime function, which includes the hour, minute, second, and AM/PM designation in a 12-hour format.

Syntax

Visual Basic (Declaration)
Public Const vbLongTime As DateFormat
C#
public const DateFormat vbLongTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbLowerCase Field

[image]
ActiveReports 19 .NET Edition
vbLowerCase Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbLowerCase Field

Glossary Item Box

Specifies the lowercase conversion type for the StrConv function, converting characters in a string to lowercase.

Syntax

Visual Basic (Declaration)
Public Const vbLowerCase As VbStrConv
C#
public const VbStrConv vbLowerCase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMaximizedFocus Field

[image]
ActiveReports 19 .NET Edition
vbMaximizedFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMaximizedFocus Field

Glossary Item Box

Specifies that the window of the invoked program should be maximized and receive focus when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbMaximizedFocus As AppWinStyle
C#
public const AppWinStyle vbMaximizedFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMethod Field

[image]
ActiveReports 19 .NET Edition
vbMethod Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMethod Field

Glossary Item Box

Specifies that the method being invoked when calling the CallByName function is a regular method.

Syntax

Visual Basic (Declaration)
Public Const vbMethod As CallType
C#
public const CallType vbMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMinimizedFocus Field

[image]
ActiveReports 19 .NET Edition
vbMinimizedFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMinimizedFocus Field

Glossary Item Box

Specifies that the window of the invoked program should be minimized and receive focus when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbMinimizedFocus As AppWinStyle
C#
public const AppWinStyle vbMinimizedFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMinimizedNoFocus Field

[image]
ActiveReports 19 .NET Edition
vbMinimizedNoFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMinimizedNoFocus Field

Glossary Item Box

Specifies that the window of the invoked program should be minimized but not receive focus when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbMinimizedNoFocus As AppWinStyle
C#
public const AppWinStyle vbMinimizedNoFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMonday Field

[image]
ActiveReports 19 .NET Edition
vbMonday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMonday Field

Glossary Item Box

Specifies Monday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbMonday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbMonday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMsgBoxHelp Field

[image]
ActiveReports 19 .NET Edition
vbMsgBoxHelp Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMsgBoxHelp Field

Glossary Item Box

Specifies that the message box should display a Help button. This style is used to add a Help button to the message box, which can be linked to a Help file or Help context.

Syntax

Visual Basic (Declaration)
Public Const vbMsgBoxHelp As MsgBoxStyle
C#
public const MsgBoxStyle vbMsgBoxHelp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMsgBoxRight Field

[image]
ActiveReports 19 .NET Edition
vbMsgBoxRight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMsgBoxRight Field

Glossary Item Box

Specifies that the text in the message box should be right-aligned. This style is useful in certain locales or with specific text layouts.

Syntax

Visual Basic (Declaration)
Public Const vbMsgBoxRight As MsgBoxStyle
C#
public const MsgBoxStyle vbMsgBoxRight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMsgBoxRtlReading Field

[image]
ActiveReports 19 .NET Edition
vbMsgBoxRtlReading Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMsgBoxRtlReading Field

Glossary Item Box

Specifies that the message box text should be displayed with right-to-left reading order. This style is used for languages that are read from right to left, such as Arabic or Hebrew.

Syntax

Visual Basic (Declaration)
Public Const vbMsgBoxRtlReading As MsgBoxStyle
C#
public const MsgBoxStyle vbMsgBoxRtlReading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbMsgBoxSetForeground Field

[image]
ActiveReports 19 .NET Edition
vbMsgBoxSetForeground Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbMsgBoxSetForeground Field

Glossary Item Box

Specifies that the message box should appear in the foreground. This style ensures that the message box is displayed in the foreground, making it immediately visible to the user.

Syntax

Visual Basic (Declaration)
Public Const vbMsgBoxSetForeground As MsgBoxStyle
C#
public const MsgBoxStyle vbMsgBoxSetForeground

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNarrow Field

[image]
ActiveReports 19 .NET Edition
vbNarrow Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNarrow Field

Glossary Item Box

Specifies the narrow (half-width) characters conversion type for the StrConv function, converting characters in a string to their half-width equivalents.

Syntax

Visual Basic (Declaration)
Public Const vbNarrow As VbStrConv
C#
public const VbStrConv vbNarrow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNewLine Field

[image]
ActiveReports 19 .NET Edition
vbNewLine Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNewLine Field

Glossary Item Box

Represents a newline character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbNewLine As String
C#
public const string vbNewLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNo Field

[image]
ActiveReports 19 .NET Edition
vbNo Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNo Field

Glossary Item Box

Represents the No button on a message box. This constant is returned by the MsgBox function to indicate that the No button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbNo As MsgBoxResult
C#
public const MsgBoxResult vbNo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNormal Field

[image]
ActiveReports 19 .NET Edition
vbNormal Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNormal Field

Glossary Item Box

Specifies the normal file attribute. This attribute indicates that the file does not have other attributes set. This is the default attribute for most files.

Syntax

Visual Basic (Declaration)
Public Const vbNormal As FileAttribute
C#
public const FileAttribute vbNormal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNormalFocus Field

[image]
ActiveReports 19 .NET Edition
vbNormalFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNormalFocus Field

Glossary Item Box

Specifies that the window of the invoked program should be displayed in its normal size and position, and receive focus when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbNormalFocus As AppWinStyle
C#
public const AppWinStyle vbNormalFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNormalNoFocus Field

[image]
ActiveReports 19 .NET Edition
vbNormalNoFocus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNormalNoFocus Field

Glossary Item Box

Specifies that the window of the invoked program should be displayed in its normal size and position but not receive focus when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Const vbNormalNoFocus As AppWinStyle
C#
public const AppWinStyle vbNormalNoFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNull Field

[image]
ActiveReports 19 .NET Edition
vbNull Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNull Field

Glossary Item Box

Represents a variant with no valid data, equivalent to the Visual Basic Null keyword. This value is used to indicate the absence of a value or a null state.

Syntax

Visual Basic (Declaration)
Public Const vbNull As VariantType
C#
public const VariantType vbNull

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNullChar Field

[image]
ActiveReports 19 .NET Edition
vbNullChar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNullChar Field

Glossary Item Box

Represents a null character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbNullChar As String
C#
public const string vbNullChar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbNullString Field

[image]
ActiveReports 19 .NET Edition
vbNullString Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbNullString Field

Glossary Item Box

Represents a zero-length string for print and display functions, and for calling external procedures.

Syntax

Visual Basic (Declaration)
Public Const vbNullString As String
C#
public const string vbNullString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbObject Field

[image]
ActiveReports 19 .NET Edition
vbObject Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbObject Field

Glossary Item Box

Represents an object variant type, equivalent to the Visual Basic Object keyword. This value is used for variables that store references to objects.

Syntax

Visual Basic (Declaration)
Public Const vbObject As VariantType
C#
public const VariantType vbObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbObjectError Field

[image]
ActiveReports 19 .NET Edition
vbObjectError Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbObjectError Field

Glossary Item Box

Represents the object error number. User-defined error numbers should be greater than this value.

Syntax

Visual Basic (Declaration)
Public Const vbObjectError As Integer
C#
public const int vbObjectError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbOK Field

[image]
ActiveReports 19 .NET Edition
vbOK Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbOK Field

Glossary Item Box

Represents the OK button on a message box. This constant is returned by the MsgBox function to indicate that the OK button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbOK As MsgBoxResult
C#
public const MsgBoxResult vbOK

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbOKCancel Field

[image]
ActiveReports 19 .NET Edition
vbOKCancel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbOKCancel Field

Glossary Item Box

Specifies that the message box should display both the OK and Cancel buttons, allowing the user to cancel the operation.

Syntax

Visual Basic (Declaration)
Public Const vbOKCancel As MsgBoxStyle
C#
public const MsgBoxStyle vbOKCancel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbOKOnly Field

[image]
ActiveReports 19 .NET Edition
vbOKOnly Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbOKOnly Field

Glossary Item Box

Specifies that the message box should display only the OK button. This is the default button configuration.

Syntax

Visual Basic (Declaration)
Public Const vbOKOnly As MsgBoxStyle
C#
public const MsgBoxStyle vbOKOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbProperCase Field

[image]
ActiveReports 19 .NET Edition
vbProperCase Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbProperCase Field

Glossary Item Box

Specifies the proper case conversion type for the StrConv function, converting the first character of each word in a string to uppercase and the remaining characters to lowercase.

Syntax

Visual Basic (Declaration)
Public Const vbProperCase As VbStrConv
C#
public const VbStrConv vbProperCase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbQuestion Field

[image]
ActiveReports 19 .NET Edition
vbQuestion Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbQuestion Field

Glossary Item Box

Specifies that the message box should be displayed with a Question icon, indicating a query requiring a user response.

Syntax

Visual Basic (Declaration)
Public Const vbQuestion As MsgBoxStyle
C#
public const MsgBoxStyle vbQuestion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbReadOnly Field

[image]
ActiveReports 19 .NET Edition
vbReadOnly Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbReadOnly Field

Glossary Item Box

Specifies the read-only file attribute. This attribute indicates that the file cannot be written to.

Syntax

Visual Basic (Declaration)
Public Const vbReadOnly As FileAttribute
C#
public const FileAttribute vbReadOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbRetry Field

[image]
ActiveReports 19 .NET Edition
vbRetry Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbRetry Field

Glossary Item Box

Represents the Retry button on a message box. This constant is returned by the MsgBox function to indicate that the Retry button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbRetry As MsgBoxResult
C#
public const MsgBoxResult vbRetry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbRetryCancel Field

[image]
ActiveReports 19 .NET Edition
vbRetryCancel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbRetryCancel Field

Glossary Item Box

Specifies that the message box should display Retry and Cancel buttons, offering the option to retry an operation or cancel it.

Syntax

Visual Basic (Declaration)
Public Const vbRetryCancel As MsgBoxStyle
C#
public const MsgBoxStyle vbRetryCancel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSaturday Field

[image]
ActiveReports 19 .NET Edition
vbSaturday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSaturday Field

Glossary Item Box

Specifies Saturday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbSaturday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbSaturday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSet Field

[image]
ActiveReports 19 .NET Edition
vbSet Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSet Field

Glossary Item Box

Specifies that the property being accessed when calling the CallByName function is to assign an object reference to a property.

Syntax

Visual Basic (Declaration)
Public Const vbSet As CallType
C#
public const CallType vbSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbShortDate Field

[image]
ActiveReports 19 .NET Edition
vbShortDate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbShortDate Field

Glossary Item Box

Specifies the short date format option for the FormatDateTime function, which presents the date in a numerical format.

Syntax

Visual Basic (Declaration)
Public Const vbShortDate As DateFormat
C#
public const DateFormat vbShortDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbShortTime Field

[image]
ActiveReports 19 .NET Edition
vbShortTime Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbShortTime Field

Glossary Item Box

Specifies the short time format option for the FormatDateTime function, which includes the hour and minute in a 24-hour format.

Syntax

Visual Basic (Declaration)
Public Const vbShortTime As DateFormat
C#
public const DateFormat vbShortTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSimplifiedChinese Field

[image]
ActiveReports 19 .NET Edition
vbSimplifiedChinese Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSimplifiedChinese Field

Glossary Item Box

Specifies the simplified Chinese characters conversion type for the StrConv function, converting traditional Chinese characters in a string to simplified Chinese characters.

Syntax

Visual Basic (Declaration)
Public Const vbSimplifiedChinese As VbStrConv
C#
public const VbStrConv vbSimplifiedChinese

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSingle Field

[image]
ActiveReports 19 .NET Edition
vbSingle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSingle Field

Glossary Item Box

Represents a single-precision floating-point variant type, equivalent to the Visual Basic Single keyword. This value is used for variables that store single-precision floating-point numbers.

Syntax

Visual Basic (Declaration)
Public Const vbSingle As VariantType
C#
public const VariantType vbSingle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbString Field

[image]
ActiveReports 19 .NET Edition
vbString Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbString Field

Glossary Item Box

Represents a string variant type, equivalent to the Visual Basic String keyword. This value is used for variables that store text.

Syntax

Visual Basic (Declaration)
Public Const vbString As VariantType
C#
public const VariantType vbString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSunday Field

[image]
ActiveReports 19 .NET Edition
vbSunday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSunday Field

Glossary Item Box

Specifies Sunday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbSunday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbSunday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSystem Field

[image]
ActiveReports 19 .NET Edition
vbSystem Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSystem Field

Glossary Item Box

Specifies the system file attribute. This attribute indicates that the file is part of the operating system or is used exclusively by the operating system.

Syntax

Visual Basic (Declaration)
Public Const vbSystem As FileAttribute
C#
public const FileAttribute vbSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbSystemModal Field

[image]
ActiveReports 19 .NET Edition
vbSystemModal Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbSystemModal Field

Glossary Item Box

Specifies that the message box is system modal, meaning it will stay on top of all applications and require user interaction before the user can continue with any application on the system. This style makes the message box block input to all windows on the system.

Syntax

Visual Basic (Declaration)
Public Const vbSystemModal As MsgBoxStyle
C#
public const MsgBoxStyle vbSystemModal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbTab Field

[image]
ActiveReports 19 .NET Edition
vbTab Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbTab Field

Glossary Item Box

Represents a tab character for print and display functions.

Syntax

Visual Basic (Declaration)
Public Const vbTab As String
C#
public const string vbTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbTextCompare Field

[image]
ActiveReports 19 .NET Edition
vbTextCompare Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbTextCompare Field

Glossary Item Box

Specifies that string comparisons should be performed using a textual comparison.

Syntax

Visual Basic (Declaration)
Public Const vbTextCompare As CompareMethod
C#
public const CompareMethod vbTextCompare

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbThursday Field

[image]
ActiveReports 19 .NET Edition
vbThursday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbThursday Field

Glossary Item Box

Specifies Thursday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbThursday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbThursday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbTraditionalChinese Field

[image]
ActiveReports 19 .NET Edition
vbTraditionalChinese Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbTraditionalChinese Field

Glossary Item Box

Specifies the traditional Chinese characters conversion type for the StrConv function, converting simplified Chinese characters in a string to traditional Chinese characters.

Syntax

Visual Basic (Declaration)
Public Const vbTraditionalChinese As VbStrConv
C#
public const VbStrConv vbTraditionalChinese

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbTrue Field

[image]
ActiveReports 19 .NET Edition
vbTrue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbTrue Field

Glossary Item Box

Represents a Boolean true value when calling number-formatting and other functions that accept a TriState parameter.

Syntax

Visual Basic (Declaration)
Public Const vbTrue As TriState
C#
public const TriState vbTrue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbTuesday Field

[image]
ActiveReports 19 .NET Edition
vbTuesday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbTuesday Field

Glossary Item Box

Specifies Tuesday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbTuesday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbTuesday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbUpperCase Field

[image]
ActiveReports 19 .NET Edition
vbUpperCase Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbUpperCase Field

Glossary Item Box

Specifies the uppercase conversion type for the StrConv function, converting characters in a string to uppercase.

Syntax

Visual Basic (Declaration)
Public Const vbUpperCase As VbStrConv
C#
public const VbStrConv vbUpperCase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbUseDefault Field

[image]
ActiveReports 19 .NET Edition
vbUseDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbUseDefault Field

Glossary Item Box

Represents the default behavior (as determined by the system) when calling number-formatting and other functions that accept a TriState parameter.

Syntax

Visual Basic (Declaration)
Public Const vbUseDefault As TriState
C#
public const TriState vbUseDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbUserDefinedType Field

[image]
ActiveReports 19 .NET Edition
vbUserDefinedType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbUserDefinedType Field

Glossary Item Box

Represents a user-defined type variant type, equivalent to the Visual Basic structure types. This value is used for variables that store user-defined types.

Syntax

Visual Basic (Declaration)
Public Const vbUserDefinedType As VariantType
C#
public const VariantType vbUserDefinedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbUseSystem Field

[image]
ActiveReports 19 .NET Edition
vbUseSystem Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbUseSystem Field

Glossary Item Box

Specifies that the system's setting should be used to determine the first week of the year for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbUseSystem As FirstWeekOfYear
C#
public const FirstWeekOfYear vbUseSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbUseSystemDayOfWeek Field

[image]
ActiveReports 19 .NET Edition
vbUseSystemDayOfWeek Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbUseSystemDayOfWeek Field

Glossary Item Box

Specifies the system's default as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbUseSystemDayOfWeek As FirstDayOfWeek
C#
public const FirstDayOfWeek vbUseSystemDayOfWeek

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbVariant Field

[image]
ActiveReports 19 .NET Edition
vbVariant Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbVariant Field

Glossary Item Box

Represents a variant type that can contain any type of data, equivalent to the Visual Basic Variant keyword. This value is used for variables that can store data of any type.

Syntax

Visual Basic (Declaration)
Public Const vbVariant As VariantType
C#
public const VariantType vbVariant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbVerticalTab Field

[image]
ActiveReports 19 .NET Edition
vbVerticalTab Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbVerticalTab Field

Glossary Item Box

Represents a carriage-return character for print functions.

Syntax

Visual Basic (Declaration)
Public Const vbVerticalTab As String
C#
public const string vbVerticalTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbVolume Field

[image]
ActiveReports 19 .NET Edition
vbVolume Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbVolume Field

Glossary Item Box

Specifies the volume label attribute. This attribute is used to mark a disk volume and is not valid on files.

Syntax

Visual Basic (Declaration)
Public Const vbVolume As FileAttribute
C#
public const FileAttribute vbVolume

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbWednesday Field

[image]
ActiveReports 19 .NET Edition
vbWednesday Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbWednesday Field

Glossary Item Box

Specifies Wednesday as the first day of the week for date-related functions.

Syntax

Visual Basic (Declaration)
Public Const vbWednesday As FirstDayOfWeek
C#
public const FirstDayOfWeek vbWednesday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbWide Field

[image]
ActiveReports 19 .NET Edition
vbWide Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbWide Field

Glossary Item Box

Specifies the wide (full-width) characters conversion type for the StrConv function, converting characters in a string to their full-width equivalents.

Syntax

Visual Basic (Declaration)
Public Const vbWide As VbStrConv
C#
public const VbStrConv vbWide

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbYes Field

[image]
ActiveReports 19 .NET Edition
vbYes Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbYes Field

Glossary Item Box

Represents the Yes button on a message box. This constant is returned by the MsgBox function to indicate that the Yes button was pressed.

Syntax

Visual Basic (Declaration)
Public Const vbYes As MsgBoxResult
C#
public const MsgBoxResult vbYes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbYesNo Field

[image]
ActiveReports 19 .NET Edition
vbYesNo Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbYesNo Field

Glossary Item Box

Specifies that the message box should display Yes and No buttons, allowing a choice between two actions without the option to cancel.

Syntax

Visual Basic (Declaration)
Public Const vbYesNo As MsgBoxStyle
C#
public const MsgBoxStyle vbYesNo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


vbYesNoCancel Field

[image]
ActiveReports 19 .NET Edition
vbYesNoCancel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Constants Class : vbYesNoCancel Field

Glossary Item Box

Specifies that the message box should display Yes, No, and Cancel buttons, offering a choice between two actions or the option to cancel.

Syntax

Visual Basic (Declaration)
Public Const vbYesNoCancel As MsgBoxStyle
C#
public const MsgBoxStyle vbYesNoCancel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


Conversion Class

[image]
ActiveReports 19 .NET Edition
Conversion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversion Class

Glossary Item Box

Represents conversions in Visual Basic style

Object Model

Conversion Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Conversion
C#
public static class Conversion

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Conversion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Conversion Class Members

[image]
ActiveReports 19 .NET Edition
Conversion Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversion Class

Glossary Item Box

The following tables list the members exposed by Conversion.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CBool | Overloaded. Converts string to bool
static (Shared in Visual Basic) | CByte | Overloaded. Converts string to byte
static (Shared in Visual Basic) | CChar | Overloaded. Converts string to char
static (Shared in Visual Basic) | CDate | Overloaded. Converts string to DateTime
static (Shared in Visual Basic) | CDbl | Overloaded. Converts string to double
static (Shared in Visual Basic) | CDec | Overloaded. Converts string to decimal
static (Shared in Visual Basic) | CInt | Overloaded. Converts string to int
static (Shared in Visual Basic) | CLng | Overloaded. Converts string to long
static (Shared in Visual Basic) | CObj | Converts object to object
static (Shared in Visual Basic) | CShort | Overloaded. Converts string to short
static (Shared in Visual Basic) | CSng | Overloaded. Converts string to float
static (Shared in Visual Basic) | CStr | Overloaded. Converts a boolean value to its equivalent string representation.
static (Shared in Visual Basic) | Fix | Overloaded. Return the integer portion of a number.
static (Shared in Visual Basic) | Hex | Overloaded. Returns a string representing the hexadecimal value of a number.
static (Shared in Visual Basic) | Int | Overloaded. Return the integer portion of a number.
static (Shared in Visual Basic) | Oct | Overloaded. Returns a string representing the octal value of a number.
static (Shared in Visual Basic) | Str | Returns a String representation of a number.
static (Shared in Visual Basic) | Val | Overloaded. Returns the numbers contained in a string as a numeric value of appropriate type.
Top

See Also

Reference

Conversion Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Conversion Class Methods

[image]
ActiveReports 19 .NET Edition
Conversion Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversion Class

Glossary Item Box

For a list of all members of this type, see Conversion members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CBool | Overloaded. Converts string to bool
static (Shared in Visual Basic) | CByte | Overloaded. Converts string to byte
static (Shared in Visual Basic) | CChar | Overloaded. Converts string to char
static (Shared in Visual Basic) | CDate | Overloaded. Converts string to DateTime
static (Shared in Visual Basic) | CDbl | Overloaded. Converts string to double
static (Shared in Visual Basic) | CDec | Overloaded. Converts string to decimal
static (Shared in Visual Basic) | CInt | Overloaded. Converts string to int
static (Shared in Visual Basic) | CLng | Overloaded. Converts string to long
static (Shared in Visual Basic) | CObj | Converts object to object
static (Shared in Visual Basic) | CShort | Overloaded. Converts string to short
static (Shared in Visual Basic) | CSng | Overloaded. Converts string to float
static (Shared in Visual Basic) | CStr | Overloaded. Converts a boolean value to its equivalent string representation.
static (Shared in Visual Basic) | Fix | Overloaded. Return the integer portion of a number.
static (Shared in Visual Basic) | Hex | Overloaded. Returns a string representing the hexadecimal value of a number.
static (Shared in Visual Basic) | Int | Overloaded. Return the integer portion of a number.
static (Shared in Visual Basic) | Oct | Overloaded. Returns a string representing the octal value of a number.
static (Shared in Visual Basic) | Str | Returns a String representation of a number.
static (Shared in Visual Basic) | Val | Overloaded. Returns the numbers contained in a string as a numeric value of appropriate type.
Top

See Also

Reference

Conversion Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


CBool Method

[image]
ActiveReports 19 .NET Edition
CBool Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CBool Method

Glossary Item Box

Converts string to bool

Overload List

Overload | Description
CBool(String) | Converts string to bool
CBool(Object) | Converts object to bool

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CBool(String) Method

[image]
ActiveReports 19 .NET Edition
CBool(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CBool Method : CBool(String) Method

value
string value

Glossary Item Box

Converts string to bool

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CBool( _
   ByVal value As String _
) As Boolean
C#
public static bool CBool(
   string value
)

Parameters

value
string value

Return Value

bool value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CBool(Object) Method

[image]
ActiveReports 19 .NET Edition
CBool(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CBool Method : CBool(Object) Method

value
object value

Glossary Item Box

Converts object to bool

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CBool( _
   ByVal value As Object _
) As Boolean
C#
public static bool CBool(
   object value
)

Parameters

value
object value

Return Value

bool value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CByte Method

[image]
ActiveReports 19 .NET Edition
CByte Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CByte Method

Glossary Item Box

Converts string to byte

Overload List

Overload | Description
CByte(String) | Converts string to byte
CByte(Object) | Converts object to byte

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CByte(String) Method

[image]
ActiveReports 19 .NET Edition
CByte(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CByte Method : CByte(String) Method

value
string value

Glossary Item Box

Converts string to byte

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CByte( _
   ByVal value As String _
) As Byte
C#
public static byte CByte(
   string value
)

Parameters

value
string value

Return Value

byte value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CByte(Object) Method

[image]
ActiveReports 19 .NET Edition
CByte(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CByte Method : CByte(Object) Method

value
object value

Glossary Item Box

Converts object to byte

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CByte( _
   ByVal value As Object _
) As Byte
C#
public static byte CByte(
   object value
)

Parameters

value
object value

Return Value

byte value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CChar Method

[image]
ActiveReports 19 .NET Edition
CChar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CChar Method

Glossary Item Box

Converts string to char

Overload List

Overload | Description
CChar(String) | Converts string to char
CChar(Object) | Converts object to char

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CChar(String) Method

[image]
ActiveReports 19 .NET Edition
CChar(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CChar Method : CChar(String) Method

value
string value

Glossary Item Box

Converts string to char

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CChar( _
   ByVal value As String _
) As Char
C#
public static char CChar(
   string value
)

Parameters

value
string value

Return Value

char value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CChar(Object) Method

[image]
ActiveReports 19 .NET Edition
CChar(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CChar Method : CChar(Object) Method

value
object value

Glossary Item Box

Converts object to char

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CChar( _
   ByVal value As Object _
) As Char
C#
public static char CChar(
   object value
)

Parameters

value
object value

Return Value

char value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDate Method

[image]
ActiveReports 19 .NET Edition
CDate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CDate Method

Glossary Item Box

Converts string to DateTime

Overload List

Overload | Description
CDate(String) | Converts string to DateTime
CDate(Object) | Converts object to DateTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CDate(String) Method

[image]
ActiveReports 19 .NET Edition
CDate(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDate Method : CDate(String) Method

value
string value

Glossary Item Box

Converts string to DateTime

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDate( _
   ByVal value As String _
) As Date
C#
public static DateTime CDate(
   string value
)

Parameters

value
string value

Return Value

DateTime value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDate(Object) Method

[image]
ActiveReports 19 .NET Edition
CDate(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDate Method : CDate(Object) Method

value
object value

Glossary Item Box

Converts object to DateTime

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDate( _
   ByVal value As Object _
) As Date
C#
public static DateTime CDate(
   object value
)

Parameters

value
object value

Return Value

DateTime value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDbl Method

[image]
ActiveReports 19 .NET Edition
CDbl Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CDbl Method

Glossary Item Box

Converts string to double

Overload List

Overload | Description
CDbl(String) | Converts string to double
CDbl(Object) | Converts object to double

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CDbl(String) Method

[image]
ActiveReports 19 .NET Edition
CDbl(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDbl Method : CDbl(String) Method

value
string value

Glossary Item Box

Converts string to double

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDbl( _
   ByVal value As String _
) As Double
C#
public static double CDbl(
   string value
)

Parameters

value
string value

Return Value

double value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDbl(Object) Method

[image]
ActiveReports 19 .NET Edition
CDbl(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDbl Method : CDbl(Object) Method

value
object value

Glossary Item Box

Converts object to double

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDbl( _
   ByVal value As Object _
) As Double
C#
public static double CDbl(
   object value
)

Parameters

value
object value

Return Value

double value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDec Method

[image]
ActiveReports 19 .NET Edition
CDec Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CDec Method

Glossary Item Box

Converts string to decimal

Overload List

Overload | Description
CDec(String) | Converts string to decimal
CDec(Boolean) | Converts bool to decimal
CDec(Object) | Converts object to decimal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CDec(String) Method

[image]
ActiveReports 19 .NET Edition
CDec(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDec Method : CDec(String) Method

value
string value

Glossary Item Box

Converts string to decimal

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDec( _
   ByVal value As String _
) As Decimal
C#
public static decimal CDec(
   string value
)

Parameters

value
string value

Return Value

decimal value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDec(Boolean) Method

[image]
ActiveReports 19 .NET Edition
CDec(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDec Method : CDec(Boolean) Method

value
bool value

Glossary Item Box

Converts bool to decimal

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDec( _
   ByVal value As Boolean _
) As Decimal
C#
public static decimal CDec(
   bool value
)

Parameters

value
bool value

Return Value

decimal value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CDec(Object) Method

[image]
ActiveReports 19 .NET Edition
CDec(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CDec Method : CDec(Object) Method

value
object value

Glossary Item Box

Converts object to decimal

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CDec( _
   ByVal value As Object _
) As Decimal
C#
public static decimal CDec(
   object value
)

Parameters

value
object value

Return Value

decimal value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CInt Method

[image]
ActiveReports 19 .NET Edition
CInt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CInt Method

Glossary Item Box

Converts string to int

Overload List

Overload | Description
CInt(String) | Converts string to int
CInt(Object) | Converts object to int

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CInt(String) Method

[image]
ActiveReports 19 .NET Edition
CInt(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CInt Method : CInt(String) Method

value
string value

Glossary Item Box

Converts string to int

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CInt( _
   ByVal value As String _
) As Integer
C#
public static int CInt(
   string value
)

Parameters

value
string value

Return Value

int value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CInt(Object) Method

[image]
ActiveReports 19 .NET Edition
CInt(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CInt Method : CInt(Object) Method

value
object value

Glossary Item Box

Converts object to int

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CInt( _
   ByVal value As Object _
) As Integer
C#
public static int CInt(
   object value
)

Parameters

value
object value

Return Value

int value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CLng Method

[image]
ActiveReports 19 .NET Edition
CLng Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CLng Method

Glossary Item Box

Converts string to long

Overload List

Overload | Description
CLng(String) | Converts string to long
CLng(Object) | Converts object to long

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CLng(String) Method

[image]
ActiveReports 19 .NET Edition
CLng(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CLng Method : CLng(String) Method

value
string value

Glossary Item Box

Converts string to long

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CLng( _
   ByVal value As String _
) As Long
C#
public static long CLng(
   string value
)

Parameters

value
string value

Return Value

long value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CLng(Object) Method

[image]
ActiveReports 19 .NET Edition
CLng(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CLng Method : CLng(Object) Method

value
object value

Glossary Item Box

Converts object to long

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CLng( _
   ByVal value As Object _
) As Long
C#
public static long CLng(
   object value
)

Parameters

value
object value

Return Value

long value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CObj Method

[image]
ActiveReports 19 .NET Edition
CObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CObj Method

o
object value

Glossary Item Box

Converts object to object

Syntax

Visual Basic (Declaration)
Public Shared Function CObj( _
   ByVal o As Object _
) As Object
C#
public static object CObj(
   object o
)

Parameters

o
object value

Return Value

object value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CShort Method

[image]
ActiveReports 19 .NET Edition
CShort Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CShort Method

Glossary Item Box

Converts string to short

Overload List

Overload | Description
CShort(String) | Converts string to short
CShort(Object) | Converts object to short

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CShort(String) Method

[image]
ActiveReports 19 .NET Edition
CShort(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CShort Method : CShort(String) Method

value
string value

Glossary Item Box

Converts string to short

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CShort( _
   ByVal value As String _
) As Short
C#
public static short CShort(
   string value
)

Parameters

value
string value

Return Value

short value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CShort(Object) Method

[image]
ActiveReports 19 .NET Edition
CShort(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CShort Method : CShort(Object) Method

value
object value

Glossary Item Box

Converts object to short

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CShort( _
   ByVal value As Object _
) As Short
C#
public static short CShort(
   object value
)

Parameters

value
object value

Return Value

short value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CSng Method

[image]
ActiveReports 19 .NET Edition
CSng Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CSng Method

Glossary Item Box

Converts string to float

Overload List

Overload | Description
CSng(String) | Converts string to float
CSng(Object) | Converts object to float

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CSng(String) Method

[image]
ActiveReports 19 .NET Edition
CSng(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CSng Method : CSng(String) Method

value
string value

Glossary Item Box

Converts string to float

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CSng( _
   ByVal value As String _
) As Single
C#
public static float CSng(
   string value
)

Parameters

value
string value

Return Value

float value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CSng(Object) Method

[image]
ActiveReports 19 .NET Edition
CSng(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CSng Method : CSng(Object) Method

value
object value

Glossary Item Box

Converts object to float

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CSng( _
   ByVal value As Object _
) As Single
C#
public static float CSng(
   object value
)

Parameters

value
object value

Return Value

float value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr Method

[image]
ActiveReports 19 .NET Edition
CStr Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : CStr Method

Glossary Item Box

Converts a boolean value to its equivalent string representation.

Overload List

Overload | Description
CStr(Boolean) | Converts a boolean value to its equivalent string representation.
CStr(Char) | Converts a char value to its equivalent string representation.
CStr(Int32) | Converts an integer value to its equivalent string representation.
CStr(UInt32) | Converts an unsigned integer (uint) value to its equivalent string representation.
CStr(Int64) | Converts a long integer value to its equivalent string representation.
CStr(UInt64) | Converts an unsigned long (ulong) value to its equivalent string representation.
CStr(Single) | Converts a float value to its equivalent string representation.
CStr(Double) | Converts a double-precision floating-point number to its equivalent string representation.
CStr(DateTime) | Converts a DateTime value to its equivalent string representation.
CStr(Decimal) | Converts a decimal value to its equivalent string representation.
CStr(Object) | Converts an object to its equivalent string representation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


CStr(Boolean) Method

[image]
ActiveReports 19 .NET Edition
CStr(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Boolean) Method

value
The boolean value to convert.

Glossary Item Box

Converts a boolean value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Boolean _
) As String
C#
public static string CStr(
   bool value
)

Parameters

value
The boolean value to convert.

Return Value

A string representation of the boolean value, where true is converted to "True" and false is converted to "False".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Char) Method

[image]
ActiveReports 19 .NET Edition
CStr(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Char) Method

value
The char value to convert.

Glossary Item Box

Converts a char value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Char _
) As String
C#
public static string CStr(
   char value
)

Parameters

value
The char value to convert.

Return Value

A string representation of the char value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Int32) Method

[image]
ActiveReports 19 .NET Edition
CStr(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Int32) Method

value
The integer value to convert.

Glossary Item Box

Converts an integer value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Integer _
) As String
C#
public static string CStr(
   int value
)

Parameters

value
The integer value to convert.

Return Value

A string representation of the integer value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(UInt32) Method

[image]
ActiveReports 19 .NET Edition
CStr(UInt32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(UInt32) Method

value
The unsigned integer value to convert.

Glossary Item Box

Converts an unsigned integer (uint) value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As UInteger _
) As String
C#
public static string CStr(
   uint value
)

Parameters

value
The unsigned integer value to convert.

Return Value

A string representation of the unsigned integer value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Int64) Method

[image]
ActiveReports 19 .NET Edition
CStr(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Int64) Method

value
The long integer value to convert.

Glossary Item Box

Converts a long integer value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Long _
) As String
C#
public static string CStr(
   long value
)

Parameters

value
The long integer value to convert.

Return Value

A string representation of the long integer value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(UInt64) Method

[image]
ActiveReports 19 .NET Edition
CStr(UInt64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(UInt64) Method

value
The unsigned long value to convert.

Glossary Item Box

Converts an unsigned long (ulong) value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As ULong _
) As String
C#
public static string CStr(
   ulong value
)

Parameters

value
The unsigned long value to convert.

Return Value

A string representation of the unsigned long value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Single) Method

[image]
ActiveReports 19 .NET Edition
CStr(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Single) Method

value
The float value to convert.

Glossary Item Box

Converts a float value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Single _
) As String
C#
public static string CStr(
   float value
)

Parameters

value
The float value to convert.

Return Value

A string representation of the float value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Double) Method

[image]
ActiveReports 19 .NET Edition
CStr(Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Double) Method

value
The double value to convert.

Glossary Item Box

Converts a double-precision floating-point number to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Double _
) As String
C#
public static string CStr(
   double value
)

Parameters

value
The double value to convert.

Return Value

A string representation of the double value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(DateTime) Method

[image]
ActiveReports 19 .NET Edition
CStr(DateTime) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(DateTime) Method

value
The DateTime value to convert.

Glossary Item Box

Converts a DateTime value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Date _
) As String
C#
public static string CStr(
   DateTime value
)

Parameters

value
The DateTime value to convert.

Return Value

A string representation of the DateTime value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Decimal) Method

[image]
ActiveReports 19 .NET Edition
CStr(Decimal) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Decimal) Method

value
The decimal value to convert.

Glossary Item Box

Converts a decimal value to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Decimal _
) As String
C#
public static string CStr(
   decimal value
)

Parameters

value
The decimal value to convert.

Return Value

A string representation of the decimal value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


CStr(Object) Method

[image]
ActiveReports 19 .NET Edition
CStr(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > CStr Method : CStr(Object) Method

value
The object to convert.

Glossary Item Box

Converts an object to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CStr( _
   ByVal value As Object _
) As String
C#
public static string CStr(
   object value
)

Parameters

value
The object to convert.

Return Value

A string representation of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix Method

[image]
ActiveReports 19 .NET Edition
Fix Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Fix Method

Glossary Item Box

Return the integer portion of a number.

Overload List

Overload | Description
Fix(Int16) | Return the integer portion of a number.
Fix(Int32) | Return the integer portion of a number.
Fix(Int64) | Return the integer portion of a number.
Fix(Double) | Return the integer portion of a number.
Fix(Single) | Return the integer portion of a number.
Fix(Decimal) | Return the integer portion of a number.
Fix(Object) | Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Fix(Int16) Method

[image]
ActiveReports 19 .NET Edition
Fix(Int16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Int16) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Short _
) As Short
C#
public static short Fix(
   short number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Int32) Method

[image]
ActiveReports 19 .NET Edition
Fix(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Int32) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Integer _
) As Integer
C#
public static int Fix(
   int number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Int64) Method

[image]
ActiveReports 19 .NET Edition
Fix(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Int64) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Long _
) As Long
C#
public static long Fix(
   long number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Double) Method

[image]
ActiveReports 19 .NET Edition
Fix(Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Double) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Double _
) As Double
C#
public static double Fix(
   double number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Single) Method

[image]
ActiveReports 19 .NET Edition
Fix(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Single) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Single _
) As Single
C#
public static float Fix(
   float number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Decimal) Method

[image]
ActiveReports 19 .NET Edition
Fix(Decimal) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Decimal) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Decimal _
) As Decimal
C#
public static decimal Fix(
   decimal number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Fix(Object) Method

[image]
ActiveReports 19 .NET Edition
Fix(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Fix Method : Fix(Object) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Fix( _
   ByVal number As Object _
) As Object
C#
public static object Fix(
   object number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex Method

[image]
ActiveReports 19 .NET Edition
Hex Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Hex Method

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Overload List

Overload | Description
Hex(SByte) | Returns a string representing the hexadecimal value of a number.
Hex(Byte) | Returns a string representing the hexadecimal value of a number.
Hex(Int16) | Returns a string representing the hexadecimal value of a number.
Hex(UInt16) | Returns a string representing the hexadecimal value of a number.
Hex(Int32) | Returns a string representing the hexadecimal value of a number.
Hex(UInt32) | Returns a string representing the hexadecimal value of a number.
Hex(Int64) | Returns a string representing the hexadecimal value of a number.
Hex(UInt64) | Returns a string representing the hexadecimal value of a number.
Hex(Object) | Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Hex(SByte) Method

[image]
ActiveReports 19 .NET Edition
Hex(SByte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(SByte) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As SByte _
) As String
C#
public static string Hex(
   sbyte number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(Byte) Method

[image]
ActiveReports 19 .NET Edition
Hex(Byte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(Byte) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As Byte _
) As String
C#
public static string Hex(
   byte number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(Int16) Method

[image]
ActiveReports 19 .NET Edition
Hex(Int16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(Int16) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As Short _
) As String
C#
public static string Hex(
   short number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(UInt16) Method

[image]
ActiveReports 19 .NET Edition
Hex(UInt16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(UInt16) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As UShort _
) As String
C#
public static string Hex(
   ushort number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(Int32) Method

[image]
ActiveReports 19 .NET Edition
Hex(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(Int32) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As Integer _
) As String
C#
public static string Hex(
   int number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(UInt32) Method

[image]
ActiveReports 19 .NET Edition
Hex(UInt32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(UInt32) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As UInteger _
) As String
C#
public static string Hex(
   uint number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(Int64) Method

[image]
ActiveReports 19 .NET Edition
Hex(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(Int64) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As Long _
) As String
C#
public static string Hex(
   long number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(UInt64) Method

[image]
ActiveReports 19 .NET Edition
Hex(UInt64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(UInt64) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As ULong _
) As String
C#
public static string Hex(
   ulong number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Hex(Object) Method

[image]
ActiveReports 19 .NET Edition
Hex(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Hex Method : Hex(Object) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the hexadecimal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Hex( _
   ByVal number As Object _
) As String
C#
public static string Hex(
   object number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the hexadecimal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int Method

[image]
ActiveReports 19 .NET Edition
Int Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Int Method

Glossary Item Box

Return the integer portion of a number.

Overload List

Overload | Description
Int(Int16) | Return the integer portion of a number.
Int(Int32) | Return the integer portion of a number.
Int(Int64) | Return the integer portion of a number.
Int(Double) | Return the integer portion of a number.
Int(Single) | Return the integer portion of a number.
Int(Decimal) | Return the integer portion of a number.
Int(Object) | Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Int(Int16) Method

[image]
ActiveReports 19 .NET Edition
Int(Int16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Int16) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Short _
) As Short
C#
public static short Int(
   short number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Int32) Method

[image]
ActiveReports 19 .NET Edition
Int(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Int32) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Integer _
) As Integer
C#
public static int Int(
   int number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Int64) Method

[image]
ActiveReports 19 .NET Edition
Int(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Int64) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Long _
) As Long
C#
public static long Int(
   long number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Double) Method

[image]
ActiveReports 19 .NET Edition
Int(Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Double) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Double _
) As Double
C#
public static double Int(
   double number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Single) Method

[image]
ActiveReports 19 .NET Edition
Int(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Single) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Single _
) As Single
C#
public static float Int(
   float number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Decimal) Method

[image]
ActiveReports 19 .NET Edition
Int(Decimal) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Decimal) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Decimal _
) As Decimal
C#
public static decimal Int(
   decimal number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Int(Object) Method

[image]
ActiveReports 19 .NET Edition
Int(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Int Method : Int(Object) Method

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Glossary Item Box

Return the integer portion of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Int( _
   ByVal number As Object _
) As Object
C#
public static object Int(
   object number
)

Parameters

number
Required. A number of type Double or any valid numeric expression. If number contains Nothing, Nothing is returned.

Return Value

Return the integer portion of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct Method

[image]
ActiveReports 19 .NET Edition
Oct Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Oct Method

Glossary Item Box

Returns a string representing the octal value of a number.

Overload List

Overload | Description
Oct(SByte) | Returns a string representing the octal value of a number.
Oct(Byte) | Returns a string representing the octal value of a number.
Oct(Int16) | Returns a string representing the octal value of a number.
Oct(UInt16) | Returns a string representing the octal value of a number.
Oct(Int32) | Returns a string representing the octal value of a number.
Oct(UInt32) | Returns a string representing the octal value of a number.
Oct(Int64) | Returns a string representing the octal value of a number.
Oct(UInt64) | Returns a string representing the octal value of a number.
Oct(Object) | Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Oct(SByte) Method

[image]
ActiveReports 19 .NET Edition
Oct(SByte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(SByte) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As SByte _
) As String
C#
public static string Oct(
   sbyte number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(Byte) Method

[image]
ActiveReports 19 .NET Edition
Oct(Byte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(Byte) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As Byte _
) As String
C#
public static string Oct(
   byte number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(Int16) Method

[image]
ActiveReports 19 .NET Edition
Oct(Int16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(Int16) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As Short _
) As String
C#
public static string Oct(
   short number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(UInt16) Method

[image]
ActiveReports 19 .NET Edition
Oct(UInt16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(UInt16) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As UShort _
) As String
C#
public static string Oct(
   ushort number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(Int32) Method

[image]
ActiveReports 19 .NET Edition
Oct(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(Int32) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As Integer _
) As String
C#
public static string Oct(
   int number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(UInt32) Method

[image]
ActiveReports 19 .NET Edition
Oct(UInt32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(UInt32) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As UInteger _
) As String
C#
public static string Oct(
   uint number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(Int64) Method

[image]
ActiveReports 19 .NET Edition
Oct(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(Int64) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As Long _
) As String
C#
public static string Oct(
   long number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(UInt64) Method

[image]
ActiveReports 19 .NET Edition
Oct(UInt64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(UInt64) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As ULong _
) As String
C#
public static string Oct(
   ulong number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Oct(Object) Method

[image]
ActiveReports 19 .NET Edition
Oct(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Oct Method : Oct(Object) Method

number
Required. Any valid numeric expression or String expression.

Glossary Item Box

Returns a string representing the octal value of a number.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Oct( _
   ByVal number As Object _
) As String
C#
public static string Oct(
   object number
)

Parameters

number
Required. Any valid numeric expression or String expression.

Return Value

Returns a string representing the octal value of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Str Method

[image]
ActiveReports 19 .NET Edition
Str Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Str Method

number
Required. An Object containing any valid numeric expression.

Glossary Item Box

Returns a String representation of a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Str( _
   ByVal number As Object _
) As String
C#
public static string Str(
   object number
)

Parameters

number
Required. An Object containing any valid numeric expression.

Return Value

Returns a String representation of a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Val Method

[image]
ActiveReports 19 .NET Edition
Val Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class : Val Method

Glossary Item Box

Returns the numbers contained in a string as a numeric value of appropriate type.

Overload List

Overload | Description
Val(String) | Returns the numbers contained in a string as a numeric value of appropriate type.
Val(Char) | Returns the numbers contained in a string as a numeric value of appropriate type.
Val(Object) | Returns the numbers contained in a string as a numeric value of appropriate type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members


Val(String) Method

[image]
ActiveReports 19 .NET Edition
Val(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Val Method : Val(String) Method

inputStr
Required. Any valid String expression, Object variable, or Char value. If inputStr is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Glossary Item Box

Returns the numbers contained in a string as a numeric value of appropriate type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Val( _
   ByVal inputStr As String _
) As Double
C#
public static double Val(
   string inputStr
)

Parameters

inputStr
Required. Any valid String expression, Object variable, or Char value. If inputStr is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Return Value

Returns the numbers contained in a string as a numeric value of appropriate type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Val(Char) Method

[image]
ActiveReports 19 .NET Edition
Val(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Val Method : Val(Char) Method

expression
Required. Any valid String expression, Object variable, or Char value. If expression is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Glossary Item Box

Returns the numbers contained in a string as a numeric value of appropriate type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Val( _
   ByVal expression As Char _
) As Integer
C#
public static int Val(
   char expression
)

Parameters

expression
Required. Any valid String expression, Object variable, or Char value. If expression is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Return Value

Returns the numbers contained in a string as a numeric value of appropriate type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Val(Object) Method

[image]
ActiveReports 19 .NET Edition
Val(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversion Class > Val Method : Val(Object) Method

expression
Required. Any valid String expression, Object variable, or Char value. If expression is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Glossary Item Box

Returns the numbers contained in a string as a numeric value of appropriate type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Val( _
   ByVal expression As Object _
) As Double
C#
public static double Val(
   object expression
)

Parameters

expression
Required. Any valid String expression, Object variable, or Char value. If expression is of type Object, its value must be convertible to String or an System.ArgumentException error occurs.

Return Value

Returns the numbers contained in a string as a numeric value of appropriate type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversion Class
Conversion Members
Overload List


Conversions Class

[image]
ActiveReports 19 .NET Edition
Conversions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversions Class

Glossary Item Box

Represents conversion methods

Object Model

Conversions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Conversions
C#
public static class Conversions

Remarks

Only for direct invoking. Shouldn't be reflected.This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Conversions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversions Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Conversions Class Members

[image]
ActiveReports 19 .NET Edition
Conversions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversions Class

Glossary Item Box

The following tables list the members exposed by Conversions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToInt | Rounds a specified System.Decimal number to the closest integer toward negative infinity.
Top

See Also

Reference

Conversions Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Conversions Class Methods

[image]
ActiveReports 19 .NET Edition
Conversions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Conversions Class

Glossary Item Box

For a list of all members of this type, see Conversions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToInt | Rounds a specified System.Decimal number to the closest integer toward negative infinity.
Top

See Also

Reference

Conversions Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ToInt(Decimal) Method

[image]
ActiveReports 19 .NET Edition
ToInt(Decimal) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversions Class : ToInt(Decimal) Method

Number
decimal number

Glossary Item Box

Rounds a specified System.Decimal number to the closest integer toward negative infinity.

Syntax

Visual Basic (Declaration)
Public Shared Function ToInt( _
   ByVal Number As Decimal _
) As Decimal
C#
public static decimal ToInt(
   decimal Number
)

Parameters

Number
decimal number

Return Value

>decimal number, rounded to the floor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversions Class
Conversions Members


DateAndTime Class

[image]
ActiveReports 19 .NET Edition
DateAndTime Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateAndTime Class

Glossary Item Box

Represents DateAndTime operations in Visual Basic style

Object Model

DateAndTime Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DateAndTime
C#
public static class DateAndTime

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.DateAndTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateAndTime Class Members

[image]
ActiveReports 19 .NET Edition
DateAndTime Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateAndTime Class

Glossary Item Box

The following tables list the members exposed by DateAndTime.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | DateString | Returns a String value representing the current date according to your system.
static (Shared in Visual Basic) | Now | Returns a Date value containing the current date and time according to your system.
static (Shared in Visual Basic) | TimeOfDay | Returns a Date value containing the current time of day according to your system.
static (Shared in Visual Basic) | Timer | Returns a Double value representing the number of seconds elapsed since midnight.
static (Shared in Visual Basic) | TimeString | Returns a String value representing the current time of day according to your system.
static (Shared in Visual Basic) | Today | Returns a Date value containing the current date according to your system.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DateAdd | Overloaded. Returns a Date value containing a date and time value to which a specified time interval has been added.
static (Shared in Visual Basic) | DateDiff | Overloaded. Returns a Long value specifying the number of time intervals between two Date values.
static (Shared in Visual Basic) | DatePart | Overloaded. Returns an Integer value containing the specified component of a given Date value.
static (Shared in Visual Basic) | DateSerial | Returns a Date value representing a specified year, month, and day, with the time information set to midnight (00:00:00).
static (Shared in Visual Basic) | DateValue | Returns a Date value containing the date information represented by a string, with the time information set to midnight (00:00:00).
static (Shared in Visual Basic) | Day | Returns an Integer value from 1 through 31 representing the day of the month.
static (Shared in Visual Basic) | Hour | Returns an Integer value from 0 through 23 representing the hour of the day.
static (Shared in Visual Basic) | Minute | Returns an Integer value from 0 through 59 representing the minute of the hour.
static (Shared in Visual Basic) | Month | Returns an Integer value from 1 through 12 representing the month of the year.
static (Shared in Visual Basic) | MonthName | Returns a String value containing the name of the specified month.
static (Shared in Visual Basic) | Second | Returns an Integer value from 0 through 59 representing the second of the minute.
static (Shared in Visual Basic) | TimeSerial | Returns a Date value representing a specified hour, minute, and second, with the date information set relative to January 1 of the year 1.
static (Shared in Visual Basic) | TimeValue | Returns a Date value containing the time information represented by a string, with the date information set to January 1 of the year 1.
static (Shared in Visual Basic) | Weekday | Returns an Integer value containing a number representing the day of the week.
static (Shared in Visual Basic) | WeekdayName | Returns a String value containing the name of the specified weekday.
static (Shared in Visual Basic) | Year | Returns an Integer value from 1 through 9999 representing the year.
Top

See Also

Reference

DateAndTime Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateAndTime Class Methods

[image]
ActiveReports 19 .NET Edition
DateAndTime Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateAndTime Class

Glossary Item Box

For a list of all members of this type, see DateAndTime members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DateAdd | Overloaded. Returns a Date value containing a date and time value to which a specified time interval has been added.
static (Shared in Visual Basic) | DateDiff | Overloaded. Returns a Long value specifying the number of time intervals between two Date values.
static (Shared in Visual Basic) | DatePart | Overloaded. Returns an Integer value containing the specified component of a given Date value.
static (Shared in Visual Basic) | DateSerial | Returns a Date value representing a specified year, month, and day, with the time information set to midnight (00:00:00).
static (Shared in Visual Basic) | DateValue | Returns a Date value containing the date information represented by a string, with the time information set to midnight (00:00:00).
static (Shared in Visual Basic) | Day | Returns an Integer value from 1 through 31 representing the day of the month.
static (Shared in Visual Basic) | Hour | Returns an Integer value from 0 through 23 representing the hour of the day.
static (Shared in Visual Basic) | Minute | Returns an Integer value from 0 through 59 representing the minute of the hour.
static (Shared in Visual Basic) | Month | Returns an Integer value from 1 through 12 representing the month of the year.
static (Shared in Visual Basic) | MonthName | Returns a String value containing the name of the specified month.
static (Shared in Visual Basic) | Second | Returns an Integer value from 0 through 59 representing the second of the minute.
static (Shared in Visual Basic) | TimeSerial | Returns a Date value representing a specified hour, minute, and second, with the date information set relative to January 1 of the year 1.
static (Shared in Visual Basic) | TimeValue | Returns a Date value containing the time information represented by a string, with the date information set to January 1 of the year 1.
static (Shared in Visual Basic) | Weekday | Returns an Integer value containing a number representing the day of the week.
static (Shared in Visual Basic) | WeekdayName | Returns a String value containing the name of the specified weekday.
static (Shared in Visual Basic) | Year | Returns an Integer value from 1 through 9999 representing the year.
Top

See Also

Reference

DateAndTime Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateAdd Method

[image]
ActiveReports 19 .NET Edition
DateAdd Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DateAdd Method

Glossary Item Box

Returns a Date value containing a date and time value to which a specified time interval has been added.

Overload List

Overload | Description
DateAdd(DateInterval,Double,DateTime) | Returns a Date value containing a date and time value to which a specified time interval has been added.
DateAdd(String,Double,Object) | Returns a Date value containing a date and time value to which a specified time interval has been added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DateAdd(DateInterval,Double,DateTime) Method

[image]
ActiveReports 19 .NET Edition
DateAdd(DateInterval,Double,DateTime) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DateAdd Method : DateAdd(DateInterval,Double,DateTime) Method

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to add.
number
Required. Double. Floating-point expression representing the number of intervals you want to add. number can be positive (to get date/time values in the future) or negative (to get date/time values in the past). It can contain a fractional part when interval specifies hours, minutes, or seconds. For other values of interval, any fractional part of number is ignored.
dateValue
Required. Date. An expression representing the date and time to which the interval is to be added. dateValue itself is not changed in the calling program.

Glossary Item Box

Returns a Date value containing a date and time value to which a specified time interval has been added.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DateAdd( _
   ByVal interval As DateInterval, _
   ByVal number As Double, _
   ByVal dateValue As Date _
) As Date
C#
public static DateTime DateAdd(
   DateInterval interval,
   double number,
   DateTime dateValue
)

Parameters

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to add.
number
Required. Double. Floating-point expression representing the number of intervals you want to add. number can be positive (to get date/time values in the future) or negative (to get date/time values in the past). It can contain a fractional part when interval specifies hours, minutes, or seconds. For other values of interval, any fractional part of number is ignored.
dateValue
Required. Date. An expression representing the date and time to which the interval is to be added. dateValue itself is not changed in the calling program.

Return Value

Returns a Date value containing a date and time value to which a specified time interval has been added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DateAdd(String,Double,Object) Method

[image]
ActiveReports 19 .NET Edition
DateAdd(String,Double,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DateAdd Method : DateAdd(String,Double,Object) Method

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to add.
number
Required. Double. Floating-point expression representing the number of intervals you want to add. number can be positive (to get date/time values in the future) or negative (to get date/time values in the past). It can contain a fractional part when interval specifies hours, minutes, or seconds. For other values of interval, any fractional part of number is ignored.
dateValue
Required. Date. An expression representing the date and time to which the interval is to be added. dateValue itself is not changed in the calling program.

Glossary Item Box

Returns a Date value containing a date and time value to which a specified time interval has been added.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DateAdd( _
   ByVal interval As String, _
   ByVal number As Double, _
   ByVal dateValue As Object _
) As Date
C#
public static DateTime DateAdd(
   string interval,
   double number,
   object dateValue
)

Parameters

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to add.
number
Required. Double. Floating-point expression representing the number of intervals you want to add. number can be positive (to get date/time values in the future) or negative (to get date/time values in the past). It can contain a fractional part when interval specifies hours, minutes, or seconds. For other values of interval, any fractional part of number is ignored.
dateValue
Required. Date. An expression representing the date and time to which the interval is to be added. dateValue itself is not changed in the calling program.

Return Value

Returns a Date value containing a date and time value to which a specified time interval has been added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DateDiff Method

[image]
ActiveReports 19 .NET Edition
DateDiff Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DateDiff Method

Glossary Item Box

Returns a Long value specifying the number of time intervals between two Date values.

Overload List

Overload | Description
DateDiff(String,Object,Object,FirstDayOfWeek,FirstWeekOfYear) | Returns a Long value specifying the number of time intervals between two Date values.
DateDiff(DateInterval,DateTime,DateTime,FirstDayOfWeek,FirstWeekOfYear) | Returns a Long value specifying the number of time intervals between two Date values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DateDiff(String,Object,Object,FirstDayOfWeek,FirstWeekOfYear) Method

[image]
ActiveReports 19 .NET Edition
DateDiff(String,Object,Object,FirstDayOfWeek,FirstWeekOfYear) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DateDiff Method : DateDiff(String,Object,Object,FirstDayOfWeek,FirstWeekOfYear) Method

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to use as the unit of difference between date1 and date2.
date1
Required. Date. The first date/time value you want to use in the calculation.
date2
Required. Date. The second date/time value you want to use in the calculation.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Glossary Item Box

Returns a Long value specifying the number of time intervals between two Date values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DateDiff( _
   ByVal interval As String, _
   ByVal date1 As Object, _
   ByVal date2 As Object, _
   Optional ByVal dayOfWeek As FirstDayOfWeek, _
   Optional ByVal weekOfYear As FirstWeekOfYear _
) As Long
C#
public static long DateDiff(
   string interval,
   object date1,
   object date2,
   FirstDayOfWeek dayOfWeek,
   FirstWeekOfYear weekOfYear
)

Parameters

interval
Required. DateInterval enumeration value or String expression representing the time interval you want to use as the unit of difference between date1 and date2.
date1
Required. Date. The first date/time value you want to use in the calculation.
date2
Required. Date. The second date/time value you want to use in the calculation.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Return Value

Returns a Long value specifying the number of time intervals between two Date values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DateDiff(DateInterval,DateTime,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method

[image]
ActiveReports 19 .NET Edition
DateDiff(DateInterval,DateTime,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DateDiff Method : DateDiff(DateInterval,DateTime,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method

interval
Required. A DateInterval enumeration value or a string expression representing the time interval you want to use as the unit of difference between Date1 and Date2.
date1
Required. Date. The first date/time value you want to use in the calculation.
date2
Required. Date. The second date/time value you want to use in the calculation.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Glossary Item Box

Returns a Long value specifying the number of time intervals between two Date values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DateDiff( _
   ByVal interval As DateInterval, _
   ByVal date1 As Date, _
   ByVal date2 As Date, _
   Optional ByVal dayOfWeek As FirstDayOfWeek, _
   Optional ByVal weekOfYear As FirstWeekOfYear _
) As Long
C#
public static long DateDiff(
   DateInterval interval,
   DateTime date1,
   DateTime date2,
   FirstDayOfWeek dayOfWeek,
   FirstWeekOfYear weekOfYear
)

Parameters

interval
Required. A DateInterval enumeration value or a string expression representing the time interval you want to use as the unit of difference between Date1 and Date2.
date1
Required. Date. The first date/time value you want to use in the calculation.
date2
Required. Date. The second date/time value you want to use in the calculation.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Return Value

Returns a Long value specifying the number of time intervals between two Date values.

Exceptions

Exception | Description
System.ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DatePart Method

[image]
ActiveReports 19 .NET Edition
DatePart Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DatePart Method

Glossary Item Box

Returns an Integer value containing the specified component of a given Date value.

Overload List

Overload | Description
DatePart(DateInterval,DateTime,FirstDayOfWeek,FirstWeekOfYear) | Returns an Integer value containing the specified component of a given Date value.
DatePart(String,Object,FirstDayOfWeek,FirstWeekOfYear) | Returns an Integer value containing the specified component of a given Date value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DatePart(DateInterval,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method

[image]
ActiveReports 19 .NET Edition
DatePart(DateInterval,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DatePart Method : DatePart(DateInterval,DateTime,FirstDayOfWeek,FirstWeekOfYear) Method

interval
Required. DateInterval enumeration value or String expression representing the part of the date/time value you want to return.
dateValue
Required. Date value that you want to evaluate.
firstDayOfWeekValue
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
firstWeekOfYearValue
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Glossary Item Box

Returns an Integer value containing the specified component of a given Date value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DatePart( _
   ByVal interval As DateInterval, _
   ByVal dateValue As Date, _
   Optional ByVal firstDayOfWeekValue As FirstDayOfWeek, _
   Optional ByVal firstWeekOfYearValue As FirstWeekOfYear _
) As Integer
C#
public static int DatePart(
   DateInterval interval,
   DateTime dateValue,
   FirstDayOfWeek firstDayOfWeekValue,
   FirstWeekOfYear firstWeekOfYearValue
)

Parameters

interval
Required. DateInterval enumeration value or String expression representing the part of the date/time value you want to return.
dateValue
Required. Date value that you want to evaluate.
firstDayOfWeekValue
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
firstWeekOfYearValue
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Return Value

Returns an Integer value containing the specified component of a given Date value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DatePart(String,Object,FirstDayOfWeek,FirstWeekOfYear) Method

[image]
ActiveReports 19 .NET Edition
DatePart(String,Object,FirstDayOfWeek,FirstWeekOfYear) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class > DatePart Method : DatePart(String,Object,FirstDayOfWeek,FirstWeekOfYear) Method

interval
Required. DateInterval enumeration value or String expression representing the part of the date/time value you want to return.
dateValue
Required. Date value that you want to evaluate.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Glossary Item Box

Returns an Integer value containing the specified component of a given Date value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DatePart( _
   ByVal interval As String, _
   ByVal dateValue As Object, _
   Optional ByVal dayOfWeek As FirstDayOfWeek, _
   Optional ByVal weekOfYear As FirstWeekOfYear _
) As Integer
C#
public static int DatePart(
   string interval,
   object dateValue,
   FirstDayOfWeek dayOfWeek,
   FirstWeekOfYear weekOfYear
)

Parameters

interval
Required. DateInterval enumeration value or String expression representing the part of the date/time value you want to return.
dateValue
Required. Date value that you want to evaluate.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.
weekOfYear
Optional. A value chosen from the FirstWeekOfYear enumeration that specifies the first week of the year. If not specified, FirstWeekOfYear.Jan1 is used.

Return Value

Returns an Integer value containing the specified component of a given Date value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members
Overload List


DateSerial Method

[image]
ActiveReports 19 .NET Edition
DateSerial Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DateSerial Method

year
Required. Integer expression from 1 through 9999. However, values below this range are also accepted. If year is 0 through 99, it is interpreted as being between 1930 and 2029, as explained in the "Remarks" section below. If year is less than 1, it is subtracted from the current year.
month
Required. Integer expression from 1 through 12. However, values outside this range are also accepted. The value of month is offset by 1 and applied to January of the calculated year. In other words, (month - 1) is added to January. The year is recalculated if necessary. The following results illustrate this effect: If month is 1, the result is January of the calculated year. If month is 0, the result is December of the previous year. If month is -1, the result is November of the previous year. If month is 13, the result is January of the following year.
day
Required. Integer expression from 1 through 31. However, values outside this range are also accepted. The value of day is offset by 1 and applied to the first day of the calculated month. In other words, (day - 1) is added to the first of the month. The month and year are recalculated if necessary. The following results illustrate this effect: If day is 1, the result is the first day of the calculated month. If day is 0, the result is the last day of the previous month. If day is -1, the result is the penultimate day of the previous month. If day is past the end of the current month, the result is the appropriate day of the following month. For example, if month is 4 and day is 31, the result is May 1.

Glossary Item Box

Returns a Date value representing a specified year, month, and day, with the time information set to midnight (00:00:00).

Syntax

Visual Basic (Declaration)
Public Shared Function DateSerial( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
) As Date
C#
public static DateTime DateSerial(
   int year,
   int month,
   int day
)

Parameters

year
Required. Integer expression from 1 through 9999. However, values below this range are also accepted. If year is 0 through 99, it is interpreted as being between 1930 and 2029, as explained in the "Remarks" section below. If year is less than 1, it is subtracted from the current year.
month
Required. Integer expression from 1 through 12. However, values outside this range are also accepted. The value of month is offset by 1 and applied to January of the calculated year. In other words, (month - 1) is added to January. The year is recalculated if necessary. The following results illustrate this effect: If month is 1, the result is January of the calculated year. If month is 0, the result is December of the previous year. If month is -1, the result is November of the previous year. If month is 13, the result is January of the following year.
day
Required. Integer expression from 1 through 31. However, values outside this range are also accepted. The value of day is offset by 1 and applied to the first day of the calculated month. In other words, (day - 1) is added to the first of the month. The month and year are recalculated if necessary. The following results illustrate this effect: If day is 1, the result is the first day of the calculated month. If day is 0, the result is the last day of the previous month. If day is -1, the result is the penultimate day of the previous month. If day is past the end of the current month, the result is the appropriate day of the following month. For example, if month is 4 and day is 31, the result is May 1.

Return Value

Returns a Date value representing a specified year, month, and day, with the time information set to midnight (00:00:00).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DateValue Method

[image]
ActiveReports 19 .NET Edition
DateValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DateValue Method

stringDate
Required. String expression representing a date/time value from 00:00:00 on January 1 of the year 1 through 23:59:59 on December 31, 9999.

Glossary Item Box

Returns a Date value containing the date information represented by a string, with the time information set to midnight (00:00:00).

Syntax

Visual Basic (Declaration)
Public Shared Function DateValue( _
   ByVal stringDate As String _
) As Date
C#
public static DateTime DateValue(
   string stringDate
)

Parameters

stringDate
Required. String expression representing a date/time value from 00:00:00 on January 1 of the year 1 through 23:59:59 on December 31, 9999.

Return Value

Returns a Date value containing the date information represented by a string, with the time information set to midnight (00:00:00).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Day Method

[image]
ActiveReports 19 .NET Edition
Day Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Day Method

dateValue
Required. Date value from which you want to extract the day.

Glossary Item Box

Returns an Integer value from 1 through 31 representing the day of the month.

Syntax

Visual Basic (Declaration)
Public Shared Function Day( _
   ByVal dateValue As Date _
) As Integer
C#
public static int Day(
   DateTime dateValue
)

Parameters

dateValue
Required. Date value from which you want to extract the day.

Return Value

Returns an Integer value from 1 through 31 representing the day of the month.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Hour Method

[image]
ActiveReports 19 .NET Edition
Hour Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Hour Method

timeValue
Required. Date value from which you want to extract the hour.

Glossary Item Box

Returns an Integer value from 0 through 23 representing the hour of the day.

Syntax

Visual Basic (Declaration)
Public Shared Function Hour( _
   ByVal timeValue As Date _
) As Integer
C#
public static int Hour(
   DateTime timeValue
)

Parameters

timeValue
Required. Date value from which you want to extract the hour.

Return Value

Returns an Integer value from 0 through 23 representing the hour of the day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Minute Method

[image]
ActiveReports 19 .NET Edition
Minute Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Minute Method

timeValue
Required. Date value from which you want to extract the minute.

Glossary Item Box

Returns an Integer value from 0 through 59 representing the minute of the hour.

Syntax

Visual Basic (Declaration)
Public Shared Function Minute( _
   ByVal timeValue As Date _
) As Integer
C#
public static int Minute(
   DateTime timeValue
)

Parameters

timeValue
Required. Date value from which you want to extract the minute.

Return Value

Returns an Integer value from 0 through 59 representing the minute of the hour.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Month Method

[image]
ActiveReports 19 .NET Edition
Month Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Month Method

dateValue
Required. Date value from which you want to extract the month.

Glossary Item Box

Returns an Integer value from 1 through 12 representing the month of the year.

Syntax

Visual Basic (Declaration)
Public Shared Function Month( _
   ByVal dateValue As Date _
) As Integer
C#
public static int Month(
   DateTime dateValue
)

Parameters

dateValue
Required. Date value from which you want to extract the month.

Return Value

Returns an Integer value from 1 through 12 representing the month of the year.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


MonthName Method

[image]
ActiveReports 19 .NET Edition
MonthName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : MonthName Method

month
Required. Integer. The numeric designation of the month, from 1 through 13; 1 indicates January and 12 indicates December. You can use the value 13 with a 13-month calendar. If your system is using a 12-month calendar and month is 13, MonthName returns an empty string.
abbreviate
Optional. Boolean value that indicates if the month name is to be abbreviated. If omitted, the default is False, which means the month name is not abbreviated.

Glossary Item Box

Returns a String value containing the name of the specified month.

Syntax

Visual Basic (Declaration)
Public Shared Function MonthName( _
   ByVal month As Integer, _
   Optional ByVal abbreviate As Boolean _
) As String
C#
public static string MonthName(
   int month,
   bool abbreviate
)

Parameters

month
Required. Integer. The numeric designation of the month, from 1 through 13; 1 indicates January and 12 indicates December. You can use the value 13 with a 13-month calendar. If your system is using a 12-month calendar and month is 13, MonthName returns an empty string.
abbreviate
Optional. Boolean value that indicates if the month name is to be abbreviated. If omitted, the default is False, which means the month name is not abbreviated.

Return Value

Returns a String value containing the name of the specified month.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Second Method

[image]
ActiveReports 19 .NET Edition
Second Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Second Method

timeValue
Required. Date value from which you want to extract the second.

Glossary Item Box

Returns an Integer value from 0 through 59 representing the second of the minute.

Syntax

Visual Basic (Declaration)
Public Shared Function Second( _
   ByVal timeValue As Date _
) As Integer
C#
public static int Second(
   DateTime timeValue
)

Parameters

timeValue
Required. Date value from which you want to extract the second.

Return Value

Returns an Integer value from 0 through 59 representing the second of the minute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


TimeSerial Method

[image]
ActiveReports 19 .NET Edition
TimeSerial Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : TimeSerial Method

hour
Required. Integer expression from 0 through 23. However, values outside this range are also accepted.
minute
Required. Integer expression from 0 through 59. However, values outside this range are also accepted. The value of minute is added to the calculated hour, so a negative value specifies minutes before that hour.
second
Required. Integer expression from 0 through 59. However, values outside this range are also accepted. The value of second is added to the calculated minute, so a negative value specifies seconds before that minute.

Glossary Item Box

Returns a Date value representing a specified hour, minute, and second, with the date information set relative to January 1 of the year 1.

Syntax

Visual Basic (Declaration)
Public Shared Function TimeSerial( _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer _
) As Date
C#
public static DateTime TimeSerial(
   int hour,
   int minute,
   int second
)

Parameters

hour
Required. Integer expression from 0 through 23. However, values outside this range are also accepted.
minute
Required. Integer expression from 0 through 59. However, values outside this range are also accepted. The value of minute is added to the calculated hour, so a negative value specifies minutes before that hour.
second
Required. Integer expression from 0 through 59. However, values outside this range are also accepted. The value of second is added to the calculated minute, so a negative value specifies seconds before that minute.

Return Value

Returns a Date value representing a specified hour, minute, and second, with the date information set relative to January 1 of the year 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


TimeValue Method

[image]
ActiveReports 19 .NET Edition
TimeValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : TimeValue Method

stringTime
Required. String expression representing a date/time value from 00:00:00 on January 1 of the year 1 through 23:59:59 on December 31, 9999.

Glossary Item Box

Returns a Date value containing the time information represented by a string, with the date information set to January 1 of the year 1.

Syntax

Visual Basic (Declaration)
Public Shared Function TimeValue( _
   ByVal stringTime As String _
) As Date
C#
public static DateTime TimeValue(
   string stringTime
)

Parameters

stringTime
Required. String expression representing a date/time value from 00:00:00 on January 1 of the year 1 through 23:59:59 on December 31, 9999.

Return Value

Returns a Date value containing the time information represented by a string, with the date information set to January 1 of the year 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Weekday Method

[image]
ActiveReports 19 .NET Edition
Weekday Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Weekday Method

dateValue
Required. Date value for which you want to determine the day of the week.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.

Glossary Item Box

Returns an Integer value containing a number representing the day of the week.

Syntax

Visual Basic (Declaration)
Public Shared Function Weekday( _
   ByVal dateValue As Date, _
   Optional ByVal dayOfWeek As FirstDayOfWeek _
) As Integer
C#
public static int Weekday(
   DateTime dateValue,
   FirstDayOfWeek dayOfWeek
)

Parameters

dateValue
Required. Date value for which you want to determine the day of the week.
dayOfWeek
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.Sunday is used.

Return Value

Returns an Integer value containing a number representing the day of the week.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


WeekdayName Method

[image]
ActiveReports 19 .NET Edition
WeekdayName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : WeekdayName Method

weekday
Required. Integer. The numeric designation for the weekday, from 1 through 7; 1 indicates the first day of the week and 7 indicates the last day of the week. The identities of the first and last days depend on the setting of firstDayOfWeekValue.
abbreviate
Optional. Boolean value that indicates if the weekday name is to be abbreviated. If omitted, the default is False, which means the weekday name is not abbreviated.
firstDayOfWeekValue
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.System is used.

Glossary Item Box

Returns a String value containing the name of the specified weekday.

Syntax

Visual Basic (Declaration)
Public Shared Function WeekdayName( _
   ByVal weekday As Integer, _
   Optional ByVal abbreviate As Boolean, _
   Optional ByVal firstDayOfWeekValue As FirstDayOfWeek _
) As String
C#
public static string WeekdayName(
   int weekday,
   bool abbreviate,
   FirstDayOfWeek firstDayOfWeekValue
)

Parameters

weekday
Required. Integer. The numeric designation for the weekday, from 1 through 7; 1 indicates the first day of the week and 7 indicates the last day of the week. The identities of the first and last days depend on the setting of firstDayOfWeekValue.
abbreviate
Optional. Boolean value that indicates if the weekday name is to be abbreviated. If omitted, the default is False, which means the weekday name is not abbreviated.
firstDayOfWeekValue
Optional. A value chosen from the FirstDayOfWeek enumeration that specifies the first day of the week. If not specified, FirstDayOfWeek.System is used.

Return Value

Returns a String value containing the name of the specified weekday.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Year Method

[image]
ActiveReports 19 .NET Edition
Year Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Year Method

dateValue
Required. Date value from which you want to extract the year.

Glossary Item Box

Returns an Integer value from 1 through 9999 representing the year.

Syntax

Visual Basic (Declaration)
Public Shared Function Year( _
   ByVal dateValue As Date _
) As Integer
C#
public static int Year(
   DateTime dateValue
)

Parameters

dateValue
Required. Date value from which you want to extract the year.

Return Value

Returns an Integer value from 1 through 9999 representing the year.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DateAndTime Class Properties

[image]
ActiveReports 19 .NET Edition
DateAndTime Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateAndTime Class

Glossary Item Box

For a list of all members of this type, see DateAndTime members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | DateString | Returns a String value representing the current date according to your system.
static (Shared in Visual Basic) | Now | Returns a Date value containing the current date and time according to your system.
static (Shared in Visual Basic) | TimeOfDay | Returns a Date value containing the current time of day according to your system.
static (Shared in Visual Basic) | Timer | Returns a Double value representing the number of seconds elapsed since midnight.
static (Shared in Visual Basic) | TimeString | Returns a String value representing the current time of day according to your system.
static (Shared in Visual Basic) | Today | Returns a Date value containing the current date according to your system.
Top

See Also

Reference

DateAndTime Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateString Property

[image]
ActiveReports 19 .NET Edition
DateString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : DateString Property

Glossary Item Box

Returns a String value representing the current date according to your system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DateString As String
C#
public static string DateString {get;}

Property Value

Returns a String value representing the current date according to your system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Now Property

[image]
ActiveReports 19 .NET Edition
Now Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Now Property

Glossary Item Box

Returns a Date value containing the current date and time according to your system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Now As Date
C#
public static DateTime Now {get;}

Property Value

Returns a Date value containing the current date and time according to your system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


TimeOfDay Property

[image]
ActiveReports 19 .NET Edition
TimeOfDay Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : TimeOfDay Property

Glossary Item Box

Returns a Date value containing the current time of day according to your system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TimeOfDay As Date
C#
public static DateTime TimeOfDay {get;}

Property Value

Returns a Date value containing the current time of day according to your system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Timer Property

[image]
ActiveReports 19 .NET Edition
Timer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Timer Property

Glossary Item Box

Returns a Double value representing the number of seconds elapsed since midnight.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Timer As Double
C#
public static double Timer {get;}

Property Value

Returns a Double value representing the number of seconds elapsed since midnight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


TimeString Property

[image]
ActiveReports 19 .NET Edition
TimeString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : TimeString Property

Glossary Item Box

Returns a String value representing the current time of day according to your system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TimeString As String
C#
public static string TimeString {get;}

Property Value

Returns a String value representing the current time of day according to your system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


Today Property

[image]
ActiveReports 19 .NET Edition
Today Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DateAndTime Class : Today Property

Glossary Item Box

Returns a Date value containing the current date according to your system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Today As Date
C#
public static DateTime Today {get;}

Property Value

Returns a Date value containing the current date according to your system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateAndTime Class
DateAndTime Members


DecimalType Class

[image]
ActiveReports 19 .NET Edition
DecimalType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DecimalType Class

Glossary Item Box

Represents conversions to Decimal

Object Model

DecimalType Class

Syntax

Visual Basic (Declaration)
Public Class DecimalType
C#
public class DecimalType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.DecimalType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DecimalType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DecimalType Class Members

[image]
ActiveReports 19 .NET Edition
DecimalType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DecimalType Class

Glossary Item Box

The following tables list the members exposed by DecimalType.

Public Constructors

 | Name | Description
Public Constructor | DecimalType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Decimal value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Decimal value.
Top

See Also

Reference

DecimalType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DecimalType Constructor

[image]
ActiveReports 19 .NET Edition
DecimalType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DecimalType Class : DecimalType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DecimalType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DecimalType Class
DecimalType Members


DecimalType Class Methods

[image]
ActiveReports 19 .NET Edition
DecimalType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DecimalType Class

Glossary Item Box

For a list of all members of this type, see DecimalType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Decimal value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Decimal value.
Top

See Also

Reference

DecimalType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DecimalType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a System.Decimal value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Decimal
C#
public static decimal FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Decimal value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DecimalType Class
DecimalType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DecimalType Class : FromString Method

value
The object to convert.
format
Format information.

Glossary Item Box

Converts an object to a System.Decimal value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String, _
   ByVal format As NumberFormatInfo _
) As Decimal
C#
public static decimal FromString(
   string value,
   NumberFormatInfo format
)

Parameters

value
The object to convert.
format
Format information.

Return Value

The Decimal value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DecimalType Class
DecimalType Members


DoubleType Class

[image]
ActiveReports 19 .NET Edition
DoubleType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DoubleType Class

Glossary Item Box

Represents conversions to Double

Object Model

DoubleType Class

Syntax

Visual Basic (Declaration)
Public Class DoubleType
C#
public class DoubleType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.DoubleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DoubleType Class Members

[image]
ActiveReports 19 .NET Edition
DoubleType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DoubleType Class

Glossary Item Box

The following tables list the members exposed by DoubleType.

Public Constructors

 | Name | Description
Public Constructor | DoubleType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Double value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Double value.
Top

See Also

Reference

DoubleType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DoubleType Constructor

[image]
ActiveReports 19 .NET Edition
DoubleType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DoubleType Class : DoubleType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleType Class
DoubleType Members


DoubleType Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DoubleType Class

Glossary Item Box

For a list of all members of this type, see DoubleType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Double value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Double value.
Top

See Also

Reference

DoubleType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DoubleType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a System.Double value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Double
C#
public static double FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Double value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleType Class
DoubleType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > DoubleType Class : FromString Method

value
The object to convert.
format
Format information.

Glossary Item Box

Converts an object to a System.Double value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String, _
   ByVal format As NumberFormatInfo _
) As Double
C#
public static double FromString(
   string value,
   NumberFormatInfo format
)

Parameters

value
The object to convert.
format
Format information.

Return Value

The Double value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleType Class
DoubleType Members


Financial Class

[image]
ActiveReports 19 .NET Edition
Financial Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Financial Class

Glossary Item Box

References the Financial enumeration when reflecting financial methods.

Object Model

Financial Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Financial
C#
public static class Financial

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Financial

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Financial Class Members

[image]
ActiveReports 19 .NET Edition
Financial Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Financial Class

Glossary Item Box

The following tables list the members exposed by Financial.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DDB | Returns a value specifying the depreciation of an asset for a specific time period using the double-declining balance method or some other method you specify.
static (Shared in Visual Basic) | FV | Returns a value specifying the future value of an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | IPmt | Returns a value specifying the interest payment for a given period of an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | NPer | Returns a value specifying the number of periods for an annuity based on periodic fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | Pmt | Returns a value specifying the payment for an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | PPmt | Returns a value specifying the principal payment for a given period of an annuity based on periodic fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | PV | Returns a value specifying the present value of an annuity based on periodic, fixed payments to be paid in the future and a fixed interest rate.
static (Shared in Visual Basic) | Rate | Returns a value specifying the interest rate per period for an annuity.
static (Shared in Visual Basic) | SLN | Returns a value specifying the straight-line depreciation of an asset for a single period.
static (Shared in Visual Basic) | SYD | Returns a value specifying the sum-of-years digits depreciation of an asset for a specified period.
Top

See Also

Reference

Financial Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Financial Class Methods

[image]
ActiveReports 19 .NET Edition
Financial Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Financial Class

Glossary Item Box

For a list of all members of this type, see Financial members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DDB | Returns a value specifying the depreciation of an asset for a specific time period using the double-declining balance method or some other method you specify.
static (Shared in Visual Basic) | FV | Returns a value specifying the future value of an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | IPmt | Returns a value specifying the interest payment for a given period of an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | NPer | Returns a value specifying the number of periods for an annuity based on periodic fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | Pmt | Returns a value specifying the payment for an annuity based on periodic, fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | PPmt | Returns a value specifying the principal payment for a given period of an annuity based on periodic fixed payments and a fixed interest rate.
static (Shared in Visual Basic) | PV | Returns a value specifying the present value of an annuity based on periodic, fixed payments to be paid in the future and a fixed interest rate.
static (Shared in Visual Basic) | Rate | Returns a value specifying the interest rate per period for an annuity.
static (Shared in Visual Basic) | SLN | Returns a value specifying the straight-line depreciation of an asset for a single period.
static (Shared in Visual Basic) | SYD | Returns a value specifying the sum-of-years digits depreciation of an asset for a specified period.
Top

See Also

Reference

Financial Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DDB Method

[image]
ActiveReports 19 .NET Edition
DDB Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : DDB Method

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of useful life of the asset.
Period
Required. The period for which asset depreciation is calculated.
Factor
Optional. The rate at which the balance declines. If omitted, 2 (double-declining method) is assumed.

Glossary Item Box

Returns a value specifying the depreciation of an asset for a specific time period using the double-declining balance method or some other method you specify.

Syntax

Visual Basic (Declaration)
Public Shared Function DDB( _
   ByVal Cost As Double, _
   ByVal Salvage As Double, _
   ByVal Life As Double, _
   ByVal Period As Double, _
   Optional ByVal Factor As Double _
) As Double
C#
public static double DDB(
   double Cost,
   double Salvage,
   double Life,
   double Period,
   double Factor
)

Parameters

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of useful life of the asset.
Period
Required. The period for which asset depreciation is calculated.
Factor
Optional. The rate at which the balance declines. If omitted, 2 (double-declining method) is assumed.

Return Value

The depreciation of an asset for a specific time period using the double-declining balance method or some other method you specify.

Exceptions

Exception | Description
System.ArgumentException | Factor less than or equal to 0, Salvage less than 0, Period less than or equal to 0, or Period greater than Life.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


FV Method

[image]
ActiveReports 19 .NET Edition
FV Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : FV Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that doesn't change over the life of the annuity.
PV
Optional. The present value (or lump sum) of a series of future payments. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the future value of an annuity based on periodic, fixed payments and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function FV( _
   ByVal Rate As Double, _
   ByVal NPer As Double, _
   ByVal Pmt As Double, _
   Optional ByVal PV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double FV(
   double Rate,
   double NPer,
   double Pmt,
   double PV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that doesn't change over the life of the annuity.
PV
Optional. The present value (or lump sum) of a series of future payments. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The future value of an annuity based on periodic, fixed payments and a fixed interest rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


IPmt Method

[image]
ActiveReports 19 .NET Edition
IPmt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : IPmt Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Per
Required. The payment period in the range 1 through NPer.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you've made the final payment. For example, the future value of a loan is $0 because that's its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the interest payment for a given period of an annuity based on periodic, fixed payments and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function IPmt( _
   ByVal Rate As Double, _
   ByVal Per As Double, _
   ByVal NPer As Double, _
   ByVal PV As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double IPmt(
   double Rate,
   double Per,
   double NPer,
   double PV,
   double FV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Per
Required. The payment period in the range 1 through NPer.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you've made the final payment. For example, the future value of a loan is $0 because that's its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The interest payment for a given period of an annuity based on periodic, fixed payments and a fixed interest rate.

Exceptions

Exception | Description
System.ArgumentException | Per less than or equal to 0 or Per greater than NPer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


NPer Method

[image]
ActiveReports 19 .NET Edition
NPer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : NPer Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that does not change over the life of the annuity.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the number of periods for an annuity based on periodic fixed payments and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function NPer( _
   ByVal Rate As Double, _
   ByVal Pmt As Double, _
   ByVal PV As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double NPer(
   double Rate,
   double Pmt,
   double PV,
   double FV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that does not change over the life of the annuity.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The number of periods for an annuity based on periodic fixed payments and a fixed interest rate.

Exceptions

Exception | Description
System.ArgumentException | Rate = 0 and Pmt = 0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


Pmt Method

[image]
ActiveReports 19 .NET Edition
Pmt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : Pmt Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 × 12 (or 48) payment periods.
PV
Required. The present value (or lump sum) that a series of payments to be paid in the future is worth now. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 during 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the payment for an annuity based on periodic, fixed payments and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function Pmt( _
   ByVal Rate As Double, _
   ByVal NPer As Double, _
   ByVal PV As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double Pmt(
   double Rate,
   double NPer,
   double PV,
   double FV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 × 12 (or 48) payment periods.
PV
Required. The present value (or lump sum) that a series of payments to be paid in the future is worth now. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 during 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The payment for an annuity based on periodic, fixed payments and a fixed interest rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


PPmt Method

[image]
ActiveReports 19 .NET Edition
PPmt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : PPmt Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Per
Required. The payment period in the range 1 through NPer.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
PV
Required. The current value of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the principal payment for a given period of an annuity based on periodic fixed payments and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function PPmt( _
   ByVal Rate As Double, _
   ByVal Per As Double, _
   ByVal NPer As Double, _
   ByVal PV As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double PPmt(
   double Rate,
   double Per,
   double NPer,
   double PV,
   double FV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
Per
Required. The payment period in the range 1 through NPer.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 x 12 (or 48) payment periods.
PV
Required. The current value of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you have made the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The principal payment for a given period of an annuity based on periodic fixed payments and a fixed interest rate.

Exceptions

Exception | Description
System.ArgumentException | Per less or equals 0 or Per greater NPer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


PV Method

[image]
ActiveReports 19 .NET Edition
PV Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : PV Method

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has 4 x 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that does not change during the life of the annuity.
FV
Optional. The future value or cash balance you want after you make the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Glossary Item Box

Returns a value specifying the present value of an annuity based on periodic, fixed payments to be paid in the future and a fixed interest rate.

Syntax

Visual Basic (Declaration)
Public Shared Function PV( _
   ByVal Rate As Double, _
   ByVal NPer As Double, _
   ByVal Pmt As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate _
) As Double
C#
public static double PV(
   double Rate,
   double NPer,
   double Pmt,
   double FV,
   DueDate Due
)

Parameters

Rate
Required. The interest rate per period. For example, if you get a car loan at an annual percentage rate (APR) of 10 percent and make monthly payments, the rate per period is 0.1/12, or 0.0083.
NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has 4 x 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that does not change during the life of the annuity.
FV
Optional. The future value or cash balance you want after you make the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.

Return Value

The present value of an annuity based on periodic, fixed payments to be paid in the future and a fixed interest rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


Rate Method

[image]
ActiveReports 19 .NET Edition
Rate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : Rate Method

NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 * 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that doesn't change over the life of the annuity.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you make the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.
Guess
Optional. The value you estimate is returned by Rate. If omitted, Guess is 0.1 (10 percent).

Glossary Item Box

Returns a value specifying the interest rate per period for an annuity.

Syntax

Visual Basic (Declaration)
Public Shared Function Rate( _
   ByVal NPer As Double, _
   ByVal Pmt As Double, _
   ByVal PV As Double, _
   Optional ByVal FV As Double, _
   Optional ByVal Due As DueDate, _
   Optional ByVal Guess As Double _
) As Double
C#
public static double Rate(
   double NPer,
   double Pmt,
   double PV,
   double FV,
   DueDate Due,
   double Guess
)

Parameters

NPer
Required. The total number of payment periods in the annuity. For example, if you make monthly payments on a four-year car loan, your loan has a total of 4 * 12 (or 48) payment periods.
Pmt
Required. The payment to be made each period. Payments usually contain principal and interest that doesn't change over the life of the annuity.
PV
Required. The present value, or value today, of a series of future payments or receipts. For example, when you borrow money to buy a car, the loan amount is the present value to the lender of the monthly car payments you will make.
FV
Optional. The future value or cash balance you want after you make the final payment. For example, the future value of a loan is $0 because that is its value after the final payment. However, if you want to save $50,000 over 18 years for your child's education, then $50,000 is the future value. If omitted, 0 is assumed.
Due
Optional. Object of type DueDate that specifies when payments are due. This argument must be either DueDate.EndOfPeriod if payments are due at the end of the payment period, or DueDate.BegOfPeriod if payments are due at the beginning of the period. If omitted, DueDate.EndOfPeriod is assumed.
Guess
Optional. The value you estimate is returned by Rate. If omitted, Guess is 0.1 (10 percent).

Return Value

The interest rate per period for an annuity.

Exceptions

Exception | Description
System.ArgumentException | NPer less than or equal to 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


SLN Method

[image]
ActiveReports 19 .NET Edition
SLN Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : SLN Method

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of the useful life of the asset.

Glossary Item Box

Returns a value specifying the straight-line depreciation of an asset for a single period.

Syntax

Visual Basic (Declaration)
Public Shared Function SLN( _
   ByVal Cost As Double, _
   ByVal Salvage As Double, _
   ByVal Life As Double _
) As Double
C#
public static double SLN(
   double Cost,
   double Salvage,
   double Life
)

Parameters

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of the useful life of the asset.

Return Value

a value specifying the straight-line depreciation of an asset for a single period.

Exceptions

Exception | Description
System.ArgumentException | Life = 0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


SYD Method

[image]
ActiveReports 19 .NET Edition
SYD Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Financial Class : SYD Method

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of the useful life of the asset.
Period
Required. The period for which asset depreciation is calculated.

Glossary Item Box

Returns a value specifying the sum-of-years digits depreciation of an asset for a specified period.

Syntax

Visual Basic (Declaration)
Public Shared Function SYD( _
   ByVal Cost As Double, _
   ByVal Salvage As Double, _
   ByVal Life As Double, _
   ByVal Period As Double _
) As Double
C#
public static double SYD(
   double Cost,
   double Salvage,
   double Life,
   double Period
)

Parameters

Cost
Required. The initial cost of the asset.
Salvage
Required. The value of the asset at the end of its useful life.
Life
Required. The length of the useful life of the asset.
Period
Required. The period for which asset depreciation is calculated.

Return Value

The sum-of-years digits depreciation of an asset for a specified period.

Exceptions

Exception | Description
System.ArgumentException | Salvage less than 0, Period greater than Life, or Period less or equals 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Financial Class
Financial Members


Information Class

[image]
ActiveReports 19 .NET Edition
Information Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Information Class

Glossary Item Box

Represents VisualBasic Information methods

Object Model

Information Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Information
C#
public static class Information

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Information

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Information Class Members

[image]
ActiveReports 19 .NET Edition
Information Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Information Class

Glossary Item Box

The following tables list the members exposed by Information.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsArray | Returns a Boolean value indicating whether a variable points to an array.
static (Shared in Visual Basic) | IsDate | Returns a Boolean value indicating whether an expression represents a valid Date value.
static (Shared in Visual Basic) | IsDBNull | Returns a Boolean value indicating whether an expression evaluates to the DBNull class.
static (Shared in Visual Basic) | IsError | Returns a Boolean value indicating whether an expression is an exception type.
static (Shared in Visual Basic) | IsNothing | Returns a Boolean value indicating whether an expression has no object assigned to it.
static (Shared in Visual Basic) | IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.
Top

See Also

Reference

Information Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Information Class Methods

[image]
ActiveReports 19 .NET Edition
Information Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Information Class

Glossary Item Box

For a list of all members of this type, see Information members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsArray | Returns a Boolean value indicating whether a variable points to an array.
static (Shared in Visual Basic) | IsDate | Returns a Boolean value indicating whether an expression represents a valid Date value.
static (Shared in Visual Basic) | IsDBNull | Returns a Boolean value indicating whether an expression evaluates to the DBNull class.
static (Shared in Visual Basic) | IsError | Returns a Boolean value indicating whether an expression is an exception type.
static (Shared in Visual Basic) | IsNothing | Returns a Boolean value indicating whether an expression has no object assigned to it.
static (Shared in Visual Basic) | IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.
Top

See Also

Reference

Information Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


IsArray Method

[image]
ActiveReports 19 .NET Edition
IsArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsArray Method

exp
Required. Object variable.

Glossary Item Box

Returns a Boolean value indicating whether a variable points to an array.

Syntax

Visual Basic (Declaration)
Public Shared Function IsArray( _
   ByVal exp As Object _
) As Boolean
C#
public static bool IsArray(
   object exp
)

Parameters

exp
Required. Object variable.

Return Value

Returns a Boolean value indicating whether a variable points to an array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IsDate Method

[image]
ActiveReports 19 .NET Edition
IsDate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsDate Method

exp
Required. Object expression.

Glossary Item Box

Returns a Boolean value indicating whether an expression represents a valid Date value.

Syntax

Visual Basic (Declaration)
Public Shared Function IsDate( _
   ByVal exp As Object _
) As Boolean
C#
public static bool IsDate(
   object exp
)

Parameters

exp
Required. Object expression.

Return Value

Returns a Boolean value indicating whether an expression represents a valid Date value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IsDBNull Method

[image]
ActiveReports 19 .NET Edition
IsDBNull Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsDBNull Method

exp
Required. Object expression.

Glossary Item Box

Returns a Boolean value indicating whether an expression evaluates to the DBNull class.

Syntax

Visual Basic (Declaration)
Public Shared Function IsDBNull( _
   ByVal exp As Object _
) As Boolean
C#
public static bool IsDBNull(
   object exp
)

Parameters

exp
Required. Object expression.

Return Value

Returns a Boolean value indicating whether an expression evaluates to the DBNull class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IsError Method

[image]
ActiveReports 19 .NET Edition
IsError Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsError Method

exp
Required. Object expression.

Glossary Item Box

Returns a Boolean value indicating whether an expression is an exception type.

Syntax

Visual Basic (Declaration)
Public Shared Function IsError( _
   ByVal exp As Object _
) As Boolean
C#
public static bool IsError(
   object exp
)

Parameters

exp
Required. Object expression.

Return Value

Returns a Boolean value indicating whether an expression is an exception type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IsNothing Method

[image]
ActiveReports 19 .NET Edition
IsNothing Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsNothing Method

exp
Required. Object expression.

Glossary Item Box

Returns a Boolean value indicating whether an expression has no object assigned to it.

Syntax

Visual Basic (Declaration)
Public Shared Function IsNothing( _
   ByVal exp As Object _
) As Boolean
C#
public static bool IsNothing(
   object exp
)

Parameters

exp
Required. Object expression.

Return Value

Returns a Boolean value indicating whether an expression has no object assigned to it.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IsNumeric Method

[image]
ActiveReports 19 .NET Edition
IsNumeric Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Information Class : IsNumeric Method

Expression
Required. Object expression.

Glossary Item Box

Returns a Boolean value indicating whether an expression can be evaluated as a number.

Syntax

Visual Basic (Declaration)
Public Shared Function IsNumeric( _
   ByVal Expression As Object _
) As Boolean
C#
public static bool IsNumeric(
   object Expression
)

Parameters

Expression
Required. Object expression.

Return Value

Returns a Boolean value indicating whether an expression can be evaluated as a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Information Class
Information Members


IntegerType Class

[image]
ActiveReports 19 .NET Edition
IntegerType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : IntegerType Class

Glossary Item Box

Represents conversions to Integer

Object Model

IntegerType Class

Syntax

Visual Basic (Declaration)
Public Class IntegerType
C#
public class IntegerType

Remarks

Only for direct invoking. Shouldn't be reflected.This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.IntegerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntegerType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


IntegerType Class Members

[image]
ActiveReports 19 .NET Edition
IntegerType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : IntegerType Class

Glossary Item Box

The following tables list the members exposed by IntegerType.

Public Constructors

 | Name | Description
Public Constructor | IntegerType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to an integer value.
static (Shared in Visual Basic) | FromString | Converts a string to an integer value.
Top

See Also

Reference

IntegerType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


IntegerType Constructor

[image]
ActiveReports 19 .NET Edition
IntegerType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > IntegerType Class : IntegerType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public IntegerType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntegerType Class
IntegerType Members


IntegerType Class Methods

[image]
ActiveReports 19 .NET Edition
IntegerType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : IntegerType Class

Glossary Item Box

For a list of all members of this type, see IntegerType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to an integer value.
static (Shared in Visual Basic) | FromString | Converts a string to an integer value.
Top

See Also

Reference

IntegerType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > IntegerType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to an integer value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Integer
C#
public static int FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The int value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntegerType Class
IntegerType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > IntegerType Class : FromString Method

value
The string to convert.

Glossary Item Box

Converts a string to an integer value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String _
) As Integer
C#
public static int FromString(
   string value
)

Parameters

value
The string to convert.

Return Value

The int value of the string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntegerType Class
IntegerType Members


Interaction Class

[image]
ActiveReports 19 .NET Edition
Interaction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Interaction Class

Glossary Item Box

Contains methods used to interact with objects, applications, and systems in VisualBasic style.

Object Model

Interaction Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Interaction
C#
public static class Interaction

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Interaction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Interaction Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Interaction Class Members

[image]
ActiveReports 19 .NET Edition
Interaction Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Interaction Class

Glossary Item Box

The following tables list the members exposed by Interaction.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Choose | Selects and returns a value from a list of arguments.
static (Shared in Visual Basic) | IIf | Returns one of two objects, depending on the evaluation of an expression.
static (Shared in Visual Basic) | Partition | Returns a string representing the calculated range that contains a number.
static (Shared in Visual Basic) | Switch | Evaluates a list of expressions and returns an Object value corresponding to the first expression in the list that is True.
Top

See Also

Reference

Interaction Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Interaction Class Methods

[image]
ActiveReports 19 .NET Edition
Interaction Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Interaction Class

Glossary Item Box

For a list of all members of this type, see Interaction members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Choose | Selects and returns a value from a list of arguments.
static (Shared in Visual Basic) | IIf | Returns one of two objects, depending on the evaluation of an expression.
static (Shared in Visual Basic) | Partition | Returns a string representing the calculated range that contains a number.
static (Shared in Visual Basic) | Switch | Evaluates a list of expressions and returns an Object value corresponding to the first expression in the list that is True.
Top

See Also

Reference

Interaction Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Choose Method

[image]
ActiveReports 19 .NET Edition
Choose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Interaction Class : Choose Method

Index
Required. Double. Numeric expression that results in a value between 1 and the number of elements passed in the Choice argument.
Choice
Required. Object parameter array. You can supply either a single variable or an expression that evaluates to the Object data type, to a list of Object variables or expressions separated by commas, or to a single-dimensional array of Object elements.

Glossary Item Box

Selects and returns a value from a list of arguments.

Syntax

Visual Basic (Declaration)
Public Shared Function Choose( _
   ByVal Index As Double, _
   ByVal ParamArray Choice() As Object _
) As Object
C#
public static object Choose(
   double Index,
   params object[] Choice
)

Parameters

Index
Required. Double. Numeric expression that results in a value between 1 and the number of elements passed in the Choice argument.
Choice
Required. Object parameter array. You can supply either a single variable or an expression that evaluates to the Object data type, to a list of Object variables or expressions separated by commas, or to a single-dimensional array of Object elements.

Return Value

Selects and returns a value from a list of arguments.

Exceptions

Exception | Description
System.ArgumentException | Choice.Rank != 1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Interaction Class
Interaction Members


IIf Method

[image]
ActiveReports 19 .NET Edition
IIf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Interaction Class : IIf Method

Expression
Required. Boolean. The expression you want to evaluate.
TruePart
Required. Object. Returned if Expression evaluates to True.
FalsePart
Required. Object. Returned if Expression evaluates to False.

Glossary Item Box

Returns one of two objects, depending on the evaluation of an expression.

Syntax

Visual Basic (Declaration)
Public Shared Function IIf( _
   ByVal Expression As Boolean, _
   ByVal TruePart As Object, _
   ByVal FalsePart As Object _
) As Object
C#
public static object IIf(
   bool Expression,
   object TruePart,
   object FalsePart
)

Parameters

Expression
Required. Boolean. The expression you want to evaluate.
TruePart
Required. Object. Returned if Expression evaluates to True.
FalsePart
Required. Object. Returned if Expression evaluates to False.

Return Value

Returns one of two objects, depending on the evaluation of an expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Interaction Class
Interaction Members


Partition Method

[image]
ActiveReports 19 .NET Edition
Partition Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Interaction Class : Partition Method

Number
Required. Long. Whole number that you want to locate within one of the calculated ranges.
Start
Required. Long. Whole number that indicates the start of the set of calculated ranges. Start cannot be less than 0.
Stop
Required. Long. Whole number that indicates the end of the set of calculated ranges. Stop cannot be less than or equal to Start.
Interval
Required. Long. Whole number that indicates the size of each range calculated between Start and Stop. Interval cannot be less than 1.

Glossary Item Box

Returns a string representing the calculated range that contains a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Partition( _
   ByVal Number As Long, _
   ByVal Start As Long, _
   ByVal Stop As Long, _
   ByVal Interval As Long _
) As String
C#
public static string Partition(
   long Number,
   long Start,
   long Stop,
   long Interval
)

Parameters

Number
Required. Long. Whole number that you want to locate within one of the calculated ranges.
Start
Required. Long. Whole number that indicates the start of the set of calculated ranges. Start cannot be less than 0.
Stop
Required. Long. Whole number that indicates the end of the set of calculated ranges. Stop cannot be less than or equal to Start.
Interval
Required. Long. Whole number that indicates the size of each range calculated between Start and Stop. Interval cannot be less than 1.

Return Value

Returns a string representing the calculated range that contains a number.

Exceptions

Exception | Description
System.ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Interaction Class
Interaction Members


Switch Method

[image]
ActiveReports 19 .NET Edition
Switch Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Interaction Class : Switch Method

VarExpr
Required. Object parameter array. Must have an even number of elements. You can supply a list of Object variables or expressions separated by commas, or a single-dimensional array of Object elements.

Glossary Item Box

Evaluates a list of expressions and returns an Object value corresponding to the first expression in the list that is True.

Syntax

Visual Basic (Declaration)
Public Shared Function Switch( _
   ByVal ParamArray VarExpr() As Object _
) As Object
C#
public static object Switch(
   params object[] VarExpr
)

Parameters

VarExpr
Required. Object parameter array. Must have an even number of elements. You can supply a list of Object variables or expressions separated by commas, or a single-dimensional array of Object elements.

Return Value

Evaluates a list of expressions and returns an Object value corresponding to the first expression in the list that is True.

Exceptions

Exception | Description
System.ArgumentException | Number of arguments is odd.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Interaction Class
Interaction Members


LongType Class

[image]
ActiveReports 19 .NET Edition
LongType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : LongType Class

Glossary Item Box

Represents conversions to Long

Object Model

LongType Class

Syntax

Visual Basic (Declaration)
Public Class LongType
C#
public class LongType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.LongType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LongType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


LongType Class Members

[image]
ActiveReports 19 .NET Edition
LongType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : LongType Class

Glossary Item Box

The following tables list the members exposed by LongType.

Public Constructors

 | Name | Description
Public Constructor | LongType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a Long value.
static (Shared in Visual Basic) | FromString | Converts a string to a Long value.
Top

See Also

Reference

LongType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


LongType Constructor

[image]
ActiveReports 19 .NET Edition
LongType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > LongType Class : LongType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LongType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LongType Class
LongType Members


LongType Class Methods

[image]
ActiveReports 19 .NET Edition
LongType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : LongType Class

Glossary Item Box

For a list of all members of this type, see LongType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a Long value.
static (Shared in Visual Basic) | FromString | Converts a string to a Long value.
Top

See Also

Reference

LongType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > LongType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a Long value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Long
C#
public static long FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Long value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LongType Class
LongType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > LongType Class : FromString Method

value
The string to convert.

Glossary Item Box

Converts a string to a Long value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String _
) As Long
C#
public static long FromString(
   string value
)

Parameters

value
The string to convert.

Return Value

The Long value of the string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LongType Class
LongType Members


ObjectType Class

[image]
ActiveReports 19 .NET Edition
ObjectType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ObjectType Class

Glossary Item Box

Object Model

ObjectType Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectType
C#
public sealed class ObjectType

Remarks

Only for direct invoking. Shouldn't be reflected. This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.ObjectType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ObjectType Class Members

[image]
ActiveReports 19 .NET Edition
ObjectType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ObjectType Class

Glossary Item Box

The following tables list the members exposed by ObjectType.

Public Constructors

 | Name | Description
Public Constructor | ObjectType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddObj | Performs an addition (+) operation.
static (Shared in Visual Basic) | BitAndObj | Performs a bitwise And operation.
static (Shared in Visual Basic) | BitOrObj | Performs a bitwise Or operation.
static (Shared in Visual Basic) | BitXorObj | Performs an Xor operation.
static (Shared in Visual Basic) | DivObj | Performs a division (/) operation.
static (Shared in Visual Basic) | GetWidestType | Returns the widest type among the two objects.
static (Shared in Visual Basic) | IDivObj | Performs an integer division (\) operation.
static (Shared in Visual Basic) | ModObj | Performs a modulus (Mod) operation.
static (Shared in Visual Basic) | MulObj | Performs a multiplication (*) operation.
static (Shared in Visual Basic) | NegObj | Performs a unary minus (–) operation.
static (Shared in Visual Basic) | NotObj | Performs a Not operation.
static (Shared in Visual Basic) | ObjTst | Performs binary or text string comparison when given two objects.
static (Shared in Visual Basic) | PowObj | Performs an exponent (^) operation.
static (Shared in Visual Basic) | ShiftLeftObj | Performs an arithmetic left shift (<<) operation.
static (Shared in Visual Basic) | ShiftRightObj | Performs an arithmetic right shift (>>) operation.
static (Shared in Visual Basic) | SubObj | Performs a subtraction (–) operation.
Top

See Also

Reference

ObjectType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ObjectType Constructor

[image]
ActiveReports 19 .NET Edition
ObjectType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : ObjectType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ObjectType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ObjectType Class Methods

[image]
ActiveReports 19 .NET Edition
ObjectType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ObjectType Class

Glossary Item Box

For a list of all members of this type, see ObjectType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddObj | Performs an addition (+) operation.
static (Shared in Visual Basic) | BitAndObj | Performs a bitwise And operation.
static (Shared in Visual Basic) | BitOrObj | Performs a bitwise Or operation.
static (Shared in Visual Basic) | BitXorObj | Performs an Xor operation.
static (Shared in Visual Basic) | DivObj | Performs a division (/) operation.
static (Shared in Visual Basic) | GetWidestType | Returns the widest type among the two objects.
static (Shared in Visual Basic) | IDivObj | Performs an integer division (\) operation.
static (Shared in Visual Basic) | ModObj | Performs a modulus (Mod) operation.
static (Shared in Visual Basic) | MulObj | Performs a multiplication (*) operation.
static (Shared in Visual Basic) | NegObj | Performs a unary minus (–) operation.
static (Shared in Visual Basic) | NotObj | Performs a Not operation.
static (Shared in Visual Basic) | ObjTst | Performs binary or text string comparison when given two objects.
static (Shared in Visual Basic) | PowObj | Performs an exponent (^) operation.
static (Shared in Visual Basic) | ShiftLeftObj | Performs an arithmetic left shift (<<) operation.
static (Shared in Visual Basic) | ShiftRightObj | Performs an arithmetic right shift (>>) operation.
static (Shared in Visual Basic) | SubObj | Performs a subtraction (–) operation.
Top

See Also

Reference

ObjectType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


AddObj Method

[image]
ActiveReports 19 .NET Edition
AddObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : AddObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs an addition (+) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function AddObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object AddObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The sum of o1 and o2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


BitAndObj Method

[image]
ActiveReports 19 .NET Edition
BitAndObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : BitAndObj Method

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Glossary Item Box

Performs a bitwise And operation.

Syntax

Visual Basic (Declaration)
Public Shared Function BitAndObj( _
   ByVal obj1 As Object, _
   ByVal obj2 As Object _
) As Object
C#
public static object BitAndObj(
   object obj1,
   object obj2
)

Parameters

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Return Value

1 if both obj1 and obj2 evaluate to 1; otherwise, 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


BitOrObj Method

[image]
ActiveReports 19 .NET Edition
BitOrObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : BitOrObj Method

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Glossary Item Box

Performs a bitwise Or operation.

Syntax

Visual Basic (Declaration)
Public Shared Function BitOrObj( _
   ByVal obj1 As Object, _
   ByVal obj2 As Object _
) As Object
C#
public static object BitOrObj(
   object obj1,
   object obj2
)

Parameters

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Return Value

0 if both obj1 and obj2 evaluate to 0; otherwise, 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


BitXorObj Method

[image]
ActiveReports 19 .NET Edition
BitXorObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : BitXorObj Method

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Glossary Item Box

Performs an Xor operation.

Syntax

Visual Basic (Declaration)
Public Shared Function BitXorObj( _
   ByVal obj1 As Object, _
   ByVal obj2 As Object _
) As Object
C#
public static object BitXorObj(
   object obj1,
   object obj2
)

Parameters

obj1
Required. Any Boolean or numeric expression.
obj2
Required. Any Boolean or numeric expression.

Return Value

A numeric value that represents the bitwise exclusion (exclusive bitwise disjunction) of two numeric bit patterns. For more information, see Xor Operator (Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


DivObj Method

[image]
ActiveReports 19 .NET Edition
DivObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : DivObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs a division (/) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function DivObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object DivObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The full quotient of o1 divided by o2, including any remainder.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


GetWidestType Method

[image]
ActiveReports 19 .NET Edition
GetWidestType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : GetWidestType Method

obj1
The first object.
obj2
The second object.
IsAdd
If true, doesn’t compare String and DBNull and returns TypeCode.Empty.

Glossary Item Box

Returns the widest type among the two objects.

Syntax

Visual Basic (Declaration)
Public Shared Function GetWidestType( _
   ByVal obj1 As Object, _
   ByVal obj2 As Object, _
   Optional ByVal IsAdd As Boolean _
) As TypeCode
C#
public static TypeCode GetWidestType(
   object obj1,
   object obj2,
   bool IsAdd
)

Parameters

obj1
The first object.
obj2
The second object.
IsAdd
If true, doesn’t compare String and DBNull and returns TypeCode.Empty.

Return Value

Returns the widest type among the two objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


IDivObj Method

[image]
ActiveReports 19 .NET Edition
IDivObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : IDivObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs an integer division (\) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function IDivObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object IDivObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The integer quotient of o1 divided by o2, which discards any remainder and retains only the integer portion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ModObj Method

[image]
ActiveReports 19 .NET Edition
ModObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : ModObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs a modulus (Mod) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function ModObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object ModObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The remainder after o1 is divided by o2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


MulObj Method

[image]
ActiveReports 19 .NET Edition
MulObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : MulObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs a multiplication (*) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function MulObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object MulObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The product of o1 and o2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


NegObj Method

[image]
ActiveReports 19 .NET Edition
NegObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : NegObj Method

obj
Required. Any numeric expression.

Glossary Item Box

Performs a unary minus (–) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function NegObj( _
   ByVal obj As Object _
) As Object
C#
public static object NegObj(
   object obj
)

Parameters

obj
Required. Any numeric expression.

Return Value

The negative value of obj.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


NotObj Method

[image]
ActiveReports 19 .NET Edition
NotObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : NotObj Method

obj
Required. Any Boolean or numeric expression.

Glossary Item Box

Performs a Not operation.

Syntax

Visual Basic (Declaration)
Public Shared Function NotObj( _
   ByVal obj As Object _
) As Object
C#
public static object NotObj(
   object obj
)

Parameters

obj
Required. Any Boolean or numeric expression.

Return Value

For Boolean operations, False if obj is True; otherwise, True. For bitwise operations, 1 if obj is 0; otherwise, 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ObjTst Method

[image]
ActiveReports 19 .NET Edition
ObjTst Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : ObjTst Method

o1
Required. Any expression.
o2
Required. Any expression.
TextCompare
Required. True to perform a case-insensitive string comparison; otherwise, False.

Glossary Item Box

Performs binary or text string comparison when given two objects.

Syntax

Visual Basic (Declaration)
Public Shared Function ObjTst( _
   ByVal o1 As Object, _
   ByVal o2 As Object, _
   ByVal TextCompare As Boolean _
) As Integer
C#
public static int ObjTst(
   object o1,
   object o2,
   bool TextCompare
)

Parameters

o1
Required. Any expression.
o2
Required. Any expression.
TextCompare
Required. True to perform a case-insensitive string comparison; otherwise, False.

Return Value

Value Condition -1 o1 is less than o2. 0 o1 is equal to o2. 1 o1 is greater than o2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


PowObj Method

[image]
ActiveReports 19 .NET Edition
PowObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : PowObj Method

obj1
Required. Any numeric expression.
obj2
Required. Any numeric expression.

Glossary Item Box

Performs an exponent (^) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function PowObj( _
   ByVal obj1 As Object, _
   ByVal obj2 As Object _
) As Object
C#
public static object PowObj(
   object obj1,
   object obj2
)

Parameters

obj1
Required. Any numeric expression.
obj2
Required. Any numeric expression.

Return Value

The result of obj1 raised to the power of obj2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ShiftLeftObj Method

[image]
ActiveReports 19 .NET Edition
ShiftLeftObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : ShiftLeftObj Method

o1
Required. Integral numeric expression. The bit pattern to be shifted. The data type must be an integral type (SByte, Byte, Short, UShort, Integer, UInteger, Long, or ULong).
amount
Required. Numeric expression. The number of bits to shift the bit pattern. The data type must be Integer or widen to Integer.

Glossary Item Box

Performs an arithmetic left shift (<<) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function ShiftLeftObj( _
   ByVal o1 As Object, _
   ByVal amount As Integer _
) As Object
C#
public static object ShiftLeftObj(
   object o1,
   int amount
)

Parameters

o1
Required. Integral numeric expression. The bit pattern to be shifted. The data type must be an integral type (SByte, Byte, Short, UShort, Integer, UInteger, Long, or ULong).
amount
Required. Numeric expression. The number of bits to shift the bit pattern. The data type must be Integer or widen to Integer.

Return Value

An integral numeric value. The result of shifting the bit pattern. The data type is the same as that of o1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ShiftRightObj Method

[image]
ActiveReports 19 .NET Edition
ShiftRightObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : ShiftRightObj Method

o1
Required. Integral numeric expression. The bit pattern to be shifted. The data type must be an integral type (SByte, Byte, Short, UShort, Integer, UInteger, Long, or ULong).
amount
Required. Numeric expression. The number of bits to shift the bit pattern. The data type must be Integer or widen to Integer.

Glossary Item Box

Performs an arithmetic right shift (>>) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function ShiftRightObj( _
   ByVal o1 As Object, _
   ByVal amount As Integer _
) As Object
C#
public static object ShiftRightObj(
   object o1,
   int amount
)

Parameters

o1
Required. Integral numeric expression. The bit pattern to be shifted. The data type must be an integral type (SByte, Byte, Short, UShort, Integer, UInteger, Long, or ULong).
amount
Required. Numeric expression. The number of bits to shift the bit pattern. The data type must be Integer or widen to Integer.

Return Value

An integral numeric value. The result of shifting the bit pattern. The data type is the same as that of o1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


SubObj Method

[image]
ActiveReports 19 .NET Edition
SubObj Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ObjectType Class : SubObj Method

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Glossary Item Box

Performs a subtraction (–) operation.

Syntax

Visual Basic (Declaration)
Public Shared Function SubObj( _
   ByVal o1 As Object, _
   ByVal o2 As Object _
) As Object
C#
public static object SubObj(
   object o1,
   object o2
)

Parameters

o1
Required. Any numeric expression.
o2
Required. Any numeric expression.

Return Value

The difference between o1 and o2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectType Class
ObjectType Members


ShortType Class

[image]
ActiveReports 19 .NET Edition
ShortType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ShortType Class

Glossary Item Box

Represents conversions to Short

Object Model

ShortType Class

Syntax

Visual Basic (Declaration)
Public Class ShortType
C#
public class ShortType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.ShortType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShortType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ShortType Class Members

[image]
ActiveReports 19 .NET Edition
ShortType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ShortType Class

Glossary Item Box

The following tables list the members exposed by ShortType.

Public Constructors

 | Name | Description
Public Constructor | ShortType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a Short value.
static (Shared in Visual Basic) | FromString | Converts a string to a Short value.
Top

See Also

Reference

ShortType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


ShortType Constructor

[image]
ActiveReports 19 .NET Edition
ShortType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ShortType Class : ShortType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ShortType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShortType Class
ShortType Members


ShortType Class Methods

[image]
ActiveReports 19 .NET Edition
ShortType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : ShortType Class

Glossary Item Box

For a list of all members of this type, see ShortType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a Short value.
static (Shared in Visual Basic) | FromString | Converts a string to a Short value.
Top

See Also

Reference

ShortType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ShortType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a Short value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Short
C#
public static short FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Short value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShortType Class
ShortType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > ShortType Class : FromString Method

value
The string to convert.

Glossary Item Box

Converts a string to a Short value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String _
) As Short
C#
public static short FromString(
   string value
)

Parameters

value
The string to convert.

Return Value

The Short value of the string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShortType Class
ShortType Members


SingleType Class

[image]
ActiveReports 19 .NET Edition
SingleType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : SingleType Class

Glossary Item Box

Represents conversions to Single

Object Model

SingleType Class

Syntax

Visual Basic (Declaration)
Public Class SingleType
C#
public class SingleType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.SingleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


SingleType Class Members

[image]
ActiveReports 19 .NET Edition
SingleType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : SingleType Class

Glossary Item Box

The following tables list the members exposed by SingleType.

Public Constructors

 | Name | Description
Public Constructor | SingleType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Single value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Single value.
Top

See Also

Reference

SingleType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


SingleType Constructor

[image]
ActiveReports 19 .NET Edition
SingleType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > SingleType Class : SingleType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SingleType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleType Class
SingleType Members


SingleType Class Methods

[image]
ActiveReports 19 .NET Edition
SingleType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : SingleType Class

Glossary Item Box

For a list of all members of this type, see SingleType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromObject | Converts an object to a System.Single value.
static (Shared in Visual Basic) | FromString | Converts an object to a System.Single value.
Top

See Also

Reference

SingleType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromObject Method

[image]
ActiveReports 19 .NET Edition
FromObject Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > SingleType Class : FromObject Method

value
The object to convert.

Glossary Item Box

Converts an object to a System.Single value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromObject( _
   ByVal value As Object _
) As Single
C#
public static float FromObject(
   object value
)

Parameters

value
The object to convert.

Return Value

The Single value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleType Class
SingleType Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > SingleType Class : FromString Method

value
The object to convert.
format
Format information.

Glossary Item Box

Converts an object to a System.Single value.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String, _
   ByVal format As NumberFormatInfo _
) As Single
C#
public static float FromString(
   string value,
   NumberFormatInfo format
)

Parameters

value
The object to convert.
format
Format information.

Return Value

The Single value of the object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SingleType Class
SingleType Members


Strings Class

[image]
ActiveReports 19 .NET Edition
Strings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Strings Class

Glossary Item Box

Represents strings operations.

Object Model

Strings Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Strings
C#
public static class Strings

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.Strings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Strings Class Members

[image]
ActiveReports 19 .NET Edition
Strings Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Strings Class

Glossary Item Box

The following tables list the members exposed by Strings.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Asc | Overloaded. Returns an Integer value representing the character code corresponding to a character.
static (Shared in Visual Basic) | AscW | Overloaded. Returns an Integer value representing the character code corresponding to a character.
static (Shared in Visual Basic) | Chr | Returns the character associated with the specified character code.
static (Shared in Visual Basic) | ChrW | Returns the character associated with the specified character code.
static (Shared in Visual Basic) | Filter | Overloaded. Returns a zero-based array containing a subset of a String array based on specified filter criteria.
static (Shared in Visual Basic) | Format | Returns a string formatted according to instructions contained in a format String expression.
static (Shared in Visual Basic) | FormatCurrency | Returns an expression formatted as a currency value using the currency symbol defined in the system control panel.
static (Shared in Visual Basic) | FormatDateTime | Returns a string expression representing a date/time value.
static (Shared in Visual Basic) | FormatNumber | Returns an expression formatted as a number.
static (Shared in Visual Basic) | FormatPercent | Returns an expression formatted as a percentage (that is, multiplied by 100) with a trailing % character.
static (Shared in Visual Basic) | GetChar | Gets a character by its 1-based index
static (Shared in Visual Basic) | InStr | Overloaded. Returns an integer specifying the start position of the first occurrence of one string within another.
static (Shared in Visual Basic) | InStrRev | Returns the position of the first occurrence of one string within another, starting from the right side of the string.
static (Shared in Visual Basic) | Join | Overloaded. Returns a string created by joining a number of substrings contained in an array.
static (Shared in Visual Basic) | LCase | Overloaded. Returns a string or character converted to lowercase.
static (Shared in Visual Basic) | Left | Returns a string containing a specified number of characters from the left side of a string.
static (Shared in Visual Basic) | Len | Overloaded. Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
static (Shared in Visual Basic) | LSet | Returns a left-aligned string containing the specified string adjusted to the specified length.
static (Shared in Visual Basic) | LTrim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | Mid | Overloaded. Returns a string containing a specified number of characters from a string.
static (Shared in Visual Basic) | Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
static (Shared in Visual Basic) | Right | Returns a string containing a specified number of characters from the right side of a string.
static (Shared in Visual Basic) | RSet | Returns a right-aligned string containing the specified string adjusted to the specified length.
static (Shared in Visual Basic) | RTrim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | Space | Returns a string consisting of the specified number of spaces.
static (Shared in Visual Basic) | Split | Returns a zero-based, one-dimensional array containing a specified number of substrings.
static (Shared in Visual Basic) | StrComp | Returns -1, 0, or 1, based on the result of a string comparison.
static (Shared in Visual Basic) | StrConv | [NotImplemented] Returns a string converted as specified. This method called kernel32.dll.
static (Shared in Visual Basic) | StrDup | Overloaded. Returns a string or object consisting of the specified character repeated the specified number of times.
static (Shared in Visual Basic) | StrLike | Compares the parameters and and returns the same results as the Like operator.
static (Shared in Visual Basic) | StrLikeBinary | Compares the parameters and and returns the same results as the Like operator, using binary comparison.
static (Shared in Visual Basic) | StrLikeText | Compares the parameters and and returns the same results as the Like operator, using text comparison.
static (Shared in Visual Basic) | StrReverse | Returns a string in which the character order of a specified string is reversed.
static (Shared in Visual Basic) | Trim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | UCase | Overloaded. Returns a string or character containing the specified string converted to uppercase.
Top

See Also

Reference

Strings Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Strings Class Methods

[image]
ActiveReports 19 .NET Edition
Strings Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Strings Class

Glossary Item Box

For a list of all members of this type, see Strings members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Asc | Overloaded. Returns an Integer value representing the character code corresponding to a character.
static (Shared in Visual Basic) | AscW | Overloaded. Returns an Integer value representing the character code corresponding to a character.
static (Shared in Visual Basic) | Chr | Returns the character associated with the specified character code.
static (Shared in Visual Basic) | ChrW | Returns the character associated with the specified character code.
static (Shared in Visual Basic) | Filter | Overloaded. Returns a zero-based array containing a subset of a String array based on specified filter criteria.
static (Shared in Visual Basic) | Format | Returns a string formatted according to instructions contained in a format String expression.
static (Shared in Visual Basic) | FormatCurrency | Returns an expression formatted as a currency value using the currency symbol defined in the system control panel.
static (Shared in Visual Basic) | FormatDateTime | Returns a string expression representing a date/time value.
static (Shared in Visual Basic) | FormatNumber | Returns an expression formatted as a number.
static (Shared in Visual Basic) | FormatPercent | Returns an expression formatted as a percentage (that is, multiplied by 100) with a trailing % character.
static (Shared in Visual Basic) | GetChar | Gets a character by its 1-based index
static (Shared in Visual Basic) | InStr | Overloaded. Returns an integer specifying the start position of the first occurrence of one string within another.
static (Shared in Visual Basic) | InStrRev | Returns the position of the first occurrence of one string within another, starting from the right side of the string.
static (Shared in Visual Basic) | Join | Overloaded. Returns a string created by joining a number of substrings contained in an array.
static (Shared in Visual Basic) | LCase | Overloaded. Returns a string or character converted to lowercase.
static (Shared in Visual Basic) | Left | Returns a string containing a specified number of characters from the left side of a string.
static (Shared in Visual Basic) | Len | Overloaded. Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
static (Shared in Visual Basic) | LSet | Returns a left-aligned string containing the specified string adjusted to the specified length.
static (Shared in Visual Basic) | LTrim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | Mid | Overloaded. Returns a string containing a specified number of characters from a string.
static (Shared in Visual Basic) | Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
static (Shared in Visual Basic) | Right | Returns a string containing a specified number of characters from the right side of a string.
static (Shared in Visual Basic) | RSet | Returns a right-aligned string containing the specified string adjusted to the specified length.
static (Shared in Visual Basic) | RTrim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | Space | Returns a string consisting of the specified number of spaces.
static (Shared in Visual Basic) | Split | Returns a zero-based, one-dimensional array containing a specified number of substrings.
static (Shared in Visual Basic) | StrComp | Returns -1, 0, or 1, based on the result of a string comparison.
static (Shared in Visual Basic) | StrConv | [NotImplemented] Returns a string converted as specified. This method called kernel32.dll.
static (Shared in Visual Basic) | StrDup | Overloaded. Returns a string or object consisting of the specified character repeated the specified number of times.
static (Shared in Visual Basic) | StrLike | Compares the parameters and and returns the same results as the Like operator.
static (Shared in Visual Basic) | StrLikeBinary | Compares the parameters and and returns the same results as the Like operator, using binary comparison.
static (Shared in Visual Basic) | StrLikeText | Compares the parameters and and returns the same results as the Like operator, using text comparison.
static (Shared in Visual Basic) | StrReverse | Returns a string in which the character order of a specified string is reversed.
static (Shared in Visual Basic) | Trim | Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).
static (Shared in Visual Basic) | UCase | Overloaded. Returns a string or character containing the specified string converted to uppercase.
Top

See Also

Reference

Strings Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Asc Method

[image]
ActiveReports 19 .NET Edition
Asc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Asc Method

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Overload List

Overload | Description
Asc(Char) | Returns an Integer value representing the character code corresponding to a character.
Asc(String) | Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Asc(Char) Method

[image]
ActiveReports 19 .NET Edition
Asc(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Asc Method : Asc(Char) Method

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Asc( _
   ByVal String As Char _
) As Integer
C#
public static int Asc(
   char String
)

Parameters

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Return Value

Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Asc(String) Method

[image]
ActiveReports 19 .NET Edition
Asc(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Asc Method : Asc(String) Method

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Asc( _
   ByVal String As String _
) As Integer
C#
public static int Asc(
   string String
)

Parameters

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Return Value

Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


AscW Method

[image]
ActiveReports 19 .NET Edition
AscW Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : AscW Method

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Overload List

Overload | Description
AscW(String) | Returns an Integer value representing the character code corresponding to a character.
AscW(Char) | Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


AscW(String) Method

[image]
ActiveReports 19 .NET Edition
AscW(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > AscW Method : AscW(String) Method

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function AscW( _
   ByVal String As String _
) As Integer
C#
public static int AscW(
   string String
)

Parameters

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Return Value

Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


AscW(Char) Method

[image]
ActiveReports 19 .NET Edition
AscW(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > AscW Method : AscW(Char) Method

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Glossary Item Box

Returns an Integer value representing the character code corresponding to a character.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function AscW( _
   ByVal String As Char _
) As Integer
C#
public static int AscW(
   char String
)

Parameters

String
Required. Any valid Char or String expression. If String is a String expression, only the first character of the string is used for input. If String is Nothing or contains no characters, an System.ArgumentException error occurs.

Return Value

Returns an Integer value representing the character code corresponding to a character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Chr Method

[image]
ActiveReports 19 .NET Edition
Chr Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Chr Method

charCode
Required. An Integer expression representing the code point, or character code, for the character. If charCode is outside the valid range, an System.ArgumentException error occurs. The valid range for Chr is 0 through 255, and the valid range for ChrW is -32768 through 65535.

Glossary Item Box

Returns the character associated with the specified character code.

Syntax

Visual Basic (Declaration)
Public Shared Function Chr( _
   ByVal charCode As Integer _
) As Char
C#
public static char Chr(
   int charCode
)

Parameters

charCode
Required. An Integer expression representing the code point, or character code, for the character. If charCode is outside the valid range, an System.ArgumentException error occurs. The valid range for Chr is 0 through 255, and the valid range for ChrW is -32768 through 65535.

Return Value

Returns the character associated with the specified character code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


ChrW Method

[image]
ActiveReports 19 .NET Edition
ChrW Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : ChrW Method

charCode
Required. An Integer expression representing the code point, or character code, for the character. If charCode is outside the valid range, an System.ArgumentException error occurs. The valid range for Chr is 0 through 255, and the valid range for ChrW is -32768 through 65535.

Glossary Item Box

Returns the character associated with the specified character code.

Syntax

Visual Basic (Declaration)
Public Shared Function ChrW( _
   ByVal charCode As Integer _
) As Char
C#
public static char ChrW(
   int charCode
)

Parameters

charCode
Required. An Integer expression representing the code point, or character code, for the character. If charCode is outside the valid range, an System.ArgumentException error occurs. The valid range for Chr is 0 through 255, and the valid range for ChrW is -32768 through 65535.

Return Value

Returns the character associated with the specified character code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Filter Method

[image]
ActiveReports 19 .NET Edition
Filter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Filter Method

Glossary Item Box

Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Overload List

Overload | Description
Filter(Object[],String,Boolean,CompareMethod) | Returns a zero-based array containing a subset of a String array based on specified filter criteria.
Filter(String[],String,Boolean,CompareMethod) | Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Filter(Object[],String,Boolean,CompareMethod) Method

[image]
ActiveReports 19 .NET Edition
Filter(Object[],String,Boolean,CompareMethod) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Filter Method : Filter(Object[],String,Boolean,CompareMethod) Method

source
Required. One-dimensional array of strings to be searched.
match
Required. String to search for.
include
Optional. Boolean value indicating whether to return substrings that include or exclude match. If include is True, the Filter function returns the subset of the array that contains match as a substring. If include is False, the Filter function returns the subset of the array that does not contain match as a substring.
compare
Optional. Numeric value indicating the kind of string comparison to use. See "Settings" for values.

Glossary Item Box

Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Filter( _
   ByVal source() As Object, _
   ByVal match As String, _
   Optional ByVal include As Boolean, _
   Optional ByVal compare As CompareMethod _
) As String()
C#
public static string[] Filter(
   object[] source,
   string match,
   bool include,
   CompareMethod compare
)

Parameters

source
Required. One-dimensional array of strings to be searched.
match
Required. String to search for.
include
Optional. Boolean value indicating whether to return substrings that include or exclude match. If include is True, the Filter function returns the subset of the array that contains match as a substring. If include is False, the Filter function returns the subset of the array that does not contain match as a substring.
compare
Optional. Numeric value indicating the kind of string comparison to use. See "Settings" for values.

Return Value

Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Filter(String[],String,Boolean,CompareMethod) Method

[image]
ActiveReports 19 .NET Edition
Filter(String[],String,Boolean,CompareMethod) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Filter Method : Filter(String[],String,Boolean,CompareMethod) Method

source
Required. One-dimensional array of strings to be searched.
match
Required. String to search for.
include
Optional. Boolean value indicating whether to return substrings that include or exclude match. If include is True, the Filter function returns the subset of the array that contains match as a substring. If include is False, the Filter function returns the subset of the array that does not contain match as a substring.
compare
Optional. Numeric value indicating the kind of string comparison to use. See "Settings" for values.

Glossary Item Box

Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Filter( _
   ByVal source() As String, _
   ByVal match As String, _
   Optional ByVal include As Boolean, _
   Optional ByVal compare As CompareMethod _
) As String()
C#
public static string[] Filter(
   string[] source,
   string match,
   bool include,
   CompareMethod compare
)

Parameters

source
Required. One-dimensional array of strings to be searched.
match
Required. String to search for.
include
Optional. Boolean value indicating whether to return substrings that include or exclude match. If include is True, the Filter function returns the subset of the array that contains match as a substring. If include is False, the Filter function returns the subset of the array that does not contain match as a substring.
compare
Optional. Numeric value indicating the kind of string comparison to use. See "Settings" for values.

Return Value

Returns a zero-based array containing a subset of a String array based on specified filter criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Format Method

[image]
ActiveReports 19 .NET Edition
Format Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Format Method

expression
Required. Any valid expression.
style
Optional. A valid named or user-defined format String expression.

Glossary Item Box

Returns a string formatted according to instructions contained in a format String expression.

Syntax

Visual Basic (Declaration)
Public Shared Function Format( _
   ByVal expression As Object, _
   Optional ByVal style As String _
) As String
C#
public static string Format(
   object expression,
   string style
)

Parameters

expression
Required. Any valid expression.
style
Optional. A valid named or user-defined format String expression.

Return Value

Returns a string formatted according to instructions contained in a format String expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


FormatCurrency Method

[image]
ActiveReports 19 .NET Edition
FormatCurrency Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : FormatCurrency Method

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places are displayed to the right of the decimal. Default value is –1, which indicates that the computer's regional settings are used.
includeLeadingDigit
Optional. TriState enumeration that indicates whether or not a leading zero is displayed for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState enumeration that indicates whether or not to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState enumeration that indicates whether or not numbers are grouped using the group delimiter specified in the computer's regional settings. See "Settings" for values.

Glossary Item Box

Returns an expression formatted as a currency value using the currency symbol defined in the system control panel.

Syntax

Visual Basic (Declaration)
Public Shared Function FormatCurrency( _
   ByVal expression As Object, _
   Optional ByVal numDigitsAfterDecimal As Integer, _
   Optional ByVal includeLeadingDigit As TriState, _
   Optional ByVal useParensForNegativeNumbers As TriState, _
   Optional ByVal groupDigits As TriState _
) As String
C#
public static string FormatCurrency(
   object expression,
   int numDigitsAfterDecimal,
   TriState includeLeadingDigit,
   TriState useParensForNegativeNumbers,
   TriState groupDigits
)

Parameters

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places are displayed to the right of the decimal. Default value is –1, which indicates that the computer's regional settings are used.
includeLeadingDigit
Optional. TriState enumeration that indicates whether or not a leading zero is displayed for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState enumeration that indicates whether or not to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState enumeration that indicates whether or not numbers are grouped using the group delimiter specified in the computer's regional settings. See "Settings" for values.

Return Value

Returns an expression formatted as a currency value using the currency symbol defined in the system control panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


FormatDateTime Method

[image]
ActiveReports 19 .NET Edition
FormatDateTime Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : FormatDateTime Method

expression
Required. Date expression to be formatted.
namedFormat
Optional. Numeric value that indicates the date/time format used. If omitted, DateFormat.GeneralDate is used.

Glossary Item Box

Returns a string expression representing a date/time value.

Syntax

Visual Basic (Declaration)
Public Shared Function FormatDateTime( _
   ByVal expression As Date, _
   Optional ByVal namedFormat As DateFormat _
) As String
C#
public static string FormatDateTime(
   DateTime expression,
   DateFormat namedFormat
)

Parameters

expression
Required. Date expression to be formatted.
namedFormat
Optional. Numeric value that indicates the date/time format used. If omitted, DateFormat.GeneralDate is used.

Return Value

Returns a string expression representing a date/time value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


FormatNumber Method

[image]
ActiveReports 19 .NET Edition
FormatNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : FormatNumber Method

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places are displayed to the right of the decimal. The default value is –1, which indicates that the computer's regional settings are used.
includeLeadingDigit
Optional. TriState constant that indicates whether a leading 0 is displayed for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState constant that indicates whether to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState constant that indicates whether or not numbers are grouped using the group delimiter specified in the locale settings. See "Settings" for values.

Glossary Item Box

Returns an expression formatted as a number.

Syntax

Visual Basic (Declaration)
Public Shared Function FormatNumber( _
   ByVal expression As Object, _
   Optional ByVal numDigitsAfterDecimal As Integer, _
   Optional ByVal includeLeadingDigit As TriState, _
   Optional ByVal useParensForNegativeNumbers As TriState, _
   Optional ByVal groupDigits As TriState _
) As String
C#
public static string FormatNumber(
   object expression,
   int numDigitsAfterDecimal,
   TriState includeLeadingDigit,
   TriState useParensForNegativeNumbers,
   TriState groupDigits
)

Parameters

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places are displayed to the right of the decimal. The default value is –1, which indicates that the computer's regional settings are used.
includeLeadingDigit
Optional. TriState constant that indicates whether a leading 0 is displayed for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState constant that indicates whether to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState constant that indicates whether or not numbers are grouped using the group delimiter specified in the locale settings. See "Settings" for values.

Return Value

Returns an expression formatted as a number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


FormatPercent Method

[image]
ActiveReports 19 .NET Edition
FormatPercent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : FormatPercent Method

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places to the right of the decimal are displayed. Default value is –1, which indicates that the locale settings are used.
includeLeadingDigit
Optional. TriState constant that indicates whether or not a leading zero displays for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState constant that indicates whether or not to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState constant that indicates whether or not numbers are grouped using the group delimiter specified in the locale settings. See "Settings" for values.

Glossary Item Box

Returns an expression formatted as a percentage (that is, multiplied by 100) with a trailing % character.

Syntax

Visual Basic (Declaration)
Public Shared Function FormatPercent( _
   ByVal expression As Object, _
   Optional ByVal numDigitsAfterDecimal As Integer, _
   Optional ByVal includeLeadingDigit As TriState, _
   Optional ByVal useParensForNegativeNumbers As TriState, _
   Optional ByVal groupDigits As TriState _
) As String
C#
public static string FormatPercent(
   object expression,
   int numDigitsAfterDecimal,
   TriState includeLeadingDigit,
   TriState useParensForNegativeNumbers,
   TriState groupDigits
)

Parameters

expression
Required. Expression to be formatted.
numDigitsAfterDecimal
Optional. Numeric value indicating how many places to the right of the decimal are displayed. Default value is –1, which indicates that the locale settings are used.
includeLeadingDigit
Optional. TriState constant that indicates whether or not a leading zero displays for fractional values. See "Settings" for values.
useParensForNegativeNumbers
Optional. TriState constant that indicates whether or not to place negative values within parentheses. See "Settings" for values.
groupDigits
Optional. TriState constant that indicates whether or not numbers are grouped using the group delimiter specified in the locale settings. See "Settings" for values.

Return Value

Returns an expression formatted as a percentage (that is, multiplied by 100) with a trailing % character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


GetChar Method

[image]
ActiveReports 19 .NET Edition
GetChar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : GetChar Method

str
string
Index
character index

Glossary Item Box

Gets a character by its 1-based index

Syntax

Visual Basic (Declaration)
Public Shared Function GetChar( _
   ByVal str As String, _
   ByVal Index As Integer _
) As Char
C#
public static char GetChar(
   string str,
   int Index
)

Parameters

str
string
Index
character index

Return Value

a character by its 1-based index

Exceptions

Exception | Description
System.ArgumentException | Thrown if str is null. Thrown if Index is out if range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


InStr Method

[image]
ActiveReports 19 .NET Edition
InStr Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : InStr Method

Glossary Item Box

Returns an integer specifying the start position of the first occurrence of one string within another.

Overload List

Overload | Description
InStr(String,String,CompareMethod) | Returns an integer specifying the start position of the first occurrence of one string within another.
InStr(Int32,String,String,CompareMethod) | Returns an integer specifying the start position of the first occurrence of one string within another.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


InStr(String,String,CompareMethod) Method

[image]
ActiveReports 19 .NET Edition
InStr(String,String,CompareMethod) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > InStr Method : InStr(String,String,CompareMethod) Method

string1
Required. String expression being searched.
string2
Required. String expression sought.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Glossary Item Box

Returns an integer specifying the start position of the first occurrence of one string within another.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function InStr( _
   ByVal string1 As String, _
   ByVal string2 As String, _
   Optional ByVal compare As CompareMethod _
) As Integer
C#
public static int InStr(
   string string1,
   string string2,
   CompareMethod compare
)

Parameters

string1
Required. String expression being searched.
string2
Required. String expression sought.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Return Value

If string1 is zero length or Nothing, InStr returns 0. If string2 is not found, InStr returns 0. If string2 is found within string1, InStr returns position where match begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


InStr(Int32,String,String,CompareMethod) Method

[image]
ActiveReports 19 .NET Edition
InStr(Int32,String,String,CompareMethod) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > InStr Method : InStr(Int32,String,String,CompareMethod) Method

start
Optional. Numeric expression that sets the starting position for each search. If omitted, search begins at the first character position. The start index is 1-based.
string1
Required. String expression being searched.
string2
Required. String expression sought.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Glossary Item Box

Returns an integer specifying the start position of the first occurrence of one string within another.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function InStr( _
   ByVal start As Integer, _
   ByVal string1 As String, _
   ByVal string2 As String, _
   Optional ByVal compare As CompareMethod _
) As Integer
C#
public static int InStr(
   int start,
   string string1,
   string string2,
   CompareMethod compare
)

Parameters

start
Optional. Numeric expression that sets the starting position for each search. If omitted, search begins at the first character position. The start index is 1-based.
string1
Required. String expression being searched.
string2
Required. String expression sought.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Return Value

If string1 is zero length or Nothing, InStr returns 0. If string2 is zero length or Nothing, InStr returns start. If string2 is not found, InStr returns 0. If string2 is found within string1, InStr returns position where match begins. If start > string2, InStr returns 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


InStrRev Method

[image]
ActiveReports 19 .NET Edition
InStrRev Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : InStrRev Method

stringCheck
Required. String expression being searched.
stringMatch
Required. String expression being searched for.
start
Optional. Numeric expression setting the one-based starting position for each search, starting from the left side of the string. If start is omitted then –1 is used, meaning the search begins at the last character position. Search then proceeds from right to left.
compare
Optional. Numeric value indicating the kind of comparison to use when evaluating substrings. If omitted, a binary comparison is performed. See Settings for values.

Glossary Item Box

Returns the position of the first occurrence of one string within another, starting from the right side of the string.

Syntax

Visual Basic (Declaration)
Public Shared Function InStrRev( _
   ByVal stringCheck As String, _
   ByVal stringMatch As String, _
   Optional ByVal start As Integer, _
   Optional ByVal compare As CompareMethod _
) As Integer
C#
public static int InStrRev(
   string stringCheck,
   string stringMatch,
   int start,
   CompareMethod compare
)

Parameters

stringCheck
Required. String expression being searched.
stringMatch
Required. String expression being searched for.
start
Optional. Numeric expression setting the one-based starting position for each search, starting from the left side of the string. If start is omitted then –1 is used, meaning the search begins at the last character position. Search then proceeds from right to left.
compare
Optional. Numeric value indicating the kind of comparison to use when evaluating substrings. If omitted, a binary comparison is performed. See Settings for values.

Return Value

If stringCheck is zero-length, InStrRev returns 0. If stringMatch is zero-length, InStrRev returns start. If stringMatch is not found, InStrRev returns 0. If stringMatch is found within stringCheck, InStrRev returns position at which the first match is found, starting with the right side of the string. If start is greater than length of stringMatch, InStrRev returns 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Join Method

[image]
ActiveReports 19 .NET Edition
Join Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Join Method

Glossary Item Box

Returns a string created by joining a number of substrings contained in an array.

Overload List

Overload | Description
Join(Object[],String) | Returns a string created by joining a number of substrings contained in an array.
Join(String[],String) | Returns a string created by joining a number of substrings contained in an array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Join(Object[],String) Method

[image]
ActiveReports 19 .NET Edition
Join(Object[],String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Join Method : Join(Object[],String) Method

sourceArray
Required. One-dimensional array containing substrings to be joined.
delimiter
Optional. Any string, used to separate the substrings in the returned string. If omitted, the space character (" ") is used. If delimiter is a zero-length string ("") or Nothing, all items in the list are concatenated with no delimiters.

Glossary Item Box

Returns a string created by joining a number of substrings contained in an array.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Join( _
   ByVal sourceArray() As Object, _
   Optional ByVal delimiter As String _
) As String
C#
public static string Join(
   object[] sourceArray,
   string delimiter
)

Parameters

sourceArray
Required. One-dimensional array containing substrings to be joined.
delimiter
Optional. Any string, used to separate the substrings in the returned string. If omitted, the space character (" ") is used. If delimiter is a zero-length string ("") or Nothing, all items in the list are concatenated with no delimiters.

Return Value

Returns a string created by joining a number of substrings contained in an array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Join(String[],String) Method

[image]
ActiveReports 19 .NET Edition
Join(String[],String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Join Method : Join(String[],String) Method

sourceArray
Required. One-dimensional array containing substrings to be joined.
delimiter
Optional. Any string, used to separate the substrings in the returned string. If omitted, the space character (" ") is used. If delimiter is a zero-length string ("") or Nothing, all items in the list are concatenated with no delimiters.

Glossary Item Box

Returns a string created by joining a number of substrings contained in an array.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Join( _
   ByVal sourceArray() As String, _
   Optional ByVal delimiter As String _
) As String
C#
public static string Join(
   string[] sourceArray,
   string delimiter
)

Parameters

sourceArray
Required. One-dimensional array containing substrings to be joined.
delimiter
Optional. Any string, used to separate the substrings in the returned string. If omitted, the space character (" ") is used. If delimiter is a zero-length string ("") or Nothing, all items in the list are concatenated with no delimiters.

Return Value

Returns a string created by joining a number of substrings contained in an array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


LCase Method

[image]
ActiveReports 19 .NET Edition
LCase Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : LCase Method

Glossary Item Box

Returns a string or character converted to lowercase.

Overload List

Overload | Description
LCase(String) | Returns a string or character converted to lowercase.
LCase(Char) | Returns a string or character converted to lowercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


LCase(String) Method

[image]
ActiveReports 19 .NET Edition
LCase(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > LCase Method : LCase(String) Method

value
Required. Any valid String or Char expression.

Glossary Item Box

Returns a string or character converted to lowercase.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LCase( _
   ByVal value As String _
) As String
C#
public static string LCase(
   string value
)

Parameters

value
Required. Any valid String or Char expression.

Return Value

Returns a string or character converted to lowercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


LCase(Char) Method

[image]
ActiveReports 19 .NET Edition
LCase(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > LCase Method : LCase(Char) Method

value
Required. Any valid String or Char expression.

Glossary Item Box

Returns a string or character converted to lowercase.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LCase( _
   ByVal value As Char _
) As Char
C#
public static char LCase(
   char value
)

Parameters

value
Required. Any valid String or Char expression.

Return Value

Returns a string or character converted to lowercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Left Method

[image]
ActiveReports 19 .NET Edition
Left Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Left Method

str
Required. String expression from which the leftmost characters are returned.
length
Required. Integer expression. Numeric expression indicating how many characters to return. If 0, a zero-length string ("") is returned. If greater than or equal to the number of characters in str, the entire string is returned.

Glossary Item Box

Returns a string containing a specified number of characters from the left side of a string.

Syntax

Visual Basic (Declaration)
Public Shared Function Left( _
   ByVal str As String, _
   ByVal length As Integer _
) As String
C#
public static string Left(
   string str,
   int length
)

Parameters

str
Required. String expression from which the leftmost characters are returned.
length
Required. Integer expression. Numeric expression indicating how many characters to return. If 0, a zero-length string ("") is returned. If greater than or equal to the number of characters in str, the entire string is returned.

Return Value

Returns a string containing a specified number of characters from the left side of a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Len Method

[image]
ActiveReports 19 .NET Edition
Len Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Len Method

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Overload List

Overload | Description
Len(Boolean) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(SByte) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Byte) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Int16) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(UInt16) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Int32) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(UInt32) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Int64) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(UInt64) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Decimal) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Single) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Double) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(DateTime) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Char) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(String) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.
Len(Object) | Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Len(Boolean) Method

[image]
ActiveReports 19 .NET Edition
Len(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Boolean) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Boolean _
) As Integer
C#
public static int Len(
   bool expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(SByte) Method

[image]
ActiveReports 19 .NET Edition
Len(SByte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(SByte) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As SByte _
) As Integer
C#
public static int Len(
   sbyte expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Byte) Method

[image]
ActiveReports 19 .NET Edition
Len(Byte) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Byte) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Byte _
) As Integer
C#
public static int Len(
   byte expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Int16) Method

[image]
ActiveReports 19 .NET Edition
Len(Int16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Int16) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Short _
) As Integer
C#
public static int Len(
   short expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(UInt16) Method

[image]
ActiveReports 19 .NET Edition
Len(UInt16) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(UInt16) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As UShort _
) As Integer
C#
public static int Len(
   ushort expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Int32) Method

[image]
ActiveReports 19 .NET Edition
Len(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Int32) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Integer _
) As Integer
C#
public static int Len(
   int expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(UInt32) Method

[image]
ActiveReports 19 .NET Edition
Len(UInt32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(UInt32) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As UInteger _
) As Integer
C#
public static int Len(
   uint expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Int64) Method

[image]
ActiveReports 19 .NET Edition
Len(Int64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Int64) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Long _
) As Integer
C#
public static int Len(
   long expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(UInt64) Method

[image]
ActiveReports 19 .NET Edition
Len(UInt64) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(UInt64) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As ULong _
) As Integer
C#
public static int Len(
   ulong expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Decimal) Method

[image]
ActiveReports 19 .NET Edition
Len(Decimal) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Decimal) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Decimal _
) As Integer
C#
public static int Len(
   decimal expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Single) Method

[image]
ActiveReports 19 .NET Edition
Len(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Single) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Single _
) As Integer
C#
public static int Len(
   float expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Double) Method

[image]
ActiveReports 19 .NET Edition
Len(Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Double) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Double _
) As Integer
C#
public static int Len(
   double expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(DateTime) Method

[image]
ActiveReports 19 .NET Edition
Len(DateTime) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(DateTime) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Date _
) As Integer
C#
public static int Len(
   DateTime expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Char) Method

[image]
ActiveReports 19 .NET Edition
Len(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Char) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Char _
) As Integer
C#
public static int Len(
   char expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(String) Method

[image]
ActiveReports 19 .NET Edition
Len(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(String) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As String _
) As Integer
C#
public static int Len(
   string expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Len(Object) Method

[image]
ActiveReports 19 .NET Edition
Len(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Len Method : Len(Object) Method

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Glossary Item Box

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Len( _
   ByVal expression As Object _
) As Integer
C#
public static int Len(
   object expression
)

Parameters

expression
Any valid String expression or variable name. If expression is of type Object, the Len function returns the size as it will be written to the file by the FilePut function.

Return Value

Returns an integer containing either the number of characters in a string or the nominal number of bytes required to store a variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


LSet Method

[image]
ActiveReports 19 .NET Edition
LSet Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : LSet Method

source
Required. String expression. Name of string variable.
length
Required. Integer expression. Length of returned string.

Glossary Item Box

Returns a left-aligned string containing the specified string adjusted to the specified length.

Syntax

Visual Basic (Declaration)
Public Shared Function LSet( _
   ByVal source As String, _
   ByVal length As Integer _
) As String
C#
public static string LSet(
   string source,
   int length
)

Parameters

source
Required. String expression. Name of string variable.
length
Required. Integer expression. Length of returned string.

Return Value

Returns a left-aligned string containing the specified string adjusted to the specified length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


LTrim Method

[image]
ActiveReports 19 .NET Edition
LTrim Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : LTrim Method

str
Required. Any valid String expression.

Glossary Item Box

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Syntax

Visual Basic (Declaration)
Public Shared Function LTrim( _
   ByVal str As String _
) As String
C#
public static string LTrim(
   string str
)

Parameters

str
Required. Any valid String expression.

Return Value

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Mid Method

[image]
ActiveReports 19 .NET Edition
Mid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Mid Method

Glossary Item Box

Returns a string containing a specified number of characters from a string.

Overload List

Overload | Description
Mid(String,Int32) | Returns a string containing a specified number of characters from a string.
Mid(String,Int32,Int32) | Returns a string containing a specified number of characters from a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Mid(String,Int32) Method

[image]
ActiveReports 19 .NET Edition
Mid(String,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Mid Method : Mid(String,Int32) Method

str
Required. String expression from which characters are returned.
start
Required. Integer expression. Starting position of the characters to return. If start is greater than the number of characters in str, the Mid function returns a zero-length string (""). start is one based.

Glossary Item Box

Returns a string containing a specified number of characters from a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Mid( _
   ByVal str As String, _
   ByVal start As Integer _
) As String
C#
public static string Mid(
   string str,
   int start
)

Parameters

str
Required. String expression from which characters are returned.
start
Required. Integer expression. Starting position of the characters to return. If start is greater than the number of characters in str, the Mid function returns a zero-length string (""). start is one based.

Return Value

Returns a string containing a specified number of characters from a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Mid(String,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
Mid(String,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > Mid Method : Mid(String,Int32,Int32) Method

str
Required. String expression from which characters are returned.
start
Required. Integer expression. Starting position of the characters to return. If start is greater than the number of characters in str, the Mid function returns a zero-length string (""). start is one based.
Length
Optional. Integer expression. Number of characters to return. If omitted or if there are fewer than Length characters in the text (including the character at position start), all characters from the start position to the end of the string are returned.

Glossary Item Box

Returns a string containing a specified number of characters from a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Mid( _
   ByVal str As String, _
   ByVal start As Integer, _
   ByVal Length As Integer _
) As String
C#
public static string Mid(
   string str,
   int start,
   int Length
)

Parameters

str
Required. String expression from which characters are returned.
start
Required. Integer expression. Starting position of the characters to return. If start is greater than the number of characters in str, the Mid function returns a zero-length string (""). start is one based.
Length
Optional. Integer expression. Number of characters to return. If omitted or if there are fewer than Length characters in the text (including the character at position start), all characters from the start position to the end of the string are returned.

Return Value

Returns a string containing a specified number of characters from a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


Replace Method

[image]
ActiveReports 19 .NET Edition
Replace Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Replace Method

expression
Required. String expression containing substring to replace.
find
Required. Substring being searched for.
replacement
Required. Replacement substring.
start
Optional. Position within expression where substring search is to begin. If omitted, 1 is assumed.
count
Optional. Number of substring substitutions to perform. If omitted, the default value is –1, which means "make all possible substitutions."
compare
Optional. Numeric value indicating the kind of comparison to use when evaluating substrings. See Settings for values.

Glossary Item Box

Returns a string in which a specified substring has been replaced with another substring a specified number of times.

Syntax

Visual Basic (Declaration)
Public Shared Function Replace( _
   ByVal expression As String, _
   ByVal find As String, _
   ByVal replacement As String, _
   Optional ByVal start As Integer, _
   Optional ByVal count As Integer, _
   Optional ByVal compare As CompareMethod _
) As String
C#
public static string Replace(
   string expression,
   string find,
   string replacement,
   int start,
   int count,
   CompareMethod compare
)

Parameters

expression
Required. String expression containing substring to replace.
find
Required. Substring being searched for.
replacement
Required. Replacement substring.
start
Optional. Position within expression where substring search is to begin. If omitted, 1 is assumed.
count
Optional. Number of substring substitutions to perform. If omitted, the default value is –1, which means "make all possible substitutions."
compare
Optional. Numeric value indicating the kind of comparison to use when evaluating substrings. See Settings for values.

Return Value

If find is zero-length or Nothing, Replace returns copy of expression. If replacement is zero-length, Replace returns copy of expression with no occurrences of find. If expression is zero-length or Nothing, or start is greater than length of expression, Replace returns Nothing. If count is 0, Replace returns copy of expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Right Method

[image]
ActiveReports 19 .NET Edition
Right Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Right Method

str
Required. String expression from which the rightmost characters are returned.
length
Required. Integer. Numeric expression indicating how many characters to return. If 0, a zero-length string ("") is returned. If greater than or equal to the number of characters in str, the entire string is returned.

Glossary Item Box

Returns a string containing a specified number of characters from the right side of a string.

Syntax

Visual Basic (Declaration)
Public Shared Function Right( _
   ByVal str As String, _
   ByVal length As Integer _
) As String
C#
public static string Right(
   string str,
   int length
)

Parameters

str
Required. String expression from which the rightmost characters are returned.
length
Required. Integer. Numeric expression indicating how many characters to return. If 0, a zero-length string ("") is returned. If greater than or equal to the number of characters in str, the entire string is returned.

Return Value

Returns a string containing a specified number of characters from the right side of a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


RSet Method

[image]
ActiveReports 19 .NET Edition
RSet Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : RSet Method

source
Required. String expression. Name of string variable.
length
Required. Integer expression. Length of returned string.

Glossary Item Box

Returns a right-aligned string containing the specified string adjusted to the specified length.

Syntax

Visual Basic (Declaration)
Public Shared Function RSet( _
   ByVal source As String, _
   ByVal length As Integer _
) As String
C#
public static string RSet(
   string source,
   int length
)

Parameters

source
Required. String expression. Name of string variable.
length
Required. Integer expression. Length of returned string.

Return Value

Returns a right-aligned string containing the specified string adjusted to the specified length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


RTrim Method

[image]
ActiveReports 19 .NET Edition
RTrim Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : RTrim Method

str
Required. Any valid String expression.

Glossary Item Box

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Syntax

Visual Basic (Declaration)
Public Shared Function RTrim( _
   ByVal str As String _
) As String
C#
public static string RTrim(
   string str
)

Parameters

str
Required. Any valid String expression.

Return Value

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Space Method

[image]
ActiveReports 19 .NET Edition
Space Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Space Method

number
Required. Integer expression. The number of spaces you want in the string.

Glossary Item Box

Returns a string consisting of the specified number of spaces.

Syntax

Visual Basic (Declaration)
Public Shared Function Space( _
   ByVal number As Integer _
) As String
C#
public static string Space(
   int number
)

Parameters

number
Required. Integer expression. The number of spaces you want in the string.

Return Value

Returns a string consisting of the specified number of spaces.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Split Method

[image]
ActiveReports 19 .NET Edition
Split Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Split Method

expression
Required. String expression containing substrings and delimiters.
delimiter
Optional. Any single character used to identify substring limits. If delimiter is omitted, the space character (" ") is assumed to be the delimiter.
limit
Optional. Maximum number of substrings into which the input string should be split. The default, –1, indicates that the input string should be split at every occurrence of the delimiter string.
compare
Optional. Numeric value indicating the comparison to use when evaluating substrings. See "Settings" for values.

Glossary Item Box

Returns a zero-based, one-dimensional array containing a specified number of substrings.

Syntax

Visual Basic (Declaration)
Public Shared Function Split( _
   ByVal expression As String, _
   Optional ByVal delimiter As String, _
   Optional ByVal limit As Integer, _
   Optional ByVal compare As CompareMethod _
) As String()
C#
public static string[] Split(
   string expression,
   string delimiter,
   int limit,
   CompareMethod compare
)

Parameters

expression
Required. String expression containing substrings and delimiters.
delimiter
Optional. Any single character used to identify substring limits. If delimiter is omitted, the space character (" ") is assumed to be the delimiter.
limit
Optional. Maximum number of substrings into which the input string should be split. The default, –1, indicates that the input string should be split at every occurrence of the delimiter string.
compare
Optional. Numeric value indicating the comparison to use when evaluating substrings. See "Settings" for values.

Return Value

String array. If expression is a zero-length string (""), Split returns a single-element array containing a zero-length string. If delimiter is a zero-length string, or if it does not appear anywhere in expression, Split returns a single-element array containing the entire expression string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrComp Method

[image]
ActiveReports 19 .NET Edition
StrComp Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrComp Method

string1
Required. Any valid String expression.
string2
Required. Any valid String expression.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Glossary Item Box

Returns -1, 0, or 1, based on the result of a string comparison.

Syntax

Visual Basic (Declaration)
Public Shared Function StrComp( _
   ByVal string1 As String, _
   ByVal string2 As String, _
   Optional ByVal compare As CompareMethod _
) As Integer
C#
public static int StrComp(
   string string1,
   string string2,
   CompareMethod compare
)

Parameters

string1
Required. Any valid String expression.
string2
Required. Any valid String expression.
compare
Optional. Specifies the type of string comparison. If compare is omitted, the Option Compare setting determines the type of comparison.

Return Value

If string1 sorts ahead of string2, StrComp returns -1. If string1 is equal to string2, StrComp returns 0. If string1 sorts after string2, StrComp returns 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrConv Method

[image]
ActiveReports 19 .NET Edition
StrConv Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrConv Method

str
Required. String expression to be converted.
conversion
Required. VbStrConv Enumeration member. The enumeration value specifying the type of conversion to perform.
localeID
Optional. The LocaleID value, if different from the system LocaleID value. (The system LocaleID value is the default.)

Glossary Item Box

[NotImplemented] Returns a string converted as specified. This method called kernel32.dll.

Syntax

Visual Basic (Declaration)
Public Shared Function StrConv( _
   ByVal str As String, _
   ByVal conversion As VbStrConv, _
   Optional ByVal localeID As Integer _
) As String
C#
public static string StrConv(
   string str,
   VbStrConv conversion,
   int localeID
)

Parameters

str
Required. String expression to be converted.
conversion
Required. VbStrConv Enumeration member. The enumeration value specifying the type of conversion to perform.
localeID
Optional. The LocaleID value, if different from the system LocaleID value. (The system LocaleID value is the default.)

Return Value

Returns a string converted as specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrDup Method

[image]
ActiveReports 19 .NET Edition
StrDup Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrDup Method

Glossary Item Box

Returns a string or object consisting of the specified character repeated the specified number of times.

Overload List

Overload | Description
StrDup(Int32,Object) | Returns a string or object consisting of the specified character repeated the specified number of times.
StrDup(Int32,Char) | Returns a string or object consisting of the specified character repeated the specified number of times.
StrDup(Int32,String) | Returns a string or object consisting of the specified character repeated the specified number of times.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrDup(Int32,Object) Method

[image]
ActiveReports 19 .NET Edition
StrDup(Int32,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > StrDup Method : StrDup(Int32,Object) Method

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Glossary Item Box

Returns a string or object consisting of the specified character repeated the specified number of times.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function StrDup( _
   ByVal number As Integer, _
   ByVal character As Object _
) As Object
C#
public static object StrDup(
   int number,
   object character
)

Parameters

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Return Value

Returns a string or object consisting of the specified character repeated the specified number of times.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


StrDup(Int32,Char) Method

[image]
ActiveReports 19 .NET Edition
StrDup(Int32,Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > StrDup Method : StrDup(Int32,Char) Method

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Glossary Item Box

Returns a string or object consisting of the specified character repeated the specified number of times.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function StrDup( _
   ByVal number As Integer, _
   ByVal character As Char _
) As String
C#
public static string StrDup(
   int number,
   char character
)

Parameters

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Return Value

Returns a string or object consisting of the specified character repeated the specified number of times.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


StrDup(Int32,String) Method

[image]
ActiveReports 19 .NET Edition
StrDup(Int32,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > StrDup Method : StrDup(Int32,String) Method

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Glossary Item Box

Returns a string or object consisting of the specified character repeated the specified number of times.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function StrDup( _
   ByVal number As Integer, _
   ByVal character As String _
) As String
C#
public static string StrDup(
   int number,
   string character
)

Parameters

number
Required. Integer expression. The length to the string to be returned.
character
Required. Any valid Char, String, or Object expression. Only the first character of the expression will be used. If Character is of type Object, it must contain either a Char or a String value.

Return Value

Returns a string or object consisting of the specified character repeated the specified number of times.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


StrLike Method

[image]
ActiveReports 19 .NET Edition
StrLike Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrLike Method

source
Required. Any String expression.
pattern
Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).
compareOption
Specifies how to compare strings to patterns, according to the CompareMethod Enumeration. Can be vbBinaryCompare for binary comparison or vbTextCompare for comparison based on a case-insensitive text sort order determined by your system's LocaleID value.

Glossary Item Box

Compares the parameters and and returns the same results as the Like operator.

Syntax

Visual Basic (Declaration)
Public Shared Function StrLike( _
   ByVal source As String, _
   ByVal pattern As String, _
   ByVal compareOption As CompareMethod _
) As Boolean
C#
public static bool StrLike(
   string source,
   string pattern,
   CompareMethod compareOption
)

Parameters

source
Required. Any String expression.
pattern
Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).
compareOption
Specifies how to compare strings to patterns, according to the CompareMethod Enumeration. Can be vbBinaryCompare for binary comparison or vbTextCompare for comparison based on a case-insensitive text sort order determined by your system's LocaleID value.

Return Value

A Boolean value indicating whether or not the string satisfies the pattern. If the value in string satisfies the pattern contained in pattern, result is True. If the string does not satisfy the pattern, result is False. If both string and pattern are empty strings, the result is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrLikeBinary Method

[image]
ActiveReports 19 .NET Edition
StrLikeBinary Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrLikeBinary Method

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Glossary Item Box

Compares the parameters and and returns the same results as the Like operator, using binary comparison.

Syntax

Visual Basic (Declaration)
Public Shared Function StrLikeBinary( _
   ByVal source As String, _
   ByVal pattern As String _
) As Boolean
C#
public static bool StrLikeBinary(
   string source,
   string pattern
)

Parameters

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Return Value

A Boolean value indicating whether or not the string satisfies the pattern. If the value in string satisfies the pattern contained in pattern, result is True. If the string does not satisfy the pattern, result is False. If both string and pattern are empty strings, the result is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrLikeText Method

[image]
ActiveReports 19 .NET Edition
StrLikeText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrLikeText Method

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Glossary Item Box

Compares the parameters and and returns the same results as the Like operator, using text comparison.

Syntax

Visual Basic (Declaration)
Public Shared Function StrLikeText( _
   ByVal source As String, _
   ByVal pattern As String _
) As Boolean
C#
public static bool StrLikeText(
   string source,
   string pattern
)

Parameters

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Return Value

A Boolean value indicating whether or not the string satisfies the pattern. If the value in string satisfies the pattern contained in pattern, result is True. If the string does not satisfy the pattern, result is False. If both string and pattern are empty strings, the result is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


StrReverse Method

[image]
ActiveReports 19 .NET Edition
StrReverse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : StrReverse Method

expression
Required. String expression whose characters are to be reversed. If expression is a zero-length string (""), a zero-length string is returned.

Glossary Item Box

Returns a string in which the character order of a specified string is reversed.

Syntax

Visual Basic (Declaration)
Public Shared Function StrReverse( _
   ByVal expression As String _
) As String
C#
public static string StrReverse(
   string expression
)

Parameters

expression
Required. String expression whose characters are to be reversed. If expression is a zero-length string (""), a zero-length string is returned.

Return Value

Returns a string in which the character order of a specified string is reversed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


Trim Method

[image]
ActiveReports 19 .NET Edition
Trim Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : Trim Method

str
Required. Any valid String expression.

Glossary Item Box

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Syntax

Visual Basic (Declaration)
Public Shared Function Trim( _
   ByVal str As String _
) As String
C#
public static string Trim(
   string str
)

Parameters

str
Required. Any valid String expression.

Return Value

Returns a string containing a copy of a specified string with no leading spaces (LTrim), no trailing spaces (RTrim), or no leading or trailing spaces (Trim).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


UCase Method

[image]
ActiveReports 19 .NET Edition
UCase Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class : UCase Method

Glossary Item Box

Returns a string or character containing the specified string converted to uppercase.

Overload List

Overload | Description
UCase(String) | Returns a string or character containing the specified string converted to uppercase.
UCase(Char) | Returns a string or character containing the specified string converted to uppercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members


UCase(String) Method

[image]
ActiveReports 19 .NET Edition
UCase(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > UCase Method : UCase(String) Method

value
Required. Any valid String or Char expression.

Glossary Item Box

Returns a string or character containing the specified string converted to uppercase.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function UCase( _
   ByVal value As String _
) As String
C#
public static string UCase(
   string value
)

Parameters

value
Required. Any valid String or Char expression.

Return Value

Returns a string or character containing the specified string converted to uppercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


UCase(Char) Method

[image]
ActiveReports 19 .NET Edition
UCase(Char) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Strings Class > UCase Method : UCase(Char) Method

value
Required. Any valid String or Char expression.

Glossary Item Box

Returns a string or character containing the specified string converted to uppercase.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function UCase( _
   ByVal value As Char _
) As Char
C#
public static char UCase(
   char value
)

Parameters

value
Required. Any valid String or Char expression.

Return Value

Returns a string or character containing the specified string converted to uppercase.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Strings Class
Strings Members
Overload List


StringType Class

[image]
ActiveReports 19 .NET Edition
StringType Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : StringType Class

Glossary Item Box

Represents conversions to String

Object Model

StringType Class

Syntax

Visual Basic (Declaration)
Public Class StringType
C#
public class StringType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.StringType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringType Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


StringType Class Members

[image]
ActiveReports 19 .NET Edition
StringType Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : StringType Class

Glossary Item Box

The following tables list the members exposed by StringType.

Public Constructors

 | Name | Description
Public Constructor | StringType Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromChar | Converts a System.Char value to a System.String.
static (Shared in Visual Basic) | StrLike | Compares the parameters and and returns the same results as the Like operator.
static (Shared in Visual Basic) | StrLikeBinary | Compares the parameters and and returns the same results as the Like operator, using binary comparison.
Top

See Also

Reference

StringType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


StringType Constructor

[image]
ActiveReports 19 .NET Edition
StringType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > StringType Class : StringType Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StringType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringType Class
StringType Members


StringType Class Methods

[image]
ActiveReports 19 .NET Edition
StringType Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : StringType Class

Glossary Item Box

For a list of all members of this type, see StringType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromChar | Converts a System.Char value to a System.String.
static (Shared in Visual Basic) | StrLike | Compares the parameters and and returns the same results as the Like operator.
static (Shared in Visual Basic) | StrLikeBinary | Compares the parameters and and returns the same results as the Like operator, using binary comparison.
Top

See Also

Reference

StringType Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FromChar Method

[image]
ActiveReports 19 .NET Edition
FromChar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > StringType Class : FromChar Method

value
The Char value to convert.

Glossary Item Box

Converts a System.Char value to a System.String.

Syntax

Visual Basic (Declaration)
Public Shared Function FromChar( _
   ByVal value As Char _
) As String
C#
public static string FromChar(
   char value
)

Parameters

value
The Char value to convert.

Return Value

The String representation of the Char value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringType Class
StringType Members


StrLike Method

[image]
ActiveReports 19 .NET Edition
StrLike Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > StringType Class : StrLike Method

source
Required. Any String expression.
pattern
Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).
compareOption
Specifies how to compare strings to patterns, according to the CompareMethod Enumeration. Can be vbBinaryCompare for binary comparison or vbTextCompare for comparison based on a case-insensitive text sort order determined by your system's LocaleID value.

Glossary Item Box

Compares the parameters and and returns the same results as the Like operator.

Syntax

Visual Basic (Declaration)
Public Shared Function StrLike( _
   ByVal source As String, _
   ByVal pattern As String, _
   ByVal compareOption As CompareMethod _
) As Boolean
C#
public static bool StrLike(
   string source,
   string pattern,
   CompareMethod compareOption
)

Parameters

source
Required. Any String expression.
pattern
Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).
compareOption
Specifies how to compare strings to patterns, according to the CompareMethod Enumeration. Can be vbBinaryCompare for binary comparison or vbTextCompare for comparison based on a case-insensitive text sort order determined by your system's LocaleID value.

Return Value

A Boolean value indicating whether or not the string satisfies the pattern. If the value in string satisfies the pattern contained in pattern, result is True. If the string does not satisfy the pattern, result is False. If both string and pattern are empty strings, the result is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringType Class
StringType Members


StrLikeBinary Method

[image]
ActiveReports 19 .NET Edition
StrLikeBinary Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > StringType Class : StrLikeBinary Method

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Glossary Item Box

Compares the parameters and and returns the same results as the Like operator, using binary comparison.

Syntax

Visual Basic (Declaration)
Public Shared Function StrLikeBinary( _
   ByVal source As String, _
   ByVal pattern As String _
) As Boolean
C#
public static bool StrLikeBinary(
   string source,
   string pattern
)

Parameters

source
Required. Any String expression.
pattern
Required. Any String expression conforming to the pattern-matching conventions described in Like Operator (Visual Basic).

Return Value

A Boolean value indicating whether or not the string satisfies the pattern. If the value in string satisfies the pattern contained in pattern, result is True. If the string does not satisfy the pattern, result is False. If both string and pattern are empty strings, the result is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringType Class
StringType Members


VBMath Class

[image]
ActiveReports 19 .NET Edition
VBMath Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : VBMath Class

Glossary Item Box

The VbMath module contains procedures used to perform mathematical operations.

Object Model

VBMath Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class VBMath
C#
public static class VBMath

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.VBMath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VBMath Members
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


VBMath Class Members

[image]
ActiveReports 19 .NET Edition
VBMath Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : VBMath Class

Glossary Item Box

The following tables list the members exposed by VBMath.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Rnd | Overloaded. Returns a random number of type float.
Top

See Also

Reference

VBMath Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


VBMath Class Methods

[image]
ActiveReports 19 .NET Edition
VBMath Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : VBMath Class

Glossary Item Box

For a list of all members of this type, see VBMath members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Rnd | Overloaded. Returns a random number of type float.
Top

See Also

Reference

VBMath Class
GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Rnd Method

[image]
ActiveReports 19 .NET Edition
Rnd Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > VBMath Class : Rnd Method

Glossary Item Box

Returns a random number of type float.

Overload List

Overload | Description
Rnd() | Returns a random number of type float.
Rnd(Single) | Returns a random number of type Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VBMath Class
VBMath Members


Rnd() Method

[image]
ActiveReports 19 .NET Edition
Rnd() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > VBMath Class > Rnd Method : Rnd() Method

Glossary Item Box

Returns a random number of type float.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Rnd() As Single
C#
public static float Rnd()

Return Value

Returns a random number of type float.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VBMath Class
VBMath Members
Overload List


Rnd(Single) Method

[image]
ActiveReports 19 .NET Edition
Rnd(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > VBMath Class > Rnd Method : Rnd(Single) Method

number
Optional. A Single value or any valid Single expression.

Glossary Item Box

Returns a random number of type Single.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Rnd( _
   ByVal number As Single _
) As Single
C#
public static float Rnd(
   float number
)

Parameters

number
Optional. A Single value or any valid Single expression.

Return Value

If number is less than zero, Rnd generates the same number every time, using number as the seed. If number is greater than zero, Rnd generates the next random number in the sequence. If number is equal to zero, Rnd generates the most recently generated number. If number is not supplied, Rnd generates the next random number in the sequence.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VBMath Class
VBMath Members
Overload List


AppWinStyle Enumeration

[image]
ActiveReports 19 .NET Edition
AppWinStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : AppWinStyle Enumeration

Glossary Item Box

Indicates the window style to use for the invoked program when calling the Shell function.

Syntax

Visual Basic (Declaration)
Public Enum AppWinStyle
   Inherits System.Enum
C#
public enum AppWinStyle : System.Enum

Members

Member | Description
Hide | Window is hidden and focus is passed to the hidden window. This member is equivalent to the Visual Basic constant vbHide.
MaximizedFocus | Window is maximized with focus. This member is equivalent to the Visual Basic constant vbMaximizedFocus.
MinimizedFocus | Window is displayed as an icon with focus. This member is equivalent to the Visual Basic constant vbMinimizedFocus.
MinimizedNoFocus | Window is displayed as an icon. The currently active window remains active. This member is equivalent to the Visual Basic constant vbMinimizedNoFocus.
NormalFocus | Window has focus and is restored to its original size and position. This member is equivalent to the Visual Basic constant vbNormalFocus.
NormalNoFocus | Window is restored to its most recent size and position. The currently active window remains active. This member is equivalent to the Visual Basic constant vbNormalNoFocus.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.AppWinStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


CallType Enumeration

[image]
ActiveReports 19 .NET Edition
CallType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : CallType Enumeration

Glossary Item Box

Indicates the type of procedure being invoked when calling the CallByName function.

Syntax

Visual Basic (Declaration)
Public Enum CallType
   Inherits System.Enum
C#
public enum CallType : System.Enum

Members

Member | Description
Get | A property value is being retrieved. This member is equivalent to the Visual Basic constant vbGet.
Let | An Object property value is being determined. This member is equivalent to the Visual Basic constant vbLet.
Method | A method is being invoked. This member is equivalent to the Visual Basic constant vbMethod.
Set | A property value is being determined. This member is equivalent to the Visual Basic constant vbSet.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.CallType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


CompareMethod Enumeration

[image]
ActiveReports 19 .NET Edition
CompareMethod Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : CompareMethod Enumeration

Glossary Item Box

Indicates how to compare strings when calling comparison functions.

Syntax

Visual Basic (Declaration)
Public Enum CompareMethod
   Inherits System.Enum
C#
public enum CompareMethod : System.Enum

Members

Member | Description
Binary | Performs a binary comparison. This member is equivalent to the Visual Basic constant vbBinaryCompare.
Text | Performs a textual comparison. This member is equivalent to the Visual Basic constant vbTextCompare.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.CompareMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateFormat Enumeration

[image]
ActiveReports 19 .NET Edition
DateFormat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateFormat Enumeration

Glossary Item Box

Indicates how to display dates when calling the FormatDateTime function.

Syntax

Visual Basic (Declaration)
Public Enum DateFormat
   Inherits System.Enum
C#
public enum DateFormat : System.Enum

Members

Member | Description
GeneralDate | For real numbers, displays a date and time. If the number has no fractional part, displays only a date. If the number has no integer part, displays time only. Date and time display is determined by your computer's regional settings. This member is equivalent to the Visual Basic constant vbGeneralDate.
LongDate | Displays a date using the long-date format specified in your computer's regional settings. This member is equivalent to the Visual Basic constant vbLongDate.
LongTime | Displays a time using the long-time format specified in your computer's regional settings. This member is equivalent to the Visual Basic constant vbLongTime.
ShortDate | Displays a date using the short-date format specified in your computer's regional settings. This member is equivalent to the Visual Basic constant vbShortDate.
ShortTime | Displays a time using the short-time format specified in your computer's regional settings. This member is equivalent to the Visual Basic constant vbShortTime.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.DateFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DateInterval Enumeration

[image]
ActiveReports 19 .NET Edition
DateInterval Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DateInterval Enumeration

Glossary Item Box

Indicates how to determine and format date intervals when calling date-related functions.

Syntax

Visual Basic (Declaration)
Public Enum DateInterval
   Inherits System.Enum
C#
public enum DateInterval : System.Enum

Members

Member | Description
Day | Day of month (1 through 31)
DayOfYear | Day of year (1 through 366)
Hour | Hour (1 through 24)
Minute | Minute (1 through 60)
Month | Month (1 through 12)
Quarter | Quarter of year (1 through 4)
Second | Second (1 through 60)
Weekday | Day of week (1 through 7)
WeekOfYear | Week of year (1 through 53)
Year | Year

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.DateInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


DueDate Enumeration

[image]
ActiveReports 19 .NET Edition
DueDate Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : DueDate Enumeration

Glossary Item Box

References the DueDate enumeration when reflecting financial methods.

Syntax

Visual Basic (Declaration)
Public Enum DueDate
   Inherits System.Enum
C#
public enum DueDate : System.Enum

Members

Member | Description
BegOfPeriod | Begin of period
EndOfPeriod | End of period

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.DueDate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FileAttribute Enumeration

[image]
ActiveReports 19 .NET Edition
FileAttribute Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : FileAttribute Enumeration

Glossary Item Box

Indicates the file attributes to use when calling file-access functions.

Syntax

Visual Basic (Declaration)
Public Enum FileAttribute
   Inherits System.Enum
C#
public enum FileAttribute : System.Enum

Members

Member | Description
Archive | File has changed since last backup. This member is equivalent to the Visual Basic constant vbArchive.
Directory | Directory or folder. This member is equivalent to the Visual Basic constant vbDirectory.
Hidden | Hidden. This member is equivalent to the Visual Basic constant vbHidden.
Normal | Normal (default for Dir and SetAttr). No special characteristics apply to this file. This member is equivalent to the Visual Basic constant vbNormal.
ReadOnly | Read only. This member is equivalent to the Visual Basic constant vbReadOnly.
System | System file. This member is equivalent to the Visual Basic constant vbSystem.
Volume | Volume label. This attribute is not valid when used with SetAttr. This member is equivalent to the Visual Basic constant vbVolume.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.FileAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FirstDayOfWeek Enumeration

[image]
ActiveReports 19 .NET Edition
FirstDayOfWeek Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : FirstDayOfWeek Enumeration

Glossary Item Box

Indicates the first day of the week to use when calling date-related functions.

Syntax

Visual Basic (Declaration)
Public Enum FirstDayOfWeek
   Inherits System.Enum
C#
public enum FirstDayOfWeek : System.Enum

Members

Member | Description
Friday | Friday. This member is equivalent to the Visual Basic constant vbFriday.
Monday | Monday. This member is equivalent to the Visual Basic constant vbMonday.
Saturday | Saturday. This member is equivalent to the Visual Basic constant vbSaturday.
Sunday | Sunday (default). This member is equivalent to the Visual Basic constant vbSunday.
System | The first day of the week as specified in your system settings. This member is equivalent to the Visual Basic constant vbUseSystemDayOfWeek.
Thursday | Thursday. This member is equivalent to the Visual Basic constant vbThursday.
Tuesday | Tuesday. This member is equivalent to the Visual Basic constant vbTuesday.
Wednesday | Wednesday. This member is equivalent to the Visual Basic constant vbWednesday.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.FirstDayOfWeek

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


FirstWeekOfYear Enumeration

[image]
ActiveReports 19 .NET Edition
FirstWeekOfYear Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : FirstWeekOfYear Enumeration

Glossary Item Box

Indicates the first week of the year to use when calling date-related functions.

Syntax

Visual Basic (Declaration)
Public Enum FirstWeekOfYear
   Inherits System.Enum
C#
public enum FirstWeekOfYear : System.Enum

Members

Member | Description
FirstFourDays | The first week that has at least four days in the new year. This member is equivalent to the Visual Basic constant vbFirstFourDays.
FirstFullWeek | The first full week of the year. This member is equivalent to the Visual Basic constant vbFirstFullWeek.
Jan1 | The week in which January 1 occurs (default). This member is equivalent to the Visual Basic constant vbFirstJan1.
System | The day of the week specified in your system settings as the first day of the week. This member is equivalent to the Visual Basic constant vbUseSystem.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.FirstWeekOfYear

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


MsgBoxResult Enumeration

[image]
ActiveReports 19 .NET Edition
MsgBoxResult Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : MsgBoxResult Enumeration

Glossary Item Box

Indicates which button was pressed on a message box, returned by the MsgBox function.

Syntax

Visual Basic (Declaration)
Public Enum MsgBoxResult
   Inherits System.Enum
C#
public enum MsgBoxResult : System.Enum

Members

Member | Description
Abort | Abort button was pressed. This member is equivalent to the Visual Basic constant vbAbort.
Cancel | Cancel button was pressed. This member is equivalent to the Visual Basic constant vbCancel.
Ignore | Ignore button was pressed. This member is equivalent to the Visual Basic constant vbIgnore.
No | No button was pressed. This member is equivalent to the Visual Basic constant vbNo.
Ok | OK button was pressed. This member is equivalent to the Visual Basic constant vbOK.
Retry | Retry button was pressed. This member is equivalent to the Visual Basic constant vbRetry.
Yes | Yes button was pressed. This member is equivalent to the Visual Basic constant vbYes.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.MsgBoxResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


MsgBoxStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MsgBoxStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : MsgBoxStyle Enumeration

Glossary Item Box

Indicates which buttons to display when calling the MsgBox function.

Syntax

Visual Basic (Declaration)
Public Enum MsgBoxStyle
   Inherits System.Enum
C#
public enum MsgBoxStyle : System.Enum

Members

Member | Description
AbortRetryIgnore | Abort, Retry, and Ignore buttons. This member is equivalent to the Visual Basic constant vbAbortRetryIgnore.
ApplicationModal | Application modal message box. This member is equivalent to the Visual Basic constant vbApplicationModal.
Critical | Critical message. This member is equivalent to the Visual Basic constant vbCritical.
DefaultButton1 | First button is default. This member is equivalent to the Visual Basic constant vbDefaultButton1.
DefaultButton2 | Second button is default. This member is equivalent to the Visual Basic constant vbDefaultButton2.
DefaultButton3 | Third button is default. This member is equivalent to the Visual Basic constant vbDefaultButton3.
Exclamation | Warning message. This member is equivalent to the Visual Basic constant vbExclamation.
Information | Information message. This member is equivalent to the Visual Basic constant vbInformation.
MsgBoxHelp | Help text. This member is equivalent to the Visual Basic constant vbMsgBoxHelp.
MsgBoxRight | Right-aligned text. This member is equivalent to the Visual Basic constant vbMsgBoxRight.
MsgBoxRtlReading | Right-to-left reading text (Hebrew and Arabic systems). This member is equivalent to the Visual Basic constant vbMsgBoxRtlReading.
MsgBoxSetForeground | Foreground message box window. This member is equivalent to the Visual Basic constant vbMsgBoxSetForeground.
OkCancel | OK and Cancel buttons. This member is equivalent to the Visual Basic constant vbOKCancel.
OkOnly | OK button only (default). This member is equivalent to the Visual Basic constant vbOKOnly.
Question | Warning query. This member is equivalent to the Visual Basic constant vbQuestion.
RetryCancel | Retry and Cancel buttons. This member is equivalent to the Visual Basic constant vbRetryCancel.
SystemModal | System modal message box. This member is equivalent to the Visual Basic constant vbSystemModal.
YesNo | Yes and No buttons. This member is equivalent to the Visual Basic constant vbYesNo.
YesNoCancel | Yes, No, and Cancel buttons. This member is equivalent to the Visual Basic constant vbYesNoCancel.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.MsgBoxStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Strings.FormatType Enumeration

[image]
ActiveReports 19 .NET Edition
Strings.FormatType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : Strings.FormatType Enumeration

Glossary Item Box

Represent format type

Syntax

Visual Basic (Declaration)
Public Enum Strings.FormatType
   Inherits System.Enum
C#
public enum Strings.FormatType : System.Enum

Members

Member | Description
Currency | Currency
Number | Number
Percent | Percent

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.Strings.FormatType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


TriState Enumeration

[image]
ActiveReports 19 .NET Edition
TriState Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : TriState Enumeration

Glossary Item Box

Indicates a Boolean value or whether the default should be used when calling number-formatting functions.

Syntax

Visual Basic (Declaration)
Public Enum TriState
   Inherits System.Enum
C#
public enum TriState : System.Enum

Members

Member | Description
False | False. The numeric value of this member is 0.
True | True. The numeric value of this member is -1.
UseDefault | Default setting. The numeric value of this member is -2.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.TriState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


VariantType Enumeration

[image]
ActiveReports 19 .NET Edition
VariantType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : VariantType Enumeration

Glossary Item Box

Indicates the type of a variant object, returned by the VarType function.

Syntax

Visual Basic (Declaration)
Public Enum VariantType
   Inherits System.Enum
C#
public enum VariantType : System.Enum

Members

Member | Description
Array | Array. This member is equivalent to the Visual Basic constant vbArray.
Boolean | Boolean. (True or False.) This member is equivalent to the Visual Basic constant vbBoolean.
Byte | Byte. (0 through 255.) This member is equivalent to the Visual Basic constant vbByte.
Char | Char. (0 through 65535.) This member is equivalent to the Visual Basic constant vbChar.
Currency | Currency. This member is equivalent to the Visual Basic constant vbCurrency.
DataObject | DataObject.
Date | Date. (0:00:00 on January 1, 0001 through 11:59:59 PM on December 31, 9999.) This member is equivalent to the Visual Basic constant vbDate.
Decimal | Decimal. (0 through +/-79,228,162,514,264,337,593,543,950,335 with no decimal point; 0 through +/-7.9228162514264337593543950335 with 28 places to the right of the decimal; smallest non-zero number is +/-0.0000000000000000000000000001.) This member is equivalent to the Visual Basic constant vbDecimal.
Double | Double. (-1.79769313486231E+308 through -4.94065645841247E-324 for negative values; 4.94065645841247E-324 through 1.79769313486231E+308 for positive values.) This member is equivalent to the Visual Basic constant vbDouble.
Empty | Null reference. This member is equivalent to the Visual Basic constant vbEmpty.
Error | Represents a general error identifier. This constant can be used to identify error types when handling exceptions.
Integer | Integer. (-2,147,483,648 through 2,147,483,647.) This member is equivalent to the Visual Basic constant vbInteger.
Long | Long. (-9,223,372,036,854,775,808 through 9,223,372,036,854,775,807.) This member is equivalent to the Visual Basic constant vbLong.
Null | Null object. This member is equivalent to the Visual Basic constant vbNull.
Object | Any type can be stored in a variable of type Object. This member is equivalent to the Visual Basic constant vbObject.
Short | Short. (-32,768 through 32,767.)
Single | Single. (-3.402823E+38 through -1.401298E-45 for negative values; 1.401298E-45 through 3.402823E+38 for positive values.) This member is equivalent to the Visual Basic constant vbSingle.
String | String. (0 to approximately 2 billion Unicode characters.) This member is equivalent to the Visual Basic constant vbString.
UserDefinedType | User-defined type. Each member of the structure has a range determined by its data type and independent of the ranges of the other members. This member is equivalent to the Visual Basic constant vbUserDefinedType.
Variant | Variant. This member is equivalent to the Visual Basic constant vbVariant.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.VariantType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


VbStrConv Enumeration

[image]
ActiveReports 19 .NET Edition
VbStrConv Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace : VbStrConv Enumeration

Glossary Item Box

Indicates which type of conversion to perform when calling the StrConv function.

Syntax

Visual Basic (Declaration)
Public Enum VbStrConv
   Inherits System.Enum
C#
public enum VbStrConv : System.Enum

Members

Member | Description
Hiragana | Converts Katakana characters in the string to Hiragana characters. Applies to Japanese locale only. This member is equivalent to the Visual Basic constant vbHiragana.
Katakana | Converts Hiragana characters in the string to Katakana characters. Applies to Japanese locale only. This member is equivalent to the Visual Basic constant vbKatakana.
LinguisticCasing | Converts the string from file system rules for casing to linguistic rules. This member is equivalent to the Visual Basic constant vbLinguisticCasing.
Lowercase | Converts the string to lowercase characters. This member is equivalent to the Visual Basic constant vbLowerCase.
Narrow | Converts wide (double-byte) characters in the string to narrow (single-byte) characters. Applies to Asian locales. This member is equivalent to the Visual Basic constant vbNarrow.
None | Performs no conversion.
ProperCase | Converts the first letter of every word in the string to uppercase. This member is equivalent to the Visual Basic constant vbProperCase.
SimplifiedChinese | Converts the string to Simplified Chinese characters. This member is equivalent to the Visual Basic constant vbSimplifiedChinese.
TraditionalChinese | Converts the string to Traditional Chinese characters. This member is equivalent to the Visual Basic constant vbTraditionalChinese.
Uppercase | Converts the string to uppercase characters. This member is equivalent to the Visual Basic constant vbUpperCase.
Wide | Converts narrow (single-byte) characters in the string to wide (double-byte) characters. Applies to Asian locales. This member is equivalent to the Visual Basic constant vbWide.

Remarks

This type should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Enterprise.Data.VisualBasicReplacement.VbStrConv

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace


Border Class

[image]
ActiveReports 19 .NET Edition
Border Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

Represents the border.

Object Model

Border Class

Syntax

Visual Basic (Declaration)
Public Class Border
C#
public class Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Members
GrapeCity.ActiveReports Namespace


Border Class Members

[image]
ActiveReports 19 .NET Edition
Border Class Members
See Also Fields Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

The following tables list the members exposed by Border.

Public Constructors

 | Name | Description
Public Constructor | Border Constructor | Initializes a new instance of the Border class.
Top

Public Fields

 | Name | Description
Public Field | ShadowLineWidth | The constant that specifies the width used to draw the shadow line.
Top

Public Properties

 | Name | Description
Public Property | BottomColor | Gets or sets the color of the bottom edge.
Public Property | BottomStyle | Gets or sets the style of the bottom border line.
Public Property | Color | Gets or sets the color for all sides.
Public Property | LeftColor | Gets or sets the color of the left edge.
Public Property | LeftStyle | Gets or sets the style of the left border line.
Public Property | LineStyleOfEdges | Gets the line style of edges.
Public Property | RightColor | Gets or sets the color of the right edge.
Public Property | RightStyle | Gets or sets the style of the right border line.
Public Property | Shadow | Gets or sets a value indicating whether this Border is shadow.
Public Property | Style | Gets or sets the style for all border lines.
Public Property | TopColor | Gets or sets the color of the top edge.
Public Property | TopStyle | Gets or sets the style of the top border line.
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | ColorOfEdges | Gets color of the edge at the given index.
Public Method | CopyTo | Copies this border attributes to the specified border.
static (Shared in Visual Basic) | GetBorderLineWidth | Gets width of the border line.
Public Method | GetMargins | Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.
Public Method | GetShadowLinePosition | Gets the position of the shadow line.
Public Method | Inflate | Overloaded. Inflates the boundaries according to the mergins.
Public Method | InflateInches | Inflates the boundaries according to the mergins in inch units.
Public Method | IsEmpty | Gets whether the current instance is empty.
Public Method | MarginsInPoints | Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.
Public Method | PenStyle | Gets the line style for the pen using the specified edge.
Public Method | Read | Reads properties from a System.IO.BinaryReader.
Public Method | ReadXml | Reads data from the specified System.Xml.XmlNode.
Public Method | Render | Renders the border around the specified rectangle.
Public Method | ToString | Returns a string that represents the current object.
Public Method | Write | Writing the current values using a specified System.IO.BinaryWriter.
Public Method | WriteXml | Writes the current data to the specified System.Xml.XmlElement.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | The event occurs when the property is changed.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Border Constructor

[image]
ActiveReports 19 .NET Edition
Border Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Border Constructor

Glossary Item Box

Initializes a new instance of the Border class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Border()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Methods

[image]
ActiveReports 19 .NET Edition
Border Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | ColorOfEdges | Gets color of the edge at the given index.
Public Method | CopyTo | Copies this border attributes to the specified border.
static (Shared in Visual Basic) | GetBorderLineWidth | Gets width of the border line.
Public Method | GetMargins | Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.
Public Method | GetShadowLinePosition | Gets the position of the shadow line.
Public Method | Inflate | Overloaded. Inflates the boundaries according to the mergins.
Public Method | InflateInches | Inflates the boundaries according to the mergins in inch units.
Public Method | IsEmpty | Gets whether the current instance is empty.
Public Method | MarginsInPoints | Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.
Public Method | PenStyle | Gets the line style for the pen using the specified edge.
Public Method | Read | Reads properties from a System.IO.BinaryReader.
Public Method | ReadXml | Reads data from the specified System.Xml.XmlNode.
Public Method | Render | Renders the border around the specified rectangle.
Public Method | ToString | Returns a string that represents the current object.
Public Method | Write | Writing the current values using a specified System.IO.BinaryWriter.
Public Method | WriteXml | Writes the current data to the specified System.Xml.XmlElement.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Border
C#
public Border Clone()

Return Value

Returns the cloned Border instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


ColorOfEdges Method

[image]
ActiveReports 19 .NET Edition
ColorOfEdges Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : ColorOfEdges Method

index
The index in the colors collection. For a list of valid values, see here: BorderEdges

Glossary Item Box

Gets color of the edge at the given index.

Syntax

Visual Basic (Declaration)
Public Function ColorOfEdges( _
   ByVal index As Integer _
) As Color
C#
public Color ColorOfEdges(
   int index
)

Parameters

index
The index in the colors collection. For a list of valid values, see here: BorderEdges

Return Value

The edge color.

Example

C# Copy Code
border.Color = Color.Yellow;
Color edgeColor;
//All of the values below should be equal to the color yellow.
edgeColor = border.ColorOfEdges((int)BorderEdges.Left);
edgeColor = border.ColorOfEdges((int)BorderEdges.Right);
edgeColor = border.ColorOfEdges((int)BorderEdges.Bottom);
edgeColor = border.ColorOfEdges((int)BorderEdges.Top);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : CopyTo Method

border
Specified border.

Glossary Item Box

Copies this border attributes to the specified border.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal border As Border _
)
C#
public void CopyTo(
   Border border
)

Parameters

border
Specified border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


GetBorderLineWidth Method

[image]
ActiveReports 19 .NET Edition
GetBorderLineWidth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : GetBorderLineWidth Method

borderLineStyle
The Border line style.
pageScale
The page scale.

Glossary Item Box

Gets width of the border line.

Syntax

Visual Basic (Declaration)
Public Shared Function GetBorderLineWidth( _
   ByVal borderLineStyle As BorderLineStyle, _
   ByVal pageScale As Single _
) As Single
C#
public static float GetBorderLineWidth(
   BorderLineStyle borderLineStyle,
   float pageScale
)

Parameters

borderLineStyle
The Border line style.
pageScale
The page scale.

Return Value

Returns the width of border line.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


GetMargins Method

[image]
ActiveReports 19 .NET Edition
GetMargins Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : GetMargins Method

pageScale
The page scale value.

Glossary Item Box

Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.

Syntax

Visual Basic (Declaration)
Public Function GetMargins( _
   ByVal pageScale As Single _
) As Border.BorderMargins
C#
public Border.BorderMargins GetMargins(
   float pageScale
)

Parameters

pageScale
The page scale value.

Return Value

Returns the border margins.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


GetShadowLinePosition Method

[image]
ActiveReports 19 .NET Edition
GetShadowLinePosition Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : GetShadowLinePosition Method

borderEdges
The border edges.
borderRect
The rectangle area of the border.
pageScale
The page scale.
shadowStart
Output parameter of the beginning of the shadow.
shadowEnd
Output parameter of the ending of the shadow.

Glossary Item Box

Gets the position of the shadow line.

Syntax

Visual Basic (Declaration)
Public Sub GetShadowLinePosition( _
   ByVal borderEdges As BorderEdges, _
   ByVal borderRect As RectangleF, _
   ByVal pageScale As Single, _
   ByRef shadowStart As PointF, _
   ByRef shadowEnd As PointF _
)
C#
public void GetShadowLinePosition(
   BorderEdges borderEdges,
   RectangleF borderRect,
   float pageScale,
   out PointF shadowStart,
   out PointF shadowEnd
)

Parameters

borderEdges
The border edges.
borderRect
The rectangle area of the border.
pageScale
The page scale.
shadowStart
Output parameter of the beginning of the shadow.
shadowEnd
Output parameter of the ending of the shadow.

Example

C# Copy Code
public void DrawShadow(Border border, float pageScale, RectangleF borderRect)
{
 using (var pen = new Pen(Brushes.Black, Border.ShadowLineWidth / pageScale))
 {
  pen.SetLineCap(LineCap.Square, LineCap.Square, DashCap.Flat);
  // Right Shadow
  border.GetShadowLinePosition(BorderEdges.Right, borderRect, pageScale, out var shadowStart, out var shadowEnd);
  DrawLine(pen, shadowStart, shadowEnd);
  // Bottom Shadow
  border.GetShadowLinePosition(BorderEdges.Bottom, borderRect, pageScale, out shadowStart, out shadowEnd);
  DrawLine(pen, shadowStart, shadowEnd);
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Inflate Method

[image]
ActiveReports 19 .NET Edition
Inflate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Inflate Method

Glossary Item Box

Inflates the boundaries according to the mergins.

Overload List

Overload | Description
Inflate(Single,RectangleF) | Inflates the boundaries according to the mergins.
Inflate(Single,RectangleF,Single) | Inflates the boundaries according to the mergins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Inflate(Single,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Inflate(Single,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class > Inflate Method : Inflate(Single,RectangleF) Method

pageScale
The page scale.
bounds
Specified bounds.

Glossary Item Box

Inflates the boundaries according to the mergins.

Syntax

Visual Basic (Declaration)
Public Overloads Function Inflate( _
   ByVal pageScale As Single, _
   ByVal bounds As RectangleF _
) As RectangleF
C#
public RectangleF Inflate(
   float pageScale,
   RectangleF bounds
)

Parameters

pageScale
The page scale.
bounds
Specified bounds.

Return Value

Returns the inflated bounds.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Inflate(Single,RectangleF,Single) Method

[image]
ActiveReports 19 .NET Edition
Inflate(Single,RectangleF,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class > Inflate Method : Inflate(Single,RectangleF,Single) Method

pageScale
The page scale.
bounds
Specified bounds.
percentage
The specified percentage.

Glossary Item Box

Inflates the boundaries according to the mergins.

Syntax

Visual Basic (Declaration)
Public Overloads Function Inflate( _
   ByVal pageScale As Single, _
   ByVal bounds As RectangleF, _
   ByVal percentage As Single _
) As RectangleF
C#
public RectangleF Inflate(
   float pageScale,
   RectangleF bounds,
   float percentage
)

Parameters

pageScale
The page scale.
bounds
Specified bounds.
percentage
The specified percentage.

Return Value

Returns the inflated bounds.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


InflateInches Method

[image]
ActiveReports 19 .NET Edition
InflateInches Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : InflateInches Method

graphics
The device info.
inchBounds
Specified bounds.

Glossary Item Box

Inflates the boundaries according to the mergins in inch units.

Syntax

Visual Basic (Declaration)
Public Function InflateInches( _
   ByVal graphics As DeviceInfo, _
   ByVal inchBounds As RectangleF _
) As RectangleF
C#
public RectangleF InflateInches(
   DeviceInfo graphics,
   RectangleF inchBounds
)

Parameters

graphics
The device info.
inchBounds
Specified bounds.

Return Value

Returns the inflated bounds.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


IsEmpty Method

[image]
ActiveReports 19 .NET Edition
IsEmpty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : IsEmpty Method

Glossary Item Box

Gets whether the current instance is empty.

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
C#
public bool IsEmpty()

Return Value

True if this object is empty, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


MarginsInPoints Method

[image]
ActiveReports 19 .NET Edition
MarginsInPoints Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : MarginsInPoints Method

pageScale
The page scale.
dpiX
The dpi X value.
dpiY
the dpi Y value.

Glossary Item Box

Returns a Border.BorderMargins object that contains the thickness of the top, left, right, and bottom edges of the drawn border.

Syntax

Visual Basic (Declaration)
Public Function MarginsInPoints( _
   ByVal pageScale As Single, _
   ByVal dpiX As Single, _
   ByVal dpiY As Single _
) As Border.BorderMargins
C#
public Border.BorderMargins MarginsInPoints(
   float pageScale,
   float dpiX,
   float dpiY
)

Parameters

pageScale
The page scale.
dpiX
The dpi X value.
dpiY
the dpi Y value.

Return Value

Returns the border margins.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


PenStyle Method

[image]
ActiveReports 19 .NET Edition
PenStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : PenStyle Method

edge
The specified edge.

Glossary Item Box

Gets the line style for the pen using the specified edge.

Syntax

Visual Basic (Declaration)
Public Function PenStyle( _
   ByVal edge As Integer _
) As DashStyle
C#
public DashStyle PenStyle(
   int edge
)

Parameters

edge
The specified edge.

Return Value

Returns the line style.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Read Method

[image]
ActiveReports 19 .NET Edition
Read Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Read Method

reader
The binary reader.
fileVersion
The file version.

Glossary Item Box

Reads properties from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Sub Read( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
)
C#
public void Read(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
The binary reader.
fileVersion
The file version.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


ReadXml Method

[image]
ActiveReports 19 .NET Edition
ReadXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : ReadXml Method

controlNode
The xml node.

Glossary Item Box

Reads data from the specified System.Xml.XmlNode.

Syntax

Visual Basic (Declaration)
Public Sub ReadXml( _
   ByVal controlNode As XmlNode _
)
C#
public void ReadXml(
   XmlNode controlNode
)

Parameters

controlNode
The xml node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Render Method

borderLines
The border lines.
bounds
The Border's rectangle in inches.
dpiX
The dpi X value.
dpiY
The dpi Y value.
pageScale
Graphics' page scale.

Glossary Item Box

Renders the border around the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal borderLines As ArrayList, _
   ByVal bounds As RectangleF, _
   ByVal dpiX As Single, _
   ByVal dpiY As Single, _
   ByVal pageScale As Single _
)
C#
public void Render(
   ArrayList borderLines,
   RectangleF bounds,
   float dpiX,
   float dpiY,
   float pageScale
)

Parameters

borderLines
The border lines.
bounds
The Border's rectangle in inches.
dpiX
The dpi X value.
dpiY
The dpi Y value.
pageScale
Graphics' page scale.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Write Method

[image]
ActiveReports 19 .NET Edition
Write Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Write Method

writer
The binary writer.
fileVersion
The file version.

Glossary Item Box

Writing the current values using a specified System.IO.BinaryWriter.

Syntax

Visual Basic (Declaration)
Public Sub Write( _
   ByVal writer As BinaryWriter, _
   ByVal fileVersion As Short _
)
C#
public void Write(
   BinaryWriter writer,
   short fileVersion
)

Parameters

writer
The binary writer.
fileVersion
The file version.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


WriteXml Method

[image]
ActiveReports 19 .NET Edition
WriteXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : WriteXml Method

controlNode
The specified xml element.

Glossary Item Box

Writes the current data to the specified System.Xml.XmlElement.

Syntax

Visual Basic (Declaration)
Public Sub WriteXml( _
   ByVal controlNode As XmlElement _
)
C#
public void WriteXml(
   XmlElement controlNode
)

Parameters

controlNode
The specified xml element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Properties

[image]
ActiveReports 19 .NET Edition
Border Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Properties

 | Name | Description
Public Property | BottomColor | Gets or sets the color of the bottom edge.
Public Property | BottomStyle | Gets or sets the style of the bottom border line.
Public Property | Color | Gets or sets the color for all sides.
Public Property | LeftColor | Gets or sets the color of the left edge.
Public Property | LeftStyle | Gets or sets the style of the left border line.
Public Property | LineStyleOfEdges | Gets the line style of edges.
Public Property | RightColor | Gets or sets the color of the right edge.
Public Property | RightStyle | Gets or sets the style of the right border line.
Public Property | Shadow | Gets or sets a value indicating whether this Border is shadow.
Public Property | Style | Gets or sets the style for all border lines.
Public Property | TopColor | Gets or sets the color of the top edge.
Public Property | TopStyle | Gets or sets the style of the top border line.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


BottomColor Property

[image]
ActiveReports 19 .NET Edition
BottomColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomColor Property

Glossary Item Box

Gets or sets the color of the bottom edge.

Syntax

Visual Basic (Declaration)
Public Property BottomColor As Color
C#
public Color BottomColor {get; set;}

Remarks

Default value is Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


BottomStyle Property

[image]
ActiveReports 19 .NET Edition
BottomStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomStyle Property

Glossary Item Box

Gets or sets the style of the bottom border line.

Syntax

Visual Basic (Declaration)
Public Property BottomStyle As BorderLineStyle
C#
public BorderLineStyle BottomStyle {get; set;}

Property Value

For a list of valid values, see here: BorderLineStyle

Remarks

Default value is None

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Color Property

Glossary Item Box

Gets or sets the color for all sides.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Remarks

Default value is Black

Example

C# Copy Code
border.Color = Color.Yellow;
Color edgeColor;
//All of the values below should be equal to the color yellow.
edgeColor = border.RightColor;
edgeColor = border.LeftColor;
edgeColor = border.BottomColor;
edgeColor = border.TopColor;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


LeftColor Property

[image]
ActiveReports 19 .NET Edition
LeftColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftColor Property

Glossary Item Box

Gets or sets the color of the left edge.

Syntax

Visual Basic (Declaration)
Public Property LeftColor As Color
C#
public Color LeftColor {get; set;}

Remarks

Default value is Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


LeftStyle Property

[image]
ActiveReports 19 .NET Edition
LeftStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftStyle Property

Glossary Item Box

Gets or sets the style of the left border line.

Syntax

Visual Basic (Declaration)
Public Property LeftStyle As BorderLineStyle
C#
public BorderLineStyle LeftStyle {get; set;}

Property Value

For a list of valid values, see here: BorderLineStyle

Remarks

Default value is None

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


LineStyleOfEdges Property

[image]
ActiveReports 19 .NET Edition
LineStyleOfEdges Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : LineStyleOfEdges Property

Glossary Item Box

Gets the line style of edges.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineStyleOfEdges As BorderLineStyle()
C#
public BorderLineStyle[] LineStyleOfEdges {get;}

Property Value

For a list of valid values, see here: BorderLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


RightColor Property

[image]
ActiveReports 19 .NET Edition
RightColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightColor Property

Glossary Item Box

Gets or sets the color of the right edge.

Syntax

Visual Basic (Declaration)
Public Property RightColor As Color
C#
public Color RightColor {get; set;}

Remarks

Default value is Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


RightStyle Property

[image]
ActiveReports 19 .NET Edition
RightStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightStyle Property

Glossary Item Box

Gets or sets the style of the right border line.

Syntax

Visual Basic (Declaration)
Public Property RightStyle As BorderLineStyle
C#
public BorderLineStyle RightStyle {get; set;}

Property Value

For a list of valid values, see here: BorderLineStyle

Remarks

Default value is None

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Shadow Property

[image]
ActiveReports 19 .NET Edition
Shadow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Shadow Property

Glossary Item Box

Gets or sets a value indicating whether this Border is shadow.

Syntax

Visual Basic (Declaration)
Public Property Shadow As Boolean
C#
public bool Shadow {get; set;}

Property Value

true if shadow; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Style Property

Glossary Item Box

Gets or sets the style for all border lines.

Syntax

Visual Basic (Declaration)
Public Property Style As BorderLineStyle
C#
public BorderLineStyle Style {get; set;}

Property Value

For a list of valid values, see here: BorderLineStyle

Remarks

Default value is None

Example

C# Copy Code
border.Style = BorderLineStyle.Solid;
BorderLineStyle edgeStyle;
//All of the values below should be equal to the style solid.
edgeStyle = border.RightStyle;
edgeStyle = border.LeftStyle;
edgeStyle = border.BottomStyle;
edgeStyle = border.TopStyle;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


TopColor Property

[image]
ActiveReports 19 .NET Edition
TopColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopColor Property

Glossary Item Box

Gets or sets the color of the top edge.

Syntax

Visual Basic (Declaration)
Public Property TopColor As Color
C#
public Color TopColor {get; set;}

Remarks

Default value is Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


TopStyle Property

[image]
ActiveReports 19 .NET Edition
TopStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopStyle Property

Glossary Item Box

Gets or sets the style of the top border line.

Syntax

Visual Basic (Declaration)
Public Property TopStyle As BorderLineStyle
C#
public BorderLineStyle TopStyle {get; set;}

Property Value

For a list of valid values, see here: BorderLineStyle

Remarks

Default value is None

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Fields

[image]
ActiveReports 19 .NET Edition
Border Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Fields

 | Name | Description
Public Field | ShadowLineWidth | The constant that specifies the width used to draw the shadow line.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


ShadowLineWidth Field

[image]
ActiveReports 19 .NET Edition
ShadowLineWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : ShadowLineWidth Field

Glossary Item Box

The constant that specifies the width used to draw the shadow line.

Syntax

Visual Basic (Declaration)
Public Const ShadowLineWidth As Single
C#
public const float ShadowLineWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Events

[image]
ActiveReports 19 .NET Edition
Border Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Events

 | Name | Description
Public Event | PropertyChanged | The event occurs when the property is changed.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


PropertyChanged Event

[image]
ActiveReports 19 .NET Edition
PropertyChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : PropertyChanged Event

Glossary Item Box

The event occurs when the property is changed.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border.BorderMargins Class

[image]
ActiveReports 19 .NET Edition
Border.BorderMargins Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

Represents the margins of the border. Used only for Border.GetMargins(). Contains the thickness of the top, left, right, and bottom borders that will be drawn around the outside of the control. This is used to preview the FormatBorderDialog and in AREngine to prevent growing or shrinking sections from clipping the borders.

Object Model

Border.BorderMargins Class

Syntax

Visual Basic (Declaration)
Public Class Border.BorderMargins
C#
public class Border.BorderMargins

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border.BorderMargins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Members
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Members

[image]
ActiveReports 19 .NET Edition
Border.BorderMargins Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

The following tables list the members exposed by Border.BorderMargins.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the thickness of the Bottom border.
Public Property | Left | Gets the thickness of the Left border.
Public Property | Right | Gets the thickness of the Right border.
Public Property | Top | Gets the thickness of the Top border.
Top

See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Properties

[image]
ActiveReports 19 .NET Edition
Border.BorderMargins Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

For a list of all members of this type, see Border.BorderMargins members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the thickness of the Bottom border.
Public Property | Left | Gets the thickness of the Left border.
Public Property | Right | Gets the thickness of the Right border.
Public Property | Top | Gets the thickness of the Top border.
Top

See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Bottom Property

Glossary Item Box

Gets the thickness of the Bottom border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Left Property

Glossary Item Box

Gets the thickness of the Left border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Integer
C#
public int Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Right Property

Glossary Item Box

Gets the thickness of the Right border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Top Property

Glossary Item Box

Gets the thickness of the Top border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Integer
C#
public int Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


PaddingEx.PaddingExConverter Class

[image]
ActiveReports 19 .NET Edition
PaddingEx.PaddingExConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx.PaddingExConverter Class

Glossary Item Box

Represents the padding type converter.

Object Model

PaddingEx.PaddingExConverter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PaddingEx.PaddingExConverter
   Inherits System.ComponentModel.TypeConverter
C#
public sealed class PaddingEx.PaddingExConverter : System.ComponentModel.TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.PaddingEx.PaddingExConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Members
GrapeCity.ActiveReports Namespace


PaddingEx.PaddingExConverter Class Members

[image]
ActiveReports 19 .NET Edition
PaddingEx.PaddingExConverter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx.PaddingExConverter Class

Glossary Item Box

The following tables list the members exposed by PaddingEx.PaddingExConverter.

Public Constructors

 | Name | Description
Public Constructor | PaddingEx.PaddingExConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if we can convert from anything.
Public Method | CanConvertTo | Overloaded. Overridden. Determines if we can convert to anything.
Public Method | ConvertFrom | Overloaded. Overridden. Converts from anything.
Public Method | ConvertTo | Overloaded. Overridden. Converts to destination type.
Public Method | CreateInstance | Overloaded. Overridden. Creates instance.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines whether the creation of an instance
Public Method | GetProperties | Overloaded. Overridden. Gets properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines whether property retrieval is supported.
Top

See Also

Reference

PaddingEx.PaddingExConverter Class
GrapeCity.ActiveReports Namespace


PaddingEx.PaddingExConverter Constructor

[image]
ActiveReports 19 .NET Edition
PaddingEx.PaddingExConverter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : PaddingEx.PaddingExConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PaddingEx.PaddingExConverter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


PaddingEx.PaddingExConverter Class Methods

[image]
ActiveReports 19 .NET Edition
PaddingEx.PaddingExConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx.PaddingExConverter Class

Glossary Item Box

For a list of all members of this type, see PaddingEx.PaddingExConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if we can convert from anything.
Public Method | CanConvertTo | Overloaded. Overridden. Determines if we can convert to anything.
Public Method | ConvertFrom | Overloaded. Overridden. Converts from anything.
Public Method | ConvertTo | Overloaded. Overridden. Converts to destination type.
Public Method | CreateInstance | Overloaded. Overridden. Creates instance.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines whether the creation of an instance
Public Method | GetProperties | Overloaded. Overridden. Gets properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines whether property retrieval is supported.
Top

See Also

Reference

PaddingEx.PaddingExConverter Class
GrapeCity.ActiveReports Namespace


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : CanConvertFrom Method

Glossary Item Box

Determines if we can convert from anything.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if we can convert from anything.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
The context.
sourceType
The source type.

Glossary Item Box

Determines if we can convert from anything.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
The context.
sourceType
The source type.

Return Value

Returns True if we can convert, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : CanConvertTo Method

Glossary Item Box

Determines if we can convert to anything.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Determines if we can convert to anything.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
The context.
destinationType
The destination type.

Glossary Item Box

Determines if we can convert to anything.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
The context.
destinationType
The destination type.

Return Value

Returns True if we can convert, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : ConvertFrom Method

Glossary Item Box

Converts from anything.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts from anything.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
The context.
culture
The culture.
value
The value.

Glossary Item Box

Converts from anything.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
The context.
culture
The culture.
value
The value.

Return Value

Returns the converted object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertTo Method

[image]
ActiveReports 19 .NET Edition
ConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : ConvertTo Method

Glossary Item Box

Converts to destination type.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts to destination type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
The context.
culture
The culture.
value
The value.
destinationType
The destination type.

Glossary Item Box

Converts to destination type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
The context.
culture
The culture.
value
The value.
destinationType
The destination type.

Return Value

Returns the converted object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : CreateInstance Method

Glossary Item Box

Creates instance.

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) | Creates instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
The context.
propertyValues
The properties.

Glossary Item Box

Creates instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
The context.
propertyValues
The properties.

Return Value

New instance.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs if context or properties is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : GetCreateInstanceSupported Method

Glossary Item Box

Determines whether the creation of an instance

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) | Determines whether the creation of an instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context
The context.

Glossary Item Box

Determines whether the creation of an instance

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context
The context.

Return Value

Returns True if we can create an instance, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : GetProperties Method

Glossary Item Box

Gets properties.

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Gets properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
The context.
value
The value.
attributes
The attributes.

Glossary Item Box

Gets properties.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
The context.
value
The value.
attributes
The attributes.

Return Value

Returns property descriptors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : GetPropertiesSupported Method

Glossary Item Box

Determines whether property retrieval is supported.

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Determines whether property retrieval is supported.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context
The context.

Glossary Item Box

Determines whether property retrieval is supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context
The context.

Return Value

Returns True if we can retrieve the properties, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


BorderEdges Enumeration

[image]
ActiveReports 19 .NET Edition
BorderEdges Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : BorderEdges Enumeration

Glossary Item Box

Represents the border edges.

Syntax

Visual Basic (Declaration)
Public Enum BorderEdges
   Inherits System.Enum
C#
public enum BorderEdges : System.Enum

Members

Member | Description
Bottom | Bottom edge of the border
Left | Left edge of the border
Right | Right edge of the border
Top | Top edge of the border.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BorderEdges

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


BorderLineStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BorderLineStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : BorderLineStyle Enumeration

Glossary Item Box

Represents the possible border styles.

Syntax

Visual Basic (Declaration)
Public Enum BorderLineStyle
   Inherits System.Enum
C#
public enum BorderLineStyle : System.Enum

Members

Member | Description
Dash | The dash border style.
DashDot | The dash dot border style.
DashDotDot | The dash dot dot border style.
Dot | The dot border style.
Double | The double border style.
ExtraThickSolid | The extra thick solid border style.
None | The none border style.
Solid | The solid border style.
ThickDash | The thick dash border style.
ThickDashDot | The thick dash dot border style.
ThickDashDotDot | The thick dash dot dot border style.
ThickDot | The thick dot border style.
ThickDouble | The thick double border style.
ThickSolid | The thick solid border style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BorderLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


PaddingEx Structure

[image]
ActiveReports 19 .NET Edition
PaddingEx Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

Represents the padding.

Object Model

PaddingEx Structure

Syntax

Visual Basic (Declaration)
Public Structure PaddingEx
   Inherits System.ValueType
C#
public struct PaddingEx : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PaddingEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Members
GrapeCity.ActiveReports Namespace


PaddingEx Structure Members

[image]
ActiveReports 19 .NET Edition
PaddingEx Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

The following tables list the members exposed by PaddingEx.

Public Constructors

 | Name | Description
Public Constructor | PaddingEx Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns empty structure.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets all paddings.
Public Property | Bottom | Gets or sets bottom padding
Public Property | Horizontal | Gets horizontal padding property
Public Property | Left | Gets or sets left padding
Public Property | Right | Gets or sets right padding
Public Property | Size | Gets size
Public Property | Top | Gets or sets top padding
Public Property | Vertical | Gets versical padding property
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified PaddingEx is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Top

Public Operators

public Operator Equality | Implements the == operator.
public Operator Inequality | Implements the != operator.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


PaddingEx Constructor

[image]
ActiveReports 19 .NET Edition
PaddingEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : PaddingEx Constructor

Glossary Item Box

Overload List

Overload | Description
PaddingEx Constructor(Int32) | Initializes the PaddingEx structure.
PaddingEx Constructor(Int32,Int32,Int32,Int32) | Initializes the PaddingEx structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
PaddingEx Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32)

all
All paddings.

Glossary Item Box

Initializes the PaddingEx structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal all As Integer _
)
C#
public PaddingEx(
   int all
)

Parameters

all
All paddings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Constructor(Int32,Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
PaddingEx Constructor(Int32,Int32,Int32,Int32)
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32,Int32,Int32,Int32)

left
The left padding.
top
The top padding.
right
The right padding.
bottom
The bottom padding.

Glossary Item Box

Initializes the PaddingEx structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
C#
public PaddingEx(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The left padding.
top
The top padding.
right
The right padding.
bottom
The bottom padding.

Example

C# Copy Code
_paddings = new PaddingEx(1, 1, 1, 1);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Structure Methods

[image]
ActiveReports 19 .NET Edition
PaddingEx Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified PaddingEx is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equals Method

Glossary Item Box

Determines whether the specified PaddingEx is equal to this instance.

Overload List

Overload | Description
Equals(PaddingEx) | Determines whether the specified PaddingEx is equal to this instance.
Equals(Object) | Determines whether the specified System.Object is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Equals(PaddingEx) Method

[image]
ActiveReports 19 .NET Edition
Equals(PaddingEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(PaddingEx) Method

paddingEx
Another object to compare to.

Glossary Item Box

Determines whether the specified PaddingEx is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal paddingEx As PaddingEx _
) As Boolean
C#
public bool Equals(
   PaddingEx paddingEx
)

Parameters

paddingEx
Another object to compare to.

Return Value

true if the specified PaddingEx is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(Object) Method

obj
Another object to compare to.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Properties

[image]
ActiveReports 19 .NET Edition
PaddingEx Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets all paddings.
Public Property | Bottom | Gets or sets bottom padding
Public Property | Horizontal | Gets horizontal padding property
Public Property | Left | Gets or sets left padding
Public Property | Right | Gets or sets right padding
Public Property | Size | Gets size
Public Property | Top | Gets or sets top padding
Public Property | Vertical | Gets versical padding property
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


All Property

[image]
ActiveReports 19 .NET Edition
All Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : All Property

Glossary Item Box

Gets or sets all paddings.

Syntax

Visual Basic (Declaration)
Public Property All As Integer
C#
public int All {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Bottom Property

Glossary Item Box

Gets or sets bottom padding

Syntax

Visual Basic (Declaration)
Public Property Bottom As Integer
C#
public int Bottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Horizontal Property

[image]
ActiveReports 19 .NET Edition
Horizontal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Horizontal Property

Glossary Item Box

Gets horizontal padding property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Horizontal As Integer
C#
public int Horizontal {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Left Property

Glossary Item Box

Gets or sets left padding

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Right Property

Glossary Item Box

Gets or sets right padding

Syntax

Visual Basic (Declaration)
Public Property Right As Integer
C#
public int Right {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Size Property

Glossary Item Box

Gets size

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Top Property

Glossary Item Box

Gets or sets top padding

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Vertical Property

[image]
ActiveReports 19 .NET Edition
Vertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Vertical Property

Glossary Item Box

Gets versical padding property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertical As Integer
C#
public int Vertical {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Fields

[image]
ActiveReports 19 .NET Edition
PaddingEx Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns empty structure.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Empty Field

Glossary Item Box

Returns empty structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As PaddingEx
C#
public static readonly PaddingEx Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equality Operator

p1
p2

Glossary Item Box

Implements the == operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As Boolean
C#
public bool operator ==(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
p2

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Inequality Operator

p1
p2

Glossary Item Box

Implements the != operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As Boolean
C#
public bool operator !=(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
p2

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


DocumentBase<PageType> Class

PageType
[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

Represents vector graphics document.

Object Model

DocumentBase<PageType> Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DocumentBase(Of PageType As {New, Page})
   Implements IDocument(Of PageType)
C#
public abstract class DocumentBase<PageType> : IDocument<PageType>
where PageType: new(), Page

Type Parameters

PageType

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DocumentBase<PageType>
GrapeCity.ActiveReports.Core.Document.GenericDocument<PageType,PagesCollectionType>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Members
GrapeCity.ActiveReports.Core.Document Namespace


DocumentBase<PageType> Class Members

[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class Members
See Also Fields Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

The following tables list the members exposed by DocumentBase<PageType>.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MetafileLockObject | Used for locking code in different assemblies.
Top

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets a reference to the document's bookmarks.
Public Property | CacheToDiskEnabled | Gets or sets whether to make the pages collection use a temp file for the canvas item streams.
Public Property | CacheToDiskLocation | Gets or sets the location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.
Public Property | InProgress | Gets or sets whether the document is currently loaded.
Public Property | Name | Gets or sets the name.
Public Property | Pages | Gets a reference to the page of the document.
Public Property | Password | Gets or sets a password to protect the saved document file.
Public Property | UserPreferences | Gets or sets the user preferences.
Top

Public Methods

 | Name | Description
Public Method | ClearFindTextSelection | Clears text selection.
Public Method | DisableCacheToDisk | Disables cache to disk.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources. If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Public Method | EnableCacheToDisk | Enables cache to disk.
Public Method | Find | Overloaded. Search for the specified character string.
Public Method | Load | Overloaded. Loads document from the specified System.IO.Stream.
Public Method | LoadFromUrl | Loads a document from the specified data path.
Public Method | Save | Overloaded. Saves document to the specified file.
Top

Public Events

 | Name | Description
Public Event | LoadCompleted | Event occurs after all document pages are fully loaded.
Public Event | StateChanged | Event occurs when a change of state.
Top

See Also

Reference

DocumentBase<PageType> Class
GrapeCity.ActiveReports.Core.Document Namespace


DocumentBase<PageType> Class Methods

[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

For a list of all members of this type, see DocumentBase<PageType> members.

Public Methods

 | Name | Description
Public Method | ClearFindTextSelection | Clears text selection.
Public Method | DisableCacheToDisk | Disables cache to disk.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources. If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Public Method | EnableCacheToDisk | Enables cache to disk.
Public Method | Find | Overloaded. Search for the specified character string.
Public Method | Load | Overloaded. Loads document from the specified System.IO.Stream.
Public Method | LoadFromUrl | Loads a document from the specified data path.
Public Method | Save | Overloaded. Saves document to the specified file.
Top

See Also

Reference

DocumentBase<PageType> Class
GrapeCity.ActiveReports.Core.Document Namespace


ClearFindTextSelection Method

[image]
ActiveReports 19 .NET Edition
ClearFindTextSelection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : ClearFindTextSelection Method

Glossary Item Box

Clears text selection.

Syntax

Visual Basic (Declaration)
Public Sub ClearFindTextSelection()
C#
public void ClearFindTextSelection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


DisableCacheToDisk Method

[image]
ActiveReports 19 .NET Edition
DisableCacheToDisk Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : DisableCacheToDisk Method

Glossary Item Box

Disables cache to disk.

Syntax

Visual Basic (Declaration)
Public Sub DisableCacheToDisk()
C#
public void DisableCacheToDisk()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources. If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


EnableCacheToDisk Method

[image]
ActiveReports 19 .NET Edition
EnableCacheToDisk Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : EnableCacheToDisk Method

imageConverterService
The image converter service.

Glossary Item Box

Enables cache to disk.

Syntax

Visual Basic (Declaration)
Public Sub EnableCacheToDisk( _
   ByVal imageConverterService As IImageConverterService _
)
C#
public void EnableCacheToDisk(
   IImageConverterService imageConverterService
)

Parameters

imageConverterService
The image converter service.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs if image converter service is null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Find Method

[image]
ActiveReports 19 .NET Edition
Find Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Find Method

Glossary Item Box

Search for the specified character string.

Overload List

Overload | Description
Find(String,Int32) | Search for the specified character string.
Find(String,FindOptions,Int32,Single) | Searches the document page for the specified string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Find(String,Int32) Method

[image]
ActiveReports 19 .NET Edition
Find(String,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Find Method : Find(String,Int32) Method

searchString
The string you are searching for
currentIndex
The page's collection zero based index

Glossary Item Box

Search for the specified character string.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal searchString As String, _
   ByRef currentIndex As Integer _
) As Boolean
C#
public bool Find(
   string searchString,
   ref int currentIndex
)

Parameters

searchString
The string you are searching for
currentIndex
The page's collection zero based index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Find(String,FindOptions,Int32,Single) Method

[image]
ActiveReports 19 .NET Edition
Find(String,FindOptions,Int32,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Find Method : Find(String,FindOptions,Int32,Single) Method

searchString
The string you are searching for
options
which direction you are searching
currentIndex
The page's collection zero based index
currentOffset
The current offset into the text string

Glossary Item Box

Searches the document page for the specified string.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal searchString As String, _
   ByVal options As FindOptions, _
   ByRef currentIndex As Integer, _
   ByRef currentOffset As Single _
) As FindResult
C#
public FindResult Find(
   string searchString,
   FindOptions options,
   ref int currentIndex,
   ref float currentOffset
)

Parameters

searchString
The string you are searching for
options
which direction you are searching
currentIndex
The page's collection zero based index
currentOffset
The current offset into the text string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Load Method

Glossary Item Box

Loads document from the specified System.IO.Stream.

Overload List

Overload | Description
Load(Stream,IImageConverterService) | Loads document from the specified System.IO.Stream.
Load(String,IImageConverterService) | Loads document from the specified RDF file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Load(Stream,IImageConverterService) Method

[image]
ActiveReports 19 .NET Edition
Load(Stream,IImageConverterService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Load Method : Load(Stream,IImageConverterService) Method

stream
The stream.
imageConverterService
Service that converts image data from one format to another.

Glossary Item Box

Loads document from the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal stream As Stream, _
   ByVal imageConverterService As IImageConverterService _
)
C#
public void Load(
   Stream stream,
   IImageConverterService imageConverterService
)

Parameters

stream
The stream.
imageConverterService
Service that converts image data from one format to another.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Load(String,IImageConverterService) Method

[image]
ActiveReports 19 .NET Edition
Load(String,IImageConverterService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Load Method : Load(String,IImageConverterService) Method

fileName
The RDF file.
imageConverterService
Service that converts image data from one format to another.

Glossary Item Box

Loads document from the specified RDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal fileName As String, _
   ByVal imageConverterService As IImageConverterService _
)
C#
public void Load(
   string fileName,
   IImageConverterService imageConverterService
)

Parameters

fileName
The RDF file.
imageConverterService
Service that converts image data from one format to another.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


LoadFromUrl Method

[image]
ActiveReports 19 .NET Edition
LoadFromUrl Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : LoadFromUrl Method

dataPath
The data path.
imageConverterService
The image converter service.
downloadError
The Error event handler.

Glossary Item Box

Loads a document from the specified data path.

Syntax

Visual Basic (Declaration)
Public Sub LoadFromUrl( _
   ByVal dataPath As String, _
   ByVal imageConverterService As IImageConverterService, _
   ByVal downloadError As UrlErrorEventHandler _
)
C#
public void LoadFromUrl(
   string dataPath,
   IImageConverterService imageConverterService,
   UrlErrorEventHandler downloadError
)

Parameters

dataPath
The data path.
imageConverterService
The image converter service.
downloadError
The Error event handler.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Save Method

Glossary Item Box

Saves document to the specified file.

Overload List

Overload | Description
Save(String,RdfFormat) | Saves document to the specified file.
Save(String,RdfFormat,SaveOptions) | Saves document to the specified file.
Save(String) | Saves document to the specified file.
Save(Stream,RdfFormat) | Saves document to the specified System.IO.Stream.
Save(Stream,RdfFormat,SaveOptions) | Saves document to the specified System.IO.Stream.
Save(Stream) | Saves document to the specified System.IO.Stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Save(String,RdfFormat) Method

[image]
ActiveReports 19 .NET Edition
Save(String,RdfFormat) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(String,RdfFormat) Method

fileName
Name of the file.
fmt
The format.

Glossary Item Box

Saves document to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal fmt As RdfFormat _
)
C#
public void Save(
   string fileName,
   RdfFormat fmt
)

Parameters

fileName
Name of the file.
fmt
The format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Save(String,RdfFormat,SaveOptions) Method

[image]
ActiveReports 19 .NET Edition
Save(String,RdfFormat,SaveOptions) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(String,RdfFormat,SaveOptions) Method

fileName
Name of the file.
fmt
The format.
options
The options.

Glossary Item Box

Saves document to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
C#
public void Save(
   string fileName,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

fileName
Name of the file.
fmt
The format.
options
The options.

Exceptions

Exception | Description
System.Security.SecurityException | The exception that is thrown when a security error is detected.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Save(String) Method

[image]
ActiveReports 19 .NET Edition
Save(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(String) Method

fileName
Name of the file.

Glossary Item Box

Saves document to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String _
)
C#
public void Save(
   string fileName
)

Parameters

fileName
Name of the file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Save(Stream,RdfFormat) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream,RdfFormat) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(Stream,RdfFormat) Method

stream
The stream.
fmt
The format.

Glossary Item Box

Saves document to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat _
)
C#
public void Save(
   Stream stream,
   RdfFormat fmt
)

Parameters

stream
The stream.
fmt
The format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Save(Stream,RdfFormat,SaveOptions) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream,RdfFormat,SaveOptions) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(Stream,RdfFormat,SaveOptions) Method

stream
The stream.
fmt
The format.
options
The options.

Glossary Item Box

Saves document to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
C#
public void Save(
   Stream stream,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

stream
The stream.
fmt
The format.
options
The options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


Save(Stream) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class > Save Method : Save(Stream) Method

stream
The stream.

Glossary Item Box

Saves document to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream _
)
C#
public void Save(
   Stream stream
)

Parameters

stream
The stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members
Overload List


DocumentBase<PageType> Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

For a list of all members of this type, see DocumentBase<PageType> members.

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets a reference to the document's bookmarks.
Public Property | CacheToDiskEnabled | Gets or sets whether to make the pages collection use a temp file for the canvas item streams.
Public Property | CacheToDiskLocation | Gets or sets the location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.
Public Property | InProgress | Gets or sets whether the document is currently loaded.
Public Property | Name | Gets or sets the name.
Public Property | Pages | Gets a reference to the page of the document.
Public Property | Password | Gets or sets a password to protect the saved document file.
Public Property | UserPreferences | Gets or sets the user preferences.
Top

See Also

Reference

DocumentBase<PageType> Class
GrapeCity.ActiveReports.Core.Document Namespace


Bookmarks Property

[image]
ActiveReports 19 .NET Edition
Bookmarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Bookmarks Property

Glossary Item Box

Gets a reference to the document's bookmarks.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As BookmarksCollection
C#
public BookmarksCollection Bookmarks {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


CacheToDiskEnabled Property

[image]
ActiveReports 19 .NET Edition
CacheToDiskEnabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : CacheToDiskEnabled Property

Glossary Item Box

Gets or sets whether to make the pages collection use a temp file for the canvas item streams.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheToDiskEnabled As Boolean
C#
public bool CacheToDiskEnabled {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


CacheToDiskLocation Property

[image]
ActiveReports 19 .NET Edition
CacheToDiskLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : CacheToDiskLocation Property

Glossary Item Box

Gets or sets the location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.

Syntax

Visual Basic (Declaration)
Public Property CacheToDiskLocation As String
C#
public string CacheToDiskLocation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


InProgress Property

[image]
ActiveReports 19 .NET Edition
InProgress Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : InProgress Property

Glossary Item Box

Gets or sets whether the document is currently loaded.

Syntax

Visual Basic (Declaration)
Public Property InProgress As Boolean
C#
public bool InProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Name Property

Glossary Item Box

Gets or sets the name.

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Pages Property

Glossary Item Box

Gets a reference to the page of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As IPagesCollection(Of PageType)
C#
public IPagesCollection<PageType> Pages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Password Property

Glossary Item Box

Gets or sets a password to protect the saved document file.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


UserPreferences Property

[image]
ActiveReports 19 .NET Edition
UserPreferences Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : UserPreferences Property

Glossary Item Box

Gets or sets the user preferences.

Syntax

Visual Basic (Declaration)
Public Property UserPreferences As UserPreferences
C#
public UserPreferences UserPreferences {get; set;}

Property Value

The user preferences.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


DocumentBase<PageType> Class Fields

[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

For a list of all members of this type, see DocumentBase<PageType> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MetafileLockObject | Used for locking code in different assemblies.
Top

See Also

Reference

DocumentBase<PageType> Class
GrapeCity.ActiveReports.Core.Document Namespace


MetafileLockObject Field

[image]
ActiveReports 19 .NET Edition
MetafileLockObject Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : MetafileLockObject Field

Glossary Item Box

Used for locking code in different assemblies.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MetafileLockObject As Object
C#
public static readonly object MetafileLockObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


DocumentBase<PageType> Class Events

[image]
ActiveReports 19 .NET Edition
DocumentBase<PageType> Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DocumentBase<PageType> Class

Glossary Item Box

For a list of all members of this type, see DocumentBase<PageType> members.

Public Events

 | Name | Description
Public Event | LoadCompleted | Event occurs after all document pages are fully loaded.
Public Event | StateChanged | Event occurs when a change of state.
Top

See Also

Reference

DocumentBase<PageType> Class
GrapeCity.ActiveReports.Core.Document Namespace


LoadCompleted Event

[image]
ActiveReports 19 .NET Edition
LoadCompleted Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : LoadCompleted Event

Glossary Item Box

Event occurs after all document pages are fully loaded.

Syntax

Visual Basic (Declaration)
Public Event LoadCompleted As LoadCompletedEventHandler
C#
public event LoadCompletedEventHandler LoadCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


StateChanged Event

[image]
ActiveReports 19 .NET Edition
StateChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : StateChanged Event

Glossary Item Box

Event occurs when a change of state.

Syntax

Visual Basic (Declaration)
Public Event StateChanged As StateChangedHandler
C#
public event StateChangedHandler StateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


FindOptions Class

[image]
ActiveReports 19 .NET Edition
FindOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FindOptions Class

Glossary Item Box

Represents the find options.

Object Model

FindOptions Class

Syntax

Visual Basic (Declaration)
Public Class FindOptions
C#
public class FindOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.FindOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindOptions Members
GrapeCity.ActiveReports.Core.Document Namespace


FindOptions Class Members

[image]
ActiveReports 19 .NET Edition
FindOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FindOptions Class

Glossary Item Box

The following tables list the members exposed by FindOptions.

Public Constructors

 | Name | Description
Public Constructor | FindOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | MatchCase | Gets or sets whether case is matched when searching.
Public Property | MatchWholeWord | Gets or sets whether to search for whole words only.
Public Property | Reverse | Gets or sets a value indicating whether this FindOptions is reverse.
Top

See Also

Reference

FindOptions Class
GrapeCity.ActiveReports.Core.Document Namespace


FindOptions Constructor

[image]
ActiveReports 19 .NET Edition
FindOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FindOptions Class : FindOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FindOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindOptions Class
FindOptions Members


FindOptions Class Properties

[image]
ActiveReports 19 .NET Edition
FindOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FindOptions Class

Glossary Item Box

For a list of all members of this type, see FindOptions members.

Public Properties

 | Name | Description
Public Property | MatchCase | Gets or sets whether case is matched when searching.
Public Property | MatchWholeWord | Gets or sets whether to search for whole words only.
Public Property | Reverse | Gets or sets a value indicating whether this FindOptions is reverse.
Top

See Also

Reference

FindOptions Class
GrapeCity.ActiveReports.Core.Document Namespace


MatchCase Property

[image]
ActiveReports 19 .NET Edition
MatchCase Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FindOptions Class : MatchCase Property

Glossary Item Box

Gets or sets whether case is matched when searching.

Syntax

Visual Basic (Declaration)
Public Property MatchCase As Boolean
C#
public bool MatchCase {get; set;}

Property Value

true if case is matched; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindOptions Class
FindOptions Members


MatchWholeWord Property

[image]
ActiveReports 19 .NET Edition
MatchWholeWord Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FindOptions Class : MatchWholeWord Property

Glossary Item Box

Gets or sets whether to search for whole words only.

Syntax

Visual Basic (Declaration)
Public Property MatchWholeWord As Boolean
C#
public bool MatchWholeWord {get; set;}

Property Value

true if to search for whole words only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindOptions Class
FindOptions Members


Reverse Property

[image]
ActiveReports 19 .NET Edition
Reverse Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FindOptions Class : Reverse Property

Glossary Item Box

Gets or sets a value indicating whether this FindOptions is reverse.

Syntax

Visual Basic (Declaration)
Public Property Reverse As Boolean
C#
public bool Reverse {get; set;}

Property Value

true if reverse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindOptions Class
FindOptions Members


FontsCollection Class

[image]
ActiveReports 19 .NET Edition
FontsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FontsCollection Class

Glossary Item Box

Represents the font collection.

Object Model

FontsCollection Class

Syntax

Visual Basic (Declaration)
Public Class FontsCollection
   Inherits System.Collections.CollectionBase
C#
public class FontsCollection : System.Collections.CollectionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Core.Document.FontsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Members
GrapeCity.ActiveReports.Core.Document Namespace


FontsCollection Class Members

[image]
ActiveReports 19 .NET Edition
FontsCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FontsCollection Class

Glossary Item Box

The following tables list the members exposed by FontsCollection.

Public Constructors

 | Name | Description
Public Constructor | FontsCollection Constructor | Default constructor for FontsCollection object.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a GrapeCity.ActiveReports.Document.Drawing.Font item to the collection.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top

See Also

Reference

FontsCollection Class
GrapeCity.ActiveReports.Core.Document Namespace


FontsCollection Constructor

[image]
ActiveReports 19 .NET Edition
FontsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : FontsCollection Constructor

Glossary Item Box

Default constructor for FontsCollection object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FontsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


FontsCollection Class Methods

[image]
ActiveReports 19 .NET Edition
FontsCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FontsCollection Class

Glossary Item Box

For a list of all members of this type, see FontsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a GrapeCity.ActiveReports.Document.Drawing.Font item to the collection.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top

See Also

Reference

FontsCollection Class
GrapeCity.ActiveReports.Core.Document Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Add Method

inFont
A GrapeCity.ActiveReports.Document.Drawing.Font item to add.

Glossary Item Box

Adds a GrapeCity.ActiveReports.Document.Drawing.Font item to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal inFont As Font _
) As Integer
C#
public int Add(
   Font inFont
)

Parameters

inFont
A GrapeCity.ActiveReports.Document.Drawing.Font item to add.

Return Value

The position into which the new item was inserted, or -1 to indicate that the item was not inserted into the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


GenericDocument<PageType,PagesCollectionType> Class

PageType
PagesCollectionType
[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : GenericDocument<PageType,PagesCollectionType> Class

Glossary Item Box

Represents a vector graphics document.

Object Model

GenericDocument<PageType,PagesCollectionType> Class

Syntax

Visual Basic (Declaration)
Public Class GenericDocument
    (Of PageType As {New, Page},
     PagesCollectionType As {New, PagesCollection(Of PageType)})
   Inherits DocumentBase(Of PageType)
   Implements IDocument(Of PageType)
C#
public class GenericDocument<PageType,PagesCollectionType> : DocumentBase<PageType>, IDocument<PageType>
where PageType: new(), Page
where PagesCollectionType: new(), PagesCollection<PageType>

Type Parameters

PageType
PagesCollectionType

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DocumentBase<PageType>
GrapeCity.ActiveReports.Core.Document.GenericDocument<PageType,PagesCollectionType>
GrapeCity.ActiveReports.Document.SectionDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Members
GrapeCity.ActiveReports.Core.Document Namespace


GenericDocument<PageType,PagesCollectionType> Class Members

[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : GenericDocument<PageType,PagesCollectionType> Class

Glossary Item Box

The following tables list the members exposed by GenericDocument<PageType,PagesCollectionType>.

Public Constructors

 | Name | Description
Public Constructor | GenericDocument<PageType,PagesCollectionType> Constructor |
Top

Public Properties

 | Name | Description
Public Property | Pages | Gets or sets a reference to the page of the document.
Top

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GrapeCity.ActiveReports.Core.Document Namespace


GenericDocument<PageType,PagesCollectionType> Constructor

[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > GenericDocument<PageType,PagesCollectionType> Class : GenericDocument<PageType,PagesCollectionType> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GenericDocument<PageType,PagesCollectionType>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GenericDocument<PageType,PagesCollectionType> Members


GenericDocument<PageType,PagesCollectionType> Class Properties

[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : GenericDocument<PageType,PagesCollectionType> Class

Glossary Item Box

For a list of all members of this type, see GenericDocument<PageType,PagesCollectionType> members.

Public Properties

 | Name | Description
Public Property | Pages | Gets or sets a reference to the page of the document.
Top

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GrapeCity.ActiveReports.Core.Document Namespace


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > GenericDocument<PageType,PagesCollectionType> Class : Pages Property

Glossary Item Box

Gets or sets a reference to the page of the document.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Pages As PagesCollectionType
C#
public new PagesCollectionType Pages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GenericDocument<PageType,PagesCollectionType> Members


Globals Class

[image]
ActiveReports 19 .NET Edition
Globals Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Globals Class

Glossary Item Box

Presents global units of measurement and methods for evaluation.

Object Model

Globals Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Globals
C#
public static class Globals

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Globals

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Members
GrapeCity.ActiveReports.Core.Document Namespace


Globals Class Members

[image]
ActiveReports 19 .NET Edition
Globals Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Globals Class

Glossary Item Box

The following tables list the members exposed by Globals.

Public Fields

 | Name | Description
Public Field | DocumentVersion | The AR15 version.
Public Field | DocumentVersionAR20 | The AR2 version.
Public Field | DocumentVersionAR63 | The AR6-AR14 versions.
Top

See Also

Reference

Globals Class
GrapeCity.ActiveReports.Core.Document Namespace


Globals Class Fields

[image]
ActiveReports 19 .NET Edition
Globals Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Globals Class

Glossary Item Box

For a list of all members of this type, see Globals members.

Public Fields

 | Name | Description
Public Field | DocumentVersion | The AR15 version.
Public Field | DocumentVersionAR20 | The AR2 version.
Public Field | DocumentVersionAR63 | The AR6-AR14 versions.
Top

See Also

Reference

Globals Class
GrapeCity.ActiveReports.Core.Document Namespace


DocumentVersion Field

[image]
ActiveReports 19 .NET Edition
DocumentVersion Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Globals Class : DocumentVersion Field

Glossary Item Box

The AR15 version.

Syntax

Visual Basic (Declaration)
Public Const DocumentVersion As Short
C#
public const short DocumentVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


DocumentVersionAR20 Field

[image]
ActiveReports 19 .NET Edition
DocumentVersionAR20 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Globals Class : DocumentVersionAR20 Field

Glossary Item Box

The AR2 version.

Syntax

Visual Basic (Declaration)
Public Const DocumentVersionAR20 As Short
C#
public const short DocumentVersionAR20

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


DocumentVersionAR63 Field

[image]
ActiveReports 19 .NET Edition
DocumentVersionAR63 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Globals Class : DocumentVersionAR63 Field

Glossary Item Box

The AR6-AR14 versions.

Syntax

Visual Basic (Declaration)
Public Const DocumentVersionAR63 As Short
C#
public const short DocumentVersionAR63

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


Page Class

[image]
ActiveReports 19 .NET Edition
Page Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Page Class

Glossary Item Box

Represents the page.

Object Model

Page Class

Syntax

Visual Basic (Declaration)
Public Class Page
   Implements GrapeCity.ActiveReports.Document.Section.ICanvasItemsModifier
C#
public class Page : GrapeCity.ActiveReports.Document.Section.ICanvasItemsModifier

Remarks

Internally, all page dimensions are kept in inches.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Page
GrapeCity.ActiveReports.Document.Section.Page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Members
GrapeCity.ActiveReports.Core.Document Namespace


Page Class Members

[image]
ActiveReports 19 .NET Edition
Page Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Page Class

Glossary Item Box

The following tables list the members exposed by Page.

Public Constructors

 | Name | Description
Public Constructor | Page Constructor | Initializes an instance of class Page.
Top

Public Properties

 | Name | Description
Public Property | Annotations | Getsthe annotations.
Public Property | Bookmarks | Gets the bookmarks.
Public Property | CanvasItems | Gets readonly collection of canvas items.
Public Property | Compress | Gets or sets whether the page is compressed.
Public Property | Fonts | Gets or sets the fonts.
Public Property | Height | Gets or sets the height.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | IsPro | Gets whether there is a pro license
Public Property | Margins | Gets the margins.
Public Property | Orientation | Gets or sets the orientation.
Public Property | Pages | Gets the pages collection.
Public Property | Size | Gets the size of the page in *inches*.
Public Property | Units | Gets or sets the units.
Public Property | UserPreferences | Gets or sets users preferences.
Public Property | Width | Gets or sets the width.
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Overloaded. Adds the bookmark.
Public Method | Clear | Clears canvas items, bookmarks, fonts and objects tags.
Public Method | ClearCanvasItems | Clears canvas items.
Public Method | Clone | Performs a cloning of this instance.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | Load | Overloaded. Summary description for Load Method.
Public Method | Overlay | Overlays page.
Public Method | RefreshPageInTheCache | Refreshes the page in the cache.
Public Method | Render | Renders the page using the canvas item renderer.
Public Method | Save | Overloaded. Save Method
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Core.Document Namespace


Page Constructor

[image]
ActiveReports 19 .NET Edition
Page Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Page Constructor

Glossary Item Box

Initializes an instance of class Page.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Page()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Methods

[image]
ActiveReports 19 .NET Edition
Page Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Overloaded. Adds the bookmark.
Public Method | Clear | Clears canvas items, bookmarks, fonts and objects tags.
Public Method | ClearCanvasItems | Clears canvas items.
Public Method | Clone | Performs a cloning of this instance.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | Load | Overloaded. Summary description for Load Method.
Public Method | Overlay | Overlays page.
Public Method | RefreshPageInTheCache | Refreshes the page in the cache.
Public Method | Render | Renders the page using the canvas item renderer.
Public Method | Save | Overloaded. Save Method
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Core.Document Namespace


AddBookmark Method

[image]
ActiveReports 19 .NET Edition
AddBookmark Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : AddBookmark Method

Glossary Item Box

Adds the bookmark.

Overload List

Overload | Description
AddBookmark(Bookmark) | Adds the bookmark.
AddBookmark(String,Single) | Adds the GrapeCity.ActiveReports.Document.Section.Bookmark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


AddBookmark(Bookmark) Method

[image]
ActiveReports 19 .NET Edition
AddBookmark(Bookmark) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > AddBookmark Method : AddBookmark(Bookmark) Method

theBookmark
GrapeCity.ActiveReports.Document.Section.Bookmark to be added.

Glossary Item Box

Adds the bookmark.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddBookmark( _
   ByVal theBookmark As Bookmark _
) As Integer
C#
public int AddBookmark(
   Bookmark theBookmark
)

Parameters

theBookmark
GrapeCity.ActiveReports.Document.Section.Bookmark to be added.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


AddBookmark(String,Single) Method

[image]
ActiveReports 19 .NET Edition
AddBookmark(String,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > AddBookmark Method : AddBookmark(String,Single) Method

strBookmark
Name of the GrapeCity.ActiveReports.Document.Section.Bookmark
offset
The offSet from the top of the page where the GrapeCity.ActiveReports.Document.Section.Bookmark is on the page object

Glossary Item Box

Adds the GrapeCity.ActiveReports.Document.Section.Bookmark.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddBookmark( _
   ByVal strBookmark As String, _
   ByVal offset As Single _
) As Integer
C#
public int AddBookmark(
   string strBookmark,
   float offset
)

Parameters

strBookmark
Name of the GrapeCity.ActiveReports.Document.Section.Bookmark
offset
The offSet from the top of the page where the GrapeCity.ActiveReports.Document.Section.Bookmark is on the page object

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Clear Method

Glossary Item Box

Clears canvas items, bookmarks, fonts and objects tags.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ClearCanvasItems Method

[image]
ActiveReports 19 .NET Edition
ClearCanvasItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : ClearCanvasItems Method

Glossary Item Box

Clears canvas items.

Syntax

Visual Basic (Declaration)
Public Sub ClearCanvasItems()
C#
public void ClearCanvasItems()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
C#
public virtual object Clone()

Return Value

Returns the cloned Page instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Load Method

Glossary Item Box

Summary description for Load Method.

Overload List

Overload | Description
Load(String,IImageConverterService) | Loads the page using the filename and image converter service.
Load(Stream,IImageConverterService) | Loads the page using the stream and image converter service.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Load(String,IImageConverterService) Method

[image]
ActiveReports 19 .NET Edition
Load(String,IImageConverterService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > Load Method : Load(String,IImageConverterService) Method

strFileName
The file name.
imageConverterService
The image converter service.

Glossary Item Box

Loads the page using the filename and image converter service.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal strFileName As String, _
   ByVal imageConverterService As IImageConverterService _
) As Boolean
C#
public bool Load(
   string strFileName,
   IImageConverterService imageConverterService
)

Parameters

strFileName
The file name.
imageConverterService
The image converter service.

Return Value

Returns the result of successful execution of the operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Load(Stream,IImageConverterService) Method

[image]
ActiveReports 19 .NET Edition
Load(Stream,IImageConverterService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > Load Method : Load(Stream,IImageConverterService) Method

stm
The stream.
imageConverterService
The image converter service.

Glossary Item Box

Loads the page using the stream and image converter service.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal stm As Stream, _
   ByVal imageConverterService As IImageConverterService _
) As Boolean
C#
public bool Load(
   Stream stm,
   IImageConverterService imageConverterService
)

Parameters

stm
The stream.
imageConverterService
The image converter service.

Return Value

Returns the result of successful execution of the operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Overlay Method

[image]
ActiveReports 19 .NET Edition
Overlay Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Overlay Method

page
Page to overlay.

Glossary Item Box

Overlays page.

Syntax

Visual Basic (Declaration)
Public Sub Overlay( _
   ByVal page As Page _
)
C#
public void Overlay(
   Page page
)

Parameters

page
Page to overlay.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


RefreshPageInTheCache Method

[image]
ActiveReports 19 .NET Edition
RefreshPageInTheCache Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : RefreshPageInTheCache Method

Glossary Item Box

Refreshes the page in the cache.

Syntax

Visual Basic (Declaration)
Public Sub RefreshPageInTheCache()
C#
public void RefreshPageInTheCache()

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Render Method

renderer
The canvas item renderer.

Glossary Item Box

Renders the page using the canvas item renderer.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal renderer As ICanvasItemRenderer _
)
C#
public void Render(
   ICanvasItemRenderer renderer
)

Parameters

renderer
The canvas item renderer.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs when renderer is null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Save Method

Glossary Item Box

Save Method

Overload List

Overload | Description
Save(String) | Saves data to the specified path.
Save(Stream) | Save data to the specified stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Save(String) Method

[image]
ActiveReports 19 .NET Edition
Save(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > Save Method : Save(String) Method

strFileName
The file name.

Glossary Item Box

Saves data to the specified path.

Syntax

Visual Basic (Declaration)
Public Overloads Function Save( _
   ByVal strFileName As String _
) As Boolean
C#
public bool Save(
   string strFileName
)

Parameters

strFileName
The file name.

Return Value

Returns the result of successful execution of the operation. True if operation was successfull

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Save(Stream) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class > Save Method : Save(Stream) Method

stm
The stream.

Glossary Item Box

Save data to the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Function Save( _
   ByVal stm As Stream _
) As Boolean
C#
public bool Save(
   Stream stm
)

Parameters

stm
The stream.

Return Value

Returns the result of successful execution of the operation. True if operation was successfull

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Properties

[image]
ActiveReports 19 .NET Edition
Page Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Properties

 | Name | Description
Public Property | Annotations | Getsthe annotations.
Public Property | Bookmarks | Gets the bookmarks.
Public Property | CanvasItems | Gets readonly collection of canvas items.
Public Property | Compress | Gets or sets whether the page is compressed.
Public Property | Fonts | Gets or sets the fonts.
Public Property | Height | Gets or sets the height.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | IsPro | Gets whether there is a pro license
Public Property | Margins | Gets the margins.
Public Property | Orientation | Gets or sets the orientation.
Public Property | Pages | Gets the pages collection.
Public Property | Size | Gets the size of the page in *inches*.
Public Property | Units | Gets or sets the units.
Public Property | UserPreferences | Gets or sets users preferences.
Public Property | Width | Gets or sets the width.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Core.Document Namespace


Annotations Property

[image]
ActiveReports 19 .NET Edition
Annotations Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Annotations Property

Glossary Item Box

Getsthe annotations.

Syntax

Visual Basic (Declaration)
Public Property Annotations As AnnotationCollection
C#
public AnnotationCollection Annotations {get; set;}

Remarks

Use AnnotationCollection's methods to modify it.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Bookmarks Property

[image]
ActiveReports 19 .NET Edition
Bookmarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Bookmarks Property

Glossary Item Box

Gets the bookmarks.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As IList
C#
public IList Bookmarks {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


CanvasItems Property

[image]
ActiveReports 19 .NET Edition
CanvasItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : CanvasItems Property

Glossary Item Box

Gets readonly collection of canvas items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanvasItems As IList(Of CanvasItem)
C#
public IList<CanvasItem> CanvasItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Compress Property

[image]
ActiveReports 19 .NET Edition
Compress Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Compress Property

Glossary Item Box

Gets or sets whether the page is compressed.

Syntax

Visual Basic (Declaration)
Public Property Compress As Boolean
C#
public bool Compress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Fonts Property

Glossary Item Box

Gets or sets the fonts.

Syntax

Visual Basic (Declaration)
Public Property Fonts As FontsCollection
C#
public FontsCollection Fonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Height Property

Glossary Item Box

Gets or sets the height.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Remarks

Value must be in the units specified in Units.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Identifier Property

[image]
ActiveReports 19 .NET Edition
Identifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Identifier Property

Glossary Item Box

Gets unique page identifier (used in PagesCollection to track swapped out pages)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Identifier As Guid
C#
public Guid Identifier {get;}

Remarks

Value type is System.Guid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


IsPro Property

[image]
ActiveReports 19 .NET Edition
IsPro Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : IsPro Property

Glossary Item Box

Gets whether there is a pro license

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPro As Boolean
C#
public bool IsPro {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Margins Property

[image]
ActiveReports 19 .NET Edition
Margins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Margins Property

Glossary Item Box

Gets the margins.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Margins As Margins
C#
public Margins Margins {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Orientation Property

[image]
ActiveReports 19 .NET Edition
Orientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Orientation Property

Glossary Item Box

Gets or sets the orientation.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Pages Property

Glossary Item Box

Gets the pages collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As IPagesCollection(Of Page)
C#
public IPagesCollection<Page> Pages {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Size Property

Glossary Item Box

Gets the size of the page in *inches*.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
C#
public SizeF Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Units Property

[image]
ActiveReports 19 .NET Edition
Units Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Units Property

Glossary Item Box

Gets or sets the units.

Syntax

Visual Basic (Declaration)
Public Property Units As Units
C#
public Units Units {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.Units

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


UserPreferences Property

[image]
ActiveReports 19 .NET Edition
UserPreferences Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : UserPreferences Property

Glossary Item Box

Gets or sets users preferences.

Syntax

Visual Basic (Declaration)
Public Property UserPreferences As UserPreferences
C#
public UserPreferences UserPreferences {get; set;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Width Property

Glossary Item Box

Gets or sets the width.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Remarks

Value must be in the units specified in Units.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PagesCollection<T> Class

T
[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : PagesCollection<T> Class

Glossary Item Box

Contains a collection of Page objects.

Object Model

PagesCollection<T> Class

Syntax

Visual Basic (Declaration)
Public Class PagesCollection(Of T As {New, Page})
   Implements IPagesCollection(Of T)
C#
public class PagesCollection<T> : IPagesCollection<T>
where T: new(), Page

Type Parameters

T

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.PagesCollection<T>
GrapeCity.ActiveReports.Document.Section.PagesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Members
GrapeCity.ActiveReports.Core.Document Namespace


PagesCollection<T> Class Members

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : PagesCollection<T> Class

Glossary Item Box

The following tables list the members exposed by PagesCollection<T>.

Public Constructors

 | Name | Description
Public Constructor | PagesCollection<T> Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ICollection.
Public Property | Document | Gets the document.
Public Property | FileVersion | Gets the file version.
Public Property | Fonts | Gets the fonts collection.
Public Property | IsFixedSize | Gets whether the System.Collections.IList has a fixed size.
Public Property | IsReadOnly | Gets whether the System.Collections.IList is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).
Public Property | Item | Returns a Page object at specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the System.Collections.ICollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new item into the cache.
Public Method | AddRange | Overloaded. Adds the elements of an array of pages to the end of the pages collection.
Public Method | Clear | Removes all the page objects from the page collection.
Public Method | Clone | Performs a cloning of this instance.
Public Method | Contains | Overloaded. Determines whether the System.Collections.IList contains a specific value.
Public Method | CopyTo | Overloaded. Copies the elements of the System.Collections.ICollection to an System.Array, starting at a given System.Array index.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | IndexOf | Overloaded. Gets the index of a specific item in the System.Collections.IList.
Public Method | Insert | Overloaded. Inserts an item to the System.Collections.IList at the specified index.
Public Method | InsertNew | Inserts a new page element into the pages collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts the elements from page collections objects into the pages collection at the specified index.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.IList.
Public Method | RemoveAt | Removes item by index.
Top

Public Events

 | Name | Description
Public Event | Changed | The event occurs when the item is changed.
Top

See Also

Reference

PagesCollection<T> Class
GrapeCity.ActiveReports.Core.Document Namespace


PagesCollection<T> Constructor

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : PagesCollection<T> Constructor

Glossary Item Box

Overload List

Overload | Description
PagesCollection<T> Constructor() | Initializes a new instance of the PagesCollection<T> Constructor class.
PagesCollection<T> Constructor(DocumentBase<T>) | Initializes a new instance of the PagesCollection<T> class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


PagesCollection<T> Constructor()

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > PagesCollection<T> Constructor : PagesCollection<T> Constructor()

Glossary Item Box

Initializes a new instance of the PagesCollection<T> Constructor class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PagesCollection<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


PagesCollection<T> Constructor(DocumentBase<T>)

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Constructor(DocumentBase<T>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > PagesCollection<T> Constructor : PagesCollection<T> Constructor(DocumentBase<T>)

document
The document.

Glossary Item Box

Initializes a new instance of the PagesCollection<T> class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal document As DocumentBase(Of T) _
)
C#
public PagesCollection<T>(
   DocumentBase<T> document
)

Parameters

document
The document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


PagesCollection<T> Class Methods

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : PagesCollection<T> Class

Glossary Item Box

For a list of all members of this type, see PagesCollection<T> members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new item into the cache.
Public Method | AddRange | Overloaded. Adds the elements of an array of pages to the end of the pages collection.
Public Method | Clear | Removes all the page objects from the page collection.
Public Method | Clone | Performs a cloning of this instance.
Public Method | Contains | Overloaded. Determines whether the System.Collections.IList contains a specific value.
Public Method | CopyTo | Overloaded. Copies the elements of the System.Collections.ICollection to an System.Array, starting at a given System.Array index.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | IndexOf | Overloaded. Gets the index of a specific item in the System.Collections.IList.
Public Method | Insert | Overloaded. Inserts an item to the System.Collections.IList at the specified index.
Public Method | InsertNew | Inserts a new page element into the pages collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts the elements from page collections objects into the pages collection at the specified index.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.IList.
Public Method | RemoveAt | Removes item by index.
Top

See Also

Reference

PagesCollection<T> Class
GrapeCity.ActiveReports.Core.Document Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Add Method

Glossary Item Box

Adds a new item into the cache.

Overload List

Overload | Description
Add(Object) | Adds an item to the System.Collections.IList.
Add(T) | Adds a page object to the end of the pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Add(Object) Method

[image]
ActiveReports 19 .NET Edition
Add(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Add Method : Add(Object) Method

value
The System.Object to add to the System.Collections.IList.

Glossary Item Box

Adds an item to the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As Object _
) As Integer
C#
public int Add(
   object value
)

Parameters

value
The System.Object to add to the System.Collections.IList.

Return Value

The position into which the new element was inserted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Add(T) Method

[image]
ActiveReports 19 .NET Edition
Add(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Add Method : Add(T) Method

value
An item to add.

Glossary Item Box

Adds a page object to the end of the pages collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As T _
) As Integer
C#
public int Add(
   T value
)

Parameters

value
An item to add.

Return Value

The position into which the new item was inserted

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when value is null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : AddRange Method

Glossary Item Box

Adds the elements of an array of pages to the end of the pages collection.

Overload List

Overload | Description
AddRange(T[]) | Adds the elements of an array of pages to the end of the pages collection.
AddRange(PagesCollection<T>) | Adds the elements of pages collection to the end of the pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


AddRange(T[]) Method

[image]
ActiveReports 19 .NET Edition
AddRange(T[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > AddRange Method : AddRange(T[]) Method

pages
The pages to add.

Glossary Item Box

Adds the elements of an array of pages to the end of the pages collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal pages() As T _
)
C#
public void AddRange(
   T[] pages
)

Parameters

pages
The pages to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


AddRange(PagesCollection<T>) Method

[image]
ActiveReports 19 .NET Edition
AddRange(PagesCollection<T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > AddRange Method : AddRange(PagesCollection<T>) Method

pages
The pages collection to add.

Glossary Item Box

Adds the elements of pages collection to the end of the pages collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal pages As PagesCollection(Of T) _
)
C#
public void AddRange(
   PagesCollection<T> pages
)

Parameters

pages
The pages collection to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Clear Method

Glossary Item Box

Removes all the page objects from the page collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
C#
public virtual object Clone()

Return Value

Returns the cloned PagesCollection<T> instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Contains Method

Glossary Item Box

Determines whether the System.Collections.IList contains a specific value.

Overload List

Overload | Description
Contains(Object) | Determines whether the System.Collections.IList contains a specific value.
Contains(T) | Determines whether a page element is in the PagesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Contains(Object) Method

[image]
ActiveReports 19 .NET Edition
Contains(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Contains Method : Contains(Object) Method

value
The System.Object to locate in the System.Collections.IList.

Glossary Item Box

Determines whether the System.Collections.IList contains a specific value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
The System.Object to locate in the System.Collections.IList.

Return Value

true if the System.Object is found in the System.Collections.IList; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Contains(T) Method

[image]
ActiveReports 19 .NET Edition
Contains(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Contains Method : Contains(T) Method

value
A page to be found in the collection.

Glossary Item Box

Determines whether a page element is in the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As T _
) As Boolean
C#
public bool Contains(
   T value
)

Parameters

value
A page to be found in the collection.

Return Value

The value is true if the item parameter is found in the collection; otherwise, the value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : CopyTo Method

Glossary Item Box

Copies the elements of the System.Collections.ICollection to an System.Array, starting at a given System.Array index.

Overload List

Overload | Description
CopyTo(Array,Int32) | Copies the elements of the System.Collections.ICollection to an System.Array, starting at a given System.Array index.
CopyTo(T[],Int32) | Copies an array of page objects to the pages collection from the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


CopyTo(Array,Int32) Method

[image]
ActiveReports 19 .NET Edition
CopyTo(Array,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > CopyTo Method : CopyTo(Array,Int32) Method

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the elements of the System.Collections.ICollection to an System.Array, starting at a given System.Array index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


CopyTo(T[],Int32) Method

[image]
ActiveReports 19 .NET Edition
CopyTo(T[],Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > CopyTo Method : CopyTo(T[],Int32) Method

values
The array to which it is copied.
index
The zero-based index in values at which copying begins.

Glossary Item Box

Copies an array of page objects to the pages collection from the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal values() As T, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   T[] values,
   int index
)

Parameters

values
The array to which it is copied.
index
The zero-based index in values at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : IndexOf Method

Glossary Item Box

Gets the index of a specific item in the System.Collections.IList.

Overload List

Overload | Description
IndexOf(Object) | Gets the index of a specific item in the System.Collections.IList.
IndexOf(T) | Returns the zero-based index of the first occurrence of the page object in the pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


IndexOf(Object) Method

[image]
ActiveReports 19 .NET Edition
IndexOf(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > IndexOf Method : IndexOf(Object) Method

value
The System.Object to locate in the System.Collections.IList.

Glossary Item Box

Gets the index of a specific item in the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value
The System.Object to locate in the System.Collections.IList.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


IndexOf(T) Method

[image]
ActiveReports 19 .NET Edition
IndexOf(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > IndexOf Method : IndexOf(T) Method

value
An object to search for in the collection.

Glossary Item Box

Returns the zero-based index of the first occurrence of the page object in the pages collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As T _
) As Integer
C#
public int IndexOf(
   T value
)

Parameters

value
An object to search for in the collection.

Return Value

Index (zero-based) of the first occurrence of the item if it is found in the collection; otherwise -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Insert Method

Glossary Item Box

Inserts an item to the System.Collections.IList at the specified index.

Overload List

Overload | Description
Insert(Int32,Object) | Inserts an item to the System.Collections.IList at the specified index.
Insert(Int32,T) | Inserts a page element into the pages collection at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Insert(Int32,Object) Method

[image]
ActiveReports 19 .NET Edition
Insert(Int32,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Insert Method : Insert(Int32,Object) Method

index
The zero-based index at which value should be inserted.
value
The System.Object to insert into the System.Collections.IList.

Glossary Item Box

Inserts an item to the System.Collections.IList at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index at which value should be inserted.
value
The System.Object to insert into the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Insert(Int32,T) Method

[image]
ActiveReports 19 .NET Edition
Insert(Int32,T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Insert Method : Insert(Int32,T) Method

index
The index.
value
The value.

Glossary Item Box

Inserts a page element into the pages collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal value As T _
)
C#
public void Insert(
   int index,
   T value
)

Parameters

index
The index.
value
The value.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs if the value is null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


InsertNew Method

[image]
ActiveReports 19 .NET Edition
InsertNew Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : InsertNew Method

index
The index.

Glossary Item Box

Inserts a new page element into the pages collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Function InsertNew( _
   ByVal index As Integer _
) As T
C#
public T InsertNew(
   int index
)

Parameters

index
The index.

Return Value

Returns the added page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


InsertRange Method

[image]
ActiveReports 19 .NET Edition
InsertRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : InsertRange Method

Glossary Item Box

Inserts the elements from page collections objects into the pages collection at the specified index.

Overload List

Overload | Description
InsertRange(Int32,PagesCollection<T>) | Inserts the elements from page collections objects into the pages collection at the specified index.
InsertRange(Int32,T[]) | Inserts the elements from an array of page objects into the pages collection at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


InsertRange(Int32,PagesCollection<T>) Method

[image]
ActiveReports 19 .NET Edition
InsertRange(Int32,PagesCollection<T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > InsertRange Method : InsertRange(Int32,PagesCollection<T>) Method

index
The index.
pages
The pages collection.

Glossary Item Box

Inserts the elements from page collections objects into the pages collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertRange( _
   ByVal index As Integer, _
   ByVal pages As PagesCollection(Of T) _
)
C#
public void InsertRange(
   int index,
   PagesCollection<T> pages
)

Parameters

index
The index.
pages
The pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


InsertRange(Int32,T[]) Method

[image]
ActiveReports 19 .NET Edition
InsertRange(Int32,T[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > InsertRange Method : InsertRange(Int32,T[]) Method

index
The index.
pages
The pages.

Glossary Item Box

Inserts the elements from an array of page objects into the pages collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertRange( _
   ByVal index As Integer, _
   ByVal pages() As T _
)
C#
public void InsertRange(
   int index,
   T[] pages
)

Parameters

index
The index.
pages
The pages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Remove Method

Glossary Item Box

Removes the first occurrence of a specific object from the System.Collections.IList.

Overload List

Overload | Description
Remove(Object) | Removes the first occurrence of a specific object from the System.Collections.IList.
Remove(T) | Removes the first occurrence of page object from the pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Remove(Object) Method

[image]
ActiveReports 19 .NET Edition
Remove(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Remove Method : Remove(Object) Method

value
The System.Object to remove from the System.Collections.IList.

Glossary Item Box

Removes the first occurrence of a specific object from the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal value As Object _
)
C#
public void Remove(
   object value
)

Parameters

value
The System.Object to remove from the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


Remove(T) Method

[image]
ActiveReports 19 .NET Edition
Remove(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class > Remove Method : Remove(T) Method

page
The page.

Glossary Item Box

Removes the first occurrence of page object from the pages collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal page As T _
)
C#
public void Remove(
   T page
)

Parameters

page
The page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members
Overload List


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : RemoveAt Method

index
The zero-based index of the item to remove.

Glossary Item Box

Removes item by index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


PagesCollection<T> Class Properties

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : PagesCollection<T> Class

Glossary Item Box

For a list of all members of this type, see PagesCollection<T> members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ICollection.
Public Property | Document | Gets the document.
Public Property | FileVersion | Gets the file version.
Public Property | Fonts | Gets the fonts collection.
Public Property | IsFixedSize | Gets whether the System.Collections.IList has a fixed size.
Public Property | IsReadOnly | Gets whether the System.Collections.IList is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).
Public Property | Item | Returns a Page object at specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the System.Collections.ICollection.
Top

See Also

Reference

PagesCollection<T> Class
GrapeCity.ActiveReports.Core.Document Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The ammount of items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Document Property

Glossary Item Box

Gets the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As IDocument(Of T)
C#
public IDocument<T> Document {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


FileVersion Property

[image]
ActiveReports 19 .NET Edition
FileVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : FileVersion Property

Glossary Item Box

Gets the file version.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileVersion As Nullable(Of Short)
C#
public Nullable<short> FileVersion {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Fonts Property

Glossary Item Box

Gets the fonts collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fonts As FontsCollection
C#
public FontsCollection Fonts {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


IsFixedSize Property

[image]
ActiveReports 19 .NET Edition
IsFixedSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : IsFixedSize Property

Glossary Item Box

Gets whether the System.Collections.IList has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

true if this instance is fixed size; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : IsReadOnly Property

Glossary Item Box

Gets whether the System.Collections.IList is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if this instance is read only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

true if this instance is synchronized; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Item Property

index
The index.

Glossary Item Box

Returns a Page object at specified index in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As T
C#
public T this[
   int index
]; {get;}

Parameters

index
The index.

Property Value

An instanse of the Page class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

The synchronize root.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


PagesCollection<T> Class Events

[image]
ActiveReports 19 .NET Edition
PagesCollection<T> Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : PagesCollection<T> Class

Glossary Item Box

For a list of all members of this type, see PagesCollection<T> members.

Public Events

 | Name | Description
Public Event | Changed | The event occurs when the item is changed.
Top

See Also

Reference

PagesCollection<T> Class
GrapeCity.ActiveReports.Core.Document Namespace


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Changed Event

Glossary Item Box

The event occurs when the item is changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As ChangedEventHandler
C#
public event ChangedEventHandler Changed

Remarks

This event should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


DeviceInfo Structure

[image]
ActiveReports 19 .NET Edition
DeviceInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DeviceInfo Structure

Glossary Item Box

Presents information on the drawing device.

Object Model

DeviceInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure DeviceInfo
   Inherits System.ValueType
C#
public struct DeviceInfo : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.DeviceInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Members
GrapeCity.ActiveReports.Core.Document Namespace


DeviceInfo Structure Members

[image]
ActiveReports 19 .NET Edition
DeviceInfo Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DeviceInfo Structure

Glossary Item Box

The following tables list the members exposed by DeviceInfo.

Public Constructors

 | Name | Description
Public Constructor | DeviceInfo Constructor | Initializes the DeviceInfo structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | Gets the default device information.
Top

Public Properties

 | Name | Description
Public Property | DpiX | Gets the dpi on the X axis.
Public Property | DpiY | Gets the dpi on the Y axis.
Public Property | PageScale | Gets the page scale.
Top

See Also

Reference

DeviceInfo Structure
GrapeCity.ActiveReports.Core.Document Namespace


DeviceInfo Constructor

[image]
ActiveReports 19 .NET Edition
DeviceInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DeviceInfo Structure : DeviceInfo Constructor

dpiX
The dpi X value.
dpiY
The dpi Y value.
pageScale
Page scale value.

Glossary Item Box

Initializes the DeviceInfo structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dpiX As Single, _
   ByVal dpiY As Single, _
   ByVal pageScale As Single _
)
C#
public DeviceInfo(
   float dpiX,
   float dpiY,
   float pageScale
)

Parameters

dpiX
The dpi X value.
dpiY
The dpi Y value.
pageScale
Page scale value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Structure
DeviceInfo Members


DeviceInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
DeviceInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DeviceInfo Structure

Glossary Item Box

For a list of all members of this type, see DeviceInfo members.

Public Properties

 | Name | Description
Public Property | DpiX | Gets the dpi on the X axis.
Public Property | DpiY | Gets the dpi on the Y axis.
Public Property | PageScale | Gets the page scale.
Top

See Also

Reference

DeviceInfo Structure
GrapeCity.ActiveReports.Core.Document Namespace


DpiX Property

[image]
ActiveReports 19 .NET Edition
DpiX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DeviceInfo Structure : DpiX Property

Glossary Item Box

Gets the dpi on the X axis.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiX As Single
C#
public float DpiX {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Structure
DeviceInfo Members


DpiY Property

[image]
ActiveReports 19 .NET Edition
DpiY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DeviceInfo Structure : DpiY Property

Glossary Item Box

Gets the dpi on the Y axis.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiY As Single
C#
public float DpiY {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Structure
DeviceInfo Members


PageScale Property

[image]
ActiveReports 19 .NET Edition
PageScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DeviceInfo Structure : PageScale Property

Glossary Item Box

Gets the page scale.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageScale As Single
C#
public float PageScale {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Structure
DeviceInfo Members


DeviceInfo Structure Fields

[image]
ActiveReports 19 .NET Edition
DeviceInfo Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : DeviceInfo Structure

Glossary Item Box

For a list of all members of this type, see DeviceInfo members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | Gets the default device information.
Top

See Also

Reference

DeviceInfo Structure
GrapeCity.ActiveReports.Core.Document Namespace


Default Field

[image]
ActiveReports 19 .NET Edition
Default Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DeviceInfo Structure : Default Field

Glossary Item Box

Gets the default device information.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As DeviceInfo
C#
public static readonly DeviceInfo Default

Remarks

This field should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceInfo Structure
DeviceInfo Members


ImageData Structure

[image]
ActiveReports 19 .NET Edition
ImageData Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : ImageData Structure

Glossary Item Box

Represents the data stream from which the image can be loaded and the format of the image.

Object Model

ImageData Structure

Syntax

Visual Basic (Declaration)
Public Structure ImageData
   Inherits System.ValueType
C#
public struct ImageData : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.ImageData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageData Members
GrapeCity.ActiveReports.Core.Document Namespace


ImageData Structure Members

[image]
ActiveReports 19 .NET Edition
ImageData Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : ImageData Structure

Glossary Item Box

The following tables list the members exposed by ImageData.

Public Constructors

 | Name | Description
Public Constructor | ImageData Constructor | Initializes an instance of ImageData structure.
Top

Public Fields

 | Name | Description
Public Field | ImageFormat | The image format field.
Public Field | MemoryStream | The memory stream field.
Top

See Also

Reference

ImageData Structure
GrapeCity.ActiveReports.Core.Document Namespace


ImageData Constructor

[image]
ActiveReports 19 .NET Edition
ImageData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > ImageData Structure : ImageData Constructor

memoryStream
The memory stream.
imageFormat
The image format.

Glossary Item Box

Initializes an instance of ImageData structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal memoryStream As MemoryStream, _
   ByVal imageFormat As ImageFormat _
)
C#
public ImageData(
   MemoryStream memoryStream,
   ImageFormat imageFormat
)

Parameters

memoryStream
The memory stream.
imageFormat
The image format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageData Structure
ImageData Members


ImageData Structure Fields

[image]
ActiveReports 19 .NET Edition
ImageData Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : ImageData Structure

Glossary Item Box

For a list of all members of this type, see ImageData members.

Public Fields

 | Name | Description
Public Field | ImageFormat | The image format field.
Public Field | MemoryStream | The memory stream field.
Top

See Also

Reference

ImageData Structure
GrapeCity.ActiveReports.Core.Document Namespace


ImageFormat Field

[image]
ActiveReports 19 .NET Edition
ImageFormat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > ImageData Structure : ImageFormat Field

Glossary Item Box

The image format field.

Syntax

Visual Basic (Declaration)
Public ReadOnly ImageFormat As ImageFormat
C#
public readonly ImageFormat ImageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageData Structure
ImageData Members


MemoryStream Field

[image]
ActiveReports 19 .NET Edition
MemoryStream Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > ImageData Structure : MemoryStream Field

Glossary Item Box

The memory stream field.

Syntax

Visual Basic (Declaration)
Public ReadOnly MemoryStream As MemoryStream
C#
public readonly MemoryStream MemoryStream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageData Structure
ImageData Members


TextLayoutParams Structure

[image]
ActiveReports 19 .NET Edition
TextLayoutParams Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutParams Structure

Glossary Item Box

Text layout parameters. Please ensure to specify WrapMode/EnableKinsoku/MultiLine to obtain right output.

Object Model

TextLayoutParams Structure

Syntax

Visual Basic (Declaration)
Public Structure TextLayoutParams
   Inherits System.ValueType
C#
public struct TextLayoutParams : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.TextLayoutParams

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Members
GrapeCity.ActiveReports.Core.Document Namespace


TextLayoutParams Structure Members

[image]
ActiveReports 19 .NET Edition
TextLayoutParams Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutParams Structure

Glossary Item Box

The following tables list the members exposed by TextLayoutParams.

Public Constructors

 | Name | Description
Public Constructor | TextLayoutParams Constructor | Initialize new instance of TextLayoutParams class.
Top

Public Fields

 | Name | Description
Public Field | HorizontalAlignment | Text alignment.
Public Field | VerticalAlignment | Lines alignment.
Top

Public Properties

 | Name | Description
Public Property | CharacterSpacing | Gets or sets character spacing in points.
Public Property | ClipHeight | Gets or sets the height of the Vertical clip position.
Public Property | ClipStart | Gets or sets the start of the vertical clip position.
Public Property | EnableKinsoku | Gets or sets whether to force Kinsoku rules (if supported).
Public Property | IsRtl | Gets or sets text direction.
Public Property | IsVertical | Gets or sets whether vertical glyphs are allowed or not.
Public Property | LineSpacing | Gets or sets line spacing in points.
Public Property | MultiLine | Gets or sets whether multiline is allowed or not.
Public Property | Padding | Gets or sets predefined padding in points.
Public Property | TabStops | Tabs.
Public Property | TextAngle | Gets or sets the text rotation in angels * 10.
Public Property | TextJustify | Gets or sets justification algorithm (in case of Justified text alignment).
Public Property | WrapMode | Gets or sets line breaking wrap mode.
Top

See Also

Reference

TextLayoutParams Structure
GrapeCity.ActiveReports.Core.Document Namespace


TextLayoutParams Constructor

[image]
ActiveReports 19 .NET Edition
TextLayoutParams Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : TextLayoutParams Constructor

horizontalAlignment
Text alignment
verticalAlignment
Lines alignment
textJustify
Justification algorithm
wrapMode
Line breaking wrap mode
enableKinsoku
Force Kinsoku rules
characterSpacing
Character spacing in points.
lineSpacing
Line spacing in points.
isRtl
Text direction.
textAngle
Text rotation in angels * 10.
isVertical
Vertical glyphs are allowed or not.
multiLine
Multiline is allowed or not.

Glossary Item Box

Initialize new instance of TextLayoutParams class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   Optional ByVal horizontalAlignment As TextAlignment, _
   Optional ByVal verticalAlignment As VerticalTextAlignment, _
   Optional ByVal textJustify As TextJustify, _
   Optional ByVal wrapMode As WrapMode, _
   Optional ByVal enableKinsoku As Boolean, _
   Optional ByVal characterSpacing As Single, _
   Optional ByVal lineSpacing As Single, _
   Optional ByVal isRtl As Boolean, _
   Optional ByVal textAngle As Single, _
   Optional ByVal isVertical As Boolean, _
   Optional ByVal multiLine As Boolean _
)
C#
public TextLayoutParams(
   TextAlignment horizontalAlignment,
   VerticalTextAlignment verticalAlignment,
   TextJustify textJustify,
   WrapMode wrapMode,
   bool enableKinsoku,
   float characterSpacing,
   float lineSpacing,
   bool isRtl,
   float textAngle,
   bool isVertical,
   bool multiLine
)

Parameters

horizontalAlignment
Text alignment
verticalAlignment
Lines alignment
textJustify
Justification algorithm
wrapMode
Line breaking wrap mode
enableKinsoku
Force Kinsoku rules
characterSpacing
Character spacing in points.
lineSpacing
Line spacing in points.
isRtl
Text direction.
textAngle
Text rotation in angels * 10.
isVertical
Vertical glyphs are allowed or not.
multiLine
Multiline is allowed or not.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TextLayoutParams Structure Properties

[image]
ActiveReports 19 .NET Edition
TextLayoutParams Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutParams Structure

Glossary Item Box

For a list of all members of this type, see TextLayoutParams members.

Public Properties

 | Name | Description
Public Property | CharacterSpacing | Gets or sets character spacing in points.
Public Property | ClipHeight | Gets or sets the height of the Vertical clip position.
Public Property | ClipStart | Gets or sets the start of the vertical clip position.
Public Property | EnableKinsoku | Gets or sets whether to force Kinsoku rules (if supported).
Public Property | IsRtl | Gets or sets text direction.
Public Property | IsVertical | Gets or sets whether vertical glyphs are allowed or not.
Public Property | LineSpacing | Gets or sets line spacing in points.
Public Property | MultiLine | Gets or sets whether multiline is allowed or not.
Public Property | Padding | Gets or sets predefined padding in points.
Public Property | TabStops | Tabs.
Public Property | TextAngle | Gets or sets the text rotation in angels * 10.
Public Property | TextJustify | Gets or sets justification algorithm (in case of Justified text alignment).
Public Property | WrapMode | Gets or sets line breaking wrap mode.
Top

See Also

Reference

TextLayoutParams Structure
GrapeCity.ActiveReports.Core.Document Namespace


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : CharacterSpacing Property

Glossary Item Box

Gets or sets character spacing in points.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


ClipHeight Property

[image]
ActiveReports 19 .NET Edition
ClipHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : ClipHeight Property

Glossary Item Box

Gets or sets the height of the Vertical clip position.

Syntax

Visual Basic (Declaration)
Public Property ClipHeight As Single
C#
public float ClipHeight {get; set;}

Remarks

Allowed values from 0 to 'height' for line trimming

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


ClipStart Property

[image]
ActiveReports 19 .NET Edition
ClipStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : ClipStart Property

Glossary Item Box

Gets or sets the start of the vertical clip position.

Syntax

Visual Basic (Declaration)
Public Property ClipStart As Single
C#
public float ClipStart {get; set;}

Remarks

Allowed values from 0 to 'height' for line trimming

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


EnableKinsoku Property

[image]
ActiveReports 19 .NET Edition
EnableKinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : EnableKinsoku Property

Glossary Item Box

Gets or sets whether to force Kinsoku rules (if supported).

Syntax

Visual Basic (Declaration)
Public Property EnableKinsoku As Boolean
C#
public bool EnableKinsoku {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


IsRtl Property

[image]
ActiveReports 19 .NET Edition
IsRtl Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : IsRtl Property

Glossary Item Box

Gets or sets text direction.

Syntax

Visual Basic (Declaration)
Public Property IsRtl As Boolean
C#
public bool IsRtl {get; set;}

Property Value

True if text is right-to-left

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


IsVertical Property

[image]
ActiveReports 19 .NET Edition
IsVertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : IsVertical Property

Glossary Item Box

Gets or sets whether vertical glyphs are allowed or not.

Syntax

Visual Basic (Declaration)
Public Property IsVertical As Boolean
C#
public bool IsVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : LineSpacing Property

Glossary Item Box

Gets or sets line spacing in points.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : MultiLine Property

Glossary Item Box

Gets or sets whether multiline is allowed or not.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Remarks

Default value - False

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : Padding Property

Glossary Item Box

Gets or sets predefined padding in points.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : TabStops Property

Glossary Item Box

Tabs.

Syntax

Visual Basic (Declaration)
Public Property TabStops As TabStopsItem.TabStop()
C#
public TabStopsItem.TabStop[] TabStops {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TextAngle Property

[image]
ActiveReports 19 .NET Edition
TextAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : TextAngle Property

Glossary Item Box

Gets or sets the text rotation in angels * 10.

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Single
C#
public float TextAngle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : TextJustify Property

Glossary Item Box

Gets or sets justification algorithm (in case of Justified text alignment).

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : WrapMode Property

Glossary Item Box

Gets or sets line breaking wrap mode.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.WrapMode

Remarks

Default value is GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TextLayoutParams Structure Fields

[image]
ActiveReports 19 .NET Edition
TextLayoutParams Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutParams Structure

Glossary Item Box

For a list of all members of this type, see TextLayoutParams members.

Public Fields

 | Name | Description
Public Field | HorizontalAlignment | Text alignment.
Public Field | VerticalAlignment | Lines alignment.
Top

See Also

Reference

TextLayoutParams Structure
GrapeCity.ActiveReports.Core.Document Namespace


HorizontalAlignment Field

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : HorizontalAlignment Field

Glossary Item Box

Text alignment.

Syntax

Visual Basic (Declaration)
Public HorizontalAlignment As TextAlignment
C#
public TextAlignment HorizontalAlignment

Field Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.TextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


VerticalAlignment Field

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutParams Structure : VerticalAlignment Field

Glossary Item Box

Lines alignment.

Syntax

Visual Basic (Declaration)
Public VerticalAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalAlignment

Field Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutParams Structure
TextLayoutParams Members


TextLayoutResult Structure

[image]
ActiveReports 19 .NET Edition
TextLayoutResult Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutResult Structure

Glossary Item Box

Represents text layout result.

Object Model

TextLayoutResult Structure

Syntax

Visual Basic (Declaration)
Public Structure TextLayoutResult
   Inherits System.ValueType
C#
public struct TextLayoutResult : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.TextLayoutResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutResult Members
GrapeCity.ActiveReports.Core.Document Namespace


TextLayoutResult Structure Members

[image]
ActiveReports 19 .NET Edition
TextLayoutResult Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutResult Structure

Glossary Item Box

The following tables list the members exposed by TextLayoutResult.

Public Constructors

 | Name | Description
Public Constructor | TextLayoutResult Constructor | Initialize new instance of TextLayoutResult class.
Top

Public Properties

 | Name | Description
Public Property | LogicalStrings | Logical strings for justify alignment algorithms. Null otherwise.
Public Property | Size | Result size in inches.
Public Property | Strings | Text lines after text layout.
Top

See Also

Reference

TextLayoutResult Structure
GrapeCity.ActiveReports.Core.Document Namespace


TextLayoutResult Constructor

[image]
ActiveReports 19 .NET Edition
TextLayoutResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutResult Structure : TextLayoutResult Constructor

strings
Text lines after text layout.
size
Result size in inches
logicalStrings
Logical strings for justify alignment algorithms. Null otherwise.

Glossary Item Box

Initialize new instance of TextLayoutResult class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strings() As String, _
   ByVal size As SizeF, _
   Optional ByVal logicalStrings() As String _
)
C#
public TextLayoutResult(
   string[] strings,
   SizeF size,
   string[] logicalStrings
)

Parameters

strings
Text lines after text layout.
size
Result size in inches
logicalStrings
Logical strings for justify alignment algorithms. Null otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutResult Structure
TextLayoutResult Members


TextLayoutResult Structure Properties

[image]
ActiveReports 19 .NET Edition
TextLayoutResult Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : TextLayoutResult Structure

Glossary Item Box

For a list of all members of this type, see TextLayoutResult members.

Public Properties

 | Name | Description
Public Property | LogicalStrings | Logical strings for justify alignment algorithms. Null otherwise.
Public Property | Size | Result size in inches.
Public Property | Strings | Text lines after text layout.
Top

See Also

Reference

TextLayoutResult Structure
GrapeCity.ActiveReports.Core.Document Namespace


LogicalStrings Property

[image]
ActiveReports 19 .NET Edition
LogicalStrings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutResult Structure : LogicalStrings Property

Glossary Item Box

Logical strings for justify alignment algorithms. Null otherwise.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogicalStrings As String()
C#
public string[] LogicalStrings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutResult Structure
TextLayoutResult Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutResult Structure : Size Property

Glossary Item Box

Result size in inches.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
C#
public SizeF Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutResult Structure
TextLayoutResult Members


Strings Property

[image]
ActiveReports 19 .NET Edition
Strings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > TextLayoutResult Structure : Strings Property

Glossary Item Box

Text lines after text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Strings As String()
C#
public string[] Strings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextLayoutResult Structure
TextLayoutResult Members


IDocument<T> Interface

T
Page Type
[image]
ActiveReports 19 .NET Edition
IDocument<T> Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IDocument<T> Interface

Glossary Item Box

Represents the document interface

Syntax

Visual Basic (Declaration)
Public Interface IDocument(Of T As {New, Page})
C#
public interface IDocument<T>
where T: new(), Page

Type Parameters

T
Page Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Members
GrapeCity.ActiveReports.Core.Document Namespace


IDocument<T> Interface Members

[image]
ActiveReports 19 .NET Edition
IDocument<T> Interface Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IDocument<T> Interface

Glossary Item Box

The following tables list the members exposed by IDocument<T>.

Public Properties

 | Name | Description
Property | CacheToDiskEnabled | Gets whether this make the pages collection should use a temp file for the canvas item streams
Property | CacheToDiskLocation | Gets or sets Specifies location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.
Property | DocumentVersion | Gets the document version.
Property | InProgress | Gets or sets whether the document is currently loaded.
Property | Name | Gets or sets the name.
Property | Pages | Gets a reference to the document's page.
Property | Password | Gets or sets a password to protect the saved document file.
Property | UserPreferences | Gets or sets the user preferences.
Top

Public Methods

 | Name | Description
Method | Save | Overloaded. Saves document to the specified System.IO.Stream.
Top

Public Events

 | Name | Description
Event | StateChanged | Event that occurs when the state is changed.
Top

See Also

Reference

IDocument<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


IDocument<T> Interface Methods

[image]
ActiveReports 19 .NET Edition
IDocument<T> Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IDocument<T> Interface

Glossary Item Box

For a list of all members of this type, see IDocument<T> members.

Public Methods

 | Name | Description
Method | Save | Overloaded. Saves document to the specified System.IO.Stream.
Top

See Also

Reference

IDocument<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : Save Method

Glossary Item Box

Saves document to the specified System.IO.Stream.

Overload List

Overload | Description
Save(Stream,RdfFormat) | Saves document to the specified System.IO.Stream.
Save(Stream,RdfFormat,SaveOptions) | Saves document to the specified System.IO.Stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


Save(Stream,RdfFormat) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream,RdfFormat) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface > Save Method : Save(Stream,RdfFormat) Method

stream
The stream.
fmt
The format.

Glossary Item Box

Saves document to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat _
)
C#
void Save(
   Stream stream,
   RdfFormat fmt
)

Parameters

stream
The stream.
fmt
The format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members
Overload List


Save(Stream,RdfFormat,SaveOptions) Method

[image]
ActiveReports 19 .NET Edition
Save(Stream,RdfFormat,SaveOptions) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface > Save Method : Save(Stream,RdfFormat,SaveOptions) Method

stream
The stream.
fmt
The format.
options
The options.

Glossary Item Box

Saves document to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
C#
void Save(
   Stream stream,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

stream
The stream.
fmt
The format.
options
The options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members
Overload List


IDocument<T> Interface Properties

[image]
ActiveReports 19 .NET Edition
IDocument<T> Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IDocument<T> Interface

Glossary Item Box

For a list of all members of this type, see IDocument<T> members.

Public Properties

 | Name | Description
Property | CacheToDiskEnabled | Gets whether this make the pages collection should use a temp file for the canvas item streams
Property | CacheToDiskLocation | Gets or sets Specifies location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.
Property | DocumentVersion | Gets the document version.
Property | InProgress | Gets or sets whether the document is currently loaded.
Property | Name | Gets or sets the name.
Property | Pages | Gets a reference to the document's page.
Property | Password | Gets or sets a password to protect the saved document file.
Property | UserPreferences | Gets or sets the user preferences.
Top

See Also

Reference

IDocument<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


CacheToDiskEnabled Property

[image]
ActiveReports 19 .NET Edition
CacheToDiskEnabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : CacheToDiskEnabled Property

Glossary Item Box

Gets whether this make the pages collection should use a temp file for the canvas item streams

Syntax

Visual Basic (Declaration)
ReadOnly Property CacheToDiskEnabled As Boolean
C#
bool CacheToDiskEnabled {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


CacheToDiskLocation Property

[image]
ActiveReports 19 .NET Edition
CacheToDiskLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : CacheToDiskLocation Property

Glossary Item Box

Gets or sets Specifies location of CacheToDisk files - can be physical path or "IsolatedStorage" to use IsolatedStorage.

Syntax

Visual Basic (Declaration)
Property CacheToDiskLocation As String
C#
string CacheToDiskLocation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


DocumentVersion Property

[image]
ActiveReports 19 .NET Edition
DocumentVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : DocumentVersion Property

Glossary Item Box

Gets the document version.

Syntax

Visual Basic (Declaration)
ReadOnly Property DocumentVersion As Short
C#
short DocumentVersion {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


InProgress Property

[image]
ActiveReports 19 .NET Edition
InProgress Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : InProgress Property

Glossary Item Box

Gets or sets whether the document is currently loaded.

Syntax

Visual Basic (Declaration)
Property InProgress As Boolean
C#
bool InProgress {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : Name Property

Glossary Item Box

Gets or sets the name.

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : Pages Property

Glossary Item Box

Gets a reference to the document's page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pages As IPagesCollection(Of T)
C#
IPagesCollection<T> Pages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : Password Property

Glossary Item Box

Gets or sets a password to protect the saved document file.

Syntax

Visual Basic (Declaration)
Property Password As String
C#
string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


UserPreferences Property

[image]
ActiveReports 19 .NET Edition
UserPreferences Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : UserPreferences Property

Glossary Item Box

Gets or sets the user preferences.

Syntax

Visual Basic (Declaration)
ReadOnly Property UserPreferences As UserPreferences
C#
UserPreferences UserPreferences {get;}

Property Value

The user preferences.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


IDocument<T> Interface Events

[image]
ActiveReports 19 .NET Edition
IDocument<T> Interface Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IDocument<T> Interface

Glossary Item Box

For a list of all members of this type, see IDocument<T> members.

Public Events

 | Name | Description
Event | StateChanged | Event that occurs when the state is changed.
Top

See Also

Reference

IDocument<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


StateChanged Event

[image]
ActiveReports 19 .NET Edition
StateChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : StateChanged Event

Glossary Item Box

Event that occurs when the state is changed.

Syntax

Visual Basic (Declaration)
Event StateChanged As StateChangedHandler
C#
event StateChangedHandler StateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


IImageConverterService Interface

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IImageConverterService Interface

Glossary Item Box

Represents service that converts image data from one format to another.

Syntax

Visual Basic (Declaration)
Public Interface IImageConverterService
C#
public interface IImageConverterService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageConverterService Members
GrapeCity.ActiveReports.Core.Document Namespace


IImageConverterService Interface Members

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IImageConverterService Interface

Glossary Item Box

The following tables list the members exposed by IImageConverterService.

Public Methods

 | Name | Description
Method | Convert | Converts image to one of allowed image format if needed.
Top

See Also

Reference

IImageConverterService Interface
GrapeCity.ActiveReports.Core.Document Namespace


IImageConverterService Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IImageConverterService Interface

Glossary Item Box

For a list of all members of this type, see IImageConverterService members.

Public Methods

 | Name | Description
Method | Convert | Converts image to one of allowed image format if needed.
Top

See Also

Reference

IImageConverterService Interface
GrapeCity.ActiveReports.Core.Document Namespace


Convert Method

[image]
ActiveReports 19 .NET Edition
Convert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IImageConverterService Interface : Convert Method

imageStream
A stream that contains the image data.
allowedFormats
Allowed image formats. The conversion will not be performed if the image have one of these formats.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Glossary Item Box

Converts image to one of allowed image format if needed.

Syntax

Visual Basic (Declaration)
Function Convert( _
   ByVal imageStream As MemoryStream, _
   ByVal allowedFormats() As ImageFormat, _
   ByVal fixRotation As Boolean _
) As ImageData
C#
ImageData Convert(
   MemoryStream imageStream,
   ImageFormat[] allowedFormats,
   bool fixRotation
)

Parameters

imageStream
A stream that contains the image data.
allowedFormats
Allowed image formats. The conversion will not be performed if the image have one of these formats.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Return Value

The ImageData struct which contains the data stream from which the image can be loaded and the format of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageConverterService Interface
IImageConverterService Members


IPagesCollection<T> Interface

T
Represents a class of type Page.
[image]
ActiveReports 19 .NET Edition
IPagesCollection<T> Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IPagesCollection<T> Interface

Glossary Item Box

Represents the pages collection.

Syntax

Visual Basic (Declaration)
Public Interface IPagesCollection(Of T As {New, Page})
C#
public interface IPagesCollection<T>
where T: new(), Page

Type Parameters

T
Represents a class of type Page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Members
GrapeCity.ActiveReports.Core.Document Namespace


IPagesCollection<T> Interface Members

[image]
ActiveReports 19 .NET Edition
IPagesCollection<T> Interface Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IPagesCollection<T> Interface

Glossary Item Box

The following tables list the members exposed by IPagesCollection<T>.

Public Properties

 | Name | Description
Property | Document | Gets the document.
Property | Fonts | Gets the font collection of texts of pages.
Top

Public Events

 | Name | Description
Event | Changed | The change event.
Event | FetchItem | The item fetch event.
Top

See Also

Reference

IPagesCollection<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


IPagesCollection<T> Interface Properties

[image]
ActiveReports 19 .NET Edition
IPagesCollection<T> Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IPagesCollection<T> Interface

Glossary Item Box

For a list of all members of this type, see IPagesCollection<T> members.

Public Properties

 | Name | Description
Property | Document | Gets the document.
Property | Fonts | Gets the font collection of texts of pages.
Top

See Also

Reference

IPagesCollection<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


Document Property

[image]
ActiveReports 19 .NET Edition
Document Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Document Property

Glossary Item Box

Gets the document.

Syntax

Visual Basic (Declaration)
ReadOnly Property Document As IDocument(Of T)
C#
IDocument<T> Document {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Fonts Property

Glossary Item Box

Gets the font collection of texts of pages.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fonts As FontsCollection
C#
FontsCollection Fonts {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


IPagesCollection<T> Interface Events

[image]
ActiveReports 19 .NET Edition
IPagesCollection<T> Interface Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IPagesCollection<T> Interface

Glossary Item Box

For a list of all members of this type, see IPagesCollection<T> members.

Public Events

 | Name | Description
Event | Changed | The change event.
Event | FetchItem | The item fetch event.
Top

See Also

Reference

IPagesCollection<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Changed Event

Glossary Item Box

The change event.

Syntax

Visual Basic (Declaration)
Event Changed As ChangedEventHandler
C#
event ChangedEventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


FetchItem Event

[image]
ActiveReports 19 .NET Edition
FetchItem Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : FetchItem Event

Glossary Item Box

The item fetch event.

Syntax

Visual Basic (Declaration)
Event FetchItem As EventHandler
C#
event EventHandler FetchItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


ChangedEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
ChangedEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : ChangedEventHandler Delegate

sender
e

Glossary Item Box

The change event handler.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void ChangedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
e

Remarks

This delegate should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangedEventHandler Members
GrapeCity.ActiveReports.Core.Document Namespace


LoadCompletedEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
LoadCompletedEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : LoadCompletedEventHandler Delegate

sender
The sender.
e
The System.EventArgs instance containing the event data.

Glossary Item Box

Event occurs when load completed.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LoadCompletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void LoadCompletedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
The sender.
e
The System.EventArgs instance containing the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoadCompletedEventHandler Members
GrapeCity.ActiveReports.Core.Document Namespace


StateChangedHandler Delegate

[image]
ActiveReports 19 .NET Edition
StateChangedHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : StateChangedHandler Delegate

sender
The sender.
e
The arguments.

Glossary Item Box

Event occurs when state changes.

Syntax

Visual Basic (Declaration)
Public Delegate Sub StateChangedHandler( _
   ByVal sender As Object, _
   ByVal e As StateChangedArgs _
)
C#
public delegate void StateChangedHandler(
   object sender,
   StateChangedArgs e
)

Parameters

sender
The sender.
e
The arguments.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedHandler Members
GrapeCity.ActiveReports.Core.Document Namespace


ZlibExtensions Class

[image]
ActiveReports 19 .NET Edition
ZlibExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace : ZlibExtensions Class

Glossary Item Box

Used to compress/decompress simple zlib stream (without structure).

Object Model

ZlibExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ZlibExtensions
C#
public static class ZlibExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib.ZlibExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZlibExtensions Members
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace


ZlibExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ZlibExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace : ZlibExtensions Class

Glossary Item Box

The following tables list the members exposed by ZlibExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compress | Compress stream.
static (Shared in Visual Basic) | DeCompress | Decompress stream.
Top

See Also

Reference

ZlibExtensions Class
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace


ZlibExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ZlibExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace : ZlibExtensions Class

Glossary Item Box

For a list of all members of this type, see ZlibExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compress | Compress stream.
static (Shared in Visual Basic) | DeCompress | Decompress stream.
Top

See Also

Reference

ZlibExtensions Class
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace


Compress Method

[image]
ActiveReports 19 .NET Edition
Compress Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace > ZlibExtensions Class : Compress Method

inStream
The memory stream that is subject to compression.

Glossary Item Box

Compress stream.

Syntax

Visual Basic (Declaration)
Public Shared Function Compress( _
   ByVal inStream As MemoryStream _
) As MemoryStream
C#
public static MemoryStream Compress(
   MemoryStream inStream
)

Parameters

inStream
The memory stream that is subject to compression.

Return Value

Returns the compressed stream.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZlibExtensions Class
ZlibExtensions Members


DeCompress Method

[image]
ActiveReports 19 .NET Edition
DeCompress Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace > ZlibExtensions Class : DeCompress Method

inStream
The memory stream that is subject to decompression.

Glossary Item Box

Decompress stream.

Syntax

Visual Basic (Declaration)
Public Shared Function DeCompress( _
   ByVal inStream As MemoryStream _
) As MemoryStream
C#
public static MemoryStream DeCompress(
   MemoryStream inStream
)

Parameters

inStream
The memory stream that is subject to decompression.

Return Value

Returns the decompressed stream.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZlibExtensions Class
ZlibExtensions Members


BorderLine Class

[image]
ActiveReports 19 .NET Edition
BorderLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : BorderLine Class

Glossary Item Box

Represents the border line.

Object Model

BorderLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BorderLine
C#
public sealed class BorderLine

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Utility.BorderLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Members
GrapeCity.ActiveReports.Core.Document.Utility Namespace


BorderLine Class Members

[image]
ActiveReports 19 .NET Edition
BorderLine Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : BorderLine Class

Glossary Item Box

The following tables list the members exposed by BorderLine.

Public Constructors

 | Name | Description
Public Constructor | BorderLine Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets hte color.
Public Property | EndPoint | Gets or sets the end point.
Public Property | StartPoint | Gets or sets the start point.
Public Property | Style | Gets or sets the dash style.
Public Property | Thickness | Gets or sets the thickness.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

BorderLine Class
GrapeCity.ActiveReports.Core.Document.Utility Namespace


BorderLine Constructor

[image]
ActiveReports 19 .NET Edition
BorderLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : BorderLine Constructor

Glossary Item Box

Overload List

Overload | Description
BorderLine Constructor() | Initializes a new instance of the BorderLine class.
BorderLine Constructor(DashStyle,Single,Color,PointF,PointF) | Initializes a new instance of the BorderLine class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


BorderLine Constructor()

[image]
ActiveReports 19 .NET Edition
BorderLine Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class > BorderLine Constructor : BorderLine Constructor()

Glossary Item Box

Initializes a new instance of the BorderLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members
Overload List


BorderLine Constructor(DashStyle,Single,Color,PointF,PointF)

[image]
ActiveReports 19 .NET Edition
BorderLine Constructor(DashStyle,Single,Color,PointF,PointF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class > BorderLine Constructor : BorderLine Constructor(DashStyle,Single,Color,PointF,PointF)

style
The style of the line. For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.Drawing2D.DashStyle
thickness
The thickness of the line.
color
The color of the line.
ptStart
The start point of the line.
ptEnd
The end point of the line.

Glossary Item Box

Initializes a new instance of the BorderLine class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As DashStyle, _
   ByVal thickness As Single, _
   ByVal color As Color, _
   ByVal ptStart As PointF, _
   ByVal ptEnd As PointF _
)
C#
public BorderLine(
   DashStyle style,
   float thickness,
   Color color,
   PointF ptStart,
   PointF ptEnd
)

Parameters

style
The style of the line. For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.Drawing2D.DashStyle
thickness
The thickness of the line.
color
The color of the line.
ptStart
The start point of the line.
ptEnd
The end point of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members
Overload List


BorderLine Class Methods

[image]
ActiveReports 19 .NET Edition
BorderLine Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : BorderLine Class

Glossary Item Box

For a list of all members of this type, see BorderLine members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

BorderLine Class
GrapeCity.ActiveReports.Core.Document.Utility Namespace


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


BorderLine Class Properties

[image]
ActiveReports 19 .NET Edition
BorderLine Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : BorderLine Class

Glossary Item Box

For a list of all members of this type, see BorderLine members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets hte color.
Public Property | EndPoint | Gets or sets the end point.
Public Property | StartPoint | Gets or sets the start point.
Public Property | Style | Gets or sets the dash style.
Public Property | Thickness | Gets or sets the thickness.
Top

See Also

Reference

BorderLine Class
GrapeCity.ActiveReports.Core.Document.Utility Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : Color Property

Glossary Item Box

Gets or sets hte color.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Remarks

Default value is Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


EndPoint Property

[image]
ActiveReports 19 .NET Edition
EndPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : EndPoint Property

Glossary Item Box

Gets or sets the end point.

Syntax

Visual Basic (Declaration)
Public Property EndPoint As PointF
C#
public PointF EndPoint {get; set;}

Property Value

A System.Drawing.PointF that represents the end point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


StartPoint Property

[image]
ActiveReports 19 .NET Edition
StartPoint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : StartPoint Property

Glossary Item Box

Gets or sets the start point.

Syntax

Visual Basic (Declaration)
Public Property StartPoint As PointF
C#
public PointF StartPoint {get; set;}

Property Value

A System.Drawing.PointF that represents the start point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : Style Property

Glossary Item Box

Gets or sets the dash style.

Syntax

Visual Basic (Declaration)
Public Property Style As DashStyle
C#
public DashStyle Style {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.Drawing2D.DashStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


Thickness Property

[image]
ActiveReports 19 .NET Edition
Thickness Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > BorderLine Class : Thickness Property

Glossary Item Box

Gets or sets the thickness.

Syntax

Visual Basic (Declaration)
Public Property Thickness As Single
C#
public float Thickness {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderLine Class
BorderLine Members


ImageHelper Class

[image]
ActiveReports 19 .NET Edition
ImageHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper Class

Glossary Item Box

Contains platform-independent implementation of methods to extract image info from image stream.

Object Model

ImageHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ImageHelper
C#
public static class ImageHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Utility.ImageHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Members
GrapeCity.ActiveReports.Core.Document.Utility Namespace


ImageHelper Class Members

[image]
ActiveReports 19 .NET Edition
ImageHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper Class

Glossary Item Box

The following tables list the members exposed by ImageHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDimensions |
static (Shared in Visual Basic) | GetImageFormat |
Top

See Also

Reference

ImageHelper Class
GrapeCity.ActiveReports.Core.Document.Utility Namespace


ImageHelper Class Methods

[image]
ActiveReports 19 .NET Edition
ImageHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper Class

Glossary Item Box

For a list of all members of this type, see ImageHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDimensions |
static (Shared in Visual Basic) | GetImageFormat |
Top

See Also

Reference

ImageHelper Class
GrapeCity.ActiveReports.Core.Document.Utility Namespace


GetDimensions Method

[image]
ActiveReports 19 .NET Edition
GetDimensions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper Class : GetDimensions Method

reader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDimensions( _
   ByVal reader As BinaryReader _
) As ImageHelper.DecodeImageResult
C#
public static ImageHelper.DecodeImageResult GetDimensions(
   BinaryReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members


GetImageFormat Method

[image]
ActiveReports 19 .NET Edition
GetImageFormat Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper Class : GetImageFormat Method

binaryReader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetImageFormat( _
   ByVal binaryReader As BinaryReader _
) As ImageFormat
C#
public static ImageFormat GetImageFormat(
   BinaryReader binaryReader
)

Parameters

binaryReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members


ImageHelper.DecodeImageResult Structure

[image]
ActiveReports 19 .NET Edition
ImageHelper.DecodeImageResult Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper.DecodeImageResult Structure

Glossary Item Box

Represents the result of decoding an image.

Object Model

ImageHelper.DecodeImageResult Structure

Syntax

Visual Basic (Declaration)
Public Structure ImageHelper.DecodeImageResult
   Inherits System.ValueType
C#
public struct ImageHelper.DecodeImageResult : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.Utility.ImageHelper.DecodeImageResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Members
GrapeCity.ActiveReports.Core.Document.Utility Namespace


ImageHelper.DecodeImageResult Structure Members

[image]
ActiveReports 19 .NET Edition
ImageHelper.DecodeImageResult Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper.DecodeImageResult Structure

Glossary Item Box

The following tables list the members exposed by ImageHelper.DecodeImageResult.

Public Constructors

 | Name | Description
Public Constructor | ImageHelper.DecodeImageResult Constructor | Initializes an instance of structure ImageHelper.DecodeImageResult.
Top

Public Properties

 | Name | Description
Public Property | DpiX | Gets the dpi X value.
Public Property | DpiY | Gets the dpi Y value.
Public Property | Height | Gets the height.
Public Property | RawFormat | Gets the image format.
Public Property | Width | Gets the width.
Top

See Also

Reference

ImageHelper.DecodeImageResult Structure
GrapeCity.ActiveReports.Core.Document.Utility Namespace


ImageHelper.DecodeImageResult Constructor

[image]
ActiveReports 19 .NET Edition
ImageHelper.DecodeImageResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : ImageHelper.DecodeImageResult Constructor

rawFormat
The image format.
width
The width.
height
The height.
dpiX
The dpi X value.
dpiY
the dpi Y value.

Glossary Item Box

Initializes an instance of structure ImageHelper.DecodeImageResult.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawFormat As ImageFormat, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal dpiX As Single, _
   ByVal dpiY As Single _
)
C#
public ImageHelper.DecodeImageResult(
   ImageFormat rawFormat,
   int width,
   int height,
   float dpiX,
   float dpiY
)

Parameters

rawFormat
The image format.
width
The width.
height
The height.
dpiX
The dpi X value.
dpiY
the dpi Y value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


ImageHelper.DecodeImageResult Structure Properties

[image]
ActiveReports 19 .NET Edition
ImageHelper.DecodeImageResult Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace : ImageHelper.DecodeImageResult Structure

Glossary Item Box

For a list of all members of this type, see ImageHelper.DecodeImageResult members.

Public Properties

 | Name | Description
Public Property | DpiX | Gets the dpi X value.
Public Property | DpiY | Gets the dpi Y value.
Public Property | Height | Gets the height.
Public Property | RawFormat | Gets the image format.
Public Property | Width | Gets the width.
Top

See Also

Reference

ImageHelper.DecodeImageResult Structure
GrapeCity.ActiveReports.Core.Document.Utility Namespace


DpiX Property

[image]
ActiveReports 19 .NET Edition
DpiX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : DpiX Property

Glossary Item Box

Gets the dpi X value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiX As Single
C#
public float DpiX {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


DpiY Property

[image]
ActiveReports 19 .NET Edition
DpiY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : DpiY Property

Glossary Item Box

Gets the dpi Y value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiY As Single
C#
public float DpiY {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : Height Property

Glossary Item Box

Gets the height.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


RawFormat Property

[image]
ActiveReports 19 .NET Edition
RawFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : RawFormat Property

Glossary Item Box

Gets the image format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RawFormat As ImageFormat
C#
public ImageFormat RawFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document.Utility Namespace > ImageHelper.DecodeImageResult Structure : Width Property

Glossary Item Box

Gets the width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper.DecodeImageResult Structure
ImageHelper.DecodeImageResult Members


Font Class

[image]
ActiveReports 19 .NET Edition
Font Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Font Class

Glossary Item Box

Defines a particular format for text, including font face, size, and style attributes. It is a cross-platform version of Font.

Object Model

Font Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Font
C#
public sealed class Font

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Members
GrapeCity.ActiveReports.Document.Drawing Namespace


Font Class Members

[image]
ActiveReports 19 .NET Edition
Font Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Font Class

Glossary Item Box

The following tables list the members exposed by Font.

Public Constructors

 | Name | Description
Public Constructor | Font Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bold | Gets information about whether the font is bold.
Public Property | GdiCharSet | Gets GDI char set.
Public Property | GdiVerticalFont | Gets information about whether the GDI font is vertical.
Public Property | Italic | Gets information about whether the font is italic.
Public Property | Name | Gets the name.
Public Property | OriginalFontName | Gets the original font name.
Public Property | Size | Gets the size.
Public Property | SizeInPoints | Gets the size in inches.
Public Property | Strikeout | Gets information about whether the font is strikethrough or not.
Public Property | Style | Gets the font style.
Public Property | Underline | Gets information about whether the font is underlined or not.
Public Property | Unit | Gets the graphical unit of measure.
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Equals | Performs a comparison of two Font objects by value.
Public Method | GetHashCode | Gets the hash code of the current instance of class Font.
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Font Constructor

[image]
ActiveReports 19 .NET Edition
Font Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Font Constructor

Glossary Item Box

Overload List

Overload | Description
Font Constructor(Font,FontStyle) | Initializes an instance of class Font.
Font Constructor(String,Single) | Initializes an instance of class Font.
Font Constructor(String,Single,FontStyle) | Initializes an instance of class Font.
Font Constructor(String,Single,GraphicsUnit) | Initializes an instance of class Font.
Font Constructor(String,Single,FontStyle,GraphicsUnit) | Initializes an instance of class Font.
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte) | Initializes an instance of class Font.
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean) | Initializes an instance of class Font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Font Constructor(Font,FontStyle)

[image]
ActiveReports 19 .NET Edition
Font Constructor(Font,FontStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(Font,FontStyle)

prototype
The prototype.
newStyle
The font style.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal prototype As Font, _
   ByVal newStyle As FontStyle _
)
C#
public Font(
   Font prototype,
   FontStyle newStyle
)

Parameters

prototype
The prototype.
newStyle
The font style.

Exceptions

Exception | Description
System.ArgumentException | Occurs when prototype.size is less than or equal to 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single)

familyName
The family name.
emSize
The size.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single _
)
C#
public Font(
   string familyName,
   float emSize
)

Parameters

familyName
The family name.
emSize
The size.

Exceptions

Exception | Description
System.ArgumentException | Occurs when size is less than or equal to 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle)

familyName
The family name.
emSize
The size.
style
The font style.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style
)

Parameters

familyName
The family name.
emSize
The size.
style
The font style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,GraphicsUnit)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,GraphicsUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,GraphicsUnit)

familyName
The family name.
emSize
The size.
unit
The graphic Unit.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal unit As GraphicsUnit _
)
C#
public Font(
   string familyName,
   float emSize,
   GraphicsUnit unit
)

Parameters

familyName
The family name.
emSize
The size.
unit
The graphic Unit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle,GraphicsUnit)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle,GraphicsUnit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle,GraphicsUnit)

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit
)

Parameters

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte)

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.
gdiCharSet
The GDI char set.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit, _
   ByVal gdiCharSet As Byte _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit,
   byte gdiCharSet
)

Parameters

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.
gdiCharSet
The GDI char set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)

[image]
ActiveReports 19 .NET Edition
Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class > Font Constructor : Font Constructor(String,Single,FontStyle,GraphicsUnit,Byte,Boolean)

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.
gdiCharSet
The GDI char set.
gdiVerticalFont
Determines whether the font is vertical.

Glossary Item Box

Initializes an instance of class Font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal style As FontStyle, _
   ByVal unit As GraphicsUnit, _
   ByVal gdiCharSet As Byte, _
   ByVal gdiVerticalFont As Boolean _
)
C#
public Font(
   string familyName,
   float emSize,
   FontStyle style,
   GraphicsUnit unit,
   byte gdiCharSet,
   bool gdiVerticalFont
)

Parameters

familyName
The family name.
emSize
The size.
style
The font style.
unit
The graphic Unit.
gdiCharSet
The GDI char set.
gdiVerticalFont
Determines whether the font is vertical.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members
Overload List


Font Class Methods

[image]
ActiveReports 19 .NET Edition
Font Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Equals | Performs a comparison of two Font objects by value.
Public Method | GetHashCode | Gets the hash code of the current instance of class Font.
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

Returns the cloned Font instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Equals Method

obj
The Font for comparison.

Glossary Item Box

Performs a comparison of two Font objects by value.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Font for comparison.

Return Value

Returns True if the two objects are identical, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : GetHashCode Method

Glossary Item Box

Gets the hash code of the current instance of class Font.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

Returns the hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Font Class Properties

[image]
ActiveReports 19 .NET Edition
Font Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Properties

 | Name | Description
Public Property | Bold | Gets information about whether the font is bold.
Public Property | GdiCharSet | Gets GDI char set.
Public Property | GdiVerticalFont | Gets information about whether the GDI font is vertical.
Public Property | Italic | Gets information about whether the font is italic.
Public Property | Name | Gets the name.
Public Property | OriginalFontName | Gets the original font name.
Public Property | Size | Gets the size.
Public Property | SizeInPoints | Gets the size in inches.
Public Property | Strikeout | Gets information about whether the font is strikethrough or not.
Public Property | Style | Gets the font style.
Public Property | Underline | Gets information about whether the font is underlined or not.
Public Property | Unit | Gets the graphical unit of measure.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Bold Property

[image]
ActiveReports 19 .NET Edition
Bold Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Bold Property

Glossary Item Box

Gets information about whether the font is bold.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bold As Boolean
C#
public bool Bold {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GdiCharSet Property

[image]
ActiveReports 19 .NET Edition
GdiCharSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : GdiCharSet Property

Glossary Item Box

Gets GDI char set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GdiCharSet As Byte
C#
public byte GdiCharSet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


GdiVerticalFont Property

[image]
ActiveReports 19 .NET Edition
GdiVerticalFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : GdiVerticalFont Property

Glossary Item Box

Gets information about whether the GDI font is vertical.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GdiVerticalFont As Boolean
C#
public bool GdiVerticalFont {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Italic Property

[image]
ActiveReports 19 .NET Edition
Italic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Italic Property

Glossary Item Box

Gets information about whether the font is italic.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Italic As Boolean
C#
public bool Italic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Name Property

Glossary Item Box

Gets the name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


OriginalFontName Property

[image]
ActiveReports 19 .NET Edition
OriginalFontName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : OriginalFontName Property

Glossary Item Box

Gets the original font name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginalFontName As String
C#
public string OriginalFontName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Size Property

Glossary Item Box

Gets the size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Single
C#
public float Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


SizeInPoints Property

[image]
ActiveReports 19 .NET Edition
SizeInPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : SizeInPoints Property

Glossary Item Box

Gets the size in inches.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SizeInPoints As Single
C#
public float SizeInPoints {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Strikeout Property

[image]
ActiveReports 19 .NET Edition
Strikeout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Strikeout Property

Glossary Item Box

Gets information about whether the font is strikethrough or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Strikeout As Boolean
C#
public bool Strikeout {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Style Property

Glossary Item Box

Gets the font style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As FontStyle
C#
public FontStyle Style {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Underline Property

[image]
ActiveReports 19 .NET Edition
Underline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Underline Property

Glossary Item Box

Gets information about whether the font is underlined or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Underline As Boolean
C#
public bool Underline {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Font Class : Unit Property

Glossary Item Box

Gets the graphical unit of measure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unit As GraphicsUnit
C#
public GraphicsUnit Unit {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Image Class

[image]
ActiveReports 19 .NET Edition
Image Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Image Class

Glossary Item Box

It is a cross-platform Image-like image descriptor.

Object Model

Image Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Image
C#
public sealed class Image

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.Image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Members
GrapeCity.ActiveReports.Document.Drawing Namespace


Image Class Members

[image]
ActiveReports 19 .NET Edition
Image Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Image Class

Glossary Item Box

The following tables list the members exposed by Image.

Public Properties

 | Name | Description
Public Property | Data | Gets a byte array containing the image data.
Public Property | Height | Gets the height of this Image.
Public Property | HorizontalResolution | Gets the horizontal resolution, in pixels-per-inch, of this Image.
Public Property | RawFormat | Gets the format of this Image.
Public Property | Size | Gets the width and height of this Image.
Public Property | VerticalResolution | Gets the vertical resolution, in pixels-per-inch, of this Image.
Public Property | Width | Gets the width of this Image.
Top

Public Methods

 | Name | Description
Public Method | Equals | Performs a comparison of two Image objects by value.
static (Shared in Visual Basic) | FromFile | Creates an Image from the specified file.
static (Shared in Visual Basic) | FromStream | Creates an Image from the specified data stream.
Public Method | GetHashCode | Gets the hash code of the current instance of class Font.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Image Class Methods

[image]
ActiveReports 19 .NET Edition
Image Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Methods

 | Name | Description
Public Method | Equals | Performs a comparison of two Image objects by value.
static (Shared in Visual Basic) | FromFile | Creates an Image from the specified file.
static (Shared in Visual Basic) | FromStream | Creates an Image from the specified data stream.
Public Method | GetHashCode | Gets the hash code of the current instance of class Font.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : Equals Method

obj
The Image for comparison.

Glossary Item Box

Performs a comparison of two Image objects by value.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Image for comparison.

Return Value

Returns True if the two objects are identical, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


FromFile Method

[image]
ActiveReports 19 .NET Edition
FromFile Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : FromFile Method

filename
The path to the file.

Glossary Item Box

Creates an Image from the specified file.

Syntax

Visual Basic (Declaration)
Public Shared Function FromFile( _
   ByVal filename As String _
) As Image
C#
public static Image FromFile(
   string filename
)

Parameters

filename
The path to the file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


FromStream(Stream) Method

[image]
ActiveReports 19 .NET Edition
FromStream(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class > FromStream Method : FromStream(Stream) Method

stream
The image stream.

Glossary Item Box

Creates an Image from the specified data stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromStream( _
   ByVal stream As Stream _
) As Image
C#
public static Image FromStream(
   Stream stream
)

Parameters

stream
The image stream.

Example

This example shows how to restore an Image from a manually created stream.
C# Copy Code
using (System.Drawing.Image imgSrc = new Bitmap(12, 12))
{
    using (Graphics g1 = Graphics.FromImage(imgSrc))
        g1.FillRectangle(Brushes.Yellow, new Rectangle(0, 0, 12, 12));
    MemoryStream stream1 = new MemoryStream();
    img1.Save(stream1, ImageFormat.Jpeg);
    return Image.FromStream(stream1);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : GetHashCode Method

Glossary Item Box

Gets the hash code of the current instance of class Font.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

Returns the hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Image Class Properties

[image]
ActiveReports 19 .NET Edition
Image Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Properties

 | Name | Description
Public Property | Data | Gets a byte array containing the image data.
Public Property | Height | Gets the height of this Image.
Public Property | HorizontalResolution | Gets the horizontal resolution, in pixels-per-inch, of this Image.
Public Property | RawFormat | Gets the format of this Image.
Public Property | Size | Gets the width and height of this Image.
Public Property | VerticalResolution | Gets the vertical resolution, in pixels-per-inch, of this Image.
Public Property | Width | Gets the width of this Image.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : Data Property

Glossary Item Box

Gets a byte array containing the image data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
C#
public byte[] Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : Height Property

Glossary Item Box

Gets the height of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


HorizontalResolution Property

[image]
ActiveReports 19 .NET Edition
HorizontalResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : HorizontalResolution Property

Glossary Item Box

Gets the horizontal resolution, in pixels-per-inch, of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalResolution As Single
C#
public float HorizontalResolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


RawFormat Property

[image]
ActiveReports 19 .NET Edition
RawFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : RawFormat Property

Glossary Item Box

Gets the format of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RawFormat As ImageFormat
C#
public ImageFormat RawFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : Size Property

Glossary Item Box

Gets the width and height of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


VerticalResolution Property

[image]
ActiveReports 19 .NET Edition
VerticalResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : VerticalResolution Property

Glossary Item Box

Gets the vertical resolution, in pixels-per-inch, of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalResolution As Single
C#
public float VerticalResolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : Width Property

Glossary Item Box

Gets the width of this Image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


StringFormat Class

[image]
ActiveReports 19 .NET Edition
StringFormat Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : StringFormat Class

Glossary Item Box

Encapsulates text layout information: text alignment and line alignment. This is a simplified cross-platform version of System.Drawing.StringFormat.

Object Model

StringFormat Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringFormat
C#
public sealed class StringFormat

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.StringFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormat Members
GrapeCity.ActiveReports.Document.Drawing Namespace


StringFormat Class Members

[image]
ActiveReports 19 .NET Edition
StringFormat Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : StringFormat Class

Glossary Item Box

The following tables list the members exposed by StringFormat.

Public Constructors

 | Name | Description
Public Constructor | StringFormat Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment information.
Public Property | LineAlignment | Gets or sets the line alignment.
Top

See Also

Reference

StringFormat Class
GrapeCity.ActiveReports.Document.Drawing Namespace


StringFormat Constructor

[image]
ActiveReports 19 .NET Edition
StringFormat Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > StringFormat Class : StringFormat Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StringFormat()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormat Class
StringFormat Members


StringFormat Class Properties

[image]
ActiveReports 19 .NET Edition
StringFormat Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : StringFormat Class

Glossary Item Box

For a list of all members of this type, see StringFormat members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment information.
Public Property | LineAlignment | Gets or sets the line alignment.
Top

See Also

Reference

StringFormat Class
GrapeCity.ActiveReports.Document.Drawing Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > StringFormat Class : Alignment Property

Glossary Item Box

Gets or sets the text alignment information.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignment
C#
public StringAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormat Class
StringFormat Members


LineAlignment Property

[image]
ActiveReports 19 .NET Edition
LineAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > StringFormat Class : LineAlignment Property

Glossary Item Box

Gets or sets the line alignment.

Syntax

Visual Basic (Declaration)
Public Property LineAlignment As StringAlignment
C#
public StringAlignment LineAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormat Class
StringFormat Members


FontStyle Enumeration

[image]
ActiveReports 19 .NET Edition
FontStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : FontStyle Enumeration

Glossary Item Box

Specifies style information applied to text. It is a cross-platform version of System.Drawing.FontStyle.

Syntax

Visual Basic (Declaration)
Public Enum FontStyle
   Inherits System.Enum
C#
public enum FontStyle : System.Enum

Members

Member | Description
Bold | Bold font style.
Italic | Italic font style.
Regular | Regular font style.
Strikeout | Strikeout font style.
Underline | Underline font style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Drawing.FontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Drawing Namespace


GraphicsUnit Enumeration

[image]
ActiveReports 19 .NET Edition
GraphicsUnit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : GraphicsUnit Enumeration

Glossary Item Box

Specifies the unit of measure for the given data. It is a cross-platform version of System.Drawing.GraphicsUnit.

Syntax

Visual Basic (Declaration)
Public Enum GraphicsUnit
   Inherits System.Enum
C#
public enum GraphicsUnit : System.Enum

Members

Member | Description
Display | The display unit.
Document | The document unit.
Inch | The inch unit.
Millimeter | The millimetr unit.
Pixel | The pixel unit.
Point | The point unit.
World | The word unit.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Drawing.GraphicsUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Drawing Namespace


StringAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
StringAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace : StringAlignment Enumeration

Glossary Item Box

Specifies the alignment of a text string relative to its layout rectangle. It is a cross-platform version of StringAlignment.

Syntax

Visual Basic (Declaration)
Public Enum StringAlignment
   Inherits System.Enum
C#
public enum StringAlignment : System.Enum

Members

Member | Description
Center | The center string alignment.
Far | The far string alignment.
Near | The near string alignment.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Drawing.StringAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Drawing Namespace


DashCap Enumeration

[image]
ActiveReports 19 .NET Edition
DashCap Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace : DashCap Enumeration

Glossary Item Box

Specifies the type of graphic shape to use on both ends of each dash in a dashed line. It is a cross-platform version of DashCap.

Syntax

Visual Basic (Declaration)
Public Enum DashCap
   Inherits System.Enum
C#
public enum DashCap : System.Enum

Members

Member | Description
Flat | The flat dash cap.
Round | The round dash cap.
Triangle | The triangle dash cap.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Drawing.Drawing2D.DashCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace


DashStyle Enumeration

[image]
ActiveReports 19 .NET Edition
DashStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace : DashStyle Enumeration

Glossary Item Box

Specifies the style of dashed lines drawn with a Pen object. It is a cross-platform version of DashStyle.

Syntax

Visual Basic (Declaration)
Public Enum DashStyle
   Inherits System.Enum
C#
public enum DashStyle : System.Enum

Members

Member | Description
Custom | The custom style.
Dash | The das style.
DashDot | The Dash Dot style.
DashDotDot | The Dash Dot Dot style.
Dot | The dot style.
Solid | The solid style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Drawing.Drawing2D.DashStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace


ImageFormat Class

[image]
ActiveReports 19 .NET Edition
ImageFormat Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

Represents the file format of the image. It is a cross-platform version of ImageFormat.

Object Model

ImageFormat Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ImageFormat
C#
public sealed class ImageFormat

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.Imaging.ImageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Members
GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace


ImageFormat Class Members

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

The following tables list the members exposed by ImageFormat.

Public Constructors

 | Name | Description
Public Constructor | ImageFormat Constructor | Initializes a new instance of the ImageFormat class with the specified GUID.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Bmp | Gets the bitmap image format.
static (Shared in Visual Basic) | Emf | Gets the enhanced Windows metafile image format.
static (Shared in Visual Basic) | Exif | Gets the Exchangeable Image Format (EXIF).
static (Shared in Visual Basic) | Gif | Gets the GIF image format.
Public Property | Guid | Gets a global unique identifier (System.Guid) that represents this ImageFormat.
static (Shared in Visual Basic) | Icon | Gets the Windows icon image format.
static (Shared in Visual Basic) | Jpeg | Gets the JPEG image format.
static (Shared in Visual Basic) | MemoryBmp | Gets a memory bitmap image format.
static (Shared in Visual Basic) | Png | Gets the W3C PNG image format.
static (Shared in Visual Basic) | Svg | Gets the Scalable Vector Graphics (SVG).
static (Shared in Visual Basic) | Tiff | Gets the Tag Image File Format (TIFF) image format.
static (Shared in Visual Basic) | Wmf | Gets the Windows metafile image format.
Top

Public Methods

 | Name | Description
Public Method | Equals | Performs a comparison of two ImageFormat objects by value.
Public Method | GetHashCode | Gets the hash code of the current instance of class GrapeCity.ActiveReports.Document.Drawing.Font.
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace


ImageFormat Constructor

[image]
ActiveReports 19 .NET Edition
ImageFormat Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : ImageFormat Constructor

guid
The global unique identifier.

Glossary Item Box

Initializes a new instance of the ImageFormat class with the specified GUID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal guid As Guid _
)
C#
public ImageFormat(
   Guid guid
)

Parameters

guid
The global unique identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


ImageFormat Class Methods

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

For a list of all members of this type, see ImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | Performs a comparison of two ImageFormat objects by value.
Public Method | GetHashCode | Gets the hash code of the current instance of class GrapeCity.ActiveReports.Document.Drawing.Font.
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Equals Method

o
The ImageFormat for comparison.

Glossary Item Box

Performs a comparison of two ImageFormat objects by value.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal o As Object _
) As Boolean
C#
public override bool Equals(
   object o
)

Parameters

o
The ImageFormat for comparison.

Return Value

Returns True if the two objects are identical, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : GetHashCode Method

Glossary Item Box

Gets the hash code of the current instance of class GrapeCity.ActiveReports.Document.Drawing.Font.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

Returns the hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


ImageFormat Class Properties

[image]
ActiveReports 19 .NET Edition
ImageFormat Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace : ImageFormat Class

Glossary Item Box

For a list of all members of this type, see ImageFormat members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Bmp | Gets the bitmap image format.
static (Shared in Visual Basic) | Emf | Gets the enhanced Windows metafile image format.
static (Shared in Visual Basic) | Exif | Gets the Exchangeable Image Format (EXIF).
static (Shared in Visual Basic) | Gif | Gets the GIF image format.
Public Property | Guid | Gets a global unique identifier (System.Guid) that represents this ImageFormat.
static (Shared in Visual Basic) | Icon | Gets the Windows icon image format.
static (Shared in Visual Basic) | Jpeg | Gets the JPEG image format.
static (Shared in Visual Basic) | MemoryBmp | Gets a memory bitmap image format.
static (Shared in Visual Basic) | Png | Gets the W3C PNG image format.
static (Shared in Visual Basic) | Svg | Gets the Scalable Vector Graphics (SVG).
static (Shared in Visual Basic) | Tiff | Gets the Tag Image File Format (TIFF) image format.
static (Shared in Visual Basic) | Wmf | Gets the Windows metafile image format.
Top

See Also

Reference

ImageFormat Class
GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace


Bmp Property

[image]
ActiveReports 19 .NET Edition
Bmp Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Bmp Property

Glossary Item Box

Gets the bitmap image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Bmp As ImageFormat
C#
public static ImageFormat Bmp {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Emf Property

[image]
ActiveReports 19 .NET Edition
Emf Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Emf Property

Glossary Item Box

Gets the enhanced Windows metafile image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Emf As ImageFormat
C#
public static ImageFormat Emf {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Exif Property

[image]
ActiveReports 19 .NET Edition
Exif Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Exif Property

Glossary Item Box

Gets the Exchangeable Image Format (EXIF).

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Exif As ImageFormat
C#
public static ImageFormat Exif {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Gif Property

[image]
ActiveReports 19 .NET Edition
Gif Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Gif Property

Glossary Item Box

Gets the GIF image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Gif As ImageFormat
C#
public static ImageFormat Gif {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Guid Property

[image]
ActiveReports 19 .NET Edition
Guid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Guid Property

Glossary Item Box

Gets a global unique identifier (System.Guid) that represents this ImageFormat.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Guid As Guid
C#
public Guid Guid {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Icon Property

[image]
ActiveReports 19 .NET Edition
Icon Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Icon Property

Glossary Item Box

Gets the Windows icon image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Icon As ImageFormat
C#
public static ImageFormat Icon {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Jpeg Property

[image]
ActiveReports 19 .NET Edition
Jpeg Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Jpeg Property

Glossary Item Box

Gets the JPEG image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Jpeg As ImageFormat
C#
public static ImageFormat Jpeg {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


MemoryBmp Property

[image]
ActiveReports 19 .NET Edition
MemoryBmp Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : MemoryBmp Property

Glossary Item Box

Gets a memory bitmap image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MemoryBmp As ImageFormat
C#
public static ImageFormat MemoryBmp {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Png Property

[image]
ActiveReports 19 .NET Edition
Png Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Png Property

Glossary Item Box

Gets the W3C PNG image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Png As ImageFormat
C#
public static ImageFormat Png {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Svg Property

[image]
ActiveReports 19 .NET Edition
Svg Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Svg Property

Glossary Item Box

Gets the Scalable Vector Graphics (SVG).

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Svg As ImageFormat
C#
public static ImageFormat Svg {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Tiff Property

[image]
ActiveReports 19 .NET Edition
Tiff Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Tiff Property

Glossary Item Box

Gets the Tag Image File Format (TIFF) image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Tiff As ImageFormat
C#
public static ImageFormat Tiff {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Wmf Property

[image]
ActiveReports 19 .NET Edition
Wmf Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace > ImageFormat Class : Wmf Property

Glossary Item Box

Gets the Windows metafile image format.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Wmf As ImageFormat
C#
public static ImageFormat Wmf {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageFormat Class
ImageFormat Members


Align Class

[image]
ActiveReports 19 .NET Edition
Align Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Align Class

Glossary Item Box

Represents the align canvas item.

Object Model

Align Class

Syntax

Visual Basic (Declaration)
Public Class Align
   Inherits CanvasItem
C#
public class Align : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Align Members
GrapeCity.ActiveReports.Document.Section Namespace


Align Class Members

[image]
ActiveReports 19 .NET Edition
Align Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Align Class

Glossary Item Box

The following tables list the members exposed by Align.

See Also

Reference

Align Class
GrapeCity.ActiveReports.Document.Section Namespace


BackColor Class

[image]
ActiveReports 19 .NET Edition
BackColor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackColor Class

Glossary Item Box

Represents the background color.

Object Model

BackColor Class

Syntax

Visual Basic (Declaration)
Public Class BackColor
   Inherits CanvasItem
C#
public class BackColor : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.BackColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackColor Members
GrapeCity.ActiveReports.Document.Section Namespace


BackColor Class Members

[image]
ActiveReports 19 .NET Edition
BackColor Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackColor Class

Glossary Item Box

The following tables list the members exposed by BackColor.

See Also

Reference

BackColor Class
GrapeCity.ActiveReports.Document.Section Namespace


BackStyle Class

[image]
ActiveReports 19 .NET Edition
BackStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackStyle Class

Glossary Item Box

Represents the BackStyle.

Object Model

BackStyle Class

Syntax

Visual Basic (Declaration)
Public Class BackStyle
   Inherits CanvasItem
C#
public class BackStyle : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.BackStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackStyle Members
GrapeCity.ActiveReports.Document.Section Namespace


BackStyle Class Members

[image]
ActiveReports 19 .NET Edition
BackStyle Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackStyle Class

Glossary Item Box

The following tables list the members exposed by BackStyle.

See Also

Reference

BackStyle Class
GrapeCity.ActiveReports.Document.Section Namespace


BitmapImage Class

[image]
ActiveReports 19 .NET Edition
BitmapImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BitmapImage Class

Glossary Item Box

Represents the abstract bitmap canvas item.

Object Model

BitmapImage Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class BitmapImage
   Inherits ResourcedCanvasItem
   Implements IBordered
C#
public abstract class BitmapImage : ResourcedCanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.BitmapImage
GrapeCity.ActiveReports.Document.Section.JPEGImage
GrapeCity.ActiveReports.Document.Section.PngImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BitmapImage Members
GrapeCity.ActiveReports.Document.Section Namespace


BitmapImage Class Members

[image]
ActiveReports 19 .NET Edition
BitmapImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BitmapImage Class

Glossary Item Box

The following tables list the members exposed by BitmapImage.

See Also

Reference

BitmapImage Class
GrapeCity.ActiveReports.Document.Section Namespace


Bookmark Class

[image]
ActiveReports 19 .NET Edition
Bookmark Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

Represents a bookmark.

Object Model

Bookmark Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Bookmark
C#
public sealed class Bookmark

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Members
GrapeCity.ActiveReports.Document.Section Namespace


Bookmark Class Members

[image]
ActiveReports 19 .NET Edition
Bookmark Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

The following tables list the members exposed by Bookmark.

Public Constructors

 | Name | Description
Public Constructor | Bookmark Constructor | Default bookark constructor. Initializes the Bookmark structure.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the name of the bookmark.
Public Property | Offset | Gets or sets the offSet from the top of page where the bookmark resides on the Page object.
Public Property | PageNumber | Gets or sets the page number in the document's pages collection in which this bookmark is contained.
Top

See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace


Bookmark Constructor

[image]
ActiveReports 19 .NET Edition
Bookmark Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor

Glossary Item Box

Default bookark constructor. Initializes the Bookmark structure.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Bookmark()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


Bookmark Class Properties

[image]
ActiveReports 19 .NET Edition
Bookmark Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

For a list of all members of this type, see Bookmark members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the name of the bookmark.
Public Property | Offset | Gets or sets the offSet from the top of page where the bookmark resides on the Page object.
Public Property | PageNumber | Gets or sets the page number in the document's pages collection in which this bookmark is contained.
Top

See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Label Property

Glossary Item Box

Gets or sets the name of the bookmark.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


Offset Property

[image]
ActiveReports 19 .NET Edition
Offset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Offset Property

Glossary Item Box

Gets or sets the offSet from the top of page where the bookmark resides on the Page object.

Syntax

Visual Basic (Declaration)
Public Property Offset As Single
C#
public float Offset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : PageNumber Property

Glossary Item Box

Gets or sets the page number in the document's pages collection in which this bookmark is contained.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
C#
public int PageNumber {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


BookmarksCollection Class

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

Represents the bookmarks collection.

Object Model

BookmarksCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BookmarksCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class BookmarksCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.BookmarksCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Class Members

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

The following tables list the members exposed by BookmarksCollection.

Public Constructors

 | Name | Description
Public Constructor | BookmarksCollection Constructor | Initializes a new instance of the BookmarksCollection class.
Top

Public Properties

 | Name | Description
Public Property | CurrentBookmark | Gets or sets the index of currently active or selected bookmark from the BookmarksCollection.
Public Property | Item | Gets a Bookmark object at specified index in the BookmarksCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds Bookmark item to the collection.
Public Method | Clear | Removes all boomark objects from the BookmarksCollection.
Public Method | Contains | Gets whether the element is part of a collection.
Public Method | CopyTo | Copies a range of items from the collection to a compatible one-dimensional array, starting at the specified index of the final array..
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the value in the collection or part of it.
Public Method | Insert | Inserts an item to the collection at the specified index.
Public Method | Remove | Removes the object from the collection.
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Constructor

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor

Glossary Item Box

Initializes a new instance of the BookmarksCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BookmarksCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Methods

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

For a list of all members of this type, see BookmarksCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds Bookmark item to the collection.
Public Method | Clear | Removes all boomark objects from the BookmarksCollection.
Public Method | Contains | Gets whether the element is part of a collection.
Public Method | CopyTo | Copies a range of items from the collection to a compatible one-dimensional array, starting at the specified index of the final array..
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | IndexOf | Returns the zero-based index of the first occurrence of the value in the collection or part of it.
Public Method | Insert | Inserts an item to the collection at the specified index.
Public Method | Remove | Removes the object from the collection.
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Add Method

value
An Bookmark element to add.

Glossary Item Box

Adds Bookmark item to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Bookmark _
) As Integer
C#
public int Add(
   Bookmark value
)

Parameters

value
An Bookmark element to add.

Return Value

The position into which the new element was inserted, or -1 to indicate that the item was not inserted into the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Clear Method

Glossary Item Box

Removes all boomark objects from the BookmarksCollection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Contains Method

value
Object to search for in the collection.

Glossary Item Box

Gets whether the element is part of a collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Bookmark _
) As Boolean
C#
public bool Contains(
   Bookmark value
)

Parameters

value
Object to search for in the collection.

Return Value

The value is true if the item parameter is found in the collection; otherwise, the value is false.

Example

C# Copy Code
private void RemoveBookmark(Bookmark bookmarkToRemove)
{
    while (bookMarkCollection.Contains(bookmarkToRemove))
    {
        bookMarkCollection.Remove(bookmarkToRemove);
    }
    bool isExists = bookMarkCollection.Contains(bookmarkToRemove);//should be false
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CopyTo Method

values
The collection into which the items are copied.
index
The zero-basef index of the source collection from which the copying starts.

Glossary Item Box

Copies a range of items from the collection to a compatible one-dimensional array, starting at the specified index of the final array..

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal values() As Bookmark, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Bookmark[] values,
   int index
)

Parameters

values
The collection into which the items are copied.
index
The zero-basef index of the source collection from which the copying starts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : IndexOf Method

value
Object to search for in the collection.

Glossary Item Box

Returns the zero-based index of the first occurrence of the value in the collection or part of it.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Bookmark _
) As Integer
C#
public int IndexOf(
   Bookmark value
)

Parameters

value
Object to search for in the collection.

Return Value

Index (zero-based) of the first occurrence of the item parameter if it is found in the collection; otherwise -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Insert Method

index
The zero-based index at which to insert the value.
value
An Bookmark item to insert.

Glossary Item Box

Inserts an item to the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Bookmark _
)
C#
public void Insert(
   int index,
   Bookmark value
)

Parameters

index
The zero-based index at which to insert the value.
value
An Bookmark item to insert.

Example

This example shoes how to add new bookmark at the begining of the collection
C# Copy Code
if (!bookmarkCollection.Contains(newBookmark))
{
    bookmarkCollection.Insert(0,newBookmark);
    int index = bookmarkCollection.IndexOf(newBookmark);//should be 0
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Remove Method

value
Object to remove from the collection.

Glossary Item Box

Removes the object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Bookmark _
)
C#
public void Remove(
   Bookmark value
)

Parameters

value
Object to remove from the collection.

Example

C# Copy Code
private void RemoveBookmark(Bookmark bookmarkToRemove)
{
    while (bookMarkCollection.Contains(bookmarkToRemove))
    {
        bookMarkCollection.Remove(bookmarkToRemove);
    }
    bool isRemoved = bookMarkCollection.Contains(bookmarkToRemove)//should be false
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Properties

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

For a list of all members of this type, see BookmarksCollection members.

Public Properties

 | Name | Description
Public Property | CurrentBookmark | Gets or sets the index of currently active or selected bookmark from the BookmarksCollection.
Public Property | Item | Gets a Bookmark object at specified index in the BookmarksCollection.
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


CurrentBookmark Property

[image]
ActiveReports 19 .NET Edition
CurrentBookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CurrentBookmark Property

Glossary Item Box

Gets or sets the index of currently active or selected bookmark from the BookmarksCollection.

Syntax

Visual Basic (Declaration)
Public Property CurrentBookmark As Integer
C#
public int CurrentBookmark {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Item Property

index
The index of the bookmark.

Glossary Item Box

Gets a Bookmark object at specified index in the BookmarksCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Bookmark
C#
public Bookmark this[
   int index
]; {get;}

Parameters

index
The index of the bookmark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BorderItem Class

[image]
ActiveReports 19 .NET Edition
BorderItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BorderItem Class

Glossary Item Box

Represents the border canvas item.

Object Model

BorderItem Class

Syntax

Visual Basic (Declaration)
Public Class BorderItem
   Inherits CanvasItem
C#
public class BorderItem : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.BorderItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderItem Members
GrapeCity.ActiveReports.Document.Section Namespace


BorderItem Class Members

[image]
ActiveReports 19 .NET Edition
BorderItem Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BorderItem Class

Glossary Item Box

The following tables list the members exposed by BorderItem.

See Also

Reference

BorderItem Class
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItem Class

[image]
ActiveReports 19 .NET Edition
CanvasItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItem Class

Glossary Item Box

Represents an abstract class of a canvas element.

Object Model

CanvasItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class CanvasItem
C#
public abstract class CanvasItem

Remarks

All canvas items coordinates are in inches.

Example

C# Copy Code
public class MyCanvasItem : CanvasItem
{
    public MyCanvasItem(CanvasType ctType) : base(ctType)
    {
    }
    public override CanvasItem Clone()
    {
        return new MyCanvasItem(Type);
    }
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Align
GrapeCity.ActiveReports.Document.Section.BackColor
GrapeCity.ActiveReports.Document.Section.BackStyle
GrapeCity.ActiveReports.Document.Section.BorderItem
GrapeCity.ActiveReports.Document.Section.ClipRect
GrapeCity.ActiveReports.Document.Section.ControlInfo
GrapeCity.ActiveReports.Document.Section.ControlInfoEnd
GrapeCity.ActiveReports.Document.Section.DrawText
GrapeCity.ActiveReports.Document.Section.DrawText2
GrapeCity.ActiveReports.Document.Section.DrawTextLink
GrapeCity.ActiveReports.Document.Section.Ellipse
GrapeCity.ActiveReports.Document.Section.EvaluationEnd
GrapeCity.ActiveReports.Document.Section.EvaluationStart
GrapeCity.ActiveReports.Document.Section.FillRect
GrapeCity.ActiveReports.Document.Section.ForeColor
GrapeCity.ActiveReports.Document.Section.InputFieldItem
GrapeCity.ActiveReports.Document.Section.InputFieldTabIndexItem
GrapeCity.ActiveReports.Document.Section.IntersectClip
GrapeCity.ActiveReports.Document.Section.LineItem
GrapeCity.ActiveReports.Document.Section.PenStyle
GrapeCity.ActiveReports.Document.Section.PenWidth
GrapeCity.ActiveReports.Document.Section.Rect
GrapeCity.ActiveReports.Document.Section.ResetContext
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.RoundRect
GrapeCity.ActiveReports.Document.Section.RoundRectEx
GrapeCity.ActiveReports.Document.Section.RTL
GrapeCity.ActiveReports.Document.Section.SectionInfo
GrapeCity.ActiveReports.Document.Section.SectionInfoEnd
GrapeCity.ActiveReports.Document.Section.SelectFont
GrapeCity.ActiveReports.Document.Section.SetCharacterSpacing
GrapeCity.ActiveReports.Document.Section.SetLineSpacing
GrapeCity.ActiveReports.Document.Section.SetPadding
GrapeCity.ActiveReports.Document.Section.SetScaleX
GrapeCity.ActiveReports.Document.Section.SVG
GrapeCity.ActiveReports.Document.Section.Table
GrapeCity.ActiveReports.Document.Section.TabStopsItem
GrapeCity.ActiveReports.Document.Section.TextAngle
GrapeCity.ActiveReports.Document.Section.TextBoundsRange
GrapeCity.ActiveReports.Document.Section.TextInfoItem
GrapeCity.ActiveReports.Document.Section.TextOut
GrapeCity.ActiveReports.Document.Section.TextRenderHintItem
GrapeCity.ActiveReports.Document.Section.VerticalText
GrapeCity.ActiveReports.Document.Section.WordWrap
GrapeCity.ActiveReports.Document.Section.WrapModeItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItem Members
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
CanvasItem Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItem Class

Glossary Item Box

The following tables list the members exposed by CanvasItem.

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Top

See Also

Reference

CanvasItem Class
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItem Class Methods

[image]
ActiveReports 19 .NET Edition
CanvasItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItem Class

Glossary Item Box

For a list of all members of this type, see CanvasItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Top

See Also

Reference

CanvasItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItem Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItem Class
CanvasItem Members


CanvasItemCollection Class

[image]
ActiveReports 19 .NET Edition
CanvasItemCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemCollection Class

Glossary Item Box

Represents a collection of canvas elements.

Object Model

CanvasItemCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CanvasItemCollection
   Inherits System.Collections.ObjectModel.Collection(Of CanvasItem)
C#
public sealed class CanvasItemCollection : System.Collections.ObjectModel.Collection<CanvasItem>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Document.Section.CanvasItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItemCollection Class Members

[image]
ActiveReports 19 .NET Edition
CanvasItemCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemCollection Class

Glossary Item Box

The following tables list the members exposed by CanvasItemCollection.

Public Properties

 | Name | Description
Public Property | Page | Gets the page.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | GetReadOnlyList | Gets a read-only list of canvas elements.
Top

See Also

Reference

CanvasItemCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItemCollection Class Methods

[image]
ActiveReports 19 .NET Edition
CanvasItemCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemCollection Class

Glossary Item Box

For a list of all members of this type, see CanvasItemCollection members.

Public Methods

 | Name | Description
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | GetReadOnlyList | Gets a read-only list of canvas elements.
Top

See Also

Reference

CanvasItemCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


GetReadOnlyList Method

[image]
ActiveReports 19 .NET Edition
GetReadOnlyList Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : GetReadOnlyList Method

Glossary Item Box

Gets a read-only list of canvas elements.

Syntax

Visual Basic (Declaration)
Public Function GetReadOnlyList() As IList(Of CanvasItem)
C#
public IList<CanvasItem> GetReadOnlyList()

Return Value

Returns the read-only list of canvas elements

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


CanvasItemCollection Class Properties

[image]
ActiveReports 19 .NET Edition
CanvasItemCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemCollection Class

Glossary Item Box

For a list of all members of this type, see CanvasItemCollection members.

Public Properties

 | Name | Description
Public Property | Page | Gets the page.
Top

See Also

Reference

CanvasItemCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Page Property

Glossary Item Box

Gets the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As Page
C#
public Page Page {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


CanvasItemRenderer Class

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemRenderer Class

Glossary Item Box

Represents the rederer for canvas items.

Object Model

CanvasItemRenderer Class

Syntax

Visual Basic (Declaration)
Public Class CanvasItemRenderer
   Implements ICanvasItemRenderer
C#
public class CanvasItemRenderer : ICanvasItemRenderer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiCanvasItemRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Members
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItemRenderer Class Members

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemRenderer Class

Glossary Item Box

The following tables list the members exposed by CanvasItemRenderer.

Public Constructors

 | Name | Description
Public Constructor | CanvasItemRenderer Constructor |
Top

Public Fields

 | Name | Description
Public Field | DeviceInfo | Gets or sets the device information.
Top

Public Properties

 | Name | Description
Public Property | State | Gets or sets the RenderState.
Top

Public Methods

 | Name | Description
Public Method | BeginPage | Begins the specified Page.
Public Method | EndPage | Ends the page.
Public Method | Render | Renders the specified canvas item.
Top

See Also

Reference

CanvasItemRenderer Class
GrapeCity.ActiveReports.Document.Section Namespace


CanvasItemRenderer Constructor

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : CanvasItemRenderer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CanvasItemRenderer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


CanvasItemRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see CanvasItemRenderer members.

Public Methods

 | Name | Description
Public Method | BeginPage | Begins the specified Page.
Public Method | EndPage | Ends the page.
Public Method | Render | Renders the specified canvas item.
Top

See Also

Reference

CanvasItemRenderer Class
GrapeCity.ActiveReports.Document.Section Namespace


BeginPage Method

[image]
ActiveReports 19 .NET Edition
BeginPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : BeginPage Method

page
The specified page.

Glossary Item Box

Begins the specified Page.

Syntax

Visual Basic (Declaration)
Public Overridable Sub BeginPage( _
   ByVal page As Page _
)
C#
public virtual void BeginPage(
   Page page
)

Parameters

page
The specified page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


EndPage Method

[image]
ActiveReports 19 .NET Edition
EndPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : EndPage Method

Glossary Item Box

Ends the page.

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndPage()
C#
public virtual void EndPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : Render Method

item
The specified page canvas item.

Glossary Item Box

Renders the specified canvas item.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Render( _
   ByVal item As CanvasItem _
)
C#
public virtual void Render(
   CanvasItem item
)

Parameters

item
The specified page canvas item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


CanvasItemRenderer Class Properties

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see CanvasItemRenderer members.

Public Properties

 | Name | Description
Public Property | State | Gets or sets the RenderState.
Top

See Also

Reference

CanvasItemRenderer Class
GrapeCity.ActiveReports.Document.Section Namespace


State Property

[image]
ActiveReports 19 .NET Edition
State Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : State Property

Glossary Item Box

Gets or sets the RenderState.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As RenderState
C#
public RenderState State {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


CanvasItemRenderer Class Fields

[image]
ActiveReports 19 .NET Edition
CanvasItemRenderer Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see CanvasItemRenderer members.

Public Fields

 | Name | Description
Public Field | DeviceInfo | Gets or sets the device information.
Top

See Also

Reference

CanvasItemRenderer Class
GrapeCity.ActiveReports.Document.Section Namespace


DeviceInfo Field

[image]
ActiveReports 19 .NET Edition
DeviceInfo Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemRenderer Class : DeviceInfo Field

Glossary Item Box

Gets or sets the device information.

Syntax

Visual Basic (Declaration)
Public DeviceInfo As DeviceInfo
C#
public DeviceInfo DeviceInfo

Remarks

This field should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemRenderer Class
CanvasItemRenderer Members


ClippingStack Class

[image]
ActiveReports 19 .NET Edition
ClippingStack Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClippingStack Class

Glossary Item Box

Represents the clipping stack.

Object Model

ClippingStack Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClippingStack
C#
public sealed class ClippingStack

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.ClippingStack

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Members
GrapeCity.ActiveReports.Document.Section Namespace


ClippingStack Class Members

[image]
ActiveReports 19 .NET Edition
ClippingStack Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClippingStack Class

Glossary Item Box

The following tables list the members exposed by ClippingStack.

Public Methods

 | Name | Description
Public Method | IntersectClipRect | Overloaded. Uses member method System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) on the currentCliprect to calculate the intersecting clipping rectangle and sets that resulting clip rect as the current clip rect available via the ClipRect property.
Public Method | IsRectOutside | Overloaded. Represents whether the element is completely outside the rectangle.
Public Method | PopClipRect | Takes the last cliprect put on the stack and makes it the current cliprect. If there are no cliprects on the stack then the current cliprect is cleared, and IsClipActive is set to false.
Public Method | PushClipRect | Takes the current clipRect (in CurrentClipRect property) and pushes it onto the ClipStack. The current cliprect is still maintained as the "current cliprect".
Top

See Also

Reference

ClippingStack Class
GrapeCity.ActiveReports.Document.Section Namespace


ClippingStack Class Methods

[image]
ActiveReports 19 .NET Edition
ClippingStack Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClippingStack Class

Glossary Item Box

For a list of all members of this type, see ClippingStack members.

Public Methods

 | Name | Description
Public Method | IntersectClipRect | Overloaded. Uses member method System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) on the currentCliprect to calculate the intersecting clipping rectangle and sets that resulting clip rect as the current clip rect available via the ClipRect property.
Public Method | IsRectOutside | Overloaded. Represents whether the element is completely outside the rectangle.
Public Method | PopClipRect | Takes the last cliprect put on the stack and makes it the current cliprect. If there are no cliprects on the stack then the current cliprect is cleared, and IsClipActive is set to false.
Public Method | PushClipRect | Takes the current clipRect (in CurrentClipRect property) and pushes it onto the ClipStack. The current cliprect is still maintained as the "current cliprect".
Top

See Also

Reference

ClippingStack Class
GrapeCity.ActiveReports.Document.Section Namespace


IntersectClipRect Method

[image]
ActiveReports 19 .NET Edition
IntersectClipRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class : IntersectClipRect Method

Glossary Item Box

Uses member method System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) on the currentCliprect to calculate the intersecting clipping rectangle and sets that resulting clip rect as the current clip rect available via the ClipRect property.

Overload List

Overload | Description
IntersectClipRect(RectangleF) | Uses member method System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) on the currentCliprect to calculate the intersecting clipping rectangle and sets that resulting clip rect as the current clip rect available via the ClipRect property.
IntersectClipRect(Single,Single,Single,Single) | Uses the IntersectClipRect(RectangleF) member method for which System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) is initialized based on the values passed to this method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members


IntersectClipRect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClipRect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class > IntersectClipRect Method : IntersectClipRect(RectangleF) Method

intersectClip
The clipping rectangle to intersect the current clipping rectangle with.

Glossary Item Box

Uses member method System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) on the currentCliprect to calculate the intersecting clipping rectangle and sets that resulting clip rect as the current clip rect available via the ClipRect property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClipRect( _
   ByVal intersectClip As RectangleF _
)
C#
public void IntersectClipRect(
   RectangleF intersectClip
)

Parameters

intersectClip
The clipping rectangle to intersect the current clipping rectangle with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members
Overload List


IntersectClipRect(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
IntersectClipRect(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class > IntersectClipRect Method : IntersectClipRect(Single,Single,Single,Single) Method

x
X coordinate of the rectangle
y
Y coordinate of the rectangle
width
Width of the rectangle
height
Height of the rectangle

Glossary Item Box

Uses the IntersectClipRect(RectangleF) member method for which System.Drawing.RectangleF.Intersect(System.Drawing.RectangleF) is initialized based on the values passed to this method.

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClipRect( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void IntersectClipRect(
   float x,
   float y,
   float width,
   float height
)

Parameters

x
X coordinate of the rectangle
y
Y coordinate of the rectangle
width
Width of the rectangle
height
Height of the rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members
Overload List


IsRectOutside Method

[image]
ActiveReports 19 .NET Edition
IsRectOutside Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class : IsRectOutside Method

Glossary Item Box

Represents whether the element is completely outside the rectangle.

Overload List

Overload | Description
IsRectOutside(Single,Single,Single,Single) | Represents whether the element is completely outside the rectangle.
IsRectOutside(RectangleF) | Represents whether the element is completely outside the rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members


IsRectOutside(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
IsRectOutside(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class > IsRectOutside Method : IsRectOutside(Single,Single,Single,Single) Method

x
X coordinate of the rectangle
y
Y coordinate of the rectangle
width
Width of the rectangle
height
Height of the rectangle

Glossary Item Box

Represents whether the element is completely outside the rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsRectOutside( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
) As Boolean
C#
public bool IsRectOutside(
   float x,
   float y,
   float width,
   float height
)

Parameters

x
X coordinate of the rectangle
y
Y coordinate of the rectangle
width
Width of the rectangle
height
Height of the rectangle

Return Value

True if element is entirely outside rectangle, otherwise returns false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members
Overload List


IsRectOutside(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IsRectOutside(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class > IsRectOutside Method : IsRectOutside(RectangleF) Method

rect
Rectangular area

Glossary Item Box

Represents whether the element is completely outside the rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsRectOutside( _
   ByVal rect As RectangleF _
) As Boolean
C#
public bool IsRectOutside(
   RectangleF rect
)

Parameters

rect
Rectangular area

Return Value

True if element is entirely outside rectangle, otherwise returns false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members
Overload List


PopClipRect Method

[image]
ActiveReports 19 .NET Edition
PopClipRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class : PopClipRect Method

Glossary Item Box

Takes the last cliprect put on the stack and makes it the current cliprect. If there are no cliprects on the stack then the current cliprect is cleared, and IsClipActive is set to false.

Syntax

Visual Basic (Declaration)
Public Sub PopClipRect()
C#
public void PopClipRect()

Remarks

The returned value will no longer be present on the stack

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members


PushClipRect Method

[image]
ActiveReports 19 .NET Edition
PushClipRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ClippingStack Class : PushClipRect Method

Glossary Item Box

Takes the current clipRect (in CurrentClipRect property) and pushes it onto the ClipStack. The current cliprect is still maintained as the "current cliprect".

Syntax

Visual Basic (Declaration)
Public Sub PushClipRect()
C#
public void PushClipRect()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClippingStack Class
ClippingStack Members


ClipRect Class

[image]
ActiveReports 19 .NET Edition
ClipRect Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClipRect Class

Glossary Item Box

Represents the rectangle of the clip.

Object Model

ClipRect Class

Syntax

Visual Basic (Declaration)
Public Class ClipRect
   Inherits CanvasItem
C#
public class ClipRect : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ClipRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClipRect Members
GrapeCity.ActiveReports.Document.Section Namespace


ClipRect Class Members

[image]
ActiveReports 19 .NET Edition
ClipRect Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClipRect Class

Glossary Item Box

The following tables list the members exposed by ClipRect.

See Also

Reference

ClipRect Class
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfo Class

[image]
ActiveReports 19 .NET Edition
ControlInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfo Class

Glossary Item Box

Represents the inforamtion about control.

Object Model

ControlInfo Class

Syntax

Visual Basic (Declaration)
Public Class ControlInfo
   Inherits CanvasItem
C#
public class ControlInfo : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ControlInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfo Members
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfo Class Members

[image]
ActiveReports 19 .NET Edition
ControlInfo Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfo Class

Glossary Item Box

The following tables list the members exposed by ControlInfo.

Public Constructors

 | Name | Description
Public Constructor | ControlInfo Constructor | Overloaded.
Top

See Also

Reference

ControlInfo Class
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfo Constructor

[image]
ActiveReports 19 .NET Edition
ControlInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ControlInfo Class : ControlInfo Constructor

Glossary Item Box

Overload List

Overload | Description
ControlInfo Constructor() | Initializes an instance of class ControlInfo.
ControlInfo Constructor(ControlType,String,RectangleF) | Initializes an instance of class ControlInfo..

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfo Class
ControlInfo Members


ControlInfo Constructor()

[image]
ActiveReports 19 .NET Edition
ControlInfo Constructor()
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ControlInfo Class > ControlInfo Constructor : ControlInfo Constructor()

Glossary Item Box

Initializes an instance of class ControlInfo.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ControlInfo()

Example

C# Copy Code
ControlInfo ci = new ControlInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfo Class
ControlInfo Members
Overload List


ControlInfo Constructor(ControlType,String,RectangleF)

[image]
ActiveReports 19 .NET Edition
ControlInfo Constructor(ControlType,String,RectangleF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ControlInfo Class > ControlInfo Constructor : ControlInfo Constructor(ControlType,String,RectangleF)

type
The control type.
name
The name.
bounds
The bounds.

Glossary Item Box

Initializes an instance of class ControlInfo..

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As ControlType, _
   ByVal name As String, _
   ByVal bounds As RectangleF _
)
C#
public ControlInfo(
   ControlType type,
   string name,
   RectangleF bounds
)

Parameters

type
The control type.
name
The name.
bounds
The bounds.

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfo Class
ControlInfo Members
Overload List


ControlInfoEnd Class

[image]
ActiveReports 19 .NET Edition
ControlInfoEnd Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfoEnd Class

Glossary Item Box

Represents the end of the control information.

Object Model

ControlInfoEnd Class

Syntax

Visual Basic (Declaration)
Public Class ControlInfoEnd
   Inherits CanvasItem
C#
public class ControlInfoEnd : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ControlInfoEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfoEnd Members
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfoEnd Class Members

[image]
ActiveReports 19 .NET Edition
ControlInfoEnd Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfoEnd Class

Glossary Item Box

The following tables list the members exposed by ControlInfoEnd.

Public Constructors

 | Name | Description
Public Constructor | ControlInfoEnd Constructor | Initializes an instance of class ControlInfoEnd.
Top

See Also

Reference

ControlInfoEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfoEnd Constructor

[image]
ActiveReports 19 .NET Edition
ControlInfoEnd Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ControlInfoEnd Class : ControlInfoEnd Constructor

Glossary Item Box

Initializes an instance of class ControlInfoEnd.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ControlInfoEnd()

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlInfoEnd Class
ControlInfoEnd Members


DrawCanvas Class

[image]
ActiveReports 19 .NET Edition
DrawCanvas Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawCanvas Class

Glossary Item Box

Represents a canvas for painting.

Object Model

DrawCanvas Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DrawCanvas
C#
public sealed class DrawCanvas

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.DrawCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Members
GrapeCity.ActiveReports.Document.Section Namespace


DrawCanvas Class Members

[image]
ActiveReports 19 .NET Edition
DrawCanvas Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawCanvas Class

Glossary Item Box

The following tables list the members exposed by DrawCanvas.

Public Constructors

 | Name | Description
Public Constructor | DrawCanvas Constructor | Initializes new instance of DrawCanvas object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | BackColor
Public Property | CharacterSpacing | Character Spacing in inches. Could be negative.
Public Property | DeviceInfo | Gets the DeviceInfo.
Public Property | EnableKinsoku |
Public Property | Font |
Public Property | Fonts | Summary description for Fonts Property.
Public Property | ForeColor | ForeColor
Public Property | ImageConverterService | Gets the image converter service.
Public Property | LineSpacing | Line height in inches
Public Property | Padding | Padding
Public Property | PenStyle | PenStyle
Public Property | PenWidth | PenWidth
Public Property | RightToLeft | RightToLeft
Public Property | ScaleX | Minimal character condensed rate (from 0.1 to 1).
Public Property | TabStops | Custom tab stops collection
Public Property | TextAlignment | TextAlignment
Public Property | TextAngle | TextAngle
Public Property | TextJustify |
Public Property | TextLayoutService | Gets the text layout service.
Public Property | TextRenderHint |
Public Property | Units | Units
Public Property | VerticalText |
Public Property | VerticalTextAlignment | VerticalTextAlignment
Public Property | WordWrap |
Public Property | WrapMode | Gets or sets the wrap mode.
Top

Public Methods

 | Name | Description
Public Method | DrawBorder | Overloaded. DrawBorder
Public Method | DrawCheckBoxInputField | Overloaded.
Public Method | DrawEllipse | DrawEllipse
Public Method | DrawEvaluationTextLink |
Public Method | DrawImage | Overloaded. Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.
Public Method | DrawLine | DrawLine
Public Method | DrawRect | Overloaded. DrawRect
Public Method | DrawRoundRect | Overloaded. DrawRoundRect
Public Method | DrawSvg | DrawSvg
Public Method | DrawTable | The DrawTable Method allows to draw a table control to a page.
Public Method | DrawText | Overloaded. DrawText
Public Method | DrawTextFallback | Overloaded. DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)
Public Method | DrawTextInputField | Overloaded.
Public Method | FillRect | Overloaded. FillRect
Public Method | IntersectClip | Overloaded. IntersectClip
Public Method | RestoreClip |
Public Method | SaveClip |
Public Method | SetTextBoundsRange | Set text top/bottom bounds range.
Public Method | WriteTextInfo |
Top

See Also

Reference

DrawCanvas Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawCanvas Constructor

[image]
ActiveReports 19 .NET Edition
DrawCanvas Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawCanvas Constructor

deviceInfo
The device info.
textLayoutService
The text layout service.
imageConverterService
The image converter service.
page
The page.

Glossary Item Box

Initializes new instance of DrawCanvas object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal deviceInfo As DeviceInfo, _
   ByVal textLayoutService As ITextLayoutService, _
   ByVal imageConverterService As IImageConverterService, _
   ByVal page As Page _
)
C#
public DrawCanvas(
   DeviceInfo deviceInfo,
   ITextLayoutService textLayoutService,
   IImageConverterService imageConverterService,
   Page page
)

Parameters

deviceInfo
The device info.
textLayoutService
The text layout service.
imageConverterService
The image converter service.
page
The page.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if any parameter (except device info) is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawCanvas Class Methods

[image]
ActiveReports 19 .NET Edition
DrawCanvas Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawCanvas Class

Glossary Item Box

For a list of all members of this type, see DrawCanvas members.

Public Methods

 | Name | Description
Public Method | DrawBorder | Overloaded. DrawBorder
Public Method | DrawCheckBoxInputField | Overloaded.
Public Method | DrawEllipse | DrawEllipse
Public Method | DrawEvaluationTextLink |
Public Method | DrawImage | Overloaded. Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.
Public Method | DrawLine | DrawLine
Public Method | DrawRect | Overloaded. DrawRect
Public Method | DrawRoundRect | Overloaded. DrawRoundRect
Public Method | DrawSvg | DrawSvg
Public Method | DrawTable | The DrawTable Method allows to draw a table control to a page.
Public Method | DrawText | Overloaded. DrawText
Public Method | DrawTextFallback | Overloaded. DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)
Public Method | DrawTextInputField | Overloaded.
Public Method | FillRect | Overloaded. FillRect
Public Method | IntersectClip | Overloaded. IntersectClip
Public Method | RestoreClip |
Public Method | SaveClip |
Public Method | SetTextBoundsRange | Set text top/bottom bounds range.
Public Method | WriteTextInfo |
Top

See Also

Reference

DrawCanvas Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawBorder Method

[image]
ActiveReports 19 .NET Edition
DrawBorder Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawBorder Method

Glossary Item Box

DrawBorder

Overload List

Overload | Description
DrawBorder(Border,Single,Single,Single,Single) | DrawBorder
DrawBorder(Border,RectangleF) | DrawBorder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawBorder(Border,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawBorder(Border,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawBorder Method : DrawBorder(Border,Single,Single,Single,Single) Method

border
left
top
width
height

Glossary Item Box

DrawBorder

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawBorder(
   Border border,
   float left,
   float top,
   float width,
   float height
)

Parameters

border
left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawBorder(Border,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawBorder(Border,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawBorder Method : DrawBorder(Border,RectangleF) Method

border
bounds

Glossary Item Box

DrawBorder

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal bounds As RectangleF _
)
C#
public void DrawBorder(
   Border border,
   RectangleF bounds
)

Parameters

border
bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawCheckBoxInputField Method

[image]
ActiveReports 19 .NET Edition
DrawCheckBoxInputField Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawCheckBoxInputField Method

Glossary Item Box

Overload List

Overload | Description
DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle) |
DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawCheckBoxInputField Method : DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle) Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawCheckBoxInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal checked As Boolean, _
   ByVal checkSize As Single, _
   ByVal checkStyle As InputCheckStyle _
)
C#
public void DrawCheckBoxInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   bool checked,
   float checkSize,
   InputCheckStyle checkStyle
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle,Int32) Method

[image]
ActiveReports 19 .NET Edition
DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawCheckBoxInputField Method : DrawCheckBoxInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Boolean,Single,InputCheckStyle,Int32) Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle
tabIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawCheckBoxInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal checked As Boolean, _
   ByVal checkSize As Single, _
   ByVal checkStyle As InputCheckStyle, _
   ByVal tabIndex As Integer _
)
C#
public void DrawCheckBoxInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   bool checked,
   float checkSize,
   InputCheckStyle checkStyle,
   int tabIndex
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
checked
checkSize
checkStyle
tabIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawEllipse Method

left
top
width
height

Glossary Item Box

DrawEllipse

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawEllipse(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawEvaluationTextLink Method

[image]
ActiveReports 19 .NET Edition
DrawEvaluationTextLink Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawEvaluationTextLink Method

text
link
bounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawEvaluationTextLink( _
   ByVal text As String, _
   ByVal link As String, _
   ByVal bounds As RectangleF _
)
C#
public void DrawEvaluationTextLink(
   string text,
   string link,
   RectangleF bounds
)

Parameters

text
link
bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawImage Method

Glossary Item Box

Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.

Overload List

Overload | Description
DrawImage(Image,Single,Single,Single,Single,String,String,String) | Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.
DrawImage(Image,RectangleF,String,String,String) | Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,Single,Single,Single,Single,String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

image
left
top
width
height
strLink
title
description

Glossary Item Box

Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   Optional ByVal strLink As String, _
   Optional ByVal title As String, _
   Optional ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string strLink,
   string title,
   string description
)

Parameters

image
left
top
width
height
strLink
title
description

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawImage(Image,RectangleF,String,String,String) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(Image,RectangleF,String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawImage Method : DrawImage(Image,RectangleF,String,String,String) Method

image
bounds
strLink
title
description

Glossary Item Box

Creates a resourced сanvas item based on image data and adds it to internal canvas items collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF, _
   Optional ByVal strLink As String, _
   Optional ByVal title As String, _
   Optional ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   RectangleF bounds,
   string strLink,
   string title,
   string description
)

Parameters

image
bounds
strLink
title
description

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawLine Method

x1
y1
x2
y2

Glossary Item Box

DrawLine

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

x1
y1
x2
y2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawRect Method

[image]
ActiveReports 19 .NET Edition
DrawRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawRect Method

Glossary Item Box

DrawRect

Overload List

Overload | Description
DrawRect(Single,Single,Single,Single) | DrawRect
DrawRect(RectangleF) | DrawRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawRect(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRect(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawRect Method : DrawRect(Single,Single,Single,Single) Method

left
top
width
height

Glossary Item Box

DrawRect

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawRect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawRect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawRect Method : DrawRect(RectangleF) Method

rc

Glossary Item Box

DrawRect

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal rc As RectangleF _
)
C#
public void DrawRect(
   RectangleF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawRoundRect Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawRoundRect Method

Glossary Item Box

DrawRoundRect

Overload List

Overload | Description
DrawRoundRect(Single,Single,Single,Single,Single,Single) | DrawRoundRect
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) | Renders rounded rect with different corner radiuses.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(Single,Single,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

left
top
width
height
edgeWidth
edgeHeight

Glossary Item Box

DrawRoundRect

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal edgeWidth As Single, _
   ByVal edgeHeight As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float edgeWidth,
   float edgeHeight
)

Parameters

left
top
width
height
edgeWidth
edgeHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Renders rounded rect with different corner radiuses.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawSvg Method

[image]
ActiveReports 19 .NET Edition
DrawSvg Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawSvg Method

left
top
width
height
svg

Glossary Item Box

DrawSvg

Syntax

Visual Basic (Declaration)
Public Sub DrawSvg( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal svg As String _
)
C#
public void DrawSvg(
   float left,
   float top,
   float width,
   float height,
   string svg
)

Parameters

left
top
width
height
svg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawTable Method

[image]
ActiveReports 19 .NET Edition
DrawTable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawTable Method

bounds

Glossary Item Box

The DrawTable Method allows to draw a table control to a page.

Syntax

Visual Basic (Declaration)
Public Function DrawTable( _
   ByVal bounds As RectangleF _
) As PageTable
C#
public PageTable DrawTable(
   RectangleF bounds
)

Parameters

bounds

Return Value

PageTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawText Method

[image]
ActiveReports 19 .NET Edition
DrawText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawText Method

Glossary Item Box

DrawText

Overload List

Overload | Description
DrawText(String,Single,Single,Single,Single) | DrawText
DrawText(String,RectangleF) | DrawText
DrawText(String[],Single,Single,Single,Single) | RS: CR 24033 - Keep the method with the old signature for the back compatibility
DrawText(String[],RectangleF) | DrawText
DrawText(String,Single,Single,Single,Single,String) | DrawText
DrawText(String,RectangleF,String) | DrawText
DrawText(String[],Single,Single,Single,Single,String) | RS: CR 24033 - Keep the old method signature for the back compatibility
DrawText(String[],RectangleF,String) | DrawText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawText(String,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String,Single,Single,Single,Single) Method

strText
left
top
width
height

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height
)

Parameters

strText
left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String,RectangleF) Method

strText
text

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string strText,
   RectangleF text
)

Parameters

strText
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String[],Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String[],Single,Single,Single,Single) Method

astrText
left
top
width
height

Glossary Item Box

RS: CR 24033 - Keep the method with the old signature for the back compatibility

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height
)

Parameters

astrText
left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String[],RectangleF) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String[],RectangleF) Method

astrText
text

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text
)

Parameters

astrText
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String,Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String,Single,Single,Single,Single,String) Method

strText
left
top
width
height
strLink

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

strText
left
top
width
height
strLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String,RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String,RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String,RectangleF,String) Method

strText
text
strLink

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   RectangleF text,
   string strLink
)

Parameters

strText
text
strLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String[],Single,Single,Single,Single,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],Single,Single,Single,Single,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String[],Single,Single,Single,Single,String) Method

astrText
left
top
width
height
strLink

Glossary Item Box

RS: CR 24033 - Keep the old method signature for the back compatibility

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

astrText
left
top
width
height
strLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawText(String[],RectangleF,String) Method

[image]
ActiveReports 19 .NET Edition
DrawText(String[],RectangleF,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawText Method : DrawText(String[],RectangleF,String) Method

astrText
text
strLink

Glossary Item Box

DrawText

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text,
   string strLink
)

Parameters

astrText
text
strLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawTextFallback Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawTextFallback Method

Glossary Item Box

DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)

Overload List

Overload | Description
DrawTextFallback(String[],Single,Single,Single,Single,String[]) | DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)
DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) | DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawTextFallback Method : DrawTextFallback(String[],Single,Single,Single,Single,String[]) Method

astrText
left
top
width
height
astrTextFallback

Glossary Item Box

DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextFallback( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal astrTextFallback() As String _
)
C#
public void DrawTextFallback(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string[] astrTextFallback
)

Parameters

astrText
left
top
width
height
astrTextFallback

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method

[image]
ActiveReports 19 .NET Edition
DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawTextFallback Method : DrawTextFallback(String[],Single,Single,Single,Single,String,String[]) Method

astrText
left
top
width
height
strLink
astrTextFallback

Glossary Item Box

DrawText RS: CR 24033 - Add parameter to store fallback set of lines(when the align is set to Justify and the report is exported into RDF 20)

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextFallback( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String, _
   ByVal astrTextFallback() As String _
)
C#
public void DrawTextFallback(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string strLink,
   string[] astrTextFallback
)

Parameters

astrText
left
top
width
height
strLink
astrTextFallback

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawTextInputField Method

[image]
ActiveReports 19 .NET Edition
DrawTextInputField Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DrawTextInputField Method

Glossary Item Box

Overload List

Overload | Description
DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[]) |
DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[],Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[]) Method

[image]
ActiveReports 19 .NET Edition
DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawTextInputField Method : DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[]) Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal maxLength As Integer, _
   ByVal multiline As Boolean, _
   ByVal password As Boolean, _
   ByVal spellCheck As Boolean, _
   ByVal alignment As InputTextAlign, _
   ByVal textArray() As String _
)
C#
public void DrawTextInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   int maxLength,
   bool multiline,
   bool password,
   bool spellCheck,
   InputTextAlign alignment,
   string[] textArray
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[],Int32) Method

[image]
ActiveReports 19 .NET Edition
DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[],Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > DrawTextInputField Method : DrawTextInputField(RectangleF,String,Boolean,Boolean,InputBorderStyle,Single,Color,Int32,Boolean,Boolean,Boolean,InputTextAlign,String[],Int32) Method

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray
tabIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawTextInputField( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal maxLength As Integer, _
   ByVal multiline As Boolean, _
   ByVal password As Boolean, _
   ByVal spellCheck As Boolean, _
   ByVal alignment As InputTextAlign, _
   ByVal textArray() As String, _
   ByVal tabIndex As Integer _
)
C#
public void DrawTextInputField(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   int maxLength,
   bool multiline,
   bool password,
   bool spellCheck,
   InputTextAlign alignment,
   string[] textArray,
   int tabIndex
)

Parameters

bounds
fieldName
readOnly
required
borderStyle
borderWidth
borderColor
maxLength
multiline
password
spellCheck
alignment
textArray
tabIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


FillRect Method

[image]
ActiveReports 19 .NET Edition
FillRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : FillRect Method

Glossary Item Box

FillRect

Overload List

Overload | Description
FillRect(Single,Single,Single,Single) | FillRect
FillRect(RectangleF) | FillRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


FillRect(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
FillRect(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > FillRect Method : FillRect(Single,Single,Single,Single) Method

left
top
width
height

Glossary Item Box

FillRect

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void FillRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


FillRect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
FillRect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > FillRect Method : FillRect(RectangleF) Method

rc

Glossary Item Box

FillRect

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal rc As RectangleF _
)
C#
public void FillRect(
   RectangleF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : IntersectClip Method

Glossary Item Box

IntersectClip

Overload List

Overload | Description
IntersectClip(RectangleF) |
IntersectClip(Single,Single,Single,Single) | IntersectClip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


IntersectClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > IntersectClip Method : IntersectClip(RectangleF) Method

clip

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal clip As RectangleF _
)
C#
public void IntersectClip(
   RectangleF clip
)

Parameters

clip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


IntersectClip(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class > IntersectClip Method : IntersectClip(Single,Single,Single,Single) Method

left
top
width
height

Glossary Item Box

IntersectClip

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void IntersectClip(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
top
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members
Overload List


RestoreClip Method

[image]
ActiveReports 19 .NET Edition
RestoreClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : RestoreClip Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RestoreClip()
C#
public void RestoreClip()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


SaveClip Method

[image]
ActiveReports 19 .NET Edition
SaveClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : SaveClip Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SaveClip()
C#
public void SaveClip()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


SetTextBoundsRange Method

[image]
ActiveReports 19 .NET Edition
SetTextBoundsRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : SetTextBoundsRange Method

startPos
endPos

Glossary Item Box

Set text top/bottom bounds range.

Syntax

Visual Basic (Declaration)
Public Sub SetTextBoundsRange( _
   ByVal startPos As Single, _
   ByVal endPos As Single _
)
C#
public void SetTextBoundsRange(
   float startPos,
   float endPos
)

Parameters

startPos
endPos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


WriteTextInfo Method

[image]
ActiveReports 19 .NET Edition
WriteTextInfo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : WriteTextInfo Method

textInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub WriteTextInfo( _
   ByVal textInfo As TextInfoItem _
)
C#
public void WriteTextInfo(
   TextInfoItem textInfo
)

Parameters

textInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawCanvas Class Properties

[image]
ActiveReports 19 .NET Edition
DrawCanvas Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawCanvas Class

Glossary Item Box

For a list of all members of this type, see DrawCanvas members.

Public Properties

 | Name | Description
Public Property | BackColor | BackColor
Public Property | CharacterSpacing | Character Spacing in inches. Could be negative.
Public Property | DeviceInfo | Gets the DeviceInfo.
Public Property | EnableKinsoku |
Public Property | Font |
Public Property | Fonts | Summary description for Fonts Property.
Public Property | ForeColor | ForeColor
Public Property | ImageConverterService | Gets the image converter service.
Public Property | LineSpacing | Line height in inches
Public Property | Padding | Padding
Public Property | PenStyle | PenStyle
Public Property | PenWidth | PenWidth
Public Property | RightToLeft | RightToLeft
Public Property | ScaleX | Minimal character condensed rate (from 0.1 to 1).
Public Property | TabStops | Custom tab stops collection
Public Property | TextAlignment | TextAlignment
Public Property | TextAngle | TextAngle
Public Property | TextJustify |
Public Property | TextLayoutService | Gets the text layout service.
Public Property | TextRenderHint |
Public Property | Units | Units
Public Property | VerticalText |
Public Property | VerticalTextAlignment | VerticalTextAlignment
Public Property | WordWrap |
Public Property | WrapMode | Gets or sets the wrap mode.
Top

See Also

Reference

DrawCanvas Class
GrapeCity.ActiveReports.Document.Section Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : BackColor Property

Glossary Item Box

BackColor

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : CharacterSpacing Property

Glossary Item Box

Character Spacing in inches. Could be negative.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DeviceInfo Property

[image]
ActiveReports 19 .NET Edition
DeviceInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : DeviceInfo Property

Glossary Item Box

Gets the DeviceInfo.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceInfo As DeviceInfo
C#
public DeviceInfo DeviceInfo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


EnableKinsoku Property

[image]
ActiveReports 19 .NET Edition
EnableKinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : EnableKinsoku Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnableKinsoku As Boolean
C#
public bool EnableKinsoku {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : Fonts Property

Glossary Item Box

Summary description for Fonts Property.

Syntax

Visual Basic (Declaration)
Public Property Fonts As FontsCollection
C#
public FontsCollection Fonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


ForeColor Property

[image]
ActiveReports 19 .NET Edition
ForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : ForeColor Property

Glossary Item Box

ForeColor

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


ImageConverterService Property

[image]
ActiveReports 19 .NET Edition
ImageConverterService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : ImageConverterService Property

Glossary Item Box

Gets the image converter service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageConverterService As IImageConverterService
C#
public IImageConverterService ImageConverterService {get;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Core.Document.IImageConverterService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : LineSpacing Property

Glossary Item Box

Line height in inches

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : Padding Property

Glossary Item Box

Padding

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


PenStyle Property

[image]
ActiveReports 19 .NET Edition
PenStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : PenStyle Property

Glossary Item Box

PenStyle

Syntax

Visual Basic (Declaration)
Public Property PenStyle As PenStyles
C#
public PenStyles PenStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


PenWidth Property

[image]
ActiveReports 19 .NET Edition
PenWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : PenWidth Property

Glossary Item Box

PenWidth

Syntax

Visual Basic (Declaration)
Public Property PenWidth As Short
C#
public short PenWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : RightToLeft Property

Glossary Item Box

RightToLeft

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


ScaleX Property

[image]
ActiveReports 19 .NET Edition
ScaleX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : ScaleX Property

Glossary Item Box

Minimal character condensed rate (from 0.1 to 1).

Syntax

Visual Basic (Declaration)
Public Property ScaleX As Single
C#
public float ScaleX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TabStops Property

Glossary Item Box

Custom tab stops collection

Syntax

Visual Basic (Declaration)
Public Property TabStops As TabStopsItem.TabStop()
C#
public TabStopsItem.TabStop[] TabStops {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TextAlignment Property

[image]
ActiveReports 19 .NET Edition
TextAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TextAlignment Property

Glossary Item Box

TextAlignment

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment
C#
public TextAlignment TextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TextAngle Property

[image]
ActiveReports 19 .NET Edition
TextAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TextAngle Property

Glossary Item Box

TextAngle

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Integer
C#
public int TextAngle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TextJustify Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TextLayoutService Property

[image]
ActiveReports 19 .NET Edition
TextLayoutService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TextLayoutService Property

Glossary Item Box

Gets the text layout service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextLayoutService As ITextLayoutService
C#
public ITextLayoutService TextLayoutService {get;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Core.Document.ITextLayoutService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


TextRenderHint Property

[image]
ActiveReports 19 .NET Edition
TextRenderHint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : TextRenderHint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextRenderHint As TextRenderHint
C#
public TextRenderHint TextRenderHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


Units Property

[image]
ActiveReports 19 .NET Edition
Units Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : Units Property

Glossary Item Box

Units

Syntax

Visual Basic (Declaration)
Public Property Units As Units
C#
public Units Units {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


VerticalText Property

[image]
ActiveReports 19 .NET Edition
VerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : VerticalText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


VerticalTextAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalTextAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : VerticalTextAlignment Property

Glossary Item Box

VerticalTextAlignment

Syntax

Visual Basic (Declaration)
Public Property VerticalTextAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalTextAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


WordWrap Property

[image]
ActiveReports 19 .NET Edition
WordWrap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : WordWrap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property WordWrap As Boolean
C#
public bool WordWrap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawCanvas Class : WrapMode Property

Glossary Item Box

Gets or sets the wrap mode.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawCanvas Class
DrawCanvas Members


DrawText Class

[image]
ActiveReports 19 .NET Edition
DrawText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText Class

Glossary Item Box

Represents the text for drawing.

Object Model

DrawText Class

Syntax

Visual Basic (Declaration)
Public Class DrawText
   Inherits CanvasItem
   Implements IBordered
C#
public class DrawText : CanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.DrawText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText Members
GrapeCity.ActiveReports.Document.Section Namespace


DrawText Class Members

[image]
ActiveReports 19 .NET Edition
DrawText Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText Class

Glossary Item Box

The following tables list the members exposed by DrawText.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

DrawText Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawText Class Properties

[image]
ActiveReports 19 .NET Edition
DrawText Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText Class

Glossary Item Box

For a list of all members of this type, see DrawText members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

DrawText Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText Class
DrawText Members


DrawText2 Class

[image]
ActiveReports 19 .NET Edition
DrawText2 Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText2 Class

Glossary Item Box

Represents the text for drawing.

Object Model

DrawText2 Class

Syntax

Visual Basic (Declaration)
Public Class DrawText2
   Inherits CanvasItem
   Implements IBordered
C#
public class DrawText2 : CanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.DrawText2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Members
GrapeCity.ActiveReports.Document.Section Namespace


DrawText2 Class Members

[image]
ActiveReports 19 .NET Edition
DrawText2 Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText2 Class

Glossary Item Box

The following tables list the members exposed by DrawText2.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets or sets the height of the item.
Public Property | Left | Gets the left of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

DrawText2 Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawText2 Class Properties

[image]
ActiveReports 19 .NET Edition
DrawText2 Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText2 Class

Glossary Item Box

For a list of all members of this type, see DrawText2 members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets or sets the height of the item.
Public Property | Left | Gets the left of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

DrawText2 Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText2 Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Class
DrawText2 Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText2 Class : Height Property

Glossary Item Box

Gets or sets the height of the item.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Class
DrawText2 Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText2 Class : Left Property

Glossary Item Box

Gets the left of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Class
DrawText2 Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText2 Class : Top Property

Glossary Item Box

Gets the top of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Class
DrawText2 Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawText2 Class : Width Property

Glossary Item Box

Gets the width of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
C#
public float Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawText2 Class
DrawText2 Members


DrawTextLink Class

[image]
ActiveReports 19 .NET Edition
DrawTextLink Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawTextLink Class

Glossary Item Box

Represents a text link to draw.

Object Model

DrawTextLink Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DrawTextLink
   Inherits CanvasItem
   Implements IBordered, ILinkItem
C#
public sealed class DrawTextLink : CanvasItem, IBordered, ILinkItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.DrawTextLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawTextLink Members
GrapeCity.ActiveReports.Document.Section Namespace


DrawTextLink Class Members

[image]
ActiveReports 19 .NET Edition
DrawTextLink Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawTextLink Class

Glossary Item Box

The following tables list the members exposed by DrawTextLink.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Link | Gets the link.
Public Property | Title | Gets the title of the item.
Top

See Also

Reference

DrawTextLink Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawTextLink Class Properties

[image]
ActiveReports 19 .NET Edition
DrawTextLink Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawTextLink Class

Glossary Item Box

For a list of all members of this type, see DrawTextLink members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Link | Gets the link.
Public Property | Title | Gets the title of the item.
Top

See Also

Reference

DrawTextLink Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawTextLink Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawTextLink Class
DrawTextLink Members


Link Property

[image]
ActiveReports 19 .NET Edition
Link Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawTextLink Class : Link Property

Glossary Item Box

Gets the link.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Link As String
C#
public string Link {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawTextLink Class
DrawTextLink Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > DrawTextLink Class : Title Property

Glossary Item Box

Gets the title of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Title As String
C#
public string Title {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawTextLink Class
DrawTextLink Members


Ellipse Class

[image]
ActiveReports 19 .NET Edition
Ellipse Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Ellipse Class

Glossary Item Box

Represents the ellipse canvas item.

Object Model

Ellipse Class

Syntax

Visual Basic (Declaration)
Public Class Ellipse
   Inherits CanvasItem
   Implements IBordered
C#
public class Ellipse : CanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Ellipse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Members
GrapeCity.ActiveReports.Document.Section Namespace


Ellipse Class Members

[image]
ActiveReports 19 .NET Edition
Ellipse Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Ellipse Class

Glossary Item Box

The following tables list the members exposed by Ellipse.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets the height of the item.
Public Property | Left | Gets the left of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

Ellipse Class
GrapeCity.ActiveReports.Document.Section Namespace


Ellipse Class Properties

[image]
ActiveReports 19 .NET Edition
Ellipse Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Ellipse Class

Glossary Item Box

For a list of all members of this type, see Ellipse members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets the height of the item.
Public Property | Left | Gets the left of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

Ellipse Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Ellipse Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Class
Ellipse Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Ellipse Class : Height Property

Glossary Item Box

Gets the height of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
C#
public float Height {get;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Class
Ellipse Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Ellipse Class : Left Property

Glossary Item Box

Gets the left of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Property Value

The left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Class
Ellipse Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Ellipse Class : Top Property

Glossary Item Box

Gets the top of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Property Value

The top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Class
Ellipse Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Ellipse Class : Width Property

Glossary Item Box

Gets the width of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
C#
public float Width {get;}

Property Value

The width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Ellipse Class
Ellipse Members


EnhMeta Class

[image]
ActiveReports 19 .NET Edition
EnhMeta Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMeta Class

Glossary Item Box

Represents the canvas item for WMF or EMF images. Represents the canvas item for WMF or EMF images.

Object Model

EnhMeta Class

Syntax

Visual Basic (Declaration)
Public Class EnhMeta
   Inherits ResourcedCanvasItem
   Implements IBordered
C#
public class EnhMeta : ResourcedCanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.EnhMeta

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnhMeta Members
GrapeCity.ActiveReports.Document.Section Namespace


EnhMeta Class Members

[image]
ActiveReports 19 .NET Edition
EnhMeta Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMeta Class

Glossary Item Box

The following tables list the members exposed by EnhMeta.

See Also

Reference

EnhMeta Class
GrapeCity.ActiveReports.Document.Section Namespace


EnhMetaLink Class

[image]
ActiveReports 19 .NET Edition
EnhMetaLink Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMetaLink Class

Glossary Item Box

Represents the canvas item for WMF or EMF images with hyperlink. Represents the canvas item for WMF or EMF images with hyperlink.

Object Model

EnhMetaLink Class

Syntax

Visual Basic (Declaration)
Public Class EnhMetaLink
   Inherits LinkItem
   Implements IBordered, ILinkItem
C#
public class EnhMetaLink : LinkItem, IBordered, ILinkItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.LinkItem
GrapeCity.ActiveReports.Document.Section.EnhMetaLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnhMetaLink Members
GrapeCity.ActiveReports.Document.Section Namespace


EnhMetaLink Class Members

[image]
ActiveReports 19 .NET Edition
EnhMetaLink Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMetaLink Class

Glossary Item Box

The following tables list the members exposed by EnhMetaLink.

See Also

Reference

EnhMetaLink Class
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationEnd Class

[image]
ActiveReports 19 .NET Edition
EvaluationEnd Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationEnd Class

Glossary Item Box

Represents the end of the evalution.

Object Model

EvaluationEnd Class

Syntax

Visual Basic (Declaration)
Public Class EvaluationEnd
   Inherits CanvasItem
C#
public class EvaluationEnd : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.EvaluationEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationEnd Members
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationEnd Class Members

[image]
ActiveReports 19 .NET Edition
EvaluationEnd Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationEnd Class

Glossary Item Box

The following tables list the members exposed by EvaluationEnd.

See Also

Reference

EvaluationEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationStart Class

[image]
ActiveReports 19 .NET Edition
EvaluationStart Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationStart Class

Glossary Item Box

Represents the beginning of the evaluation.

Object Model

EvaluationStart Class

Syntax

Visual Basic (Declaration)
Public Class EvaluationStart
   Inherits CanvasItem
C#
public class EvaluationStart : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.EvaluationStart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationStart Members
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationStart Class Members

[image]
ActiveReports 19 .NET Edition
EvaluationStart Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationStart Class

Glossary Item Box

The following tables list the members exposed by EvaluationStart.

See Also

Reference

EvaluationStart Class
GrapeCity.ActiveReports.Document.Section Namespace


FillRect Class

[image]
ActiveReports 19 .NET Edition
FillRect Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : FillRect Class

Glossary Item Box

Represents a canvas element with a rectangular fill.

Object Model

FillRect Class

Syntax

Visual Basic (Declaration)
Public Class FillRect
   Inherits CanvasItem
   Implements IBordered
C#
public class FillRect : CanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.FillRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillRect Members
GrapeCity.ActiveReports.Document.Section Namespace


FillRect Class Members

[image]
ActiveReports 19 .NET Edition
FillRect Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : FillRect Class

Glossary Item Box

The following tables list the members exposed by FillRect.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

FillRect Class
GrapeCity.ActiveReports.Document.Section Namespace


FillRect Class Properties

[image]
ActiveReports 19 .NET Edition
FillRect Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : FillRect Class

Glossary Item Box

For a list of all members of this type, see FillRect members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

FillRect Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > FillRect Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillRect Class
FillRect Members


ForeColor Class

[image]
ActiveReports 19 .NET Edition
ForeColor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ForeColor Class

Glossary Item Box

Represents the foreground color.

Object Model

ForeColor Class

Syntax

Visual Basic (Declaration)
Public Class ForeColor
   Inherits CanvasItem
C#
public class ForeColor : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ForeColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeColor Members
GrapeCity.ActiveReports.Document.Section Namespace


ForeColor Class Members

[image]
ActiveReports 19 .NET Edition
ForeColor Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ForeColor Class

Glossary Item Box

The following tables list the members exposed by ForeColor.

Public Constructors

 | Name | Description
Public Constructor | ForeColor Constructor | Initializes a new instance of the ForeColor class.
Top

See Also

Reference

ForeColor Class
GrapeCity.ActiveReports.Document.Section Namespace


ForeColor Constructor

[image]
ActiveReports 19 .NET Edition
ForeColor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ForeColor Class : ForeColor Constructor

crFore
The foreground color.

Glossary Item Box

Initializes a new instance of the ForeColor class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal crFore As Color _
)
C#
public ForeColor(
   Color crFore
)

Parameters

crFore
The foreground color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeColor Class
ForeColor Members


InputFieldCheckBoxItem Class

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldCheckBoxItem Class

Glossary Item Box

Represents the canvas item for checkBox fields.

Object Model

InputFieldCheckBoxItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InputFieldCheckBoxItem
   Inherits InputFieldItem
   Implements IBordered
C#
public sealed class InputFieldCheckBoxItem : InputFieldItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.InputFieldItem
GrapeCity.ActiveReports.Document.Section.InputFieldCheckBoxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Members
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldCheckBoxItem Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldCheckBoxItem Class

Glossary Item Box

The following tables list the members exposed by InputFieldCheckBoxItem.

Public Constructors

 | Name | Description
Public Constructor | InputFieldCheckBoxItem Constructor | Initializes an instance of class InputFieldCheckBoxItem.
Top

Public Properties

 | Name | Description
Public Property | Checked | Gets the value indicating the state of the CheckBox.
Public Property | CheckSize | Gets the size of check symbol inside the CheckBox.
Public Property | CheckStyle | Gets the style of check symbol inside the CheckBox.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Performs a cloning of this instance.
Public Method | ToString | Overridden. Returns a string that represents the current object.
Top

See Also

Reference

InputFieldCheckBoxItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldCheckBoxItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : InputFieldCheckBoxItem Constructor

bounds
The bounds.
fieldName
The field name.
readOnly
The flag defining the read-only state.
required
The flag defining the required state.
borderStyle
The border style.
borderWidth
The border width.
borderColor
The border color.
checked
The flag defining the checked state.
checkSize
The check size.
checkStyle
The ceck style.

Glossary Item Box

Initializes an instance of class InputFieldCheckBoxItem.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal checked As Boolean, _
   ByVal checkSize As Single, _
   ByVal checkStyle As InputCheckStyle _
)
C#
public InputFieldCheckBoxItem(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   bool checked,
   float checkSize,
   InputCheckStyle checkStyle
)

Parameters

bounds
The bounds.
fieldName
The field name.
readOnly
The flag defining the read-only state.
required
The flag defining the required state.
borderStyle
The border style.
borderWidth
The border width.
borderColor
The border color.
checked
The flag defining the checked state.
checkSize
The check size.
checkStyle
The ceck style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


InputFieldCheckBoxItem Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldCheckBoxItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldCheckBoxItem members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Performs a cloning of this instance.
Public Method | ToString | Overridden. Returns a string that represents the current object.
Top

See Also

Reference

InputFieldCheckBoxItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As CanvasItem
C#
public override CanvasItem Clone()

Return Value

Returns the cloned InputFieldCheckBoxItem item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


InputFieldCheckBoxItem Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldCheckBoxItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldCheckBoxItem members.

Public Properties

 | Name | Description
Public Property | Checked | Gets the value indicating the state of the CheckBox.
Public Property | CheckSize | Gets the size of check symbol inside the CheckBox.
Public Property | CheckStyle | Gets the style of check symbol inside the CheckBox.
Top

See Also

Reference

InputFieldCheckBoxItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : Checked Property

Glossary Item Box

Gets the value indicating the state of the CheckBox.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Checked As Boolean
C#
public bool Checked {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


CheckSize Property

[image]
ActiveReports 19 .NET Edition
CheckSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : CheckSize Property

Glossary Item Box

Gets the size of check symbol inside the CheckBox.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckSize As Single
C#
public float CheckSize {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


CheckStyle Property

[image]
ActiveReports 19 .NET Edition
CheckStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : CheckStyle Property

Glossary Item Box

Gets the style of check symbol inside the CheckBox.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckStyle As InputCheckStyle
C#
public InputCheckStyle CheckStyle {get;}

Property Value

For a list of valid values, see here: InputCheckStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


InputFieldItem Class

[image]
ActiveReports 19 .NET Edition
InputFieldItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldItem Class

Glossary Item Box

Represents the base canvas item for input field.

Object Model

InputFieldItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class InputFieldItem
   Inherits CanvasItem
   Implements IBordered
C#
public abstract class InputFieldItem : CanvasItem, IBordered

Example

C# Copy Code
internal class MyInputFieldItemClass : InputFieldItem
{
    public MyInputFieldItemClass(CanvasType type, RectangleF bounds, string fieldName, bool readOnly, bool required, InputBorderStyle borderStyle, float borderWidth, Color borderColor) : base(type, bounds, fieldName, readOnly, required, borderStyle, borderWidth, borderColor)
    {
    }
    public override CanvasItem Clone()
    {
        return new MyInputFieldItemClass(Type, Bounds, FieldName, ReadOnly, Required, BorderStyle, BorderWidth, BorderColor);
    }
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.InputFieldItem
GrapeCity.ActiveReports.Document.Section.InputFieldCheckBoxItem
GrapeCity.ActiveReports.Document.Section.InputFieldTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Members
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldItem Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldItem Class

Glossary Item Box

The following tables list the members exposed by InputFieldItem.

Public Properties

 | Name | Description
Public Property | BorderColor | Gets the border color.
Public Property | BorderStyle | Gets the border style.
Public Property | BorderWidth | Gets the border width.
Public Property | Bounds | Gets the bounds of the item.
Public Property | FieldName | Gets the unique name of the field.
Public Property | Height | Gets the height of the inputFieldItem.
Public Property | Left | Gets the left position of the inputFieldItem.
Public Property | ReadOnly | Gets the read-only state. Prevents the user from changing the form field content.
Public Property | Required | Gets the required state. Forces the user to fill in the selected field.
Public Property | Top | Gets the top position of the inputFieldItem.
Public Property | Width | Gets the width of the inputFieldItem.
Top

See Also

Reference

InputFieldItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldItem Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldItem members.

Public Properties

 | Name | Description
Public Property | BorderColor | Gets the border color.
Public Property | BorderStyle | Gets the border style.
Public Property | BorderWidth | Gets the border width.
Public Property | Bounds | Gets the bounds of the item.
Public Property | FieldName | Gets the unique name of the field.
Public Property | Height | Gets the height of the inputFieldItem.
Public Property | Left | Gets the left position of the inputFieldItem.
Public Property | ReadOnly | Gets the read-only state. Prevents the user from changing the form field content.
Public Property | Required | Gets the required state. Forces the user to fill in the selected field.
Public Property | Top | Gets the top position of the inputFieldItem.
Public Property | Width | Gets the width of the inputFieldItem.
Top

See Also

Reference

InputFieldItem Class
GrapeCity.ActiveReports.Document.Section Namespace


BorderColor Property

[image]
ActiveReports 19 .NET Edition
BorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : BorderColor Property

Glossary Item Box

Gets the border color.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderColor As Color
C#
public Color BorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


BorderStyle Property

[image]
ActiveReports 19 .NET Edition
BorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : BorderStyle Property

Glossary Item Box

Gets the border style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderStyle As InputBorderStyle
C#
public InputBorderStyle BorderStyle {get;}

Property Value

For a list of valid values, see here: InputBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


BorderWidth Property

[image]
ActiveReports 19 .NET Edition
BorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : BorderWidth Property

Glossary Item Box

Gets the border width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderWidth As Single
C#
public float BorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


FieldName Property

[image]
ActiveReports 19 .NET Edition
FieldName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : FieldName Property

Glossary Item Box

Gets the unique name of the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldName As String
C#
public string FieldName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Height Property

Glossary Item Box

Gets the height of the inputFieldItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
C#
public float Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Left Property

Glossary Item Box

Gets the left position of the inputFieldItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


ReadOnly Property

[image]
ActiveReports 19 .NET Edition
ReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : ReadOnly Property

Glossary Item Box

Gets the read-only state. Prevents the user from changing the form field content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadOnly As Boolean
C#
public bool ReadOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Required Property

[image]
ActiveReports 19 .NET Edition
Required Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Required Property

Glossary Item Box

Gets the required state. Forces the user to fill in the selected field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Required As Boolean
C#
public bool Required {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Top Property

Glossary Item Box

Gets the top position of the inputFieldItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldItem Class : Width Property

Glossary Item Box

Gets the width of the inputFieldItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
C#
public float Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldItem Class
InputFieldItem Members


InputFieldTabIndexItem Class

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTabIndexItem Class

Glossary Item Box

Represents the canvas item to specify tab order.

Object Model

InputFieldTabIndexItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InputFieldTabIndexItem
   Inherits CanvasItem
C#
public sealed class InputFieldTabIndexItem : CanvasItem

Example

C# Copy Code
InputFieldTabIndexItem item = new InputFieldTabIndexItem(tabIndex);
_canvasItems.Add(item);

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.InputFieldTabIndexItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTabIndexItem Members
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTabIndexItem Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTabIndexItem Class

Glossary Item Box

The following tables list the members exposed by InputFieldTabIndexItem.

Public Constructors

 | Name | Description
Public Constructor | InputFieldTabIndexItem Constructor | Initializes an instance of class InputFieldTabIndexItem.
Top

Public Properties

 | Name | Description
Public Property | TabIndex | Gets the tab index.
Top

See Also

Reference

InputFieldTabIndexItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTabIndexItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTabIndexItem Class : InputFieldTabIndexItem Constructor

tabIndex
The tab index.

Glossary Item Box

Initializes an instance of class InputFieldTabIndexItem.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tabIndex As Integer _
)
C#
public InputFieldTabIndexItem(
   int tabIndex
)

Parameters

tabIndex
The tab index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTabIndexItem Class
InputFieldTabIndexItem Members


InputFieldTabIndexItem Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTabIndexItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldTabIndexItem members.

Public Properties

 | Name | Description
Public Property | TabIndex | Gets the tab index.
Top

See Also

Reference

InputFieldTabIndexItem Class
GrapeCity.ActiveReports.Document.Section Namespace


TabIndex Property

[image]
ActiveReports 19 .NET Edition
TabIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTabIndexItem Class : TabIndex Property

Glossary Item Box

Gets the tab index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TabIndex As Integer
C#
public int TabIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTabIndexItem Class
InputFieldTabIndexItem Members


InputFieldTextItem Class

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTextItem Class

Glossary Item Box

Represents the canvas item for text fields.

Object Model

InputFieldTextItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InputFieldTextItem
   Inherits InputFieldItem
   Implements IBordered
C#
public sealed class InputFieldTextItem : InputFieldItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.InputFieldItem
GrapeCity.ActiveReports.Document.Section.InputFieldTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Members
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTextItem Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTextItem Class

Glossary Item Box

The following tables list the members exposed by InputFieldTextItem.

Public Constructors

 | Name | Description
Public Constructor | InputFieldTextItem Constructor | Initializes an instance of class InputFieldTextItem.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets the text alignment.
Public Property | MaxLength | Gets the maximum length of the text entered. When 0, the text is not restricted to any specified length.
Public Property | Multiline | Gets the multiline. Allows more than a single-line entry in the text field.
Public Property | Password | Gets the password. Displays the user-entered text as a series of asterisks (*).
Public Property | SpellCheck | Gets the spell check. Indicates whether the text should be spell checked during its input or not.
Public Property | Text | Gets the text value.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Performs a cloning of this instance.
Public Method | ToString | Overridden. Returns a string that represents the current object.
Top

See Also

Reference

InputFieldTextItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTextItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : InputFieldTextItem Constructor

bounds
The bounds.
fieldName
The field name.
readOnly
The flag defining the read-only state.
required
The flag defining the required state.
borderStyle
The border style.
borderWidth
The border width.
borderColor
The border color.
maxLength
The max length.
multiline
The flag defining the multiline state.
password
The flag defining the password state.
spellCheck
The flag defining the spell check state.
alignment
The alignment.
textArray
The text.

Glossary Item Box

Initializes an instance of class InputFieldTextItem.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bounds As RectangleF, _
   ByVal fieldName As String, _
   ByVal readOnly As Boolean, _
   ByVal required As Boolean, _
   ByVal borderStyle As InputBorderStyle, _
   ByVal borderWidth As Single, _
   ByVal borderColor As Color, _
   ByVal maxLength As Integer, _
   ByVal multiline As Boolean, _
   ByVal password As Boolean, _
   ByVal spellCheck As Boolean, _
   ByVal alignment As InputTextAlign, _
   ByVal textArray() As String _
)
C#
public InputFieldTextItem(
   RectangleF bounds,
   string fieldName,
   bool readOnly,
   bool required,
   InputBorderStyle borderStyle,
   float borderWidth,
   Color borderColor,
   int maxLength,
   bool multiline,
   bool password,
   bool spellCheck,
   InputTextAlign alignment,
   string[] textArray
)

Parameters

bounds
The bounds.
fieldName
The field name.
readOnly
The flag defining the read-only state.
required
The flag defining the required state.
borderStyle
The border style.
borderWidth
The border width.
borderColor
The border color.
maxLength
The max length.
multiline
The flag defining the multiline state.
password
The flag defining the password state.
spellCheck
The flag defining the spell check state.
alignment
The alignment.
textArray
The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


InputFieldTextItem Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTextItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldTextItem members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Performs a cloning of this instance.
Public Method | ToString | Overridden. Returns a string that represents the current object.
Top

See Also

Reference

InputFieldTextItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As CanvasItem
C#
public override CanvasItem Clone()

Return Value

Returns the cloned InputFieldTextItem item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


InputFieldTextItem Class Properties

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTextItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldTextItem members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets the text alignment.
Public Property | MaxLength | Gets the maximum length of the text entered. When 0, the text is not restricted to any specified length.
Public Property | Multiline | Gets the multiline. Allows more than a single-line entry in the text field.
Public Property | Password | Gets the password. Displays the user-entered text as a series of asterisks (*).
Public Property | SpellCheck | Gets the spell check. Indicates whether the text should be spell checked during its input or not.
Public Property | Text | Gets the text value.
Top

See Also

Reference

InputFieldTextItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : Alignment Property

Glossary Item Box

Gets the text alignment.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Alignment As InputTextAlign
C#
public InputTextAlign Alignment {get;}

Property Value

For a list of valid values, see here: InputTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


MaxLength Property

[image]
ActiveReports 19 .NET Edition
MaxLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : MaxLength Property

Glossary Item Box

Gets the maximum length of the text entered. When 0, the text is not restricted to any specified length.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLength As Integer
C#
public int MaxLength {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


Multiline Property

[image]
ActiveReports 19 .NET Edition
Multiline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : Multiline Property

Glossary Item Box

Gets the multiline. Allows more than a single-line entry in the text field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Multiline As Boolean
C#
public bool Multiline {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : Password Property

Glossary Item Box

Gets the password. Displays the user-entered text as a series of asterisks (*).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Password As Boolean
C#
public bool Password {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


SpellCheck Property

[image]
ActiveReports 19 .NET Edition
SpellCheck Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : SpellCheck Property

Glossary Item Box

Gets the spell check. Indicates whether the text should be spell checked during its input or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpellCheck As Boolean
C#
public bool SpellCheck {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : Text Property

Glossary Item Box

Gets the text value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


IntersectClip Class

[image]
ActiveReports 19 .NET Edition
IntersectClip Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IntersectClip Class

Glossary Item Box

Represents a canvas element with an intersection clip.

Object Model

IntersectClip Class

Syntax

Visual Basic (Declaration)
Public Class IntersectClip
   Inherits CanvasItem
   Implements IBordered
C#
public class IntersectClip : CanvasItem, IBordered

Example

C# Copy Code
public void DrawIntersectClip(float startX, float startY, float endX, float endY)
{
    CanvasItems.Add(new IntersectClip(new RectangleF(startX,startY,endX,endY));
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.IntersectClip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Members
GrapeCity.ActiveReports.Document.Section Namespace


IntersectClip Class Members

[image]
ActiveReports 19 .NET Edition
IntersectClip Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IntersectClip Class

Glossary Item Box

The following tables list the members exposed by IntersectClip.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets the height of the item.
Public Property | Left | Gets the left of of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

IntersectClip Class
GrapeCity.ActiveReports.Document.Section Namespace


IntersectClip Class Properties

[image]
ActiveReports 19 .NET Edition
IntersectClip Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IntersectClip Class

Glossary Item Box

For a list of all members of this type, see IntersectClip members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | Height | Gets the height of the item.
Public Property | Left | Gets the left of of the item.
Public Property | Top | Gets the top of the item.
Public Property | Width | Gets the width of the item.
Top

See Also

Reference

IntersectClip Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > IntersectClip Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Class
IntersectClip Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > IntersectClip Class : Height Property

Glossary Item Box

Gets the height of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Single
C#
public float Height {get;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Class
IntersectClip Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > IntersectClip Class : Left Property

Glossary Item Box

Gets the left of of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Property Value

The left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Class
IntersectClip Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > IntersectClip Class : Top Property

Glossary Item Box

Gets the top of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Property Value

The top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Class
IntersectClip Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > IntersectClip Class : Width Property

Glossary Item Box

Gets the width of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
C#
public float Width {get;}

Property Value

The width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntersectClip Class
IntersectClip Members


JPEGImage Class

[image]
ActiveReports 19 .NET Edition
JPEGImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGImage Class

Glossary Item Box

Represents the canvas item for JPEG image.

Object Model

JPEGImage Class

Syntax

Visual Basic (Declaration)
Public Class JPEGImage
   Inherits BitmapImage
   Implements IBordered
C#
public class JPEGImage : BitmapImage, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.BitmapImage
GrapeCity.ActiveReports.Document.Section.JPEGImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPEGImage Members
GrapeCity.ActiveReports.Document.Section Namespace


JPEGImage Class Members

[image]
ActiveReports 19 .NET Edition
JPEGImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGImage Class

Glossary Item Box

The following tables list the members exposed by JPEGImage.

See Also

Reference

JPEGImage Class
GrapeCity.ActiveReports.Document.Section Namespace


JPEGLink Class

[image]
ActiveReports 19 .NET Edition
JPEGLink Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGLink Class

Glossary Item Box

Represents the canvas item for JPEG image with hyperlink.

Object Model

JPEGLink Class

Syntax

Visual Basic (Declaration)
Public Class JPEGLink
   Inherits LinkItem
   Implements IBordered, ILinkItem
C#
public class JPEGLink : LinkItem, IBordered, ILinkItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.LinkItem
GrapeCity.ActiveReports.Document.Section.JPEGLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPEGLink Members
GrapeCity.ActiveReports.Document.Section Namespace


JPEGLink Class Members

[image]
ActiveReports 19 .NET Edition
JPEGLink Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGLink Class

Glossary Item Box

The following tables list the members exposed by JPEGLink.

See Also

Reference

JPEGLink Class
GrapeCity.ActiveReports.Document.Section Namespace


LabelAttribute Class

[image]
ActiveReports 19 .NET Edition
LabelAttribute Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LabelAttribute Class

Glossary Item Box

Represents the class for setting the Label attribute.

Object Model

LabelAttribute Class

Syntax

Visual Basic (Declaration)
Public Class LabelAttribute
   Inherits System.Attribute
C#
public class LabelAttribute : System.Attribute

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Document.Section.LabelAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Members
GrapeCity.ActiveReports.Document.Section Namespace


LabelAttribute Class Members

[image]
ActiveReports 19 .NET Edition
LabelAttribute Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LabelAttribute Class

Glossary Item Box

The following tables list the members exposed by LabelAttribute.

Public Constructors

 | Name | Description
Public Constructor | LabelAttribute Constructor | Initializes a new instance of the LabelAttribute class.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the string representation of a label.
Top

See Also

Reference

LabelAttribute Class
GrapeCity.ActiveReports.Document.Section Namespace


LabelAttribute Constructor

[image]
ActiveReports 19 .NET Edition
LabelAttribute Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : LabelAttribute Constructor

label
String representation of a label

Glossary Item Box

Initializes a new instance of the LabelAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String _
)
C#
public LabelAttribute(
   string label
)

Parameters

label
String representation of a label

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


LabelAttribute Class Properties

[image]
ActiveReports 19 .NET Edition
LabelAttribute Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LabelAttribute Class

Glossary Item Box

For a list of all members of this type, see LabelAttribute members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the string representation of a label.
Top

See Also

Reference

LabelAttribute Class
GrapeCity.ActiveReports.Document.Section Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : Label Property

Glossary Item Box

Gets or sets the string representation of a label.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


LineItem Class

[image]
ActiveReports 19 .NET Edition
LineItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LineItem Class

Glossary Item Box

Represents an line item element.

Object Model

LineItem Class

Syntax

Visual Basic (Declaration)
Public Class LineItem
   Inherits CanvasItem
C#
public class LineItem : CanvasItem

Example

C# Copy Code
public void DrawLine(float startX, float startY, float endX, float endY)
{
    CanvasItems.Add(new LineItem(startX,startY,endX,endY));
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.LineItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineItem Members
GrapeCity.ActiveReports.Document.Section Namespace


LineItem Class Members

[image]
ActiveReports 19 .NET Edition
LineItem Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LineItem Class

Glossary Item Box

The following tables list the members exposed by LineItem.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Creates LineItem and reads it from specified reader.
Top

See Also

Reference

LineItem Class
GrapeCity.ActiveReports.Document.Section Namespace


LineItem Class Methods

[image]
ActiveReports 19 .NET Edition
LineItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LineItem Class

Glossary Item Box

For a list of all members of this type, see LineItem members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Creates LineItem and reads it from specified reader.
Top

See Also

Reference

LineItem Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LineItem Class : CreateRead Method

reader
The binary reader.
fileVersion
The file version.

Glossary Item Box

Creates LineItem and reads it from specified reader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As LineItem
C#
public static LineItem CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
The binary reader.
fileVersion
The file version.

Return Value

The instance of the LineItem class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineItem Class
LineItem Members


LinkItem Class

[image]
ActiveReports 19 .NET Edition
LinkItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LinkItem Class

Glossary Item Box

Represents the abstract canvas item for image with hyperlink.

Object Model

LinkItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class LinkItem
   Inherits ResourcedCanvasItem
   Implements IBordered, ILinkItem
C#
public abstract class LinkItem : ResourcedCanvasItem, IBordered, ILinkItem

Example

C# Copy Code
public class MyLinkItem : LinkItem
{
    public MyLinkItem(IImageConverterService imageConverterService, CanvasType ctType) : base(imageConverterService, ctType)
    {
    }
    public MyLinkItem(IImageConverterService imageConverterService, CanvasType canvasType, float left, float top, float width, float height, string strLink) : base(imageConverterService, canvasType, left, top, width, height, strLink)
    {
    }
       protected override Guid ImageFormatGuid() => ImageFormat.Bmp.Guid;
    protected override string ImageTypeName() => ResourceManager.ImageResource.BitmapTypeName;
    internal override ResourcedCanvasItem Clone(ResourceManager targetResourceMgr) => new MyLinkItem(ImageConverterService, Type);
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.LinkItem
GrapeCity.ActiveReports.Document.Section.EnhMetaLink
GrapeCity.ActiveReports.Document.Section.JPEGLink
GrapeCity.ActiveReports.Document.Section.PngLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkItem Members
GrapeCity.ActiveReports.Document.Section Namespace


LinkItem Class Members

[image]
ActiveReports 19 .NET Edition
LinkItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LinkItem Class

Glossary Item Box

The following tables list the members exposed by LinkItem.

See Also

Reference

LinkItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Margins Class

[image]
ActiveReports 19 .NET Edition
Margins Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

Represents the margins.

Object Model

Margins Class

Syntax

Visual Basic (Declaration)
Public Class Margins
C#
public class Margins

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Margins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Members
GrapeCity.ActiveReports.Document.Section Namespace


Margins Class Members

[image]
ActiveReports 19 .NET Edition
Margins Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

The following tables list the members exposed by Margins.

Public Constructors

 | Name | Description
Public Constructor | Margins Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets the bottom margin.
Public Property | Left | Gets the left margin.
Public Property | Right | Gets the right margin.
Public Property | Top | Gets the top margin.
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode |
Top

Public Events

 | Name | Description
Public Event | Changed | Event that occurs when an element is changed.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Margins Constructor

[image]
ActiveReports 19 .NET Edition
Margins Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Margins Constructor

Glossary Item Box

Overload List

Overload | Description
Margins Constructor() | Initializes a new instance of the Margins class.
Margins Constructor(Single,Single,Single,Single) | Initializes a new instance of the Margins class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Constructor()

[image]
ActiveReports 19 .NET Edition
Margins Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor()

Glossary Item Box

Initializes a new instance of the Margins class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Margins()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members
Overload List


Margins Constructor(Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
Margins Constructor(Single,Single,Single,Single)
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor(Single,Single,Single,Single)

left
The left.
top
The top.
right
The right.
bottom
The bottom.

Glossary Item Box

Initializes a new instance of the Margins class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal right As Single, _
   ByVal bottom As Single _
)
C#
public Margins(
   float left,
   float top,
   float right,
   float bottom
)

Parameters

left
The left.
top
The top.
right
The right.
bottom
The bottom.

Exceptions

Exception | Description
System.ArgumentException | Left margin value must be greater than 0 or Top margin value must be greater than 0 or Right margin value must be greater than 0 or Bottom margin value must be greater than 0

Example

C# Copy Code
_margins = new Margins(1, 1, 1, 1);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members
Overload List


Margins Class Methods

[image]
ActiveReports 19 .NET Edition
Margins Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode |
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

Returns the cloned Margins instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Equals Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Properties

[image]
ActiveReports 19 .NET Edition
Margins Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the bottom margin.
Public Property | Left | Gets the left margin.
Public Property | Right | Gets the right margin.
Public Property | Top | Gets the top margin.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Bottom Property

Glossary Item Box

Gets the bottom margin.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
C#
public float Bottom {get; set;}

Remarks

Default value is 1.0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Left Property

Glossary Item Box

Gets the left margin.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left {get; set;}

Remarks

Default value is 1.0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Right Property

Glossary Item Box

Gets the right margin.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
C#
public float Right {get; set;}

Remarks

Default value is 1.0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Top Property

Glossary Item Box

Gets the top margin.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
C#
public float Top {get; set;}

Remarks

Default value is 1.0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Events

[image]
ActiveReports 19 .NET Edition
Margins Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Events

 | Name | Description
Public Event | Changed | Event that occurs when an element is changed.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Changed Event

[image]
ActiveReports 19 .NET Edition
Changed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Changed Event

Glossary Item Box

Event that occurs when an element is changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Remarks

Event occurs when the Left, Right, Top, or Bottom property is changed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


PageCell Class

[image]
ActiveReports 19 .NET Edition
PageCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageCell Class

Glossary Item Box

Represents the page cell.

Object Model

PageCell Class

Syntax

Visual Basic (Declaration)
Public Class PageCell
C#
public class PageCell

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Members
GrapeCity.ActiveReports.Document.Section Namespace


PageCell Class Members

[image]
ActiveReports 19 .NET Edition
PageCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageCell Class

Glossary Item Box

The following tables list the members exposed by PageCell.

Public Constructors

 | Name | Description
Public Constructor | PageCell Constructor | Initializes an instance of class PageCell.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of the cell.
Public Property | Attributes | Gets or sets the attributes of the parent table of the cells.
Public Property | Bounds | Gets the bounds of the cell.
Public Property | ColSpan | Gets or sets the column span of the cell.
Public Property | Height | Gets or sets the height of the cell.
Public Property | Padding | Gets or sets the padding of the cell.
Public Property | Page | Gets the parent page of this cell.
Public Property | RowSpan | Gets or sets the row span of the cell.
Public Property | Site | Gets the cell site.
Public Property | TagName | Gets the tag of the cell.
Public Property | VAlign | Gets or sets the vertical alignment of the cell.
Public Property | Width | Gets or sets the width of the cell.
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Delete | Deletes a cell from the parent row.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | SetResource | Overloaded. Sets resource from existing page.
Public Method | SplitHorizontally | Splits cells horizontally.
Public Method | SplitVertically | Splits cells vertically.
Public Method | ToString | Returns a string that represents the current object.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | An event that occurs when a property is changed.
Top

See Also

Reference

PageCell Class
GrapeCity.ActiveReports.Document.Section Namespace


PageCell Constructor

[image]
ActiveReports 19 .NET Edition
PageCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : PageCell Constructor

Glossary Item Box

Initializes an instance of class PageCell.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


PageCell Class Methods

[image]
ActiveReports 19 .NET Edition
PageCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageCell Class

Glossary Item Box

For a list of all members of this type, see PageCell members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Public Method | Delete | Deletes a cell from the parent row.
Public Method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Public Method | SetResource | Overloaded. Sets resource from existing page.
Public Method | SplitHorizontally | Splits cells horizontally.
Public Method | SplitVertically | Splits cells vertically.
Public Method | ToString | Returns a string that represents the current object.
Top

See Also

Reference

PageCell Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As ITableCell
C#
public ITableCell Clone()

Return Value

Returns the cloned GrapeCity.ActiveReports.Core.Document.DDLib.Table.ITableCell item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Delete Method

[image]
ActiveReports 19 .NET Edition
Delete Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Delete Method

deviceInfo
The device information.

Glossary Item Box

Deletes a cell from the parent row.

Syntax

Visual Basic (Declaration)
Public Sub Delete( _
   ByVal deviceInfo As DeviceInfo _
)
C#
public void Delete(
   DeviceInfo deviceInfo
)

Parameters

deviceInfo
The device information.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Dispose() Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


SetResource Method

[image]
ActiveReports 19 .NET Edition
SetResource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : SetResource Method

Glossary Item Box

Sets resource from existing page.

Overload List

Overload | Description
SetResource(Page) | Sets resource from existing page.
SetResource(DrawCanvas) | Sets resource from canvas.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


SetResource(Page) Method

[image]
ActiveReports 19 .NET Edition
SetResource(Page) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class > SetResource Method : SetResource(Page) Method

existPage
Source Page

Glossary Item Box

Sets resource from existing page.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetResource( _
   ByVal existPage As Page _
)
C#
public void SetResource(
   Page existPage
)

Parameters

existPage
Source Page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members
Overload List


SetResource(DrawCanvas) Method

[image]
ActiveReports 19 .NET Edition
SetResource(DrawCanvas) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class > SetResource Method : SetResource(DrawCanvas) Method

canvas
Source DrawCanvas

Glossary Item Box

Sets resource from canvas.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetResource( _
   ByVal canvas As DrawCanvas _
)
C#
public void SetResource(
   DrawCanvas canvas
)

Parameters

canvas
Source DrawCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members
Overload List


SplitHorizontally Method

[image]
ActiveReports 19 .NET Edition
SplitHorizontally Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : SplitHorizontally Method

deviceInfo
The device inforamtion.
splitColumnIntoColumns
Number of columns.

Glossary Item Box

Splits cells horizontally.

Syntax

Visual Basic (Declaration)
Public Sub SplitHorizontally( _
   ByVal deviceInfo As DeviceInfo, _
   ByVal splitColumnIntoColumns As Integer _
)
C#
public void SplitHorizontally(
   DeviceInfo deviceInfo,
   int splitColumnIntoColumns
)

Parameters

deviceInfo
The device inforamtion.
splitColumnIntoColumns
Number of columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


SplitVertically Method

[image]
ActiveReports 19 .NET Edition
SplitVertically Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : SplitVertically Method

deviceInfo
The device inforamtion.
splitRowIntoRows
Number of rows.

Glossary Item Box

Splits cells vertically.

Syntax

Visual Basic (Declaration)
Public Sub SplitVertically( _
   ByVal deviceInfo As DeviceInfo, _
   ByVal splitRowIntoRows As Integer _
)
C#
public void SplitVertically(
   DeviceInfo deviceInfo,
   int splitRowIntoRows
)

Parameters

deviceInfo
The device inforamtion.
splitRowIntoRows
Number of rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : ToString Method

Glossary Item Box

Returns a string that represents the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


PageCell Class Properties

[image]
ActiveReports 19 .NET Edition
PageCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageCell Class

Glossary Item Box

For a list of all members of this type, see PageCell members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of the cell.
Public Property | Attributes | Gets or sets the attributes of the parent table of the cells.
Public Property | Bounds | Gets the bounds of the cell.
Public Property | ColSpan | Gets or sets the column span of the cell.
Public Property | Height | Gets or sets the height of the cell.
Public Property | Padding | Gets or sets the padding of the cell.
Public Property | Page | Gets the parent page of this cell.
Public Property | RowSpan | Gets or sets the row span of the cell.
Public Property | Site | Gets the cell site.
Public Property | TagName | Gets the tag of the cell.
Public Property | VAlign | Gets or sets the vertical alignment of the cell.
Public Property | Width | Gets or sets the width of the cell.
Top

See Also

Reference

PageCell Class
GrapeCity.ActiveReports.Document.Section Namespace


Align Property

[image]
ActiveReports 19 .NET Edition
Align Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Align Property

Glossary Item Box

Gets or sets the alignment of the cell.

Syntax

Visual Basic (Declaration)
Public Property Align As CellAlignmentTypes
C#
public CellAlignmentTypes Align {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Core.Document.DDLib.Table.CellAlignmentTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Attributes Property

[image]
ActiveReports 19 .NET Edition
Attributes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Attributes Property

Glossary Item Box

Gets or sets the attributes of the parent table of the cells.

Syntax

Visual Basic (Declaration)
Public Property Attributes As TableCellAttributes
C#
public TableCellAttributes Attributes {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Bounds Property

Glossary Item Box

Gets the bounds of the cell.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


ColSpan Property

[image]
ActiveReports 19 .NET Edition
ColSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : ColSpan Property

Glossary Item Box

Gets or sets the column span of the cell.

Syntax

Visual Basic (Declaration)
Public Property ColSpan As Integer
C#
public int ColSpan {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Height Property

Glossary Item Box

Gets or sets the height of the cell.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Remarks

Default value is -1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Padding Property

Glossary Item Box

Gets or sets the padding of the cell.

Syntax

Visual Basic (Declaration)
Public Property Padding As Single
C#
public float Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Page Property

Glossary Item Box

Gets the parent page of this cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As Page
C#
public Page Page {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : RowSpan Property

Glossary Item Box

Gets or sets the row span of the cell.

Syntax

Visual Basic (Declaration)
Public Property RowSpan As Integer
C#
public int RowSpan {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Site Property

Glossary Item Box

Gets the cell site.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ICellSite
C#
public ICellSite Site {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


TagName Property

[image]
ActiveReports 19 .NET Edition
TagName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : TagName Property

Glossary Item Box

Gets the tag of the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TagName As String
C#
public string TagName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


VAlign Property

[image]
ActiveReports 19 .NET Edition
VAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : VAlign Property

Glossary Item Box

Gets or sets the vertical alignment of the cell.

Syntax

Visual Basic (Declaration)
Public Property VAlign As CellAlignmentTypes
C#
public CellAlignmentTypes VAlign {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Core.Document.DDLib.Table.CellAlignmentTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Width Property

Glossary Item Box

Gets or sets the width of the cell.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Remarks

Default value is -1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


PageCell Class Events

[image]
ActiveReports 19 .NET Edition
PageCell Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageCell Class

Glossary Item Box

For a list of all members of this type, see PageCell members.

Public Events

 | Name | Description
Public Event | PropertyChanged | An event that occurs when a property is changed.
Top

See Also

Reference

PageCell Class
GrapeCity.ActiveReports.Document.Section Namespace


PropertyChanged Event

[image]
ActiveReports 19 .NET Edition
PropertyChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : PropertyChanged Event

Glossary Item Box

An event that occurs when a property is changed.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


PageDoubleLineExtensions Class

[image]
ActiveReports 19 .NET Edition
PageDoubleLineExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

Provides extension methods for GrapeCity.ActiveReports.Core.Document.Page

Object Model

PageDoubleLineExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PageDoubleLineExtensions
C#
public static class PageDoubleLineExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageDoubleLineExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Members
GrapeCity.ActiveReports.Document.Section Namespace


PageDoubleLineExtensions Class Members

[image]
ActiveReports 19 .NET Edition
PageDoubleLineExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

The following tables list the members exposed by PageDoubleLineExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawDoubleLine | Draws the double line.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws the double-lined ellipse.
static (Shared in Visual Basic) | DrawRoundRectDoubleLine | Draws the double-lined round rect.
Top

See Also

Reference

PageDoubleLineExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


PageDoubleLineExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
PageDoubleLineExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

For a list of all members of this type, see PageDoubleLineExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawDoubleLine | Draws the double line.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws the double-lined ellipse.
static (Shared in Visual Basic) | DrawRoundRectDoubleLine | Draws the double-lined round rect.
Top

See Also

Reference

PageDoubleLineExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawDoubleLine Method

canvas
The canvas where the double line will be drawn.
x1
The X1 coordinate.
y1
The Y1 coordinate.
x2
The X2 coordinate.
y2
The Y2 coordinate.

Glossary Item Box

Draws the double line.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawDoubleLine( _
   ByVal canvas As DrawCanvas, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public static void DrawDoubleLine(
   DrawCanvas canvas,
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

canvas
The canvas where the double line will be drawn.
x1
The X1 coordinate.
y1
The Y1 coordinate.
x2
The X2 coordinate.
y2
The Y2 coordinate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


DrawEllipseDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawEllipseDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawEllipseDoubleLine Method

canvas
The canvas where the ellipse will be drawn.
left
The left coordinate of the ellipse.
top
The top coordinate of the ellipse.
width
The width of the ellipse.
height
The height of the ellipse.

Glossary Item Box

Draws the double-lined ellipse.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawEllipseDoubleLine( _
   ByVal canvas As DrawCanvas, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public static void DrawEllipseDoubleLine(
   DrawCanvas canvas,
   float left,
   float top,
   float width,
   float height
)

Parameters

canvas
The canvas where the ellipse will be drawn.
left
The left coordinate of the ellipse.
top
The top coordinate of the ellipse.
width
The width of the ellipse.
height
The height of the ellipse.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


DrawRoundRectDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRectDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawRoundRectDoubleLine Method

canvas
The canvas where the rect will be drawn.
left
The left coordinate of the rect.
top
The top coordinate of the rect.
width
The width of the rect.
height
The height of the rect.
topLeftEdge
Top Left edge of the rect.
topRightEdge
Top Right edge of the rect.
bottomLeftEdge
Bottom Left edge of the rect.
bottomRightEdge
Bottom Right Edge of the rect.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Draws the double-lined round rect.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawRoundRectDoubleLine( _
   ByVal canvas As DrawCanvas, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public static void DrawRoundRectDoubleLine(
   DrawCanvas canvas,
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

canvas
The canvas where the rect will be drawn.
left
The left coordinate of the rect.
top
The top coordinate of the rect.
width
The width of the rect.
height
The height of the rect.
topLeftEdge
Top Left edge of the rect.
topRightEdge
Top Right edge of the rect.
bottomLeftEdge
Bottom Left edge of the rect.
bottomRightEdge
Bottom Right Edge of the rect.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


PageTable Class

[image]
ActiveReports 19 .NET Edition
PageTable Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageTable Class

Glossary Item Box

Represents the table.

Object Model

PageTable Class

Syntax

Visual Basic (Declaration)
Public Class PageTable
C#
public class PageTable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Members
GrapeCity.ActiveReports.Document.Section Namespace


PageTable Class Members

[image]
ActiveReports 19 .NET Edition
PageTable Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageTable Class

Glossary Item Box

The following tables list the members exposed by PageTable.

Public Properties

 | Name | Description
Public Property | Attributes | Gets the attributesof the table.
Public Property | Border | Gets or sets the border of the table.
Public Property | BorderLines | Sets the border lines of the table.
Public Property | Bounds | Gets or sets the bounds rectangle of the table.
Public Property | CellPadding | Gets or sets the padding of the cells of the table.
Public Property | CellSpacing | Gets or sets the spacing of the cells of the table.
Public Property | Columns | Gets the columns of the table.
Public Property | Rows | Gets the rows of the table.
Public Property | Rules | Gets or sets the rules.
Public Property | Summary | Gets or sets the summary of the table.
Top

Public Methods

 | Name | Description
Public Method | PerformLayout | Performs the layout.
Public Method | ResumeLayout | Resumes the layout.
Public Method | SuspendLayout | Suspends the layout.
Top

See Also

Reference

PageTable Class
GrapeCity.ActiveReports.Document.Section Namespace


PageTable Class Methods

[image]
ActiveReports 19 .NET Edition
PageTable Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageTable Class

Glossary Item Box

For a list of all members of this type, see PageTable members.

Public Methods

 | Name | Description
Public Method | PerformLayout | Performs the layout.
Public Method | ResumeLayout | Resumes the layout.
Public Method | SuspendLayout | Suspends the layout.
Top

See Also

Reference

PageTable Class
GrapeCity.ActiveReports.Document.Section Namespace


PerformLayout Method

[image]
ActiveReports 19 .NET Edition
PerformLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : PerformLayout Method

Glossary Item Box

Performs the layout.

Syntax

Visual Basic (Declaration)
Public Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


ResumeLayout Method

[image]
ActiveReports 19 .NET Edition
ResumeLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : ResumeLayout Method

Glossary Item Box

Resumes the layout.

Syntax

Visual Basic (Declaration)
Public Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


SuspendLayout Method

[image]
ActiveReports 19 .NET Edition
SuspendLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : SuspendLayout Method

Glossary Item Box

Suspends the layout.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


PageTable Class Properties

[image]
ActiveReports 19 .NET Edition
PageTable Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageTable Class

Glossary Item Box

For a list of all members of this type, see PageTable members.

Public Properties

 | Name | Description
Public Property | Attributes | Gets the attributesof the table.
Public Property | Border | Gets or sets the border of the table.
Public Property | BorderLines | Sets the border lines of the table.
Public Property | Bounds | Gets or sets the bounds rectangle of the table.
Public Property | CellPadding | Gets or sets the padding of the cells of the table.
Public Property | CellSpacing | Gets or sets the spacing of the cells of the table.
Public Property | Columns | Gets the columns of the table.
Public Property | Rows | Gets the rows of the table.
Public Property | Rules | Gets or sets the rules.
Public Property | Summary | Gets or sets the summary of the table.
Top

See Also

Reference

PageTable Class
GrapeCity.ActiveReports.Document.Section Namespace


Attributes Property

[image]
ActiveReports 19 .NET Edition
Attributes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Attributes Property

Glossary Item Box

Gets the attributesof the table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attributes As TableAttributes
C#
public TableAttributes Attributes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Border Property

Glossary Item Box

Gets or sets the border of the table.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


BorderLines Property

[image]
ActiveReports 19 .NET Edition
BorderLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : BorderLines Property

Glossary Item Box

Sets the border lines of the table.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderLines As ArrayList
C#
public ArrayList BorderLines {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Bounds Property

Glossary Item Box

Gets or sets the bounds rectangle of the table.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


CellPadding Property

[image]
ActiveReports 19 .NET Edition
CellPadding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : CellPadding Property

Glossary Item Box

Gets or sets the padding of the cells of the table.

Syntax

Visual Basic (Declaration)
Public Property CellPadding As Single
C#
public float CellPadding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


CellSpacing Property

[image]
ActiveReports 19 .NET Edition
CellSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : CellSpacing Property

Glossary Item Box

Gets or sets the spacing of the cells of the table.

Syntax

Visual Basic (Declaration)
Public Property CellSpacing As Single
C#
public float CellSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Columns Property

Glossary Item Box

Gets the columns of the table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As ColumnCollection
C#
public ColumnCollection Columns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Rows Property

Glossary Item Box

Gets the rows of the table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As RowCollection
C#
public RowCollection Rows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Rules Property

[image]
ActiveReports 19 .NET Edition
Rules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Rules Property

Glossary Item Box

Gets or sets the rules.

Syntax

Visual Basic (Declaration)
Public Property Rules As Border
C#
public Border Rules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


Summary Property

[image]
ActiveReports 19 .NET Edition
Summary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageTable Class : Summary Property

Glossary Item Box

Gets or sets the summary of the table.

Syntax

Visual Basic (Declaration)
Public Property Summary As String
C#
public string Summary {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageTable Class
PageTable Members


PenStyle Class

[image]
ActiveReports 19 .NET Edition
PenStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyle Class

Glossary Item Box

Represents the style of pen.

Object Model

PenStyle Class

Syntax

Visual Basic (Declaration)
Public Class PenStyle
   Inherits CanvasItem
C#
public class PenStyle : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.PenStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenStyle Members
GrapeCity.ActiveReports.Document.Section Namespace


PenStyle Class Members

[image]
ActiveReports 19 .NET Edition
PenStyle Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyle Class

Glossary Item Box

The following tables list the members exposed by PenStyle.

Public Constructors

 | Name | Description
Public Constructor | PenStyle Constructor | Initializes a new instance of the PenStyle class.
Top

See Also

Reference

PenStyle Class
GrapeCity.ActiveReports.Document.Section Namespace


PenStyle Constructor

[image]
ActiveReports 19 .NET Edition
PenStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PenStyle Class : PenStyle Constructor

psStyle
The style of pen. For a list of valid values, see here: PenStyles

Glossary Item Box

Initializes a new instance of the PenStyle class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal psStyle As PenStyles _
)
C#
public PenStyle(
   PenStyles psStyle
)

Parameters

psStyle
The style of pen. For a list of valid values, see here: PenStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenStyle Class
PenStyle Members


PenWidth Class

[image]
ActiveReports 19 .NET Edition
PenWidth Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenWidth Class

Glossary Item Box

Represents the width of pen.

Object Model

PenWidth Class

Syntax

Visual Basic (Declaration)
Public Class PenWidth
   Inherits CanvasItem
C#
public class PenWidth : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.PenWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenWidth Members
GrapeCity.ActiveReports.Document.Section Namespace


PenWidth Class Members

[image]
ActiveReports 19 .NET Edition
PenWidth Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenWidth Class

Glossary Item Box

The following tables list the members exposed by PenWidth.

Public Constructors

 | Name | Description
Public Constructor | PenWidth Constructor | Initializes a new instance of the PenWidth class.
Top

See Also

Reference

PenWidth Class
GrapeCity.ActiveReports.Document.Section Namespace


PenWidth Constructor

[image]
ActiveReports 19 .NET Edition
PenWidth Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PenWidth Class : PenWidth Constructor

penThickness
The pen thickness.

Glossary Item Box

Initializes a new instance of the PenWidth class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal penThickness As Short _
)
C#
public PenWidth(
   short penThickness
)

Parameters

penThickness
The pen thickness.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenWidth Class
PenWidth Members


PngImage Class

[image]
ActiveReports 19 .NET Edition
PngImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngImage Class

Glossary Item Box

Represents the canvas item for PNG image.

Object Model

PngImage Class

Syntax

Visual Basic (Declaration)
Public Class PngImage
   Inherits BitmapImage
   Implements IBordered
C#
public class PngImage : BitmapImage, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.BitmapImage
GrapeCity.ActiveReports.Document.Section.PngImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PngImage Members
GrapeCity.ActiveReports.Document.Section Namespace


PngImage Class Members

[image]
ActiveReports 19 .NET Edition
PngImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngImage Class

Glossary Item Box

The following tables list the members exposed by PngImage.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the PngImage received from a System.IO.BinaryReader.
Top

See Also

Reference

PngImage Class
GrapeCity.ActiveReports.Document.Section Namespace


PngImage Class Methods

[image]
ActiveReports 19 .NET Edition
PngImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngImage Class

Glossary Item Box

For a list of all members of this type, see PngImage members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the PngImage received from a System.IO.BinaryReader.
Top

See Also

Reference

PngImage Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PngImage Class : CreateRead Method

reader
Reader containing the binary data of PngImage.
fileVersion
The type of data in the stream.
pageObj
The page.
imageConverterService
Service that converts image data from one format to another.

Glossary Item Box

Return an instance of the PngImage received from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short, _
   ByVal pageObj As Page, _
   ByVal imageConverterService As IImageConverterService _
) As PngImage
C#
public static PngImage CreateRead(
   BinaryReader reader,
   short fileVersion,
   Page pageObj,
   IImageConverterService imageConverterService
)

Parameters

reader
Reader containing the binary data of PngImage.
fileVersion
The type of data in the stream.
pageObj
The page.
imageConverterService
Service that converts image data from one format to another.

Return Value

A new PngImage instance.

Example

C# Copy Code
private void AddImageToPage(Page page, string filename)
    {
        var fileStream = new FileStream(filename, FileMode.Open);
        var binaryReader = new BinaryReader(fileStream);
        var reuslt = PngImage.CreateRead(binaryReader, Globals.DocumentVersion, page, new GcImageConverterService(CustomFontResolver.Instance));
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PngImage Class
PngImage Members


PngLink Class

[image]
ActiveReports 19 .NET Edition
PngLink Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngLink Class

Glossary Item Box

Represents the canvas item for PNG image with hyperlink.

Object Model

PngLink Class

Syntax

Visual Basic (Declaration)
Public Class PngLink
   Inherits LinkItem
   Implements IBordered, ILinkItem
C#
public class PngLink : LinkItem, IBordered, ILinkItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.LinkItem
GrapeCity.ActiveReports.Document.Section.PngLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PngLink Members
GrapeCity.ActiveReports.Document.Section Namespace


PngLink Class Members

[image]
ActiveReports 19 .NET Edition
PngLink Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngLink Class

Glossary Item Box

The following tables list the members exposed by PngLink.

See Also

Reference

PngLink Class
GrapeCity.ActiveReports.Document.Section Namespace


Rect Class

[image]
ActiveReports 19 .NET Edition
Rect Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Rect Class

Glossary Item Box

Represents a rectangle canvas element.

Object Model

Rect Class

Syntax

Visual Basic (Declaration)
Public Class Rect
   Inherits CanvasItem
   Implements IBordered
C#
public class Rect : CanvasItem, IBordered

Example

C# Copy Code
public void DrawRect(float startX, float startY, float endX, float endY)
{
    CanvasItems.Add(new Rect(startX,startY,endX,endY));
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Members
GrapeCity.ActiveReports.Document.Section Namespace


Rect Class Members

[image]
ActiveReports 19 .NET Edition
Rect Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Rect Class

Glossary Item Box

The following tables list the members exposed by Rect.

Public Constructors

 | Name | Description
Public Constructor | Rect Constructor | Initializes a new instance of the Rect class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

Rect Class
GrapeCity.ActiveReports.Document.Section Namespace


Rect Constructor

[image]
ActiveReports 19 .NET Edition
Rect Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Rect Class : Rect Constructor

left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Initializes a new instance of the Rect class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public Rect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Class
Rect Members


Rect Class Properties

[image]
ActiveReports 19 .NET Edition
Rect Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Rect Class

Glossary Item Box

For a list of all members of this type, see Rect members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

Rect Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Rect Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Class
Rect Members


RenderState Class

[image]
ActiveReports 19 .NET Edition
RenderState Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RenderState Class

Glossary Item Box

Represents the rendering state

Object Model

RenderState Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RenderState
C#
public sealed class RenderState

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.RenderState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Members
GrapeCity.ActiveReports.Document.Section Namespace


RenderState Class Members

[image]
ActiveReports 19 .NET Edition
RenderState Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RenderState Class

Glossary Item Box

The following tables list the members exposed by RenderState.

Public Fields

 | Name | Description
Public Field | BackColor | Theback color.
Public Field | BackStyleTransparent | The flag determining that back style is transparent.
Public Field | CharacterSpacing | The character spacing.
Public Field | ClippingStack | The clipping stack.
Public Field | CurrentFontIndex | The current font index.
Public Field | EnableKinsoku | The kinsoku field. If True, it is enabled.
Public Field | Font | The font.
Public Field | ForeColor | The for color.
Public Field | LineSpacing | The line spacing.
Public Field | Padding | The padding.
Public Field | PenStyle | The pen style.
Public Field | PenStyleTransparent | The flag determining that pen style is transparent.
Public Field | PenThickness | The pen thickness.
Public Field | RightToLeft | The RTL text flag.
Public Field | ScaleX | Scale on the X axis.
Public Field | TabStops | Array of the tab stops.
Public Field | TextAlignment | The text alignment.
Public Field | TextAngle | The angle of the text.
Public Field | TextJustify | The text justification.
Public Field | TextRenderingHint | The text render hint.
Public Field | VerticalText | The vertical text.
Public Field | VerticalTextAlignment | The vertical text alignment.
Public Field | WrapMode | The wrap mode.
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Top

See Also

Reference

RenderState Class
GrapeCity.ActiveReports.Document.Section Namespace


RenderState Class Methods

[image]
ActiveReports 19 .NET Edition
RenderState Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RenderState Class

Glossary Item Box

For a list of all members of this type, see RenderState members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a cloning of this instance.
Top

See Also

Reference

RenderState Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : Clone Method

Glossary Item Box

Performs a cloning of this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As RenderState
C#
public RenderState Clone()

Return Value

Returns the cloned render state item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


RenderState Class Fields

[image]
ActiveReports 19 .NET Edition
RenderState Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RenderState Class

Glossary Item Box

For a list of all members of this type, see RenderState members.

Public Fields

 | Name | Description
Public Field | BackColor | Theback color.
Public Field | BackStyleTransparent | The flag determining that back style is transparent.
Public Field | CharacterSpacing | The character spacing.
Public Field | ClippingStack | The clipping stack.
Public Field | CurrentFontIndex | The current font index.
Public Field | EnableKinsoku | The kinsoku field. If True, it is enabled.
Public Field | Font | The font.
Public Field | ForeColor | The for color.
Public Field | LineSpacing | The line spacing.
Public Field | Padding | The padding.
Public Field | PenStyle | The pen style.
Public Field | PenStyleTransparent | The flag determining that pen style is transparent.
Public Field | PenThickness | The pen thickness.
Public Field | RightToLeft | The RTL text flag.
Public Field | ScaleX | Scale on the X axis.
Public Field | TabStops | Array of the tab stops.
Public Field | TextAlignment | The text alignment.
Public Field | TextAngle | The angle of the text.
Public Field | TextJustify | The text justification.
Public Field | TextRenderingHint | The text render hint.
Public Field | VerticalText | The vertical text.
Public Field | VerticalTextAlignment | The vertical text alignment.
Public Field | WrapMode | The wrap mode.
Top

See Also

Reference

RenderState Class
GrapeCity.ActiveReports.Document.Section Namespace


BackColor Field

[image]
ActiveReports 19 .NET Edition
BackColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : BackColor Field

Glossary Item Box

Theback color.

Syntax

Visual Basic (Declaration)
Public BackColor As Color
C#
public Color BackColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


BackStyleTransparent Field

[image]
ActiveReports 19 .NET Edition
BackStyleTransparent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : BackStyleTransparent Field

Glossary Item Box

The flag determining that back style is transparent.

Syntax

Visual Basic (Declaration)
Public BackStyleTransparent As Boolean
C#
public bool BackStyleTransparent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


CharacterSpacing Field

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : CharacterSpacing Field

Glossary Item Box

The character spacing.

Syntax

Visual Basic (Declaration)
Public CharacterSpacing As Single
C#
public float CharacterSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


ClippingStack Field

[image]
ActiveReports 19 .NET Edition
ClippingStack Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : ClippingStack Field

Glossary Item Box

The clipping stack.

Syntax

Visual Basic (Declaration)
Public ReadOnly ClippingStack As ClippingStack
C#
public readonly ClippingStack ClippingStack

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


CurrentFontIndex Field

[image]
ActiveReports 19 .NET Edition
CurrentFontIndex Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : CurrentFontIndex Field

Glossary Item Box

The current font index.

Syntax

Visual Basic (Declaration)
Public CurrentFontIndex As Integer
C#
public int CurrentFontIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


EnableKinsoku Field

[image]
ActiveReports 19 .NET Edition
EnableKinsoku Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : EnableKinsoku Field

Glossary Item Box

The kinsoku field. If True, it is enabled.

Syntax

Visual Basic (Declaration)
Public EnableKinsoku As Boolean
C#
public bool EnableKinsoku

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


Font Field

[image]
ActiveReports 19 .NET Edition
Font Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : Font Field

Glossary Item Box

The font.

Syntax

Visual Basic (Declaration)
Public Font As Font
C#
public Font Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


ForeColor Field

[image]
ActiveReports 19 .NET Edition
ForeColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : ForeColor Field

Glossary Item Box

The for color.

Syntax

Visual Basic (Declaration)
Public ForeColor As Color
C#
public Color ForeColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


LineSpacing Field

[image]
ActiveReports 19 .NET Edition
LineSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : LineSpacing Field

Glossary Item Box

The line spacing.

Syntax

Visual Basic (Declaration)
Public LineSpacing As Single
C#
public float LineSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


Padding Field

[image]
ActiveReports 19 .NET Edition
Padding Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : Padding Field

Glossary Item Box

The padding.

Syntax

Visual Basic (Declaration)
Public Padding As PaddingEx
C#
public PaddingEx Padding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


PenStyle Field

[image]
ActiveReports 19 .NET Edition
PenStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : PenStyle Field

Glossary Item Box

The pen style.

Syntax

Visual Basic (Declaration)
Public PenStyle As PenStyles
C#
public PenStyles PenStyle

Field Value

For a list of valid values, see here: PenStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


PenStyleTransparent Field

[image]
ActiveReports 19 .NET Edition
PenStyleTransparent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : PenStyleTransparent Field

Glossary Item Box

The flag determining that pen style is transparent.

Syntax

Visual Basic (Declaration)
Public PenStyleTransparent As Boolean
C#
public bool PenStyleTransparent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


PenThickness Field

[image]
ActiveReports 19 .NET Edition
PenThickness Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : PenThickness Field

Glossary Item Box

The pen thickness.

Syntax

Visual Basic (Declaration)
Public PenThickness As Short
C#
public short PenThickness

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


RightToLeft Field

[image]
ActiveReports 19 .NET Edition
RightToLeft Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : RightToLeft Field

Glossary Item Box

The RTL text flag.

Syntax

Visual Basic (Declaration)
Public RightToLeft As Boolean
C#
public bool RightToLeft

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


ScaleX Field

[image]
ActiveReports 19 .NET Edition
ScaleX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : ScaleX Field

Glossary Item Box

Scale on the X axis.

Syntax

Visual Basic (Declaration)
Public ScaleX As Single
C#
public float ScaleX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


TabStops Field

[image]
ActiveReports 19 .NET Edition
TabStops Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : TabStops Field

Glossary Item Box

Array of the tab stops.

Syntax

Visual Basic (Declaration)
Public TabStops As TabStopsItem.TabStop()
C#
public TabStopsItem.TabStop[] TabStops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


TextAlignment Field

[image]
ActiveReports 19 .NET Edition
TextAlignment Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : TextAlignment Field

Glossary Item Box

The text alignment.

Syntax

Visual Basic (Declaration)
Public TextAlignment As TextAlignment
C#
public TextAlignment TextAlignment

Field Value

For a list of valid values, see here: TextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


TextAngle Field

[image]
ActiveReports 19 .NET Edition
TextAngle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : TextAngle Field

Glossary Item Box

The angle of the text.

Syntax

Visual Basic (Declaration)
Public TextAngle As Integer
C#
public int TextAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


TextJustify Field

[image]
ActiveReports 19 .NET Edition
TextJustify Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : TextJustify Field

Glossary Item Box

The text justification.

Syntax

Visual Basic (Declaration)
Public TextJustify As TextJustify
C#
public TextJustify TextJustify

Field Value

For a list of valid values, see here: TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


TextRenderingHint Field

[image]
ActiveReports 19 .NET Edition
TextRenderingHint Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : TextRenderingHint Field

Glossary Item Box

The text render hint.

Syntax

Visual Basic (Declaration)
Public TextRenderingHint As TextRenderHint
C#
public TextRenderHint TextRenderingHint

Field Value

For a list of valid values, see here: TextRenderHint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


VerticalText Field

[image]
ActiveReports 19 .NET Edition
VerticalText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : VerticalText Field

Glossary Item Box

The vertical text.

Syntax

Visual Basic (Declaration)
Public VerticalText As Boolean
C#
public bool VerticalText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


VerticalTextAlignment Field

[image]
ActiveReports 19 .NET Edition
VerticalTextAlignment Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : VerticalTextAlignment Field

Glossary Item Box

The vertical text alignment.

Syntax

Visual Basic (Declaration)
Public VerticalTextAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VerticalTextAlignment

Field Value

For a list of valid values, see here: VerticalTextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


WrapMode Field

[image]
ActiveReports 19 .NET Edition
WrapMode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RenderState Class : WrapMode Field

Glossary Item Box

The wrap mode.

Syntax

Visual Basic (Declaration)
Public WrapMode As WrapMode
C#
public WrapMode WrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderState Class
RenderState Members


ResetContext Class

[image]
ActiveReports 19 .NET Edition
ResetContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResetContext Class

Glossary Item Box

Represents the context for reset.

Object Model

ResetContext Class

Syntax

Visual Basic (Declaration)
Public Class ResetContext
   Inherits CanvasItem
C#
public class ResetContext : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResetContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResetContext Members
GrapeCity.ActiveReports.Document.Section Namespace


ResetContext Class Members

[image]
ActiveReports 19 .NET Edition
ResetContext Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResetContext Class

Glossary Item Box

The following tables list the members exposed by ResetContext.

See Also

Reference

ResetContext Class
GrapeCity.ActiveReports.Document.Section Namespace


ResourcedCanvasItem Class

[image]
ActiveReports 19 .NET Edition
ResourcedCanvasItem Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResourcedCanvasItem Class

Glossary Item Box

Represents a canvas element with resources.

Object Model

ResourcedCanvasItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ResourcedCanvasItem
   Inherits CanvasItem
   Implements IBordered
C#
public abstract class ResourcedCanvasItem : CanvasItem, IBordered

Example

C# Copy Code
public class MyResourcedCanvasItem : ResourcedCanvasItem
{
    public MyResourcedCanvasItem(IImageConverterService imageConverterService, CanvasType ctType) : base(imageConverterService, ctType)
    {
    }
    public MyResourcedCanvasItem(IImageConverterService imageConverterService, CanvasType canvasType, float left, float top, float width, float height, string strLink) : base(imageConverterService, canvasType, left, top, width, height, strLink)
    {
    }
       protected override Guid ImageFormatGuid() => ImageFormat.Bmp.Guid;
    protected override string ImageTypeName() => ResourceManager.ImageResource.BitmapTypeName;
    internal override ResourcedCanvasItem Clone(ResourceManager targetResourceMgr) => new MyResourcedCanvasItem(ImageConverterService, Type);
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.BitmapImage
GrapeCity.ActiveReports.Document.Section.EnhMeta
GrapeCity.ActiveReports.Document.Section.LinkItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcedCanvasItem Members
GrapeCity.ActiveReports.Document.Section Namespace


ResourcedCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
ResourcedCanvasItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResourcedCanvasItem Class

Glossary Item Box

The following tables list the members exposed by ResourcedCanvasItem.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | InnerKey | Gets the inner key.
Top

Public Methods

 | Name | Description
Public Method | ConvertImageData | Converts image to one of allowed image format if needed.
Public Method | GetImageStream | Gets a stream for loading image data from resource pool.
Top

See Also

Reference

ResourcedCanvasItem Class
GrapeCity.ActiveReports.Document.Section Namespace


ResourcedCanvasItem Class Methods

[image]
ActiveReports 19 .NET Edition
ResourcedCanvasItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResourcedCanvasItem Class

Glossary Item Box

For a list of all members of this type, see ResourcedCanvasItem members.

Public Methods

 | Name | Description
Public Method | ConvertImageData | Converts image to one of allowed image format if needed.
Public Method | GetImageStream | Gets a stream for loading image data from resource pool.
Top

See Also

Reference

ResourcedCanvasItem Class
GrapeCity.ActiveReports.Document.Section Namespace


ConvertImageData Method

[image]
ActiveReports 19 .NET Edition
ConvertImageData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ResourcedCanvasItem Class : ConvertImageData Method

allowedFormats
Allowed image formats for conversion.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Glossary Item Box

Converts image to one of allowed image format if needed.

Syntax

Visual Basic (Declaration)
Public Function ConvertImageData( _
   ByVal allowedFormats() As ImageFormat, _
   ByVal fixRotation As Boolean _
) As ImageData
C#
public ImageData ConvertImageData(
   ImageFormat[] allowedFormats,
   bool fixRotation
)

Parameters

allowedFormats
Allowed image formats for conversion.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Return Value

The ImageData struct which contains the data stream from which the image can be loaded and the format of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcedCanvasItem Class
ResourcedCanvasItem Members


GetImageStream Method

[image]
ActiveReports 19 .NET Edition
GetImageStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ResourcedCanvasItem Class : GetImageStream Method

Glossary Item Box

Gets a stream for loading image data from resource pool.

Syntax

Visual Basic (Declaration)
Public Function GetImageStream() As MemoryStream
C#
public MemoryStream GetImageStream()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcedCanvasItem Class
ResourcedCanvasItem Members


ResourcedCanvasItem Class Properties

[image]
ActiveReports 19 .NET Edition
ResourcedCanvasItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResourcedCanvasItem Class

Glossary Item Box

For a list of all members of this type, see ResourcedCanvasItem members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | InnerKey | Gets the inner key.
Top

See Also

Reference

ResourcedCanvasItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ResourcedCanvasItem Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcedCanvasItem Class
ResourcedCanvasItem Members


InnerKey Property

[image]
ActiveReports 19 .NET Edition
InnerKey Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ResourcedCanvasItem Class : InnerKey Property

Glossary Item Box

Gets the inner key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerKey As Integer
C#
public int InnerKey {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcedCanvasItem Class
ResourcedCanvasItem Members


RoundRect Class

[image]
ActiveReports 19 .NET Edition
RoundRect Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRect Class

Glossary Item Box

Represents a canvas element with a rounded rectangle.

Object Model

RoundRect Class

Syntax

Visual Basic (Declaration)
Public Class RoundRect
   Inherits CanvasItem
   Implements IBordered
C#
public class RoundRect : CanvasItem, IBordered

Example

C# Copy Code
public void DrawRoundRect(float left, float top, float width, float height, float edgeWidth, float edgeHeight)
{
    CanvasItems.Add(new RoundRect(left, top, width, height, edgeWidth, edgeHeight));
}

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.RoundRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRect Members
GrapeCity.ActiveReports.Document.Section Namespace


RoundRect Class Members

[image]
ActiveReports 19 .NET Edition
RoundRect Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRect Class

Glossary Item Box

The following tables list the members exposed by RoundRect.

Public Constructors

 | Name | Description
Public Constructor | RoundRect Constructor | Initializes a new instance of the RoundRect class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

RoundRect Class
GrapeCity.ActiveReports.Document.Section Namespace


RoundRect Constructor

[image]
ActiveReports 19 .NET Edition
RoundRect Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRect Class : RoundRect Constructor

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Glossary Item Box

Initializes a new instance of the RoundRect class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal edgeWidth As Single, _
   ByVal edgeHeight As Single _
)
C#
public RoundRect(
   float left,
   float top,
   float width,
   float height,
   float edgeWidth,
   float edgeHeight
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRect Class
RoundRect Members


RoundRect Class Properties

[image]
ActiveReports 19 .NET Edition
RoundRect Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRect Class

Glossary Item Box

For a list of all members of this type, see RoundRect members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

RoundRect Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRect Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRect Class
RoundRect Members


RoundRectEx Class

[image]
ActiveReports 19 .NET Edition
RoundRectEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRectEx Class

Glossary Item Box

Represents the extended version of RoundRect canvas item. It provides ability to change radius of each corner separately.

Object Model

RoundRectEx Class

Syntax

Visual Basic (Declaration)
Public Class RoundRectEx
   Inherits CanvasItem
   Implements IBordered
C#
public class RoundRectEx : CanvasItem, IBordered

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.RoundRectEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRectEx Members
GrapeCity.ActiveReports.Document.Section Namespace


RoundRectEx Class Members

[image]
ActiveReports 19 .NET Edition
RoundRectEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRectEx Class

Glossary Item Box

The following tables list the members exposed by RoundRectEx.

Public Constructors

 | Name | Description
Public Constructor | RoundRectEx Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

RoundRectEx Class
GrapeCity.ActiveReports.Document.Section Namespace


RoundRectEx Constructor

[image]
ActiveReports 19 .NET Edition
RoundRectEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRectEx Class : RoundRectEx Constructor

Glossary Item Box

Overload List

Overload | Description
RoundRectEx Constructor(Single,Single,Single,Single,Single,Single) | Initializes a new instance of the RoundRectEx class.
RoundRectEx Constructor(Single,Single,Single,Single,Single,Single,Single,Single) | Initializes a new instance of the RoundRectEx class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRectEx Class
RoundRectEx Members


RoundRectEx Constructor(Single,Single,Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
RoundRectEx Constructor(Single,Single,Single,Single,Single,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRectEx Class > RoundRectEx Constructor : RoundRectEx Constructor(Single,Single,Single,Single,Single,Single)

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Glossary Item Box

Initializes a new instance of the RoundRectEx class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal edgeWidth As Single, _
   ByVal edgeHeight As Single _
)
C#
public RoundRectEx(
   float left,
   float top,
   float width,
   float height,
   float edgeWidth,
   float edgeHeight
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRectEx Class
RoundRectEx Members
Overload List


RoundRectEx Constructor(Single,Single,Single,Single,Single,Single,Single,Single)

[image]
ActiveReports 19 .NET Edition
RoundRectEx Constructor(Single,Single,Single,Single,Single,Single,Single,Single)
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRectEx Class > RoundRectEx Constructor : RoundRectEx Constructor(Single,Single,Single,Single,Single,Single,Single,Single)

left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
The top left edge.
topRightEdge
The top right edge.
bottomLeftEdge
The bottom left edge.
bottomRightEdge
The bottom right edge.

Glossary Item Box

Initializes a new instance of the RoundRectEx class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single _
)
C#
public RoundRectEx(
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
The top left edge.
topRightEdge
The top right edge.
bottomLeftEdge
The bottom left edge.
bottomRightEdge
The bottom right edge.

Example

C# Copy Code
public void DrawRoundRect(float left, float top, float width, float height,
float topLeftEdge, float topRightEdge,
    float bottomLeftEdge, float bottomRightEdge,
    float precision)
{
        CanvasItems.Add(new RoundRectEx(left, top,
            width, height,
            topLeftEdge, topRightEdge,
            bottomLeftEdge, bottomRightEdge
            ));
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRectEx Class
RoundRectEx Members
Overload List


RoundRectEx Class Properties

[image]
ActiveReports 19 .NET Edition
RoundRectEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRectEx Class

Glossary Item Box

For a list of all members of this type, see RoundRectEx members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Top

See Also

Reference

RoundRectEx Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRectEx Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRectEx Class
RoundRectEx Members


RTL Class

[image]
ActiveReports 19 .NET Edition
RTL Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RTL Class

Glossary Item Box

Represents the Right To Left canvas item.

Object Model

RTL Class

Syntax

Visual Basic (Declaration)
Public Class RTL
   Inherits CanvasItem
C#
public class RTL : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.RTL

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RTL Members
GrapeCity.ActiveReports.Document.Section Namespace


RTL Class Members

[image]
ActiveReports 19 .NET Edition
RTL Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RTL Class

Glossary Item Box

The following tables list the members exposed by RTL.

See Also

Reference

RTL Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfo Class

[image]
ActiveReports 19 .NET Edition
SectionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfo Class

Glossary Item Box

Provides information about the section.

Object Model

SectionInfo Class

Syntax

Visual Basic (Declaration)
Public Class SectionInfo
   Inherits CanvasItem
C#
public class SectionInfo : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SectionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionInfo Members
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfo Class Members

[image]
ActiveReports 19 .NET Edition
SectionInfo Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfo Class

Glossary Item Box

The following tables list the members exposed by SectionInfo.

Public Constructors

 | Name | Description
Public Constructor | SectionInfo Constructor | Initializes an instance of class SectionInfo.
Top

See Also

Reference

SectionInfo Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfo Constructor

[image]
ActiveReports 19 .NET Edition
SectionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SectionInfo Class : SectionInfo Constructor

type
The section type.
name
The name.

Glossary Item Box

Initializes an instance of class SectionInfo.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As SectionType, _
   ByVal name As String _
)
C#
public SectionInfo(
   SectionType type,
   string name
)

Parameters

type
The section type.
name
The name.

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionInfo Class
SectionInfo Members


SectionInfoEnd Class

[image]
ActiveReports 19 .NET Edition
SectionInfoEnd Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfoEnd Class

Glossary Item Box

Represents the end of the section information.

Object Model

SectionInfoEnd Class

Syntax

Visual Basic (Declaration)
Public Class SectionInfoEnd
   Inherits CanvasItem
C#
public class SectionInfoEnd : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SectionInfoEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionInfoEnd Members
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfoEnd Class Members

[image]
ActiveReports 19 .NET Edition
SectionInfoEnd Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfoEnd Class

Glossary Item Box

The following tables list the members exposed by SectionInfoEnd.

Public Constructors

 | Name | Description
Public Constructor | SectionInfoEnd Constructor | Initializes an instance of class SectionInfoEnd.
Top

See Also

Reference

SectionInfoEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfoEnd Constructor

[image]
ActiveReports 19 .NET Edition
SectionInfoEnd Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SectionInfoEnd Class : SectionInfoEnd Constructor

Glossary Item Box

Initializes an instance of class SectionInfoEnd.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SectionInfoEnd()

Remarks

This constructor should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionInfoEnd Class
SectionInfoEnd Members


SelectFont Class

[image]
ActiveReports 19 .NET Edition
SelectFont Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SelectFont Class

Glossary Item Box

Represents the selected font.

Object Model

SelectFont Class

Syntax

Visual Basic (Declaration)
Public Class SelectFont
   Inherits CanvasItem
C#
public class SelectFont : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SelectFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectFont Members
GrapeCity.ActiveReports.Document.Section Namespace


SelectFont Class Members

[image]
ActiveReports 19 .NET Edition
SelectFont Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SelectFont Class

Glossary Item Box

The following tables list the members exposed by SelectFont.

See Also

Reference

SelectFont Class
GrapeCity.ActiveReports.Document.Section Namespace


SetCharacterSpacing Class

[image]
ActiveReports 19 .NET Edition
SetCharacterSpacing Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetCharacterSpacing Class

Glossary Item Box

Represents the setter of character spacing.

Object Model

SetCharacterSpacing Class

Syntax

Visual Basic (Declaration)
Public Class SetCharacterSpacing
   Inherits CanvasItem
C#
public class SetCharacterSpacing : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SetCharacterSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetCharacterSpacing Members
GrapeCity.ActiveReports.Document.Section Namespace


SetCharacterSpacing Class Members

[image]
ActiveReports 19 .NET Edition
SetCharacterSpacing Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetCharacterSpacing Class

Glossary Item Box

The following tables list the members exposed by SetCharacterSpacing.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetCharacterSpacing received from a System.IO.BinaryReader.
Top

See Also

Reference

SetCharacterSpacing Class
GrapeCity.ActiveReports.Document.Section Namespace


SetCharacterSpacing Class Methods

[image]
ActiveReports 19 .NET Edition
SetCharacterSpacing Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetCharacterSpacing Class

Glossary Item Box

For a list of all members of this type, see SetCharacterSpacing members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetCharacterSpacing received from a System.IO.BinaryReader.
Top

See Also

Reference

SetCharacterSpacing Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetCharacterSpacing Class : CreateRead Method

reader
Reader containing the binary data of SetCharacterSpacing.
fileVersion
The type of data in the stream.

Glossary Item Box

Return an instance of the SetCharacterSpacing received from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As SetCharacterSpacing
C#
public static SetCharacterSpacing CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
Reader containing the binary data of SetCharacterSpacing.
fileVersion
The type of data in the stream.

Return Value

A new SetCharacterSpacing instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetCharacterSpacing Class
SetCharacterSpacing Members


SetLineSpacing Class

[image]
ActiveReports 19 .NET Edition
SetLineSpacing Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetLineSpacing Class

Glossary Item Box

Represents the setter of line spacing.

Object Model

SetLineSpacing Class

Syntax

Visual Basic (Declaration)
Public Class SetLineSpacing
   Inherits CanvasItem
C#
public class SetLineSpacing : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SetLineSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetLineSpacing Members
GrapeCity.ActiveReports.Document.Section Namespace


SetLineSpacing Class Members

[image]
ActiveReports 19 .NET Edition
SetLineSpacing Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetLineSpacing Class

Glossary Item Box

The following tables list the members exposed by SetLineSpacing.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetLineSpacing received from a System.IO.BinaryReader.
Top

See Also

Reference

SetLineSpacing Class
GrapeCity.ActiveReports.Document.Section Namespace


SetLineSpacing Class Methods

[image]
ActiveReports 19 .NET Edition
SetLineSpacing Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetLineSpacing Class

Glossary Item Box

For a list of all members of this type, see SetLineSpacing members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetLineSpacing received from a System.IO.BinaryReader.
Top

See Also

Reference

SetLineSpacing Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetLineSpacing Class : CreateRead Method

reader
Reader containing the binary data of SetLineSpacing.
fileVersion
The type of data in the stream.

Glossary Item Box

Return an instance of the SetLineSpacing received from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As SetLineSpacing
C#
public static SetLineSpacing CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
Reader containing the binary data of SetLineSpacing.
fileVersion
The type of data in the stream.

Return Value

A new SetLineSpacing instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetLineSpacing Class
SetLineSpacing Members


SetPadding Class

[image]
ActiveReports 19 .NET Edition
SetPadding Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetPadding Class

Glossary Item Box

Represents the setter of the padding.

Object Model

SetPadding Class

Syntax

Visual Basic (Declaration)
Public Class SetPadding
   Inherits CanvasItem
C#
public class SetPadding : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SetPadding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetPadding Members
GrapeCity.ActiveReports.Document.Section Namespace


SetPadding Class Members

[image]
ActiveReports 19 .NET Edition
SetPadding Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetPadding Class

Glossary Item Box

The following tables list the members exposed by SetPadding.

See Also

Reference

SetPadding Class
GrapeCity.ActiveReports.Document.Section Namespace


SetScaleX Class

[image]
ActiveReports 19 .NET Edition
SetScaleX Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

Represents the setter of minimal character condensed rate for the X coordinate.

Object Model

SetScaleX Class

Syntax

Visual Basic (Declaration)
Public Class SetScaleX
   Inherits CanvasItem
C#
public class SetScaleX : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SetScaleX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Members
GrapeCity.ActiveReports.Document.Section Namespace


SetScaleX Class Members

[image]
ActiveReports 19 .NET Edition
SetScaleX Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

The following tables list the members exposed by SetScaleX.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetScaleX received from a System.IO.BinaryReader.
Top

See Also

Reference

SetScaleX Class
GrapeCity.ActiveReports.Document.Section Namespace


SetScaleX Class Methods

[image]
ActiveReports 19 .NET Edition
SetScaleX Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

For a list of all members of this type, see SetScaleX members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the SetScaleX received from a System.IO.BinaryReader.
Top

See Also

Reference

SetScaleX Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetScaleX Class : CreateRead Method

reader
Reader containing the binary data of SetScaleX.
fileVersion
The type of data in the stream.

Glossary Item Box

Return an instance of the SetScaleX received from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As SetScaleX
C#
public static SetScaleX CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
Reader containing the binary data of SetScaleX.
fileVersion
The type of data in the stream.

Return Value

A new SetScaleX instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Class
SetScaleX Members


StateChangedArgs Class

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StateChangedArgs Class

Glossary Item Box

Represents the arguments of a state change.

Object Model

StateChangedArgs Class

Syntax

Visual Basic (Declaration)
Public Class StateChangedArgs
   Inherits System.EventArgs
C#
public class StateChangedArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Document.Section.StateChangedArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Members
GrapeCity.ActiveReports.Document.Section Namespace


StateChangedArgs Class Members

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StateChangedArgs Class

Glossary Item Box

The following tables list the members exposed by StateChangedArgs.

Public Constructors

 | Name | Description
Public Constructor | StateChangedArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | State | Gets the state.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode |
Top

See Also

Reference

StateChangedArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


StateChangedArgs Constructor

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class : StateChangedArgs Constructor

Glossary Item Box

Overload List

Overload | Description
StateChangedArgs Constructor(State) | Initializes a new instance of the StateChangedArgs class.
StateChangedArgs Constructor() | Initializes a new instance of the StateChangedArgs class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members


StateChangedArgs Constructor(State)

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Constructor(State)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class > StateChangedArgs Constructor : StateChangedArgs Constructor(State)

state
The state.

Glossary Item Box

Initializes a new instance of the StateChangedArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal state As State _
)
C#
public StateChangedArgs(
   State state
)

Parameters

state
The state.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members
Overload List


StateChangedArgs Constructor()

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class > StateChangedArgs Constructor : StateChangedArgs Constructor()

Glossary Item Box

Initializes a new instance of the StateChangedArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StateChangedArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members
Overload List


StateChangedArgs Class Methods

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StateChangedArgs Class

Glossary Item Box

For a list of all members of this type, see StateChangedArgs members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode |
Top

See Also

Reference

StateChangedArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class : Equals Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members


StateChangedArgs Class Properties

[image]
ActiveReports 19 .NET Edition
StateChangedArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StateChangedArgs Class

Glossary Item Box

For a list of all members of this type, see StateChangedArgs members.

Public Properties

 | Name | Description
Public Property | State | Gets the state.
Top

See Also

Reference

StateChangedArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


State Property

[image]
ActiveReports 19 .NET Edition
State Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StateChangedArgs Class : State Property

Glossary Item Box

Gets the state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As State
C#
public State State {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedArgs Class
StateChangedArgs Members


SVG Class

[image]
ActiveReports 19 .NET Edition
SVG Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SVG Class

Glossary Item Box

Represents a SVG canvas element.

Object Model

SVG Class

Syntax

Visual Basic (Declaration)
Public Class SVG
   Inherits CanvasItem
C#
public class SVG : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SVG

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SVG Members
GrapeCity.ActiveReports.Document.Section Namespace


SVG Class Members

[image]
ActiveReports 19 .NET Edition
SVG Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SVG Class

Glossary Item Box

The following tables list the members exposed by SVG.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | InnerKey | Gets or sets the inner key.
Public Property | SvgData | Gets SVG data.
Top

See Also

Reference

SVG Class
GrapeCity.ActiveReports.Document.Section Namespace


SVG Class Properties

[image]
ActiveReports 19 .NET Edition
SVG Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SVG Class

Glossary Item Box

For a list of all members of this type, see SVG members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the item.
Public Property | InnerKey | Gets or sets the inner key.
Public Property | SvgData | Gets SVG data.
Top

See Also

Reference

SVG Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SVG Class : Bounds Property

Glossary Item Box

Gets the bounds of the item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SVG Class
SVG Members


InnerKey Property

[image]
ActiveReports 19 .NET Edition
InnerKey Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SVG Class : InnerKey Property

Glossary Item Box

Gets or sets the inner key.

Syntax

Visual Basic (Declaration)
Public Property InnerKey As Integer
C#
public int InnerKey {get; set;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SVG Class
SVG Members


SvgData Property

[image]
ActiveReports 19 .NET Edition
SvgData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SVG Class : SvgData Property

Glossary Item Box

Gets SVG data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SvgData As String
C#
public string SvgData {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SVG Class
SVG Members


Table Class

[image]
ActiveReports 19 .NET Edition
Table Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Table Class

Glossary Item Box

Represents the table canvas item. The Table CanvasItems contains an arrayList of TableRow Object which contain an array list of TableCell Objects which contains an array list of canvasItems. This class saves, load, and renders a table.

Object Model

Table Class

Syntax

Visual Basic (Declaration)
Public Class Table
   Inherits CanvasItem
C#
public class Table : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Members
GrapeCity.ActiveReports.Document.Section Namespace


Table Class Members

[image]
ActiveReports 19 .NET Edition
Table Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Table Class

Glossary Item Box

The following tables list the members exposed by Table.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overridden. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Document.Section Namespace


Table Class Methods

[image]
ActiveReports 19 .NET Edition
Table Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Methods

 | Name | Description
Public Method | Dispose | Overridden. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Document.Section Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Table Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Properties

[image]
ActiveReports 19 .NET Edition
Table Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Document.Section Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Table Class : Bounds Property

Glossary Item Box

Gets or sets the bounds.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Property Value

A System.Drawing.RectangleF struct that represents the boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TabStopsItem Class

[image]
ActiveReports 19 .NET Edition
TabStopsItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem Class

Glossary Item Box

Represents an element of a collection of custom tab stops.

Object Model

TabStopsItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TabStopsItem
   Inherits CanvasItem
C#
public sealed class TabStopsItem : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TabStopsItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem Members
GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem Class Members

[image]
ActiveReports 19 .NET Edition
TabStopsItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem Class

Glossary Item Box

The following tables list the members exposed by TabStopsItem.

Public Constructors

 | Name | Description
Public Constructor | TabStopsItem Constructor | Initializes a new instance of the TabStopsItem class.
Top

Public Properties

 | Name | Description
Public Property | TabStops | Gets the tab stops.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the CanvasItem received from a System.IO.BinaryReader
Top

See Also

Reference

TabStopsItem Class
GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem Constructor

[image]
ActiveReports 19 .NET Edition
TabStopsItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem Class : TabStopsItem Constructor

tabStops
The tab stops.

Glossary Item Box

Initializes a new instance of the TabStopsItem class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tabStops() As TabStopsItem.TabStop _
)
C#
public TabStopsItem(
   TabStopsItem.TabStop[] tabStops
)

Parameters

tabStops
The tab stops.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem Class
TabStopsItem Members


TabStopsItem Class Methods

[image]
ActiveReports 19 .NET Edition
TabStopsItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem Class

Glossary Item Box

For a list of all members of this type, see TabStopsItem members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the CanvasItem received from a System.IO.BinaryReader
Top

See Also

Reference

TabStopsItem Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem Class : CreateRead Method

reader
Reader containing the binary data of CanvasItem.
fileVersion
The type of data in the stream.

Glossary Item Box

Return an instance of the CanvasItem received from a System.IO.BinaryReader

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As CanvasItem
C#
public static CanvasItem CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
Reader containing the binary data of CanvasItem.
fileVersion
The type of data in the stream.

Return Value

A new CanvasItem instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem Class
TabStopsItem Members


TabStopsItem Class Properties

[image]
ActiveReports 19 .NET Edition
TabStopsItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem Class

Glossary Item Box

For a list of all members of this type, see TabStopsItem members.

Public Properties

 | Name | Description
Public Property | TabStops | Gets the tab stops.
Top

See Also

Reference

TabStopsItem Class
GrapeCity.ActiveReports.Document.Section Namespace


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem Class : TabStops Property

Glossary Item Box

Gets the tab stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TabStops As TabStopsItem.TabStop()
C#
public TabStopsItem.TabStop[] TabStops {get;}

Property Value

A TabStopsItem.TabStop collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem Class
TabStopsItem Members


TextAngle Class

[image]
ActiveReports 19 .NET Edition
TextAngle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextAngle Class

Glossary Item Box

Represents the angle of the text.

Object Model

TextAngle Class

Syntax

Visual Basic (Declaration)
Public Class TextAngle
   Inherits CanvasItem
C#
public class TextAngle : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TextAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextAngle Members
GrapeCity.ActiveReports.Document.Section Namespace


TextAngle Class Members

[image]
ActiveReports 19 .NET Edition
TextAngle Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextAngle Class

Glossary Item Box

The following tables list the members exposed by TextAngle.

See Also

Reference

TextAngle Class
GrapeCity.ActiveReports.Document.Section Namespace


TextBoundsRange Class

[image]
ActiveReports 19 .NET Edition
TextBoundsRange Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

Represents the range of text boundaries.

Object Model

TextBoundsRange Class

Syntax

Visual Basic (Declaration)
Public Class TextBoundsRange
   Inherits CanvasItem
C#
public class TextBoundsRange : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TextBoundsRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Members
GrapeCity.ActiveReports.Document.Section Namespace


TextBoundsRange Class Members

[image]
ActiveReports 19 .NET Edition
TextBoundsRange Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

The following tables list the members exposed by TextBoundsRange.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the TextBoundsRange received from a System.IO.BinaryReader.
Top

See Also

Reference

TextBoundsRange Class
GrapeCity.ActiveReports.Document.Section Namespace


TextBoundsRange Class Methods

[image]
ActiveReports 19 .NET Edition
TextBoundsRange Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

For a list of all members of this type, see TextBoundsRange members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateRead | Return an instance of the TextBoundsRange received from a System.IO.BinaryReader.
Top

See Also

Reference

TextBoundsRange Class
GrapeCity.ActiveReports.Document.Section Namespace


CreateRead Method

[image]
ActiveReports 19 .NET Edition
CreateRead Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextBoundsRange Class : CreateRead Method

reader
Reader containing the binary data of TextBoundsRange.
fileVersion
The type of data in the stream.

Glossary Item Box

Return an instance of the TextBoundsRange received from a System.IO.BinaryReader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As TextBoundsRange
C#
public static TextBoundsRange CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
Reader containing the binary data of TextBoundsRange.
fileVersion
The type of data in the stream.

Return Value

A new TextBoundsRange instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Class
TextBoundsRange Members


TextInfoItem Class

[image]
ActiveReports 19 .NET Edition
TextInfoItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextInfoItem Class

Glossary Item Box

Represents the text information canvas item. Used for TextBox control while exporting report to Excel.

Object Model

TextInfoItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextInfoItem
   Inherits CanvasItem
C#
public sealed class TextInfoItem : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TextInfoItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextInfoItem Members
GrapeCity.ActiveReports.Document.Section Namespace


TextInfoItem Class Members

[image]
ActiveReports 19 .NET Edition
TextInfoItem Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextInfoItem Class

Glossary Item Box

The following tables list the members exposed by TextInfoItem.

Public Constructors

 | Name | Description
Public Constructor | TextInfoItem Constructor | Initialize the instance of the TextInfoItem class.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadSafe | Return an instance of the TextInfoItem class saved in AR6
Top

See Also

Reference

TextInfoItem Class
GrapeCity.ActiveReports.Document.Section Namespace


TextInfoItem Constructor

[image]
ActiveReports 19 .NET Edition
TextInfoItem Constructor
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextInfoItem Class : TextInfoItem Constructor

outputFormat
The output format.
value
The value.
culture
The culture.
currencyCulture
The culture of the currency.

Glossary Item Box

Initialize the instance of the TextInfoItem class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal outputFormat As String, _
   ByVal value As Object, _
   ByVal culture As CultureInfo, _
   ByVal currencyCulture As CultureInfo _
)
C#
public TextInfoItem(
   string outputFormat,
   object value,
   CultureInfo culture,
   CultureInfo currencyCulture
)

Parameters

outputFormat
The output format.
value
The value.
culture
The culture.
currencyCulture
The culture of the currency.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if "value" is null

Example

C# Copy Code
public void AddTextInfoItem(string outputFormat, object value, CultureInfo culture, CultureInfo currencyCulture)
    {
        CanvasItems.add(new TextInfoItem(outputFormat, value??0, culture, currencyCulture));
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextInfoItem Class
TextInfoItem Members


TextInfoItem Class Methods

[image]
ActiveReports 19 .NET Edition
TextInfoItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextInfoItem Class

Glossary Item Box

For a list of all members of this type, see TextInfoItem members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadSafe | Return an instance of the TextInfoItem class saved in AR6
Top

See Also

Reference

TextInfoItem Class
GrapeCity.ActiveReports.Document.Section Namespace


ReadSafe Method

[image]
ActiveReports 19 .NET Edition
ReadSafe Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextInfoItem Class : ReadSafe Method

textOut
The text output.
ver
The version.

Glossary Item Box

Return an instance of the TextInfoItem class saved in AR6

Syntax

Visual Basic (Declaration)
Public Shared Function ReadSafe( _
   ByVal textOut As DrawTextLink, _
   ByVal ver As Short _
) As CanvasItem
C#
public static CanvasItem ReadSafe(
   DrawTextLink textOut,
   short ver
)

Parameters

textOut
The text output.
ver
The version.

Return Value

A new TextInfoItem instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextInfoItem Class
TextInfoItem Members


TextOut Class

[image]
ActiveReports 19 .NET Edition
TextOut Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextOut Class

Glossary Item Box

Represents the text output.

Object Model

TextOut Class

Syntax

Visual Basic (Declaration)
Public Class TextOut
   Inherits CanvasItem
C#
public class TextOut : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TextOut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextOut Members
GrapeCity.ActiveReports.Document.Section Namespace


TextOut Class Members

[image]
ActiveReports 19 .NET Edition
TextOut Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextOut Class

Glossary Item Box

The following tables list the members exposed by TextOut.

See Also

Reference

TextOut Class
GrapeCity.ActiveReports.Document.Section Namespace


TextRenderHintItem Class

[image]
ActiveReports 19 .NET Edition
TextRenderHintItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextRenderHintItem Class

Glossary Item Box

Represents a hint when rendering text.

Object Model

TextRenderHintItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextRenderHintItem
   Inherits CanvasItem
C#
public sealed class TextRenderHintItem : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.TextRenderHintItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextRenderHintItem Members
GrapeCity.ActiveReports.Document.Section Namespace


TextRenderHintItem Class Members

[image]
ActiveReports 19 .NET Edition
TextRenderHintItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextRenderHintItem Class

Glossary Item Box

The following tables list the members exposed by TextRenderHintItem.

Public Properties

 | Name | Description
Public Property | Hint | Gets the hint.
Top

See Also

Reference

TextRenderHintItem Class
GrapeCity.ActiveReports.Document.Section Namespace


TextRenderHintItem Class Properties

[image]
ActiveReports 19 .NET Edition
TextRenderHintItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextRenderHintItem Class

Glossary Item Box

For a list of all members of this type, see TextRenderHintItem members.

Public Properties

 | Name | Description
Public Property | Hint | Gets the hint.
Top

See Also

Reference

TextRenderHintItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Hint Property

[image]
ActiveReports 19 .NET Edition
Hint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextRenderHintItem Class : Hint Property

Glossary Item Box

Gets the hint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hint As TextRenderHint
C#
public TextRenderHint Hint {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextRenderHintItem Class
TextRenderHintItem Members


UrlErrorEventArgs Class

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

Represents the arguments of the url error event

Object Model

UrlErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UrlErrorEventArgs
   Inherits System.EventArgs
C#
public class UrlErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Members
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by UrlErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UrlErrorEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception.
Top

See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : UrlErrorEventArgs Constructor

Glossary Item Box

Overload List

Overload | Description
UrlErrorEventArgs Constructor() | Initializes a new instance of the UrlErrorEventArgs class.
UrlErrorEventArgs Constructor(Exception) | Initializes a new instance of the UrlErrorEventArgs class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UrlErrorEventArgs Constructor()

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor()

Glossary Item Box

Initializes a new instance of the UrlErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UrlErrorEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Constructor(Exception)

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Constructor(Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor(Exception)

e
The exception

Glossary Item Box

Initializes a new instance of the UrlErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal e As Exception _
)
C#
public UrlErrorEventArgs(
   Exception e
)

Parameters

e
The exception

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
UrlErrorEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see UrlErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception.
Top

See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


Exception Property

[image]
ActiveReports 19 .NET Edition
Exception Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : Exception Property

Glossary Item Box

Gets the exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UserPreferences Class

[image]
ActiveReports 19 .NET Edition
UserPreferences Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

Represents the user preferences.

Object Model

UserPreferences Class

Syntax

Visual Basic (Declaration)
Public Class UserPreferences
C#
public class UserPreferences

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.UserPreferences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Members
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Class Members

[image]
ActiveReports 19 .NET Edition
UserPreferences Class Members
See Also Properties Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

The following tables list the members exposed by UserPreferences.

Public Constructors

 | Name | Description
Public Constructor | UserPreferences Constructor | Initializes a new instance of the UserPreferences class.
Top

Public Properties

 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the hyper link.
Public Property | HyperLinkForeColor | Gets or sets the forefround color of the hyper link.
Public Property | HyperLinkUnderline | Gets or sets a value indicating whether the hyperlink is underlined.
Public Property | SearchResultsBackColor | Gets or sets the background color of the search results.
Public Property | SearchResultsForeColor | Gets or sets the foreground color of the search results.
Public Property | UseHyperLinkSettings | Gets or sets the use of hyperlink settings.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | Occurs when property is changed.
Top

See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Constructor

[image]
ActiveReports 19 .NET Edition
UserPreferences Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UserPreferences Constructor

Glossary Item Box

Initializes a new instance of the UserPreferences class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UserPreferences()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


UserPreferences Class Properties

[image]
ActiveReports 19 .NET Edition
UserPreferences Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

For a list of all members of this type, see UserPreferences members.

Public Properties

 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the hyper link.
Public Property | HyperLinkForeColor | Gets or sets the forefround color of the hyper link.
Public Property | HyperLinkUnderline | Gets or sets a value indicating whether the hyperlink is underlined.
Public Property | SearchResultsBackColor | Gets or sets the background color of the search results.
Public Property | SearchResultsForeColor | Gets or sets the foreground color of the search results.
Public Property | UseHyperLinkSettings | Gets or sets the use of hyperlink settings.
Top

See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


HyperLinkBackColor Property

[image]
ActiveReports 19 .NET Edition
HyperLinkBackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkBackColor Property

Glossary Item Box

Gets or sets the background color of the hyper link.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkBackColor As Color
C#
public Color HyperLinkBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkForeColor Property

[image]
ActiveReports 19 .NET Edition
HyperLinkForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkForeColor Property

Glossary Item Box

Gets or sets the forefround color of the hyper link.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkForeColor As Color
C#
public Color HyperLinkForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkUnderline Property

[image]
ActiveReports 19 .NET Edition
HyperLinkUnderline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkUnderline Property

Glossary Item Box

Gets or sets a value indicating whether the hyperlink is underlined.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkUnderline As Boolean
C#
public bool HyperLinkUnderline {get; set;}

Property Value

true if the hyperlink is underlined; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsBackColor Property

[image]
ActiveReports 19 .NET Edition
SearchResultsBackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsBackColor Property

Glossary Item Box

Gets or sets the background color of the search results.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsBackColor As Color
C#
public Color SearchResultsBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsForeColor Property

[image]
ActiveReports 19 .NET Edition
SearchResultsForeColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsForeColor Property

Glossary Item Box

Gets or sets the foreground color of the search results.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsForeColor As Color
C#
public Color SearchResultsForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


UseHyperLinkSettings Property

[image]
ActiveReports 19 .NET Edition
UseHyperLinkSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UseHyperLinkSettings Property

Glossary Item Box

Gets or sets the use of hyperlink settings.

Syntax

Visual Basic (Declaration)
Public Property UseHyperLinkSettings As Boolean
C#
public bool UseHyperLinkSettings {get; set;}

Property Value

If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


UserPreferences Class Events

[image]
ActiveReports 19 .NET Edition
UserPreferences Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

For a list of all members of this type, see UserPreferences members.

Public Events

 | Name | Description
Public Event | PropertyChanged | Occurs when property is changed.
Top

See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


PropertyChanged Event

[image]
ActiveReports 19 .NET Edition
PropertyChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : PropertyChanged Event

Glossary Item Box

Occurs when property is changed.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


VerticalText Class

[image]
ActiveReports 19 .NET Edition
VerticalText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : VerticalText Class

Glossary Item Box

Represents the vertical text.

Object Model

VerticalText Class

Syntax

Visual Basic (Declaration)
Public Class VerticalText
   Inherits CanvasItem
C#
public class VerticalText : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.VerticalText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VerticalText Members
GrapeCity.ActiveReports.Document.Section Namespace


VerticalText Class Members

[image]
ActiveReports 19 .NET Edition
VerticalText Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : VerticalText Class

Glossary Item Box

The following tables list the members exposed by VerticalText.

See Also

Reference

VerticalText Class
GrapeCity.ActiveReports.Document.Section Namespace


WordWrap Class

[image]
ActiveReports 19 .NET Edition
WordWrap Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WordWrap Class

Glossary Item Box

Represents the word wrap.

Object Model

WordWrap Class

Syntax

Visual Basic (Declaration)
Public Class WordWrap
   Inherits CanvasItem
C#
public class WordWrap : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.WordWrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordWrap Members
GrapeCity.ActiveReports.Document.Section Namespace


WordWrap Class Members

[image]
ActiveReports 19 .NET Edition
WordWrap Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WordWrap Class

Glossary Item Box

The following tables list the members exposed by WordWrap.

See Also

Reference

WordWrap Class
GrapeCity.ActiveReports.Document.Section Namespace


WrapModeItem Class

[image]
ActiveReports 19 .NET Edition
WrapModeItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapModeItem Class

Glossary Item Box

Represents text wrap mode

Object Model

WrapModeItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WrapModeItem
   Inherits CanvasItem
C#
public sealed class WrapModeItem : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.WrapModeItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WrapModeItem Members
GrapeCity.ActiveReports.Document.Section Namespace


WrapModeItem Class Members

[image]
ActiveReports 19 .NET Edition
WrapModeItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapModeItem Class

Glossary Item Box

The following tables list the members exposed by WrapModeItem.

Public Properties

 | Name | Description
Public Property | Kinsoku | Gets true if Kinsoky word breaking rules are enabled
Public Property | Mode | Gets the mode.
Top

See Also

Reference

WrapModeItem Class
GrapeCity.ActiveReports.Document.Section Namespace


WrapModeItem Class Properties

[image]
ActiveReports 19 .NET Edition
WrapModeItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapModeItem Class

Glossary Item Box

For a list of all members of this type, see WrapModeItem members.

Public Properties

 | Name | Description
Public Property | Kinsoku | Gets true if Kinsoky word breaking rules are enabled
Public Property | Mode | Gets the mode.
Top

See Also

Reference

WrapModeItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Kinsoku Property

[image]
ActiveReports 19 .NET Edition
Kinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > WrapModeItem Class : Kinsoku Property

Glossary Item Box

Gets true if Kinsoky word breaking rules are enabled

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Kinsoku As Boolean
C#
public bool Kinsoku {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WrapModeItem Class
WrapModeItem Members


Mode Property

[image]
ActiveReports 19 .NET Edition
Mode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > WrapModeItem Class : Mode Property

Glossary Item Box

Gets the mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mode As WrapMode
C#
public WrapMode Mode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WrapModeItem Class
WrapModeItem Members


AlignmentTypes Enumeration

[image]
ActiveReports 19 .NET Edition
AlignmentTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : AlignmentTypes Enumeration

Glossary Item Box

Represents the types of alignment. This AlignmentTypes enumeration specifies how text will be aligned in a table cell.

Syntax

Visual Basic (Declaration)
Public Enum AlignmentTypes
   Inherits System.Enum
C#
public enum AlignmentTypes : System.Enum

Members

Member | Description
Center | The center alignment
Far | The far alignment
Near | The near alignment

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.AlignmentTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


BackgroundStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackgroundStyle Enumeration

Glossary Item Box

Represents the background style when using the lower level page rendering API.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundStyle
   Inherits System.Enum
C#
public enum BackgroundStyle : System.Enum

Members

Member | Description
Opaque | Fill the background. Objects in the background are transparent.
Transparent | The background becomes transparent. Objects in the background can be seen through.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.BackgroundStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


CanvasType Enumeration

[image]
ActiveReports 19 .NET Edition
CanvasType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : CanvasType Enumeration

Glossary Item Box

The enumeration of canvas types.

Syntax

Visual Basic (Declaration)
Public Enum CanvasType
   Inherits System.Enum
C#
public enum CanvasType : System.Enum

Members

Member | Description
AlignBottom | The AlignBottom canvas type.
AlignCenter | The AlignCenter canvas type.
AlignJustify | The AlignJustify canvas type.
AlignLeft | The AlignLeft canvas type.
AlignMiddle | The AlignMiddle canvas type.
AlignRight | The AlignRight canvas type.
AlignTop | The AlignTop canvas type.
BackColor | The BackColor canvas type.
BackStyleOpaque | The BackStyleOpaque canvas type.
BackStyleTransparent | The BackStyleTransparent canvas type.
Border | The Border canvas type.
ControlInfo | The ControlInfo canvas type.
ControlInfoEnd | The ControlInfoEnd canvas type.
DrawText | The DrawText canvas type.
DrawText2 | The DrawText2 canvas type.
DrawTextLink | The DrawTextLink canvas type.
Ellipse | The Ellipse canvas type.
EnhMeta | The EnhMeta canvas type.
EnhMetaLink | The EnhMetaLink canvas type.
EvaluationEnd | The EvaluationEnd canvas type.
EvaluationStart | The EvaluationStart canvas type.
Extension | The Extension canvas type.
FillRect | The FillRect canvas type.
ForeColor | The ForeColor canvas type.
InputFieldCheckBox | The CheckBox field.
InputFieldTabIndex | The Tab index of current input field (if exist).
InputFieldText | The Text field.
IntersectClip | The IntersectClip canvas type.
JPEG | The JPEG canvas type.
JPEGLink | The JPEGLink canvas type.
JustifyDistribute | The JustifyDistribute canvas type.
JustifyDistributeAllLines | The JustifyDistributeAllLines canvas type.
LeftToRight | The LeftToRight canvas type.
LineItem | The LineItem canvas type.
PenStyle | The PenStyle canvas type.
PenWidth | The PenWidth canvas type.
PING | The PING canvas type.
PINGLink | The PINGLink canvas type.
PopClipRect | The PopClipRect canvas type.
PushClipRect | The PushClipRect canvas type.
Rect | The Rect canvas type.
ResetContext | The ResetContext canvas type.
Resource | The Resource canvas type.
RightToLeft | The RightToLeft canvas type.
RoundRect | The RoundRect canvas type.
RoundRectEx | The RoundRectEx canvas type.
SectionInfo | The SectionInfo canvas type.
SectionInfoEnd | The SectionInfoEnd canvas type.
SelectFont | The SelectFont canvas type.
SetCharacterSpacing | The SetCharacterSpacing canvas type.
SetLineSpacing | The SetLineSpacing canvas type.
SetPadding | The SetPadding canvas type.
SetScaleX | The SetMinCondenseRate canvas type.
SVG | The SVG field.
Table | The Table canvas type.
TabStops | The TabStops canvas type.
TextAngle | The TextAngle canvas type.
TextBoundsRange | The Text top/bottom bounds range canvas type.
TextInfo | The TextInfo canvas type.
TextOut | The TextOut canvas type.
TextRenderHint | The TextRenderHint canvas type.
VerticalText | The VerticalText canvas type.
WordWrapOff | . The WordWrapOff canvas type.
WordWrapOn | The WordWrapOn canvas type.
WrapMode | The WrapMode canvas type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.CanvasType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


ControlType Enumeration

[image]
ActiveReports 19 .NET Edition
ControlType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlType Enumeration

Glossary Item Box

Specifies control type

Syntax

Visual Basic (Declaration)
Public Enum ControlType
   Inherits System.Enum
C#
public enum ControlType : System.Enum

Members

Member | Description
Barcode | Barcode control type
Chart | Chart control type
Checkbox | Checkbox control type
CrossSectionBox | CrossSectionBox control type
CrossSectionLine | CrossSectionLine control type
Custom | Custom control type
InputFieldCheckBox | Input field checkBox control type
InputFieldText | Input field text control type
Label | Label control type
Line | Line control type
None | None control type
OleObject | OleObject control type
PageBreak | PageBreak control type
Picture | Picture control type
ReportInfo | ReportInfo control type
RichText | RichText control type
Shape | Shape control type
SubReport | SubReport control type
Table | Table control type
Textbox | Textbox control type

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.ControlType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


FindResult Enumeration

[image]
ActiveReports 19 .NET Edition
FindResult Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : FindResult Enumeration

Glossary Item Box

Represents the results of the search.

Syntax

Visual Basic (Declaration)
Public Enum FindResult
   Inherits System.Enum
C#
public enum FindResult : System.Enum

Members

Member | Description
BeginningOfPages | The beginning of pages.
EndOfPages | The end of pages.
Found | The found result.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.FindResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


InputBorderStyle Enumeration

[image]
ActiveReports 19 .NET Edition
InputBorderStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputBorderStyle Enumeration

Glossary Item Box

Border styles for input fields

Syntax

Visual Basic (Declaration)
Public Enum InputBorderStyle
   Inherits System.Enum
C#
public enum InputBorderStyle : System.Enum

Members

Member | Description
Dashed | Dashed border.
Inset | Inset, a simulated engraved rectangle that appears to be recessed below the surface of the page.
None | No border.
Solid | Solid border.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.InputBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


InputCheckStyle Enumeration

[image]
ActiveReports 19 .NET Edition
InputCheckStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputCheckStyle Enumeration

Glossary Item Box

Check styles for checkBox input fields

Syntax

Visual Basic (Declaration)
Public Enum InputCheckStyle
   Inherits System.Enum
C#
public enum InputCheckStyle : System.Enum

Members

Member | Description
Check | The check style.
Circle | The circle style.
Cross | The cross style.
Diamond | The diamond style.
Square | The square style.
Star | The start style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.InputCheckStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


InputTextAlign Enumeration

[image]
ActiveReports 19 .NET Edition
InputTextAlign Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputTextAlign Enumeration

Glossary Item Box

Alignment for text input fields

Syntax

Visual Basic (Declaration)
Public Enum InputTextAlign
   Inherits System.Enum
C#
public enum InputTextAlign : System.Enum

Members

Member | Description
Center | The center text alignment.
Left | The left text alignment.
Right | The right text alignment.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.InputTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


PageOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
PageOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageOrientation Enumeration

Glossary Item Box

Indicates the orientation of the page when outputting to the printer.

Syntax

Visual Basic (Declaration)
Public Enum PageOrientation
   Inherits System.Enum
C#
public enum PageOrientation : System.Enum

Members

Member | Description
Default | Follow the printer's default settings.
Landscape | Print page in landscape orientation.
Portrait | Print pages in portrait orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


PenStyles Enumeration

[image]
ActiveReports 19 .NET Edition
PenStyles Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyles Enumeration

Glossary Item Box

Represents the type of pen used when drawing lines on a page.

Syntax

Visual Basic (Declaration)
Public Enum PenStyles
   Inherits System.Enum
C#
public enum PenStyles : System.Enum

Members

Member | Description
Dash | Dash styled line.
DashDot | DashDot styled line.
DashDotDot | DashDotDot styled line.
Dot | Dot styled line.
Solid | Solid line.
Transparent | No line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PenStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


RdfFormat Enumeration

[image]
ActiveReports 19 .NET Edition
RdfFormat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RdfFormat Enumeration

Glossary Item Box

Represents the file format used for saving report documents.

Syntax

Visual Basic (Declaration)
Public Enum RdfFormat
   Inherits System.Enum
C#
public enum RdfFormat : System.Enum

Members

Member | Description
AR20 | ActiveX version of ActiveReports 2.0 file format. This member is left for compatibility. It is not supported to display the report outputted in this format with the ActiveX viewer control contained in "ActiveReports 2.0J" of ActiveX product or "ActiveReports for .NET 3.0J" of .NET product.
ARNet | ActiveReports for. NET file format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.RdfFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


SaveOptions Enumeration

[image]
ActiveReports 19 .NET Edition
SaveOptions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SaveOptions Enumeration

Glossary Item Box

Represents the save options.

Syntax

Visual Basic (Declaration)
Public Enum SaveOptions
   Inherits System.Enum
C#
public enum SaveOptions : System.Enum

Members

Member | Description
Compressed | Option to save in compressed form.
Normal | The default save option.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.SaveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


SectionType Enumeration

[image]
ActiveReports 19 .NET Edition
SectionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionType Enumeration

Glossary Item Box

Specifies report section type

Syntax

Visual Basic (Declaration)
Public Enum SectionType
   Inherits System.Enum
C#
public enum SectionType : System.Enum

Members

Member | Description
Detail | The detail
GroupFooter | The group footer
GroupHeader | The group header
PageFooter | The page footer
PageHeader | The page header
ReportFooter | The report footer
ReportHeader | The report header

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.SectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


State Enumeration

[image]
ActiveReports 19 .NET Edition
State Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : State Enumeration

Glossary Item Box

Represents the states

Syntax

Visual Basic (Declaration)
Public Enum State
   Inherits System.Enum
C#
public enum State : System.Enum

Members

Member | Description
Finished | The finished state.
InProgress | The in progress state.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.State

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem.TabStopTypes Enumeration

[image]
ActiveReports 19 .NET Edition
TabStopsItem.TabStopTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem.TabStopTypes Enumeration

Glossary Item Box

Represents the Tab Stop types

Syntax

Visual Basic (Declaration)
Public Enum TabStopsItem.TabStopTypes
   Inherits System.Enum
C#
public enum TabStopsItem.TabStopTypes : System.Enum

Members

Member | Description
Center | The center tab stop.
Left | The left tab stop.
Right | The right tab stop.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TabStopsItem.TabStopTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TextAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
TextAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextAlignment Enumeration

Glossary Item Box

Represents the text alignment enumeration.

Syntax

Visual Basic (Declaration)
Public Enum TextAlignment
   Inherits System.Enum
C#
public enum TextAlignment : System.Enum

Members

Member | Description
Center | The center text alignment.
Justify | The justify text alignment.
Left | The left text alignment.
Right | The right text alignment.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TextJustify Enumeration

[image]
ActiveReports 19 .NET Edition
TextJustify Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextJustify Enumeration

Glossary Item Box

Represents the text justification.

Syntax

Visual Basic (Declaration)
Public Enum TextJustify
   Inherits System.Enum
C#
public enum TextJustify : System.Enum

Members

Member | Description
Auto | Defines the justification algorithm that is determined automatically.
Distribute | Defines the newspaper-like distribution except the last line of text which is not modified.
DistributeAllLines | Defines the newspaper-like distribution including the last line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TextRenderHint Enumeration

[image]
ActiveReports 19 .NET Edition
TextRenderHint Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextRenderHint Enumeration

Glossary Item Box

Hint options for TextRenderHint canvas item

Syntax

Visual Basic (Declaration)
Public Enum TextRenderHint
   Inherits System.Enum
C#
public enum TextRenderHint : System.Enum

Members

Member | Description
Autoshrink | The autoshrink hint.
None | The no hint.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TextRenderHint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


Units Enumeration

[image]
ActiveReports 19 .NET Edition
Units Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Units Enumeration

Glossary Item Box

Represents the unit of measure of the document when using the low level rendering API on the document page.

Syntax

Visual Basic (Declaration)
Public Enum Units
   Inherits System.Enum
C#
public enum Units : System.Enum

Members

Member | Description
Centimeters | Specify the parameters of the page drawing method in centimeters.
Document | Specify the parameters of the page rendering method with the document's own unit (1/300 inch).
Inches | Specify the parameters of the page drawing method in inches.
Pixels | Specify the parameters of the page drawing method in pixels.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Units

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


VerticalTextAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
VerticalTextAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : VerticalTextAlignment Enumeration

Glossary Item Box

Represents the vertical text alignment enumeration.

Syntax

Visual Basic (Declaration)
Public Enum VerticalTextAlignment
   Inherits System.Enum
C#
public enum VerticalTextAlignment : System.Enum

Members

Member | Description
Bottom | The bottom vertical alignment.
Middle | The middle vertical alignment.
Top | The top vertical alignment.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


WrapMode Enumeration

[image]
ActiveReports 19 .NET Edition
WrapMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapMode Enumeration

Glossary Item Box

Specifies whether the text is written from left to right or right to left.

Syntax

Visual Basic (Declaration)
Public Enum WrapMode
   Inherits System.Enum
C#
public enum WrapMode : System.Enum

Members

Member | Description
CharWrap | Per-character wrapping mode.
NoWrap | No text wrap.
WordWrap | Wrap by word boundaries

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.WrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem.TabStop Structure

[image]
ActiveReports 19 .NET Edition
TabStopsItem.TabStop Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem.TabStop Structure

Glossary Item Box

Represents the structure of tab stops.

Object Model

TabStopsItem.TabStop Structure

Syntax

Visual Basic (Declaration)
Public Structure TabStopsItem.TabStop
   Inherits System.ValueType
C#
public struct TabStopsItem.TabStop : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Document.Section.TabStopsItem.TabStop

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem.TabStop Members
GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem.TabStop Structure Members

[image]
ActiveReports 19 .NET Edition
TabStopsItem.TabStop Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem.TabStop Structure

Glossary Item Box

The following tables list the members exposed by TabStopsItem.TabStop.

Public Fields

 | Name | Description
Public Field | Leading | The leading field.
Public Field | Position | The position field.
Public Field | Type | The type field.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Initializes a TabStopsItem.TabStop structure.
Top

See Also

Reference

TabStopsItem.TabStop Structure
GrapeCity.ActiveReports.Document.Section Namespace


TabStopsItem.TabStop Structure Methods

[image]
ActiveReports 19 .NET Edition
TabStopsItem.TabStop Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem.TabStop Structure

Glossary Item Box

For a list of all members of this type, see TabStopsItem.TabStop members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Initializes a TabStopsItem.TabStop structure.
Top

See Also

Reference

TabStopsItem.TabStop Structure
GrapeCity.ActiveReports.Document.Section Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem.TabStop Structure : Create Method

position
The position.
leading
The leading.
type
The tab stop type. For a list of valid values, see here: TabStopsItem.TabStopTypes.

Glossary Item Box

Initializes a TabStopsItem.TabStop structure.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal position As Single, _
   ByVal leading As String, _
   ByVal type As TabStopsItem.TabStopTypes _
) As TabStopsItem.TabStop
C#
public static TabStopsItem.TabStop Create(
   float position,
   string leading,
   TabStopsItem.TabStopTypes type
)

Parameters

position
The position.
leading
The leading.
type
The tab stop type. For a list of valid values, see here: TabStopsItem.TabStopTypes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem.TabStop Structure
TabStopsItem.TabStop Members


TabStopsItem.TabStop Structure Fields

[image]
ActiveReports 19 .NET Edition
TabStopsItem.TabStop Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TabStopsItem.TabStop Structure

Glossary Item Box

For a list of all members of this type, see TabStopsItem.TabStop members.

Public Fields

 | Name | Description
Public Field | Leading | The leading field.
Public Field | Position | The position field.
Public Field | Type | The type field.
Top

See Also

Reference

TabStopsItem.TabStop Structure
GrapeCity.ActiveReports.Document.Section Namespace


Leading Field

[image]
ActiveReports 19 .NET Edition
Leading Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem.TabStop Structure : Leading Field

Glossary Item Box

The leading field.

Syntax

Visual Basic (Declaration)
Public Leading As String
C#
public string Leading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem.TabStop Structure
TabStopsItem.TabStop Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem.TabStop Structure : Position Field

Glossary Item Box

The position field.

Syntax

Visual Basic (Declaration)
Public Position As Single
C#
public float Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem.TabStop Structure
TabStopsItem.TabStop Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TabStopsItem.TabStop Structure : Type Field

Glossary Item Box

The type field.

Syntax

Visual Basic (Declaration)
Public Type As TabStopsItem.TabStopTypes
C#
public TabStopsItem.TabStopTypes Type

Field Value

For a list of valid values, see here: TabStopsItem.TabStopTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStopsItem.TabStop Structure
TabStopsItem.TabStop Members


IBordered Interface

[image]
ActiveReports 19 .NET Edition
IBordered Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IBordered Interface

Glossary Item Box

Represents the interface with bounds.

Syntax

Visual Basic (Declaration)
Public Interface IBordered
C#
public interface IBordered

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBordered Members
GrapeCity.ActiveReports.Document.Section Namespace


IBordered Interface Members

[image]
ActiveReports 19 .NET Edition
IBordered Interface Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IBordered Interface

Glossary Item Box

The following tables list the members exposed by IBordered.

See Also

Reference

IBordered Interface
GrapeCity.ActiveReports.Document.Section Namespace


ICanvasItemRenderer Interface

[image]
ActiveReports 19 .NET Edition
ICanvasItemRenderer Interface
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemRenderer Interface

Glossary Item Box

Represents the canvas item rederer.

Syntax

Visual Basic (Declaration)
Public Interface ICanvasItemRenderer
C#
public interface ICanvasItemRenderer

Example

C# Copy Code
public void RenderPage(ICanvasItemRenderer renderer)
{
    if (renderer == null)
        throw new ArgumentNullException(nameof(renderer));
    renderer.BeginPage(this);
    foreach (var canvasItem in _pageCanvasItems)
    {
        renderer.Render(canvasItem);
    }
    renderer.EndPage();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemRenderer Members
GrapeCity.ActiveReports.Document.Section Namespace


ICanvasItemRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
ICanvasItemRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemRenderer Interface

Glossary Item Box

The following tables list the members exposed by ICanvasItemRenderer.

Public Methods

 | Name | Description
Method | BeginPage | Begins the specified GrapeCity.ActiveReports.Core.Document.Page.
Method | EndPage | Ends the page.
Method | Render | Performs a rendering of the specified CanvasItem.
Top

See Also

Reference

ICanvasItemRenderer Interface
GrapeCity.ActiveReports.Document.Section Namespace


ICanvasItemRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
ICanvasItemRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemRenderer Interface

Glossary Item Box

For a list of all members of this type, see ICanvasItemRenderer members.

Public Methods

 | Name | Description
Method | BeginPage | Begins the specified GrapeCity.ActiveReports.Core.Document.Page.
Method | EndPage | Ends the page.
Method | Render | Performs a rendering of the specified CanvasItem.
Top

See Also

Reference

ICanvasItemRenderer Interface
GrapeCity.ActiveReports.Document.Section Namespace


BeginPage Method

[image]
ActiveReports 19 .NET Edition
BeginPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ICanvasItemRenderer Interface : BeginPage Method

page
The specified page.

Glossary Item Box

Begins the specified GrapeCity.ActiveReports.Core.Document.Page.

Syntax

Visual Basic (Declaration)
Sub BeginPage( _
   ByVal page As Page _
)
C#
void BeginPage(
   Page page
)

Parameters

page
The specified page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemRenderer Interface
ICanvasItemRenderer Members


EndPage Method

[image]
ActiveReports 19 .NET Edition
EndPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ICanvasItemRenderer Interface : EndPage Method

Glossary Item Box

Ends the page.

Syntax

Visual Basic (Declaration)
Sub EndPage()
C#
void EndPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemRenderer Interface
ICanvasItemRenderer Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ICanvasItemRenderer Interface : Render Method

item
The specified page canvas item.

Glossary Item Box

Performs a rendering of the specified CanvasItem.

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal item As CanvasItem _
)
C#
void Render(
   CanvasItem item
)

Parameters

item
The specified page canvas item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemRenderer Interface
ICanvasItemRenderer Members


ICanvasItemsModifier Interface

[image]
ActiveReports 19 .NET Edition
ICanvasItemsModifier Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemsModifier Interface

Glossary Item Box

Representing modified canvas elements.

Syntax

Visual Basic (Declaration)
Public Interface ICanvasItemsModifier
C#
public interface ICanvasItemsModifier

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemsModifier Members
GrapeCity.ActiveReports.Document.Section Namespace


ICanvasItemsModifier Interface Members

[image]
ActiveReports 19 .NET Edition
ICanvasItemsModifier Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemsModifier Interface

Glossary Item Box

The following tables list the members exposed by ICanvasItemsModifier.

Public Methods

 | Name | Description
Method | InsertCanvasItem | Inserts the canvas item.
Top

See Also

Reference

ICanvasItemsModifier Interface
GrapeCity.ActiveReports.Document.Section Namespace


ICanvasItemsModifier Interface Methods

[image]
ActiveReports 19 .NET Edition
ICanvasItemsModifier Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ICanvasItemsModifier Interface

Glossary Item Box

For a list of all members of this type, see ICanvasItemsModifier members.

Public Methods

 | Name | Description
Method | InsertCanvasItem | Inserts the canvas item.
Top

See Also

Reference

ICanvasItemsModifier Interface
GrapeCity.ActiveReports.Document.Section Namespace


InsertCanvasItem Method

[image]
ActiveReports 19 .NET Edition
InsertCanvasItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ICanvasItemsModifier Interface : InsertCanvasItem Method

index
The index.
item
The item.

Glossary Item Box

Inserts the canvas item.

Syntax

Visual Basic (Declaration)
Sub InsertCanvasItem( _
   ByVal index As Integer, _
   ByVal item As CanvasItem _
)
C#
void InsertCanvasItem(
   int index,
   CanvasItem item
)

Parameters

index
The index.
item
The item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanvasItemsModifier Interface
ICanvasItemsModifier Members


ILinkItem Interface

[image]
ActiveReports 19 .NET Edition
ILinkItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ILinkItem Interface

Glossary Item Box

Represents the common interface for link items.

Syntax

Visual Basic (Declaration)
Public Interface ILinkItem
   Inherits IBordered
C#
public interface ILinkItem : IBordered

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILinkItem Members
GrapeCity.ActiveReports.Document.Section Namespace


ILinkItem Interface Members

[image]
ActiveReports 19 .NET Edition
ILinkItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ILinkItem Interface

Glossary Item Box

The following tables list the members exposed by ILinkItem.

Public Properties

 | Name | Description
Property | Link | Gets the link.
Property | Title | Gets the title of the item.
Top

See Also

Reference

ILinkItem Interface
GrapeCity.ActiveReports.Document.Section Namespace


ILinkItem Interface Properties

[image]
ActiveReports 19 .NET Edition
ILinkItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ILinkItem Interface

Glossary Item Box

For a list of all members of this type, see ILinkItem members.

Public Properties

 | Name | Description
Property | Link | Gets the link.
Property | Title | Gets the title of the item.
Top

See Also

Reference

ILinkItem Interface
GrapeCity.ActiveReports.Document.Section Namespace


Link Property

[image]
ActiveReports 19 .NET Edition
Link Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ILinkItem Interface : Link Property

Glossary Item Box

Gets the link.

Syntax

Visual Basic (Declaration)
ReadOnly Property Link As String
C#
string Link {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILinkItem Interface
ILinkItem Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ILinkItem Interface : Title Property

Glossary Item Box

Gets the title of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Title As String
C#
string Title {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILinkItem Interface
ILinkItem Members


UrlErrorEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
UrlErrorEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventHandler Delegate

sender
The sender.
e
The UrlErrorEventArgs instance containing the event data.

Glossary Item Box

Event handler for url errors.

Syntax

Visual Basic (Declaration)
Public Delegate Sub UrlErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As UrlErrorEventArgs _
)
C#
public delegate void UrlErrorEventHandler(
   object sender,
   UrlErrorEventArgs e
)

Parameters

sender
The sender.
e
The UrlErrorEventArgs instance containing the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventHandler Members
GrapeCity.ActiveReports.Document.Section Namespace


Annotation Class

[image]
ActiveReports 19 .NET Edition
Annotation Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

Represents the annotation.

Object Model

Annotation Class

Syntax

Visual Basic (Declaration)
Public Class Annotation
   Inherits System.ComponentModel.Component
C#
public class Annotation : System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Class Members

[image]
ActiveReports 19 .NET Edition
Annotation Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

The following tables list the members exposed by Annotation.

Public Constructors

 | Name | Description
Public Constructor | Annotation Constructor | Constructor for the annotation object
Top

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the alpha channel of the background color
Public Property | Border | Gets the border object for the annotation object.
Public Property | Color | Gets or sets the color used to fill the annotation object.
Public Property | Height | Gets or sets the height of the annotation object.
Public Property | Width | Gets or sets the width of the annotation object.
Public Property | X | Gets or sets X - the leftmost coordinate for the annotation object.
Public Property | Y | Gets or sets Y - the topmost coordinate for the annotation object.
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top leftmost coordinates for the annotation object.
Public Method | Refresh | Updates the display of the annotation object.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | Event that occurs when a property is changed.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Constructor

[image]
ActiveReports 19 .NET Edition
Annotation Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Annotation Constructor

border
Boundary around the Annotations object

Glossary Item Box

Constructor for the annotation object

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal border As Border _
)
C#
public Annotation(
   Border border
)

Parameters

border
Boundary around the Annotations object

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Annotation Class Methods

[image]
ActiveReports 19 .NET Edition
Annotation Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top leftmost coordinates for the annotation object.
Public Method | Refresh | Updates the display of the annotation object.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Attach Method

[image]
ActiveReports 19 .NET Edition
Attach Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Attach Method

x
The X - the leftmost coordinate for the annotation object.
y
The Y - the topmost coordinate for the annotation object.

Glossary Item Box

Sets the top leftmost coordinates for the annotation object.

Syntax

Visual Basic (Declaration)
Public Sub Attach( _
   ByVal x As Single, _
   ByVal y As Single _
)
C#
public void Attach(
   float x,
   float y
)

Parameters

x
The X - the leftmost coordinate for the annotation object.
y
The Y - the topmost coordinate for the annotation object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Refresh Method

[image]
ActiveReports 19 .NET Edition
Refresh Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Refresh Method

Glossary Item Box

Updates the display of the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Annotation Class Properties

[image]
ActiveReports 19 .NET Edition
Annotation Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the alpha channel of the background color
Public Property | Border | Gets the border object for the annotation object.
Public Property | Color | Gets or sets the color used to fill the annotation object.
Public Property | Height | Gets or sets the height of the annotation object.
Public Property | Width | Gets or sets the width of the annotation object.
Public Property | X | Gets or sets X - the leftmost coordinate for the annotation object.
Public Property | Y | Gets or sets Y - the topmost coordinate for the annotation object.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alpha Property

[image]
ActiveReports 19 .NET Edition
Alpha Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Alpha Property

Glossary Item Box

Gets or sets the alpha channel of the background color

Syntax

Visual Basic (Declaration)
Public Overridable Property Alpha As Integer
C#
public virtual int Alpha {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Border Property

Glossary Item Box

Gets the border object for the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As Border
C#
public virtual Border Border {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Color Property

Glossary Item Box

Gets or sets the color used to fill the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As Color
C#
public virtual Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Height Property

Glossary Item Box

Gets or sets the height of the annotation object.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Width Property

Glossary Item Box

Gets or sets the width of the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Single
C#
public virtual float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : X Property

Glossary Item Box

Gets or sets X - the leftmost coordinate for the annotation object.

Syntax

Visual Basic (Declaration)
Public Property X As Single
C#
public float X {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Y Property

Glossary Item Box

Gets or sets Y - the topmost coordinate for the annotation object.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
C#
public float Y {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Annotation Class Events

[image]
ActiveReports 19 .NET Edition
Annotation Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Events

 | Name | Description
Public Event | PropertyChanged | Event that occurs when a property is changed.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


PropertyChanged Event

[image]
ActiveReports 19 .NET Edition
PropertyChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : PropertyChanged Event

Glossary Item Box

Event that occurs when a property is changed.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


AnnotationArrow Class

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

Summary description for AnnotationArrow.

Object Model

AnnotationArrow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationArrow
   Inherits AnnotationText
C#
public sealed class AnnotationArrow : AnnotationText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

The following tables list the members exposed by AnnotationArrow.

Public Constructors

 | Name | Description
Public Constructor | AnnotationArrow Constructor | Default constructor for the AnnotationArrow object.
Top

Public Properties

 | Name | Description
Public Property | ArrowDirection | Gets or sets the arrow direction.
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : AnnotationArrow Constructor

Glossary Item Box

Default constructor for the AnnotationArrow object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationArrow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationArrow Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

Public Properties

 | Name | Description
Public Property | ArrowDirection | Gets or sets the arrow direction.
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Property

[image]
ActiveReports 19 .NET Edition
ArrowDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ArrowDirection Property

Glossary Item Box

Gets or sets the arrow direction.

Syntax

Visual Basic (Declaration)
Public Property ArrowDirection As ArrowDirection
C#
public ArrowDirection ArrowDirection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

Summary description for AnnotationBalloon.

Object Model

AnnotationBalloon Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationBalloon
   Inherits AnnotationText
C#
public sealed class AnnotationBalloon : AnnotationText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

The following tables list the members exposed by AnnotationBalloon.

Public Constructors

 | Name | Description
Public Constructor | AnnotationBalloon Constructor | Default constructor for the AnnotationBalloon object.
Top

Public Properties

 | Name | Description
Public Property | Quadrant | Gets or sets the quadrant of baloon
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : AnnotationBalloon Constructor

Glossary Item Box

Default constructor for the AnnotationBalloon object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationBalloon()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBalloon Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

Public Properties

 | Name | Description
Public Property | Quadrant | Gets or sets the quadrant of baloon
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Quadrant Property

[image]
ActiveReports 19 .NET Edition
Quadrant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Quadrant Property

Glossary Item Box

Gets or sets the quadrant of baloon

Syntax

Visual Basic (Declaration)
Public Property Quadrant As AnnotationBalloon.BallonQuadrant
C#
public AnnotationBalloon.BallonQuadrant Quadrant {get; set;}

Property Value

For a list of valid values, see here: AnnotationBalloon.BallonQuadrant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class

[image]
ActiveReports 19 .NET Edition
AnnotationBaseText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

Represents the base class of all Annotation objects.

Object Model

AnnotationBaseText Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class AnnotationBaseText
   Inherits Annotation
C#
public abstract class AnnotationBaseText : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationBaseText Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

The following tables list the members exposed by AnnotationBaseText.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text in the annotation's bounds.
Public Property | Font | Gets or sets the font of text.
Public Property | Format | Gets the annotation string format.
Public Property | LineAligment | Gets or sets the vertical alignment of the text in the annotation's bounds.
Public Property | Text | Gets or sets the text of the AnnotationText object.
Public Property | TextColor | Gets or sets the text color of text.
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationBaseText Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text in the annotation's bounds.
Public Property | Font | Gets or sets the font of text.
Public Property | Format | Gets the annotation string format.
Public Property | LineAligment | Gets or sets the vertical alignment of the text in the annotation's bounds.
Public Property | Text | Gets or sets the text of the AnnotationText object.
Public Property | TextColor | Gets or sets the text color of text.
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Alignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the text in the annotation's bounds.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignment
C#
public StringAlignment Alignment {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.StringAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Font Property

Glossary Item Box

Gets or sets the font of text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Format Property

Glossary Item Box

Gets the annotation string format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Format As StringFormat
C#
public StringFormat Format {get;}

Remarks

This propery should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


LineAligment Property

[image]
ActiveReports 19 .NET Edition
LineAligment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : LineAligment Property

Glossary Item Box

Gets or sets the vertical alignment of the text in the annotation's bounds.

Syntax

Visual Basic (Declaration)
Public Property LineAligment As StringAlignment
C#
public StringAlignment LineAligment {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.StringAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Text Property

Glossary Item Box

Gets or sets the text of the AnnotationText object.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


TextColor Property

[image]
ActiveReports 19 .NET Edition
TextColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : TextColor Property

Glossary Item Box

Gets or sets the text color of text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

Represents the circle of the annotation.

Object Model

AnnotationCircle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationCircle
   Inherits Annotation
C#
public sealed class AnnotationCircle : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

The following tables list the members exposed by AnnotationCircle.

Public Constructors

 | Name | Description
Public Constructor | AnnotationCircle Constructor | Default constructor for the AnnotationCircle object.
Top

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : AnnotationCircle Constructor

Glossary Item Box

Default constructor for the AnnotationCircle object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationCircle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


AnnotationCollection Class

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

Represents a collection that contains a set of annotations.

Object Model

AnnotationCollection Class

Syntax

Visual Basic (Declaration)
Public Class AnnotationCollection
   Inherits System.Collections.CollectionBase
C#
public class AnnotationCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

The following tables list the members exposed by AnnotationCollection.

Public Constructors

 | Name | Description
Public Constructor | AnnotationCollection Constructor | Initializes a new instance of AnnotationCollecion class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color.
Public Property | Item | Gets the item at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Refresh | Updates the annotation display.
Public Method | Remove | Removes the specified annotation.
Top

Public Events

 | Name | Description
Public Event | AnnotationAdded | The event occurs when annotation was just added.
Public Event | AnnotationRemoved | The event occurs when annotation was just removed.
Public Event | CollectionCleared | The event occurs when annotation was cleared.
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : AnnotationCollection Constructor

Glossary Item Box

Initializes a new instance of AnnotationCollecion class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Refresh | Updates the annotation display.
Public Method | Remove | Removes the specified annotation.
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Add Method

annotation
The annotation that will be added to the collection.

Glossary Item Box

Adds an annotation to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal annotation As Annotation _
)
C#
public void Add(
   Annotation annotation
)

Parameters

annotation
The annotation that will be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Refresh Method

[image]
ActiveReports 19 .NET Edition
Refresh Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Refresh Method

annotation
The annotation whose display will be updated

Glossary Item Box

Updates the annotation display.

Syntax

Visual Basic (Declaration)
Public Sub Refresh( _
   ByVal annotation As Annotation _
)
C#
public void Refresh(
   Annotation annotation
)

Parameters

annotation
The annotation whose display will be updated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Remove Method

annotation
The annotation that will be removed from the collection.

Glossary Item Box

Removes the specified annotation.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal annotation As Annotation _
)
C#
public void Remove(
   Annotation annotation
)

Parameters

annotation
The annotation that will be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationCollection members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color.
Public Property | Item | Gets the item at the specified index.
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : BackColor Property

Glossary Item Box

Gets or sets the background color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Item Property

index
Index of the item.

Glossary Item Box

Gets the item at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Annotation
C#
public Annotation this[
   int index
]; {get;}

Parameters

index
Index of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationCollection members.

Public Events

 | Name | Description
Public Event | AnnotationAdded | The event occurs when annotation was just added.
Public Event | AnnotationRemoved | The event occurs when annotation was just removed.
Public Event | CollectionCleared | The event occurs when annotation was cleared.
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationAdded Event

[image]
ActiveReports 19 .NET Edition
AnnotationAdded Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : AnnotationAdded Event

Glossary Item Box

The event occurs when annotation was just added.

Syntax

Visual Basic (Declaration)
Public Event AnnotationAdded As Action(Of AnnotationCollection,Annotation)
C#
public event Action<AnnotationCollection,Annotation> AnnotationAdded

Remarks

This event should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationRemoved Event

[image]
ActiveReports 19 .NET Edition
AnnotationRemoved Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : AnnotationRemoved Event

Glossary Item Box

The event occurs when annotation was just removed.

Syntax

Visual Basic (Declaration)
Public Event AnnotationRemoved As Action(Of AnnotationCollection,Annotation)
C#
public event Action<AnnotationCollection,Annotation> AnnotationRemoved

Remarks

This event should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


CollectionCleared Event

[image]
ActiveReports 19 .NET Edition
CollectionCleared Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : CollectionCleared Event

Glossary Item Box

The event occurs when annotation was cleared.

Syntax

Visual Basic (Declaration)
Public Event CollectionCleared As Action
C#
public event Action CollectionCleared

Remarks

This event should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class

[image]
ActiveReports 19 .NET Edition
AnnotationImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

Represents the annotation image.

Object Model

AnnotationImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationImage
   Inherits AnnotationText
C#
public sealed class AnnotationImage : AnnotationText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationImage Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

The following tables list the members exposed by AnnotationImage.

Public Constructors

 | Name | Description
Public Constructor | AnnotationImage Constructor | Default constructor for the AnnotationImage object.
Top

Public Properties

 | Name | Description
Public Property | BackgroundImage | Gets or sets the background image.
Public Property | BackgroundLayout | Gets or sets the background layout.
Public Property | ShowBorder | Gets or sets a value indicating whether to show border.
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : AnnotationImage Constructor

Glossary Item Box

Default constructor for the AnnotationImage object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationImage Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

Public Properties

 | Name | Description
Public Property | BackgroundImage | Gets or sets the background image.
Public Property | BackgroundLayout | Gets or sets the background layout.
Public Property | ShowBorder | Gets or sets a value indicating whether to show border.
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackgroundImage Property

[image]
ActiveReports 19 .NET Edition
BackgroundImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Image
C#
public Image BackgroundImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


BackgroundLayout Property

[image]
ActiveReports 19 .NET Edition
BackgroundLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundLayout Property

Glossary Item Box

Gets or sets the background layout.

Syntax

Visual Basic (Declaration)
Public Property BackgroundLayout As ImageLayout
C#
public ImageLayout BackgroundLayout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


ShowBorder Property

[image]
ActiveReports 19 .NET Edition
ShowBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ShowBorder Property

Glossary Item Box

Gets or sets a value indicating whether to show border.

Syntax

Visual Basic (Declaration)
Public Property ShowBorder As Boolean
C#
public bool ShowBorder {get; set;}

Property Value

true if show border; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

Summary description for AnnotationLine

Object Model

AnnotationLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationLine
   Inherits Annotation
C#
public sealed class AnnotationLine : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

The following tables list the members exposed by AnnotationLine.

Public Constructors

 | Name | Description
Public Constructor | AnnotationLine Constructor | Default constructor for the AnnotationLine object.
Top

Public Properties

 | Name | Description
Public Property | Alpha | Overridden. Gets or sets the alpha channel of the background color.
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap.
Public Property | ArrowCapWidth | Gets or sets the width of the arrow cap.
Public Property | Border | Overridden. Gets the border property that provides access to the Border object for the annotation object.
Public Property | Color | Overridden. Gets the color used to fill the annotation object.
Public Property | DashCap | Gets or sets the dash cap.
Public Property | DashStyle | Gets or sets the dash style.
Public Property | FillArrowCaps | Gets or sets a value indicating whether to fill arrow caps.
Public Property | Font | Gets or sets the font.
Public Property | Format | Gets the string format of the Annotation object.
Public Property | LineColor | Gets or sets the color of the line.
Public Property | LineLocation | Gets or sets the line location.
Public Property | LineWidth | Gets or sets the line width of the AnnotationLine object.
Public Property | ShowArrowCaps | Gets or sets the show arrow caps.
Public Property | Text | Gets or sets the text of an AnnotationLine object.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text within the annotation boundary.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | TextWidth | Gets or sets the width of the text.
Public Property | Width | Overridden. Gets or sets the width of the annotation object.
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : AnnotationLine Constructor

Glossary Item Box

Default constructor for the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Properties

 | Name | Description
Public Property | Alpha | Overridden. Gets or sets the alpha channel of the background color.
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap.
Public Property | ArrowCapWidth | Gets or sets the width of the arrow cap.
Public Property | Border | Overridden. Gets the border property that provides access to the Border object for the annotation object.
Public Property | Color | Overridden. Gets the color used to fill the annotation object.
Public Property | DashCap | Gets or sets the dash cap.
Public Property | DashStyle | Gets or sets the dash style.
Public Property | FillArrowCaps | Gets or sets a value indicating whether to fill arrow caps.
Public Property | Font | Gets or sets the font.
Public Property | Format | Gets the string format of the Annotation object.
Public Property | LineColor | Gets or sets the color of the line.
Public Property | LineLocation | Gets or sets the line location.
Public Property | LineWidth | Gets or sets the line width of the AnnotationLine object.
Public Property | ShowArrowCaps | Gets or sets the show arrow caps.
Public Property | Text | Gets or sets the text of an AnnotationLine object.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text within the annotation boundary.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | TextWidth | Gets or sets the width of the text.
Public Property | Width | Overridden. Gets or sets the width of the annotation object.
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alpha Property

[image]
ActiveReports 19 .NET Edition
Alpha Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Alpha Property

Glossary Item Box

Gets or sets the alpha channel of the background color.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Alpha As Integer
C#
public override int Alpha {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ArrowCapHeight Property

[image]
ActiveReports 19 .NET Edition
ArrowCapHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapHeight Property

Glossary Item Box

Gets or sets the height of the arrow cap.

Syntax

Visual Basic (Declaration)
Public Property ArrowCapHeight As Single
C#
public float ArrowCapHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ArrowCapWidth Property

[image]
ActiveReports 19 .NET Edition
ArrowCapWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapWidth Property

Glossary Item Box

Gets or sets the width of the arrow cap.

Syntax

Visual Basic (Declaration)
Public Property ArrowCapWidth As Single
C#
public float ArrowCapWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Border Property

Glossary Item Box

Gets the border property that provides access to the Border object for the annotation object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Border As Border
C#
public override Border Border {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Color Property

Glossary Item Box

Gets the color used to fill the annotation object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Color As Color
C#
public override Color Color {get;}

Property Value

The color is used to fill the annotation object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashCap Property

[image]
ActiveReports 19 .NET Edition
DashCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashCap Property

Glossary Item Box

Gets or sets the dash cap.

Syntax

Visual Basic (Declaration)
Public Property DashCap As DashCap
C#
public DashCap DashCap {get; set;}

Property Value

For a list of valid values, see here: DashCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashStyle Property

[image]
ActiveReports 19 .NET Edition
DashStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashStyle Property

Glossary Item Box

Gets or sets the dash style.

Syntax

Visual Basic (Declaration)
Public Property DashStyle As DashStyle
C#
public DashStyle DashStyle {get; set;}

Property Value

For a list of valid values, see here: DashStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


FillArrowCaps Property

[image]
ActiveReports 19 .NET Edition
FillArrowCaps Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : FillArrowCaps Property

Glossary Item Box

Gets or sets a value indicating whether to fill arrow caps.

Syntax

Visual Basic (Declaration)
Public Property FillArrowCaps As Boolean
C#
public bool FillArrowCaps {get; set;}

Property Value

true if fill arrow caps; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Font Property

Glossary Item Box

Gets or sets the font.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Format Property

Glossary Item Box

Gets the string format of the Annotation object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Format As StringFormat
C#
public StringFormat Format {get;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineColor Property

Glossary Item Box

Gets or sets the color of the line.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineLocation Property

[image]
ActiveReports 19 .NET Edition
LineLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineLocation Property

Glossary Item Box

Gets or sets the line location.

Syntax

Visual Basic (Declaration)
Public Property LineLocation As AnnotationLine.LinePlacement
C#
public AnnotationLine.LinePlacement LineLocation {get; set;}

Property Value

For a list of valid values, see here: AnnotationLine.LinePlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineWidth Property

[image]
ActiveReports 19 .NET Edition
LineWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineWidth Property

Glossary Item Box

Gets or sets the line width of the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property LineWidth As Single
C#
public float LineWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ShowArrowCaps Property

[image]
ActiveReports 19 .NET Edition
ShowArrowCaps Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ShowArrowCaps Property

Glossary Item Box

Gets or sets the show arrow caps.

Syntax

Visual Basic (Declaration)
Public Property ShowArrowCaps As AnnotationLine.ShowArrowCap
C#
public AnnotationLine.ShowArrowCap ShowArrowCaps {get; set;}

Property Value

For a list of valid values, see here: AnnotationLine.ShowArrowCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Text Property

Glossary Item Box

Gets or sets the text of an AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextAlignment Property

[image]
ActiveReports 19 .NET Edition
TextAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextAlignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the text within the annotation boundary.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As StringAlignment
C#
public StringAlignment TextAlignment {get; set;}

Property Value

For a list of valid values, see here: GrapeCity.ActiveReports.Document.Drawing.StringAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextColor Property

[image]
ActiveReports 19 .NET Edition
TextColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextColor Property

Glossary Item Box

Gets or sets the color of the text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextWidth Property

[image]
ActiveReports 19 .NET Edition
TextWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextWidth Property

Glossary Item Box

Gets or sets the width of the text.

Syntax

Visual Basic (Declaration)
Public Property TextWidth As Single
C#
public float TextWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Width Property

Glossary Item Box

Gets or sets the width of the annotation object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Width As Single
C#
public override float Width {get; set;}

Property Value

The Width is the width of the annotation object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

Represents the annotation rectangle.

Object Model

AnnotationRectangle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationRectangle
   Inherits Annotation
C#
public sealed class AnnotationRectangle : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

The following tables list the members exposed by AnnotationRectangle.

Public Constructors

 | Name | Description
Public Constructor | AnnotationRectangle Constructor | Default constructor for the AnnotationRectangle object.
Top

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : AnnotationRectangle Constructor

Glossary Item Box

Default constructor for the AnnotationRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationRectangle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class

[image]
ActiveReports 19 .NET Edition
AnnotationText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

Represents a summarized description for AnnotationText.

Object Model

AnnotationText Class

Syntax

Visual Basic (Declaration)
Public Class AnnotationText
   Inherits AnnotationBaseText
C#
public class AnnotationText : AnnotationBaseText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Members

[image]
ActiveReports 19 .NET Edition
AnnotationText Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

The following tables list the members exposed by AnnotationText.

Public Constructors

 | Name | Description
Public Constructor | AnnotationText Constructor | Initializes a new instance of AnnotationText class.
Top

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationText Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : AnnotationText Constructor

Glossary Item Box

Initializes a new instance of AnnotationText class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Border Class

[image]
ActiveReports 19 .NET Edition
Border Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Border Class

Glossary Item Box

Represents the border around the Annotations object.

Object Model

Border Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Border
C#
public abstract class Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Border Class Members

[image]
ActiveReports 19 .NET Edition
Border Class Members
See Also Properties Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Border Class

Glossary Item Box

The following tables list the members exposed by Border.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the boundaries of the border.
Public Property | Color | Gets or sets the color that will be used to display the border.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged | Event that occurs when a property is changed.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Border Class Properties

[image]
ActiveReports 19 .NET Edition
Border Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the boundaries of the border.
Public Property | Color | Gets or sets the color that will be used to display the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Border Class : Bounds Property

Glossary Item Box

Gets or sets the boundaries of the border.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Border Class : Color Property

Glossary Item Box

Gets or sets the color that will be used to display the border.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Events

[image]
ActiveReports 19 .NET Edition
Border Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Events

 | Name | Description
Public Event | PropertyChanged | Event that occurs when a property is changed.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


PropertyChanged Event

[image]
ActiveReports 19 .NET Edition
PropertyChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Border Class : PropertyChanged Event

Glossary Item Box

Event that occurs when a property is changed.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


BorderCircle Class

[image]
ActiveReports 19 .NET Edition
BorderCircle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

Represents the border around the circle annotation.

Object Model

BorderCircle Class

Syntax

Visual Basic (Declaration)
Public Class BorderCircle
   Inherits Border
C#
public class BorderCircle : Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Class Members

[image]
ActiveReports 19 .NET Edition
BorderCircle Class Members
See Also Properties Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

The following tables list the members exposed by BorderCircle.

Public Constructors

 | Name | Description
Public Constructor | BorderCircle Constructor | Initializes a new instance of BorderCircle class.
Top

See Also

Reference

BorderCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Constructor

[image]
ActiveReports 19 .NET Edition
BorderCircle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderCircle Class : BorderCircle Constructor

Glossary Item Box

Initializes a new instance of BorderCircle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderCircle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderCircle Class
BorderCircle Members


BorderRectangle Class

[image]
ActiveReports 19 .NET Edition
BorderRectangle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

Represents the border around the rectangle annotation.

Object Model

BorderRectangle Class

Syntax

Visual Basic (Declaration)
Public Class BorderRectangle
   Inherits Border
C#
public class BorderRectangle : Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Class Members

[image]
ActiveReports 19 .NET Edition
BorderRectangle Class Members
See Also Properties Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

The following tables list the members exposed by BorderRectangle.

Public Constructors

 | Name | Description
Public Constructor | BorderRectangle Constructor | Initializes a new instance of BorderRectangle class.
Top

See Also

Reference

BorderRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Constructor

[image]
ActiveReports 19 .NET Edition
BorderRectangle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderRectangle Class : BorderRectangle Constructor

Glossary Item Box

Initializes a new instance of BorderRectangle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderRectangle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRectangle Class
BorderRectangle Members


AnnotationBalloon.BallonQuadrant Enumeration

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon.BallonQuadrant Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon.BallonQuadrant Enumeration

Glossary Item Box

Represents quadrant of the baloon

Syntax

Visual Basic (Declaration)
Public Enum AnnotationBalloon.BallonQuadrant
   Inherits System.Enum
C#
public enum AnnotationBalloon.BallonQuadrant : System.Enum

Members

Member | Description
BottomLeft | The bottom left
BottomRight | The bottom right
LeftBottom | The left bottom
LeftTop | The left top
None | The none
RightBottom | The right bottom
RightTop | The right top
TopLeft | The top left
TopRight | The top right

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon.BallonQuadrant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.LinePlacement Enumeration

[image]
ActiveReports 19 .NET Edition
AnnotationLine.LinePlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.LinePlacement Enumeration

Glossary Item Box

Represents where the border of the object is drawn.

Syntax

Visual Basic (Declaration)
Public Enum AnnotationLine.LinePlacement
   Inherits System.Enum
C#
public enum AnnotationLine.LinePlacement : System.Enum

Members

Member | Description
Bottom | Draws a line at the bottom of the object.
Middle | Draws a line in the center of the object.
Top | Draws a line at the top of the object.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.LinePlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.ShowArrowCap Enumeration

[image]
ActiveReports 19 .NET Edition
AnnotationLine.ShowArrowCap Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.ShowArrowCap Enumeration

Glossary Item Box

Represents whether to draw arrowheads or not.

Syntax

Visual Basic (Declaration)
Public Enum AnnotationLine.ShowArrowCap
   Inherits System.Enum
C#
public enum AnnotationLine.ShowArrowCap : System.Enum

Members

Member | Description
LeftOnly | Draw the arrowhead at the left end.
LeftRight | Draw arrowheads at both ends.
None | Do not draw arrowheads.
RightOnly | Draw the arrowhead at the right end.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.ShowArrowCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Enumeration

[image]
ActiveReports 19 .NET Edition
ArrowDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ArrowDirection Enumeration

Glossary Item Box

Represents arrow annotation direction

Syntax

Visual Basic (Declaration)
Public Enum ArrowDirection
   Inherits System.Enum
C#
public enum ArrowDirection : System.Enum

Members

Member | Description
Bottom | Bottom Arrow
Left | Left Arrow
Right | Right Arrow
Top | Top Arrow

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ArrowDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ImageLayout Enumeration

[image]
ActiveReports 19 .NET Edition
ImageLayout Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ImageLayout Enumeration

Glossary Item Box

Represents image annotation layout

Syntax

Visual Basic (Declaration)
Public Enum ImageLayout
   Inherits System.Enum
C#
public enum ImageLayout : System.Enum

Members

Member | Description
Bottom | The image is displayed at the bottom of the annotation area.
Center | The image is displayed in the center of the annotation area.
Left | The image is displayed at the left edge of the annotation area.
LeftBottom | The image is displayed at the bottom left corner of the annotation area.
LeftTop | The image is displayed at the upper left corner of the annotation area.
Right | The image is displayed at the right end of the annotation area.
RightBottom | The image is displayed at the bottom right corner of the annotation area.
RightTop | The image is displayed at the upper right corner of the annotation area.
Stretch | The image is stretched to the region of the annotation regardless of the aspect ratio.
Tile | The image is the actual size and is displayed side-by-side across the area of the annotation.
Top | The image is displayed at the top of the annotation area.
Zoom | The image is displayed according to the size of the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ImageLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


GcGdiGraphics Class

[image]
ActiveReports 19 .NET Edition
GcGdiGraphics Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace : GcGdiGraphics Class

Glossary Item Box

It is a bridge between GcDoc and GDI+ which allows to draw in viewers. Limitations: doesn't support some pen alignments, smoothing...

Object Model

GcGdiGraphics Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GcGdiGraphics
   Inherits GrapeCity.Documents.Drawing.GcGraphics
C#
public sealed class GcGdiGraphics : GrapeCity.Documents.Drawing.GcGraphics

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.Documents.Drawing.GcGraphics
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi.GcGdiGraphics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Members
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace


GcGdiGraphics Class Members

[image]
ActiveReports 19 .NET Edition
GcGdiGraphics Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace : GcGdiGraphics Class

Glossary Item Box

The following tables list the members exposed by GcGdiGraphics.

Public Constructors

 | Name | Description
Public Constructor | GcGdiGraphics Constructor | Creates new bridge.
Top

Public Properties

 | Name | Description
Public Property | Resolution | Overridden.
Public Property | Transform | Overridden.
Top

See Also

Reference

GcGdiGraphics Class
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace


GcGdiGraphics Constructor

[image]
ActiveReports 19 .NET Edition
GcGdiGraphics Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : GcGdiGraphics Constructor

graphics
fontHinting

Glossary Item Box

Creates new bridge.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graphics As Graphics, _
   ByVal fontHinting As FontHinting _
)
C#
public GcGdiGraphics(
   Graphics graphics,
   FontHinting fontHinting
)

Parameters

graphics
fontHinting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


GcGdiGraphics Class Properties

[image]
ActiveReports 19 .NET Edition
GcGdiGraphics Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace : GcGdiGraphics Class

Glossary Item Box

For a list of all members of this type, see GcGdiGraphics members.

Public Properties

 | Name | Description
Public Property | Resolution | Overridden.
Public Property | Transform | Overridden.
Top

See Also

Reference

GcGdiGraphics Class
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace


Resolution Property

[image]
ActiveReports 19 .NET Edition
Resolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : Resolution Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Resolution As Single
C#
public override float Resolution {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


Transform Property

[image]
ActiveReports 19 .NET Edition
Transform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : Transform Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Transform As Matrix3x2
C#
public override Matrix3x2 Transform {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FontHinting Enumeration

[image]
ActiveReports 19 .NET Edition
FontHinting Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace : FontHinting Enumeration

Glossary Item Box

Specifies the algorithm used for font hinting in text layout.

Syntax

Visual Basic (Declaration)
Public Enum FontHinting
   Inherits System.Enum
C#
public enum FontHinting : System.Enum

Members

Member | Description
Default | Default.
TrueType | WIC-based.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi.FontHinting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace


BorderRenderer Class

[image]
ActiveReports 19 .NET Edition
BorderRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : BorderRenderer Class

Glossary Item Box

Represents the GDI implementation of border rendering.

Object Model

BorderRenderer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class BorderRenderer
C#
public static class BorderRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.BorderRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRenderer Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


BorderRenderer Class Members

[image]
ActiveReports 19 .NET Edition
BorderRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : BorderRenderer Class

Glossary Item Box

The following tables list the members exposed by BorderRenderer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Render | Renders the border around the specified rectangle.
Top

See Also

Reference

BorderRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


BorderRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
BorderRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : BorderRenderer Class

Glossary Item Box

For a list of all members of this type, see BorderRenderer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Render | Renders the border around the specified rectangle.
Top

See Also

Reference

BorderRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Render(Border,Graphics,RectangleF,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Render(Border,Graphics,RectangleF,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > BorderRenderer Class : Render(Border,Graphics,RectangleF,Boolean) Method

border
The border to render.
graphics
The graphics object for drawing a boundary.
bounds
The Border's rectangle in inches.
printing
The printing flag.

Glossary Item Box

Renders the border around the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Shared Sub Render( _
   ByVal border As Border, _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF, _
   Optional ByVal printing As Boolean _
)
C#
public static void Render(
   Border border,
   Graphics graphics,
   RectangleF bounds,
   bool printing
)

Parameters

border
The border to render.
graphics
The graphics object for drawing a boundary.
bounds
The Border's rectangle in inches.
printing
The printing flag.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRenderer Class
BorderRenderer Members


GdiCanvasItemRenderer Class

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiCanvasItemRenderer Class

Glossary Item Box

Represents the GDI canvas item renderer.

Object Model

GdiCanvasItemRenderer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GdiCanvasItemRenderer
   Inherits GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer
   Implements GrapeCity.ActiveReports.Document.Section.ICanvasItemRenderer
C#
public sealed class GdiCanvasItemRenderer : GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer, GrapeCity.ActiveReports.Document.Section.ICanvasItemRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiCanvasItemRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiCanvasItemRenderer Class Members

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiCanvasItemRenderer Class

Glossary Item Box

The following tables list the members exposed by GdiCanvasItemRenderer.

Public Constructors

 | Name | Description
Public Constructor | GdiCanvasItemRenderer Constructor | Initializes an instance of the class GdiCanvasItemRenderer.
Top

Public Fields

 | Name | Description
Public Field | Origin | Gets the origin point.
Top

Public Properties

 | Name | Description
Public Property | Graphics | Gets the graphics.
Public Property | Printing | Determines whether printing is currently in progress.
Top

Public Methods

 | Name | Description
Public Method | Render | Overridden. Renders the canvas item.
Public Method | Reset | Resets the clip region.
Top

See Also

Reference

GdiCanvasItemRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiCanvasItemRenderer Constructor

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : GdiCanvasItemRenderer Constructor

resources
The resources.

Glossary Item Box

Initializes an instance of the class GdiCanvasItemRenderer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resources As Dictionary(Of Integer,IDisposable) _
)
C#
public GdiCanvasItemRenderer(
   Dictionary<int,IDisposable> resources
)

Parameters

resources
The resources.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs if the resources is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


GdiCanvasItemRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiCanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see GdiCanvasItemRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Overridden. Renders the canvas item.
Public Method | Reset | Resets the clip region.
Top

See Also

Reference

GdiCanvasItemRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Render Method

item
The canvas item.

Glossary Item Box

Renders the canvas item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Render( _
   ByVal item As CanvasItem _
)
C#
public override void Render(
   CanvasItem item
)

Parameters

item
The canvas item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


Reset(Region) Method

[image]
ActiveReports 19 .NET Edition
Reset(Region) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Reset(Region) Method

clipRegion
The clip region.

Glossary Item Box

Resets the clip region.

Syntax

Visual Basic (Declaration)
Public Sub Reset( _
   ByVal clipRegion As Region _
)
C#
public void Reset(
   Region clipRegion
)

Parameters

clipRegion
The clip region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


GdiCanvasItemRenderer Class Properties

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiCanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see GdiCanvasItemRenderer members.

Public Properties

 | Name | Description
Public Property | Graphics | Gets the graphics.
Public Property | Printing | Determines whether printing is currently in progress.
Top

See Also

Reference

GdiCanvasItemRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Graphics Property

[image]
ActiveReports 19 .NET Edition
Graphics Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Graphics Property

Glossary Item Box

Gets the graphics.

Syntax

Visual Basic (Declaration)
Public Property Graphics As Graphics
C#
public Graphics Graphics {get; set;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


Printing Property

[image]
ActiveReports 19 .NET Edition
Printing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Printing Property

Glossary Item Box

Determines whether printing is currently in progress.

Syntax

Visual Basic (Declaration)
Public Property Printing As Boolean
C#
public bool Printing {get; set;}

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


GdiCanvasItemRenderer Class Fields

[image]
ActiveReports 19 .NET Edition
GdiCanvasItemRenderer Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiCanvasItemRenderer Class

Glossary Item Box

For a list of all members of this type, see GdiCanvasItemRenderer members.

Public Fields

 | Name | Description
Public Field | Origin | Gets the origin point.
Top

See Also

Reference

GdiCanvasItemRenderer Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Origin Field

[image]
ActiveReports 19 .NET Edition
Origin Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Origin Field

Glossary Item Box

Gets the origin point.

Syntax

Visual Basic (Declaration)
Public Origin As PointF
C#
public PointF Origin

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


GdiImageConverterService Class

[image]
ActiveReports 19 .NET Edition
GdiImageConverterService Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiImageConverterService Class

Glossary Item Box

Service for converting image data to another format through System.Drawing.

Object Model

GdiImageConverterService Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GdiImageConverterService
   Implements GrapeCity.ActiveReports.Core.Document.IImageConverterService
C#
public sealed class GdiImageConverterService : GrapeCity.ActiveReports.Core.Document.IImageConverterService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiImageConverterService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiImageConverterService Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiImageConverterService Class Members

[image]
ActiveReports 19 .NET Edition
GdiImageConverterService Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiImageConverterService Class

Glossary Item Box

The following tables list the members exposed by GdiImageConverterService.

Public Constructors

 | Name | Description
Public Constructor | GdiImageConverterService Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the image converter service.
Top

Public Methods

 | Name | Description
Public Method | Convert | Converts image to one of allowed image format if needed.
Top

See Also

Reference

GdiImageConverterService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiImageConverterService Constructor

[image]
ActiveReports 19 .NET Edition
GdiImageConverterService Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiImageConverterService Class : GdiImageConverterService Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GdiImageConverterService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiImageConverterService Class
GdiImageConverterService Members


GdiImageConverterService Class Methods

[image]
ActiveReports 19 .NET Edition
GdiImageConverterService Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiImageConverterService Class

Glossary Item Box

For a list of all members of this type, see GdiImageConverterService members.

Public Methods

 | Name | Description
Public Method | Convert | Converts image to one of allowed image format if needed.
Top

See Also

Reference

GdiImageConverterService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Convert Method

[image]
ActiveReports 19 .NET Edition
Convert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiImageConverterService Class : Convert Method

imageStream
A stream that contains the image data.
allowedFormats
Allowed image formats. The conversion will not be performed if the image have one of these formats.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Glossary Item Box

Converts image to one of allowed image format if needed.

Syntax

Visual Basic (Declaration)
Public Function Convert( _
   ByVal imageStream As MemoryStream, _
   ByVal allowedFormats() As ImageFormat, _
   ByVal fixRotation As Boolean _
) As ImageData
C#
public ImageData Convert(
   MemoryStream imageStream,
   ImageFormat[] allowedFormats,
   bool fixRotation
)

Parameters

imageStream
A stream that contains the image data.
allowedFormats
Allowed image formats. The conversion will not be performed if the image have one of these formats.
fixRotation
Specifies whether to rotate the image according to the EXIF orientation.

Return Value

The ImageData struct which contains the data stream from which the image can be loaded and the format of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiImageConverterService Class
GdiImageConverterService Members


GdiImageConverterService Class Fields

[image]
ActiveReports 19 .NET Edition
GdiImageConverterService Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiImageConverterService Class

Glossary Item Box

For a list of all members of this type, see GdiImageConverterService members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the image converter service.
Top

See Also

Reference

GdiImageConverterService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiImageConverterService Class : Instance Field

Glossary Item Box

Gets the image converter service.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As IImageConverterService
C#
public static readonly IImageConverterService Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiImageConverterService Class
GdiImageConverterService Members


GdiTextLayoutService Class

[image]
ActiveReports 19 .NET Edition
GdiTextLayoutService Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiTextLayoutService Class

Glossary Item Box

Represents the GDI text layout service.

Object Model

GdiTextLayoutService Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GdiTextLayoutService
   Implements GrapeCity.ActiveReports.Core.Document.ITextLayoutService, GrapeCity.ActiveReports.Core.Document.ITextLineHeightService
C#
public sealed class GdiTextLayoutService : GrapeCity.ActiveReports.Core.Document.ITextLayoutService, GrapeCity.ActiveReports.Core.Document.ITextLineHeightService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiTextLayoutService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiTextLayoutService Class Members

[image]
ActiveReports 19 .NET Edition
GdiTextLayoutService Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiTextLayoutService Class

Glossary Item Box

The following tables list the members exposed by GdiTextLayoutService.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

Public Methods

 | Name | Description
Public Method | GetLineHeight | Calculates line height without line spacing, in inches.
Public Method | Layout |
Public Method | LayoutShrinkToFit |
Public Method | TrimTextLines |
Top

See Also

Reference

GdiTextLayoutService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GdiTextLayoutService Class Methods

[image]
ActiveReports 19 .NET Edition
GdiTextLayoutService Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiTextLayoutService Class

Glossary Item Box

For a list of all members of this type, see GdiTextLayoutService members.

Public Methods

 | Name | Description
Public Method | GetLineHeight | Calculates line height without line spacing, in inches.
Public Method | Layout |
Public Method | LayoutShrinkToFit |
Public Method | TrimTextLines |
Top

See Also

Reference

GdiTextLayoutService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


GetLineHeight Method

[image]
ActiveReports 19 .NET Edition
GetLineHeight Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiTextLayoutService Class : GetLineHeight Method

font
Text font

Glossary Item Box

Calculates line height without line spacing, in inches.

Syntax

Visual Basic (Declaration)
Public Function GetLineHeight( _
   ByVal font As Font _
) As Single
C#
public float GetLineHeight(
   Font font
)

Parameters

font
Text font

Return Value

Line Hight in inches

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Class
GdiTextLayoutService Members


Layout Method

[image]
ActiveReports 19 .NET Edition
Layout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiTextLayoutService Class : Layout Method

text
font
width
descriptor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Layout( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal width As Single, _
   ByVal descriptor As TextLayoutParams _
) As TextLayoutResult
C#
public TextLayoutResult Layout(
   string text,
   Font font,
   float width,
   TextLayoutParams descriptor
)

Parameters

text
font
width
descriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Class
GdiTextLayoutService Members


LayoutShrinkToFit Method

[image]
ActiveReports 19 .NET Edition
LayoutShrinkToFit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiTextLayoutService Class : LayoutShrinkToFit Method

text
font
width
height
descriptor
fontSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LayoutShrinkToFit( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal descriptor As TextLayoutParams, _
   ByRef fontSize As Single _
) As TextLayoutResult
C#
public TextLayoutResult LayoutShrinkToFit(
   string text,
   Font font,
   float width,
   float height,
   TextLayoutParams descriptor,
   out float fontSize
)

Parameters

text
font
width
height
descriptor
fontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Class
GdiTextLayoutService Members


TrimTextLines Method

[image]
ActiveReports 19 .NET Edition
TrimTextLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiTextLayoutService Class : TrimTextLines Method

text
font
width
height
descriptor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function TrimTextLines( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal descriptor As TextLayoutParams _
) As TextLayoutResult
C#
public TextLayoutResult TrimTextLines(
   string text,
   Font font,
   float width,
   float height,
   TextLayoutParams descriptor
)

Parameters

text
font
width
height
descriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Class
GdiTextLayoutService Members


GdiTextLayoutService Class Fields

[image]
ActiveReports 19 .NET Edition
GdiTextLayoutService Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace : GdiTextLayoutService Class

Glossary Item Box

For a list of all members of this type, see GdiTextLayoutService members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

See Also

Reference

GdiTextLayoutService Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiTextLayoutService Class : Instance Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As ITextLayoutService
C#
public static readonly ITextLayoutService Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiTextLayoutService Class
GdiTextLayoutService Members


PaddingExtension Class

[image]
ActiveReports 19 .NET Edition
PaddingExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace : PaddingExtension Class

Glossary Item Box

Represents the extension for padding.

Object Model

PaddingExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PaddingExtension
C#
public static class PaddingExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document.PaddingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingExtension Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace


PaddingExtension Class Members

[image]
ActiveReports 19 .NET Edition
PaddingExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace : PaddingExtension Class

Glossary Item Box

The following tables list the members exposed by PaddingExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToGdiPadding | Converts the default padding to GDI padding.
Top

See Also

Reference

PaddingExtension Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace


PaddingExtension Class Methods

[image]
ActiveReports 19 .NET Edition
PaddingExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace : PaddingExtension Class

Glossary Item Box

For a list of all members of this type, see PaddingExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToGdiPadding | Converts the default padding to GDI padding.
Top

See Also

Reference

PaddingExtension Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace


ToGdiPadding Method

[image]
ActiveReports 19 .NET Edition
ToGdiPadding Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace > PaddingExtension Class : ToGdiPadding Method

padding
The specified padding.

Glossary Item Box

Converts the default padding to GDI padding.

Syntax

Visual Basic (Declaration)
Public Shared Function ToGdiPadding( _
   ByVal padding As PaddingEx _
) As RText.PaddingEx
C#
public static RText.PaddingEx ToGdiPadding(
   PaddingEx padding
)

Parameters

padding
The specified padding.

Return Value

Returns the GDI padding.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingExtension Class
PaddingExtension Members


GraphicsCache Class

[image]
ActiveReports 19 .NET Edition
GraphicsCache Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : GraphicsCache Class

Glossary Item Box

Represents the graphics cache.

Object Model

GraphicsCache Class

Syntax

Visual Basic (Declaration)
Public Class GraphicsCache
C#
public class GraphicsCache

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.GraphicsCache

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


GraphicsCache Class Members

[image]
ActiveReports 19 .NET Edition
GraphicsCache Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : GraphicsCache Class

Glossary Item Box

The following tables list the members exposed by GraphicsCache.

Public Constructors

 | Name | Description
Public Constructor | GraphicsCache Constructor | Initializes a new instance of the GraphicsCache class.
Top

Public Fields

 | Name | Description
Public Field | DpiX | The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.
Public Field | DpiY | The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.
Public Field | Graphics | The Graphics object used to paint.
Public Field | StringFormat | The text layout information.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes this instance.
Top

See Also

Reference

GraphicsCache Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


GraphicsCache Constructor

[image]
ActiveReports 19 .NET Edition
GraphicsCache Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : GraphicsCache Constructor

gRef
The Graphics object used to paint.

Glossary Item Box

Initializes a new instance of the GraphicsCache class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gRef As Graphics _
)
C#
public GraphicsCache(
   Graphics gRef
)

Parameters

gRef
The Graphics object used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


GraphicsCache Class Methods

[image]
ActiveReports 19 .NET Edition
GraphicsCache Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : GraphicsCache Class

Glossary Item Box

For a list of all members of this type, see GraphicsCache members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes this instance.
Top

See Also

Reference

GraphicsCache Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : Dispose Method

Glossary Item Box

Disposes this instance.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


GraphicsCache Class Fields

[image]
ActiveReports 19 .NET Edition
GraphicsCache Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : GraphicsCache Class

Glossary Item Box

For a list of all members of this type, see GraphicsCache members.

Public Fields

 | Name | Description
Public Field | DpiX | The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.
Public Field | DpiY | The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.
Public Field | Graphics | The Graphics object used to paint.
Public Field | StringFormat | The text layout information.
Top

See Also

Reference

GraphicsCache Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


DpiX Field

[image]
ActiveReports 19 .NET Edition
DpiX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : DpiX Field

Glossary Item Box

The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.

Syntax

Visual Basic (Declaration)
Public ReadOnly DpiX As Single
C#
public readonly float DpiX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


DpiY Field

[image]
ActiveReports 19 .NET Edition
DpiY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : DpiY Field

Glossary Item Box

The values, in dots per inch, for the horizontal and vertical resolution supported by Graphics.

Syntax

Visual Basic (Declaration)
Public ReadOnly DpiY As Single
C#
public readonly float DpiY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


Graphics Field

[image]
ActiveReports 19 .NET Edition
Graphics Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : Graphics Field

Glossary Item Box

The Graphics object used to paint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Graphics As Graphics
C#
public readonly Graphics Graphics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


StringFormat Field

[image]
ActiveReports 19 .NET Edition
StringFormat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > GraphicsCache Class : StringFormat Field

Glossary Item Box

The text layout information.

Syntax

Visual Basic (Declaration)
Public ReadOnly StringFormat As StringFormat
C#
public readonly StringFormat StringFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsCache Class
GraphicsCache Members


RText Class

[image]
ActiveReports 19 .NET Edition
RText Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText Class

Glossary Item Box

GDI/GDI+ based text renderer. Limitations: - Right to left word ordering for BIDI not supported, but right to left text is. - Tab characters are ignored unless alignment=left. ShrinkToFit algorithm part

Object Model

RText Class

Syntax

Visual Basic (Declaration)
Public Class RText
C#
public class RText

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText Class Members

[image]
ActiveReports 19 .NET Edition
RText Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText Class

Glossary Item Box

The following tables list the members exposed by RText.

Public Constructors

 | Name | Description
Public Constructor | RText Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | m_bFormatted | True if formatted
Public Field | m_outputSize | The output size
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment.
Public Property | BackColor | Gets or sets the color of the back.
Public Property | CharacterSpacing | Determines the distance beetween two characters in the string. Applied only when UseCharacterSpacing is true.
Public Property | Font | Gets or sets the font.
Public Property | FontIndex | Gets or sets the index of the font.
Public Property | Kinsoku | Gets or sets a value indicating whether this RText is kinsoku.
Public Property | LineSpacing | Determines the spacing in inches between text lines
Public Property | MultiLine | Gets or sets a value indicating whether [multi line].
Public Property | Padding | Gets or sets the padding.
Public Property | Printing | Gets or sets a value indicating whether this RText is printing.
Public Property | RightToLeft | Gets or sets a value indicating whether [right to left].
Public Property | Selection | Gets or sets the selection.
Public Property | Text | Gets or sets the text.
Public Property | TextAngle | Gets or sets the text angle.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | VertAlignment | Gets or sets the vert alignment.
Public Property | VerticalText | Gets or sets a value indicating whether [vertical text].
Public Property | WrapMode | Gets or sets the wrap mode.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalcRectRotation | Calculates the rect rotation.
Public Method | ClearRuns | Clears the runs.
Public Method | FormatText | Overloaded. FormatText Uses textruns to go through m_text and creates LineDesc
Public Method | FormatTextAndTrim |
Public Method | FormatTextShrinkToFit | Overloaded. FormatText and returns updated font. Uses textruns to go through m_text and creates LineDesc with ShrinkToFit algorithm
Public Method | GetBlocks | Gets the blocks.
Public Method | GetLastLinesIndexes | Returns indexes of last paragraphs lines. Used to define lines which should not be justified.
Public Method | GetLines | Gets the lines.
Public Method | GetLogicalLines | Returns an array of lines that are "logically" together. GetLines() splits the entire text based on width. GetLines() >= GetLogicalLines()
Public Method | GetParagraphSize | Gets the size of the paragraph.
Public Method | IsLastLineInParagraph | Returns true is the line at index "line" is the lasst line in the paragraph. Done only for justified alignment and lineCount > 1
static (Shared in Visual Basic) | NormalizeLineFeeds | Normalizes line-feed characters to unified presentation with \n as line delimiter
Public Method | Render | Renders Lines and pieces that contains text only. This method is used to render Label, Textbox, CheckBox, RichtextBox at run time. Label, Textbox, CheckBox, at design time.
Public Method | RenderWithGraphics | Renders text
Public Method | SetSelectionColors | Sets selection painting colors
Top

See Also

Reference

RText Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText Constructor

[image]
ActiveReports 19 .NET Edition
RText Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : RText Constructor

Glossary Item Box

Overload List

Overload | Description
RText Constructor(String,Font,Color) | Initializes a new instance of the RText class.
RText Constructor(String,Font,Color,IEnumerable<TabStop>) | Initializes a new instance of the RText class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RText Constructor(String,Font,Color)

[image]
ActiveReports 19 .NET Edition
RText Constructor(String,Font,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > RText Constructor : RText Constructor(String,Font,Color)

text
The text.
font
The font.
textColor
Color of the text.

Glossary Item Box

Initializes a new instance of the RText class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal textColor As Color _
)
C#
public RText(
   string text,
   Font font,
   Color textColor
)

Parameters

text
The text.
font
The font.
textColor
Color of the text.

Exceptions

Exception | Description
System.ArgumentNullException | text or font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


RText Constructor(String,Font,Color,IEnumerable<TabStop>)

[image]
ActiveReports 19 .NET Edition
RText Constructor(String,Font,Color,IEnumerable<TabStop>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > RText Constructor : RText Constructor(String,Font,Color,IEnumerable<TabStop>)

text
The text.
font
The font.
textColor
Color of the text.
tabStops
The tab stops.

Glossary Item Box

Initializes a new instance of the RText class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal textColor As Color, _
   ByVal tabStops As IEnumerable(Of RText.TabStop) _
)
C#
public RText(
   string text,
   Font font,
   Color textColor,
   IEnumerable<RText.TabStop> tabStops
)

Parameters

text
The text.
font
The font.
textColor
Color of the text.
tabStops
The tab stops.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


RText Class Methods

[image]
ActiveReports 19 .NET Edition
RText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText Class

Glossary Item Box

For a list of all members of this type, see RText members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalcRectRotation | Calculates the rect rotation.
Public Method | ClearRuns | Clears the runs.
Public Method | FormatText | Overloaded. FormatText Uses textruns to go through m_text and creates LineDesc
Public Method | FormatTextAndTrim |
Public Method | FormatTextShrinkToFit | Overloaded. FormatText and returns updated font. Uses textruns to go through m_text and creates LineDesc with ShrinkToFit algorithm
Public Method | GetBlocks | Gets the blocks.
Public Method | GetLastLinesIndexes | Returns indexes of last paragraphs lines. Used to define lines which should not be justified.
Public Method | GetLines | Gets the lines.
Public Method | GetLogicalLines | Returns an array of lines that are "logically" together. GetLines() splits the entire text based on width. GetLines() >= GetLogicalLines()
Public Method | GetParagraphSize | Gets the size of the paragraph.
Public Method | IsLastLineInParagraph | Returns true is the line at index "line" is the lasst line in the paragraph. Done only for justified alignment and lineCount > 1
static (Shared in Visual Basic) | NormalizeLineFeeds | Normalizes line-feed characters to unified presentation with \n as line delimiter
Public Method | Render | Renders Lines and pieces that contains text only. This method is used to render Label, Textbox, CheckBox, RichtextBox at run time. Label, Textbox, CheckBox, at design time.
Public Method | RenderWithGraphics | Renders text
Public Method | SetSelectionColors | Sets selection painting colors
Top

See Also

Reference

RText Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


CalcRectRotation Method

[image]
ActiveReports 19 .NET Edition
CalcRectRotation Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : CalcRectRotation Method

width
The width.
height
The height.
angle
The angle.
leftMostX
The left most x.
topMostY
The top most y.
dx
The dx.
dy
The dy.

Glossary Item Box

Calculates the rect rotation.

Syntax

Visual Basic (Declaration)
Public Shared Sub CalcRectRotation( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal angle As Single, _
   ByRef leftMostX As Single, _
   ByRef topMostY As Single, _
   ByRef dx As Single, _
   ByRef dy As Single _
)
C#
public static void CalcRectRotation(
   float width,
   float height,
   float angle,
   out float leftMostX,
   out float topMostY,
   out float dx,
   out float dy
)

Parameters

width
The width.
height
The height.
angle
The angle.
leftMostX
The left most x.
topMostY
The top most y.
dx
The dx.
dy
The dy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


ClearRuns Method

[image]
ActiveReports 19 .NET Edition
ClearRuns Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : ClearRuns Method

Glossary Item Box

Clears the runs.

Syntax

Visual Basic (Declaration)
Public Sub ClearRuns()
C#
public void ClearRuns()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


FormatText Method

[image]
ActiveReports 19 .NET Edition
FormatText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : FormatText Method

Glossary Item Box

FormatText Uses textruns to go through m_text and creates LineDesc

Overload List

Overload | Description
FormatText(GraphicsCache,Single) | FormatText Uses textruns to go through m_text and creates LineDesc
FormatText(GraphicsCache,RectangleF,RectangleF) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


FormatText(GraphicsCache,Single) Method

[image]
ActiveReports 19 .NET Edition
FormatText(GraphicsCache,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > FormatText Method : FormatText(GraphicsCache,Single) Method

cache
docWidth

Glossary Item Box

FormatText Uses textruns to go through m_text and creates LineDesc

Syntax

Visual Basic (Declaration)
Public Overloads Sub FormatText( _
   ByVal cache As GraphicsCache, _
   ByVal docWidth As Single _
)
C#
public void FormatText(
   GraphicsCache cache,
   float docWidth
)

Parameters

cache
docWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


FormatText(GraphicsCache,RectangleF,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
FormatText(GraphicsCache,RectangleF,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > FormatText Method : FormatText(GraphicsCache,RectangleF,RectangleF) Method

cache
outRect
outRectDev

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub FormatText( _
   ByVal cache As GraphicsCache, _
   ByVal outRect As RectangleF, _
   ByRef outRectDev As RectangleF _
)
C#
public virtual void FormatText(
   GraphicsCache cache,
   RectangleF outRect,
   ref RectangleF outRectDev
)

Parameters

cache
outRect
outRectDev

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


FormatTextAndTrim(GraphicsCache,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
FormatTextAndTrim(GraphicsCache,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : FormatTextAndTrim(GraphicsCache,Single,Single) Method

cache
trimWidth
trimHeight

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FormatTextAndTrim( _
   ByVal cache As GraphicsCache, _
   ByVal trimWidth As Single, _
   ByVal trimHeight As Single _
)
C#
public void FormatTextAndTrim(
   GraphicsCache cache,
   float trimWidth,
   float trimHeight
)

Parameters

cache
trimWidth
trimHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


FormatTextShrinkToFit Method

[image]
ActiveReports 19 .NET Edition
FormatTextShrinkToFit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : FormatTextShrinkToFit Method

Glossary Item Box

FormatText and returns updated font. Uses textruns to go through m_text and creates LineDesc with ShrinkToFit algorithm

Overload List

Overload | Description
FormatTextShrinkToFit(GraphicsCache,Font,Single,Single) | FormatText and returns updated font. Uses textruns to go through m_text and creates LineDesc with ShrinkToFit algorithm
FormatTextShrinkToFit(GraphicsCache,Font,Single,Single,Boolean) | Formats the text shrink to fit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


FormatTextShrinkToFit(GraphicsCache,Font,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
FormatTextShrinkToFit(GraphicsCache,Font,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > FormatTextShrinkToFit Method : FormatTextShrinkToFit(GraphicsCache,Font,Single,Single) Method

cache
initialFont
docWidth
docHeight

Glossary Item Box

FormatText and returns updated font. Uses textruns to go through m_text and creates LineDesc with ShrinkToFit algorithm

Syntax

Visual Basic (Declaration)
Public Overloads Function FormatTextShrinkToFit( _
   ByVal cache As GraphicsCache, _
   ByVal initialFont As Font, _
   ByVal docWidth As Single, _
   ByVal docHeight As Single _
) As Font
C#
public Font FormatTextShrinkToFit(
   GraphicsCache cache,
   Font initialFont,
   float docWidth,
   float docHeight
)

Parameters

cache
initialFont
docWidth
docHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


FormatTextShrinkToFit(GraphicsCache,Font,Single,Single,Boolean) Method

[image]
ActiveReports 19 .NET Edition
FormatTextShrinkToFit(GraphicsCache,Font,Single,Single,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class > FormatTextShrinkToFit Method : FormatTextShrinkToFit(GraphicsCache,Font,Single,Single,Boolean) Method

cache
The cache.
initialFont
The initial font.
docWidth
Width of the document.
docHeight
Height of the document.
needSubtractPadding
if set to true [need subtract padding].

Glossary Item Box

Formats the text shrink to fit.

Syntax

Visual Basic (Declaration)
Public Overloads Function FormatTextShrinkToFit( _
   ByVal cache As GraphicsCache, _
   ByVal initialFont As Font, _
   ByVal docWidth As Single, _
   ByVal docHeight As Single, _
   ByVal needSubtractPadding As Boolean _
) As Font
C#
public Font FormatTextShrinkToFit(
   GraphicsCache cache,
   Font initialFont,
   float docWidth,
   float docHeight,
   bool needSubtractPadding
)

Parameters

cache
The cache.
initialFont
The initial font.
docWidth
Width of the document.
docHeight
Height of the document.
needSubtractPadding
if set to true [need subtract padding].

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members
Overload List


GetBlocks Method

[image]
ActiveReports 19 .NET Edition
GetBlocks Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : GetBlocks Method

Glossary Item Box

Gets the blocks.

Syntax

Visual Basic (Declaration)
Public Function GetBlocks() As IEnumerable(Of RText.Line)
C#
public IEnumerable<RText.Line> GetBlocks()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


GetLastLinesIndexes Method

[image]
ActiveReports 19 .NET Edition
GetLastLinesIndexes Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : GetLastLinesIndexes Method

Glossary Item Box

Returns indexes of last paragraphs lines. Used to define lines which should not be justified.

Syntax

Visual Basic (Declaration)
Public Function GetLastLinesIndexes() As IEnumerable(Of Integer)
C#
public IEnumerable<int> GetLastLinesIndexes()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


GetLines Method

[image]
ActiveReports 19 .NET Edition
GetLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : GetLines Method

Glossary Item Box

Gets the lines.

Syntax

Visual Basic (Declaration)
Public Function GetLines() As String()
C#
public string[] GetLines()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


GetLogicalLines Method

[image]
ActiveReports 19 .NET Edition
GetLogicalLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : GetLogicalLines Method

clipLineCutoff
line number cut off(iteration starts from this line)

Glossary Item Box

Returns an array of lines that are "logically" together. GetLines() splits the entire text based on width. GetLines() >= GetLogicalLines()

Syntax

Visual Basic (Declaration)
Public Function GetLogicalLines( _
   ByVal clipLineCutoff As Integer _
) As String()
C#
public string[] GetLogicalLines(
   int clipLineCutoff
)

Parameters

clipLineCutoff
line number cut off(iteration starts from this line)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


GetParagraphSize Method

[image]
ActiveReports 19 .NET Edition
GetParagraphSize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : GetParagraphSize Method

cache
The cache.
width
The width.

Glossary Item Box

Gets the size of the paragraph.

Syntax

Visual Basic (Declaration)
Public Function GetParagraphSize( _
   ByVal cache As GraphicsCache, _
   ByVal width As Single _
) As SizeF
C#
public SizeF GetParagraphSize(
   GraphicsCache cache,
   float width
)

Parameters

cache
The cache.
width
The width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


IsLastLineInParagraph Method

[image]
ActiveReports 19 .NET Edition
IsLastLineInParagraph Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : IsLastLineInParagraph Method

line
CurrentLine index that is being processed

Glossary Item Box

Returns true is the line at index "line" is the lasst line in the paragraph. Done only for justified alignment and lineCount > 1

Syntax

Visual Basic (Declaration)
Public Function IsLastLineInParagraph( _
   ByVal line As Integer _
) As Boolean
C#
public bool IsLastLineInParagraph(
   int line
)

Parameters

line
CurrentLine index that is being processed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


NormalizeLineFeeds Method

[image]
ActiveReports 19 .NET Edition
NormalizeLineFeeds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : NormalizeLineFeeds Method

inputString

Glossary Item Box

Normalizes line-feed characters to unified presentation with \n as line delimiter

Syntax

Visual Basic (Declaration)
Public Shared Function NormalizeLineFeeds( _
   ByVal inputString As String _
) As String
C#
public static string NormalizeLineFeeds(
   string inputString
)

Parameters

inputString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Render Method

cache
Cache that contains the graphics object used to render.
outRect
rectangle that the text has to be rendered on the canvas or design surface.

Glossary Item Box

Renders Lines and pieces that contains text only. This method is used to render Label, Textbox, CheckBox, RichtextBox at run time. Label, Textbox, CheckBox, at design time.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal cache As GraphicsCache, _
   ByVal outRect As RectangleF _
)
C#
public void Render(
   GraphicsCache cache,
   RectangleF outRect
)

Parameters

cache
Cache that contains the graphics object used to render.
outRect
rectangle that the text has to be rendered on the canvas or design surface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RenderWithGraphics Method

[image]
ActiveReports 19 .NET Edition
RenderWithGraphics Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : RenderWithGraphics Method

g
rect
rectangle that the text has to be rendered on the canvas or design surface.

Glossary Item Box

Renders text

Syntax

Visual Basic (Declaration)
Public Sub RenderWithGraphics( _
   ByVal g As Graphics, _
   ByVal rect As RectangleF _
)
C#
public void RenderWithGraphics(
   Graphics g,
   RectangleF rect
)

Parameters

g
rect
rectangle that the text has to be rendered on the canvas or design surface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


SetSelectionColors Method

[image]
ActiveReports 19 .NET Edition
SetSelectionColors Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : SetSelectionColors Method

backColor
foreColor

Glossary Item Box

Sets selection painting colors

Syntax

Visual Basic (Declaration)
Public Sub SetSelectionColors( _
   ByVal backColor As Color, _
   ByVal foreColor As Color _
)
C#
public void SetSelectionColors(
   Color backColor,
   Color foreColor
)

Parameters

backColor
foreColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RText Class Properties

[image]
ActiveReports 19 .NET Edition
RText Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText Class

Glossary Item Box

For a list of all members of this type, see RText members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment.
Public Property | BackColor | Gets or sets the color of the back.
Public Property | CharacterSpacing | Determines the distance beetween two characters in the string. Applied only when UseCharacterSpacing is true.
Public Property | Font | Gets or sets the font.
Public Property | FontIndex | Gets or sets the index of the font.
Public Property | Kinsoku | Gets or sets a value indicating whether this RText is kinsoku.
Public Property | LineSpacing | Determines the spacing in inches between text lines
Public Property | MultiLine | Gets or sets a value indicating whether [multi line].
Public Property | Padding | Gets or sets the padding.
Public Property | Printing | Gets or sets a value indicating whether this RText is printing.
Public Property | RightToLeft | Gets or sets a value indicating whether [right to left].
Public Property | Selection | Gets or sets the selection.
Public Property | Text | Gets or sets the text.
Public Property | TextAngle | Gets or sets the text angle.
Public Property | TextColor | Gets or sets the color of the text.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | VertAlignment | Gets or sets the vert alignment.
Public Property | VerticalText | Gets or sets a value indicating whether [vertical text].
Public Property | WrapMode | Gets or sets the wrap mode.
Top

See Also

Reference

RText Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Alignment Property

Glossary Item Box

Gets or sets the alignment.

Syntax

Visual Basic (Declaration)
Public Property Alignment As TextAlignment
C#
public TextAlignment Alignment {get; set;}

Property Value

The alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


BackColor Property

[image]
ActiveReports 19 .NET Edition
BackColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : BackColor Property

Glossary Item Box

Gets or sets the color of the back.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

The color of the back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : CharacterSpacing Property

Glossary Item Box

Determines the distance beetween two characters in the string. Applied only when UseCharacterSpacing is true.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Font Property

Glossary Item Box

Gets or sets the font.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


FontIndex Property

[image]
ActiveReports 19 .NET Edition
FontIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : FontIndex Property

Glossary Item Box

Gets or sets the index of the font.

Syntax

Visual Basic (Declaration)
Public Property FontIndex As Integer
C#
public int FontIndex {get; set;}

Property Value

The index of the font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Kinsoku Property

[image]
ActiveReports 19 .NET Edition
Kinsoku Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Kinsoku Property

Glossary Item Box

Gets or sets a value indicating whether this RText is kinsoku.

Syntax

Visual Basic (Declaration)
Public Property Kinsoku As Boolean
C#
public bool Kinsoku {get; set;}

Property Value

true if kinsoku; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : LineSpacing Property

Glossary Item Box

Determines the spacing in inches between text lines

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


MultiLine Property

[image]
ActiveReports 19 .NET Edition
MultiLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether [multi line].

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Property Value

true if [multi line]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Padding Property

[image]
ActiveReports 19 .NET Edition
Padding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Padding Property

Glossary Item Box

Gets or sets the padding.

Syntax

Visual Basic (Declaration)
Public Property Padding As RText.PaddingEx
C#
public RText.PaddingEx Padding {get; set;}

Property Value

The padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Printing Property

[image]
ActiveReports 19 .NET Edition
Printing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Printing Property

Glossary Item Box

Gets or sets a value indicating whether this RText is printing.

Syntax

Visual Basic (Declaration)
Public Property Printing As Boolean
C#
public bool Printing {get; set;}

Property Value

true if printing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RightToLeft Property

[image]
ActiveReports 19 .NET Edition
RightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether [right to left].

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Property Value

true if [right to left]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Selection Property

[image]
ActiveReports 19 .NET Edition
Selection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Selection Property

Glossary Item Box

Gets or sets the selection.

Syntax

Visual Basic (Declaration)
Public Property Selection As RText.SelectionRange
C#
public RText.SelectionRange Selection {get; set;}

Property Value

The selection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : Text Property

Glossary Item Box

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


TextAngle Property

[image]
ActiveReports 19 .NET Edition
TextAngle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : TextAngle Property

Glossary Item Box

Gets or sets the text angle.

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Single
C#
public float TextAngle {get; set;}

Property Value

The text angle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


TextColor Property

[image]
ActiveReports 19 .NET Edition
TextColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : TextColor Property

Glossary Item Box

Gets or sets the color of the text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Property Value

The color of the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : TextJustify Property

Glossary Item Box

Gets or sets the text justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Property Value

The text justify.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


VertAlignment Property

[image]
ActiveReports 19 .NET Edition
VertAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : VertAlignment Property

Glossary Item Box

Gets or sets the vert alignment.

Syntax

Visual Basic (Declaration)
Public Property VertAlignment As VerticalTextAlignment
C#
public VerticalTextAlignment VertAlignment {get; set;}

Property Value

The vert alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


VerticalText Property

[image]
ActiveReports 19 .NET Edition
VerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : VerticalText Property

Glossary Item Box

Gets or sets a value indicating whether [vertical text].

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Property Value

true if [vertical text]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : WrapMode Property

Glossary Item Box

Gets or sets the wrap mode.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Property Value

The wrap mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RText Class Fields

[image]
ActiveReports 19 .NET Edition
RText Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText Class

Glossary Item Box

For a list of all members of this type, see RText members.

Public Fields

 | Name | Description
Public Field | m_bFormatted | True if formatted
Public Field | m_outputSize | The output size
Top

See Also

Reference

RText Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


m_bFormatted Field

[image]
ActiveReports 19 .NET Edition
m_bFormatted Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : m_bFormatted Field

Glossary Item Box

True if formatted

Syntax

Visual Basic (Declaration)
Public m_bFormatted As Boolean
C#
public bool m_bFormatted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


m_outputSize Field

[image]
ActiveReports 19 .NET Edition
m_outputSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : m_outputSize Field

Glossary Item Box

The output size

Syntax

Visual Basic (Declaration)
Public m_outputSize As SizeF
C#
public SizeF m_outputSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


RText.Line Class

[image]
ActiveReports 19 .NET Edition
RText.Line Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.Line Class

Glossary Item Box

Represents the line.

Object Model

RText.Line Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RText.Line
C#
public sealed class RText.Line

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.Line Class Members

[image]
ActiveReports 19 .NET Edition
RText.Line Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.Line Class

Glossary Item Box

The following tables list the members exposed by RText.Line.

Public Constructors

 | Name | Description
Public Constructor | RText.Line Constructor |
Top

Public Fields

 | Name | Description
Public Field | _contentWidth | The content width.
Public Field | _lineHeight | The line height.
Public Field | IsParaStart | True if parastart.
Top

Public Properties

 | Name | Description
Public Property | Pieces | Gets the pieces.
Public Property | Selection | Gets line's selected area.
Public Property | TextOffset | Gets the text offset.
Top

Public Methods

 | Name | Description
Public Method | AddPiece | Adds the piece.
Public Method | GetPiece | Gets the piece by index.
Public Method | GetPieceCount | Gets the number of pieces.
Public Method | GetText | Gets the text.
Top

See Also

Reference

RText.Line Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.Line Constructor

[image]
ActiveReports 19 .NET Edition
RText.Line Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : RText.Line Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RText.Line()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


RText.Line Class Methods

[image]
ActiveReports 19 .NET Edition
RText.Line Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.Line Class

Glossary Item Box

For a list of all members of this type, see RText.Line members.

Public Methods

 | Name | Description
Public Method | AddPiece | Adds the piece.
Public Method | GetPiece | Gets the piece by index.
Public Method | GetPieceCount | Gets the number of pieces.
Public Method | GetText | Gets the text.
Top

See Also

Reference

RText.Line Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


AddPiece Method

[image]
ActiveReports 19 .NET Edition
AddPiece Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : AddPiece Method

piece
The piece.

Glossary Item Box

Adds the piece.

Syntax

Visual Basic (Declaration)
Public Sub AddPiece( _
   ByVal piece As RText.LinePiece _
)
C#
public void AddPiece(
   RText.LinePiece piece
)

Parameters

piece
The piece.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


GetPiece Method

[image]
ActiveReports 19 .NET Edition
GetPiece Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : GetPiece Method

index
The index.

Glossary Item Box

Gets the piece by index.

Syntax

Visual Basic (Declaration)
Public Function GetPiece( _
   ByVal index As Integer _
) As RText.LinePiece
C#
public RText.LinePiece GetPiece(
   int index
)

Parameters

index
The index.

Return Value

Returns the specified piece.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


GetPieceCount Method

[image]
ActiveReports 19 .NET Edition
GetPieceCount Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : GetPieceCount Method

Glossary Item Box

Gets the number of pieces.

Syntax

Visual Basic (Declaration)
Public Function GetPieceCount() As Integer
C#
public int GetPieceCount()

Return Value

Returns the number of pieces.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


GetText Method

[image]
ActiveReports 19 .NET Edition
GetText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : GetText Method

Glossary Item Box

Gets the text.

Syntax

Visual Basic (Declaration)
Public Function GetText() As String
C#
public string GetText()

Return Value

Returns the string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


RText.Line Class Properties

[image]
ActiveReports 19 .NET Edition
RText.Line Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.Line Class

Glossary Item Box

For a list of all members of this type, see RText.Line members.

Public Properties

 | Name | Description
Public Property | Pieces | Gets the pieces.
Public Property | Selection | Gets line's selected area.
Public Property | TextOffset | Gets the text offset.
Top

See Also

Reference

RText.Line Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Pieces Property

[image]
ActiveReports 19 .NET Edition
Pieces Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : Pieces Property

Glossary Item Box

Gets the pieces.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pieces As IEnumerable(Of RText.LinePiece)
C#
public IEnumerable<RText.LinePiece> Pieces {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


Selection Property

[image]
ActiveReports 19 .NET Edition
Selection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : Selection Property

Glossary Item Box

Gets line's selected area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selection As RText.SelectionRange
C#
public RText.SelectionRange Selection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


TextOffset Property

[image]
ActiveReports 19 .NET Edition
TextOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : TextOffset Property

Glossary Item Box

Gets the text offset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextOffset As Integer
C#
public int TextOffset {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


RText.Line Class Fields

[image]
ActiveReports 19 .NET Edition
RText.Line Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.Line Class

Glossary Item Box

For a list of all members of this type, see RText.Line members.

Public Fields

 | Name | Description
Public Field | _contentWidth | The content width.
Public Field | _lineHeight | The line height.
Public Field | IsParaStart | True if parastart.
Top

See Also

Reference

RText.Line Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


_contentWidth Field

[image]
ActiveReports 19 .NET Edition
_contentWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : _contentWidth Field

Glossary Item Box

The content width.

Syntax

Visual Basic (Declaration)
Public _contentWidth As Single
C#
public float _contentWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


_lineHeight Field

[image]
ActiveReports 19 .NET Edition
_lineHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : _lineHeight Field

Glossary Item Box

The line height.

Syntax

Visual Basic (Declaration)
Public _lineHeight As Single
C#
public float _lineHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


IsParaStart Field

[image]
ActiveReports 19 .NET Edition
IsParaStart Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.Line Class : IsParaStart Field

Glossary Item Box

True if parastart.

Syntax

Visual Basic (Declaration)
Public IsParaStart As Boolean
C#
public bool IsParaStart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.Line Class
RText.Line Members


RText.LinePiece Class

[image]
ActiveReports 19 .NET Edition
RText.LinePiece Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.LinePiece Class

Glossary Item Box

Represents the line piece.

Object Model

RText.LinePiece Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class RText.LinePiece
C#
public abstract class RText.LinePiece

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.LinePiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabPiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TextPiece

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.LinePiece Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.LinePiece Class Members

[image]
ActiveReports 19 .NET Edition
RText.LinePiece Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.LinePiece Class

Glossary Item Box

The following tables list the members exposed by RText.LinePiece.

Public Fields

 | Name | Description
Public Field | Text | The text.
Public Field | X | The X coordinate.
Top

See Also

Reference

RText.LinePiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.LinePiece Class Fields

[image]
ActiveReports 19 .NET Edition
RText.LinePiece Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.LinePiece Class

Glossary Item Box

For a list of all members of this type, see RText.LinePiece members.

Public Fields

 | Name | Description
Public Field | Text | The text.
Public Field | X | The X coordinate.
Top

See Also

Reference

RText.LinePiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Text Field

[image]
ActiveReports 19 .NET Edition
Text Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.LinePiece Class : Text Field

Glossary Item Box

The text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Text As String
C#
public readonly string Text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.LinePiece Class
RText.LinePiece Members


X Field

[image]
ActiveReports 19 .NET Edition
X Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.LinePiece Class : X Field

Glossary Item Box

The X coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly X As Single
C#
public readonly float X

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.LinePiece Class
RText.LinePiece Members


RText.TabPiece Class

[image]
ActiveReports 19 .NET Edition
RText.TabPiece Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabPiece Class

Glossary Item Box

Represents the tab piece.

Object Model

RText.TabPiece Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RText.TabPiece
   Inherits RText.LinePiece
C#
public sealed class RText.TabPiece : RText.LinePiece

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.LinePiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabPiece

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabPiece Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TabPiece Class Members

[image]
ActiveReports 19 .NET Edition
RText.TabPiece Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabPiece Class

Glossary Item Box

The following tables list the members exposed by RText.TabPiece.

Public Constructors

 | Name | Description
Public Constructor | RText.TabPiece Constructor | Initializes a new instance of the RText.TabPiece class.
Top

Public Fields

 | Name | Description
Public Field | Anchor | The anchor.
Public Field | Tab | The tab.
Top

Public Properties

 | Name | Description
Public Property | Width | Gets the width.
Top

See Also

Reference

RText.TabPiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TabPiece Constructor

[image]
ActiveReports 19 .NET Edition
RText.TabPiece Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabPiece Class : RText.TabPiece Constructor

x
The X coodinate.
anchor
The anchor.
tab
The tab.

Glossary Item Box

Initializes a new instance of the RText.TabPiece class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal anchor As Single, _
   ByVal tab As RText.TabStop _
)
C#
public RText.TabPiece(
   float x,
   float anchor,
   RText.TabStop tab
)

Parameters

x
The X coodinate.
anchor
The anchor.
tab
The tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabPiece Class
RText.TabPiece Members


RText.TabPiece Class Properties

[image]
ActiveReports 19 .NET Edition
RText.TabPiece Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabPiece Class

Glossary Item Box

For a list of all members of this type, see RText.TabPiece members.

Public Properties

 | Name | Description
Public Property | Width | Gets the width.
Top

See Also

Reference

RText.TabPiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabPiece Class : Width Property

Glossary Item Box

Gets the width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Single
C#
public float Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabPiece Class
RText.TabPiece Members


RText.TabPiece Class Fields

[image]
ActiveReports 19 .NET Edition
RText.TabPiece Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabPiece Class

Glossary Item Box

For a list of all members of this type, see RText.TabPiece members.

Public Fields

 | Name | Description
Public Field | Anchor | The anchor.
Public Field | Tab | The tab.
Top

See Also

Reference

RText.TabPiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Anchor Field

[image]
ActiveReports 19 .NET Edition
Anchor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabPiece Class : Anchor Field

Glossary Item Box

The anchor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Anchor As Single
C#
public readonly float Anchor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabPiece Class
RText.TabPiece Members


Tab Field

[image]
ActiveReports 19 .NET Edition
Tab Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabPiece Class : Tab Field

Glossary Item Box

The tab.

Syntax

Visual Basic (Declaration)
Public ReadOnly Tab As RText.TabStop
C#
public readonly RText.TabStop Tab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabPiece Class
RText.TabPiece Members


RText.TabStop Class

[image]
ActiveReports 19 .NET Edition
RText.TabStop Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabStop Class

Glossary Item Box

Represents the custom tab stop.

Object Model

RText.TabStop Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RText.TabStop
C#
public sealed class RText.TabStop

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabStop

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TabStop Class Members

[image]
ActiveReports 19 .NET Edition
RText.TabStop Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabStop Class

Glossary Item Box

The following tables list the members exposed by RText.TabStop.

Public Constructors

 | Name | Description
Public Constructor | RText.TabStop Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position (in inches) of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top

See Also

Reference

RText.TabStop Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TabStop Constructor

[image]
ActiveReports 19 .NET Edition
RText.TabStop Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class : RText.TabStop Constructor

Glossary Item Box

Overload List

Overload | Description
RText.TabStop Constructor(Single,TabType) | Initializes a new instance of the RText.TabStop class.
RText.TabStop Constructor(Single,TabType,String) | Initializes a new instance of the RText.TabStop class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members


RText.TabStop Constructor(Single,TabType)

[image]
ActiveReports 19 .NET Edition
RText.TabStop Constructor(Single,TabType)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class > RText.TabStop Constructor : RText.TabStop Constructor(Single,TabType)

position
The position.
type
The type.

Glossary Item Box

Initializes a new instance of the RText.TabStop class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Single, _
   ByVal type As RText.TabType _
)
C#
public RText.TabStop(
   float position,
   RText.TabType type
)

Parameters

position
The position.
type
The type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members
Overload List


RText.TabStop Constructor(Single,TabType,String)

[image]
ActiveReports 19 .NET Edition
RText.TabStop Constructor(Single,TabType,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class > RText.TabStop Constructor : RText.TabStop Constructor(Single,TabType,String)

position
The position.
type
The type.
leadingChar
The leading character.

Glossary Item Box

Initializes a new instance of the RText.TabStop class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Single, _
   ByVal type As RText.TabType, _
   ByVal leadingChar As String _
)
C#
public RText.TabStop(
   float position,
   RText.TabType type,
   string leadingChar
)

Parameters

position
The position.
type
The type.
leadingChar
The leading character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members
Overload List


RText.TabStop Class Properties

[image]
ActiveReports 19 .NET Edition
RText.TabStop Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabStop Class

Glossary Item Box

For a list of all members of this type, see RText.TabStop members.

Public Properties

 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position (in inches) of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top

See Also

Reference

RText.TabStop Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class : LeadingChar Property

Glossary Item Box

Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeadingChar As String
C#
public string LeadingChar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class : Position Property

Glossary Item Box

Specifies the position (in inches) of the current tab stop.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Single
C#
public float Position {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TabStop Class : Type Property

Glossary Item Box

Specifies the type of tab stop.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As RText.TabType
C#
public RText.TabType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TabStop Class
RText.TabStop Members


RText.TextPiece Class

[image]
ActiveReports 19 .NET Edition
RText.TextPiece Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TextPiece Class

Glossary Item Box

Represents the text piece.

Object Model

RText.TextPiece Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RText.TextPiece
   Inherits RText.LinePiece
C#
public sealed class RText.TextPiece : RText.LinePiece

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.LinePiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TextPiece

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TextPiece Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TextPiece Class Members

[image]
ActiveReports 19 .NET Edition
RText.TextPiece Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TextPiece Class

Glossary Item Box

The following tables list the members exposed by RText.TextPiece.

Public Constructors

 | Name | Description
Public Constructor | RText.TextPiece Constructor | Initializes a new instance of the RText.TextPiece class.
Top

See Also

Reference

RText.TextPiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.TextPiece Constructor

[image]
ActiveReports 19 .NET Edition
RText.TextPiece Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.TextPiece Class : RText.TextPiece Constructor

x
The X coodinate.
text
The text.

Glossary Item Box

Initializes a new instance of the RText.TextPiece class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal text As String _
)
C#
public RText.TextPiece(
   float x,
   string text
)

Parameters

x
The X coodinate.
text
The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.TextPiece Class
RText.TextPiece Members


RText.TabType Enumeration

[image]
ActiveReports 19 .NET Edition
RText.TabType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TabType Enumeration

Glossary Item Box

Specifies tab stop types.

Syntax

Visual Basic (Declaration)
Public Enum RText.TabType
   Inherits System.Enum
C#
public enum RText.TabType : System.Enum

Members

Member | Description
Center | The center tap stop.
Left | The left tap stop.
Right | The right tap stop.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.PaddingEx Structure

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.PaddingEx Structure

Glossary Item Box

Represents the padding.

Object Model

RText.PaddingEx Structure

Syntax

Visual Basic (Declaration)
Public Structure RText.PaddingEx
   Inherits System.ValueType
C#
public struct RText.PaddingEx : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.PaddingEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.PaddingEx Structure Members

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.PaddingEx Structure

Glossary Item Box

The following tables list the members exposed by RText.PaddingEx.

Public Constructors

 | Name | Description
Public Constructor | RText.PaddingEx Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the empty padding structure.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets the all paddings.
Public Property | Bottom | Gets or sets bottom padding
Public Property | Horizontal | Gets horizontal padding property
Public Property | Left | Gets or sets left padding
Public Property | Right | Gets or sets right padding
Public Property | Size | Gets size.
Public Property | Top | Gets or sets top padding
Public Property | Vertical | Gets vertical padding.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified RText.PaddingEx is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Top

Public Operators

public Operator Equality | Implements the == operator.
public Operator Inequality | Implements the != operator.
Top

See Also

Reference

RText.PaddingEx Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.PaddingEx Constructor

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : RText.PaddingEx Constructor

Glossary Item Box

Overload List

Overload | Description
RText.PaddingEx Constructor(Int32) | Initializes an instance of class RText.PaddingEx.
RText.PaddingEx Constructor(Int32,Int32,Int32,Int32) | Initializes an instance of class RText.PaddingEx.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


RText.PaddingEx Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure > RText.PaddingEx Constructor : RText.PaddingEx Constructor(Int32)

all
All paddings.

Glossary Item Box

Initializes an instance of class RText.PaddingEx.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal all As Integer _
)
C#
public RText.PaddingEx(
   int all
)

Parameters

all
All paddings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members
Overload List


RText.PaddingEx Constructor(Int32,Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Constructor(Int32,Int32,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure > RText.PaddingEx Constructor : RText.PaddingEx Constructor(Int32,Int32,Int32,Int32)

left
The left padding.
top
The top padding.
right
The right padding.
bottom
The bottom padding.

Glossary Item Box

Initializes an instance of class RText.PaddingEx.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
C#
public RText.PaddingEx(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The left padding.
top
The top padding.
right
The right padding.
bottom
The bottom padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members
Overload List


RText.PaddingEx Structure Methods

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see RText.PaddingEx members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified RText.PaddingEx is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Top

See Also

Reference

RText.PaddingEx Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Equals Method

Glossary Item Box

Determines whether the specified RText.PaddingEx is equal to this instance.

Overload List

Overload | Description
Equals(PaddingEx) | Determines whether the specified RText.PaddingEx is equal to this instance.
Equals(Object) | Determines whether the specified System.Object is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Equals(PaddingEx) Method

[image]
ActiveReports 19 .NET Edition
Equals(PaddingEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure > Equals Method : Equals(PaddingEx) Method

paddingExEx
Another object to compare to.

Glossary Item Box

Determines whether the specified RText.PaddingEx is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal paddingExEx As RText.PaddingEx _
) As Boolean
C#
public bool Equals(
   RText.PaddingEx paddingExEx
)

Parameters

paddingExEx
Another object to compare to.

Return Value

true if the specified RText.PaddingEx is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure > Equals Method : Equals(Object) Method

obj
Another object to compare to.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


RText.PaddingEx Structure Properties

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see RText.PaddingEx members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the all paddings.
Public Property | Bottom | Gets or sets bottom padding
Public Property | Horizontal | Gets horizontal padding property
Public Property | Left | Gets or sets left padding
Public Property | Right | Gets or sets right padding
Public Property | Size | Gets size.
Public Property | Top | Gets or sets top padding
Public Property | Vertical | Gets vertical padding.
Top

See Also

Reference

RText.PaddingEx Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


All Property

[image]
ActiveReports 19 .NET Edition
All Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : All Property

Glossary Item Box

Gets or sets the all paddings.

Syntax

Visual Basic (Declaration)
Public Property All As Integer
C#
public int All {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Bottom Property

Glossary Item Box

Gets or sets bottom padding

Syntax

Visual Basic (Declaration)
Public Property Bottom As Integer
C#
public int Bottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Horizontal Property

[image]
ActiveReports 19 .NET Edition
Horizontal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Horizontal Property

Glossary Item Box

Gets horizontal padding property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Horizontal As Integer
C#
public int Horizontal {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Left Property

Glossary Item Box

Gets or sets left padding

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Right Property

Glossary Item Box

Gets or sets right padding

Syntax

Visual Basic (Declaration)
Public Property Right As Integer
C#
public int Right {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Size Property

Glossary Item Box

Gets size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Top Property

Glossary Item Box

Gets or sets top padding

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Vertical Property

[image]
ActiveReports 19 .NET Edition
Vertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Vertical Property

Glossary Item Box

Gets vertical padding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertical As Integer
C#
public int Vertical {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


RText.PaddingEx Structure Fields

[image]
ActiveReports 19 .NET Edition
RText.PaddingEx Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see RText.PaddingEx members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the empty padding structure.
Top

See Also

Reference

RText.PaddingEx Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Empty Field

Glossary Item Box

Gets the empty padding structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As RText.PaddingEx
C#
public static readonly RText.PaddingEx Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Equality Operator

p1
p2

Glossary Item Box

Implements the == operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal p1 As RText.PaddingEx, _
   ByVal p2 As RText.PaddingEx _
) As Boolean
C#
public bool operator ==(
   RText.PaddingEx p1,
   RText.PaddingEx p2
)

Parameters

p1
p2

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.PaddingEx Structure : Inequality Operator

p1
p2

Glossary Item Box

Implements the != operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal p1 As RText.PaddingEx, _
   ByVal p2 As RText.PaddingEx _
) As Boolean
C#
public bool operator !=(
   RText.PaddingEx p1,
   RText.PaddingEx p2
)

Parameters

p1
p2

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.PaddingEx Structure
RText.PaddingEx Members


RText.SelectionRange Structure

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.SelectionRange Structure

Glossary Item Box

Represents text selection range.

Object Model

RText.SelectionRange Structure

Syntax

Visual Basic (Declaration)
Public Structure RText.SelectionRange
   Inherits System.ValueType
C#
public struct RText.SelectionRange : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.SelectionRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Members
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.SelectionRange Structure Members

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.SelectionRange Structure

Glossary Item Box

The following tables list the members exposed by RText.SelectionRange.

Public Constructors

 | Name | Description
Public Constructor | RText.SelectionRange Constructor | Initializes a new instance of the RText.SelectionRange class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty selection.
Public Field | Length | The length field.
Public Field | Start | The start field.
Top

Public Properties

 | Name | Description
Public Property | End | Gets the last character in selection. Gets incorrect position in case of empty selection.
Public Property | IsEmpty | Gets true if selection is empty
Top

Public Methods

 | Name | Description
Public Method | CompareTo | Compares objects to each other.
Public Method | Intersect | Returns intersection of current selection with another one.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

RText.SelectionRange Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


RText.SelectionRange Constructor

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : RText.SelectionRange Constructor

start
The start position.
length
The end position.

Glossary Item Box

Initializes a new instance of the RText.SelectionRange class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
C#
public RText.SelectionRange(
   int start,
   int length
)

Parameters

start
The start position.
length
The end position.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | Occurs if the start/end position is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


RText.SelectionRange Structure Methods

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.SelectionRange Structure

Glossary Item Box

For a list of all members of this type, see RText.SelectionRange members.

Public Methods

 | Name | Description
Public Method | CompareTo | Compares objects to each other.
Public Method | Intersect | Returns intersection of current selection with another one.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

RText.SelectionRange Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


CompareTo Method

[image]
ActiveReports 19 .NET Edition
CompareTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : CompareTo Method

other1
The object for comparison.

Glossary Item Box

Compares objects to each other.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal other1 As Object _
) As Integer
C#
public int CompareTo(
   object other1
)

Parameters

other1
The object for comparison.

Return Value

A 32-bit signed integer that indicates whether this instance precedes, follows, or appears in the same position in the sort order as the value parameter. Less than zero - this instance precedes value. Zero - this instance has the same position in the sort order as value. Greater than zero - this instance follows value or value is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


Intersect Method

[image]
ActiveReports 19 .NET Edition
Intersect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : Intersect Method

other
The area for intersection.

Glossary Item Box

Returns intersection of current selection with another one.

Syntax

Visual Basic (Declaration)
Public Function Intersect( _
   ByVal other As RText.SelectionRange _
) As RText.SelectionRange
C#
public RText.SelectionRange Intersect(
   RText.SelectionRange other
)

Parameters

other
The area for intersection.

Return Value

Returns a new instance of the RText.SelectionRange structure that represents the intersection area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


RText.SelectionRange Structure Properties

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.SelectionRange Structure

Glossary Item Box

For a list of all members of this type, see RText.SelectionRange members.

Public Properties

 | Name | Description
Public Property | End | Gets the last character in selection. Gets incorrect position in case of empty selection.
Public Property | IsEmpty | Gets true if selection is empty
Top

See Also

Reference

RText.SelectionRange Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


End Property

[image]
ActiveReports 19 .NET Edition
End Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : End Property

Glossary Item Box

Gets the last character in selection. Gets incorrect position in case of empty selection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property End As Integer
C#
public int End {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : IsEmpty Property

Glossary Item Box

Gets true if selection is empty

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


RText.SelectionRange Structure Fields

[image]
ActiveReports 19 .NET Edition
RText.SelectionRange Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.SelectionRange Structure

Glossary Item Box

For a list of all members of this type, see RText.SelectionRange members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty selection.
Public Field | Length | The length field.
Public Field | Start | The start field.
Top

See Also

Reference

RText.SelectionRange Structure
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : Empty Field

Glossary Item Box

Gets empty selection.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As RText.SelectionRange
C#
public static readonly RText.SelectionRange Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : Length Field

Glossary Item Box

The length field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Length As Integer
C#
public readonly int Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


Start Field

[image]
ActiveReports 19 .NET Edition
Start Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText.SelectionRange Structure : Start Field

Glossary Item Box

The start field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Start As Integer
C#
public readonly int Start

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText.SelectionRange Structure
RText.SelectionRange Members


PageExtensions Class

[image]
ActiveReports 19 .NET Edition
PageExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageExtensions Class

Glossary Item Box

Represents the extensions for the page.

Object Model

PageExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PageExtensions
C#
public static class PageExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageExtensions Members
GrapeCity.ActiveReports.Document.Section Namespace


PageExtensions Class Members

[image]
ActiveReports 19 .NET Edition
PageExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageExtensions Class

Glossary Item Box

The following tables list the members exposed by PageExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw | Overloaded. Draws the page.
Top

See Also

Reference

PageExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


PageExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
PageExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageExtensions Class

Glossary Item Box

For a list of all members of this type, see PageExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw | Overloaded. Draws the page.
Top

See Also

Reference

PageExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


Draw Method

[image]
ActiveReports 19 .NET Edition
Draw Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageExtensions Class : Draw Method

Glossary Item Box

Draws the page.

Overload List

Overload | Description
Draw(Page,Graphics,RectangleF) | Draws the page.
Draw(Page,Graphics,RectangleF,Single,Single,Boolean) | Draws the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageExtensions Class
PageExtensions Members


Draw(Page,Graphics,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Draw(Page,Graphics,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageExtensions Class > Draw Method : Draw(Page,Graphics,RectangleF) Method

page
The page for drawing.
graphics
The graphics for drawing.
bounds
The bounds of the page.

Glossary Item Box

Draws the page.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Draw( _
   ByVal page As Page, _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF _
)
C#
public static void Draw(
   Page page,
   Graphics graphics,
   RectangleF bounds
)

Parameters

page
The page for drawing.
graphics
The graphics for drawing.
bounds
The bounds of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageExtensions Class
PageExtensions Members
Overload List


Draw(Page,Graphics,RectangleF,Single,Single,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Draw(Page,Graphics,RectangleF,Single,Single,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageExtensions Class > Draw Method : Draw(Page,Graphics,RectangleF,Single,Single,Boolean) Method

page
The page for drawing.
graphics
The graphics for drawing.
bounds
The bounds of the page.
scaleFactorX
The X scale factor.
scaleFactorY
The Y scale factor.
printing
Flag that determines whether printing is currently in progress.

Glossary Item Box

Draws the page.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Draw( _
   ByVal page As Page, _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF, _
   ByVal scaleFactorX As Single, _
   ByVal scaleFactorY As Single, _
   ByVal printing As Boolean _
)
C#
public static void Draw(
   Page page,
   Graphics graphics,
   RectangleF bounds,
   float scaleFactorX,
   float scaleFactorY,
   bool printing
)

Parameters

page
The page for drawing.
graphics
The graphics for drawing.
bounds
The bounds of the page.
scaleFactorX
The X scale factor.
scaleFactorY
The Y scale factor.
printing
Flag that determines whether printing is currently in progress.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageExtensions Class
PageExtensions Members
Overload List


DefaultResourceLocator Class

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : DefaultResourceLocator Class

Glossary Item Box

Represents a default implementation of ResourceLocator class.

Object Model

DefaultResourceLocator Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DefaultResourceLocator
   Inherits ResourceLocator
C#
public sealed class DefaultResourceLocator : ResourceLocator

Remarks

Provides the following URI schemes for locating the resources:

URI scheme | Description
file | URI scheme for locating files on a local computer or local network (e.g. "file://localhost/etc/example.txt").
http | URI scheme for locating resources on a web server using HTTP protocol (e.g. "http://example.com/example.xml")
https | URI scheme for locating resources on a web server using HTTPS protocol (e.g. "https://example.com/example.png")
data | URI scheme indicating that the URI contains a resource bytes converted in Base64 string (e.g. "data:TXkgdGV4dA==...").
res | URI scheme for locating a resources from assembly using an assembly name and resource name (e.g. "res:myassemblyname/resources.textboxlocalization").
theme | URI scheme for locating an image from the current attached theme using a name of the image (e.g. "theme:Logo").
embeddedimage | URI scheme for locating an embedded image using a name of the image (e.g. "embeddedimage:MyEmbeddedImage").

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ResourceLocator
GrapeCity.ActiveReports.DefaultResourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Members
GrapeCity.ActiveReports Namespace


DefaultResourceLocator Class Members

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : DefaultResourceLocator Class

Glossary Item Box

The following tables list the members exposed by DefaultResourceLocator.

Public Constructors

 | Name | Description
Public Constructor | DefaultResourceLocator Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | UriSchemeAssemblyResource |
static (Shared in Visual Basic) | UriSchemeData |
static (Shared in Visual Basic) | UriSchemeEmbeddedImage |
static (Shared in Visual Basic) | UriSchemeThemeItem |
Top

Public Methods

 | Name | Description
Public Method | Fork | Overloaded. Overridden. Gets a ResourceLocator for a specified subreport.
Public Method | GetResource | Overloaded. Overridden. Gets a Resource using a specified ResourceInfo and System.IServiceProvider.
Top

See Also

Reference

DefaultResourceLocator Class
GrapeCity.ActiveReports Namespace


DefaultResourceLocator Constructor

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : DefaultResourceLocator Constructor

Glossary Item Box

Overload List

Overload | Description
DefaultResourceLocator Constructor() | Initializes a new instance of DefaultResourceLocator class.
DefaultResourceLocator Constructor(Uri) | Initializes a new instance of DefaultResourceLocator class with a specified base System.Uri.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


DefaultResourceLocator Constructor()

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > DefaultResourceLocator Constructor : DefaultResourceLocator Constructor()

Glossary Item Box

Initializes a new instance of DefaultResourceLocator class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DefaultResourceLocator()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


DefaultResourceLocator Constructor(Uri)

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Constructor(Uri)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > DefaultResourceLocator Constructor : DefaultResourceLocator Constructor(Uri)

baseUri
A base System.Uri object for locating resources.

Glossary Item Box

Initializes a new instance of DefaultResourceLocator class with a specified base System.Uri.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal baseUri As Uri _
)
C#
public DefaultResourceLocator(
   Uri baseUri
)

Parameters

baseUri
A base System.Uri object for locating resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


DefaultResourceLocator Class Methods

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : DefaultResourceLocator Class

Glossary Item Box

For a list of all members of this type, see DefaultResourceLocator members.

Public Methods

 | Name | Description
Public Method | Fork | Overloaded. Overridden. Gets a ResourceLocator for a specified subreport.
Public Method | GetResource | Overloaded. Overridden. Gets a Resource using a specified ResourceInfo and System.IServiceProvider.
Top

See Also

Reference

DefaultResourceLocator Class
GrapeCity.ActiveReports Namespace


Fork Method

[image]
ActiveReports 19 .NET Edition
Fork Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : Fork Method

Glossary Item Box

Gets a ResourceLocator for a specified subreport.

Overload List

Overload | Description
Fork(String) | Gets a ResourceLocator for a specified subreport.
Fork(Uri) | Returns a ResourceLocator for a specified part item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


Fork(String) Method

[image]
ActiveReports 19 .NET Edition
Fork(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > Fork Method : Fork(String) Method

subreportName
A System.String value indicating the name of the subreport to get the ResourceLocator for.

Glossary Item Box

Gets a ResourceLocator for a specified subreport.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Fork( _
   ByVal subreportName As String _
) As ResourceLocator
C#
public override ResourceLocator Fork(
   string subreportName
)

Parameters

subreportName
A System.String value indicating the name of the subreport to get the ResourceLocator for.

Return Value

A ResourceLocator object specific to the specified subreport.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


Fork(Uri) Method

[image]
ActiveReports 19 .NET Edition
Fork(Uri) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > Fork Method : Fork(Uri) Method

uri
A System.Uri object of the part item to get the ResourceLocator for.

Glossary Item Box

Returns a ResourceLocator for a specified part item.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Fork( _
   ByVal uri As Uri _
) As ResourceLocator
C#
public override ResourceLocator Fork(
   Uri uri
)

Parameters

uri
A System.Uri object of the part item to get the ResourceLocator for.

Return Value

A ResourceLocator object specific to the specified URI.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


GetResource Method

[image]
ActiveReports 19 .NET Edition
GetResource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : GetResource Method

Glossary Item Box

Gets a Resource using a specified ResourceInfo and System.IServiceProvider.

Overload List

Overload | Description
GetResource(ResourceInfo,IServiceProvider) | Gets a Resource using a specified ResourceInfo and System.IServiceProvider.
GetResource(ResourceInfo) | Gets a Resource using a specified ResourceInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


GetResource(ResourceInfo,IServiceProvider) Method

[image]
ActiveReports 19 .NET Edition
GetResource(ResourceInfo,IServiceProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > GetResource Method : GetResource(ResourceInfo,IServiceProvider) Method

resourceInfo
A ResourceInfo object containing information about the resource to be located.
serviceProvider
A System.IServiceProvider object to use to get the resource.

Glossary Item Box

Gets a Resource using a specified ResourceInfo and System.IServiceProvider.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetResource( _
   ByVal resourceInfo As ResourceInfo, _
   ByVal serviceProvider As IServiceProvider _
) As Resource
C#
public override Resource GetResource(
   ResourceInfo resourceInfo,
   IServiceProvider serviceProvider
)

Parameters

resourceInfo
A ResourceInfo object containing information about the resource to be located.
serviceProvider
A System.IServiceProvider object to use to get the resource.

Return Value

A Resource object that contains the located resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


GetResource(ResourceInfo) Method

[image]
ActiveReports 19 .NET Edition
GetResource(ResourceInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class > GetResource Method : GetResource(ResourceInfo) Method

resourceInfo
The ResourceInfo object containing information about the resource to be located.

Glossary Item Box

Gets a Resource using a specified ResourceInfo.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetResource( _
   ByVal resourceInfo As ResourceInfo _
) As Resource
C#
public override Resource GetResource(
   ResourceInfo resourceInfo
)

Parameters

resourceInfo
The ResourceInfo object containing information about the resource to be located.

Return Value

A Resource object that contains the located resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members
Overload List


DefaultResourceLocator Class Fields

[image]
ActiveReports 19 .NET Edition
DefaultResourceLocator Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : DefaultResourceLocator Class

Glossary Item Box

For a list of all members of this type, see DefaultResourceLocator members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | UriSchemeAssemblyResource |
static (Shared in Visual Basic) | UriSchemeData |
static (Shared in Visual Basic) | UriSchemeEmbeddedImage |
static (Shared in Visual Basic) | UriSchemeThemeItem |
Top

See Also

Reference

DefaultResourceLocator Class
GrapeCity.ActiveReports Namespace


UriSchemeAssemblyResource Field

[image]
ActiveReports 19 .NET Edition
UriSchemeAssemblyResource Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : UriSchemeAssemblyResource Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UriSchemeAssemblyResource As String
C#
public static readonly string UriSchemeAssemblyResource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


UriSchemeData Field

[image]
ActiveReports 19 .NET Edition
UriSchemeData Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : UriSchemeData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UriSchemeData As String
C#
public static readonly string UriSchemeData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


UriSchemeEmbeddedImage Field

[image]
ActiveReports 19 .NET Edition
UriSchemeEmbeddedImage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : UriSchemeEmbeddedImage Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UriSchemeEmbeddedImage As String
C#
public static readonly string UriSchemeEmbeddedImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


UriSchemeThemeItem Field

[image]
ActiveReports 19 .NET Edition
UriSchemeThemeItem Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > DefaultResourceLocator Class : UriSchemeThemeItem Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UriSchemeThemeItem As String
C#
public static readonly string UriSchemeThemeItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultResourceLocator Class
DefaultResourceLocator Members


ResourceLocator Class

[image]
ActiveReports 19 .NET Edition
ResourceLocator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceLocator Class

Glossary Item Box

Represents an abstract base class for locating resources based on their information.

Object Model

ResourceLocator Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ResourceLocator
C#
public abstract class ResourceLocator

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ResourceLocator
GrapeCity.ActiveReports.DefaultResourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Members
GrapeCity.ActiveReports Namespace


ResourceLocator Class Members

[image]
ActiveReports 19 .NET Edition
ResourceLocator Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceLocator Class

Glossary Item Box

The following tables list the members exposed by ResourceLocator.

Public Properties

 | Name | Description
Public Property | BaseUri | Gets or sets the base System.Uri that all the resources are located relative to.
Public Property | ServiceProvider | Gets or sets an System.IServiceProvider object used to obtain report services.
Top

Public Methods

 | Name | Description
Public Method | Fork | Overloaded. Gets a ResourceLocator for a specified subreport.
Public Method | GetResource | Overloaded. Gets a Resource using a specified ResourceInfo.
Top

See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports Namespace


ResourceLocator Class Methods

[image]
ActiveReports 19 .NET Edition
ResourceLocator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceLocator Class

Glossary Item Box

For a list of all members of this type, see ResourceLocator members.

Public Methods

 | Name | Description
Public Method | Fork | Overloaded. Gets a ResourceLocator for a specified subreport.
Public Method | GetResource | Overloaded. Gets a Resource using a specified ResourceInfo.
Top

See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports Namespace


Fork Method

[image]
ActiveReports 19 .NET Edition
Fork Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class : Fork Method

Glossary Item Box

Gets a ResourceLocator for a specified subreport.

Overload List

Overload | Description
Fork(String) | Gets a ResourceLocator for a specified subreport.
Fork(Uri) | Returns a ResourceLocator for a specified part item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members


Fork(String) Method

[image]
ActiveReports 19 .NET Edition
Fork(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class > Fork Method : Fork(String) Method

subreportName
A System.String value indicating the name of the subreport to get the ResourceLocator for.

Glossary Item Box

Gets a ResourceLocator for a specified subreport.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Fork( _
   ByVal subreportName As String _
) As ResourceLocator
C#
public virtual ResourceLocator Fork(
   string subreportName
)

Parameters

subreportName
A System.String value indicating the name of the subreport to get the ResourceLocator for.

Return Value

If not overridden, returns this; otherwise, returns a ResourceLocator object specific to the specified subreport.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


Fork(Uri) Method

[image]
ActiveReports 19 .NET Edition
Fork(Uri) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class > Fork Method : Fork(Uri) Method

uri
A System.Uri object of the part item to get the ResourceLocator for.

Glossary Item Box

Returns a ResourceLocator for a specified part item.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Fork( _
   ByVal uri As Uri _
) As ResourceLocator
C#
public virtual ResourceLocator Fork(
   Uri uri
)

Parameters

uri
A System.Uri object of the part item to get the ResourceLocator for.

Return Value

If not overridden, returns this; otherwise, returns a ResourceLocator object specific to the specified URI.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


GetResource Method

[image]
ActiveReports 19 .NET Edition
GetResource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class : GetResource Method

Glossary Item Box

Gets a Resource using a specified ResourceInfo.

Overload List

Overload | Description
GetResource(ResourceInfo) | Gets a Resource using a specified ResourceInfo.
GetResource(ResourceInfo,IServiceProvider) | Gets a Resource using a specified ResourceInfo and System.IServiceProvider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members


GetResource(ResourceInfo) Method

[image]
ActiveReports 19 .NET Edition
GetResource(ResourceInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class > GetResource Method : GetResource(ResourceInfo) Method

resourceInfo
The ResourceInfo object containing information about the resource to be located.

Glossary Item Box

Gets a Resource using a specified ResourceInfo.

Syntax

Visual Basic (Declaration)
Public Overloads MustOverride Function GetResource( _
   ByVal resourceInfo As ResourceInfo _
) As Resource
C#
public abstract Resource GetResource(
   ResourceInfo resourceInfo
)

Parameters

resourceInfo
The ResourceInfo object containing information about the resource to be located.

Return Value

A Resource object that contains the located resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


GetResource(ResourceInfo,IServiceProvider) Method

[image]
ActiveReports 19 .NET Edition
GetResource(ResourceInfo,IServiceProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class > GetResource Method : GetResource(ResourceInfo,IServiceProvider) Method

resourceInfo
A ResourceInfo object containing information about the resource to be located.
serviceProvider
A System.IServiceProvider object to use to get the resource.

Glossary Item Box

Gets a Resource using a specified ResourceInfo and System.IServiceProvider.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetResource( _
   ByVal resourceInfo As ResourceInfo, _
   ByVal serviceProvider As IServiceProvider _
) As Resource
C#
public virtual Resource GetResource(
   ResourceInfo resourceInfo,
   IServiceProvider serviceProvider
)

Parameters

resourceInfo
A ResourceInfo object containing information about the resource to be located.
serviceProvider
A System.IServiceProvider object to use to get the resource.

Return Value

A Resource object that contains the located resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


ResourceLocator Class Properties

[image]
ActiveReports 19 .NET Edition
ResourceLocator Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceLocator Class

Glossary Item Box

For a list of all members of this type, see ResourceLocator members.

Public Properties

 | Name | Description
Public Property | BaseUri | Gets or sets the base System.Uri that all the resources are located relative to.
Public Property | ServiceProvider | Gets or sets an System.IServiceProvider object used to obtain report services.
Top

See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports Namespace


BaseUri Property

[image]
ActiveReports 19 .NET Edition
BaseUri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class : BaseUri Property

Glossary Item Box

Gets or sets the base System.Uri that all the resources are located relative to.

Syntax

Visual Basic (Declaration)
Public Property BaseUri As Uri
C#
public Uri BaseUri {get; set;}

Property Value

A base System.Uri object for locating resources.

Exceptions

Exception | Description
System.ArgumentException | Thrown if value is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members


ServiceProvider Property

[image]
ActiveReports 19 .NET Edition
ServiceProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceLocator Class : ServiceProvider Property

Glossary Item Box

Gets or sets an System.IServiceProvider object used to obtain report services.

Syntax

Visual Basic (Declaration)
Public Property ServiceProvider As IServiceProvider
C#
public IServiceProvider ServiceProvider {get; set;}

Property Value

A System.IServiceProvider object used to obtain report services.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceLocator Class
ResourceLocator Members


ResourceType Enumeration

[image]
ActiveReports 19 .NET Edition
ResourceType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceType Enumeration

Glossary Item Box

Specifies the types of resources.

Syntax

Visual Basic (Declaration)
Public Enum ResourceType
   Inherits System.Enum
C#
public enum ResourceType : System.Enum

Members

Member | Description
DataFile | A data file resource.
DataSetTemplate | A dataset template resource (web designer only).
Image | An image resource.
LibraryReport | A library report resource.
MasterReport | A master report resource.
Other | A resource of another type.
Report | A report resource.
ReportTemplate | A report template resource (web designer only).
SharedDataSet | A shared dataset resource.
SharedDataSource | A shared data source resource.
StyleSheet | A stylesheet resource.
Subreport | A subreport resource.
Theme | A theme resource.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ResourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


Resource Structure

[image]
ActiveReports 19 .NET Edition
Resource Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : Resource Structure

Glossary Item Box

Represents a report resource returned by ResourceLocator.GetResource.

Object Model

Resource Structure

Syntax

Visual Basic (Declaration)
Public Structure Resource
   Inherits System.ValueType
C#
public struct Resource : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Resource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Resource Members
GrapeCity.ActiveReports Namespace


Resource Structure Members

[image]
ActiveReports 19 .NET Edition
Resource Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : Resource Structure

Glossary Item Box

The following tables list the members exposed by Resource.

Public Constructors

 | Name | Description
Public Constructor | Resource Constructor | Initializes a new instance of the Resource struct.
Top

Public Properties

 | Name | Description
Public Property | ParentUri | Gets the parent System.Uri of the located resource.
Public Property | Value | Gets the System.IO.Stream that contains the resource content.
Top

See Also

Reference

Resource Structure
GrapeCity.ActiveReports Namespace


Resource Constructor

[image]
ActiveReports 19 .NET Edition
Resource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > Resource Structure : Resource Constructor

stream
A System.IO.Stream that contains the resource content.
parentUri
A parent System.Uri of the located resource.

Glossary Item Box

Initializes a new instance of the Resource struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal parentUri As Uri _
)
C#
public Resource(
   Stream stream,
   Uri parentUri
)

Parameters

stream
A System.IO.Stream that contains the resource content.
parentUri
A parent System.Uri of the located resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Resource Structure
Resource Members


Resource Structure Properties

[image]
ActiveReports 19 .NET Edition
Resource Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : Resource Structure

Glossary Item Box

For a list of all members of this type, see Resource members.

Public Properties

 | Name | Description
Public Property | ParentUri | Gets the parent System.Uri of the located resource.
Public Property | Value | Gets the System.IO.Stream that contains the resource content.
Top

See Also

Reference

Resource Structure
GrapeCity.ActiveReports Namespace


ParentUri Property

[image]
ActiveReports 19 .NET Edition
ParentUri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > Resource Structure : ParentUri Property

Glossary Item Box

Gets the parent System.Uri of the located resource.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentUri As Uri
C#
public Uri ParentUri {get;}

Property Value

A System.Uri object representing the parent URI of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Resource Structure
Resource Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > Resource Structure : Value Property

Glossary Item Box

Gets the System.IO.Stream that contains the resource content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Stream
C#
public Stream Value {get;}

Property Value

A System.IO.Stream object representing the content of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Resource Structure
Resource Members


ResourceInfo Structure

[image]
ActiveReports 19 .NET Edition
ResourceInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceInfo Structure

Glossary Item Box

Represents a resource key to be located by ResourceLocator.

Object Model

ResourceInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure ResourceInfo
   Inherits System.ValueType
C#
public struct ResourceInfo : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.ResourceInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Members
GrapeCity.ActiveReports Namespace


ResourceInfo Structure Members

[image]
ActiveReports 19 .NET Edition
ResourceInfo Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceInfo Structure

Glossary Item Box

The following tables list the members exposed by ResourceInfo.

Public Constructors

 | Name | Description
Public Constructor | ResourceInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the resource to be located.
Public Property | Type | Gets the type of the resource to be located.
Top

See Also

Reference

ResourceInfo Structure
GrapeCity.ActiveReports Namespace


ResourceInfo Constructor

[image]
ActiveReports 19 .NET Edition
ResourceInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceInfo Structure : ResourceInfo Constructor

Glossary Item Box

Overload List

Overload | Description
ResourceInfo Constructor(String,ResourceType) | Initializes a new instance of the ResourceInfo struct with the specified name and type.
ResourceInfo Constructor(String) | Initializes a new instance of the ResourceInfo struct with the specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Structure
ResourceInfo Members


ResourceInfo Constructor(String,ResourceType)

[image]
ActiveReports 19 .NET Edition
ResourceInfo Constructor(String,ResourceType)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceInfo Structure > ResourceInfo Constructor : ResourceInfo Constructor(String,ResourceType)

name
A System.String value indicating the name of the resource.
type
A ResourceType value indicating the type of the resource.

Glossary Item Box

Initializes a new instance of the ResourceInfo struct with the specified name and type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ResourceType _
)
C#
public ResourceInfo(
   string name,
   ResourceType type
)

Parameters

name
A System.String value indicating the name of the resource.
type
A ResourceType value indicating the type of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Structure
ResourceInfo Members
Overload List


ResourceInfo Constructor(String)

[image]
ActiveReports 19 .NET Edition
ResourceInfo Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceInfo Structure > ResourceInfo Constructor : ResourceInfo Constructor(String)

name
A System.String value indicating the name of the resource.

Glossary Item Box

Initializes a new instance of the ResourceInfo struct with the specified name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public ResourceInfo(
   string name
)

Parameters

name
A System.String value indicating the name of the resource.

Remarks

This constructor is obsolete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Structure
ResourceInfo Members
Overload List


ResourceInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
ResourceInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : ResourceInfo Structure

Glossary Item Box

For a list of all members of this type, see ResourceInfo members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the resource to be located.
Public Property | Type | Gets the type of the resource to be located.
Top

See Also

Reference

ResourceInfo Structure
GrapeCity.ActiveReports Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceInfo Structure : Name Property

Glossary Item Box

Gets the name of the resource to be located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A System.String value indicating the name of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Structure
ResourceInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > ResourceInfo Structure : Type Property

Glossary Item Box

Gets the type of the resource to be located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ResourceType
C#
public ResourceType Type {get;}

Property Value

A ResourceType value indicating the type of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceInfo Structure
ResourceInfo Members


IReportComponentFactory Interface

[image]
ActiveReports 19 .NET Edition
IReportComponentFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : IReportComponentFactory Interface

Glossary Item Box

Represents a factory for creating GrapeCity.ActiveReports.PageReportModel.ReportComponent objects.

Syntax

Visual Basic (Declaration)
Public Interface IReportComponentFactory
C#
public interface IReportComponentFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponentFactory Members
GrapeCity.ActiveReports Namespace


IReportComponentFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IReportComponentFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : IReportComponentFactory Interface

Glossary Item Box

The following tables list the members exposed by IReportComponentFactory.

Public Methods

 | Name | Description
Method | CreateComponent | Creates an instance of a component of the specified type.
Top

See Also

Reference

IReportComponentFactory Interface
GrapeCity.ActiveReports Namespace


IReportComponentFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportComponentFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace : IReportComponentFactory Interface

Glossary Item Box

For a list of all members of this type, see IReportComponentFactory members.

Public Methods

 | Name | Description
Method | CreateComponent | Creates an instance of a component of the specified type.
Top

See Also

Reference

IReportComponentFactory Interface
GrapeCity.ActiveReports Namespace


CreateComponent Method

[image]
ActiveReports 19 .NET Edition
CreateComponent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports Namespace > IReportComponentFactory Interface : CreateComponent Method

componentType
A System.Type of the component to create.

Glossary Item Box

Creates an instance of a component of the specified type.

Syntax

Visual Basic (Declaration)
Function CreateComponent( _
   ByVal componentType As Type _
) As IComponent
C#
IComponent CreateComponent(
   Type componentType
)

Parameters

componentType
A System.Type of the component to create.

Return Value

An System.ComponentModel.IComponent object of the specified type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponentFactory Interface
IReportComponentFactory Members


JsonSerializersFactory Class

[image]
ActiveReports 19 .NET Edition
JsonSerializersFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : JsonSerializersFactory Class

Glossary Item Box

Represents the factory for the external report items json serializers.

Object Model

JsonSerializersFactory Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class JsonSerializersFactory
C#
public static class JsonSerializersFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Extensibility.JsonSerializersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializersFactory Members
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


JsonSerializersFactory Class Members

[image]
ActiveReports 19 .NET Edition
JsonSerializersFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : JsonSerializersFactory Class

Glossary Item Box

The following tables list the members exposed by JsonSerializersFactory.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a JSON converter for a specific type of report item.
Top

See Also

Reference

JsonSerializersFactory Class
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


JsonSerializersFactory Class Methods

[image]
ActiveReports 19 .NET Edition
JsonSerializersFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : JsonSerializersFactory Class

Glossary Item Box

For a list of all members of this type, see JsonSerializersFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a JSON converter for a specific type of report item.
Top

See Also

Reference

JsonSerializersFactory Class
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > JsonSerializersFactory Class : Register Method

typeName
A System.String value indicating the report item name used to specify the type in the JSON..
type
A System.Type object representing the type of the report item.
getConverter
The function to get a JsonConverter object used for serialization and deserialization.

Glossary Item Box

Registers a JSON converter for a specific type of report item.

Syntax

Visual Basic (Declaration)
Public Shared Sub Register( _
   ByVal typeName As String, _
   ByVal type As Type, _
   ByVal getConverter As Func(Of JsonConverter(Of ReportItem)) _
)
C#
public static void Register(
   string typeName,
   Type type,
   Func<JsonConverter<ReportItem>> getConverter
)

Parameters

typeName
A System.String value indicating the report item name used to specify the type in the JSON..
type
A System.Type object representing the type of the report item.
getConverter
The function to get a JsonConverter object used for serialization and deserialization.

Remarks

This method allows the registration of custom JSON converters for specific report item types. The converters will be used to handle the serialization and deserialization of those types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializersFactory Class
JsonSerializersFactory Members


XmlSerializersFactory Class

[image]
ActiveReports 19 .NET Edition
XmlSerializersFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : XmlSerializersFactory Class

Glossary Item Box

Represents the factory for the external report items xml (rdlx) serializers.

Object Model

XmlSerializersFactory Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class XmlSerializersFactory
C#
public static class XmlSerializersFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Extensibility.XmlSerializersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlSerializersFactory Members
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


XmlSerializersFactory Class Members

[image]
ActiveReports 19 .NET Edition
XmlSerializersFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : XmlSerializersFactory Class

Glossary Item Box

The following tables list the members exposed by XmlSerializersFactory.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a XML serializer for a specific type of report item.
Top

See Also

Reference

XmlSerializersFactory Class
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


XmlSerializersFactory Class Methods

[image]
ActiveReports 19 .NET Edition
XmlSerializersFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : XmlSerializersFactory Class

Glossary Item Box

For a list of all members of this type, see XmlSerializersFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Register | Registers a XML serializer for a specific type of report item.
Top

See Also

Reference

XmlSerializersFactory Class
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > XmlSerializersFactory Class : Register Method

getXmlSerializer
The function to get an IXmlItemSerializer object used for serialization and deserialization.

Glossary Item Box

Registers a XML serializer for a specific type of report item.

Syntax

Visual Basic (Declaration)
Public Shared Sub Register( _
   ByVal getXmlSerializer As Func(Of IXmlItemSerializer) _
)
C#
public static void Register(
   Func<IXmlItemSerializer> getXmlSerializer
)

Parameters

getXmlSerializer
The function to get an IXmlItemSerializer object used for serialization and deserialization.

Remarks

This method allows the registration of custom XML serializer for specific report item types. The serializers will be used to handle the serialization and deserialization of those types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlSerializersFactory Class
XmlSerializersFactory Members


IXmlItemSerializer Interface

[image]
ActiveReports 19 .NET Edition
IXmlItemSerializer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : IXmlItemSerializer Interface

Glossary Item Box

Represents an interface for report item XML serializer/deserializer.

Syntax

Visual Basic (Declaration)
Public Interface IXmlItemSerializer
C#
public interface IXmlItemSerializer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Members
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


IXmlItemSerializer Interface Members

[image]
ActiveReports 19 .NET Edition
IXmlItemSerializer Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : IXmlItemSerializer Interface

Glossary Item Box

The following tables list the members exposed by IXmlItemSerializer.

Public Properties

 | Name | Description
Property | ElementName | Gets the element name to be written in the resulting XML for the item.
Property | IsLegacySerializer | Gets value Indicating whether this serializer implementation is used for legacy report serialization.
Property | Namespace | Gets the namespace to be used to write the item data to the XML.
Property | ObjectType | Gets the report item's type which should be serialized with this surrogate.
Top

Public Methods

 | Name | Description
Method | Read | Reads the item data from the XML using a specified System.Xml.XmlReader.
Method | Write | Writes the specified item data to the XML using a specified System.Xml.XmlWriter.
Top

See Also

Reference

IXmlItemSerializer Interface
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


IXmlItemSerializer Interface Methods

[image]
ActiveReports 19 .NET Edition
IXmlItemSerializer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : IXmlItemSerializer Interface

Glossary Item Box

For a list of all members of this type, see IXmlItemSerializer members.

Public Methods

 | Name | Description
Method | Read | Reads the item data from the XML using a specified System.Xml.XmlReader.
Method | Write | Writes the specified item data to the XML using a specified System.Xml.XmlWriter.
Top

See Also

Reference

IXmlItemSerializer Interface
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


Read Method

[image]
ActiveReports 19 .NET Edition
Read Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : Read Method

ctx
A System.Xml.XmlReader object used to read the item data from XML.

Glossary Item Box

Reads the item data from the XML using a specified System.Xml.XmlReader.

Syntax

Visual Basic (Declaration)
Function Read( _
   ByVal ctx As XmlReader _
) As Object
C#
object Read(
   XmlReader ctx
)

Parameters

ctx
A System.Xml.XmlReader object used to read the item data from XML.

Return Value

A System.Object representing the deserialized item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


Write Method

[image]
ActiveReports 19 .NET Edition
Write Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : Write Method

ctx
A System.Xml.XmlWriter object used to write the item data to XML.
item
A System.Object representing the item to be serialized.

Glossary Item Box

Writes the specified item data to the XML using a specified System.Xml.XmlWriter.

Syntax

Visual Basic (Declaration)
Sub Write( _
   ByVal ctx As XmlWriter, _
   ByVal item As Object _
)
C#
void Write(
   XmlWriter ctx,
   object item
)

Parameters

ctx
A System.Xml.XmlWriter object used to write the item data to XML.
item
A System.Object representing the item to be serialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


IXmlItemSerializer Interface Properties

[image]
ActiveReports 19 .NET Edition
IXmlItemSerializer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace : IXmlItemSerializer Interface

Glossary Item Box

For a list of all members of this type, see IXmlItemSerializer members.

Public Properties

 | Name | Description
Property | ElementName | Gets the element name to be written in the resulting XML for the item.
Property | IsLegacySerializer | Gets value Indicating whether this serializer implementation is used for legacy report serialization.
Property | Namespace | Gets the namespace to be used to write the item data to the XML.
Property | ObjectType | Gets the report item's type which should be serialized with this surrogate.
Top

See Also

Reference

IXmlItemSerializer Interface
GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace


ElementName Property

[image]
ActiveReports 19 .NET Edition
ElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : ElementName Property

Glossary Item Box

Gets the element name to be written in the resulting XML for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property ElementName As String
C#
string ElementName {get;}

Property Value

A System.String value indicating the XML element name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


IsLegacySerializer Property

[image]
ActiveReports 19 .NET Edition
IsLegacySerializer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : IsLegacySerializer Property

Glossary Item Box

Gets value Indicating whether this serializer implementation is used for legacy report serialization.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLegacySerializer As Boolean
C#
bool IsLegacySerializer {get;}

Property Value

A System.Boolean value indicating whether this serializer implementation is used for legacy report serialization.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


Namespace Property

[image]
ActiveReports 19 .NET Edition
Namespace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : Namespace Property

Glossary Item Box

Gets the namespace to be used to write the item data to the XML.

Syntax

Visual Basic (Declaration)
ReadOnly Property Namespace As String
C#
string Namespace {get;}

Property Value

A System.String value indicating the XML namespace.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


ObjectType Property

[image]
ActiveReports 19 .NET Edition
ObjectType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Extensibility Namespace > IXmlItemSerializer Interface : ObjectType Property

Glossary Item Box

Gets the report item's type which should be serialized with this surrogate.

Syntax

Visual Basic (Declaration)
ReadOnly Property ObjectType As Type
C#
Type ObjectType {get;}

Property Value

A System.Type object representing the type of the report item to be serialized.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IXmlItemSerializer Interface
IXmlItemSerializer Members


Coder<T1,T2> Class

T1
The type of objects to be encoded.
T2
The type of result object.
[image]
ActiveReports 19 .NET Edition
Coder<T1,T2> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : Coder<T1,T2> Class

Glossary Item Box

Pair of arbitrary encoder/decoder objects.

Object Model

Coder<T1,T2> Class

Syntax

Visual Basic (Declaration)
Public Class Coder
    (Of T1,T2)
C#
public class Coder<T1,T2>

Type Parameters

T1
The type of objects to be encoded.
T2
The type of result object.

Remarks

This record should not be used directly in application code.It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.Coder<T1,T2>
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoder<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coder<T1,T2> Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


Coder<T1,T2> Class Members

[image]
ActiveReports 19 .NET Edition
Coder<T1,T2> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : Coder<T1,T2> Class

Glossary Item Box

The following tables list the members exposed by Coder<T1,T2>.

Public Constructors

 | Name | Description
Public Constructor | Coder<T1,T2> Constructor | Pair of arbitrary encoder/decoder objects.
Top

Public Properties

 | Name | Description
Public Property | Decode |
Public Property | Encode |
Top

See Also

Reference

Coder<T1,T2> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


Coder<T1,T2> Constructor

[image]
ActiveReports 19 .NET Edition
Coder<T1,T2> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > Coder<T1,T2> Class : Coder<T1,T2> Constructor

Encode
A function that takes an object of type T1 and encodes it into an T2.
Decode
A function that takes an T2 and decodes it into an object of type T1.

Glossary Item Box

Pair of arbitrary encoder/decoder objects.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Encode As Func(Of T1,T2), _
   ByVal Decode As Func(Of T2,T1) _
)
C#
public Coder<T1,T2>(
   Func<T1,T2> Encode,
   Func<T2,T1> Decode
)

Parameters

Encode
A function that takes an object of type T1 and encodes it into an T2.
Decode
A function that takes an T2 and decodes it into an object of type T1.

Remarks

This record should not be used directly in application code.It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coder<T1,T2> Class
Coder<T1,T2> Members


Coder<T1,T2> Class Properties

[image]
ActiveReports 19 .NET Edition
Coder<T1,T2> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : Coder<T1,T2> Class

Glossary Item Box

For a list of all members of this type, see Coder<T1,T2> members.

Public Properties

 | Name | Description
Public Property | Decode |
Public Property | Encode |
Top

See Also

Reference

Coder<T1,T2> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


Decode Property

[image]
ActiveReports 19 .NET Edition
Decode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > Coder<T1,T2> Class : Decode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Decode As Func(Of T2,T1)
C#
public Func<T2,T1> Decode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coder<T1,T2> Class
Coder<T1,T2> Members


Encode Property

[image]
ActiveReports 19 .NET Edition
Encode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > Coder<T1,T2> Class : Encode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encode As Func(Of T1,T2)
C#
public Func<T1,T2> Encode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coder<T1,T2> Class
Coder<T1,T2> Members


JsonCoder<T> Class

T
The type of objects to be encoded and decoded.
[image]
ActiveReports 19 .NET Edition
JsonCoder<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoder<T> Class

Glossary Item Box

Represents a JSON coder that encodes and decodes objects of type T to and from JSON variants.

Object Model

JsonCoder<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class JsonCoder(Of T)
   Inherits GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.Coder(Of T,IJsonVariant)
C#
public sealed class JsonCoder<T> : GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.Coder<T,IJsonVariant>

Type Parameters

T
The type of objects to be encoded and decoded.

Remarks

This record should not be used directly in application code.It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.Coder<T1,T2>
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoder<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoder<T> Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonCoder<T> Class Members

[image]
ActiveReports 19 .NET Edition
JsonCoder<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoder<T> Class

Glossary Item Box

The following tables list the members exposed by JsonCoder<T>.

Public Constructors

 | Name | Description
Public Constructor | JsonCoder<T> Constructor | Represents a JSON coder that encodes and decodes objects of type T to and from JSON variants.
Top

See Also

Reference

JsonCoder<T> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonCoder<T> Constructor

[image]
ActiveReports 19 .NET Edition
JsonCoder<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoder<T> Class : JsonCoder<T> Constructor

Encode
A function that takes an object of type T and encodes it into an GrapeCity.ActiveReports.Rdl.Json.Common.IJsonVariant.
Decode
A function that takes an GrapeCity.ActiveReports.Rdl.Json.Common.IJsonVariant and decodes it into an object of type T.

Glossary Item Box

Represents a JSON coder that encodes and decodes objects of type T to and from JSON variants.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Encode As Func(Of T,IJsonVariant), _
   ByVal Decode As Func(Of IJsonVariant,T) _
)
C#
public JsonCoder<T>(
   Func<T,IJsonVariant> Encode,
   Func<IJsonVariant,T> Decode
)

Parameters

Encode
A function that takes an object of type T and encodes it into an GrapeCity.ActiveReports.Rdl.Json.Common.IJsonVariant.
Decode
A function that takes an GrapeCity.ActiveReports.Rdl.Json.Common.IJsonVariant and decodes it into an object of type T.

Remarks

This record should not be used directly in application code.It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoder<T> Class
JsonCoder<T> Members


JsonCoders Class

[image]
ActiveReports 19 .NET Edition
JsonCoders Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoders Class

Glossary Item Box

Represents the JSON coders for various data types.

Object Model

JsonCoders Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class JsonCoders
C#
public static class JsonCoders

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonCoders Class Members

[image]
ActiveReports 19 .NET Edition
JsonCoders Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoders Class

Glossary Item Box

The following tables list the members exposed by JsonCoders.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Bool | Gets a coder for the System.Boolean type.
static (Shared in Visual Basic) | BoolDefFalse | Gets a coder for the System.Boolean type with a default value of an false.
static (Shared in Visual Basic) | Double | Gets a coder for the System.Double type.
static (Shared in Visual Basic) | Int | Gets a coder for the System.Int32 type.
static (Shared in Visual Basic) | IntDefZero | Gets a coder for the System.Int32 type with a default value of 0.
static (Shared in Visual Basic) | NullableDouble | Gets a coder for the nullable System.Double type.
static (Shared in Visual Basic) | String | Gets a coder for the System.String type.
static (Shared in Visual Basic) | StringDefEmpty | Gets a coder for the System.String type with a default value of an empty string.
static (Shared in Visual Basic) | StringDefNull | Gets a coder for the System.String type with a default value of null.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Collection<T,TCollection> | Gets a coder for the Collection type.
static (Shared in Visual Basic) | CollectionDefEmpty<T,TCollection> | Gets a coder for the Collection type with a default value of an empty collection.
static (Shared in Visual Basic) | CollectionDefNull<T,TCollection> | Gets a coder for the Collection type with a default value of null.
static (Shared in Visual Basic) | Default<T> | Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.
static (Shared in Visual Basic) | Enum<T> | Gets a coder for the GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoders.Enum``1 type.
static (Shared in Visual Basic) | List<T> | Gets a coder for the IList type.
static (Shared in Visual Basic) | ListDefEmpty<T> | Gets a coder for the IList type with a default value of empty list.
static (Shared in Visual Basic) | NullAsUndefined<T> | if variant value is undefined it will be converted to null instead During deserialization, the null value will be replaced with the undefiend variant should be usedin in combination with Default coder
static (Shared in Visual Basic) | Optional | Overloaded. Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.
Top

See Also

Reference

JsonCoders Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonCoders Class Methods

[image]
ActiveReports 19 .NET Edition
JsonCoders Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoders Class

Glossary Item Box

For a list of all members of this type, see JsonCoders members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Collection<T,TCollection> | Gets a coder for the Collection type.
static (Shared in Visual Basic) | CollectionDefEmpty<T,TCollection> | Gets a coder for the Collection type with a default value of an empty collection.
static (Shared in Visual Basic) | CollectionDefNull<T,TCollection> | Gets a coder for the Collection type with a default value of null.
static (Shared in Visual Basic) | Default<T> | Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.
static (Shared in Visual Basic) | Enum<T> | Gets a coder for the GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoders.Enum``1 type.
static (Shared in Visual Basic) | List<T> | Gets a coder for the IList type.
static (Shared in Visual Basic) | ListDefEmpty<T> | Gets a coder for the IList type with a default value of empty list.
static (Shared in Visual Basic) | NullAsUndefined<T> | if variant value is undefined it will be converted to null instead During deserialization, the null value will be replaced with the undefiend variant should be usedin in combination with Default coder
static (Shared in Visual Basic) | Optional | Overloaded. Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.
Top

See Also

Reference

JsonCoders Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


Collection<T,TCollection> Method

T
The type of the value.
TCollection
The collection of the Collection values.
[image]
ActiveReports 19 .NET Edition
Collection<T,TCollection> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Collection<T,TCollection> Method

itemCoder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Gets a coder for the Collection type.

Syntax

Visual Basic (Declaration)
Public Shared Function Collection
    (Of T,TCollection As {New, Collection(Of T)})( _
   ByVal itemCoder As JsonCoder(Of T) _
) As JsonCoder(Of TCollection)
C#
public static JsonCoder<TCollection> Collection<T,TCollection>(
   JsonCoder<T> itemCoder
)
where TCollection: new(), Collection<T>

Parameters

itemCoder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the value.
TCollection
The collection of the Collection values.

Return Value

A JsonCoder<T> with the default value handling.

Exceptions

Exception | Description
System.FormatException | Thrown if the value is not a array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


CollectionDefEmpty<T,TCollection> Method

T
The type of the value.
TCollection
The collection of the Collection values.
[image]
ActiveReports 19 .NET Edition
CollectionDefEmpty<T,TCollection> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : CollectionDefEmpty<T,TCollection> Method

itemCoder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Gets a coder for the Collection type with a default value of an empty collection.

Syntax

Visual Basic (Declaration)
Public Shared Function CollectionDefEmpty
    (Of T,TCollection As {New, Collection(Of T)})( _
   ByVal itemCoder As JsonCoder(Of T) _
) As JsonCoder(Of TCollection)
C#
public static JsonCoder<TCollection> CollectionDefEmpty<T,TCollection>(
   JsonCoder<T> itemCoder
)
where TCollection: new(), Collection<T>

Parameters

itemCoder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the value.
TCollection
The collection of the Collection values.

Return Value

A JsonCoder<T> with the default value handling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


CollectionDefNull<T,TCollection> Method

T
The type of the value.
TCollection
The collection of the Collection values.
[image]
ActiveReports 19 .NET Edition
CollectionDefNull<T,TCollection> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : CollectionDefNull<T,TCollection> Method

itemCoder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Gets a coder for the Collection type with a default value of null.

Syntax

Visual Basic (Declaration)
Public Shared Function CollectionDefNull
    (Of T,TCollection As {New, Collection(Of T)})( _
   ByVal itemCoder As JsonCoder(Of T) _
) As JsonCoder(Of TCollection)
C#
public static JsonCoder<TCollection> CollectionDefNull<T,TCollection>(
   JsonCoder<T> itemCoder
)
where TCollection: new(), Collection<T>

Parameters

itemCoder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the value.
TCollection
The collection of the Collection values.

Return Value

A JsonCoder<T> with the default value handling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Default<T> Method

T
A type of the value.
[image]
ActiveReports 19 .NET Edition
Default<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Default<T> Method

coder
The current JsonCoder<T> to encode and decode the value.
defValue
A default value.

Glossary Item Box

Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.

Syntax

Visual Basic (Declaration)
Public Shared Function Default(Of T)( _
   ByVal coder As JsonCoder(Of T), _
   ByVal defValue As T _
) As JsonCoder(Of T)
C#
public static JsonCoder<T> Default<T>(
   JsonCoder<T> coder,
   T defValue
)

Parameters

coder
The current JsonCoder<T> to encode and decode the value.
defValue
A default value.

Type Parameters

T
A type of the value.

Return Value

A JsonCoder<T> with the default value handling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Enum<T> Method

T
[image]
ActiveReports 19 .NET Edition
Enum<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Enum<T> Method

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonCoders.Enum``1 type.

Syntax

Visual Basic (Declaration)
Public Shared Function Enum(Of T As Enum)() As JsonCoder(Of T)
C#
public static JsonCoder<T> Enum<T>()
where T: Enum

Type Parameters

T

Exceptions

Exception | Description
System.FormatException | Thrown if the value is not a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


List<T> Method

T
The type of the value.
[image]
ActiveReports 19 .NET Edition
List<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : List<T> Method

itemCoder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Gets a coder for the IList type.

Syntax

Visual Basic (Declaration)
Public Shared Function List(Of T)( _
   ByVal itemCoder As JsonCoder(Of T) _
) As JsonCoder(Of IList(Of T))
C#
public static JsonCoder<IList<T>> List<T>(
   JsonCoder<T> itemCoder
)

Parameters

itemCoder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the value.

Return Value

A JsonCoder<T> with the default value handling.

Exceptions

Exception | Description
System.FormatException | Thrown if the value is not a array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


ListDefEmpty<T> Method

T
The type of the value.
[image]
ActiveReports 19 .NET Edition
ListDefEmpty<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : ListDefEmpty<T> Method

itemCoder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Gets a coder for the IList type with a default value of empty list.

Syntax

Visual Basic (Declaration)
Public Shared Function ListDefEmpty(Of T)( _
   ByVal itemCoder As JsonCoder(Of T) _
) As JsonCoder(Of IList(Of T))
C#
public static JsonCoder<IList<T>> ListDefEmpty<T>(
   JsonCoder<T> itemCoder
)

Parameters

itemCoder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the value.

Return Value

A JsonCoder<T> with the default value handling.

Exceptions

Exception | Description
System.FormatException | Thrown if the value is not a array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


NullAsUndefined<T> Method

T
A type of the value.
[image]
ActiveReports 19 .NET Edition
NullAsUndefined<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : NullAsUndefined<T> Method

coder
The current JsonCoder<T> to encode and decode the value.

Glossary Item Box

if variant value is undefined it will be converted to null instead During deserialization, the null value will be replaced with the undefiend variant should be usedin in combination with Default coder

Syntax

Visual Basic (Declaration)
Public Shared Function NullAsUndefined(Of T)( _
   ByVal coder As JsonCoder(Of T) _
) As JsonCoder(Of T)
C#
public static JsonCoder<T> NullAsUndefined<T>(
   JsonCoder<T> coder
)

Parameters

coder
The current JsonCoder<T> to encode and decode the value.

Type Parameters

T
A type of the value.

Return Value

A JsonCoder<T> with the default value handling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Optional Method

[image]
ActiveReports 19 .NET Edition
Optional Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Optional Method

Glossary Item Box

Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.

Overload List

Overload | Description
Optional<T>(JsonCoder<T>,T) | Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.
Optional<T>(JsonCoder<T>) | Skips empty objects during serialization and deserializes undefined values as a default object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Optional<T>(JsonCoder<T>,T) Method

T
The type of the value.
[image]
ActiveReports 19 .NET Edition
Optional<T>(JsonCoder<T>,T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class > Optional Method : Optional<T>(JsonCoder<T>,T) Method

coder
A JsonCoder<T> to encode and decode the value.
defValue
The default value.

Glossary Item Box

Encodes the specified default value as undefined and skips it during serialization. During deserialization, the undefined value will be replaced with the specified default value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Optional(Of T)( _
   ByVal coder As JsonCoder(Of T), _
   ByVal defValue As T _
) As JsonCoder(Of T)
C#
public static JsonCoder<T> Optional<T>(
   JsonCoder<T> coder,
   T defValue
)

Parameters

coder
A JsonCoder<T> to encode and decode the value.
defValue
The default value.

Type Parameters

T
The type of the value.

Return Value

A JsonCoder<T> with the default value handling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members
Overload List


Optional<T>(JsonCoder<T>) Method

T
The type of the object to be encoded and decoded.
[image]
ActiveReports 19 .NET Edition
Optional<T>(JsonCoder<T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class > Optional Method : Optional<T>(JsonCoder<T>) Method

coder
A JsonCoder<T> to encode and decode the value.

Glossary Item Box

Skips empty objects during serialization and deserializes undefined values as a default object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Optional(Of T)( _
   ByVal coder As JsonCoder(Of T) _
) As JsonCoder(Of T)
C#
public static JsonCoder<T> Optional<T>(
   JsonCoder<T> coder
)

Parameters

coder
A JsonCoder<T> to encode and decode the value.

Type Parameters

T
The type of the object to be encoded and decoded.

Return Value

A JsonCoder<T> that handles optional values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members
Overload List


JsonCoders Class Fields

[image]
ActiveReports 19 .NET Edition
JsonCoders Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonCoders Class

Glossary Item Box

For a list of all members of this type, see JsonCoders members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Bool | Gets a coder for the System.Boolean type.
static (Shared in Visual Basic) | BoolDefFalse | Gets a coder for the System.Boolean type with a default value of an false.
static (Shared in Visual Basic) | Double | Gets a coder for the System.Double type.
static (Shared in Visual Basic) | Int | Gets a coder for the System.Int32 type.
static (Shared in Visual Basic) | IntDefZero | Gets a coder for the System.Int32 type with a default value of 0.
static (Shared in Visual Basic) | NullableDouble | Gets a coder for the nullable System.Double type.
static (Shared in Visual Basic) | String | Gets a coder for the System.String type.
static (Shared in Visual Basic) | StringDefEmpty | Gets a coder for the System.String type with a default value of an empty string.
static (Shared in Visual Basic) | StringDefNull | Gets a coder for the System.String type with a default value of null.
Top

See Also

Reference

JsonCoders Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


Bool Field

[image]
ActiveReports 19 .NET Edition
Bool Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Bool Field

Glossary Item Box

Gets a coder for the System.Boolean type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Bool As JsonCoder(Of Boolean)
C#
public static readonly JsonCoder<bool> Bool

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


BoolDefFalse Field

[image]
ActiveReports 19 .NET Edition
BoolDefFalse Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : BoolDefFalse Field

Glossary Item Box

Gets a coder for the System.Boolean type with a default value of an false.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BoolDefFalse As JsonCoder(Of Boolean)
C#
public static readonly JsonCoder<bool> BoolDefFalse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Double Field

[image]
ActiveReports 19 .NET Edition
Double Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Double Field

Glossary Item Box

Gets a coder for the System.Double type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Double As JsonCoder(Of Double)
C#
public static readonly JsonCoder<double> Double

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


Int Field

[image]
ActiveReports 19 .NET Edition
Int Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : Int Field

Glossary Item Box

Gets a coder for the System.Int32 type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Int As JsonCoder(Of Integer)
C#
public static readonly JsonCoder<int> Int

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


IntDefZero Field

[image]
ActiveReports 19 .NET Edition
IntDefZero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : IntDefZero Field

Glossary Item Box

Gets a coder for the System.Int32 type with a default value of 0.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly IntDefZero As JsonCoder(Of Integer)
C#
public static readonly JsonCoder<int> IntDefZero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


NullableDouble Field

[image]
ActiveReports 19 .NET Edition
NullableDouble Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : NullableDouble Field

Glossary Item Box

Gets a coder for the nullable System.Double type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NullableDouble As JsonCoder(Of Nullable(Of Double))
C#
public static readonly JsonCoder<Nullable<double>> NullableDouble

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


String Field

[image]
ActiveReports 19 .NET Edition
String Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : String Field

Glossary Item Box

Gets a coder for the System.String type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly String As JsonCoder(Of String)
C#
public static readonly JsonCoder<string> String

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


StringDefEmpty Field

[image]
ActiveReports 19 .NET Edition
StringDefEmpty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : StringDefEmpty Field

Glossary Item Box

Gets a coder for the System.String type with a default value of an empty string.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StringDefEmpty As JsonCoder(Of String)
C#
public static readonly JsonCoder<string> StringDefEmpty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


StringDefNull Field

[image]
ActiveReports 19 .NET Edition
StringDefNull Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonCoders Class : StringDefNull Field

Glossary Item Box

Gets a coder for the System.String type with a default value of null.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StringDefNull As JsonCoder(Of String)
C#
public static readonly JsonCoder<string> StringDefNull

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonCoders Class
JsonCoders Members


JsonConverterBuilder Class

[image]
ActiveReports 19 .NET Edition
JsonConverterBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonConverterBuilder Class

Glossary Item Box

Represents a builder for the external report items json serializers.

Object Model

JsonConverterBuilder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class JsonConverterBuilder
C#
public static class JsonConverterBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonConverterBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterBuilder Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonConverterBuilder Class Members

[image]
ActiveReports 19 .NET Edition
JsonConverterBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonConverterBuilder Class

Glossary Item Box

The following tables list the members exposed by JsonConverterBuilder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildConverter<TConverterItem,TItem> | Builds a JSON converter for the specified item type using the provided builder.
static (Shared in Visual Basic) | Type<TItem> | Creates a new JsonObjectCoderBuilder<TObject> instance for the specified type.
Top

See Also

Reference

JsonConverterBuilder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonConverterBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
JsonConverterBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonConverterBuilder Class

Glossary Item Box

For a list of all members of this type, see JsonConverterBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildConverter<TConverterItem,TItem> | Builds a JSON converter for the specified item type using the provided builder.
static (Shared in Visual Basic) | Type<TItem> | Creates a new JsonObjectCoderBuilder<TObject> instance for the specified type.
Top

See Also

Reference

JsonConverterBuilder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


BuildConverter<TConverterItem,TItem> Method

TConverterItem
The base type of the items to be converted.
TItem
The specific type of the items to be converted, which must derive from TConverterItem.
[image]
ActiveReports 19 .NET Edition
BuildConverter<TConverterItem,TItem> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonConverterBuilder Class : BuildConverter<TConverterItem,TItem> Method

builder
The builder used to configure the JSON object coder.

Glossary Item Box

Builds a JSON converter for the specified item type using the provided builder.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildConverter
    (Of TConverterItem,TItem As {New, TConverterItem})( _
   ByVal builder As JsonObjectCoderBuilder(Of TItem) _
) As JsonConverter(Of TConverterItem)
C#
public static JsonConverter<TConverterItem> BuildConverter<TConverterItem,TItem>(
   JsonObjectCoderBuilder<TItem> builder
)
where TItem: new(), TConverterItem

Parameters

builder
The builder used to configure the JSON object coder.

Type Parameters

TConverterItem
The base type of the items to be converted.
TItem
The specific type of the items to be converted, which must derive from TConverterItem.

Return Value

A new instance of JsonConverter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterBuilder Class
JsonConverterBuilder Members


Type<TItem> Method

TItem
The type of the item to build a JSON object coder for.
[image]
ActiveReports 19 .NET Edition
Type<TItem> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonConverterBuilder Class : Type<TItem> Method

Glossary Item Box

Creates a new JsonObjectCoderBuilder<TObject> instance for the specified type.

Syntax

Visual Basic (Declaration)
Public Shared Function Type(Of TItem As {New})() As JsonObjectCoderBuilder(Of TItem)
C#
public static JsonObjectCoderBuilder<TItem> Type<TItem>()
where TItem: new()

Type Parameters

TItem
The type of the item to build a JSON object coder for.

Return Value

A new instance of JsonObjectCoderBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterBuilder Class
JsonConverterBuilder Members


JsonObjectCoderBuilder<TObject> Class

TObject
[image]
ActiveReports 19 .NET Edition
JsonObjectCoderBuilder<TObject> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonObjectCoderBuilder<TObject> Class

Glossary Item Box

Represents the builder for the JSON object coder.

Object Model

JsonObjectCoderBuilder<TObject> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class JsonObjectCoderBuilder(Of TObject As {New})
C#
public sealed class JsonObjectCoderBuilder<TObject>
where TObject: new()

Type Parameters

TObject

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonObjectCoderBuilder<TObject>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonObjectCoderBuilder<TObject> Class Members

[image]
ActiveReports 19 .NET Edition
JsonObjectCoderBuilder<TObject> Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonObjectCoderBuilder<TObject> Class

Glossary Item Box

The following tables list the members exposed by JsonObjectCoderBuilder<TObject>.

Public Constructors

 | Name | Description
Public Constructor | JsonObjectCoderBuilder<TObject> Constructor |
Top

Public Methods

 | Name | Description
Public Method | End | Gets a coder for the %% type.
Public Method | Prop | Overloaded. Adds a property to the JSON object coder with the specified name, getter, and coder.
Public Method | Sub<TProperty> | Adds a child bject properties to the JSON object coder with the specified getter, and coder.
Top

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonObjectCoderBuilder<TObject> Constructor

[image]
ActiveReports 19 .NET Edition
JsonObjectCoderBuilder<TObject> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class : JsonObjectCoderBuilder<TObject> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public JsonObjectCoderBuilder<TObject>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members


JsonObjectCoderBuilder<TObject> Class Methods

[image]
ActiveReports 19 .NET Edition
JsonObjectCoderBuilder<TObject> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonObjectCoderBuilder<TObject> Class

Glossary Item Box

For a list of all members of this type, see JsonObjectCoderBuilder<TObject> members.

Public Methods

 | Name | Description
Public Method | End | Gets a coder for the %% type.
Public Method | Prop | Overloaded. Adds a property to the JSON object coder with the specified name, getter, and coder.
Public Method | Sub<TProperty> | Adds a child bject properties to the JSON object coder with the specified getter, and coder.
Top

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


End Method

[image]
ActiveReports 19 .NET Edition
End Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class : End Method

Glossary Item Box

Gets a coder for the scrap:condition=communityenabled,name=_COMMUNITY_SECTION,contenttype=summary%%

Syntax

Visual Basic (Declaration)
Public Function End() As JsonCoder(Of TObject)
C#
public JsonCoder<TObject> End()

Return Value

A JsonCoder<T> to encode and decode the object.

Exceptions

Exception | Description
System.ArgumentException | Thrown if the value is not a object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members


Prop Method

[image]
ActiveReports 19 .NET Edition
Prop Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class : Prop Method

Glossary Item Box

Adds a property to the JSON object coder with the specified name, getter, and coder.

Overload List

Overload | Description
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) | Adds a property to the JSON object coder with the specified name, getter, and coder.
Prop<TProperty>(Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) | Adds a property to the JSON object coder with the specified getter and coder. The property name is derived from the expression.
Prop<TProperty>(String,JsonCoder<TProperty>,Func<TObject,TProperty>,Action<TObject,TProperty>,Func<TProperty,Boolean>) | Adds a property to the JSON object coder with the specified name, coder, getter function, and setter function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members


Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class > Prop Method : Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method

name
A System.String value indicating the name of the property in the JSON object.
getter
An System.Linq.Expressions.Expression object to get the property value from the object.
coder
A JsonCoder<T> used to encode and decode the property value.
skipOnWrite
A function with condition to skip writing the property.

Glossary Item Box

Adds a property to the JSON object coder with the specified name, getter, and coder.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As JsonCoder(Of TProperty), _
   Optional ByVal skipOnWrite As Func(Of TProperty,Boolean) _
) As JsonObjectCoderBuilder(Of TObject)
C#
public JsonObjectCoderBuilder<TObject> Prop<TProperty>(
   string name,
   Expression<Func<TObject,TProperty>> getter,
   JsonCoder<TProperty> coder,
   Func<TProperty,bool> skipOnWrite
)

Parameters

name
A System.String value indicating the name of the property in the JSON object.
getter
An System.Linq.Expressions.Expression object to get the property value from the object.
coder
A JsonCoder<T> used to encode and decode the property value.
skipOnWrite
A function with condition to skip writing the property.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of JsonObjectCoderBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members
Overload List


Prop<TProperty>(Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class > Prop Method : Prop<TProperty>(Expression<Func<TObject,TProperty>>,JsonCoder<TProperty>,Func<TProperty,Boolean>) Method

getter
An System.Linq.Expressions.Expression object to get the property value from the object.
coder
A JsonCoder<T> used to encode and decode the property value.
skipOnWrite
A function with condition to skip writing the property.

Glossary Item Box

Adds a property to the JSON object coder with the specified getter and coder. The property name is derived from the expression.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As JsonCoder(Of TProperty), _
   Optional ByVal skipOnWrite As Func(Of TProperty,Boolean) _
) As JsonObjectCoderBuilder(Of TObject)
C#
public JsonObjectCoderBuilder<TObject> Prop<TProperty>(
   Expression<Func<TObject,TProperty>> getter,
   JsonCoder<TProperty> coder,
   Func<TProperty,bool> skipOnWrite
)

Parameters

getter
An System.Linq.Expressions.Expression object to get the property value from the object.
coder
A JsonCoder<T> used to encode and decode the property value.
skipOnWrite
A function with condition to skip writing the property.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of JsonObjectCoderBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members
Overload List


Prop<TProperty>(String,JsonCoder<TProperty>,Func<TObject,TProperty>,Action<TObject,TProperty>,Func<TProperty,Boolean>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(String,JsonCoder<TProperty>,Func<TObject,TProperty>,Action<TObject,TProperty>,Func<TProperty,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class > Prop Method : Prop<TProperty>(String,JsonCoder<TProperty>,Func<TObject,TProperty>,Action<TObject,TProperty>,Func<TProperty,Boolean>) Method

name
A System.String value indicating the name of the property in the JSON object.
coder
A JsonCoder<T> used to encode and decode the property value.
getterFn
A function to get the property value from the object.
setterFn
An action to set the property value in the object.
skipOnWrite
A function with condition to skip writing the property.

Glossary Item Box

Adds a property to the JSON object coder with the specified name, coder, getter function, and setter function.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal name As String, _
   ByVal coder As JsonCoder(Of TProperty), _
   ByVal getterFn As Func(Of TObject,TProperty), _
   ByVal setterFn As Action(Of TObject,TProperty), _
   Optional ByVal skipOnWrite As Func(Of TProperty,Boolean) _
) As JsonObjectCoderBuilder(Of TObject)
C#
public JsonObjectCoderBuilder<TObject> Prop<TProperty>(
   string name,
   JsonCoder<TProperty> coder,
   Func<TObject,TProperty> getterFn,
   Action<TObject,TProperty> setterFn,
   Func<TProperty,bool> skipOnWrite
)

Parameters

name
A System.String value indicating the name of the property in the JSON object.
coder
A JsonCoder<T> used to encode and decode the property value.
getterFn
A function to get the property value from the object.
setterFn
An action to set the property value in the object.
skipOnWrite
A function with condition to skip writing the property.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of JsonObjectCoderBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members
Overload List


Sub<TProperty> Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Sub<TProperty> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonObjectCoderBuilder<TObject> Class : Sub<TProperty> Method

getter
An System.Linq.Expressions.Expression object to get the property value from the object.
props
An System.Action for setting of an object properties to the object coder builder.
skipOnWrite
A function with condition to skip writing the property.

Glossary Item Box

Adds a child bject properties to the JSON object coder with the specified getter, and coder.

Syntax

Visual Basic (Declaration)
Public Function Sub(Of TProperty As {New})( _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal props As Action(Of JsonObjectCoderBuilder(Of TProperty)), _
   Optional ByVal skipOnWrite As Func(Of TProperty,Boolean) _
) As JsonObjectCoderBuilder(Of TObject)
C#
public JsonObjectCoderBuilder<TObject> Sub<TProperty>(
   Expression<Func<TObject,TProperty>> getter,
   Action<JsonObjectCoderBuilder<TProperty>> props,
   Func<TProperty,bool> skipOnWrite
)
where TProperty: new()

Parameters

getter
An System.Linq.Expressions.Expression object to get the property value from the object.
props
An System.Action for setting of an object properties to the object coder builder.
skipOnWrite
A function with condition to skip writing the property.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of JsonObjectCoderBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectCoderBuilder<TObject> Class
JsonObjectCoderBuilder<TObject> Members


JsonReportCoders Class

[image]
ActiveReports 19 .NET Edition
JsonReportCoders Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonReportCoders Class

Glossary Item Box

Represents a JSON coders for various types used in reports.

Object Model

JsonReportCoders Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class JsonReportCoders
C#
public static class JsonReportCoders

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.JsonReportCoders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonReportCoders Class Members

[image]
ActiveReports 19 .NET Edition
JsonReportCoders Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonReportCoders Class

Glossary Item Box

The following tables list the members exposed by JsonReportCoders.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Action type.
static (Shared in Visual Basic) | ActionParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.
static (Shared in Visual Basic) | ApplyParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParameter type.
static (Shared in Visual Basic) | ApplyParametersActionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParametersAction type.
static (Shared in Visual Basic) | CustomPropertyDefinitionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition type.
static (Shared in Visual Basic) | DataSetParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.
static (Shared in Visual Basic) | DrillthroughCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Drillthrough type.
static (Shared in Visual Basic) | DrillThroughParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type, difference from other coders that it should use "ParameterName" instead of "Name"
static (Shared in Visual Basic) | Expression | Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type.
static (Shared in Visual Basic) | ExpressionDefEmpty | Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type with an empty expression as the default value.
static (Shared in Visual Basic) | Expressions | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection type.
static (Shared in Visual Basic) | FilterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Filter type.
static (Shared in Visual Basic) | GroupingCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Grouping type.
static (Shared in Visual Basic) | Length | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type.
static (Shared in Visual Basic) | LengthDefZero | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type with GrapeCity.ActiveReports.PageReportModel.Length.Zero as the default value.
static (Shared in Visual Basic) | SortByCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.SortBy type.
Top

See Also

Reference

JsonReportCoders Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


JsonReportCoders Class Fields

[image]
ActiveReports 19 .NET Edition
JsonReportCoders Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : JsonReportCoders Class

Glossary Item Box

For a list of all members of this type, see JsonReportCoders members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Action type.
static (Shared in Visual Basic) | ActionParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.
static (Shared in Visual Basic) | ApplyParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParameter type.
static (Shared in Visual Basic) | ApplyParametersActionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParametersAction type.
static (Shared in Visual Basic) | CustomPropertyDefinitionCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition type.
static (Shared in Visual Basic) | DataSetParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.
static (Shared in Visual Basic) | DrillthroughCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Drillthrough type.
static (Shared in Visual Basic) | DrillThroughParameterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type, difference from other coders that it should use "ParameterName" instead of "Name"
static (Shared in Visual Basic) | Expression | Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type.
static (Shared in Visual Basic) | ExpressionDefEmpty | Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type with an empty expression as the default value.
static (Shared in Visual Basic) | Expressions | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection type.
static (Shared in Visual Basic) | FilterCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Filter type.
static (Shared in Visual Basic) | GroupingCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Grouping type.
static (Shared in Visual Basic) | Length | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type.
static (Shared in Visual Basic) | LengthDefZero | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type with GrapeCity.ActiveReports.PageReportModel.Length.Zero as the default value.
static (Shared in Visual Basic) | SortByCoder | Gets a coder for the GrapeCity.ActiveReports.PageReportModel.SortBy type.
Top

See Also

Reference

JsonReportCoders Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


ActionCoder Field

[image]
ActiveReports 19 .NET Edition
ActionCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : ActionCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Action type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ActionCoder As JsonCoder(Of Action)
C#
public static readonly JsonCoder<Action> ActionCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


ActionParameterCoder Field

[image]
ActiveReports 19 .NET Edition
ActionParameterCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : ActionParameterCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ActionParameterCoder As JsonCoder(Of Parameter)
C#
public static readonly JsonCoder<Parameter> ActionParameterCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


ApplyParameterCoder Field

[image]
ActiveReports 19 .NET Edition
ApplyParameterCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : ApplyParameterCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParameter type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ApplyParameterCoder As JsonCoder(Of ApplyParameter)
C#
public static readonly JsonCoder<ApplyParameter> ApplyParameterCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


ApplyParametersActionCoder Field

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : ApplyParametersActionCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ApplyParametersAction type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ApplyParametersActionCoder As JsonCoder(Of ApplyParametersAction)
C#
public static readonly JsonCoder<ApplyParametersAction> ApplyParametersActionCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


CustomPropertyDefinitionCoder Field

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : CustomPropertyDefinitionCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CustomPropertyDefinitionCoder As JsonCoder(Of CustomPropertyDefinition)
C#
public static readonly JsonCoder<CustomPropertyDefinition> CustomPropertyDefinitionCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


DataSetParameterCoder Field

[image]
ActiveReports 19 .NET Edition
DataSetParameterCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : DataSetParameterCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DataSetParameterCoder As JsonCoder(Of Parameter)
C#
public static readonly JsonCoder<Parameter> DataSetParameterCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


DrillthroughCoder Field

[image]
ActiveReports 19 .NET Edition
DrillthroughCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : DrillthroughCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Drillthrough type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DrillthroughCoder As JsonCoder(Of Drillthrough)
C#
public static readonly JsonCoder<Drillthrough> DrillthroughCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


DrillThroughParameterCoder Field

[image]
ActiveReports 19 .NET Edition
DrillThroughParameterCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : DrillThroughParameterCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Parameter type, difference from other coders that it should use "ParameterName" instead of "Name"

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DrillThroughParameterCoder As JsonCoder(Of Parameter)
C#
public static readonly JsonCoder<Parameter> DrillThroughParameterCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


Expression Field

[image]
ActiveReports 19 .NET Edition
Expression Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : Expression Field

Glossary Item Box

Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Expression As JsonCoder(Of ExpressionInfo)
C#
public static readonly JsonCoder<ExpressionInfo> Expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


ExpressionDefEmpty Field

[image]
ActiveReports 19 .NET Edition
ExpressionDefEmpty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : ExpressionDefEmpty Field

Glossary Item Box

Gets a coder for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo type with an empty expression as the default value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpressionDefEmpty As JsonCoder(Of ExpressionInfo)
C#
public static readonly JsonCoder<ExpressionInfo> ExpressionDefEmpty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


Expressions Field

[image]
ActiveReports 19 .NET Edition
Expressions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : Expressions Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Expressions As JsonCoder(Of IList(Of ExpressionInfo))
C#
public static readonly JsonCoder<IList<ExpressionInfo>> Expressions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


FilterCoder Field

[image]
ActiveReports 19 .NET Edition
FilterCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : FilterCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Filter type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FilterCoder As JsonCoder(Of Filter)
C#
public static readonly JsonCoder<Filter> FilterCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


GroupingCoder Field

[image]
ActiveReports 19 .NET Edition
GroupingCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : GroupingCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Grouping type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GroupingCoder As JsonCoder(Of Grouping)
C#
public static readonly JsonCoder<Grouping> GroupingCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : Length Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Length As JsonCoder(Of Length)
C#
public static readonly JsonCoder<Length> Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


LengthDefZero Field

[image]
ActiveReports 19 .NET Edition
LengthDefZero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : LengthDefZero Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.Length type with GrapeCity.ActiveReports.PageReportModel.Length.Zero as the default value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LengthDefZero As JsonCoder(Of Length)
C#
public static readonly JsonCoder<Length> LengthDefZero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


SortByCoder Field

[image]
ActiveReports 19 .NET Edition
SortByCoder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > JsonReportCoders Class : SortByCoder Field

Glossary Item Box

Gets a coder for the GrapeCity.ActiveReports.PageReportModel.SortBy type.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SortByCoder As JsonCoder(Of SortBy)
C#
public static readonly JsonCoder<SortBy> SortByCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReportCoders Class
JsonReportCoders Members


ReportItemBaseCoder Class

[image]
ActiveReports 19 .NET Edition
ReportItemBaseCoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : ReportItemBaseCoder Class

Glossary Item Box

Represents a JSON coders for the base GrapeCity.ActiveReports.PageReportModel.ReportItem class.

Object Model

ReportItemBaseCoder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemBaseCoder
C#
public static class ReportItemBaseCoder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json.ReportItemBaseCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemBaseCoder Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


ReportItemBaseCoder Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemBaseCoder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : ReportItemBaseCoder Class

Glossary Item Box

The following tables list the members exposed by ReportItemBaseCoder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReportItem<T> | Configures a JsonObjectCoderBuilder<TObject> to handle a specific report item type.
Top

See Also

Reference

ReportItemBaseCoder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


ReportItemBaseCoder Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemBaseCoder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace : ReportItemBaseCoder Class

Glossary Item Box

For a list of all members of this type, see ReportItemBaseCoder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReportItem<T> | Configures a JsonObjectCoderBuilder<TObject> to handle a specific report item type.
Top

See Also

Reference

ReportItemBaseCoder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace


ReportItem<T> Method

T
The type of the report item, which must derive from GrapeCity.ActiveReports.PageReportModel.ReportItem.
[image]
ActiveReports 19 .NET Edition
ReportItem<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Json Namespace > ReportItemBaseCoder Class : ReportItem<T> Method

coder
The current JsonObjectCoderBuilder<TObject> to configure.
typeName
A System.String value indicating the name of the report item type.

Glossary Item Box

Configures a JsonObjectCoderBuilder<TObject> to handle a specific report item type.

Syntax

Visual Basic (Declaration)
Public Shared Function ReportItem(Of T As {New, ReportItem})( _
   ByVal coder As JsonObjectCoderBuilder(Of T), _
   ByVal typeName As String _
) As JsonObjectCoderBuilder(Of T)
C#
public static JsonObjectCoderBuilder<T> ReportItem<T>(
   JsonObjectCoderBuilder<T> coder,
   string typeName
)
where T: new(), ReportItem

Parameters

coder
The current JsonObjectCoderBuilder<TObject> to configure.
typeName
A System.String value indicating the name of the report item type.

Type Parameters

T
The type of the report item, which must derive from GrapeCity.ActiveReports.PageReportModel.ReportItem.

Return Value

The configured JsonObjectCoderBuilder<TObject> instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemBaseCoder Class
ReportItemBaseCoder Members


SerializerBuilder Class

[image]
ActiveReports 19 .NET Edition
SerializerBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder Class

Glossary Item Box

Represents a set of methods for creating GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> instances.

Object Model

SerializerBuilder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SerializerBuilder
C#
public static class SerializerBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml.SerializerBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilder Class Members

[image]
ActiveReports 19 .NET Edition
SerializerBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder Class

Glossary Item Box

The following tables list the members exposed by SerializerBuilder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Collection | Overloaded. Creates a coder for serializing collections of items to/from XML.
static (Shared in Visual Basic) | Expressions | Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection objects.
static (Shared in Visual Basic) | Switch<TBaseItem> | Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of collections with different item types.
static (Shared in Visual Basic) | Type<T> | Creates a new SerializerBuilder.TypeBuilder<TObject> for the specified type.
Top

See Also

Reference

SerializerBuilder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
SerializerBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder Class

Glossary Item Box

For a list of all members of this type, see SerializerBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Collection | Overloaded. Creates a coder for serializing collections of items to/from XML.
static (Shared in Visual Basic) | Expressions | Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection objects.
static (Shared in Visual Basic) | Switch<TBaseItem> | Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of collections with different item types.
static (Shared in Visual Basic) | Type<T> | Creates a new SerializerBuilder.TypeBuilder<TObject> for the specified type.
Top

See Also

Reference

SerializerBuilder Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


Collection Method

[image]
ActiveReports 19 .NET Edition
Collection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class : Collection Method

Glossary Item Box

Creates a coder for serializing collections of items to/from XML.

Overload List

Overload | Description
Collection<TItem>(ObjectCoder<TItem>) | Creates a coder for serializing collections of items to/from XML.
Collection<TItem>(IXmlItemSerializer) | Creates a coder for serializing collections of items to/from XML.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members


Collection<TItem>(ObjectCoder<TItem>) Method

TItem
The type of the items in the collection.
[image]
ActiveReports 19 .NET Edition
Collection<TItem>(ObjectCoder<TItem>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class > Collection Method : Collection<TItem>(ObjectCoder<TItem>) Method

itemSerializer
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object for serializing individual items.

Glossary Item Box

Creates a coder for serializing collections of items to/from XML.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Collection(Of TItem)( _
   ByVal itemSerializer As Coders.ObjectCoder(Of TItem) _
) As Coders.ObjectCoder(Of ICollection(Of TItem))
C#
public static Coders.ObjectCoder<ICollection<TItem>> Collection<TItem>(
   Coders.ObjectCoder<TItem> itemSerializer
)

Parameters

itemSerializer
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object for serializing individual items.

Type Parameters

TItem
The type of the items in the collection.

Return Value

A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object which writes and reads collections of TItem to/from XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members
Overload List


Collection<TItem>(IXmlItemSerializer) Method

TItem
The type of the items in the collection.
[image]
ActiveReports 19 .NET Edition
Collection<TItem>(IXmlItemSerializer) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class > Collection Method : Collection<TItem>(IXmlItemSerializer) Method

itemSerializer
An GrapeCity.ActiveReports.Core.Rdl.Extensibility.IXmlItemSerializer object for serializing individual items.

Glossary Item Box

Creates a coder for serializing collections of items to/from XML.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Collection(Of TItem)( _
   ByVal itemSerializer As IXmlItemSerializer _
) As Coders.ObjectCoder(Of ICollection(Of TItem))
C#
public static Coders.ObjectCoder<ICollection<TItem>> Collection<TItem>(
   IXmlItemSerializer itemSerializer
)

Parameters

itemSerializer
An GrapeCity.ActiveReports.Core.Rdl.Extensibility.IXmlItemSerializer object for serializing individual items.

Type Parameters

TItem
The type of the items in the collection.

Return Value

The GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> instance which writes and reads collections of TItem to/from XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members
Overload List


Expressions Method

[image]
ActiveReports 19 .NET Edition
Expressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class : Expressions Method

elementName
A System.String value indicating the name of the XML element representing the collection item.

Glossary Item Box

Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection objects.

Syntax

Visual Basic (Declaration)
Public Shared Function Expressions( _
   ByVal elementName As String _
) As Coders.ObjectCoder(Of IList(Of ExpressionInfo))
C#
public static Coders.ObjectCoder<IList<ExpressionInfo>> Expressions(
   string elementName
)

Parameters

elementName
A System.String value indicating the name of the XML element representing the collection item.

Return Value

A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object which writes and reads the GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection object to/from XML format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members


Switch<TBaseItem> Method

TBaseItem
[image]
ActiveReports 19 .NET Edition
Switch<TBaseItem> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class : Switch<TBaseItem> Method

itemSerializer
A collection of item serializers with different item types.

Glossary Item Box

Creates a GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> type coder for the XML serialization of collections with different item types.

Syntax

Visual Basic (Declaration)
Public Shared Function Switch(Of TBaseItem)( _
   ByVal ParamArray itemSerializer() As IXmlItemSerializer _
) As Coders.ObjectCoder(Of TBaseItem)
C#
public static Coders.ObjectCoder<TBaseItem> Switch<TBaseItem>(
   params IXmlItemSerializer[] itemSerializer
)

Parameters

itemSerializer
A collection of item serializers with different item types.

Type Parameters

TBaseItem

Return Value

A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object which writes and reads collections of objects to/from XML format.

Remarks

The method should be used to create serializers for properties that can reference objects of different types, such as a collection of report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members


Type<T> Method

T
The type to create a serializer for. Must have a parameterless constructor.
[image]
ActiveReports 19 .NET Edition
Type<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder Class : Type<T> Method

itemName
A System.String value indicating the name of the XML element representing the type.
namespaceUri
A System.String value indicating the XML namespace URI.
version
A System.String value indicating the version of the XML schema. Default is null.

Glossary Item Box

Creates a new SerializerBuilder.TypeBuilder<TObject> for the specified type.

Syntax

Visual Basic (Declaration)
Public Shared Function Type(Of T As {New})( _
   ByVal itemName As String, _
   ByVal namespaceUri As String, _
   Optional ByVal version As String _
) As SerializerBuilder.TypeBuilder(Of T)
C#
public static SerializerBuilder.TypeBuilder<T> Type<T>(
   string itemName,
   string namespaceUri,
   string version
)
where T: new()

Parameters

itemName
A System.String value indicating the name of the XML element representing the type.
namespaceUri
A System.String value indicating the XML namespace URI.
version
A System.String value indicating the version of the XML schema. Default is null.

Type Parameters

T
The type to create a serializer for. Must have a parameterless constructor.

Return Value

A new instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder Class
SerializerBuilder Members


SerializerBuilder.TypeBuilder<TObject> Class

TObject
The type to create a serializer for. Must have a parameterless constructor.
[image]
ActiveReports 19 .NET Edition
SerializerBuilder.TypeBuilder<TObject> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder.TypeBuilder<TObject> Class

Glossary Item Box

Represents a builder for creating serializers for a specific type.

Object Model

SerializerBuilder.TypeBuilder<TObject> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SerializerBuilder.TypeBuilder(Of TObject As {New})
C#
public sealed class SerializerBuilder.TypeBuilder<TObject>
where TObject: new()

Type Parameters

TObject
The type to create a serializer for. Must have a parameterless constructor.

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml.SerializerBuilder.TypeBuilder<TObject>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilder.TypeBuilder<TObject> Class Members

[image]
ActiveReports 19 .NET Edition
SerializerBuilder.TypeBuilder<TObject> Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder.TypeBuilder<TObject> Class

Glossary Item Box

The following tables list the members exposed by SerializerBuilder.TypeBuilder<TObject>.

Public Methods

 | Name | Description
Public Method | Attr | Overloaded. Adds an attribute to the XML serializer for the specified property.
Public Method | CustomProp | Adds Custom property, reads and writes InnerXML
Public Method | Prop | Overloaded. Adds a property to the XML serializer.
Public Method | Sub | Write the some properties to the XML inside an additional element with specified name.
Top

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilder.TypeBuilder<TObject> Class Methods

[image]
ActiveReports 19 .NET Edition
SerializerBuilder.TypeBuilder<TObject> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilder.TypeBuilder<TObject> Class

Glossary Item Box

For a list of all members of this type, see SerializerBuilder.TypeBuilder<TObject> members.

Public Methods

 | Name | Description
Public Method | Attr | Overloaded. Adds an attribute to the XML serializer for the specified property.
Public Method | CustomProp | Adds Custom property, reads and writes InnerXML
Public Method | Prop | Overloaded. Adds a property to the XML serializer.
Public Method | Sub | Write the some properties to the XML inside an additional element with specified name.
Top

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


Attr Method

[image]
ActiveReports 19 .NET Edition
Attr Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class : Attr Method

Glossary Item Box

Adds an attribute to the XML serializer for the specified property.

Overload List

Overload | Description
Attr<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) | Adds an attribute to the XML serializer for the specified property.
Attr(String,Expression<Func<TObject,String>>) | Adds an optional string attribute to the XML serializer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members


Attr<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Attr<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Attr Method : Attr<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

name
A System.String value indicating the name of the attribute.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Glossary Item Box

Adds an attribute to the XML serializer for the specified property.

Syntax

Visual Basic (Declaration)
Public Overloads Function Attr(Of TProperty)( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As Coders.Coder(Of TProperty) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Attr<TProperty>(
   string name,
   Expression<Func<TObject,TProperty>> getter,
   Coders.Coder<TProperty> coder
)

Parameters

name
A System.String value indicating the name of the attribute.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Attr(String,Expression<Func<TObject,String>>) Method

[image]
ActiveReports 19 .NET Edition
Attr(String,Expression<Func<TObject,String>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Attr Method : Attr(String,Expression<Func<TObject,String>>) Method

name
A System.String value indicating the name of the attribute in XML.
getter
An System.Linq.Expressions.Expression object to get the attribute value.

Glossary Item Box

Adds an optional string attribute to the XML serializer.

Syntax

Visual Basic (Declaration)
Public Overloads Function Attr( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,String)) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Attr(
   string name,
   Expression<Func<TObject,string>> getter
)

Parameters

name
A System.String value indicating the name of the attribute in XML.
getter
An System.Linq.Expressions.Expression object to get the attribute value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


CustomProp Method

[image]
ActiveReports 19 .NET Edition
CustomProp Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class : CustomProp Method

getter
An System.Linq.Expressions.Expression object to get the property value.

Glossary Item Box

Adds Custom property, reads and writes InnerXML

Syntax

Visual Basic (Declaration)
Public Function CustomProp( _
   ByVal getter As Expression(Of Func(Of TObject,Custom)) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> CustomProp(
   Expression<Func<TObject,Custom>> getter
)

Parameters

getter
An System.Linq.Expressions.Expression object to get the property value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members


Prop Method

[image]
ActiveReports 19 .NET Edition
Prop Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class : Prop Method

Glossary Item Box

Adds a property to the XML serializer.

Overload List

Overload | Description
Prop<TProperty>(Expression<Func<TObject,TProperty>>,Coder<TProperty>) | Adds a property to the XML serializer.
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) | Adds a property to the XML serializer with a specified custom name.
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,ObjectCoder<TProperty>,Func<TProperty,Boolean>) | Adds a property to the XML serializer with a specified custom name and object coder.
Prop<TItem>(String,Expression<Func<TObject,TItem>>,TItem) | Adds an enumeration property to the XML serializer with a specified default value.
Prop(String,Expression<Func<TObject,Length>>,Length) | Adds a length property to the XML serializer with a specified default value.
Prop(Expression<Func<TObject,ExpressionInfo>>,ExpressionInfo) | Adds an expression property to the XML serializer with a specified default value.
Prop(String,Expression<Func<TObject,String>>) | Adds an optional string property to the XML serializer.
Prop(String,Expression<Func<TObject,Boolean>>,Boolean) | Adds a boolean property to the XML serializer with a specified default value.
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,IXmlItemSerializer,Func<TProperty,Boolean>,Func<TProperty>) | Adds a property to the XML serializer with a specified custom name and item serializer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members


Prop<TProperty>(Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop<TProperty>(Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Glossary Item Box

Adds a property to the XML serializer.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As Coders.Coder(Of TProperty) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop<TProperty>(
   Expression<Func<TObject,TProperty>> getter,
   Coders.Coder<TProperty> coder
)

Parameters

getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,Coder<TProperty>) Method

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Glossary Item Box

Adds a property to the XML serializer with a specified custom name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As Coders.Coder(Of TProperty) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop<TProperty>(
   string name,
   Expression<Func<TObject,TProperty>> getter,
   Coders.Coder<TProperty> coder
)

Parameters

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T> object to use for serialization.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,ObjectCoder<TProperty>,Func<TProperty,Boolean>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,ObjectCoder<TProperty>,Func<TProperty,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,ObjectCoder<TProperty>,Func<TProperty,Boolean>) Method

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object to use for serialization.
skipOnWrite
A function with condition to skip writing the property.

Glossary Item Box

Adds a property to the XML serializer with a specified custom name and object coder.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty)( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal coder As Coders.ObjectCoder(Of TProperty), _
   Optional ByVal skipOnWrite As Func(Of TProperty,Boolean) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop<TProperty>(
   string name,
   Expression<Func<TObject,TProperty>> getter,
   Coders.ObjectCoder<TProperty> coder,
   Func<TProperty,bool> skipOnWrite
)

Parameters

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
coder
A GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T> object to use for serialization.
skipOnWrite
A function with condition to skip writing the property.

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop<TItem>(String,Expression<Func<TObject,TItem>>,TItem) Method

TItem
The type of the enumeration.
[image]
ActiveReports 19 .NET Edition
Prop<TItem>(String,Expression<Func<TObject,TItem>>,TItem) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop<TItem>(String,Expression<Func<TObject,TItem>>,TItem) Method

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A TItem value indicating the default value of the enumeration.

Glossary Item Box

Adds an enumeration property to the XML serializer with a specified default value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TItem As {New, Enum, Struct})( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TItem)), _
   ByVal defaultValue As TItem _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop<TItem>(
   string name,
   Expression<Func<TObject,TItem>> getter,
   TItem defaultValue
)
where TItem: new(), Enum, struct

Parameters

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A TItem value indicating the default value of the enumeration.

Type Parameters

TItem
The type of the enumeration.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop(String,Expression<Func<TObject,Length>>,Length) Method

[image]
ActiveReports 19 .NET Edition
Prop(String,Expression<Func<TObject,Length>>,Length) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop(String,Expression<Func<TObject,Length>>,Length) Method

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A GrapeCity.ActiveReports.PageReportModel.Length value indicating the default value.

Glossary Item Box

Adds a length property to the XML serializer with a specified default value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,Length)), _
   ByVal defaultValue As Length _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop(
   string name,
   Expression<Func<TObject,Length>> getter,
   Length defaultValue
)

Parameters

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A GrapeCity.ActiveReports.PageReportModel.Length value indicating the default value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop(Expression<Func<TObject,ExpressionInfo>>,ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
Prop(Expression<Func<TObject,ExpressionInfo>>,ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop(Expression<Func<TObject,ExpressionInfo>>,ExpressionInfo) Method

getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
An System.Linq.Expressions.Expression object representing the default expression value.

Glossary Item Box

Adds an expression property to the XML serializer with a specified default value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop( _
   ByVal getter As Expression(Of Func(Of TObject,ExpressionInfo)), _
   ByVal defaultValue As ExpressionInfo _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop(
   Expression<Func<TObject,ExpressionInfo>> getter,
   ExpressionInfo defaultValue
)

Parameters

getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
An System.Linq.Expressions.Expression object representing the default expression value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop(String,Expression<Func<TObject,String>>) Method

[image]
ActiveReports 19 .NET Edition
Prop(String,Expression<Func<TObject,String>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop(String,Expression<Func<TObject,String>>) Method

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.

Glossary Item Box

Adds an optional string property to the XML serializer.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,String)) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop(
   string name,
   Expression<Func<TObject,string>> getter
)

Parameters

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop(String,Expression<Func<TObject,Boolean>>,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Prop(String,Expression<Func<TObject,Boolean>>,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop(String,Expression<Func<TObject,Boolean>>,Boolean) Method

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A System.Boolean value indicating the default value.

Glossary Item Box

Adds a boolean property to the XML serializer with a specified default value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,Boolean)), _
   ByVal defaultValue As Boolean _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop(
   string name,
   Expression<Func<TObject,bool>> getter,
   bool defaultValue
)

Parameters

name
A System.String value indicating the name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
defaultValue
A System.Boolean value indicating the default value.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,IXmlItemSerializer,Func<TProperty,Boolean>,Func<TProperty>) Method

TProperty
The type of the property.
[image]
ActiveReports 19 .NET Edition
Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,IXmlItemSerializer,Func<TProperty,Boolean>,Func<TProperty>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class > Prop Method : Prop<TProperty>(String,Expression<Func<TObject,TProperty>>,IXmlItemSerializer,Func<TProperty,Boolean>,Func<TProperty>) Method

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
serializer
An GrapeCity.ActiveReports.Core.Rdl.Extensibility.IXmlItemSerializer object to use for serialization.
SkipOnWrite
A delegate that determines whether to skip writing the property based on its value.
defaultValue
A delegate that gets the default value

Glossary Item Box

Adds a property to the XML serializer with a specified custom name and item serializer.

Syntax

Visual Basic (Declaration)
Public Overloads Function Prop(Of TProperty As {New})( _
   ByVal name As String, _
   ByVal getter As Expression(Of Func(Of TObject,TProperty)), _
   ByVal serializer As IXmlItemSerializer, _
   Optional ByVal SkipOnWrite As Func(Of TProperty,Boolean), _
   Optional ByVal defaultValue As Func(Of TProperty) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Prop<TProperty>(
   string name,
   Expression<Func<TObject,TProperty>> getter,
   IXmlItemSerializer serializer,
   Func<TProperty,bool> SkipOnWrite,
   Func<TProperty> defaultValue
)
where TProperty: new()

Parameters

name
A System.String value indicating the custom name of the property in XML.
getter
An System.Linq.Expressions.Expression object to get the property value.
serializer
An GrapeCity.ActiveReports.Core.Rdl.Extensibility.IXmlItemSerializer object to use for serialization.
SkipOnWrite
A delegate that determines whether to skip writing the property based on its value.
defaultValue
A delegate that gets the default value

Type Parameters

TProperty
The type of the property.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members
Overload List


Sub Method

[image]
ActiveReports 19 .NET Edition
Sub Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilder.TypeBuilder<TObject> Class : Sub Method

name
A System.String value indicating the custom element name for the properties.
action
An GrapeCity.ActiveReports.PageReportModel.Action to getting for a set of properties for an additional element.

Glossary Item Box

Write the some properties to the XML inside an additional element with specified name.

Syntax

Visual Basic (Declaration)
Public Function Sub( _
   ByVal name As String, _
   ByVal action As Action(Of SerializerBuilder.TypeBuilder(Of TObject)) _
) As SerializerBuilder.TypeBuilder(Of TObject)
C#
public SerializerBuilder.TypeBuilder<TObject> Sub(
   string name,
   Action<SerializerBuilder.TypeBuilder<TObject>> action
)

Parameters

name
A System.String value indicating the custom element name for the properties.
action
An GrapeCity.ActiveReports.PageReportModel.Action to getting for a set of properties for an additional element.

Return Value

The current instance of SerializerBuilder.TypeBuilder<TObject>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilder.TypeBuilder<TObject> Class
SerializerBuilder.TypeBuilder<TObject> Members


SerializerBuilderExtensions Class

[image]
ActiveReports 19 .NET Edition
SerializerBuilderExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilderExtensions Class

Glossary Item Box

Represents an extension methods for building XML serializers using the SerializerBuilder.

Object Model

SerializerBuilderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SerializerBuilderExtensions
C#
public static class SerializerBuilderExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml.SerializerBuilderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilderExtensions Members
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilderExtensions Class Members

[image]
ActiveReports 19 .NET Edition
SerializerBuilderExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilderExtensions Class

Glossary Item Box

The following tables list the members exposed by SerializerBuilderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildXmlSerializer<T> | Builds an XML serializer for the specified type using the provided SerializerBuilder.TypeBuilder<TObject>.
Top

See Also

Reference

SerializerBuilderExtensions Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


SerializerBuilderExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
SerializerBuilderExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace : SerializerBuilderExtensions Class

Glossary Item Box

For a list of all members of this type, see SerializerBuilderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildXmlSerializer<T> | Builds an XML serializer for the specified type using the provided SerializerBuilder.TypeBuilder<TObject>.
Top

See Also

Reference

SerializerBuilderExtensions Class
GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace


BuildXmlSerializer<T> Method

T
The type to build the XML serializer for. Must have a parameterless constructor.
[image]
ActiveReports 19 .NET Edition
BuildXmlSerializer<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Persistence.Xml Namespace > SerializerBuilderExtensions Class : BuildXmlSerializer<T> Method

builder
The SerializerBuilder.TypeBuilder<TObject> to use for building the XML serializer.

Glossary Item Box

Builds an XML serializer for the specified type using the provided SerializerBuilder.TypeBuilder<TObject>.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildXmlSerializer(Of T As {New})( _
   ByVal builder As SerializerBuilder.TypeBuilder(Of T) _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer BuildXmlSerializer<T>(
   SerializerBuilder.TypeBuilder<T> builder
)
where T: new()

Parameters

builder
The SerializerBuilder.TypeBuilder<TObject> to use for building the XML serializer.

Type Parameters

T
The type to build the XML serializer for. Must have a parameterless constructor.

Return Value

A new instance of GrapeCity.ActiveReports.Core.Rdl.Extensibility.IXmlItemSerializer for the specified type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializerBuilderExtensions Class
SerializerBuilderExtensions Members


Coders Class

[image]
ActiveReports 19 .NET Edition
Coders Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders Class

Glossary Item Box

Represents a collection of coder functions for encoding and decoding common types.

Object Model

Coders Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Coders
C#
public static class Coders

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders Class Members

[image]
ActiveReports 19 .NET Edition
Coders Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders Class

Glossary Item Box

The following tables list the members exposed by Coders.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Int | Gets a coder for integer values.
static (Shared in Visual Basic) | OptionalString | Gets a coder for strings with a null value as the default.
static (Shared in Visual Basic) | StringDefEmpty | Gets a coder for strings with an empty string as the default value.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IntDefZero | Gets a coder for integer values with 0 as the default value.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Bool | Overloaded. Creates a coder for boolean values.
static (Shared in Visual Basic) | Default<T> | Creates a coder with a default value.
static (Shared in Visual Basic) | Enum | Overloaded. Creates a coder for enumeration values.
static (Shared in Visual Basic) | SkipOnWrite<T> | Used for legacy properties which can be read but must not be written.
static (Shared in Visual Basic) | SkipOnWriteIf<T> | Creates a coder for objects with a value which shouldn't be written is satisfies the condition.
static (Shared in Visual Basic) | String | Creates a coder for strings with a default value.
Top

See Also

Reference

Coders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders Class Methods

[image]
ActiveReports 19 .NET Edition
Coders Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders Class

Glossary Item Box

For a list of all members of this type, see Coders members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Bool | Overloaded. Creates a coder for boolean values.
static (Shared in Visual Basic) | Default<T> | Creates a coder with a default value.
static (Shared in Visual Basic) | Enum | Overloaded. Creates a coder for enumeration values.
static (Shared in Visual Basic) | SkipOnWrite<T> | Used for legacy properties which can be read but must not be written.
static (Shared in Visual Basic) | SkipOnWriteIf<T> | Creates a coder for objects with a value which shouldn't be written is satisfies the condition.
static (Shared in Visual Basic) | String | Creates a coder for strings with a default value.
Top

See Also

Reference

Coders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Bool Method

[image]
ActiveReports 19 .NET Edition
Bool Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : Bool Method

Glossary Item Box

Creates a coder for boolean values.

Overload List

Overload | Description
Bool() | Creates a coder for boolean values.
Bool(Boolean) | Creates a coder for boolean values with a default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Bool() Method

[image]
ActiveReports 19 .NET Edition
Bool() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class > Bool Method : Bool() Method

Glossary Item Box

Creates a coder for boolean values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Bool() As Coders.Coder(Of Boolean)
C#
public static Coders.Coder<bool> Bool()

Return Value

A Coders.Coder<T> object for System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members
Overload List


Bool(Boolean) Method

[image]
ActiveReports 19 .NET Edition
Bool(Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class > Bool Method : Bool(Boolean) Method

defaultValue
A System.Boolean value indicating the default value.

Glossary Item Box

Creates a coder for boolean values with a default value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Bool( _
   ByVal defaultValue As Boolean _
) As Coders.Coder(Of Boolean)
C#
public static Coders.Coder<bool> Bool(
   bool defaultValue
)

Parameters

defaultValue
A System.Boolean value indicating the default value.

Return Value

A Coders.Coder<T> object for System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members
Overload List


Default<T> Method

T
The type to encode/decode.
[image]
ActiveReports 19 .NET Edition
Default<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : Default<T> Method

coder
The base coder.
defaultValue
The default value.

Glossary Item Box

Creates a coder with a default value.

Syntax

Visual Basic (Declaration)
Public Shared Function Default(Of T)( _
   ByVal coder As Coders.Coder(Of T), _
   ByVal defaultValue As T _
) As Coders.Coder(Of T)
C#
public static Coders.Coder<T> Default<T>(
   Coders.Coder<T> coder,
   T defaultValue
)

Parameters

coder
The base coder.
defaultValue
The default value.

Type Parameters

T
The type to encode/decode.

Return Value

A coder with a default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Enum Method

[image]
ActiveReports 19 .NET Edition
Enum Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : Enum Method

Glossary Item Box

Creates a coder for enumeration values.

Overload List

Overload | Description
Enum<T>() | Creates a coder for enumeration values.
Enum<T>(T) | Creates a coder for enumeration values with a default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Enum<T>() Method

T
The enumeration type.
[image]
ActiveReports 19 .NET Edition
Enum<T>() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class > Enum Method : Enum<T>() Method

Glossary Item Box

Creates a coder for enumeration values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Enum(Of T As Enum)() As Coders.Coder(Of T)
C#
public static Coders.Coder<T> Enum<T>()
where T: Enum

Type Parameters

T
The enumeration type.

Return Value

A Coders.Coder<T> object for the specified enumeration type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members
Overload List


Enum<T>(T) Method

T
The enumeration type.
[image]
ActiveReports 19 .NET Edition
Enum<T>(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class > Enum Method : Enum<T>(T) Method

defValue
The default enumeration value.

Glossary Item Box

Creates a coder for enumeration values with a default value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Enum(Of T As {New, Enum, Struct})( _
   ByVal defValue As T _
) As Coders.Coder(Of T)
C#
public static Coders.Coder<T> Enum<T>(
   T defValue
)
where T: new(), Enum, struct

Parameters

defValue
The default enumeration value.

Type Parameters

T
The enumeration type.

Return Value

A coder for the specified enumeration type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members
Overload List


SkipOnWrite<T> Method

T
The type to encode/decode.
[image]
ActiveReports 19 .NET Edition
SkipOnWrite<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : SkipOnWrite<T> Method

coder
The base coder.

Glossary Item Box

Used for legacy properties which can be read but must not be written.

Syntax

Visual Basic (Declaration)
Public Shared Function SkipOnWrite(Of T)( _
   ByVal coder As Coders.Coder(Of T) _
) As Coders.Coder(Of T)
C#
public static Coders.Coder<T> SkipOnWrite<T>(
   Coders.Coder<T> coder
)

Parameters

coder
The base coder.

Type Parameters

T
The type to encode/decode.

Return Value

A coder that skips writing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


SkipOnWriteIf<T> Method

T
[image]
ActiveReports 19 .NET Edition
SkipOnWriteIf<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : SkipOnWriteIf<T> Method

coder
skipCondition

Glossary Item Box

Creates a coder for objects with a value which shouldn't be written is satisfies the condition.

Syntax

Visual Basic (Declaration)
Public Shared Function SkipOnWriteIf(Of T)( _
   ByVal coder As Coders.Coder(Of T), _
   ByVal skipCondition As Func(Of T,Boolean) _
) As Coders.Coder(Of T)
C#
public static Coders.Coder<T> SkipOnWriteIf<T>(
   Coders.Coder<T> coder,
   Func<T,bool> skipCondition
)

Parameters

coder
skipCondition

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


String Method

[image]
ActiveReports 19 .NET Edition
String Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : String Method

def
A System.String value indicating the default value.

Glossary Item Box

Creates a coder for strings with a default value.

Syntax

Visual Basic (Declaration)
Public Shared Function String( _
   ByVal def As String _
) As Coders.Coder(Of String)
C#
public static Coders.Coder<string> String(
   string def
)

Parameters

def
A System.String value indicating the default value.

Return Value

A Coders.Coder<T> object for System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Coders Class Properties

[image]
ActiveReports 19 .NET Edition
Coders Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders Class

Glossary Item Box

For a list of all members of this type, see Coders members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IntDefZero | Gets a coder for integer values with 0 as the default value.
Top

See Also

Reference

Coders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


IntDefZero Property

[image]
ActiveReports 19 .NET Edition
IntDefZero Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : IntDefZero Property

Glossary Item Box

Gets a coder for integer values with 0 as the default value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IntDefZero As Coders.Coder(Of Integer)
C#
public static Coders.Coder<int> IntDefZero {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Coders Class Fields

[image]
ActiveReports 19 .NET Edition
Coders Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders Class

Glossary Item Box

For a list of all members of this type, see Coders members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Int | Gets a coder for integer values.
static (Shared in Visual Basic) | OptionalString | Gets a coder for strings with a null value as the default.
static (Shared in Visual Basic) | StringDefEmpty | Gets a coder for strings with an empty string as the default value.
Top

See Also

Reference

Coders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Int Field

[image]
ActiveReports 19 .NET Edition
Int Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : Int Field

Glossary Item Box

Gets a coder for integer values.

Syntax

Visual Basic (Declaration)
Public Shared Int As Coders.Coder(Of Integer)
C#
public static Coders.Coder<int> Int

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


OptionalString Field

[image]
ActiveReports 19 .NET Edition
OptionalString Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : OptionalString Field

Glossary Item Box

Gets a coder for strings with a null value as the default.

Syntax

Visual Basic (Declaration)
Public Shared OptionalString As Coders.Coder(Of String)
C#
public static Coders.Coder<string> OptionalString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


StringDefEmpty Field

[image]
ActiveReports 19 .NET Edition
StringDefEmpty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders Class : StringDefEmpty Field

Glossary Item Box

Gets a coder for strings with an empty string as the default value.

Syntax

Visual Basic (Declaration)
Public Shared StringDefEmpty As Coders.Coder(Of String)
C#
public static Coders.Coder<string> StringDefEmpty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders Class
Coders Members


Coders.Coder<T> Class

T
The type to encode/decode.
[image]
ActiveReports 19 .NET Edition
Coders.Coder<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.Coder<T> Class

Glossary Item Box

Represents a coder with encode and decode functions for a specific type.

Object Model

Coders.Coder<T> Class

Syntax

Visual Basic (Declaration)
Public Class Coders.Coder(Of T)
C#
public class Coders.Coder<T>

Type Parameters

T
The type to encode/decode.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T>
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.ExpressionCoder
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.LengthCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.Coder<T> Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders.Coder<T> Class Members

[image]
ActiveReports 19 .NET Edition
Coders.Coder<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.Coder<T> Class

Glossary Item Box

The following tables list the members exposed by Coders.Coder<T>.

Public Constructors

 | Name | Description
Public Constructor | Coders.Coder<T> Constructor | Represents a coder with encode and decode functions for a specific type.
Top

Public Properties

 | Name | Description
Public Property | Decode |
Public Property | Encode |
Top

See Also

Reference

Coders.Coder<T> Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders.Coder<T> Constructor

[image]
ActiveReports 19 .NET Edition
Coders.Coder<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.Coder<T> Class : Coders.Coder<T> Constructor

Encode
Function to encode a value of type T to a System.String.
Decode
Function to decode a System.String to a value of type T.

Glossary Item Box

Represents a coder with encode and decode functions for a specific type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Encode As Func(Of T,String), _
   ByVal Decode As Func(Of String,T) _
)
C#
public Coders.Coder<T>(
   Func<T,string> Encode,
   Func<string,T> Decode
)

Parameters

Encode
Function to encode a value of type T to a System.String.
Decode
Function to decode a System.String to a value of type T.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.Coder<T> Class
Coders.Coder<T> Members


Coders.Coder<T> Class Properties

[image]
ActiveReports 19 .NET Edition
Coders.Coder<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.Coder<T> Class

Glossary Item Box

For a list of all members of this type, see Coders.Coder<T> members.

Public Properties

 | Name | Description
Public Property | Decode |
Public Property | Encode |
Top

See Also

Reference

Coders.Coder<T> Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Decode Property

[image]
ActiveReports 19 .NET Edition
Decode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.Coder<T> Class : Decode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Decode As Func(Of String,T)
C#
public Func<string,T> Decode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.Coder<T> Class
Coders.Coder<T> Members


Encode Property

[image]
ActiveReports 19 .NET Edition
Encode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.Coder<T> Class : Encode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encode As Func(Of T,String)
C#
public Func<T,string> Encode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.Coder<T> Class
Coders.Coder<T> Members


Coders.ObjectCoder<T> Class

T
The type to write/read.
[image]
ActiveReports 19 .NET Edition
Coders.ObjectCoder<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.ObjectCoder<T> Class

Glossary Item Box

Represents an object coder with write and read functions for a specific type.

Object Model

Coders.ObjectCoder<T> Class

Syntax

Visual Basic (Declaration)
Public Class Coders.ObjectCoder(Of T)
C#
public class Coders.ObjectCoder<T>

Type Parameters

T
The type to write/read.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.ObjectCoder<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.ObjectCoder<T> Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders.ObjectCoder<T> Class Members

[image]
ActiveReports 19 .NET Edition
Coders.ObjectCoder<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.ObjectCoder<T> Class

Glossary Item Box

The following tables list the members exposed by Coders.ObjectCoder<T>.

Public Constructors

 | Name | Description
Public Constructor | Coders.ObjectCoder<T> Constructor | Represents an object coder with write and read functions for a specific type.
Top

Public Properties

 | Name | Description
Public Property | Read |
Public Property | Write |
Top

See Also

Reference

Coders.ObjectCoder<T> Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Coders.ObjectCoder<T> Constructor

[image]
ActiveReports 19 .NET Edition
Coders.ObjectCoder<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.ObjectCoder<T> Class : Coders.ObjectCoder<T> Constructor

Write
Function to write a value of type T to an System.Xml.XmlWriter.
Read
Function to read a value of type T from an System.Xml.XmlReader.

Glossary Item Box

Represents an object coder with write and read functions for a specific type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal Write As Action(Of XmlWriter,T), _
   ByVal Read As Func(Of XmlReader,T) _
)
C#
public Coders.ObjectCoder<T>(
   Action<XmlWriter,T> Write,
   Func<XmlReader,T> Read
)

Parameters

Write
Function to write a value of type T to an System.Xml.XmlWriter.
Read
Function to read a value of type T from an System.Xml.XmlReader.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.ObjectCoder<T> Class
Coders.ObjectCoder<T> Members


Coders.ObjectCoder<T> Class Properties

[image]
ActiveReports 19 .NET Edition
Coders.ObjectCoder<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : Coders.ObjectCoder<T> Class

Glossary Item Box

For a list of all members of this type, see Coders.ObjectCoder<T> members.

Public Properties

 | Name | Description
Public Property | Read |
Public Property | Write |
Top

See Also

Reference

Coders.ObjectCoder<T> Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Read Property

[image]
ActiveReports 19 .NET Edition
Read Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.ObjectCoder<T> Class : Read Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Read As Func(Of XmlReader,T)
C#
public Func<XmlReader,T> Read {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.ObjectCoder<T> Class
Coders.ObjectCoder<T> Members


Write Property

[image]
ActiveReports 19 .NET Edition
Write Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > Coders.ObjectCoder<T> Class : Write Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Write As Action(Of XmlWriter,T)
C#
public Action<XmlWriter,T> Write {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Coders.ObjectCoder<T> Class
Coders.ObjectCoder<T> Members


ExpressionCoder Class

[image]
ActiveReports 19 .NET Edition
ExpressionCoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder Class

Glossary Item Box

Represents a coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.

Object Model

ExpressionCoder Class

Syntax

Visual Basic (Declaration)
Public Class ExpressionCoder
   Inherits GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder(Of ExpressionInfo)
C#
public class ExpressionCoder : GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<ExpressionInfo>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T>
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.ExpressionCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionCoder Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder Class

Glossary Item Box

The following tables list the members exposed by ExpressionCoder.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Expression | Gets a coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.
Top

Public Properties

 | Name | Description
Public Property | Default | Gets the predefined coders with the default values.
Public Property | SkipOnWrite | Gets the predefined coders with the values that are skipped on write.
Top

See Also

Reference

ExpressionCoder Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder Class Properties

[image]
ActiveReports 19 .NET Edition
ExpressionCoder Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder Class

Glossary Item Box

For a list of all members of this type, see ExpressionCoder members.

Public Properties

 | Name | Description
Public Property | Default | Gets the predefined coders with the default values.
Public Property | SkipOnWrite | Gets the predefined coders with the values that are skipped on write.
Top

See Also

Reference

ExpressionCoder Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder Class : Default Property

Glossary Item Box

Gets the predefined coders with the default values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Default As ExpressionCoder.DefaultValues
C#
public ExpressionCoder.DefaultValues Default {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder Class
ExpressionCoder Members


SkipOnWrite Property

[image]
ActiveReports 19 .NET Edition
SkipOnWrite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder Class : SkipOnWrite Property

Glossary Item Box

Gets the predefined coders with the values that are skipped on write.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SkipOnWrite As ExpressionCoder.SkipOnWriteValues
C#
public ExpressionCoder.SkipOnWriteValues SkipOnWrite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder Class
ExpressionCoder Members


ExpressionCoder Class Fields

[image]
ActiveReports 19 .NET Edition
ExpressionCoder Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder Class

Glossary Item Box

For a list of all members of this type, see ExpressionCoder members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Expression | Gets a coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.
Top

See Also

Reference

ExpressionCoder Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Expression Field

[image]
ActiveReports 19 .NET Edition
Expression Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder Class : Expression Field

Glossary Item Box

Gets a coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Expression As ExpressionCoder
C#
public static readonly ExpressionCoder Expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder Class
ExpressionCoder Members


ExpressionCoder.DefaultValues Class

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.DefaultValues Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.DefaultValues Class

Glossary Item Box

Object Model

ExpressionCoder.DefaultValues Class

Syntax

Visual Basic (Declaration)
Public Class ExpressionCoder.DefaultValues
C#
public class ExpressionCoder.DefaultValues

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.ExpressionCoder.DefaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder.DefaultValues Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.DefaultValues Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.DefaultValues Class

Glossary Item Box

The following tables list the members exposed by ExpressionCoder.DefaultValues.

Public Constructors

 | Name | Description
Public Constructor | ExpressionCoder.DefaultValues Constructor |
Top

Public Fields

 | Name | Description
Public Field | EmptyString | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with an empty string as the default value.
Public Field | Inherit | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.
Public Field | Null | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with null as the default value.
Top

Public Methods

 | Name | Description
Public Method | FromString |
Top

See Also

Reference

ExpressionCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder.DefaultValues Constructor

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.DefaultValues Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.DefaultValues Class : ExpressionCoder.DefaultValues Constructor

coder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coder As ExpressionCoder _
)
C#
public ExpressionCoder.DefaultValues(
   ExpressionCoder coder
)

Parameters

coder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Class
ExpressionCoder.DefaultValues Members


ExpressionCoder.DefaultValues Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.DefaultValues Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.DefaultValues Class

Glossary Item Box

For a list of all members of this type, see ExpressionCoder.DefaultValues members.

Public Methods

 | Name | Description
Public Method | FromString |
Top

See Also

Reference

ExpressionCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.DefaultValues Class : FromString Method

defValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FromString( _
   ByVal defValue As String _
) As Coders.Coder(Of ExpressionInfo)
C#
public Coders.Coder<ExpressionInfo> FromString(
   string defValue
)

Parameters

defValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Class
ExpressionCoder.DefaultValues Members


ExpressionCoder.DefaultValues Class Fields

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.DefaultValues Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.DefaultValues Class

Glossary Item Box

For a list of all members of this type, see ExpressionCoder.DefaultValues members.

Public Fields

 | Name | Description
Public Field | EmptyString | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with an empty string as the default value.
Public Field | Inherit | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.
Public Field | Null | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with null as the default value.
Top

See Also

Reference

ExpressionCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


EmptyString Field

[image]
ActiveReports 19 .NET Edition
EmptyString Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.DefaultValues Class : EmptyString Field

Glossary Item Box

Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with an empty string as the default value.

Syntax

Visual Basic (Declaration)
Public ReadOnly EmptyString As ExpressionCoder
C#
public readonly ExpressionCoder EmptyString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Class
ExpressionCoder.DefaultValues Members


Inherit Field

[image]
ActiveReports 19 .NET Edition
Inherit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.DefaultValues Class : Inherit Field

Glossary Item Box

Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Inherit As Coders.Coder(Of ExpressionInfo)
C#
public readonly Coders.Coder<ExpressionInfo> Inherit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Class
ExpressionCoder.DefaultValues Members


Null Field

[image]
ActiveReports 19 .NET Edition
Null Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.DefaultValues Class : Null Field

Glossary Item Box

Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with null as the default value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Null As Coders.Coder(Of ExpressionInfo)
C#
public readonly Coders.Coder<ExpressionInfo> Null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.DefaultValues Class
ExpressionCoder.DefaultValues Members


ExpressionCoder.SkipOnWriteValues Class

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.SkipOnWriteValues Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.SkipOnWriteValues Class

Glossary Item Box

Object Model

ExpressionCoder.SkipOnWriteValues Class

Syntax

Visual Basic (Declaration)
Public Class ExpressionCoder.SkipOnWriteValues
C#
public class ExpressionCoder.SkipOnWriteValues

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.ExpressionCoder.SkipOnWriteValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.SkipOnWriteValues Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder.SkipOnWriteValues Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.SkipOnWriteValues Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.SkipOnWriteValues Class

Glossary Item Box

The following tables list the members exposed by ExpressionCoder.SkipOnWriteValues.

Public Constructors

 | Name | Description
Public Constructor | ExpressionCoder.SkipOnWriteValues Constructor |
Top

Public Fields

 | Name | Description
Public Field | Inherit | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.
Top

See Also

Reference

ExpressionCoder.SkipOnWriteValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


ExpressionCoder.SkipOnWriteValues Constructor

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.SkipOnWriteValues Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.SkipOnWriteValues Class : ExpressionCoder.SkipOnWriteValues Constructor

coder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coder As ExpressionCoder _
)
C#
public ExpressionCoder.SkipOnWriteValues(
   ExpressionCoder coder
)

Parameters

coder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.SkipOnWriteValues Class
ExpressionCoder.SkipOnWriteValues Members


ExpressionCoder.SkipOnWriteValues Class Fields

[image]
ActiveReports 19 .NET Edition
ExpressionCoder.SkipOnWriteValues Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : ExpressionCoder.SkipOnWriteValues Class

Glossary Item Box

For a list of all members of this type, see ExpressionCoder.SkipOnWriteValues members.

Public Fields

 | Name | Description
Public Field | Inherit | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.
Top

See Also

Reference

ExpressionCoder.SkipOnWriteValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Inherit Field

[image]
ActiveReports 19 .NET Edition
Inherit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > ExpressionCoder.SkipOnWriteValues Class : Inherit Field

Glossary Item Box

Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values with GrapeCity.ActiveReports.PageReportModel.Style.InheritedValue as the default value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Inherit As Coders.Coder(Of ExpressionInfo)
C#
public readonly Coders.Coder<ExpressionInfo> Inherit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionCoder.SkipOnWriteValues Class
ExpressionCoder.SkipOnWriteValues Members


LengthCoder Class

[image]
ActiveReports 19 .NET Edition
LengthCoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder Class

Glossary Item Box

Represents a coder for GrapeCity.ActiveReports.PageReportModel.Length values.

Object Model

LengthCoder Class

Syntax

Visual Basic (Declaration)
Public Class LengthCoder
   Inherits GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder(Of Length)
C#
public class LengthCoder : GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<Length>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.Coders.Coder<T>
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.LengthCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


LengthCoder Class Members

[image]
ActiveReports 19 .NET Edition
LengthCoder Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder Class

Glossary Item Box

The following tables list the members exposed by LengthCoder.

Public Fields

 | Name | Description
Public Field | Default |
static (Shared in Visual Basic) | Length | Gets a coder for Length values.
Top

See Also

Reference

LengthCoder Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


LengthCoder Class Fields

[image]
ActiveReports 19 .NET Edition
LengthCoder Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder Class

Glossary Item Box

For a list of all members of this type, see LengthCoder members.

Public Fields

 | Name | Description
Public Field | Default |
static (Shared in Visual Basic) | Length | Gets a coder for Length values.
Top

See Also

Reference

LengthCoder Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Default Field

[image]
ActiveReports 19 .NET Edition
Default Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder Class : Default Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default As LengthCoder.DefaultValues
C#
public readonly LengthCoder.DefaultValues Default

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder Class
LengthCoder Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder Class : Length Field

Glossary Item Box

Gets a coder for Length values.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Length As LengthCoder
C#
public static readonly LengthCoder Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder Class
LengthCoder Members


LengthCoder.DefaultValues Class

[image]
ActiveReports 19 .NET Edition
LengthCoder.DefaultValues Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder.DefaultValues Class

Glossary Item Box

Represents default values for the Length coder.

Object Model

LengthCoder.DefaultValues Class

Syntax

Visual Basic (Declaration)
Public Class LengthCoder.DefaultValues
C#
public class LengthCoder.DefaultValues

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.LengthCoder.DefaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder.DefaultValues Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


LengthCoder.DefaultValues Class Members

[image]
ActiveReports 19 .NET Edition
LengthCoder.DefaultValues Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder.DefaultValues Class

Glossary Item Box

The following tables list the members exposed by LengthCoder.DefaultValues.

Public Constructors

 | Name | Description
Public Constructor | LengthCoder.DefaultValues Constructor | Represents default values for the Length coder.
Top

Public Fields

 | Name | Description
Public Field | EmptyOrZero |
Public Field | Zero |
Top

Public Methods

 | Name | Description
Public Method | Value |
Top

See Also

Reference

LengthCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


LengthCoder.DefaultValues Constructor

[image]
ActiveReports 19 .NET Edition
LengthCoder.DefaultValues Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder.DefaultValues Class : LengthCoder.DefaultValues Constructor

coder

Glossary Item Box

Represents default values for the Length coder.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coder As LengthCoder _
)
C#
public LengthCoder.DefaultValues(
   LengthCoder coder
)

Parameters

coder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder.DefaultValues Class
LengthCoder.DefaultValues Members


LengthCoder.DefaultValues Class Methods

[image]
ActiveReports 19 .NET Edition
LengthCoder.DefaultValues Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder.DefaultValues Class

Glossary Item Box

For a list of all members of this type, see LengthCoder.DefaultValues members.

Public Methods

 | Name | Description
Public Method | Value |
Top

See Also

Reference

LengthCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Value Method

[image]
ActiveReports 19 .NET Edition
Value Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder.DefaultValues Class : Value Method

defaultValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Value( _
   ByVal defaultValue As Length _
) As Coders.Coder(Of Length)
C#
public Coders.Coder<Length> Value(
   Length defaultValue
)

Parameters

defaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder.DefaultValues Class
LengthCoder.DefaultValues Members


LengthCoder.DefaultValues Class Fields

[image]
ActiveReports 19 .NET Edition
LengthCoder.DefaultValues Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : LengthCoder.DefaultValues Class

Glossary Item Box

For a list of all members of this type, see LengthCoder.DefaultValues members.

Public Fields

 | Name | Description
Public Field | EmptyOrZero |
Public Field | Zero |
Top

See Also

Reference

LengthCoder.DefaultValues Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


EmptyOrZero Field

[image]
ActiveReports 19 .NET Edition
EmptyOrZero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder.DefaultValues Class : EmptyOrZero Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly EmptyOrZero As Coders.Coder(Of Length)
C#
public readonly Coders.Coder<Length> EmptyOrZero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder.DefaultValues Class
LengthCoder.DefaultValues Members


Zero Field

[image]
ActiveReports 19 .NET Edition
Zero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > LengthCoder.DefaultValues Class : Zero Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Zero As Coders.Coder(Of Length)
C#
public readonly Coders.Coder<Length> Zero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LengthCoder.DefaultValues Class
LengthCoder.DefaultValues Members


RomCoders Class

[image]
ActiveReports 19 .NET Edition
RomCoders Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : RomCoders Class

Glossary Item Box

Represents the coders for the Page Report Object Model types.

Object Model

RomCoders Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class RomCoders
C#
public static class RomCoders

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common.RomCoders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RomCoders Members
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


RomCoders Class Members

[image]
ActiveReports 19 .NET Edition
RomCoders Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : RomCoders Class

Glossary Item Box

The following tables list the members exposed by RomCoders.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Expression | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.
static (Shared in Visual Basic) | Length | Gets the coder for Length values.
Top

See Also

Reference

RomCoders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


RomCoders Class Fields

[image]
ActiveReports 19 .NET Edition
RomCoders Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace : RomCoders Class

Glossary Item Box

For a list of all members of this type, see RomCoders members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Expression | Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.
static (Shared in Visual Basic) | Length | Gets the coder for Length values.
Top

See Also

Reference

RomCoders Class
GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace


Expression Field

[image]
ActiveReports 19 .NET Edition
Expression Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > RomCoders Class : Expression Field

Glossary Item Box

Gets the coder for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Expression As ExpressionCoder
C#
public static readonly ExpressionCoder Expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RomCoders Class
RomCoders Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Core.Rdl.Seralization.Common Namespace > RomCoders Class : Length Field

Glossary Item Box

Gets the coder for Length values.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Length As LengthCoder
C#
public static readonly LengthCoder Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RomCoders Class
RomCoders Members


Chart Class

[image]
ActiveReports 19 .NET Edition
Chart Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Chart Class

Glossary Item Box

Represents a chart model of the SSRS RDL reports with version 2008 and above. This class is used by the ImportTool and for converting to the DVChart.

Object Model

Chart Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Chart
   Inherits GrapeCity.ActiveReports.PageReportModel.DataRegion
   Implements GrapeCity.ActiveReports.PageReportModel.IReportComponent, GrapeCity.ActiveReports.PageReportModel.IScopeDefinition, GrapeCity.ActiveReports.PageReportModel.IValidateable
C#
public sealed class Chart : GrapeCity.ActiveReports.PageReportModel.DataRegion, GrapeCity.ActiveReports.PageReportModel.IReportComponent, GrapeCity.ActiveReports.PageReportModel.IScopeDefinition, GrapeCity.ActiveReports.PageReportModel.IValidateable

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.Import.Models.Chart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Members
GrapeCity.ActiveReports.Import.Models Namespace


Chart Class Members

[image]
ActiveReports 19 .NET Edition
Chart Class Members
See Also Fields Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Chart Class

Glossary Item Box

The following tables list the members exposed by Chart.

Public Constructors

 | Name | Description
Public Constructor | Chart Constructor |
Top

Public Fields

 | Name | Description
Public Field | ChartAreas |
Public Field | ChartCategoryHierarchy |
Public Field | ChartData |
Public Field | ChartNoDataMessage |
Public Field | ChartSeriesHierarchy |
Public Field | CustomPaletteColors |
Public Field | Legends |
Public Field | PageBreak |
Public Field | Palette |
Public Field | Title |
Top

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden.
Public Property | ReportItemsInScope | Overridden.
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.Import.Models Namespace


Chart Constructor

[image]
ActiveReports 19 .NET Edition
Chart Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : Chart Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Chart()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

[image]
ActiveReports 19 .NET Edition
Chart Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Chart Class

Glossary Item Box

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden.
Public Property | ReportItemsInScope | Overridden.
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.Import.Models Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChildScopes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ReportItemsInScope Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Chart Class Fields

[image]
ActiveReports 19 .NET Edition
Chart Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Chart Class

Glossary Item Box

For a list of all members of this type, see Chart members.

Public Fields

 | Name | Description
Public Field | ChartAreas |
Public Field | ChartCategoryHierarchy |
Public Field | ChartData |
Public Field | ChartNoDataMessage |
Public Field | ChartSeriesHierarchy |
Public Field | CustomPaletteColors |
Public Field | Legends |
Public Field | PageBreak |
Public Field | Palette |
Public Field | Title |
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartAreas Field

[image]
ActiveReports 19 .NET Edition
ChartAreas Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChartAreas Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartAreas As Collection(Of ChartArea)
C#
public Collection<ChartArea> ChartAreas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartCategoryHierarchy Field

[image]
ActiveReports 19 .NET Edition
ChartCategoryHierarchy Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChartCategoryHierarchy Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartCategoryHierarchy As ChartHierarchy
C#
public ChartHierarchy ChartCategoryHierarchy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartData Field

[image]
ActiveReports 19 .NET Edition
ChartData Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChartData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartData As ChartData
C#
public ChartData ChartData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartNoDataMessage Field

[image]
ActiveReports 19 .NET Edition
ChartNoDataMessage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChartNoDataMessage Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartNoDataMessage As Title
C#
public Title ChartNoDataMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartSeriesHierarchy Field

[image]
ActiveReports 19 .NET Edition
ChartSeriesHierarchy Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : ChartSeriesHierarchy Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartSeriesHierarchy As ChartHierarchy
C#
public ChartHierarchy ChartSeriesHierarchy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


CustomPaletteColors Field

[image]
ActiveReports 19 .NET Edition
CustomPaletteColors Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : CustomPaletteColors Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public CustomPaletteColors As Collection(Of ExpressionInfo)
C#
public Collection<ExpressionInfo> CustomPaletteColors

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Legends Field

[image]
ActiveReports 19 .NET Edition
Legends Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : Legends Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Legends As Collection(Of ChartLegend)
C#
public Collection<ChartLegend> Legends

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


PageBreak Field

[image]
ActiveReports 19 .NET Edition
PageBreak Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : PageBreak Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public PageBreak As PageBreak
C#
public PageBreak PageBreak

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Palette Field

[image]
ActiveReports 19 .NET Edition
Palette Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : Palette Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Palette As ExpressionInfo
C#
public ExpressionInfo Palette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Title Field

[image]
ActiveReports 19 .NET Edition
Title Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Chart Class : Title Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Title As Title
C#
public Title Title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartArea Class

[image]
ActiveReports 19 .NET Edition
ChartArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartArea Class

Glossary Item Box

Represents a chart area that contains the axes and style.

Object Model

ChartArea Class

Syntax

Visual Basic (Declaration)
Public Class ChartArea
C#
public class ChartArea

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartArea Class Members

[image]
ActiveReports 19 .NET Edition
ChartArea Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartArea Class

Glossary Item Box

The following tables list the members exposed by ChartArea.

Public Constructors

 | Name | Description
Public Constructor | ChartArea Constructor |
Top

Public Fields

 | Name | Description
Public Field | CategoryAxes |
Public Field | Style |
Public Field | ValueAxes |
Top

See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartArea Constructor

[image]
ActiveReports 19 .NET Edition
ChartArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartArea Class : ChartArea Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartArea()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Class Fields

[image]
ActiveReports 19 .NET Edition
ChartArea Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartArea Class

Glossary Item Box

For a list of all members of this type, see ChartArea members.

Public Fields

 | Name | Description
Public Field | CategoryAxes |
Public Field | Style |
Public Field | ValueAxes |
Top

See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Import.Models Namespace


CategoryAxes Field

[image]
ActiveReports 19 .NET Edition
CategoryAxes Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartArea Class : CategoryAxes Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public CategoryAxes As Collection(Of ChartAxis)
C#
public Collection<ChartAxis> CategoryAxes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartArea Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ValueAxes Field

[image]
ActiveReports 19 .NET Edition
ValueAxes Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartArea Class : ValueAxes Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ValueAxes As Collection(Of ChartAxis)
C#
public Collection<ChartAxis> ValueAxes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


ChartAxis Class

[image]
ActiveReports 19 .NET Edition
ChartAxis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartAxis Class

Glossary Item Box

Represents a chart axis.

Object Model

ChartAxis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartAxis
C#
public sealed class ChartAxis

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartAxis Class Members

[image]
ActiveReports 19 .NET Edition
ChartAxis Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartAxis Class

Glossary Item Box

The following tables list the members exposed by ChartAxis.

Public Constructors

 | Name | Description
Public Constructor | ChartAxis Constructor |
Top

Public Fields

 | Name | Description
Public Field | CrossAt |
Public Field | HideLabels |
Public Field | Interval |
Public Field | LabelsAngle |
Public Field | Location |
Public Field | LogBase |
Public Field | LogScale |
Public Field | MajorGridLines |
Public Field | MajorTickMarks |
Public Field | Max |
Public Field | Min |
Public Field | MinorGridLines |
Public Field | MinorTickMarks |
Public Field | Name |
Public Field | Reverse |
Public Field | Style |
Public Field | Title |
Public Field | Visible |
Top

See Also

Reference

ChartAxis Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartAxis Constructor

[image]
ActiveReports 19 .NET Edition
ChartAxis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : ChartAxis Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartAxis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


ChartAxis Class Fields

[image]
ActiveReports 19 .NET Edition
ChartAxis Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartAxis Class

Glossary Item Box

For a list of all members of this type, see ChartAxis members.

Public Fields

 | Name | Description
Public Field | CrossAt |
Public Field | HideLabels |
Public Field | Interval |
Public Field | LabelsAngle |
Public Field | Location |
Public Field | LogBase |
Public Field | LogScale |
Public Field | MajorGridLines |
Public Field | MajorTickMarks |
Public Field | Max |
Public Field | Min |
Public Field | MinorGridLines |
Public Field | MinorTickMarks |
Public Field | Name |
Public Field | Reverse |
Public Field | Style |
Public Field | Title |
Public Field | Visible |
Top

See Also

Reference

ChartAxis Class
GrapeCity.ActiveReports.Import.Models Namespace


CrossAt Field

[image]
ActiveReports 19 .NET Edition
CrossAt Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : CrossAt Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public CrossAt As ExpressionInfo
C#
public ExpressionInfo CrossAt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


HideLabels Field

[image]
ActiveReports 19 .NET Edition
HideLabels Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : HideLabels Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public HideLabels As ExpressionInfo
C#
public ExpressionInfo HideLabels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Interval Field

[image]
ActiveReports 19 .NET Edition
Interval Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Interval Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interval As ExpressionInfo
C#
public ExpressionInfo Interval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


LabelsAngle Field

[image]
ActiveReports 19 .NET Edition
LabelsAngle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : LabelsAngle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public LabelsAngle As ExpressionInfo
C#
public ExpressionInfo LabelsAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Location Field

[image]
ActiveReports 19 .NET Edition
Location Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Location Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Location As String
C#
public string Location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


LogBase Field

[image]
ActiveReports 19 .NET Edition
LogBase Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : LogBase Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public LogBase As ExpressionInfo
C#
public ExpressionInfo LogBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


LogScale Field

[image]
ActiveReports 19 .NET Edition
LogScale Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : LogScale Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public LogScale As ExpressionInfo
C#
public ExpressionInfo LogScale

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


MajorGridLines Field

[image]
ActiveReports 19 .NET Edition
MajorGridLines Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : MajorGridLines Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MajorGridLines As GridLines
C#
public GridLines MajorGridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


MajorTickMarks Field

[image]
ActiveReports 19 .NET Edition
MajorTickMarks Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : MajorTickMarks Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MajorTickMarks As TickMarks
C#
public TickMarks MajorTickMarks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Max Field

[image]
ActiveReports 19 .NET Edition
Max Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Max Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Max As ExpressionInfo
C#
public ExpressionInfo Max

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Min Field

[image]
ActiveReports 19 .NET Edition
Min Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Min Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Min As ExpressionInfo
C#
public ExpressionInfo Min

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


MinorGridLines Field

[image]
ActiveReports 19 .NET Edition
MinorGridLines Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : MinorGridLines Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MinorGridLines As GridLines
C#
public GridLines MinorGridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


MinorTickMarks Field

[image]
ActiveReports 19 .NET Edition
MinorTickMarks Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : MinorTickMarks Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MinorTickMarks As TickMarks
C#
public TickMarks MinorTickMarks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Name Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Name As String
C#
public string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Reverse Field

[image]
ActiveReports 19 .NET Edition
Reverse Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Reverse Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Reverse As ExpressionInfo
C#
public ExpressionInfo Reverse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Title Field

[image]
ActiveReports 19 .NET Edition
Title Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Title Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Title As Title
C#
public Title Title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


Visible Field

[image]
ActiveReports 19 .NET Edition
Visible Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartAxis Class : Visible Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Visible As ExpressionInfo
C#
public ExpressionInfo Visible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxis Class
ChartAxis Members


ChartData Class

[image]
ActiveReports 19 .NET Edition
ChartData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartData Class

Glossary Item Box

Represents a chart data that contains a collection of chart series.

Object Model

ChartData Class

Syntax

Visual Basic (Declaration)
Public Class ChartData
C#
public class ChartData

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartData Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartData Class Members

[image]
ActiveReports 19 .NET Edition
ChartData Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartData Class

Glossary Item Box

The following tables list the members exposed by ChartData.

Public Constructors

 | Name | Description
Public Constructor | ChartData Constructor |
Top

Public Fields

 | Name | Description
Public Field | ChartSeriesCollection |
Top

See Also

Reference

ChartData Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartData Constructor

[image]
ActiveReports 19 .NET Edition
ChartData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartData Class : ChartData Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartData Class
ChartData Members


ChartData Class Fields

[image]
ActiveReports 19 .NET Edition
ChartData Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartData Class

Glossary Item Box

For a list of all members of this type, see ChartData members.

Public Fields

 | Name | Description
Public Field | ChartSeriesCollection |
Top

See Also

Reference

ChartData Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartSeriesCollection Field

[image]
ActiveReports 19 .NET Edition
ChartSeriesCollection Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartData Class : ChartSeriesCollection Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartSeriesCollection As Collection(Of ChartSeries)
C#
public Collection<ChartSeries> ChartSeriesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartData Class
ChartData Members


ChartHierarchy Class

[image]
ActiveReports 19 .NET Edition
ChartHierarchy Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartHierarchy Class

Glossary Item Box

Represents a hierarchy of categories or series.

Object Model

ChartHierarchy Class

Syntax

Visual Basic (Declaration)
Public Class ChartHierarchy
C#
public class ChartHierarchy

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartHierarchy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHierarchy Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartHierarchy Class Members

[image]
ActiveReports 19 .NET Edition
ChartHierarchy Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartHierarchy Class

Glossary Item Box

The following tables list the members exposed by ChartHierarchy.

Public Constructors

 | Name | Description
Public Constructor | ChartHierarchy Constructor |
Top

Public Fields

 | Name | Description
Public Field | ChartMembers |
Top

See Also

Reference

ChartHierarchy Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartHierarchy Constructor

[image]
ActiveReports 19 .NET Edition
ChartHierarchy Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartHierarchy Class : ChartHierarchy Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartHierarchy()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHierarchy Class
ChartHierarchy Members


ChartHierarchy Class Fields

[image]
ActiveReports 19 .NET Edition
ChartHierarchy Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartHierarchy Class

Glossary Item Box

For a list of all members of this type, see ChartHierarchy members.

Public Fields

 | Name | Description
Public Field | ChartMembers |
Top

See Also

Reference

ChartHierarchy Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartMembers Field

[image]
ActiveReports 19 .NET Edition
ChartMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartHierarchy Class : ChartMembers Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartMembers As Collection(Of ChartMember)
C#
public Collection<ChartMember> ChartMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHierarchy Class
ChartHierarchy Members


ChartItemInLegend Class

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartItemInLegend Class

Glossary Item Box

Represents a legend text of a chart item.

Object Model

ChartItemInLegend Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartItemInLegend
C#
public sealed class ChartItemInLegend

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartItemInLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartItemInLegend Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartItemInLegend Class Members

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartItemInLegend Class

Glossary Item Box

The following tables list the members exposed by ChartItemInLegend.

Public Constructors

 | Name | Description
Public Constructor | ChartItemInLegend Constructor |
Top

Public Fields

 | Name | Description
Public Field | Hidden |
Public Field | LegendText |
Top

See Also

Reference

ChartItemInLegend Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartItemInLegend Constructor

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartItemInLegend Class : ChartItemInLegend Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartItemInLegend()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartItemInLegend Class
ChartItemInLegend Members


ChartItemInLegend Class Fields

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartItemInLegend Class

Glossary Item Box

For a list of all members of this type, see ChartItemInLegend members.

Public Fields

 | Name | Description
Public Field | Hidden |
Public Field | LegendText |
Top

See Also

Reference

ChartItemInLegend Class
GrapeCity.ActiveReports.Import.Models Namespace


Hidden Field

[image]
ActiveReports 19 .NET Edition
Hidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartItemInLegend Class : Hidden Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartItemInLegend Class
ChartItemInLegend Members


LegendText Field

[image]
ActiveReports 19 .NET Edition
LegendText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartItemInLegend Class : LegendText Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public LegendText As ExpressionInfo
C#
public ExpressionInfo LegendText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartItemInLegend Class
ChartItemInLegend Members


ChartLegend Class

[image]
ActiveReports 19 .NET Edition
ChartLegend Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartLegend Class

Glossary Item Box

Represents a chart legend that contains title and style.

Object Model

ChartLegend Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartLegend
C#
public sealed class ChartLegend

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartLegend Class Members

[image]
ActiveReports 19 .NET Edition
ChartLegend Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartLegend Class

Glossary Item Box

The following tables list the members exposed by ChartLegend.

Public Constructors

 | Name | Description
Public Constructor | ChartLegend Constructor |
Top

Public Fields

 | Name | Description
Public Field | Hidden |
Public Field | MaxAutoSize |
Public Field | Name |
Public Field | Position |
Public Field | Style |
Public Field | Title |
Top

See Also

Reference

ChartLegend Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartLegend Constructor

[image]
ActiveReports 19 .NET Edition
ChartLegend Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : ChartLegend Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartLegend()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


ChartLegend Class Fields

[image]
ActiveReports 19 .NET Edition
ChartLegend Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartLegend Class

Glossary Item Box

For a list of all members of this type, see ChartLegend members.

Public Fields

 | Name | Description
Public Field | Hidden |
Public Field | MaxAutoSize |
Public Field | Name |
Public Field | Position |
Public Field | Style |
Public Field | Title |
Top

See Also

Reference

ChartLegend Class
GrapeCity.ActiveReports.Import.Models Namespace


Hidden Field

[image]
ActiveReports 19 .NET Edition
Hidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : Hidden Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


MaxAutoSize Field

[image]
ActiveReports 19 .NET Edition
MaxAutoSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : MaxAutoSize Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MaxAutoSize As ExpressionInfo
C#
public ExpressionInfo MaxAutoSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : Name Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Name As String
C#
public string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : Position Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Position As String
C#
public string Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


Title Field

[image]
ActiveReports 19 .NET Edition
Title Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartLegend Class : Title Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Title As Title
C#
public Title Title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegend Class
ChartLegend Members


ChartMember Class

[image]
ActiveReports 19 .NET Edition
ChartMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartMember Class

Glossary Item Box

Represents the chart member that contains the grouping and sorting expressions.

Object Model

ChartMember Class

Syntax

Visual Basic (Declaration)
Public Class ChartMember
C#
public class ChartMember

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartMember Class Members

[image]
ActiveReports 19 .NET Edition
ChartMember Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartMember Class

Glossary Item Box

The following tables list the members exposed by ChartMember.

Public Constructors

 | Name | Description
Public Constructor | ChartMember Constructor |
Top

Public Fields

 | Name | Description
Public Field | ChartMembers |
Public Field | DataElementName |
Public Field | DataElementOutput |
Public Field | Grouping |
Public Field | Label |
Public Field | SortExpressions |
Top

See Also

Reference

ChartMember Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartMember Constructor

[image]
ActiveReports 19 .NET Edition
ChartMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : ChartMember Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartMember()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


ChartMember Class Fields

[image]
ActiveReports 19 .NET Edition
ChartMember Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartMember Class

Glossary Item Box

For a list of all members of this type, see ChartMember members.

Public Fields

 | Name | Description
Public Field | ChartMembers |
Public Field | DataElementName |
Public Field | DataElementOutput |
Public Field | Grouping |
Public Field | Label |
Public Field | SortExpressions |
Top

See Also

Reference

ChartMember Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartMembers Field

[image]
ActiveReports 19 .NET Edition
ChartMembers Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : ChartMembers Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartMembers As Collection(Of ChartMember)
C#
public Collection<ChartMember> ChartMembers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


DataElementName Field

[image]
ActiveReports 19 .NET Edition
DataElementName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : DataElementName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DataElementName As String
C#
public string DataElementName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


DataElementOutput Field

[image]
ActiveReports 19 .NET Edition
DataElementOutput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : DataElementOutput Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


Grouping Field

[image]
ActiveReports 19 .NET Edition
Grouping Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : Grouping Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Grouping As Grouping
C#
public Grouping Grouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


Label Field

[image]
ActiveReports 19 .NET Edition
Label Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : Label Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Label As ExpressionInfo
C#
public ExpressionInfo Label

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


SortExpressions Field

[image]
ActiveReports 19 .NET Edition
SortExpressions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartMember Class : SortExpressions Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public SortExpressions As Collection(Of SortExpression)
C#
public Collection<SortExpression> SortExpressions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMember Class
ChartMember Members


ChartSeries Class

[image]
ActiveReports 19 .NET Edition
ChartSeries Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartSeries Class

Glossary Item Box

Represents the chart series that contains collection of data points.

Object Model

ChartSeries Class

Syntax

Visual Basic (Declaration)
Public Class ChartSeries
C#
public class ChartSeries

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.ChartSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Members
GrapeCity.ActiveReports.Import.Models Namespace


ChartSeries Class Members

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartSeries Class

Glossary Item Box

The following tables list the members exposed by ChartSeries.

Public Constructors

 | Name | Description
Public Constructor | ChartSeries Constructor |
Top

Public Fields

 | Name | Description
Public Field | CategoryAxisName |
Public Field | ChartItemInLegend |
Public Field | DataPoints |
Public Field | Name |
Public Field | Type |
Public Field | ValueAxisName |
Public Field | Visible |
Top

Public Properties

 | Name | Description
Public Property | Subtype |
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.Import.Models Namespace


ChartSeries Constructor

[image]
ActiveReports 19 .NET Edition
ChartSeries Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : ChartSeries Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartSeries()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Properties

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartSeries Class

Glossary Item Box

For a list of all members of this type, see ChartSeries members.

Public Properties

 | Name | Description
Public Property | Subtype |
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.Import.Models Namespace


Subtype Property

[image]
ActiveReports 19 .NET Edition
Subtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : Subtype Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Subtype As String
C#
public string Subtype {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Fields

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : ChartSeries Class

Glossary Item Box

For a list of all members of this type, see ChartSeries members.

Public Fields

 | Name | Description
Public Field | CategoryAxisName |
Public Field | ChartItemInLegend |
Public Field | DataPoints |
Public Field | Name |
Public Field | Type |
Public Field | ValueAxisName |
Public Field | Visible |
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.Import.Models Namespace


CategoryAxisName Field

[image]
ActiveReports 19 .NET Edition
CategoryAxisName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : CategoryAxisName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public CategoryAxisName As String
C#
public string CategoryAxisName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartItemInLegend Field

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : ChartItemInLegend Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartItemInLegend As ChartItemInLegend
C#
public ChartItemInLegend ChartItemInLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


DataPoints Field

[image]
ActiveReports 19 .NET Edition
DataPoints Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : DataPoints Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DataPoints As Collection(Of DataPoint)
C#
public Collection<DataPoint> DataPoints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : Name Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Name As String
C#
public string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Type As String
C#
public string Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ValueAxisName Field

[image]
ActiveReports 19 .NET Edition
ValueAxisName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : ValueAxisName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ValueAxisName As String
C#
public string ValueAxisName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


Visible Field

[image]
ActiveReports 19 .NET Edition
Visible Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > ChartSeries Class : Visible Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Visible As ExpressionInfo
C#
public ExpressionInfo Visible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


DataLabel Class

[image]
ActiveReports 19 .NET Edition
DataLabel Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataLabel Class

Glossary Item Box

Represents a data point label.

Object Model

DataLabel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataLabel
C#
public sealed class DataLabel

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.DataLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Members
GrapeCity.ActiveReports.Import.Models Namespace


DataLabel Class Members

[image]
ActiveReports 19 .NET Edition
DataLabel Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataLabel Class

Glossary Item Box

The following tables list the members exposed by DataLabel.

Public Constructors

 | Name | Description
Public Constructor | DataLabel Constructor |
Top

Public Fields

 | Name | Description
Public Field | Position |
Public Field | Rotation |
Public Field | Style |
Public Field | Tooltip |
Public Field | Value |
Public Field | Visible |
Top

See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.Import.Models Namespace


DataLabel Constructor

[image]
ActiveReports 19 .NET Edition
DataLabel Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : DataLabel Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataLabel()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


DataLabel Class Fields

[image]
ActiveReports 19 .NET Edition
DataLabel Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataLabel Class

Glossary Item Box

For a list of all members of this type, see DataLabel members.

Public Fields

 | Name | Description
Public Field | Position |
Public Field | Rotation |
Public Field | Style |
Public Field | Tooltip |
Public Field | Value |
Public Field | Visible |
Top

See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.Import.Models Namespace


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Position Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Position As ExpressionInfo
C#
public ExpressionInfo Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Rotation Field

[image]
ActiveReports 19 .NET Edition
Rotation Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Rotation Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Rotation As ExpressionInfo
C#
public ExpressionInfo Rotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Tooltip Field

[image]
ActiveReports 19 .NET Edition
Tooltip Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Tooltip Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Tooltip As ExpressionInfo
C#
public ExpressionInfo Tooltip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Value Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Value As ExpressionInfo
C#
public ExpressionInfo Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Visible Field

[image]
ActiveReports 19 .NET Edition
Visible Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataLabel Class : Visible Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Visible As ExpressionInfo
C#
public ExpressionInfo Visible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


DataPoint Class

[image]
ActiveReports 19 .NET Edition
DataPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPoint Class

Glossary Item Box

Represents a data point that contains a collection of values, label, marker, tooltip and style.

Object Model

DataPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPoint
C#
public sealed class DataPoint

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.DataPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Members
GrapeCity.ActiveReports.Import.Models Namespace


DataPoint Class Members

[image]
ActiveReports 19 .NET Edition
DataPoint Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPoint Class

Glossary Item Box

The following tables list the members exposed by DataPoint.

Public Constructors

 | Name | Description
Public Constructor | DataPoint Constructor |
Top

Public Fields

 | Name | Description
Public Field | Action |
Public Field | ChartDataLabel |
Public Field | ChartDataPointValues |
Public Field | ChartItemInLegend |
Public Field | DataElementName |
Public Field | DataElementOutput |
Public Field | Marker |
Public Field | Style |
Public Field | ToolTip |
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Import.Models Namespace


DataPoint Constructor

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : DataPoint Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPoint()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Fields

[image]
ActiveReports 19 .NET Edition
DataPoint Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPoint Class

Glossary Item Box

For a list of all members of this type, see DataPoint members.

Public Fields

 | Name | Description
Public Field | Action |
Public Field | ChartDataLabel |
Public Field | ChartDataPointValues |
Public Field | ChartItemInLegend |
Public Field | DataElementName |
Public Field | DataElementOutput |
Public Field | Marker |
Public Field | Style |
Public Field | ToolTip |
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Import.Models Namespace


Action Field

[image]
ActiveReports 19 .NET Edition
Action Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : Action Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Action As Action
C#
public Action Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ChartDataLabel Field

[image]
ActiveReports 19 .NET Edition
ChartDataLabel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : ChartDataLabel Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartDataLabel As DataLabel
C#
public DataLabel ChartDataLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ChartDataPointValues Field

[image]
ActiveReports 19 .NET Edition
ChartDataPointValues Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : ChartDataPointValues Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartDataPointValues As DataPointValue
C#
public DataPointValue ChartDataPointValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ChartItemInLegend Field

[image]
ActiveReports 19 .NET Edition
ChartItemInLegend Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : ChartItemInLegend Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ChartItemInLegend As ChartItemInLegend
C#
public ChartItemInLegend ChartItemInLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataElementName Field

[image]
ActiveReports 19 .NET Edition
DataElementName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : DataElementName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DataElementName As String
C#
public string DataElementName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataElementOutput Field

[image]
ActiveReports 19 .NET Edition
DataElementOutput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : DataElementOutput Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Marker Field

[image]
ActiveReports 19 .NET Edition
Marker Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : Marker Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Marker As Marker
C#
public Marker Marker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ToolTip Field

[image]
ActiveReports 19 .NET Edition
ToolTip Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPoint Class : ToolTip Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ToolTip As ExpressionInfo
C#
public ExpressionInfo ToolTip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPointValue Class

[image]
ActiveReports 19 .NET Edition
DataPointValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPointValue Class

Glossary Item Box

Represents the expressions of data point value.

Object Model

DataPointValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPointValue
C#
public sealed class DataPointValue

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.DataPointValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Members
GrapeCity.ActiveReports.Import.Models Namespace


DataPointValue Class Members

[image]
ActiveReports 19 .NET Edition
DataPointValue Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPointValue Class

Glossary Item Box

The following tables list the members exposed by DataPointValue.

Public Constructors

 | Name | Description
Public Constructor | DataPointValue Constructor |
Top

Public Fields

 | Name | Description
Public Field | End |
Public Field | High |
Public Field | Low |
Public Field | Mean |
Public Field | Median |
Public Field | Size |
Public Field | Start |
Public Field | X |
Public Field | Y |
Top

See Also

Reference

DataPointValue Class
GrapeCity.ActiveReports.Import.Models Namespace


DataPointValue Constructor

[image]
ActiveReports 19 .NET Edition
DataPointValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : DataPointValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPointValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


DataPointValue Class Fields

[image]
ActiveReports 19 .NET Edition
DataPointValue Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : DataPointValue Class

Glossary Item Box

For a list of all members of this type, see DataPointValue members.

Public Fields

 | Name | Description
Public Field | End |
Public Field | High |
Public Field | Low |
Public Field | Mean |
Public Field | Median |
Public Field | Size |
Public Field | Start |
Public Field | X |
Public Field | Y |
Top

See Also

Reference

DataPointValue Class
GrapeCity.ActiveReports.Import.Models Namespace


End Field

[image]
ActiveReports 19 .NET Edition
End Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : End Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public End As ExpressionInfo
C#
public ExpressionInfo End

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


High Field

[image]
ActiveReports 19 .NET Edition
High Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : High Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public High As ExpressionInfo
C#
public ExpressionInfo High

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Low Field

[image]
ActiveReports 19 .NET Edition
Low Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Low Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Low As ExpressionInfo
C#
public ExpressionInfo Low

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Mean Field

[image]
ActiveReports 19 .NET Edition
Mean Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Mean Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Mean As ExpressionInfo
C#
public ExpressionInfo Mean

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Median Field

[image]
ActiveReports 19 .NET Edition
Median Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Median Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Median As ExpressionInfo
C#
public ExpressionInfo Median

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Size Field

[image]
ActiveReports 19 .NET Edition
Size Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Size Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Size As ExpressionInfo
C#
public ExpressionInfo Size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Start Field

[image]
ActiveReports 19 .NET Edition
Start Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Start Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Start As ExpressionInfo
C#
public ExpressionInfo Start

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


X Field

[image]
ActiveReports 19 .NET Edition
X Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : X Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public X As ExpressionInfo
C#
public ExpressionInfo X

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


Y Field

[image]
ActiveReports 19 .NET Edition
Y Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > DataPointValue Class : Y Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Y As ExpressionInfo
C#
public ExpressionInfo Y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointValue Class
DataPointValue Members


GridLines Class

[image]
ActiveReports 19 .NET Edition
GridLines Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : GridLines Class

Glossary Item Box

Represents a chart axis grid line properties.

Object Model

GridLines Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridLines
C#
public sealed class GridLines

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.GridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Members
GrapeCity.ActiveReports.Import.Models Namespace


GridLines Class Members

[image]
ActiveReports 19 .NET Edition
GridLines Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : GridLines Class

Glossary Item Box

The following tables list the members exposed by GridLines.

Public Constructors

 | Name | Description
Public Constructor | GridLines Constructor |
Top

Public Fields

 | Name | Description
Public Field | Enabled |
Public Field | Interval |
Public Field | Style |
Top

See Also

Reference

GridLines Class
GrapeCity.ActiveReports.Import.Models Namespace


GridLines Constructor

[image]
ActiveReports 19 .NET Edition
GridLines Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > GridLines Class : GridLines Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridLines()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


GridLines Class Fields

[image]
ActiveReports 19 .NET Edition
GridLines Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : GridLines Class

Glossary Item Box

For a list of all members of this type, see GridLines members.

Public Fields

 | Name | Description
Public Field | Enabled |
Public Field | Interval |
Public Field | Style |
Top

See Also

Reference

GridLines Class
GrapeCity.ActiveReports.Import.Models Namespace


Enabled Field

[image]
ActiveReports 19 .NET Edition
Enabled Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > GridLines Class : Enabled Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enabled As ExpressionInfo
C#
public ExpressionInfo Enabled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


Interval Field

[image]
ActiveReports 19 .NET Edition
Interval Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > GridLines Class : Interval Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interval As ExpressionInfo
C#
public ExpressionInfo Interval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > GridLines Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


Marker Class

[image]
ActiveReports 19 .NET Edition
Marker Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Marker Class

Glossary Item Box

Represents a data point marker that contains shape type, size and style.

Object Model

Marker Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Marker
C#
public sealed class Marker

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.Marker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Members
GrapeCity.ActiveReports.Import.Models Namespace


Marker Class Members

[image]
ActiveReports 19 .NET Edition
Marker Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Marker Class

Glossary Item Box

The following tables list the members exposed by Marker.

Public Constructors

 | Name | Description
Public Constructor | Marker Constructor |
Top

Public Fields

 | Name | Description
Public Field | Size |
Public Field | Style |
Public Field | Type |
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.Import.Models Namespace


Marker Constructor

[image]
ActiveReports 19 .NET Edition
Marker Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Marker Class : Marker Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Marker()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Marker Class Fields

[image]
ActiveReports 19 .NET Edition
Marker Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Marker Class

Glossary Item Box

For a list of all members of this type, see Marker members.

Public Fields

 | Name | Description
Public Field | Size |
Public Field | Style |
Public Field | Type |
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.Import.Models Namespace


Size Field

[image]
ActiveReports 19 .NET Edition
Size Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Marker Class : Size Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Size As ExpressionInfo
C#
public ExpressionInfo Size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Marker Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Marker Class : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Type As ExpressionInfo
C#
public ExpressionInfo Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


SortExpression Class

[image]
ActiveReports 19 .NET Edition
SortExpression Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : SortExpression Class

Glossary Item Box

Represents a chart member sorting expression and direction.

Object Model

SortExpression Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SortExpression
C#
public sealed class SortExpression

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.SortExpression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortExpression Members
GrapeCity.ActiveReports.Import.Models Namespace


SortExpression Class Members

[image]
ActiveReports 19 .NET Edition
SortExpression Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : SortExpression Class

Glossary Item Box

The following tables list the members exposed by SortExpression.

Public Constructors

 | Name | Description
Public Constructor | SortExpression Constructor |
Top

Public Fields

 | Name | Description
Public Field | Direction |
Public Field | Value |
Top

See Also

Reference

SortExpression Class
GrapeCity.ActiveReports.Import.Models Namespace


SortExpression Constructor

[image]
ActiveReports 19 .NET Edition
SortExpression Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > SortExpression Class : SortExpression Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SortExpression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortExpression Class
SortExpression Members


SortExpression Class Fields

[image]
ActiveReports 19 .NET Edition
SortExpression Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : SortExpression Class

Glossary Item Box

For a list of all members of this type, see SortExpression members.

Public Fields

 | Name | Description
Public Field | Direction |
Public Field | Value |
Top

See Also

Reference

SortExpression Class
GrapeCity.ActiveReports.Import.Models Namespace


Direction Field

[image]
ActiveReports 19 .NET Edition
Direction Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > SortExpression Class : Direction Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Direction As SortByDirection
C#
public SortByDirection Direction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortExpression Class
SortExpression Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > SortExpression Class : Value Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Value As ExpressionInfo
C#
public ExpressionInfo Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortExpression Class
SortExpression Members


TickMarks Class

[image]
ActiveReports 19 .NET Edition
TickMarks Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : TickMarks Class

Glossary Item Box

Represents a chart axis tick marks properties.

Object Model

TickMarks Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TickMarks
C#
public sealed class TickMarks

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.TickMarks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Members
GrapeCity.ActiveReports.Import.Models Namespace


TickMarks Class Members

[image]
ActiveReports 19 .NET Edition
TickMarks Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : TickMarks Class

Glossary Item Box

The following tables list the members exposed by TickMarks.

Public Constructors

 | Name | Description
Public Constructor | TickMarks Constructor |
Top

Public Fields

 | Name | Description
Public Field | Enabled |
Public Field | Interval |
Public Field | Length |
Public Field | Style |
Public Field | Type |
Top

See Also

Reference

TickMarks Class
GrapeCity.ActiveReports.Import.Models Namespace


TickMarks Constructor

[image]
ActiveReports 19 .NET Edition
TickMarks Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : TickMarks Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TickMarks()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


TickMarks Class Fields

[image]
ActiveReports 19 .NET Edition
TickMarks Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : TickMarks Class

Glossary Item Box

For a list of all members of this type, see TickMarks members.

Public Fields

 | Name | Description
Public Field | Enabled |
Public Field | Interval |
Public Field | Length |
Public Field | Style |
Public Field | Type |
Top

See Also

Reference

TickMarks Class
GrapeCity.ActiveReports.Import.Models Namespace


Enabled Field

[image]
ActiveReports 19 .NET Edition
Enabled Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : Enabled Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enabled As ExpressionInfo
C#
public ExpressionInfo Enabled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


Interval Field

[image]
ActiveReports 19 .NET Edition
Interval Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : Interval Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interval As ExpressionInfo
C#
public ExpressionInfo Interval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : Length Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Length As ExpressionInfo
C#
public ExpressionInfo Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > TickMarks Class : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Type As ExpressionInfo
C#
public ExpressionInfo Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TickMarks Class
TickMarks Members


Title Class

[image]
ActiveReports 19 .NET Edition
Title Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Title Class

Glossary Item Box

Represents a header title of chart.

Object Model

Title Class

Syntax

Visual Basic (Declaration)
Public Class Title
C#
public class Title

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Import.Models.Title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Members
GrapeCity.ActiveReports.Import.Models Namespace


Title Class Members

[image]
ActiveReports 19 .NET Edition
Title Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Title Class

Glossary Item Box

The following tables list the members exposed by Title.

Public Constructors

 | Name | Description
Public Constructor | Title Constructor |
Top

Public Fields

 | Name | Description
Public Field | Caption |
Public Field | Position |
Public Field | Style |
Public Field | TextAlign |
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.Import.Models Namespace


Title Constructor

[image]
ActiveReports 19 .NET Edition
Title Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Title Class : Title Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Title()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Title Class Fields

[image]
ActiveReports 19 .NET Edition
Title Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace : Title Class

Glossary Item Box

For a list of all members of this type, see Title members.

Public Fields

 | Name | Description
Public Field | Caption |
Public Field | Position |
Public Field | Style |
Public Field | TextAlign |
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.Import.Models Namespace


Caption Field

[image]
ActiveReports 19 .NET Edition
Caption Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Title Class : Caption Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Caption As ExpressionInfo
C#
public ExpressionInfo Caption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Title Class : Position Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Position As ExpressionInfo
C#
public ExpressionInfo Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Title Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Style As Style
C#
public Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


TextAlign Field

[image]
ActiveReports 19 .NET Edition
TextAlign Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Import.Models Namespace > Title Class : TextAlign Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public TextAlign As ExpressionInfo
C#
public ExpressionInfo TextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Action Class

[image]
ActiveReports 19 .NET Edition
Action Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

Glossary Item Box

Represents an Action element defines a Hyperlink, Bookmark link, Drillthrough or ApplyParameters action associated with a ReportItem.

Object Model

Action Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Action
   Implements IValidateable
C#
public sealed class Action : IValidateable

Remarks

An Action must have one and only one of the following properties: Hyperlink, BookmarkLink, Drillthrough or ApplyParameters.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Members
GrapeCity.ActiveReports.PageReportModel Namespace


Action Class Members

[image]
ActiveReports 19 .NET Edition
Action Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

Glossary Item Box

The following tables list the members exposed by Action.

Public Constructors

 | Name | Description
Public Constructor | Action Constructor | Initializes a new instance of the Action class.
Top

Public Properties

 | Name | Description
Public Property | ApplyParameters | Gets an apply parameters action settings that is executed by clicking the report item.
Public Property | BookmarkLink | Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.
Public Property | Drillthrough | Gets or sets a drillthrough report that is executed by clicking the hyperlink.
Public Property | Hyperlink | Gets or sets an expression that evaluates to the URL of the hyperlink.
Public Property | Slice | Gets or sets a slice action information.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Action object.
Top

See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Constructor

[image]
ActiveReports 19 .NET Edition
Action Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Action Constructor

Glossary Item Box

Initializes a new instance of the Action class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Action()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


Action Class Methods

[image]
ActiveReports 19 .NET Edition
Action Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

Glossary Item Box

For a list of all members of this type, see Action members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Action object.
Top

See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Action object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


Action Class Properties

[image]
ActiveReports 19 .NET Edition
Action Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

Glossary Item Box

For a list of all members of this type, see Action members.

Public Properties

 | Name | Description
Public Property | ApplyParameters | Gets an apply parameters action settings that is executed by clicking the report item.
Public Property | BookmarkLink | Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.
Public Property | Drillthrough | Gets or sets a drillthrough report that is executed by clicking the hyperlink.
Public Property | Hyperlink | Gets or sets an expression that evaluates to the URL of the hyperlink.
Public Property | Slice | Gets or sets a slice action information.
Top

See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParameters Property

[image]
ActiveReports 19 .NET Edition
ApplyParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : ApplyParameters Property

Glossary Item Box

Gets an apply parameters action settings that is executed by clicking the report item.

Syntax

Visual Basic (Declaration)
Public Property ApplyParameters As ApplyParametersAction
C#
public ApplyParametersAction ApplyParameters {get; set;}

Property Value

A ApplyParametersAction object representing the apply parameters action settings that is executed by clicking the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


BookmarkLink Property

[image]
ActiveReports 19 .NET Edition
BookmarkLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : BookmarkLink Property

Glossary Item Box

Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.

Syntax

Visual Basic (Declaration)
Public Property BookmarkLink As ExpressionInfo
C#
public ExpressionInfo BookmarkLink {get; set;}

Property Value

An ExpressionInfo object that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.

Remarks

If no bookmark with this ID is found, the link is not included in the report. If the bookmark is hidden, the link goes to the start of the page of the bookmark. If multiple bookmarks with the ID are found, the link goes to the first one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


Drillthrough Property

[image]
ActiveReports 19 .NET Edition
Drillthrough Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Drillthrough Property

Glossary Item Box

Gets or sets a drillthrough report that is executed by clicking the hyperlink.

Syntax

Visual Basic (Declaration)
Public Property Drillthrough As Drillthrough
C#
public Drillthrough Drillthrough {get; set;}

Property Value

A Drillthrough object representing the drillthrough report that is executed by clicking the hyperlink.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


Hyperlink Property

[image]
ActiveReports 19 .NET Edition
Hyperlink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Hyperlink Property

Glossary Item Box

Gets or sets an expression that evaluates to the URL of the hyperlink.

Syntax

Visual Basic (Declaration)
Public Property Hyperlink As ExpressionInfo
C#
public ExpressionInfo Hyperlink {get; set;}

Property Value

An ExpressionInfo object that evaluates to the URL of the hyperlink.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


Slice Property

[image]
ActiveReports 19 .NET Edition
Slice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Slice Property

Glossary Item Box

Gets or sets a slice action information.

Syntax

Visual Basic (Declaration)
Public Property Slice As SliceAction
C#
public SliceAction Slice {get; set;}

Property Value

A SliceAction object representing the slice action information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Action Class
Action Members


ActionInfo Class

[image]
ActiveReports 19 .NET Edition
ActionInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class

Glossary Item Box

Represents information about a collection of actions.

Object Model

ActionInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ActionInfo
C#
public sealed class ActionInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ActionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInfo Members
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Class Members

[image]
ActiveReports 19 .NET Edition
ActionInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class

Glossary Item Box

The following tables list the members exposed by ActionInfo.

Public Constructors

 | Name | Description
Public Constructor | ActionInfo Constructor | Initializes a new instance of the ActionInfo class.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets a list of actions associated with this ActionInfo object.
Top

See Also

Reference

ActionInfo Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Constructor

[image]
ActiveReports 19 .NET Edition
ActionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ActionInfo Class : ActionInfo Constructor

Glossary Item Box

Initializes a new instance of the ActionInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ActionInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInfo Class
ActionInfo Members


ActionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ActionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class

Glossary Item Box

For a list of all members of this type, see ActionInfo members.

Public Properties

 | Name | Description
Public Property | Actions | Gets a list of actions associated with this ActionInfo object.
Top

See Also

Reference

ActionInfo Class
GrapeCity.ActiveReports.PageReportModel Namespace


Actions Property

[image]
ActiveReports 19 .NET Edition
Actions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ActionInfo Class : Actions Property

Glossary Item Box

Gets a list of actions associated with this ActionInfo object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As IList(Of Action)
C#
public IList<Action> Actions {get;}

Property Value

An IList object containing the Action objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInfo Class
ActionInfo Members


ApplyParameter Class

[image]
ActiveReports 19 .NET Edition
ApplyParameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParameter Class

Glossary Item Box

Represents the settings for a single apply parameters action, including parameter name, value, and type.

Object Model

ApplyParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ApplyParameter
C#
public sealed class ApplyParameter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ApplyParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParameter Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParameter Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParameter Class

Glossary Item Box

The following tables list the members exposed by ApplyParameter.

Public Constructors

 | Name | Description
Public Constructor | ApplyParameter Constructor | Initializes a new instance of the ApplyParameter class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the report parameter.
Public Property | Type | Gets or sets the type of the apply parameter action.
Public Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

ApplyParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParameter Constructor

[image]
ActiveReports 19 .NET Edition
ApplyParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParameter Class : ApplyParameter Constructor

Glossary Item Box

Initializes a new instance of the ApplyParameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ApplyParameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameter Class
ApplyParameter Members


ApplyParameter Class Properties

[image]
ActiveReports 19 .NET Edition
ApplyParameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParameter Class

Glossary Item Box

For a list of all members of this type, see ApplyParameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the report parameter.
Public Property | Type | Gets or sets the type of the apply parameter action.
Public Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

ApplyParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParameter Class : Name Property

Glossary Item Box

Gets or sets the name of the report parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameter Class
ApplyParameter Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParameter Class : Type Property

Glossary Item Box

Gets or sets the type of the apply parameter action.

Syntax

Visual Basic (Declaration)
Public Property Type As ApplyParameterType
C#
public ApplyParameterType Type {get; set;}

Property Value

An ApplyParameterType value indicating the type of the action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameter Class
ApplyParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParameter Class : Value Property

Glossary Item Box

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the parameter value.

Remarks

Must be specified for the ApplyParameterType.Set and ApplyParameterType.Toggle types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameter Class
ApplyParameter Members


ApplyParametersAction Class

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersAction Class

Glossary Item Box

Represents an element that defines an Apply Parameters action associated with an Action.

Object Model

ApplyParametersAction Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ApplyParametersAction
   Implements IValidateable
C#
public sealed class ApplyParametersAction : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ApplyParametersAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Members
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParametersAction Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersAction Class

Glossary Item Box

The following tables list the members exposed by ApplyParametersAction.

Public Constructors

 | Name | Description
Public Constructor | ApplyParametersAction Constructor | Initializes a new instance of the ApplyParametersAction class.
Top

Public Properties

 | Name | Description
Public Property | Parameters | Gets the collection of parameters to be applied within this action.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ApplyParametersAction object.
Top

See Also

Reference

ApplyParametersAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParametersAction Constructor

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParametersAction Class : ApplyParametersAction Constructor

Glossary Item Box

Initializes a new instance of the ApplyParametersAction class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ApplyParametersAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Class
ApplyParametersAction Members


ApplyParametersAction Class Methods

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersAction Class

Glossary Item Box

For a list of all members of this type, see ApplyParametersAction members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ApplyParametersAction object.
Top

See Also

Reference

ApplyParametersAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParametersAction Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ApplyParametersAction object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Class
ApplyParametersAction Members


ApplyParametersAction Class Properties

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersAction Class

Glossary Item Box

For a list of all members of this type, see ApplyParametersAction members.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the collection of parameters to be applied within this action.
Top

See Also

Reference

ApplyParametersAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParametersAction Class : Parameters Property

Glossary Item Box

Gets the collection of parameters to be applied within this action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ApplyParametersCollection
C#
public ApplyParametersCollection Parameters {get;}

Property Value

An ApplyParametersCollection object containing the parameters for this action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Class
ApplyParametersAction Members


ApplyParametersCollection Class

[image]
ActiveReports 19 .NET Edition
ApplyParametersCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersCollection Class

Glossary Item Box

Represents a collection of parameters for the 'Apply Parameters' action.

Object Model

ApplyParametersCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ApplyParametersCollection
   Inherits System.Collections.ObjectModel.Collection(Of ApplyParameter)
C#
public sealed class ApplyParametersCollection : System.Collections.ObjectModel.Collection<ApplyParameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ApplyParametersCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParametersCollection Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParametersCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParametersCollection Class

Glossary Item Box

The following tables list the members exposed by ApplyParametersCollection.

Public Constructors

 | Name | Description
Public Constructor | ApplyParametersCollection Constructor | Initializes a new instance of the ApplyParametersCollection class.
Top

See Also

Reference

ApplyParametersCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParametersCollection Constructor

[image]
ActiveReports 19 .NET Edition
ApplyParametersCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ApplyParametersCollection Class : ApplyParametersCollection Constructor

Glossary Item Box

Initializes a new instance of the ApplyParametersCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ApplyParametersCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersCollection Class
ApplyParametersCollection Members


Axis Class

[image]
ActiveReports 19 .NET Edition
Axis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

Glossary Item Box

The Axis element defines properties for labels, titles and gridlines along an axis.

Object Model

Axis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Axis
   Implements IValidateable
C#
public sealed class Axis : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Members
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Class Members

[image]
ActiveReports 19 .NET Edition
Axis Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

Glossary Item Box

The following tables list the members exposed by Axis.

Public Constructors

 | Name | Description
Public Constructor | Axis Constructor | Initializes a new instance of the Axis class.
Top

Public Properties

 | Name | Description
Public Property | CrossAt | Gets or sets the value at which to cross the other axis.
Public Property | DefaultOffset | Gets default value of offset.
Public Property | EndCap | The end cap style to use for the axis.
Public Property | Interlaced | Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Public Property | LabelsTextOrientation | Indicates the orientation of the labels text.
Public Property | Location | Gets or sets axis location related to chart data.
Public Property | LogScale | Gets or sets a value indicating whether the axis is logarithmic.
Public Property | MajorGridLines | Gets or sets a value indicating how the major gridlines are displayed.
Public Property | MajorInterval | Gets or sets the unit of measurement for major gridlines and tickmarks.
Public Property | MajorTickMarks | Gets or sets the style of the major tick marks.
Public Property | Margin | Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorGridLines | Gets or sets a value indicating how the minor gridlines are displayed.
Public Property | MinorInterval | Gets or sets the unit of measurement for minor gridlines and tickmarks.
Public Property | MinorTickMarks | Gets or sets the style of minor tick marks.
Public Property | Name | Gets or sets axis name.
Public Property | Offset | Gets or sets axis offset from previous axis (or data in case of first axis).
Public Property | ReferenceLine | Gets or sets reference line for axis.
Public Property | Reverse | Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Public Property | Scalar | Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Public Property | Style | Gets or sets text style properties for the axis labels and line style properties for the axis line.
Public Property | Title | Gets or sets the title for the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis labels are displayed.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Axis object.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Constructor

[image]
ActiveReports 19 .NET Edition
Axis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Axis Constructor

Glossary Item Box

Initializes a new instance of the Axis class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Axis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Axis Class Methods

[image]
ActiveReports 19 .NET Edition
Axis Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

Glossary Item Box

For a list of all members of this type, see Axis members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Axis object.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Validate Method

context
The ValidationContext containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Axis object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Axis Class Properties

[image]
ActiveReports 19 .NET Edition
Axis Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

Glossary Item Box

For a list of all members of this type, see Axis members.

Public Properties

 | Name | Description
Public Property | CrossAt | Gets or sets the value at which to cross the other axis.
Public Property | DefaultOffset | Gets default value of offset.
Public Property | EndCap | The end cap style to use for the axis.
Public Property | Interlaced | Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Public Property | LabelsTextOrientation | Indicates the orientation of the labels text.
Public Property | Location | Gets or sets axis location related to chart data.
Public Property | LogScale | Gets or sets a value indicating whether the axis is logarithmic.
Public Property | MajorGridLines | Gets or sets a value indicating how the major gridlines are displayed.
Public Property | MajorInterval | Gets or sets the unit of measurement for major gridlines and tickmarks.
Public Property | MajorTickMarks | Gets or sets the style of the major tick marks.
Public Property | Margin | Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorGridLines | Gets or sets a value indicating how the minor gridlines are displayed.
Public Property | MinorInterval | Gets or sets the unit of measurement for minor gridlines and tickmarks.
Public Property | MinorTickMarks | Gets or sets the style of minor tick marks.
Public Property | Name | Gets or sets axis name.
Public Property | Offset | Gets or sets axis offset from previous axis (or data in case of first axis).
Public Property | ReferenceLine | Gets or sets reference line for axis.
Public Property | Reverse | Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Public Property | Scalar | Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Public Property | Style | Gets or sets text style properties for the axis labels and line style properties for the axis line.
Public Property | Title | Gets or sets the title for the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis labels are displayed.
Top

See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


CrossAt Property

[image]
ActiveReports 19 .NET Edition
CrossAt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : CrossAt Property

Glossary Item Box

Gets or sets the value at which to cross the other axis.

Syntax

Visual Basic (Declaration)
Public Property CrossAt As ExpressionInfo
C#
public ExpressionInfo CrossAt {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the value at which to cross the other axis.

Remarks

If this value is omitted, it uses the default value for the chart type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


DefaultOffset Property

[image]
ActiveReports 19 .NET Edition
DefaultOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : DefaultOffset Property

Glossary Item Box

Gets default value of offset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultOffset As Length
C#
public Length DefaultOffset {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


EndCap Property

[image]
ActiveReports 19 .NET Edition
EndCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : EndCap Property

Glossary Item Box

The end cap style to use for the axis.

Syntax

Visual Basic (Declaration)
Public Property EndCap As ExpressionInfo
C#
public ExpressionInfo EndCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Interlaced Property

[image]
ActiveReports 19 .NET Edition
Interlaced Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Interlaced Property

Glossary Item Box

Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.

Syntax

Visual Basic (Declaration)
Public Property Interlaced As Boolean
C#
public bool Interlaced {get; set;}

Property Value

A System.Boolean value where true indicates that strip lines are drawn for every second grid line interval for the axis; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


LabelsTextOrientation Property

[image]
ActiveReports 19 .NET Edition
LabelsTextOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : LabelsTextOrientation Property

Glossary Item Box

Indicates the orientation of the labels text.

Syntax

Visual Basic (Declaration)
Public Property LabelsTextOrientation As AxisLabelOrientation
C#
public AxisLabelOrientation LabelsTextOrientation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Location Property

Glossary Item Box

Gets or sets axis location related to chart data.

Syntax

Visual Basic (Declaration)
Public Property Location As Axis.AxisLocation
C#
public Axis.AxisLocation Location {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


LogScale Property

[image]
ActiveReports 19 .NET Edition
LogScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : LogScale Property

Glossary Item Box

Gets or sets a value indicating whether the axis is logarithmic.

Syntax

Visual Basic (Declaration)
Public Property LogScale As Boolean
C#
public bool LogScale {get; set;}

Property Value

A System.Boolean value where true indicates that the axis is logarithmic; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MajorGridLines Property

[image]
ActiveReports 19 .NET Edition
MajorGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorGridLines Property

Glossary Item Box

Gets or sets a value indicating how the major gridlines are displayed.

Syntax

Visual Basic (Declaration)
Public Property MajorGridLines As GridLines
C#
public GridLines MajorGridLines {get; set;}

Property Value

A GridLines object indicating how the major gridlines are displayed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MajorInterval Property

[image]
ActiveReports 19 .NET Edition
MajorInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorInterval Property

Glossary Item Box

Gets or sets the unit of measurement for major gridlines and tickmarks.

Syntax

Visual Basic (Declaration)
Public Property MajorInterval As ExpressionInfo
C#
public ExpressionInfo MajorInterval {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the unit of measurement for major gridlines and tickmarks.

Remarks

If omitted, the axis is automatically divided.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MajorTickMarks Property

[image]
ActiveReports 19 .NET Edition
MajorTickMarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorTickMarks Property

Glossary Item Box

Gets or sets the style of the major tick marks.

Syntax

Visual Basic (Declaration)
Public Property MajorTickMarks As TickMark
C#
public TickMark MajorTickMarks {get; set;}

Property Value

A TickMark enumeration indicating whether the major tick marks are inside, outside, or cross the axis, or are nonexistent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Margin Property

[image]
ActiveReports 19 .NET Edition
Margin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Margin Property

Glossary Item Box

Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.

Syntax

Visual Basic (Declaration)
Public Property Margin As Boolean
C#
public bool Margin {get; set;}

Property Value

A System.Boolean value where true indicates that the axis margin is created; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Max Property

[image]
ActiveReports 19 .NET Edition
Max Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Max Property

Glossary Item Box

Gets or sets the maximum value for the axis.

Syntax

Visual Basic (Declaration)
Public Property Max As ExpressionInfo
C#
public ExpressionInfo Max {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the maximum value for the axis.

Remarks

If omitted, the axis automatically scales.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Min Property

[image]
ActiveReports 19 .NET Edition
Min Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Min Property

Glossary Item Box

Gets or sets the minimum value for the axis.

Syntax

Visual Basic (Declaration)
Public Property Min As ExpressionInfo
C#
public ExpressionInfo Min {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the minimum value for the axis.

Remarks

If omitted, the axis automatically scales.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MinorGridLines Property

[image]
ActiveReports 19 .NET Edition
MinorGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorGridLines Property

Glossary Item Box

Gets or sets a value indicating how the minor gridlines are displayed.

Syntax

Visual Basic (Declaration)
Public Property MinorGridLines As GridLines
C#
public GridLines MinorGridLines {get; set;}

Property Value

A GridLines object indicating how the minor gridlines are displayed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MinorInterval Property

[image]
ActiveReports 19 .NET Edition
MinorInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorInterval Property

Glossary Item Box

Gets or sets the unit of measurement for minor gridlines and tickmarks.

Syntax

Visual Basic (Declaration)
Public Property MinorInterval As ExpressionInfo
C#
public ExpressionInfo MinorInterval {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the unit of measurement for minor gridlines and tickmarks.

Remarks

If omitted, the axis is automatically divided.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


MinorTickMarks Property

[image]
ActiveReports 19 .NET Edition
MinorTickMarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorTickMarks Property

Glossary Item Box

Gets or sets the style of minor tick marks.

Syntax

Visual Basic (Declaration)
Public Property MinorTickMarks As TickMark
C#
public TickMark MinorTickMarks {get; set;}

Property Value

A TickMark enumeration indicating whether the minor tick marks are inside, outside, or cross the axis, or are nonexistent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Name Property

Glossary Item Box

Gets or sets axis name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Offset Property

[image]
ActiveReports 19 .NET Edition
Offset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Offset Property

Glossary Item Box

Gets or sets axis offset from previous axis (or data in case of first axis).

Syntax

Visual Basic (Declaration)
Public Property Offset As Length
C#
public Length Offset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


ReferenceLine Property

[image]
ActiveReports 19 .NET Edition
ReferenceLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : ReferenceLine Property

Glossary Item Box

Gets or sets reference line for axis.

Syntax

Visual Basic (Declaration)
Public Property ReferenceLine As ReferenceLine
C#
public ReferenceLine ReferenceLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Reverse Property

[image]
ActiveReports 19 .NET Edition
Reverse Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Reverse Property

Glossary Item Box

Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.

Syntax

Visual Basic (Declaration)
Public Property Reverse As Boolean
C#
public bool Reverse {get; set;}

Property Value

A System.Boolean value where true indicates that the axis direction is plotted in reverse; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Scalar Property

[image]
ActiveReports 19 .NET Edition
Scalar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Scalar Property

Glossary Item Box

Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.

Syntax

Visual Basic (Declaration)
Public Property Scalar As Boolean
C#
public bool Scalar {get; set;}

Property Value

A System.Boolean value where true indicates that the values along the axis are scalar (i.e numeric or date) values; otherwise false. The default value is false.

Remarks

Scalar cannot be true if the axis has more than one grouping, if the grouping is static or has more than one group expression, or if the axis values have labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Style Property

Glossary Item Box

Gets or sets text style properties for the axis labels and line style properties for the axis line.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object indicating the text style properties for the axis labels and line style properties for the axis line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Title Property

Glossary Item Box

Gets or sets the title for the axis.

Syntax

Visual Basic (Declaration)
Public Property Title As ChartAxisTitle
C#
public ChartAxisTitle Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the axis labels are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A System.Boolean value where true indicates that the axis labels are displayed; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


BackgroundImage Class

[image]
ActiveReports 19 .NET Edition
BackgroundImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

Glossary Item Box

Represents a background image for the style.

Object Model

BackgroundImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackgroundImage
   Implements IValidateable
C#
public sealed class BackgroundImage : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BackgroundImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundImage Class Members

[image]
ActiveReports 19 .NET Edition
BackgroundImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

Glossary Item Box

The following tables list the members exposed by BackgroundImage.

Public Constructors

 | Name | Description
Public Constructor | BackgroundImage Constructor | Initializes a new instance of the BackgroundImage class.
Top

Public Properties

 | Name | Description
Public Property | BackgroundRepeat | Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).
Public Property | MIMEType | Gets or sets the MIMEType for the image.
Public Property | Source | Gets or sets a source of the image.
Public Property | Value | Gets or sets the value of the background image (see Source).
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BackgroundImage object.
Top

See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundImage Constructor

[image]
ActiveReports 19 .NET Edition
BackgroundImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : BackgroundImage Constructor

Glossary Item Box

Initializes a new instance of the BackgroundImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BackgroundImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


BackgroundImage Class Methods

[image]
ActiveReports 19 .NET Edition
BackgroundImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

Glossary Item Box

For a list of all members of this type, see BackgroundImage members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BackgroundImage object.
Top

See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the BackgroundImage object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


BackgroundImage Class Properties

[image]
ActiveReports 19 .NET Edition
BackgroundImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

Glossary Item Box

For a list of all members of this type, see BackgroundImage members.

Public Properties

 | Name | Description
Public Property | BackgroundRepeat | Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).
Public Property | MIMEType | Gets or sets the MIMEType for the image.
Public Property | Source | Gets or sets a source of the image.
Public Property | Value | Gets or sets the value of the background image (see Source).
Top

See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundRepeat Property

[image]
ActiveReports 19 .NET Edition
BackgroundRepeat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : BackgroundRepeat Property

Glossary Item Box

Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).

Syntax

Visual Basic (Declaration)
Public Property BackgroundRepeat As ExpressionInfo
C#
public ExpressionInfo BackgroundRepeat {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BackgroundRepeat enumeration.

Remarks

Valid values are listed in the table below.

Enumerated Value | Description
Repeat | An image repeats horizontally and vertically in the background.
NoRepeat | An image is rendered once and does not repeat.
RepeatX | An image repeats horizontally in the background.
RepeatY | An image repeats vertically in the background.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : MIMEType Property

Glossary Item Box

Gets or sets the MIMEType for the image.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As ExpressionInfo
C#
public ExpressionInfo MIMEType {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a MIMEType for the image.

Remarks

Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png, image/svg+xml. MIMEType is required if the Source is set to ImageSource.Database; otherwise, it is ignored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Source Property

Glossary Item Box

Gets or sets a source of the image.

Syntax

Visual Basic (Declaration)
Public Property Source As ImageSource
C#
public ImageSource Source {get; set;}

Property Value

An ImageSource value indicating the source of the image.

Remarks

Valid values are listed in the table below.

Enumerated Value | Description
External | The Value contains a constant or expression that evaluates to the location of the image.
Embedded | The Value contains a constant or expression that evaluates to the name of an EmbeddedImage within the report.
Database | The Value contains an expression (a field in the database) that evaluates to the binary data for the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Value Property

Glossary Item Box

Gets or sets the value of the background image (see Source).

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the value of the background image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BackgroundImage Class
BackgroundImage Members


Band Class

[image]
ActiveReports 19 .NET Edition
Band Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Band Class

Glossary Item Box

Represents a band in a banded list, contains a collection of report items which repeat for every group in the rowset or each row in the dataset.

Object Model

Band Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Band
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class Band : ReportItem, IReportComponent, IValidateable

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Band

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Members
GrapeCity.ActiveReports.PageReportModel Namespace


Band Class Members

[image]
ActiveReports 19 .NET Edition
Band Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Band Class

Glossary Item Box

The following tables list the members exposed by Band.

Public Constructors

 | Name | Description
Public Constructor | Band Constructor | Initializes a new instance of the Band class.
Top

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the band can grow vertically.
Public Property | CanShrink | Gets or sets a value indicating whether the band can shrink vertically.
Public Property | PageBreak | Gets or sets the page break options.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current band.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current band.
Public Property | PrintAtBottom | Gets or sets a value indicating whether the footer band will print at the bottom of the page.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header bands are displayed on each page where the banded list is displayed.
Public Property | ReportItems | Gets a collection of report items in this band.
Top

See Also

Reference

Band Class
GrapeCity.ActiveReports.PageReportModel Namespace


Band Constructor

[image]
ActiveReports 19 .NET Edition
Band Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : Band Constructor

Glossary Item Box

Initializes a new instance of the Band class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Band()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


Band Class Properties

[image]
ActiveReports 19 .NET Edition
Band Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Band Class

Glossary Item Box

For a list of all members of this type, see Band members.

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the band can grow vertically.
Public Property | CanShrink | Gets or sets a value indicating whether the band can shrink vertically.
Public Property | PageBreak | Gets or sets the page break options.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current band.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current band.
Public Property | PrintAtBottom | Gets or sets a value indicating whether the footer band will print at the bottom of the page.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header bands are displayed on each page where the banded list is displayed.
Public Property | ReportItems | Gets a collection of report items in this band.
Top

See Also

Reference

Band Class
GrapeCity.ActiveReports.PageReportModel Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : CanGrow Property

Glossary Item Box

Gets or sets a value indicating whether the band can grow vertically.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A System.Boolean value where true if the band can grow vertically; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : CanShrink Property

Glossary Item Box

Gets or sets a value indicating whether the band can shrink vertically.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A System.Boolean value where true if the band can shrink vertically; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : PageBreak Property

Glossary Item Box

Gets or sets the page break options.

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
C#
public PageBreak PageBreak {get; set;}

Property Value

A PageBreak object representing the page break options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately after the current band.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true if a page break occurs after the band; otherwise, false.

Remarks

This property is obsolete. Use PageBreak instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately before the current band.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true if a page break occurs before the band; otherwise, false.

Remarks

This property is obsolete. Use PageBreak instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value indicating whether the footer band will print at the bottom of the page.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A System.Boolean value where true if the footer band prints at the bottom of the page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : RepeatOnNewPage Property

Glossary Item Box

Gets or sets a value indicating whether the footer or header bands are displayed on each page where the banded list is displayed.

Syntax

Visual Basic (Declaration)
Public Property RepeatOnNewPage As Boolean
C#
public bool RepeatOnNewPage {get; set;}

Property Value

A System.Boolean value where true if the footer or header bands are repeated on each page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Band Class : ReportItems Property

Glossary Item Box

Gets a collection of report items in this band.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection object containing the report items in this band.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Band Class
Band Members


BandedList Class

[image]
ActiveReports 19 .NET Edition
BandedList Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedList Class

Glossary Item Box

Represents a DataRegion is a collection of free-form bands to visualize bound data where data may be grouped by data field or an aggregate function like summary and total value.

Object Model

BandedList Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BandedList
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class BandedList : ReportItem, IReportComponent, IValidateable

Remarks

By default, it is composed of three bands: a header, a footer and a details band. The banded list may also have group header and group footer bands, which should be created when a data group was added to a banded list. Report items in these bands repeat once for each group in a banded list.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.BandedList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Members
GrapeCity.ActiveReports.PageReportModel Namespace


BandedList Class Members

[image]
ActiveReports 19 .NET Edition
BandedList Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedList Class

Glossary Item Box

The following tables list the members exposed by BandedList.

Public Constructors

 | Name | Description
Public Constructor | BandedList Constructor | Initializes a new instance of the BandedList class.
Top

Public Properties

 | Name | Description
Public Property | CustomData | Gets or sets the custom data settings used by the custom report item.
Public Property | Details | Gets or sets the details band (if any) for this banded list.
Public Property | FixedHeight | Gets or sets a fixed height of the banded list for FPL reports.
Public Property | FixedWidth | Gets or sets a fixed width of the banded list for FPL reports.
Public Property | Footer | Gets or sets a footer that is rendered at the bottom of this banded list.
Public Property | Groups | Gets a collection of groups for this banded list.
Public Property | Header | Gets or sets a header that is rendered at the top of this banded list.
Public Property | NewPage | Gets or sets a page on which the content should start after the page break.
Public Property | NewSection | Gets or sets a value indicating whether this group is in its own section.
Public Property | OverflowName | Gets or sets an overflow name of the banded list for FPL reports.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current banded list.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current banded list.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the orphaned header is displayed on the page.
Top

See Also

Reference

BandedList Class
GrapeCity.ActiveReports.PageReportModel Namespace


BandedList Constructor

[image]
ActiveReports 19 .NET Edition
BandedList Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : BandedList Constructor

Glossary Item Box

Initializes a new instance of the BandedList class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BandedList()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


BandedList Class Properties

[image]
ActiveReports 19 .NET Edition
BandedList Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedList Class

Glossary Item Box

For a list of all members of this type, see BandedList members.

Public Properties

 | Name | Description
Public Property | CustomData | Gets or sets the custom data settings used by the custom report item.
Public Property | Details | Gets or sets the details band (if any) for this banded list.
Public Property | FixedHeight | Gets or sets a fixed height of the banded list for FPL reports.
Public Property | FixedWidth | Gets or sets a fixed width of the banded list for FPL reports.
Public Property | Footer | Gets or sets a footer that is rendered at the bottom of this banded list.
Public Property | Groups | Gets a collection of groups for this banded list.
Public Property | Header | Gets or sets a header that is rendered at the top of this banded list.
Public Property | NewPage | Gets or sets a page on which the content should start after the page break.
Public Property | NewSection | Gets or sets a value indicating whether this group is in its own section.
Public Property | OverflowName | Gets or sets an overflow name of the banded list for FPL reports.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current banded list.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current banded list.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the orphaned header is displayed on the page.
Top

See Also

Reference

BandedList Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomData Property

[image]
ActiveReports 19 .NET Edition
CustomData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : CustomData Property

Glossary Item Box

Gets or sets the custom data settings used by the custom report item.

Syntax

Visual Basic (Declaration)
Public Property CustomData As CustomData
C#
public CustomData CustomData {get; set;}

Property Value

A CustomData object representing the custom data settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : Details Property

Glossary Item Box

Gets or sets the details band (if any) for this banded list.

Syntax

Visual Basic (Declaration)
Public Property Details As Band
C#
public Band Details {get; set;}

Property Value

A Band object representing the details band.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


FixedHeight Property

[image]
ActiveReports 19 .NET Edition
FixedHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : FixedHeight Property

Glossary Item Box

Gets or sets a fixed height of the banded list for FPL reports.

Syntax

Visual Basic (Declaration)
Public Property FixedHeight As Length
C#
public Length FixedHeight {get; set;}

Property Value

A Length value indicating the fixed height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


FixedWidth Property

[image]
ActiveReports 19 .NET Edition
FixedWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : FixedWidth Property

Glossary Item Box

Gets or sets a fixed width of the banded list for FPL reports.

Syntax

Visual Basic (Declaration)
Public Property FixedWidth As Length
C#
public Length FixedWidth {get; set;}

Property Value

A Length value indicating the fixed width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : Footer Property

Glossary Item Box

Gets or sets a footer that is rendered at the bottom of this banded list.

Syntax

Visual Basic (Declaration)
Public Property Footer As Band
C#
public Band Footer {get; set;}

Property Value

A Band object representing the footer of the banded list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


Groups Property

[image]
ActiveReports 19 .NET Edition
Groups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : Groups Property

Glossary Item Box

Gets a collection of groups for this banded list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groups As List(Of BandedListGroup)
C#
public List<BandedListGroup> Groups {get;}

Property Value

A collection of BandedListGroup objects representing the groups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : Header Property

Glossary Item Box

Gets or sets a header that is rendered at the top of this banded list.

Syntax

Visual Basic (Declaration)
Public Property Header As Band
C#
public Band Header {get; set;}

Property Value

A Band object representing the header of the banded list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : NewPage Property

Glossary Item Box

Gets or sets a page on which the content should start after the page break.

Syntax

Visual Basic (Declaration)
Public Property NewPage As StartNewPage
C#
public StartNewPage NewPage {get; set;}

Property Value

A StartNewPage value indicating the start page after the page break.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : NewSection Property

Glossary Item Box

Gets or sets a value indicating whether this group is in its own section.

Syntax

Visual Basic (Declaration)
Public Property NewSection As Boolean
C#
public bool NewSection {get; set;}

Property Value

A System.Boolean value where true if the group is in its own section; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : OverflowName Property

Glossary Item Box

Gets or sets an overflow name of the banded list for FPL reports.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A System.String value indicating the overflow name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately after the current banded list.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true if a page break occurs after the banded list; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately before the current banded list.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true if a page break occurs before the banded list; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : PreventOrphanedFooter Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedFooter As Boolean
C#
public bool PreventOrphanedFooter {get; set;}

Property Value

A System.Boolean value where true if the orphaned footer is displayed on the next page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedList Class : PreventOrphanedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned header is displayed on the page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedHeader As Boolean
C#
public bool PreventOrphanedHeader {get; set;}

Property Value

A System.Boolean value where true if the orphaned header is displayed on the page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedList Class
BandedList Members


BandedListGroup Class

[image]
ActiveReports 19 .NET Edition
BandedListGroup Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListGroup Class

Glossary Item Box

Represents a banded list group, allows to group the details bands by one or multiple criteria.

Object Model

BandedListGroup Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BandedListGroup
   Inherits ReportComponent
   Implements IReportComponent
C#
public sealed class BandedListGroup : ReportComponent, IReportComponent

Remarks

The banded list group may have header and footer bands, which repeat for each group.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.BandedListGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Members
GrapeCity.ActiveReports.PageReportModel Namespace


BandedListGroup Class Members

[image]
ActiveReports 19 .NET Edition
BandedListGroup Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListGroup Class

Glossary Item Box

The following tables list the members exposed by BandedListGroup.

Public Constructors

 | Name | Description
Public Constructor | BandedListGroup Constructor | Initializes a new instance of the BandedListGroup class.
Top

Public Properties

 | Name | Description
Public Property | Footer | Gets or sets a footer that is rendered at the bottom of each group.
Public Property | Header | Gets or sets a header that is rendered at the top of each group.
Public Property | KeepTogether | Gets or sets a value indicating whether the group is kept together on a single page where possible.
Public Property | Name | Gets or sets a name of this banded list group.
Public Property | NewSection | Gets or sets a value indicating whether this group is in its own section.
Public Property | PageBreak | Gets or sets a page break options.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current group.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current group.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the orphaned header is displayed on the page.
Public Property | Visibility | Gets or sets a value indicating whether the group is hidden.
Top

See Also

Reference

BandedListGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


BandedListGroup Constructor

[image]
ActiveReports 19 .NET Edition
BandedListGroup Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : BandedListGroup Constructor

Glossary Item Box

Initializes a new instance of the BandedListGroup class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BandedListGroup()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


BandedListGroup Class Properties

[image]
ActiveReports 19 .NET Edition
BandedListGroup Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListGroup Class

Glossary Item Box

For a list of all members of this type, see BandedListGroup members.

Public Properties

 | Name | Description
Public Property | Footer | Gets or sets a footer that is rendered at the bottom of each group.
Public Property | Header | Gets or sets a header that is rendered at the top of each group.
Public Property | KeepTogether | Gets or sets a value indicating whether the group is kept together on a single page where possible.
Public Property | Name | Gets or sets a name of this banded list group.
Public Property | NewSection | Gets or sets a value indicating whether this group is in its own section.
Public Property | PageBreak | Gets or sets a page break options.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the current group.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the current group.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the orphaned header is displayed on the page.
Public Property | Visibility | Gets or sets a value indicating whether the group is hidden.
Top

See Also

Reference

BandedListGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : Footer Property

Glossary Item Box

Gets or sets a footer that is rendered at the bottom of each group.

Syntax

Visual Basic (Declaration)
Public Property Footer As Band
C#
public Band Footer {get; set;}

Property Value

A Band object representing the footer of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : Header Property

Glossary Item Box

Gets or sets a header that is rendered at the top of each group.

Syntax

Visual Basic (Declaration)
Public Property Header As Band
C#
public Band Header {get; set;}

Property Value

A Band object representing the header of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : KeepTogether Property

Glossary Item Box

Gets or sets a value indicating whether the group is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A System.Boolean value where true if the group is kept together on a single page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : Name Property

Glossary Item Box

Gets or sets a name of this banded list group.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : NewSection Property

Glossary Item Box

Gets or sets a value indicating whether this group is in its own section.

Syntax

Visual Basic (Declaration)
Public Property NewSection As Boolean
C#
public bool NewSection {get; set;}

Property Value

A System.Boolean value where true if the group is in its own section; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : PageBreak Property

Glossary Item Box

Gets or sets a page break options.

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
C#
public PageBreak PageBreak {get; set;}

Property Value

A PageBreak object representing the page break options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately after the current group.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true if a page break occurs after the group; otherwise, false.

Remarks

This property is obsolete. Use PageBreak instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately before the current group.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true if a page break occurs before the group; otherwise, false.

Remarks

This property is obsolete. Use PageBreak instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : PreventOrphanedFooter Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedFooter As Boolean
C#
public bool PreventOrphanedFooter {get; set;}

Property Value

A System.Boolean value where true if the orphaned footer is displayed on the next page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : PreventOrphanedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned header is displayed on the page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedHeader As Boolean
C#
public bool PreventOrphanedHeader {get; set;}

Property Value

A System.Boolean value where true if the orphaned header is displayed on the page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListGroup Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the group is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListGroup Class
BandedListGroup Members


BandedListLoader Class

[image]
ActiveReports 19 .NET Edition
BandedListLoader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListLoader Class

Glossary Item Box

Represents a builder loading the banded lists from a custom report items.

Object Model

BandedListLoader Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class BandedListLoader
C#
public static class BandedListLoader

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BandedListLoader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListLoader Members
GrapeCity.ActiveReports.PageReportModel Namespace


BandedListLoader Class Members

[image]
ActiveReports 19 .NET Edition
BandedListLoader Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListLoader Class

Glossary Item Box

The following tables list the members exposed by BandedListLoader.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromCustomReportItem | Loads a BandedList from a CustomReportItem.
Top

See Also

Reference

BandedListLoader Class
GrapeCity.ActiveReports.PageReportModel Namespace


BandedListLoader Class Methods

[image]
ActiveReports 19 .NET Edition
BandedListLoader Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandedListLoader Class

Glossary Item Box

For a list of all members of this type, see BandedListLoader members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromCustomReportItem | Loads a BandedList from a CustomReportItem.
Top

See Also

Reference

BandedListLoader Class
GrapeCity.ActiveReports.PageReportModel Namespace


FromCustomReportItem Method

[image]
ActiveReports 19 .NET Edition
FromCustomReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandedListLoader Class : FromCustomReportItem Method

item
A CustomReportItem object to load the banded list from.

Glossary Item Box

Loads a BandedList from a CustomReportItem.

Syntax

Visual Basic (Declaration)
Public Shared Function FromCustomReportItem( _
   ByVal item As CustomReportItem _
) As BandedList
C#
public static BandedList FromCustomReportItem(
   CustomReportItem item
)

Parameters

item
A CustomReportItem object to load the banded list from.

Return Value

A new BandedList object loaded from the specified custom report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandedListLoader Class
BandedListLoader Members


BandLayoutOptions Class

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandLayoutOptions Class

Glossary Item Box

Represents a specific layout options to use when the Tablix is rendered on the canvas.

Object Model

BandLayoutOptions Class

Syntax

Visual Basic (Declaration)
Public Class BandLayoutOptions
C#
public class BandLayoutOptions

Remarks

The BandLayoutOptions class provides various settings for rendering a tablix on the canvas. It includes properties to specify the number of rows and columns per band, as well as settings for different navigation styles like CoverFlow, PlayAxis, and TabStrip.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BandLayoutOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Members
GrapeCity.ActiveReports.PageReportModel Namespace


BandLayoutOptions Class Members

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandLayoutOptions Class

Glossary Item Box

The following tables list the members exposed by BandLayoutOptions.

Public Constructors

 | Name | Description
Public Constructor | BandLayoutOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets or sets a number of columns that should be displayed on each band sheet when the tablix is rendered.
Public Property | CoverFlow | Gets or sets the coverflow settings.
Public Property | PlayAxis | Gets or sets the play axis settings.
Public Property | RowCount | Gets or sets a number of rows that should be displayed on each band sheet when the tablix is rendered.
Public Property | TabStrip | Gets or sets the tabstrip settings.
Top

See Also

Reference

BandLayoutOptions Class
GrapeCity.ActiveReports.PageReportModel Namespace


BandLayoutOptions Constructor

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : BandLayoutOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BandLayoutOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


BandLayoutOptions Class Properties

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BandLayoutOptions Class

Glossary Item Box

For a list of all members of this type, see BandLayoutOptions members.

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets or sets a number of columns that should be displayed on each band sheet when the tablix is rendered.
Public Property | CoverFlow | Gets or sets the coverflow settings.
Public Property | PlayAxis | Gets or sets the play axis settings.
Public Property | RowCount | Gets or sets a number of rows that should be displayed on each band sheet when the tablix is rendered.
Public Property | TabStrip | Gets or sets the tabstrip settings.
Top

See Also

Reference

BandLayoutOptions Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnCount Property

[image]
ActiveReports 19 .NET Edition
ColumnCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : ColumnCount Property

Glossary Item Box

Gets or sets a number of columns that should be displayed on each band sheet when the tablix is rendered.

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
C#
public int ColumnCount {get; set;}

Property Value

An System.Int32 value indicating the number of columns per band sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


CoverFlow Property

[image]
ActiveReports 19 .NET Edition
CoverFlow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : CoverFlow Property

Glossary Item Box

Gets or sets the coverflow settings.

Syntax

Visual Basic (Declaration)
Public Property CoverFlow As CoverFlow
C#
public CoverFlow CoverFlow {get; set;}

Property Value

A CoverFlow object representing the coverflow settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


PlayAxis Property

[image]
ActiveReports 19 .NET Edition
PlayAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : PlayAxis Property

Glossary Item Box

Gets or sets the play axis settings.

Syntax

Visual Basic (Declaration)
Public Property PlayAxis As PlayAxis
C#
public PlayAxis PlayAxis {get; set;}

Property Value

A PlayAxis object representing the play axis settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


RowCount Property

[image]
ActiveReports 19 .NET Edition
RowCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : RowCount Property

Glossary Item Box

Gets or sets a number of rows that should be displayed on each band sheet when the tablix is rendered.

Syntax

Visual Basic (Declaration)
Public Property RowCount As Integer
C#
public int RowCount {get; set;}

Property Value

An System.Int32 value indicating the number of rows per band sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


TabStrip Property

[image]
ActiveReports 19 .NET Edition
TabStrip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BandLayoutOptions Class : TabStrip Property

Glossary Item Box

Gets or sets the tabstrip settings.

Syntax

Visual Basic (Declaration)
Public Property TabStrip As TabStrip
C#
public TabStrip TabStrip {get; set;}

Property Value

A TabStrip object representing the tabstrip settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BandLayoutOptions Class
BandLayoutOptions Members


Body Class

[image]
ActiveReports 19 .NET Edition
Body Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

Glossary Item Box

Represents the body section of a report, serving as the main container for all report items.

Object Model

Body Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Body
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Body : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Body

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Members
GrapeCity.ActiveReports.PageReportModel Namespace


Body Class Members

[image]
ActiveReports 19 .NET Edition
Body Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

Glossary Item Box

The following tables list the members exposed by Body.

Public Constructors

 | Name | Description
Public Constructor | Body Constructor | Initializes a new instance of the Body class.
Top

Public Properties

 | Name | Description
Public Property | Columns | Gets or sets a number of columns in the report.
Public Property | ColumnSpacing | Gets or sets the spacing between columns in the report body.
Public Property | Height | Gets or sets a height of the report body.
Public Property | Style | Gets or sets the style properties for the report body.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Body object.
Top

See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Body Constructor

[image]
ActiveReports 19 .NET Edition
Body Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Body Constructor

Glossary Item Box

Initializes a new instance of the Body class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Body()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


Body Class Methods

[image]
ActiveReports 19 .NET Edition
Body Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

Glossary Item Box

For a list of all members of this type, see Body members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Body object.
Top

See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Body object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


Body Class Properties

[image]
ActiveReports 19 .NET Edition
Body Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

Glossary Item Box

For a list of all members of this type, see Body members.

Public Properties

 | Name | Description
Public Property | Columns | Gets or sets a number of columns in the report.
Public Property | ColumnSpacing | Gets or sets the spacing between columns in the report body.
Public Property | Height | Gets or sets a height of the report body.
Public Property | Style | Gets or sets the style properties for the report body.
Top

See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Columns Property

Glossary Item Box

Gets or sets a number of columns in the report.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
C#
public int Columns {get; set;}

Property Value

An System.Int32 value indicating the number of columns. Default is 1, with a minimum of 1 and a maximum of 100.

Example

C# Copy Code
Body body = new Body();
body.Columns = 3;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


ColumnSpacing Property

[image]
ActiveReports 19 .NET Edition
ColumnSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : ColumnSpacing Property

Glossary Item Box

Gets or sets the spacing between columns in the report body.

Syntax

Visual Basic (Declaration)
Public Property ColumnSpacing As Length
C#
public Length ColumnSpacing {get; set;}

Property Value

A Length value indicating the column spacing. Default is 0.5 inches.

Example

C# Copy Code
Body body = new Body();
body.ColumnSpacing = "0.75in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Height Property

Glossary Item Box

Gets or sets a height of the report body.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the report body.

Example

C# Copy Code
Body body = new Body();
body.Height = "11in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Style Property

Glossary Item Box

Gets or sets the style properties for the report body.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object representing the style settings for the body.

Remarks

The body is styled similarly to a ReportItem, except the Style.Language property does not apply.

Example

C# Copy Code
Body body = new Body();
body.Style = new Style { BackgroundColor = "LightGray" };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Body Class
Body Members


Border Class

[image]
ActiveReports 19 .NET Edition
Border Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

Glossary Item Box

Represents the properties of a border in a report item.

Object Model

Border Class

Syntax

Visual Basic (Declaration)
Public Class Border
C#
public class Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Border

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Members
GrapeCity.ActiveReports.PageReportModel Namespace


Border Class Members

[image]
ActiveReports 19 .NET Edition
Border Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

Glossary Item Box

The following tables list the members exposed by Border.

Public Constructors

 | Name | Description
Public Constructor | Border Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColorDefaultValue | The default color of the border.
static (Shared in Visual Basic) | WidthDefaultValue | The default width of the border.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the border.
Public Property | Style | Gets or sets the style of the border.
Public Property | Width | Gets or sets the width of the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


Border Constructor

[image]
ActiveReports 19 .NET Edition
Border Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Border Constructor

Glossary Item Box

Overload List

Overload | Description
Border Constructor() | Initializes a new instance of the Border class.
Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo) | Initializes a new instance of the Border class using the specified style, width, and color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Constructor()

[image]
ActiveReports 19 .NET Edition
Border Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class > Border Constructor : Border Constructor()

Glossary Item Box

Initializes a new instance of the Border class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Border()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)

[image]
ActiveReports 19 .NET Edition
Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class > Border Constructor : Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)

style
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the style of the border.
width
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the width of the border.
color
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the color of the border.

Glossary Item Box

Initializes a new instance of the Border class using the specified style, width, and color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As ExpressionInfo, _
   ByVal width As ExpressionInfo, _
   ByVal color As ExpressionInfo _
)
C#
public Border(
   ExpressionInfo style,
   ExpressionInfo width,
   ExpressionInfo color
)

Parameters

style
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the style of the border.
width
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the width of the border.
color
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the color of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
Overload List


Border Class Properties

[image]
ActiveReports 19 .NET Edition
Border Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of the border.
Public Property | Style | Gets or sets the style of the border.
Public Property | Width | Gets or sets the width of the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Color Property

Glossary Item Box

Gets or sets the color of the border.

Syntax

Visual Basic (Declaration)
Public Property Color As ExpressionInfo
C#
public ExpressionInfo Color {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the color of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Style Property

Glossary Item Box

Gets or sets the style of the border.

Syntax

Visual Basic (Declaration)
Public Property Style As ExpressionInfo
C#
public ExpressionInfo Style {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the style of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Width Property

Glossary Item Box

Gets or sets the width of the border.

Syntax

Visual Basic (Declaration)
Public Property Width As ExpressionInfo
C#
public ExpressionInfo Width {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the width of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Fields

[image]
ActiveReports 19 .NET Edition
Border Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColorDefaultValue | The default color of the border.
static (Shared in Visual Basic) | WidthDefaultValue | The default width of the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColorDefaultValue Field

[image]
ActiveReports 19 .NET Edition
ColorDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : ColorDefaultValue Field

Glossary Item Box

The default color of the border.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColorDefaultValue As ExpressionInfo
C#
public static readonly ExpressionInfo ColorDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


WidthDefaultValue Field

[image]
ActiveReports 19 .NET Edition
WidthDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : WidthDefaultValue Field

Glossary Item Box

The default width of the border.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly WidthDefaultValue As Length
C#
public static readonly Length WidthDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


BorderColor Class

[image]
ActiveReports 19 .NET Edition
BorderColor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

Glossary Item Box

Represents a color of the border for the style.

Object Model

BorderColor Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BorderColor
   Implements IValidateable
C#
public sealed class BorderColor : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderColor Class Members

[image]
ActiveReports 19 .NET Edition
BorderColor Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

Glossary Item Box

The following tables list the members exposed by BorderColor.

Public Constructors

 | Name | Description
Public Constructor | BorderColor Constructor | Initializes a new instance of the BorderColor class.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a color of the bottom border.
Public Property | Default | Gets or sets a color of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a color of the left border.
Public Property | Right | Gets or sets a color of the right border.
Public Property | Top | Gets or sets a color of the top border.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderColor object.
Top

See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderColor Constructor

[image]
ActiveReports 19 .NET Edition
BorderColor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : BorderColor Constructor

Glossary Item Box

Initializes a new instance of the BorderColor class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderColor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


BorderColor Class Methods

[image]
ActiveReports 19 .NET Edition
BorderColor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

Glossary Item Box

For a list of all members of this type, see BorderColor members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderColor object.
Top

See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the BorderColor object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


BorderColor Class Properties

[image]
ActiveReports 19 .NET Edition
BorderColor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

Glossary Item Box

For a list of all members of this type, see BorderColor members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a color of the bottom border.
Public Property | Default | Gets or sets a color of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a color of the left border.
Public Property | Right | Gets or sets a color of the right border.
Public Property | Top | Gets or sets a color of the top border.
Top

See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Bottom Property

Glossary Item Box

Gets or sets a color of the bottom border.

Syntax

Visual Basic (Declaration)
Public Property Bottom As ExpressionInfo
C#
public ExpressionInfo Bottom {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the color of the bottom border.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Default Property

Glossary Item Box

Gets or sets a color of the border (unless overridden for a specific side).

Syntax

Visual Basic (Declaration)
Public Property Default As ExpressionInfo
C#
public ExpressionInfo Default {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the color of the border.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Left Property

Glossary Item Box

Gets or sets a color of the left border.

Syntax

Visual Basic (Declaration)
Public Property Left As ExpressionInfo
C#
public ExpressionInfo Left {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the color of the left border.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Right Property

Glossary Item Box

Gets or sets a color of the right border.

Syntax

Visual Basic (Declaration)
Public Property Right As ExpressionInfo
C#
public ExpressionInfo Right {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the color of the right border.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Top Property

Glossary Item Box

Gets or sets a color of the top border.

Syntax

Visual Basic (Declaration)
Public Property Top As ExpressionInfo
C#
public ExpressionInfo Top {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the color of the top border.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderColor Class
BorderColor Members


BorderStyle Class

[image]
ActiveReports 19 .NET Edition
BorderStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

Glossary Item Box

Represents the style for the border.

Object Model

BorderStyle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BorderStyle
   Implements IValidateable
C#
public sealed class BorderStyle : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderStyle Class Members

[image]
ActiveReports 19 .NET Edition
BorderStyle Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

Glossary Item Box

The following tables list the members exposed by BorderStyle.

Public Constructors

 | Name | Description
Public Constructor | BorderStyle Constructor | Initializes a new instance of the BorderStyle class.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a style of the bottom border.
Public Property | Default | Gets or sets a style of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a style of the left border.
Public Property | Right | Gets or sets a style of the right border.
Public Property | Top | Gets or sets a style of the top border.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderStyle object.
Top

See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderStyle Constructor

[image]
ActiveReports 19 .NET Edition
BorderStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : BorderStyle Constructor

Glossary Item Box

Initializes a new instance of the BorderStyle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


BorderStyle Class Methods

[image]
ActiveReports 19 .NET Edition
BorderStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

Glossary Item Box

For a list of all members of this type, see BorderStyle members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderStyle object.
Top

See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the BorderStyle object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


BorderStyle Class Properties

[image]
ActiveReports 19 .NET Edition
BorderStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

Glossary Item Box

For a list of all members of this type, see BorderStyle members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a style of the bottom border.
Public Property | Default | Gets or sets a style of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a style of the left border.
Public Property | Right | Gets or sets a style of the right border.
Public Property | Top | Gets or sets a style of the top border.
Top

See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Bottom Property

Glossary Item Box

Gets or sets a style of the bottom border.

Syntax

Visual Basic (Declaration)
Public Property Bottom As ExpressionInfo
C#
public ExpressionInfo Bottom {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BorderDrawingStyle value for the bottom border.

Remarks

Default value is BorderDrawingStyle.None. Valid values are listed in the table below.

BorderStyle | Description
None | No border line is drawn around the report item.
Dotted | A dotted line is drawn around the report item.
Dashed | A dashed line is drawn around the report item.
Solid | A solid line is drawn around the report item.
Double | A double line is drawn around the report item.
Groove | A grooved line is drawn around the report item.
Ridge | A ridged line is drawn around the report item.
Inset | An inset line is drawn around the report item.
WindowInset | A Windows-style inset line is drawn around the report item.
Outset | An outset line is drawn around the report item.
DashDot | A line of alternating dashes and dots is drawn around the report item.
DashDotDot | A line of alternating dashes and double-dots is drawn around the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Default Property

Glossary Item Box

Gets or sets a style of the border (unless overridden for a specific side).

Syntax

Visual Basic (Declaration)
Public Property Default As ExpressionInfo
C#
public ExpressionInfo Default {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BorderDrawingStyle value for the border.

Remarks

Default value is BorderDrawingStyle.None. Valid values are listed in the table below.

BorderStyle | Description
None | No border line is drawn around the report item.
Dotted | A dotted line is drawn around the report item.
Dashed | A dashed line is drawn around the report item.
Solid | A solid line is drawn around the report item.
Double | A double line is drawn around the report item.
Groove | A grooved line is drawn around the report item.
Ridge | A ridged line is drawn around the report item.
Inset | An inset line is drawn around the report item.
WindowInset | A Windows-style inset line is drawn around the report item.
Outset | An outset line is drawn around the report item.
DashDot | A line of alternating dashes and dots is drawn around the report item.
DashDotDot | A line of alternating dashes and double-dots is drawn around the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Left Property

Glossary Item Box

Gets or sets a style of the left border.

Syntax

Visual Basic (Declaration)
Public Property Left As ExpressionInfo
C#
public ExpressionInfo Left {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BorderDrawingStyle value for the left border.

Remarks

Default value is BorderDrawingStyle.None. Valid values are listed in the table below.

BorderStyle | Description
None | No border line is drawn around the report item.
Dotted | A dotted line is drawn around the report item.
Dashed | A dashed line is drawn around the report item.
Solid | A solid line is drawn around the report item.
Double | A double line is drawn around the report item.
Groove | A grooved line is drawn around the report item.
Ridge | A ridged line is drawn around the report item.
Inset | An inset line is drawn around the report item.
WindowInset | A Windows-style inset line is drawn around the report item.
Outset | An outset line is drawn around the report item.
DashDot | A line of alternating dashes and dots is drawn around the report item.
DashDotDot | A line of alternating dashes and double-dots is drawn around the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Right Property

Glossary Item Box

Gets or sets a style of the right border.

Syntax

Visual Basic (Declaration)
Public Property Right As ExpressionInfo
C#
public ExpressionInfo Right {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BorderDrawingStyle value for the right border.

Remarks

Default value is BorderDrawingStyle.None. Valid values are listed in the table below.

BorderStyle | Description
None | No border line is drawn around the report item.
Dotted | A dotted line is drawn around the report item.
Dashed | A dashed line is drawn around the report item.
Solid | A solid line is drawn around the report item.
Double | A double line is drawn around the report item.
Groove | A grooved line is drawn around the report item.
Ridge | A ridged line is drawn around the report item.
Inset | An inset line is drawn around the report item.
WindowInset | A Windows-style inset line is drawn around the report item.
Outset | An outset line is drawn around the report item.
DashDot | A line of alternating dashes and dots is drawn around the report item.
DashDotDot | A line of alternating dashes and double-dots is drawn around the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Top Property

Glossary Item Box

Gets or sets a style of the top border.

Syntax

Visual Basic (Declaration)
Public Property Top As ExpressionInfo
C#
public ExpressionInfo Top {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a BorderDrawingStyle value for the top border.

Remarks

Default value is BorderDrawingStyle.None. Valid values are listed in the table below.

BorderStyle | Description
None | No border line is drawn around the report item.
Dotted | A dotted line is drawn around the report item.
Dashed | A dashed line is drawn around the report item.
Solid | A solid line is drawn around the report item.
Double | A double line is drawn around the report item.
Groove | A grooved line is drawn around the report item.
Ridge | A ridged line is drawn around the report item.
Inset | An inset line is drawn around the report item.
WindowInset | A Windows-style inset line is drawn around the report item.
Outset | An outset line is drawn around the report item.
DashDot | A line of alternating dashes and dots is drawn around the report item.
DashDotDot | A line of alternating dashes and double-dots is drawn around the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderStyle Class
BorderStyle Members


BorderWidth Class

[image]
ActiveReports 19 .NET Edition
BorderWidth Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

Glossary Item Box

Represents a width of the border for the style.

Object Model

BorderWidth Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BorderWidth
   Implements IValidateable
C#
public sealed class BorderWidth : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderWidth Class Members

[image]
ActiveReports 19 .NET Edition
BorderWidth Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

Glossary Item Box

The following tables list the members exposed by BorderWidth.

Public Constructors

 | Name | Description
Public Constructor | BorderWidth Constructor | Initializes a new instance of the BorderWidth class.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a width of the bottom border.
Public Property | Default | Gets or sets a width of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a width of the left border.
Public Property | Right | Gets or sets a width of the right border.
Public Property | Top | Gets or sets a width of the top border.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderWidth object.
Top

See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderWidth Constructor

[image]
ActiveReports 19 .NET Edition
BorderWidth Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : BorderWidth Constructor

Glossary Item Box

Initializes a new instance of the BorderWidth class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderWidth()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


BorderWidth Class Methods

[image]
ActiveReports 19 .NET Edition
BorderWidth Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

Glossary Item Box

For a list of all members of this type, see BorderWidth members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the BorderWidth object.
Top

See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the BorderWidth object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


BorderWidth Class Properties

[image]
ActiveReports 19 .NET Edition
BorderWidth Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

Glossary Item Box

For a list of all members of this type, see BorderWidth members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets a width of the bottom border.
Public Property | Default | Gets or sets a width of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets a width of the left border.
Public Property | Right | Gets or sets a width of the right border.
Public Property | Top | Gets or sets a width of the top border.
Top

See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property

[image]
ActiveReports 19 .NET Edition
Bottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Bottom Property

Glossary Item Box

Gets or sets a width of the bottom border.

Syntax

Visual Basic (Declaration)
Public Property Bottom As ExpressionInfo
C#
public ExpressionInfo Bottom {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a Length value indicating the width of the bottom border.

Remarks

Default value is 1pt; the maximum is 20pt; the minimum is .25pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Default Property

Glossary Item Box

Gets or sets a width of the border (unless overridden for a specific side).

Syntax

Visual Basic (Declaration)
Public Property Default As ExpressionInfo
C#
public ExpressionInfo Default {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a Length value indicating the width of the border.

Remarks

Default value is 1pt; the maximum is 20pt; the minimum is .25pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Left Property

Glossary Item Box

Gets or sets a width of the left border.

Syntax

Visual Basic (Declaration)
Public Property Left As ExpressionInfo
C#
public ExpressionInfo Left {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a Length value indicating the width of the left border.

Remarks

Default value is 1pt; the maximum is 20pt; the minimum is .25pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


Right Property

[image]
ActiveReports 19 .NET Edition
Right Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Right Property

Glossary Item Box

Gets or sets a width of the right border.

Syntax

Visual Basic (Declaration)
Public Property Right As ExpressionInfo
C#
public ExpressionInfo Right {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a Length value indicating the width of the right border.

Remarks

Default value is 1pt; the maximum is 20pt; the minimum is .25pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Top Property

Glossary Item Box

Gets or sets a width of the top border.

Syntax

Visual Basic (Declaration)
Public Property Top As ExpressionInfo
C#
public ExpressionInfo Top {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to a Length value indicating the width of the top border.

Remarks

Default value is 1pt; the maximum is 20pt; the minimum is .25pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderWidth Class
BorderWidth Members


CategoryGrouping Class

[image]
ActiveReports 19 .NET Edition
CategoryGrouping Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

Glossary Item Box

The CategoryGrouping element defines the category level for a Chart. The labels for the categories are displayed along the category axis.

Object Model

CategoryGrouping Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CategoryGrouping
   Inherits ReportComponent
   Implements IReportComponent, IValidateable
C#
public sealed class CategoryGrouping : ReportComponent, IReportComponent, IValidateable

Remarks

A CategoryGrouping object must have either a defined DynamicCategories or a defined StaticCategories property, but not both.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.CategoryGrouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGrouping Class Members

[image]
ActiveReports 19 .NET Edition
CategoryGrouping Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

Glossary Item Box

The following tables list the members exposed by CategoryGrouping.

Public Constructors

 | Name | Description
Public Constructor | CategoryGrouping Constructor | Initializes a new instance of the CategoryGrouping class.
Top

Public Properties

 | Name | Description
Public Property | DynamicCategories | Gets the dynamic category headings for the grouping.
Public Property | StaticCategories | Gets the static category headings for the grouping.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the CategoryGrouping object.
Top

See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGrouping Constructor

[image]
ActiveReports 19 .NET Edition
CategoryGrouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : CategoryGrouping Constructor

Glossary Item Box

Initializes a new instance of the CategoryGrouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CategoryGrouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGrouping Class Methods

[image]
ActiveReports 19 .NET Edition
CategoryGrouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

Glossary Item Box

For a list of all members of this type, see CategoryGrouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the CategoryGrouping object.
Top

See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the CategoryGrouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGrouping Class Properties

[image]
ActiveReports 19 .NET Edition
CategoryGrouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

Glossary Item Box

For a list of all members of this type, see CategoryGrouping members.

Public Properties

 | Name | Description
Public Property | DynamicCategories | Gets the dynamic category headings for the grouping.
Public Property | StaticCategories | Gets the static category headings for the grouping.
Top

See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategories Property

[image]
ActiveReports 19 .NET Edition
DynamicCategories Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : DynamicCategories Property

Glossary Item Box

Gets the dynamic category headings for the grouping.

Syntax

Visual Basic (Declaration)
Public Property DynamicCategories As DynamicCategoriesSeries
C#
public DynamicCategoriesSeries DynamicCategories {get; set;}

Property Value

A DynamicCategoriesSeries object indicating the dynamic category headings for the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


StaticCategories Property

[image]
ActiveReports 19 .NET Edition
StaticCategories Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : StaticCategories Property

Glossary Item Box

Gets the static category headings for the grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticCategories As StaticMemberCollection
C#
public StaticMemberCollection StaticCategories {get;}

Property Value

A StaticMemberCollection object indicating static category headings for the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
CategoryGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

Glossary Item Box

Represents a strongly typed collection of CategoryGrouping objects.

Object Model

CategoryGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CategoryGroupingCollection
   Inherits System.Collections.ObjectModel.Collection(Of CategoryGrouping)
C#
public sealed class CategoryGroupingCollection : System.Collections.ObjectModel.Collection<CategoryGrouping>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.CategoryGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
CategoryGroupingCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by CategoryGroupingCollection.

Public Constructors

 | Name | Description
Public Constructor | CategoryGroupingCollection Constructor | Initializes a new instance of the CategoryGroupingCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a CategoryGroupingCollection to the existing CategoryGroupingCollection.
Top

See Also

Reference

CategoryGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGroupingCollection Constructor

[image]
ActiveReports 19 .NET Edition
CategoryGroupingCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : CategoryGroupingCollection Constructor

Glossary Item Box

Initializes a new instance of the CategoryGroupingCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CategoryGroupingCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


CategoryGroupingCollection Class Methods

[image]
ActiveReports 19 .NET Edition
CategoryGroupingCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

Glossary Item Box

For a list of all members of this type, see CategoryGroupingCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a CategoryGroupingCollection to the existing CategoryGroupingCollection.
Top

See Also

Reference

CategoryGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : AddRange Method

collection
The CategoryGroupingCollection to add to the current collection.

Glossary Item Box

Adds a CategoryGroupingCollection to the existing CategoryGroupingCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of CategoryGrouping) _
)
C#
public void AddRange(
   IEnumerable<CategoryGrouping> collection
)

Parameters

collection
The CategoryGroupingCollection to add to the current collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Chart Class

[image]
ActiveReports 19 .NET Edition
Chart Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

Glossary Item Box

The Chart element defines a chart data region. The Chart is defined much like a Matrix, but instead of Columns, Rows, and Cells, the Chart has Categories, Series, and DataPoints.

Object Model

Chart Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Chart
   Inherits DataRegion
   Implements IReportComponent, IScopeDefinition, IValidateable
C#
public sealed class Chart : DataRegion, IReportComponent, IScopeDefinition, IValidateable

Remarks

A Chart must have either a defined SeriesGroupings or a defined CategoryGroupings property, or both.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Chart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Members
GrapeCity.ActiveReports.PageReportModel Namespace


Chart Class Members

[image]
ActiveReports 19 .NET Edition
Chart Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

Glossary Item Box

The following tables list the members exposed by Chart.

Public Constructors

 | Name | Description
Public Constructor | Chart Constructor | Initializes a new instance of the Chart class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Public Property | CategoryAxis | Gets or sets the category axis.
Public Property | CategoryGroupings | Gets the set of category groupings for the chart.
Public Property | ChartCustomPaletteColors | Represents ChartCustomPaletteColors element (DD RDL extension).
Public Property | ChartData | Gets the data values for the chart.
Public Property | ChartElementOutput | Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.
Public Property | ChartPalette | Gets or sets the color palette for the chart items.
Public Property | ChartValueAxes | Gets collection of value axes for chart.
Public Property | ChildScopes | Overridden. Gets the child scopes.
Public Property | Legend | Gets or sets the chart legend.
Public Property | Palette | Gets or sets the color palette for the chart items.
Public Property | PlotArea | Gets or sets the properties for the plot area.
Public Property | PointWidth | Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.
Public Property | Properties | Gets the properties for extended chart types.
Public Property | ReferenceLine | Gets or sets the properties for reference line.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope.
Public Property | SeriesGroupings | Gets the set of series groupings for the chart.
Public Property | Subtype | Gets or sets the subtype of the chart.
Public Property | ThreeDProperties | Gets or sets the properties for a 3D chart layout.
Public Property | Title | Gets or sets the title for the chart.
Public Property | Type | Gets or sets the type of the chart.
Public Property | ValueAxis | Gets or sets the value axis.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions required for chart to be rendered.
Public Method | Validate | Overridden. Validates the information in each property of the Chart object.
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


Chart Constructor

[image]
ActiveReports 19 .NET Edition
Chart Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Chart Constructor

Glossary Item Box

Initializes a new instance of the Chart class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Chart()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Chart Class Methods

[image]
ActiveReports 19 .NET Edition
Chart Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

Glossary Item Box

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions required for chart to be rendered.
Public Method | Validate | Overridden. Validates the information in each property of the Chart object.
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : GetExpressions Method

Glossary Item Box

Gets the expressions required for chart to be rendered.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Chart object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

[image]
ActiveReports 19 .NET Edition
Chart Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

Glossary Item Box

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Public Property | CategoryAxis | Gets or sets the category axis.
Public Property | CategoryGroupings | Gets the set of category groupings for the chart.
Public Property | ChartCustomPaletteColors | Represents ChartCustomPaletteColors element (DD RDL extension).
Public Property | ChartData | Gets the data values for the chart.
Public Property | ChartElementOutput | Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.
Public Property | ChartPalette | Gets or sets the color palette for the chart items.
Public Property | ChartValueAxes | Gets collection of value axes for chart.
Public Property | ChildScopes | Overridden. Gets the child scopes.
Public Property | Legend | Gets or sets the chart legend.
Public Property | Palette | Gets or sets the color palette for the chart items.
Public Property | PlotArea | Gets or sets the properties for the plot area.
Public Property | PointWidth | Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.
Public Property | Properties | Gets the properties for extended chart types.
Public Property | ReferenceLine | Gets or sets the properties for reference line.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope.
Public Property | SeriesGroupings | Gets the set of series groupings for the chart.
Public Property | Subtype | Gets or sets the subtype of the chart.
Public Property | ThreeDProperties | Gets or sets the properties for a 3D chart layout.
Public Property | Title | Gets or sets the title for the chart.
Public Property | Type | Gets or sets the type of the chart.
Public Property | ValueAxis | Gets or sets the value axis.
Top

See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : AccessibleDescription Property

Glossary Item Box

Gets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


CategoryAxis Property

[image]
ActiveReports 19 .NET Edition
CategoryAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : CategoryAxis Property

Glossary Item Box

Gets or sets the category axis.

Syntax

Visual Basic (Declaration)
Public Property CategoryAxis As ValueCategoryAxis
C#
public ValueCategoryAxis CategoryAxis {get; set;}

Property Value

A ValueCategoryAxisrepresenting the chart's category axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


CategoryGroupings Property

[image]
ActiveReports 19 .NET Edition
CategoryGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : CategoryGroupings Property

Glossary Item Box

Gets the set of category groupings for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CategoryGroupings As CategoryGroupingCollection
C#
public CategoryGroupingCollection CategoryGroupings {get;}

Property Value

A CategoryGroupingCollection indicating the set of category groupings for the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartCustomPaletteColors Property

[image]
ActiveReports 19 .NET Edition
ChartCustomPaletteColors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartCustomPaletteColors Property

Glossary Item Box

Represents ChartCustomPaletteColors element (DD RDL extension).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartCustomPaletteColors As CustomPaletteColorsCollection
C#
public CustomPaletteColorsCollection ChartCustomPaletteColors {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartData Property

[image]
ActiveReports 19 .NET Edition
ChartData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartData Property

Glossary Item Box

Gets the data values for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartData As ChartSeriesCollection
C#
public ChartSeriesCollection ChartData {get;}

Property Value

A ChartSeriesCollection indicating the data values for the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartElementOutput Property

[image]
ActiveReports 19 .NET Edition
ChartElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property ChartElementOutput As DataElementOutput
C#
public DataElementOutput ChartElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether a DataPoint element containing the chart data points appears in a data rendering. Valid values are listed in the table below.
DataElementOutput | Description
Auto | The chart appears in an XML rendering of the report.
Output (Default) | The chart appears in an XML rendering of the report.
NoOutput | The chart does not appear in an XML rendering of the report.
ContentsOnly | This value does not apply to the chart data region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartPalette Property

[image]
ActiveReports 19 .NET Edition
ChartPalette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartPalette Property

Glossary Item Box

Gets or sets the color palette for the chart items.

Syntax

Visual Basic (Declaration)
Public Property ChartPalette As String
C#
public string ChartPalette {get; set;}

Property Value

A chart palette key indicating the color palette for the chart items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartValueAxes Property

[image]
ActiveReports 19 .NET Edition
ChartValueAxes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartValueAxes Property

Glossary Item Box

Gets collection of value axes for chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartValueAxes As List(Of ValueCategoryAxis)
C#
public List<ValueCategoryAxis> ChartValueAxes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChildScopes Property

Glossary Item Box

Gets the child scopes.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

The child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Legend Property

[image]
ActiveReports 19 .NET Edition
Legend Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Legend Property

Glossary Item Box

Gets or sets the chart legend.

Syntax

Visual Basic (Declaration)
Public Property Legend As Legend
C#
public Legend Legend {get; set;}

Property Value

A Legend object representing the chart's legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Palette Property

[image]
ActiveReports 19 .NET Edition
Palette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Palette Property

Glossary Item Box

Gets or sets the color palette for the chart items.

Syntax

Visual Basic (Declaration)
Public Property Palette As ChartPalette
C#
public ChartPalette Palette {get; set;}

Property Value

A ChartPalette enumeration indicating the color palette for the chart items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


PlotArea Property

[image]
ActiveReports 19 .NET Edition
PlotArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : PlotArea Property

Glossary Item Box

Gets or sets the properties for the plot area.

Syntax

Visual Basic (Declaration)
Public Property PlotArea As PlotArea
C#
public PlotArea PlotArea {get; set;}

Property Value

A PlotArea object representing the properties for a plot area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


PointWidth Property

[image]
ActiveReports 19 .NET Edition
PointWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : PointWidth Property

Glossary Item Box

Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.

Syntax

Visual Basic (Declaration)
Public Property PointWidth As Nullable(Of Integer)
C#
public Nullable<int> PointWidth {get; set;}

Property Value

A int? representing the percent width for bars and columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Properties Property

Glossary Item Box

Gets the properties for extended chart types.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As PropertyCollection
C#
public PropertyCollection Properties {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ReferenceLine Property

[image]
ActiveReports 19 .NET Edition
ReferenceLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ReferenceLine Property

Glossary Item Box

Gets or sets the properties for reference line.

Syntax

Visual Basic (Declaration)
Public Property ReferenceLine As ReferenceLine
C#
public ReferenceLine ReferenceLine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

The report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


SeriesGroupings Property

[image]
ActiveReports 19 .NET Edition
SeriesGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : SeriesGroupings Property

Glossary Item Box

Gets the set of series groupings for the chart.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeriesGroupings As SeriesGroupingCollection
C#
public SeriesGroupingCollection SeriesGroupings {get;}

Property Value

A SeriesGroupingCollection indicating the set of series groupings for the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Subtype Property

[image]
ActiveReports 19 .NET Edition
Subtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Subtype Property

Glossary Item Box

Gets or sets the subtype of the chart.

Syntax

Visual Basic (Declaration)
Public Property Subtype As ChartSubtype
C#
public ChartSubtype Subtype {get; set;}

Property Value

A ChartSubtype enumeration indicating the subtype of the chart.

Remarks

Available subtypes, and their default values, depend on the chart's Type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ThreeDProperties Property

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ThreeDProperties Property

Glossary Item Box

Gets or sets the properties for a 3D chart layout.

Syntax

Visual Basic (Declaration)
Public Property ThreeDProperties As ThreeDProperties
C#
public ThreeDProperties ThreeDProperties {get; set;}

Property Value

A ThreeDProperties object representing the properties for a 3D layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Title Property

Glossary Item Box

Gets or sets the title for the chart.

Syntax

Visual Basic (Declaration)
Public Property Title As Title
C#
public Title Title {get; set;}

Property Value

A Title object representing the chart's title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Type Property

Glossary Item Box

Gets or sets the type of the chart.

Syntax

Visual Basic (Declaration)
Public Property Type As ChartType
C#
public ChartType Type {get; set;}

Property Value

A ChartType enumeration indicating the type of chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ValueAxis Property

[image]
ActiveReports 19 .NET Edition
ValueAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ValueAxis Property

Glossary Item Box

Gets or sets the value axis.

Syntax

Visual Basic (Declaration)
Public Property ValueAxis As ValueCategoryAxis
C#
public ValueCategoryAxis ValueAxis {get; set;}

Property Value

A ValueCategoryAxis representing the chart's value axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


ChartAxisTitle Class

[image]
ActiveReports 19 .NET Edition
ChartAxisTitle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartAxisTitle Class

Glossary Item Box

The ChartAxisTitle element defines a title for an axis.

Object Model

ChartAxisTitle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartAxisTitle
   Inherits Title
   Implements IValidateable
C#
public sealed class ChartAxisTitle : Title, IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Title
GrapeCity.ActiveReports.PageReportModel.ChartAxisTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


ChartAxisTitle Class Members

[image]
ActiveReports 19 .NET Edition
ChartAxisTitle Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartAxisTitle Class

Glossary Item Box

The following tables list the members exposed by ChartAxisTitle.

Public Constructors

 | Name | Description
Public Constructor | ChartAxisTitle Constructor | Initializes a new instance of the ChartAxisTitle class.
Top

Public Properties

 | Name | Description
Public Property | TextOrientation | Indicates the orientation of the text.
Top

See Also

Reference

ChartAxisTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChartAxisTitle Constructor

[image]
ActiveReports 19 .NET Edition
ChartAxisTitle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartAxisTitle Class : ChartAxisTitle Constructor

Glossary Item Box

Initializes a new instance of the ChartAxisTitle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartAxisTitle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisTitle Class
ChartAxisTitle Members


ChartAxisTitle Class Properties

[image]
ActiveReports 19 .NET Edition
ChartAxisTitle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartAxisTitle Class

Glossary Item Box

For a list of all members of this type, see ChartAxisTitle members.

Public Properties

 | Name | Description
Public Property | TextOrientation | Indicates the orientation of the text.
Top

See Also

Reference

ChartAxisTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextOrientation Property

[image]
ActiveReports 19 .NET Edition
TextOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartAxisTitle Class : TextOrientation Property

Glossary Item Box

Indicates the orientation of the text.

Syntax

Visual Basic (Declaration)
Public Property TextOrientation As AxisTextOrientation
C#
public AxisTextOrientation TextOrientation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisTitle Class
ChartAxisTitle Members


ChartSeries Class

[image]
ActiveReports 19 .NET Edition
ChartSeries Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

Glossary Item Box

The ChartSeries element defines the set of data points for one series.

Object Model

ChartSeries Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartSeries
   Implements IValidateable
C#
public sealed class ChartSeries : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ChartSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Members
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeries Class Members

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

Glossary Item Box

The following tables list the members exposed by ChartSeries.

Public Constructors

 | Name | Description
Public Constructor | ChartSeries Constructor | Initializes a new instance of the ChartSeries class.
Top

Public Properties

 | Name | Description
Public Property | DataPoints | Gets the data points within the series.
Public Property | DefaultSubtype | Gets default subtype for series.
Public Property | DefaultType | Gets default type for series.
Public Property | PlotType | Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.
Public Property | Subtype | Gets or sets subtype.
Public Property | Type | Gets or sets type.
Public Property | ValueAxisName | Gets or sets name of corresponding value axis.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ChartSeries object.
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeries Constructor

[image]
ActiveReports 19 .NET Edition
ChartSeries Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : ChartSeries Constructor

Glossary Item Box

Initializes a new instance of the ChartSeries class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartSeries()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Methods

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

Glossary Item Box

For a list of all members of this type, see ChartSeries members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ChartSeries object.
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the ChartSeries object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Properties

[image]
ActiveReports 19 .NET Edition
ChartSeries Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

Glossary Item Box

For a list of all members of this type, see ChartSeries members.

Public Properties

 | Name | Description
Public Property | DataPoints | Gets the data points within the series.
Public Property | DefaultSubtype | Gets default subtype for series.
Public Property | DefaultType | Gets default type for series.
Public Property | PlotType | Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.
Public Property | Subtype | Gets or sets subtype.
Public Property | Type | Gets or sets type.
Public Property | ValueAxisName | Gets or sets name of corresponding value axis.
Top

See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoints Property

[image]
ActiveReports 19 .NET Edition
DataPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : DataPoints Property

Glossary Item Box

Gets the data points within the series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataPoints As DataPointCollection
C#
public DataPointCollection DataPoints {get;}

Property Value

A DataPointCollection object containing all of the data points in the series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


DefaultSubtype Property

[image]
ActiveReports 19 .NET Edition
DefaultSubtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : DefaultSubtype Property

Glossary Item Box

Gets default subtype for series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultSubtype As ChartSubtype
C#
public ChartSubtype DefaultSubtype {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


DefaultType Property

[image]
ActiveReports 19 .NET Edition
DefaultType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : DefaultType Property

Glossary Item Box

Gets default type for series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultType As ChartType
C#
public ChartType DefaultType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


PlotType Property

[image]
ActiveReports 19 .NET Edition
PlotType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : PlotType Property

Glossary Item Box

Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.

Syntax

Visual Basic (Declaration)
Public Property PlotType As ChartSeriesPlotType
C#
public ChartSeriesPlotType PlotType {get; set;}

Property Value

A ChartSeriesPlotType enumeration indicating whether the series is plotted as a line in a Column chart. The default value is Auto.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


Subtype Property

[image]
ActiveReports 19 .NET Edition
Subtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : Subtype Property

Glossary Item Box

Gets or sets subtype.

Syntax

Visual Basic (Declaration)
Public Property Subtype As ChartSubtype
C#
public ChartSubtype Subtype {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : Type Property

Glossary Item Box

Gets or sets type.

Syntax

Visual Basic (Declaration)
Public Property Type As ChartType
C#
public ChartType Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ValueAxisName Property

[image]
ActiveReports 19 .NET Edition
ValueAxisName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : ValueAxisName Property

Glossary Item Box

Gets or sets name of corresponding value axis.

Syntax

Visual Basic (Declaration)
Public Property ValueAxisName As String
C#
public string ValueAxisName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeriesCollection Class

[image]
ActiveReports 19 .NET Edition
ChartSeriesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

Glossary Item Box

Provides a strongly typed collection for ChartSeries objects.

Object Model

ChartSeriesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartSeriesCollection
   Inherits System.Collections.ObjectModel.Collection(Of ChartSeries)
C#
public sealed class ChartSeriesCollection : System.Collections.ObjectModel.Collection<ChartSeries>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ChartSeriesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesCollection Class Members

[image]
ActiveReports 19 .NET Edition
ChartSeriesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesCollection Constructor | Initializes a new instance of the ChartSeriesCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a ChartSeriesCollection to the existing ChartSeriesCollection.
Top

See Also

Reference

ChartSeriesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesCollection Constructor

[image]
ActiveReports 19 .NET Edition
ChartSeriesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : ChartSeriesCollection Constructor

Glossary Item Box

Initializes a new instance of the ChartSeriesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartSeriesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ChartSeriesCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ChartSeriesCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a ChartSeriesCollection to the existing ChartSeriesCollection.
Top

See Also

Reference

ChartSeriesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : AddRange Method

collection
The ChartSeriesCollection to add to the current collection.

Glossary Item Box

Adds a ChartSeriesCollection to the existing ChartSeriesCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ChartSeries) _
)
C#
public void AddRange(
   IEnumerable<ChartSeries> collection
)

Parameters

collection
The ChartSeriesCollection to add to the current collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


CheckBox Class

[image]
ActiveReports 19 .NET Edition
CheckBox Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

Glossary Item Box

Represents a check box ReportItem within the report definition, displaying text and indicating a boolean state (checked or unchecked).

Object Model

CheckBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckBox
   Inherits TextItem
   Implements IReportComponent, IValidateable
C#
public sealed class CheckBox : TextItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.CheckBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Members
GrapeCity.ActiveReports.PageReportModel Namespace


CheckBox Class Members

[image]
ActiveReports 19 .NET Edition
CheckBox Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

Glossary Item Box

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor | Initializes a new instance of the CheckBox class.
Top

Public Properties

 | Name | Description
Public Property | CheckAlignment | Gets or sets an alignment of the check box within the control.
Public Property | Checked | Gets or sets the expression that determines if the check box is checked.
Public Property | Text | Gets or sets the text associated with the check box.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the CheckBox object.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


CheckBox Constructor

[image]
ActiveReports 19 .NET Edition
CheckBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : CheckBox Constructor

Glossary Item Box

Initializes a new instance of the CheckBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CheckBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Methods

[image]
ActiveReports 19 .NET Edition
CheckBox Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

Glossary Item Box

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the CheckBox object.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the CheckBox object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

[image]
ActiveReports 19 .NET Edition
CheckBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

Glossary Item Box

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | CheckAlignment | Gets or sets an alignment of the check box within the control.
Public Property | Checked | Gets or sets the expression that determines if the check box is checked.
Public Property | Text | Gets or sets the text associated with the check box.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


CheckAlignment Property

[image]
ActiveReports 19 .NET Edition
CheckAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : CheckAlignment Property

Glossary Item Box

Gets or sets an alignment of the check box within the control.

Syntax

Visual Basic (Declaration)
Public Property CheckAlignment As CheckAlignment
C#
public CheckAlignment CheckAlignment {get; set;}

Property Value

A CheckAlignment value indicating the alignment of the check box.

Example

C# Copy Code
CheckBox checkBox = new CheckBox();
checkBox.CheckAlignment = CheckAlignment.BottomCenter;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Checked Property

Glossary Item Box

Gets or sets the expression that determines if the check box is checked.

Syntax

Visual Basic (Declaration)
Public Property Checked As ExpressionInfo
C#
public ExpressionInfo Checked {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a System.Boolean value indicating the check box state.

Example

C# Copy Code
CheckBox checkBox = new CheckBox();
checkBox.Checked = ExpressionInfo.FromString("true");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Text Property

Glossary Item Box

Gets or sets the text associated with the check box.

Syntax

Visual Basic (Declaration)
Public Property Text As ExpressionInfo
C#
public ExpressionInfo Text {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the text displayed next to the check box.

Example

C# Copy Code
CheckBox checkBox = new CheckBox();
checkBox.Text = "Agree to Terms and Conditions";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CodeClass Class

[image]
ActiveReports 19 .NET Edition
CodeClass Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

Glossary Item Box

Represents фт information about a class instantiated during the report's initialization. The instantiated class can be used in expressions.

Object Model

CodeClass Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CodeClass
   Implements IValidateable
C#
public sealed class CodeClass : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CodeClass

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClass Members
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClass Class Members

[image]
ActiveReports 19 .NET Edition
CodeClass Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

Glossary Item Box

The following tables list the members exposed by CodeClass.

Public Constructors

 | Name | Description
Public Constructor | CodeClass Constructor | Initializes a new instance of the CodeClass class.
Top

Public Properties

 | Name | Description
Public Property | ClassName | Gets or sets a name used for the class.
Public Property | InstanceName | Gets or sets a variable name to which the class instance is assigned. The InstanceName can be used in expressions.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the CodeClass object.
Top

See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClass Constructor

[image]
ActiveReports 19 .NET Edition
CodeClass Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : CodeClass Constructor

Glossary Item Box

Initializes a new instance of the CodeClass class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CodeClass()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClass Class
CodeClass Members


CodeClass Class Methods

[image]
ActiveReports 19 .NET Edition
CodeClass Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

Glossary Item Box

For a list of all members of this type, see CodeClass members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the CodeClass object.
Top

See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the CodeClass object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClass Class
CodeClass Members


CodeClass Class Properties

[image]
ActiveReports 19 .NET Edition
CodeClass Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

Glossary Item Box

For a list of all members of this type, see CodeClass members.

Public Properties

 | Name | Description
Public Property | ClassName | Gets or sets a name used for the class.
Public Property | InstanceName | Gets or sets a variable name to which the class instance is assigned. The InstanceName can be used in expressions.
Top

See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


ClassName Property

[image]
ActiveReports 19 .NET Edition
ClassName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : ClassName Property

Glossary Item Box

Gets or sets a name used for the class.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

A System.String value indicating the name of the class.

Example

C# Copy Code
CodeClass codeClass = new CodeClass();
codeClass.ClassName = "MyClassName";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClass Class
CodeClass Members


InstanceName Property

[image]
ActiveReports 19 .NET Edition
InstanceName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : InstanceName Property

Glossary Item Box

Gets or sets a variable name to which the class instance is assigned. The InstanceName can be used in expressions.

Syntax

Visual Basic (Declaration)
Public Property InstanceName As String
C#
public string InstanceName {get; set;}

Property Value

A System.String value indicating the variable name assigned to the class instance.

Example

C# Copy Code
CodeClass codeClass = new CodeClass();
codeClass.InstanceName = "myInstance";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClass Class
CodeClass Members


CodeClassCollection Class

[image]
ActiveReports 19 .NET Edition
CodeClassCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class

Glossary Item Box

Represents a strongly typed collection of CodeClass objects.

Object Model

CodeClassCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CodeClassCollection
   Inherits System.Collections.ObjectModel.Collection(Of CodeClass)
C#
public sealed class CodeClassCollection : System.Collections.ObjectModel.Collection<CodeClass>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.CodeClassCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CodeClassCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClassCollection Class Members

[image]
ActiveReports 19 .NET Edition
CodeClassCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class

Glossary Item Box

The following tables list the members exposed by CodeClassCollection.

See Also

Reference

CodeClassCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGrouping Class

[image]
ActiveReports 19 .NET Edition
ColumnGrouping Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

Glossary Item Box

Represents a ColumnGrouping element defines a column header region for a matrix.

Object Model

ColumnGrouping Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnGrouping
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class ColumnGrouping : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ColumnGrouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGrouping Class Members

[image]
ActiveReports 19 .NET Edition
ColumnGrouping Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

Glossary Item Box

The following tables list the members exposed by ColumnGrouping.

Public Constructors

 | Name | Description
Public Constructor | ColumnGrouping Constructor | Initializes a new instance of the ColumnGrouping class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DynamicColumns | Gets or sets the dynamic column headings for this grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Height | Gets or sets a height of the column header.
Public Property | StaticColumns | Gets the static column headings for this grouping.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ColumnGrouping object.
Top

See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGrouping Constructor

[image]
ActiveReports 19 .NET Edition
ColumnGrouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : ColumnGrouping Constructor

Glossary Item Box

Initializes a new instance of the ColumnGrouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ColumnGrouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGrouping Class Methods

[image]
ActiveReports 19 .NET Edition
ColumnGrouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

Glossary Item Box

For a list of all members of this type, see ColumnGrouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ColumnGrouping object.
Top

See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ColumnGrouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGrouping Class Properties

[image]
ActiveReports 19 .NET Edition
ColumnGrouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

Glossary Item Box

For a list of all members of this type, see ColumnGrouping members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DynamicColumns | Gets or sets the dynamic column headings for this grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Height | Gets or sets a height of the column header.
Public Property | StaticColumns | Gets the static column headings for this grouping.
Top

See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


DynamicColumns Property

[image]
ActiveReports 19 .NET Edition
DynamicColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : DynamicColumns Property

Glossary Item Box

Gets or sets the dynamic column headings for this grouping.

Syntax

Visual Basic (Declaration)
Public Property DynamicColumns As DynamicColumnsRows
C#
public DynamicColumnsRows DynamicColumns {get; set;}

Property Value

A DynamicColumnsRows object containing the dynamic column headings for this grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


FixedHeader Property

[image]
ActiveReports 19 .NET Edition
FixedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : FixedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedHeader As Boolean
C#
public bool FixedHeader {get; set;}

Property Value

A System.Boolean value where true indicates the grouping should be displayed on the page even when the user scrolls part of the matrix off the page; otherwise false. Default value is false.

Remarks

Fixed headers must be touching each other and must also include the outermost grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Height Property

Glossary Item Box

Gets or sets a height of the column header.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the column header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


StaticColumns Property

[image]
ActiveReports 19 .NET Edition
StaticColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : StaticColumns Property

Glossary Item Box

Gets the static column headings for this grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticColumns As StaticRowColumnCollection
C#
public StaticRowColumnCollection StaticColumns {get;}

Property Value

A StaticRowColumnCollection object containing the static column headings for this grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
ColumnGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class

Glossary Item Box

Represents a strongly typed collection of ColumnGrouping objects.

Object Model

ColumnGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnGroupingCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of ColumnGrouping)
C#
public sealed class ColumnGroupingCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<ColumnGrouping>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.ColumnGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
ColumnGroupingCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by ColumnGroupingCollection.

See Also

Reference

ColumnGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Class

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

Glossary Item Box

Represents the connection properties used to connect to a data source.

Object Model

ConnectionProperties Class

Syntax

Visual Basic (Declaration)
Public Class ConnectionProperties
   Implements IValidateable
C#
public class ConnectionProperties : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ConnectionProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Members
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Class Members

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

Glossary Item Box

The following tables list the members exposed by ConnectionProperties.

Public Constructors

 | Name | Description
Public Constructor | ConnectionProperties Constructor | Initializes a new instance of the ConnectionProperties class.
Top

Public Properties

 | Name | Description
Public Property | ConnectString | Gets or sets a connection string used to connect to the data source.
Public Property | ConnectStringType | Gets or sets the type of the connection string.
Public Property | DataProvider | Gets or sets the type of the data source.
Public Property | IntegratedSecurity | Gets or sets a value indicating whether the data source uses integrated security for connection.
Public Property | Prompt | Gets or sets a prompt displayed to the user when credentials are required for connecting to the database with the specified data source.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ConnectionProperties object.
Top

See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Constructor

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : ConnectionProperties Constructor

Glossary Item Box

Initializes a new instance of the ConnectionProperties class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ConnectionProperties()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


ConnectionProperties Class Methods

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

Glossary Item Box

For a list of all members of this type, see ConnectionProperties members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ConnectionProperties object.
Top

See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ConnectionProperties object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


ConnectionProperties Class Properties

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

Glossary Item Box

For a list of all members of this type, see ConnectionProperties members.

Public Properties

 | Name | Description
Public Property | ConnectString | Gets or sets a connection string used to connect to the data source.
Public Property | ConnectStringType | Gets or sets the type of the connection string.
Public Property | DataProvider | Gets or sets the type of the data source.
Public Property | IntegratedSecurity | Gets or sets a value indicating whether the data source uses integrated security for connection.
Public Property | Prompt | Gets or sets a prompt displayed to the user when credentials are required for connecting to the database with the specified data source.
Top

See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectString Property

[image]
ActiveReports 19 .NET Edition
ConnectString Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : ConnectString Property

Glossary Item Box

Gets or sets a connection string used to connect to the data source.

Syntax

Visual Basic (Declaration)
Public Property ConnectString As ExpressionInfo
C#
public ExpressionInfo ConnectString {get; set;}

Property Value

A System.String value indicating the connection string for the data source.

Example

C# Copy Code
var connectionProperties = new ConnectionProperties();
connectionProperties.ConnectString = ExpressionInfo.FromString("Server=myServer;Database=myDatabase;Integrated Security=True;");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


ConnectStringType Property

[image]
ActiveReports 19 .NET Edition
ConnectStringType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : ConnectStringType Property

Glossary Item Box

Gets or sets the type of the connection string.

Syntax

Visual Basic (Declaration)
Public Property ConnectStringType As ConnectStringType
C#
public ConnectStringType ConnectStringType {get; set;}

Property Value

The ConnectStringType value indicating the type of the connection string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


DataProvider Property

[image]
ActiveReports 19 .NET Edition
DataProvider Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : DataProvider Property

Glossary Item Box

Gets or sets the type of the data source.

Syntax

Visual Basic (Declaration)
Public Property DataProvider As String
C#
public string DataProvider {get; set;}

Property Value

A System.String value indicating the type of the data source.

Remarks

The DataProvider value determines the syntax used for the ConnectString and CommandText properties.

The table below contains the set of data source extensions available by default. Custom extensions can be created but RDL consumers take caution when loading reports containing unknown or unsupported extensions.

Extension | Description
SQL | Microsoft SQL Server
OLEDB | Microsoft OLE DB Provider
ODBC | Microsoft Open Database Connectivity Driver

Example

C# Copy Code
var connectionProperties = new ConnectionProperties();
connectionProperties.DataProvider = "SQL";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


IntegratedSecurity Property

[image]
ActiveReports 19 .NET Edition
IntegratedSecurity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : IntegratedSecurity Property

Glossary Item Box

Gets or sets a value indicating whether the data source uses integrated security for connection.

Syntax

Visual Basic (Declaration)
Public Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity {get; set;}

Property Value

A System.Boolean vaalue. true if the data source uses integrated security; otherwise, false. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : Prompt Property

Glossary Item Box

Gets or sets a prompt displayed to the user when credentials are required for connecting to the database with the specified data source.

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt {get; set;}

Property Value

A System.String value indicating the prompt shown to the user.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


Container Class

[image]
ActiveReports 19 .NET Edition
Container Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

Glossary Item Box

Represents a rectangle ReportItem contained in the report definition.

Object Model

Container Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Container
   Inherits ShapeBase
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Container : ShapeBase, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.ShapeBase
GrapeCity.ActiveReports.PageReportModel.Container

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Members
GrapeCity.ActiveReports.PageReportModel Namespace


Container Class Members

[image]
ActiveReports 19 .NET Edition
Container Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

Glossary Item Box

The following tables list the members exposed by Container.

Public Constructors

 | Name | Description
Public Constructor | Container Constructor | Initializes a new instance of the Container class.
Top

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the container can grow when the size of its content is greater than the size of the container.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeWhiteSpace | Gets or sets a value indicating that all white space in the container is consumed during report rendering when the container’s contents grow, rather than preserving the minimum white space between the contents and the bounds of the container.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | Overflow | Gets or sets a value indicating how content that is larger than the container should be handled.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the container ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the container begins.
Public Property | PageName | Gets or sets the string used for naming the sheet in Excel export.
Public Property | ReportItems | Gets a collection of the ReportItem objects hosted in the Container.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Public Method | Validate | Overridden. Validates the current state of the Container object.
Top

See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Constructor

[image]
ActiveReports 19 .NET Edition
Container Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Container Constructor

Glossary Item Box

Initializes a new instance of the Container class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Container()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Container Class Methods

[image]
ActiveReports 19 .NET Edition
Container Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

Glossary Item Box

For a list of all members of this type, see Container members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Public Method | Validate | Overridden. Validates the current state of the Container object.
Top

See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


SortReportItems Method

[image]
ActiveReports 19 .NET Edition
SortReportItems Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : SortReportItems Method

Glossary Item Box

Sorts the report items to improve rendering performance.

Syntax

Visual Basic (Declaration)
Public Sub SortReportItems()
C#
public void SortReportItems()

Example

C# Copy Code
Container container = new Container();
container.SortReportItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Container object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Container Class Properties

[image]
ActiveReports 19 .NET Edition
Container Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

Glossary Item Box

For a list of all members of this type, see Container members.

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the container can grow when the size of its content is greater than the size of the container.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeWhiteSpace | Gets or sets a value indicating that all white space in the container is consumed during report rendering when the container’s contents grow, rather than preserving the minimum white space between the contents and the bounds of the container.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | Overflow | Gets or sets a value indicating how content that is larger than the container should be handled.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the container ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the container begins.
Public Property | PageName | Gets or sets the string used for naming the sheet in Excel export.
Public Property | ReportItems | Gets a collection of the ReportItem objects hosted in the Container.
Top

See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : CanGrow Property

Glossary Item Box

Gets or sets a value indicating whether the container can grow when the size of its content is greater than the size of the container.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A System.Boolean value where true indicates that the container can grow; otherwise, false.

Remarks

This property is obsolete. Use Overflow.Grow instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Example

C# Copy Code
Container container = new Container();
ReportComponentCollection components = container.Components;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : ConsumeWhiteSpace Property

Glossary Item Box

Gets or sets a value indicating that all white space in the container is consumed during report rendering when the container’s contents grow, rather than preserving the minimum white space between the contents and the bounds of the container.

Syntax

Visual Basic (Declaration)
Public Property ConsumeWhiteSpace As Boolean
C#
public bool ConsumeWhiteSpace {get; set;}

Property Value

A System.Boolean value where true indicates that all white space in the container is consumed; otherwise, false.

Example

C# Copy Code
Container container = new Container();
container.ConsumeWhiteSpace = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : NewPage Property

Glossary Item Box

Gets or sets a value indicating on which page the content should start after the page break.

Syntax

Visual Basic (Declaration)
Public Property NewPage As StartNewPage
C#
public StartNewPage NewPage {get; set;}

Property Value

A StartNewPage value indicating the page on which to start the content after the page break.

Example

C# Copy Code
Container container = new Container();
container.NewPage = StartNewPage.After;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Overflow Property

[image]
ActiveReports 19 .NET Edition
Overflow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Overflow Property

Glossary Item Box

Gets or sets a value indicating how content that is larger than the container should be handled.

Syntax

Visual Basic (Declaration)
Public Property Overflow As Overflow
C#
public Overflow Overflow {get; set;}

Property Value

An Overflow value indicating how to handle content larger than the container. The default value is Overflow.Auto.

Example

C# Copy Code
Container container = new Container();
container.Overflow = Overflow.Grow;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately after the container ends.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true indicates that a page break occurs immediately after the container ends; otherwise, false. The default value is false.

Remarks

Page breaks are ignored if the container contains no report items.

Example

C# Copy Code
Container container = new Container();
container.PageBreakAtEnd = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately before the container begins.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true indicates that a page break occurs immediately before the container begins; otherwise, false. The default value is false.

Remarks

Page breaks are ignored if the container contains no report items.

Example

C# Copy Code
Container container = new Container();
container.PageBreakAtStart = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : PageName Property

Glossary Item Box

Gets or sets the string used for naming the sheet in Excel export.

Syntax

Visual Basic (Declaration)
Public Property PageName As ExpressionInfo
C#
public ExpressionInfo PageName {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the name of the sheet in Excel export.

Example

C# Copy Code
Container container = new Container();
container.PageName = "Sheet1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : ReportItems Property

Glossary Item Box

Gets a collection of the ReportItem objects hosted in the Container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection щиоусе containing the report items hosted in the container.

Example

C# Copy Code
Container container = new Container();
ReportItemCollection items = container.ReportItems;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Container Class
Container Members


Corner Class

[image]
ActiveReports 19 .NET Edition
Corner Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

Glossary Item Box

Represents a Corner element defines the layout and structure of the upper left-hand corner region of a matrix.

Object Model

Corner Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Corner
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Corner : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Corner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Corner Members
GrapeCity.ActiveReports.PageReportModel Namespace


Corner Class Members

[image]
ActiveReports 19 .NET Edition
Corner Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

Glossary Item Box

The following tables list the members exposed by Corner.

Public Constructors

 | Name | Description
Public Constructor | Corner Constructor | Initializes a new instance of the Corner class.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Corner object.
Top

See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Corner Constructor

[image]
ActiveReports 19 .NET Edition
Corner Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Corner Constructor

Glossary Item Box

Initializes a new instance of the Corner class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Corner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Corner Class
Corner Members


Corner Class Methods

[image]
ActiveReports 19 .NET Edition
Corner Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

Glossary Item Box

For a list of all members of this type, see Corner members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Corner object.
Top

See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Corner object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Corner Class
Corner Members


CoverFlow Class

[image]
ActiveReports 19 .NET Edition
CoverFlow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CoverFlow Class

Glossary Item Box

Represents a band navigation style in which a flow of images is integrated into the navigation of the tablix band.

Object Model

CoverFlow Class

Syntax

Visual Basic (Declaration)
Public Class CoverFlow
C#
public class CoverFlow

Remarks

The CoverFlow class provides settings for cover flow navigation, including the navigation item and slider settings.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CoverFlow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CoverFlow Members
GrapeCity.ActiveReports.PageReportModel Namespace


CoverFlow Class Members

[image]
ActiveReports 19 .NET Edition
CoverFlow Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CoverFlow Class

Glossary Item Box

The following tables list the members exposed by CoverFlow.

Public Constructors

 | Name | Description
Public Constructor | CoverFlow Constructor |
Top

Public Properties

 | Name | Description
Public Property | NavigationItem | Gets or sets a navigation item to use to draw the cover flow navigation layout.
Public Property | Slider | Gets or sets a slider settings for the cover flow navigation layout.
Top

See Also

Reference

CoverFlow Class
GrapeCity.ActiveReports.PageReportModel Namespace


CoverFlow Constructor

[image]
ActiveReports 19 .NET Edition
CoverFlow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CoverFlow Class : CoverFlow Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CoverFlow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CoverFlow Class
CoverFlow Members


CoverFlow Class Properties

[image]
ActiveReports 19 .NET Edition
CoverFlow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CoverFlow Class

Glossary Item Box

For a list of all members of this type, see CoverFlow members.

Public Properties

 | Name | Description
Public Property | NavigationItem | Gets or sets a navigation item to use to draw the cover flow navigation layout.
Public Property | Slider | Gets or sets a slider settings for the cover flow navigation layout.
Top

See Also

Reference

CoverFlow Class
GrapeCity.ActiveReports.PageReportModel Namespace


NavigationItem Property

[image]
ActiveReports 19 .NET Edition
NavigationItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CoverFlow Class : NavigationItem Property

Glossary Item Box

Gets or sets a navigation item to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Public Property NavigationItem As NavigationItem
C#
public NavigationItem NavigationItem {get; set;}

Property Value

A NavigationItem object representing the navigation item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CoverFlow Class
CoverFlow Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CoverFlow Class : Slider Property

Glossary Item Box

Gets or sets a slider settings for the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Public Property Slider As Slider
C#
public Slider Slider {get; set;}

Property Value

A Slider object representing the slider settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CoverFlow Class
CoverFlow Members


Custom Class

[image]
ActiveReports 19 .NET Edition
Custom Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class

Glossary Item Box

Represents a Custom element that allows report design tools to pass information to report output components. This element can contain any valid XML. The engine passes the contents of the Custom object unchanged. Client applications using the Custom element place custom properties under their own single subelement of Custom, defining a namespace for that node.

Object Model

Custom Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Custom
C#
public sealed class Custom

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Custom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Custom Members
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Class Members

[image]
ActiveReports 19 .NET Edition
Custom Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class

Glossary Item Box

The following tables list the members exposed by Custom.

Public Constructors

 | Name | Description
Public Constructor | Custom Constructor | Initializes a new instance of the Custom class.
Top

Public Properties

 | Name | Description
Public Property | InnerXML | Gets or sets a custom inner XML.
Top

See Also

Reference

Custom Class
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Constructor

[image]
ActiveReports 19 .NET Edition
Custom Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Custom Class : Custom Constructor

Glossary Item Box

Initializes a new instance of the Custom class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Custom()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Custom Class
Custom Members


Custom Class Properties

[image]
ActiveReports 19 .NET Edition
Custom Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class

Glossary Item Box

For a list of all members of this type, see Custom members.

Public Properties

 | Name | Description
Public Property | InnerXML | Gets or sets a custom inner XML.
Top

See Also

Reference

Custom Class
GrapeCity.ActiveReports.PageReportModel Namespace


InnerXML Property

[image]
ActiveReports 19 .NET Edition
InnerXML Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Custom Class : InnerXML Property

Glossary Item Box

Gets or sets a custom inner XML.

Syntax

Visual Basic (Declaration)
Public Property InnerXML As String
C#
public string InnerXML {get; set;}

Property Value

A System.String value indicating the custom XML content.

Example

C# Copy Code
Custom customElement = new Custom();
customElement.InnerXML = "<CustomProperty>Value</CustomProperty>";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Custom Class
Custom Members


CustomData Class

[image]
ActiveReports 19 .NET Edition
CustomData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

Glossary Item Box

Represents data intended for use by a CustomReportItem.

Object Model

CustomData Class

Syntax

Visual Basic (Declaration)
Public Class CustomData
   Implements IValidateable
C#
public class CustomData : IValidateable

Remarks

This class corresponds to the RDL (Report Definition Language) CustomData element. If a CustomReportItem defines a CustomData element, it is treated as a data region. This imposes similar restrictions as other data regions, such as disallowing placement in detail rows or page header/footer sections.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomData Class Members

[image]
ActiveReports 19 .NET Edition
CustomData Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

Glossary Item Box

The following tables list the members exposed by CustomData.

Public Constructors

 | Name | Description
Public Constructor | CustomData Constructor | Initializes a new instance of the CustomData class.
Top

Public Properties

 | Name | Description
Public Property | DataColumnGroupings | Gets the column groupings defined for the custom report item's data.
Public Property | DataRowGroupings | Gets the row groupings defined for the custom report item's data.
Public Property | DataRows | Gets the data values calculated for each detail cell of the custom report item's data.
Public Property | DataSetName | Gets or sets s name of the data set used as the data source for the CustomReportItem.
Public Property | DataSetParameters | Gets a collection of parameters associated with the custom report item's data.
Public Property | Filters | Gets a collection of filters to apply to each row of data.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the CustomData object.
Top

See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomData Constructor

[image]
ActiveReports 19 .NET Edition
CustomData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : CustomData Constructor

Glossary Item Box

Initializes a new instance of the CustomData class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


CustomData Class Methods

[image]
ActiveReports 19 .NET Edition
CustomData Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

Glossary Item Box

For a list of all members of this type, see CustomData members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the CustomData object.
Top

See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the CustomData object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


CustomData Class Properties

[image]
ActiveReports 19 .NET Edition
CustomData Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

Glossary Item Box

For a list of all members of this type, see CustomData members.

Public Properties

 | Name | Description
Public Property | DataColumnGroupings | Gets the column groupings defined for the custom report item's data.
Public Property | DataRowGroupings | Gets the row groupings defined for the custom report item's data.
Public Property | DataRows | Gets the data values calculated for each detail cell of the custom report item's data.
Public Property | DataSetName | Gets or sets s name of the data set used as the data source for the CustomReportItem.
Public Property | DataSetParameters | Gets a collection of parameters associated with the custom report item's data.
Public Property | Filters | Gets a collection of filters to apply to each row of data.
Top

See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataColumnGroupings Property

[image]
ActiveReports 19 .NET Edition
DataColumnGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataColumnGroupings Property

Glossary Item Box

Gets the column groupings defined for the custom report item's data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataColumnGroupings As DataGroupingCollection
C#
public DataGroupingCollection DataColumnGroupings {get;}

Property Value

A DataGroupingCollection object containing the column groupings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataRowGroupings Property

[image]
ActiveReports 19 .NET Edition
DataRowGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataRowGroupings Property

Glossary Item Box

Gets the row groupings defined for the custom report item's data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataRowGroupings As DataGroupingCollection
C#
public DataGroupingCollection DataRowGroupings {get;}

Property Value

A DataGroupingCollection object containing the row groupings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataRows Property

[image]
ActiveReports 19 .NET Edition
DataRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataRows Property

Glossary Item Box

Gets the data values calculated for each detail cell of the custom report item's data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataRows As DataRowCollection
C#
public DataRowCollection DataRows {get;}

Property Value

A DataRowCollection object containing the data values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataSetName Property

Glossary Item Box

Gets or sets s name of the data set used as the data source for the CustomReportItem.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As String
C#
public string DataSetName {get; set;}

Property Value

A System.String value indicating the name of the data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataSetParameters Property

[image]
ActiveReports 19 .NET Edition
DataSetParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataSetParameters Property

Glossary Item Box

Gets a collection of parameters associated with the custom report item's data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSetParameters As IList(Of Parameter)
C#
public IList<Parameter> DataSetParameters {get;}

Property Value

A collection of the Parameter objects containing the parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : Filters Property

Glossary Item Box

Gets a collection of filters to apply to each row of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter)
C#
public IList<Filter> Filters {get;}

Property Value

A collection of the Filter objects containing the filters to apply.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


CustomPaletteColorsCollection Class

[image]
ActiveReports 19 .NET Edition
CustomPaletteColorsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPaletteColorsCollection Class

Glossary Item Box

Represents a strongly typed collection of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects.

Object Model

CustomPaletteColorsCollection Class

Syntax

Visual Basic (Declaration)
Public Class CustomPaletteColorsCollection
   Inherits System.Collections.ObjectModel.Collection(Of ExpressionInfo)
C#
public class CustomPaletteColorsCollection : System.Collections.ObjectModel.Collection<ExpressionInfo>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.CustomPaletteColorsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPaletteColorsCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPaletteColorsCollection Class Members

[image]
ActiveReports 19 .NET Edition
CustomPaletteColorsCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPaletteColorsCollection Class

Glossary Item Box

The following tables list the members exposed by CustomPaletteColorsCollection.

Public Constructors

 | Name | Description
Public Constructor | CustomPaletteColorsCollection Constructor |
Top

See Also

Reference

CustomPaletteColorsCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPaletteColorsCollection Constructor

[image]
ActiveReports 19 .NET Edition
CustomPaletteColorsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPaletteColorsCollection Class : CustomPaletteColorsCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomPaletteColorsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPaletteColorsCollection Class
CustomPaletteColorsCollection Members


CustomPropertyDefinition Class

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class

Glossary Item Box

Represents a CustomProperty element from RDL (Report Definition Language). When processing the PageReportModel, if the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object contains any aggregate functions that do not specify the scope, the scope is updated with the current scope.

Object Model

CustomPropertyDefinition Class

Syntax

Visual Basic (Declaration)
Public Class CustomPropertyDefinition
C#
public class CustomPropertyDefinition

Example

C# Copy Code
var customProperty = new CustomPropertyDefinition("CustomName", "=Fields!FieldName.Value");

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinition Class Members

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class

Glossary Item Box

The following tables list the members exposed by CustomPropertyDefinition.

Public Constructors

 | Name | Description
Public Constructor | CustomPropertyDefinition Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the custom property.
Public Property | Value | Gets or sets the value of the custom property, which can be an expression.
Top

See Also

Reference

CustomPropertyDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinition Constructor

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : CustomPropertyDefinition Constructor

Glossary Item Box

Overload List

Overload | Description
CustomPropertyDefinition Constructor() | Initializes a new instance of the CustomPropertyDefinition class.
CustomPropertyDefinition Constructor(String,ExpressionInfo) | Initializes a new instance of the CustomPropertyDefinition class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


CustomPropertyDefinition Constructor()

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class > CustomPropertyDefinition Constructor : CustomPropertyDefinition Constructor()

Glossary Item Box

Initializes a new instance of the CustomPropertyDefinition class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomPropertyDefinition()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members
Overload List


CustomPropertyDefinition Constructor(String,ExpressionInfo)

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Constructor(String,ExpressionInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class > CustomPropertyDefinition Constructor : CustomPropertyDefinition Constructor(String,ExpressionInfo)

name
A System.String value indicating the name of the custom property.
value
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the value or the expression and data type to assign to the custom property.

Glossary Item Box

Initializes a new instance of the CustomPropertyDefinition class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As ExpressionInfo _
)
C#
public CustomPropertyDefinition(
   string name,
   ExpressionInfo value
)

Parameters

name
A System.String value indicating the name of the custom property.
value
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the value or the expression and data type to assign to the custom property.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if name is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members
Overload List


CustomPropertyDefinition Class Properties

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinition Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class

Glossary Item Box

For a list of all members of this type, see CustomPropertyDefinition members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the custom property.
Public Property | Value | Gets or sets the value of the custom property, which can be an expression.
Top

See Also

Reference

CustomPropertyDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : Name Property

Glossary Item Box

Gets or sets the name of the custom property.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : Value Property

Glossary Item Box

Gets or sets the value of the custom property, which can be an expression.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the value of the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


CustomPropertyDefinitionCollection Class

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

Glossary Item Box

Represents a strongly typed collection of CustomPropertyDefinition objects.

Object Model

CustomPropertyDefinitionCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomPropertyDefinitionCollection
   Inherits System.Collections.ObjectModel.Collection(Of CustomPropertyDefinition)
C#
public sealed class CustomPropertyDefinitionCollection : System.Collections.ObjectModel.Collection<CustomPropertyDefinition>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinitionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinitionCollection Class Members

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

Glossary Item Box

The following tables list the members exposed by CustomPropertyDefinitionCollection.

Public Constructors

 | Name | Description
Public Constructor | CustomPropertyDefinitionCollection Constructor | Initializes a new instance of the CustomPropertyDefinitionCollection class.
Top

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets a CustomPropertyDefinition using the specified name.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a range of CustomPropertyDefinition objects to the collection.
Top

See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinitionCollection Constructor

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : CustomPropertyDefinitionCollection Constructor

Glossary Item Box

Initializes a new instance of the CustomPropertyDefinitionCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomPropertyDefinitionCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


CustomPropertyDefinitionCollection Class Methods

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

Glossary Item Box

For a list of all members of this type, see CustomPropertyDefinitionCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a range of CustomPropertyDefinition objects to the collection.
Top

See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : AddRange Method

collection
A collection of CustomPropertyDefinition objects to add.

Glossary Item Box

Adds a range of CustomPropertyDefinition objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of CustomPropertyDefinition) _
)
C#
public void AddRange(
   IEnumerable<CustomPropertyDefinition> collection
)

Parameters

collection
A collection of CustomPropertyDefinition objects to add.

Example

C# Copy Code
var customProperties = new CustomPropertyDefinitionCollection();
var newProperties = new List<CustomPropertyDefinition>
{
    new CustomPropertyDefinition { Name = "Property1", Value = "Value1" },
    new CustomPropertyDefinition { Name = "Property2", Value = "Value2" }
};
customProperties.AddRange(newProperties);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


CustomPropertyDefinitionCollection Class Properties

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

Glossary Item Box

For a list of all members of this type, see CustomPropertyDefinitionCollection members.

Public Properties

 | Name | Description
Public Property | Item | Overloaded. Gets a CustomPropertyDefinition using the specified name.
Top

See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Item Property

Glossary Item Box

Gets a CustomPropertyDefinition using the specified name.

Overload List

Overload | Description
Item(String) | Gets a CustomPropertyDefinition using the specified name.

Example

C# Copy Code
var customProperties = new CustomPropertyDefinitionCollection();
var customProperty = customProperties["Property1"];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class > Item Property : Item(String) Property

name
A System.String value indicating the name of the property definition to get.

Glossary Item Box

Gets a CustomPropertyDefinition using the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As CustomPropertyDefinition
C#
public CustomPropertyDefinition Item(
   string name
) {get;}

Parameters

name
A System.String value indicating the name of the property definition to get.

Property Value

The CustomPropertyDefinition with the specified name, or null if not found.

Example

C# Copy Code
var customProperties = new CustomPropertyDefinitionCollection();
var customProperty = customProperties["Property1"];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members
Overload List


CustomReportItem Class

[image]
ActiveReports 19 .NET Edition
CustomReportItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

Glossary Item Box

Represents a custom ReportItem that not defined within the RDL (Report Definition Language) specification.

Object Model

CustomReportItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomReportItem
   Inherits ReportItem
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class CustomReportItem : ReportItem, IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

The custom report item's definition is encapsulated within the CustomReportItem element under a namespace specific to the supporting tool or server. If unrecognized, it defaults to behaving as an System.ComponentModel.IContainer.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.CustomReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItem Class Members

[image]
ActiveReports 19 .NET Edition
CustomReportItem Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

Glossary Item Box

The following tables list the members exposed by CustomReportItem.

Public Constructors

 | Name | Description
Public Constructor | CustomReportItem Constructor | Initializes a new instance of the CustomReportItem class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets a description of the control used by accessibility client applications.
Public Property | AltReportItem | Gets or sets an alternative report item to use if the custom report item cannot be processed.
Public Property | CustomData | Gets or sets a custom data settings used by the custom report item.
Public Property | InnerXml | Gets or sets a XML representation of the custom report item.
Public Property | IsDataRegion | Gets a value indicating whether the custom report item functions as a data region.
Public Property | ReportItems | Gets a collection of report items contained within the custom report item.
Public Property | Type | Gets or sets a type of the custom report item interpreted by the report server or designer tool.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the contained report items to optimize rendering performance.
Public Method | Validate | Overridden. Validates the current state of the CustomReportItem object.
Top

See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItem Constructor

[image]
ActiveReports 19 .NET Edition
CustomReportItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CustomReportItem Constructor

Glossary Item Box

Initializes a new instance of the CustomReportItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomReportItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomReportItem Class Methods

[image]
ActiveReports 19 .NET Edition
CustomReportItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

Glossary Item Box

For a list of all members of this type, see CustomReportItem members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the contained report items to optimize rendering performance.
Public Method | Validate | Overridden. Validates the current state of the CustomReportItem object.
Top

See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


SortReportItems Method

[image]
ActiveReports 19 .NET Edition
SortReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : SortReportItems Method

Glossary Item Box

Sorts the contained report items to optimize rendering performance.

Syntax

Visual Basic (Declaration)
Public Sub SortReportItems()
C#
public void SortReportItems()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the CustomReportItem object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomReportItem Class Properties

[image]
ActiveReports 19 .NET Edition
CustomReportItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

Glossary Item Box

For a list of all members of this type, see CustomReportItem members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets a description of the control used by accessibility client applications.
Public Property | AltReportItem | Gets or sets an alternative report item to use if the custom report item cannot be processed.
Public Property | CustomData | Gets or sets a custom data settings used by the custom report item.
Public Property | InnerXml | Gets or sets a XML representation of the custom report item.
Public Property | IsDataRegion | Gets a value indicating whether the custom report item functions as a data region.
Public Property | ReportItems | Gets a collection of report items contained within the custom report item.
Public Property | Type | Gets or sets a type of the custom report item interpreted by the report server or designer tool.
Top

See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : AccessibleDescription Property

Glossary Item Box

Gets or sets a description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the accessible description of the custom report item.

Example

C# Copy Code
CustomReportItem customReportItem = new CustomReportItem();
customReportItem.AccessibleDescription = "Custom report item.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


AltReportItem Property

[image]
ActiveReports 19 .NET Edition
AltReportItem Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : AltReportItem Property

Glossary Item Box

Gets or sets an alternative report item to use if the custom report item cannot be processed.

Syntax

Visual Basic (Declaration)
Public Property AltReportItem As ReportItem
C#
public ReportItem AltReportItem {get; set;}

Property Value

A ReportItem object representing the alternative report item.

Example

C# Copy Code
CustomReportItem customReportItem = new CustomReportItem();
customReportItem.AltReportItem = new TextBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomData Property

[image]
ActiveReports 19 .NET Edition
CustomData Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CustomData Property

Glossary Item Box

Gets or sets a custom data settings used by the custom report item.

Syntax

Visual Basic (Declaration)
Public Property CustomData As CustomData
C#
public CustomData CustomData {get; set;}

Property Value

A CustomData object representing custom data settings, or null if none are defined.

Example

C# Copy Code
CustomReportItem customReportItem = new CustomReportItem();
customReportItem.CustomData = new CustomData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


InnerXml Property

[image]
ActiveReports 19 .NET Edition
InnerXml Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : InnerXml Property

Glossary Item Box

Gets or sets a XML representation of the custom report item.

Syntax

Visual Basic (Declaration)
Public Property InnerXml As String
C#
public string InnerXml {get; set;}

Property Value

A System.String value containing XML content representing the custom report item.

Remarks

This contains all of the XML content inside the CustomReportItem element.

Example

C# Copy Code
CustomReportItem customReportItem = new CustomReportItem();
customReportItem.InnerXml = "<CustomReportItem><Property1>Value1</Property1></CustomReportItem>";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


IsDataRegion Property

[image]
ActiveReports 19 .NET Edition
IsDataRegion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : IsDataRegion Property

Glossary Item Box

Gets a value indicating whether the custom report item functions as a data region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataRegion As Boolean
C#
public bool IsDataRegion {get;}

Property Value

A System.Boolean value. true if the custom report item is a DataRegion; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : ReportItems Property

Glossary Item Box

Gets a collection of report items contained within the custom report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection object representing the collection of report items.

Remarks

Allows a CustomReportItem to implement a composite ReportItem. The serialization to the report definition of any contained ReportItem must be implemented using custom syntax specific to the derived ReportItem implementation. A Custom Designer for the derived implementation may be useful in that case.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Type Property

Glossary Item Box

Gets or sets a type of the custom report item interpreted by the report server or designer tool.

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type {get; set;}

Property Value

A System.String value indicating the type of the custom report item.

Example

C# Copy Code
CustomReportItem customReportItem = new CustomReportItem();
customReportItem.Type = "FormattedText";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomReportItemNames Class

[image]
ActiveReports 19 .NET Edition
CustomReportItemNames Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItemNames Class

Glossary Item Box

Object Model

CustomReportItemNames Class

Syntax

Visual Basic (Declaration)
Public Class CustomReportItemNames
C#
public class CustomReportItemNames

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomReportItemNames

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItemNames Class Members

[image]
ActiveReports 19 .NET Edition
CustomReportItemNames Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItemNames Class

Glossary Item Box

The following tables list the members exposed by CustomReportItemNames.

Public Constructors

 | Name | Description
Public Constructor | CustomReportItemNames Constructor |
Top

Public Fields

 | Name | Description
Public Field | BandedList |
Public Field | Barcode |
Public Field | Bullet |
Public Field | Calendar |
Public Field | ContentPlaceHolder |
Public Field | FormattedText |
Public Field | InputField |
Public Field | Sparkline |
Top

See Also

Reference

CustomReportItemNames Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItemNames Constructor

[image]
ActiveReports 19 .NET Edition
CustomReportItemNames Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : CustomReportItemNames Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomReportItemNames()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


CustomReportItemNames Class Fields

[image]
ActiveReports 19 .NET Edition
CustomReportItemNames Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItemNames Class

Glossary Item Box

For a list of all members of this type, see CustomReportItemNames members.

Public Fields

 | Name | Description
Public Field | BandedList |
Public Field | Barcode |
Public Field | Bullet |
Public Field | Calendar |
Public Field | ContentPlaceHolder |
Public Field | FormattedText |
Public Field | InputField |
Public Field | Sparkline |
Top

See Also

Reference

CustomReportItemNames Class
GrapeCity.ActiveReports.PageReportModel Namespace


BandedList Field

[image]
ActiveReports 19 .NET Edition
BandedList Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : BandedList Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BandedList As String
C#
public const string BandedList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


Barcode Field

[image]
ActiveReports 19 .NET Edition
Barcode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : Barcode Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Barcode As String
C#
public const string Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


Bullet Field

[image]
ActiveReports 19 .NET Edition
Bullet Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : Bullet Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Bullet As String
C#
public const string Bullet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


Calendar Field

[image]
ActiveReports 19 .NET Edition
Calendar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : Calendar Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Calendar As String
C#
public const string Calendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


ContentPlaceHolder Field

[image]
ActiveReports 19 .NET Edition
ContentPlaceHolder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : ContentPlaceHolder Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ContentPlaceHolder As String
C#
public const string ContentPlaceHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


FormattedText Field

[image]
ActiveReports 19 .NET Edition
FormattedText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : FormattedText Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FormattedText As String
C#
public const string FormattedText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


InputField Field

[image]
ActiveReports 19 .NET Edition
InputField Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : InputField Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const InputField As String
C#
public const string InputField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


Sparkline Field

[image]
ActiveReports 19 .NET Edition
Sparkline Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItemNames Class : Sparkline Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Sparkline As String
C#
public const string Sparkline

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemNames Class
CustomReportItemNames Members


DataCell Class

[image]
ActiveReports 19 .NET Edition
DataCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCell Class

Glossary Item Box

Represents the set of data values to pass to the custom report item for specific leaf-node groupings within CustomData.

Object Model

DataCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCell
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class DataCell : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.DataCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataCell Class Members

[image]
ActiveReports 19 .NET Edition
DataCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCell Class

Glossary Item Box

The following tables list the members exposed by DataCell.

Public Constructors

 | Name | Description
Public Constructor | DataCell Constructor | Initializes a new instance of the DataCell class.
Top

Public Properties

 | Name | Description
Public Property | DataValues | Gets the collection of data values to pass to the custom report item.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataCell object.
Top

See Also

Reference

DataCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataCell Constructor

[image]
ActiveReports 19 .NET Edition
DataCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCell Class : DataCell Constructor

Glossary Item Box

Initializes a new instance of the DataCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Class
DataCell Members


DataCell Class Methods

[image]
ActiveReports 19 .NET Edition
DataCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCell Class

Glossary Item Box

For a list of all members of this type, see DataCell members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataCell object.
Top

See Also

Reference

DataCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCell Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataCell object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Class
DataCell Members


DataCell Class Properties

[image]
ActiveReports 19 .NET Edition
DataCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCell Class

Glossary Item Box

For a list of all members of this type, see DataCell members.

Public Properties

 | Name | Description
Public Property | DataValues | Gets the collection of data values to pass to the custom report item.
Top

See Also

Reference

DataCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataValues Property

[image]
ActiveReports 19 .NET Edition
DataValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCell Class : DataValues Property

Glossary Item Box

Gets the collection of data values to pass to the custom report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataValues As DataValueCollection
C#
public DataValueCollection DataValues {get;}

Property Value

A DataValueCollection object representing the collection of data values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Class
DataCell Members


DataCellCollection Class

[image]
ActiveReports 19 .NET Edition
DataCellCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class

Glossary Item Box

Represents a strongly typed collection of DataCell objects.

Object Model

DataCellCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataCellCollection
   Inherits System.Collections.ObjectModel.Collection(Of DataCell)
C#
public sealed class DataCellCollection : System.Collections.ObjectModel.Collection<DataCell>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataCellCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataCellCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class

Glossary Item Box

The following tables list the members exposed by DataCellCollection.

Public Constructors

 | Name | Description
Public Constructor | DataCellCollection Constructor | Initializes a new instance of the DataCellCollection class.
Top

See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataCellCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataCellCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : DataCellCollection Constructor

Glossary Item Box

Initializes a new instance of the DataCellCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataCellCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Class
DataCellCollection Members


DataGrouping Class

[image]
ActiveReports 19 .NET Edition
DataGrouping Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

Glossary Item Box

Represents a data grouping definition that specifies how data is grouped and sorted in a report.

Object Model

DataGrouping Class

Syntax

Visual Basic (Declaration)
Public Class DataGrouping
   Implements IScopeDefinition, IValidateable
C#
public class DataGrouping : IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataGrouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataGrouping Class Members

[image]
ActiveReports 19 .NET Edition
DataGrouping Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

Glossary Item Box

The following tables list the members exposed by DataGrouping.

Public Constructors

 | Name | Description
Public Constructor | DataGrouping Constructor | Initializes a new instance of the DataGrouping class.
Top

Public Properties

 | Name | Description
Public Property | CustomProperties | Gets a custom properties for report item.
Public Property | DataGroupings | Gets a subgroupings contained within the current group.
Public Property | Grouping | Gets or sets an expressions by which to group the data.
Public Property | ReportItems | Gets a collection of report items in this grouping.
Public Property | Sorting | Gets how to sort the group instances.
Public Property | Static | Gets or sets a value indicating if this is a static grouping.
Public Property | Visibility | Gets a visibility of the grouping or DataRegion this DataGrouping represents.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataGrouping object.
Top

See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataGrouping Constructor

[image]
ActiveReports 19 .NET Edition
DataGrouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : DataGrouping Constructor

Glossary Item Box

Initializes a new instance of the DataGrouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataGrouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


DataGrouping Class Methods

[image]
ActiveReports 19 .NET Edition
DataGrouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

Glossary Item Box

For a list of all members of this type, see DataGrouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataGrouping object.
Top

See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataGrouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


DataGrouping Class Properties

[image]
ActiveReports 19 .NET Edition
DataGrouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

Glossary Item Box

For a list of all members of this type, see DataGrouping members.

Public Properties

 | Name | Description
Public Property | CustomProperties | Gets a custom properties for report item.
Public Property | DataGroupings | Gets a subgroupings contained within the current group.
Public Property | Grouping | Gets or sets an expressions by which to group the data.
Public Property | ReportItems | Gets a collection of report items in this grouping.
Public Property | Sorting | Gets how to sort the group instances.
Public Property | Static | Gets or sets a value indicating if this is a static grouping.
Public Property | Visibility | Gets a visibility of the grouping or DataRegion this DataGrouping represents.
Top

See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : CustomProperties Property

Glossary Item Box

Gets a custom properties for report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A collection of CustomPropertyDefinition objects.

Remarks

Custom properties from RDL or intrinsic RI properties. This is useful for external custom report item implementations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


DataGroupings Property

[image]
ActiveReports 19 .NET Edition
DataGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : DataGroupings Property

Glossary Item Box

Gets a subgroupings contained within the current group.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataGroupings As DataGroupingCollection
C#
public DataGroupingCollection DataGroupings {get;}

Property Value

A collection of DataGrouping objects representing subgroupings.

Remarks

If there are no subgroupings in the current collection, the current grouping is the inner-most grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Grouping Property

Glossary Item Box

Gets or sets an expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

An instance of the Grouping class containing the grouping expressions.

Remarks

If Grouping is null or the Grouping.GroupExpressions property is empty and there are no DataGroupings, it indicates that this is a detail grouping which is repeated for every detail record.

However, if Grouping is null or the Grouping.GroupExpressions property is empty and there are DataGroupings, it indicates that this grouping has a single instance which contains all records and all DataGroupings objects and is not repeated for each record.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : ReportItems Property

Glossary Item Box

Gets a collection of report items in this grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A collection of ReportItem objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Sorting Property

Glossary Item Box

Gets how to sort the group instances.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A of SortByCollection object representing the sort criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


Static Property

[image]
ActiveReports 19 .NET Edition
Static Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Static Property

Glossary Item Box

Gets or sets a value indicating if this is a static grouping.

Syntax

Visual Basic (Declaration)
Public Property Static As Boolean
C#
public bool Static {get; set;}

Property Value

A System.Boolean value indicating whether this is a static grouping.

Remarks

Must be true if any ancestor grouping is a detail grouping.

One member is created for each expression in the Grouping.GroupExpressions property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Visibility Property

Glossary Item Box

Gets a visibility of the grouping or DataRegion this DataGrouping represents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visibility As Visibility
C#
public Visibility Visibility {get;}

Property Value

A of Visibility object represents the visibility rules.

Remarks

Consider making this public. It is used for CustomData/Matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGrouping Class
DataGrouping Members


DataGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class

Glossary Item Box

Represents a strongly typed collection of DataGrouping objects.

Object Model

DataGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataGroupingCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of DataGrouping)
C#
public sealed class DataGroupingCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<DataGrouping>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.DataGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by DataGroupingCollection.

Public Constructors

 | Name | Description
Public Constructor | DataGroupingCollection Constructor |
Top

See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataGroupingCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : DataGroupingCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataGroupingCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


DataLabel Class

[image]
ActiveReports 19 .NET Edition
DataLabel Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

Glossary Item Box

The DataLabel element defines the data labels to display on the data values in the chart.

Object Model

DataLabel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataLabel
   Implements IValidateable
C#
public sealed class DataLabel : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataLabel Class Members

[image]
ActiveReports 19 .NET Edition
DataLabel Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

Glossary Item Box

The following tables list the members exposed by DataLabel.

Public Constructors

 | Name | Description
Public Constructor | DataLabel Constructor | Initializes a new instance of the DataLabel class.
Top

Public Properties

 | Name | Description
Public Property | Position | Gets or sets the position of the label.
Public Property | Rotation | Gets or sets the angle of rotation of the label text.
Public Property | Style | Gets or sets the text, border and background style properties for the labels.
Public Property | Value | Gets or sets the expression to use for the value labels.
Public Property | Visible | Gets or sets a value indicating whether the data label is displayed on the chart.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DataLabel object.
Top

See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataLabel Constructor

[image]
ActiveReports 19 .NET Edition
DataLabel Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : DataLabel Constructor

Glossary Item Box

Initializes a new instance of the DataLabel class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataLabel()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


DataLabel Class Methods

[image]
ActiveReports 19 .NET Edition
DataLabel Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

Glossary Item Box

For a list of all members of this type, see DataLabel members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DataLabel object.
Top

See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the DataLabel object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


DataLabel Class Properties

[image]
ActiveReports 19 .NET Edition
DataLabel Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

Glossary Item Box

For a list of all members of this type, see DataLabel members.

Public Properties

 | Name | Description
Public Property | Position | Gets or sets the position of the label.
Public Property | Rotation | Gets or sets the angle of rotation of the label text.
Public Property | Style | Gets or sets the text, border and background style properties for the labels.
Public Property | Value | Gets or sets the expression to use for the value labels.
Public Property | Visible | Gets or sets a value indicating whether the data label is displayed on the chart.
Top

See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Position Property

Glossary Item Box

Gets or sets the position of the label.

Syntax

Visual Basic (Declaration)
Public Property Position As Position
C#
public Position Position {get; set;}

Property Value

A Position enumeration indicating the position of the label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Rotation Property

Glossary Item Box

Gets or sets the angle of rotation of the label text.

Syntax

Visual Basic (Declaration)
Public Property Rotation As Nullable(Of Integer)
C#
public Nullable<int> Rotation {get; set;}

Property Value

A System.Nullable value indicating the angle of rotation of the label text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Style Property

Glossary Item Box

Gets or sets the text, border and background style properties for the labels.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object indicating the text, border and background style properties for the labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Value Property

Glossary Item Box

Gets or sets the expression to use for the value labels.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the expression for the value labels.

Remarks

If omitted, values in the ValueCategoryAxis object are used instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the data label is displayed on the chart.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A System.Boolean value where true indicates that the data label is displayed on the chart; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataLabel Class
DataLabel Members


DataPoint Class

[image]
ActiveReports 19 .NET Edition
DataPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

Glossary Item Box

The DataPoint element defines a set of data for a single point in the chart. There must be a corresponding DataPoint for each static category in a static series. A DataPoint may consist of a single value expression (for example in a bar or line chart) or multiple value expressions (for example in a stock or bubble chart).

Object Model

DataPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPoint
   Implements IValidateable
C#
public sealed class DataPoint : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoint Class Members

[image]
ActiveReports 19 .NET Edition
DataPoint Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

Glossary Item Box

The following tables list the members exposed by DataPoint.

Public Constructors

 | Name | Description
Public Constructor | DataPoint Constructor | Initializes a new instance of the DataPoint class.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to execute.
Public Property | DataElementName | Gets or sets the name to use for the data element for the data point.
Public Property | DataElementOutput | Gets or sets a value defining how or whether a data point appears in a data rendering.
Public Property | DataLabel | Gets or sets the data label with which to mark the value.
Public Property | DataValues | Gets the data value set for the Y axis.
Public Property | Marker | Gets or sets the marker properties.
Public Property | ShowBeginEndMarkersOnly | Specify whether the first and last markers for the data point are displayed. Otherwise, all markers are displayed.
Public Property | Style | Gets or sets the border and background style properties for the data point.
Public Property | ToolTip | Gets or sets expression of tooltip.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DataPoint object.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoint Constructor

[image]
ActiveReports 19 .NET Edition
DataPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataPoint Constructor

Glossary Item Box

Initializes a new instance of the DataPoint class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPoint()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Methods

[image]
ActiveReports 19 .NET Edition
DataPoint Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

Glossary Item Box

For a list of all members of this type, see DataPoint members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DataPoint object.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the DataPoint object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Properties

[image]
ActiveReports 19 .NET Edition
DataPoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

Glossary Item Box

For a list of all members of this type, see DataPoint members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to execute.
Public Property | DataElementName | Gets or sets the name to use for the data element for the data point.
Public Property | DataElementOutput | Gets or sets a value defining how or whether a data point appears in a data rendering.
Public Property | DataLabel | Gets or sets the data label with which to mark the value.
Public Property | DataValues | Gets the data value set for the Y axis.
Public Property | Marker | Gets or sets the marker properties.
Public Property | ShowBeginEndMarkersOnly | Specify whether the first and last markers for the data point are displayed. Otherwise, all markers are displayed.
Public Property | Style | Gets or sets the border and background style properties for the data point.
Public Property | ToolTip | Gets or sets expression of tooltip.
Top

See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Action Property

Glossary Item Box

Gets or sets the action to execute.

Syntax

Visual Basic (Declaration)
Public Property Action As Action
C#
public Action Action {get; set;}

Property Value

An Action indicating the action to execute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataElementName Property

Glossary Item Box

Gets or sets the name to use for the data element for the data point.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String indicating the name to use for the data element for the data point.

Remarks

The default value is the name of the corresponding static series or category. If there is no static series or category, "Value."

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value defining how or whether a data point appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration defining how or whether a data point appears in a data rendering.

Remarks

Output (Default) indicates that the DataPoints appear in the output. NoOutput indicates that the DataPoints do not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataLabel Property

[image]
ActiveReports 19 .NET Edition
DataLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataLabel Property

Glossary Item Box

Gets or sets the data label with which to mark the value.

Syntax

Visual Basic (Declaration)
Public Property DataLabel As DataLabel
C#
public DataLabel DataLabel {get; set;}

Property Value

A DataLabel object indicating that the values are marked with data labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataValues Property

[image]
ActiveReports 19 .NET Edition
DataValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataValues Property

Glossary Item Box

Gets the data value set for the Y axis.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataValues As DataValueCollection
C#
public DataValueCollection DataValues {get;}

Property Value

A DataValueCollection object containing the data value set for the Y axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Marker Property

Glossary Item Box

Gets or sets the marker properties.

Syntax

Visual Basic (Declaration)
Public Property Marker As Marker
C#
public Marker Marker {get; set;}

Property Value

A Marker object containing the marker properties.

Remarks

Markers do not apply to data points of pie, doughnut, or stacked chart types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ShowBeginEndMarkersOnly Property

[image]
ActiveReports 19 .NET Edition
ShowBeginEndMarkersOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : ShowBeginEndMarkersOnly Property

Glossary Item Box

Specify whether the first and last markers for the data point are displayed. Otherwise, all markers are displayed.

Syntax

Visual Basic (Declaration)
Public Property ShowBeginEndMarkersOnly As Boolean
C#
public bool ShowBeginEndMarkersOnly {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Style Property

Glossary Item Box

Gets or sets the border and background style properties for the data point.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : ToolTip Property

Glossary Item Box

Gets or sets expression of tooltip.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As ExpressionInfo
C#
public ExpressionInfo ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPoint Class
DataPoint Members


DataPointCollection Class

[image]
ActiveReports 19 .NET Edition
DataPointCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

Glossary Item Box

Represents a strongly typed collection of DataPoint objects.

Object Model

DataPointCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataPointCollection
   Inherits System.Collections.ObjectModel.Collection(Of DataPoint)
C#
public sealed class DataPointCollection : System.Collections.ObjectModel.Collection<DataPoint>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataPointCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataPointCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataPointCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

Glossary Item Box

The following tables list the members exposed by DataPointCollection.

Public Constructors

 | Name | Description
Public Constructor | DataPointCollection Constructor | Initializes a new instance of the DataPointCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of DataPoint objects to the existing DataPointCollection.
Top

See Also

Reference

DataPointCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPointCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataPointCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : DataPointCollection Constructor

Glossary Item Box

Initializes a new instance of the DataPointCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataPointCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection Class Methods

[image]
ActiveReports 19 .NET Edition
DataPointCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

Glossary Item Box

For a list of all members of this type, see DataPointCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of DataPoint objects to the existing DataPointCollection.
Top

See Also

Reference

DataPointCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : AddRange Method

collection
A collection of the DataPoint objects to add.

Glossary Item Box

Adds a collection of DataPoint objects to the existing DataPointCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of DataPoint) _
)
C#
public void AddRange(
   IEnumerable<DataPoint> collection
)

Parameters

collection
A collection of the DataPoint objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataRegion Class

[image]
ActiveReports 19 .NET Edition
DataRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

Glossary Item Box

Specifies a region where a dataset is laid out for a report. A data region bound to a dataset's results may repeat its contents to account for the dataset's size. The List, Matrix, Table and Chart report items are all data regions.Specifies a region where a dataset is laid out for a report. A data region bound to a dataset's results may repeat its contents to account for the dataset's size. The List, Matrix, Table, Tablix and Chart report items are all data regions.

Object Model

DataRegion Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataRegion
   Inherits ReportItem
   Implements IReportComponent, IScopeDefinition, IValidateable
C#
public abstract class DataRegion : ReportItem, IReportComponent, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.Import.Models.Chart
GrapeCity.ActiveReports.PageReportModel.Chart
GrapeCity.ActiveReports.PageReportModel.FixedPage
GrapeCity.ActiveReports.PageReportModel.List
GrapeCity.ActiveReports.PageReportModel.Matrix
GrapeCity.ActiveReports.PageReportModel.Table
GrapeCity.ActiveReports.PageReportModel.Tablix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataRegion Class Members

[image]
ActiveReports 19 .NET Edition
DataRegion Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

Glossary Item Box

The following tables list the members exposed by DataRegion.

Public Properties

 | Name | Description
Public Property | ChildScopes | Gets the child scopes for the data region.
Public Property | DataSetName | Gets or sets the name of the dataset used by the data region.
Public Property | DataSetParameters | Gets a collection of the parameters for the dataset.
Public Property | Filters | Gets a collection of filters applied to each row of data within the data region.
Public Property | FixedHeight | Gets or sets a maximum height of the data region per page.
Public Property | FixedWidth | Gets or sets a maximum width of the data region per page.
Public Property | NewPage | Gets or sets a value indicating how the page on which the content should start after a page break.
Public Property | NewSection | Gets or sets a value indicating whether the data region is in its own section.
Public Property | NoRows | Gets or sets a message to display inside the data region when the region contains no rows.
Public Property | OverflowName | Gets or sets the name of the overflow region.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins.
Public Property | PageName | Gets or sets a name of the sheet when exporting to Excel.
Public Property | ReportItemsInScope | Gets the report items in scope for the data region.
Top

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the DataRegion object.
Top

See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataRegion Class Methods

[image]
ActiveReports 19 .NET Edition
DataRegion Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

Glossary Item Box

For a list of all members of this type, see DataRegion members.

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the DataRegion object.
Top

See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataRegion object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


DataRegion Class Properties

[image]
ActiveReports 19 .NET Edition
DataRegion Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

Glossary Item Box

For a list of all members of this type, see DataRegion members.

Public Properties

 | Name | Description
Public Property | ChildScopes | Gets the child scopes for the data region.
Public Property | DataSetName | Gets or sets the name of the dataset used by the data region.
Public Property | DataSetParameters | Gets a collection of the parameters for the dataset.
Public Property | Filters | Gets a collection of filters applied to each row of data within the data region.
Public Property | FixedHeight | Gets or sets a maximum height of the data region per page.
Public Property | FixedWidth | Gets or sets a maximum width of the data region per page.
Public Property | NewPage | Gets or sets a value indicating how the page on which the content should start after a page break.
Public Property | NewSection | Gets or sets a value indicating whether the data region is in its own section.
Public Property | NoRows | Gets or sets a message to display inside the data region when the region contains no rows.
Public Property | OverflowName | Gets or sets the name of the overflow region.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins.
Public Property | PageName | Gets or sets a name of the sheet when exporting to Excel.
Public Property | ReportItemsInScope | Gets the report items in scope for the data region.
Top

See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the data region.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ChildScopes As IEnumerable
C#
public abstract IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : DataSetName Property

Glossary Item Box

Gets or sets the name of the dataset used by the data region.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As String
C#
public string DataSetName {get; set;}

Property Value

A System.String value indicating the dataset name used by the data region.

Remarks

If there are multiple datasets in the report, DataSetName is required for all DataRegions not contained within a parent data region.

If there is only one dataset in the report, this dataset is assumed if DataSetName is not specified.

If there are no datasets in the report, DataSetName cannot be set.

Example

C# Copy Code
dataRegion.DataSetName = "SalesData";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


DataSetParameters Property

[image]
ActiveReports 19 .NET Edition
DataSetParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : DataSetParameters Property

Glossary Item Box

Gets a collection of the parameters for the dataset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSetParameters As ParameterCollection
C#
public ParameterCollection DataSetParameters {get;}

Property Value

A ParameterCollection object containing the parameters for the dataset.

Remarks

These parameters can be used for filtering data in regions where the dataset name differs from the parent data region's dataset name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Filters Property

Glossary Item Box

Gets a collection of filters applied to each row of data within the data region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter)
C#
public IList<Filter> Filters {get;}

Property Value

A collection of the Filter objects containing the filters applied to each row of data within the data region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


FixedHeight Property

[image]
ActiveReports 19 .NET Edition
FixedHeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : FixedHeight Property

Glossary Item Box

Gets or sets a maximum height of the data region per page.

Syntax

Visual Basic (Declaration)
Public Property FixedHeight As Length
C#
public Length FixedHeight {get; set;}

Property Value

A Length value indicating the maximum height of the data region per page. If undefined, uses ReportItem.Height.

Example

C# Copy Code
dataRegion.FixedHeight = "11in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


FixedWidth Property

[image]
ActiveReports 19 .NET Edition
FixedWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : FixedWidth Property

Glossary Item Box

Gets or sets a maximum width of the data region per page.

Syntax

Visual Basic (Declaration)
Public Property FixedWidth As Length
C#
public Length FixedWidth {get; set;}

Property Value

A Length value indicating the maximum width of the data region per page. If undefined, uses ReportItem.Width.

Example

C# Copy Code
dataRegion.FixedWidth = "8in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : NewPage Property

Glossary Item Box

Gets or sets a value indicating how the page on which the content should start after a page break.

Syntax

Visual Basic (Declaration)
Public Property NewPage As StartNewPage
C#
public StartNewPage NewPage {get; set;}

Property Value

A StartNewPage value indicating the page where content should start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : NewSection Property

Glossary Item Box

Gets or sets a value indicating whether the data region is in its own section.

Syntax

Visual Basic (Declaration)
Public Property NewSection As Boolean
C#
public bool NewSection {get; set;}

Property Value

A System.Boolean value indicating whether the data region is in its own section. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : NoRows Property

Glossary Item Box

Gets or sets a message to display inside the data region when the region contains no rows.

Syntax

Visual Basic (Declaration)
Public Property NoRows As ExpressionInfo
C#
public ExpressionInfo NoRows {get; set;}

Property Value

A System.String value indicating the message to display when the region contains no rows.

Remarks

When the NoRows message is displayed, the style information for the region is applied to the text.

Data regions inside a Table or Matrix cell that do not have a NoRows property value set display no content when there is no data, but the region's border and background properties are still applied to the cell.

Example

C# Copy Code
dataRegion.NoRows = "No data available";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : OverflowName Property

Glossary Item Box

Gets or sets the name of the overflow region.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A System.String value indicating the name of the overflow region.

Example

C# Copy Code
dataRegion.OverflowName = "OverflowRegion";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately after the data region ends.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true indicates that a page break occurs immediately after the data region ends; otherwise, false. Default value is false.

Remarks

If PageBreakAtEnd is true, controls before the data region that extend horizontally past its end are moved to the next page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether a page break occurs immediately before the data region begins.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true indicates that a page break occurs immediately before the data region begins; otherwise, false. Default value is false.

Remarks

If PageBreakAtStart is true, controls above the data region that extend horizontally past its start are not moved to the next page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : PageName Property

Glossary Item Box

Gets or sets a name of the sheet when exporting to Excel.

Syntax

Visual Basic (Declaration)
Public Property PageName As ExpressionInfo
C#
public ExpressionInfo PageName {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the sheet name for Excel export.

Example

C# Copy Code
dataRegion.PageName = "SalesReport";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the data region.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ReportItemsInScope As IEnumerable
C#
public abstract IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


DataRow Class

[image]
ActiveReports 19 .NET Edition
DataRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRow Class

Glossary Item Box

Represents a row of data containing columns to pass to a custom report item.

Object Model

DataRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataRow
   Implements IValidateable
C#
public sealed class DataRow : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataRow Class Members

[image]
ActiveReports 19 .NET Edition
DataRow Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRow Class

Glossary Item Box

The following tables list the members exposed by DataRow.

Public Constructors

 | Name | Description
Public Constructor | DataRow Constructor | Initializes a new instance of the DataRow class.
Top

Public Properties

 | Name | Description
Public Property | DataCells | Gets the collection of data cells within this data row.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataRow object.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataRow Constructor

[image]
ActiveReports 19 .NET Edition
DataRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRow Class : DataRow Constructor

Glossary Item Box

Initializes a new instance of the DataRow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataRow Class Methods

[image]
ActiveReports 19 .NET Edition
DataRow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRow Class

Glossary Item Box

For a list of all members of this type, see DataRow members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataRow object.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRow Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataRow object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataRow Class Properties

[image]
ActiveReports 19 .NET Edition
DataRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRow Class

Glossary Item Box

For a list of all members of this type, see DataRow members.

Public Properties

 | Name | Description
Public Property | DataCells | Gets the collection of data cells within this data row.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataCells Property

[image]
ActiveReports 19 .NET Edition
DataCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRow Class : DataCells Property

Glossary Item Box

Gets the collection of data cells within this data row.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataCells As DataCellCollection
C#
public DataCellCollection DataCells {get;}

Property Value

A collection of DataCell objects representing individual data cells.

Remarks

There must be as many DataCell elements as there are leaf-node DataGrouping objects in the DataGroupingCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataRowCollection Class

[image]
ActiveReports 19 .NET Edition
DataRowCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportItem objects.

Object Model

DataRowCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataRowCollection
   Inherits System.Collections.ObjectModel.Collection(Of DataRow)
C#
public sealed class DataRowCollection : System.Collections.ObjectModel.Collection<DataRow>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataRowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataRowCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataRowCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class

Glossary Item Box

The following tables list the members exposed by DataRowCollection.

Public Constructors

 | Name | Description
Public Constructor | DataRowCollection Constructor | Initializes a new instance of the DataRowCollection class.
Top

See Also

Reference

DataRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataRowCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataRowCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : DataRowCollection Constructor

Glossary Item Box

Initializes a new instance of the DataRowCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataRowCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRowCollection Class
DataRowCollection Members


DataSet Class

[image]
ActiveReports 19 .NET Edition
DataSet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

Glossary Item Box

Represents a DataSet element for a report that contains information about a set of data retrieved as part of the report.

Object Model

DataSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSet
   Implements IBaseDataSet, IDataSet, IReportComponent, IValidateable
C#
public sealed class DataSet : IBaseDataSet, IDataSet, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSet Class Members

[image]
ActiveReports 19 .NET Edition
DataSet Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

Glossary Item Box

The following tables list the members exposed by DataSet.

Public Constructors

 | Name | Description
Public Constructor | DataSet Constructor | Initializes a new instance of the DataSet class.
Top

Public Properties

 | Name | Description
Public Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Public Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Public Property | Collation | Gets or sets a locale to use in the collation sequence for sorting data.
Public Property | Fields | Gets the fields in the dataset.
Public Property | Filters | Gets a collection of filters applied to each row of data in the dataset.
Public Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Public Property | Name | Gets or sets a name of the dataset.
Public Property | Query | Gets or sets a query information for the dataset.
Public Property | SharedDataSet | Gets or sets a shared dataset.
Public Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSet object.
Top

See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSet Constructor

[image]
ActiveReports 19 .NET Edition
DataSet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : DataSet Constructor

Glossary Item Box

Initializes a new instance of the DataSet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


DataSet Class Methods

[image]
ActiveReports 19 .NET Edition
DataSet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

Glossary Item Box

For a list of all members of this type, see DataSet members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSet object.
Top

See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataSet object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


DataSet Class Properties

[image]
ActiveReports 19 .NET Edition
DataSet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

Glossary Item Box

For a list of all members of this type, see DataSet members.

Public Properties

 | Name | Description
Public Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Public Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Public Property | Collation | Gets or sets a locale to use in the collation sequence for sorting data.
Public Property | Fields | Gets the fields in the dataset.
Public Property | Filters | Gets a collection of filters applied to each row of data in the dataset.
Public Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Public Property | Name | Gets or sets a name of the dataset.
Public Property | Query | Gets or sets a query information for the dataset.
Public Property | SharedDataSet | Gets or sets a shared dataset.
Public Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top

See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccentSensitivity Property

[image]
ActiveReports 19 .NET Edition
AccentSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : AccentSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is accent sensitive.

Syntax

Visual Basic (Declaration)
Public Property AccentSensitivity As AccentSensitivity
C#
public AccentSensitivity AccentSensitivity {get; set;}

Property Value

An AccentSensitivity value indicating whether the data is accent sensitive.

Remarks

If AccentSensitivity.Auto value is specified, the application attempts to determine the accent sensitivity by querying the data provider.

Defaults to AccentSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


CaseSensitivity Property

[image]
ActiveReports 19 .NET Edition
CaseSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : CaseSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is case sensitive.

Syntax

Visual Basic (Declaration)
Public Property CaseSensitivity As CaseSensitivity
C#
public CaseSensitivity CaseSensitivity {get; set;}

Property Value

A CaseSensitivity value indicating whether the fields in the dataset are case sensitive.

Remarks

If CaseSensitivity.Auto value is specified, the application attempts to determine the case sensitivity by querying the data provider.

Defaults to CaseSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Collation Property

[image]
ActiveReports 19 .NET Edition
Collation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Collation Property

Glossary Item Box

Gets or sets a locale to use in the collation sequence for sorting data.

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation {get; set;}

Property Value

A System.String value indicating the locale for the collation sequence.

Remarks

If no collation is specified, the application attempts to determine the collation setting by querying the data provider.

Defaults to the application's locale settings if the data provider does not support this feature or returns an invalid value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Fields Property

[image]
ActiveReports 19 .NET Edition
Fields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Fields Property

Glossary Item Box

Gets the fields in the dataset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
C#
public FieldCollection Fields {get;}

Property Value

A FieldCollection object containing the fields in the dataset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Filters Property

Glossary Item Box

Gets a collection of filters applied to each row of data in the dataset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter)
C#
public IList<Filter> Filters {get;}

Property Value

An IList object containing the filters to be applied to each row of data.

Remarks

Filters help in refining the data by including or excluding rows based on specified criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


KanatypeSensitivity Property

[image]
ActiveReports 19 .NET Edition
KanatypeSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : KanatypeSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is kanatype sensitive.

Syntax

Visual Basic (Declaration)
Public Property KanatypeSensitivity As KanatypeSensitivity
C#
public KanatypeSensitivity KanatypeSensitivity {get; set;}

Property Value

A KanatypeSensitivity value indicating whether the data is kanatype sensitive.

Remarks

If KanatypeSensitivity.Auto value is specified, the application attempts to determine the kanatype sensitivity by querying the data provider.

Defaults to KanatypeSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Name Property

Glossary Item Box

Gets or sets a name of the dataset.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the dataset.

Remarks

The dataset name must be unique and cannot match any data region or grouping name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Query Property

[image]
ActiveReports 19 .NET Edition
Query Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Query Property

Glossary Item Box

Gets or sets a query information for the dataset.

Syntax

Visual Basic (Declaration)
Public Property Query As Query
C#
public Query Query {get; set;}

Property Value

A Query object including connection details, query text, and other relevant information for retrieving data.

Remarks

This property must be set to fetch data from the data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


SharedDataSet Property

[image]
ActiveReports 19 .NET Edition
SharedDataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : SharedDataSet Property

Glossary Item Box

Gets or sets a shared dataset.

Syntax

Visual Basic (Declaration)
Public Property SharedDataSet As SharedDataSet
C#
public SharedDataSet SharedDataSet {get; set;}

Property Value

A SharedDataSet object representing the shared dataset used by this dataset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


WidthSensitivity Property

[image]
ActiveReports 19 .NET Edition
WidthSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : WidthSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is width sensitive.

Syntax

Visual Basic (Declaration)
Public Property WidthSensitivity As WidthSensitivity
C#
public WidthSensitivity WidthSensitivity {get; set;}

Property Value

A WidthSensitivity ����� indicating whether the data is width sensitive.

Remarks

If WidthSensitivity.Auto value is specified, the application attempts to determine the width sensitivity by querying the data provider.

Defaults to WidthSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


DataSetCollection Class

[image]
ActiveReports 19 .NET Edition
DataSetCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class

Glossary Item Box

Represents a strongly typed collection of IDataSet objects.

Object Model

DataSetCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSetCollection
   Inherits System.Collections.ObjectModel.Collection(Of IDataSet)
C#
public sealed class DataSetCollection : System.Collections.ObjectModel.Collection<IDataSet>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataSetCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataSetCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class

Glossary Item Box

The following tables list the members exposed by DataSetCollection.

See Also

Reference

DataSetCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Class

[image]
ActiveReports 19 .NET Edition
DataSetReference Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

Glossary Item Box

Represents the query to execute to obtain a list of values or default values for a parameter.

Object Model

DataSetReference Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSetReference
   Implements IValidateable
C#
public sealed class DataSetReference : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSetReference

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Class Members

[image]
ActiveReports 19 .NET Edition
DataSetReference Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

Glossary Item Box

The following tables list the members exposed by DataSetReference.

Public Constructors

 | Name | Description
Public Constructor | DataSetReference Constructor | Initializes a new instance of the DataSetReference class.
Top

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets a name of the dataset to use for the parameter.
Public Property | LabelField | Gets or sets a name of the field to use for the value displayed to the user for selection.
Public Property | ValueField | Gets or sets a name of the field to use for the values and defaults of the parameter.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSetReference object.
Top

See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Constructor

[image]
ActiveReports 19 .NET Edition
DataSetReference Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : DataSetReference Constructor

Glossary Item Box

Initializes a new instance of the DataSetReference class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSetReference()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Class
DataSetReference Members


DataSetReference Class Methods

[image]
ActiveReports 19 .NET Edition
DataSetReference Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

Glossary Item Box

For a list of all members of this type, see DataSetReference members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSetReference object.
Top

See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataSetReference object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Class
DataSetReference Members


DataSetReference Class Properties

[image]
ActiveReports 19 .NET Edition
DataSetReference Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

Glossary Item Box

For a list of all members of this type, see DataSetReference members.

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets a name of the dataset to use for the parameter.
Public Property | LabelField | Gets or sets a name of the field to use for the value displayed to the user for selection.
Public Property | ValueField | Gets or sets a name of the field to use for the values and defaults of the parameter.
Top

See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : DataSetName Property

Glossary Item Box

Gets or sets a name of the dataset to use for the parameter.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As String
C#
public string DataSetName {get; set;}

Property Value

A System.String value indicating the name of the dataset to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Class
DataSetReference Members


LabelField Property

[image]
ActiveReports 19 .NET Edition
LabelField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : LabelField Property

Glossary Item Box

Gets or sets a name of the field to use for the value displayed to the user for selection.

Syntax

Visual Basic (Declaration)
Public Property LabelField As String
C#
public string LabelField {get; set;}

Property Value

A System.String value indicating the name of the field to use for the value displayed to the user for selection.

Remarks

If this property is not supplied, or if the returned value is null, the value in the ValueField is used.

This property is not used for the DefaultValue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Class
DataSetReference Members


ValueField Property

[image]
ActiveReports 19 .NET Edition
ValueField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : ValueField Property

Glossary Item Box

Gets or sets a name of the field to use for the values and defaults of the parameter.

Syntax

Visual Basic (Declaration)
Public Property ValueField As String
C#
public string ValueField {get; set;}

Property Value

A System.String value indicating the name of the field to use for the values and defaults of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetReference Class
DataSetReference Members


DataSource Class

[image]
ActiveReports 19 .NET Edition
DataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

Glossary Item Box

Represents information about a report data source, specifying its connection details.

Object Model

DataSource Class

Syntax

Visual Basic (Declaration)
Public Class DataSource
   Implements IValidateable
C#
public class DataSource : IValidateable

Remarks

A DataSource must have only one DataSourceReference or one ConnectionProperties object defined.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSource Class Members

[image]
ActiveReports 19 .NET Edition
DataSource Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

Glossary Item Box

The following tables list the members exposed by DataSource.

Public Constructors

 | Name | Description
Public Constructor | DataSource Constructor | Initializes a new instance of the DataSource class.
Top

Public Properties

 | Name | Description
Public Property | ConnectionProperties | Gets or sets the connection properties used to connect to the data source.
Public Property | DataSourceReference | Gets or sets a full or relative path to the reference of the data source.
Public Property | Name | Gets or sets a name of the data source.
Public Property | Transaction | Gets or sets a value indicating whether the data source should execute its datasets within a single transaction.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSource object.
Top

See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSource Constructor

[image]
ActiveReports 19 .NET Edition
DataSource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : DataSource Constructor

Glossary Item Box

Initializes a new instance of the DataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSource Class Methods

[image]
ActiveReports 19 .NET Edition
DataSource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

Glossary Item Box

For a list of all members of this type, see DataSource members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DataSource object.
Top

See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DataSource object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSource Class Properties

[image]
ActiveReports 19 .NET Edition
DataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

Glossary Item Box

For a list of all members of this type, see DataSource members.

Public Properties

 | Name | Description
Public Property | ConnectionProperties | Gets or sets the connection properties used to connect to the data source.
Public Property | DataSourceReference | Gets or sets a full or relative path to the reference of the data source.
Public Property | Name | Gets or sets a name of the data source.
Public Property | Transaction | Gets or sets a value indicating whether the data source should execute its datasets within a single transaction.
Top

See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Property

[image]
ActiveReports 19 .NET Edition
ConnectionProperties Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : ConnectionProperties Property

Glossary Item Box

Gets or sets the connection properties used to connect to the data source.

Syntax

Visual Basic (Declaration)
Public Property ConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ConnectionProperties {get; set;}

Property Value

A ConnectionProperties object representing the connection details.

Example

C# Copy Code
var dataSource = new DataSource();
dataSource.ConnectionProperties = new ConnectionProperties()
{
    DataProvider = "SQL",
    ConnectString = ExpressionInfo.FromString("Server=myServer;Database=myDatabase;Integrated Security=True;"),
    ConnectStringType = ConnectStringType.Embedded,
    IntegratedSecurity = true,
    Prompt = "Please enter your credentials."
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSourceReference Property

[image]
ActiveReports 19 .NET Edition
DataSourceReference Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : DataSourceReference Property

Glossary Item Box

Gets or sets a full or relative path to the reference of the data source.

Syntax

Visual Basic (Declaration)
Public Property DataSourceReference As String
C#
public string DataSourceReference {get; set;}

Property Value

A System.String value indicating the full or relative path to the data source reference.

Remarks

Relative paths are based on the location of the report.

Example

C# Copy Code
var dataSource = new DataSource();
dataSource.DataSourceReference = "path/to/your/datasource";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Name Property

Glossary Item Box

Gets or sets a name of the data source.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the data source.

Remarks

Each data source must have a unique name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


Transaction Property

[image]
ActiveReports 19 .NET Edition
Transaction Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Transaction Property

Glossary Item Box

Gets or sets a value indicating whether the data source should execute its datasets within a single transaction.

Syntax

Visual Basic (Declaration)
Public Property Transaction As Boolean
C#
public bool Transaction {get; set;}

Property Value

A System.Boolean value. true if the data source executes within a single transaction; otherwise, false. Default is false.

Example

C# Copy Code
var dataSource = new DataSource();
dataSource.Transaction = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSourceCollection Class

[image]
ActiveReports 19 .NET Edition
DataSourceCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class

Glossary Item Box

Represents a strongly typed collection of DataSource objects.

Object Model

DataSourceCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSourceCollection
   Inherits System.Collections.ObjectModel.Collection(Of DataSource)
C#
public sealed class DataSourceCollection : System.Collections.ObjectModel.Collection<DataSource>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataSourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourceCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class

Glossary Item Box

The following tables list the members exposed by DataSourceCollection.

Public Constructors

 | Name | Description
Public Constructor | DataSourceCollection Constructor |
Top

See Also

Reference

DataSourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourceCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataSourceCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : DataSourceCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSourceCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


DataSourcePrompt Class

[image]
ActiveReports 19 .NET Edition
DataSourcePrompt Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class

Glossary Item Box

Represents a request for credentials to connect to a data source.

Object Model

DataSourcePrompt Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSourcePrompt
C#
public sealed class DataSourcePrompt

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSourcePrompt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcePrompt Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourcePrompt Class Members

[image]
ActiveReports 19 .NET Edition
DataSourcePrompt Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class

Glossary Item Box

The following tables list the members exposed by DataSourcePrompt.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the data source for which credentials are required.
Public Property | Password | Gets or sets the password for the credentials.
Public Property | Prompt | Gets the prompt message shown when credentials need to be entered.
Public Property | User | Gets or sets the user name for the credentials.
Top

See Also

Reference

DataSourcePrompt Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourcePrompt Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourcePrompt Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class

Glossary Item Box

For a list of all members of this type, see DataSourcePrompt members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the data source for which credentials are required.
Public Property | Password | Gets or sets the password for the credentials.
Public Property | Prompt | Gets the prompt message shown when credentials need to be entered.
Public Property | User | Gets or sets the user name for the credentials.
Top

See Also

Reference

DataSourcePrompt Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Name Property

Glossary Item Box

Gets the name of the data source for which credentials are required.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A System.String value indicating the name of the data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Password Property

Glossary Item Box

Gets or sets the password for the credentials.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Property Value

A System.String value indicating the password for the credentials.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Prompt Property

Glossary Item Box

Gets the prompt message shown when credentials need to be entered.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prompt As String
C#
public string Prompt {get;}

Property Value

A System.String value indicating the prompt message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


User Property

[image]
ActiveReports 19 .NET Edition
User Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : User Property

Glossary Item Box

Gets or sets the user name for the credentials.

Syntax

Visual Basic (Declaration)
Public Property User As String
C#
public string User {get; set;}

Property Value

A System.String value indicating the user name for the credentials.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


DataValue Class

[image]
ActiveReports 19 .NET Edition
DataValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

Glossary Item Box

Represents a data value element that defines a collection of data values for a single data point in a chart or custom report item.

Object Model

DataValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataValue
   Implements IValidateable
C#
public sealed class DataValue : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataValue Class Members

[image]
ActiveReports 19 .NET Edition
DataValue Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

Glossary Item Box

The following tables list the members exposed by DataValue.

Public Constructors

 | Name | Description
Public Constructor | DataValue Constructor | Initializes a new instance of the DataValue class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name expression for the data value.
Public Property | Value | Gets or sets the value expression for the data point.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataValue Constructor

[image]
ActiveReports 19 .NET Edition
DataValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : DataValue Constructor

Glossary Item Box

Initializes a new instance of the DataValue class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


DataValue Class Methods

[image]
ActiveReports 19 .NET Edition
DataValue Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

Glossary Item Box

For a list of all members of this type, see DataValue members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ReportItem object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


DataValue Class Properties

[image]
ActiveReports 19 .NET Edition
DataValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

Glossary Item Box

For a list of all members of this type, see DataValue members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name expression for the data value.
Public Property | Value | Gets or sets the value expression for the data point.
Top

See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Name Property

Glossary Item Box

Gets or sets a name expression for the data value.

Syntax

Visual Basic (Declaration)
Public Property Name As ExpressionInfo
C#
public ExpressionInfo Name {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the name expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Value Property

Glossary Item Box

Gets or sets the value expression for the data point.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the value expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


DataValueCollection Class

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

Glossary Item Box

Represents a strongly typed collection of DataValue objects.

Object Model

DataValueCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataValueCollection
   Inherits System.Collections.ObjectModel.Collection(Of DataValue)
C#
public sealed class DataValueCollection : System.Collections.ObjectModel.Collection<DataValue>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.DataValueCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataValueCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

Glossary Item Box

The following tables list the members exposed by DataValueCollection.

Public Constructors

 | Name | Description
Public Constructor | DataValueCollection Constructor | Initializes a new instance of the DataValueCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of DataValue objects to the existing DataValueCollection.
Top

See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataValueCollection Constructor

[image]
ActiveReports 19 .NET Edition
DataValueCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : DataValueCollection Constructor

Glossary Item Box

Initializes a new instance of the DataValueCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataValueCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Class
DataValueCollection Members


DataValueCollection Class Methods

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

Glossary Item Box

For a list of all members of this type, see DataValueCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of DataValue objects to the existing DataValueCollection.
Top

See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : AddRange Method

collection
A collection of the DataValue objects to add.

Glossary Item Box

Adds a collection of DataValue objects to the existing DataValueCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of DataValue) _
)
C#
public void AddRange(
   IEnumerable<DataValue> collection
)

Parameters

collection
A collection of the DataValue objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Class
DataValueCollection Members


DefaultValue Class

[image]
ActiveReports 19 .NET Edition
DefaultValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

Glossary Item Box

Represents the default value for a report parameter.

Object Model

DefaultValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DefaultValue
   Implements IValidateable
C#
public sealed class DefaultValue : IValidateable

Remarks

The DefaultValue class must have one and only one of the following properties set: Values or DataSetReference.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultValue Class Members

[image]
ActiveReports 19 .NET Edition
DefaultValue Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

Glossary Item Box

The following tables list the members exposed by DefaultValue.

Public Constructors

 | Name | Description
Public Constructor | DefaultValue Constructor | Initializes a new instance of the DefaultValue class.
Top

Public Properties

 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | Values | Gets the default values for the parameter.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the DefaultValue object.
Top

See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultValue Constructor

[image]
ActiveReports 19 .NET Edition
DefaultValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : DefaultValue Constructor

Glossary Item Box

Initializes a new instance of the DefaultValue class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DefaultValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Class
DefaultValue Members


DefaultValue Class Methods

[image]
ActiveReports 19 .NET Edition
DefaultValue Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

Glossary Item Box

For a list of all members of this type, see DefaultValue members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the DefaultValue object.
Top

See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As DefaultValue
C#
public DefaultValue Clone()

Return Value

A new DefaultValue object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Class
DefaultValue Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DefaultValue object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Class
DefaultValue Members


DefaultValue Class Properties

[image]
ActiveReports 19 .NET Edition
DefaultValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

Glossary Item Box

For a list of all members of this type, see DefaultValue members.

Public Properties

 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | Values | Gets the default values for the parameter.
Top

See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Property

[image]
ActiveReports 19 .NET Edition
DataSetReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : DataSetReference Property

Glossary Item Box

Gets or sets the query to execute to obtain the default value(s) for the parameter.

Syntax

Visual Basic (Declaration)
Public Property DataSetReference As DataSetReference
C#
public DataSetReference DataSetReference {get; set;}

Property Value

A DataSetReference object representing the query to execute to obtain the default value(s) for the parameter.

Remarks

If this property is set, the query specified by the DataSetReference is executed to obtain the default value(s). If this property is not set, the first value of the ValueField is used as the default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Class
DefaultValue Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : Values Property

Glossary Item Box

Gets the default values for the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> Values {get;}

Property Value

An ExpressionInfoCollection object containing the default values for the parameter.

Remarks

This property is used to directly specify the default values for the parameter when DataSetReference is not set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultValue Class
DefaultValue Members


DesignerSerializationProvider Class

[image]
ActiveReports 19 .NET Edition
DesignerSerializationProvider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DesignerSerializationProvider Class

Glossary Item Box

Represents a class that enables access to a serializer.

Object Model

DesignerSerializationProvider Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DesignerSerializationProvider
   Implements IComponentSerializationProvider
C#
public sealed class DesignerSerializationProvider : IComponentSerializationProvider

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DesignerSerializationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSerializationProvider Members
GrapeCity.ActiveReports.PageReportModel Namespace


DesignerSerializationProvider Class Members

[image]
ActiveReports 19 .NET Edition
DesignerSerializationProvider Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DesignerSerializationProvider Class

Glossary Item Box

The following tables list the members exposed by DesignerSerializationProvider.

Public Constructors

 | Name | Description
Public Constructor | DesignerSerializationProvider Constructor | Overloaded.
Top

See Also

Reference

DesignerSerializationProvider Class
GrapeCity.ActiveReports.PageReportModel Namespace


DesignerSerializationProvider Constructor

[image]
ActiveReports 19 .NET Edition
DesignerSerializationProvider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DesignerSerializationProvider Class : DesignerSerializationProvider Constructor

Glossary Item Box

Overload List

Overload | Description
DesignerSerializationProvider Constructor() | Initializes a new instance of the GrapeCity.ActiveReports.Rdl.ExpressionBaseTypeAttribute class.
DesignerSerializationProvider Constructor(Func<Report>) | Initializes a new instance of the GrapeCity.ActiveReports.Rdl.ExpressionBaseTypeAttribute class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSerializationProvider Class
DesignerSerializationProvider Members


DesignerSerializationProvider Constructor()

[image]
ActiveReports 19 .NET Edition
DesignerSerializationProvider Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DesignerSerializationProvider Class > DesignerSerializationProvider Constructor : DesignerSerializationProvider Constructor()

Glossary Item Box

Initializes a new instance of the GrapeCity.ActiveReports.Rdl.ExpressionBaseTypeAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DesignerSerializationProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSerializationProvider Class
DesignerSerializationProvider Members
Overload List


DesignerSerializationProvider Constructor(Func<Report>)

[image]
ActiveReports 19 .NET Edition
DesignerSerializationProvider Constructor(Func<Report>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DesignerSerializationProvider Class > DesignerSerializationProvider Constructor : DesignerSerializationProvider Constructor(Func<Report>)

report
A function for getting a report.

Glossary Item Box

Initializes a new instance of the GrapeCity.ActiveReports.Rdl.ExpressionBaseTypeAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Func(Of Report) _
)
C#
public DesignerSerializationProvider(
   Func<Report> report
)

Parameters

report
A function for getting a report.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if report is null.

Remarks

Allows initialization with the specified GrapeCity.ActiveReports.IReportComponentFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSerializationProvider Class
DesignerSerializationProvider Members
Overload List


Details Class

[image]
ActiveReports 19 .NET Edition
Details Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

Glossary Item Box

Represents the detail rows for a table, where grouping, sorting and visibility can be configured.

Object Model

Details Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Details
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class Details : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

The Details row repeats for each bound data set record that passed through the data set filters and data region filters.

If a table has the grouping configured, then the details row appears between the Header and Footer of the enclosing group instance.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.Details

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Members
GrapeCity.ActiveReports.PageReportModel Namespace


Details Class Members

[image]
ActiveReports 19 .NET Edition
Details Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

Glossary Item Box

The following tables list the members exposed by Details.

Public Constructors

 | Name | Description
Public Constructor | Details Constructor | Initializes a new instance of the Details class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the detail data.
Public Property | KeepTogether | Gets or sets a value indicating whether the details is kept together on a single page where possible.
Public Property | Sorting | Gets the expressions by which to sort the detail data.
Public Property | TableRows | Gets a collection of the detail rows for the table.
Public Property | Visibility | Gets or sets a value indicating whether the details is hidden.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Details object.
Top

See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Details Constructor

[image]
ActiveReports 19 .NET Edition
Details Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Details Constructor

Glossary Item Box

Initializes a new instance of the Details class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Details()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Details Class Methods

[image]
ActiveReports 19 .NET Edition
Details Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

Glossary Item Box

For a list of all members of this type, see Details members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Details object.
Top

See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Details object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Details Class Properties

[image]
ActiveReports 19 .NET Edition
Details Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

Glossary Item Box

For a list of all members of this type, see Details members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the detail data.
Public Property | KeepTogether | Gets or sets a value indicating whether the details is kept together on a single page where possible.
Public Property | Sorting | Gets the expressions by which to sort the detail data.
Public Property | TableRows | Gets a collection of the detail rows for the table.
Public Property | Visibility | Gets or sets a value indicating whether the details is hidden.
Top

See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the detail data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the detail data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : KeepTogether Property

Glossary Item Box

Gets or sets a value indicating whether the details is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A System.Boolean value where true if the details is kept together on a single page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the detail data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the detail data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


TableRows Property

[image]
ActiveReports 19 .NET Edition
TableRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : TableRows Property

Glossary Item Box

Gets a collection of the detail rows for the table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableRows As TableRowCollection
C#
public TableRowCollection TableRows {get;}

Property Value

A TableRowCollection object containing the detail rows.

Remarks

The detail rows cannot contain any DataRegions in any of their TableCells.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the details is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the details.

Example

C# Copy Code
Details details = new Details();
details.Visibility = new Visibility { Hidden = ExpressionInfo.FromString("true") };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Details Class
Details Members


DocumentMap Class

[image]
ActiveReports 19 .NET Edition
DocumentMap Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

Glossary Item Box

Represents the settings of a document map.

Object Model

DocumentMap Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DocumentMap
C#
public sealed class DocumentMap

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DocumentMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Members
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap Class Members

[image]
ActiveReports 19 .NET Edition
DocumentMap Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

Glossary Item Box

The following tables list the members exposed by DocumentMap.

Public Constructors

 | Name | Description
Public Constructor | DocumentMap Constructor | Initializes a new instance of the DocumentMap class.
Top

Public Properties

 | Name | Description
Public Property | Levels | Gets a collection of document map levels.
Public Property | NumberingStyle | Gets or sets the default numbering style for headings in the document map.
Public Property | Source | Gets or sets a source of the document map.
Top

Public Methods

 | Name | Description
Public Method | IsDefault | Gets a value indicating whether the document map has default settings.
Top

See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap Constructor

[image]
ActiveReports 19 .NET Edition
DocumentMap Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : DocumentMap Constructor

Glossary Item Box

Initializes a new instance of the DocumentMap class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentMap()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMap Class Methods

[image]
ActiveReports 19 .NET Edition
DocumentMap Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

Glossary Item Box

For a list of all members of this type, see DocumentMap members.

Public Methods

 | Name | Description
Public Method | IsDefault | Gets a value indicating whether the document map has default settings.
Top

See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsDefault Method

[image]
ActiveReports 19 .NET Edition
IsDefault Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : IsDefault Method

Glossary Item Box

Gets a value indicating whether the document map has default settings.

Syntax

Visual Basic (Declaration)
Public Function IsDefault() As Boolean
C#
public bool IsDefault()

Return Value

A System.Boolean value indicating whether the document map is using default settings.

Example

C# Copy Code
DocumentMap docMap = new DocumentMap();
bool isDefault = docMap.IsDefault();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMap Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentMap Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

Glossary Item Box

For a list of all members of this type, see DocumentMap members.

Public Properties

 | Name | Description
Public Property | Levels | Gets a collection of document map levels.
Public Property | NumberingStyle | Gets or sets the default numbering style for headings in the document map.
Public Property | Source | Gets or sets a source of the document map.
Top

See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


Levels Property

[image]
ActiveReports 19 .NET Edition
Levels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : Levels Property

Glossary Item Box

Gets a collection of document map levels.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Levels As List(Of DocumentMapLevel)
C#
public List<DocumentMapLevel> Levels {get;}

Property Value

A collection od the DocumentMapLevel objects containing the levels in the document map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Class
DocumentMap Members


NumberingStyle Property

[image]
ActiveReports 19 .NET Edition
NumberingStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : NumberingStyle Property

Glossary Item Box

Gets or sets the default numbering style for headings in the document map.

Syntax

Visual Basic (Declaration)
Public Property NumberingStyle As NumberingStyle
C#
public NumberingStyle NumberingStyle {get; set;}

Property Value

A NumberingStyle value indicating the default numbering style for headings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Class
DocumentMap Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : Source Property

Glossary Item Box

Gets or sets a source of the document map.

Syntax

Visual Basic (Declaration)
Public Property Source As DocumentMapSource
C#
public DocumentMapSource Source {get; set;}

Property Value

A DocumentMapSource value indicating the source of the document map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMap.Defaults Class

[image]
ActiveReports 19 .NET Edition
DocumentMap.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap.Defaults Class

Glossary Item Box

Represents the default values for document map settings.

Object Model

DocumentMap.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DocumentMap.Defaults
C#
public static class DocumentMap.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DocumentMap.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
DocumentMap.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap.Defaults Class

Glossary Item Box

The following tables list the members exposed by DocumentMap.Defaults.

Public Fields

 | Name | Description
Public Field | LabelsNumberingStyle | The default numbering style for labels.
Public Field | NumberingStyle | The default numbering style for headings.
Public Field | Source | The default source for the document map.
Top

See Also

Reference

DocumentMap.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
DocumentMap.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap.Defaults Class

Glossary Item Box

For a list of all members of this type, see DocumentMap.Defaults members.

Public Fields

 | Name | Description
Public Field | LabelsNumberingStyle | The default numbering style for labels.
Public Field | NumberingStyle | The default numbering style for headings.
Public Field | Source | The default source for the document map.
Top

See Also

Reference

DocumentMap.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelsNumberingStyle Field

[image]
ActiveReports 19 .NET Edition
LabelsNumberingStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap.Defaults Class : LabelsNumberingStyle Field

Glossary Item Box

The default numbering style for labels.

Syntax

Visual Basic (Declaration)
Public Const LabelsNumberingStyle As NumberingStyle
C#
public const NumberingStyle LabelsNumberingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap.Defaults Class
DocumentMap.Defaults Members


NumberingStyle Field

[image]
ActiveReports 19 .NET Edition
NumberingStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap.Defaults Class : NumberingStyle Field

Glossary Item Box

The default numbering style for headings.

Syntax

Visual Basic (Declaration)
Public Const NumberingStyle As NumberingStyle
C#
public const NumberingStyle NumberingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap.Defaults Class
DocumentMap.Defaults Members


Source Field

[image]
ActiveReports 19 .NET Edition
Source Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap.Defaults Class : Source Field

Glossary Item Box

The default source for the document map.

Syntax

Visual Basic (Declaration)
Public Const Source As DocumentMapSource
C#
public const DocumentMapSource Source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMap.Defaults Class
DocumentMap.Defaults Members


DocumentMapLevel Class

[image]
ActiveReports 19 .NET Edition
DocumentMapLevel Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class

Glossary Item Box

Represents the properties of a document map level.

Object Model

DocumentMapLevel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DocumentMapLevel
C#
public sealed class DocumentMapLevel

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DocumentMapLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapLevel Members
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapLevel Class Members

[image]
ActiveReports 19 .NET Edition
DocumentMapLevel Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class

Glossary Item Box

The following tables list the members exposed by DocumentMapLevel.

Public Constructors

 | Name | Description
Public Constructor | DocumentMapLevel Constructor | Initializes a new instance of the DocumentMapLevel class.
Top

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the numbering style for the document map level.
Top

See Also

Reference

DocumentMapLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapLevel Constructor

[image]
ActiveReports 19 .NET Edition
DocumentMapLevel Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMapLevel Class : DocumentMapLevel Constructor

Glossary Item Box

Initializes a new instance of the DocumentMapLevel class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentMapLevel()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapLevel Class
DocumentMapLevel Members


DocumentMapLevel Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentMapLevel Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class

Glossary Item Box

For a list of all members of this type, see DocumentMapLevel members.

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the numbering style for the document map level.
Top

See Also

Reference

DocumentMapLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


NumberingStyle Property

[image]
ActiveReports 19 .NET Edition
NumberingStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMapLevel Class : NumberingStyle Property

Glossary Item Box

Gets or sets the numbering style for the document map level.

Syntax

Visual Basic (Declaration)
Public Property NumberingStyle As NumberingStyle
C#
public NumberingStyle NumberingStyle {get; set;}

Property Value

A NumberingStyle value indicating the numbering style for the document map level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapLevel Class
DocumentMapLevel Members


Drillthrough Class

[image]
ActiveReports 19 .NET Edition
Drillthrough Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

Glossary Item Box

Represents an element that defines a Drillthrough action associated with an Action.

Object Model

Drillthrough Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Drillthrough
   Implements IValidateable
C#
public sealed class Drillthrough : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Drillthrough

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Drillthrough Members
GrapeCity.ActiveReports.PageReportModel Namespace


Drillthrough Class Members

[image]
ActiveReports 19 .NET Edition
Drillthrough Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

Glossary Item Box

The following tables list the members exposed by Drillthrough.

Public Constructors

 | Name | Description
Public Constructor | Drillthrough Constructor | Initializes a new instance of the Drillthrough class.
Top

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameters to pass to the drillthrough report.
Public Property | ReportName | Gets or sets a System.String value representing the path of the drillthrough report.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Drillthrough object.
Top

See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Drillthrough Constructor

[image]
ActiveReports 19 .NET Edition
Drillthrough Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Drillthrough Constructor

Glossary Item Box

Initializes a new instance of the Drillthrough class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Drillthrough()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Drillthrough Class
Drillthrough Members


Drillthrough Class Methods

[image]
ActiveReports 19 .NET Edition
Drillthrough Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

Glossary Item Box

For a list of all members of this type, see Drillthrough members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Drillthrough object.
Top

See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Drillthrough object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Drillthrough Class
Drillthrough Members


Drillthrough Class Properties

[image]
ActiveReports 19 .NET Edition
Drillthrough Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

Glossary Item Box

For a list of all members of this type, see Drillthrough members.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameters to pass to the drillthrough report.
Public Property | ReportName | Gets or sets a System.String value representing the path of the drillthrough report.
Top

See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Parameters Property

Glossary Item Box

Gets the parameters to pass to the drillthrough report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Property Value

A ParameterCollection object containing the parameters to pass to the drillthrough report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Drillthrough Class
Drillthrough Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : ReportName Property

Glossary Item Box

Gets or sets a System.String value representing the path of the drillthrough report.

Syntax

Visual Basic (Declaration)
Public Property ReportName As ExpressionInfo
C#
public ExpressionInfo ReportName {get; set;}

Property Value

A System.String value representing the path to the drillthrough report.

Remarks

The path may be absolute (i.e. "/orderentry/processedorders") or relative (i.e. "processedorders").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Drillthrough Class
Drillthrough Members


DynamicCategoriesSeries Class

[image]
ActiveReports 19 .NET Edition
DynamicCategoriesSeries Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

Glossary Item Box

Defines a Series level that repeats with each Series group in the rowset of the chart.

Object Model

DynamicCategoriesSeries Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DynamicCategoriesSeries
   Implements IValidateable
C#
public sealed class DynamicCategoriesSeries : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DynamicCategoriesSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Members
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategoriesSeries Class Members

[image]
ActiveReports 19 .NET Edition
DynamicCategoriesSeries Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

Glossary Item Box

The following tables list the members exposed by DynamicCategoriesSeries.

Public Constructors

 | Name | Description
Public Constructor | DynamicCategoriesSeries Constructor | Initializes a new instance of the DynamicCategoriesSeries class.
Top

Public Properties

 | Name | Description
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Label | Gets the label displayed on the legend.
Public Property | Sorting | Gets the expression by which to sort the columns or data.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DynamicCategoriesSeries object.
Top

See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategoriesSeries Constructor

[image]
ActiveReports 19 .NET Edition
DynamicCategoriesSeries Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : DynamicCategoriesSeries Constructor

Glossary Item Box

Initializes a new instance of the DynamicCategoriesSeries class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DynamicCategoriesSeries()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicCategoriesSeries Class Methods

[image]
ActiveReports 19 .NET Edition
DynamicCategoriesSeries Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

Glossary Item Box

For a list of all members of this type, see DynamicCategoriesSeries members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the DynamicCategoriesSeries object.
Top

See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the DynamicCategoriesSeries object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicCategoriesSeries Class Properties

[image]
ActiveReports 19 .NET Edition
DynamicCategoriesSeries Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

Glossary Item Box

For a list of all members of this type, see DynamicCategoriesSeries members.

Public Properties

 | Name | Description
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Label | Gets the label displayed on the legend.
Public Property | Sorting | Gets the expression by which to sort the columns or data.
Top

See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Remarks

Page breaks in the grouping are not allowed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Label Property

Glossary Item Box

Gets the label displayed on the legend.

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object indicating the label displayed on the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Sorting Property

Glossary Item Box

Gets the expression by which to sort the columns or data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expression by which to sort the columns or data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicColumnsRows Class

[image]
ActiveReports 19 .NET Edition
DynamicColumnsRows Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

Glossary Item Box

Represents a column or row header region that repeats with each column or row group in the rowset of a Matrix.

Object Model

DynamicColumnsRows Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DynamicColumnsRows
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class DynamicColumnsRows : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.DynamicColumnsRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Members
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicColumnsRows Class Members

[image]
ActiveReports 19 .NET Edition
DynamicColumnsRows Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

Glossary Item Box

The following tables list the members exposed by DynamicColumnsRows.

Public Constructors

 | Name | Description
Public Constructor | DynamicColumnsRows Constructor | Initializes a new instance of the DynamicColumnsRows class.
Top

Public Properties

 | Name | Description
Public Property | Components | Overridden. Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Sorting | Gets the expressions by which to sort the columns or rows.
Public Property | Subtotal | Gets or sets an automatic subtotal for the column or row.
Public Property | Visibility | Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DynamicColumnsRows object.
Top

See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicColumnsRows Constructor

[image]
ActiveReports 19 .NET Edition
DynamicColumnsRows Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : DynamicColumnsRows Constructor

Glossary Item Box

Initializes a new instance of the DynamicColumnsRows class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DynamicColumnsRows()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


DynamicColumnsRows Class Methods

[image]
ActiveReports 19 .NET Edition
DynamicColumnsRows Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

Glossary Item Box

For a list of all members of this type, see DynamicColumnsRows members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the DynamicColumnsRows object.
Top

See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the DynamicColumnsRows object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


DynamicColumnsRows Class Properties

[image]
ActiveReports 19 .NET Edition
DynamicColumnsRows Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

Glossary Item Box

For a list of all members of this type, see DynamicColumnsRows members.

Public Properties

 | Name | Description
Public Property | Components | Overridden. Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Sorting | Gets the expressions by which to sort the columns or rows.
Public Property | Subtotal | Gets or sets an automatic subtotal for the column or row.
Public Property | Visibility | Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.
Top

See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Components As ReportComponentCollection
C#
public override ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the columns or rows.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expression by which to sort the columns or rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Subtotal Property

[image]
ActiveReports 19 .NET Edition
Subtotal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Subtotal Property

Glossary Item Box

Gets or sets an automatic subtotal for the column or row.

Syntax

Visual Basic (Declaration)
Public Property Subtotal As Subtotal
C#
public Subtotal Subtotal {get; set;}

Property Value

A Subtotal object containing an automatic subtotal for the column or row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the dynamic columns or rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


EmbeddedImage Class

[image]
ActiveReports 19 .NET Edition
EmbeddedImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

Glossary Item Box

Represents an image embedded within the report definition.

Object Model

EmbeddedImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EmbeddedImage
   Implements IValidateable
C#
public sealed class EmbeddedImage : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.EmbeddedImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImage Class Members

[image]
ActiveReports 19 .NET Edition
EmbeddedImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

Glossary Item Box

The following tables list the members exposed by EmbeddedImage.

Public Constructors

 | Name | Description
Public Constructor | EmbeddedImage Constructor | Initializes a new instance of the EmbeddedImage class.
Top

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets a Base-64 encoded data of the image.
Public Property | MIMEType | Gets or sets a MIME type of the embedded image.
Public Property | Name | Gets or sets a name of the embedded image.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the EmbeddedImage object.
Top

See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImage Constructor

[image]
ActiveReports 19 .NET Edition
EmbeddedImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : EmbeddedImage Constructor

Glossary Item Box

Initializes a new instance of the EmbeddedImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EmbeddedImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImage Class Methods

[image]
ActiveReports 19 .NET Edition
EmbeddedImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

Glossary Item Box

For a list of all members of this type, see EmbeddedImage members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the EmbeddedImage object.
Top

See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the EmbeddedImage object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImage Class Properties

[image]
ActiveReports 19 .NET Edition
EmbeddedImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

Glossary Item Box

For a list of all members of this type, see EmbeddedImage members.

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets a Base-64 encoded data of the image.
Public Property | MIMEType | Gets or sets a MIME type of the embedded image.
Public Property | Name | Gets or sets a name of the embedded image.
Top

See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ImageData Property

[image]
ActiveReports 19 .NET Edition
ImageData Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : ImageData Property

Glossary Item Box

Gets or sets a Base-64 encoded data of the image.

Syntax

Visual Basic (Declaration)
Public Property ImageData As String
C#
public string ImageData {get; set;}

Property Value

A System.String value containing the Base-64 encoded image data.

Example

C# Copy Code
var embeddedImage = new EmbeddedImage
{
    ImageData = "iVBORw0KGgoAAAANSUhEUgAAA..."
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : MIMEType Property

Glossary Item Box

Gets or sets a MIME type of the embedded image.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As String
C#
public string MIMEType {get; set;}

Property Value

A System.String value indicating the MIME type of the image.

Remarks

Valid MIME types include: image/bmp, image/jpeg, image/gif, image/png, image/x-png, and image/svg+xml.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : Name Property

Glossary Item Box

Gets or sets a name of the embedded image.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImageCollection Class

[image]
ActiveReports 19 .NET Edition
EmbeddedImageCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class

Glossary Item Box

Represents a strongly typed collection of EmbeddedImage objects.

Object Model

EmbeddedImageCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EmbeddedImageCollection
   Inherits System.Collections.ObjectModel.Collection(Of EmbeddedImage)
C#
public sealed class EmbeddedImageCollection : System.Collections.ObjectModel.Collection<EmbeddedImage>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.EmbeddedImageCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImageCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImageCollection Class Members

[image]
ActiveReports 19 .NET Edition
EmbeddedImageCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class

Glossary Item Box

The following tables list the members exposed by EmbeddedImageCollection.

Public Constructors

 | Name | Description
Public Constructor | EmbeddedImageCollection Constructor |
Top

See Also

Reference

EmbeddedImageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImageCollection Constructor

[image]
ActiveReports 19 .NET Edition
EmbeddedImageCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : EmbeddedImageCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EmbeddedImageCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


EmbeddedStyleSheet Class

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

Glossary Item Box

Represents information about a stylesheet that is embedded within the report definition.

Object Model

EmbeddedStyleSheet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EmbeddedStyleSheet
   Implements IValidateable
C#
public sealed class EmbeddedStyleSheet : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.EmbeddedStyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedStyleSheet Class Members

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

Glossary Item Box

The following tables list the members exposed by EmbeddedStyleSheet.

Public Constructors

 | Name | Description
Public Constructor | EmbeddedStyleSheet Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets or sets a data of the embedded stylesheet in XML format.
Public Property | Name | Gets or sets a name of the embedded stylesheet.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the EmbeddedStyleSheet object.
Top

See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedStyleSheet Constructor

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : EmbeddedStyleSheet Constructor

Glossary Item Box

Overload List

Overload | Description
EmbeddedStyleSheet Constructor(String,StyleSheet) | Initializes a new instance of the EmbeddedStyleSheet class using a specified name and stylesheet.
EmbeddedStyleSheet Constructor() | Initializes a new instance of the EmbeddedStyleSheet class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


EmbeddedStyleSheet Constructor(String,StyleSheet)

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Constructor(String,StyleSheet)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class > EmbeddedStyleSheet Constructor : EmbeddedStyleSheet Constructor(String,StyleSheet)

name
A System.String value indicating the name of the embedded stylesheet.
styleSheet
A StyleSheet object containing the stylesheet data.

Glossary Item Box

Initializes a new instance of the EmbeddedStyleSheet class using a specified name and stylesheet.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal styleSheet As StyleSheet _
)
C#
public EmbeddedStyleSheet(
   string name,
   StyleSheet styleSheet
)

Parameters

name
A System.String value indicating the name of the embedded stylesheet.
styleSheet
A StyleSheet object containing the stylesheet data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members
Overload List


EmbeddedStyleSheet Constructor()

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class > EmbeddedStyleSheet Constructor : EmbeddedStyleSheet Constructor()

Glossary Item Box

Initializes a new instance of the EmbeddedStyleSheet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EmbeddedStyleSheet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members
Overload List


EmbeddedStyleSheet Class Methods

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

Glossary Item Box

For a list of all members of this type, see EmbeddedStyleSheet members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the EmbeddedStyleSheet object.
Top

See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the EmbeddedStyleSheet object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


EmbeddedStyleSheet Class Properties

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

Glossary Item Box

For a list of all members of this type, see EmbeddedStyleSheet members.

Public Properties

 | Name | Description
Public Property | Data | Gets or sets a data of the embedded stylesheet in XML format.
Public Property | Name | Gets or sets a name of the embedded stylesheet.
Top

See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Data Property

Glossary Item Box

Gets or sets a data of the embedded stylesheet in XML format.

Syntax

Visual Basic (Declaration)
Public Property Data As String
C#
public string Data {get; set;}

Property Value

A System.String value containing the XML data of the embedded stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Name Property

Glossary Item Box

Gets or sets a name of the embedded stylesheet.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the embedded stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


ExpressionInfoCollection Class

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollection Class

Glossary Item Box

Implements a strongly typed collection for GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.

Object Model

ExpressionInfoCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionInfoCollection
   Inherits System.Collections.ObjectModel.Collection(Of ExpressionInfo)
C#
public sealed class ExpressionInfoCollection : System.Collections.ObjectModel.Collection<ExpressionInfo>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ExpressionInfoCollection Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollection Class

Glossary Item Box

The following tables list the members exposed by ExpressionInfoCollection.

Public Constructors

 | Name | Description
Public Constructor | ExpressionInfoCollection Constructor | Initializes a new instance of the ExpressionInfoCollection class.
Top

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets a value indicating whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfoCollection is read-only.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds the expressions sequence to the end of the collection.
Top

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top

See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ExpressionInfoCollection Constructor

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollection Class : ExpressionInfoCollection Constructor

Glossary Item Box

Initializes a new instance of the ExpressionInfoCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExpressionInfoCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfoCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds the expressions sequence to the end of the collection.
Top

See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollection Class : AddRange Method

expressions
The expressions.

Glossary Item Box

Adds the expressions sequence to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal expressions As IEnumerable(Of ExpressionInfo) _
)
C#
public void AddRange(
   IEnumerable<ExpressionInfo> expressions
)

Parameters

expressions
The expressions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfoCollection members.

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets a value indicating whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfoCollection is read-only.
Top

See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollection Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfoCollection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if the GrapeCity.Enterprise.Data.Expressions.ExpressionInfoCollection is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Events

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfoCollection members.

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top

See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemAdded Event

[image]
ActiveReports 19 .NET Edition
ItemAdded Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollection Class : ItemAdded Event

Glossary Item Box

Occurs immediately after adding an item to the collection.

Syntax

Visual Basic (Declaration)
Public Event ItemAdded As ExpressionInfoCollectionEventHandler
C#
public event ExpressionInfoCollectionEventHandler ItemAdded

Event Data

The event handler receives an argument of type ExpressionInfoCollectionEventArgs containing data related to this event. The following ExpressionInfoCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns the Integer for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Value | Returns the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ItemRemoved Event

[image]
ActiveReports 19 .NET Edition
ItemRemoved Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollection Class : ItemRemoved Event

Glossary Item Box

Occurs immediately after removing an item from the collection.

Syntax

Visual Basic (Declaration)
Public Event ItemRemoved As ExpressionInfoCollectionEventHandler
C#
public event ExpressionInfoCollectionEventHandler ItemRemoved

Event Data

The event handler receives an argument of type ExpressionInfoCollectionEventArgs containing data related to this event. The following ExpressionInfoCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns the Integer for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Value | Returns the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollectionEventArgs Class

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollectionEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollectionEventArgs Class

Glossary Item Box

Provides data for the ExpressionInfoCollection.ItemAdded or ExpressionInfoCollection.ItemRemoved event of the ExpressionInfoCollection.

Object Model

ExpressionInfoCollectionEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionInfoCollectionEventArgs
   Inherits System.EventArgs
C#
public sealed class ExpressionInfoCollectionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.ExpressionInfoCollectionEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollectionEventArgs Members
GrapeCity.ActiveReports.PageReportModel Namespace


ExpressionInfoCollectionEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollectionEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollectionEventArgs Class

Glossary Item Box

The following tables list the members exposed by ExpressionInfoCollectionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ExpressionInfoCollectionEventArgs Constructor | Initializes a new instance of ExpressionInfoCollectionEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Index | Returns the Integer for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Public Property | Value | Returns the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Top

See Also

Reference

ExpressionInfoCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


ExpressionInfoCollectionEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollectionEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollectionEventArgs Class : ExpressionInfoCollectionEventArgs Constructor

index
The index of object that was added or removed.
value
The object that was added or removed.

Glossary Item Box

Initializes a new instance of ExpressionInfoCollectionEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal index As Integer, _
   ByVal value As ExpressionInfo _
)
C#
public ExpressionInfoCollectionEventArgs(
   int index,
   ExpressionInfo value
)

Parameters

index
The index of object that was added or removed.
value
The object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


ExpressionInfoCollectionEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollectionEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollectionEventArgs Class

Glossary Item Box

For a list of all members of this type, see ExpressionInfoCollectionEventArgs members.

Public Properties

 | Name | Description
Public Property | Index | Returns the Integer for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Public Property | Value | Returns the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.
Top

See Also

Reference

ExpressionInfoCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollectionEventArgs Class : Index Property

Glossary Item Box

Returns the Integer for the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
C#
public int Index {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ExpressionInfoCollectionEventArgs Class : Value Property

Glossary Item Box

Returns the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that was added or removed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


Field Class

[image]
ActiveReports 19 .NET Edition
Field Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

Glossary Item Box

Represents a Field element of a DataSet, containing information about a field within the data model of the report.

Object Model

Field Class

Syntax

Visual Basic (Declaration)
Public Class Field
   Implements IValidateable
C#
public class Field : IValidateable

Remarks

A Field must have either a DataField or Value property set, but not both.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Field

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Members
GrapeCity.ActiveReports.PageReportModel Namespace


Field Class Members

[image]
ActiveReports 19 .NET Edition
Field Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

Glossary Item Box

The following tables list the members exposed by Field.

Public Constructors

 | Name | Description
Public Constructor | Field Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DataField | Gets or sets the name of the field in the query.
Public Property | Name | Gets or sets the name to use for the field within the report. Gets or sets the name to use for the field within the report.
Public Property | Value | Gets or sets an expression that evaluates to the value of the field. Gets or sets an expression that evaluates to the value of the field.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


Field Constructor

[image]
ActiveReports 19 .NET Edition
Field Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Field Constructor

Glossary Item Box

Overload List

Overload | Description
Field Constructor() | Initializes a new instance of the Field class.
Field Constructor(String,String,ExpressionInfo) | Initializes a new instance of the Field class using a specified name, data field, and value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Constructor()

[image]
ActiveReports 19 .NET Edition
Field Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class > Field Constructor : Field Constructor()

Glossary Item Box

Initializes a new instance of the Field class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Field()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members
Overload List


Field Constructor(String,String,ExpressionInfo)

[image]
ActiveReports 19 .NET Edition
Field Constructor(String,String,ExpressionInfo)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class > Field Constructor : Field Constructor(String,String,ExpressionInfo)

name
A System.String value indicating the name to use for the field.
dataField
A System.String value indicating the data field to use.
value
A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value of the field.

Glossary Item Box

Initializes a new instance of the Field class using a specified name, data field, and value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dataField As String, _
   ByVal value As ExpressionInfo _
)
C#
public Field(
   string name,
   string dataField,
   ExpressionInfo value
)

Parameters

name
A System.String value indicating the name to use for the field.
dataField
A System.String value indicating the data field to use.
value
A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members
Overload List


Field Class Methods

[image]
ActiveReports 19 .NET Edition
Field Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Field object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Properties

[image]
ActiveReports 19 .NET Edition
Field Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Properties

 | Name | Description
Public Property | DataField | Gets or sets the name of the field in the query.
Public Property | Name | Gets or sets the name to use for the field within the report. Gets or sets the name to use for the field within the report.
Public Property | Value | Gets or sets an expression that evaluates to the value of the field. Gets or sets an expression that evaluates to the value of the field.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataField Property

[image]
ActiveReports 19 .NET Edition
DataField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : DataField Property

Glossary Item Box

Gets or sets the name of the field in the query.

Syntax

Visual Basic (Declaration)
Public Property DataField As String
C#
public string DataField {get; set;}

Property Value

A System.String value indicating the name of the field in the query.

Remarks

Data field names do not need to be unique. Multiple fields can refer to the same data field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Name Property

Glossary Item Box

Gets or sets the name to use for the field within the report.

Gets or sets the name to use for the field within the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A String containing the name to use for the field within a report.

A System.String containing the name to use for the field within a report.

Remarks

Field names need only be unique within the containing Fields collection.

Field names need only be unique within the containing Fields collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Value Property

Glossary Item Box

Gets or sets an expression that evaluates to the value of the field.

Gets or sets an expression that evaluates to the value of the field.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object containing the expression that evaluates to the value of the field.

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the expression that evaluates to the value of the field.

Remarks

For example: =Fields!Quantity.Value+Fields!UnitPrice.Value

The expression cannot contain aggregates or references to report items.

Expressions are fully described in the Expressions namespace.

For example: =Fields!Quantity.Value + Fields!UnitPrice.Value

The expression cannot contain aggregates or references to report items.

Expressions are fully described in the Expressions namespace.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


FieldCollection Class

[image]
ActiveReports 19 .NET Edition
FieldCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class

Glossary Item Box

Represents a strongly typed collection of Field objects.

Object Model

FieldCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FieldCollection
   Inherits System.Collections.ObjectModel.Collection(Of Field)
C#
public sealed class FieldCollection : System.Collections.ObjectModel.Collection<Field>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.FieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


FieldCollection Class Members

[image]
ActiveReports 19 .NET Edition
FieldCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class

Glossary Item Box

The following tables list the members exposed by FieldCollection.

Public Constructors

 | Name | Description
Public Constructor | FieldCollection Constructor |
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


FieldCollection Constructor

[image]
ActiveReports 19 .NET Edition
FieldCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : FieldCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FieldCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Filter Class

[image]
ActiveReports 19 .NET Edition
Filter Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

Glossary Item Box

Represents a Filter element of a DataSet, describing a filter to apply to rows of data in a dataset or data region, or to apply to the group instances.

Object Model

Filter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Filter
   Implements IValidateable
C#
public sealed class Filter : IValidateable

Remarks

Filters are used to selectively include or exclude data rows or group instances based on specified criteria.

Example

C# Copy Code
Filter filter = new Filter { Operator = FilterOperator.Equal, FilterExpression = "Germany", FilterValues = { "=Fields!Country.Value" } }

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Filter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Members
GrapeCity.ActiveReports.PageReportModel Namespace


Filter Class Members

[image]
ActiveReports 19 .NET Edition
Filter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

Glossary Item Box

The following tables list the members exposed by Filter.

Public Constructors

 | Name | Description
Public Constructor | Filter Constructor | Initializes a new instance of the Filter class.
Top

Public Properties

 | Name | Description
Public Property | FilterExpression | Gets or sets an expression that will be evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.
Public Property | FilterValues | Gets the values to compare to the FilterExpression.
Public Property | Operator | Gets or sets an operator used when comparing the FilterExpression to the FilterValues.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Filter object.
Top

See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Filter Constructor

[image]
ActiveReports 19 .NET Edition
Filter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Filter Constructor

Glossary Item Box

Initializes a new instance of the Filter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Filter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Class
Filter Members


Filter Class Methods

[image]
ActiveReports 19 .NET Edition
Filter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

Glossary Item Box

For a list of all members of this type, see Filter members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Filter object.
Top

See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Filter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Class
Filter Members


Filter Class Properties

[image]
ActiveReports 19 .NET Edition
Filter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

Glossary Item Box

For a list of all members of this type, see Filter members.

Public Properties

 | Name | Description
Public Property | FilterExpression | Gets or sets an expression that will be evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.
Public Property | FilterValues | Gets the values to compare to the FilterExpression.
Public Property | Operator | Gets or sets an operator used when comparing the FilterExpression to the FilterValues.
Top

See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


FilterExpression Property

[image]
ActiveReports 19 .NET Edition
FilterExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : FilterExpression Property

Glossary Item Box

Gets or sets an expression that will be evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.

Syntax

Visual Basic (Declaration)
Public Property FilterExpression As ExpressionInfo
C#
public ExpressionInfo FilterExpression {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that is evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.

Remarks

Failed comparisons result in the row or instance being filtered out of the dataset, data region, or grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Class
Filter Members


FilterValues Property

[image]
ActiveReports 19 .NET Edition
FilterValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : FilterValues Property

Glossary Item Box

Gets the values to compare to the FilterExpression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterValues As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> FilterValues {get;}

Property Value

An IList object containing the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo values to compare to the FilterExpression.

Remarks

For Equal, Like, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan, LessThanOrEqual, TopN, BottomN, TopPercent and BottomPercent, there must be exactly one FilterValues.

For TopN and BottomN, the FilterValues expression must evaluate to an integer.

For TopPercent and BottomPercent, the FilterValues expression must evaluate to an integer or a float.

For TopN, BottomN, TopPercent and BottomPercent, the FilterValue expression is evaluated only once: for the first row (after all earlier filters have been applied) in the case of a dataset or data region; a filter for the first group instance (after all earlier filters have been applied) in the case of a group filter.

For Between, there must be exactly two FilterValues.

For In, the FilterValues are treated as a set (if the FilterExpression value appears anywhere in the set of FilterValues, the instance is not filtered out).

Like uses the same special characters as the Visual Basic LIKE operator (e.g. "?" to represent a single character and "*" to represent any series of characters).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Class
Filter Members


Operator Property

[image]
ActiveReports 19 .NET Edition
Operator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Operator Property

Glossary Item Box

Gets or sets an operator used when comparing the FilterExpression to the FilterValues.

Syntax

Visual Basic (Declaration)
Public Property Operator As FilterOperator
C#
public FilterOperator Operator {get; set;}

Property Value

A FilterOperator value indicating the operator used when comparing the FilterExpression to the FilterValues.

Remarks

Top and Bottom operators include ties in the resulting data.

String comparisons are locale-dependent.

Null equals Null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Filter Class
Filter Members


FixedPage Class

[image]
ActiveReports 19 .NET Edition
FixedPage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FixedPage Class

Glossary Item Box

Represents a data region in a report layout that repeats with each grouping or detail row (if no grouping is defined), consisting of a collection of the Pages that containing one or more defined fixed layout pages used to render fixed pages with possible overflow.

Object Model

FixedPage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FixedPage
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class FixedPage : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.FixedPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Members
GrapeCity.ActiveReports.PageReportModel Namespace


FixedPage Class Members

[image]
ActiveReports 19 .NET Edition
FixedPage Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FixedPage Class

Glossary Item Box

The following tables list the members exposed by FixedPage.

Public Constructors

 | Name | Description
Public Constructor | FixedPage Constructor | Initializes a new instance of the FixedPage class.
Top

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Pages | Gets a collection of fixed layout pages that compose the FixedPage layout.
Public Property | ReportItems | Gets all report items from all pages within the fixed page.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | Sorting | Gets the expressions by which to sort the data.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the FixedPage object.
Top

See Also

Reference

FixedPage Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedPage Constructor

[image]
ActiveReports 19 .NET Edition
FixedPage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : FixedPage Constructor

Glossary Item Box

Initializes a new instance of the FixedPage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FixedPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


FixedPage Class Methods

[image]
ActiveReports 19 .NET Edition
FixedPage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FixedPage Class

Glossary Item Box

For a list of all members of this type, see FixedPage members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the FixedPage object.
Top

See Also

Reference

FixedPage Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the FixedPage object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


FixedPage Class Properties

[image]
ActiveReports 19 .NET Edition
FixedPage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FixedPage Class

Glossary Item Box

For a list of all members of this type, see FixedPage members.

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Pages | Gets a collection of fixed layout pages that compose the FixedPage layout.
Public Property | ReportItems | Gets all report items from all pages within the fixed page.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | Sorting | Gets the expressions by which to sort the data.
Top

See Also

Reference

FixedPage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : Pages Property

Glossary Item Box

Gets a collection of fixed layout pages that compose the FixedPage layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PageCollection
C#
public PageCollection Pages {get;}

Property Value

A PageCollection object containing the fixed layout pages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : ReportItems Property

Glossary Item Box

Gets all report items from all pages within the fixed page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As IEnumerable(Of ReportItem)
C#
public IEnumerable<ReportItem> ReportItems {get;}

Property Value

A collection of ReportItem objects representing all report items from all pages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FixedPage Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FixedPage Class
FixedPage Members


Footer Class

[image]
ActiveReports 19 .NET Edition
Footer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

Glossary Item Box

Represents a footer component of a table or group, containing rows that appear at the end of a group or table.

Object Model

Footer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Footer
   Inherits HeaderFooter
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Footer : HeaderFooter, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Footer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Members
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Class Members

[image]
ActiveReports 19 .NET Edition
Footer Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

Glossary Item Box

The following tables list the members exposed by Footer.

Public Constructors

 | Name | Description
Public Constructor | Footer Constructor | Initializes a new instance of the Footer class.
Top

Public Properties

 | Name | Description
Public Property | PrintAtBottom | Gets or sets a value indicating whether the footer rows are pushed to the bottom of the table or group by empty rows.
Top

See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Constructor

[image]
ActiveReports 19 .NET Edition
Footer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Footer Constructor

Glossary Item Box

Initializes a new instance of the Footer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Footer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Class
Footer Members


Footer Class Properties

[image]
ActiveReports 19 .NET Edition
Footer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

Glossary Item Box

For a list of all members of this type, see Footer members.

Public Properties

 | Name | Description
Public Property | PrintAtBottom | Gets or sets a value indicating whether the footer rows are pushed to the bottom of the table or group by empty rows.
Top

See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value indicating whether the footer rows are pushed to the bottom of the table or group by empty rows.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A System.Boolean value where true indicates that the footer rows are pushed to the bottom by empty rows; otherwise, false. Default value is false.

Remarks

This property is allowed only with the TableGroup.Footer property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Footer Class
Footer Members


Grid Class

[image]
ActiveReports 19 .NET Edition
Grid Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grid Class

Glossary Item Box

Represents a component containing information about the alignment of report items on the grid.

Object Model

Grid Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Grid
   Inherits ReportComponent
   Implements IReportComponent
C#
public sealed class Grid : ReportComponent, IReportComponent

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.Grid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grid Members
GrapeCity.ActiveReports.PageReportModel Namespace


Grid Class Members

[image]
ActiveReports 19 .NET Edition
Grid Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grid Class

Glossary Item Box

The following tables list the members exposed by Grid.

Public Constructors

 | Name | Description
Public Constructor | Grid Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cells | Gets the cells of the grid.
Public Property | Columns | Gets the columns of the grid.
Public Property | Rows | Gets the rows of the grid.
Top

See Also

Reference

Grid Class
GrapeCity.ActiveReports.PageReportModel Namespace


Grid Constructor

[image]
ActiveReports 19 .NET Edition
Grid Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grid Class : Grid Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Grid()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grid Class
Grid Members


Grid Class Properties

[image]
ActiveReports 19 .NET Edition
Grid Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grid Class

Glossary Item Box

For a list of all members of this type, see Grid members.

Public Properties

 | Name | Description
Public Property | Cells | Gets the cells of the grid.
Public Property | Columns | Gets the columns of the grid.
Public Property | Rows | Gets the rows of the grid.
Top

See Also

Reference

Grid Class
GrapeCity.ActiveReports.PageReportModel Namespace


Cells Property

[image]
ActiveReports 19 .NET Edition
Cells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grid Class : Cells Property

Glossary Item Box

Gets the cells of the grid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridCell)
C#
public IList<GridCell> Cells {get;}

Property Value

A list of GridCell objects representing the cells of the grid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grid Class
Grid Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grid Class : Columns Property

Glossary Item Box

Gets the columns of the grid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As IList(Of GridColumn)
C#
public IList<GridColumn> Columns {get;}

Property Value

A list of GridColumn objects representing the columns of the grid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grid Class
Grid Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grid Class : Rows Property

Glossary Item Box

Gets the rows of the grid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of GridRow)
C#
public IList<GridRow> Rows {get;}

Property Value

A list of GridRow objects representing the rows of the grid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grid Class
Grid Members


GridCell Class

[image]
ActiveReports 19 .NET Edition
GridCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridCell Class

Glossary Item Box

Represents a cell in the Grid.

Object Model

GridCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridCell
   Inherits ReportComponent
   Implements IReportComponent
C#
public sealed class GridCell : ReportComponent, IReportComponent

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.GridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


GridCell Class Members

[image]
ActiveReports 19 .NET Edition
GridCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridCell Class

Glossary Item Box

The following tables list the members exposed by GridCell.

Public Constructors

 | Name | Description
Public Constructor | GridCell Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColSpan | Gets or sets a number of columns the cell spans.
Public Property | ColumnIndex | Gets or sets an index of the column the cell is in.
Public Property | ReportItemName | Gets or sets a name of the report item contained in the cell.
Public Property | RowIndex | Gets or sets an index of the row the cell is in.
Public Property | RowSpan | Gets or sets a number of rows the cell spans.
Top

See Also

Reference

GridCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


GridCell Constructor

[image]
ActiveReports 19 .NET Edition
GridCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : GridCell Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


GridCell Class Properties

[image]
ActiveReports 19 .NET Edition
GridCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridCell Class

Glossary Item Box

For a list of all members of this type, see GridCell members.

Public Properties

 | Name | Description
Public Property | ColSpan | Gets or sets a number of columns the cell spans.
Public Property | ColumnIndex | Gets or sets an index of the column the cell is in.
Public Property | ReportItemName | Gets or sets a name of the report item contained in the cell.
Public Property | RowIndex | Gets or sets an index of the row the cell is in.
Public Property | RowSpan | Gets or sets a number of rows the cell spans.
Top

See Also

Reference

GridCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColSpan Property

[image]
ActiveReports 19 .NET Edition
ColSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : ColSpan Property

Glossary Item Box

Gets or sets a number of columns the cell spans.

Syntax

Visual Basic (Declaration)
Public Property ColSpan As Integer
C#
public int ColSpan {get; set;}

Property Value

An System.Int32 value indicating the number of columns the cell spans. Default is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


ColumnIndex Property

[image]
ActiveReports 19 .NET Edition
ColumnIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : ColumnIndex Property

Glossary Item Box

Gets or sets an index of the column the cell is in.

Syntax

Visual Basic (Declaration)
Public Property ColumnIndex As Integer
C#
public int ColumnIndex {get; set;}

Property Value

An System.Int32 value indicating the index of the column the cell is in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


ReportItemName Property

[image]
ActiveReports 19 .NET Edition
ReportItemName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : ReportItemName Property

Glossary Item Box

Gets or sets a name of the report item contained in the cell.

Syntax

Visual Basic (Declaration)
Public Property ReportItemName As String
C#
public string ReportItemName {get; set;}

Property Value

A System.String value indicating the name of the report item contained in the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


RowIndex Property

[image]
ActiveReports 19 .NET Edition
RowIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : RowIndex Property

Glossary Item Box

Gets or sets an index of the row the cell is in.

Syntax

Visual Basic (Declaration)
Public Property RowIndex As Integer
C#
public int RowIndex {get; set;}

Property Value

An System.Int32 value indicating the index of the row the cell is in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridCell Class : RowSpan Property

Glossary Item Box

Gets or sets a number of rows the cell spans.

Syntax

Visual Basic (Declaration)
Public Property RowSpan As Integer
C#
public int RowSpan {get; set;}

Property Value

An System.Int32 value indicating the number of rows the cell spans. Default is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridCell Class
GridCell Members


GridColumn Class

[image]
ActiveReports 19 .NET Edition
GridColumn Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridColumn Class

Glossary Item Box

Represents a column in the Grid.

Object Model

GridColumn Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridColumn
   Inherits ReportComponent
   Implements IReportComponent
C#
public sealed class GridColumn : ReportComponent, IReportComponent

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.GridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


GridColumn Class Members

[image]
ActiveReports 19 .NET Edition
GridColumn Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridColumn Class

Glossary Item Box

The following tables list the members exposed by GridColumn.

Public Constructors

 | Name | Description
Public Constructor | GridColumn Constructor |
Top

Public Properties

 | Name | Description
Public Property | Index | Gets or sets an index of the column.
Public Property | Width | Gets or sets a width of the column.
Top

See Also

Reference

GridColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


GridColumn Constructor

[image]
ActiveReports 19 .NET Edition
GridColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridColumn Class : GridColumn Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridColumn()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


GridColumn Class Properties

[image]
ActiveReports 19 .NET Edition
GridColumn Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridColumn Class

Glossary Item Box

For a list of all members of this type, see GridColumn members.

Public Properties

 | Name | Description
Public Property | Index | Gets or sets an index of the column.
Public Property | Width | Gets or sets a width of the column.
Top

See Also

Reference

GridColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridColumn Class : Index Property

Glossary Item Box

Gets or sets an index of the column.

Syntax

Visual Basic (Declaration)
Public Property Index As Integer
C#
public int Index {get; set;}

Property Value

An System.Int32 value indicating the index of the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridColumn Class : Width Property

Glossary Item Box

Gets or sets a width of the column.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


GridLines Class

[image]
ActiveReports 19 .NET Edition
GridLines Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

Glossary Item Box

Defines the style properties for the major and minor gridlines along an axis in a chart.

Object Model

GridLines Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridLines
   Implements IValidateable
C#
public sealed class GridLines : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.GridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Members
GrapeCity.ActiveReports.PageReportModel Namespace


GridLines Class Members

[image]
ActiveReports 19 .NET Edition
GridLines Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

Glossary Item Box

The following tables list the members exposed by GridLines.

Public Constructors

 | Name | Description
Public Constructor | GridLines Constructor | Initializes a new instance of the GridLines class.
Top

Public Properties

 | Name | Description
Public Property | ShowGridLines | Gets or sets a value indicating whether the gridlines are shown.
Public Property | Style | Gets or sets the line style properties for the gridlines and tickmarks.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the GridLines object.
Top

See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


GridLines Constructor

[image]
ActiveReports 19 .NET Edition
GridLines Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : GridLines Constructor

Glossary Item Box

Initializes a new instance of the GridLines class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridLines()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


GridLines Class Methods

[image]
ActiveReports 19 .NET Edition
GridLines Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

Glossary Item Box

For a list of all members of this type, see GridLines members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the GridLines object.
Top

See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : Validate Method

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the GridLines object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


GridLines Class Properties

[image]
ActiveReports 19 .NET Edition
GridLines Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

Glossary Item Box

For a list of all members of this type, see GridLines members.

Public Properties

 | Name | Description
Public Property | ShowGridLines | Gets or sets a value indicating whether the gridlines are shown.
Public Property | Style | Gets or sets the line style properties for the gridlines and tickmarks.
Top

See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


ShowGridLines Property

[image]
ActiveReports 19 .NET Edition
ShowGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : ShowGridLines Property

Glossary Item Box

Gets or sets a value indicating whether the gridlines are shown.

Syntax

Visual Basic (Declaration)
Public Property ShowGridLines As Boolean
C#
public bool ShowGridLines {get; set;}

Property Value

A Boolean value where true indicates that the gridlines are shown; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : Style Property

Glossary Item Box

Gets or sets the line style properties for the gridlines and tickmarks.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the line style properties for the gridlines and tickmarks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridLines Class
GridLines Members


GridRow Class

[image]
ActiveReports 19 .NET Edition
GridRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridRow Class

Glossary Item Box

Represents a row in the Grid.

Object Model

GridRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GridRow
   Inherits ReportComponent
   Implements IReportComponent
C#
public sealed class GridRow : ReportComponent, IReportComponent

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.GridRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


GridRow Class Members

[image]
ActiveReports 19 .NET Edition
GridRow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridRow Class

Glossary Item Box

The following tables list the members exposed by GridRow.

Public Constructors

 | Name | Description
Public Constructor | GridRow Constructor |
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets a height of the row.
Public Property | Index | Gets or sets an index of the row.
Top

See Also

Reference

GridRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


GridRow Constructor

[image]
ActiveReports 19 .NET Edition
GridRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridRow Class : GridRow Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GridRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridRow Class
GridRow Members


GridRow Class Properties

[image]
ActiveReports 19 .NET Edition
GridRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridRow Class

Glossary Item Box

For a list of all members of this type, see GridRow members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets a height of the row.
Public Property | Index | Gets or sets an index of the row.
Top

See Also

Reference

GridRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridRow Class : Height Property

Glossary Item Box

Gets or sets a height of the row.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridRow Class
GridRow Members


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridRow Class : Index Property

Glossary Item Box

Gets or sets an index of the row.

Syntax

Visual Basic (Declaration)
Public Property Index As Integer
C#
public int Index {get; set;}

Property Value

An System.Int32 value indicating the index of the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridRow Class
GridRow Members


Grouping Class

[image]
ActiveReports 19 .NET Edition
Grouping Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

Glossary Item Box

Represents an element that defines the expressions by which to group the data.

Object Model

Grouping Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Grouping
   Implements IValidateable
C#
public sealed class Grouping : IValidateable

Example

An example of creating a simple grouping:
C# Copy Code
var grouping = new Grouping { Name = "TypeGroup", GroupExpressions = { "=Fields!Type.Value" } };

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Grouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Class Members

[image]
ActiveReports 19 .NET Edition
Grouping Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

Glossary Item Box

The following tables list the members exposed by Grouping.

Public Constructors

 | Name | Description
Public Constructor | Grouping Constructor | Initializes a new instance of the Grouping class.
Top

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets an information to be passed to the report output component.
Public Property | DataCollectionName | Gets or sets a name to use for the data element for the collection of all instances of this group.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DomainScope | Gets or sets a domain scope for grouping.
Public Property | Filters | Gets the filters to apply to each instance of the group.
Public Property | GroupExpressions | Gets a set of expressions by which to group the data.
Public Property | Label | Gets or sets a label to identify an instance of the group within the client UI, providing a user-friendly label for searching.
Public Property | Name | Gets or sets a name of the grouping.
Public Property | NewSection | Gets or sets a value indicating whether the grouping is in its own section.
Public Property | PageBreak | Gets or sets the page break options.
Public Property | PageName | Gets or sets a page name for grouping.
Public Property | Parent | Gets or sets an expression that identifies the parent group in a recursive hierarchy.
Public Property | PrintFooterAtBottom | Gets or sets a value indicating that these rows should be printed at the bottom of the group.
Public Property | Variables | Gets a collection of the variables for grouping.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Grouping object.
Top

See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Constructor

[image]
ActiveReports 19 .NET Edition
Grouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Grouping Constructor

Glossary Item Box

Initializes a new instance of the Grouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Grouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Grouping Class Methods

[image]
ActiveReports 19 .NET Edition
Grouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

Glossary Item Box

For a list of all members of this type, see Grouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Grouping object.
Top

See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Grouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Grouping Class Properties

[image]
ActiveReports 19 .NET Edition
Grouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

Glossary Item Box

For a list of all members of this type, see Grouping members.

Public Properties

 | Name | Description
Public Property | Custom | Gets or sets an information to be passed to the report output component.
Public Property | DataCollectionName | Gets or sets a name to use for the data element for the collection of all instances of this group.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DomainScope | Gets or sets a domain scope for grouping.
Public Property | Filters | Gets the filters to apply to each instance of the group.
Public Property | GroupExpressions | Gets a set of expressions by which to group the data.
Public Property | Label | Gets or sets a label to identify an instance of the group within the client UI, providing a user-friendly label for searching.
Public Property | Name | Gets or sets a name of the grouping.
Public Property | NewSection | Gets or sets a value indicating whether the grouping is in its own section.
Public Property | PageBreak | Gets or sets the page break options.
Public Property | PageName | Gets or sets a page name for grouping.
Public Property | Parent | Gets or sets an expression that identifies the parent group in a recursive hierarchy.
Public Property | PrintFooterAtBottom | Gets or sets a value indicating that these rows should be printed at the bottom of the group.
Public Property | Variables | Gets a collection of the variables for grouping.
Top

See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Property

[image]
ActiveReports 19 .NET Edition
Custom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Custom Property

Glossary Item Box

Gets or sets an information to be passed to the report output component.

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Property Value

A Custom object containing the information to be passed to the report output component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


DataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DataCollectionName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataCollectionName Property

Glossary Item Box

Gets or sets a name to use for the data element for the collection of all instances of this group.

Syntax

Visual Basic (Declaration)
Public Property DataCollectionName As String
C#
public string DataCollectionName {get; set;}

Property Value

A System.String value indicating the name to use for the data element for the collection of all instances of this group.

Remarks

Default value is "DataElementName_Collection".

Example

C# Copy Code
Grouping group = new Grouping();
group.DataCollectionName = "CategoryGroup_Collection";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the instances of this group.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for instances of this group.

Remarks

Default value is the name of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the group appears in the output.

NoOutput indicates that the group does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


DomainScope Property

[image]
ActiveReports 19 .NET Edition
DomainScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DomainScope Property

Glossary Item Box

Gets or sets a domain scope for grouping.

Syntax

Visual Basic (Declaration)
Public Property DomainScope As String
C#
public string DomainScope {get; set;}

Property Value

A System.String value indicating the domain scope for grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Filters Property

Glossary Item Box

Gets the filters to apply to each instance of the group.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter)
C#
public IList<Filter> Filters {get;}

Property Value

A collection of the Filter objects to apply to each instance of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


GroupExpressions Property

[image]
ActiveReports 19 .NET Edition
GroupExpressions Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : GroupExpressions Property

Glossary Item Box

Gets a set of expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupExpressions As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> GroupExpressions {get;}

Property Value

An ExpressionInfoCollection object by which to group the data.

Example

C# Copy Code
Grouping group = new Grouping();
group.GroupExpressions.Add(ExpressionInfo.FromString("=Fields!Category.Value"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Label Property

Glossary Item Box

Gets or sets a label to identify an instance of the group within the client UI, providing a user-friendly label for searching.

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing label to identify an instance of the group within the client UI.

Example

C# Copy Code
Grouping group = new Grouping();
group.Label = ExpressionInfo.FromString("GroupLabel");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Name Property

Glossary Item Box

Gets or sets a name of the grouping.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the grouping.

Remarks

This property is used for RunningValue and RowNumber aggregate functions.

No two grouping elements may have the same name and no grouping element may have the same name as a dataset or a data region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : NewSection Property

Glossary Item Box

Gets or sets a value indicating whether the grouping is in its own section.

Syntax

Visual Basic (Declaration)
Public Property NewSection As Boolean
C#
public bool NewSection {get; set;}

Property Value

A System.Boolean value where true if the grouping is in its own section; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageBreak Property

Glossary Item Box

Gets or sets the page break options.

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
C#
public PageBreak PageBreak {get; set;}

Property Value

A PageBreak object representing the page break options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageName Property

Glossary Item Box

Gets or sets a page name for grouping.

Syntax

Visual Basic (Declaration)
Public Property PageName As ExpressionInfo
C#
public ExpressionInfo PageName {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the page name for grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Parent Property

Glossary Item Box

Gets or sets an expression that identifies the parent group in a recursive hierarchy.

Syntax

Visual Basic (Declaration)
Public Property Parent As ExpressionInfo
C#
public ExpressionInfo Parent {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the parent group in a recursive hierarchy.

Remarks

This property only applies if the group has exactly one group expression

Indicates the following:

  1. Groups are sorted according to the recursive hierarchy (sort is still used to sort peer groups).
  2. Labels (in the document map) are indented according to the recursive hierarchy.
  3. Intra-group show/hide toggles items according to the recursive hierarchy (see ToggleItem).

If filters on the group eliminate the parent of a group instance, it is instead treated as a child of the parent's parent.

Example

C# Copy Code
Grouping group = new Grouping();
group.Parent = ExpressionInfo.FromString("=Fields!ParentCategory.Value");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


PrintFooterAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintFooterAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PrintFooterAtBottom Property

Glossary Item Box

Gets or sets a value indicating that these rows should be printed at the bottom of the group.

Syntax

Visual Basic (Declaration)
Public Property PrintFooterAtBottom As Boolean
C#
public bool PrintFooterAtBottom {get; set;}

Property Value

A System.Boolean value where true if the rows should be printed at the bottom of the group; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Variables Property

[image]
ActiveReports 19 .NET Edition
Variables Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Variables Property

Glossary Item Box

Gets a collection of the variables for grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Variables As List(Of Variable)
C#
public List<Variable> Variables {get;}

Property Value

A collection of the Variable objects for grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Grouping Class
Grouping Members


Header Class

[image]
ActiveReports 19 .NET Edition
Header Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

Glossary Item Box

Represents a header component of a table or group, containing rows that appear at the beginning of a group or table.

Object Model

Header Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Header
   Inherits HeaderFooter
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Header : HeaderFooter, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Header

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Members
GrapeCity.ActiveReports.PageReportModel Namespace


Header Class Members

[image]
ActiveReports 19 .NET Edition
Header Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

Glossary Item Box

The following tables list the members exposed by Header.

Public Constructors

 | Name | Description
Public Constructor | Header Constructor | Initializes a new instance of the Header class.
Top

Public Properties

 | Name | Description
Public Property | FixedHeader | Gets or sets a value indicating whether the header remains visible on the page when the user scrolls part of the table off the page.
Top

See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


Header Constructor

[image]
ActiveReports 19 .NET Edition
Header Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Header Constructor

Glossary Item Box

Initializes a new instance of the Header class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Header()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Class
Header Members


Header Class Properties

[image]
ActiveReports 19 .NET Edition
Header Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

Glossary Item Box

For a list of all members of this type, see Header members.

Public Properties

 | Name | Description
Public Property | FixedHeader | Gets or sets a value indicating whether the header remains visible on the page when the user scrolls part of the table off the page.
Top

See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedHeader Property

[image]
ActiveReports 19 .NET Edition
FixedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : FixedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header remains visible on the page when the user scrolls part of the table off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedHeader As Boolean
C#
public bool FixedHeader {get; set;}

Property Value

A System.Boolean value where true indicates that the header remains visible when scrolling; otherwise, false. Default value is false.

Remarks

Fixed headers must be contiguous and must include the first or last column in the table. This property is allowed only with the Table.Header property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Header Class
Header Members


HeaderFooter Class

[image]
ActiveReports 19 .NET Edition
HeaderFooter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

Glossary Item Box

Represents a base class for header or footer component of a table or group, containing rows.

Object Model

HeaderFooter Class

Syntax

Visual Basic (Declaration)
Public Class HeaderFooter
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public class HeaderFooter : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Footer
GrapeCity.ActiveReports.PageReportModel.Header

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HeaderFooter Members
GrapeCity.ActiveReports.PageReportModel Namespace


HeaderFooter Class Members

[image]
ActiveReports 19 .NET Edition
HeaderFooter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

Glossary Item Box

The following tables list the members exposed by HeaderFooter.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header should be displayed on each page on which the table or group is displayed.
Public Property | TableRows | Gets the footer or header rows for the table or group.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the HeaderFooter object.
Top

See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


HeaderFooter Class Methods

[image]
ActiveReports 19 .NET Edition
HeaderFooter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

Glossary Item Box

For a list of all members of this type, see HeaderFooter members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the HeaderFooter object.
Top

See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the HeaderFooter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HeaderFooter Class
HeaderFooter Members


HeaderFooter Class Properties

[image]
ActiveReports 19 .NET Edition
HeaderFooter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

Glossary Item Box

For a list of all members of this type, see HeaderFooter members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header should be displayed on each page on which the table or group is displayed.
Public Property | TableRows | Gets the footer or header rows for the table or group.
Top

See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HeaderFooter Class
HeaderFooter Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : RepeatOnNewPage Property

Glossary Item Box

Gets or sets a value indicating whether the footer or header should be displayed on each page on which the table or group is displayed.

Syntax

Visual Basic (Declaration)
Public Property RepeatOnNewPage As Boolean
C#
public bool RepeatOnNewPage {get; set;}

Property Value

A System.Boolean value where true indicating that the footer or header should be displayed on each page on which the table or group is displayed; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HeaderFooter Class
HeaderFooter Members


TableRows Property

[image]
ActiveReports 19 .NET Edition
TableRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : TableRows Property

Glossary Item Box

Gets the footer or header rows for the table or group.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableRows As TableRowCollection
C#
public TableRowCollection TableRows {get;}

Property Value

A TableRowCollection object containing the footer or header rows for the table or group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HeaderFooter Class
HeaderFooter Members


Image Class

[image]
ActiveReports 19 .NET Edition
Image Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

Glossary Item Box

Represents an image ReportItem within the report definition.

Object Model

Image Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Image
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class Image : ReportItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Members
GrapeCity.ActiveReports.PageReportModel Namespace


Image Class Members

[image]
ActiveReports 19 .NET Edition
Image Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

Glossary Item Box

The following tables list the members exposed by Image.

Public Constructors

 | Name | Description
Public Constructor | Image Constructor | Initializes a new instance of the Image class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets a description of the control used by accessibility client applications.
Public Property | HorizontalAlignment | Gets or sets a horizontal alignment of the picture inside the image report item.
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Sizing | Gets or sets a value indicating how the image is rendered if it does not fit within the defined size.
Public Property | Source | Gets or sets a source of the image.
Public Property | Value | Gets or sets the value of the image.
Public Property | VerticalAlignment | Gets or sets a vertical alignment of the picture inside the image report item.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Image object.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


Image Constructor

[image]
ActiveReports 19 .NET Edition
Image Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Image Constructor

Glossary Item Box

Initializes a new instance of the Image class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Image()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Image Class Methods

[image]
ActiveReports 19 .NET Edition
Image Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Image object.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Image object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Image Class Properties

[image]
ActiveReports 19 .NET Edition
Image Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets a description of the control used by accessibility client applications.
Public Property | HorizontalAlignment | Gets or sets a horizontal alignment of the picture inside the image report item.
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Sizing | Gets or sets a value indicating how the image is rendered if it does not fit within the defined size.
Public Property | Source | Gets or sets a source of the image.
Public Property | Value | Gets or sets the value of the image.
Public Property | VerticalAlignment | Gets or sets a vertical alignment of the picture inside the image report item.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : AccessibleDescription Property

Glossary Item Box

Gets or sets a description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the accessible description of the image.

Example

C# Copy Code
Image image = new Image();
image.AccessibleDescription = "Image of a product.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


HorizontalAlignment Property

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : HorizontalAlignment Property

Glossary Item Box

Gets or sets a horizontal alignment of the picture inside the image report item.

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlignment As ExpressionInfo
C#
public ExpressionInfo HorizontalAlignment {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the horizontal alignment of the image. The default value is HorizontalAlignment.Left

Example

C# Copy Code
Image image = new Image();
image.HorizontalAlignment = ExpressionInfo.FromString("Right");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : MIMEType Property

Glossary Item Box

Gets or sets the MIME type of the image.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As ExpressionInfo
C#
public ExpressionInfo MIMEType {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the MIME type of the image.

Remarks

Valid values are image/bmp, image/jpeg, image/gif, image/png, image/emf, image/wmf, image/x-emf, image/x-wmf, and image/svg+xml. This property is required if the source is set to Database, but ignored otherwise.

Example

C# Copy Code
Image image = new Image();
image.Source = ImageSource.Database;
image.Value = ExpressionInfo.FromString("BinaryData");
image.MIMEType = ExpressionInfo.FromString("image/png");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Sizing Property

[image]
ActiveReports 19 .NET Edition
Sizing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Sizing Property

Glossary Item Box

Gets or sets a value indicating how the image is rendered if it does not fit within the defined size.

Syntax

Visual Basic (Declaration)
Public Property Sizing As ImageSizing
C#
public ImageSizing Sizing {get; set;}

Property Value

An ImageSizing value indicating how the image is rendered if it does not fit within the defined size.

Remarks

If Sizing is set to ImageSizing.AutoSize, the control's borders grow or shrink to match the size of the image.

If Sizing is set to ImageSizing.Fit, the image is resized to match the height and width of the control.

If Sizing is set to ImageSizing.FitProportional, the image is resized while preserving the aspect ratio to match either the height or width of the control or both.

If Sizing is set to ImageSizing.Clip, the image is clipped to fit inside the borders of the control.

Report output formats which do not support ImageSizing.FitProportional or ImageSizing.Clip should use ImageSizing.Fit instead.

Example

C# Copy Code
Image image = new Image();
image.Sizing = ImageSizing.Fit;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Source Property

Glossary Item Box

Gets or sets a source of the image.

Syntax

Visual Basic (Declaration)
Public Property Source As ImageSource
C#
public ImageSource Source {get; set;}

Property Value

An ImageSource value indicating the source of the image.

Remarks

If the source is set to ImageSource.External, the Value property evaluates to the location of the image.

If the source is set to ImageSource.Embedded, the Value property evaluates to the name of the EmbeddedImage in the report.

If the source is set to ImageSource.Database, the Value property evaluates to the binary data of the image.

Example

C# Copy Code
Image image = new Image();
image.Source = ImageSource.External;
image.Value = ExpressionInfo.FromString("http://example.com/image.jpg");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Value Property

Glossary Item Box

Gets or sets the value of the image.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the value of the image.

Remarks

The value depends on the Source property setting.

If Source is set to ImageSource.External, the value is the URL or file path of the image.

If Source is set to ImageSource.Embedded, the value is the name of the EmbeddedImage in the report.

If Source is set to ImageSource.Database, the value is the binary data of the image.

Example

C# Copy Code
Image image = new Image();
image.Source = ImageSource.Embedded;
image.Value = ExpressionInfo.FromString("LogoImage");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : VerticalAlignment Property

Glossary Item Box

Gets or sets a vertical alignment of the picture inside the image report item.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As ExpressionInfo
C#
public ExpressionInfo VerticalAlignment {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the vertical alignment of the image. The default value is VerticalAlign.Top

Example

C# Copy Code
Image image = new Image();
image.VerticalAlignment = ExpressionInfo.FromString("Middle");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


InvalidBooleanExpressionException Class

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : InvalidBooleanExpressionException Class

Glossary Item Box

Represents an exception that is thrown when an invalid boolean literal is used in an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo property.

Object Model

InvalidBooleanExpressionException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidBooleanExpressionException
   Inherits System.Exception
C#
public class InvalidBooleanExpressionException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.PageReportModel.InvalidBooleanExpressionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidBooleanExpressionException Members
GrapeCity.ActiveReports.PageReportModel Namespace


InvalidBooleanExpressionException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : InvalidBooleanExpressionException Class

Glossary Item Box

The following tables list the members exposed by InvalidBooleanExpressionException.

Public Constructors

 | Name | Description
Public Constructor | InvalidBooleanExpressionException Constructor | Overloaded.
Top

See Also

Reference

InvalidBooleanExpressionException Class
GrapeCity.ActiveReports.PageReportModel Namespace


InvalidBooleanExpressionException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidBooleanExpressionException Class : InvalidBooleanExpressionException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidBooleanExpressionException Constructor() | Initializes a new instance of the InvalidBooleanExpressionException class.
InvalidBooleanExpressionException Constructor(String) | Initializes a new instance of the InvalidBooleanExpressionException class using a specified error message.
InvalidBooleanExpressionException Constructor(String,Exception) | Initializes a new instance of the InvalidBooleanExpressionException class using a specified error message and a reference to the inner exception that caused this exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidBooleanExpressionException Class
InvalidBooleanExpressionException Members


InvalidBooleanExpressionException Constructor()

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidBooleanExpressionException Class > InvalidBooleanExpressionException Constructor : InvalidBooleanExpressionException Constructor()

Glossary Item Box

Initializes a new instance of the InvalidBooleanExpressionException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InvalidBooleanExpressionException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidBooleanExpressionException Class
InvalidBooleanExpressionException Members
Overload List


InvalidBooleanExpressionException Constructor(String)

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidBooleanExpressionException Class > InvalidBooleanExpressionException Constructor : InvalidBooleanExpressionException Constructor(String)

message
A System.String value indicating the error message.

Glossary Item Box

Initializes a new instance of the InvalidBooleanExpressionException class using a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidBooleanExpressionException(
   string message
)

Parameters

message
A System.String value indicating the error message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidBooleanExpressionException Class
InvalidBooleanExpressionException Members
Overload List


InvalidBooleanExpressionException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
InvalidBooleanExpressionException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidBooleanExpressionException Class > InvalidBooleanExpressionException Constructor : InvalidBooleanExpressionException Constructor(String,Exception)

message
A System.String value indicating the error message that explained the reason for the exception.
innerException
An System.Exception object that caused the current exception.

Glossary Item Box

Initializes a new instance of the InvalidBooleanExpressionException class using a specified error message and a reference to the inner exception that caused this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public InvalidBooleanExpressionException(
   string message,
   Exception innerException
)

Parameters

message
A System.String value indicating the error message that explained the reason for the exception.
innerException
An System.Exception object that caused the current exception.

Remarks

If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidBooleanExpressionException Class
InvalidBooleanExpressionException Members
Overload List


InvalidLengthException Class

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : InvalidLengthException Class

Glossary Item Box

Represents an exception that is thrown when an invalid value is specified for a Length unit designator.

Object Model

InvalidLengthException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidLengthException
   Inherits System.Exception
C#
public class InvalidLengthException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.PageReportModel.InvalidLengthException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidLengthException Members
GrapeCity.ActiveReports.PageReportModel Namespace


InvalidLengthException Class Members

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : InvalidLengthException Class

Glossary Item Box

The following tables list the members exposed by InvalidLengthException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLengthException Constructor | Overloaded.
Top

See Also

Reference

InvalidLengthException Class
GrapeCity.ActiveReports.PageReportModel Namespace


InvalidLengthException Constructor

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidLengthException Class : InvalidLengthException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidLengthException Constructor() | Initializes a new instance of the InvalidLengthException class.
InvalidLengthException Constructor(String) | Initializes a new instance of the InvalidLengthException class using a specified error message.
InvalidLengthException Constructor(String,Exception) | Initializes a new instance of the InvalidLengthException class using a specified error message and a reference to the inner exception that caused this exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidLengthException Class
InvalidLengthException Members


InvalidLengthException Constructor()

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidLengthException Class > InvalidLengthException Constructor : InvalidLengthException Constructor()

Glossary Item Box

Initializes a new instance of the InvalidLengthException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InvalidLengthException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidLengthException Class
InvalidLengthException Members
Overload List


InvalidLengthException Constructor(String)

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidLengthException Class > InvalidLengthException Constructor : InvalidLengthException Constructor(String)

message
A System.String value indicating the error message.

Glossary Item Box

Initializes a new instance of the InvalidLengthException class using a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidLengthException(
   string message
)

Parameters

message
A System.String value indicating the error message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidLengthException Class
InvalidLengthException Members
Overload List


InvalidLengthException Constructor(String,Exception)

[image]
ActiveReports 19 .NET Edition
InvalidLengthException Constructor(String,Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > InvalidLengthException Class > InvalidLengthException Constructor : InvalidLengthException Constructor(String,Exception)

message
A System.String value indicating the error message that explained the reason for the exception.
innerException
An System.Exception object that caused the current exception.

Glossary Item Box

Initializes a new instance of the InvalidLengthException class using a specified error message and a reference to the inner exception that caused this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public InvalidLengthException(
   string message,
   Exception innerException
)

Parameters

message
A System.String value indicating the error message that explained the reason for the exception.
innerException
An System.Exception object that caused the current exception.

Remarks

If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidLengthException Class
InvalidLengthException Members
Overload List


ItemCollection<T> Class

T
A type of collection items.
[image]
ActiveReports 19 .NET Edition
ItemCollection<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemCollection<T> Class

Glossary Item Box

Represents a base class for strongly typed collection of T objects.

Object Model

ItemCollection<T> Class

Syntax

Visual Basic (Declaration)
Public Class ItemCollection(Of T)
C#
public class ItemCollection<T>

Type Parameters

T
A type of collection items.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.ColumnGroupingCollection
GrapeCity.ActiveReports.PageReportModel.DataGroupingCollection
GrapeCity.ActiveReports.PageReportModel.MatrixCellCollection
GrapeCity.ActiveReports.PageReportModel.MatrixRowCollection
GrapeCity.ActiveReports.PageReportModel.RowGroupingCollection
GrapeCity.ActiveReports.PageReportModel.StaticRowColumnCollection
GrapeCity.ActiveReports.PageReportModel.TableCellCollection
GrapeCity.ActiveReports.PageReportModel.TableGroupCollection
GrapeCity.ActiveReports.PageReportModel.TableRowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Members
GrapeCity.ActiveReports.PageReportModel Namespace


ItemCollection<T> Class Members

[image]
ActiveReports 19 .NET Edition
ItemCollection<T> Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemCollection<T> Class

Glossary Item Box

The following tables list the members exposed by ItemCollection<T>.

Public Constructors

 | Name | Description
Public Constructor | ItemCollection<T> Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of T objects in the ItemCollection<T>.
Public Property | IsReadOnly | Gets a value indicating whether the ItemCollection<T> is read-only.
Public Property | Item | Gets or sets a specific T object in the ItemCollection<T> by position.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a T object to the ItemCollection<T>.
Public Method | AddRange | Adds a collection of T objects to the existing ItemCollection<T>.
Public Method | Clear | Removes all items from the ItemCollection<T>.
Public Method | Contains | Gets a value indicating whether the ItemCollection<T> contains the specified T.
Public Method | CopyTo | Copies the objects in the ItemCollection<T> to a T array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific T object in the ItemCollection<T>.
Public Method | Insert | Inserts a new T into the ItemCollection<T> at the specified location.
Public Method | Remove | Removes the specified T object from the ItemCollection<T>.
Public Method | RemoveAt | Removes a T object from the ItemCollection<T> at the specified index.
Public Method | ToArray | Copies the elements of the ItemCollection<T> to a new array.
Top

See Also

Reference

ItemCollection<T> Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemCollection<T> Constructor

[image]
ActiveReports 19 .NET Edition
ItemCollection<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : ItemCollection<T> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ItemCollection<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


ItemCollection<T> Class Methods

[image]
ActiveReports 19 .NET Edition
ItemCollection<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemCollection<T> Class

Glossary Item Box

For a list of all members of this type, see ItemCollection<T> members.

Public Methods

 | Name | Description
Public Method | Add | Adds a T object to the ItemCollection<T>.
Public Method | AddRange | Adds a collection of T objects to the existing ItemCollection<T>.
Public Method | Clear | Removes all items from the ItemCollection<T>.
Public Method | Contains | Gets a value indicating whether the ItemCollection<T> contains the specified T.
Public Method | CopyTo | Copies the objects in the ItemCollection<T> to a T array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific T object in the ItemCollection<T>.
Public Method | Insert | Inserts a new T into the ItemCollection<T> at the specified location.
Public Method | Remove | Removes the specified T object from the ItemCollection<T>.
Public Method | RemoveAt | Removes a T object from the ItemCollection<T> at the specified index.
Public Method | ToArray | Copies the elements of the ItemCollection<T> to a new array.
Top

See Also

Reference

ItemCollection<T> Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Add Method

item
A T object to add.

Glossary Item Box

Adds a T object to the ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As T _
) As Integer
C#
public int Add(
   T item
)

Parameters

item
A T object to add.

Return Value

An System.Int32 value indicating the index of newly added item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : AddRange Method

collection
A collection of the T objects to add.

Glossary Item Box

Adds a collection of T objects to the existing ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of T) _
)
C#
public void AddRange(
   IEnumerable<T> collection
)

Parameters

collection
A collection of the T objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Clear Method

Glossary Item Box

Removes all items from the ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Contains Method

item
A T object for which to check.

Glossary Item Box

Gets a value indicating whether the ItemCollection<T> contains the specified T.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As T _
) As Boolean
C#
public bool Contains(
   T item
)

Parameters

item
A T object for which to check.

Return Value

A System.Boolean value. true if the ItemCollection<T> contains the specified T; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : CopyTo Method

array
An one-dimensional array of the T objects that is the destination of the elements copied from the ItemCollection<T>. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Glossary Item Box

Copies the objects in the ItemCollection<T> to a T array, starting at the specified array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   T[] array,
   int arrayIndex
)

Parameters

array
An one-dimensional array of the T objects that is the destination of the elements copied from the ItemCollection<T>. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : IndexOf Method

item
A T object to locate in the ItemCollection<T>.

Glossary Item Box

Determines the index of a specific T object in the ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As T _
) As Integer
C#
public int IndexOf(
   T item
)

Parameters

item
A T object to locate in the ItemCollection<T>.

Return Value

An System.Int32 value indicating the index of the entry if it was found in the collection; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Insert Method

index
A zero-based System.Int32 index indicating the position at which to insert the T object.
item
A T object to insert.

Glossary Item Box

Inserts a new T into the ItemCollection<T> at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As T _
)
C#
public void Insert(
   int index,
   T item
)

Parameters

index
A zero-based System.Int32 index indicating the position at which to insert the T object.
item
A T object to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Remove Method

item
A T object to remove.

Glossary Item Box

Removes the specified T object from the ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As T _
) As Boolean
C#
public bool Remove(
   T item
)

Parameters

item
A T object to remove.

Return Value

A System.Boolean value. true if the T was successfully removed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : RemoveAt Method

index
A zero-based System.Int32 index at which to remove the T object.

Glossary Item Box

Removes a T object from the ItemCollection<T> at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
A zero-based System.Int32 index at which to remove the T object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : ToArray Method

Glossary Item Box

Copies the elements of the ItemCollection<T> to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As T()
C#
public T[] ToArray()

Return Value

An array of T objects containing copies of the elements in the ItemCollection<T>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


ItemCollection<T> Class Properties

[image]
ActiveReports 19 .NET Edition
ItemCollection<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemCollection<T> Class

Glossary Item Box

For a list of all members of this type, see ItemCollection<T> members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of T objects in the ItemCollection<T>.
Public Property | IsReadOnly | Gets a value indicating whether the ItemCollection<T> is read-only.
Public Property | Item | Gets or sets a specific T object in the ItemCollection<T> by position.
Top

See Also

Reference

ItemCollection<T> Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Count Property

Glossary Item Box

Gets the number of T objects in the ItemCollection<T>.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An System.Int32 value indicating the number of T objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the ItemCollection<T> is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

A System.Boolean value. true if the ItemCollection<T> is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ItemCollection<T> Class : Item Property

index
A zero-based System.Int32 index of the T to return or set.

Glossary Item Box

Gets or sets a specific T object in the ItemCollection<T> by position.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As T
C#
public T this[
   int index
]; {get; set;}

Parameters

index
A zero-based System.Int32 index of the T to return or set.

Property Value

A T object at the specified position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollection<T> Class
ItemCollection<T> Members


LabelData Class

[image]
ActiveReports 19 .NET Edition
LabelData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LabelData Class

Glossary Item Box

Represents the dataset used to populate the data for the slider labels.

Object Model

LabelData Class

Syntax

Visual Basic (Declaration)
Public Class LabelData
C#
public class LabelData

Remarks

The LabelData class provides settings for specifying the dataset and fields used for slider labels.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.LabelData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelData Members
GrapeCity.ActiveReports.PageReportModel Namespace


LabelData Class Members

[image]
ActiveReports 19 .NET Edition
LabelData Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LabelData Class

Glossary Item Box

The following tables list the members exposed by LabelData.

Public Constructors

 | Name | Description
Public Constructor | LabelData Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets a dataset name.
Public Property | Key | Gets or sets the field name in the dataset to be matched with the band group expression value.
Public Property | Label | Gets or sets the field name in the dataset to be displayed as navigation labels.
Top

See Also

Reference

LabelData Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelData Constructor

[image]
ActiveReports 19 .NET Edition
LabelData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LabelData Class : LabelData Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LabelData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelData Class
LabelData Members


LabelData Class Properties

[image]
ActiveReports 19 .NET Edition
LabelData Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LabelData Class

Glossary Item Box

For a list of all members of this type, see LabelData members.

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets a dataset name.
Public Property | Key | Gets or sets the field name in the dataset to be matched with the band group expression value.
Public Property | Label | Gets or sets the field name in the dataset to be displayed as navigation labels.
Top

See Also

Reference

LabelData Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LabelData Class : DataSetName Property

Glossary Item Box

Gets or sets a dataset name.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As String
C#
public string DataSetName {get; set;}

Property Value

A System.String value indicating the dataset name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelData Class
LabelData Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LabelData Class : Key Property

Glossary Item Box

Gets or sets the field name in the dataset to be matched with the band group expression value.

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Property Value

A System.String value indicating the key of field name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelData Class
LabelData Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LabelData Class : Label Property

Glossary Item Box

Gets or sets the field name in the dataset to be displayed as navigation labels.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Property Value

A System.String value indicating the label of field name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelData Class
LabelData Members


Layer Class

[image]
ActiveReports 19 .NET Edition
Layer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

Glossary Item Box

Represents a layer on which ReportItem objects are located in a report.

Object Model

Layer Class

Syntax

Visual Basic (Declaration)
Public Class Layer
   Implements IValidateable
C#
public class Layer : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Layer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Members
GrapeCity.ActiveReports.PageReportModel Namespace


Layer Class Members

[image]
ActiveReports 19 .NET Edition
Layer Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

Glossary Item Box

The following tables list the members exposed by Layer.

Public Constructors

 | Name | Description
Public Constructor | Layer Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultLayerName | The name of the default layer, which is always present.
Top

Public Properties

 | Name | Description
Public Property | DesignerDataFieldVisible | Gets or sets a value indicating whether data field icons on this layer are visible in the designer.
Public Property | DesignerLock | Gets or sets a value indicating whether elements on this layer are locked in the designer.
Public Property | DesignerTransparency | Gets or sets the transparency level of elements on this layer in the designer.
Public Property | DesignerVisible | Gets or sets a value indicating whether elements on this layer are visible in the designer.
Public Property | Name | Gets or sets a name of the layer.
Public Property | TargetDevice | Gets or sets a target device for the layer.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Layer object.
Top

See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Layer Constructor

[image]
ActiveReports 19 .NET Edition
Layer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Layer Constructor

Glossary Item Box

Overload List

Overload | Description
Layer Constructor() | Initializes a new instance of the Layer class.
Layer Constructor(String) | Initializes a new instance of the Layer class using a specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


Layer Constructor()

[image]
ActiveReports 19 .NET Edition
Layer Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class > Layer Constructor : Layer Constructor()

Glossary Item Box

Initializes a new instance of the Layer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Layer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members
Overload List


Layer Constructor(String)

[image]
ActiveReports 19 .NET Edition
Layer Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class > Layer Constructor : Layer Constructor(String)

name
A System.String value indicating the name of the layer.

Glossary Item Box

Initializes a new instance of the Layer class using a specified name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public Layer(
   string name
)

Parameters

name
A System.String value indicating the name of the layer.

Exceptions

Exception | Description
System.ArgumentException | Throws if name is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members
Overload List


Layer Class Methods

[image]
ActiveReports 19 .NET Edition
Layer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

Glossary Item Box

For a list of all members of this type, see Layer members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Layer object.
Top

See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Layer object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


Layer Class Properties

[image]
ActiveReports 19 .NET Edition
Layer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

Glossary Item Box

For a list of all members of this type, see Layer members.

Public Properties

 | Name | Description
Public Property | DesignerDataFieldVisible | Gets or sets a value indicating whether data field icons on this layer are visible in the designer.
Public Property | DesignerLock | Gets or sets a value indicating whether elements on this layer are locked in the designer.
Public Property | DesignerTransparency | Gets or sets the transparency level of elements on this layer in the designer.
Public Property | DesignerVisible | Gets or sets a value indicating whether elements on this layer are visible in the designer.
Public Property | Name | Gets or sets a name of the layer.
Public Property | TargetDevice | Gets or sets a target device for the layer.
Top

See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DesignerDataFieldVisible Property

[image]
ActiveReports 19 .NET Edition
DesignerDataFieldVisible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerDataFieldVisible Property

Glossary Item Box

Gets or sets a value indicating whether data field icons on this layer are visible in the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerDataFieldVisible As Boolean
C#
public bool DesignerDataFieldVisible {get; set;}

Property Value

A System.Boolean value indicating whether the data field icons are visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


DesignerLock Property

[image]
ActiveReports 19 .NET Edition
DesignerLock Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerLock Property

Glossary Item Box

Gets or sets a value indicating whether elements on this layer are locked in the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerLock As Boolean
C#
public bool DesignerLock {get; set;}

Property Value

A System.Boolean value indicating whether the elements are locked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


DesignerTransparency Property

[image]
ActiveReports 19 .NET Edition
DesignerTransparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerTransparency Property

Glossary Item Box

Gets or sets the transparency level of elements on this layer in the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerTransparency As Single
C#
public float DesignerTransparency {get; set;}

Property Value

A System.Single value indicating the transparency level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


DesignerVisible Property

[image]
ActiveReports 19 .NET Edition
DesignerVisible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerVisible Property

Glossary Item Box

Gets or sets a value indicating whether elements on this layer are visible in the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerVisible As Boolean
C#
public bool DesignerVisible {get; set;}

Property Value

A System.Boolean value indicating whether the elements are visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Name Property

Glossary Item Box

Gets or sets a name of the layer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the layer name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : TargetDevice Property

Glossary Item Box

Gets or sets a target device for the layer.

Syntax

Visual Basic (Declaration)
Public Property TargetDevice As TargetDevices
C#
public TargetDevices TargetDevice {get; set;}

Property Value

A TargetDevices value indicating the target device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


Layer Class Fields

[image]
ActiveReports 19 .NET Edition
Layer Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

Glossary Item Box

For a list of all members of this type, see Layer members.

Public Fields

 | Name | Description
Public Field | DefaultLayerName | The name of the default layer, which is always present.
Top

See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultLayerName Field

[image]
ActiveReports 19 .NET Edition
DefaultLayerName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DefaultLayerName Field

Glossary Item Box

The name of the default layer, which is always present.

Syntax

Visual Basic (Declaration)
Public Const DefaultLayerName As String
C#
public const string DefaultLayerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer Class
Layer Members


Layer.Defaults Class

[image]
ActiveReports 19 .NET Edition
Layer.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer.Defaults Class

Glossary Item Box

Represents the default property values for a layer.

Object Model

Layer.Defaults Class

Syntax

Visual Basic (Declaration)
Public Class Layer.Defaults
C#
public class Layer.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Layer.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


Layer.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
Layer.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer.Defaults Class

Glossary Item Box

The following tables list the members exposed by Layer.Defaults.

Public Constructors

 | Name | Description
Public Constructor | Layer.Defaults Constructor |
Top

Public Fields

 | Name | Description
Public Field | DesignerDataFieldVisible | The default visibility status of data field icons in the designer.
Public Field | DesignerLock | The default lock status in the designer.
Public Field | DesignerTransparency | The default transparency level in the designer.
Public Field | DesignerVisible | The default visibility status in the designer.
Public Field | TargetDevice | The default target device for the layer.
Top

See Also

Reference

Layer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


Layer.Defaults Constructor

[image]
ActiveReports 19 .NET Edition
Layer.Defaults Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : Layer.Defaults Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Layer.Defaults()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


Layer.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
Layer.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer.Defaults Class

Glossary Item Box

For a list of all members of this type, see Layer.Defaults members.

Public Fields

 | Name | Description
Public Field | DesignerDataFieldVisible | The default visibility status of data field icons in the designer.
Public Field | DesignerLock | The default lock status in the designer.
Public Field | DesignerTransparency | The default transparency level in the designer.
Public Field | DesignerVisible | The default visibility status in the designer.
Public Field | TargetDevice | The default target device for the layer.
Top

See Also

Reference

Layer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


DesignerDataFieldVisible Field

[image]
ActiveReports 19 .NET Edition
DesignerDataFieldVisible Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : DesignerDataFieldVisible Field

Glossary Item Box

The default visibility status of data field icons in the designer.

Syntax

Visual Basic (Declaration)
Public Const DesignerDataFieldVisible As Boolean
C#
public const bool DesignerDataFieldVisible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


DesignerLock Field

[image]
ActiveReports 19 .NET Edition
DesignerLock Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : DesignerLock Field

Glossary Item Box

The default lock status in the designer.

Syntax

Visual Basic (Declaration)
Public Const DesignerLock As Boolean
C#
public const bool DesignerLock

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


DesignerTransparency Field

[image]
ActiveReports 19 .NET Edition
DesignerTransparency Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : DesignerTransparency Field

Glossary Item Box

The default transparency level in the designer.

Syntax

Visual Basic (Declaration)
Public Const DesignerTransparency As Single
C#
public const float DesignerTransparency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


DesignerVisible Field

[image]
ActiveReports 19 .NET Edition
DesignerVisible Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : DesignerVisible Field

Glossary Item Box

The default visibility status in the designer.

Syntax

Visual Basic (Declaration)
Public Const DesignerVisible As Boolean
C#
public const bool DesignerVisible

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


TargetDevice Field

[image]
ActiveReports 19 .NET Edition
TargetDevice Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer.Defaults Class : TargetDevice Field

Glossary Item Box

The default target device for the layer.

Syntax

Visual Basic (Declaration)
Public Const TargetDevice As TargetDevices
C#
public const TargetDevices TargetDevice

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Layer.Defaults Class
Layer.Defaults Members


LayerCollection Class

[image]
ActiveReports 19 .NET Edition
LayerCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

Glossary Item Box

Represents a strongly typed collection of Layer objects.

Object Model

LayerCollection Class

Syntax

Visual Basic (Declaration)
Public Class LayerCollection
   Inherits System.Collections.CollectionBase
   Implements IValidateable
C#
public class LayerCollection : System.Collections.CollectionBase, IValidateable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.PageReportModel.LayerCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


LayerCollection Class Members

[image]
ActiveReports 19 .NET Edition
LayerCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

Glossary Item Box

The following tables list the members exposed by LayerCollection.

Public Constructors

 | Name | Description
Public Constructor | LayerCollection Constructor | Initializes a new instance of the LayerCollection class.
Top

Public Properties

 | Name | Description
Public Property | DefaultLayer | Gets the default Layer in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the LayerCollection is read-only.
Public Property | Item | Gets or sets a specific Layer object in the LayerCollection by position.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Layer object to the LayerCollection.
Public Method | Contains | Gets a value indicating whether the LayerCollection contains the specified Layer.
Public Method | CopyTo | Copies the objects in the LayerCollection to a Layer array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific Layer object in the LayerCollection.
Public Method | Insert | Inserts a new Layer into the LayerCollection at the specified location.
Public Method | Remove | Removes the specified Layer object from the LayerCollection.
Public Method | Validate | Validates the current state of the LayerCollection object.
Top

See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


LayerCollection Constructor

[image]
ActiveReports 19 .NET Edition
LayerCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : LayerCollection Constructor

report
The Report to which this collection belongs.

Glossary Item Box

Initializes a new instance of the LayerCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report _
)
C#
public LayerCollection(
   Report report
)

Parameters

report
The Report to which this collection belongs.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if report is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


LayerCollection Class Methods

[image]
ActiveReports 19 .NET Edition
LayerCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

Glossary Item Box

For a list of all members of this type, see LayerCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Layer object to the LayerCollection.
Public Method | Contains | Gets a value indicating whether the LayerCollection contains the specified Layer.
Public Method | CopyTo | Copies the objects in the LayerCollection to a Layer array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific Layer object in the LayerCollection.
Public Method | Insert | Inserts a new Layer into the LayerCollection at the specified location.
Public Method | Remove | Removes the specified Layer object from the LayerCollection.
Public Method | Validate | Validates the current state of the LayerCollection object.
Top

See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Add Method

item
A Layer object to add.

Glossary Item Box

Adds a Layer object to the LayerCollection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Layer _
)
C#
public void Add(
   Layer item
)

Parameters

item
A Layer object to add.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
collection.Add(new Layer("Layer1"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Contains Method

item
A Layer object for which to check.

Glossary Item Box

Gets a value indicating whether the LayerCollection contains the specified Layer.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Layer _
) As Boolean
C#
public bool Contains(
   Layer item
)

Parameters

item
A Layer object for which to check.

Return Value

A System.Boolean value. true if the LayerCollection contains the specified Layer; otherwise, false.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
Layer layer = new Layer("Layer1");
collection.Add(layer);
bool contains = collection.Contains(layer);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : CopyTo Method

array
An one-dimensional array of the Layer objects that is the destination of the elements copied from the LayerCollection. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Glossary Item Box

Copies the objects in the LayerCollection to a Layer array, starting at the specified array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Layer, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Layer[] array,
   int arrayIndex
)

Parameters

array
An one-dimensional array of the Layer objects that is the destination of the elements copied from the LayerCollection. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : IndexOf Method

item
A Layer object to locate in the LayerCollection.

Glossary Item Box

Determines the index of a specific Layer object in the LayerCollection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As Layer _
) As Integer
C#
public int IndexOf(
   Layer item
)

Parameters

item
A Layer object to locate in the LayerCollection.

Return Value

An System.Int32 value indicating the index of the entry if it was found in the collection; otherwise, -1.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
Layer layer = new Layer("Layer1");
int index = collection.IndexOf(layer);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Insert Method

index
A zero-based System.Int32 index indicating the position at which to insert the Layer object.
item
A Layer object to insert.

Glossary Item Box

Inserts a new Layer into the LayerCollection at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Layer _
)
C#
public void Insert(
   int index,
   Layer item
)

Parameters

index
A zero-based System.Int32 index indicating the position at which to insert the Layer object.
item
A Layer object to insert.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
collection.Insert(0, new Layer("Layer2"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Remove Method

item
A Layer object to remove.

Glossary Item Box

Removes the specified Layer object from the LayerCollection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Layer _
) As Boolean
C#
public bool Remove(
   Layer item
)

Parameters

item
A Layer object to remove.

Return Value

A System.Boolean value. true if the Layer was successfully removed; otherwise, false.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
Layer layer = new Layer("Layer1");
collection.Add(layer);
bool removed = collection.Remove(layer);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the LayerCollection object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


LayerCollection Class Properties

[image]
ActiveReports 19 .NET Edition
LayerCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

Glossary Item Box

For a list of all members of this type, see LayerCollection members.

Public Properties

 | Name | Description
Public Property | DefaultLayer | Gets the default Layer in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the LayerCollection is read-only.
Public Property | Item | Gets or sets a specific Layer object in the LayerCollection by position.
Top

See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultLayer Property

[image]
ActiveReports 19 .NET Edition
DefaultLayer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : DefaultLayer Property

Glossary Item Box

Gets the default Layer in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultLayer As Layer
C#
public Layer DefaultLayer {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the LayerCollection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

A System.Boolean value. true if the LayerCollection is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Item Property

index
A zero-based System.Int32 index of the Layer to return or set.

Glossary Item Box

Gets or sets a specific Layer object in the LayerCollection by position.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Layer
C#
public Layer this[
   int index
]; {get; set;}

Parameters

index
A zero-based System.Int32 index of the Layer to return or set.

Property Value

A Layer object at the specified position.

Example

C# Copy Code
LayerCollection collection = new LayerCollection(_report);
collection.Add(new Layer("Layer1"));
Layer layer = collection[0];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerCollection Class
LayerCollection Members


Legend Class

[image]
ActiveReports 19 .NET Edition
Legend Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

Glossary Item Box

The Legend element defines the properties that are used to display instances of the series groupings in a chart legend.

Object Model

Legend Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Legend
   Implements IValidateable
C#
public sealed class Legend : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Legend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Members
GrapeCity.ActiveReports.PageReportModel Namespace


Legend Class Members

[image]
ActiveReports 19 .NET Edition
Legend Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

Glossary Item Box

The following tables list the members exposed by Legend.

Public Constructors

 | Name | Description
Public Constructor | Legend Constructor | Initializes a new instance of the Legend class.
Top

Public Properties

 | Name | Description
Public Property | InsidePlotArea | Gets or sets a value indicating whether to draw the legend inside or outside the plot area.
Public Property | Layout | Gets or sets the arrangement of labels within the legend.
Public Property | Position | Gets or sets the position of the legend.
Public Property | Style | Gets or sets the text, border and background style properties for the legend.
Public Property | UseSmartSettings | Gets or sets the value indicates whether to use automatic legend.
Public Property | Visible | Gets or sets a value indicating whether a legend is displayed.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Legend object.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


Legend Constructor

[image]
ActiveReports 19 .NET Edition
Legend Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Legend Constructor

Glossary Item Box

Initializes a new instance of the Legend class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Legend()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Legend Class Methods

[image]
ActiveReports 19 .NET Edition
Legend Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

Glossary Item Box

For a list of all members of this type, see Legend members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Legend object.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Legend object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Legend Class Properties

[image]
ActiveReports 19 .NET Edition
Legend Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

Glossary Item Box

For a list of all members of this type, see Legend members.

Public Properties

 | Name | Description
Public Property | InsidePlotArea | Gets or sets a value indicating whether to draw the legend inside or outside the plot area.
Public Property | Layout | Gets or sets the arrangement of labels within the legend.
Public Property | Position | Gets or sets the position of the legend.
Public Property | Style | Gets or sets the text, border and background style properties for the legend.
Public Property | UseSmartSettings | Gets or sets the value indicates whether to use automatic legend.
Public Property | Visible | Gets or sets a value indicating whether a legend is displayed.
Top

See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


InsidePlotArea Property

[image]
ActiveReports 19 .NET Edition
InsidePlotArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : InsidePlotArea Property

Glossary Item Box

Gets or sets a value indicating whether to draw the legend inside or outside the plot area.

Syntax

Visual Basic (Declaration)
Public Property InsidePlotArea As Boolean
C#
public bool InsidePlotArea {get; set;}

Property Value

A System.Boolean value where true indicates that the legend is displayed inside the plot area; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Layout Property

[image]
ActiveReports 19 .NET Edition
Layout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Layout Property

Glossary Item Box

Gets or sets the arrangement of labels within the legend.

Syntax

Visual Basic (Declaration)
Public Property Layout As LegendLayout
C#
public LegendLayout Layout {get; set;}

Property Value

A LegendLayout enumeration indicating the arrangement of labels within the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Position Property

Glossary Item Box

Gets or sets the position of the legend.

Syntax

Visual Basic (Declaration)
Public Property Position As LegendPosition
C#
public LegendPosition Position {get; set;}

Property Value

A LegendPosition enumeration indicating the position of the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Style Property

Glossary Item Box

Gets or sets the text, border and background style properties for the legend.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the text, border and background style properties for the legend.

Remarks

All textbox properties apply.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


UseSmartSettings Property

[image]
ActiveReports 19 .NET Edition
UseSmartSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : UseSmartSettings Property

Glossary Item Box

Gets or sets the value indicates whether to use automatic legend.

Syntax

Visual Basic (Declaration)
Public Property UseSmartSettings As Boolean
C#
public bool UseSmartSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether a legend is displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A System.Boolean value where true indicates that the legend is displayed; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


LibrariesCollection Class

[image]
ActiveReports 19 .NET Edition
LibrariesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LibrariesCollection Class

Glossary Item Box

Represents a strongly typed collection of PartsLibraryReference objects.

Object Model

LibrariesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LibrariesCollection
   Inherits System.Collections.ObjectModel.Collection(Of PartsLibraryReference)
C#
public sealed class LibrariesCollection : System.Collections.ObjectModel.Collection<PartsLibraryReference>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.LibrariesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LibrariesCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


LibrariesCollection Class Members

[image]
ActiveReports 19 .NET Edition
LibrariesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LibrariesCollection Class

Glossary Item Box

The following tables list the members exposed by LibrariesCollection.

Public Constructors

 | Name | Description
Public Constructor | LibrariesCollection Constructor |
Top

See Also

Reference

LibrariesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


LibrariesCollection Constructor

[image]
ActiveReports 19 .NET Edition
LibrariesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LibrariesCollection Class : LibrariesCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LibrariesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LibrariesCollection Class
LibrariesCollection Members


Line Class

[image]
ActiveReports 19 .NET Edition
Line Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

Glossary Item Box

Represents a line ReportItem within the report definition.

Object Model

Line Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Line
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class Line : ReportItem, IReportComponent, IValidateable

Remarks

Lines can be drawn from the top or left (or both) and can have negative heights or widths (or both). However, the sum of Top and Height, and the sum of Left and Width, must be non-negative and valid sizes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Members
GrapeCity.ActiveReports.PageReportModel Namespace


Line Class Members

[image]
ActiveReports 19 .NET Edition
Line Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

Glossary Item Box

The following tables list the members exposed by Line.

Public Constructors

 | Name | Description
Public Constructor | Line Constructor | Initializes a new instance of the Line class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets the description of the control for accessibility client applications.
Public Property | Height | Overridden. Gets or sets a height of the line, allowing for negative values.
Public Property | Width | Overridden. Gets or sets a width of the line, allowing for negative values.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


Line Constructor

[image]
ActiveReports 19 .NET Edition
Line Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Line Constructor

Glossary Item Box

Initializes a new instance of the Line class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line Class Properties

[image]
ActiveReports 19 .NET Edition
Line Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets the description of the control for accessibility client applications.
Public Property | Height | Overridden. Gets or sets a height of the line, allowing for negative values.
Public Property | Width | Overridden. Gets or sets a width of the line, allowing for negative values.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control for accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the accessible description.

Example

C# Copy Code
Line line = new Line();
line.AccessibleDescription = "This is a vertical line.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Height Property

Glossary Item Box

Gets or sets a height of the line, allowing for negative values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Height As Length
C#
public override Length Height {get; set;}

Property Value

A Length value indicating the height of the line.

Example

C# Copy Code
Line line = new Line();
line.Height = "-2cm";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Width Property

Glossary Item Box

Gets or sets a width of the line, allowing for negative values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Width As Length
C#
public override Length Width {get; set;}

Property Value

A Length value indicating the width of the line.

Example

C# Copy Code
Line line = new Line();
line.Width = "2cm";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


List Class

[image]
ActiveReports 19 .NET Edition
List Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

Glossary Item Box

Represents a DataRegion repeating any report controls it contains for every group in the rowset or each row in the dataset, if no group expression is defined.

Object Model

List Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class List
   Inherits DataRegion
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class List : DataRegion, IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

The data records could be grouped or sorted, use Grouping and Sorting properties.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.List

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Members
GrapeCity.ActiveReports.PageReportModel Namespace


List Class Members

[image]
ActiveReports 19 .NET Edition
List Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

Glossary Item Box

The following tables list the members exposed by List.

Public Constructors

 | Name | Description
Public Constructor | List Constructor | Initializes a new instance of the List class.
Top

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the data region.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeWhiteSpace | Gets or sets a value indicating whether all white space in the list is consumed during report rendering when the container’s contents grow.
Public Property | DataInstanceElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DataInstanceName | Gets or sets the name to use for the data element or attribute for the list.
Public Property | Grouping | Gets or sets an expression by which to group the data.
Public Property | GrowDirection | Gets or sets the direction in which the list layout grows.
Public Property | ReportItems | Gets a collection of report items contained within the List.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the data region.
Public Property | RowsOrColumnsCount | Gets or sets the number of rows or columns, depending on the GrowDirection, of the list.
Public Property | Sorting | Gets a collection of expressions by which to sort the repeated list regions.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Public Method | Validate | Overridden. Validates the current state of the List object.
Top

See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


List Constructor

[image]
ActiveReports 19 .NET Edition
List Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : List Constructor

Glossary Item Box

Initializes a new instance of the List class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public List()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


List Class Methods

[image]
ActiveReports 19 .NET Edition
List Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

Glossary Item Box

For a list of all members of this type, see List members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Public Method | Validate | Overridden. Validates the current state of the List object.
Top

See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


SortReportItems Method

[image]
ActiveReports 19 .NET Edition
SortReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : SortReportItems Method

Glossary Item Box

Sorts the report items to improve rendering performance.

Syntax

Visual Basic (Declaration)
Public Sub SortReportItems()
C#
public void SortReportItems()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the List object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


List Class Properties

[image]
ActiveReports 19 .NET Edition
List Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

Glossary Item Box

For a list of all members of this type, see List members.

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the data region.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeWhiteSpace | Gets or sets a value indicating whether all white space in the list is consumed during report rendering when the container’s contents grow.
Public Property | DataInstanceElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DataInstanceName | Gets or sets the name to use for the data element or attribute for the list.
Public Property | Grouping | Gets or sets an expression by which to group the data.
Public Property | GrowDirection | Gets or sets the direction in which the list layout grows.
Public Property | ReportItems | Gets a collection of report items contained within the List.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the data region.
Public Property | RowsOrColumnsCount | Gets or sets the number of rows or columns, depending on the GrowDirection, of the list.
Public Property | Sorting | Gets a collection of expressions by which to sort the repeated list regions.
Top

See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the data region.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ConsumeWhiteSpace Property

Glossary Item Box

Gets or sets a value indicating whether all white space in the list is consumed during report rendering when the container’s contents grow.

Syntax

Visual Basic (Declaration)
Public Property ConsumeWhiteSpace As Boolean
C#
public bool ConsumeWhiteSpace {get; set;}

Property Value

A System.Boolean value indicating whether all white space in the list is consumed during report rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


DataInstanceElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataInstanceElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : DataInstanceElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataInstanceElementOutput As DataElementOutput
C#
public DataElementOutput DataInstanceElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the list instances appear in the output.

NoOutput indicates that the list instance does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


DataInstanceName Property

[image]
ActiveReports 19 .NET Edition
DataInstanceName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : DataInstanceName Property

Glossary Item Box

Gets or sets the name to use for the data element or attribute for the list.

Syntax

Visual Basic (Declaration)
Public Property DataInstanceName As String
C#
public string DataInstanceName {get; set;}

Property Value

A System.String value indicating the name to use for the data element or attribute for the list.

Remarks

This property is ignored if there is a grouping for the list.

Default value is "Item".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Grouping Property

Glossary Item Box

Gets or sets an expression by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object representing the expression by which to group the data.

Remarks

This property is required if there are any DataRegion contained within the List.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


GrowDirection Property

[image]
ActiveReports 19 .NET Edition
GrowDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : GrowDirection Property

Glossary Item Box

Gets or sets the direction in which the list layout grows.

Syntax

Visual Basic (Declaration)
Public Property GrowDirection As GrowDirection
C#
public GrowDirection GrowDirection {get; set;}

Property Value

A GrowDirection value indicating the direction in which the list layout grows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ReportItems Property

Glossary Item Box

Gets a collection of report items contained within the List.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection object containing the report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the data region.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


RowsOrColumnsCount Property

[image]
ActiveReports 19 .NET Edition
RowsOrColumnsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : RowsOrColumnsCount Property

Glossary Item Box

Gets or sets the number of rows or columns, depending on the GrowDirection, of the list.

Syntax

Visual Basic (Declaration)
Public Property RowsOrColumnsCount As Integer
C#
public int RowsOrColumnsCount {get; set;}

Property Value

An System.Int32 value indicating the number of rows or columns of the list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Sorting Property

Glossary Item Box

Gets a collection of expressions by which to sort the repeated list regions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing expressions by which to sort the repeated list regions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

List Class
List Members


LocalizationResource Class

[image]
ActiveReports 19 .NET Edition
LocalizationResource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

Glossary Item Box

Represents a localization resource for the Report.

Object Model

LocalizationResource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocalizationResource
C#
public sealed class LocalizationResource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.LocalizationResource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Members
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResource Class Members

[image]
ActiveReports 19 .NET Edition
LocalizationResource Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

Glossary Item Box

The following tables list the members exposed by LocalizationResource.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | KeyFormat | Gets a format of key for resource.
Top

Public Methods

 | Name | Description
Public Method | AddResourceValue | Adds a resource value for the given key.
Public Method | GetResourcesByItemName | Gets the resources using the specified item name.
Public Method | GetResourceValue | Gets the resource value using the specified key.
Public Method | RemoveResourceValue | Removes the resource value using the specified key.
Top

See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResource Class Methods

[image]
ActiveReports 19 .NET Edition
LocalizationResource Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

Glossary Item Box

For a list of all members of this type, see LocalizationResource members.

Public Methods

 | Name | Description
Public Method | AddResourceValue | Adds a resource value for the given key.
Public Method | GetResourcesByItemName | Gets the resources using the specified item name.
Public Method | GetResourceValue | Gets the resource value using the specified key.
Public Method | RemoveResourceValue | Removes the resource value using the specified key.
Top

See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddResourceValue Method

[image]
ActiveReports 19 .NET Edition
AddResourceValue Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : AddResourceValue Method

key
A System.String value indicating the resource key, based on the template: [control name].[property name].
value
A System.String value indicating the resource value.

Glossary Item Box

Adds a resource value for the given key.

Syntax

Visual Basic (Declaration)
Public Sub AddResourceValue( _
   ByVal key As String, _
   ByVal value As String _
)
C#
public void AddResourceValue(
   string key,
   string value
)

Parameters

key
A System.String value indicating the resource key, based on the template: [control name].[property name].
value
A System.String value indicating the resource value.

Example

C# Copy Code
localizationResource.AddResourceValue("TextBox1.Value", "Text Value");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Class
LocalizationResource Members


GetResourcesByItemName Method

[image]
ActiveReports 19 .NET Edition
GetResourcesByItemName Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : GetResourcesByItemName Method

itemName
A System.String value indicating the item name.

Glossary Item Box

Gets the resources using the specified item name.

Syntax

Visual Basic (Declaration)
Public Function GetResourcesByItemName( _
   ByVal itemName As String _
) As IEnumerable(Of KeyValuePair(Of String,String))
C#
public IEnumerable<KeyValuePair<string,string>> GetResourcesByItemName(
   string itemName
)

Parameters

itemName
A System.String value indicating the item name.

Return Value

An IEnumerable containing key-value pairs of resource names and their corresponding values.

Example

C# Copy Code
textBox1Resources = localizationResource.GetResourcesByItemName("TextBox1");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Class
LocalizationResource Members


GetResourceValue Method

[image]
ActiveReports 19 .NET Edition
GetResourceValue Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : GetResourceValue Method

key
A System.String value indicating the resource key, based on the template: [control name].[property name].

Glossary Item Box

Gets the resource value using the specified key.

Syntax

Visual Basic (Declaration)
Public Function GetResourceValue( _
   ByVal key As String _
) As String
C#
public string GetResourceValue(
   string key
)

Parameters

key
A System.String value indicating the resource key, based on the template: [control name].[property name].

Return Value

A System.String value indicating the resource value.

Example

C# Copy Code
textBox1.Value = localizationResource.GetResourceValue("TextBox1.Value");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Class
LocalizationResource Members


RemoveResourceValue Method

[image]
ActiveReports 19 .NET Edition
RemoveResourceValue Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : RemoveResourceValue Method

key
A System.String value indicating the resource key, based on the template: [control name].[property name].

Glossary Item Box

Removes the resource value using the specified key.

Syntax

Visual Basic (Declaration)
Public Sub RemoveResourceValue( _
   ByVal key As String _
)
C#
public void RemoveResourceValue(
   string key
)

Parameters

key
A System.String value indicating the resource key, based on the template: [control name].[property name].

Example

C# Copy Code
localizationResource.RemoveResourceValue("TextBox1.Value");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Class
LocalizationResource Members


LocalizationResource Class Fields

[image]
ActiveReports 19 .NET Edition
LocalizationResource Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

Glossary Item Box

For a list of all members of this type, see LocalizationResource members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | KeyFormat | Gets a format of key for resource.
Top

See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


KeyFormat Field

[image]
ActiveReports 19 .NET Edition
KeyFormat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : KeyFormat Field

Glossary Item Box

Gets a format of key for resource.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly KeyFormat As String
C#
public static readonly string KeyFormat

Remarks

Uses for the GetResourcesByItemName.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResource Class
LocalizationResource Members


LocalizationResourceCollection Class

[image]
ActiveReports 19 .NET Edition
LocalizationResourceCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResourceCollection Class

Glossary Item Box

Represents a collection of localization resources for the Report.

Object Model

LocalizationResourceCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocalizationResourceCollection
C#
public sealed class LocalizationResourceCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.LocalizationResourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResourceCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResourceCollection Class Members

[image]
ActiveReports 19 .NET Edition
LocalizationResourceCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResourceCollection Class

Glossary Item Box

The following tables list the members exposed by LocalizationResourceCollection.

Public Properties

 | Name | Description
Public Property | Item | Get the LocalizationResource using a specified culture.
Top

See Also

Reference

LocalizationResourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResourceCollection Class Properties

[image]
ActiveReports 19 .NET Edition
LocalizationResourceCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResourceCollection Class

Glossary Item Box

For a list of all members of this type, see LocalizationResourceCollection members.

Public Properties

 | Name | Description
Public Property | Item | Get the LocalizationResource using a specified culture.
Top

See Also

Reference

LocalizationResourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResourceCollection Class : Item Property

culture
A System.String value indicating the culture to obtain resource.

Glossary Item Box

Get the LocalizationResource using a specified culture.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal culture As String _
) As LocalizationResource
C#
public LocalizationResource this[
   string culture
]; {get;}

Parameters

culture
A System.String value indicating the culture to obtain resource.

Property Value

A LocalizationResource object for the specified culture.

Remarks

If LocalizationResource does not exist for the specified culture, then it will be created and added to collection.

Example

C# Copy Code
LocalizationResource jaResource = _report.LocalizationResources["ja"];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizationResourceCollection Class
LocalizationResourceCollection Members


Map Class

[image]
ActiveReports 19 .NET Edition
Map Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

Glossary Item Box

Defines map-based data visualization.

Object Model

Map Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Map
   Inherits ReportItem
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Map : ReportItem, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Map

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Members
GrapeCity.ActiveReports.PageReportModel Namespace


Map Class Members

[image]
ActiveReports 19 .NET Edition
Map Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

Glossary Item Box

The following tables list the members exposed by Map.

Public Constructors

 | Name | Description
Public Constructor | Map Constructor | Initializes a new instance of the Map class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Public Property | ActionInfo | Gets or sets the map action info.
Public Property | AntiAliasing | Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.
Public Property | DocumentMapLabel | Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.
Public Property | MapBorderSkin | Gets or sets the map border skin.
Public Property | MapColorScale | Gets or sets the map color scale.
Public Property | MapDataRegions | Gets the map data regions.
Public Property | MapDistanceScale | Gets or sets the map distance scale.
Public Property | MapLayers | Gets the map layers.
Public Property | MapLegends | Gets the map legends.
Public Property | MapTitles | Gets the map titles.
Public Property | MapViewport | Gets or sets the map viewport.
Public Property | MaximumSpatialElementCount | Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.
Public Property | MaximumTotalPointCount | Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.
Public Property | PageBreak | Gets or sets the page break.
Public Property | PageName | Specifies value to use for the name of a paginated page.
Public Property | ShadowIntensity | Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.
Public Property | TextAntiAliasingQuality | Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of the values in TextAntiAliasingQuality. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.
Public Property | TileLanguage | Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.
Top

See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


Map Constructor

[image]
ActiveReports 19 .NET Edition
Map Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Map Constructor

Glossary Item Box

Initializes a new instance of the Map class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Map()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


Map Class Properties

[image]
ActiveReports 19 .NET Edition
Map Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

Glossary Item Box

For a list of all members of this type, see Map members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Public Property | ActionInfo | Gets or sets the map action info.
Public Property | AntiAliasing | Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.
Public Property | DocumentMapLabel | Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.
Public Property | MapBorderSkin | Gets or sets the map border skin.
Public Property | MapColorScale | Gets or sets the map color scale.
Public Property | MapDataRegions | Gets the map data regions.
Public Property | MapDistanceScale | Gets or sets the map distance scale.
Public Property | MapLayers | Gets the map layers.
Public Property | MapLegends | Gets the map legends.
Public Property | MapTitles | Gets the map titles.
Public Property | MapViewport | Gets or sets the map viewport.
Public Property | MaximumSpatialElementCount | Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.
Public Property | MaximumTotalPointCount | Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.
Public Property | PageBreak | Gets or sets the page break.
Public Property | PageName | Specifies value to use for the name of a paginated page.
Public Property | ShadowIntensity | Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.
Public Property | TextAntiAliasingQuality | Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of the values in TextAntiAliasingQuality. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.
Public Property | TileLanguage | Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.
Top

See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : AccessibleDescription Property

Glossary Item Box

Gets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


ActionInfo Property

[image]
ActiveReports 19 .NET Edition
ActionInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : ActionInfo Property

Glossary Item Box

Gets or sets the map action info.

Syntax

Visual Basic (Declaration)
Public Property ActionInfo As ActionInfo
C#
public ActionInfo ActionInfo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


AntiAliasing Property

[image]
ActiveReports 19 .NET Edition
AntiAliasing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : AntiAliasing Property

Glossary Item Box

Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.

Syntax

Visual Basic (Declaration)
Public Property AntiAliasing As ExpressionInfo
C#
public ExpressionInfo AntiAliasing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


DocumentMapLabel Property

[image]
ActiveReports 19 .NET Edition
DocumentMapLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : DocumentMapLabel Property

Glossary Item Box

Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.

Syntax

Visual Basic (Declaration)
Public Property DocumentMapLabel As ExpressionInfo
C#
public ExpressionInfo DocumentMapLabel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapBorderSkin Property

[image]
ActiveReports 19 .NET Edition
MapBorderSkin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapBorderSkin Property

Glossary Item Box

Gets or sets the map border skin.

Syntax

Visual Basic (Declaration)
Public Property MapBorderSkin As MapBorderSkin
C#
public MapBorderSkin MapBorderSkin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapColorScale Property

[image]
ActiveReports 19 .NET Edition
MapColorScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapColorScale Property

Glossary Item Box

Gets or sets the map color scale.

Syntax

Visual Basic (Declaration)
Public Property MapColorScale As MapColorScale
C#
public MapColorScale MapColorScale {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapDataRegions Property

[image]
ActiveReports 19 .NET Edition
MapDataRegions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapDataRegions Property

Glossary Item Box

Gets the map data regions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapDataRegions As IList(Of MapDataRegion)
C#
public IList<MapDataRegion> MapDataRegions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapDistanceScale Property

[image]
ActiveReports 19 .NET Edition
MapDistanceScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapDistanceScale Property

Glossary Item Box

Gets or sets the map distance scale.

Syntax

Visual Basic (Declaration)
Public Property MapDistanceScale As MapDistanceScale
C#
public MapDistanceScale MapDistanceScale {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapLayers Property

[image]
ActiveReports 19 .NET Edition
MapLayers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapLayers Property

Glossary Item Box

Gets the map layers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapLayers As IList(Of MapLayer)
C#
public IList<MapLayer> MapLayers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapLegends Property

[image]
ActiveReports 19 .NET Edition
MapLegends Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapLegends Property

Glossary Item Box

Gets the map legends.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapLegends As IList(Of MapLegend)
C#
public IList<MapLegend> MapLegends {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapTitles Property

[image]
ActiveReports 19 .NET Edition
MapTitles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapTitles Property

Glossary Item Box

Gets the map titles.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapTitles As IList(Of MapTitle)
C#
public IList<MapTitle> MapTitles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MapViewport Property

[image]
ActiveReports 19 .NET Edition
MapViewport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapViewport Property

Glossary Item Box

Gets or sets the map viewport.

Syntax

Visual Basic (Declaration)
Public Property MapViewport As MapViewport
C#
public MapViewport MapViewport {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MaximumSpatialElementCount Property

[image]
ActiveReports 19 .NET Edition
MaximumSpatialElementCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MaximumSpatialElementCount Property

Glossary Item Box

Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.

Syntax

Visual Basic (Declaration)
Public Property MaximumSpatialElementCount As Integer
C#
public int MaximumSpatialElementCount {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


MaximumTotalPointCount Property

[image]
ActiveReports 19 .NET Edition
MaximumTotalPointCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MaximumTotalPointCount Property

Glossary Item Box

Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.

Syntax

Visual Basic (Declaration)
Public Property MaximumTotalPointCount As Integer
C#
public int MaximumTotalPointCount {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : PageBreak Property

Glossary Item Box

Gets or sets the page break.

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
C#
public PageBreak PageBreak {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : PageName Property

Glossary Item Box

Specifies value to use for the name of a paginated page.

Syntax

Visual Basic (Declaration)
Public Property PageName As ExpressionInfo
C#
public ExpressionInfo PageName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


ShadowIntensity Property

[image]
ActiveReports 19 .NET Edition
ShadowIntensity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : ShadowIntensity Property

Glossary Item Box

Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.

Syntax

Visual Basic (Declaration)
Public Property ShadowIntensity As ExpressionInfo
C#
public ExpressionInfo ShadowIntensity {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


TextAntiAliasingQuality Property

[image]
ActiveReports 19 .NET Edition
TextAntiAliasingQuality Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : TextAntiAliasingQuality Property

Glossary Item Box

Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of the values in TextAntiAliasingQuality. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.

Syntax

Visual Basic (Declaration)
Public Property TextAntiAliasingQuality As ExpressionInfo
C#
public ExpressionInfo TextAntiAliasingQuality {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


TileLanguage Property

[image]
ActiveReports 19 .NET Edition
TileLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : TileLanguage Property

Glossary Item Box

Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.

Syntax

Visual Basic (Declaration)
Public Property TileLanguage As ExpressionInfo
C#
public ExpressionInfo TileLanguage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map Class
Map Members


Map.Defaults Class

[image]
ActiveReports 19 .NET Edition
Map.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map.Defaults Class

Glossary Item Box

Contains default values for map properties.

Object Model

Map.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Map.Defaults
C#
public static class Map.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Map.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


Map.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
Map.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map.Defaults Class

Glossary Item Box

The following tables list the members exposed by Map.Defaults.

Public Fields

 | Name | Description
Public Field | AntiAliasing | Default anti-aliasing
Public Field | MaximumSpatialElementCount | Default maximum spatial element count
Public Field | MaximumTotalPointCount | Default maximum total point count
Public Field | ShadowIntensity | Default shadow intensity
Public Field | TextAntiAliasingQuality | Default text anti-aliasing quality
Public Field | TileLanguage | Default tile language
Top

See Also

Reference

Map.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


Map.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
Map.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map.Defaults Class

Glossary Item Box

For a list of all members of this type, see Map.Defaults members.

Public Fields

 | Name | Description
Public Field | AntiAliasing | Default anti-aliasing
Public Field | MaximumSpatialElementCount | Default maximum spatial element count
Public Field | MaximumTotalPointCount | Default maximum total point count
Public Field | ShadowIntensity | Default shadow intensity
Public Field | TextAntiAliasingQuality | Default text anti-aliasing quality
Public Field | TileLanguage | Default tile language
Top

See Also

Reference

Map.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


AntiAliasing Field

[image]
ActiveReports 19 .NET Edition
AntiAliasing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : AntiAliasing Field

Glossary Item Box

Default anti-aliasing

Syntax

Visual Basic (Declaration)
Public Const AntiAliasing As AntiAliasing
C#
public const AntiAliasing AntiAliasing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


MaximumSpatialElementCount Field

[image]
ActiveReports 19 .NET Edition
MaximumSpatialElementCount Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : MaximumSpatialElementCount Field

Glossary Item Box

Default maximum spatial element count

Syntax

Visual Basic (Declaration)
Public Const MaximumSpatialElementCount As Integer
C#
public const int MaximumSpatialElementCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


MaximumTotalPointCount Field

[image]
ActiveReports 19 .NET Edition
MaximumTotalPointCount Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : MaximumTotalPointCount Field

Glossary Item Box

Default maximum total point count

Syntax

Visual Basic (Declaration)
Public Const MaximumTotalPointCount As Integer
C#
public const int MaximumTotalPointCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


ShadowIntensity Field

[image]
ActiveReports 19 .NET Edition
ShadowIntensity Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : ShadowIntensity Field

Glossary Item Box

Default shadow intensity

Syntax

Visual Basic (Declaration)
Public Const ShadowIntensity As Double
C#
public const double ShadowIntensity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


TextAntiAliasingQuality Field

[image]
ActiveReports 19 .NET Edition
TextAntiAliasingQuality Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : TextAntiAliasingQuality Field

Glossary Item Box

Default text anti-aliasing quality

Syntax

Visual Basic (Declaration)
Public Const TextAntiAliasingQuality As TextAntiAliasingQuality
C#
public const TextAntiAliasingQuality TextAntiAliasingQuality

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


TileLanguage Field

[image]
ActiveReports 19 .NET Edition
TileLanguage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map.Defaults Class : TileLanguage Field

Glossary Item Box

Default tile language

Syntax

Visual Basic (Declaration)
Public Const TileLanguage As String
C#
public const string TileLanguage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Map.Defaults Class
Map.Defaults Members


MapAppearanceRule Class

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

Glossary Item Box

Defines the appearance rule for spatial elements based on a data field

Object Model

MapAppearanceRule Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapAppearanceRule
C#
public abstract class MapAppearanceRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapMarkerRule
GrapeCity.ActiveReports.PageReportModel.MapSizeRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule Class Members

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

Glossary Item Box

The following tables list the members exposed by MapAppearanceRule.

Public Properties

 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is Custom or if DataValue is not Scalar. An expression should evaluate to an System.Int32. The default value is 5
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of the values in MapRuleDistributionType. The default value is MapRuleDistributionType.Optimal.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.
Public Property | LegendName | Name of the legend in which the data field will appear.
Public Property | LegendText | Label to use in the legend for the data field.
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = Custom, otherwise ignored.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Gets the expressions.
Top

See Also

Reference

MapAppearanceRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule Class Methods

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

Glossary Item Box

For a list of all members of this type, see MapAppearanceRule members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Gets the expressions.
Top

See Also

Reference

MapAppearanceRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : GetExpressions Method

Glossary Item Box

Gets the expressions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetExpressions() As IEnumerable(Of ExpressionInfo)
C#
public virtual IEnumerable<ExpressionInfo> GetExpressions()

Return Value

System.Collections.Generic.IEnumerable<GrapeCity.ActiveReports.Expressions.ExpressionInfo>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


MapAppearanceRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

Glossary Item Box

For a list of all members of this type, see MapAppearanceRule members.

Public Properties

 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is Custom or if DataValue is not Scalar. An expression should evaluate to an System.Int32. The default value is 5
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of the values in MapRuleDistributionType. The default value is MapRuleDistributionType.Optimal.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.
Public Property | LegendName | Name of the legend in which the data field will appear.
Public Property | LegendText | Label to use in the legend for the data field.
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = Custom, otherwise ignored.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.
Top

See Also

Reference

MapAppearanceRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


BucketCount Property

[image]
ActiveReports 19 .NET Edition
BucketCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : BucketCount Property

Glossary Item Box

Defines the number of buckets for the specified distribution. Ignored if DistributionType is Custom or if DataValue is not Scalar. An expression should evaluate to an System.Int32. The default value is 5

Syntax

Visual Basic (Declaration)
Public Property BucketCount As ExpressionInfo
C#
public ExpressionInfo BucketCount {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataElementName Property

Glossary Item Box

The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataElementOutput Property

Glossary Item Box

Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataValue Property

[image]
ActiveReports 19 .NET Edition
DataValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataValue Property

Glossary Item Box

An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.

Syntax

Visual Basic (Declaration)
Public Property DataValue As ExpressionInfo
C#
public ExpressionInfo DataValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DistributionType Property

[image]
ActiveReports 19 .NET Edition
DistributionType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DistributionType Property

Glossary Item Box

Gets or sets the distribution type. That evaluates to one of the values in MapRuleDistributionType. The default value is MapRuleDistributionType.Optimal.

Syntax

Visual Basic (Declaration)
Public Property DistributionType As ExpressionInfo
C#
public ExpressionInfo DistributionType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


EndValue Property

[image]
ActiveReports 19 .NET Edition
EndValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : EndValue Property

Glossary Item Box

Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.

Syntax

Visual Basic (Declaration)
Public Property EndValue As ExpressionInfo
C#
public ExpressionInfo EndValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


LegendName Property

[image]
ActiveReports 19 .NET Edition
LegendName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : LegendName Property

Glossary Item Box

Name of the legend in which the data field will appear.

Syntax

Visual Basic (Declaration)
Public Property LegendName As String
C#
public string LegendName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


LegendText Property

[image]
ActiveReports 19 .NET Edition
LegendText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : LegendText Property

Glossary Item Box

Label to use in the legend for the data field.

Syntax

Visual Basic (Declaration)
Public Property LegendText As ExpressionInfo
C#
public ExpressionInfo LegendText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


MapBuckets Property

[image]
ActiveReports 19 .NET Edition
MapBuckets Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : MapBuckets Property

Glossary Item Box

Gets the set of buckets used to distribute the data. Mandatory if DistributionType = Custom, otherwise ignored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapBuckets As IList(Of MapBucket)
C#
public IList<MapBucket> MapBuckets {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


StartValue Property

[image]
ActiveReports 19 .NET Edition
StartValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : StartValue Property

Glossary Item Box

Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = Custom.

Syntax

Visual Basic (Declaration)
Public Property StartValue As ExpressionInfo
C#
public ExpressionInfo StartValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


MapAppearanceRule.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule.Defaults Class

Glossary Item Box

Contains default values for MapAppearanceRule's properties.

Object Model

MapAppearanceRule.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapAppearanceRule.Defaults
C#
public static class MapAppearanceRule.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapAppearanceRule.Defaults.

Public Fields

 | Name | Description
Public Field | BucketCount | Default BucketCount
Public Field | DataElementOutput | Default DataElementOutput
Public Field | DistributionType | Default DistributionType
Public Field | LegendText | Default LegendText
Top

See Also

Reference

MapAppearanceRule.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapAppearanceRule.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapAppearanceRule.Defaults members.

Public Fields

 | Name | Description
Public Field | BucketCount | Default BucketCount
Public Field | DataElementOutput | Default DataElementOutput
Public Field | DistributionType | Default DistributionType
Public Field | LegendText | Default LegendText
Top

See Also

Reference

MapAppearanceRule.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


BucketCount Field

[image]
ActiveReports 19 .NET Edition
BucketCount Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule.Defaults Class : BucketCount Field

Glossary Item Box

Default BucketCount

Syntax

Visual Basic (Declaration)
Public Const BucketCount As Integer
C#
public const int BucketCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule.Defaults Class
MapAppearanceRule.Defaults Members


DataElementOutput Field

[image]
ActiveReports 19 .NET Edition
DataElementOutput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule.Defaults Class : DataElementOutput Field

Glossary Item Box

Default DataElementOutput

Syntax

Visual Basic (Declaration)
Public Const DataElementOutput As DataElementOutput
C#
public const DataElementOutput DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule.Defaults Class
MapAppearanceRule.Defaults Members


DistributionType Field

[image]
ActiveReports 19 .NET Edition
DistributionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule.Defaults Class : DistributionType Field

Glossary Item Box

Default DistributionType

Syntax

Visual Basic (Declaration)
Public Const DistributionType As MapRuleDistributionType
C#
public const MapRuleDistributionType DistributionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule.Defaults Class
MapAppearanceRule.Defaults Members


LegendText Field

[image]
ActiveReports 19 .NET Edition
LegendText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule.Defaults Class : LegendText Field

Glossary Item Box

Default LegendText

Syntax

Visual Basic (Declaration)
Public Const LegendText As String
C#
public const string LegendText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapAppearanceRule.Defaults Class
MapAppearanceRule.Defaults Members


MapBindingFieldPair Class

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPair Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class

Glossary Item Box

Defines a field/expression pairs to be used to bind the map elements within a vector based layer to the data region associated with it

Object Model

MapBindingFieldPair Class

Syntax

Visual Basic (Declaration)
Public Class MapBindingFieldPair
C#
public class MapBindingFieldPair

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBindingFieldPair

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBindingFieldPair Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBindingFieldPair Class Members

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPair Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class

Glossary Item Box

The following tables list the members exposed by MapBindingFieldPair.

Public Constructors

 | Name | Description
Public Constructor | MapBindingFieldPair Constructor |
Top

Public Properties

 | Name | Description
Public Property | BindingExpression | An expression that is evaluated for each inner most group instance and is compared to the field value.
Public Property | FieldName | Gets or sets which map element field to be used for binding.
Top

See Also

Reference

MapBindingFieldPair Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBindingFieldPair Constructor

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPair Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : MapBindingFieldPair Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapBindingFieldPair()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


MapBindingFieldPair Class Properties

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPair Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class

Glossary Item Box

For a list of all members of this type, see MapBindingFieldPair members.

Public Properties

 | Name | Description
Public Property | BindingExpression | An expression that is evaluated for each inner most group instance and is compared to the field value.
Public Property | FieldName | Gets or sets which map element field to be used for binding.
Top

See Also

Reference

MapBindingFieldPair Class
GrapeCity.ActiveReports.PageReportModel Namespace


BindingExpression Property

[image]
ActiveReports 19 .NET Edition
BindingExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : BindingExpression Property

Glossary Item Box

An expression that is evaluated for each inner most group instance and is compared to the field value.

Syntax

Visual Basic (Declaration)
Public Property BindingExpression As ExpressionInfo
C#
public ExpressionInfo BindingExpression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


FieldName Property

[image]
ActiveReports 19 .NET Edition
FieldName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : FieldName Property

Glossary Item Box

Gets or sets which map element field to be used for binding.

Syntax

Visual Basic (Declaration)
Public Property FieldName As ExpressionInfo
C#
public ExpressionInfo FieldName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


MapBorderSkin Class

[image]
ActiveReports 19 .NET Edition
MapBorderSkin Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class

Glossary Item Box

Defines the appearance of the border skin around the map report item

Object Model

MapBorderSkin Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapBorderSkin
C#
public sealed class MapBorderSkin

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBorderSkin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBorderSkin Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin Class Members

[image]
ActiveReports 19 .NET Edition
MapBorderSkin Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class

Glossary Item Box

The following tables list the members exposed by MapBorderSkin.

Public Constructors

 | Name | Description
Public Constructor | MapBorderSkin Constructor | Initializes a new instance of the MapBorderSkin class.
Top

Public Properties

 | Name | Description
Public Property | MapBorderSkinType | Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.
Public Property | Style | Style properties for the border skin. Each of the properties of type Color support transparency.
Top

See Also

Reference

MapBorderSkin Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin Constructor

[image]
ActiveReports 19 .NET Edition
MapBorderSkin Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : MapBorderSkin Constructor

Glossary Item Box

Initializes a new instance of the MapBorderSkin class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapBorderSkin()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


MapBorderSkin Class Properties

[image]
ActiveReports 19 .NET Edition
MapBorderSkin Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class

Glossary Item Box

For a list of all members of this type, see MapBorderSkin members.

Public Properties

 | Name | Description
Public Property | MapBorderSkinType | Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.
Public Property | Style | Style properties for the border skin. Each of the properties of type Color support transparency.
Top

See Also

Reference

MapBorderSkin Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkinType Property

[image]
ActiveReports 19 .NET Edition
MapBorderSkinType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : MapBorderSkinType Property

Glossary Item Box

Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.

Syntax

Visual Basic (Declaration)
Public Property MapBorderSkinType As ExpressionInfo
C#
public ExpressionInfo MapBorderSkinType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : Style Property

Glossary Item Box

Style properties for the border skin. Each of the properties of type Color support transparency.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


MapBucket Class

[image]
ActiveReports 19 .NET Edition
MapBucket Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class

Glossary Item Box

Defines a bucket for custom data distribution

Object Model

MapBucket Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapBucket
C#
public sealed class MapBucket

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBucket

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBucket Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBucket Class Members

[image]
ActiveReports 19 .NET Edition
MapBucket Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class

Glossary Item Box

The following tables list the members exposed by MapBucket.

Public Constructors

 | Name | Description
Public Constructor | MapBucket Constructor |
Top

Public Properties

 | Name | Description
Public Property | EndValue | Gets or sets the end value for the bucket.
Public Property | StartValue | Gets or sets the start value for the bucket
Top

See Also

Reference

MapBucket Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBucket Constructor

[image]
ActiveReports 19 .NET Edition
MapBucket Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : MapBucket Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapBucket()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBucket Class
MapBucket Members


MapBucket Class Properties

[image]
ActiveReports 19 .NET Edition
MapBucket Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class

Glossary Item Box

For a list of all members of this type, see MapBucket members.

Public Properties

 | Name | Description
Public Property | EndValue | Gets or sets the end value for the bucket.
Public Property | StartValue | Gets or sets the start value for the bucket
Top

See Also

Reference

MapBucket Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndValue Property

[image]
ActiveReports 19 .NET Edition
EndValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : EndValue Property

Glossary Item Box

Gets or sets the end value for the bucket.

Syntax

Visual Basic (Declaration)
Public Property EndValue As ExpressionInfo
C#
public ExpressionInfo EndValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBucket Class
MapBucket Members


StartValue Property

[image]
ActiveReports 19 .NET Edition
StartValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : StartValue Property

Glossary Item Box

Gets or sets the start value for the bucket

Syntax

Visual Basic (Declaration)
Public Property StartValue As ExpressionInfo
C#
public ExpressionInfo StartValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapBucket Class
MapBucket Members


MapColorPaletteRule Class

[image]
ActiveReports 19 .NET Edition
MapColorPaletteRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

Glossary Item Box

Defines the color palette for spatial elements based on a data field

Object Model

MapColorPaletteRule Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapColorPaletteRule
   Inherits MapColorRule
C#
public sealed class MapColorPaletteRule : MapColorRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorPaletteRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorPaletteRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPaletteRule Class Members

[image]
ActiveReports 19 .NET Edition
MapColorPaletteRule Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

Glossary Item Box

The following tables list the members exposed by MapColorPaletteRule.

Public Constructors

 | Name | Description
Public Constructor | MapColorPaletteRule Constructor | Initializes a new instance of the MapColorPaletteRule class.
Top

Public Fields

 | Name | Description
Public Field | PaletteDefaultValue | The palette default value
Top

Public Properties

 | Name | Description
Public Property | Palette | Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of the values in MapColorPalette. The default value is MapColorPalette.Random.
Top

See Also

Reference

MapColorPaletteRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPaletteRule Constructor

[image]
ActiveReports 19 .NET Edition
MapColorPaletteRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorPaletteRule Class : MapColorPaletteRule Constructor

Glossary Item Box

Initializes a new instance of the MapColorPaletteRule class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapColorPaletteRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorPaletteRule Class
MapColorPaletteRule Members


MapColorPaletteRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapColorPaletteRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

Glossary Item Box

For a list of all members of this type, see MapColorPaletteRule members.

Public Properties

 | Name | Description
Public Property | Palette | Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of the values in MapColorPalette. The default value is MapColorPalette.Random.
Top

See Also

Reference

MapColorPaletteRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


Palette Property

[image]
ActiveReports 19 .NET Edition
Palette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorPaletteRule Class : Palette Property

Glossary Item Box

Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of the values in MapColorPalette. The default value is MapColorPalette.Random.

Syntax

Visual Basic (Declaration)
Public Property Palette As ExpressionInfo
C#
public ExpressionInfo Palette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorPaletteRule Class
MapColorPaletteRule Members


MapColorPaletteRule Class Fields

[image]
ActiveReports 19 .NET Edition
MapColorPaletteRule Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

Glossary Item Box

For a list of all members of this type, see MapColorPaletteRule members.

Public Fields

 | Name | Description
Public Field | PaletteDefaultValue | The palette default value
Top

See Also

Reference

MapColorPaletteRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


PaletteDefaultValue Field

[image]
ActiveReports 19 .NET Edition
PaletteDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorPaletteRule Class : PaletteDefaultValue Field

Glossary Item Box

The palette default value

Syntax

Visual Basic (Declaration)
Public Const PaletteDefaultValue As String
C#
public const string PaletteDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorPaletteRule Class
MapColorPaletteRule Members


MapColorRangeRule Class

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class

Glossary Item Box

Defines the color ranges for spatial elements based on a data field

Object Model

MapColorRangeRule Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapColorRangeRule
   Inherits MapColorRule
C#
public sealed class MapColorRangeRule : MapColorRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule Class Members

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class

Glossary Item Box

The following tables list the members exposed by MapColorRangeRule.

Public Constructors

 | Name | Description
Public Constructor | MapColorRangeRule Constructor | Initializes a new instance of the MapColorRangeRule class.
Top

Public Properties

 | Name | Description
Public Property | EndColor | Defines the end color to be used for the spatial elements. Default value is Red
Public Property | MiddleColor | Defines the middle color to be used for the spatial elements. Default value is Yellow
Public Property | StartColor | Defines the start color to be used for the spatial elements. Default value is Green
Top

See Also

Reference

MapColorRangeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule Constructor

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : MapColorRangeRule Constructor

Glossary Item Box

Initializes a new instance of the MapColorRangeRule class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapColorRangeRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MapColorRangeRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class

Glossary Item Box

For a list of all members of this type, see MapColorRangeRule members.

Public Properties

 | Name | Description
Public Property | EndColor | Defines the end color to be used for the spatial elements. Default value is Red
Public Property | MiddleColor | Defines the middle color to be used for the spatial elements. Default value is Yellow
Public Property | StartColor | Defines the start color to be used for the spatial elements. Default value is Green
Top

See Also

Reference

MapColorRangeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndColor Property

[image]
ActiveReports 19 .NET Edition
EndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : EndColor Property

Glossary Item Box

Defines the end color to be used for the spatial elements. Default value is Red

Syntax

Visual Basic (Declaration)
Public Property EndColor As ExpressionInfo
C#
public ExpressionInfo EndColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MiddleColor Property

[image]
ActiveReports 19 .NET Edition
MiddleColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : MiddleColor Property

Glossary Item Box

Defines the middle color to be used for the spatial elements. Default value is Yellow

Syntax

Visual Basic (Declaration)
Public Property MiddleColor As ExpressionInfo
C#
public ExpressionInfo MiddleColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


StartColor Property

[image]
ActiveReports 19 .NET Edition
StartColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : StartColor Property

Glossary Item Box

Defines the start color to be used for the spatial elements. Default value is Green

Syntax

Visual Basic (Declaration)
Public Property StartColor As ExpressionInfo
C#
public ExpressionInfo StartColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MapColorRangeRule.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule.Defaults Class

Glossary Item Box

Contains default values for MapColorRangeRule's properties.

Object Model

MapColorRangeRule.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapColorRangeRule.Defaults
C#
public static class MapColorRangeRule.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapColorRangeRule.Defaults.

Public Fields

 | Name | Description
Public Field | EndColor | Default EndColor
Public Field | MiddleColor | Default MiddleColor
Public Field | StartColor | Default StartColor
Top

See Also

Reference

MapColorRangeRule.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapColorRangeRule.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapColorRangeRule.Defaults members.

Public Fields

 | Name | Description
Public Field | EndColor | Default EndColor
Public Field | MiddleColor | Default MiddleColor
Public Field | StartColor | Default StartColor
Top

See Also

Reference

MapColorRangeRule.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndColor Field

[image]
ActiveReports 19 .NET Edition
EndColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule.Defaults Class : EndColor Field

Glossary Item Box

Default EndColor

Syntax

Visual Basic (Declaration)
Public Const EndColor As String
C#
public const string EndColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule.Defaults Class
MapColorRangeRule.Defaults Members


MiddleColor Field

[image]
ActiveReports 19 .NET Edition
MiddleColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule.Defaults Class : MiddleColor Field

Glossary Item Box

Default MiddleColor

Syntax

Visual Basic (Declaration)
Public Const MiddleColor As String
C#
public const string MiddleColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule.Defaults Class
MapColorRangeRule.Defaults Members


StartColor Field

[image]
ActiveReports 19 .NET Edition
StartColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule.Defaults Class : StartColor Field

Glossary Item Box

Default StartColor

Syntax

Visual Basic (Declaration)
Public Const StartColor As String
C#
public const string StartColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRangeRule.Defaults Class
MapColorRangeRule.Defaults Members


MapColorRule Class

[image]
ActiveReports 19 .NET Edition
MapColorRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

Glossary Item Box

Defines the color rule for spatial elements based on a data field.

Object Model

MapColorRule Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapColorRule
   Inherits MapAppearanceRule
C#
public abstract class MapColorRule : MapAppearanceRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorPaletteRule
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule
GrapeCity.ActiveReports.PageReportModel.MapCustomColorRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Class Members

[image]
ActiveReports 19 .NET Edition
MapColorRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

Glossary Item Box

The following tables list the members exposed by MapColorRule.

Public Properties

 | Name | Description
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions.
Top

See Also

Reference

MapColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Class Methods

[image]
ActiveReports 19 .NET Edition
MapColorRule Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

Glossary Item Box

For a list of all members of this type, see MapColorRule members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions.
Top

See Also

Reference

MapColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRule Class : GetExpressions Method

Glossary Item Box

Gets the expressions.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetExpressions() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> GetExpressions()

Return Value

System.Collections.Generic.IEnumerable<GrapeCity.ActiveReports.Expressions.ExpressionInfo>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRule Class
MapColorRule Members


MapColorRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapColorRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

Glossary Item Box

For a list of all members of this type, see MapColorRule members.

Public Properties

 | Name | Description
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


ShowInColorScale Property

[image]
ActiveReports 19 .NET Edition
ShowInColorScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRule Class : ShowInColorScale Property

Glossary Item Box

Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property ShowInColorScale As ExpressionInfo
C#
public ExpressionInfo ShowInColorScale {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorRule Class
MapColorRule Members


MapColorScale Class

[image]
ActiveReports 19 .NET Edition
MapColorScale Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class

Glossary Item Box

Defines the map color scale

Object Model

MapColorScale Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapColorScale
   Inherits MapDockableSubItem
C#
public sealed class MapColorScale : MapDockableSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapColorScale

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale Class Members

[image]
ActiveReports 19 .NET Edition
MapColorScale Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class

Glossary Item Box

The following tables list the members exposed by MapColorScale.

Public Constructors

 | Name | Description
Public Constructor | MapColorScale Constructor | Initializes a new instance of the MapColorScale class.
Top

Public Properties

 | Name | Description
Public Property | ColorBarBorderColor | Gets or sets the border color for the color bar. The default value is Black.
Public Property | HideEndLabels | Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.
Public Property | LabelBehavior | Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.
Public Property | LabelFormat | Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.
Public Property | LabelInterval | Gets or sets the frequency of the labels along the color bar. An expression should evaluate to an System.Int32. The default value is 1.
Public Property | LabelPlacement | Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.
Public Property | MapColorScaleTitle | Gets or sets the title to be displayed for the color scale.
Public Property | NoDataText | Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.
Public Property | RangeGapColor | Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.
Public Property | TickMarkLength | Gets or sets the tick mark length. An expression should evaluate to a Length. The default value is 2.25pt.
Top

See Also

Reference

MapColorScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale Constructor

[image]
ActiveReports 19 .NET Edition
MapColorScale Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : MapColorScale Constructor

Glossary Item Box

Initializes a new instance of the MapColorScale class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapColorScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScale Class Properties

[image]
ActiveReports 19 .NET Edition
MapColorScale Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class

Glossary Item Box

For a list of all members of this type, see MapColorScale members.

Public Properties

 | Name | Description
Public Property | ColorBarBorderColor | Gets or sets the border color for the color bar. The default value is Black.
Public Property | HideEndLabels | Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.
Public Property | LabelBehavior | Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.
Public Property | LabelFormat | Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.
Public Property | LabelInterval | Gets or sets the frequency of the labels along the color bar. An expression should evaluate to an System.Int32. The default value is 1.
Public Property | LabelPlacement | Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.
Public Property | MapColorScaleTitle | Gets or sets the title to be displayed for the color scale.
Public Property | NoDataText | Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.
Public Property | RangeGapColor | Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.
Public Property | TickMarkLength | Gets or sets the tick mark length. An expression should evaluate to a Length. The default value is 2.25pt.
Top

See Also

Reference

MapColorScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColorBarBorderColor Property

[image]
ActiveReports 19 .NET Edition
ColorBarBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : ColorBarBorderColor Property

Glossary Item Box

Gets or sets the border color for the color bar. The default value is Black.

Syntax

Visual Basic (Declaration)
Public Property ColorBarBorderColor As ExpressionInfo
C#
public ExpressionInfo ColorBarBorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


HideEndLabels Property

[image]
ActiveReports 19 .NET Edition
HideEndLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : HideEndLabels Property

Glossary Item Box

Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property HideEndLabels As ExpressionInfo
C#
public ExpressionInfo HideEndLabels {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


LabelBehavior Property

[image]
ActiveReports 19 .NET Edition
LabelBehavior Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelBehavior Property

Glossary Item Box

Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.

Syntax

Visual Basic (Declaration)
Public Property LabelBehavior As ExpressionInfo
C#
public ExpressionInfo LabelBehavior {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


LabelFormat Property

[image]
ActiveReports 19 .NET Edition
LabelFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelFormat Property

Glossary Item Box

Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.

Syntax

Visual Basic (Declaration)
Public Property LabelFormat As ExpressionInfo
C#
public ExpressionInfo LabelFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


LabelInterval Property

[image]
ActiveReports 19 .NET Edition
LabelInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelInterval Property

Glossary Item Box

Gets or sets the frequency of the labels along the color bar. An expression should evaluate to an System.Int32. The default value is 1.

Syntax

Visual Basic (Declaration)
Public Property LabelInterval As ExpressionInfo
C#
public ExpressionInfo LabelInterval {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelPlacement Property

Glossary Item Box

Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.

Syntax

Visual Basic (Declaration)
Public Property LabelPlacement As ExpressionInfo
C#
public ExpressionInfo LabelPlacement {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScaleTitle Property

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : MapColorScaleTitle Property

Glossary Item Box

Gets or sets the title to be displayed for the color scale.

Syntax

Visual Basic (Declaration)
Public Property MapColorScaleTitle As MapColorScaleTitle
C#
public MapColorScaleTitle MapColorScaleTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


NoDataText Property

[image]
ActiveReports 19 .NET Edition
NoDataText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : NoDataText Property

Glossary Item Box

Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property NoDataText As ExpressionInfo
C#
public ExpressionInfo NoDataText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


RangeGapColor Property

[image]
ActiveReports 19 .NET Edition
RangeGapColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : RangeGapColor Property

Glossary Item Box

Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.

Syntax

Visual Basic (Declaration)
Public Property RangeGapColor As ExpressionInfo
C#
public ExpressionInfo RangeGapColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


TickMarkLength Property

[image]
ActiveReports 19 .NET Edition
TickMarkLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : TickMarkLength Property

Glossary Item Box

Gets or sets the tick mark length. An expression should evaluate to a Length. The default value is 2.25pt.

Syntax

Visual Basic (Declaration)
Public Property TickMarkLength As ExpressionInfo
C#
public ExpressionInfo TickMarkLength {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScale.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapColorScale.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.Defaults Class

Glossary Item Box

Contains default values for MapColorScale's properties.

Object Model

MapColorScale.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapColorScale.Defaults
C#
public static class MapColorScale.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapColorScale.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapColorScale.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapColorScale.Defaults.

Public Fields

 | Name | Description
Public Field | ColorBarBorderColor | Default ColorBarBorderColor
static (Shared in Visual Basic) | FontSize | Default FontSize
static (Shared in Visual Basic) | HeightDefaultValue | Default HeightDefaultValue
Public Field | HideEndLabels | Default HideEndLabels
Public Field | LabelBehavior | Default LabelBehavior
Public Field | LabelFormat | Default LabelFormat
Public Field | LabelInterval | Default LabelInterval
Public Field | LabelPlacement | Default LabelPlacement
Public Field | LocationUnit | Default LocationUnit
static (Shared in Visual Basic) | NoDataText | Default NoDataText
Public Field | RangeGapColor | Default RangeGapColor
static (Shared in Visual Basic) | SizeUnitDefaultValue | Default SizeUnitDefaultValue
Public Field | TickMarkLength | Default TickMarkLength
static (Shared in Visual Basic) | Width | Default Width
Top

See Also

Reference

MapColorScale.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapColorScale.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapColorScale.Defaults members.

Public Fields

 | Name | Description
Public Field | ColorBarBorderColor | Default ColorBarBorderColor
static (Shared in Visual Basic) | FontSize | Default FontSize
static (Shared in Visual Basic) | HeightDefaultValue | Default HeightDefaultValue
Public Field | HideEndLabels | Default HideEndLabels
Public Field | LabelBehavior | Default LabelBehavior
Public Field | LabelFormat | Default LabelFormat
Public Field | LabelInterval | Default LabelInterval
Public Field | LabelPlacement | Default LabelPlacement
Public Field | LocationUnit | Default LocationUnit
static (Shared in Visual Basic) | NoDataText | Default NoDataText
Public Field | RangeGapColor | Default RangeGapColor
static (Shared in Visual Basic) | SizeUnitDefaultValue | Default SizeUnitDefaultValue
Public Field | TickMarkLength | Default TickMarkLength
static (Shared in Visual Basic) | Width | Default Width
Top

See Also

Reference

MapColorScale.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColorBarBorderColor Field

[image]
ActiveReports 19 .NET Edition
ColorBarBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : ColorBarBorderColor Field

Glossary Item Box

Default ColorBarBorderColor

Syntax

Visual Basic (Declaration)
Public Const ColorBarBorderColor As String
C#
public const string ColorBarBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


FontSize Field

[image]
ActiveReports 19 .NET Edition
FontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : FontSize Field

Glossary Item Box

Default FontSize

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSize As String
C#
public static readonly string FontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


HeightDefaultValue Field

[image]
ActiveReports 19 .NET Edition
HeightDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : HeightDefaultValue Field

Glossary Item Box

Default HeightDefaultValue

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HeightDefaultValue As String
C#
public static readonly string HeightDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


HideEndLabels Field

[image]
ActiveReports 19 .NET Edition
HideEndLabels Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : HideEndLabels Field

Glossary Item Box

Default HideEndLabels

Syntax

Visual Basic (Declaration)
Public Const HideEndLabels As String
C#
public const string HideEndLabels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


LabelBehavior Field

[image]
ActiveReports 19 .NET Edition
LabelBehavior Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : LabelBehavior Field

Glossary Item Box

Default LabelBehavior

Syntax

Visual Basic (Declaration)
Public Const LabelBehavior As MapColorScale.MapLabelBehavior
C#
public const MapColorScale.MapLabelBehavior LabelBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


LabelFormat Field

[image]
ActiveReports 19 .NET Edition
LabelFormat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : LabelFormat Field

Glossary Item Box

Default LabelFormat

Syntax

Visual Basic (Declaration)
Public Const LabelFormat As String
C#
public const string LabelFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


LabelInterval Field

[image]
ActiveReports 19 .NET Edition
LabelInterval Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : LabelInterval Field

Glossary Item Box

Default LabelInterval

Syntax

Visual Basic (Declaration)
Public Const LabelInterval As Integer
C#
public const int LabelInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


LabelPlacement Field

[image]
ActiveReports 19 .NET Edition
LabelPlacement Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : LabelPlacement Field

Glossary Item Box

Default LabelPlacement

Syntax

Visual Basic (Declaration)
Public Const LabelPlacement As MapColorScale.MapLabelPlacement
C#
public const MapColorScale.MapLabelPlacement LabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


LocationUnit Field

[image]
ActiveReports 19 .NET Edition
LocationUnit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : LocationUnit Field

Glossary Item Box

Default LocationUnit

Syntax

Visual Basic (Declaration)
Public Const LocationUnit As MapUnit
C#
public const MapUnit LocationUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


NoDataText Field

[image]
ActiveReports 19 .NET Edition
NoDataText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : NoDataText Field

Glossary Item Box

Default NoDataText

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NoDataText As String
C#
public static readonly string NoDataText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


RangeGapColor Field

[image]
ActiveReports 19 .NET Edition
RangeGapColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : RangeGapColor Field

Glossary Item Box

Default RangeGapColor

Syntax

Visual Basic (Declaration)
Public Const RangeGapColor As String
C#
public const string RangeGapColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


SizeUnitDefaultValue Field

[image]
ActiveReports 19 .NET Edition
SizeUnitDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : SizeUnitDefaultValue Field

Glossary Item Box

Default SizeUnitDefaultValue

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SizeUnitDefaultValue As MapUnit
C#
public static readonly MapUnit SizeUnitDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


TickMarkLength Field

[image]
ActiveReports 19 .NET Edition
TickMarkLength Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : TickMarkLength Field

Glossary Item Box

Default TickMarkLength

Syntax

Visual Basic (Declaration)
Public Const TickMarkLength As String
C#
public const string TickMarkLength

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


Width Field

[image]
ActiveReports 19 .NET Edition
Width Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale.Defaults Class : Width Field

Glossary Item Box

Default Width

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Width As String
C#
public static readonly string Width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScale.Defaults Class
MapColorScale.Defaults Members


MapColorScaleTitle Class

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

Glossary Item Box

Defines the settings for the title to be displayed within the color scale

Object Model

MapColorScaleTitle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapColorScaleTitle
C#
public sealed class MapColorScaleTitle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapColorScaleTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScaleTitle Class Members

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

Glossary Item Box

The following tables list the members exposed by MapColorScaleTitle.

Public Constructors

 | Name | Description
Public Constructor | MapColorScaleTitle Constructor | Initializes a new instance of the MapColorScaleTitle class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSizeDefaultValue | The font size default value
static (Shared in Visual Basic) | FontWeightDefaultValue | The font weight default value
Top

Public Properties

 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.
Top

See Also

Reference

MapColorScaleTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScaleTitle Constructor

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : MapColorScaleTitle Constructor

Glossary Item Box

Initializes a new instance of the MapColorScaleTitle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapColorScaleTitle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


MapColorScaleTitle Class Properties

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

Glossary Item Box

For a list of all members of this type, see MapColorScaleTitle members.

Public Properties

 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.
Top

See Also

Reference

MapColorScaleTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : Caption Property

Glossary Item Box

Caption of the title. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property Caption As ExpressionInfo
C#
public ExpressionInfo Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : Style Property

Glossary Item Box

Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


MapColorScaleTitle Class Fields

[image]
ActiveReports 19 .NET Edition
MapColorScaleTitle Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

Glossary Item Box

For a list of all members of this type, see MapColorScaleTitle members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSizeDefaultValue | The font size default value
static (Shared in Visual Basic) | FontWeightDefaultValue | The font weight default value
Top

See Also

Reference

MapColorScaleTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


FontSizeDefaultValue Field

[image]
ActiveReports 19 .NET Edition
FontSizeDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : FontSizeDefaultValue Field

Glossary Item Box

The font size default value

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSizeDefaultValue As String
C#
public static readonly string FontSizeDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


FontWeightDefaultValue Field

[image]
ActiveReports 19 .NET Edition
FontWeightDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : FontWeightDefaultValue Field

Glossary Item Box

The font weight default value

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontWeightDefaultValue As String
C#
public static readonly string FontWeightDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


MapCustomColorRule Class

[image]
ActiveReports 19 .NET Edition
MapCustomColorRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class

Glossary Item Box

Defines a set of custom colors for spatial elements based on a data field

Object Model

MapCustomColorRule Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapCustomColorRule
   Inherits MapColorRule
C#
public sealed class MapCustomColorRule : MapColorRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapCustomColorRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomColorRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColorRule Class Members

[image]
ActiveReports 19 .NET Edition
MapCustomColorRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class

Glossary Item Box

The following tables list the members exposed by MapCustomColorRule.

Public Constructors

 | Name | Description
Public Constructor | MapCustomColorRule Constructor | Initializes a new instance of the MapCustomColorRule class.
Top

Public Properties

 | Name | Description
Public Property | MapCustomColors | Gets the custom colors to be used.
Top

See Also

Reference

MapCustomColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColorRule Constructor

[image]
ActiveReports 19 .NET Edition
MapCustomColorRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomColorRule Class : MapCustomColorRule Constructor

Glossary Item Box

Initializes a new instance of the MapCustomColorRule class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapCustomColorRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomColorRule Class
MapCustomColorRule Members


MapCustomColorRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapCustomColorRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class

Glossary Item Box

For a list of all members of this type, see MapCustomColorRule members.

Public Properties

 | Name | Description
Public Property | MapCustomColors | Gets the custom colors to be used.
Top

See Also

Reference

MapCustomColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColors Property

[image]
ActiveReports 19 .NET Edition
MapCustomColors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomColorRule Class : MapCustomColors Property

Glossary Item Box

Gets the custom colors to be used.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapCustomColors As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> MapCustomColors {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomColorRule Class
MapCustomColorRule Members


MapCustomView Class

[image]
ActiveReports 19 .NET Edition
MapCustomView Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

Glossary Item Box

Defines the center of the view port based on an arbitrary center point

Object Model

MapCustomView Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapCustomView
   Inherits MapView
C#
public sealed class MapCustomView : MapView

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapCustomView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomView Class Members

[image]
ActiveReports 19 .NET Edition
MapCustomView Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

Glossary Item Box

The following tables list the members exposed by MapCustomView.

Public Constructors

 | Name | Description
Public Constructor | MapCustomView Constructor | Initializes a new instance of the MapCustomView class.
Top

Public Fields

 | Name | Description
Public Field | CenterXDefaultValue | The center x default value
Public Field | CenterYDefaultValue | The center y default value
Top

Public Properties

 | Name | Description
Public Property | CenterX | X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | CenterY | Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Top

See Also

Reference

MapCustomView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomView Constructor

[image]
ActiveReports 19 .NET Edition
MapCustomView Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : MapCustomView Constructor

Glossary Item Box

Initializes a new instance of the MapCustomView class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapCustomView()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Class
MapCustomView Members


MapCustomView Class Properties

[image]
ActiveReports 19 .NET Edition
MapCustomView Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

Glossary Item Box

For a list of all members of this type, see MapCustomView members.

Public Properties

 | Name | Description
Public Property | CenterX | X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | CenterY | Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Top

See Also

Reference

MapCustomView Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterX Property

[image]
ActiveReports 19 .NET Edition
CenterX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterX Property

Glossary Item Box

X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.

Syntax

Visual Basic (Declaration)
Public Property CenterX As ExpressionInfo
C#
public ExpressionInfo CenterX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Class
MapCustomView Members


CenterY Property

[image]
ActiveReports 19 .NET Edition
CenterY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterY Property

Glossary Item Box

Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.

Syntax

Visual Basic (Declaration)
Public Property CenterY As ExpressionInfo
C#
public ExpressionInfo CenterY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Class
MapCustomView Members


MapCustomView Class Fields

[image]
ActiveReports 19 .NET Edition
MapCustomView Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

Glossary Item Box

For a list of all members of this type, see MapCustomView members.

Public Fields

 | Name | Description
Public Field | CenterXDefaultValue | The center x default value
Public Field | CenterYDefaultValue | The center y default value
Top

See Also

Reference

MapCustomView Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterXDefaultValue Field

[image]
ActiveReports 19 .NET Edition
CenterXDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterXDefaultValue Field

Glossary Item Box

The center x default value

Syntax

Visual Basic (Declaration)
Public Const CenterXDefaultValue As Double
C#
public const double CenterXDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Class
MapCustomView Members


CenterYDefaultValue Field

[image]
ActiveReports 19 .NET Edition
CenterYDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterYDefaultValue Field

Glossary Item Box

The center y default value

Syntax

Visual Basic (Declaration)
Public Const CenterYDefaultValue As Double
C#
public const double CenterYDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapCustomView Class
MapCustomView Members


MapDataBoundView Class

[image]
ActiveReports 19 .NET Edition
MapDataBoundView Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataBoundView Class

Glossary Item Box

Defines the center/zoom of the view port based on the spatial map elements bound to data

Object Model

MapDataBoundView Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapDataBoundView
   Inherits MapView
C#
public sealed class MapDataBoundView : MapView

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapDataBoundView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataBoundView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataBoundView Class Members

[image]
ActiveReports 19 .NET Edition
MapDataBoundView Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataBoundView Class

Glossary Item Box

The following tables list the members exposed by MapDataBoundView.

Public Constructors

 | Name | Description
Public Constructor | MapDataBoundView Constructor | Initializes a new instance of the MapDataBoundView class.
Top

See Also

Reference

MapDataBoundView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataBoundView Constructor

[image]
ActiveReports 19 .NET Edition
MapDataBoundView Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataBoundView Class : MapDataBoundView Constructor

Glossary Item Box

Initializes a new instance of the MapDataBoundView class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapDataBoundView()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataBoundView Class
MapDataBoundView Members


MapDataRegion Class

[image]
ActiveReports 19 .NET Edition
MapDataRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class

Glossary Item Box

Defines a data region for the map

Object Model

MapDataRegion Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapDataRegion
C#
public sealed class MapDataRegion

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapDataRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataRegion Class Members

[image]
ActiveReports 19 .NET Edition
MapDataRegion Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class

Glossary Item Box

The following tables list the members exposed by MapDataRegion.

Public Constructors

 | Name | Description
Public Constructor | MapDataRegion Constructor | Initializes a new instance of the MapDataRegion class.
Top

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use for this data region.
Public Property | Filters | Gets filters to apply to each row of data in the data region.
Public Property | MapMember | Gets or sets group, and filter behavior for the data.
Public Property | Name | Gets or sets the map's name
Top

See Also

Reference

MapDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataRegion Constructor

[image]
ActiveReports 19 .NET Edition
MapDataRegion Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : MapDataRegion Constructor

Glossary Item Box

Initializes a new instance of the MapDataRegion class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapDataRegion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapDataRegion Class Properties

[image]
ActiveReports 19 .NET Edition
MapDataRegion Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class

Glossary Item Box

For a list of all members of this type, see MapDataRegion members.

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use for this data region.
Public Property | Filters | Gets filters to apply to each row of data in the data region.
Public Property | MapMember | Gets or sets group, and filter behavior for the data.
Public Property | Name | Gets or sets the map's name
Top

See Also

Reference

MapDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : DataSetName Property

Glossary Item Box

Gets or sets which data set to use for this data region.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As String
C#
public string DataSetName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Class
MapDataRegion Members


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : Filters Property

Glossary Item Box

Gets filters to apply to each row of data in the data region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter)
C#
public IList<Filter> Filters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapMember Property

[image]
ActiveReports 19 .NET Edition
MapMember Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : MapMember Property

Glossary Item Box

Gets or sets group, and filter behavior for the data.

Syntax

Visual Basic (Declaration)
Public Property MapMember As MapMember
C#
public MapMember MapMember {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Class
MapDataRegion Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : Name Property

Glossary Item Box

Gets or sets the map's name

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapDistanceScale Class

[image]
ActiveReports 19 .NET Edition
MapDistanceScale Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class

Glossary Item Box

Defines the map distance scale

Object Model

MapDistanceScale Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapDistanceScale
   Inherits MapDockableSubItem
C#
public sealed class MapDistanceScale : MapDockableSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale Class Members

[image]
ActiveReports 19 .NET Edition
MapDistanceScale Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class

Glossary Item Box

The following tables list the members exposed by MapDistanceScale.

Public Constructors

 | Name | Description
Public Constructor | MapDistanceScale Constructor | Initializes a new instance of the MapDistanceScale class.
Top

Public Properties

 | Name | Description
Public Property | ScaleBorderColor | Defines the border color for the scale. Default value is DarkGray
Public Property | ScaleColor | Gets or sets the color for the scale. Default value is White
Top

See Also

Reference

MapDistanceScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale Constructor

[image]
ActiveReports 19 .NET Edition
MapDistanceScale Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : MapDistanceScale Constructor

Glossary Item Box

Initializes a new instance of the MapDistanceScale class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapDistanceScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


MapDistanceScale Class Properties

[image]
ActiveReports 19 .NET Edition
MapDistanceScale Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class

Glossary Item Box

For a list of all members of this type, see MapDistanceScale members.

Public Properties

 | Name | Description
Public Property | ScaleBorderColor | Defines the border color for the scale. Default value is DarkGray
Public Property | ScaleColor | Gets or sets the color for the scale. Default value is White
Top

See Also

Reference

MapDistanceScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


ScaleBorderColor Property

[image]
ActiveReports 19 .NET Edition
ScaleBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : ScaleBorderColor Property

Glossary Item Box

Defines the border color for the scale. Default value is DarkGray

Syntax

Visual Basic (Declaration)
Public Property ScaleBorderColor As ExpressionInfo
C#
public ExpressionInfo ScaleBorderColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


ScaleColor Property

[image]
ActiveReports 19 .NET Edition
ScaleColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : ScaleColor Property

Glossary Item Box

Gets or sets the color for the scale. Default value is White

Syntax

Visual Basic (Declaration)
Public Property ScaleColor As ExpressionInfo
C#
public ExpressionInfo ScaleColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


MapDistanceScale.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapDistanceScale.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale.Defaults Class

Glossary Item Box

Contains default values for MapDistanceScale's properties.

Object Model

MapDistanceScale.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapDistanceScale.Defaults
C#
public static class MapDistanceScale.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapDistanceScale.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapDistanceScale.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSize | Default FontSize
static (Shared in Visual Basic) | Height | Default Height
Public Field | ScaleBorderColor | Default ScaleBorderColor
Public Field | ScaleColor | Default ScaleColor
static (Shared in Visual Basic) | SizeUnit | Default SizeUnit
static (Shared in Visual Basic) | Width | Default Width
Top

See Also

Reference

MapDistanceScale.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapDistanceScale.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapDistanceScale.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSize | Default FontSize
static (Shared in Visual Basic) | Height | Default Height
Public Field | ScaleBorderColor | Default ScaleBorderColor
Public Field | ScaleColor | Default ScaleColor
static (Shared in Visual Basic) | SizeUnit | Default SizeUnit
static (Shared in Visual Basic) | Width | Default Width
Top

See Also

Reference

MapDistanceScale.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


FontSize Field

[image]
ActiveReports 19 .NET Edition
FontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : FontSize Field

Glossary Item Box

Default FontSize

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSize As String
C#
public static readonly string FontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


Height Field

[image]
ActiveReports 19 .NET Edition
Height Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : Height Field

Glossary Item Box

Default Height

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Height As String
C#
public static readonly string Height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


ScaleBorderColor Field

[image]
ActiveReports 19 .NET Edition
ScaleBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : ScaleBorderColor Field

Glossary Item Box

Default ScaleBorderColor

Syntax

Visual Basic (Declaration)
Public Const ScaleBorderColor As String
C#
public const string ScaleBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


ScaleColor Field

[image]
ActiveReports 19 .NET Edition
ScaleColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : ScaleColor Field

Glossary Item Box

Default ScaleColor

Syntax

Visual Basic (Declaration)
Public Const ScaleColor As String
C#
public const string ScaleColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


SizeUnit Field

[image]
ActiveReports 19 .NET Edition
SizeUnit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : SizeUnit Field

Glossary Item Box

Default SizeUnit

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SizeUnit As String
C#
public static readonly string SizeUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


Width Field

[image]
ActiveReports 19 .NET Edition
Width Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale.Defaults Class : Width Field

Glossary Item Box

Default Width

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Width As String
C#
public static readonly string Width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDistanceScale.Defaults Class
MapDistanceScale.Defaults Members


MapDockableSubItem Class

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class

Glossary Item Box

Defines the common properties for map dockable sub items

Object Model

MapDockableSubItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapDockableSubItem
   Inherits MapSubItem
C#
public abstract class MapDockableSubItem : MapSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapColorScale
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale
GrapeCity.ActiveReports.PageReportModel.MapLegend
GrapeCity.ActiveReports.PageReportModel.MapTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem Class Members

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class

Glossary Item Box

The following tables list the members exposed by MapDockableSubItem.

Public Properties

 | Name | Description
Public Property | ActionInfo | Actions for the map sub item.
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String.
Top

See Also

Reference

MapDockableSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem Class Properties

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class

Glossary Item Box

For a list of all members of this type, see MapDockableSubItem members.

Public Properties

 | Name | Description
Public Property | ActionInfo | Actions for the map sub item.
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String.
Top

See Also

Reference

MapDockableSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property

[image]
ActiveReports 19 .NET Edition
ActionInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : ActionInfo Property

Glossary Item Box

Actions for the map sub item.

Syntax

Visual Basic (Declaration)
Public Property ActionInfo As ActionInfo
C#
public ActionInfo ActionInfo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


DockOutsideViewport Property

[image]
ActiveReports 19 .NET Edition
DockOutsideViewport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : DockOutsideViewport Property

Glossary Item Box

Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property DockOutsideViewport As ExpressionInfo
C#
public ExpressionInfo DockOutsideViewport {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : Hidden Property

Glossary Item Box

Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : Position Property

Glossary Item Box

The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.

Syntax

Visual Basic (Declaration)
Public Property Position As ExpressionInfo
C#
public ExpressionInfo Position {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : ToolTip Property

Glossary Item Box

Tool tip to display for the map sub item. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As ExpressionInfo
C#
public ExpressionInfo ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


MapDockableSubItem.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem.Defaults Class

Glossary Item Box

Contains default values for MapDockableSubItem's properties.

Object Model

MapDockableSubItem.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapDockableSubItem.Defaults
C#
public static class MapDockableSubItem.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapDockableSubItem.Defaults.

Public Fields

 | Name | Description
Public Field | DockOutsideViewport | Default DockOutsideViewport
Public Field | Hidden | Default Hidden
Public Field | Position | Default Position
Public Field | Tooltip | Default Tooltip
Top

See Also

Reference

MapDockableSubItem.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapDockableSubItem.Defaults members.

Public Fields

 | Name | Description
Public Field | DockOutsideViewport | Default DockOutsideViewport
Public Field | Hidden | Default Hidden
Public Field | Position | Default Position
Public Field | Tooltip | Default Tooltip
Top

See Also

Reference

MapDockableSubItem.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


DockOutsideViewport Field

[image]
ActiveReports 19 .NET Edition
DockOutsideViewport Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem.Defaults Class : DockOutsideViewport Field

Glossary Item Box

Default DockOutsideViewport

Syntax

Visual Basic (Declaration)
Public Const DockOutsideViewport As Boolean
C#
public const bool DockOutsideViewport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem.Defaults Class
MapDockableSubItem.Defaults Members


Hidden Field

[image]
ActiveReports 19 .NET Edition
Hidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem.Defaults Class : Hidden Field

Glossary Item Box

Default Hidden

Syntax

Visual Basic (Declaration)
Public Const Hidden As Boolean
C#
public const bool Hidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem.Defaults Class
MapDockableSubItem.Defaults Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem.Defaults Class : Position Field

Glossary Item Box

Default Position

Syntax

Visual Basic (Declaration)
Public Const Position As MapDockableSubItem.MapPosition
C#
public const MapDockableSubItem.MapPosition Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem.Defaults Class
MapDockableSubItem.Defaults Members


Tooltip Field

[image]
ActiveReports 19 .NET Edition
Tooltip Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem.Defaults Class : Tooltip Field

Glossary Item Box

Default Tooltip

Syntax

Visual Basic (Declaration)
Public Const Tooltip As String
C#
public const string Tooltip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDockableSubItem.Defaults Class
MapDockableSubItem.Defaults Members


MapElementView Class

[image]
ActiveReports 19 .NET Edition
MapElementView Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class

Glossary Item Box

Defines the center/zoom of the view port based on map spatial element

Object Model

MapElementView Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapElementView
   Inherits MapView
C#
public sealed class MapElementView : MapView

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapElementView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapElementView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapElementView Class Members

[image]
ActiveReports 19 .NET Edition
MapElementView Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class

Glossary Item Box

The following tables list the members exposed by MapElementView.

Public Constructors

 | Name | Description
Public Constructor | MapElementView Constructor | Initializes a new instance of the MapElementView class.
Top

Public Properties

 | Name | Description
Public Property | LayerName | Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.
Public Property | MapBindingFieldPairs | Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.
Top

See Also

Reference

MapElementView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapElementView Constructor

[image]
ActiveReports 19 .NET Edition
MapElementView Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : MapElementView Constructor

Glossary Item Box

Initializes a new instance of the MapElementView class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapElementView()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapElementView Class
MapElementView Members


MapElementView Class Properties

[image]
ActiveReports 19 .NET Edition
MapElementView Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class

Glossary Item Box

For a list of all members of this type, see MapElementView members.

Public Properties

 | Name | Description
Public Property | LayerName | Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.
Public Property | MapBindingFieldPairs | Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.
Top

See Also

Reference

MapElementView Class
GrapeCity.ActiveReports.PageReportModel Namespace


LayerName Property

[image]
ActiveReports 19 .NET Edition
LayerName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : LayerName Property

Glossary Item Box

Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property LayerName As ExpressionInfo
C#
public ExpressionInfo LayerName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapElementView Class
MapElementView Members


MapBindingFieldPairs Property

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPairs Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : MapBindingFieldPairs Property

Glossary Item Box

Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapBindingFieldPairs As IList(Of MapBindingFieldPair)
C#
public IList<MapBindingFieldPair> MapBindingFieldPairs {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapElementView Class
MapElementView Members


MapField Class

[image]
ActiveReports 19 .NET Edition
MapField Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class

Glossary Item Box

Defines a field for map elements within a static layer

Object Model

MapField Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapField
C#
public sealed class MapField

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapField Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapField Class Members

[image]
ActiveReports 19 .NET Edition
MapField Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class

Glossary Item Box

The following tables list the members exposed by MapField.

Public Constructors

 | Name | Description
Public Constructor | MapField Constructor | Initializes a new instance of the MapField class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Value | Gets or sets the field value.
Top

See Also

Reference

MapField Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapField Constructor

[image]
ActiveReports 19 .NET Edition
MapField Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : MapField Constructor

Glossary Item Box

Initializes a new instance of the MapField class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapField()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapField Class
MapField Members


MapField Class Properties

[image]
ActiveReports 19 .NET Edition
MapField Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class

Glossary Item Box

For a list of all members of this type, see MapField members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Value | Gets or sets the field value.
Top

See Also

Reference

MapField Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : Name Property

Glossary Item Box

Gets or sets the field name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapField Class
MapField Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : Value Property

Glossary Item Box

Gets or sets the field value.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapField Class
MapField Members


MapFieldDefinition Class

[image]
ActiveReports 19 .NET Edition
MapFieldDefinition Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class

Glossary Item Box

Defines a field definition for map elements within a static layer

Object Model

MapFieldDefinition Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapFieldDefinition
C#
public sealed class MapFieldDefinition

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapFieldDefinition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapFieldDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldDefinition Class Members

[image]
ActiveReports 19 .NET Edition
MapFieldDefinition Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class

Glossary Item Box

The following tables list the members exposed by MapFieldDefinition.

Public Constructors

 | Name | Description
Public Constructor | MapFieldDefinition Constructor | Initializes a new instance of the MapFieldDefinition class.
Top

Public Properties

 | Name | Description
Public Property | DataType | The data type of the field. That evaluates to one of MapDataType.
Public Property | Name | Gets or sets the field name.
Top

See Also

Reference

MapFieldDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldDefinition Constructor

[image]
ActiveReports 19 .NET Edition
MapFieldDefinition Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : MapFieldDefinition Constructor

Glossary Item Box

Initializes a new instance of the MapFieldDefinition class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapFieldDefinition()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


MapFieldDefinition Class Properties

[image]
ActiveReports 19 .NET Edition
MapFieldDefinition Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class

Glossary Item Box

For a list of all members of this type, see MapFieldDefinition members.

Public Properties

 | Name | Description
Public Property | DataType | The data type of the field. That evaluates to one of MapDataType.
Public Property | Name | Gets or sets the field name.
Top

See Also

Reference

MapFieldDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataType Property

[image]
ActiveReports 19 .NET Edition
DataType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : DataType Property

Glossary Item Box

The data type of the field. That evaluates to one of MapDataType.

Syntax

Visual Basic (Declaration)
Public Property DataType As MapDataType
C#
public MapDataType DataType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : Name Property

Glossary Item Box

Gets or sets the field name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


MapGridLines Class

[image]
ActiveReports 19 .NET Edition
MapGridLines Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class

Glossary Item Box

Defines the properties for map grid (meridians/parallels)

Object Model

MapGridLines Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapGridLines
C#
public sealed class MapGridLines

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapGridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines Class Members

[image]
ActiveReports 19 .NET Edition
MapGridLines Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class

Glossary Item Box

The following tables list the members exposed by MapGridLines.

Public Constructors

 | Name | Description
Public Constructor | MapGridLines Constructor | Initializes a new instance of the MapGridLines class.
Top

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.
Public Property | Interval | Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | LabelPosition | Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.
Public Property | ShowLabels | Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.
Public Property | Style | Gets or sets the style.
Top

See Also

Reference

MapGridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines Constructor

[image]
ActiveReports 19 .NET Edition
MapGridLines Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : MapGridLines Constructor

Glossary Item Box

Initializes a new instance of the MapGridLines class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapGridLines()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


MapGridLines Class Properties

[image]
ActiveReports 19 .NET Edition
MapGridLines Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class

Glossary Item Box

For a list of all members of this type, see MapGridLines members.

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.
Public Property | Interval | Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | LabelPosition | Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.
Public Property | ShowLabels | Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.
Public Property | Style | Gets or sets the style.
Top

See Also

Reference

MapGridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Hidden Property

Glossary Item Box

Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


Interval Property

[image]
ActiveReports 19 .NET Edition
Interval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Interval Property

Glossary Item Box

Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property Interval As ExpressionInfo
C#
public ExpressionInfo Interval {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


LabelPosition Property

[image]
ActiveReports 19 .NET Edition
LabelPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : LabelPosition Property

Glossary Item Box

Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.

Syntax

Visual Basic (Declaration)
Public Property LabelPosition As ExpressionInfo
C#
public ExpressionInfo LabelPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


ShowLabels Property

[image]
ActiveReports 19 .NET Edition
ShowLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : ShowLabels Property

Glossary Item Box

Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property ShowLabels As ExpressionInfo
C#
public ExpressionInfo ShowLabels {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Style Property

Glossary Item Box

Gets or sets the style.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

The style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines Class
MapGridLines Members


MapGridLines.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapGridLines.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines.Defaults Class

Glossary Item Box

Contains default values for MapGridLines' properties.

Object Model

MapGridLines.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapGridLines.Defaults
C#
public static class MapGridLines.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapGridLines.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapGridLines.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapGridLines.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BorderColor | Default BorderColor
static (Shared in Visual Basic) | FontSize | Default FontSize
Public Field | Hidden | Default Hidden
Public Field | Interval | Default Interval
static (Shared in Visual Basic) | LabelColor | Default LabelColor
Public Field | LabelPosition | Default LabelPosition
Public Field | ShowLabels | Default ShowLabels
Top

See Also

Reference

MapGridLines.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapGridLines.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapGridLines.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BorderColor | Default BorderColor
static (Shared in Visual Basic) | FontSize | Default FontSize
Public Field | Hidden | Default Hidden
Public Field | Interval | Default Interval
static (Shared in Visual Basic) | LabelColor | Default LabelColor
Public Field | LabelPosition | Default LabelPosition
Public Field | ShowLabels | Default ShowLabels
Top

See Also

Reference

MapGridLines.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderColor Field

[image]
ActiveReports 19 .NET Edition
BorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : BorderColor Field

Glossary Item Box

Default BorderColor

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BorderColor As String
C#
public static readonly string BorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


FontSize Field

[image]
ActiveReports 19 .NET Edition
FontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : FontSize Field

Glossary Item Box

Default FontSize

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSize As String
C#
public static readonly string FontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


Hidden Field

[image]
ActiveReports 19 .NET Edition
Hidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : Hidden Field

Glossary Item Box

Default Hidden

Syntax

Visual Basic (Declaration)
Public Const Hidden As Boolean
C#
public const bool Hidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


Interval Field

[image]
ActiveReports 19 .NET Edition
Interval Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : Interval Field

Glossary Item Box

Default Interval

Syntax

Visual Basic (Declaration)
Public Const Interval As Double
C#
public const double Interval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


LabelColor Field

[image]
ActiveReports 19 .NET Edition
LabelColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : LabelColor Field

Glossary Item Box

Default LabelColor

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly LabelColor As String
C#
public static readonly string LabelColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


LabelPosition Field

[image]
ActiveReports 19 .NET Edition
LabelPosition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : LabelPosition Field

Glossary Item Box

Default LabelPosition

Syntax

Visual Basic (Declaration)
Public Const LabelPosition As MapGridLines.LabelPositionType
C#
public const MapGridLines.LabelPositionType LabelPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


ShowLabels Field

[image]
ActiveReports 19 .NET Edition
ShowLabels Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines.Defaults Class : ShowLabels Field

Glossary Item Box

Default ShowLabels

Syntax

Visual Basic (Declaration)
Public Const ShowLabels As Boolean
C#
public const bool ShowLabels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapGridLines.Defaults Class
MapGridLines.Defaults Members


MapLayer Class

[image]
ActiveReports 19 .NET Edition
MapLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class

Glossary Item Box

Defines a layer to be drawn within a map

Object Model

MapLayer Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapLayer
C#
public abstract class MapLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapTileLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapLayer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class

Glossary Item Box

The following tables list the members exposed by MapLayer.

Public Properties

 | Name | Description
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Name | Name of the layer.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.
Top

See Also

Reference

MapLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class

Glossary Item Box

For a list of all members of this type, see MapLayer members.

Public Properties

 | Name | Description
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Name | Name of the layer.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.
Top

See Also

Reference

MapLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaximumZoom Property

[image]
ActiveReports 19 .NET Edition
MaximumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : MaximumZoom Property

Glossary Item Box

Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.

Syntax

Visual Basic (Declaration)
Public Property MaximumZoom As ExpressionInfo
C#
public ExpressionInfo MaximumZoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


MinimumZoom Property

[image]
ActiveReports 19 .NET Edition
MinimumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : MinimumZoom Property

Glossary Item Box

Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.

Syntax

Visual Basic (Declaration)
Public Property MinimumZoom As ExpressionInfo
C#
public ExpressionInfo MinimumZoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : Name Property

Glossary Item Box

Name of the layer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


Transparency Property

[image]
ActiveReports 19 .NET Edition
Transparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : Transparency Property

Glossary Item Box

Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property Transparency As ExpressionInfo
C#
public ExpressionInfo Transparency {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


VisibilityMode Property

[image]
ActiveReports 19 .NET Edition
VisibilityMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : VisibilityMode Property

Glossary Item Box

Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.

Syntax

Visual Basic (Declaration)
Public Property VisibilityMode As ExpressionInfo
C#
public ExpressionInfo VisibilityMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


MapLayer.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapLayer.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer.Defaults Class

Glossary Item Box

The default values of the MapLayer class properties.

Object Model

MapLayer.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapLayer.Defaults
C#
public static class MapLayer.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapLayer.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapLayer.Defaults.

Public Fields

 | Name | Description
Public Field | MaximumZoom | Default value of the maximum zoom level at which the layer is visible.
Public Field | MinimumZoom | Default value of the minimum zoom level at which the layer is visible.
Public Field | Transparency | Default value of the transparency for all map elements contained in layer.
Public Field | Visibility | Default value of the layer visibility mode.
Top

See Also

Reference

MapLayer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapLayer.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapLayer.Defaults members.

Public Fields

 | Name | Description
Public Field | MaximumZoom | Default value of the maximum zoom level at which the layer is visible.
Public Field | MinimumZoom | Default value of the minimum zoom level at which the layer is visible.
Public Field | Transparency | Default value of the transparency for all map elements contained in layer.
Public Field | Visibility | Default value of the layer visibility mode.
Top

See Also

Reference

MapLayer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaximumZoom Field

[image]
ActiveReports 19 .NET Edition
MaximumZoom Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer.Defaults Class : MaximumZoom Field

Glossary Item Box

Default value of the maximum zoom level at which the layer is visible.

Syntax

Visual Basic (Declaration)
Public Const MaximumZoom As String
C#
public const string MaximumZoom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer.Defaults Class
MapLayer.Defaults Members


MinimumZoom Field

[image]
ActiveReports 19 .NET Edition
MinimumZoom Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer.Defaults Class : MinimumZoom Field

Glossary Item Box

Default value of the minimum zoom level at which the layer is visible.

Syntax

Visual Basic (Declaration)
Public Const MinimumZoom As String
C#
public const string MinimumZoom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer.Defaults Class
MapLayer.Defaults Members


Transparency Field

[image]
ActiveReports 19 .NET Edition
Transparency Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer.Defaults Class : Transparency Field

Glossary Item Box

Default value of the transparency for all map elements contained in layer.

Syntax

Visual Basic (Declaration)
Public Const Transparency As String
C#
public const string Transparency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer.Defaults Class
MapLayer.Defaults Members


Visibility Field

[image]
ActiveReports 19 .NET Edition
Visibility Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer.Defaults Class : Visibility Field

Glossary Item Box

Default value of the layer visibility mode.

Syntax

Visual Basic (Declaration)
Public Const Visibility As String
C#
public const string Visibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer.Defaults Class
MapLayer.Defaults Members


MapLegend Class

[image]
ActiveReports 19 .NET Edition
MapLegend Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class

Glossary Item Box

Defines a legend to be drawn within a map

Object Model

MapLegend Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLegend
   Inherits MapDockableSubItem
C#
public sealed class MapLegend : MapDockableSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend Class Members

[image]
ActiveReports 19 .NET Edition
MapLegend Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class

Glossary Item Box

The following tables list the members exposed by MapLegend.

Public Constructors

 | Name | Description
Public Constructor | MapLegend Constructor | Initializes a new instance of the MapLegend class.
Top

Public Properties

 | Name | Description
Public Property | AutoFitTextDisabled | Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.
Public Property | EquallySpacedItems | Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRows | Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRowsColor | The background color to use for interlaced legend rows. The default value is LightGray.
Public Property | Layout | The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.
Public Property | MapLegendTitle | Title displays in the legend.
Public Property | MinFontSize | Minimum size for autosized legend text. An expression should evaluate to a Length. The default value is 7pt.
Public Property | Name | Name of the legend.
Public Property | TextWrapThreshold | Number of characters after which the legend text wraps. An expression should evaluate to a System.Int32. The default value is 25.
Top

See Also

Reference

MapLegend Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend Constructor

[image]
ActiveReports 19 .NET Edition
MapLegend Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MapLegend Constructor

Glossary Item Box

Initializes a new instance of the MapLegend class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLegend()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


MapLegend Class Properties

[image]
ActiveReports 19 .NET Edition
MapLegend Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class

Glossary Item Box

For a list of all members of this type, see MapLegend members.

Public Properties

 | Name | Description
Public Property | AutoFitTextDisabled | Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.
Public Property | EquallySpacedItems | Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRows | Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRowsColor | The background color to use for interlaced legend rows. The default value is LightGray.
Public Property | Layout | The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.
Public Property | MapLegendTitle | Title displays in the legend.
Public Property | MinFontSize | Minimum size for autosized legend text. An expression should evaluate to a Length. The default value is 7pt.
Public Property | Name | Name of the legend.
Public Property | TextWrapThreshold | Number of characters after which the legend text wraps. An expression should evaluate to a System.Int32. The default value is 25.
Top

See Also

Reference

MapLegend Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoFitTextDisabled Property

[image]
ActiveReports 19 .NET Edition
AutoFitTextDisabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : AutoFitTextDisabled Property

Glossary Item Box

Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property AutoFitTextDisabled As ExpressionInfo
C#
public ExpressionInfo AutoFitTextDisabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


EquallySpacedItems Property

[image]
ActiveReports 19 .NET Edition
EquallySpacedItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : EquallySpacedItems Property

Glossary Item Box

Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property EquallySpacedItems As ExpressionInfo
C#
public ExpressionInfo EquallySpacedItems {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


InterlacedRows Property

[image]
ActiveReports 19 .NET Edition
InterlacedRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : InterlacedRows Property

Glossary Item Box

Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property InterlacedRows As ExpressionInfo
C#
public ExpressionInfo InterlacedRows {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


InterlacedRowsColor Property

[image]
ActiveReports 19 .NET Edition
InterlacedRowsColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : InterlacedRowsColor Property

Glossary Item Box

The background color to use for interlaced legend rows. The default value is LightGray.

Syntax

Visual Basic (Declaration)
Public Property InterlacedRowsColor As ExpressionInfo
C#
public ExpressionInfo InterlacedRowsColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


Layout Property

[image]
ActiveReports 19 .NET Edition
Layout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : Layout Property

Glossary Item Box

The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.

Syntax

Visual Basic (Declaration)
Public Property Layout As ExpressionInfo
C#
public ExpressionInfo Layout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


MapLegendTitle Property

[image]
ActiveReports 19 .NET Edition
MapLegendTitle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MapLegendTitle Property

Glossary Item Box

Title displays in the legend.

Syntax

Visual Basic (Declaration)
Public Property MapLegendTitle As MapLegendTitle
C#
public MapLegendTitle MapLegendTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


MinFontSize Property

[image]
ActiveReports 19 .NET Edition
MinFontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MinFontSize Property

Glossary Item Box

Minimum size for autosized legend text. An expression should evaluate to a Length. The default value is 7pt.

Syntax

Visual Basic (Declaration)
Public Property MinFontSize As ExpressionInfo
C#
public ExpressionInfo MinFontSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : Name Property

Glossary Item Box

Name of the legend.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


TextWrapThreshold Property

[image]
ActiveReports 19 .NET Edition
TextWrapThreshold Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : TextWrapThreshold Property

Glossary Item Box

Number of characters after which the legend text wraps. An expression should evaluate to a System.Int32. The default value is 25.

Syntax

Visual Basic (Declaration)
Public Property TextWrapThreshold As ExpressionInfo
C#
public ExpressionInfo TextWrapThreshold {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend Class
MapLegend Members


MapLegend.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapLegend.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend.Defaults Class

Glossary Item Box

The default values of the MapLegend class properties.

Object Model

MapLegend.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapLegend.Defaults
C#
public static class MapLegend.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLegend.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapLegend.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapLegend.Defaults.

Public Fields

 | Name | Description
Public Field | AutoFitTextDisabled | Default value of text will not be autosized to fit in the legend area.
Public Field | EquallySpacedItems | Default value of legend items should be equally spaced.
Public Field | FontSizeDefaultValue | Default value of the point size of the font.
Public Field | InterlacedRows | Default value of legend rows should use interlaced colors.
Public Field | InterlacedRowsColor | Default value of the background color to use for interlaced legend rows.
Public Field | MinFontSize | Default value of minimum size for autosized legend text.
Public Field | SizeHeight | Default value of the height of the item.
Public Field | SizeUnit | Default value of the unit for width and height of the map.
Public Field | SizeWidth | Default value of the width of the item.
Public Field | TextWrapThreshold | Default value of number of characters after which the legend text wraps.
Top

See Also

Reference

MapLegend.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapLegend.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapLegend.Defaults members.

Public Fields

 | Name | Description
Public Field | AutoFitTextDisabled | Default value of text will not be autosized to fit in the legend area.
Public Field | EquallySpacedItems | Default value of legend items should be equally spaced.
Public Field | FontSizeDefaultValue | Default value of the point size of the font.
Public Field | InterlacedRows | Default value of legend rows should use interlaced colors.
Public Field | InterlacedRowsColor | Default value of the background color to use for interlaced legend rows.
Public Field | MinFontSize | Default value of minimum size for autosized legend text.
Public Field | SizeHeight | Default value of the height of the item.
Public Field | SizeUnit | Default value of the unit for width and height of the map.
Public Field | SizeWidth | Default value of the width of the item.
Public Field | TextWrapThreshold | Default value of number of characters after which the legend text wraps.
Top

See Also

Reference

MapLegend.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoFitTextDisabled Field

[image]
ActiveReports 19 .NET Edition
AutoFitTextDisabled Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : AutoFitTextDisabled Field

Glossary Item Box

Default value of text will not be autosized to fit in the legend area.

Syntax

Visual Basic (Declaration)
Public Const AutoFitTextDisabled As Boolean
C#
public const bool AutoFitTextDisabled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


EquallySpacedItems Field

[image]
ActiveReports 19 .NET Edition
EquallySpacedItems Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : EquallySpacedItems Field

Glossary Item Box

Default value of legend items should be equally spaced.

Syntax

Visual Basic (Declaration)
Public Const EquallySpacedItems As Boolean
C#
public const bool EquallySpacedItems

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


FontSizeDefaultValue Field

[image]
ActiveReports 19 .NET Edition
FontSizeDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : FontSizeDefaultValue Field

Glossary Item Box

Default value of the point size of the font.

Syntax

Visual Basic (Declaration)
Public Const FontSizeDefaultValue As String
C#
public const string FontSizeDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


InterlacedRows Field

[image]
ActiveReports 19 .NET Edition
InterlacedRows Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : InterlacedRows Field

Glossary Item Box

Default value of legend rows should use interlaced colors.

Syntax

Visual Basic (Declaration)
Public Const InterlacedRows As Boolean
C#
public const bool InterlacedRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


InterlacedRowsColor Field

[image]
ActiveReports 19 .NET Edition
InterlacedRowsColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : InterlacedRowsColor Field

Glossary Item Box

Default value of the background color to use for interlaced legend rows.

Syntax

Visual Basic (Declaration)
Public Const InterlacedRowsColor As String
C#
public const string InterlacedRowsColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


MinFontSize Field

[image]
ActiveReports 19 .NET Edition
MinFontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : MinFontSize Field

Glossary Item Box

Default value of minimum size for autosized legend text.

Syntax

Visual Basic (Declaration)
Public Const MinFontSize As String
C#
public const string MinFontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


SizeHeight Field

[image]
ActiveReports 19 .NET Edition
SizeHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : SizeHeight Field

Glossary Item Box

Default value of the height of the item.

Syntax

Visual Basic (Declaration)
Public Const SizeHeight As Double
C#
public const double SizeHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


SizeUnit Field

[image]
ActiveReports 19 .NET Edition
SizeUnit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : SizeUnit Field

Glossary Item Box

Default value of the unit for width and height of the map.

Syntax

Visual Basic (Declaration)
Public Const SizeUnit As MapUnit
C#
public const MapUnit SizeUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


SizeWidth Field

[image]
ActiveReports 19 .NET Edition
SizeWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : SizeWidth Field

Glossary Item Box

Default value of the width of the item.

Syntax

Visual Basic (Declaration)
Public Const SizeWidth As Double
C#
public const double SizeWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


TextWrapThreshold Field

[image]
ActiveReports 19 .NET Edition
TextWrapThreshold Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend.Defaults Class : TextWrapThreshold Field

Glossary Item Box

Default value of number of characters after which the legend text wraps.

Syntax

Visual Basic (Declaration)
Public Const TextWrapThreshold As Integer
C#
public const int TextWrapThreshold

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegend.Defaults Class
MapLegend.Defaults Members


MapLegendTitle Class

[image]
ActiveReports 19 .NET Edition
MapLegendTitle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class

Glossary Item Box

Defines a title for a map legend

Object Model

MapLegendTitle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLegendTitle
C#
public sealed class MapLegendTitle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle Class Members

[image]
ActiveReports 19 .NET Edition
MapLegendTitle Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class

Glossary Item Box

The following tables list the members exposed by MapLegendTitle.

Public Constructors

 | Name | Description
Public Constructor | MapLegendTitle Constructor | Initializes a new instance of the MapLegendTitle class.
Top

Public Properties

 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties for the title. Each of the properties of type Color support transparency.
Public Property | TitleSeparator | Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.
Public Property | TitleSeparatorColor | Gets or sets the color for the title separator. The default value is Gray
Top

See Also

Reference

MapLegendTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle Constructor

[image]
ActiveReports 19 .NET Edition
MapLegendTitle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : MapLegendTitle Constructor

Glossary Item Box

Initializes a new instance of the MapLegendTitle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLegendTitle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


MapLegendTitle Class Properties

[image]
ActiveReports 19 .NET Edition
MapLegendTitle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class

Glossary Item Box

For a list of all members of this type, see MapLegendTitle members.

Public Properties

 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties for the title. Each of the properties of type Color support transparency.
Public Property | TitleSeparator | Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.
Public Property | TitleSeparatorColor | Gets or sets the color for the title separator. The default value is Gray
Top

See Also

Reference

MapLegendTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : Caption Property

Glossary Item Box

Caption of the title. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property Caption As ExpressionInfo
C#
public ExpressionInfo Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : Style Property

Glossary Item Box

Gets or sets style properties for the title. Each of the properties of type Color support transparency.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


TitleSeparator Property

[image]
ActiveReports 19 .NET Edition
TitleSeparator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : TitleSeparator Property

Glossary Item Box

Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.

Syntax

Visual Basic (Declaration)
Public Property TitleSeparator As ExpressionInfo
C#
public ExpressionInfo TitleSeparator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


TitleSeparatorColor Property

[image]
ActiveReports 19 .NET Edition
TitleSeparatorColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : TitleSeparatorColor Property

Glossary Item Box

Gets or sets the color for the title separator. The default value is Gray

Syntax

Visual Basic (Declaration)
Public Property TitleSeparatorColor As ExpressionInfo
C#
public ExpressionInfo TitleSeparatorColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


MapLegendTitle.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapLegendTitle.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle.Defaults Class

Glossary Item Box

The default values of the MapLegendTitle class properties.

Object Model

MapLegendTitle.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapLegendTitle.Defaults
C#
public static class MapLegendTitle.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapLegendTitle.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapLegendTitle.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSizeDefaultValue | Default value of the point size of the font.
static (Shared in Visual Basic) | FontWeightDefaultValue | Default value of the thickness of the font.
Public Field | TitleSeparator | Default value of type of separator to use for the legend title.
Public Field | TitleSeparatorColor | Default value of the color for the title separator.
Top

See Also

Reference

MapLegendTitle.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapLegendTitle.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapLegendTitle.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FontSizeDefaultValue | Default value of the point size of the font.
static (Shared in Visual Basic) | FontWeightDefaultValue | Default value of the thickness of the font.
Public Field | TitleSeparator | Default value of type of separator to use for the legend title.
Public Field | TitleSeparatorColor | Default value of the color for the title separator.
Top

See Also

Reference

MapLegendTitle.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


FontSizeDefaultValue Field

[image]
ActiveReports 19 .NET Edition
FontSizeDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle.Defaults Class : FontSizeDefaultValue Field

Glossary Item Box

Default value of the point size of the font.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSizeDefaultValue As String
C#
public static readonly string FontSizeDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle.Defaults Class
MapLegendTitle.Defaults Members


FontWeightDefaultValue Field

[image]
ActiveReports 19 .NET Edition
FontWeightDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle.Defaults Class : FontWeightDefaultValue Field

Glossary Item Box

Default value of the thickness of the font.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontWeightDefaultValue As String
C#
public static readonly string FontWeightDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle.Defaults Class
MapLegendTitle.Defaults Members


TitleSeparator Field

[image]
ActiveReports 19 .NET Edition
TitleSeparator Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle.Defaults Class : TitleSeparator Field

Glossary Item Box

Default value of type of separator to use for the legend title.

Syntax

Visual Basic (Declaration)
Public Const TitleSeparator As MapLegendTitle.LegendTitleSeparator
C#
public const MapLegendTitle.LegendTitleSeparator TitleSeparator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle.Defaults Class
MapLegendTitle.Defaults Members


TitleSeparatorColor Field

[image]
ActiveReports 19 .NET Edition
TitleSeparatorColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle.Defaults Class : TitleSeparatorColor Field

Glossary Item Box

Default value of the color for the title separator.

Syntax

Visual Basic (Declaration)
Public Const TitleSeparatorColor As String
C#
public const string TitleSeparatorColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLegendTitle.Defaults Class
MapLegendTitle.Defaults Members


MapLimits Class

[image]
ActiveReports 19 .NET Edition
MapLimits Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

Glossary Item Box

Defines the map limits

Object Model

MapLimits Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLimits
C#
public sealed class MapLimits

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLimits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLimits Class Members

[image]
ActiveReports 19 .NET Edition
MapLimits Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

Glossary Item Box

The following tables list the members exposed by MapLimits.

Public Constructors

 | Name | Description
Public Constructor | MapLimits Constructor | Initializes a new instance of the MapLimits class.
Top

Public Fields

 | Name | Description
Public Field | LimitDefaultValue | Default value of the map limits.
Top

Public Properties

 | Name | Description
Public Property | MaximumX | Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MaximumY | Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumX | Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumY | Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapLimits Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLimits Constructor

[image]
ActiveReports 19 .NET Edition
MapLimits Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MapLimits Constructor

Glossary Item Box

Initializes a new instance of the MapLimits class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLimits()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MapLimits Class Properties

[image]
ActiveReports 19 .NET Edition
MapLimits Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

Glossary Item Box

For a list of all members of this type, see MapLimits members.

Public Properties

 | Name | Description
Public Property | MaximumX | Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MaximumY | Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumX | Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumY | Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapLimits Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaximumX Property

[image]
ActiveReports 19 .NET Edition
MaximumX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MaximumX Property

Glossary Item Box

Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property MaximumX As ExpressionInfo
C#
public ExpressionInfo MaximumX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MaximumY Property

[image]
ActiveReports 19 .NET Edition
MaximumY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MaximumY Property

Glossary Item Box

Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property MaximumY As ExpressionInfo
C#
public ExpressionInfo MaximumY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MinimumX Property

[image]
ActiveReports 19 .NET Edition
MinimumX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MinimumX Property

Glossary Item Box

Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property MinimumX As ExpressionInfo
C#
public ExpressionInfo MinimumX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MinimumY Property

[image]
ActiveReports 19 .NET Edition
MinimumY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MinimumY Property

Glossary Item Box

Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property MinimumY As ExpressionInfo
C#
public ExpressionInfo MinimumY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MapLimits Class Fields

[image]
ActiveReports 19 .NET Edition
MapLimits Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

Glossary Item Box

For a list of all members of this type, see MapLimits members.

Public Fields

 | Name | Description
Public Field | LimitDefaultValue | Default value of the map limits.
Top

See Also

Reference

MapLimits Class
GrapeCity.ActiveReports.PageReportModel Namespace


LimitDefaultValue Field

[image]
ActiveReports 19 .NET Edition
LimitDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : LimitDefaultValue Field

Glossary Item Box

Default value of the map limits.

Syntax

Visual Basic (Declaration)
Public Const LimitDefaultValue As Double
C#
public const double LimitDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLimits Class
MapLimits Members


MapLine Class

[image]
ActiveReports 19 .NET Edition
MapLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

Glossary Item Box

Defines an element to be embedded within a MapLineLayer

Object Model

MapLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLine
   Inherits MapSpatialElement
C#
public sealed class MapLine : MapSpatialElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLine Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLine Class Members

[image]
ActiveReports 19 .NET Edition
MapLine Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

Glossary Item Box

The following tables list the members exposed by MapLine.

Public Constructors

 | Name | Description
Public Constructor | MapLine Constructor | Initializes a new instance of the MapLine class.
Top

Public Fields

 | Name | Description
Public Field | DefaultUseCustomLineTemplate | The default value of the UseCustomLineTemplate property.
Top

Public Properties

 | Name | Description
Public Property | MapLineTemplate | Gets or sets the custom template to be used for the line. Ignored if UseCustomLineTemplate is false.
Public Property | UseCustomLineTemplate | Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLine Constructor

[image]
ActiveReports 19 .NET Edition
MapLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : MapLine Constructor

Glossary Item Box

Initializes a new instance of the MapLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLine Class
MapLine Members


MapLine Class Properties

[image]
ActiveReports 19 .NET Edition
MapLine Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

Glossary Item Box

For a list of all members of this type, see MapLine members.

Public Properties

 | Name | Description
Public Property | MapLineTemplate | Gets or sets the custom template to be used for the line. Ignored if UseCustomLineTemplate is false.
Public Property | UseCustomLineTemplate | Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Property

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : MapLineTemplate Property

Glossary Item Box

Gets or sets the custom template to be used for the line. Ignored if UseCustomLineTemplate is false.

Syntax

Visual Basic (Declaration)
Public Property MapLineTemplate As MapLineTemplate
C#
public MapLineTemplate MapLineTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLine Class
MapLine Members


UseCustomLineTemplate Property

[image]
ActiveReports 19 .NET Edition
UseCustomLineTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : UseCustomLineTemplate Property

Glossary Item Box

Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property UseCustomLineTemplate As ExpressionInfo
C#
public ExpressionInfo UseCustomLineTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLine Class
MapLine Members


MapLine Class Fields

[image]
ActiveReports 19 .NET Edition
MapLine Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

Glossary Item Box

For a list of all members of this type, see MapLine members.

Public Fields

 | Name | Description
Public Field | DefaultUseCustomLineTemplate | The default value of the UseCustomLineTemplate property.
Top

See Also

Reference

MapLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultUseCustomLineTemplate Field

[image]
ActiveReports 19 .NET Edition
DefaultUseCustomLineTemplate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : DefaultUseCustomLineTemplate Field

Glossary Item Box

The default value of the UseCustomLineTemplate property.

Syntax

Visual Basic (Declaration)
Public Const DefaultUseCustomLineTemplate As String
C#
public const string DefaultUseCustomLineTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLine Class
MapLine Members


MapLineLayer Class

[image]
ActiveReports 19 .NET Edition
MapLineLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class

Glossary Item Box

Defines a vector-based layer of lines to be drawn within a map

Object Model

MapLineLayer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLineLayer
   Inherits MapVectorLayer
C#
public sealed class MapLineLayer : MapVectorLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapLineLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapLineLayer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class

Glossary Item Box

The following tables list the members exposed by MapLineLayer.

Public Constructors

 | Name | Description
Public Constructor | MapLineLayer Constructor | Initializes a new instance of the MapLineLayer class.
Top

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Returns a collection of layer elements.
Public Property | MapLineRules | Gets or sets the set of rules to be applied for lines within the layer.
Public Property | MapLines | Gets the set of embedded lines in the layer.
Public Property | MapLineTemplate | Gets or sets the template to be applied for lines within the layer.
Top

See Also

Reference

MapLineLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineLayer Constructor

[image]
ActiveReports 19 .NET Edition
MapLineLayer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineLayer Constructor

Glossary Item Box

Initializes a new instance of the MapLineLayer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLineLayer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapLineLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class

Glossary Item Box

For a list of all members of this type, see MapLineLayer members.

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Returns a collection of layer elements.
Public Property | MapLineRules | Gets or sets the set of rules to be applied for lines within the layer.
Public Property | MapLines | Gets the set of embedded lines in the layer.
Public Property | MapLineTemplate | Gets or sets the template to be applied for lines within the layer.
Top

See Also

Reference

MapLineLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : Elements Property

Glossary Item Box

Returns a collection of layer elements.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Elements As IEnumerable(Of MapSpatialElement)
C#
public override IEnumerable<MapSpatialElement> Elements {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineRules Property

[image]
ActiveReports 19 .NET Edition
MapLineRules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineRules Property

Glossary Item Box

Gets or sets the set of rules to be applied for lines within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapLineRules As MapLineRules
C#
public MapLineRules MapLineRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLines Property

[image]
ActiveReports 19 .NET Edition
MapLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLines Property

Glossary Item Box

Gets the set of embedded lines in the layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapLines As IList(Of MapLine)
C#
public IList<MapLine> MapLines {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineTemplate Property

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineTemplate Property

Glossary Item Box

Gets or sets the template to be applied for lines within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapLineTemplate As MapLineTemplate
C#
public MapLineTemplate MapLineTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineRules Class

[image]
ActiveReports 19 .NET Edition
MapLineRules Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class

Glossary Item Box

Defines a set of rules to be applied on lines

Object Model

MapLineRules Class

Syntax

Visual Basic (Declaration)
Public Class MapLineRules
C#
public class MapLineRules

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLineRules

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineRules Class Members

[image]
ActiveReports 19 .NET Edition
MapLineRules Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class

Glossary Item Box

The following tables list the members exposed by MapLineRules.

Public Constructors

 | Name | Description
Public Constructor | MapLineRules Constructor | Initializes a new instance of the MapLineRules class.
Top

Public Properties

 | Name | Description
Public Property | MapColorRule | Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color
Public Property | MapSizeRule | Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width
Top

See Also

Reference

MapLineRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineRules Constructor

[image]
ActiveReports 19 .NET Edition
MapLineRules Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapLineRules Constructor

Glossary Item Box

Initializes a new instance of the MapLineRules class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLineRules()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineRules Class
MapLineRules Members


MapLineRules Class Properties

[image]
ActiveReports 19 .NET Edition
MapLineRules Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class

Glossary Item Box

For a list of all members of this type, see MapLineRules members.

Public Properties

 | Name | Description
Public Property | MapColorRule | Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color
Public Property | MapSizeRule | Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width
Top

See Also

Reference

MapLineRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property

[image]
ActiveReports 19 .NET Edition
MapColorRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapColorRule Property

Glossary Item Box

Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color

Syntax

Visual Basic (Declaration)
Public Property MapColorRule As MapColorRule
C#
public MapColorRule MapColorRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineRules Class
MapLineRules Members


MapSizeRule Property

[image]
ActiveReports 19 .NET Edition
MapSizeRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapSizeRule Property

Glossary Item Box

Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width

Syntax

Visual Basic (Declaration)
Public Property MapSizeRule As MapSizeRule
C#
public MapSizeRule MapSizeRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineRules Class
MapLineRules Members


MapLineTemplate Class

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

Glossary Item Box

Defines a template to be applied to lines within a line layer

Object Model

MapLineTemplate Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLineTemplate
   Inherits MapSpatialElementTemplate
C#
public sealed class MapLineTemplate : MapSpatialElementTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Class Members

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

Glossary Item Box

The following tables list the members exposed by MapLineTemplate.

Public Constructors

 | Name | Description
Public Constructor | MapLineTemplate Constructor | Initializes a new instance of the MapLineTemplate class.
Top

Public Properties

 | Name | Description
Public Property | LabelPlacement | Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.
Public Property | Width | Defines the width of the line. Default: 3.75pt An expression should evaluate to a Length. The default value is 3.75pt.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Constructor

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : MapLineTemplate Constructor

Glossary Item Box

Initializes a new instance of the MapLineTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLineTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLineTemplate Class Methods

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

Glossary Item Box

For a list of all members of this type, see MapLineTemplate members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLineTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
MapLineTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

Glossary Item Box

For a list of all members of this type, see MapLineTemplate members.

Public Properties

 | Name | Description
Public Property | LabelPlacement | Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.
Public Property | Width | Defines the width of the line. Default: 3.75pt An expression should evaluate to a Length. The default value is 3.75pt.
Top

See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : LabelPlacement Property

Glossary Item Box

Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.

Syntax

Visual Basic (Declaration)
Public Property LabelPlacement As ExpressionInfo
C#
public ExpressionInfo LabelPlacement {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : Width Property

Glossary Item Box

Defines the width of the line. Default: 3.75pt An expression should evaluate to a Length. The default value is 3.75pt.

Syntax

Visual Basic (Declaration)
Public Property Width As ExpressionInfo
C#
public ExpressionInfo Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLineTemplate.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapLineTemplate.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate.Defaults Class

Glossary Item Box

The default values of the MapLineTemplate class properties.

Object Model

MapLineTemplate.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapLineTemplate.Defaults
C#
public static class MapLineTemplate.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapLineTemplate.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapLineTemplate.Defaults.

Public Fields

 | Name | Description
Public Field | LabelPlacement | Default value for the label placement of the line.
Public Field | Width | Default value for the width of the line.
Top

See Also

Reference

MapLineTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapLineTemplate.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapLineTemplate.Defaults members.

Public Fields

 | Name | Description
Public Field | LabelPlacement | Default value for the label placement of the line.
Public Field | Width | Default value for the width of the line.
Top

See Also

Reference

MapLineTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelPlacement Field

[image]
ActiveReports 19 .NET Edition
LabelPlacement Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate.Defaults Class : LabelPlacement Field

Glossary Item Box

Default value for the label placement of the line.

Syntax

Visual Basic (Declaration)
Public Const LabelPlacement As MapLineTemplate.LineLabelPlacement
C#
public const MapLineTemplate.LineLabelPlacement LabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate.Defaults Class
MapLineTemplate.Defaults Members


Width Field

[image]
ActiveReports 19 .NET Edition
Width Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate.Defaults Class : Width Field

Glossary Item Box

Default value for the width of the line.

Syntax

Visual Basic (Declaration)
Public Const Width As String
C#
public const string Width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLineTemplate.Defaults Class
MapLineTemplate.Defaults Members


MapLocation Class

[image]
ActiveReports 19 .NET Edition
MapLocation Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class

Glossary Item Box

Defines the properties for map sub items location

Object Model

MapLocation Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLocation
C#
public sealed class MapLocation

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation Class Members

[image]
ActiveReports 19 .NET Edition
MapLocation Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class

Glossary Item Box

The following tables list the members exposed by MapLocation.

Public Constructors

 | Name | Description
Public Constructor | MapLocation Constructor | Initializes a new instance of the MapLocation class.
Top

Public Properties

 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Unit | Gets or sets the unit for both left and top. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.
Top

See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation Constructor

[image]
ActiveReports 19 .NET Edition
MapLocation Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : MapLocation Constructor

Glossary Item Box

Initializes a new instance of the MapLocation class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLocation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


MapLocation Class Properties

[image]
ActiveReports 19 .NET Edition
MapLocation Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class

Glossary Item Box

For a list of all members of this type, see MapLocation members.

Public Properties

 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Unit | Gets or sets the unit for both left and top. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.
Top

See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.PageReportModel Namespace


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Left Property

Glossary Item Box

The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property Left As ExpressionInfo
C#
public ExpressionInfo Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Top Property

Glossary Item Box

The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property Top As ExpressionInfo
C#
public ExpressionInfo Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Unit Property

Glossary Item Box

Gets or sets the unit for both left and top. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.

Syntax

Visual Basic (Declaration)
Public Property Unit As ExpressionInfo
C#
public ExpressionInfo Unit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


MapLocation.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapLocation.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation.Defaults Class

Glossary Item Box

The default values of the MapLocation class properties.

Object Model

MapLocation.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapLocation.Defaults
C#
public static class MapLocation.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLocation.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapLocation.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapLocation.Defaults.

Public Fields

 | Name | Description
Public Field | Left | Default value for the distance of the item from the left of the containing object.
Public Field | Top | Default value for the distance of the item from the top of the containing object.
Public Field | Unit | Default value for the unit for both left and top values.
Top

See Also

Reference

MapLocation.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapLocation.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapLocation.Defaults members.

Public Fields

 | Name | Description
Public Field | Left | Default value for the distance of the item from the left of the containing object.
Public Field | Top | Default value for the distance of the item from the top of the containing object.
Public Field | Unit | Default value for the unit for both left and top values.
Top

See Also

Reference

MapLocation.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


Left Field

[image]
ActiveReports 19 .NET Edition
Left Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation.Defaults Class : Left Field

Glossary Item Box

Default value for the distance of the item from the left of the containing object.

Syntax

Visual Basic (Declaration)
Public Const Left As String
C#
public const string Left

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation.Defaults Class
MapLocation.Defaults Members


Top Field

[image]
ActiveReports 19 .NET Edition
Top Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation.Defaults Class : Top Field

Glossary Item Box

Default value for the distance of the item from the top of the containing object.

Syntax

Visual Basic (Declaration)
Public Const Top As String
C#
public const string Top

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation.Defaults Class
MapLocation.Defaults Members


Unit Field

[image]
ActiveReports 19 .NET Edition
Unit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation.Defaults Class : Unit Field

Glossary Item Box

Default value for the unit for both left and top values.

Syntax

Visual Basic (Declaration)
Public Const Unit As MapUnit
C#
public const MapUnit Unit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation.Defaults Class
MapLocation.Defaults Members


MapMarker Class

[image]
ActiveReports 19 .NET Edition
MapMarker Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

Glossary Item Box

Defines a marker to be applied to points within a point or polygon layer.

Object Model

MapMarker Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapMarker
C#
public sealed class MapMarker

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Class Members

[image]
ActiveReports 19 .NET Edition
MapMarker Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

Glossary Item Box

The following tables list the members exposed by MapMarker.

Public Constructors

 | Name | Description
Public Constructor | MapMarker Constructor | Initializes a new instance of the MapMarker class.
Top

Public Fields

 | Name | Description
Public Field | DefaultMarkerStyle | Default value for the point marker style.
Top

Public Properties

 | Name | Description
Public Property | MapMarkerImage | Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.
Public Property | MapMarkerStyle | Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Constructor

[image]
ActiveReports 19 .NET Edition
MapMarker Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarker Constructor

Glossary Item Box

Initializes a new instance of the MapMarker class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapMarker()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Class
MapMarker Members


MapMarker Class Methods

[image]
ActiveReports 19 .NET Edition
MapMarker Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

Glossary Item Box

For a list of all members of this type, see MapMarker members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Class
MapMarker Members


MapMarker Class Properties

[image]
ActiveReports 19 .NET Edition
MapMarker Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

Glossary Item Box

For a list of all members of this type, see MapMarker members.

Public Properties

 | Name | Description
Public Property | MapMarkerImage | Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.
Public Property | MapMarkerStyle | Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.
Top

See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Property

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarkerImage Property

Glossary Item Box

Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.

Syntax

Visual Basic (Declaration)
Public Property MapMarkerImage As MapMarkerImage
C#
public MapMarkerImage MapMarkerImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Class
MapMarker Members


MapMarkerStyle Property

[image]
ActiveReports 19 .NET Edition
MapMarkerStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarkerStyle Property

Glossary Item Box

Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.

Syntax

Visual Basic (Declaration)
Public Property MapMarkerStyle As ExpressionInfo
C#
public ExpressionInfo MapMarkerStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Class
MapMarker Members


MapMarker Class Fields

[image]
ActiveReports 19 .NET Edition
MapMarker Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

Glossary Item Box

For a list of all members of this type, see MapMarker members.

Public Fields

 | Name | Description
Public Field | DefaultMarkerStyle | Default value for the point marker style.
Top

See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultMarkerStyle Field

[image]
ActiveReports 19 .NET Edition
DefaultMarkerStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : DefaultMarkerStyle Field

Glossary Item Box

Default value for the point marker style.

Syntax

Visual Basic (Declaration)
Public Const DefaultMarkerStyle As MapMarker.MarkerStyle
C#
public const MapMarker.MarkerStyle DefaultMarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarker Class
MapMarker Members


MapMarkerImage Class

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

Glossary Item Box

Represents an image to be applied to the map marker.

Object Model

MapMarkerImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapMarkerImage
C#
public sealed class MapMarkerImage

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Class Members

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

Glossary Item Box

The following tables list the members exposed by MapMarkerImage.

Public Constructors

 | Name | Description
Public Constructor | MapMarkerImage Constructor | Initializes a new instance of the MapMarkerImage class.
Top

Public Properties

 | Name | Description
Public Property | MIMEType | The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png, image/svg+xml. Required if Source = Database. Ignored otherwise.
Public Property | ResizeMode | Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.
Public Property | Source | Identifies the source of the image. That evaluates to one of ImageSource />.
Public Property | TransparentColor | Color to treat as transparent in the image.
Public Property | Value | See Source. Expected datatype is string or binary,
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Constructor

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : MapMarkerImage Constructor

Glossary Item Box

Initializes a new instance of the MapMarkerImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapMarkerImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerImage Class Methods

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

Glossary Item Box

For a list of all members of this type, see MapMarkerImage members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerImage Class Properties

[image]
ActiveReports 19 .NET Edition
MapMarkerImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

Glossary Item Box

For a list of all members of this type, see MapMarkerImage members.

Public Properties

 | Name | Description
Public Property | MIMEType | The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png, image/svg+xml. Required if Source = Database. Ignored otherwise.
Public Property | ResizeMode | Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.
Public Property | Source | Identifies the source of the image. That evaluates to one of ImageSource />.
Public Property | TransparentColor | Color to treat as transparent in the image.
Public Property | Value | See Source. Expected datatype is string or binary,
Top

See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : MIMEType Property

Glossary Item Box

The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png, image/svg+xml. Required if Source = Database. Ignored otherwise.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As ExpressionInfo
C#
public ExpressionInfo MIMEType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


ResizeMode Property

[image]
ActiveReports 19 .NET Edition
ResizeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : ResizeMode Property

Glossary Item Box

Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.

Syntax

Visual Basic (Declaration)
Public Property ResizeMode As ExpressionInfo
C#
public ExpressionInfo ResizeMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Source Property

Glossary Item Box

Identifies the source of the image. That evaluates to one of ImageSource />.

Syntax

Visual Basic (Declaration)
Public Property Source As ExpressionInfo
C#
public ExpressionInfo Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


TransparentColor Property

[image]
ActiveReports 19 .NET Edition
TransparentColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : TransparentColor Property

Glossary Item Box

Color to treat as transparent in the image.

Syntax

Visual Basic (Declaration)
Public Property TransparentColor As ExpressionInfo
C#
public ExpressionInfo TransparentColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Value Property

Glossary Item Box

See Source. Expected datatype is string or binary,

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerImage.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapMarkerImage.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage.Defaults Class

Glossary Item Box

The default values of the MapMarkerImage class properties.

Object Model

MapMarkerImage.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapMarkerImage.Defaults
C#
public static class MapMarkerImage.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapMarkerImage.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapMarkerImage.Defaults.

Public Fields

 | Name | Description
Public Field | ResizeMode | Default value of the whether the content will resize to fit in the available space.
Public Field | Source | Default value of the source of the image.
Public Field | TransparentColor | Default value of сolor to treat as transparent in the image.
Top

See Also

Reference

MapMarkerImage.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapMarkerImage.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapMarkerImage.Defaults members.

Public Fields

 | Name | Description
Public Field | ResizeMode | Default value of the whether the content will resize to fit in the available space.
Public Field | Source | Default value of the source of the image.
Public Field | TransparentColor | Default value of сolor to treat as transparent in the image.
Top

See Also

Reference

MapMarkerImage.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


ResizeMode Field

[image]
ActiveReports 19 .NET Edition
ResizeMode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage.Defaults Class : ResizeMode Field

Glossary Item Box

Default value of the whether the content will resize to fit in the available space.

Syntax

Visual Basic (Declaration)
Public Const ResizeMode As ResizeModes
C#
public const ResizeModes ResizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage.Defaults Class
MapMarkerImage.Defaults Members


Source Field

[image]
ActiveReports 19 .NET Edition
Source Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage.Defaults Class : Source Field

Glossary Item Box

Default value of the source of the image.

Syntax

Visual Basic (Declaration)
Public Const Source As ImageSource
C#
public const ImageSource Source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage.Defaults Class
MapMarkerImage.Defaults Members


TransparentColor Field

[image]
ActiveReports 19 .NET Edition
TransparentColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage.Defaults Class : TransparentColor Field

Glossary Item Box

Default value of сolor to treat as transparent in the image.

Syntax

Visual Basic (Declaration)
Public Const TransparentColor As String
C#
public const string TransparentColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerImage.Defaults Class
MapMarkerImage.Defaults Members


MapMarkerRule Class

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

Glossary Item Box

Defines the points marker based on a data field

Object Model

MapMarkerRule Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapMarkerRule
   Inherits MapAppearanceRule
C#
public sealed class MapMarkerRule : MapAppearanceRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapMarkerRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerRule Class Members

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

Glossary Item Box

The following tables list the members exposed by MapMarkerRule.

Public Constructors

 | Name | Description
Public Constructor | MapMarkerRule Constructor | Initializes a new instance of the MapMarkerRule class.
Top

Public Properties

 | Name | Description
Public Property | MapMarkers | Gets a set of markers to be used for points.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions.
Top

See Also

Reference

MapMarkerRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerRule Constructor

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerRule Class : MapMarkerRule Constructor

Glossary Item Box

Initializes a new instance of the MapMarkerRule class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapMarkerRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerRule Class
MapMarkerRule Members


MapMarkerRule Class Methods

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

Glossary Item Box

For a list of all members of this type, see MapMarkerRule members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Gets the expressions.
Top

See Also

Reference

MapMarkerRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerRule Class : GetExpressions Method

Glossary Item Box

Gets the expressions.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> GetExpressions()

Return Value

System.Collections.Generic.IEnumerable<GrapeCity.ActiveReports.Expressions.ExpressionInfo>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerRule Class
MapMarkerRule Members


MapMarkerRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

Glossary Item Box

For a list of all members of this type, see MapMarkerRule members.

Public Properties

 | Name | Description
Public Property | MapMarkers | Gets a set of markers to be used for points.
Top

See Also

Reference

MapMarkerRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkers Property

[image]
ActiveReports 19 .NET Edition
MapMarkers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerRule Class : MapMarkers Property

Glossary Item Box

Gets a set of markers to be used for points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapMarkers As IList(Of MapMarker)
C#
public IList<MapMarker> MapMarkers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerRule Class
MapMarkerRule Members


MapMarkerTemplate Class

[image]
ActiveReports 19 .NET Edition
MapMarkerTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

Glossary Item Box

Defines a marker template to be applied to points within a point or polygon layer

Object Model

MapMarkerTemplate Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapMarkerTemplate
   Inherits MapPointTemplate
C#
public sealed class MapMarkerTemplate : MapPointTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapMarkerTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerTemplate Class Members

[image]
ActiveReports 19 .NET Edition
MapMarkerTemplate Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

Glossary Item Box

The following tables list the members exposed by MapMarkerTemplate.

Public Constructors

 | Name | Description
Public Constructor | MapMarkerTemplate Constructor | Initializes a new instance of the MapMarkerTemplate class.
Top

Public Properties

 | Name | Description
Public Property | MapMarker | Gets or sets the point marker.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
Top

See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerTemplate Constructor

[image]
ActiveReports 19 .NET Edition
MapMarkerTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : MapMarkerTemplate Constructor

Glossary Item Box

Initializes a new instance of the MapMarkerTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapMarkerTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMarkerTemplate Class Methods

[image]
ActiveReports 19 .NET Edition
MapMarkerTemplate Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

Glossary Item Box

For a list of all members of this type, see MapMarkerTemplate members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
Top

See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : Clone Method

Glossary Item Box

Clones this instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMarkerTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
MapMarkerTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

Glossary Item Box

For a list of all members of this type, see MapMarkerTemplate members.

Public Properties

 | Name | Description
Public Property | MapMarker | Gets or sets the point marker.
Top

See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Property

[image]
ActiveReports 19 .NET Edition
MapMarker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : MapMarker Property

Glossary Item Box

Gets or sets the point marker.

Syntax

Visual Basic (Declaration)
Public Property MapMarker As MapMarker
C#
public MapMarker MapMarker {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMember Class

[image]
ActiveReports 19 .NET Edition
MapMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class

Glossary Item Box

Defines group and filter behavior for the data.

Object Model

MapMember Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapMember
C#
public sealed class MapMember

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMember Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMember Class Members

[image]
ActiveReports 19 .NET Edition
MapMember Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class

Glossary Item Box

The following tables list the members exposed by MapMember.

Public Constructors

 | Name | Description
Public Constructor | MapMember Constructor | Initializes a new instance of the MapMember class.
Top

Public Properties

 | Name | Description
Public Property | ChildMember | Nested grouping/ filtering.
Public Property | Group | Grouping to apply to the data.
Top

See Also

Reference

MapMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMember Constructor

[image]
ActiveReports 19 .NET Edition
MapMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : MapMember Constructor

Glossary Item Box

Initializes a new instance of the MapMember class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapMember()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMember Class
MapMember Members


MapMember Class Properties

[image]
ActiveReports 19 .NET Edition
MapMember Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class

Glossary Item Box

For a list of all members of this type, see MapMember members.

Public Properties

 | Name | Description
Public Property | ChildMember | Nested grouping/ filtering.
Public Property | Group | Grouping to apply to the data.
Top

See Also

Reference

MapMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildMember Property

[image]
ActiveReports 19 .NET Edition
ChildMember Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : ChildMember Property

Glossary Item Box

Nested grouping/ filtering.

Syntax

Visual Basic (Declaration)
Public Property ChildMember As MapMember
C#
public MapMember ChildMember {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMember Class
MapMember Members


Group Property

[image]
ActiveReports 19 .NET Edition
Group Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : Group Property

Glossary Item Box

Grouping to apply to the data.

Syntax

Visual Basic (Declaration)
Public Property Group As Grouping
C#
public Grouping Group {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapMember Class
MapMember Members


MappedPropertiesCollection Class

[image]
ActiveReports 19 .NET Edition
MappedPropertiesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MappedPropertiesCollection Class

Glossary Item Box

Represents a strongly typed collection of MappedProperty objects.

Object Model

MappedPropertiesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MappedPropertiesCollection
   Inherits System.Collections.ObjectModel.Collection(Of MappedProperty)
C#
public sealed class MappedPropertiesCollection : System.Collections.ObjectModel.Collection<MappedProperty>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.MappedPropertiesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedPropertiesCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MappedPropertiesCollection Class Members

[image]
ActiveReports 19 .NET Edition
MappedPropertiesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MappedPropertiesCollection Class

Glossary Item Box

The following tables list the members exposed by MappedPropertiesCollection.

Public Constructors

 | Name | Description
Public Constructor | MappedPropertiesCollection Constructor |
Top

See Also

Reference

MappedPropertiesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MappedPropertiesCollection Constructor

[image]
ActiveReports 19 .NET Edition
MappedPropertiesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MappedPropertiesCollection Class : MappedPropertiesCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MappedPropertiesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedPropertiesCollection Class
MappedPropertiesCollection Members


MappedProperty Class

[image]
ActiveReports 19 .NET Edition
MappedProperty Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MappedProperty Class

Glossary Item Box

Represents a specific property of shared report item.

Object Model

MappedProperty Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MappedProperty
C#
public sealed class MappedProperty

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MappedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedProperty Members
GrapeCity.ActiveReports.PageReportModel Namespace


MappedProperty Class Members

[image]
ActiveReports 19 .NET Edition
MappedProperty Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MappedProperty Class

Glossary Item Box

The following tables list the members exposed by MappedProperty.

Public Constructors

 | Name | Description
Public Constructor | MappedProperty Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the property.
Public Property | Value | Gets or sets the value expression for the property.
Top

See Also

Reference

MappedProperty Class
GrapeCity.ActiveReports.PageReportModel Namespace


MappedProperty Constructor

[image]
ActiveReports 19 .NET Edition
MappedProperty Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MappedProperty Class : MappedProperty Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MappedProperty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedProperty Class
MappedProperty Members


MappedProperty Class Properties

[image]
ActiveReports 19 .NET Edition
MappedProperty Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MappedProperty Class

Glossary Item Box

For a list of all members of this type, see MappedProperty members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the property.
Public Property | Value | Gets or sets the value expression for the property.
Top

See Also

Reference

MappedProperty Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MappedProperty Class : Name Property

Glossary Item Box

Gets or sets the name of the property.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedProperty Class
MappedProperty Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MappedProperty Class : Value Property

Glossary Item Box

Gets or sets the value expression for the property.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the value expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MappedProperty Class
MappedProperty Members


MapPoint Class

[image]
ActiveReports 19 .NET Edition
MapPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

Glossary Item Box

Defines an element to be embedded within a MapPointLayer

Object Model

MapPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPoint
   Inherits MapSpatialElement
C#
public sealed class MapPoint : MapSpatialElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPoint Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPoint Class Members

[image]
ActiveReports 19 .NET Edition
MapPoint Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

Glossary Item Box

The following tables list the members exposed by MapPoint.

Public Constructors

 | Name | Description
Public Constructor | MapPoint Constructor | Initializes a new instance of the MapPoint class.
Top

Public Fields

 | Name | Description
Public Field | DefaultUseCustomPointTemplate | Defaul value defining will the custom template be used for the point or the layer template.
Top

Public Properties

 | Name | Description
Public Property | MapPointTemplate | Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.
Public Property | UseCustomPointTemplate | Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPoint Constructor

[image]
ActiveReports 19 .NET Edition
MapPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : MapPoint Constructor

Glossary Item Box

Initializes a new instance of the MapPoint class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPoint()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPoint Class
MapPoint Members


MapPoint Class Properties

[image]
ActiveReports 19 .NET Edition
MapPoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

Glossary Item Box

For a list of all members of this type, see MapPoint members.

Public Properties

 | Name | Description
Public Property | MapPointTemplate | Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.
Public Property | UseCustomPointTemplate | Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Property

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : MapPointTemplate Property

Glossary Item Box

Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.

Syntax

Visual Basic (Declaration)
Public Property MapPointTemplate As MapMarkerTemplate
C#
public MapMarkerTemplate MapPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPoint Class
MapPoint Members


UseCustomPointTemplate Property

[image]
ActiveReports 19 .NET Edition
UseCustomPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : UseCustomPointTemplate Property

Glossary Item Box

Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property UseCustomPointTemplate As ExpressionInfo
C#
public ExpressionInfo UseCustomPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPoint Class
MapPoint Members


MapPoint Class Fields

[image]
ActiveReports 19 .NET Edition
MapPoint Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

Glossary Item Box

For a list of all members of this type, see MapPoint members.

Public Fields

 | Name | Description
Public Field | DefaultUseCustomPointTemplate | Defaul value defining will the custom template be used for the point or the layer template.
Top

See Also

Reference

MapPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultUseCustomPointTemplate Field

[image]
ActiveReports 19 .NET Edition
DefaultUseCustomPointTemplate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : DefaultUseCustomPointTemplate Field

Glossary Item Box

Defaul value defining will the custom template be used for the point or the layer template.

Syntax

Visual Basic (Declaration)
Public Const DefaultUseCustomPointTemplate As String
C#
public const string DefaultUseCustomPointTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPoint Class
MapPoint Members


MapPointLayer Class

[image]
ActiveReports 19 .NET Edition
MapPointLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class

Glossary Item Box

Defines a vector-based layer of points to be drawn within a map

Object Model

MapPointLayer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPointLayer
   Inherits MapVectorLayer
C#
public sealed class MapPointLayer : MapVectorLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapPointLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapPointLayer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class

Glossary Item Box

The following tables list the members exposed by MapPointLayer.

Public Constructors

 | Name | Description
Public Constructor | MapPointLayer Constructor | Initializes a new instance of the MapPointLayer class.
Top

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Gets the elements.
Public Property | MapPointRules | Gets or sets the set of rules to be applied for points within the layer.
Public Property | MapPoints | Gets the set of embedded points in the layer.
Public Property | MapPointTemplate | Gets or sets the template to be applied for points within the layer.
Top

See Also

Reference

MapPointLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointLayer Constructor

[image]
ActiveReports 19 .NET Edition
MapPointLayer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointLayer Constructor

Glossary Item Box

Initializes a new instance of the MapPointLayer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPointLayer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapPointLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class

Glossary Item Box

For a list of all members of this type, see MapPointLayer members.

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Gets the elements.
Public Property | MapPointRules | Gets or sets the set of rules to be applied for points within the layer.
Public Property | MapPoints | Gets the set of embedded points in the layer.
Public Property | MapPointTemplate | Gets or sets the template to be applied for points within the layer.
Top

See Also

Reference

MapPointLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : Elements Property

Glossary Item Box

Gets the elements.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Elements As IEnumerable(Of MapSpatialElement)
C#
public override IEnumerable<MapSpatialElement> Elements {get;}

Property Value

The elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointRules Property

[image]
ActiveReports 19 .NET Edition
MapPointRules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointRules Property

Glossary Item Box

Gets or sets the set of rules to be applied for points within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapPointRules As MapPointRules
C#
public MapPointRules MapPointRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPoints Property

[image]
ActiveReports 19 .NET Edition
MapPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPoints Property

Glossary Item Box

Gets the set of embedded points in the layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapPoints As IList(Of MapPoint)
C#
public IList<MapPoint> MapPoints {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointTemplate Property

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointTemplate Property

Glossary Item Box

Gets or sets the template to be applied for points within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapPointTemplate As MapMarkerTemplate
C#
public MapMarkerTemplate MapPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointRules Class

[image]
ActiveReports 19 .NET Edition
MapPointRules Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class

Glossary Item Box

Defines a set of rules to be applied on points on a point or polygon layer

Object Model

MapPointRules Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPointRules
C#
public sealed class MapPointRules

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPointRules

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointRules Class Members

[image]
ActiveReports 19 .NET Edition
MapPointRules Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class

Glossary Item Box

The following tables list the members exposed by MapPointRules.

Public Constructors

 | Name | Description
Public Constructor | MapPointRules Constructor | Initializes a new instance of the MapPointRules class.
Top

Public Properties

 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the point based on a data field. Overrides an MapPointTemplate.Style.Color value.
Public Property | MapMarkerRule | Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker
Public Property | MapSizeRule | Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size
Top

See Also

Reference

MapPointRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointRules Constructor

[image]
ActiveReports 19 .NET Edition
MapPointRules Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapPointRules Constructor

Glossary Item Box

Initializes a new instance of the MapPointRules class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPointRules()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointRules Class
MapPointRules Members


MapPointRules Class Properties

[image]
ActiveReports 19 .NET Edition
MapPointRules Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class

Glossary Item Box

For a list of all members of this type, see MapPointRules members.

Public Properties

 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the point based on a data field. Overrides an MapPointTemplate.Style.Color value.
Public Property | MapMarkerRule | Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker
Public Property | MapSizeRule | Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size
Top

See Also

Reference

MapPointRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property

[image]
ActiveReports 19 .NET Edition
MapColorRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapColorRule Property

Glossary Item Box

Gets or sets the color of the point based on a data field. Overrides an MapPointTemplate.Style.Color value.

Syntax

Visual Basic (Declaration)
Public Property MapColorRule As MapColorRule
C#
public MapColorRule MapColorRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointRules Class
MapPointRules Members


MapMarkerRule Property

[image]
ActiveReports 19 .NET Edition
MapMarkerRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapMarkerRule Property

Glossary Item Box

Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker

Syntax

Visual Basic (Declaration)
Public Property MapMarkerRule As MapMarkerRule
C#
public MapMarkerRule MapMarkerRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointRules Class
MapPointRules Members


MapSizeRule Property

[image]
ActiveReports 19 .NET Edition
MapSizeRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapSizeRule Property

Glossary Item Box

Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size

Syntax

Visual Basic (Declaration)
Public Property MapSizeRule As MapSizeRule
C#
public MapSizeRule MapSizeRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointRules Class
MapPointRules Members


MapPointTemplate Class

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

Glossary Item Box

Defines a template to be applied to points within a point or polygon layer

Object Model

MapPointTemplate Class

Syntax

Visual Basic (Declaration)
Public Class MapPointTemplate
   Inherits MapSpatialElementTemplate
C#
public class MapPointTemplate : MapSpatialElementTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapMarkerTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Class Members

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

Glossary Item Box

The following tables list the members exposed by MapPointTemplate.

Public Constructors

 | Name | Description
Public Constructor | MapPointTemplate Constructor | Initializes a new instance of the MapPointTemplate class.
Top

Public Properties

 | Name | Description
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of MapPointTemplate.MapPointLabelPlacement. The default value is MapPointTemplate.MapPointLabelPlacement.Bottom.
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a Length. The default value is 5.25pt.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Constructor

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : MapPointTemplate Constructor

Glossary Item Box

Initializes a new instance of the MapPointTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPointTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPointTemplate Class Methods

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

Glossary Item Box

For a list of all members of this type, see MapPointTemplate members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPointTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
MapPointTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

Glossary Item Box

For a list of all members of this type, see MapPointTemplate members.

Public Properties

 | Name | Description
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of MapPointTemplate.MapPointLabelPlacement. The default value is MapPointTemplate.MapPointLabelPlacement.Bottom.
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a Length. The default value is 5.25pt.
Top

See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : LabelPlacement Property

Glossary Item Box

Gets or sets the label placement for the point. That evaluates to one of MapPointTemplate.MapPointLabelPlacement. The default value is MapPointTemplate.MapPointLabelPlacement.Bottom.

Syntax

Visual Basic (Declaration)
Public Property LabelPlacement As ExpressionInfo
C#
public ExpressionInfo LabelPlacement {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : Size Property

Glossary Item Box

Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a Length. The default value is 5.25pt.

Syntax

Visual Basic (Declaration)
Public Property Size As ExpressionInfo
C#
public ExpressionInfo Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPointTemplate.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapPointTemplate.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate.Defaults Class

Glossary Item Box

The default values of the MapPointTemplate class properties.

Object Model

MapPointTemplate.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapPointTemplate.Defaults
C#
public static class MapPointTemplate.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapPointTemplate.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapPointTemplate.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor | Default value for the backgroundgolor of the point marker.
Public Field | LabelPlacement | Default value for the label placement for the point marker.
Public Field | Size | Default value for the height and width of the plotting area of the point marker.
Top

See Also

Reference

MapPointTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapPointTemplate.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapPointTemplate.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor | Default value for the backgroundgolor of the point marker.
Public Field | LabelPlacement | Default value for the label placement for the point marker.
Public Field | Size | Default value for the height and width of the plotting area of the point marker.
Top

See Also

Reference

MapPointTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate.Defaults Class : BackgroundColor Field

Glossary Item Box

Default value for the backgroundgolor of the point marker.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundColor As String
C#
public static readonly string BackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate.Defaults Class
MapPointTemplate.Defaults Members


LabelPlacement Field

[image]
ActiveReports 19 .NET Edition
LabelPlacement Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate.Defaults Class : LabelPlacement Field

Glossary Item Box

Default value for the label placement for the point marker.

Syntax

Visual Basic (Declaration)
Public Const LabelPlacement As MapPointTemplate.MapPointLabelPlacement
C#
public const MapPointTemplate.MapPointLabelPlacement LabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate.Defaults Class
MapPointTemplate.Defaults Members


Size Field

[image]
ActiveReports 19 .NET Edition
Size Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate.Defaults Class : Size Field

Glossary Item Box

Default value for the height and width of the plotting area of the point marker.

Syntax

Visual Basic (Declaration)
Public Const Size As String
C#
public const string Size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPointTemplate.Defaults Class
MapPointTemplate.Defaults Members


MapPolygon Class

[image]
ActiveReports 19 .NET Edition
MapPolygon Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

Glossary Item Box

Defines an element to be embedded within a MapPolygonLayer

Object Model

MapPolygon Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPolygon
   Inherits MapSpatialElement
C#
public sealed class MapPolygon : MapSpatialElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapPolygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygon Class Members

[image]
ActiveReports 19 .NET Edition
MapPolygon Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

Glossary Item Box

The following tables list the members exposed by MapPolygon.

Public Constructors

 | Name | Description
Public Constructor | MapPolygon Constructor | Initializes a new instance of the MapPolygon class.
Top

Public Fields

 | Name | Description
Public Field | DefaultUseCustomCenterPointTemplate | Defaul value defining will the custom point template be used for the polygon center point or the layer template.
Public Field | DefaultUseCustomPolygonTemplate | Defaul value defining will the custom polygon template be used for the polygon or the layer template.
Top

Public Properties

 | Name | Description
Public Property | MapCenterPointTemplate | Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.
Public Property | MapPolygonTemplate | Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.
Public Property | UseCustomCenterPointTemplate | Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | UseCustomPolygonTemplate | Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapPolygon Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygon Constructor

[image]
ActiveReports 19 .NET Edition
MapPolygon Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapPolygon Constructor

Glossary Item Box

Initializes a new instance of the MapPolygon class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPolygon()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygon Class Properties

[image]
ActiveReports 19 .NET Edition
MapPolygon Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

Glossary Item Box

For a list of all members of this type, see MapPolygon members.

Public Properties

 | Name | Description
Public Property | MapCenterPointTemplate | Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.
Public Property | MapPolygonTemplate | Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.
Public Property | UseCustomCenterPointTemplate | Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | UseCustomPolygonTemplate | Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Top

See Also

Reference

MapPolygon Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCenterPointTemplate Property

[image]
ActiveReports 19 .NET Edition
MapCenterPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapCenterPointTemplate Property

Glossary Item Box

Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.

Syntax

Visual Basic (Declaration)
Public Property MapCenterPointTemplate As MapMarkerTemplate
C#
public MapMarkerTemplate MapCenterPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygonTemplate Property

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapPolygonTemplate Property

Glossary Item Box

Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.

Syntax

Visual Basic (Declaration)
Public Property MapPolygonTemplate As MapPolygonTemplate
C#
public MapPolygonTemplate MapPolygonTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


UseCustomCenterPointTemplate Property

[image]
ActiveReports 19 .NET Edition
UseCustomCenterPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : UseCustomCenterPointTemplate Property

Glossary Item Box

Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property UseCustomCenterPointTemplate As ExpressionInfo
C#
public ExpressionInfo UseCustomCenterPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


UseCustomPolygonTemplate Property

[image]
ActiveReports 19 .NET Edition
UseCustomPolygonTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : UseCustomPolygonTemplate Property

Glossary Item Box

Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property UseCustomPolygonTemplate As ExpressionInfo
C#
public ExpressionInfo UseCustomPolygonTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygon Class Fields

[image]
ActiveReports 19 .NET Edition
MapPolygon Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

Glossary Item Box

For a list of all members of this type, see MapPolygon members.

Public Fields

 | Name | Description
Public Field | DefaultUseCustomCenterPointTemplate | Defaul value defining will the custom point template be used for the polygon center point or the layer template.
Public Field | DefaultUseCustomPolygonTemplate | Defaul value defining will the custom polygon template be used for the polygon or the layer template.
Top

See Also

Reference

MapPolygon Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultUseCustomCenterPointTemplate Field

[image]
ActiveReports 19 .NET Edition
DefaultUseCustomCenterPointTemplate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : DefaultUseCustomCenterPointTemplate Field

Glossary Item Box

Defaul value defining will the custom point template be used for the polygon center point or the layer template.

Syntax

Visual Basic (Declaration)
Public Const DefaultUseCustomCenterPointTemplate As String
C#
public const string DefaultUseCustomCenterPointTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


DefaultUseCustomPolygonTemplate Field

[image]
ActiveReports 19 .NET Edition
DefaultUseCustomPolygonTemplate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : DefaultUseCustomPolygonTemplate Field

Glossary Item Box

Defaul value defining will the custom polygon template be used for the polygon or the layer template.

Syntax

Visual Basic (Declaration)
Public Const DefaultUseCustomPolygonTemplate As String
C#
public const string DefaultUseCustomPolygonTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygonLayer Class

[image]
ActiveReports 19 .NET Edition
MapPolygonLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class

Glossary Item Box

Defines a vector-based layer of polygons to be drawn within a map.

Object Model

MapPolygonLayer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPolygonLayer
   Inherits MapVectorLayer
C#
public sealed class MapPolygonLayer : MapVectorLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapPolygonLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapPolygonLayer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class

Glossary Item Box

The following tables list the members exposed by MapPolygonLayer.

Public Constructors

 | Name | Description
Public Constructor | MapPolygonLayer Constructor | Initializes a new instance of the MapPolygonLayer class.
Top

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Returns a collection of layer elements.
Public Property | MapCenterPointRules | Gets or sets the set of rules to be applied for polygon center point.
Public Property | MapCenterPointTemplate | Gets or sets the template to be applied for polygon center point.
Public Property | MapPolygonRules | Gets or sets the set of rules to be applied for polygons within the layer.
Public Property | MapPolygons | Gets the set of embedded polygons in the layer.
Public Property | MapPolygonTemplate | Gets or sets the template to be applied for polygons within the layer.
Top

See Also

Reference

MapPolygonLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonLayer Constructor

[image]
ActiveReports 19 .NET Edition
MapPolygonLayer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonLayer Constructor

Glossary Item Box

Initializes a new instance of the MapPolygonLayer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPolygonLayer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapPolygonLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class

Glossary Item Box

For a list of all members of this type, see MapPolygonLayer members.

Public Properties

 | Name | Description
Public Property | Elements | Overridden. Returns a collection of layer elements.
Public Property | MapCenterPointRules | Gets or sets the set of rules to be applied for polygon center point.
Public Property | MapCenterPointTemplate | Gets or sets the template to be applied for polygon center point.
Public Property | MapPolygonRules | Gets or sets the set of rules to be applied for polygons within the layer.
Public Property | MapPolygons | Gets the set of embedded polygons in the layer.
Public Property | MapPolygonTemplate | Gets or sets the template to be applied for polygons within the layer.
Top

See Also

Reference

MapPolygonLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : Elements Property

Glossary Item Box

Returns a collection of layer elements.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Elements As IEnumerable(Of MapSpatialElement)
C#
public override IEnumerable<MapSpatialElement> Elements {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapCenterPointRules Property

[image]
ActiveReports 19 .NET Edition
MapCenterPointRules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapCenterPointRules Property

Glossary Item Box

Gets or sets the set of rules to be applied for polygon center point.

Syntax

Visual Basic (Declaration)
Public Property MapCenterPointRules As MapPointRules
C#
public MapPointRules MapCenterPointRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapCenterPointTemplate Property

[image]
ActiveReports 19 .NET Edition
MapCenterPointTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapCenterPointTemplate Property

Glossary Item Box

Gets or sets the template to be applied for polygon center point.

Syntax

Visual Basic (Declaration)
Public Property MapCenterPointTemplate As MapMarkerTemplate
C#
public MapMarkerTemplate MapCenterPointTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonRules Property

[image]
ActiveReports 19 .NET Edition
MapPolygonRules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonRules Property

Glossary Item Box

Gets or sets the set of rules to be applied for polygons within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapPolygonRules As MapPolygonRules
C#
public MapPolygonRules MapPolygonRules {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygons Property

[image]
ActiveReports 19 .NET Edition
MapPolygons Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygons Property

Glossary Item Box

Gets the set of embedded polygons in the layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapPolygons As IList(Of MapPolygon)
C#
public IList<MapPolygon> MapPolygons {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonTemplate Property

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonTemplate Property

Glossary Item Box

Gets or sets the template to be applied for polygons within the layer.

Syntax

Visual Basic (Declaration)
Public Property MapPolygonTemplate As MapPolygonTemplate
C#
public MapPolygonTemplate MapPolygonTemplate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonRules Class

[image]
ActiveReports 19 .NET Edition
MapPolygonRules Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class

Glossary Item Box

Defines a set of rules to be applied on polygons

Object Model

MapPolygonRules Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPolygonRules
C#
public sealed class MapPolygonRules

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPolygonRules

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonRules Class Members

[image]
ActiveReports 19 .NET Edition
MapPolygonRules Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class

Glossary Item Box

The following tables list the members exposed by MapPolygonRules.

Public Constructors

 | Name | Description
Public Constructor | MapPolygonRules Constructor | Initializes a new instance of the MapPolygonRules class.
Top

Public Properties

 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the polygon based on a data field. Overrides %%
Top

See Also

Reference

MapPolygonRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonRules Constructor

[image]
ActiveReports 19 .NET Edition
MapPolygonRules Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonRules Class : MapPolygonRules Constructor

Glossary Item Box

Initializes a new instance of the MapPolygonRules class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPolygonRules()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonRules Class
MapPolygonRules Members


MapPolygonRules Class Properties

[image]
ActiveReports 19 .NET Edition
MapPolygonRules Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class

Glossary Item Box

For a list of all members of this type, see MapPolygonRules members.

Public Properties

 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the polygon based on a data field. Overrides %%
Top

See Also

Reference

MapPolygonRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property

[image]
ActiveReports 19 .NET Edition
MapColorRule Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonRules Class : MapColorRule Property

Glossary Item Box

Gets or sets the color of the polygon based on a data field. Overrides scrap:condition=communityenabled,name=_COMMUNITY_SECTION,contenttype=summary%%

Syntax

Visual Basic (Declaration)
Public Property MapColorRule As MapColorRule
C#
public MapColorRule MapColorRule {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonRules Class
MapPolygonRules Members


MapPolygonTemplate Class

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

Glossary Item Box

Defines a template to be applied to polygons within a polygon layer.

Object Model

MapPolygonTemplate Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapPolygonTemplate
   Inherits MapSpatialElementTemplate
C#
public sealed class MapPolygonTemplate : MapSpatialElementTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate Class Members

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

Glossary Item Box

The following tables list the members exposed by MapPolygonTemplate.

Public Constructors

 | Name | Description
Public Constructor | MapPolygonTemplate Constructor | Initializes a new instance of the MapPolygonTemplate class.
Top

Public Properties

 | Name | Description
Public Property | CenterPointOffsetX | Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | CenterPointOffsetY | Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | LabelPlacement | Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.
Public Property | ScaleFactor | Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.
Public Property | ShowLabel | Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate Constructor

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : MapPolygonTemplate Constructor

Glossary Item Box

Initializes a new instance of the MapPolygonTemplate class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapPolygonTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapPolygonTemplate Class Methods

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

Glossary Item Box

For a list of all members of this type, see MapPolygonTemplate members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapPolygonTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

Glossary Item Box

For a list of all members of this type, see MapPolygonTemplate members.

Public Properties

 | Name | Description
Public Property | CenterPointOffsetX | Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | CenterPointOffsetY | Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | LabelPlacement | Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.
Public Property | ScaleFactor | Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.
Public Property | ShowLabel | Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.
Top

See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterPointOffsetX Property

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : CenterPointOffsetX Property

Glossary Item Box

Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property CenterPointOffsetX As ExpressionInfo
C#
public ExpressionInfo CenterPointOffsetX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


CenterPointOffsetY Property

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : CenterPointOffsetY Property

Glossary Item Box

Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property CenterPointOffsetY As ExpressionInfo
C#
public ExpressionInfo CenterPointOffsetY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : LabelPlacement Property

Glossary Item Box

Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.

Syntax

Visual Basic (Declaration)
Public Property LabelPlacement As ExpressionInfo
C#
public ExpressionInfo LabelPlacement {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


ScaleFactor Property

[image]
ActiveReports 19 .NET Edition
ScaleFactor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : ScaleFactor Property

Glossary Item Box

Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.

Syntax

Visual Basic (Declaration)
Public Property ScaleFactor As ExpressionInfo
C#
public ExpressionInfo ScaleFactor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


ShowLabel Property

[image]
ActiveReports 19 .NET Edition
ShowLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : ShowLabel Property

Glossary Item Box

Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.

Syntax

Visual Basic (Declaration)
Public Property ShowLabel As ExpressionInfo
C#
public ExpressionInfo ShowLabel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapPolygonTemplate.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.Defaults Class

Glossary Item Box

The default values of the MapPolygonTemplate class properties.

Object Model

MapPolygonTemplate.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapPolygonTemplate.Defaults
C#
public static class MapPolygonTemplate.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapPolygonTemplate.Defaults.

Public Fields

 | Name | Description
Public Field | CenterPointOffsetX | Default value for the X offset for the polygon center point in geographic units.
Public Field | CenterPointOffsetY | Default value for the Y offset for the polygon center point in geographic units.
Public Field | LabelPlacement | Default value for the label placement of the polygon.
Public Field | ScaleFactor | Default value for the factor by which the polygon will be scaled.
Public Field | ShowLabel | Default value defining should the label be shown or not.
Top

See Also

Reference

MapPolygonTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapPolygonTemplate.Defaults members.

Public Fields

 | Name | Description
Public Field | CenterPointOffsetX | Default value for the X offset for the polygon center point in geographic units.
Public Field | CenterPointOffsetY | Default value for the Y offset for the polygon center point in geographic units.
Public Field | LabelPlacement | Default value for the label placement of the polygon.
Public Field | ScaleFactor | Default value for the factor by which the polygon will be scaled.
Public Field | ShowLabel | Default value defining should the label be shown or not.
Top

See Also

Reference

MapPolygonTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterPointOffsetX Field

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate.Defaults Class : CenterPointOffsetX Field

Glossary Item Box

Default value for the X offset for the polygon center point in geographic units.

Syntax

Visual Basic (Declaration)
Public Const CenterPointOffsetX As Double
C#
public const double CenterPointOffsetX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Class
MapPolygonTemplate.Defaults Members


CenterPointOffsetY Field

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate.Defaults Class : CenterPointOffsetY Field

Glossary Item Box

Default value for the Y offset for the polygon center point in geographic units.

Syntax

Visual Basic (Declaration)
Public Const CenterPointOffsetY As Double
C#
public const double CenterPointOffsetY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Class
MapPolygonTemplate.Defaults Members


LabelPlacement Field

[image]
ActiveReports 19 .NET Edition
LabelPlacement Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate.Defaults Class : LabelPlacement Field

Glossary Item Box

Default value for the label placement of the polygon.

Syntax

Visual Basic (Declaration)
Public Const LabelPlacement As MapPolygonTemplate.PolygonLabelPlacement
C#
public const MapPolygonTemplate.PolygonLabelPlacement LabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Class
MapPolygonTemplate.Defaults Members


ScaleFactor Field

[image]
ActiveReports 19 .NET Edition
ScaleFactor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate.Defaults Class : ScaleFactor Field

Glossary Item Box

Default value for the factor by which the polygon will be scaled.

Syntax

Visual Basic (Declaration)
Public Const ScaleFactor As Double
C#
public const double ScaleFactor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Class
MapPolygonTemplate.Defaults Members


ShowLabel Field

[image]
ActiveReports 19 .NET Edition
ShowLabel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate.Defaults Class : ShowLabel Field

Glossary Item Box

Default value defining should the label be shown or not.

Syntax

Visual Basic (Declaration)
Public Const ShowLabel As MapPolygonTemplate.PolygonShowLabel
C#
public const MapPolygonTemplate.PolygonShowLabel ShowLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapPolygonTemplate.Defaults Class
MapPolygonTemplate.Defaults Members


MapShapefile Class

[image]
ActiveReports 19 .NET Edition
MapShapefile Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class

Glossary Item Box

Defines a file-based source for spatial data and possibly non-spatial data

Object Model

MapShapefile Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapShapefile
   Inherits MapSpatialData
C#
public sealed class MapShapefile : MapSpatialData

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapShapefile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapShapefile Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapShapefile Class Members

[image]
ActiveReports 19 .NET Edition
MapShapefile Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class

Glossary Item Box

The following tables list the members exposed by MapShapefile.

Public Constructors

 | Name | Description
Public Constructor | MapShapefile Constructor | Initializes a new instance of the MapShapefile class.
Top

Public Properties

 | Name | Description
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the shape file.
Public Property | Source | Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.
Top

See Also

Reference

MapShapefile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapShapefile Constructor

[image]
ActiveReports 19 .NET Edition
MapShapefile Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : MapShapefile Constructor

Glossary Item Box

Initializes a new instance of the MapShapefile class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapShapefile()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapShapefile Class
MapShapefile Members


MapShapefile Class Properties

[image]
ActiveReports 19 .NET Edition
MapShapefile Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class

Glossary Item Box

For a list of all members of this type, see MapShapefile members.

Public Properties

 | Name | Description
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the shape file.
Public Property | Source | Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.
Top

See Also

Reference

MapShapefile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldNames Property

[image]
ActiveReports 19 .NET Edition
MapFieldNames Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : MapFieldNames Property

Glossary Item Box

Gets the set of non-spatial data fields to be imported from the shape file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapFieldNames As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> MapFieldNames {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapShapefile Class
MapShapefile Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : Source Property

Glossary Item Box

Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property Source As ExpressionInfo
C#
public ExpressionInfo Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapShapefile Class
MapShapefile Members


MapSize Class

[image]
ActiveReports 19 .NET Edition
MapSize Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class

Glossary Item Box

Defines the properties for map sub items size

Object Model

MapSize Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapSize
C#
public sealed class MapSize

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSize Class Members

[image]
ActiveReports 19 .NET Edition
MapSize Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class

Glossary Item Box

The following tables list the members exposed by MapSize.

Public Constructors

 | Name | Description
Public Constructor | MapSize Constructor | Initializes a new instance of the MapSize class.
Top

Public Properties

 | Name | Description
Public Property | Height | Height of the item. An expression should evaluate to a System.Double.
Public Property | Unit | Gets or sets the unit for both width and height. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.
Public Property | Width | Width of the item. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapSize Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSize Constructor

[image]
ActiveReports 19 .NET Edition
MapSize Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : MapSize Constructor

Glossary Item Box

Initializes a new instance of the MapSize class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapSize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


MapSize Class Properties

[image]
ActiveReports 19 .NET Edition
MapSize Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class

Glossary Item Box

For a list of all members of this type, see MapSize members.

Public Properties

 | Name | Description
Public Property | Height | Height of the item. An expression should evaluate to a System.Double.
Public Property | Unit | Gets or sets the unit for both width and height. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.
Public Property | Width | Width of the item. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapSize Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Height Property

Glossary Item Box

Height of the item. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property Height As ExpressionInfo
C#
public ExpressionInfo Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Unit Property

Glossary Item Box

Gets or sets the unit for both width and height. That evaluates to one of MapUnit. The default value is MapUnit.Percentage.

Syntax

Visual Basic (Declaration)
Public Property Unit As ExpressionInfo
C#
public ExpressionInfo Unit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Width Property

Glossary Item Box

Width of the item. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property Width As ExpressionInfo
C#
public ExpressionInfo Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


MapSizeRule Class

[image]
ActiveReports 19 .NET Edition
MapSizeRule Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

Glossary Item Box

Defines the size rule for point or line based on a data field

Object Model

MapSizeRule Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapSizeRule
   Inherits MapAppearanceRule
C#
public sealed class MapSizeRule : MapAppearanceRule

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapSizeRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSizeRule Class Members

[image]
ActiveReports 19 .NET Edition
MapSizeRule Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

Glossary Item Box

The following tables list the members exposed by MapSizeRule.

Public Constructors

 | Name | Description
Public Constructor | MapSizeRule Constructor | Initializes a new instance of the MapSizeRule class.
Top

Public Fields

 | Name | Description
Public Field | EndSizeDefaultValue | Default value of the end size to be used for the map elements.
Public Field | StartSizeDefaultValue | Default value of the start size to be used for the map elements.
Top

Public Properties

 | Name | Description
Public Property | EndSize | Gets or sets the end size to be used for the map elements.
Public Property | StartSize | Gets or sets the start size to be used for the map elements.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns expressions used for the map elements.
Top

See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSizeRule Constructor

[image]
ActiveReports 19 .NET Edition
MapSizeRule Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : MapSizeRule Constructor

Glossary Item Box

Initializes a new instance of the MapSizeRule class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapSizeRule()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSizeRule Class Methods

[image]
ActiveReports 19 .NET Edition
MapSizeRule Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

Glossary Item Box

For a list of all members of this type, see MapSizeRule members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns expressions used for the map elements.
Top

See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : GetExpressions Method

Glossary Item Box

Returns expressions used for the map elements.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As IEnumerable(Of ExpressionInfo)
C#
public override IEnumerable<ExpressionInfo> GetExpressions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSizeRule Class Properties

[image]
ActiveReports 19 .NET Edition
MapSizeRule Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

Glossary Item Box

For a list of all members of this type, see MapSizeRule members.

Public Properties

 | Name | Description
Public Property | EndSize | Gets or sets the end size to be used for the map elements.
Public Property | StartSize | Gets or sets the start size to be used for the map elements.
Top

See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndSize Property

[image]
ActiveReports 19 .NET Edition
EndSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : EndSize Property

Glossary Item Box

Gets or sets the end size to be used for the map elements.

Syntax

Visual Basic (Declaration)
Public Property EndSize As ExpressionInfo
C#
public ExpressionInfo EndSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


StartSize Property

[image]
ActiveReports 19 .NET Edition
StartSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : StartSize Property

Glossary Item Box

Gets or sets the start size to be used for the map elements.

Syntax

Visual Basic (Declaration)
Public Property StartSize As ExpressionInfo
C#
public ExpressionInfo StartSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSizeRule Class Fields

[image]
ActiveReports 19 .NET Edition
MapSizeRule Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

Glossary Item Box

For a list of all members of this type, see MapSizeRule members.

Public Fields

 | Name | Description
Public Field | EndSizeDefaultValue | Default value of the end size to be used for the map elements.
Public Field | StartSizeDefaultValue | Default value of the start size to be used for the map elements.
Top

See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndSizeDefaultValue Field

[image]
ActiveReports 19 .NET Edition
EndSizeDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : EndSizeDefaultValue Field

Glossary Item Box

Default value of the end size to be used for the map elements.

Syntax

Visual Basic (Declaration)
Public Const EndSizeDefaultValue As String
C#
public const string EndSizeDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


StartSizeDefaultValue Field

[image]
ActiveReports 19 .NET Edition
StartSizeDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : StartSizeDefaultValue Field

Glossary Item Box

Default value of the start size to be used for the map elements.

Syntax

Visual Basic (Declaration)
Public Const StartSizeDefaultValue As String
C#
public const string StartSizeDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSpatialData Class

[image]
ActiveReports 19 .NET Edition
MapSpatialData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialData Class

Glossary Item Box

Defines the source of spatial data for a vector layer

Object Model

MapSpatialData Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapSpatialData
C#
public abstract class MapSpatialData

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapShapefile
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataRegion
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialData Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialData Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialData Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialData Class

Glossary Item Box

The following tables list the members exposed by MapSpatialData.

See Also

Reference

MapSpatialData Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Class

[image]
ActiveReports 19 .NET Edition
MapSpatialDataRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataRegion Class

Glossary Item Box

Defines a data region-based source for spatial data

Object Model

MapSpatialDataRegion Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapSpatialDataRegion
   Inherits MapSpatialData
C#
public sealed class MapSpatialDataRegion : MapSpatialData

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialDataRegion Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataRegion Class

Glossary Item Box

The following tables list the members exposed by MapSpatialDataRegion.

Public Constructors

 | Name | Description
Public Constructor | MapSpatialDataRegion Constructor | Initializes a new instance of the MapSpatialDataRegion class.
Top

Public Properties

 | Name | Description
Public Property | VectorData | Gets or sets vector data for a map element. An expression that is evaluated for each inner most group instance of the data region. The expected value is either SqlGeometry or SqlGeography. If <> Null, the appropriate map element will be created and added to the layer.
Top

See Also

Reference

MapSpatialDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Constructor

[image]
ActiveReports 19 .NET Edition
MapSpatialDataRegion Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataRegion Class : MapSpatialDataRegion Constructor

Glossary Item Box

Initializes a new instance of the MapSpatialDataRegion class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapSpatialDataRegion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataRegion Class
MapSpatialDataRegion Members


MapSpatialDataRegion Class Properties

[image]
ActiveReports 19 .NET Edition
MapSpatialDataRegion Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataRegion Class

Glossary Item Box

For a list of all members of this type, see MapSpatialDataRegion members.

Public Properties

 | Name | Description
Public Property | VectorData | Gets or sets vector data for a map element. An expression that is evaluated for each inner most group instance of the data region. The expected value is either SqlGeometry or SqlGeography. If <> Null, the appropriate map element will be created and added to the layer.
Top

See Also

Reference

MapSpatialDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


VectorData Property

[image]
ActiveReports 19 .NET Edition
VectorData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataRegion Class : VectorData Property

Glossary Item Box

Gets or sets vector data for a map element. An expression that is evaluated for each inner most group instance of the data region. The expected value is either SqlGeometry or SqlGeography. If <> Null, the appropriate map element will be created and added to the layer.

Syntax

Visual Basic (Declaration)
Public Property VectorData As ExpressionInfo
C#
public ExpressionInfo VectorData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataRegion Class
MapSpatialDataRegion Members


MapSpatialDataSet Class

[image]
ActiveReports 19 .NET Edition
MapSpatialDataSet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class

Glossary Item Box

Defines a dataset-based source for spatial and possibly non-spatial data.

Object Model

MapSpatialDataSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapSpatialDataSet
   Inherits MapSpatialData
C#
public sealed class MapSpatialDataSet : MapSpatialData

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataSet Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialDataSet Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class

Glossary Item Box

The following tables list the members exposed by MapSpatialDataSet.

Public Constructors

 | Name | Description
Public Constructor | MapSpatialDataSet Constructor | Initializes a new instance of the MapSpatialDataSet class.
Top

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the data set.
Public Property | SpatialField | Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.
Top

See Also

Reference

MapSpatialDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataSet Constructor

[image]
ActiveReports 19 .NET Edition
MapSpatialDataSet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : MapSpatialDataSet Constructor

Glossary Item Box

Initializes a new instance of the MapSpatialDataSet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapSpatialDataSet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapSpatialDataSet Class Properties

[image]
ActiveReports 19 .NET Edition
MapSpatialDataSet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class

Glossary Item Box

For a list of all members of this type, see MapSpatialDataSet members.

Public Properties

 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the data set.
Public Property | SpatialField | Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.
Top

See Also

Reference

MapSpatialDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : DataSetName Property

Glossary Item Box

Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property DataSetName As ExpressionInfo
C#
public ExpressionInfo DataSetName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapFieldNames Property

[image]
ActiveReports 19 .NET Edition
MapFieldNames Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : MapFieldNames Property

Glossary Item Box

Gets the set of non-spatial data fields to be imported from the data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapFieldNames As IList(Of ExpressionInfo)
C#
public IList<ExpressionInfo> MapFieldNames {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


SpatialField Property

[image]
ActiveReports 19 .NET Edition
SpatialField Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : SpatialField Property

Glossary Item Box

Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property SpatialField As ExpressionInfo
C#
public ExpressionInfo SpatialField {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapSpatialElement Class

[image]
ActiveReports 19 .NET Edition
MapSpatialElement Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class

Glossary Item Box

Defines a spatial element to be embedded within a static layer

Object Model

MapSpatialElement Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapSpatialElement
C#
public abstract class MapSpatialElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapLine
GrapeCity.ActiveReports.PageReportModel.MapPoint
GrapeCity.ActiveReports.PageReportModel.MapPolygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElement Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElement Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialElement Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class

Glossary Item Box

The following tables list the members exposed by MapSpatialElement.

Public Properties

 | Name | Description
Public Property | MapFields | Gets a set of fields for the element.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string)
Top

See Also

Reference

MapSpatialElement Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElement Class Properties

[image]
ActiveReports 19 .NET Edition
MapSpatialElement Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class

Glossary Item Box

For a list of all members of this type, see MapSpatialElement members.

Public Properties

 | Name | Description
Public Property | MapFields | Gets a set of fields for the element.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string)
Top

See Also

Reference

MapSpatialElement Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFields Property

[image]
ActiveReports 19 .NET Edition
MapFields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElement Class : MapFields Property

Glossary Item Box

Gets a set of fields for the element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapFields As ICollection(Of MapField)
C#
public ICollection<MapField> MapFields {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElement Class
MapSpatialElement Members


VectorData Property

[image]
ActiveReports 19 .NET Edition
VectorData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElement Class : VectorData Property

Glossary Item Box

Gets or sets the element vector data. (Based-64 encoded string)

Syntax

Visual Basic (Declaration)
Public Property VectorData As String
C#
public string VectorData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElement Class
MapSpatialElement Members


MapSpatialElementTemplate Class

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

Glossary Item Box

Defines the template to be applied on map spatial elements within a vector layer

Object Model

MapSpatialElementTemplate Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapSpatialElementTemplate
C#
public abstract class MapSpatialElementTemplate

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

Glossary Item Box

The following tables list the members exposed by MapSpatialElementTemplate.

Public Properties

 | Name | Description
Public Property | ActionInfo | Actions for the map elements.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate Class Methods

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

Glossary Item Box

For a list of all members of this type, see MapSpatialElementTemplate members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone() As Object
C#
public abstract object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


MapSpatialElementTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

Glossary Item Box

For a list of all members of this type, see MapSpatialElementTemplate members.

Public Properties

 | Name | Description
Public Property | ActionInfo | Actions for the map elements.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String.
Top

See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property

[image]
ActiveReports 19 .NET Edition
ActionInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : ActionInfo Property

Glossary Item Box

Actions for the map elements.

Syntax

Visual Basic (Declaration)
Public Property ActionInfo As ActionInfo
C#
public ActionInfo ActionInfo {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementLabel Property

[image]
ActiveReports 19 .NET Edition
DataElementLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementLabel Property

Glossary Item Box

The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property DataElementLabel As ExpressionInfo
C#
public ExpressionInfo DataElementLabel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementName Property

Glossary Item Box

The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementOutput Property

Glossary Item Box

Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Hidden Property

Glossary Item Box

Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Label Property

Glossary Item Box

The label to display on the map elements. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


OffsetX Property

[image]
ActiveReports 19 .NET Edition
OffsetX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : OffsetX Property

Glossary Item Box

Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property OffsetX As ExpressionInfo
C#
public ExpressionInfo OffsetX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


OffsetY Property

[image]
ActiveReports 19 .NET Edition
OffsetY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : OffsetY Property

Glossary Item Box

Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property OffsetY As ExpressionInfo
C#
public ExpressionInfo OffsetY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Style Property

Glossary Item Box

Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : ToolTip Property

Glossary Item Box

Tool tip to display for the map elements. An expression should evaluate to a System.String.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As ExpressionInfo
C#
public ExpressionInfo ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


MapSpatialElementTemplate.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate.Defaults Class

Glossary Item Box

The default values of the MapSpatialElementTemplate class properties.

Object Model

MapSpatialElementTemplate.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapSpatialElementTemplate.Defaults
C#
public static class MapSpatialElementTemplate.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapSpatialElementTemplate.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor | Default value for the background color.
static (Shared in Visual Basic) | BackgroundGradientEndColor | Default value for the end color of the background gradient.
static (Shared in Visual Basic) | BorderColor | Default value for the border color.
static (Shared in Visual Basic) | BorderStyle | Default value for the border style.
Public Field | DataElementOutput | Default value defining how an item should appear in data output.
static (Shared in Visual Basic) | FontSize | Default value for the point size of the font.
Public Field | OffsetX | Default value for the X offset for the element in geographic units.
Public Field | OffsetY | Default value for the Y offset for the element in geographic units.
Top

See Also

Reference

MapSpatialElementTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapSpatialElementTemplate.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapSpatialElementTemplate.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor | Default value for the background color.
static (Shared in Visual Basic) | BackgroundGradientEndColor | Default value for the end color of the background gradient.
static (Shared in Visual Basic) | BorderColor | Default value for the border color.
static (Shared in Visual Basic) | BorderStyle | Default value for the border style.
Public Field | DataElementOutput | Default value defining how an item should appear in data output.
static (Shared in Visual Basic) | FontSize | Default value for the point size of the font.
Public Field | OffsetX | Default value for the X offset for the element in geographic units.
Public Field | OffsetY | Default value for the Y offset for the element in geographic units.
Top

See Also

Reference

MapSpatialElementTemplate.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : BackgroundColor Field

Glossary Item Box

Default value for the background color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundColor As String
C#
public static readonly string BackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


BackgroundGradientEndColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : BackgroundGradientEndColor Field

Glossary Item Box

Default value for the end color of the background gradient.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundGradientEndColor As String
C#
public static readonly string BackgroundGradientEndColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


BorderColor Field

[image]
ActiveReports 19 .NET Edition
BorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : BorderColor Field

Glossary Item Box

Default value for the border color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BorderColor As String
C#
public static readonly string BorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


BorderStyle Field

[image]
ActiveReports 19 .NET Edition
BorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : BorderStyle Field

Glossary Item Box

Default value for the border style.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BorderStyle As BorderDrawingStyle
C#
public static readonly BorderDrawingStyle BorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


DataElementOutput Field

[image]
ActiveReports 19 .NET Edition
DataElementOutput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : DataElementOutput Field

Glossary Item Box

Default value defining how an item should appear in data output.

Syntax

Visual Basic (Declaration)
Public Const DataElementOutput As DataElementOutput
C#
public const DataElementOutput DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


FontSize Field

[image]
ActiveReports 19 .NET Edition
FontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : FontSize Field

Glossary Item Box

Default value for the point size of the font.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontSize As String
C#
public static readonly string FontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


OffsetX Field

[image]
ActiveReports 19 .NET Edition
OffsetX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : OffsetX Field

Glossary Item Box

Default value for the X offset for the element in geographic units.

Syntax

Visual Basic (Declaration)
Public Const OffsetX As Double
C#
public const double OffsetX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


OffsetY Field

[image]
ActiveReports 19 .NET Edition
OffsetY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate.Defaults Class : OffsetY Field

Glossary Item Box

Default value for the Y offset for the element in geographic units.

Syntax

Visual Basic (Declaration)
Public Const OffsetY As Double
C#
public const double OffsetY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSpatialElementTemplate.Defaults Class
MapSpatialElementTemplate.Defaults Members


MapSubItem Class

[image]
ActiveReports 19 .NET Edition
MapSubItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class

Glossary Item Box

Defines the common properties for map sub items

Object Model

MapSubItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapSubItem
C#
public abstract class MapSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapViewport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem Class Members

[image]
ActiveReports 19 .NET Edition
MapSubItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class

Glossary Item Box

The following tables list the members exposed by MapSubItem.

Public Properties

 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Int32. The default value is 0.
Top

See Also

Reference

MapSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem Class Properties

[image]
ActiveReports 19 .NET Edition
MapSubItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class

Glossary Item Box

For a list of all members of this type, see MapSubItem members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a Length. The default value is 0 in.
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Int32. The default value is 0.
Top

See Also

Reference

MapSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : BottomMargin Property

Glossary Item Box

Width of the bottom margin. An expression should evaluate to a Length. The default value is 0 in.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As ExpressionInfo
C#
public ExpressionInfo BottomMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : LeftMargin Property

Glossary Item Box

Width of the left margin. An expression should evaluate to a Length. The default value is 0 in.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As ExpressionInfo
C#
public ExpressionInfo LeftMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


MapLocation Property

[image]
ActiveReports 19 .NET Edition
MapLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : MapLocation Property

Glossary Item Box

Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used.

Syntax

Visual Basic (Declaration)
Public Property MapLocation As MapLocation
C#
public MapLocation MapLocation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


MapSize Property

[image]
ActiveReports 19 .NET Edition
MapSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : MapSize Property

Glossary Item Box

Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.

Syntax

Visual Basic (Declaration)
Public Property MapSize As MapSize
C#
public MapSize MapSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : RightMargin Property

Glossary Item Box

Width of the right margin. An expression should evaluate to a Length. The default value is 0 in.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As ExpressionInfo
C#
public ExpressionInfo RightMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : Style Property

Glossary Item Box

Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : TopMargin Property

Glossary Item Box

Width of the top margin. An expression should evaluate to a Length. The default value is 0 in.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As ExpressionInfo
C#
public ExpressionInfo TopMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


ZIndex Property

[image]
ActiveReports 19 .NET Edition
ZIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : ZIndex Property

Glossary Item Box

Drawing order of the item within the map. An expression should evaluate to a System.Int32. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property ZIndex As ExpressionInfo
C#
public ExpressionInfo ZIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem Class
MapSubItem Members


MapSubItem.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapSubItem.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem.Defaults Class

Glossary Item Box

The default values of the common properties.

Object Model

MapSubItem.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapSubItem.Defaults
C#
public static class MapSubItem.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapSubItem.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapSubItem.Defaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor |
static (Shared in Visual Basic) | BackgroundGradientEndColor |
static (Shared in Visual Basic) | BackgroundGradientType | Default value of the color of the background. Default value of the end color for the background gradient. Default value of the end color for the background gradient.
static (Shared in Visual Basic) | BorderColor |
static (Shared in Visual Basic) | BorderStyle | Default value of the color of the border. Default value of the style of the border.
Public Field | Margin | Default value of the width of the margin.
Public Field | ShadowOffset | Default value of the shadow offset
Public Field | ZIndex | Default value of the drawing order.
Top

See Also

Reference

MapSubItem.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapSubItem.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapSubItem.Defaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundColor |
static (Shared in Visual Basic) | BackgroundGradientEndColor |
static (Shared in Visual Basic) | BackgroundGradientType | Default value of the color of the background. Default value of the end color for the background gradient. Default value of the end color for the background gradient.
static (Shared in Visual Basic) | BorderColor |
static (Shared in Visual Basic) | BorderStyle | Default value of the color of the border. Default value of the style of the border.
Public Field | Margin | Default value of the width of the margin.
Public Field | ShadowOffset | Default value of the shadow offset
Public Field | ZIndex | Default value of the drawing order.
Top

See Also

Reference

MapSubItem.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : BackgroundColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundColor As String
C#
public static readonly string BackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


BackgroundGradientEndColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : BackgroundGradientEndColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundGradientEndColor As String
C#
public static readonly string BackgroundGradientEndColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


BackgroundGradientType Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : BackgroundGradientType Field

Glossary Item Box

Default value of the color of the background. Default value of the end color for the background gradient. Default value of the end color for the background gradient.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundGradientType As String
C#
public static readonly string BackgroundGradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


BorderColor Field

[image]
ActiveReports 19 .NET Edition
BorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : BorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BorderColor As String
C#
public static readonly string BorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


BorderStyle Field

[image]
ActiveReports 19 .NET Edition
BorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : BorderStyle Field

Glossary Item Box

Default value of the color of the border. Default value of the style of the border.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BorderStyle As String
C#
public static readonly string BorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


Margin Field

[image]
ActiveReports 19 .NET Edition
Margin Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : Margin Field

Glossary Item Box

Default value of the width of the margin.

Syntax

Visual Basic (Declaration)
Public Const Margin As String
C#
public const string Margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


ShadowOffset Field

[image]
ActiveReports 19 .NET Edition
ShadowOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : ShadowOffset Field

Glossary Item Box

Default value of the shadow offset

Syntax

Visual Basic (Declaration)
Public Const ShadowOffset As String
C#
public const string ShadowOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


ZIndex Field

[image]
ActiveReports 19 .NET Edition
ZIndex Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem.Defaults Class : ZIndex Field

Glossary Item Box

Default value of the drawing order.

Syntax

Visual Basic (Declaration)
Public Const ZIndex As String
C#
public const string ZIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSubItem.Defaults Class
MapSubItem.Defaults Members


MapTile Class

[image]
ActiveReports 19 .NET Edition
MapTile Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class

Glossary Item Box

Defines a tile to be embedded in a MapTileLayer

Object Model

MapTile Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapTile
C#
public sealed class MapTile

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapTile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTile Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTile Class Members

[image]
ActiveReports 19 .NET Edition
MapTile Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class

Glossary Item Box

The following tables list the members exposed by MapTile.

Public Constructors

 | Name | Description
Public Constructor | MapTile Constructor | Initializes a new instance of the MapTile class.
Top

Public Properties

 | Name | Description
Public Property | MIMEType | The MIMEType for the image. Valid values are: image/jpeg, image/png.
Public Property | Name | TileName
Public Property | TileData | Based-64 encoded tile data
Top

See Also

Reference

MapTile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTile Constructor

[image]
ActiveReports 19 .NET Edition
MapTile Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : MapTile Constructor

Glossary Item Box

Initializes a new instance of the MapTile class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapTile()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTile Class
MapTile Members


MapTile Class Properties

[image]
ActiveReports 19 .NET Edition
MapTile Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class

Glossary Item Box

For a list of all members of this type, see MapTile members.

Public Properties

 | Name | Description
Public Property | MIMEType | The MIMEType for the image. Valid values are: image/jpeg, image/png.
Public Property | Name | TileName
Public Property | TileData | Based-64 encoded tile data
Top

See Also

Reference

MapTile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : MIMEType Property

Glossary Item Box

The MIMEType for the image. Valid values are: image/jpeg, image/png.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As String
C#
public string MIMEType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTile Class
MapTile Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : Name Property

Glossary Item Box

TileName

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTile Class
MapTile Members


TileData Property

[image]
ActiveReports 19 .NET Edition
TileData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : TileData Property

Glossary Item Box

Based-64 encoded tile data

Syntax

Visual Basic (Declaration)
Public Property TileData As String
C#
public string TileData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTile Class
MapTile Members


MapTileLayer Class

[image]
ActiveReports 19 .NET Edition
MapTileLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class

Glossary Item Box

Defines a raster-based layer to be drawn within a map

Object Model

MapTileLayer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapTileLayer
   Inherits MapLayer
C#
public sealed class MapTileLayer : MapLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapTileLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapTileLayer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class

Glossary Item Box

The following tables list the members exposed by MapTileLayer.

Public Constructors

 | Name | Description
Public Constructor | MapTileLayer Constructor | Initializes a new instance of the MapTileLayer class.
Top

Public Properties

 | Name | Description
Public Property | MapTiles | Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.
Public Property | Provider | Gets or sets the name of tile provider. 'Bing' by default.
Public Property | TileStyle | Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.
Public Property | UseSecureConnection | Gets or sets value indicating whether secure connection should be used for tiles retrieveing.
Top

See Also

Reference

MapTileLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer Constructor

[image]
ActiveReports 19 .NET Edition
MapTileLayer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : MapTileLayer Constructor

Glossary Item Box

Initializes a new instance of the MapTileLayer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapTileLayer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Class
MapTileLayer Members


MapTileLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapTileLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class

Glossary Item Box

For a list of all members of this type, see MapTileLayer members.

Public Properties

 | Name | Description
Public Property | MapTiles | Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.
Public Property | Provider | Gets or sets the name of tile provider. 'Bing' by default.
Public Property | TileStyle | Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.
Public Property | UseSecureConnection | Gets or sets value indicating whether secure connection should be used for tiles retrieveing.
Top

See Also

Reference

MapTileLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTiles Property

[image]
ActiveReports 19 .NET Edition
MapTiles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : MapTiles Property

Glossary Item Box

Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapTiles As IList(Of MapTile)
C#
public IList<MapTile> MapTiles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Class
MapTileLayer Members


Provider Property

[image]
ActiveReports 19 .NET Edition
Provider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : Provider Property

Glossary Item Box

Gets or sets the name of tile provider. 'Bing' by default.

Syntax

Visual Basic (Declaration)
Public Property Provider As ExpressionInfo
C#
public ExpressionInfo Provider {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Class
MapTileLayer Members


TileStyle Property

[image]
ActiveReports 19 .NET Edition
TileStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : TileStyle Property

Glossary Item Box

Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.

Syntax

Visual Basic (Declaration)
Public Property TileStyle As ExpressionInfo
C#
public ExpressionInfo TileStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Class
MapTileLayer Members


UseSecureConnection Property

[image]
ActiveReports 19 .NET Edition
UseSecureConnection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : UseSecureConnection Property

Glossary Item Box

Gets or sets value indicating whether secure connection should be used for tiles retrieveing.

Syntax

Visual Basic (Declaration)
Public Property UseSecureConnection As ExpressionInfo
C#
public ExpressionInfo UseSecureConnection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer Class
MapTileLayer Members


MapTileLayer.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapTileLayer.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer.Defaults Class

Glossary Item Box

The default values of the MapTileLayer class properties.

Object Model

MapTileLayer.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapTileLayer.Defaults
C#
public static class MapTileLayer.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapTileLayer.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapTileLayer.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapTileLayer.Defaults.

Public Fields

 | Name | Description
Public Field | TileProvider | Default value of the tile provider name.
Public Field | TileStyle | Default value of the tiles style.
Public Field | UseSecureConnection | Default value indicating whether secure connection should be used for tiles retrieveing.
Top

See Also

Reference

MapTileLayer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapTileLayer.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapTileLayer.Defaults members.

Public Fields

 | Name | Description
Public Field | TileProvider | Default value of the tile provider name.
Public Field | TileStyle | Default value of the tiles style.
Public Field | UseSecureConnection | Default value indicating whether secure connection should be used for tiles retrieveing.
Top

See Also

Reference

MapTileLayer.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


TileProvider Field

[image]
ActiveReports 19 .NET Edition
TileProvider Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer.Defaults Class : TileProvider Field

Glossary Item Box

Default value of the tile provider name.

Syntax

Visual Basic (Declaration)
Public Const TileProvider As String
C#
public const string TileProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer.Defaults Class
MapTileLayer.Defaults Members


TileStyle Field

[image]
ActiveReports 19 .NET Edition
TileStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer.Defaults Class : TileStyle Field

Glossary Item Box

Default value of the tiles style.

Syntax

Visual Basic (Declaration)
Public Const TileStyle As String
C#
public const string TileStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer.Defaults Class
MapTileLayer.Defaults Members


UseSecureConnection Field

[image]
ActiveReports 19 .NET Edition
UseSecureConnection Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer.Defaults Class : UseSecureConnection Field

Glossary Item Box

Default value indicating whether secure connection should be used for tiles retrieveing.

Syntax

Visual Basic (Declaration)
Public Const UseSecureConnection As String
C#
public const string UseSecureConnection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileLayer.Defaults Class
MapTileLayer.Defaults Members


MapTitle Class

[image]
ActiveReports 19 .NET Edition
MapTitle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class

Glossary Item Box

Defines a title to be drawn within a map

Object Model

MapTitle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapTitle
   Inherits MapDockableSubItem
C#
public sealed class MapTitle : MapDockableSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle Class Members

[image]
ActiveReports 19 .NET Edition
MapTitle Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class

Glossary Item Box

The following tables list the members exposed by MapTitle.

Public Constructors

 | Name | Description
Public Constructor | MapTitle Constructor | Initializes a new instance of the MapTitle class.
Top

Public Properties

 | Name | Description
Public Property | Angle | Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Name | Name of the title.
Public Property | Text | Text of the title.
Public Property | TextShadowOffset | Size of the text shadow. An expression should evaluate to a Length. The default value is 0.
Top

See Also

Reference

MapTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle Constructor

[image]
ActiveReports 19 .NET Edition
MapTitle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : MapTitle Constructor

Glossary Item Box

Initializes a new instance of the MapTitle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapTitle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Class
MapTitle Members


MapTitle Class Properties

[image]
ActiveReports 19 .NET Edition
MapTitle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class

Glossary Item Box

For a list of all members of this type, see MapTitle members.

Public Properties

 | Name | Description
Public Property | Angle | Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Name | Name of the title.
Public Property | Text | Text of the title.
Public Property | TextShadowOffset | Size of the text shadow. An expression should evaluate to a Length. The default value is 0.
Top

See Also

Reference

MapTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Angle Property

Glossary Item Box

Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property Angle As ExpressionInfo
C#
public ExpressionInfo Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Class
MapTitle Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Name Property

Glossary Item Box

Name of the title.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Class
MapTitle Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Text Property

Glossary Item Box

Text of the title.

Syntax

Visual Basic (Declaration)
Public Property Text As ExpressionInfo
C#
public ExpressionInfo Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Class
MapTitle Members


TextShadowOffset Property

[image]
ActiveReports 19 .NET Edition
TextShadowOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : TextShadowOffset Property

Glossary Item Box

Size of the text shadow. An expression should evaluate to a Length. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property TextShadowOffset As ExpressionInfo
C#
public ExpressionInfo TextShadowOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle Class
MapTitle Members


MapTitle.Defaults Class

[image]
ActiveReports 19 .NET Edition
MapTitle.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle.Defaults Class

Glossary Item Box

The default values of the MapTitle class properties.

Object Model

MapTitle.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MapTitle.Defaults
C#
public static class MapTitle.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapTitle.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
MapTitle.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle.Defaults Class

Glossary Item Box

The following tables list the members exposed by MapTitle.Defaults.

Public Fields

 | Name | Description
Public Field | Angle | Default value for the angle of rotation for the title.
Public Field | BackgroundColor | Default value for the title background color.
Public Field | BackgroundGradientEndColor | Default value for the end color for the background gradient.
static (Shared in Visual Basic) | BackgroundGradientType | Default value for the gradient type of the background.
Public Field | BorderStyle | Default value for the style of the border.
static (Shared in Visual Basic) | FontWeight | Default value for the thickness of the font.
Public Field | ShadowOffsetDefaultValue | Default value for the size of the text shadow.
Public Field | Text | Default value for the text of the title.
Public Field | TextShadowOffset | Default value for the size of the text shadow.
Top

See Also

Reference

MapTitle.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
MapTitle.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle.Defaults Class

Glossary Item Box

For a list of all members of this type, see MapTitle.Defaults members.

Public Fields

 | Name | Description
Public Field | Angle | Default value for the angle of rotation for the title.
Public Field | BackgroundColor | Default value for the title background color.
Public Field | BackgroundGradientEndColor | Default value for the end color for the background gradient.
static (Shared in Visual Basic) | BackgroundGradientType | Default value for the gradient type of the background.
Public Field | BorderStyle | Default value for the style of the border.
static (Shared in Visual Basic) | FontWeight | Default value for the thickness of the font.
Public Field | ShadowOffsetDefaultValue | Default value for the size of the text shadow.
Public Field | Text | Default value for the text of the title.
Public Field | TextShadowOffset | Default value for the size of the text shadow.
Top

See Also

Reference

MapTitle.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Field

[image]
ActiveReports 19 .NET Edition
Angle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : Angle Field

Glossary Item Box

Default value for the angle of rotation for the title.

Syntax

Visual Basic (Declaration)
Public Const Angle As Double
C#
public const double Angle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


BackgroundColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : BackgroundColor Field

Glossary Item Box

Default value for the title background color.

Syntax

Visual Basic (Declaration)
Public Const BackgroundColor As String
C#
public const string BackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


BackgroundGradientEndColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : BackgroundGradientEndColor Field

Glossary Item Box

Default value for the end color for the background gradient.

Syntax

Visual Basic (Declaration)
Public Const BackgroundGradientEndColor As String
C#
public const string BackgroundGradientEndColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


BackgroundGradientType Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : BackgroundGradientType Field

Glossary Item Box

Default value for the gradient type of the background.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly BackgroundGradientType As String
C#
public static readonly string BackgroundGradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


BorderStyle Field

[image]
ActiveReports 19 .NET Edition
BorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : BorderStyle Field

Glossary Item Box

Default value for the style of the border.

Syntax

Visual Basic (Declaration)
Public Const BorderStyle As BorderDrawingStyle
C#
public const BorderDrawingStyle BorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


FontWeight Field

[image]
ActiveReports 19 .NET Edition
FontWeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : FontWeight Field

Glossary Item Box

Default value for the thickness of the font.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FontWeight As String
C#
public static readonly string FontWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


ShadowOffsetDefaultValue Field

[image]
ActiveReports 19 .NET Edition
ShadowOffsetDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : ShadowOffsetDefaultValue Field

Glossary Item Box

Default value for the size of the text shadow.

Syntax

Visual Basic (Declaration)
Public Const ShadowOffsetDefaultValue As String
C#
public const string ShadowOffsetDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


Text Field

[image]
ActiveReports 19 .NET Edition
Text Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : Text Field

Glossary Item Box

Default value for the text of the title.

Syntax

Visual Basic (Declaration)
Public Const Text As String
C#
public const string Text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


TextShadowOffset Field

[image]
ActiveReports 19 .NET Edition
TextShadowOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle.Defaults Class : TextShadowOffset Field

Glossary Item Box

Default value for the size of the text shadow.

Syntax

Visual Basic (Declaration)
Public Const TextShadowOffset As String
C#
public const string TextShadowOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTitle.Defaults Class
MapTitle.Defaults Members


MapVectorLayer Class

[image]
ActiveReports 19 .NET Edition
MapVectorLayer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

Glossary Item Box

Defines a vector-based layer of map elements to be drawn within a map

Object Model

MapVectorLayer Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapVectorLayer
   Inherits MapLayer
C#
public abstract class MapVectorLayer : MapLayer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapLineLayer
GrapeCity.ActiveReports.PageReportModel.MapPointLayer
GrapeCity.ActiveReports.PageReportModel.MapPolygonLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapVectorLayer Class Members

[image]
ActiveReports 19 .NET Edition
MapVectorLayer Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

Glossary Item Box

The following tables list the members exposed by MapVectorLayer.

Public Fields

 | Name | Description
Public Field | DefaultDataElementOutput | The default value of the DataElementOutput property.
Top

Public Properties

 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | Elements | Gets the elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.
Top

See Also

Reference

MapVectorLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapVectorLayer Class Properties

[image]
ActiveReports 19 .NET Edition
MapVectorLayer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

Glossary Item Box

For a list of all members of this type, see MapVectorLayer members.

Public Properties

 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.
Public Property | Elements | Gets the elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.
Top

See Also

Reference

MapVectorLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : DataElementName Property

Glossary Item Box

The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : DataElementOutput Property

Glossary Item Box

Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is Output.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : Elements Property

Glossary Item Box

Gets the elements.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Elements As IEnumerable(Of MapSpatialElement)
C#
public abstract IEnumerable<MapSpatialElement> Elements {get;}

Property Value

The elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapBindingFieldPairs Property

[image]
ActiveReports 19 .NET Edition
MapBindingFieldPairs Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapBindingFieldPairs Property

Glossary Item Box

Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapBindingFieldPairs As IList(Of MapBindingFieldPair)
C#
public IList<MapBindingFieldPair> MapBindingFieldPairs {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapDataRegionName Property

[image]
ActiveReports 19 .NET Edition
MapDataRegionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapDataRegionName Property

Glossary Item Box

Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.

Syntax

Visual Basic (Declaration)
Public Property MapDataRegionName As String
C#
public string MapDataRegionName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapFieldDefinitions Property

[image]
ActiveReports 19 .NET Edition
MapFieldDefinitions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapFieldDefinitions Property

Glossary Item Box

Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MapFieldDefinitions As IList(Of MapFieldDefinition)
C#
public IList<MapFieldDefinition> MapFieldDefinitions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapSpatialData Property

[image]
ActiveReports 19 .NET Edition
MapSpatialData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapSpatialData Property

Glossary Item Box

Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.

Syntax

Visual Basic (Declaration)
Public Property MapSpatialData As MapSpatialData
C#
public MapSpatialData MapSpatialData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapVectorLayer Class Fields

[image]
ActiveReports 19 .NET Edition
MapVectorLayer Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

Glossary Item Box

For a list of all members of this type, see MapVectorLayer members.

Public Fields

 | Name | Description
Public Field | DefaultDataElementOutput | The default value of the DataElementOutput property.
Top

See Also

Reference

MapVectorLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultDataElementOutput Field

[image]
ActiveReports 19 .NET Edition
DefaultDataElementOutput Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : DefaultDataElementOutput Field

Glossary Item Box

The default value of the DataElementOutput property.

Syntax

Visual Basic (Declaration)
Public Const DefaultDataElementOutput As DataElementOutput
C#
public const DataElementOutput DefaultDataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapView Class

[image]
ActiveReports 19 .NET Edition
MapView Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

Glossary Item Box

Defines the viewport center and zoom level

Object Model

MapView Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MapView
C#
public abstract class MapView

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapCustomView
GrapeCity.ActiveReports.PageReportModel.MapDataBoundView
GrapeCity.ActiveReports.PageReportModel.MapElementView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapView Class Members

[image]
ActiveReports 19 .NET Edition
MapView Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

Glossary Item Box

The following tables list the members exposed by MapView.

Public Fields

 | Name | Description
Public Field | ZoomDefaultValue | Default value of the viewport zoom level.
Top

Public Properties

 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapView Class Properties

[image]
ActiveReports 19 .NET Edition
MapView Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

Glossary Item Box

For a list of all members of this type, see MapView members.

Public Properties

 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.
Top

See Also

Reference

MapView Class
GrapeCity.ActiveReports.PageReportModel Namespace


Zoom Property

[image]
ActiveReports 19 .NET Edition
Zoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapView Class : Zoom Property

Glossary Item Box

Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property Zoom As ExpressionInfo
C#
public ExpressionInfo Zoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapView Class
MapView Members


MapView Class Fields

[image]
ActiveReports 19 .NET Edition
MapView Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

Glossary Item Box

For a list of all members of this type, see MapView members.

Public Fields

 | Name | Description
Public Field | ZoomDefaultValue | Default value of the viewport zoom level.
Top

See Also

Reference

MapView Class
GrapeCity.ActiveReports.PageReportModel Namespace


ZoomDefaultValue Field

[image]
ActiveReports 19 .NET Edition
ZoomDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapView Class : ZoomDefaultValue Field

Glossary Item Box

Default value of the viewport zoom level.

Syntax

Visual Basic (Declaration)
Public Const ZoomDefaultValue As Double
C#
public const double ZoomDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapView Class
MapView Members


MapViewport Class

[image]
ActiveReports 19 .NET Edition
MapViewport Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

Glossary Item Box

Defines the map viewport

Object Model

MapViewport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapViewport
   Inherits MapSubItem
C#
public sealed class MapViewport : MapSubItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapViewport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapViewport Class Members

[image]
ActiveReports 19 .NET Edition
MapViewport Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

Glossary Item Box

The following tables list the members exposed by MapViewport.

Public Constructors

 | Name | Description
Public Constructor | MapViewport Constructor | Initializes a new instance of the MapViewport class.
Top

Public Fields

 | Name | Description
Public Field | GeographicalMeridiansLabelFormatDefaultValue | Default value for the geographical format of map medians labels.
Public Field | GeographicalParallelsLabelFormatDefaultValue | Default value for the geographical format of map parallels labels.
Public Field | HeightDefaultValue | Default value for the height of map viewport.
Public Field | LeftDefaultValue | Default value for the X coordinate of the map viewport top left point.
Public Field | MapCoordinateSystemDefaultValue | Default value for the map projection.
Public Field | MaximumZoomDefaultValue | Default value for the maximum zoom level allowed.
Public Field | MinimumZoomDefaultValue | Default value for the minimum zoom level allowed.
Public Field | PlanarLabelFormatDefaultValue | Default value for the planar format of map medians labels.
Public Field | TopDefaultValue | Default value for the Y coordinate of the map viewport top left point.
Public Field | WidthDefaultValue | Default value for the width of map viewport.
Top

Public Properties

 | Name | Description
Public Property | ContentMargin | Gets or sets the content margin. An expression should evaluate to a Length. The default value is 10pt.
Public Property | GridUnderContent | Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.
Public Property | MapCoordinateSystem | The map projection That evaluates to one of MapCoordinateSystem. The default value is MapCoordinateSystem.Planar.
Public Property | MapLimits | Gets or sets the map limits. Automatically calculated if omitted.
Public Property | MapMeridians | Gets or sets the map meridians.
Public Property | MapParallels | Gets or sets the map parallels.
Public Property | MapProjection | The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.
Public Property | MapView | Gets or sets the view center and zoom. An expression should evaluate to a MapView.
Public Property | MaximumZoom | Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.
Public Property | MinimumZoom | Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.
Public Property | ProjectionCenterX | Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | ProjectionCenterY | Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | SimplificationResolution | Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).
Top

See Also

Reference

MapViewport Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapViewport Constructor

[image]
ActiveReports 19 .NET Edition
MapViewport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapViewport Constructor

Glossary Item Box

Initializes a new instance of the MapViewport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapViewport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapViewport Class Properties

[image]
ActiveReports 19 .NET Edition
MapViewport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

Glossary Item Box

For a list of all members of this type, see MapViewport members.

Public Properties

 | Name | Description
Public Property | ContentMargin | Gets or sets the content margin. An expression should evaluate to a Length. The default value is 10pt.
Public Property | GridUnderContent | Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.
Public Property | MapCoordinateSystem | The map projection That evaluates to one of MapCoordinateSystem. The default value is MapCoordinateSystem.Planar.
Public Property | MapLimits | Gets or sets the map limits. Automatically calculated if omitted.
Public Property | MapMeridians | Gets or sets the map meridians.
Public Property | MapParallels | Gets or sets the map parallels.
Public Property | MapProjection | The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.
Public Property | MapView | Gets or sets the view center and zoom. An expression should evaluate to a MapView.
Public Property | MaximumZoom | Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.
Public Property | MinimumZoom | Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.
Public Property | ProjectionCenterX | Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | ProjectionCenterY | Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | SimplificationResolution | Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).
Top

See Also

Reference

MapViewport Class
GrapeCity.ActiveReports.PageReportModel Namespace


ContentMargin Property

[image]
ActiveReports 19 .NET Edition
ContentMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ContentMargin Property

Glossary Item Box

Gets or sets the content margin. An expression should evaluate to a Length. The default value is 10pt.

Syntax

Visual Basic (Declaration)
Public Property ContentMargin As ExpressionInfo
C#
public ExpressionInfo ContentMargin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


GridUnderContent Property

[image]
ActiveReports 19 .NET Edition
GridUnderContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : GridUnderContent Property

Glossary Item Box

Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.

Syntax

Visual Basic (Declaration)
Public Property GridUnderContent As ExpressionInfo
C#
public ExpressionInfo GridUnderContent {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapCoordinateSystem Property

[image]
ActiveReports 19 .NET Edition
MapCoordinateSystem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapCoordinateSystem Property

Glossary Item Box

The map projection That evaluates to one of MapCoordinateSystem. The default value is MapCoordinateSystem.Planar.

Syntax

Visual Basic (Declaration)
Public Property MapCoordinateSystem As ExpressionInfo
C#
public ExpressionInfo MapCoordinateSystem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapLimits Property

[image]
ActiveReports 19 .NET Edition
MapLimits Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapLimits Property

Glossary Item Box

Gets or sets the map limits. Automatically calculated if omitted.

Syntax

Visual Basic (Declaration)
Public Property MapLimits As MapLimits
C#
public MapLimits MapLimits {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapMeridians Property

[image]
ActiveReports 19 .NET Edition
MapMeridians Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapMeridians Property

Glossary Item Box

Gets or sets the map meridians.

Syntax

Visual Basic (Declaration)
Public Property MapMeridians As MapGridLines
C#
public MapGridLines MapMeridians {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapParallels Property

[image]
ActiveReports 19 .NET Edition
MapParallels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapParallels Property

Glossary Item Box

Gets or sets the map parallels.

Syntax

Visual Basic (Declaration)
Public Property MapParallels As MapGridLines
C#
public MapGridLines MapParallels {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapProjection Property

[image]
ActiveReports 19 .NET Edition
MapProjection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapProjection Property

Glossary Item Box

The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.

Syntax

Visual Basic (Declaration)
Public Property MapProjection As ExpressionInfo
C#
public ExpressionInfo MapProjection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapView Property

[image]
ActiveReports 19 .NET Edition
MapView Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapView Property

Glossary Item Box

Gets or sets the view center and zoom. An expression should evaluate to a MapView.

Syntax

Visual Basic (Declaration)
Public Property MapView As MapView
C#
public MapView MapView {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MaximumZoom Property

[image]
ActiveReports 19 .NET Edition
MaximumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MaximumZoom Property

Glossary Item Box

Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.

Syntax

Visual Basic (Declaration)
Public Property MaximumZoom As ExpressionInfo
C#
public ExpressionInfo MaximumZoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MinimumZoom Property

[image]
ActiveReports 19 .NET Edition
MinimumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MinimumZoom Property

Glossary Item Box

Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.

Syntax

Visual Basic (Declaration)
Public Property MinimumZoom As ExpressionInfo
C#
public ExpressionInfo MinimumZoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


ProjectionCenterX Property

[image]
ActiveReports 19 .NET Edition
ProjectionCenterX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ProjectionCenterX Property

Glossary Item Box

Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property ProjectionCenterX As ExpressionInfo
C#
public ExpressionInfo ProjectionCenterX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


ProjectionCenterY Property

[image]
ActiveReports 19 .NET Edition
ProjectionCenterY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ProjectionCenterY Property

Glossary Item Box

Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.

Syntax

Visual Basic (Declaration)
Public Property ProjectionCenterY As ExpressionInfo
C#
public ExpressionInfo ProjectionCenterY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


SimplificationResolution Property

[image]
ActiveReports 19 .NET Edition
SimplificationResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : SimplificationResolution Property

Glossary Item Box

Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).

Syntax

Visual Basic (Declaration)
Public Property SimplificationResolution As ExpressionInfo
C#
public ExpressionInfo SimplificationResolution {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapViewport Class Fields

[image]
ActiveReports 19 .NET Edition
MapViewport Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

Glossary Item Box

For a list of all members of this type, see MapViewport members.

Public Fields

 | Name | Description
Public Field | GeographicalMeridiansLabelFormatDefaultValue | Default value for the geographical format of map medians labels.
Public Field | GeographicalParallelsLabelFormatDefaultValue | Default value for the geographical format of map parallels labels.
Public Field | HeightDefaultValue | Default value for the height of map viewport.
Public Field | LeftDefaultValue | Default value for the X coordinate of the map viewport top left point.
Public Field | MapCoordinateSystemDefaultValue | Default value for the map projection.
Public Field | MaximumZoomDefaultValue | Default value for the maximum zoom level allowed.
Public Field | MinimumZoomDefaultValue | Default value for the minimum zoom level allowed.
Public Field | PlanarLabelFormatDefaultValue | Default value for the planar format of map medians labels.
Public Field | TopDefaultValue | Default value for the Y coordinate of the map viewport top left point.
Public Field | WidthDefaultValue | Default value for the width of map viewport.
Top

See Also

Reference

MapViewport Class
GrapeCity.ActiveReports.PageReportModel Namespace


GeographicalMeridiansLabelFormatDefaultValue Field

[image]
ActiveReports 19 .NET Edition
GeographicalMeridiansLabelFormatDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : GeographicalMeridiansLabelFormatDefaultValue Field

Glossary Item Box

Default value for the geographical format of map medians labels.

Syntax

Visual Basic (Declaration)
Public Const GeographicalMeridiansLabelFormatDefaultValue As String
C#
public const string GeographicalMeridiansLabelFormatDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


GeographicalParallelsLabelFormatDefaultValue Field

[image]
ActiveReports 19 .NET Edition
GeographicalParallelsLabelFormatDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : GeographicalParallelsLabelFormatDefaultValue Field

Glossary Item Box

Default value for the geographical format of map parallels labels.

Syntax

Visual Basic (Declaration)
Public Const GeographicalParallelsLabelFormatDefaultValue As String
C#
public const string GeographicalParallelsLabelFormatDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


HeightDefaultValue Field

[image]
ActiveReports 19 .NET Edition
HeightDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : HeightDefaultValue Field

Glossary Item Box

Default value for the height of map viewport.

Syntax

Visual Basic (Declaration)
Public Const HeightDefaultValue As String
C#
public const string HeightDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


LeftDefaultValue Field

[image]
ActiveReports 19 .NET Edition
LeftDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : LeftDefaultValue Field

Glossary Item Box

Default value for the X coordinate of the map viewport top left point.

Syntax

Visual Basic (Declaration)
Public Const LeftDefaultValue As String
C#
public const string LeftDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MapCoordinateSystemDefaultValue Field

[image]
ActiveReports 19 .NET Edition
MapCoordinateSystemDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapCoordinateSystemDefaultValue Field

Glossary Item Box

Default value for the map projection.

Syntax

Visual Basic (Declaration)
Public Const MapCoordinateSystemDefaultValue As MapCoordinateSystem
C#
public const MapCoordinateSystem MapCoordinateSystemDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MaximumZoomDefaultValue Field

[image]
ActiveReports 19 .NET Edition
MaximumZoomDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MaximumZoomDefaultValue Field

Glossary Item Box

Default value for the maximum zoom level allowed.

Syntax

Visual Basic (Declaration)
Public Const MaximumZoomDefaultValue As Double
C#
public const double MaximumZoomDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


MinimumZoomDefaultValue Field

[image]
ActiveReports 19 .NET Edition
MinimumZoomDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MinimumZoomDefaultValue Field

Glossary Item Box

Default value for the minimum zoom level allowed.

Syntax

Visual Basic (Declaration)
Public Const MinimumZoomDefaultValue As Double
C#
public const double MinimumZoomDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


PlanarLabelFormatDefaultValue Field

[image]
ActiveReports 19 .NET Edition
PlanarLabelFormatDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : PlanarLabelFormatDefaultValue Field

Glossary Item Box

Default value for the planar format of map medians labels.

Syntax

Visual Basic (Declaration)
Public Const PlanarLabelFormatDefaultValue As String
C#
public const string PlanarLabelFormatDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


TopDefaultValue Field

[image]
ActiveReports 19 .NET Edition
TopDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : TopDefaultValue Field

Glossary Item Box

Default value for the Y coordinate of the map viewport top left point.

Syntax

Visual Basic (Declaration)
Public Const TopDefaultValue As String
C#
public const string TopDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


WidthDefaultValue Field

[image]
ActiveReports 19 .NET Edition
WidthDefaultValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : WidthDefaultValue Field

Glossary Item Box

Default value for the width of map viewport.

Syntax

Visual Basic (Declaration)
Public Const WidthDefaultValue As String
C#
public const string WidthDefaultValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapViewport Class
MapViewport Members


Marker Class

[image]
ActiveReports 19 .NET Edition
Marker Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

Glossary Item Box

The Marker element defines a marker for displayed chart values.

Object Model

Marker Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Marker
   Implements IValidateable
C#
public sealed class Marker : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Marker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Members
GrapeCity.ActiveReports.PageReportModel Namespace


Marker Class Members

[image]
ActiveReports 19 .NET Edition
Marker Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

Glossary Item Box

The following tables list the members exposed by Marker.

Public Constructors

 | Name | Description
Public Constructor | Marker Constructor | Initializes a new instance of the Marker class.
Top

Public Properties

 | Name | Description
Public Property | Size | Gets or sets the height and width of the plotting area of the markers.
Public Property | Style | Gets or sets the border and background style properties for the markers.
Public Property | Type | Gets or sets the marker type for values.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Marker object.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Marker Constructor

[image]
ActiveReports 19 .NET Edition
Marker Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Marker Constructor

Glossary Item Box

Initializes a new instance of the Marker class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Marker()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Marker Class Methods

[image]
ActiveReports 19 .NET Edition
Marker Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

Glossary Item Box

For a list of all members of this type, see Marker members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Marker object.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Marker object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Marker Class Properties

[image]
ActiveReports 19 .NET Edition
Marker Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

Glossary Item Box

For a list of all members of this type, see Marker members.

Public Properties

 | Name | Description
Public Property | Size | Gets or sets the height and width of the plotting area of the markers.
Public Property | Style | Gets or sets the border and background style properties for the markers.
Public Property | Type | Gets or sets the marker type for values.
Top

See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Size Property

Glossary Item Box

Gets or sets the height and width of the plotting area of the markers.

Syntax

Visual Basic (Declaration)
Public Property Size As Length
C#
public Length Size {get; set;}

Property Value

A Length structure containing the height and width of the plotting area of the markers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Style Property

Glossary Item Box

Gets or sets the border and background style properties for the markers.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the markers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Type Property

Glossary Item Box

Gets or sets the marker type for values.

Syntax

Visual Basic (Declaration)
Public Property Type As MarkerType
C#
public MarkerType Type {get; set;}

Property Value

A MarkerType enumeration indicating the marker type for values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Marker Class
Marker Members


MasterContentService Class

[image]
ActiveReports 19 .NET Edition
MasterContentService Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentService Class

Glossary Item Box

Represents a class for determining report and report item ownership. Implements of the IMasterContentService interface.

Object Model

MasterContentService Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MasterContentService
   Implements IMasterContentService
C#
public sealed class MasterContentService : IMasterContentService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MasterContentService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Members
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentService Class Members

[image]
ActiveReports 19 .NET Edition
MasterContentService Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentService Class

Glossary Item Box

The following tables list the members exposed by MasterContentService.

Public Constructors

 | Name | Description
Public Constructor | MasterContentService Constructor | Initializes a new instance of the MasterContentService class.
Top

Public Properties

 | Name | Description
Public Property | IsMaster | Gets a value indicating whether the current report is a master report.
Public Property | MasterReport | Gets or sets the name of the master report, if any.
Top

Public Methods

 | Name | Description
Public Method | GetCode | Gets the child and master report code based on the provided combined code.
Public Method | GetMasterContent | Gets the content for the specified item/property that was inferred from the master report.
Public Method | GetOwner | Overloaded. Gets the owner of the specified report component.
Public Method | IsUpdatedReportProperty | Gets a value indicating whether the report property value has been changed from the master.
Public Method | UpdateReports | Updates the service with a new master and combined report.
Top

See Also

Reference

MasterContentService Class
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentService Constructor

[image]
ActiveReports 19 .NET Edition
MasterContentService Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : MasterContentService Constructor

masterReport
The master Report to use with the service.
combinedReport
The combined Report to use with the service.

Glossary Item Box

Initializes a new instance of the MasterContentService class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal masterReport As Report, _
   ByVal combinedReport As Report _
)
C#
public MasterContentService(
   Report masterReport,
   Report combinedReport
)

Parameters

masterReport
The master Report to use with the service.
combinedReport
The combined Report to use with the service.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


MasterContentService Class Methods

[image]
ActiveReports 19 .NET Edition
MasterContentService Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentService Class

Glossary Item Box

For a list of all members of this type, see MasterContentService members.

Public Methods

 | Name | Description
Public Method | GetCode | Gets the child and master report code based on the provided combined code.
Public Method | GetMasterContent | Gets the content for the specified item/property that was inferred from the master report.
Public Method | GetOwner | Overloaded. Gets the owner of the specified report component.
Public Method | IsUpdatedReportProperty | Gets a value indicating whether the report property value has been changed from the master.
Public Method | UpdateReports | Updates the service with a new master and combined report.
Top

See Also

Reference

MasterContentService Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetCode Method

[image]
ActiveReports 19 .NET Edition
GetCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : GetCode Method

combinedCode
A System.String value indicating the combined code of the master and child reports.

Glossary Item Box

Gets the child and master report code based on the provided combined code.

Syntax

Visual Basic (Declaration)
Public Function GetCode( _
   ByVal combinedCode As String _
) As MasterContentCode
C#
public MasterContentCode GetCode(
   string combinedCode
)

Parameters

combinedCode
A System.String value indicating the combined code of the master and child reports.

Return Value

A MasterContentCode containing the master report code and child report code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


GetMasterContent Method

[image]
ActiveReports 19 .NET Edition
GetMasterContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : GetMasterContent Method

itemName
A System.String value indicating the name of the item or property.

Glossary Item Box

Gets the content for the specified item/property that was inferred from the master report.

Syntax

Visual Basic (Declaration)
Public Function GetMasterContent( _
   ByVal itemName As String _
) As ICollection
C#
public ICollection GetMasterContent(
   string itemName
)

Parameters

itemName
A System.String value indicating the name of the item or property.

Return Value

An System.Collections.ICollection of content items inferred from the master report.

Remarks

Currently assumes the collection being requested is directly off of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


GetOwner Method

[image]
ActiveReports 19 .NET Edition
GetOwner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : GetOwner Method

Glossary Item Box

Gets the owner of the specified report component.

Overload List

Overload | Description
GetOwner(IComponent) | Gets the owner of the specified report component.
GetOwner(CodeClass) | Gets the owner of the specified CodeClass.
GetOwner(ReportParameter) | Gets the owner of the specified ReportParameter.
GetOwner(EmbeddedImage) | Gets the owner of the specified EmbeddedImage.
GetOwner(DataSource) | Gets the owner of the specified DataSource.
GetOwner(IDataSet) | Gets the owner of the specified IDataSet.
GetOwner(EmbeddedStyleSheet) | Gets the owner of the specified EmbeddedStyleSheet.
GetOwner(String,Field) | Gets the owner of the specified Field belonging to the specified data set.
GetOwner(String,Filter) | Gets the owner of the specified Filter belonging to the specified data set.
GetOwner(String,String,String) | Gets the owner of the resource using the specified culture.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


GetOwner(IComponent) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(IComponent) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(IComponent) Method

reportComponent
A System.ComponentModel.IComponent object representing the report component.

Glossary Item Box

Gets the owner of the specified report component.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal reportComponent As IComponent _
) As ItemOwners
C#
public ItemOwners GetOwner(
   IComponent reportComponent
)

Parameters

reportComponent
A System.ComponentModel.IComponent object representing the report component.

Return Value

An ItemOwners value indicating the owner of the report component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(CodeClass) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(CodeClass) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(CodeClass) Method

codeClass
A CodeClass for getting owner for.

Glossary Item Box

Gets the owner of the specified CodeClass.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal codeClass As CodeClass _
) As ItemOwners
C#
public ItemOwners GetOwner(
   CodeClass codeClass
)

Parameters

codeClass
A CodeClass for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified code class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(ReportParameter) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(ReportParameter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(ReportParameter) Method

reportParameter
A ReportParameter for getting owner for.

Glossary Item Box

Gets the owner of the specified ReportParameter.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal reportParameter As ReportParameter _
) As ItemOwners
C#
public ItemOwners GetOwner(
   ReportParameter reportParameter
)

Parameters

reportParameter
A ReportParameter for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(EmbeddedImage) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(EmbeddedImage) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(EmbeddedImage) Method

embeddedImage
An EmbeddedImage for getting owner for.

Glossary Item Box

Gets the owner of the specified EmbeddedImage.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal embeddedImage As EmbeddedImage _
) As ItemOwners
C#
public ItemOwners GetOwner(
   EmbeddedImage embeddedImage
)

Parameters

embeddedImage
An EmbeddedImage for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified embedded image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(DataSource) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(DataSource) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(DataSource) Method

dataSource
A DataSource for getting owner for.

Glossary Item Box

Gets the owner of the specified DataSource.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal dataSource As DataSource _
) As ItemOwners
C#
public ItemOwners GetOwner(
   DataSource dataSource
)

Parameters

dataSource
A DataSource for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(IDataSet) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(IDataSet) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(IDataSet) Method

dataSet
An IDataSet for getting owner for.

Glossary Item Box

Gets the owner of the specified IDataSet.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal dataSet As IDataSet _
) As ItemOwners
C#
public ItemOwners GetOwner(
   IDataSet dataSet
)

Parameters

dataSet
An IDataSet for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(EmbeddedStyleSheet) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(EmbeddedStyleSheet) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(EmbeddedStyleSheet) Method

embeddedStyleSheet
An EmbeddedStyleSheet for getting owner for.

Glossary Item Box

Gets the owner of the specified EmbeddedStyleSheet.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal embeddedStyleSheet As EmbeddedStyleSheet _
) As ItemOwners
C#
public ItemOwners GetOwner(
   EmbeddedStyleSheet embeddedStyleSheet
)

Parameters

embeddedStyleSheet
An EmbeddedStyleSheet for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified embedded style sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(String,Field) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(String,Field) Method

dataSetName
A System.String value indicating the name of the data set.
field
A Field for getting owner for.

Glossary Item Box

Gets the owner of the specified Field belonging to the specified data set.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal dataSetName As String, _
   ByVal field As Field _
) As ItemOwners
C#
public ItemOwners GetOwner(
   string dataSetName,
   Field field
)

Parameters

dataSetName
A System.String value indicating the name of the data set.
field
A Field for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(String,Filter) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,Filter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(String,Filter) Method

dataSetName
A System.String value indicating the name of the data set.
filter
A Filter for getting owner for.

Glossary Item Box

Gets the owner of the specified Filter belonging to the specified data set.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal dataSetName As String, _
   ByVal filter As Filter _
) As ItemOwners
C#
public ItemOwners GetOwner(
   string dataSetName,
   Filter filter
)

Parameters

dataSetName
A System.String value indicating the name of the data set.
filter
A Filter for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified filter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


GetOwner(String,String,String) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class > GetOwner Method : GetOwner(String,String,String) Method

culture
A System.String value indicating the culture of the resource.
resourceName
A System.String value indicating the name of the resource.
resourceValue
A System.String value indicating the value of the resource.

Glossary Item Box

Gets the owner of the resource using the specified culture.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOwner( _
   ByVal culture As String, _
   ByVal resourceName As String, _
   ByVal resourceValue As String _
) As ItemOwners
C#
public ItemOwners GetOwner(
   string culture,
   string resourceName,
   string resourceValue
)

Parameters

culture
A System.String value indicating the culture of the resource.
resourceName
A System.String value indicating the name of the resource.
resourceValue
A System.String value indicating the value of the resource.

Return Value

An ItemOwners value indicating the owner of the specified resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members
Overload List


IsUpdatedReportProperty Method

[image]
ActiveReports 19 .NET Edition
IsUpdatedReportProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : IsUpdatedReportProperty Method

propertyName
A System.String value indicating the name of the property to check.
propertyValue
A System.String value indicating the value of the property to compare against the master.

Glossary Item Box

Gets a value indicating whether the report property value has been changed from the master.

Syntax

Visual Basic (Declaration)
Public Function IsUpdatedReportProperty( _
   ByVal propertyName As String, _
   ByVal propertyValue As Object _
) As Boolean
C#
public bool IsUpdatedReportProperty(
   string propertyName,
   object propertyValue
)

Parameters

propertyName
A System.String value indicating the name of the property to check.
propertyValue
A System.String value indicating the value of the property to compare against the master.

Return Value

A System.Boolean value. true if the property value is the same; otherwise, false.

Remarks

This member deals directly with the simple properties on the report object. Passing in an empty string will return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


UpdateReports Method

[image]
ActiveReports 19 .NET Edition
UpdateReports Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : UpdateReports Method

masterReport
A Report object representing the master report to be set.
combinedReport
A Report object representing the combined report to be set.

Glossary Item Box

Updates the service with a new master and combined report.

Syntax

Visual Basic (Declaration)
Public Sub UpdateReports( _
   ByVal masterReport As Report, _
   ByVal combinedReport As Report _
)
C#
public void UpdateReports(
   Report masterReport,
   Report combinedReport
)

Parameters

masterReport
A Report object representing the master report to be set.
combinedReport
A Report object representing the combined report to be set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


MasterContentService Class Properties

[image]
ActiveReports 19 .NET Edition
MasterContentService Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentService Class

Glossary Item Box

For a list of all members of this type, see MasterContentService members.

Public Properties

 | Name | Description
Public Property | IsMaster | Gets a value indicating whether the current report is a master report.
Public Property | MasterReport | Gets or sets the name of the master report, if any.
Top

See Also

Reference

MasterContentService Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsMaster Property

[image]
ActiveReports 19 .NET Edition
IsMaster Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : IsMaster Property

Glossary Item Box

Gets a value indicating whether the current report is a master report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMaster As Boolean
C#
public bool IsMaster {get;}

Property Value

A System.Boolean value. true if the current report is a master report; otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


MasterReport Property

[image]
ActiveReports 19 .NET Edition
MasterReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentService Class : MasterReport Property

Glossary Item Box

Gets or sets the name of the master report, if any.

Syntax

Visual Basic (Declaration)
Public Property MasterReport As String
C#
public string MasterReport {get; set;}

Property Value

A System.String value indicating the name of the master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentService Class
MasterContentService Members


MasterReportNotFoundException Class

[image]
ActiveReports 19 .NET Edition
MasterReportNotFoundException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class

Glossary Item Box

Represents an exception throws when a master report cannot be found.

Object Model

MasterReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MasterReportNotFoundException
   Inherits System.Exception
C#
public sealed class MasterReportNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.PageReportModel.MasterReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterReportNotFoundException Members
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Class Members

[image]
ActiveReports 19 .NET Edition
MasterReportNotFoundException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by MasterReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | MasterReportNotFoundException Constructor | Initializes a new instance of the MasterReportNotFoundException class.
Top

See Also

Reference

MasterReportNotFoundException Class
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Constructor

[image]
ActiveReports 19 .NET Edition
MasterReportNotFoundException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : MasterReportNotFoundException Constructor

Glossary Item Box

Initializes a new instance of the MasterReportNotFoundException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MasterReportNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Matrix Class

[image]
ActiveReports 19 .NET Edition
Matrix Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

Glossary Item Box

Represents a Matrix element that defines a grid of regions that repeats with each column group and row group in the dataset.

Object Model

Matrix Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Matrix
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class Matrix : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Members
GrapeCity.ActiveReports.PageReportModel Namespace


Matrix Class Members

[image]
ActiveReports 19 .NET Edition
Matrix Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

Glossary Item Box

The following tables list the members exposed by Matrix.

Public Constructors

 | Name | Description
Public Constructor | Matrix Constructor | Initializes a new instance of the Matrix class.
Top

Public Properties

 | Name | Description
Public Property | CellDataElementName | Gets or sets a name of the top-level XML element that represents the cell.
Public Property | CellDataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | ChildScopes | Overridden. Gets the child scopes for the data region.
Public Property | ColumnGroupings | Gets a set of column groupings for the matrix.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Corner | Gets or sets a region that contains the elements of the upper left corner area of the matrix.
Public Property | GroupsBeforeRowHeaders | Gets or sets a number of instances of the outermost column group that appear to the left of the row headers, right of the row headers for right-to-left matrices.
Public Property | LayoutDirection | Gets or sets a value indicating whether the matrix columns grow left-to-right, with headers on the left, or right-to-left, with headers on the right.
Public Property | MatrixColumns | Gets the columns contained in each detail cell of the matrix layout.
Public Property | MatrixRows | Gets the rows contained in each detail cell of the matrix layout.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the data region.
Public Property | RowGroupings | Gets a set of row groupings for the matrix.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Matrix object.
Top

See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


Matrix Constructor

[image]
ActiveReports 19 .NET Edition
Matrix Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Matrix Constructor

Glossary Item Box

Initializes a new instance of the Matrix class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Matrix()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


Matrix Class Methods

[image]
ActiveReports 19 .NET Edition
Matrix Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

Glossary Item Box

For a list of all members of this type, see Matrix members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Matrix object.
Top

See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Matrix object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


Matrix Class Properties

[image]
ActiveReports 19 .NET Edition
Matrix Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

Glossary Item Box

For a list of all members of this type, see Matrix members.

Public Properties

 | Name | Description
Public Property | CellDataElementName | Gets or sets a name of the top-level XML element that represents the cell.
Public Property | CellDataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | ChildScopes | Overridden. Gets the child scopes for the data region.
Public Property | ColumnGroupings | Gets a set of column groupings for the matrix.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Corner | Gets or sets a region that contains the elements of the upper left corner area of the matrix.
Public Property | GroupsBeforeRowHeaders | Gets or sets a number of instances of the outermost column group that appear to the left of the row headers, right of the row headers for right-to-left matrices.
Public Property | LayoutDirection | Gets or sets a value indicating whether the matrix columns grow left-to-right, with headers on the left, or right-to-left, with headers on the right.
Public Property | MatrixColumns | Gets the columns contained in each detail cell of the matrix layout.
Public Property | MatrixRows | Gets the rows contained in each detail cell of the matrix layout.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the data region.
Public Property | RowGroupings | Gets a set of row groupings for the matrix.
Top

See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


CellDataElementName Property

[image]
ActiveReports 19 .NET Edition
CellDataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : CellDataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the cell.

Syntax

Visual Basic (Declaration)
Public Property CellDataElementName As String
C#
public string CellDataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for cell.

Remarks

Default value is "Cell".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


CellDataElementOutput Property

[image]
ActiveReports 19 .NET Edition
CellDataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : CellDataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property CellDataElementOutput As DataElementOutput
C#
public DataElementOutput CellDataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

Output(Default) indicates that the cell appears in the output.

NoOutput indicates that the cell does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the data region.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


ColumnGroupings Property

[image]
ActiveReports 19 .NET Edition
ColumnGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ColumnGroupings Property

Glossary Item Box

Gets a set of column groupings for the matrix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnGroupings As ColumnGroupingCollection
C#
public ColumnGroupingCollection ColumnGroupings {get;}

Property Value

A ColumnGroupingCollection object containing the set of column groupings for the matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


Corner Property

[image]
ActiveReports 19 .NET Edition
Corner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Corner Property

Glossary Item Box

Gets or sets a region that contains the elements of the upper left corner area of the matrix.

Syntax

Visual Basic (Declaration)
Public Property Corner As Corner
C#
public Corner Corner {get; set;}

Property Value

A Corner object representing the region that contains the elements of the upper left corner area of the matrix.

Remarks

If omitted, no report items are output in the corner.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


GroupsBeforeRowHeaders Property

[image]
ActiveReports 19 .NET Edition
GroupsBeforeRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : GroupsBeforeRowHeaders Property

Glossary Item Box

Gets or sets a number of instances of the outermost column group that appear to the left of the row headers, right of the row headers for right-to-left matrices.

Syntax

Visual Basic (Declaration)
Public Property GroupsBeforeRowHeaders As Integer
C#
public int GroupsBeforeRowHeaders {get; set;}

Property Value

An System.Int32 value indicating the number of instances of the outermost column group that appear to the left of the row headers.

Remarks

For the purposes of GroupsBeforeRowHeaders, a subtotal column is considered a part of (and will move with) the rightmost or leftmost detail column, as appropriate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


LayoutDirection Property

[image]
ActiveReports 19 .NET Edition
LayoutDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : LayoutDirection Property

Glossary Item Box

Gets or sets a value indicating whether the matrix columns grow left-to-right, with headers on the left, or right-to-left, with headers on the right.

Syntax

Visual Basic (Declaration)
Public Property LayoutDirection As LayoutDirection
C#
public LayoutDirection LayoutDirection {get; set;}

Property Value

A LayoutDirection value indicating whether the matrix columns grow left-to-right or right-to-left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


MatrixColumns Property

[image]
ActiveReports 19 .NET Edition
MatrixColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : MatrixColumns Property

Glossary Item Box

Gets the columns contained in each detail cell of the matrix layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatrixColumns As MatrixColumnCollection
C#
public MatrixColumnCollection MatrixColumns {get;}

Property Value

A MatrixColumnCollection object containing the columns contained in each detail cell of the matrix layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


MatrixRows Property

[image]
ActiveReports 19 .NET Edition
MatrixRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : MatrixRows Property

Glossary Item Box

Gets the rows contained in each detail cell of the matrix layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatrixRows As MatrixRowCollection
C#
public MatrixRowCollection MatrixRows {get;}

Property Value

A MatrixRowCollection object containing the rows contained in each detail cell of the matrix layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the data region.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


RowGroupings Property

[image]
ActiveReports 19 .NET Edition
RowGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : RowGroupings Property

Glossary Item Box

Gets a set of row groupings for the matrix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowGroupings As RowGroupingCollection
C#
public RowGroupingCollection RowGroupings {get;}

Property Value

A SeriesGroupingCollection object containing the set of row groupings for the matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Matrix Class
Matrix Members


MatrixCell Class

[image]
ActiveReports 19 .NET Edition
MatrixCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

Glossary Item Box

Represents a MatrixCell class defines the contents of each detail cell in a matrix.

Object Model

MatrixCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixCell
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class MatrixCell : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.MatrixCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Class Members

[image]
ActiveReports 19 .NET Edition
MatrixCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

Glossary Item Box

The following tables list the members exposed by MatrixCell.

Public Constructors

 | Name | Description
Public Constructor | MatrixCell Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Constructor

[image]
ActiveReports 19 .NET Edition
MatrixCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : MatrixCell Constructor

Glossary Item Box

Overload List

Overload | Description
MatrixCell Constructor() | Initializes a new instance of the MatrixCell class
MatrixCell Constructor(IEnumerable<ReportItem>) | Initializes a new instance of the MatrixCell class using a collection of child report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCell Class
MatrixCell Members


MatrixCell Constructor()

[image]
ActiveReports 19 .NET Edition
MatrixCell Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class > MatrixCell Constructor : MatrixCell Constructor()

Glossary Item Box

Initializes a new instance of the MatrixCell class

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MatrixCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCell Class
MatrixCell Members
Overload List


MatrixCell Constructor(IEnumerable<ReportItem>)

[image]
ActiveReports 19 .NET Edition
MatrixCell Constructor(IEnumerable<ReportItem>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class > MatrixCell Constructor : MatrixCell Constructor(IEnumerable<ReportItem>)

items
A collection of child ReportItem objects.

Glossary Item Box

Initializes a new instance of the MatrixCell class using a collection of child report items.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items As IEnumerable(Of ReportItem) _
)
C#
public MatrixCell(
   IEnumerable<ReportItem> items
)

Parameters

items
A collection of child ReportItem objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCell Class
MatrixCell Members
Overload List


MatrixCell Class Methods

[image]
ActiveReports 19 .NET Edition
MatrixCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

Glossary Item Box

For a list of all members of this type, see MatrixCell members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ReportItem object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCell Class
MatrixCell Members


MatrixCellCollection Class

[image]
ActiveReports 19 .NET Edition
MatrixCellCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class

Glossary Item Box

Represents a strongly typed collection of MatrixCell objects.

Object Model

MatrixCellCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixCellCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of MatrixCell)
C#
public sealed class MatrixCellCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<MatrixCell>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.MatrixCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCellCollection Class Members

[image]
ActiveReports 19 .NET Edition
MatrixCellCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class

Glossary Item Box

The following tables list the members exposed by MatrixCellCollection.

See Also

Reference

MatrixCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumn Class

[image]
ActiveReports 19 .NET Edition
MatrixColumn Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class

Glossary Item Box

Represents a column in the detail section of a matrix.

Object Model

MatrixColumn Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixColumn
C#
public sealed class MatrixColumn

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MatrixColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumn Class Members

[image]
ActiveReports 19 .NET Edition
MatrixColumn Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class

Glossary Item Box

The following tables list the members exposed by MatrixColumn.

Public Constructors

 | Name | Description
Public Constructor | MatrixColumn Constructor | Initializes a new instance of the MatrixColumn class.
Top

Public Properties

 | Name | Description
Public Property | Width | Gets or sets a width of each detail cell in the column.
Top

See Also

Reference

MatrixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumn Constructor

[image]
ActiveReports 19 .NET Edition
MatrixColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumn Class : MatrixColumn Constructor

Glossary Item Box

Initializes a new instance of the MatrixColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MatrixColumn()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixColumn Class
MatrixColumn Members


MatrixColumn Class Properties

[image]
ActiveReports 19 .NET Edition
MatrixColumn Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class

Glossary Item Box

For a list of all members of this type, see MatrixColumn members.

Public Properties

 | Name | Description
Public Property | Width | Gets or sets a width of each detail cell in the column.
Top

See Also

Reference

MatrixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumn Class : Width Property

Glossary Item Box

Gets or sets a width of each detail cell in the column.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of each detail cell in the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixColumn Class
MatrixColumn Members


MatrixColumnCollection Class

[image]
ActiveReports 19 .NET Edition
MatrixColumnCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

Glossary Item Box

Represents a strongly typed collection of MatrixColumn objects.

Object Model

MatrixColumnCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixColumnCollection
   Inherits System.Collections.ObjectModel.Collection(Of MatrixColumn)
C#
public sealed class MatrixColumnCollection : System.Collections.ObjectModel.Collection<MatrixColumn>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.MatrixColumnCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumnCollection Class Members

[image]
ActiveReports 19 .NET Edition
MatrixColumnCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

Glossary Item Box

The following tables list the members exposed by MatrixColumnCollection.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of MatrixColumn objects to the existing MatrixColumnCollection.
Top

See Also

Reference

MatrixColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumnCollection Class Methods

[image]
ActiveReports 19 .NET Edition
MatrixColumnCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

Glossary Item Box

For a list of all members of this type, see MatrixColumnCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of MatrixColumn objects to the existing MatrixColumnCollection.
Top

See Also

Reference

MatrixColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : AddRange Method

collection
A collection of the MatrixColumn objects to add.

Glossary Item Box

Adds a collection of MatrixColumn objects to the existing MatrixColumnCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of MatrixColumn) _
)
C#
public void AddRange(
   IEnumerable<MatrixColumn> collection
)

Parameters

collection
A collection of the MatrixColumn objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


MatrixRow Class

[image]
ActiveReports 19 .NET Edition
MatrixRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

Glossary Item Box

Represents a set of the matrix cells in a row of the detail section of a matrix.

Object Model

MatrixRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class MatrixRow : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.MatrixRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRow Class Members

[image]
ActiveReports 19 .NET Edition
MatrixRow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

Glossary Item Box

The following tables list the members exposed by MatrixRow.

Public Constructors

 | Name | Description
Public Constructor | MatrixRow Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of each detail cell in the row.
Public Property | MatrixCells | Gets a collection of cells in the row in the detail section of the Matrix.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the MatrixRow object.
Top

See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRow Constructor

[image]
ActiveReports 19 .NET Edition
MatrixRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : MatrixRow Constructor

Glossary Item Box

Overload List

Overload | Description
MatrixRow Constructor() | Initializes a new instance of the MatrixRow class.
MatrixRow Constructor(Length,IEnumerable<MatrixCell>) | Initializes a new instance of the MatrixRow class using a specified height and collection of cells.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRow Constructor()

[image]
ActiveReports 19 .NET Edition
MatrixRow Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class > MatrixRow Constructor : MatrixRow Constructor()

Glossary Item Box

Initializes a new instance of the MatrixRow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MatrixRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members
Overload List


MatrixRow Constructor(Length,IEnumerable<MatrixCell>)

[image]
ActiveReports 19 .NET Edition
MatrixRow Constructor(Length,IEnumerable<MatrixCell>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class > MatrixRow Constructor : MatrixRow Constructor(Length,IEnumerable<MatrixCell>)

height
A Length value indicating the height of the matrix row.
cells
A collection of the MatrixCell objects in the row.

Glossary Item Box

Initializes a new instance of the MatrixRow class using a specified height and collection of cells.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal height As Length, _
   ByVal cells As IEnumerable(Of MatrixCell) _
)
C#
public MatrixRow(
   Length height,
   IEnumerable<MatrixCell> cells
)

Parameters

height
A Length value indicating the height of the matrix row.
cells
A collection of the MatrixCell objects in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members
Overload List


MatrixRow Class Methods

[image]
ActiveReports 19 .NET Edition
MatrixRow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

Glossary Item Box

For a list of all members of this type, see MatrixRow members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the MatrixRow object.
Top

See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Validate Method

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the MatrixRow object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRow Class Properties

[image]
ActiveReports 19 .NET Edition
MatrixRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

Glossary Item Box

For a list of all members of this type, see MatrixRow members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of each detail cell in the row.
Public Property | MatrixCells | Gets a collection of cells in the row in the detail section of the Matrix.
Top

See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Height Property

Glossary Item Box

Gets or sets a height of each detail cell in the row.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of each detail cell in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixCells Property

[image]
ActiveReports 19 .NET Edition
MatrixCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : MatrixCells Property

Glossary Item Box

Gets a collection of cells in the row in the detail section of the Matrix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatrixCells As MatrixCellCollection
C#
public MatrixCellCollection MatrixCells {get;}

Property Value

A MatrixCellCollection object containing the cells in the row in the detail section of the Matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRowCollection Class

[image]
ActiveReports 19 .NET Edition
MatrixRowCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class

Glossary Item Box

Represents a strongly typed collection of MatrixRow objects.

Object Model

MatrixRowCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MatrixRowCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of MatrixRow)
C#
public sealed class MatrixRowCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<MatrixRow>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.MatrixRowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRowCollection Class Members

[image]
ActiveReports 19 .NET Edition
MatrixRowCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class

Glossary Item Box

The following tables list the members exposed by MatrixRowCollection.

See Also

Reference

MatrixRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


NameValidator Class

[image]
ActiveReports 19 .NET Edition
NameValidator Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class

Glossary Item Box

Represents a validator to check names contained in a report.

Object Model

NameValidator Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NameValidator
C#
public sealed class NameValidator

Example

C# Copy Code
var validator = new NameValidator();
bool isValid = validator.ValidateName("ReportItemName", NameType.Control);

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.NameValidator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameValidator Members
GrapeCity.ActiveReports.PageReportModel Namespace


NameValidator Class Members

[image]
ActiveReports 19 .NET Edition
NameValidator Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class

Glossary Item Box

The following tables list the members exposed by NameValidator.

Public Methods

 | Name | Description
Public Method | ValidateName | Checks report item names to ensure that they are unique, not empty or null, and do not contain invalid characters.
Top

See Also

Reference

NameValidator Class
GrapeCity.ActiveReports.PageReportModel Namespace


NameValidator Class Methods

[image]
ActiveReports 19 .NET Edition
NameValidator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class

Glossary Item Box

For a list of all members of this type, see NameValidator members.

Public Methods

 | Name | Description
Public Method | ValidateName | Checks report item names to ensure that they are unique, not empty or null, and do not contain invalid characters.
Top

See Also

Reference

NameValidator Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidateName Method

[image]
ActiveReports 19 .NET Edition
ValidateName Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > NameValidator Class : ValidateName Method

name
A System.String value indicating the name to validate.
nameType
A NameType value indicating whether the name is for a control, dataset, data region, or grouping object.

Glossary Item Box

Checks report item names to ensure that they are unique, not empty or null, and do not contain invalid characters.

Syntax

Visual Basic (Declaration)
Public Function ValidateName( _
   ByVal name As String, _
   ByVal nameType As NameType _
) As Boolean
C#
public bool ValidateName(
   string name,
   NameType nameType
)

Parameters

name
A System.String value indicating the name to validate.
nameType
A NameType value indicating whether the name is for a control, dataset, data region, or grouping object.

Return Value

A System.Booleanvalue. true if the name is valid; otherwise false.

Example

C# Copy Code
var validator = new NameValidator();
bool isValid = validator.ValidateName("ReportItemName", NameType.Control);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameValidator Class
NameValidator Members


NavigationItem Class

[image]
ActiveReports 19 .NET Edition
NavigationItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NavigationItem Class

Glossary Item Box

Represents a navigation item to use to draw the cover flow navigation layout.

Object Model

NavigationItem Class

Syntax

Visual Basic (Declaration)
Public Class NavigationItem
C#
public class NavigationItem

Remarks

The NavigationItem class provides settings for specifying the report item or reference to be used for drawing the cover flow navigation layout.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.NavigationItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigationItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


NavigationItem Class Members

[image]
ActiveReports 19 .NET Edition
NavigationItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NavigationItem Class

Glossary Item Box

The following tables list the members exposed by NavigationItem.

Public Constructors

 | Name | Description
Public Constructor | NavigationItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReportItem | Gets or sets a report item to use to draw the cover flow navigation layout.
Public Property | ReportItemReference | Gets or sets a report item reference to use to draw the cover flow navigation layout.
Top

See Also

Reference

NavigationItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


NavigationItem Constructor

[image]
ActiveReports 19 .NET Edition
NavigationItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > NavigationItem Class : NavigationItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public NavigationItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigationItem Class
NavigationItem Members


NavigationItem Class Properties

[image]
ActiveReports 19 .NET Edition
NavigationItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NavigationItem Class

Glossary Item Box

For a list of all members of this type, see NavigationItem members.

Public Properties

 | Name | Description
Public Property | ReportItem | Gets or sets a report item to use to draw the cover flow navigation layout.
Public Property | ReportItemReference | Gets or sets a report item reference to use to draw the cover flow navigation layout.
Top

See Also

Reference

NavigationItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > NavigationItem Class : ReportItem Property

Glossary Item Box

Gets or sets a report item to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Public Property ReportItem As ReportItem
C#
public ReportItem ReportItem {get; set;}

Property Value

A ReportItem object representing the referenced report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigationItem Class
NavigationItem Members


ReportItemReference Property

[image]
ActiveReports 19 .NET Edition
ReportItemReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > NavigationItem Class : ReportItemReference Property

Glossary Item Box

Gets or sets a report item reference to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Public Property ReportItemReference As String
C#
public string ReportItemReference {get; set;}

Property Value

A System.String value indicating the report item reference.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigationItem Class
NavigationItem Members


OrderBy Class

[image]
ActiveReports 19 .NET Edition
OrderBy Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderBy Class

Glossary Item Box

Represents an order for the parameter values.

Object Model

OrderBy Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OrderBy
C#
public sealed class OrderBy

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.OrderBy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderBy Members
GrapeCity.ActiveReports.PageReportModel Namespace


OrderBy Class Members

[image]
ActiveReports 19 .NET Edition
OrderBy Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderBy Class

Glossary Item Box

The following tables list the members exposed by OrderBy.

Public Constructors

 | Name | Description
Public Constructor | OrderBy Constructor | Initializes a new instance of the OrderBy class.
Top

Public Properties

 | Name | Description
Public Property | Condition | Gets or sets a condition of the order.
Public Property | Direction | Gets or sets a direction of the order.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

OrderBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


OrderBy Constructor

[image]
ActiveReports 19 .NET Edition
OrderBy Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OrderBy Class : OrderBy Constructor

Glossary Item Box

Initializes a new instance of the OrderBy class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OrderBy()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderBy Class
OrderBy Members


OrderBy Class Methods

[image]
ActiveReports 19 .NET Edition
OrderBy Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderBy Class

Glossary Item Box

For a list of all members of this type, see OrderBy members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top

See Also

Reference

OrderBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OrderBy Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OrderBy
C#
public OrderBy Clone()

Return Value

A new OrderBy object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderBy Class
OrderBy Members


OrderBy Class Properties

[image]
ActiveReports 19 .NET Edition
OrderBy Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderBy Class

Glossary Item Box

For a list of all members of this type, see OrderBy members.

Public Properties

 | Name | Description
Public Property | Condition | Gets or sets a condition of the order.
Public Property | Direction | Gets or sets a direction of the order.
Top

See Also

Reference

OrderBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Condition Property

[image]
ActiveReports 19 .NET Edition
Condition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OrderBy Class : Condition Property

Glossary Item Box

Gets or sets a condition of the order.

Syntax

Visual Basic (Declaration)
Public Property Condition As OrderByCondition
C#
public OrderByCondition Condition {get; set;}

Property Value

A OrderByCondition value indicating the condition of the parameter values order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderBy Class
OrderBy Members


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OrderBy Class : Direction Property

Glossary Item Box

Gets or sets a direction of the order.

Syntax

Visual Basic (Declaration)
Public Property Direction As OrderByDirection
C#
public OrderByDirection Direction {get; set;}

Property Value

A OrderByDirection value indicating the direction of the parameter values order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderBy Class
OrderBy Members


OverflowPlaceHolder Class

[image]
ActiveReports 19 .NET Edition
OverflowPlaceHolder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

Glossary Item Box

Represents a placeholder ReportItem associated with a DataRegion from a previous page.

Object Model

OverflowPlaceHolder Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OverflowPlaceHolder
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class OverflowPlaceHolder : ReportItem, IReportComponent, IValidateable

Remarks

The ReportItem.Height and ReportItem.Width of this report item dictate the DataRegion.FixedHeight and DataRegion.FixedWidth when continuing layout of the data region.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.OverflowPlaceHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OverflowPlaceHolder Members
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowPlaceHolder Class Members

[image]
ActiveReports 19 .NET Edition
OverflowPlaceHolder Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

Glossary Item Box

The following tables list the members exposed by OverflowPlaceHolder.

Public Constructors

 | Name | Description
Public Constructor | OverflowPlaceHolder Constructor | Initializes a new instance of the OverflowPlaceHolder class.
Top

Public Properties

 | Name | Description
Public Property | OverflowName | Gets or sets the name of the data region's overflow.
Top

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the OverflowPlaceHolder object.
Top

See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowPlaceHolder Constructor

[image]
ActiveReports 19 .NET Edition
OverflowPlaceHolder Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : OverflowPlaceHolder Constructor

Glossary Item Box

Initializes a new instance of the OverflowPlaceHolder class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OverflowPlaceHolder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


OverflowPlaceHolder Class Methods

[image]
ActiveReports 19 .NET Edition
OverflowPlaceHolder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

Glossary Item Box

For a list of all members of this type, see OverflowPlaceHolder members.

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the OverflowPlaceHolder object.
Top

See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the OverflowPlaceHolder object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


OverflowPlaceHolder Class Properties

[image]
ActiveReports 19 .NET Edition
OverflowPlaceHolder Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

Glossary Item Box

For a list of all members of this type, see OverflowPlaceHolder members.

Public Properties

 | Name | Description
Public Property | OverflowName | Gets or sets the name of the data region's overflow.
Top

See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : OverflowName Property

Glossary Item Box

Gets or sets the name of the data region's overflow.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A System.String value indicating the name of the data region's overflow.

Example

C# Copy Code
OverflowPlaceHolder placeHolder = new OverflowPlaceHolder();
placeHolder.OverflowName = "OverflowPlaceHolder1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Page Class

[image]
ActiveReports 19 .NET Edition
Page Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

Glossary Item Box

The Page element contains the definition of a fixed layout page.

Object Model

Page Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Page
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
C#
public sealed class Page : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Members
GrapeCity.ActiveReports.PageReportModel Namespace


Page Class Members

[image]
ActiveReports 19 .NET Edition
Page Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

Glossary Item Box

The following tables list the members exposed by Page.

Public Constructors

 | Name | Description
Public Constructor | Page Constructor | Initializes a new instance of the Page class.
Top

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | CustomProperties | Gets the custom properties of the page.
Public Property | Height | Gets or sets a height of the page.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | PaperOrientation | Gets or sets an orientation of the page for printing.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component.
Public Property | Style | Gets or sets a style settings for the page.
Public Property | ThrowIfPlaceHoldersEmpty | Gets or sets a value indicating whether the page should throw an error if placeholders are empty.
Public Property | TopMargin | Gets or sets a height of the top margin.
Public Property | Visibility | Gets or sets a value indicating whether the page is hidden.
Public Property | Width | Gets or sets a width of the page.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


Page Constructor

[image]
ActiveReports 19 .NET Edition
Page Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Page Constructor

Glossary Item Box

Initializes a new instance of the Page class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Page()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Properties

[image]
ActiveReports 19 .NET Edition
Page Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | CustomProperties | Gets the custom properties of the page.
Public Property | Height | Gets or sets a height of the page.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | PaperOrientation | Gets or sets an orientation of the page for printing.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component.
Public Property | Style | Gets or sets a style settings for the page.
Public Property | ThrowIfPlaceHoldersEmpty | Gets or sets a value indicating whether the page should throw an error if placeholders are empty.
Public Property | TopMargin | Gets or sets a height of the top margin.
Public Property | Visibility | Gets or sets a value indicating whether the page is hidden.
Public Property | Width | Gets or sets a width of the page.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : BottomMargin Property

Glossary Item Box

Gets or sets a height of the bottom margin.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As Length
C#
public Length BottomMargin {get; set;}

Property Value

A Length value indicating the height of the bottom margin. Default value is 0in.

Example

C# Copy Code
Page page = new Page();
page.BottomMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : CustomProperties Property

Glossary Item Box

Gets the custom properties of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection object containing custom properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Height Property

Glossary Item Box

Gets or sets a height of the page.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the page.

Example

C# Copy Code
Page page = new Page();
page.Height = "11in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : LeftMargin Property

Glossary Item Box

Gets or sets a width of the left margin.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As Length
C#
public Length LeftMargin {get; set;}

Property Value

A Length value indicating the width of the left margin. Default value is 0in.

Example

C# Copy Code
Page page = new Page();
page.LeftMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PaperOrientation Property

[image]
ActiveReports 19 .NET Edition
PaperOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : PaperOrientation Property

Glossary Item Box

Gets or sets an orientation of the page for printing.

Syntax

Visual Basic (Declaration)
Public Property PaperOrientation As PaperOrientation
C#
public PaperOrientation PaperOrientation {get; set;}

Property Value

A PaperOrientation value indicating the page orientation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : RightMargin Property

Glossary Item Box

Gets or sets a width of the right margin.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As Length
C#
public Length RightMargin {get; set;}

Property Value

A Length value indicating the width of the right margin. Default value is 0in.

Example

C# Copy Code
Page page = new Page();
page.RightMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Site Property

Glossary Item Box

Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component.

Syntax

Visual Basic (Declaration)
Public Shadows Property Site As ISite
C#
public new ISite Site {get; set;}

Property Value

An System.ComponentModel.ISite object representing the site associated with the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Style Property

Glossary Item Box

Gets or sets a style settings for the page.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object representing the style of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ThrowIfPlaceHoldersEmpty Property

[image]
ActiveReports 19 .NET Edition
ThrowIfPlaceHoldersEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : ThrowIfPlaceHoldersEmpty Property

Glossary Item Box

Gets or sets a value indicating whether the page should throw an error if placeholders are empty.

Syntax

Visual Basic (Declaration)
Public Property ThrowIfPlaceHoldersEmpty As Boolean
C#
public bool ThrowIfPlaceHoldersEmpty {get; set;}

Property Value

A System.Boolean value indicating whether to throw an error for empty placeholders.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : TopMargin Property

Glossary Item Box

Gets or sets a height of the top margin.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As Length
C#
public Length TopMargin {get; set;}

Property Value

A Length value indicating the height of the top margin. Default value is 0in.

Example

C# Copy Code
Page page = new Page();
page.TopMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the page is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Width Property

Glossary Item Box

Gets or sets a width of the page.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the page.

Example

C# Copy Code
Page page = new Page();
page.Width = "8.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PageBreak Class

[image]
ActiveReports 19 .NET Edition
PageBreak Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class

Glossary Item Box

Represents the options for page breaking in a report.

Object Model

PageBreak Class

Syntax

Visual Basic (Declaration)
Public Class PageBreak
C#
public class PageBreak

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PageBreak

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageBreak Class Members

[image]
ActiveReports 19 .NET Edition
PageBreak Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class

Glossary Item Box

The following tables list the members exposed by PageBreak.

Public Constructors

 | Name | Description
Public Constructor | PageBreak Constructor | Initializes a new instance of the PageBreak class.
Top

Public Properties

 | Name | Description
Public Property | BreakLocation | Gets or sets a location where the page break occurs.
Public Property | Disabled | Gets or sets a value indicating whether the page break is disabled.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | ResetPageNumber | Gets or sets a value indicating whether the page number should reset after the page break.
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageBreak Constructor

[image]
ActiveReports 19 .NET Edition
PageBreak Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : PageBreak Constructor

Glossary Item Box

Initializes a new instance of the PageBreak class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageBreak()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageBreak Class Properties

[image]
ActiveReports 19 .NET Edition
PageBreak Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class

Glossary Item Box

For a list of all members of this type, see PageBreak members.

Public Properties

 | Name | Description
Public Property | BreakLocation | Gets or sets a location where the page break occurs.
Public Property | Disabled | Gets or sets a value indicating whether the page break is disabled.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | ResetPageNumber | Gets or sets a value indicating whether the page number should reset after the page break.
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.PageReportModel Namespace


BreakLocation Property

[image]
ActiveReports 19 .NET Edition
BreakLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : BreakLocation Property

Glossary Item Box

Gets or sets a location where the page break occurs.

Syntax

Visual Basic (Declaration)
Public Property BreakLocation As BreakLocation
C#
public BreakLocation BreakLocation {get; set;}

Property Value

A BreakLocation value indicating the location of the page break. Default is BreakLocation.None.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


Disabled Property

[image]
ActiveReports 19 .NET Edition
Disabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : Disabled Property

Glossary Item Box

Gets or sets a value indicating whether the page break is disabled.

Syntax

Visual Basic (Declaration)
Public Property Disabled As ExpressionInfo
C#
public ExpressionInfo Disabled {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing a System.Boolean value. true indicates the page break is disabled; otherwise, false. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : NewPage Property

Glossary Item Box

Gets or sets a value indicating on which page the content should start after the page break.

Syntax

Visual Basic (Declaration)
Public Property NewPage As StartNewPage
C#
public StartNewPage NewPage {get; set;}

Property Value

A StartNewPage value indicating the page where the new content starts after the page break.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


ResetPageNumber Property

[image]
ActiveReports 19 .NET Edition
ResetPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : ResetPageNumber Property

Glossary Item Box

Gets or sets a value indicating whether the page number should reset after the page break.

Syntax

Visual Basic (Declaration)
Public Property ResetPageNumber As ExpressionInfo
C#
public ExpressionInfo ResetPageNumber {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing a System.Boolean value. true indicates the page number resets after the page break; otherwise, false. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageCollection Class

[image]
ActiveReports 19 .NET Edition
PageCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

Glossary Item Box

Represents a strongly typed collection of Page objects.

Object Model

PageCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageCollection
C#
public sealed class PageCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PageCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollection Class Members

[image]
ActiveReports 19 .NET Edition
PageCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

Glossary Item Box

The following tables list the members exposed by PageCollection.

Public Constructors

 | Name | Description
Public Constructor | PageCollection Constructor | Initializes a new instance of the PageCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of Page objects in the PageCollection.
Public Property | IsReadOnly | Gets a value indicating whether the PageCollection is read-only.
Public Property | Item | Gets or sets a specific Page object in the PageCollection by position.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Page object to the PageCollection.
Public Method | Clear | Removes all items from the PageCollection.
Public Method | Contains | Gets a value indicating whether the PageCollection contains the specified Page.
Public Method | CopyTo | Copies the objects in the PageCollection to a Page array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific Page object in the PageCollection.
Public Method | Insert | Inserts a new Page into the PageCollection at the specified location.
Public Method | Remove | Removes the specified Page object from the PageCollection.
Public Method | RemoveAt | Removes a Page object from the PageCollection at the specified index.
Public Method | ToArray | Copies the elements of the PageCollection to a new array.
Top

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Top

See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollection Constructor

[image]
ActiveReports 19 .NET Edition
PageCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : PageCollection Constructor

Glossary Item Box

Initializes a new instance of the PageCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Methods

[image]
ActiveReports 19 .NET Edition
PageCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

Glossary Item Box

For a list of all members of this type, see PageCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Page object to the PageCollection.
Public Method | Clear | Removes all items from the PageCollection.
Public Method | Contains | Gets a value indicating whether the PageCollection contains the specified Page.
Public Method | CopyTo | Copies the objects in the PageCollection to a Page array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific Page object in the PageCollection.
Public Method | Insert | Inserts a new Page into the PageCollection at the specified location.
Public Method | Remove | Removes the specified Page object from the PageCollection.
Public Method | RemoveAt | Removes a Page object from the PageCollection at the specified index.
Public Method | ToArray | Copies the elements of the PageCollection to a new array.
Top

See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Add Method

value
A Page object to add.

Glossary Item Box

Adds a Page object to the PageCollection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal value As Page _
)
C#
public void Add(
   Page value
)

Parameters

value
A Page object to add.

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Add(new Page());

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Clear Method

Glossary Item Box

Removes all items from the PageCollection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Contains Method

item
A Page object for which to check.

Glossary Item Box

Gets a value indicating whether the PageCollection contains the specified Page.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Page _
) As Boolean
C#
public bool Contains(
   Page item
)

Parameters

item
A Page object for which to check.

Return Value

A System.Boolean value. true if the PageCollection contains the specified Page; otherwise, false.

Example

C# Copy Code
PageCollection collection = new PageCollection();
Page page = new Page();
collection.Add(page);
bool contains = collection.Contains(page);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : CopyTo Method

array
An one-dimensional array of the Page objects that is the destination of the elements copied from the PageCollection. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Glossary Item Box

Copies the objects in the PageCollection to a Page array, starting at the specified array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Page, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Page[] array,
   int arrayIndex
)

Parameters

array
An one-dimensional array of the Page objects that is the destination of the elements copied from the PageCollection. The array must have zero-based indexing.
arrayIndex
A zero-based System.Int32 index in the array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : IndexOf Method

item
A Page object to locate in the PageCollection.

Glossary Item Box

Determines the index of a specific Page object in the PageCollection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As Page _
) As Integer
C#
public int IndexOf(
   Page item
)

Parameters

item
A Page object to locate in the PageCollection.

Return Value

An System.Int32 value indicating the index of the entry if it was found in the collection; otherwise, -1.

Example

C# Copy Code
PageCollection collection = new PageCollection();
Page page = new Page();
int index = collection.IndexOf(page);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Insert Method

index
A zero-based System.Int32 index indicating the position at which to insert the Page object.
value
A Page object to insert.

Glossary Item Box

Inserts a new Page into the PageCollection at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Page _
)
C#
public void Insert(
   int index,
   Page value
)

Parameters

index
A zero-based System.Int32 index indicating the position at which to insert the Page object.
value
A Page object to insert.

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Insert(0, new Page());

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Remove Method

value
A Page object to remove.

Glossary Item Box

Removes the specified Page object from the PageCollection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal value As Page _
) As Boolean
C#
public bool Remove(
   Page value
)

Parameters

value
A Page object to remove.

Return Value

A System.Boolean value. true if the Page was successfully removed; otherwise, false.

Example

C# Copy Code
PageCollection collection = new PageCollection();
Page page = new Page();
collection.Add(page);
bool removed = collection.Remove(page);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : RemoveAt Method

index
A zero-based System.Int32 index at which to remove the Page object.

Glossary Item Box

Removes a Page object from the PageCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
A zero-based System.Int32 index at which to remove the Page object.

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Add(new Page());
collection.RemoveAt(0);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : ToArray Method

Glossary Item Box

Copies the elements of the PageCollection to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As Page()
C#
public Page[] ToArray()

Return Value

An array of Page objects containing copies of the elements in the PageCollection.

Example

C# Copy Code
PageCollection collection = new PageCollection();
Page[] array = collection.ToArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Properties

[image]
ActiveReports 19 .NET Edition
PageCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

Glossary Item Box

For a list of all members of this type, see PageCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of Page objects in the PageCollection.
Public Property | IsReadOnly | Gets a value indicating whether the PageCollection is read-only.
Public Property | Item | Gets or sets a specific Page object in the PageCollection by position.
Top

See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Count Property

Glossary Item Box

Gets the number of Page objects in the PageCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An System.Int32 value indicating the number of Page objects.

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Add(new Page());
int count = collection.Count;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the PageCollection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

A System.Boolean value. true if the PageCollection is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Item Property

index
A zero-based System.Int32 index of the Page to return or set.

Glossary Item Box

Gets or sets a specific Page object in the PageCollection by position.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Page
C#
public Page this[
   int index
]; {get; set;}

Parameters

index
A zero-based System.Int32 index of the Page to return or set.

Property Value

A Page object at the specified position.

Example

C# Copy Code
PageCollection collection = new PageCollection();
collection.Add(new Page());
Page page = collection[0];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Events

[image]
ActiveReports 19 .NET Edition
PageCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

Glossary Item Box

For a list of all members of this type, see PageCollection members.

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Top

See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemAdded Event

[image]
ActiveReports 19 .NET Edition
ItemAdded Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : ItemAdded Event

Glossary Item Box

Occurs immediately after adding an item to the collection.

Syntax

Visual Basic (Declaration)
Public Event ItemAdded As PageCollectionEventHandler
C#
public event PageCollectionEventHandler ItemAdded

Event Data

The event handler receives an argument of type PageCollectionEventArgs containing data related to this event. The following PageCollectionEventArgs properties provide information specific to this event.

Property | Description
Value | Gets the Page object that was added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollection Class
PageCollection Members


PageCollectionEventArgs Class

[image]
ActiveReports 19 .NET Edition
PageCollectionEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class

Glossary Item Box

Represents a data for the PageCollection.ItemAdded event of the PageCollection.

Object Model

PageCollectionEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageCollectionEventArgs
   Inherits System.EventArgs
C#
public sealed class PageCollectionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.PageCollectionEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollectionEventArgs Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollectionEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
PageCollectionEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class

Glossary Item Box

The following tables list the members exposed by PageCollectionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PageCollectionEventArgs Constructor | Initializes a new instance of the PageCollectionEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Value | Gets the Page object that was added.
Top

See Also

Reference

PageCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollectionEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
PageCollectionEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollectionEventArgs Class : PageCollectionEventArgs Constructor

value
The Page object that was added.

Glossary Item Box

Initializes a new instance of the PageCollectionEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Page _
)
C#
public PageCollectionEventArgs(
   Page value
)

Parameters

value
The Page object that was added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollectionEventArgs Class
PageCollectionEventArgs Members


PageCollectionEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
PageCollectionEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class

Glossary Item Box

For a list of all members of this type, see PageCollectionEventArgs members.

Public Properties

 | Name | Description
Public Property | Value | Gets the Page object that was added.
Top

See Also

Reference

PageCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollectionEventArgs Class : Value Property

Glossary Item Box

Gets the Page object that was added.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Page
C#
public Page Value {get;}

Property Value

A Page object representing the item that was added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollectionEventArgs Class
PageCollectionEventArgs Members


PageHeaderFooter Class

[image]
ActiveReports 19 .NET Edition
PageHeaderFooter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

Glossary Item Box

Represents the layout for each ReportItem at the top (PageHeader) or bottom (PageFooter) of each page.

Object Model

PageHeaderFooter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageHeaderFooter
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class PageHeaderFooter : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.PageHeaderFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageHeaderFooter Class Members

[image]
ActiveReports 19 .NET Edition
PageHeaderFooter Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

Glossary Item Box

The following tables list the members exposed by PageHeaderFooter.

Public Constructors

 | Name | Description
Public Constructor | PageHeaderFooter Constructor | Initializes a new instance of the PageHeaderFooter class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets a height of the page header or footer.
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the page header or footer is rendered on the first page.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the page header or footer is rendered on the last page.
Public Property | Style | Gets or sets a style information for the page header or footer.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the PageHeaderFooter object.
Top

See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageHeaderFooter Constructor

[image]
ActiveReports 19 .NET Edition
PageHeaderFooter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PageHeaderFooter Constructor

Glossary Item Box

Initializes a new instance of the PageHeaderFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageHeaderFooter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PageHeaderFooter Class Methods

[image]
ActiveReports 19 .NET Edition
PageHeaderFooter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

Glossary Item Box

For a list of all members of this type, see PageHeaderFooter members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the PageHeaderFooter object.
Top

See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the PageHeaderFooter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PageHeaderFooter Class Properties

[image]
ActiveReports 19 .NET Edition
PageHeaderFooter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

Glossary Item Box

For a list of all members of this type, see PageHeaderFooter members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets a height of the page header or footer.
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the page header or footer is rendered on the first page.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the page header or footer is rendered on the last page.
Public Property | Style | Gets or sets a style information for the page header or footer.
Top

See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Height Property

Glossary Item Box

Gets or sets a height of the page header or footer.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the page header or footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PrintOnFirstPage Property

[image]
ActiveReports 19 .NET Edition
PrintOnFirstPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PrintOnFirstPage Property

Glossary Item Box

Gets or sets a value indicating whether the page header or footer is rendered on the first page.

Syntax

Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean
C#
public bool PrintOnFirstPage {get; set;}

Property Value

A System.Boolean value where true means the header or footer is rendered on the first page; otherwise, false. Default is false.

Remarks

This property is ignored in single-page reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PrintOnLastPage Property

[image]
ActiveReports 19 .NET Edition
PrintOnLastPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PrintOnLastPage Property

Glossary Item Box

Gets or sets a value indicating whether the page header or footer is rendered on the last page.

Syntax

Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean
C#
public bool PrintOnLastPage {get; set;}

Property Value

A System.Boolean value where true means the header or footer is rendered on the last page; otherwise, false. Default is false.

Remarks

This property is ignored in single-page reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Style Property

Glossary Item Box

Gets or sets a style information for the page header or footer.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object representing the style details for the page header or footer.

Remarks

When applying style information, the page header and footer are treated similarly to a Container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Parameter Class

[image]
ActiveReports 19 .NET Edition
Parameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

Glossary Item Box

Represents a parameter element for a subreport, containing information about the parameter's value and behavior.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter
   Implements IValidateable
C#
public sealed class Parameter : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Parameter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor | Initializes a new instance of the Parameter class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Omit | Gets or sets a Boolean expression that indicates whether the parameter is skipped.
Public Property | Value | Gets or sets the expression that evaluates to the value to pass for the parameter to the subreport.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Parameter object.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parameter Constructor

[image]
ActiveReports 19 .NET Edition
Parameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Parameter Constructor

Glossary Item Box

Initializes a new instance of the Parameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Parameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

[image]
ActiveReports 19 .NET Edition
Parameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Parameter object.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Parameter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

[image]
ActiveReports 19 .NET Edition
Parameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Omit | Gets or sets a Boolean expression that indicates whether the parameter is skipped.
Public Property | Value | Gets or sets the expression that evaluates to the value to pass for the parameter to the subreport.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Name Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String representing the name of the parameter.

Example

C# Copy Code
Parameter param = new Parameter();
param.Name = "OrderParam";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Omit Property

[image]
ActiveReports 19 .NET Edition
Omit Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Omit Property

Glossary Item Box

Gets or sets a Boolean expression that indicates whether the parameter is skipped.

Syntax

Visual Basic (Declaration)
Public Property Omit As ExpressionInfo
C#
public ExpressionInfo Omit {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a System.Boolean value indicating whether the parameter is skipped. The default value is false.

Remarks

When this property evaluates to true, the parameter is omitted from the subreport.

Example

C# Copy Code
Parameter param = new Parameter();
param.Omit = ExpressionInfo.FromString("true");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Value Property

Glossary Item Box

Gets or sets the expression that evaluates to the value to pass for the parameter to the subreport.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value to pass for the parameter to the subreport.

Example

C# Copy Code
Parameter param = new Parameter();
param.Value = "=Fields!OrderID.Value";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class

Glossary Item Box

Represents a strongly typed collection of Parameter objects.

Object Model

ParameterCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterCollection
   Inherits System.Collections.ObjectModel.Collection(Of Parameter)
C#
public sealed class ParameterCollection : System.Collections.ObjectModel.Collection<Parameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterCollection Class Members

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor | Initializes a new instance of the ParameterCollection class.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterCollection Constructor

[image]
ActiveReports 19 .NET Edition
ParameterCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : ParameterCollection Constructor

Glossary Item Box

Initializes a new instance of the ParameterCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterValue Class

[image]
ActiveReports 19 .NET Edition
ParameterValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

Glossary Item Box

Represents a possible value for the parameter.

Object Model

ParameterValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterValue
   Implements IValidateable
C#
public sealed class ParameterValue : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ParameterValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValue Class Members

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

Glossary Item Box

The following tables list the members exposed by ParameterValue.

Public Constructors

 | Name | Description
Public Constructor | ParameterValue Constructor | Initializes a new instance of the ParameterValue class.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets a user-friendly label to display for the value in the UI.
Public Property | Value | Gets or sets a possible value for the parameter.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the ParameterValue object.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValue Constructor

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : ParameterValue Constructor

Glossary Item Box

Initializes a new instance of the ParameterValue class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

Glossary Item Box

For a list of all members of this type, see ParameterValue members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the ParameterValue object.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As ParameterValue
C#
public ParameterValue Clone()

Return Value

A new ParameterValue object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ParameterValue object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

Glossary Item Box

For a list of all members of this type, see ParameterValue members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets a user-friendly label to display for the value in the UI.
Public Property | Value | Gets or sets a possible value for the parameter.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Label Property

Glossary Item Box

Gets or sets a user-friendly label to display for the value in the UI.

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing a label to display for the value in the UI.

Remarks

If not supplied, the Value is used as the label. If a Value is not supplied, the label is an empty string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Value Property

Glossary Item Box

Gets or sets a possible value for the parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing a possible value for the parameter.

Remarks

For Boolean parameters, use true or false.

For DateTime parameters, use ISO 8601 date time format: yyyy-mm-ddThh:mm:ss[.mmm].

For Float parameters, use "." as the optional decimal separator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValueCollection Class

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class

Glossary Item Box

Represents a strongly typed collection of ParameterValue objects.

Object Model

ParameterValueCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterValueCollection
   Inherits System.Collections.ObjectModel.Collection(Of ParameterValue)
C#
public sealed class ParameterValueCollection : System.Collections.ObjectModel.Collection<ParameterValue>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ParameterValueCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValueCollection Class Members

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterValueCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterValueCollection Constructor |
Top

See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValueCollection Constructor

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : ParameterValueCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterValueCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


PartItem Class

[image]
ActiveReports 19 .NET Edition
PartItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartItem Class

Glossary Item Box

Represents a reference to a shared report item.

Object Model

PartItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartItem
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class PartItem : ReportItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.PartItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


PartItem Class Members

[image]
ActiveReports 19 .NET Edition
PartItem Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartItem Class

Glossary Item Box

The following tables list the members exposed by PartItem.

Public Constructors

 | Name | Description
Public Constructor | PartItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Library | Gets or sets a name of the reports parts library.
Public Property | OverflowName | Gets or sets the name of the overflow placeholder report item to be used if the part item does not fit into its size.
Public Property | Properties | Gets or sets a collection of properties for the part item.
Public Property | ReportPart | Gets or sets the name of the report part in the library.
Top

See Also

Reference

PartItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


PartItem Constructor

[image]
ActiveReports 19 .NET Edition
PartItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartItem Class : PartItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PartItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Class
PartItem Members


PartItem Class Properties

[image]
ActiveReports 19 .NET Edition
PartItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartItem Class

Glossary Item Box

For a list of all members of this type, see PartItem members.

Public Properties

 | Name | Description
Public Property | Library | Gets or sets a name of the reports parts library.
Public Property | OverflowName | Gets or sets the name of the overflow placeholder report item to be used if the part item does not fit into its size.
Public Property | Properties | Gets or sets a collection of properties for the part item.
Public Property | ReportPart | Gets or sets the name of the report part in the library.
Top

See Also

Reference

PartItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Library Property

[image]
ActiveReports 19 .NET Edition
Library Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartItem Class : Library Property

Glossary Item Box

Gets or sets a name of the reports parts library.

Syntax

Visual Basic (Declaration)
Public Property Library As String
C#
public string Library {get; set;}

Property Value

A System.String value indicating the name of the reports parts library. See PartsLibraryReference.Name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Class
PartItem Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartItem Class : OverflowName Property

Glossary Item Box

Gets or sets the name of the overflow placeholder report item to be used if the part item does not fit into its size.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A A System.String value indicating the name of the overflow placeholder report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Class
PartItem Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartItem Class : Properties Property

Glossary Item Box

Gets or sets a collection of properties for the part item.

Syntax

Visual Basic (Declaration)
Public Property Properties As MappedPropertiesCollection
C#
public MappedPropertiesCollection Properties {get; set;}

Property Value

A MappedPropertiesCollection object containing the properties for the part item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Class
PartItem Members


ReportPart Property

[image]
ActiveReports 19 .NET Edition
ReportPart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartItem Class : ReportPart Property

Glossary Item Box

Gets or sets the name of the report part in the library.

Syntax

Visual Basic (Declaration)
Public Property ReportPart As String
C#
public string ReportPart {get; set;}

Property Value

A System.String value indicating the name of the report part in the library.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartItem Class
PartItem Members


PartsLibraryReference Class

[image]
ActiveReports 19 .NET Edition
PartsLibraryReference Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartsLibraryReference Class

Glossary Item Box

Represents a reference to the report items library.

Object Model

PartsLibraryReference Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartsLibraryReference
C#
public sealed class PartsLibraryReference

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PartsLibraryReference

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartsLibraryReference Members
GrapeCity.ActiveReports.PageReportModel Namespace


PartsLibraryReference Class Members

[image]
ActiveReports 19 .NET Edition
PartsLibraryReference Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartsLibraryReference Class

Glossary Item Box

The following tables list the members exposed by PartsLibraryReference.

Public Constructors

 | Name | Description
Public Constructor | PartsLibraryReference Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name of the library.
Public Property | Path | Gets or sets a path or identifier of the library.
Top

See Also

Reference

PartsLibraryReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


PartsLibraryReference Constructor

[image]
ActiveReports 19 .NET Edition
PartsLibraryReference Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartsLibraryReference Class : PartsLibraryReference Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PartsLibraryReference()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartsLibraryReference Class
PartsLibraryReference Members


PartsLibraryReference Class Properties

[image]
ActiveReports 19 .NET Edition
PartsLibraryReference Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PartsLibraryReference Class

Glossary Item Box

For a list of all members of this type, see PartsLibraryReference members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name of the library.
Public Property | Path | Gets or sets a path or identifier of the library.
Top

See Also

Reference

PartsLibraryReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartsLibraryReference Class : Name Property

Glossary Item Box

Gets or sets a name of the library.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the library. This name is used to reference the library from PartItem.Library.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartsLibraryReference Class
PartsLibraryReference Members


Path Property

[image]
ActiveReports 19 .NET Edition
Path Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PartsLibraryReference Class : Path Property

Glossary Item Box

Gets or sets a path or identifier of the library.

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path {get; set;}

Property Value

A System.String value indicating the path or identifier of the library, which allows the rendering engine to look up the library definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartsLibraryReference Class
PartsLibraryReference Members


PlayAxis Class

[image]
ActiveReports 19 .NET Edition
PlayAxis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlayAxis Class

Glossary Item Box

Represents a play axis navigation type.

Object Model

PlayAxis Class

Syntax

Visual Basic (Declaration)
Public Class PlayAxis
C#
public class PlayAxis

Remarks

The PlayAxis class includes settings for the slider and its docking option.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PlayAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlayAxis Members
GrapeCity.ActiveReports.PageReportModel Namespace


PlayAxis Class Members

[image]
ActiveReports 19 .NET Edition
PlayAxis Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlayAxis Class

Glossary Item Box

The following tables list the members exposed by PlayAxis.

Public Constructors

 | Name | Description
Public Constructor | PlayAxis Constructor |
Top

Public Properties

 | Name | Description
Public Property | DockingOption | Gets or sets a docking option of the slider.
Public Property | Slider | Gets or sets the slider settings.
Top

See Also

Reference

PlayAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


PlayAxis Constructor

[image]
ActiveReports 19 .NET Edition
PlayAxis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlayAxis Class : PlayAxis Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PlayAxis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlayAxis Class
PlayAxis Members


PlayAxis Class Properties

[image]
ActiveReports 19 .NET Edition
PlayAxis Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlayAxis Class

Glossary Item Box

For a list of all members of this type, see PlayAxis members.

Public Properties

 | Name | Description
Public Property | DockingOption | Gets or sets a docking option of the slider.
Public Property | Slider | Gets or sets the slider settings.
Top

See Also

Reference

PlayAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


DockingOption Property

[image]
ActiveReports 19 .NET Edition
DockingOption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlayAxis Class : DockingOption Property

Glossary Item Box

Gets or sets a docking option of the slider.

Syntax

Visual Basic (Declaration)
Public Property DockingOption As String
C#
public string DockingOption {get; set;}

Property Value

A System.String value indicating the docking option.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlayAxis Class
PlayAxis Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlayAxis Class : Slider Property

Glossary Item Box

Gets or sets the slider settings.

Syntax

Visual Basic (Declaration)
Public Property Slider As Slider
C#
public Slider Slider {get; set;}

Property Value

A Slider object representing the slider settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlayAxis Class
PlayAxis Members


PlotArea Class

[image]
ActiveReports 19 .NET Edition
PlotArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

Glossary Item Box

The PlotArea element defines properties for the plot area (for chart types with X and Y axes).

Object Model

PlotArea Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PlotArea
   Implements IValidateable
C#
public sealed class PlotArea : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PlotArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlotArea Members
GrapeCity.ActiveReports.PageReportModel Namespace


PlotArea Class Members

[image]
ActiveReports 19 .NET Edition
PlotArea Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

Glossary Item Box

The following tables list the members exposed by PlotArea.

Public Constructors

 | Name | Description
Public Constructor | PlotArea Constructor | Initializes a new instance of the PlotArea class.
Top

Public Properties

 | Name | Description
Public Property | SeriesLineStyle | Gets or sets the border style property for the plot area.
Public Property | Style | Gets or sets the border and background style properties for the plot area.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the PlotArea object.
Top

See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


PlotArea Constructor

[image]
ActiveReports 19 .NET Edition
PlotArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : PlotArea Constructor

Glossary Item Box

Initializes a new instance of the PlotArea class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PlotArea()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlotArea Class
PlotArea Members


PlotArea Class Methods

[image]
ActiveReports 19 .NET Edition
PlotArea Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

Glossary Item Box

For a list of all members of this type, see PlotArea members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the PlotArea object.
Top

See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : Validate Method

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the PlotArea object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlotArea Class
PlotArea Members


PlotArea Class Properties

[image]
ActiveReports 19 .NET Edition
PlotArea Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

Glossary Item Box

For a list of all members of this type, see PlotArea members.

Public Properties

 | Name | Description
Public Property | SeriesLineStyle | Gets or sets the border style property for the plot area.
Public Property | Style | Gets or sets the border and background style properties for the plot area.
Top

See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesLineStyle Property

[image]
ActiveReports 19 .NET Edition
SeriesLineStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : SeriesLineStyle Property

Glossary Item Box

Gets or sets the border style property for the plot area.

Syntax

Visual Basic (Declaration)
Public Property SeriesLineStyle As Style
C#
public Style SeriesLineStyle {get; set;}

Property Value

A Style object containing the border style property for the plot area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlotArea Class
PlotArea Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : Style Property

Glossary Item Box

Gets or sets the border and background style properties for the plot area.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the plot area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlotArea Class
PlotArea Members


Property Class

[image]
ActiveReports 19 .NET Edition
Property Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class

Glossary Item Box

Represents a property with a name and an associated value that can be evaluated.

Object Model

Property Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Property
C#
public sealed class Property

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Members
GrapeCity.ActiveReports.PageReportModel Namespace


Property Class Members

[image]
ActiveReports 19 .NET Edition
Property Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class

Glossary Item Box

The following tables list the members exposed by Property.

Public Constructors

 | Name | Description
Public Constructor | Property Constructor | Initializes a new instance of the Property class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the property.
Public Property | Value | Gets or sets the value of the property.
Top

See Also

Reference

Property Class
GrapeCity.ActiveReports.PageReportModel Namespace


Property Constructor

[image]
ActiveReports 19 .NET Edition
Property Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Property Constructor

name
A System.String value indicating the name to use for the property.
value
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value of the property.

Glossary Item Box

Initializes a new instance of the Property class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As ExpressionInfo _
)
C#
public Property(
   string name,
   ExpressionInfo value
)

Parameters

name
A System.String value indicating the name to use for the property.
value
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value of the property.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if name or value is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


Property Class Properties

[image]
ActiveReports 19 .NET Edition
Property Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class

Glossary Item Box

For a list of all members of this type, see Property members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the property.
Public Property | Value | Gets or sets the value of the property.
Top

See Also

Reference

Property Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Name Property

Glossary Item Box

Gets or sets the name of the property.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Value Property

Glossary Item Box

Gets or sets the value of the property.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Property Class
Property Members


PropertyCollection Class

[image]
ActiveReports 19 .NET Edition
PropertyCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class

Glossary Item Box

Represents a strongly typed collection of Property objects.

Object Model

PropertyCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PropertyCollection
   Inherits System.Collections.ObjectModel.Collection(Of Property)
C#
public sealed class PropertyCollection : System.Collections.ObjectModel.Collection<Property>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.PropertyCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


PropertyCollection Class Members

[image]
ActiveReports 19 .NET Edition
PropertyCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class

Glossary Item Box

The following tables list the members exposed by PropertyCollection.

Public Constructors

 | Name | Description
Public Constructor | PropertyCollection Constructor |
Top

See Also

Reference

PropertyCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


PropertyCollection Constructor

[image]
ActiveReports 19 .NET Edition
PropertyCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : PropertyCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PropertyCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyCollection Class
PropertyCollection Members


Query Class

[image]
ActiveReports 19 .NET Edition
Query Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

Glossary Item Box

Represents a Query element of a DataSet, containing the description of the query to be executed to retrieve data for the report.

Object Model

Query Class

Syntax

Visual Basic (Declaration)
Public Class Query
   Implements IValidateable
C#
public class Query : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Query

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Members
GrapeCity.ActiveReports.PageReportModel Namespace


Query Class Members

[image]
ActiveReports 19 .NET Edition
Query Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

Glossary Item Box

The following tables list the members exposed by Query.

Public Constructors

 | Name | Description
Public Constructor | Query Constructor | Initializes a new instance of the Query class.
Top

Public Properties

 | Name | Description
Public Property | CommandText | Gets or sets a query to execute for obtaining data for the report.
Public Property | CommandType | Gets or sets a type of query contained in the CommandText property.
Public Property | DataSourceName | Gets or sets a name of the data source against which the query will be executed.
Public Property | QueryParameters | Gets a list of parameters passed to the data source as part of the query.
Public Property | Timeout | Gets or sets the number of seconds allowed for the query to run before timing out.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Query object.
Top

See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


Query Constructor

[image]
ActiveReports 19 .NET Edition
Query Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Query Constructor

Glossary Item Box

Initializes a new instance of the Query class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Query()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


Query Class Methods

[image]
ActiveReports 19 .NET Edition
Query Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

Glossary Item Box

For a list of all members of this type, see Query members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Query object.
Top

See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Query object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


Query Class Properties

[image]
ActiveReports 19 .NET Edition
Query Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

Glossary Item Box

For a list of all members of this type, see Query members.

Public Properties

 | Name | Description
Public Property | CommandText | Gets or sets a query to execute for obtaining data for the report.
Public Property | CommandType | Gets or sets a type of query contained in the CommandText property.
Public Property | DataSourceName | Gets or sets a name of the data source against which the query will be executed.
Public Property | QueryParameters | Gets a list of parameters passed to the data source as part of the query.
Public Property | Timeout | Gets or sets the number of seconds allowed for the query to run before timing out.
Top

See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


CommandText Property

[image]
ActiveReports 19 .NET Edition
CommandText Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : CommandText Property

Glossary Item Box

Gets or sets a query to execute for obtaining data for the report.

Syntax

Visual Basic (Declaration)
Public Property CommandText As ExpressionInfo
C#
public ExpressionInfo CommandText {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the query text.

Example

C# Copy Code
Query query = new Query();
query.CommandText = "SELECT * FROM Users";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


CommandType Property

[image]
ActiveReports 19 .NET Edition
CommandType Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : CommandType Property

Glossary Item Box

Gets or sets a type of query contained in the CommandText property.

Syntax

Visual Basic (Declaration)
Public Property CommandType As QueryCommandType
C#
public QueryCommandType CommandType {get; set;}

Property Value

A QueryCommandType value indicating the type of query.

Example

C# Copy Code
Query query = new Query();
query.CommandType = QueryCommandType.Text;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


DataSourceName Property

[image]
ActiveReports 19 .NET Edition
DataSourceName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : DataSourceName Property

Glossary Item Box

Gets or sets a name of the data source against which the query will be executed.

Syntax

Visual Basic (Declaration)
Public Property DataSourceName As String
C#
public string DataSourceName {get; set;}

Property Value

A System.String value indicating the name of the data source.

Example

C# Copy Code
Query query = new Query();
query.DataSourceName = "MyDataSource";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


QueryParameters Property

[image]
ActiveReports 19 .NET Edition
QueryParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : QueryParameters Property

Glossary Item Box

Gets a list of parameters passed to the data source as part of the query.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryParameters As QueryParameterCollection
C#
public QueryParameterCollection QueryParameters {get;}

Property Value

A QueryParameterCollection object containing the query parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


Timeout Property

[image]
ActiveReports 19 .NET Edition
Timeout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Timeout Property

Glossary Item Box

Gets or sets the number of seconds allowed for the query to run before timing out.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Property Value

An System.Int32 value indicating the query timeout in seconds.

Remarks

The value must be non-negative.

If the value is zero or omitted, the query does not time out.

The maximum value is 2 147 483 647 seconds.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


QueryParameter Class

[image]
ActiveReports 19 .NET Edition
QueryParameter Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

Glossary Item Box

Represents a QueryParameter element of a Query, containing information about a parameter passed to the data source as part of the query.

Object Model

QueryParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class QueryParameter
   Implements IValidateable
C#
public sealed class QueryParameter : IValidateable

Remarks

Query parameters are used to dynamically filter data retrieved from the data source by passing user-provided or calculated values.

Example

C# Copy Code
QueryParameter queryParam = new QueryParameter { Name = "StartDate", Value = "=Parameters!StartDate.Value" };

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.QueryParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameter Class Members

[image]
ActiveReports 19 .NET Edition
QueryParameter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

Glossary Item Box

The following tables list the members exposed by QueryParameter.

Public Constructors

 | Name | Description
Public Constructor | QueryParameter Constructor | Initializes a new instance of the QueryParameter class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name for the parameter.
Public Property | Value | Gets or sets an expression that evaluates to the parameter value to pass to the data source.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the QueryParameter object.
Top

See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameter Constructor

[image]
ActiveReports 19 .NET Edition
QueryParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : QueryParameter Constructor

Glossary Item Box

Initializes a new instance of the QueryParameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public QueryParameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameter Class Methods

[image]
ActiveReports 19 .NET Edition
QueryParameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

Glossary Item Box

For a list of all members of this type, see QueryParameter members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the QueryParameter object.
Top

See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the QueryParameter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameter Class Properties

[image]
ActiveReports 19 .NET Edition
QueryParameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

Glossary Item Box

For a list of all members of this type, see QueryParameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name for the parameter.
Public Property | Value | Gets or sets an expression that evaluates to the parameter value to pass to the data source.
Top

See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Name Property

Glossary Item Box

Gets or sets a name for the parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name for the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameter Class
QueryParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Value Property

Glossary Item Box

Gets or sets an expression that evaluates to the parameter value to pass to the data source.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the value to pass to the data source.

Remarks

The expression can refer to report parameters but cannot contain references to report elements, fields in the data model, or aggregate functions.

In the case of a parameter for a DataValue query, the expression can only refer to report parameters that occur earlier in the parameters list. The value for this query parameter is then taken from the user selection for that earlier report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameterCollection Class

[image]
ActiveReports 19 .NET Edition
QueryParameterCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class

Glossary Item Box

Represents a strongly typed collection of QueryParameter objects.

Object Model

QueryParameterCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class QueryParameterCollection
   Inherits System.Collections.ObjectModel.Collection(Of QueryParameter)
C#
public sealed class QueryParameterCollection : System.Collections.ObjectModel.Collection<QueryParameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.QueryParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

QueryParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameterCollection Class Members

[image]
ActiveReports 19 .NET Edition
QueryParameterCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class

Glossary Item Box

The following tables list the members exposed by QueryParameterCollection.

See Also

Reference

QueryParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReferenceLine Class

[image]
ActiveReports 19 .NET Edition
ReferenceLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

Glossary Item Box

Defines the properties for the reference line in a chart.

Object Model

ReferenceLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReferenceLine
   Implements IValidateable
C#
public sealed class ReferenceLine : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReferenceLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReferenceLine Class Members

[image]
ActiveReports 19 .NET Edition
ReferenceLine Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

Glossary Item Box

The following tables list the members exposed by ReferenceLine.

Public Constructors

 | Name | Description
Public Constructor | ReferenceLine Constructor | Initializes a new instance of the ReferenceLine class.
Top

Public Properties

 | Name | Description
Public Property | LegendLabel | Gets or sets the string to insert in to the legend for the reference line.
Public Property | Style | Gets or sets the line style properties for the reference line.
Public Property | Value | Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ReferenceLine object.
Top

See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReferenceLine Constructor

[image]
ActiveReports 19 .NET Edition
ReferenceLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : ReferenceLine Constructor

Glossary Item Box

Initializes a new instance of the ReferenceLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReferenceLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Class
ReferenceLine Members


ReferenceLine Class Methods

[image]
ActiveReports 19 .NET Edition
ReferenceLine Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

Glossary Item Box

For a list of all members of this type, see ReferenceLine members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ReferenceLine object.
Top

See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Validate Method

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the ReferenceLine object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The GrapeCity.ActiveReports.PageReportModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Class
ReferenceLine Members


ReferenceLine Class Properties

[image]
ActiveReports 19 .NET Edition
ReferenceLine Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

Glossary Item Box

For a list of all members of this type, see ReferenceLine members.

Public Properties

 | Name | Description
Public Property | LegendLabel | Gets or sets the string to insert in to the legend for the reference line.
Public Property | Style | Gets or sets the line style properties for the reference line.
Public Property | Value | Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.
Top

See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


LegendLabel Property

[image]
ActiveReports 19 .NET Edition
LegendLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : LegendLabel Property

Glossary Item Box

Gets or sets the string to insert in to the legend for the reference line.

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Class
ReferenceLine Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Style Property

Glossary Item Box

Gets or sets the line style properties for the reference line.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the line style properties for the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Class
ReferenceLine Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Value Property

Glossary Item Box

Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReferenceLine Class
ReferenceLine Members


Report Class

[image]
ActiveReports 19 .NET Edition
Report Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

Glossary Item Box

Represents a report definition which is the top-level element containing property, data and layout information.

Object Model

Report Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Report
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Report : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.Report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Members
GrapeCity.ActiveReports.PageReportModel Namespace


Report Class Members

[image]
ActiveReports 19 .NET Edition
Report Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

Glossary Item Box

The following tables list the members exposed by Report.

Public Constructors

 | Name | Description
Public Constructor | Report Constructor | Initializes a new instance of the Report class.
Top

Public Properties

Name | Description
Public Property | Author | Gets or sets a author of the report.
Public Property AutoRefresh

Caution: This property is not yet implemented. Please ignore.

Public Property | Body | Gets or sets a body layout information for the report.
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | Classes | Gets a collection of the code classes to instantiate during report initialization.
Public Property | Code | Gets or sets a string of code available to the report for use as a custom functions.
Public Property | CodeModules | Gets a collection of the code modules that available to the report for use in expressions.
Public Property | CollateBy | Gets or sets the collation setting for the report when using a theme.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeContainerWhitespace | Gets or sets a value indicating whether all white space in containers (such as Body and Container) will be consumed during report rendering as the container's contents grow, rather than preserving the minimum amount of white space between the contents and the container's bounds.
Public Property | Custom | Gets or sets a custom information to be passed to the report engine.
Public Property | CustomProperties | Gets the custom properties of the report.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the report data.
Public Property | DataElementStyle | Gets or sets a style in which textboxes are rendered in an exported report (as elements or attributes).
Public Property | DataSchema | Gets or sets a schema or namespace used for an exported report.
Public Property | DataSets | Gets the data sets displayed in the report.
Public Property | DataSources | Gets a collection of data sources from which data sets are taken for the report.
Public Property | DataTransform | Gets or sets the file path and name of the transformation file applied to exported reports.
Public Property | Description | Gets or sets a description of the report.
Public Property | DocumentMap | Gets the report document map options.
Public Property | EmbeddedImages | Gets a collection of the images embedded in the report.
Public Property | EmbeddedStyleSheets | Gets a collection of the stylesheets embedded in the report.
Public Property | InteractiveHeight | Gets or sets the default report height when the report is rendered in interactive mode.
Public Property | InteractiveWidth | Gets or sets the default report width when the report is rendered in interactive mode.
Public Property | IsFixedPageReport | Gets a value indicating whether the report is a fixed page report.
Public Property | IsMaster | Gets or sets a value indicating whether the current report is a master report.
Public Property | IsMerged | Gets or sets a value indicating whether the report has been merged with the master report.
Public Property | Language | Gets or sets the primary language of the text localization.
Public Property | Layers | Gets a collection of layers within the report.
Public Property | LayoutOrder | Gets or sets an order layout of the report pages ('Z' or 'N').
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | Libraries | Gets or sets a collection of references to libraries with the report parts.
Public Property | LocalizationResources | Gets the collection of localization resources for the report.
Public Property | MasterReport | Gets or sets an URI for the master report, if any.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageFooter | Gets or sets a footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets a height of the pages in the report.
Public Property | PageWidth | Gets or sets a width of the pages in the report.
Public Property | PaperOrientation | Gets or sets an orientation of the report pages for printing.
Public Property | Parent | Overridden. Gets or sets a parent container.
Public Property | ReportParameters | Gets a collection of parameters for a report.
Public Property | ReportParts | Gets or sets a collection of exported report parts.
Public Property | ReportSections | Gets or sets the collection of report sections.
Public Property | ReportSlicers | Gets a collection of slicers for a report.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | StartPageNumber | Gets or sets the starting page number for numbering within a report.
Public Property | StyleSheetSource | Gets or sets a source of the report stylesheet.
Public Property | StyleSheetValue | Gets or sets a value of the report stylesheet.
Public Property | Themes | Gets the all themes associated with the report.
Public Property | ThemeUri | Gets or sets an URI for the current attached theme.
Public Property | TopMargin | Gets or sets a height of the top margin.
Public Property | ViewerType | Gets the type of viewer available for a report.
Public Property | Width | Gets or sets a width of the report.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Report object.
Top

See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Report Constructor

[image]
ActiveReports 19 .NET Edition
Report Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Report Constructor

Glossary Item Box

Initializes a new instance of the Report class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Report()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Report Class Methods

[image]
ActiveReports 19 .NET Edition
Report Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

Glossary Item Box

For a list of all members of this type, see Report members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Report object.
Top

See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Report object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Report Class Properties

[image]
ActiveReports 19 .NET Edition
Report Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

Glossary Item Box

For a list of all members of this type, see Report members.

Public Properties

Name | Description
Public Property | Author | Gets or sets a author of the report.
Public Property AutoRefresh

Caution: This property is not yet implemented. Please ignore.

Public Property | Body | Gets or sets a body layout information for the report.
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | Classes | Gets a collection of the code classes to instantiate during report initialization.
Public Property | Code | Gets or sets a string of code available to the report for use as a custom functions.
Public Property | CodeModules | Gets a collection of the code modules that available to the report for use in expressions.
Public Property | CollateBy | Gets or sets the collation setting for the report when using a theme.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | ConsumeContainerWhitespace | Gets or sets a value indicating whether all white space in containers (such as Body and Container) will be consumed during report rendering as the container's contents grow, rather than preserving the minimum amount of white space between the contents and the container's bounds.
Public Property | Custom | Gets or sets a custom information to be passed to the report engine.
Public Property | CustomProperties | Gets the custom properties of the report.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the report data.
Public Property | DataElementStyle | Gets or sets a style in which textboxes are rendered in an exported report (as elements or attributes).
Public Property | DataSchema | Gets or sets a schema or namespace used for an exported report.
Public Property | DataSets | Gets the data sets displayed in the report.
Public Property | DataSources | Gets a collection of data sources from which data sets are taken for the report.
Public Property | DataTransform | Gets or sets the file path and name of the transformation file applied to exported reports.
Public Property | Description | Gets or sets a description of the report.
Public Property | DocumentMap | Gets the report document map options.
Public Property | EmbeddedImages | Gets a collection of the images embedded in the report.
Public Property | EmbeddedStyleSheets | Gets a collection of the stylesheets embedded in the report.
Public Property | InteractiveHeight | Gets or sets the default report height when the report is rendered in interactive mode.
Public Property | InteractiveWidth | Gets or sets the default report width when the report is rendered in interactive mode.
Public Property | IsFixedPageReport | Gets a value indicating whether the report is a fixed page report.
Public Property | IsMaster | Gets or sets a value indicating whether the current report is a master report.
Public Property | IsMerged | Gets or sets a value indicating whether the report has been merged with the master report.
Public Property | Language | Gets or sets the primary language of the text localization.
Public Property | Layers | Gets a collection of layers within the report.
Public Property | LayoutOrder | Gets or sets an order layout of the report pages ('Z' or 'N').
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | Libraries | Gets or sets a collection of references to libraries with the report parts.
Public Property | LocalizationResources | Gets the collection of localization resources for the report.
Public Property | MasterReport | Gets or sets an URI for the master report, if any.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageFooter | Gets or sets a footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets a height of the pages in the report.
Public Property | PageWidth | Gets or sets a width of the pages in the report.
Public Property | PaperOrientation | Gets or sets an orientation of the report pages for printing.
Public Property | Parent | Overridden. Gets or sets a parent container.
Public Property | ReportParameters | Gets a collection of parameters for a report.
Public Property | ReportParts | Gets or sets a collection of exported report parts.
Public Property | ReportSections | Gets or sets the collection of report sections.
Public Property | ReportSlicers | Gets a collection of slicers for a report.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | StartPageNumber | Gets or sets the starting page number for numbering within a report.
Public Property | StyleSheetSource | Gets or sets a source of the report stylesheet.
Public Property | StyleSheetValue | Gets or sets a value of the report stylesheet.
Public Property | Themes | Gets the all themes associated with the report.
Public Property | ThemeUri | Gets or sets an URI for the current attached theme.
Public Property | TopMargin | Gets or sets a height of the top margin.
Public Property | ViewerType | Gets the type of viewer available for a report.
Public Property | Width | Gets or sets a width of the report.
Top

See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Author Property

[image]
ActiveReports 19 .NET Edition
Author Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Author Property

Glossary Item Box

Gets or sets a author of the report.

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author {get; set;}

Property Value

A System.String value indicating the author of the report.

Example

C# Copy Code
Report report = new Report();
report.Author = "Your Author";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


AutoRefresh Property

[image]
ActiveReports 19 .NET Edition
AutoRefresh Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : AutoRefresh Property

Glossary Item Box

Caution: This property is not yet implemented. Please ignore.

Syntax

Visual Basic (Declaration)
Public Property AutoRefresh As Integer
C#
public int AutoRefresh {get; set;}

Property Value

An System.Int32 value indicating the period of the report page automatic refreshing.

Remarks

Example

C# Copy Code
Report report = new Report();
report.AutoRefresh = 60; // Refresh every 60 seconds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Body Property

Glossary Item Box

Gets or sets a body layout information for the report.

Syntax

Visual Basic (Declaration)
Public Property Body As Body
C#
public Body Body {get; set;}

Property Value

A Body object representing the body layout details of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : BottomMargin Property

Glossary Item Box

Gets or sets a height of the bottom margin.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As Length
C#
public Length BottomMargin {get; set;}

Property Value

A Length value indicating the height of the bottom margin. Default value is 0in.

Example

C# Copy Code
Report report = new Report();
report.BottomMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Classes Property

[image]
ActiveReports 19 .NET Edition
Classes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Classes Property

Glossary Item Box

Gets a collection of the code classes to instantiate during report initialization.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Classes As CodeClassCollection
C#
public CodeClassCollection Classes {get;}

Property Value

A CodeClassCollection object containing the code classes associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Code Property

[image]
ActiveReports 19 .NET Edition
Code Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Code Property

Glossary Item Box

Gets or sets a string of code available to the report for use as a custom functions.

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code {get; set;}

Property Value

A System.String value containing the custom functions.

Remarks

The custom functions contained in the string must be instance methods written in Visual Basic.NET syntax.

See the "Custom Code" topic in the User Guide for more information.

Example

C# Copy Code
Report report = new Report();
report.Code = "Public Function CustomFunction() As String Return \"Hello\" End Function";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


CodeModules Property

[image]
ActiveReports 19 .NET Edition
CodeModules Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CodeModules Property

Glossary Item Box

Gets a collection of the code modules that available to the report for use in expressions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeModules As StringCollection
C#
public StringCollection CodeModules {get;}

Property Value

A System.Collections.Specialized.StringCollection object containing the code modules associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


CollateBy Property

[image]
ActiveReports 19 .NET Edition
CollateBy Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CollateBy Property

Glossary Item Box

Gets or sets the collation setting for the report when using a theme.

Syntax

Visual Basic (Declaration)
Public Property CollateBy As CollateBy
C#
public CollateBy CollateBy {get; set;}

Property Value

A CollateBy value indicating the collation setting for the report.

Remarks

This property is specifically used for FPL reports only.

Example

C# Copy Code
Report report = new Report();
report.CollateBy = CollateBy.Simple;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ConsumeContainerWhitespace Property

[image]
ActiveReports 19 .NET Edition
ConsumeContainerWhitespace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ConsumeContainerWhitespace Property

Glossary Item Box

Gets or sets a value indicating whether all white space in containers (such as Body and Container) will be consumed during report rendering as the container's contents grow, rather than preserving the minimum amount of white space between the contents and the container's bounds.

Syntax

Visual Basic (Declaration)
Public Property ConsumeContainerWhitespace As Boolean
C#
public bool ConsumeContainerWhitespace {get; set;}

Property Value

A System.Boolean value indicating whether all white space in containers is consumed during report rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Custom Property

[image]
ActiveReports 19 .NET Edition
Custom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Custom Property

Glossary Item Box

Gets or sets a custom information to be passed to the report engine.

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Property Value

A Custom object containing custom information to be passed to the report engine.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CustomProperties Property

Glossary Item Box

Gets the custom properties of the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection object containing custom properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the report data.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for report data.

Remarks

Default value is "Report".

Example

C# Copy Code
Report report = new Report();
report.DataElementName = "MyReport";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataElementStyle Property

[image]
ActiveReports 19 .NET Edition
DataElementStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataElementStyle Property

Glossary Item Box

Gets or sets a style in which textboxes are rendered in an exported report (as elements or attributes).

Syntax

Visual Basic (Declaration)
Public Property DataElementStyle As DataElementStyle
C#
public DataElementStyle DataElementStyle {get; set;}

Property Value

A DataElementStyle value indicating how textboxes are rendered.

Example

C# Copy Code
Report report = new Report();
report.DataElementStyle = DataElementStyle.AttributeNormal;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataSchema Property

[image]
ActiveReports 19 .NET Edition
DataSchema Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSchema Property

Glossary Item Box

Gets or sets a schema or namespace used for an exported report.

Syntax

Visual Basic (Declaration)
Public Property DataSchema As String
C#
public string DataSchema {get; set;}

Property Value

A System.String value indicating the schema or namespace for an exported report.

Example

C# Copy Code
Report report = new Report();
report.DataSchema = "http://schemas.example.com/reports";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataSets Property

[image]
ActiveReports 19 .NET Edition
DataSets Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSets Property

Glossary Item Box

Gets the data sets displayed in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSets As DataSetCollection
C#
public DataSetCollection DataSets {get;}

Property Value

A DataSetCollection object containing the data sets of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataSources Property

[image]
ActiveReports 19 .NET Edition
DataSources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSources Property

Glossary Item Box

Gets a collection of data sources from which data sets are taken for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSources As DataSourceCollection
C#
public DataSourceCollection DataSources {get;}

Property Value

A DataSourceCollection object containing the data sources from which data sets are taken for the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DataTransform Property

[image]
ActiveReports 19 .NET Edition
DataTransform Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataTransform Property

Glossary Item Box

Gets or sets the file path and name of the transformation file applied to exported reports.

Syntax

Visual Basic (Declaration)
Public Property DataTransform As String
C#
public string DataTransform {get; set;}

Property Value

A System.String value indicating the file path and name of the transformation file.

Remarks

The file path can be a full path (e.g. "/xsl/xfrm.xsl"), or a relative path (e.g. "xfrm.xsl").

Example

C# Copy Code
Report report = new Report();
report.DataTransform = "/xsl/transform.xsl";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Description Property

Glossary Item Box

Gets or sets a description of the report.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Property Value

A System.String value containing the description of the report.

Example

C# Copy Code
Report report = new Report();
report.Description = "Your favorite report.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


DocumentMap Property

[image]
ActiveReports 19 .NET Edition
DocumentMap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DocumentMap Property

Glossary Item Box

Gets the report document map options.

Syntax

Visual Basic (Declaration)
Public Property DocumentMap As DocumentMap
C#
public DocumentMap DocumentMap {get; set;}

Property Value

A DocumentMap object representing the document map settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


EmbeddedImages Property

[image]
ActiveReports 19 .NET Edition
EmbeddedImages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : EmbeddedImages Property

Glossary Item Box

Gets a collection of the images embedded in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EmbeddedImages As EmbeddedImageCollection
C#
public EmbeddedImageCollection EmbeddedImages {get;}

Property Value

An EmbeddedImageCollection object containing images embedded associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


EmbeddedStyleSheets Property

[image]
ActiveReports 19 .NET Edition
EmbeddedStyleSheets Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : EmbeddedStyleSheets Property

Glossary Item Box

Gets a collection of the stylesheets embedded in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EmbeddedStyleSheets As List(Of EmbeddedStyleSheet)
C#
public List<EmbeddedStyleSheet> EmbeddedStyleSheets {get;}

Property Value

A collection of the EmbeddedStyleSheet objects containing stylesheets embedded associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


InteractiveHeight Property

[image]
ActiveReports 19 .NET Edition
InteractiveHeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : InteractiveHeight Property

Glossary Item Box

Gets or sets the default report height when the report is rendered in interactive mode.

Syntax

Visual Basic (Declaration)
Public Property InteractiveHeight As Length
C#
public Length InteractiveHeight {get; set;}

Property Value

A Length value indicating the default report height when the report is rendered in interactive mode.

Remarks

Using a length of 0 with any unit indicates that the height should be treated as unlimited.

Default value is PageHeight.

Example

C# Copy Code
Report report = new Report();
report.InteractiveHeight = "12in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


InteractiveWidth Property

[image]
ActiveReports 19 .NET Edition
InteractiveWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : InteractiveWidth Property

Glossary Item Box

Gets or sets the default report width when the report is rendered in interactive mode.

Syntax

Visual Basic (Declaration)
Public Property InteractiveWidth As Length
C#
public Length InteractiveWidth {get; set;}

Property Value

A Length value indicating the default report width when the report is rendered in interactive mode.

Remarks

Using a length of 0 with any unit indicates that the width should be treated as unlimited.

Default value is PageWidth.

Example

C# Copy Code
Report report = new Report();
report.InteractiveWidth = "9.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


IsFixedPageReport Property

[image]
ActiveReports 19 .NET Edition
IsFixedPageReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : IsFixedPageReport Property

Glossary Item Box

Gets a value indicating whether the report is a fixed page report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedPageReport As Boolean
C#
public bool IsFixedPageReport {get;}

Property Value

A System.Boolean value where true if the report is a fixed page report; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


IsMaster Property

[image]
ActiveReports 19 .NET Edition
IsMaster Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : IsMaster Property

Glossary Item Box

Gets or sets a value indicating whether the current report is a master report.

Syntax

Visual Basic (Declaration)
Public Property IsMaster As Boolean
C#
public bool IsMaster {get; set;}

Property Value

A System.Boolean value indicating whether the current report is a master report.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


IsMerged Property

[image]
ActiveReports 19 .NET Edition
IsMerged Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : IsMerged Property

Glossary Item Box

Gets or sets a value indicating whether the report has been merged with the master report.

Syntax

Visual Basic (Declaration)
Public Property IsMerged As Boolean
C#
public bool IsMerged {get; set;}

Property Value

A System.Boolean value where true if the report is merged with the master report; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Language Property

Glossary Item Box

Gets or sets the primary language of the text localization.

Syntax

Visual Basic (Declaration)
Public Property Language As ExpressionInfo
C#
public ExpressionInfo Language {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a language value which complies with the Internet Engineering Task Force (IETF) RFC1766 specification.

Remarks

The default value is the server language.

Example

C# Copy Code
Report report = new Report();
report.Language = ExpressionInfo.FromString("en-US");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Layers Property

[image]
ActiveReports 19 .NET Edition
Layers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Layers Property

Glossary Item Box

Gets a collection of layers within the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As LayerCollection
C#
public LayerCollection Layers {get;}

Property Value

A LayerCollection object representing a collection of layers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


LayoutOrder Property

[image]
ActiveReports 19 .NET Edition
LayoutOrder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : LayoutOrder Property

Glossary Item Box

Gets or sets an order layout of the report pages ('Z' or 'N').

Syntax

Visual Basic (Declaration)
Public Property LayoutOrder As PagesLayoutOrder
C#
public PagesLayoutOrder LayoutOrder {get; set;}

Property Value

A PagesLayoutOrder value indicating the layout order of the pages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : LeftMargin Property

Glossary Item Box

Gets or sets a width of the left margin.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As Length
C#
public Length LeftMargin {get; set;}

Property Value

A Length value indicating the width of the left margin. Default value is 0in.

Example

C# Copy Code
Report report = new Report();
report.LeftMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Libraries Property

[image]
ActiveReports 19 .NET Edition
Libraries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Libraries Property

Glossary Item Box

Gets or sets a collection of references to libraries with the report parts.

Syntax

Visual Basic (Declaration)
Public Property Libraries As LibrariesCollection
C#
public LibrariesCollection Libraries {get; set;}

Property Value

A LibrariesCollection object representing the collection of the libraries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


LocalizationResources Property

[image]
ActiveReports 19 .NET Edition
LocalizationResources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : LocalizationResources Property

Glossary Item Box

Gets the collection of localization resources for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocalizationResources As LocalizationResourceCollection
C#
public LocalizationResourceCollection LocalizationResources {get;}

Property Value

A LocalizationResourceCollection object containing localization resources associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


MasterReport Property

[image]
ActiveReports 19 .NET Edition
MasterReport Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : MasterReport Property

Glossary Item Box

Gets or sets an URI for the master report, if any.

Syntax

Visual Basic (Declaration)
Public Property MasterReport As String
C#
public string MasterReport {get; set;}

Property Value

A System.String value indicating the URI for the master report.

Example

C# Copy Code
Report report = new Report();
report.MasterReport = "ExampleMasterReport.rdlx-master";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Name Property

Glossary Item Box

Gets or sets the name of the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the report.

Example

C# Copy Code
Report report = new Report();
report.Name = "YourNewReport";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


PageFooter Property

[image]
ActiveReports 19 .NET Edition
PageFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageFooter Property

Glossary Item Box

Gets or sets a footer object that is output at the bottom of each report page.

Syntax

Visual Basic (Declaration)
Public Property PageFooter As PageHeaderFooter
C#
public PageHeaderFooter PageFooter {get; set;}

Property Value

A PageHeaderFooter object representing the footer layout of each report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


PageHeader Property

[image]
ActiveReports 19 .NET Edition
PageHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageHeader Property

Glossary Item Box

Gets or sets the header object that is output at the top of each report page.

Syntax

Visual Basic (Declaration)
Public Property PageHeader As PageHeaderFooter
C#
public PageHeaderFooter PageHeader {get; set;}

Property Value

A PageHeaderFooter object representing the header layout of each report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


PageHeight Property

[image]
ActiveReports 19 .NET Edition
PageHeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageHeight Property

Glossary Item Box

Gets or sets a height of the pages in the report.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As Length
C#
public Length PageHeight {get; set;}

Property Value

A Length value indicating the height of the pages in the report. Default value is 11in.

Example

C# Copy Code
Report report = new Report();
report.PageHeight = "11in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


PageWidth Property

[image]
ActiveReports 19 .NET Edition
PageWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageWidth Property

Glossary Item Box

Gets or sets a width of the pages in the report.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As Length
C#
public Length PageWidth {get; set;}

Property Value

A Length value indicating the width of the pages in the report. Default value is 8.5in.

Example

C# Copy Code
Report report = new Report();
report.PageWidth = "8.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


PaperOrientation Property

[image]
ActiveReports 19 .NET Edition
PaperOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PaperOrientation Property

Glossary Item Box

Gets or sets an orientation of the report pages for printing.

Syntax

Visual Basic (Declaration)
Public Property PaperOrientation As PaperOrientation
C#
public PaperOrientation PaperOrientation {get; set;}

Property Value

A PaperOrientation value indicating the page orientation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Parent Property

Glossary Item Box

Gets or sets a parent container.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Parent As IReportComponentContainer
C#
public override IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer object representing the parent container.

Remarks

The Report does not not use this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ReportParameters Property

[image]
ActiveReports 19 .NET Edition
ReportParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ReportParameters Property

Glossary Item Box

Gets a collection of parameters for a report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportParameters As ReportParameterCollection
C#
public ReportParameterCollection ReportParameters {get;}

Property Value

A ReportParameterCollection object containing the parameters for a report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ReportParts Property

[image]
ActiveReports 19 .NET Edition
ReportParts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ReportParts Property

Glossary Item Box

Gets or sets a collection of exported report parts.

Syntax

Visual Basic (Declaration)
Public Property ReportParts As ReportPartsCollection
C#
public ReportPartsCollection ReportParts {get; set;}

Property Value

A ReportPartsCollection ovject representing the collection of report parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ReportSections Property

[image]
ActiveReports 19 .NET Edition
ReportSections Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ReportSections Property

Glossary Item Box

Gets or sets the collection of report sections.

Syntax

Visual Basic (Declaration)
Public Property ReportSections As ReportSectionsCollection
C#
public ReportSectionsCollection ReportSections {get; set;}

Property Value

An object representing the ReportSectionsCollection containing the report sections of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ReportSlicers Property

[image]
ActiveReports 19 .NET Edition
ReportSlicers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ReportSlicers Property

Glossary Item Box

Gets a collection of slicers for a report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportSlicers As ReportSlicersCollection
C#
public ReportSlicersCollection ReportSlicers {get;}

Property Value

A ReportSlicersCollection object containing the slicers for a report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : RightMargin Property

Glossary Item Box

Gets or sets a width of the right margin.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As Length
C#
public Length RightMargin {get; set;}

Property Value

A Length value indicating the width of the right margin. Default value is 0in.

Example

C# Copy Code
Report report = new Report();
report.RightMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


StartPageNumber Property

[image]
ActiveReports 19 .NET Edition
StartPageNumber Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StartPageNumber Property

Glossary Item Box

Gets or sets the starting page number for numbering within a report.

Syntax

Visual Basic (Declaration)
Public Property StartPageNumber As Integer
C#
public int StartPageNumber {get; set;}

Property Value

An System.Int32 value indicating the starting page number.

Example

C# Copy Code
Report report = new Report();
report.StartPageNumber = 1;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


StyleSheetSource Property

[image]
ActiveReports 19 .NET Edition
StyleSheetSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StyleSheetSource Property

Glossary Item Box

Gets or sets a source of the report stylesheet.

Syntax

Visual Basic (Declaration)
Public Property StyleSheetSource As StyleSheetSource
C#
public StyleSheetSource StyleSheetSource {get; set;}

Property Value

A StyleSheetSource value indicating the source of the report stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


StyleSheetValue Property

[image]
ActiveReports 19 .NET Edition
StyleSheetValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StyleSheetValue Property

Glossary Item Box

Gets or sets a value of the report stylesheet.

Syntax

Visual Basic (Declaration)
Public Property StyleSheetValue As ExpressionInfo
C#
public ExpressionInfo StyleSheetValue {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the value of the report stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Themes Property

Glossary Item Box

Gets the all themes associated with the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Themes As ExpressionInfoCollection
C#
public ExpressionInfoCollection Themes {get;}

Property Value

A Collection object containing the themes URIs associated with the report.

Example

or using an expression
C# Copy Code
Report.Themes.Add("path/to/your/theme.rdlx-theme");
C# Copy Code
Report.Themes.Add("=IIF(Parameters!Theme.Value = \"Black\", \"black.rdlx-theme\",\"white.rdlx-theme\")");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ThemeUri Property

[image]
ActiveReports 19 .NET Edition
ThemeUri Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ThemeUri Property

Glossary Item Box

Gets or sets an URI for the current attached theme.

Syntax

Visual Basic (Declaration)
Public Property ThemeUri As ExpressionInfo
C#
public ExpressionInfo ThemeUri {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object indicating the URI for the current attached theme.

Example

C# Copy Code
Report.ThemeUri = "path/to/your/theme.rdlx-theme";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : TopMargin Property

Glossary Item Box

Gets or sets a height of the top margin.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As Length
C#
public Length TopMargin {get; set;}

Property Value

A Length value indicating the height of the top margin. Default value is 0in.

Example

C# Copy Code
Report report = new Report();
report.TopMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ViewerType Property

[image]
ActiveReports 19 .NET Edition
ViewerType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ViewerType Property

Glossary Item Box

Gets the type of viewer available for a report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ViewerType As ViewerType
C#
public ViewerType ViewerType {get;}

Property Value

A ViewerType value indicating the type of viewer for s report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Width Property

Glossary Item Box

Gets or sets a width of the report.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the report.

Example

C# Copy Code
Report report = new Report();
report.Width = "8.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Report Class
Report Members


ReportComponent Class

[image]
ActiveReports 19 .NET Edition
ReportComponent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

Glossary Item Box

Represents a base class for a report component within a report.

Object Model

ReportComponent Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportComponent
   Inherits System.ComponentModel.Component
   Implements IReportComponent
C#
public abstract class ReportComponent : System.ComponentModel.Component, IReportComponent

Remarks

This abstract class defines the core properties and behaviors for all report components.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.BandedListGroup
GrapeCity.ActiveReports.PageReportModel.CategoryGrouping
GrapeCity.ActiveReports.PageReportModel.ColumnGrouping
GrapeCity.ActiveReports.PageReportModel.Details
GrapeCity.ActiveReports.PageReportModel.Grid
GrapeCity.ActiveReports.PageReportModel.GridCell
GrapeCity.ActiveReports.PageReportModel.GridColumn
GrapeCity.ActiveReports.PageReportModel.GridRow
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.MatrixRow
GrapeCity.ActiveReports.PageReportModel.Report
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.ReportSection
GrapeCity.ActiveReports.PageReportModel.ReportSectionPage
GrapeCity.ActiveReports.PageReportModel.RowGrouping
GrapeCity.ActiveReports.PageReportModel.SeriesGrouping
GrapeCity.ActiveReports.PageReportModel.TableGroup
GrapeCity.ActiveReports.PageReportModel.TableRow
GrapeCity.ActiveReports.PageReportModel.TablixBody
GrapeCity.ActiveReports.PageReportModel.TablixCell
GrapeCity.ActiveReports.PageReportModel.TablixCorner
GrapeCity.ActiveReports.PageReportModel.TablixCornerCell
GrapeCity.ActiveReports.PageReportModel.TablixCornerRow
GrapeCity.ActiveReports.PageReportModel.TablixHeader
GrapeCity.ActiveReports.PageReportModel.TablixHierarchy
GrapeCity.ActiveReports.PageReportModel.TablixMember
GrapeCity.ActiveReports.PageReportModel.TablixRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponent Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Members

[image]
ActiveReports 19 .NET Edition
ReportComponent Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

Glossary Item Box

The following tables list the members exposed by ReportComponent.

Public Properties

 | Name | Description
Public Property | Parent | Gets or sets the parent container that hosts the report component.
Top

See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Properties

[image]
ActiveReports 19 .NET Edition
ReportComponent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

Glossary Item Box

For a list of all members of this type, see ReportComponent members.

Public Properties

 | Name | Description
Public Property | Parent | Gets or sets the parent container that hosts the report component.
Top

See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Parent Property

Glossary Item Box

Gets or sets the parent container that hosts the report component.

Syntax

Visual Basic (Declaration)
Public Overridable Property Parent As IReportComponentContainer
C#
public virtual IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer object representing the parent container that hosts the report component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponent Class
ReportComponent Members


ReportComponentCollection Class

[image]
ActiveReports 19 .NET Edition
ReportComponentCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

Glossary Item Box

Represents a collection of IReportComponent objects.

Object Model

ReportComponentCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportComponentCollection
C#
public sealed class ReportComponentCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportComponentCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportComponentCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

Glossary Item Box

The following tables list the members exposed by ReportComponentCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportComponentCollection Constructor | Initializes a new instance of the ReportComponentCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Copies the elements of the collection to an System.Array, starting at a particular array index.
Top

See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportComponentCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : ReportComponentCollection Constructor

components
An array of the IReportComponent objects to add to the collection.

Glossary Item Box

Initializes a new instance of the ReportComponentCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal components() As IReportComponent _
)
C#
public ReportComponentCollection(
   IReportComponent[] components
)

Parameters

components
An array of the IReportComponent objects to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ReportComponentCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

Glossary Item Box

For a list of all members of this type, see ReportComponentCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo | Copies the elements of the collection to an System.Array, starting at a particular array index.
Top

See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from the collection.
index
An System.Int32 value indicating the zero-based index in the array at which copying begins.

Glossary Item Box

Copies the elements of the collection to an System.Array, starting at a particular array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from the collection.
index
An System.Int32 value indicating the zero-based index in the array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if array is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ReportComponentCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

Glossary Item Box

For a list of all members of this type, see ReportComponentCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An System.Int32 value indicating the number of IReportComponent objects in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the collection is synchronized (thread-safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

A System.Boolean value. true if access to the collection is synchronized (thread-safe); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

An System.Object that can be used to synchronize access to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentContainer Class

[image]
ActiveReports 19 .NET Edition
ReportComponentContainer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

Glossary Item Box

Represents a container for ReportComponent objects, capable of holding and managing multiple ReportItem objects.

Object Model

ReportComponentContainer Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportComponentContainer
   Inherits ReportComponent
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
C#
public abstract class ReportComponentContainer : ReportComponent, IRdlContainer, IReportComponent, IReportComponentContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Body
GrapeCity.ActiveReports.PageReportModel.Corner
GrapeCity.ActiveReports.PageReportModel.DataCell
GrapeCity.ActiveReports.PageReportModel.DynamicColumnsRows
GrapeCity.ActiveReports.PageReportModel.MatrixCell
GrapeCity.ActiveReports.PageReportModel.Page
GrapeCity.ActiveReports.PageReportModel.PageHeaderFooter
GrapeCity.ActiveReports.PageReportModel.StaticRowColumn
GrapeCity.ActiveReports.PageReportModel.Subtotal
GrapeCity.ActiveReports.PageReportModel.TableCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Members

[image]
ActiveReports 19 .NET Edition
ReportComponentContainer Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

Glossary Item Box

The following tables list the members exposed by ReportComponentContainer.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponents in the container.
Public Property | ReportItems | Gets a ReportItemCollection containing all the ReportItems in the container.
Top

Public Methods

 | Name | Description
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Top

See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Methods

[image]
ActiveReports 19 .NET Edition
ReportComponentContainer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

Glossary Item Box

For a list of all members of this type, see ReportComponentContainer members.

Public Methods

 | Name | Description
Public Method | SortReportItems | Sorts the report items to improve rendering performance.
Top

See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortReportItems Method

[image]
ActiveReports 19 .NET Edition
SortReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : SortReportItems Method

Glossary Item Box

Sorts the report items to improve rendering performance.

Syntax

Visual Basic (Declaration)
Public Sub SortReportItems()
C#
public void SortReportItems()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ReportComponentContainer Class Properties

[image]
ActiveReports 19 .NET Edition
ReportComponentContainer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

Glossary Item Box

For a list of all members of this type, see ReportComponentContainer members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponents in the container.
Public Property | ReportItems | Gets a ReportItemCollection containing all the ReportItems in the container.
Top

See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponents in the container.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Components As ReportComponentCollection
C#
public virtual ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : ReportItems Property

Glossary Item Box

Gets a ReportItemCollection containing all the ReportItems in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItems As ReportItemCollection
C#
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection object containing all the ReportItem objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ReportDefinitionException Class

[image]
ActiveReports 19 .NET Edition
ReportDefinitionException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportDefinitionException Class

Glossary Item Box

Represents an exception about report definition errors.

Object Model

ReportDefinitionException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportDefinitionException
   Inherits System.Exception
C#
public sealed class ReportDefinitionException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDefinitionException Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportDefinitionException Class Members

[image]
ActiveReports 19 .NET Edition
ReportDefinitionException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportDefinitionException Class

Glossary Item Box

The following tables list the members exposed by ReportDefinitionException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

See Also

Reference

ReportDefinitionException Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportDefinitionException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDefinitionException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportDefinitionException Class

Glossary Item Box

For a list of all members of this type, see ReportDefinitionException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

See Also

Reference

ReportDefinitionException Class
GrapeCity.ActiveReports.PageReportModel Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportDefinitionException Class : ErrorCode Property

Glossary Item Box

Gets the error code associated with this exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As ReportDefinitionException.ErrorCodes
C#
public ReportDefinitionException.ErrorCodes ErrorCode {get;}

Property Value

An ReportDefinitionException.ErrorCodes value indicating the specific type of report definition error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDefinitionException Class
ReportDefinitionException Members


ReportItem Class

[image]
ActiveReports 19 .NET Edition
ReportItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

Glossary Item Box

Represents a report item within a report, which can be one of several types of objects: Line, Shape, TextBox, Image, Subreport, CustomReportItem, or DataRegion. DataRegions include List, Table, Matrix, Tablix, and Chart. This base class is not used directly; specific report item types are used instead.

Object Model

ReportItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItem
   Inherits ReportComponent
   Implements IReportComponent, IValidateable
C#
public abstract class ReportItem : ReportComponent, IReportComponent, IValidateable

Remarks

This class provides common properties shared among all report item types. However, not all properties are relevant to every type of report item.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Band
GrapeCity.ActiveReports.PageReportModel.BandedList
GrapeCity.ActiveReports.PageReportModel.CustomReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Image
GrapeCity.ActiveReports.PageReportModel.Line
GrapeCity.ActiveReports.PageReportModel.Map
GrapeCity.ActiveReports.PageReportModel.OverflowPlaceHolder
GrapeCity.ActiveReports.PageReportModel.PartItem
GrapeCity.ActiveReports.PageReportModel.ShapeBase
GrapeCity.ActiveReports.PageReportModel.Subreport
GrapeCity.ActiveReports.PageReportModel.TableOfContents
GrapeCity.ActiveReports.PageReportModel.TextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItem Class Members

[image]
ActiveReports 19 .NET Edition
ReportItem Class Members
See Also Fields Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

Glossary Item Box

The following tables list the members exposed by ReportItem.

Public Fields

 | Name | Description
Public Field | DefaultLayerName | The name of the default layer, which is always present.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets an action (e.g., hyperlink) associated with the report item.
Public Property | Bookmark | Gets or sets a bookmark for the report item, which can be linked via a Bookmark action.
Public Property | Custom | Gets or sets custom information for the report item.
Public Property | CustomProperties | Gets a collection of custom property elements.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Height | Gets or sets a height of the report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible.
Public Property | Label | Gets or sets a label for identifying an instance of a report item within the client UI (e.g., a user-friendly label for searching or appearing in the Document Map).
Public Property | LayerName | Gets or sets the name of the layer to which this report item belongs.
Public Property | Left | Gets or sets a horizontal position of the item within its container object.
Public Property | LinkToChild | Gets or sets the name of a report item contained within this report item that serves as the target location for the Document Map label (if any).
Public Property | Name | Gets or sets the name of the report item.
Public Property | Style | Gets or sets a style settings for the report item.
Public Property | ToolTip | Gets or sets a tooltip for the report item.
Public Property | Top | Gets or sets a vertical position of the item within its container object.
Public Property | Visibility | Gets or sets a value indicating whether the report item is hidden.
Public Property | Width | Gets or sets a width of the report item.
Public Property | ZIndex | Gets or sets a drawing order of the report item within its container.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Returns a list of the expressions contained by this report item.
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItem Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

Glossary Item Box

For a list of all members of this type, see ReportItem members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Returns a list of the expressions contained by this report item.
Public Method | Validate | Validates the current state of the ReportItem object.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetExpressions() As ExpressionInfo()
C#
public virtual ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ReportItem object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public virtual ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ReportItem Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

Glossary Item Box

For a list of all members of this type, see ReportItem members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets an action (e.g., hyperlink) associated with the report item.
Public Property | Bookmark | Gets or sets a bookmark for the report item, which can be linked via a Bookmark action.
Public Property | Custom | Gets or sets custom information for the report item.
Public Property | CustomProperties | Gets a collection of custom property elements.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Height | Gets or sets a height of the report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible.
Public Property | Label | Gets or sets a label for identifying an instance of a report item within the client UI (e.g., a user-friendly label for searching or appearing in the Document Map).
Public Property | LayerName | Gets or sets the name of the layer to which this report item belongs.
Public Property | Left | Gets or sets a horizontal position of the item within its container object.
Public Property | LinkToChild | Gets or sets the name of a report item contained within this report item that serves as the target location for the Document Map label (if any).
Public Property | Name | Gets or sets the name of the report item.
Public Property | Style | Gets or sets a style settings for the report item.
Public Property | ToolTip | Gets or sets a tooltip for the report item.
Public Property | Top | Gets or sets a vertical position of the item within its container object.
Public Property | Visibility | Gets or sets a value indicating whether the report item is hidden.
Public Property | Width | Gets or sets a width of the report item.
Public Property | ZIndex | Gets or sets a drawing order of the report item within its container.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Action Property

Glossary Item Box

Gets or sets an action (e.g., hyperlink) associated with the report item.

Syntax

Visual Basic (Declaration)
Public Property Action As Action
C#
public Action Action {get; set;}

Property Value

An Action object representing the action to perform when the report item is clicked.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Action = new Action { Hyperlink = "http://example.com" };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Bookmark Property

Glossary Item Box

Gets or sets a bookmark for the report item, which can be linked via a Bookmark action.

Syntax

Visual Basic (Declaration)
Public Property Bookmark As ExpressionInfo
C#
public ExpressionInfo Bookmark {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the bookmark text.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Bookmark = "Bookmark1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Custom Property

[image]
ActiveReports 19 .NET Edition
Custom Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Custom Property

Glossary Item Box

Gets or sets custom information for the report item.

Syntax

Visual Basic (Declaration)
Public Property Custom As Custom
C#
public Custom Custom {get; set;}

Property Value

A Custom object containing the custom information to be passed to a report output component.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Custom = new Custom { Info = "Custom data" };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : CustomProperties Property

Glossary Item Box

Gets a collection of custom property elements.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection containing the custom properties for the report item.

Example

C# Copy Code
var reportItem = new TextBox();
var customProperties = reportItem.CustomProperties;
customProperties.Add(new CustomPropertyDefinition { Name = "Property1", Value = "Value1" });

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DataElementName Property

Glossary Item Box

Gets or sets the name to use for the data element or attribute for the report item.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name to use for the data element or attribute for the report item.

Remarks

The default value is the Name of the report item.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.DataElementName = "DataElement1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

Output value indicates that the group appears in the output.

NoOutput value indicates that the group does not appear in the output.

ContentsOnly value indicates that the item does not appear in the XML, but its contents are rendered as if they were in the item's container. This value only applies to Lists.

DataElementOutput.Auto (Default) value behaves in the same manner as NoOutput for TextBox report items with constant values, ContentsOnly for Container report items and Output for all other items.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.DataElementOutput = DataElementOutput.Output;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Height Property

Glossary Item Box

Gets or sets a height of the report item.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As Length
C#
public virtual Length Height {get; set;}

Property Value

A Length value indicating the height of the report item.

Remarks

Negative sizes are allowed only for Line items.

If not specified, the default value is the height of the container minus the Top value.

For Table and Matrix items, the height is derived from the sizes of their component parts (i.e. columns, rows, matrix cells).

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Height = new Length("1in");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : KeepTogether Property

Glossary Item Box

Gets or sets a value indicating whether a data region is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A System.Boolean value where true indicates that the data region's content is kept together on a single page if possible; otherwise false. The default value is false.

Remarks

If the data region is larger than the body of the page, the property is ignored.

Example

C# Copy Code
var reportItem = new Table();
reportItem.KeepTogether = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Label Property

Glossary Item Box

Gets or sets a label for identifying an instance of a report item within the client UI (e.g., a user-friendly label for searching or appearing in the Document Map).

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the label text.

Remarks

The label is used in hierarchical listings of report items within the UI (the Document Map) based on the object containment hierarchy in the report definition. Peer items are listed in left-to-right, top-to-bottom order.

If the expression returns null, no item is added to the Document Map.

Labels are not used for report items in the page header or footer.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Label = "Section 1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


LayerName Property

[image]
ActiveReports 19 .NET Edition
LayerName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : LayerName Property

Glossary Item Box

Gets or sets the name of the layer to which this report item belongs.

Syntax

Visual Basic (Declaration)
Public Property LayerName As String
C#
public string LayerName {get; set;}

Property Value

A System.String value indicating the name of the layer. Default value is "default".

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.LayerName = "Layer1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Left Property

Glossary Item Box

Gets or sets a horizontal position of the item within its container object.

Syntax

Visual Basic (Declaration)
Public Property Left As Length
C#
public Length Left {get; set;}

Property Value

A Length value indicating the distance from the left of the container object.

Remarks

The default value is 0 if not specified.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Left = new Length("1in");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


LinkToChild Property

[image]
ActiveReports 19 .NET Edition
LinkToChild Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : LinkToChild Property

Glossary Item Box

Gets or sets the name of a report item contained within this report item that serves as the target location for the Document Map label (if any).

Syntax

Visual Basic (Declaration)
Public Property LinkToChild As String
C#
public string LinkToChild {get; set;}

Property Value

A System.String value indicating the name of the contained report item.

Remarks

Used only for Container items.

This property is ignored if a Label is not present.

Example

C# Copy Code
var containerItem = new Container();
containerItem.LinkToChild = "ChildItemName";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Name Property

Glossary Item Box

Gets or sets the name of the report item.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the report item.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Name = "TitleTextBox";
string textBoxName = reportItem.Name;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Style Property

Glossary Item Box

Gets or sets a style settings for the report item.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object representing the style of the report item.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Style.FontSize = "12pt";
reportItem.Style.Color = "Red";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : ToolTip Property

Glossary Item Box

Gets or sets a tooltip for the report item.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As ExpressionInfo
C#
public ExpressionInfo ToolTip {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object evaluating to the tooltip text.

Remarks

The tooltip is used for elements such as TITLE and ALT attributes in HTML reports.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.ToolTip = "This is a tooltip.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Top Property

Glossary Item Box

Gets or sets a vertical position of the item within its container object.

Syntax

Visual Basic (Declaration)
Public Property Top As Length
C#
public Length Top {get; set;}

Property Value

A Length value indicating the distance from the top of the container object.

Remarks

The default value is 0 if not specified.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Top = new Length("2in");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the report item is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Width Property

Glossary Item Box

Gets or sets a width of the report item.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Length
C#
public virtual Length Width {get; set;}

Property Value

A Length value indicating the width of the report item.

Remarks

Negative sizes are allowed only for Line items.

If not specified, the default value is the width of the container minus the Left value.

For Table and Matrix items, the width is derived from the sizes of their component parts (i.e. columns, rows, matrix cells).

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Width = new Length("3in");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ZIndex Property

[image]
ActiveReports 19 .NET Edition
ZIndex Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : ZIndex Property

Glossary Item Box

Gets or sets a drawing order of the report item within its container.

Syntax

Visual Basic (Declaration)
Public Property ZIndex As Integer
C#
public int ZIndex {get; set;}

Property Value

An System.Int32 value indicating the drawing order of the report item within the containing object.

Remarks

Items with lower indices are drawn first and appear behind items with higher indices.

Items with the same index have an unspecified order.

The default value is 0. The range is 0 to 2147483647.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.ZIndex = 2;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ReportItem Class Fields

[image]
ActiveReports 19 .NET Edition
ReportItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

Glossary Item Box

For a list of all members of this type, see ReportItem members.

Public Fields

 | Name | Description
Public Field | DefaultLayerName | The name of the default layer, which is always present.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultLayerName Field

[image]
ActiveReports 19 .NET Edition
DefaultLayerName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DefaultLayerName Field

Glossary Item Box

The name of the default layer, which is always present.

Syntax

Visual Basic (Declaration)
Public Const DefaultLayerName As String
C#
public const string DefaultLayerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ReportItemCollection Class

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportItem objects.

Object Model

ReportItemCollection Class

Syntax

Visual Basic (Declaration)
Public Class ReportItemCollection
C#
public class ReportItemCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

Glossary Item Box

The following tables list the members exposed by ReportItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportItemCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of ReportItem objects in the ReportItemCollection.
Public Property | IsFixedSize | Gets a value indicating whether the ReportItemCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the ReportItemCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ReportItemCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a ReportItem object to the ReportItemCollection.
Public Method | AddRange | Adds a collection of ReportItem objects to the existing ReportItemCollection.
Public Method | Clear | Removes all items from the ReportItemCollection.
Public Method | Contains | Gets a value indicating whether the ReportItemCollection contains the specified ReportItem.
Public Method | CopyTo | Overloaded. Copies the objects in the ReportItemCollection to an array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific ReportItem object in the ReportItemCollection.
Public Method | Insert | Inserts a new ReportItem into the ReportItemCollection at the specified location.
Public Method | Remove | Removes the specified ReportItem object from the ReportItemCollection.
Public Method | RemoveAt | Removes a ReportItem object from the ReportItemCollection at the specified index.
Public Method | ToArray | Copies the elements of the ReportItemCollection to a new array.
Top

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top

See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ReportItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ReportItemCollection Constructor() | Initializes a new instance of the ReportItemCollection class.
ReportItemCollection Constructor(IEnumerable<ReportItem>) | Initializes a new instance of the ReportItemCollection using the specified items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Constructor()

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > ReportItemCollection Constructor : ReportItemCollection Constructor()

Glossary Item Box

Initializes a new instance of the ReportItemCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportItemCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


ReportItemCollection Constructor(IEnumerable<ReportItem>)

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Constructor(IEnumerable<ReportItem>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > ReportItemCollection Constructor : ReportItemCollection Constructor(IEnumerable<ReportItem>)

items
The items of the collection.

Glossary Item Box

Initializes a new instance of the ReportItemCollection using the specified items.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items As IEnumerable(Of ReportItem) _
)
C#
public ReportItemCollection(
   IEnumerable<ReportItem> items
)

Parameters

items
The items of the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


ReportItemCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

Glossary Item Box

For a list of all members of this type, see ReportItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a ReportItem object to the ReportItemCollection.
Public Method | AddRange | Adds a collection of ReportItem objects to the existing ReportItemCollection.
Public Method | Clear | Removes all items from the ReportItemCollection.
Public Method | Contains | Gets a value indicating whether the ReportItemCollection contains the specified ReportItem.
Public Method | CopyTo | Overloaded. Copies the objects in the ReportItemCollection to an array, starting at the specified array index.
Public Method | IndexOf | Determines the index of a specific ReportItem object in the ReportItemCollection.
Public Method | Insert | Inserts a new ReportItem into the ReportItemCollection at the specified location.
Public Method | Remove | Removes the specified ReportItem object from the ReportItemCollection.
Public Method | RemoveAt | Removes a ReportItem object from the ReportItemCollection at the specified index.
Public Method | ToArray | Copies the elements of the ReportItemCollection to a new array.
Top

See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Add Method

value
A ReportItem object to add.

Glossary Item Box

Adds a ReportItem object to the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal value As ReportItem _
)
C#
public void Add(
   ReportItem value
)

Parameters

value
A ReportItem object to add.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Add(new TextBox());

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : AddRange Method

collection
A collection of the ReportItem objects to add.

Glossary Item Box

Adds a collection of ReportItem objects to the existing ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ReportItem) _
)
C#
public void AddRange(
   IEnumerable<ReportItem> collection
)

Parameters

collection
A collection of the ReportItem objects to add.

Example

C# Copy Code
ReportItemCollection collection1 = new ReportItemCollection();
ReportItemCollection collection2 = new ReportItemCollection();
collection2.Add(new TextBox());
collection1.AddRange(collection2);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Clear Method

Glossary Item Box

Removes all items from the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Contains Method

value
A ReportItem object for which to check.

Glossary Item Box

Gets a value indicating whether the ReportItemCollection contains the specified ReportItem.

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal value As ReportItem _
) As Boolean
C#
public virtual bool Contains(
   ReportItem value
)

Parameters

value
A ReportItem object for which to check.

Return Value

A System.Boolean value. true if the ReportItemCollection contains the specified ReportItem; otherwise, false.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
ReportItem item = new TextBox();
collection.Add(item);
bool contains = collection.Contains(item);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : CopyTo Method

Glossary Item Box

Copies the objects in the ReportItemCollection to an array, starting at the specified array index.

Overload List

Overload | Description
CopyTo(Array,Int32) | Copies the objects in the ReportItemCollection to an array, starting at the specified array index.
CopyTo(ReportItem[],Int32) | Copies the objects in the ReportItemCollection to a ReportItem array, starting at the specified array index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


CopyTo(Array,Int32) Method

[image]
ActiveReports 19 .NET Edition
CopyTo(Array,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > CopyTo Method : CopyTo(Array,Int32) Method

array
An one-dimensional array that is the destination of the objects copied from the ReportItemCollection. The array must have zero-based indexing.
index
A zero-based System.Int32 index in the array at which copying begins.

Glossary Item Box

Copies the objects in the ReportItemCollection to an array, starting at the specified array index.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public virtual void CopyTo(
   Array array,
   int index
)

Parameters

array
An one-dimensional array that is the destination of the objects copied from the ReportItemCollection. The array must have zero-based indexing.
index
A zero-based System.Int32 index in the array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


CopyTo(ReportItem[],Int32) Method

[image]
ActiveReports 19 .NET Edition
CopyTo(ReportItem[],Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > CopyTo Method : CopyTo(ReportItem[],Int32) Method

array
An one-dimensional array of the ReportItem objects that is the destination of the elements copied from the ReportItemCollection. The array must have zero-based indexing.
index
A zero-based System.Int32 index in the array at which copying begins.

Glossary Item Box

Copies the objects in the ReportItemCollection to a ReportItem array, starting at the specified array index.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyTo( _
   ByVal array() As ReportItem, _
   ByVal index As Integer _
)
C#
public virtual void CopyTo(
   ReportItem[] array,
   int index
)

Parameters

array
An one-dimensional array of the ReportItem objects that is the destination of the elements copied from the ReportItemCollection. The array must have zero-based indexing.
index
A zero-based System.Int32 index in the array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IndexOf Method

value
A ReportItem object to locate in the ReportItemCollection.

Glossary Item Box

Determines the index of a specific ReportItem object in the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOf( _
   ByVal value As ReportItem _
) As Integer
C#
public virtual int IndexOf(
   ReportItem value
)

Parameters

value
A ReportItem object to locate in the ReportItemCollection.

Return Value

An System.Int32 value indicating the index of the entry if it was found in the collection; otherwise, -1.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
ReportItem item = new ReportItem();
int index = collection.IndexOf(item);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Insert Method

index
A zero-based System.Int32 index indicating the position at which to insert the ReportItem object.
value
A ReportItem object to insert.

Glossary Item Box

Inserts a new ReportItem into the ReportItemCollection at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ReportItem _
)
C#
public void Insert(
   int index,
   ReportItem value
)

Parameters

index
A zero-based System.Int32 index indicating the position at which to insert the ReportItem object.
value
A ReportItem object to insert.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Insert(0, new TextBox());

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Remove Method

value
A ReportItem object to remove.

Glossary Item Box

Removes the specified ReportItem object from the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal value As ReportItem _
) As Boolean
C#
public bool Remove(
   ReportItem value
)

Parameters

value
A ReportItem object to remove.

Return Value

A System.Boolean value. true if the ReportItem was successfully removed; otherwise, false.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
ReportItem item = new TextBox();
collection.Add(item);
bool removed = collection.Remove(item);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : RemoveAt Method

index
A zero-based System.Int32 index at which to remove the ReportItem object.

Glossary Item Box

Removes a ReportItem object from the ReportItemCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
A zero-based System.Int32 index at which to remove the ReportItem object.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Add(new TextBox());
collection.RemoveAt(0);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ToArray Method

Glossary Item Box

Copies the elements of the ReportItemCollection to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As ReportItem()
C#
public ReportItem[] ToArray()

Return Value

An array of ReportItem objects containing copies of the elements in the ReportItemCollection.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
ReportItem[] array = collection.ToArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

Glossary Item Box

For a list of all members of this type, see ReportItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of ReportItem objects in the ReportItemCollection.
Public Property | IsFixedSize | Gets a value indicating whether the ReportItemCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the ReportItemCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ReportItemCollection.
Top

See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Count Property

Glossary Item Box

Gets the number of ReportItem objects in the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An System.Int32 value indicating the number of ReportItem objects.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Add(new TextBox());
int count = collection.Count;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsFixedSize Property

[image]
ActiveReports 19 .NET Edition
IsFixedSize Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsFixedSize Property

Glossary Item Box

Gets a value indicating whether the ReportItemCollection has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

A System.Boolean value. true if the ReportItemCollection has a fixed size; otherwise, false.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
bool isFixedSize = collection.IsFixedSize;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the ReportItemCollection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

A System.Boolean value. true if the ReportItemCollection is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsSynchronized As Boolean
C#
public virtual bool IsSynchronized {get;}

Property Value

A System.Boolean value. true if access to the ReportItemCollection is synchronized (thread safe); otherwise, false.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
bool isSynchronized = collection.IsSynchronized;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Item Property

Glossary Item Box

Gets or sets a specific ReportItem object in the ReportItemCollection by position.

Overload List

Overload | Description
Item(Int32) | Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Item(String) | Gets the ReportItem object using the specified name.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Add(new TextBox());
ReportItem item = collection[0];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > Item Property : Item(Int32) Property

index
A zero-based System.Int32 index of the ReportItem to return or set.

Glossary Item Box

Gets or sets a specific ReportItem object in the ReportItemCollection by position.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As ReportItem
C#
public ReportItem Item(
   int index
) {get; set;}

Parameters

index
A zero-based System.Int32 index of the ReportItem to return or set.

Property Value

A ReportItem object at the specified position.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
collection.Add(new TextBox());
ReportItem item = collection[0];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > Item Property : Item(String) Property

name
A System.String value indicating the name of the ReportItem to get.

Glossary Item Box

Gets the ReportItem object using the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ReportItem
C#
public ReportItem Item(
   string name
) {get;}

Parameters

name
A System.String value indicating the name of the ReportItem to get.

Property Value

A ReportItem object with the specified name.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
ReportItem item = collection["itemName"];

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the ReportItemCollection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SyncRoot As Object
C#
public virtual object SyncRoot {get;}

Property Value

An System.Object that can be used to synchronize access to the ReportItemCollection.

Example

C# Copy Code
ReportItemCollection collection = new ReportItemCollection();
object syncRoot = collection.SyncRoot;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Class Events

[image]
ActiveReports 19 .NET Edition
ReportItemCollection Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

Glossary Item Box

For a list of all members of this type, see ReportItemCollection members.

Public Events

 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top

See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemAdded Event

[image]
ActiveReports 19 .NET Edition
ItemAdded Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ItemAdded Event

Glossary Item Box

Occurs immediately after adding an item to the collection.

Syntax

Visual Basic (Declaration)
Public Event ItemAdded As ReportItemCollectionEventHandler
C#
public event ReportItemCollectionEventHandler ItemAdded

Event Data

The event handler receives an argument of type ReportItemCollectionEventArgs containing data related to this event. The following ReportItemCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Gets an index of the ReportItem that was added or removed.
Value | Gets the ReportItem object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ItemRemoved Event

[image]
ActiveReports 19 .NET Edition
ItemRemoved Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ItemRemoved Event

Glossary Item Box

Occurs immediately after removing an item from the collection.

Syntax

Visual Basic (Declaration)
Public Event ItemRemoved As ReportItemCollectionEventHandler
C#
public event ReportItemCollectionEventHandler ItemRemoved

Event Data

The event handler receives an argument of type ReportItemCollectionEventArgs containing data related to this event. The following ReportItemCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Gets an index of the ReportItem that was added or removed.
Value | Gets the ReportItem object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollectionEventArgs Class

[image]
ActiveReports 19 .NET Edition
ReportItemCollectionEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class

Glossary Item Box

Represents a data for the ReportItemCollection.ItemAdded or ReportItemCollection.ItemRemoved event of the ReportItemCollection.

Object Model

ReportItemCollectionEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ReportItemCollectionEventArgs
   Inherits System.EventArgs
C#
public class ReportItemCollectionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.ReportItemCollectionEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollectionEventArgs Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemCollectionEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class

Glossary Item Box

The following tables list the members exposed by ReportItemCollectionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ReportItemCollectionEventArgs Constructor | Initializes a new instance of the ReportItemCollectionEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Index | Gets an index of the ReportItem that was added or removed.
Public Property | Value | Gets the ReportItem object that was added or removed.
Top

See Also

Reference

ReportItemCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
ReportItemCollectionEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : ReportItemCollectionEventArgs Constructor

index
An System.Int32 value indicating the index of the ReportItem object added or removed.
value
The ReportItem object that was added or removed.

Glossary Item Box

Initializes a new instance of the ReportItemCollectionEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal index As Integer, _
   ByVal value As ReportItem _
)
C#
public ReportItemCollectionEventArgs(
   int index,
   ReportItem value
)

Parameters

index
An System.Int32 value indicating the index of the ReportItem object added or removed.
value
The ReportItem object that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


ReportItemCollectionEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItemCollectionEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class

Glossary Item Box

For a list of all members of this type, see ReportItemCollectionEventArgs members.

Public Properties

 | Name | Description
Public Property | Index | Gets an index of the ReportItem that was added or removed.
Public Property | Value | Gets the ReportItem object that was added or removed.
Top

See Also

Reference

ReportItemCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : Index Property

Glossary Item Box

Gets an index of the ReportItem that was added or removed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
C#
public int Index {get;}

Property Value

An System.Int32 value indicating the index of the ReportItem that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : Value Property

Glossary Item Box

Gets the ReportItem object that was added or removed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As ReportItem
C#
public ReportItem Value {get;}

Property Value

A ReportItem object representing the item that was added or removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


ReportParameter Class

[image]
ActiveReports 19 .NET Edition
ReportParameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

Glossary Item Box

Represents a parameter for the report, containing relevant information and settings.

Object Model

ReportParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportParameter
   Implements IValidateable
C#
public sealed class ReportParameter : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameter Class Members

[image]
ActiveReports 19 .NET Edition
ReportParameter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

Glossary Item Box

The following tables list the members exposed by ReportParameter.

Public Constructors

 | Name | Description
Public Constructor | ReportParameter Constructor | Initializes a new instance of the ReportParameter class.
Top

Public Properties

 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the parameter value can be an empty string.
Public Property | DataType | Gets or sets a data type of the parameter.
Public Property | DateOnly | Gets or sets a value indicating whether the parameter contains only a date without a time component.
Public Property | DefaultValue | Gets or sets a default value for the parameter, used if none is provided by the user.
Public Property | DisplayFormat | Gets or sets a display format for the parameter.
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | Multiline | Gets or sets a value indicating whether the parameter is intended to accept multiline values.
Public Property | MultiValue | Gets or sets a value indicating whether multiple values for the parameter are allowed.
Public Property | Name | Gets or sets a name of the parameter, which is used when expressions refer to the parameter.
Public Property | Nullable | Gets or sets a value indicating whether the parameter value can be null.
Public Property | Prompt | Gets or sets a user prompt displayed when asking for parameter values.
Public Property | SelectAllValue | Gets or sets the value passed when the "Select All" option is chosen for a multiline parameter.
Public Property | UsedInQuery | Gets or sets a value indicating whether the parameter is used in a query within the report.
Public Property | ValidValues | Gets or sets the possible values for the parameter, used in an end-user prompting interface.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the information in each property of the ReportParameter object.
Top

See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameter Constructor

[image]
ActiveReports 19 .NET Edition
ReportParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : ReportParameter Constructor

Glossary Item Box

Initializes a new instance of the ReportParameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportParameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Class Methods

[image]
ActiveReports 19 .NET Edition
ReportParameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

Glossary Item Box

For a list of all members of this type, see ReportParameter members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the information in each property of the ReportParameter object.
Top

See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new ReportParameter object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the ReportParameter object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Class Properties

[image]
ActiveReports 19 .NET Edition
ReportParameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

Glossary Item Box

For a list of all members of this type, see ReportParameter members.

Public Properties

 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the parameter value can be an empty string.
Public Property | DataType | Gets or sets a data type of the parameter.
Public Property | DateOnly | Gets or sets a value indicating whether the parameter contains only a date without a time component.
Public Property | DefaultValue | Gets or sets a default value for the parameter, used if none is provided by the user.
Public Property | DisplayFormat | Gets or sets a display format for the parameter.
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | Multiline | Gets or sets a value indicating whether the parameter is intended to accept multiline values.
Public Property | MultiValue | Gets or sets a value indicating whether multiple values for the parameter are allowed.
Public Property | Name | Gets or sets a name of the parameter, which is used when expressions refer to the parameter.
Public Property | Nullable | Gets or sets a value indicating whether the parameter value can be null.
Public Property | Prompt | Gets or sets a user prompt displayed when asking for parameter values.
Public Property | SelectAllValue | Gets or sets the value passed when the "Select All" option is chosen for a multiline parameter.
Public Property | UsedInQuery | Gets or sets a value indicating whether the parameter is used in a query within the report.
Public Property | ValidValues | Gets or sets the possible values for the parameter, used in an end-user prompting interface.
Top

See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


AllowBlank Property

[image]
ActiveReports 19 .NET Edition
AllowBlank Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : AllowBlank Property

Glossary Item Box

Gets or sets a value indicating whether the parameter value can be an empty string.

Syntax

Visual Basic (Declaration)
Public Property AllowBlank As Boolean
C#
public bool AllowBlank {get; set;}

Property Value

A System.Boolean value where true indicates that the parameter can be an empty string; otherwise, false. Default value is false.

Remarks

This property is ignored if the DataType is not string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


DataType Property

[image]
ActiveReports 19 .NET Edition
DataType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DataType Property

Glossary Item Box

Gets or sets a data type of the parameter.

Syntax

Visual Basic (Declaration)
Public Property DataType As ReportParameterDataType
C#
public ReportParameterDataType DataType {get; set;}

Property Value

A ReportParameterDataType value indicating the data type of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


DateOnly Property

[image]
ActiveReports 19 .NET Edition
DateOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DateOnly Property

Glossary Item Box

Gets or sets a value indicating whether the parameter contains only a date without a time component.

Syntax

Visual Basic (Declaration)
Public Property DateOnly As Boolean
C#
public bool DateOnly {get; set;}

Property Value

A System.Boolean value where true indicates that this parameter contains only a date without a time component; otherwise, false. The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DefaultValue Property

Glossary Item Box

Gets or sets a default value for the parameter, used if none is provided by the user.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As DefaultValue
C#
public DefaultValue DefaultValue {get; set;}

Property Value

A DefaultValue object representing the default value for the parameter.

Remarks

If no value is provided by definition or by the user, the parameter value is null. A DefaultValue is required if there is no Prompt and either Nullable is false or a ValidValues list is provided that does not contain null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


DisplayFormat Property

[image]
ActiveReports 19 .NET Edition
DisplayFormat Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DisplayFormat Property

Glossary Item Box

Gets or sets a display format for the parameter.

Syntax

Visual Basic (Declaration)
Public Property DisplayFormat As ExpressionInfo
C#
public ExpressionInfo DisplayFormat {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value indicating the display format for the parameter.

Example

C# Copy Code
ReportParameter reportParameter = new ReportParameter();
reportParameter.DisplayFormat = "dddd";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Hidden Property

Glossary Item Box

Gets or sets a value indicating whether this parameter should be visible to the end user.

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden {get; set;}

Property Value

A System.Boolean value where true indicates that this parameter should not be visible to the end user; otherwise, false. The default value is false.

Remarks

The parameter remains usable programmatically, such as with subreports and drillthrough reports, when this property is set to true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Multiline Property

[image]
ActiveReports 19 .NET Edition
Multiline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Multiline Property

Glossary Item Box

Gets or sets a value indicating whether the parameter is intended to accept multiline values.

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
C#
public bool Multiline {get; set;}

Property Value

A System.Boolean value where true indicates that the parameter is intended to accept multiline values; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


MultiValue Property

[image]
ActiveReports 19 .NET Edition
MultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : MultiValue Property

Glossary Item Box

Gets or sets a value indicating whether multiple values for the parameter are allowed.

Syntax

Visual Basic (Declaration)
Public Property MultiValue As Boolean
C#
public bool MultiValue {get; set;}

Property Value

A System.Boolean value where true indicates that multiple parameter values are allowed; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Name Property

Glossary Item Box

Gets or sets a name of the parameter, which is used when expressions refer to the parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String valie indicating the name of the parameter.

Remarks

Parameter names must be unique within the containing Parameters collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Nullable Property

[image]
ActiveReports 19 .NET Edition
Nullable Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Nullable Property

Glossary Item Box

Gets or sets a value indicating whether the parameter value can be null.

Syntax

Visual Basic (Declaration)
Public Property Nullable As Boolean
C#
public bool Nullable {get; set;}

Property Value

A System.Boolean value where true indicates that the parameter can be null; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Prompt Property

Glossary Item Box

Gets or sets a user prompt displayed when asking for parameter values.

Syntax

Visual Basic (Declaration)
Public Property Prompt As ExpressionInfo
C#
public ExpressionInfo Prompt {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the user prompt displayed when asking for parameter values.

Remarks

If this value is omitted, the user is not prompted for a value for the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


SelectAllValue Property

[image]
ActiveReports 19 .NET Edition
SelectAllValue Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : SelectAllValue Property

Glossary Item Box

Gets or sets the value passed when the "Select All" option is chosen for a multiline parameter.

Syntax

Visual Basic (Declaration)
Public Property SelectAllValue As ExpressionInfo
C#
public ExpressionInfo SelectAllValue {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the value passed when the "Select All" option is chosen.

Example

C# Copy Code
ReportParameter reportParameter = new ReportParameter();
reportParameter.SelectAllValue = "*";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


UsedInQuery Property

[image]
ActiveReports 19 .NET Edition
UsedInQuery Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : UsedInQuery Property

Glossary Item Box

Gets or sets a value indicating whether the parameter is used in a query within the report.

Syntax

Visual Basic (Declaration)
Public Property UsedInQuery As ReportParameterUsedInQuery
C#
public ReportParameterUsedInQuery UsedInQuery {get; set;}

Property Value

A ReportParameterUsedInQuery value indicating whether the parameter is used in a query within the report.

Remarks

This property helps determine if queries need to be re-executed when the parameter changes.

ReportParameterUsedInQuery.Auto (default) automatically detects if the parameter is referenced in any query value expression. If so, it returns true; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ValidValues Property

[image]
ActiveReports 19 .NET Edition
ValidValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : ValidValues Property

Glossary Item Box

Gets or sets the possible values for the parameter, used in an end-user prompting interface.

Syntax

Visual Basic (Declaration)
Public Property ValidValues As ValidValues
C#
public ValidValues ValidValues {get; set;}

Property Value

A ValidValues object containing the possible values for the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameterCollection Class

[image]
ActiveReports 19 .NET Edition
ReportParameterCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportParameter objects.

Object Model

ReportParameterCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportParameterCollection
   Inherits System.Collections.ObjectModel.Collection(Of ReportParameter)
C#
public sealed class ReportParameterCollection : System.Collections.ObjectModel.Collection<ReportParameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportParameterCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class

Glossary Item Box

The following tables list the members exposed by ReportParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterCollection Constructor |
Top

See Also

Reference

ReportParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportParameterCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : ReportParameterCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportParameterCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


ReportPart Class

[image]
ActiveReports 19 .NET Edition
ReportPart Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPart Class

Glossary Item Box

Represents an exported report part.

Object Model

ReportPart Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportPart
C#
public sealed class ReportPart

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportPart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPart Class Members

[image]
ActiveReports 19 .NET Edition
ReportPart Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPart Class

Glossary Item Box

The following tables list the members exposed by ReportPart.

Public Constructors

 | Name | Description
Public Constructor | ReportPart Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the detailed description of the report part visible in the designer.
Public Property | DisplayName | Gets or sets the name of the report part visible in the designer.
Public Property | Name | Gets or sets the name of the exported report part.
Public Property | Properties | Gets or sets the properties that can be used inside expressions of ReportItem and will be visible in the designer.
Public Property | ReportItemName | Gets or sets the name of the existing report item to be exported as a report part.
Public Property | SizeMode | Gets or sets a value indicating whether the part item's size can be applied to the report part.
Top

See Also

Reference

ReportPart Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPart Constructor

[image]
ActiveReports 19 .NET Edition
ReportPart Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : ReportPart Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportPart()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


ReportPart Class Properties

[image]
ActiveReports 19 .NET Edition
ReportPart Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPart Class

Glossary Item Box

For a list of all members of this type, see ReportPart members.

Public Properties

 | Name | Description
Public Property | Description | Gets or sets the detailed description of the report part visible in the designer.
Public Property | DisplayName | Gets or sets the name of the report part visible in the designer.
Public Property | Name | Gets or sets the name of the exported report part.
Public Property | Properties | Gets or sets the properties that can be used inside expressions of ReportItem and will be visible in the designer.
Public Property | ReportItemName | Gets or sets the name of the existing report item to be exported as a report part.
Public Property | SizeMode | Gets or sets a value indicating whether the part item's size can be applied to the report part.
Top

See Also

Reference

ReportPart Class
GrapeCity.ActiveReports.PageReportModel Namespace


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : Description Property

Glossary Item Box

Gets or sets the detailed description of the report part visible in the designer.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Property Value

A System.String value indicating the detailed description of the report part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


DisplayName Property

[image]
ActiveReports 19 .NET Edition
DisplayName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : DisplayName Property

Glossary Item Box

Gets or sets the name of the report part visible in the designer.

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName {get; set;}

Property Value

A System.String value indicating the display name of the report part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : Name Property

Glossary Item Box

Gets or sets the name of the exported report part.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the exported report part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : Properties Property

Glossary Item Box

Gets or sets the properties that can be used inside expressions of ReportItem and will be visible in the designer.

Syntax

Visual Basic (Declaration)
Public Property Properties As ReportPartPropertiesCollection
C#
public ReportPartPropertiesCollection Properties {get; set;}

Property Value

A ReportPartPropertiesCollection object containing the properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


ReportItemName Property

[image]
ActiveReports 19 .NET Edition
ReportItemName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : ReportItemName Property

Glossary Item Box

Gets or sets the name of the existing report item to be exported as a report part.

Syntax

Visual Basic (Declaration)
Public Property ReportItemName As String
C#
public string ReportItemName {get; set;}

Property Value

A System.String value indicating the name of the existing report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


SizeMode Property

[image]
ActiveReports 19 .NET Edition
SizeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPart Class : SizeMode Property

Glossary Item Box

Gets or sets a value indicating whether the part item's size can be applied to the report part.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As ReportPartSizeMode
C#
public ReportPartSizeMode SizeMode {get; set;}

Property Value

A ReportPartSizeMode value indicating how the part item size can be applied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPart Class
ReportPart Members


ReportPartPropertiesCollection Class

[image]
ActiveReports 19 .NET Edition
ReportPartPropertiesCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartPropertiesCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportPartProperty objects.

Object Model

ReportPartPropertiesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportPartPropertiesCollection
   Inherits System.Collections.ObjectModel.Collection(Of ReportPartProperty)
C#
public sealed class ReportPartPropertiesCollection : System.Collections.ObjectModel.Collection<ReportPartProperty>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ReportPartPropertiesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartPropertiesCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartPropertiesCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportPartPropertiesCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartPropertiesCollection Class

Glossary Item Box

The following tables list the members exposed by ReportPartPropertiesCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportPartPropertiesCollection Constructor |
Top

See Also

Reference

ReportPartPropertiesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartPropertiesCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportPartPropertiesCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartPropertiesCollection Class : ReportPartPropertiesCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportPartPropertiesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartPropertiesCollection Class
ReportPartPropertiesCollection Members


ReportPartProperty Class

[image]
ActiveReports 19 .NET Edition
ReportPartProperty Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartProperty Class

Glossary Item Box

Represents a property of an exported report part.

Object Model

ReportPartProperty Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportPartProperty
C#
public sealed class ReportPartProperty

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportPartProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartProperty Class Members

[image]
ActiveReports 19 .NET Edition
ReportPartProperty Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartProperty Class

Glossary Item Box

The following tables list the members exposed by ReportPartProperty.

Public Constructors

 | Name | Description
Public Constructor | ReportPartProperty Constructor |
Top

Public Properties

 | Name | Description
Public Property | Category | Gets or sets the category of the property.
Public Property | DefaultValue | Gets or sets the default value of the property.
Public Property | Description | Gets or sets the description of the property.
Public Property | DisplayName | Gets or sets the display name of the property.
Public Property | Name | Gets or sets the CLS-compliant property name.
Public Property | PropertyType | Gets or sets the type of the property.
Top

See Also

Reference

ReportPartProperty Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartProperty Constructor

[image]
ActiveReports 19 .NET Edition
ReportPartProperty Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : ReportPartProperty Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportPartProperty()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


ReportPartProperty Class Properties

[image]
ActiveReports 19 .NET Edition
ReportPartProperty Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartProperty Class

Glossary Item Box

For a list of all members of this type, see ReportPartProperty members.

Public Properties

 | Name | Description
Public Property | Category | Gets or sets the category of the property.
Public Property | DefaultValue | Gets or sets the default value of the property.
Public Property | Description | Gets or sets the description of the property.
Public Property | DisplayName | Gets or sets the display name of the property.
Public Property | Name | Gets or sets the CLS-compliant property name.
Public Property | PropertyType | Gets or sets the type of the property.
Top

See Also

Reference

ReportPartProperty Class
GrapeCity.ActiveReports.PageReportModel Namespace


Category Property

[image]
ActiveReports 19 .NET Edition
Category Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : Category Property

Glossary Item Box

Gets or sets the category of the property.

Syntax

Visual Basic (Declaration)
Public Property Category As String
C#
public string Category {get; set;}

Property Value

A System.String value indicating the category of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : DefaultValue Property

Glossary Item Box

Gets or sets the default value of the property.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As ExpressionInfo
C#
public ExpressionInfo DefaultValue {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the default value of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


Description Property

[image]
ActiveReports 19 .NET Edition
Description Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : Description Property

Glossary Item Box

Gets or sets the description of the property.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Property Value

A System.String value indicating the description of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


DisplayName Property

[image]
ActiveReports 19 .NET Edition
DisplayName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : DisplayName Property

Glossary Item Box

Gets or sets the display name of the property.

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName {get; set;}

Property Value

A System.String value indicating the display name of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : Name Property

Glossary Item Box

Gets or sets the CLS-compliant property name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the CLS-compliant property name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


PropertyType Property

[image]
ActiveReports 19 .NET Edition
PropertyType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartProperty Class : PropertyType Property

Glossary Item Box

Gets or sets the type of the property.

Syntax

Visual Basic (Declaration)
Public Property PropertyType As ReportPartPropertyType
C#
public ReportPartPropertyType PropertyType {get; set;}

Property Value

A ReportPartPropertyType value indicating the type of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartProperty Class
ReportPartProperty Members


ReportPartsCollection Class

[image]
ActiveReports 19 .NET Edition
ReportPartsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartsCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportPart objects.

Object Model

ReportPartsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportPartsCollection
   Inherits System.Collections.ObjectModel.Collection(Of ReportPart)
C#
public sealed class ReportPartsCollection : System.Collections.ObjectModel.Collection<ReportPart>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ReportPartsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartsCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportPartsCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartsCollection Class

Glossary Item Box

The following tables list the members exposed by ReportPartsCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportPartsCollection Constructor |
Top

See Also

Reference

ReportPartsCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartsCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportPartsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportPartsCollection Class : ReportPartsCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportPartsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportPartsCollection Class
ReportPartsCollection Members


ReportSection Class

[image]
ActiveReports 19 .NET Edition
ReportSection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSection Class

Glossary Item Box

Represents a section within a report.

Object Model

ReportSection Class

Syntax

Visual Basic (Declaration)
Public Class ReportSection
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public class ReportSection : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportSection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSection Class Members

[image]
ActiveReports 19 .NET Edition
ReportSection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSection Class

Glossary Item Box

The following tables list the members exposed by ReportSection.

Public Constructors

 | Name | Description
Public Constructor | ReportSection Constructor | Initializes a new instance of the ReportSection class.
Top

Public Properties

 | Name | Description
Public Property | Body | Gets or sets a body layout information for the report section.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | CustomProperties | Gets the custom properties of the section.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the report data.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DisplayName | Gets or sets a display name of the report section. This name is visible to the user, such as in a tab page title in a dashboard viewer.
Public Property | Label | Gets or sets a label to identify an instance of a report section within the client UI, providing a user-friendly label in the Document Map or in Dashboard tabs.
Public Property | Name | Gets or sets the name of the report section.
Public Property | Page | Gets or sets the page layout information for the report section.
Public Property | Visibility | Gets or sets a value indicating whether the report section is hidden.
Public Property | Width | Gets or sets the width of the report section.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportSection object.
Top

See Also

Reference

ReportSection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSection Constructor

[image]
ActiveReports 19 .NET Edition
ReportSection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : ReportSection Constructor

Glossary Item Box

Initializes a new instance of the ReportSection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportSection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


ReportSection Class Methods

[image]
ActiveReports 19 .NET Edition
ReportSection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSection Class

Glossary Item Box

For a list of all members of this type, see ReportSection members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ReportSection object.
Top

See Also

Reference

ReportSection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ReportSection object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


ReportSection Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSection Class

Glossary Item Box

For a list of all members of this type, see ReportSection members.

Public Properties

 | Name | Description
Public Property | Body | Gets or sets a body layout information for the report section.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | CustomProperties | Gets the custom properties of the section.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the report data.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | DisplayName | Gets or sets a display name of the report section. This name is visible to the user, such as in a tab page title in a dashboard viewer.
Public Property | Label | Gets or sets a label to identify an instance of a report section within the client UI, providing a user-friendly label in the Document Map or in Dashboard tabs.
Public Property | Name | Gets or sets the name of the report section.
Public Property | Page | Gets or sets the page layout information for the report section.
Public Property | Visibility | Gets or sets a value indicating whether the report section is hidden.
Public Property | Width | Gets or sets the width of the report section.
Top

See Also

Reference

ReportSection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Body Property

Glossary Item Box

Gets or sets a body layout information for the report section.

Syntax

Visual Basic (Declaration)
Public Property Body As Body
C#
public Body Body {get; set;}

Property Value

A Body object representing the body layout details of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : CustomProperties Property

Glossary Item Box

Gets the custom properties of the section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection object containing custom properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the report data.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for the report data.

Example

C# Copy Code
ReportSection section = new ReportSection();
section.DataElementName = "ReportSection";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Example

C# Copy Code
ReportSection section = new ReportSection();
section.DataElementOutput = DataElementOutput.Output;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


DisplayName Property

[image]
ActiveReports 19 .NET Edition
DisplayName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : DisplayName Property

Glossary Item Box

Gets or sets a display name of the report section. This name is visible to the user, such as in a tab page title in a dashboard viewer.

Syntax

Visual Basic (Declaration)
Public Property DisplayName As ExpressionInfo
C#
public ExpressionInfo DisplayName {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the display name of the report section.

Remarks

This property is obsolete. Use Label instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Label Property

Glossary Item Box

Gets or sets a label to identify an instance of a report section within the client UI, providing a user-friendly label in the Document Map or in Dashboard tabs.

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the label for the report section.

Example

C# Copy Code
ReportSection section = new ReportSection();
section.Label = ExpressionInfo.FromString("Section Label");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Name Property

Glossary Item Box

Gets or sets the name of the report section.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the report section.

Example

C# Copy Code
ReportSection section = new ReportSection();
section.Name = "Section1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Page Property

Glossary Item Box

Gets or sets the page layout information for the report section.

Syntax

Visual Basic (Declaration)
Public Property Page As ReportSectionPage
C#
public ReportSectionPage Page {get; set;}

Property Value

A ReportSectionPage object representing the page layout details for the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the report section is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSection Class : Width Property

Glossary Item Box

Gets or sets the width of the report section.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the report section.

Example

C# Copy Code
ReportSection section = new ReportSection();
section.Width = new Length("8.5in");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSection Class
ReportSection Members


ReportSectionPage Class

[image]
ActiveReports 19 .NET Edition
ReportSectionPage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSectionPage Class

Glossary Item Box

Represents a section page within a report.

Object Model

ReportSectionPage Class

Syntax

Visual Basic (Declaration)
Public Class ReportSectionPage
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
C#
public class ReportSectionPage : ReportComponent, IReportComponent, IReportComponentContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportSectionPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSectionPage Class Members

[image]
ActiveReports 19 .NET Edition
ReportSectionPage Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSectionPage Class

Glossary Item Box

The following tables list the members exposed by ReportSectionPage.

Public Constructors

 | Name | Description
Public Constructor | ReportSectionPage Constructor |
Top

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | Columns | Gets or sets the number of columns in the section page.
Public Property | ColumnSpacing | Gets or sets the amount of white space between each column in the section page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | PageFooter | Gets or sets a footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets a height of the pages in the report section.
Public Property | PageWidth | Gets or sets a width of the pages in the report section.
Public Property | PaperOrientation | Gets or sets the paper orientation for the report pages used for printing.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | TopMargin | Gets or sets a height of the top margin.
Top

See Also

Reference

ReportSectionPage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSectionPage Constructor

[image]
ActiveReports 19 .NET Edition
ReportSectionPage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : ReportSectionPage Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportSectionPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


ReportSectionPage Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSectionPage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSectionPage Class

Glossary Item Box

For a list of all members of this type, see ReportSectionPage members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | Columns | Gets or sets the number of columns in the section page.
Public Property | ColumnSpacing | Gets or sets the amount of white space between each column in the section page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | PageFooter | Gets or sets a footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets a height of the pages in the report section.
Public Property | PageWidth | Gets or sets a width of the pages in the report section.
Public Property | PaperOrientation | Gets or sets the paper orientation for the report pages used for printing.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | TopMargin | Gets or sets a height of the top margin.
Top

See Also

Reference

ReportSectionPage Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : BottomMargin Property

Glossary Item Box

Gets or sets a height of the bottom margin.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As Length
C#
public Length BottomMargin {get; set;}

Property Value

A Length value indicating the height of the bottom margin. Default value is 0in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.BottomMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : Columns Property

Glossary Item Box

Gets or sets the number of columns in the section page.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
C#
public int Columns {get; set;}

Property Value

An System.Int32 value indicating the number of columns. Default value is 1. Minimum value is 1 and the maximum value is 100.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.Columns = 2;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


ColumnSpacing Property

[image]
ActiveReports 19 .NET Edition
ColumnSpacing Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : ColumnSpacing Property

Glossary Item Box

Gets or sets the amount of white space between each column in the section page.

Syntax

Visual Basic (Declaration)
Public Property ColumnSpacing As Length
C#
public Length ColumnSpacing {get; set;}

Property Value

A Length value indicating the spacing between columns. Default value is 0.5in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.ColumnSpacing = "0.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : LeftMargin Property

Glossary Item Box

Gets or sets a width of the left margin.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As Length
C#
public Length LeftMargin {get; set;}

Property Value

A Length value indicating the width of the left margin. Default value is 0in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.LeftMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


PageFooter Property

[image]
ActiveReports 19 .NET Edition
PageFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : PageFooter Property

Glossary Item Box

Gets or sets a footer object that is output at the bottom of each report page.

Syntax

Visual Basic (Declaration)
Public Property PageFooter As PageHeaderFooter
C#
public PageHeaderFooter PageFooter {get; set;}

Property Value

A PageHeaderFooter object representing the footer layout of each report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


PageHeader Property

[image]
ActiveReports 19 .NET Edition
PageHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : PageHeader Property

Glossary Item Box

Gets or sets the header object that is output at the top of each report page.

Syntax

Visual Basic (Declaration)
Public Property PageHeader As PageHeaderFooter
C#
public PageHeaderFooter PageHeader {get; set;}

Property Value

A PageHeaderFooter object representing the header layout of each report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


PageHeight Property

[image]
ActiveReports 19 .NET Edition
PageHeight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : PageHeight Property

Glossary Item Box

Gets or sets a height of the pages in the report section.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As Length
C#
public Length PageHeight {get; set;}

Property Value

A Length value indicating the height of the pages. Default value is 11in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.PageHeight = "11in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


PageWidth Property

[image]
ActiveReports 19 .NET Edition
PageWidth Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : PageWidth Property

Glossary Item Box

Gets or sets a width of the pages in the report section.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As Length
C#
public Length PageWidth {get; set;}

Property Value

A Length value indicating the width of the pages. Default value is 8.5in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.PageWidth = "8.5in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


PaperOrientation Property

[image]
ActiveReports 19 .NET Edition
PaperOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : PaperOrientation Property

Glossary Item Box

Gets or sets the paper orientation for the report pages used for printing.

Syntax

Visual Basic (Declaration)
Public Property PaperOrientation As PaperOrientation
C#
public PaperOrientation PaperOrientation {get; set;}

Property Value

A PaperOrientation value indicating the paper orientation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : RightMargin Property

Glossary Item Box

Gets or sets a width of the right margin.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As Length
C#
public Length RightMargin {get; set;}

Property Value

A Length value indicating the width of the right margin. Default value is 0in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.RightMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionPage Class : TopMargin Property

Glossary Item Box

Gets or sets a height of the top margin.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As Length
C#
public Length TopMargin {get; set;}

Property Value

A Length value indicating the height of the top margin. Default value is 0in.

Example

C# Copy Code
ReportSectionPage sectionPage = new ReportSectionPage();
sectionPage.TopMargin = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionPage Class
ReportSectionPage Members


ReportSectionsCollection Class

[image]
ActiveReports 19 .NET Edition
ReportSectionsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSectionsCollection Class

Glossary Item Box

Represents a strongly typed observable collection of ReportSection objects.

Object Model

ReportSectionsCollection Class

Syntax

Visual Basic (Declaration)
Public Class ReportSectionsCollection
   Inherits System.Collections.ObjectModel.ObservableCollection(Of ReportSection)
C#
public class ReportSectionsCollection : System.Collections.ObjectModel.ObservableCollection<ReportSection>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
GrapeCity.ActiveReports.PageReportModel.ReportSectionsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionsCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSectionsCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportSectionsCollection Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSectionsCollection Class

Glossary Item Box

The following tables list the members exposed by ReportSectionsCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportSectionsCollection Constructor |
Top

See Also

Reference

ReportSectionsCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSectionsCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportSectionsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSectionsCollection Class : ReportSectionsCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportSectionsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionsCollection Class
ReportSectionsCollection Members


ReportSlicer Class

[image]
ActiveReports 19 .NET Edition
ReportSlicer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicer Class

Glossary Item Box

Report slicer definition. Slicers are similar to parameters, but unlike them, changing a slicer does not lead to a complete rebuild of the report and re-query the data. Instead, the existing report data tree is rebuilt to form a new report.

Object Model

ReportSlicer Class

Syntax

Visual Basic (Declaration)
Public Class ReportSlicer
   Implements IValidateable
C#
public class ReportSlicer : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportSlicer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSlicer Class Members

[image]
ActiveReports 19 .NET Edition
ReportSlicer Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicer Class

Glossary Item Box

The following tables list the members exposed by ReportSlicer.

Public Constructors

 | Name | Description
Public Constructor | ReportSlicer Constructor |
Top

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the default value to use for the slicer (if none is provided by the user).
Public Property | MultiValue | Gets or sets a value indicating whether multiple values for this parameter are allowed.
Public Property | Name | Gets or sets the name of the slicer (this is the name used when expressions refer to the slicer).
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Validate |
Top

See Also

Reference

ReportSlicer Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSlicer Constructor

[image]
ActiveReports 19 .NET Edition
ReportSlicer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : ReportSlicer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportSlicer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


ReportSlicer Class Methods

[image]
ActiveReports 19 .NET Edition
ReportSlicer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicer Class

Glossary Item Box

For a list of all members of this type, see ReportSlicer members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Validate |
Top

See Also

Reference

ReportSlicer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As ReportSlicer
C#
public ReportSlicer Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : Validate Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


ReportSlicer Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSlicer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicer Class

Glossary Item Box

For a list of all members of this type, see ReportSlicer members.

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the default value to use for the slicer (if none is provided by the user).
Public Property | MultiValue | Gets or sets a value indicating whether multiple values for this parameter are allowed.
Public Property | Name | Gets or sets the name of the slicer (this is the name used when expressions refer to the slicer).
Top

See Also

Reference

ReportSlicer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultValue Property

[image]
ActiveReports 19 .NET Edition
DefaultValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : DefaultValue Property

Glossary Item Box

Gets or sets the default value to use for the slicer (if none is provided by the user).

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As DefaultValue
C#
public DefaultValue DefaultValue {get; set;}

Property Value

A DefaultValue object used to supply the slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


MultiValue Property

[image]
ActiveReports 19 .NET Edition
MultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : MultiValue Property

Glossary Item Box

Gets or sets a value indicating whether multiple values for this parameter are allowed.

Syntax

Visual Basic (Declaration)
Public Property MultiValue As Boolean
C#
public bool MultiValue {get; set;}

Property Value

A Boolean value where true indicates that multiple parameter values are allowed; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicer Class : Name Property

Glossary Item Box

Gets or sets the name of the slicer (this is the name used when expressions refer to the slicer).

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A String representing the name of the slicer.

Remarks

Slicer names need only be unique within the containing Slicers collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicer Class
ReportSlicer Members


ReportSlicersCollection Class

[image]
ActiveReports 19 .NET Edition
ReportSlicersCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicersCollection Class

Glossary Item Box

Represents a strongly typed collection of ReportSlicer objects.

Object Model

ReportSlicersCollection Class

Syntax

Visual Basic (Declaration)
Public Class ReportSlicersCollection
   Inherits System.Collections.ObjectModel.Collection(Of ReportSlicer)
C#
public class ReportSlicersCollection : System.Collections.ObjectModel.Collection<ReportSlicer>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.ReportSlicersCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicersCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSlicersCollection Class Members

[image]
ActiveReports 19 .NET Edition
ReportSlicersCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicersCollection Class

Glossary Item Box

The following tables list the members exposed by ReportSlicersCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportSlicersCollection Constructor |
Top

Public Methods

 | Name | Description
Public Method | Clone |
Top

See Also

Reference

ReportSlicersCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportSlicersCollection Constructor

[image]
ActiveReports 19 .NET Edition
ReportSlicersCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicersCollection Class : ReportSlicersCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportSlicersCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicersCollection Class
ReportSlicersCollection Members


ReportSlicersCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ReportSlicersCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportSlicersCollection Class

Glossary Item Box

For a list of all members of this type, see ReportSlicersCollection members.

Public Methods

 | Name | Description
Public Method | Clone |
Top

See Also

Reference

ReportSlicersCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportSlicersCollection Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicersCollection Class
ReportSlicersCollection Members


RoundingRadius Class

[image]
ActiveReports 19 .NET Edition
RoundingRadius Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

Glossary Item Box

Represents the rounding radius settings for the corners of a shape.

Object Model

RoundingRadius Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RoundingRadius
   Implements IValidateable
C#
public sealed class RoundingRadius : IValidateable

Remarks

The RoundingRadius class provides properties to define the corner rounding radii of a shape, allowing for customization of each corner individually or using a default value for all corners.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.RoundingRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Members
GrapeCity.ActiveReports.PageReportModel Namespace


RoundingRadius Class Members

[image]
ActiveReports 19 .NET Edition
RoundingRadius Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

Glossary Item Box

The following tables list the members exposed by RoundingRadius.

Public Constructors

 | Name | Description
Public Constructor | RoundingRadius Constructor | Initializes a new instance of the RoundingRadius class.
Top

Public Properties

 | Name | Description
Public Property | BottomLeft | Gets or sets the radius of the bottom-left corner.
Public Property | BottomRight | Gets or sets the radius of the bottom-right corner.
Public Property | Default | Gets or sets the default radius for the corner rounding.
Public Property | TopLeft | Gets or sets the radius of the top-left corner.
Public Property | TopRight | Gets or sets the radius of the top-right corner.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the RoundingRadius object.
Top

See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


RoundingRadius Constructor

[image]
ActiveReports 19 .NET Edition
RoundingRadius Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : RoundingRadius Constructor

Glossary Item Box

Initializes a new instance of the RoundingRadius class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RoundingRadius()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


RoundingRadius Class Methods

[image]
ActiveReports 19 .NET Edition
RoundingRadius Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

Glossary Item Box

For a list of all members of this type, see RoundingRadius members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the RoundingRadius object.
Top

See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the RoundingRadius object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


RoundingRadius Class Properties

[image]
ActiveReports 19 .NET Edition
RoundingRadius Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

Glossary Item Box

For a list of all members of this type, see RoundingRadius members.

Public Properties

 | Name | Description
Public Property | BottomLeft | Gets or sets the radius of the bottom-left corner.
Public Property | BottomRight | Gets or sets the radius of the bottom-right corner.
Public Property | Default | Gets or sets the default radius for the corner rounding.
Public Property | TopLeft | Gets or sets the radius of the top-left corner.
Public Property | TopRight | Gets or sets the radius of the top-right corner.
Top

See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomLeft Property

[image]
ActiveReports 19 .NET Edition
BottomLeft Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : BottomLeft Property

Glossary Item Box

Gets or sets the radius of the bottom-left corner.

Syntax

Visual Basic (Declaration)
Public Property BottomLeft As ExpressionInfo
C#
public ExpressionInfo BottomLeft {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the radius of the bottom-left corner.

Remarks

This value overrides the default radius for the bottom-left corner.

Example

C# Copy Code
roundingRadius.BottomLeft = "10pt";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


BottomRight Property

[image]
ActiveReports 19 .NET Edition
BottomRight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : BottomRight Property

Glossary Item Box

Gets or sets the radius of the bottom-right corner.

Syntax

Visual Basic (Declaration)
Public Property BottomRight As ExpressionInfo
C#
public ExpressionInfo BottomRight {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the radius of the bottom-right corner.

Remarks

This value overrides the default radius for the bottom-right corner.

Example

C# Copy Code
roundingRadius.BottomRight = "10pt";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : Default Property

Glossary Item Box

Gets or sets the default radius for the corner rounding.

Syntax

Visual Basic (Declaration)
Public Property Default As ExpressionInfo
C#
public ExpressionInfo Default {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the default rounding radius for the corners.

Remarks

This value is used unless overridden for a specific corner. The default value is 0.

Example

C# Copy Code
roundingRadius.Default = "5pt";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


TopLeft Property

[image]
ActiveReports 19 .NET Edition
TopLeft Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : TopLeft Property

Glossary Item Box

Gets or sets the radius of the top-left corner.

Syntax

Visual Basic (Declaration)
Public Property TopLeft As ExpressionInfo
C#
public ExpressionInfo TopLeft {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the radius of the top-left corner.

Remarks

This value overrides the default radius for the top-left corner.

Example

C# Copy Code
roundingRadius.TopLeft = "10pt";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


TopRight Property

[image]
ActiveReports 19 .NET Edition
TopRight Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : TopRight Property

Glossary Item Box

Gets or sets the radius of the top-right corner.

Syntax

Visual Basic (Declaration)
Public Property TopRight As ExpressionInfo
C#
public ExpressionInfo TopRight {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the radius of the top-right corner.

Remarks

This value overrides the default radius for the top-right corner.

Example

C# Copy Code
roundingRadius.TopRight = "10pt";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundingRadius Class
RoundingRadius Members


RowGrouping Class

[image]
ActiveReports 19 .NET Edition
RowGrouping Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

Glossary Item Box

Represents a row grouping for a matrix.

Object Model

RowGrouping Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RowGrouping
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class RowGrouping : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.RowGrouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


RowGrouping Class Members

[image]
ActiveReports 19 .NET Edition
RowGrouping Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

Glossary Item Box

The following tables list the members exposed by RowGrouping.

Public Constructors

 | Name | Description
Public Constructor | RowGrouping Constructor | Initializes a new instance of the RowGrouping class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DynamicRows | Gets or sets the dynamic row headings for the grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | StaticRows | Gets the static row headings for the grouping.
Public Property | Width | Gets or sets a width of the row header.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the RowGrouping object.
Top

See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


RowGrouping Constructor

[image]
ActiveReports 19 .NET Edition
RowGrouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : RowGrouping Constructor

Glossary Item Box

Initializes a new instance of the RowGrouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RowGrouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


RowGrouping Class Methods

[image]
ActiveReports 19 .NET Edition
RowGrouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

Glossary Item Box

For a list of all members of this type, see RowGrouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the RowGrouping object.
Top

See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the RowGrouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


RowGrouping Class Properties

[image]
ActiveReports 19 .NET Edition
RowGrouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

Glossary Item Box

For a list of all members of this type, see RowGrouping members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DynamicRows | Gets or sets the dynamic row headings for the grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | StaticRows | Gets the static row headings for the grouping.
Public Property | Width | Gets or sets a width of the row header.
Top

See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


DynamicRows Property

[image]
ActiveReports 19 .NET Edition
DynamicRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : DynamicRows Property

Glossary Item Box

Gets or sets the dynamic row headings for the grouping.

Syntax

Visual Basic (Declaration)
Public Property DynamicRows As DynamicColumnsRows
C#
public DynamicColumnsRows DynamicRows {get; set;}

Property Value

A DynamicColumnsRows object containing the dynamic row headings for this grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


FixedHeader Property

[image]
ActiveReports 19 .NET Edition
FixedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : FixedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedHeader As Boolean
C#
public bool FixedHeader {get; set;}

Property Value

A System.Boolean value where true indicates the grouping should be displayed on the page even when the user scrolls part of the matrix off the page; otherwise false. The default value is false.

Remarks

Fixed headers must be touching each other and must also include the outermost grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


StaticRows Property

[image]
ActiveReports 19 .NET Edition
StaticRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : StaticRows Property

Glossary Item Box

Gets the static row headings for the grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticRows As StaticRowColumnCollection
C#
public StaticRowColumnCollection StaticRows {get;}

Property Value

A StaticRowColumnCollection object containing the static row headings for the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Width Property

Glossary Item Box

Gets or sets a width of the row header.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the row header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGrouping Class
RowGrouping Members


RowGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
RowGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

Glossary Item Box

Represents a strongly typed collection of RowGrouping objects.

Object Model

RowGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RowGroupingCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of RowGrouping)
C#
public sealed class RowGroupingCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<RowGrouping>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.RowGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


RowGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
RowGroupingCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by RowGroupingCollection.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Get a new instance of the RowGroupingCollection class.
Top

See Also

Reference

RowGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


RowGroupingCollection Class Methods

[image]
ActiveReports 19 .NET Edition
RowGroupingCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

Glossary Item Box

For a list of all members of this type, see RowGroupingCollection members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Get a new instance of the RowGroupingCollection class.
Top

See Also

Reference

RowGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Create Method

Glossary Item Box

Get a new instance of the RowGroupingCollection class.

Syntax

Visual Basic (Declaration)
Public Shared Function Create() As RowGroupingCollection
C#
public static RowGroupingCollection Create()

Return Value

A newly instance of RowGroupingCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


SeriesGrouping Class

[image]
ActiveReports 19 .NET Edition
SeriesGrouping Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

Glossary Item Box

The SeriesGrouping element defines a Series level for a chart SeriesGrouping. The labels for the series are displayed in the legend.

Object Model

SeriesGrouping Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SeriesGrouping
   Inherits ReportComponent
   Implements IReportComponent, IValidateable
C#
public sealed class SeriesGrouping : ReportComponent, IReportComponent, IValidateable

Remarks

A SeriesGrouping must have a defined DynamicSeries, a defined StaticSeries, or both.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.SeriesGrouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGrouping Class Members

[image]
ActiveReports 19 .NET Edition
SeriesGrouping Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

Glossary Item Box

The following tables list the members exposed by SeriesGrouping.

Public Constructors

 | Name | Description
Public Constructor | SeriesGrouping Constructor | Initializes a new instance of the SeriesGrouping class.
Top

Public Properties

 | Name | Description
Public Property | DynamicSeries | Gets the dynamic series headings for the grouping.
Public Property | StaticSeries | Gets the static series headings for the grouping.
Public Property | Style | Gets or sets the border and background style properties for the series legend items(s) and data points in the series.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the SeriesGrouping object.
Top

See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGrouping Constructor

[image]
ActiveReports 19 .NET Edition
SeriesGrouping Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : SeriesGrouping Constructor

Glossary Item Box

Initializes a new instance of the SeriesGrouping class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SeriesGrouping()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGrouping Class Methods

[image]
ActiveReports 19 .NET Edition
SeriesGrouping Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

Glossary Item Box

For a list of all members of this type, see SeriesGrouping members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the SeriesGrouping object.
Top

See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the SeriesGrouping object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGrouping Class Properties

[image]
ActiveReports 19 .NET Edition
SeriesGrouping Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

Glossary Item Box

For a list of all members of this type, see SeriesGrouping members.

Public Properties

 | Name | Description
Public Property | DynamicSeries | Gets the dynamic series headings for the grouping.
Public Property | StaticSeries | Gets the static series headings for the grouping.
Public Property | Style | Gets or sets the border and background style properties for the series legend items(s) and data points in the series.
Top

See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicSeries Property

[image]
ActiveReports 19 .NET Edition
DynamicSeries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : DynamicSeries Property

Glossary Item Box

Gets the dynamic series headings for the grouping.

Syntax

Visual Basic (Declaration)
Public Property DynamicSeries As DynamicCategoriesSeries
C#
public DynamicCategoriesSeries DynamicSeries {get; set;}

Property Value

A DynamicCategoriesSeries containing dynamic series headings for the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


StaticSeries Property

[image]
ActiveReports 19 .NET Edition
StaticSeries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : StaticSeries Property

Glossary Item Box

Gets the static series headings for the grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StaticSeries As StaticMemberCollection
C#
public StaticMemberCollection StaticSeries {get;}

Property Value

A StaticMemberCollection containing static series headings for the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Style Property

Glossary Item Box

Gets or sets the border and background style properties for the series legend items(s) and data points in the series.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the series legend items(s) and data points in the series.

Remarks

Style expressions are evaluated for each group instance when applied to DynamicSeries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
SeriesGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

Glossary Item Box

Represents a strongly typed collection of SeriesGrouping objects.

Object Model

SeriesGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SeriesGroupingCollection
   Inherits System.Collections.ObjectModel.Collection(Of SeriesGrouping)
C#
public sealed class SeriesGroupingCollection : System.Collections.ObjectModel.Collection<SeriesGrouping>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.SeriesGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
SeriesGroupingCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by SeriesGroupingCollection.

Public Constructors

 | Name | Description
Public Constructor | SeriesGroupingCollection Constructor | Initializes a new instance of the SeriesGroupingCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of SeriesGrouping objects to the existing SeriesGroupingCollection.
Top

See Also

Reference

SeriesGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGroupingCollection Constructor

[image]
ActiveReports 19 .NET Edition
SeriesGroupingCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : SeriesGroupingCollection Constructor

Glossary Item Box

Initializes a new instance of the SeriesGroupingCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SeriesGroupingCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


SeriesGroupingCollection Class Methods

[image]
ActiveReports 19 .NET Edition
SeriesGroupingCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

Glossary Item Box

For a list of all members of this type, see SeriesGroupingCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of SeriesGrouping objects to the existing SeriesGroupingCollection.
Top

See Also

Reference

SeriesGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : AddRange Method

collection
A collection of the SeriesGrouping objects to add.

Glossary Item Box

Adds a collection of SeriesGrouping objects to the existing SeriesGroupingCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of SeriesGrouping) _
)
C#
public void AddRange(
   IEnumerable<SeriesGrouping> collection
)

Parameters

collection
A collection of the SeriesGrouping objects to add.

Example

C# Copy Code
SeriesGroupingCollection collection1 = new SeriesGroupingCollection();
SeriesGroupingCollection collection2 = new SeriesGroupingCollection();
collection2.Add(new SeriesGrouping());
collection1.AddRange(collection2);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Shape Class

[image]
ActiveReports 19 .NET Edition
Shape Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

Glossary Item Box

Represents a shape ReportItem within the report definition.

Object Model

Shape Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Shape
   Inherits ShapeBase
   Implements IReportComponent, IValidateable
C#
public sealed class Shape : ShapeBase, IReportComponent, IValidateable

Remarks

The Shape class is a sealed class that extends the ShapeBase class, providing additional properties for accessibility.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.ShapeBase
GrapeCity.ActiveReports.PageReportModel.Shape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Members
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Class Members

[image]
ActiveReports 19 .NET Edition
Shape Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

Glossary Item Box

The following tables list the members exposed by Shape.

Public Constructors

 | Name | Description
Public Constructor | Shape Constructor | Initializes a new instance of the Shape class.
Top

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications.
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Constructor

[image]
ActiveReports 19 .NET Edition
Shape Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Shape Constructor

Glossary Item Box

Initializes a new instance of the Shape class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Shape()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Shape Class Properties

[image]
ActiveReports 19 .NET Edition
Shape Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

Glossary Item Box

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications.
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As ExpressionInfo
C#
public ExpressionInfo AccessibleDescription {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the accessible description of the shape.

Example

C# Copy Code
Shape shape = new Shape();
shape.AccessibleDescription = "This is a rectangle shape.";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


ShapeBase Class

[image]
ActiveReports 19 .NET Edition
ShapeBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ShapeBase Class

Glossary Item Box

Represents the base class for different shapes in a report.

Object Model

ShapeBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ShapeBase
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public abstract class ShapeBase : ReportItem, IReportComponent, IValidateable

Remarks

This abstract class serves as the foundation for all shape types in the report, providing common properties such as RoundingRadius and ShapeStyle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.ShapeBase
GrapeCity.ActiveReports.PageReportModel.Container
GrapeCity.ActiveReports.PageReportModel.Shape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeBase Members
GrapeCity.ActiveReports.PageReportModel Namespace


ShapeBase Class Members

[image]
ActiveReports 19 .NET Edition
ShapeBase Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ShapeBase Class

Glossary Item Box

The following tables list the members exposed by ShapeBase.

Public Properties

 | Name | Description
Public Property | RoundingRadius | Gets or sets the rounding radius of the shape.
Public Property | ShapeStyle | Gets or sets the style of the shape, which should be a ShapeStyle.
Top

See Also

Reference

ShapeBase Class
GrapeCity.ActiveReports.PageReportModel Namespace


ShapeBase Class Properties

[image]
ActiveReports 19 .NET Edition
ShapeBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ShapeBase Class

Glossary Item Box

For a list of all members of this type, see ShapeBase members.

Public Properties

 | Name | Description
Public Property | RoundingRadius | Gets or sets the rounding radius of the shape.
Public Property | ShapeStyle | Gets or sets the style of the shape, which should be a ShapeStyle.
Top

See Also

Reference

ShapeBase Class
GrapeCity.ActiveReports.PageReportModel Namespace


RoundingRadius Property

[image]
ActiveReports 19 .NET Edition
RoundingRadius Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ShapeBase Class : RoundingRadius Property

Glossary Item Box

Gets or sets the rounding radius of the shape.

Syntax

Visual Basic (Declaration)
Public Property RoundingRadius As RoundingRadius
C#
public RoundingRadius RoundingRadius {get; set;}

Property Value

A RoundingRadius object representing the rounding radius of the shape.

Example

C# Copy Code
var shape = new Shape();
shape.RoundingRadius = new RoundingRadius { Default = "12pt" };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeBase Class
ShapeBase Members


ShapeStyle Property

[image]
ActiveReports 19 .NET Edition
ShapeStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ShapeBase Class : ShapeStyle Property

Glossary Item Box

Gets or sets the style of the shape, which should be a ShapeStyle.

Syntax

Visual Basic (Declaration)
Public Property ShapeStyle As ExpressionInfo
C#
public ExpressionInfo ShapeStyle {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the style of the shape.

Example

C# Copy Code
var shape = new Shape();
shape.ShapeStyle = "Rectangle";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeBase Class
ShapeBase Members


SharedDataSet Class

[image]
ActiveReports 19 .NET Edition
SharedDataSet Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

Glossary Item Box

Represents a shared dataset used across multiple reports.

Object Model

SharedDataSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SharedDataSet
   Implements IValidateable
C#
public sealed class SharedDataSet : IValidateable

Remarks

A shared dataset is a predefined dataset that can be used by multiple reports to ensure consistent data retrieval and reduce redundancy.

Example

C# Copy Code
SharedDataSet sharedDataSet = new SharedDataSet();
sharedDataSet.SharedDataSetReference = "/SharedDataSets/SalesData";
sharedDataSet.QueryParameterCollection.Add(new QueryParameter { Name = "StartDate", Value = "=Parameters!StartDate.Value" });

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SharedDataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


SharedDataSet Class Members

[image]
ActiveReports 19 .NET Edition
SharedDataSet Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

Glossary Item Box

The following tables list the members exposed by SharedDataSet.

Public Constructors

 | Name | Description
Public Constructor | SharedDataSet Constructor | Initializes a new instance of the SharedDataSet class.
Top

Public Properties

 | Name | Description
Public Property | QueryParameters | Gets a collection of query parameters used by the shared dataset.
Public Property | SharedDataSetReference | Gets or sets the reference to a shared dataset.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SharedDataSet object.
Top

See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


SharedDataSet Constructor

[image]
ActiveReports 19 .NET Edition
SharedDataSet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : SharedDataSet Constructor

Glossary Item Box

Initializes a new instance of the SharedDataSet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SharedDataSet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSet Class Methods

[image]
ActiveReports 19 .NET Edition
SharedDataSet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

Glossary Item Box

For a list of all members of this type, see SharedDataSet members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SharedDataSet object.
Top

See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the SharedDataSet object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSet Class Properties

[image]
ActiveReports 19 .NET Edition
SharedDataSet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

Glossary Item Box

For a list of all members of this type, see SharedDataSet members.

Public Properties

 | Name | Description
Public Property | QueryParameters | Gets a collection of query parameters used by the shared dataset.
Public Property | SharedDataSetReference | Gets or sets the reference to a shared dataset.
Top

See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameters Property

[image]
ActiveReports 19 .NET Edition
QueryParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : QueryParameters Property

Glossary Item Box

Gets a collection of query parameters used by the shared dataset.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryParameters As QueryParameterCollection
C#
public QueryParameterCollection QueryParameters {get;}

Property Value

A QueryParameterCollection object containing the query parameters for the shared dataset.

Remarks

Query parameters are used to filter and modify the data retrieved by the shared dataset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSetReference Property

[image]
ActiveReports 19 .NET Edition
SharedDataSetReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : SharedDataSetReference Property

Glossary Item Box

Gets or sets the reference to a shared dataset.

Syntax

Visual Basic (Declaration)
Public Property SharedDataSetReference As String
C#
public string SharedDataSetReference {get; set;}

Property Value

A String containing the reference to the shared dataset.

Remarks

This reference is used to locate the shared dataset definition stored on the report server.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSet Class
SharedDataSet Members


SliceAction Class

[image]
ActiveReports 19 .NET Edition
SliceAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SliceAction Class

Glossary Item Box

Represents an element that defines a Slice action associated with an Action.

Object Model

SliceAction Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SliceAction
   Implements IValidateable
C#
public sealed class SliceAction : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SliceAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SliceAction Members
GrapeCity.ActiveReports.PageReportModel Namespace


SliceAction Class Members

[image]
ActiveReports 19 .NET Edition
SliceAction Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SliceAction Class

Glossary Item Box

The following tables list the members exposed by SliceAction.

Public Constructors

 | Name | Description
Public Constructor | SliceAction Constructor |
Top

Public Properties

 | Name | Description
Public Property | Slicers | Gets the collection of slicers to be applied within this action.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SliceAction object.
Top

See Also

Reference

SliceAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


SliceAction Constructor

[image]
ActiveReports 19 .NET Edition
SliceAction Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SliceAction Class : SliceAction Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SliceAction()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SliceAction Class
SliceAction Members


SliceAction Class Methods

[image]
ActiveReports 19 .NET Edition
SliceAction Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SliceAction Class

Glossary Item Box

For a list of all members of this type, see SliceAction members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SliceAction object.
Top

See Also

Reference

SliceAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SliceAction Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the SliceAction object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SliceAction Class
SliceAction Members


SliceAction Class Properties

[image]
ActiveReports 19 .NET Edition
SliceAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SliceAction Class

Glossary Item Box

For a list of all members of this type, see SliceAction members.

Public Properties

 | Name | Description
Public Property | Slicers | Gets the collection of slicers to be applied within this action.
Top

See Also

Reference

SliceAction Class
GrapeCity.ActiveReports.PageReportModel Namespace


Slicers Property

[image]
ActiveReports 19 .NET Edition
Slicers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SliceAction Class : Slicers Property

Glossary Item Box

Gets the collection of slicers to be applied within this action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Slicers As SlicersCollection
C#
public SlicersCollection Slicers {get;}

Property Value

A SlicersCollection object containing the slicers for this action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SliceAction Class
SliceAction Members


Slicer Class

[image]
ActiveReports 19 .NET Edition
Slicer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slicer Class

Glossary Item Box

Represents the parameters for a single slicer action.

Object Model

Slicer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Slicer
C#
public sealed class Slicer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Slicer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slicer Members
GrapeCity.ActiveReports.PageReportModel Namespace


Slicer Class Members

[image]
ActiveReports 19 .NET Edition
Slicer Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slicer Class

Glossary Item Box

The following tables list the members exposed by Slicer.

Public Constructors

 | Name | Description
Public Constructor | Slicer Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the report slicer to be affected.
Public Property | Type | Gets or sets the type of the slice action.
Public Property | Value | Gets or sets the value for the slicer.
Top

See Also

Reference

Slicer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Slicer Constructor

[image]
ActiveReports 19 .NET Edition
Slicer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slicer Class : Slicer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Slicer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slicer Class
Slicer Members


Slicer Class Properties

[image]
ActiveReports 19 .NET Edition
Slicer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slicer Class

Glossary Item Box

For a list of all members of this type, see Slicer members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the report slicer to be affected.
Public Property | Type | Gets or sets the type of the slice action.
Public Property | Value | Gets or sets the value for the slicer.
Top

See Also

Reference

Slicer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slicer Class : Name Property

Glossary Item Box

Gets or sets the name of the report slicer to be affected.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slicer Class
Slicer Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slicer Class : Type Property

Glossary Item Box

Gets or sets the type of the slice action.

Syntax

Visual Basic (Declaration)
Public Property Type As SliceType
C#
public SliceType Type {get; set;}

Property Value

A SliceType value indicating the type of the slice action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slicer Class
Slicer Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slicer Class : Value Property

Glossary Item Box

Gets or sets the value for the slicer.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the slicer value.

Remarks

Must be specified for the SliceType.Set and SliceType.Toggle types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slicer Class
Slicer Members


SlicersCollection Class

[image]
ActiveReports 19 .NET Edition
SlicersCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SlicersCollection Class

Glossary Item Box

Represents a collection of slicers for the 'Slice' action.

Object Model

SlicersCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SlicersCollection
   Inherits System.Collections.ObjectModel.Collection(Of Slicer)
C#
public sealed class SlicersCollection : System.Collections.ObjectModel.Collection<Slicer>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.SlicersCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicersCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


SlicersCollection Class Members

[image]
ActiveReports 19 .NET Edition
SlicersCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SlicersCollection Class

Glossary Item Box

The following tables list the members exposed by SlicersCollection.

Public Constructors

 | Name | Description
Public Constructor | SlicersCollection Constructor |
Top

See Also

Reference

SlicersCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


SlicersCollection Constructor

[image]
ActiveReports 19 .NET Edition
SlicersCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SlicersCollection Class : SlicersCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SlicersCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicersCollection Class
SlicersCollection Members


Slider Class

[image]
ActiveReports 19 .NET Edition
Slider Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slider Class

Glossary Item Box

Represents a slider in a navigation control.

Object Model

Slider Class

Syntax

Visual Basic (Declaration)
Public Class Slider
C#
public class Slider

Remarks

The Slider class provides settings for a navigation slider, including visibility and label data.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Slider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slider Members
GrapeCity.ActiveReports.PageReportModel Namespace


Slider Class Members

[image]
ActiveReports 19 .NET Edition
Slider Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slider Class

Glossary Item Box

The following tables list the members exposed by Slider.

Public Constructors

 | Name | Description
Public Constructor | Slider Constructor |
Top

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets a value indicating whether the slider is hidden.
Public Property | LabelData | Gets or sets a data used to populate the labels for the slider.
Top

See Also

Reference

Slider Class
GrapeCity.ActiveReports.PageReportModel Namespace


Slider Constructor

[image]
ActiveReports 19 .NET Edition
Slider Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slider Class : Slider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Slider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slider Class
Slider Members


Slider Class Properties

[image]
ActiveReports 19 .NET Edition
Slider Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Slider Class

Glossary Item Box

For a list of all members of this type, see Slider members.

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets a value indicating whether the slider is hidden.
Public Property | LabelData | Gets or sets a data used to populate the labels for the slider.
Top

See Also

Reference

Slider Class
GrapeCity.ActiveReports.PageReportModel Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slider Class : Hidden Property

Glossary Item Box

Gets or sets a value indicating whether the slider is hidden.

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden {get; set;}

Property Value

A System.Boolean value where true if the slider is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slider Class
Slider Members


LabelData Property

[image]
ActiveReports 19 .NET Edition
LabelData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Slider Class : LabelData Property

Glossary Item Box

Gets or sets a data used to populate the labels for the slider.

Syntax

Visual Basic (Declaration)
Public Property LabelData As LabelData
C#
public LabelData LabelData {get; set;}

Property Value

A LabelData object representing the label data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Slider Class
Slider Members


SortBy Class

[image]
ActiveReports 19 .NET Edition
SortBy Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

Glossary Item Box

Represents an element that defines an expression by which to sort the groups.

Object Model

SortBy Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SortBy
   Implements IValidateable
C#
public sealed class SortBy : IValidateable

Example

An example of creating a simple sorting:
C# Copy Code
var sortBy = new SortBy { SortExpression = { "=Fields!Type.Value" }, Direction = SortByDirection.Descending };

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SortBy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Members
GrapeCity.ActiveReports.PageReportModel Namespace


SortBy Class Members

[image]
ActiveReports 19 .NET Edition
SortBy Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

Glossary Item Box

The following tables list the members exposed by SortBy.

Public Constructors

 | Name | Description
Public Constructor | SortBy Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Direction | Gets or sets a direction of the sort.
Public Property | SortExpression | Gets or sets an expression by which to sort the groups.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SortBy object.
Top

See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortBy Constructor

[image]
ActiveReports 19 .NET Edition
SortBy Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : SortBy Constructor

Glossary Item Box

Overload List

Overload | Description
SortBy Constructor() | Initializes a new instance of the SortBy class.
SortBy Constructor(ExpressionInfo,SortByDirection) | Initializes a new instance of the SortBy class using a specified sort expression and direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members


SortBy Constructor()

[image]
ActiveReports 19 .NET Edition
SortBy Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class > SortBy Constructor : SortBy Constructor()

Glossary Item Box

Initializes a new instance of the SortBy class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SortBy()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members
Overload List


SortBy Constructor(ExpressionInfo,SortByDirection)

[image]
ActiveReports 19 .NET Edition
SortBy Constructor(ExpressionInfo,SortByDirection)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class > SortBy Constructor : SortBy Constructor(ExpressionInfo,SortByDirection)

sortExpression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object by which to sort for.
direction
A SortByDirection value indicating the initial sorting direction.

Glossary Item Box

Initializes a new instance of the SortBy class using a specified sort expression and direction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sortExpression As ExpressionInfo, _
   ByVal direction As SortByDirection _
)
C#
public SortBy(
   ExpressionInfo sortExpression,
   SortByDirection direction
)

Parameters

sortExpression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object by which to sort for.
direction
A SortByDirection value indicating the initial sorting direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members
Overload List


SortBy Class Methods

[image]
ActiveReports 19 .NET Edition
SortBy Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

Glossary Item Box

For a list of all members of this type, see SortBy members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the SortBy object.
Top

See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the SortBy object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members


SortBy Class Properties

[image]
ActiveReports 19 .NET Edition
SortBy Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

Glossary Item Box

For a list of all members of this type, see SortBy members.

Public Properties

 | Name | Description
Public Property | Direction | Gets or sets a direction of the sort.
Public Property | SortExpression | Gets or sets an expression by which to sort the groups.
Top

See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : Direction Property

Glossary Item Box

Gets or sets a direction of the sort.

Syntax

Visual Basic (Declaration)
Public Property Direction As SortByDirection
C#
public SortByDirection Direction {get; set;}

Property Value

A SortByDirection value indicating the direction of the sort.

Remarks

Default value is SortByDirection.Ascending.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members


SortExpression Property

[image]
ActiveReports 19 .NET Edition
SortExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : SortExpression Property

Glossary Item Box

Gets or sets an expression by which to sort the groups.

Syntax

Visual Basic (Declaration)
Public Property SortExpression As ExpressionInfo
C#
public ExpressionInfo SortExpression {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object by which to sort the groups.

Remarks

The aggregate functions RunningValue and RowNumber are not allowed in a SortExpression.

References to report items are not allowed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBy Class
SortBy Members


SortByCollection Class

[image]
ActiveReports 19 .NET Edition
SortByCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

Glossary Item Box

Represents a strongly typed collection of SortBy objects.

Object Model

SortByCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SortByCollection
   Inherits System.Collections.ObjectModel.Collection(Of SortBy)
   Implements IValidateable
C#
public sealed class SortByCollection : System.Collections.ObjectModel.Collection<SortBy>, IValidateable

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.SortByCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortByCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


SortByCollection Class Members

[image]
ActiveReports 19 .NET Edition
SortByCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

Glossary Item Box

The following tables list the members exposed by SortByCollection.

Public Constructors

 | Name | Description
Public Constructor | SortByCollection Constructor | Initializes a new instance of the SortByCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of SortBy objects to the existing SortByCollection.
Public Method | ToArray | Copies the elements of the SortByCollection to a new array.
Public Method | Validate | Validates the current state of the SortByCollection object.
Top

See Also

Reference

SortByCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortByCollection Constructor

[image]
ActiveReports 19 .NET Edition
SortByCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : SortByCollection Constructor

Glossary Item Box

Initializes a new instance of the SortByCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SortByCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortByCollection Class
SortByCollection Members


SortByCollection Class Methods

[image]
ActiveReports 19 .NET Edition
SortByCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

Glossary Item Box

For a list of all members of this type, see SortByCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of SortBy objects to the existing SortByCollection.
Public Method | ToArray | Copies the elements of the SortByCollection to a new array.
Public Method | Validate | Validates the current state of the SortByCollection object.
Top

See Also

Reference

SortByCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : AddRange Method

items
A collection of the SortBy objects to add.

Glossary Item Box

Adds a collection of SortBy objects to the existing SortByCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items As IEnumerable(Of SortBy) _
)
C#
public void AddRange(
   IEnumerable<SortBy> items
)

Parameters

items
A collection of the SortBy objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortByCollection Class
SortByCollection Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : ToArray Method

Glossary Item Box

Copies the elements of the SortByCollection to a new array.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As SortBy()
C#
public SortBy[] ToArray()

Return Value

An array of SortBy objects containing copies of the elements in the SortByCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortByCollection Class
SortByCollection Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the SortByCollection object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortByCollection Class
SortByCollection Members


StaticMember Class

[image]
ActiveReports 19 .NET Edition
StaticMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

Glossary Item Box

Defines the data label to display for a static series or static category member.

Object Model

StaticMember Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticMember
   Implements IValidateable
C#
public sealed class StaticMember : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StaticMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMember Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMember Class Members

[image]
ActiveReports 19 .NET Edition
StaticMember Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

Glossary Item Box

The following tables list the members exposed by StaticMember.

Public Constructors

 | Name | Description
Public Constructor | StaticMember Constructor | Initializes a new instance of the StaticMember class.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the StaticMember object.
Top

See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMember Constructor

[image]
ActiveReports 19 .NET Edition
StaticMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : StaticMember Constructor

Glossary Item Box

Initializes a new instance of the StaticMember class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StaticMember()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMember Class
StaticMember Members


StaticMember Class Methods

[image]
ActiveReports 19 .NET Edition
StaticMember Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

Glossary Item Box

For a list of all members of this type, see StaticMember members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the StaticMember object.
Top

See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the StaticMember object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMember Class
StaticMember Members


StaticMember Class Properties

[image]
ActiveReports 19 .NET Edition
StaticMember Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

Glossary Item Box

For a list of all members of this type, see StaticMember members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).
Top

See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : Label Property

Glossary Item Box

Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).

Syntax

Visual Basic (Declaration)
Public Property Label As ExpressionInfo
C#
public ExpressionInfo Label {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object indicating the label for the static member (displayed either on the category axis or in the legend, as appropriate).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMember Class
StaticMember Members


StaticMemberCollection Class

[image]
ActiveReports 19 .NET Edition
StaticMemberCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

Glossary Item Box

Represents a strongly typed collection of StaticMember objects.

Object Model

StaticMemberCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticMemberCollection
   Inherits System.Collections.ObjectModel.Collection(Of StaticMember)
C#
public sealed class StaticMemberCollection : System.Collections.ObjectModel.Collection<StaticMember>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.StaticMemberCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMemberCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMemberCollection Class Members

[image]
ActiveReports 19 .NET Edition
StaticMemberCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

Glossary Item Box

The following tables list the members exposed by StaticMemberCollection.

Public Constructors

 | Name | Description
Public Constructor | StaticMemberCollection Constructor | Initializes a new instance of the StaticMemberCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of StaticMember objects to the existing StaticMemberCollection.
Top

See Also

Reference

StaticMemberCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMemberCollection Constructor

[image]
ActiveReports 19 .NET Edition
StaticMemberCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : StaticMemberCollection Constructor

Glossary Item Box

Initializes a new instance of the StaticMemberCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StaticMemberCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


StaticMemberCollection Class Methods

[image]
ActiveReports 19 .NET Edition
StaticMemberCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

Glossary Item Box

For a list of all members of this type, see StaticMemberCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of StaticMember objects to the existing StaticMemberCollection.
Top

See Also

Reference

StaticMemberCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : AddRange Method

collection
A collection of the StaticMember objects to add.

Glossary Item Box

Adds a collection of StaticMember objects to the existing StaticMemberCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of StaticMember) _
)
C#
public void AddRange(
   IEnumerable<StaticMember> collection
)

Parameters

collection
A collection of the StaticMember objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


StaticRowColumn Class

[image]
ActiveReports 19 .NET Edition
StaticRowColumn Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

Glossary Item Box

Represents a column or row header region with a fixed set of columns or rows.

Object Model

StaticRowColumn Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticRowColumn
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class StaticRowColumn : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Remarks

Only one ColumnGrouping in each matrix may be static.

Only one RowGrouping in each matrix may be static.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.StaticRowColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticRowColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumn Class Members

[image]
ActiveReports 19 .NET Edition
StaticRowColumn Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

Glossary Item Box

The following tables list the members exposed by StaticRowColumn.

Public Constructors

 | Name | Description
Public Constructor | StaticRowColumn Constructor | Initializes a new instance of the StaticRowColumn class.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the StaticRowColumn object.
Top

See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumn Constructor

[image]
ActiveReports 19 .NET Edition
StaticRowColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : StaticRowColumn Constructor

Glossary Item Box

Initializes a new instance of the StaticRowColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StaticRowColumn()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


StaticRowColumn Class Methods

[image]
ActiveReports 19 .NET Edition
StaticRowColumn Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

Glossary Item Box

For a list of all members of this type, see StaticRowColumn members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the StaticRowColumn object.
Top

See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the StaticRowColumn object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


StaticRowColumnCollection Class

[image]
ActiveReports 19 .NET Edition
StaticRowColumnCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class

Glossary Item Box

Represents a strongly typed collection of StaticRowColumn objects.

Object Model

StaticRowColumnCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticRowColumnCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of StaticRowColumn)
C#
public sealed class StaticRowColumnCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<StaticRowColumn>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.StaticRowColumnCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StaticRowColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumnCollection Class Members

[image]
ActiveReports 19 .NET Edition
StaticRowColumnCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class

Glossary Item Box

The following tables list the members exposed by StaticRowColumnCollection.

See Also

Reference

StaticRowColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Style Class

[image]
ActiveReports 19 .NET Edition
Style Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

Glossary Item Box

The Style element contains information about the style of a report item. Where possible, the style property names and values match standard HTML/CSS properties. All expression-based Style elements evaluate to either the type listed or to Nothing (an error in evaluation is treated as Nothing). Nothing is equivalent to not specifying the style, thereby indicating that it uses the default value. The epxression must evaluate to a Boolean value for Boolean properties, an enumerated value for enum properties, an integer for integer properties and a (formatted) string for all other properties.

Object Model

Style Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Style
   Implements IValidateable
C#
public sealed class Style : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Members
GrapeCity.ActiveReports.PageReportModel Namespace


Style Class Members

[image]
ActiveReports 19 .NET Edition
Style Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

Glossary Item Box

The following tables list the members exposed by Style.

Public Constructors

 | Name | Description
Public Constructor | Style Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | AngleDefault | The default value for the Angle property.
Public Field | BackgroundColorDefault | The default value for the BackgroundColor property.
Public Field | BackgroundGradientEndColorDefault | The default value for the BackgroundGradientEndColor property.
Public Field | BackgroundGradientTypeDefault | The default value for the BackgroundGradientType property.
Public Field | BorderColorDefault | The default value for the BorderColor property.
Public Field | BorderStyleDefault | The default value for the BorderStyle property.
Public Field | BorderWidthDefault | The default value for the BorderWidth property.
Public Field | CharacterSpacingDefault | The default value for the CharacterSpacing property.
Public Field | ColorDefault | The default value for the Color property.
static (Shared in Visual Basic) | DefaultStyle | The singleton default Style object.
Public Field | DirectionDefault | The default value for the Direction property.
Public Field | FontFamilyDefault | The default value for the FontFamily property.
Public Field | FontSizeDefault | The default value for the FontSize property.
Public Field | FontStyleDefault | The default value for the FontStyle property.
Public Field | FontWeightDefault | The default value for the FontWeight property.
Public Field | HeadingLevelDefault | The default value for the HeadingLevel property.
Public Field | InheritedValue | The special value for a property of style which indicates that the value should be evaluated from parent style.
Public Field | LabelExpressionDefault | The default value for the LabelExpression property.
Public Field | LeadingCharDefault | The default value for the LeadingChar property.
Public Field | LineBorderStyleDefault | The default value for the BorderStyle line property.
Public Field | MaxLevelDefault | The default value for the MaxLevel property.
Public Field | MinCondenseRateDefault | The default value for the MinCondenseRate property.
static (Shared in Visual Basic) | MinTextIndent | The minimum value for the TextIndent property.
Public Field | NumberingStyleDefault | The default value for the NumberingStyle property.
Public Field | ShadowOffsetDefault | The default value for the ShadowOffset property.
Public Field | ShrinkToFitDefault | The default value for the ShrinkToFit property.
Public Field | TextAlignDefault | The default value for the TextAlign property.
Public Field | TextDecorationDefault | The default value for the TextDecoration property.
Public Field | TextIndentDefault | The default value for the TextIndent property.
Public Field | TextJustifyDefault | The default value for the TextJustify property.
Public Field | UprightInVerticalTextDefault | The default value for the UprightInVerticalText property.
Public Field | VerticalAlignDefault | The default value for the VerticalAlign property.
Public Field | WrapModeDefault | The default value for the WrapMode property.
Public Field | WritingModeDefault | The default value for the WritingMode property.
Top

Public Properties

 | Name | Description
Public Property | Angle | Gets or sets a number of degrees the text is rorated counter-clockwise.
Public Property | BackgroundColor | Gets or sets a color of the background.
Public Property | BackgroundGradientEndColor | Gets or sets an end color for the background gradient.
Public Property | BackgroundGradientType | Gets or sets a gradient type of the background.
Public Property | BackgroundHatchType | Gets or sets a hatching pattern of a report item.
Public Property | BackgroundImage | Gets a background image for the report item.
Public Property | Border | Gets or sets the default border properties, such as color, style and width.
Public Property | BorderColor | Gets a color of the border, containing the default color or color for each side of the border.
Public Property | BorderStyle | Gets a style of the border, containing the default style or style for each side of the border.
Public Property | BorderWidth | Gets a width of the border, containing the default width or width for each side of the border.
Public Property | BottomBorder | Gets or sets the bottom border properties, such as color, style and width.
Public Property | Calendar | Gets or sets a calendar used for formatting dates.
Public Property | CharacterSpacing | Gets or sets a spacing between characters.
Public Property | Color | Gets or sets a color of the text.
Public Property | Direction | Specifies the direction.
Public Property | FontFamily | Gets or sets a name of the font family.
Public Property | FontSize | Gets or sets a size of the font in Length.Unit.Points units.
Public Property | FontStyle | Gets or sets a style of the font.
Public Property | FontWeight | Gets or sets a thickness of the font.
Public Property | Format | Gets or sets a .NET Framework formatting string.
Public Property | HeadingLevel | Gets or sets a heading level of the table of contents.
Public Property | LabelExpression | Gets or sets an expression for label of the table of contents.
Public Property | Language | Gets or sets the primary language of the text.
Public Property | LeadingChar | Gets or sets an leading char for label of the table of contents.
Public Property | LeftBorder | Gets or sets the left border properties, such as color, style and width.
Public Property | LineHeight | Gets or sets a line height (leading).
Public Property | LineSpacing | Gets or sets a spacing between lines.
Public Property | MaxLevel | Gets or sets a maximum depth of the table of contents.
Public Property | MinCondenseRate | Gets or sets a minimum character condense rate value.
Public Property | Name | Gets or sets a name of the style.
Public Property | NumberingStyle | Gets or sets a numbering style for headings of the table of contents.
Public Property | NumeralLanguage | Gets or sets a digit format to use as described by its primary language.
Public Property | NumeralVariant | Gets or sets a variant of the digit format to use.
Public Property | PaddingBottom | Gets or sets an amount of padding between the bottom edge of the report item and its contents.
Public Property | PaddingLeft | Gets or sets an amount of padding between the left edge of the report item and its contents.
Public Property | PaddingRight | Gets or sets an amount of padding between the right edge of the report item and its contents.
Public Property | PaddingTop | Gets or sets an amount of padding between the top edge of the report item and its contents.
Public Property | ParentStyle | Gets or sets the parent style.
Public Property | RightBorder | Gets or sets the right border properties, such as color, style and width.
Public Property | ShadowOffset | Gets or sets a size of the shadow.
Public Property | ShrinkToFit | Gets or sets a value indicating whether the text font size should be adjusted to fit the text in to container.
Public Property | StyleName | Gets or sets a name of the external style.
Public Property | TextAlign | Gets or sets a horizontal alignment of the text.
Public Property | TextDecoration | Gets or sets a special text formatting.
Public Property | TextIndent | Gets or sets a text indentation for level of the table of contents.
Public Property | TextJustify | Specifies the text justify.
Public Property | TopBorder | Gets or sets the top border properties, such as color, style and width.
Public Property | Type | Gets or sets the type of the style.
Public Property | UnicodeBiDi | Gets or sets an Unicode Bi-directional embedding mode.
Public Property | UprightInVerticalText | Gets or sets a value indicates whether the digits or digits along with Latin text appear horizontally in the vertical text.
Public Property | VerticalAlign | Gets or sets a vertical alignment of the text.
Public Property | WrapMode | Gets or sets a word wrap behavior for the text.
Public Property | WritingMode | Gets or sets a value indicating whether the text is written horizontally or vertically.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | CreateDefaultStyle | Creates a new Style object with default values.
Public Method | Equals | Determines whether the specified object is equal to the current Style.
Public Method | GetExpressions | Returns a list of the expressions contained by this component.
Public Method | GetHashCode | Serves as a hash function for the Length.
static (Shared in Visual Basic) | Merge | Merges a specified report item style with an external style from a stylesheet.
Public Method | Validate | Validates the current state of the Style object.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


Style Constructor

[image]
ActiveReports 19 .NET Edition
Style Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Style Constructor

Glossary Item Box

Overload List

Overload | Description
Style Constructor() | Initializes a new instance of the Style class.
Style Constructor(String,Style,StyleType,Boolean) | Initializes a new instance of the Style class using a specified name, parent style and style type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Style Constructor()

[image]
ActiveReports 19 .NET Edition
Style Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class > Style Constructor : Style Constructor()

Glossary Item Box

Initializes a new instance of the Style class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Style()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members
Overload List


Style Constructor(String,Style,StyleType,Boolean)

[image]
ActiveReports 19 .NET Edition
Style Constructor(String,Style,StyleType,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class > Style Constructor : Style Constructor(String,Style,StyleType,Boolean)

name
A System.String value indicating the name of the style.
parent
A parent Style object.
type
A StyleType value indicating the type of style.
isLineStyle
A System.Boolean value indicating whether the style is for a line. Default is false.

Glossary Item Box

Initializes a new instance of the Style class using a specified name, parent style and style type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal parent As Style, _
   ByVal type As StyleType, _
   Optional ByVal isLineStyle As Boolean _
)
C#
public Style(
   string name,
   Style parent,
   StyleType type,
   bool isLineStyle
)

Parameters

name
A System.String value indicating the name of the style.
parent
A parent Style object.
type
A StyleType value indicating the type of style.
isLineStyle
A System.Boolean value indicating whether the style is for a line. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members
Overload List


Style Class Methods

[image]
ActiveReports 19 .NET Edition
Style Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

Glossary Item Box

For a list of all members of this type, see Style members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
static (Shared in Visual Basic) | CreateDefaultStyle | Creates a new Style object with default values.
Public Method | Equals | Determines whether the specified object is equal to the current Style.
Public Method | GetExpressions | Returns a list of the expressions contained by this component.
Public Method | GetHashCode | Serves as a hash function for the Length.
static (Shared in Visual Basic) | Merge | Merges a specified report item style with an external style from a stylesheet.
Public Method | Validate | Validates the current state of the Style object.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Style
C#
public Style Clone()

Return Value

A new Style object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


CreateDefaultStyle Method

[image]
ActiveReports 19 .NET Edition
CreateDefaultStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CreateDefaultStyle Method

isLineStyle
A System.Boolean value indicating whether the style is for a line. Default is false.

Glossary Item Box

Creates a new Style object with default values.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefaultStyle( _
   Optional ByVal isLineStyle As Boolean _
) As Style
C#
public static Style CreateDefaultStyle(
   bool isLineStyle
)

Parameters

isLineStyle
A System.Boolean value indicating whether the style is for a line. Default is false.

Return Value

A new Style object with default values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Equals Method

obj
An System.Object to compare with the current Style.

Glossary Item Box

Determines whether the specified object is equal to the current Style.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
An System.Object to compare with the current Style.

Return Value

A System.Boolean value. true if the specified object is equal to the current Style; otherwise, false.

Example

C# Copy Code
Style style1 = new Style { BackgroundColor = "Black" };
Style style2 = new Style { BackgroundColor = "White" };
bool result = style1.Equals(style2); // false

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this component.

Syntax

Visual Basic (Declaration)
Public Function GetExpressions() As ExpressionInfo()
C#
public ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : GetHashCode Method

Glossary Item Box

Serves as a hash function for the Length.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

An System.Int32 value indicating the hash code for the current Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Merge Method

[image]
ActiveReports 19 .NET Edition
Merge Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Merge Method

local
A Style object of the report element.
external
An external Style object obtained from the stylesheet. If this parameter is null, the default style will be used.

Glossary Item Box

Merges a specified report item style with an external style from a stylesheet.

Syntax

Visual Basic (Declaration)
Public Shared Function Merge( _
   ByVal local As Style, _
   ByVal external As Style _
) As Style
C#
public static Style Merge(
   Style local,
   Style external
)

Parameters

local
A Style object of the report element.
external
An external Style object obtained from the stylesheet. If this parameter is null, the default style will be used.

Return Value

A Style object representing the merged style.

Example

An example of how to merge with the default style: An example of how to merge with the different style:
C# Copy Code
Style style = new Style { BackgroundColor = "White" };
Style newStyle = Style.Merge(style, null);
C# Copy Code
TextBox textBox = new TextBox();
textBox.Style.TextAlign = TextAlign.Justify;

Style style = new Style { BackgroundColor = "Red" };

Style newStyle = Style.Merge(textBox.Style, style);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Style object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Style Class Properties

[image]
ActiveReports 19 .NET Edition
Style Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

Glossary Item Box

For a list of all members of this type, see Style members.

Public Properties

 | Name | Description
Public Property | Angle | Gets or sets a number of degrees the text is rorated counter-clockwise.
Public Property | BackgroundColor | Gets or sets a color of the background.
Public Property | BackgroundGradientEndColor | Gets or sets an end color for the background gradient.
Public Property | BackgroundGradientType | Gets or sets a gradient type of the background.
Public Property | BackgroundHatchType | Gets or sets a hatching pattern of a report item.
Public Property | BackgroundImage | Gets a background image for the report item.
Public Property | Border | Gets or sets the default border properties, such as color, style and width.
Public Property | BorderColor | Gets a color of the border, containing the default color or color for each side of the border.
Public Property | BorderStyle | Gets a style of the border, containing the default style or style for each side of the border.
Public Property | BorderWidth | Gets a width of the border, containing the default width or width for each side of the border.
Public Property | BottomBorder | Gets or sets the bottom border properties, such as color, style and width.
Public Property | Calendar | Gets or sets a calendar used for formatting dates.
Public Property | CharacterSpacing | Gets or sets a spacing between characters.
Public Property | Color | Gets or sets a color of the text.
Public Property | Direction | Specifies the direction.
Public Property | FontFamily | Gets or sets a name of the font family.
Public Property | FontSize | Gets or sets a size of the font in Length.Unit.Points units.
Public Property | FontStyle | Gets or sets a style of the font.
Public Property | FontWeight | Gets or sets a thickness of the font.
Public Property | Format | Gets or sets a .NET Framework formatting string.
Public Property | HeadingLevel | Gets or sets a heading level of the table of contents.
Public Property | LabelExpression | Gets or sets an expression for label of the table of contents.
Public Property | Language | Gets or sets the primary language of the text.
Public Property | LeadingChar | Gets or sets an leading char for label of the table of contents.
Public Property | LeftBorder | Gets or sets the left border properties, such as color, style and width.
Public Property | LineHeight | Gets or sets a line height (leading).
Public Property | LineSpacing | Gets or sets a spacing between lines.
Public Property | MaxLevel | Gets or sets a maximum depth of the table of contents.
Public Property | MinCondenseRate | Gets or sets a minimum character condense rate value.
Public Property | Name | Gets or sets a name of the style.
Public Property | NumberingStyle | Gets or sets a numbering style for headings of the table of contents.
Public Property | NumeralLanguage | Gets or sets a digit format to use as described by its primary language.
Public Property | NumeralVariant | Gets or sets a variant of the digit format to use.
Public Property | PaddingBottom | Gets or sets an amount of padding between the bottom edge of the report item and its contents.
Public Property | PaddingLeft | Gets or sets an amount of padding between the left edge of the report item and its contents.
Public Property | PaddingRight | Gets or sets an amount of padding between the right edge of the report item and its contents.
Public Property | PaddingTop | Gets or sets an amount of padding between the top edge of the report item and its contents.
Public Property | ParentStyle | Gets or sets the parent style.
Public Property | RightBorder | Gets or sets the right border properties, such as color, style and width.
Public Property | ShadowOffset | Gets or sets a size of the shadow.
Public Property | ShrinkToFit | Gets or sets a value indicating whether the text font size should be adjusted to fit the text in to container.
Public Property | StyleName | Gets or sets a name of the external style.
Public Property | TextAlign | Gets or sets a horizontal alignment of the text.
Public Property | TextDecoration | Gets or sets a special text formatting.
Public Property | TextIndent | Gets or sets a text indentation for level of the table of contents.
Public Property | TextJustify | Specifies the text justify.
Public Property | TopBorder | Gets or sets the top border properties, such as color, style and width.
Public Property | Type | Gets or sets the type of the style.
Public Property | UnicodeBiDi | Gets or sets an Unicode Bi-directional embedding mode.
Public Property | UprightInVerticalText | Gets or sets a value indicates whether the digits or digits along with Latin text appear horizontally in the vertical text.
Public Property | VerticalAlign | Gets or sets a vertical alignment of the text.
Public Property | WrapMode | Gets or sets a word wrap behavior for the text.
Public Property | WritingMode | Gets or sets a value indicating whether the text is written horizontally or vertically.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Angle Property

Glossary Item Box

Gets or sets a number of degrees the text is rorated counter-clockwise.

Syntax

Visual Basic (Declaration)
Public Property Angle As ExpressionInfo
C#
public ExpressionInfo Angle {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Single value indicating the number of degrees the text is rorated counter-clockwise.

Remarks

Negative value indicating a clockwise rotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundColor Property

Glossary Item Box

Gets or sets a color of the background.

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As ExpressionInfo
C#
public ExpressionInfo BackgroundColor {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the color of the background.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundGradientEndColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientEndColor Property

Glossary Item Box

Gets or sets an end color for the background gradient.

Syntax

Visual Basic (Declaration)
Public Property BackgroundGradientEndColor As ExpressionInfo
C#
public ExpressionInfo BackgroundGradientEndColor {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the end color for the background gradient.

Remarks

If this value is omitted, there is no gradient.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundGradientType Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientType Property

Glossary Item Box

Gets or sets a gradient type of the background.

Syntax

Visual Basic (Declaration)
Public Property BackgroundGradientType As ExpressionInfo
C#
public ExpressionInfo BackgroundGradientType {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the BackgroundGradientType enumeration indicating the gradient type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundHatchType Property

[image]
ActiveReports 19 .NET Edition
BackgroundHatchType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundHatchType Property

Glossary Item Box

Gets or sets a hatching pattern of a report item.

Syntax

Visual Basic (Declaration)
Public Property BackgroundHatchType As ExpressionInfo
C#
public ExpressionInfo BackgroundHatchType {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a BackgroundHatchTypes enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundImage Property

[image]
ActiveReports 19 .NET Edition
BackgroundImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundImage Property

Glossary Item Box

Gets a background image for the report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundImage As BackgroundImage
C#
public BackgroundImage BackgroundImage {get;}

Property Value

A BackgroundImage object containing the background image for the report item.

Remarks

If omitted, there is no background image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Border Property

[image]
ActiveReports 19 .NET Edition
Border Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Border Property

Glossary Item Box

Gets or sets the default border properties, such as color, style and width.

Syntax

Visual Basic (Declaration)
Public Property Border As Border
C#
public Border Border {get; set;}

Property Value

A Border object containing the default border properties.

Remarks

The object copies Default property from BorderColor, BorderStyle and BorderWidth, or set new values to them.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderColor Property

[image]
ActiveReports 19 .NET Edition
BorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderColor Property

Glossary Item Box

Gets a color of the border, containing the default color or color for each side of the border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderColor As BorderColor
C#
public BorderColor BorderColor {get;}

Property Value

A BorderStyle object representing the border color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderStyle Property

[image]
ActiveReports 19 .NET Edition
BorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderStyle Property

Glossary Item Box

Gets a style of the border, containing the default style or style for each side of the border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get;}

Property Value

A BorderStyle object representing the border style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderWidth Property

[image]
ActiveReports 19 .NET Edition
BorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderWidth Property

Glossary Item Box

Gets a width of the border, containing the default width or width for each side of the border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderWidth As BorderWidth
C#
public BorderWidth BorderWidth {get;}

Property Value

A BorderWidth object representing the border width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BottomBorder Property

[image]
ActiveReports 19 .NET Edition
BottomBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BottomBorder Property

Glossary Item Box

Gets or sets the bottom border properties, such as color, style and width.

Syntax

Visual Basic (Declaration)
Public Property BottomBorder As Border
C#
public Border BottomBorder {get; set;}

Property Value

A Border object containing the bottom border properties.

Remarks

The object copies Bottom property from BorderColor, BorderStyle and BorderWidth, or set new values to them.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Calendar Property

[image]
ActiveReports 19 .NET Edition
Calendar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Calendar Property

Glossary Item Box

Gets or sets a calendar used for formatting dates.

Syntax

Visual Basic (Declaration)
Public Property Calendar As ExpressionInfo
C#
public ExpressionInfo Calendar {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Calendar enumeration.

Remarks

This property allows specifying the calendar system used for formatting date values. Default calendar is the Gregorian calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CharacterSpacing Property

Glossary Item Box

Gets or sets a spacing between characters.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As ExpressionInfo
C#
public ExpressionInfo CharacterSpacing {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length value indicating the spacing between characters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Color Property

Glossary Item Box

Gets or sets a color of the text.

Syntax

Visual Basic (Declaration)
Public Property Color As ExpressionInfo
C#
public ExpressionInfo Color {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the color of the text.

Remarks

Default value is Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Direction Property

Glossary Item Box

Specifies the direction.

Syntax

Visual Basic (Declaration)
Public Property Direction As ExpressionInfo
C#
public ExpressionInfo Direction {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontFamily Property

Glossary Item Box

Gets or sets a name of the font family.

Syntax

Visual Basic (Declaration)
Public Property FontFamily As ExpressionInfo
C#
public ExpressionInfo FontFamily {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a string containing the name of the font family.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontSize Property

Glossary Item Box

Gets or sets a size of the font in Length.Unit.Points units.

Syntax

Visual Basic (Declaration)
Public Property FontSize As ExpressionInfo
C#
public ExpressionInfo FontSize {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length containing the point size of the font.

Remarks

Default value is 10pt, the maximum value is 200pt, the minimum value is 1pt.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontStyle Property

Glossary Item Box

Gets or sets a style of the font.

Syntax

Visual Basic (Declaration)
Public Property FontStyle As ExpressionInfo
C#
public ExpressionInfo FontStyle {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a FontStyle enumeration indicating the font style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontWeight Property

Glossary Item Box

Gets or sets a thickness of the font.

Syntax

Visual Basic (Declaration)
Public Property FontWeight As ExpressionInfo
C#
public ExpressionInfo FontWeight {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a FontWeight enumeration or a number between 0 and 900 indicating the thickness of the font.

Remarks

Valid values are listed in the table below.

FontWeight | Description
Lighter | A lighter font weight with a numeric value of 0.
Thin | A thin font weight with a numeric value of 100.
ExtraLight | An extra-light font weight with a numeric value of 200.
Light | A light font weight with a numeric value of 300.
Normal (Default) | A normal font weight with a numeric value of 400.
Medium | A medium font weight with a numeric value of 500.
Semibold | A semi-bold font weight with a numeric value of 600.
Bold | A bold font weight with a numeric value of 700.
Extrabold | An extra-bold font weight with a numeric value of 800.
Heavy | The heaviest possible font weight with a numeric value of 900.
Bolder | Selects the next value that is darker than the inherited value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Format Property

Glossary Item Box

Gets or sets a .NET Framework formatting string.

Syntax

Visual Basic (Declaration)
Public Property Format As ExpressionInfo
C#
public ExpressionInfo Format {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a .NET Framework formatting string.

Remarks

Locale-dependent currency formatting (format code "C") is based on the language setting of the report item.

Locale-dependent date formatting is supported and is based on the language property of the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


HeadingLevel Property

[image]
ActiveReports 19 .NET Edition
HeadingLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : HeadingLevel Property

Glossary Item Box

Gets or sets a heading level of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property HeadingLevel As ExpressionInfo
C#
public ExpressionInfo HeadingLevel {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Int32 value indicating the heading level of the ToC.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LabelExpression Property

[image]
ActiveReports 19 .NET Edition
LabelExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LabelExpression Property

Glossary Item Box

Gets or sets an expression for label of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property LabelExpression As ExpressionInfo
C#
public ExpressionInfo LabelExpression {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.String value indicating the label of the ToC.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Language Property

Glossary Item Box

Gets or sets the primary language of the text.

Syntax

Visual Basic (Declaration)
Public Property Language As ExpressionInfo
C#
public ExpressionInfo Language {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the primary language of the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeadingChar Property

Glossary Item Box

Gets or sets an leading char for label of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property LeadingChar As ExpressionInfo
C#
public ExpressionInfo LeadingChar {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.String value indicating the leading char for label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LeftBorder Property

[image]
ActiveReports 19 .NET Edition
LeftBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeftBorder Property

Glossary Item Box

Gets or sets the left border properties, such as color, style and width.

Syntax

Visual Basic (Declaration)
Public Property LeftBorder As Border
C#
public Border LeftBorder {get; set;}

Property Value

A Border object containing the left border properties.

Remarks

The object copies Left property from BorderColor, BorderStyle and BorderWidth, or set new values to them.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LineHeight Property

[image]
ActiveReports 19 .NET Edition
LineHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LineHeight Property

Glossary Item Box

Gets or sets a line height (leading).

Syntax

Visual Basic (Declaration)
Public Property LineHeight As ExpressionInfo
C#
public ExpressionInfo LineHeight {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length value indicating the line height.

Remarks

This property is used to control the spacing between lines of text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LineSpacing Property

Glossary Item Box

Gets or sets a spacing between lines.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As ExpressionInfo
C#
public ExpressionInfo LineSpacing {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length value indicating the spacing between lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


MaxLevel Property

[image]
ActiveReports 19 .NET Edition
MaxLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MaxLevel Property

Glossary Item Box

Gets or sets a maximum depth of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property MaxLevel As ExpressionInfo
C#
public ExpressionInfo MaxLevel {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Int32 value indicating the maximum depth of the ToC. Default value is 0, the minimum value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


MinCondenseRate Property

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MinCondenseRate Property

Glossary Item Box

Gets or sets a minimum character condense rate value.

Syntax

Visual Basic (Declaration)
Public Property MinCondenseRate As ExpressionInfo
C#
public ExpressionInfo MinCondenseRate {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Int32 value indicating the minimum condense rate.

Default value is 100, the maximum value is 100, the minimum value is 10.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Name Property

Glossary Item Box

Gets or sets a name of the style.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


NumberingStyle Property

[image]
ActiveReports 19 .NET Edition
NumberingStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumberingStyle Property

Glossary Item Box

Gets or sets a numbering style for headings of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property NumberingStyle As ExpressionInfo
C#
public ExpressionInfo NumberingStyle {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a NumberingStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


NumeralLanguage Property

[image]
ActiveReports 19 .NET Edition
NumeralLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumeralLanguage Property

Glossary Item Box

Gets or sets a digit format to use as described by its primary language.

Syntax

Visual Basic (Declaration)
Public Property NumeralLanguage As ExpressionInfo
C#
public ExpressionInfo NumeralLanguage {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the digit format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


NumeralVariant Property

[image]
ActiveReports 19 .NET Edition
NumeralVariant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumeralVariant Property

Glossary Item Box

Gets or sets a variant of the digit format to use.

Syntax

Visual Basic (Declaration)
Public Property NumeralVariant As ExpressionInfo
C#
public ExpressionInfo NumeralVariant {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Int32 value indicating the variant of the digit format to use.

Remarks

Currently defined values are:

Value | Description
1 | Default, follow Unicode context rules
2 | 0123456789
3 | Traditional digits for the script as defined in GDI+. Currently supports: ar|bn|bo|fa|gu|hi|kn|kok|lo|mr|ms|or|pa|sa|ta|te|th|ur and variants.
4 | ko, ja, zh-CHS, zh-CHT only
5 | ko, ja, zh-CHS, zh-CHT only
6 | ko, ja, zh-CHS, zh-CHT only (Wide versions of regular digits)
7 | ko only

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


PaddingBottom Property

[image]
ActiveReports 19 .NET Edition
PaddingBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingBottom Property

Glossary Item Box

Gets or sets an amount of padding between the bottom edge of the report item and its contents.

Syntax

Visual Basic (Declaration)
Public Property PaddingBottom As ExpressionInfo
C#
public ExpressionInfo PaddingBottom {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that evaluates to the Length value indacating the padding between the bottom edge of the report item and its contents.

Remarks

Default value is 0pt, the maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


PaddingLeft Property

[image]
ActiveReports 19 .NET Edition
PaddingLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingLeft Property

Glossary Item Box

Gets or sets an amount of padding between the left edge of the report item and its contents.

Syntax

Visual Basic (Declaration)
Public Property PaddingLeft As ExpressionInfo
C#
public ExpressionInfo PaddingLeft {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that evaluates to the Length value indacating the padding between the left edge of the report item and its contents.

Remarks

Default value is 0pt, the maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


PaddingRight Property

[image]
ActiveReports 19 .NET Edition
PaddingRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingRight Property

Glossary Item Box

Gets or sets an amount of padding between the right edge of the report item and its contents.

Syntax

Visual Basic (Declaration)
Public Property PaddingRight As ExpressionInfo
C#
public ExpressionInfo PaddingRight {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that evaluates to the Length value indacating the padding between the right edge of the report item and its contents.

Remarks

Default value is 0pt, the maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


PaddingTop Property

[image]
ActiveReports 19 .NET Edition
PaddingTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingTop Property

Glossary Item Box

Gets or sets an amount of padding between the top edge of the report item and its contents.

Syntax

Visual Basic (Declaration)
Public Property PaddingTop As ExpressionInfo
C#
public ExpressionInfo PaddingTop {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo that evaluates to the Length value indacating the padding between the top edge of the report item and its contents.

Remarks

Default value is 0pt, the maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ParentStyle Property

[image]
ActiveReports 19 .NET Edition
ParentStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ParentStyle Property

Glossary Item Box

Gets or sets the parent style.

Syntax

Visual Basic (Declaration)
Public Property ParentStyle As Style
C#
public Style ParentStyle {get; set;}

Property Value

A Style object representing the parent style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


RightBorder Property

[image]
ActiveReports 19 .NET Edition
RightBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : RightBorder Property

Glossary Item Box

Gets or sets the right border properties, such as color, style and width.

Syntax

Visual Basic (Declaration)
Public Property RightBorder As Border
C#
public Border RightBorder {get; set;}

Property Value

A Border object containing the right border properties.

Remarks

The object copies Right property from BorderColor, BorderStyle and BorderWidth, or set new values to them.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ShadowOffset Property

[image]
ActiveReports 19 .NET Edition
ShadowOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShadowOffset Property

Glossary Item Box

Gets or sets a size of the shadow.

Syntax

Visual Basic (Declaration)
Public Property ShadowOffset As ExpressionInfo
C#
public ExpressionInfo ShadowOffset {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length value indicating the size of the shadow.

Remarks

Shadow offsets are drawn to the right and below an element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShrinkToFit Property

Glossary Item Box

Gets or sets a value indicating whether the text font size should be adjusted to fit the text in to container.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As ExpressionInfo
C#
public ExpressionInfo ShrinkToFit {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to an System.Boolean value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


StyleName Property

[image]
ActiveReports 19 .NET Edition
StyleName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : StyleName Property

Glossary Item Box

Gets or sets a name of the external style.

Syntax

Visual Basic (Declaration)
Public Property StyleName As ExpressionInfo
C#
public ExpressionInfo StyleName {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the name of the external style.

Remarks

An external style name is used to merge the external style with current.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextAlign Property

Glossary Item Box

Gets or sets a horizontal alignment of the text.

Syntax

Visual Basic (Declaration)
Public Property TextAlign As ExpressionInfo
C#
public ExpressionInfo TextAlign {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a TextAlign enumeration indicating the horizontal alignment of the text.

Remarks

Valid values are listed in the table below.

TextAlign | Description
General | The alignment is based on the content type.
Left | Text is aligned to the left.
Center | Text is centered in the control.
Right | Text is aligned to the right.
Justify | Text stretched from the left to the right.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextDecoration Property

[image]
ActiveReports 19 .NET Edition
TextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextDecoration Property

Glossary Item Box

Gets or sets a special text formatting.

Syntax

Visual Basic (Declaration)
Public Property TextDecoration As ExpressionInfo
C#
public ExpressionInfo TextDecoration {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a TextDecoration enumeration indicating the special text formatting.

Remarks

Valid values are listed in the table below.

TextDecoration | Description
None | No special formatting is used.
Underline | Text is rendered with a line below it.
Overline | Text is rendered with a line above it.
LineThrough | Text is rendered with a line through it.
DoubleUnderline | Text is rendered with a double line through it.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextIndent Property

[image]
ActiveReports 19 .NET Edition
TextIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextIndent Property

Glossary Item Box

Gets or sets a text indentation for level of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property TextIndent As ExpressionInfo
C#
public ExpressionInfo TextIndent {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a Length value indicating the text indentation for level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextJustify Property

Glossary Item Box

Specifies the text justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As ExpressionInfo
C#
public ExpressionInfo TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TopBorder Property

[image]
ActiveReports 19 .NET Edition
TopBorder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TopBorder Property

Glossary Item Box

Gets or sets the top border properties, such as color, style and width.

Syntax

Visual Basic (Declaration)
Public Property TopBorder As Border
C#
public Border TopBorder {get; set;}

Property Value

A Border object containing the top border properties.

Remarks

The object copies Top property from BorderColor, BorderStyle and BorderWidth, or set new values to them.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Type Property

Glossary Item Box

Gets or sets the type of the style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As StyleType
C#
public StyleType Type {get;}

Property Value

A StyleType value indicating the type of the style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


UnicodeBiDi Property

[image]
ActiveReports 19 .NET Edition
UnicodeBiDi Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : UnicodeBiDi Property

Glossary Item Box

Gets or sets an Unicode Bi-directional embedding mode.

Syntax

Visual Basic (Declaration)
Public Property UnicodeBiDi As ExpressionInfo
C#
public ExpressionInfo UnicodeBiDi {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a UnicodeBiDi enumeration.

Remarks

This property specifies how the text should be displayed when using a bi-directional language such as Arabic or Hebrew.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


UprightInVerticalText Property

[image]
ActiveReports 19 .NET Edition
UprightInVerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : UprightInVerticalText Property

Glossary Item Box

Gets or sets a value indicates whether the digits or digits along with Latin text appear horizontally in the vertical text.

Syntax

Visual Basic (Declaration)
Public Property UprightInVerticalText As ExpressionInfo
C#
public ExpressionInfo UprightInVerticalText {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a System.String value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : VerticalAlign Property

Glossary Item Box

Gets or sets a vertical alignment of the text.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As ExpressionInfo
C#
public ExpressionInfo VerticalAlign {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a VerticalAlign enumeration indicating the vertical alignment of the text.

Remarks

Valid values are listed in the table below.

VerticalAlign | Description
Top | Text is aligned to the top.
Middle | Text is centered in the control.
Bottom | Text is aligned to the bottom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WrapMode Property

Glossary Item Box

Gets or sets a word wrap behavior for the text.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As ExpressionInfo
C#
public ExpressionInfo WrapMode {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a WrapMode enumeration indicating the word wrap behavior.

Remarks

Valid values are listed in the table below.

WrapMode | Description
NoWrap | Text does not wrap.
WordWrap | Text wraps at word boundaries.
CharWrap | Text wraps at character boundaries.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


WritingMode Property

[image]
ActiveReports 19 .NET Edition
WritingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WritingMode Property

Glossary Item Box

Gets or sets a value indicating whether the text is written horizontally or vertically.

Syntax

Visual Basic (Declaration)
Public Property WritingMode As ExpressionInfo
C#
public ExpressionInfo WritingMode {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to how the text is written.

Remarks

Valid values are listed in the table below.

WritingMode | Description
lr-tb | Text is written from left to right and from top to bottom.
tb-rl | Text is written from top to bottom and from right to left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Style Class Fields

[image]
ActiveReports 19 .NET Edition
Style Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

Glossary Item Box

For a list of all members of this type, see Style members.

Public Fields

 | Name | Description
Public Field | AngleDefault | The default value for the Angle property.
Public Field | BackgroundColorDefault | The default value for the BackgroundColor property.
Public Field | BackgroundGradientEndColorDefault | The default value for the BackgroundGradientEndColor property.
Public Field | BackgroundGradientTypeDefault | The default value for the BackgroundGradientType property.
Public Field | BorderColorDefault | The default value for the BorderColor property.
Public Field | BorderStyleDefault | The default value for the BorderStyle property.
Public Field | BorderWidthDefault | The default value for the BorderWidth property.
Public Field | CharacterSpacingDefault | The default value for the CharacterSpacing property.
Public Field | ColorDefault | The default value for the Color property.
static (Shared in Visual Basic) | DefaultStyle | The singleton default Style object.
Public Field | DirectionDefault | The default value for the Direction property.
Public Field | FontFamilyDefault | The default value for the FontFamily property.
Public Field | FontSizeDefault | The default value for the FontSize property.
Public Field | FontStyleDefault | The default value for the FontStyle property.
Public Field | FontWeightDefault | The default value for the FontWeight property.
Public Field | HeadingLevelDefault | The default value for the HeadingLevel property.
Public Field | InheritedValue | The special value for a property of style which indicates that the value should be evaluated from parent style.
Public Field | LabelExpressionDefault | The default value for the LabelExpression property.
Public Field | LeadingCharDefault | The default value for the LeadingChar property.
Public Field | LineBorderStyleDefault | The default value for the BorderStyle line property.
Public Field | MaxLevelDefault | The default value for the MaxLevel property.
Public Field | MinCondenseRateDefault | The default value for the MinCondenseRate property.
static (Shared in Visual Basic) | MinTextIndent | The minimum value for the TextIndent property.
Public Field | NumberingStyleDefault | The default value for the NumberingStyle property.
Public Field | ShadowOffsetDefault | The default value for the ShadowOffset property.
Public Field | ShrinkToFitDefault | The default value for the ShrinkToFit property.
Public Field | TextAlignDefault | The default value for the TextAlign property.
Public Field | TextDecorationDefault | The default value for the TextDecoration property.
Public Field | TextIndentDefault | The default value for the TextIndent property.
Public Field | TextJustifyDefault | The default value for the TextJustify property.
Public Field | UprightInVerticalTextDefault | The default value for the UprightInVerticalText property.
Public Field | VerticalAlignDefault | The default value for the VerticalAlign property.
Public Field | WrapModeDefault | The default value for the WrapMode property.
Public Field | WritingModeDefault | The default value for the WritingMode property.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


AngleDefault Field

[image]
ActiveReports 19 .NET Edition
AngleDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : AngleDefault Field

Glossary Item Box

The default value for the Angle property.

Syntax

Visual Basic (Declaration)
Public Const AngleDefault As String
C#
public const string AngleDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundColorDefault Field

[image]
ActiveReports 19 .NET Edition
BackgroundColorDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundColorDefault Field

Glossary Item Box

The default value for the BackgroundColor property.

Syntax

Visual Basic (Declaration)
Public Const BackgroundColorDefault As String
C#
public const string BackgroundColorDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundGradientEndColorDefault Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColorDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientEndColorDefault Field

Glossary Item Box

The default value for the BackgroundGradientEndColor property.

Syntax

Visual Basic (Declaration)
Public Const BackgroundGradientEndColorDefault As String
C#
public const string BackgroundGradientEndColorDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackgroundGradientTypeDefault Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientTypeDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientTypeDefault Field

Glossary Item Box

The default value for the BackgroundGradientType property.

Syntax

Visual Basic (Declaration)
Public Const BackgroundGradientTypeDefault As String
C#
public const string BackgroundGradientTypeDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderColorDefault Field

[image]
ActiveReports 19 .NET Edition
BorderColorDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderColorDefault Field

Glossary Item Box

The default value for the BorderColor property.

Syntax

Visual Basic (Declaration)
Public Const BorderColorDefault As String
C#
public const string BorderColorDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderStyleDefault Field

[image]
ActiveReports 19 .NET Edition
BorderStyleDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderStyleDefault Field

Glossary Item Box

The default value for the BorderStyle property.

Syntax

Visual Basic (Declaration)
Public Const BorderStyleDefault As String
C#
public const string BorderStyleDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BorderWidthDefault Field

[image]
ActiveReports 19 .NET Edition
BorderWidthDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderWidthDefault Field

Glossary Item Box

The default value for the BorderWidth property.

Syntax

Visual Basic (Declaration)
Public Const BorderWidthDefault As String
C#
public const string BorderWidthDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


CharacterSpacingDefault Field

[image]
ActiveReports 19 .NET Edition
CharacterSpacingDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CharacterSpacingDefault Field

Glossary Item Box

The default value for the CharacterSpacing property.

Syntax

Visual Basic (Declaration)
Public Const CharacterSpacingDefault As String
C#
public const string CharacterSpacingDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ColorDefault Field

[image]
ActiveReports 19 .NET Edition
ColorDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ColorDefault Field

Glossary Item Box

The default value for the Color property.

Syntax

Visual Basic (Declaration)
Public Const ColorDefault As String
C#
public const string ColorDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


DefaultStyle Field

[image]
ActiveReports 19 .NET Edition
DefaultStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : DefaultStyle Field

Glossary Item Box

The singleton default Style object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultStyle As Style
C#
public static readonly Style DefaultStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


DirectionDefault Field

[image]
ActiveReports 19 .NET Edition
DirectionDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : DirectionDefault Field

Glossary Item Box

The default value for the Direction property.

Syntax

Visual Basic (Declaration)
Public Const DirectionDefault As String
C#
public const string DirectionDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontFamilyDefault Field

[image]
ActiveReports 19 .NET Edition
FontFamilyDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontFamilyDefault Field

Glossary Item Box

The default value for the FontFamily property.

Syntax

Visual Basic (Declaration)
Public Const FontFamilyDefault As String
C#
public const string FontFamilyDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontSizeDefault Field

[image]
ActiveReports 19 .NET Edition
FontSizeDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontSizeDefault Field

Glossary Item Box

The default value for the FontSize property.

Syntax

Visual Basic (Declaration)
Public Const FontSizeDefault As String
C#
public const string FontSizeDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontStyleDefault Field

[image]
ActiveReports 19 .NET Edition
FontStyleDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontStyleDefault Field

Glossary Item Box

The default value for the FontStyle property.

Syntax

Visual Basic (Declaration)
Public Const FontStyleDefault As String
C#
public const string FontStyleDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontWeightDefault Field

[image]
ActiveReports 19 .NET Edition
FontWeightDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontWeightDefault Field

Glossary Item Box

The default value for the FontWeight property.

Syntax

Visual Basic (Declaration)
Public Const FontWeightDefault As String
C#
public const string FontWeightDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


HeadingLevelDefault Field

[image]
ActiveReports 19 .NET Edition
HeadingLevelDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : HeadingLevelDefault Field

Glossary Item Box

The default value for the HeadingLevel property.

Syntax

Visual Basic (Declaration)
Public Const HeadingLevelDefault As String
C#
public const string HeadingLevelDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


InheritedValue Field

[image]
ActiveReports 19 .NET Edition
InheritedValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : InheritedValue Field

Glossary Item Box

The special value for a property of style which indicates that the value should be evaluated from parent style.

Syntax

Visual Basic (Declaration)
Public Const InheritedValue As String
C#
public const string InheritedValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LabelExpressionDefault Field

[image]
ActiveReports 19 .NET Edition
LabelExpressionDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LabelExpressionDefault Field

Glossary Item Box

The default value for the LabelExpression property.

Syntax

Visual Basic (Declaration)
Public Const LabelExpressionDefault As String
C#
public const string LabelExpressionDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LeadingCharDefault Field

[image]
ActiveReports 19 .NET Edition
LeadingCharDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeadingCharDefault Field

Glossary Item Box

The default value for the LeadingChar property.

Syntax

Visual Basic (Declaration)
Public Const LeadingCharDefault As String
C#
public const string LeadingCharDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


LineBorderStyleDefault Field

[image]
ActiveReports 19 .NET Edition
LineBorderStyleDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LineBorderStyleDefault Field

Glossary Item Box

The default value for the BorderStyle line property.

Syntax

Visual Basic (Declaration)
Public Const LineBorderStyleDefault As String
C#
public const string LineBorderStyleDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


MaxLevelDefault Field

[image]
ActiveReports 19 .NET Edition
MaxLevelDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MaxLevelDefault Field

Glossary Item Box

The default value for the MaxLevel property.

Syntax

Visual Basic (Declaration)
Public Const MaxLevelDefault As String
C#
public const string MaxLevelDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


MinCondenseRateDefault Field

[image]
ActiveReports 19 .NET Edition
MinCondenseRateDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MinCondenseRateDefault Field

Glossary Item Box

The default value for the MinCondenseRate property.

Syntax

Visual Basic (Declaration)
Public Const MinCondenseRateDefault As String
C#
public const string MinCondenseRateDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


MinTextIndent Field

[image]
ActiveReports 19 .NET Edition
MinTextIndent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MinTextIndent Field

Glossary Item Box

The minimum value for the TextIndent property.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinTextIndent As Length
C#
public static readonly Length MinTextIndent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


NumberingStyleDefault Field

[image]
ActiveReports 19 .NET Edition
NumberingStyleDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumberingStyleDefault Field

Glossary Item Box

The default value for the NumberingStyle property.

Syntax

Visual Basic (Declaration)
Public Const NumberingStyleDefault As String
C#
public const string NumberingStyleDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ShadowOffsetDefault Field

[image]
ActiveReports 19 .NET Edition
ShadowOffsetDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShadowOffsetDefault Field

Glossary Item Box

The default value for the ShadowOffset property.

Syntax

Visual Basic (Declaration)
Public Const ShadowOffsetDefault As String
C#
public const string ShadowOffsetDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ShrinkToFitDefault Field

[image]
ActiveReports 19 .NET Edition
ShrinkToFitDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShrinkToFitDefault Field

Glossary Item Box

The default value for the ShrinkToFit property.

Syntax

Visual Basic (Declaration)
Public Const ShrinkToFitDefault As String
C#
public const string ShrinkToFitDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextAlignDefault Field

[image]
ActiveReports 19 .NET Edition
TextAlignDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextAlignDefault Field

Glossary Item Box

The default value for the TextAlign property.

Syntax

Visual Basic (Declaration)
Public Const TextAlignDefault As String
C#
public const string TextAlignDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextDecorationDefault Field

[image]
ActiveReports 19 .NET Edition
TextDecorationDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextDecorationDefault Field

Glossary Item Box

The default value for the TextDecoration property.

Syntax

Visual Basic (Declaration)
Public Const TextDecorationDefault As String
C#
public const string TextDecorationDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextIndentDefault Field

[image]
ActiveReports 19 .NET Edition
TextIndentDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextIndentDefault Field

Glossary Item Box

The default value for the TextIndent property.

Syntax

Visual Basic (Declaration)
Public Const TextIndentDefault As String
C#
public const string TextIndentDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


TextJustifyDefault Field

[image]
ActiveReports 19 .NET Edition
TextJustifyDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextJustifyDefault Field

Glossary Item Box

The default value for the TextJustify property.

Syntax

Visual Basic (Declaration)
Public Const TextJustifyDefault As String
C#
public const string TextJustifyDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


UprightInVerticalTextDefault Field

[image]
ActiveReports 19 .NET Edition
UprightInVerticalTextDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : UprightInVerticalTextDefault Field

Glossary Item Box

The default value for the UprightInVerticalText property.

Syntax

Visual Basic (Declaration)
Public Const UprightInVerticalTextDefault As String
C#
public const string UprightInVerticalTextDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


VerticalAlignDefault Field

[image]
ActiveReports 19 .NET Edition
VerticalAlignDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : VerticalAlignDefault Field

Glossary Item Box

The default value for the VerticalAlign property.

Syntax

Visual Basic (Declaration)
Public Const VerticalAlignDefault As String
C#
public const string VerticalAlignDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


WrapModeDefault Field

[image]
ActiveReports 19 .NET Edition
WrapModeDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WrapModeDefault Field

Glossary Item Box

The default value for the WrapMode property.

Syntax

Visual Basic (Declaration)
Public Const WrapModeDefault As String
C#
public const string WrapModeDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


WritingModeDefault Field

[image]
ActiveReports 19 .NET Edition
WritingModeDefault Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WritingModeDefault Field

Glossary Item Box

The default value for the WritingMode property.

Syntax

Visual Basic (Declaration)
Public Const WritingModeDefault As String
C#
public const string WritingModeDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


StyleExpressionExtensions Class

[image]
ActiveReports 19 .NET Edition
StyleExpressionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class

Glossary Item Box

Provides extension methods for expressions of style

Object Model

StyleExpressionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class StyleExpressionExtensions
C#
public static class StyleExpressionExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StyleExpressionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleExpressionExtensions Members
GrapeCity.ActiveReports.PageReportModel Namespace


StyleExpressionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
StyleExpressionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class

Glossary Item Box

The following tables list the members exposed by StyleExpressionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsInheritedValue | Checks that the value is inherited value
Top

See Also

Reference

StyleExpressionExtensions Class
GrapeCity.ActiveReports.PageReportModel Namespace


StyleExpressionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
StyleExpressionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class

Glossary Item Box

For a list of all members of this type, see StyleExpressionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsInheritedValue | Checks that the value is inherited value
Top

See Also

Reference

StyleExpressionExtensions Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsInheritedValue Method

[image]
ActiveReports 19 .NET Edition
IsInheritedValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleExpressionExtensions Class : IsInheritedValue Method

value
GrapeCity.ActiveReports.Expressions.ExpressionInfo value

Glossary Item Box

Checks that the value is inherited value

Syntax

Visual Basic (Declaration)
Public Shared Function IsInheritedValue( _
   ByVal value As ExpressionInfo _
) As Boolean
C#
public static bool IsInheritedValue(
   ExpressionInfo value
)

Parameters

value
GrapeCity.ActiveReports.Expressions.ExpressionInfo value

Return Value

True if value is inherited value, otherwise: False

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleExpressionExtensions Class
StyleExpressionExtensions Members


StyleSheet Class

[image]
ActiveReports 19 .NET Edition
StyleSheet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

Glossary Item Box

Represents a stylesheet for a report, containing a collection of Style objects.

Object Model

StyleSheet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StyleSheet
   Inherits System.Collections.Generic.List(Of Style)
C#
public sealed class StyleSheet : System.Collections.Generic.List<Style>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
GrapeCity.ActiveReports.PageReportModel.StyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Members
GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheet Class Members

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

Glossary Item Box

The following tables list the members exposed by StyleSheet.

Public Constructors

 | Name | Description
Public Constructor | StyleSheet Constructor | Initializes a new instance of the StyleSheet class.
Top

Public Properties

 | Name | Description
Public Property | AutoUpgrade | Gets or sets a value indicating whether the stylesheet should automatically upgrade.
Public Property | Item | Overloaded. Gets a specific Style object in the StyleSheet using a specified name.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Loads a StyleSheet object from a System.IO.Stream.
Public Method | Save | Writes a StyleSheet object to a System.IO.Stream.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheet Constructor

[image]
ActiveReports 19 .NET Edition
StyleSheet Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : StyleSheet Constructor

Glossary Item Box

Initializes a new instance of the StyleSheet class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StyleSheet()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Methods

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Loads a StyleSheet object from a System.IO.Stream.
Public Method | Save | Writes a StyleSheet object to a System.IO.Stream.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Load Method

stream
A System.IO.Stream object to load from.

Glossary Item Box

Loads a StyleSheet object from a System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Shared Function Load( _
   ByVal stream As Stream _
) As StyleSheet
C#
public static StyleSheet Load(
   Stream stream
)

Parameters

stream
A System.IO.Stream object to load from.

Return Value

A loaded StyleSheet object.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if stream is null.

Example

C# Copy Code
using (var stream = new MemoryStream(Encoding.Unicode.GetBytes(embeddedStyleSheet.Data)))
{
    var styleSheet = StyleSheet.Load(stream);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Save Method

stream
A System.IO.Stream object to write to.

Glossary Item Box

Writes a StyleSheet object to a System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal stream As Stream _
)
C#
public void Save(
   Stream stream
)

Parameters

stream
A System.IO.Stream object to write to.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if stream is null.

Example

C# Copy Code
using (var stream = new MemoryStream())
{
    styleSheet.Save(stream);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

[image]
ActiveReports 19 .NET Edition
StyleSheet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Properties

 | Name | Description
Public Property | AutoUpgrade | Gets or sets a value indicating whether the stylesheet should automatically upgrade.
Public Property | Item | Overloaded. Gets a specific Style object in the StyleSheet using a specified name.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoUpgrade Property

[image]
ActiveReports 19 .NET Edition
AutoUpgrade Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : AutoUpgrade Property

Glossary Item Box

Gets or sets a value indicating whether the stylesheet should automatically upgrade.

Syntax

Visual Basic (Declaration)
Public Property AutoUpgrade As Boolean
C#
public bool AutoUpgrade {get; set;}

Property Value

A System.Boolean value where true indicates that the stylesheet will auto-upgrade; otherwise, false.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Item Property

Glossary Item Box

Gets a specific Style object in the StyleSheet using a specified name.

Overload List

Overload | Description
Item(String) | Gets a specific Style object in the StyleSheet using a specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Item Property : Item(String) Property

styleName
A System.String value indicating the name of the Style to retrieve.

Glossary Item Box

Gets a specific Style object in the StyleSheet using a specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal styleName As String _
) As Style
C#
public Style Item(
   string styleName
) {get;}

Parameters

styleName
A System.String value indicating the name of the Style to retrieve.

Property Value

A Style object with the specified name, or null if not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Subreport Class

[image]
ActiveReports 19 .NET Edition
Subreport Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

Glossary Item Box

Represents a Subreport ReportItem which is a separate report contained within the main report definition.

Object Model

Subreport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Subreport
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class Subreport : ReportItem, IReportComponent, IValidateable

Remarks

If the specified subreport fails to execute properly, an error message is displayed in its place.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Subreport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Members
GrapeCity.ActiveReports.PageReportModel Namespace


Subreport Class Members

[image]
ActiveReports 19 .NET Edition
Subreport Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

Glossary Item Box

The following tables list the members exposed by Subreport.

Public Constructors

 | Name | Description
Public Constructor | Subreport Constructor | Initializes a new instance of the Subreport class.
Top

Public Properties

 | Name | Description
Public Property | InheritStyleSheet | Gets or sets a value indicating whether the subreport inherits the containing report's style sheet.
Public Property | MergeTransactions | Gets or sets a value indicating whether the transactions in the subreport are merged with the parent report.
Public Property | NoRows | Gets or sets a message to display in the subreport if no rows of data are available.
Public Property | OverflowName | Gets or sets the overflow name for the subreport.
Public Property | PageName | Gets or sets the name used for the sheet in Excel exports.
Public Property | Parameters | Gets the parameters associated with the subreport.
Public Property | ReportName | Gets or sets the path to the subreport.
Public Property | SubstituteThemeOnSubreport | Gets or sets a value indicating whether the subreport uses the theme from the current report.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Subreport object.
Top

See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


Subreport Constructor

[image]
ActiveReports 19 .NET Edition
Subreport Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Subreport Constructor

Glossary Item Box

Initializes a new instance of the Subreport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Subreport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


Subreport Class Methods

[image]
ActiveReports 19 .NET Edition
Subreport Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

Glossary Item Box

For a list of all members of this type, see Subreport members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the Subreport object.
Top

See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Subreport object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


Subreport Class Properties

[image]
ActiveReports 19 .NET Edition
Subreport Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

Glossary Item Box

For a list of all members of this type, see Subreport members.

Public Properties

 | Name | Description
Public Property | InheritStyleSheet | Gets or sets a value indicating whether the subreport inherits the containing report's style sheet.
Public Property | MergeTransactions | Gets or sets a value indicating whether the transactions in the subreport are merged with the parent report.
Public Property | NoRows | Gets or sets a message to display in the subreport if no rows of data are available.
Public Property | OverflowName | Gets or sets the overflow name for the subreport.
Public Property | PageName | Gets or sets the name used for the sheet in Excel exports.
Public Property | Parameters | Gets the parameters associated with the subreport.
Public Property | ReportName | Gets or sets the path to the subreport.
Public Property | SubstituteThemeOnSubreport | Gets or sets a value indicating whether the subreport uses the theme from the current report.
Top

See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


InheritStyleSheet Property

[image]
ActiveReports 19 .NET Edition
InheritStyleSheet Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : InheritStyleSheet Property

Glossary Item Box

Gets or sets a value indicating whether the subreport inherits the containing report's style sheet.

Syntax

Visual Basic (Declaration)
Public Property InheritStyleSheet As Boolean
C#
public bool InheritStyleSheet {get; set;}

Property Value

A System.Boolean value where true indicates that the subreport inherits the containing report's style sheet; otherwise false. Default is true.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.InheritStyleSheet = false;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


MergeTransactions Property

[image]
ActiveReports 19 .NET Edition
MergeTransactions Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : MergeTransactions Property

Glossary Item Box

Gets or sets a value indicating whether the transactions in the subreport are merged with the parent report.

Syntax

Visual Basic (Declaration)
Public Property MergeTransactions As Boolean
C#
public bool MergeTransactions {get; set;}

Property Value

A System.Boolean value where true indicates that subreport transactions merge with parent report transactions if using the same connection; otherwise false. Default is false.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.MergeTransactions = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : NoRows Property

Glossary Item Box

Gets or sets a message to display in the subreport if no rows of data are available.

Syntax

Visual Basic (Declaration)
Public Property NoRows As ExpressionInfo
C#
public ExpressionInfo NoRows {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the message to display when no rows of data are available in the subreport.

Remarks

Style information for this text is derived from the subreport.

If the subreport is within a table or matrix cell without a NoRows property, the cell's border properties still apply even if the subreport's contents are omitted.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.NoRows = "No data available";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : OverflowName Property

Glossary Item Box

Gets or sets the overflow name for the subreport.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A System.String value indicating the overflow name for the subreport.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.OverflowName = "SalesReportOverflow";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : PageName Property

Glossary Item Box

Gets or sets the name used for the sheet in Excel exports.

Syntax

Visual Basic (Declaration)
Public Property PageName As ExpressionInfo
C#
public ExpressionInfo PageName {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the name used for the sheet in Excel exports.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.PageName = new ExpressionInfo("SalesReportSheet");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Parameters Property

Glossary Item Box

Gets the parameters associated with the subreport.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Property Value

A ParameterCollection object containing parameters for the subreport.

Remarks

If the subreport is executed without parameters and lacks Toggle elements, it runs only once even when nested within a list, table, or matrix.

Example

C# Copy Code
Subreport subreport = new Subreport();
var parameters = subreport.Parameters;
parameters.Add(new Parameter("OrderID", "10248"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : ReportName Property

Glossary Item Box

Gets or sets the path to the subreport.

Syntax

Visual Basic (Declaration)
Public Property ReportName As String
C#
public string ReportName {get; set;}

Property Value

A System.String value indicating the full (e.g. "/salesreports/orderdetails") or relative path (e.g. "orderdetails") to the subreport.

Remarks

Relative paths are relative to the current application's folder. The value cannot be an empty string.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.ReportName = "/salesreports/orderdetails";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


SubstituteThemeOnSubreport Property

[image]
ActiveReports 19 .NET Edition
SubstituteThemeOnSubreport Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : SubstituteThemeOnSubreport Property

Glossary Item Box

Gets or sets a value indicating whether the subreport uses the theme from the current report.

Syntax

Visual Basic (Declaration)
Public Property SubstituteThemeOnSubreport As Boolean
C#
public bool SubstituteThemeOnSubreport {get; set;}

Property Value

A System.Boolean value where true indicates that the subreport uses the theme from the current report; otherwise false. Default is false.

Example

C# Copy Code
Subreport subreport = new Subreport();
subreport.SubstituteThemeOnSubreport = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subreport Class
Subreport Members


Subtotal Class

[image]
ActiveReports 19 .NET Edition
Subtotal Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

Glossary Item Box

Represents a Subtotals element defines a subtotal column or row to include in a matrix.

Object Model

Subtotal Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Subtotal
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class Subtotal : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Remarks

In the subtotal column or row, the full set of data for the entire group is aggregated in the matrix cell.

If a matrix cell contains an aggregate that uses an explicit grouping scope contained within the scope of the aggregate, that scope is automatically adjusted to equal the current scope. For example, if a textbox in a matrix cell contains the expression =Sum(Fields!Sales.Value/Sum(Fields!Sales.Value,"State") and this subtotal is applied to the Country grouping scope, the expression evaluates to =Sum(Fields!Sales.Value)/Sum(Fields!Sales.Value,"Country"), since the State grouping scope is contained within the country grouping scope.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Subtotal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Members
GrapeCity.ActiveReports.PageReportModel Namespace


Subtotal Class Members

[image]
ActiveReports 19 .NET Edition
Subtotal Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

Glossary Item Box

The following tables list the members exposed by Subtotal.

Public Constructors

 | Name | Description
Public Constructor | Subtotal Constructor | Initializes a new instance of the Subtotal class.
Top

Public Properties

 | Name | Description
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the subtotal.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Name | Gets a name of a subtotal.
Public Property | Position | Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.
Public Property | Style | Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Subtotal object.
Top

See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


Subtotal Constructor

[image]
ActiveReports 19 .NET Edition
Subtotal Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Subtotal Constructor

Glossary Item Box

Initializes a new instance of the Subtotal class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Subtotal()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Subtotal Class Methods

[image]
ActiveReports 19 .NET Edition
Subtotal Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

Glossary Item Box

For a list of all members of this type, see Subtotal members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Subtotal object.
Top

See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Subtotal object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Subtotal Class Properties

[image]
ActiveReports 19 .NET Edition
Subtotal Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

Glossary Item Box

For a list of all members of this type, see Subtotal members.

Public Properties

 | Name | Description
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the subtotal.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Name | Gets a name of a subtotal.
Public Property | Position | Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.
Public Property | Style | Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.
Top

See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the subtotal.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for subtotal.

Remarks

Default value is "Total".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

Output indicates that the subtotal appears in the output.

NoOutput(Default) indicates that the subtotal does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Name Property

Glossary Item Box

Gets a name of a subtotal.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Remarks

The returned value is always "Subtotal".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Position Property

Glossary Item Box

Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.

Syntax

Visual Basic (Declaration)
Public Property Position As SubtotalPosition
C#
public SubtotalPosition Position {get; set;}

Property Value

A SubtotalPosition value indicating whether the subtotal column or row appears before or after the detail columns or rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Style Property

Glossary Item Box

Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the style properties that override any style properties of report items contained in the subtotal column or row.

Remarks

At Subtotal MatrixColumn and MatrixRow intersections, the MatrixRow style takes priority.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Subtotal Class
Subtotal Members


Table Class

[image]
ActiveReports 19 .NET Edition
Table Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

Glossary Item Box

Represents a table element defines a DataRegion that visualizes the bound data in a multicolumn, multirow fashion, with an ordered set of fields in columns and each data record displayed in a row.

Object Model

Table Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Table
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class Table : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Members
GrapeCity.ActiveReports.PageReportModel Namespace


Table Class Members

[image]
ActiveReports 19 .NET Edition
Table Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

Glossary Item Box

The following tables list the members exposed by Table.

Public Constructors

 | Name | Description
Public Constructor | Table Constructor | Initializes a new instance of the Table class.
Top

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DetailDataCollectionName | Gets or sets a name of the top-level XML element that represents the collection of all instances of the group.
Public Property | DetailDataElementName | Gets or sets a name of the top-level XML element that represents the details.
Public Property | DetailDataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Details | Gets or sets the detail rows for a table.
Public Property | Footer | Gets or sets a footer of a table.
Public Property | FrozenColumns | Gets or sets a number of frozen columns.
Public Property | FrozenRows | Gets or sets a number of frozen rows.
Public Property | Header | Gets or sets a header of a table.
Public Property | MaxDetailsPerPage | Gets or sets a maximum number of rows which can be in the details group on the page.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the header is displayed without at least one line of data below it.
Public Property | RepeatBlankRows | Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Public Property | RepeatToFill | Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | TableColumns | Gets a collection of the columns columns in a table.
Public Property | TableGroups | Gets the groups to use in a table.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this component.
Public Method | Validate | Overridden. Validates the current state of the Table object.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


Table Constructor

[image]
ActiveReports 19 .NET Edition
Table Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Table Constructor

Glossary Item Box

Initializes a new instance of the Table class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Table()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Methods

[image]
ActiveReports 19 .NET Edition
Table Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this component.
Public Method | Validate | Overridden. Validates the current state of the Table object.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this component.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Table object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Properties

[image]
ActiveReports 19 .NET Edition
Table Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Properties

 | Name | Description
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DetailDataCollectionName | Gets or sets a name of the top-level XML element that represents the collection of all instances of the group.
Public Property | DetailDataElementName | Gets or sets a name of the top-level XML element that represents the details.
Public Property | DetailDataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Details | Gets or sets the detail rows for a table.
Public Property | Footer | Gets or sets a footer of a table.
Public Property | FrozenColumns | Gets or sets a number of frozen columns.
Public Property | FrozenRows | Gets or sets a number of frozen rows.
Public Property | Header | Gets or sets a header of a table.
Public Property | MaxDetailsPerPage | Gets or sets a maximum number of rows which can be in the details group on the page.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the header is displayed without at least one line of data below it.
Public Property | RepeatBlankRows | Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Public Property | RepeatToFill | Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | TableColumns | Gets a collection of the columns columns in a table.
Public Property | TableGroups | Gets the groups to use in a table.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


DetailDataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DetailDataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataCollectionName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the collection of all instances of the group.

Syntax

Visual Basic (Declaration)
Public Property DetailDataCollectionName As String
C#
public string DetailDataCollectionName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for for the collection of all instances of the group.

Remarks

Default value is "Details_Collection".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


DetailDataElementName Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the details.

Syntax

Visual Basic (Declaration)
Public Property DetailDataElementName As String
C#
public string DetailDataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for details.

Remarks

Default value is "Details".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


DetailDataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DetailDataElementOutput As DataElementOutput
C#
public DataElementOutput DetailDataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

Output(Default) indicates that the details appears in the output.

NoOutput indicates that the details does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Details Property

Glossary Item Box

Gets or sets the detail rows for a table.

Syntax

Visual Basic (Declaration)
Public Property Details As Details
C#
public Details Details {get; set;}

Property Value

A Details object containing the set of detail rows for the table.

Remarks

The table must include at least one of the following: Details, Header, or Footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Footer Property

Glossary Item Box

Gets or sets a footer of a table.

Syntax

Visual Basic (Declaration)
Public Property Footer As Footer
C#
public Footer Footer {get; set;}

Property Value

A Footer object representing the footer of the table.

Remarks

The table must include at least one of the following: Details, Header, or Footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


FrozenColumns Property

[image]
ActiveReports 19 .NET Edition
FrozenColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : FrozenColumns Property

Glossary Item Box

Gets or sets a number of frozen columns.

Syntax

Visual Basic (Declaration)
Public Property FrozenColumns As Integer
C#
public int FrozenColumns {get; set;}

Property Value

An System.Int32 representing the number of columns that remain visible when the user scrolls horizontally.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


FrozenRows Property

[image]
ActiveReports 19 .NET Edition
FrozenRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : FrozenRows Property

Glossary Item Box

Gets or sets a number of frozen rows.

Syntax

Visual Basic (Declaration)
Public Property FrozenRows As Integer
C#
public int FrozenRows {get; set;}

Property Value

An System.Int32 value indicating the number of rows that remain visible when the user scrolls vertically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Header Property

Glossary Item Box

Gets or sets a header of a table.

Syntax

Visual Basic (Declaration)
Public Property Header As Header
C#
public Header Header {get; set;}

Property Value

A Header object representing the header of the table.

Remarks

The table must include at least one of the following: Details, Header, or Footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


MaxDetailsPerPage Property

[image]
ActiveReports 19 .NET Edition
MaxDetailsPerPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : MaxDetailsPerPage Property

Glossary Item Box

Gets or sets a maximum number of rows which can be in the details group on the page.

Syntax

Visual Basic (Declaration)
Public Property MaxDetailsPerPage As ExpressionInfo
C#
public ExpressionInfo MaxDetailsPerPage {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the maximum number of rows in the details group on the page.

Remarks

0, null, or an empty value are interpreted as 'no limit', which is the default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : PreventOrphanedFooter Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedFooter As Boolean
C#
public bool PreventOrphanedFooter {get; set;}

Property Value

A System.Boolean value where true if the orphaned footer is displayed on the next page; otherwise, false. Default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : PreventOrphanedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header is displayed without at least one line of data below it.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedHeader As Boolean
C#
public bool PreventOrphanedHeader {get; set;}

Property Value

A System.Boolean value where true if the header is displayed without at least one line of data below it; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


RepeatBlankRows Property

[image]
ActiveReports 19 .NET Edition
RepeatBlankRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : RepeatBlankRows Property

Glossary Item Box

Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.

Syntax

Visual Basic (Declaration)
Public Property RepeatBlankRows As RepeatBlankRows
C#
public RepeatBlankRows RepeatBlankRows {get; set;}

Property Value

A RepeatBlankRows value indicating whether a table should fill the space with empty rows to reach its FixedHeight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


RepeatToFill Property

[image]
ActiveReports 19 .NET Edition
RepeatToFill Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : RepeatToFill Property

Glossary Item Box

Gets or sets a value indicating whether a table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.

Syntax

Visual Basic (Declaration)
Public Property RepeatToFill As Boolean
C#
public bool RepeatToFill {get; set;}

Property Value

A System.Boolean value indicating whether a table should fill the space with empty rows to reach its FixedHeight.

Remarks

This property is obsolete. Please, use RepeatBlankRows property instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableColumns Property

[image]
ActiveReports 19 .NET Edition
TableColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : TableColumns Property

Glossary Item Box

Gets a collection of the columns columns in a table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableColumns As TableColumnCollection
C#
public TableColumnCollection TableColumns {get;}

Property Value

A TableColumnCollection object containing the columns in the table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableGroups Property

[image]
ActiveReports 19 .NET Edition
TableGroups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : TableGroups Property

Glossary Item Box

Gets the groups to use in a table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableGroups As TableGroupCollection
C#
public TableGroupCollection TableGroups {get;}

Property Value

A TableGroupCollection object containing the set of row groupings for the table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableCell Class

[image]
ActiveReports 19 .NET Edition
TableCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

Glossary Item Box

Represents a content container of a cell in a table data region.

Object Model

TableCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableCell
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TableCell : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer, IValidateable

Example

TableCell tableCell = new TableCell; tableCell.ColSpan = 2; tableCell.RowSpan = 1; tableCell.ReportItems = { new TextBox { Name = "Cell1", Width = "100pt", Height = "1in" }};

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.TableCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableCell Class Members

[image]
ActiveReports 19 .NET Edition
TableCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

Glossary Item Box

The following tables list the members exposed by TableCell.

Public Constructors

 | Name | Description
Public Constructor | TableCell Constructor | Initializes a new instance of the TableCell class.
Top

Public Properties

 | Name | Description
Public Property | AutoMergeMode | Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.
Public Property | ColSpan | Gets or sets a number of columns the cell spans.
Public Property | RowSpan | Gets or sets a number of rows the cell spans.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableCell object.
Top

See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableCell Constructor

[image]
ActiveReports 19 .NET Edition
TableCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : TableCell Constructor

Glossary Item Box

Initializes a new instance of the TableCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Class
TableCell Members


TableCell Class Methods

[image]
ActiveReports 19 .NET Edition
TableCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

Glossary Item Box

For a list of all members of this type, see TableCell members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableCell object.
Top

See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TableCell object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Class
TableCell Members


TableCell Class Properties

[image]
ActiveReports 19 .NET Edition
TableCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

Glossary Item Box

For a list of all members of this type, see TableCell members.

Public Properties

 | Name | Description
Public Property | AutoMergeMode | Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.
Public Property | ColSpan | Gets or sets a number of columns the cell spans.
Public Property | RowSpan | Gets or sets a number of rows the cell spans.
Top

See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoMergeMode Property

[image]
ActiveReports 19 .NET Edition
AutoMergeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : AutoMergeMode Property

Glossary Item Box

Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.

Syntax

Visual Basic (Declaration)
Public Property AutoMergeMode As MergePolicy
C#
public MergePolicy AutoMergeMode {get; set;}

Property Value

A MergePolicy value indicating the auto merging policy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Class
TableCell Members


ColSpan Property

[image]
ActiveReports 19 .NET Edition
ColSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : ColSpan Property

Glossary Item Box

Gets or sets a number of columns the cell spans.

Syntax

Visual Basic (Declaration)
Public Property ColSpan As Integer
C#
public int ColSpan {get; set;}

Property Value

An System.Int32 value indicating the number of columns the cell spans.

Remarks

A ColSpan of 1 is the same as not specifying a ColSpan.

For the purposes of hidden columns, the cell is considered to occupy the first visible column in which it appears. Hiding a spanned column reduces the effective number of spanned columns. The cell remains visible, spanning the non-hidden columns, unless all spanned columns are hidden.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Class
TableCell Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : RowSpan Property

Glossary Item Box

Gets or sets a number of rows the cell spans.

Syntax

Visual Basic (Declaration)
Public Property RowSpan As Integer
C#
public int RowSpan {get; set;}

Property Value

An System.Int32 value indicating the number of rows the cell spans.

Remarks

A RowSpan of 1 is the same as not specifying a RowSpan.

For the purposes of hidden rows, the cell is considered to occupy the first visible row in which it appears. Hiding a spanned row reduces the effective number of spanned rows. The cell remains visible, spanning the non-hidden rows, unless all spanned rows are hidden.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCell Class
TableCell Members


TableCellCollection Class

[image]
ActiveReports 19 .NET Edition
TableCellCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class

Glossary Item Box

Represents a strongly typed collection of TableCell objects.

Object Model

TableCellCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableCellCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of TableCell)
C#
public sealed class TableCellCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<TableCell>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.TableCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableCellCollection Class Members

[image]
ActiveReports 19 .NET Edition
TableCellCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class

Glossary Item Box

The following tables list the members exposed by TableCellCollection.

See Also

Reference

TableCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumn Class

[image]
ActiveReports 19 .NET Edition
TableColumn Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class

Glossary Item Box

Represents a column in the table, containing properties for the design table.

Object Model

TableColumn Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableColumn
C#
public sealed class TableColumn

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumn Class Members

[image]
ActiveReports 19 .NET Edition
TableColumn Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class

Glossary Item Box

The following tables list the members exposed by TableColumn.

Public Constructors

 | Name | Description
Public Constructor | TableColumn Constructor | Initializes a new instance of the TableColumn class.
Top

Public Properties

 | Name | Description
Public Property | AutoWidth | Gets or sets an auto grow behavior of the column when there are hidden columns are present.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Visibility | Gets or sets a value indicating whether the column is hidden.
Public Property | Width | Gets or sets a width of the column.
Top

See Also

Reference

TableColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumn Constructor

[image]
ActiveReports 19 .NET Edition
TableColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : TableColumn Constructor

Glossary Item Box

Initializes a new instance of the TableColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableColumn()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Class
TableColumn Members


TableColumn Class Properties

[image]
ActiveReports 19 .NET Edition
TableColumn Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class

Glossary Item Box

For a list of all members of this type, see TableColumn members.

Public Properties

 | Name | Description
Public Property | AutoWidth | Gets or sets an auto grow behavior of the column when there are hidden columns are present.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Visibility | Gets or sets a value indicating whether the column is hidden.
Public Property | Width | Gets or sets a width of the column.
Top

See Also

Reference

TableColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoWidth Property

[image]
ActiveReports 19 .NET Edition
AutoWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : AutoWidth Property

Glossary Item Box

Gets or sets an auto grow behavior of the column when there are hidden columns are present.

Syntax

Visual Basic (Declaration)
Public Property AutoWidth As AutoWidth
C#
public AutoWidth AutoWidth {get; set;}

Property Value

An AutoWidth value indicating the auto grow behavior of the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Class
TableColumn Members


FixedHeader Property

[image]
ActiveReports 19 .NET Edition
FixedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : FixedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedHeader As Boolean
C#
public bool FixedHeader {get; set;}

Property Value

A System.Boolean value where true indicating the grouping should be displayed on the page even when the user scrolls part of the table off the page; otherwise, false. Default value is false.

Remarks

Fixed headers must be touching each other and must also include the first or last column in the table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Class
TableColumn Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the column is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Class
TableColumn Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : Width Property

Glossary Item Box

Gets or sets a width of the column.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumn Class
TableColumn Members


TableColumnCollection Class

[image]
ActiveReports 19 .NET Edition
TableColumnCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

Glossary Item Box

Represents a strongly typed collection of TableColumn objects.

Object Model

TableColumnCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableColumnCollection
   Inherits System.Collections.ObjectModel.Collection(Of TableColumn)
C#
public sealed class TableColumnCollection : System.Collections.ObjectModel.Collection<TableColumn>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.TableColumnCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumnCollection Class Members

[image]
ActiveReports 19 .NET Edition
TableColumnCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

Glossary Item Box

The following tables list the members exposed by TableColumnCollection.

Public Constructors

 | Name | Description
Public Constructor | TableColumnCollection Constructor | Initializes a new instance of the TableColumnCollection class.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of TableColumn objects to the existing TableColumnCollection.
Top

See Also

Reference

TableColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumnCollection Constructor

[image]
ActiveReports 19 .NET Edition
TableColumnCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : TableColumnCollection Constructor

Glossary Item Box

Initializes a new instance of the TableColumnCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableColumnCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


TableColumnCollection Class Methods

[image]
ActiveReports 19 .NET Edition
TableColumnCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

Glossary Item Box

For a list of all members of this type, see TableColumnCollection members.

Public Methods

 | Name | Description
Public Method | AddRange | Adds a collection of TableColumn objects to the existing TableColumnCollection.
Top

See Also

Reference

TableColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : AddRange Method

collection
A collection of the TableColumn objects to add.

Glossary Item Box

Adds a collection of TableColumn objects to the existing TableColumnCollection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of TableColumn) _
)
C#
public void AddRange(
   IEnumerable<TableColumn> collection
)

Parameters

collection
A collection of the TableColumn objects to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


TableGroup Class

[image]
ActiveReports 19 .NET Edition
TableGroup Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

Glossary Item Box

Represents a group in a table, allows to group and sort the details rows by one or multiple criteria.

Object Model

TableGroup Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableGroup
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class TableGroup : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

The table group may have header and footer bands, which repeat for each group.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TableGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroup Class Members

[image]
ActiveReports 19 .NET Edition
TableGroup Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

Glossary Item Box

The following tables list the members exposed by TableGroup.

Public Constructors

 | Name | Description
Public Constructor | TableGroup Constructor | Initializes a new instance of the TableGroup class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Footer | Gets or sets a group footer row for the table.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Header | Gets or sets a group header row for the table.
Public Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the header is displayed without at least one line of data below it.
Public Property | Sorting | Gets the expressions by which to sort the data.
Public Property | Visibility | Gets or sets a value indicating whether the group is hidden.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableGroup object.
Top

See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroup Constructor

[image]
ActiveReports 19 .NET Edition
TableGroup Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : TableGroup Constructor

Glossary Item Box

Initializes a new instance of the TableGroup class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableGroup()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


TableGroup Class Methods

[image]
ActiveReports 19 .NET Edition
TableGroup Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

Glossary Item Box

For a list of all members of this type, see TableGroup members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableGroup object.
Top

See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TableGroup object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


TableGroup Class Properties

[image]
ActiveReports 19 .NET Edition
TableGroup Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

Glossary Item Box

For a list of all members of this type, see TableGroup members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Footer | Gets or sets a group footer row for the table.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Header | Gets or sets a group header row for the table.
Public Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Public Property | PreventOrphanedFooter | Gets or sets a value indicating whether the orphaned footer is displayed on the next page.
Public Property | PreventOrphanedHeader | Gets or sets a value indicating whether the header is displayed without at least one line of data below it.
Public Property | Sorting | Gets the expressions by which to sort the data.
Public Property | Visibility | Gets or sets a value indicating whether the group is hidden.
Top

See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Footer Property

Glossary Item Box

Gets or sets a group footer row for the table.

Syntax

Visual Basic (Declaration)
Public Property Footer As Footer
C#
public Footer Footer {get; set;}

Property Value

A Footer object containing the group footer row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Header Property

Glossary Item Box

Gets or sets a group header row for the table.

Syntax

Visual Basic (Declaration)
Public Property Header As Header
C#
public Header Header {get; set;}

Property Value

A Header object containing the group header row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : KeepTogether Property

Glossary Item Box

Gets or sets a value indicating whether a table group is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A System.Boolean value where true if the table group's content is kept together on a single page if possible; otherwise false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : PreventOrphanedFooter Property

Glossary Item Box

Gets or sets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedFooter As Boolean
C#
public bool PreventOrphanedFooter {get; set;}

Property Value

A System.Boolean value where true if the orphaned footer is displayed on the next page; otherwise, false. Default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : PreventOrphanedHeader Property

Glossary Item Box

Gets or sets a value indicating whether the header is displayed without at least one line of data below it.

Syntax

Visual Basic (Declaration)
Public Property PreventOrphanedHeader As Boolean
C#
public bool PreventOrphanedHeader {get; set;}

Property Value

A System.Boolean value where true if the header is displayed without at least one line of data below it; otherwise, false. Default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the group is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroup Class
TableGroup Members


TableGroupCollection Class

[image]
ActiveReports 19 .NET Edition
TableGroupCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class

Glossary Item Box

Represents a strongly typed collection of TableGroup objects.

Object Model

TableGroupCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableGroupCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of TableGroup)
C#
public sealed class TableGroupCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<TableGroup>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.TableGroupCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableGroupCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroupCollection Class Members

[image]
ActiveReports 19 .NET Edition
TableGroupCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class

Glossary Item Box

The following tables list the members exposed by TableGroupCollection.

See Also

Reference

TableGroupCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Class

[image]
ActiveReports 19 .NET Edition
TableOfContents Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

Glossary Item Box

Represents a table of contents that presents the document map.

Object Model

TableOfContents Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableOfContents
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public sealed class TableOfContents : ReportItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TableOfContents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Class Members

[image]
ActiveReports 19 .NET Edition
TableOfContents Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

Glossary Item Box

The following tables list the members exposed by TableOfContents.

Public Constructors

 | Name | Description
Public Constructor | TableOfContents Constructor | Initializes a new instance of the TableOfContents class.
Top

Public Properties

 | Name | Description
Public Property | FixedHeight | Gets or sets a fixed height of the table of contents.
Public Property | Levels | Gets a collection of levels in the table of contents.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | OverflowName | Gets or sets a name for overflow content.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether to insert a page break at the end.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether to insert a page break at the start.
Top

See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Constructor

[image]
ActiveReports 19 .NET Edition
TableOfContents Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : TableOfContents Constructor

Glossary Item Box

Initializes a new instance of the TableOfContents class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableOfContents()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


TableOfContents Class Properties

[image]
ActiveReports 19 .NET Edition
TableOfContents Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

Glossary Item Box

For a list of all members of this type, see TableOfContents members.

Public Properties

 | Name | Description
Public Property | FixedHeight | Gets or sets a fixed height of the table of contents.
Public Property | Levels | Gets a collection of levels in the table of contents.
Public Property | NewPage | Gets or sets a value indicating on which page the content should start after the page break.
Public Property | OverflowName | Gets or sets a name for overflow content.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether to insert a page break at the end.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether to insert a page break at the start.
Top

See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedHeight Property

[image]
ActiveReports 19 .NET Edition
FixedHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : FixedHeight Property

Glossary Item Box

Gets or sets a fixed height of the table of contents.

Syntax

Visual Basic (Declaration)
Public Property FixedHeight As Length
C#
public Length FixedHeight {get; set;}

Property Value

A Length value representing the fixed height of the table of contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


Levels Property

[image]
ActiveReports 19 .NET Edition
Levels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Levels Property

Glossary Item Box

Gets a collection of levels in the table of contents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Levels As IList(Of TableOfContentsLevel)
C#
public IList<TableOfContentsLevel> Levels {get;}

Property Value

A collection of the TableOfContentsLevel objects representing the levels in the table of contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


NewPage Property

[image]
ActiveReports 19 .NET Edition
NewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : NewPage Property

Glossary Item Box

Gets or sets a value indicating on which page the content should start after the page break.

Syntax

Visual Basic (Declaration)
Public Property NewPage As StartNewPage
C#
public StartNewPage NewPage {get; set;}

Property Value

A StartNewPage value indicating the page to start after the page break.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : OverflowName Property

Glossary Item Box

Gets or sets a name for overflow content.

Syntax

Visual Basic (Declaration)
Public Property OverflowName As String
C#
public string OverflowName {get; set;}

Property Value

A System.String value indicating the name for overflow content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : PageBreakAtEnd Property

Glossary Item Box

Gets or sets a value indicating whether to insert a page break at the end.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get; set;}

Property Value

A System.Boolean value where true if a page break should be inserted at the end; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : PageBreakAtStart Property

Glossary Item Box

Gets or sets a value indicating whether to insert a page break at the start.

Syntax

Visual Basic (Declaration)
Public Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get; set;}

Property Value

A System.Boolean value where true if a page break should be inserted at the start; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents Class
TableOfContents Members


TableOfContents.Defaults Class

[image]
ActiveReports 19 .NET Edition
TableOfContents.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents.Defaults Class

Glossary Item Box

Represents the default values for TableOfContents properties.

Object Model

TableOfContents.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class TableOfContents.Defaults
C#
public static class TableOfContents.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableOfContents.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
TableOfContents.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents.Defaults Class

Glossary Item Box

The following tables list the members exposed by TableOfContents.Defaults.

Public Fields

 | Name | Description
Public Field | MaxLevel | The default maximum level
Public Field | NewPage | Tha default NewPage
Public Field | PageBreakAtEnd | The default PageBreakAtEnd
Public Field | PageBreakAtStart | The default PageBreakAtStart
Top

See Also

Reference

TableOfContents.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
TableOfContents.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents.Defaults Class

Glossary Item Box

For a list of all members of this type, see TableOfContents.Defaults members.

Public Fields

 | Name | Description
Public Field | MaxLevel | The default maximum level
Public Field | NewPage | Tha default NewPage
Public Field | PageBreakAtEnd | The default PageBreakAtEnd
Public Field | PageBreakAtStart | The default PageBreakAtStart
Top

See Also

Reference

TableOfContents.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaxLevel Field

[image]
ActiveReports 19 .NET Edition
MaxLevel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents.Defaults Class : MaxLevel Field

Glossary Item Box

The default maximum level

Syntax

Visual Basic (Declaration)
Public Const MaxLevel As String
C#
public const string MaxLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents.Defaults Class
TableOfContents.Defaults Members


NewPage Field

[image]
ActiveReports 19 .NET Edition
NewPage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents.Defaults Class : NewPage Field

Glossary Item Box

Tha default NewPage

Syntax

Visual Basic (Declaration)
Public Const NewPage As StartNewPage
C#
public const StartNewPage NewPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents.Defaults Class
TableOfContents.Defaults Members


PageBreakAtEnd Field

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents.Defaults Class : PageBreakAtEnd Field

Glossary Item Box

The default PageBreakAtEnd

Syntax

Visual Basic (Declaration)
Public Const PageBreakAtEnd As Boolean
C#
public const bool PageBreakAtEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents.Defaults Class
TableOfContents.Defaults Members


PageBreakAtStart Field

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents.Defaults Class : PageBreakAtStart Field

Glossary Item Box

The default PageBreakAtStart

Syntax

Visual Basic (Declaration)
Public Const PageBreakAtStart As Boolean
C#
public const bool PageBreakAtStart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContents.Defaults Class
TableOfContents.Defaults Members


TableOfContentsLevel Class

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class

Glossary Item Box

Represents a level within the TableOfContents.

Object Model

TableOfContentsLevel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableOfContentsLevel
C#
public sealed class TableOfContentsLevel

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableOfContentsLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel Class Members

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class

Glossary Item Box

The following tables list the members exposed by TableOfContentsLevel.

Public Constructors

 | Name | Description
Public Constructor | TableOfContentsLevel Constructor | Initializes a new instance of TableOfContentsLevel class.
Top

Public Properties

 | Name | Description
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents this level.
Public Property | Name | Gets or sets a name of the level.
Public Property | Style | Gets or sets the style of the level.
Top

See Also

Reference

TableOfContentsLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel Constructor

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : TableOfContentsLevel Constructor

Glossary Item Box

Initializes a new instance of TableOfContentsLevel class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableOfContentsLevel()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


TableOfContentsLevel Class Properties

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class

Glossary Item Box

For a list of all members of this type, see TableOfContentsLevel members.

Public Properties

 | Name | Description
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents this level.
Public Property | Name | Gets or sets a name of the level.
Public Property | Style | Gets or sets the style of the level.
Top

See Also

Reference

TableOfContentsLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents this level.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for this level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : Name Property

Glossary Item Box

Gets or sets a name of the level.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : Style Property

Glossary Item Box

Gets or sets the style of the level.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object representing the style of the level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


TableOfContentsLevel.Defaults Class

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel.Defaults Class

Glossary Item Box

Represents the default values for TableOfContentsLevel properties.

Object Model

TableOfContentsLevel.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class TableOfContentsLevel.Defaults
C#
public static class TableOfContentsLevel.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableOfContentsLevel.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel.Defaults Class

Glossary Item Box

The following tables list the members exposed by TableOfContentsLevel.Defaults.

Public Fields

 | Name | Description
Public Field | Label | The default label
Public Field | LeadingChar | The default leading character
Public Field | TextIndent | The default text indent
Top

See Also

Reference

TableOfContentsLevel.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
TableOfContentsLevel.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel.Defaults Class

Glossary Item Box

For a list of all members of this type, see TableOfContentsLevel.Defaults members.

Public Fields

 | Name | Description
Public Field | Label | The default label
Public Field | LeadingChar | The default leading character
Public Field | TextIndent | The default text indent
Top

See Also

Reference

TableOfContentsLevel.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


Label Field

[image]
ActiveReports 19 .NET Edition
Label Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel.Defaults Class : Label Field

Glossary Item Box

The default label

Syntax

Visual Basic (Declaration)
Public Const Label As String
C#
public const string Label

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel.Defaults Class
TableOfContentsLevel.Defaults Members


LeadingChar Field

[image]
ActiveReports 19 .NET Edition
LeadingChar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel.Defaults Class : LeadingChar Field

Glossary Item Box

The default leading character

Syntax

Visual Basic (Declaration)
Public Const LeadingChar As String
C#
public const string LeadingChar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel.Defaults Class
TableOfContentsLevel.Defaults Members


TextIndent Field

[image]
ActiveReports 19 .NET Edition
TextIndent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel.Defaults Class : TextIndent Field

Glossary Item Box

The default text indent

Syntax

Visual Basic (Declaration)
Public Const TextIndent As String
C#
public const string TextIndent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableOfContentsLevel.Defaults Class
TableOfContentsLevel.Defaults Members


TableRow Class

[image]
ActiveReports 19 .NET Edition
TableRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

Glossary Item Box

Represents a row in a table data region, containing table cells.

Object Model

TableRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TableRow : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TableRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableRow Class Members

[image]
ActiveReports 19 .NET Edition
TableRow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

Glossary Item Box

The following tables list the members exposed by TableRow.

Public Constructors

 | Name | Description
Public Constructor | TableRow Constructor | Initializes a new instance of the TableRow class.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets an action (e.g., hyperlink) associated with the row.
Public Property | CanShrink | Gets a value indicating whether a row can shrink.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of the row.
Public Property | TableCells | Gets the cells with a content of the row.
Public Property | Visibility | Gets or sets a value indicating whether the row is hidden.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableRow object.
Top

See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableRow Constructor

[image]
ActiveReports 19 .NET Edition
TableRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : TableRow Constructor

Glossary Item Box

Initializes a new instance of the TableRow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TableRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


TableRow Class Methods

[image]
ActiveReports 19 .NET Edition
TableRow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

Glossary Item Box

For a list of all members of this type, see TableRow members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TableRow object.
Top

See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TableRow object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


TableRow Class Properties

[image]
ActiveReports 19 .NET Edition
TableRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

Glossary Item Box

For a list of all members of this type, see TableRow members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets an action (e.g., hyperlink) associated with the row.
Public Property | CanShrink | Gets a value indicating whether a row can shrink.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of the row.
Public Property | TableCells | Gets the cells with a content of the row.
Public Property | Visibility | Gets or sets a value indicating whether the row is hidden.
Top

See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Action Property

Glossary Item Box

Gets or sets an action (e.g., hyperlink) associated with the row.

Syntax

Visual Basic (Declaration)
Public Property Action As Action
C#
public Action Action {get; set;}

Property Value

An Action object representing the action to perform when the row is clicked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : CanShrink Property

Glossary Item Box

Gets a value indicating whether a row can shrink.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanShrink As Boolean
C#
public bool CanShrink {get;}

Property Value

A System.Boolean value where true if the row contains only TextBox with CanShrink set to true; otherwise, false.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Height Property

Glossary Item Box

Gets or sets a height of the row.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


TableCells Property

[image]
ActiveReports 19 .NET Edition
TableCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : TableCells Property

Glossary Item Box

Gets the cells with a content of the row.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableCells As TableCellCollection
C#
public TableCellCollection TableCells {get;}

Property Value

A TableCellCollection object containing the cells of the row.

Remarks

There is one cell per column in a table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the row is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRow Class
TableRow Members


TableRowCollection Class

[image]
ActiveReports 19 .NET Edition
TableRowCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class

Glossary Item Box

Represents a strongly typed collection of TableRow objects.

Object Model

TableRowCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableRowCollection
   Inherits GrapeCity.ActiveReports.PageReportModel.ItemCollection(Of TableRow)
C#
public sealed class TableRowCollection : GrapeCity.ActiveReports.PageReportModel.ItemCollection<TableRow>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ItemCollection<T>
GrapeCity.ActiveReports.PageReportModel.TableRowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableRowCollection Class Members

[image]
ActiveReports 19 .NET Edition
TableRowCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class

Glossary Item Box

The following tables list the members exposed by TableRowCollection.

See Also

Reference

TableRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Tablix Class

[image]
ActiveReports 19 .NET Edition
Tablix Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Tablix Class

Glossary Item Box

Represents a DataRegion that displays the data in a cross-table format, defined a flexible layout grid with nested repeating column groups and row groups.

Object Model

Tablix Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Tablix
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class Tablix : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

A tablix is a combination of two data regions, a table and a matrix. Therefore, it combines the functionalities of both the data regions (table and matrix) with added capabilities including the support for adjacent groups, interactive layout options such as the stepped row group, collapsed group.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Tablix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Members
GrapeCity.ActiveReports.PageReportModel Namespace


Tablix Class Members

[image]
ActiveReports 19 .NET Edition
Tablix Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Tablix Class

Glossary Item Box

The following tables list the members exposed by Tablix.

Public Constructors

 | Name | Description
Public Constructor | Tablix Constructor | Initializes a new instance of the Tablix class.
Top

Public Properties

 | Name | Description
Public Property | ActionInfo | Gets or sets the actions associated with the ReportItem.
Public Property | BandLayoutOptions | Gets or sets the band layout options used to navigate by the tablix.
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | CanScroll | Gets or sets a value indicating whether the tablix will have scroll bars when the content size exceeds the defined size of the tablix.
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | FixedColumnHeaders | Gets or sets a value indicating whether the column headers should remain visible when the user scrolls part of the Tablix off the page.
Public Property | FixedRowHeaders | Gets or sets a value indicating whether the row headers should remain visible when the user scrolls part of the Tablix off the page.
Public Property | FrozenColumns | Gets or sets a number of frozen columns.
Public Property | FrozenRows | Gets or sets a number of frozen rows.
Public Property | GroupsBeforeRowHeaders | Gets or sets a number of instances of the leftmost outer column member that should appear to the left of the row headers, right of the row headers for tablix with RTL direction.
Public Property | LayoutDirection | Gets or sets a overall layout direction of the Tablix.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | OmitBorderOnPageBreak | Gets or sets a value indicating whether the borders should be omitted at locations where the tablix spans multiple pages.
Public Property | PageBreak | Gets or sets a page break options.
Public Property | RepeatColumnHeaders | Gets or sets a value indicating whether the column headers should be repeated on each page where a portion of the tablix appears.
Public Property | RepeatRowHeaders | Gets or sets a value indicating whether the row headers should be repeated on each page where a portion of the tablix appears.
Public Property | RepeatToFill | Gets or sets a value indicating whether the tablix should fill the space with empty rows to reach its fixed height.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | Sorting | Gets the expressions by which to sort the columns or rows.
Public Property | TablixBody | Gets a region that contains the data elements of the tablix.
Public Property | TablixColumnHierarchy | Gets a column member hierarchy for the tablix.
Public Property | TablixCorner | Gets or sets a region containing the elements in the upper-left corner of the еablix.
Public Property | TablixRowHierarchy | Gets a row member hierarchy for the Tablix.
Public Property | TopMargin | Gets or sets a height of the top margin.
Top

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the Tablix object.
Public Method | ValidateCommon | Validates the information in each property of the Tablix object.
Top

See Also

Reference

Tablix Class
GrapeCity.ActiveReports.PageReportModel Namespace


Tablix Constructor

[image]
ActiveReports 19 .NET Edition
Tablix Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : Tablix Constructor

Glossary Item Box

Initializes a new instance of the Tablix class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Tablix()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


Tablix Class Methods

[image]
ActiveReports 19 .NET Edition
Tablix Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Tablix Class

Glossary Item Box

For a list of all members of this type, see Tablix members.

Public Methods

 | Name | Description
Public Method | Validate | Overridden. Validates the current state of the Tablix object.
Public Method | ValidateCommon | Validates the information in each property of the Tablix object.
Top

See Also

Reference

Tablix Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Tablix object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


ValidateCommon Method

[image]
ActiveReports 19 .NET Edition
ValidateCommon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : ValidateCommon Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Tablix object.

Syntax

Visual Basic (Declaration)
Public Function ValidateCommon( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] ValidateCommon(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


Tablix Class Properties

[image]
ActiveReports 19 .NET Edition
Tablix Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Tablix Class

Glossary Item Box

For a list of all members of this type, see Tablix members.

Public Properties

 | Name | Description
Public Property | ActionInfo | Gets or sets the actions associated with the ReportItem.
Public Property | BandLayoutOptions | Gets or sets the band layout options used to navigate by the tablix.
Public Property | BottomMargin | Gets or sets a height of the bottom margin.
Public Property | CanScroll | Gets or sets a value indicating whether the tablix will have scroll bars when the content size exceeds the defined size of the tablix.
Public Property | ChildScopes | Overridden. Gets the child scopes for the fixed page.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | FixedColumnHeaders | Gets or sets a value indicating whether the column headers should remain visible when the user scrolls part of the Tablix off the page.
Public Property | FixedRowHeaders | Gets or sets a value indicating whether the row headers should remain visible when the user scrolls part of the Tablix off the page.
Public Property | FrozenColumns | Gets or sets a number of frozen columns.
Public Property | FrozenRows | Gets or sets a number of frozen rows.
Public Property | GroupsBeforeRowHeaders | Gets or sets a number of instances of the leftmost outer column member that should appear to the left of the row headers, right of the row headers for tablix with RTL direction.
Public Property | LayoutDirection | Gets or sets a overall layout direction of the Tablix.
Public Property | LeftMargin | Gets or sets a width of the left margin.
Public Property | OmitBorderOnPageBreak | Gets or sets a value indicating whether the borders should be omitted at locations where the tablix spans multiple pages.
Public Property | PageBreak | Gets or sets a page break options.
Public Property | RepeatColumnHeaders | Gets or sets a value indicating whether the column headers should be repeated on each page where a portion of the tablix appears.
Public Property | RepeatRowHeaders | Gets or sets a value indicating whether the row headers should be repeated on each page where a portion of the tablix appears.
Public Property | RepeatToFill | Gets or sets a value indicating whether the tablix should fill the space with empty rows to reach its fixed height.
Public Property | ReportItemsInScope | Overridden. Gets the report items in scope for the fixed page.
Public Property | RightMargin | Gets or sets a width of the right margin.
Public Property | Sorting | Gets the expressions by which to sort the columns or rows.
Public Property | TablixBody | Gets a region that contains the data elements of the tablix.
Public Property | TablixColumnHierarchy | Gets a column member hierarchy for the tablix.
Public Property | TablixCorner | Gets or sets a region containing the elements in the upper-left corner of the еablix.
Public Property | TablixRowHierarchy | Gets a row member hierarchy for the Tablix.
Public Property | TopMargin | Gets or sets a height of the top margin.
Top

See Also

Reference

Tablix Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property

[image]
ActiveReports 19 .NET Edition
ActionInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : ActionInfo Property

Glossary Item Box

Gets or sets the actions associated with the ReportItem.

Syntax

Visual Basic (Declaration)
Public Property ActionInfo As ActionInfo
C#
public ActionInfo ActionInfo {get; set;}

Property Value

An ActionInfo object representing the actions associated with the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


BandLayoutOptions Property

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : BandLayoutOptions Property

Glossary Item Box

Gets or sets the band layout options used to navigate by the tablix.

Syntax

Visual Basic (Declaration)
Public Property BandLayoutOptions As BandLayoutOptions
C#
public BandLayoutOptions BandLayoutOptions {get; set;}

Property Value

A BandLayoutOptions object representing the band layout options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : BottomMargin Property

Glossary Item Box

Gets or sets a height of the bottom margin.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As Length
C#
public Length BottomMargin {get; set;}

Property Value

A Length value indicating the height of the bottom margin. Default value is 0in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


CanScroll Property

[image]
ActiveReports 19 .NET Edition
CanScroll Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : CanScroll Property

Glossary Item Box

Gets or sets a value indicating whether the tablix will have scroll bars when the content size exceeds the defined size of the tablix.

Syntax

Visual Basic (Declaration)
Public Property CanScroll As Boolean
C#
public bool CanScroll {get; set;}

Property Value

A System.Boolean value indicating whether the tablix can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : ChildScopes Property

Glossary Item Box

Gets the child scopes for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ChildScopes As IEnumerable
C#
public override IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of child scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


FixedColumnHeaders Property

[image]
ActiveReports 19 .NET Edition
FixedColumnHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : FixedColumnHeaders Property

Glossary Item Box

Gets or sets a value indicating whether the column headers should remain visible when the user scrolls part of the Tablix off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedColumnHeaders As Boolean
C#
public bool FixedColumnHeaders {get; set;}

Property Value

A System.Boolean value indicating whether to fix column headers during scrolling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


FixedRowHeaders Property

[image]
ActiveReports 19 .NET Edition
FixedRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : FixedRowHeaders Property

Glossary Item Box

Gets or sets a value indicating whether the row headers should remain visible when the user scrolls part of the Tablix off the page.

Syntax

Visual Basic (Declaration)
Public Property FixedRowHeaders As Boolean
C#
public bool FixedRowHeaders {get; set;}

Property Value

A System.Boolean value indicating whether to fix row headers during scrolling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


FrozenColumns Property

[image]
ActiveReports 19 .NET Edition
FrozenColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : FrozenColumns Property

Glossary Item Box

Gets or sets a number of frozen columns.

Syntax

Visual Basic (Declaration)
Public Property FrozenColumns As Integer
C#
public int FrozenColumns {get; set;}

Property Value

An System.Int32 representing the number of columns that remain visible when the user scrolls horizontally.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


FrozenRows Property

[image]
ActiveReports 19 .NET Edition
FrozenRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : FrozenRows Property

Glossary Item Box

Gets or sets a number of frozen rows.

Syntax

Visual Basic (Declaration)
Public Property FrozenRows As Integer
C#
public int FrozenRows {get; set;}

Property Value

An System.Int32 value indicating the number of rows that remain visible when the user scrolls vertically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


GroupsBeforeRowHeaders Property

[image]
ActiveReports 19 .NET Edition
GroupsBeforeRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : GroupsBeforeRowHeaders Property

Glossary Item Box

Gets or sets a number of instances of the leftmost outer column member that should appear to the left of the row headers, right of the row headers for tablix with RTL direction.

Syntax

Visual Basic (Declaration)
Public Property GroupsBeforeRowHeaders As Integer
C#
public int GroupsBeforeRowHeaders {get; set;}

Property Value

An System.Int32 value indicating the number of groups before the row headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


LayoutDirection Property

[image]
ActiveReports 19 .NET Edition
LayoutDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : LayoutDirection Property

Glossary Item Box

Gets or sets a overall layout direction of the Tablix.

Syntax

Visual Basic (Declaration)
Public Property LayoutDirection As LayoutDirection
C#
public LayoutDirection LayoutDirection {get; set;}

Property Value

A LayoutDirection value indicating the layout direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : LeftMargin Property

Glossary Item Box

Gets or sets a width of the left margin.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As Length
C#
public Length LeftMargin {get; set;}

Property Value

A Length value indicating the width of the left margin. Default value is 0in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


OmitBorderOnPageBreak Property

[image]
ActiveReports 19 .NET Edition
OmitBorderOnPageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : OmitBorderOnPageBreak Property

Glossary Item Box

Gets or sets a value indicating whether the borders should be omitted at locations where the tablix spans multiple pages.

Syntax

Visual Basic (Declaration)
Public Property OmitBorderOnPageBreak As Boolean
C#
public bool OmitBorderOnPageBreak {get; set;}

Property Value

A System.Boolean value indicating whether to omit borders on page breaks.

Remarks

This also causes repeated background images to continue rather than restart after a page break.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : PageBreak Property

Glossary Item Box

Gets or sets a page break options.

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
C#
public PageBreak PageBreak {get; set;}

Property Value

A PageBreak object representing the page break options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


RepeatColumnHeaders Property

[image]
ActiveReports 19 .NET Edition
RepeatColumnHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : RepeatColumnHeaders Property

Glossary Item Box

Gets or sets a value indicating whether the column headers should be repeated on each page where a portion of the tablix appears.

Syntax

Visual Basic (Declaration)
Public Property RepeatColumnHeaders As Boolean
C#
public bool RepeatColumnHeaders {get; set;}

Property Value

A System.Boolean value indicating whether to repeat column headers on each page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


RepeatRowHeaders Property

[image]
ActiveReports 19 .NET Edition
RepeatRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : RepeatRowHeaders Property

Glossary Item Box

Gets or sets a value indicating whether the row headers should be repeated on each page where a portion of the tablix appears.

Syntax

Visual Basic (Declaration)
Public Property RepeatRowHeaders As Boolean
C#
public bool RepeatRowHeaders {get; set;}

Property Value

A System.Boolean value indicating whether to repeat row headers on each page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


RepeatToFill Property

[image]
ActiveReports 19 .NET Edition
RepeatToFill Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : RepeatToFill Property

Glossary Item Box

Gets or sets a value indicating whether the tablix should fill the space with empty rows to reach its fixed height.

Syntax

Visual Basic (Declaration)
Public Property RepeatToFill As Boolean
C#
public bool RepeatToFill {get; set;}

Property Value

A System.Boolean value indicating whether to repeat empty rows to fill space.

Remarks

This is applicable to FPL reports only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : ReportItemsInScope Property

Glossary Item Box

Gets the report items in scope for the fixed page.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As IEnumerable
C#
public override IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of report items in scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : RightMargin Property

Glossary Item Box

Gets or sets a width of the right margin.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As Length
C#
public Length RightMargin {get; set;}

Property Value

A Length value indicating the width of the right margin. Default value is 0in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the columns or rows.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the columns or rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TablixBody Property

[image]
ActiveReports 19 .NET Edition
TablixBody Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : TablixBody Property

Glossary Item Box

Gets a region that contains the data elements of the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixBody As TablixBody
C#
public TablixBody TablixBody {get;}

Property Value

A TablixBody object representing the data elements region of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TablixColumnHierarchy Property

[image]
ActiveReports 19 .NET Edition
TablixColumnHierarchy Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : TablixColumnHierarchy Property

Glossary Item Box

Gets a column member hierarchy for the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixColumnHierarchy As TablixHierarchy
C#
public TablixHierarchy TablixColumnHierarchy {get;}

Property Value

A TablixHierarchy object representing the column hierarchy of the Tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TablixCorner Property

[image]
ActiveReports 19 .NET Edition
TablixCorner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : TablixCorner Property

Glossary Item Box

Gets or sets a region containing the elements in the upper-left corner of the еablix.

Syntax

Visual Basic (Declaration)
Public Property TablixCorner As TablixCorner
C#
public TablixCorner TablixCorner {get; set;}

Property Value

A TablixCorner object representing the corner region of the еablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TablixRowHierarchy Property

[image]
ActiveReports 19 .NET Edition
TablixRowHierarchy Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : TablixRowHierarchy Property

Glossary Item Box

Gets a row member hierarchy for the Tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixRowHierarchy As TablixHierarchy
C#
public TablixHierarchy TablixRowHierarchy {get;}

Property Value

A TablixHierarchy object representing the row hierarchy of the Tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Tablix Class : TopMargin Property

Glossary Item Box

Gets or sets a height of the top margin.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As Length
C#
public Length TopMargin {get; set;}

Property Value

A Length value indicating the height of the top margin. Default value is 0in.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tablix Class
Tablix Members


TablixBody Class

[image]
ActiveReports 19 .NET Edition
TablixBody Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixBody Class

Glossary Item Box

Represents a layout and structure of the bottom right region containing the columns and rows of the tablix.

Object Model

TablixBody Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixBody
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixBody : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixBody

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixBody Class Members

[image]
ActiveReports 19 .NET Edition
TablixBody Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixBody Class

Glossary Item Box

The following tables list the members exposed by TablixBody.

Public Constructors

 | Name | Description
Public Constructor | TablixBody Constructor | Initializes a new instance of the TablixBody class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixColumns | Gets a collection of columns in the body section of the tablix.
Public Property | TablixRows | Gets a collection of rows in the body section of the tablix.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixBody object.
Top

See Also

Reference

TablixBody Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixBody Constructor

[image]
ActiveReports 19 .NET Edition
TablixBody Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixBody Class : TablixBody Constructor

Glossary Item Box

Initializes a new instance of the TablixBody class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixBody()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Class
TablixBody Members


TablixBody Class Methods

[image]
ActiveReports 19 .NET Edition
TablixBody Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixBody Class

Glossary Item Box

For a list of all members of this type, see TablixBody members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixBody object.
Top

See Also

Reference

TablixBody Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixBody Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixBody object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Class
TablixBody Members


TablixBody Class Properties

[image]
ActiveReports 19 .NET Edition
TablixBody Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixBody Class

Glossary Item Box

For a list of all members of this type, see TablixBody members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixColumns | Gets a collection of columns in the body section of the tablix.
Public Property | TablixRows | Gets a collection of rows in the body section of the tablix.
Top

See Also

Reference

TablixBody Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixBody Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Class
TablixBody Members


TablixColumns Property

[image]
ActiveReports 19 .NET Edition
TablixColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixBody Class : TablixColumns Property

Glossary Item Box

Gets a collection of columns in the body section of the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixColumns As IList(Of TablixColumn)
C#
public IList<TablixColumn> TablixColumns {get;}

Property Value

An IList object containing the columns in the body section of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Class
TablixBody Members


TablixRows Property

[image]
ActiveReports 19 .NET Edition
TablixRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixBody Class : TablixRows Property

Glossary Item Box

Gets a collection of rows in the body section of the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixRows As TablixItems(Of TablixRow)
C#
public TablixItems<TablixRow> TablixRows {get;}

Property Value

A TablixItems<T> object containing the rows in the body section of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixBody Class
TablixBody Members


TablixCell Class

[image]
ActiveReports 19 .NET Edition
TablixCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCell Class

Glossary Item Box

Represents the contents of each cell in the body section of a tablix.

Object Model

TablixCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixCell
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixCell : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCell Class Members

[image]
ActiveReports 19 .NET Edition
TablixCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCell Class

Glossary Item Box

The following tables list the members exposed by TablixCell.

Public Constructors

 | Name | Description
Public Constructor | TablixCell Constructor | Initializes a new instance of the TablixCell class.
Top

Public Properties

 | Name | Description
Public Property | AutoMergeMode | Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.
Public Property | CellContents | Gets or sets a report item contained in a cell.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCell object.
Top

See Also

Reference

TablixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCell Constructor

[image]
ActiveReports 19 .NET Edition
TablixCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : TablixCell Constructor

Glossary Item Box

Initializes a new instance of the TablixCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


TablixCell Class Methods

[image]
ActiveReports 19 .NET Edition
TablixCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCell Class

Glossary Item Box

For a list of all members of this type, see TablixCell members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCell object.
Top

See Also

Reference

TablixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixCell object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


TablixCell Class Properties

[image]
ActiveReports 19 .NET Edition
TablixCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCell Class

Glossary Item Box

For a list of all members of this type, see TablixCell members.

Public Properties

 | Name | Description
Public Property | AutoMergeMode | Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.
Public Property | CellContents | Gets or sets a report item contained in a cell.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Top

See Also

Reference

TablixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoMergeMode Property

[image]
ActiveReports 19 .NET Edition
AutoMergeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : AutoMergeMode Property

Glossary Item Box

Gets a mode to merge the adjacent cells (text boxes) in a row group with the same value.

Syntax

Visual Basic (Declaration)
Public Property AutoMergeMode As MergePolicy
C#
public MergePolicy AutoMergeMode {get; set;}

Property Value

A MergePolicy value indicating the auto merging policy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : CellContents Property

Glossary Item Box

Gets or sets a report item contained in a cell.

Syntax

Visual Basic (Declaration)
Public Property CellContents As CellContents
C#
public CellContents CellContents {get; set;}

Property Value

A CellContents object representing the report item within the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the instances of this group.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for instances of this group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCell Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the group appears in the output.

NoOutput indicates that the group does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCell Class
TablixCell Members


TablixColumn Class

[image]
ActiveReports 19 .NET Edition
TablixColumn Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixColumn Class

Glossary Item Box

Represents a column within the body section of a tablix.

Object Model

TablixColumn Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixColumn
C#
public sealed class TablixColumn

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TablixColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixColumn Class Members

[image]
ActiveReports 19 .NET Edition
TablixColumn Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixColumn Class

Glossary Item Box

The following tables list the members exposed by TablixColumn.

Public Constructors

 | Name | Description
Public Constructor | TablixColumn Constructor | Initializes a new instance of the TablixColumn class.
Top

Public Properties

 | Name | Description
Public Property | Width | Gets or sets a width of each cell in this column.
Top

See Also

Reference

TablixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixColumn Constructor

[image]
ActiveReports 19 .NET Edition
TablixColumn Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixColumn Class : TablixColumn Constructor

Glossary Item Box

Initializes a new instance of the TablixColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixColumn()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixColumn Class
TablixColumn Members


TablixColumn Class Properties

[image]
ActiveReports 19 .NET Edition
TablixColumn Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixColumn Class

Glossary Item Box

For a list of all members of this type, see TablixColumn members.

Public Properties

 | Name | Description
Public Property | Width | Gets or sets a width of each cell in this column.
Top

See Also

Reference

TablixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixColumn Class : Width Property

Glossary Item Box

Gets or sets a width of each cell in this column.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Property Value

A Length value indicating the width of the cells in this column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixColumn Class
TablixColumn Members


TablixCorner Class

[image]
ActiveReports 19 .NET Edition
TablixCorner Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCorner Class

Glossary Item Box

Represents a layout and structure of the upper left-hand corner region of a tablix. The height of the corner is the sum of the heights of the column headers, and the width of the corner is the sum of the widths of the row headers.

Object Model

TablixCorner Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixCorner
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixCorner : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Remarks

This class contains a collection of TablixCornerRow objects, which in turn contain TablixCornerCell objects, allowing for a detailed and structured layout of the corner section.

A corner may contain only static cells that are rendered only once in Tablix.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixCorner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCorner Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCorner Class Members

[image]
ActiveReports 19 .NET Edition
TablixCorner Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCorner Class

Glossary Item Box

The following tables list the members exposed by TablixCorner.

Public Constructors

 | Name | Description
Public Constructor | TablixCorner Constructor | Creates a new instance of the TablixCorner class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixCornerRows | Gets a collection of rows in the corner section of the tablix.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCorner object.
Top

See Also

Reference

TablixCorner Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCorner Constructor

[image]
ActiveReports 19 .NET Edition
TablixCorner Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCorner Class : TablixCorner Constructor

Glossary Item Box

Creates a new instance of the TablixCorner class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixCorner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCorner Class
TablixCorner Members


TablixCorner Class Methods

[image]
ActiveReports 19 .NET Edition
TablixCorner Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCorner Class

Glossary Item Box

For a list of all members of this type, see TablixCorner members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCorner object.
Top

See Also

Reference

TablixCorner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCorner Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixCorner object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCorner Class
TablixCorner Members


TablixCorner Class Properties

[image]
ActiveReports 19 .NET Edition
TablixCorner Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCorner Class

Glossary Item Box

For a list of all members of this type, see TablixCorner members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixCornerRows | Gets a collection of rows in the corner section of the tablix.
Top

See Also

Reference

TablixCorner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCorner Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCorner Class
TablixCorner Members


TablixCornerRows Property

[image]
ActiveReports 19 .NET Edition
TablixCornerRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCorner Class : TablixCornerRows Property

Glossary Item Box

Gets a collection of rows in the corner section of the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixCornerRows As TablixItems(Of TablixCornerRow)
C#
public TablixItems<TablixCornerRow> TablixCornerRows {get;}

Property Value

A TablixItems<T> collection representing the rows in the corner section of the tablix.

Remarks

There must be as many TablixCornerRow elements as there are unique total heights of TablixMember in the Tablix.TablixColumnHierarchy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCorner Class
TablixCorner Members


TablixCornerCell Class

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerCell Class

Glossary Item Box

Represents the contents of each corner cell in the tablix.

Object Model

TablixCornerCell Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixCornerCell
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixCornerCell : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Remarks

The TablixCornerCell class defines the individual cells within the corner section of a tablix. Each cell can contain various contents, which are specified using the CellContents property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixCornerCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCornerCell Class Members

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerCell Class

Glossary Item Box

The following tables list the members exposed by TablixCornerCell.

Public Constructors

 | Name | Description
Public Constructor | TablixCornerCell Constructor | Initializes a new instance of the TablixCornerCell class.
Top

Public Properties

 | Name | Description
Public Property | CellContents | Gets or sets the contents of a cell in a tablix corner.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCornerCell object.
Top

See Also

Reference

TablixCornerCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCornerCell Constructor

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerCell Class : TablixCornerCell Constructor

Glossary Item Box

Initializes a new instance of the TablixCornerCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixCornerCell()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerCell Class
TablixCornerCell Members


TablixCornerCell Class Methods

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerCell Class

Glossary Item Box

For a list of all members of this type, see TablixCornerCell members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCornerCell object.
Top

See Also

Reference

TablixCornerCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerCell Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixCornerCell object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerCell Class
TablixCornerCell Members


TablixCornerCell Class Properties

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerCell Class

Glossary Item Box

For a list of all members of this type, see TablixCornerCell members.

Public Properties

 | Name | Description
Public Property | CellContents | Gets or sets the contents of a cell in a tablix corner.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Top

See Also

Reference

TablixCornerCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerCell Class : CellContents Property

Glossary Item Box

Gets or sets the contents of a cell in a tablix corner.

Syntax

Visual Basic (Declaration)
Public Property CellContents As CellContents
C#
public CellContents CellContents {get; set;}

Property Value

A CellContents object representing the contents of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerCell Class
TablixCornerCell Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerCell Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerCell Class
TablixCornerCell Members


TablixCornerRow Class

[image]
ActiveReports 19 .NET Edition
TablixCornerRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerRow Class

Glossary Item Box

Represents a list of cells in a row of the corner section of a tablix.

Object Model

TablixCornerRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixCornerRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixCornerRow : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixCornerRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCornerRow Class Members

[image]
ActiveReports 19 .NET Edition
TablixCornerRow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerRow Class

Glossary Item Box

The following tables list the members exposed by TablixCornerRow.

Public Constructors

 | Name | Description
Public Constructor | TablixCornerRow Constructor | Creates a new instance of the TablixCornerRow class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixCornerCell | Gets a collection of cells in a row of the corner section of a tablix.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCornerRow object.
Top

See Also

Reference

TablixCornerRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixCornerRow Constructor

[image]
ActiveReports 19 .NET Edition
TablixCornerRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerRow Class : TablixCornerRow Constructor

Glossary Item Box

Creates a new instance of the TablixCornerRow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixCornerRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerRow Class
TablixCornerRow Members


TablixCornerRow Class Methods

[image]
ActiveReports 19 .NET Edition
TablixCornerRow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerRow Class

Glossary Item Box

For a list of all members of this type, see TablixCornerRow members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixCornerRow object.
Top

See Also

Reference

TablixCornerRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerRow Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixCornerRow object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerRow Class
TablixCornerRow Members


TablixCornerRow Class Properties

[image]
ActiveReports 19 .NET Edition
TablixCornerRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixCornerRow Class

Glossary Item Box

For a list of all members of this type, see TablixCornerRow members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixCornerCell | Gets a collection of cells in a row of the corner section of a tablix.
Top

See Also

Reference

TablixCornerRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerRow Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerRow Class
TablixCornerRow Members


TablixCornerCell Property

[image]
ActiveReports 19 .NET Edition
TablixCornerCell Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixCornerRow Class : TablixCornerCell Property

Glossary Item Box

Gets a collection of cells in a row of the corner section of a tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixCornerCell As TablixItems(Of TablixCornerCell)
C#
public TablixItems<TablixCornerCell> TablixCornerCell {get;}

Property Value

A TablixItems<T> collection representing the cells in a row of the corner section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixCornerRow Class
TablixCornerRow Members


TablixHeader Class

[image]
ActiveReports 19 .NET Edition
TablixHeader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHeader Class

Glossary Item Box

Represents a group header in a tablix, containing the individual cells that appear at the beginning of a tablix member.

Object Model

TablixHeader Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixHeader
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixHeader : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixHeader Class Members

[image]
ActiveReports 19 .NET Edition
TablixHeader Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHeader Class

Glossary Item Box

The following tables list the members exposed by TablixHeader.

Public Constructors

 | Name | Description
Public Constructor | TablixHeader Constructor | Initializes a new instance of the TablixHeader class.
Top

Public Properties

 | Name | Description
Public Property | CellContents | Gets or sets a report item contained in the cell within a group header.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Size | Gets or sets a height or width of a group header.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixHeader object.
Top

See Also

Reference

TablixHeader Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixHeader Constructor

[image]
ActiveReports 19 .NET Edition
TablixHeader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHeader Class : TablixHeader Constructor

Glossary Item Box

Initializes a new instance of the TablixHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Class
TablixHeader Members


TablixHeader Class Methods

[image]
ActiveReports 19 .NET Edition
TablixHeader Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHeader Class

Glossary Item Box

For a list of all members of this type, see TablixHeader members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixHeader object.
Top

See Also

Reference

TablixHeader Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHeader Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixHeader object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Class
TablixHeader Members


TablixHeader Class Properties

[image]
ActiveReports 19 .NET Edition
TablixHeader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHeader Class

Glossary Item Box

For a list of all members of this type, see TablixHeader members.

Public Properties

 | Name | Description
Public Property | CellContents | Gets or sets a report item contained in the cell within a group header.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Size | Gets or sets a height or width of a group header.
Top

See Also

Reference

TablixHeader Class
GrapeCity.ActiveReports.PageReportModel Namespace


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHeader Class : CellContents Property

Glossary Item Box

Gets or sets a report item contained in the cell within a group header.

Syntax

Visual Basic (Declaration)
Public Property CellContents As CellContents
C#
public CellContents CellContents {get; set;}

Property Value

A CellContents object representing the contents of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Class
TablixHeader Members


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHeader Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Class
TablixHeader Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHeader Class : Size Property

Glossary Item Box

Gets or sets a height or width of a group header.

Syntax

Visual Basic (Declaration)
Public Property Size As Length
C#
public Length Size {get; set;}

Property Value

A Length value indicating the size of the group header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHeader Class
TablixHeader Members


TablixHierarchy Class

[image]
ActiveReports 19 .NET Edition
TablixHierarchy Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHierarchy Class

Glossary Item Box

Represents a hierarchy of members within a tablix.

Object Model

TablixHierarchy Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixHierarchy
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IValidateable
C#
public sealed class TablixHierarchy : ReportComponent, IReportComponent, IReportComponentContainer, IValidateable

Remarks

The TablixHierarchy class models a hierarchical structure of members within a tablix, which is a data region used to organize and present data in rows and columns.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixHierarchy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHierarchy Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixHierarchy Class Members

[image]
ActiveReports 19 .NET Edition
TablixHierarchy Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHierarchy Class

Glossary Item Box

The following tables list the members exposed by TablixHierarchy.

Public Constructors

 | Name | Description
Public Constructor | TablixHierarchy Constructor | Initializes a new instance of the TablixHierarchy class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixMembers | Gets a collection of members at the base level of the hierarchy.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixHierarchy object.
Top

See Also

Reference

TablixHierarchy Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixHierarchy Constructor

[image]
ActiveReports 19 .NET Edition
TablixHierarchy Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHierarchy Class : TablixHierarchy Constructor

Glossary Item Box

Initializes a new instance of the TablixHierarchy class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixHierarchy()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHierarchy Class
TablixHierarchy Members


TablixHierarchy Class Methods

[image]
ActiveReports 19 .NET Edition
TablixHierarchy Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHierarchy Class

Glossary Item Box

For a list of all members of this type, see TablixHierarchy members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixHierarchy object.
Top

See Also

Reference

TablixHierarchy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHierarchy Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixHierarchy object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHierarchy Class
TablixHierarchy Members


TablixHierarchy Class Properties

[image]
ActiveReports 19 .NET Edition
TablixHierarchy Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixHierarchy Class

Glossary Item Box

For a list of all members of this type, see TablixHierarchy members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | TablixMembers | Gets a collection of members at the base level of the hierarchy.
Top

See Also

Reference

TablixHierarchy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHierarchy Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHierarchy Class
TablixHierarchy Members


TablixMembers Property

[image]
ActiveReports 19 .NET Edition
TablixMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixHierarchy Class : TablixMembers Property

Glossary Item Box

Gets a collection of members at the base level of the hierarchy.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixMembers As TablixItems(Of TablixMember)
C#
public TablixItems<TablixMember> TablixMembers {get;}

Property Value

A TablixItems<T> collection representing the members at the base level of the hierarchy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixHierarchy Class
TablixHierarchy Members


TablixItems<T> Class

T
A type that derives from ReportComponent.
[image]
ActiveReports 19 .NET Edition
TablixItems<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixItems<T> Class

Glossary Item Box

Represents a collection of ReportComponent items.

Object Model

TablixItems<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixItems(Of T As ReportComponent)
   Inherits System.Collections.ObjectModel.Collection(Of T)
C#
public sealed class TablixItems<T> : System.Collections.ObjectModel.Collection<T>
where T: ReportComponent

Type Parameters

T
A type that derives from ReportComponent.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.TablixItems<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixItems<T> Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixItems<T> Class Members

[image]
ActiveReports 19 .NET Edition
TablixItems<T> Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixItems<T> Class

Glossary Item Box

The following tables list the members exposed by TablixItems<T>.

Public Methods

 | Name | Description
Public Method | ToArray | Converts the TablixItems<T> collection into an array of ReportComponent items.
Top

See Also

Reference

TablixItems<T> Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixItems<T> Class Methods

[image]
ActiveReports 19 .NET Edition
TablixItems<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixItems<T> Class

Glossary Item Box

For a list of all members of this type, see TablixItems<T> members.

Public Methods

 | Name | Description
Public Method | ToArray | Converts the TablixItems<T> collection into an array of ReportComponent items.
Top

See Also

Reference

TablixItems<T> Class
GrapeCity.ActiveReports.PageReportModel Namespace


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixItems<T> Class : ToArray Method

Glossary Item Box

Converts the TablixItems<T> collection into an array of ReportComponent items.

Syntax

Visual Basic (Declaration)
Public Function ToArray() As T()
C#
public T[] ToArray()

Return Value

An array containing the elements of the TablixItems<T> collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixItems<T> Class
TablixItems<T> Members


TablixMember Class

[image]
ActiveReports 19 .NET Edition
TablixMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixMember Class

Glossary Item Box

Represents a member within the hierarchical structure of a tablix, defining how data is grouped, sorted and displayed.

Object Model

TablixMember Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixMember
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable
C#
public sealed class TablixMember : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition, IValidateable

Remarks

The TablixMember class provides properties to define grouping expressions, sorting criteria, visibility settings, custom properties, and layout behaviors for children tablix members.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixMember Class Members

[image]
ActiveReports 19 .NET Edition
TablixMember Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixMember Class

Glossary Item Box

The following tables list the members exposed by TablixMember.

Public Constructors

 | Name | Description
Public Constructor | TablixMember Constructor | Initializes a new instance of the TablixMember class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | CustomProperties | Gets a collection of custom properties defined for the member.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | ExtraTotalSize | Gets or sets a height or width of the extra total group header.
Public Property | FixedData | Gets or sets a value indicating whether the tablix member's data should remain fixed in the viewing window when scrolling.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | HideIfNoRows | Gets or sets a value indicating whether to hide this tablix member when it contains no rows.
Public Property | IsExtraTotal | Gets or sets a value indicating whether the member has been added for interactivity purposes.
Public Property | IsZeroSpan | Gets or sets a value indicating whether the member should have zero span during layout.
Public Property | KeepTogether | Gets or sets a value indicating whether the member is kept together on a single page where possible.
Public Property | KeepWithGroup | Gets or sets how a static tablix member should be kept on the page with the previous or next non-hidden sibling.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether a static tablix member should be repeated on every page when a visible dynamic member sibling with the corresponding KeepWithGroup or its children appears on that page.
Public Property | Sorting | Gets the expressions by which to sort the data.
Public Property | TablixHeader | Gets or sets a header cell associated with the tablix member.
Public Property | TablixMembers | Gets a collection of submembers contained within this member.
Public Property | Visibility | Gets or sets a value indicating whether the member is hidden.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixMember object.
Top

See Also

Reference

TablixMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixMember Constructor

[image]
ActiveReports 19 .NET Edition
TablixMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : TablixMember Constructor

Glossary Item Box

Initializes a new instance of the TablixMember class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixMember()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


TablixMember Class Methods

[image]
ActiveReports 19 .NET Edition
TablixMember Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixMember Class

Glossary Item Box

For a list of all members of this type, see TablixMember members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the TablixMember object.
Top

See Also

Reference

TablixMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TablixMember object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


TablixMember Class Properties

[image]
ActiveReports 19 .NET Edition
TablixMember Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixMember Class

Glossary Item Box

For a list of all members of this type, see TablixMember members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | CustomProperties | Gets a collection of custom properties defined for the member.
Public Property | DataElementName | Gets or sets a name of the top-level XML element that represents the instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | ExtraTotalSize | Gets or sets a height or width of the extra total group header.
Public Property | FixedData | Gets or sets a value indicating whether the tablix member's data should remain fixed in the viewing window when scrolling.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | HideIfNoRows | Gets or sets a value indicating whether to hide this tablix member when it contains no rows.
Public Property | IsExtraTotal | Gets or sets a value indicating whether the member has been added for interactivity purposes.
Public Property | IsZeroSpan | Gets or sets a value indicating whether the member should have zero span during layout.
Public Property | KeepTogether | Gets or sets a value indicating whether the member is kept together on a single page where possible.
Public Property | KeepWithGroup | Gets or sets how a static tablix member should be kept on the page with the previous or next non-hidden sibling.
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether a static tablix member should be repeated on every page when a visible dynamic member sibling with the corresponding KeepWithGroup or its children appears on that page.
Public Property | Sorting | Gets the expressions by which to sort the data.
Public Property | TablixHeader | Gets or sets a header cell associated with the tablix member.
Public Property | TablixMembers | Gets a collection of submembers contained within this member.
Public Property | Visibility | Gets or sets a value indicating whether the member is hidden.
Top

See Also

Reference

TablixMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : CustomProperties Property

Glossary Item Box

Gets a collection of custom properties defined for the member.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
C#
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection object containing custom properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : DataElementName Property

Glossary Item Box

Gets or sets a name of the top-level XML element that represents the instances of this group.

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Property Value

A System.String value indicating the name of the top-level XML element for instances of this group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : DataElementOutput Property

Glossary Item Box

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput value indicating whether the item appears in a data rendering.

Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the group appears in the output.

NoOutput indicates that the group does not appear in the output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


ExtraTotalSize Property

[image]
ActiveReports 19 .NET Edition
ExtraTotalSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : ExtraTotalSize Property

Glossary Item Box

Gets or sets a height or width of the extra total group header.

Syntax

Visual Basic (Declaration)
Public Property ExtraTotalSize As Nullable(Of Length)
C#
public Nullable<Length> ExtraTotalSize {get; set;}

Property Value

A nullable Length value indicating the size of the extra total group header.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


FixedData Property

[image]
ActiveReports 19 .NET Edition
FixedData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : FixedData Property

Glossary Item Box

Gets or sets a value indicating whether the tablix member's data should remain fixed in the viewing window when scrolling.

Syntax

Visual Basic (Declaration)
Public Property FixedData As Boolean
C#
public bool FixedData {get; set;}

Property Value

A System.Boolean value where true if the member's data should remain fixed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


Grouping Property

[image]
ActiveReports 19 .NET Edition
Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : Grouping Property

Glossary Item Box

Gets or sets the expressions by which to group the data.

Syntax

Visual Basic (Declaration)
Public Property Grouping As Grouping
C#
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Remarks

If omitted, this member is static; otherwise, it is dynamic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


HideIfNoRows Property

[image]
ActiveReports 19 .NET Edition
HideIfNoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : HideIfNoRows Property

Glossary Item Box

Gets or sets a value indicating whether to hide this tablix member when it contains no rows.

Syntax

Visual Basic (Declaration)
Public Property HideIfNoRows As Boolean
C#
public bool HideIfNoRows {get; set;}

Property Value

A System.Boolean value where true to hide the member if no rows are present; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


IsExtraTotal Property

[image]
ActiveReports 19 .NET Edition
IsExtraTotal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : IsExtraTotal Property

Glossary Item Box

Gets or sets a value indicating whether the member has been added for interactivity purposes.

Syntax

Visual Basic (Declaration)
Public Property IsExtraTotal As Boolean
C#
public bool IsExtraTotal {get; set;}

Property Value

A System.Boolean value indicating whether the member is added for interactivity.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


IsZeroSpan Property

[image]
ActiveReports 19 .NET Edition
IsZeroSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : IsZeroSpan Property

Glossary Item Box

Gets or sets a value indicating whether the member should have zero span during layout.

Syntax

Visual Basic (Declaration)
Public Property IsZeroSpan As Boolean
C#
public bool IsZeroSpan {get; set;}

Property Value

A System.Boolean value indicating whether the member should have zero span during layout.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : KeepTogether Property

Glossary Item Box

Gets or sets a value indicating whether the member is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A System.Boolean value where true if the member is kept together on a single page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


KeepWithGroup Property

[image]
ActiveReports 19 .NET Edition
KeepWithGroup Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : KeepWithGroup Property

Glossary Item Box

Gets or sets how a static tablix member should be kept on the page with the previous or next non-hidden sibling.

Syntax

Visual Basic (Declaration)
Public Property KeepWithGroup As KeepWithGroup
C#
public KeepWithGroup KeepWithGroup {get; set;}

Property Value

A KeepWithGroup value indicating the positioning behavior.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : RepeatOnNewPage Property

Glossary Item Box

Gets or sets a value indicating whether a static tablix member should be repeated on every page when a visible dynamic member sibling with the corresponding KeepWithGroup or its children appears on that page.

Syntax

Visual Basic (Declaration)
Public Property RepeatOnNewPage As Boolean
C#
public bool RepeatOnNewPage {get; set;}

Property Value

A System.Boolean value where true to repeat the member on new pages; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


Sorting Property

[image]
ActiveReports 19 .NET Edition
Sorting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : Sorting Property

Glossary Item Box

Gets the expressions by which to sort the data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortByCollection
C#
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


TablixHeader Property

[image]
ActiveReports 19 .NET Edition
TablixHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : TablixHeader Property

Glossary Item Box

Gets or sets a header cell associated with the tablix member.

Syntax

Visual Basic (Declaration)
Public Property TablixHeader As TablixHeader
C#
public TablixHeader TablixHeader {get; set;}

Property Value

A TablixHeader object representing the header cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


TablixMembers Property

[image]
ActiveReports 19 .NET Edition
TablixMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : TablixMembers Property

Glossary Item Box

Gets a collection of submembers contained within this member.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixMembers As TablixItems(Of TablixMember)
C#
public TablixItems<TablixMember> TablixMembers {get;}

Property Value

A TablixItems<T> collection representing submembers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


Visibility Property

[image]
ActiveReports 19 .NET Edition
Visibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixMember Class : Visibility Property

Glossary Item Box

Gets or sets a value indicating whether the member is hidden.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A Visibility object representing the visibility of the member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixMember Class
TablixMember Members


TablixRow Class

[image]
ActiveReports 19 .NET Edition
TablixRow Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixRow Class

Glossary Item Box

Represents a row within a tablix that contains a collection of cells.

Object Model

TablixRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
C#
public sealed class TablixRow : ReportComponent, IReportComponent, IReportComponentContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TablixRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


TablixRow Class Members

[image]
ActiveReports 19 .NET Edition
TablixRow Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixRow Class

Glossary Item Box

The following tables list the members exposed by TablixRow.

Public Constructors

 | Name | Description
Public Constructor | TablixRow Constructor | Initializes a new instance of the TablixRow class.
Top

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of each cell in this row.
Public Property | TablixCells | Gets a collection of cells within this row in the body section of the tablix.
Top

See Also

Reference

TablixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


TablixRow Constructor

[image]
ActiveReports 19 .NET Edition
TablixRow Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixRow Class : TablixRow Constructor

Glossary Item Box

Initializes a new instance of the TablixRow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixRow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixRow Class
TablixRow Members


TablixRow Class Properties

[image]
ActiveReports 19 .NET Edition
TablixRow Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TablixRow Class

Glossary Item Box

For a list of all members of this type, see TablixRow members.

Public Properties

 | Name | Description
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container.
Public Property | Height | Gets or sets a height of each cell in this row.
Public Property | TablixCells | Gets a collection of cells within this row in the body section of the tablix.
Top

See Also

Reference

TablixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixRow Class : Components Property

Glossary Item Box

Gets a ReportComponentCollection containing all the ReportComponent in the container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ReportComponentCollection
C#
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection object containing all the ReportComponent objects in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixRow Class
TablixRow Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixRow Class : Height Property

Glossary Item Box

Gets or sets a height of each cell in this row.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Property Value

A Length value indicating the height of each cell in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixRow Class
TablixRow Members


TablixCells Property

[image]
ActiveReports 19 .NET Edition
TablixCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TablixRow Class : TablixCells Property

Glossary Item Box

Gets a collection of cells within this row in the body section of the tablix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TablixCells As TablixItems(Of TablixCell)
C#
public TablixItems<TablixCell> TablixCells {get;}

Property Value

A TablixItems<T> collection representing the cells in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixRow Class
TablixRow Members


TabStrip Class

[image]
ActiveReports 19 .NET Edition
TabStrip Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TabStrip Class

Glossary Item Box

Represents a tabstrip navigation layout.

Object Model

TabStrip Class

Syntax

Visual Basic (Declaration)
Public Class TabStrip
C#
public class TabStrip

Remarks

The TabStrip class provides settings for tabstrip navigation, including the navigation item and slider settings.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TabStrip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStrip Members
GrapeCity.ActiveReports.PageReportModel Namespace


TabStrip Class Members

[image]
ActiveReports 19 .NET Edition
TabStrip Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TabStrip Class

Glossary Item Box

The following tables list the members exposed by TabStrip.

Public Constructors

 | Name | Description
Public Constructor | TabStrip Constructor |
Top

Public Properties

 | Name | Description
Public Property | NavigationItem | Gets or sets a report item or report item reference to use to draw the tabstrip navigation layout.
Public Property | Slider | Gets or sets the slider settings for the tabstrip.
Top

See Also

Reference

TabStrip Class
GrapeCity.ActiveReports.PageReportModel Namespace


TabStrip Constructor

[image]
ActiveReports 19 .NET Edition
TabStrip Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TabStrip Class : TabStrip Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TabStrip()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStrip Class
TabStrip Members


TabStrip Class Properties

[image]
ActiveReports 19 .NET Edition
TabStrip Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TabStrip Class

Glossary Item Box

For a list of all members of this type, see TabStrip members.

Public Properties

 | Name | Description
Public Property | NavigationItem | Gets or sets a report item or report item reference to use to draw the tabstrip navigation layout.
Public Property | Slider | Gets or sets the slider settings for the tabstrip.
Top

See Also

Reference

TabStrip Class
GrapeCity.ActiveReports.PageReportModel Namespace


NavigationItem Property

[image]
ActiveReports 19 .NET Edition
NavigationItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TabStrip Class : NavigationItem Property

Glossary Item Box

Gets or sets a report item or report item reference to use to draw the tabstrip navigation layout.

Syntax

Visual Basic (Declaration)
Public Property NavigationItem As NavigationItem
C#
public NavigationItem NavigationItem {get; set;}

Property Value

A NavigationItem object representing the navigation item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStrip Class
TabStrip Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TabStrip Class : Slider Property

Glossary Item Box

Gets or sets the slider settings for the tabstrip.

Syntax

Visual Basic (Declaration)
Public Property Slider As Slider
C#
public Slider Slider {get; set;}

Property Value

A Slider object representing the slider settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStrip Class
TabStrip Members


TextBox Class

[image]
ActiveReports 19 .NET Edition
TextBox Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

Glossary Item Box

Represents a textbox ReportItem within the report definition.

Object Model

TextBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextBox
   Inherits TextItem
   Implements IReportComponent, IValidateable
C#
public sealed class TextBox : TextItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.TextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Members
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox Class Members

[image]
ActiveReports 19 .NET Edition
TextBox Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

Glossary Item Box

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the textbox size can increase to accommodate its contents.
Public Property | CanShrink | Gets or sets a value indicating whether the textbox size can decrease to match its contents.
Public Property | HideDuplicates | Gets or sets a name of a grouping or data set within which to hide the item when the expression's value matches the preceding instance.
Public Property | ToggleImage | Gets or sets the initial state of a toggle image, if present in the textbox. The image displays a plus sign (+) for collapsed state and a minus sign (-) for expanded state.
Public Property | UserSort | Gets or sets a value indicating whether the end-user sort control should be displayed in the textbox UI.
Top

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the TextBox object.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox Constructor

[image]
ActiveReports 19 .NET Edition
TextBox Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : TextBox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Methods

[image]
ActiveReports 19 .NET Edition
TextBox Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

Glossary Item Box

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | GetExpressions | Overridden. Returns a list of the expressions contained by this report item.
Public Method | Validate | Overridden. Validates the current state of the TextBox object.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method

[image]
ActiveReports 19 .NET Edition
GetExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : GetExpressions Method

Glossary Item Box

Returns a list of the expressions contained by this report item.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
C#
public override ExpressionInfo[] GetExpressions()

Return Value

An array of GrapeCity.Enterprise.Data.Expressions.ExpressionInfo objects representing the expressions contained by this report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the TextBox object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

[image]
ActiveReports 19 .NET Edition
TextBox Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

Glossary Item Box

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | CanGrow | Gets or sets a value indicating whether the textbox size can increase to accommodate its contents.
Public Property | CanShrink | Gets or sets a value indicating whether the textbox size can decrease to match its contents.
Public Property | HideDuplicates | Gets or sets a name of a grouping or data set within which to hide the item when the expression's value matches the preceding instance.
Public Property | ToggleImage | Gets or sets the initial state of a toggle image, if present in the textbox. The image displays a plus sign (+) for collapsed state and a minus sign (-) for expanded state.
Public Property | UserSort | Gets or sets a value indicating whether the end-user sort control should be displayed in the textbox UI.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : CanGrow Property

Glossary Item Box

Gets or sets a value indicating whether the textbox size can increase to accommodate its contents.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A System.Boolean value where true indicates the textbox size can grow to fit the contents; otherwise, false. The default is false.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.CanGrow = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : CanShrink Property

Glossary Item Box

Gets or sets a value indicating whether the textbox size can decrease to match its contents.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A System.Boolean value where true indicates the textbox size can shrink to fit the contents; otherwise, false. The default is false.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.CanShrink = true;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


HideDuplicates Property

[image]
ActiveReports 19 .NET Edition
HideDuplicates Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : HideDuplicates Property

Glossary Item Box

Gets or sets a name of a grouping or data set within which to hide the item when the expression's value matches the preceding instance.

Syntax

Visual Basic (Declaration)
Public Property HideDuplicates As String
C#
public string HideDuplicates {get; set;}

Property Value

A System.String value indicating the name of the grouping or data set to apply the hiding.

Remarks

This property hides duplicates within a specified group or data set. When a new group instance is encountered, the first item is shown. Rows on previous pages are ignored for hiding duplicates. If within a table or matrix cell, only the text is hidden, not the textbox itself.

This property is ignored in matrix subtotals.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.HideDuplicates = "GroupName";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ToggleImage Property

[image]
ActiveReports 19 .NET Edition
ToggleImage Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : ToggleImage Property

Glossary Item Box

Gets or sets the initial state of a toggle image, if present in the textbox. The image displays a plus sign (+) for collapsed state and a minus sign (-) for expanded state.

Syntax

Visual Basic (Declaration)
Public Property ToggleImage As ToggleImage
C#
public ToggleImage ToggleImage {get; set;}

Property Value

A ToggleImage object indicating the initial state of the toggle image.

Remarks

The ToggleImage works with the Visibility class for toggling report items within the textbox.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.ToggleImage = new ToggleImage { InitialState = ExpressionInfo.FromString("true") };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


UserSort Property

[image]
ActiveReports 19 .NET Edition
UserSort Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : UserSort Property

Glossary Item Box

Gets or sets a value indicating whether the end-user sort control should be displayed in the textbox UI.

Syntax

Visual Basic (Declaration)
Public Property UserSort As UserSort
C#
public UserSort UserSort {get; set;}

Property Value

A UserSort value indicating the presence of the end-user sort control.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.UserSort = new UserSort { Enabled = true };

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextBox.Defaults Class

[image]
ActiveReports 19 .NET Edition
TextBox.Defaults Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox.Defaults Class

Glossary Item Box

Represents the default values for textbox properties.

Object Model

TextBox.Defaults Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class TextBox.Defaults
C#
public static class TextBox.Defaults

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TextBox.Defaults

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox.Defaults Members
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox.Defaults Class Members

[image]
ActiveReports 19 .NET Edition
TextBox.Defaults Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox.Defaults Class

Glossary Item Box

The following tables list the members exposed by TextBox.Defaults.

Public Fields

 | Name | Description
Public Field | HeadingLevel | The default heading level
Top

See Also

Reference

TextBox.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox.Defaults Class Fields

[image]
ActiveReports 19 .NET Edition
TextBox.Defaults Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox.Defaults Class

Glossary Item Box

For a list of all members of this type, see TextBox.Defaults members.

Public Fields

 | Name | Description
Public Field | HeadingLevel | The default heading level
Top

See Also

Reference

TextBox.Defaults Class
GrapeCity.ActiveReports.PageReportModel Namespace


HeadingLevel Field

[image]
ActiveReports 19 .NET Edition
HeadingLevel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox.Defaults Class : HeadingLevel Field

Glossary Item Box

The default heading level

Syntax

Visual Basic (Declaration)
Public Const HeadingLevel As String
C#
public const string HeadingLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox.Defaults Class
TextBox.Defaults Members


TextItem Class

[image]
ActiveReports 19 .NET Edition
TextItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

Glossary Item Box

Abstract base class for TextBox and CheckBox items in a report.

Object Model

TextItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class TextItem
   Inherits ReportItem
   Implements IReportComponent, IValidateable
C#
public abstract class TextItem : ReportItem, IReportComponent, IValidateable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.CheckBox
GrapeCity.ActiveReports.PageReportModel.TextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


TextItem Class Members

[image]
ActiveReports 19 .NET Edition
TextItem Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

Glossary Item Box

The following tables list the members exposed by TextItem.

Public Properties

 | Name | Description
Public Property | CustomCSSClasses | Gets or sets the custom CSS class names for a text item.
Public Property | DataElementStyle | Gets or sets a value indicating whether the text item value is rendered as an element or attribute.
Public Property | Value | Gets or sets an expression whose value is displayed in the text item.
Top

See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextItem Class Properties

[image]
ActiveReports 19 .NET Edition
TextItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

Glossary Item Box

For a list of all members of this type, see TextItem members.

Public Properties

 | Name | Description
Public Property | CustomCSSClasses | Gets or sets the custom CSS class names for a text item.
Public Property | DataElementStyle | Gets or sets a value indicating whether the text item value is rendered as an element or attribute.
Public Property | Value | Gets or sets an expression whose value is displayed in the text item.
Top

See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomCSSClasses Property

[image]
ActiveReports 19 .NET Edition
CustomCSSClasses Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : CustomCSSClasses Property

Glossary Item Box

Gets or sets the custom CSS class names for a text item.

Syntax

Visual Basic (Declaration)
Public Property CustomCSSClasses As ExpressionInfo
C#
public ExpressionInfo CustomCSSClasses {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value representing the custom CSS class names applied to the report item.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.CustomCSSClasses = "ar-button ar-button-pressed";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItem Class
TextItem Members


DataElementStyle Property

[image]
ActiveReports 19 .NET Edition
DataElementStyle Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : DataElementStyle Property

Glossary Item Box

Gets or sets a value indicating whether the text item value is rendered as an element or attribute.

Syntax

Visual Basic (Declaration)
Public Property DataElementStyle As DataElementStyle
C#
public DataElementStyle DataElementStyle {get; set;}

Property Value

A DataElementStyle value indicating whether the text item value is rendered as an element or attribute.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.DataElementStyle = DataElementStyle.Attribute;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItem Class
TextItem Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Value Property

Glossary Item Box

Gets or sets an expression whose value is displayed in the text item.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to the text displayed in the text item.

Remarks

The value can be a constant expression for static labels.

Example

C# Copy Code
TextBox textBox = new TextBox();
textBox.Value = "Hello, World!";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItem Class
TextItem Members


ThreeDProperties Class

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class

Glossary Item Box

The ThreeDProperties element defines properties for a 3D chart layout.

Object Model

ThreeDProperties Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThreeDProperties
C#
public sealed class ThreeDProperties

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ThreeDProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Members
GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDProperties Class Members

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class

Glossary Item Box

The following tables list the members exposed by ThreeDProperties.

Public Constructors

 | Name | Description
Public Constructor | ThreeDProperties Constructor | Initializes a new instance of the ThreeDProperties class.
Top

Public Properties

 | Name | Description
Public Property | Clustered | Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).
Public Property | DrawingStyle | Gets or sets the shape of bars or columns to display in the chart.
Public Property | Enabled | Gets or sets a value indicating whether a chart is displayed in 3D.
Public Property | Inclination | Gets or sets the angle of inclination.
Public Property | Perspective | Gets or sets the angle of perspective.
Public Property | ProjectionMode | Gets or sets the projection mode used for 3D rendering.
Public Property | Rotation | Gets or sets the angle of rotation.
Public Property | Shading | Gets or sets the 3D shading type to use.
Public Property | WallThickness | Gets or sets the thickness percent of the outer walls.
Top

See Also

Reference

ThreeDProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDProperties Constructor

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : ThreeDProperties Constructor

Glossary Item Box

Initializes a new instance of the ThreeDProperties class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThreeDProperties()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


ThreeDProperties Class Properties

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class

Glossary Item Box

For a list of all members of this type, see ThreeDProperties members.

Public Properties

 | Name | Description
Public Property | Clustered | Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).
Public Property | DrawingStyle | Gets or sets the shape of bars or columns to display in the chart.
Public Property | Enabled | Gets or sets a value indicating whether a chart is displayed in 3D.
Public Property | Inclination | Gets or sets the angle of inclination.
Public Property | Perspective | Gets or sets the angle of perspective.
Public Property | ProjectionMode | Gets or sets the projection mode used for 3D rendering.
Public Property | Rotation | Gets or sets the angle of rotation.
Public Property | Shading | Gets or sets the 3D shading type to use.
Public Property | WallThickness | Gets or sets the thickness percent of the outer walls.
Top

See Also

Reference

ThreeDProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clustered Property

[image]
ActiveReports 19 .NET Edition
Clustered Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Clustered Property

Glossary Item Box

Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).

Syntax

Visual Basic (Declaration)
Public Property Clustered As Boolean
C#
public bool Clustered {get; set;}

Property Value

A Boolean value where true indicates that the data series is clustered; otherwise false. The default value is false.

Remarks

This property only applies to bar and column chart types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


DrawingStyle Property

[image]
ActiveReports 19 .NET Edition
DrawingStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : DrawingStyle Property

Glossary Item Box

Gets or sets the shape of bars or columns to display in the chart.

Syntax

Visual Basic (Declaration)
Public Property DrawingStyle As ThreeDPropertiesDrawingStyle
C#
public ThreeDPropertiesDrawingStyle DrawingStyle {get; set;}

Property Value

A ThreeDPropertiesDrawingStyle enumeration indicating the shape of bars or columns displayed.

Remarks

This property only applies to bar and column chart types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether a chart is displayed in 3D.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

A Boolean value where true indicates that the chart is displayed in 3D; otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Inclination Property

[image]
ActiveReports 19 .NET Edition
Inclination Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Inclination Property

Glossary Item Box

Gets or sets the angle of inclination.

Syntax

Visual Basic (Declaration)
Public Property Inclination As Nullable(Of Integer)
C#
public Nullable<int> Inclination {get; set;}

Property Value

An int? value indicating the angle of inclination.

Remarks

This property is ignored unless the ProjectionMode property is set to ThreeDPropertiesProjectionMode.Perspective

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Perspective Property

[image]
ActiveReports 19 .NET Edition
Perspective Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Perspective Property

Glossary Item Box

Gets or sets the angle of perspective.

Syntax

Visual Basic (Declaration)
Public Property Perspective As Nullable(Of Integer)
C#
public Nullable<int> Perspective {get; set;}

Property Value

An int? value indicating the angle of perspective.

Remarks

This property is ignored unless the ProjectionMode property is set to ThreeDPropertiesProjectionMode.Perspective

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


ProjectionMode Property

[image]
ActiveReports 19 .NET Edition
ProjectionMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : ProjectionMode Property

Glossary Item Box

Gets or sets the projection mode used for 3D rendering.

Syntax

Visual Basic (Declaration)
Public Property ProjectionMode As ThreeDPropertiesProjectionMode
C#
public ThreeDPropertiesProjectionMode ProjectionMode {get; set;}

Property Value

A ThreeDPropertiesProjectionMode enumeration indicating the projection mode used for 3D rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Rotation Property

Glossary Item Box

Gets or sets the angle of rotation.

Syntax

Visual Basic (Declaration)
Public Property Rotation As Nullable(Of Integer)
C#
public Nullable<int> Rotation {get; set;}

Property Value

An int? value indicating the angle of rotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Shading Property

[image]
ActiveReports 19 .NET Edition
Shading Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Shading Property

Glossary Item Box

Gets or sets the 3D shading type to use.

Syntax

Visual Basic (Declaration)
Public Property Shading As ThreeDPropertiesShading
C#
public ThreeDPropertiesShading Shading {get; set;}

Property Value

A ThreeDPropertiesShading enumeration indicating the 3D shading type to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


WallThickness Property

[image]
ActiveReports 19 .NET Edition
WallThickness Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : WallThickness Property

Glossary Item Box

Gets or sets the thickness percent of the outer walls.

Syntax

Visual Basic (Declaration)
Public Property WallThickness As Nullable(Of Integer)
C#
public Nullable<int> WallThickness {get; set;}

Property Value

A nullable int value indicating the thickness percent of the outer walls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Title Class

[image]
ActiveReports 19 .NET Edition
Title Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

Glossary Item Box

The Title element defines a title for the chart or for an axis.

Object Model

Title Class

Syntax

Visual Basic (Declaration)
Public Class Title
   Implements IValidateable
C#
public class Title : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Title
GrapeCity.ActiveReports.PageReportModel.ChartAxisTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Members
GrapeCity.ActiveReports.PageReportModel Namespace


Title Class Members

[image]
ActiveReports 19 .NET Edition
Title Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

Glossary Item Box

The following tables list the members exposed by Title.

Public Constructors

 | Name | Description
Public Constructor | Title Constructor | Initializes a new instance of the Title class.
Top

Public Properties

 | Name | Description
Public Property | Caption | Gets or sets the caption of the title.
Public Property | Position | Gets or sets the position of the title.
Public Property | Style | Gets or sets the text, border and background style properties for the title.
Public Property | Vertical | Specifies whether the title should be vertical.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Title object.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Title Constructor

[image]
ActiveReports 19 .NET Edition
Title Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Title Constructor

Glossary Item Box

Initializes a new instance of the Title class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Title()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Title Class Methods

[image]
ActiveReports 19 .NET Edition
Title Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

Glossary Item Box

For a list of all members of this type, see Title members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the Title object.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the Title object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Title Class Properties

[image]
ActiveReports 19 .NET Edition
Title Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

Glossary Item Box

For a list of all members of this type, see Title members.

Public Properties

 | Name | Description
Public Property | Caption | Gets or sets the caption of the title.
Public Property | Position | Gets or sets the position of the title.
Public Property | Style | Gets or sets the text, border and background style properties for the title.
Public Property | Vertical | Specifies whether the title should be vertical.
Top

See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Caption Property

Glossary Item Box

Gets or sets the caption of the title.

Syntax

Visual Basic (Declaration)
Public Property Caption As ExpressionInfo
C#
public ExpressionInfo Caption {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object containing the caption of the title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Position Property

Glossary Item Box

Gets or sets the position of the title.

Syntax

Visual Basic (Declaration)
Public Property Position As TitlePosition
C#
public TitlePosition Position {get; set;}

Property Value

A TitlePosition enumeration indicating the position of the title.

Remarks

This property is only used for chart axis titles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Style Property

Glossary Item Box

Gets or sets the text, border and background style properties for the title.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

A Style object containing the text, border and background style properties for the title.

Remarks

All textbox properties apply.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Vertical Property

[image]
ActiveReports 19 .NET Edition
Vertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Vertical Property

Glossary Item Box

Specifies whether the title should be vertical.

Syntax

Visual Basic (Declaration)
Public Property Vertical As Boolean
C#
public bool Vertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


ToggleImage Class

[image]
ActiveReports 19 .NET Edition
ToggleImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

Glossary Item Box

Represents an initial state of a toggle image displayed as part of a TextBox.

Object Model

ToggleImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToggleImage
   Implements IValidateable
C#
public sealed class ToggleImage : IValidateable

Remarks

The toggle image is displayed if the textbox serves as a toggle item for another report item. If no ToggleImage element is present, no image is displayed.

The toggle image displays as a plus sign (+) to indicate a collapsed state with hidden report items, and as a minus sign (-) to indicate an expanded state with all report items visible.

Clicking the textbox or image flips the toggle image state, displaying the image associated with the new state.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ToggleImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


ToggleImage Class Members

[image]
ActiveReports 19 .NET Edition
ToggleImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

Glossary Item Box

The following tables list the members exposed by ToggleImage.

Public Constructors

 | Name | Description
Public Constructor | ToggleImage Constructor | Initializes a new instance of the ToggleImage class.
Top

Public Properties

 | Name | Description
Public Property | InitialState | Gets or sets a Boolean expression that determines the initial state of the toggle image.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ToggleImage object.
Top

See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ToggleImage Constructor

[image]
ActiveReports 19 .NET Edition
ToggleImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : ToggleImage Constructor

Glossary Item Box

Initializes a new instance of the ToggleImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToggleImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleImage Class
ToggleImage Members


ToggleImage Class Methods

[image]
ActiveReports 19 .NET Edition
ToggleImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

Glossary Item Box

For a list of all members of this type, see ToggleImage members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the ToggleImage object.
Top

See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ToggleImage object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleImage Class
ToggleImage Members


ToggleImage Class Properties

[image]
ActiveReports 19 .NET Edition
ToggleImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

Glossary Item Box

For a list of all members of this type, see ToggleImage members.

Public Properties

 | Name | Description
Public Property | InitialState | Gets or sets a Boolean expression that determines the initial state of the toggle image.
Top

See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


InitialState Property

[image]
ActiveReports 19 .NET Edition
InitialState Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : InitialState Property

Glossary Item Box

Gets or sets a Boolean expression that determines the initial state of the toggle image.

Syntax

Visual Basic (Declaration)
Public Property InitialState As ExpressionInfo
C#
public ExpressionInfo InitialState {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a System.Boolean value, determining the initial state of the toggle image.

Remarks

The default value is false, which displays a collapsed toggle image (plus sign).

Setting this property to true displays an expanded toggle image (minus sign).

Example

C# Copy Code
ToggleImage toggleImage = new ToggleImage();
toggleImage.InitialState = ExpressionInfo.FromString("true");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleImage Class
ToggleImage Members


UserSort Class

[image]
ActiveReports 19 .NET Edition
UserSort Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

Glossary Item Box

Represents an object that provides sort information to the end-user within the TextBox UI.

Object Model

UserSort Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserSort
   Implements IValidateable
C#
public sealed class UserSort : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.UserSort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Members
GrapeCity.ActiveReports.PageReportModel Namespace


UserSort Class Members

[image]
ActiveReports 19 .NET Edition
UserSort Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

Glossary Item Box

The following tables list the members exposed by UserSort.

Public Constructors

 | Name | Description
Public Constructor | UserSort Constructor | Initializes a new instance of the UserSort class.
Top

Public Properties

 | Name | Description
Public Property | SortExpression | Gets or sets the expression used for sorting.
Public Property | SortExpressionScope | Gets or sets the scope within which SortExpression is evaluated.
Public Property | SortTarget | Gets or sets the name of the data region, grouping, or dataset to which the sort is applied.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the UserSort object.
Top

See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


UserSort Constructor

[image]
ActiveReports 19 .NET Edition
UserSort Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : UserSort Constructor

Glossary Item Box

Initializes a new instance of the UserSort class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UserSort()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Class
UserSort Members


UserSort Class Methods

[image]
ActiveReports 19 .NET Edition
UserSort Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

Glossary Item Box

For a list of all members of this type, see UserSort members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the UserSort object.
Top

See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the UserSort object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Class
UserSort Members


UserSort Class Properties

[image]
ActiveReports 19 .NET Edition
UserSort Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

Glossary Item Box

For a list of all members of this type, see UserSort members.

Public Properties

 | Name | Description
Public Property | SortExpression | Gets or sets the expression used for sorting.
Public Property | SortExpressionScope | Gets or sets the scope within which SortExpression is evaluated.
Public Property | SortTarget | Gets or sets the name of the data region, grouping, or dataset to which the sort is applied.
Top

See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortExpression Property

[image]
ActiveReports 19 .NET Edition
SortExpression Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortExpression Property

Glossary Item Box

Gets or sets the expression used for sorting.

Syntax

Visual Basic (Declaration)
Public Property SortExpression As ExpressionInfo
C#
public ExpressionInfo SortExpression {get; set;}

Property Value

A GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the expression used for sorting.

Remarks

This property specifies the expression used to determine the sorting order. It should adhere to the same rules as grouping filter expressions. Aggregates within SortExpression should only reference scopes that are equal to or contain SortExpressionScope. If SortExpressionScope is not specified, aggregates must define their scope.

Example

C# Copy Code
UserSort userSort = new UserSort();
userSort.SortExpression = ExpressionInfo.FromString("Fields!Name.Value");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Class
UserSort Members


SortExpressionScope Property

[image]
ActiveReports 19 .NET Edition
SortExpressionScope Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortExpressionScope Property

Glossary Item Box

Gets or sets the scope within which SortExpression is evaluated.

Syntax

Visual Basic (Declaration)
Public Property SortExpressionScope As String
C#
public string SortExpressionScope {get; set;}

Property Value

A System.String value indicating the scope within which SortExpression is evaluated.

Remarks

If specified, SortExpressionScope defines the grouping or dataset scope where SortExpression is evaluated.

The scope must be either identical to or contained within the current scope. If the TextBox has no scope is undefined, SortExpressionScope must be within SortTarget.

Sorting occurs within the group containing SortExpressionScope. For example, in a report with state and city groups where each header has UserSort and corresponding groups have SortExpressionScope, state sorting sorts state groups within the report, and city sorting sorts city groups within each state group without rearranging country state groups.

Example

C# Copy Code
UserSort userSort = new UserSort();
userSort.SortExpression = ExpressionInfo.FromString("Fields!CityGroupName.Value");
userSort.SortExpressionScope = "CityGroup";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Class
UserSort Members


SortTarget Property

[image]
ActiveReports 19 .NET Edition
SortTarget Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortTarget Property

Glossary Item Box

Gets or sets the name of the data region, grouping, or dataset to which the sort is applied.

Syntax

Visual Basic (Declaration)
Public Property SortTarget As String
C#
public string SortTarget {get; set;}

Property Value

A System.String value indicating the name of the data region, grouping, or dataset to which the sort is applied.

Remarks

If not specified, the sort applies to the current report scope.

SortTarget must be either the current scope, an ancestor scope, or a peer scope that is a data region.

Matrix groupings are valid SortTargets only within matrix grouping scopes along the same matrix axis.

Example

C# Copy Code
UserSort userSort = new UserSort();
userSort.SortExpression = ExpressionInfo.FromString("Fields!CityGroupName.Value");
userSort.SortExpressionScope = "CityGroup";
userSort.SortTarget = "DataRegion1";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserSort Class
UserSort Members


ValidationContext Class

[image]
ActiveReports 19 .NET Edition
ValidationContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class

Glossary Item Box

Represents a type of context information that is available during validation.

Object Model

ValidationContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationContext
C#
public sealed class ValidationContext

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidationContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationContext Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationContext Class Members

[image]
ActiveReports 19 .NET Edition
ValidationContext Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class

Glossary Item Box

The following tables list the members exposed by ValidationContext.

Public Constructors

 | Name | Description
Public Constructor | ValidationContext Constructor | Initializes a new instance of the ValidationContext class with the specified validation mode.
Top

Public Properties

 | Name | Description
Public Property | ContextualInformation | Gets a hybrid dictionary containing any information that needs to be passed through validation.
Public Property | Mode | Gets the mode for which the validation context is set.
Public Property | NameValidator | Gets a validator to use for name validation.
Top

See Also

Reference

ValidationContext Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationContext Constructor

[image]
ActiveReports 19 .NET Edition
ValidationContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : ValidationContext Constructor

mode
A ValidationMode value indicating the mode to run the validation for.

Glossary Item Box

Initializes a new instance of the ValidationContext class with the specified validation mode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mode As ValidationMode _
)
C#
public ValidationContext(
   ValidationMode mode
)

Parameters

mode
A ValidationMode value indicating the mode to run the validation for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationContext Class
ValidationContext Members


ValidationContext Class Properties

[image]
ActiveReports 19 .NET Edition
ValidationContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class

Glossary Item Box

For a list of all members of this type, see ValidationContext members.

Public Properties

 | Name | Description
Public Property | ContextualInformation | Gets a hybrid dictionary containing any information that needs to be passed through validation.
Public Property | Mode | Gets the mode for which the validation context is set.
Public Property | NameValidator | Gets a validator to use for name validation.
Top

See Also

Reference

ValidationContext Class
GrapeCity.ActiveReports.PageReportModel Namespace


ContextualInformation Property

[image]
ActiveReports 19 .NET Edition
ContextualInformation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : ContextualInformation Property

Glossary Item Box

Gets a hybrid dictionary containing any information that needs to be passed through validation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContextualInformation As HybridDictionary
C#
public HybridDictionary ContextualInformation {get;}

Property Value

A System.Collections.Specialized.HybridDictionary object containing the information of current validation context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationContext Class
ValidationContext Members


Mode Property

[image]
ActiveReports 19 .NET Edition
Mode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : Mode Property

Glossary Item Box

Gets the mode for which the validation context is set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mode As ValidationMode
C#
public ValidationMode Mode {get;}

Property Value

A ValidationMode value indicating the current validation mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationContext Class
ValidationContext Members


NameValidator Property

[image]
ActiveReports 19 .NET Edition
NameValidator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : NameValidator Property

Glossary Item Box

Gets a validator to use for name validation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NameValidator As NameValidator
C#
public NameValidator NameValidator {get;}

Property Value

A NameValidator object of current validation context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationContext Class
ValidationContext Members


ValidationEntry Class

[image]
ActiveReports 19 .NET Edition
ValidationEntry Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class

Glossary Item Box

Represents a single entry of information related to validation.

Object Model

ValidationEntry Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationEntry
C#
public sealed class ValidationEntry

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidationEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntry Class Members

[image]
ActiveReports 19 .NET Edition
ValidationEntry Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class

Glossary Item Box

The following tables list the members exposed by ValidationEntry.

Public Constructors

 | Name | Description
Public Constructor | ValidationEntry Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets the System.Exception object that is associated with this validation entry, if any.
Public Property | Message | Gets the user-friendly message for the validation entry.
Public Property | Owner | Gets the object that owns the validation entry.
Public Property | Severity | Gets the severity level of the entry.
Top

See Also

Reference

ValidationEntry Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntry Constructor

[image]
ActiveReports 19 .NET Edition
ValidationEntry Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : ValidationEntry Constructor

Glossary Item Box

Overload List

Overload | Description
ValidationEntry Constructor(Severity,String,Object) | Initializes a new instance of the ValidationEntry class.
ValidationEntry Constructor(Severity,String,Exception,Object) | Initializes a new instance of the ValidationEntry class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members


ValidationEntry Constructor(Severity,String,Object)

[image]
ActiveReports 19 .NET Edition
ValidationEntry Constructor(Severity,String,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class > ValidationEntry Constructor : ValidationEntry Constructor(Severity,String,Object)

severity
A Severity value indicating the severity level for the entry.
message
A System.String value indicating the user-friendly message to use for the entry. This message will be displayed in the task list.
owner
An System.Object representing the owner of the validation entry.

Glossary Item Box

Initializes a new instance of the ValidationEntry class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal severity As Severity, _
   ByVal message As String, _
   ByVal owner As Object _
)
C#
public ValidationEntry(
   Severity severity,
   string message,
   object owner
)

Parameters

severity
A Severity value indicating the severity level for the entry.
message
A System.String value indicating the user-friendly message to use for the entry. This message will be displayed in the task list.
owner
An System.Object representing the owner of the validation entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members
Overload List


ValidationEntry Constructor(Severity,String,Exception,Object)

[image]
ActiveReports 19 .NET Edition
ValidationEntry Constructor(Severity,String,Exception,Object)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class > ValidationEntry Constructor : ValidationEntry Constructor(Severity,String,Exception,Object)

severity
A Severity value indicating the severity level for the entry
message
A System.String value indicating the user friendly message to use for the entry. This message will be displayed in the task list.
exception
An System.Exception to be logged/fired by the entry.
owner
An System.Object representing the owner of the validation entry.

Glossary Item Box

Initializes a new instance of the ValidationEntry class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal severity As Severity, _
   ByVal message As String, _
   ByVal exception As Exception, _
   ByVal owner As Object _
)
C#
public ValidationEntry(
   Severity severity,
   string message,
   Exception exception,
   object owner
)

Parameters

severity
A Severity value indicating the severity level for the entry
message
A System.String value indicating the user friendly message to use for the entry. This message will be displayed in the task list.
exception
An System.Exception to be logged/fired by the entry.
owner
An System.Object representing the owner of the validation entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members
Overload List


ValidationEntry Class Properties

[image]
ActiveReports 19 .NET Edition
ValidationEntry Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class

Glossary Item Box

For a list of all members of this type, see ValidationEntry members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the System.Exception object that is associated with this validation entry, if any.
Public Property | Message | Gets the user-friendly message for the validation entry.
Public Property | Owner | Gets the object that owns the validation entry.
Public Property | Severity | Gets the severity level of the entry.
Top

See Also

Reference

ValidationEntry Class
GrapeCity.ActiveReports.PageReportModel Namespace


Exception Property

[image]
ActiveReports 19 .NET Edition
Exception Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Exception Property

Glossary Item Box

Gets the System.Exception object that is associated with this validation entry, if any.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Property Value

An System.Exception associated with the validation entry, or null if there is no exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Message Property

Glossary Item Box

Gets the user-friendly message for the validation entry.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

A System.String value indicating the message to display for the validation entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members


Owner Property

[image]
ActiveReports 19 .NET Edition
Owner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Owner Property

Glossary Item Box

Gets the object that owns the validation entry.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As Object
C#
public object Owner {get;}

Property Value

An System.Object representing the owner of the validation entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members


Severity Property

[image]
ActiveReports 19 .NET Edition
Severity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Severity Property

Glossary Item Box

Gets the severity level of the entry.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Severity As Severity
C#
public Severity Severity {get;}

Property Value

A Severity value indicating the severity level of the entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEntry Class
ValidationEntry Members


Validator Class

[image]
ActiveReports 19 .NET Edition
Validator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

Glossary Item Box

Represents an object for performing validation on a report definition.

Object Model

Validator Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Validator
C#
public sealed class Validator

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Validator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Validator Members
GrapeCity.ActiveReports.PageReportModel Namespace


Validator Class Members

[image]
ActiveReports 19 .NET Edition
Validator Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

Glossary Item Box

The following tables list the members exposed by Validator.

Public Properties

 | Name | Description
Public Property | ValidationEntries | Gets the ValidationEntry results from a validated report definition.
Top

Public Methods

 | Name | Description
Public Method | Validate | Performs validation on the specified report definition.
Top

See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validator Class Methods

[image]
ActiveReports 19 .NET Edition
Validator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

Glossary Item Box

For a list of all members of this type, see Validator members.

Public Methods

 | Name | Description
Public Method | Validate | Performs validation on the specified report definition.
Top

See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Validator Class : Validate Method

report
A Report object to validate.

Glossary Item Box

Performs validation on the specified report definition.

Syntax

Visual Basic (Declaration)
Public Sub Validate( _
   ByVal report As Report _
)
C#
public void Validate(
   Report report
)

Parameters

report
A Report object to validate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Validator Class
Validator Members


Validator Class Properties

[image]
ActiveReports 19 .NET Edition
Validator Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

Glossary Item Box

For a list of all members of this type, see Validator members.

Public Properties

 | Name | Description
Public Property | ValidationEntries | Gets the ValidationEntry results from a validated report definition.
Top

See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntries Property

[image]
ActiveReports 19 .NET Edition
ValidationEntries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Validator Class : ValidationEntries Property

Glossary Item Box

Gets the ValidationEntry results from a validated report definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValidationEntries As ValidationEntry()
C#
public ValidationEntry[] ValidationEntries {get;}

Property Value

An array of ValidationEntry objects containing the validation results. If there are no entries, the returned array is empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Validator Class
Validator Members


ValidValues Class

[image]
ActiveReports 19 .NET Edition
ValidValues Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

Glossary Item Box

Represents the possible values for a parameter. This is used to populate UI selection lists from which users can select a parameter value.

Object Model

ValidValues Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidValues
   Implements IValidateable
C#
public sealed class ValidValues : IValidateable

Remarks

A ValidValues object must have one and only one of the following properties set: DataSetReference or ParameterValues.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidValues Class Members

[image]
ActiveReports 19 .NET Edition
ValidValues Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

Glossary Item Box

The following tables list the members exposed by ValidValues.

Public Constructors

 | Name | Description
Public Constructor | ValidValues Constructor | Initializes a new instance of the ValidValues class.
Top

Public Properties

 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | OrderBy | Gets a collection of hardcoded values for the parameter values order.
Public Property | ParameterValues | Gets a collection of hardcoded values for the parameter.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the ValidValues object.
Top

See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidValues Constructor

[image]
ActiveReports 19 .NET Edition
ValidValues Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : ValidValues Constructor

Glossary Item Box

Initializes a new instance of the ValidValues class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ValidValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


ValidValues Class Methods

[image]
ActiveReports 19 .NET Edition
ValidValues Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

Glossary Item Box

For a list of all members of this type, see ValidValues members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | Validate | Validates the current state of the ValidValues object.
Top

See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As ValidValues
C#
public ValidValues Clone()

Return Value

A new ValidValues object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the ValidValues object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


ValidValues Class Properties

[image]
ActiveReports 19 .NET Edition
ValidValues Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

Glossary Item Box

For a list of all members of this type, see ValidValues members.

Public Properties

 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | OrderBy | Gets a collection of hardcoded values for the parameter values order.
Public Property | ParameterValues | Gets a collection of hardcoded values for the parameter.
Top

See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Property

[image]
ActiveReports 19 .NET Edition
DataSetReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : DataSetReference Property

Glossary Item Box

Gets or sets the query to execute to obtain the default value(s) for the parameter.

Syntax

Visual Basic (Declaration)
Public Property DataSetReference As DataSetReference
C#
public DataSetReference DataSetReference {get; set;}

Property Value

A DataSetReference object representing the query to execute to obtain the default value(s) for the parameter.

Remarks

By default, this is the first value from the ValueField property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


OrderBy Property

[image]
ActiveReports 19 .NET Edition
OrderBy Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : OrderBy Property

Glossary Item Box

Gets a collection of hardcoded values for the parameter values order.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderBy As OrderBy
C#
public OrderBy OrderBy {get;}

Property Value

An OrderBy object containing hardcoded values for the parameter values order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


ParameterValues Property

[image]
ActiveReports 19 .NET Edition
ParameterValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : ParameterValues Property

Glossary Item Box

Gets a collection of hardcoded values for the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterValues As ParameterValueCollection
C#
public ParameterValueCollection ParameterValues {get;}

Property Value

A ParameterValueCollection object containing hardcoded values for the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidValues Class
ValidValues Members


ValueCategoryAxis Class

[image]
ActiveReports 19 .NET Edition
ValueCategoryAxis Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

Glossary Item Box

Used as a Category axis in a chart, the element defines the category (X) axis. There must be a corresponding DataPoint for each StaticCategories member. Used as a Value axis, the element defines the data (Y) axis.

Object Model

ValueCategoryAxis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValueCategoryAxis
   Implements IValidateable
C#
public sealed class ValueCategoryAxis : IValidateable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValueCategoryAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValueCategoryAxis Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValueCategoryAxis Class Members

[image]
ActiveReports 19 .NET Edition
ValueCategoryAxis Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

Glossary Item Box

The following tables list the members exposed by ValueCategoryAxis.

Public Constructors

 | Name | Description
Public Constructor | ValueCategoryAxis Constructor | Initializes a new instance of the ValueCategoryAxis class.
Top

Public Properties

 | Name | Description
Public Property | Axis | Gets or sets the display properties for the category or value axis.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ValueCategoryAxis object.
Top

See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValueCategoryAxis Constructor

[image]
ActiveReports 19 .NET Edition
ValueCategoryAxis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : ValueCategoryAxis Constructor

Glossary Item Box

Initializes a new instance of the ValueCategoryAxis class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ValueCategoryAxis()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


ValueCategoryAxis Class Methods

[image]
ActiveReports 19 .NET Edition
ValueCategoryAxis Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

Glossary Item Box

For a list of all members of this type, see ValueCategoryAxis members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the information in each property of the ValueCategoryAxis object.
Top

See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : Validate Method

context
The ValidationContext object containing the contextual information used to drive the validation.

Glossary Item Box

Validates the information in each property of the ValueCategoryAxis object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


ValueCategoryAxis Class Properties

[image]
ActiveReports 19 .NET Edition
ValueCategoryAxis Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

Glossary Item Box

For a list of all members of this type, see ValueCategoryAxis members.

Public Properties

 | Name | Description
Public Property | Axis | Gets or sets the display properties for the category or value axis.
Top

See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Property

[image]
ActiveReports 19 .NET Edition
Axis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : Axis Property

Glossary Item Box

Gets or sets the display properties for the category or value axis.

Syntax

Visual Basic (Declaration)
Public Property Axis As Axis
C#
public Axis Axis {get; set;}

Property Value

An Axis object containing the display properties for the category or value axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


Variable Class

[image]
ActiveReports 19 .NET Edition
Variable Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class

Glossary Item Box

Represents a variable of the list grouping.

Object Model

Variable Class

Syntax

Visual Basic (Declaration)
Public Class Variable
C#
public class Variable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Variable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variable Members
GrapeCity.ActiveReports.PageReportModel Namespace


Variable Class Members

[image]
ActiveReports 19 .NET Edition
Variable Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class

Glossary Item Box

The following tables list the members exposed by Variable.

Public Constructors

 | Name | Description
Public Constructor | Variable Constructor | Initializes a new instance of the Variable class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name of the variable.
Public Property | Value | Gets or sets a value of the variable.
Public Property | Writable | Gets or sets a value indicating whether the variable is writable.
Top

See Also

Reference

Variable Class
GrapeCity.ActiveReports.PageReportModel Namespace


Variable Constructor

[image]
ActiveReports 19 .NET Edition
Variable Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Variable Constructor

Glossary Item Box

Initializes a new instance of the Variable class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Variable()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variable Class
Variable Members


Variable Class Properties

[image]
ActiveReports 19 .NET Edition
Variable Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class

Glossary Item Box

For a list of all members of this type, see Variable members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a name of the variable.
Public Property | Value | Gets or sets a value of the variable.
Public Property | Writable | Gets or sets a value indicating whether the variable is writable.
Top

See Also

Reference

Variable Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Name Property

Glossary Item Box

Gets or sets a name of the variable.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variable Class
Variable Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Value Property

Glossary Item Box

Gets or sets a value of the variable.

Syntax

Visual Basic (Declaration)
Public Property Value As ExpressionInfo
C#
public ExpressionInfo Value {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object representing the value of the variable.

Example

C# Copy Code
Variable myVariable = new Variable();
myVariable.Value = "=Sum(Sales)";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variable Class
Variable Members


Writable Property

[image]
ActiveReports 19 .NET Edition
Writable Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Writable Property

Glossary Item Box

Gets or sets a value indicating whether the variable is writable.

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable {get; set;}

Property Value

A System.Boolean value where true if the variable is writable; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variable Class
Variable Members


Visibility Class

[image]
ActiveReports 19 .NET Edition
Visibility Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

Glossary Item Box

Represents the Visibility element controls whether the ReportItem is initially visible in the output report.

Object Model

Visibility Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Visibility
   Implements IValidateable
C#
public sealed class Visibility : IValidateable

Remarks

The Visibility class provides properties to control the visibility of a report item, allowing for dynamic display based on expressions and user interactions.

Example

C# Copy Code
var reportItem = new TextBox();
reportItem.Visibility = new Visibility { Hidden = ExpressionInfo.FromString("true") };

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Visibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Visibility Members
GrapeCity.ActiveReports.PageReportModel Namespace


Visibility Class Members

[image]
ActiveReports 19 .NET Edition
Visibility Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

Glossary Item Box

The following tables list the members exposed by Visibility.

Public Constructors

 | Name | Description
Public Constructor | Visibility Constructor | Initializes a new instance of the Visibility class.
Top

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets a Boolean expression that indicates whether the item is initially hidden.
Public Property | ToggleItem | Gets or sets the name of the TextBox used to toggle the visibility of the report item.
Top

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Visibility object.
Top

See Also

Reference

Visibility Class
GrapeCity.ActiveReports.PageReportModel Namespace


Visibility Constructor

[image]
ActiveReports 19 .NET Edition
Visibility Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : Visibility Constructor

Glossary Item Box

Initializes a new instance of the Visibility class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Visibility()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Visibility Class
Visibility Members


Visibility Class Methods

[image]
ActiveReports 19 .NET Edition
Visibility Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

Glossary Item Box

For a list of all members of this type, see Visibility members.

Public Methods

 | Name | Description
Public Method | Validate | Validates the current state of the Visibility object.
Top

See Also

Reference

Visibility Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the Visibility object.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if context is null.

Remarks

Clicking an instance of the ToggleItem toggles the hidden state of every corresponding instance of the item. If the ToggleItem becomes hidden, this item becomes hidden. This cascading does not apply if the ToggleItem becomes hidden as a result of a containing table column or matrix cell becoming hidden.

The ToggleItem must be a textbox in the same grouping scope as this item or in any containing grouping scope.

If a value for the ToggleItem is omitted, no item toggles the hidden state of this item.

ToggleItems are not allowed on and cannot refer to report items contained in a page header or footer.

ToggleItems cannot refer to a report item contained within the current report item unless the current grouping scope has a parent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Visibility Class
Visibility Members


Visibility Class Properties

[image]
ActiveReports 19 .NET Edition
Visibility Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

Glossary Item Box

For a list of all members of this type, see Visibility members.

Public Properties

 | Name | Description
Public Property | Hidden | Gets or sets a Boolean expression that indicates whether the item is initially hidden.
Public Property | ToggleItem | Gets or sets the name of the TextBox used to toggle the visibility of the report item.
Top

See Also

Reference

Visibility Class
GrapeCity.ActiveReports.PageReportModel Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : Hidden Property

Glossary Item Box

Gets or sets a Boolean expression that indicates whether the item is initially hidden.

Syntax

Visual Basic (Declaration)
Public Property Hidden As ExpressionInfo
C#
public ExpressionInfo Hidden {get; set;}

Property Value

An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object that evaluates to a System.Boolean value indicating whether the item is initially hidden. The default value is false.

Example

C# Copy Code
visibility.Hidden = ExpressionInfo.FromString("true");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Visibility Class
Visibility Members


ToggleItem Property

[image]
ActiveReports 19 .NET Edition
ToggleItem Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : ToggleItem Property

Glossary Item Box

Gets or sets the name of the TextBox used to toggle the visibility of the report item.

Syntax

Visual Basic (Declaration)
Public Property ToggleItem As String
C#
public string ToggleItem {get; set;}

Property Value

A System.String value indicating the name of the textbox used to toggle the visibility of the report item.

Remarks

Clicking an instance of the ToggleItem toggles the hidden state of every corresponding instance of the item. If the ToggleItem becomes hidden, this item becomes hidden. This cascading does not apply if the ToggleItem becomes hidden as a result of a containing table column or matrix cell becoming hidden.

The ToggleItem must be a textbox in the same grouping scope as this item or in any containing grouping scope.

If a value for the ToggleItem is omitted, no item toggles the hidden state of this item.

ToggleItems are not allowed on and cannot refer to report items contained in a page header or footer.

ToggleItems cannot refer to a report item contained within the current report item unless the current grouping scope has a parent.

Example

C# Copy Code
visibility.ToggleItem = "ToggleTextBoxName";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Visibility Class
Visibility Members


AccentSensitivity Enumeration

[image]
ActiveReports 19 .NET Edition
AccentSensitivity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AccentSensitivity Enumeration

Glossary Item Box

Specifies whether the data is accent sensitive.

Syntax

Visual Basic (Declaration)
Public Enum AccentSensitivity
   Inherits System.Enum
C#
public enum AccentSensitivity : System.Enum

Members

Member | Description
Auto | The accent sensitivity setting is derived by querying the data provider.
False | The data is not accent sensitive.
True | The data is accent sensitive.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AccentSensitivity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


AntiAliasing Enumeration

[image]
ActiveReports 19 .NET Edition
AntiAliasing Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AntiAliasing Enumeration

Glossary Item Box

The possible values for the GaugePanel.AntiAliasing and Map.AntiAliasing properties.

Syntax

Visual Basic (Declaration)
Public Enum AntiAliasing
   Inherits System.Enum
C#
public enum AntiAliasing : System.Enum

Members

Member | Description
All | Anti-aliasing is applied to both text and graphics.
Graphics | Anti-aliasing is applied to graphics.
None | Anti-aliasing is not applied.
Text | Anti-aliasing is applied to text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AntiAliasing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ApplyParameterType Enumeration

[image]
ActiveReports 19 .NET Edition
ApplyParameterType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ApplyParameterType Enumeration

Glossary Item Box

Specifies the types of apply parameter actions.

Syntax

Visual Basic (Declaration)
Public Enum ApplyParameterType
   Inherits System.Enum
C#
public enum ApplyParameterType : System.Enum

Members

Member | Description
Reset | Resets the parameter to its initial (default) value. See ReportParameter.DefaultValue.
Set | Sets the parameter value.
Toggle | Adds or removes a value from a collection of values (applicable for multi-value parameters).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ApplyParameterType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


AutoWidth Enumeration

[image]
ActiveReports 19 .NET Edition
AutoWidth Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AutoWidth Enumeration

Glossary Item Box

Specifies a column auto grow behavior.

Syntax

Visual Basic (Declaration)
Public Enum AutoWidth
   Inherits System.Enum
C#
public enum AutoWidth : System.Enum

Members

Member | Description
None | Columns do not grow
Proportional | Columns grow proportionally to fill free table space

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AutoWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Axis.AxisLocation Enumeration

[image]
ActiveReports 19 .NET Edition
Axis.AxisLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis.AxisLocation Enumeration

Glossary Item Box

The axis location related to chart data.

Syntax

Visual Basic (Declaration)
Public Enum Axis.AxisLocation
   Inherits System.Enum
C#
public enum Axis.AxisLocation : System.Enum

Members

Member | Description
Left | Specifies that the chart axis should be drawn to the left of the chart area.
Right | Specifies that the chart axis should be drawn to the right of the chart area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Axis.AxisLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


AxisLabelOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
AxisLabelOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AxisLabelOrientation Enumeration

Glossary Item Box

The axis title text orientations.

Syntax

Visual Basic (Declaration)
Public Enum AxisLabelOrientation
   Inherits System.Enum
C#
public enum AxisLabelOrientation : System.Enum

Members

Member | Description
Angled | Rotated 45 degrees.
Auto | Indicates the orientation will be selected automatically based on context (for example, Rotated270 for titles docked on the left).
Horizontal | Horizontal text
Rotated270 | Vertical text � Rotated 270 degrees.
Rotated90 | Vertical text � Rotated 90 degrees.
Stacked | Vertical text � No character rotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AxisLabelOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


AxisTextOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
AxisTextOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AxisTextOrientation Enumeration

Glossary Item Box

The axis title text orientations.

Syntax

Visual Basic (Declaration)
Public Enum AxisTextOrientation
   Inherits System.Enum
C#
public enum AxisTextOrientation : System.Enum

Members

Member | Description
Auto | Indicates the orientation will be selected automatically based on context (for example, Rotated270 for titles docked on the left).
Horizontal | Horizontal text
Rotated270 | Vertical text � Rotated 270 degrees.
Rotated90 | Vertical text � Rotated 90 degrees.
Stacked | Vertical text � No character rotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AxisTextOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundGradientType Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundGradientType Enumeration

Glossary Item Box

Specifies a type of background gradient.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundGradientType
   Inherits System.Enum
C#
public enum BackgroundGradientType : System.Enum

Members

Member | Description
Center | Indicates the gradient moves out from the center.
DiagonalLeft | Indicates the gradient moves diagonally from the left.
DiagonalRight | Indicates the gradient moves diagonally from the right.
HorizontalCenter | Indicates the gradient move out to the left and right from the center.
LeftRight | Indicates the gradient moves from left to right.
None | Indicates no gradient
TopBottom | Indicates the gradient moves from top to bottom.
VerticalCenter | Indicates the gradient move out to the top and bottom from the center.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BackgroundGradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundHatchTypes Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundHatchTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundHatchTypes Enumeration

Glossary Item Box

Specifies a hatching pattern for the background.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundHatchTypes
   Inherits System.Enum
C#
public enum BackgroundHatchTypes : System.Enum

Members

Member | Description
BackwardDiagonal | The backward diagonal hatch type.
Cross | The cross hatch type.
DarkDownwardDiagonal | The dark downward diagonal hatch type.
DarkHorizontal | The dark horizontal hatch type.
DarkUpwardDiagonal | The dark upward diagonal hatch type.
DarkVertical | The dark vertical hatch type.
DashedDownwardDiagonal | The dashed downward diagonal hatch type.
DashedHorizontal | The dashed horizontal hatch type.
DashedUpwardDiagonal | The dashed upward diagonal hatch type.
DashedVertical | The dashed vertical hatch type.
Default | The default hatch type.
DiagonalBrick | The diagonal brick hatch type.
DiagonalCross | The diagonal cross hatch type.
Divot | The divot hatch type.
DottedDiamond | The dotted diamond hatch type.
DottedGrid | The dotted grid hatch type.
ForwardDiagonal | The forward diagonal hatch type.
Horizontal | The horizontal hatch type.
HorizontalBrick | The horizontal brick hatch type.
LargeCheckerBoard | The large checker board hatch type.
LargeConfetti | The large confetti hatch type.
LargeGrid | The large grid hatch type.
LightDownwardDiagonal | The light downward diagonal hatch type.
LightHorizontal | The light horizontal hatch type.
LightUpwardDiagonal | The light upward diagonal hatch type.
LightVertical | The light vertical hatch type.
NarrowHorizontal | The narrow horizontal hatch type.
NarrowVertical | The narrow vertical hatch type.
None | The none hatch type.
OutlinedDiamond | The outlined diamond hatch type.
Percent05 | The percent05 hatch type.
Percent10 | The percent10 hatch type.
Percent20 | The percent20 hatch type.
Percent25 | The percent25 hatch type.
Percent30 | The percent30 hatch type.
Percent40 | The percent40 hatch type.
Percent50 | The percent50 hatch type.
Percent60 | The percent60 hatch type.
Percent70 | The percent70 hatch type.
Percent75 | The percent75 hatch type.
Percent80 | The percent80 hatch type.
Percent90 | The percent90 hatch type.
Plaid | The plaid
Shingle | The shingle hatch type.
SmallCheckerBoard | The small checker board hatch type.
SmallConfetti | The small confetti hatch type.
SmallGrid | The small grid hatch type.
SolidDiamond | The solid diamond hatch type.
Sphere | The sphere hatch type.
Trellis | The trellis hatch type.
Vertical | The vertical hatch type.
Wave | The wave hatch type.
Weave | The weave hatch type.
WideDownwardDiagonal | The wide downward diagonal hatch type.
WideUpwardDiagonal | The wide upward diagonal hatch type.
ZigZag | The zig zag hatch type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BackgroundHatchTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundRepeat Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundRepeat Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundRepeat Enumeration

Glossary Item Box

Specifies how the background image fills the available space.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundRepeat
   Inherits System.Enum
C#
public enum BackgroundRepeat : System.Enum

Members

Member | Description
NoRepeat | Indicates that this image is rendered once and does not repeat.
Repeat | Indicates that the image repeats horizontally and vertically in the background.
RepeatX | Indicates that this image repeats horizontally in the background.
RepeatY | Indicates that this image repeats vertically in the background.

Remarks

BackgroundRepeat applies only to Rectangle, TextBox, List, Matrix, Table, Body, and Subtotal items.BackgroundRepeat does not apply to Line, Image, Subreport, and Chart items.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BackgroundRepeat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BorderDrawingStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BorderDrawingStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderDrawingStyle Enumeration

Glossary Item Box

Specifies a style of the border on a report item.

Syntax

Visual Basic (Declaration)
Public Enum BorderDrawingStyle
   Inherits System.Enum
C#
public enum BorderDrawingStyle : System.Enum

Members

Member | Description
DashDot | Indicates a DashDot border line.
DashDotDot | Indicates a DashDotDot border line.
Dashed | Indicates a dashed border line.
Dotted | Indicates a dotted border line.
Double | Indicates a double border line.
Groove | Indicates a grooved border line.
Inset | Indicates an inset border line.
None | Indicates no border line.
Outset | Indicates an outset border line.
Ridge | Indicates a ridged border line.
Solid | Indicates a solid border line.
WindowInset | Indicates a Windows-style inset border line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BorderDrawingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BorderDrawingStyle2008 Enumeration

[image]
ActiveReports 19 .NET Edition
BorderDrawingStyle2008 Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderDrawingStyle2008 Enumeration

Glossary Item Box

Specifies a style of the border on a report item.

Syntax

Visual Basic (Declaration)
Public Enum BorderDrawingStyle2008
   Inherits System.Enum
C#
public enum BorderDrawingStyle2008 : System.Enum

Members

Member | Description
DashDot | Indicates a grooved border line.
DashDotDot | Indicates a DashDotDot border line.
Dashed | Indicates a dashed border line.
Dotted | Indicates a dotted border line.
Double | Indicates a double border line.
None | Indicates no border line.
Solid | Indicates a solid border line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BorderDrawingStyle2008

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BreakLocation Enumeration

[image]
ActiveReports 19 .NET Edition
BreakLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BreakLocation Enumeration

Glossary Item Box

Specifies a break location.

Syntax

Visual Basic (Declaration)
Public Enum BreakLocation
   Inherits System.Enum
C#
public enum BreakLocation : System.Enum

Members

Member | Description
Between | Break between.
End | Break at end.
None | No break.
Start | Break at start.
StartAndEnd | Break at start and end.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BreakLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


CaseSensitivity Enumeration

[image]
ActiveReports 19 .NET Edition
CaseSensitivity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CaseSensitivity Enumeration

Glossary Item Box

Specifies whether the data is case sensitive.

Syntax

Visual Basic (Declaration)
Public Enum CaseSensitivity
   Inherits System.Enum
C#
public enum CaseSensitivity : System.Enum

Members

Member | Description
Auto | The case sensitivity setting is derived by querying the data provider.
False | The data is not case sensitive.
True | The data is case sensitive.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.CaseSensitivity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartPalette Enumeration

[image]
ActiveReports 19 .NET Edition
ChartPalette Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartPalette Enumeration

Glossary Item Box

Specifies the color palette for chart items.

Syntax

Visual Basic (Declaration)
Public Enum ChartPalette
   Inherits System.Enum
C#
public enum ChartPalette : System.Enum

Members

Member | Description
Custom | Custom chart palette
Default | Indicates the default palette of rich jewel tones.
EarthTones | Indicates an earth tone palette of autumnal browns, oranges, and greens.
Excel | Indicates an Excel palette of muted plums, blues, and creams.
GrayScale | Indicates a gray scale palette of patterns suitable for printing to a black and white printer.
Light | Indicates a light colored palette of pale pinks and peaches.
Pastel | Indicates a pastel palette of blues, greens and purples.
SemiTransparent | Indicates a semi-transparent palette of primary and tertiary colors that allows the backdrop to show through.
Subdued | Indicates a palette of subdued colors ideal for charts where the data should not have special emphasis drawn to it.
Theme | Theme chart palette
Vivid | Indicates a vivid palette of colors idea for drawing emphasis to the data being displayed in the chart.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartPalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesPlotType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartSeriesPlotType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesPlotType Enumeration

Glossary Item Box

Specifies whether the series is plotted as a line for column charts.

Syntax

Visual Basic (Declaration)
Public Enum ChartSeriesPlotType
   Inherits System.Enum
C#
public enum ChartSeriesPlotType : System.Enum

Members

Member | Description
Auto | Indicates that the series is plotted based off on the primary chart type. For example, the plot type for a column chart is columns.
Line | Indicates that the series is plotted as a line.
Point | Indicates that the series should be plotted with points.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartSeriesPlotType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartSubtype Enumeration

[image]
ActiveReports 19 .NET Edition
ChartSubtype Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSubtype Enumeration

Glossary Item Box

Specifies the subtype of the chart. Different subtypes are available for each chart type.

Syntax

Visual Basic (Declaration)
Public Enum ChartSubtype
   Inherits System.Enum
C#
public enum ChartSubtype : System.Enum

Members

Member | Description
Candlestick | Used with Stock chart types.
Exploded | Used with Pie and Doughnut chart types.
HighLowClose | Used with Stock chart types.
Line | Used with Scatter chart types.
OpenHighLowClose | Used with Stock chart types.
PercentStacked | Used with Column, Bar, and Area chart types.
Plain | Used with Column, Bar, Line, Pie, Scatter, Bubble, Area, and Doughnut chart types.
Smooth | Used with Line chart types.
SmoothLine | Used with Scatter chart types.
Stacked | Used with Column, Bar, and Area chart types.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartSubtype

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartType Enumeration

Glossary Item Box

Specifies a type of the chart.

Syntax

Visual Basic (Declaration)
Public Enum ChartType
   Inherits System.Enum
C#
public enum ChartType : System.Enum

Members

Member | Description
Area | The chart fills an area below a line to display values.
Bar | The chart uses horizontal bars to display values.
Bubble | The chart uses bubbles to display values.
Column | The chart uses vertical bars to display values.
DotPlot | Dot plot chart type
Doughnut | The chart uses segments of a doughnut to display values to total 100%.
Funnel | The chart uses segments of a funnel to display values to total 100%.
Gantt | The chart uses bars to display beginning and ending values.
Kagi | The chart uses connected vertical lines of varying thicknesses to display values and reversals.
Line | The chart uses lines to display values.
Pie | The chart uses wedges in a pie to display values to total 100%.
PointAndFigure | The chart uses Xs and Os to display rising or falling values.
Pyramid | The chart uses segments of a pyramid to display values to total 100%.
Renko | The chart uses bricks to display trends in values.
Scatter | The chart uses markers or points to display values.
Stock | The chart uses sticks to display high, low, and closing (and opening) values.
ThreeLineBreak | The chart uses boxes to display rising or falling values which break the previous high or low value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


CheckAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
CheckAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckAlignment Enumeration

Glossary Item Box

Specifies a type of alignment checking.

Syntax

Visual Basic (Declaration)
Public Enum CheckAlignment
   Inherits System.Enum
C#
public enum CheckAlignment : System.Enum

Members

Member | Description
BottomCenter | Content is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Content is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Content is vertically aligned at the bottom, and horizontally aligned on the right.
MiddleCenter | Content is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Content is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Content is vertically aligned in the middle, and horizontally aligned on the right.
TopCenter | Content is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Content is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Content is vertically aligned at the top, and horizontally aligned on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.CheckAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


CollateBy Enumeration

[image]
ActiveReports 19 .NET Edition
CollateBy Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CollateBy Enumeration

Glossary Item Box

Specifies a combination of reports when using a theme.

Syntax

Visual Basic (Declaration)
Public Enum CollateBy
   Inherits System.Enum
C#
public enum CollateBy : System.Enum

Members

Member | Description
Simple | Draw the pages of the report without sorting.
Value | Sort the pages of the report according to the page number.
ValueIndex | Rearrange the report pages according to the grouping expression you specify in the Report's Page dialog.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.CollateBy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ConnectStringType Enumeration

[image]
ActiveReports 19 .NET Edition
ConnectStringType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectStringType Enumeration

Glossary Item Box

Specifies a type of connection string used in a data source configuration.

Syntax

Visual Basic (Declaration)
Public Enum ConnectStringType
   Inherits System.Enum
C#
public enum ConnectStringType : System.Enum

Members

Member | Description
Embedded | Default behavior - connection string is just a part of the data source.
External | Required external processing for connection string. For example - it can be name from config file.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ConnectStringType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DataElementOutput Enumeration

[image]
ActiveReports 19 .NET Edition
DataElementOutput Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataElementOutput Enumeration

Glossary Item Box

Specifies how an item should appear in data output.

Syntax

Visual Basic (Declaration)
Public Enum DataElementOutput
   Inherits System.Enum
C#
public enum DataElementOutput : System.Enum

Members

Member | Description
Auto | Will behave as NoOutput for Textboxes with constant values, ContentsOnly for Rectangles and Output for all other items.
ContentsOnly | Indicates the item should not appear in the (e.g. XML), but its contents should be rendered as if they were in this item’s container. Only applies to Lists.
NoOutput | Indicates the item should not appear in the output.
Output | Indicates the item should appear in the output

Remarks

Some ReportItems do not support all values (for example List and Table do not support Auto).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DataElementStyle Enumeration

[image]
ActiveReports 19 .NET Edition
DataElementStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataElementStyle Enumeration

Glossary Item Box

Specifies whether an item should render as an element or attribute.

Syntax

Visual Basic (Declaration)
Public Enum DataElementStyle
   Inherits System.Enum
C#
public enum DataElementStyle : System.Enum

Members

Member | Description
AttributeNormal | Render as an attribute.
Auto | Auto indicates using the setting defined by the report.
ElementNormal | Render as an element.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DataElementStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Direction Enumeration

[image]
ActiveReports 19 .NET Edition
Direction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Direction Enumeration

Glossary Item Box

Specifies whether the text is written from left to right or right to left.

Syntax

Visual Basic (Declaration)
Public Enum Direction
   Inherits System.Enum
C#
public enum Direction : System.Enum

Members

Member | Description
LTR | Indicates left to right.
RTL | Indicates right to left.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Direction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapSource Enumeration

[image]
ActiveReports 19 .NET Edition
DocumentMapSource Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapSource Enumeration

Glossary Item Box

Specifies the document map sources.

Syntax

Visual Basic (Declaration)
Public Enum DocumentMapSource
   Inherits System.Enum
C#
public enum DocumentMapSource : System.Enum

Members

Member | Description
All | Document map provided by both labels and headings.
Headings | Document map provided by headings.
Labels | Document map provided by labels of controls.
None | No document map.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DocumentMapSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


FilterOperator Enumeration

[image]
ActiveReports 19 .NET Edition
FilterOperator Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FilterOperator Enumeration

Glossary Item Box

Specifies an operator to use to compare the values returned by the FilterExpression with those in the FilterValues object.

Syntax

Visual Basic (Declaration)
Public Enum FilterOperator
   Inherits System.Enum
C#
public enum FilterOperator : System.Enum

Members

Member | Description
Between | Displays the record if the FilterExpression result falls between the two FilterValues.
BottomN | Displays the record if the FilterExpression result is in the bottom N of all records processed.
BottomPercent | Displays the record if the FilterExpression result is in the bottom N% of all records processed.
Equal | Displays the record if the two values are equal.
GreaterThan | Displays the record if the FilterExpression result is greater than the FilterValues.
GreaterThanOrEqual | Displays the record if the FilterExpression result is greater than or equal to the FilterValues.
In | Displays the record if the FilterExpression result is within the list of FilterValues.
LessThan | Displays the record if the FilterExpression result is less than the FilterValue.
LessThanOrEqual | Displays the record if the FilterExpression result is less than or equal to the FilterValue.
Like | Displays the record if the FilterExpression results satisfy the pattern set in the FilterValues.
NotEqual | Displays the record if the two values are not equal.
TopN | Displays the record if the FilterExpression result is in the top N of all records processed.
TopPercent | Displays the record if the FilterExpression result is in the top N% of all records processed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.FilterOperator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


FontStyle Enumeration

[image]
ActiveReports 19 .NET Edition
FontStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FontStyle Enumeration

Glossary Item Box

Specifies a font style.

Syntax

Visual Basic (Declaration)
Public Enum FontStyle
   Inherits System.Enum
C#
public enum FontStyle : System.Enum

Members

Member | Description
Italic | Indicates Italicised text.
Normal | Indicates normal text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.FontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


FontWeight Enumeration

[image]
ActiveReports 19 .NET Edition
FontWeight Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FontWeight Enumeration

Glossary Item Box

Specifies a thickness of the font.

Syntax

Visual Basic (Declaration)
Public Enum FontWeight
   Inherits System.Enum
C#
public enum FontWeight : System.Enum

Members

Member | Description
Bold | Indicates a bold font weight.
Bolder | Indicates a bolder font weight.
ExtraBold | Indicates an extra bold font weight.
ExtraLight | Indicates an extra light font weight
Heavy | Indicates a heavy font weight.
Light | Indicates a light font weight
Lighter | Indicates a lighter font weight
Medium | Indicates a medium font weight.
Normal | Indicates a normal font weight.
SemiBold | Indicates a semi-bold font weight.
Thin | Indicates a thin font weight

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.FontWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


GrowDirection Enumeration

[image]
ActiveReports 19 .NET Edition
GrowDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GrowDirection Enumeration

Glossary Item Box

Specifies the layout direction for List report item.

Syntax

Visual Basic (Declaration)
Public Enum GrowDirection
   Inherits System.Enum
C#
public enum GrowDirection : System.Enum

Members

Member | Description
Column | List are laid out in a column, from top to bottom.
ColumnReverse | List are laid out in a column, from bottom to top.
Row | List are laid out in a row, from left to right.
RowReverse | List are laid out in a row, from right to left.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.GrowDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


HorizontalAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HorizontalAlignment Enumeration

Glossary Item Box

Specifies the vertical alignment of the picture.

Syntax

Visual Basic (Declaration)
Public Enum HorizontalAlignment
   Inherits System.Enum
C#
public enum HorizontalAlignment : System.Enum

Members

Member | Description
Center | Indicates align to the center.
Left | Indicates align to the left.
Right | Indicates align to the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.HorizontalAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ImageSizing Enumeration

[image]
ActiveReports 19 .NET Edition
ImageSizing Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ImageSizing Enumeration

Glossary Item Box

Specifies how an image should be sized within the image report control area.

Syntax

Visual Basic (Declaration)
Public Enum ImageSizing
   Inherits System.Enum
C#
public enum ImageSizing : System.Enum

Members

Member | Description
AutoSize | Indicates that the image report control should expand or shrink to fit the size of the image.
Clip | Indicates that the image should be clipped to fit within the dimensions of the image report control, potentially losing parts of the image.
Fit | Indicates that the image should be resized to fit within the dimensions of the image report control, potentially distorting the image's aspect ratio.
FitProportional | Indicates that the image should be resized to fit within the dimensions of the image report control while maintaining the image's original aspect ratio.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ImageSizing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ImageSource Enumeration

[image]
ActiveReports 19 .NET Edition
ImageSource Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ImageSource Enumeration

Glossary Item Box

Specifies a source of the image.

Syntax

Visual Basic (Declaration)
Public Enum ImageSource
   Inherits System.Enum
C#
public enum ImageSource : System.Enum

Members

Member | Description
Database | Database image source.
Embedded | Embedded image source.
External | External image source.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ImageSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ItemOwners Enumeration

[image]
ActiveReports 19 .NET Edition
ItemOwners Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemOwners Enumeration

Glossary Item Box

Specifies the report component owner when master report is defined for child report.

Syntax

Visual Basic (Declaration)
Public Enum ItemOwners
   Inherits System.Enum
C#
public enum ItemOwners : System.Enum

Members

Member | Description
Child | Item was contributed by the child report.
Master | Item was inferred from the master report.
None | Unknow/not applicable.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ItemOwners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


KanatypeSensitivity Enumeration

[image]
ActiveReports 19 .NET Edition
KanatypeSensitivity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : KanatypeSensitivity Enumeration

Glossary Item Box

Specifies whether the data is Kanatype sensitive. (Used with the Japanese language to distinguish between hiragana and katakana.)

Syntax

Visual Basic (Declaration)
Public Enum KanatypeSensitivity
   Inherits System.Enum
C#
public enum KanatypeSensitivity : System.Enum

Members

Member | Description
Auto | The Kanatype sensitivity setting is derived by querying the data provider.
False | There is no distinction between hiragana and katakana.
True | There is a distinction between hiragana and katakana.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.KanatypeSensitivity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


KeepWithGroup Enumeration

[image]
ActiveReports 19 .NET Edition
KeepWithGroup Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : KeepWithGroup Enumeration

Glossary Item Box

Specifies the values of the KeepWithGroup property.

Syntax

Visual Basic (Declaration)
Public Enum KeepWithGroup
   Inherits System.Enum
C#
public enum KeepWithGroup : System.Enum

Members

Member | Description
After | Keep after group.
Before | Keep before group.
None | Do not keep with group.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.KeepWithGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


LayoutDirection Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayoutDirection Enumeration

Glossary Item Box

Specifies the overall direction of the layout.

Syntax

Visual Basic (Declaration)
Public Enum LayoutDirection
   Inherits System.Enum
C#
public enum LayoutDirection : System.Enum

Members

Member | Description
Ltr | Dynamic columns grow left-to-right with headers on the left.
Rtl | Dynamic columns grow right-to-left with headers on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.LayoutDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


LegendLayout Enumeration

[image]
ActiveReports 19 .NET Edition
LegendLayout Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LegendLayout Enumeration

Glossary Item Box

Specifies the arrangement of labels within the legend.

Syntax

Visual Basic (Declaration)
Public Enum LegendLayout
   Inherits System.Enum
C#
public enum LegendLayout : System.Enum

Members

Member | Description
Column | Indicates that the labels are arranged in a single column.
Row | Indicates that the labels are arranged in a single row.
Table | Indicates that the labels are arranged in a table with as many rows and columns as required.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.LegendLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


LegendPosition Enumeration

[image]
ActiveReports 19 .NET Edition
LegendPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LegendPosition Enumeration

Glossary Item Box

Specifies the position of the legend.

Syntax

Visual Basic (Declaration)
Public Enum LegendPosition
   Inherits System.Enum
C#
public enum LegendPosition : System.Enum

Members

Member | Description
BottomCenter | Indicates that the legend is positioned below the chart at the center.
BottomLeft | Indicates that the legend is positioned below the chart on the left.
BottomRight | Indicates that the legend is positioned below the chart on the right.
LeftBottom | Indicates that the legend is positioned to the left of the chart at the bottom.
LeftCenter | Indicates that the legend is positioned to the left of the chart at the center.
LeftTop | Indicates that the legend is positioned to the left of the chart at the top.
RightBottom | Indicates that the legend is positioned to the right of the chart at the bottom.
RightCenter | Indicates that the legend is positioned to the right of the chart at the center.
RightTop | Indicates that the legend is positioned to the right of the chart at the top.
TopCenter | Indicates that the legend is positioned above the chart at the center.
TopLeft | Indicates that the legend is positioned above the chart on the left.
TopRight | Indicates that the legend is positioned above the chart on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.LegendPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Length.Unit Enumeration

[image]
ActiveReports 19 .NET Edition
Length.Unit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length.Unit Enumeration

Glossary Item Box

Specifies the unit of measurement for a length value.

Syntax

Visual Basic (Declaration)
Public Enum Length.Unit
   Inherits System.Enum
C#
public enum Length.Unit : System.Enum

Members

Member | Description
Centimeters | Centimeters unit.
Inches | Inches unit.
Millimeters | Millimeters unit.
Picas | Picas unit.
Points | Points unit.
Unknown | Unknown unit.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Length.Unit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin.BorderSkinType Enumeration

[image]
ActiveReports 19 .NET Edition
MapBorderSkin.BorderSkinType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin.BorderSkinType Enumeration

Glossary Item Box

Border skin type for the map

Syntax

Visual Basic (Declaration)
Public Enum MapBorderSkin.BorderSkinType
   Inherits System.Enum
C#
public enum MapBorderSkin.BorderSkinType : System.Enum

Members

Member | Description
Emboss | Use Emboss border skin
FrameThin1 | Use FrameThin1 border skin
FrameThin2 | Use FrameThin2 border skin
FrameThin3 | Use FrameThin3 border skin
FrameThin4 | Use FrameThin4 border skin
FrameThin5 | Use FrameThin5 border skin
FrameThin6 | Use FrameThin6 border skin
FrameTitle1 | Use FrameTitle1 border skin
FrameTitle2 | Use FrameTitle2 border skin
FrameTitle3 | Use FrameTitle3 border skin
FrameTitle4 | Use FrameTitle4 border skin
FrameTitle5 | Use FrameTitle5 border skin
FrameTitle6 | Use FrameTitle6 border skin
FrameTitle7 | Use FrameTitle7 border skin
FrameTitle8 | Use FrameTitle8 border skin
None | No border skin
Raised | Use Raised border skin
Sunken | Use Sunken border skin

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapBorderSkin.BorderSkinType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPalette Enumeration

[image]
ActiveReports 19 .NET Edition
MapColorPalette Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPalette Enumeration

Glossary Item Box

Indicates the palette to be used for coloring the spatial elements.

Syntax

Visual Basic (Declaration)
Public Enum MapColorPalette
   Inherits System.Enum
C#
public enum MapColorPalette : System.Enum

Members

Member | Description
BrightPastel | Use BrightPastel palette
Light | Use Light palette
Random | Use Random palette
SemiTransparent | Use SemiTransparent palette

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorPalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.MapLabelBehavior Enumeration

[image]
ActiveReports 19 .NET Edition
MapColorScale.MapLabelBehavior Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.MapLabelBehavior Enumeration

Glossary Item Box

Indicates the positioning of the color scale labels.

Syntax

Visual Basic (Declaration)
Public Enum MapColorScale.MapLabelBehavior
   Inherits System.Enum
C#
public enum MapColorScale.MapLabelBehavior : System.Enum

Members

Member | Description
Auto | Automatically determined
ShowBorderValue | Labels are displayed at the borders between color divisions.
ShowMiddleValue | Labels are displayed in the middle of each color division.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorScale.MapLabelBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.MapLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapColorScale.MapLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.MapLabelPlacement Enumeration

Glossary Item Box

Indicates the labels placement along the color bar.

Syntax

Visual Basic (Declaration)
Public Enum MapColorScale.MapLabelPlacement
   Inherits System.Enum
C#
public enum MapColorScale.MapLabelPlacement : System.Enum

Members

Member | Description
Alternate | Odd labels are below the color bar and even ones are above.
Bottom | Labels are positioned below the color bar.
Top | Labels are positioned above the color bar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorScale.MapLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapCoordinateSystem Enumeration

[image]
ActiveReports 19 .NET Edition
MapCoordinateSystem Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCoordinateSystem Enumeration

Glossary Item Box

The map coordinate system.

Syntax

Visual Basic (Declaration)
Public Enum MapCoordinateSystem
   Inherits System.Enum
C#
public enum MapCoordinateSystem : System.Enum

Members

Member | Description
Geographic | Geographic coordinate system (longitude and latitude).
Planar | Planar coordinate system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapCoordinateSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapDataType Enumeration

[image]
ActiveReports 19 .NET Edition
MapDataType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataType Enumeration

Glossary Item Box

The data type of the field.

Syntax

Visual Basic (Declaration)
Public Enum MapDataType
   Inherits System.Enum
C#
public enum MapDataType : System.Enum

Members

Member | Description
Boolean | Field values are Boolean
DateTime | Fields values are DateTime
Decimal | Fields values are Decimal
Float | Fields values are Float
Integer | Fields values are Integer
String | Fields values are String

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapDataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem.MapPosition Enumeration

[image]
ActiveReports 19 .NET Edition
MapDockableSubItem.MapPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem.MapPosition Enumeration

Glossary Item Box

The position of the sub item.

Syntax

Visual Basic (Declaration)
Public Enum MapDockableSubItem.MapPosition
   Inherits System.Enum
C#
public enum MapDockableSubItem.MapPosition : System.Enum

Members

Member | Description
BottomCenter | Position title at BottomCenter
BottomLeft | Position title at BottomLeft
BottomRight | Position title at BottomRight
LeftBottom | Position title at LeftBottom
LeftCenter | Position title at LeftCenter
LeftTop | Position title at LeftTop
RightBottom | Position title at RightBottom
RightCenter | Position title at RightCenter
RightTop | Position title at RightTop
TopCenter | Position title at TopCenter
TopLeft | Position title at TopLeft
TopRight | Position title at TopRight

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem.MapPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines.LabelPositionType Enumeration

[image]
ActiveReports 19 .NET Edition
MapGridLines.LabelPositionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines.LabelPositionType Enumeration

Glossary Item Box

Defines the position for grid labels.

Syntax

Visual Basic (Declaration)
Public Enum MapGridLines.LabelPositionType
   Inherits System.Enum
C#
public enum MapGridLines.LabelPositionType : System.Enum

Members

Member | Description
Center | Labels are centered.
Far | Labels are on the right for parallels and on bottom for meridians.
Near | Labels are on the left for parallels and on top for meridians.
OneQuarter | Labels are between the left and center for parallels and between top and center for meridians.
ThreeQuarters | Labels are between the center and right for parallels and between center and bottom for meridians.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapGridLines.LabelPositionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle.LegendTitleSeparator Enumeration

[image]
ActiveReports 19 .NET Edition
MapLegendTitle.LegendTitleSeparator Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle.LegendTitleSeparator Enumeration

Glossary Item Box

Indicates what type of separator to use for the legend title.

Syntax

Visual Basic (Declaration)
Public Enum MapLegendTitle.LegendTitleSeparator
   Inherits System.Enum
C#
public enum MapLegendTitle.LegendTitleSeparator : System.Enum

Members

Member | Description
DashLine | Separate with DashLine
DotLine | Separate with DotLine
DoubleLine | Separate with DoubleLine
GradientLine | Separate with GradientLine
Line | Separate with Line
None | No separator
ThickGradientLine | Separate with ThickGradientLine
ThickLine | Separate with ThickLine

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle.LegendTitleSeparator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate.LineLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapLineTemplate.LineLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate.LineLabelPlacement Enumeration

Glossary Item Box

Defines the label placement for the line.

Syntax

Visual Basic (Declaration)
Public Enum MapLineTemplate.LineLabelPlacement
   Inherits System.Enum
C#
public enum MapLineTemplate.LineLabelPlacement : System.Enum

Members

Member | Description
Above | Label placed above.
Below | Label placed below.
Center | Label placed to the center.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate.LineLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker.MarkerStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MapMarker.MarkerStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker.MarkerStyle Enumeration

Glossary Item Box

Defines the point marker.

Syntax

Visual Basic (Declaration)
Public Enum MapMarker.MarkerStyle
   Inherits System.Enum
C#
public enum MapMarker.MarkerStyle : System.Enum

Members

Member | Description
Circle | Circle marker
Diamond | Diamond marker
Image | Image marker
None | Default
Pentagon | Pentagon marker
PushPin | Push Pin marker
Rectangle | Rectangle marker
Star | Star marker
Trapezoid | Trapezoid marker
Triangle | Triangle marker
Wedge | Wedge marker

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapMarker.MarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage.ImageResizeMode Enumeration

[image]
ActiveReports 19 .NET Edition
MapMarkerImage.ImageResizeMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage.ImageResizeMode Enumeration

Glossary Item Box

Indicates whether the content will resize to fit in the available space.

Syntax

Visual Basic (Declaration)
Public Enum MapMarkerImage.ImageResizeMode
   Inherits System.Enum
C#
public enum MapMarkerImage.ImageResizeMode : System.Enum

Members

Member | Description
AutoFit | Fits the available size.
None | No fitting.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage.ImageResizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate.MapPointLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapPointTemplate.MapPointLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate.MapPointLabelPlacement Enumeration

Glossary Item Box

Defines the label placement for the point.

Syntax

Visual Basic (Declaration)
Public Enum MapPointTemplate.MapPointLabelPlacement
   Inherits System.Enum
C#
public enum MapPointTemplate.MapPointLabelPlacement : System.Enum

Members

Member | Description
Bottom | Label placed to the bottom.
Center | Label placed to the center.
Left | Label placed to the left.
Right | Label placed to the right.
Top | Label placed to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate.MapPointLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.PolygonLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate.PolygonLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.PolygonLabelPlacement Enumeration

Glossary Item Box

Indicates the label placement of the polygon

Syntax

Visual Basic (Declaration)
Public Enum MapPolygonTemplate.PolygonLabelPlacement
   Inherits System.Enum
C#
public enum MapPolygonTemplate.PolygonLabelPlacement : System.Enum

Members

Member | Description
BottomCenter | Label placed to the bottom center.
BottomLeft | Label placed to the bottom left.
BottomRight | Label placed to the bottom right.
MiddleCenter | Label placed to the middle center.
MiddleLeft | Label placed to the middle left.
MiddleRight | Label placed to the middle right.
TopCenter | Label placed to the top center.
TopLeft | Label placed to the top left.
TopRight | Label placed to the top right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate.PolygonLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.PolygonShowLabel Enumeration

[image]
ActiveReports 19 .NET Edition
MapPolygonTemplate.PolygonShowLabel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.PolygonShowLabel Enumeration

Glossary Item Box

Indicates if the label should be shown.

Syntax

Visual Basic (Declaration)
Public Enum MapPolygonTemplate.PolygonShowLabel
   Inherits System.Enum
C#
public enum MapPolygonTemplate.PolygonShowLabel : System.Enum

Members

Member | Description
Auto | Default
False | Always Hide
True | Always Show

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate.PolygonShowLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapProjection Enumeration

[image]
ActiveReports 19 .NET Edition
MapProjection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapProjection Enumeration

Glossary Item Box

The map projection.

Syntax

Visual Basic (Declaration)
Public Enum MapProjection
   Inherits System.Enum
C#
public enum MapProjection : System.Enum

Members

Member | Description
Bonne | Bonne projection
Eckert1 | Eckert1 projection
Eckert3 | Eckert3 projection
Equirectangular | Equirectangular projection
Fahey | Fahey projection
HammerAitoff | HammerAitoff projection
Mercator | Mercator projection
Robinson | Robinson projection
Wagner3 | Wagner3 projection

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapProjection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapRuleDistributionType Enumeration

[image]
ActiveReports 19 .NET Edition
MapRuleDistributionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapRuleDistributionType Enumeration

Glossary Item Box

Indicates the distribution type.

Syntax

Visual Basic (Declaration)
Public Enum MapRuleDistributionType
   Inherits System.Enum
C#
public enum MapRuleDistributionType : System.Enum

Members

Member | Description
Custom | Custom Distribution
EqualDistribution | Equal Distribution
EqualInterval | Equal Interval
Optimal | Optimal Distribution

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapRuleDistributionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer.MapTileStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MapTileLayer.MapTileStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer.MapTileStyle Enumeration

Glossary Item Box

Indicates the tiles style.

Syntax

Visual Basic (Declaration)
Public Enum MapTileLayer.MapTileStyle
   Inherits System.Enum
C#
public enum MapTileLayer.MapTileStyle : System.Enum

Members

Member | Description
Aerial | Tiles containing aerial imagery of the earth.
Hybrid | Tiles containing aerial imagery of borders and roads.
Road | Tiles containing roads and streets.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapTileLayer.MapTileStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapUnit Enumeration

[image]
ActiveReports 19 .NET Edition
MapUnit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapUnit Enumeration

Glossary Item Box

Defines the unit for both width and height.

Syntax

Visual Basic (Declaration)
Public Enum MapUnit
   Inherits System.Enum
C#
public enum MapUnit : System.Enum

Members

Member | Description
Centimeter | Unit is Centimeter
Inch | Unit is Inch
Millimeter | Unit is Millimeter
Percentage | Unit is percentage of the containing object’s width/height.
Pica | Unit is Pica (12 Points)
Point | Unit is Point

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapVisibilityMode Enumeration

[image]
ActiveReports 19 .NET Edition
MapVisibilityMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVisibilityMode Enumeration

Glossary Item Box

Indicates the layer visibility mode.

Syntax

Visual Basic (Declaration)
Public Enum MapVisibilityMode
   Inherits System.Enum
C#
public enum MapVisibilityMode : System.Enum

Members

Member | Description
Hidden | Layer is hidden
Visible | Layer is Shown
ZoomBased | Layer is shown within a zoom level range defined by MapLayer.MinimumZoom MapLayer.MaximumZoom

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapVisibilityMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MarkerType Enumeration

[image]
ActiveReports 19 .NET Edition
MarkerType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MarkerType Enumeration

Glossary Item Box

Specifies the type of marker to use with chart data.

Syntax

Visual Basic (Declaration)
Public Enum MarkerType
   Inherits System.Enum
C#
public enum MarkerType : System.Enum

Members

Member | Description
Auto | Indicates that a marker shape is chosen automatically.
Circle | Indicates a round marker.
Cross | Indicates a cross-shaped marker.
Diamond | Indicates a diamond-shaped marker.
None | Indicates no marker.
Square | Indicates a square marker.
Triangle | Indicates a triangular marker.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MarkerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MergePolicy Enumeration

[image]
ActiveReports 19 .NET Edition
MergePolicy Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MergePolicy Enumeration

Glossary Item Box

Specifies a merging policy of the table cells.

Syntax

Visual Basic (Declaration)
Public Enum MergePolicy
   Inherits System.Enum
C#
public enum MergePolicy : System.Enum

Members

Member | Description
Always | Cells are always merged.
Never | Cells are never merged.
Restricted | Cells are merged based on certain restrictions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MergePolicy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


NameType Enumeration

[image]
ActiveReports 19 .NET Edition
NameType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameType Enumeration

Glossary Item Box

Specifies the type of object the name belongs to.

Syntax

Visual Basic (Declaration)
Public Enum NameType
   Inherits System.Enum
C#
public enum NameType : System.Enum

Members

Member | Description
Control | The name belongs to a control.
DataRegion | The name belongs to a DataRegion.
DataSet | The name belongs to a DataSet.
Grouping | The name belongs to a Grouping.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.NameType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


NumberingStyle Enumeration

[image]
ActiveReports 19 .NET Edition
NumberingStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NumberingStyle Enumeration

Glossary Item Box

Specifies the numbering style for headings.

Syntax

Visual Basic (Declaration)
Public Enum NumberingStyle
   Inherits System.Enum
C#
public enum NumberingStyle : System.Enum

Members

Member | Description
CircledNumber | The upper circled number numbering style.
Decimal | The decimal numbering style.
DecimalLeadingZero | The decimal numbering style with leading zero .
Georgian | The georgian numbering style.
Katakana | The upper katakana numbering style.
KatakanaBrackets | The upper katakana brackets numbering style.
KatakanaIroha | The upper katakana iroha numbering style.
KatakanaIrohaBrackets | The upper katakana iroha brackets numbering style.
KatakanaIrohaLower | The upper katakana iroha lower numbering style.
KatakanaLower | The upper katakana lower numbering style.
LowerArmenian | The lower armenian numbering style.
LowerGreek | The lower greek numbering style.
LowerLatin | The lower latin numbering style.
LowerRoman | The lower roman numbering style.
None | No numbering.
UpperArmenian | The upper armenian numbering style.
UpperGreek | The upper greek numbering style.
UpperLatin | The upper latin numbering style.
UpperRoman | The upper roman numbering style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.NumberingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


OrderByCondition Enumeration

[image]
ActiveReports 19 .NET Edition
OrderByCondition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderByCondition Enumeration

Glossary Item Box

Specifies whether items are ordered by labels, values or none.

Syntax

Visual Basic (Declaration)
Public Enum OrderByCondition
   Inherits System.Enum
C#
public enum OrderByCondition : System.Enum

Members

Member | Description
Label | Items are sorted by labels.
None | Items are not specifically sorted.
Value | Items are sorted by values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.OrderByCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


OrderByDirection Enumeration

[image]
ActiveReports 19 .NET Edition
OrderByDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OrderByDirection Enumeration

Glossary Item Box

Specifies whether items are ordered in ascending or descending order.

Syntax

Visual Basic (Declaration)
Public Enum OrderByDirection
   Inherits System.Enum
C#
public enum OrderByDirection : System.Enum

Members

Member | Description
Ascending | Items are sorted in ascending order.
Descending | Items are sorted in descending order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.OrderByDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Overflow Enumeration

[image]
ActiveReports 19 .NET Edition
Overflow Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Overflow Enumeration

Glossary Item Box

Specifies and overflow behavior for Container report item.

Syntax

Visual Basic (Declaration)
Public Enum Overflow
   Inherits System.Enum
C#
public enum Overflow : System.Enum

Members

Member | Description
Auto | The action value is depends on report type. For the dashboards the auto equals to 'Scroll'.
Clip | Content is clipped on overflow.
Grow | Container grows with content.
Hidden | Content is clipped on overflow.
Scroll | Scrollbar is automatically added to scroll the content.
Visible | Content is not clipped on overflow.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Overflow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


PagesLayoutOrder Enumeration

[image]
ActiveReports 19 .NET Edition
PagesLayoutOrder Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PagesLayoutOrder Enumeration

Glossary Item Box

Specifies the layout order of pages in a report.

Syntax

Visual Basic (Declaration)
Public Enum PagesLayoutOrder
   Inherits System.Enum
C#
public enum PagesLayoutOrder : System.Enum

Members

Member | Description
NOrder | Pages are laid out in 'N' order.
ZOrder | Pages are laid out in 'Z' order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.PagesLayoutOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Pagination Enumeration

[image]
ActiveReports 19 .NET Edition
Pagination Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Pagination Enumeration

Glossary Item Box

Specifies the pagination options for report rendering.

Syntax

Visual Basic (Declaration)
Public Enum Pagination
   Inherits System.Enum
C#
public enum Pagination : System.Enum

Members

Member | Description
AutoHeight | Automatically adjusts the report height to fit content, ignoring the Report.PageHeight property.
Standard | Standard pagination based on the Report.PageHeight property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Pagination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


PaperOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
PaperOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PaperOrientation Enumeration

Glossary Item Box

Specifies the orientation options for paper size.

Syntax

Visual Basic (Declaration)
Public Enum PaperOrientation
   Inherits System.Enum
C#
public enum PaperOrientation : System.Enum

Members

Member | Description
Landscape | Landscape orientation.
Portrait | Portrait orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.PaperOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Position Enumeration

[image]
ActiveReports 19 .NET Edition
Position Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Position Enumeration

Glossary Item Box

Specifies the position of a data label.

Syntax

Visual Basic (Declaration)
Public Enum Position
   Inherits System.Enum
C#
public enum Position : System.Enum

Members

Member | Description
Auto | Indicates that the data label position is automatically determined.
Bottom | Indicates that the data label is at the bottom.
BottomLeft | Indicates that the data label is at the bottom left.
BottomRight | Indicates that the data label is at the bottom right.
Center | Indicates that the data label is at the center.
Left | Indicates that the data label is at the left.
Right | Indicates that the data label is at the right.
Top | Indicates that the data label is at the top.
TopLeft | Indicates that the data label is at the top left.
TopRight | Indicates that the data label is at the top right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


QueryCommandType Enumeration

[image]
ActiveReports 19 .NET Edition
QueryCommandType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryCommandType Enumeration

Glossary Item Box

Specifies a type of query contained in the Query.CommandText property.

Syntax

Visual Basic (Declaration)
Public Enum QueryCommandType
   Inherits System.Enum
C#
public enum QueryCommandType : System.Enum

Members

Member | Description
StoredProcedure | Indicates that the value of the CommandText is the name of a stored procedure to execute. The stored procedure must return a single result set.
TableDirect | Indicates that the value of the CommandText is the name of a table from which to retrieve data. All data from the table is returned.
Text | Indicates that the value of the CommandText is a text string to pass to the data source, for example, a Transact-SQL query.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.QueryCommandType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


RepeatBlankRows Enumeration

[image]
ActiveReports 19 .NET Edition
RepeatBlankRows Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RepeatBlankRows Enumeration

Glossary Item Box

Specifies a type of filling with blank rows.

Syntax

Visual Basic (Declaration)
Public Enum RepeatBlankRows
   Inherits System.Enum
C#
public enum RepeatBlankRows : System.Enum

Members

Member | Description
FillGroup | Indicates filling within a group.
FillPage | Indicates filling within a page.
None | Indicates no filling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.RepeatBlankRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportDefinitionException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
ReportDefinitionException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportDefinitionException.ErrorCodes Enumeration

Glossary Item Box

Specifies error codes for report definition exceptions.

Syntax

Visual Basic (Declaration)
Public Enum ReportDefinitionException.ErrorCodes
   Inherits System.Enum
C#
public enum ReportDefinitionException.ErrorCodes : System.Enum

Members

Member | Description
ContentReportNonUniqReportItemName | The content report has non-unique item names causing a conflict with the master report.
InvalidIntegerRange | The integer value specified is out of the valid range.
InvalidLengthUnitRange | The length unit specified is out of the valid range.
PostiveNonZeroValueRequired | The value specified must be positive and non-zero.
UnableToReadTheme | The theme file is not a valid XML document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterDataType Enumeration

[image]
ActiveReports 19 .NET Edition
ReportParameterDataType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterDataType Enumeration

Glossary Item Box

Specifies a data type for the parameter.

Syntax

Visual Basic (Declaration)
Public Enum ReportParameterDataType
   Inherits System.Enum
C#
public enum ReportParameterDataType : System.Enum

Members

Member | Description
Boolean | The data type is Boolean.
DateTime | The data type is date/time.
Float | The data type is float.
Integer | The data type is integer.
String | The data type is string.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportParameterDataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterUsedInQuery Enumeration

[image]
ActiveReports 19 .NET Edition
ReportParameterUsedInQuery Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterUsedInQuery Enumeration

Glossary Item Box

Specifies whether the parameter is used in a query in the report. This evaluates to True if the parameter is referenced in any query value expression.

Syntax

Visual Basic (Declaration)
Public Enum ReportParameterUsedInQuery
   Inherits System.Enum
C#
public enum ReportParameterUsedInQuery : System.Enum

Members

Member | Description
Auto | Indicates that the setting is automatically detected.
False | The parameter is not used in a query.
True | The parameter is used in a query.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportParameterUsedInQuery

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartPropertyType Enumeration

[image]
ActiveReports 19 .NET Edition
ReportPartPropertyType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartPropertyType Enumeration

Glossary Item Box

Specifies an available report part property types.

Syntax

Visual Basic (Declaration)
Public Enum ReportPartPropertyType
   Inherits System.Enum
C#
public enum ReportPartPropertyType : System.Enum

Members

Member | Description
Boolean | The data type is Boolean.
BorderStyle | The data type is borderStyle.
Color | The data type is color.
Float | The data type is float.
FontFamily | The data type is fontFamily.
FontSize | The data type is fontSize.
FontStyle | The data type is fontStyle.
FontWeight | The data type is fontWeight.
Integer | The data type is integer.
Length | The data type is length.
LineStyle | The data type is lineStyle.
LineWidth | The data type is lineWidth.
String | The data type is string.
TextDecoration | The data type is textDecoration.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportPartPropertyType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportPartSizeMode Enumeration

[image]
ActiveReports 19 .NET Edition
ReportPartSizeMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportPartSizeMode Enumeration

Glossary Item Box

Specifies a size mode of a report part.

Syntax

Visual Basic (Declaration)
Public Enum ReportPartSizeMode
   Inherits System.Enum
C#
public enum ReportPartSizeMode : System.Enum

Members

Member | Description
Fixed | The item size is defined by the library.
Resizable | The size of the item will be overridden by the part item.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportPartSizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ResizeModes Enumeration

[image]
ActiveReports 19 .NET Edition
ResizeModes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ResizeModes Enumeration

Glossary Item Box

Used in Map's and Gauge's objects.

Syntax

Visual Basic (Declaration)
Public Enum ResizeModes
   Inherits System.Enum
C#
public enum ResizeModes : System.Enum

Members

Member | Description
AutoFit | AutoFit resize mode.
None | None resize mode

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ResizeModes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Severity Enumeration

[image]
ActiveReports 19 .NET Edition
Severity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Severity Enumeration

Glossary Item Box

Specifies the severity level of a ValidationEntry object.

Syntax

Visual Basic (Declaration)
Public Enum Severity
   Inherits System.Enum
C#
public enum Severity : System.Enum

Members

Member | Description
Error | Indicates that the report cannot be processed until the error is corrected.
Information | Indicates that the entry is for informational purposes only.
Warning | Indicates that the report should be able to execute but may have unexpected results.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Severity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ShapeStyle Enumeration

[image]
ActiveReports 19 .NET Edition
ShapeStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ShapeStyle Enumeration

Glossary Item Box

Specifies the style of a shape.

Syntax

Visual Basic (Declaration)
Public Enum ShapeStyle
   Inherits System.Enum
C#
public enum ShapeStyle : System.Enum

Members

Member | Description
Ellipse | An elliptical shape.
Rectangle | A rectangular shape.
RoundRect | A rounded rectangle shape.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ShapeStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


SliceType Enumeration

[image]
ActiveReports 19 .NET Edition
SliceType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SliceType Enumeration

Glossary Item Box

Specifies the types of slice actions.

Syntax

Visual Basic (Declaration)
Public Enum SliceType
   Inherits System.Enum
C#
public enum SliceType : System.Enum

Members

Member | Description
Reset | Resets the slicer to its initial (default) value. See ReportSlicer.DefaultValue.
Set | Sets the slicer value.
Toggle | Toggles the value in a multi-value slicer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.SliceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


SortByDirection Enumeration

[image]
ActiveReports 19 .NET Edition
SortByDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByDirection Enumeration

Glossary Item Box

Specifies whether items are sorted in ascending or descending order.

Syntax

Visual Basic (Declaration)
Public Enum SortByDirection
   Inherits System.Enum
C#
public enum SortByDirection : System.Enum

Members

Member | Description
Ascending | Items are sorted in ascending order.
Descending | Items are sorted in descending order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.SortByDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


StartNewPage Enumeration

[image]
ActiveReports 19 .NET Edition
StartNewPage Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StartNewPage Enumeration

Glossary Item Box

Specifies where the content should continue after page break.

Syntax

Visual Basic (Declaration)
Public Enum StartNewPage
   Inherits System.Enum
C#
public enum StartNewPage : System.Enum

Members

Member | Description
Even | Place content to even page.
Next | Place content to next page.
Odd | Place content to odd page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.StartNewPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheetSource Enumeration

[image]
ActiveReports 19 .NET Edition
StyleSheetSource Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheetSource Enumeration

Glossary Item Box

Specifies the sources of stylesheet.

Syntax

Visual Basic (Declaration)
Public Enum StyleSheetSource
   Inherits System.Enum
C#
public enum StyleSheetSource : System.Enum

Members

Member | Description
Embedded | Embedded stylesheet source.
External | External stylesheet source.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.StyleSheetSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


StyleType Enumeration

[image]
ActiveReports 19 .NET Edition
StyleType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleType Enumeration

Glossary Item Box

Specifies of style types.

Syntax

Visual Basic (Declaration)
Public Enum StyleType
   Inherits System.Enum
C#
public enum StyleType : System.Enum

Members

Member | Description
Common | Common style type.
TableOfContent | TOC style type
TableOfContentLevel | TOC level style type
Text | Text style type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.StyleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


SubtotalPosition Enumeration

[image]
ActiveReports 19 .NET Edition
SubtotalPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SubtotalPosition Enumeration

Glossary Item Box

Specifies whether the subtotal rows or columns appear before or after the detail rows or columns.

Syntax

Visual Basic (Declaration)
Public Enum SubtotalPosition
   Inherits System.Enum
C#
public enum SubtotalPosition : System.Enum

Members

Member | Description
After | Subtotal column or row appears after the detail columns or rows.
Before | Subtotal column or row appears before the detail columns or rows.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.SubtotalPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TargetDeviceKind Enumeration

[image]
ActiveReports 19 .NET Edition
TargetDeviceKind Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TargetDeviceKind Enumeration

Glossary Item Box

Specifies the possible target devices for layer.

Syntax

Visual Basic (Declaration)
Public Enum TargetDeviceKind
   Inherits System.Enum
C#
public enum TargetDeviceKind : System.Enum

Members

Member | Description
All | Allows to output to Screen, Paper and Export target devices
Export | Allows to output to Export target device
None | Forbids to output to any target device
Paper | Allows to output to Paper target device
Screen | Allows to output to Screen target device

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TargetDeviceKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TargetDevices Enumeration

[image]
ActiveReports 19 .NET Edition
TargetDevices Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TargetDevices Enumeration

Glossary Item Box

Specifies the possible target devices for layer.

Syntax

Visual Basic (Declaration)
Public Enum TargetDevices
   Inherits System.Enum
C#
public enum TargetDevices : System.Enum

Members

Member | Description
All | Allows to output to Screen, Paper and Export target devices
Export | Allows to output to Export target device
None | Forbids to output to any target device
Paper | Allows to output to Paper target device
Screen | Allows to output to Screen target device

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TargetDevices

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextAlign Enumeration

[image]
ActiveReports 19 .NET Edition
TextAlign Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextAlign Enumeration

Glossary Item Box

Specifies a horizontal alignment of the text

Syntax

Visual Basic (Declaration)
Public Enum TextAlign
   Inherits System.Enum
C#
public enum TextAlign : System.Enum

Members

Member | Description
Center | Indicates align centered.
General | Indicates aligment will be based off of the content type.
Justify | Indicates justified align.
Left | Indicates align to the left.
Right | Indicates align to the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextAntiAliasingQuality Enumeration

[image]
ActiveReports 19 .NET Edition
TextAntiAliasingQuality Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextAntiAliasingQuality Enumeration

Glossary Item Box

Specifies a quality of text anti-aliasing.

Syntax

Visual Basic (Declaration)
Public Enum TextAntiAliasingQuality
   Inherits System.Enum
C#
public enum TextAntiAliasingQuality : System.Enum

Members

Member | Description
High | The high quality anti-aliasing.
Normal | The normal quality anti-aliasing.
SystemDefault | The system default anti-aliasing.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextAntiAliasingQuality

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextDecoration Enumeration

[image]
ActiveReports 19 .NET Edition
TextDecoration Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextDecoration Enumeration

Glossary Item Box

Specifies a special text formatting.

Syntax

Visual Basic (Declaration)
Public Enum TextDecoration
   Inherits System.Enum
C#
public enum TextDecoration : System.Enum

Members

Member | Description
DoubleUnderline | Indicates double underlined text.
LineThrough | Indicates struck out text.
None | Indicates no speical formatting.
Overline | Indicates overlined text.
Underline | Indicates underlined text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextDecoration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextJustify Enumeration

[image]
ActiveReports 19 .NET Edition
TextJustify Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextJustify Enumeration

Glossary Item Box

Specifies the justification of the text within a container.

Syntax

Visual Basic (Declaration)
Public Enum TextJustify
   Inherits System.Enum
C#
public enum TextJustify : System.Enum

Members

Member | Description
Auto | Automatically determines the justification based on context.
Distribute | Distributes the text evenly across the line, adjusting the spacing between words.
DistributeAllLines | Distributes the text evenly across all lines, including the last line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesDrawingStyle Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesDrawingStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesDrawingStyle Enumeration

Glossary Item Box

Specifies a shape of the columns or bars in a three-dimensional chart. ThreeDPropertiesDrawingStyle only applies to bar and column charts.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesDrawingStyle
   Inherits System.Enum
C#
public enum ThreeDPropertiesDrawingStyle : System.Enum

Members

Member | Description
Cube | Indicates that the column or bar is drawn as a cube.
Cylinder | Indicates that the column or bar is drawn as a cylinder.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesDrawingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesProjectionMode Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesProjectionMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesProjectionMode Enumeration

Glossary Item Box

Specifies the projection mode for the three-dimensional chart.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesProjectionMode
   Inherits System.Enum
C#
public enum ThreeDPropertiesProjectionMode : System.Enum

Members

Member | Description
Orthographic | Indicates that the projection is set to Orthographic.
Perspective | Indicates that the projection is set to perspective.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesProjectionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesShading Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesShading Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesShading Enumeration

Glossary Item Box

Specifies the shading style of the three-dimensional chart.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesShading
   Inherits System.Enum
C#
public enum ThreeDPropertiesShading : System.Enum

Members

Member | Description
None | Indicates no shading.
Real | Indicates realistic shading.
Simple | Indicates simple shading.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TickMark Enumeration

[image]
ActiveReports 19 .NET Edition
TickMark Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TickMark Enumeration

Glossary Item Box

Specifies the position of the tick marks on the axis.

Syntax

Visual Basic (Declaration)
Public Enum TickMark
   Inherits System.Enum
C#
public enum TickMark : System.Enum

Members

Member | Description
Cross | Indicates that the tick marks cross the axis.
Inside | Indicates that the tick marks are inside the axis.
None | Indicates no tick marks.
Outside | Indicates that the tick marks are outside the axis.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TickMark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TitlePosition Enumeration

[image]
ActiveReports 19 .NET Edition
TitlePosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TitlePosition Enumeration

Glossary Item Box

Specifies the position of the title. TitlePosition is not used for the chart title.

Syntax

Visual Basic (Declaration)
Public Enum TitlePosition
   Inherits System.Enum
C#
public enum TitlePosition : System.Enum

Members

Member | Description
Center | Indicates that the title is centered.
Far | Indicates that the title is aligned further from the chart.
Near | Indicates that the title is aligned near the chart.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TitlePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


UnicodeBiDi Enumeration

[image]
ActiveReports 19 .NET Edition
UnicodeBiDi Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UnicodeBiDi Enumeration

Glossary Item Box

Specifies a level of embedding with respect to the Bi-directional algorithm.

Syntax

Visual Basic (Declaration)
Public Enum UnicodeBiDi
   Inherits System.Enum
C#
public enum UnicodeBiDi : System.Enum

Members

Member | Description
BidiOverride | Indicates element opens an additional level of embedding except that reordering is sequential.
Embed | Indicates element opens an additional level of embedding.
Normal | Indicates element does not open an additioanl level fo embedding.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.UnicodeBiDi

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


UprightTextMode Enumeration

[image]
ActiveReports 19 .NET Edition
UprightTextMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UprightTextMode Enumeration

Glossary Item Box

Specifies whether the digits or digits along with Latin text appear horizontally in the vertical text.

Syntax

Visual Basic (Declaration)
Public Enum UprightTextMode
   Inherits System.Enum
C#
public enum UprightTextMode : System.Enum

Members

Member | Description
Digits | Only horizontal digits
DigitsAndLatinLetters | Horizontal digits with latin letters
None | No horizontal runs

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.UprightTextMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ValidationMode Enumeration

[image]
ActiveReports 19 .NET Edition
ValidationMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationMode Enumeration

Glossary Item Box

Specifies the current mode of the validation system. Different severities and validation entries may be used for different modes.

Syntax

Visual Basic (Declaration)
Public Enum ValidationMode
   Inherits System.Enum
C#
public enum ValidationMode : System.Enum

Members

Member | Description
BeforeProcessing | Indicates that the validation is being done in order to process a report. Any errors will cause the report processing to halt.
DesignTime | Indicates that the validation is being done at design time, allowing the user to correct any detected validation entries.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ValidationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


VerticalAlign Enumeration

[image]
ActiveReports 19 .NET Edition
VerticalAlign Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : VerticalAlign Enumeration

Glossary Item Box

Specifies a vertical alignment of the text or the picture.

Syntax

Visual Basic (Declaration)
Public Enum VerticalAlign
   Inherits System.Enum
C#
public enum VerticalAlign : System.Enum

Members

Member | Description
Bottom | Indicates align to the bottom.
Middle | Indicates align to the middle.
Top | Indicates align to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.VerticalAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ViewerType Enumeration

[image]
ActiveReports 19 .NET Edition
ViewerType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ViewerType Enumeration

Glossary Item Box

Specifies the types of viewer available for a report.

Syntax

Visual Basic (Declaration)
Public Enum ViewerType
   Inherits System.Enum
C#
public enum ViewerType : System.Enum

Members

Member | Description
Dashboard | Dashboard view type for the report.
Report | Default view type for the report.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ViewerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


WidthSensitivity Enumeration

[image]
ActiveReports 19 .NET Edition
WidthSensitivity Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : WidthSensitivity Enumeration

Glossary Item Box

Specifies whether the data is width sensitive.

Syntax

Visual Basic (Declaration)
Public Enum WidthSensitivity
   Inherits System.Enum
C#
public enum WidthSensitivity : System.Enum

Members

Member | Description
Auto | The width sensitivity setting is derived by querying the data provider.
False | Data is not width sensitive.
True | Data is width sensitive.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.WidthSensitivity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


WrapMode Enumeration

[image]
ActiveReports 19 .NET Edition
WrapMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : WrapMode Enumeration

Glossary Item Box

Specifies a wrap mode for text.

Syntax

Visual Basic (Declaration)
Public Enum WrapMode
   Inherits System.Enum
C#
public enum WrapMode : System.Enum

Members

Member | Description
CharWrap | Text wraps at character boundaries. When the text reaches the container's edge, it moves to the next line at the nearest character boundary.
NoWrap | Text does not wrap. It continues on the same line until it reaches the container's edge.
WordWrap | Text wraps at word boundaries. When the text reaches the container's edge, it moves to the next line at the nearest word boundary.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.WrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


WritingMode Enumeration

[image]
ActiveReports 19 .NET Edition
WritingMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : WritingMode Enumeration

Glossary Item Box

Specifies if the text is written horizontally or vertically.

Syntax

Visual Basic (Declaration)
Public Enum WritingMode
   Inherits System.Enum
C#
public enum WritingMode : System.Enum

Members

Member | Description
lrtb | Indicates left to right, top to bottom.
tbrl | Indicates top to bottom, right to left.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.WritingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Length Structure

[image]
ActiveReports 19 .NET Edition
Length Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length Structure

Glossary Item Box

Represents a length measurement with units.

Object Model

Length Structure

Syntax

Visual Basic (Declaration)
Public Structure Length
   Inherits System.ValueType
C#
public struct Length : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PageReportModel.Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Members
GrapeCity.ActiveReports.PageReportModel Namespace


Length Structure Members

[image]
ActiveReports 19 .NET Edition
Length Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length Structure

Glossary Item Box

The following tables list the members exposed by Length.

Public Constructors

 | Name | Description
Public Constructor | Length Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | An empty Length with no value.
static (Shared in Visual Basic) | Zero | A Length value representing zero inches.
Top

Public Properties

 | Name | Description
Public Property | IsUndefined | Gets a value indicating whether the Length is undefined.
Public Property | IsValid | Gets a value indicating whether the Length is valid.
Public Property | IsZero | Gets a value indicating whether the length is valid and equals zero.
Public Property | OriginalUnit | Gets an original unit type that was specified for this Length.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Adds two Length values and returns the result in the unit of the first length.
Public Method | CompareTo | Overloaded. Compares the current Length instance to a specified object and returns an indication of their relative values.
static (Shared in Visual Basic) | Divide | Divides one Length value by another.
static (Shared in Visual Basic) | DivideBy | Divides a Length value using a specified value.
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current Length.
static (Shared in Visual Basic) | FromTwips | Creates a new Length from a specified value in twips.
Public Method | GetHashCode | Serves as a hash function for the Length.
static (Shared in Visual Basic) | Multiply | Multiplies a specified Length value using a scale factor.
static (Shared in Visual Basic) | Subtract | Subtracts one Length value from another and returns the result in the unit of the first length.
Public Method | ToCentimeters | Converts the Length value to centimeters (1cm = 567twips).
Public Method | ToInches | Converts the Length value to inches (1in = 1440twips).
Public Method | ToMillimeters | Converts the Length value to millimeters (1mm = 56.7twips).
Public Method | ToPica | Converts the Length value to picas (1pc = 240twips).
Public Method | ToPoints | Converts the existing Length twips to points (1pt = 20twips)
Public Method | ToString | Overloaded. Converts the value of this instance to its equivalent string representation.
Public Method | ToTwips | Converts the Length value to twips.
static (Shared in Visual Basic) | TryParse | Attempts to parse a string as a Length value.
static (Shared in Visual Basic) | TwipsToString | Converts a value in twips to a string representation in the specified unit.
Top

Public Operators

public Operator Addition | Adds two Length values and returns the result in the unit of the first length.
public Operator Equality | Determines if two Length value values are equal.
public Operator Explicit Type Conversion | Converts a Length instance to its string representation.
public Operator Greater Than | Determines if the first Length value is greater than the second.
public Operator Greater Than or Equal | Determines if the first Length value is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts a string to a Length instance.
public Operator Inequality | Determines if two Length values are not equal.
public Operator Less Than | Determines if the first Length value is less than the second.
public Operator Less Than or Equal | Determines if the first Length value is less than or equal to the second.
public Operator Subtraction | Subtracts one Length value from another and returns the result in the unit of the first length.
public Operator Unary Negation | Inverts a specified Length value.
Top

See Also

Reference

Length Structure
GrapeCity.ActiveReports.PageReportModel Namespace


Length Constructor

[image]
ActiveReports 19 .NET Edition
Length Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Length Constructor

Glossary Item Box

Overload List

Overload | Description
Length Constructor(String) | Initializes a new instance of the Length struct using a specified string length.
Length Constructor(Double,Unit) | Initializes a new instance of the Length struct using a specified length and unit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Length Constructor(String)

[image]
ActiveReports 19 .NET Edition
Length Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > Length Constructor : Length Constructor(String)

length
A System.String value indicating the length, e.g., "1 cm", "10 pt".

Glossary Item Box

Initializes a new instance of the Length struct using a specified string length.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As String _
)
C#
public Length(
   string length
)

Parameters

length
A System.String value indicating the length, e.g., "1 cm", "10 pt".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


Length Constructor(Double,Unit)

[image]
ActiveReports 19 .NET Edition
Length Constructor(Double,Unit)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > Length Constructor : Length Constructor(Double,Unit)

originalLength
A System.String value indicating the numeric value of the length.
originalUnit
A Length.Unit of measurement for the length.

Glossary Item Box

Initializes a new instance of the Length struct using a specified length and unit.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal originalLength As Double, _
   ByVal originalUnit As Length.Unit _
)
C#
public Length(
   double originalLength,
   Length.Unit originalUnit
)

Parameters

originalLength
A System.String value indicating the numeric value of the length.
originalUnit
A Length.Unit of measurement for the length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


Length Structure Methods

[image]
ActiveReports 19 .NET Edition
Length Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length Structure

Glossary Item Box

For a list of all members of this type, see Length members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Adds two Length values and returns the result in the unit of the first length.
Public Method | CompareTo | Overloaded. Compares the current Length instance to a specified object and returns an indication of their relative values.
static (Shared in Visual Basic) | Divide | Divides one Length value by another.
static (Shared in Visual Basic) | DivideBy | Divides a Length value using a specified value.
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current Length.
static (Shared in Visual Basic) | FromTwips | Creates a new Length from a specified value in twips.
Public Method | GetHashCode | Serves as a hash function for the Length.
static (Shared in Visual Basic) | Multiply | Multiplies a specified Length value using a scale factor.
static (Shared in Visual Basic) | Subtract | Subtracts one Length value from another and returns the result in the unit of the first length.
Public Method | ToCentimeters | Converts the Length value to centimeters (1cm = 567twips).
Public Method | ToInches | Converts the Length value to inches (1in = 1440twips).
Public Method | ToMillimeters | Converts the Length value to millimeters (1mm = 56.7twips).
Public Method | ToPica | Converts the Length value to picas (1pc = 240twips).
Public Method | ToPoints | Converts the existing Length twips to points (1pt = 20twips)
Public Method | ToString | Overloaded. Converts the value of this instance to its equivalent string representation.
Public Method | ToTwips | Converts the Length value to twips.
static (Shared in Visual Basic) | TryParse | Attempts to parse a string as a Length value.
static (Shared in Visual Basic) | TwipsToString | Converts a value in twips to a string representation in the specified unit.
Top

See Also

Reference

Length Structure
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Add Method

unit1
A first Length value.
unit2
A second Length value.

Glossary Item Box

Adds two Length values and returns the result in the unit of the first length.

Syntax

Visual Basic (Declaration)
Public Shared Function Add( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
C#
public static Length Add(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value.
unit2
A second Length value.

Return Value

A new Length value representing the sum of the two lengths.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("2in");
var result = Length.Add(length1, length2); // 3in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


CompareTo Method

[image]
ActiveReports 19 .NET Edition
CompareTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : CompareTo Method

Glossary Item Box

Compares the current Length instance to a specified object and returns an indication of their relative values.

Overload List

Overload | Description
CompareTo(Object) | Compares the current Length instance to a specified object and returns an indication of their relative values.
CompareTo(Length) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


CompareTo(Object) Method

[image]
ActiveReports 19 .NET Edition
CompareTo(Object) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > CompareTo Method : CompareTo(Object) Method

obj
An System.Object to compare with the current instance.

Glossary Item Box

Compares the current Length instance to a specified object and returns an indication of their relative values.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
An System.Object to compare with the current instance.

Return Value

An System.Int32 value indicating the relative order of the objects being compared.

Example

C# Copy Code
var length1 = new Length("10in");
var length2 = new Length("5in");
int comparison = length1.CompareTo(length2); // 1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


CompareTo(Length) Method

[image]
ActiveReports 19 .NET Edition
CompareTo(Length) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > CompareTo Method : CompareTo(Length) Method

other
An System.Object to compare with this instance.

Glossary Item Box

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal other As Length _
) As Integer
C#
public int CompareTo(
   Length other
)

Parameters

other
An System.Object to compare with this instance.

Return Value

An System.Int32 value indicating the relative order of the objects being compared.

Less than zero | This instance is less than other.
Zero | This instance is equal to other.
Greater than zero | This instance is greater than other.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("2in");
int result = length1.CompareTo(length2); // -1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


Divide Method

[image]
ActiveReports 19 .NET Edition
Divide Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Divide Method

unit1
A dividend Length value.
unit2
A divisor Length value.

Glossary Item Box

Divides one Length value by another.

Syntax

Visual Basic (Declaration)
Public Shared Function Divide( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Double
C#
public static double Divide(
   Length unit1,
   Length unit2
)

Parameters

unit1
A dividend Length value.
unit2
A divisor Length value.

Return Value

A System.Double value indicating the quotient of the division.

Exceptions

Exception | Description
System.DivideByZeroException | Throws if unit1 or unit2 is zero.

Example

C# Copy Code
var length1 = new Length("2in");
var length2 = new Length("1in");
var result = Length.Divide(length1, length2); // 2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


DivideBy Method

[image]
ActiveReports 19 .NET Edition
DivideBy Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : DivideBy Method

unit
A dividend Length value.
divisor
A System.Single value indicating the divisor.

Glossary Item Box

Divides a Length value using a specified value.

Syntax

Visual Basic (Declaration)
Public Shared Function DivideBy( _
   ByVal unit As Length, _
   ByVal divisor As Single _
) As Length
C#
public static Length DivideBy(
   Length unit,
   float divisor
)

Parameters

unit
A dividend Length value.
divisor
A System.Single value indicating the divisor.

Return Value

A new Length value representing the quotient.

Exceptions

Exception | Description
System.DivideByZeroException | Throws if divisor is zero.

Example

C# Copy Code
var length = new Length("2in");
var result = Length.DivideBy(length, 2); // 1in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Equals Method

Glossary Item Box

Determines whether the specified object is equal to the current Length.

Overload List

Overload | Description
Equals(Object) | Determines whether the specified object is equal to the current Length.
Equals(Length) | Indicates whether the current object is equal to another object of the same type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > Equals Method : Equals(Object) Method

obj
An System.Object to compare with the current Length.

Glossary Item Box

Determines whether the specified object is equal to the current Length.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
An System.Object to compare with the current Length.

Return Value

A System.Boolean value. true if the specified object is equal to the current Length; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
object length2 = new Length("1in");
bool result = length1.Equals(length2); // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


Equals(Length) Method

[image]
ActiveReports 19 .NET Edition
Equals(Length) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > Equals Method : Equals(Length) Method

other
An System.Object to compare with this object.

Glossary Item Box

Indicates whether the current object is equal to another object of the same type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Length _
) As Boolean
C#
public bool Equals(
   Length other
)

Parameters

other
An System.Object to compare with this object.

Return Value

A System.Boolean value. true if the current object is equal to the other parameter; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("1in");
bool result = length1.Equals(length2); // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


FromTwips Method

[image]
ActiveReports 19 .NET Edition
FromTwips Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : FromTwips Method

twips
A System.Single value indicating the length in twips.
target
A target Length.Unit for the resulting length.

Glossary Item Box

Creates a new Length from a specified value in twips.

Syntax

Visual Basic (Declaration)
Public Shared Function FromTwips( _
   ByVal twips As Single, _
   ByVal target As Length.Unit _
) As Length
C#
public static Length FromTwips(
   float twips,
   Length.Unit target
)

Parameters

twips
A System.Single value indicating the length in twips.
target
A target Length.Unit for the resulting length.

Return Value

A new Length instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : GetHashCode Method

Glossary Item Box

Serves as a hash function for the Length.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

An System.Int32 value indicating the hash code for the current Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Multiply Method

[image]
ActiveReports 19 .NET Edition
Multiply Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Multiply Method

unit
A Length value to multiply.
scale
A System.Single value indicating the scale factor.

Glossary Item Box

Multiplies a specified Length value using a scale factor.

Syntax

Visual Basic (Declaration)
Public Shared Function Multiply( _
   ByVal unit As Length, _
   ByVal scale As Single _
) As Length
C#
public static Length Multiply(
   Length unit,
   float scale
)

Parameters

unit
A Length value to multiply.
scale
A System.Single value indicating the scale factor.

Return Value

A new Length value representing the scaled length.

Example

C# Copy Code
var length = new Length("1in");
var scaledLength = Length.Multiply(length, 2); // 2in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Subtract Method

[image]
ActiveReports 19 .NET Edition
Subtract Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Subtract Method

unit1
A minuend Length value.
unit2
A subtrahend Length value.

Glossary Item Box

Subtracts one Length value from another and returns the result in the unit of the first length.

Syntax

Visual Basic (Declaration)
Public Shared Function Subtract( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
C#
public static Length Subtract(
   Length unit1,
   Length unit2
)

Parameters

unit1
A minuend Length value.
unit2
A subtrahend Length value.

Return Value

A new Length value representing the difference between the two lengths.

Example

C# Copy Code
var length1 = new Length("2in");
var length2 = new Length("1in");
var result = Length.Subtract(length1, length2); // 1in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToCentimeters Method

[image]
ActiveReports 19 .NET Edition
ToCentimeters Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToCentimeters Method

Glossary Item Box

Converts the Length value to centimeters (1cm = 567twips).

Syntax

Visual Basic (Declaration)
Public Function ToCentimeters() As Single
C#
public float ToCentimeters()

Return Value

A Length value in centimeters.

Example

C# Copy Code
var length = new Length("1in");
float cm = length.ToCentimeters(); // 2.54

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToInches Method

[image]
ActiveReports 19 .NET Edition
ToInches Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToInches Method

Glossary Item Box

Converts the Length value to inches (1in = 1440twips).

Syntax

Visual Basic (Declaration)
Public Function ToInches() As Single
C#
public float ToInches()

Return Value

A Length value in inches.

Example

C# Copy Code
var length = new Length("2.54cm");
float inches = length.ToInches(); // 1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToMillimeters Method

[image]
ActiveReports 19 .NET Edition
ToMillimeters Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToMillimeters Method

Glossary Item Box

Converts the Length value to millimeters (1mm = 56.7twips).

Syntax

Visual Basic (Declaration)
Public Function ToMillimeters() As Single
C#
public float ToMillimeters()

Return Value

A Length value in millimeters.

Example

C# Copy Code
var length = new Length("1in");
float mm = length.ToMillimeters(); // 25.4

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToPica Method

[image]
ActiveReports 19 .NET Edition
ToPica Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToPica Method

Glossary Item Box

Converts the Length value to picas (1pc = 240twips).

Syntax

Visual Basic (Declaration)
Public Function ToPica() As Single
C#
public float ToPica()

Return Value

A Length value in picas.

Example

C# Copy Code
var length = new Length("1in");
float picas = length.ToPica(); // 6

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToPoints Method

[image]
ActiveReports 19 .NET Edition
ToPoints Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToPoints Method

Glossary Item Box

Converts the existing Length twips to points (1pt = 20twips)

Syntax

Visual Basic (Declaration)
Public Function ToPoints() As Single
C#
public float ToPoints()

Return Value

A Length value in points.

Example

C# Copy Code
var length = new Length("1in");
float points = length.ToPoints(); // 72

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToString Method

Glossary Item Box

Converts the value of this instance to its equivalent string representation.

Overload List

Overload | Description
ToString() | Converts the value of this instance to its equivalent string representation.
ToString(IFormatProvider) | Converts the value of this instance to its equivalent string representation using the specified format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


ToString() Method

[image]
ActiveReports 19 .NET Edition
ToString() Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > ToString Method : ToString() Method

Glossary Item Box

Converts the value of this instance to its equivalent string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String value indicating the current Length instance.

Example

C# Copy Code
var length = new Length("1in");
string result = length.ToString(); // "1in"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


ToString(IFormatProvider) Method

[image]
ActiveReports 19 .NET Edition
ToString(IFormatProvider) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure > ToString Method : ToString(IFormatProvider) Method

provider
An System.IFormatProvider object supplying the culture-specific formatting information.

Glossary Item Box

Converts the value of this instance to its equivalent string representation using the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal provider As IFormatProvider _
) As String
C#
public string ToString(
   IFormatProvider provider
)

Parameters

provider
An System.IFormatProvider object supplying the culture-specific formatting information.

Return Value

A System.String value indicating the current Length instance.

Example

C# Copy Code
var length = new Length("1in");
string result = length.ToString(CultureInfo.InvariantCulture); // "1in"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members
Overload List


ToTwips Method

[image]
ActiveReports 19 .NET Edition
ToTwips Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : ToTwips Method

Glossary Item Box

Converts the Length value to twips.

Syntax

Visual Basic (Declaration)
Public Function ToTwips() As Single
C#
public float ToTwips()

Return Value

A Length value in twips.

Example

C# Copy Code
var length = new Length("1in");
float twips = length.ToTwips(); // 1440

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


TryParse Method

[image]
ActiveReports 19 .NET Edition
TryParse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : TryParse Method

value
A System.String value to parse.
result
The resulting Length value if the parse is successful.

Glossary Item Box

Attempts to parse a string as a Length value.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As Length _
) As Boolean
C#
public static bool TryParse(
   string value,
   out Length result
)

Parameters

value
A System.String value to parse.
result
The resulting Length value if the parse is successful.

Return Value

A System.Boolean value. true if the string can be parsed as a Length; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


TwipsToString Method

[image]
ActiveReports 19 .NET Edition
TwipsToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : TwipsToString Method

twips
A System.Single value indicating the length in twips.
target
A target Length.Unit for the string representation.

Glossary Item Box

Converts a value in twips to a string representation in the specified unit.

Syntax

Visual Basic (Declaration)
Public Shared Function TwipsToString( _
   ByVal twips As Single, _
   ByVal target As Length.Unit _
) As String
C#
public static string TwipsToString(
   float twips,
   Length.Unit target
)

Parameters

twips
A System.Single value indicating the length in twips.
target
A target Length.Unit for the string representation.

Return Value

A System.String value representing the length in the specified unit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Length Structure Properties

[image]
ActiveReports 19 .NET Edition
Length Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length Structure

Glossary Item Box

For a list of all members of this type, see Length members.

Public Properties

 | Name | Description
Public Property | IsUndefined | Gets a value indicating whether the Length is undefined.
Public Property | IsValid | Gets a value indicating whether the Length is valid.
Public Property | IsZero | Gets a value indicating whether the length is valid and equals zero.
Public Property | OriginalUnit | Gets an original unit type that was specified for this Length.
Top

See Also

Reference

Length Structure
GrapeCity.ActiveReports.PageReportModel Namespace


IsUndefined Property

[image]
ActiveReports 19 .NET Edition
IsUndefined Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : IsUndefined Property

Glossary Item Box

Gets a value indicating whether the Length is undefined.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsUndefined As Boolean
C#
public bool IsUndefined {get;}

Property Value

A System.Boolean value. true if the Length is undefined; otherwise, false.

Example

C# Copy Code
var length = Length.Empty;
bool isUndefined = length.IsUndefined; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


IsValid Property

[image]
ActiveReports 19 .NET Edition
IsValid Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : IsValid Property

Glossary Item Box

Gets a value indicating whether the Length is valid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid {get;}

Property Value

A System.Boolean value. true if the Length is valid; otherwise, false.

Example

C# Copy Code
var length = new Length("10in");
bool isValid = length.IsValid; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


IsZero Property

[image]
ActiveReports 19 .NET Edition
IsZero Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : IsZero Property

Glossary Item Box

Gets a value indicating whether the length is valid and equals zero.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
C#
public bool IsZero {get;}

Property Value

A System.Boolean value. true if the length is zero; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


OriginalUnit Property

[image]
ActiveReports 19 .NET Edition
OriginalUnit Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : OriginalUnit Property

Glossary Item Box

Gets an original unit type that was specified for this Length.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginalUnit As Length.Unit
C#
public Length.Unit OriginalUnit {get;}

Property Value

An original Length.Unit of measurement.

Example

C# Copy Code
var length = new Length(1, Length.Unit.Centimeters);
var unit = length.OriginalUnit; // Centimeters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Length Structure Fields

[image]
ActiveReports 19 .NET Edition
Length Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Length Structure

Glossary Item Box

For a list of all members of this type, see Length members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | An empty Length with no value.
static (Shared in Visual Basic) | Zero | A Length value representing zero inches.
Top

See Also

Reference

Length Structure
GrapeCity.ActiveReports.PageReportModel Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Empty Field

Glossary Item Box

An empty Length with no value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Length
C#
public static readonly Length Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Zero Field

[image]
ActiveReports 19 .NET Edition
Zero Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Zero Field

Glossary Item Box

A Length value representing zero inches.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As Length
C#
public static readonly Length Zero

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Addition Operator

[image]
ActiveReports 19 .NET Edition
Addition Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Addition Operator

unit1
A first Length value.
unit2
A second Length value.

Glossary Item Box

Adds two Length values and returns the result in the unit of the first length.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
C#
public Length operator +(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value.
unit2
A second Length value.

Return Value

A new Length value representing the sum of the two lengths.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("2in");
var result = length1 + length2; // 3in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Equality Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if two Length value values are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator ==(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the two lengths are equal; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("1in");
bool result = length1 == length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Explicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Explicit Type Conversion Operator

unit
A Length value to convert.

Glossary Item Box

Converts a Length instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal unit As Length _
) As String
C#
public string operator explicit(
   Length unit
)

Parameters

unit
A Length value to convert.

Return Value

A System.String value indicating the Length.

Example

C# Copy Code
var length = new Length("1in");
string lengthString = (string)length; // "1in"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Greater Than Operator

[image]
ActiveReports 19 .NET Edition
Greater Than Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Greater Than Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if the first Length value is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator >(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the first length is greater than the second; otherwise, false.

Example

C# Copy Code
var length1 = new Length("2in");
var length2 = new Length("1in");
bool result = length1 > length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Greater Than or Equal Operator

[image]
ActiveReports 19 .NET Edition
Greater Than or Equal Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Greater Than or Equal Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if the first Length value is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator >=(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the first length is greater than or equal to the second; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("1in");
bool result = length1 >= length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Implicit Type Conversion Operator

length
A System.String value indicating the length.

Glossary Item Box

Converts a string to a Length instance.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal length As String _
) As Length
C#
public Length operator implicit(
   string length
)

Parameters

length
A System.String value indicating the length.

Return Value

A new Length instance.

Example

C# Copy Code
Length length = "1in";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Inequality Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if two Length values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator !=(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the two lengths are not equal; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("2in");
bool result = length1 != length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Less Than Operator

[image]
ActiveReports 19 .NET Edition
Less Than Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Less Than Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if the first Length value is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator <(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the first length is less than the second; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("2in");
bool result = length1 < length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Less Than or Equal Operator

[image]
ActiveReports 19 .NET Edition
Less Than or Equal Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Less Than or Equal Operator

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Glossary Item Box

Determines if the first Length value is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Boolean
C#
public bool operator <=(
   Length unit1,
   Length unit2
)

Parameters

unit1
A first Length value to compare.
unit2
A second Length value to compare.

Return Value

A System.Boolean value. true if the first length is less than or equal to the second; otherwise, false.

Example

C# Copy Code
var length1 = new Length("1in");
var length2 = new Length("1in");
bool result = length1 <= length2; // true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Subtraction Operator

[image]
ActiveReports 19 .NET Edition
Subtraction Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Subtraction Operator

unit1
A minuend Length value.
unit2
A subtrahend Length value.

Glossary Item Box

Subtracts one Length value from another and returns the result in the unit of the first length.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
C#
public Length operator -(
   Length unit1,
   Length unit2
)

Parameters

unit1
A minuend Length value.
unit2
A subtrahend Length value.

Return Value

A new Length value representing the difference between the two lengths.

Example

C# Copy Code
var length1 = new Length("2in");
var length2 = new Length("1in");
var result = length1 - length2; // 1in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


Unary Negation Operator

[image]
ActiveReports 19 .NET Edition
Unary Negation Operator
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Length Structure : Unary Negation Operator

l
A Length value to negate.

Glossary Item Box

Inverts a specified Length value.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal l As Length _
) As Length
C#
public Length operator -(
   Length l
)

Parameters

l
A Length value to negate.

Return Value

A new Length value with the inverted value.

Example

C# Copy Code
var length = new Length("1in");
var negatedLength = -length; // -1in

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Length Structure
Length Members


MasterContentCode Structure

[image]
ActiveReports 19 .NET Edition
MasterContentCode Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure

Glossary Item Box

Represents a struct for containing the master and child report code separately.

Object Model

MasterContentCode Structure

Syntax

Visual Basic (Declaration)
Public Structure MasterContentCode
   Inherits System.ValueType
C#
public struct MasterContentCode : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PageReportModel.MasterContentCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentCode Members
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentCode Structure Members

[image]
ActiveReports 19 .NET Edition
MasterContentCode Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure

Glossary Item Box

The following tables list the members exposed by MasterContentCode.

Public Constructors

 | Name | Description
Public Constructor | MasterContentCode Constructor | Initializes a new instance of the MasterContentCode struct.
Top

Public Properties

 | Name | Description
Public Property | ChildCode | Gets the code property value from the child report.
Public Property | MasterCode | Gets the code property value from the master report.
Top

See Also

Reference

MasterContentCode Structure
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentCode Constructor

[image]
ActiveReports 19 .NET Edition
MasterContentCode Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : MasterContentCode Constructor

masterCode
A System.String value indicating the code property value coming from the master report.
childCode
A System.String value indicating the code property value coming from the child report.

Glossary Item Box

Initializes a new instance of the MasterContentCode struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal masterCode As String, _
   ByVal childCode As String _
)
C#
public MasterContentCode(
   string masterCode,
   string childCode
)

Parameters

masterCode
A System.String value indicating the code property value coming from the master report.
childCode
A System.String value indicating the code property value coming from the child report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentCode Structure
MasterContentCode Members


MasterContentCode Structure Properties

[image]
ActiveReports 19 .NET Edition
MasterContentCode Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure

Glossary Item Box

For a list of all members of this type, see MasterContentCode members.

Public Properties

 | Name | Description
Public Property | ChildCode | Gets the code property value from the child report.
Public Property | MasterCode | Gets the code property value from the master report.
Top

See Also

Reference

MasterContentCode Structure
GrapeCity.ActiveReports.PageReportModel Namespace


ChildCode Property

[image]
ActiveReports 19 .NET Edition
ChildCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : ChildCode Property

Glossary Item Box

Gets the code property value from the child report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChildCode As String
C#
public string ChildCode {get;}

Property Value

A System.String value indicating the code property value from the child report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentCode Structure
MasterContentCode Members


MasterCode Property

[image]
ActiveReports 19 .NET Edition
MasterCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : MasterCode Property

Glossary Item Box

Gets the code property value from the master report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MasterCode As String
C#
public string MasterCode {get;}

Property Value

A System.String value indicating the code property value from the master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterContentCode Structure
MasterContentCode Members


IBaseDataSet Interface

[image]
ActiveReports 19 .NET Edition
IBaseDataSet Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface

Glossary Item Box

Represents the properties common to all types of datasets.

Syntax

Visual Basic (Declaration)
Public Interface IBaseDataSet
C#
public interface IBaseDataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


IBaseDataSet Interface Members

[image]
ActiveReports 19 .NET Edition
IBaseDataSet Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface

Glossary Item Box

The following tables list the members exposed by IBaseDataSet.

Public Properties

 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Property | Collation | Gets or sets a locale to use in the collation sequence for sorting data.
Property | Fields | Gets the fields in the dataset.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Property | Name | Gets or sets a name of the dataset.
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top

See Also

Reference

IBaseDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IBaseDataSet Interface Properties

[image]
ActiveReports 19 .NET Edition
IBaseDataSet Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface

Glossary Item Box

For a list of all members of this type, see IBaseDataSet members.

Public Properties

 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Property | Collation | Gets or sets a locale to use in the collation sequence for sorting data.
Property | Fields | Gets the fields in the dataset.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Property | Name | Gets or sets a name of the dataset.
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top

See Also

Reference

IBaseDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


AccentSensitivity Property

[image]
ActiveReports 19 .NET Edition
AccentSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : AccentSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is accent sensitive.

Syntax

Visual Basic (Declaration)
Property AccentSensitivity As AccentSensitivity
C#
AccentSensitivity AccentSensitivity {get; set;}

Property Value

An AccentSensitivity value indicating whether the data is accent sensitive.

Remarks

If AccentSensitivity.Auto value is specified, the application attempts to determine the accent sensitivity by querying the data provider. Defaults to AccentSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


CaseSensitivity Property

[image]
ActiveReports 19 .NET Edition
CaseSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : CaseSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is case sensitive.

Syntax

Visual Basic (Declaration)
Property CaseSensitivity As CaseSensitivity
C#
CaseSensitivity CaseSensitivity {get; set;}

Property Value

A CaseSensitivity value indicating whether the fields in the dataset are case sensitive.

Remarks

If CaseSensitivity.Auto value is specified, the application attempts to determine the case sensitivity by querying the data provider. Defaults to CaseSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Collation Property

[image]
ActiveReports 19 .NET Edition
Collation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Collation Property

Glossary Item Box

Gets or sets a locale to use in the collation sequence for sorting data.

Syntax

Visual Basic (Declaration)
Property Collation As String
C#
string Collation {get; set;}

Property Value

A System.String value indicating the locale for the collation sequence.

Remarks

If no collation is specified, the application attempts to determine the collation setting by querying the data provider. Defaults to the application's locale settings if the data provider does not support this feature or returns an invalid value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Fields Property

[image]
ActiveReports 19 .NET Edition
Fields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Fields Property

Glossary Item Box

Gets the fields in the dataset.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fields As FieldCollection
C#
FieldCollection Fields {get;}

Property Value

A FieldCollection object containing the fields in the dataset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


KanatypeSensitivity Property

[image]
ActiveReports 19 .NET Edition
KanatypeSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : KanatypeSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is kanatype sensitive.

Syntax

Visual Basic (Declaration)
Property KanatypeSensitivity As KanatypeSensitivity
C#
KanatypeSensitivity KanatypeSensitivity {get; set;}

Property Value

A KanatypeSensitivity value indicating whether the data is kanatype sensitive.

Remarks

If KanatypeSensitivity.Auto value is specified, the application attempts to determine the kanatype sensitivity by querying the data provider. Defaults to KanatypeSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Name Property

Glossary Item Box

Gets or sets a name of the dataset.

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Property Value

A System.String value indicating the name of the dataset.

Remarks

The dataset name must be unique and cannot match any data region or grouping name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


WidthSensitivity Property

[image]
ActiveReports 19 .NET Edition
WidthSensitivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : WidthSensitivity Property

Glossary Item Box

Gets or sets a value indicating whether the data is width sensitive.

Syntax

Visual Basic (Declaration)
Property WidthSensitivity As WidthSensitivity
C#
WidthSensitivity WidthSensitivity {get; set;}

Property Value

A WidthSensitivity ìôäãó indicating whether the data is width sensitive.

Remarks

If WidthSensitivity.Auto value is specified, the application attempts to determine the width sensitivity by querying the data provider. Defaults to WidthSensitivity.False value if the data provider does not support this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


IComponentSerializationProvider Interface

[image]
ActiveReports 19 .NET Edition
IComponentSerializationProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationProvider Interface

Glossary Item Box

Represents an interface that enables access to a serializer.

Syntax

Visual Basic (Declaration)
Public Interface IComponentSerializationProvider
C#
public interface IComponentSerializationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IComponentSerializationProvider Members
GrapeCity.ActiveReports.PageReportModel Namespace


IComponentSerializationProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IComponentSerializationProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationProvider Interface

Glossary Item Box

The following tables list the members exposed by IComponentSerializationProvider.

Public Methods

 | Name | Description
Method | GetSerializer | Gets a serializer using the specified object type.
Top

See Also

Reference

IComponentSerializationProvider Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IComponentSerializationProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IComponentSerializationProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationProvider Interface

Glossary Item Box

For a list of all members of this type, see IComponentSerializationProvider members.

Public Methods

 | Name | Description
Method | GetSerializer | Gets a serializer using the specified object type.
Top

See Also

Reference

IComponentSerializationProvider Interface
GrapeCity.ActiveReports.PageReportModel Namespace


GetSerializer Method

[image]
ActiveReports 19 .NET Edition
GetSerializer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IComponentSerializationProvider Interface : GetSerializer Method

objectType
A System.Type object representing the type to get serializer for.

Glossary Item Box

Gets a serializer using the specified object type.

Syntax

Visual Basic (Declaration)
Function GetSerializer( _
   ByVal objectType As Type _
) As Object
C#
object GetSerializer(
   Type objectType
)

Parameters

objectType
A System.Type object representing the type to get serializer for.

Return Value

A System.Object object representing the serializer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IComponentSerializationProvider Interface
IComponentSerializationProvider Members


IComponentSerializationService Interface

[image]
ActiveReports 19 .NET Edition
IComponentSerializationService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationService Interface

Glossary Item Box

Provides the serialization/deserialization methods of the report components.

Syntax

Visual Basic (Declaration)
Public Interface IComponentSerializationService
C#
public interface IComponentSerializationService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IComponentSerializationService Members
GrapeCity.ActiveReports.PageReportModel Namespace


IComponentSerializationService Interface Members

[image]
ActiveReports 19 .NET Edition
IComponentSerializationService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationService Interface

Glossary Item Box

The following tables list the members exposed by IComponentSerializationService.

Public Methods

 | Name | Description
Method | Deserialize | Deserializes the specified single object.
Method | Serialize | Serializes the specified object and stores them in a serialization data object.
Top

See Also

Reference

IComponentSerializationService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IComponentSerializationService Interface Methods

[image]
ActiveReports 19 .NET Edition
IComponentSerializationService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IComponentSerializationService Interface

Glossary Item Box

For a list of all members of this type, see IComponentSerializationService members.

Public Methods

 | Name | Description
Method | Deserialize | Deserializes the specified single object.
Method | Serialize | Serializes the specified object and stores them in a serialization data object.
Top

See Also

Reference

IComponentSerializationService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Deserialize Method

[image]
ActiveReports 19 .NET Edition
Deserialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IComponentSerializationService Interface : Deserialize Method

fromStream
A System.IO.Stream object containing the serialized data.

Glossary Item Box

Deserializes the specified single object.

Syntax

Visual Basic (Declaration)
Function Deserialize( _
   ByVal fromStream As Stream _
) As Object
C#
object Deserialize(
   Stream fromStream
)

Parameters

fromStream
A System.IO.Stream object containing the serialized data.

Return Value

The deserialized System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IComponentSerializationService Interface
IComponentSerializationService Members


Serialize Method

[image]
ActiveReports 19 .NET Edition
Serialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IComponentSerializationService Interface : Serialize Method

sourceObject
An System.Object to serialize.
toStream
A System.IO.Stream object where the serialized data will be stored.

Glossary Item Box

Serializes the specified object and stores them in a serialization data object.

Syntax

Visual Basic (Declaration)
Sub Serialize( _
   ByVal sourceObject As Object, _
   ByVal toStream As Stream _
)
C#
void Serialize(
   object sourceObject,
   Stream toStream
)

Parameters

sourceObject
An System.Object to serialize.
toStream
A System.IO.Stream object where the serialized data will be stored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IComponentSerializationService Interface
IComponentSerializationService Members


IDataSet Interface

[image]
ActiveReports 19 .NET Edition
IDataSet Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

Glossary Item Box

Represents a dataset element within a report, containing details about a set of data retrieved as part of the report.

Syntax

Visual Basic (Declaration)
Public Interface IDataSet
   Inherits IBaseDataSet, IReportComponent
C#
public interface IDataSet : IBaseDataSet, IReportComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


IDataSet Interface Members

[image]
ActiveReports 19 .NET Edition
IDataSet Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

Glossary Item Box

The following tables list the members exposed by IDataSet.

Public Properties

 | Name | Description
Property | Filters | Gets a collection of filters applied to each row of data in the dataset.
Property | Query | Gets or sets a query information for the dataset.
Property | SharedDataSet | Gets or sets a shared dataset.
Top

See Also

Reference

IDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IDataSet Interface Properties

[image]
ActiveReports 19 .NET Edition
IDataSet Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

Glossary Item Box

For a list of all members of this type, see IDataSet members.

Public Properties

 | Name | Description
Property | Filters | Gets a collection of filters applied to each row of data in the dataset.
Property | Query | Gets or sets a query information for the dataset.
Property | SharedDataSet | Gets or sets a shared dataset.
Top

See Also

Reference

IDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Filters Property

[image]
ActiveReports 19 .NET Edition
Filters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Filters Property

Glossary Item Box

Gets a collection of filters applied to each row of data in the dataset.

Syntax

Visual Basic (Declaration)
ReadOnly Property Filters As IList(Of Filter)
C#
IList<Filter> Filters {get;}

Property Value

An IList object containing the filters to be applied to each row of data.

Remarks

Filters help in refining the data by including or excluding rows based on specified criteria.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataSet Interface
IDataSet Members


Query Property

[image]
ActiveReports 19 .NET Edition
Query Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Query Property

Glossary Item Box

Gets or sets a query information for the dataset.

Syntax

Visual Basic (Declaration)
Property Query As Query
C#
Query Query {get; set;}

Property Value

A Query object including connection details, query text, and other relevant information for retrieving data.

Remarks

This property must be set to fetch data from the data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataSet Interface
IDataSet Members


SharedDataSet Property

[image]
ActiveReports 19 .NET Edition
SharedDataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : SharedDataSet Property

Glossary Item Box

Gets or sets a shared dataset.

Syntax

Visual Basic (Declaration)
Property SharedDataSet As SharedDataSet
C#
SharedDataSet SharedDataSet {get; set;}

Property Value

A SharedDataSet object representing the shared dataset used by this dataset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataSet Interface
IDataSet Members


IMasterContentService Interface

[image]
ActiveReports 19 .NET Edition
IMasterContentService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

Glossary Item Box

Represents an auxiliary interface for determining report and report item ownership.

Syntax

Visual Basic (Declaration)
Public Interface IMasterContentService
C#
public interface IMasterContentService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Members
GrapeCity.ActiveReports.PageReportModel Namespace


IMasterContentService Interface Members

[image]
ActiveReports 19 .NET Edition
IMasterContentService Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

Glossary Item Box

The following tables list the members exposed by IMasterContentService.

Public Properties

 | Name | Description
Property | IsMaster | Gets a value indicating whether the current report is a master report.
Property | MasterReport | Gets or sets the name of the master report, if any.
Top

Public Methods

 | Name | Description
Method | GetCode | Gets the child and master report code based on the provided combined code.
Method | GetMasterContent | Gets the content for the specified item/property that was inferred from the master report.
Method | GetOwner | Overloaded. Gets the owner of the specified report component.
Method | IsUpdatedReportProperty | Gets a value indicating whether the report property value has been changed from the master.
Method | UpdateReports | Updates the service with a new master and combined report.
Top

See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IMasterContentService Interface Methods

[image]
ActiveReports 19 .NET Edition
IMasterContentService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

Glossary Item Box

For a list of all members of this type, see IMasterContentService members.

Public Methods

 | Name | Description
Method | GetCode | Gets the child and master report code based on the provided combined code.
Method | GetMasterContent | Gets the content for the specified item/property that was inferred from the master report.
Method | GetOwner | Overloaded. Gets the owner of the specified report component.
Method | IsUpdatedReportProperty | Gets a value indicating whether the report property value has been changed from the master.
Method | UpdateReports | Updates the service with a new master and combined report.
Top

See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


GetCode Method

[image]
ActiveReports 19 .NET Edition
GetCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : GetCode Method

combinedCode
A System.String value indicating the combined code of the master and child reports.

Glossary Item Box

Gets the child and master report code based on the provided combined code.

Syntax

Visual Basic (Declaration)
Function GetCode( _
   ByVal combinedCode As String _
) As MasterContentCode
C#
MasterContentCode GetCode(
   string combinedCode
)

Parameters

combinedCode
A System.String value indicating the combined code of the master and child reports.

Return Value

A MasterContentCode containing the master report code and child report code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


GetMasterContent Method

[image]
ActiveReports 19 .NET Edition
GetMasterContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : GetMasterContent Method

itemName
A System.String value indicating the name of the item or property.

Glossary Item Box

Gets the content for the specified item/property that was inferred from the master report.

Syntax

Visual Basic (Declaration)
Function GetMasterContent( _
   ByVal itemName As String _
) As ICollection
C#
ICollection GetMasterContent(
   string itemName
)

Parameters

itemName
A System.String value indicating the name of the item or property.

Return Value

An System.Collections.ICollection of content items inferred from the master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


GetOwner Method

[image]
ActiveReports 19 .NET Edition
GetOwner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : GetOwner Method

Glossary Item Box

Gets the owner of the specified report component.

Overload List

Overload | Description
GetOwner(IComponent) | Gets the owner of the specified report component.
GetOwner(CodeClass) | Gets the owner of the specified CodeClass.
GetOwner(EmbeddedImage) | Gets the owner of the specified EmbeddedImage.
GetOwner(DataSource) | Gets the owner of the specified DataSource.
GetOwner(ReportParameter) | Gets the owner of the specified ReportParameter.
GetOwner(IDataSet) | Gets the owner of the specified IDataSet.
GetOwner(EmbeddedStyleSheet) | Gets the owner of the specified EmbeddedStyleSheet.
GetOwner(String,Field) | Gets the owner of the specified Field belonging to the specified data set.
GetOwner(String,Filter) | Gets the owner of the specified Filter belonging to the specified data set.
GetOwner(String,String,String) | Gets the owner of the resource using the specified culture.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


GetOwner(IComponent) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(IComponent) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(IComponent) Method

component
A System.ComponentModel.IComponent object representing the report component.

Glossary Item Box

Gets the owner of the specified report component.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal component As IComponent _
) As ItemOwners
C#
ItemOwners GetOwner(
   IComponent component
)

Parameters

component
A System.ComponentModel.IComponent object representing the report component.

Return Value

An ItemOwners value indicating the owner of the report component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(CodeClass) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(CodeClass) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(CodeClass) Method

codeClass
A CodeClass for getting owner for.

Glossary Item Box

Gets the owner of the specified CodeClass.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal codeClass As CodeClass _
) As ItemOwners
C#
ItemOwners GetOwner(
   CodeClass codeClass
)

Parameters

codeClass
A CodeClass for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified code class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(EmbeddedImage) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(EmbeddedImage) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(EmbeddedImage) Method

embeddedImage
An EmbeddedImage for getting owner for.

Glossary Item Box

Gets the owner of the specified EmbeddedImage.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal embeddedImage As EmbeddedImage _
) As ItemOwners
C#
ItemOwners GetOwner(
   EmbeddedImage embeddedImage
)

Parameters

embeddedImage
An EmbeddedImage for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified embedded image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(DataSource) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(DataSource) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(DataSource) Method

dataSource
A DataSource for getting owner for.

Glossary Item Box

Gets the owner of the specified DataSource.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal dataSource As DataSource _
) As ItemOwners
C#
ItemOwners GetOwner(
   DataSource dataSource
)

Parameters

dataSource
A DataSource for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(ReportParameter) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(ReportParameter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(ReportParameter) Method

reportParameter
A ReportParameter for getting owner for.

Glossary Item Box

Gets the owner of the specified ReportParameter.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal reportParameter As ReportParameter _
) As ItemOwners
C#
ItemOwners GetOwner(
   ReportParameter reportParameter
)

Parameters

reportParameter
A ReportParameter for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(IDataSet) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(IDataSet) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(IDataSet) Method

dataSet
An IDataSet for getting owner for.

Glossary Item Box

Gets the owner of the specified IDataSet.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal dataSet As IDataSet _
) As ItemOwners
C#
ItemOwners GetOwner(
   IDataSet dataSet
)

Parameters

dataSet
An IDataSet for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(EmbeddedStyleSheet) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(EmbeddedStyleSheet) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(EmbeddedStyleSheet) Method

embeddedStyleSheet
An EmbeddedStyleSheet for getting owner for.

Glossary Item Box

Gets the owner of the specified EmbeddedStyleSheet.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal embeddedStyleSheet As EmbeddedStyleSheet _
) As ItemOwners
C#
ItemOwners GetOwner(
   EmbeddedStyleSheet embeddedStyleSheet
)

Parameters

embeddedStyleSheet
An EmbeddedStyleSheet for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified embedded style sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(String,Field) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,Field) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(String,Field) Method

dataSetName
A System.String value indicating the name of the data set.
field
A Field for getting owner for.

Glossary Item Box

Gets the owner of the specified Field belonging to the specified data set.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal dataSetName As String, _
   ByVal field As Field _
) As ItemOwners
C#
ItemOwners GetOwner(
   string dataSetName,
   Field field
)

Parameters

dataSetName
A System.String value indicating the name of the data set.
field
A Field for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(String,Filter) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,Filter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(String,Filter) Method

dataSetName
A System.String value indicating the name of the data set.
filter
A Filter for getting owner for.

Glossary Item Box

Gets the owner of the specified Filter belonging to the specified data set.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal dataSetName As String, _
   ByVal filter As Filter _
) As ItemOwners
C#
ItemOwners GetOwner(
   string dataSetName,
   Filter filter
)

Parameters

dataSetName
A System.String value indicating the name of the data set.
filter
A Filter for getting owner for.

Return Value

An ItemOwners value indicating the owner of the specified filter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


GetOwner(String,String,String) Method

[image]
ActiveReports 19 .NET Edition
GetOwner(String,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface > GetOwner Method : GetOwner(String,String,String) Method

culture
A System.String value indicating the culture of the resource.
resourceName
A System.String value indicating the name of the resource.
resourceValue
A System.String value indicating the value of the resource.

Glossary Item Box

Gets the owner of the resource using the specified culture.

Syntax

Visual Basic (Declaration)
Overloads Function GetOwner( _
   ByVal culture As String, _
   ByVal resourceName As String, _
   ByVal resourceValue As String _
) As ItemOwners
C#
ItemOwners GetOwner(
   string culture,
   string resourceName,
   string resourceValue
)

Parameters

culture
A System.String value indicating the culture of the resource.
resourceName
A System.String value indicating the name of the resource.
resourceValue
A System.String value indicating the value of the resource.

Return Value

An ItemOwners value indicating the owner of the specified resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members
Overload List


IsUpdatedReportProperty Method

[image]
ActiveReports 19 .NET Edition
IsUpdatedReportProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : IsUpdatedReportProperty Method

propertyName
A System.String value indicating the name of the property to check.
propertyValue
A System.String value indicating the value of the property to compare against the master.

Glossary Item Box

Gets a value indicating whether the report property value has been changed from the master.

Syntax

Visual Basic (Declaration)
Function IsUpdatedReportProperty( _
   ByVal propertyName As String, _
   ByVal propertyValue As Object _
) As Boolean
C#
bool IsUpdatedReportProperty(
   string propertyName,
   object propertyValue
)

Parameters

propertyName
A System.String value indicating the name of the property to check.
propertyValue
A System.String value indicating the value of the property to compare against the master.

Return Value

A System.Boolean value. true if the property value has been updated from the master; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


UpdateReports Method

[image]
ActiveReports 19 .NET Edition
UpdateReports Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : UpdateReports Method

masterReport
A Report object representing the master report to be set.
combinedReport
A Report object representing the combined report to be set.

Glossary Item Box

Updates the service with a new master and combined report.

Syntax

Visual Basic (Declaration)
Sub UpdateReports( _
   ByVal masterReport As Report, _
   ByVal combinedReport As Report _
)
C#
void UpdateReports(
   Report masterReport,
   Report combinedReport
)

Parameters

masterReport
A Report object representing the master report to be set.
combinedReport
A Report object representing the combined report to be set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


IMasterContentService Interface Properties

[image]
ActiveReports 19 .NET Edition
IMasterContentService Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

Glossary Item Box

For a list of all members of this type, see IMasterContentService members.

Public Properties

 | Name | Description
Property | IsMaster | Gets a value indicating whether the current report is a master report.
Property | MasterReport | Gets or sets the name of the master report, if any.
Top

See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IsMaster Property

[image]
ActiveReports 19 .NET Edition
IsMaster Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : IsMaster Property

Glossary Item Box

Gets a value indicating whether the current report is a master report.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsMaster As Boolean
C#
bool IsMaster {get;}

Property Value

A System.Boolean value. true if the current report is a master report; otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


MasterReport Property

[image]
ActiveReports 19 .NET Edition
MasterReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : MasterReport Property

Glossary Item Box

Gets or sets the name of the master report, if any.

Syntax

Visual Basic (Declaration)
Property MasterReport As String
C#
string MasterReport {get; set;}

Property Value

A System.String value indicating the name of the master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMasterContentService Interface
IMasterContentService Members


IRdlContainer Interface

[image]
ActiveReports 19 .NET Edition
IRdlContainer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

Glossary Item Box

Represents a container for report items in an RDL (Report Definition Language) report.

Syntax

Visual Basic (Declaration)
Public Interface IRdlContainer
   Inherits IReportComponent
C#
public interface IRdlContainer : IReportComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRdlContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


IRdlContainer Interface Members

[image]
ActiveReports 19 .NET Edition
IRdlContainer Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

Glossary Item Box

The following tables list the members exposed by IRdlContainer.

Public Properties

 | Name | Description
Property | ReportItems | Gets a collection of report items contained in the container.
Top

Public Methods

 | Name | Description
Method | SortReportItems | Sorts the report items to improve rendering performance.
Top

See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IRdlContainer Interface Methods

[image]
ActiveReports 19 .NET Edition
IRdlContainer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

Glossary Item Box

For a list of all members of this type, see IRdlContainer members.

Public Methods

 | Name | Description
Method | SortReportItems | Sorts the report items to improve rendering performance.
Top

See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


SortReportItems Method

[image]
ActiveReports 19 .NET Edition
SortReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IRdlContainer Interface : SortReportItems Method

Glossary Item Box

Sorts the report items to improve rendering performance.

Syntax

Visual Basic (Declaration)
Sub SortReportItems()
C#
void SortReportItems()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRdlContainer Interface
IRdlContainer Members


IRdlContainer Interface Properties

[image]
ActiveReports 19 .NET Edition
IRdlContainer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

Glossary Item Box

For a list of all members of this type, see IRdlContainer members.

Public Properties

 | Name | Description
Property | ReportItems | Gets a collection of report items contained in the container.
Top

See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IRdlContainer Interface : ReportItems Property

Glossary Item Box

Gets a collection of report items contained in the container.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItems As ReportItemCollection
C#
ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection of ReportItem objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRdlContainer Interface
IRdlContainer Members


IReportComponent Interface

[image]
ActiveReports 19 .NET Edition
IReportComponent Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

Glossary Item Box

Represents an interface of component for the report.

Syntax

Visual Basic (Declaration)
Public Interface IReportComponent
C#
public interface IReportComponent

Remarks

Provides a base interface for types like Report, Body, and ReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponent Members
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponent Interface Members

[image]
ActiveReports 19 .NET Edition
IReportComponent Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

Glossary Item Box

The following tables list the members exposed by IReportComponent.

Public Properties

 | Name | Description
Property | Parent | Gets or sets a parent container.
Top

See Also

Reference

IReportComponent Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponent Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportComponent Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

Glossary Item Box

For a list of all members of this type, see IReportComponent members.

Public Properties

 | Name | Description
Property | Parent | Gets or sets a parent container.
Top

See Also

Reference

IReportComponent Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponent Interface : Parent Property

Glossary Item Box

Gets or sets a parent container.

Syntax

Visual Basic (Declaration)
Property Parent As IReportComponentContainer
C#
IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer object representing the parent container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponent Interface
IReportComponent Members


IReportComponentContainer Interface

[image]
ActiveReports 19 .NET Edition
IReportComponentContainer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

Glossary Item Box

Represents a report object that can contain other IReportComponent objects.

Syntax

Visual Basic (Declaration)
Public Interface IReportComponentContainer
   Inherits IReportComponent
C#
public interface IReportComponentContainer : IReportComponent

Remarks

This interface extends IReportComponent and provides functionality for containing and managing child report components.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponentContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponentContainer Interface Members

[image]
ActiveReports 19 .NET Edition
IReportComponentContainer Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

Glossary Item Box

The following tables list the members exposed by IReportComponentContainer.

Public Properties

 | Name | Description
Property | Components | Gets the collection of child components contained within the container.
Top

See Also

Reference

IReportComponentContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponentContainer Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportComponentContainer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

Glossary Item Box

For a list of all members of this type, see IReportComponentContainer members.

Public Properties

 | Name | Description
Property | Components | Gets the collection of child components contained within the container.
Top

See Also

Reference

IReportComponentContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property

[image]
ActiveReports 19 .NET Edition
Components Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponentContainer Interface : Components Property

Glossary Item Box

Gets the collection of child components contained within the container.

Syntax

Visual Basic (Declaration)
ReadOnly Property Components As ReportComponentCollection
C#
ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection containing the child components in the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportComponentContainer Interface
IReportComponentContainer Members


IScopeDefinition Interface

[image]
ActiveReports 19 .NET Edition
IScopeDefinition Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface

Glossary Item Box

Represents an object that defines a data scope in the RDL (Report Definition Language) report object model, such as a data region or grouping.

Syntax

Visual Basic (Declaration)
Public Interface IScopeDefinition
C#
public interface IScopeDefinition

Remarks

Some objects, such as CustomReportItem, may represent a scope only based on their settings. As a result, some properties might return default values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScopeDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


IScopeDefinition Interface Members

[image]
ActiveReports 19 .NET Edition
IScopeDefinition Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface

Glossary Item Box

The following tables list the members exposed by IScopeDefinition.

Public Properties

 | Name | Description
Property | ChildScopes | Gets the scope objects that are direct children of this scope.
Property | ParentScope | Gets the parent scope of this scope.
Property | ReportItemsInScope | Gets the report items contained directly within this scope.
Property | ScopeName | Gets the name of this scope.
Top

See Also

Reference

IScopeDefinition Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IScopeDefinition Interface Properties

[image]
ActiveReports 19 .NET Edition
IScopeDefinition Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface

Glossary Item Box

For a list of all members of this type, see IScopeDefinition members.

Public Properties

 | Name | Description
Property | ChildScopes | Gets the scope objects that are direct children of this scope.
Property | ParentScope | Gets the parent scope of this scope.
Property | ReportItemsInScope | Gets the report items contained directly within this scope.
Property | ScopeName | Gets the name of this scope.
Top

See Also

Reference

IScopeDefinition Interface
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property

[image]
ActiveReports 19 .NET Edition
ChildScopes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ChildScopes Property

Glossary Item Box

Gets the scope objects that are direct children of this scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property ChildScopes As IEnumerable
C#
IEnumerable ChildScopes {get;}

Property Value

An System.Collections.IEnumerable of IScopeDefinition object representing the children scopes.

Remarks

This may not be the same set of objects as the child components; it represents the children in terms of RDL scope rules and may be empty if there are no descendant scopes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ParentScope Property

[image]
ActiveReports 19 .NET Edition
ParentScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ParentScope Property

Glossary Item Box

Gets the parent scope of this scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property ParentScope As IScopeDefinition
C#
IScopeDefinition ParentScope {get;}

Property Value

An IScopeDefinition object representing the parent scope.

Remarks

This may not be the same object as the parent component or report item container; it is the parent in terms of RDL scope rules.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ReportItemsInScope Property

[image]
ActiveReports 19 .NET Edition
ReportItemsInScope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ReportItemsInScope Property

Glossary Item Box

Gets the report items contained directly within this scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItemsInScope As IEnumerable
C#
IEnumerable ReportItemsInScope {get;}

Property Value

An System.Collections.IEnumerable of ReportItem object representing the items contained in this scope.

Remarks

These may not be direct descendants of the component/report item this object represents; instead, they are the items considered to be in this scope according to RDL rules.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ScopeName Property

[image]
ActiveReports 19 .NET Edition
ScopeName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ScopeName Property

Glossary Item Box

Gets the name of this scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScopeName As String
C#
string ScopeName {get;}

Property Value

A System.String value indicating the name of the scope.

Remarks

Returns null if the object does not currently represent a scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


IValidateable Interface

[image]
ActiveReports 19 .NET Edition
IValidateable Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IValidateable Interface

Glossary Item Box

Represents a method for validating the current state of an object.

Syntax

Visual Basic (Declaration)
Public Interface IValidateable
C#
public interface IValidateable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValidateable Members
GrapeCity.ActiveReports.PageReportModel Namespace


IValidateable Interface Members

[image]
ActiveReports 19 .NET Edition
IValidateable Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IValidateable Interface

Glossary Item Box

The following tables list the members exposed by IValidateable.

Public Methods

 | Name | Description
Method | Validate | Validates the current state of the object.
Top

See Also

Reference

IValidateable Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IValidateable Interface Methods

[image]
ActiveReports 19 .NET Edition
IValidateable Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IValidateable Interface

Glossary Item Box

For a list of all members of this type, see IValidateable members.

Public Methods

 | Name | Description
Method | Validate | Validates the current state of the object.
Top

See Also

Reference

IValidateable Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IValidateable Interface : Validate Method

context
A ValidationContext object representing the context details during validation.

Glossary Item Box

Validates the current state of the object.

Syntax

Visual Basic (Declaration)
Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
C#
ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
A ValidationContext object representing the context details during validation.

Return Value

An array of ValidationEntry objects representing the information about the validation warnings or failures.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValidateable Interface
IValidateable Members


ExpressionInfoCollectionEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
ExpressionInfoCollectionEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ExpressionInfoCollectionEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles the ExpressionInfoCollection.ItemAdded or ExpressionInfoCollection.ItemRemoved event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ExpressionInfoCollectionEventHandler( _
   ByVal sender As Object, _
   ByVal e As ExpressionInfoCollectionEventArgs _
)
C#
public delegate void ExpressionInfoCollectionEventHandler(
   object sender,
   ExpressionInfoCollectionEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfoCollectionEventHandler Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollectionEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
PageCollectionEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventHandler Delegate

sender
An System.Object representing source of the event.
e
A PageCollectionEventArgs object that contains event data.

Glossary Item Box

Represents a method that handles the PageCollection.ItemAdded event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PageCollectionEventHandler( _
   ByVal sender As Object, _
   ByVal e As PageCollectionEventArgs _
)
C#
public delegate void PageCollectionEventHandler(
   object sender,
   PageCollectionEventArgs e
)

Parameters

sender
An System.Object representing source of the event.
e
A PageCollectionEventArgs object that contains event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCollectionEventHandler Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
ReportItemCollectionEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventHandler Delegate

sender
An System.Object representing source of the event.
e
A ReportItemCollectionEventArgs object that contains event data.

Glossary Item Box

Represents a method that handles the ReportItemCollection.ItemAdded or ReportItemCollection.ItemRemoved event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ReportItemCollectionEventHandler( _
   ByVal sender As Object, _
   ByVal e As ReportItemCollectionEventArgs _
)
C#
public delegate void ReportItemCollectionEventHandler(
   object sender,
   ReportItemCollectionEventArgs e
)

Parameters

sender
An System.Object representing source of the event.
e
A ReportItemCollectionEventArgs object that contains event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemCollectionEventHandler Members
GrapeCity.ActiveReports.PageReportModel Namespace


RomUtils.FromStringConverter<T> Delegate

T
[image]
ActiveReports 19 .NET Edition
RomUtils.FromStringConverter<T> Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RomUtils.FromStringConverter<T> Delegate

stringValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Function RomUtils.FromStringConverter(Of T)( _
   ByVal stringValue As String _
) As T
C#
public delegate T RomUtils.FromStringConverter<T>(
   string stringValue
)

Parameters

stringValue

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RomUtils.FromStringConverter<T> Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationUtils Class

[image]
ActiveReports 19 .NET Edition
ValidationUtils Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace : ValidationUtils Class

Glossary Item Box

Represents a set of methods for validating values of general data types.

Object Model

ValidationUtils Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationUtils
C#
public sealed class ValidationUtils

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Validation.ValidationUtils

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Members
GrapeCity.ActiveReports.PageReportModel.Validation Namespace


ValidationUtils Class Members

[image]
ActiveReports 19 .NET Edition
ValidationUtils Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace : ValidationUtils Class

Glossary Item Box

The following tables list the members exposed by ValidationUtils.

Public Constructors

 | Name | Description
Public Constructor | ValidationUtils Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Validate | Overloaded. Validates a length value against the RDL defined min/max length defaults ("0in","160in").
static (Shared in Visual Basic) | ValidateBoolean | Validates an expression value to make sure any literal booleans can be evaluate to either true or false.
static (Shared in Visual Basic) | ValidateDouble | Overloaded. Validates a double value to make sure it is valid and is within the specified min/max range limit.
static (Shared in Visual Basic) | ValidateEnum | Overloaded. Validates an enum value against the specified type.
static (Shared in Visual Basic) | ValidateInteger | Overloaded. Validates an integer value to make sure it is valid and is within the specified min/max range limit.
static (Shared in Visual Basic) | ValidateLength | Overloaded. Validates a length value to make sure it is valid and is within the specified min/max range limit.
Top

See Also

Reference

ValidationUtils Class
GrapeCity.ActiveReports.PageReportModel.Validation Namespace


ValidationUtils Constructor

[image]
ActiveReports 19 .NET Edition
ValidationUtils Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidationUtils Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ValidationUtils()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidationUtils Class Methods

[image]
ActiveReports 19 .NET Edition
ValidationUtils Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace : ValidationUtils Class

Glossary Item Box

For a list of all members of this type, see ValidationUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Validate | Overloaded. Validates a length value against the RDL defined min/max length defaults ("0in","160in").
static (Shared in Visual Basic) | ValidateBoolean | Validates an expression value to make sure any literal booleans can be evaluate to either true or false.
static (Shared in Visual Basic) | ValidateDouble | Overloaded. Validates a double value to make sure it is valid and is within the specified min/max range limit.
static (Shared in Visual Basic) | ValidateEnum | Overloaded. Validates an enum value against the specified type.
static (Shared in Visual Basic) | ValidateInteger | Overloaded. Validates an integer value to make sure it is valid and is within the specified min/max range limit.
static (Shared in Visual Basic) | ValidateLength | Overloaded. Validates a length value to make sure it is valid and is within the specified min/max range limit.
Top

See Also

Reference

ValidationUtils Class
GrapeCity.ActiveReports.PageReportModel.Validation Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : Validate Method

Glossary Item Box

Validates a length value against the RDL defined min/max length defaults ("0in","160in").

Overload List

Overload | Description
Validate(Length) | Validates a length value against the RDL defined min/max length defaults ("0in","160in").
Validate<T>(T) | Validates a value to make sure it is valid enum value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


Validate(Length) Method

[image]
ActiveReports 19 .NET Edition
Validate(Length) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > Validate Method : Validate(Length) Method

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.

Glossary Item Box

Validates a length value against the RDL defined min/max length defaults ("0in","160in").

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Validate( _
   ByVal value As Length _
) As Length
C#
public static Length Validate(
   Length value
)

Parameters

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


Validate<T>(T) Method

T
[image]
ActiveReports 19 .NET Edition
Validate<T>(T) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > Validate Method : Validate<T>(T) Method

value
A value to validate.

Glossary Item Box

Validates a value to make sure it is valid enum value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Validate(Of T As Enum)( _
   ByVal value As T _
) As T
C#
public static T Validate<T>(
   T value
)
where T: Enum

Parameters

value
A value to validate.

Type Parameters

T

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Throws if the value is not valid enum of Enum type.

Example

C# Copy Code
OrderByCondition value = OrderByCondition.Value;
ValidationUtils.Validate(value);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateBoolean Method

[image]
ActiveReports 19 .NET Edition
ValidateBoolean Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidateBoolean Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.

Glossary Item Box

Validates an expression value to make sure any literal booleans can be evaluate to either true or false.

Syntax

Visual Basic (Declaration)
Public Shared Sub ValidateBoolean( _
   ByVal expression As ExpressionInfo _
)
C#
public static void ValidateBoolean(
   ExpressionInfo expression
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.InvalidBooleanExpressionException | Throws if the value is not evalueted to boolean.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("true");
ValidationUtils.ValidateBoolean(value);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidateDouble Method

[image]
ActiveReports 19 .NET Edition
ValidateDouble Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidateDouble Method

Glossary Item Box

Validates a double value to make sure it is valid and is within the specified min/max range limit.

Overload List

Overload | Description
ValidateDouble(Double,Double,Double) | Validates a double value to make sure it is valid and is within the specified min/max range limit.
ValidateDouble(ExpressionInfo,Double,Double) | Validates an expression value to make sure it is valid and is within the specified min/max values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidateDouble(Double,Double,Double) Method

[image]
ActiveReports 19 .NET Edition
ValidateDouble(Double,Double,Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateDouble Method : ValidateDouble(Double,Double,Double) Method

value
A System.Double value to validate.
min
A System.Double value representing the minimum integer allowed.
max
A System.Double value representing the maximum integer allowed.

Glossary Item Box

Validates a double value to make sure it is valid and is within the specified min/max range limit.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateDouble( _
   ByVal value As Double, _
   ByVal min As Double, _
   ByVal max As Double _
)
C#
public static void ValidateDouble(
   double value,
   double min,
   double max
)

Parameters

value
A System.Double value to validate.
min
A System.Double value representing the minimum integer allowed.
max
A System.Double value representing the maximum integer allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateDouble(ExpressionInfo,Double,Double) Method

[image]
ActiveReports 19 .NET Edition
ValidateDouble(ExpressionInfo,Double,Double) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateDouble Method : ValidateDouble(ExpressionInfo,Double,Double) Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
A System.Double value representing the minimun size allowed.
max
A System.Double value representing the maximum size allowed.

Glossary Item Box

Validates an expression value to make sure it is valid and is within the specified min/max values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateDouble( _
   ByVal expression As ExpressionInfo, _
   ByVal min As Double, _
   ByVal max As Double _
)
C#
public static void ValidateDouble(
   ExpressionInfo expression,
   double min,
   double max
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
A System.Double value representing the minimun size allowed.
max
A System.Double value representing the maximum size allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("2.5");
ValidationUtils.ValidateDouble(value, 0.0d, 5.0d);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateEnum Method

[image]
ActiveReports 19 .NET Edition
ValidateEnum Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidateEnum Method

Glossary Item Box

Validates an enum value against the specified type.

Overload List

Overload | Description
ValidateEnum(Object,Type) | Validates an enum value against the specified type.
ValidateEnum(ExpressionInfo,Type) | Validates an expression value to make sure it is valid enum value and against the specified type.
ValidateEnum(ExpressionInfo,Type,IList<String>) | Validates an expression value to make sure it is valid enum value and against the specified type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidateEnum(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ValidateEnum(Object,Type) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateEnum Method : ValidateEnum(Object,Type) Method

value
An System.Enum value to validate.
type
A System.Type to validate the value against.

Glossary Item Box

Validates an enum value against the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateEnum( _
   ByVal value As Object, _
   ByVal type As Type _
)
C#
public static void ValidateEnum(
   object value,
   Type type
)

Parameters

value
An System.Enum value to validate.
type
A System.Type to validate the value against.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Throws if the value is not against the specified type.

Example

C# Copy Code
BorderDrawingStyle value = BorderDrawingStyle.Solid;
ValidationUtils.ValidateEnum(value, typeof(BorderDrawingStyle));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateEnum(ExpressionInfo,Type) Method

[image]
ActiveReports 19 .NET Edition
ValidateEnum(ExpressionInfo,Type) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateEnum Method : ValidateEnum(ExpressionInfo,Type) Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
type
A System.Type to validate the value against.

Glossary Item Box

Validates an expression value to make sure it is valid enum value and against the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateEnum( _
   ByVal expression As ExpressionInfo, _
   ByVal type As Type _
)
C#
public static void ValidateEnum(
   ExpressionInfo expression,
   Type type
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
type
A System.Type to validate the value against.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Throws if the value is not against the specified type.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("Solid");
ValidationUtils.ValidateEnum(value, typeof(BorderDrawingStyle));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateEnum(ExpressionInfo,Type,IList<String>) Method

[image]
ActiveReports 19 .NET Edition
ValidateEnum(ExpressionInfo,Type,IList<String>) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateEnum Method : ValidateEnum(ExpressionInfo,Type,IList<String>) Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
type
A System.Type to validate the value against.
additionalValues
The additional allowed values.

Glossary Item Box

Validates an expression value to make sure it is valid enum value and against the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateEnum( _
   ByVal expression As ExpressionInfo, _
   ByVal type As Type, _
   ByVal additionalValues As IList(Of String) _
)
C#
public static void ValidateEnum(
   ExpressionInfo expression,
   Type type,
   IList<string> additionalValues
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
type
A System.Type to validate the value against.
additionalValues
The additional allowed values.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Throws if the value is not against the specified type.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("Solid");
ValidationUtils.ValidateEnum(value, typeof(BorderDrawingStyle), new[] { "Transparent"});

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateInteger Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidateInteger Method

Glossary Item Box

Validates an integer value to make sure it is valid and is within the specified min/max range limit.

Overload List

Overload | Description
ValidateInteger(Int32,Int32,Int32) | Validates an integer value to make sure it is valid and is within the specified min/max range limit.
ValidateInteger(Int32) | Validates an integer value to make sure it is valid and is within the specified usual default RDL min/max range limit (0, int.maxvalue).
ValidateInteger(Nullable<Int32>,Int32,Int32) | Validates a nullable integer value to make sure it is valid and is within the specified min/max range limit.
ValidateInteger(Nullable<Int32>) | Validates a nullable integer value to make sure it is valid and is within the specified usual default RDL min/max range limit (0, int.maxvalue).
ValidateInteger(ExpressionInfo,Int32,Int32) | Valiates an expression value to make sure it is valid integer value and is within the specified min/max values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidateInteger(Int32,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger(Int32,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateInteger Method : ValidateInteger(Int32,Int32,Int32) Method

value
An System.Int32 value to validate.
min
An System.Int32 value representing the minimum integer allowed.
max
An System.Int32 value representing the maximum integer allowed.

Glossary Item Box

Validates an integer value to make sure it is valid and is within the specified min/max range limit.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ValidateInteger( _
   ByVal value As Integer, _
   ByVal min As Integer, _
   ByVal max As Integer _
) As Integer
C#
public static int ValidateInteger(
   int value,
   int min,
   int max
)

Parameters

value
An System.Int32 value to validate.
min
An System.Int32 value representing the minimum integer allowed.
max
An System.Int32 value representing the maximum integer allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateInteger(Int32) Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateInteger Method : ValidateInteger(Int32) Method

value
An System.Int32 value to validate.

Glossary Item Box

Validates an integer value to make sure it is valid and is within the specified usual default RDL min/max range limit (0, int.maxvalue).

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ValidateInteger( _
   ByVal value As Integer _
) As Integer
C#
public static int ValidateInteger(
   int value
)

Parameters

value
An System.Int32 value to validate.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateInteger(Nullable<Int32>,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger(Nullable<Int32>,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateInteger Method : ValidateInteger(Nullable<Int32>,Int32,Int32) Method

value
An System.Int32 value to validate.
min
An System.Int32 value representing the minimum integer allowed.
max
An System.Int32 value representing the maximum integer allowed.

Glossary Item Box

Validates a nullable integer value to make sure it is valid and is within the specified min/max range limit.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateInteger( _
   ByVal value As Nullable(Of Integer), _
   ByVal min As Integer, _
   ByVal max As Integer _
)
C#
public static void ValidateInteger(
   Nullable<int> value,
   int min,
   int max
)

Parameters

value
An System.Int32 value to validate.
min
An System.Int32 value representing the minimum integer allowed.
max
An System.Int32 value representing the maximum integer allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateInteger(Nullable<Int32>) Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger(Nullable<Int32>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateInteger Method : ValidateInteger(Nullable<Int32>) Method

value
An System.Int32 value to validate.

Glossary Item Box

Validates a nullable integer value to make sure it is valid and is within the specified usual default RDL min/max range limit (0, int.maxvalue).

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateInteger( _
   ByVal value As Nullable(Of Integer) _
)
C#
public static void ValidateInteger(
   Nullable<int> value
)

Parameters

value
An System.Int32 value to validate.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateInteger(ExpressionInfo,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
ValidateInteger(ExpressionInfo,Int32,Int32) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateInteger Method : ValidateInteger(ExpressionInfo,Int32,Int32) Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
An System.Int32 value representing the minimun size allowed.
max
An System.Int32 value representing the maximum size allowed.

Glossary Item Box

Valiates an expression value to make sure it is valid integer value and is within the specified min/max values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateInteger( _
   ByVal expression As ExpressionInfo, _
   ByVal min As Integer, _
   ByVal max As Integer _
)
C#
public static void ValidateInteger(
   ExpressionInfo expression,
   int min,
   int max
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
An System.Int32 value representing the minimun size allowed.
max
An System.Int32 value representing the maximum size allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("2");
ValidationUtils.ValidateInteger(value, 1, 5);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateLength Method

[image]
ActiveReports 19 .NET Edition
ValidateLength Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class : ValidateLength Method

Glossary Item Box

Validates a length value to make sure it is valid and is within the specified min/max range limit.

Overload List

Overload | Description
ValidateLength(Length,Length,Length,Length[]) | Validates a length value to make sure it is valid and is within the specified min/max range limit.
ValidateLength(Length,Length[]) | Validates a length value against the RDL defined min/max length defaults ("0in","160in").
ValidateLength(Length,Boolean) | Validates a length value against the RDL defined min/max length defaults ("0in","160in").
ValidateLength(ExpressionInfo,Length,Length) | Validates an expression value to make sure it is valid length value and is within the specified min/max range limit.
ValidateLength(ExpressionInfo) | Validates an expression value to make sure it is valid double value and against the RDL defined min/max length defaults ("0in","160in").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members


ValidateLength(Length,Length,Length,Length[]) Method

[image]
ActiveReports 19 .NET Edition
ValidateLength(Length,Length,Length,Length[]) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateLength Method : ValidateLength(Length,Length,Length,Length[]) Method

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
min
A GrapeCity.ActiveReports.PageReportModel.Lengthvalue representing the minimun size allowed.
max
A GrapeCity.ActiveReports.PageReportModel.Lengthvalue representing the maximum size allowed.
extraValues
The additional allowed GrapeCity.ActiveReports.PageReportModel.Length values.

Glossary Item Box

Validates a length value to make sure it is valid and is within the specified min/max range limit.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateLength( _
   ByVal value As Length, _
   ByVal min As Length, _
   ByVal max As Length, _
   ByVal ParamArray extraValues() As Length _
)
C#
public static void ValidateLength(
   Length value,
   Length min,
   Length max,
   params Length[] extraValues
)

Parameters

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
min
A GrapeCity.ActiveReports.PageReportModel.Lengthvalue representing the minimun size allowed.
max
A GrapeCity.ActiveReports.PageReportModel.Lengthvalue representing the maximum size allowed.
extraValues
The additional allowed GrapeCity.ActiveReports.PageReportModel.Length values.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
Length value = new Length("2in");
Length min = new Length("1in");
Length max = new Length("5in");
ValidationUtils.ValidateLength(value, min, max, new Length("0in"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateLength(Length,Length[]) Method

[image]
ActiveReports 19 .NET Edition
ValidateLength(Length,Length[]) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateLength Method : ValidateLength(Length,Length[]) Method

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
extraValues
The additional allowed GrapeCity.ActiveReports.PageReportModel.Length values.

Glossary Item Box

Validates a length value against the RDL defined min/max length defaults ("0in","160in").

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ValidateLength( _
   ByVal value As Length, _
   ByVal ParamArray extraValues() As Length _
) As Length
C#
public static Length ValidateLength(
   Length value,
   params Length[] extraValues
)

Parameters

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
extraValues
The additional allowed GrapeCity.ActiveReports.PageReportModel.Length values.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
Length value = new Length("2in");
ValidationUtils.ValidateLength(value, new Length("200in"));

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateLength(Length,Boolean) Method

[image]
ActiveReports 19 .NET Edition
ValidateLength(Length,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateLength Method : ValidateLength(Length,Boolean) Method

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
hasNoMaxValue
A boolean value indicating if there should be validation against the default max value.

Glossary Item Box

Validates a length value against the RDL defined min/max length defaults ("0in","160in").

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateLength( _
   ByVal value As Length, _
   ByVal hasNoMaxValue As Boolean _
)
C#
public static void ValidateLength(
   Length value,
   bool hasNoMaxValue
)

Parameters

value
A GrapeCity.ActiveReports.PageReportModel.Length value to validate.
hasNoMaxValue
A boolean value indicating if there should be validation against the default max value.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateLength(ExpressionInfo,Length,Length) Method

[image]
ActiveReports 19 .NET Edition
ValidateLength(ExpressionInfo,Length,Length) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateLength Method : ValidateLength(ExpressionInfo,Length,Length) Method

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
A GrapeCity.ActiveReports.PageReportModel.Length value representing the minium size allowed.
max
A GrapeCity.ActiveReports.PageReportModel.Length value representing the maximum size allowed.

Glossary Item Box

Validates an expression value to make sure it is valid length value and is within the specified min/max range limit.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateLength( _
   ByVal expression As ExpressionInfo, _
   ByVal min As Length, _
   ByVal max As Length _
)
C#
public static void ValidateLength(
   ExpressionInfo expression,
   Length min,
   Length max
)

Parameters

expression
An GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.
min
A GrapeCity.ActiveReports.PageReportModel.Length value representing the minium size allowed.
max
A GrapeCity.ActiveReports.PageReportModel.Length value representing the maximum size allowed.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("2in");
Length min = new Length("1in");
Length max = new Length("5in");
ValidationUtils.ValidateLength(value, min, max);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ValidateLength(ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
ValidateLength(ExpressionInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.PageReportModel.Validation Namespace > ValidationUtils Class > ValidateLength Method : ValidateLength(ExpressionInfo) Method

expression
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.

Glossary Item Box

Validates an expression value to make sure it is valid double value and against the RDL defined min/max length defaults ("0in","160in").

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ValidateLength( _
   ByVal expression As ExpressionInfo _
)
C#
public static void ValidateLength(
   ExpressionInfo expression
)

Parameters

expression
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo value to validate.

Exceptions

Exception | Description
GrapeCity.ActiveReports.PageReportModel.ReportDefinitionException | Throws if the value is out of range limit.

Example

C# Copy Code
ExpressionInfo value = ExpressionInfo.FromString("2in");
ValidationUtils.ValidateLength(value);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationUtils Class
ValidationUtils Members
Overload List


ExpressionBaseTypeAttribute Class

[image]
ActiveReports 19 .NET Edition
ExpressionBaseTypeAttribute Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : ExpressionBaseTypeAttribute Class

Glossary Item Box

Represents the base type of an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo property that is useful for other type converters to know the underlying type of the expression.

Object Model

ExpressionBaseTypeAttribute Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionBaseTypeAttribute
   Inherits System.Attribute
C#
public sealed class ExpressionBaseTypeAttribute : System.Attribute

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Rdl.ExpressionBaseTypeAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionBaseTypeAttribute Members
GrapeCity.ActiveReports.Rdl Namespace


ExpressionBaseTypeAttribute Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionBaseTypeAttribute Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : ExpressionBaseTypeAttribute Class

Glossary Item Box

The following tables list the members exposed by ExpressionBaseTypeAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExpressionBaseTypeAttribute Constructor | Initializes a new instance of the ExpressionBaseTypeAttribute class.
Top

Public Properties

 | Name | Description
Public Property | BaseType | Gets a base type of the underlying property.
Top

See Also

Reference

ExpressionBaseTypeAttribute Class
GrapeCity.ActiveReports.Rdl Namespace


ExpressionBaseTypeAttribute Constructor

[image]
ActiveReports 19 .NET Edition
ExpressionBaseTypeAttribute Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace > ExpressionBaseTypeAttribute Class : ExpressionBaseTypeAttribute Constructor

baseType
A System.Type object representing a base value type.

Glossary Item Box

Initializes a new instance of the ExpressionBaseTypeAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal baseType As Type _
)
C#
public ExpressionBaseTypeAttribute(
   Type baseType
)

Parameters

baseType
A System.Type object representing a base value type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionBaseTypeAttribute Class
ExpressionBaseTypeAttribute Members


ExpressionBaseTypeAttribute Class Properties

[image]
ActiveReports 19 .NET Edition
ExpressionBaseTypeAttribute Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : ExpressionBaseTypeAttribute Class

Glossary Item Box

For a list of all members of this type, see ExpressionBaseTypeAttribute members.

Public Properties

 | Name | Description
Public Property | BaseType | Gets a base type of the underlying property.
Top

See Also

Reference

ExpressionBaseTypeAttribute Class
GrapeCity.ActiveReports.Rdl Namespace


BaseType Property

[image]
ActiveReports 19 .NET Edition
BaseType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace > ExpressionBaseTypeAttribute Class : BaseType Property

Glossary Item Box

Gets a base type of the underlying property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As Type
C#
public Type BaseType {get;}

Property Value

A System.Type object representing the base type of the property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionBaseTypeAttribute Class
ExpressionBaseTypeAttribute Members


MasterMerge Class

[image]
ActiveReports 19 .NET Edition
MasterMerge Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : MasterMerge Class

Glossary Item Box

Represents a master report utility class that handles the merging and unmerging of master and child reports.

Object Model

MasterMerge Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MasterMerge
C#
public static class MasterMerge

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.MasterMerge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterMerge Members
GrapeCity.ActiveReports.Rdl Namespace


MasterMerge Class Members

[image]
ActiveReports 19 .NET Edition
MasterMerge Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : MasterMerge Class

Glossary Item Box

The following tables list the members exposed by MasterMerge.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CopyContentPlaceHolders | Copies a ContentPlaceHolders from master GrapeCity.ActiveReports.PageReportModel.Report object to the target GrapeCity.ActiveReports.PageReportModel.Report object.
static (Shared in Visual Basic) | MergeSourceIntoTarget | Merges a source GrapeCity.ActiveReports.PageReportModel.Report object with the contents of the target GrapeCity.ActiveReports.PageReportModel.Report object.
static (Shared in Visual Basic) | UnmergeCombinedReport | Unmerges a combined master-child GrapeCity.ActiveReports.PageReportModel.Report object and strips out only the relevant information for the child GrapeCity.ActiveReports.PageReportModel.Report object.
Top

See Also

Reference

MasterMerge Class
GrapeCity.ActiveReports.Rdl Namespace


MasterMerge Class Methods

[image]
ActiveReports 19 .NET Edition
MasterMerge Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace : MasterMerge Class

Glossary Item Box

For a list of all members of this type, see MasterMerge members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CopyContentPlaceHolders | Copies a ContentPlaceHolders from master GrapeCity.ActiveReports.PageReportModel.Report object to the target GrapeCity.ActiveReports.PageReportModel.Report object.
static (Shared in Visual Basic) | MergeSourceIntoTarget | Merges a source GrapeCity.ActiveReports.PageReportModel.Report object with the contents of the target GrapeCity.ActiveReports.PageReportModel.Report object.
static (Shared in Visual Basic) | UnmergeCombinedReport | Unmerges a combined master-child GrapeCity.ActiveReports.PageReportModel.Report object and strips out only the relevant information for the child GrapeCity.ActiveReports.PageReportModel.Report object.
Top

See Also

Reference

MasterMerge Class
GrapeCity.ActiveReports.Rdl Namespace


CopyContentPlaceHolders(Report,Report) Method

[image]
ActiveReports 19 .NET Edition
CopyContentPlaceHolders(Report,Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace > MasterMerge Class : CopyContentPlaceHolders(Report,Report) Method

masterReport
A GrapeCity.ActiveReports.PageReportModel.Report object to copy from.
targetReport
A GrapeCity.ActiveReports.PageReportModel.Report object to copy into.

Glossary Item Box

Copies a ContentPlaceHolders from master GrapeCity.ActiveReports.PageReportModel.Report object to the target GrapeCity.ActiveReports.PageReportModel.Report object.

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyContentPlaceHolders( _
   ByVal masterReport As Report, _
   ByVal targetReport As Report _
)
C#
public static void CopyContentPlaceHolders(
   Report masterReport,
   Report targetReport
)

Parameters

masterReport
A GrapeCity.ActiveReports.PageReportModel.Report object to copy from.
targetReport
A GrapeCity.ActiveReports.PageReportModel.Report object to copy into.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Report object with the results of the merged reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterMerge Class
MasterMerge Members


MergeSourceIntoTarget Method

[image]
ActiveReports 19 .NET Edition
MergeSourceIntoTarget Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace > MasterMerge Class : MergeSourceIntoTarget Method

targetReport
A GrapeCity.ActiveReports.PageReportModel.Report object to merge the source report into.
sourceReport
A GrapeCity.ActiveReports.PageReportModel.Report object containing the content to merge into the target.

Glossary Item Box

Merges a source GrapeCity.ActiveReports.PageReportModel.Report object with the contents of the target GrapeCity.ActiveReports.PageReportModel.Report object.

Syntax

Visual Basic (Declaration)
Public Shared Sub MergeSourceIntoTarget( _
   ByVal targetReport As Report, _
   ByVal sourceReport As Report _
)
C#
public static void MergeSourceIntoTarget(
   Report targetReport,
   Report sourceReport
)

Parameters

targetReport
A GrapeCity.ActiveReports.PageReportModel.Report object to merge the source report into.
sourceReport
A GrapeCity.ActiveReports.PageReportModel.Report object containing the content to merge into the target.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterMerge Class
MasterMerge Members


UnmergeCombinedReport Method

[image]
ActiveReports 19 .NET Edition
UnmergeCombinedReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl Namespace > MasterMerge Class : UnmergeCombinedReport Method

combinedReport
A GrapeCity.ActiveReports.PageReportModel.Report object containing the combined master and child content.
contentService
A GrapeCity.ActiveReports.PageReportModel.IMasterContentService object used to help identify what content belongs to the master and child.

Glossary Item Box

Unmerges a combined master-child GrapeCity.ActiveReports.PageReportModel.Report object and strips out only the relevant information for the child GrapeCity.ActiveReports.PageReportModel.Report object.

Syntax

Visual Basic (Declaration)
Public Shared Function UnmergeCombinedReport( _
   ByVal combinedReport As Report, _
   ByVal contentService As IMasterContentService _
) As Report
C#
public static Report UnmergeCombinedReport(
   Report combinedReport,
   IMasterContentService contentService
)

Parameters

combinedReport
A GrapeCity.ActiveReports.PageReportModel.Report object containing the combined master and child content.
contentService
A GrapeCity.ActiveReports.PageReportModel.IMasterContentService object used to help identify what content belongs to the master and child.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Report object containing only the stripped out content belonging to the child report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MasterMerge Class
MasterMerge Members


ActionParameterSerializer Class

[image]
ActiveReports 19 .NET Edition
ActionParameterSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionParameterSerializer Class

Glossary Item Box

Object Model

ActionParameterSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ActionParameterSerializer
C#
public static class ActionParameterSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.ActionParameterSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionParameterSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ActionParameterSerializer Class Members

[image]
ActiveReports 19 .NET Edition
ActionParameterSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionParameterSerializer Class

Glossary Item Box

The following tables list the members exposed by ActionParameterSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ActionParameterSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ActionParameterSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
ActionParameterSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionParameterSerializer Class

Glossary Item Box

For a list of all members of this type, see ActionParameterSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ActionParameterSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > ActionParameterSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionParameterSerializer Class
ActionParameterSerializer Members


ActionSerializer Class

[image]
ActiveReports 19 .NET Edition
ActionSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionSerializer Class

Glossary Item Box

Object Model

ActionSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ActionSerializer
C#
public static class ActionSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.ActionSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ActionSerializer Class Members

[image]
ActiveReports 19 .NET Edition
ActionSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionSerializer Class

Glossary Item Box

The following tables list the members exposed by ActionSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ActionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ActionSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
ActionSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ActionSerializer Class

Glossary Item Box

For a list of all members of this type, see ActionSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ActionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > ActionSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionSerializer Class
ActionSerializer Members


ApplyParametersActionSerializer Class

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParametersActionSerializer Class

Glossary Item Box

Object Model

ApplyParametersActionSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ApplyParametersActionSerializer
C#
public static class ApplyParametersActionSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.ApplyParametersActionSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ApplyParametersActionSerializer Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParametersActionSerializer Class

Glossary Item Box

The following tables list the members exposed by ApplyParametersActionSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ApplyParametersActionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ApplyParametersActionSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParametersActionSerializer Class

Glossary Item Box

For a list of all members of this type, see ApplyParametersActionSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ApplyParametersActionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > ApplyParametersActionSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionSerializer Class
ApplyParametersActionSerializer Members


ApplyParameterSerializer Class

[image]
ActiveReports 19 .NET Edition
ApplyParameterSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParameterSerializer Class

Glossary Item Box

Object Model

ApplyParameterSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ApplyParameterSerializer
C#
public static class ApplyParameterSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.ApplyParameterSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameterSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ApplyParameterSerializer Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParameterSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParameterSerializer Class

Glossary Item Box

The following tables list the members exposed by ApplyParameterSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ApplyParameterSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


ApplyParameterSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
ApplyParameterSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : ApplyParameterSerializer Class

Glossary Item Box

For a list of all members of this type, see ApplyParameterSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

ApplyParameterSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > ApplyParameterSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParameterSerializer Class
ApplyParameterSerializer Members


CustomPropertyDefinitionSerializer Class

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : CustomPropertyDefinitionSerializer Class

Glossary Item Box

Object Model

CustomPropertyDefinitionSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CustomPropertyDefinitionSerializer
C#
public static class CustomPropertyDefinitionSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.CustomPropertyDefinitionSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


CustomPropertyDefinitionSerializer Class Members

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : CustomPropertyDefinitionSerializer Class

Glossary Item Box

The following tables list the members exposed by CustomPropertyDefinitionSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

CustomPropertyDefinitionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


CustomPropertyDefinitionSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
CustomPropertyDefinitionSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : CustomPropertyDefinitionSerializer Class

Glossary Item Box

For a list of all members of this type, see CustomPropertyDefinitionSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

CustomPropertyDefinitionSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > CustomPropertyDefinitionSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyDefinitionSerializer Class
CustomPropertyDefinitionSerializer Members


DataSetParametersSerializer Class

[image]
ActiveReports 19 .NET Edition
DataSetParametersSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DataSetParametersSerializer Class

Glossary Item Box

Object Model

DataSetParametersSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataSetParametersSerializer
C#
public static class DataSetParametersSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.DataSetParametersSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetParametersSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


DataSetParametersSerializer Class Members

[image]
ActiveReports 19 .NET Edition
DataSetParametersSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DataSetParametersSerializer Class

Glossary Item Box

The following tables list the members exposed by DataSetParametersSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

DataSetParametersSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


DataSetParametersSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
DataSetParametersSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DataSetParametersSerializer Class

Glossary Item Box

For a list of all members of this type, see DataSetParametersSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

DataSetParametersSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > DataSetParametersSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetParametersSerializer Class
DataSetParametersSerializer Members


DrillthroughSerializer Class

[image]
ActiveReports 19 .NET Edition
DrillthroughSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DrillthroughSerializer Class

Glossary Item Box

Object Model

DrillthroughSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DrillthroughSerializer
C#
public static class DrillthroughSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.DrillthroughSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


DrillthroughSerializer Class Members

[image]
ActiveReports 19 .NET Edition
DrillthroughSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DrillthroughSerializer Class

Glossary Item Box

The following tables list the members exposed by DrillthroughSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

DrillthroughSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


DrillthroughSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
DrillthroughSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : DrillthroughSerializer Class

Glossary Item Box

For a list of all members of this type, see DrillthroughSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

DrillthroughSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > DrillthroughSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughSerializer Class
DrillthroughSerializer Members


FiltersSerializer Class

[image]
ActiveReports 19 .NET Edition
FiltersSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : FiltersSerializer Class

Glossary Item Box

Object Model

FiltersSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FiltersSerializer
C#
public static class FiltersSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.FiltersSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FiltersSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


FiltersSerializer Class Members

[image]
ActiveReports 19 .NET Edition
FiltersSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : FiltersSerializer Class

Glossary Item Box

The following tables list the members exposed by FiltersSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

FiltersSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


FiltersSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
FiltersSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : FiltersSerializer Class

Glossary Item Box

For a list of all members of this type, see FiltersSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

FiltersSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > FiltersSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FiltersSerializer Class
FiltersSerializer Members


GroupingSerializer Class

[image]
ActiveReports 19 .NET Edition
GroupingSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : GroupingSerializer Class

Glossary Item Box

Object Model

GroupingSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class GroupingSerializer
C#
public static class GroupingSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.GroupingSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupingSerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


GroupingSerializer Class Members

[image]
ActiveReports 19 .NET Edition
GroupingSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : GroupingSerializer Class

Glossary Item Box

The following tables list the members exposed by GroupingSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

GroupingSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


GroupingSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
GroupingSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : GroupingSerializer Class

Glossary Item Box

For a list of all members of this type, see GroupingSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

GroupingSerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > GroupingSerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupingSerializer Class
GroupingSerializer Members


SortBySerializer Class

[image]
ActiveReports 19 .NET Edition
SortBySerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : SortBySerializer Class

Glossary Item Box

Object Model

SortBySerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SortBySerializer
C#
public static class SortBySerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.SortBySerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBySerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


SortBySerializer Class Members

[image]
ActiveReports 19 .NET Edition
SortBySerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : SortBySerializer Class

Glossary Item Box

The following tables list the members exposed by SortBySerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

SortBySerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


SortBySerializer Class Methods

[image]
ActiveReports 19 .NET Edition
SortBySerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : SortBySerializer Class

Glossary Item Box

For a list of all members of this type, see SortBySerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

SortBySerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > SortBySerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortBySerializer Class
SortBySerializer Members


VisibilitySerializer Class

[image]
ActiveReports 19 .NET Edition
VisibilitySerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : VisibilitySerializer Class

Glossary Item Box

Object Model

VisibilitySerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class VisibilitySerializer
C#
public static class VisibilitySerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Extensibility.XML.VisibilitySerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VisibilitySerializer Members
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


VisibilitySerializer Class Members

[image]
ActiveReports 19 .NET Edition
VisibilitySerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : VisibilitySerializer Class

Glossary Item Box

The following tables list the members exposed by VisibilitySerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

VisibilitySerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


VisibilitySerializer Class Methods

[image]
ActiveReports 19 .NET Edition
VisibilitySerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace : VisibilitySerializer Class

Glossary Item Box

For a list of all members of this type, see VisibilitySerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Top

See Also

Reference

VisibilitySerializer Class
GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Extensibility.XML Namespace > VisibilitySerializer Class : Create Method

xmlNameSpace

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal xmlNameSpace As String _
) As IXmlItemSerializer
C#
public static IXmlItemSerializer Create(
   string xmlNameSpace
)

Parameters

xmlNameSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VisibilitySerializer Class
VisibilitySerializer Members


ChartImportOptions Class

[image]
ActiveReports 19 .NET Edition
ChartImportOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ChartImportOptions Class

Glossary Item Box

Represents the RDL import options for charts.

Object Model

ChartImportOptions Class

Syntax

Visual Basic (Declaration)
Public Class ChartImportOptions
C#
public class ChartImportOptions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Import.ChartImportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImportOptions Members
GrapeCity.ActiveReports.Rdl.Import Namespace


ChartImportOptions Class Members

[image]
ActiveReports 19 .NET Edition
ChartImportOptions Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ChartImportOptions Class

Glossary Item Box

The following tables list the members exposed by ChartImportOptions.

Public Constructors

 | Name | Description
Public Constructor | ChartImportOptions Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConvertToDV | Gets or sets a value indicating whether RDL charts should be converted to DV charts.
Top

See Also

Reference

ChartImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ChartImportOptions Constructor

[image]
ActiveReports 19 .NET Edition
ChartImportOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ChartImportOptions Class : ChartImportOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartImportOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImportOptions Class
ChartImportOptions Members


ChartImportOptions Class Fields

[image]
ActiveReports 19 .NET Edition
ChartImportOptions Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ChartImportOptions Class

Glossary Item Box

For a list of all members of this type, see ChartImportOptions members.

Public Fields

 | Name | Description
Public Field | ConvertToDV | Gets or sets a value indicating whether RDL charts should be converted to DV charts.
Top

See Also

Reference

ChartImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ConvertToDV Field

[image]
ActiveReports 19 .NET Edition
ConvertToDV Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ChartImportOptions Class : ConvertToDV Field

Glossary Item Box

Gets or sets a value indicating whether RDL charts should be converted to DV charts.

Syntax

Visual Basic (Declaration)
Public ConvertToDV As Boolean
C#
public bool ConvertToDV

Field Value

A System.Boolean value. true if RDL charts should be converted to DV charts; otherwise, false and charts are skipped.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImportOptions Class
ChartImportOptions Members


ImportOptions Class

[image]
ActiveReports 19 .NET Edition
ImportOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ImportOptions Class

Glossary Item Box

Represents the RDL import options.

Object Model

ImportOptions Class

Syntax

Visual Basic (Declaration)
Public Class ImportOptions
C#
public class ImportOptions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Import.ImportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Members
GrapeCity.ActiveReports.Rdl.Import Namespace


ImportOptions Class Members

[image]
ActiveReports 19 .NET Edition
ImportOptions Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ImportOptions Class

Glossary Item Box

The following tables list the members exposed by ImportOptions.

Public Constructors

 | Name | Description
Public Constructor | ImportOptions Constructor |
Top

Public Fields

 | Name | Description
Public Field | ChartOptions | Gets or sets the options for importing charts.
Public Field | TablixOptions | Gets or sets the options for importing tablixes.
Public Field | TextBoxOptions | Gets or sets the options for importing text boxes.
Public Field | Version | Gets or sets the options for importing text boxes.
Top

See Also

Reference

ImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ImportOptions Constructor

[image]
ActiveReports 19 .NET Edition
ImportOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ImportOptions Class : ImportOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImportOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Class
ImportOptions Members


ImportOptions Class Fields

[image]
ActiveReports 19 .NET Edition
ImportOptions Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : ImportOptions Class

Glossary Item Box

For a list of all members of this type, see ImportOptions members.

Public Fields

 | Name | Description
Public Field | ChartOptions | Gets or sets the options for importing charts.
Public Field | TablixOptions | Gets or sets the options for importing tablixes.
Public Field | TextBoxOptions | Gets or sets the options for importing text boxes.
Public Field | Version | Gets or sets the options for importing text boxes.
Top

See Also

Reference

ImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ChartOptions Field

[image]
ActiveReports 19 .NET Edition
ChartOptions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ImportOptions Class : ChartOptions Field

Glossary Item Box

Gets or sets the options for importing charts.

Syntax

Visual Basic (Declaration)
Public ChartOptions As ChartImportOptions
C#
public ChartImportOptions ChartOptions

Field Value

A TextBoxImportOptions object representing the import options for charts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Class
ImportOptions Members


TablixOptions Field

[image]
ActiveReports 19 .NET Edition
TablixOptions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ImportOptions Class : TablixOptions Field

Glossary Item Box

Gets or sets the options for importing tablixes.

Syntax

Visual Basic (Declaration)
Public TablixOptions As TablixImportOptions
C#
public TablixImportOptions TablixOptions

Field Value

A TextBoxImportOptions object representing the import options for tablixes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Class
ImportOptions Members


TextBoxOptions Field

[image]
ActiveReports 19 .NET Edition
TextBoxOptions Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ImportOptions Class : TextBoxOptions Field

Glossary Item Box

Gets or sets the options for importing text boxes.

Syntax

Visual Basic (Declaration)
Public TextBoxOptions As TextBoxImportOptions
C#
public TextBoxImportOptions TextBoxOptions

Field Value

A TextBoxImportOptions object representing the import options for text boxes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Class
ImportOptions Members


Version Field

[image]
ActiveReports 19 .NET Edition
Version Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > ImportOptions Class : Version Field

Glossary Item Box

Gets or sets the options for importing text boxes.

Syntax

Visual Basic (Declaration)
Public Version As RdlVersion
C#
public RdlVersion Version

Field Value

A TextBoxImportOptions object representing the import options for text boxes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImportOptions Class
ImportOptions Members


TablixImportOptions Class

[image]
ActiveReports 19 .NET Edition
TablixImportOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TablixImportOptions Class

Glossary Item Box

Represents the RDL import options for tablixes.

Object Model

TablixImportOptions Class

Syntax

Visual Basic (Declaration)
Public Class TablixImportOptions
C#
public class TablixImportOptions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Import.TablixImportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixImportOptions Members
GrapeCity.ActiveReports.Rdl.Import Namespace


TablixImportOptions Class Members

[image]
ActiveReports 19 .NET Edition
TablixImportOptions Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TablixImportOptions Class

Glossary Item Box

The following tables list the members exposed by TablixImportOptions.

Public Constructors

 | Name | Description
Public Constructor | TablixImportOptions Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConversionType | Gets or sets the conversion type for tablixes.
Public Field | CoversionType | Gets or sets the conversion type for tablixes.
Top

See Also

Reference

TablixImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


TablixImportOptions Constructor

[image]
ActiveReports 19 .NET Edition
TablixImportOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TablixImportOptions Class : TablixImportOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TablixImportOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixImportOptions Class
TablixImportOptions Members


TablixImportOptions Class Fields

[image]
ActiveReports 19 .NET Edition
TablixImportOptions Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TablixImportOptions Class

Glossary Item Box

For a list of all members of this type, see TablixImportOptions members.

Public Fields

 | Name | Description
Public Field | ConversionType | Gets or sets the conversion type for tablixes.
Public Field | CoversionType | Gets or sets the conversion type for tablixes.
Top

See Also

Reference

TablixImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ConversionType Field

[image]
ActiveReports 19 .NET Edition
ConversionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TablixImportOptions Class : ConversionType Field

Glossary Item Box

Gets or sets the conversion type for tablixes.

Syntax

Visual Basic (Declaration)
Public ConversionType As TablixConversionType
C#
public TablixConversionType ConversionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixImportOptions Class
TablixImportOptions Members


CoversionType Field

[image]
ActiveReports 19 .NET Edition
CoversionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TablixImportOptions Class : CoversionType Field

Glossary Item Box

Gets or sets the conversion type for tablixes.

Syntax

Visual Basic (Declaration)
Public CoversionType As TablixConversionType
C#
public TablixConversionType CoversionType

Remarks

Please update your code to use ConversionType instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixImportOptions Class
TablixImportOptions Members


TextBoxImportOptions Class

[image]
ActiveReports 19 .NET Edition
TextBoxImportOptions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TextBoxImportOptions Class

Glossary Item Box

Represents the RDL import options for text boxes.

Object Model

TextBoxImportOptions Class

Syntax

Visual Basic (Declaration)
Public Class TextBoxImportOptions
C#
public class TextBoxImportOptions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Import.TextBoxImportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxImportOptions Members
GrapeCity.ActiveReports.Rdl.Import Namespace


TextBoxImportOptions Class Members

[image]
ActiveReports 19 .NET Edition
TextBoxImportOptions Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TextBoxImportOptions Class

Glossary Item Box

The following tables list the members exposed by TextBoxImportOptions.

Public Constructors

 | Name | Description
Public Constructor | TextBoxImportOptions Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConversionType | Gets or sets the conversion type for text boxes.
Public Field | CoversionType | Gets or sets the conversion type for text boxes.
Top

See Also

Reference

TextBoxImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


TextBoxImportOptions Constructor

[image]
ActiveReports 19 .NET Edition
TextBoxImportOptions Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TextBoxImportOptions Class : TextBoxImportOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextBoxImportOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxImportOptions Class
TextBoxImportOptions Members


TextBoxImportOptions Class Fields

[image]
ActiveReports 19 .NET Edition
TextBoxImportOptions Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TextBoxImportOptions Class

Glossary Item Box

For a list of all members of this type, see TextBoxImportOptions members.

Public Fields

 | Name | Description
Public Field | ConversionType | Gets or sets the conversion type for text boxes.
Public Field | CoversionType | Gets or sets the conversion type for text boxes.
Top

See Also

Reference

TextBoxImportOptions Class
GrapeCity.ActiveReports.Rdl.Import Namespace


ConversionType Field

[image]
ActiveReports 19 .NET Edition
ConversionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TextBoxImportOptions Class : ConversionType Field

Glossary Item Box

Gets or sets the conversion type for text boxes.

Syntax

Visual Basic (Declaration)
Public ConversionType As TextBoxConversionType
C#
public TextBoxConversionType ConversionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxImportOptions Class
TextBoxImportOptions Members


CoversionType Field

[image]
ActiveReports 19 .NET Edition
CoversionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace > TextBoxImportOptions Class : CoversionType Field

Glossary Item Box

Gets or sets the conversion type for text boxes.

Syntax

Visual Basic (Declaration)
Public CoversionType As TextBoxConversionType
C#
public TextBoxConversionType CoversionType

Remarks

Please update your code to use ConversionType instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoxImportOptions Class
TextBoxImportOptions Members


RdlVersion Enumeration

[image]
ActiveReports 19 .NET Edition
RdlVersion Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : RdlVersion Enumeration

Glossary Item Box

Specifies the result file format version.

Syntax

Visual Basic (Declaration)
Public Enum RdlVersion
   Inherits System.Enum
C#
public enum RdlVersion : System.Enum

Members

Member | Description
Rdl2005 | Legacy (since AR17) RDL 2005.
Rdl2011 | Modern multi-section rdl reports.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Import.RdlVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Import Namespace


TablixConversionType Enumeration

[image]
ActiveReports 19 .NET Edition
TablixConversionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TablixConversionType Enumeration

Glossary Item Box

Specifies the conversion type for tablixes.

Syntax

Visual Basic (Declaration)
Public Enum TablixConversionType
   Inherits System.Enum
C#
public enum TablixConversionType : System.Enum

Members

Member | Description
Default | Convert RDL tablix to AR tablix
SmartConvert | Check if RDL tablix is table or list and try to convert it to AR table/list

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Import.TablixConversionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Import Namespace


TextBoxConversionType Enumeration

[image]
ActiveReports 19 .NET Edition
TextBoxConversionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Import Namespace : TextBoxConversionType Enumeration

Glossary Item Box

Specifies the conversion type for text boxes.

Syntax

Visual Basic (Declaration)
Public Enum TextBoxConversionType
   Inherits System.Enum
C#
public enum TextBoxConversionType : System.Enum

Members

Member | Description
ConvertAll | All text boxes are converted to formatted text.
None | RDL text box is converted to AR text box with loss of paragraph and textrun settings.
SmartConvert | Only complicated text boxes are converted to formatted text; simple single line text boxes are left untouched.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Import.TextBoxConversionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Import Namespace


ReportJsonSerializer Class

[image]
ActiveReports 19 .NET Edition
ReportJsonSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonSerializer Class

Glossary Item Box

Represents a set of methods for serializing and deserializing GrapeCity.ActiveReports.PageReportModel.Report objects to and from JSON format.

Object Model

ReportJsonSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportJsonSerializer
C#
public static class ReportJsonSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.ReportJsonSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Members
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonSerializer Class Members

[image]
ActiveReports 19 .NET Edition
ReportJsonSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonSerializer Class

Glossary Item Box

The following tables list the members exposed by ReportJsonSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DeserializeAsync<T> | Deserializes an object of the specified type from the report definition model.
static (Shared in Visual Basic) | GetSerializerOptions | Creates a System.Text.Json.JsonSerializerOptions object for serializing and deserializing GrapeCity.ActiveReports.PageReportModel.Report objects.
static (Shared in Visual Basic) | Save | Overloaded. Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified file.
static (Shared in Visual Basic) | Serialize | Serializes a specified GrapeCity.ActiveReports.PageReportModel.Report object to a JSON string.
Top

See Also

Reference

ReportJsonSerializer Class
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
ReportJsonSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonSerializer Class

Glossary Item Box

For a list of all members of this type, see ReportJsonSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DeserializeAsync<T> | Deserializes an object of the specified type from the report definition model.
static (Shared in Visual Basic) | GetSerializerOptions | Creates a System.Text.Json.JsonSerializerOptions object for serializing and deserializing GrapeCity.ActiveReports.PageReportModel.Report objects.
static (Shared in Visual Basic) | Save | Overloaded. Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified file.
static (Shared in Visual Basic) | Serialize | Serializes a specified GrapeCity.ActiveReports.PageReportModel.Report object to a JSON string.
Top

See Also

Reference

ReportJsonSerializer Class
GrapeCity.ActiveReports.Rdl.Json Namespace


DeserializeAsync<T> Method

T
The type of the object to deserialize.
[image]
ActiveReports 19 .NET Edition
DeserializeAsync<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class : DeserializeAsync<T> Method

utf8Stream
A System.IO.Stream containing the JSON data in UTF-8 format.

Glossary Item Box

Deserializes an object of the specified type from the report definition model.

Syntax

Visual Basic (Declaration)
Public Shared Function DeserializeAsync(Of T)( _
   ByVal utf8Stream As Stream _
) As Task(Of T)
C#
public static Task<T> DeserializeAsync<T>(
   Stream utf8Stream
)

Parameters

utf8Stream
A System.IO.Stream containing the JSON data in UTF-8 format.

Type Parameters

T
The type of the object to deserialize.

Return Value

A task representing the asynchronous operation, with a result of the deserialized object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members


GetSerializerOptions Method

[image]
ActiveReports 19 .NET Edition
GetSerializerOptions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class : GetSerializerOptions Method

formatted
A System.Boolean value indicating whether the JSON should be formatted for readability. Default is false.

Glossary Item Box

Creates a System.Text.Json.JsonSerializerOptions object for serializing and deserializing GrapeCity.ActiveReports.PageReportModel.Report objects.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSerializerOptions( _
   Optional ByVal formatted As Boolean _
) As JsonSerializerOptions
C#
public static JsonSerializerOptions GetSerializerOptions(
   bool formatted
)

Parameters

formatted
A System.Boolean value indicating whether the JSON should be formatted for readability. Default is false.

Return Value

A System.Text.Json.JsonSerializerOptions object configured for GrapeCity.ActiveReports.PageReportModel.Report serialization.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class : Save Method

Glossary Item Box

Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified file.

Overload List

Overload | Description
Save(Report,FileInfo) | Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified file.
Save(Report,Stream) | Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members


Save(Report,FileInfo) Method

[image]
ActiveReports 19 .NET Edition
Save(Report,FileInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class > Save Method : Save(Report,FileInfo) Method

report
A GrapeCity.ActiveReports.PageReportModel.Report instance to be serialized.
file
A file where the serialized JSON will be written.

Glossary Item Box

Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Save( _
   ByVal report As Report, _
   ByVal file As FileInfo _
)
C#
public static void Save(
   Report report,
   FileInfo file
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report instance to be serialized.
file
A file where the serialized JSON will be written.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members
Overload List


Save(Report,Stream) Method

[image]
ActiveReports 19 .NET Edition
Save(Report,Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class > Save Method : Save(Report,Stream) Method

report
A GrapeCity.ActiveReports.PageReportModel.Report instance to be serialized.
output
A System.IO.Stream where the serialized JSON will be written.

Glossary Item Box

Serializes a GrapeCity.ActiveReports.PageReportModel.Report to JSON and writes it to a specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Save( _
   ByVal report As Report, _
   ByVal output As Stream _
)
C#
public static void Save(
   Report report,
   Stream output
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report instance to be serialized.
output
A System.IO.Stream where the serialized JSON will be written.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members
Overload List


Serialize Method

[image]
ActiveReports 19 .NET Edition
Serialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonSerializer Class : Serialize Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to be serialized.

Glossary Item Box

Serializes a specified GrapeCity.ActiveReports.PageReportModel.Report object to a JSON string.

Syntax

Visual Basic (Declaration)
Public Shared Function Serialize( _
   ByVal report As Report _
) As String
C#
public static string Serialize(
   Report report
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to be serialized.

Return Value

A JSON System.String representing the serialized report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonSerializer Class
ReportJsonSerializer Members


ReportJsonTemplateBuilder Class

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder Class

Glossary Item Box

Represents the tools for building single bundle with GrapeCity.ActiveReports.PageReportModel.Report, its subreports and resources.

Object Model

ReportJsonTemplateBuilder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportJsonTemplateBuilder
C#
public static class ReportJsonTemplateBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.ReportJsonTemplateBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder Members
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder Class Members

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder Class

Glossary Item Box

The following tables list the members exposed by ReportJsonTemplateBuilder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildReportTemplate | Combines a GrapeCity.ActiveReports.PageReportModel.Report object and its dependencies into a single bundle.
Top

See Also

Reference

ReportJsonTemplateBuilder Class
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder Class

Glossary Item Box

For a list of all members of this type, see ReportJsonTemplateBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildReportTemplate | Combines a GrapeCity.ActiveReports.PageReportModel.Report object and its dependencies into a single bundle.
Top

See Also

Reference

ReportJsonTemplateBuilder Class
GrapeCity.ActiveReports.Rdl.Json Namespace


BuildReportTemplate Method

[image]
ActiveReports 19 .NET Edition
BuildReportTemplate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder Class : BuildReportTemplate Method

report
The root GrapeCity.ActiveReports.PageReportModel.Report to be bundled.
resourceLocator
The GrapeCity.ActiveReports.ResourceLocator for accessing subreports and resources.

Glossary Item Box

Combines a GrapeCity.ActiveReports.PageReportModel.Report object and its dependencies into a single bundle.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildReportTemplate( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator _
) As ReportJsonTemplateBuilder.ReportTemplate
C#
public static ReportJsonTemplateBuilder.ReportTemplate BuildReportTemplate(
   Report report,
   ResourceLocator resourceLocator
)

Parameters

report
The root GrapeCity.ActiveReports.PageReportModel.Report to be bundled.
resourceLocator
The GrapeCity.ActiveReports.ResourceLocator for accessing subreports and resources.

Return Value

A ReportJsonTemplateBuilder.ReportTemplate object containing the bundled report and its dependencies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder Class
ReportJsonTemplateBuilder Members


ReportJsonTemplateBuilder.ImageResource Class

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ImageResource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ImageResource Class

Glossary Item Box

Represents an image resource, including its value and MIME type.

Object Model

ReportJsonTemplateBuilder.ImageResource Class

Syntax

Visual Basic (Declaration)
Public Class ReportJsonTemplateBuilder.ImageResource
C#
public class ReportJsonTemplateBuilder.ImageResource

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.ReportJsonTemplateBuilder.ImageResource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Members
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ImageResource Class Members

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ImageResource Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ImageResource Class

Glossary Item Box

The following tables list the members exposed by ReportJsonTemplateBuilder.ImageResource.

Public Constructors

 | Name | Description
Public Constructor | ReportJsonTemplateBuilder.ImageResource Constructor |
Top

Public Properties

 | Name | Description
Public Property | MimeType | Gets or sets the MIME type of the image resource.
Public Property | Value | Gets or sets the value of the image resource.
Top

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Class
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ImageResource Constructor

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ImageResource Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ImageResource Class : ReportJsonTemplateBuilder.ImageResource Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportJsonTemplateBuilder.ImageResource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Class
ReportJsonTemplateBuilder.ImageResource Members


ReportJsonTemplateBuilder.ImageResource Class Properties

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ImageResource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ImageResource Class

Glossary Item Box

For a list of all members of this type, see ReportJsonTemplateBuilder.ImageResource members.

Public Properties

 | Name | Description
Public Property | MimeType | Gets or sets the MIME type of the image resource.
Public Property | Value | Gets or sets the value of the image resource.
Top

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Class
GrapeCity.ActiveReports.Rdl.Json Namespace


MimeType Property

[image]
ActiveReports 19 .NET Edition
MimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ImageResource Class : MimeType Property

Glossary Item Box

Gets or sets the MIME type of the image resource.

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
C#
public string MimeType {get; set;}

Property Value

A System.String representing the MIME type of the image resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Class
ReportJsonTemplateBuilder.ImageResource Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ImageResource Class : Value Property

Glossary Item Box

Gets or sets the value of the image resource.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

A System.String representing the value of the image resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ImageResource Class
ReportJsonTemplateBuilder.ImageResource Members


ReportJsonTemplateBuilder.ReportResources Class

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportResources Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportResources Class

Glossary Item Box

Represents the resources associated with a report, including themes and images.

Object Model

ReportJsonTemplateBuilder.ReportResources Class

Syntax

Visual Basic (Declaration)
Public Class ReportJsonTemplateBuilder.ReportResources
C#
public class ReportJsonTemplateBuilder.ReportResources

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.ReportJsonTemplateBuilder.ReportResources

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Members
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ReportResources Class Members

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportResources Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportResources Class

Glossary Item Box

The following tables list the members exposed by ReportJsonTemplateBuilder.ReportResources.

Public Constructors

 | Name | Description
Public Constructor | ReportJsonTemplateBuilder.ReportResources Constructor |
Top

Public Properties

 | Name | Description
Public Property | Images | Gets or sets a dictionary of image resources used in the report.
Public Property | Themes | Gets or sets a dictionary of themes used in the report.
Top

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Class
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ReportResources Constructor

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportResources Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportResources Class : ReportJsonTemplateBuilder.ReportResources Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportJsonTemplateBuilder.ReportResources()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Class
ReportJsonTemplateBuilder.ReportResources Members


ReportJsonTemplateBuilder.ReportResources Class Properties

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportResources Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportResources Class

Glossary Item Box

For a list of all members of this type, see ReportJsonTemplateBuilder.ReportResources members.

Public Properties

 | Name | Description
Public Property | Images | Gets or sets a dictionary of image resources used in the report.
Public Property | Themes | Gets or sets a dictionary of themes used in the report.
Top

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Class
GrapeCity.ActiveReports.Rdl.Json Namespace


Images Property

[image]
ActiveReports 19 .NET Edition
Images Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportResources Class : Images Property

Glossary Item Box

Gets or sets a dictionary of image resources used in the report.

Syntax

Visual Basic (Declaration)
Public Property Images As Dictionary(Of String,ReportJsonTemplateBuilder.ImageResource)
C#
public Dictionary<string,ReportJsonTemplateBuilder.ImageResource> Images {get; set;}

Property Value

A Dictionary with keys of type System.String and values of type ReportJsonTemplateBuilder.ImageResource, representing the image resources used in the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Class
ReportJsonTemplateBuilder.ReportResources Members


Themes Property

[image]
ActiveReports 19 .NET Edition
Themes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportResources Class : Themes Property

Glossary Item Box

Gets or sets a dictionary of themes used in the report.

Syntax

Visual Basic (Declaration)
Public Property Themes As Dictionary(Of String,Theme)
C#
public Dictionary<string,Theme> Themes {get; set;}

Property Value

A Dictionary with keys of type System.String and values of type GrapeCity.ActiveReports.Rdl.Themes.Theme, representing the themes used in the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportResources Class
ReportJsonTemplateBuilder.ReportResources Members


ReportJsonTemplateBuilder.ReportTemplate Class

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportTemplate Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportTemplate Class

Glossary Item Box

Represents a template for a report, including its subreports and resources.

Object Model

ReportJsonTemplateBuilder.ReportTemplate Class

Syntax

Visual Basic (Declaration)
Public Class ReportJsonTemplateBuilder.ReportTemplate
C#
public class ReportJsonTemplateBuilder.ReportTemplate

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.ReportJsonTemplateBuilder.ReportTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Members
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ReportTemplate Class Members

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportTemplate Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportTemplate Class

Glossary Item Box

The following tables list the members exposed by ReportJsonTemplateBuilder.ReportTemplate.

Public Constructors

 | Name | Description
Public Constructor | ReportJsonTemplateBuilder.ReportTemplate Constructor |
Top

Public Properties

 | Name | Description
Public Property | Definition | Gets or sets the definition of the main report.
Public Property | Name | Gets or sets the name of the report template.
Public Property | Resources | Gets or sets the resources associated with the report.
Public Property | Subreports | Gets or sets a dictionary of subreports associated with the main report.
Top

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
GrapeCity.ActiveReports.Rdl.Json Namespace


ReportJsonTemplateBuilder.ReportTemplate Constructor

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportTemplate Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportTemplate Class : ReportJsonTemplateBuilder.ReportTemplate Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportJsonTemplateBuilder.ReportTemplate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
ReportJsonTemplateBuilder.ReportTemplate Members


ReportJsonTemplateBuilder.ReportTemplate Class Properties

[image]
ActiveReports 19 .NET Edition
ReportJsonTemplateBuilder.ReportTemplate Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace : ReportJsonTemplateBuilder.ReportTemplate Class

Glossary Item Box

For a list of all members of this type, see ReportJsonTemplateBuilder.ReportTemplate members.

Public Properties

 | Name | Description
Public Property | Definition | Gets or sets the definition of the main report.
Public Property | Name | Gets or sets the name of the report template.
Public Property | Resources | Gets or sets the resources associated with the report.
Public Property | Subreports | Gets or sets a dictionary of subreports associated with the main report.
Top

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
GrapeCity.ActiveReports.Rdl.Json Namespace


Definition Property

[image]
ActiveReports 19 .NET Edition
Definition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportTemplate Class : Definition Property

Glossary Item Box

Gets or sets the definition of the main report.

Syntax

Visual Basic (Declaration)
Public Property Definition As Report
C#
public Report Definition {get; set;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Report object representing the main report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
ReportJsonTemplateBuilder.ReportTemplate Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportTemplate Class : Name Property

Glossary Item Box

Gets or sets the name of the report template.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the report template.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
ReportJsonTemplateBuilder.ReportTemplate Members


Resources Property

[image]
ActiveReports 19 .NET Edition
Resources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportTemplate Class : Resources Property

Glossary Item Box

Gets or sets the resources associated with the report.

Syntax

Visual Basic (Declaration)
Public Property Resources As ReportJsonTemplateBuilder.ReportResources
C#
public ReportJsonTemplateBuilder.ReportResources Resources {get; set;}

Property Value

A ReportJsonTemplateBuilder.ReportResources object representing the resources associated with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
ReportJsonTemplateBuilder.ReportTemplate Members


Subreports Property

[image]
ActiveReports 19 .NET Edition
Subreports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json Namespace > ReportJsonTemplateBuilder.ReportTemplate Class : Subreports Property

Glossary Item Box

Gets or sets a dictionary of subreports associated with the main report.

Syntax

Visual Basic (Declaration)
Public Property Subreports As Dictionary(Of String,Report)
C#
public Dictionary<string,Report> Subreports {get; set;}

Property Value

A Dictionary with keys of type System.String and values of type GrapeCity.ActiveReports.PageReportModel.Report, representing the subreports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportJsonTemplateBuilder.ReportTemplate Class
ReportJsonTemplateBuilder.ReportTemplate Members


IJsonVariant Interface

[image]
ActiveReports 19 .NET Edition
IJsonVariant Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Common Namespace : IJsonVariant Interface

Glossary Item Box

Base interface for possible json values.

Syntax

Visual Basic (Declaration)
Public Interface IJsonVariant
C#
public interface IJsonVariant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJsonVariant Members
GrapeCity.ActiveReports.Rdl.Json.Common Namespace


IJsonVariant Interface Members

[image]
ActiveReports 19 .NET Edition
IJsonVariant Interface Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Common Namespace : IJsonVariant Interface

Glossary Item Box

The following tables list the members exposed by IJsonVariant.

See Also

Reference

IJsonVariant Interface
GrapeCity.ActiveReports.Rdl.Json.Common Namespace


TypeInfo Class

[image]
ActiveReports 19 .NET Edition
TypeInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace : TypeInfo Class

Glossary Item Box

Object Model

TypeInfo Class

Syntax

Visual Basic (Declaration)
Public Class TypeInfo
C#
public class TypeInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Json.Converters.TypeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Members
GrapeCity.ActiveReports.Rdl.Json.Converters Namespace


TypeInfo Class Members

[image]
ActiveReports 19 .NET Edition
TypeInfo Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace : TypeInfo Class

Glossary Item Box

The following tables list the members exposed by TypeInfo.

Public Constructors

 | Name | Description
Public Constructor | TypeInfo Constructor |
Top

Public Fields

 | Name | Description
Public Field | ReadConverter |
Public Field | ReadType |
Public Field | WriteConverter |
Public Field | WriteType |
Top

Public Operators

public Operator Implicit Type Conversion
Top

See Also

Reference

TypeInfo Class
GrapeCity.ActiveReports.Rdl.Json.Converters Namespace


TypeInfo Constructor

[image]
ActiveReports 19 .NET Edition
TypeInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : TypeInfo Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TypeInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


TypeInfo Class Fields

[image]
ActiveReports 19 .NET Edition
TypeInfo Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace : TypeInfo Class

Glossary Item Box

For a list of all members of this type, see TypeInfo members.

Public Fields

 | Name | Description
Public Field | ReadConverter |
Public Field | ReadType |
Public Field | WriteConverter |
Public Field | WriteType |
Top

See Also

Reference

TypeInfo Class
GrapeCity.ActiveReports.Rdl.Json.Converters Namespace


ReadConverter Field

[image]
ActiveReports 19 .NET Edition
ReadConverter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : ReadConverter Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadConverter As Func(Of Object,Object)
C#
public Func<object,object> ReadConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


ReadType Field

[image]
ActiveReports 19 .NET Edition
ReadType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : ReadType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadType As Type
C#
public Type ReadType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


WriteConverter Field

[image]
ActiveReports 19 .NET Edition
WriteConverter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : WriteConverter Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public WriteConverter As Func(Of Object,Object)
C#
public Func<object,object> WriteConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


WriteType Field

[image]
ActiveReports 19 .NET Edition
WriteType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : WriteType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public WriteType As Type
C#
public Type WriteType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Json.Converters Namespace > TypeInfo Class : Implicit Type Conversion Operator

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal type As Type _
) As TypeInfo
C#
public TypeInfo operator implicit(
   Type type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TypeInfo Class
TypeInfo Members


DataSetExtensions Class

[image]
ActiveReports 19 .NET Edition
DataSetExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace : DataSetExtensions Class

Glossary Item Box

Represents a set of extension methods for the GrapeCity.ActiveReports.PageReportModel.Query class.

Object Model

DataSetExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataSetExtensions
C#
public static class DataSetExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Model.DataSetExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Members
GrapeCity.ActiveReports.Rdl.Model Namespace


DataSetExtensions Class Members

[image]
ActiveReports 19 .NET Edition
DataSetExtensions Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace : DataSetExtensions Class

Glossary Item Box

The following tables list the members exposed by DataSetExtensions.

Public Fields

 | Name | Description
Public Field | NestedDataSetPrefix |
Public Field | NestedDataSetSeparator |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetParentDataSetName | Gets a name of the parent dataset.
static (Shared in Visual Basic) | GetParentFieldName | Gets a name of the field that is the data source of the specified dataset.
static (Shared in Visual Basic) | GetRootDataSet | Gets a root dataset by traversing up the dataset hierarchy.
static (Shared in Visual Basic) | IsNested | Determines if the dataset is a nested dataset. A nested dataset is a dataset that references another dataset instead of a datasource. A dataset reference consists of the prefix "$dataset:", the name of the parent dataset, the path separator "/", and the name of the field from the parent dataset containing this dataset.
static (Shared in Visual Basic) | SetParentDataSet | Sets the parent dataset and field names for the nested dataset.
Top

See Also

Reference

DataSetExtensions Class
GrapeCity.ActiveReports.Rdl.Model Namespace


DataSetExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
DataSetExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace : DataSetExtensions Class

Glossary Item Box

For a list of all members of this type, see DataSetExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetParentDataSetName | Gets a name of the parent dataset.
static (Shared in Visual Basic) | GetParentFieldName | Gets a name of the field that is the data source of the specified dataset.
static (Shared in Visual Basic) | GetRootDataSet | Gets a root dataset by traversing up the dataset hierarchy.
static (Shared in Visual Basic) | IsNested | Determines if the dataset is a nested dataset. A nested dataset is a dataset that references another dataset instead of a datasource. A dataset reference consists of the prefix "$dataset:", the name of the parent dataset, the path separator "/", and the name of the field from the parent dataset containing this dataset.
static (Shared in Visual Basic) | SetParentDataSet | Sets the parent dataset and field names for the nested dataset.
Top

See Also

Reference

DataSetExtensions Class
GrapeCity.ActiveReports.Rdl.Model Namespace


GetParentDataSetName Method

[image]
ActiveReports 19 .NET Edition
GetParentDataSetName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : GetParentDataSetName Method

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to get the name of the parent dataset from.

Glossary Item Box

Gets a name of the parent dataset.

Syntax

Visual Basic (Declaration)
Public Shared Function GetParentDataSetName( _
   ByVal dataSet As IDataSet _
) As String
C#
public static string GetParentDataSetName(
   IDataSet dataSet
)

Parameters

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to get the name of the parent dataset from.

Return Value

A System.String value indicating the name of the parent dataset.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


GetParentFieldName Method

[image]
ActiveReports 19 .NET Edition
GetParentFieldName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : GetParentFieldName Method

dataSet
A target GrapeCity.ActiveReports.PageReportModel.IDataSet object.

Glossary Item Box

Gets a name of the field that is the data source of the specified dataset.

Syntax

Visual Basic (Declaration)
Public Shared Function GetParentFieldName( _
   ByVal dataSet As IDataSet _
) As String
C#
public static string GetParentFieldName(
   IDataSet dataSet
)

Parameters

dataSet
A target GrapeCity.ActiveReports.PageReportModel.IDataSet object.

Return Value

A System.String value indicating the name of the field that is the data source of the specified dataset.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


GetRootDataSet Method

[image]
ActiveReports 19 .NET Edition
GetRootDataSet Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : GetRootDataSet Method

dataSet
A starting GrapeCity.ActiveReports.PageReportModel.IDataSet object.
getDataSetFn
A function to retrieve a dataset by name.

Glossary Item Box

Gets a root dataset by traversing up the dataset hierarchy.

Syntax

Visual Basic (Declaration)
Public Shared Function GetRootDataSet( _
   ByVal dataSet As IDataSet, _
   ByVal getDataSetFn As Func(Of String,IDataSet) _
) As IDataSet
C#
public static IDataSet GetRootDataSet(
   IDataSet dataSet,
   Func<string,IDataSet> getDataSetFn
)

Parameters

dataSet
A starting GrapeCity.ActiveReports.PageReportModel.IDataSet object.
getDataSetFn
A function to retrieve a dataset by name.

Return Value

A root GrapeCity.ActiveReports.PageReportModel.IDataSet object in the hierarchy.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


IsNested Method

[image]
ActiveReports 19 .NET Edition
IsNested Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : IsNested Method

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to check.

Glossary Item Box

Determines if the dataset is a nested dataset. A nested dataset is a dataset that references another dataset instead of a datasource. A dataset reference consists of the prefix "$dataset:", the name of the parent dataset, the path separator "/", and the name of the field from the parent dataset containing this dataset.

Syntax

Visual Basic (Declaration)
Public Shared Function IsNested( _
   ByVal dataSet As IDataSet _
) As Boolean
C#
public static bool IsNested(
   IDataSet dataSet
)

Parameters

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to check.

Return Value

A System.Boolean value. true if the dataset is a nested dataset; otherwise, false.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


SetParentDataSet Method

[image]
ActiveReports 19 .NET Edition
SetParentDataSet Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : SetParentDataSet Method

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to update.
dataSetName
A System.String value indicating the name of the parent dataset.
fieldName
A System.String value indicating the field of the parent dataset which represents the data for the nested dataset.

Glossary Item Box

Sets the parent dataset and field names for the nested dataset.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetParentDataSet( _
   ByVal dataSet As IDataSet, _
   ByVal dataSetName As String, _
   ByVal fieldName As String _
)
C#
public static void SetParentDataSet(
   IDataSet dataSet,
   string dataSetName,
   string fieldName
)

Parameters

dataSet
A GrapeCity.ActiveReports.PageReportModel.IDataSet object to update.
dataSetName
A System.String value indicating the name of the parent dataset.
fieldName
A System.String value indicating the field of the parent dataset which represents the data for the nested dataset.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


DataSetExtensions Class Fields

[image]
ActiveReports 19 .NET Edition
DataSetExtensions Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace : DataSetExtensions Class

Glossary Item Box

For a list of all members of this type, see DataSetExtensions members.

Public Fields

 | Name | Description
Public Field | NestedDataSetPrefix |
Public Field | NestedDataSetSeparator |
Top

See Also

Reference

DataSetExtensions Class
GrapeCity.ActiveReports.Rdl.Model Namespace


NestedDataSetPrefix Field

[image]
ActiveReports 19 .NET Edition
NestedDataSetPrefix Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : NestedDataSetPrefix Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const NestedDataSetPrefix As String
C#
public const string NestedDataSetPrefix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


NestedDataSetSeparator Field

[image]
ActiveReports 19 .NET Edition
NestedDataSetSeparator Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Model Namespace > DataSetExtensions Class : NestedDataSetSeparator Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const NestedDataSetSeparator As String
C#
public const string NestedDataSetSeparator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetExtensions Class
DataSetExtensions Members


PersistenceException Class

[image]
ActiveReports 19 .NET Edition
PersistenceException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceException Class

Glossary Item Box

Represents an exception that throws during persistence operations.

Object Model

PersistenceException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PersistenceException
   Inherits System.Exception
C#
public sealed class PersistenceException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceException Members
GrapeCity.ActiveReports.Rdl.Persistence Namespace


PersistenceException Class Members

[image]
ActiveReports 19 .NET Edition
PersistenceException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceException Class

Glossary Item Box

The following tables list the members exposed by PersistenceException.

Public Constructors

 | Name | Description
Public Constructor | PersistenceException Constructor | Initializes a new instance of the PersistenceException class.
Top

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

See Also

Reference

PersistenceException Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


PersistenceException Constructor

[image]
ActiveReports 19 .NET Edition
PersistenceException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceException Class : PersistenceException Constructor

errorCode
An PersistenceException.ErrorCodes value indicating the type of persistence error.
message
A System.String value indicating the message that describes the error.

Glossary Item Box

Initializes a new instance of the PersistenceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorCode As PersistenceException.ErrorCodes, _
   ByVal message As String _
)
C#
public PersistenceException(
   PersistenceException.ErrorCodes errorCode,
   string message
)

Parameters

errorCode
An PersistenceException.ErrorCodes value indicating the type of persistence error.
message
A System.String value indicating the message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceException Class
PersistenceException Members


PersistenceException Class Properties

[image]
ActiveReports 19 .NET Edition
PersistenceException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceException Class

Glossary Item Box

For a list of all members of this type, see PersistenceException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

See Also

Reference

PersistenceException Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceException Class : ErrorCode Property

Glossary Item Box

Gets the error code associated with this exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As PersistenceException.ErrorCodes
C#
public PersistenceException.ErrorCodes ErrorCode {get;}

Property Value

An PersistenceException.ErrorCodes value indicating the specific type of persistence error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceException Class
PersistenceException Members


PersistenceFilter Class

[image]
ActiveReports 19 .NET Edition
PersistenceFilter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceFilter Class

Glossary Item Box

Represents a class that sits between the GrapeCity.ActiveReports.Rdl.Persistence.Director and GrapeCity.ActiveReports.PageReportModel.Report to perform custom actions on a report object such as merging and unmerging with the master report, or serializing and deserializing the report. At this time, the class is designed for master reports.

Object Model

PersistenceFilter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PersistenceFilter
C#
public sealed class PersistenceFilter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Members
GrapeCity.ActiveReports.Rdl.Persistence Namespace


PersistenceFilter Class Members

[image]
ActiveReports 19 .NET Edition
PersistenceFilter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceFilter Class

Glossary Item Box

The following tables list the members exposed by PersistenceFilter.

Public Constructors

 | Name | Description
Public Constructor | PersistenceFilter Constructor | Initializes a new instance of the PersistenceFilter class.
Top

Public Properties

 | Name | Description
Public Property | IsConvertedFromLegacyReport | Gets a value indicating whether the report was converted from a legacy report format.
Public Property | MasterContentService | Gets the master content service.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDataElementName | Creates a unique data element name that does not conflict with the data element names of any components in the specified collection.
Public Method | CreateFromMaster | Creates a new report based on the master report.
Public Method | DeserializeRoot | Overloaded. Deserializes a report from the specified System.IO.TextReader, performing post-deserialization actions on the resulting report object.
static (Shared in Visual Basic) | Load | Loads a report from the specified text reader, optionally merging with the master report.
Public Method | MergeWithMaster | Merges the report content with its master report.
Public Method | SerializeRoot | Overloaded. Serializes the root report to the specified System.IO.FileInfo, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.
Top

See Also

Reference

PersistenceFilter Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


PersistenceFilter Constructor

[image]
ActiveReports 19 .NET Edition
PersistenceFilter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : PersistenceFilter Constructor

factory
A GrapeCity.ActiveReports.IReportComponentFactory object to use in GrapeCity.ActiveReports.Rdl.Persistence.Director object.
report
A GrapeCity.ActiveReports.PageReportModel.Report object to be processed.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object for locating report resources.
masterContentService
Optional a GrapeCity.ActiveReports.PageReportModel.IMasterContentService object for operations with master report. Default is null.
isSnapShotFilter
Optional a System.Boolean value indicating whether this is a snapshot filter. Default is false.

Glossary Item Box

Initializes a new instance of the PersistenceFilter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal factory As IReportComponentFactory, _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal masterContentService As IMasterContentService, _
   Optional ByVal isSnapShotFilter As Boolean _
)
C#
public PersistenceFilter(
   IReportComponentFactory factory,
   Report report,
   ResourceLocator resourceLocator,
   IMasterContentService masterContentService,
   bool isSnapShotFilter
)

Parameters

factory
A GrapeCity.ActiveReports.IReportComponentFactory object to use in GrapeCity.ActiveReports.Rdl.Persistence.Director object.
report
A GrapeCity.ActiveReports.PageReportModel.Report object to be processed.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object for locating report resources.
masterContentService
Optional a GrapeCity.ActiveReports.PageReportModel.IMasterContentService object for operations with master report. Default is null.
isSnapShotFilter
Optional a System.Boolean value indicating whether this is a snapshot filter. Default is false.

Exceptions

Exception | Description
System.ArgumentNullException | Thows if factory is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


PersistenceFilter Class Methods

[image]
ActiveReports 19 .NET Edition
PersistenceFilter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceFilter Class

Glossary Item Box

For a list of all members of this type, see PersistenceFilter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDataElementName | Creates a unique data element name that does not conflict with the data element names of any components in the specified collection.
Public Method | CreateFromMaster | Creates a new report based on the master report.
Public Method | DeserializeRoot | Overloaded. Deserializes a report from the specified System.IO.TextReader, performing post-deserialization actions on the resulting report object.
static (Shared in Visual Basic) | Load | Loads a report from the specified text reader, optionally merging with the master report.
Public Method | MergeWithMaster | Merges the report content with its master report.
Public Method | SerializeRoot | Overloaded. Serializes the root report to the specified System.IO.FileInfo, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.
Top

See Also

Reference

PersistenceFilter Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


CreateDataElementName Method

[image]
ActiveReports 19 .NET Edition
CreateDataElementName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : CreateDataElementName Method

names
A collection of existing data element names.
item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object for which to create a unique data element name.

Glossary Item Box

Creates a unique data element name that does not conflict with the data element names of any components in the specified collection.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDataElementName( _
   ByVal names As HashSet(Of String), _
   ByVal item As ReportItem _
) As String
C#
public static string CreateDataElementName(
   HashSet<string> names,
   ReportItem item
)

Parameters

names
A collection of existing data element names.
item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object for which to create a unique data element name.

Return Value

A System.String value indicating the unique data element name.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if names or item is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


CreateFromMaster Method

[image]
ActiveReports 19 .NET Edition
CreateFromMaster Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : CreateFromMaster Method

Glossary Item Box

Creates a new report based on the master report.

Syntax

Visual Basic (Declaration)
Public Function CreateFromMaster() As Report
C#
public Report CreateFromMaster()

Return Value

The newly created GrapeCity.ActiveReports.PageReportModel.Report object based on the master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


DeserializeRoot Method

[image]
ActiveReports 19 .NET Edition
DeserializeRoot Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : DeserializeRoot Method

Glossary Item Box

Deserializes a report from the specified System.IO.TextReader, performing post-deserialization actions on the resulting report object.

Overload List

Overload | Description
DeserializeRoot(TextReader,Action<Report>) | Deserializes a report from the specified System.IO.TextReader, performing post-deserialization actions on the resulting report object.
DeserializeRoot(TextReader,ResourceLocator,IReportComponentFactory) | Deserializes a report from the specified text reader, performing post-deserialization actions.
DeserializeRoot(FileInfo) | Deserializes a report from the specified System.IO.FileInfo, performing post-deserialization actions on the resulting report object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


DeserializeRoot(TextReader,Action<Report>) Method

[image]
ActiveReports 19 .NET Edition
DeserializeRoot(TextReader,Action<Report>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class > DeserializeRoot Method : DeserializeRoot(TextReader,Action<Report>) Method

reader
A System.IO.TextReader object containing the report xml.
setter
The callback function to be called after deserialization.

Glossary Item Box

Deserializes a report from the specified System.IO.TextReader, performing post-deserialization actions on the resulting report object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DeserializeRoot( _
   ByVal reader As TextReader, _
   ByVal setter As Action(Of Report) _
)
C#
public void DeserializeRoot(
   TextReader reader,
   Action<Report> setter
)

Parameters

reader
A System.IO.TextReader object containing the report xml.
setter
The callback function to be called after deserialization.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Report object containing the deserialized report and any post-deserialization actions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members
Overload List


DeserializeRoot(TextReader,ResourceLocator,IReportComponentFactory) Method

[image]
ActiveReports 19 .NET Edition
DeserializeRoot(TextReader,ResourceLocator,IReportComponentFactory) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class > DeserializeRoot Method : DeserializeRoot(TextReader,ResourceLocator,IReportComponentFactory) Method

reader
A System.IO.TextReader object containing the report XML.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object for locating report resources.
reportComponentFactory
An pptional GrapeCity.ActiveReports.IReportComponentFactory object to use in GrapeCity.ActiveReports.Rdl.Persistence.Director object. Default is null.

Glossary Item Box

Deserializes a report from the specified text reader, performing post-deserialization actions.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DeserializeRoot( _
   ByVal reader As TextReader, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal reportComponentFactory As IReportComponentFactory _
) As Report
C#
public static Report DeserializeRoot(
   TextReader reader,
   ResourceLocator resourceLocator,
   IReportComponentFactory reportComponentFactory
)

Parameters

reader
A System.IO.TextReader object containing the report XML.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object for locating report resources.
reportComponentFactory
An pptional GrapeCity.ActiveReports.IReportComponentFactory object to use in GrapeCity.ActiveReports.Rdl.Persistence.Director object. Default is null.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members
Overload List


DeserializeRoot(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
DeserializeRoot(FileInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class > DeserializeRoot Method : DeserializeRoot(FileInfo) Method

file
A System.IO.FileInfo containing the report XML.

Glossary Item Box

Deserializes a report from the specified System.IO.FileInfo, performing post-deserialization actions on the resulting report object.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeserializeRoot( _
   ByVal file As FileInfo _
) As Report
C#
public Report DeserializeRoot(
   FileInfo file
)

Parameters

file
A System.IO.FileInfo containing the report XML.

Return Value

The deserialized GrapeCity.ActiveReports.PageReportModel.Report object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members
Overload List


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : Load Method

streamReader
A System.IO.TextReader object containing the report XML.
resourceLocator
Optional GrapeCity.ActiveReports.ResourceLocator object for locating report resources. Default is null.
mergeWithMaster
Optional System.Boolean value indicating whether to merge with the master report. Default is true.

Glossary Item Box

Loads a report from the specified text reader, optionally merging with the master report.

Syntax

Visual Basic (Declaration)
Public Shared Function Load( _
   ByVal streamReader As TextReader, _
   Optional ByVal resourceLocator As ResourceLocator, _
   Optional ByVal mergeWithMaster As Boolean _
) As Report
C#
public static Report Load(
   TextReader streamReader,
   ResourceLocator resourceLocator,
   bool mergeWithMaster
)

Parameters

streamReader
A System.IO.TextReader object containing the report XML.
resourceLocator
Optional GrapeCity.ActiveReports.ResourceLocator object for locating report resources. Default is null.
mergeWithMaster
Optional System.Boolean value indicating whether to merge with the master report. Default is true.

Return Value

A deserialized GrapeCity.ActiveReports.PageReportModel.Report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


MergeWithMaster Method

[image]
ActiveReports 19 .NET Edition
MergeWithMaster Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : MergeWithMaster Method

Glossary Item Box

Merges the report content with its master report.

Syntax

Visual Basic (Declaration)
Public Function MergeWithMaster() As Report
C#
public Report MergeWithMaster()

Return Value

The merged GrapeCity.ActiveReports.PageReportModel.Report object, or the original GrapeCity.ActiveReports.PageReportModel.Report if no actions were performed.

Remarks

The report will be identified as being a standard or master-child report. If it is a master-child report, the master report will be loaded and combined with the child.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


SerializeRoot Method

[image]
ActiveReports 19 .NET Edition
SerializeRoot Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : SerializeRoot Method

Glossary Item Box

Serializes the root report to the specified System.IO.FileInfo, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.

Overload List

Overload | Description
SerializeRoot(Report,FileInfo) | Serializes the root report to the specified System.IO.FileInfo, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.
SerializeRoot(Report,XmlWriter) | Serializes the root report to the specified System.Xml.XmlWriter, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


SerializeRoot(Report,FileInfo) Method

[image]
ActiveReports 19 .NET Edition
SerializeRoot(Report,FileInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class > SerializeRoot Method : SerializeRoot(Report,FileInfo) Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to serialize.
file
A System.IO.FileInfo to serialize the report to.

Glossary Item Box

Serializes the root report to the specified System.IO.FileInfo, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SerializeRoot( _
   ByVal report As Report, _
   ByVal file As FileInfo _
)
C#
public void SerializeRoot(
   Report report,
   FileInfo file
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to serialize.
file
A System.IO.FileInfo to serialize the report to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members
Overload List


SerializeRoot(Report,XmlWriter) Method

[image]
ActiveReports 19 .NET Edition
SerializeRoot(Report,XmlWriter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class > SerializeRoot Method : SerializeRoot(Report,XmlWriter) Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to serialize.
writer
A System.Xml.XmlWriter to serialize the report to.

Glossary Item Box

Serializes the root report to the specified System.Xml.XmlWriter, performing pre-serialization actions on the report object before it is sent to the System.IO.Directory.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SerializeRoot( _
   ByVal report As Report, _
   ByVal writer As XmlWriter _
)
C#
public void SerializeRoot(
   Report report,
   XmlWriter writer
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to serialize.
writer
A System.Xml.XmlWriter to serialize the report to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members
Overload List


PersistenceFilter Class Properties

[image]
ActiveReports 19 .NET Edition
PersistenceFilter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceFilter Class

Glossary Item Box

For a list of all members of this type, see PersistenceFilter members.

Public Properties

 | Name | Description
Public Property | IsConvertedFromLegacyReport | Gets a value indicating whether the report was converted from a legacy report format.
Public Property | MasterContentService | Gets the master content service.
Top

See Also

Reference

PersistenceFilter Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


IsConvertedFromLegacyReport Property

[image]
ActiveReports 19 .NET Edition
IsConvertedFromLegacyReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : IsConvertedFromLegacyReport Property

Glossary Item Box

Gets a value indicating whether the report was converted from a legacy report format.

Syntax

Visual Basic (Declaration)
Public Property IsConvertedFromLegacyReport As Boolean
C#
public bool IsConvertedFromLegacyReport {get; set;}

Property Value

A System.Boolean value where true if the report was converted from a legacy report format; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


MasterContentService Property

[image]
ActiveReports 19 .NET Edition
MasterContentService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > PersistenceFilter Class : MasterContentService Property

Glossary Item Box

Gets the master content service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MasterContentService As IMasterContentService
C#
public IMasterContentService MasterContentService {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.IMasterContentService object representing the master content service.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PersistenceFilter Class
PersistenceFilter Members


ReportComponentFactory Class

[image]
ActiveReports 19 .NET Edition
ReportComponentFactory Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : ReportComponentFactory Class

Glossary Item Box

Represents a factory for creating report components.

Object Model

ReportComponentFactory Class

Syntax

Visual Basic (Declaration)
Public Class ReportComponentFactory
   Implements GrapeCity.ActiveReports.IReportComponentFactory
C#
public class ReportComponentFactory : GrapeCity.ActiveReports.IReportComponentFactory

Example

C# Copy Code
IComponent reportComponent = ReportComponentFactory.Instance.CreateComponent(typeof(Report));

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Persistence.ReportComponentFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentFactory Members
GrapeCity.ActiveReports.Rdl.Persistence Namespace


ReportComponentFactory Class Members

[image]
ActiveReports 19 .NET Edition
ReportComponentFactory Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : ReportComponentFactory Class

Glossary Item Box

The following tables list the members exposed by ReportComponentFactory.

Public Constructors

 | Name | Description
Public Constructor | ReportComponentFactory Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets a singleton instance of the ReportComponentFactory.
Top

See Also

Reference

ReportComponentFactory Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


ReportComponentFactory Constructor

[image]
ActiveReports 19 .NET Edition
ReportComponentFactory Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > ReportComponentFactory Class : ReportComponentFactory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportComponentFactory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentFactory Class
ReportComponentFactory Members


ReportComponentFactory Class Fields

[image]
ActiveReports 19 .NET Edition
ReportComponentFactory Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : ReportComponentFactory Class

Glossary Item Box

For a list of all members of this type, see ReportComponentFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets a singleton instance of the ReportComponentFactory.
Top

See Also

Reference

ReportComponentFactory Class
GrapeCity.ActiveReports.Rdl.Persistence Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace > ReportComponentFactory Class : Instance Field

Glossary Item Box

Gets a singleton instance of the ReportComponentFactory.

Syntax

Visual Basic (Declaration)
Public Shared Instance As ReportComponentFactory
C#
public static ReportComponentFactory Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportComponentFactory Class
ReportComponentFactory Members


PersistenceException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
PersistenceException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Persistence Namespace : PersistenceException.ErrorCodes Enumeration

Glossary Item Box

Specifies error codes for persistence exceptions.

Syntax

Visual Basic (Declaration)
Public Enum PersistenceException.ErrorCodes
   Inherits System.Enum
C#
public enum PersistenceException.ErrorCodes : System.Enum

Members

Member | Description
MissingNamespaceURI | The namespace URI is missing.
UnrecognizedFileFormat | The file format is unrecognized.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Persistence.PersistenceException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Persistence Namespace


Colors Class

[image]
ActiveReports 19 .NET Edition
Colors Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Colors Class

Glossary Item Box

Represents a collection of colors associated with a theme.

Object Model

Colors Class

Syntax

Visual Basic (Declaration)
Public Class Colors
C#
public class Colors

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Colors

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Colors Class Members

[image]
ActiveReports 19 .NET Edition
Colors Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Colors Class

Glossary Item Box

The following tables list the members exposed by Colors.

Public Constructors

 | Name | Description
Public Constructor | Colors Constructor | Initializes a new instance of the Colors class.
Top

Public Fields

 | Name | Description
Public Field | ColorDerivationCount |
Top

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the Accent1 theme color.
Public Property | Accent2 | Gets or sets the Accent2 theme color.
Public Property | Accent3 | Gets or sets the Accent3 theme color.
Public Property | Accent4 | Gets or sets the Accent4 theme color.
Public Property | Accent5 | Gets or sets the Accent5 theme color.
Public Property | Accent6 | Gets or sets the Accent6 theme color.
Public Property | Dark1 | Gets or sets the Dark1 theme color.
Public Property | Dark2 | Gets or sets the Dark2 theme color.
Public Property | Hyperlink | Gets or sets the Hyperlink theme color.
Public Property | HyperlinkFollowed | Gets or sets the HyperlinkFollowed theme color.
Public Property | Item | Overloaded. Gets the color using a specified name.
Public Property | Light1 | Gets or sets the Light1 theme color.
Public Property | Light2 | Gets or sets the Light2 theme color.
Top

See Also

Reference

Colors Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Colors Constructor

[image]
ActiveReports 19 .NET Edition
Colors Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Colors Constructor

Glossary Item Box

Initializes a new instance of the Colors class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Colors()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Colors Class Properties

[image]
ActiveReports 19 .NET Edition
Colors Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Colors Class

Glossary Item Box

For a list of all members of this type, see Colors members.

Public Properties

 | Name | Description
Public Property | Accent1 | Gets or sets the Accent1 theme color.
Public Property | Accent2 | Gets or sets the Accent2 theme color.
Public Property | Accent3 | Gets or sets the Accent3 theme color.
Public Property | Accent4 | Gets or sets the Accent4 theme color.
Public Property | Accent5 | Gets or sets the Accent5 theme color.
Public Property | Accent6 | Gets or sets the Accent6 theme color.
Public Property | Dark1 | Gets or sets the Dark1 theme color.
Public Property | Dark2 | Gets or sets the Dark2 theme color.
Public Property | Hyperlink | Gets or sets the Hyperlink theme color.
Public Property | HyperlinkFollowed | Gets or sets the HyperlinkFollowed theme color.
Public Property | Item | Overloaded. Gets the color using a specified name.
Public Property | Light1 | Gets or sets the Light1 theme color.
Public Property | Light2 | Gets or sets the Light2 theme color.
Top

See Also

Reference

Colors Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Accent1 Property

[image]
ActiveReports 19 .NET Edition
Accent1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent1 Property

Glossary Item Box

Gets or sets the Accent1 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent1 As String
C#
public string Accent1 {get; set;}

Property Value

A System.String value indicating the Accent1 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Accent2 Property

[image]
ActiveReports 19 .NET Edition
Accent2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent2 Property

Glossary Item Box

Gets or sets the Accent2 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent2 As String
C#
public string Accent2 {get; set;}

Property Value

A System.String value indicating the Accent2 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Accent3 Property

[image]
ActiveReports 19 .NET Edition
Accent3 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent3 Property

Glossary Item Box

Gets or sets the Accent3 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent3 As String
C#
public string Accent3 {get; set;}

Property Value

A System.String value indicating the Accent3 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Accent4 Property

[image]
ActiveReports 19 .NET Edition
Accent4 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent4 Property

Glossary Item Box

Gets or sets the Accent4 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent4 As String
C#
public string Accent4 {get; set;}

Property Value

A System.String value indicating the Accent4 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Accent5 Property

[image]
ActiveReports 19 .NET Edition
Accent5 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent5 Property

Glossary Item Box

Gets or sets the Accent5 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent5 As String
C#
public string Accent5 {get; set;}

Property Value

A System.String value indicating the Accent5 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Accent6 Property

[image]
ActiveReports 19 .NET Edition
Accent6 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Accent6 Property

Glossary Item Box

Gets or sets the Accent6 theme color.

Syntax

Visual Basic (Declaration)
Public Property Accent6 As String
C#
public string Accent6 {get; set;}

Property Value

A System.String value indicating the Accent6 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Dark1 Property

[image]
ActiveReports 19 .NET Edition
Dark1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Dark1 Property

Glossary Item Box

Gets or sets the Dark1 theme color.

Syntax

Visual Basic (Declaration)
Public Property Dark1 As String
C#
public string Dark1 {get; set;}

Property Value

A System.String value indicating the Dark1 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Dark2 Property

[image]
ActiveReports 19 .NET Edition
Dark2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Dark2 Property

Glossary Item Box

Gets or sets the Dark2 theme color.

Syntax

Visual Basic (Declaration)
Public Property Dark2 As String
C#
public string Dark2 {get; set;}

Property Value

A System.String value indicating the Dark2 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Hyperlink Property

[image]
ActiveReports 19 .NET Edition
Hyperlink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Hyperlink Property

Glossary Item Box

Gets or sets the Hyperlink theme color.

Syntax

Visual Basic (Declaration)
Public Property Hyperlink As String
C#
public string Hyperlink {get; set;}

Property Value

A System.String value indicating the Hyperlink theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


HyperlinkFollowed Property

[image]
ActiveReports 19 .NET Edition
HyperlinkFollowed Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : HyperlinkFollowed Property

Glossary Item Box

Gets or sets the HyperlinkFollowed theme color.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkFollowed As String
C#
public string HyperlinkFollowed {get; set;}

Property Value

A System.String value indicating the HyperlinkFollowed theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Item Property

Glossary Item Box

Gets the color using a specified name.

Overload List

Overload | Description
Item(String) | Gets the color using a specified name.
Item(Int32) | Gets the color using a specified index.

Exceptions

Exception | Description
System.ArgumentException | Throws if the color with a specified name was not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class > Item Property : Item(String) Property

name
A System.String value indicating the name of the color to get.

Glossary Item Box

Gets the color using a specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As String
C#
public string Item(
   string name
) {get;}

Parameters

name
A System.String value indicating the name of the color to get.

Property Value

A System.String value indicating the color with the specified name.

Exceptions

Exception | Description
System.ArgumentException | Throws if the color with a specified name was not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members
Overload List


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class > Item Property : Item(Int32) Property

baseColorIndex
A System.Int32 value indicating the index of the base color to get.

Glossary Item Box

Gets the color using a specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal baseColorIndex As Integer _
) As String
C#
public string Item(
   int baseColorIndex
) {get;}

Parameters

baseColorIndex
A System.Int32 value indicating the index of the base color to get.

Property Value

A System.String value indicating the color with the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members
Overload List


Light1 Property

[image]
ActiveReports 19 .NET Edition
Light1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Light1 Property

Glossary Item Box

Gets or sets the Light1 theme color.

Syntax

Visual Basic (Declaration)
Public Property Light1 As String
C#
public string Light1 {get; set;}

Property Value

A System.String value indicating the Light1 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Light2 Property

[image]
ActiveReports 19 .NET Edition
Light2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : Light2 Property

Glossary Item Box

Gets or sets the Light2 theme color.

Syntax

Visual Basic (Declaration)
Public Property Light2 As String
C#
public string Light2 {get; set;}

Property Value

A System.String value indicating the Light2 theme color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


Colors Class Fields

[image]
ActiveReports 19 .NET Edition
Colors Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Colors Class

Glossary Item Box

For a list of all members of this type, see Colors members.

Public Fields

 | Name | Description
Public Field | ColorDerivationCount |
Top

See Also

Reference

Colors Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


ColorDerivationCount Field

[image]
ActiveReports 19 .NET Edition
ColorDerivationCount Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Colors Class : ColorDerivationCount Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColorDerivationCount As Integer
C#
public const int ColorDerivationCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Colors Class
Colors Members


ConstantsCollection Class

[image]
ActiveReports 19 .NET Edition
ConstantsCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ConstantsCollection Class

Glossary Item Box

Represents a collection of theme constants. It acts as a wrapper over a regular dictionary to facilitate the evaluation of expressions through the GetResult method.

Object Model

ConstantsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConstantsCollection
C#
public sealed class ConstantsCollection

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.ConstantsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantsCollection Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


ConstantsCollection Class Members

[image]
ActiveReports 19 .NET Edition
ConstantsCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ConstantsCollection Class

Glossary Item Box

The following tables list the members exposed by ConstantsCollection.

Public Properties

 | Name | Description
Public Property | Item | Gets the ThemeConstant object associated with the specified key.
Top

See Also

Reference

ConstantsCollection Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


ConstantsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ConstantsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ConstantsCollection Class

Glossary Item Box

For a list of all members of this type, see ConstantsCollection members.

Public Properties

 | Name | Description
Public Property | Item | Gets the ThemeConstant object associated with the specified key.
Top

See Also

Reference

ConstantsCollection Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ConstantsCollection Class : Item Property

key
A System.String value indicating the key of the theme constant to get.

Glossary Item Box

Gets the ThemeConstant object associated with the specified key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal key As String _
) As Object
C#
public object this[
   string key
]; {get;}

Parameters

key
A System.String value indicating the key of the theme constant to get.

Property Value

A System.Object object representing the theme constant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConstantsCollection Class
ConstantsCollection Members


Font Class

[image]
ActiveReports 19 .NET Edition
Font Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Font Class

Glossary Item Box

Represents a font of the theme, providing access to font family, size, style and weight.

Object Model

Font Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Font
C#
public sealed class Font

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Font Class Members

[image]
ActiveReports 19 .NET Edition
Font Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Font Class

Glossary Item Box

The following tables list the members exposed by Font.

Public Properties

 | Name | Description
Public Property | Family | Gets the family name of this theme font.
Public Property | Size | Gets the size of this theme font.
Public Property | Style | Gets the style of this theme font.
Public Property | Weight | Gets the weight of this theme font.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Font Class Properties

[image]
ActiveReports 19 .NET Edition
Font Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Font Class

Glossary Item Box

For a list of all members of this type, see Font members.

Public Properties

 | Name | Description
Public Property | Family | Gets the family name of this theme font.
Public Property | Size | Gets the size of this theme font.
Public Property | Style | Gets the style of this theme font.
Public Property | Weight | Gets the weight of this theme font.
Top

See Also

Reference

Font Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Family Property

[image]
ActiveReports 19 .NET Edition
Family Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Font Class : Family Property

Glossary Item Box

Gets the family name of this theme font.

Syntax

Visual Basic (Declaration)
Public Property Family As String
C#
public string Family {get; set;}

Property Value

A System.String value indicating the font family name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Font Class : Size Property

Glossary Item Box

Gets the size of this theme font.

Syntax

Visual Basic (Declaration)
Public Property Size As Length
C#
public Length Size {get; set;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value indicating the font size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Font Class : Style Property

Glossary Item Box

Gets the style of this theme font.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

A System.String value indicating the font style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Weight Property

[image]
ActiveReports 19 .NET Edition
Weight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Font Class : Weight Property

Glossary Item Box

Gets the weight of this theme font.

Syntax

Visual Basic (Declaration)
Public Property Weight As String
C#
public string Weight {get; set;}

Property Value

A System.String value indicating the font weight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Font Class
Font Members


Fonts Class

[image]
ActiveReports 19 .NET Edition
Fonts Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Fonts Class

Glossary Item Box

Represents a collection of fonts for the theme, providing access to major and minor fonts as well as the ability to retrieve fonts by name.

Object Model

Fonts Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Fonts
C#
public sealed class Fonts

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Fonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fonts Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Fonts Class Members

[image]
ActiveReports 19 .NET Edition
Fonts Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Fonts Class

Glossary Item Box

The following tables list the members exposed by Fonts.

Public Properties

 | Name | Description
Public Property | Item | Gets a font associated with the specified name.
Public Property | MajorFont | Gets a major font.
Public Property | MinorFont | Gets a minor font.
Top

See Also

Reference

Fonts Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Fonts Class Properties

[image]
ActiveReports 19 .NET Edition
Fonts Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Fonts Class

Glossary Item Box

For a list of all members of this type, see Fonts members.

Public Properties

 | Name | Description
Public Property | Item | Gets a font associated with the specified name.
Public Property | MajorFont | Gets a major font.
Public Property | MinorFont | Gets a minor font.
Top

See Also

Reference

Fonts Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Fonts Class : Item Property

name
A System.String value indicating the name of the font to retrieve.

Glossary Item Box

Gets a font associated with the specified name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As Font
C#
public Font this[
   string name
]; {get;}

Parameters

name
A System.String value indicating the name of the font to retrieve.

Property Value

A Font object associated with the specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fonts Class
Fonts Members


MajorFont Property

[image]
ActiveReports 19 .NET Edition
MajorFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Fonts Class : MajorFont Property

Glossary Item Box

Gets a major font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorFont As Font
C#
public Font MajorFont {get;}

Property Value

A Font object used for primary content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fonts Class
Fonts Members


MinorFont Property

[image]
ActiveReports 19 .NET Edition
MinorFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Fonts Class : MinorFont Property

Glossary Item Box

Gets a minor font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinorFont As Font
C#
public Font MinorFont {get;}

Property Value

A Font object used for secondary content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fonts Class
Fonts Members


Image Class

[image]
ActiveReports 19 .NET Edition
Image Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Image Class

Glossary Item Box

Represents an image of the theme, providing access to binary data, name and MIME type.

Object Model

Image Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Image
C#
public sealed class Image

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Image Class Members

[image]
ActiveReports 19 .NET Edition
Image Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Image Class

Glossary Item Box

The following tables list the members exposed by Image.

Public Constructors

 | Name | Description
Public Constructor | Image Constructor | Initializes a new instance of the Image class in the Theme Editor.
Top

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets the binary data associated with this image.
Public Property | MIMEType | Gets or sets the MIME type of this image.
Public Property | Name | Gets or sets the name of this image.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Image Constructor

[image]
ActiveReports 19 .NET Edition
Image Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Image Class : Image Constructor

Glossary Item Box

Initializes a new instance of the Image class in the Theme Editor.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Image()

Remarks

This constructor should not be used directly in application code. It is designed is for deserialization purposes and should not be used directly. It may be changed or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Image Class Properties

[image]
ActiveReports 19 .NET Edition
Image Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Image Class

Glossary Item Box

For a list of all members of this type, see Image members.

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets the binary data associated with this image.
Public Property | MIMEType | Gets or sets the MIME type of this image.
Public Property | Name | Gets or sets the name of this image.
Top

See Also

Reference

Image Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


ImageData Property

[image]
ActiveReports 19 .NET Edition
ImageData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Image Class : ImageData Property

Glossary Item Box

Gets or sets the binary data associated with this image.

Syntax

Visual Basic (Declaration)
Public Property ImageData As Byte()
C#
public byte[] ImageData {get; set;}

Property Value

A System.Byte array representing the image data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


MIMEType Property

[image]
ActiveReports 19 .NET Edition
MIMEType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Image Class : MIMEType Property

Glossary Item Box

Gets or sets the MIME type of this image.

Syntax

Visual Basic (Declaration)
Public Property MIMEType As String
C#
public string MIMEType {get; set;}

Property Value

A System.String value indicating the MIME type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Image Class : Name Property

Glossary Item Box

Gets or sets the name of this image.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A System.String value indicating the name of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


Images Class

[image]
ActiveReports 19 .NET Edition
Images Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Images Class

Glossary Item Box

Represents a collection of images associated with a theme.

Object Model

Images Class

Syntax

Visual Basic (Declaration)
Public Class Images
C#
public class Images

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Images

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Images Class Members

[image]
ActiveReports 19 .NET Edition
Images Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Images Class

Glossary Item Box

The following tables list the members exposed by Images.

Public Constructors

 | Name | Description
Public Constructor | Images Constructor | Initializes a new instance of the Images class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets a number of images in the collection.
Public Property | Item | Gets the Image using a specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an image to the collection.
Public Method | Clear | Removes all images from the collection.
Public Method | Remove | Removes a specified image from the collection.
Top

See Also

Reference

Images Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Images Constructor

[image]
ActiveReports 19 .NET Edition
Images Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Images Constructor

Glossary Item Box

Initializes a new instance of the Images class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Images()

Remarks

For internal use only. Used to create the new images collection in the Theme Editor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Images Class Methods

[image]
ActiveReports 19 .NET Edition
Images Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Images Class

Glossary Item Box

For a list of all members of this type, see Images members.

Public Methods

 | Name | Description
Public Method | Add | Adds an image to the collection.
Public Method | Clear | Removes all images from the collection.
Public Method | Remove | Removes a specified image from the collection.
Top

See Also

Reference

Images Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Add Method

image
An Image object to add.

Glossary Item Box

Adds an image to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal image As Image _
)
C#
public void Add(
   Image image
)

Parameters

image
An Image object to add.

Exceptions

Exception | Description
System.ArgumentException | Throws if the collection already has an image with the same name as image has.
System.ArgumentNullException | Throws if image is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Clear Method

Glossary Item Box

Removes all images from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Remove Method

image
A Image object to remove.

Glossary Item Box

Removes a specified image from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal image As Image _
)
C#
public void Remove(
   Image image
)

Parameters

image
A Image object to remove.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if image is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Images Class Properties

[image]
ActiveReports 19 .NET Edition
Images Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Images Class

Glossary Item Box

For a list of all members of this type, see Images members.

Public Properties

 | Name | Description
Public Property | Count | Gets a number of images in the collection.
Public Property | Item | Gets the Image using a specified name.
Top

See Also

Reference

Images Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Count Property

Glossary Item Box

Gets a number of images in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

A System.Int32 value indicating the number of images in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Images Class : Item Property

name
A System.String value indicating the name of the image to get.

Glossary Item Box

Gets the Image using a specified name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As Image
C#
public Image this[
   string name
]; {get;}

Parameters

name
A System.String value indicating the name of the image to get.

Property Value

An Image object with the specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Images Class
Images Members


Theme Class

[image]
ActiveReports 19 .NET Edition
Theme Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Theme Class

Glossary Item Box

Represents a theme that contains various design elements such as fonts, images, and colors.

Object Model

Theme Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Theme
C#
public sealed class Theme

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.Theme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


Theme Class Members

[image]
ActiveReports 19 .NET Edition
Theme Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Theme Class

Glossary Item Box

The following tables list the members exposed by Theme.

Public Constructors

 | Name | Description
Public Constructor | Theme Constructor |
Top

Public Properties

 | Name | Description
Public Property | Colors | Gets the colors associated with this theme.
Public Property | Constants | Gets the theme constants collection.
Public Property | ConstantsDictionary | Gets the constants dictionary associated with this theme. Use only for serialization. For API usage, the Constants property should be used.
Public Property | Fonts | Gets the fonts associated with this theme.
Public Property | Images | Gets the images associated with this theme.
Public Property | Item | Gets a property value by its name.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a theme using the specified theme URI and resource locator.
static (Shared in Visual Basic) | Load | Loads a theme from the specified XML stream.
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Theme Constructor

[image]
ActiveReports 19 .NET Edition
Theme Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Theme Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Theme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Theme Class Methods

[image]
ActiveReports 19 .NET Edition
Theme Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Theme Class

Glossary Item Box

For a list of all members of this type, see Theme members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a theme using the specified theme URI and resource locator.
static (Shared in Visual Basic) | Load | Loads a theme from the specified XML stream.
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Create Method

themeUri
A System.String value indicating the URI of the theme.
locator
A GrapeCity.ActiveReports.ResourceLocator object for locating theme resources.

Glossary Item Box

Creates a theme using the specified theme URI and resource locator.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal themeUri As String, _
   ByVal locator As ResourceLocator _
) As Theme
C#
public static Theme Create(
   string themeUri,
   ResourceLocator locator
)

Parameters

themeUri
A System.String value indicating the URI of the theme.
locator
A GrapeCity.ActiveReports.ResourceLocator object for locating theme resources.

Return Value

A new instance of Theme.

Example

C# Copy Code
Uri themeUri = new Uri("path/to/theme/file.rdlx-theme");
ResourceLocator resourceLocator = GetResourceLocator();
Theme theme = Theme.Create(themeUri, resourceLocator)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Load Method

stream
A XML System.IO.Stream containing the theme data.

Glossary Item Box

Loads a theme from the specified XML stream.

Syntax

Visual Basic (Declaration)
Public Shared Function Load( _
   ByVal stream As Stream _
) As Theme
C#
public static Theme Load(
   Stream stream
)

Parameters

stream
A XML System.IO.Stream containing the theme data.

Return Value

A Theme object representing the loaded theme.

Example

C# Copy Code
using FileStream fileStream = new FileStream(""path/to/theme/file.rdlx-theme"", FileMode.Open, FileAccess.Read);
Theme theme = Theme.Load(fileStream)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Theme Class Properties

[image]
ActiveReports 19 .NET Edition
Theme Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Theme Class

Glossary Item Box

For a list of all members of this type, see Theme members.

Public Properties

 | Name | Description
Public Property | Colors | Gets the colors associated with this theme.
Public Property | Constants | Gets the theme constants collection.
Public Property | ConstantsDictionary | Gets the constants dictionary associated with this theme. Use only for serialization. For API usage, the Constants property should be used.
Public Property | Fonts | Gets the fonts associated with this theme.
Public Property | Images | Gets the images associated with this theme.
Public Property | Item | Gets a property value by its name.
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Colors Property

[image]
ActiveReports 19 .NET Edition
Colors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Colors Property

Glossary Item Box

Gets the colors associated with this theme.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Colors As Colors
C#
public Colors Colors {get;}

Property Value

A Colors associated with this theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Constants Property

[image]
ActiveReports 19 .NET Edition
Constants Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Constants Property

Glossary Item Box

Gets the theme constants collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Constants As ConstantsCollection
C#
public ConstantsCollection Constants {get;}

Property Value

A ConstantsCollection object representing the collection of theme constants.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


ConstantsDictionary Property

[image]
ActiveReports 19 .NET Edition
ConstantsDictionary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : ConstantsDictionary Property

Glossary Item Box

Gets the constants dictionary associated with this theme. Use only for serialization. For API usage, the Constants property should be used.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConstantsDictionary As Dictionary(Of String,ThemeConstant)
C#
public Dictionary<string,ThemeConstant> ConstantsDictionary {get;}

Property Value

A dictionary where the key is a System.String value representing the constant name and the value is a ThemeConstant object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Fonts Property

[image]
ActiveReports 19 .NET Edition
Fonts Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Fonts Property

Glossary Item Box

Gets the fonts associated with this theme.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fonts As Fonts
C#
public Fonts Fonts {get;}

Property Value

A Fonts associated with this theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Images Property

[image]
ActiveReports 19 .NET Edition
Images Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Images Property

Glossary Item Box

Gets the images associated with this theme.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Images As Images
C#
public Images Images {get;}

Property Value

An Images associated with this theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > Theme Class : Item Property

name
A System.String value indicating the name of the property.

Glossary Item Box

Gets a property value by its name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As Object
C#
public object this[
   string name
]; {get;}

Parameters

name
A System.String value indicating the name of the property.

Property Value

An System.Object representing the property value.

Remarks

The indexer to support the various VB collection access syntax.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


ThemeConstant Class

[image]
ActiveReports 19 .NET Edition
ThemeConstant Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ThemeConstant Class

Glossary Item Box

Represents a theme constant.

Object Model

ThemeConstant Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeConstant
C#
public sealed class ThemeConstant

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.ThemeConstant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


ThemeConstant Class Members

[image]
ActiveReports 19 .NET Edition
ThemeConstant Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ThemeConstant Class

Glossary Item Box

The following tables list the members exposed by ThemeConstant.

Public Constructors

 | Name | Description
Public Constructor | ThemeConstant Constructor | Initializes a new instance of the ThemeConstant class.
Top

Public Fields

 | Name | Description
Public Field | Description | Gets the description of the theme constant.
static (Shared in Visual Basic) | Empty | Gets an empty ThemeConstant instance.
Public Field | Key | Gets the key of the theme constant.
Public Field | Value | Gets the value of the theme constant as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


ThemeConstant Constructor

[image]
ActiveReports 19 .NET Edition
ThemeConstant Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ThemeConstant Class : ThemeConstant Constructor

key
A System.String value indicating the key of the theme constant.
value
A System.String value indicating the value of the theme constant as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.
description
A System.String value indicating the description of the theme constant.

Glossary Item Box

Initializes a new instance of the ThemeConstant class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal value As String, _
   ByVal description As String _
)
C#
public ThemeConstant(
   string key,
   string value,
   string description
)

Parameters

key
A System.String value indicating the key of the theme constant.
value
A System.String value indicating the value of the theme constant as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.
description
A System.String value indicating the description of the theme constant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


ThemeConstant Class Fields

[image]
ActiveReports 19 .NET Edition
ThemeConstant Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ThemeConstant Class

Glossary Item Box

For a list of all members of this type, see ThemeConstant members.

Public Fields

 | Name | Description
Public Field | Description | Gets the description of the theme constant.
static (Shared in Visual Basic) | Empty | Gets an empty ThemeConstant instance.
Public Field | Key | Gets the key of the theme constant.
Public Field | Value | Gets the value of the theme constant as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


Description Field

[image]
ActiveReports 19 .NET Edition
Description Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ThemeConstant Class : Description Field

Glossary Item Box

Gets the description of the theme constant.

Syntax

Visual Basic (Declaration)
Public ReadOnly Description As String
C#
public readonly string Description

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ThemeConstant Class : Empty Field

Glossary Item Box

Gets an empty ThemeConstant instance.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As ThemeConstant
C#
public static readonly ThemeConstant Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


Key Field

[image]
ActiveReports 19 .NET Edition
Key Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ThemeConstant Class : Key Field

Glossary Item Box

Gets the key of the theme constant.

Syntax

Visual Basic (Declaration)
Public ReadOnly Key As String
C#
public readonly string Key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ThemeConstant Class : Value Field

Glossary Item Box

Gets the value of the theme constant as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As ExpressionInfo
C#
public readonly ExpressionInfo Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


XmlThemeReader Class

[image]
ActiveReports 19 .NET Edition
XmlThemeReader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeReader Class

Glossary Item Box

Provides functionality to read and parse Theme from XML.

Object Model

XmlThemeReader Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlThemeReader
C#
public sealed class XmlThemeReader

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.XmlThemeReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlThemeReader Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


XmlThemeReader Class Members

[image]
ActiveReports 19 .NET Edition
XmlThemeReader Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeReader Class

Glossary Item Box

The following tables list the members exposed by XmlThemeReader.

Public Constructors

 | Name | Description
Public Constructor | XmlThemeReader Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadTheme | Reads a theme from the specified file.
Top

See Also

Reference

XmlThemeReader Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


XmlThemeReader Constructor

[image]
ActiveReports 19 .NET Edition
XmlThemeReader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > XmlThemeReader Class : XmlThemeReader Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public XmlThemeReader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlThemeReader Class
XmlThemeReader Members


XmlThemeReader Class Methods

[image]
ActiveReports 19 .NET Edition
XmlThemeReader Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeReader Class

Glossary Item Box

For a list of all members of this type, see XmlThemeReader members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadTheme | Reads a theme from the specified file.
Top

See Also

Reference

XmlThemeReader Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


ReadTheme(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
ReadTheme(FileInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > XmlThemeReader Class : ReadTheme(FileInfo) Method

themefileInfo
The System.IO.FileInfo object representing the file that contains the theme.

Glossary Item Box

Reads a theme from the specified file.

Syntax

Visual Basic (Declaration)
Public Shared Function ReadTheme( _
   ByVal themefileInfo As FileInfo _
) As Theme
C#
public static Theme ReadTheme(
   FileInfo themefileInfo
)

Parameters

themefileInfo
The System.IO.FileInfo object representing the file that contains the theme.

Return Value

A Theme object representing the parsed theme.

Exceptions

Exception | Description
System.IO.FileNotFoundException | Thrown if the specified file does not exist.
System.IO.IOException | Thrown if an I/O error occurs while opening the file.

Example

C# Copy Code
var themeFileInfo = new FileInfo("path/to/theme.rdlx-theme");
var theme = XmlThemeReader.ReadTheme(themeFileInfo);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlThemeReader Class
XmlThemeReader Members


XmlThemeWriter Class

[image]
ActiveReports 19 .NET Edition
XmlThemeWriter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeWriter Class

Glossary Item Box

Represents a set of method allows to save a theme.

Object Model

XmlThemeWriter Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class XmlThemeWriter
C#
public static class XmlThemeWriter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Themes.XmlThemeWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlThemeWriter Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


XmlThemeWriter Class Members

[image]
ActiveReports 19 .NET Edition
XmlThemeWriter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeWriter Class

Glossary Item Box

The following tables list the members exposed by XmlThemeWriter.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | WriteTheme | Saves the specified theme to the specified file.
Top

See Also

Reference

XmlThemeWriter Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


XmlThemeWriter Class Methods

[image]
ActiveReports 19 .NET Edition
XmlThemeWriter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : XmlThemeWriter Class

Glossary Item Box

For a list of all members of this type, see XmlThemeWriter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | WriteTheme | Saves the specified theme to the specified file.
Top

See Also

Reference

XmlThemeWriter Class
GrapeCity.ActiveReports.Rdl.Themes Namespace


WriteTheme Method

[image]
ActiveReports 19 .NET Edition
WriteTheme Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > XmlThemeWriter Class : WriteTheme Method

theme
A Theme object to save.
fileInfo
A System.IO.FileInfo object representing the file where the theme will be saved.

Glossary Item Box

Saves the specified theme to the specified file.

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteTheme( _
   ByVal theme As Theme, _
   ByVal fileInfo As FileInfo _
)
C#
public static void WriteTheme(
   Theme theme,
   FileInfo fileInfo
)

Parameters

theme
A Theme object to save.
fileInfo
A System.IO.FileInfo object representing the file where the theme will be saved.

Example

C# Copy Code
var themeFileInfo = new FileInfo("path/for/theme.rdlx-theme");
XmlThemeWriter.WriteTheme(yourTheme, themeFileInfo);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlThemeWriter Class
XmlThemeWriter Members


Colors.BaseColor Enumeration

[image]
ActiveReports 19 .NET Edition
Colors.BaseColor Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : Colors.BaseColor Enumeration

Glossary Item Box

Specifies the base theme colors.

Syntax

Visual Basic (Declaration)
Public Enum Colors.BaseColor
   Inherits System.Enum
C#
public enum Colors.BaseColor : System.Enum

Members

Member | Description
Accent1 | The Accent1 theme color.
Accent2 | The Accent2 theme color.
Accent3 | The Accent3 theme color.
Accent4 | The Accent4 theme color.
Accent5 | The Accent5 theme color.
Accent6 | The Accent6 theme color.
Dark1 | The Dark1 theme color.
Dark2 | The Dark2 theme color.
Hyperlink | The Hyperlink theme color.
HyperlinkFollowed | The HyperlinkFollowed theme color.
Light1 | The Light1 theme color.
Light2 | The Light2 theme color.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Themes.Colors.BaseColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Themes Namespace


ITheme Interface

[image]
ActiveReports 19 .NET Edition
ITheme Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ITheme Interface

Glossary Item Box

Represents an interface to interact with theme information.

Syntax

Visual Basic (Declaration)
Public Interface ITheme
C#
public interface ITheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Members
GrapeCity.ActiveReports.Rdl.Themes Namespace


ITheme Interface Members

[image]
ActiveReports 19 .NET Edition
ITheme Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ITheme Interface

Glossary Item Box

The following tables list the members exposed by ITheme.

Public Properties

 | Name | Description
Property | Theme | Gets the currently attached theme.
Property | ThemeAttached | Gets a value indicating whether a theme file is currently attached.
Property | ThemeUri | Gets the URI of the currently attached theme.
Top

Public Methods

 | Name | Description
Method | CreateTheme | Creates a new theme based on the supplied URI.
Method | GetColors | Returns all the theme colors associated with the currently attached theme.
Top

See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Rdl.Themes Namespace


ITheme Interface Methods

[image]
ActiveReports 19 .NET Edition
ITheme Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ITheme Interface

Glossary Item Box

For a list of all members of this type, see ITheme members.

Public Methods

 | Name | Description
Method | CreateTheme | Creates a new theme based on the supplied URI.
Method | GetColors | Returns all the theme colors associated with the currently attached theme.
Top

See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Rdl.Themes Namespace


CreateTheme Method

[image]
ActiveReports 19 .NET Edition
CreateTheme Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ITheme Interface : CreateTheme Method

uri
A System.String value indicating URI of the theme to create.

Glossary Item Box

Creates a new theme based on the supplied URI.

Syntax

Visual Basic (Declaration)
Sub CreateTheme( _
   ByVal uri As String _
)
C#
void CreateTheme(
   string uri
)

Parameters

uri
A System.String value indicating URI of the theme to create.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Interface
ITheme Members


GetColors Method

[image]
ActiveReports 19 .NET Edition
GetColors Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ITheme Interface : GetColors Method

Glossary Item Box

Returns all the theme colors associated with the currently attached theme.

Syntax

Visual Basic (Declaration)
Function GetColors() As String()
C#
string[] GetColors()

Return Value

A jagged array of System.String representing the theme colors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Interface
ITheme Members


ITheme Interface Properties

[image]
ActiveReports 19 .NET Edition
ITheme Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace : ITheme Interface

Glossary Item Box

For a list of all members of this type, see ITheme members.

Public Properties

 | Name | Description
Property | Theme | Gets the currently attached theme.
Property | ThemeAttached | Gets a value indicating whether a theme file is currently attached.
Property | ThemeUri | Gets the URI of the currently attached theme.
Top

See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Rdl.Themes Namespace


Theme Property

[image]
ActiveReports 19 .NET Edition
Theme Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ITheme Interface : Theme Property

Glossary Item Box

Gets the currently attached theme.

Syntax

Visual Basic (Declaration)
ReadOnly Property Theme As Theme
C#
Theme Theme {get;}

Property Value

A Theme object representing the currently attached theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Interface
ITheme Members


ThemeAttached Property

[image]
ActiveReports 19 .NET Edition
ThemeAttached Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ITheme Interface : ThemeAttached Property

Glossary Item Box

Gets a value indicating whether a theme file is currently attached.

Syntax

Visual Basic (Declaration)
ReadOnly Property ThemeAttached As Boolean
C#
bool ThemeAttached {get;}

Property Value

A System.Boolean value. true if a theme file is currently attached; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Interface
ITheme Members


ThemeUri Property

[image]
ActiveReports 19 .NET Edition
ThemeUri Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Themes Namespace > ITheme Interface : ThemeUri Property

Glossary Item Box

Gets the URI of the currently attached theme.

Syntax

Visual Basic (Declaration)
ReadOnly Property ThemeUri As String
C#
string ThemeUri {get;}

Property Value

A System.String value indicating the URI of the currently attached theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITheme Interface
ITheme Members


ActionExtensions Class

[image]
ActiveReports 19 .NET Edition
ActionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ActionExtensions Class

Glossary Item Box

Represents a set of extension methods for the GrapeCity.ActiveReports.PageReportModel.Action class.

Object Model

ActionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ActionExtensions
C#
public static class ActionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ActionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionExtensions Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


ActionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ActionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ActionExtensions Class

Glossary Item Box

The following tables list the members exposed by ActionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsEmpty | Gets a value indicating whether the specified action is empty.
Top

See Also

Reference

ActionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ActionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ActionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ActionExtensions Class

Glossary Item Box

For a list of all members of this type, see ActionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsEmpty | Gets a value indicating whether the specified action is empty.
Top

See Also

Reference

ActionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


IsEmpty Method

[image]
ActiveReports 19 .NET Edition
IsEmpty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ActionExtensions Class : IsEmpty Method

action
The GrapeCity.ActiveReports.PageReportModel.Action object to check.

Glossary Item Box

Gets a value indicating whether the specified action is empty.

Syntax

Visual Basic (Declaration)
Public Shared Function IsEmpty( _
   ByVal action As Action _
) As Boolean
C#
public static bool IsEmpty(
   Action action
)

Parameters

action
The GrapeCity.ActiveReports.PageReportModel.Action object to check.

Return Value

A System.Boolean value. true if the action is empty; otherwise, false.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionExtensions Class
ActionExtensions Members


CollectionExtensions Class

[image]
ActiveReports 19 .NET Edition
CollectionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : CollectionExtensions Class

Glossary Item Box

Represents a set of extension methods for the collection classes.

Object Model

CollectionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CollectionExtensions
C#
public static class CollectionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.CollectionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CollectionExtensions Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


CollectionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
CollectionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : CollectionExtensions Class

Glossary Item Box

The following tables list the members exposed by CollectionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddRange<TCollection,TItem> | Adds a range of items to the specified collection.
static (Shared in Visual Basic) | Sum | Computes the sum of a sequence of GrapeCity.ActiveReports.PageReportModel.Length values.
Top

See Also

Reference

CollectionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


CollectionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
CollectionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : CollectionExtensions Class

Glossary Item Box

For a list of all members of this type, see CollectionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddRange<TCollection,TItem> | Adds a range of items to the specified collection.
static (Shared in Visual Basic) | Sum | Computes the sum of a sequence of GrapeCity.ActiveReports.PageReportModel.Length values.
Top

See Also

Reference

CollectionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


AddRange<TCollection,TItem> Method

TCollection
The type of the collection.
TItem
The type of the items in the collection.
[image]
ActiveReports 19 .NET Edition
AddRange<TCollection,TItem> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > CollectionExtensions Class : AddRange<TCollection,TItem> Method

collection
The collection to add items to.
items
The items to add to the collection.

Glossary Item Box

Adds a range of items to the specified collection.

Syntax

Visual Basic (Declaration)
Public Shared Function AddRange
    (Of TCollection As ICollection(Of TItem),
     TItem)( _
   ByVal collection As TCollection, _
   ByVal items As IEnumerable(Of TItem) _
) As TCollection
C#
public static TCollection AddRange<TCollection,TItem>(
   TCollection collection,
   IEnumerable<TItem> items
)
where TCollection: ICollection<TItem>

Parameters

collection
The collection to add items to.
items
The items to add to the collection.

Type Parameters

TCollection
The type of the collection.
TItem
The type of the items in the collection.

Return Value

A collection with the items added.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CollectionExtensions Class
CollectionExtensions Members


Sum Method

[image]
ActiveReports 19 .NET Edition
Sum Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > CollectionExtensions Class : Sum Method

seq
A sequence of GrapeCity.ActiveReports.PageReportModel.Length values to compute.

Glossary Item Box

Computes the sum of a sequence of GrapeCity.ActiveReports.PageReportModel.Length values.

Syntax

Visual Basic (Declaration)
Public Shared Function Sum( _
   ByVal seq As IEnumerable(Of Length) _
) As Length
C#
public static Length Sum(
   IEnumerable<Length> seq
)

Parameters

seq
A sequence of GrapeCity.ActiveReports.PageReportModel.Length values to compute.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the sum of the sequence of GrapeCity.ActiveReports.PageReportModel.Length values.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CollectionExtensions Class
CollectionExtensions Members


ColorTranslator Class

[image]
ActiveReports 19 .NET Edition
ColorTranslator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ColorTranslator Class

Glossary Item Box

Providers functionality for values converting colors represented in various string formats to system colors.

Object Model

ColorTranslator Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ColorTranslator
C#
public static class ColorTranslator

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ColorTranslator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTranslator Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


ColorTranslator Class Members

[image]
ActiveReports 19 .NET Edition
ColorTranslator Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ColorTranslator Class

Glossary Item Box

The following tables list the members exposed by ColorTranslator.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColorMap |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromHtml |
Top

See Also

Reference

ColorTranslator Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ColorTranslator Class Methods

[image]
ActiveReports 19 .NET Edition
ColorTranslator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ColorTranslator Class

Glossary Item Box

For a list of all members of this type, see ColorTranslator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromHtml |
Top

See Also

Reference

ColorTranslator Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


FromHtml Method

[image]
ActiveReports 19 .NET Edition
FromHtml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ColorTranslator Class : FromHtml Method

htmlColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function FromHtml( _
   ByVal htmlColor As String _
) As Color
C#
public static Color FromHtml(
   string htmlColor
)

Parameters

htmlColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTranslator Class
ColorTranslator Members


ColorTranslator Class Fields

[image]
ActiveReports 19 .NET Edition
ColorTranslator Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ColorTranslator Class

Glossary Item Box

For a list of all members of this type, see ColorTranslator members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ColorMap |
Top

See Also

Reference

ColorTranslator Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ColorMap Field

[image]
ActiveReports 19 .NET Edition
ColorMap Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ColorTranslator Class : ColorMap Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ColorMap As Dictionary(Of String,Color)
C#
public static readonly Dictionary<string,Color> ColorMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorTranslator Class
ColorTranslator Members


LoadHelper Class

[image]
ActiveReports 19 .NET Edition
LoadHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : LoadHelper Class

Glossary Item Box

Represents a set of methods to loading data sets.

Object Model

LoadHelper Class

Syntax

Visual Basic (Declaration)
Public Class LoadHelper
C#
public class LoadHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.LoadHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoadHelper Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


LoadHelper Class Members

[image]
ActiveReports 19 .NET Edition
LoadHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : LoadHelper Class

Glossary Item Box

The following tables list the members exposed by LoadHelper.

Public Constructors

 | Name | Description
Public Constructor | LoadHelper Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadDataSet | Loads a data set using the specified resource locator and data set reference.
Top

See Also

Reference

LoadHelper Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


LoadHelper Constructor

[image]
ActiveReports 19 .NET Edition
LoadHelper Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > LoadHelper Class : LoadHelper Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LoadHelper()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoadHelper Class
LoadHelper Members


LoadHelper Class Methods

[image]
ActiveReports 19 .NET Edition
LoadHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : LoadHelper Class

Glossary Item Box

For a list of all members of this type, see LoadHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadDataSet | Loads a data set using the specified resource locator and data set reference.
Top

See Also

Reference

LoadHelper Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


LoadDataSet Method

[image]
ActiveReports 19 .NET Edition
LoadDataSet Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > LoadHelper Class : LoadDataSet Method

resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
dataSetReference
A System.String value indicating reference to the data set to be loaded.

Glossary Item Box

Loads a data set using the specified resource locator and data set reference.

Syntax

Visual Basic (Declaration)
Public Shared Function LoadDataSet( _
   ByVal resourceLocator As ResourceLocator, _
   ByVal dataSetReference As String _
) As IDataSet
C#
public static IDataSet LoadDataSet(
   ResourceLocator resourceLocator,
   string dataSetReference
)

Parameters

resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
dataSetReference
A System.String value indicating reference to the data set to be loaded.

Return Value

An GrapeCity.ActiveReports.PageReportModel.IDataSet object representing the loaded data set.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoadHelper Class
LoadHelper Members


ParameterCollectionExtensions Class

[image]
ActiveReports 19 .NET Edition
ParameterCollectionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ParameterCollectionExtensions Class

Glossary Item Box

Represents a set of extension methods for the GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection class.

Object Model

ParameterCollectionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ParameterCollectionExtensions
C#
public static class ParameterCollectionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ParameterCollectionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollectionExtensions Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


ParameterCollectionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ParameterCollectionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ParameterCollectionExtensions Class

Glossary Item Box

The following tables list the members exposed by ParameterCollectionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Sort | Sorts a parameter collection according to their dependencies on each other. The initial collection is not modified.
Top

See Also

Reference

ParameterCollectionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ParameterCollectionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterCollectionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ParameterCollectionExtensions Class

Glossary Item Box

For a list of all members of this type, see ParameterCollectionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Sort | Sorts a parameter collection according to their dependencies on each other. The initial collection is not modified.
Top

See Also

Reference

ParameterCollectionExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


Sort Method

[image]
ActiveReports 19 .NET Edition
Sort Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ParameterCollectionExtensions Class : Sort Method

initialParameters
A GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection object to be sorted.

Glossary Item Box

Sorts a parameter collection according to their dependencies on each other. The initial collection is not modified.

Syntax

Visual Basic (Declaration)
Public Shared Function Sort( _
   ByVal initialParameters As ReportParameterCollection _
) As IOrderedDictionary
C#
public static IOrderedDictionary Sort(
   ReportParameterCollection initialParameters
)

Parameters

initialParameters
A GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection object to be sorted.

Return Value

An ordered collection of the GrapeCity.ActiveReports.PageReportModel.ReportParameter objects.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollectionExtensions Class
ParameterCollectionExtensions Members


ReportExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportExtensions Class

Glossary Item Box

Represents a set of extension methods for the GrapeCity.ActiveReports.PageReportModel.Report class to visit, modify, or extract information from the Report definition model.

Object Model

ReportExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportExtensions
C#
public static class ReportExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ReportExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


ReportExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Copy | Creates a copy of the report.
static (Shared in Visual Basic) | Downgrade | Downgrades a multi-section report to the old RDL 2005 model without sections.
static (Shared in Visual Basic) | FromString | Creates a report from an RDL (Report Definition Language) string.
static (Shared in Visual Basic) | GetAllReportItems | Enumerates all report items (from body, header, footer, and their descendants).
static (Shared in Visual Basic) | GetSelfAndAllDescendants | Enumerates self and all descendants. Enumerates a report item and all its descendants.
static (Shared in Visual Basic) | MergeWithMaster | Merges a report with its master report.
static (Shared in Visual Basic) | PreSortReport | Pre-sorts a report for optimized processing.
static (Shared in Visual Basic) | SaveRdl | Saves the report as RDL (Report Definition Language) using the specified XML writer.
static (Shared in Visual Basic) | ToRdlString | Converts the report to an RDL (Report Definition Language) string representation.
static (Shared in Visual Basic) | Upgrade | Upgrades a report to a multi-section report.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ReportExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Copy | Creates a copy of the report.
static (Shared in Visual Basic) | Downgrade | Downgrades a multi-section report to the old RDL 2005 model without sections.
static (Shared in Visual Basic) | FromString | Creates a report from an RDL (Report Definition Language) string.
static (Shared in Visual Basic) | GetAllReportItems | Enumerates all report items (from body, header, footer, and their descendants).
static (Shared in Visual Basic) | GetSelfAndAllDescendants | Enumerates self and all descendants. Enumerates a report item and all its descendants.
static (Shared in Visual Basic) | MergeWithMaster | Merges a report with its master report.
static (Shared in Visual Basic) | PreSortReport | Pre-sorts a report for optimized processing.
static (Shared in Visual Basic) | SaveRdl | Saves the report as RDL (Report Definition Language) using the specified XML writer.
static (Shared in Visual Basic) | ToRdlString | Converts the report to an RDL (Report Definition Language) string representation.
static (Shared in Visual Basic) | Upgrade | Upgrades a report to a multi-section report.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


Copy Method

[image]
ActiveReports 19 .NET Edition
Copy Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : Copy Method

report
A GrapeCity.ActiveReports.PageReportModel.Report to copy for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.

Glossary Item Box

Creates a copy of the report.

Syntax

Visual Basic (Declaration)
Public Shared Function Copy( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator _
) As Report
C#
public static Report Copy(
   Report report,
   ResourceLocator resourceLocator
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report to copy for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.

Return Value

A new GrapeCity.ActiveReports.PageReportModel.Report object that is a copy of the original.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


Downgrade Method

[image]
ActiveReports 19 .NET Edition
Downgrade Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : Downgrade Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to downgrade for.

Glossary Item Box

Downgrades a multi-section report to the old RDL 2005 model without sections.

Syntax

Visual Basic (Declaration)
Public Shared Sub Downgrade( _
   ByVal report As Report _
)
C#
public static void Downgrade(
   Report report
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to downgrade for.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : FromString Method

rdlText
A RDL System.String value to create the report from.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource. Default is null.

Glossary Item Box

Creates a report from an RDL (Report Definition Language) string.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal rdlText As String, _
   Optional ByVal resourceLocator As ResourceLocator _
) As Report
C#
public static Report FromString(
   string rdlText,
   ResourceLocator resourceLocator
)

Parameters

rdlText
A RDL System.String value to create the report from.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource. Default is null.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Report object created from the RDL string.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


GetAllReportItems Method

[image]
ActiveReports 19 .NET Edition
GetAllReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : GetAllReportItems Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to enumerate items from.

Glossary Item Box

Enumerates all report items (from body, header, footer, and their descendants).

Syntax

Visual Basic (Declaration)
Public Shared Function GetAllReportItems( _
   ByVal report As Report _
) As IEnumerable(Of ReportItem)
C#
public static IEnumerable<ReportItem> GetAllReportItems(
   Report report
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to enumerate items from.

Return Value

An IEnumerable object containing all report items.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


GetSelfAndAllDescendants Method

[image]
ActiveReports 19 .NET Edition
GetSelfAndAllDescendants Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : GetSelfAndAllDescendants Method

reportItem
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to enumerate for.

Glossary Item Box

Enumerates self and all descendants. Enumerates a report item and all its descendants.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSelfAndAllDescendants( _
   ByVal reportItem As ReportItem _
) As IEnumerable(Of ReportItem)
C#
public static IEnumerable<ReportItem> GetSelfAndAllDescendants(
   ReportItem reportItem
)

Parameters

reportItem
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to enumerate for.

Return Value

An IEnumerable object containing the report item and its descendants.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


MergeWithMaster Method

[image]
ActiveReports 19 .NET Edition
MergeWithMaster Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : MergeWithMaster Method

report
A GrapeCity.ActiveReports.PageReportModel.Report to merge for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
masterContentService
A GrapeCity.ActiveReports.PageReportModel.IMasterContentService object to provide master content. Default is null.

Glossary Item Box

Merges a report with its master report.

Syntax

Visual Basic (Declaration)
Public Shared Function MergeWithMaster( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal masterContentService As IMasterContentService _
) As Report
C#
public static Report MergeWithMaster(
   Report report,
   ResourceLocator resourceLocator,
   IMasterContentService masterContentService
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report to merge for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
masterContentService
A GrapeCity.ActiveReports.PageReportModel.IMasterContentService object to provide master content. Default is null.

Return Value

A GrapeCity.ActiveReports.PageReportModel.Report object that is the result of the merge.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


PreSortReport Method

[image]
ActiveReports 19 .NET Edition
PreSortReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : PreSortReport Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to pre-sort for.

Glossary Item Box

Pre-sorts a report for optimized processing.

Syntax

Visual Basic (Declaration)
Public Shared Sub PreSortReport( _
   ByVal report As Report _
)
C#
public static void PreSortReport(
   Report report
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to pre-sort for.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


SaveRdl Method

[image]
ActiveReports 19 .NET Edition
SaveRdl Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : SaveRdl Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to save for.
writer
A System.Xml.XmlWriter object to use for saving the report.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
isSnapShotFilter
A System.Boolean value indicating whether the snapshot filtering is applied. Default is false.

Glossary Item Box

Saves the report as RDL (Report Definition Language) using the specified XML writer.

Syntax

Visual Basic (Declaration)
Public Shared Sub SaveRdl( _
   ByVal report As Report, _
   ByVal writer As XmlWriter, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal isSnapShotFilter As Boolean _
)
C#
public static void SaveRdl(
   Report report,
   XmlWriter writer,
   ResourceLocator resourceLocator,
   bool isSnapShotFilter
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to save for.
writer
A System.Xml.XmlWriter object to use for saving the report.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
isSnapShotFilter
A System.Boolean value indicating whether the snapshot filtering is applied. Default is false.

Exceptions

Exception | Description
System.ArgumentNullException | Throws if writer is null.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


ToRdlString Method

[image]
ActiveReports 19 .NET Edition
ToRdlString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : ToRdlString Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to convert for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
reportComponentFactory
A GrapeCity.ActiveReports.IReportComponentFactory object to create report components. Default is null.
IsSnapShotFilter
A System.Boolean value indicating whether the snapshot filtering is applied. Default is false.

Glossary Item Box

Converts the report to an RDL (Report Definition Language) string representation.

Syntax

Visual Basic (Declaration)
Public Shared Function ToRdlString( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal reportComponentFactory As IReportComponentFactory, _
   Optional ByVal IsSnapShotFilter As Boolean _
) As String
C#
public static string ToRdlString(
   Report report,
   ResourceLocator resourceLocator,
   IReportComponentFactory reportComponentFactory,
   bool IsSnapShotFilter
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to convert for.
resourceLocator
A GrapeCity.ActiveReports.ResourceLocator object used to locate the resource.
reportComponentFactory
A GrapeCity.ActiveReports.IReportComponentFactory object to create report components. Default is null.
IsSnapShotFilter
A System.Boolean value indicating whether the snapshot filtering is applied. Default is false.

Return Value

A System.String value representing the RDL representation of the report.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


Upgrade Method

[image]
ActiveReports 19 .NET Edition
Upgrade Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportExtensions Class : Upgrade Method

report
A GrapeCity.ActiveReports.PageReportModel.Report object to upgrade for.

Glossary Item Box

Upgrades a report to a multi-section report.

Syntax

Visual Basic (Declaration)
Public Shared Sub Upgrade( _
   ByVal report As Report _
)
C#
public static void Upgrade(
   Report report
)

Parameters

report
A GrapeCity.ActiveReports.PageReportModel.Report object to upgrade for.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


ReportItemExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportItemExtensions Class

Glossary Item Box

Represents a set of extension methods for the GrapeCity.ActiveReports.PageReportModel.ReportItem class.

Object Model

ReportItemExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemExtensions
C#
public static class ReportItemExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ReportItemExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Members
GrapeCity.ActiveReports.Rdl.Tools Namespace


ReportItemExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportItemExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportItemExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Clone<TItem> | Creates a clone of a specified report component.
static (Shared in Visual Basic) | GetReportItemTypeName | Gets a type name of the report item.
Top

See Also

Reference

ReportItemExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


ReportItemExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ReportItemExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportItemExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Clone<TItem> | Creates a clone of a specified report component.
static (Shared in Visual Basic) | GetReportItemTypeName | Gets a type name of the report item.
Top

See Also

Reference

ReportItemExtensions Class
GrapeCity.ActiveReports.Rdl.Tools Namespace


Clone<TItem> Method

TItem
A type of the report component to clone.
[image]
ActiveReports 19 .NET Edition
Clone<TItem> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportItemExtensions Class : Clone<TItem> Method

item
An GrapeCity.ActiveReports.PageReportModel.IReportComponent object to clone.

Glossary Item Box

Creates a clone of a specified report component.

Syntax

Visual Basic (Declaration)
Public Shared Function Clone(Of TItem As IReportComponent)( _
   ByVal item As TItem _
) As TItem
C#
public static TItem Clone<TItem>(
   TItem item
)
where TItem: IReportComponent

Parameters

item
An GrapeCity.ActiveReports.PageReportModel.IReportComponent object to clone.

Type Parameters

TItem
A type of the report component to clone.

Return Value

A new instance of TItem that is a clone of the original.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


GetReportItemTypeName Method

[image]
ActiveReports 19 .NET Edition
GetReportItemTypeName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace > ReportItemExtensions Class : GetReportItemTypeName Method

item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to get the type name of.

Glossary Item Box

Gets a type name of the report item.

Syntax

Visual Basic (Declaration)
Public Shared Function GetReportItemTypeName( _
   ByVal item As ReportItem _
) As String
C#
public static string GetReportItemTypeName(
   ReportItem item
)

Parameters

item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to get the type name of.

Return Value

A System.String value indicating the type name of the report item.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


ColorTranslator.KnownColor Enumeration

[image]
ActiveReports 19 .NET Edition
ColorTranslator.KnownColor Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools Namespace : ColorTranslator.KnownColor Enumeration

Glossary Item Box

Represents known System Color names

Syntax

Visual Basic (Declaration)
Public Enum ColorTranslator.KnownColor
   Inherits System.Enum
C#
public enum ColorTranslator.KnownColor : System.Enum

Members

Member | Description
AliceBlue |
AntiqueWhite |
Aqua |
Aquamarine |
Azure |
Beige |
Bisque |
Black |
BlanchedAlmond |
Blue |
BlueViolet |
Brown |
BurlyWood |
CadetBlue |
Chartreuse |
Chocolate |
Coral |
CornflowerBlue |
Cornsilk |
Crimson |
Cyan |
DarkBlue |
DarkCyan |
DarkGoldenrod |
DarkGray |
DarkGreen |
DarkKhaki |
DarkMagenta |
DarkOliveGreen |
DarkOrange |
DarkOrchid |
DarkRed |
DarkSalmon |
DarkSeaGreen |
DarkSlateBlue |
DarkSlateGray |
DarkTurquoise |
DarkViolet |
DeepPink |
DeepSkyBlue |
DimGray |
DodgerBlue |
Firebrick |
FloralWhite |
ForestGreen |
Fuchsia |
Gainsboro |
GhostWhite |
Gold |
Goldenrod |
Gray |
Green |
GreenYellow |
Honeydew |
HotPink |
IndianRed |
Indigo |
Ivory |
Khaki |
Lavender |
LavenderBlush |
LawnGreen |
LemonChiffon |
LightBlue |
LightCoral |
LightCyan |
LightGoldenrodYellow |
LightGray |
LightGreen |
LightPink |
LightSalmon |
LightSeaGreen |
LightSkyBlue |
LightSlateGray |
LightSteelBlue |
LightYellow |
Lime |
LimeGreen |
Linen |
Magenta |
Maroon |
MediumAquamarine |
MediumBlue |
MediumOrchid |
MediumPurple |
MediumSeaGreen |
MediumSlateBlue |
MediumSpringGreen |
MediumTurquoise |
MediumVioletRed |
MidnightBlue |
MintCream |
MistyRose |
Moccasin |
NavajoWhite |
Navy |
OldLace |
Olive |
OliveDrab |
Orange |
OrangeRed |
Orchid |
PaleGoldenrod |
PaleGreen |
PaleTurquoise |
PaleVioletRed |
PapayaWhip |
PeachPuff |
Peru |
Pink |
Plum |
PowderBlue |
Purple |
Red |
RosyBrown |
RoyalBlue |
SaddleBrown |
Salmon |
SandyBrown |
SeaGreen |
SeaShell |
Sienna |
Silver |
SkyBlue |
SlateBlue |
SlateGray |
Snow |
SpringGreen |
SteelBlue |
Tan |
Teal |
Thistle |
Tomato |
Transparent |
Turquoise |
Violet |
Wheat |
White |
WhiteSmoke |
Yellow |
YellowGreen |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Tools.ColorTranslator.KnownColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Tools Namespace


ReportItemTransformersFactory Class

[image]
ActiveReports 19 .NET Edition
ReportItemTransformersFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : ReportItemTransformersFactory Class

Glossary Item Box

Registered report items transformers.

Object Model

ReportItemTransformersFactory Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemTransformersFactory
C#
public static class ReportItemTransformersFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade.ReportItemTransformersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemTransformersFactory Members
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


ReportItemTransformersFactory Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemTransformersFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : ReportItemTransformersFactory Class

Glossary Item Box

The following tables list the members exposed by ReportItemTransformersFactory.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetTransformer | Gets a report item transformer using specified report item.
static (Shared in Visual Basic) | Register | Registers report item transformer in the transformers list.
Top

See Also

Reference

ReportItemTransformersFactory Class
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


ReportItemTransformersFactory Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemTransformersFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : ReportItemTransformersFactory Class

Glossary Item Box

For a list of all members of this type, see ReportItemTransformersFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetTransformer | Gets a report item transformer using specified report item.
static (Shared in Visual Basic) | Register | Registers report item transformer in the transformers list.
Top

See Also

Reference

ReportItemTransformersFactory Class
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


GetTransformer(ReportItem) Method

[image]
ActiveReports 19 .NET Edition
GetTransformer(ReportItem) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace > ReportItemTransformersFactory Class : GetTransformer(ReportItem) Method

item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to get transformer for.

Glossary Item Box

Gets a report item transformer using specified report item.

Syntax

Visual Basic (Declaration)
Public Shared Function GetTransformer( _
   ByVal item As ReportItem _
) As IReportItemTransformer
C#
public static IReportItemTransformer GetTransformer(
   ReportItem item
)

Parameters

item
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to get transformer for.

Return Value

A IReportItemTransformer object representing the report item transformer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemTransformersFactory Class
ReportItemTransformersFactory Members


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace > ReportItemTransformersFactory Class : Register Method

type
The type of report item to register for.
getTransformer
The function to get a transformer instance to be registered.

Glossary Item Box

Registers report item transformer in the transformers list.

Syntax

Visual Basic (Declaration)
Public Shared Sub Register( _
   ByVal type As Type, _
   ByVal getTransformer As Func(Of IReportItemTransformer) _
)
C#
public static void Register(
   Type type,
   Func<IReportItemTransformer> getTransformer
)

Parameters

type
The type of report item to register for.
getTransformer
The function to get a transformer instance to be registered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemTransformersFactory Class
ReportItemTransformersFactory Members


IReportItemTransformer Interface

[image]
ActiveReports 19 .NET Edition
IReportItemTransformer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : IReportItemTransformer Interface

Glossary Item Box

Implement this interface if you want to transform specified report item to new report item.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemTransformer
C#
public interface IReportItemTransformer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemTransformer Members
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


IReportItemTransformer Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemTransformer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : IReportItemTransformer Interface

Glossary Item Box

The following tables list the members exposed by IReportItemTransformer.

Public Methods

 | Name | Description
Method | TransformReportItem | Creates new GrapeCity.ActiveReports.PageReportModel.ReportItem object from specified report item.
Top

See Also

Reference

IReportItemTransformer Interface
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


IReportItemTransformer Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportItemTransformer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace : IReportItemTransformer Interface

Glossary Item Box

For a list of all members of this type, see IReportItemTransformer members.

Public Methods

 | Name | Description
Method | TransformReportItem | Creates new GrapeCity.ActiveReports.PageReportModel.ReportItem object from specified report item.
Top

See Also

Reference

IReportItemTransformer Interface
GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace


TransformReportItem Method

[image]
ActiveReports 19 .NET Edition
TransformReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Tools.ReportUpgrade Namespace > IReportItemTransformer Interface : TransformReportItem Method

reportItem
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to transform for.

Glossary Item Box

Creates new GrapeCity.ActiveReports.PageReportModel.ReportItem object from specified report item.

Syntax

Visual Basic (Declaration)
Function TransformReportItem( _
   ByVal reportItem As ReportItem _
) As ReportItem
C#
ReportItem TransformReportItem(
   ReportItem reportItem
)

Parameters

reportItem
A GrapeCity.ActiveReports.PageReportModel.ReportItem object to transform for.

Return Value

New GrapeCity.ActiveReports.PageReportModel.ReportItem instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemTransformer Interface
IReportItemTransformer Members


ValidationReportException Class

[image]
ActiveReports 19 .NET Edition
ValidationReportException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace : ValidationReportException Class

Glossary Item Box

Represents an exception about report validation errors.

Object Model

ValidationReportException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValidationReportException
   Inherits System.Exception
C#
public sealed class ValidationReportException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationReportException Members
GrapeCity.ActiveReports.Rdl.Validation Namespace


ValidationReportException Class Members

[image]
ActiveReports 19 .NET Edition
ValidationReportException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace : ValidationReportException Class

Glossary Item Box

The following tables list the members exposed by ValidationReportException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | InvalidGroupingName | Creates a new ValidationReportException indicating that the specified grouping name is invalid.
static (Shared in Visual Basic) | InvalidGroupingParent | Creates a new ValidationReportException indicating that the specified grouping parent is invalid.
static (Shared in Visual Basic) | SubreportNotFound | Creates a new ValidationReportException indicating that the specified subreport was not found.
Top

See Also

Reference

ValidationReportException Class
GrapeCity.ActiveReports.Rdl.Validation Namespace


ValidationReportException Class Methods

[image]
ActiveReports 19 .NET Edition
ValidationReportException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace : ValidationReportException Class

Glossary Item Box

For a list of all members of this type, see ValidationReportException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | InvalidGroupingName | Creates a new ValidationReportException indicating that the specified grouping name is invalid.
static (Shared in Visual Basic) | InvalidGroupingParent | Creates a new ValidationReportException indicating that the specified grouping parent is invalid.
static (Shared in Visual Basic) | SubreportNotFound | Creates a new ValidationReportException indicating that the specified subreport was not found.
Top

See Also

Reference

ValidationReportException Class
GrapeCity.ActiveReports.Rdl.Validation Namespace


InvalidGroupingName Method

[image]
ActiveReports 19 .NET Edition
InvalidGroupingName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace > ValidationReportException Class : InvalidGroupingName Method

groupName
A System.String value indicating the name of the invalid grouping.

Glossary Item Box

Creates a new ValidationReportException indicating that the specified grouping name is invalid.

Syntax

Visual Basic (Declaration)
Public Shared Function InvalidGroupingName( _
   ByVal groupName As String _
) As ValidationReportException
C#
public static ValidationReportException InvalidGroupingName(
   string groupName
)

Parameters

groupName
A System.String value indicating the name of the invalid grouping.

Return Value

A new ValidationReportException instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationReportException Class
ValidationReportException Members


InvalidGroupingParent Method

[image]
ActiveReports 19 .NET Edition
InvalidGroupingParent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace > ValidationReportException Class : InvalidGroupingParent Method

groupName
A System.String value indicating the name of the invalid grouping parent.

Glossary Item Box

Creates a new ValidationReportException indicating that the specified grouping parent is invalid.

Syntax

Visual Basic (Declaration)
Public Shared Function InvalidGroupingParent( _
   ByVal groupName As String _
) As ValidationReportException
C#
public static ValidationReportException InvalidGroupingParent(
   string groupName
)

Parameters

groupName
A System.String value indicating the name of the invalid grouping parent.

Return Value

A new ValidationReportException instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationReportException Class
ValidationReportException Members


SubreportNotFound Method

[image]
ActiveReports 19 .NET Edition
SubreportNotFound Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace > ValidationReportException Class : SubreportNotFound Method

reportName
A System.String value indicating the name of the subreport that was not found.

Glossary Item Box

Creates a new ValidationReportException indicating that the specified subreport was not found.

Syntax

Visual Basic (Declaration)
Public Shared Function SubreportNotFound( _
   ByVal reportName As String _
) As ValidationReportException
C#
public static ValidationReportException SubreportNotFound(
   string reportName
)

Parameters

reportName
A System.String value indicating the name of the subreport that was not found.

Return Value

A new ValidationReportException instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationReportException Class
ValidationReportException Members


ValidationReportException Class Properties

[image]
ActiveReports 19 .NET Edition
ValidationReportException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace : ValidationReportException Class

Glossary Item Box

For a list of all members of this type, see ValidationReportException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with this exception.
Top

See Also

Reference

ValidationReportException Class
GrapeCity.ActiveReports.Rdl.Validation Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace > ValidationReportException Class : ErrorCode Property

Glossary Item Box

Gets the error code associated with this exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As ValidationReportException.ErrorCodes
C#
public ValidationReportException.ErrorCodes ErrorCode {get;}

Property Value

An ValidationReportException.ErrorCodes value indicating the specific type of report validation error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationReportException Class
ValidationReportException Members


ValidationReportException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
ValidationReportException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rdl Assembly > GrapeCity.ActiveReports.Rdl.Validation Namespace : ValidationReportException.ErrorCodes Enumeration

Glossary Item Box

Specifies the possible error codes for report validation exceptions.

Syntax

Visual Basic (Declaration)
Public Enum ValidationReportException.ErrorCodes
   Inherits System.Enum
C#
public enum ValidationReportException.ErrorCodes : System.Enum

Members

Member | Description
BadReportItemName | Bad report item name.
CircularReferenceFromAnother | Circular reference from another item.
CircularReferenceToItself | Circular reference to itself.
DataRegionMissingDataSetName | Data region missing dataset name.
DataRegionWithNoGrouping | Data region with no grouping.
InvalidActionControlInPageHeaderFooter | Invalid action control in page header or footer.
InvalidCustomDataDataGrouping | Invalid custom data grouping.
InvalidDataRegionDataSetName | Invalid data region dataset name.
InvalidDataRegionName | Invalid data region name.
InvalidGroupingName | Invalid grouping name.
InvalidGroupingParent | Invalid grouping parent.
InvalidToggleControlInPageHeaderFooter | Invalid toggle control in page header or footer.
InvalidToggleItemReference | Invalid toggle item reference.
InvalidUserSortSortExpressionNoScope | Invalid user sort expression without scope.
InvalidUsingPageNumberReference | Invalid reference to page number.
InvalidUsingReportItemReference | Invalid using report item reference.
MissingRequiredElement | Missing a required element.
OverflowHeightTooSmall | Overflow height is too small.
OverflowWidthTooSmall | Overflow width is too small.
ReportItemExpressionReferenceMustBeInScope | Report item expression reference must be in scope.
ReportItemExpressionReferenceShouldNotContainOtherReferences | Report item expression reference should not contain other references.
SubreportNotFound | Subreport not found.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rdl.Validation.ValidationReportException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rdl.Validation Namespace


BarCodeException Class

[image]
ActiveReports 19 .NET Edition
BarCodeException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarCodeException Class

Glossary Item Box

The exception thrown when an error is caused by an inapplicable value of the barcode control.

Object Model

BarCodeException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BarCodeException
   Inherits System.Exception
C#
public sealed class BarCodeException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.BarCodes.BarCodeException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Members
GrapeCity.ActiveReports.BarCodes Namespace


BarCodeException Class Members

[image]
ActiveReports 19 .NET Edition
BarCodeException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarCodeException Class

Glossary Item Box

The following tables list the members exposed by BarCodeException.

Public Constructors

 | Name | Description
Public Constructor | BarCodeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code of current exception.
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

See Also

Reference

BarCodeException Class
GrapeCity.ActiveReports.BarCodes Namespace


BarCodeException Constructor

[image]
ActiveReports 19 .NET Edition
BarCodeException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarCodeException Class : BarCodeException Constructor

Glossary Item Box

Overload List

Overload | Description
BarCodeException Constructor(ErrorCodes) | Creates new BarCodeException instance.
BarCodeException Constructor(ErrorCodes,Object[]) | Creates new BarCodeException instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Class
BarCodeException Members


BarCodeException Constructor(ErrorCodes)

[image]
ActiveReports 19 .NET Edition
BarCodeException Constructor(ErrorCodes)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarCodeException Class > BarCodeException Constructor : BarCodeException Constructor(ErrorCodes)

errorCode
Error code.

Glossary Item Box

Creates new BarCodeException instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorCode As BarCodeException.ErrorCodes _
)
C#
public BarCodeException(
   BarCodeException.ErrorCodes errorCode
)

Parameters

errorCode
Error code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Class
BarCodeException Members
Overload List


BarCodeException Constructor(ErrorCodes,Object[])

[image]
ActiveReports 19 .NET Edition
BarCodeException Constructor(ErrorCodes,Object[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarCodeException Class > BarCodeException Constructor : BarCodeException Constructor(ErrorCodes,Object[])

errorCode
Error code.
messageFormatArgs
Message formatting arguments.

Glossary Item Box

Creates new BarCodeException instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorCode As BarCodeException.ErrorCodes, _
   ByVal ParamArray messageFormatArgs() As Object _
)
C#
public BarCodeException(
   BarCodeException.ErrorCodes errorCode,
   params object[] messageFormatArgs
)

Parameters

errorCode
Error code.
messageFormatArgs
Message formatting arguments.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Class
BarCodeException Members
Overload List


BarCodeException Class Properties

[image]
ActiveReports 19 .NET Edition
BarCodeException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarCodeException Class

Glossary Item Box

For a list of all members of this type, see BarCodeException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code of current exception.
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

See Also

Reference

BarCodeException Class
GrapeCity.ActiveReports.BarCodes Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarCodeException Class : ErrorCode Property

Glossary Item Box

Error code of current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As BarCodeException.ErrorCodes
C#
public BarCodeException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Class
BarCodeException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarCodeException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarCodeException Class
BarCodeException Members


BarEngine.UpcE0Encoder Class

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE0Encoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcE0Encoder Class

Glossary Item Box

Object Model

BarEngine.UpcE0Encoder Class

Syntax

Visual Basic (Declaration)
Public Class BarEngine.UpcE0Encoder
   Inherits BarEngine.UpcEEncoder
C#
public class BarEngine.UpcE0Encoder : BarEngine.UpcEEncoder

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcEEncoder
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcE0Encoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcE0Encoder Members
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcE0Encoder Class Members

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE0Encoder Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcE0Encoder Class

Glossary Item Box

The following tables list the members exposed by BarEngine.UpcE0Encoder.

Public Constructors

 | Name | Description
Public Constructor | BarEngine.UpcE0Encoder Constructor |
Top

See Also

Reference

BarEngine.UpcE0Encoder Class
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcE0Encoder Constructor

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE0Encoder Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.UpcE0Encoder Class : BarEngine.UpcE0Encoder Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BarEngine.UpcE0Encoder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcE0Encoder Class
BarEngine.UpcE0Encoder Members


BarEngine.UpcE1Encoder Class

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE1Encoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcE1Encoder Class

Glossary Item Box

Object Model

BarEngine.UpcE1Encoder Class

Syntax

Visual Basic (Declaration)
Public Class BarEngine.UpcE1Encoder
   Inherits BarEngine.UpcEEncoder
C#
public class BarEngine.UpcE1Encoder : BarEngine.UpcEEncoder

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcEEncoder
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcE1Encoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcE1Encoder Members
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcE1Encoder Class Members

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE1Encoder Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcE1Encoder Class

Glossary Item Box

The following tables list the members exposed by BarEngine.UpcE1Encoder.

Public Constructors

 | Name | Description
Public Constructor | BarEngine.UpcE1Encoder Constructor |
Top

See Also

Reference

BarEngine.UpcE1Encoder Class
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcE1Encoder Constructor

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcE1Encoder Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.UpcE1Encoder Class : BarEngine.UpcE1Encoder Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BarEngine.UpcE1Encoder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcE1Encoder Class
BarEngine.UpcE1Encoder Members


BarEngine.UpcEEncoder Class

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcEEncoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcEEncoder Class

Glossary Item Box

Object Model

BarEngine.UpcEEncoder Class

Syntax

Visual Basic (Declaration)
Public Class BarEngine.UpcEEncoder
C#
public class BarEngine.UpcEEncoder

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcEEncoder
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcE0Encoder
GrapeCity.ActiveReports.BarCodes.BarEngine.UpcE1Encoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcEEncoder Members
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcEEncoder Class Members

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcEEncoder Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.UpcEEncoder Class

Glossary Item Box

The following tables list the members exposed by BarEngine.UpcEEncoder.

Public Constructors

 | Name | Description
Public Constructor | BarEngine.UpcEEncoder Constructor |
Top

See Also

Reference

BarEngine.UpcEEncoder Class
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.UpcEEncoder Constructor

[image]
ActiveReports 19 .NET Edition
BarEngine.UpcEEncoder Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.UpcEEncoder Class : BarEngine.UpcEEncoder Constructor

code

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As Integer _
)
C#
public BarEngine.UpcEEncoder(
   int code
)

Parameters

code

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.UpcEEncoder Class
BarEngine.UpcEEncoder Members


DrawingDeviceBase Class

[image]
ActiveReports 19 .NET Edition
DrawingDeviceBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DrawingDeviceBase Class

Glossary Item Box

Base class for PageDrawingDevice and GdiDrawingDevice

Object Model

DrawingDeviceBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DrawingDeviceBase
C#
public abstract class DrawingDeviceBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.BarCodes.DrawingDeviceBase
GrapeCity.ActiveReports.BarCodes.Drawing.PageDrawingDevice

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingDeviceBase Members
GrapeCity.ActiveReports.BarCodes Namespace


DrawingDeviceBase Class Members

[image]
ActiveReports 19 .NET Edition
DrawingDeviceBase Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DrawingDeviceBase Class

Glossary Item Box

The following tables list the members exposed by DrawingDeviceBase.

Public Methods

 | Name | Description
Public Method | Dispose |
Top

See Also

Reference

DrawingDeviceBase Class
GrapeCity.ActiveReports.BarCodes Namespace


DrawingDeviceBase Class Methods

[image]
ActiveReports 19 .NET Edition
DrawingDeviceBase Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DrawingDeviceBase Class

Glossary Item Box

For a list of all members of this type, see DrawingDeviceBase members.

Public Methods

 | Name | Description
Public Method | Dispose |
Top

See Also

Reference

DrawingDeviceBase Class
GrapeCity.ActiveReports.BarCodes Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > DrawingDeviceBase Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingDeviceBase Class
DrawingDeviceBase Members


BarCodeException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarCodeException.ErrorCodes Enumeration

Glossary Item Box

Barcode error codes.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeException.ErrorCodes
   Inherits System.Enum
C#
public enum BarCodeException.ErrorCodes : System.Enum

Members

Member | Description
AztecErrorCorrection |
AztecLayers |
BadValue |
Code128Selector |
Code49GroupNo |
DataMatrixFileIdentifier |
DataMatrixStructureNumber |
HaveNoValue |
IncorrectValueLength |
MicroPDF417CompactionMode |
MicroPDF417FileID |
MicroPDF417SegmentCount |
MicroPDF417SegmentIndex |
MicroPDF417SegmentIndexCount |
NoEncoding |
NoMoreConnection |
NoMoreGroup |
OverConnection |
ParameterError |
PDF417Col |
PDF417ErrorLevel |
PDF417Row |
QRCodeConnectionNo |
QRCodeModel1Version |
QRCodeModel2Version |
RSSExpandedStackedCount |
TooBigValue |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.BarCodeException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.BarStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BarEngine.BarStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.BarStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BarEngine.BarStyle
   Inherits System.Enum
C#
public enum BarEngine.BarStyle : System.Enum

Members

Member | Description
cbsAnsi39 |
cbsAnsi39x |
cbsAztec |
cbsBc412 |
cbsCCA |
cbsCCB |
cbsCodabar |
cbsCode11 |
cbsCode128A |
cbsCode128Auto |
cbsCode128B |
cbsCode128C |
cbsCode25Intlv |
cbsCode25Mat |
cbsCode2Of5 |
cbsCode39 |
cbsCode39x |
cbsCode49 |
cbsCode93 |
cbsCode93x |
cbsDataMatrix |
cbsEAN128FNC1 |
cbsEan13 |
cbsEan8 |
cbsGS1DataMatrix |
cbsGS1QRCode |
cbsHIBCCode128 |
cbsHIBCCode39 |
cbsIata25 |
cbsIntelligentMail |
cbsIntelligentMailPackage |
cbsISBN |
cbsISMN |
cbsISSN |
cbsITF14 |
cbsJapanesePostal |
cbsMaxiCode |
cbsMicroPDF417 |
cbsMicroQRCode |
cbsMsi |
cbsNone |
cbsPdf417 |
cbsPharmacode |
cbsPlessey |
cbsPostNet |
cbsPZN |
cbsQRCode |
cbsRm4Scc |
cbsRSS14 |
cbsRSS14Stacked |
cbsRSS14StackedOmnidirectional |
cbsRSS14Truncated |
cbsRSSExpanded |
cbsRSSExpandedStacked |
cbsRSSLimited |
cbsSSCC18 |
cbsSupplement2 |
cbsSupplement5 |
cbsTelepen |
cbsUccEan128 |
cbsUpcA |
cbsUpcE0 |
cbsUpcE1 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.BarEngine.BarStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.EncodingMode Enumeration

[image]
ActiveReports 19 .NET Edition
BarEngine.EncodingMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.EncodingMode Enumeration

Glossary Item Box

Current encoding mode (primary for QR code).

Syntax

Visual Basic (Declaration)
Public Enum BarEngine.EncodingMode
   Inherits System.Enum
C#
public enum BarEngine.EncodingMode : System.Enum

Members

Member | Description
Binary | Force binary mode (if supported).
Default | Default mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.BarEngine.EncodingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


DataMatrixEcc000_140SymbolSize Enumeration

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc000_140SymbolSize Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DataMatrixEcc000_140SymbolSize Enumeration

Glossary Item Box

Specifies the symbol size enumeration for ECC000-140 mode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEcc000_140SymbolSize
   Inherits System.Enum
C#
public enum DataMatrixEcc000_140SymbolSize : System.Enum

Members

Member | Description
Auto | Auto. The smallest symbol size which fits the data will be selected automatically.
Square11 | Square11. Represents 11 by 11 square symbol.
Square13 | Square13. Represents 13 by 13 square symbol.
Square15 | Square15. Represents 15 by 15 square symbol.
Square17 | Square17. Represents 17 by 17 square symbol.
Square19 | Square19. Represents 19 by 19 square symbol.
Square21 | Square21. Represents 21 by 21 square symbol.
Square23 | Square23. Represents 23 by 23 square symbol.
Square25 | Square25. Represents 25 by 25 square symbol.
Square27 | Square27. Represents 27 by 27 square symbol.
Square29 | Square29. Represents 29 by 29 square symbol.
Square31 | Square31. Represents 31 by 31 square symbol.
Square33 | Square33. Represents 33 by 33 square symbol.
Square35 | Square35. Represents 35 by 35 square symbol.
Square37 | Square37 Represents 37 by 37 square symbol.
Square39 | Square39. Represents 39 by 39 square symbol.
Square41 | Square41. Represents 41 by 41 square symbol.
Square43 | Square43. Represents 43 by 43 square symbol.
Square45 | Square45. Represents 45 by 45 square symbol.
Square47 | Square47. Represents 47 by 47 square symbol.
Square49 | Square49. Represents 49 by 49 square symbol.
Square9 | Square9. Represents 9 by 9 square symbol.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.DataMatrixEcc000_140SymbolSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


DataMatrixEcc200EncodingMode Enumeration

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc200EncodingMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DataMatrixEcc200EncodingMode Enumeration

Glossary Item Box

Specifies the enumeration of encoding char set under ECC200 mode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEcc200EncodingMode
   Inherits System.Enum
C#
public enum DataMatrixEcc200EncodingMode : System.Enum

Members

Member | Description
ASCII | ASCII.
Auto | Auto. The encoding char set will be selected automatically to achieve a better compression efficiency.
Base256 | Base256.
C40 | C40.
EDIFACT | EDIFACT. Only 63 EDIFACT characters are supported by this char set.
Text | Text.
X12 | X12. Only 40 X12 characters are supported by this char set.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.DataMatrixEcc200EncodingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


DataMatrixEcc200SymbolSize Enumeration

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc200SymbolSize Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DataMatrixEcc200SymbolSize Enumeration

Glossary Item Box

Specifies the symbol size enumeration for ECC200 mode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEcc200SymbolSize
   Inherits System.Enum
C#
public enum DataMatrixEcc200SymbolSize : System.Enum

Members

Member | Description
Rectangular12x26 | Rectangular12x26. Represents 12 by 26 rectangular symbol.
Rectangular12x36 | Rectangular12x36. Represents 12 by 36 rectangular symbol.
Rectangular16x36 | Rectangular16x36. Represents 16 by 36 rectangular symbol.
Rectangular16x48 | Rectangular16x48. Represents 16 by 48 rectangular symbol.
Rectangular8x18 | Rectangular8x18. Represents 8 by 18 rectangular symbol.
Rectangular8x32 | Rectangular8x32. Represents 8 by 32 rectangular symbol.
RectangularAuto | RectangularAuto. The minimum rectangular symbol size that fits the data will be selected automatically.
Square10 | Square10. Represents 10 by 10 square symbol.
Square104 | Square104. Represents 104 by 104 square symbol.
Square12 | Square12. Represents 12 by 12 square symbol.
Square120 | Square120. Represents 120 by 120 square symbol.
Square132 | Square132. Represents 132 by 132 square symbol.
Square14 | Square14. Represents 14 by 14 square symbol.
Square144 | Square144. Represents 144 by 144 square symbol.
Square16 | Square16. Represents 16 by 16 square symbol.
Square18 | Square18. Represents 18 by 18 square symbol.
Square20 | Square20. Represents 20 by 20 square symbol.
Square22 | Square22. Represents 22 by 22 square symbol.
Square24 | Square24. Represents 24 by 24 square symbol.
Square26 | Square26. Represents 26 by 26 square symbol.
Square32 | Square32. Represents 32 by 32 square symbol.
Square36 | Square36. Represents 36 by 36 square symbol.
Square40 | Square40. Represents 40 by 40 square symbol.
Square44 | Square44. Represents 44 by 44 square symbol.
Square48 | Square48. Represents 48 by 48 square symbol.
Square52 | Square52. Represents 52 by 52 square symbol.
Square64 | Square64. Represents 64 by 64 square symbol.
Square72 | Square72. Represents 72 by 72 square symbol.
Square80 | Square80. Represents 80 by 80 square symbol.
Square88 | Square88. Represents 88 by 88 square symbol.
Square96 | Square96. Represents 96 by 96 square symbol.
SquareAuto | SquareAuto. The minimum square symbol size that fits the data will be selected automatically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.DataMatrixEcc200SymbolSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


DataMatrixEccMode Enumeration

[image]
ActiveReports 19 .NET Edition
DataMatrixEccMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : DataMatrixEccMode Enumeration

Glossary Item Box

Specifies the ECC mode enumeration.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEccMode
   Inherits System.Enum
C#
public enum DataMatrixEccMode : System.Enum

Members

Member | Description
ECC000 | ECC000. This mode encodes data with only CRC checksum, no additional error checking bits. Data encoded with this ECC mode usually requiers the smallest symbol size.
ECC050 | ECC050.
ECC080 | ECC080.
ECC100 | ECC100.
ECC140 | ECC140.
ECC200 | ECC200. This is the suggested ECC mode. Data encoded with this ECC mode will be protedted Reed-Solomon error checking and correcting algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.DataMatrixEccMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


Direction Enumeration

[image]
ActiveReports 19 .NET Edition
Direction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : Direction Enumeration

Glossary Item Box

Specifies the direction.

Syntax

Visual Basic (Declaration)
Public Enum Direction
   Inherits System.Enum
C#
public enum Direction : System.Enum

Members

Member | Description
BottomToTop |
LeftToRight |
RightToLeft |
TopToBottom |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.Direction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


GS1CompositeType Enumeration

[image]
ActiveReports 19 .NET Edition
GS1CompositeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : GS1CompositeType Enumeration

Glossary Item Box

Specifies the composite symbol type for a GS1 barcode.

Syntax

Visual Basic (Declaration)
Public Enum GS1CompositeType
   Inherits System.Enum
C#
public enum GS1CompositeType : System.Enum

Members

Member | Description
CCA | Composite the GS1 barcode with a dependent CC-A barcode.
None | Does not composite the GS1 barcode with a depenent barcode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.GS1CompositeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MaxiCodeMode Enumeration

[image]
ActiveReports 19 .NET Edition
MaxiCodeMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MaxiCodeMode Enumeration

Glossary Item Box

Specifies the mode for MaxiCode.

Syntax

Visual Basic (Declaration)
Public Enum MaxiCodeMode
   Inherits System.Enum
C#
public enum MaxiCodeMode : System.Enum

Members

Member | Description
Mode2 | US Carrier with postal codes up to 9 digits in length. Approximately 138 numeric characters may be encoded in this mode.
Mode3 | International Carrier with alpha-numeric postal codes up to 6 digits in length. Approximately 93 characters may be encoded in this mode.
Mode4 | Standard Symbol encodes general information for purposes other than the shipping industry. Approximately 90 characters may be encoded in this mode.
Mode5 | Secure Symbol encodes general information with more error correction. Approximately 74 characters may be encoded in this mode.
Mode6 | Reader Program allows scanner manufacturers to program barcode readers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MaxiCodeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MicroPDF417SymbolCompactionMode Enumeration

[image]
ActiveReports 19 .NET Edition
MicroPDF417SymbolCompactionMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MicroPDF417SymbolCompactionMode Enumeration

Glossary Item Box

Specifies the compaction mode for MicroPDF417 encoding.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolCompactionMode
   Inherits System.Enum
C#
public enum MicroPDF417SymbolCompactionMode : System.Enum

Members

Member | Description
Auto | Auto, The compaction mode will be selected automatically to achieve a better compression efficiency.
ByteCompactionMode | Byte Compaction Mode.
NumericCompactionMode | Numeric Compaction Mode.
TextCompactionMode | Text Compaction Mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MicroPDF417SymbolCompactionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MicroPDF417SymbolVersion Enumeration

[image]
ActiveReports 19 .NET Edition
MicroPDF417SymbolVersion Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MicroPDF417SymbolVersion Enumeration

Glossary Item Box

Specifies the version for MicroPDF417 symbols.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolVersion
   Inherits System.Enum
C#
public enum MicroPDF417SymbolVersion : System.Enum

Members

Member | Description
ColumnPriorAuto | Symbol Size Auto The minimum symbol size with column prior that fits the data will be selected automatically.
RowPriorAuto | Symbol Size Auto The minimum symbol size with row prior that fits the data will be selected automatically.
Version1X11 | Version 1X11,Represents 1 column and 11 row.
Version1X14 | Version 1X14,Represents 1 column and 14 row.
Version1X17 | Version 1X17,Represents 1 column and 17 row.
Version1X20 | Version 1X20,Represents 1 column and 20 row.
Version1X24 | Version 1X24,Represents 1 column and 24 row.
Version1X28 | Version 1X28,Represents 1 column and 28 row.
Version2X11 | Version 2X11,Represents 2 column and 11 row.
Version2X14 | Version 2X14,Represents 2 column and 14 row.
Version2X17 | Version 2X17,Represents 2 column and 17 row.
Version2X20 | Version 2X20,Represents 2 column and 20 row.
Version2X23 | Version 2X23,Represents 2 column and 23 row.
Version2X26 | Version 2X26,Represents 2 column and 26 row.
Version2X8 | Version 2X8,Represents 2 column and 8 row.
Version3X10 | Version 3X10,Represents 3 column and 10 row.
Version3X12 | Version 3X12,Represents 3 column and 12 row.
Version3X15 | Version 3X15,Represents 3 column and 15 row.
Version3X20 | Version 3X20,Represents 3 column and 20 row.
Version3X26 | Version 3X26,Represents 3 column and 26 row.
Version3X32 | Version 3X32,Represents 3 column and 32 row.
Version3X38 | Version 3X38,Represents 3 column and 38 row.
Version3X44 | Version 3X44,Represents 3 column and 44 row.
Version3X6 | Version 3X6,Represents 3 column and 6 row.
Version3X8 | Version 3X8,Represents 3 column and 8 row.
Version4X10 | Version 4X10,Represents 4 column and 10 row.
Version4X12 | Version 4X12,Represents 4 column and 12 row.
Version4X15 | Version 4X15,Represents 4 column and 15 row.
Version4X20 | Version 4X20,Represents 4 column and 20 row.
Version4X26 | Version 4X26,Represents 4 column and 26 row.
Version4X32 | Version 4X32,Represents 4 column and 32 row.
Version4X38 | Version 4X38,Represents 4 column and 38 row.
Version4X4 | Version 4X4,Represents 4 column and 4 row.
Version4X44 | Version 4X44,Represents 4 column and 44 row.
Version4X6 | Version 4X6,Represents 4 column and 6 row.
Version4X8 | Version 4X8,Represents 4 column and 8 row.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MicroPDF417SymbolVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MicroQRCodeErrorLevel Enumeration

[image]
ActiveReports 19 .NET Edition
MicroQRCodeErrorLevel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MicroQRCodeErrorLevel Enumeration

Glossary Item Box

Specifies the MicroQRCode's error correction level.

Syntax

Visual Basic (Declaration)
Public Enum MicroQRCodeErrorLevel
   Inherits System.Enum
C#
public enum MicroQRCodeErrorLevel : System.Enum

Members

Member | Description
L | Low
M | Medium
None | None
Q | Quality

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MicroQRCodeErrorLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MicroQRCodeMask Enumeration

[image]
ActiveReports 19 .NET Edition
MicroQRCodeMask Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MicroQRCodeMask Enumeration

Glossary Item Box

Specifies the MicroQRCode's mask pattern reference.

Syntax

Visual Basic (Declaration)
Public Enum MicroQRCodeMask
   Inherits System.Enum
C#
public enum MicroQRCodeMask : System.Enum

Members

Member | Description
Auto | Auto configuration.
Mask00 | Pattern 000.
Mask01 | Pattern 001.
Mask10 | Pattern 010.
Mask11 | Pattern 011.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MicroQRCodeMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


MicroQRVersion Enumeration

[image]
ActiveReports 19 .NET Edition
MicroQRVersion Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : MicroQRVersion Enumeration

Glossary Item Box

Specifies the MicroQRCode's version.

Syntax

Visual Basic (Declaration)
Public Enum MicroQRVersion
   Inherits System.Enum
C#
public enum MicroQRVersion : System.Enum

Members

Member | Description
Auto | The version of QR code inferred automatically
M1 | Specifies the micro QR code of version M1 (11 modules).
M2 | Specifies the micro QR code of version M2 (13 modules).
M3 | Specifies the micro QR code of version M3 (15 modules).
M4 | Specifies the micro QR code of version M4 (17 modules).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.MicroQRVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


PDF417Type Enumeration

[image]
ActiveReports 19 .NET Edition
PDF417Type Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : PDF417Type Enumeration

Glossary Item Box

Specifies PDF417's barcode type.

Syntax

Visual Basic (Declaration)
Public Enum PDF417Type
   Inherits System.Enum
C#
public enum PDF417Type : System.Enum

Members

Member | Description
Normal | Standard type.
Simple | Compact type (right indicator is neither displayed nor printed).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.PDF417Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


QRCodeErrorLevel Enumeration

[image]
ActiveReports 19 .NET Edition
QRCodeErrorLevel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : QRCodeErrorLevel Enumeration

Glossary Item Box

Specifies the QRCode's error correction level.

Syntax

Visual Basic (Declaration)
Public Enum QRCodeErrorLevel
   Inherits System.Enum
C#
public enum QRCodeErrorLevel : System.Enum

Members

Member | Description
H | High
L | Low
M | Medium
Q | Quality

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.QRCodeErrorLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


QRCodeMask Enumeration

[image]
ActiveReports 19 .NET Edition
QRCodeMask Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : QRCodeMask Enumeration

Glossary Item Box

Specifies the QRCode's mask pattern reference.

Syntax

Visual Basic (Declaration)
Public Enum QRCodeMask
   Inherits System.Enum
C#
public enum QRCodeMask : System.Enum

Members

Member | Description
Auto | Auto configuration.
Mask000 | Pattern 000.
Mask001 | Pattern 001.
Mask010 | Pattern 010.
Mask011 | Pattern 011.
Mask100 | Pattern 100.
Mask101 | Pattern 101.
Mask110 | Pattern 110
Mask111 | Pattern 111

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.QRCodeMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


QRCodeModel Enumeration

[image]
ActiveReports 19 .NET Edition
QRCodeModel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : QRCodeModel Enumeration

Glossary Item Box

Specifies the QRCode's model.

Syntax

Visual Basic (Declaration)
Public Enum QRCodeModel
   Inherits System.Enum
C#
public enum QRCodeModel : System.Enum

Members

Member | Description
Model1 | 1
Model2 | 2

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BarCodes.QRCodeModel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.BarDataInfo Structure

[image]
ActiveReports 19 .NET Edition
BarEngine.BarDataInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.BarDataInfo Structure

Glossary Item Box

Object Model

BarEngine.BarDataInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure BarEngine.BarDataInfo
   Inherits System.ValueType
C#
public struct BarEngine.BarDataInfo : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.BarCodes.BarEngine.BarDataInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.BarDataInfo Members
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.BarDataInfo Structure Members

[image]
ActiveReports 19 .NET Edition
BarEngine.BarDataInfo Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.BarDataInfo Structure

Glossary Item Box

The following tables list the members exposed by BarEngine.BarDataInfo.

Public Constructors

 | Name | Description
Public Constructor | BarEngine.BarDataInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | CheckSumEnabled |
Public Property | DataLen |
Public Property | DataString |
Top

See Also

Reference

BarEngine.BarDataInfo Structure
GrapeCity.ActiveReports.BarCodes Namespace


BarEngine.BarDataInfo Constructor

[image]
ActiveReports 19 .NET Edition
BarEngine.BarDataInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.BarDataInfo Structure : BarEngine.BarDataInfo Constructor

data
checksum

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal checksum As Boolean _
)
C#
public BarEngine.BarDataInfo(
   string data,
   bool checksum
)

Parameters

data
checksum

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.BarDataInfo Structure
BarEngine.BarDataInfo Members


BarEngine.BarDataInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
BarEngine.BarDataInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace : BarEngine.BarDataInfo Structure

Glossary Item Box

For a list of all members of this type, see BarEngine.BarDataInfo members.

Public Properties

 | Name | Description
Public Property | CheckSumEnabled |
Public Property | DataLen |
Public Property | DataString |
Top

See Also

Reference

BarEngine.BarDataInfo Structure
GrapeCity.ActiveReports.BarCodes Namespace


CheckSumEnabled Property

[image]
ActiveReports 19 .NET Edition
CheckSumEnabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.BarDataInfo Structure : CheckSumEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckSumEnabled As Boolean
C#
public bool CheckSumEnabled {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.BarDataInfo Structure
BarEngine.BarDataInfo Members


DataLen Property

[image]
ActiveReports 19 .NET Edition
DataLen Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.BarDataInfo Structure : DataLen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataLen As Integer
C#
public int DataLen {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.BarDataInfo Structure
BarEngine.BarDataInfo Members


DataString Property

[image]
ActiveReports 19 .NET Edition
DataString Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.BarCodes Namespace > BarEngine.BarDataInfo Structure : DataString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataString As String
C#
public string DataString {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarEngine.BarDataInfo Structure
BarEngine.BarDataInfo Members


RenderingContext Class

[image]
ActiveReports 19 .NET Edition
RenderingContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : RenderingContext Class

Glossary Item Box

Represents a context with rendering time variables.

Object Model

RenderingContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RenderingContext
C#
public sealed class RenderingContext

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.RenderingContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingContext Members
GrapeCity.ActiveReports.Core.Rendering Namespace


RenderingContext Class Members

[image]
ActiveReports 19 .NET Edition
RenderingContext Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : RenderingContext Class

Glossary Item Box

The following tables list the members exposed by RenderingContext.

Public Constructors

 | Name | Description
Public Constructor | RenderingContext Constructor | Initializes a new instance of the RenderingContext class.
Top

Public Properties

 | Name | Description
Public Property | LayoutArea | Gets the layout area.
Public Property | PageInfo | Gets the page information service.
Public Property | ThemeIndex | Gets the theme index.
Top

See Also

Reference

RenderingContext Class
GrapeCity.ActiveReports.Core.Rendering Namespace


RenderingContext Constructor

[image]
ActiveReports 19 .NET Edition
RenderingContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > RenderingContext Class : RenderingContext Constructor

pageInfo
The page information service.
themeIndex
The theme index. Must be greater than or equal to 0.
layoutArea
Optional layout area.

Glossary Item Box

Initializes a new instance of the RenderingContext class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageInfo As IPageInformationService, _
   ByVal themeIndex As Integer, _
   Optional ByVal layoutArea As ILayoutArea _
)
C#
public RenderingContext(
   IPageInformationService pageInfo,
   int themeIndex,
   ILayoutArea layoutArea
)

Parameters

pageInfo
The page information service.
themeIndex
The theme index. Must be greater than or equal to 0.
layoutArea
Optional layout area.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when pageInfo is null.
System.ArgumentOutOfRangeException | Thrown when themeIndex is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingContext Class
RenderingContext Members


RenderingContext Class Properties

[image]
ActiveReports 19 .NET Edition
RenderingContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : RenderingContext Class

Glossary Item Box

For a list of all members of this type, see RenderingContext members.

Public Properties

 | Name | Description
Public Property | LayoutArea | Gets the layout area.
Public Property | PageInfo | Gets the page information service.
Public Property | ThemeIndex | Gets the theme index.
Top

See Also

Reference

RenderingContext Class
GrapeCity.ActiveReports.Core.Rendering Namespace


LayoutArea Property

[image]
ActiveReports 19 .NET Edition
LayoutArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > RenderingContext Class : LayoutArea Property

Glossary Item Box

Gets the layout area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutArea As ILayoutArea
C#
public ILayoutArea LayoutArea {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingContext Class
RenderingContext Members


PageInfo Property

[image]
ActiveReports 19 .NET Edition
PageInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > RenderingContext Class : PageInfo Property

Glossary Item Box

Gets the page information service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageInfo As IPageInformationService
C#
public IPageInformationService PageInfo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingContext Class
RenderingContext Members


ThemeIndex Property

[image]
ActiveReports 19 .NET Edition
ThemeIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > RenderingContext Class : ThemeIndex Property

Glossary Item Box

Gets the theme index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ThemeIndex As Integer
C#
public int ThemeIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingContext Class
RenderingContext Members


ReportEval Class

[image]
ActiveReports 19 .NET Edition
ReportEval Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : ReportEval Class

Glossary Item Box

Provides expression evaluation in the context of the report engine.

Object Model

ReportEval Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportEval
C#
public static class ReportEval

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.ReportEval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Members
GrapeCity.ActiveReports.Core.Rendering Namespace


ReportEval Class Members

[image]
ActiveReports 19 .NET Edition
ReportEval Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : ReportEval Class

Glossary Item Box

The following tables list the members exposed by ReportEval.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate | Evaluates the specified expression using the provided context.
static (Shared in Visual Basic) | MakeContext | Overloaded. Creates an evaluation context with the specified parameters.
static (Shared in Visual Basic) | MakeEvalFunc | Creates an expression evaluator with the given evaluation context.
static (Shared in Visual Basic) | MakeEvaluator | Creates an expression evaluator bound to the given context.
Top

See Also

Reference

ReportEval Class
GrapeCity.ActiveReports.Core.Rendering Namespace


ReportEval Class Methods

[image]
ActiveReports 19 .NET Edition
ReportEval Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : ReportEval Class

Glossary Item Box

For a list of all members of this type, see ReportEval members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate | Evaluates the specified expression using the provided context.
static (Shared in Visual Basic) | MakeContext | Overloaded. Creates an evaluation context with the specified parameters.
static (Shared in Visual Basic) | MakeEvalFunc | Creates an expression evaluator with the given evaluation context.
static (Shared in Visual Basic) | MakeEvaluator | Creates an expression evaluator bound to the given context.
Top

See Also

Reference

ReportEval Class
GrapeCity.ActiveReports.Core.Rendering Namespace


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class : Evaluate Method

expr
The expression to evaluate.
context
The context in which to evaluate the expression.

Glossary Item Box

Evaluates the specified expression using the provided context.

Syntax

Visual Basic (Declaration)
Public Shared Function Evaluate( _
   ByVal expr As ExpressionInfo, _
   ByVal context As IExpressionContext _
) As Object
C#
public static object Evaluate(
   ExpressionInfo expr,
   IExpressionContext context
)

Parameters

expr
The expression to evaluate.
context
The context in which to evaluate the expression.

Return Value

The result of the evaluation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members


MakeContext Method

[image]
ActiveReports 19 .NET Edition
MakeContext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class : MakeContext Method

Glossary Item Box

Creates an evaluation context with the specified parameters.

Overload List

Overload | Description
MakeContext(IReportInformationService,IPageInformationService,IReadOnlyDictionary<String,Object>,Lazy<Parameters>) | Creates an evaluation context with the specified parameters.
MakeContext(Report,ThemeService,IReportInformationService,ResourceLocator,Lazy<Parameters>,Int32,IReadOnlyDictionary<String,Object>) | Creates an evaluation context for a report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members


MakeContext(IReportInformationService,IPageInformationService,IReadOnlyDictionary<String,Object>,Lazy<Parameters>) Method

[image]
ActiveReports 19 .NET Edition
MakeContext(IReportInformationService,IPageInformationService,IReadOnlyDictionary<String,Object>,Lazy<Parameters>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class > MakeContext Method : MakeContext(IReportInformationService,IPageInformationService,IReadOnlyDictionary<String,Object>,Lazy<Parameters>) Method

reportInfo
The report information service.
pageInfo
The page information service.
customContext
Optional custom context fields.
parameters
Optional parameters.

Glossary Item Box

Creates an evaluation context with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function MakeContext( _
   ByVal reportInfo As IReportInformationService, _
   ByVal pageInfo As IPageInformationService, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Object), _
   Optional ByVal parameters As Lazy(Of Parameters) _
) As IEvaluationContext
C#
public static IEvaluationContext MakeContext(
   IReportInformationService reportInfo,
   IPageInformationService pageInfo,
   IReadOnlyDictionary<string,object> customContext,
   Lazy<Parameters> parameters
)

Parameters

reportInfo
The report information service.
pageInfo
The page information service.
customContext
Optional custom context fields.
parameters
Optional parameters.

Return Value

An instance of IEvaluationContext.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members
Overload List


MakeContext(Report,ThemeService,IReportInformationService,ResourceLocator,Lazy<Parameters>,Int32,IReadOnlyDictionary<String,Object>) Method

[image]
ActiveReports 19 .NET Edition
MakeContext(Report,ThemeService,IReportInformationService,ResourceLocator,Lazy<Parameters>,Int32,IReadOnlyDictionary<String,Object>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class > MakeContext Method : MakeContext(Report,ThemeService,IReportInformationService,ResourceLocator,Lazy<Parameters>,Int32,IReadOnlyDictionary<String,Object>) Method

report
The report definition.
themeService
The theme service.
reportInfo
The report information service.
resourceLocator
The resource locator.
parameters
Optional parameters.
themeIndex
The theme index.
customContext
Optional custom context fields.

Glossary Item Box

Creates an evaluation context for a report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function MakeContext( _
   ByVal report As Report, _
   ByVal themeService As ThemeService, _
   ByVal reportInfo As IReportInformationService, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal parameters As Lazy(Of Parameters), _
   Optional ByVal themeIndex As Integer, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Object) _
) As IEvaluationContext
C#
public static IEvaluationContext MakeContext(
   Report report,
   ThemeService themeService,
   IReportInformationService reportInfo,
   ResourceLocator resourceLocator,
   Lazy<Parameters> parameters,
   int themeIndex,
   IReadOnlyDictionary<string,object> customContext
)

Parameters

report
The report definition.
themeService
The theme service.
reportInfo
The report information service.
resourceLocator
The resource locator.
parameters
Optional parameters.
themeIndex
The theme index.
customContext
Optional custom context fields.

Return Value

An instance of IEvaluationContext.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when report is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members
Overload List


MakeEvalFunc Method

[image]
ActiveReports 19 .NET Edition
MakeEvalFunc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class : MakeEvalFunc Method

context
Specifies the custom evaluation context.

Glossary Item Box

Creates an expression evaluator with the given evaluation context.

Syntax

Visual Basic (Declaration)
Public Shared Function MakeEvalFunc( _
   ByVal context As IExpressionContext _
) As Func(Of ExpressionInfo,Object)
C#
public static Func<ExpressionInfo,object> MakeEvalFunc(
   IExpressionContext context
)

Parameters

context
Specifies the custom evaluation context.

Return Value

A function that evaluates expressions using the given context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members


MakeEvaluator Method

[image]
ActiveReports 19 .NET Edition
MakeEvaluator Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > ReportEval Class : MakeEvaluator Method

appContext
The application context.

Glossary Item Box

Creates an expression evaluator bound to the given context.

Syntax

Visual Basic (Declaration)
Public Shared Function MakeEvaluator( _
   ByVal appContext As IExpressionContext _
) As IExpressionEvaluatorService
C#
public static IExpressionEvaluatorService MakeEvaluator(
   IExpressionContext appContext
)

Parameters

appContext
The application context.

Return Value

An instance of IExpressionEvaluatorService.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportEval Class
ReportEval Members


IEvaluationContext Interface

[image]
ActiveReports 19 .NET Edition
IEvaluationContext Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IEvaluationContext Interface

Glossary Item Box

Report expression evaluation context passed to expression eval module.

Syntax

Visual Basic (Declaration)
Public Interface IEvaluationContext
   Inherits GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject
C#
public interface IEvaluationContext : GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEvaluationContext Members
GrapeCity.ActiveReports.Core.Rendering Namespace


IEvaluationContext Interface Members

[image]
ActiveReports 19 .NET Edition
IEvaluationContext Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IEvaluationContext Interface

Glossary Item Box

The following tables list the members exposed by IEvaluationContext.

Public Methods

 | Name | Description
Method | Fork |
Top

See Also

Reference

IEvaluationContext Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


IEvaluationContext Interface Methods

[image]
ActiveReports 19 .NET Edition
IEvaluationContext Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IEvaluationContext Interface

Glossary Item Box

For a list of all members of this type, see IEvaluationContext members.

Public Methods

 | Name | Description
Method | Fork |
Top

See Also

Reference

IEvaluationContext Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


Fork Method

[image]
ActiveReports 19 .NET Edition
Fork Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > IEvaluationContext Interface : Fork Method

renderingContext

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function Fork( _
   ByVal renderingContext As RenderingContext _
) As IEvaluationContext
C#
IEvaluationContext Fork(
   RenderingContext renderingContext
)

Parameters

renderingContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEvaluationContext Interface
IEvaluationContext Members


IExpressionEvaluatorService Interface

[image]
ActiveReports 19 .NET Edition
IExpressionEvaluatorService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IExpressionEvaluatorService Interface

Glossary Item Box

Allows an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object to be evaluated.

Syntax

Visual Basic (Declaration)
Public Interface IExpressionEvaluatorService
C#
public interface IExpressionEvaluatorService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpressionEvaluatorService Members
GrapeCity.ActiveReports.Core.Rendering Namespace


IExpressionEvaluatorService Interface Members

[image]
ActiveReports 19 .NET Edition
IExpressionEvaluatorService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IExpressionEvaluatorService Interface

Glossary Item Box

The following tables list the members exposed by IExpressionEvaluatorService.

Public Methods

 | Name | Description
Method | Evaluate | Evaluates the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.
Method | IsValid | Determines whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.
Top

See Also

Reference

IExpressionEvaluatorService Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


IExpressionEvaluatorService Interface Methods

[image]
ActiveReports 19 .NET Edition
IExpressionEvaluatorService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IExpressionEvaluatorService Interface

Glossary Item Box

For a list of all members of this type, see IExpressionEvaluatorService members.

Public Methods

 | Name | Description
Method | Evaluate | Evaluates the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.
Method | IsValid | Determines whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.
Top

See Also

Reference

IExpressionEvaluatorService Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > IExpressionEvaluatorService Interface : Evaluate Method

expression
The GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object to evaluate.

Glossary Item Box

Evaluates the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.

Syntax

Visual Basic (Declaration)
Function Evaluate( _
   ByVal expression As ExpressionInfo _
) As Object
C#
object Evaluate(
   ExpressionInfo expression
)

Parameters

expression
The GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object to evaluate.

Return Value

Resulting value of the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpressionEvaluatorService Interface
IExpressionEvaluatorService Members


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > IExpressionEvaluatorService Interface : IsValid Method

expression
The GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object to evaluate.

Glossary Item Box

Determines whether the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.

Syntax

Visual Basic (Declaration)
Function IsValid( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
bool IsValid(
   ExpressionInfo expression
)

Parameters

expression
The GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object to evaluate.

Return Value

True if the syntax is valid, otherwise False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpressionEvaluatorService Interface
IExpressionEvaluatorService Members


IServiceContainer Interface

[image]
ActiveReports 19 .NET Edition
IServiceContainer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IServiceContainer Interface

Glossary Item Box

Represents a container for services.

Syntax

Visual Basic (Declaration)
Public Interface IServiceContainer
C#
public interface IServiceContainer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Members
GrapeCity.ActiveReports.Core.Rendering Namespace


IServiceContainer Interface Members

[image]
ActiveReports 19 .NET Edition
IServiceContainer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IServiceContainer Interface

Glossary Item Box

The following tables list the members exposed by IServiceContainer.

Public Methods

 | Name | Description
Method | AddService | Adds the specified service to the service container.
Method | RemoveService | Removes the specified service type from the service container.
Top

See Also

Reference

IServiceContainer Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


IServiceContainer Interface Methods

[image]
ActiveReports 19 .NET Edition
IServiceContainer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace : IServiceContainer Interface

Glossary Item Box

For a list of all members of this type, see IServiceContainer members.

Public Methods

 | Name | Description
Method | AddService | Adds the specified service to the service container.
Method | RemoveService | Removes the specified service type from the service container.
Top

See Also

Reference

IServiceContainer Interface
GrapeCity.ActiveReports.Core.Rendering Namespace


AddService Method

[image]
ActiveReports 19 .NET Edition
AddService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > IServiceContainer Interface : AddService Method

serviceType
The type of service to add.
serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Glossary Item Box

Adds the specified service to the service container.

Syntax

Visual Basic (Declaration)
Sub AddService( _
   ByVal serviceType As Type, _
   ByVal serviceInstance As Object _
)
C#
void AddService(
   Type serviceType,
   object serviceInstance
)

Parameters

serviceType
The type of service to add.
serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Interface
IServiceContainer Members


RemoveService Method

[image]
ActiveReports 19 .NET Edition
RemoveService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering Namespace > IServiceContainer Interface : RemoveService Method

serviceType
The type of service to remove.

Glossary Item Box

Removes the specified service type from the service container.

Syntax

Visual Basic (Declaration)
Sub RemoveService( _
   ByVal serviceType As Type _
)
C#
void RemoveService(
   Type serviceType
)

Parameters

serviceType
The type of service to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Interface
IServiceContainer Members


CommandParameter Class

[image]
ActiveReports 19 .NET Edition
CommandParameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : CommandParameter Class

Glossary Item Box

Represents a command parameter for use as a sql parameter.

Object Model

CommandParameter Class

Syntax

Visual Basic (Declaration)
Public Class CommandParameter
C#
public class CommandParameter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.CommandParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


CommandParameter Class Members

[image]
ActiveReports 19 .NET Edition
CommandParameter Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : CommandParameter Class

Glossary Item Box

The following tables list the members exposed by CommandParameter.

Public Constructors

 | Name | Description
Public Constructor | CommandParameter Constructor | Creates new CommandParameter instance.
Top

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current object.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

CommandParameter Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


CommandParameter Constructor

[image]
ActiveReports 19 .NET Edition
CommandParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class : CommandParameter Constructor

name
value

Glossary Item Box

Creates new CommandParameter instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public CommandParameter(
   string name,
   object value
)

Parameters

name
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members


CommandParameter Class Methods

[image]
ActiveReports 19 .NET Edition
CommandParameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : CommandParameter Class

Glossary Item Box

For a list of all members of this type, see CommandParameter members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified object is equal to the current object.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

CommandParameter Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class : Equals Method

Glossary Item Box

Determines whether the specified object is equal to the current object.

Overload List

Overload | Description
Equals(CommandParameter) |
Equals(Object) | Determines whether the specified object is equal to the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members


Equals(CommandParameter) Method

[image]
ActiveReports 19 .NET Edition
Equals(CommandParameter) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class > Equals Method : Equals(CommandParameter) Method

other

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As CommandParameter _
) As Boolean
C#
public bool Equals(
   CommandParameter other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class > Equals Method : Equals(Object) Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members


CommandParameter Class Fields

[image]
ActiveReports 19 .NET Edition
CommandParameter Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : CommandParameter Class

Glossary Item Box

For a list of all members of this type, see CommandParameter members.

Public Fields

 | Name | Description
Public Field | Name | Parameter name.
Public Field | Value | Parameter value.
Top

See Also

Reference

CommandParameter Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class : Name Field

Glossary Item Box

Parameter name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > CommandParameter Class : Value Field

Glossary Item Box

Parameter value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As Object
C#
public readonly object Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandParameter Class
CommandParameter Members


DataProvidersFactory Class

[image]
ActiveReports 19 .NET Edition
DataProvidersFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersFactory Class

Glossary Item Box

Represents the default data providers factory. Supports SQL, CSV, JSON, XML, TESTING, and OBJECT data providers.

Object Model

DataProvidersFactory Class

Syntax

Visual Basic (Declaration)
Public Class DataProvidersFactory
   Implements IDataProvidersFactory
C#
public class DataProvidersFactory : IDataProvidersFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.DataProvidersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DataProvidersFactory Class Members

[image]
ActiveReports 19 .NET Edition
DataProvidersFactory Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersFactory Class

Glossary Item Box

The following tables list the members exposed by DataProvidersFactory.

Public Constructors

 | Name | Description
Public Constructor | DataProvidersFactory Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | The default registry of the data providers factories and adapters
Top

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns the registered IDbConnectionAdapter with a given name.
Public Method | GetFactory | Returns the registered System.Data.Common.DbProviderFactory with a given name.
Public Method | Register | Registers ADO component as a data provider for the renderin engine.
Top

See Also

Reference

DataProvidersFactory Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DataProvidersFactory Constructor

[image]
ActiveReports 19 .NET Edition
DataProvidersFactory Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersFactory Class : DataProvidersFactory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataProvidersFactory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Class
DataProvidersFactory Members


DataProvidersFactory Class Methods

[image]
ActiveReports 19 .NET Edition
DataProvidersFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersFactory Class

Glossary Item Box

For a list of all members of this type, see DataProvidersFactory members.

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns the registered IDbConnectionAdapter with a given name.
Public Method | GetFactory | Returns the registered System.Data.Common.DbProviderFactory with a given name.
Public Method | Register | Registers ADO component as a data provider for the renderin engine.
Top

See Also

Reference

DataProvidersFactory Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


GetAdapter Method

[image]
ActiveReports 19 .NET Edition
GetAdapter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersFactory Class : GetAdapter Method

name
The name of the data providers (SQL, CSV, etc...) to lookup adapter for.

Glossary Item Box

Returns the registered IDbConnectionAdapter with a given name.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetAdapter( _
   ByVal name As String _
) As IDbConnectionAdapter
C#
public virtual IDbConnectionAdapter GetAdapter(
   string name
)

Parameters

name
The name of the data providers (SQL, CSV, etc...) to lookup adapter for.

Return Value

A IDbConnectionAdapter instance with a given name.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the name is not specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Class
DataProvidersFactory Members


GetFactory Method

[image]
ActiveReports 19 .NET Edition
GetFactory Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersFactory Class : GetFactory Method

name
The name of the data providers (SQL, CSV, etc...)

Glossary Item Box

Returns the registered System.Data.Common.DbProviderFactory with a given name.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFactory( _
   ByVal name As String _
) As DbProviderFactory
C#
public virtual DbProviderFactory GetFactory(
   string name
)

Parameters

name
The name of the data providers (SQL, CSV, etc...)

Return Value

A System.Data.Common.DbProviderFactory instance with a given name.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown if the name is not specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Class
DataProvidersFactory Members


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersFactory Class : Register Method

name
The name of the data provider. This name will be used to lookup the data provider and this name will be written in the report.
dbFactory
System.Data.Common.DbProviderFactory instance.
adapter
IDbConnectionAdapter instance.

Glossary Item Box

Registers ADO component as a data provider for the renderin engine.

Syntax

Visual Basic (Declaration)
Public Sub Register( _
   ByVal name As String, _
   ByVal dbFactory As DbProviderFactory, _
   Optional ByVal adapter As IDbConnectionAdapter _
)
C#
public void Register(
   string name,
   DbProviderFactory dbFactory,
   IDbConnectionAdapter adapter
)

Parameters

name
The name of the data provider. This name will be used to lookup the data provider and this name will be written in the report.
dbFactory
System.Data.Common.DbProviderFactory instance.
adapter
IDbConnectionAdapter instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Class
DataProvidersFactory Members


DataProvidersFactory Class Fields

[image]
ActiveReports 19 .NET Edition
DataProvidersFactory Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersFactory Class

Glossary Item Box

For a list of all members of this type, see DataProvidersFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | The default registry of the data providers factories and adapters
Top

See Also

Reference

DataProvidersFactory Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Default Field

[image]
ActiveReports 19 .NET Edition
Default Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersFactory Class : Default Field

Glossary Item Box

The default registry of the data providers factories and adapters

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As DataProvidersFactory
C#
public static readonly DataProvidersFactory Default

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersFactory Class
DataProvidersFactory Members


DataProvidersNames Class

[image]
ActiveReports 19 .NET Edition
DataProvidersNames Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersNames Class

Glossary Item Box

Represents the names of various data providers.

Object Model

DataProvidersNames Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataProvidersNames
C#
public static class DataProvidersNames

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.DataProvidersNames

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DataProvidersNames Class Members

[image]
ActiveReports 19 .NET Edition
DataProvidersNames Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersNames Class

Glossary Item Box

The following tables list the members exposed by DataProvidersNames.

Public Fields

 | Name | Description
Public Field | Csv | Represents the name for the CSV data provider.
Public Field | Dataset | Represents the name for the Dataset data provider.
Public Field | Excel | Represents the name for the Excel data provider.
Public Field | Json | Represents the name for the JSON data provider.
Public Field | MsSql | Represents the name for the Microsoft SQL Server data provider.
Public Field | MsSqLite | Represents the name for the Microsoft SQL Server Lite data provider.
Public Field | MySql | Represents the name for the MySQL data provider.
Public Field | Npgsql | Represents the name for the PostgreSQL data provider.
Public Field | Object | Represents the name for the Object data provider.
Public Field | Odbc | Represents the name for the ODBC data provider.
Public Field | OleDb | Represents the name for the OLE DB data provider.
Public Field | Oracle | Represents the name for the Oracle data provider.
Public Field | SqLite | Represents the name for the SQLite data provider.
Public Field | Testing | Represents the name for the Testing data provider.
Public Field | Xml | Represents the name for the XML data provider.
Top

See Also

Reference

DataProvidersNames Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DataProvidersNames Class Fields

[image]
ActiveReports 19 .NET Edition
DataProvidersNames Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DataProvidersNames Class

Glossary Item Box

For a list of all members of this type, see DataProvidersNames members.

Public Fields

 | Name | Description
Public Field | Csv | Represents the name for the CSV data provider.
Public Field | Dataset | Represents the name for the Dataset data provider.
Public Field | Excel | Represents the name for the Excel data provider.
Public Field | Json | Represents the name for the JSON data provider.
Public Field | MsSql | Represents the name for the Microsoft SQL Server data provider.
Public Field | MsSqLite | Represents the name for the Microsoft SQL Server Lite data provider.
Public Field | MySql | Represents the name for the MySQL data provider.
Public Field | Npgsql | Represents the name for the PostgreSQL data provider.
Public Field | Object | Represents the name for the Object data provider.
Public Field | Odbc | Represents the name for the ODBC data provider.
Public Field | OleDb | Represents the name for the OLE DB data provider.
Public Field | Oracle | Represents the name for the Oracle data provider.
Public Field | SqLite | Represents the name for the SQLite data provider.
Public Field | Testing | Represents the name for the Testing data provider.
Public Field | Xml | Represents the name for the XML data provider.
Top

See Also

Reference

DataProvidersNames Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Csv Field

[image]
ActiveReports 19 .NET Edition
Csv Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Csv Field

Glossary Item Box

Represents the name for the CSV data provider.

Syntax

Visual Basic (Declaration)
Public Const Csv As String
C#
public const string Csv

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Dataset Field

[image]
ActiveReports 19 .NET Edition
Dataset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Dataset Field

Glossary Item Box

Represents the name for the Dataset data provider.

Syntax

Visual Basic (Declaration)
Public Const Dataset As String
C#
public const string Dataset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Excel Field

[image]
ActiveReports 19 .NET Edition
Excel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Excel Field

Glossary Item Box

Represents the name for the Excel data provider.

Syntax

Visual Basic (Declaration)
Public Const Excel As String
C#
public const string Excel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Json Field

[image]
ActiveReports 19 .NET Edition
Json Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Json Field

Glossary Item Box

Represents the name for the JSON data provider.

Syntax

Visual Basic (Declaration)
Public Const Json As String
C#
public const string Json

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


MsSql Field

[image]
ActiveReports 19 .NET Edition
MsSql Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : MsSql Field

Glossary Item Box

Represents the name for the Microsoft SQL Server data provider.

Syntax

Visual Basic (Declaration)
Public Const MsSql As String
C#
public const string MsSql

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


MsSqLite Field

[image]
ActiveReports 19 .NET Edition
MsSqLite Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : MsSqLite Field

Glossary Item Box

Represents the name for the Microsoft SQL Server Lite data provider.

Syntax

Visual Basic (Declaration)
Public Const MsSqLite As String
C#
public const string MsSqLite

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


MySql Field

[image]
ActiveReports 19 .NET Edition
MySql Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : MySql Field

Glossary Item Box

Represents the name for the MySQL data provider.

Syntax

Visual Basic (Declaration)
Public Const MySql As String
C#
public const string MySql

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Npgsql Field

[image]
ActiveReports 19 .NET Edition
Npgsql Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Npgsql Field

Glossary Item Box

Represents the name for the PostgreSQL data provider.

Syntax

Visual Basic (Declaration)
Public Const Npgsql As String
C#
public const string Npgsql

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Object Field

[image]
ActiveReports 19 .NET Edition
Object Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Object Field

Glossary Item Box

Represents the name for the Object data provider.

Syntax

Visual Basic (Declaration)
Public Const Object As String
C#
public const string Object

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Odbc Field

[image]
ActiveReports 19 .NET Edition
Odbc Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Odbc Field

Glossary Item Box

Represents the name for the ODBC data provider.

Syntax

Visual Basic (Declaration)
Public Const Odbc As String
C#
public const string Odbc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


OleDb Field

[image]
ActiveReports 19 .NET Edition
OleDb Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : OleDb Field

Glossary Item Box

Represents the name for the OLE DB data provider.

Syntax

Visual Basic (Declaration)
Public Const OleDb As String
C#
public const string OleDb

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Oracle Field

[image]
ActiveReports 19 .NET Edition
Oracle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Oracle Field

Glossary Item Box

Represents the name for the Oracle data provider.

Syntax

Visual Basic (Declaration)
Public Const Oracle As String
C#
public const string Oracle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


SqLite Field

[image]
ActiveReports 19 .NET Edition
SqLite Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : SqLite Field

Glossary Item Box

Represents the name for the SQLite data provider.

Syntax

Visual Basic (Declaration)
Public Const SqLite As String
C#
public const string SqLite

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Testing Field

[image]
ActiveReports 19 .NET Edition
Testing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Testing Field

Glossary Item Box

Represents the name for the Testing data provider.

Syntax

Visual Basic (Declaration)
Public Const Testing As String
C#
public const string Testing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


Xml Field

[image]
ActiveReports 19 .NET Edition
Xml Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DataProvidersNames Class : Xml Field

Glossary Item Box

Represents the name for the XML data provider.

Syntax

Visual Basic (Declaration)
Public Const Xml As String
C#
public const string Xml

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProvidersNames Class
DataProvidersNames Members


DbConnectionAdapterContext Class

[image]
ActiveReports 19 .NET Edition
DbConnectionAdapterContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DbConnectionAdapterContext Class

Glossary Item Box

Represents additional context for the IDbConnectionAdapter methods.

Object Model

DbConnectionAdapterContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DbConnectionAdapterContext
C#
public sealed class DbConnectionAdapterContext

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.DbConnectionAdapterContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbConnectionAdapterContext Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DbConnectionAdapterContext Class Members

[image]
ActiveReports 19 .NET Edition
DbConnectionAdapterContext Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DbConnectionAdapterContext Class

Glossary Item Box

The following tables list the members exposed by DbConnectionAdapterContext.

Public Properties

 | Name | Description
Public Property | ResourceLocator | Gets the ResourceLocator object that provides resources for the current report.
Top

See Also

Reference

DbConnectionAdapterContext Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


DbConnectionAdapterContext Class Properties

[image]
ActiveReports 19 .NET Edition
DbConnectionAdapterContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : DbConnectionAdapterContext Class

Glossary Item Box

For a list of all members of this type, see DbConnectionAdapterContext members.

Public Properties

 | Name | Description
Public Property | ResourceLocator | Gets the ResourceLocator object that provides resources for the current report.
Top

See Also

Reference

DbConnectionAdapterContext Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > DbConnectionAdapterContext Class : ResourceLocator Property

Glossary Item Box

Gets the ResourceLocator object that provides resources for the current report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResourceLocator As ResourceLocator
C#
public ResourceLocator ResourceLocator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbConnectionAdapterContext Class
DbConnectionAdapterContext Members


LocateDataSourceArgs Class

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : LocateDataSourceArgs Class

Glossary Item Box

Represents the data that is passed to the IDbConnectionAdapterWithDataSource.SetDataSourceLocator method.

Object Model

LocateDataSourceArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateDataSourceArgs
C#
public sealed class LocateDataSourceArgs

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.LocateDataSourceArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


LocateDataSourceArgs Class Members

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : LocateDataSourceArgs Class

Glossary Item Box

The following tables list the members exposed by LocateDataSourceArgs.

Public Constructors

 | Name | Description
Public Constructor | LocateDataSourceArgs Constructor | Initializes a new instance of the LocateDataSourceArgs class.
Top

Public Properties

 | Name | Description
Public Property | Data | Get the data set by SetData method.
Public Property | HasTheDataBeenSet | Gets a sign indicating whether the data was set by SetData method.
Public Property | Name | Gets the name of the requested data source. The meaning depends on the data provider type.
Public Property | Parameters | Gets the collection of the parameters of the command for which the data is requested.
Top

Public Methods

 | Name | Description
Public Method | SetData | Sets the requested data. It can be an object, stream, string or something else depending on the data provider.
Top

See Also

Reference

LocateDataSourceArgs Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


LocateDataSourceArgs Constructor

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : LocateDataSourceArgs Constructor

name
The name of the requested data.
parameters
Collection of the parameters of the command for which the data is requested.

Glossary Item Box

Initializes a new instance of the LocateDataSourceArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal parameters As IReadOnlyList(Of DbParameter) _
)
C#
public LocateDataSourceArgs(
   string name,
   IReadOnlyList<DbParameter> parameters
)

Parameters

name
The name of the requested data.
parameters
Collection of the parameters of the command for which the data is requested.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


LocateDataSourceArgs Class Methods

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : LocateDataSourceArgs Class

Glossary Item Box

For a list of all members of this type, see LocateDataSourceArgs members.

Public Methods

 | Name | Description
Public Method | SetData | Sets the requested data. It can be an object, stream, string or something else depending on the data provider.
Top

See Also

Reference

LocateDataSourceArgs Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SetData Method

[image]
ActiveReports 19 .NET Edition
SetData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : SetData Method

data
The data to be passed to the DbCommand

Glossary Item Box

Sets the requested data. It can be an object, stream, string or something else depending on the data provider.

Syntax

Visual Basic (Declaration)
Public Sub SetData( _
   ByVal data As Object _
)
C#
public void SetData(
   object data
)

Parameters

data
The data to be passed to the DbCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


LocateDataSourceArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : LocateDataSourceArgs Class

Glossary Item Box

For a list of all members of this type, see LocateDataSourceArgs members.

Public Properties

 | Name | Description
Public Property | Data | Get the data set by SetData method.
Public Property | HasTheDataBeenSet | Gets a sign indicating whether the data was set by SetData method.
Public Property | Name | Gets the name of the requested data source. The meaning depends on the data provider type.
Public Property | Parameters | Gets the collection of the parameters of the command for which the data is requested.
Top

See Also

Reference

LocateDataSourceArgs Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : Data Property

Glossary Item Box

Get the data set by SetData method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Object
C#
public object Data {get;}

Property Value

This could be a string, a stream, or something else that is supported by a specific data provider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


HasTheDataBeenSet Property

[image]
ActiveReports 19 .NET Edition
HasTheDataBeenSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : HasTheDataBeenSet Property

Glossary Item Box

Gets a sign indicating whether the data was set by SetData method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasTheDataBeenSet As Boolean
C#
public bool HasTheDataBeenSet {get;}

Property Value

True if the data has been set, false otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : Name Property

Glossary Item Box

Gets the name of the requested data source. The meaning depends on the data provider type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of the requested data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > LocateDataSourceArgs Class : Parameters Property

Glossary Item Box

Gets the collection of the parameters of the command for which the data is requested.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IReadOnlyList(Of DbParameter)
C#
public IReadOnlyList<DbParameter> Parameters {get;}

Property Value

A read-only list of System.Data.Common.DbParameter objects representing the parameters of the command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


ReportDataSnapshot Class

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshot Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportDataSnapshot Class

Glossary Item Box

Represents the data necessary to render a report.

Object Model

ReportDataSnapshot Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportDataSnapshot
C#
public sealed class ReportDataSnapshot

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportDataSnapshot Class Members

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshot Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportDataSnapshot Class

Glossary Item Box

The following tables list the members exposed by ReportDataSnapshot.

Public Constructors

 | Name | Description
Public Constructor | ReportDataSnapshot Constructor |
Top

Public Properties

 | Name | Description
Public Property | AggregateTree | Gets the tree of aggregates.
Public Property | ReportDataDefinition | Get the definition of data.
Public Property | ResultTree | Gets the tree of data.
Public Property | Version | Get the version of the data snapshot format.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Loads a report snapshot from a given stream.
Public Method | ReleaseDataSource | Releases related data sources.
Public Method | ResetAggregateTree | Resets the aggregate tree.
Public Method | Save | Saves the snapshot to the specified stream.
Top

See Also

Reference

ReportDataSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportDataSnapshot Constructor

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshot Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : ReportDataSnapshot Constructor

reportDataDefinition
aggregateTree
resultTree
finalizers
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportDataDefinition As Def.Report, _
   ByVal aggregateTree As DataTree.Snapshot(Of Aggregate), _
   ByVal resultTree As DataTree.Snapshot(Of Object), _
   Optional ByVal finalizers As IList(Of Action), _
   Optional ByVal version As Integer _
)
C#
public ReportDataSnapshot(
   Def.Report reportDataDefinition,
   DataTree.Snapshot<Aggregate> aggregateTree,
   DataTree.Snapshot<object> resultTree,
   IList<Action> finalizers,
   int version
)

Parameters

reportDataDefinition
aggregateTree
resultTree
finalizers
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ReportDataSnapshot Class Methods

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshot Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportDataSnapshot Class

Glossary Item Box

For a list of all members of this type, see ReportDataSnapshot members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Loads a report snapshot from a given stream.
Public Method | ReleaseDataSource | Releases related data sources.
Public Method | ResetAggregateTree | Resets the aggregate tree.
Public Method | Save | Saves the snapshot to the specified stream.
Top

See Also

Reference

ReportDataSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : Load Method

input
Stream which contains serialized report snapshot data.

Glossary Item Box

Loads a report snapshot from a given stream.

Syntax

Visual Basic (Declaration)
Public Shared Function Load( _
   ByVal input As Stream _
) As ReportDataSnapshot
C#
public static ReportDataSnapshot Load(
   Stream input
)

Parameters

input
Stream which contains serialized report snapshot data.

Return Value

Loaded report data snapshot.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ReleaseDataSource Method

[image]
ActiveReports 19 .NET Edition
ReleaseDataSource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : ReleaseDataSource Method

Glossary Item Box

Releases related data sources.

Syntax

Visual Basic (Declaration)
Public Sub ReleaseDataSource()
C#
public void ReleaseDataSource()

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ResetAggregateTree Method

[image]
ActiveReports 19 .NET Edition
ResetAggregateTree Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : ResetAggregateTree Method

Glossary Item Box

Resets the aggregate tree.

Syntax

Visual Basic (Declaration)
Public Function ResetAggregateTree() As ReportDataSnapshot
C#
public ReportDataSnapshot ResetAggregateTree()

Return Value

A new ReportDataSnapshot instance with the aggregate tree reset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : Save Method

output
The stream where data have to be written.
isInteractive
if false than aggregate tree will be omitted.

Glossary Item Box

Saves the snapshot to the specified stream.

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal output As Stream, _
   Optional ByVal isInteractive As Boolean _
)
C#
public void Save(
   Stream output,
   bool isInteractive
)

Parameters

output
The stream where data have to be written.
isInteractive
if false than aggregate tree will be omitted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ReportDataSnapshot Class Properties

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshot Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportDataSnapshot Class

Glossary Item Box

For a list of all members of this type, see ReportDataSnapshot members.

Public Properties

 | Name | Description
Public Property | AggregateTree | Gets the tree of aggregates.
Public Property | ReportDataDefinition | Get the definition of data.
Public Property | ResultTree | Gets the tree of data.
Public Property | Version | Get the version of the data snapshot format.
Top

See Also

Reference

ReportDataSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


AggregateTree Property

[image]
ActiveReports 19 .NET Edition
AggregateTree Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : AggregateTree Property

Glossary Item Box

Gets the tree of aggregates.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AggregateTree As DataTree.Snapshot(Of Aggregate)
C#
public DataTree.Snapshot<Aggregate> AggregateTree {get;}

Property Value

The GrapeCity.Enterprise.Data.DataEngine.DataTree.Snapshot<T> object representing the tree of aggregates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ReportDataDefinition Property

[image]
ActiveReports 19 .NET Edition
ReportDataDefinition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : ReportDataDefinition Property

Glossary Item Box

Get the definition of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportDataDefinition As Def.Report
C#
public Def.Report ReportDataDefinition {get;}

Property Value

The GrapeCity.Enterprise.Data.DataEngine.Def.Report object representing the data definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ResultTree Property

[image]
ActiveReports 19 .NET Edition
ResultTree Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : ResultTree Property

Glossary Item Box

Gets the tree of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultTree As DataTree.Snapshot(Of Object)
C#
public DataTree.Snapshot<object> ResultTree {get;}

Property Value

The GrapeCity.Enterprise.Data.DataEngine.DataTree.Snapshot<T> object representing the tree of data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


Version Property

[image]
ActiveReports 19 .NET Edition
Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportDataSnapshot Class : Version Property

Glossary Item Box

Get the version of the data snapshot format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version {get;}

Property Value

The version of the data snapshot format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshot Class
ReportDataSnapshot Members


ReportParameterInfo<T> Class

T
The type of the parameter value.
[image]
ActiveReports 19 .NET Edition
ReportParameterInfo<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportParameterInfo<T> Class

Glossary Item Box

Represents information about a report parameter.

Object Model

ReportParameterInfo<T> Class

Syntax

Visual Basic (Declaration)
Public Class ReportParameterInfo(Of T)
C#
public class ReportParameterInfo<T>

Type Parameters

T
The type of the parameter value.

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.ReportParameterInfo<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterInfo<T> Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportParameterInfo<T> Class Members

[image]
ActiveReports 19 .NET Edition
ReportParameterInfo<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportParameterInfo<T> Class

Glossary Item Box

The following tables list the members exposed by ReportParameterInfo<T>.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterInfo<T> Constructor | Initializes a new instance of the ReportParameterInfo<T> class.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets the label of the report parameter.
Public Property | Value | Gets the value of the report parameter.
Top

See Also

Reference

ReportParameterInfo<T> Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportParameterInfo<T> Constructor

[image]
ActiveReports 19 .NET Edition
ReportParameterInfo<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportParameterInfo<T> Class : ReportParameterInfo<T> Constructor

label
The label of the report parameter.
value
The value of the report parameter.

Glossary Item Box

Initializes a new instance of the ReportParameterInfo<T> class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String, _
   ByVal value As T _
)
C#
public ReportParameterInfo<T>(
   string label,
   T value
)

Parameters

label
The label of the report parameter.
value
The value of the report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterInfo<T> Class
ReportParameterInfo<T> Members


ReportParameterInfo<T> Class Properties

[image]
ActiveReports 19 .NET Edition
ReportParameterInfo<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportParameterInfo<T> Class

Glossary Item Box

For a list of all members of this type, see ReportParameterInfo<T> members.

Public Properties

 | Name | Description
Public Property | Label | Gets the label of the report parameter.
Public Property | Value | Gets the value of the report parameter.
Top

See Also

Reference

ReportParameterInfo<T> Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportParameterInfo<T> Class : Label Property

Glossary Item Box

Gets the label of the report parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As String
C#
public string Label {get;}

Property Value

A System.String representing the label of the report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterInfo<T> Class
ReportParameterInfo<T> Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportParameterInfo<T> Class : Value Property

Glossary Item Box

Gets the value of the report parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As T
C#
public T Value {get;}

Property Value

A T representing the value of the report parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterInfo<T> Class
ReportParameterInfo<T> Members


ReportSlicerState Class

[image]
ActiveReports 19 .NET Edition
ReportSlicerState Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSlicerState Class

Glossary Item Box

Represents the initial state of a report slicer.

Object Model

ReportSlicerState Class

Syntax

Visual Basic (Declaration)
Public Class ReportSlicerState
C#
public class ReportSlicerState

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.ReportSlicerState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicerState Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportSlicerState Class Members

[image]
ActiveReports 19 .NET Edition
ReportSlicerState Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSlicerState Class

Glossary Item Box

The following tables list the members exposed by ReportSlicerState.

Public Constructors

 | Name | Description
Public Constructor | ReportSlicerState Constructor | Initializes a new instance of the ReportSlicerState class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report slicer.
Public Property | Value | Gets the initial value of the slicer.
Top

See Also

Reference

ReportSlicerState Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportSlicerState Constructor

[image]
ActiveReports 19 .NET Edition
ReportSlicerState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSlicerState Class : ReportSlicerState Constructor

name
The name of the report slicer.
value
The initial value of the slicer.

Glossary Item Box

Initializes a new instance of the ReportSlicerState class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public ReportSlicerState(
   string name,
   object value
)

Parameters

name
The name of the report slicer.
value
The initial value of the slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicerState Class
ReportSlicerState Members


ReportSlicerState Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSlicerState Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSlicerState Class

Glossary Item Box

For a list of all members of this type, see ReportSlicerState members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report slicer.
Public Property | Value | Gets the initial value of the slicer.
Top

See Also

Reference

ReportSlicerState Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSlicerState Class : Name Property

Glossary Item Box

Gets the name of the report slicer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A System.String representing the name of the report slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicerState Class
ReportSlicerState Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSlicerState Class : Value Property

Glossary Item Box

Gets the initial value of the slicer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

An System.Object representing the initial value of the slicer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSlicerState Class
ReportSlicerState Members


ReportSnapshot Class

[image]
ActiveReports 19 .NET Edition
ReportSnapshot Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSnapshot Class

Glossary Item Box

Represents a report data-tree based snapshot.

Object Model

ReportSnapshot Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportSnapshot
C#
public sealed class ReportSnapshot

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.ReportSnapshot

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportSnapshot Class Members

[image]
ActiveReports 19 .NET Edition
ReportSnapshot Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSnapshot Class

Glossary Item Box

The following tables list the members exposed by ReportSnapshot.

Public Constructors

 | Name | Description
Public Constructor | ReportSnapshot Constructor | Initializes a new instance of the ReportSnapshot class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets the data necessary to render the report.
Public Property | EvaluationMessage | Gets or sets the evaluation message.
Public Property | Parameters | Gets the report parameter values.
Public Property | Signature | Gets or sets the signature.
Public Property | Slicers | Gets the initial states of the report slicers.
Public Property | Subreports | Gets the subreports RDL templates.
Public Property | Template | Gets the report RDL template.
Top

Public Methods

 | Name | Description
Public Method | ForSubReport | Creates a new instance of ReportSnapshot for a subreport.
static (Shared in Visual Basic) | Load | Loads a report snapshot from a given stream.
Public Method | Save | Saves the snapshot to the specified stream.
Public Method | UpdateEvalMessage | Updates the evaluation message in the report snapshot.
Public Method | UpdateReportTemplate | Updates the report template with the specified report and resource locator.
Public Method | Verify |
Top

See Also

Reference

ReportSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ReportSnapshot Constructor

[image]
ActiveReports 19 .NET Edition
ReportSnapshot Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : ReportSnapshot Constructor

data
The data necessary to render the report.
template
The report RDL template.
subreports
The subreports RDL templates.
evaluationMessage
The evaluation message.
signature
The signature.
parameters
The report parameter values.
slicers
The initial states of the report slicers.

Glossary Item Box

Initializes a new instance of the ReportSnapshot class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As ReportDataSnapshot, _
   Optional ByVal template As String, _
   Optional ByVal subreports As SubreportsInfo, _
   Optional ByVal evaluationMessage As String, _
   Optional ByVal signature As String, _
   Optional ByVal parameters As Dictionary(Of String,List(Of ReportParameterInfo(Of Object))), _
   Optional ByVal slicers() As ReportSlicerState _
)
C#
public ReportSnapshot(
   ReportDataSnapshot data,
   string template,
   SubreportsInfo subreports,
   string evaluationMessage,
   string signature,
   Dictionary<string,List<ReportParameterInfo<object>>> parameters,
   ReportSlicerState[] slicers
)

Parameters

data
The data necessary to render the report.
template
The report RDL template.
subreports
The subreports RDL templates.
evaluationMessage
The evaluation message.
signature
The signature.
parameters
The report parameter values.
slicers
The initial states of the report slicers.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when the data parameter is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


ReportSnapshot Class Methods

[image]
ActiveReports 19 .NET Edition
ReportSnapshot Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSnapshot Class

Glossary Item Box

For a list of all members of this type, see ReportSnapshot members.

Public Methods

 | Name | Description
Public Method | ForSubReport | Creates a new instance of ReportSnapshot for a subreport.
static (Shared in Visual Basic) | Load | Loads a report snapshot from a given stream.
Public Method | Save | Saves the snapshot to the specified stream.
Public Method | UpdateEvalMessage | Updates the evaluation message in the report snapshot.
Public Method | UpdateReportTemplate | Updates the report template with the specified report and resource locator.
Public Method | Verify |
Top

See Also

Reference

ReportSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


ForSubReport Method

[image]
ActiveReports 19 .NET Edition
ForSubReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : ForSubReport Method

Glossary Item Box

Creates a new instance of ReportSnapshot for a subreport.

Syntax

Visual Basic (Declaration)
Public Function ForSubReport() As ReportSnapshot
C#
public ReportSnapshot ForSubReport()

Return Value

A new instance of ReportSnapshot for a subreport.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Load Method

input
The stream which contains serialized report snapshot data.

Glossary Item Box

Loads a report snapshot from a given stream.

Syntax

Visual Basic (Declaration)
Public Shared Function Load( _
   ByVal input As Stream _
) As ReportSnapshot
C#
public static ReportSnapshot Load(
   Stream input
)

Parameters

input
The stream which contains serialized report snapshot data.

Return Value

The loaded report data snapshot.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Save Method

output
The stream where data have to be written.
isInteractive
If false, then the aggregate tree will be omitted.

Glossary Item Box

Saves the snapshot to the specified stream.

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal output As Stream, _
   Optional ByVal isInteractive As Boolean _
)
C#
public void Save(
   Stream output,
   bool isInteractive
)

Parameters

output
The stream where data have to be written.
isInteractive
If false, then the aggregate tree will be omitted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


UpdateEvalMessage Method

[image]
ActiveReports 19 .NET Edition
UpdateEvalMessage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : UpdateEvalMessage Method

message
The evaluation message.

Glossary Item Box

Updates the evaluation message in the report snapshot.

Syntax

Visual Basic (Declaration)
Public Function UpdateEvalMessage( _
   ByVal message As String _
) As ReportSnapshot
C#
public ReportSnapshot UpdateEvalMessage(
   string message
)

Parameters

message
The evaluation message.

Return Value

A new instance of ReportSnapshot with the updated evaluation message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


UpdateReportTemplate Method

[image]
ActiveReports 19 .NET Edition
UpdateReportTemplate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : UpdateReportTemplate Method

report
The report to be updated.
resourceLocator
The resource locator for the report.

Glossary Item Box

Updates the report template with the specified report and resource locator.

Syntax

Visual Basic (Declaration)
Public Function UpdateReportTemplate( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator _
) As ReportSnapshot
C#
public ReportSnapshot UpdateReportTemplate(
   Report report,
   ResourceLocator resourceLocator
)

Parameters

report
The report to be updated.
resourceLocator
The resource locator for the report.

Return Value

A new instance of ReportSnapshot with the updated template.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when the report parameter is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Verify Method

[image]
ActiveReports 19 .NET Edition
Verify Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Verify Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Verify() As Boolean
C#
public bool Verify()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


ReportSnapshot Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSnapshot Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : ReportSnapshot Class

Glossary Item Box

For a list of all members of this type, see ReportSnapshot members.

Public Properties

 | Name | Description
Public Property | Data | Gets the data necessary to render the report.
Public Property | EvaluationMessage | Gets or sets the evaluation message.
Public Property | Parameters | Gets the report parameter values.
Public Property | Signature | Gets or sets the signature.
Public Property | Slicers | Gets the initial states of the report slicers.
Public Property | Subreports | Gets the subreports RDL templates.
Public Property | Template | Gets the report RDL template.
Top

See Also

Reference

ReportSnapshot Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Data Property

Glossary Item Box

Gets the data necessary to render the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As ReportDataSnapshot
C#
public ReportDataSnapshot Data {get;}

Property Value

A ReportDataSnapshot object representing the data necessary to render the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


EvaluationMessage Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : EvaluationMessage Property

Glossary Item Box

Gets or sets the evaluation message.

Syntax

Visual Basic (Declaration)
Public Property EvaluationMessage As String
C#
public string EvaluationMessage {get; set;}

Property Value

A System.String representing the evaluation message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Parameters Property

Glossary Item Box

Gets the report parameter values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Dictionary(Of String,List(Of ReportParameterInfo(Of Variant)))
C#
public Dictionary<string,List<ReportParameterInfo<Variant>>> Parameters {get;}

Property Value

A dictionary where the key is a System.String representing the parameter name, and the value is a list of ReportParameterInfo<T> objects representing the parameter values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Signature Property

[image]
ActiveReports 19 .NET Edition
Signature Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Signature Property

Glossary Item Box

Gets or sets the signature.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Signature As String
C#
public string Signature {get;}

Property Value

A System.String representing the signature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Slicers Property

[image]
ActiveReports 19 .NET Edition
Slicers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Slicers Property

Glossary Item Box

Gets the initial states of the report slicers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Slicers As ReportSlicerState()
C#
public ReportSlicerState[] Slicers {get;}

Property Value

An array of ReportSlicerState objects representing the initial states of the report slicers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Subreports Property

[image]
ActiveReports 19 .NET Edition
Subreports Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Subreports Property

Glossary Item Box

Gets the subreports RDL templates.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subreports As SubreportsInfo
C#
public SubreportsInfo Subreports {get;}

Property Value

A SubreportsInfo object containing subreport definitions and mappings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


Template Property

[image]
ActiveReports 19 .NET Edition
Template Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > ReportSnapshot Class : Template Property

Glossary Item Box

Gets the report RDL template.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Template As String
C#
public string Template {get;}

Property Value

A System.String representing the report RDL template.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSnapshot Class
ReportSnapshot Members


SubreportsInfo Class

[image]
ActiveReports 19 .NET Edition
SubreportsInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : SubreportsInfo Class

Glossary Item Box

Represents an information about subreports in a report.

Object Model

SubreportsInfo Class

Syntax

Visual Basic (Declaration)
Public Class SubreportsInfo
C#
public class SubreportsInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Data.SubreportsInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubreportsInfo Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SubreportsInfo Class Members

[image]
ActiveReports 19 .NET Edition
SubreportsInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : SubreportsInfo Class

Glossary Item Box

The following tables list the members exposed by SubreportsInfo.

Public Constructors

 | Name | Description
Public Constructor | SubreportsInfo Constructor | Initializes a new instance of the SubreportsInfo class.
Top

Public Properties

 | Name | Description
Public Property | Definitions | Gets an array of subreport definitions.
Public Property | Map | Gets an array of dictionaries that map subreport names to their indices.
Top

See Also

Reference

SubreportsInfo Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SubreportsInfo Constructor

[image]
ActiveReports 19 .NET Edition
SubreportsInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > SubreportsInfo Class : SubreportsInfo Constructor

definitions
An array of subreport definitions.
map
An array of dictionaries that map subreport names to their indices.

Glossary Item Box

Initializes a new instance of the SubreportsInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal definitions() As String, _
   ByVal map() As Dictionary(Of String,Integer) _
)
C#
public SubreportsInfo(
   string[] definitions,
   Dictionary<string,int>[] map
)

Parameters

definitions
An array of subreport definitions.
map
An array of dictionaries that map subreport names to their indices.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubreportsInfo Class
SubreportsInfo Members


SubreportsInfo Class Properties

[image]
ActiveReports 19 .NET Edition
SubreportsInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : SubreportsInfo Class

Glossary Item Box

For a list of all members of this type, see SubreportsInfo members.

Public Properties

 | Name | Description
Public Property | Definitions | Gets an array of subreport definitions.
Public Property | Map | Gets an array of dictionaries that map subreport names to their indices.
Top

See Also

Reference

SubreportsInfo Class
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


Definitions Property

[image]
ActiveReports 19 .NET Edition
Definitions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > SubreportsInfo Class : Definitions Property

Glossary Item Box

Gets an array of subreport definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Definitions As String()
C#
public string[] Definitions {get;}

Property Value

An array of System.String representing the subreport definitions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubreportsInfo Class
SubreportsInfo Members


Map Property

[image]
ActiveReports 19 .NET Edition
Map Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > SubreportsInfo Class : Map Property

Glossary Item Box

Gets an array of dictionaries that map subreport names to their indices.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Map As Dictionary(Of String,Integer)()
C#
public Dictionary<string,int>[] Map {get;}

Property Value

An array of Dictionary where the key is a System.String representing the subreport name, and the value is an System.Int32 representing the report index.

Remarks

Index represents the report index: 0 for the main report; 1, 2, etc. for subreports from Definitions starting from 1. Value is a dictionary to resolve report subreports. Key is the subreport name in the definition, Value is the report index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubreportsInfo Class
SubreportsInfo Members


IDataProvidersFactory Interface

[image]
ActiveReports 19 .NET Edition
IDataProvidersFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDataProvidersFactory Interface

Glossary Item Box

Data providers factory's abstract factory interface.

Syntax

Visual Basic (Declaration)
Public Interface IDataProvidersFactory
C#
public interface IDataProvidersFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataProvidersFactory Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDataProvidersFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IDataProvidersFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDataProvidersFactory Interface

Glossary Item Box

The following tables list the members exposed by IDataProvidersFactory.

Public Methods

 | Name | Description
Method | GetAdapter | Returns the adapter for setting multivalue parameters.
Method | GetFactory | Returns the data provider factory for the specified provider name.
Top

See Also

Reference

IDataProvidersFactory Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDataProvidersFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IDataProvidersFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDataProvidersFactory Interface

Glossary Item Box

For a list of all members of this type, see IDataProvidersFactory members.

Public Methods

 | Name | Description
Method | GetAdapter | Returns the adapter for setting multivalue parameters.
Method | GetFactory | Returns the data provider factory for the specified provider name.
Top

See Also

Reference

IDataProvidersFactory Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


GetAdapter Method

[image]
ActiveReports 19 .NET Edition
GetAdapter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDataProvidersFactory Interface : GetAdapter Method

dataProviderName
The invariant name of the data provider to return the adapter for..

Glossary Item Box

Returns the adapter for setting multivalue parameters.

Syntax

Visual Basic (Declaration)
Function GetAdapter( _
   ByVal dataProviderName As String _
) As IDbConnectionAdapter
C#
IDbConnectionAdapter GetAdapter(
   string dataProviderName
)

Parameters

dataProviderName
The invariant name of the data provider to return the adapter for..

Return Value

The IDbConnectionAdapter for the specified data provider name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataProvidersFactory Interface
IDataProvidersFactory Members


GetFactory Method

[image]
ActiveReports 19 .NET Edition
GetFactory Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDataProvidersFactory Interface : GetFactory Method

dataProviderName
The invariant name of the data provider (e.g., SQL, OLEDB).

Glossary Item Box

Returns the data provider factory for the specified provider name.

Syntax

Visual Basic (Declaration)
Function GetFactory( _
   ByVal dataProviderName As String _
) As DbProviderFactory
C#
DbProviderFactory GetFactory(
   string dataProviderName
)

Parameters

dataProviderName
The invariant name of the data provider (e.g., SQL, OLEDB).

Return Value

The System.Data.Common.DbProviderFactory for the specified data provider name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataProvidersFactory Interface
IDataProvidersFactory Members


IDbCommandAdapterWithCache Interface

[image]
ActiveReports 19 .NET Edition
IDbCommandAdapterWithCache Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandAdapterWithCache Interface

Glossary Item Box

Represents a command adapter for supporting caching.

Syntax

Visual Basic (Declaration)
Public Interface IDbCommandAdapterWithCache
C#
public interface IDbCommandAdapterWithCache

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbCommandAdapterWithCache Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbCommandAdapterWithCache Interface Members

[image]
ActiveReports 19 .NET Edition
IDbCommandAdapterWithCache Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandAdapterWithCache Interface

Glossary Item Box

The following tables list the members exposed by IDbCommandAdapterWithCache.

Public Methods

 | Name | Description
Method | CanBeCached | Checks if the command execution result can be cached.
Top

See Also

Reference

IDbCommandAdapterWithCache Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbCommandAdapterWithCache Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbCommandAdapterWithCache Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandAdapterWithCache Interface

Glossary Item Box

For a list of all members of this type, see IDbCommandAdapterWithCache members.

Public Methods

 | Name | Description
Method | CanBeCached | Checks if the command execution result can be cached.
Top

See Also

Reference

IDbCommandAdapterWithCache Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


CanBeCached Method

[image]
ActiveReports 19 .NET Edition
CanBeCached Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbCommandAdapterWithCache Interface : CanBeCached Method

command
The command to check.

Glossary Item Box

Checks if the command execution result can be cached.

Syntax

Visual Basic (Declaration)
Function CanBeCached( _
   ByVal command As IDbCommand _
) As Boolean
C#
bool CanBeCached(
   IDbCommand command
)

Parameters

command
The command to check.

Return Value

true if the result can be cached; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbCommandAdapterWithCache Interface
IDbCommandAdapterWithCache Members


IDbCommandParametersAdapter Interface

[image]
ActiveReports 19 .NET Edition
IDbCommandParametersAdapter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandParametersAdapter Interface

Glossary Item Box

Represents an adapter for adding parameters to a database command.

Syntax

Visual Basic (Declaration)
Public Interface IDbCommandParametersAdapter
C#
public interface IDbCommandParametersAdapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbCommandParametersAdapter Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbCommandParametersAdapter Interface Members

[image]
ActiveReports 19 .NET Edition
IDbCommandParametersAdapter Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandParametersAdapter Interface

Glossary Item Box

The following tables list the members exposed by IDbCommandParametersAdapter.

Public Methods

 | Name | Description
Method | SetParameters | Adds parameter values in to the command.
Top

See Also

Reference

IDbCommandParametersAdapter Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbCommandParametersAdapter Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbCommandParametersAdapter Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbCommandParametersAdapter Interface

Glossary Item Box

For a list of all members of this type, see IDbCommandParametersAdapter members.

Public Methods

 | Name | Description
Method | SetParameters | Adds parameter values in to the command.
Top

See Also

Reference

IDbCommandParametersAdapter Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SetParameters Method

[image]
ActiveReports 19 .NET Edition
SetParameters Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbCommandParametersAdapter Interface : SetParameters Method

command
The database command to which the parameters will be added.
commandParameters
The collection of parameters to add to the command.

Glossary Item Box

Adds parameter values in to the command.

Syntax

Visual Basic (Declaration)
Sub SetParameters( _
   ByVal command As DbCommand, _
   ByVal commandParameters As IReadOnlyList(Of CommandParameter) _
)
C#
void SetParameters(
   DbCommand command,
   IReadOnlyList<CommandParameter> commandParameters
)

Parameters

command
The database command to which the parameters will be added.
commandParameters
The collection of parameters to add to the command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbCommandParametersAdapter Interface
IDbCommandParametersAdapter Members


IDbConnectionAdapter Interface

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapter Interface

Glossary Item Box

Represents an adapter for supporting multivalue parameters and setting credentials.

Syntax

Visual Basic (Declaration)
Public Interface IDbConnectionAdapter
C#
public interface IDbConnectionAdapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapter Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbConnectionAdapter Interface Members

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapter Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapter Interface

Glossary Item Box

The following tables list the members exposed by IDbConnectionAdapter.

Public Properties

 | Name | Description
Property | IsCredentialsSupported | Gets a value indicating whether the adapter supports setting credentials.
Property | IsSetConnectionStringSupported | Gets a value indicating whether the adapter supports setting a custom connection string.
Top

Public Methods

 | Name | Description
Method | SetConnectionString | Sets the connection string for the specified connection.
Method | SetCredentials | Sets the user login and password for the specified connection.
Top

See Also

Reference

IDbConnectionAdapter Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbConnectionAdapter Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapter Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapter Interface

Glossary Item Box

For a list of all members of this type, see IDbConnectionAdapter members.

Public Methods

 | Name | Description
Method | SetConnectionString | Sets the connection string for the specified connection.
Method | SetCredentials | Sets the user login and password for the specified connection.
Top

See Also

Reference

IDbConnectionAdapter Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SetConnectionString Method

[image]
ActiveReports 19 .NET Edition
SetConnectionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbConnectionAdapter Interface : SetConnectionString Method

connection
The connection to set the connection string for.
connectionString
The connection string to set.
context
The additional context for the operation.

Glossary Item Box

Sets the connection string for the specified connection.

Syntax

Visual Basic (Declaration)
Sub SetConnectionString( _
   ByVal connection As DbConnection, _
   ByVal connectionString As String, _
   ByVal context As DbConnectionAdapterContext _
)
C#
void SetConnectionString(
   DbConnection connection,
   string connectionString,
   DbConnectionAdapterContext context
)

Parameters

connection
The connection to set the connection string for.
connectionString
The connection string to set.
context
The additional context for the operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapter Interface
IDbConnectionAdapter Members


SetCredentials Method

[image]
ActiveReports 19 .NET Edition
SetCredentials Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbConnectionAdapter Interface : SetCredentials Method

connection
The connection to set the credentials for.
credentials
The pair of user login name and password.

Glossary Item Box

Sets the user login and password for the specified connection.

Syntax

Visual Basic (Declaration)
Sub SetCredentials( _
   ByVal connection As DbConnection, _
   ByVal credentials As LoginPasswordCredentials _
)
C#
void SetCredentials(
   DbConnection connection,
   LoginPasswordCredentials credentials
)

Parameters

connection
The connection to set the credentials for.
credentials
The pair of user login name and password.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapter Interface
IDbConnectionAdapter Members


IDbConnectionAdapter Interface Properties

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapter Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapter Interface

Glossary Item Box

For a list of all members of this type, see IDbConnectionAdapter members.

Public Properties

 | Name | Description
Property | IsCredentialsSupported | Gets a value indicating whether the adapter supports setting credentials.
Property | IsSetConnectionStringSupported | Gets a value indicating whether the adapter supports setting a custom connection string.
Top

See Also

Reference

IDbConnectionAdapter Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IsCredentialsSupported Property

[image]
ActiveReports 19 .NET Edition
IsCredentialsSupported Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbConnectionAdapter Interface : IsCredentialsSupported Property

Glossary Item Box

Gets a value indicating whether the adapter supports setting credentials.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsCredentialsSupported As Boolean
C#
bool IsCredentialsSupported {get;}

Property Value

True if the data provider supports credentials setting.

Remarks

If the property returns false the SetCredentials method won't be called.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapter Interface
IDbConnectionAdapter Members


IsSetConnectionStringSupported Property

[image]
ActiveReports 19 .NET Edition
IsSetConnectionStringSupported Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbConnectionAdapter Interface : IsSetConnectionStringSupported Property

Glossary Item Box

Gets a value indicating whether the adapter supports setting a custom connection string.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSetConnectionStringSupported As Boolean
C#
bool IsSetConnectionStringSupported {get;}

Property Value

True if the adapter requires the SetConnectionString method to be called.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapter Interface
IDbConnectionAdapter Members


IDbConnectionAdapterWithDataSource Interface

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapterWithDataSource Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapterWithDataSource Interface

Glossary Item Box

Represents a command adapter for supporting data source locators.

Syntax

Visual Basic (Declaration)
Public Interface IDbConnectionAdapterWithDataSource
C#
public interface IDbConnectionAdapterWithDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapterWithDataSource Members
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbConnectionAdapterWithDataSource Interface Members

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapterWithDataSource Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapterWithDataSource Interface

Glossary Item Box

The following tables list the members exposed by IDbConnectionAdapterWithDataSource.

Public Methods

 | Name | Description
Method | SetDataSourceLocator | Sets the data source getter function for the specified database connection command.
Top

See Also

Reference

IDbConnectionAdapterWithDataSource Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


IDbConnectionAdapterWithDataSource Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbConnectionAdapterWithDataSource Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace : IDbConnectionAdapterWithDataSource Interface

Glossary Item Box

For a list of all members of this type, see IDbConnectionAdapterWithDataSource members.

Public Methods

 | Name | Description
Method | SetDataSourceLocator | Sets the data source getter function for the specified database connection command.
Top

See Also

Reference

IDbConnectionAdapterWithDataSource Interface
GrapeCity.ActiveReports.Core.Rendering.Data Namespace


SetDataSourceLocator Method

[image]
ActiveReports 19 .NET Edition
SetDataSourceLocator Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Data Namespace > IDbConnectionAdapterWithDataSource Interface : SetDataSourceLocator Method

command
The database connection command that needs to be assigned a data source.
func
The function which returns the data source for the command.

Glossary Item Box

Sets the data source getter function for the specified database connection command.

Syntax

Visual Basic (Declaration)
Function SetDataSourceLocator( _
   ByVal command As IDbConnection, _
   ByVal func As Action(Of LocateDataSourceArgs) _
) As Boolean
C#
bool SetDataSourceLocator(
   IDbConnection command,
   Action<LocateDataSourceArgs> func
)

Parameters

command
The database connection command that needs to be assigned a data source.
func
The function which returns the data source for the command.

Return Value

true if the locator is set successfully; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbConnectionAdapterWithDataSource Interface
IDbConnectionAdapterWithDataSource Members


EvalServiceExtension Class

[image]
ActiveReports 19 .NET Edition
EvalServiceExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace : EvalServiceExtension Class

Glossary Item Box

Useful extensions.

Object Model

EvalServiceExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EvalServiceExtension
C#
public static class EvalServiceExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Expressions.EvalServiceExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Members
GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace


EvalServiceExtension Class Members

[image]
ActiveReports 19 .NET Edition
EvalServiceExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace : EvalServiceExtension Class

Glossary Item Box

The following tables list the members exposed by EvalServiceExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate | Overloaded. Evaluate with simple default.
static (Shared in Visual Basic) | EvaluateBool | Evaluate as bool.
static (Shared in Visual Basic) | EvaluateLength | Evaluate as length.
Top

See Also

Reference

EvalServiceExtension Class
GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace


EvalServiceExtension Class Methods

[image]
ActiveReports 19 .NET Edition
EvalServiceExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace : EvalServiceExtension Class

Glossary Item Box

For a list of all members of this type, see EvalServiceExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate | Overloaded. Evaluate with simple default.
static (Shared in Visual Basic) | EvaluateBool | Evaluate as bool.
static (Shared in Visual Basic) | EvaluateLength | Evaluate as length.
Top

See Also

Reference

EvalServiceExtension Class
GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class : Evaluate Method

Glossary Item Box

Evaluate with simple default.

Overload List

Overload | Description
Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo) | Evaluate with simple default.
Evaluate(IExpressionEvaluatorService,ExpressionInfo,Boolean) | Evaluate as bool.
Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo,T) | Evaluate with null value checks.
Evaluate(ExpressionInfo,IExpressionContext) | Evaluate as object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members


Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo) Method

T
[image]
ActiveReports 19 .NET Edition
Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class > Evaluate Method : Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo) Method

evaluator
exp

Glossary Item Box

Evaluate with simple default.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Evaluate(Of T)( _
   ByVal evaluator As IExpressionEvaluatorService, _
   ByVal exp As ExpressionInfo _
) As T
C#
public static T Evaluate<T>(
   IExpressionEvaluatorService evaluator,
   ExpressionInfo exp
)

Parameters

evaluator
exp

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members
Overload List


Evaluate(IExpressionEvaluatorService,ExpressionInfo,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Evaluate(IExpressionEvaluatorService,ExpressionInfo,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class > Evaluate Method : Evaluate(IExpressionEvaluatorService,ExpressionInfo,Boolean) Method

evaluator
exp
defVal

Glossary Item Box

Evaluate as bool.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Evaluate( _
   ByVal evaluator As IExpressionEvaluatorService, _
   ByVal exp As ExpressionInfo, _
   ByVal defVal As Boolean _
) As Boolean
C#
public static bool Evaluate(
   IExpressionEvaluatorService evaluator,
   ExpressionInfo exp,
   bool defVal
)

Parameters

evaluator
exp
defVal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members
Overload List


Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo,T) Method

T
[image]
ActiveReports 19 .NET Edition
Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo,T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class > Evaluate Method : Evaluate<T>(IExpressionEvaluatorService,ExpressionInfo,T) Method

evaluator
exp
defVal

Glossary Item Box

Evaluate with null value checks.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Evaluate(Of T)( _
   ByVal evaluator As IExpressionEvaluatorService, _
   ByVal exp As ExpressionInfo, _
   ByVal defVal As T _
) As T
C#
public static T Evaluate<T>(
   IExpressionEvaluatorService evaluator,
   ExpressionInfo exp,
   T defVal
)

Parameters

evaluator
exp
defVal

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members
Overload List


Evaluate(ExpressionInfo,IExpressionContext) Method

[image]
ActiveReports 19 .NET Edition
Evaluate(ExpressionInfo,IExpressionContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class > Evaluate Method : Evaluate(ExpressionInfo,IExpressionContext) Method

expr
context

Glossary Item Box

Evaluate as object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Evaluate( _
   ByVal expr As ExpressionInfo, _
   ByVal context As IExpressionContext _
) As Object
C#
public static object Evaluate(
   ExpressionInfo expr,
   IExpressionContext context
)

Parameters

expr
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members
Overload List


EvaluateBool Method

[image]
ActiveReports 19 .NET Edition
EvaluateBool Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class : EvaluateBool Method

evaluator
exp

Glossary Item Box

Evaluate as bool.

Syntax

Visual Basic (Declaration)
Public Shared Function EvaluateBool( _
   ByVal evaluator As IExpressionEvaluatorService, _
   ByVal exp As ExpressionInfo _
) As Boolean
C#
public static bool EvaluateBool(
   IExpressionEvaluatorService evaluator,
   ExpressionInfo exp
)

Parameters

evaluator
exp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members


EvaluateLength Method

[image]
ActiveReports 19 .NET Edition
EvaluateLength Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Expressions Namespace > EvalServiceExtension Class : EvaluateLength Method

evaluator
exp
defVal

Glossary Item Box

Evaluate as length.

Syntax

Visual Basic (Declaration)
Public Shared Function EvaluateLength( _
   ByVal evaluator As IExpressionEvaluatorService, _
   ByVal exp As ExpressionInfo, _
   ByVal defVal As String _
) As String
C#
public static string EvaluateLength(
   IExpressionEvaluatorService evaluator,
   ExpressionInfo exp,
   string defVal
)

Parameters

evaluator
exp
defVal

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalServiceExtension Class
EvalServiceExtension Members


ReportItemsFactories Class

[image]
ActiveReports 19 .NET Edition
ReportItemsFactories Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : ReportItemsFactories Class

Glossary Item Box

Registered report items factories.

Object Model

ReportItemsFactories Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemsFactories
C#
public static class ReportItemsFactories

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Extensibility.ReportItemsFactories

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsFactories Members
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


ReportItemsFactories Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemsFactories Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : ReportItemsFactories Class

Glossary Item Box

The following tables list the members exposed by ReportItemsFactories.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetRenderer<TRenderer> |
static (Shared in Visual Basic) | Register | Registers report item factory in the factories list.
Top

See Also

Reference

ReportItemsFactories Class
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


ReportItemsFactories Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemsFactories Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : ReportItemsFactories Class

Glossary Item Box

For a list of all members of this type, see ReportItemsFactories members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetRenderer<TRenderer> |
static (Shared in Visual Basic) | Register | Registers report item factory in the factories list.
Top

See Also

Reference

ReportItemsFactories Class
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


GetRenderer<TRenderer> Method

TRenderer
[image]
ActiveReports 19 .NET Edition
GetRenderer<TRenderer> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > ReportItemsFactories Class : GetRenderer<TRenderer> Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetRenderer(Of TRenderer As {Class, IRenderer})( _
   ByVal item As IReportItem _
) As TRenderer
C#
public static TRenderer GetRenderer<TRenderer>(
   IReportItem item
)
where TRenderer: class, IRenderer

Parameters

item

Type Parameters

TRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsFactories Class
ReportItemsFactories Members


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > ReportItemsFactories Class : Register Method

definitionType
The type of the report item definition.
componentType
The type of render component (part of rendering tree).
getFactory
The function to get a factory instance to be registered.

Glossary Item Box

Registers report item factory in the factories list.

Syntax

Visual Basic (Declaration)
Public Shared Sub Register( _
   ByVal definitionType As Type, _
   ByVal componentType As Type, _
   ByVal getFactory As Func(Of IReportItemFactory) _
)
C#
public static void Register(
   Type definitionType,
   Type componentType,
   Func<IReportItemFactory> getFactory
)

Parameters

definitionType
The type of the report item definition.
componentType
The type of render component (part of rendering tree).
getFactory
The function to get a factory instance to be registered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsFactories Class
ReportItemsFactories Members


IReportItemFactory Interface

[image]
ActiveReports 19 .NET Edition
IReportItemFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : IReportItemFactory Interface

Glossary Item Box

Implement this interface if you want to extend Rendering with new report item.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemFactory
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory
C#
public interface IReportItemFactory : GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemFactory Members
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


IReportItemFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : IReportItemFactory Interface

Glossary Item Box

The following tables list the members exposed by IReportItemFactory.

Public Methods

 | Name | Description
Method | BuildQuery |
Method | CreateItem |
Method | CreateProgram<TReportItemDef> |
Method | GetItemExpressions |
Top

See Also

Reference

IReportItemFactory Interface
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


IReportItemFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportItemFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace : IReportItemFactory Interface

Glossary Item Box

For a list of all members of this type, see IReportItemFactory members.

Public Methods

 | Name | Description
Method | BuildQuery |
Method | CreateItem |
Method | CreateProgram<TReportItemDef> |
Method | GetItemExpressions |
Top

See Also

Reference

IReportItemFactory Interface
GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace


BuildQuery Method

[image]
ActiveReports 19 .NET Edition
BuildQuery Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > IReportItemFactory Interface : BuildQuery Method

ctx
reportItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function BuildQuery( _
   ByVal ctx As ReportBuilder.Context, _
   ByVal reportItem As ReportItem _
) As Def.Region
C#
Def.Region BuildQuery(
   ReportBuilder.Context ctx,
   ReportItem reportItem
)

Parameters

ctx
reportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemFactory Interface
IReportItemFactory Members


CreateItem Method

[image]
ActiveReports 19 .NET Edition
CreateItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > IReportItemFactory Interface : CreateItem Method

program
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateItem( _
   ByVal program As IReportItemProgram(Of ReportItem), _
   ByVal context As IDataScopeInternal _
) As IReportItem
C#
IReportItem CreateItem(
   IReportItemProgram<ReportItem> program,
   IDataScopeInternal context
)

Parameters

program
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemFactory Interface
IReportItemFactory Members


CreateProgram<TReportItemDef> Method

TReportItemDef
[image]
ActiveReports 19 .NET Edition
CreateProgram<TReportItemDef> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > IReportItemFactory Interface : CreateProgram<TReportItemDef> Method

services
item
content

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateProgram(Of TReportItemDef)( _
   ByVal services As IProgramServices, _
   ByVal item As ReportItem, _
   ByVal content As Def.Content _
) As IReportItemProgram(Of TReportItemDef)
C#
IReportItemProgram<TReportItemDef> CreateProgram<TReportItemDef>(
   IProgramServices services,
   ReportItem item,
   Def.Content content
)

Parameters

services
item
content

Type Parameters

TReportItemDef

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemFactory Interface
IReportItemFactory Members


GetItemExpressions Method

[image]
ActiveReports 19 .NET Edition
GetItemExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Extensibility Namespace > IReportItemFactory Interface : GetItemExpressions Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetItemExpressions( _
   ByVal item As ReportItem _
) As IEnumerable(Of ExpressionInfo)
C#
IEnumerable<ExpressionInfo> GetItemExpressions(
   ReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemFactory Interface
IReportItemFactory Members


ActionKind Enumeration

[image]
ActiveReports 19 .NET Edition
ActionKind Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : ActionKind Enumeration

Glossary Item Box

Specifies the kind of action that can be performed.

Syntax

Visual Basic (Declaration)
Public Enum ActionKind
   Inherits System.Enum
C#
public enum ActionKind : System.Enum

Members

Member | Description
None |
Slice |
Sort |
Toggle |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Rendering.Interactivity.ActionKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


ActionKey Structure

[image]
ActiveReports 19 .NET Edition
ActionKey Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : ActionKey Structure

Glossary Item Box

Defines unique identifier of interactive element clicked by user during interactive preview.

Object Model

ActionKey Structure

Syntax

Visual Basic (Declaration)
Public Structure ActionKey
   Inherits System.ValueType
C#
public struct ActionKey : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Rendering.Interactivity.ActionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Members
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


ActionKey Structure Members

[image]
ActiveReports 19 .NET Edition
ActionKey Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : ActionKey Structure

Glossary Item Box

The following tables list the members exposed by ActionKey.

Public Fields

 | Name | Description
Public Field | Kind |
static (Shared in Visual Basic) | Null |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Checks whether the given ActionKey equals to this.
Public Method | GetHashCode | Gets ActionKey hash code.
Public Method | ToString | Gets string representation of ActionKey.
Top

Public Operators

public Operator Explicit Type Conversion Converts string to ActionKey.
Top

See Also

Reference

ActionKey Structure
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


ActionKey Structure Methods

[image]
ActiveReports 19 .NET Edition
ActionKey Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : ActionKey Structure

Glossary Item Box

For a list of all members of this type, see ActionKey members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Checks whether the given ActionKey equals to this.
Public Method | GetHashCode | Gets ActionKey hash code.
Public Method | ToString | Gets string representation of ActionKey.
Top

See Also

Reference

ActionKey Structure
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : Equals Method

Glossary Item Box

Checks whether the given ActionKey equals to this.

Overload List

Overload | Description
Equals(ActionKey) | Checks whether the given ActionKey equals to this.
Equals(Object) | Checks whether the given object equals to this.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


Equals(ActionKey) Method

[image]
ActiveReports 19 .NET Edition
Equals(ActionKey) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure > Equals Method : Equals(ActionKey) Method

other
The ActionKey to compare with.

Glossary Item Box

Checks whether the given ActionKey equals to this.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As ActionKey _
) As Boolean
C#
public bool Equals(
   ActionKey other
)

Parameters

other
The ActionKey to compare with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure > Equals Method : Equals(Object) Method

other
The object to compare with.

Glossary Item Box

Checks whether the given object equals to this.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
C#
public override bool Equals(
   object other
)

Parameters

other
The object to compare with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : GetHashCode Method

Glossary Item Box

Gets ActionKey hash code.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : ToString Method

Glossary Item Box

Gets string representation of ActionKey.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


ActionKey Structure Fields

[image]
ActiveReports 19 .NET Edition
ActionKey Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : ActionKey Structure

Glossary Item Box

For a list of all members of this type, see ActionKey members.

Public Fields

 | Name | Description
Public Field | Kind |
static (Shared in Visual Basic) | Null |
Top

See Also

Reference

ActionKey Structure
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


Kind Field

[image]
ActiveReports 19 .NET Edition
Kind Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : Kind Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Kind As ActionKind
C#
public readonly ActionKind Kind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


Null Field

[image]
ActiveReports 19 .NET Edition
Null Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : Null Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As ActionKey
C#
public static readonly ActionKey Null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


Explicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > ActionKey Structure : Explicit Type Conversion Operator

s
String which contains textual representation of ActionKey

Glossary Item Box

Converts string to ActionKey.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal s As String _
) As ActionKey
C#
public ActionKey operator explicit(
   string s
)

Parameters

s
String which contains textual representation of ActionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionKey Structure
ActionKey Members


InteractiveActions Structure

[image]
ActiveReports 19 .NET Edition
InteractiveActions Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : InteractiveActions Structure

Glossary Item Box

Defines interactivity actions need to be applied to report instance during next rendering.

Object Model

InteractiveActions Structure

Syntax

Visual Basic (Declaration)
Public Structure InteractiveActions
   Inherits System.ValueType
C#
public struct InteractiveActions : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Core.Rendering.Interactivity.InteractiveActions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveActions Members
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


InteractiveActions Structure Members

[image]
ActiveReports 19 .NET Edition
InteractiveActions Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : InteractiveActions Structure

Glossary Item Box

The following tables list the members exposed by InteractiveActions.

Public Properties

 | Name | Description
Public Property | ClickHistory | Gets or sets history of user clicks during interactive preview.
Top

See Also

Reference

InteractiveActions Structure
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


InteractiveActions Structure Properties

[image]
ActiveReports 19 .NET Edition
InteractiveActions Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace : InteractiveActions Structure

Glossary Item Box

For a list of all members of this type, see InteractiveActions members.

Public Properties

 | Name | Description
Public Property | ClickHistory | Gets or sets history of user clicks during interactive preview.
Top

See Also

Reference

InteractiveActions Structure
GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace


ClickHistory Property

[image]
ActiveReports 19 .NET Edition
ClickHistory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Interactivity Namespace > InteractiveActions Structure : ClickHistory Property

Glossary Item Box

Gets or sets history of user clicks during interactive preview.

Syntax

Visual Basic (Declaration)
Public Property ClickHistory As ActionKey()
C#
public ActionKey[] ClickHistory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveActions Structure
InteractiveActions Members


DateTimeFormat Class

[image]
ActiveReports 19 .NET Edition
DateTimeFormat Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : DateTimeFormat Class

Glossary Item Box

DateTime formatting code forJP calendar only.

Object Model

DateTimeFormat Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DateTimeFormat
C#
public static class DateTimeFormat

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.JpCalendar.DateTimeFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeFormat Members
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


DateTimeFormat Class Members

[image]
ActiveReports 19 .NET Edition
DateTimeFormat Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : DateTimeFormat Class

Glossary Item Box

The following tables list the members exposed by DateTimeFormat.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CustomJpCalendar |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Format | Formats date as general for not JP case. For JP - with era settings and custom format "ggYY" support.
static (Shared in Visual Basic) | FormatCustomized |
Top

See Also

Reference

DateTimeFormat Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


DateTimeFormat Class Methods

[image]
ActiveReports 19 .NET Edition
DateTimeFormat Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : DateTimeFormat Class

Glossary Item Box

For a list of all members of this type, see DateTimeFormat members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Format | Formats date as general for not JP case. For JP - with era settings and custom format "ggYY" support.
static (Shared in Visual Basic) | FormatCustomized |
Top

See Also

Reference

DateTimeFormat Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


Format Method

[image]
ActiveReports 19 .NET Edition
Format Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > DateTimeFormat Class : Format Method

format
arg
culture

Glossary Item Box

Formats date as general for not JP case. For JP - with era settings and custom format "ggYY" support.

Syntax

Visual Basic (Declaration)
Public Shared Function Format( _
   ByVal format As String, _
   ByVal arg As Date, _
   ByVal culture As CultureInfo _
) As String
C#
public static string Format(
   string format,
   DateTime arg,
   CultureInfo culture
)

Parameters

format
arg
culture

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeFormat Class
DateTimeFormat Members


FormatCustomized Method

[image]
ActiveReports 19 .NET Edition
FormatCustomized Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > DateTimeFormat Class : FormatCustomized Method

dateTime
format
dtfi
calendar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function FormatCustomized( _
   ByVal dateTime As Date, _
   ByVal format As String, _
   ByVal dtfi As DateTimeFormatInfo, _
   ByVal calendar As Calendar _
) As String
C#
public static string FormatCustomized(
   DateTime dateTime,
   string format,
   DateTimeFormatInfo dtfi,
   Calendar calendar
)

Parameters

dateTime
format
dtfi
calendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeFormat Class
DateTimeFormat Members


DateTimeFormat Class Fields

[image]
ActiveReports 19 .NET Edition
DateTimeFormat Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : DateTimeFormat Class

Glossary Item Box

For a list of all members of this type, see DateTimeFormat members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CustomJpCalendar |
Top

See Also

Reference

DateTimeFormat Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


CustomJpCalendar Field

[image]
ActiveReports 19 .NET Edition
CustomJpCalendar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > DateTimeFormat Class : CustomJpCalendar Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared CustomJpCalendar As JapaneseCalendarEx
C#
public static JapaneseCalendarEx CustomJpCalendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeFormat Class
DateTimeFormat Members


EraInfo Class

[image]
ActiveReports 19 .NET Edition
EraInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : EraInfo Class

Glossary Item Box

Represents the era info.

Object Model

EraInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EraInfo
C#
public sealed class EraInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.JpCalendar.EraInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Members
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


EraInfo Class Members

[image]
ActiveReports 19 .NET Edition
EraInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : EraInfo Class

Glossary Item Box

The following tables list the members exposed by EraInfo.

Public Constructors

 | Name | Description
Public Constructor | EraInfo Constructor | Initializes a new instance of the EraInfo class.
Top

Public Properties

 | Name | Description
Public Property | AbbreviatedEraName |
Public Property | EndTime |
Public Property | EnglishEraName |
Public Property | Era |
Public Property | EraName |
Public Property | StartTime |
Public Property | SymbolEraName |
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | IsValid | Determines whether the specified date time is valid.
Top

See Also

Reference

EraInfo Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


EraInfo Constructor

[image]
ActiveReports 19 .NET Edition
EraInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : EraInfo Constructor

era
The era.
startTime
The start time.
endTime
The end time.
eraName
Name of the era.
abbreviatedEraName
Name of the abbreviated era.
englishEraName
Name of the english era.
symbolEraName
Name of the symbol era.

Glossary Item Box

Initializes a new instance of the EraInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal era As Integer, _
   ByVal startTime As Date, _
   ByVal endTime As Date, _
   ByVal eraName As String, _
   ByVal abbreviatedEraName As String, _
   ByVal englishEraName As String, _
   ByVal symbolEraName As String _
)
C#
public EraInfo(
   int era,
   DateTime startTime,
   DateTime endTime,
   string eraName,
   string abbreviatedEraName,
   string englishEraName,
   string symbolEraName
)

Parameters

era
The era.
startTime
The start time.
endTime
The end time.
eraName
Name of the era.
abbreviatedEraName
Name of the abbreviated era.
englishEraName
Name of the english era.
symbolEraName
Name of the symbol era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


EraInfo Class Methods

[image]
ActiveReports 19 .NET Edition
EraInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : EraInfo Class

Glossary Item Box

For a list of all members of this type, see EraInfo members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Public Method | IsValid | Determines whether the specified date time is valid.
Top

See Also

Reference

EraInfo Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : IsValid Method

dateTime
The date time.

Glossary Item Box

Determines whether the specified date time is valid.

Syntax

Visual Basic (Declaration)
Public Function IsValid( _
   ByVal dateTime As Date _
) As Boolean
C#
public bool IsValid(
   DateTime dateTime
)

Parameters

dateTime
The date time.

Return Value

true if the specified date time is valid; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


EraInfo Class Properties

[image]
ActiveReports 19 .NET Edition
EraInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : EraInfo Class

Glossary Item Box

For a list of all members of this type, see EraInfo members.

Public Properties

 | Name | Description
Public Property | AbbreviatedEraName |
Public Property | EndTime |
Public Property | EnglishEraName |
Public Property | Era |
Public Property | EraName |
Public Property | StartTime |
Public Property | SymbolEraName |
Top

See Also

Reference

EraInfo Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


AbbreviatedEraName Property

[image]
ActiveReports 19 .NET Edition
AbbreviatedEraName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : AbbreviatedEraName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbbreviatedEraName As String
C#
public string AbbreviatedEraName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


EndTime Property

[image]
ActiveReports 19 .NET Edition
EndTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : EndTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndTime As Date
C#
public DateTime EndTime {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


EnglishEraName Property

[image]
ActiveReports 19 .NET Edition
EnglishEraName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : EnglishEraName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnglishEraName As String
C#
public string EnglishEraName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


Era Property

[image]
ActiveReports 19 .NET Edition
Era Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : Era Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Era As Integer
C#
public int Era {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


EraName Property

[image]
ActiveReports 19 .NET Edition
EraName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : EraName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EraName As String
C#
public string EraName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


StartTime Property

[image]
ActiveReports 19 .NET Edition
StartTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : StartTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartTime As Date
C#
public DateTime StartTime {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


SymbolEraName Property

[image]
ActiveReports 19 .NET Edition
SymbolEraName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > EraInfo Class : SymbolEraName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SymbolEraName As String
C#
public string SymbolEraName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EraInfo Class
EraInfo Members


JapaneseCalendarEx Class

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : JapaneseCalendarEx Class

Glossary Item Box

Jp calendar implementation that can be configured with custom eras set.

Object Model

JapaneseCalendarEx Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class JapaneseCalendarEx
   Inherits System.Globalization.Calendar
C#
public sealed class JapaneseCalendarEx : System.Globalization.Calendar

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Globalization.Calendar
GrapeCity.ActiveReports.Core.Rendering.JpCalendar.JapaneseCalendarEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Members
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


JapaneseCalendarEx Class Members

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : JapaneseCalendarEx Class

Glossary Item Box

The following tables list the members exposed by JapaneseCalendarEx.

Public Constructors

 | Name | Description
Public Constructor | JapaneseCalendarEx Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Error |
Top

Public Properties

 | Name | Description
Public Property | AlgorithmType | Overridden. Gets a value that indicates whether the current calendar is solar-based, lunar-based, or a combination of both.
Public Property | Eras | Overridden. Gets the list of eras in the CalendarEx.
Public Property | MaxSupportedDateTime | Overridden. Gets the latest date and time supported by the current JapaneseCalendarEx object.
Public Property | MinSupportedDateTime | Overridden. Gets the earliest date and time supported by the current JapaneseCalendarEx object.
Public Property | TwoDigitYearMax | Overridden. Gets or sets the last year of a 100-year range that can be represented by a 2-digit year.
Top

Public Methods

 | Name | Description
Public Method | AddMonths | Overridden. Returns a System.DateTime that is the specified number of months away from the specified System.DateTime.
Public Method | AddYears | Overridden. Returns a System.DateTime that is the specified number of years away from the specified System.DateTime.
Public Method | GetDayOfMonth | Overridden. Returns the day of the month in the specified System.DateTime.
Public Method | GetDayOfWeek | Overridden. Returns the day of the week in the specified System.DateTime.
Public Method | GetDayOfYear | Overridden. Returns the day of the year in the specified System.DateTime.
Public Method | GetDaysInMonth | Overloaded. Overridden. Returns the number of days in the specified month in the specified year in the specified era.
Public Method | GetDaysInYear | Overloaded. Overridden. Returns the number of days in the specified year in the specified era.
Public Method | GetEra | Overridden. Returns the era in the specified System.DateTime.
Public Method | GetLeapMonth | Overloaded. Overridden. Calculates the leap month for a specified year and era.
Public Method | GetMonth | Overridden. Returns the month in the specified System.DateTime.
Public Method | GetMonthsInYear | Overloaded. Overridden. Returns the number of months in the specified year in the specified era.
Public Method | GetWeekOfYear | Overridden. Returns the week of the year that includes the date in the specified System.DateTime object.
Public Method | GetYear | Overridden. Returns the year in the specified System.DateTime.
Public Method | IsLeapDay | Overloaded. Overridden. Determines whether the specified date in the specified era is a leap day.
Public Method | IsLeapMonth | Overloaded. Overridden. Determines whether the specified month in the specified year in the specified era is a leap month.
Public Method | IsLeapYear | Overloaded. Overridden. Determines whether the specified year in the specified era is a leap year.
Public Method | ToDateTime | Overloaded. Overridden. Returns a System.DateTime that is set to the specified date and time in the specified era.
Top

See Also

Reference

JapaneseCalendarEx Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


JapaneseCalendarEx Constructor

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : JapaneseCalendarEx Constructor

Glossary Item Box

Overload List

Overload | Description
JapaneseCalendarEx Constructor(Exception) |
JapaneseCalendarEx Constructor(EraInfo[]) | Initializes a new instance of the JapaneseCalendarEx class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


JapaneseCalendarEx Constructor(Exception)

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Constructor(Exception)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > JapaneseCalendarEx Constructor : JapaneseCalendarEx Constructor(Exception)

ex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ex As Exception _
)
C#
public JapaneseCalendarEx(
   Exception ex
)

Parameters

ex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


JapaneseCalendarEx Constructor(EraInfo[])

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Constructor(EraInfo[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > JapaneseCalendarEx Constructor : JapaneseCalendarEx Constructor(EraInfo[])

erasInfo
An EraInfo array that represents the eras information.

Glossary Item Box

Initializes a new instance of the JapaneseCalendarEx class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal erasInfo() As EraInfo _
)
C#
public JapaneseCalendarEx(
   EraInfo[] erasInfo
)

Parameters

erasInfo
An EraInfo array that represents the eras information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


JapaneseCalendarEx Class Methods

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : JapaneseCalendarEx Class

Glossary Item Box

For a list of all members of this type, see JapaneseCalendarEx members.

Public Methods

 | Name | Description
Public Method | AddMonths | Overridden. Returns a System.DateTime that is the specified number of months away from the specified System.DateTime.
Public Method | AddYears | Overridden. Returns a System.DateTime that is the specified number of years away from the specified System.DateTime.
Public Method | GetDayOfMonth | Overridden. Returns the day of the month in the specified System.DateTime.
Public Method | GetDayOfWeek | Overridden. Returns the day of the week in the specified System.DateTime.
Public Method | GetDayOfYear | Overridden. Returns the day of the year in the specified System.DateTime.
Public Method | GetDaysInMonth | Overloaded. Overridden. Returns the number of days in the specified month in the specified year in the specified era.
Public Method | GetDaysInYear | Overloaded. Overridden. Returns the number of days in the specified year in the specified era.
Public Method | GetEra | Overridden. Returns the era in the specified System.DateTime.
Public Method | GetLeapMonth | Overloaded. Overridden. Calculates the leap month for a specified year and era.
Public Method | GetMonth | Overridden. Returns the month in the specified System.DateTime.
Public Method | GetMonthsInYear | Overloaded. Overridden. Returns the number of months in the specified year in the specified era.
Public Method | GetWeekOfYear | Overridden. Returns the week of the year that includes the date in the specified System.DateTime object.
Public Method | GetYear | Overridden. Returns the year in the specified System.DateTime.
Public Method | IsLeapDay | Overloaded. Overridden. Determines whether the specified date in the specified era is a leap day.
Public Method | IsLeapMonth | Overloaded. Overridden. Determines whether the specified month in the specified year in the specified era is a leap month.
Public Method | IsLeapYear | Overloaded. Overridden. Determines whether the specified year in the specified era is a leap year.
Public Method | ToDateTime | Overloaded. Overridden. Returns a System.DateTime that is set to the specified date and time in the specified era.
Top

See Also

Reference

JapaneseCalendarEx Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


AddMonths Method

[image]
ActiveReports 19 .NET Edition
AddMonths Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : AddMonths Method

time
The System.DateTime to which to add months.
months
The number of months to add.

Glossary Item Box

Returns a System.DateTime that is the specified number of months away from the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function AddMonths( _
   ByVal time As Date, _
   ByVal months As Integer _
) As Date
C#
public override DateTime AddMonths(
   DateTime time,
   int months
)

Parameters

time
The System.DateTime to which to add months.
months
The number of months to add.

Return Value

The System.DateTime that results from adding the specified number of months to the specified System.DateTime.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | months is less than -120000.-or- months is greater than 120000.
System.ArgumentException | The resulting System.DateTime is outside the supported range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


AddYears Method

[image]
ActiveReports 19 .NET Edition
AddYears Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : AddYears Method

time
The System.DateTime to which to add years.
years
The number of years to add.

Glossary Item Box

Returns a System.DateTime that is the specified number of years away from the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function AddYears( _
   ByVal time As Date, _
   ByVal years As Integer _
) As Date
C#
public override DateTime AddYears(
   DateTime time,
   int years
)

Parameters

time
The System.DateTime to which to add years.
years
The number of years to add.

Return Value

The System.DateTime that results from adding the specified number of years to the specified System.DateTime.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | time is outside the supported range of the JapaneseCalendarEx type. -or-years is less than -10,000 or greater than 10,000.
System.ArgumentException | The resulting System.DateTime is outside the supported range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDayOfMonth Method

[image]
ActiveReports 19 .NET Edition
GetDayOfMonth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetDayOfMonth Method

time
The System.DateTime to read.

Glossary Item Box

Returns the day of the month in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetDayOfMonth( _
   ByVal time As Date _
) As Integer
C#
public override int GetDayOfMonth(
   DateTime time
)

Parameters

time
The System.DateTime to read.

Return Value

An integer from 1 to 31 that represents the day of the month in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDayOfWeek Method

[image]
ActiveReports 19 .NET Edition
GetDayOfWeek Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetDayOfWeek Method

time
The System.DateTime to read.

Glossary Item Box

Returns the day of the week in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetDayOfWeek( _
   ByVal time As Date _
) As DayOfWeek
C#
public override DayOfWeek GetDayOfWeek(
   DateTime time
)

Parameters

time
The System.DateTime to read.

Return Value

A System.DayOfWeek value that represents the day of the week in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDayOfYear Method

[image]
ActiveReports 19 .NET Edition
GetDayOfYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetDayOfYear Method

time
The System.DateTime to read.

Glossary Item Box

Returns the day of the year in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetDayOfYear( _
   ByVal time As Date _
) As Integer
C#
public override int GetDayOfYear(
   DateTime time
)

Parameters

time
The System.DateTime to read.

Return Value

An integer from 1 to 366 that represents the day of the year in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDaysInMonth Method

[image]
ActiveReports 19 .NET Edition
GetDaysInMonth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetDaysInMonth Method

Glossary Item Box

Returns the number of days in the specified month in the specified year in the specified era.

Overload List

Overload | Description
GetDaysInMonth(Int32,Int32,Int32) | Returns the number of days in the specified month in the specified year in the specified era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDaysInMonth(Int32,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
GetDaysInMonth(Int32,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > GetDaysInMonth Method : GetDaysInMonth(Int32,Int32,Int32) Method

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
era
An integer that represents the era.

Glossary Item Box

Returns the number of days in the specified month in the specified year in the specified era.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetDaysInMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Integer
C#
public override int GetDaysInMonth(
   int year,
   int month,
   int era
)

Parameters

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
era
An integer that represents the era.

Return Value

The number of days in the specified month in the specified year in the specified era.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- month is outside the range supported by the calendar. -or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


GetDaysInYear Method

[image]
ActiveReports 19 .NET Edition
GetDaysInYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetDaysInYear Method

Glossary Item Box

Returns the number of days in the specified year in the specified era.

Overload List

Overload | Description
GetDaysInYear(Int32,Int32) | Returns the number of days in the specified year in the specified era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetDaysInYear(Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
GetDaysInYear(Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > GetDaysInYear Method : GetDaysInYear(Int32,Int32) Method

year
An integer that represents the year.
era
An integer that represents the era.

Glossary Item Box

Returns the number of days in the specified year in the specified era.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetDaysInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
C#
public override int GetDaysInYear(
   int year,
   int era
)

Parameters

year
An integer that represents the year.
era
An integer that represents the era.

Return Value

The number of days in the specified year in the specified era.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


GetEra Method

[image]
ActiveReports 19 .NET Edition
GetEra Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetEra Method

dateTime
The System.DateTime to read.

Glossary Item Box

Returns the era in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetEra( _
   ByVal dateTime As Date _
) As Integer
C#
public override int GetEra(
   DateTime dateTime
)

Parameters

dateTime
The System.DateTime to read.

Return Value

An integer that represents the era in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetLeapMonth Method

[image]
ActiveReports 19 .NET Edition
GetLeapMonth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetLeapMonth Method

Glossary Item Box

Calculates the leap month for a specified year and era.

Overload List

Overload | Description
GetLeapMonth(Int32,Int32) | Calculates the leap month for a specified year and era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetLeapMonth(Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
GetLeapMonth(Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > GetLeapMonth Method : GetLeapMonth(Int32,Int32) Method

year
A year.
era
An era.

Glossary Item Box

Calculates the leap month for a specified year and era.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetLeapMonth( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
C#
public override int GetLeapMonth(
   int year,
   int era
)

Parameters

year
A year.
era
An era.

Return Value

The return value is always 0 because the JapaneseCalendarEx type does not support the notion of a leap month.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year or era is outside the range supported by the JapaneseCalendarEx type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


GetMonth Method

[image]
ActiveReports 19 .NET Edition
GetMonth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetMonth Method

time
The System.DateTime to read.

Glossary Item Box

Returns the month in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetMonth( _
   ByVal time As Date _
) As Integer
C#
public override int GetMonth(
   DateTime time
)

Parameters

time
The System.DateTime to read.

Return Value

An integer from 1 to 12 that represents the month in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetMonthsInYear Method

[image]
ActiveReports 19 .NET Edition
GetMonthsInYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetMonthsInYear Method

Glossary Item Box

Returns the number of months in the specified year in the specified era.

Overload List

Overload | Description
GetMonthsInYear(Int32,Int32) | Returns the number of months in the specified year in the specified era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetMonthsInYear(Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
GetMonthsInYear(Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > GetMonthsInYear Method : GetMonthsInYear(Int32,Int32) Method

year
An integer that represents the year.
era
An integer that represents the era.

Glossary Item Box

Returns the number of months in the specified year in the specified era.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetMonthsInYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Integer
C#
public override int GetMonthsInYear(
   int year,
   int era
)

Parameters

year
An integer that represents the year.
era
An integer that represents the era.

Return Value

The return value is always 12.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


GetWeekOfYear Method

[image]
ActiveReports 19 .NET Edition
GetWeekOfYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetWeekOfYear Method

time
The System.DateTime object to read.
rule
One of the System.Globalization.CalendarWeekRule values that defines a calendar week.
firstDayOfWeek
One of the System.DayOfWeek values that represents the first day of the week.

Glossary Item Box

Returns the week of the year that includes the date in the specified System.DateTime object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetWeekOfYear( _
   ByVal time As Date, _
   ByVal rule As CalendarWeekRule, _
   ByVal firstDayOfWeek As DayOfWeek _
) As Integer
C#
public override int GetWeekOfYear(
   DateTime time,
   CalendarWeekRule rule,
   DayOfWeek firstDayOfWeek
)

Parameters

time
The System.DateTime object to read.
rule
One of the System.Globalization.CalendarWeekRule values that defines a calendar week.
firstDayOfWeek
One of the System.DayOfWeek values that represents the first day of the week.

Return Value

A 1-based integer that represents the week of the year that includes the date in the time parameter.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | time or firstDayOfWeek is outside the range supported by the calendar. -or- rule is not a valid System.Globalization.CalendarWeekRule value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


GetYear Method

[image]
ActiveReports 19 .NET Edition
GetYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : GetYear Method

dateTime
The System.DateTime to read.

Glossary Item Box

Returns the year in the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetYear( _
   ByVal dateTime As Date _
) As Integer
C#
public override int GetYear(
   DateTime dateTime
)

Parameters

dateTime
The System.DateTime to read.

Return Value

An integer that represents the year in the specified System.DateTime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


IsLeapDay Method

[image]
ActiveReports 19 .NET Edition
IsLeapDay Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : IsLeapDay Method

Glossary Item Box

Determines whether the specified date in the specified era is a leap day.

Overload List

Overload | Description
IsLeapDay(Int32,Int32,Int32,Int32) | Determines whether the specified date in the specified era is a leap day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


IsLeapDay(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
IsLeapDay(Int32,Int32,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > IsLeapDay Method : IsLeapDay(Int32,Int32,Int32,Int32) Method

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
day
An integer from 1 to 31 that represents the day.
era
An integer that represents the era.

Glossary Item Box

Determines whether the specified date in the specified era is a leap day.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsLeapDay( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal era As Integer _
) As Boolean
C#
public override bool IsLeapDay(
   int year,
   int month,
   int day,
   int era
)

Parameters

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
day
An integer from 1 to 31 that represents the day.
era
An integer that represents the era.

Return Value

true, if the specified day is a leap day; otherwise, false.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- month is outside the range supported by the calendar. -or- day is outside the range supported by the calendar.-or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


IsLeapMonth Method

[image]
ActiveReports 19 .NET Edition
IsLeapMonth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : IsLeapMonth Method

Glossary Item Box

Determines whether the specified month in the specified year in the specified era is a leap month.

Overload List

Overload | Description
IsLeapMonth(Int32,Int32,Int32) | Determines whether the specified month in the specified year in the specified era is a leap month.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


IsLeapMonth(Int32,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
IsLeapMonth(Int32,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > IsLeapMonth Method : IsLeapMonth(Int32,Int32,Int32) Method

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
era
An integer that represents the era.

Glossary Item Box

Determines whether the specified month in the specified year in the specified era is a leap month.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsLeapMonth( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal era As Integer _
) As Boolean
C#
public override bool IsLeapMonth(
   int year,
   int month,
   int era
)

Parameters

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
era
An integer that represents the era.

Return Value

This method always returns false, unless overridden by a derived class.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- month is outside the range supported by the calendar. -or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


IsLeapYear Method

[image]
ActiveReports 19 .NET Edition
IsLeapYear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : IsLeapYear Method

Glossary Item Box

Determines whether the specified year in the specified era is a leap year.

Overload List

Overload | Description
IsLeapYear(Int32,Int32) | Determines whether the specified year in the specified era is a leap year.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


IsLeapYear(Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
IsLeapYear(Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > IsLeapYear Method : IsLeapYear(Int32,Int32) Method

year
An integer that represents the year.
era
An integer that represents the era.

Glossary Item Box

Determines whether the specified year in the specified era is a leap year.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsLeapYear( _
   ByVal year As Integer, _
   ByVal era As Integer _
) As Boolean
C#
public override bool IsLeapYear(
   int year,
   int era
)

Parameters

year
An integer that represents the year.
era
An integer that represents the era.

Return Value

true, if the specified year is a leap year; otherwise, false.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar. -or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


ToDateTime Method

[image]
ActiveReports 19 .NET Edition
ToDateTime Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : ToDateTime Method

Glossary Item Box

Returns a System.DateTime that is set to the specified date and time in the specified era.

Overload List

Overload | Description
ToDateTime(Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32) | Returns a System.DateTime that is set to the specified date and time in the specified era.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


ToDateTime(Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
ToDateTime(Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class > ToDateTime Method : ToDateTime(Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32) Method

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
day
An integer from 1 to 31 that represents the day.
hour
An integer from 0 to 23 that represents the hour.
minute
An integer from 0 to 59 that represents the minute.
second
An integer from 0 to 59 that represents the second.
millisecond
An integer from 0 to 999 that represents the millisecond.
era
An integer that represents the era.

Glossary Item Box

Returns a System.DateTime that is set to the specified date and time in the specified era.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ToDateTime( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal millisecond As Integer, _
   ByVal era As Integer _
) As Date
C#
public override DateTime ToDateTime(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int millisecond,
   int era
)

Parameters

year
An integer that represents the year.
month
An integer from 1 to 12 that represents the month.
day
An integer from 1 to 31 that represents the day.
hour
An integer from 0 to 23 that represents the hour.
minute
An integer from 0 to 59 that represents the minute.
second
An integer from 0 to 59 that represents the second.
millisecond
An integer from 0 to 999 that represents the millisecond.
era
An integer that represents the era.

Return Value

The System.DateTime that is set to the specified date and time in the current era.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | year is outside the range supported by the calendar.-or- month is outside the range supported by the calendar. -or- day is outside the range supported by the calendar.-or- hour is less than zero or greater than 23. -or- minute is less than zero or greater than 59.-or- second is less than zero or greater than 59. -or- millisecond is less than zero or greater than 999.-or- era is outside the range supported by the calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members
Overload List


JapaneseCalendarEx Class Properties

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : JapaneseCalendarEx Class

Glossary Item Box

For a list of all members of this type, see JapaneseCalendarEx members.

Public Properties

 | Name | Description
Public Property | AlgorithmType | Overridden. Gets a value that indicates whether the current calendar is solar-based, lunar-based, or a combination of both.
Public Property | Eras | Overridden. Gets the list of eras in the CalendarEx.
Public Property | MaxSupportedDateTime | Overridden. Gets the latest date and time supported by the current JapaneseCalendarEx object.
Public Property | MinSupportedDateTime | Overridden. Gets the earliest date and time supported by the current JapaneseCalendarEx object.
Public Property | TwoDigitYearMax | Overridden. Gets or sets the last year of a 100-year range that can be represented by a 2-digit year.
Top

See Also

Reference

JapaneseCalendarEx Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


AlgorithmType Property

[image]
ActiveReports 19 .NET Edition
AlgorithmType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : AlgorithmType Property

Glossary Item Box

Gets a value that indicates whether the current calendar is solar-based, lunar-based, or a combination of both.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AlgorithmType As CalendarAlgorithmType
C#
public override CalendarAlgorithmType AlgorithmType {get;}

Property Value

Always returns the System.Globalization.CalendarAlgorithmType.SolarCalendar value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


Eras Property

[image]
ActiveReports 19 .NET Edition
Eras Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : Eras Property

Glossary Item Box

Gets the list of eras in the CalendarEx.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Eras As Integer()
C#
public override int[] Eras {get;}

Property Value

An array of integers that represents the eras in the CalendarEx.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


MaxSupportedDateTime Property

[image]
ActiveReports 19 .NET Edition
MaxSupportedDateTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : MaxSupportedDateTime Property

Glossary Item Box

Gets the latest date and time supported by the current JapaneseCalendarEx object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property MaxSupportedDateTime As Date
C#
public override DateTime MaxSupportedDateTime {get;}

Property Value

The latest date and time supported by the JapaneseCalendarEx type, which is equivalent to the last moment of December 31, 9999 C.E. in the Gregorian calendar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


MinSupportedDateTime Property

[image]
ActiveReports 19 .NET Edition
MinSupportedDateTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : MinSupportedDateTime Property

Glossary Item Box

Gets the earliest date and time supported by the current JapaneseCalendarEx object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property MinSupportedDateTime As Date
C#
public override DateTime MinSupportedDateTime {get;}

Property Value

The earliest date and time supported by the JapaneseCalendarEx type, which is equivalent to the first moment of September 8, 1868 C.E. in the Gregorian calendar. For more information, see Remarks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


TwoDigitYearMax Property

[image]
ActiveReports 19 .NET Edition
TwoDigitYearMax Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : TwoDigitYearMax Property

Glossary Item Box

Gets or sets the last year of a 100-year range that can be represented by a 2-digit year.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property TwoDigitYearMax As Integer
C#
public override int TwoDigitYearMax {get; set;}

Property Value

The last year of a 100-year range that can be represented by a 2-digit year.

Exceptions

Exception | Description
System.InvalidOperationException | The current System.Globalization.Calendar object is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


JapaneseCalendarEx Class Fields

[image]
ActiveReports 19 .NET Edition
JapaneseCalendarEx Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace : JapaneseCalendarEx Class

Glossary Item Box

For a list of all members of this type, see JapaneseCalendarEx members.

Public Fields

 | Name | Description
Public Field | Error |
Top

See Also

Reference

JapaneseCalendarEx Class
GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace


Error Field

[image]
ActiveReports 19 .NET Edition
Error Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.JpCalendar Namespace > JapaneseCalendarEx Class : Error Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Error As Exception
C#
public readonly Exception Error

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JapaneseCalendarEx Class
JapaneseCalendarEx Members


Parameter Class

[image]
ActiveReports 19 .NET Edition
Parameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : Parameter Class

Glossary Item Box

Specifies information about a parameter for the report.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter
C#
public sealed class Parameter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Parameter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor | Creates a Parameter using the Rdl report parameter and the datamap.
Top

Public Properties

 | Name | Description
Public Property | AllowBlank | Indicates whether an empty string is a valid value for this parameter.
Public Property | CurrentValue | Gets or sets the current value of the Parameter.
Public Property | DataType | The data type of the parameter.
Public Property | DateOnly | Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Public Property | DefaultValues | The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.
Public Property | DefinesValidValues | Gets whether this parameter has valid values defined in the report definition.
Public Property | DependentParameters | Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.
Public Property | DisplayFormat | Parameter display format.
Public Property | ErrorMessage | Gets the error message associated with this parameter.
Public Property | Hidden | Indicates the parameter should not be displayed to the user.
Public Property | Label | Gets or sets the label of the current value of the Parameter.
Public Property | LabelsArray | Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.
Public Property | Multiline | Indicates whether the parameter value supposes to be multiline.
Public Property | MultiValue | Indicates if this parameter accepts multiple values.
Public Property | Name | Name of the parameter (This name can be used by expressions to refer to this parameter).
Public Property | Nullable | Indicates the value for this parameter is allowed to be Null.
Public Property | OrderByCondition | Gets a condition of the this parameter's valid values order.
Public Property | OrderByDirection | Gets a direction of the this parameter's valid values order.
Public Property | Prompt | The text to display to a user when prompting the a for the parameter's value.
Public Property | PromptUser | Indicates if the user should be prompted for this parameter's value.
Public Property | QueryParameter | Indicates whether the parameter is used in a query.
Public Property | SelectAllValue | If not empty, determines the value which will be passed in parameter value if "Select All" flag was set for multivalue parameter.
Public Property | State | Specifies the current state of this parameter.
Public Property | ValidValues | The ordered list of possible values for this parameter.
Public Property | Values | Gets the Values collection for this parameter. Used for Multivalue parameters.
Public Property | ValuesArray | Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates new instance of Parameter with specified properties.
Public Method | RefreshParameterValues |
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Parameter Constructor

[image]
ActiveReports 19 .NET Edition
Parameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Parameter Constructor

report
rParameter
parameterInfo

Glossary Item Box

Creates a Parameter using the Rdl report parameter and the datamap.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   ByVal rParameter As ReportParameter, _
   ByVal parameterInfo As IParameterInfo _
)
C#
public Parameter(
   Report report,
   ReportParameter rParameter,
   IParameterInfo parameterInfo
)

Parameters

report
rParameter
parameterInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

[image]
ActiveReports 19 .NET Edition
Parameter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates new instance of Parameter with specified properties.
Public Method | RefreshParameterValues |
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Create Method

Glossary Item Box

Creates new instance of Parameter with specified properties.

Overload List

Overload | Description
Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,Report) | Creates new instance of Parameter with specified properties.
Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,ExpressionInfo,Report) | Creates new instance of Parameter with specified properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,Report) Method

[image]
ActiveReports 19 .NET Edition
Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class > Create Method : Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,Report) Method

name
The parameter name.
prompt
The text to display to a user when prompting the a for the parameter's value.
dataType
The data type of the new parameter.
state
Specifies the state of the new parameter.
nullable
Specifies whether the new parameter is allowed to be Null.
allowBlank
Specifies whether an empty string is a valid value for the new parameter.
hidden
Specifies whether parameter should not be displayed to the user.
multiValue
Specifies whether the new parameter accepts multiple values.
usedInQuery
Specifies whether the new parameter is used in a query.
multiline
Specifies whether the parameter value supposes to be multiline.
dateOnly
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
orderByCondition
Specifies whether the valid values are ordered by labels, values or none for the parameter.
orderByDirection
Specifies whether the valid values are ordered in ascending or descending order for the parameter.
report
The report.

Glossary Item Box

Creates new instance of Parameter with specified properties.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal name As String, _
   ByVal prompt As ExpressionInfo, _
   ByVal dataType As ParameterType, _
   ByVal state As ParameterState, _
   ByVal nullable As Boolean, _
   ByVal allowBlank As Boolean, _
   ByVal hidden As Boolean, _
   ByVal multiValue As Boolean, _
   ByVal usedInQuery As Boolean, _
   ByVal multiline As Boolean, _
   ByVal dateOnly As Boolean, _
   ByVal orderByCondition As OrderByCondition, _
   ByVal orderByDirection As OrderByDirection, _
   Optional ByVal report As Report _
) As Parameter
C#
public static Parameter Create(
   string name,
   ExpressionInfo prompt,
   ParameterType dataType,
   ParameterState state,
   bool nullable,
   bool allowBlank,
   bool hidden,
   bool multiValue,
   bool usedInQuery,
   bool multiline,
   bool dateOnly,
   OrderByCondition orderByCondition,
   OrderByDirection orderByDirection,
   Report report
)

Parameters

name
The parameter name.
prompt
The text to display to a user when prompting the a for the parameter's value.
dataType
The data type of the new parameter.
state
Specifies the state of the new parameter.
nullable
Specifies whether the new parameter is allowed to be Null.
allowBlank
Specifies whether an empty string is a valid value for the new parameter.
hidden
Specifies whether parameter should not be displayed to the user.
multiValue
Specifies whether the new parameter accepts multiple values.
usedInQuery
Specifies whether the new parameter is used in a query.
multiline
Specifies whether the parameter value supposes to be multiline.
dateOnly
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
orderByCondition
Specifies whether the valid values are ordered by labels, values or none for the parameter.
orderByDirection
Specifies whether the valid values are ordered in ascending or descending order for the parameter.
report
The report.

Return Value

New Parameter instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members
Overload List


Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,ExpressionInfo,Report) Method

[image]
ActiveReports 19 .NET Edition
Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,ExpressionInfo,Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class > Create Method : Create(String,ExpressionInfo,ParameterType,ParameterState,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,OrderByCondition,OrderByDirection,ExpressionInfo,Report) Method

name
The parameter name.
prompt
The text to display to a user when prompting the a for the parameter's value.
dataType
The data type of the new parameter.
state
Specifies the state of the new parameter.
nullable
Specifies whether the new parameter is allowed to be Null.
allowBlank
Specifies whether an empty string is a valid value for the new parameter.
hidden
Specifies whether parameter should not be displayed to the user.
multiValue
Specifies whether the new parameter accepts multiple values.
usedInQuery
Specifies whether the new parameter is used in a query.
multiline
Specifies whether the parameter value supposes to be multiline.
dateOnly
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
orderByCondition
Specifies whether the valid values are ordered by labels, values or none for the parameter.
orderByDirection
Specifies whether the valid values are ordered in ascending or descending order for the parameter.
displayFormat
Parameter display format.
report
The report.

Glossary Item Box

Creates new instance of Parameter with specified properties.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal name As String, _
   ByVal prompt As ExpressionInfo, _
   ByVal dataType As ParameterType, _
   ByVal state As ParameterState, _
   ByVal nullable As Boolean, _
   ByVal allowBlank As Boolean, _
   ByVal hidden As Boolean, _
   ByVal multiValue As Boolean, _
   ByVal usedInQuery As Boolean, _
   ByVal multiline As Boolean, _
   ByVal dateOnly As Boolean, _
   ByVal orderByCondition As OrderByCondition, _
   ByVal orderByDirection As OrderByDirection, _
   ByVal displayFormat As ExpressionInfo, _
   Optional ByVal report As Report _
) As Parameter
C#
public static Parameter Create(
   string name,
   ExpressionInfo prompt,
   ParameterType dataType,
   ParameterState state,
   bool nullable,
   bool allowBlank,
   bool hidden,
   bool multiValue,
   bool usedInQuery,
   bool multiline,
   bool dateOnly,
   OrderByCondition orderByCondition,
   OrderByDirection orderByDirection,
   ExpressionInfo displayFormat,
   Report report
)

Parameters

name
The parameter name.
prompt
The text to display to a user when prompting the a for the parameter's value.
dataType
The data type of the new parameter.
state
Specifies the state of the new parameter.
nullable
Specifies whether the new parameter is allowed to be Null.
allowBlank
Specifies whether an empty string is a valid value for the new parameter.
hidden
Specifies whether parameter should not be displayed to the user.
multiValue
Specifies whether the new parameter accepts multiple values.
usedInQuery
Specifies whether the new parameter is used in a query.
multiline
Specifies whether the parameter value supposes to be multiline.
dateOnly
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
orderByCondition
Specifies whether the valid values are ordered by labels, values or none for the parameter.
orderByDirection
Specifies whether the valid values are ordered in ascending or descending order for the parameter.
displayFormat
Parameter display format.
report
The report.

Return Value

New Parameter instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members
Overload List


RefreshParameterValues Method

[image]
ActiveReports 19 .NET Edition
RefreshParameterValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : RefreshParameterValues Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RefreshParameterValues()
C#
public void RefreshParameterValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

[image]
ActiveReports 19 .NET Edition
Parameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | AllowBlank | Indicates whether an empty string is a valid value for this parameter.
Public Property | CurrentValue | Gets or sets the current value of the Parameter.
Public Property | DataType | The data type of the parameter.
Public Property | DateOnly | Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Public Property | DefaultValues | The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.
Public Property | DefinesValidValues | Gets whether this parameter has valid values defined in the report definition.
Public Property | DependentParameters | Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.
Public Property | DisplayFormat | Parameter display format.
Public Property | ErrorMessage | Gets the error message associated with this parameter.
Public Property | Hidden | Indicates the parameter should not be displayed to the user.
Public Property | Label | Gets or sets the label of the current value of the Parameter.
Public Property | LabelsArray | Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.
Public Property | Multiline | Indicates whether the parameter value supposes to be multiline.
Public Property | MultiValue | Indicates if this parameter accepts multiple values.
Public Property | Name | Name of the parameter (This name can be used by expressions to refer to this parameter).
Public Property | Nullable | Indicates the value for this parameter is allowed to be Null.
Public Property | OrderByCondition | Gets a condition of the this parameter's valid values order.
Public Property | OrderByDirection | Gets a direction of the this parameter's valid values order.
Public Property | Prompt | The text to display to a user when prompting the a for the parameter's value.
Public Property | PromptUser | Indicates if the user should be prompted for this parameter's value.
Public Property | QueryParameter | Indicates whether the parameter is used in a query.
Public Property | SelectAllValue | If not empty, determines the value which will be passed in parameter value if "Select All" flag was set for multivalue parameter.
Public Property | State | Specifies the current state of this parameter.
Public Property | ValidValues | The ordered list of possible values for this parameter.
Public Property | Values | Gets the Values collection for this parameter. Used for Multivalue parameters.
Public Property | ValuesArray | Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


AllowBlank Property

[image]
ActiveReports 19 .NET Edition
AllowBlank Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : AllowBlank Property

Glossary Item Box

Indicates whether an empty string is a valid value for this parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowBlank As Boolean
C#
public bool AllowBlank {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


CurrentValue Property

[image]
ActiveReports 19 .NET Edition
CurrentValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : CurrentValue Property

Glossary Item Box

Gets or sets the current value of the Parameter.

Syntax

Visual Basic (Declaration)
Public Property CurrentValue As Object
C#
public object CurrentValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DataType Property

[image]
ActiveReports 19 .NET Edition
DataType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DataType Property

Glossary Item Box

The data type of the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataType As ParameterType
C#
public ParameterType DataType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DateOnly Property

[image]
ActiveReports 19 .NET Edition
DateOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DateOnly Property

Glossary Item Box

Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DateOnly As Boolean
C#
public bool DateOnly {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DefaultValues Property

[image]
ActiveReports 19 .NET Edition
DefaultValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DefaultValues Property

Glossary Item Box

The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultValues As ParameterValueCollection
C#
public ParameterValueCollection DefaultValues {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DefinesValidValues Property

[image]
ActiveReports 19 .NET Edition
DefinesValidValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DefinesValidValues Property

Glossary Item Box

Gets whether this parameter has valid values defined in the report definition.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefinesValidValues As Boolean
C#
public bool DefinesValidValues {get;}

Remarks

Can be used to determine if a selection list is needed when populating UI.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DependentParameters Property

[image]
ActiveReports 19 .NET Edition
DependentParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DependentParameters Property

Glossary Item Box

Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentParameters As ParameterCollection
C#
public ParameterCollection DependentParameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


DisplayFormat Property

[image]
ActiveReports 19 .NET Edition
DisplayFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : DisplayFormat Property

Glossary Item Box

Parameter display format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayFormat As String
C#
public string DisplayFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ErrorMessage Property

[image]
ActiveReports 19 .NET Edition
ErrorMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : ErrorMessage Property

Glossary Item Box

Gets the error message associated with this parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorMessage As String
C#
public string ErrorMessage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Hidden Property

Glossary Item Box

Indicates the parameter should not be displayed to the user.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hidden As Boolean
C#
public bool Hidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Label Property

Glossary Item Box

Gets or sets the label of the current value of the Parameter.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


LabelsArray Property

[image]
ActiveReports 19 .NET Edition
LabelsArray Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : LabelsArray Property

Glossary Item Box

Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LabelsArray As String()
C#
public string[] LabelsArray {get;}

Property Value

Returns a string array of all the Values.Label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Multiline Property

[image]
ActiveReports 19 .NET Edition
Multiline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Multiline Property

Glossary Item Box

Indicates whether the parameter value supposes to be multiline.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Multiline As Boolean
C#
public bool Multiline {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


MultiValue Property

[image]
ActiveReports 19 .NET Edition
MultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : MultiValue Property

Glossary Item Box

Indicates if this parameter accepts multiple values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MultiValue As Boolean
C#
public bool MultiValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Name Property

Glossary Item Box

Name of the parameter (This name can be used by expressions to refer to this parameter).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Nullable Property

[image]
ActiveReports 19 .NET Edition
Nullable Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Nullable Property

Glossary Item Box

Indicates the value for this parameter is allowed to be Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nullable As Boolean
C#
public bool Nullable {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


OrderByCondition Property

[image]
ActiveReports 19 .NET Edition
OrderByCondition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : OrderByCondition Property

Glossary Item Box

Gets a condition of the this parameter's valid values order.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderByCondition As OrderByCondition
C#
public OrderByCondition OrderByCondition {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


OrderByDirection Property

[image]
ActiveReports 19 .NET Edition
OrderByDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : OrderByDirection Property

Glossary Item Box

Gets a direction of the this parameter's valid values order.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderByDirection As OrderByDirection
C#
public OrderByDirection OrderByDirection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Prompt Property

Glossary Item Box

The text to display to a user when prompting the a for the parameter's value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prompt As String
C#
public string Prompt {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


PromptUser Property

[image]
ActiveReports 19 .NET Edition
PromptUser Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : PromptUser Property

Glossary Item Box

Indicates if the user should be prompted for this parameter's value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PromptUser As Boolean
C#
public bool PromptUser {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


QueryParameter Property

[image]
ActiveReports 19 .NET Edition
QueryParameter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : QueryParameter Property

Glossary Item Box

Indicates whether the parameter is used in a query.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryParameter As Boolean
C#
public bool QueryParameter {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


SelectAllValue Property

[image]
ActiveReports 19 .NET Edition
SelectAllValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : SelectAllValue Property

Glossary Item Box

If not empty, determines the value which will be passed in parameter value if "Select All" flag was set for multivalue parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectAllValue As ParameterValue
C#
public ParameterValue SelectAllValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


State Property

[image]
ActiveReports 19 .NET Edition
State Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : State Property

Glossary Item Box

Specifies the current state of this parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ParameterState
C#
public ParameterState State {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ValidValues Property

[image]
ActiveReports 19 .NET Edition
ValidValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : ValidValues Property

Glossary Item Box

The ordered list of possible values for this parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValidValues As ParameterValueCollection
C#
public ParameterValueCollection ValidValues {get;}

Remarks

Can be used for populating UI selection lists for users to select a parameter value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : Values Property

Glossary Item Box

Gets the Values collection for this parameter. Used for Multivalue parameters.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ParameterValueCollection
C#
public ParameterValueCollection Values {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ValuesArray Property

[image]
ActiveReports 19 .NET Edition
ValuesArray Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > Parameter Class : ValuesArray Property

Glossary Item Box

Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValuesArray As Object()
C#
public object[] ValuesArray {get;}

Property Value

Returns an object array of all the Values.Value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterCollection Class

Glossary Item Box

A Collection of Parameter objects.

Object Model

ParameterCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterCollection
   Inherits System.Collections.ObjectModel.Collection(Of Parameter)
C#
public sealed class ParameterCollection : System.Collections.ObjectModel.Collection<Parameter>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterCollection Class Members

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor | Initializes a new instance of the ParameterCollection class.
Top

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Overloaded. Gets the Parameter with the given name.
Top

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Returns true if a parameter is in the collection with the specified name.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterCollection Constructor

[image]
ActiveReports 19 .NET Edition
ParameterCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class : ParameterCollection Constructor

Glossary Item Box

Initializes a new instance of the ParameterCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Returns true if a parameter is in the collection with the specified name.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class : Contains Method

Glossary Item Box

Returns true if a parameter is in the collection with the specified name.

Overload List

Overload | Description
Contains(String) | Returns true if a parameter is in the collection with the specified name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains(String) Method

[image]
ActiveReports 19 .NET Edition
Contains(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class > Contains Method : Contains(String) Method

name

Glossary Item Box

Returns true if a parameter is in the collection with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal name As String _
) As Boolean
C#
public bool Contains(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParameterCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Overloaded. Gets the Parameter with the given name.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class : IsReadOnly Property

Glossary Item Box

Gets if the collection is readonly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class : Item Property

Glossary Item Box

Gets the Parameter with the given name.

Overload List

Overload | Description
Item(String) | Gets the Parameter with the given name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterCollection Class > Item Property : Item(String) Property

name
Name of the parameter to return.

Glossary Item Box

Gets the Parameter with the given name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Parameter
C#
public Parameter Item(
   string name
) {get;}

Parameters

name
Name of the parameter to return.

Property Value

The Parameter, otherwise null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParameterValue Class

[image]
ActiveReports 19 .NET Edition
ParameterValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValue Class

Glossary Item Box

Describes a parameter value.

Object Model

ParameterValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterValue
C#
public sealed class ParameterValue

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterValue Class Members

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValue Class

Glossary Item Box

The following tables list the members exposed by ParameterValue.

Public Constructors

 | Name | Description
Public Constructor | ParameterValue Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Label | Label for the value to display in a UI
Public Property | Value | Specifies a value for a parameter.
Top

Public Methods

 | Name | Description
Public Method | Equals | Tests for equivalence between two ParameterValue objects.
Public Method | GetHashCode | Returns the hash code for ParameterValue.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterValue Constructor

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class : ParameterValue Constructor

Glossary Item Box

Overload List

Overload | Description
ParameterValue Constructor() | Creates a new ParameterValue.
ParameterValue Constructor(ParameterValue) | Creates a copy of the ParameterValue parameter.
ParameterValue Constructor(Parameter) | Creates a ParameterValue object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Constructor()

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor()

Glossary Item Box

Creates a new ParameterValue.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterValue()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Constructor(ParameterValue)

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor(ParameterValue)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor(ParameterValue)

p

Glossary Item Box

Creates a copy of the ParameterValue parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As ParameterValue _
)
C#
public ParameterValue(
   ParameterValue p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Constructor(Parameter)

[image]
ActiveReports 19 .NET Edition
ParameterValue Constructor(Parameter)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor(Parameter)

p
Parameter object to initialize with.

Glossary Item Box

Creates a ParameterValue object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As Parameter _
)
C#
public ParameterValue(
   Parameter p
)

Parameters

p
Parameter object to initialize with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValue Class

Glossary Item Box

For a list of all members of this type, see ParameterValue members.

Public Methods

 | Name | Description
Public Method | Equals | Tests for equivalence between two ParameterValue objects.
Public Method | GetHashCode | Returns the hash code for ParameterValue.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class : Equals Method

obj

Glossary Item Box

Tests for equivalence between two ParameterValue objects.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Return Value

True if the objects are equal; otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class : GetHashCode Method

Glossary Item Box

Returns the hash code for ParameterValue.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValue Class

Glossary Item Box

For a list of all members of this type, see ParameterValue members.

Public Properties

 | Name | Description
Public Property | Label | Label for the value to display in a UI
Public Property | Value | Specifies a value for a parameter.
Top

See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class : Label Property

Glossary Item Box

Label for the value to display in a UI

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Remarks

If not supplied, the Value is used as the label. If Value is not supplied, Label is the empty string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValue Class : Value Property

Glossary Item Box

Specifies a value for a parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Remarks

For Boolean parameters, use "true" and "false". For DateTime parameters, use ISO 8601. For Float parameters, use “.” As the optional decimal separator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValueCollection Class

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValueCollection Class

Glossary Item Box

A Collection of ParameterValue objects.

Object Model

ParameterValueCollection Class

Syntax

Visual Basic (Declaration)
Public Class ParameterValueCollection
   Inherits System.Collections.CollectionBase
C#
public class ParameterValueCollection : System.Collections.CollectionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterValueCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterValueCollection Class Members

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValueCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterValueCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterValueCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Gets the ParameterValue by specified index
Top

Public Methods

 | Name | Description
Public Method | Add | Adds ParameterValue item to this collection.
Public Method | AddRange | Adds an array of ParameterValue items to this collection.
Public Method | Clear | Clear the collection.
Public Method | Contains | Determines if a ParameterValue is in this collection.
Public Method | CopyTo | Copies this collection of ParameterValue items to the array.
Public Method | Remove | Removes the ParameterValue from this collection.
Top

See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterValueCollection Constructor

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : ParameterValueCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ParameterValueCollection Constructor() | Creates a new instance of the ParameterValueCollection.
ParameterValueCollection Constructor(Boolean) | Creates a new instance of the ParameterValueCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ParameterValueCollection Constructor()

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class > ParameterValueCollection Constructor : ParameterValueCollection Constructor()

Glossary Item Box

Creates a new instance of the ParameterValueCollection.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ParameterValueCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members
Overload List


ParameterValueCollection Constructor(Boolean)

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Constructor(Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class > ParameterValueCollection Constructor : ParameterValueCollection Constructor(Boolean)

multiValue

Glossary Item Box

Creates a new instance of the ParameterValueCollection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal multiValue As Boolean _
)
C#
public ParameterValueCollection(
   bool multiValue
)

Parameters

multiValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members
Overload List


ParameterValueCollection Class Methods

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValueCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterValueCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds ParameterValue item to this collection.
Public Method | AddRange | Adds an array of ParameterValue items to this collection.
Public Method | Clear | Clear the collection.
Public Method | Contains | Determines if a ParameterValue is in this collection.
Public Method | CopyTo | Copies this collection of ParameterValue items to the array.
Public Method | Remove | Removes the ParameterValue from this collection.
Top

See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : Add Method

item
ParameterValue to add.

Glossary Item Box

Adds ParameterValue item to this collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As ParameterValue _
)
C#
public void Add(
   ParameterValue item
)

Parameters

item
ParameterValue to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


AddRange Method

[image]
ActiveReports 19 .NET Edition
AddRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : AddRange Method

items
Array of ParameterValue items to add.

Glossary Item Box

Adds an array of ParameterValue items to this collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As ParameterValue _
)
C#
public void AddRange(
   ParameterValue[] items
)

Parameters

items
Array of ParameterValue items to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : Clear Method

Glossary Item Box

Clear the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : Contains Method

item
ParameterValue to find.

Glossary Item Box

Determines if a ParameterValue is in this collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ParameterValue _
) As Boolean
C#
public bool Contains(
   ParameterValue item
)

Parameters

item
ParameterValue to find.

Return Value

true if item is in this collection, otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : CopyTo Method

array
destination
arrayIndex
starting point.

Glossary Item Box

Copies this collection of ParameterValue items to the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ParameterValue, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   ParameterValue[] array,
   int arrayIndex
)

Parameters

array
destination
arrayIndex
starting point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : Remove Method

item
the ParameterValue to remove

Glossary Item Box

Removes the ParameterValue from this collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ParameterValue _
)
C#
public void Remove(
   ParameterValue item
)

Parameters

item
the ParameterValue to remove

Return Value

true if successful, otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ParameterValueCollection Class Properties

[image]
ActiveReports 19 .NET Edition
ParameterValueCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValueCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterValueCollection members.

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Gets the ParameterValue by specified index
Top

See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : IsReadOnly Property

Glossary Item Box

Gets if the collection is readonly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ParameterValueCollection Class : Item Property

index
Index of the ParameterValue to return.

Glossary Item Box

Gets the ParameterValue by specified index

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ParameterValue
C#
public ParameterValue this[
   int index
]; {get;}

Parameters

index
Index of the ParameterValue to return.

Property Value

The ParameterValue, otherwise throws exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ReportParameterException Class

[image]
ActiveReports 19 .NET Edition
ReportParameterException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParameterException Class

Glossary Item Box

An exception thrown when an error related to a report's parameter occurs.

Object Model

ReportParameterException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportParameterException
   Inherits System.Exception
C#
public sealed class ReportParameterException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterException Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ReportParameterException Class Members

[image]
ActiveReports 19 .NET Edition
ReportParameterException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParameterException Class

Glossary Item Box

The following tables list the members exposed by ReportParameterException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code.
Top

See Also

Reference

ReportParameterException Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ReportParameterException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportParameterException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParameterException Class

Glossary Item Box

For a list of all members of this type, see ReportParameterException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Error code.
Top

See Also

Reference

ReportParameterException Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ReportParameterException Class : ErrorCode Property

Glossary Item Box

Error code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As ReportParameterException.ErrorCodes
C#
public ReportParameterException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterException Class
ReportParameterException Members


ReportParametersManager Class

[image]
ActiveReports 19 .NET Edition
ReportParametersManager Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParametersManager Class

Glossary Item Box

Manages report parameters.

Object Model

ReportParametersManager Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportParametersManager
   Implements IReportParametersManager
C#
public sealed class ReportParametersManager : IReportParametersManager

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParametersManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersManager Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ReportParametersManager Class Members

[image]
ActiveReports 19 .NET Edition
ReportParametersManager Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParametersManager Class

Glossary Item Box

The following tables list the members exposed by ReportParametersManager.

Public Constructors

 | Name | Description
Public Constructor | ReportParametersManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | Parameters |
Top

Public Methods

 | Name | Description
Public Method | RefreshParameterData | If any parameter values are from a dataset, requery when report is to refresh data.
Public Method | ValidateAndResolveValues | Initializes the parameter collection.
Top

See Also

Reference

ReportParametersManager Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ReportParametersManager Constructor

[image]
ActiveReports 19 .NET Edition
ReportParametersManager Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ReportParametersManager Class : ReportParametersManager Constructor

parameters
getRecordSet
getDataSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameters As ParameterCollection, _
   ByVal getRecordSet As Func(Of IDataSet,IEnumerable(Of Record)), _
   ByVal getDataSet As Func(Of String,IDataSet) _
)
C#
public ReportParametersManager(
   ParameterCollection parameters,
   Func<IDataSet,IEnumerable<Record>> getRecordSet,
   Func<string,IDataSet> getDataSet
)

Parameters

parameters
getRecordSet
getDataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersManager Class
ReportParametersManager Members


ReportParametersManager Class Methods

[image]
ActiveReports 19 .NET Edition
ReportParametersManager Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParametersManager Class

Glossary Item Box

For a list of all members of this type, see ReportParametersManager members.

Public Methods

 | Name | Description
Public Method | RefreshParameterData | If any parameter values are from a dataset, requery when report is to refresh data.
Public Method | ValidateAndResolveValues | Initializes the parameter collection.
Top

See Also

Reference

ReportParametersManager Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


RefreshParameterData Method

[image]
ActiveReports 19 .NET Edition
RefreshParameterData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ReportParametersManager Class : RefreshParameterData Method

Glossary Item Box

If any parameter values are from a dataset, requery when report is to refresh data.

Syntax

Visual Basic (Declaration)
Public Sub RefreshParameterData()
C#
public void RefreshParameterData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersManager Class
ReportParametersManager Members


ValidateAndResolveValues Method

[image]
ActiveReports 19 .NET Edition
ValidateAndResolveValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ReportParametersManager Class : ValidateAndResolveValues Method

Glossary Item Box

Initializes the parameter collection.

Syntax

Visual Basic (Declaration)
Public Sub ValidateAndResolveValues()
C#
public void ValidateAndResolveValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersManager Class
ReportParametersManager Members


ReportParametersManager Class Properties

[image]
ActiveReports 19 .NET Edition
ReportParametersManager Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParametersManager Class

Glossary Item Box

For a list of all members of this type, see ReportParametersManager members.

Public Properties

 | Name | Description
Public Property | Parameters |
Top

See Also

Reference

ReportParametersManager Class
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > ReportParametersManager Class : Parameters Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersManager Class
ReportParametersManager Members


ParameterState Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterState Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterState Enumeration

Glossary Item Box

Specifies the state of a parameter.

Syntax

Visual Basic (Declaration)
Public Enum ParameterState
   Inherits System.Enum
C#
public enum ParameterState : System.Enum

Members

Member | Description
DynamicValuesUnavailable | Indicates that no valid, query-based values were returned as a result of the query used to populate the valid values for the parameter.
HasOutstandingDependencies | Indicates that the valid values for the parameter are dependent upon another parameter's value and the other parameter does not yet have a valid value. Once the other parameter has a valid value, the state of the dependent parameter will change.
HasValidValue | The current value for the parameter is valid.
MissingValidValue | The current value for the parameter is not valid.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterType Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterType Enumeration

Glossary Item Box

Specifies the available data types for a parameter.

Syntax

Visual Basic (Declaration)
Public Enum ParameterType
   Inherits System.Enum
C#
public enum ParameterType : System.Enum

Members

Member | Description
Boolean | Specifies a true or false value.
DateTime | Specifies an ISO 8601 date/time value.
Float | Specifies a floating point number.
Integer | Specifies an integral number.
String | Specifies a textual value.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ParameterValidationError Enumeration

[image]
ActiveReports 19 .NET Edition
ParameterValidationError Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ParameterValidationError Enumeration

Glossary Item Box

Specifies the types of parameter validation errors.

Syntax

Visual Basic (Declaration)
Public Enum ParameterValidationError
   Inherits System.Enum
C#
public enum ParameterValidationError : System.Enum

Members

Member | Description
BlankValueAssignedToNonBlankParameter | Parameters validation error.
InvalidDataTypeForParameter | Parameters validation error.
NoErrors | No errors.
NullValueAssignedToNonNullableParameter | Parameters validation error.
ParameterNotValidated | Parameters was not validated.
ParameterValueIsNotValid | Parameters validation error.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ParameterValidationError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ReportParameterException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
ReportParameterException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : ReportParameterException.ErrorCodes Enumeration

Glossary Item Box

Error codes.

Syntax

Visual Basic (Declaration)
Public Enum ReportParameterException.ErrorCodes
   Inherits System.Enum
C#
public enum ReportParameterException.ErrorCodes : System.Enum

Members

Member | Description
BlankValueAssignedToNonBlankParameter |
CyclicParameter |
InvalidDataTypeForParameter |
NullValueAssignedToNonNullableParameter |
ParameterNotValidated |
ParameterValueIsNotValid |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Core.Rendering.ReportParameters.ReportParameterException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IParameterInfo Interface

[image]
ActiveReports 19 .NET Edition
IParameterInfo Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IParameterInfo Interface

Glossary Item Box

Provides access to report parameter facilities from Parameter instance.

Syntax

Visual Basic (Declaration)
Public Interface IParameterInfo
C#
public interface IParameterInfo

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IParameterInfo Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IParameterInfo Interface Members

[image]
ActiveReports 19 .NET Edition
IParameterInfo Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IParameterInfo Interface

Glossary Item Box

The following tables list the members exposed by IParameterInfo.

Public Methods

 | Name | Description
Method | ResolveParameterValues | Resolves default values and valid values of specified Parameter by queries running or expressions evaluation.
Top

See Also

Reference

IParameterInfo Interface
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IParameterInfo Interface Methods

[image]
ActiveReports 19 .NET Edition
IParameterInfo Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IParameterInfo Interface

Glossary Item Box

For a list of all members of this type, see IParameterInfo members.

Public Methods

 | Name | Description
Method | ResolveParameterValues | Resolves default values and valid values of specified Parameter by queries running or expressions evaluation.
Top

See Also

Reference

IParameterInfo Interface
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


ResolveParameterValues Method

[image]
ActiveReports 19 .NET Edition
ResolveParameterValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > IParameterInfo Interface : ResolveParameterValues Method

parameter

Glossary Item Box

Resolves default values and valid values of specified Parameter by queries running or expressions evaluation.

Syntax

Visual Basic (Declaration)
Sub ResolveParameterValues( _
   ByVal parameter As Parameter _
)
C#
void ResolveParameterValues(
   Parameter parameter
)

Parameters

parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IParameterInfo Interface
IParameterInfo Members


IReportParametersManager Interface

[image]
ActiveReports 19 .NET Edition
IReportParametersManager Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IReportParametersManager Interface

Glossary Item Box

Provides methods for managing report parameters.

Syntax

Visual Basic (Declaration)
Public Interface IReportParametersManager
C#
public interface IReportParametersManager

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportParametersManager Members
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IReportParametersManager Interface Members

[image]
ActiveReports 19 .NET Edition
IReportParametersManager Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IReportParametersManager Interface

Glossary Item Box

The following tables list the members exposed by IReportParametersManager.

Public Properties

 | Name | Description
Property | Parameters | Gets the collection of report parameters.
Top

Public Methods

 | Name | Description
Method | RefreshParameterData | Refreshes the parameter data.
Top

See Also

Reference

IReportParametersManager Interface
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


IReportParametersManager Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportParametersManager Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IReportParametersManager Interface

Glossary Item Box

For a list of all members of this type, see IReportParametersManager members.

Public Methods

 | Name | Description
Method | RefreshParameterData | Refreshes the parameter data.
Top

See Also

Reference

IReportParametersManager Interface
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


RefreshParameterData Method

[image]
ActiveReports 19 .NET Edition
RefreshParameterData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > IReportParametersManager Interface : RefreshParameterData Method

Glossary Item Box

Refreshes the parameter data.

Syntax

Visual Basic (Declaration)
Sub RefreshParameterData()
C#
void RefreshParameterData()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportParametersManager Interface
IReportParametersManager Members


IReportParametersManager Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportParametersManager Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace : IReportParametersManager Interface

Glossary Item Box

For a list of all members of this type, see IReportParametersManager members.

Public Properties

 | Name | Description
Property | Parameters | Gets the collection of report parameters.
Top

See Also

Reference

IReportParametersManager Interface
GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.ReportParameters Namespace > IReportParametersManager Interface : Parameters Property

Glossary Item Box

Gets the collection of report parameters.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parameters As ParameterCollection
C#
ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportParametersManager Interface
IReportParametersManager Members


ObjectExtensions Class

[image]
ActiveReports 19 .NET Edition
ObjectExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ObjectExtensions Class

Glossary Item Box

Provides extension methods for working with objects.

Object Model

ObjectExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ObjectExtensions
C#
public static class ObjectExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Tools.ObjectExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectExtensions Members
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


ObjectExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ObjectExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ObjectExtensions Class

Glossary Item Box

The following tables list the members exposed by ObjectExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsNumber | Determines whether the specified object is a numeric type.
Top

See Also

Reference

ObjectExtensions Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


ObjectExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ObjectExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ObjectExtensions Class

Glossary Item Box

For a list of all members of this type, see ObjectExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsNumber | Determines whether the specified object is a numeric type.
Top

See Also

Reference

ObjectExtensions Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


IsNumber Method

[image]
ActiveReports 19 .NET Edition
IsNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > ObjectExtensions Class : IsNumber Method

value

Glossary Item Box

Determines whether the specified object is a numeric type.

Syntax

Visual Basic (Declaration)
Public Shared Function IsNumber( _
   ByVal value As Object _
) As Boolean
C#
public static bool IsNumber(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectExtensions Class
ObjectExtensions Members


ServiceProviderExtension Class

[image]
ActiveReports 19 .NET Edition
ServiceProviderExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ServiceProviderExtension Class

Glossary Item Box

Extension methods for the System.IServiceProvider.

Object Model

ServiceProviderExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ServiceProviderExtension
C#
public static class ServiceProviderExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Tools.ServiceProviderExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProviderExtension Members
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


ServiceProviderExtension Class Members

[image]
ActiveReports 19 .NET Edition
ServiceProviderExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ServiceProviderExtension Class

Glossary Item Box

The following tables list the members exposed by ServiceProviderExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetService<T> | Get the service of specified type.
Top

See Also

Reference

ServiceProviderExtension Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


ServiceProviderExtension Class Methods

[image]
ActiveReports 19 .NET Edition
ServiceProviderExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : ServiceProviderExtension Class

Glossary Item Box

For a list of all members of this type, see ServiceProviderExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetService<T> | Get the service of specified type.
Top

See Also

Reference

ServiceProviderExtension Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


GetService<T> Method

T
The type of service to get.
[image]
ActiveReports 19 .NET Edition
GetService<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > ServiceProviderExtension Class : GetService<T> Method

provider
The service provider to get from.

Glossary Item Box

Get the service of specified type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetService(Of T As Class)( _
   ByVal provider As IServiceProvider _
) As T
C#
public static T GetService<T>(
   IServiceProvider provider
)
where T: class

Parameters

provider
The service provider to get from.

Type Parameters

T
The type of service to get.

Return Value

The found service of specified type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProviderExtension Class
ServiceProviderExtension Members


StringExtensions Class

[image]
ActiveReports 19 .NET Edition
StringExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : StringExtensions Class

Glossary Item Box

Provides extension methods for working with strings.

Object Model

StringExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class StringExtensions
C#
public static class StringExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Rendering.Tools.StringExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringExtensions Members
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


StringExtensions Class Members

[image]
ActiveReports 19 .NET Edition
StringExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : StringExtensions Class

Glossary Item Box

The following tables list the members exposed by StringExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CssEncode | Encodes a CSS string by replacing apostrophes, quotes, and other characters with \xxx where xxx is the UTF code.
static (Shared in Visual Basic) | GetUnicodeChar | Gets the Unicode character from the string, taking into account high surrogates (characters represented by a 32-bit value).
static (Shared in Visual Basic) | IsIvs | Detects if the IVS characters are encoded at the specified position.
static (Shared in Visual Basic) | SwitchToNativeDigits | Switches the digits in the content to the native digits of the specified language.
Top

See Also

Reference

StringExtensions Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


StringExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
StringExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace : StringExtensions Class

Glossary Item Box

For a list of all members of this type, see StringExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CssEncode | Encodes a CSS string by replacing apostrophes, quotes, and other characters with \xxx where xxx is the UTF code.
static (Shared in Visual Basic) | GetUnicodeChar | Gets the Unicode character from the string, taking into account high surrogates (characters represented by a 32-bit value).
static (Shared in Visual Basic) | IsIvs | Detects if the IVS characters are encoded at the specified position.
static (Shared in Visual Basic) | SwitchToNativeDigits | Switches the digits in the content to the native digits of the specified language.
Top

See Also

Reference

StringExtensions Class
GrapeCity.ActiveReports.Core.Rendering.Tools Namespace


CssEncode Method

[image]
ActiveReports 19 .NET Edition
CssEncode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > StringExtensions Class : CssEncode Method

value
The string to encode.

Glossary Item Box

Encodes a CSS string by replacing apostrophes, quotes, and other characters with \xxx where xxx is the UTF code.

Syntax

Visual Basic (Declaration)
Public Shared Function CssEncode( _
   ByVal value As String _
) As String
C#
public static string CssEncode(
   string value
)

Parameters

value
The string to encode.

Return Value

The encoded string if it contains any symbols that need to be encoded; otherwise, the input string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringExtensions Class
StringExtensions Members


GetUnicodeChar Method

[image]
ActiveReports 19 .NET Edition
GetUnicodeChar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > StringExtensions Class : GetUnicodeChar Method

source
The source string.
i
The index in the source string.

Glossary Item Box

Gets the Unicode character from the string, taking into account high surrogates (characters represented by a 32-bit value).

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnicodeChar( _
   ByVal source As String, _
   ByRef i As Integer _
) As String
C#
public static string GetUnicodeChar(
   string source,
   ref int i
)

Parameters

source
The source string.
i
The index in the source string.

Return Value

The Unicode character as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringExtensions Class
StringExtensions Members


IsIvs Method

[image]
ActiveReports 19 .NET Edition
IsIvs Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > StringExtensions Class : IsIvs Method

text
The text to check.
index
The index in the text.

Glossary Item Box

Detects if the IVS characters are encoded at the specified position.

Syntax

Visual Basic (Declaration)
Public Shared Function IsIvs( _
   ByVal text As String, _
   ByVal index As Integer _
) As Boolean
C#
public static bool IsIvs(
   string text,
   int index
)

Parameters

text
The text to check.
index
The index in the text.

Return Value

true if the IVS characters are encoded at the specified position; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringExtensions Class
StringExtensions Members


SwitchToNativeDigits Method

[image]
ActiveReports 19 .NET Edition
SwitchToNativeDigits Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Core.Rendering.Tools Namespace > StringExtensions Class : SwitchToNativeDigits Method

content
The content to switch.
language
The language LCID (Locale Identifier).

Glossary Item Box

Switches the digits in the content to the native digits of the specified language.

Syntax

Visual Basic (Declaration)
Public Shared Function SwitchToNativeDigits( _
   ByVal content As String, _
   ByVal language As Integer _
) As String
C#
public static string SwitchToNativeDigits(
   string content,
   int language
)

Parameters

content
The content to switch.
language
The language LCID (Locale Identifier).

Return Value

The content with native digits if the language is valid; otherwise, the original content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringExtensions Class
StringExtensions Members


BlendEx Class

[image]
ActiveReports 19 .NET Edition
BlendEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BlendEx Class

Glossary Item Box

Defines a blend pattern for a LinearGradientBrush object. This class cannot be inherited.

Object Model

BlendEx Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BlendEx
C#
public sealed class BlendEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BlendEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Members
GrapeCity.ActiveReports.Drawing Namespace


BlendEx Class Members

[image]
ActiveReports 19 .NET Edition
BlendEx Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BlendEx Class

Glossary Item Box

The following tables list the members exposed by BlendEx.

Public Constructors

 | Name | Description
Public Constructor | BlendEx Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Factors | Gets or sets an array of blend factors for the gradient.
Public Property | Positions | Gets or sets an array of blend positions for the gradient.
Top

See Also

Reference

BlendEx Class
GrapeCity.ActiveReports.Drawing Namespace


BlendEx Constructor

[image]
ActiveReports 19 .NET Edition
BlendEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BlendEx Class : BlendEx Constructor

Glossary Item Box

Overload List

Overload | Description
BlendEx Constructor() | Initializes a new instance of the BlendEx class.
BlendEx Constructor(Int32) | Initializes a new instance of the BlendEx class with the specified number of factors and positions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Class
BlendEx Members


BlendEx Constructor()

[image]
ActiveReports 19 .NET Edition
BlendEx Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BlendEx Class > BlendEx Constructor : BlendEx Constructor()

Glossary Item Box

Initializes a new instance of the BlendEx class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BlendEx()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Class
BlendEx Members
Overload List


BlendEx Constructor(Int32)

[image]
ActiveReports 19 .NET Edition
BlendEx Constructor(Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BlendEx Class > BlendEx Constructor : BlendEx Constructor(Int32)

count
The number of elements in the Factors and Positions arrays.

Glossary Item Box

Initializes a new instance of the BlendEx class with the specified number of factors and positions.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As Integer _
)
C#
public BlendEx(
   int count
)

Parameters

count
The number of elements in the Factors and Positions arrays.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Class
BlendEx Members
Overload List


BlendEx Class Properties

[image]
ActiveReports 19 .NET Edition
BlendEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BlendEx Class

Glossary Item Box

For a list of all members of this type, see BlendEx members.

Public Properties

 | Name | Description
Public Property | Factors | Gets or sets an array of blend factors for the gradient.
Public Property | Positions | Gets or sets an array of blend positions for the gradient.
Top

See Also

Reference

BlendEx Class
GrapeCity.ActiveReports.Drawing Namespace


Factors Property

[image]
ActiveReports 19 .NET Edition
Factors Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BlendEx Class : Factors Property

Glossary Item Box

Gets or sets an array of blend factors for the gradient.

Syntax

Visual Basic (Declaration)
Public Property Factors As Single()
C#
public float[] Factors {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Class
BlendEx Members


Positions Property

[image]
ActiveReports 19 .NET Edition
Positions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BlendEx Class : Positions Property

Glossary Item Box

Gets or sets an array of blend positions for the gradient.

Syntax

Visual Basic (Declaration)
Public Property Positions As Single()
C#
public float[] Positions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BlendEx Class
BlendEx Members


BrushEx Class

[image]
ActiveReports 19 .NET Edition
BrushEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BrushEx Class

Glossary Item Box

Classes derived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.

Object Model

BrushEx Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class BrushEx
C#
public abstract class BrushEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BrushEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaHatchBrush
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaLinearGradientBrush
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaRadialGradientBrush
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaSolidBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrushEx Members
GrapeCity.ActiveReports.Drawing Namespace


BrushEx Class Members

[image]
ActiveReports 19 .NET Edition
BrushEx Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BrushEx Class

Glossary Item Box

The following tables list the members exposed by BrushEx.

Public Methods

 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this BrushEx object.
Public Method | Dispose | Releases all resources used by this BrushEx object.
Top

See Also

Reference

BrushEx Class
GrapeCity.ActiveReports.Drawing Namespace


BrushEx Class Methods

[image]
ActiveReports 19 .NET Edition
BrushEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : BrushEx Class

Glossary Item Box

For a list of all members of this type, see BrushEx members.

Public Methods

 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this BrushEx object.
Public Method | Dispose | Releases all resources used by this BrushEx object.
Top

See Also

Reference

BrushEx Class
GrapeCity.ActiveReports.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BrushEx Class : Clone Method

Glossary Item Box

When overridden in a derived class, creates an exact copy of this BrushEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone() As Object
C#
public abstract object Clone()

Return Value

The new BrushEx object that this method creates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrushEx Class
BrushEx Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > BrushEx Class : Dispose Method

Glossary Item Box

Releases all resources used by this BrushEx object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrushEx Class
BrushEx Members


EvalMessageInfo Class

[image]
ActiveReports 19 .NET Edition
EvalMessageInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : EvalMessageInfo Class

Glossary Item Box

Evaluation message draw settings.

Object Model

EvalMessageInfo Class

Syntax

Visual Basic (Declaration)
Public Class EvalMessageInfo
C#
public class EvalMessageInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.EvalMessageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalMessageInfo Members
GrapeCity.ActiveReports.Drawing Namespace


EvalMessageInfo Class Members

[image]
ActiveReports 19 .NET Edition
EvalMessageInfo Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : EvalMessageInfo Class

Glossary Item Box

The following tables list the members exposed by EvalMessageInfo.

Public Constructors

 | Name | Description
Public Constructor | EvalMessageInfo Constructor |
Top

Public Fields

 | Name | Description
Public Field | IncludePageMargins |
Public Field | Position |
Public Field | Text |
Top

See Also

Reference

EvalMessageInfo Class
GrapeCity.ActiveReports.Drawing Namespace


EvalMessageInfo Constructor

[image]
ActiveReports 19 .NET Edition
EvalMessageInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > EvalMessageInfo Class : EvalMessageInfo Constructor

text
includePageMargins
position

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal includePageMargins As Boolean, _
   ByVal position As EvalPosition _
)
C#
public EvalMessageInfo(
   string text,
   bool includePageMargins,
   EvalPosition position
)

Parameters

text
includePageMargins
position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalMessageInfo Class
EvalMessageInfo Members


EvalMessageInfo Class Fields

[image]
ActiveReports 19 .NET Edition
EvalMessageInfo Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : EvalMessageInfo Class

Glossary Item Box

For a list of all members of this type, see EvalMessageInfo members.

Public Fields

 | Name | Description
Public Field | IncludePageMargins |
Public Field | Position |
Public Field | Text |
Top

See Also

Reference

EvalMessageInfo Class
GrapeCity.ActiveReports.Drawing Namespace


IncludePageMargins Field

[image]
ActiveReports 19 .NET Edition
IncludePageMargins Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > EvalMessageInfo Class : IncludePageMargins Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly IncludePageMargins As Boolean
C#
public readonly bool IncludePageMargins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalMessageInfo Class
EvalMessageInfo Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > EvalMessageInfo Class : Position Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Position As EvalPosition
C#
public readonly EvalPosition Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalMessageInfo Class
EvalMessageInfo Members


Text Field

[image]
ActiveReports 19 .NET Edition
Text Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > EvalMessageInfo Class : Text Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Text As String
C#
public readonly string Text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalMessageInfo Class
EvalMessageInfo Members


FontInfo Class

[image]
ActiveReports 19 .NET Edition
FontInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontInfo Class

Glossary Item Box

Represents font information.

Object Model

FontInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FontInfo
C#
public sealed class FontInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.FontInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Members
GrapeCity.ActiveReports.Drawing Namespace


FontInfo Class Members

[image]
ActiveReports 19 .NET Edition
FontInfo Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontInfo Class

Glossary Item Box

The following tables list the members exposed by FontInfo.

Public Constructors

 | Name | Description
Public Constructor | FontInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Decoration | Gets the font decoration.
Public Field | Family | Gets the font family name.
Public Field | Size | Gets the font size in points.
Public Field | Style | Gets the font style.
Public Field | Weight | Gets the font weight.
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Drawing Namespace


FontInfo Constructor

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : FontInfo Constructor

Glossary Item Box

Overload List

Overload | Description
FontInfo Constructor(String,Single,FontStyle,FontWeight,FontDecoration) | Initializes a new instance of the FontInfo class with specified font family, size, style, weight, and decoration.
FontInfo Constructor(String,Single) | Initializes a new instance of the FontInfo class with specified font family and size.
FontInfo Constructor(String,Single,String,String,String) | Initializes a new instance of the FontInfo class with specified font family, size, style, weight, and decoration as strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Constructor(String,Single,FontStyle,FontWeight,FontDecoration)

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor(String,Single,FontStyle,FontWeight,FontDecoration)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(String,Single,FontStyle,FontWeight,FontDecoration)

familyName
The font family name.
size
The font size in points.
style
The font style.
weight
The font weight.
decoration
The font decoration.

Glossary Item Box

Initializes a new instance of the FontInfo class with specified font family, size, style, weight, and decoration.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal size As Single, _
   ByVal style As FontStyle, _
   ByVal weight As FontWeight, _
   ByVal decoration As FontDecoration _
)
C#
public FontInfo(
   string familyName,
   float size,
   FontStyle style,
   FontWeight weight,
   FontDecoration decoration
)

Parameters

familyName
The font family name.
size
The font size in points.
style
The font style.
weight
The font weight.
decoration
The font decoration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor(String,Single)

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor(String,Single)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(String,Single)

familyName
The font family name.
size
The font size in points.

Glossary Item Box

Initializes a new instance of the FontInfo class with specified font family and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal size As Single _
)
C#
public FontInfo(
   string familyName,
   float size
)

Parameters

familyName
The font family name.
size
The font size in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor(String,Single,String,String,String)

[image]
ActiveReports 19 .NET Edition
FontInfo Constructor(String,Single,String,String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(String,Single,String,String,String)

familyName
The font family name.
size
The font size in points.
style
The font style as a string.
weight
The font weight as a string.
decoration
The font decoration as a string.

Glossary Item Box

Initializes a new instance of the FontInfo class with specified font family, size, style, weight, and decoration as strings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal familyName As String, _
   ByVal size As Single, _
   ByVal style As String, _
   ByVal weight As String, _
   ByVal decoration As String _
)
C#
public FontInfo(
   string familyName,
   float size,
   string style,
   string weight,
   string decoration
)

Parameters

familyName
The font family name.
size
The font size in points.
style
The font style as a string.
weight
The font weight as a string.
decoration
The font decoration as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Class Methods

[image]
ActiveReports 19 .NET Edition
FontInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontInfo Class

Glossary Item Box

For a list of all members of this type, see FontInfo members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Drawing Namespace


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Equals(Object) Method

other

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
C#
public override bool Equals(
   object other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Class Fields

[image]
ActiveReports 19 .NET Edition
FontInfo Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontInfo Class

Glossary Item Box

For a list of all members of this type, see FontInfo members.

Public Fields

 | Name | Description
Public Field | Decoration | Gets the font decoration.
Public Field | Family | Gets the font family name.
Public Field | Size | Gets the font size in points.
Public Field | Style | Gets the font style.
Public Field | Weight | Gets the font weight.
Top

See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Drawing Namespace


Decoration Field

[image]
ActiveReports 19 .NET Edition
Decoration Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Decoration Field

Glossary Item Box

Gets the font decoration.

Syntax

Visual Basic (Declaration)
Public ReadOnly Decoration As FontDecoration
C#
public readonly FontDecoration Decoration

Field Value

The font decoration as a FontDecoration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Family Field

[image]
ActiveReports 19 .NET Edition
Family Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Family Field

Glossary Item Box

Gets the font family name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Family As String
C#
public readonly string Family

Field Value

The font family name as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Size Field

[image]
ActiveReports 19 .NET Edition
Size Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Size Field

Glossary Item Box

Gets the font size in points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Size As Single
C#
public readonly float Size

Field Value

The font size in points as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Style Field

Glossary Item Box

Gets the font style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Style As FontStyle
C#
public readonly FontStyle Style

Field Value

The font style as a FontStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


Weight Field

[image]
ActiveReports 19 .NET Edition
Weight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontInfo Class : Weight Field

Glossary Item Box

Gets the font weight.

Syntax

Visual Basic (Declaration)
Public ReadOnly Weight As FontWeight
C#
public readonly FontWeight Weight

Field Value

The font weight as a FontWeight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontInfo Class
FontInfo Members


FontNameResolverExtensions Class

[image]
ActiveReports 19 .NET Edition
FontNameResolverExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontNameResolverExtensions Class

Glossary Item Box

This class defines extension methods for resolving font names.

Object Model

FontNameResolverExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FontNameResolverExtensions
C#
public static class FontNameResolverExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.FontNameResolverExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontNameResolverExtensions Members
GrapeCity.ActiveReports.Drawing Namespace


FontNameResolverExtensions Class Members

[image]
ActiveReports 19 .NET Edition
FontNameResolverExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontNameResolverExtensions Class

Glossary Item Box

The following tables list the members exposed by FontNameResolverExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ResolveFontName | Resolves the name of the font.
Top

See Also

Reference

FontNameResolverExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


FontNameResolverExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
FontNameResolverExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontNameResolverExtensions Class

Glossary Item Box

For a list of all members of this type, see FontNameResolverExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ResolveFontName | Resolves the name of the font.
Top

See Also

Reference

FontNameResolverExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


ResolveFontName Method

[image]
ActiveReports 19 .NET Edition
ResolveFontName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontNameResolverExtensions Class : ResolveFontName Method

fontNameResolver
sourceName

Glossary Item Box

Resolves the name of the font.

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveFontName( _
   ByVal fontNameResolver As IFontNameResolver, _
   ByVal sourceName As String _
) As String
C#
public static string ResolveFontName(
   IFontNameResolver fontNameResolver,
   string sourceName
)

Parameters

fontNameResolver
sourceName

Return Value

Returns the resolved font name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontNameResolverExtensions Class
FontNameResolverExtensions Members


GradientStopColor Class

[image]
ActiveReports 19 .NET Edition
GradientStopColor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GradientStopColor Class

Glossary Item Box

Object Model

GradientStopColor Class

Syntax

Visual Basic (Declaration)
Public Class GradientStopColor
C#
public class GradientStopColor

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.GradientStopColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GradientStopColor Members
GrapeCity.ActiveReports.Drawing Namespace


GradientStopColor Class Members

[image]
ActiveReports 19 .NET Edition
GradientStopColor Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GradientStopColor Class

Glossary Item Box

The following tables list the members exposed by GradientStopColor.

Public Constructors

 | Name | Description
Public Constructor | GradientStopColor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Offset |
Top

See Also

Reference

GradientStopColor Class
GrapeCity.ActiveReports.Drawing Namespace


GradientStopColor Constructor

[image]
ActiveReports 19 .NET Edition
GradientStopColor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GradientStopColor Class : GradientStopColor Constructor

color
offset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal offset As Single _
)
C#
public GradientStopColor(
   Color color,
   float offset
)

Parameters

color
offset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GradientStopColor Class
GradientStopColor Members


GradientStopColor Class Properties

[image]
ActiveReports 19 .NET Edition
GradientStopColor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GradientStopColor Class

Glossary Item Box

For a list of all members of this type, see GradientStopColor members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Offset |
Top

See Also

Reference

GradientStopColor Class
GrapeCity.ActiveReports.Drawing Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GradientStopColor Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Color As Color
C#
public Color Color {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GradientStopColor Class
GradientStopColor Members


Offset Property

[image]
ActiveReports 19 .NET Edition
Offset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GradientStopColor Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Single
C#
public float Offset {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GradientStopColor Class
GradientStopColor Members


GraphicsRenderContext Class

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsRenderContext Class

Glossary Item Box

Represents the context for rendering graphics.

Object Model

GraphicsRenderContext Class

Syntax

Visual Basic (Declaration)
Public Class GraphicsRenderContext
C#
public class GraphicsRenderContext

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.GraphicsRenderContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Members
GrapeCity.ActiveReports.Drawing Namespace


GraphicsRenderContext Class Members

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsRenderContext Class

Glossary Item Box

The following tables list the members exposed by GraphicsRenderContext.

Public Constructors

 | Name | Description
Public Constructor | GraphicsRenderContext Constructor |
Top

Public Fields

 | Name | Description
Public Field | RenderDynamicallyHidden | If True the dynamically hidden content will be rendered at first. It is necessary when there are one more layer which is responsible for dynamic visibility (for example ReportMetaCanvas)
Top

Public Properties

 | Name | Description
Public Property | BookmarkService | Gets factory.
Public Property | Canvas | The canvas to draw on.
Public Property | DoBackground |
Public Property | DoBorders |
Public Property | DoContent |
Public Property | EvalMessage |
Public Property | MetricsProvider | Gets metrics provider.
Public Property | RenderersFactory | Gets factory.
Public Property | TargetDevice | Specifies GrapeCity.ActiveReports.Extensibility.Layout.ITargetDevice associated with this context
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateInstance |
Top

See Also

Reference

GraphicsRenderContext Class
GrapeCity.ActiveReports.Drawing Namespace


GraphicsRenderContext Constructor

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : GraphicsRenderContext Constructor

device
canvas
metricsProvider
renderersFactory
bookmarkService
evalMessage
doContent
doBackground
doBorders

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal device As ITargetDevice, _
   ByVal canvas As IDrawingCanvas, _
   ByVal metricsProvider As ITextMetricsProvider, _
   ByVal renderersFactory As IRenderersFactory, _
   ByVal bookmarkService As IBookmarkService, _
   Optional ByVal evalMessage As EvalMessageInfo, _
   Optional ByVal doContent As Boolean, _
   Optional ByVal doBackground As Boolean, _
   Optional ByVal doBorders As Boolean _
)
C#
public GraphicsRenderContext(
   ITargetDevice device,
   IDrawingCanvas canvas,
   ITextMetricsProvider metricsProvider,
   IRenderersFactory renderersFactory,
   IBookmarkService bookmarkService,
   EvalMessageInfo evalMessage,
   bool doContent,
   bool doBackground,
   bool doBorders
)

Parameters

device
canvas
metricsProvider
renderersFactory
bookmarkService
evalMessage
doContent
doBackground
doBorders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


GraphicsRenderContext Class Methods

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsRenderContext Class

Glossary Item Box

For a list of all members of this type, see GraphicsRenderContext members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateInstance |
Top

See Also

Reference

GraphicsRenderContext Class
GrapeCity.ActiveReports.Drawing Namespace


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : CreateInstance Method

device
canvas
metricsProvider
renderersFactory
bookmarkService
evalMessage
doContent
doBackground
doBorders
patchCollector

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance( _
   ByVal device As ITargetDevice, _
   ByVal canvas As IDrawingCanvas, _
   ByVal metricsProvider As ITextMetricsProvider, _
   ByVal renderersFactory As IRenderersFactory, _
   ByVal bookmarkService As IBookmarkService, _
   Optional ByVal evalMessage As EvalMessageInfo, _
   Optional ByVal doContent As Boolean, _
   Optional ByVal doBackground As Boolean, _
   Optional ByVal doBorders As Boolean, _
   Optional ByVal patchCollector As IPatchCollector _
) As GraphicsRenderContext
C#
public static GraphicsRenderContext CreateInstance(
   ITargetDevice device,
   IDrawingCanvas canvas,
   ITextMetricsProvider metricsProvider,
   IRenderersFactory renderersFactory,
   IBookmarkService bookmarkService,
   EvalMessageInfo evalMessage,
   bool doContent,
   bool doBackground,
   bool doBorders,
   IPatchCollector patchCollector
)

Parameters

device
canvas
metricsProvider
renderersFactory
bookmarkService
evalMessage
doContent
doBackground
doBorders
patchCollector

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


GraphicsRenderContext Class Properties

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsRenderContext Class

Glossary Item Box

For a list of all members of this type, see GraphicsRenderContext members.

Public Properties

 | Name | Description
Public Property | BookmarkService | Gets factory.
Public Property | Canvas | The canvas to draw on.
Public Property | DoBackground |
Public Property | DoBorders |
Public Property | DoContent |
Public Property | EvalMessage |
Public Property | MetricsProvider | Gets metrics provider.
Public Property | RenderersFactory | Gets factory.
Public Property | TargetDevice | Specifies GrapeCity.ActiveReports.Extensibility.Layout.ITargetDevice associated with this context
Top

See Also

Reference

GraphicsRenderContext Class
GrapeCity.ActiveReports.Drawing Namespace


BookmarkService Property

[image]
ActiveReports 19 .NET Edition
BookmarkService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : BookmarkService Property

Glossary Item Box

Gets factory.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BookmarkService As IBookmarkService
C#
public IBookmarkService BookmarkService {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


Canvas Property

[image]
ActiveReports 19 .NET Edition
Canvas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : Canvas Property

Glossary Item Box

The canvas to draw on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As IDrawingCanvas
C#
public IDrawingCanvas Canvas {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


DoBackground Property

[image]
ActiveReports 19 .NET Edition
DoBackground Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : DoBackground Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoBackground As Boolean
C#
public bool DoBackground {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


DoBorders Property

[image]
ActiveReports 19 .NET Edition
DoBorders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : DoBorders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoBorders As Boolean
C#
public bool DoBorders {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


DoContent Property

[image]
ActiveReports 19 .NET Edition
DoContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : DoContent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoContent As Boolean
C#
public bool DoContent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


EvalMessage Property

[image]
ActiveReports 19 .NET Edition
EvalMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : EvalMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EvalMessage As EvalMessageInfo
C#
public EvalMessageInfo EvalMessage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


MetricsProvider Property

[image]
ActiveReports 19 .NET Edition
MetricsProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : MetricsProvider Property

Glossary Item Box

Gets metrics provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetricsProvider As ITextMetricsProvider
C#
public ITextMetricsProvider MetricsProvider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


RenderersFactory Property

[image]
ActiveReports 19 .NET Edition
RenderersFactory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : RenderersFactory Property

Glossary Item Box

Gets factory.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RenderersFactory As IRenderersFactory
C#
public IRenderersFactory RenderersFactory {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : TargetDevice Property

Glossary Item Box

Specifies GrapeCity.ActiveReports.Extensibility.Layout.ITargetDevice associated with this context

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetDevice As ITargetDevice
C#
public ITargetDevice TargetDevice {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


GraphicsRenderContext Class Fields

[image]
ActiveReports 19 .NET Edition
GraphicsRenderContext Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsRenderContext Class

Glossary Item Box

For a list of all members of this type, see GraphicsRenderContext members.

Public Fields

 | Name | Description
Public Field | RenderDynamicallyHidden | If True the dynamically hidden content will be rendered at first. It is necessary when there are one more layer which is responsible for dynamic visibility (for example ReportMetaCanvas)
Top

See Also

Reference

GraphicsRenderContext Class
GrapeCity.ActiveReports.Drawing Namespace


RenderDynamicallyHidden Field

[image]
ActiveReports 19 .NET Edition
RenderDynamicallyHidden Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > GraphicsRenderContext Class : RenderDynamicallyHidden Field

Glossary Item Box

If True the dynamically hidden content will be rendered at first. It is necessary when there are one more layer which is responsible for dynamic visibility (for example ReportMetaCanvas)

Syntax

Visual Basic (Declaration)
Public RenderDynamicallyHidden As Boolean
C#
public bool RenderDynamicallyHidden

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsRenderContext Class
GraphicsRenderContext Members


ImageEx Class

[image]
ActiveReports 19 .NET Edition
ImageEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ImageEx Class

Glossary Item Box

Classes derived from this abstract base class define objects used to hold images.

Object Model

ImageEx Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ImageEx
C#
public abstract class ImageEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.ImageEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEx Members
GrapeCity.ActiveReports.Drawing Namespace


ImageEx Class Members

[image]
ActiveReports 19 .NET Edition
ImageEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ImageEx Class

Glossary Item Box

The following tables list the members exposed by ImageEx.

Public Properties

 | Name | Description
Public Property | Size | Gets image size in twips.
Top

Public Methods

 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this ImageEx object.
Public Method | Dispose | Releases all resources used by this ImageEx object.
Top

See Also

Reference

ImageEx Class
GrapeCity.ActiveReports.Drawing Namespace


ImageEx Class Methods

[image]
ActiveReports 19 .NET Edition
ImageEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ImageEx Class

Glossary Item Box

For a list of all members of this type, see ImageEx members.

Public Methods

 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this ImageEx object.
Public Method | Dispose | Releases all resources used by this ImageEx object.
Top

See Also

Reference

ImageEx Class
GrapeCity.ActiveReports.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ImageEx Class : Clone Method

Glossary Item Box

When overridden in a derived class, creates an exact copy of this ImageEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone() As Object
C#
public abstract object Clone()

Return Value

The new ImageEx object that this method creates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEx Class
ImageEx Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ImageEx Class : Dispose Method

Glossary Item Box

Releases all resources used by this ImageEx object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEx Class
ImageEx Members


ImageEx Class Properties

[image]
ActiveReports 19 .NET Edition
ImageEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ImageEx Class

Glossary Item Box

For a list of all members of this type, see ImageEx members.

Public Properties

 | Name | Description
Public Property | Size | Gets image size in twips.
Top

See Also

Reference

ImageEx Class
GrapeCity.ActiveReports.Drawing Namespace


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ImageEx Class : Size Property

Glossary Item Box

Gets image size in twips.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Size As SizeF
C#
public abstract SizeF Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEx Class
ImageEx Members


MatrixEx Class

[image]
ActiveReports 19 .NET Edition
MatrixEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : MatrixEx Class

Glossary Item Box

Matrix extensions.

Object Model

MatrixEx Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class MatrixEx
C#
public static class MatrixEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.MatrixEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Members
GrapeCity.ActiveReports.Drawing Namespace


MatrixEx Class Members

[image]
ActiveReports 19 .NET Edition
MatrixEx Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : MatrixEx Class

Glossary Item Box

The following tables list the members exposed by MatrixEx.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Apply | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided System.Drawing.RectangleF.
static (Shared in Visual Basic) | CreateMatrix3x2 | Creates new matrix.
static (Shared in Visual Basic) | GetElements | Gets an array of floating point value representing the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Invert | Inverts the System.Numerics.Matrix3x2 if it can be inverted.
static (Shared in Visual Basic) | Rotate | Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | RotateAt | Applies a clockwise rotation to the System.Numerics.Matrix3x2, around the point specified and by the indicated angle, in the order specified.
static (Shared in Visual Basic) | RotateDeg | Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Scale | Prepends a scale vector to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Transform | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided point.
static (Shared in Visual Basic) | TransformPoints | Overloaded. Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.
static (Shared in Visual Basic) | Translate | Prepends the specified translation vector to the System.Numerics.Matrix3x2.
Top

See Also

Reference

MatrixEx Class
GrapeCity.ActiveReports.Drawing Namespace


MatrixEx Class Methods

[image]
ActiveReports 19 .NET Edition
MatrixEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : MatrixEx Class

Glossary Item Box

For a list of all members of this type, see MatrixEx members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Apply | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided System.Drawing.RectangleF.
static (Shared in Visual Basic) | CreateMatrix3x2 | Creates new matrix.
static (Shared in Visual Basic) | GetElements | Gets an array of floating point value representing the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Invert | Inverts the System.Numerics.Matrix3x2 if it can be inverted.
static (Shared in Visual Basic) | Rotate | Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | RotateAt | Applies a clockwise rotation to the System.Numerics.Matrix3x2, around the point specified and by the indicated angle, in the order specified.
static (Shared in Visual Basic) | RotateDeg | Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Scale | Prepends a scale vector to the System.Numerics.Matrix3x2.
static (Shared in Visual Basic) | Transform | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided point.
static (Shared in Visual Basic) | TransformPoints | Overloaded. Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.
static (Shared in Visual Basic) | Translate | Prepends the specified translation vector to the System.Numerics.Matrix3x2.
Top

See Also

Reference

MatrixEx Class
GrapeCity.ActiveReports.Drawing Namespace


Apply Method

[image]
ActiveReports 19 .NET Edition
Apply Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Apply Method

matrix
rect

Glossary Item Box

Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided System.Drawing.RectangleF.

Syntax

Visual Basic (Declaration)
Public Shared Function Apply( _
   ByVal matrix As Matrix3x2, _
   ByVal rect As RectangleF _
) As RectangleF
C#
public static RectangleF Apply(
   Matrix3x2 matrix,
   RectangleF rect
)

Parameters

matrix
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


CreateMatrix3x2 Method

[image]
ActiveReports 19 .NET Edition
CreateMatrix3x2 Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : CreateMatrix3x2 Method

elems

Glossary Item Box

Creates new matrix.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateMatrix3x2( _
   ByVal elems() As Single _
) As Matrix3x2
C#
public static Matrix3x2 CreateMatrix3x2(
   float[] elems
)

Parameters

elems

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


GetElements Method

[image]
ActiveReports 19 .NET Edition
GetElements Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : GetElements Method

matrix

Glossary Item Box

Gets an array of floating point value representing the System.Numerics.Matrix3x2.

Syntax

Visual Basic (Declaration)
Public Shared Function GetElements( _
   ByVal matrix As Matrix3x2 _
) As Single()
C#
public static float[] GetElements(
   Matrix3x2 matrix
)

Parameters

matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


Invert Method

[image]
ActiveReports 19 .NET Edition
Invert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Invert Method

matrix

Glossary Item Box

Inverts the System.Numerics.Matrix3x2 if it can be inverted.

Syntax

Visual Basic (Declaration)
Public Shared Function Invert( _
   ByVal matrix As Matrix3x2 _
) As Matrix3x2
C#
public static Matrix3x2 Invert(
   Matrix3x2 matrix
)

Parameters

matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


Rotate Method

[image]
ActiveReports 19 .NET Edition
Rotate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Rotate Method

matrix
This Matrix3x2 object.
angle
The angle for the rotation in radians.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Glossary Item Box

Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.

Syntax

Visual Basic (Declaration)
Public Shared Function Rotate( _
   ByVal matrix As Matrix3x2, _
   ByVal angle As Single, _
   Optional ByVal order As MatrixOrderEx _
) As Matrix3x2
C#
public static Matrix3x2 Rotate(
   Matrix3x2 matrix,
   float angle,
   MatrixOrderEx order
)

Parameters

matrix
This Matrix3x2 object.
angle
The angle for the rotation in radians.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


RotateAt Method

[image]
ActiveReports 19 .NET Edition
RotateAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : RotateAt Method

matrix
This Matrix3x2 object.
angle
The angle for the rotation.
point
The point to rotate around.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Glossary Item Box

Applies a clockwise rotation to the System.Numerics.Matrix3x2, around the point specified and by the indicated angle, in the order specified.

Syntax

Visual Basic (Declaration)
Public Shared Function RotateAt( _
   ByVal matrix As Matrix3x2, _
   ByVal angle As Single, _
   ByVal point As Vector2, _
   Optional ByVal order As MatrixOrderEx _
) As Matrix3x2
C#
public static Matrix3x2 RotateAt(
   Matrix3x2 matrix,
   float angle,
   Vector2 point,
   MatrixOrderEx order
)

Parameters

matrix
This Matrix3x2 object.
angle
The angle for the rotation.
point
The point to rotate around.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


RotateDeg Method

[image]
ActiveReports 19 .NET Edition
RotateDeg Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : RotateDeg Method

matrix
This Matrix3x2 object.
angle
The angle for the rotation in degrees.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Glossary Item Box

Applies a clockwise rotation, around the origin and by the indicated angle, to the System.Numerics.Matrix3x2.

Syntax

Visual Basic (Declaration)
Public Shared Function RotateDeg( _
   ByVal matrix As Matrix3x2, _
   ByVal angle As Single, _
   Optional ByVal order As MatrixOrderEx _
) As Matrix3x2
C#
public static Matrix3x2 RotateDeg(
   Matrix3x2 matrix,
   float angle,
   MatrixOrderEx order
)

Parameters

matrix
This Matrix3x2 object.
angle
The angle for the rotation in degrees.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


Scale Method

[image]
ActiveReports 19 .NET Edition
Scale Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Scale Method

matrix
This Matrix3x2 object.
scaleX
The scaled amount on the x-axis.
scaleY
The scaled mount on the y-axis.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Glossary Item Box

Prepends a scale vector to the System.Numerics.Matrix3x2.

Syntax

Visual Basic (Declaration)
Public Shared Function Scale( _
   ByVal matrix As Matrix3x2, _
   ByVal scaleX As Single, _
   ByVal scaleY As Single, _
   Optional ByVal order As MatrixOrderEx _
) As Matrix3x2
C#
public static Matrix3x2 Scale(
   Matrix3x2 matrix,
   float scaleX,
   float scaleY,
   MatrixOrderEx order
)

Parameters

matrix
This Matrix3x2 object.
scaleX
The scaled amount on the x-axis.
scaleY
The scaled mount on the y-axis.
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


Transform Method

[image]
ActiveReports 19 .NET Edition
Transform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Transform Method

matrix
position

Glossary Item Box

Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided point.

Syntax

Visual Basic (Declaration)
Public Shared Function Transform( _
   ByVal matrix As Matrix3x2, _
   ByVal position As PointF _
) As PointF
C#
public static PointF Transform(
   Matrix3x2 matrix,
   PointF position
)

Parameters

matrix
position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


TransformPoints Method

[image]
ActiveReports 19 .NET Edition
TransformPoints Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : TransformPoints Method

Glossary Item Box

Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.

Overload List

Overload | Description
TransformPoints(Matrix3x2,PointF[]) | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.
TransformPoints(Matrix3x2,Vector2[]) | Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


TransformPoints(Matrix3x2,PointF[]) Method

[image]
ActiveReports 19 .NET Edition
TransformPoints(Matrix3x2,PointF[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class > TransformPoints Method : TransformPoints(Matrix3x2,PointF[]) Method

matrix
Transformation matrix.
points
An array of points to transform.

Glossary Item Box

Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub TransformPoints( _
   ByVal matrix As Matrix3x2, _
   ByVal points() As PointF _
)
C#
public static void TransformPoints(
   Matrix3x2 matrix,
   PointF[] points
)

Parameters

matrix
Transformation matrix.
points
An array of points to transform.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


TransformPoints(Matrix3x2,Vector2[]) Method

[image]
ActiveReports 19 .NET Edition
TransformPoints(Matrix3x2,Vector2[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class > TransformPoints Method : TransformPoints(Matrix3x2,Vector2[]) Method

matrix
Transformation matrix.
points
An array of points to transform.

Glossary Item Box

Applies a geometric transform represented by the System.Numerics.Matrix3x2 to the provided points.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub TransformPoints( _
   ByVal matrix As Matrix3x2, _
   ByVal points() As Vector2 _
)
C#
public static void TransformPoints(
   Matrix3x2 matrix,
   Vector2[] points
)

Parameters

matrix
Transformation matrix.
points
An array of points to transform.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


Translate Method

[image]
ActiveReports 19 .NET Edition
Translate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > MatrixEx Class : Translate Method

matrix
The matrix to prepend the translation to
offsetX
the translation X value to use
offsetY
the translation Y value to use
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Glossary Item Box

Prepends the specified translation vector to the System.Numerics.Matrix3x2.

Syntax

Visual Basic (Declaration)
Public Shared Function Translate( _
   ByVal matrix As Matrix3x2, _
   ByVal offsetX As Single, _
   ByVal offsetY As Single, _
   Optional ByVal order As MatrixOrderEx _
) As Matrix3x2
C#
public static Matrix3x2 Translate(
   Matrix3x2 matrix,
   float offsetX,
   float offsetY,
   MatrixOrderEx order
)

Parameters

matrix
The matrix to prepend the translation to
offsetX
the translation X value to use
offsetY
the translation Y value to use
order
A MatrixOrderEx indicating the order in which the rotation should be applied

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixEx Class
MatrixEx Members


PathBuilder Class

[image]
ActiveReports 19 .NET Edition
PathBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathBuilder Class

Glossary Item Box

Helper class to build PathEx objects from SVG-like path data.

Object Model

PathBuilder Class

Syntax

Visual Basic (Declaration)
Public Class PathBuilder
C#
public class PathBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.PathBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathBuilder Members
GrapeCity.ActiveReports.Drawing Namespace


PathBuilder Class Members

[image]
ActiveReports 19 .NET Edition
PathBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathBuilder Class

Glossary Item Box

The following tables list the members exposed by PathBuilder.

Public Constructors

 | Name | Description
Public Constructor | PathBuilder Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromString | Creates path form svg-like path data.
Top

See Also

Reference

PathBuilder Class
GrapeCity.ActiveReports.Drawing Namespace


PathBuilder Constructor

[image]
ActiveReports 19 .NET Edition
PathBuilder Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathBuilder Class : PathBuilder Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PathBuilder()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathBuilder Class
PathBuilder Members


PathBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
PathBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathBuilder Class

Glossary Item Box

For a list of all members of this type, see PathBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromString | Creates path form svg-like path data.
Top

See Also

Reference

PathBuilder Class
GrapeCity.ActiveReports.Drawing Namespace


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathBuilder Class : FromString Method

data
transform

Glossary Item Box

Creates path form svg-like path data.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal data As String, _
   Optional ByVal transform As String _
) As PathEx
C#
public static PathEx FromString(
   string data,
   string transform
)

Parameters

data
transform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathBuilder Class
PathBuilder Members


PathEx Class

[image]
ActiveReports 19 .NET Edition
PathEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx Class

Glossary Item Box

Path implementation.

Object Model

PathEx Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PathEx
C#
public sealed class PathEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.PathEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Members
GrapeCity.ActiveReports.Drawing Namespace


PathEx Class Members

[image]
ActiveReports 19 .NET Edition
PathEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx Class

Glossary Item Box

The following tables list the members exposed by PathEx.

Public Constructors

 | Name | Description
Public Constructor | PathEx Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | FillMode |
Public Property | IsEmpty |
Public Property | PathPoints | Gets current path points.
Public Property | Segments | Gets internal path representation.
Top

Public Methods

 | Name | Description
Public Method | AddArc | Overloaded. Adds arc.
Public Method | AddBeziers | Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).
Public Method | AddCurve | Adds spline curve.
Public Method | AddEllipse | Adds ellipse to rectangle.
Public Method | AddLine | Adds line from point to point.
Public Method | AddLines | Adds polyline.
Public Method | AddLineTo | Adds line from last point to point.
Public Method | AddPath | Overloaded. Appends path.
Public Method | AddPolygon | Adds polygon.
Public Method | AddRectangle | Adds rectangle and closes the figure.
Public Method | Clone |
Public Method | CloseAllFigures | Closes all figures in current path.
Public Method | CloseFigure | Closes only last figure.
Public Method | Flatten | Overloaded. Break beziers to lines.
Public Method | GetBounds | Evaluates the bounds of the figure specified by the given path.
Public Method | IsVisible | Contains point implementation.
Public Method | Reverse | Reverses the order of points in the path.
Public Method | StartFigure | Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.
Public Method | ToString |
Public Method | Transform | Applies transformation.
Public Method | Translate | Translates the path by the given offset.
Public Method | Widen |
Top

See Also

Reference

PathEx Class
GrapeCity.ActiveReports.Drawing Namespace


PathEx Constructor

[image]
ActiveReports 19 .NET Edition
PathEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : PathEx Constructor

Glossary Item Box

Overload List

Overload | Description
PathEx Constructor() |
PathEx Constructor(IEnumerable<Segment>,FillModeEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


PathEx Constructor()

[image]
ActiveReports 19 .NET Edition
PathEx Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > PathEx Constructor : PathEx Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PathEx()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


PathEx Constructor(IEnumerable<Segment>,FillModeEx)

[image]
ActiveReports 19 .NET Edition
PathEx Constructor(IEnumerable<Segment>,FillModeEx)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > PathEx Constructor : PathEx Constructor(IEnumerable<Segment>,FillModeEx)

gpath
fillMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gpath As IEnumerable(Of PathEx.Segment), _
   ByVal fillMode As FillModeEx _
)
C#
public PathEx(
   IEnumerable<PathEx.Segment> gpath,
   FillModeEx fillMode
)

Parameters

gpath
fillMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


PathEx Class Methods

[image]
ActiveReports 19 .NET Edition
PathEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx Class

Glossary Item Box

For a list of all members of this type, see PathEx members.

Public Methods

 | Name | Description
Public Method | AddArc | Overloaded. Adds arc.
Public Method | AddBeziers | Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).
Public Method | AddCurve | Adds spline curve.
Public Method | AddEllipse | Adds ellipse to rectangle.
Public Method | AddLine | Adds line from point to point.
Public Method | AddLines | Adds polyline.
Public Method | AddLineTo | Adds line from last point to point.
Public Method | AddPath | Overloaded. Appends path.
Public Method | AddPolygon | Adds polygon.
Public Method | AddRectangle | Adds rectangle and closes the figure.
Public Method | Clone |
Public Method | CloseAllFigures | Closes all figures in current path.
Public Method | CloseFigure | Closes only last figure.
Public Method | Flatten | Overloaded. Break beziers to lines.
Public Method | GetBounds | Evaluates the bounds of the figure specified by the given path.
Public Method | IsVisible | Contains point implementation.
Public Method | Reverse | Reverses the order of points in the path.
Public Method | StartFigure | Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.
Public Method | ToString |
Public Method | Transform | Applies transformation.
Public Method | Translate | Translates the path by the given offset.
Public Method | Widen |
Top

See Also

Reference

PathEx Class
GrapeCity.ActiveReports.Drawing Namespace


AddArc Method

[image]
ActiveReports 19 .NET Edition
AddArc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddArc Method

Glossary Item Box

Adds arc.

Overload List

Overload | Description
AddArc(RectangleF,Single,Single) | Adds arc.
AddArc(Single,Single,Single,Single,Single,Single) | Adds arc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddArc(RectangleF,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
AddArc(RectangleF,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > AddArc Method : AddArc(RectangleF,Single,Single) Method

rect
startAngle
sweepAngle

Glossary Item Box

Adds arc.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddArc( _
   ByVal rect As RectangleF, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
C#
public void AddArc(
   RectangleF rect,
   float startAngle,
   float sweepAngle
)

Parameters

rect
startAngle
sweepAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


AddArc(Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
AddArc(Single,Single,Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > AddArc Method : AddArc(Single,Single,Single,Single,Single,Single) Method

x
y
width
height
startAngle
sweepAngle

Glossary Item Box

Adds arc.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddArc( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal startAngle As Single, _
   ByVal sweepAngle As Single _
)
C#
public void AddArc(
   float x,
   float y,
   float width,
   float height,
   float startAngle,
   float sweepAngle
)

Parameters

x
y
width
height
startAngle
sweepAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


AddBeziers Method

[image]
ActiveReports 19 .NET Edition
AddBeziers Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddBeziers Method

points

Glossary Item Box

Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).

Syntax

Visual Basic (Declaration)
Public Sub AddBeziers( _
   ByVal points() As Vector2 _
)
C#
public void AddBeziers(
   Vector2[] points
)

Parameters

points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddCurve Method

[image]
ActiveReports 19 .NET Edition
AddCurve Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddCurve Method

points
tension

Glossary Item Box

Adds spline curve.

Syntax

Visual Basic (Declaration)
Public Sub AddCurve( _
   ByVal points() As Vector2, _
   ByVal tension As Single _
)
C#
public void AddCurve(
   Vector2[] points,
   float tension
)

Parameters

points
tension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddEllipse(Single,Single,Single,Single) Method

[image]
ActiveReports 19 .NET Edition
AddEllipse(Single,Single,Single,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddEllipse(Single,Single,Single,Single) Method

x
y
width
height

Glossary Item Box

Adds ellipse to rectangle.

Syntax

Visual Basic (Declaration)
Public Sub AddEllipse( _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void AddEllipse(
   float x,
   float y,
   float width,
   float height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddLine Method

[image]
ActiveReports 19 .NET Edition
AddLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddLine Method

point1
point2

Glossary Item Box

Adds line from point to point.

Syntax

Visual Basic (Declaration)
Public Sub AddLine( _
   ByVal point1 As Vector2, _
   ByVal point2 As Vector2 _
)
C#
public void AddLine(
   Vector2 point1,
   Vector2 point2
)

Parameters

point1
point2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddLines Method

[image]
ActiveReports 19 .NET Edition
AddLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddLines Method

linePoints

Glossary Item Box

Adds polyline.

Syntax

Visual Basic (Declaration)
Public Sub AddLines( _
   ByVal linePoints() As Vector2 _
)
C#
public void AddLines(
   Vector2[] linePoints
)

Parameters

linePoints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddLineTo Method

[image]
ActiveReports 19 .NET Edition
AddLineTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddLineTo Method

point

Glossary Item Box

Adds line from last point to point.

Syntax

Visual Basic (Declaration)
Public Sub AddLineTo( _
   ByVal point As Vector2 _
)
C#
public void AddLineTo(
   Vector2 point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddPath Method

[image]
ActiveReports 19 .NET Edition
AddPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddPath Method

Glossary Item Box

Appends path.

Overload List

Overload | Description
AddPath(PathEx) | Appends path.
AddPath(PathEx,Boolean) | Appends path.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddPath(PathEx) Method

[image]
ActiveReports 19 .NET Edition
AddPath(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > AddPath Method : AddPath(PathEx) Method

graphicsPath

Glossary Item Box

Appends path.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddPath( _
   ByVal graphicsPath As PathEx _
)
C#
public void AddPath(
   PathEx graphicsPath
)

Parameters

graphicsPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


AddPath(PathEx,Boolean) Method

[image]
ActiveReports 19 .NET Edition
AddPath(PathEx,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > AddPath Method : AddPath(PathEx,Boolean) Method

graphicsPath
connected

Glossary Item Box

Appends path.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddPath( _
   ByVal graphicsPath As PathEx, _
   ByVal connected As Boolean _
)
C#
public void AddPath(
   PathEx graphicsPath,
   bool connected
)

Parameters

graphicsPath
connected

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


AddPolygon Method

[image]
ActiveReports 19 .NET Edition
AddPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddPolygon Method

pointData

Glossary Item Box

Adds polygon.

Syntax

Visual Basic (Declaration)
Public Sub AddPolygon( _
   ByVal pointData() As Vector2 _
)
C#
public void AddPolygon(
   Vector2[] pointData
)

Parameters

pointData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


AddRectangle Method

[image]
ActiveReports 19 .NET Edition
AddRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : AddRectangle Method

rectangle

Glossary Item Box

Adds rectangle and closes the figure.

Syntax

Visual Basic (Declaration)
Public Sub AddRectangle( _
   ByVal rectangle As RectangleF _
)
C#
public void AddRectangle(
   RectangleF rectangle
)

Parameters

rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As PathEx
C#
public PathEx Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


CloseAllFigures Method

[image]
ActiveReports 19 .NET Edition
CloseAllFigures Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : CloseAllFigures Method

Glossary Item Box

Closes all figures in current path.

Syntax

Visual Basic (Declaration)
Public Sub CloseAllFigures()
C#
public void CloseAllFigures()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


CloseFigure Method

[image]
ActiveReports 19 .NET Edition
CloseFigure Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : CloseFigure Method

Glossary Item Box

Closes only last figure.

Syntax

Visual Basic (Declaration)
Public Sub CloseFigure()
C#
public void CloseFigure()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Flatten Method

[image]
ActiveReports 19 .NET Edition
Flatten Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Flatten Method

Glossary Item Box

Break beziers to lines.

Overload List

Overload | Description
Flatten(Single) | Break beziers to lines.
Flatten(Int32) | Break beziers to lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Flatten(Single) Method

[image]
ActiveReports 19 .NET Edition
Flatten(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > Flatten Method : Flatten(Single) Method

flatness
Distance tolerance.

Glossary Item Box

Break beziers to lines.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Flatten( _
   ByVal flatness As Single _
)
C#
public void Flatten(
   float flatness
)

Parameters

flatness
Distance tolerance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


Flatten(Int32) Method

[image]
ActiveReports 19 .NET Edition
Flatten(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class > Flatten Method : Flatten(Int32) Method

segmentsCount
Count of segments to break bezier.

Glossary Item Box

Break beziers to lines.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Flatten( _
   ByVal segmentsCount As Integer _
)
C#
public void Flatten(
   int segmentsCount
)

Parameters

segmentsCount
Count of segments to break bezier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members
Overload List


GetBounds Method

[image]
ActiveReports 19 .NET Edition
GetBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : GetBounds Method

Glossary Item Box

Evaluates the bounds of the figure specified by the given path.

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As RectangleF
C#
public RectangleF GetBounds()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : IsVisible Method

point

Glossary Item Box

Contains point implementation.

Syntax

Visual Basic (Declaration)
Public Function IsVisible( _
   ByVal point As Vector2 _
) As Boolean
C#
public bool IsVisible(
   Vector2 point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Reverse Method

[image]
ActiveReports 19 .NET Edition
Reverse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Reverse Method

Glossary Item Box

Reverses the order of points in the path.

Syntax

Visual Basic (Declaration)
Public Sub Reverse()
C#
public void Reverse()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


StartFigure Method

[image]
ActiveReports 19 .NET Edition
StartFigure Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : StartFigure Method

Glossary Item Box

Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.

Syntax

Visual Basic (Declaration)
Public Sub StartFigure()
C#
public void StartFigure()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Transform Method

[image]
ActiveReports 19 .NET Edition
Transform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Transform Method

matrix

Glossary Item Box

Applies transformation.

Syntax

Visual Basic (Declaration)
Public Sub Transform( _
   ByVal matrix As Matrix3x2 _
)
C#
public void Transform(
   Matrix3x2 matrix
)

Parameters

matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Translate Method

[image]
ActiveReports 19 .NET Edition
Translate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Translate Method

x
y

Glossary Item Box

Translates the path by the given offset.

Syntax

Visual Basic (Declaration)
Public Sub Translate( _
   ByVal x As Single, _
   ByVal y As Single _
)
C#
public void Translate(
   float x,
   float y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Widen Method

[image]
ActiveReports 19 .NET Edition
Widen Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Widen Method

width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Widen( _
   ByVal width As Single _
)
C#
public void Widen(
   float width
)

Parameters

width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


PathEx Class Properties

[image]
ActiveReports 19 .NET Edition
PathEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx Class

Glossary Item Box

For a list of all members of this type, see PathEx members.

Public Properties

 | Name | Description
Public Property | FillMode |
Public Property | IsEmpty |
Public Property | PathPoints | Gets current path points.
Public Property | Segments | Gets internal path representation.
Top

See Also

Reference

PathEx Class
GrapeCity.ActiveReports.Drawing Namespace


FillMode Property

[image]
ActiveReports 19 .NET Edition
FillMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : FillMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FillMode As FillModeEx
C#
public FillModeEx FillMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : IsEmpty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


PathPoints Property

[image]
ActiveReports 19 .NET Edition
PathPoints Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : PathPoints Property

Glossary Item Box

Gets current path points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PathPoints As Vector2()
C#
public Vector2[] PathPoints {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


Segments Property

[image]
ActiveReports 19 .NET Edition
Segments Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx Class : Segments Property

Glossary Item Box

Gets internal path representation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segments As IReadOnlyCollection(Of PathEx.Segment)
C#
public IReadOnlyCollection<PathEx.Segment> Segments {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx Class
PathEx Members


PathExtensions Class

[image]
ActiveReports 19 .NET Edition
PathExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathExtensions Class

Glossary Item Box

Represents an extension methods for PathEx class.

Object Model

PathExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PathExtensions
C#
public static class PathExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.PathExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Members
GrapeCity.ActiveReports.Drawing Namespace


PathExtensions Class Members

[image]
ActiveReports 19 .NET Edition
PathExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathExtensions Class

Glossary Item Box

The following tables list the members exposed by PathExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddBeziers | Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).
static (Shared in Visual Basic) | AddCurve | Adds spline curve.
static (Shared in Visual Basic) | AddLine |
static (Shared in Visual Basic) | AddLines |
static (Shared in Visual Basic) | AddLineTo |
static (Shared in Visual Basic) | AddPolygon |
static (Shared in Visual Basic) | IsVisible |
static (Shared in Visual Basic) | ToPoint |
static (Shared in Visual Basic) | ToPoints |
static (Shared in Visual Basic) | ToVector |
static (Shared in Visual Basic) | ToVectors |
Top

See Also

Reference

PathExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


PathExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
PathExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathExtensions Class

Glossary Item Box

For a list of all members of this type, see PathExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddBeziers | Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).
static (Shared in Visual Basic) | AddCurve | Adds spline curve.
static (Shared in Visual Basic) | AddLine |
static (Shared in Visual Basic) | AddLines |
static (Shared in Visual Basic) | AddLineTo |
static (Shared in Visual Basic) | AddPolygon |
static (Shared in Visual Basic) | IsVisible |
static (Shared in Visual Basic) | ToPoint |
static (Shared in Visual Basic) | ToPoints |
static (Shared in Visual Basic) | ToVector |
static (Shared in Visual Basic) | ToVectors |
Top

See Also

Reference

PathExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


AddBeziers Method

[image]
ActiveReports 19 .NET Edition
AddBeziers Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddBeziers Method

path
points

Glossary Item Box

Adds curve as already calculated beziers (start, control, control, end-start, control, control, end-start ...).

Syntax

Visual Basic (Declaration)
Public Shared Sub AddBeziers( _
   ByVal path As PathEx, _
   ByVal points() As PointF _
)
C#
public static void AddBeziers(
   PathEx path,
   PointF[] points
)

Parameters

path
points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


AddCurve Method

[image]
ActiveReports 19 .NET Edition
AddCurve Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddCurve Method

path
points
tension

Glossary Item Box

Adds spline curve.

Syntax

Visual Basic (Declaration)
Public Shared Sub AddCurve( _
   ByVal path As PathEx, _
   ByVal points() As PointF, _
   ByVal tension As Single _
)
C#
public static void AddCurve(
   PathEx path,
   PointF[] points,
   float tension
)

Parameters

path
points
tension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


AddLine Method

[image]
ActiveReports 19 .NET Edition
AddLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddLine Method

path
point1
point2

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub AddLine( _
   ByVal path As PathEx, _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
)
C#
public static void AddLine(
   PathEx path,
   PointF point1,
   PointF point2
)

Parameters

path
point1
point2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


AddLines Method

[image]
ActiveReports 19 .NET Edition
AddLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddLines Method

path
linePoints

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub AddLines( _
   ByVal path As PathEx, _
   ByVal linePoints() As PointF _
)
C#
public static void AddLines(
   PathEx path,
   PointF[] linePoints
)

Parameters

path
linePoints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


AddLineTo Method

[image]
ActiveReports 19 .NET Edition
AddLineTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddLineTo Method

path
point

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub AddLineTo( _
   ByVal path As PathEx, _
   ByVal point As PointF _
)
C#
public static void AddLineTo(
   PathEx path,
   PointF point
)

Parameters

path
point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


AddPolygon Method

[image]
ActiveReports 19 .NET Edition
AddPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : AddPolygon Method

path
pointData

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub AddPolygon( _
   ByVal path As PathEx, _
   ByVal pointData() As PointF _
)
C#
public static void AddPolygon(
   PathEx path,
   PointF[] pointData
)

Parameters

path
pointData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : IsVisible Method

path
pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function IsVisible( _
   ByVal path As PathEx, _
   ByVal pt As PointF _
) As Boolean
C#
public static bool IsVisible(
   PathEx path,
   PointF pt
)

Parameters

path
pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


ToPoint Method

[image]
ActiveReports 19 .NET Edition
ToPoint Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : ToPoint Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ToPoint( _
   ByVal pt As Vector2 _
) As PointF
C#
public static PointF ToPoint(
   Vector2 pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


ToPoints Method

[image]
ActiveReports 19 .NET Edition
ToPoints Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : ToPoints Method

pts

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ToPoints( _
   ByVal pts() As Vector2 _
) As PointF()
C#
public static PointF[] ToPoints(
   Vector2[] pts
)

Parameters

pts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


ToVector Method

[image]
ActiveReports 19 .NET Edition
ToVector Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : ToVector Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ToVector( _
   ByVal pt As PointF _
) As Vector2
C#
public static Vector2 ToVector(
   PointF pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


ToVectors Method

[image]
ActiveReports 19 .NET Edition
ToVectors Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathExtensions Class : ToVectors Method

pts

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ToVectors( _
   ByVal pts() As PointF _
) As Vector2()
C#
public static Vector2[] ToVectors(
   PointF[] pts
)

Parameters

pts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathExtensions Class
PathExtensions Members


PenEx Class

[image]
ActiveReports 19 .NET Edition
PenEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenEx Class

Glossary Item Box

Defines an object used to draw lines and curves. This class is abstract.

Object Model

PenEx Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PenEx
C#
public abstract class PenEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.PenEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaPen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Members
GrapeCity.ActiveReports.Drawing Namespace


PenEx Class Members

[image]
ActiveReports 19 .NET Edition
PenEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenEx Class

Glossary Item Box

The following tables list the members exposed by PenEx.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment for this PenEx object.
Public Property | Color | Gets or sets the color of this PenEx object.
Public Property | DashCap | Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces used for dashed lines drawn with this PenEx object.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this PenEx object.
Public Property | EndCap | Gets or sets the cap style used at the end of lines drawn with this PenEx object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
Public Property | StartCap | Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.
Public Property | Width | Gets or sets the width of this PenEx object.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this PenEx object.
Public Method | Dispose | Releases resources.
Top

See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Drawing Namespace


PenEx Class Methods

[image]
ActiveReports 19 .NET Edition
PenEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenEx Class

Glossary Item Box

For a list of all members of this type, see PenEx members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this PenEx object.
Public Method | Dispose | Releases resources.
Top

See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : Clone Method

Glossary Item Box

Creates an exact copy of this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone() As Object
C#
public abstract object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : Dispose Method

Glossary Item Box

Releases resources.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
C#
public virtual void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


PenEx Class Properties

[image]
ActiveReports 19 .NET Edition
PenEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenEx Class

Glossary Item Box

For a list of all members of this type, see PenEx members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment for this PenEx object.
Public Property | Color | Gets or sets the color of this PenEx object.
Public Property | DashCap | Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces used for dashed lines drawn with this PenEx object.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this PenEx object.
Public Property | EndCap | Gets or sets the cap style used at the end of lines drawn with this PenEx object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
Public Property | StartCap | Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.
Public Property | Width | Gets or sets the width of this PenEx object.
Top

See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Drawing Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : Alignment Property

Glossary Item Box

Gets or sets the alignment for this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property Alignment As PenAlignment
C#
public abstract PenAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : Color Property

Glossary Item Box

Gets or sets the color of this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property Color As Color
C#
public abstract Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


DashCap Property

[image]
ActiveReports 19 .NET Edition
DashCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : DashCap Property

Glossary Item Box

Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property DashCap As DashCap
C#
public abstract DashCap DashCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


DashPattern Property

[image]
ActiveReports 19 .NET Edition
DashPattern Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : DashPattern Property

Glossary Item Box

Gets or sets an array of custom dashes and spaces used for dashed lines drawn with this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property DashPattern As Single()
C#
public abstract float[] DashPattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


DashStyle Property

[image]
ActiveReports 19 .NET Edition
DashStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : DashStyle Property

Glossary Item Box

Gets or sets the style used for dashed lines drawn with this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property DashStyle As PenStyleEx
C#
public abstract PenStyleEx DashStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


EndCap Property

[image]
ActiveReports 19 .NET Edition
EndCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : EndCap Property

Glossary Item Box

Gets or sets the cap style used at the end of lines drawn with this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property EndCap As LineCap
C#
public abstract LineCap EndCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


LineJoin Property

[image]
ActiveReports 19 .NET Edition
LineJoin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : LineJoin Property

Glossary Item Box

Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.

Syntax

Visual Basic (Declaration)
Public MustOverride Property LineJoin As LineJoin
C#
public abstract LineJoin LineJoin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


StartCap Property

[image]
ActiveReports 19 .NET Edition
StartCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : StartCap Property

Glossary Item Box

Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property StartCap As LineCap
C#
public abstract LineCap StartCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PenEx Class : Width Property

Glossary Item Box

Gets or sets the width of this PenEx object.

Syntax

Visual Basic (Declaration)
Public MustOverride Property Width As Single
C#
public abstract float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenEx Class
PenEx Members


RegionEx Class

[image]
ActiveReports 19 .NET Edition
RegionEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx Class

Glossary Item Box

Represents Region

Object Model

RegionEx Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RegionEx
C#
public sealed class RegionEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.RegionEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Members
GrapeCity.ActiveReports.Drawing Namespace


RegionEx Class Members

[image]
ActiveReports 19 .NET Edition
RegionEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx Class

Glossary Item Box

The following tables list the members exposed by RegionEx.

Public Constructors

 | Name | Description
Public Constructor | RegionEx Constructor |
Top

Public Properties

 | Name | Description
Public Property | Entities |
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones a given region.
static (Shared in Visual Basic) | CreateRegion | Overloaded. Creates new Region that consists from one rectangle.
Public Method | Exclude | Overloaded.
Public Method | GetBounds |
Public Method | Intersect | Overloaded.
Public Method | IsVisible |
Public Method | Transform |
Public Method | Union | Overloaded. Adds Rectangle to a given region.
Top

See Also

Reference

RegionEx Class
GrapeCity.ActiveReports.Drawing Namespace


RegionEx Constructor

[image]
ActiveReports 19 .NET Edition
RegionEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : RegionEx Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RegionEx()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


RegionEx Class Methods

[image]
ActiveReports 19 .NET Edition
RegionEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx Class

Glossary Item Box

For a list of all members of this type, see RegionEx members.

Public Methods

 | Name | Description
Public Method | Clone | Clones a given region.
static (Shared in Visual Basic) | CreateRegion | Overloaded. Creates new Region that consists from one rectangle.
Public Method | Exclude | Overloaded.
Public Method | GetBounds |
Public Method | Intersect | Overloaded.
Public Method | IsVisible |
Public Method | Transform |
Public Method | Union | Overloaded. Adds Rectangle to a given region.
Top

See Also

Reference

RegionEx Class
GrapeCity.ActiveReports.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Clone Method

Glossary Item Box

Clones a given region.

Syntax

Visual Basic (Declaration)
Public Function Clone() As RegionEx
C#
public RegionEx Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


CreateRegion Method

[image]
ActiveReports 19 .NET Edition
CreateRegion Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : CreateRegion Method

Glossary Item Box

Creates new Region that consists from one rectangle.

Overload List

Overload | Description
CreateRegion(RectangleF) | Creates new Region that consists from one rectangle.
CreateRegion(PathEx) | Creates new Region that consists from path.
CreateRegion() | Creates empty region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


CreateRegion(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
CreateRegion(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > CreateRegion Method : CreateRegion(RectangleF) Method

rect

Glossary Item Box

Creates new Region that consists from one rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateRegion( _
   ByVal rect As RectangleF _
) As RegionEx
C#
public static RegionEx CreateRegion(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


CreateRegion(PathEx) Method

[image]
ActiveReports 19 .NET Edition
CreateRegion(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > CreateRegion Method : CreateRegion(PathEx) Method

path

Glossary Item Box

Creates new Region that consists from path.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateRegion( _
   ByVal path As PathEx _
) As RegionEx
C#
public static RegionEx CreateRegion(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


CreateRegion() Method

[image]
ActiveReports 19 .NET Edition
CreateRegion() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > CreateRegion Method : CreateRegion() Method

Glossary Item Box

Creates empty region.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateRegion() As RegionEx
C#
public static RegionEx CreateRegion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Exclude Method

[image]
ActiveReports 19 .NET Edition
Exclude Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Exclude Method

Glossary Item Box

Overload List

Overload | Description
Exclude(PathEx) |
Exclude(RectangleF) |
Exclude(RegionEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Exclude(PathEx) Method

[image]
ActiveReports 19 .NET Edition
Exclude(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Exclude Method : Exclude(PathEx) Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Exclude( _
   ByVal path As PathEx _
)
C#
public void Exclude(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Exclude(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Exclude(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Exclude Method : Exclude(RectangleF) Method

rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Exclude( _
   ByVal rect As RectangleF _
)
C#
public void Exclude(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Exclude(RegionEx) Method

[image]
ActiveReports 19 .NET Edition
Exclude(RegionEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Exclude Method : Exclude(RegionEx) Method

regionToExclude

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Exclude( _
   ByVal regionToExclude As RegionEx _
)
C#
public void Exclude(
   RegionEx regionToExclude
)

Parameters

regionToExclude

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


GetBounds Method

[image]
ActiveReports 19 .NET Edition
GetBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : GetBounds Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As RectangleF
C#
public RectangleF GetBounds()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Intersect Method

[image]
ActiveReports 19 .NET Edition
Intersect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Intersect Method

Glossary Item Box

Overload List

Overload | Description
Intersect(RectangleF) |
Intersect(PathEx) |
Intersect(RegionEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Intersect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Intersect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Intersect Method : Intersect(RectangleF) Method

rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Intersect( _
   ByVal rect As RectangleF _
)
C#
public void Intersect(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Intersect(PathEx) Method

[image]
ActiveReports 19 .NET Edition
Intersect(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Intersect Method : Intersect(PathEx) Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Intersect( _
   ByVal path As PathEx _
)
C#
public void Intersect(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Intersect(RegionEx) Method

[image]
ActiveReports 19 .NET Edition
Intersect(RegionEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Intersect Method : Intersect(RegionEx) Method

regionEx

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Intersect( _
   ByVal regionEx As RegionEx _
)
C#
public void Intersect(
   RegionEx regionEx
)

Parameters

regionEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : IsVisible Method

point

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsVisible( _
   ByVal point As PointF _
) As Boolean
C#
public bool IsVisible(
   PointF point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Transform Method

[image]
ActiveReports 19 .NET Edition
Transform Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Transform Method

matrix

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Transform( _
   ByVal matrix As Matrix3x2 _
)
C#
public void Transform(
   Matrix3x2 matrix
)

Parameters

matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Union Method

[image]
ActiveReports 19 .NET Edition
Union Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Union Method

Glossary Item Box

Adds Rectangle to a given region.

Overload List

Overload | Description
Union(RectangleF) | Adds Rectangle to a given region.
Union(PathEx) |
Union(RegionEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


Union(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Union(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Union Method : Union(RectangleF) Method

rect

Glossary Item Box

Adds Rectangle to a given region.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Union( _
   ByVal rect As RectangleF _
)
C#
public void Union(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Union(PathEx) Method

[image]
ActiveReports 19 .NET Edition
Union(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Union Method : Union(PathEx) Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Union( _
   ByVal path As PathEx _
)
C#
public void Union(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


Union(RegionEx) Method

[image]
ActiveReports 19 .NET Edition
Union(RegionEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class > Union Method : Union(RegionEx) Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Union( _
   ByVal region As RegionEx _
)
C#
public void Union(
   RegionEx region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members
Overload List


RegionEx Class Properties

[image]
ActiveReports 19 .NET Edition
RegionEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx Class

Glossary Item Box

For a list of all members of this type, see RegionEx members.

Public Properties

 | Name | Description
Public Property | Entities |
Top

See Also

Reference

RegionEx Class
GrapeCity.ActiveReports.Drawing Namespace


Entities Property

[image]
ActiveReports 19 .NET Edition
Entities Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx Class : Entities Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Entities As IReadOnlyCollection(Of RegionEx.RegionEntity)
C#
public IReadOnlyCollection<RegionEx.RegionEntity> Entities {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx Class
RegionEx Members


RegionEx.RegionEntity Class

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.RegionEntity Class

Glossary Item Box

Object Model

RegionEx.RegionEntity Class

Syntax

Visual Basic (Declaration)
Public Class RegionEx.RegionEntity
C#
public class RegionEx.RegionEntity

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.RegionEx.RegionEntity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Members
GrapeCity.ActiveReports.Drawing Namespace


RegionEx.RegionEntity Class Members

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.RegionEntity Class

Glossary Item Box

The following tables list the members exposed by RegionEx.RegionEntity.

Public Constructors

 | Name | Description
Public Constructor | RegionEx.RegionEntity Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Action |
Public Field | Path |
Public Field | Rectangle |
Public Field | Region |
Public Field | Type |
Top

Public Properties

 | Name | Description
Public Property | IsEmpty |
Top

See Also

Reference

RegionEx.RegionEntity Class
GrapeCity.ActiveReports.Drawing Namespace


RegionEx.RegionEntity Constructor

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : RegionEx.RegionEntity Constructor

Glossary Item Box

Overload List

Overload | Description
RegionEx.RegionEntity Constructor(RectangleF,EntityAction) |
RegionEx.RegionEntity Constructor(RegionEx,EntityAction) |
RegionEx.RegionEntity Constructor(PathEx,EntityAction) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


RegionEx.RegionEntity Constructor(RectangleF,EntityAction)

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Constructor(RectangleF,EntityAction)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class > RegionEx.RegionEntity Constructor : RegionEx.RegionEntity Constructor(RectangleF,EntityAction)

rect
action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF, _
   ByVal action As RegionEx.EntityAction _
)
C#
public RegionEx.RegionEntity(
   RectangleF rect,
   RegionEx.EntityAction action
)

Parameters

rect
action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members
Overload List


RegionEx.RegionEntity Constructor(RegionEx,EntityAction)

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Constructor(RegionEx,EntityAction)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class > RegionEx.RegionEntity Constructor : RegionEx.RegionEntity Constructor(RegionEx,EntityAction)

regionEx
action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal regionEx As RegionEx, _
   ByVal action As RegionEx.EntityAction _
)
C#
public RegionEx.RegionEntity(
   RegionEx regionEx,
   RegionEx.EntityAction action
)

Parameters

regionEx
action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members
Overload List


RegionEx.RegionEntity Constructor(PathEx,EntityAction)

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Constructor(PathEx,EntityAction)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class > RegionEx.RegionEntity Constructor : RegionEx.RegionEntity Constructor(PathEx,EntityAction)

path
action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal path As PathEx, _
   ByVal action As RegionEx.EntityAction _
)
C#
public RegionEx.RegionEntity(
   PathEx path,
   RegionEx.EntityAction action
)

Parameters

path
action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members
Overload List


RegionEx.RegionEntity Class Properties

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.RegionEntity Class

Glossary Item Box

For a list of all members of this type, see RegionEx.RegionEntity members.

Public Properties

 | Name | Description
Public Property | IsEmpty |
Top

See Also

Reference

RegionEx.RegionEntity Class
GrapeCity.ActiveReports.Drawing Namespace


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : IsEmpty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


RegionEx.RegionEntity Class Fields

[image]
ActiveReports 19 .NET Edition
RegionEx.RegionEntity Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.RegionEntity Class

Glossary Item Box

For a list of all members of this type, see RegionEx.RegionEntity members.

Public Fields

 | Name | Description
Public Field | Action |
Public Field | Path |
Public Field | Rectangle |
Public Field | Region |
Public Field | Type |
Top

See Also

Reference

RegionEx.RegionEntity Class
GrapeCity.ActiveReports.Drawing Namespace


Action Field

[image]
ActiveReports 19 .NET Edition
Action Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : Action Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Action As RegionEx.EntityAction
C#
public readonly RegionEx.EntityAction Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


Path Field

[image]
ActiveReports 19 .NET Edition
Path Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : Path Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Path As PathEx
C#
public readonly PathEx Path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


Rectangle Field

[image]
ActiveReports 19 .NET Edition
Rectangle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : Rectangle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Rectangle As RectangleF
C#
public readonly RectangleF Rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


Region Field

[image]
ActiveReports 19 .NET Edition
Region Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : Region Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Region As RegionEx
C#
public readonly RegionEx Region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > RegionEx.RegionEntity Class : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Type As RegionEx.EntityType
C#
public readonly RegionEx.EntityType Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegionEx.RegionEntity Class
RegionEx.RegionEntity Members


StringFormatEx Class

[image]
ActiveReports 19 .NET Edition
StringFormatEx Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringFormatEx Class

Glossary Item Box

Classes derived from this abstract base class define objects used to hold string formatting information.

Object Model

StringFormatEx Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringFormatEx
C#
public sealed class StringFormatEx

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.StringFormatEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Members
GrapeCity.ActiveReports.Drawing Namespace


StringFormatEx Class Members

[image]
ActiveReports 19 .NET Edition
StringFormatEx Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringFormatEx Class

Glossary Item Box

The following tables list the members exposed by StringFormatEx.

Public Constructors

 | Name | Description
Public Constructor | StringFormatEx Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment | Get ot sets text alignment in line.
Public Property | CharacterSpacing | Character spacing in twips.
static (Shared in Visual Basic) | GetGenericDefault |
static (Shared in Visual Basic) | GetGenericTypographic |
Public Property | IsRightToLeft | True of text is right to left.
Public Property | IsVertical | True of text is vertical.
Public Property | LineAlignment | Gets or sets alignment of entire text line.
Public Property | LineLimit |
Public Property | LineSpacing | Line spacing in twips.
Public Property | MeasureTrailingSpaces |
Public Property | NoClip |
Public Property | ShrinkToFit | Gets or sets shrink to fit flag.
Public Property | TabStops | Gets or sets the custom tab stops.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | Trimming | Gets or sets trimming.
Public Property | UprightInVerticalText | Gets or sets upright mode in the vertical text.
Public Property | WrapMode | Gets or sets the wrap mode.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones.
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

StringFormatEx Class
GrapeCity.ActiveReports.Drawing Namespace


StringFormatEx Constructor

[image]
ActiveReports 19 .NET Edition
StringFormatEx Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : StringFormatEx Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StringFormatEx()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


StringFormatEx Class Methods

[image]
ActiveReports 19 .NET Edition
StringFormatEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringFormatEx Class

Glossary Item Box

For a list of all members of this type, see StringFormatEx members.

Public Methods

 | Name | Description
Public Method | Clone | Clones.
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

StringFormatEx Class
GrapeCity.ActiveReports.Drawing Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : Clone Method

Glossary Item Box

Clones.

Syntax

Visual Basic (Declaration)
Public Function Clone() As StringFormatEx
C#
public StringFormatEx Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : Equals Method

Glossary Item Box

Overload List

Overload | Description
Equals(Object) |
Equals(StringFormatEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class > Equals Method : Equals(Object) Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members
Overload List


Equals(StringFormatEx) Method

[image]
ActiveReports 19 .NET Edition
Equals(StringFormatEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class > Equals Method : Equals(StringFormatEx) Method

other

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As StringFormatEx _
) As Boolean
C#
public bool Equals(
   StringFormatEx other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


StringFormatEx Class Properties

[image]
ActiveReports 19 .NET Edition
StringFormatEx Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringFormatEx Class

Glossary Item Box

For a list of all members of this type, see StringFormatEx members.

Public Properties

 | Name | Description
Public Property | Alignment | Get ot sets text alignment in line.
Public Property | CharacterSpacing | Character spacing in twips.
static (Shared in Visual Basic) | GetGenericDefault |
static (Shared in Visual Basic) | GetGenericTypographic |
Public Property | IsRightToLeft | True of text is right to left.
Public Property | IsVertical | True of text is vertical.
Public Property | LineAlignment | Gets or sets alignment of entire text line.
Public Property | LineLimit |
Public Property | LineSpacing | Line spacing in twips.
Public Property | MeasureTrailingSpaces |
Public Property | NoClip |
Public Property | ShrinkToFit | Gets or sets shrink to fit flag.
Public Property | TabStops | Gets or sets the custom tab stops.
Public Property | TextJustify | Gets or sets the text justify.
Public Property | Trimming | Gets or sets trimming.
Public Property | UprightInVerticalText | Gets or sets upright mode in the vertical text.
Public Property | WrapMode | Gets or sets the wrap mode.
Top

See Also

Reference

StringFormatEx Class
GrapeCity.ActiveReports.Drawing Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : Alignment Property

Glossary Item Box

Get ot sets text alignment in line.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignmentEx
C#
public StringAlignmentEx Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : CharacterSpacing Property

Glossary Item Box

Character spacing in twips.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


GetGenericDefault Property

[image]
ActiveReports 19 .NET Edition
GetGenericDefault Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : GetGenericDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property GetGenericDefault As StringFormatEx
C#
public static StringFormatEx GetGenericDefault {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


GetGenericTypographic Property

[image]
ActiveReports 19 .NET Edition
GetGenericTypographic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : GetGenericTypographic Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property GetGenericTypographic As StringFormatEx
C#
public static StringFormatEx GetGenericTypographic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


IsRightToLeft Property

[image]
ActiveReports 19 .NET Edition
IsRightToLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : IsRightToLeft Property

Glossary Item Box

True of text is right to left.

Syntax

Visual Basic (Declaration)
Public Property IsRightToLeft As Boolean
C#
public bool IsRightToLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


IsVertical Property

[image]
ActiveReports 19 .NET Edition
IsVertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : IsVertical Property

Glossary Item Box

True of text is vertical.

Syntax

Visual Basic (Declaration)
Public Property IsVertical As Boolean
C#
public bool IsVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


LineAlignment Property

[image]
ActiveReports 19 .NET Edition
LineAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : LineAlignment Property

Glossary Item Box

Gets or sets alignment of entire text line.

Syntax

Visual Basic (Declaration)
Public Property LineAlignment As StringLineAlignmentEx
C#
public StringLineAlignmentEx LineAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


LineLimit Property

[image]
ActiveReports 19 .NET Edition
LineLimit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : LineLimit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LineLimit As Boolean
C#
public bool LineLimit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : LineSpacing Property

Glossary Item Box

Line spacing in twips.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


MeasureTrailingSpaces Property

[image]
ActiveReports 19 .NET Edition
MeasureTrailingSpaces Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : MeasureTrailingSpaces Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MeasureTrailingSpaces As Boolean
C#
public bool MeasureTrailingSpaces {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


NoClip Property

[image]
ActiveReports 19 .NET Edition
NoClip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : NoClip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NoClip As Boolean
C#
public bool NoClip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : ShrinkToFit Property

Glossary Item Box

Gets or sets shrink to fit flag.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : TabStops Property

Glossary Item Box

Gets or sets the custom tab stops.

Syntax

Visual Basic (Declaration)
Public Property TabStops As IReadOnlyList(Of TabStop)
C#
public IReadOnlyList<TabStop> TabStops {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : TextJustify Property

Glossary Item Box

Gets or sets the text justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As TextJustify
C#
public TextJustify TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


Trimming Property

[image]
ActiveReports 19 .NET Edition
Trimming Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : Trimming Property

Glossary Item Box

Gets or sets trimming.

Syntax

Visual Basic (Declaration)
Public Property Trimming As StringTrimmingEx
C#
public StringTrimmingEx Trimming {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


UprightInVerticalText Property

[image]
ActiveReports 19 .NET Edition
UprightInVerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : UprightInVerticalText Property

Glossary Item Box

Gets or sets upright mode in the vertical text.

Syntax

Visual Basic (Declaration)
Public Property UprightInVerticalText As UprightTextMode
C#
public UprightTextMode UprightInVerticalText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > StringFormatEx Class : WrapMode Property

Glossary Item Box

Gets or sets the wrap mode.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As WrapMode
C#
public WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringFormatEx Class
StringFormatEx Members


TextMetricsProviderExtensions Class

[image]
ActiveReports 19 .NET Edition
TextMetricsProviderExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetricsProviderExtensions Class

Glossary Item Box

Represents an extension methods for ITextMetricsProvider class.

Object Model

TextMetricsProviderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class TextMetricsProviderExtensions
C#
public static class TextMetricsProviderExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.TextMetricsProviderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetricsProviderExtensions Members
GrapeCity.ActiveReports.Drawing Namespace


TextMetricsProviderExtensions Class Members

[image]
ActiveReports 19 .NET Edition
TextMetricsProviderExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetricsProviderExtensions Class

Glossary Item Box

The following tables list the members exposed by TextMetricsProviderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | MeasureString | Overloaded. Measures string content based on currently selected font, device capabilities and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.
Top

See Also

Reference

TextMetricsProviderExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


TextMetricsProviderExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
TextMetricsProviderExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetricsProviderExtensions Class

Glossary Item Box

For a list of all members of this type, see TextMetricsProviderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | MeasureString | Overloaded. Measures string content based on currently selected font, device capabilities and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.
Top

See Also

Reference

TextMetricsProviderExtensions Class
GrapeCity.ActiveReports.Drawing Namespace


MeasureString Method

[image]
ActiveReports 19 .NET Edition
MeasureString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetricsProviderExtensions Class : MeasureString Method

Glossary Item Box

Measures string content based on currently selected font, device capabilities and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Overload List

Overload | Description
MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,Single,Single,CultureInfo) | Measures string content based on currently selected font, device capabilities and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.
MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,StringFormatEx,Single,Single,CultureInfo) | Measures string content based on currently selected font, device capabilities, string format and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetricsProviderExtensions Class
TextMetricsProviderExtensions Members


MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,Single,Single,CultureInfo) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,Single,Single,CultureInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetricsProviderExtensions Class > MeasureString Method : MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,Single,Single,CultureInfo) Method

tm
font
contentText
style
boundWidth
boundHeight
reportCulture

Glossary Item Box

Measures string content based on currently selected font, device capabilities and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function MeasureString( _
   ByVal tm As ITextMetricsProvider, _
   ByVal font As FontInfo, _
   ByVal contentText As String, _
   ByVal style As IStyle, _
   ByVal boundWidth As Single, _
   ByVal boundHeight As Single, _
   Optional ByVal reportCulture As CultureInfo _
) As TextMetrics
C#
public static TextMetrics MeasureString(
   ITextMetricsProvider tm,
   FontInfo font,
   string contentText,
   IStyle style,
   float boundWidth,
   float boundHeight,
   CultureInfo reportCulture
)

Parameters

tm
font
contentText
style
boundWidth
boundHeight
reportCulture

Return Value

Number of characters fit into provided bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetricsProviderExtensions Class
TextMetricsProviderExtensions Members
Overload List


MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,StringFormatEx,Single,Single,CultureInfo) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,StringFormatEx,Single,Single,CultureInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetricsProviderExtensions Class > MeasureString Method : MeasureString(ITextMetricsProvider,FontInfo,String,IStyle,StringFormatEx,Single,Single,CultureInfo) Method

tm
font
contentText
style
stringFormat
boundWidth
boundHeight
reportCulture

Glossary Item Box

Measures string content based on currently selected font, device capabilities, string format and GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function MeasureString( _
   ByVal tm As ITextMetricsProvider, _
   ByVal font As FontInfo, _
   ByVal contentText As String, _
   ByVal style As IStyle, _
   ByVal stringFormat As StringFormatEx, _
   Optional ByVal boundWidth As Single, _
   Optional ByVal boundHeight As Single, _
   Optional ByVal reportCulture As CultureInfo _
) As TextMetrics
C#
public static TextMetrics MeasureString(
   ITextMetricsProvider tm,
   FontInfo font,
   string contentText,
   IStyle style,
   StringFormatEx stringFormat,
   float boundWidth,
   float boundHeight,
   CultureInfo reportCulture
)

Parameters

tm
font
contentText
style
stringFormat
boundWidth
boundHeight
reportCulture

Return Value

Number of characters fit into provided bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetricsProviderExtensions Class
TextMetricsProviderExtensions Members
Overload List


DashCap Enumeration

[image]
ActiveReports 19 .NET Edition
DashCap Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : DashCap Enumeration

Glossary Item Box

Specifies the type of graphic shape to use on both ends of each dash in a dashed line.

Syntax

Visual Basic (Declaration)
Public Enum DashCap
   Inherits System.Enum
C#
public enum DashCap : System.Enum

Members

Member | Description
Flat | Specifies a square cap that squares off both ends of each dash.
Round | Specifies a circular cap that rounds off both ends of each dash.
Triangle | Specifies a triangular cap that points both ends of each dash.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.DashCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FillModeEx Enumeration

[image]
ActiveReports 19 .NET Edition
FillModeEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FillModeEx Enumeration

Glossary Item Box

Specifies how the interior of a closed path is filled.

Syntax

Visual Basic (Declaration)
Public Enum FillModeEx
   Inherits System.Enum
C#
public enum FillModeEx : System.Enum

Members

Member | Description
Alternate | Specifies the alternate fill mode.
Winding | Specifies the winding fill mode.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.FillModeEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FontDecoration Enumeration

[image]
ActiveReports 19 .NET Edition
FontDecoration Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontDecoration Enumeration

Glossary Item Box

Specifies the font decoration.

Syntax

Visual Basic (Declaration)
Public Enum FontDecoration
   Inherits System.Enum
C#
public enum FontDecoration : System.Enum

Members

Member | Description
DoubleUnderline | Defines the two lines below the text.
Linethrough | Defines a line through the text.
None | Defines a normal text.
Overline | Defines a line above the text.
Underline | Defines a line below the text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.FontDecoration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FontStyle Enumeration

[image]
ActiveReports 19 .NET Edition
FontStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontStyle Enumeration

Glossary Item Box

Specifies the font style.

Syntax

Visual Basic (Declaration)
Public Enum FontStyle
   Inherits System.Enum
C#
public enum FontStyle : System.Enum

Members

Member | Description
Italic | Defines an italic text.
Normal | Defines a normal text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.FontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FontStyleEx Enumeration

[image]
ActiveReports 19 .NET Edition
FontStyleEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontStyleEx Enumeration

Glossary Item Box

Specifies style information applied to text.

Syntax

Visual Basic (Declaration)
Public Enum FontStyleEx
   Inherits System.Enum
C#
public enum FontStyleEx : System.Enum

Members

Member | Description
Bold | The bold text.
DoubleUnderline | The text with a double underline.
Italic | The italic text.
Regular | The regular text.
Strikeout | The text with a strikeout.
Underline | The underlined text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.FontStyleEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FontWeight Enumeration

[image]
ActiveReports 19 .NET Edition
FontWeight Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontWeight Enumeration

Glossary Item Box

Specifies font thickness.

Syntax

Visual Basic (Declaration)
Public Enum FontWeight
   Inherits System.Enum
C#
public enum FontWeight : System.Enum

Members

Member | Description
Bold | Indicates a bold font weight.
Bolder | Indicates a bolder font weight.
ExtraBold | Indicates an extra bold font weight.
ExtraLight | Indicates an extra light font weight
Heavy | Indicates a heavy font weight.
Light | Indicates a light font weight
Lighter | Indicates a lighter font weight
Medium | Indicates a medium font weight.
Normal | Indicates a normal font weight.
SemiBold | Indicates a semi-bold font weight.
Thin | Indicates a thin font weight

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.FontWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


GraphicsUnitEx Enumeration

[image]
ActiveReports 19 .NET Edition
GraphicsUnitEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : GraphicsUnitEx Enumeration

Glossary Item Box

Specifies the unit of measure the provided data is in.

Syntax

Visual Basic (Declaration)
Public Enum GraphicsUnitEx
   Inherits System.Enum
C#
public enum GraphicsUnitEx : System.Enum

Members

Member | Description
Display | Specifies the unit of measure is 1/75 inch
Document | Specifies the unit of measure is the document unit (1/300 inch)
Inch | Specifies the unit of measure is an inch.
Millimeter | Specifies the unit of measure is a millimeter
Pixel | Specifies the unit of measure is the device pixel.
Point | Specifies the unit of measure is a printer's point (1/72 inch)
World | Specifies the unit of measure is the world unit.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.GraphicsUnitEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


HatchStyleEx Enumeration

[image]
ActiveReports 19 .NET Edition
HatchStyleEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : HatchStyleEx Enumeration

Glossary Item Box

See System.Drawing.Drawing2D.HatchStyle

Syntax

Visual Basic (Declaration)
Public Enum HatchStyleEx
   Inherits System.Enum
C#
public enum HatchStyleEx : System.Enum

Members

Member | Description
BackwardDiagonal |
Cross |
DarkDownwardDiagonal |
DarkHorizontal |
DarkUpwardDiagonal |
DarkVertical |
DashedDownwardDiagonal |
DashedHorizontal |
DashedUpwardDiagonal |
DashedVertical |
DiagonalBrick |
DiagonalCross |
Divot |
DottedDiamond |
DottedGrid |
ForwardDiagonal |
Horizontal |
HorizontalBrick |
LargeCheckerBoard |
LargeConfetti |
LargeGrid |
LightDownwardDiagonal |
LightHorizontal |
LightUpwardDiagonal |
LightVertical |
Max |
Min |
NarrowHorizontal |
NarrowVertical |
OutlinedDiamond |
Percent05 |
Percent10 |
Percent20 |
Percent25 |
Percent30 |
Percent40 |
Percent50 |
Percent60 |
Percent70 |
Percent75 |
Percent80 |
Percent90 |
Plaid |
Shingle |
SmallCheckerBoard |
SmallConfetti |
SmallGrid |
SolidDiamond |
Sphere |
Trellis |
Vertical |
Wave |
Weave |
WideDownwardDiagonal |
WideUpwardDiagonal |
ZigZag |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.HatchStyleEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


LineCap Enumeration

[image]
ActiveReports 19 .NET Edition
LineCap Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : LineCap Enumeration

Glossary Item Box

Specifies the available cap styles with which a PenEx object can end a line.

Syntax

Visual Basic (Declaration)
Public Enum LineCap
   Inherits System.Enum
C#
public enum LineCap : System.Enum

Members

Member | Description
AnchorMask | Specifies a mask used to check whether a line cap is an anchor cap.
ArrowAnchor | Specifies an arrow-shaped anchor cap.
Custom | Specifies a custom line cap.
DiamondAnchor | Specifies a diamond anchor cap.
Flat | Specifies a flat line cap.
NoAnchor | Specifies no anchor.
Round | Specifies a round line cap.
RoundAnchor | Specifies a round anchor cap.
Square | Specifies a square line cap.
SquareAnchor | Specifies a square anchor line cap.
Triangle | Specifies a triangular line cap.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.LineCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


LineJoin Enumeration

[image]
ActiveReports 19 .NET Edition
LineJoin Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : LineJoin Enumeration

Glossary Item Box

Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object.

Syntax

Visual Basic (Declaration)
Public Enum LineJoin
   Inherits System.Enum
C#
public enum LineJoin : System.Enum

Members

Member | Description
Bevel | Specifies a beveled join. This produces a diagonal corner.
Miter | Specifies a mitered join. This produces a sharp corner or a clipped corner, depending on whether the length of the miter exceeds the miter limit.
MiterClipped | Specifies a mitered join. This produces a sharp corner or a beveled corner, depending on whether the length of the miter exceeds the miter limit.
Round | Specifies a circular join. This produces a smooth, circular arc between the lines.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.LineJoin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


MatrixOrderEx Enumeration

[image]
ActiveReports 19 .NET Edition
MatrixOrderEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : MatrixOrderEx Enumeration

Glossary Item Box

Specifies matrix transform operation order.

Syntax

Visual Basic (Declaration)
Public Enum MatrixOrderEx
   Inherits System.Enum
C#
public enum MatrixOrderEx : System.Enum

Members

Member | Description
Append | Specifies the new operation will occur after the old operation.
Prepend | Specifies the new operation will occur before the old operation.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.MatrixOrderEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


PathEx.SegmentType Enumeration

[image]
ActiveReports 19 .NET Edition
PathEx.SegmentType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx.SegmentType Enumeration

Glossary Item Box

Segment type.

Syntax

Visual Basic (Declaration)
Public Enum PathEx.SegmentType
   Inherits System.Enum
C#
public enum PathEx.SegmentType : System.Enum

Members

Member | Description
BezierTo | Adds bezier from last point to 2 control and end points.
FigureEnd | Ends figure, close if necessary.
LineTo | Adds line from last point to point.
MoveTo | Moves to point.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.PathEx.SegmentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


PenAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
PenAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenAlignment Enumeration

Glossary Item Box

Gets or sets the alignment for PenEx object.

Syntax

Visual Basic (Declaration)
Public Enum PenAlignment
   Inherits System.Enum
C#
public enum PenAlignment : System.Enum

Members

Member | Description
Center | Specifies that the System.Drawing.Pen object is centered over the theoretical line.
Inset | Specifies that the System.Drawing.Pen is positioned on the inside of the theoretical line.
Left | Reserved.
Outset | Reserved.
Right | Reserved.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.PenAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


PenStyleEx Enumeration

[image]
ActiveReports 19 .NET Edition
PenStyleEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PenStyleEx Enumeration

Glossary Item Box

Specifies the style of dashed lines drawn with a System.Drawing.Pen object.

Syntax

Visual Basic (Declaration)
Public Enum PenStyleEx
   Inherits System.Enum
C#
public enum PenStyleEx : System.Enum

Members

Member | Description
Custom | Specifies a user-defined custom dash style.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.PenStyleEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


RegionEx.EntityAction Enumeration

[image]
ActiveReports 19 .NET Edition
RegionEx.EntityAction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.EntityAction Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RegionEx.EntityAction
   Inherits System.Enum
C#
public enum RegionEx.EntityAction : System.Enum

Members

Member | Description
Exclude |
Include |
Intersect |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.RegionEx.EntityAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


RegionEx.EntityType Enumeration

[image]
ActiveReports 19 .NET Edition
RegionEx.EntityType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : RegionEx.EntityType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RegionEx.EntityType
   Inherits System.Enum
C#
public enum RegionEx.EntityType : System.Enum

Members

Member | Description
Path |
Rectangle |
Region |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.RegionEx.EntityType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


SmoothingModeEx Enumeration

[image]
ActiveReports 19 .NET Edition
SmoothingModeEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : SmoothingModeEx Enumeration

Glossary Item Box

Specifies if, and how, smoothing is applied to lines, curves and filled area edges.

Syntax

Visual Basic (Declaration)
Public Enum SmoothingModeEx
   Inherits System.Enum
C#
public enum SmoothingModeEx : System.Enum

Members

Member | Description
AntiAlias | Specifies using antialiasing.
Default | Specifies default mode.
HighQuality | Specifies high qulaity rendering which has a lower rendering speed.
HighSpeed | Specifies a higher speed rendering which has a lower rendering quality.
Invalid | Specifies an invalid mode.
None | Specifies not to use antialiasing.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.SmoothingModeEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


StringAlignmentEx Enumeration

[image]
ActiveReports 19 .NET Edition
StringAlignmentEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringAlignmentEx Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringAlignmentEx
   Inherits System.Enum
C#
public enum StringAlignmentEx : System.Enum

Members

Member | Description
Center |
Far |
Justify |
Near |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.StringAlignmentEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


StringDigitSubstituteEx Enumeration

[image]
ActiveReports 19 .NET Edition
StringDigitSubstituteEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringDigitSubstituteEx Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringDigitSubstituteEx
   Inherits System.Enum
C#
public enum StringDigitSubstituteEx : System.Enum

Members

Member | Description
National |
None |
Traditional |
User |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.StringDigitSubstituteEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


StringLineAlignmentEx Enumeration

[image]
ActiveReports 19 .NET Edition
StringLineAlignmentEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringLineAlignmentEx Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringLineAlignmentEx
   Inherits System.Enum
C#
public enum StringLineAlignmentEx : System.Enum

Members

Member | Description
Center |
Far |
Near |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.StringLineAlignmentEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


StringTrimmingEx Enumeration

[image]
ActiveReports 19 .NET Edition
StringTrimmingEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : StringTrimmingEx Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringTrimmingEx
   Inherits System.Enum
C#
public enum StringTrimmingEx : System.Enum

Members

Member | Description
Character |
EllipsisCharacter |
EllipsisPath |
EllipsisWord |
None |
Word |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.StringTrimmingEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


TextAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
TextAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextAlignment Enumeration

Glossary Item Box

Enum TextAlignment

Syntax

Visual Basic (Declaration)
Public Enum TextAlignment
   Inherits System.Enum
C#
public enum TextAlignment : System.Enum

Members

Member | Description
Center | The center
Justify | The justify
Left | The left
Right | The right

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.TextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


TextJustify Enumeration

[image]
ActiveReports 19 .NET Edition
TextJustify Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextJustify Enumeration

Glossary Item Box

Represents the text justification.

Syntax

Visual Basic (Declaration)
Public Enum TextJustify
   Inherits System.Enum
C#
public enum TextJustify : System.Enum

Members

Member | Description
Auto | Defines the justification algorithm that is determined automatically.
Distribute | Defines the newspaper-like distribution except the last line of text which is not modified.
DistributeAllLines | Defines the newspaper-like distribution including the last line.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


TextRenderingHintEx Enumeration

[image]
ActiveReports 19 .NET Edition
TextRenderingHintEx Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextRenderingHintEx Enumeration

Glossary Item Box

Specifies the text rendering quality.

Syntax

Visual Basic (Declaration)
Public Enum TextRenderingHintEx
   Inherits System.Enum
C#
public enum TextRenderingHintEx : System.Enum

Members

Member | Description
AntiAlias | Specifies characters are drawn using antialiased glyph bitmaps without hinting. Improves quality but with performance cost.
AntiAliasGridFit | Specifies characters are drawn using antialiased glyph bitmaps with hinting. Improves quality but with performance cost.
ClearTypeGridFit | Specifies characters are drawn using glyph CT bitmap with hinting. Highest quality rendering but with performance costs. Takes advantage of ClearType font features.
SingleBitPerPixel | Specifies characters are drawn using its glyph bitmp with no hinting used.
SingleBitPerPixelGridFit | Specifies characters are drawn using its glyph bitmap with hinting used to improve stms and curvature appearance.
SystemDefault | Specifies characters are drawn using its glyph bitmap using the user's system font smoothing settings.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.TextRenderingHintEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


UprightTextMode Enumeration

[image]
ActiveReports 19 .NET Edition
UprightTextMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : UprightTextMode Enumeration

Glossary Item Box

Indicates whether the digits or digits along with Latin text appear horizontally in the vertical text.

Syntax

Visual Basic (Declaration)
Public Enum UprightTextMode
   Inherits System.Enum
C#
public enum UprightTextMode : System.Enum

Members

Member | Description
Digits | Only horizontal digits
DigitsAndLatinLetters | Horizontal digits with latin letters
None | No horizontal runs

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.UprightTextMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


VerticalTextAlignment Enumeration

[image]
ActiveReports 19 .NET Edition
VerticalTextAlignment Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : VerticalTextAlignment Enumeration

Glossary Item Box

Enum VerticalTextAlignment

Syntax

Visual Basic (Declaration)
Public Enum VerticalTextAlignment
   Inherits System.Enum
C#
public enum VerticalTextAlignment : System.Enum

Members

Member | Description
Bottom | The bottom
Middle | The middle
Top | The top

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.VerticalTextAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


WrapMode Enumeration

[image]
ActiveReports 19 .NET Edition
WrapMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : WrapMode Enumeration

Glossary Item Box

Specifies whether the text is written from left to right or right to left.

Syntax

Visual Basic (Declaration)
Public Enum WrapMode
   Inherits System.Enum
C#
public enum WrapMode : System.Enum

Members

Member | Description
CharWrap | Per-character wrapping mode.
NoWrap | No text wrap.
WordWrap | Wrap by word boundaries

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Drawing.WrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Drawing Namespace


FontMetrics Structure

[image]
ActiveReports 19 .NET Edition
FontMetrics Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontMetrics Structure

Glossary Item Box

Different font metrics.

Object Model

FontMetrics Structure

Syntax

Visual Basic (Declaration)
Public Structure FontMetrics
   Inherits System.ValueType
C#
public struct FontMetrics : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Drawing.FontMetrics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Members
GrapeCity.ActiveReports.Drawing Namespace


FontMetrics Structure Members

[image]
ActiveReports 19 .NET Edition
FontMetrics Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontMetrics Structure

Glossary Item Box

The following tables list the members exposed by FontMetrics.

Public Constructors

 | Name | Description
Public Constructor | FontMetrics Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Ascent | Font ascent in Twips.
Public Field | BaseLine | Font baseline position in twips.
Public Field | FontHeight | Font height in Twips.
Public Field | LineSpacing | Line spacing in twips.
Top

See Also

Reference

FontMetrics Structure
GrapeCity.ActiveReports.Drawing Namespace


FontMetrics Constructor

[image]
ActiveReports 19 .NET Edition
FontMetrics Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure : FontMetrics Constructor

Glossary Item Box

Overload List

Overload | Description
FontMetrics Constructor(Int32,Int32) | Constructor.
FontMetrics Constructor(Int32,Int32,Int32) | Constructor.
FontMetrics Constructor(Int32,Int32,Int32,Int32) | Constructor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members


FontMetrics Constructor(Int32,Int32)

[image]
ActiveReports 19 .NET Edition
FontMetrics Constructor(Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure > FontMetrics Constructor : FontMetrics Constructor(Int32,Int32)

lineSpacing
baseLine

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lineSpacing As Integer, _
   ByVal baseLine As Integer _
)
C#
public FontMetrics(
   int lineSpacing,
   int baseLine
)

Parameters

lineSpacing
baseLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members
Overload List


FontMetrics Constructor(Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
FontMetrics Constructor(Int32,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure > FontMetrics Constructor : FontMetrics Constructor(Int32,Int32,Int32)

lineSpacing
baseLine
ascent

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lineSpacing As Integer, _
   ByVal baseLine As Integer, _
   ByVal ascent As Integer _
)
C#
public FontMetrics(
   int lineSpacing,
   int baseLine,
   int ascent
)

Parameters

lineSpacing
baseLine
ascent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members
Overload List


FontMetrics Constructor(Int32,Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
FontMetrics Constructor(Int32,Int32,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure > FontMetrics Constructor : FontMetrics Constructor(Int32,Int32,Int32,Int32)

lineSpacing
baseLine
ascent
fontHeight

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lineSpacing As Integer, _
   ByVal baseLine As Integer, _
   ByVal ascent As Integer, _
   ByVal fontHeight As Integer _
)
C#
public FontMetrics(
   int lineSpacing,
   int baseLine,
   int ascent,
   int fontHeight
)

Parameters

lineSpacing
baseLine
ascent
fontHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members
Overload List


FontMetrics Structure Fields

[image]
ActiveReports 19 .NET Edition
FontMetrics Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : FontMetrics Structure

Glossary Item Box

For a list of all members of this type, see FontMetrics members.

Public Fields

 | Name | Description
Public Field | Ascent | Font ascent in Twips.
Public Field | BaseLine | Font baseline position in twips.
Public Field | FontHeight | Font height in Twips.
Public Field | LineSpacing | Line spacing in twips.
Top

See Also

Reference

FontMetrics Structure
GrapeCity.ActiveReports.Drawing Namespace


Ascent Field

[image]
ActiveReports 19 .NET Edition
Ascent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure : Ascent Field

Glossary Item Box

Font ascent in Twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Ascent As Integer
C#
public readonly int Ascent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members


BaseLine Field

[image]
ActiveReports 19 .NET Edition
BaseLine Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure : BaseLine Field

Glossary Item Box

Font baseline position in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly BaseLine As Integer
C#
public readonly int BaseLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members


FontHeight Field

[image]
ActiveReports 19 .NET Edition
FontHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure : FontHeight Field

Glossary Item Box

Font height in Twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly FontHeight As Integer
C#
public readonly int FontHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members


LineSpacing Field

[image]
ActiveReports 19 .NET Edition
LineSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > FontMetrics Structure : LineSpacing Field

Glossary Item Box

Line spacing in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly LineSpacing As Integer
C#
public readonly int LineSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontMetrics Structure
FontMetrics Members


PathEx.Segment Structure

[image]
ActiveReports 19 .NET Edition
PathEx.Segment Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx.Segment Structure

Glossary Item Box

Segment description.

Object Model

PathEx.Segment Structure

Syntax

Visual Basic (Declaration)
Public Structure PathEx.Segment
   Inherits System.ValueType
C#
public struct PathEx.Segment : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Drawing.PathEx.Segment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Members
GrapeCity.ActiveReports.Drawing Namespace


PathEx.Segment Structure Members

[image]
ActiveReports 19 .NET Edition
PathEx.Segment Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx.Segment Structure

Glossary Item Box

The following tables list the members exposed by PathEx.Segment.

Public Fields

 | Name | Description
Public Field | Closed |
Public Field | Point1 |
Public Field | Point2 |
Public Field | Point3 |
Public Field | Type |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BezierTo |
static (Shared in Visual Basic) | FigureEnd |
static (Shared in Visual Basic) | LineTo |
static (Shared in Visual Basic) | MoveTo |
Public Method | ToString |
Top

See Also

Reference

PathEx.Segment Structure
GrapeCity.ActiveReports.Drawing Namespace


PathEx.Segment Structure Methods

[image]
ActiveReports 19 .NET Edition
PathEx.Segment Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx.Segment Structure

Glossary Item Box

For a list of all members of this type, see PathEx.Segment members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BezierTo |
static (Shared in Visual Basic) | FigureEnd |
static (Shared in Visual Basic) | LineTo |
static (Shared in Visual Basic) | MoveTo |
Public Method | ToString |
Top

See Also

Reference

PathEx.Segment Structure
GrapeCity.ActiveReports.Drawing Namespace


BezierTo Method

[image]
ActiveReports 19 .NET Edition
BezierTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : BezierTo Method

p1
p2
endPoint

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function BezierTo( _
   ByVal p1 As Vector2, _
   ByVal p2 As Vector2, _
   ByVal endPoint As Vector2 _
) As PathEx.Segment
C#
public static PathEx.Segment BezierTo(
   Vector2 p1,
   Vector2 p2,
   Vector2 endPoint
)

Parameters

p1
p2
endPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


FigureEnd Method

[image]
ActiveReports 19 .NET Edition
FigureEnd Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : FigureEnd Method

closed

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function FigureEnd( _
   ByVal closed As Boolean _
) As PathEx.Segment
C#
public static PathEx.Segment FigureEnd(
   bool closed
)

Parameters

closed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


LineTo Method

[image]
ActiveReports 19 .NET Edition
LineTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : LineTo Method

point

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function LineTo( _
   ByVal point As Vector2 _
) As PathEx.Segment
C#
public static PathEx.Segment LineTo(
   Vector2 point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


MoveTo Method

[image]
ActiveReports 19 .NET Edition
MoveTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : MoveTo Method

point

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function MoveTo( _
   ByVal point As Vector2 _
) As PathEx.Segment
C#
public static PathEx.Segment MoveTo(
   Vector2 point
)

Parameters

point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


PathEx.Segment Structure Fields

[image]
ActiveReports 19 .NET Edition
PathEx.Segment Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : PathEx.Segment Structure

Glossary Item Box

For a list of all members of this type, see PathEx.Segment members.

Public Fields

 | Name | Description
Public Field | Closed |
Public Field | Point1 |
Public Field | Point2 |
Public Field | Point3 |
Public Field | Type |
Top

See Also

Reference

PathEx.Segment Structure
GrapeCity.ActiveReports.Drawing Namespace


Closed Field

[image]
ActiveReports 19 .NET Edition
Closed Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : Closed Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Closed As Boolean
C#
public bool Closed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


Point1 Field

[image]
ActiveReports 19 .NET Edition
Point1 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : Point1 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Point1 As Vector2
C#
public Vector2 Point1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


Point2 Field

[image]
ActiveReports 19 .NET Edition
Point2 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : Point2 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Point2 As Vector2
C#
public Vector2 Point2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


Point3 Field

[image]
ActiveReports 19 .NET Edition
Point3 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : Point3 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Point3 As Vector2
C#
public Vector2 Point3

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


Type Field

[image]
ActiveReports 19 .NET Edition
Type Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > PathEx.Segment Structure : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Type As PathEx.SegmentType
C#
public PathEx.SegmentType Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PathEx.Segment Structure
PathEx.Segment Members


TextMetrics Structure

[image]
ActiveReports 19 .NET Edition
TextMetrics Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetrics Structure

Glossary Item Box

Represents the metrics of a text layout.

Object Model

TextMetrics Structure

Syntax

Visual Basic (Declaration)
Public Structure TextMetrics
   Inherits System.ValueType
C#
public struct TextMetrics : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Drawing.TextMetrics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Members
GrapeCity.ActiveReports.Drawing Namespace


TextMetrics Structure Members

[image]
ActiveReports 19 .NET Edition
TextMetrics Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetrics Structure

Glossary Item Box

The following tables list the members exposed by TextMetrics.

Public Constructors

 | Name | Description
Public Constructor | TextMetrics Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | CharsFitted | Gets the number of characters fitted within the text layout.
Public Field | FirstSplitPosition | Gets the position of the first split in the text layout.
Public Field | Fitted | Gets a value indicating whether the text was fully fitted within the layout.
Public Field | Height | Gets the height of the text layout.
Public Field | LinesFilled | Gets the number of lines filled by the text layout.
Public Field | Width | Gets the width of the text layout.
Top

See Also

Reference

TextMetrics Structure
GrapeCity.ActiveReports.Drawing Namespace


TextMetrics Constructor

[image]
ActiveReports 19 .NET Edition
TextMetrics Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : TextMetrics Constructor

Glossary Item Box

Overload List

Overload | Description
TextMetrics Constructor(Single,Single,Int32,Int32,Boolean) |
TextMetrics Constructor(Single,Single,Int32,Int32,Boolean,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


TextMetrics Constructor(Single,Single,Int32,Int32,Boolean)

[image]
ActiveReports 19 .NET Edition
TextMetrics Constructor(Single,Single,Int32,Int32,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure > TextMetrics Constructor : TextMetrics Constructor(Single,Single,Int32,Int32,Boolean)

width
height
linesFilled
charsFitted
fitted

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal linesFilled As Integer, _
   ByVal charsFitted As Integer, _
   Optional ByVal fitted As Boolean _
)
C#
public TextMetrics(
   float width,
   float height,
   int linesFilled,
   int charsFitted,
   bool fitted
)

Parameters

width
height
linesFilled
charsFitted
fitted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members
Overload List


TextMetrics Constructor(Single,Single,Int32,Int32,Boolean,Int32)

[image]
ActiveReports 19 .NET Edition
TextMetrics Constructor(Single,Single,Int32,Int32,Boolean,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure > TextMetrics Constructor : TextMetrics Constructor(Single,Single,Int32,Int32,Boolean,Int32)

width
height
linesFilled
charsFitted
fitted
firstSplitPosition

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal linesFilled As Integer, _
   ByVal charsFitted As Integer, _
   ByVal fitted As Boolean, _
   ByVal firstSplitPosition As Integer _
)
C#
public TextMetrics(
   float width,
   float height,
   int linesFilled,
   int charsFitted,
   bool fitted,
   int firstSplitPosition
)

Parameters

width
height
linesFilled
charsFitted
fitted
firstSplitPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members
Overload List


TextMetrics Structure Fields

[image]
ActiveReports 19 .NET Edition
TextMetrics Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : TextMetrics Structure

Glossary Item Box

For a list of all members of this type, see TextMetrics members.

Public Fields

 | Name | Description
Public Field | CharsFitted | Gets the number of characters fitted within the text layout.
Public Field | FirstSplitPosition | Gets the position of the first split in the text layout.
Public Field | Fitted | Gets a value indicating whether the text was fully fitted within the layout.
Public Field | Height | Gets the height of the text layout.
Public Field | LinesFilled | Gets the number of lines filled by the text layout.
Public Field | Width | Gets the width of the text layout.
Top

See Also

Reference

TextMetrics Structure
GrapeCity.ActiveReports.Drawing Namespace


CharsFitted Field

[image]
ActiveReports 19 .NET Edition
CharsFitted Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : CharsFitted Field

Glossary Item Box

Gets the number of characters fitted within the text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly CharsFitted As Integer
C#
public readonly int CharsFitted

Field Value

The number of characters fitted within the text layout as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


FirstSplitPosition Field

[image]
ActiveReports 19 .NET Edition
FirstSplitPosition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : FirstSplitPosition Field

Glossary Item Box

Gets the position of the first split in the text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly FirstSplitPosition As Integer
C#
public readonly int FirstSplitPosition

Field Value

The position of the first split in the text layout as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


Fitted Field

[image]
ActiveReports 19 .NET Edition
Fitted Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : Fitted Field

Glossary Item Box

Gets a value indicating whether the text was fully fitted within the layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Fitted As Boolean
C#
public readonly bool Fitted

Field Value

A System.Boolean value. true if the text was fully fitted; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


Height Field

[image]
ActiveReports 19 .NET Edition
Height Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : Height Field

Glossary Item Box

Gets the height of the text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Height As Single
C#
public readonly float Height

Field Value

The height of the text layout as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


LinesFilled Field

[image]
ActiveReports 19 .NET Edition
LinesFilled Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : LinesFilled Field

Glossary Item Box

Gets the number of lines filled by the text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly LinesFilled As Integer
C#
public readonly int LinesFilled

Field Value

The number of lines filled by the text layout as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


Width Field

[image]
ActiveReports 19 .NET Edition
Width Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > TextMetrics Structure : Width Field

Glossary Item Box

Gets the width of the text layout.

Syntax

Visual Basic (Declaration)
Public ReadOnly Width As Single
C#
public readonly float Width

Field Value

The width of the text layout as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextMetrics Structure
TextMetrics Members


IDrawingCanvas Interface

[image]
ActiveReports 19 .NET Edition
IDrawingCanvas Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IDrawingCanvas Interface

Glossary Item Box

Defines a set of properties and methods used to render a canvas.

Syntax

Visual Basic (Declaration)
Public Interface IDrawingCanvas
C#
public interface IDrawingCanvas

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Members
GrapeCity.ActiveReports.Drawing Namespace


IDrawingCanvas Interface Members

[image]
ActiveReports 19 .NET Edition
IDrawingCanvas Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IDrawingCanvas Interface

Glossary Item Box

The following tables list the members exposed by IDrawingCanvas.

Public Properties

 | Name | Description
Property | SmoothingMode | Specifies the rendering quality for lines, curves, and the edges of filled areas.
Property | TextRenderingHint | Specifies the quality of text rendering.
Property | Transform | Gets or sets the world transformation for this object
Top

Public Methods

 | Name | Description
Method | CreateHatchBrush | Initializes a new BrushEx using specified hatch pattern and colors.
Method | CreateImage | Overloaded. Initializes a new instance of ImageEx.
Method | CreateLinearGradientBrush | Overloaded. Initializes a new BrushEx linear gradient brush object.
Method | CreatePen | Overloaded. Initializes a new instance of PenEx with the specified color and width
Method | CreateRadialGradientBrush | Creates new radial gradient BrushEx.
Method | CreateSolidBrush | Initializes a new BrushEx solid brush object of specified color.
Method | DrawAndFillPath | Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.
Method | DrawEllipse | Draws an ellipse defined by a bounding System.Drawing.RectangleF.
Method | DrawImage | Draws the specified Image object with specified size, at the specified location.
Method | DrawLine | Draws the line between specified points.
Method | DrawLines | Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Method | DrawPolygon | Draws a polygon defined by an array of System.Drawing.PointF structures
Method | DrawRectangle | Draws a rectangle rectangle specified by a RectangleF structure.
Method | DrawString | Draws the specified text string at the specified location with the specified Brush and Font objects. using the specified layout rectangle and formatting attributes of the specified StringFormat object.
Method | FillEllipse | Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures
Method | FillRectangle | Fills the interior of a rectangle specified by a RectangleF structure.
Method | IntersectClip | Overloaded. Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Method | PopState | Restores the state of this IDrawingCanvas object to the previous saved state.
Method | PushState | Saves the current state on a stack.
Top

See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Drawing Namespace


IDrawingCanvas Interface Methods

[image]
ActiveReports 19 .NET Edition
IDrawingCanvas Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IDrawingCanvas Interface

Glossary Item Box

For a list of all members of this type, see IDrawingCanvas members.

Public Methods

 | Name | Description
Method | CreateHatchBrush | Initializes a new BrushEx using specified hatch pattern and colors.
Method | CreateImage | Overloaded. Initializes a new instance of ImageEx.
Method | CreateLinearGradientBrush | Overloaded. Initializes a new BrushEx linear gradient brush object.
Method | CreatePen | Overloaded. Initializes a new instance of PenEx with the specified color and width
Method | CreateRadialGradientBrush | Creates new radial gradient BrushEx.
Method | CreateSolidBrush | Initializes a new BrushEx solid brush object of specified color.
Method | DrawAndFillPath | Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.
Method | DrawEllipse | Draws an ellipse defined by a bounding System.Drawing.RectangleF.
Method | DrawImage | Draws the specified Image object with specified size, at the specified location.
Method | DrawLine | Draws the line between specified points.
Method | DrawLines | Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Method | DrawPolygon | Draws a polygon defined by an array of System.Drawing.PointF structures
Method | DrawRectangle | Draws a rectangle rectangle specified by a RectangleF structure.
Method | DrawString | Draws the specified text string at the specified location with the specified Brush and Font objects. using the specified layout rectangle and formatting attributes of the specified StringFormat object.
Method | FillEllipse | Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures
Method | FillRectangle | Fills the interior of a rectangle specified by a RectangleF structure.
Method | IntersectClip | Overloaded. Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Method | PopState | Restores the state of this IDrawingCanvas object to the previous saved state.
Method | PushState | Saves the current state on a stack.
Top

See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Drawing Namespace


CreateHatchBrush Method

[image]
ActiveReports 19 .NET Edition
CreateHatchBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreateHatchBrush Method

hatchStyle
The hatch style.
foreColor
The foreground color.
backColor
The background color.

Glossary Item Box

Initializes a new BrushEx using specified hatch pattern and colors.

Syntax

Visual Basic (Declaration)
Function CreateHatchBrush( _
   ByVal hatchStyle As HatchStyleEx, _
   ByVal foreColor As Color, _
   ByVal backColor As Color _
) As BrushEx
C#
BrushEx CreateHatchBrush(
   HatchStyleEx hatchStyle,
   Color foreColor,
   Color backColor
)

Parameters

hatchStyle
The hatch style.
foreColor
The foreground color.
backColor
The background color.

Return Value

The hatch brush.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateImage Method

[image]
ActiveReports 19 .NET Edition
CreateImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreateImage Method

Glossary Item Box

Initializes a new instance of ImageEx.

Overload List

Overload | Description
CreateImage(ImageInfo) | Initializes a new instance of ImageEx.
CreateImage(ImageInfo,String) | Initializes a new instance of ImageEx and supplies a unique id for which the IDrawingCanvas can implement caching.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateImage(ImageInfo) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreateImage Method : CreateImage(ImageInfo) Method

image

Glossary Item Box

Initializes a new instance of ImageEx.

Syntax

Visual Basic (Declaration)
Overloads Function CreateImage( _
   ByVal image As ImageInfo _
) As ImageEx
C#
ImageEx CreateImage(
   ImageInfo image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateImage(ImageInfo,String) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreateImage Method : CreateImage(ImageInfo,String) Method

image
cacheID

Glossary Item Box

Initializes a new instance of ImageEx and supplies a unique id for which the IDrawingCanvas can implement caching.

Syntax

Visual Basic (Declaration)
Overloads Function CreateImage( _
   ByVal image As ImageInfo, _
   ByVal cacheID As String _
) As ImageEx
C#
ImageEx CreateImage(
   ImageInfo image,
   string cacheID
)

Parameters

image
cacheID

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateLinearGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreateLinearGradientBrush Method

Glossary Item Box

Initializes a new BrushEx linear gradient brush object.

Overload List

Overload | Description
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) | Initializes a new BrushEx linear gradient brush object.
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) | Create linear gradient brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

point1
point2
color1
color2
blend

Glossary Item Box

Initializes a new BrushEx linear gradient brush object.

Syntax

Visual Basic (Declaration)
Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   Optional ByVal blend As BlendEx _
) As BrushEx
C#
BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   BlendEx blend
)

Parameters

point1
point2
color1
color2
blend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

point1
Start point
point2
End point
color1
Start color
color2
End color
stops
Gradient color stops

Glossary Item Box

Create linear gradient brush

Syntax

Visual Basic (Declaration)
Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal stops As IEnumerable(Of GradientStopColor) _
) As BrushEx
C#
BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   IEnumerable<GradientStopColor> stops
)

Parameters

point1
Start point
point2
End point
color1
Start color
color2
End color
stops
Gradient color stops

Return Value

Gradient brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen Method

[image]
ActiveReports 19 .NET Edition
CreatePen Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreatePen Method

Glossary Item Box

Initializes a new instance of PenEx with the specified color and width

Overload List

Overload | Description
CreatePen(Color,Single) | Initializes a new instance of PenEx with the specified color and width
CreatePen(Color) | Initializes a new instance of PenEx with the specified color and default width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreatePen(Color,Single) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(Color,Single) Method

color
width

Glossary Item Box

Initializes a new instance of PenEx with the specified color and width

Syntax

Visual Basic (Declaration)
Overloads Function CreatePen( _
   ByVal color As Color, _
   ByVal width As Single _
) As PenEx
C#
PenEx CreatePen(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen(Color) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(Color) Method

color

Glossary Item Box

Initializes a new instance of PenEx with the specified color and default width

Syntax

Visual Basic (Declaration)
Overloads Function CreatePen( _
   ByVal color As Color _
) As PenEx
C#
PenEx CreatePen(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateRadialGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateRadialGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreateRadialGradientBrush Method

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Glossary Item Box

Creates new radial gradient BrushEx.

Syntax

Visual Basic (Declaration)
Function CreateRadialGradientBrush( _
   ByVal centerPoint As PointF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal centerColor As Color, _
   ByVal surroundingColor As Color _
) As BrushEx
C#
BrushEx CreateRadialGradientBrush(
   PointF centerPoint,
   float radiusX,
   float radiusY,
   Color centerColor,
   Color surroundingColor
)

Parameters

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateSolidBrush Method

[image]
ActiveReports 19 .NET Edition
CreateSolidBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : CreateSolidBrush Method

color

Glossary Item Box

Initializes a new BrushEx solid brush object of specified color.

Syntax

Visual Basic (Declaration)
Function CreateSolidBrush( _
   ByVal color As Color _
) As BrushEx
C#
BrushEx CreateSolidBrush(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawAndFillPath Method

[image]
ActiveReports 19 .NET Edition
DrawAndFillPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawAndFillPath Method

pen
brush
path

Glossary Item Box

Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.

Syntax

Visual Basic (Declaration)
Sub DrawAndFillPath( _
   ByVal pen As PenEx, _
   ByVal brush As BrushEx, _
   ByVal path As PathEx _
)
C#
void DrawAndFillPath(
   PenEx pen,
   BrushEx brush,
   PathEx path
)

Parameters

pen
brush
path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawEllipse Method

pen
rect

Glossary Item Box

Draws an ellipse defined by a bounding System.Drawing.RectangleF.

Syntax

Visual Basic (Declaration)
Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
void DrawEllipse(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawImage Method

image
x
y
width
height
opacity

Glossary Item Box

Draws the specified Image object with specified size, at the specified location.

Syntax

Visual Basic (Declaration)
Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   Optional ByVal opacity As Single _
)
C#
void DrawImage(
   ImageEx image,
   float x,
   float y,
   float width,
   float height,
   float opacity
)

Parameters

image
x
y
width
height
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawLine Method

pen
from
to

Glossary Item Box

Draws the line between specified points.

Syntax

Visual Basic (Declaration)
Sub DrawLine( _
   ByVal pen As PenEx, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
void DrawLine(
   PenEx pen,
   PointF from,
   PointF to
)

Parameters

pen
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawLines Method

[image]
ActiveReports 19 .NET Edition
DrawLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawLines Method

pen
polyLine

Glossary Item Box

Draws a series of line segments that connect an array of System.Drawing.PointF structures.

Syntax

Visual Basic (Declaration)
Sub DrawLines( _
   ByVal pen As PenEx, _
   ByVal polyLine() As PointF _
)
C#
void DrawLines(
   PenEx pen,
   PointF[] polyLine
)

Parameters

pen
polyLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawPolygon Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawPolygon Method

pen
polygon

Glossary Item Box

Draws a polygon defined by an array of System.Drawing.PointF structures

Syntax

Visual Basic (Declaration)
Sub DrawPolygon( _
   ByVal pen As PenEx, _
   ByVal polygon() As PointF _
)
C#
void DrawPolygon(
   PenEx pen,
   PointF[] polygon
)

Parameters

pen
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawRectangle Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawRectangle Method

pen
rect

Glossary Item Box

Draws a rectangle rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Sub DrawRectangle( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
void DrawRectangle(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : DrawString Method

value
font
brush
layoutRectangle
format

Glossary Item Box

Draws the specified text string at the specified location with the specified Brush and Font objects. using the specified layout rectangle and formatting attributes of the specified StringFormat object.

Syntax

Visual Basic (Declaration)
Sub DrawString( _
   ByVal value As String, _
   ByVal font As FontInfo, _
   ByVal brush As BrushEx, _
   ByVal layoutRectangle As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
void DrawString(
   string value,
   FontInfo font,
   BrushEx brush,
   RectangleF layoutRectangle,
   StringFormatEx format
)

Parameters

value
font
brush
layoutRectangle
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillEllipse Method

[image]
ActiveReports 19 .NET Edition
FillEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : FillEllipse Method

brush
rect

Glossary Item Box

Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.

Syntax

Visual Basic (Declaration)
Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
void FillEllipse(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : FillPolygon Method

brush
polygon

Glossary Item Box

Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures

Syntax

Visual Basic (Declaration)
Sub FillPolygon( _
   ByVal brush As BrushEx, _
   ByVal polygon() As PointF _
)
C#
void FillPolygon(
   BrushEx brush,
   PointF[] polygon
)

Parameters

brush
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : FillRectangle Method

brush
rect

Glossary Item Box

Fills the interior of a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Sub FillRectangle( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
void FillRectangle(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : IntersectClip Method

Glossary Item Box

Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.

Overload List

Overload | Description
IntersectClip(RectangleF) | Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
IntersectClip(PathEx) | Sets the clipping region of this Graphics object to the shape specified by a IDDPath structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IntersectClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > IntersectClip Method : IntersectClip(RectangleF) Method

rect

Glossary Item Box

Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Sub IntersectClip( _
   ByVal rect As RectangleF _
)
C#
void IntersectClip(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


IntersectClip(PathEx) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface > IntersectClip Method : IntersectClip(PathEx) Method

path

Glossary Item Box

Sets the clipping region of this Graphics object to the shape specified by a IDDPath structure.

Syntax

Visual Basic (Declaration)
Overloads Sub IntersectClip( _
   ByVal path As PathEx _
)
C#
void IntersectClip(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


PopState Method

[image]
ActiveReports 19 .NET Edition
PopState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : PopState Method

Glossary Item Box

Restores the state of this IDrawingCanvas object to the previous saved state.

Syntax

Visual Basic (Declaration)
Sub PopState()
C#
void PopState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


PushState Method

[image]
ActiveReports 19 .NET Edition
PushState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : PushState Method

Glossary Item Box

Saves the current state on a stack.

Syntax

Visual Basic (Declaration)
Sub PushState()
C#
void PushState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IDrawingCanvas Interface Properties

[image]
ActiveReports 19 .NET Edition
IDrawingCanvas Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IDrawingCanvas Interface

Glossary Item Box

For a list of all members of this type, see IDrawingCanvas members.

Public Properties

 | Name | Description
Property | SmoothingMode | Specifies the rendering quality for lines, curves, and the edges of filled areas.
Property | TextRenderingHint | Specifies the quality of text rendering.
Property | Transform | Gets or sets the world transformation for this object
Top

See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Drawing Namespace


SmoothingMode Property

[image]
ActiveReports 19 .NET Edition
SmoothingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : SmoothingMode Property

Glossary Item Box

Specifies the rendering quality for lines, curves, and the edges of filled areas.

Syntax

Visual Basic (Declaration)
Property SmoothingMode As SmoothingModeEx
C#
SmoothingModeEx SmoothingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


TextRenderingHint Property

[image]
ActiveReports 19 .NET Edition
TextRenderingHint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : TextRenderingHint Property

Glossary Item Box

Specifies the quality of text rendering.

Syntax

Visual Basic (Declaration)
Property TextRenderingHint As TextRenderingHintEx
C#
TextRenderingHintEx TextRenderingHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


Transform Property

[image]
ActiveReports 19 .NET Edition
Transform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IDrawingCanvas Interface : Transform Property

Glossary Item Box

Gets or sets the world transformation for this object

Syntax

Visual Basic (Declaration)
Property Transform As Matrix3x2
C#
Matrix3x2 Transform {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IFontNameResolver Interface

[image]
ActiveReports 19 .NET Edition
IFontNameResolver Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IFontNameResolver Interface

Glossary Item Box

Encapsulates string font name resolver.

Syntax

Visual Basic (Declaration)
Public Interface IFontNameResolver
C#
public interface IFontNameResolver

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFontNameResolver Members
GrapeCity.ActiveReports.Drawing Namespace


IFontNameResolver Interface Members

[image]
ActiveReports 19 .NET Edition
IFontNameResolver Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IFontNameResolver Interface

Glossary Item Box

The following tables list the members exposed by IFontNameResolver.

Public Methods

 | Name | Description
Method | GetFontFamily | Gets font name for generic fonts, check if specified font installed.
Top

See Also

Reference

IFontNameResolver Interface
GrapeCity.ActiveReports.Drawing Namespace


IFontNameResolver Interface Methods

[image]
ActiveReports 19 .NET Edition
IFontNameResolver Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IFontNameResolver Interface

Glossary Item Box

For a list of all members of this type, see IFontNameResolver members.

Public Methods

 | Name | Description
Method | GetFontFamily | Gets font name for generic fonts, check if specified font installed.
Top

See Also

Reference

IFontNameResolver Interface
GrapeCity.ActiveReports.Drawing Namespace


GetFontFamily Method

[image]
ActiveReports 19 .NET Edition
GetFontFamily Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IFontNameResolver Interface : GetFontFamily Method

fontFamily

Glossary Item Box

Gets font name for generic fonts, check if specified font installed.

Syntax

Visual Basic (Declaration)
Function GetFontFamily( _
   ByVal fontFamily As String _
) As String
C#
string GetFontFamily(
   string fontFamily
)

Parameters

fontFamily

Return Value

Font name, or null if font not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFontNameResolver Interface
IFontNameResolver Members


IGraphicsRenderer Interface

[image]
ActiveReports 19 .NET Edition
IGraphicsRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IGraphicsRenderer Interface

Glossary Item Box

Renderer base interface that ReportItems can use to draw graphics on for items such as printing, our winforms viewer and PDF.

Syntax

Visual Basic (Declaration)
Public Interface IGraphicsRenderer
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer
C#
public interface IGraphicsRenderer : GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGraphicsRenderer Members
GrapeCity.ActiveReports.Drawing Namespace


IGraphicsRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IGraphicsRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IGraphicsRenderer Interface

Glossary Item Box

The following tables list the members exposed by IGraphicsRenderer.

Public Methods

 | Name | Description
Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GraphicsRenderContext
Top

See Also

Reference

IGraphicsRenderer Interface
GrapeCity.ActiveReports.Drawing Namespace


IGraphicsRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
IGraphicsRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : IGraphicsRenderer Interface

Glossary Item Box

For a list of all members of this type, see IGraphicsRenderer members.

Public Methods

 | Name | Description
Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GraphicsRenderContext
Top

See Also

Reference

IGraphicsRenderer Interface
GrapeCity.ActiveReports.Drawing Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > IGraphicsRenderer Interface : Render Method

context
area

Glossary Item Box

Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GraphicsRenderContext

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal context As GraphicsRenderContext, _
   ByVal area As ILayoutArea _
)
C#
void Render(
   GraphicsRenderContext context,
   ILayoutArea area
)

Parameters

context
area

Remarks

Each GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea represent GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem or its part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGraphicsRenderer Interface
IGraphicsRenderer Members


ITextMetricsProvider Interface

[image]
ActiveReports 19 .NET Edition
ITextMetricsProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextMetricsProvider Interface

Glossary Item Box

Encapsulates string measurements and related functionality.

Syntax

Visual Basic (Declaration)
Public Interface ITextMetricsProvider
C#
public interface ITextMetricsProvider

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMetricsProvider Members
GrapeCity.ActiveReports.Drawing Namespace


ITextMetricsProvider Interface Members

[image]
ActiveReports 19 .NET Edition
ITextMetricsProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextMetricsProvider Interface

Glossary Item Box

The following tables list the members exposed by ITextMetricsProvider.

Public Methods

 | Name | Description
Method | GetFontFamily | Gets font family for generic fonts, check if specified font installed.
Method | GetFontMetrics | Gets line spacing in twips.
Method | MeasureString | Measures string content based on currently selected font, device capabilities, string format.
Top

See Also

Reference

ITextMetricsProvider Interface
GrapeCity.ActiveReports.Drawing Namespace


ITextMetricsProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
ITextMetricsProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextMetricsProvider Interface

Glossary Item Box

For a list of all members of this type, see ITextMetricsProvider members.

Public Methods

 | Name | Description
Method | GetFontFamily | Gets font family for generic fonts, check if specified font installed.
Method | GetFontMetrics | Gets line spacing in twips.
Method | MeasureString | Measures string content based on currently selected font, device capabilities, string format.
Top

See Also

Reference

ITextMetricsProvider Interface
GrapeCity.ActiveReports.Drawing Namespace


GetFontFamily Method

[image]
ActiveReports 19 .NET Edition
GetFontFamily Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ITextMetricsProvider Interface : GetFontFamily Method

fontFamily

Glossary Item Box

Gets font family for generic fonts, check if specified font installed.

Syntax

Visual Basic (Declaration)
Function GetFontFamily( _
   ByVal fontFamily As String _
) As String
C#
string GetFontFamily(
   string fontFamily
)

Parameters

fontFamily

Return Value

Font family name, or null if font not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMetricsProvider Interface
ITextMetricsProvider Members


GetFontMetrics Method

[image]
ActiveReports 19 .NET Edition
GetFontMetrics Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ITextMetricsProvider Interface : GetFontMetrics Method

font

Glossary Item Box

Gets line spacing in twips.

Syntax

Visual Basic (Declaration)
Function GetFontMetrics( _
   ByVal font As FontInfo _
) As FontMetrics
C#
FontMetrics GetFontMetrics(
   FontInfo font
)

Parameters

font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMetricsProvider Interface
ITextMetricsProvider Members


MeasureString Method

[image]
ActiveReports 19 .NET Edition
MeasureString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ITextMetricsProvider Interface : MeasureString Method

font
contentText
stringFormat
boundWidth
boundHeight

Glossary Item Box

Measures string content based on currently selected font, device capabilities, string format.

Syntax

Visual Basic (Declaration)
Function MeasureString( _
   ByVal font As FontInfo, _
   ByVal contentText As String, _
   ByVal stringFormat As StringFormatEx, _
   Optional ByVal boundWidth As Single, _
   Optional ByVal boundHeight As Single _
) As TextMetrics
C#
TextMetrics MeasureString(
   FontInfo font,
   string contentText,
   StringFormatEx stringFormat,
   float boundWidth,
   float boundHeight
)

Parameters

font
contentText
stringFormat
boundWidth
boundHeight

Return Value

The TextMetrics structure that contains numbers of lines of text and total chars fitted in available bounds and minimal desired bounds to fit the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMetricsProvider Interface
ITextMetricsProvider Members


ITextRenderingService Interface

[image]
ActiveReports 19 .NET Edition
ITextRenderingService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextRenderingService Interface

Glossary Item Box

Allows to render text. (Used in svg rendering.)

Syntax

Visual Basic (Declaration)
Public Interface ITextRenderingService
C#
public interface ITextRenderingService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderingService Members
GrapeCity.ActiveReports.Drawing Namespace


ITextRenderingService Interface Members

[image]
ActiveReports 19 .NET Edition
ITextRenderingService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextRenderingService Interface

Glossary Item Box

The following tables list the members exposed by ITextRenderingService.

Public Methods

 | Name | Description
Method | DrawStringAsPath | Draw text layout as path based on currently selected font, device capabilities, string format.
Top

See Also

Reference

ITextRenderingService Interface
GrapeCity.ActiveReports.Drawing Namespace


ITextRenderingService Interface Methods

[image]
ActiveReports 19 .NET Edition
ITextRenderingService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace : ITextRenderingService Interface

Glossary Item Box

For a list of all members of this type, see ITextRenderingService members.

Public Methods

 | Name | Description
Method | DrawStringAsPath | Draw text layout as path based on currently selected font, device capabilities, string format.
Top

See Also

Reference

ITextRenderingService Interface
GrapeCity.ActiveReports.Drawing Namespace


DrawStringAsPath Method

[image]
ActiveReports 19 .NET Edition
DrawStringAsPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing Namespace > ITextRenderingService Interface : DrawStringAsPath Method

fontInfo
Selected font info.
text
Text content.
format
String format.
dpi
Resolution dots per inch, default value 96.

Glossary Item Box

Draw text layout as path based on currently selected font, device capabilities, string format.

Syntax

Visual Basic (Declaration)
Function DrawStringAsPath( _
   ByVal fontInfo As FontInfo, _
   ByVal text As String, _
   ByVal format As StringFormatEx, _
   ByVal dpi As Single _
) As PathEx
C#
PathEx DrawStringAsPath(
   FontInfo fontInfo,
   string text,
   StringFormatEx format,
   float dpi
)

Parameters

fontInfo
Selected font info.
text
Text content.
format
String format.
dpi
Resolution dots per inch, default value 96.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderingService Interface
ITextRenderingService Members


BinaryCanvasSerializer Class

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer Class

Glossary Item Box

Binary serializer for the MetaCanvas.

Object Model

BinaryCanvasSerializer Class

Syntax

Visual Basic (Declaration)
Public Class BinaryCanvasSerializer
   Implements IMetaCanvasItemWriter
C#
public class BinaryCanvasSerializer : IMetaCanvasItemWriter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.BinaryCanvasSerializer
GrapeCity.ActiveReports.Drawing.Serialization.FilteredBinaryCanvasSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


BinaryCanvasSerializer Class Members

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer Class

Glossary Item Box

The following tables list the members exposed by BinaryCanvasSerializer.

Public Constructors

 | Name | Description
Public Constructor | BinaryCanvasSerializer Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose |
static (Shared in Visual Basic) | ReadMeta |
Public Method | WriteItem |
Top

See Also

Reference

BinaryCanvasSerializer Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


BinaryCanvasSerializer Constructor

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer Class : BinaryCanvasSerializer Constructor

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
C#
public BinaryCanvasSerializer(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer Class
BinaryCanvasSerializer Members


BinaryCanvasSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer Class

Glossary Item Box

For a list of all members of this type, see BinaryCanvasSerializer members.

Public Methods

 | Name | Description
Public Method | Dispose |
static (Shared in Visual Basic) | ReadMeta |
Public Method | WriteItem |
Top

See Also

Reference

BinaryCanvasSerializer Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer Class
BinaryCanvasSerializer Members


ReadMeta Method

[image]
ActiveReports 19 .NET Edition
ReadMeta Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer Class : ReadMeta Method

reader
beforeReadItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ReadMeta( _
   ByVal reader As BinaryReader, _
   Optional ByVal beforeReadItem As Func(Of BinaryCanvasSerializer.ReadContext,Integer,MetaCanvas.CanvasItem) _
) As IEnumerable(Of MetaCanvas.CanvasItem)
C#
public static IEnumerable<MetaCanvas.CanvasItem> ReadMeta(
   BinaryReader reader,
   Func<BinaryCanvasSerializer.ReadContext,int,MetaCanvas.CanvasItem> beforeReadItem
)

Parameters

reader
beforeReadItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer Class
BinaryCanvasSerializer Members


WriteItem Method

[image]
ActiveReports 19 .NET Edition
WriteItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer Class : WriteItem Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteItem( _
   ByVal item As MetaCanvas.CanvasItem _
)
C#
public virtual void WriteItem(
   MetaCanvas.CanvasItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer Class
BinaryCanvasSerializer Members


BinaryCanvasSerializer.ReadContext Class

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer.ReadContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer.ReadContext Class

Glossary Item Box

Object Model

BinaryCanvasSerializer.ReadContext Class

Syntax

Visual Basic (Declaration)
Public Class BinaryCanvasSerializer.ReadContext
C#
public class BinaryCanvasSerializer.ReadContext

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.BinaryCanvasSerializer.ReadContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


BinaryCanvasSerializer.ReadContext Class Members

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer.ReadContext Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer.ReadContext Class

Glossary Item Box

The following tables list the members exposed by BinaryCanvasSerializer.ReadContext.

Public Constructors

 | Name | Description
Public Constructor | BinaryCanvasSerializer.ReadContext Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brushes |
Public Field | Fonts |
Public Field | Formats |
Public Field | Pens |
Top

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


BinaryCanvasSerializer.ReadContext Constructor

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer.ReadContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer.ReadContext Class : BinaryCanvasSerializer.ReadContext Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BinaryCanvasSerializer.ReadContext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
BinaryCanvasSerializer.ReadContext Members


BinaryCanvasSerializer.ReadContext Class Fields

[image]
ActiveReports 19 .NET Edition
BinaryCanvasSerializer.ReadContext Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : BinaryCanvasSerializer.ReadContext Class

Glossary Item Box

For a list of all members of this type, see BinaryCanvasSerializer.ReadContext members.

Public Fields

 | Name | Description
Public Field | Brushes |
Public Field | Fonts |
Public Field | Formats |
Public Field | Pens |
Top

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brushes Field

[image]
ActiveReports 19 .NET Edition
Brushes Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer.ReadContext Class : Brushes Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Brushes As List(Of BrushEx)
C#
public List<BrushEx> Brushes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
BinaryCanvasSerializer.ReadContext Members


Fonts Field

[image]
ActiveReports 19 .NET Edition
Fonts Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer.ReadContext Class : Fonts Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Fonts As List(Of FontInfo)
C#
public List<FontInfo> Fonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
BinaryCanvasSerializer.ReadContext Members


Formats Field

[image]
ActiveReports 19 .NET Edition
Formats Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer.ReadContext Class : Formats Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Formats As List(Of StringFormatEx)
C#
public List<StringFormatEx> Formats

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
BinaryCanvasSerializer.ReadContext Members


Pens Field

[image]
ActiveReports 19 .NET Edition
Pens Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > BinaryCanvasSerializer.ReadContext Class : Pens Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Pens As List(Of MetaCanvas.MetaPen)
C#
public List<MetaCanvas.MetaPen> Pens

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryCanvasSerializer.ReadContext Class
BinaryCanvasSerializer.ReadContext Members


CanvasMetaExtensions Class

[image]
ActiveReports 19 .NET Edition
CanvasMetaExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : CanvasMetaExtensions Class

Glossary Item Box

Represents extension methods for GrapeCity.ActiveReports.Drawing.IDrawingCanvas

Object Model

CanvasMetaExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CanvasMetaExtensions
C#
public static class CanvasMetaExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.CanvasMetaExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasMetaExtensions Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


CanvasMetaExtensions Class Members

[image]
ActiveReports 19 .NET Edition
CanvasMetaExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : CanvasMetaExtensions Class

Glossary Item Box

The following tables list the members exposed by CanvasMetaExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawMetaStream | Draws the graphics from provided stream to the provided GrapeCity.ActiveReports.Drawing.IDrawingCanvas object.
Top

See Also

Reference

CanvasMetaExtensions Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


CanvasMetaExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
CanvasMetaExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : CanvasMetaExtensions Class

Glossary Item Box

For a list of all members of this type, see CanvasMetaExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawMetaStream | Draws the graphics from provided stream to the provided GrapeCity.ActiveReports.Drawing.IDrawingCanvas object.
Top

See Also

Reference

CanvasMetaExtensions Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


DrawMetaStream Method

[image]
ActiveReports 19 .NET Edition
DrawMetaStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > CanvasMetaExtensions Class : DrawMetaStream Method

canvas
The GrapeCity.ActiveReports.Drawing.IDrawingCanvas object to the graphics be drawn on.
stream
The stream containing binary representation of the graphics (produced by MetaCanvas).
delayedContent
The store of patches to be graphics drawn with.
images
The external images store.
deviceKind
The device filter.

Glossary Item Box

Draws the graphics from provided stream to the provided GrapeCity.ActiveReports.Drawing.IDrawingCanvas object.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawMetaStream( _
   ByVal canvas As IDrawingCanvas, _
   ByVal stream As Stream, _
   ByVal delayedContent As ReportMetaCanvas.DelayedContent, _
   ByVal images As IImageStore, _
   ByVal deviceKind As TargetDeviceKind _
)
C#
public static void DrawMetaStream(
   IDrawingCanvas canvas,
   Stream stream,
   ReportMetaCanvas.DelayedContent delayedContent,
   IImageStore images,
   TargetDeviceKind deviceKind
)

Parameters

canvas
The GrapeCity.ActiveReports.Drawing.IDrawingCanvas object to the graphics be drawn on.
stream
The stream containing binary representation of the graphics (produced by MetaCanvas).
delayedContent
The store of patches to be graphics drawn with.
images
The external images store.
deviceKind
The device filter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasMetaExtensions Class
CanvasMetaExtensions Members


FilteredBinaryCanvasSerializer Class

[image]
ActiveReports 19 .NET Edition
FilteredBinaryCanvasSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredBinaryCanvasSerializer Class

Glossary Item Box

Binary serializer for the FilteredMetaCanvas.

Object Model

FilteredBinaryCanvasSerializer Class

Syntax

Visual Basic (Declaration)
Public Class FilteredBinaryCanvasSerializer
   Inherits BinaryCanvasSerializer
   Implements IMetaCanvasItemWriter
C#
public class FilteredBinaryCanvasSerializer : BinaryCanvasSerializer, IMetaCanvasItemWriter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.BinaryCanvasSerializer
GrapeCity.ActiveReports.Drawing.Serialization.FilteredBinaryCanvasSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredBinaryCanvasSerializer Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


FilteredBinaryCanvasSerializer Class Members

[image]
ActiveReports 19 .NET Edition
FilteredBinaryCanvasSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredBinaryCanvasSerializer Class

Glossary Item Box

The following tables list the members exposed by FilteredBinaryCanvasSerializer.

Public Constructors

 | Name | Description
Public Constructor | FilteredBinaryCanvasSerializer Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadMeta |
Public Method | WriteItem | Overridden.
Top

See Also

Reference

FilteredBinaryCanvasSerializer Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


FilteredBinaryCanvasSerializer Constructor

[image]
ActiveReports 19 .NET Edition
FilteredBinaryCanvasSerializer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredBinaryCanvasSerializer Class : FilteredBinaryCanvasSerializer Constructor

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
C#
public FilteredBinaryCanvasSerializer(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredBinaryCanvasSerializer Class
FilteredBinaryCanvasSerializer Members


FilteredBinaryCanvasSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
FilteredBinaryCanvasSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredBinaryCanvasSerializer Class

Glossary Item Box

For a list of all members of this type, see FilteredBinaryCanvasSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadMeta |
Public Method | WriteItem | Overridden.
Top

See Also

Reference

FilteredBinaryCanvasSerializer Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ReadMeta Method

[image]
ActiveReports 19 .NET Edition
ReadMeta Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredBinaryCanvasSerializer Class : ReadMeta Method

reader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ReadMeta( _
   ByVal reader As BinaryReader _
) As IEnumerable(Of MetaCanvas.CanvasItem)
C#
public static IEnumerable<MetaCanvas.CanvasItem> ReadMeta(
   BinaryReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredBinaryCanvasSerializer Class
FilteredBinaryCanvasSerializer Members


WriteItem Method

[image]
ActiveReports 19 .NET Edition
WriteItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredBinaryCanvasSerializer Class : WriteItem Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteItem( _
   ByVal item As MetaCanvas.CanvasItem _
)
C#
public override void WriteItem(
   MetaCanvas.CanvasItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredBinaryCanvasSerializer Class
FilteredBinaryCanvasSerializer Members


FilteredMetaCanvas Class

[image]
ActiveReports 19 .NET Edition
FilteredMetaCanvas Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredMetaCanvas Class

Glossary Item Box

Represents MetaCanvas with draw-time filtering support.

Object Model

FilteredMetaCanvas Class

Syntax

Visual Basic (Declaration)
Public Class FilteredMetaCanvas
   Inherits MetaCanvas
   Implements GrapeCity.ActiveReports.Drawing.IDrawingCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchableCanvas
C#
public class FilteredMetaCanvas : MetaCanvas, GrapeCity.ActiveReports.Drawing.IDrawingCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchableCanvas

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas
GrapeCity.ActiveReports.Drawing.Serialization.FilteredMetaCanvas
GrapeCity.ActiveReports.Drawing.Serialization.ReportMetaCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


FilteredMetaCanvas Class Members

[image]
ActiveReports 19 .NET Edition
FilteredMetaCanvas Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredMetaCanvas Class

Glossary Item Box

The following tables list the members exposed by FilteredMetaCanvas.

Public Methods

 | Name | Description
Public Method | ApplyPatchToString |
static (Shared in Visual Basic) | Draw |
Public Method | DrawPatchableString |
Public Method | GroupEnd |
Public Method | GroupStart |
Public Method | SetTargetDevice |
Top

See Also

Reference

FilteredMetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


FilteredMetaCanvas Class Methods

[image]
ActiveReports 19 .NET Edition
FilteredMetaCanvas Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : FilteredMetaCanvas Class

Glossary Item Box

For a list of all members of this type, see FilteredMetaCanvas members.

Public Methods

 | Name | Description
Public Method | ApplyPatchToString |
static (Shared in Visual Basic) | Draw |
Public Method | DrawPatchableString |
Public Method | GroupEnd |
Public Method | GroupStart |
Public Method | SetTargetDevice |
Top

See Also

Reference

FilteredMetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ApplyPatchToString Method

[image]
ActiveReports 19 .NET Edition
ApplyPatchToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : ApplyPatchToString Method

id
patch

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyPatchToString( _
   ByVal id As PatchTargetId, _
   ByVal patch As StringPatch _
)
C#
public void ApplyPatchToString(
   PatchTargetId id,
   StringPatch patch
)

Parameters

id
patch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


Draw Method

[image]
ActiveReports 19 .NET Edition
Draw Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : Draw Method

canvas
stream
delayed
images
deviceKind

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Draw( _
   ByVal canvas As IDrawingCanvas, _
   ByVal stream As Stream, _
   ByVal delayed As ReportMetaCanvas.DelayedContent, _
   ByVal images As IImageStore, _
   ByVal deviceKind As TargetDeviceKind _
)
C#
public static void Draw(
   IDrawingCanvas canvas,
   Stream stream,
   ReportMetaCanvas.DelayedContent delayed,
   IImageStore images,
   TargetDeviceKind deviceKind
)

Parameters

canvas
stream
delayed
images
deviceKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


DrawPatchableString Method

[image]
ActiveReports 19 .NET Edition
DrawPatchableString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : DrawPatchableString Method

id
text
font
brush
bounds
format

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawPatchableString( _
   ByVal id As PatchTargetId, _
   ByVal text As String, _
   ByVal font As FontInfo, _
   ByVal brush As BrushEx, _
   ByVal bounds As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
public void DrawPatchableString(
   PatchTargetId id,
   string text,
   FontInfo font,
   BrushEx brush,
   RectangleF bounds,
   StringFormatEx format
)

Parameters

id
text
font
brush
bounds
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


GroupEnd Method

[image]
ActiveReports 19 .NET Edition
GroupEnd Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : GroupEnd Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GroupEnd()
C#
public void GroupEnd()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


GroupStart Method

[image]
ActiveReports 19 .NET Edition
GroupStart Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : GroupStart Method

itemId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GroupStart( _
   ByVal itemId As String _
)
C#
public void GroupStart(
   string itemId
)

Parameters

itemId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


SetTargetDevice Method

[image]
ActiveReports 19 .NET Edition
SetTargetDevice Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > FilteredMetaCanvas Class : SetTargetDevice Method

td

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetTargetDevice( _
   ByVal td As TargetDeviceKind _
)
C#
public void SetTargetDevice(
   TargetDeviceKind td
)

Parameters

td

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilteredMetaCanvas Class
FilteredMetaCanvas Members


MetaCanvas Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas Class

Glossary Item Box

Pure GrapeCity.ActiveReports.Drawing.IDrawingCanvas implementation which allows you to save the drawing into stream and then re-draw on to arbitrary IDrawingCanvas. It is for creation of temporary storage of preview pages. Each IDrawingCanvas's method call turns into the single or multiple CanvasItem which written than to the IMetaCanvasItemWriter DrawImage calls also stores image content into separated storage IImageWriter.

Object Model

MetaCanvas Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas
   Implements GrapeCity.ActiveReports.Drawing.IDrawingCanvas
C#
public class MetaCanvas : GrapeCity.ActiveReports.Drawing.IDrawingCanvas

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas
GrapeCity.ActiveReports.Drawing.Serialization.FilteredMetaCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.

Public Properties

 | Name | Description
Public Property | SmoothingMode |
Public Property | TextRenderingHint |
Public Property | Transform |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertBrush |
Public Method | CreateHatchBrush |
Public Method | CreateImage | Overloaded.
Public Method | CreateLinearGradientBrush | Overloaded.
Public Method | CreatePen | Overloaded.
Public Method | CreateRadialGradientBrush |
Public Method | CreateSolidBrush |
Public Method | Dispose |
static (Shared in Visual Basic) | Draw |
Public Method | DrawAndFillPath |
Public Method | DrawEllipse |
Public Method | DrawImage |
Public Method | DrawLine |
Public Method | DrawLines |
Public Method | DrawPolygon |
Public Method | DrawRectangle |
Public Method | DrawString |
Public Method | FillEllipse |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | IntersectClip | Overloaded.
Public Method | PopState |
Public Method | PushState |
Top

See Also

Reference

MetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertBrush |
Public Method | CreateHatchBrush |
Public Method | CreateImage | Overloaded.
Public Method | CreateLinearGradientBrush | Overloaded.
Public Method | CreatePen | Overloaded.
Public Method | CreateRadialGradientBrush |
Public Method | CreateSolidBrush |
Public Method | Dispose |
static (Shared in Visual Basic) | Draw |
Public Method | DrawAndFillPath |
Public Method | DrawEllipse |
Public Method | DrawImage |
Public Method | DrawLine |
Public Method | DrawLines |
Public Method | DrawPolygon |
Public Method | DrawRectangle |
Public Method | DrawString |
Public Method | FillEllipse |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | IntersectClip | Overloaded.
Public Method | PopState |
Public Method | PushState |
Top

See Also

Reference

MetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ConvertBrush Method

[image]
ActiveReports 19 .NET Edition
ConvertBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : ConvertBrush Method

canvas
brush

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertBrush( _
   ByVal canvas As IDrawingCanvas, _
   ByVal brush As BrushEx _
) As BrushEx
C#
public static BrushEx ConvertBrush(
   IDrawingCanvas canvas,
   BrushEx brush
)

Parameters

canvas
brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreateHatchBrush Method

[image]
ActiveReports 19 .NET Edition
CreateHatchBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreateHatchBrush Method

hatchStyle
foreColor
backColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateHatchBrush( _
   ByVal hatchStyle As HatchStyleEx, _
   ByVal foreColor As Color, _
   ByVal backColor As Color _
) As BrushEx
C#
public BrushEx CreateHatchBrush(
   HatchStyleEx hatchStyle,
   Color foreColor,
   Color backColor
)

Parameters

hatchStyle
foreColor
backColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreateImage Method

[image]
ActiveReports 19 .NET Edition
CreateImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreateImage Method

Glossary Item Box

Overload List

Overload | Description
CreateImage(ImageInfo) |
CreateImage(ImageInfo,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreateImage(ImageInfo) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreateImage Method : CreateImage(ImageInfo) Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateImage( _
   ByVal image As ImageInfo _
) As ImageEx
C#
public ImageEx CreateImage(
   ImageInfo image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreateImage(ImageInfo,String) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreateImage Method : CreateImage(ImageInfo,String) Method

image
cacheId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateImage( _
   ByVal image As ImageInfo, _
   ByVal cacheId As String _
) As ImageEx
C#
public ImageEx CreateImage(
   ImageInfo image,
   string cacheId
)

Parameters

image
cacheId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreateLinearGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreateLinearGradientBrush Method

Glossary Item Box

Overload List

Overload | Description
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) |
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

point1
point2
color1
color2
blend

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   Optional ByVal blend As BlendEx _
) As BrushEx
C#
public BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   BlendEx blend
)

Parameters

point1
point2
color1
color2
blend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

point1
point2
color1
color2
stops

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal stops As IEnumerable(Of GradientStopColor) _
) As BrushEx
C#
public BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   IEnumerable<GradientStopColor> stops
)

Parameters

point1
point2
color1
color2
stops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreatePen Method

[image]
ActiveReports 19 .NET Edition
CreatePen Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreatePen Method

Glossary Item Box

Overload List

Overload | Description
CreatePen(Color,Single) |
CreatePen(Color) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreatePen(Color,Single) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreatePen Method : CreatePen(Color,Single) Method

color
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreatePen( _
   ByVal color As Color, _
   ByVal width As Single _
) As PenEx
C#
public PenEx CreatePen(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreatePen(Color) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > CreatePen Method : CreatePen(Color) Method

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreatePen( _
   ByVal color As Color _
) As PenEx
C#
public PenEx CreatePen(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


CreateRadialGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateRadialGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreateRadialGradientBrush Method

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateRadialGradientBrush( _
   ByVal centerPoint As PointF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal centerColor As Color, _
   ByVal surroundingColor As Color _
) As BrushEx
C#
public BrushEx CreateRadialGradientBrush(
   PointF centerPoint,
   float radiusX,
   float radiusY,
   Color centerColor,
   Color surroundingColor
)

Parameters

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


CreateSolidBrush Method

[image]
ActiveReports 19 .NET Edition
CreateSolidBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : CreateSolidBrush Method

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateSolidBrush( _
   ByVal color As Color _
) As BrushEx
C#
public BrushEx CreateSolidBrush(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


Draw Method

[image]
ActiveReports 19 .NET Edition
Draw Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : Draw Method

canvas
items
images
beforeItemDraw

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Draw( _
   ByVal canvas As IDrawingCanvas, _
   ByVal items As IEnumerable(Of MetaCanvas.CanvasItem), _
   ByVal images As IImageStore, _
   Optional ByVal beforeItemDraw As Func(Of MetaCanvas.CanvasItem,Boolean) _
)
C#
public static void Draw(
   IDrawingCanvas canvas,
   IEnumerable<MetaCanvas.CanvasItem> items,
   IImageStore images,
   Func<MetaCanvas.CanvasItem,bool> beforeItemDraw
)

Parameters

canvas
items
images
beforeItemDraw

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawAndFillPath Method

[image]
ActiveReports 19 .NET Edition
DrawAndFillPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawAndFillPath Method

pen
brush
path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawAndFillPath( _
   ByVal pen As PenEx, _
   ByVal brush As BrushEx, _
   ByVal path As PathEx _
)
C#
public void DrawAndFillPath(
   PenEx pen,
   BrushEx brush,
   PathEx path
)

Parameters

pen
brush
path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawEllipse Method

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
public void DrawEllipse(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawImage Method

image
x
y
width
height
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   Optional ByVal opacity As Single _
)
C#
public void DrawImage(
   ImageEx image,
   float x,
   float y,
   float width,
   float height,
   float opacity
)

Parameters

image
x
y
width
height
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawLine Method

pen
from
to

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
   ByVal pen As PenEx, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
public void DrawLine(
   PenEx pen,
   PointF from,
   PointF to
)

Parameters

pen
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawLines Method

[image]
ActiveReports 19 .NET Edition
DrawLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawLines Method

pen
polyLine

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawLines( _
   ByVal pen As PenEx, _
   ByVal polyLine() As PointF _
)
C#
public void DrawLines(
   PenEx pen,
   PointF[] polyLine
)

Parameters

pen
polyLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawPolygon Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawPolygon Method

pen
polygon

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawPolygon( _
   ByVal pen As PenEx, _
   ByVal polygon() As PointF _
)
C#
public void DrawPolygon(
   PenEx pen,
   PointF[] polygon
)

Parameters

pen
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawRectangle Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawRectangle Method

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawRectangle( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
public void DrawRectangle(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : DrawString Method

value
font
brush
layoutRectangle
format

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawString( _
   ByVal value As String, _
   ByVal font As FontInfo, _
   ByVal brush As BrushEx, _
   ByVal layoutRectangle As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
public void DrawString(
   string value,
   FontInfo font,
   BrushEx brush,
   RectangleF layoutRectangle,
   StringFormatEx format
)

Parameters

value
font
brush
layoutRectangle
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


FillEllipse Method

[image]
ActiveReports 19 .NET Edition
FillEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : FillEllipse Method

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public void FillEllipse(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : FillPolygon Method

brush
polygon

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillPolygon( _
   ByVal brush As BrushEx, _
   ByVal polygon() As PointF _
)
C#
public void FillPolygon(
   BrushEx brush,
   PointF[] polygon
)

Parameters

brush
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : FillRectangle Method

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillRectangle( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public void FillRectangle(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : IntersectClip Method

Glossary Item Box

Overload List

Overload | Description
IntersectClip(RectangleF) |
IntersectClip(PathEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


IntersectClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > IntersectClip Method : IntersectClip(RectangleF) Method

rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal rect As RectangleF _
)
C#
public void IntersectClip(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


IntersectClip(PathEx) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class > IntersectClip Method : IntersectClip(PathEx) Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal path As PathEx _
)
C#
public void IntersectClip(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members
Overload List


PopState Method

[image]
ActiveReports 19 .NET Edition
PopState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : PopState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PopState()
C#
public void PopState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


PushState Method

[image]
ActiveReports 19 .NET Edition
PushState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : PushState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PushState()
C#
public void PushState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


MetaCanvas Class Properties

[image]
ActiveReports 19 .NET Edition
MetaCanvas Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas members.

Public Properties

 | Name | Description
Public Property | SmoothingMode |
Public Property | TextRenderingHint |
Public Property | Transform |
Top

See Also

Reference

MetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


SmoothingMode Property

[image]
ActiveReports 19 .NET Edition
SmoothingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : SmoothingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SmoothingMode As SmoothingModeEx
C#
public SmoothingModeEx SmoothingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


TextRenderingHint Property

[image]
ActiveReports 19 .NET Edition
TextRenderingHint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : TextRenderingHint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextRenderingHint As TextRenderingHintEx
C#
public TextRenderingHintEx TextRenderingHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


Transform Property

[image]
ActiveReports 19 .NET Edition
Transform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas Class : Transform Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Transform As Matrix3x2
C#
public Matrix3x2 Transform {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas Class
MetaCanvas Members


MetaCanvas.CanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.CanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.CanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.CanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.CanvasItem
C#
public class MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawAndFillPathCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawEllipseCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawImageCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawLineCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawLinesCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawPolygonCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawRectangleCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawStringCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillEllipseCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillPolygonCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillRectangleCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.IntersectClipPathCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.IntersectClipRectCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.PopStateCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.PushStateCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetSmoothingModeCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetTextRenderingHintCanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetTransformCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.CanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.CanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.CanvasItem Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.CanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.CanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.CanvasItem Constructor |
Top

See Also

Reference

MetaCanvas.CanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.CanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.CanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.CanvasItem Class : MetaCanvas.CanvasItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MetaCanvas.CanvasItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.CanvasItem Class
MetaCanvas.CanvasItem Members


MetaCanvas.DrawAndFillPathCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawAndFillPathCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawAndFillPathCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawAndFillPathCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawAndFillPathCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawAndFillPathCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawAndFillPathCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawAndFillPathCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawAndFillPathCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawAndFillPathCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawAndFillPathCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawAndFillPathCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Path |
Public Field | Pen |
Top

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawAndFillPathCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawAndFillPathCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawAndFillPathCanvasItem Class : MetaCanvas.DrawAndFillPathCanvasItem Constructor

pen
brush
path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As MetaCanvas.MetaPen, _
   ByVal brush As BrushEx, _
   ByVal path As PathEx _
)
C#
public MetaCanvas.DrawAndFillPathCanvasItem(
   MetaCanvas.MetaPen pen,
   BrushEx brush,
   PathEx path
)

Parameters

pen
brush
path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
MetaCanvas.DrawAndFillPathCanvasItem Members


MetaCanvas.DrawAndFillPathCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawAndFillPathCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawAndFillPathCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawAndFillPathCanvasItem members.

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Path |
Public Field | Pen |
Top

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brush Field

[image]
ActiveReports 19 .NET Edition
Brush Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawAndFillPathCanvasItem Class : Brush Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Brush As BrushEx
C#
public readonly BrushEx Brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
MetaCanvas.DrawAndFillPathCanvasItem Members


Path Field

[image]
ActiveReports 19 .NET Edition
Path Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawAndFillPathCanvasItem Class : Path Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Path As PathEx
C#
public readonly PathEx Path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
MetaCanvas.DrawAndFillPathCanvasItem Members


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawAndFillPathCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Pen As MetaCanvas.MetaPen
C#
public readonly MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawAndFillPathCanvasItem Class
MetaCanvas.DrawAndFillPathCanvasItem Members


MetaCanvas.DrawEllipseCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawEllipseCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawEllipseCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawEllipseCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawEllipseCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawEllipseCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawEllipseCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawEllipseCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawEllipseCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawEllipseCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawEllipseCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawEllipseCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawEllipseCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawEllipseCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawEllipseCanvasItem Class : MetaCanvas.DrawEllipseCanvasItem Constructor

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As MetaCanvas.MetaPen, _
   ByVal rect As RectangleF _
)
C#
public MetaCanvas.DrawEllipseCanvasItem(
   MetaCanvas.MetaPen pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Class
MetaCanvas.DrawEllipseCanvasItem Members


MetaCanvas.DrawEllipseCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawEllipseCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawEllipseCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawEllipseCanvasItem members.

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawEllipseCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Pen As MetaCanvas.MetaPen
C#
public readonly MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Class
MetaCanvas.DrawEllipseCanvasItem Members


Rect Field

[image]
ActiveReports 19 .NET Edition
Rect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawEllipseCanvasItem Class : Rect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Rect As RectangleF
C#
public readonly RectangleF Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawEllipseCanvasItem Class
MetaCanvas.DrawEllipseCanvasItem Members


MetaCanvas.DrawImageCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawImageCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawImageCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawImageCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawImageCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawImageCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawImageCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawImageCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawImageCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawImageCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawImageCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawImageCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | CacheId |
Public Field | ImageInfoId |
Public Field | Opacity |
Public Field | RectangleF |
Top

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawImageCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawImageCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawImageCanvasItem Class : MetaCanvas.DrawImageCanvasItem Constructor

imageInfoId
rectangleF
opacity
cacheId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imageInfoId As Integer, _
   ByVal rectangleF As RectangleF, _
   ByVal opacity As Single, _
   ByVal cacheId As String _
)
C#
public MetaCanvas.DrawImageCanvasItem(
   int imageInfoId,
   RectangleF rectangleF,
   float opacity,
   string cacheId
)

Parameters

imageInfoId
rectangleF
opacity
cacheId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
MetaCanvas.DrawImageCanvasItem Members


MetaCanvas.DrawImageCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawImageCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawImageCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawImageCanvasItem members.

Public Fields

 | Name | Description
Public Field | CacheId |
Public Field | ImageInfoId |
Public Field | Opacity |
Public Field | RectangleF |
Top

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


CacheId Field

[image]
ActiveReports 19 .NET Edition
CacheId Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawImageCanvasItem Class : CacheId Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly CacheId As String
C#
public readonly string CacheId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
MetaCanvas.DrawImageCanvasItem Members


ImageInfoId Field

[image]
ActiveReports 19 .NET Edition
ImageInfoId Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawImageCanvasItem Class : ImageInfoId Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ImageInfoId As Integer
C#
public readonly int ImageInfoId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
MetaCanvas.DrawImageCanvasItem Members


Opacity Field

[image]
ActiveReports 19 .NET Edition
Opacity Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawImageCanvasItem Class : Opacity Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Opacity As Single
C#
public readonly float Opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
MetaCanvas.DrawImageCanvasItem Members


RectangleF Field

[image]
ActiveReports 19 .NET Edition
RectangleF Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawImageCanvasItem Class : RectangleF Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RectangleF As RectangleF
C#
public readonly RectangleF RectangleF

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawImageCanvasItem Class
MetaCanvas.DrawImageCanvasItem Members


MetaCanvas.DrawLineCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLineCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLineCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawLineCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawLineCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawLineCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawLineCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLineCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawLineCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLineCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLineCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawLineCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawLineCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | From |
Public Field | Pen |
Public Field | To |
Top

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawLineCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLineCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLineCanvasItem Class : MetaCanvas.DrawLineCanvasItem Constructor

clone
from
to

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal clone As MetaCanvas.MetaPen, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
public MetaCanvas.DrawLineCanvasItem(
   MetaCanvas.MetaPen clone,
   PointF from,
   PointF to
)

Parameters

clone
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
MetaCanvas.DrawLineCanvasItem Members


MetaCanvas.DrawLineCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLineCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLineCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawLineCanvasItem members.

Public Fields

 | Name | Description
Public Field | From |
Public Field | Pen |
Public Field | To |
Top

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


From Field

[image]
ActiveReports 19 .NET Edition
From Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLineCanvasItem Class : From Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public From As PointF
C#
public PointF From

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
MetaCanvas.DrawLineCanvasItem Members


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLineCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Pen As MetaCanvas.MetaPen
C#
public MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
MetaCanvas.DrawLineCanvasItem Members


To Field

[image]
ActiveReports 19 .NET Edition
To Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLineCanvasItem Class : To Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public To As PointF
C#
public PointF To

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLineCanvasItem Class
MetaCanvas.DrawLineCanvasItem Members


MetaCanvas.DrawLinesCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLinesCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLinesCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawLinesCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawLinesCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawLinesCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawLinesCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawLinesCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLinesCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLinesCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawLinesCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawLinesCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | PolyLine |
Top

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawLinesCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLinesCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLinesCanvasItem Class : MetaCanvas.DrawLinesCanvasItem Constructor

pen
polyLine

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As MetaCanvas.MetaPen, _
   ByVal polyLine() As PointF _
)
C#
public MetaCanvas.DrawLinesCanvasItem(
   MetaCanvas.MetaPen pen,
   PointF[] polyLine
)

Parameters

pen
polyLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Class
MetaCanvas.DrawLinesCanvasItem Members


MetaCanvas.DrawLinesCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawLinesCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawLinesCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawLinesCanvasItem members.

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | PolyLine |
Top

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLinesCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Pen As MetaCanvas.MetaPen
C#
public readonly MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Class
MetaCanvas.DrawLinesCanvasItem Members


PolyLine Field

[image]
ActiveReports 19 .NET Edition
PolyLine Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawLinesCanvasItem Class : PolyLine Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly PolyLine As PointF()
C#
public readonly PointF[] PolyLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawLinesCanvasItem Class
MetaCanvas.DrawLinesCanvasItem Members


MetaCanvas.DrawPolygonCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawPolygonCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawPolygonCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawPolygonCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawPolygonCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawPolygonCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawPolygonCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawPolygonCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawPolygonCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawPolygonCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawPolygonCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawPolygonCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Points |
Top

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawPolygonCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawPolygonCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawPolygonCanvasItem Class : MetaCanvas.DrawPolygonCanvasItem Constructor

pen
points

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As MetaCanvas.MetaPen, _
   ByVal points() As PointF _
)
C#
public MetaCanvas.DrawPolygonCanvasItem(
   MetaCanvas.MetaPen pen,
   PointF[] points
)

Parameters

pen
points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Class
MetaCanvas.DrawPolygonCanvasItem Members


MetaCanvas.DrawPolygonCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawPolygonCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawPolygonCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawPolygonCanvasItem members.

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Points |
Top

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawPolygonCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Pen As MetaCanvas.MetaPen
C#
public readonly MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Class
MetaCanvas.DrawPolygonCanvasItem Members


Points Field

[image]
ActiveReports 19 .NET Edition
Points Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawPolygonCanvasItem Class : Points Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Points As PointF()
C#
public readonly PointF[] Points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawPolygonCanvasItem Class
MetaCanvas.DrawPolygonCanvasItem Members


MetaCanvas.DrawRectangleCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawRectangleCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawRectangleCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawRectangleCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawRectangleCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawRectangleCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawRectangleCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawRectangleCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawRectangleCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawRectangleCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawRectangleCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawRectangleCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawRectangleCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawRectangleCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawRectangleCanvasItem Class : MetaCanvas.DrawRectangleCanvasItem Constructor

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As MetaCanvas.MetaPen, _
   ByVal rect As RectangleF _
)
C#
public MetaCanvas.DrawRectangleCanvasItem(
   MetaCanvas.MetaPen pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Class
MetaCanvas.DrawRectangleCanvasItem Members


MetaCanvas.DrawRectangleCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawRectangleCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawRectangleCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawRectangleCanvasItem members.

Public Fields

 | Name | Description
Public Field | Pen |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Pen Field

[image]
ActiveReports 19 .NET Edition
Pen Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawRectangleCanvasItem Class : Pen Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Pen As MetaCanvas.MetaPen
C#
public MetaCanvas.MetaPen Pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Class
MetaCanvas.DrawRectangleCanvasItem Members


Rect Field

[image]
ActiveReports 19 .NET Edition
Rect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawRectangleCanvasItem Class : Rect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Rect As RectangleF
C#
public RectangleF Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawRectangleCanvasItem Class
MetaCanvas.DrawRectangleCanvasItem Members


MetaCanvas.DrawStringCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawStringCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawStringCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.DrawStringCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.DrawStringCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.DrawStringCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.DrawStringCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawStringCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawStringCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawStringCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.DrawStringCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.DrawStringCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Font |
Public Field | Format |
Public Field | Rectangle |
Public Field | Value |
Top

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.DrawStringCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawStringCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : MetaCanvas.DrawStringCanvasItem Constructor

value
font
clone
layoutRectangle
format

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal font As FontInfo, _
   ByVal clone As BrushEx, _
   ByVal layoutRectangle As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
public MetaCanvas.DrawStringCanvasItem(
   string value,
   FontInfo font,
   BrushEx clone,
   RectangleF layoutRectangle,
   StringFormatEx format
)

Parameters

value
font
clone
layoutRectangle
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


MetaCanvas.DrawStringCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.DrawStringCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.DrawStringCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.DrawStringCanvasItem members.

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Font |
Public Field | Format |
Public Field | Rectangle |
Public Field | Value |
Top

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brush Field

[image]
ActiveReports 19 .NET Edition
Brush Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : Brush Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Brush As BrushEx
C#
public readonly BrushEx Brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


Font Field

[image]
ActiveReports 19 .NET Edition
Font Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : Font Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Font As FontInfo
C#
public readonly FontInfo Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


Format Field

[image]
ActiveReports 19 .NET Edition
Format Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : Format Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Format As StringFormatEx
C#
public readonly StringFormatEx Format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


Rectangle Field

[image]
ActiveReports 19 .NET Edition
Rectangle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : Rectangle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Rectangle As RectangleF
C#
public readonly RectangleF Rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.DrawStringCanvasItem Class : Value Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As String
C#
public readonly string Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.DrawStringCanvasItem Class
MetaCanvas.DrawStringCanvasItem Members


MetaCanvas.FillEllipseCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillEllipseCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillEllipseCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.FillEllipseCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.FillEllipseCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.FillEllipseCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillEllipseCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillEllipseCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillEllipseCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillEllipseCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.FillEllipseCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.FillEllipseCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillEllipseCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillEllipseCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillEllipseCanvasItem Class : MetaCanvas.FillEllipseCanvasItem Constructor

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public MetaCanvas.FillEllipseCanvasItem(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Class
MetaCanvas.FillEllipseCanvasItem Members


MetaCanvas.FillEllipseCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillEllipseCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillEllipseCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.FillEllipseCanvasItem members.

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brush Field

[image]
ActiveReports 19 .NET Edition
Brush Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillEllipseCanvasItem Class : Brush Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Brush As BrushEx
C#
public BrushEx Brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Class
MetaCanvas.FillEllipseCanvasItem Members


Rect Field

[image]
ActiveReports 19 .NET Edition
Rect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillEllipseCanvasItem Class : Rect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Rect As RectangleF
C#
public RectangleF Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillEllipseCanvasItem Class
MetaCanvas.FillEllipseCanvasItem Members


MetaCanvas.FillPolygonCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillPolygonCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillPolygonCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.FillPolygonCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.FillPolygonCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.FillPolygonCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillPolygonCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillPolygonCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillPolygonCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillPolygonCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.FillPolygonCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.FillPolygonCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Points |
Top

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillPolygonCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillPolygonCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillPolygonCanvasItem Class : MetaCanvas.FillPolygonCanvasItem Constructor

brush
points

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal brush As BrushEx, _
   ByVal points() As PointF _
)
C#
public MetaCanvas.FillPolygonCanvasItem(
   BrushEx brush,
   PointF[] points
)

Parameters

brush
points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Class
MetaCanvas.FillPolygonCanvasItem Members


MetaCanvas.FillPolygonCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillPolygonCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillPolygonCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.FillPolygonCanvasItem members.

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Points |
Top

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brush Field

[image]
ActiveReports 19 .NET Edition
Brush Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillPolygonCanvasItem Class : Brush Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Brush As BrushEx
C#
public readonly BrushEx Brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Class
MetaCanvas.FillPolygonCanvasItem Members


Points Field

[image]
ActiveReports 19 .NET Edition
Points Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillPolygonCanvasItem Class : Points Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Points As PointF()
C#
public readonly PointF[] Points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillPolygonCanvasItem Class
MetaCanvas.FillPolygonCanvasItem Members


MetaCanvas.FillRectangleCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillRectangleCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillRectangleCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.FillRectangleCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.FillRectangleCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.FillRectangleCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.FillRectangleCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillRectangleCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillRectangleCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillRectangleCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.FillRectangleCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.FillRectangleCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.FillRectangleCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillRectangleCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillRectangleCanvasItem Class : MetaCanvas.FillRectangleCanvasItem Constructor

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public MetaCanvas.FillRectangleCanvasItem(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Class
MetaCanvas.FillRectangleCanvasItem Members


MetaCanvas.FillRectangleCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.FillRectangleCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.FillRectangleCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.FillRectangleCanvasItem members.

Public Fields

 | Name | Description
Public Field | Brush |
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Brush Field

[image]
ActiveReports 19 .NET Edition
Brush Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillRectangleCanvasItem Class : Brush Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Brush As BrushEx
C#
public BrushEx Brush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Class
MetaCanvas.FillRectangleCanvasItem Members


Rect Field

[image]
ActiveReports 19 .NET Edition
Rect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.FillRectangleCanvasItem Class : Rect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Rect As RectangleF
C#
public RectangleF Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.FillRectangleCanvasItem Class
MetaCanvas.FillRectangleCanvasItem Members


MetaCanvas.IntersectClipPathCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipPathCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipPathCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.IntersectClipPathCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.IntersectClipPathCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.IntersectClipPathCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.IntersectClipPathCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipPathCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.IntersectClipPathCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipPathCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipPathCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.IntersectClipPathCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.IntersectClipPathCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Path |
Top

See Also

Reference

MetaCanvas.IntersectClipPathCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.IntersectClipPathCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipPathCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.IntersectClipPathCanvasItem Class : MetaCanvas.IntersectClipPathCanvasItem Constructor

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal path As PathEx _
)
C#
public MetaCanvas.IntersectClipPathCanvasItem(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipPathCanvasItem Class
MetaCanvas.IntersectClipPathCanvasItem Members


MetaCanvas.IntersectClipPathCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipPathCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipPathCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.IntersectClipPathCanvasItem members.

Public Fields

 | Name | Description
Public Field | Path |
Top

See Also

Reference

MetaCanvas.IntersectClipPathCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Path Field

[image]
ActiveReports 19 .NET Edition
Path Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.IntersectClipPathCanvasItem Class : Path Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Path As PathEx
C#
public readonly PathEx Path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipPathCanvasItem Class
MetaCanvas.IntersectClipPathCanvasItem Members


MetaCanvas.IntersectClipRectCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipRectCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipRectCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.IntersectClipRectCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.IntersectClipRectCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.IntersectClipRectCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.IntersectClipRectCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipRectCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.IntersectClipRectCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipRectCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipRectCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.IntersectClipRectCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.IntersectClipRectCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.IntersectClipRectCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.IntersectClipRectCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipRectCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.IntersectClipRectCanvasItem Class : MetaCanvas.IntersectClipRectCanvasItem Constructor

rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF _
)
C#
public MetaCanvas.IntersectClipRectCanvasItem(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipRectCanvasItem Class
MetaCanvas.IntersectClipRectCanvasItem Members


MetaCanvas.IntersectClipRectCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.IntersectClipRectCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.IntersectClipRectCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.IntersectClipRectCanvasItem members.

Public Fields

 | Name | Description
Public Field | Rect |
Top

See Also

Reference

MetaCanvas.IntersectClipRectCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Rect Field

[image]
ActiveReports 19 .NET Edition
Rect Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.IntersectClipRectCanvasItem Class : Rect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Rect As RectangleF
C#
public readonly RectangleF Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.IntersectClipRectCanvasItem Class
MetaCanvas.IntersectClipRectCanvasItem Members


MetaCanvas.MetaHatchBrush Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaHatchBrush Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaHatchBrush Class

Glossary Item Box

Object Model

MetaCanvas.MetaHatchBrush Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.MetaHatchBrush
   Inherits GrapeCity.ActiveReports.Drawing.BrushEx
C#
public class MetaCanvas.MetaHatchBrush : GrapeCity.ActiveReports.Drawing.BrushEx

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BrushEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaHatchBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaHatchBrush Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaHatchBrush Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaHatchBrush Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.MetaHatchBrush.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.MetaHatchBrush Constructor |
Top

Public Fields

 | Name | Description
Public Field | BackColor |
Public Field | ForeColor |
Public Field | HatchStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaHatchBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaHatchBrush Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaHatchBrush Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaHatchBrush Class : MetaCanvas.MetaHatchBrush Constructor

hatchStyle
foreColor
backColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hatchStyle As HatchStyleEx, _
   ByVal foreColor As Color, _
   ByVal backColor As Color _
)
C#
public MetaCanvas.MetaHatchBrush(
   HatchStyleEx hatchStyle,
   Color foreColor,
   Color backColor
)

Parameters

hatchStyle
foreColor
backColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Class
MetaCanvas.MetaHatchBrush Members


MetaCanvas.MetaHatchBrush Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaHatchBrush Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaHatchBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaHatchBrush members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaHatchBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaHatchBrush Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Class
MetaCanvas.MetaHatchBrush Members


MetaCanvas.MetaHatchBrush Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaHatchBrush Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaHatchBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaHatchBrush members.

Public Fields

 | Name | Description
Public Field | BackColor |
Public Field | ForeColor |
Public Field | HatchStyle |
Top

See Also

Reference

MetaCanvas.MetaHatchBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


BackColor Field

[image]
ActiveReports 19 .NET Edition
BackColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaHatchBrush Class : BackColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackColor As Color
C#
public readonly Color BackColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Class
MetaCanvas.MetaHatchBrush Members


ForeColor Field

[image]
ActiveReports 19 .NET Edition
ForeColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaHatchBrush Class : ForeColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ForeColor As Color
C#
public readonly Color ForeColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Class
MetaCanvas.MetaHatchBrush Members


HatchStyle Field

[image]
ActiveReports 19 .NET Edition
HatchStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaHatchBrush Class : HatchStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HatchStyle As HatchStyleEx
C#
public readonly HatchStyleEx HatchStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaHatchBrush Class
MetaCanvas.MetaHatchBrush Members


MetaCanvas.MetaLinearGradientBrush Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaLinearGradientBrush Class

Glossary Item Box

Object Model

MetaCanvas.MetaLinearGradientBrush Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.MetaLinearGradientBrush
   Inherits GrapeCity.ActiveReports.Drawing.BrushEx
C#
public class MetaCanvas.MetaLinearGradientBrush : GrapeCity.ActiveReports.Drawing.BrushEx

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BrushEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaLinearGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaLinearGradientBrush Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaLinearGradientBrush Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.MetaLinearGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.MetaLinearGradientBrush Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Blend |
Public Field | Color1 |
Public Field | Color2 |
Public Field | IsVersion2 | A flag that defines the version of the interface IDrawingCanvas2
Public Field | Point1 |
Public Field | Point2 |
Public Field | Stops |
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaLinearGradientBrush Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : MetaCanvas.MetaLinearGradientBrush Constructor

Glossary Item Box

Overload List

Overload | Description
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx) |
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) |
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx,IEnumerable<GradientStopColor>) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx)

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class > MetaCanvas.MetaLinearGradientBrush Constructor : MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx)

point1
point2
color1
color2
blend

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByRef color1 As Color, _
   ByRef color2 As Color, _
   ByVal blend As BlendEx _
)
C#
public MetaCanvas.MetaLinearGradientBrush(
   PointF point1,
   PointF point2,
   ref Color color1,
   ref Color color2,
   BlendEx blend
)

Parameters

point1
point2
color1
color2
blend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members
Overload List


MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>)

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class > MetaCanvas.MetaLinearGradientBrush Constructor : MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>)

point1
point2
color1
color2
stops

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByRef color1 As Color, _
   ByRef color2 As Color, _
   ByVal stops As IEnumerable(Of GradientStopColor) _
)
C#
public MetaCanvas.MetaLinearGradientBrush(
   PointF point1,
   PointF point2,
   ref Color color1,
   ref Color color2,
   IEnumerable<GradientStopColor> stops
)

Parameters

point1
point2
color1
color2
stops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members
Overload List


MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx,IEnumerable<GradientStopColor>)

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx,IEnumerable<GradientStopColor>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class > MetaCanvas.MetaLinearGradientBrush Constructor : MetaCanvas.MetaLinearGradientBrush Constructor(PointF,PointF,Color,Color,BlendEx,IEnumerable<GradientStopColor>)

point1
point2
color1
color2
blend
stops

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByRef color1 As Color, _
   ByRef color2 As Color, _
   ByVal blend As BlendEx, _
   ByVal stops As IEnumerable(Of GradientStopColor) _
)
C#
public MetaCanvas.MetaLinearGradientBrush(
   PointF point1,
   PointF point2,
   ref Color color1,
   ref Color color2,
   BlendEx blend,
   IEnumerable<GradientStopColor> stops
)

Parameters

point1
point2
color1
color2
blend
stops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members
Overload List


MetaCanvas.MetaLinearGradientBrush Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaLinearGradientBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaLinearGradientBrush members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


MetaCanvas.MetaLinearGradientBrush Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaLinearGradientBrush Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaLinearGradientBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaLinearGradientBrush members.

Public Fields

 | Name | Description
Public Field | Blend |
Public Field | Color1 |
Public Field | Color2 |
Public Field | IsVersion2 | A flag that defines the version of the interface IDrawingCanvas2
Public Field | Point1 |
Public Field | Point2 |
Public Field | Stops |
Top

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Blend Field

[image]
ActiveReports 19 .NET Edition
Blend Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Blend Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Blend As BlendEx
C#
public readonly BlendEx Blend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


Color1 Field

[image]
ActiveReports 19 .NET Edition
Color1 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Color1 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Color1 As Color
C#
public readonly Color Color1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


Color2 Field

[image]
ActiveReports 19 .NET Edition
Color2 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Color2 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Color2 As Color
C#
public readonly Color Color2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


IsVersion2 Field

[image]
ActiveReports 19 .NET Edition
IsVersion2 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : IsVersion2 Field

Glossary Item Box

A flag that defines the version of the interface IDrawingCanvas2

Syntax

Visual Basic (Declaration)
Public ReadOnly IsVersion2 As Boolean
C#
public readonly bool IsVersion2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


Point1 Field

[image]
ActiveReports 19 .NET Edition
Point1 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Point1 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Point1 As PointF
C#
public readonly PointF Point1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


Point2 Field

[image]
ActiveReports 19 .NET Edition
Point2 Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Point2 Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Point2 As PointF
C#
public readonly PointF Point2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


Stops Field

[image]
ActiveReports 19 .NET Edition
Stops Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaLinearGradientBrush Class : Stops Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Stops As IEnumerable(Of GradientStopColor)
C#
public readonly IEnumerable<GradientStopColor> Stops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaLinearGradientBrush Class
MetaCanvas.MetaLinearGradientBrush Members


MetaCanvas.MetaPen Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaPen Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaPen Class

Glossary Item Box

Object Model

MetaCanvas.MetaPen Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.MetaPen
   Inherits GrapeCity.ActiveReports.Drawing.PenEx
C#
public class MetaCanvas.MetaPen : GrapeCity.ActiveReports.Drawing.PenEx

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.PenEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaPen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaPen Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaPen Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaPen Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.MetaPen.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.MetaPen Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment | Overridden.
Public Property | Color | Overridden.
Public Property | DashCap | Overridden.
Public Property | DashPattern | Overridden.
Public Property | DashStyle | Overridden.
Public Property | EndCap | Overridden.
Public Property | LineJoin | Overridden.
Public Property | StartCap | Overridden.
Public Property | Width | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

MetaCanvas.MetaPen Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaPen Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaPen Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : MetaCanvas.MetaPen Constructor

color
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single _
)
C#
public MetaCanvas.MetaPen(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


MetaCanvas.MetaPen Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaPen Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaPen Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaPen members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

MetaCanvas.MetaPen Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


MetaCanvas.MetaPen Class Properties

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaPen Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaPen Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaPen members.

Public Properties

 | Name | Description
Public Property | Alignment | Overridden.
Public Property | Color | Overridden.
Public Property | DashCap | Overridden.
Public Property | DashPattern | Overridden.
Public Property | DashStyle | Overridden.
Public Property | EndCap | Overridden.
Public Property | LineJoin | Overridden.
Public Property | StartCap | Overridden.
Public Property | Width | Overridden.
Top

See Also

Reference

MetaCanvas.MetaPen Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Alignment Property

[image]
ActiveReports 19 .NET Edition
Alignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : Alignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Alignment As PenAlignment
C#
public override PenAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Color As Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


DashCap Property

[image]
ActiveReports 19 .NET Edition
DashCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : DashCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property DashCap As DashCap
C#
public override DashCap DashCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


DashPattern Property

[image]
ActiveReports 19 .NET Edition
DashPattern Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : DashPattern Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property DashPattern As Single()
C#
public override float[] DashPattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


DashStyle Property

[image]
ActiveReports 19 .NET Edition
DashStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : DashStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property DashStyle As PenStyleEx
C#
public override PenStyleEx DashStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


EndCap Property

[image]
ActiveReports 19 .NET Edition
EndCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : EndCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property EndCap As LineCap
C#
public override LineCap EndCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


LineJoin Property

[image]
ActiveReports 19 .NET Edition
LineJoin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : LineJoin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property LineJoin As LineJoin
C#
public override LineJoin LineJoin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


StartCap Property

[image]
ActiveReports 19 .NET Edition
StartCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : StartCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property StartCap As LineCap
C#
public override LineCap StartCap {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaPen Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As Single
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaPen Class
MetaCanvas.MetaPen Members


MetaCanvas.MetaRadialGradientBrush Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaRadialGradientBrush Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaRadialGradientBrush Class

Glossary Item Box

Object Model

MetaCanvas.MetaRadialGradientBrush Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.MetaRadialGradientBrush
   Inherits GrapeCity.ActiveReports.Drawing.BrushEx
C#
public class MetaCanvas.MetaRadialGradientBrush : GrapeCity.ActiveReports.Drawing.BrushEx

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BrushEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaRadialGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaRadialGradientBrush Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaRadialGradientBrush Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaRadialGradientBrush Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.MetaRadialGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.MetaRadialGradientBrush Constructor |
Top

Public Fields

 | Name | Description
Public Field | CenterColor |
Public Field | CenterPoint |
Public Field | RadiusX |
Public Field | RadiusY |
Public Field | SurroundingColor |
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaRadialGradientBrush Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaRadialGradientBrush Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : MetaCanvas.MetaRadialGradientBrush Constructor

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal centerPoint As PointF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal centerColor As Color, _
   ByVal surroundingColor As Color _
)
C#
public MetaCanvas.MetaRadialGradientBrush(
   PointF centerPoint,
   float radiusX,
   float radiusY,
   Color centerColor,
   Color surroundingColor
)

Parameters

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


MetaCanvas.MetaRadialGradientBrush Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaRadialGradientBrush Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaRadialGradientBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaRadialGradientBrush members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Top

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


MetaCanvas.MetaRadialGradientBrush Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaRadialGradientBrush Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaRadialGradientBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaRadialGradientBrush members.

Public Fields

 | Name | Description
Public Field | CenterColor |
Public Field | CenterPoint |
Public Field | RadiusX |
Public Field | RadiusY |
Public Field | SurroundingColor |
Top

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


CenterColor Field

[image]
ActiveReports 19 .NET Edition
CenterColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : CenterColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly CenterColor As Color
C#
public readonly Color CenterColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


CenterPoint Field

[image]
ActiveReports 19 .NET Edition
CenterPoint Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : CenterPoint Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly CenterPoint As PointF
C#
public readonly PointF CenterPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


RadiusX Field

[image]
ActiveReports 19 .NET Edition
RadiusX Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : RadiusX Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RadiusX As Single
C#
public readonly float RadiusX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


RadiusY Field

[image]
ActiveReports 19 .NET Edition
RadiusY Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : RadiusY Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RadiusY As Single
C#
public readonly float RadiusY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


SurroundingColor Field

[image]
ActiveReports 19 .NET Edition
SurroundingColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaRadialGradientBrush Class : SurroundingColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly SurroundingColor As Color
C#
public readonly Color SurroundingColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaRadialGradientBrush Class
MetaCanvas.MetaRadialGradientBrush Members


MetaCanvas.MetaSolidBrush Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaSolidBrush Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaSolidBrush Class

Glossary Item Box

Object Model

MetaCanvas.MetaSolidBrush Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.MetaSolidBrush
   Inherits GrapeCity.ActiveReports.Drawing.BrushEx
C#
public class MetaCanvas.MetaSolidBrush : GrapeCity.ActiveReports.Drawing.BrushEx

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.BrushEx
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.MetaSolidBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaSolidBrush Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaSolidBrush Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaSolidBrush Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.MetaSolidBrush.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.MetaSolidBrush Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color |
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

MetaCanvas.MetaSolidBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.MetaSolidBrush Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaSolidBrush Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaSolidBrush Class : MetaCanvas.MetaSolidBrush Constructor

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
C#
public MetaCanvas.MetaSolidBrush(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Class
MetaCanvas.MetaSolidBrush Members


MetaCanvas.MetaSolidBrush Class Methods

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaSolidBrush Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaSolidBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaSolidBrush members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

MetaCanvas.MetaSolidBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaSolidBrush Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
C#
public override object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Class
MetaCanvas.MetaSolidBrush Members


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaSolidBrush Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Class
MetaCanvas.MetaSolidBrush Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaSolidBrush Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Class
MetaCanvas.MetaSolidBrush Members


MetaCanvas.MetaSolidBrush Class Properties

[image]
ActiveReports 19 .NET Edition
MetaCanvas.MetaSolidBrush Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.MetaSolidBrush Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.MetaSolidBrush members.

Public Properties

 | Name | Description
Public Property | Color |
Top

See Also

Reference

MetaCanvas.MetaSolidBrush Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.MetaSolidBrush Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Color As Color
C#
public Color Color {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.MetaSolidBrush Class
MetaCanvas.MetaSolidBrush Members


MetaCanvas.PopStateCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PopStateCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.PopStateCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.PopStateCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.PopStateCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.PopStateCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.PopStateCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.PopStateCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.PopStateCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PopStateCanvasItem Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.PopStateCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.PopStateCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.PopStateCanvasItem Constructor |
Top

See Also

Reference

MetaCanvas.PopStateCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.PopStateCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PopStateCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.PopStateCanvasItem Class : MetaCanvas.PopStateCanvasItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MetaCanvas.PopStateCanvasItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.PopStateCanvasItem Class
MetaCanvas.PopStateCanvasItem Members


MetaCanvas.PushStateCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PushStateCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.PushStateCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.PushStateCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.PushStateCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.PushStateCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.PushStateCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.PushStateCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.PushStateCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PushStateCanvasItem Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.PushStateCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.PushStateCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.PushStateCanvasItem Constructor |
Top

See Also

Reference

MetaCanvas.PushStateCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.PushStateCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.PushStateCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.PushStateCanvasItem Class : MetaCanvas.PushStateCanvasItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MetaCanvas.PushStateCanvasItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.PushStateCanvasItem Class
MetaCanvas.PushStateCanvasItem Members


MetaCanvas.SetSmoothingModeCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetSmoothingModeCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetSmoothingModeCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.SetSmoothingModeCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.SetSmoothingModeCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.SetSmoothingModeCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetSmoothingModeCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetSmoothingModeCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetSmoothingModeCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetSmoothingModeCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetSmoothingModeCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.SetSmoothingModeCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.SetSmoothingModeCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Mode |
Top

See Also

Reference

MetaCanvas.SetSmoothingModeCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetSmoothingModeCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetSmoothingModeCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetSmoothingModeCanvasItem Class : MetaCanvas.SetSmoothingModeCanvasItem Constructor

mode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mode As SmoothingModeEx _
)
C#
public MetaCanvas.SetSmoothingModeCanvasItem(
   SmoothingModeEx mode
)

Parameters

mode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetSmoothingModeCanvasItem Class
MetaCanvas.SetSmoothingModeCanvasItem Members


MetaCanvas.SetSmoothingModeCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetSmoothingModeCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetSmoothingModeCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.SetSmoothingModeCanvasItem members.

Public Fields

 | Name | Description
Public Field | Mode |
Top

See Also

Reference

MetaCanvas.SetSmoothingModeCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Mode Field

[image]
ActiveReports 19 .NET Edition
Mode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetSmoothingModeCanvasItem Class : Mode Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Mode As SmoothingModeEx
C#
public readonly SmoothingModeEx Mode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetSmoothingModeCanvasItem Class
MetaCanvas.SetSmoothingModeCanvasItem Members


MetaCanvas.SetTextRenderingHintCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTextRenderingHintCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTextRenderingHintCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.SetTextRenderingHintCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.SetTextRenderingHintCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.SetTextRenderingHintCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetTextRenderingHintCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTextRenderingHintCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetTextRenderingHintCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTextRenderingHintCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTextRenderingHintCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.SetTextRenderingHintCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.SetTextRenderingHintCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Hint |
Top

See Also

Reference

MetaCanvas.SetTextRenderingHintCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetTextRenderingHintCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTextRenderingHintCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetTextRenderingHintCanvasItem Class : MetaCanvas.SetTextRenderingHintCanvasItem Constructor

hint

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hint As TextRenderingHintEx _
)
C#
public MetaCanvas.SetTextRenderingHintCanvasItem(
   TextRenderingHintEx hint
)

Parameters

hint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTextRenderingHintCanvasItem Class
MetaCanvas.SetTextRenderingHintCanvasItem Members


MetaCanvas.SetTextRenderingHintCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTextRenderingHintCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTextRenderingHintCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.SetTextRenderingHintCanvasItem members.

Public Fields

 | Name | Description
Public Field | Hint |
Top

See Also

Reference

MetaCanvas.SetTextRenderingHintCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Hint Field

[image]
ActiveReports 19 .NET Edition
Hint Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetTextRenderingHintCanvasItem Class : Hint Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Hint As TextRenderingHintEx
C#
public readonly TextRenderingHintEx Hint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTextRenderingHintCanvasItem Class
MetaCanvas.SetTextRenderingHintCanvasItem Members


MetaCanvas.SetTransformCanvasItem Class

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTransformCanvasItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTransformCanvasItem Class

Glossary Item Box

Object Model

MetaCanvas.SetTransformCanvasItem Class

Syntax

Visual Basic (Declaration)
Public Class MetaCanvas.SetTransformCanvasItem
   Inherits MetaCanvas.CanvasItem
C#
public class MetaCanvas.SetTransformCanvasItem : MetaCanvas.CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.CanvasItem
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas.SetTransformCanvasItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTransformCanvasItem Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetTransformCanvasItem Class Members

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTransformCanvasItem Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTransformCanvasItem Class

Glossary Item Box

The following tables list the members exposed by MetaCanvas.SetTransformCanvasItem.

Public Constructors

 | Name | Description
Public Constructor | MetaCanvas.SetTransformCanvasItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Matrix |
Top

See Also

Reference

MetaCanvas.SetTransformCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


MetaCanvas.SetTransformCanvasItem Constructor

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTransformCanvasItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetTransformCanvasItem Class : MetaCanvas.SetTransformCanvasItem Constructor

matrix

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal matrix As Matrix3x2 _
)
C#
public MetaCanvas.SetTransformCanvasItem(
   Matrix3x2 matrix
)

Parameters

matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTransformCanvasItem Class
MetaCanvas.SetTransformCanvasItem Members


MetaCanvas.SetTransformCanvasItem Class Fields

[image]
ActiveReports 19 .NET Edition
MetaCanvas.SetTransformCanvasItem Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : MetaCanvas.SetTransformCanvasItem Class

Glossary Item Box

For a list of all members of this type, see MetaCanvas.SetTransformCanvasItem members.

Public Fields

 | Name | Description
Public Field | Matrix |
Top

See Also

Reference

MetaCanvas.SetTransformCanvasItem Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Matrix Field

[image]
ActiveReports 19 .NET Edition
Matrix Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > MetaCanvas.SetTransformCanvasItem Class : Matrix Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Matrix As Matrix3x2
C#
public readonly Matrix3x2 Matrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MetaCanvas.SetTransformCanvasItem Class
MetaCanvas.SetTransformCanvasItem Members


ReportMetaCanvas Class

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas Class

Glossary Item Box

MetaCanvas which implements IReportDrawingCanvas.

Object Model

ReportMetaCanvas Class

Syntax

Visual Basic (Declaration)
Public Class ReportMetaCanvas
   Inherits FilteredMetaCanvas
   Implements GrapeCity.ActiveReports.Drawing.IDrawingCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchableCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IReportDrawingCanvas
C#
public class ReportMetaCanvas : FilteredMetaCanvas, GrapeCity.ActiveReports.Drawing.IDrawingCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchableCanvas, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IReportDrawingCanvas

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.MetaCanvas
GrapeCity.ActiveReports.Drawing.Serialization.FilteredMetaCanvas
GrapeCity.ActiveReports.Drawing.Serialization.ReportMetaCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ReportMetaCanvas Class Members

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas Class

Glossary Item Box

The following tables list the members exposed by ReportMetaCanvas.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Public Method | PostRender |
Public Method | PreRender |
Top

See Also

Reference

ReportMetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ReportMetaCanvas Class Methods

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas Class

Glossary Item Box

For a list of all members of this type, see ReportMetaCanvas members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Public Method | PostRender |
Public Method | PreRender |
Top

See Also

Reference

ReportMetaCanvas Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas Class : Create Method

outStream
delayedContent
images
svgMeasurer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal outStream As Stream, _
   ByVal delayedContent As ReportMetaCanvas.DelayedContent, _
   ByVal images As IImageWriter, _
   ByVal svgMeasurer As Func(Of Stream,SizeF) _
) As ReportMetaCanvas
C#
public static ReportMetaCanvas Create(
   Stream outStream,
   ReportMetaCanvas.DelayedContent delayedContent,
   IImageWriter images,
   Func<Stream,SizeF> svgMeasurer
)

Parameters

outStream
delayedContent
images
svgMeasurer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas Class
ReportMetaCanvas Members


PostRender Method

[image]
ActiveReports 19 .NET Edition
PostRender Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas Class : PostRender Method

layoutArea

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub PostRender( _
   ByVal layoutArea As ILayoutArea _
)
C#
public virtual void PostRender(
   ILayoutArea layoutArea
)

Parameters

layoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas Class
ReportMetaCanvas Members


PreRender Method

[image]
ActiveReports 19 .NET Edition
PreRender Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas Class : PreRender Method

layoutArea

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function PreRender( _
   ByVal layoutArea As ILayoutArea _
) As Boolean
C#
public virtual bool PreRender(
   ILayoutArea layoutArea
)

Parameters

layoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas Class
ReportMetaCanvas Members


ReportMetaCanvas.DelayedContent Class

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas.DelayedContent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas.DelayedContent Class

Glossary Item Box

Keeps report items that have delayed hiding.

Object Model

ReportMetaCanvas.DelayedContent Class

Syntax

Visual Basic (Declaration)
Public Class ReportMetaCanvas.DelayedContent
   Implements GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchCollector
C#
public class ReportMetaCanvas.DelayedContent : GrapeCity.ActiveReports.Rendering.GraphicalRenderers.IPatchCollector

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.ReportMetaCanvas.DelayedContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas.DelayedContent Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ReportMetaCanvas.DelayedContent Class Members

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas.DelayedContent Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas.DelayedContent Class

Glossary Item Box

The following tables list the members exposed by ReportMetaCanvas.DelayedContent.

Public Constructors

 | Name | Description
Public Constructor | ReportMetaCanvas.DelayedContent Constructor | Keeps report items that have delayed hiding.
Top

Public Properties

 | Name | Description
Public Property | IsEmpty |
Top

Public Methods

 | Name | Description
Public Method | ApplyPatches | Makes the patches visible. Should be called when the delayed content is ready.
Public Method | GroupVisible |
Top

See Also

Reference

ReportMetaCanvas.DelayedContent Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ReportMetaCanvas.DelayedContent Constructor

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas.DelayedContent Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas.DelayedContent Class : ReportMetaCanvas.DelayedContent Constructor

bookmarkService

Glossary Item Box

Keeps report items that have delayed hiding.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bookmarkService As IBookmarkService _
)
C#
public ReportMetaCanvas.DelayedContent(
   IBookmarkService bookmarkService
)

Parameters

bookmarkService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas.DelayedContent Class
ReportMetaCanvas.DelayedContent Members


ReportMetaCanvas.DelayedContent Class Methods

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas.DelayedContent Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas.DelayedContent Class

Glossary Item Box

For a list of all members of this type, see ReportMetaCanvas.DelayedContent members.

Public Methods

 | Name | Description
Public Method | ApplyPatches | Makes the patches visible. Should be called when the delayed content is ready.
Public Method | GroupVisible |
Top

See Also

Reference

ReportMetaCanvas.DelayedContent Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


ApplyPatches Method

[image]
ActiveReports 19 .NET Edition
ApplyPatches Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas.DelayedContent Class : ApplyPatches Method

Glossary Item Box

Makes the patches visible. Should be called when the delayed content is ready.

Syntax

Visual Basic (Declaration)
Public Sub ApplyPatches()
C#
public void ApplyPatches()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas.DelayedContent Class
ReportMetaCanvas.DelayedContent Members


GroupVisible Method

[image]
ActiveReports 19 .NET Edition
GroupVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas.DelayedContent Class : GroupVisible Method

groupId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GroupVisible( _
   ByVal groupId As String _
) As Boolean
C#
public bool GroupVisible(
   string groupId
)

Parameters

groupId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas.DelayedContent Class
ReportMetaCanvas.DelayedContent Members


ReportMetaCanvas.DelayedContent Class Properties

[image]
ActiveReports 19 .NET Edition
ReportMetaCanvas.DelayedContent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : ReportMetaCanvas.DelayedContent Class

Glossary Item Box

For a list of all members of this type, see ReportMetaCanvas.DelayedContent members.

Public Properties

 | Name | Description
Public Property | IsEmpty |
Top

See Also

Reference

ReportMetaCanvas.DelayedContent Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > ReportMetaCanvas.DelayedContent Class : IsEmpty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportMetaCanvas.DelayedContent Class
ReportMetaCanvas.DelayedContent Members


StringPatch Class

[image]
ActiveReports 19 .NET Edition
StringPatch Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : StringPatch Class

Glossary Item Box

Represents the update for the items with delayed content.

Object Model

StringPatch Class

Syntax

Visual Basic (Declaration)
Public Class StringPatch
C#
public class StringPatch

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Drawing.Serialization.StringPatch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringPatch Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


StringPatch Class Members

[image]
ActiveReports 19 .NET Edition
StringPatch Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : StringPatch Class

Glossary Item Box

The following tables list the members exposed by StringPatch.

Public Properties

 | Name | Description
Public Property | Bounds | The new bounds to the text be drawn in.
Public Property | Format | The actual string format to the text be rendered with.
Public Property | Text | The actual text to be rendered.
Public Property | Transform | Additional transformation matrix. It is necessary because it is not enough to simply update the text. You need to apply alignment, and in the case of rotated text, the tearing is done using a transform, since the text is torn relative to the rectangle, and not relative to the direction of the text.
Top

See Also

Reference

StringPatch Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


StringPatch Class Properties

[image]
ActiveReports 19 .NET Edition
StringPatch Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : StringPatch Class

Glossary Item Box

For a list of all members of this type, see StringPatch members.

Public Properties

 | Name | Description
Public Property | Bounds | The new bounds to the text be drawn in.
Public Property | Format | The actual string format to the text be rendered with.
Public Property | Text | The actual text to be rendered.
Public Property | Transform | Additional transformation matrix. It is necessary because it is not enough to simply update the text. You need to apply alignment, and in the case of rotated text, the tearing is done using a transform, since the text is torn relative to the rectangle, and not relative to the direction of the text.
Top

See Also

Reference

StringPatch Class
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > StringPatch Class : Bounds Property

Glossary Item Box

The new bounds to the text be drawn in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As RectangleF
C#
public RectangleF Bounds {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringPatch Class
StringPatch Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > StringPatch Class : Format Property

Glossary Item Box

The actual string format to the text be rendered with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Format As StringFormatEx
C#
public StringFormatEx Format {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringPatch Class
StringPatch Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > StringPatch Class : Text Property

Glossary Item Box

The actual text to be rendered.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringPatch Class
StringPatch Members


Transform Property

[image]
ActiveReports 19 .NET Edition
Transform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > StringPatch Class : Transform Property

Glossary Item Box

Additional transformation matrix. It is necessary because it is not enough to simply update the text. You need to apply alignment, and in the case of rotated text, the tearing is done using a transform, since the text is torn relative to the rectangle, and not relative to the direction of the text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Transform As Matrix3x2
C#
public Matrix3x2 Transform {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringPatch Class
StringPatch Members


IImageStore Interface

[image]
ActiveReports 19 .NET Edition
IImageStore Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageStore Interface

Glossary Item Box

Represents an image store interface.

Syntax

Visual Basic (Declaration)
Public Interface IImageStore
C#
public interface IImageStore

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageStore Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IImageStore Interface Members

[image]
ActiveReports 19 .NET Edition
IImageStore Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageStore Interface

Glossary Item Box

The following tables list the members exposed by IImageStore.

Public Methods

 | Name | Description
Method | Get |
Top

See Also

Reference

IImageStore Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IImageStore Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageStore Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageStore Interface

Glossary Item Box

For a list of all members of this type, see IImageStore members.

Public Methods

 | Name | Description
Method | Get |
Top

See Also

Reference

IImageStore Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


Get Method

[image]
ActiveReports 19 .NET Edition
Get Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > IImageStore Interface : Get Method

imageId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function Get( _
   ByVal imageId As Integer _
) As ImageInfo
C#
ImageInfo Get(
   int imageId
)

Parameters

imageId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageStore Interface
IImageStore Members


IImageWriter Interface

[image]
ActiveReports 19 .NET Edition
IImageWriter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageWriter Interface

Glossary Item Box

Represents interface for image writing.

Syntax

Visual Basic (Declaration)
Public Interface IImageWriter
C#
public interface IImageWriter

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageWriter Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IImageWriter Interface Members

[image]
ActiveReports 19 .NET Edition
IImageWriter Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageWriter Interface

Glossary Item Box

The following tables list the members exposed by IImageWriter.

Public Methods

 | Name | Description
Method | WriteImage |
Top

See Also

Reference

IImageWriter Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IImageWriter Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageWriter Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IImageWriter Interface

Glossary Item Box

For a list of all members of this type, see IImageWriter members.

Public Methods

 | Name | Description
Method | WriteImage |
Top

See Also

Reference

IImageWriter Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


WriteImage Method

[image]
ActiveReports 19 .NET Edition
WriteImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > IImageWriter Interface : WriteImage Method

imageInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function WriteImage( _
   ByVal imageInfo As ImageInfo _
) As Integer
C#
int WriteImage(
   ImageInfo imageInfo
)

Parameters

imageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageWriter Interface
IImageWriter Members


IMetaCanvasItemWriter Interface

[image]
ActiveReports 19 .NET Edition
IMetaCanvasItemWriter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IMetaCanvasItemWriter Interface

Glossary Item Box

Represents interface for canvas item writing.

Syntax

Visual Basic (Declaration)
Public Interface IMetaCanvasItemWriter
C#
public interface IMetaCanvasItemWriter

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetaCanvasItemWriter Members
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IMetaCanvasItemWriter Interface Members

[image]
ActiveReports 19 .NET Edition
IMetaCanvasItemWriter Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IMetaCanvasItemWriter Interface

Glossary Item Box

The following tables list the members exposed by IMetaCanvasItemWriter.

Public Methods

 | Name | Description
Method | WriteItem |
Top

See Also

Reference

IMetaCanvasItemWriter Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


IMetaCanvasItemWriter Interface Methods

[image]
ActiveReports 19 .NET Edition
IMetaCanvasItemWriter Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace : IMetaCanvasItemWriter Interface

Glossary Item Box

For a list of all members of this type, see IMetaCanvasItemWriter members.

Public Methods

 | Name | Description
Method | WriteItem |
Top

See Also

Reference

IMetaCanvasItemWriter Interface
GrapeCity.ActiveReports.Drawing.Serialization Namespace


WriteItem Method

[image]
ActiveReports 19 .NET Edition
WriteItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Drawing.Serialization Namespace > IMetaCanvasItemWriter Interface : WriteItem Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub WriteItem( _
   ByVal item As MetaCanvas.CanvasItem _
)
C#
void WriteItem(
   MetaCanvas.CanvasItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetaCanvasItemWriter Interface
IMetaCanvasItemWriter Members


DataSet Class

[image]
ActiveReports 19 .NET Edition
DataSet Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSet Class

Glossary Item Box

Represents information about a data set.

Object Model

DataSet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSet
C#
public sealed class DataSet

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSet Class Members

[image]
ActiveReports 19 .NET Edition
DataSet Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSet Class

Glossary Item Box

The following tables list the members exposed by DataSet.

Public Properties

 | Name | Description
Public Property | CommandText | Returns the command text of this DataSet.
Public Property | Name | Returns the name of this DataSet.
Public Property | RewrittenCommandText | Gets the command text of this DataSet after it has been rewritten.
Top

See Also

Reference

DataSet Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSet Class Properties

[image]
ActiveReports 19 .NET Edition
DataSet Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSet Class

Glossary Item Box

For a list of all members of this type, see DataSet members.

Public Properties

 | Name | Description
Public Property | CommandText | Returns the command text of this DataSet.
Public Property | Name | Returns the name of this DataSet.
Public Property | RewrittenCommandText | Gets the command text of this DataSet after it has been rewritten.
Top

See Also

Reference

DataSet Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


CommandText Property

[image]
ActiveReports 19 .NET Edition
CommandText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSet Class : CommandText Property

Glossary Item Box

Returns the command text of this DataSet.

Syntax

Visual Basic (Declaration)
Public Property CommandText As String
C#
public string CommandText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSet Class : Name Property

Glossary Item Box

Returns the name of this DataSet.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


RewrittenCommandText Property

[image]
ActiveReports 19 .NET Edition
RewrittenCommandText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSet Class : RewrittenCommandText Property

Glossary Item Box

Gets the command text of this DataSet after it has been rewritten.

Syntax

Visual Basic (Declaration)
Public Property RewrittenCommandText As String
C#
public string RewrittenCommandText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSet Class
DataSet Members


DataSets Class

[image]
ActiveReports 19 .NET Edition
DataSets Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSets Class

Glossary Item Box

Represents a collection of DataSet references.

Object Model

DataSets Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSets
C#
public sealed class DataSets

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DataSets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSets Class Members

[image]
ActiveReports 19 .NET Edition
DataSets Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSets Class

Glossary Item Box

The following tables list the members exposed by DataSets.

Public Properties

 | Name | Description
Public Property | Item | Gets the DataSet with the given name.
Top

See Also

Reference

DataSets Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSets Class Properties

[image]
ActiveReports 19 .NET Edition
DataSets Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSets Class

Glossary Item Box

For a list of all members of this type, see DataSets members.

Public Properties

 | Name | Description
Public Property | Item | Gets the DataSet with the given name.
Top

See Also

Reference

DataSets Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSets Class : Item Property

name

Glossary Item Box

Gets the DataSet with the given name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As DataSet
C#
public DataSet this[
   string name
]; {get;}

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSets Class
DataSets Members


DataSource Class

[image]
ActiveReports 19 .NET Edition
DataSource Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSource Class

Glossary Item Box

Represents information about a data source.

Object Model

DataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSource
C#
public sealed class DataSource

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSource Class Members

[image]
ActiveReports 19 .NET Edition
DataSource Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSource Class

Glossary Item Box

The following tables list the members exposed by DataSource.

Public Properties

 | Name | Description
Public Property | DataProvider | Returns the type of data provider of this DataSource.
Public Property | DataSourceReference | Gets the path to the data source of this DataSource.
Public Property | Name | Returns the name of this DataSource.
Top

See Also

Reference

DataSource Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSource Class Properties

[image]
ActiveReports 19 .NET Edition
DataSource Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSource Class

Glossary Item Box

For a list of all members of this type, see DataSource members.

Public Properties

 | Name | Description
Public Property | DataProvider | Returns the type of data provider of this DataSource.
Public Property | DataSourceReference | Gets the path to the data source of this DataSource.
Public Property | Name | Returns the name of this DataSource.
Top

See Also

Reference

DataSource Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataProvider Property

[image]
ActiveReports 19 .NET Edition
DataProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSource Class : DataProvider Property

Glossary Item Box

Returns the type of data provider of this DataSource.

Syntax

Visual Basic (Declaration)
Public Property DataProvider As String
C#
public string DataProvider {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSourceReference Property

[image]
ActiveReports 19 .NET Edition
DataSourceReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSource Class : DataSourceReference Property

Glossary Item Box

Gets the path to the data source of this DataSource.

Syntax

Visual Basic (Declaration)
Public Property DataSourceReference As String
C#
public string DataSourceReference {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSource Class : Name Property

Glossary Item Box

Returns the name of this DataSource.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


DataSources Class

[image]
ActiveReports 19 .NET Edition
DataSources Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSources Class

Glossary Item Box

Represents a collection of DataSource references.

Object Model

DataSources Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSources
C#
public sealed class DataSources

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DataSources

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSources Class Members

[image]
ActiveReports 19 .NET Edition
DataSources Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSources Class

Glossary Item Box

The following tables list the members exposed by DataSources.

Public Properties

 | Name | Description
Public Property | Item | Gets the DataSet with the given name.
Top

See Also

Reference

DataSources Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DataSources Class Properties

[image]
ActiveReports 19 .NET Edition
DataSources Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DataSources Class

Glossary Item Box

For a list of all members of this type, see DataSources members.

Public Properties

 | Name | Description
Public Property | Item | Gets the DataSet with the given name.
Top

See Also

Reference

DataSources Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DataSources Class : Item Property

name

Glossary Item Box

Gets the DataSet with the given name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As DataSource
C#
public DataSource this[
   string name
]; {get;}

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSources Class
DataSources Members


DocumentMapProperties Class

[image]
ActiveReports 19 .NET Edition
DocumentMapProperties Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DocumentMapProperties Class

Glossary Item Box

Represents the properties of a document map used to access the Table of Contents (TOC) properties collection.

Object Model

DocumentMapProperties Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DocumentMapProperties
C#
public sealed class DocumentMapProperties

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.DocumentMapProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DocumentMapProperties Class Members

[image]
ActiveReports 19 .NET Edition
DocumentMapProperties Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DocumentMapProperties Class

Glossary Item Box

The following tables list the members exposed by DocumentMapProperties.

Public Properties

 | Name | Description
Public Property | Label | The label in document map.
Public Property | Level | The level in document map.
Public Property | PageNumber | The page number.
Public Property | Path | The document map path.
Public Property | Properties | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).
Top

See Also

Reference

DocumentMapProperties Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


DocumentMapProperties Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentMapProperties Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : DocumentMapProperties Class

Glossary Item Box

For a list of all members of this type, see DocumentMapProperties members.

Public Properties

 | Name | Description
Public Property | Label | The label in document map.
Public Property | Level | The level in document map.
Public Property | PageNumber | The page number.
Public Property | Path | The document map path.
Public Property | Properties | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).
Top

See Also

Reference

DocumentMapProperties Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DocumentMapProperties Class : Label Property

Glossary Item Box

The label in document map.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Class
DocumentMapProperties Members


Level Property

[image]
ActiveReports 19 .NET Edition
Level Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DocumentMapProperties Class : Level Property

Glossary Item Box

The level in document map.

Syntax

Visual Basic (Declaration)
Public Property Level As Integer
C#
public int Level {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Class
DocumentMapProperties Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DocumentMapProperties Class : PageNumber Property

Glossary Item Box

The page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As String
C#
public string PageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Class
DocumentMapProperties Members


Path Property

[image]
ActiveReports 19 .NET Edition
Path Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DocumentMapProperties Class : Path Property

Glossary Item Box

The document map path.

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Class
DocumentMapProperties Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > DocumentMapProperties Class : Properties Property

property

Glossary Item Box

The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal property As String _
) As Object
C#
public object this[
   string property
]; {get;}

Parameters

property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapProperties Class
DocumentMapProperties Members


Field Class

[image]
ActiveReports 19 .NET Edition
Field Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Field Class

Glossary Item Box

Represents information about a field.

Object Model

Field Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Field
C#
public sealed class Field

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Field

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Field Class Members

[image]
ActiveReports 19 .NET Edition
Field Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Field Class

Glossary Item Box

The following tables list the members exposed by Field.

Public Properties

 | Name | Description
Public Property | Name | Field name.
Public Property | Properties | Allows to acces Name and Value by case-insensitive key (name and value respectively).
Public Property | Value | Field value.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Field Class Properties

[image]
ActiveReports 19 .NET Edition
Field Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Properties

 | Name | Description
Public Property | Name | Field name.
Public Property | Properties | Allows to acces Name and Value by case-insensitive key (name and value respectively).
Public Property | Value | Field value.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Field Class : Name Property

Glossary Item Box

Field name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Field Class : Properties Property

property

Glossary Item Box

Allows to acces Name and Value by case-insensitive key (name and value respectively).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal property As String _
) As Object
C#
public object this[
   string property
]; {get;}

Parameters

property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Field Class : Value Property

Glossary Item Box

Field value.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Fields Class

[image]
ActiveReports 19 .NET Edition
Fields Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Fields Class

Glossary Item Box

Represents the implementation for the RDL Fields global collection to be used in user's script.

Object Model

Fields Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Fields
C#
public sealed class Fields

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fields Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Fields Class Members

[image]
ActiveReports 19 .NET Edition
Fields Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Fields Class

Glossary Item Box

The following tables list the members exposed by Fields.

Public Properties

 | Name | Description
Public Property | Item | Returns the Field from collection by its name.
Top

See Also

Reference

Fields Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Fields Class Properties

[image]
ActiveReports 19 .NET Edition
Fields Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Fields Class

Glossary Item Box

For a list of all members of this type, see Fields members.

Public Properties

 | Name | Description
Public Property | Item | Returns the Field from collection by its name.
Top

See Also

Reference

Fields Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Fields Class : Item Property

fieldName
The name of the field.

Glossary Item Box

Returns the Field from collection by its name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal fieldName As String _
) As Object
C#
public object this[
   string fieldName
]; {get;}

Parameters

fieldName
The name of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Fields Class
Fields Members


Globals Class

[image]
ActiveReports 19 .NET Edition
Globals Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Globals Class

Glossary Item Box

Represents the implementation for the RDL Globals global collection.

Object Model

Globals Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Globals
C#
public sealed class Globals

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Globals

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Globals Class Members

[image]
ActiveReports 19 .NET Edition
Globals Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Globals Class

Glossary Item Box

The following tables list the members exposed by Globals.

Public Properties

 | Name | Description
Public Property | CumulativePageNumber | Gets the object representing the cumulative page number.
Public Property | CumulativeTotalPages | Gets the object representing the cumulative page count.
Public Property | ExecutionTime | Gets the DateTime when the report begins executing.
Public Property | PageNumber | Gets the object representing the page number.
Public Property | PageNumberInSection | Gets the object representing the page number within the active section.
Public Property | Properties | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).
Public Property | ReportFolder | Gets the path of the folder containing the report.
Public Property | ReportName | Gets the name of the report.
Public Property | TotalPages | Gets the object representing the page count.
Public Property | TotalPagesInSection | Gets the object representing the page count within the active section.
Top

See Also

Reference

Globals Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Globals Class Properties

[image]
ActiveReports 19 .NET Edition
Globals Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Globals Class

Glossary Item Box

For a list of all members of this type, see Globals members.

Public Properties

 | Name | Description
Public Property | CumulativePageNumber | Gets the object representing the cumulative page number.
Public Property | CumulativeTotalPages | Gets the object representing the cumulative page count.
Public Property | ExecutionTime | Gets the DateTime when the report begins executing.
Public Property | PageNumber | Gets the object representing the page number.
Public Property | PageNumberInSection | Gets the object representing the page number within the active section.
Public Property | Properties | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).
Public Property | ReportFolder | Gets the path of the folder containing the report.
Public Property | ReportName | Gets the name of the report.
Public Property | TotalPages | Gets the object representing the page count.
Public Property | TotalPagesInSection | Gets the object representing the page count within the active section.
Top

See Also

Reference

Globals Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


CumulativePageNumber Property

[image]
ActiveReports 19 .NET Edition
CumulativePageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : CumulativePageNumber Property

Glossary Item Box

Gets the object representing the cumulative page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CumulativePageNumber As Object
C#
public object CumulativePageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


CumulativeTotalPages Property

[image]
ActiveReports 19 .NET Edition
CumulativeTotalPages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : CumulativeTotalPages Property

Glossary Item Box

Gets the object representing the cumulative page count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CumulativeTotalPages As Object
C#
public object CumulativeTotalPages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


ExecutionTime Property

[image]
ActiveReports 19 .NET Edition
ExecutionTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : ExecutionTime Property

Glossary Item Box

Gets the DateTime when the report begins executing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutionTime As Date
C#
public DateTime ExecutionTime {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : PageNumber Property

Glossary Item Box

Gets the object representing the page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Object
C#
public object PageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


PageNumberInSection Property

[image]
ActiveReports 19 .NET Edition
PageNumberInSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : PageNumberInSection Property

Glossary Item Box

Gets the object representing the page number within the active section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumberInSection As Object
C#
public object PageNumberInSection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : Properties Property

name

Glossary Item Box

The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item("ObjectName") or Collection("ObjectName") ).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal name As String _
) As Object
C#
public object this[
   string name
]; {get;}

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


ReportFolder Property

[image]
ActiveReports 19 .NET Edition
ReportFolder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : ReportFolder Property

Glossary Item Box

Gets the path of the folder containing the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportFolder As String
C#
public string ReportFolder {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : ReportName Property

Glossary Item Box

Gets the name of the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportName As String
C#
public string ReportName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


TotalPages Property

[image]
ActiveReports 19 .NET Edition
TotalPages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : TotalPages Property

Glossary Item Box

Gets the object representing the page count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalPages As Object
C#
public object TotalPages {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


TotalPagesInSection Property

[image]
ActiveReports 19 .NET Edition
TotalPagesInSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Globals Class : TotalPagesInSection Property

Glossary Item Box

Gets the object representing the page count within the active section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalPagesInSection As Object
C#
public object TotalPagesInSection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Globals Class
Globals Members


MultiValueParameter Class

[image]
ActiveReports 19 .NET Edition
MultiValueParameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : MultiValueParameter Class

Glossary Item Box

Represents a report parameter that can contain multiple values.

Object Model

MultiValueParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MultiValueParameter
   Inherits Parameter
C#
public sealed class MultiValueParameter : Parameter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Parameter
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.MultiValueParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiValueParameter Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


MultiValueParameter Class Members

[image]
ActiveReports 19 .NET Edition
MultiValueParameter Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : MultiValueParameter Class

Glossary Item Box

The following tables list the members exposed by MultiValueParameter.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of values for this parameter.
Public Property | IsMultiValue | Overridden. Gets whether this parameter is a multi-value parameter.
Public Property | Label | Overridden. Gets the array of labels associated with the report parameter.
Public Property | Value | Overridden. Gets the array of values of the report parameter.
Top

See Also

Reference

MultiValueParameter Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


MultiValueParameter Class Properties

[image]
ActiveReports 19 .NET Edition
MultiValueParameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : MultiValueParameter Class

Glossary Item Box

For a list of all members of this type, see MultiValueParameter members.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of values for this parameter.
Public Property | IsMultiValue | Overridden. Gets whether this parameter is a multi-value parameter.
Public Property | Label | Overridden. Gets the array of labels associated with the report parameter.
Public Property | Value | Overridden. Gets the array of values of the report parameter.
Top

See Also

Reference

MultiValueParameter Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > MultiValueParameter Class : Count Property

Glossary Item Box

Gets the number of values for this parameter.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Count As Integer
C#
public override int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiValueParameter Class
MultiValueParameter Members


IsMultiValue Property

[image]
ActiveReports 19 .NET Edition
IsMultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > MultiValueParameter Class : IsMultiValue Property

Glossary Item Box

Gets whether this parameter is a multi-value parameter.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsMultiValue As Boolean
C#
public override bool IsMultiValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiValueParameter Class
MultiValueParameter Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > MultiValueParameter Class : Label Property

Glossary Item Box

Gets the array of labels associated with the report parameter.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Label As Object
C#
public override object Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiValueParameter Class
MultiValueParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > MultiValueParameter Class : Value Property

Glossary Item Box

Gets the array of values of the report parameter.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Value As Object
C#
public override object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiValueParameter Class
MultiValueParameter Members


Parameter Class

[image]
ActiveReports 19 .NET Edition
Parameter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameter Class

Glossary Item Box

Represents a report parameter.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public Class Parameter
C#
public class Parameter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Parameter
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.MultiValueParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Parameter Class Members

[image]
ActiveReports 19 .NET Edition
Parameter Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of values for this parameter.
Public Property | IsMultiValue | Gets whether this parameter is a multi-value parameter.
Public Property | Label | Gets the label associated with the report parameter.
Public Property | Name | Gets the name of the report parameter.
Public Property | Prompt | Gets the text to display to a user when prompting the a for the parameter's value.
Public Property | Properties | Gets the value of the specified property.
Public Property | Value | Gets the value of the report parameter.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Parameter Class Properties

[image]
ActiveReports 19 .NET Edition
Parameter Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of values for this parameter.
Public Property | IsMultiValue | Gets whether this parameter is a multi-value parameter.
Public Property | Label | Gets the label associated with the report parameter.
Public Property | Name | Gets the name of the report parameter.
Public Property | Prompt | Gets the text to display to a user when prompting the a for the parameter's value.
Public Property | Properties | Gets the value of the specified property.
Public Property | Value | Gets the value of the report parameter.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Count Property

Glossary Item Box

Gets the number of values for this parameter.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


IsMultiValue Property

[image]
ActiveReports 19 .NET Edition
IsMultiValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : IsMultiValue Property

Glossary Item Box

Gets whether this parameter is a multi-value parameter.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsMultiValue As Boolean
C#
public virtual bool IsMultiValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Label Property

Glossary Item Box

Gets the label associated with the report parameter.

Syntax

Visual Basic (Declaration)
Public Overridable Property Label As Object
C#
public virtual object Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Name Property

Glossary Item Box

Gets the name of the report parameter.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Prompt Property

[image]
ActiveReports 19 .NET Edition
Prompt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Prompt Property

Glossary Item Box

Gets the text to display to a user when prompting the a for the parameter's value.

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Properties Property

name
A string value indicating the property for which to get the value.

Glossary Item Box

Gets the value of the specified property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal name As String _
) As Object
C#
public object this[
   string name
]; {get;}

Parameters

name
A string value indicating the property for which to get the value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameter Class : Value Property

Glossary Item Box

Gets the value of the report parameter.

Syntax

Visual Basic (Declaration)
Public Overridable Property Value As Object
C#
public virtual object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameters Class

[image]
ActiveReports 19 .NET Edition
Parameters Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameters Class

Glossary Item Box

Defines a proxy to the Report parameters collection.

Object Model

Parameters Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameters
C#
public sealed class Parameters

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Parameters Class Members

[image]
ActiveReports 19 .NET Edition
Parameters Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameters Class

Glossary Item Box

The following tables list the members exposed by Parameters.

Public Constructors

 | Name | Description
Public Constructor | Parameters Constructor | Initializes a new instance of the Parameters class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Returns the corresponding Parameter based on the key.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified item.
Public Method | Clear | Clears this instance.
Public Method | Contains | Determines whether collection contains the specified item.
Public Method | CopyTo | Copies the elements collection to given array starting at particular index.
Public Method | Remove | Removes the specified item.
Top

See Also

Reference

Parameters Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Parameters Constructor(ParameterCollection)

[image]
ActiveReports 19 .NET Edition
Parameters Constructor(ParameterCollection)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class > Parameters Constructor : Parameters Constructor(ParameterCollection)

parameters
The parameters.

Glossary Item Box

Initializes a new instance of the Parameters class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameters As ParameterCollection _
)
C#
public Parameters(
   ParameterCollection parameters
)

Parameters

parameters
The parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members
Overload List


Parameters Class Methods

[image]
ActiveReports 19 .NET Edition
Parameters Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameters Class

Glossary Item Box

For a list of all members of this type, see Parameters members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified item.
Public Method | Clear | Clears this instance.
Public Method | Contains | Determines whether collection contains the specified item.
Public Method | CopyTo | Copies the elements collection to given array starting at particular index.
Public Method | Remove | Removes the specified item.
Top

See Also

Reference

Parameters Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Add Method

item
The item.

Glossary Item Box

Adds the specified item.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As Parameter _
)
C#
public void Add(
   Parameter item
)

Parameters

item
The item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Clear Method

Glossary Item Box

Clears this instance.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Contains Method

item
The item.

Glossary Item Box

Determines whether collection contains the specified item.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Parameter _
) As Boolean
C#
public bool Contains(
   Parameter item
)

Parameters

item
The item.

Return Value

System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : CopyTo Method

array
The array.
arrayIndex
Index of the array.

Glossary Item Box

Copies the elements collection to given array starting at particular index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Parameter, _
   ByVal arrayIndex As Integer _
)
C#
public void CopyTo(
   Parameter[] array,
   int arrayIndex
)

Parameters

array
The array.
arrayIndex
Index of the array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Remove Method

item
The item.

Glossary Item Box

Removes the specified item.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As Parameter _
) As Boolean
C#
public bool Remove(
   Parameter item
)

Parameters

item
The item.

Return Value

System.Boolean.

Remarks

Not supported for this collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Parameters Class Properties

[image]
ActiveReports 19 .NET Edition
Parameters Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : Parameters Class

Glossary Item Box

For a list of all members of this type, see Parameters members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Returns the corresponding Parameter based on the key.
Top

See Also

Reference

Parameters Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Count Property

Glossary Item Box

Gets the count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

Value indicating whether the collection is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > Parameters Class : Item Property

key

Glossary Item Box

Returns the corresponding Parameter based on the key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal key As Object _
) As Parameter
C#
public Parameter this[
   object key
]; {get;}

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameters Class
Parameters Members


ReportItem Class

[image]
ActiveReports 19 .NET Edition
ReportItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItem Class

Glossary Item Box

Represents a report item.

Object Model

ReportItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportItem
C#
public sealed class ReportItem

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.ReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


ReportItem Class Members

[image]
ActiveReports 19 .NET Edition
ReportItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItem Class

Glossary Item Box

The following tables list the members exposed by ReportItem.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report item.
Public Property | Properties | Gets the value of the specified property
Public Property | Value | Gets the value of the report item.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


ReportItem Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItem Class

Glossary Item Box

For a list of all members of this type, see ReportItem members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report item.
Public Property | Properties | Gets the value of the specified property
Public Property | Value | Gets the value of the report item.
Top

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > ReportItem Class : Name Property

Glossary Item Box

Gets the name of the report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Properties Property

[image]
ActiveReports 19 .NET Edition
Properties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > ReportItem Class : Properties Property

name
A string value indicating the property for which to get the value.

Glossary Item Box

Gets the value of the specified property

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Properties( _
   ByVal name As String _
) As Object
C#
public object this[
   string name
]; {get;}

Parameters

name
A string value indicating the property for which to get the value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > ReportItem Class : Value Property

Glossary Item Box

Gets the value of the report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Class
ReportItem Members


ReportItems Class

[image]
ActiveReports 19 .NET Edition
ReportItems Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItems Class

Glossary Item Box

Provides the implementation for the RDL ReportItems global collection.

Object Model

ReportItems Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportItems
C#
public sealed class ReportItems

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.ReportItems

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItems Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


ReportItems Class Members

[image]
ActiveReports 19 .NET Edition
ReportItems Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItems Class

Glossary Item Box

The following tables list the members exposed by ReportItems.

Public Properties

 | Name | Description
Public Property | Item | Return the report items by it's name.
Top

See Also

Reference

ReportItems Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


ReportItems Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItems Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : ReportItems Class

Glossary Item Box

For a list of all members of this type, see ReportItems members.

Public Properties

 | Name | Description
Public Property | Item | Return the report items by it's name.
Top

See Also

Reference

ReportItems Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > ReportItems Class : Item Property

reportItemName
The name of the report items.

Glossary Item Box

Return the report items by it's name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal reportItemName As String _
) As ReportItem()
C#
public ReportItem[] this[
   string reportItemName
]; {get;}

Parameters

reportItemName
The name of the report items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItems Class
ReportItems Members


User Class

[image]
ActiveReports 19 .NET Edition
User Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : User Class

Glossary Item Box

Provides the implementation for the RDL User global collection.

Object Model

User Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class User
C#
public sealed class User

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes.User

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Members
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


User Class Members

[image]
ActiveReports 19 .NET Edition
User Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : User Class

Glossary Item Box

The following tables list the members exposed by User.

Public Properties

 | Name | Description
Public Property | Item | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item(�ObjectName�) or Collection(�ObjectName�) ).
Public Property | Language | Gets name of the culture.
Public Property | UserID | Gets the Id of the user.
Top

See Also

Reference

User Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


User Class Properties

[image]
ActiveReports 19 .NET Edition
User Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace : User Class

Glossary Item Box

For a list of all members of this type, see User members.

Public Properties

 | Name | Description
Public Property | Item | The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item(�ObjectName�) or Collection(�ObjectName�) ).
Public Property | Language | Gets name of the culture.
Public Property | UserID | Gets the Id of the user.
Top

See Also

Reference

User Class
GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > User Class : Item Property

name

Glossary Item Box

The indexer to support the various VB collection access syntax ( Collection!ObjectName or Collection.Item(�ObjectName�) or Collection(�ObjectName�) ).

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal name As String _
) As String
C#
public string this[
   string name
]; {get;}

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > User Class : Language Property

Glossary Item Box

Gets name of the culture.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


UserID Property

[image]
ActiveReports 19 .NET Edition
UserID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Expressions.Remote.GlobalDataTypes Namespace > User Class : UserID Property

Glossary Item Box

Gets the Id of the user.

Syntax

Visual Basic (Declaration)
Public Property UserID As String
C#
public string UserID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


ContentRange Class

[image]
ActiveReports 19 .NET Edition
ContentRange Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

Glossary Item Box

This is an abstract class that the ReportItem's layout manager creates, interprets and uses to denote a range with a logical beginning and end in its underlying content.

Object Model

ContentRange Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ContentRange
   Implements IContentRange
C#
public abstract class ContentRange : IContentRange

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.ContentRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ContentRange Class Members

[image]
ActiveReports 19 .NET Edition
ContentRange Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

Glossary Item Box

The following tables list the members exposed by ContentRange.

Public Properties

 | Name | Description
Public Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top

See Also

Reference

ContentRange Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ContentRange Class Properties

[image]
ActiveReports 19 .NET Edition
ContentRange Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

Glossary Item Box

For a list of all members of this type, see ContentRange members.

Public Properties

 | Name | Description
Public Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top

See Also

Reference

ContentRange Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Owner Property

[image]
ActiveReports 19 .NET Edition
Owner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ContentRange Class : Owner Property

Glossary Item Box

Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Owner As IReportItem
C#
public abstract IReportItem Owner {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContentRange Class
ContentRange Members


ITargetDeviceExtensions Class

[image]
ActiveReports 19 .NET Edition
ITargetDeviceExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDeviceExtensions Class

Glossary Item Box

Represents an extension methods for ITargetDevice

Object Model

ITargetDeviceExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ITargetDeviceExtensions
C#
public static class ITargetDeviceExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.ITargetDeviceExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITargetDeviceExtensions Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDeviceExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ITargetDeviceExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDeviceExtensions Class

Glossary Item Box

The following tables list the members exposed by ITargetDeviceExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResolution |
static (Shared in Visual Basic) | GetTargetDeviceKind |
Top

See Also

Reference

ITargetDeviceExtensions Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDeviceExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ITargetDeviceExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDeviceExtensions Class

Glossary Item Box

For a list of all members of this type, see ITargetDeviceExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetResolution |
static (Shared in Visual Basic) | GetTargetDeviceKind |
Top

See Also

Reference

ITargetDeviceExtensions Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GetResolution Method

[image]
ActiveReports 19 .NET Edition
GetResolution Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITargetDeviceExtensions Class : GetResolution Method

device

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetResolution( _
   ByVal device As ITargetDevice _
) As SizeF
C#
public static SizeF GetResolution(
   ITargetDevice device
)

Parameters

device

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITargetDeviceExtensions Class
ITargetDeviceExtensions Members


GetTargetDeviceKind Method

[image]
ActiveReports 19 .NET Edition
GetTargetDeviceKind Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITargetDeviceExtensions Class : GetTargetDeviceKind Method

device

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetTargetDeviceKind( _
   ByVal device As ITargetDevice _
) As TargetDeviceKind
C#
public static TargetDeviceKind GetTargetDeviceKind(
   ITargetDevice device
)

Parameters

device

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITargetDeviceExtensions Class
ITargetDeviceExtensions Members


LayoutManagerAttribute Class

[image]
ActiveReports 19 .NET Edition
LayoutManagerAttribute Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

Glossary Item Box

Specifies the class used to implement layout services for a component.

Object Model

LayoutManagerAttribute Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayoutManagerAttribute
   Inherits System.Attribute
C#
public sealed class LayoutManagerAttribute : System.Attribute

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Extensibility.Layout.LayoutManagerAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutManagerAttribute Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerAttribute Class Members

[image]
ActiveReports 19 .NET Edition
LayoutManagerAttribute Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

Glossary Item Box

The following tables list the members exposed by LayoutManagerAttribute.

Public Constructors

 | Name | Description
Public Constructor | LayoutManagerAttribute Constructor | Initializes a new instance of the LayoutManagerAttribute class.
Top

Public Properties

 | Name | Description
Public Property | LayoutManagerType | Returns the System.Type that provides rendering services for the component to which the attribute is bound.
Top

See Also

Reference

LayoutManagerAttribute Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerAttribute Constructor

[image]
ActiveReports 19 .NET Edition
LayoutManagerAttribute Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : LayoutManagerAttribute Constructor

layoutManagerType
The System.Type that provides rendering services for the component to which the attribute is bound.

Glossary Item Box

Initializes a new instance of the LayoutManagerAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal layoutManagerType As Type _
)
C#
public LayoutManagerAttribute(
   Type layoutManagerType
)

Parameters

layoutManagerType
The System.Type that provides rendering services for the component to which the attribute is bound.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


LayoutManagerAttribute Class Properties

[image]
ActiveReports 19 .NET Edition
LayoutManagerAttribute Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

Glossary Item Box

For a list of all members of this type, see LayoutManagerAttribute members.

Public Properties

 | Name | Description
Public Property | LayoutManagerType | Returns the System.Type that provides rendering services for the component to which the attribute is bound.
Top

See Also

Reference

LayoutManagerAttribute Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerType Property

[image]
ActiveReports 19 .NET Edition
LayoutManagerType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : LayoutManagerType Property

Glossary Item Box

Returns the System.Type that provides rendering services for the component to which the attribute is bound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutManagerType As Type
C#
public Type LayoutManagerType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


LayoutPageExtensions Class

[image]
ActiveReports 19 .NET Edition
LayoutPageExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutPageExtensions Class

Glossary Item Box

Represents an extension methods for ILayoutPage

Object Model

LayoutPageExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class LayoutPageExtensions
C#
public static class LayoutPageExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.LayoutPageExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutPageExtensions Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutPageExtensions Class Members

[image]
ActiveReports 19 .NET Edition
LayoutPageExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutPageExtensions Class

Glossary Item Box

The following tables list the members exposed by LayoutPageExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalculateEvaluationBounds | Calculates evaluation message bounds.
Top

See Also

Reference

LayoutPageExtensions Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutPageExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
LayoutPageExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutPageExtensions Class

Glossary Item Box

For a list of all members of this type, see LayoutPageExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalculateEvaluationBounds | Calculates evaluation message bounds.
Top

See Also

Reference

LayoutPageExtensions Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CalculateEvaluationBounds Method

[image]
ActiveReports 19 .NET Edition
CalculateEvaluationBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutPageExtensions Class : CalculateEvaluationBounds Method

page
evalPosition
excludeMargins

Glossary Item Box

Calculates evaluation message bounds.

Syntax

Visual Basic (Declaration)
Public Shared Function CalculateEvaluationBounds( _
   ByVal page As ILayoutPage, _
   Optional ByVal evalPosition As EvalPosition, _
   Optional ByVal excludeMargins As Boolean _
) As RectangleF
C#
public static RectangleF CalculateEvaluationBounds(
   ILayoutPage page,
   EvalPosition evalPosition,
   bool excludeMargins
)

Parameters

page
evalPosition
excludeMargins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutPageExtensions Class
LayoutPageExtensions Members


SupportedPageInfo Class

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

Glossary Item Box

Supported page information.

Object Model

SupportedPageInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SupportedPageInfo
C#
public sealed class SupportedPageInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.SupportedPageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SupportedPageInfo Class Members

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

Glossary Item Box

The following tables list the members exposed by SupportedPageInfo.

Public Constructors

 | Name | Description
Public Constructor | SupportedPageInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BottomMargin | Specifies the bottom margin in twips.
Public Property | Height | Gets the page height in twips.
Public Property | LeftMargin | Specifies the left margin in twips.
Public Property | MarginsApplyMode |
Public Property | RightMargin | Specifies the right margin in twips.
Public Property | TopMargin | Gets the top margin in twips.
Public Property | Width | Gets the page width in twips.
Top

Public Methods

 | Name | Description
Public Method | SetWidth | Sets the width of the page in twips.
Top

See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SupportedPageInfo Constructor

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : SupportedPageInfo Constructor

Glossary Item Box

Overload List

Overload | Description
SupportedPageInfo Constructor(Int32,Int32) | Instantiates a new instance of the SupportedPageInfo class with the specified width and height.
SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Instantiates a new instance of the SupportedPageInfo class with the specified width, height and margins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


SupportedPageInfo Constructor(Int32,Int32)

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Constructor(Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class > SupportedPageInfo Constructor : SupportedPageInfo Constructor(Int32,Int32)

width
The page width in twips.
height
The page height in twips.

Glossary Item Box

Instantiates a new instance of the SupportedPageInfo class with the specified width and height.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public SupportedPageInfo(
   int width,
   int height
)

Parameters

width
The page width in twips.
height
The page height in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members
Overload List


SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class > SupportedPageInfo Constructor : SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

width
The page width in twips.
height
The page height in twips.
leftMargin
The left margin in twips.
topMargin
The top margin in twips.
rightMargin
The right margin in twips.
bottomMargin
The bottom margin in twips.

Glossary Item Box

Instantiates a new instance of the SupportedPageInfo class with the specified width, height and margins.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal leftMargin As Integer, _
   ByVal topMargin As Integer, _
   ByVal rightMargin As Integer, _
   ByVal bottomMargin As Integer _
)
C#
public SupportedPageInfo(
   int width,
   int height,
   int leftMargin,
   int topMargin,
   int rightMargin,
   int bottomMargin
)

Parameters

width
The page width in twips.
height
The page height in twips.
leftMargin
The left margin in twips.
topMargin
The top margin in twips.
rightMargin
The right margin in twips.
bottomMargin
The bottom margin in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members
Overload List


SupportedPageInfo Class Methods

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

Glossary Item Box

For a list of all members of this type, see SupportedPageInfo members.

Public Methods

 | Name | Description
Public Method | SetWidth | Sets the width of the page in twips.
Top

See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SetWidth Method

[image]
ActiveReports 19 .NET Edition
SetWidth Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : SetWidth Method

value
An System.Int32 indicating the number of twips to which to set the page width.

Glossary Item Box

Sets the width of the page in twips.

Syntax

Visual Basic (Declaration)
Public Sub SetWidth( _
   ByVal value As Integer _
)
C#
public void SetWidth(
   int value
)

Parameters

value
An System.Int32 indicating the number of twips to which to set the page width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


SupportedPageInfo Class Properties

[image]
ActiveReports 19 .NET Edition
SupportedPageInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

Glossary Item Box

For a list of all members of this type, see SupportedPageInfo members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Specifies the bottom margin in twips.
Public Property | Height | Gets the page height in twips.
Public Property | LeftMargin | Specifies the left margin in twips.
Public Property | MarginsApplyMode |
Public Property | RightMargin | Specifies the right margin in twips.
Public Property | TopMargin | Gets the top margin in twips.
Public Property | Width | Gets the page width in twips.
Top

See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : BottomMargin Property

Glossary Item Box

Specifies the bottom margin in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BottomMargin As Integer
C#
public int BottomMargin {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : Height Property

Glossary Item Box

Gets the page height in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
C#
public int Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : LeftMargin Property

Glossary Item Box

Specifies the left margin in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftMargin As Integer
C#
public int LeftMargin {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


MarginsApplyMode Property

[image]
ActiveReports 19 .NET Edition
MarginsApplyMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : MarginsApplyMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MarginsApplyMode As MarginsApplyMode
C#
public MarginsApplyMode MarginsApplyMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : RightMargin Property

Glossary Item Box

Specifies the right margin in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightMargin As Integer
C#
public int RightMargin {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : TopMargin Property

Glossary Item Box

Gets the top margin in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopMargin As Integer
C#
public int TopMargin {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : Width Property

Glossary Item Box

Gets the page width in twips.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
C#
public int Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


EvalPosition Enumeration

[image]
ActiveReports 19 .NET Edition
EvalPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : EvalPosition Enumeration

Glossary Item Box

Specifies evaluation message alignment.

Syntax

Visual Basic (Declaration)
Public Enum EvalPosition
   Inherits System.Enum
C#
public enum EvalPosition : System.Enum

Members

Member | Description
Bottom | Evaluation message should be at bottom of the page.
Top | Evaluation message should be at top of the page.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.EvalPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


Features Enumeration

[image]
ActiveReports 19 .NET Edition
Features Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : Features Enumeration

Glossary Item Box

All the features recognized by the layout engine. This enumeration is used to locate rendering device capabilities.

Syntax

Visual Basic (Declaration)
Public Enum Features
   Inherits System.Enum
C#
public enum Features : System.Enum

Members

Member | Description
CollapsibleRows | Specifies whether the target device supports expandable rows
FeatureFooter | Specifies whether the footer is generated.
FeatureHeader | Specifies whether the header is generated.
FeatureInteractiveSortingToggling | Specifies whether the target device supports interactive sorting/toggling features.
FeatureInteractivity | Specifies whether the target device supports interactivity features.
FeaturePagination | Specifies that a structure describing page size is supplied if the feature is supported.
FeatureResoluton | Specifies what resolution (dpi) is available for the target device. (The descriptor contains a single SizeF value corresponding to the horizontal and vertical resolutions respectively.)
TargetDevice | Defines output kinds which is used now by ITargetDevice

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.Features

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestResult Enumeration

[image]
ActiveReports 19 .NET Edition
HitTestResult Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestResult Enumeration

Glossary Item Box

Specifies which area is hit. This enumeration is used with the HitTestInfo.HitTestResult property to determine where a mouse click occurs.

Syntax

Visual Basic (Declaration)
Public Enum HitTestResult
   Inherits System.Enum
C#
public enum HitTestResult : System.Enum

Members

Member | Description
InteractiveArea | Indicates that the mouse click region can accept events.
NonIteractiveArea | Indicates that mouse click region can not accept events.
NoWhere | Indicates that the mouse click is in a region beyond the area of the report.
TooltipArea | Indicates that mouse click tooltip area region.
TooltipInteractiveArea | Indicates that mouse click tooltip interactive area region.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.HitTestResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutCapabilities Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutCapabilities Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutCapabilities Enumeration

Glossary Item Box

Specifies what layout options are available for the report item. This enumeration is used with the ILayoutManager.Capabilities property.

Syntax

Visual Basic (Declaration)
Public Enum LayoutCapabilities
   Inherits System.Enum
C#
public enum LayoutCapabilities : System.Enum

Members

Member | Description
CanGrowHorizontally | The report item can grow horizontally to fit the contents.
CanGrowVertically | The report item can grow vertically to fit the contents.
CanShrinkHorizontally | The report item can shrink horizontally to fit the contents.
CanShrinkVertically | The report item can shrink vertically to fit the contents.
CanSplitHorizontally | When the contents do not fit, the left portion of the report item can be rendered on the current page and the right portion on the following page. The default behavior is for the entire report item to move to the following page.
CanSplitVertically | When the contents do not fit, the top portion of the report item can be rendered on the current page and the bottom portion on the following page. The default behavior is for the entire report item to move to the following page.
None | The report item size remains fixed regardless of the contents.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutCapabilities

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutDirection Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutDirection Enumeration

Glossary Item Box

Specifies the direction in which the layout runs on the current page. This enumeration is used with the LayoutContext.LayoutDirection property.

Syntax

Visual Basic (Declaration)
Public Enum LayoutDirection
   Inherits System.Enum
C#
public enum LayoutDirection : System.Enum

Members

Member | Description
Both | The layout runs from top to bottom and left to right.
Horizontal | The layout runs from left to right.
None | No direction is specified.
Vertical | The layout runs from top to bottom.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutStatus Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutStatus Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutStatus Enumeration

Glossary Item Box

Indicates the progress of the layout operation. This enumeration is used with the LayoutResult.LayoutStatus property.

Syntax

Visual Basic (Declaration)
Public Enum LayoutStatus
   Inherits System.Enum
C#
public enum LayoutStatus : System.Enum

Members

Member | Description
Complete | Indicates that the item is laid out in its entirety.
ContinueHorizontally | Indicates that item continues layout in the next horizontal page.
ContinueVertically | Indicates that item continues layout in the next vertical page.
ForcedVerticalPageBreak | Indicates that a page break is produced after this layout operation.
NoContent | Indicates that no content is laid out.
None | Specifies an unknown status, with no layout operations performed. Please note that this is different from the NoContent status.
SomeContent | Indicates that some content is laid out, but that the layout is not complete and more layout runs are required for the item.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


MarginsApplyMode Enumeration

[image]
ActiveReports 19 .NET Edition
MarginsApplyMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : MarginsApplyMode Enumeration

Glossary Item Box

Represents the modes for applying custom margins in a report.

Syntax

Visual Basic (Declaration)
Public Enum MarginsApplyMode
   Inherits System.Enum
C#
public enum MarginsApplyMode : System.Enum

Members

Member | Description
Body | Custom margins affect page size but not body size.
Page | Custom margins affect body size but not page size.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.MarginsApplyMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


SpanCellResolveMethod Enumeration

[image]
ActiveReports 19 .NET Edition
SpanCellResolveMethod Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SpanCellResolveMethod Enumeration

Glossary Item Box

Specifies the different methods to indicate spanned cells.

Syntax

Visual Basic (Declaration)
Public Enum SpanCellResolveMethod
   Inherits System.Enum
C#
public enum SpanCellResolveMethod : System.Enum

Members

Member | Description
DuplicateCell | Duplicate cell.
NullCell | Null cell.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.SpanCellResolveMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


DeviceCapabilities Structure

[image]
ActiveReports 19 .NET Edition
DeviceCapabilities Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure

Glossary Item Box

Describes the target rendering device capabilities for a specific set of features.

Object Model

DeviceCapabilities Structure

Syntax

Visual Basic (Declaration)
Public Structure DeviceCapabilities
   Inherits System.ValueType
C#
public struct DeviceCapabilities : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.DeviceCapabilities

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceCapabilities Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


DeviceCapabilities Structure Members

[image]
ActiveReports 19 .NET Edition
DeviceCapabilities Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure

Glossary Item Box

The following tables list the members exposed by DeviceCapabilities.

Public Constructors

 | Name | Description
Public Constructor | DeviceCapabilities Constructor | Initializes a new instance of the DeviceCapabilities structure.
Top

Public Properties

 | Name | Description
Public Property | Descriptor | The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.
Public Property | Supported | Gets true if the features set is supported by the target device.
Top

See Also

Reference

DeviceCapabilities Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


DeviceCapabilities Constructor

[image]
ActiveReports 19 .NET Edition
DeviceCapabilities Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : DeviceCapabilities Constructor

supported
True if the specified feature map is supported.
supportedFeatureMap
An object containing a feature or an array of features.

Glossary Item Box

Initializes a new instance of the DeviceCapabilities structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal supported As Boolean, _
   ByVal supportedFeatureMap As Object _
)
C#
public DeviceCapabilities(
   bool supported,
   object supportedFeatureMap
)

Parameters

supported
True if the specified feature map is supported.
supportedFeatureMap
An object containing a feature or an array of features.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


DeviceCapabilities Structure Properties

[image]
ActiveReports 19 .NET Edition
DeviceCapabilities Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure

Glossary Item Box

For a list of all members of this type, see DeviceCapabilities members.

Public Properties

 | Name | Description
Public Property | Descriptor | The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.
Public Property | Supported | Gets true if the features set is supported by the target device.
Top

See Also

Reference

DeviceCapabilities Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Descriptor Property

[image]
ActiveReports 19 .NET Edition
Descriptor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : Descriptor Property

Glossary Item Box

The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Descriptor As Object
C#
public object Descriptor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


Supported Property

[image]
ActiveReports 19 .NET Edition
Supported Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : Supported Property

Glossary Item Box

Gets true if the features set is supported by the target device.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Supported As Boolean
C#
public bool Supported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


HitTestInfo Structure

[image]
ActiveReports 19 .NET Edition
HitTestInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure

Glossary Item Box

Contains information about the part of the layout area in which a mouse click occurs.

Object Model

HitTestInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure HitTestInfo
   Inherits System.ValueType
C#
public struct HitTestInfo : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.HitTestInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestInfo Structure Members

[image]
ActiveReports 19 .NET Edition
HitTestInfo Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure

Glossary Item Box

The following tables list the members exposed by HitTestInfo.

Public Constructors

 | Name | Description
Public Constructor | HitTestInfo Constructor | Initializes a new instance of the HitTestInfo structure at the area underlying a mouse click.
Top

Public Properties

 | Name | Description
Public Property | AcceptsEvents | Specifies whether the area in which the mouse click occurs can accept user events.
Public Property | Data | Hit test info data.
Public Property | HitTestResult | Specifies an enumerated HitTestResult value indicating whether the mouse click is in an interactive area.
Public Property | InteractiveAreaId | Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.
Public Property | IsInArea | Specifies whether the area in which the mouse click occurs is within the area defined by the ILayoutArea interface.
Public Property | ReportItem | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.
Top

See Also

Reference

HitTestInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestInfo Constructor

[image]
ActiveReports 19 .NET Edition
HitTestInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : HitTestInfo Constructor

result
An enumerated HitTestResult value indicating whether the mouse click is in an interactive area.
underlyingArea
An ILayoutArea interface defining the area on which the hit test is performed.
interactiveAreaID
A System.String value indicating the ID assigned to the area.
data
A System.String value containing additional data related to the hit test.

Glossary Item Box

Initializes a new instance of the HitTestInfo structure at the area underlying a mouse click.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal result As HitTestResult, _
   ByVal underlyingArea As ILayoutArea, _
   ByVal interactiveAreaID As String, _
   ByVal data As String _
)
C#
public HitTestInfo(
   HitTestResult result,
   ILayoutArea underlyingArea,
   string interactiveAreaID,
   string data
)

Parameters

result
An enumerated HitTestResult value indicating whether the mouse click is in an interactive area.
underlyingArea
An ILayoutArea interface defining the area on which the hit test is performed.
interactiveAreaID
A System.String value indicating the ID assigned to the area.
data
A System.String value containing additional data related to the hit test.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


HitTestInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
HitTestInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure

Glossary Item Box

For a list of all members of this type, see HitTestInfo members.

Public Properties

 | Name | Description
Public Property | AcceptsEvents | Specifies whether the area in which the mouse click occurs can accept user events.
Public Property | Data | Hit test info data.
Public Property | HitTestResult | Specifies an enumerated HitTestResult value indicating whether the mouse click is in an interactive area.
Public Property | InteractiveAreaId | Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.
Public Property | IsInArea | Specifies whether the area in which the mouse click occurs is within the area defined by the ILayoutArea interface.
Public Property | ReportItem | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.
Top

See Also

Reference

HitTestInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AcceptsEvents Property

[image]
ActiveReports 19 .NET Edition
AcceptsEvents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : AcceptsEvents Property

Glossary Item Box

Specifies whether the area in which the mouse click occurs can accept user events.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AcceptsEvents As Boolean
C#
public bool AcceptsEvents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : Data Property

Glossary Item Box

Hit test info data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As String
C#
public string Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


HitTestResult Property

[image]
ActiveReports 19 .NET Edition
HitTestResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : HitTestResult Property

Glossary Item Box

Specifies an enumerated HitTestResult value indicating whether the mouse click is in an interactive area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HitTestResult As HitTestResult
C#
public HitTestResult HitTestResult {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


InteractiveAreaId Property

[image]
ActiveReports 19 .NET Edition
InteractiveAreaId Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : InteractiveAreaId Property

Glossary Item Box

Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InteractiveAreaId As String
C#
public string InteractiveAreaId {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


IsInArea Property

[image]
ActiveReports 19 .NET Edition
IsInArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : IsInArea Property

Glossary Item Box

Specifies whether the area in which the mouse click occurs is within the area defined by the ILayoutArea interface.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInArea As Boolean
C#
public bool IsInArea {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : ReportItem Property

Glossary Item Box

Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItem As IReportItem
C#
public IReportItem ReportItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HitTestInfo Structure
HitTestInfo Members


LayoutContext Structure

[image]
ActiveReports 19 .NET Edition
LayoutContext Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

Glossary Item Box

Encapsulates information about layout operations for the report item to provide input for the ILayoutManager interface.

Object Model

LayoutContext Structure

Syntax

Visual Basic (Declaration)
Public Structure LayoutContext
   Inherits System.ValueType
C#
public struct LayoutContext : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutContext Structure Members

[image]
ActiveReports 19 .NET Edition
LayoutContext Structure Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

Glossary Item Box

The following tables list the members exposed by LayoutContext.

Public Constructors

 | Name | Description
Public Constructor | LayoutContext Constructor | Initializes a new instance of the LayoutContext structure with the specified values.
Top

Public Properties

 | Name | Description
Public Property | AvailableSize | Indicates the maximum size that the report item can occupy in the current operation.
Public Property | ContentRange | Specifies the logical end of the ContentRange object to pick up where a prior layout operation left off.
Public Property | HorizontalLayout | Specifies whether the context is for a horizontal layout run.
Public Property | LayoutDirection | Indicates whether the current page layout runs horizontally, vertically, neither, or both.
Public Property | MetricsProvider | Gets metrics provider.
Public Property | ReportItemSize | Indicates the size of the report item. If the element is in a table, tablix or matrix, then it is equal to the cell size.
Public Property | VerticalLayout | Specifies whether the context is for a vertical layout run.
Top

Public Methods

 | Name | Description
Public Method | AdjustFromResult | Returns a new LayoutContext corresponding to the specified LayoutResult.
Top

See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutContext Constructor

[image]
ActiveReports 19 .NET Edition
LayoutContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : LayoutContext Constructor

metricsProvider
An object that provides text metrics for the report item.
contentRange
A ContentRange object containing information about the range of the underlying content to include in the current layout operation.
direction
An enumerated LayoutDirection value indicating the direction in which the layout for the report item runs.
availableSize
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
reportItemSize
A System.Drawing.SizeF structure containing the width and height of the report item.

Glossary Item Box

Initializes a new instance of the LayoutContext structure with the specified values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal metricsProvider As ITextMetricsProvider, _
   ByVal contentRange As IContentRange, _
   ByVal direction As LayoutDirection, _
   ByVal availableSize As SizeF, _
   Optional ByVal reportItemSize As SizeF _
)
C#
public LayoutContext(
   ITextMetricsProvider metricsProvider,
   IContentRange contentRange,
   LayoutDirection direction,
   SizeF availableSize,
   SizeF reportItemSize
)

Parameters

metricsProvider
An object that provides text metrics for the report item.
contentRange
A ContentRange object containing information about the range of the underlying content to include in the current layout operation.
direction
An enumerated LayoutDirection value indicating the direction in which the layout for the report item runs.
availableSize
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
reportItemSize
A System.Drawing.SizeF structure containing the width and height of the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutContext Structure Methods

[image]
ActiveReports 19 .NET Edition
LayoutContext Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

Glossary Item Box

For a list of all members of this type, see LayoutContext members.

Public Methods

 | Name | Description
Public Method | AdjustFromResult | Returns a new LayoutContext corresponding to the specified LayoutResult.
Top

See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AdjustFromResult Method

[image]
ActiveReports 19 .NET Edition
AdjustFromResult Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : AdjustFromResult Method

result
A LayoutResult object containing the output of the ILayoutManager interface.

Glossary Item Box

Returns a new LayoutContext corresponding to the specified LayoutResult.

Syntax

Visual Basic (Declaration)
Public Function AdjustFromResult( _
   ByVal result As LayoutResult _
) As LayoutContext
C#
public LayoutContext AdjustFromResult(
   LayoutResult result
)

Parameters

result
A LayoutResult object containing the output of the ILayoutManager interface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutContext Structure Properties

[image]
ActiveReports 19 .NET Edition
LayoutContext Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

Glossary Item Box

For a list of all members of this type, see LayoutContext members.

Public Properties

 | Name | Description
Public Property | AvailableSize | Indicates the maximum size that the report item can occupy in the current operation.
Public Property | ContentRange | Specifies the logical end of the ContentRange object to pick up where a prior layout operation left off.
Public Property | HorizontalLayout | Specifies whether the context is for a horizontal layout run.
Public Property | LayoutDirection | Indicates whether the current page layout runs horizontally, vertically, neither, or both.
Public Property | MetricsProvider | Gets metrics provider.
Public Property | ReportItemSize | Indicates the size of the report item. If the element is in a table, tablix or matrix, then it is equal to the cell size.
Public Property | VerticalLayout | Specifies whether the context is for a vertical layout run.
Top

See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AvailableSize Property

[image]
ActiveReports 19 .NET Edition
AvailableSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : AvailableSize Property

Glossary Item Box

Indicates the maximum size that the report item can occupy in the current operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AvailableSize As SizeF
C#
public SizeF AvailableSize {get;}

Remarks

The width and height are in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


ContentRange Property

[image]
ActiveReports 19 .NET Edition
ContentRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : ContentRange Property

Glossary Item Box

Specifies the logical end of the ContentRange object to pick up where a prior layout operation left off.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentRange As IContentRange
C#
public IContentRange ContentRange {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


HorizontalLayout Property

[image]
ActiveReports 19 .NET Edition
HorizontalLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : HorizontalLayout Property

Glossary Item Box

Specifies whether the context is for a horizontal layout run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalLayout As Boolean
C#
public bool HorizontalLayout {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutDirection Property

[image]
ActiveReports 19 .NET Edition
LayoutDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : LayoutDirection Property

Glossary Item Box

Indicates whether the current page layout runs horizontally, vertically, neither, or both.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutDirection As LayoutDirection
C#
public LayoutDirection LayoutDirection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


MetricsProvider Property

[image]
ActiveReports 19 .NET Edition
MetricsProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : MetricsProvider Property

Glossary Item Box

Gets metrics provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetricsProvider As ITextMetricsProvider
C#
public ITextMetricsProvider MetricsProvider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


ReportItemSize Property

[image]
ActiveReports 19 .NET Edition
ReportItemSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : ReportItemSize Property

Glossary Item Box

Indicates the size of the report item. If the element is in a table, tablix or matrix, then it is equal to the cell size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItemSize As SizeF
C#
public SizeF ReportItemSize {get;}

Remarks

The width and height are in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


VerticalLayout Property

[image]
ActiveReports 19 .NET Edition
VerticalLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : VerticalLayout Property

Glossary Item Box

Specifies whether the context is for a vertical layout run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalLayout As Boolean
C#
public bool VerticalLayout {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutInfo Structure

[image]
ActiveReports 19 .NET Edition
LayoutInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

Glossary Item Box

Represents the target device and other layout operation properties.

Object Model

LayoutInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure LayoutInfo
   Inherits System.ValueType
C#
public struct LayoutInfo : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutInfo Structure Members

[image]
ActiveReports 19 .NET Edition
LayoutInfo Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

Glossary Item Box

The following tables list the members exposed by LayoutInfo.

Public Constructors

 | Name | Description
Public Constructor | LayoutInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | TextMetricsProvider |
Top

Public Properties

 | Name | Description
Public Property | NotificationCallback | Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.
Public Property | Report | Specifies Report instance for which layout tree will be generated.
Public Property | TargetDevice | Specifies target device for this LayoutContext.
Top

See Also

Reference

LayoutInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutInfo Constructor

[image]
ActiveReports 19 .NET Edition
LayoutInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : LayoutInfo Constructor

Glossary Item Box

Overload List

Overload | Description
LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider) | Initializes LayoutInfo with specifies ITargetDevice and report.
LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider,LayoutNotificationCallback) | Initializes LayoutInfo with specifies ITargetDevice, Report and notification callback.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members


LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider)

[image]
ActiveReports 19 .NET Edition
LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure > LayoutInfo Constructor : LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider)

report
targetDevice
textMetrixProvider

Glossary Item Box

Initializes LayoutInfo with specifies ITargetDevice and report.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal targetDevice As ITargetDevice, _
   ByVal textMetrixProvider As ITextMetricsProvider _
)
C#
public LayoutInfo(
   IReport report,
   ITargetDevice targetDevice,
   ITextMetricsProvider textMetrixProvider
)

Parameters

report
targetDevice
textMetrixProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members
Overload List


LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider,LayoutNotificationCallback)

[image]
ActiveReports 19 .NET Edition
LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider,LayoutNotificationCallback)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure > LayoutInfo Constructor : LayoutInfo Constructor(IReport,ITargetDevice,ITextMetricsProvider,LayoutNotificationCallback)

report
targetDevice
textMetrixProvider
notificationCallback

Glossary Item Box

Initializes LayoutInfo with specifies ITargetDevice, Report and notification callback.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal targetDevice As ITargetDevice, _
   ByVal textMetrixProvider As ITextMetricsProvider, _
   ByVal notificationCallback As LayoutNotificationCallback _
)
C#
public LayoutInfo(
   IReport report,
   ITargetDevice targetDevice,
   ITextMetricsProvider textMetrixProvider,
   LayoutNotificationCallback notificationCallback
)

Parameters

report
targetDevice
textMetrixProvider
notificationCallback

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members
Overload List


LayoutInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
LayoutInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

Glossary Item Box

For a list of all members of this type, see LayoutInfo members.

Public Properties

 | Name | Description
Public Property | NotificationCallback | Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.
Public Property | Report | Specifies Report instance for which layout tree will be generated.
Public Property | TargetDevice | Specifies target device for this LayoutContext.
Top

See Also

Reference

LayoutInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


NotificationCallback Property

[image]
ActiveReports 19 .NET Edition
NotificationCallback Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : NotificationCallback Property

Glossary Item Box

Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.

Syntax

Visual Basic (Declaration)
Public Property NotificationCallback As LayoutNotificationCallback
C#
public LayoutNotificationCallback NotificationCallback {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : Report Property

Glossary Item Box

Specifies Report instance for which layout tree will be generated.

Syntax

Visual Basic (Declaration)
Public Property Report As IReport
C#
public IReport Report {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : TargetDevice Property

Glossary Item Box

Specifies target device for this LayoutContext.

Syntax

Visual Basic (Declaration)
Public Property TargetDevice As ITargetDevice
C#
public ITargetDevice TargetDevice {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members


LayoutInfo Structure Fields

[image]
ActiveReports 19 .NET Edition
LayoutInfo Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

Glossary Item Box

For a list of all members of this type, see LayoutInfo members.

Public Fields

 | Name | Description
Public Field | TextMetricsProvider |
Top

See Also

Reference

LayoutInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


TextMetricsProvider Field

[image]
ActiveReports 19 .NET Edition
TextMetricsProvider Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : TextMetricsProvider Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TextMetricsProvider As ITextMetricsProvider
C#
public readonly ITextMetricsProvider TextMetricsProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutInfo Structure
LayoutInfo Members


LayoutResult Structure

[image]
ActiveReports 19 .NET Edition
LayoutResult Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

Glossary Item Box

Encapsulates the output of layout manager operations

Object Model

LayoutResult Structure

Syntax

Visual Basic (Declaration)
Public Structure LayoutResult
   Inherits System.ValueType
C#
public struct LayoutResult : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutResult Structure Members

[image]
ActiveReports 19 .NET Edition
LayoutResult Structure Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

Glossary Item Box

The following tables list the members exposed by LayoutResult.

Public Constructors

 | Name | Description
Public Constructor | LayoutResult Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ActualSize | Indicates the actual size that layout area, produced by layout manager, will occupy.
Public Property | Complete | Specifies that this layout was complete.
Public Property | ContentRange | Specifies the content that will need to be laid out.
Public Property | ContinueHorizontally | Specifies that layout operation indicated that next run should be in horizontal direction.
Public Property | ContinueVertically | Specifies that layout operation indicated that next run should be in vertical direction.
Public Property | ForcedVerticalBreak | Specifies that layout encountered a hard page break.
Public Property | HasContent | Specifies that layout operation generated some content.
Public Property | ImpliedVerticalBreak | Specifies that content flow should continue on next vertical page to keep content together.
Public Property | IsEmpty | Specifies that layout operation didn't produce any content at all and no other status was supplied.
Public Property | LayoutArea | Returns the ILayoutArea.
Public Property | LayoutStatus | Specifies the outcome of layout operation.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompleteResult | Indicates a complete layout operation.
static (Shared in Visual Basic) | EmptyResult | Overloaded. Indicates layout operation without any content laid out.
Public Method | SetLayoutStatus | Sets the layout status.
Public Method | SetRange | Returns a new result with the specified range.
Top

See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutResult Constructor

[image]
ActiveReports 19 .NET Edition
LayoutResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutResult Constructor

Glossary Item Box

Overload List

Overload | Description
LayoutResult Constructor(IContentRange,LayoutStatus,SizeF) | Initializes LayoutResult with specified values
LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeF) | Initializes LayoutResult with specified values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutResult Constructor(IContentRange,LayoutStatus,SizeF)

[image]
ActiveReports 19 .NET Edition
LayoutResult Constructor(IContentRange,LayoutStatus,SizeF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > LayoutResult Constructor : LayoutResult Constructor(IContentRange,LayoutStatus,SizeF)

contentRange
layoutStatus
actualSize

Glossary Item Box

Initializes LayoutResult with specified values

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal contentRange As IContentRange, _
   ByVal layoutStatus As LayoutStatus, _
   ByVal actualSize As SizeF _
)
C#
public LayoutResult(
   IContentRange contentRange,
   LayoutStatus layoutStatus,
   SizeF actualSize
)

Parameters

contentRange
layoutStatus
actualSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeF)

[image]
ActiveReports 19 .NET Edition
LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > LayoutResult Constructor : LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeF)

area
contentRange
layoutStatus
actualSize

Glossary Item Box

Initializes LayoutResult with specified values

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal area As ILayoutArea, _
   ByVal contentRange As IContentRange, _
   ByVal layoutStatus As LayoutStatus, _
   ByVal actualSize As SizeF _
)
C#
public LayoutResult(
   ILayoutArea area,
   IContentRange contentRange,
   LayoutStatus layoutStatus,
   SizeF actualSize
)

Parameters

area
contentRange
layoutStatus
actualSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


LayoutResult Structure Methods

[image]
ActiveReports 19 .NET Edition
LayoutResult Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

Glossary Item Box

For a list of all members of this type, see LayoutResult members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompleteResult | Indicates a complete layout operation.
static (Shared in Visual Basic) | EmptyResult | Overloaded. Indicates layout operation without any content laid out.
Public Method | SetLayoutStatus | Sets the layout status.
Public Method | SetRange | Returns a new result with the specified range.
Top

See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CompleteResult Method

[image]
ActiveReports 19 .NET Edition
CompleteResult Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : CompleteResult Method

Glossary Item Box

Indicates a complete layout operation.

Syntax

Visual Basic (Declaration)
Public Shared Function CompleteResult() As LayoutResult
C#
public static LayoutResult CompleteResult()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


EmptyResult Method

[image]
ActiveReports 19 .NET Edition
EmptyResult Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : EmptyResult Method

Glossary Item Box

Indicates layout operation without any content laid out.

Overload List

Overload | Description
EmptyResult() | Indicates layout operation without any content laid out.
EmptyResult(SizeF) | Indicates layout operation without any content laid out and specifies the minimum System.Drawing.SizeF required to accomodate the content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


EmptyResult() Method

[image]
ActiveReports 19 .NET Edition
EmptyResult() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > EmptyResult Method : EmptyResult() Method

Glossary Item Box

Indicates layout operation without any content laid out.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function EmptyResult() As LayoutResult
C#
public static LayoutResult EmptyResult()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


EmptyResult(SizeF) Method

[image]
ActiveReports 19 .NET Edition
EmptyResult(SizeF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > EmptyResult Method : EmptyResult(SizeF) Method

actualSize

Glossary Item Box

Indicates layout operation without any content laid out and specifies the minimum System.Drawing.SizeF required to accomodate the content.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function EmptyResult( _
   ByVal actualSize As SizeF _
) As LayoutResult
C#
public static LayoutResult EmptyResult(
   SizeF actualSize
)

Parameters

actualSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


SetLayoutStatus Method

[image]
ActiveReports 19 .NET Edition
SetLayoutStatus Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : SetLayoutStatus Method

value
The layoutstatus to set.

Glossary Item Box

Sets the layout status.

Syntax

Visual Basic (Declaration)
Public Sub SetLayoutStatus( _
   ByVal value As LayoutStatus _
)
C#
public void SetLayoutStatus(
   LayoutStatus value
)

Parameters

value
The layoutstatus to set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


SetRange Method

[image]
ActiveReports 19 .NET Edition
SetRange Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : SetRange Method

range

Glossary Item Box

Returns a new result with the specified range.

Syntax

Visual Basic (Declaration)
Public Function SetRange( _
   ByVal range As ContentRange _
) As LayoutResult
C#
public LayoutResult SetRange(
   ContentRange range
)

Parameters

range

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutResult Structure Properties

[image]
ActiveReports 19 .NET Edition
LayoutResult Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

Glossary Item Box

For a list of all members of this type, see LayoutResult members.

Public Properties

 | Name | Description
Public Property | ActualSize | Indicates the actual size that layout area, produced by layout manager, will occupy.
Public Property | Complete | Specifies that this layout was complete.
Public Property | ContentRange | Specifies the content that will need to be laid out.
Public Property | ContinueHorizontally | Specifies that layout operation indicated that next run should be in horizontal direction.
Public Property | ContinueVertically | Specifies that layout operation indicated that next run should be in vertical direction.
Public Property | ForcedVerticalBreak | Specifies that layout encountered a hard page break.
Public Property | HasContent | Specifies that layout operation generated some content.
Public Property | ImpliedVerticalBreak | Specifies that content flow should continue on next vertical page to keep content together.
Public Property | IsEmpty | Specifies that layout operation didn't produce any content at all and no other status was supplied.
Public Property | LayoutArea | Returns the ILayoutArea.
Public Property | LayoutStatus | Specifies the outcome of layout operation.
Top

See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ActualSize Property

[image]
ActiveReports 19 .NET Edition
ActualSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ActualSize Property

Glossary Item Box

Indicates the actual size that layout area, produced by layout manager, will occupy.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualSize As SizeF
C#
public SizeF ActualSize {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


Complete Property

[image]
ActiveReports 19 .NET Edition
Complete Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : Complete Property

Glossary Item Box

Specifies that this layout was complete.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Complete As Boolean
C#
public bool Complete {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


ContentRange Property

[image]
ActiveReports 19 .NET Edition
ContentRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContentRange Property

Glossary Item Box

Specifies the content that will need to be laid out.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentRange As IContentRange
C#
public IContentRange ContentRange {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


ContinueHorizontally Property

[image]
ActiveReports 19 .NET Edition
ContinueHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContinueHorizontally Property

Glossary Item Box

Specifies that layout operation indicated that next run should be in horizontal direction.

Syntax

Visual Basic (Declaration)
Public Property ContinueHorizontally As Boolean
C#
public bool ContinueHorizontally {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


ContinueVertically Property

[image]
ActiveReports 19 .NET Edition
ContinueVertically Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContinueVertically Property

Glossary Item Box

Specifies that layout operation indicated that next run should be in vertical direction.

Syntax

Visual Basic (Declaration)
Public Property ContinueVertically As Boolean
C#
public bool ContinueVertically {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


ForcedVerticalBreak Property

[image]
ActiveReports 19 .NET Edition
ForcedVerticalBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ForcedVerticalBreak Property

Glossary Item Box

Specifies that layout encountered a hard page break.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForcedVerticalBreak As Boolean
C#
public bool ForcedVerticalBreak {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


HasContent Property

[image]
ActiveReports 19 .NET Edition
HasContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : HasContent Property

Glossary Item Box

Specifies that layout operation generated some content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasContent As Boolean
C#
public bool HasContent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


ImpliedVerticalBreak Property

[image]
ActiveReports 19 .NET Edition
ImpliedVerticalBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ImpliedVerticalBreak Property

Glossary Item Box

Specifies that content flow should continue on next vertical page to keep content together.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImpliedVerticalBreak As Boolean
C#
public bool ImpliedVerticalBreak {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : IsEmpty Property

Glossary Item Box

Specifies that layout operation didn't produce any content at all and no other status was supplied.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutArea Property

[image]
ActiveReports 19 .NET Edition
LayoutArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutArea Property

Glossary Item Box

Returns the ILayoutArea.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutArea As ILayoutArea
C#
public ILayoutArea LayoutArea {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutStatus Property

[image]
ActiveReports 19 .NET Edition
LayoutStatus Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutStatus Property

Glossary Item Box

Specifies the outcome of layout operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutStatus As LayoutStatus
C#
public LayoutStatus LayoutStatus {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutState Structure

[image]
ActiveReports 19 .NET Edition
LayoutState Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

Glossary Item Box

Encapsulates intermediate result (current state) of layout operation.

Object Model

LayoutState Structure

Syntax

Visual Basic (Declaration)
Public Structure LayoutState
   Inherits System.ValueType
C#
public struct LayoutState : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutState Structure Members

[image]
ActiveReports 19 .NET Edition
LayoutState Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

Glossary Item Box

The following tables list the members exposed by LayoutState.

Public Constructors

 | Name | Description
Public Constructor | LayoutState Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | IsLastInDocument | Indicates the page is last in document.
Top

Public Properties

 | Name | Description
Public Property | LastPage | Specifies last page laid out by the engine for this LayoutTree.
Public Property | LayoutTree | Specifies LayoutTree being built by the layout engine.
Public Property | TargetDevice | Specifes target device for current layout operation.
Top

See Also

Reference

LayoutState Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutState Constructor

[image]
ActiveReports 19 .NET Edition
LayoutState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LayoutState Constructor

Glossary Item Box

Overload List

Overload | Description
LayoutState Constructor(ILayoutTree,ITargetDevice,Int32) | Creates a new instance of LayoutState and initializes it with specified value.
LayoutState Constructor(ILayoutTree,ITargetDevice,Int32,Boolean) | Creates a new instance of LayoutState and initializes it with specified value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members


LayoutState Constructor(ILayoutTree,ITargetDevice,Int32)

[image]
ActiveReports 19 .NET Edition
LayoutState Constructor(ILayoutTree,ITargetDevice,Int32)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure > LayoutState Constructor : LayoutState Constructor(ILayoutTree,ITargetDevice,Int32)

layoutTree
targetDevice
lastPageLaidOut

Glossary Item Box

Creates a new instance of LayoutState and initializes it with specified value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal layoutTree As ILayoutTree, _
   ByVal targetDevice As ITargetDevice, _
   ByVal lastPageLaidOut As Integer _
)
C#
public LayoutState(
   ILayoutTree layoutTree,
   ITargetDevice targetDevice,
   int lastPageLaidOut
)

Parameters

layoutTree
targetDevice
lastPageLaidOut

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members
Overload List


LayoutState Constructor(ILayoutTree,ITargetDevice,Int32,Boolean)

[image]
ActiveReports 19 .NET Edition
LayoutState Constructor(ILayoutTree,ITargetDevice,Int32,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure > LayoutState Constructor : LayoutState Constructor(ILayoutTree,ITargetDevice,Int32,Boolean)

layoutTree
targetDevice
lastPageLaidOut
isLastInDocument

Glossary Item Box

Creates a new instance of LayoutState and initializes it with specified value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal layoutTree As ILayoutTree, _
   ByVal targetDevice As ITargetDevice, _
   ByVal lastPageLaidOut As Integer, _
   ByVal isLastInDocument As Boolean _
)
C#
public LayoutState(
   ILayoutTree layoutTree,
   ITargetDevice targetDevice,
   int lastPageLaidOut,
   bool isLastInDocument
)

Parameters

layoutTree
targetDevice
lastPageLaidOut
isLastInDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members
Overload List


LayoutState Structure Properties

[image]
ActiveReports 19 .NET Edition
LayoutState Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

Glossary Item Box

For a list of all members of this type, see LayoutState members.

Public Properties

 | Name | Description
Public Property | LastPage | Specifies last page laid out by the engine for this LayoutTree.
Public Property | LayoutTree | Specifies LayoutTree being built by the layout engine.
Public Property | TargetDevice | Specifes target device for current layout operation.
Top

See Also

Reference

LayoutState Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LastPage Property

[image]
ActiveReports 19 .NET Edition
LastPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LastPage Property

Glossary Item Box

Specifies last page laid out by the engine for this LayoutTree.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastPage As Integer
C#
public int LastPage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members


LayoutTree Property

[image]
ActiveReports 19 .NET Edition
LayoutTree Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LayoutTree Property

Glossary Item Box

Specifies LayoutTree being built by the layout engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutTree As ILayoutTree
C#
public ILayoutTree LayoutTree {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : TargetDevice Property

Glossary Item Box

Specifes target device for current layout operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetDevice As ITargetDevice
C#
public ITargetDevice TargetDevice {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members


LayoutState Structure Fields

[image]
ActiveReports 19 .NET Edition
LayoutState Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

Glossary Item Box

For a list of all members of this type, see LayoutState members.

Public Fields

 | Name | Description
Public Field | IsLastInDocument | Indicates the page is last in document.
Top

See Also

Reference

LayoutState Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IsLastInDocument Field

[image]
ActiveReports 19 .NET Edition
IsLastInDocument Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : IsLastInDocument Field

Glossary Item Box

Indicates the page is last in document.

Syntax

Visual Basic (Declaration)
Public ReadOnly IsLastInDocument As Boolean
C#
public readonly bool IsLastInDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutState Structure
LayoutState Members


IBorders Interface

[image]
ActiveReports 19 .NET Edition
IBorders Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface

Glossary Item Box

Represents visual styles for all borders.

Syntax

Visual Basic (Declaration)
Public Interface IBorders
C#
public interface IBorders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IBorders Interface Members

[image]
ActiveReports 19 .NET Edition
IBorders Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface

Glossary Item Box

The following tables list the members exposed by IBorders.

Public Properties

 | Name | Description
Property | BottomBorderColor | Gets the color of the bottom border.
Property | BottomBorderStyle | Gets the style of the bottom border.
Property | BottomBorderWidth | Gets the width of the bottom border.
Property | LeftBorderColor | Gets the color of the left border.
Property | LeftBorderStyle | Gets the style of the left border.
Property | LeftBorderWidth | Gets the width of the left border.
Property | RightBorderColor | Gets the color of the right border.
Property | RightBorderStyle | Gets the style of the right border.
Property | RightBorderWidth | Gets the width of the right border.
Property | TopBorderColor | Gets the color of the top border.
Property | TopBorderStyle | Gets the style of the top border.
Property | TopBorderWidth | Gets the width of the top border.
Top

See Also

Reference

IBorders Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IBorders Interface Properties

[image]
ActiveReports 19 .NET Edition
IBorders Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface

Glossary Item Box

For a list of all members of this type, see IBorders members.

Public Properties

 | Name | Description
Property | BottomBorderColor | Gets the color of the bottom border.
Property | BottomBorderStyle | Gets the style of the bottom border.
Property | BottomBorderWidth | Gets the width of the bottom border.
Property | LeftBorderColor | Gets the color of the left border.
Property | LeftBorderStyle | Gets the style of the left border.
Property | LeftBorderWidth | Gets the width of the left border.
Property | RightBorderColor | Gets the color of the right border.
Property | RightBorderStyle | Gets the style of the right border.
Property | RightBorderWidth | Gets the width of the right border.
Property | TopBorderColor | Gets the color of the top border.
Property | TopBorderStyle | Gets the style of the top border.
Property | TopBorderWidth | Gets the width of the top border.
Top

See Also

Reference

IBorders Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BottomBorderColor Property

[image]
ActiveReports 19 .NET Edition
BottomBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderColor Property

Glossary Item Box

Gets the color of the bottom border.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderColor As String
C#
string BottomBorderColor {get;}

Property Value

The color of the bottom border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


BottomBorderStyle Property

[image]
ActiveReports 19 .NET Edition
BottomBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderStyle Property

Glossary Item Box

Gets the style of the bottom border.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderStyle As String
C#
string BottomBorderStyle {get;}

Property Value

The style of the bottom border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


BottomBorderWidth Property

[image]
ActiveReports 19 .NET Edition
BottomBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderWidth Property

Glossary Item Box

Gets the width of the bottom border.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderWidth As Length
C#
Length BottomBorderWidth {get;}

Property Value

The width of the bottom border as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


LeftBorderColor Property

[image]
ActiveReports 19 .NET Edition
LeftBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderColor Property

Glossary Item Box

Gets the color of the left border.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderColor As String
C#
string LeftBorderColor {get;}

Property Value

The color of the left border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


LeftBorderStyle Property

[image]
ActiveReports 19 .NET Edition
LeftBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderStyle Property

Glossary Item Box

Gets the style of the left border.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderStyle As String
C#
string LeftBorderStyle {get;}

Property Value

The style of the left border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


LeftBorderWidth Property

[image]
ActiveReports 19 .NET Edition
LeftBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderWidth Property

Glossary Item Box

Gets the width of the left border.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderWidth As Length
C#
Length LeftBorderWidth {get;}

Property Value

The width of the left border as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


RightBorderColor Property

[image]
ActiveReports 19 .NET Edition
RightBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderColor Property

Glossary Item Box

Gets the color of the right border.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderColor As String
C#
string RightBorderColor {get;}

Property Value

The color of the right border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


RightBorderStyle Property

[image]
ActiveReports 19 .NET Edition
RightBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderStyle Property

Glossary Item Box

Gets the style of the right border.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderStyle As String
C#
string RightBorderStyle {get;}

Property Value

The style of the right border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


RightBorderWidth Property

[image]
ActiveReports 19 .NET Edition
RightBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderWidth Property

Glossary Item Box

Gets the width of the right border.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderWidth As Length
C#
Length RightBorderWidth {get;}

Property Value

The width of the right border as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


TopBorderColor Property

[image]
ActiveReports 19 .NET Edition
TopBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderColor Property

Glossary Item Box

Gets the color of the top border.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderColor As String
C#
string TopBorderColor {get;}

Property Value

The color of the top border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


TopBorderStyle Property

[image]
ActiveReports 19 .NET Edition
TopBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderStyle Property

Glossary Item Box

Gets the style of the top border.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderStyle As String
C#
string TopBorderStyle {get;}

Property Value

The style of the top border as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


TopBorderWidth Property

[image]
ActiveReports 19 .NET Edition
TopBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderWidth Property

Glossary Item Box

Gets the width of the top border.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderWidth As Length
C#
Length TopBorderWidth {get;}

Property Value

The width of the top border as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorders Interface
IBorders Members


ICompositeLayoutRange Interface

[image]
ActiveReports 19 .NET Edition
ICompositeLayoutRange Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ICompositeLayoutRange Interface

Glossary Item Box

Content range implementation for the composite layout.

Syntax

Visual Basic (Declaration)
Public Interface ICompositeLayoutRange
   Inherits IContentRange
C#
public interface ICompositeLayoutRange : IContentRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ICompositeLayoutRange Interface Members

[image]
ActiveReports 19 .NET Edition
ICompositeLayoutRange Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ICompositeLayoutRange Interface

Glossary Item Box

The following tables list the members exposed by ICompositeLayoutRange.

Public Properties

 | Name | Description
Property | EndPosition | Specifies end (vertical) position in this range
Property | HorizontalOffset | Specifies horizontal viewport origin
Property | StartPosition | Specifies start (vertical) position in this range
Property | VerticalOffset | Specifies vertical viewport origin
Property | VerticalShift | Specifies occupied height by layout areas
Top

See Also

Reference

ICompositeLayoutRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ICompositeLayoutRange Interface Properties

[image]
ActiveReports 19 .NET Edition
ICompositeLayoutRange Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ICompositeLayoutRange Interface

Glossary Item Box

For a list of all members of this type, see ICompositeLayoutRange members.

Public Properties

 | Name | Description
Property | EndPosition | Specifies end (vertical) position in this range
Property | HorizontalOffset | Specifies horizontal viewport origin
Property | StartPosition | Specifies start (vertical) position in this range
Property | VerticalOffset | Specifies vertical viewport origin
Property | VerticalShift | Specifies occupied height by layout areas
Top

See Also

Reference

ICompositeLayoutRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EndPosition Property

[image]
ActiveReports 19 .NET Edition
EndPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ICompositeLayoutRange Interface : EndPosition Property

Glossary Item Box

Specifies end (vertical) position in this range

Syntax

Visual Basic (Declaration)
Property EndPosition As Integer
C#
int EndPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Interface
ICompositeLayoutRange Members


HorizontalOffset Property

[image]
ActiveReports 19 .NET Edition
HorizontalOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ICompositeLayoutRange Interface : HorizontalOffset Property

Glossary Item Box

Specifies horizontal viewport origin

Syntax

Visual Basic (Declaration)
Property HorizontalOffset As Single
C#
float HorizontalOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Interface
ICompositeLayoutRange Members


StartPosition Property

[image]
ActiveReports 19 .NET Edition
StartPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ICompositeLayoutRange Interface : StartPosition Property

Glossary Item Box

Specifies start (vertical) position in this range

Syntax

Visual Basic (Declaration)
Property StartPosition As Integer
C#
int StartPosition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Interface
ICompositeLayoutRange Members


VerticalOffset Property

[image]
ActiveReports 19 .NET Edition
VerticalOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ICompositeLayoutRange Interface : VerticalOffset Property

Glossary Item Box

Specifies vertical viewport origin

Syntax

Visual Basic (Declaration)
Property VerticalOffset As Single
C#
float VerticalOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Interface
ICompositeLayoutRange Members


VerticalShift Property

[image]
ActiveReports 19 .NET Edition
VerticalShift Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ICompositeLayoutRange Interface : VerticalShift Property

Glossary Item Box

Specifies occupied height by layout areas

Syntax

Visual Basic (Declaration)
Property VerticalShift As Single
C#
float VerticalShift {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICompositeLayoutRange Interface
ICompositeLayoutRange Members


IContentRange Interface

[image]
ActiveReports 19 .NET Edition
IContentRange Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface

Glossary Item Box

Represents a basic content range interface.

Syntax

Visual Basic (Declaration)
Public Interface IContentRange
C#
public interface IContentRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IContentRange Interface Members

[image]
ActiveReports 19 .NET Edition
IContentRange Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface

Glossary Item Box

The following tables list the members exposed by IContentRange.

Public Properties

 | Name | Description
Property | Owner | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top

See Also

Reference

IContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IContentRange Interface Properties

[image]
ActiveReports 19 .NET Edition
IContentRange Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface

Glossary Item Box

For a list of all members of this type, see IContentRange members.

Public Properties

 | Name | Description
Property | Owner | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top

See Also

Reference

IContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Owner Property

[image]
ActiveReports 19 .NET Edition
Owner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IContentRange Interface : Owner Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.

Syntax

Visual Basic (Declaration)
ReadOnly Property Owner As IReportItem
C#
IReportItem Owner {get;}

Property Value

The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem instance that this content range represents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContentRange Interface
IContentRange Members


IFixedPageLayoutRange Interface

[image]
ActiveReports 19 .NET Edition
IFixedPageLayoutRange Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IFixedPageLayoutRange Interface

Glossary Item Box

Content range implementation for the fixed page layout.

Syntax

Visual Basic (Declaration)
Public Interface IFixedPageLayoutRange
   Inherits IContentRange
C#
public interface IFixedPageLayoutRange : IContentRange

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPageLayoutRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IFixedPageLayoutRange Interface Members

[image]
ActiveReports 19 .NET Edition
IFixedPageLayoutRange Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IFixedPageLayoutRange Interface

Glossary Item Box

The following tables list the members exposed by IFixedPageLayoutRange.

Public Properties

 | Name | Description
Property | GroupIndex | Specifies FPL group index.
Top

See Also

Reference

IFixedPageLayoutRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IFixedPageLayoutRange Interface Properties

[image]
ActiveReports 19 .NET Edition
IFixedPageLayoutRange Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IFixedPageLayoutRange Interface

Glossary Item Box

For a list of all members of this type, see IFixedPageLayoutRange members.

Public Properties

 | Name | Description
Property | GroupIndex | Specifies FPL group index.
Top

See Also

Reference

IFixedPageLayoutRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GroupIndex Property

[image]
ActiveReports 19 .NET Edition
GroupIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IFixedPageLayoutRange Interface : GroupIndex Property

Glossary Item Box

Specifies FPL group index.

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupIndex As Integer
C#
int GroupIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPageLayoutRange Interface
IFixedPageLayoutRange Members


IGrid Interface

[image]
ActiveReports 19 .NET Edition
IGrid Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

Glossary Item Box

Represents a virtual grid composed of the IGridCell

Syntax

Visual Basic (Declaration)
Public Interface IGrid
C#
public interface IGrid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGrid Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGrid Interface Members

[image]
ActiveReports 19 .NET Edition
IGrid Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

Glossary Item Box

The following tables list the members exposed by IGrid.

Public Properties

 | Name | Description
Property | Columns | Gets the number of columns in the grid.
Property | Rows | Gets the number of rows in the grid.
Top

Public Methods

 | Name | Description
Method | GetCellAt | Obtains an IGridCell given the row and column numbers.
Top

See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGrid Interface Methods

[image]
ActiveReports 19 .NET Edition
IGrid Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

Glossary Item Box

For a list of all members of this type, see IGrid members.

Public Methods

 | Name | Description
Method | GetCellAt | Obtains an IGridCell given the row and column numbers.
Top

See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GetCellAt Method

[image]
ActiveReports 19 .NET Edition
GetCellAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : GetCellAt Method

row
The row number of the cell.
column
The column number of the cell.

Glossary Item Box

Obtains an IGridCell given the row and column numbers.

Syntax

Visual Basic (Declaration)
Function GetCellAt( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As IGridCell
C#
IGridCell GetCellAt(
   int row,
   int column
)

Parameters

row
The row number of the cell.
column
The column number of the cell.

Return Value

The IGridCell at the specified row and column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGrid Interface
IGrid Members


IGrid Interface Properties

[image]
ActiveReports 19 .NET Edition
IGrid Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

Glossary Item Box

For a list of all members of this type, see IGrid members.

Public Properties

 | Name | Description
Property | Columns | Gets the number of columns in the grid.
Property | Rows | Gets the number of rows in the grid.
Top

See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : Columns Property

Glossary Item Box

Gets the number of columns in the grid.

Syntax

Visual Basic (Declaration)
ReadOnly Property Columns As Integer
C#
int Columns {get;}

Property Value

The number of columns in the grid as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGrid Interface
IGrid Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : Rows Property

Glossary Item Box

Gets the number of rows in the grid.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rows As Integer
C#
int Rows {get;}

Property Value

The number of rows in the grid as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGrid Interface
IGrid Members


IGridCell Interface

[image]
ActiveReports 19 .NET Edition
IGridCell Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface

Glossary Item Box

Represents a single cell in the virtual grid.

Syntax

Visual Basic (Declaration)
Public Interface IGridCell
C#
public interface IGridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridCell Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridCell Interface Members

[image]
ActiveReports 19 .NET Edition
IGridCell Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface

Glossary Item Box

The following tables list the members exposed by IGridCell.

Public Properties

 | Name | Description
Property | ColumnSpan | Gets the column span for this cell.
Property | Content | Gets the actual content to be rendered in this cell.
Property | EffectiveBorders | Gets the effective border styles for this cell.
Property | RowSpan | Gets the row span for this cell.
Top

See Also

Reference

IGridCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridCell Interface Properties

[image]
ActiveReports 19 .NET Edition
IGridCell Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface

Glossary Item Box

For a list of all members of this type, see IGridCell members.

Public Properties

 | Name | Description
Property | ColumnSpan | Gets the column span for this cell.
Property | Content | Gets the actual content to be rendered in this cell.
Property | EffectiveBorders | Gets the effective border styles for this cell.
Property | RowSpan | Gets the row span for this cell.
Top

See Also

Reference

IGridCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ColumnSpan Property

[image]
ActiveReports 19 .NET Edition
ColumnSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : ColumnSpan Property

Glossary Item Box

Gets the column span for this cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnSpan As Integer
C#
int ColumnSpan {get;}

Property Value

The number of columns this cell spans as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridCell Interface
IGridCell Members


Content Property

[image]
ActiveReports 19 .NET Edition
Content Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : Content Property

Glossary Item Box

Gets the actual content to be rendered in this cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property Content As ILayoutArea
C#
ILayoutArea Content {get;}

Property Value

An ILayoutArea instance representing the content of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridCell Interface
IGridCell Members


EffectiveBorders Property

[image]
ActiveReports 19 .NET Edition
EffectiveBorders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : EffectiveBorders Property

Glossary Item Box

Gets the effective border styles for this cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property EffectiveBorders As IBorders
C#
IBorders EffectiveBorders {get;}

Property Value

An IBorders instance representing the effective borders of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridCell Interface
IGridCell Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : RowSpan Property

Glossary Item Box

Gets the row span for this cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowSpan As Integer
C#
int RowSpan {get;}

Property Value

The number of rows this cell spans as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridCell Interface
IGridCell Members


IGridColumns Interface

[image]
ActiveReports 19 .NET Edition
IGridColumns Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridColumns Interface

Glossary Item Box

Represents the collection of columns in a grid.

Syntax

Visual Basic (Declaration)
Public Interface IGridColumns
C#
public interface IGridColumns

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridColumns Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridColumns Interface Members

[image]
ActiveReports 19 .NET Edition
IGridColumns Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridColumns Interface

Glossary Item Box

The following tables list the members exposed by IGridColumns.

Public Properties

 | Name | Description
Property | ColumnWidths | Gets the widths of all columns in the current grid.
Top

See Also

Reference

IGridColumns Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridColumns Interface Properties

[image]
ActiveReports 19 .NET Edition
IGridColumns Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridColumns Interface

Glossary Item Box

For a list of all members of this type, see IGridColumns members.

Public Properties

 | Name | Description
Property | ColumnWidths | Gets the widths of all columns in the current grid.
Top

See Also

Reference

IGridColumns Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ColumnWidths Property

[image]
ActiveReports 19 .NET Edition
ColumnWidths Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridColumns Interface : ColumnWidths Property

Glossary Item Box

Gets the widths of all columns in the current grid.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnWidths As IReadOnlyList(Of Integer)
C#
IReadOnlyList<int> ColumnWidths {get;}

Property Value

A read-only list of integers representing the widths of the columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGridColumns Interface
IGridColumns Members


ILayoutArea Interface

[image]
ActiveReports 19 .NET Edition
ILayoutArea Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

Glossary Item Box

Represents an area that contains a layout.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutArea
C#
public interface ILayoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutArea Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutArea Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

Glossary Item Box

The following tables list the members exposed by ILayoutArea.

Public Properties

 | Name | Description
Property | Children | Gets the ILayoutArea objects that are children of this object (if any).
Property | ContentRange | Specifies the range of content in this area.
Property | Height | Gets the area's height.
Property | InteractivityAreas | Gets the interactivity areas.
Property | IsFirstHorizontally | Gets a value indicating whether this is the first area horizontally.
Property | IsFirstVertically | Gets a value indicating whether this is the first area vertically.
Property | IsLastHorizontally | Gets a value indicating whether this is the last area horizontally.
Property | IsLastVertically | Gets a value indicating whether this is the last area vertically.
Property | Left | Gets the area's left position.
Property | Name | Gets the name of the area component item (for debugging purposes).
Property | Page | Gets the ILayoutPage page that hosts this LayoutArea.
Property | Parent | Gets the parent ILayoutArea, if any.
Property | ReportItem | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem.
Property | Top | Gets the area's top position.
Property | Width | Gets the area's width.
Top

See Also

Reference

ILayoutArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutArea Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutArea Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

Glossary Item Box

For a list of all members of this type, see ILayoutArea members.

Public Properties

 | Name | Description
Property | Children | Gets the ILayoutArea objects that are children of this object (if any).
Property | ContentRange | Specifies the range of content in this area.
Property | Height | Gets the area's height.
Property | InteractivityAreas | Gets the interactivity areas.
Property | IsFirstHorizontally | Gets a value indicating whether this is the first area horizontally.
Property | IsFirstVertically | Gets a value indicating whether this is the first area vertically.
Property | IsLastHorizontally | Gets a value indicating whether this is the last area horizontally.
Property | IsLastVertically | Gets a value indicating whether this is the last area vertically.
Property | Left | Gets the area's left position.
Property | Name | Gets the name of the area component item (for debugging purposes).
Property | Page | Gets the ILayoutPage page that hosts this LayoutArea.
Property | Parent | Gets the parent ILayoutArea, if any.
Property | ReportItem | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem.
Property | Top | Gets the area's top position.
Property | Width | Gets the area's width.
Top

See Also

Reference

ILayoutArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Children Property

Glossary Item Box

Gets the ILayoutArea objects that are children of this object (if any).

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IReadOnlyList(Of ILayoutArea)
C#
IReadOnlyList<ILayoutArea> Children {get;}

Property Value

A read-only list of child layout areas as an IReadOnlyList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ContentRange Property

[image]
ActiveReports 19 .NET Edition
ContentRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : ContentRange Property

Glossary Item Box

Specifies the range of content in this area.

Syntax

Visual Basic (Declaration)
ReadOnly Property ContentRange As IContentRange
C#
IContentRange ContentRange {get;}

Property Value

The content range of the area as an IContentRange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Height Property

Glossary Item Box

Gets the area's height.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Single
C#
float Height {get;}

Property Value

The height of the area as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


InteractivityAreas Property

[image]
ActiveReports 19 .NET Edition
InteractivityAreas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : InteractivityAreas Property

Glossary Item Box

Gets the interactivity areas.

Syntax

Visual Basic (Declaration)
ReadOnly Property InteractivityAreas As IList(Of InteractiveArea)
C#
IList<InteractiveArea> InteractivityAreas {get;}

Property Value

A list of interactivity areas as an IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsFirstHorizontally Property

[image]
ActiveReports 19 .NET Edition
IsFirstHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsFirstHorizontally Property

Glossary Item Box

Gets a value indicating whether this is the first area horizontally.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFirstHorizontally As Boolean
C#
bool IsFirstHorizontally {get;}

Property Value

true if this is the first area horizontally; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsFirstVertically Property

[image]
ActiveReports 19 .NET Edition
IsFirstVertically Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsFirstVertically Property

Glossary Item Box

Gets a value indicating whether this is the first area vertically.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFirstVertically As Boolean
C#
bool IsFirstVertically {get;}

Property Value

true if this is the first area vertically; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsLastHorizontally Property

[image]
ActiveReports 19 .NET Edition
IsLastHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsLastHorizontally Property

Glossary Item Box

Gets a value indicating whether this is the last area horizontally.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLastHorizontally As Boolean
C#
bool IsLastHorizontally {get;}

Property Value

true if this is the last area horizontally; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsLastVertically Property

[image]
ActiveReports 19 .NET Edition
IsLastVertically Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsLastVertically Property

Glossary Item Box

Gets a value indicating whether this is the last area vertically.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLastVertically As Boolean
C#
bool IsLastVertically {get;}

Property Value

true if this is the last area vertically; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Left Property

Glossary Item Box

Gets the area's left position.

Syntax

Visual Basic (Declaration)
ReadOnly Property Left As Single
C#
float Left {get;}

Property Value

The distance from the left edge of the container to the left edge of the area as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Name Property

Glossary Item Box

Gets the name of the area component item (for debugging purposes).

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

The name of the area component item as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Page Property

Glossary Item Box

Gets the ILayoutPage page that hosts this LayoutArea.

Syntax

Visual Basic (Declaration)
ReadOnly Property Page As ILayoutPage
C#
ILayoutPage Page {get;}

Property Value

The page that hosts this layout area as an ILayoutPage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Parent Property

Glossary Item Box

Gets the parent ILayoutArea, if any.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As ILayoutArea
C#
ILayoutArea Parent {get;}

Property Value

The parent layout area as an ILayoutArea.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : ReportItem Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Property Value

The report item as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Top Property

Glossary Item Box

Gets the area's top position.

Syntax

Visual Basic (Declaration)
ReadOnly Property Top As Single
C#
float Top {get;}

Property Value

The distance from the top edge of the container to the top edge of the area as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Width Property

Glossary Item Box

Gets the area's width.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Single
C#
float Width {get;}

Property Value

The width of the area as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ILayoutAreaCollapsible Interface

[image]
ActiveReports 19 .NET Edition
ILayoutAreaCollapsible Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

Glossary Item Box

ц Represents an area that contains a layout and provide collapsing support for hidden items inside layout area

Syntax

Visual Basic (Declaration)
Public Interface ILayoutAreaCollapsible
   Inherits ILayoutArea
C#
public interface ILayoutAreaCollapsible : ILayoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutAreaCollapsible Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutAreaCollapsible Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutAreaCollapsible Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

Glossary Item Box

The following tables list the members exposed by ILayoutAreaCollapsible.

Public Properties

 | Name | Description
Property | Visible | Gets a value indicating whether the layout area is visible.
Top

See Also

Reference

ILayoutAreaCollapsible Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutAreaCollapsible Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutAreaCollapsible Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

Glossary Item Box

For a list of all members of this type, see ILayoutAreaCollapsible members.

Public Properties

 | Name | Description
Property | Visible | Gets a value indicating whether the layout area is visible.
Top

See Also

Reference

ILayoutAreaCollapsible Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutAreaCollapsible Interface : Visible Property

Glossary Item Box

Gets a value indicating whether the layout area is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Property Value

true if the layout area is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutAreaCollapsible Interface
ILayoutAreaCollapsible Members


ILayoutEngine Interface

[image]
ActiveReports 19 .NET Edition
ILayoutEngine Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface

Glossary Item Box

Represents the layout engine public interface.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutEngine
C#
public interface ILayoutEngine

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutEngine Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngine Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutEngine Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface

Glossary Item Box

The following tables list the members exposed by ILayoutEngine.

Public Methods

 | Name | Description
Method | BuildLayout | Builds ILayoutTree for the specified LayoutInfo
Method | BuildReportLayout | Builds IReportLayout for the specified LayoutInfo
Top

See Also

Reference

ILayoutEngine Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngine Interface Methods

[image]
ActiveReports 19 .NET Edition
ILayoutEngine Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface

Glossary Item Box

For a list of all members of this type, see ILayoutEngine members.

Public Methods

 | Name | Description
Method | BuildLayout | Builds ILayoutTree for the specified LayoutInfo
Method | BuildReportLayout | Builds IReportLayout for the specified LayoutInfo
Top

See Also

Reference

ILayoutEngine Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BuildLayout Method

[image]
ActiveReports 19 .NET Edition
BuildLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface : BuildLayout Method

layoutInfo
The LayoutInfo which provides the report to lay out.

Glossary Item Box

Builds ILayoutTree for the specified LayoutInfo

Syntax

Visual Basic (Declaration)
Function BuildLayout( _
   ByVal layoutInfo As LayoutInfo _
) As ILayoutTree
C#
ILayoutTree BuildLayout(
   LayoutInfo layoutInfo
)

Parameters

layoutInfo
The LayoutInfo which provides the report to lay out.

Return Value

LayoutTree instance representing the report layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members


BuildReportLayout Method

[image]
ActiveReports 19 .NET Edition
BuildReportLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface : BuildReportLayout Method

layoutInfo
The LayoutInfo which provides the report to lay out.

Glossary Item Box

Builds IReportLayout for the specified LayoutInfo

Syntax

Visual Basic (Declaration)
Function BuildReportLayout( _
   ByVal layoutInfo As LayoutInfo _
) As IReportLayout
C#
IReportLayout BuildReportLayout(
   LayoutInfo layoutInfo
)

Parameters

layoutInfo
The LayoutInfo which provides the report to lay out.

Return Value

ReportLayout instance representing the report layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members


ILayoutEngineFactory Interface

[image]
ActiveReports 19 .NET Edition
ILayoutEngineFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface

Glossary Item Box

Summary description for ILayoutEngineFactory.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutEngineFactory
C#
public interface ILayoutEngineFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutEngineFactory Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngineFactory Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutEngineFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface

Glossary Item Box

The following tables list the members exposed by ILayoutEngineFactory.

Public Methods

 | Name | Description
Method | GetLayoutEngine | Retrieves the LayoutEngine.
Top

See Also

Reference

ILayoutEngineFactory Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngineFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
ILayoutEngineFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface

Glossary Item Box

For a list of all members of this type, see ILayoutEngineFactory members.

Public Methods

 | Name | Description
Method | GetLayoutEngine | Retrieves the LayoutEngine.
Top

See Also

Reference

ILayoutEngineFactory Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GetLayoutEngine Method

[image]
ActiveReports 19 .NET Edition
GetLayoutEngine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngineFactory Interface : GetLayoutEngine Method

Glossary Item Box

Retrieves the LayoutEngine.

Syntax

Visual Basic (Declaration)
Function GetLayoutEngine() As ILayoutEngine
C#
ILayoutEngine GetLayoutEngine()

Return Value

The LayoutEngine.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutEngineFactory Interface
ILayoutEngineFactory Members


ILayoutManager Interface

[image]
ActiveReports 19 .NET Edition
ILayoutManager Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

Glossary Item Box

Represents a layout manager interface for providing custom layout logic or supporting advanced layout features such as pagination.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutManager
C#
public interface ILayoutManager

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutManager Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutManager Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutManager Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

Glossary Item Box

The following tables list the members exposed by ILayoutManager.

Public Properties

 | Name | Description
Property | Capabilities | Specifies layout capabilities of the item being laid out.
Top

Public Methods

 | Name | Description
Method | Initialize | Allows initialization of the layout manager with specifies ITargetDevice.
Method | Layout | Lays out the content that the specified ContentRange represents.
Method | Measure | A query by the layout system of what the results of a call to Layout would be with the specified settings.
Top

See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutManager Interface Methods

[image]
ActiveReports 19 .NET Edition
ILayoutManager Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

Glossary Item Box

For a list of all members of this type, see ILayoutManager members.

Public Methods

 | Name | Description
Method | Initialize | Allows initialization of the layout manager with specifies ITargetDevice.
Method | Layout | Lays out the content that the specified ContentRange represents.
Method | Measure | A query by the layout system of what the results of a call to Layout would be with the specified settings.
Top

See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Initialize Method

[image]
ActiveReports 19 .NET Edition
Initialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Initialize Method

forReportItem
GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem that will be laid out
targetDevice
ITargetDevice for which layout operation should be performed

Glossary Item Box

Allows initialization of the layout manager with specifies ITargetDevice.

Syntax

Visual Basic (Declaration)
Sub Initialize( _
   ByVal forReportItem As IReportItem, _
   ByVal targetDevice As ITargetDevice _
)
C#
void Initialize(
   IReportItem forReportItem,
   ITargetDevice targetDevice
)

Parameters

forReportItem
GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem that will be laid out
targetDevice
ITargetDevice for which layout operation should be performed

Remarks

Layout subsystem will call this method before fist call to Measure/Layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutManager Interface
ILayoutManager Members


Layout Method

[image]
ActiveReports 19 .NET Edition
Layout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Layout Method

context
LayoutContext specifying information about layout operations

Glossary Item Box

Lays out the content that the specified ContentRange represents.

Syntax

Visual Basic (Declaration)
Function Layout( _
   ByVal context As LayoutContext _
) As LayoutResult
C#
LayoutResult Layout(
   LayoutContext context
)

Parameters

context
LayoutContext specifying information about layout operations

Return Value

LayoutResult indicating outcome of this operation

Remarks

This method should return the exact size of the content laid out encapsulated into LayoutResult.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutManager Interface
ILayoutManager Members


Measure Method

[image]
ActiveReports 19 .NET Edition
Measure Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Measure Method

context
LayoutContext specifying information about layout operations

Glossary Item Box

A query by the layout system of what the results of a call to Layout would be with the specified settings.

Syntax

Visual Basic (Declaration)
Function Measure( _
   ByVal context As LayoutContext _
) As LayoutResult
C#
LayoutResult Measure(
   LayoutContext context
)

Parameters

context
LayoutContext specifying information about layout operations

Return Value

LayoutResult indicating outcome of this operation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutManager Interface
ILayoutManager Members


ILayoutManager Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutManager Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

Glossary Item Box

For a list of all members of this type, see ILayoutManager members.

Public Properties

 | Name | Description
Property | Capabilities | Specifies layout capabilities of the item being laid out.
Top

See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Capabilities Property

[image]
ActiveReports 19 .NET Edition
Capabilities Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Capabilities Property

Glossary Item Box

Specifies layout capabilities of the item being laid out.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capabilities As LayoutCapabilities
C#
LayoutCapabilities Capabilities {get;}

Remarks

The layout system can use this information as a hint to avoid an unnecessary Measure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutManager Interface
ILayoutManager Members


ILayoutPage Interface

[image]
ActiveReports 19 .NET Edition
ILayoutPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

Glossary Item Box

Represents an interface for a layout page.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutPage
C#
public interface ILayoutPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutPage Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutPage Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

Glossary Item Box

The following tables list the members exposed by ILayoutPage.

Public Properties

 | Name | Description
Property | BodyArea | Gets the body area of the page where content should be laid out.
Property | Footer | Gets the footer section of the page.
Property | GroupIndex | Gets the index of the group.
Property | Header | Gets the header section of the page.
Property | Height | Gets the height of the page.
Property | IsLastInDocument | Gets a value indicating whether the page is the last in the document.
Property | PageNumber | Gets the page number.
Property | Width | Gets the width of the page.
Top

See Also

Reference

ILayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutPage Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

Glossary Item Box

For a list of all members of this type, see ILayoutPage members.

Public Properties

 | Name | Description
Property | BodyArea | Gets the body area of the page where content should be laid out.
Property | Footer | Gets the footer section of the page.
Property | GroupIndex | Gets the index of the group.
Property | Header | Gets the header section of the page.
Property | Height | Gets the height of the page.
Property | IsLastInDocument | Gets a value indicating whether the page is the last in the document.
Property | PageNumber | Gets the page number.
Property | Width | Gets the width of the page.
Top

See Also

Reference

ILayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BodyArea Property

[image]
ActiveReports 19 .NET Edition
BodyArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : BodyArea Property

Glossary Item Box

Gets the body area of the page where content should be laid out.

Syntax

Visual Basic (Declaration)
ReadOnly Property BodyArea As ILayoutArea
C#
ILayoutArea BodyArea {get;}

Property Value

The body area of the page as an ILayoutArea.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Footer Property

Glossary Item Box

Gets the footer section of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Footer As ILayoutArea
C#
ILayoutArea Footer {get;}

Property Value

The footer area of the page as an ILayoutArea.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


GroupIndex Property

[image]
ActiveReports 19 .NET Edition
GroupIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : GroupIndex Property

Glossary Item Box

Gets the index of the group.

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupIndex As Integer
C#
int GroupIndex {get;}

Property Value

The index of the group as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Header Property

Glossary Item Box

Gets the header section of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Header As ILayoutArea
C#
ILayoutArea Header {get;}

Property Value

The header area of the page as an ILayoutArea.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Height Property

Glossary Item Box

Gets the height of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Single
C#
float Height {get;}

Property Value

The height of the page as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


IsLastInDocument Property

[image]
ActiveReports 19 .NET Edition
IsLastInDocument Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : IsLastInDocument Property

Glossary Item Box

Gets a value indicating whether the page is the last in the document.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLastInDocument As Boolean
C#
bool IsLastInDocument {get;}

Property Value

true if this is the last page in the document; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : PageNumber Property

Glossary Item Box

Gets the page number.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageNumber As Integer
C#
int PageNumber {get;}

Property Value

The number of this page as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Width Property

Glossary Item Box

Gets the width of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Single
C#
float Width {get;}

Property Value

The width of the page as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutPage Interface
ILayoutPage Members


ILayoutSection Interface

[image]
ActiveReports 19 .NET Edition
ILayoutSection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

Glossary Item Box

Represents an interface for layout sections.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutSection
   Inherits ILayoutArea
C#
public interface ILayoutSection : ILayoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutSection Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutSection Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutSection Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

Glossary Item Box

The following tables list the members exposed by ILayoutSection.

Public Properties

 | Name | Description
Property | Report | Gets the report associated with this page section.
Property | SectionType | Gets the section type to which this instance corresponds.
Top

See Also

Reference

ILayoutSection Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutSection Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutSection Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

Glossary Item Box

For a list of all members of this type, see ILayoutSection members.

Public Properties

 | Name | Description
Property | Report | Gets the report associated with this page section.
Property | SectionType | Gets the section type to which this instance corresponds.
Top

See Also

Reference

ILayoutSection Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutSection Interface : Report Property

Glossary Item Box

Gets the report associated with this page section.

Syntax

Visual Basic (Declaration)
ReadOnly Property Report As IReport
C#
IReport Report {get;}

Property Value

The report associated with this page section as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutSection Interface
ILayoutSection Members


SectionType Property

[image]
ActiveReports 19 .NET Edition
SectionType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutSection Interface : SectionType Property

Glossary Item Box

Gets the section type to which this instance corresponds.

Syntax

Visual Basic (Declaration)
ReadOnly Property SectionType As LayoutPageSectionType
C#
LayoutPageSectionType SectionType {get;}

Property Value

The type of the section as a GrapeCity.ActiveReports.Extensibility.Layout.Areas.LayoutPageSectionType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutSection Interface
ILayoutSection Members


ILayoutTree Interface

[image]
ActiveReports 19 .NET Edition
ILayoutTree Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

Glossary Item Box

Represents the interface for the layout tree.

Syntax

Visual Basic (Declaration)
Public Interface ILayoutTree
C#
public interface ILayoutTree

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutTree Interface Members

[image]
ActiveReports 19 .NET Edition
ILayoutTree Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

Glossary Item Box

The following tables list the members exposed by ILayoutTree.

Public Properties

 | Name | Description
Property | EvaluationMessage | Gets the evaluation message.
Property | Item | Gets the layout page at the specified index.
Property | MasterReport | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport instance associated with this layout.
Property | MetadataDictionary | Gets the metadata dictionary associated with this layout tree.
Property | PageCount | Gets the total number of laid out pages.
Property | Pages | Gets an enumerable collection of layout pages.
Top

See Also

Reference

ILayoutTree Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutTree Interface Properties

[image]
ActiveReports 19 .NET Edition
ILayoutTree Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

Glossary Item Box

For a list of all members of this type, see ILayoutTree members.

Public Properties

 | Name | Description
Property | EvaluationMessage | Gets the evaluation message.
Property | Item | Gets the layout page at the specified index.
Property | MasterReport | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport instance associated with this layout.
Property | MetadataDictionary | Gets the metadata dictionary associated with this layout tree.
Property | PageCount | Gets the total number of laid out pages.
Property | Pages | Gets an enumerable collection of layout pages.
Top

See Also

Reference

ILayoutTree Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EvaluationMessage Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : EvaluationMessage Property

Glossary Item Box

Gets the evaluation message.

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationMessage As String
C#
string EvaluationMessage {get;}

Property Value

The evaluation message as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : Item Property

index
The index of the page.

Glossary Item Box

Gets the layout page at the specified index.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ILayoutPage
C#
ILayoutPage this[
   int index
]; {get;}

Parameters

index
The index of the page.

Property Value

The layout page at the specified index as an ILayoutPage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


MasterReport Property

[image]
ActiveReports 19 .NET Edition
MasterReport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : MasterReport Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport instance associated with this layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property MasterReport As IReport
C#
IReport MasterReport {get;}

Property Value

The master report associated with this layout as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


MetadataDictionary Property

[image]
ActiveReports 19 .NET Edition
MetadataDictionary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : MetadataDictionary Property

Glossary Item Box

Gets the metadata dictionary associated with this layout tree.

Syntax

Visual Basic (Declaration)
ReadOnly Property MetadataDictionary As IMetadataDictionary
C#
IMetadataDictionary MetadataDictionary {get;}

Property Value

The metadata dictionary for the layout tree as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


PageCount Property

[image]
ActiveReports 19 .NET Edition
PageCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : PageCount Property

Glossary Item Box

Gets the total number of laid out pages.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageCount As Integer
C#
int PageCount {get;}

Property Value

The total number of pages as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : Pages Property

Glossary Item Box

Gets an enumerable collection of layout pages.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pages As IEnumerable(Of ILayoutPage)
C#
IEnumerable<ILayoutPage> Pages {get;}

Property Value

An enumerable collection of layout pages as an IEnumerable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILayoutTree Interface
ILayoutTree Members


IReportLayout Interface

[image]
ActiveReports 19 .NET Edition
IReportLayout Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayout Interface

Glossary Item Box

Represents the interface for the report layout.

Syntax

Visual Basic (Declaration)
Public Interface IReportLayout
C#
public interface IReportLayout

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayout Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportLayout Interface Members

[image]
ActiveReports 19 .NET Edition
IReportLayout Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayout Interface

Glossary Item Box

The following tables list the members exposed by IReportLayout.

Public Properties

 | Name | Description
Property | EvaluationMessage | Gets the evaluation message.
Property | MetadataDictionary | Gets the master metadata dictionary associated with this layout tree.
Property | Pages | Gets the pages enumerator.
Top

Public Methods

 | Name | Description
Method | PagesLimited | Returns an enumerable pages collection limited by the specified argument.
Top

See Also

Reference

IReportLayout Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportLayout Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportLayout Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayout Interface

Glossary Item Box

For a list of all members of this type, see IReportLayout members.

Public Methods

 | Name | Description
Method | PagesLimited | Returns an enumerable pages collection limited by the specified argument.
Top

See Also

Reference

IReportLayout Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


PagesLimited Method

[image]
ActiveReports 19 .NET Edition
PagesLimited Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayout Interface : PagesLimited Method

limit
The number of pages to preview. 0 corresponds to no limit.

Glossary Item Box

Returns an enumerable pages collection limited by the specified argument.

Syntax

Visual Basic (Declaration)
Function PagesLimited( _
   ByVal limit As Integer _
) As IEnumerable(Of ILayoutPage)
C#
IEnumerable<ILayoutPage> PagesLimited(
   int limit
)

Parameters

limit
The number of pages to preview. 0 corresponds to no limit.

Return Value

The collection of limited layout pages as an IEnumerable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayout Interface
IReportLayout Members


IReportLayout Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportLayout Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayout Interface

Glossary Item Box

For a list of all members of this type, see IReportLayout members.

Public Properties

 | Name | Description
Property | EvaluationMessage | Gets the evaluation message.
Property | MetadataDictionary | Gets the master metadata dictionary associated with this layout tree.
Property | Pages | Gets the pages enumerator.
Top

See Also

Reference

IReportLayout Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EvaluationMessage Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayout Interface : EvaluationMessage Property

Glossary Item Box

Gets the evaluation message.

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationMessage As String
C#
string EvaluationMessage {get;}

Property Value

The evaluation message as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayout Interface
IReportLayout Members


MetadataDictionary Property

[image]
ActiveReports 19 .NET Edition
MetadataDictionary Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayout Interface : MetadataDictionary Property

Glossary Item Box

Gets the master metadata dictionary associated with this layout tree.

Syntax

Visual Basic (Declaration)
ReadOnly Property MetadataDictionary As IMetadataDictionary
C#
IMetadataDictionary MetadataDictionary {get;}

Property Value

The metadata dictionary as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayout Interface
IReportLayout Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayout Interface : Pages Property

Glossary Item Box

Gets the pages enumerator.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pages As IEnumerable(Of ILayoutPage)
C#
IEnumerable<ILayoutPage> Pages {get;}

Property Value

The collection of layout pages as an IEnumerable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayout Interface
IReportLayout Members


IReportLayoutExt Interface

[image]
ActiveReports 19 .NET Edition
IReportLayoutExt Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayoutExt Interface

Glossary Item Box

Represents an extended interface for the report layout with additional properties for evaluation message styling.

Syntax

Visual Basic (Declaration)
Public Interface IReportLayoutExt
   Inherits IReportLayout
C#
public interface IReportLayoutExt : IReportLayout

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayoutExt Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportLayoutExt Interface Members

[image]
ActiveReports 19 .NET Edition
IReportLayoutExt Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayoutExt Interface

Glossary Item Box

The following tables list the members exposed by IReportLayoutExt.

Public Properties

 | Name | Description
Property | EvaluationMessageColor | Gets the color of the evaluation message.
Property | EvaluationMessageFont | Gets the font information for the evaluation message.
Top

See Also

Reference

IReportLayoutExt Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportLayoutExt Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportLayoutExt Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportLayoutExt Interface

Glossary Item Box

For a list of all members of this type, see IReportLayoutExt members.

Public Properties

 | Name | Description
Property | EvaluationMessageColor | Gets the color of the evaluation message.
Property | EvaluationMessageFont | Gets the font information for the evaluation message.
Top

See Also

Reference

IReportLayoutExt Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EvaluationMessageColor Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessageColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayoutExt Interface : EvaluationMessageColor Property

Glossary Item Box

Gets the color of the evaluation message.

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationMessageColor As Color
C#
Color EvaluationMessageColor {get;}

Property Value

The color of the evaluation message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayoutExt Interface
IReportLayoutExt Members


EvaluationMessageFont Property

[image]
ActiveReports 19 .NET Edition
EvaluationMessageFont Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportLayoutExt Interface : EvaluationMessageFont Property

Glossary Item Box

Gets the font information for the evaluation message.

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationMessageFont As FontInfo
C#
FontInfo EvaluationMessageFont {get;}

Property Value

The font information for the evaluation message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportLayoutExt Interface
IReportLayoutExt Members


IReportSectionLayoutPage Interface

[image]
ActiveReports 19 .NET Edition
IReportSectionLayoutPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportSectionLayoutPage Interface

Glossary Item Box

Represents the report section info.

Syntax

Visual Basic (Declaration)
Public Interface IReportSectionLayoutPage
C#
public interface IReportSectionLayoutPage

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportSectionLayoutPage Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportSectionLayoutPage Interface Members

[image]
ActiveReports 19 .NET Edition
IReportSectionLayoutPage Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportSectionLayoutPage Interface

Glossary Item Box

The following tables list the members exposed by IReportSectionLayoutPage.

Public Properties

 | Name | Description
Property | IsFirstInSection | Indicates whether this layout page is the first page of a Report Section.
Property | SectionLabel | Report Section Label
Top

See Also

Reference

IReportSectionLayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IReportSectionLayoutPage Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportSectionLayoutPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IReportSectionLayoutPage Interface

Glossary Item Box

For a list of all members of this type, see IReportSectionLayoutPage members.

Public Properties

 | Name | Description
Property | IsFirstInSection | Indicates whether this layout page is the first page of a Report Section.
Property | SectionLabel | Report Section Label
Top

See Also

Reference

IReportSectionLayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IsFirstInSection Property

[image]
ActiveReports 19 .NET Edition
IsFirstInSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportSectionLayoutPage Interface : IsFirstInSection Property

Glossary Item Box

Indicates whether this layout page is the first page of a Report Section.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFirstInSection As Boolean
C#
bool IsFirstInSection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportSectionLayoutPage Interface
IReportSectionLayoutPage Members


SectionLabel Property

[image]
ActiveReports 19 .NET Edition
SectionLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IReportSectionLayoutPage Interface : SectionLabel Property

Glossary Item Box

Report Section Label

Syntax

Visual Basic (Declaration)
ReadOnly Property SectionLabel As String
C#
string SectionLabel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportSectionLayoutPage Interface
IReportSectionLayoutPage Members


ISpanCellMethodResolver Interface

[image]
ActiveReports 19 .NET Edition
ISpanCellMethodResolver Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface

Glossary Item Box

Represents a resolve method for spanned cells of the grid.

Syntax

Visual Basic (Declaration)
Public Interface ISpanCellMethodResolver
C#
public interface ISpanCellMethodResolver

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISpanCellMethodResolver Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ISpanCellMethodResolver Interface Members

[image]
ActiveReports 19 .NET Edition
ISpanCellMethodResolver Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface

Glossary Item Box

The following tables list the members exposed by ISpanCellMethodResolver.

Public Properties

 | Name | Description
Property | SpanResolveMethod | Gets the method used to indicate spanned cells.
Top

See Also

Reference

ISpanCellMethodResolver Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ISpanCellMethodResolver Interface Properties

[image]
ActiveReports 19 .NET Edition
ISpanCellMethodResolver Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface

Glossary Item Box

For a list of all members of this type, see ISpanCellMethodResolver members.

Public Properties

 | Name | Description
Property | SpanResolveMethod | Gets the method used to indicate spanned cells.
Top

See Also

Reference

ISpanCellMethodResolver Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SpanResolveMethod Property

[image]
ActiveReports 19 .NET Edition
SpanResolveMethod Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ISpanCellMethodResolver Interface : SpanResolveMethod Property

Glossary Item Box

Gets the method used to indicate spanned cells.

Syntax

Visual Basic (Declaration)
ReadOnly Property SpanResolveMethod As SpanCellResolveMethod
C#
SpanCellResolveMethod SpanResolveMethod {get;}

Property Value

A SpanCellResolveMethod value representing the method to resolve spanned cells.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISpanCellMethodResolver Interface
ISpanCellMethodResolver Members


IStaticContentRange Interface

[image]
ActiveReports 19 .NET Edition
IStaticContentRange Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IStaticContentRange Interface

Glossary Item Box

Represents a content range implementation for StaticContentLayoutManager.

Syntax

Visual Basic (Declaration)
Public Interface IStaticContentRange
   Inherits IContentRange
C#
public interface IStaticContentRange : IContentRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IStaticContentRange Interface Members

[image]
ActiveReports 19 .NET Edition
IStaticContentRange Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IStaticContentRange Interface

Glossary Item Box

The following tables list the members exposed by IStaticContentRange.

Public Properties

 | Name | Description
Property | CompleteItemHorizontally | Gets a value indicating whether a complete item fits into this range horizontally.
Property | CompleteItemVertically | Gets a value indicating whether a complete item fits into this range vertically.
Property | EndHorzRange | Gets the right coordinate of the viewport.
Property | EndVertRange | Gets the bottom coordinate of the viewport.
Property | ItemHeight | Gets the complete item height.
Property | ItemWidth | Gets the complete item width.
Property | StartHorzRange | Gets the left coordinate of the viewport.
Property | StartVertRange | Gets the top coordinate of the viewport.
Top

See Also

Reference

IStaticContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IStaticContentRange Interface Properties

[image]
ActiveReports 19 .NET Edition
IStaticContentRange Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IStaticContentRange Interface

Glossary Item Box

For a list of all members of this type, see IStaticContentRange members.

Public Properties

 | Name | Description
Property | CompleteItemHorizontally | Gets a value indicating whether a complete item fits into this range horizontally.
Property | CompleteItemVertically | Gets a value indicating whether a complete item fits into this range vertically.
Property | EndHorzRange | Gets the right coordinate of the viewport.
Property | EndVertRange | Gets the bottom coordinate of the viewport.
Property | ItemHeight | Gets the complete item height.
Property | ItemWidth | Gets the complete item width.
Property | StartHorzRange | Gets the left coordinate of the viewport.
Property | StartVertRange | Gets the top coordinate of the viewport.
Top

See Also

Reference

IStaticContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CompleteItemHorizontally Property

[image]
ActiveReports 19 .NET Edition
CompleteItemHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : CompleteItemHorizontally Property

Glossary Item Box

Gets a value indicating whether a complete item fits into this range horizontally.

Syntax

Visual Basic (Declaration)
ReadOnly Property CompleteItemHorizontally As Boolean
C#
bool CompleteItemHorizontally {get;}

Property Value

true if a complete item fits horizontally; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


CompleteItemVertically Property

[image]
ActiveReports 19 .NET Edition
CompleteItemVertically Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : CompleteItemVertically Property

Glossary Item Box

Gets a value indicating whether a complete item fits into this range vertically.

Syntax

Visual Basic (Declaration)
ReadOnly Property CompleteItemVertically As Boolean
C#
bool CompleteItemVertically {get;}

Property Value

true if a complete item fits vertically; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


EndHorzRange Property

[image]
ActiveReports 19 .NET Edition
EndHorzRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : EndHorzRange Property

Glossary Item Box

Gets the right coordinate of the viewport.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndHorzRange As Single
C#
float EndHorzRange {get;}

Property Value

The right coordinate of the viewport as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


EndVertRange Property

[image]
ActiveReports 19 .NET Edition
EndVertRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : EndVertRange Property

Glossary Item Box

Gets the bottom coordinate of the viewport.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndVertRange As Single
C#
float EndVertRange {get;}

Property Value

The bottom coordinate of the viewport as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


ItemHeight Property

[image]
ActiveReports 19 .NET Edition
ItemHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : ItemHeight Property

Glossary Item Box

Gets the complete item height.

Syntax

Visual Basic (Declaration)
ReadOnly Property ItemHeight As Integer
C#
int ItemHeight {get;}

Property Value

The height of the complete item as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


ItemWidth Property

[image]
ActiveReports 19 .NET Edition
ItemWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : ItemWidth Property

Glossary Item Box

Gets the complete item width.

Syntax

Visual Basic (Declaration)
ReadOnly Property ItemWidth As Integer
C#
int ItemWidth {get;}

Property Value

The width of the complete item as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


StartHorzRange Property

[image]
ActiveReports 19 .NET Edition
StartHorzRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : StartHorzRange Property

Glossary Item Box

Gets the left coordinate of the viewport.

Syntax

Visual Basic (Declaration)
ReadOnly Property StartHorzRange As Single
C#
float StartHorzRange {get;}

Property Value

The left coordinate of the viewport as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


StartVertRange Property

[image]
ActiveReports 19 .NET Edition
StartVertRange Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IStaticContentRange Interface : StartVertRange Property

Glossary Item Box

Gets the top coordinate of the viewport.

Syntax

Visual Basic (Declaration)
ReadOnly Property StartVertRange As Single
C#
float StartVertRange {get;}

Property Value

The top coordinate of the viewport as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticContentRange Interface
IStaticContentRange Members


ITargetDevice Interface

[image]
ActiveReports 19 .NET Edition
ITargetDevice Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface

Glossary Item Box

Interface to encapsulate target device properties and features, including, but not limited: - avail. fonts; - font/color mapping; - conversion of logical units to physical (dpi); - etc.

Syntax

Visual Basic (Declaration)
Public Interface ITargetDevice
C#
public interface ITargetDevice

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITargetDevice Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDevice Interface Members

[image]
ActiveReports 19 .NET Edition
ITargetDevice Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface

Glossary Item Box

The following tables list the members exposed by ITargetDevice.

Public Properties

 | Name | Description
Property | Item | Indexer that returns DeviceCapabilities for the specified feature set.
Top

See Also

Reference

ITargetDevice Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDevice Interface Properties

[image]
ActiveReports 19 .NET Edition
ITargetDevice Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface

Glossary Item Box

For a list of all members of this type, see ITargetDevice members.

Public Properties

 | Name | Description
Property | Item | Indexer that returns DeviceCapabilities for the specified feature set.
Top

See Also

Reference

ITargetDevice Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITargetDevice Interface : Item Property

feature
Feature to fetch device capabilities for.

Glossary Item Box

Indexer that returns DeviceCapabilities for the specified feature set.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal feature As Features _
) As DeviceCapabilities
C#
DeviceCapabilities this[
   Features feature
]; {get;}

Parameters

feature
Feature to fetch device capabilities for.

Property Value

DeviceCapabilities for this feature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITargetDevice Interface
ITargetDevice Members


ITextContentRange Interface

[image]
ActiveReports 19 .NET Edition
ITextContentRange Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITextContentRange Interface

Glossary Item Box

Represents the content range of the textbox.

Syntax

Visual Basic (Declaration)
Public Interface ITextContentRange
   Inherits IContentRange
C#
public interface ITextContentRange : IContentRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITextContentRange Interface Members

[image]
ActiveReports 19 .NET Edition
ITextContentRange Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITextContentRange Interface

Glossary Item Box

The following tables list the members exposed by ITextContentRange.

Public Properties

 | Name | Description
Property | EndPosition | Gets the end of the text range.
Property | Height | Gets the full height of the textbox.
Property | HorizontalOffset | Gets the horizontal offset.
Property | IsSingleLine | Gets a value indicating whether this text run is fitted into one text line.
Property | ScaleX | Gets the horizontal scale factor.
Property | StartPosition | Gets the beginning of the text range.
Property | Text | Gets the text value.
Property | Width | Gets the full width of the textbox.
Top

See Also

Reference

ITextContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITextContentRange Interface Properties

[image]
ActiveReports 19 .NET Edition
ITextContentRange Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITextContentRange Interface

Glossary Item Box

For a list of all members of this type, see ITextContentRange members.

Public Properties

 | Name | Description
Property | EndPosition | Gets the end of the text range.
Property | Height | Gets the full height of the textbox.
Property | HorizontalOffset | Gets the horizontal offset.
Property | IsSingleLine | Gets a value indicating whether this text run is fitted into one text line.
Property | ScaleX | Gets the horizontal scale factor.
Property | StartPosition | Gets the beginning of the text range.
Property | Text | Gets the text value.
Property | Width | Gets the full width of the textbox.
Top

See Also

Reference

ITextContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EndPosition Property

[image]
ActiveReports 19 .NET Edition
EndPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : EndPosition Property

Glossary Item Box

Gets the end of the text range.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndPosition As Integer
C#
int EndPosition {get;}

Property Value

The end position of the text range as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : Height Property

Glossary Item Box

Gets the full height of the textbox.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Integer
C#
int Height {get;}

Property Value

The height of the textbox as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


HorizontalOffset Property

[image]
ActiveReports 19 .NET Edition
HorizontalOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : HorizontalOffset Property

Glossary Item Box

Gets the horizontal offset.

Syntax

Visual Basic (Declaration)
ReadOnly Property HorizontalOffset As Integer
C#
int HorizontalOffset {get;}

Property Value

The horizontal offset as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


IsSingleLine Property

[image]
ActiveReports 19 .NET Edition
IsSingleLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : IsSingleLine Property

Glossary Item Box

Gets a value indicating whether this text run is fitted into one text line.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSingleLine As Boolean
C#
bool IsSingleLine {get;}

Property Value

true if the text run is a single line; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


ScaleX Property

[image]
ActiveReports 19 .NET Edition
ScaleX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : ScaleX Property

Glossary Item Box

Gets the horizontal scale factor.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleX As Single
C#
float ScaleX {get;}

Property Value

The horizontal scale factor as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


StartPosition Property

[image]
ActiveReports 19 .NET Edition
StartPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : StartPosition Property

Glossary Item Box

Gets the beginning of the text range.

Syntax

Visual Basic (Declaration)
ReadOnly Property StartPosition As Integer
C#
int StartPosition {get;}

Property Value

The start position of the text range as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : Text Property

Glossary Item Box

Gets the text value.

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
C#
string Text {get;}

Property Value

The text content as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITextContentRange Interface : Width Property

Glossary Item Box

Gets the full width of the textbox.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Integer
C#
int Width {get;}

Property Value

The width of the textbox as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextContentRange Interface
ITextContentRange Members


LayoutNotificationCallback Delegate

[image]
ActiveReports 19 .NET Edition
LayoutNotificationCallback Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutNotificationCallback Delegate

state

Glossary Item Box

Specifies notification callback for layout operation.

Syntax

Visual Basic (Declaration)
Public Delegate Function LayoutNotificationCallback( _
   ByVal state As LayoutState _
) As Boolean
C#
public delegate bool LayoutNotificationCallback(
   LayoutState state
)

Parameters

state

Return Value

true to continue layout or false to cancel layout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutNotificationCallback Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutPageSectionType Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutPageSectionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace : LayoutPageSectionType Enumeration

Glossary Item Box

Specifies the types of sections in a layout page.

Syntax

Visual Basic (Declaration)
Public Enum LayoutPageSectionType
   Inherits System.Enum
C#
public enum LayoutPageSectionType : System.Enum

Members

Member | Description
SectionBody | Designates page body.
SectionFooter | Designates page footer.
SectionHeader | Designates page header.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.Areas.LayoutPageSectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace


CustomData Class

[image]
ActiveReports 19 .NET Edition
CustomData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class

Glossary Item Box

Represents the data for a custom data region.

Object Model

CustomData Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class CustomData
C#
public abstract class CustomData

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomData Class Members

[image]
ActiveReports 19 .NET Edition
CustomData Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class

Glossary Item Box

The following tables list the members exposed by CustomData.

Public Properties

 | Name | Description
Public Property | DataCells | Gets the cells contained in the detail-data area of the CustomData structure.
Public Property | DataColumnGroupings | Gets the groupings on the column axis for the CustomData structure.
Public Property | DataRowGroupings | Gets the groupings on the row axis for the CustomData structure.
Public Property | NoRows | Gets a value indicating whether no data is available for this data region.
Top

See Also

Reference

CustomData Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomData Class Properties

[image]
ActiveReports 19 .NET Edition
CustomData Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class

Glossary Item Box

For a list of all members of this type, see CustomData members.

Public Properties

 | Name | Description
Public Property | DataCells | Gets the cells contained in the detail-data area of the CustomData structure.
Public Property | DataColumnGroupings | Gets the groupings on the column axis for the CustomData structure.
Public Property | DataRowGroupings | Gets the groupings on the row axis for the CustomData structure.
Public Property | NoRows | Gets a value indicating whether no data is available for this data region.
Top

See Also

Reference

CustomData Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCells Property

[image]
ActiveReports 19 .NET Edition
DataCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataCells Property

Glossary Item Box

Gets the cells contained in the detail-data area of the CustomData structure.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataCells As DataCellCollection
C#
public abstract DataCellCollection DataCells {get;}

Property Value

The collection of data cells.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataColumnGroupings Property

[image]
ActiveReports 19 .NET Edition
DataColumnGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataColumnGroupings Property

Glossary Item Box

Gets the groupings on the column axis for the CustomData structure.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataColumnGroupings As DataGroupingCollection
C#
public abstract DataGroupingCollection DataColumnGroupings {get;}

Property Value

The collection of data column groupings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


DataRowGroupings Property

[image]
ActiveReports 19 .NET Edition
DataRowGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataRowGroupings Property

Glossary Item Box

Gets the groupings on the row axis for the CustomData structure.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataRowGroupings As DataGroupingCollection
C#
public abstract DataGroupingCollection DataRowGroupings {get;}

Property Value

The collection of data row groupings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : NoRows Property

Glossary Item Box

Gets a value indicating whether no data is available for this data region.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property NoRows As Boolean
C#
public abstract bool NoRows {get;}

Property Value

true if no data is available; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomData Class
CustomData Members


CustomProperty Class

[image]
ActiveReports 19 .NET Edition
CustomProperty Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class

Glossary Item Box

Represents a custom property with a name and value.

Object Model

CustomProperty Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomProperty
C#
public sealed class CustomProperty

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperty Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomProperty Class Members

[image]
ActiveReports 19 .NET Edition
CustomProperty Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class

Glossary Item Box

The following tables list the members exposed by CustomProperty.

Public Constructors

 | Name | Description
Public Constructor | CustomProperty Constructor | Initializes a new instance of the CustomProperty class with the specified name and value.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the name of this property.
Public Property | Value | Gets the value of this property.
Top

See Also

Reference

CustomProperty Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomProperty Constructor

[image]
ActiveReports 19 .NET Edition
CustomProperty Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomProperty Class : CustomProperty Constructor

name
The name of the custom property.
value
The value of the custom property.

Glossary Item Box

Initializes a new instance of the CustomProperty class with the specified name and value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public CustomProperty(
   string name,
   object value
)

Parameters

name
The name of the custom property.
value
The value of the custom property.

Remarks

This method should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperty Class
CustomProperty Members


CustomProperty Class Properties

[image]
ActiveReports 19 .NET Edition
CustomProperty Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class

Glossary Item Box

For a list of all members of this type, see CustomProperty members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of this property.
Public Property | Value | Gets the value of this property.
Top

See Also

Reference

CustomProperty Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomProperty Class : Name Property

Glossary Item Box

Gets the name of this property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperty Class
CustomProperty Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomProperty Class : Value Property

Glossary Item Box

Gets the value of this property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

The value of the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomProperty Class
CustomProperty Members


CustomPropertyCollection Class

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomPropertyCollection Class

Glossary Item Box

Represents a collection of custom properties.

Object Model

CustomPropertyCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomPropertyCollection
C#
public sealed class CustomPropertyCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomPropertyCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomPropertyCollection Class Members

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomPropertyCollection Class

Glossary Item Box

The following tables list the members exposed by CustomPropertyCollection.

Public Constructors

 | Name | Description
Public Constructor | CustomPropertyCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

See Also

Reference

CustomPropertyCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomPropertyCollection Constructor

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class : CustomPropertyCollection Constructor

Glossary Item Box

Overload List

Overload | Description
CustomPropertyCollection Constructor() | Initializes a new instance of the CustomPropertyCollection class.
CustomPropertyCollection Constructor(IEnumerable<CustomProperty>) | Initializes a new instance of the CustomPropertyCollection class with the specified properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members


CustomPropertyCollection Constructor()

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class > CustomPropertyCollection Constructor : CustomPropertyCollection Constructor()

Glossary Item Box

Initializes a new instance of the CustomPropertyCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomPropertyCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members
Overload List


CustomPropertyCollection Constructor(IEnumerable<CustomProperty>)

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Constructor(IEnumerable<CustomProperty>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class > CustomPropertyCollection Constructor : CustomPropertyCollection Constructor(IEnumerable<CustomProperty>)

properties
A collection of CustomProperty objects.

Glossary Item Box

Initializes a new instance of the CustomPropertyCollection class with the specified properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal properties As IEnumerable(Of CustomProperty) _
)
C#
public CustomPropertyCollection(
   IEnumerable<CustomProperty> properties
)

Parameters

properties
A collection of CustomProperty objects.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when properties is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members
Overload List


CustomPropertyCollection Class Properties

[image]
ActiveReports 19 .NET Edition
CustomPropertyCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomPropertyCollection Class

Glossary Item Box

For a list of all members of this type, see CustomPropertyCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

See Also

Reference

CustomPropertyCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class : Item Property

Glossary Item Box

Gets the element at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets the element at the specified index.
Item(String) | Gets the CustomProperty with the specified property name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the element to get.

Glossary Item Box

Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As CustomProperty
C#
public CustomProperty Item(
   int index
) {get;}

Parameters

index
The zero-based index of the element to get.

Property Value

The element of type CustomProperty located at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomPropertyCollection Class > Item Property : Item(String) Property

propertyName
The name of the custom property.

Glossary Item Box

Gets the CustomProperty with the specified property name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal propertyName As String _
) As CustomProperty
C#
public CustomProperty Item(
   string propertyName
) {get;}

Parameters

propertyName
The name of the custom property.

Property Value

The CustomProperty with the specified property name, or null if not found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomPropertyCollection Class
CustomPropertyCollection Members
Overload List


DataCell Class

[image]
ActiveReports 19 .NET Edition
DataCell Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCell Class

Glossary Item Box

Represents the data cell.

Object Model

DataCell Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataCell
C#
public abstract class DataCell

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCell Class Members

[image]
ActiveReports 19 .NET Edition
DataCell Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCell Class

Glossary Item Box

The following tables list the members exposed by DataCell.

Public Properties

 | Name | Description
Public Property | DataValues | Gets the data values of the current data cell.
Top

See Also

Reference

DataCell Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCell Class Properties

[image]
ActiveReports 19 .NET Edition
DataCell Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCell Class

Glossary Item Box

For a list of all members of this type, see DataCell members.

Public Properties

 | Name | Description
Public Property | DataValues | Gets the data values of the current data cell.
Top

See Also

Reference

DataCell Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataValues Property

[image]
ActiveReports 19 .NET Edition
DataValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataCell Class : DataValues Property

Glossary Item Box

Gets the data values of the current data cell.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataValues As DataValueCollection
C#
public abstract DataValueCollection DataValues {get;}

Property Value

A DataValueCollection containing the data values of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCell Class
DataCell Members


DataCellCollection Class

[image]
ActiveReports 19 .NET Edition
DataCellCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCellCollection Class

Glossary Item Box

Represents the data cell collection.

Object Model

DataCellCollection Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataCellCollection
C#
public abstract class DataCellCollection

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCellCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataCellCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCellCollection Class

Glossary Item Box

The following tables list the members exposed by DataCellCollection.

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets the column count of the current collection.
Public Property | Count | Gets the data cell count.
Public Property | Item | Gets the DataCell with the specified row and column.
Public Property | RowCount | Gets the row count of the current collection.
Top

See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCellCollection Class Properties

[image]
ActiveReports 19 .NET Edition
DataCellCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataCellCollection Class

Glossary Item Box

For a list of all members of this type, see DataCellCollection members.

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets the column count of the current collection.
Public Property | Count | Gets the data cell count.
Public Property | Item | Gets the DataCell with the specified row and column.
Public Property | RowCount | Gets the row count of the current collection.
Top

See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ColumnCount Property

[image]
ActiveReports 19 .NET Edition
ColumnCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataCellCollection Class : ColumnCount Property

Glossary Item Box

Gets the column count of the current collection.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ColumnCount As Integer
C#
public abstract int ColumnCount {get;}

Property Value

The number of columns in the collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Class
DataCellCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataCellCollection Class : Count Property

Glossary Item Box

Gets the data cell count.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Count As Integer
C#
public abstract int Count {get;}

Property Value

The total number of data cells in the collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Class
DataCellCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataCellCollection Class : Item Property

row
The row index of the cell.
column
The column index of the cell.

Glossary Item Box

Gets the DataCell with the specified row and column.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Default Property Item( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As DataCell
C#
public abstract DataCell this[
   int row,
   int column
]; {get;}

Parameters

row
The row index of the cell.
column
The column index of the cell.

Property Value

The DataCell located at the specified row and column indices.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Class
DataCellCollection Members


RowCount Property

[image]
ActiveReports 19 .NET Edition
RowCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataCellCollection Class : RowCount Property

Glossary Item Box

Gets the row count of the current collection.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property RowCount As Integer
C#
public abstract int RowCount {get;}

Property Value

The number of rows in the collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataCellCollection Class
DataCellCollection Members


DataGroupingCollection Class

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataGroupingCollection Class

Glossary Item Box

Represents the data grouping collection.

Object Model

DataGroupingCollection Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataGroupingCollection
C#
public abstract class DataGroupingCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataGroupingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGroupingCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataGroupingCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataGroupingCollection Class

Glossary Item Box

The following tables list the members exposed by DataGroupingCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the items count.
Public Property | Item | Gets the DataMemberCollection at the specified index.
Top

See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataGroupingCollection Class Properties

[image]
ActiveReports 19 .NET Edition
DataGroupingCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataGroupingCollection Class

Glossary Item Box

For a list of all members of this type, see DataGroupingCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the items count.
Public Property | Item | Gets the DataMemberCollection at the specified index.
Top

See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataGroupingCollection Class : Count Property

Glossary Item Box

Gets the items count.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Count As Integer
C#
public abstract int Count {get;}

Property Value

The total number of items in the data grouping collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataGroupingCollection Class : Item Property

index
The item index.

Glossary Item Box

Gets the DataMemberCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataMemberCollection
C#
public abstract DataMemberCollection this[
   int index
]; {get;}

Parameters

index
The item index.

Property Value

The DataMemberCollection located at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


DataMember Class

[image]
ActiveReports 19 .NET Edition
DataMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class

Glossary Item Box

Represents a heading member on the row or column axis of the CustomData structure.

Object Model

DataMember Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataMember
C#
public abstract class DataMember

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMember Class Members

[image]
ActiveReports 19 .NET Edition
DataMember Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class

Glossary Item Box

The following tables list the members exposed by DataMember.

Public Properties

 | Name | Description
Public Property | Children | Gets the members contained within this member.
Public Property | CustomProperties | Gets the custom properties for this member.
Public Property | DataElementName | Gets the name to use for the data element or attribute for this data member when rendered via a data-oriented rendering extension (e.g., XML).
Public Property | DataElementOutput | Gets the value indicating how this item should appear when rendered with a data-oriented rendering device.
Public Property | Hidden | Gets a value indicating the current hidden state of this member. The value can change via toggling.
Public Property | IsStatic | Gets a value indicating whether this member is part of a static grouping that repeats for every instance of its parent member.
Public Property | IsTotal | Gets a value indicating whether this member shows subtotal values or a value for a particular member.
Public Property | MemberCellIndex | Gets the index of the cell within CustomData.DataCells where this member starts.
Public Property | MemberHeadingSpan | Gets the number of leaf groups this member spans.
Public Property | Parent | Gets the parent of this member.
Top

See Also

Reference

DataMember Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMember Class Properties

[image]
ActiveReports 19 .NET Edition
DataMember Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class

Glossary Item Box

For a list of all members of this type, see DataMember members.

Public Properties

 | Name | Description
Public Property | Children | Gets the members contained within this member.
Public Property | CustomProperties | Gets the custom properties for this member.
Public Property | DataElementName | Gets the name to use for the data element or attribute for this data member when rendered via a data-oriented rendering extension (e.g., XML).
Public Property | DataElementOutput | Gets the value indicating how this item should appear when rendered with a data-oriented rendering device.
Public Property | Hidden | Gets a value indicating the current hidden state of this member. The value can change via toggling.
Public Property | IsStatic | Gets a value indicating whether this member is part of a static grouping that repeats for every instance of its parent member.
Public Property | IsTotal | Gets a value indicating whether this member shows subtotal values or a value for a particular member.
Public Property | MemberCellIndex | Gets the index of the cell within CustomData.DataCells where this member starts.
Public Property | MemberHeadingSpan | Gets the number of leaf groups this member spans.
Public Property | Parent | Gets the parent of this member.
Top

See Also

Reference

DataMember Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Children Property

Glossary Item Box

Gets the members contained within this member.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Children As DataGroupingCollection
C#
public abstract DataGroupingCollection Children {get;}

Property Value

A DataGroupingCollection containing the child members.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : CustomProperties Property

Glossary Item Box

Gets the custom properties for this member.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property CustomProperties As CustomPropertyCollection
C#
public abstract CustomPropertyCollection CustomProperties {get;}

Property Value

A CustomPropertyCollection containing custom properties for this member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : DataElementName Property

Glossary Item Box

Gets the name to use for the data element or attribute for this data member when rendered via a data-oriented rendering extension (e.g., XML).

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataElementName As String
C#
public abstract string DataElementName {get;}

Property Value

The name of the data element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : DataElementOutput Property

Glossary Item Box

Gets the value indicating how this item should appear when rendered with a data-oriented rendering device.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataElementOutput As DataElementOutput
C#
public abstract DataElementOutput DataElementOutput {get;}

Property Value

The DataElementOutput value specifying the rendering appearance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Hidden Property

Glossary Item Box

Gets a value indicating the current hidden state of this member. The value can change via toggling.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Hidden As Boolean
C#
public abstract bool Hidden {get;}

Property Value

true if this member is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : IsStatic Property

Glossary Item Box

Gets a value indicating whether this member is part of a static grouping that repeats for every instance of its parent member.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsStatic As Boolean
C#
public abstract bool IsStatic {get;}

Property Value

true if this member is static; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


IsTotal Property

[image]
ActiveReports 19 .NET Edition
IsTotal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : IsTotal Property

Glossary Item Box

Gets a value indicating whether this member shows subtotal values or a value for a particular member.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsTotal As Boolean
C#
public abstract bool IsTotal {get;}

Property Value

true if this member shows total values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


MemberCellIndex Property

[image]
ActiveReports 19 .NET Edition
MemberCellIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : MemberCellIndex Property

Glossary Item Box

Gets the index of the cell within CustomData.DataCells where this member starts.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property MemberCellIndex As Integer
C#
public abstract int MemberCellIndex {get;}

Property Value

The zero-based index of the starting cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members
MemberHeadingSpan Property


MemberHeadingSpan Property

[image]
ActiveReports 19 .NET Edition
MemberHeadingSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : MemberHeadingSpan Property

Glossary Item Box

Gets the number of leaf groups this member spans.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property MemberHeadingSpan As Integer
C#
public abstract int MemberHeadingSpan {get;}

Property Value

The number of leaf groups spanned by this member. This value is always at least one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Parent Property

Glossary Item Box

Gets the parent of this member.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Parent As DataMember
C#
public abstract DataMember Parent {get;}

Property Value

The parent DataMember.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMember Class
DataMember Members


DataMemberCollection Class

[image]
ActiveReports 19 .NET Edition
DataMemberCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMemberCollection Class

Glossary Item Box

Represents the data member collection.

Object Model

DataMemberCollection Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataMemberCollection
C#
public abstract class DataMemberCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataMemberCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMemberCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMemberCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataMemberCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMemberCollection Class

Glossary Item Box

The following tables list the members exposed by DataMemberCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the data member count.
Public Property | Item | Gets the DataMember at the specified index.
Top

See Also

Reference

DataMemberCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMemberCollection Class Properties

[image]
ActiveReports 19 .NET Edition
DataMemberCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMemberCollection Class

Glossary Item Box

For a list of all members of this type, see DataMemberCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the data member count.
Public Property | Item | Gets the DataMember at the specified index.
Top

See Also

Reference

DataMemberCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMemberCollection Class : Count Property

Glossary Item Box

Gets the data member count.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Count As Integer
C#
public abstract int Count {get;}

Property Value

The total number of data members in the collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMemberCollection Class
DataMemberCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMemberCollection Class : Item Property

index
The index.

Glossary Item Box

Gets the DataMember at the specified index.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataMember
C#
public abstract DataMember this[
   int index
]; {get;}

Parameters

index
The index.

Property Value

The DataMember located at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataMemberCollection Class
DataMemberCollection Members


DataValue Class

[image]
ActiveReports 19 .NET Edition
DataValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValue Class

Glossary Item Box

Represents the data value.

Object Model

DataValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataValue
C#
public sealed class DataValue

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataValue Class Members

[image]
ActiveReports 19 .NET Edition
DataValue Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValue Class

Glossary Item Box

The following tables list the members exposed by DataValue.

Public Constructors

 | Name | Description
Public Constructor | DataValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the element's name.
Public Property | Value | Gets the element's value.
Top

See Also

Reference

DataValue Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataValue Constructor

[image]
ActiveReports 19 .NET Edition
DataValue Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataValue Class : DataValue Constructor

name
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public DataValue(
   string name,
   object value
)

Parameters

name
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


DataValue Class Properties

[image]
ActiveReports 19 .NET Edition
DataValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValue Class

Glossary Item Box

For a list of all members of this type, see DataValue members.

Public Properties

 | Name | Description
Public Property | Name | Gets the element's name.
Public Property | Value | Gets the element's value.
Top

See Also

Reference

DataValue Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataValue Class : Name Property

Glossary Item Box

Gets the element's name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of the data element as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataValue Class : Value Property

Glossary Item Box

Gets the element's value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

The value of the data element as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValue Class
DataValue Members


DataValueCollection Class

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValueCollection Class

Glossary Item Box

Represents the collection of data values.

Object Model

DataValueCollection Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataValueCollection
C#
public abstract class DataValueCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataValueCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataValueCollection Class Members

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValueCollection Class

Glossary Item Box

The following tables list the members exposed by DataValueCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the data values count.
Public Property | Item | Gets the DataValue at the specified index.
Top

See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataValueCollection Class Properties

[image]
ActiveReports 19 .NET Edition
DataValueCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataValueCollection Class

Glossary Item Box

For a list of all members of this type, see DataValueCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the data values count.
Public Property | Item | Gets the DataValue at the specified index.
Top

See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataValueCollection Class : Count Property

Glossary Item Box

Gets the data values count.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Count As Integer
C#
public abstract int Count {get;}

Property Value

The total number of data values in the collection as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Class
DataValueCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataValueCollection Class : Item Property

index
The value index.

Glossary Item Box

Gets the DataValue at the specified index.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataValue
C#
public abstract DataValue this[
   int index
]; {get;}

Parameters

index
The value index.

Property Value

The DataValue located at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataValueCollection Class
DataValueCollection Members


GlobalConstants Class

[image]
ActiveReports 19 .NET Edition
GlobalConstants Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : GlobalConstants Class

Glossary Item Box

Represents constants often used in modules.

Object Model

GlobalConstants Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class GlobalConstants
C#
public static class GlobalConstants

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.GlobalConstants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GlobalConstants Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GlobalConstants Class Members

[image]
ActiveReports 19 .NET Edition
GlobalConstants Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : GlobalConstants Class

Glossary Item Box

The following tables list the members exposed by GlobalConstants.

Public Fields

 | Name | Description
Public Field | FTwipsPerInch | Gets the number of Twips per inch as a float.
Public Field | ITwipsPerInch | Gets the number of Twips per inch as an integer.
Top

See Also

Reference

GlobalConstants Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GlobalConstants Class Fields

[image]
ActiveReports 19 .NET Edition
GlobalConstants Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : GlobalConstants Class

Glossary Item Box

For a list of all members of this type, see GlobalConstants members.

Public Fields

 | Name | Description
Public Field | FTwipsPerInch | Gets the number of Twips per inch as a float.
Public Field | ITwipsPerInch | Gets the number of Twips per inch as an integer.
Top

See Also

Reference

GlobalConstants Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


FTwipsPerInch Field

[image]
ActiveReports 19 .NET Edition
FTwipsPerInch Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > GlobalConstants Class : FTwipsPerInch Field

Glossary Item Box

Gets the number of Twips per inch as a float.

Syntax

Visual Basic (Declaration)
Public Const FTwipsPerInch As Single
C#
public const float FTwipsPerInch

Field Value

A System.Single representing the number of Twips per inch, which is 1440f.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GlobalConstants Class
GlobalConstants Members


ITwipsPerInch Field

[image]
ActiveReports 19 .NET Edition
ITwipsPerInch Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > GlobalConstants Class : ITwipsPerInch Field

Glossary Item Box

Gets the number of Twips per inch as an integer.

Syntax

Visual Basic (Declaration)
Public Const ITwipsPerInch As Integer
C#
public const int ITwipsPerInch

Field Value

An System.Int32 representing the number of Twips per inch, which is 1440.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GlobalConstants Class
GlobalConstants Members


ImageInfo Class

[image]
ActiveReports 19 .NET Edition
ImageInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Class

Glossary Item Box

Represents information about an image.

Object Model

ImageInfo Class

Syntax

Visual Basic (Declaration)
Public Class ImageInfo
C#
public class ImageInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageInfo Class Members

[image]
ActiveReports 19 .NET Edition
ImageInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Class

Glossary Item Box

The following tables list the members exposed by ImageInfo.

Public Constructors

 | Name | Description
Public Constructor | ImageInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | MimeType | Gets the MIME type of the image.
Public Property | Stream | Gets the stream that contains the image data.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified ImageInfo is equal to the current ImageInfo.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

ImageInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageInfo Constructor

[image]
ActiveReports 19 .NET Edition
ImageInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class : ImageInfo Constructor

Glossary Item Box

Overload List

Overload | Description
ImageInfo Constructor(Stream,String) | Initializes a new instance of the ImageInfo struct.
ImageInfo Constructor() | Initializes a new instance of the ImageInfo class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members


ImageInfo Constructor(Stream,String)

[image]
ActiveReports 19 .NET Edition
ImageInfo Constructor(Stream,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class > ImageInfo Constructor : ImageInfo Constructor(Stream,String)

stream
The stream that contains the image data.
mimeType
The mime type of the image.

Glossary Item Box

Initializes a new instance of the ImageInfo struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mimeType As String _
)
C#
public ImageInfo(
   Stream stream,
   string mimeType
)

Parameters

stream
The stream that contains the image data.
mimeType
The mime type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members
Overload List


ImageInfo Constructor()

[image]
ActiveReports 19 .NET Edition
ImageInfo Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class > ImageInfo Constructor : ImageInfo Constructor()

Glossary Item Box

Initializes a new instance of the ImageInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members
Overload List


ImageInfo Class Methods

[image]
ActiveReports 19 .NET Edition
ImageInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Class

Glossary Item Box

For a list of all members of this type, see ImageInfo members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified ImageInfo is equal to the current ImageInfo.
Public Method | GetHashCode | Serves as the default hash function.
Top

See Also

Reference

ImageInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class : Equals Method

Glossary Item Box

Determines whether the specified ImageInfo is equal to the current ImageInfo.

Overload List

Overload | Description
Equals(ImageInfo) | Determines whether the specified ImageInfo is equal to the current ImageInfo.
Equals(Object) | Determines whether the specified object is equal to the current ImageInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members


Equals(ImageInfo) Method

[image]
ActiveReports 19 .NET Edition
Equals(ImageInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class > Equals Method : Equals(ImageInfo) Method

other
The ImageInfo to compare with the current ImageInfo.

Glossary Item Box

Determines whether the specified ImageInfo is equal to the current ImageInfo.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As ImageInfo _
) As Boolean
C#
public bool Equals(
   ImageInfo other
)

Parameters

other
The ImageInfo to compare with the current ImageInfo.

Return Value

true if the specified ImageInfo is equal to the current ImageInfo; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class > Equals Method : Equals(Object) Method

other
The object to compare with the current ImageInfo.

Glossary Item Box

Determines whether the specified object is equal to the current ImageInfo.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal other As Object _
) As Boolean
C#
public override bool Equals(
   object other
)

Parameters

other
The object to compare with the current ImageInfo.

Return Value

true if the specified object is equal to the current ImageInfo; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class : GetHashCode Method

Glossary Item Box

Serves as the default hash function.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current ImageInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members


ImageInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ImageInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Class

Glossary Item Box

For a list of all members of this type, see ImageInfo members.

Public Properties

 | Name | Description
Public Property | MimeType | Gets the MIME type of the image.
Public Property | Stream | Gets the stream that contains the image data.
Top

See Also

Reference

ImageInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


MimeType Property

[image]
ActiveReports 19 .NET Edition
MimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class : MimeType Property

Glossary Item Box

Gets the MIME type of the image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
C#
public string MimeType {get;}

Property Value

The MIME type of the image as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members


Stream Property

[image]
ActiveReports 19 .NET Edition
Stream Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Class : Stream Property

Glossary Item Box

Gets the stream that contains the image data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stream As Stream
C#
public Stream Stream {get;}

Property Value

The stream that contains the image data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Class
ImageInfo Members


RenderingPageEventArgs Class

[image]
ActiveReports 19 .NET Edition
RenderingPageEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class

Glossary Item Box

Encapsulates rendering page event data.

Object Model

RenderingPageEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RenderingPageEventArgs
   Inherits System.EventArgs
C#
public sealed class RenderingPageEventArgs : System.EventArgs

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Rendering.RenderingPageEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingPageEventArgs Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


RenderingPageEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
RenderingPageEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class

Glossary Item Box

The following tables list the members exposed by RenderingPageEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RenderingPageEventArgs Constructor | Initializes rendering event data with specified page
Top

Public Properties

 | Name | Description
Public Property | Cancel | Specifies that further processing should be canceled
Public Property | CurrentPage | Specifies a page number for which event was raised
Top

See Also

Reference

RenderingPageEventArgs Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


RenderingPageEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
RenderingPageEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : RenderingPageEventArgs Constructor

currentPage

Glossary Item Box

Initializes rendering event data with specified page

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal currentPage As Integer _
)
C#
public RenderingPageEventArgs(
   int currentPage
)

Parameters

currentPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


RenderingPageEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
RenderingPageEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class

Glossary Item Box

For a list of all members of this type, see RenderingPageEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Specifies that further processing should be canceled
Public Property | CurrentPage | Specifies a page number for which event was raised
Top

See Also

Reference

RenderingPageEventArgs Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : Cancel Property

Glossary Item Box

Specifies that further processing should be canceled

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


CurrentPage Property

[image]
ActiveReports 19 .NET Edition
CurrentPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : CurrentPage Property

Glossary Item Box

Specifies a page number for which event was raised

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Integer
C#
public int CurrentPage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


IGroup Interface

[image]
ActiveReports 19 .NET Edition
IGroup Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface

Glossary Item Box

Represents an interface for groups.

Syntax

Visual Basic (Declaration)
Public Interface IGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem
C#
public interface IGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IGroup Interface Members

[image]
ActiveReports 19 .NET Edition
IGroup Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface

Glossary Item Box

The following tables list the members exposed by IGroup.

Public Properties

 | Name | Description
Property | Custom | Gets the custom data string.
Property | CustomProperties | Gets the collection of custom properties.
Property | DataCollectionName | Gets the name of the data collection associated with this group.
Property | DataElementName | Gets the name of the data element associated with this group.
Property | DataElementOutput | Gets the data element output type for this group.
Property | EndSection | Gets the section where the layout should continue.
Property | Hidden | Gets a value indicating whether the group should be hidden.
Property | LabelValue | Gets the value representing the label for this member.
Property | Name | Gets the name used for this group.
Property | PageBreak | Gets the page breaking options.
Top

See Also

Reference

IGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IGroup Interface Properties

[image]
ActiveReports 19 .NET Edition
IGroup Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface

Glossary Item Box

For a list of all members of this type, see IGroup members.

Public Properties

 | Name | Description
Property | Custom | Gets the custom data string.
Property | CustomProperties | Gets the collection of custom properties.
Property | DataCollectionName | Gets the name of the data collection associated with this group.
Property | DataElementName | Gets the name of the data element associated with this group.
Property | DataElementOutput | Gets the data element output type for this group.
Property | EndSection | Gets the section where the layout should continue.
Property | Hidden | Gets a value indicating whether the group should be hidden.
Property | LabelValue | Gets the value representing the label for this member.
Property | Name | Gets the name used for this group.
Property | PageBreak | Gets the page breaking options.
Top

See Also

Reference

IGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Custom Property

[image]
ActiveReports 19 .NET Edition
Custom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Custom Property

Glossary Item Box

Gets the custom data string.

Syntax

Visual Basic (Declaration)
ReadOnly Property Custom As String
C#
string Custom {get;}

Property Value

The custom data string as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : CustomProperties Property

Glossary Item Box

Gets the collection of custom properties.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomProperties As CustomPropertyCollection
C#
CustomPropertyCollection CustomProperties {get;}

Property Value

The custom property collection as a CustomPropertyCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


DataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataCollectionName Property

Glossary Item Box

Gets the name of the data collection associated with this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataCollectionName As String
C#
string DataCollectionName {get;}

Property Value

The name of the data collection as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataElementName Property

Glossary Item Box

Gets the name of the data element associated with this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

The name of the data element as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataElementOutput Property

Glossary Item Box

Gets the data element output type for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

The data element output type as a DataElementOutput.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : EndSection Property

Glossary Item Box

Gets the section where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

The end section as an EndSection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether the group should be hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

true if the group should be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


LabelValue Property

[image]
ActiveReports 19 .NET Edition
LabelValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : LabelValue Property

Glossary Item Box

Gets the value representing the label for this member.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelValue As Object
C#
object LabelValue {get;}

Property Value

The label value as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Name Property

Glossary Item Box

Gets the name used for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

The name of the group as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

The page break location as a GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGroup Interface
IGroup Members


IImageLocatorService Interface

[image]
ActiveReports 19 .NET Edition
IImageLocatorService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageLocatorService Interface

Glossary Item Box

Defines functionality for image retrieval and data access.

Syntax

Visual Basic (Declaration)
Public Interface IImageLocatorService
C#
public interface IImageLocatorService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageLocatorService Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IImageLocatorService Interface Members

[image]
ActiveReports 19 .NET Edition
IImageLocatorService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageLocatorService Interface

Glossary Item Box

The following tables list the members exposed by IImageLocatorService.

Public Methods

 | Name | Description
Method | GetImageData | Overloaded. Returns image item data as ImageInfo either from Cache or creating a new image.
Top

See Also

Reference

IImageLocatorService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IImageLocatorService Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageLocatorService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageLocatorService Interface

Glossary Item Box

For a list of all members of this type, see IImageLocatorService members.

Public Methods

 | Name | Description
Method | GetImageData | Overloaded. Returns image item data as ImageInfo either from Cache or creating a new image.
Top

See Also

Reference

IImageLocatorService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetImageData Method

[image]
ActiveReports 19 .NET Edition
GetImageData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageLocatorService Interface : GetImageData Method

Glossary Item Box

Returns image item data as ImageInfo either from Cache or creating a new image.

Overload List

Overload | Description
GetImageData(ILayoutArea,Boolean) | Returns image item data as ImageInfo either from Cache or creating a new image.
GetImageData(IImage,Boolean) | Initialize ImageInfo using specified locator
GetImageData(IStyle,Boolean) | Returns the background image from the specified IStyle instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageLocatorService Interface
IImageLocatorService Members


GetImageData(ILayoutArea,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetImageData(ILayoutArea,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageLocatorService Interface > GetImageData Method : GetImageData(ILayoutArea,Boolean) Method

area
allowMetafiles

Glossary Item Box

Returns image item data as ImageInfo either from Cache or creating a new image.

Syntax

Visual Basic (Declaration)
Overloads Function GetImageData( _
   ByVal area As ILayoutArea, _
   ByVal allowMetafiles As Boolean _
) As ImageInfo
C#
ImageInfo GetImageData(
   ILayoutArea area,
   bool allowMetafiles
)

Parameters

area
allowMetafiles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageLocatorService Interface
IImageLocatorService Members
Overload List


GetImageData(IImage,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetImageData(IImage,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageLocatorService Interface > GetImageData Method : GetImageData(IImage,Boolean) Method

image
allowMetafiles

Glossary Item Box

Initialize ImageInfo using specified locator

Syntax

Visual Basic (Declaration)
Overloads Function GetImageData( _
   ByVal image As IImage, _
   ByVal allowMetafiles As Boolean _
) As ImageInfo
C#
ImageInfo GetImageData(
   IImage image,
   bool allowMetafiles
)

Parameters

image
allowMetafiles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageLocatorService Interface
IImageLocatorService Members
Overload List


GetImageData(IStyle,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetImageData(IStyle,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageLocatorService Interface > GetImageData Method : GetImageData(IStyle,Boolean) Method

style
IStyle to return the background image from.
allowMetafiles
A value indicating whether to allow metafiles.

Glossary Item Box

Returns the background image from the specified IStyle instance.

Syntax

Visual Basic (Declaration)
Overloads Function GetImageData( _
   ByVal style As IStyle, _
   ByVal allowMetafiles As Boolean _
) As ImageInfo
C#
ImageInfo GetImageData(
   IStyle style,
   bool allowMetafiles
)

Parameters

style
IStyle to return the background image from.
allowMetafiles
A value indicating whether to allow metafiles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageLocatorService Interface
IImageLocatorService Members
Overload List


IImageRenderer Interface

[image]
ActiveReports 19 .NET Edition
IImageRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageRenderer Interface

Glossary Item Box

Represents an interface allowing retrieval of an image representation of a report item or layout area.

Syntax

Visual Basic (Declaration)
Public Interface IImageRenderer
   Inherits IRenderer
C#
public interface IImageRenderer : IRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageRenderer Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IImageRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IImageRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageRenderer Interface

Glossary Item Box

The following tables list the members exposed by IImageRenderer.

Public Methods

 | Name | Description
Method | Render | Returns an image representation of the specified report item (background + content).
Method | RenderBackground | Returns an image representation of the specified report item background.
Top

See Also

Reference

IImageRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IImageRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IImageRenderer Interface

Glossary Item Box

For a list of all members of this type, see IImageRenderer members.

Public Methods

 | Name | Description
Method | Render | Returns an image representation of the specified report item (background + content).
Method | RenderBackground | Returns an image representation of the specified report item background.
Top

See Also

Reference

IImageRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageRenderer Interface : Render Method

layoutArea
The layout area to render.
mimeType
Desired type of image to render.
dpi
Desired resolution.

Glossary Item Box

Returns an image representation of the specified report item (background + content).

Syntax

Visual Basic (Declaration)
Function Render( _
   ByVal layoutArea As ILayoutArea, _
   ByVal mimeType As String, _
   ByVal dpi As SizeF _
) As ImageInfo
C#
ImageInfo Render(
   ILayoutArea layoutArea,
   string mimeType,
   SizeF dpi
)

Parameters

layoutArea
The layout area to render.
mimeType
Desired type of image to render.
dpi
Desired resolution.

Return Value

An ImageInfo representing the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageRenderer Interface
IImageRenderer Members


RenderBackground Method

[image]
ActiveReports 19 .NET Edition
RenderBackground Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IImageRenderer Interface : RenderBackground Method

layoutArea
The layout area to render.
mimeType
Desired type of image to render.
dpi
Desired resolution.

Glossary Item Box

Returns an image representation of the specified report item background.

Syntax

Visual Basic (Declaration)
Function RenderBackground( _
   ByVal layoutArea As ILayoutArea, _
   ByVal mimeType As String, _
   ByVal dpi As SizeF _
) As ImageInfo
C#
ImageInfo RenderBackground(
   ILayoutArea layoutArea,
   string mimeType,
   SizeF dpi
)

Parameters

layoutArea
The layout area to render.
mimeType
Desired type of image to render.
dpi
Desired resolution.

Return Value

An ImageInfo representing the report item background.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageRenderer Interface
IImageRenderer Members


ILocalizedTextService Interface

[image]
ActiveReports 19 .NET Edition
ILocalizedTextService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ILocalizedTextService Interface

Glossary Item Box

Represents a service for retrieving localized text.

Syntax

Visual Basic (Declaration)
Public Interface ILocalizedTextService
C#
public interface ILocalizedTextService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILocalizedTextService Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ILocalizedTextService Interface Members

[image]
ActiveReports 19 .NET Edition
ILocalizedTextService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ILocalizedTextService Interface

Glossary Item Box

The following tables list the members exposed by ILocalizedTextService.

Public Methods

 | Name | Description
Method | GetLocalizedText | Gets the localized text for the specified resource property name.
Top

See Also

Reference

ILocalizedTextService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ILocalizedTextService Interface Methods

[image]
ActiveReports 19 .NET Edition
ILocalizedTextService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ILocalizedTextService Interface

Glossary Item Box

For a list of all members of this type, see ILocalizedTextService members.

Public Methods

 | Name | Description
Method | GetLocalizedText | Gets the localized text for the specified resource property name.
Top

See Also

Reference

ILocalizedTextService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetLocalizedText Method

[image]
ActiveReports 19 .NET Edition
GetLocalizedText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ILocalizedTextService Interface : GetLocalizedText Method

resourcePropertyName
The name of the resource property for which to retrieve localized text.

Glossary Item Box

Gets the localized text for the specified resource property name.

Syntax

Visual Basic (Declaration)
Function GetLocalizedText( _
   ByVal resourcePropertyName As String _
) As String
C#
string GetLocalizedText(
   string resourcePropertyName
)

Parameters

resourcePropertyName
The name of the resource property for which to retrieve localized text.

Return Value

A System.String containing the localized text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILocalizedTextService Interface
ILocalizedTextService Members


IPropertyBag Interface

[image]
ActiveReports 19 .NET Edition
IPropertyBag Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

Glossary Item Box

Represents a way to retrieve property values.

Syntax

Visual Basic (Declaration)
Public Interface IPropertyBag
C#
public interface IPropertyBag

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertyBag Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IPropertyBag Interface Members

[image]
ActiveReports 19 .NET Edition
IPropertyBag Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

Glossary Item Box

The following tables list the members exposed by IPropertyBag.

Public Properties

 | Name | Description
Property | PropertyNames | Gets the names of the properties contained in the bag.
Top

Public Methods

 | Name | Description
Method | GetPropertyContent | Gets the content for the named property without evaluation.
Method | GetValue | Gets the value for the named property.
Top

See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IPropertyBag Interface Methods

[image]
ActiveReports 19 .NET Edition
IPropertyBag Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

Glossary Item Box

For a list of all members of this type, see IPropertyBag members.

Public Methods

 | Name | Description
Method | GetPropertyContent | Gets the content for the named property without evaluation.
Method | GetValue | Gets the value for the named property.
Top

See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetPropertyContent Method

[image]
ActiveReports 19 .NET Edition
GetPropertyContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : GetPropertyContent Method

name
The name of the property to retrieve.

Glossary Item Box

Gets the content for the named property without evaluation.

Syntax

Visual Basic (Declaration)
Function GetPropertyContent( _
   ByVal name As String _
) As Object
C#
object GetPropertyContent(
   string name
)

Parameters

name
The name of the property to retrieve.

Return Value

An System.Object representing the property's value without evaluation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertyBag Interface
IPropertyBag Members


GetValue Method

[image]
ActiveReports 19 .NET Edition
GetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : GetValue Method

name
The name of the property to retrieve.

Glossary Item Box

Gets the value for the named property.

Syntax

Visual Basic (Declaration)
Function GetValue( _
   ByVal name As String _
) As Object
C#
object GetValue(
   string name
)

Parameters

name
The name of the property to retrieve.

Return Value

An System.Object representing the property's value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertyBag Interface
IPropertyBag Members


IPropertyBag Interface Properties

[image]
ActiveReports 19 .NET Edition
IPropertyBag Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

Glossary Item Box

For a list of all members of this type, see IPropertyBag members.

Public Properties

 | Name | Description
Property | PropertyNames | Gets the names of the properties contained in the bag.
Top

See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


PropertyNames Property

[image]
ActiveReports 19 .NET Edition
PropertyNames Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : PropertyNames Property

Glossary Item Box

Gets the names of the properties contained in the bag.

Syntax

Visual Basic (Declaration)
ReadOnly Property PropertyNames As IEnumerable(Of String)
C#
IEnumerable<string> PropertyNames {get;}

Property Value

An enumerable collection of System.String representing the property names.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertyBag Interface
IPropertyBag Members


IRenderer Interface

[image]
ActiveReports 19 .NET Edition
IRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderer Interface

Glossary Item Box

Interface of report item renderer. Specific renderers have to extend it.

Syntax

Visual Basic (Declaration)
Public Interface IRenderer
C#
public interface IRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderer Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IRenderer Interface Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderer Interface

Glossary Item Box

The following tables list the members exposed by IRenderer.

See Also

Reference

IRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderersFactory Interface

[image]
ActiveReports 19 .NET Edition
IRenderersFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderersFactory Interface

Glossary Item Box

Interface of report items renderers factory.

Syntax

Visual Basic (Declaration)
Public Interface IRenderersFactory
C#
public interface IRenderersFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderersFactory Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderersFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IRenderersFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderersFactory Interface

Glossary Item Box

The following tables list the members exposed by IRenderersFactory.

Public Methods

 | Name | Description
Method | GetRenderer<TRenderer> | Returns the renderer of the specified type for the specified report item.
Top

See Also

Reference

IRenderersFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderersFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IRenderersFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderersFactory Interface

Glossary Item Box

For a list of all members of this type, see IRenderersFactory members.

Public Methods

 | Name | Description
Method | GetRenderer<TRenderer> | Returns the renderer of the specified type for the specified report item.
Top

See Also

Reference

IRenderersFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetRenderer<TRenderer> Method

TRenderer
[image]
ActiveReports 19 .NET Edition
GetRenderer<TRenderer> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderersFactory Interface : GetRenderer<TRenderer> Method

reportItem
The report item to get renderer for.

Glossary Item Box

Returns the renderer of the specified type for the specified report item.

Syntax

Visual Basic (Declaration)
Function GetRenderer(Of TRenderer As {Class, IRenderer})( _
   ByVal reportItem As IReportItem _
) As TRenderer
C#
TRenderer GetRenderer<TRenderer>(
   IReportItem reportItem
)
where TRenderer: class, IRenderer

Parameters

reportItem
The report item to get renderer for.

Type Parameters

TRenderer

Return Value

Requested IRenderer implementation. Returned value can be null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderersFactory Interface
IRenderersFactory Members


IReportInformationService Interface

[image]
ActiveReports 19 .NET Edition
IReportInformationService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface

Glossary Item Box

Represents a service that returns global variables and user-specific information related to the report.

Syntax

Visual Basic (Declaration)
Public Interface IReportInformationService
C#
public interface IReportInformationService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportInformationService Interface Members

[image]
ActiveReports 19 .NET Edition
IReportInformationService Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface

Glossary Item Box

The following tables list the members exposed by IReportInformationService.

Public Properties

 | Name | Description
Property | ExecutionTime | Gets or sets the date and time when the report began executing.
Property | Language | Gets the language code of the client executing the report.
Property | ReportFolder | Gets the path of the folder containing the report.
Property | ReportName | Gets the name of the report.
Property | UserID | Gets the ID of the user executing the report.
Top

See Also

Reference

IReportInformationService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportInformationService Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportInformationService Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface

Glossary Item Box

For a list of all members of this type, see IReportInformationService members.

Public Properties

 | Name | Description
Property | ExecutionTime | Gets or sets the date and time when the report began executing.
Property | Language | Gets the language code of the client executing the report.
Property | ReportFolder | Gets the path of the folder containing the report.
Property | ReportName | Gets the name of the report.
Property | UserID | Gets the ID of the user executing the report.
Top

See Also

Reference

IReportInformationService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ExecutionTime Property

[image]
ActiveReports 19 .NET Edition
ExecutionTime Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ExecutionTime Property

Glossary Item Box

Gets or sets the date and time when the report began executing.

Syntax

Visual Basic (Declaration)
Property ExecutionTime As Date
C#
DateTime ExecutionTime {get; set;}

Property Value

The date and time of the report execution.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Interface
IReportInformationService Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : Language Property

Glossary Item Box

Gets the language code of the client executing the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Language As String
C#
string Language {get;}

Property Value

The language code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Interface
IReportInformationService Members


ReportFolder Property

[image]
ActiveReports 19 .NET Edition
ReportFolder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ReportFolder Property

Glossary Item Box

Gets the path of the folder containing the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportFolder As String
C#
string ReportFolder {get;}

Property Value

The path of the report folder.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Interface
IReportInformationService Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ReportName Property

Glossary Item Box

Gets the name of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportName As String
C#
string ReportName {get;}

Property Value

The name of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Interface
IReportInformationService Members


UserID Property

[image]
ActiveReports 19 .NET Edition
UserID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : UserID Property

Glossary Item Box

Gets the ID of the user executing the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property UserID As String
C#
string UserID {get;}

Property Value

The user ID.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInformationService Interface
IReportInformationService Members


IReportItemRenderersFactory Interface

[image]
ActiveReports 19 .NET Edition
IReportItemRenderersFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportItemRenderersFactory Interface

Glossary Item Box

Factory for report item renderers. Should be implemented by GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem if it has specific renderers.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemRenderersFactory
C#
public interface IReportItemRenderersFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemRenderersFactory Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportItemRenderersFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemRenderersFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportItemRenderersFactory Interface

Glossary Item Box

The following tables list the members exposed by IReportItemRenderersFactory.

Public Methods

 | Name | Description
Method | GetRenderer<TRenderer> | Returns the renderer of the specified type for the specified report item.
Top

See Also

Reference

IReportItemRenderersFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportItemRenderersFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportItemRenderersFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportItemRenderersFactory Interface

Glossary Item Box

For a list of all members of this type, see IReportItemRenderersFactory members.

Public Methods

 | Name | Description
Method | GetRenderer<TRenderer> | Returns the renderer of the specified type for the specified report item.
Top

See Also

Reference

IReportItemRenderersFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetRenderer<TRenderer> Method

TRenderer
[image]
ActiveReports 19 .NET Edition
GetRenderer<TRenderer> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportItemRenderersFactory Interface : GetRenderer<TRenderer> Method

Glossary Item Box

Returns the renderer of the specified type for the specified report item.

Syntax

Visual Basic (Declaration)
Function GetRenderer(Of TRenderer As {Class, IRenderer})() As TRenderer
C#
TRenderer GetRenderer<TRenderer>()
where TRenderer: class, IRenderer

Type Parameters

TRenderer

Return Value

Requested IRenderer implementation. Returned value can be null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemRenderersFactory Interface
IReportItemRenderersFactory Members


ISettings Interface

[image]
ActiveReports 19 .NET Edition
ISettings Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface

Glossary Item Box

Represents settings for the rendering extension.

Syntax

Visual Basic (Declaration)
Public Interface ISettings
C#
public interface ISettings

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISettings Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ISettings Interface Members

[image]
ActiveReports 19 .NET Edition
ISettings Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface

Glossary Item Box

The following tables list the members exposed by ISettings.

Public Methods

 | Name | Description
Method | ApplySettings | Applies the specified settings to the rendering extension.
Method | GetSettings | Gets a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.
Top

See Also

Reference

ISettings Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ISettings Interface Methods

[image]
ActiveReports 19 .NET Edition
ISettings Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface

Glossary Item Box

For a list of all members of this type, see ISettings members.

Public Methods

 | Name | Description
Method | ApplySettings | Applies the specified settings to the rendering extension.
Method | GetSettings | Gets a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.
Top

See Also

Reference

ISettings Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ApplySettings Method

[image]
ActiveReports 19 .NET Edition
ApplySettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ISettings Interface : ApplySettings Method

settings
A System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.

Glossary Item Box

Applies the specified settings to the rendering extension.

Syntax

Visual Basic (Declaration)
Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
A System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISettings Interface
ISettings Members


GetSettings Method

[image]
ActiveReports 19 .NET Edition
GetSettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ISettings Interface : GetSettings Method

Glossary Item Box

Gets a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.

Syntax

Visual Basic (Declaration)
Function GetSettings() As NameValueCollection
C#
NameValueCollection GetSettings()

Return Value

A System.Collections.Specialized.NameValueCollection containing name/value pairs representing the settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISettings Interface
ISettings Members


ITextRenderer Interface

[image]
ActiveReports 19 .NET Edition
ITextRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITextRenderer Interface

Glossary Item Box

Renderer base interface that ReportItems can use to dump content or its part as a plain text.

Syntax

Visual Basic (Declaration)
Public Interface ITextRenderer
   Inherits IRenderer
C#
public interface ITextRenderer : IRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderer Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ITextRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
ITextRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITextRenderer Interface

Glossary Item Box

The following tables list the members exposed by ITextRenderer.

Public Methods

 | Name | Description
Method | Render | Overloaded. Exports content of the report item as a text
Top

See Also

Reference

ITextRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ITextRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
ITextRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ITextRenderer Interface

Glossary Item Box

For a list of all members of this type, see ITextRenderer members.

Public Methods

 | Name | Description
Method | Render | Overloaded. Exports content of the report item as a text
Top

See Also

Reference

ITextRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ITextRenderer Interface : Render Method

Glossary Item Box

Exports content of the report item as a text

Overload List

Overload | Description
Render(StringWriter,IReportItem,IBookmarkService) | Exports content of the report item as a text
Render(StringWriter,ILayoutArea,IBookmarkService) | Exports content of the content range, corresponding to the area, as plain text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderer Interface
ITextRenderer Members


Render(StringWriter,IReportItem,IBookmarkService) Method

[image]
ActiveReports 19 .NET Edition
Render(StringWriter,IReportItem,IBookmarkService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ITextRenderer Interface > Render Method : Render(StringWriter,IReportItem,IBookmarkService) Method

stringWriter
reportItem
bookmarkService

Glossary Item Box

Exports content of the report item as a text

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal stringWriter As StringWriter, _
   ByVal reportItem As IReportItem, _
   Optional ByVal bookmarkService As IBookmarkService _
)
C#
void Render(
   StringWriter stringWriter,
   IReportItem reportItem,
   IBookmarkService bookmarkService
)

Parameters

stringWriter
reportItem
bookmarkService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderer Interface
ITextRenderer Members
Overload List


Render(StringWriter,ILayoutArea,IBookmarkService) Method

[image]
ActiveReports 19 .NET Edition
Render(StringWriter,ILayoutArea,IBookmarkService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ITextRenderer Interface > Render Method : Render(StringWriter,ILayoutArea,IBookmarkService) Method

stringWriter
area
bookmarkService

Glossary Item Box

Exports content of the content range, corresponding to the area, as plain text

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal stringWriter As StringWriter, _
   ByVal area As ILayoutArea, _
   Optional ByVal bookmarkService As IBookmarkService _
)
C#
void Render(
   StringWriter stringWriter,
   ILayoutArea area,
   IBookmarkService bookmarkService
)

Parameters

stringWriter
area
bookmarkService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextRenderer Interface
ITextRenderer Members
Overload List


ActionBase Class

[image]
ActiveReports 19 .NET Edition
ActionBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ActionBase Class

Glossary Item Box

Represents the base class for actions.

Object Model

ActionBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ActionBase
C#
public abstract class ActionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ApplyParametersAction
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BookmarkLinkAction
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DrillthroughAction
GrapeCity.ActiveReports.Extensibility.Rendering.Components.HyperLinkAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionBase Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ActionBase Class Members

[image]
ActiveReports 19 .NET Edition
ActionBase Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ActionBase Class

Glossary Item Box

The following tables list the members exposed by ActionBase.

See Also

Reference

ActionBase Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParametersAction Class

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersAction Class

Glossary Item Box

Represents an action that applies parameters.

Object Model

ApplyParametersAction Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ApplyParametersAction
   Inherits ActionBase
C#
public abstract class ApplyParametersAction : ActionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ApplyParametersAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParametersAction Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersAction Class

Glossary Item Box

The following tables list the members exposed by ApplyParametersAction.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameter values to be applied.
Top

See Also

Reference

ApplyParametersAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParametersAction Class Properties

[image]
ActiveReports 19 .NET Edition
ApplyParametersAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersAction Class

Glossary Item Box

For a list of all members of this type, see ApplyParametersAction members.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameter values to be applied.
Top

See Also

Reference

ApplyParametersAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ApplyParametersAction Class : Parameters Property

Glossary Item Box

Gets the parameter values to be applied.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Parameters As ApplyParametersActionValue()
C#
public abstract ApplyParametersActionValue[] Parameters {get;}

Property Value

An array of ApplyParametersActionValue representing the parameter values to be applied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersAction Class
ApplyParametersAction Members


ApplyParametersActionValue Class

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersActionValue Class

Glossary Item Box

Represents a parameter of the 'apply parameters' action.

Object Model

ApplyParametersActionValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ApplyParametersActionValue
C#
public sealed class ApplyParametersActionValue

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ApplyParametersActionValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionValue Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParametersActionValue Class Members

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionValue Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersActionValue Class

Glossary Item Box

The following tables list the members exposed by ApplyParametersActionValue.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the parameter to be affected.
Public Property | Type | Gets the apply action type.
Public Property | Value | Gets the optional value of the parameter. Must be specified for 'Set' and 'Toggle' apply types.
Top

See Also

Reference

ApplyParametersActionValue Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParametersActionValue Class Properties

[image]
ActiveReports 19 .NET Edition
ApplyParametersActionValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParametersActionValue Class

Glossary Item Box

For a list of all members of this type, see ApplyParametersActionValue members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the parameter to be affected.
Public Property | Type | Gets the apply action type.
Public Property | Value | Gets the optional value of the parameter. Must be specified for 'Set' and 'Toggle' apply types.
Top

See Also

Reference

ApplyParametersActionValue Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ApplyParametersActionValue Class : Name Property

Glossary Item Box

Gets the name of the parameter to be affected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A System.String representing the name of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionValue Class
ApplyParametersActionValue Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ApplyParametersActionValue Class : Type Property

Glossary Item Box

Gets the apply action type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ApplyParameterType
C#
public ApplyParameterType Type {get;}

Property Value

An ApplyParameterType representing the apply action type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionValue Class
ApplyParametersActionValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ApplyParametersActionValue Class : Value Property

Glossary Item Box

Gets the optional value of the parameter. Must be specified for 'Set' and 'Toggle' apply types.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

An System.Object representing the optional value of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ApplyParametersActionValue Class
ApplyParametersActionValue Members


BookmarkLinkAction Class

[image]
ActiveReports 19 .NET Edition
BookmarkLinkAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : BookmarkLinkAction Class

Glossary Item Box

Represents an action that navigates to a bookmark within a report.

Object Model

BookmarkLinkAction Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class BookmarkLinkAction
   Inherits ActionBase
C#
public abstract class BookmarkLinkAction : ActionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BookmarkLinkAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkLinkAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BookmarkLinkAction Class Members

[image]
ActiveReports 19 .NET Edition
BookmarkLinkAction Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : BookmarkLinkAction Class

Glossary Item Box

The following tables list the members exposed by BookmarkLinkAction.

Public Properties

 | Name | Description
Public Property | Link | Gets the bookmark within the report to navigate to when the report item is clicked.
Top

See Also

Reference

BookmarkLinkAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BookmarkLinkAction Class Properties

[image]
ActiveReports 19 .NET Edition
BookmarkLinkAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : BookmarkLinkAction Class

Glossary Item Box

For a list of all members of this type, see BookmarkLinkAction members.

Public Properties

 | Name | Description
Public Property | Link | Gets the bookmark within the report to navigate to when the report item is clicked.
Top

See Also

Reference

BookmarkLinkAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Link Property

[image]
ActiveReports 19 .NET Edition
Link Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > BookmarkLinkAction Class : Link Property

Glossary Item Box

Gets the bookmark within the report to navigate to when the report item is clicked.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Link As String
C#
public abstract string Link {get;}

Property Value

A System.String representing the bookmark link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkLinkAction Class
BookmarkLinkAction Members


DrillthroughAction Class

[image]
ActiveReports 19 .NET Edition
DrillthroughAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughAction Class

Glossary Item Box

Represents a drillthrough (go to report) action.

Object Model

DrillthroughAction Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DrillthroughAction
   Inherits ActionBase
C#
public abstract class DrillthroughAction : ActionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DrillthroughAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughAction Class Members

[image]
ActiveReports 19 .NET Edition
DrillthroughAction Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughAction Class

Glossary Item Box

The following tables list the members exposed by DrillthroughAction.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the drillthrough parameters.
Public Property | ReportName | Gets the path of the drillthrough report. Paths may be absolute or relative.
Top

See Also

Reference

DrillthroughAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughAction Class Properties

[image]
ActiveReports 19 .NET Edition
DrillthroughAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughAction Class

Glossary Item Box

For a list of all members of this type, see DrillthroughAction members.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the drillthrough parameters.
Public Property | ReportName | Gets the path of the drillthrough report. Paths may be absolute or relative.
Top

See Also

Reference

DrillthroughAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughAction Class : Parameters Property

Glossary Item Box

Gets the drillthrough parameters.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Parameters As DrillthroughParameter()
C#
public abstract DrillthroughParameter[] Parameters {get;}

Property Value

An array of DrillthroughParameter objects representing the parameters for the drillthrough report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughAction Class
DrillthroughAction Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughAction Class : ReportName Property

Glossary Item Box

Gets the path of the drillthrough report. Paths may be absolute or relative.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ReportName As String
C#
public abstract string ReportName {get;}

Property Value

A System.String representing the path of the drillthrough report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughAction Class
DrillthroughAction Members


HyperLinkAction Class

[image]
ActiveReports 19 .NET Edition
HyperLinkAction Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : HyperLinkAction Class

Glossary Item Box

Represents a hyperlink action.

Object Model

HyperLinkAction Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class HyperLinkAction
   Inherits ActionBase
C#
public abstract class HyperLinkAction : ActionBase

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase
GrapeCity.ActiveReports.Extensibility.Rendering.Components.HyperLinkAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


HyperLinkAction Class Members

[image]
ActiveReports 19 .NET Edition
HyperLinkAction Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : HyperLinkAction Class

Glossary Item Box

The following tables list the members exposed by HyperLinkAction.

Public Properties

 | Name | Description
Public Property | Link | Gets the URL of this action hyperlink.
Top

See Also

Reference

HyperLinkAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


HyperLinkAction Class Properties

[image]
ActiveReports 19 .NET Edition
HyperLinkAction Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : HyperLinkAction Class

Glossary Item Box

For a list of all members of this type, see HyperLinkAction members.

Public Properties

 | Name | Description
Public Property | Link | Gets the URL of this action hyperlink.
Top

See Also

Reference

HyperLinkAction Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Link Property

[image]
ActiveReports 19 .NET Edition
Link Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > HyperLinkAction Class : Link Property

Glossary Item Box

Gets the URL of this action hyperlink.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Link As String
C#
public abstract string Link {get;}

Property Value

A System.String representing the URL of the hyperlink.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkAction Class
HyperLinkAction Members


ItemCollectionExtensions Class

[image]
ActiveReports 19 .NET Edition
ItemCollectionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class

Glossary Item Box

Utility methods on IItemCollection.

Object Model

ItemCollectionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ItemCollectionExtensions
C#
public static class ItemCollectionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ItemCollectionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ItemCollectionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ItemCollectionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class

Glossary Item Box

The following tables list the members exposed by ItemCollectionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Downcast<TI,TO> | Downcasts the items type within collection.
static (Shared in Visual Basic) | Empty<T> | Gets empty item collection.
static (Shared in Visual Basic) | ToItemCollection | Overloaded. Wraps the list to item collection.
static (Shared in Visual Basic) | ToLazyItemCollection<T> | Returns lazy memoizable item collection for specified sequence.
Top

See Also

Reference

ItemCollectionExtensions Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ItemCollectionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ItemCollectionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class

Glossary Item Box

For a list of all members of this type, see ItemCollectionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Downcast<TI,TO> | Downcasts the items type within collection.
static (Shared in Visual Basic) | Empty<T> | Gets empty item collection.
static (Shared in Visual Basic) | ToItemCollection | Overloaded. Wraps the list to item collection.
static (Shared in Visual Basic) | ToLazyItemCollection<T> | Returns lazy memoizable item collection for specified sequence.
Top

See Also

Reference

ItemCollectionExtensions Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Downcast<TI,TO> Method

TI
The type of the I.
TO
The type of the O.
[image]
ActiveReports 19 .NET Edition
Downcast<TI,TO> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : Downcast<TI,TO> Method

input
The input.

Glossary Item Box

Downcasts the items type within collection.

Syntax

Visual Basic (Declaration)
Public Shared Function Downcast
    (Of TI As TO,
     TO)( _
   ByVal input As IItemCollection(Of TI) _
) As IItemCollection(Of TO)
C#
public static IItemCollection<TO> Downcast<TI,TO>(
   IItemCollection<TI> input
)
where TI: TO

Parameters

input
The input.

Type Parameters

TI
The type of the I.
TO
The type of the O.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


Empty<T> Method

T
The items type.
[image]
ActiveReports 19 .NET Edition
Empty<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : Empty<T> Method

Glossary Item Box

Gets empty item collection.

Syntax

Visual Basic (Declaration)
Public Shared Function Empty(Of T)() As IItemCollection(Of T)
C#
public static IItemCollection<T> Empty<T>()

Type Parameters

T
The items type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


ToItemCollection Method

[image]
ActiveReports 19 .NET Edition
ToItemCollection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : ToItemCollection Method

Glossary Item Box

Wraps the list to item collection.

Overload List

Overload | Description
ToItemCollection<T>(IList<T>) | Wraps the list to item collection.
ToItemCollection<T>(IEnumerable<T>) | Wraps the list to item collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


ToItemCollection<T>(IList<T>) Method

T
The items type.
[image]
ActiveReports 19 .NET Edition
ToItemCollection<T>(IList<T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToItemCollection Method : ToItemCollection<T>(IList<T>) Method

list
The list.

Glossary Item Box

Wraps the list to item collection.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToItemCollection(Of T)( _
   ByVal list As IList(Of T) _
) As IItemCollection(Of T)
C#
public static IItemCollection<T> ToItemCollection<T>(
   IList<T> list
)

Parameters

list
The list.

Type Parameters

T
The items type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ToItemCollection<T>(IEnumerable<T>) Method

T
The items type.
[image]
ActiveReports 19 .NET Edition
ToItemCollection<T>(IEnumerable<T>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToItemCollection Method : ToItemCollection<T>(IEnumerable<T>) Method

seq
The seq.

Glossary Item Box

Wraps the list to item collection.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToItemCollection(Of T)( _
   ByVal seq As IEnumerable(Of T) _
) As IItemCollection(Of T)
C#
public static IItemCollection<T> ToItemCollection<T>(
   IEnumerable<T> seq
)

Parameters

seq
The seq.

Type Parameters

T
The items type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ToLazyItemCollection<T> Method

T
The items type.
[image]
ActiveReports 19 .NET Edition
ToLazyItemCollection<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : ToLazyItemCollection<T> Method

source
The sequence to memoize.

Glossary Item Box

Returns lazy memoizable item collection for specified sequence.

Syntax

Visual Basic (Declaration)
Public Shared Function ToLazyItemCollection(Of T)( _
   ByVal source As IEnumerable(Of T) _
) As IItemCollection(Of T)
C#
public static IItemCollection<T> ToLazyItemCollection<T>(
   IEnumerable<T> source
)

Parameters

source
The sequence to memoize.

Type Parameters

T
The items type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


PageBase Class

[image]
ActiveReports 19 .NET Edition
PageBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PageBase Class

Glossary Item Box

Represents report section page.

Object Model

PageBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PageBase
C#
public abstract class PageBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageBase Class Members

[image]
ActiveReports 19 .NET Edition
PageBase Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PageBase Class

Glossary Item Box

The following tables list the members exposed by PageBase.

Public Properties

 | Name | Description
Public Property | Body | Gets the body of the report section.
Public Property | BottomMargin | Gets the height of the bottom margin of the report.
Public Property | Hidden | Gets a value indicating whether the report section is hidden.
Public Property | LeftMargin | Gets the width of the left margin of the report.
Public Property | PageFooter | Gets a reference to the page footer section of the report.
Public Property | PageHeader | Gets a reference to the page header section of the report.
Public Property | PageHeight | Gets the report page height.
Public Property | PageWidth | Gets the report page width.
Public Property | Pagination | Gets the pagination mode of the report section.
Public Property | PaperOrientation | Gets the paper orientation of the report page.
Public Property | RightMargin | Gets the width of the right margin of the report.
Public Property | TopMargin | Gets the height of the top margin of the report.
Top

See Also

Reference

PageBase Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageBase Class Properties

[image]
ActiveReports 19 .NET Edition
PageBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PageBase Class

Glossary Item Box

For a list of all members of this type, see PageBase members.

Public Properties

 | Name | Description
Public Property | Body | Gets the body of the report section.
Public Property | BottomMargin | Gets the height of the bottom margin of the report.
Public Property | Hidden | Gets a value indicating whether the report section is hidden.
Public Property | LeftMargin | Gets the width of the left margin of the report.
Public Property | PageFooter | Gets a reference to the page footer section of the report.
Public Property | PageHeader | Gets a reference to the page header section of the report.
Public Property | PageHeight | Gets the report page height.
Public Property | PageWidth | Gets the report page width.
Public Property | Pagination | Gets the pagination mode of the report section.
Public Property | PaperOrientation | Gets the paper orientation of the report page.
Public Property | RightMargin | Gets the width of the right margin of the report.
Public Property | TopMargin | Gets the height of the top margin of the report.
Top

See Also

Reference

PageBase Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : Body Property

Glossary Item Box

Gets the body of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Body As IBody
C#
public abstract IBody Body {get;}

Property Value

An IBody representing the body of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : BottomMargin Property

Glossary Item Box

Gets the height of the bottom margin of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property BottomMargin As Length
C#
public abstract Length BottomMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the bottom margin of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : Hidden Property

Glossary Item Box

Gets a value indicating whether the report section is hidden.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Hidden As Boolean
C#
public abstract bool Hidden {get;}

Property Value

A System.Boolean value. true if the report section is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : LeftMargin Property

Glossary Item Box

Gets the width of the left margin of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property LeftMargin As Length
C#
public abstract Length LeftMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the left margin of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


PageFooter Property

[image]
ActiveReports 19 .NET Edition
PageFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : PageFooter Property

Glossary Item Box

Gets a reference to the page footer section of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PageFooter As IPageSection
C#
public abstract IPageSection PageFooter {get;}

Property Value

An IPageSection representing the page footer section of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


PageHeader Property

[image]
ActiveReports 19 .NET Edition
PageHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : PageHeader Property

Glossary Item Box

Gets a reference to the page header section of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PageHeader As IPageSection
C#
public abstract IPageSection PageHeader {get;}

Property Value

An IPageSection representing the page header section of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


PageHeight Property

[image]
ActiveReports 19 .NET Edition
PageHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : PageHeight Property

Glossary Item Box

Gets the report page height.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PageHeight As Length
C#
public abstract Length PageHeight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


PageWidth Property

[image]
ActiveReports 19 .NET Edition
PageWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : PageWidth Property

Glossary Item Box

Gets the report page width.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PageWidth As Length
C#
public abstract Length PageWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


Pagination Property

[image]
ActiveReports 19 .NET Edition
Pagination Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : Pagination Property

Glossary Item Box

Gets the pagination mode of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Pagination As Pagination
C#
public abstract Pagination Pagination {get;}

Property Value

A Pagination value representing the pagination mode of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


PaperOrientation Property

[image]
ActiveReports 19 .NET Edition
PaperOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : PaperOrientation Property

Glossary Item Box

Gets the paper orientation of the report page.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PaperOrientation As PaperOrientation
C#
public virtual PaperOrientation PaperOrientation {get;}

Property Value

A PaperOrientation value indicating whether the paper orientation is landscape or portrait.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : RightMargin Property

Glossary Item Box

Gets the width of the right margin of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property RightMargin As Length
C#
public abstract Length RightMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the right margin of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > PageBase Class : TopMargin Property

Glossary Item Box

Gets the height of the top margin of the report.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property TopMargin As Length
C#
public abstract Length TopMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the top margin of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBase Class
PageBase Members


ReportSectionBase Class

[image]
ActiveReports 19 .NET Edition
ReportSectionBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ReportSectionBase Class

Glossary Item Box

Represents a report section.

Object Model

ReportSectionBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportSectionBase
   Implements IDocumentMapItem
C#
public abstract class ReportSectionBase : IDocumentMapItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ReportSectionBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ReportSectionBase Class Members

[image]
ActiveReports 19 .NET Edition
ReportSectionBase Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ReportSectionBase Class

Glossary Item Box

The following tables list the members exposed by ReportSectionBase.

Public Properties

 | Name | Description
Public Property | Body | Gets the body of the report section.
Public Property | DataElementName | Gets the name to use for the element that represents this report section in a data rendering.
Public Property | DataElementOutput | Gets a value indicating whether the data of a report section appears in a data rendering.
Public Property | DisplayName | Gets the human-readable section name.
Public Property | Hidden | Gets a value indicating whether the report section is hidden.
Public Property | Label | Gets the label of the report section.
Public Property | Name | Gets the name of the report section.
Public Property | Page | Gets the page descriptor of the report section.
Public Property | Pages | Gets the page descriptors of the report section.
Public Property | Width | Gets the width of the report section.
Top

See Also

Reference

ReportSectionBase Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ReportSectionBase Class Properties

[image]
ActiveReports 19 .NET Edition
ReportSectionBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ReportSectionBase Class

Glossary Item Box

For a list of all members of this type, see ReportSectionBase members.

Public Properties

 | Name | Description
Public Property | Body | Gets the body of the report section.
Public Property | DataElementName | Gets the name to use for the element that represents this report section in a data rendering.
Public Property | DataElementOutput | Gets a value indicating whether the data of a report section appears in a data rendering.
Public Property | DisplayName | Gets the human-readable section name.
Public Property | Hidden | Gets a value indicating whether the report section is hidden.
Public Property | Label | Gets the label of the report section.
Public Property | Name | Gets the name of the report section.
Public Property | Page | Gets the page descriptor of the report section.
Public Property | Pages | Gets the page descriptors of the report section.
Public Property | Width | Gets the width of the report section.
Top

See Also

Reference

ReportSectionBase Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Body Property

Glossary Item Box

Gets the body of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Body As IBody
C#
public abstract IBody Body {get;}

Property Value

An IBody representing the body of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : DataElementName Property

Glossary Item Box

Gets the name to use for the element that represents this report section in a data rendering.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataElementName As String
C#
public abstract string DataElementName {get;}

Property Value

A System.String representing the data element name of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : DataElementOutput Property

Glossary Item Box

Gets a value indicating whether the data of a report section appears in a data rendering.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataElementOutput As DataElementOutput
C#
public abstract DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value specifying the data element output of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


DisplayName Property

[image]
ActiveReports 19 .NET Edition
DisplayName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : DisplayName Property

Glossary Item Box

Gets the human-readable section name.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property DisplayName As String
C#
public abstract string DisplayName {get;}

Property Value

A System.String representing the display name of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Hidden Property

Glossary Item Box

Gets a value indicating whether the report section is hidden.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Hidden As Boolean
C#
public abstract bool Hidden {get;}

Property Value

true if the report section is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Label Property

Glossary Item Box

Gets the label of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Label As String
C#
public abstract string Label {get;}

Property Value

A System.String representing the label of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Name Property

Glossary Item Box

Gets the name of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String
C#
public abstract string Name {get;}

Property Value

A System.String representing the name of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Page Property

[image]
ActiveReports 19 .NET Edition
Page Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Page Property

Glossary Item Box

Gets the page descriptor of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Page As PageBase
C#
public abstract PageBase Page {get;}

Property Value

A PageBase representing the page descriptor of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Pages Property

Glossary Item Box

Gets the page descriptors of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Pages As IList(Of PageBase)
C#
public abstract IList<PageBase> Pages {get;}

Property Value

A list of PageBase representing the pages of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ReportSectionBase Class : Width Property

Glossary Item Box

Gets the width of the report section.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Width As Length
C#
public abstract Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the report section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


SlicerActionValue Class

[image]
ActiveReports 19 .NET Edition
SlicerActionValue Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValue Class

Glossary Item Box

Represents single slicer action.

Object Model

SlicerActionValue Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SlicerActionValue
C#
public sealed class SlicerActionValue

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.SlicerActionValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValue Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SlicerActionValue Class Members

[image]
ActiveReports 19 .NET Edition
SlicerActionValue Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValue Class

Glossary Item Box

The following tables list the members exposed by SlicerActionValue.

Public Properties

 | Name | Description
Public Property | Name | The name of slicer to be affected.
Public Property | Type | Slice action type.
Public Property | Value | Optional value of the slicer.
Top

See Also

Reference

SlicerActionValue Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SlicerActionValue Class Properties

[image]
ActiveReports 19 .NET Edition
SlicerActionValue Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValue Class

Glossary Item Box

For a list of all members of this type, see SlicerActionValue members.

Public Properties

 | Name | Description
Public Property | Name | The name of slicer to be affected.
Public Property | Type | Slice action type.
Public Property | Value | Optional value of the slicer.
Top

See Also

Reference

SlicerActionValue Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > SlicerActionValue Class : Name Property

Glossary Item Box

The name of slicer to be affected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValue Class
SlicerActionValue Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > SlicerActionValue Class : Type Property

Glossary Item Box

Slice action type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As SliceActionType
C#
public SliceActionType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValue Class
SlicerActionValue Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > SlicerActionValue Class : Value Property

Glossary Item Box

Optional value of the slicer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValue Class
SlicerActionValue Members


SlicerActionValueExtension Class

[image]
ActiveReports 19 .NET Edition
SlicerActionValueExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValueExtension Class

Glossary Item Box

Contains methods for work with SliceActionValue

Object Model

SlicerActionValueExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SlicerActionValueExtension
C#
public static class SlicerActionValueExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.SlicerActionValueExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValueExtension Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SlicerActionValueExtension Class Members

[image]
ActiveReports 19 .NET Edition
SlicerActionValueExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValueExtension Class

Glossary Item Box

The following tables list the members exposed by SlicerActionValueExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenerateActionKey |
Top

See Also

Reference

SlicerActionValueExtension Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SlicerActionValueExtension Class Methods

[image]
ActiveReports 19 .NET Edition
SlicerActionValueExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SlicerActionValueExtension Class

Glossary Item Box

For a list of all members of this type, see SlicerActionValueExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenerateActionKey |
Top

See Also

Reference

SlicerActionValueExtension Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GenerateActionKey Method

[image]
ActiveReports 19 .NET Edition
GenerateActionKey Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > SlicerActionValueExtension Class : GenerateActionKey Method

x

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GenerateActionKey( _
   ByVal x As SlicerActionValue _
) As ActionKey
C#
public static ActionKey GenerateActionKey(
   SlicerActionValue x
)

Parameters

x

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicerActionValueExtension Class
SlicerActionValueExtension Members


ActionType Enumeration

[image]
ActiveReports 19 .NET Edition
ActionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ActionType Enumeration

Glossary Item Box

Specifies possible action types.

Syntax

Visual Basic (Declaration)
Public Enum ActionType
   Inherits System.Enum
C#
public enum ActionType : System.Enum

Members

Member | Description
ApplyParameters | Apply parameters action.
BookmarkLink | Bookmark link.
DrillThrough | Drill through.
HyperLink | Hyperlink.
None | No action.
Slice | Slice data action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


AntiAliasing Enumeration

[image]
ActiveReports 19 .NET Edition
AntiAliasing Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : AntiAliasing Enumeration

Glossary Item Box

Specifies the quality of the anti-aliasing .

Syntax

Visual Basic (Declaration)
Public Enum AntiAliasing
   Inherits System.Enum
C#
public enum AntiAliasing : System.Enum

Members

Member | Description
All | Anti-aliasing is applied to both text and graphics.
Graphics | Anti-aliasing is applied to graphics.
None | Anti-aliasing is not applied.
Text | Anti-aliasing is applied to text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.AntiAliasing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ApplyParameterType Enumeration

[image]
ActiveReports 19 .NET Edition
ApplyParameterType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ApplyParameterType Enumeration

Glossary Item Box

Specifies the apply parameter action types.

Syntax

Visual Basic (Declaration)
Public Enum ApplyParameterType
   Inherits System.Enum
C#
public enum ApplyParameterType : System.Enum

Members

Member | Description
Reset | Resets the parameter to its initial state (default value).
Set | Sets a specific value to the parameter.
Toggle | Adds or removes a specific value to the values collection of the multi-value parameter.

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ApplyParameterType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeType Enumeration

[image]
ActiveReports 19 .NET Edition
ChangeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeType Enumeration

Glossary Item Box

Specifies the type of change resulting from Process() or an event handler for a custom report item.

Syntax

Visual Basic (Declaration)
Public Enum ChangeType
   Inherits System.Enum
C#
public enum ChangeType : System.Enum

Members

Member | Description
Action | The user event should result in an action (such as redirecting to a URL) specified in ReportItem.Action
None | Neither the RenderItem nor the underlying data source changed.
Relayout | Properties of the CustomReportItem changed, requiring the report to be re-layout again.
Repaint | The RenderItem changed, requiring the report to be rendered again
Reprocess | Data Map must be re-created (for example, re-sort)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ChangeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Characteristics Enumeration

[image]
ActiveReports 19 .NET Edition
Characteristics Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : Characteristics Enumeration

Glossary Item Box

Specifies characteristics that may be held by a IReportItem.

Syntax

Visual Basic (Declaration)
Public Enum Characteristics
   Inherits System.Enum
C#
public enum Characteristics : System.Enum

Members

Member | Description
HasDelayedContent | IReportItem has a value that may not be known when initially rendered.
HasDelayedVisibility | The visibility of the ITextBox may not be known when initially rendered.
HasDocumentMapPath | True if the value expression of the text box contains document map references.
IsCumulative | The IReportItem contains cumulative total expression.
None | IReportItem has none of these characteristics.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Characteristics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementOutput Enumeration

[image]
ActiveReports 19 .NET Edition
DataElementOutput Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DataElementOutput Enumeration

Glossary Item Box

Specifies how an item should appear in data output.

Syntax

Visual Basic (Declaration)
Public Enum DataElementOutput
   Inherits System.Enum
C#
public enum DataElementOutput : System.Enum

Members

Member | Description
ContentsOnly | Indicates the item should not appear in the (e.g. XML), but its contents should be rendered as if they were in this item’s container. Only applies to Lists.
NoOutput | Indicates the item should not appear in the output.
Output | Indicates the item should appear in the output

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementStyle Enumeration

[image]
ActiveReports 19 .NET Edition
DataElementStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DataElementStyle Enumeration

Glossary Item Box

Specifies whether an item should render as an element or attribute.

Syntax

Visual Basic (Declaration)
Public Enum DataElementStyle
   Inherits System.Enum
C#
public enum DataElementStyle : System.Enum

Members

Member | Description
AttributeNormal | Render as an attribute.
ElementNormal | Render as an element.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


InteractivityStates Enumeration

[image]
ActiveReports 19 .NET Edition
InteractivityStates Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : InteractivityStates Enumeration

Glossary Item Box

Specifies interactivity state to control area appearance.

Syntax

Visual Basic (Declaration)
Public Enum InteractivityStates
   Inherits System.Enum
C#
public enum InteractivityStates : System.Enum

Members

Member | Description
StateDown | Mouse button pressed/held inside the area
StateNormal | Default state
StateRollover | User moved cursor into area without pressing mose button

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.InteractivityStates

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


KeepWithGroup Enumeration

[image]
ActiveReports 19 .NET Edition
KeepWithGroup Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : KeepWithGroup Enumeration

Glossary Item Box

Specifies whether to keep a static member on the same page as the previous or next visible dynamic member.

Syntax

Visual Basic (Declaration)
Public Enum KeepWithGroup
   Inherits System.Enum
C#
public enum KeepWithGroup : System.Enum

Members

Member | Description
After | Keep the static member on the same page as the next visible dynamic member.
Before | Keep the static member on the same page as the previous visible dynamic member.
None | Do not attempt to keep the static member on the same page as the previous or next visible dynamic member.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.KeepWithGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


LicenseLevel Enumeration

[image]
ActiveReports 19 .NET Edition
LicenseLevel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : LicenseLevel Enumeration

Glossary Item Box

Specifies the different levels of licenses available.

Syntax

Visual Basic (Declaration)
Public Enum LicenseLevel
   Inherits System.Enum
C#
public enum LicenseLevel : System.Enum

Members

Member | Description
None | None
Professional | Professional
ProfessionalTrial | Professional trial
Standard | Standard
StandardTrial | Standard trial

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.LicenseLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


MetadataType Enumeration

[image]
ActiveReports 19 .NET Edition
MetadataType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : MetadataType Enumeration

Glossary Item Box

Specifies metadata content type

Syntax

Visual Basic (Declaration)
Public Enum MetadataType
   Inherits System.Enum
C#
public enum MetadataType : System.Enum

Members

Member | Description
MetaBlob | Specifies that content is opaque binary data.
MetaText | Specifies that content is a string.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.MetadataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


MouseButton Enumeration

[image]
ActiveReports 19 .NET Edition
MouseButton Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : MouseButton Enumeration

Glossary Item Box

Specifies which mouse button was clicked.

Syntax

Visual Basic (Declaration)
Public Enum MouseButton
   Inherits System.Enum
C#
public enum MouseButton : System.Enum

Members

Member | Description
Center | The center mouse button was clicked.
Left | The left mouse button was clicked.
Right | The right mouse button was clicked.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.MouseButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageBreakLocation Enumeration

[image]
ActiveReports 19 .NET Edition
PageBreakLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PageBreakLocation Enumeration

Glossary Item Box

Specifies where a page break should occur for a Group, DataRegion or Rectangle.

Syntax

Visual Basic (Declaration)
Public Enum PageBreakLocation
   Inherits System.Enum
C#
public enum PageBreakLocation : System.Enum

Members

Member | Description
Between | Specifies that there must be a page break in between each Group.
End | Specifies that there must be a page break after a ReportItem or each Group.
None | Specifies that there is no page break.
Start | Specifies that there must be a page break before a ReportItem or each Group.
StartAndEnd | Specifies that there must be a page break both before and after a ReportItem or each Group.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Pagination Enumeration

[image]
ActiveReports 19 .NET Edition
Pagination Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : Pagination Enumeration

Glossary Item Box

Specifies the report pagination options.

Syntax

Visual Basic (Declaration)
Public Enum Pagination
   Inherits System.Enum
C#
public enum Pagination : System.Enum

Members

Member | Description
AutoHeight | Ignore the IReport.PageHeight property and automatically increase the height of the report.
Standard | Simple pagination based on IReport.PageHeight property

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Pagination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PaperOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
PaperOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PaperOrientation Enumeration

Glossary Item Box

Specifies the paper orientation of the report.

Syntax

Visual Basic (Declaration)
Public Enum PaperOrientation
   Inherits System.Enum
C#
public enum PaperOrientation : System.Enum

Members

Member | Description
Landscape | Orientation will be landscape.
Portrait | Orientation will be portrait.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.PaperOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Position Enumeration

[image]
ActiveReports 19 .NET Edition
Position Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : Position Enumeration

Glossary Item Box

Specifies the position enumeration.

Syntax

Visual Basic (Declaration)
Public Enum Position
   Inherits System.Enum
C#
public enum Position : System.Enum

Members

Member | Description
Auto | The automatic position.
Bottom | The bottom position.
BottomLeft | The bottom left position.
BottomRight | The bottom right position.
Center | The center position.
Left | The left position.
Right | The right position.
Top | The top position.
TopLeft | The top left position.
TopRight | The top right position.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SliceActionType Enumeration

[image]
ActiveReports 19 .NET Edition
SliceActionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SliceActionType Enumeration

Glossary Item Box

Slice action types.

Syntax

Visual Basic (Declaration)
Public Enum SliceActionType
   Inherits System.Enum
C#
public enum SliceActionType : System.Enum

Members

Member | Description
Reset | Resets the slicer to its initial state.
Set | Set specific value to the slicer.
Toggle | Add or remove specific value to the values collection of the multivalue slicer.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.SliceActionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SortState Enumeration

[image]
ActiveReports 19 .NET Edition
SortState Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : SortState Enumeration

Glossary Item Box

Represents state of interactive sorting.

Syntax

Visual Basic (Declaration)
Public Enum SortState
   Inherits System.Enum
C#
public enum SortState : System.Enum

Members

Member | Description
Ascending | Sorted by ascending.
Descending | Sorted by descending.
None | Not sorted.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.SortState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabType Enumeration

[image]
ActiveReports 19 .NET Edition
TabType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabType Enumeration

Glossary Item Box

Specifies tab stop types.

Syntax

Visual Basic (Declaration)
Public Enum TabType
   Inherits System.Enum
C#
public enum TabType : System.Enum

Members

Member | Description
Center | The center tab stop.
Left | The left tab stop.
Right | The right tab stop.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TabType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TextAntiAliasingQuality Enumeration

[image]
ActiveReports 19 .NET Edition
TextAntiAliasingQuality Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TextAntiAliasingQuality Enumeration

Glossary Item Box

Specifies the quality of the anti-aliasing to be used with the TextAntiAliasingQuality property.

Syntax

Visual Basic (Declaration)
Public Enum TextAntiAliasingQuality
   Inherits System.Enum
C#
public enum TextAntiAliasingQuality : System.Enum

Members

Member | Description
High | The high quality anti-aliasing.
Normal | The normal quality anti-aliasing.
SystemDefault | The quality according to system default anti-aliasing.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TextAntiAliasingQuality

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TooltipType Enumeration

[image]
ActiveReports 19 .NET Edition
TooltipType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TooltipType Enumeration

Glossary Item Box

Specifies how tooltip should be displayed for this area

Syntax

Visual Basic (Declaration)
Public Enum TooltipType
   Inherits System.Enum
C#
public enum TooltipType : System.Enum

Members

Member | Description
Balloon | Dispaly TooltipText as balloon
None | Don't dispaly a tooltip
Tooltip | Display TooltipText as a tooltip

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TooltipType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Structure

[image]
ActiveReports 19 .NET Edition
ChangeResult Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure

Glossary Item Box

Represents the resulting change for an interactivity action processed by IReportItem.

Object Model

ChangeResult Structure

Syntax

Visual Basic (Declaration)
Public Structure ChangeResult
   Inherits System.ValueType
C#
public struct ChangeResult : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ChangeResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Structure Members

[image]
ActiveReports 19 .NET Edition
ChangeResult Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure

Glossary Item Box

The following tables list the members exposed by ChangeResult.

Public Constructors

 | Name | Description
Public Constructor | ChangeResult Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets the IAction definition, if any, that should be performed. May be null.
Public Property | ChangeType | Gets the type of change resulting from Process() or an event handler for a custom report item.
static (Shared in Visual Basic) | None | Creates a ChangeResult corresponding to no action.
Top

See Also

Reference

ChangeResult Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Constructor

[image]
ActiveReports 19 .NET Edition
ChangeResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : ChangeResult Constructor

Glossary Item Box

Overload List

Overload | Description
ChangeResult Constructor(ChangeType) | Initializes a new instance of the ChangeResult struct with the specified ChangeType and no-op IAction.
ChangeResult Constructor(IAction,ChangeType) | Initializes a new instance of the ChangeResult struct with the specified ChangeType and IAction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members


ChangeResult Constructor(ChangeType)

[image]
ActiveReports 19 .NET Edition
ChangeResult Constructor(ChangeType)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure > ChangeResult Constructor : ChangeResult Constructor(ChangeType)

changeType
The type of change resulting from the action.

Glossary Item Box

Initializes a new instance of the ChangeResult struct with the specified ChangeType and no-op IAction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal changeType As ChangeType _
)
C#
public ChangeResult(
   ChangeType changeType
)

Parameters

changeType
The type of change resulting from the action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members
Overload List


ChangeResult Constructor(IAction,ChangeType)

[image]
ActiveReports 19 .NET Edition
ChangeResult Constructor(IAction,ChangeType)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure > ChangeResult Constructor : ChangeResult Constructor(IAction,ChangeType)

action
The action to be performed. May be null.
changeType
The type of change resulting from the action.

Glossary Item Box

Initializes a new instance of the ChangeResult struct with the specified ChangeType and IAction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As IAction, _
   ByVal changeType As ChangeType _
)
C#
public ChangeResult(
   IAction action,
   ChangeType changeType
)

Parameters

action
The action to be performed. May be null.
changeType
The type of change resulting from the action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members
Overload List


ChangeResult Structure Properties

[image]
ActiveReports 19 .NET Edition
ChangeResult Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure

Glossary Item Box

For a list of all members of this type, see ChangeResult members.

Public Properties

 | Name | Description
Public Property | Action | Gets the IAction definition, if any, that should be performed. May be null.
Public Property | ChangeType | Gets the type of change resulting from Process() or an event handler for a custom report item.
static (Shared in Visual Basic) | None | Creates a ChangeResult corresponding to no action.
Top

See Also

Reference

ChangeResult Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : Action Property

Glossary Item Box

Gets the IAction definition, if any, that should be performed. May be null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As IAction
C#
public IAction Action {get;}

Property Value

An IAction representing the action to be performed, or null if no action is defined.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members


ChangeType Property

[image]
ActiveReports 19 .NET Edition
ChangeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : ChangeType Property

Glossary Item Box

Gets the type of change resulting from Process() or an event handler for a custom report item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChangeType As ChangeType
C#
public ChangeType ChangeType {get;}

Property Value

A ChangeType value representing the type of change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members


None Property

[image]
ActiveReports 19 .NET Edition
None Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : None Property

Glossary Item Box

Creates a ChangeResult corresponding to no action.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property None As ChangeResult
C#
public static ChangeResult None {get;}

Property Value

A ChangeResult representing no action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeResult Structure
ChangeResult Members


DrillthroughParameter Structure

[image]
ActiveReports 19 .NET Edition
DrillthroughParameter Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure

Glossary Item Box

Represents a parameter for a drillthrough action.

Object Model

DrillthroughParameter Structure

Syntax

Visual Basic (Declaration)
Public Structure DrillthroughParameter
   Inherits System.ValueType
C#
public struct DrillthroughParameter : System.ValueType

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DrillthroughParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughParameter Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughParameter Structure Members

[image]
ActiveReports 19 .NET Edition
DrillthroughParameter Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure

Glossary Item Box

The following tables list the members exposed by DrillthroughParameter.

Public Constructors

 | Name | Description
Public Constructor | DrillthroughParameter Constructor | Initializes a new instance of the DrillthroughParameter struct.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the parameter.
Public Property | Omit | Gets a value indicating whether the parameter should be skipped.
Public Property | Value | Gets the value of the parameter.
Top

See Also

Reference

DrillthroughParameter Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughParameter Constructor

[image]
ActiveReports 19 .NET Edition
DrillthroughParameter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : DrillthroughParameter Constructor

name
The name of the parameter.
value
The value of the parameter.
omit
A value indicating whether the parameter should be skipped.

Glossary Item Box

Initializes a new instance of the DrillthroughParameter struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object, _
   ByVal omit As Boolean _
)
C#
public DrillthroughParameter(
   string name,
   object value,
   bool omit
)

Parameters

name
The name of the parameter.
value
The value of the parameter.
omit
A value indicating whether the parameter should be skipped.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


DrillthroughParameter Structure Properties

[image]
ActiveReports 19 .NET Edition
DrillthroughParameter Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure

Glossary Item Box

For a list of all members of this type, see DrillthroughParameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the parameter.
Public Property | Omit | Gets a value indicating whether the parameter should be skipped.
Public Property | Value | Gets the value of the parameter.
Top

See Also

Reference

DrillthroughParameter Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Name Property

Glossary Item Box

Gets the name of the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A System.String representing the name of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


Omit Property

[image]
ActiveReports 19 .NET Edition
Omit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Omit Property

Glossary Item Box

Gets a value indicating whether the parameter should be skipped.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Omit As Boolean
C#
public bool Omit {get;}

Property Value

true if the parameter should be skipped; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Value Property

Glossary Item Box

Gets the value of the parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

An System.Object representing the value of the parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


TabStop Structure

[image]
ActiveReports 19 .NET Edition
TabStop Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure

Glossary Item Box

Represents the tab stop.

Object Model

TabStop Structure

Syntax

Visual Basic (Declaration)
Public Structure TabStop
   Inherits System.ValueType
C#
public struct TabStop : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TabStop

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStop Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabStop Structure Members

[image]
ActiveReports 19 .NET Edition
TabStop Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure

Glossary Item Box

The following tables list the members exposed by TabStop.

Public Constructors

 | Name | Description
Public Constructor | TabStop Constructor | Initializes a new instance of the TabStop struct.
Top

Public Properties

 | Name | Description
Public Property | LeadingChar | Gets the character used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Gets the position of the current tab stop in TWIPs.
Public Property | Type | Gets the type of the tab stop.
Top

See Also

Reference

TabStop Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabStop Constructor

[image]
ActiveReports 19 .NET Edition
TabStop Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : TabStop Constructor

position
The position of the tab stop in TWIPs.
leadingChar
The character used to fill the space created by the tab stop.
type
The type of the tab stop.

Glossary Item Box

Initializes a new instance of the TabStop struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Integer, _
   ByVal leadingChar As String, _
   ByVal type As TabType _
)
C#
public TabStop(
   int position,
   string leadingChar,
   TabType type
)

Parameters

position
The position of the tab stop in TWIPs.
leadingChar
The character used to fill the space created by the tab stop.
type
The type of the tab stop.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStop Structure
TabStop Members


TabStop Structure Properties

[image]
ActiveReports 19 .NET Edition
TabStop Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure

Glossary Item Box

For a list of all members of this type, see TabStop members.

Public Properties

 | Name | Description
Public Property | LeadingChar | Gets the character used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Gets the position of the current tab stop in TWIPs.
Public Property | Type | Gets the type of the tab stop.
Top

See Also

Reference

TabStop Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : LeadingChar Property

Glossary Item Box

Gets the character used to fill in the space created by a tab which ends at this tab stop.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeadingChar As String
C#
public string LeadingChar {get;}

Property Value

The leading character as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStop Structure
TabStop Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : Position Property

Glossary Item Box

Gets the position of the current tab stop in TWIPs.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
C#
public int Position {get;}

Property Value

The position of the tab stop in TWIPs as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStop Structure
TabStop Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : Type Property

Glossary Item Box

Gets the type of the tab stop.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As TabType
C#
public TabType Type {get;}

Property Value

The type of the tab stop as a TabType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TabStop Structure
TabStop Members


IAccessibleItem Interface

[image]
ActiveReports 19 .NET Edition
IAccessibleItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAccessibleItem Interface

Glossary Item Box

Represents an interface for report items with an accessible description.

Syntax

Visual Basic (Declaration)
Public Interface IAccessibleItem
C#
public interface IAccessibleItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAccessibleItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAccessibleItem Interface Members

[image]
ActiveReports 19 .NET Edition
IAccessibleItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAccessibleItem Interface

Glossary Item Box

The following tables list the members exposed by IAccessibleItem.

Public Properties

 | Name | Description
Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Top

See Also

Reference

IAccessibleItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAccessibleItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IAccessibleItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAccessibleItem Interface

Glossary Item Box

For a list of all members of this type, see IAccessibleItem members.

Public Properties

 | Name | Description
Property | AccessibleDescription | Gets the description of the control used by accessibility client applications.
Top

See Also

Reference

IAccessibleItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


AccessibleDescription Property

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAccessibleItem Interface : AccessibleDescription Property

Glossary Item Box

Gets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
ReadOnly Property AccessibleDescription As String
C#
string AccessibleDescription {get;}

Property Value

A System.String representing the accessible description of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAccessibleItem Interface
IAccessibleItem Members


IAction Interface

[image]
ActiveReports 19 .NET Edition
IAction Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface

Glossary Item Box

Represents an interface for action items.

Syntax

Visual Basic (Declaration)
Public Interface IAction
C#
public interface IAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAction Interface Members

[image]
ActiveReports 19 .NET Edition
IAction Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface

Glossary Item Box

The following tables list the members exposed by IAction.

Public Properties

 | Name | Description
Property | ActionType | Gets the action type.
Property | BookmarkLink | Gets the bookmark within the report to go to when the report item is clicked on.
Property | Drillthrough | Gets the definition of how the drillthrough report should be executed.
Property | HyperLink | Gets the URL of this action hyperlink.
Top

See Also

Reference

IAction Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAction Interface Properties

[image]
ActiveReports 19 .NET Edition
IAction Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface

Glossary Item Box

For a list of all members of this type, see IAction members.

Public Properties

 | Name | Description
Property | ActionType | Gets the action type.
Property | BookmarkLink | Gets the bookmark within the report to go to when the report item is clicked on.
Property | Drillthrough | Gets the definition of how the drillthrough report should be executed.
Property | HyperLink | Gets the URL of this action hyperlink.
Top

See Also

Reference

IAction Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ActionType Property

[image]
ActiveReports 19 .NET Edition
ActionType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : ActionType Property

Glossary Item Box

Gets the action type.

Syntax

Visual Basic (Declaration)
ReadOnly Property ActionType As ActionType
C#
ActionType ActionType {get;}

Property Value

An ActionType enum value representing the type of action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAction Interface
IAction Members


BookmarkLink Property

[image]
ActiveReports 19 .NET Edition
BookmarkLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : BookmarkLink Property

Glossary Item Box

Gets the bookmark within the report to go to when the report item is clicked on.

Syntax

Visual Basic (Declaration)
ReadOnly Property BookmarkLink As String
C#
string BookmarkLink {get;}

Property Value

A System.String representing the bookmark link.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAction Interface
IAction Members


Drillthrough Property

[image]
ActiveReports 19 .NET Edition
Drillthrough Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : Drillthrough Property

Glossary Item Box

Gets the definition of how the drillthrough report should be executed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Drillthrough As IDrillthrough
C#
IDrillthrough Drillthrough {get;}

Property Value

An IDrillthrough object representing the drillthrough report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAction Interface
IAction Members


HyperLink Property

[image]
ActiveReports 19 .NET Edition
HyperLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : HyperLink Property

Glossary Item Box

Gets the URL of this action hyperlink.

Syntax

Visual Basic (Declaration)
ReadOnly Property HyperLink As String
C#
string HyperLink {get;}

Property Value

A System.String representing the hyperlink URL.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAction Interface
IAction Members


IActionableItem Interface

[image]
ActiveReports 19 .NET Edition
IActionableItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IActionableItem Interface

Glossary Item Box

Represents an interface for specifying the item action.

Syntax

Visual Basic (Declaration)
Public Interface IActionableItem
C#
public interface IActionableItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionableItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IActionableItem Interface Members

[image]
ActiveReports 19 .NET Edition
IActionableItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IActionableItem Interface

Glossary Item Box

The following tables list the members exposed by IActionableItem.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the item.
Top

See Also

Reference

IActionableItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IActionableItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IActionableItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IActionableItem Interface

Glossary Item Box

For a list of all members of this type, see IActionableItem members.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the item.
Top

See Also

Reference

IActionableItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IActionableItem Interface : Action Property

Glossary Item Box

Gets the action associated with the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

The action associated with the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionableItem Interface
IActionableItem Members


IBand Interface

[image]
ActiveReports 19 .NET Edition
IBand Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

Glossary Item Box

Represents the interface for the Band of a BandedList.

Syntax

Visual Basic (Declaration)
Public Interface IBand
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
C#
public interface IBand : IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBand Interface Members

[image]
ActiveReports 19 .NET Edition
IBand Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

Glossary Item Box

The following tables list the members exposed by IBand.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether this band can grow in the vertical direction.
Property | CanShrink | Gets a value indicating whether this band can shrink in the vertical direction.
Property | EndSection | Gets the value indicating where the layout should continue.
Property | KeepTogether | Gets a value indicating whether the band should try to keep the content together.
Property | PageBreak | Gets the page breaking options for this band.
Top

See Also

Reference

IBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBand Interface Properties

[image]
ActiveReports 19 .NET Edition
IBand Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

Glossary Item Box

For a list of all members of this type, see IBand members.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether this band can grow in the vertical direction.
Property | CanShrink | Gets a value indicating whether this band can shrink in the vertical direction.
Property | EndSection | Gets the value indicating where the layout should continue.
Property | KeepTogether | Gets a value indicating whether the band should try to keep the content together.
Property | PageBreak | Gets the page breaking options for this band.
Top

See Also

Reference

IBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : CanGrow Property

Glossary Item Box

Gets a value indicating whether this band can grow in the vertical direction.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanGrow As Boolean
C#
bool CanGrow {get;}

Property Value

A System.Boolean value. true if this band can grow; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Interface
IBand Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : CanShrink Property

Glossary Item Box

Gets a value indicating whether this band can shrink in the vertical direction.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanShrink As Boolean
C#
bool CanShrink {get;}

Property Value

A System.Boolean value. true if this band can shrink; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Interface
IBand Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : EndSection Property

Glossary Item Box

Gets the value indicating where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An EndSection value specifying the layout continuation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Interface
IBand Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the band should try to keep the content together.

Syntax

Visual Basic (Declaration)
Shadows ReadOnly Property KeepTogether As Boolean
C#
new bool KeepTogether {get;}

Property Value

A System.Boolean value. true if the band should keep the content together; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Interface
IBand Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options for this band.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

A PageBreakLocation value specifying the page break location.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBand Interface
IBand Members


IBandedList Interface

[image]
ActiveReports 19 .NET Edition
IBandedList Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

Glossary Item Box

Represents an interface for a banded list report item.

Syntax

Visual Basic (Declaration)
Public Interface IBandedList
   Inherits IDocumentMapItem, IFixedSizeItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface IBandedList : IDocumentMapItem, IFixedSizeItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedList Interface Members

[image]
ActiveReports 19 .NET Edition
IBandedList Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

Glossary Item Box

The following tables list the members exposed by IBandedList.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | Details | Gets the details band collection (if any) for this GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.
Property | Footer | Gets the footer for this banded list.
Property | Groups | Gets a collection of groups for this instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.
Property | Header | Gets the header for this banded list.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | PreventOrphanedHeader | Gets a value indicating whether the orphaned header is displayed on the page.
Top

See Also

Reference

IBandedList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedList Interface Properties

[image]
ActiveReports 19 .NET Edition
IBandedList Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

Glossary Item Box

For a list of all members of this type, see IBandedList members.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | Details | Gets the details band collection (if any) for this GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.
Property | Footer | Gets the footer for this banded list.
Property | Groups | Gets a collection of groups for this instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.
Property | Header | Gets the header for this banded list.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | PreventOrphanedHeader | Gets a value indicating whether the orphaned header is displayed on the page.
Top

See Also

Reference

IBandedList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : ConsumeWhiteSpace Property

Glossary Item Box

Gets a value indicating whether all whitespace in the band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeWhiteSpace As Boolean
C#
bool ConsumeWhiteSpace {get;}

Property Value

A System.Boolean value. true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Details Property

Glossary Item Box

Gets the details band collection (if any) for this GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.

Syntax

Visual Basic (Declaration)
ReadOnly Property Details As IItemCollection(Of IBand)
C#
IItemCollection<IBand> Details {get;}

Property Value

An IItemCollection<T> representing the details band collection.

Remarks

Details collection will be empty if there are Groups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Footer Property

Glossary Item Box

Gets the footer for this banded list.

Syntax

Visual Basic (Declaration)
ReadOnly Property Footer As IFooterBand
C#
IFooterBand Footer {get;}

Property Value

An IFooterBand specifying the report footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


Groups Property

[image]
ActiveReports 19 .NET Edition
Groups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Groups Property

Glossary Item Box

Gets a collection of groups for this instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.

Syntax

Visual Basic (Declaration)
ReadOnly Property Groups As IItemCollection(Of IBandedListGroup)
C#
IItemCollection<IBandedListGroup> Groups {get;}

Property Value

An IItemCollection<T> representing the collection of groups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Header Property

Glossary Item Box

Gets the header for this banded list.

Syntax

Visual Basic (Declaration)
ReadOnly Property Header As IHeaderBand
C#
IHeaderBand Header {get;}

Property Value

An IHeaderBand specifying the report header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : PreventOrphanedFooter Property

Glossary Item Box

Gets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedFooter As Boolean
C#
bool PreventOrphanedFooter {get;}

Property Value

A System.Boolean value. true if the orphaned footer is prevented; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : PreventOrphanedHeader Property

Glossary Item Box

Gets a value indicating whether the orphaned header is displayed on the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedHeader As Boolean
C#
bool PreventOrphanedHeader {get;}

Property Value

A System.Boolean value. true if the orphaned header is prevented; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedList Interface
IBandedList Members


IBody Interface

[image]
ActiveReports 19 .NET Edition
IBody Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface

Glossary Item Box

Represents the body element for a report. This is the parent container for all report items in the report.

Syntax

Visual Basic (Declaration)
Public Interface IBody
   Inherits IReportItemContainer
C#
public interface IBody : IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBody Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBody Interface Members

[image]
ActiveReports 19 .NET Edition
IBody Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface

Glossary Item Box

The following tables list the members exposed by IBody.

Public Properties

 | Name | Description
Property | Columns | Gets the number of columns inside the report's body.
Property | ColumnSpacing | Gets the amount of space in between columns when a report contains multiple columns.
Property | Height | Gets the height of the report's body.
Property | Style | Gets the defined style information for the report's body.
Top

See Also

Reference

IBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBody Interface Properties

[image]
ActiveReports 19 .NET Edition
IBody Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface

Glossary Item Box

For a list of all members of this type, see IBody members.

Public Properties

 | Name | Description
Property | Columns | Gets the number of columns inside the report's body.
Property | ColumnSpacing | Gets the amount of space in between columns when a report contains multiple columns.
Property | Height | Gets the height of the report's body.
Property | Style | Gets the defined style information for the report's body.
Top

See Also

Reference

IBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Columns Property

Glossary Item Box

Gets the number of columns inside the report's body.

Syntax

Visual Basic (Declaration)
ReadOnly Property Columns As Integer
C#
int Columns {get;}

Property Value

An System.Int32 representing the number of columns inside the report's body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBody Interface
IBody Members


ColumnSpacing Property

[image]
ActiveReports 19 .NET Edition
ColumnSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : ColumnSpacing Property

Glossary Item Box

Gets the amount of space in between columns when a report contains multiple columns.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnSpacing As Length
C#
Length ColumnSpacing {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the amount of space in between columns when a report contains multiple columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBody Interface
IBody Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Height Property

Glossary Item Box

Gets the height of the report's body.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the report's body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBody Interface
IBody Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Style Property

Glossary Item Box

Gets the defined style information for the report's body.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An IStyle representing the defined style information for the report's body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBody Interface
IBody Members


ICheckBox Interface

[image]
ActiveReports 19 .NET Edition
ICheckBox Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

Glossary Item Box

Represents a checkbox item.

Syntax

Visual Basic (Declaration)
Public Interface ICheckBox
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
C#
public interface ICheckBox : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICheckBox Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICheckBox Interface Members

[image]
ActiveReports 19 .NET Edition
ICheckBox Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

Glossary Item Box

The following tables list the members exposed by ICheckBox.

Public Properties

 | Name | Description
Property | CheckAlignment | Gets the alignment of the checkbox.
Property | Checked | Gets a value indicating whether the checkbox is checked.
Top

See Also

Reference

ICheckBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICheckBox Interface Properties

[image]
ActiveReports 19 .NET Edition
ICheckBox Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

Glossary Item Box

For a list of all members of this type, see ICheckBox members.

Public Properties

 | Name | Description
Property | CheckAlignment | Gets the alignment of the checkbox.
Property | Checked | Gets a value indicating whether the checkbox is checked.
Top

See Also

Reference

ICheckBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CheckAlignment Property

[image]
ActiveReports 19 .NET Edition
CheckAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICheckBox Interface : CheckAlignment Property

Glossary Item Box

Gets the alignment of the checkbox.

Syntax

Visual Basic (Declaration)
ReadOnly Property CheckAlignment As CheckAlignment
C#
CheckAlignment CheckAlignment {get;}

Property Value

A CheckAlignment value specifying the alignment of the checkbox.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICheckBox Interface
ICheckBox Members


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICheckBox Interface : Checked Property

Glossary Item Box

Gets a value indicating whether the checkbox is checked.

Syntax

Visual Basic (Declaration)
ReadOnly Property Checked As Boolean
C#
bool Checked {get;}

Property Value

A System.Boolean value. true if the checkbox is checked; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICheckBox Interface
ICheckBox Members


IContentPlaceHolder Interface

[image]
ActiveReports 19 .NET Edition
IContentPlaceHolder Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentPlaceHolder Interface

Glossary Item Box

Represents the content placeholder contract.

Syntax

Visual Basic (Declaration)
Public Interface IContentPlaceHolder
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
C#
public interface IContentPlaceHolder : IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContentPlaceHolder Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IContentPlaceHolder Interface Members

[image]
ActiveReports 19 .NET Edition
IContentPlaceHolder Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentPlaceHolder Interface

Glossary Item Box

The following tables list the members exposed by IContentPlaceHolder.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the ContentPlaceHolder control should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the control.
Top

See Also

Reference

IContentPlaceHolder Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IContentPlaceHolder Interface Properties

[image]
ActiveReports 19 .NET Edition
IContentPlaceHolder Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentPlaceHolder Interface

Glossary Item Box

For a list of all members of this type, see IContentPlaceHolder members.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the ContentPlaceHolder control should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the control.
Top

See Also

Reference

IContentPlaceHolder Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IContentPlaceHolder Interface : ConsumeWhiteSpace Property

Glossary Item Box

Gets a value indicating whether all whitespace in the ContentPlaceHolder control should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the control.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeWhiteSpace As Boolean
C#
bool ConsumeWhiteSpace {get;}

Property Value

A System.Boolean value. true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContentPlaceHolder Interface
IContentPlaceHolder Members


ICustomReportItem Interface

[image]
ActiveReports 19 .NET Edition
ICustomReportItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

Glossary Item Box

Represents an interface for custom report items (CRIs).

Syntax

Visual Basic (Declaration)
Public Interface ICustomReportItem
   Inherits IDocumentMapItem, IInteractiveItem, IRenderComponent, IReportItem
C#
public interface ICustomReportItem : IDocumentMapItem, IInteractiveItem, IRenderComponent, IReportItem

Remarks

Custom report items should implement this interface for proper rendering to all possible rendering extensions (REs). Many functions exist primarily for XML RE advanced export and can return null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomReportItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItem Interface Members

[image]
ActiveReports 19 .NET Edition
ICustomReportItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

Glossary Item Box

The following tables list the members exposed by ICustomReportItem.

Public Properties

 | Name | Description
Property | CustomData | Gets the custom data of this CRI. Exists primarily for XML RE advanced export. Returned value can be null.
Property | DataElementValue | Gets the data element value. Exists primarily for XML RE advanced export. Returned value can be null.
Top

See Also

Reference

ICustomReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItem Interface Properties

[image]
ActiveReports 19 .NET Edition
ICustomReportItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

Glossary Item Box

For a list of all members of this type, see ICustomReportItem members.

Public Properties

 | Name | Description
Property | CustomData | Gets the custom data of this CRI. Exists primarily for XML RE advanced export. Returned value can be null.
Property | DataElementValue | Gets the data element value. Exists primarily for XML RE advanced export. Returned value can be null.
Top

See Also

Reference

ICustomReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CustomData Property

[image]
ActiveReports 19 .NET Edition
CustomData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : CustomData Property

Glossary Item Box

Gets the custom data of this CRI. Exists primarily for XML RE advanced export. Returned value can be null.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomData As CustomData
C#
CustomData CustomData {get;}

Property Value

A CustomData representing the custom data of this CRI, or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


DataElementValue Property

[image]
ActiveReports 19 .NET Edition
DataElementValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : DataElementValue Property

Glossary Item Box

Gets the data element value. Exists primarily for XML RE advanced export. Returned value can be null.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementValue As String
C#
string DataElementValue {get;}

Property Value

A System.String representing the data element value, or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


IDataRegion Interface

[image]
ActiveReports 19 .NET Edition
IDataRegion Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

Glossary Item Box

Represents an interface for data regions.

Syntax

Visual Basic (Declaration)
Public Interface IDataRegion
   Inherits IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface IDataRegion : IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegion Interface Members

[image]
ActiveReports 19 .NET Edition
IDataRegion Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

Glossary Item Box

The following tables list the members exposed by IDataRegion.

Public Properties

 | Name | Description
Property | DataSetName | Gets the name of the data set to use for this data region.
Property | NoRows | Gets a value indicating whether the data region has no rows available.
Property | NoRowsMessage | Gets the message to display in the data region when no rows of data are available.
Property | NoRowsTextBox | Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.
Top

See Also

Reference

IDataRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegion Interface Properties

[image]
ActiveReports 19 .NET Edition
IDataRegion Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

Glossary Item Box

For a list of all members of this type, see IDataRegion members.

Public Properties

 | Name | Description
Property | DataSetName | Gets the name of the data set to use for this data region.
Property | NoRows | Gets a value indicating whether the data region has no rows available.
Property | NoRowsMessage | Gets the message to display in the data region when no rows of data are available.
Property | NoRowsTextBox | Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.
Top

See Also

Reference

IDataRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : DataSetName Property

Glossary Item Box

Gets the name of the data set to use for this data region.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataSetName As String
C#
string DataSetName {get;}

Property Value

A System.String specifying the name of the data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRows Property

Glossary Item Box

Gets a value indicating whether the data region has no rows available.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRows As Boolean
C#
bool NoRows {get;}

Property Value

A System.Boolean value. true if the data region has no rows; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRowsMessage Property

[image]
ActiveReports 19 .NET Edition
NoRowsMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRowsMessage Property

Glossary Item Box

Gets the message to display in the data region when no rows of data are available.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRowsMessage As String
C#
string NoRowsMessage {get;}

Property Value

A System.String representing the message displayed when no rows of data are available.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRowsTextBox Property

[image]
ActiveReports 19 .NET Edition
NoRowsTextBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRowsTextBox Property

Glossary Item Box

Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRowsTextBox As ITextBox
C#
ITextBox NoRowsTextBox {get;}

Property Value

An ITextBox suitable for displaying the no rows message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataRegion Interface
IDataRegion Members


IDataScope Interface

[image]
ActiveReports 19 .NET Edition
IDataScope Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

Glossary Item Box

Represents a data scope in a report at rendering time.

Syntax

Visual Basic (Declaration)
Public Interface IDataScope
C#
public interface IDataScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataScope Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataScope Interface Members

[image]
ActiveReports 19 .NET Edition
IDataScope Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

Glossary Item Box

The following tables list the members exposed by IDataScope.

Public Properties

 | Name | Description
Property | Id | Gets the identifier of the data scope.
Property | Name | Gets the name of the current scope.
Property | Parents | Gets the data scopes that are considered direct parents of the current scope.
Top

See Also

Reference

IDataScope Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataScope Interface Properties

[image]
ActiveReports 19 .NET Edition
IDataScope Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

Glossary Item Box

For a list of all members of this type, see IDataScope members.

Public Properties

 | Name | Description
Property | Id | Gets the identifier of the data scope.
Property | Name | Gets the name of the current scope.
Property | Parents | Gets the data scopes that are considered direct parents of the current scope.
Top

See Also

Reference

IDataScope Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Id Property

Glossary Item Box

Gets the identifier of the data scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property Id As Integer
C#
int Id {get;}

Property Value

An System.Int32 representing the identifier of the data scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataScope Interface
IDataScope Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Name Property

Glossary Item Box

Gets the name of the current scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the name of the current scope. If the scope is unnamed, returns an empty string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataScope Interface
IDataScope Members


Parents Property

[image]
ActiveReports 19 .NET Edition
Parents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Parents Property

Glossary Item Box

Gets the data scopes that are considered direct parents of the current scope.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parents As IDataScope()
C#
IDataScope[] Parents {get;}

Property Value

An array of IDataScope representing the direct parents of the current scope.

Remarks

A scope can have zero or more parents. For example, if the current scope represents a matrix cell, it will have a parent from each of the leaf members on the row and column axis. However, a grouping or data region will have only one parent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataScope Interface
IDataScope Members


IDocumentMapItem Interface

[image]
ActiveReports 19 .NET Edition
IDocumentMapItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface

Glossary Item Box

Represents an interface to unify document map nodes.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentMapItem
C#
public interface IDocumentMapItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDocumentMapItem Interface Members

[image]
ActiveReports 19 .NET Edition
IDocumentMapItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface

Glossary Item Box

The following tables list the members exposed by IDocumentMapItem.

Public Properties

 | Name | Description
Property | Label | Gets the label of the document map node.
Top

See Also

Reference

IDocumentMapItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDocumentMapItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IDocumentMapItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface

Glossary Item Box

For a list of all members of this type, see IDocumentMapItem members.

Public Properties

 | Name | Description
Property | Label | Gets the label of the document map node.
Top

See Also

Reference

IDocumentMapItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDocumentMapItem Interface : Label Property

Glossary Item Box

Gets the label of the document map node.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Property Value

The label of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapItem Interface
IDocumentMapItem Members


IDrillthrough Interface

[image]
ActiveReports 19 .NET Edition
IDrillthrough Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface

Glossary Item Box

Represents an interface for a drillthrough object.

Syntax

Visual Basic (Declaration)
Public Interface IDrillthrough
C#
public interface IDrillthrough

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrillthrough Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDrillthrough Interface Members

[image]
ActiveReports 19 .NET Edition
IDrillthrough Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface

Glossary Item Box

The following tables list the members exposed by IDrillthrough.

Public Properties

 | Name | Description
Property | NumberOfParameters | Gets the count of drillthrough parameters.
Property | Parameters | Gets the drillthrough parameters.
Property | ReportName | Gets the path of the drillthrough report. Paths may be absolute or relative.
Top

See Also

Reference

IDrillthrough Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDrillthrough Interface Properties

[image]
ActiveReports 19 .NET Edition
IDrillthrough Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface

Glossary Item Box

For a list of all members of this type, see IDrillthrough members.

Public Properties

 | Name | Description
Property | NumberOfParameters | Gets the count of drillthrough parameters.
Property | Parameters | Gets the drillthrough parameters.
Property | ReportName | Gets the path of the drillthrough report. Paths may be absolute or relative.
Top

See Also

Reference

IDrillthrough Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


NumberOfParameters Property

[image]
ActiveReports 19 .NET Edition
NumberOfParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : NumberOfParameters Property

Glossary Item Box

Gets the count of drillthrough parameters.

Syntax

Visual Basic (Declaration)
ReadOnly Property NumberOfParameters As Integer
C#
int NumberOfParameters {get;}

Property Value

An System.Int32 representing the number of drillthrough parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrillthrough Interface
IDrillthrough Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : Parameters Property

Glossary Item Box

Gets the drillthrough parameters.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parameters As DrillthroughParameter()
C#
DrillthroughParameter[] Parameters {get;}

Property Value

An array of DrillthroughParameter objects representing the parameters for the drillthrough report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrillthrough Interface
IDrillthrough Members


ReportName Property

[image]
ActiveReports 19 .NET Edition
ReportName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : ReportName Property

Glossary Item Box

Gets the path of the drillthrough report. Paths may be absolute or relative.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportName As String
C#
string ReportName {get;}

Property Value

A System.String representing the path of the drillthrough report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrillthrough Interface
IDrillthrough Members


IFixedPage Interface

[image]
ActiveReports 19 .NET Edition
IFixedPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

Glossary Item Box

Represents a container of IFixedPageContent objects.

Syntax

Visual Basic (Declaration)
Public Interface IFixedPage
   Inherits IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface IFixedPage : IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPage Interface Members

[image]
ActiveReports 19 .NET Edition
IFixedPage Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

Glossary Item Box

The following tables list the members exposed by IFixedPage.

Public Properties

 | Name | Description
Property | Contents | Gets the IFixedPageContent objects in this container.
Top

Public Methods

 | Name | Description
Method | GetStyle | Gets the style of the page with the specified index.
Top

See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPage Interface Methods

[image]
ActiveReports 19 .NET Edition
IFixedPage Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

Glossary Item Box

For a list of all members of this type, see IFixedPage members.

Public Methods

 | Name | Description
Method | GetStyle | Gets the style of the page with the specified index.
Top

See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetStyle Method

[image]
ActiveReports 19 .NET Edition
GetStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPage Interface : GetStyle Method

pageIndex
The index of the page to get the style for.

Glossary Item Box

Gets the style of the page with the specified index.

Syntax

Visual Basic (Declaration)
Function GetStyle( _
   ByVal pageIndex As Integer _
) As IStyle
C#
IStyle GetStyle(
   int pageIndex
)

Parameters

pageIndex
The index of the page to get the style for.

Return Value

An IStyle representing the style of the specified page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPage Interface
IFixedPage Members


IFixedPage Interface Properties

[image]
ActiveReports 19 .NET Edition
IFixedPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

Glossary Item Box

For a list of all members of this type, see IFixedPage members.

Public Properties

 | Name | Description
Property | Contents | Gets the IFixedPageContent objects in this container.
Top

See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property

[image]
ActiveReports 19 .NET Edition
Contents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPage Interface : Contents Property

Glossary Item Box

Gets the IFixedPageContent objects in this container.

Syntax

Visual Basic (Declaration)
ReadOnly Property Contents As IItemCollection(Of IFixedPageContent)
C#
IItemCollection<IFixedPageContent> Contents {get;}

Property Value

An IItemCollection<T> representing the contents of the fixed page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPage Interface
IFixedPage Members


IFixedPageContent Interface

[image]
ActiveReports 19 .NET Edition
IFixedPageContent Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface

Glossary Item Box

Represents the content of a single FixedPage instance.

Syntax

Visual Basic (Declaration)
Public Interface IFixedPageContent
   Inherits IDocumentMapItem, ISectionRegion
C#
public interface IFixedPageContent : IDocumentMapItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPageContent Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPageContent Interface Members

[image]
ActiveReports 19 .NET Edition
IFixedPageContent Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface

Glossary Item Box

The following tables list the members exposed by IFixedPageContent.

Public Properties

 | Name | Description
Property | Pages | Gets the pages in this container.
Top

See Also

Reference

IFixedPageContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPageContent Interface Properties

[image]
ActiveReports 19 .NET Edition
IFixedPageContent Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface

Glossary Item Box

For a list of all members of this type, see IFixedPageContent members.

Public Properties

 | Name | Description
Property | Pages | Gets the pages in this container.
Top

See Also

Reference

IFixedPageContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Pages Property

[image]
ActiveReports 19 .NET Edition
Pages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPageContent Interface : Pages Property

Glossary Item Box

Gets the pages in this container.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pages As IEnumerable(Of IPage)
C#
IEnumerable<IPage> Pages {get;}

Property Value

An IEnumerable representing the pages in this container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedPageContent Interface
IFixedPageContent Members


IFixedSizeItem Interface

[image]
ActiveReports 19 .NET Edition
IFixedSizeItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedSizeItem Interface

Glossary Item Box

Represents an interface for items with fixed size.

Syntax

Visual Basic (Declaration)
Public Interface IFixedSizeItem
C#
public interface IFixedSizeItem

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedSizeItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedSizeItem Interface Members

[image]
ActiveReports 19 .NET Edition
IFixedSizeItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedSizeItem Interface

Glossary Item Box

The following tables list the members exposed by IFixedSizeItem.

Public Properties

 | Name | Description
Property | FixedHeight | Gets the fixed height for FPL reports.
Property | FixedWidth | Gets the fixed width for FPL reports.
Top

See Also

Reference

IFixedSizeItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedSizeItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IFixedSizeItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedSizeItem Interface

Glossary Item Box

For a list of all members of this type, see IFixedSizeItem members.

Public Properties

 | Name | Description
Property | FixedHeight | Gets the fixed height for FPL reports.
Property | FixedWidth | Gets the fixed width for FPL reports.
Top

See Also

Reference

IFixedSizeItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


FixedHeight Property

[image]
ActiveReports 19 .NET Edition
FixedHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedSizeItem Interface : FixedHeight Property

Glossary Item Box

Gets the fixed height for FPL reports.

Syntax

Visual Basic (Declaration)
ReadOnly Property FixedHeight As Length
C#
Length FixedHeight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the fixed height for FPL reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedSizeItem Interface
IFixedSizeItem Members


FixedWidth Property

[image]
ActiveReports 19 .NET Edition
FixedWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedSizeItem Interface : FixedWidth Property

Glossary Item Box

Gets the fixed width for FPL reports.

Syntax

Visual Basic (Declaration)
ReadOnly Property FixedWidth As Length
C#
Length FixedWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the fixed width for FPL reports.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFixedSizeItem Interface
IFixedSizeItem Members


IFooterBand Interface

[image]
ActiveReports 19 .NET Edition
IFooterBand Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

Glossary Item Box

Represents the interface for the footer band of the banded list.

Syntax

Visual Basic (Declaration)
Public Interface IFooterBand
   Inherits IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
C#
public interface IFooterBand : IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFooterBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFooterBand Interface Members

[image]
ActiveReports 19 .NET Edition
IFooterBand Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

Glossary Item Box

The following tables list the members exposed by IFooterBand.

Public Properties

 | Name | Description
Property | PrintAtBottom | Gets a value indicating whether this footer band will print at the bottom of the page.
Property | RepeatOnNewPage | Gets a value indicating whether this footer band will repeat on each new page.
Top

See Also

Reference

IFooterBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFooterBand Interface Properties

[image]
ActiveReports 19 .NET Edition
IFooterBand Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

Glossary Item Box

For a list of all members of this type, see IFooterBand members.

Public Properties

 | Name | Description
Property | PrintAtBottom | Gets a value indicating whether this footer band will print at the bottom of the page.
Property | RepeatOnNewPage | Gets a value indicating whether this footer band will repeat on each new page.
Top

See Also

Reference

IFooterBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFooterBand Interface : PrintAtBottom Property

Glossary Item Box

Gets a value indicating whether this footer band will print at the bottom of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintAtBottom As Boolean
C#
bool PrintAtBottom {get;}

Property Value

A System.Boolean value. true if this footer band will print at the bottom of the page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFooterBand Interface
IFooterBand Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFooterBand Interface : RepeatOnNewPage Property

Glossary Item Box

Gets a value indicating whether this footer band will repeat on each new page.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatOnNewPage As Boolean
C#
bool RepeatOnNewPage {get;}

Property Value

A System.Boolean value. true if this footer band will repeat on each new page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFooterBand Interface
IFooterBand Members


IFormattedText Interface

[image]
ActiveReports 19 .NET Edition
IFormattedText Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface

Glossary Item Box

Represents a formatted text rendering component.

Syntax

Visual Basic (Declaration)
Public Interface IFormattedText
C#
public interface IFormattedText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattedText Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFormattedText Interface Members

[image]
ActiveReports 19 .NET Edition
IFormattedText Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface

Glossary Item Box

The following tables list the members exposed by IFormattedText.

Public Properties

 | Name | Description
Property | ParsedHtml | Gets the content of the current formatted text rendering component as an XML document.
Top

See Also

Reference

IFormattedText Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFormattedText Interface Properties

[image]
ActiveReports 19 .NET Edition
IFormattedText Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface

Glossary Item Box

For a list of all members of this type, see IFormattedText members.

Public Properties

 | Name | Description
Property | ParsedHtml | Gets the content of the current formatted text rendering component as an XML document.
Top

See Also

Reference

IFormattedText Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ParsedHtml Property

[image]
ActiveReports 19 .NET Edition
ParsedHtml Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFormattedText Interface : ParsedHtml Property

Glossary Item Box

Gets the content of the current formatted text rendering component as an XML document.

Syntax

Visual Basic (Declaration)
ReadOnly Property ParsedHtml As XmlDocument
C#
XmlDocument ParsedHtml {get;}

Property Value

An System.Xml.XmlDocument representing the parsed HTML content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattedText Interface
IFormattedText Members


IFrozen Interface

[image]
ActiveReports 19 .NET Edition
IFrozen Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFrozen Interface

Glossary Item Box

Represents an interface for report items that implement the frozen rows or columns feature.

Syntax

Visual Basic (Declaration)
Public Interface IFrozen
C#
public interface IFrozen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFrozen Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFrozen Interface Members

[image]
ActiveReports 19 .NET Edition
IFrozen Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFrozen Interface

Glossary Item Box

The following tables list the members exposed by IFrozen.

Public Properties

 | Name | Description
Property | FrozenColumns | Gets the number of frozen columns.
Property | FrozenRows | Gets the number of frozen rows.
Top

See Also

Reference

IFrozen Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFrozen Interface Properties

[image]
ActiveReports 19 .NET Edition
IFrozen Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFrozen Interface

Glossary Item Box

For a list of all members of this type, see IFrozen members.

Public Properties

 | Name | Description
Property | FrozenColumns | Gets the number of frozen columns.
Property | FrozenRows | Gets the number of frozen rows.
Top

See Also

Reference

IFrozen Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


FrozenColumns Property

[image]
ActiveReports 19 .NET Edition
FrozenColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFrozen Interface : FrozenColumns Property

Glossary Item Box

Gets the number of frozen columns.

Syntax

Visual Basic (Declaration)
ReadOnly Property FrozenColumns As Integer
C#
int FrozenColumns {get;}

Property Value

An System.Int32 indicating the number of frozen columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFrozen Interface
IFrozen Members


FrozenRows Property

[image]
ActiveReports 19 .NET Edition
FrozenRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFrozen Interface : FrozenRows Property

Glossary Item Box

Gets the number of frozen rows.

Syntax

Visual Basic (Declaration)
ReadOnly Property FrozenRows As Integer
C#
int FrozenRows {get;}

Property Value

An System.Int32 indicating the number of frozen rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFrozen Interface
IFrozen Members


IHeaderBand Interface

[image]
ActiveReports 19 .NET Edition
IHeaderBand Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

Glossary Item Box

Represents the interface for the header band of the banded list.

Syntax

Visual Basic (Declaration)
Public Interface IHeaderBand
   Inherits IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
C#
public interface IHeaderBand : IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHeaderBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IHeaderBand Interface Members

[image]
ActiveReports 19 .NET Edition
IHeaderBand Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

Glossary Item Box

The following tables list the members exposed by IHeaderBand.

Public Properties

 | Name | Description
Property | RepeatOnNewPage | Gets a value indicating whether this header band will repeat on each new page.
Top

See Also

Reference

IHeaderBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IHeaderBand Interface Properties

[image]
ActiveReports 19 .NET Edition
IHeaderBand Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

Glossary Item Box

For a list of all members of this type, see IHeaderBand members.

Public Properties

 | Name | Description
Property | RepeatOnNewPage | Gets a value indicating whether this header band will repeat on each new page.
Top

See Also

Reference

IHeaderBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IHeaderBand Interface : RepeatOnNewPage Property

Glossary Item Box

Gets a value indicating whether this header band will repeat on each new page.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatOnNewPage As Boolean
C#
bool RepeatOnNewPage {get;}

Property Value

A System.Boolean value. true if this header band will repeat on each new page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHeaderBand Interface
IHeaderBand Members


IImage Interface

[image]
ActiveReports 19 .NET Edition
IImage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

Glossary Item Box

Represents an interface for images.

Syntax

Visual Basic (Declaration)
Public Interface IImage
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem
C#
public interface IImage : IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImage Interface Members

[image]
ActiveReports 19 .NET Edition
IImage Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

Glossary Item Box

The following tables list the members exposed by IImage.

Public Properties

 | Name | Description
Property | HorizontalAlignment | Gets the horizontal alignment of the picture shown by the image report item.
Property | MimeType | Gets the Multipurpose Internet Mail Extensions (MIME) type of the image.
Property | Sizing | Gets the behavior if the image doesn't fit within the specified size.
Property | Source | Gets the source type of the image specified in the Value property.
Property | Value | Gets the source of the image.
Property | VerticalAlignment | Gets the vertical alignment of the picture shown by the image report item.
Top

See Also

Reference

IImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImage Interface Properties

[image]
ActiveReports 19 .NET Edition
IImage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

Glossary Item Box

For a list of all members of this type, see IImage members.

Public Properties

 | Name | Description
Property | HorizontalAlignment | Gets the horizontal alignment of the picture shown by the image report item.
Property | MimeType | Gets the Multipurpose Internet Mail Extensions (MIME) type of the image.
Property | Sizing | Gets the behavior if the image doesn't fit within the specified size.
Property | Source | Gets the source type of the image specified in the Value property.
Property | Value | Gets the source of the image.
Property | VerticalAlignment | Gets the vertical alignment of the picture shown by the image report item.
Top

See Also

Reference

IImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


HorizontalAlignment Property

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : HorizontalAlignment Property

Glossary Item Box

Gets the horizontal alignment of the picture shown by the image report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property HorizontalAlignment As String
C#
string HorizontalAlignment {get;}

Property Value

A System.String representing the horizontal alignment of the picture.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


MimeType Property

[image]
ActiveReports 19 .NET Edition
MimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : MimeType Property

Glossary Item Box

Gets the Multipurpose Internet Mail Extensions (MIME) type of the image.

Syntax

Visual Basic (Declaration)
ReadOnly Property MimeType As String
C#
string MimeType {get;}

Property Value

A System.String identifying the MIME type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


Sizing Property

[image]
ActiveReports 19 .NET Edition
Sizing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Sizing Property

Glossary Item Box

Gets the behavior if the image doesn't fit within the specified size.

Syntax

Visual Basic (Declaration)
ReadOnly Property Sizing As ImageSizing
C#
ImageSizing Sizing {get;}

Property Value

An GrapeCity.ActiveReports.PageReportModel.ImageSizing value determining the behavior if the image doesn't fit within the specified size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Source Property

Glossary Item Box

Gets the source type of the image specified in the Value property.

Syntax

Visual Basic (Declaration)
ReadOnly Property Source As ImageSource
C#
ImageSource Source {get;}

Property Value

An GrapeCity.ActiveReports.PageReportModel.ImageSource indicating the source type of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Value Property

Glossary Item Box

Gets the source of the image.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Object
C#
object Value {get;}

Property Value

An System.Object identifying the source of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : VerticalAlignment Property

Glossary Item Box

Gets the vertical alignment of the picture shown by the image report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property VerticalAlignment As String
C#
string VerticalAlignment {get;}

Property Value

A System.String representing the vertical alignment of the picture.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImage Interface
IImage Members


IInteractiveItem Interface

[image]
ActiveReports 19 .NET Edition
IInteractiveItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IInteractiveItem Interface

Glossary Item Box

Represents interactive report item which may contain interactive areas

Syntax

Visual Basic (Declaration)
Public Interface IInteractiveItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface IInteractiveItem : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractiveItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IInteractiveItem Interface Members

[image]
ActiveReports 19 .NET Edition
IInteractiveItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IInteractiveItem Interface

Glossary Item Box

The following tables list the members exposed by IInteractiveItem.

See Also

Reference

IInteractiveItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IItemCollection<T> Interface

T
The type of items contained in the collection.
[image]
ActiveReports 19 .NET Edition
IItemCollection<T> Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IItemCollection<T> Interface

Glossary Item Box

Represents a collection of items that can be accessed by index and provides read-only functionality.

Syntax

Visual Basic (Declaration)
Public Interface IItemCollection(Of T)
C#
public interface IItemCollection<T>

Type Parameters

T
The type of items contained in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IItemCollection<T> Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IItemCollection<T> Interface Members

[image]
ActiveReports 19 .NET Edition
IItemCollection<T> Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IItemCollection<T> Interface

Glossary Item Box

The following tables list the members exposed by IItemCollection<T>.

See Also

Reference

IItemCollection<T> Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ILine Interface

[image]
ActiveReports 19 .NET Edition
ILine Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ILine Interface

Glossary Item Box

Represents a line report item in the rendering output.

Syntax

Visual Basic (Declaration)
Public Interface ILine
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem
C#
public interface ILine : IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILine Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ILine Interface Members

[image]
ActiveReports 19 .NET Edition
ILine Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ILine Interface

Glossary Item Box

The following tables list the members exposed by ILine.

See Also

Reference

ILine Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IList Interface

[image]
ActiveReports 19 .NET Edition
IList Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

Glossary Item Box

Represents an interface for the List report item.

Syntax

Visual Basic (Declaration)
Public Interface IList
   Inherits IDataRegion, IDocumentMapItem, IFixedSizeItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface IList : IDataRegion, IDocumentMapItem, IFixedSizeItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IList Interface Members

[image]
ActiveReports 19 .NET Edition
IList Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

Glossary Item Box

The following tables list the members exposed by IList.

Public Properties

 | Name | Description
Property | CanGrowHorizontally | Gets a value indicating whether the list can grow horizontally.
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.
Property | Contents | Gets the instances of this list control based on the data.
Top

See Also

Reference

IList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IList Interface Properties

[image]
ActiveReports 19 .NET Edition
IList Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

Glossary Item Box

For a list of all members of this type, see IList members.

Public Properties

 | Name | Description
Property | CanGrowHorizontally | Gets a value indicating whether the list can grow horizontally.
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.
Property | Contents | Gets the instances of this list control based on the data.
Top

See Also

Reference

IList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrowHorizontally Property

[image]
ActiveReports 19 .NET Edition
CanGrowHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : CanGrowHorizontally Property

Glossary Item Box

Gets a value indicating whether the list can grow horizontally.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanGrowHorizontally As Boolean
C#
bool CanGrowHorizontally {get;}

Property Value

A System.Boolean value. true if the list can grow horizontally; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IList Interface
IList Members


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : ConsumeWhiteSpace Property

Glossary Item Box

Gets a value indicating whether all whitespace in the list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeWhiteSpace As Boolean
C#
bool ConsumeWhiteSpace {get;}

Property Value

A System.Boolean value. true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IList Interface
IList Members


Contents Property

[image]
ActiveReports 19 .NET Edition
Contents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : Contents Property

Glossary Item Box

Gets the instances of this list control based on the data.

Syntax

Visual Basic (Declaration)
ReadOnly Property Contents As IEnumerable(Of IListContent)
C#
IEnumerable<IListContent> Contents {get;}

Property Value

An IEnumerable providing the instances of the list control based on the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IList Interface
IList Members


IListContent Interface

[image]
ActiveReports 19 .NET Edition
IListContent Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContent Interface

Glossary Item Box

Represents an interface for list content.

Syntax

Visual Basic (Declaration)
Public Interface IListContent
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer, ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
C#
public interface IListContent : IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer, ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListContent Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListContent Interface Members

[image]
ActiveReports 19 .NET Edition
IListContent Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContent Interface

Glossary Item Box

The following tables list the members exposed by IListContent.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the containing list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.
Top

See Also

Reference

IListContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListContent Interface Properties

[image]
ActiveReports 19 .NET Edition
IListContent Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContent Interface

Glossary Item Box

For a list of all members of this type, see IListContent members.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the containing list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.
Top

See Also

Reference

IListContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IListContent Interface : ConsumeWhiteSpace Property

Glossary Item Box

Gets a value indicating whether all whitespace in the containing list should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the list.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeWhiteSpace As Boolean
C#
bool ConsumeWhiteSpace {get;}

Property Value

A System.Boolean value. true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListContent Interface
IListContent Members


IListGrid Interface

[image]
ActiveReports 19 .NET Edition
IListGrid Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListGrid Interface

Glossary Item Box

Represents an extension of the IList interface by adding multi-column/row capability.

Syntax

Visual Basic (Declaration)
Public Interface IListGrid
   Inherits IDataRegion, IDocumentMapItem, IFixedSizeItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface IListGrid : IDataRegion, IDocumentMapItem, IFixedSizeItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListGrid Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListGrid Interface Members

[image]
ActiveReports 19 .NET Edition
IListGrid Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListGrid Interface

Glossary Item Box

The following tables list the members exposed by IListGrid.

Public Properties

 | Name | Description
Property | GrowDirection | Gets the list layout grow direction.
Property | RowsOrColumnsCount | Gets the number of rows or columns, depending on the grow direction.
Top

See Also

Reference

IListGrid Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListGrid Interface Properties

[image]
ActiveReports 19 .NET Edition
IListGrid Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListGrid Interface

Glossary Item Box

For a list of all members of this type, see IListGrid members.

Public Properties

 | Name | Description
Property | GrowDirection | Gets the list layout grow direction.
Property | RowsOrColumnsCount | Gets the number of rows or columns, depending on the grow direction.
Top

See Also

Reference

IListGrid Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GrowDirection Property

[image]
ActiveReports 19 .NET Edition
GrowDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IListGrid Interface : GrowDirection Property

Glossary Item Box

Gets the list layout grow direction.

Syntax

Visual Basic (Declaration)
ReadOnly Property GrowDirection As GrowDirection
C#
GrowDirection GrowDirection {get;}

Property Value

A GrowDirection value specifying the grow direction of the list layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListGrid Interface
IListGrid Members


RowsOrColumnsCount Property

[image]
ActiveReports 19 .NET Edition
RowsOrColumnsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IListGrid Interface : RowsOrColumnsCount Property

Glossary Item Box

Gets the number of rows or columns, depending on the grow direction.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowsOrColumnsCount As Integer
C#
int RowsOrColumnsCount {get;}

Property Value

An System.Int32 representing the number of rows or columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListGrid Interface
IListGrid Members


IMetadataDictionary Interface

[image]
ActiveReports 19 .NET Edition
IMetadataDictionary Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

Glossary Item Box

Represents an interface for a dictionary of metadata objects.

Syntax

Visual Basic (Declaration)
Public Interface IMetadataDictionary
   Inherits IMetadataDictionaryEntry, IMetadataEntry
C#
public interface IMetadataDictionary : IMetadataDictionaryEntry, IMetadataEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionary Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionary Interface Members

[image]
ActiveReports 19 .NET Edition
IMetadataDictionary Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

Glossary Item Box

The following tables list the members exposed by IMetadataDictionary.

Public Properties

 | Name | Description
Property | Item | Gets the IMetadataDictionaryEntry with the specified ID.
Top

Public Methods

 | Name | Description
Method | Add | Adds a dictionary entry to the map.
Top

See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionary Interface Methods

[image]
ActiveReports 19 .NET Edition
IMetadataDictionary Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

Glossary Item Box

For a list of all members of this type, see IMetadataDictionary members.

Public Methods

 | Name | Description
Method | Add | Adds a dictionary entry to the map.
Top

See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionary Interface : Add Method

entry
The IMetadataDictionaryEntry to add to the dictionary.

Glossary Item Box

Adds a dictionary entry to the map.

Syntax

Visual Basic (Declaration)
Sub Add( _
   ByVal entry As IMetadataDictionaryEntry _
)
C#
void Add(
   IMetadataDictionaryEntry entry
)

Parameters

entry
The IMetadataDictionaryEntry to add to the dictionary.

Remarks

It will merge dictionary contents if a dictionary with the same ID and name already exists at the top level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionary Interface
IMetadataDictionary Members


IMetadataDictionary Interface Properties

[image]
ActiveReports 19 .NET Edition
IMetadataDictionary Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

Glossary Item Box

For a list of all members of this type, see IMetadataDictionary members.

Public Properties

 | Name | Description
Property | Item | Gets the IMetadataDictionaryEntry with the specified ID.
Top

See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionary Interface : Item Property

id
The ID of the metadata dictionary entry to retrieve.

Glossary Item Box

Gets the IMetadataDictionaryEntry with the specified ID.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal id As String _
) As IMetadataDictionaryEntry
C#
IMetadataDictionaryEntry this[
   string id
]; {get;}

Parameters

id
The ID of the metadata dictionary entry to retrieve.

Property Value

An IMetadataDictionaryEntry with the specified ID.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionary Interface
IMetadataDictionary Members


IMetadataDictionaryEntry Interface

[image]
ActiveReports 19 .NET Edition
IMetadataDictionaryEntry Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface

Glossary Item Box

Represents an interface for members of the IMetadataDictionary.

Syntax

Visual Basic (Declaration)
Public Interface IMetadataDictionaryEntry
   Inherits IMetadataEntry
C#
public interface IMetadataDictionaryEntry : IMetadataEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionaryEntry Interface Members

[image]
ActiveReports 19 .NET Edition
IMetadataDictionaryEntry Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface

Glossary Item Box

The following tables list the members exposed by IMetadataDictionaryEntry.

Public Properties

 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ID | Gets the identifier of this object.
Property | LayoutArea | Gets or sets the GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea instance referenced directly or indirectly via Contents.
Property | Name | Gets the name of this object.
Property | ReportItem | Gets the IReportItem referenced directly (for Document Map) or indirectly via Contents.
Top

See Also

Reference

IMetadataDictionaryEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionaryEntry Interface Properties

[image]
ActiveReports 19 .NET Edition
IMetadataDictionaryEntry Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface

Glossary Item Box

For a list of all members of this type, see IMetadataDictionaryEntry members.

Public Properties

 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ID | Gets the identifier of this object.
Property | LayoutArea | Gets or sets the GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea instance referenced directly or indirectly via Contents.
Property | Name | Gets the name of this object.
Property | ReportItem | Gets the IReportItem referenced directly (for Document Map) or indirectly via Contents.
Top

See Also

Reference

IMetadataDictionaryEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property

[image]
ActiveReports 19 .NET Edition
Contents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : Contents Property

Glossary Item Box

Gets the contents of this object.

Syntax

Visual Basic (Declaration)
Shadows ReadOnly Property Contents As Object
C#
new object Contents {get;}

Property Value

An System.Object representing the contents of the metadata entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


ID Property

[image]
ActiveReports 19 .NET Edition
ID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : ID Property

Glossary Item Box

Gets the identifier of this object.

Syntax

Visual Basic (Declaration)
Shadows ReadOnly Property ID As String
C#
new string ID {get;}

Property Value

A System.String representing the identifier of the metadata entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


LayoutArea Property

[image]
ActiveReports 19 .NET Edition
LayoutArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : LayoutArea Property

Glossary Item Box

Gets or sets the GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea instance referenced directly or indirectly via Contents.

Syntax

Visual Basic (Declaration)
Property LayoutArea As ILayoutArea
C#
ILayoutArea LayoutArea {get; set;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea instance representing the layout area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : Name Property

Glossary Item Box

Gets the name of this object.

Syntax

Visual Basic (Declaration)
Shadows ReadOnly Property Name As String
C#
new string Name {get;}

Property Value

A System.String representing the name of the metadata entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : ReportItem Property

Glossary Item Box

Gets the IReportItem referenced directly (for Document Map) or indirectly via Contents.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Property Value

An IReportItem instance representing the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


IMetadataEntry Interface

[image]
ActiveReports 19 .NET Edition
IMetadataEntry Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface

Glossary Item Box

Represents an interface for metadata entry objects.

Syntax

Visual Basic (Declaration)
Public Interface IMetadataEntry
C#
public interface IMetadataEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataEntry Interface Members

[image]
ActiveReports 19 .NET Edition
IMetadataEntry Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface

Glossary Item Box

The following tables list the members exposed by IMetadataEntry.

Public Properties

 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ContentType | Gets the content type.
Property | ID | Gets the metadata entry ID.
Property | Name | Gets the metadata entry name.
Top

See Also

Reference

IMetadataEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataEntry Interface Properties

[image]
ActiveReports 19 .NET Edition
IMetadataEntry Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface

Glossary Item Box

For a list of all members of this type, see IMetadataEntry members.

Public Properties

 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ContentType | Gets the content type.
Property | ID | Gets the metadata entry ID.
Property | Name | Gets the metadata entry name.
Top

See Also

Reference

IMetadataEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property

[image]
ActiveReports 19 .NET Edition
Contents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : Contents Property

Glossary Item Box

Gets the contents of this object.

Syntax

Visual Basic (Declaration)
ReadOnly Property Contents As Object
C#
object Contents {get;}

Property Value

An System.Object representing the contents of the metadata entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


ContentType Property

[image]
ActiveReports 19 .NET Edition
ContentType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : ContentType Property

Glossary Item Box

Gets the content type.

Syntax

Visual Basic (Declaration)
ReadOnly Property ContentType As MetadataType
C#
MetadataType ContentType {get;}

Property Value

A MetadataType enum value representing the type of content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


ID Property

[image]
ActiveReports 19 .NET Edition
ID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : ID Property

Glossary Item Box

Gets the metadata entry ID.

Syntax

Visual Basic (Declaration)
ReadOnly Property ID As String
C#
string ID {get;}

Property Value

A System.String representing the ID of the metadata entry.

Remarks

The ID should be unique across all metadata entries in the dictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : Name Property

Glossary Item Box

Gets the metadata entry name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the name of the metadata entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


IOverflowItem Interface

[image]
ActiveReports 19 .NET Edition
IOverflowItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

Glossary Item Box

Represents an interface for an overflow item.

Syntax

Visual Basic (Declaration)
Public Interface IOverflowItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface IOverflowItem : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOverflowItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IOverflowItem Interface Members

[image]
ActiveReports 19 .NET Edition
IOverflowItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

Glossary Item Box

The following tables list the members exposed by IOverflowItem.

Public Properties

 | Name | Description
Property | OverflowName | Gets the overflow name.
Top

See Also

Reference

IOverflowItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IOverflowItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IOverflowItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

Glossary Item Box

For a list of all members of this type, see IOverflowItem members.

Public Properties

 | Name | Description
Property | OverflowName | Gets the overflow name.
Top

See Also

Reference

IOverflowItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IOverflowItem Interface : OverflowName Property

Glossary Item Box

Gets the overflow name.

Syntax

Visual Basic (Declaration)
ReadOnly Property OverflowName As String
C#
string OverflowName {get;}

Property Value

A System.String representing the name of the overflow item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOverflowItem Interface
IOverflowItem Members


IOverflowPlaceHolder Interface

[image]
ActiveReports 19 .NET Edition
IOverflowPlaceHolder Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowPlaceHolder Interface

Glossary Item Box

Represents an interface for an overflow placeholder.

Syntax

Visual Basic (Declaration)
Public Interface IOverflowPlaceHolder
   Inherits IDocumentMapItem, IOverflowItem, IRenderComponent, IReportItem
C#
public interface IOverflowPlaceHolder : IDocumentMapItem, IOverflowItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOverflowPlaceHolder Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IOverflowPlaceHolder Interface Members

[image]
ActiveReports 19 .NET Edition
IOverflowPlaceHolder Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowPlaceHolder Interface

Glossary Item Box

The following tables list the members exposed by IOverflowPlaceHolder.

See Also

Reference

IOverflowPlaceHolder Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPage Interface

[image]
ActiveReports 19 .NET Edition
IPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPage Interface

Glossary Item Box

Represents the Page object of a Fixed Page report.

Syntax

Visual Basic (Declaration)
Public Interface IPage
   Inherits IRenderComponent, IReportItemContainer, IToggleReceiver
C#
public interface IPage : IRenderComponent, IReportItemContainer, IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPage Interface Members

[image]
ActiveReports 19 .NET Edition
IPage Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPage Interface

Glossary Item Box

The following tables list the members exposed by IPage.

Public Properties

 | Name | Description
Property | ThrowIfPlaceHoldersEmpty | Gets a value indicating whether the page should be thrown if placeholders are empty.
Top

See Also

Reference

IPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPage Interface Properties

[image]
ActiveReports 19 .NET Edition
IPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPage Interface

Glossary Item Box

For a list of all members of this type, see IPage members.

Public Properties

 | Name | Description
Property | ThrowIfPlaceHoldersEmpty | Gets a value indicating whether the page should be thrown if placeholders are empty.
Top

See Also

Reference

IPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ThrowIfPlaceHoldersEmpty Property

[image]
ActiveReports 19 .NET Edition
ThrowIfPlaceHoldersEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPage Interface : ThrowIfPlaceHoldersEmpty Property

Glossary Item Box

Gets a value indicating whether the page should be thrown if placeholders are empty.

Syntax

Visual Basic (Declaration)
ReadOnly Property ThrowIfPlaceHoldersEmpty As Boolean
C#
bool ThrowIfPlaceHoldersEmpty {get;}

Property Value

A System.Boolean value. true if the page should be thrown when placeholders are empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Interface
IPage Members


IPageNameProvider Interface

[image]
ActiveReports 19 .NET Edition
IPageNameProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageNameProvider Interface

Glossary Item Box

Gets sheet page name for Excel export.

Syntax

Visual Basic (Declaration)
Public Interface IPageNameProvider
C#
public interface IPageNameProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageNameProvider Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageNameProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IPageNameProvider Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageNameProvider Interface

Glossary Item Box

The following tables list the members exposed by IPageNameProvider.

Public Properties

 | Name | Description
Property | PageName | Gets sheet page name if available.
Top

See Also

Reference

IPageNameProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageNameProvider Interface Properties

[image]
ActiveReports 19 .NET Edition
IPageNameProvider Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageNameProvider Interface

Glossary Item Box

For a list of all members of this type, see IPageNameProvider members.

Public Properties

 | Name | Description
Property | PageName | Gets sheet page name if available.
Top

See Also

Reference

IPageNameProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageNameProvider Interface : PageName Property

Glossary Item Box

Gets sheet page name if available.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageName As String
C#
string PageName {get;}

Property Value

Desired sheet page name or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageNameProvider Interface
IPageNameProvider Members


IPageRegion Interface

[image]
ActiveReports 19 .NET Edition
IPageRegion Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

Glossary Item Box

Represents the page region.

Syntax

Visual Basic (Declaration)
Public Interface IPageRegion
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface IPageRegion : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageRegion Interface Members

[image]
ActiveReports 19 .NET Edition
IPageRegion Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

Glossary Item Box

The following tables list the members exposed by IPageRegion.

Public Properties

 | Name | Description
Property | EndSection | Gets the value specifying where the layout should continue.
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region.
Top

See Also

Reference

IPageRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageRegion Interface Properties

[image]
ActiveReports 19 .NET Edition
IPageRegion Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

Glossary Item Box

For a list of all members of this type, see IPageRegion members.

Public Properties

 | Name | Description
Property | EndSection | Gets the value specifying where the layout should continue.
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region.
Top

See Also

Reference

IPageRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : EndSection Property

Glossary Item Box

Gets the value specifying where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An EndSection value specifying where the layout should continue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageRegion Interface
IPageRegion Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : PageBreakAtEnd Property

Glossary Item Box

Gets a value indicating whether the page should break at the end of the region.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreakAtEnd As Boolean
C#
bool PageBreakAtEnd {get;}

Property Value

A System.Boolean value. true if the page should break at the end of the region; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageRegion Interface
IPageRegion Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : PageBreakAtStart Property

Glossary Item Box

Gets a value indicating whether the page should break at the start of the region.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreakAtStart As Boolean
C#
bool PageBreakAtStart {get;}

Property Value

A System.Boolean value. true if the page should break at the start of the region; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageRegion Interface
IPageRegion Members


IPageSection Interface

[image]
ActiveReports 19 .NET Edition
IPageSection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface

Glossary Item Box

Represents an interface for page section.

Syntax

Visual Basic (Declaration)
Public Interface IPageSection
   Inherits IReportItemContainer
C#
public interface IPageSection : IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageSection Interface Members

[image]
ActiveReports 19 .NET Edition
IPageSection Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface

Glossary Item Box

The following tables list the members exposed by IPageSection.

Public Properties

 | Name | Description
Property | Height | Gets the height of the page header/footer section.
Property | PrintOnFirstPage | Gets a value indicating whether the page header/footer should be printed on the first page.
Property | PrintOnLastPage | Gets a value indicating whether the page header/footer should be printed on the last page.
Property | Style | Gets the style of this IPageSection.
Top

See Also

Reference

IPageSection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageSection Interface Properties

[image]
ActiveReports 19 .NET Edition
IPageSection Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface

Glossary Item Box

For a list of all members of this type, see IPageSection members.

Public Properties

 | Name | Description
Property | Height | Gets the height of the page header/footer section.
Property | PrintOnFirstPage | Gets a value indicating whether the page header/footer should be printed on the first page.
Property | PrintOnLastPage | Gets a value indicating whether the page header/footer should be printed on the last page.
Property | Style | Gets the style of this IPageSection.
Top

See Also

Reference

IPageSection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : Height Property

Glossary Item Box

Gets the height of the page header/footer section.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the page header/footer section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSection Interface
IPageSection Members


PrintOnFirstPage Property

[image]
ActiveReports 19 .NET Edition
PrintOnFirstPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : PrintOnFirstPage Property

Glossary Item Box

Gets a value indicating whether the page header/footer should be printed on the first page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintOnFirstPage As Boolean
C#
bool PrintOnFirstPage {get;}

Property Value

A System.Boolean value. true if the page header/footer should be printed on the first page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSection Interface
IPageSection Members


PrintOnLastPage Property

[image]
ActiveReports 19 .NET Edition
PrintOnLastPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : PrintOnLastPage Property

Glossary Item Box

Gets a value indicating whether the page header/footer should be printed on the last page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintOnLastPage As Boolean
C#
bool PrintOnLastPage {get;}

Property Value

A System.Boolean value. true if the page header/footer should be printed on the last page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSection Interface
IPageSection Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : Style Property

Glossary Item Box

Gets the style of this IPageSection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An IStyle representing the style of this IPageSection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageSection Interface
IPageSection Members


IRectangle Interface

[image]
ActiveReports 19 .NET Edition
IRectangle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

Glossary Item Box

Represents an interface for a rectangle report item.

Syntax

Visual Basic (Declaration)
Public Interface IRectangle
   Inherits IDocumentMapItem, IPageRegion, IRenderComponent, IReportItem, IReportItemContainer, IShape
C#
public interface IRectangle : IDocumentMapItem, IPageRegion, IRenderComponent, IReportItem, IReportItemContainer, IShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRectangle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRectangle Interface Members

[image]
ActiveReports 19 .NET Edition
IRectangle Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

Glossary Item Box

The following tables list the members exposed by IRectangle.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the rectangle should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Top

See Also

Reference

IRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRectangle Interface Properties

[image]
ActiveReports 19 .NET Edition
IRectangle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

Glossary Item Box

For a list of all members of this type, see IRectangle members.

Public Properties

 | Name | Description
Property | ConsumeWhiteSpace | Gets a value indicating whether all whitespace in the rectangle should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Top

See Also

Reference

IRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property

[image]
ActiveReports 19 .NET Edition
ConsumeWhiteSpace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRectangle Interface : ConsumeWhiteSpace Property

Glossary Item Box

Gets a value indicating whether all whitespace in the rectangle should be consumed when contents grow, rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeWhiteSpace As Boolean
C#
bool ConsumeWhiteSpace {get;}

Property Value

A System.Boolean value. true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRectangle Interface
IRectangle Members


IRenderComponent Interface

[image]
ActiveReports 19 .NET Edition
IRenderComponent Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

Glossary Item Box

Represents an interface for render component objects.

Syntax

Visual Basic (Declaration)
Public Interface IRenderComponent
C#
public interface IRenderComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderComponent Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRenderComponent Interface Members

[image]
ActiveReports 19 .NET Edition
IRenderComponent Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

Glossary Item Box

The following tables list the members exposed by IRenderComponent.

Public Properties

 | Name | Description
Property | RenderComponents | Gets a collection of render components.
Top

See Also

Reference

IRenderComponent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRenderComponent Interface Properties

[image]
ActiveReports 19 .NET Edition
IRenderComponent Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

Glossary Item Box

For a list of all members of this type, see IRenderComponent members.

Public Properties

 | Name | Description
Property | RenderComponents | Gets a collection of render components.
Top

See Also

Reference

IRenderComponent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


RenderComponents Property

[image]
ActiveReports 19 .NET Edition
RenderComponents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRenderComponent Interface : RenderComponents Property

Glossary Item Box

Gets a collection of render components.

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderComponents As IEnumerable(Of IRenderComponent)
C#
IEnumerable<IRenderComponent> RenderComponents {get;}

Property Value

An enumerable collection of IRenderComponent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderComponent Interface
IRenderComponent Members


IReport Interface

[image]
ActiveReports 19 .NET Edition
IReport Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

Glossary Item Box

Represents the interface for the Report object.

Syntax

Visual Basic (Declaration)
Public Interface IReport
C#
public interface IReport

Remarks

This interface defines the properties and methods for a report, including various settings and configurations for the report's layout, data, and rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReport Interface Members

[image]
ActiveReports 19 .NET Edition
IReport Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

Glossary Item Box

The following tables list the members exposed by IReport.

Public Properties

 | Name | Description
Property | Body | Gets a reference to the body of the report.
Property | BottomMargin | Gets the height of the bottom margin of the report.
Property | ConsumeContainerWhitespace | Gets a value indicating whether to consume all whitespace in the container when contents grow, rather than preserving the minimum whitespace between the contents and the bounds.
Property | Culture | Gets the primary language of the report.
Property | DataElementName | Gets the name of the top-level element for a report rendered using a data-oriented rendering extension (e.g., XML).
Property | DataElementStyle | Gets a value indicating whether to render textboxes as an element or as an attribute.
Property | DataSchema | Gets the namespace to use in a report rendered using a data-oriented rendering extension (e.g., XML).
Property | DataTransform | Gets the location and file name of a transformation to use with a data-oriented rendering extension (e.g., XML).
Property | EvaluationPosition | Gets the evaluation position of the report.
Property | HasSharedDataSet | Gets a value indicating whether the report has a shared data set.
Property | LeftMargin | Gets the width of the left margin of the report.
Property | LicenseLevel | Gets the license level of the report.
Property | Name | Gets the name of the report.
Property | PageFooter | Gets a reference to the page footer section of the report.
Property | PageHeader | Gets a reference to the page header section of the report.
Property | PageHeight | Gets the height of the report page.
Property | PageWidth | Gets the width of the report page.
Property | Pagination | Gets the pagination mode of the report.
Property | PaperOrientation | Gets the paper orientation of the report.
Property | RightMargin | Gets the width of the right margin of the report.
Property | StartPageNumber | Gets the page number to start the numeration with.
Property | TopMargin | Gets the height of the top margin of the report.
Property | Version | Gets a unique version number to identify the instance of the report.
Property | Width | Gets the width of the report.
Top

Public Methods

 | Name | Description
Method | GetEvaluationMessage | Gets the evaluation message for the report.
Top

See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReport Interface Methods

[image]
ActiveReports 19 .NET Edition
IReport Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

Glossary Item Box

For a list of all members of this type, see IReport members.

Public Methods

 | Name | Description
Method | GetEvaluationMessage | Gets the evaluation message for the report.
Top

See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetEvaluationMessage Method

[image]
ActiveReports 19 .NET Edition
GetEvaluationMessage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : GetEvaluationMessage Method

pro
A value indicating whether the professional evaluation message is needed.

Glossary Item Box

Gets the evaluation message for the report.

Syntax

Visual Basic (Declaration)
Function GetEvaluationMessage( _
   ByVal pro As Boolean _
) As String
C#
string GetEvaluationMessage(
   bool pro
)

Parameters

pro
A value indicating whether the professional evaluation message is needed.

Return Value

A System.String representing the evaluation message.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


IReport Interface Properties

[image]
ActiveReports 19 .NET Edition
IReport Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

Glossary Item Box

For a list of all members of this type, see IReport members.

Public Properties

 | Name | Description
Property | Body | Gets a reference to the body of the report.
Property | BottomMargin | Gets the height of the bottom margin of the report.
Property | ConsumeContainerWhitespace | Gets a value indicating whether to consume all whitespace in the container when contents grow, rather than preserving the minimum whitespace between the contents and the bounds.
Property | Culture | Gets the primary language of the report.
Property | DataElementName | Gets the name of the top-level element for a report rendered using a data-oriented rendering extension (e.g., XML).
Property | DataElementStyle | Gets a value indicating whether to render textboxes as an element or as an attribute.
Property | DataSchema | Gets the namespace to use in a report rendered using a data-oriented rendering extension (e.g., XML).
Property | DataTransform | Gets the location and file name of a transformation to use with a data-oriented rendering extension (e.g., XML).
Property | EvaluationPosition | Gets the evaluation position of the report.
Property | HasSharedDataSet | Gets a value indicating whether the report has a shared data set.
Property | LeftMargin | Gets the width of the left margin of the report.
Property | LicenseLevel | Gets the license level of the report.
Property | Name | Gets the name of the report.
Property | PageFooter | Gets a reference to the page footer section of the report.
Property | PageHeader | Gets a reference to the page header section of the report.
Property | PageHeight | Gets the height of the report page.
Property | PageWidth | Gets the width of the report page.
Property | Pagination | Gets the pagination mode of the report.
Property | PaperOrientation | Gets the paper orientation of the report.
Property | RightMargin | Gets the width of the right margin of the report.
Property | StartPageNumber | Gets the page number to start the numeration with.
Property | TopMargin | Gets the height of the top margin of the report.
Property | Version | Gets a unique version number to identify the instance of the report.
Property | Width | Gets the width of the report.
Top

See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Body Property

Glossary Item Box

Gets a reference to the body of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Body As IBody
C#
IBody Body {get;}

Property Value

An IBody representing the body of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : BottomMargin Property

Glossary Item Box

Gets the height of the bottom margin of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomMargin As Length
C#
Length BottomMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the bottom margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


ConsumeContainerWhitespace Property

[image]
ActiveReports 19 .NET Edition
ConsumeContainerWhitespace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : ConsumeContainerWhitespace Property

Glossary Item Box

Gets a value indicating whether to consume all whitespace in the container when contents grow, rather than preserving the minimum whitespace between the contents and the bounds.

Syntax

Visual Basic (Declaration)
ReadOnly Property ConsumeContainerWhitespace As Boolean
C#
bool ConsumeContainerWhitespace {get;}

Property Value

true if all whitespace should be consumed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Culture Property

Glossary Item Box

Gets the primary language of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Culture As CultureInfo
C#
CultureInfo Culture {get;}

Property Value

A System.Globalization.CultureInfo representing the primary language of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataElementName Property

Glossary Item Box

Gets the name of the top-level element for a report rendered using a data-oriented rendering extension (e.g., XML).

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name of the top-level element in the rendered report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


DataElementStyle Property

[image]
ActiveReports 19 .NET Edition
DataElementStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataElementStyle Property

Glossary Item Box

Gets a value indicating whether to render textboxes as an element or as an attribute.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementStyle As DataElementStyle
C#
DataElementStyle DataElementStyle {get;}

Property Value

A DataElementStyle value indicating whether textboxes should be rendered as elements or attributes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


DataSchema Property

[image]
ActiveReports 19 .NET Edition
DataSchema Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataSchema Property

Glossary Item Box

Gets the namespace to use in a report rendered using a data-oriented rendering extension (e.g., XML).

Syntax

Visual Basic (Declaration)
ReadOnly Property DataSchema As String
C#
string DataSchema {get;}

Property Value

A System.String representing the namespace for the data-oriented rendering extension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


DataTransform Property

[image]
ActiveReports 19 .NET Edition
DataTransform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataTransform Property

Glossary Item Box

Gets the location and file name of a transformation to use with a data-oriented rendering extension (e.g., XML).

Syntax

Visual Basic (Declaration)
ReadOnly Property DataTransform As String
C#
string DataTransform {get;}

Property Value

A System.String representing the location and file name of the data transformation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


EvaluationPosition Property

[image]
ActiveReports 19 .NET Edition
EvaluationPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : EvaluationPosition Property

Glossary Item Box

Gets the evaluation position of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property EvaluationPosition As EvalPosition
C#
EvalPosition EvaluationPosition {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Layout.EvalPosition representing the evaluation position of the report.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


HasSharedDataSet Property

[image]
ActiveReports 19 .NET Edition
HasSharedDataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : HasSharedDataSet Property

Glossary Item Box

Gets a value indicating whether the report has a shared data set.

Syntax

Visual Basic (Declaration)
ReadOnly Property HasSharedDataSet As Boolean
C#
bool HasSharedDataSet {get;}

Property Value

true if the report has a shared data set; otherwise, false.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : LeftMargin Property

Glossary Item Box

Gets the width of the left margin of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftMargin As Length
C#
Length LeftMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the left margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


LicenseLevel Property

[image]
ActiveReports 19 .NET Edition
LicenseLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : LicenseLevel Property

Glossary Item Box

Gets the license level of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property LicenseLevel As LicenseLevel
C#
LicenseLevel LicenseLevel {get;}

Property Value

A LicenseLevel representing the license level of the report.

Remarks

This property should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Name Property

Glossary Item Box

Gets the name of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the name of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


PageFooter Property

[image]
ActiveReports 19 .NET Edition
PageFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageFooter Property

Glossary Item Box

Gets a reference to the page footer section of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageFooter As IPageSection
C#
IPageSection PageFooter {get;}

Property Value

An IPageSection representing the page footer section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


PageHeader Property

[image]
ActiveReports 19 .NET Edition
PageHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageHeader Property

Glossary Item Box

Gets a reference to the page header section of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageHeader As IPageSection
C#
IPageSection PageHeader {get;}

Property Value

An IPageSection representing the page header section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


PageHeight Property

[image]
ActiveReports 19 .NET Edition
PageHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageHeight Property

Glossary Item Box

Gets the height of the report page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageHeight As Length
C#
Length PageHeight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


PageWidth Property

[image]
ActiveReports 19 .NET Edition
PageWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageWidth Property

Glossary Item Box

Gets the width of the report page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageWidth As Length
C#
Length PageWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the report page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


Pagination Property

[image]
ActiveReports 19 .NET Edition
Pagination Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Pagination Property

Glossary Item Box

Gets the pagination mode of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pagination As Pagination
C#
Pagination Pagination {get;}

Property Value

A Pagination value representing the pagination mode of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


PaperOrientation Property

[image]
ActiveReports 19 .NET Edition
PaperOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PaperOrientation Property

Glossary Item Box

Gets the paper orientation of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaperOrientation As PaperOrientation
C#
PaperOrientation PaperOrientation {get;}

Property Value

A PaperOrientation value representing the paper orientation of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : RightMargin Property

Glossary Item Box

Gets the width of the right margin of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightMargin As Length
C#
Length RightMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the right margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


StartPageNumber Property

[image]
ActiveReports 19 .NET Edition
StartPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : StartPageNumber Property

Glossary Item Box

Gets the page number to start the numeration with.

Syntax

Visual Basic (Declaration)
ReadOnly Property StartPageNumber As Integer
C#
int StartPageNumber {get;}

Property Value

An System.Int32 representing the page number to start the numeration with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : TopMargin Property

Glossary Item Box

Gets the height of the top margin of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopMargin As Length
C#
Length TopMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of the top margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


Version Property

[image]
ActiveReports 19 .NET Edition
Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Version Property

Glossary Item Box

Gets a unique version number to identify the instance of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Version As String
C#
string Version {get;}

Property Value

A System.String representing a unique version number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Width Property

Glossary Item Box

Gets the width of the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReport Interface
IReport Members


IReportItem Interface

[image]
ActiveReports 19 .NET Edition
IReportItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

Glossary Item Box

Represents an interface for report item objects.

Syntax

Visual Basic (Declaration)
Public Interface IReportItem
   Inherits IDocumentMapItem, IRenderComponent
C#
public interface IReportItem : IDocumentMapItem, IRenderComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItem Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

Glossary Item Box

The following tables list the members exposed by IReportItem.

Public Properties

 | Name | Description
Property | Action | Gets the Action object of this report item.
Property | Bookmark | Gets a bookmark that can be linked to via a Bookmark action.
Property | DataElementName | Gets the name to use for the data element or attribute for this report item when rendered via a data-oriented rendering extension (e.g., XML).
Property | DataElementOutput | Gets a value indicating how this item should appear when rendered with a data-oriented rendering device.
Property | Height | Gets the height of the item.
Property | Hidden | Gets a value indicating whether this report item should be hidden.
Property | IsDynamicallyHidden | Gets a value indicating whether this item has dynamic visibility and is hidden.
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Property | Left | Gets the distance of the item from the left of the containing object.
Property | Name | Gets the name of this report item.
Property | Style | Gets the style of the report item.
Property | StyleName | Gets the style name of the report item.
Property | TargetDevice | Gets the target device kind for this report item.
Property | ToggleItem | Gets a report item that users can click to toggle the visibility of this item.
Property | ToolTip | Gets a textual label for the item.
Property | Top | Gets the distance of the item from the top of the containing object.
Property | Width | Gets the width of the item.
Property | ZIndex | Gets the drawing order of the report item within the containing object.
Top

Public Methods

 | Name | Description
Method | Initialize | Initializes the report item.
Method | OnClick | Handles the OnClick event for the report item.
Top

See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItem Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportItem Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

Glossary Item Box

For a list of all members of this type, see IReportItem members.

Public Methods

 | Name | Description
Method | Initialize | Initializes the report item.
Method | OnClick | Handles the OnClick event for the report item.
Top

See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Initialize Method

[image]
ActiveReports 19 .NET Edition
Initialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Initialize Method

dataContext
The data context associated with this report item.
properties
The property bag associated with this report item.

Glossary Item Box

Initializes the report item.

Syntax

Visual Basic (Declaration)
Sub Initialize( _
   ByVal dataContext As IDataScope, _
   ByVal properties As IPropertyBag _
)
C#
void Initialize(
   IDataScope dataContext,
   IPropertyBag properties
)

Parameters

dataContext
The data context associated with this report item.
properties
The property bag associated with this report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


OnClick Method

[image]
ActiveReports 19 .NET Edition
OnClick Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OnClick Method

reportItem
The report item that was clicked.
xPosition
The x position of the click.
yPosition
The y position of the click.
imageMapId
The image map ID.
button
The button that was clicked.

Glossary Item Box

Handles the OnClick event for the report item.

Syntax

Visual Basic (Declaration)
Function OnClick( _
   ByVal reportItem As IReportItem, _
   ByVal xPosition As Integer, _
   ByVal yPosition As Integer, _
   ByVal imageMapId As String, _
   ByVal button As MouseButton _
) As ChangeResult
C#
ChangeResult OnClick(
   IReportItem reportItem,
   int xPosition,
   int yPosition,
   string imageMapId,
   MouseButton button
)

Parameters

reportItem
The report item that was clicked.
xPosition
The x position of the click.
yPosition
The y position of the click.
imageMapId
The image map ID.
button
The button that was clicked.

Return Value

The result of the click event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


IReportItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

Glossary Item Box

For a list of all members of this type, see IReportItem members.

Public Properties

 | Name | Description
Property | Action | Gets the Action object of this report item.
Property | Bookmark | Gets a bookmark that can be linked to via a Bookmark action.
Property | DataElementName | Gets the name to use for the data element or attribute for this report item when rendered via a data-oriented rendering extension (e.g., XML).
Property | DataElementOutput | Gets a value indicating how this item should appear when rendered with a data-oriented rendering device.
Property | Height | Gets the height of the item.
Property | Hidden | Gets a value indicating whether this report item should be hidden.
Property | IsDynamicallyHidden | Gets a value indicating whether this item has dynamic visibility and is hidden.
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Property | Left | Gets the distance of the item from the left of the containing object.
Property | Name | Gets the name of this report item.
Property | Style | Gets the style of the report item.
Property | StyleName | Gets the style name of the report item.
Property | TargetDevice | Gets the target device kind for this report item.
Property | ToggleItem | Gets a report item that users can click to toggle the visibility of this item.
Property | ToolTip | Gets a textual label for the item.
Property | Top | Gets the distance of the item from the top of the containing object.
Property | Width | Gets the width of the item.
Property | ZIndex | Gets the drawing order of the report item within the containing object.
Top

See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Action Property

Glossary Item Box

Gets the Action object of this report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

An IAction representing the action associated with the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Bookmark Property

Glossary Item Box

Gets a bookmark that can be linked to via a Bookmark action.

Syntax

Visual Basic (Declaration)
ReadOnly Property Bookmark As String
C#
string Bookmark {get;}

Property Value

A System.String representing the bookmark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : DataElementName Property

Glossary Item Box

Gets the name to use for the data element or attribute for this report item when rendered via a data-oriented rendering extension (e.g., XML).

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the data element name.

Remarks

By default, this is the name of this report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : DataElementOutput Property

Glossary Item Box

Gets a value indicating how this item should appear when rendered with a data-oriented rendering device.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value indicating how this item should appear in data-oriented rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Height Property

Glossary Item Box

Gets the height of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether this report item should be hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the report item is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


IsDynamicallyHidden Property

[image]
ActiveReports 19 .NET Edition
IsDynamicallyHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : IsDynamicallyHidden Property

Glossary Item Box

Gets a value indicating whether this item has dynamic visibility and is hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDynamicallyHidden As Boolean
C#
bool IsDynamicallyHidden {get;}

Property Value

A System.Boolean value. true if the item is dynamically hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the report item is kept together on one page if possible.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepTogether As Boolean
C#
bool KeepTogether {get;}

Property Value

A System.Boolean value. true if the item is kept together on one page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Left Property

Glossary Item Box

Gets the distance of the item from the left of the containing object.

Syntax

Visual Basic (Declaration)
ReadOnly Property Left As Length
C#
Length Left {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the distance from the left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Name Property

Glossary Item Box

Gets the name of this report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

The name of this report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Style Property

Glossary Item Box

Gets the style of the report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An IStyle representing the style of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


StyleName Property

[image]
ActiveReports 19 .NET Edition
StyleName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : StyleName Property

Glossary Item Box

Gets the style name of the report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleName As String
C#
string StyleName {get;}

Property Value

A System.String representing the style name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : TargetDevice Property

Glossary Item Box

Gets the target device kind for this report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TargetDevice As TargetDeviceKind
C#
TargetDeviceKind TargetDevice {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.TargetDeviceKind representing the target device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


ToggleItem Property

[image]
ActiveReports 19 .NET Edition
ToggleItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ToggleItem Property

Glossary Item Box

Gets a report item that users can click to toggle the visibility of this item.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToggleItem As String
C#
string ToggleItem {get;}

Property Value

A System.String representing the toggle item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ToolTip Property

Glossary Item Box

Gets a textual label for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolTip As String
C#
string ToolTip {get;}

Property Value

A System.String representing the tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Top Property

Glossary Item Box

Gets the distance of the item from the top of the containing object.

Syntax

Visual Basic (Declaration)
ReadOnly Property Top As Length
C#
Length Top {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the distance from the top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Width Property

Glossary Item Box

Gets the width of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


ZIndex Property

[image]
ActiveReports 19 .NET Edition
ZIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ZIndex Property

Glossary Item Box

Gets the drawing order of the report item within the containing object.

Syntax

Visual Basic (Declaration)
ReadOnly Property ZIndex As Integer
C#
int ZIndex {get;}

Property Value

An System.Int32 representing the drawing order (z-index).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItem Interface
IReportItem Members


IReportItemContainer Interface

[image]
ActiveReports 19 .NET Edition
IReportItemContainer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface

Glossary Item Box

Represents a container of IReportItem objects.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemContainer
C#
public interface IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemContainer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemContainer Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemContainer Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface

Glossary Item Box

The following tables list the members exposed by IReportItemContainer.

Public Properties

 | Name | Description
Property | ReportItems | Gets the IReportItem objects in this container.
Top

See Also

Reference

IReportItemContainer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemContainer Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportItemContainer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface

Glossary Item Box

For a list of all members of this type, see IReportItemContainer members.

Public Properties

 | Name | Description
Property | ReportItems | Gets the IReportItem objects in this container.
Top

See Also

Reference

IReportItemContainer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ReportItems Property

[image]
ActiveReports 19 .NET Edition
ReportItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItemContainer Interface : ReportItems Property

Glossary Item Box

Gets the IReportItem objects in this container.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItems As IEnumerable(Of IReportItem)
C#
IEnumerable<IReportItem> ReportItems {get;}

Property Value

An IEnumerable containing the report items in this container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemContainer Interface
IReportItemContainer Members


IReportItemRenderInfo Interface

[image]
ActiveReports 19 .NET Edition
IReportItemRenderInfo Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemRenderInfo Interface

Glossary Item Box

Represents a report item which has a unique key. The key can be used in dictionaries.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemRenderInfo
C#
public interface IReportItemRenderInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemRenderInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemRenderInfo Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemRenderInfo Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemRenderInfo Interface

Glossary Item Box

The following tables list the members exposed by IReportItemRenderInfo.

Public Properties

 | Name | Description
Property | HasRenderTimeExpressions | Gets a value indicating whether the report item definition contains expressions which refer to render-time context (themes, page level expressions, etc.).
Property | Key | Gets the unique key of the report item in the render tree.
Top

See Also

Reference

IReportItemRenderInfo Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemRenderInfo Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportItemRenderInfo Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemRenderInfo Interface

Glossary Item Box

For a list of all members of this type, see IReportItemRenderInfo members.

Public Properties

 | Name | Description
Property | HasRenderTimeExpressions | Gets a value indicating whether the report item definition contains expressions which refer to render-time context (themes, page level expressions, etc.).
Property | Key | Gets the unique key of the report item in the render tree.
Top

See Also

Reference

IReportItemRenderInfo Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


HasRenderTimeExpressions Property

[image]
ActiveReports 19 .NET Edition
HasRenderTimeExpressions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItemRenderInfo Interface : HasRenderTimeExpressions Property

Glossary Item Box

Gets a value indicating whether the report item definition contains expressions which refer to render-time context (themes, page level expressions, etc.).

Syntax

Visual Basic (Declaration)
ReadOnly Property HasRenderTimeExpressions As Boolean
C#
bool HasRenderTimeExpressions {get;}

Property Value

A System.Boolean value. true if the report item definition contains expressions which refer to render-time context; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemRenderInfo Interface
IReportItemRenderInfo Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItemRenderInfo Interface : Key Property

Glossary Item Box

Gets the unique key of the report item in the render tree.

Syntax

Visual Basic (Declaration)
ReadOnly Property Key As ReportItemKey
C#
ReportItemKey Key {get;}

Property Value

The unique GrapeCity.ActiveReports.Rendering.Components.ReportItemKey of the report item in the render tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemRenderInfo Interface
IReportItemRenderInfo Members


IRoundingRadius Interface

[image]
ActiveReports 19 .NET Edition
IRoundingRadius Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface

Glossary Item Box

Represents the radius of a rounded rectangle.

Syntax

Visual Basic (Declaration)
Public Interface IRoundingRadius
C#
public interface IRoundingRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRoundingRadius Interface Members

[image]
ActiveReports 19 .NET Edition
IRoundingRadius Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface

Glossary Item Box

The following tables list the members exposed by IRoundingRadius.

Public Properties

 | Name | Description
Property | BottomLeft | Gets the bottom left radius of the rounded rectangle.
Property | BottomRight | Gets the bottom right radius of the rounded rectangle.
Property | Default | Gets the default radius of the rounded rectangle.
Property | TopLeft | Gets the top left radius of the rounded rectangle.
Property | TopRight | Gets the top right radius of the rounded rectangle.
Top

See Also

Reference

IRoundingRadius Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRoundingRadius Interface Properties

[image]
ActiveReports 19 .NET Edition
IRoundingRadius Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface

Glossary Item Box

For a list of all members of this type, see IRoundingRadius members.

Public Properties

 | Name | Description
Property | BottomLeft | Gets the bottom left radius of the rounded rectangle.
Property | BottomRight | Gets the bottom right radius of the rounded rectangle.
Property | Default | Gets the default radius of the rounded rectangle.
Property | TopLeft | Gets the top left radius of the rounded rectangle.
Property | TopRight | Gets the top right radius of the rounded rectangle.
Top

See Also

Reference

IRoundingRadius Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BottomLeft Property

[image]
ActiveReports 19 .NET Edition
BottomLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : BottomLeft Property

Glossary Item Box

Gets the bottom left radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomLeft As Length
C#
Length BottomLeft {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the bottom left radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


BottomRight Property

[image]
ActiveReports 19 .NET Edition
BottomRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : BottomRight Property

Glossary Item Box

Gets the bottom right radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomRight As Length
C#
Length BottomRight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the bottom right radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


Default Property

[image]
ActiveReports 19 .NET Edition
Default Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : Default Property

Glossary Item Box

Gets the default radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property Default As Length
C#
Length Default {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the default radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


TopLeft Property

[image]
ActiveReports 19 .NET Edition
TopLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : TopLeft Property

Glossary Item Box

Gets the top left radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopLeft As Length
C#
Length TopLeft {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the top left radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


TopRight Property

[image]
ActiveReports 19 .NET Edition
TopRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : TopRight Property

Glossary Item Box

Gets the top right radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopRight As Length
C#
Length TopRight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the top right radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


IScrollableRectangle Interface

[image]
ActiveReports 19 .NET Edition
IScrollableRectangle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IScrollableRectangle Interface

Glossary Item Box

Represents an interface for a scrollable rectangle.

Syntax

Visual Basic (Declaration)
Public Interface IScrollableRectangle
C#
public interface IScrollableRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScrollableRectangle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IScrollableRectangle Interface Members

[image]
ActiveReports 19 .NET Edition
IScrollableRectangle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IScrollableRectangle Interface

Glossary Item Box

The following tables list the members exposed by IScrollableRectangle.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether the container can grow when the size of its content is greater than the size of the container.
Property | Overflow | Gets a value indicating how content that is larger than the container should be handled.
Top

See Also

Reference

IScrollableRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IScrollableRectangle Interface Properties

[image]
ActiveReports 19 .NET Edition
IScrollableRectangle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IScrollableRectangle Interface

Glossary Item Box

For a list of all members of this type, see IScrollableRectangle members.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether the container can grow when the size of its content is greater than the size of the container.
Property | Overflow | Gets a value indicating how content that is larger than the container should be handled.
Top

See Also

Reference

IScrollableRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IScrollableRectangle Interface : CanGrow Property

Glossary Item Box

Gets a value indicating whether the container can grow when the size of its content is greater than the size of the container.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanGrow As Boolean
C#
bool CanGrow {get;}

Property Value

A System.Boolean value. This property is obsolete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScrollableRectangle Interface
IScrollableRectangle Members


Overflow Property

[image]
ActiveReports 19 .NET Edition
Overflow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IScrollableRectangle Interface : Overflow Property

Glossary Item Box

Gets a value indicating how content that is larger than the container should be handled.

Syntax

Visual Basic (Declaration)
ReadOnly Property Overflow As Overflow
C#
Overflow Overflow {get;}

Property Value

An Overflow value specifying how to handle content larger than the container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScrollableRectangle Interface
IScrollableRectangle Members


ISectionRegion Interface

[image]
ActiveReports 19 .NET Edition
ISectionRegion Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface

Glossary Item Box

Represents an umbrella interface to unify IDataRegion and IBandedList data regions.

Syntax

Visual Basic (Declaration)
Public Interface ISectionRegion
C#
public interface ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISectionRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISectionRegion Interface Members

[image]
ActiveReports 19 .NET Edition
ISectionRegion Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface

Glossary Item Box

The following tables list the members exposed by ISectionRegion.

Public Properties

 | Name | Description
Property | NewSection | Gets a value indicating whether the region is in its own section.
Top

See Also

Reference

ISectionRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISectionRegion Interface Properties

[image]
ActiveReports 19 .NET Edition
ISectionRegion Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface

Glossary Item Box

For a list of all members of this type, see ISectionRegion members.

Public Properties

 | Name | Description
Property | NewSection | Gets a value indicating whether the region is in its own section.
Top

See Also

Reference

ISectionRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISectionRegion Interface : NewSection Property

Glossary Item Box

Gets a value indicating whether the region is in its own section.

Syntax

Visual Basic (Declaration)
ReadOnly Property NewSection As Boolean
C#
bool NewSection {get;}

Property Value

A System.Boolean value. true if the region is in its own section; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISectionRegion Interface
ISectionRegion Members


IShape Interface

[image]
ActiveReports 19 .NET Edition
IShape Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

Glossary Item Box

Represents an interface for a shape report item.

Syntax

Visual Basic (Declaration)
Public Interface IShape
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface IShape : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IShape Interface Members

[image]
ActiveReports 19 .NET Edition
IShape Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

Glossary Item Box

The following tables list the members exposed by IShape.

Public Properties

 | Name | Description
Property | RoundingRadius | Gets the radius of the rounded rectangle.
Property | ShapeStyle | Gets the style of the shape.
Top

See Also

Reference

IShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IShape Interface Properties

[image]
ActiveReports 19 .NET Edition
IShape Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

Glossary Item Box

For a list of all members of this type, see IShape members.

Public Properties

 | Name | Description
Property | RoundingRadius | Gets the radius of the rounded rectangle.
Property | ShapeStyle | Gets the style of the shape.
Top

See Also

Reference

IShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


RoundingRadius Property

[image]
ActiveReports 19 .NET Edition
RoundingRadius Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IShape Interface : RoundingRadius Property

Glossary Item Box

Gets the radius of the rounded rectangle.

Syntax

Visual Basic (Declaration)
ReadOnly Property RoundingRadius As IRoundingRadius
C#
IRoundingRadius RoundingRadius {get;}

Property Value

An IRoundingRadius specifying the radius of the rounded rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IShape Interface
IShape Members


ShapeStyle Property

[image]
ActiveReports 19 .NET Edition
ShapeStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IShape Interface : ShapeStyle Property

Glossary Item Box

Gets the style of the shape.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShapeStyle As ShapeStyle
C#
ShapeStyle ShapeStyle {get;}

Property Value

A ShapeStyle specifying the style of the shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IShape Interface
IShape Members


ISortingController Interface

[image]
ActiveReports 19 .NET Edition
ISortingController Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISortingController Interface

Glossary Item Box

Interface for report item that can force data sorting at rendering time.

Syntax

Visual Basic (Declaration)
Public Interface ISortingController
C#
public interface ISortingController

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortingController Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISortingController Interface Members

[image]
ActiveReports 19 .NET Edition
ISortingController Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISortingController Interface

Glossary Item Box

The following tables list the members exposed by ISortingController.

Public Properties

 | Name | Description
Property | ActionKey | Specifies the current item sort action.
Property | CanSort | Specifies if the current item can force data sorting.
Property | SortTargetState | Gets the current state of sort target.
Top

See Also

Reference

ISortingController Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISortingController Interface Properties

[image]
ActiveReports 19 .NET Edition
ISortingController Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISortingController Interface

Glossary Item Box

For a list of all members of this type, see ISortingController members.

Public Properties

 | Name | Description
Property | ActionKey | Specifies the current item sort action.
Property | CanSort | Specifies if the current item can force data sorting.
Property | SortTargetState | Gets the current state of sort target.
Top

See Also

Reference

ISortingController Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ActionKey Property

[image]
ActiveReports 19 .NET Edition
ActionKey Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISortingController Interface : ActionKey Property

Glossary Item Box

Specifies the current item sort action.

Syntax

Visual Basic (Declaration)
ReadOnly Property ActionKey As String
C#
string ActionKey {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortingController Interface
ISortingController Members


CanSort Property

[image]
ActiveReports 19 .NET Edition
CanSort Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISortingController Interface : CanSort Property

Glossary Item Box

Specifies if the current item can force data sorting.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanSort As Boolean
C#
bool CanSort {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortingController Interface
ISortingController Members


SortTargetState Property

[image]
ActiveReports 19 .NET Edition
SortTargetState Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISortingController Interface : SortTargetState Property

Glossary Item Box

Gets the current state of sort target.

Syntax

Visual Basic (Declaration)
ReadOnly Property SortTargetState As SortState
C#
SortState SortTargetState {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortingController Interface
ISortingController Members


IStaticable Interface

[image]
ActiveReports 19 .NET Edition
IStaticable Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticable Interface

Glossary Item Box

This interface is used to determine if all expressions within an implementing class are constant.

Syntax

Visual Basic (Declaration)
Public Interface IStaticable
C#
public interface IStaticable

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticable Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStaticable Interface Members

[image]
ActiveReports 19 .NET Edition
IStaticable Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticable Interface

Glossary Item Box

The following tables list the members exposed by IStaticable.

Public Properties

 | Name | Description
Property | IsStatic | Returns true if all expressions are constant.
Top

See Also

Reference

IStaticable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStaticable Interface Properties

[image]
ActiveReports 19 .NET Edition
IStaticable Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticable Interface

Glossary Item Box

For a list of all members of this type, see IStaticable members.

Public Properties

 | Name | Description
Property | IsStatic | Returns true if all expressions are constant.
Top

See Also

Reference

IStaticable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStaticable Interface : IsStatic Property

Glossary Item Box

Returns true if all expressions are constant.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticable Interface
IStaticable Members


IStaticItem Interface

[image]
ActiveReports 19 .NET Edition
IStaticItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface

Glossary Item Box

Represents a static report item with static content.

Syntax

Visual Basic (Declaration)
Public Interface IStaticItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface IStaticItem : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStaticItem Interface Members

[image]
ActiveReports 19 .NET Edition
IStaticItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface

Glossary Item Box

The following tables list the members exposed by IStaticItem.

See Also

Reference

IStaticItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface

[image]
ActiveReports 19 .NET Edition
IStyle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface

Glossary Item Box

Represents an interface for the Style object.

Syntax

Visual Basic (Declaration)
Public Interface IStyle
C#
public interface IStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface Members

[image]
ActiveReports 19 .NET Edition
IStyle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface

Glossary Item Box

The following tables list the members exposed by IStyle.

Public Properties

 | Name | Description
Property | Angle | Gets the text output angle.
Property | BackgroundColor | Gets the color of the background.
Property | BackgroundGradientEndColor | Gets the secondary color for gradient fill.
Property | BackgroundGradientType | Gets the gradient type of the background.
Property | BackgroundImage | Gets a stream with the background image for this report item.
Property | BackgroundImageMimeType | Gets the MIME type of the background image.
Property | BackgroundImageSource | Gets the source of the image specified in the BackgroundImageValue.
Property | BackgroundImageValue | Gets the background image value for this report item.
Property | BackgroundRepeat | Gets the repeat style of the background.
Property | BottomBorderColor | Gets the color of the bottom border of the item.
Property | BottomBorderStyle | Gets the style of the bottom border of the item.
Property | BottomBorderWidth | Gets the height of the bottom border of the item.
Property | Calendar | Gets the calendar to use to format dates.
Property | CharacterSpacing | Gets the character spacing.
Property | Color | Gets the foreground color of the item.
Property | DefaultBorderColor | Gets the default color of the border.
Property | DefaultBorderStyle | Gets the default style of the border of the item.
Property | DefaultBorderWidth | Gets the default width of the border of the item.
Property | Direction | Gets the direction of text.
Property | DisplayPageNumber | Gets a value indicating whether to display the page number.
Property | FontFamily | Gets the name of the font for the item.
Property | FontSize | Gets the size of the font for the item.
Property | FontStyle | Gets the style of the font for the item.
Property | FontWeight | Gets the thickness of the font for the item.
Property | Format | Gets the .NET Framework formatting string for the item.
Property | HeadingLevel | Gets the heading level.
Property | LabelExpression | Gets the label expression.
Property | Language | Gets the primary language of the text.
Property | LeadingChar | Gets the leading character.
Property | LeftBorderColor | Gets the color of the left border of the item.
Property | LeftBorderStyle | Gets the style of the left border of the item.
Property | LeftBorderWidth | Gets the width of the left border of the item.
Property | LineHeight | Gets the height of a line of text.
Property | LineSpacing | Gets the line spacing.
Property | MaxLevel | Gets the max level depth for ToC.
Property | MinCondenseRate | Gets the low limit for character condense rate.
Property | NumeralLanguage | Gets the digit format as described by its primary language.
Property | NumeralVariant | Gets the variant of the digit format to use.
Property | PaddingBottom | Gets the amount of padding below the item.
Property | PaddingLeft | Gets the amount of padding to the left of the item.
Property | PaddingRight | Gets the amount of padding to the right of the item.
Property | PaddingTop | Gets the amount of padding above the item.
Property | RightBorderColor | Gets the color of the right border of the item.
Property | RightBorderStyle | Gets the style of the right border of the item.
Property | RightBorderWidth | Gets the width of the right border of the item.
Property | ShadowOffset | Gets the border shadow offset.
Property | ShrinkToFit | Gets a value indicating whether the content should shrink to fit.
Property | TextAlign | Gets the horizontal alignment of the text of the item.
Property | TextDecoration | Gets the text decoration for the item.
Property | TextIndent | Gets the text indent.
Property | TextJustify | Gets the text justify.
Property | TopBorderColor | Gets the color of the top border of the item.
Property | TopBorderStyle | Gets the style of the top border of the item.
Property | TopBorderWidth | Gets the width of the top border of the item.
Property | VerticalAlign | Gets the vertical alignment of the text of the item.
Property | WrapMode | Gets the wrap mode.
Property | WritingMode | Gets a value indicating whether the text is written horizontally or vertically.
Top

See Also

Reference

IStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface Properties

[image]
ActiveReports 19 .NET Edition
IStyle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface

Glossary Item Box

For a list of all members of this type, see IStyle members.

Public Properties

 | Name | Description
Property | Angle | Gets the text output angle.
Property | BackgroundColor | Gets the color of the background.
Property | BackgroundGradientEndColor | Gets the secondary color for gradient fill.
Property | BackgroundGradientType | Gets the gradient type of the background.
Property | BackgroundImage | Gets a stream with the background image for this report item.
Property | BackgroundImageMimeType | Gets the MIME type of the background image.
Property | BackgroundImageSource | Gets the source of the image specified in the BackgroundImageValue.
Property | BackgroundImageValue | Gets the background image value for this report item.
Property | BackgroundRepeat | Gets the repeat style of the background.
Property | BottomBorderColor | Gets the color of the bottom border of the item.
Property | BottomBorderStyle | Gets the style of the bottom border of the item.
Property | BottomBorderWidth | Gets the height of the bottom border of the item.
Property | Calendar | Gets the calendar to use to format dates.
Property | CharacterSpacing | Gets the character spacing.
Property | Color | Gets the foreground color of the item.
Property | DefaultBorderColor | Gets the default color of the border.
Property | DefaultBorderStyle | Gets the default style of the border of the item.
Property | DefaultBorderWidth | Gets the default width of the border of the item.
Property | Direction | Gets the direction of text.
Property | DisplayPageNumber | Gets a value indicating whether to display the page number.
Property | FontFamily | Gets the name of the font for the item.
Property | FontSize | Gets the size of the font for the item.
Property | FontStyle | Gets the style of the font for the item.
Property | FontWeight | Gets the thickness of the font for the item.
Property | Format | Gets the .NET Framework formatting string for the item.
Property | HeadingLevel | Gets the heading level.
Property | LabelExpression | Gets the label expression.
Property | Language | Gets the primary language of the text.
Property | LeadingChar | Gets the leading character.
Property | LeftBorderColor | Gets the color of the left border of the item.
Property | LeftBorderStyle | Gets the style of the left border of the item.
Property | LeftBorderWidth | Gets the width of the left border of the item.
Property | LineHeight | Gets the height of a line of text.
Property | LineSpacing | Gets the line spacing.
Property | MaxLevel | Gets the max level depth for ToC.
Property | MinCondenseRate | Gets the low limit for character condense rate.
Property | NumeralLanguage | Gets the digit format as described by its primary language.
Property | NumeralVariant | Gets the variant of the digit format to use.
Property | PaddingBottom | Gets the amount of padding below the item.
Property | PaddingLeft | Gets the amount of padding to the left of the item.
Property | PaddingRight | Gets the amount of padding to the right of the item.
Property | PaddingTop | Gets the amount of padding above the item.
Property | RightBorderColor | Gets the color of the right border of the item.
Property | RightBorderStyle | Gets the style of the right border of the item.
Property | RightBorderWidth | Gets the width of the right border of the item.
Property | ShadowOffset | Gets the border shadow offset.
Property | ShrinkToFit | Gets a value indicating whether the content should shrink to fit.
Property | TextAlign | Gets the horizontal alignment of the text of the item.
Property | TextDecoration | Gets the text decoration for the item.
Property | TextIndent | Gets the text indent.
Property | TextJustify | Gets the text justify.
Property | TopBorderColor | Gets the color of the top border of the item.
Property | TopBorderStyle | Gets the style of the top border of the item.
Property | TopBorderWidth | Gets the width of the top border of the item.
Property | VerticalAlign | Gets the vertical alignment of the text of the item.
Property | WrapMode | Gets the wrap mode.
Property | WritingMode | Gets a value indicating whether the text is written horizontally or vertically.
Top

See Also

Reference

IStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Angle Property

Glossary Item Box

Gets the text output angle.

Syntax

Visual Basic (Declaration)
ReadOnly Property Angle As Single
C#
float Angle {get;}

Property Value

A System.Single representing the text output angle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundColor Property

Glossary Item Box

Gets the color of the background.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundColor As String
C#
string BackgroundColor {get;}

Property Value

A System.String representing the background color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundGradientEndColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundGradientEndColor Property

Glossary Item Box

Gets the secondary color for gradient fill.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundGradientEndColor As String
C#
string BackgroundGradientEndColor {get;}

Property Value

A System.String representing the secondary color for gradient fill.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundGradientType Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundGradientType Property

Glossary Item Box

Gets the gradient type of the background.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundGradientType As String
C#
string BackgroundGradientType {get;}

Property Value

A System.String representing the background gradient type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundImage Property

[image]
ActiveReports 19 .NET Edition
BackgroundImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImage Property

Glossary Item Box

Gets a stream with the background image for this report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundImage As Stream
C#
Stream BackgroundImage {get;}

Property Value

A System.IO.Stream containing the background image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageMimeType Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageMimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageMimeType Property

Glossary Item Box

Gets the MIME type of the background image.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundImageMimeType As String
C#
string BackgroundImageMimeType {get;}

Property Value

A System.String representing the MIME type of the background image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageSource Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageSource Property

Glossary Item Box

Gets the source of the image specified in the BackgroundImageValue.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundImageSource As ImageSource
C#
ImageSource BackgroundImageSource {get;}

Property Value

An GrapeCity.ActiveReports.PageReportModel.ImageSource representing the source of the background image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageValue Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageValue Property

Glossary Item Box

Gets the background image value for this report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundImageValue As Object
C#
object BackgroundImageValue {get;}

Property Value

An System.Object representing the background image value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BackgroundRepeat Property

[image]
ActiveReports 19 .NET Edition
BackgroundRepeat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundRepeat Property

Glossary Item Box

Gets the repeat style of the background.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundRepeat As String
C#
string BackgroundRepeat {get;}

Property Value

A System.String representing the repeat style of the background.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BottomBorderColor Property

[image]
ActiveReports 19 .NET Edition
BottomBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderColor Property

Glossary Item Box

Gets the color of the bottom border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderColor As String
C#
string BottomBorderColor {get;}

Property Value

A System.String representing the color of the bottom border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BottomBorderStyle Property

[image]
ActiveReports 19 .NET Edition
BottomBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderStyle Property

Glossary Item Box

Gets the style of the bottom border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderStyle As String
C#
string BottomBorderStyle {get;}

Property Value

A System.String representing the style of the bottom border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


BottomBorderWidth Property

[image]
ActiveReports 19 .NET Edition
BottomBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderWidth Property

Glossary Item Box

Gets the height of the bottom border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderWidth As Length
C#
Length BottomBorderWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the bottom border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


Calendar Property

[image]
ActiveReports 19 .NET Edition
Calendar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Calendar Property

Glossary Item Box

Gets the calendar to use to format dates.

Syntax

Visual Basic (Declaration)
ReadOnly Property Calendar As String
C#
string Calendar {get;}

Property Value

A System.String representing the calendar to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : CharacterSpacing Property

Glossary Item Box

Gets the character spacing.

Syntax

Visual Basic (Declaration)
ReadOnly Property CharacterSpacing As Length
C#
Length CharacterSpacing {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the character spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Color Property

Glossary Item Box

Gets the foreground color of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Color As String
C#
string Color {get;}

Property Value

A System.String representing the foreground color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderColor Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderColor Property

Glossary Item Box

Gets the default color of the border.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultBorderColor As String
C#
string DefaultBorderColor {get;}

Property Value

A System.String representing the default border color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderStyle Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderStyle Property

Glossary Item Box

Gets the default style of the border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultBorderStyle As String
C#
string DefaultBorderStyle {get;}

Property Value

A System.String representing the default style of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderWidth Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderWidth Property

Glossary Item Box

Gets the default width of the border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultBorderWidth As Length
C#
Length DefaultBorderWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the default width of the border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Direction Property

Glossary Item Box

Gets the direction of text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Direction As String
C#
string Direction {get;}

Property Value

A System.String representing the text direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


DisplayPageNumber Property

[image]
ActiveReports 19 .NET Edition
DisplayPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DisplayPageNumber Property

Glossary Item Box

Gets a value indicating whether to display the page number.

Syntax

Visual Basic (Declaration)
ReadOnly Property DisplayPageNumber As Boolean
C#
bool DisplayPageNumber {get;}

Property Value

A System.Boolean value. true if the page number should be displayed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontFamily Property

Glossary Item Box

Gets the name of the font for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontFamily As String
C#
string FontFamily {get;}

Property Value

A System.String representing the font name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontSize Property

Glossary Item Box

Gets the size of the font for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontSize As Length
C#
Length FontSize {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the font size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontStyle Property

Glossary Item Box

Gets the style of the font for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontStyle As String
C#
string FontStyle {get;}

Property Value

A System.String representing the font style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontWeight Property

Glossary Item Box

Gets the thickness of the font for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontWeight As String
C#
string FontWeight {get;}

Property Value

A System.String representing the font weight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Format Property

Glossary Item Box

Gets the .NET Framework formatting string for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Format As String
C#
string Format {get;}

Property Value

A System.String representing the .NET Framework formatting string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


HeadingLevel Property

[image]
ActiveReports 19 .NET Edition
HeadingLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : HeadingLevel Property

Glossary Item Box

Gets the heading level.

Syntax

Visual Basic (Declaration)
ReadOnly Property HeadingLevel As Integer
C#
int HeadingLevel {get;}

Property Value

An System.Int32 representing the heading level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LabelExpression Property

[image]
ActiveReports 19 .NET Edition
LabelExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LabelExpression Property

Glossary Item Box

Gets the label expression.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelExpression As String
C#
string LabelExpression {get;}

Property Value

A System.String representing the label expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Language Property

Glossary Item Box

Gets the primary language of the text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Language As String
C#
string Language {get;}

Property Value

A System.String representing the primary language of the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeadingChar Property

Glossary Item Box

Gets the leading character.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeadingChar As String
C#
string LeadingChar {get;}

Property Value

A System.String representing the leading character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LeftBorderColor Property

[image]
ActiveReports 19 .NET Edition
LeftBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderColor Property

Glossary Item Box

Gets the color of the left border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderColor As String
C#
string LeftBorderColor {get;}

Property Value

A System.String representing the color of the left border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LeftBorderStyle Property

[image]
ActiveReports 19 .NET Edition
LeftBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderStyle Property

Glossary Item Box

Gets the style of the left border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderStyle As String
C#
string LeftBorderStyle {get;}

Property Value

A System.String representing the style of the left border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LeftBorderWidth Property

[image]
ActiveReports 19 .NET Edition
LeftBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderWidth Property

Glossary Item Box

Gets the width of the left border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderWidth As Length
C#
Length LeftBorderWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the left border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LineHeight Property

[image]
ActiveReports 19 .NET Edition
LineHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LineHeight Property

Glossary Item Box

Gets the height of a line of text.

Syntax

Visual Basic (Declaration)
ReadOnly Property LineHeight As Length
C#
Length LineHeight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the line height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LineSpacing Property

Glossary Item Box

Gets the line spacing.

Syntax

Visual Basic (Declaration)
ReadOnly Property LineSpacing As Length
C#
Length LineSpacing {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the line spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


MaxLevel Property

[image]
ActiveReports 19 .NET Edition
MaxLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : MaxLevel Property

Glossary Item Box

Gets the max level depth for ToC.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxLevel As Integer
C#
int MaxLevel {get;}

Property Value

An System.Int32 representing the max level depth for ToC.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


MinCondenseRate Property

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : MinCondenseRate Property

Glossary Item Box

Gets the low limit for character condense rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinCondenseRate As Integer
C#
int MinCondenseRate {get;}

Property Value

An System.Int32 representing the low limit for character condense rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


NumeralLanguage Property

[image]
ActiveReports 19 .NET Edition
NumeralLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : NumeralLanguage Property

Glossary Item Box

Gets the digit format as described by its primary language.

Syntax

Visual Basic (Declaration)
ReadOnly Property NumeralLanguage As String
C#
string NumeralLanguage {get;}

Property Value

A System.String representing the digit format described by its primary language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


NumeralVariant Property

[image]
ActiveReports 19 .NET Edition
NumeralVariant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : NumeralVariant Property

Glossary Item Box

Gets the variant of the digit format to use.

Syntax

Visual Basic (Declaration)
ReadOnly Property NumeralVariant As Integer
C#
int NumeralVariant {get;}

Property Value

An System.Int32 representing the variant of the digit format to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


PaddingBottom Property

[image]
ActiveReports 19 .NET Edition
PaddingBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingBottom Property

Glossary Item Box

Gets the amount of padding below the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaddingBottom As Length
C#
Length PaddingBottom {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the padding below the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


PaddingLeft Property

[image]
ActiveReports 19 .NET Edition
PaddingLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingLeft Property

Glossary Item Box

Gets the amount of padding to the left of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaddingLeft As Length
C#
Length PaddingLeft {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the padding to the left of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


PaddingRight Property

[image]
ActiveReports 19 .NET Edition
PaddingRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingRight Property

Glossary Item Box

Gets the amount of padding to the right of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaddingRight As Length
C#
Length PaddingRight {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the padding to the right of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


PaddingTop Property

[image]
ActiveReports 19 .NET Edition
PaddingTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingTop Property

Glossary Item Box

Gets the amount of padding above the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property PaddingTop As Length
C#
Length PaddingTop {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the padding above the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


RightBorderColor Property

[image]
ActiveReports 19 .NET Edition
RightBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderColor Property

Glossary Item Box

Gets the color of the right border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderColor As String
C#
string RightBorderColor {get;}

Property Value

A System.String representing the color of the right border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


RightBorderStyle Property

[image]
ActiveReports 19 .NET Edition
RightBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderStyle Property

Glossary Item Box

Gets the style of the right border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderStyle As String
C#
string RightBorderStyle {get;}

Property Value

A System.String representing the style of the right border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


RightBorderWidth Property

[image]
ActiveReports 19 .NET Edition
RightBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderWidth Property

Glossary Item Box

Gets the width of the right border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderWidth As Length
C#
Length RightBorderWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the right border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


ShadowOffset Property

[image]
ActiveReports 19 .NET Edition
ShadowOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : ShadowOffset Property

Glossary Item Box

Gets the border shadow offset.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShadowOffset As Length
C#
Length ShadowOffset {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the border shadow offset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : ShrinkToFit Property

Glossary Item Box

Gets a value indicating whether the content should shrink to fit.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShrinkToFit As Boolean
C#
bool ShrinkToFit {get;}

Property Value

A System.Boolean value. true if the content should shrink to fit; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextAlign Property

Glossary Item Box

Gets the horizontal alignment of the text of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextAlign As String
C#
string TextAlign {get;}

Property Value

A System.String representing the horizontal text alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TextDecoration Property

[image]
ActiveReports 19 .NET Edition
TextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextDecoration Property

Glossary Item Box

Gets the text decoration for the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextDecoration As String
C#
string TextDecoration {get;}

Property Value

A System.String representing the text decoration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TextIndent Property

[image]
ActiveReports 19 .NET Edition
TextIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextIndent Property

Glossary Item Box

Gets the text indent.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextIndent As Length
C#
Length TextIndent {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the text indent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextJustify Property

Glossary Item Box

Gets the text justify.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextJustify As String
C#
string TextJustify {get;}

Property Value

A System.String representing the text justification.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TopBorderColor Property

[image]
ActiveReports 19 .NET Edition
TopBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderColor Property

Glossary Item Box

Gets the color of the top border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderColor As String
C#
string TopBorderColor {get;}

Property Value

A System.String representing the color of the top border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TopBorderStyle Property

[image]
ActiveReports 19 .NET Edition
TopBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderStyle Property

Glossary Item Box

Gets the style of the top border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderStyle As String
C#
string TopBorderStyle {get;}

Property Value

A System.String representing the style of the top border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


TopBorderWidth Property

[image]
ActiveReports 19 .NET Edition
TopBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderWidth Property

Glossary Item Box

Gets the width of the top border of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderWidth As Length
C#
Length TopBorderWidth {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the top border.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : VerticalAlign Property

Glossary Item Box

Gets the vertical alignment of the text of the item.

Syntax

Visual Basic (Declaration)
ReadOnly Property VerticalAlign As String
C#
string VerticalAlign {get;}

Property Value

A System.String representing the vertical text alignment.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : WrapMode Property

Glossary Item Box

Gets the wrap mode.

Syntax

Visual Basic (Declaration)
ReadOnly Property WrapMode As String
C#
string WrapMode {get;}

Property Value

A System.String representing the wrap mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


WritingMode Property

[image]
ActiveReports 19 .NET Edition
WritingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : WritingMode Property

Glossary Item Box

Gets a value indicating whether the text is written horizontally or vertically.

Syntax

Visual Basic (Declaration)
ReadOnly Property WritingMode As String
C#
string WritingMode {get;}

Property Value

A System.String indicating the writing mode (horizontal or vertical).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyle Interface
IStyle Members


IStyleExtended Interface

[image]
ActiveReports 19 .NET Edition
IStyleExtended Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyleExtended Interface

Glossary Item Box

Represents an extended style interface.

Syntax

Visual Basic (Declaration)
Public Interface IStyleExtended
   Inherits IStyle, IUprightTextStyle
C#
public interface IStyleExtended : IStyle, IUprightTextStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyleExtended Interface Members

[image]
ActiveReports 19 .NET Edition
IStyleExtended Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyleExtended Interface

Glossary Item Box

The following tables list the members exposed by IStyleExtended.

Public Properties

 | Name | Description
Property | BottomBorderStyleValue | Bottom border style.
Property | Culture |
Property | DefaultBorderStyleValue | Default border style.
Property | FontInfo | Gets font descriptor.
Property | IsStatic | Determines whether style is static.
Property | LeftBorderStyleValue | Left border style.
Property | NeedsFormatting |
Property | RightBorderStyleValue | Right border style.
Property | TopBorderStyleValue | Top border style.
Top

Public Methods

 | Name | Description
Method | GetStringFormat | Gets the string format.
Top

See Also

Reference

IStyleExtended Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyleExtended Interface Methods

[image]
ActiveReports 19 .NET Edition
IStyleExtended Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyleExtended Interface

Glossary Item Box

For a list of all members of this type, see IStyleExtended members.

Public Methods

 | Name | Description
Method | GetStringFormat | Gets the string format.
Top

See Also

Reference

IStyleExtended Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetStringFormat Method

[image]
ActiveReports 19 .NET Edition
GetStringFormat Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : GetStringFormat Method

boundHeight
Height of the bound.

Glossary Item Box

Gets the string format.

Syntax

Visual Basic (Declaration)
Function GetStringFormat( _
   ByVal boundHeight As Single _
) As StringFormatEx
C#
StringFormatEx GetStringFormat(
   float boundHeight
)

Parameters

boundHeight
Height of the bound.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


IStyleExtended Interface Properties

[image]
ActiveReports 19 .NET Edition
IStyleExtended Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyleExtended Interface

Glossary Item Box

For a list of all members of this type, see IStyleExtended members.

Public Properties

 | Name | Description
Property | BottomBorderStyleValue | Bottom border style.
Property | Culture |
Property | DefaultBorderStyleValue | Default border style.
Property | FontInfo | Gets font descriptor.
Property | IsStatic | Determines whether style is static.
Property | LeftBorderStyleValue | Left border style.
Property | NeedsFormatting |
Property | RightBorderStyleValue | Right border style.
Property | TopBorderStyleValue | Top border style.
Top

See Also

Reference

IStyleExtended Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BottomBorderStyleValue Property

[image]
ActiveReports 19 .NET Edition
BottomBorderStyleValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : BottomBorderStyleValue Property

Glossary Item Box

Bottom border style.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomBorderStyleValue As Nullable(Of BorderDrawingStyle)
C#
Nullable<BorderDrawingStyle> BottomBorderStyleValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


Culture Property

[image]
ActiveReports 19 .NET Edition
Culture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : Culture Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Culture As CultureInfo
C#
CultureInfo Culture {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


DefaultBorderStyleValue Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderStyleValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : DefaultBorderStyleValue Property

Glossary Item Box

Default border style.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultBorderStyleValue As BorderDrawingStyle
C#
BorderDrawingStyle DefaultBorderStyleValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


FontInfo Property

[image]
ActiveReports 19 .NET Edition
FontInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : FontInfo Property

Glossary Item Box

Gets font descriptor.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontInfo As FontInfo
C#
FontInfo FontInfo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : IsStatic Property

Glossary Item Box

Determines whether style is static.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


LeftBorderStyleValue Property

[image]
ActiveReports 19 .NET Edition
LeftBorderStyleValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : LeftBorderStyleValue Property

Glossary Item Box

Left border style.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftBorderStyleValue As Nullable(Of BorderDrawingStyle)
C#
Nullable<BorderDrawingStyle> LeftBorderStyleValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


NeedsFormatting Property

[image]
ActiveReports 19 .NET Edition
NeedsFormatting Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : NeedsFormatting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NeedsFormatting As Boolean
C#
bool NeedsFormatting {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


RightBorderStyleValue Property

[image]
ActiveReports 19 .NET Edition
RightBorderStyleValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : RightBorderStyleValue Property

Glossary Item Box

Right border style.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightBorderStyleValue As Nullable(Of BorderDrawingStyle)
C#
Nullable<BorderDrawingStyle> RightBorderStyleValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


TopBorderStyleValue Property

[image]
ActiveReports 19 .NET Edition
TopBorderStyleValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyleExtended Interface : TopBorderStyleValue Property

Glossary Item Box

Top border style.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopBorderStyleValue As Nullable(Of BorderDrawingStyle)
C#
Nullable<BorderDrawingStyle> TopBorderStyleValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleExtended Interface
IStyleExtended Members


ISubreport Interface

[image]
ActiveReports 19 .NET Edition
ISubreport Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

Glossary Item Box

Represents an interface for the subreport report item.

Syntax

Visual Basic (Declaration)
Public Interface ISubreport
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface ISubreport : IDocumentMapItem, IRenderComponent, IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISubreport Interface Members

[image]
ActiveReports 19 .NET Edition
ISubreport Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

Glossary Item Box

The following tables list the members exposed by ISubreport.

Public Properties

 | Name | Description
Property | ErrorTextBox | Gets a renderable textbox suitable for displaying an error message when the subreport is processed with an error.
Property | NoRows | Gets a value indicating if no rows of data were loaded by the subreport.
Property | NoRowsMessage | Gets the message to display in the subreport when no rows of data are available in any data set in the subreport.
Property | NoRowsTextBox | Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.
Property | PageName | Gets the string used for naming the sheet in Excel export.
Property | ProcessedWithError | Gets a value indicating if an error occurred while attempting to process the report.
Property | Report | Gets the renderable report that this subreport report item represents.
Top

See Also

Reference

ISubreport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISubreport Interface Properties

[image]
ActiveReports 19 .NET Edition
ISubreport Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

Glossary Item Box

For a list of all members of this type, see ISubreport members.

Public Properties

 | Name | Description
Property | ErrorTextBox | Gets a renderable textbox suitable for displaying an error message when the subreport is processed with an error.
Property | NoRows | Gets a value indicating if no rows of data were loaded by the subreport.
Property | NoRowsMessage | Gets the message to display in the subreport when no rows of data are available in any data set in the subreport.
Property | NoRowsTextBox | Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.
Property | PageName | Gets the string used for naming the sheet in Excel export.
Property | ProcessedWithError | Gets a value indicating if an error occurred while attempting to process the report.
Property | Report | Gets the renderable report that this subreport report item represents.
Top

See Also

Reference

ISubreport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ErrorTextBox Property

[image]
ActiveReports 19 .NET Edition
ErrorTextBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : ErrorTextBox Property

Glossary Item Box

Gets a renderable textbox suitable for displaying an error message when the subreport is processed with an error.

Syntax

Visual Basic (Declaration)
ReadOnly Property ErrorTextBox As ITextBox
C#
ITextBox ErrorTextBox {get;}

Property Value

An ITextBox suitable for displaying the error message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRows Property

Glossary Item Box

Gets a value indicating if no rows of data were loaded by the subreport.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRows As Boolean
C#
bool NoRows {get;}

Property Value

A System.Boolean value. true if no rows of data were loaded; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


NoRowsMessage Property

[image]
ActiveReports 19 .NET Edition
NoRowsMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRowsMessage Property

Glossary Item Box

Gets the message to display in the subreport when no rows of data are available in any data set in the subreport.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRowsMessage As String
C#
string NoRowsMessage {get;}

Property Value

A System.String representing the message displayed when no rows of data are available.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


NoRowsTextBox Property

[image]
ActiveReports 19 .NET Edition
NoRowsTextBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRowsTextBox Property

Glossary Item Box

Gets a renderable textbox suitable for displaying the NoRowsMessage for this instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoRowsTextBox As ITextBox
C#
ITextBox NoRowsTextBox {get;}

Property Value

An ITextBox suitable for displaying the no rows message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : PageName Property

Glossary Item Box

Gets the string used for naming the sheet in Excel export.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageName As String
C#
string PageName {get;}

Property Value

A System.String representing the sheet name in Excel export.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


ProcessedWithError Property

[image]
ActiveReports 19 .NET Edition
ProcessedWithError Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : ProcessedWithError Property

Glossary Item Box

Gets a value indicating if an error occurred while attempting to process the report.

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcessedWithError As Boolean
C#
bool ProcessedWithError {get;}

Property Value

A System.Boolean value. true if the report was processed with an error; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : Report Property

Glossary Item Box

Gets the renderable report that this subreport report item represents.

Syntax

Visual Basic (Declaration)
ReadOnly Property Report As IReport
C#
IReport Report {get;}

Property Value

An IReport representing the renderable report for this subreport.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubreport Interface
ISubreport Members


ITextBox Interface

[image]
ActiveReports 19 .NET Edition
ITextBox Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

Glossary Item Box

Represents the interface for the textbox report item.

Syntax

Visual Basic (Declaration)
Public Interface ITextBox
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
C#
public interface ITextBox : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextBox Interface Members

[image]
ActiveReports 19 .NET Edition
ITextBox Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

Glossary Item Box

The following tables list the members exposed by ITextBox.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether the textbox can grow.
Property | CanShrink | Gets a value indicating whether the textbox can shrink.
Property | Characteristics | Gets the Characteristics held by this textbox instance.
Property | Key | Gets the unique persistent key used to identify the instance of the textbox item. This is primarily used for passing interactive state from client to server, so the server is capable of applying interactivity and relayouting the report document.
Property | TabStops | Gets the tab stops.
Property | ValueExpression | Gets the expression used to evaluate the textbox value.
Top

See Also

Reference

ITextBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextBox Interface Properties

[image]
ActiveReports 19 .NET Edition
ITextBox Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

Glossary Item Box

For a list of all members of this type, see ITextBox members.

Public Properties

 | Name | Description
Property | CanGrow | Gets a value indicating whether the textbox can grow.
Property | CanShrink | Gets a value indicating whether the textbox can shrink.
Property | Characteristics | Gets the Characteristics held by this textbox instance.
Property | Key | Gets the unique persistent key used to identify the instance of the textbox item. This is primarily used for passing interactive state from client to server, so the server is capable of applying interactivity and relayouting the report document.
Property | TabStops | Gets the tab stops.
Property | ValueExpression | Gets the expression used to evaluate the textbox value.
Top

See Also

Reference

ITextBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : CanGrow Property

Glossary Item Box

Gets a value indicating whether the textbox can grow.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanGrow As Boolean
C#
bool CanGrow {get;}

Property Value

A System.Boolean value. true if the textbox can grow; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : CanShrink Property

Glossary Item Box

Gets a value indicating whether the textbox can shrink.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanShrink As Boolean
C#
bool CanShrink {get;}

Property Value

A System.Boolean value. true if the textbox can shrink; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


Characteristics Property

[image]
ActiveReports 19 .NET Edition
Characteristics Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : Characteristics Property

Glossary Item Box

Gets the Characteristics held by this textbox instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Characteristics As Characteristics
C#
Characteristics Characteristics {get;}

Property Value

A Characteristics object representing the characteristics of this textbox instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : Key Property

Glossary Item Box

Gets the unique persistent key used to identify the instance of the textbox item. This is primarily used for passing interactive state from client to server, so the server is capable of applying interactivity and relayouting the report document.

Syntax

Visual Basic (Declaration)
ReadOnly Property Key As String
C#
string Key {get;}

Property Value

A System.String representing the unique persistent key of the textbox item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


TabStops Property

[image]
ActiveReports 19 .NET Edition
TabStops Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : TabStops Property

Glossary Item Box

Gets the tab stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property TabStops As IItemCollection(Of TabStop)
C#
IItemCollection<TabStop> TabStops {get;}

Property Value

An IItemCollection<T> representing the tab stops in the textbox.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


ValueExpression Property

[image]
ActiveReports 19 .NET Edition
ValueExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : ValueExpression Property

Glossary Item Box

Gets the expression used to evaluate the textbox value.

Syntax

Visual Basic (Declaration)
ReadOnly Property ValueExpression As String
C#
string ValueExpression {get;}

Property Value

A System.String representing the expression used to evaluate the textbox value.

Remarks

This expression is not null if the expression depends on pagination context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextBox Interface
ITextBox Members


ITextItem Interface

[image]
ActiveReports 19 .NET Edition
ITextItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

Glossary Item Box

Represents a text item that can be rendered in a report.

Syntax

Visual Basic (Declaration)
Public Interface ITextItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
C#
public interface ITextItem : IDocumentMapItem, IRenderComponent, IReportItem

Remarks

This interface extends IReportItem and includes additional properties specific to text items, such as rendering style and content value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextItem Interface Members

[image]
ActiveReports 19 .NET Edition
ITextItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

Glossary Item Box

The following tables list the members exposed by ITextItem.

Public Properties

 | Name | Description
Property | ContentValue | Gets a string representation of this instance's value.
Property | DataElementStyle | Gets a value indicating whether to render this text item as an element or as an attribute.
Property | Value | Gets the value of this text item.
Top

See Also

Reference

ITextItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextItem Interface Properties

[image]
ActiveReports 19 .NET Edition
ITextItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

Glossary Item Box

For a list of all members of this type, see ITextItem members.

Public Properties

 | Name | Description
Property | ContentValue | Gets a string representation of this instance's value.
Property | DataElementStyle | Gets a value indicating whether to render this text item as an element or as an attribute.
Property | Value | Gets the value of this text item.
Top

See Also

Reference

ITextItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ContentValue Property

[image]
ActiveReports 19 .NET Edition
ContentValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : ContentValue Property

Glossary Item Box

Gets a string representation of this instance's value.

Syntax

Visual Basic (Declaration)
ReadOnly Property ContentValue As String
C#
string ContentValue {get;}

Property Value

A System.String representing the content value of this text item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextItem Interface
ITextItem Members


DataElementStyle Property

[image]
ActiveReports 19 .NET Edition
DataElementStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : DataElementStyle Property

Glossary Item Box

Gets a value indicating whether to render this text item as an element or as an attribute.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementStyle As DataElementStyle
C#
DataElementStyle DataElementStyle {get;}

Property Value

A DataElementStyle value that indicates the rendering style of the text item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextItem Interface
ITextItem Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : Value Property

Glossary Item Box

Gets the value of this text item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Object
C#
object Value {get;}

Property Value

An System.Object representing the value of this text item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextItem Interface
ITextItem Members


ITocItem Interface

[image]
ActiveReports 19 .NET Edition
ITocItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

Glossary Item Box

Represents a Table of Contents (ToC) item.

Syntax

Visual Basic (Declaration)
Public Interface ITocItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
C#
public interface ITocItem : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocItem Interface Members

[image]
ActiveReports 19 .NET Edition
ITocItem Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

Glossary Item Box

The following tables list the members exposed by ITocItem.

Public Properties

 | Name | Description
Property | Index | Gets the index in the ToC's contents collection.
Property | IsLicenceBanner | Gets a value indicating whether the ToC item contains some banner decoration.
Property | LeadingChar | Gets the leading character.
Property | Level | Gets the level (starts from 1).
Property | Text | Gets the levels and label text.
Property | TocLevel | Gets the ToC level object (definition).
Top

See Also

Reference

ITocItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocItem Interface Properties

[image]
ActiveReports 19 .NET Edition
ITocItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

Glossary Item Box

For a list of all members of this type, see ITocItem members.

Public Properties

 | Name | Description
Property | Index | Gets the index in the ToC's contents collection.
Property | IsLicenceBanner | Gets a value indicating whether the ToC item contains some banner decoration.
Property | LeadingChar | Gets the leading character.
Property | Level | Gets the level (starts from 1).
Property | Text | Gets the levels and label text.
Property | TocLevel | Gets the ToC level object (definition).
Top

See Also

Reference

ITocItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : Index Property

Glossary Item Box

Gets the index in the ToC's contents collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Index As Integer
C#
int Index {get;}

Property Value

An System.Int32 representing the index in the ToC's contents collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


IsLicenceBanner Property

[image]
ActiveReports 19 .NET Edition
IsLicenceBanner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : IsLicenceBanner Property

Glossary Item Box

Gets a value indicating whether the ToC item contains some banner decoration.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLicenceBanner As Boolean
C#
bool IsLicenceBanner {get;}

Property Value

A System.Boolean value. true if the ToC item contains a banner decoration; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : LeadingChar Property

Glossary Item Box

Gets the leading character.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeadingChar As String
C#
string LeadingChar {get;}

Property Value

A System.String representing the leading character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


Level Property

[image]
ActiveReports 19 .NET Edition
Level Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : Level Property

Glossary Item Box

Gets the level (starts from 1).

Syntax

Visual Basic (Declaration)
ReadOnly Property Level As Integer
C#
int Level {get;}

Property Value

An System.Int32 representing the level, starting from 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : Text Property

Glossary Item Box

Gets the levels and label text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
C#
string Text {get;}

Property Value

A System.String representing the levels and label text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


TocLevel Property

[image]
ActiveReports 19 .NET Edition
TocLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : TocLevel Property

Glossary Item Box

Gets the ToC level object (definition).

Syntax

Visual Basic (Declaration)
ReadOnly Property TocLevel As ITocLevel
C#
ITocLevel TocLevel {get;}

Property Value

An ITocLevel representing the ToC level definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocItem Interface
ITocItem Members


ITocLevel Interface

[image]
ActiveReports 19 .NET Edition
ITocLevel Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface

Glossary Item Box

Represents a table of contents (ToC) level.

Syntax

Visual Basic (Declaration)
Public Interface ITocLevel
C#
public interface ITocLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocLevel Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocLevel Interface Members

[image]
ActiveReports 19 .NET Edition
ITocLevel Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface

Glossary Item Box

The following tables list the members exposed by ITocLevel.

Public Properties

 | Name | Description
Property | DataElementName | Gets the data element name of the level.
Property | Name | Gets the name of the level.
Property | Style | Gets the style of the level.
Top

See Also

Reference

ITocLevel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocLevel Interface Properties

[image]
ActiveReports 19 .NET Edition
ITocLevel Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface

Glossary Item Box

For a list of all members of this type, see ITocLevel members.

Public Properties

 | Name | Description
Property | DataElementName | Gets the data element name of the level.
Property | Name | Gets the name of the level.
Property | Style | Gets the style of the level.
Top

See Also

Reference

ITocLevel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : DataElementName Property

Glossary Item Box

Gets the data element name of the level.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the data element name of the level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocLevel Interface
ITocLevel Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : Name Property

Glossary Item Box

Gets the name of the level.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the name of the level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocLevel Interface
ITocLevel Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : Style Property

Glossary Item Box

Gets the style of the level.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An IStyle representing the style of the level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocLevel Interface
ITocLevel Members


ITocList Interface

[image]
ActiveReports 19 .NET Edition
ITocList Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

Glossary Item Box

Represents a list of table of contents (ToC) items.

Syntax

Visual Basic (Declaration)
Public Interface ITocList
   Inherits IDataRegion, IDocumentMapItem, IFixedSizeItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
C#
public interface ITocList : IDataRegion, IDocumentMapItem, IFixedSizeItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocList Interface Members

[image]
ActiveReports 19 .NET Edition
ITocList Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

Glossary Item Box

The following tables list the members exposed by ITocList.

Public Properties

 | Name | Description
Property | Levels | Gets the collection of table of contents levels.
Top

See Also

Reference

ITocList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocList Interface Properties

[image]
ActiveReports 19 .NET Edition
ITocList Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

Glossary Item Box

For a list of all members of this type, see ITocList members.

Public Properties

 | Name | Description
Property | Levels | Gets the collection of table of contents levels.
Top

See Also

Reference

ITocList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Levels Property

[image]
ActiveReports 19 .NET Edition
Levels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocList Interface : Levels Property

Glossary Item Box

Gets the collection of table of contents levels.

Syntax

Visual Basic (Declaration)
ReadOnly Property Levels As IItemCollection(Of ITocLevel)
C#
IItemCollection<ITocLevel> Levels {get;}

Property Value

An IItemCollection<T> representing the collection of table of contents levels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocList Interface
ITocList Members


IToggleController Interface

[image]
ActiveReports 19 .NET Edition
IToggleController Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleController Interface

Glossary Item Box

Represents an interface for IReportItem inheritors that can toggle the visibility of other report entities.

Syntax

Visual Basic (Declaration)
Public Interface IToggleController
C#
public interface IToggleController

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleController Interface Members

[image]
ActiveReports 19 .NET Edition
IToggleController Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleController Interface

Glossary Item Box

The following tables list the members exposed by IToggleController.

Public Properties

 | Name | Description
Property | ActionKey | Gets the action key that specifies the current item toggles action.
Property | InitialState | Gets a value indicating whether the initial toggle state is 'on'.
Property | IsExpanded | Gets a value indicating whether the current toggle state is 'on'.
Property | IsToggle | Gets a value indicating whether the current item toggles the visibility of any report items.
Top

Public Methods

 | Name | Description
Method | Toggle | Sends a toggle notification to all controlled items.
Top

See Also

Reference

IToggleController Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleController Interface Methods

[image]
ActiveReports 19 .NET Edition
IToggleController Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleController Interface

Glossary Item Box

For a list of all members of this type, see IToggleController members.

Public Methods

 | Name | Description
Method | Toggle | Sends a toggle notification to all controlled items.
Top

See Also

Reference

IToggleController Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Toggle Method

[image]
ActiveReports 19 .NET Edition
Toggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleController Interface : Toggle Method

Glossary Item Box

Sends a toggle notification to all controlled items.

Syntax

Visual Basic (Declaration)
Sub Toggle()
C#
void Toggle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Interface
IToggleController Members


IToggleController Interface Properties

[image]
ActiveReports 19 .NET Edition
IToggleController Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleController Interface

Glossary Item Box

For a list of all members of this type, see IToggleController members.

Public Properties

 | Name | Description
Property | ActionKey | Gets the action key that specifies the current item toggles action.
Property | InitialState | Gets a value indicating whether the initial toggle state is 'on'.
Property | IsExpanded | Gets a value indicating whether the current toggle state is 'on'.
Property | IsToggle | Gets a value indicating whether the current item toggles the visibility of any report items.
Top

See Also

Reference

IToggleController Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ActionKey Property

[image]
ActiveReports 19 .NET Edition
ActionKey Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleController Interface : ActionKey Property

Glossary Item Box

Gets the action key that specifies the current item toggles action.

Syntax

Visual Basic (Declaration)
ReadOnly Property ActionKey As String
C#
string ActionKey {get;}

Property Value

A System.String representing the action key for the current item's toggle action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Interface
IToggleController Members


InitialState Property

[image]
ActiveReports 19 .NET Edition
InitialState Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleController Interface : InitialState Property

Glossary Item Box

Gets a value indicating whether the initial toggle state is 'on'.

Syntax

Visual Basic (Declaration)
ReadOnly Property InitialState As Boolean
C#
bool InitialState {get;}

Property Value

A System.Boolean value. true if the initial toggle state is 'on'; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Interface
IToggleController Members


IsExpanded Property

[image]
ActiveReports 19 .NET Edition
IsExpanded Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleController Interface : IsExpanded Property

Glossary Item Box

Gets a value indicating whether the current toggle state is 'on'.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsExpanded As Boolean
C#
bool IsExpanded {get;}

Property Value

A System.Boolean value. true if the current toggle state is 'on'; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Interface
IToggleController Members


IsToggle Property

[image]
ActiveReports 19 .NET Edition
IsToggle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleController Interface : IsToggle Property

Glossary Item Box

Gets a value indicating whether the current item toggles the visibility of any report items.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsToggle As Boolean
C#
bool IsToggle {get;}

Property Value

A System.Boolean value. true if the current item toggles visibility; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleController Interface
IToggleController Members


IToggleReceiver Interface

[image]
ActiveReports 19 .NET Edition
IToggleReceiver Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

Glossary Item Box

Represents report entities whose visibility state can be toggled by a toggle report item.

Syntax

Visual Basic (Declaration)
Public Interface IToggleReceiver
C#
public interface IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleReceiver Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleReceiver Interface Members

[image]
ActiveReports 19 .NET Edition
IToggleReceiver Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

Glossary Item Box

The following tables list the members exposed by IToggleReceiver.

Public Properties

 | Name | Description
Property | Hidden | Gets a value indicating whether the item should be hidden.
Property | ToggleItem | Gets the name of the toggle item.
Top

See Also

Reference

IToggleReceiver Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleReceiver Interface Properties

[image]
ActiveReports 19 .NET Edition
IToggleReceiver Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

Glossary Item Box

For a list of all members of this type, see IToggleReceiver members.

Public Properties

 | Name | Description
Property | Hidden | Gets a value indicating whether the item should be hidden.
Property | ToggleItem | Gets the name of the toggle item.
Top

See Also

Reference

IToggleReceiver Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether the item should be hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the item is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


ToggleItem Property

[image]
ActiveReports 19 .NET Edition
ToggleItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : ToggleItem Property

Glossary Item Box

Gets the name of the toggle item.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToggleItem As String
C#
string ToggleItem {get;}

Property Value

A System.String representing the name of the toggle item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


IUprightTextStyle Interface

[image]
ActiveReports 19 .NET Edition
IUprightTextStyle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IUprightTextStyle Interface

Glossary Item Box

Represents the style object.

Syntax

Visual Basic (Declaration)
Public Interface IUprightTextStyle
C#
public interface IUprightTextStyle

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUprightTextStyle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IUprightTextStyle Interface Members

[image]
ActiveReports 19 .NET Edition
IUprightTextStyle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IUprightTextStyle Interface

Glossary Item Box

The following tables list the members exposed by IUprightTextStyle.

Public Properties

 | Name | Description
Property | UprightInVerticalText | Gets a value indicating whether the text is written upright in the vertical text.
Top

See Also

Reference

IUprightTextStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IUprightTextStyle Interface Properties

[image]
ActiveReports 19 .NET Edition
IUprightTextStyle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IUprightTextStyle Interface

Glossary Item Box

For a list of all members of this type, see IUprightTextStyle members.

Public Properties

 | Name | Description
Property | UprightInVerticalText | Gets a value indicating whether the text is written upright in the vertical text.
Top

See Also

Reference

IUprightTextStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


UprightInVerticalText Property

[image]
ActiveReports 19 .NET Edition
UprightInVerticalText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IUprightTextStyle Interface : UprightInVerticalText Property

Glossary Item Box

Gets a value indicating whether the text is written upright in the vertical text.

Syntax

Visual Basic (Declaration)
ReadOnly Property UprightInVerticalText As String
C#
string UprightInVerticalText {get;}

Property Value

A System.String value indicating if the text is upright in vertical text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUprightTextStyle Interface
IUprightTextStyle Members


IValueCollection Interface

[image]
ActiveReports 19 .NET Edition
IValueCollection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IValueCollection Interface

Glossary Item Box

Represents a collection of values.

Syntax

Visual Basic (Declaration)
Public Interface IValueCollection
C#
public interface IValueCollection

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValueCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IValueCollection Interface Members

[image]
ActiveReports 19 .NET Edition
IValueCollection Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IValueCollection Interface

Glossary Item Box

The following tables list the members exposed by IValueCollection.

See Also

Reference

IValueCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualAppearance Interface

[image]
ActiveReports 19 .NET Edition
IVisualAppearance Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface

Glossary Item Box

Interface for the visual appearance.

Syntax

Visual Basic (Declaration)
Public Interface IVisualAppearance
C#
public interface IVisualAppearance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualAppearance Interface Members

[image]
ActiveReports 19 .NET Edition
IVisualAppearance Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface

Glossary Item Box

The following tables list the members exposed by IVisualAppearance.

Public Properties

 | Name | Description
Property | BackgroundColor | The color of the background.
Property | Image | Specifies the image that should be displayed, if any.
Property | ImageSource | Specifies image source for image.
Property | InteractivityStates | Specifies interactivity states to which this appearance is applicable.
Property | Tooltip | Specifies how tooltip should be displayed for this area.
Property | TooltipText | Specifies balloon or tooltip text that should be displayed for this area.
Property | Transparency | Specifies how image should be alpha-blended with the underlying area.
Property | Visible | Specifies that there should be visual effects for the area.
Top

See Also

Reference

IVisualAppearance Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualAppearance Interface Properties

[image]
ActiveReports 19 .NET Edition
IVisualAppearance Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface

Glossary Item Box

For a list of all members of this type, see IVisualAppearance members.

Public Properties

 | Name | Description
Property | BackgroundColor | The color of the background.
Property | Image | Specifies the image that should be displayed, if any.
Property | ImageSource | Specifies image source for image.
Property | InteractivityStates | Specifies interactivity states to which this appearance is applicable.
Property | Tooltip | Specifies how tooltip should be displayed for this area.
Property | TooltipText | Specifies balloon or tooltip text that should be displayed for this area.
Property | Transparency | Specifies how image should be alpha-blended with the underlying area.
Property | Visible | Specifies that there should be visual effects for the area.
Top

See Also

Reference

IVisualAppearance Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : BackgroundColor Property

Glossary Item Box

The color of the background.

Syntax

Visual Basic (Declaration)
Property BackgroundColor As Color
C#
Color BackgroundColor {get; set;}

Remarks

Does not seem as used somewhere, probably should be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Image Property

[image]
ActiveReports 19 .NET Edition
Image Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Image Property

Glossary Item Box

Specifies the image that should be displayed, if any.

Syntax

Visual Basic (Declaration)
ReadOnly Property Image As String
C#
string Image {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


ImageSource Property

[image]
ActiveReports 19 .NET Edition
ImageSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : ImageSource Property

Glossary Item Box

Specifies image source for image.

Syntax

Visual Basic (Declaration)
ReadOnly Property ImageSource As ImageSource
C#
ImageSource ImageSource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


InteractivityStates Property

[image]
ActiveReports 19 .NET Edition
InteractivityStates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : InteractivityStates Property

Glossary Item Box

Specifies interactivity states to which this appearance is applicable.

Syntax

Visual Basic (Declaration)
ReadOnly Property InteractivityStates As InteractivityStates
C#
InteractivityStates InteractivityStates {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Tooltip Property

Glossary Item Box

Specifies how tooltip should be displayed for this area.

Syntax

Visual Basic (Declaration)
ReadOnly Property Tooltip As TooltipType
C#
TooltipType Tooltip {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


TooltipText Property

[image]
ActiveReports 19 .NET Edition
TooltipText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : TooltipText Property

Glossary Item Box

Specifies balloon or tooltip text that should be displayed for this area.

Syntax

Visual Basic (Declaration)
Property TooltipText As String
C#
string TooltipText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Transparency Property

[image]
ActiveReports 19 .NET Edition
Transparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Transparency Property

Glossary Item Box

Specifies how image should be alpha-blended with the underlying area.

Syntax

Visual Basic (Declaration)
ReadOnly Property Transparency As Single
C#
float Transparency {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Visible Property

Glossary Item Box

Specifies that there should be visual effects for the area.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


IVisualShape Interface

[image]
ActiveReports 19 .NET Edition
IVisualShape Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface

Glossary Item Box

Represents an interface for a visual shape.

Syntax

Visual Basic (Declaration)
Public Interface IVisualShape
C#
public interface IVisualShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualShape Interface Members

[image]
ActiveReports 19 .NET Edition
IVisualShape Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface

Glossary Item Box

The following tables list the members exposed by IVisualShape.

Public Methods

 | Name | Description
Method | GetBounds | Returns a System.Drawing.RectangleF that bounds this shape.
Method | GetImageMapArea | Renders an interactive map area for use in HTML, PDF, and other exports.
Method | IsVisible | Indicates if the specified System.Drawing.PointF is contained within this IVisualShape.
Top

See Also

Reference

IVisualShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualShape Interface Methods

[image]
ActiveReports 19 .NET Edition
IVisualShape Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface

Glossary Item Box

For a list of all members of this type, see IVisualShape members.

Public Methods

 | Name | Description
Method | GetBounds | Returns a System.Drawing.RectangleF that bounds this shape.
Method | GetImageMapArea | Renders an interactive map area for use in HTML, PDF, and other exports.
Method | IsVisible | Indicates if the specified System.Drawing.PointF is contained within this IVisualShape.
Top

See Also

Reference

IVisualShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetBounds Method

[image]
ActiveReports 19 .NET Edition
GetBounds Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualShape Interface : GetBounds Method

Glossary Item Box

Returns a System.Drawing.RectangleF that bounds this shape.

Syntax

Visual Basic (Declaration)
Function GetBounds() As RectangleF
C#
RectangleF GetBounds()

Return Value

A System.Drawing.RectangleF that represents the bounding rectangle of this shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualShape Interface
IVisualShape Members


GetImageMapArea Method

[image]
ActiveReports 19 .NET Edition
GetImageMapArea Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualShape Interface : GetImageMapArea Method

Glossary Item Box

Renders an interactive map area for use in HTML, PDF, and other exports.

Syntax

Visual Basic (Declaration)
Function GetImageMapArea() As ImageMapArea
C#
ImageMapArea GetImageMapArea()

Return Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.ImageMapArea representing the interactive map area of this shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualShape Interface
IVisualShape Members


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualShape Interface : IsVisible Method

point
The System.Drawing.PointF to check for containment within this shape.

Glossary Item Box

Indicates if the specified System.Drawing.PointF is contained within this IVisualShape.

Syntax

Visual Basic (Declaration)
Function IsVisible( _
   ByVal point As PointF _
) As Boolean
C#
bool IsVisible(
   PointF point
)

Parameters

point
The System.Drawing.PointF to check for containment within this shape.

Return Value

true if the specified System.Drawing.PointF is contained within this IVisualShape; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVisualShape Interface
IVisualShape Members


GroupKeepTogether Enumeration

[image]
ActiveReports 19 .NET Edition
GroupKeepTogether Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : GroupKeepTogether Enumeration

Glossary Item Box

Specifies how BandedListGroup content should be kept together

Syntax

Visual Basic (Declaration)
Public Enum GroupKeepTogether
   Inherits System.Enum
C#
public enum GroupKeepTogether : System.Enum

Members

Member | Description
All | Specifies that BandedListGroup content should be kept together when possible
FirstDetail | Specifies that BandedListGroup header band should be kept together with first details band when possible
LastDetail | Specifies that BandedListGroup footer band should be kept together with last details band when possible
None | Specifies that BandedListGroup content could be broken across pages

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.GroupKeepTogether

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface

[image]
ActiveReports 19 .NET Edition
IBandedListGroup Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface

Glossary Item Box

Represents the interface for the banded list group object.

Syntax

Visual Basic (Declaration)
Public Interface IBandedListGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
C#
public interface IBandedListGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface Members

[image]
ActiveReports 19 .NET Edition
IBandedListGroup Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface

Glossary Item Box

The following tables list the members exposed by IBandedListGroup.

Public Properties

 | Name | Description
Property | DataCollectionName | Gets the name of the banded list group element.
Property | DataElementName | Gets the name of this group instance element.
Property | DataElementOutput | Gets a value indicating whether the group should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Gets the details band collection for this group.
Property | EndSection | Gets the value indicating where the layout should continue.
Property | GroupFooter | Gets the footer for this group instance.
Property | GroupHeader | Gets the header for this group instance.
Property | Hidden | Gets a value indicating the initial visibility for this instance.
Property | KeepTogether | Gets a value indicating whether the group should keep its contents together.
Property | Name | Gets the name of this IBandedListGroup.
Property | PageBreak | Gets the page breaking options for this group.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | PreventOrphanedHeader | Gets a value indicating whether the orphaned header is displayed on the page.
Property | SubGroups | Gets the collection of subgroups for this group.
Top

See Also

Reference

IBandedListGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface Properties

[image]
ActiveReports 19 .NET Edition
IBandedListGroup Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface

Glossary Item Box

For a list of all members of this type, see IBandedListGroup members.

Public Properties

 | Name | Description
Property | DataCollectionName | Gets the name of the banded list group element.
Property | DataElementName | Gets the name of this group instance element.
Property | DataElementOutput | Gets a value indicating whether the group should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Gets the details band collection for this group.
Property | EndSection | Gets the value indicating where the layout should continue.
Property | GroupFooter | Gets the footer for this group instance.
Property | GroupHeader | Gets the header for this group instance.
Property | Hidden | Gets a value indicating the initial visibility for this instance.
Property | KeepTogether | Gets a value indicating whether the group should keep its contents together.
Property | Name | Gets the name of this IBandedListGroup.
Property | PageBreak | Gets the page breaking options for this group.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | PreventOrphanedHeader | Gets a value indicating whether the orphaned header is displayed on the page.
Property | SubGroups | Gets the collection of subgroups for this group.
Top

See Also

Reference

IBandedListGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


DataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataCollectionName Property

Glossary Item Box

Gets the name of the banded list group element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataCollectionName As String
C#
string DataCollectionName {get;}

Property Value

A System.String specifying the data collection name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataElementName Property

Glossary Item Box

Gets the name of this group instance element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String specifying the data element name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataElementOutput Property

Glossary Item Box

Gets a value indicating whether the group should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value specifying whether the group should appear in a data rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Details Property

Glossary Item Box

Gets the details band collection for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Details As IItemCollection(Of IBand)
C#
IItemCollection<IBand> Details {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the details band collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : EndSection Property

Glossary Item Box

Gets the value indicating where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An EndSection value specifying the layout continuation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


GroupFooter Property

[image]
ActiveReports 19 .NET Edition
GroupFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : GroupFooter Property

Glossary Item Box

Gets the footer for this group instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupFooter As IFooterBand
C#
IFooterBand GroupFooter {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFooterBand specifying the group footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


GroupHeader Property

[image]
ActiveReports 19 .NET Edition
GroupHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : GroupHeader Property

Glossary Item Box

Gets the header for this group instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupHeader As IHeaderBand
C#
IHeaderBand GroupHeader {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IHeaderBand specifying the group header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Hidden Property

Glossary Item Box

Gets a value indicating the initial visibility for this instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the instance is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the group should keep its contents together.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepTogether As Boolean
C#
bool KeepTogether {get;}

Property Value

A System.Boolean value. true if the group should keep its contents together; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Name Property

Glossary Item Box

Gets the name of this IBandedListGroup.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String specifying the name of the banded list group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

A GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation value specifying the page break location.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PreventOrphanedFooter Property

Glossary Item Box

Gets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedFooter As Boolean
C#
bool PreventOrphanedFooter {get;}

Property Value

A System.Boolean value. true if the orphaned footer is prevented; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PreventOrphanedHeader Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PreventOrphanedHeader Property

Glossary Item Box

Gets a value indicating whether the orphaned header is displayed on the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedHeader As Boolean
C#
bool PreventOrphanedHeader {get;}

Property Value

A System.Boolean value. true if the orphaned header is prevented; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


SubGroups Property

[image]
ActiveReports 19 .NET Edition
SubGroups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : SubGroups Property

Glossary Item Box

Gets the collection of subgroups for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property SubGroups As IItemCollection(Of IBandedListGroup)
C#
IItemCollection<IBandedListGroup> SubGroups {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the collection of subgroups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


BarCodeCaptionPosition Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeCaptionPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : BarCodeCaptionPosition Enumeration

Glossary Item Box

Specifies position for barcode caption.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeCaptionPosition
   Inherits System.Enum
C#
public enum BarCodeCaptionPosition : System.Enum

Members

Member | Description
Above | The above
Below | The below
None | The none

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeCaptionPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


BarCodeDirection Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : BarCodeDirection Enumeration

Glossary Item Box

Specifies the print direction of the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeDirection
   Inherits System.Enum
C#
public enum BarCodeDirection : System.Enum

Members

Member | Description
BottomToTop | The barcode symbol is printed bottom to top.
LeftToRight | The barcode symbol is printed left to right (default).
RightToLeft | The barcode symbol is printed right to left.
TopToBottom | The barcode symbol is printed top to bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


BarCodeStyle Enumeration

[image]
ActiveReports 19 .NET Edition
BarCodeStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : BarCodeStyle Enumeration

Glossary Item Box

Specifies the type of code, or symbology, the barcode control will use to generate the barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeStyle
   Inherits System.Enum
C#
public enum BarCodeStyle : System.Enum

Members

Member | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Aztec | Aztec Code
BC412 | Data BC412 uses 35 characters, 0 - 9 and A - Z. It is designed for semiconductor wafer identification.
Codabar | Codabar uses A B C D + - : , / and numbers.
Code_11 | Encodes the numbers 0 through 9, the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses the complete ASCII character set.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). If there are only 12 numbers in the string, it calculates a checksum and adds it to the thirteenth position. If there are 13, it validates the checksum and throws an error if it is incorrect.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1 | EAN-128 is an alphanumeric one-dimensional representation of Application Identifier data. It is not meant for point-of-sales use, but for marking containers in the shipping industry.
GS1DataMatrix | GS1 Data Matrix
GS1QRCode | GS1 QRCode
HIBCCode128 | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
HIBCCode39 | HIBCCode39 barcode uses the Code39 symbology, with Code39OptionalCheckDigit property set to True. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numbers with a check digit.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | Interleaved Two of Five. This code is used to mark cartons and palettes that are including goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars. Matrix_2_of_5 uses only numbers.
MaxiCode | MaxiCode is special polar barcode.
MicroPDF417 | MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.
MicroQRCode | Micro QR Code is a variant of QR Code, with reduced barcode size. It has only one position detection pattern.
MSI | MSI Code uses only numbers.
None | None.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. Capable of encoding as many as 2725 data characters.
Pharmacode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet uses only numbers with a check digit.
PZN | PZN Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification for use with omnidirectional point-of-sale scanners.
RSS14Stacked | RSS14Stacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14Truncated, but stacked in two rows when RSS14Truncated is too wide.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14, but stacked in two rows when RSS14 is too wide.
RSS14Truncated | RSS14Truncated is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus Indicator digits for use on small items, not for point-of-sale scanners.
RSSExpanded | RSSExpanded is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus AI element strings (expiration date, weight, etc.) for use with omnidirectional point-of-sale scanners.
RSSExpandedStacked | RSSExpandedStacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSSExpanded, but stacked in two rows when RSSExpanded is too wide.
RSSLimited | RSS Limited is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification with indicator digits of 0 or 1 in a small symbol that is not scanned by point-of-sale scanners.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be 0 (zero)) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


Rotation Enumeration

[image]
ActiveReports 19 .NET Edition
Rotation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : Rotation Enumeration

Glossary Item Box

Specifies the orientation of the bars in the barcode.

Syntax

Visual Basic (Declaration)
Public Enum Rotation
   Inherits System.Enum
C#
public enum Rotation : System.Enum

Members

Member | Description
None | None
Rotate180Degrees | 180 degrees
Rotate270Degrees | 270 degrees
Rotate90Degrees | 90 degrees

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.Rotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


IBarcodeRdfRenderer Interface

[image]
ActiveReports 19 .NET Edition
IBarcodeRdfRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IBarcodeRdfRenderer Interface

Glossary Item Box

Provides possibility for barcode rendering directly to RDF page.

Syntax

Visual Basic (Declaration)
Public Interface IBarcodeRdfRenderer
C#
public interface IBarcodeRdfRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


IBarcodeRdfRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IBarcodeRdfRenderer Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IBarcodeRdfRenderer Interface

Glossary Item Box

The following tables list the members exposed by IBarcodeRdfRenderer.

Public Properties

 | Name | Description
Property | CaptionAlignment |
Property | Direction | Provide the orientation of the barcode data
Property | FontInfo |
Property | Rotation |
Property | StyleEvaluator |
Property | Symbology |
Top

Public Methods

 | Name | Description
Method | Render | Render barcode to drawing device
Top

See Also

Reference

IBarcodeRdfRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


IBarcodeRdfRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
IBarcodeRdfRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IBarcodeRdfRenderer Interface

Glossary Item Box

For a list of all members of this type, see IBarcodeRdfRenderer members.

Public Methods

 | Name | Description
Method | Render | Render barcode to drawing device
Top

See Also

Reference

IBarcodeRdfRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : Render Method

createDevice
The factory method to get GrapeCity.ActiveReports.Drawing.IDrawingCanvas.
bounds
Item bounds.
renderError
Action for error message rendering into drawing device. It has next parameters: error message, forecolor, backcolor, barcode style

Glossary Item Box

Render barcode to drawing device

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal createDevice As Func(Of RectangleF,IDrawingDevice), _
   ByVal bounds As RectangleF, _
   ByVal renderError As Action(Of String,Color,Color,IStyle) _
)
C#
void Render(
   Func<RectangleF,IDrawingDevice> createDevice,
   RectangleF bounds,
   Action<string,Color,Color,IStyle> renderError
)

Parameters

createDevice
The factory method to get GrapeCity.ActiveReports.Drawing.IDrawingCanvas.
bounds
Item bounds.
renderError
Action for error message rendering into drawing device. It has next parameters: error message, forecolor, backcolor, barcode style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


IBarcodeRdfRenderer Interface Properties

[image]
ActiveReports 19 .NET Edition
IBarcodeRdfRenderer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IBarcodeRdfRenderer Interface

Glossary Item Box

For a list of all members of this type, see IBarcodeRdfRenderer members.

Public Properties

 | Name | Description
Property | CaptionAlignment |
Property | Direction | Provide the orientation of the barcode data
Property | FontInfo |
Property | Rotation |
Property | StyleEvaluator |
Property | Symbology |
Top

See Also

Reference

IBarcodeRdfRenderer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


CaptionAlignment Property

[image]
ActiveReports 19 .NET Edition
CaptionAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : CaptionAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CaptionAlignment As StringAlignmentEx
C#
StringAlignmentEx CaptionAlignment {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : Direction Property

Glossary Item Box

Provide the orientation of the barcode data

Syntax

Visual Basic (Declaration)
ReadOnly Property Direction As Integer
C#
int Direction {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


FontInfo Property

[image]
ActiveReports 19 .NET Edition
FontInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : FontInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property FontInfo As FontInfo
C#
FontInfo FontInfo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : Rotation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Rotation As Rotation
C#
Rotation Rotation {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


StyleEvaluator Property

[image]
ActiveReports 19 .NET Edition
StyleEvaluator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : StyleEvaluator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleEvaluator As IStyle
C#
IStyle StyleEvaluator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


Symbology Property

[image]
ActiveReports 19 .NET Edition
Symbology Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IBarcodeRdfRenderer Interface : Symbology Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Symbology As BarCodeStyle
C#
BarCodeStyle Symbology {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeRdfRenderer Interface
IBarcodeRdfRenderer Members


IDrawingDevice Interface

[image]
ActiveReports 19 .NET Edition
IDrawingDevice Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IDrawingDevice Interface

Glossary Item Box

The IDrawingDevice interface provides methods for drawing objects to the display device.

Syntax

Visual Basic (Declaration)
Public Interface IDrawingDevice
   Inherits ITextMeasurer
C#
public interface IDrawingDevice : ITextMeasurer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingDevice Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


IDrawingDevice Interface Members

[image]
ActiveReports 19 .NET Edition
IDrawingDevice Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IDrawingDevice Interface

Glossary Item Box

The following tables list the members exposed by IDrawingDevice.

Public Methods

 | Name | Description
Method | DrawEllipse | Fills circle.
Method | DrawString | Draws the specified text at the specified location using the specified device context, font, and color.
Method | FillPolygon | Fills polygon.
Method | FillRectangle | Fills the interior with a rectangle specified by a pair of coordinates, a width, and a height.
Top

See Also

Reference

IDrawingDevice Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


IDrawingDevice Interface Methods

[image]
ActiveReports 19 .NET Edition
IDrawingDevice Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : IDrawingDevice Interface

Glossary Item Box

For a list of all members of this type, see IDrawingDevice members.

Public Methods

 | Name | Description
Method | DrawEllipse | Fills circle.
Method | DrawString | Draws the specified text at the specified location using the specified device context, font, and color.
Method | FillPolygon | Fills polygon.
Method | FillRectangle | Fills the interior with a rectangle specified by a pair of coordinates, a width, and a height.
Top

See Also

Reference

IDrawingDevice Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IDrawingDevice Interface : DrawEllipse Method

center
rx
ry
width

Glossary Item Box

Fills circle.

Syntax

Visual Basic (Declaration)
Sub DrawEllipse( _
   ByVal center As PointF, _
   ByVal rx As Single, _
   ByVal ry As Single, _
   ByVal width As Single _
)
C#
void DrawEllipse(
   PointF center,
   float rx,
   float ry,
   float width
)

Parameters

center
rx
ry
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingDevice Interface
IDrawingDevice Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IDrawingDevice Interface : DrawString Method

text
The text to draw.///
bounds
The rectangle that bounds the text.///

Glossary Item Box

Draws the specified text at the specified location using the specified device context, font, and color.

Syntax

Visual Basic (Declaration)
Sub DrawString( _
   ByVal text As String, _
   ByVal bounds As RectangleF _
)
C#
void DrawString(
   string text,
   RectangleF bounds
)

Parameters

text
The text to draw.///
bounds
The rectangle that bounds the text.///

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingDevice Interface
IDrawingDevice Members


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IDrawingDevice Interface : FillPolygon Method

bounds

Glossary Item Box

Fills polygon.

Syntax

Visual Basic (Declaration)
Sub FillPolygon( _
   ByVal bounds() As PointF _
)
C#
void FillPolygon(
   PointF[] bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingDevice Interface
IDrawingDevice Members


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > IDrawingDevice Interface : FillRectangle Method

bounds

Glossary Item Box

Fills the interior with a rectangle specified by a pair of coordinates, a width, and a height.

Syntax

Visual Basic (Declaration)
Sub FillRectangle( _
   ByVal bounds As RectangleF _
)
C#
void FillRectangle(
   RectangleF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingDevice Interface
IDrawingDevice Members


ITextMeasurer Interface

[image]
ActiveReports 19 .NET Edition
ITextMeasurer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : ITextMeasurer Interface

Glossary Item Box

Provides methods used to measure text.

Syntax

Visual Basic (Declaration)
Public Interface ITextMeasurer
C#
public interface ITextMeasurer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMeasurer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


ITextMeasurer Interface Members

[image]
ActiveReports 19 .NET Edition
ITextMeasurer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : ITextMeasurer Interface

Glossary Item Box

The following tables list the members exposed by ITextMeasurer.

Public Methods

 | Name | Description
Method | MeasureString | Measures the specified text when drawn with the specified font.
Top

See Also

Reference

ITextMeasurer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


ITextMeasurer Interface Methods

[image]
ActiveReports 19 .NET Edition
ITextMeasurer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace : ITextMeasurer Interface

Glossary Item Box

For a list of all members of this type, see ITextMeasurer members.

Public Methods

 | Name | Description
Method | MeasureString | Measures the specified text when drawn with the specified font.
Top

See Also

Reference

ITextMeasurer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace


MeasureString Method

[image]
ActiveReports 19 .NET Edition
MeasureString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode Namespace > ITextMeasurer Interface : MeasureString Method

text
The text to measure. ///

Glossary Item Box

Measures the specified text when drawn with the specified font.

Syntax

Visual Basic (Declaration)
Function MeasureString( _
   ByVal text As String _
) As SizeF
C#
SizeF MeasureString(
   string text
)

Parameters

text
The text to measure. ///

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextMeasurer Interface
ITextMeasurer Members


AxisLabelOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
AxisLabelOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : AxisLabelOrientation Enumeration

Glossary Item Box

Specifies the axis label text orientations.

Syntax

Visual Basic (Declaration)
Public Enum AxisLabelOrientation
   Inherits System.Enum
C#
public enum AxisLabelOrientation : System.Enum

Members

Member | Description
Angled | Text at an angle of 45 degrees
Auto | Indicates the orientation will be selected automatically based on context (for example, Rotated270 for titles docked on the left).
Horizontal | Horizontal text
Rotated270 | Vertical text: Rotated 270 degrees.
Rotated90 | Vertical text: Rotated 90 degrees.
Stacked | Vertical text: No character rotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.AxisLabelOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


AxisLocation Enumeration

[image]
ActiveReports 19 .NET Edition
AxisLocation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : AxisLocation Enumeration

Glossary Item Box

Specifies the axis location.

Syntax

Visual Basic (Declaration)
Public Enum AxisLocation
   Inherits System.Enum
C#
public enum AxisLocation : System.Enum

Members

Member | Description
Left | Indicates that the axis should be drawn on the left side of the chart area.
Right | Indicates that the axis should be drawn on the right side of the chart area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.AxisLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


AxisTextOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
AxisTextOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : AxisTextOrientation Enumeration

Glossary Item Box

Specifies the axis title text orientations.

Syntax

Visual Basic (Declaration)
Public Enum AxisTextOrientation
   Inherits System.Enum
C#
public enum AxisTextOrientation : System.Enum

Members

Member | Description
Auto | Indicates the orientation will be selected automatically based on context (for example, Rotated270 for titles docked on the left).
Horizontal | Horizontal text
Rotated270 | Vertical text: Rotated 270 degrees.
Rotated90 | Vertical text: Rotated 90 degrees.
Stacked | Vertical text: No character rotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.AxisTextOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ChartSeriesPlotType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartSeriesPlotType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartSeriesPlotType Enumeration

Glossary Item Box

Specifies the chart series plot types.

Syntax

Visual Basic (Declaration)
Public Enum ChartSeriesPlotType
   Inherits System.Enum
C#
public enum ChartSeriesPlotType : System.Enum

Members

Member | Description
Auto | The automatic plot type.
Line | The line plot type.
Point | The point plot type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartSeriesPlotType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ChartSubtype Enumeration

[image]
ActiveReports 19 .NET Edition
ChartSubtype Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartSubtype Enumeration

Glossary Item Box

Specifies the chart subtypes.

Syntax

Visual Basic (Declaration)
Public Enum ChartSubtype
   Inherits System.Enum
C#
public enum ChartSubtype : System.Enum

Members

Member | Description
Candlestick | The candle stick chart subtype.
Exploded | The exploded chart subtype.
HighLowClose | The high low close chart subtype.
Line | The line chart subtype.
OpenHighLowClose | The open high low close chart subtype.
PercentStacked | The percent stacked chart subtype.
Plain | The plain chart subtype.
Smooth | The smooth chart subtype.
SmoothLine | The smooth line chart subtype.
Stacked | The stacked chart subtype.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartSubtype

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ChartType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartType Enumeration

Glossary Item Box

Specifies the enumeration of chart types.

Syntax

Visual Basic (Declaration)
Public Enum ChartType
   Inherits System.Enum
C#
public enum ChartType : System.Enum

Members

Member | Description
Area | The area chart type.
Bar | The bar chart type.
Bubble | The bubble chart type.
Column | The column chart type.
DotPlot | The dot plot chart type.
Doughnut | The doughnut chart type.
Funnel | The funnel chart type.
Gantt | The gantt chart type.
Kagi | The kagi chart type.
Line | The line chart type.
Pie | The pie chart type.
PointAndFigure | The point and figure chart type.
Pyramid | The pyramid chart type.
Renko | The renko chart type.
Scatter | The scatter chart type.
Stock | The stock chart type.
ThreeLineBreak | The three line break chart type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ImageType Enumeration

[image]
ActiveReports 19 .NET Edition
ImageType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ImageType Enumeration

Glossary Item Box

Specifies the enumeration of chart image types.

Syntax

Visual Basic (Declaration)
Public Enum ImageType
   Inherits System.Enum
C#
public enum ImageType : System.Enum

Members

Member | Description
Emf | Metafile image.
Png | PNG image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ImageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendLayout Enumeration

[image]
ActiveReports 19 .NET Edition
LegendLayout Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : LegendLayout Enumeration

Glossary Item Box

Specifies the legend layout.

Syntax

Visual Basic (Declaration)
Public Enum LegendLayout
   Inherits System.Enum
C#
public enum LegendLayout : System.Enum

Members

Member | Description
Column | The column legend.
Row | The row legend.
Table | The table layout.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.LegendLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendPosition Enumeration

[image]
ActiveReports 19 .NET Edition
LegendPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : LegendPosition Enumeration

Glossary Item Box

Specifies the legend position enumeration.

Syntax

Visual Basic (Declaration)
Public Enum LegendPosition
   Inherits System.Enum
C#
public enum LegendPosition : System.Enum

Members

Member | Description
BottomCenter | The bottom center legend position.
BottomLeft | The bottom left legend position.
BottomRight | The bottom right legend position.
LeftBottom | The left bottom legend position.
LeftCenter | The left center legend position.
LeftTop | The left top legend position.
RightBottom | The right bottom legend position.
RightCenter | The right center legend position.
RightTop | The right top legend position.
TopCenter | The top center legend position.
TopLeft | The top left legend position.
TopRight | The top right legend position.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.LegendPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


MarkerType Enumeration

[image]
ActiveReports 19 .NET Edition
MarkerType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : MarkerType Enumeration

Glossary Item Box

Specifies the marker types for charts.

Syntax

Visual Basic (Declaration)
Public Enum MarkerType
   Inherits System.Enum
C#
public enum MarkerType : System.Enum

Members

Member | Description
Auto | The automatically determined marker type.
Circle | The circle markers.
Cross | The cross markers.
Diamond | The diamond markers.
None | No markers should be displayed.
Square | The square markers.
Triangle | The triangle markers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.MarkerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


SortOrder Enumeration

[image]
ActiveReports 19 .NET Edition
SortOrder Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : SortOrder Enumeration

Glossary Item Box

Specifies the sort orders for chart data.

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits System.Enum
C#
public enum SortOrder : System.Enum

Members

Member | Description
Ascending | Sort from low values to high values.
Descending | Sort from high values to low values.
None | Do not sort.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.SortOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesDrawingStyle Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesDrawingStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesDrawingStyle Enumeration

Glossary Item Box

Specifies the 3D properties drawing styles enumeration.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesDrawingStyle
   Inherits System.Enum
C#
public enum ThreeDPropertiesDrawingStyle : System.Enum

Members

Member | Description
Cube | The cube drawing style.
Cylinder | The cylinder drawing style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesDrawingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesProjectionMode Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesProjectionMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesProjectionMode Enumeration

Glossary Item Box

Specifies the 3D properties projection mode enumeration.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesProjectionMode
   Inherits System.Enum
C#
public enum ThreeDPropertiesProjectionMode : System.Enum

Members

Member | Description
Orthographic | The orthographic projection.
Perspective | The perspective projection.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesProjectionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesShading Enumeration

[image]
ActiveReports 19 .NET Edition
ThreeDPropertiesShading Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesShading Enumeration

Glossary Item Box

Specifies the 3D properties shading enumeration.

Syntax

Visual Basic (Declaration)
Public Enum ThreeDPropertiesShading
   Inherits System.Enum
C#
public enum ThreeDPropertiesShading : System.Enum

Members

Member | Description
None | No shading.
Real | The real shading.
Simple | The simple shading.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


TickMark Enumeration

[image]
ActiveReports 19 .NET Edition
TickMark Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : TickMark Enumeration

Glossary Item Box

Specifies the tick mark enumeration.

Syntax

Visual Basic (Declaration)
Public Enum TickMark
   Inherits System.Enum
C#
public enum TickMark : System.Enum

Members

Member | Description
Cross | The cross tick mark.
Inside | The inside tick mark.
None | No tick mark.
Outside | The outside tick mark.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.TickMark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


TitlePosition Enumeration

[image]
ActiveReports 19 .NET Edition
TitlePosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : TitlePosition Enumeration

Glossary Item Box

Specifies the title position enumeration.

Syntax

Visual Basic (Declaration)
Public Enum TitlePosition
   Inherits System.Enum
C#
public enum TitlePosition : System.Enum

Members

Member | Description
Center | The center title position.
Far | The far title position.
Near | The near title position.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.TitlePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Structure

[image]
ActiveReports 19 .NET Edition
PaletteEntry Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

Glossary Item Box

Represents a chart palette entry.

Object Model

PaletteEntry Structure

Syntax

Visual Basic (Declaration)
Public Structure PaletteEntry
   Inherits System.ValueType
C#
public struct PaletteEntry : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.PaletteEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Structure Members

[image]
ActiveReports 19 .NET Edition
PaletteEntry Structure Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

Glossary Item Box

The following tables list the members exposed by PaletteEntry.

Public Constructors

 | Name | Description
Public Constructor | PaletteEntry Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Color | Specifies color of the palette entry.
static (Shared in Visual Basic) | Empty | The empty palette entry.
Public Field | HatchStyle | Specifies hatch style of the palette entry.
Top

Public Properties

 | Name | Description
Public Property | IsHatch | Gets a value indicating whether the entry defines a hatch style.
Top

Public Methods

 | Name | Description
Public Method | IsEmpty | Gets a value indicating whether the properties of the entry are unspecified.
Top

See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Constructor

[image]
ActiveReports 19 .NET Edition
PaletteEntry Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : PaletteEntry Constructor

Glossary Item Box

Overload List

Overload | Description
PaletteEntry Constructor(Color) | Initializes a palette entry with the specified color.
PaletteEntry Constructor(Byte) | Initializes palette entry with specified hatch style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Constructor(Color)

[image]
ActiveReports 19 .NET Edition
PaletteEntry Constructor(Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure > PaletteEntry Constructor : PaletteEntry Constructor(Color)

color
The color of palette entry.

Glossary Item Box

Initializes a palette entry with the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
C#
public PaletteEntry(
   Color color
)

Parameters

color
The color of palette entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members
Overload List


PaletteEntry Constructor(Byte)

[image]
ActiveReports 19 .NET Edition
PaletteEntry Constructor(Byte)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure > PaletteEntry Constructor : PaletteEntry Constructor(Byte)

style
The hatch style of palette entry.

Glossary Item Box

Initializes palette entry with specified hatch style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Byte _
)
C#
public PaletteEntry(
   byte style
)

Parameters

style
The hatch style of palette entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members
Overload List


PaletteEntry Structure Methods

[image]
ActiveReports 19 .NET Edition
PaletteEntry Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

Glossary Item Box

For a list of all members of this type, see PaletteEntry members.

Public Methods

 | Name | Description
Public Method | IsEmpty | Gets a value indicating whether the properties of the entry are unspecified.
Top

See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IsEmpty Method

[image]
ActiveReports 19 .NET Edition
IsEmpty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : IsEmpty Method

Glossary Item Box

Gets a value indicating whether the properties of the entry are unspecified.

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
C#
public bool IsEmpty()

Return Value

A System.Boolean value. true if the properties of the entry are unspecified; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Structure Properties

[image]
ActiveReports 19 .NET Edition
PaletteEntry Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

Glossary Item Box

For a list of all members of this type, see PaletteEntry members.

Public Properties

 | Name | Description
Public Property | IsHatch | Gets a value indicating whether the entry defines a hatch style.
Top

See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IsHatch Property

[image]
ActiveReports 19 .NET Edition
IsHatch Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : IsHatch Property

Glossary Item Box

Gets a value indicating whether the entry defines a hatch style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHatch As Boolean
C#
public bool IsHatch {get;}

Property Value

A System.Boolean value. true if the entry defines a hatch style; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Structure Fields

[image]
ActiveReports 19 .NET Edition
PaletteEntry Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

Glossary Item Box

For a list of all members of this type, see PaletteEntry members.

Public Fields

 | Name | Description
Public Field | Color | Specifies color of the palette entry.
static (Shared in Visual Basic) | Empty | The empty palette entry.
Public Field | HatchStyle | Specifies hatch style of the palette entry.
Top

See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Color Field

[image]
ActiveReports 19 .NET Edition
Color Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : Color Field

Glossary Item Box

Specifies color of the palette entry.

Syntax

Visual Basic (Declaration)
Public ReadOnly Color As Color
C#
public readonly Color Color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : Empty Field

Glossary Item Box

The empty palette entry.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As PaletteEntry
C#
public static readonly PaletteEntry Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


HatchStyle Field

[image]
ActiveReports 19 .NET Edition
HatchStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : HatchStyle Field

Glossary Item Box

Specifies hatch style of the palette entry.

Syntax

Visual Basic (Declaration)
Public ReadOnly HatchStyle As Byte
C#
public readonly byte HatchStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaletteEntry Structure
PaletteEntry Members


IAxis Interface

[image]
ActiveReports 19 .NET Edition
IAxis Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface

Glossary Item Box

Represents the axis information required for chart rendering.

Syntax

Visual Basic (Declaration)
Public Interface IAxis
C#
public interface IAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxis Interface Members

[image]
ActiveReports 19 .NET Edition
IAxis Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface

Glossary Item Box

The following tables list the members exposed by IAxis.

Public Properties

 | Name | Description
Property | CrossAt | Gets the value at which to cross the other axis.
Property | EndCap | Gets the end cap style to use for the axis.
Property | Interlaced | Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Property | LabelsTextOrientation | Gets the rotation angle of the axis labels text.
Property | Location | Gets the location of the axis inside the plot area (Left or Right). Applicable only for value axes.
Property | LogScale | Gets a value indicating whether the axis is logarithmic.
Property | MajorGridStyle | Gets the style of the axis major grid lines.
Property | MajorInterval | Gets the unit of measurement for major grid lines and tick marks.
Property | MajorTickMarks | Gets the style of the major tick marks.
Property | Margin | Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Property | Max | Gets the maximum value for the axis.
Property | Min | Gets the minimum value for the axis.
Property | MinorGridStyle | Gets the style of the axis minor grid lines.
Property | MinorInterval | Gets the unit of measurement for minor grid lines and tick marks.
Property | MinorTickMarks | Gets the style of the minor tick marks.
Property | Name | Gets the axis name.
Property | Offset | Gets the offset of the axis relative to the previous axis (for multiple Y-axes cases).
Property | ReferenceLine | Gets the axis's reference line.
Property | Reverse | Gets a value indicating whether the axis is plotted in reverse or normally.
Property | Scalar | Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Property | ShowMajorGridLines | Gets a value indicating whether the major grid lines are visible.
Property | ShowMinorGridLines | Gets a value indicating whether the minor grid lines are visible.
Property | Style | Gets the axis style.
Property | Title | Gets the style of the axis title.
Property | Visible | Gets a value indicating whether the axis labels are displayed.
Top

See Also

Reference

IAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxis Interface Properties

[image]
ActiveReports 19 .NET Edition
IAxis Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface

Glossary Item Box

For a list of all members of this type, see IAxis members.

Public Properties

 | Name | Description
Property | CrossAt | Gets the value at which to cross the other axis.
Property | EndCap | Gets the end cap style to use for the axis.
Property | Interlaced | Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Property | LabelsTextOrientation | Gets the rotation angle of the axis labels text.
Property | Location | Gets the location of the axis inside the plot area (Left or Right). Applicable only for value axes.
Property | LogScale | Gets a value indicating whether the axis is logarithmic.
Property | MajorGridStyle | Gets the style of the axis major grid lines.
Property | MajorInterval | Gets the unit of measurement for major grid lines and tick marks.
Property | MajorTickMarks | Gets the style of the major tick marks.
Property | Margin | Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Property | Max | Gets the maximum value for the axis.
Property | Min | Gets the minimum value for the axis.
Property | MinorGridStyle | Gets the style of the axis minor grid lines.
Property | MinorInterval | Gets the unit of measurement for minor grid lines and tick marks.
Property | MinorTickMarks | Gets the style of the minor tick marks.
Property | Name | Gets the axis name.
Property | Offset | Gets the offset of the axis relative to the previous axis (for multiple Y-axes cases).
Property | ReferenceLine | Gets the axis's reference line.
Property | Reverse | Gets a value indicating whether the axis is plotted in reverse or normally.
Property | Scalar | Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Property | ShowMajorGridLines | Gets a value indicating whether the major grid lines are visible.
Property | ShowMinorGridLines | Gets a value indicating whether the minor grid lines are visible.
Property | Style | Gets the axis style.
Property | Title | Gets the style of the axis title.
Property | Visible | Gets a value indicating whether the axis labels are displayed.
Top

See Also

Reference

IAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


CrossAt Property

[image]
ActiveReports 19 .NET Edition
CrossAt Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : CrossAt Property

Glossary Item Box

Gets the value at which to cross the other axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property CrossAt As Nullable(Of Double)
C#
Nullable<double> CrossAt {get;}

Property Value

A Nullable specifying the cross at value.

Remarks

If this value is omitted, it uses the default value for the chart type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


EndCap Property

[image]
ActiveReports 19 .NET Edition
EndCap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : EndCap Property

Glossary Item Box

Gets the end cap style to use for the axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndCap As String
C#
string EndCap {get;}

Property Value

A System.String specifying the end cap style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Interlaced Property

[image]
ActiveReports 19 .NET Edition
Interlaced Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Interlaced Property

Glossary Item Box

Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.

Syntax

Visual Basic (Declaration)
ReadOnly Property Interlaced As Boolean
C#
bool Interlaced {get;}

Property Value

A System.Boolean value. true if strip lines are drawn for every second grid line interval; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


LabelsTextOrientation Property

[image]
ActiveReports 19 .NET Edition
LabelsTextOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : LabelsTextOrientation Property

Glossary Item Box

Gets the rotation angle of the axis labels text.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelsTextOrientation As AxisLabelOrientation
C#
AxisLabelOrientation LabelsTextOrientation {get;}

Property Value

An AxisLabelOrientation value specifying the rotation angle of the axis labels text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Location Property

Glossary Item Box

Gets the location of the axis inside the plot area (Left or Right). Applicable only for value axes.

Syntax

Visual Basic (Declaration)
ReadOnly Property Location As AxisLocation
C#
AxisLocation Location {get;}

Property Value

An AxisLocation value specifying the location of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


LogScale Property

[image]
ActiveReports 19 .NET Edition
LogScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : LogScale Property

Glossary Item Box

Gets a value indicating whether the axis is logarithmic.

Syntax

Visual Basic (Declaration)
ReadOnly Property LogScale As Boolean
C#
bool LogScale {get;}

Property Value

A System.Boolean value. true if the axis is logarithmic; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MajorGridStyle Property

[image]
ActiveReports 19 .NET Edition
MajorGridStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorGridStyle Property

Glossary Item Box

Gets the style of the axis major grid lines.

Syntax

Visual Basic (Declaration)
ReadOnly Property MajorGridStyle As IStyle
C#
IStyle MajorGridStyle {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the axis major grid lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MajorInterval Property

[image]
ActiveReports 19 .NET Edition
MajorInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorInterval Property

Glossary Item Box

Gets the unit of measurement for major grid lines and tick marks.

Syntax

Visual Basic (Declaration)
ReadOnly Property MajorInterval As Nullable(Of Double)
C#
Nullable<double> MajorInterval {get;}

Property Value

A Nullable specifying the major interval.

Remarks

If omitted, the axis is automatically divided.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MajorTickMarks Property

[image]
ActiveReports 19 .NET Edition
MajorTickMarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorTickMarks Property

Glossary Item Box

Gets the style of the major tick marks.

Syntax

Visual Basic (Declaration)
ReadOnly Property MajorTickMarks As TickMark
C#
TickMark MajorTickMarks {get;}

Property Value

A TickMark specifying the style of the major tick marks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Margin Property

[image]
ActiveReports 19 .NET Edition
Margin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Margin Property

Glossary Item Box

Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.

Syntax

Visual Basic (Declaration)
ReadOnly Property Margin As Boolean
C#
bool Margin {get;}

Property Value

A System.Boolean value. true if an axis margin is created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Max Property

[image]
ActiveReports 19 .NET Edition
Max Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Max Property

Glossary Item Box

Gets the maximum value for the axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property Max As Nullable(Of Double)
C#
Nullable<double> Max {get;}

Property Value

A Nullable specifying the maximum value.

Remarks

If omitted, the axis automatically scales.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Min Property

[image]
ActiveReports 19 .NET Edition
Min Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Min Property

Glossary Item Box

Gets the minimum value for the axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property Min As Nullable(Of Double)
C#
Nullable<double> Min {get;}

Property Value

A Nullable specifying the minimum value.

Remarks

If omitted, the axis automatically scales.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MinorGridStyle Property

[image]
ActiveReports 19 .NET Edition
MinorGridStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorGridStyle Property

Glossary Item Box

Gets the style of the axis minor grid lines.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinorGridStyle As IStyle
C#
IStyle MinorGridStyle {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the axis minor grid lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MinorInterval Property

[image]
ActiveReports 19 .NET Edition
MinorInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorInterval Property

Glossary Item Box

Gets the unit of measurement for minor grid lines and tick marks.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinorInterval As Nullable(Of Double)
C#
Nullable<double> MinorInterval {get;}

Property Value

A Nullable specifying the minor interval.

Remarks

If omitted, the axis is automatically divided.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


MinorTickMarks Property

[image]
ActiveReports 19 .NET Edition
MinorTickMarks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorTickMarks Property

Glossary Item Box

Gets the style of the minor tick marks.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinorTickMarks As TickMark
C#
TickMark MinorTickMarks {get;}

Property Value

A TickMark specifying the style of the minor tick marks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Name Property

Glossary Item Box

Gets the axis name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String specifying the name of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Offset Property

[image]
ActiveReports 19 .NET Edition
Offset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Offset Property

Glossary Item Box

Gets the offset of the axis relative to the previous axis (for multiple Y-axes cases).

Syntax

Visual Basic (Declaration)
ReadOnly Property Offset As Length
C#
Length Offset {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the offset of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


ReferenceLine Property

[image]
ActiveReports 19 .NET Edition
ReferenceLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : ReferenceLine Property

Glossary Item Box

Gets the axis's reference line.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReferenceLine As IReferenceLine
C#
IReferenceLine ReferenceLine {get;}

Property Value

An IReferenceLine specifying the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Reverse Property

[image]
ActiveReports 19 .NET Edition
Reverse Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Reverse Property

Glossary Item Box

Gets a value indicating whether the axis is plotted in reverse or normally.

Syntax

Visual Basic (Declaration)
ReadOnly Property Reverse As Boolean
C#
bool Reverse {get;}

Property Value

A System.Boolean value. true if the axis direction is reversed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Scalar Property

[image]
ActiveReports 19 .NET Edition
Scalar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Scalar Property

Glossary Item Box

Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.

Syntax

Visual Basic (Declaration)
ReadOnly Property Scalar As Boolean
C#
bool Scalar {get;}

Property Value

A System.Boolean value. true if the values along the axis are scalar; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


ShowMajorGridLines Property

[image]
ActiveReports 19 .NET Edition
ShowMajorGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : ShowMajorGridLines Property

Glossary Item Box

Gets a value indicating whether the major grid lines are visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShowMajorGridLines As Boolean
C#
bool ShowMajorGridLines {get;}

Property Value

A System.Boolean value. true if the major grid lines are visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


ShowMinorGridLines Property

[image]
ActiveReports 19 .NET Edition
ShowMinorGridLines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : ShowMinorGridLines Property

Glossary Item Box

Gets a value indicating whether the minor grid lines are visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShowMinorGridLines As Boolean
C#
bool ShowMinorGridLines {get;}

Property Value

A System.Boolean value. true if the minor grid lines are visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Style Property

Glossary Item Box

Gets the axis style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Title Property

Glossary Item Box

Gets the style of the axis title.

Syntax

Visual Basic (Declaration)
ReadOnly Property Title As IAxisTitle
C#
IAxisTitle Title {get;}

Property Value

An IAxisTitle specifying the style of the axis title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Visible Property

Glossary Item Box

Gets a value indicating whether the axis labels are displayed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Property Value

A System.Boolean value. true if the axis labels are displayed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxis Interface
IAxis Members


IAxisTitle Interface

[image]
ActiveReports 19 .NET Edition
IAxisTitle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxisTitle Interface

Glossary Item Box

Represents the interface for a chart axis title.

Syntax

Visual Basic (Declaration)
Public Interface IAxisTitle
   Inherits ITitle
C#
public interface IAxisTitle : ITitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxisTitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxisTitle Interface Members

[image]
ActiveReports 19 .NET Edition
IAxisTitle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxisTitle Interface

Glossary Item Box

The following tables list the members exposed by IAxisTitle.

Public Properties

 | Name | Description
Property | TextOrientation | Gets the rotation angle of the axis title text.
Top

See Also

Reference

IAxisTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxisTitle Interface Properties

[image]
ActiveReports 19 .NET Edition
IAxisTitle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxisTitle Interface

Glossary Item Box

For a list of all members of this type, see IAxisTitle members.

Public Properties

 | Name | Description
Property | TextOrientation | Gets the rotation angle of the axis title text.
Top

See Also

Reference

IAxisTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


TextOrientation Property

[image]
ActiveReports 19 .NET Edition
TextOrientation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxisTitle Interface : TextOrientation Property

Glossary Item Box

Gets the rotation angle of the axis title text.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextOrientation As AxisTextOrientation
C#
AxisTextOrientation TextOrientation {get;}

Property Value

An AxisTextOrientation value specifying the rotation angle of the axis title text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAxisTitle Interface
IAxisTitle Members


IChart Interface

[image]
ActiveReports 19 .NET Edition
IChart Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

Glossary Item Box

Represents the interface for the chart report item.

Syntax

Visual Basic (Declaration)
Public Interface IChart
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
C#
public interface IChart : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChart Interface Members

[image]
ActiveReports 19 .NET Edition
IChart Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

Glossary Item Box

The following tables list the members exposed by IChart.

Public Properties

 | Name | Description
Property | CategoriesCount | Gets the count of the number of categories in this chart.
Property | CategoryAxis | Gets the chart category axis.
Property | CategoryGroupingsCount | Gets the number of category groupings defined in the chart definition.
Property | CategoryMemberCollection | Gets the top-level category grouping members.
Property | ChartSeries | Gets the chart series collection.
Property | ChartValueAxes | Gets the chart value axes collection.
Property | DataPointCategoryCount | Gets the category count.
Property | DataPointCollection | Gets the data point collection.
Property | DataPointSeriesCount | Gets the series count.
Property | DefinitionSeriesCount | Gets the count of series defined in the chart data of the chart definition.
Property | Legend | Gets the chart legend.
Property | Palette | Gets the chart palette.
Property | PlainCategoryMembers | Gets the category members as an array of chart members.
Property | PlainSeriesMembers | Gets the series members as an array of chart members.
Property | PlotArea | Gets the chart plot area.
Property | PointWidth | Specifies the point width.
Property | ReferenceLine | Gets the reference line.
Property | SeriesCount | Gets the count of the number of series in this chart.
Property | SeriesMemberCollection | Gets the series member collection.
Property | Subtype | Gets the chart subtype.
Property | ThreeDProperties | Gets the properties to setup the 3D-chart.
Property | Title | Gets the chart title properties.
Property | Type | Gets the chart type.
Top

See Also

Reference

IChart Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChart Interface Properties

[image]
ActiveReports 19 .NET Edition
IChart Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

Glossary Item Box

For a list of all members of this type, see IChart members.

Public Properties

 | Name | Description
Property | CategoriesCount | Gets the count of the number of categories in this chart.
Property | CategoryAxis | Gets the chart category axis.
Property | CategoryGroupingsCount | Gets the number of category groupings defined in the chart definition.
Property | CategoryMemberCollection | Gets the top-level category grouping members.
Property | ChartSeries | Gets the chart series collection.
Property | ChartValueAxes | Gets the chart value axes collection.
Property | DataPointCategoryCount | Gets the category count.
Property | DataPointCollection | Gets the data point collection.
Property | DataPointSeriesCount | Gets the series count.
Property | DefinitionSeriesCount | Gets the count of series defined in the chart data of the chart definition.
Property | Legend | Gets the chart legend.
Property | Palette | Gets the chart palette.
Property | PlainCategoryMembers | Gets the category members as an array of chart members.
Property | PlainSeriesMembers | Gets the series members as an array of chart members.
Property | PlotArea | Gets the chart plot area.
Property | PointWidth | Specifies the point width.
Property | ReferenceLine | Gets the reference line.
Property | SeriesCount | Gets the count of the number of series in this chart.
Property | SeriesMemberCollection | Gets the series member collection.
Property | Subtype | Gets the chart subtype.
Property | ThreeDProperties | Gets the properties to setup the 3D-chart.
Property | Title | Gets the chart title properties.
Property | Type | Gets the chart type.
Top

See Also

Reference

IChart Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


CategoriesCount Property

[image]
ActiveReports 19 .NET Edition
CategoriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoriesCount Property

Glossary Item Box

Gets the count of the number of categories in this chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property CategoriesCount As Integer
C#
int CategoriesCount {get;}

Property Value

An System.Int32 specifying the count of the number of categories in this chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


CategoryAxis Property

[image]
ActiveReports 19 .NET Edition
CategoryAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryAxis Property

Glossary Item Box

Gets the chart category axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property CategoryAxis As IAxis
C#
IAxis CategoryAxis {get;}

Property Value

An IAxis specifying the category axis of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


CategoryGroupingsCount Property

[image]
ActiveReports 19 .NET Edition
CategoryGroupingsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryGroupingsCount Property

Glossary Item Box

Gets the number of category groupings defined in the chart definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property CategoryGroupingsCount As Integer
C#
int CategoryGroupingsCount {get;}

Property Value

An System.Int32 specifying the number of category groupings defined in the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


CategoryMemberCollection Property

[image]
ActiveReports 19 .NET Edition
CategoryMemberCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryMemberCollection Property

Glossary Item Box

Gets the top-level category grouping members.

Syntax

Visual Basic (Declaration)
ReadOnly Property CategoryMemberCollection As IItemCollection(Of IChartMember)
C#
IItemCollection<IChartMember> CategoryMemberCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the top-level category grouping members.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


ChartSeries Property

[image]
ActiveReports 19 .NET Edition
ChartSeries Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ChartSeries Property

Glossary Item Box

Gets the chart series collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property ChartSeries As IChartSeries()
C#
IChartSeries[] ChartSeries {get;}

Property Value

An array of IChartSeries representing the chart series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


ChartValueAxes Property

[image]
ActiveReports 19 .NET Edition
ChartValueAxes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ChartValueAxes Property

Glossary Item Box

Gets the chart value axes collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property ChartValueAxes As IAxis()
C#
IAxis[] ChartValueAxes {get;}

Property Value

An array of IAxis representing the chart value axes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


DataPointCategoryCount Property

[image]
ActiveReports 19 .NET Edition
DataPointCategoryCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointCategoryCount Property

Glossary Item Box

Gets the category count.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataPointCategoryCount As Integer
C#
int DataPointCategoryCount {get;}

Property Value

An System.Int32 specifying the category count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


DataPointCollection Property

[image]
ActiveReports 19 .NET Edition
DataPointCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointCollection Property

Glossary Item Box

Gets the data point collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataPointCollection As IChartDataPointCollection
C#
IChartDataPointCollection DataPointCollection {get;}

Property Value

An IChartDataPointCollection representing the data point collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


DataPointSeriesCount Property

[image]
ActiveReports 19 .NET Edition
DataPointSeriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointSeriesCount Property

Glossary Item Box

Gets the series count.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataPointSeriesCount As Integer
C#
int DataPointSeriesCount {get;}

Property Value

An System.Int32 specifying the series count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


DefinitionSeriesCount Property

[image]
ActiveReports 19 .NET Edition
DefinitionSeriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DefinitionSeriesCount Property

Glossary Item Box

Gets the count of series defined in the chart data of the chart definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property DefinitionSeriesCount As Integer
C#
int DefinitionSeriesCount {get;}

Property Value

An System.Int32 specifying the count of series defined in the chart data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


Legend Property

[image]
ActiveReports 19 .NET Edition
Legend Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Legend Property

Glossary Item Box

Gets the chart legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property Legend As ILegend
C#
ILegend Legend {get;}

Property Value

An ILegend specifying the legend of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


Palette Property

[image]
ActiveReports 19 .NET Edition
Palette Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Palette Property

Glossary Item Box

Gets the chart palette.

Syntax

Visual Basic (Declaration)
ReadOnly Property Palette As IPalette
C#
IPalette Palette {get;}

Property Value

An IPalette specifying the palette of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


PlainCategoryMembers Property

[image]
ActiveReports 19 .NET Edition
PlainCategoryMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlainCategoryMembers Property

Glossary Item Box

Gets the category members as an array of chart members.

Syntax

Visual Basic (Declaration)
ReadOnly Property PlainCategoryMembers As IChartMember()
C#
IChartMember[] PlainCategoryMembers {get;}

Property Value

An array of IChartMember representing the category members.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


PlainSeriesMembers Property

[image]
ActiveReports 19 .NET Edition
PlainSeriesMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlainSeriesMembers Property

Glossary Item Box

Gets the series members as an array of chart members.

Syntax

Visual Basic (Declaration)
ReadOnly Property PlainSeriesMembers As IChartMember()
C#
IChartMember[] PlainSeriesMembers {get;}

Property Value

An array of IChartMember representing the series members.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


PlotArea Property

[image]
ActiveReports 19 .NET Edition
PlotArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlotArea Property

Glossary Item Box

Gets the chart plot area.

Syntax

Visual Basic (Declaration)
ReadOnly Property PlotArea As IPlotArea
C#
IPlotArea PlotArea {get;}

Property Value

An IPlotArea specifying the plot area of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


PointWidth Property

[image]
ActiveReports 19 .NET Edition
PointWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PointWidth Property

Glossary Item Box

Specifies the point width.

Syntax

Visual Basic (Declaration)
ReadOnly Property PointWidth As Nullable(Of Integer)
C#
Nullable<int> PointWidth {get;}

Property Value

An Nullable specifying the point width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


ReferenceLine Property

[image]
ActiveReports 19 .NET Edition
ReferenceLine Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ReferenceLine Property

Glossary Item Box

Gets the reference line.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReferenceLine As IReferenceLine
C#
IReferenceLine ReferenceLine {get;}

Property Value

An IReferenceLine specifying the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


SeriesCount Property

[image]
ActiveReports 19 .NET Edition
SeriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : SeriesCount Property

Glossary Item Box

Gets the count of the number of series in this chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property SeriesCount As Integer
C#
int SeriesCount {get;}

Property Value

An System.Int32 specifying the count of the number of series in this chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


SeriesMemberCollection Property

[image]
ActiveReports 19 .NET Edition
SeriesMemberCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : SeriesMemberCollection Property

Glossary Item Box

Gets the series member collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property SeriesMemberCollection As IItemCollection(Of IChartMember)
C#
IItemCollection<IChartMember> SeriesMemberCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the series member collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


Subtype Property

[image]
ActiveReports 19 .NET Edition
Subtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Subtype Property

Glossary Item Box

Gets the chart subtype.

Syntax

Visual Basic (Declaration)
ReadOnly Property Subtype As ChartSubtype
C#
ChartSubtype Subtype {get;}

Property Value

A ChartSubtype specifying the subtype of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


ThreeDProperties Property

[image]
ActiveReports 19 .NET Edition
ThreeDProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ThreeDProperties Property

Glossary Item Box

Gets the properties to setup the 3D-chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property ThreeDProperties As IThreeDProperties
C#
IThreeDProperties ThreeDProperties {get;}

Property Value

An IThreeDProperties specifying the 3D properties of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Title Property

Glossary Item Box

Gets the chart title properties.

Syntax

Visual Basic (Declaration)
ReadOnly Property Title As ITitle
C#
ITitle Title {get;}

Property Value

An ITitle specifying the title properties of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Type Property

Glossary Item Box

Gets the chart type.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As ChartType
C#
ChartType Type {get;}

Property Value

A ChartType specifying the type of the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChart Interface
IChart Members


IChartDataPoint Interface

[image]
ActiveReports 19 .NET Edition
IChartDataPoint Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface

Glossary Item Box

Represents the interface for chart data points.

Syntax

Visual Basic (Declaration)
Public Interface IChartDataPoint
C#
public interface IChartDataPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPoint Interface Members

[image]
ActiveReports 19 .NET Edition
IChartDataPoint Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface

Glossary Item Box

The following tables list the members exposed by IChartDataPoint.

Public Properties

 | Name | Description
Property | Action | Gets the default action to perform for this instance.
Property | CustomProperties | Gets the custom properties for this data point.
Property | DataElementName | Gets the name used for this chart data point in data renderings.
Property | DataElementOutput | Gets a value indicating how to render the item in data renderings.
Property | DataLabel | Gets the data label style.
Property | DataValues | Gets the values for the data point.
Property | MapAreas | Gets the image map areas contained within the IChartDataPoint.
Property | Marker | Gets the data point marker style.
Property | ShowBeginEndMarkersOnly | Gets a value indicating whether only the first and last markers are shown for the data point; otherwise, all markers are shown.
Property | Style | Gets the data point style.
Property | StyleProperties | Gets the properties to customize rendering for specific chart types.
Property | ToolTip | Gets the data point tooltip.
Top

See Also

Reference

IChartDataPoint Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPoint Interface Properties

[image]
ActiveReports 19 .NET Edition
IChartDataPoint Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface

Glossary Item Box

For a list of all members of this type, see IChartDataPoint members.

Public Properties

 | Name | Description
Property | Action | Gets the default action to perform for this instance.
Property | CustomProperties | Gets the custom properties for this data point.
Property | DataElementName | Gets the name used for this chart data point in data renderings.
Property | DataElementOutput | Gets a value indicating how to render the item in data renderings.
Property | DataLabel | Gets the data label style.
Property | DataValues | Gets the values for the data point.
Property | MapAreas | Gets the image map areas contained within the IChartDataPoint.
Property | Marker | Gets the data point marker style.
Property | ShowBeginEndMarkersOnly | Gets a value indicating whether only the first and last markers are shown for the data point; otherwise, all markers are shown.
Property | Style | Gets the data point style.
Property | StyleProperties | Gets the properties to customize rendering for specific chart types.
Property | ToolTip | Gets the data point tooltip.
Top

See Also

Reference

IChartDataPoint Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Action Property

Glossary Item Box

Gets the default action to perform for this instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction specifying the default action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


CustomProperties Property

[image]
ActiveReports 19 .NET Edition
CustomProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : CustomProperties Property

Glossary Item Box

Gets the custom properties for this data point.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomProperties As CustomPropertyCollection
C#
CustomPropertyCollection CustomProperties {get;}

Property Value

A GrapeCity.ActiveReports.Extensibility.Rendering.CustomPropertyCollection specifying the custom properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataElementName Property

Glossary Item Box

Gets the name used for this chart data point in data renderings.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String specifying the data element name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataElementOutput Property

Glossary Item Box

Gets a value indicating how to render the item in data renderings.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value specifying the rendering behavior.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataLabel Property

[image]
ActiveReports 19 .NET Edition
DataLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataLabel Property

Glossary Item Box

Gets the data label style.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataLabel As IDataLabel
C#
IDataLabel DataLabel {get;}

Property Value

An IDataLabel specifying the data label style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataValues Property

[image]
ActiveReports 19 .NET Edition
DataValues Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataValues Property

Glossary Item Box

Gets the values for the data point.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataValues As Object()
C#
object[] DataValues {get;}

Property Value

An array of System.Object representing the data values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


MapAreas Property

[image]
ActiveReports 19 .NET Edition
MapAreas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : MapAreas Property

Glossary Item Box

Gets the image map areas contained within the IChartDataPoint.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapAreas As Collection(Of ImageMapArea)
C#
Collection<ImageMapArea> MapAreas {get;}

Property Value

A Collection specifying the map areas.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Marker Property

Glossary Item Box

Gets the data point marker style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Marker As IMarker
C#
IMarker Marker {get;}

Property Value

An IMarker specifying the marker style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


ShowBeginEndMarkersOnly Property

[image]
ActiveReports 19 .NET Edition
ShowBeginEndMarkersOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : ShowBeginEndMarkersOnly Property

Glossary Item Box

Gets a value indicating whether only the first and last markers are shown for the data point; otherwise, all markers are shown.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShowBeginEndMarkersOnly As Boolean
C#
bool ShowBeginEndMarkersOnly {get;}

Property Value

A System.Boolean value. true if only the first and last markers are shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Style Property

Glossary Item Box

Gets the data point style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


StyleProperties Property

[image]
ActiveReports 19 .NET Edition
StyleProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : StyleProperties Property

Glossary Item Box

Gets the properties to customize rendering for specific chart types.

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleProperties As IEnumerable(Of KeyValuePair(Of String,String))
C#
IEnumerable<KeyValuePair<string,string>> StyleProperties {get;}

Property Value

An enumerable specifying the style properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : ToolTip Property

Glossary Item Box

Gets the data point tooltip.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolTip As String
C#
string ToolTip {get;}

Property Value

A System.String specifying the tooltip text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


IChartDataPointCollection Interface

[image]
ActiveReports 19 .NET Edition
IChartDataPointCollection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface

Glossary Item Box

Represents a collection of chart data point objects.

Syntax

Visual Basic (Declaration)
Public Interface IChartDataPointCollection
C#
public interface IChartDataPointCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPointCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPointCollection Interface Members

[image]
ActiveReports 19 .NET Edition
IChartDataPointCollection Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface

Glossary Item Box

The following tables list the members exposed by IChartDataPointCollection.

Public Properties

 | Name | Description
Property | CategoryCount | Gets the number of categories in the data point collection.
Property | Count | Gets the number of category*series cells.
Property | Item | Gets the two-dimensional array of data points in the chart.
Property | SeriesCount | Gets the number of series in the data point collection.
Top

See Also

Reference

IChartDataPointCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPointCollection Interface Properties

[image]
ActiveReports 19 .NET Edition
IChartDataPointCollection Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface

Glossary Item Box

For a list of all members of this type, see IChartDataPointCollection members.

Public Properties

 | Name | Description
Property | CategoryCount | Gets the number of categories in the data point collection.
Property | Count | Gets the number of category*series cells.
Property | Item | Gets the two-dimensional array of data points in the chart.
Property | SeriesCount | Gets the number of series in the data point collection.
Top

See Also

Reference

IChartDataPointCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


CategoryCount Property

[image]
ActiveReports 19 .NET Edition
CategoryCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : CategoryCount Property

Glossary Item Box

Gets the number of categories in the data point collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property CategoryCount As Integer
C#
int CategoryCount {get;}

Property Value

An System.Int32 specifying the number of categories.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : Count Property

Glossary Item Box

Gets the number of category*series cells.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Property Value

An System.Int32 specifying the total number of data points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : Item Property

series
The series index of the item.
category
The category index of the item.

Glossary Item Box

Gets the two-dimensional array of data points in the chart.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal series As Integer, _
   ByVal category As Integer _
) As IChartDataPoint
C#
IChartDataPoint this[
   int series,
   int category
]; {get;}

Parameters

series
The series index of the item.
category
The category index of the item.

Property Value

An IChartDataPoint representing the data point at the specified series and category indices.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


SeriesCount Property

[image]
ActiveReports 19 .NET Edition
SeriesCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : SeriesCount Property

Glossary Item Box

Gets the number of series in the data point collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property SeriesCount As Integer
C#
int SeriesCount {get;}

Property Value

An System.Int32 specifying the number of series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


IChartMember Interface

[image]
ActiveReports 19 .NET Edition
IChartMember Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

Glossary Item Box

Represents the interface for chart members.

Syntax

Visual Basic (Declaration)
Public Interface IChartMember
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
C#
public interface IChartMember : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMember Interface Members

[image]
ActiveReports 19 .NET Edition
IChartMember Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

Glossary Item Box

The following tables list the members exposed by IChartMember.

Public Properties

 | Name | Description
Property | Children | Gets the members collection of a chart series or category.
Property | IsInnerMostMember | Gets a value indicating whether the current chart member has no child items.
Property | IsStatic | Gets a value indicating whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.
Property | IsToggleChild | Gets a value indicating whether this member is a child of a toggle item.
Property | MemberDataPointIndex | Gets the index location of the current member in the grid of data points.
Property | MemberHeadingSpan | Gets the number of innermost group instances that the current chart member spans.
Property | Parent | Gets the parent member of the current chart member.
Property | SortOrder | Gets the order in which the data is sorted. Possible values are Ascending, Descending, or None.
Property | ToggleParent | Gets the parent toggle item of this member.
Top

See Also

Reference

IChartMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMember Interface Properties

[image]
ActiveReports 19 .NET Edition
IChartMember Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

Glossary Item Box

For a list of all members of this type, see IChartMember members.

Public Properties

 | Name | Description
Property | Children | Gets the members collection of a chart series or category.
Property | IsInnerMostMember | Gets a value indicating whether the current chart member has no child items.
Property | IsStatic | Gets a value indicating whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.
Property | IsToggleChild | Gets a value indicating whether this member is a child of a toggle item.
Property | MemberDataPointIndex | Gets the index location of the current member in the grid of data points.
Property | MemberHeadingSpan | Gets the number of innermost group instances that the current chart member spans.
Property | Parent | Gets the parent member of the current chart member.
Property | SortOrder | Gets the order in which the data is sorted. Possible values are Ascending, Descending, or None.
Property | ToggleParent | Gets the parent toggle item of this member.
Top

See Also

Reference

IChartMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : Children Property

Glossary Item Box

Gets the members collection of a chart series or category.

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IItemCollection(Of IChartMember)
C#
IItemCollection<IChartMember> Children {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the child members of the current chart member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


IsInnerMostMember Property

[image]
ActiveReports 19 .NET Edition
IsInnerMostMember Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsInnerMostMember Property

Glossary Item Box

Gets a value indicating whether the current chart member has no child items.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsInnerMostMember As Boolean
C#
bool IsInnerMostMember {get;}

Property Value

A System.Boolean value. true if the current chart member has no child items; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsStatic Property

Glossary Item Box

Gets a value indicating whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Property Value

A System.Boolean value. true if the chart member is static; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


IsToggleChild Property

[image]
ActiveReports 19 .NET Edition
IsToggleChild Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsToggleChild Property

Glossary Item Box

Gets a value indicating whether this member is a child of a toggle item.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsToggleChild As Boolean
C#
bool IsToggleChild {get;}

Property Value

A System.Boolean value. true if this member is a child of a toggle item; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


MemberDataPointIndex Property

[image]
ActiveReports 19 .NET Edition
MemberDataPointIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : MemberDataPointIndex Property

Glossary Item Box

Gets the index location of the current member in the grid of data points.

Syntax

Visual Basic (Declaration)
ReadOnly Property MemberDataPointIndex As Integer
C#
int MemberDataPointIndex {get;}

Property Value

An System.Int32 specifying the index location of the current member in the data point grid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


MemberHeadingSpan Property

[image]
ActiveReports 19 .NET Edition
MemberHeadingSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : MemberHeadingSpan Property

Glossary Item Box

Gets the number of innermost group instances that the current chart member spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property MemberHeadingSpan As Integer
C#
int MemberHeadingSpan {get;}

Property Value

An System.Int32 specifying the number of innermost group instances spanned by the current chart member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : Parent Property

Glossary Item Box

Gets the parent member of the current chart member.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As IChartMember
C#
IChartMember Parent {get;}

Property Value

An IChartMember representing the parent member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


SortOrder Property

[image]
ActiveReports 19 .NET Edition
SortOrder Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : SortOrder Property

Glossary Item Box

Gets the order in which the data is sorted. Possible values are Ascending, Descending, or None.

Syntax

Visual Basic (Declaration)
ReadOnly Property SortOrder As SortOrder
C#
SortOrder SortOrder {get;}

Property Value

A SortOrder value specifying the sort order of the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


ToggleParent Property

[image]
ActiveReports 19 .NET Edition
ToggleParent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : ToggleParent Property

Glossary Item Box

Gets the parent toggle item of this member.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToggleParent As ITextBox
C#
ITextBox ToggleParent {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextBox representing the toggle parent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartMember Interface
IChartMember Members


IChartSeries Interface

[image]
ActiveReports 19 .NET Edition
IChartSeries Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartSeries Interface

Glossary Item Box

Represents chart series data.

Syntax

Visual Basic (Declaration)
Public Interface IChartSeries
C#
public interface IChartSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartSeries Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartSeries Interface Members

[image]
ActiveReports 19 .NET Edition
IChartSeries Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartSeries Interface

Glossary Item Box

The following tables list the members exposed by IChartSeries.

Public Properties

 | Name | Description
Property | Subtype | Gets the subtype of the series.
Property | Type | Gets the type of the series.
Property | ValueAxis | Gets the value axis of the series.
Top

See Also

Reference

IChartSeries Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartSeries Interface Properties

[image]
ActiveReports 19 .NET Edition
IChartSeries Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartSeries Interface

Glossary Item Box

For a list of all members of this type, see IChartSeries members.

Public Properties

 | Name | Description
Property | Subtype | Gets the subtype of the series.
Property | Type | Gets the type of the series.
Property | ValueAxis | Gets the value axis of the series.
Top

See Also

Reference

IChartSeries Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Subtype Property

[image]
ActiveReports 19 .NET Edition
Subtype Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartSeries Interface : Subtype Property

Glossary Item Box

Gets the subtype of the series.

Syntax

Visual Basic (Declaration)
ReadOnly Property Subtype As ChartSubtype
C#
ChartSubtype Subtype {get;}

Property Value

A ChartSubtype specifying the subtype of the series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartSeries Interface
IChartSeries Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartSeries Interface : Type Property

Glossary Item Box

Gets the type of the series.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As ChartType
C#
ChartType Type {get;}

Property Value

A ChartType specifying the type of the series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartSeries Interface
IChartSeries Members


ValueAxis Property

[image]
ActiveReports 19 .NET Edition
ValueAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartSeries Interface : ValueAxis Property

Glossary Item Box

Gets the value axis of the series.

Syntax

Visual Basic (Declaration)
ReadOnly Property ValueAxis As IAxis
C#
IAxis ValueAxis {get;}

Property Value

An IAxis specifying the value axis of the series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartSeries Interface
IChartSeries Members


IDataLabel Interface

[image]
ActiveReports 19 .NET Edition
IDataLabel Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface

Glossary Item Box

Represents the interface for styling labels of the chart data point values.

Syntax

Visual Basic (Declaration)
Public Interface IDataLabel
C#
public interface IDataLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IDataLabel Interface Members

[image]
ActiveReports 19 .NET Edition
IDataLabel Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface

Glossary Item Box

The following tables list the members exposed by IDataLabel.

Public Properties

 | Name | Description
Property | Position | Gets the position of the label.
Property | Rotation | Gets the angle of rotation of the label text.
Property | Style | Gets the text, border, and background style properties for the labels.
Property | Value | Gets the label text to use for the value labels.
Property | Visible | Gets a value indicating whether the data label is displayed on the chart.
Top

See Also

Reference

IDataLabel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IDataLabel Interface Properties

[image]
ActiveReports 19 .NET Edition
IDataLabel Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface

Glossary Item Box

For a list of all members of this type, see IDataLabel members.

Public Properties

 | Name | Description
Property | Position | Gets the position of the label.
Property | Rotation | Gets the angle of rotation of the label text.
Property | Style | Gets the text, border, and background style properties for the labels.
Property | Value | Gets the label text to use for the value labels.
Property | Visible | Gets a value indicating whether the data label is displayed on the chart.
Top

See Also

Reference

IDataLabel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Position Property

Glossary Item Box

Gets the position of the label.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Position
C#
Position Position {get;}

Property Value

A Position value specifying the position of the label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Interface
IDataLabel Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Rotation Property

Glossary Item Box

Gets the angle of rotation of the label text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rotation As Nullable(Of Integer)
C#
Nullable<int> Rotation {get;}

Property Value

An Nullable specifying the rotation angle of the label text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Interface
IDataLabel Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Style Property

Glossary Item Box

Gets the text, border, and background style properties for the labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Interface
IDataLabel Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Value Property

Glossary Item Box

Gets the label text to use for the value labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As String
C#
string Value {get;}

Property Value

A System.String specifying the label text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Interface
IDataLabel Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Visible Property

Glossary Item Box

Gets a value indicating whether the data label is displayed on the chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Property Value

A System.Boolean value. true if the data label is displayed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataLabel Interface
IDataLabel Members


ILegend Interface

[image]
ActiveReports 19 .NET Edition
ILegend Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface

Glossary Item Box

Represents the interface for chart legend.

Syntax

Visual Basic (Declaration)
Public Interface ILegend
C#
public interface ILegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ILegend Interface Members

[image]
ActiveReports 19 .NET Edition
ILegend Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface

Glossary Item Box

The following tables list the members exposed by ILegend.

Public Properties

 | Name | Description
Property | InsidePlotArea | Gets a value indicating whether the legend is inside the plot area.
Property | Layout | Gets the layout of the legend.
Property | Position | Gets the position of the legend.
Property | Style | Gets the style for the legend.
Property | UseSmartSettings | Gets a value indicating whether to use smart settings for the legend.
Property | Visible | Gets a value indicating whether the legend is visible.
Top

See Also

Reference

ILegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ILegend Interface Properties

[image]
ActiveReports 19 .NET Edition
ILegend Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface

Glossary Item Box

For a list of all members of this type, see ILegend members.

Public Properties

 | Name | Description
Property | InsidePlotArea | Gets a value indicating whether the legend is inside the plot area.
Property | Layout | Gets the layout of the legend.
Property | Position | Gets the position of the legend.
Property | Style | Gets the style for the legend.
Property | UseSmartSettings | Gets a value indicating whether to use smart settings for the legend.
Property | Visible | Gets a value indicating whether the legend is visible.
Top

See Also

Reference

ILegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


InsidePlotArea Property

[image]
ActiveReports 19 .NET Edition
InsidePlotArea Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : InsidePlotArea Property

Glossary Item Box

Gets a value indicating whether the legend is inside the plot area.

Syntax

Visual Basic (Declaration)
ReadOnly Property InsidePlotArea As Boolean
C#
bool InsidePlotArea {get;}

Property Value

A System.Boolean value. true if the legend is inside the plot area; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


Layout Property

[image]
ActiveReports 19 .NET Edition
Layout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Layout Property

Glossary Item Box

Gets the layout of the legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property Layout As LegendLayout
C#
LegendLayout Layout {get;}

Property Value

A LegendLayout value specifying the layout of the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Position Property

Glossary Item Box

Gets the position of the legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As LegendPosition
C#
LegendPosition Position {get;}

Property Value

A LegendPosition value specifying the position of the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Style Property

Glossary Item Box

Gets the style for the legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


UseSmartSettings Property

[image]
ActiveReports 19 .NET Edition
UseSmartSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : UseSmartSettings Property

Glossary Item Box

Gets a value indicating whether to use smart settings for the legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property UseSmartSettings As Boolean
C#
bool UseSmartSettings {get;}

Property Value

A System.Boolean value. true if smart settings are used; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Visible Property

Glossary Item Box

Gets a value indicating whether the legend is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Property Value

A System.Boolean value. true if the legend is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILegend Interface
ILegend Members


IMarker Interface

[image]
ActiveReports 19 .NET Edition
IMarker Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface

Glossary Item Box

Represents the marker properties for displayed chart values.

Syntax

Visual Basic (Declaration)
Public Interface IMarker
C#
public interface IMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMarker Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IMarker Interface Members

[image]
ActiveReports 19 .NET Edition
IMarker Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface

Glossary Item Box

The following tables list the members exposed by IMarker.

Public Properties

 | Name | Description
Property | Size | Gets the height and width of the plotting area of the markers.
Property | Style | Gets the border and background style properties for the markers.
Property | Type | Gets the marker type for values.
Top

See Also

Reference

IMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IMarker Interface Properties

[image]
ActiveReports 19 .NET Edition
IMarker Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface

Glossary Item Box

For a list of all members of this type, see IMarker members.

Public Properties

 | Name | Description
Property | Size | Gets the height and width of the plotting area of the markers.
Property | Style | Gets the border and background style properties for the markers.
Property | Type | Gets the marker type for values.
Top

See Also

Reference

IMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Size Property

Glossary Item Box

Gets the height and width of the plotting area of the markers.

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As Length
C#
Length Size {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the size of the markers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMarker Interface
IMarker Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Style Property

Glossary Item Box

Gets the border and background style properties for the markers.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the markers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMarker Interface
IMarker Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Type Property

Glossary Item Box

Gets the marker type for values.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As MarkerType
C#
MarkerType Type {get;}

Property Value

A MarkerType specifying the type of the marker.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMarker Interface
IMarker Members


IPalette Interface

[image]
ActiveReports 19 .NET Edition
IPalette Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface

Glossary Item Box

Represents a chart palette.

Syntax

Visual Basic (Declaration)
Public Interface IPalette
C#
public interface IPalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPalette Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPalette Interface Members

[image]
ActiveReports 19 .NET Edition
IPalette Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface

Glossary Item Box

The following tables list the members exposed by IPalette.

Public Properties

 | Name | Description
Property | Count | Gets the number of entries in the palette.
Property | Item | Gets the palette entry (color or hatch style) at the specified index.
Top

See Also

Reference

IPalette Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPalette Interface Properties

[image]
ActiveReports 19 .NET Edition
IPalette Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface

Glossary Item Box

For a list of all members of this type, see IPalette members.

Public Properties

 | Name | Description
Property | Count | Gets the number of entries in the palette.
Property | Item | Gets the palette entry (color or hatch style) at the specified index.
Top

See Also

Reference

IPalette Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPalette Interface : Count Property

Glossary Item Box

Gets the number of entries in the palette.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Property Value

An System.Int32 specifying the number of entries in the palette.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPalette Interface
IPalette Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPalette Interface : Item Property

index
The index of the palette entry.

Glossary Item Box

Gets the palette entry (color or hatch style) at the specified index.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PaletteEntry
C#
PaletteEntry this[
   int index
]; {get;}

Parameters

index
The index of the palette entry.

Property Value

A PaletteEntry representing the palette entry at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPalette Interface
IPalette Members


IPlotArea Interface

[image]
ActiveReports 19 .NET Edition
IPlotArea Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface

Glossary Item Box

Represents the interface for the chart plot area.

Syntax

Visual Basic (Declaration)
Public Interface IPlotArea
C#
public interface IPlotArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlotArea Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPlotArea Interface Members

[image]
ActiveReports 19 .NET Edition
IPlotArea Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface

Glossary Item Box

The following tables list the members exposed by IPlotArea.

Public Properties

 | Name | Description
Property | SeriesLineStyle | Gets the style of the chart series lines.
Property | Style | Gets the style of the plot area.
Top

See Also

Reference

IPlotArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPlotArea Interface Properties

[image]
ActiveReports 19 .NET Edition
IPlotArea Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface

Glossary Item Box

For a list of all members of this type, see IPlotArea members.

Public Properties

 | Name | Description
Property | SeriesLineStyle | Gets the style of the chart series lines.
Property | Style | Gets the style of the plot area.
Top

See Also

Reference

IPlotArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


SeriesLineStyle Property

[image]
ActiveReports 19 .NET Edition
SeriesLineStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPlotArea Interface : SeriesLineStyle Property

Glossary Item Box

Gets the style of the chart series lines.

Syntax

Visual Basic (Declaration)
ReadOnly Property SeriesLineStyle As IStyle
C#
IStyle SeriesLineStyle {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the chart series lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlotArea Interface
IPlotArea Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPlotArea Interface : Style Property

Glossary Item Box

Gets the style of the plot area.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the plot area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlotArea Interface
IPlotArea Members


IReferenceLine Interface

[image]
ActiveReports 19 .NET Edition
IReferenceLine Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface

Glossary Item Box

Represents the interface for a chart reference line.

Syntax

Visual Basic (Declaration)
Public Interface IReferenceLine
C#
public interface IReferenceLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceLine Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IReferenceLine Interface Members

[image]
ActiveReports 19 .NET Edition
IReferenceLine Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface

Glossary Item Box

The following tables list the members exposed by IReferenceLine.

Public Properties

 | Name | Description
Property | LegendLabel | Gets the legend label of the reference line.
Property | Style | Gets the style of the reference line.
Property | Value | Gets the value of the reference line.
Property | Visible | Gets a value indicating whether the reference line is visible.
Top

See Also

Reference

IReferenceLine Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IReferenceLine Interface Properties

[image]
ActiveReports 19 .NET Edition
IReferenceLine Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface

Glossary Item Box

For a list of all members of this type, see IReferenceLine members.

Public Properties

 | Name | Description
Property | LegendLabel | Gets the legend label of the reference line.
Property | Style | Gets the style of the reference line.
Property | Value | Gets the value of the reference line.
Property | Visible | Gets a value indicating whether the reference line is visible.
Top

See Also

Reference

IReferenceLine Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendLabel Property

[image]
ActiveReports 19 .NET Edition
LegendLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : LegendLabel Property

Glossary Item Box

Gets the legend label of the reference line.

Syntax

Visual Basic (Declaration)
ReadOnly Property LegendLabel As String
C#
string LegendLabel {get;}

Property Value

A System.String specifying the legend label of the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Style Property

Glossary Item Box

Gets the style of the reference line.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Value Property

Glossary Item Box

Gets the value of the reference line.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Double
C#
double Value {get;}

Property Value

A System.Double specifying the value of the reference line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Visible Property

[image]
ActiveReports 19 .NET Edition
Visible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Visible Property

Glossary Item Box

Gets a value indicating whether the reference line is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible {get;}

Property Value

A System.Boolean value. true if the reference line is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceLine Interface
IReferenceLine Members


IThreeDProperties Interface

[image]
ActiveReports 19 .NET Edition
IThreeDProperties Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface

Glossary Item Box

Represents 3D properties for chart.

Syntax

Visual Basic (Declaration)
Public Interface IThreeDProperties
C#
public interface IThreeDProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IThreeDProperties Interface Members

[image]
ActiveReports 19 .NET Edition
IThreeDProperties Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface

Glossary Item Box

The following tables list the members exposed by IThreeDProperties.

Public Properties

 | Name | Description
Property | Clustered | Gets a value indicating whether the chart is clustered.
Property | DrawingStyle | Gets the drawing style.
Property | Enabled | Gets a value indicating whether 3D is enabled.
Property | Inclination | Gets the inclination.
Property | Perspective | Gets the perspective.
Property | ProjectionMode | Gets the projection mode.
Property | Rotation | Gets the rotation.
Property | Shading | Gets the shading.
Property | WallThickness | Gets the wall thickness.
Top

See Also

Reference

IThreeDProperties Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IThreeDProperties Interface Properties

[image]
ActiveReports 19 .NET Edition
IThreeDProperties Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface

Glossary Item Box

For a list of all members of this type, see IThreeDProperties members.

Public Properties

 | Name | Description
Property | Clustered | Gets a value indicating whether the chart is clustered.
Property | DrawingStyle | Gets the drawing style.
Property | Enabled | Gets a value indicating whether 3D is enabled.
Property | Inclination | Gets the inclination.
Property | Perspective | Gets the perspective.
Property | ProjectionMode | Gets the projection mode.
Property | Rotation | Gets the rotation.
Property | Shading | Gets the shading.
Property | WallThickness | Gets the wall thickness.
Top

See Also

Reference

IThreeDProperties Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Clustered Property

[image]
ActiveReports 19 .NET Edition
Clustered Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Clustered Property

Glossary Item Box

Gets a value indicating whether the chart is clustered.

Syntax

Visual Basic (Declaration)
ReadOnly Property Clustered As Boolean
C#
bool Clustered {get;}

Property Value

A System.Boolean value. true if the chart is clustered; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


DrawingStyle Property

[image]
ActiveReports 19 .NET Edition
DrawingStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : DrawingStyle Property

Glossary Item Box

Gets the drawing style.

Syntax

Visual Basic (Declaration)
ReadOnly Property DrawingStyle As ThreeDPropertiesDrawingStyle
C#
ThreeDPropertiesDrawingStyle DrawingStyle {get;}

Property Value

A ThreeDPropertiesDrawingStyle value specifying the drawing style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Enabled Property

[image]
ActiveReports 19 .NET Edition
Enabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Enabled Property

Glossary Item Box

Gets a value indicating whether 3D is enabled.

Syntax

Visual Basic (Declaration)
ReadOnly Property Enabled As Boolean
C#
bool Enabled {get;}

Property Value

A System.Boolean value. true if 3D is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Inclination Property

[image]
ActiveReports 19 .NET Edition
Inclination Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Inclination Property

Glossary Item Box

Gets the inclination.

Syntax

Visual Basic (Declaration)
ReadOnly Property Inclination As Nullable(Of Integer)
C#
Nullable<int> Inclination {get;}

Property Value

An Nullable specifying the inclination angle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Perspective Property

[image]
ActiveReports 19 .NET Edition
Perspective Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Perspective Property

Glossary Item Box

Gets the perspective.

Syntax

Visual Basic (Declaration)
ReadOnly Property Perspective As Nullable(Of Integer)
C#
Nullable<int> Perspective {get;}

Property Value

An Nullable specifying the perspective.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


ProjectionMode Property

[image]
ActiveReports 19 .NET Edition
ProjectionMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : ProjectionMode Property

Glossary Item Box

Gets the projection mode.

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectionMode As ThreeDPropertiesProjectionMode
C#
ThreeDPropertiesProjectionMode ProjectionMode {get;}

Property Value

A ThreeDPropertiesProjectionMode value specifying the projection mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Rotation Property

Glossary Item Box

Gets the rotation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rotation As Nullable(Of Integer)
C#
Nullable<int> Rotation {get;}

Property Value

An Nullable specifying the rotation angle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Shading Property

[image]
ActiveReports 19 .NET Edition
Shading Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Shading Property

Glossary Item Box

Gets the shading.

Syntax

Visual Basic (Declaration)
ReadOnly Property Shading As ThreeDPropertiesShading
C#
ThreeDPropertiesShading Shading {get;}

Property Value

A ThreeDPropertiesShading value specifying the shading.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


WallThickness Property

[image]
ActiveReports 19 .NET Edition
WallThickness Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : WallThickness Property

Glossary Item Box

Gets the wall thickness.

Syntax

Visual Basic (Declaration)
ReadOnly Property WallThickness As Nullable(Of Integer)
C#
Nullable<int> WallThickness {get;}

Property Value

An Nullable specifying the wall thickness.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


ITitle Interface

[image]
ActiveReports 19 .NET Edition
ITitle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface

Glossary Item Box

Represents the interface for a chart title.

Syntax

Visual Basic (Declaration)
Public Interface ITitle
C#
public interface ITitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ITitle Interface Members

[image]
ActiveReports 19 .NET Edition
ITitle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface

Glossary Item Box

The following tables list the members exposed by ITitle.

Public Properties

 | Name | Description
Property | Caption | Gets the chart title caption.
Property | Position | Gets the chart title position.
Property | Style | Gets the chart title style.
Property | Vertical | Gets a value indicating whether the chart title is vertical.
Top

See Also

Reference

ITitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ITitle Interface Properties

[image]
ActiveReports 19 .NET Edition
ITitle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface

Glossary Item Box

For a list of all members of this type, see ITitle members.

Public Properties

 | Name | Description
Property | Caption | Gets the chart title caption.
Property | Position | Gets the chart title position.
Property | Style | Gets the chart title style.
Property | Vertical | Gets a value indicating whether the chart title is vertical.
Top

See Also

Reference

ITitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Caption Property

Glossary Item Box

Gets the chart title caption.

Syntax

Visual Basic (Declaration)
ReadOnly Property Caption As String
C#
string Caption {get;}

Property Value

A System.String specifying the chart title caption.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITitle Interface
ITitle Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Position Property

Glossary Item Box

Gets the chart title position.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As TitlePosition
C#
TitlePosition Position {get;}

Property Value

A TitlePosition value specifying the position of the chart title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITitle Interface
ITitle Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Style Property

Glossary Item Box

Gets the chart title style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle specifying the style of the chart title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITitle Interface
ITitle Members


Vertical Property

[image]
ActiveReports 19 .NET Edition
Vertical Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Vertical Property

Glossary Item Box

Gets a value indicating whether the chart title is vertical.

Syntax

Visual Basic (Declaration)
ReadOnly Property Vertical As Boolean
C#
bool Vertical {get;}

Property Value

A System.Boolean value. true if the chart title is vertical; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITitle Interface
ITitle Members


MapLocation Class

[image]
ActiveReports 19 .NET Edition
MapLocation Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class

Glossary Item Box

Represents the properties for map sub-items location.

Object Model

MapLocation Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapLocation
C#
public sealed class MapLocation

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLocation Class Members

[image]
ActiveReports 19 .NET Edition
MapLocation Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class

Glossary Item Box

The following tables list the members exposed by MapLocation.

Public Constructors

 | Name | Description
Public Constructor | MapLocation Constructor |
Top

Public Properties

 | Name | Description
Public Property | Left | Gets or sets the distance of the item from the left of the containing object.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Unit | Gets or sets the unit for both left and top.
Top

See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLocation Constructor

[image]
ActiveReports 19 .NET Edition
MapLocation Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : MapLocation Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapLocation()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


MapLocation Class Properties

[image]
ActiveReports 19 .NET Edition
MapLocation Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class

Glossary Item Box

For a list of all members of this type, see MapLocation members.

Public Properties

 | Name | Description
Public Property | Left | Gets or sets the distance of the item from the left of the containing object.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Unit | Gets or sets the unit for both left and top.
Top

See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Left Property

Glossary Item Box

Gets or sets the distance of the item from the left of the containing object.

Syntax

Visual Basic (Declaration)
Public Property Left As Double
C#
public double Left {get; set;}

Property Value

A System.Double representing the distance from the left of the containing object.

Remarks

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Top Property

Glossary Item Box

Gets or sets the distance of the item from the top of the containing object.

Syntax

Visual Basic (Declaration)
Public Property Top As Double
C#
public double Top {get; set;}

Property Value

A System.Double representing the distance from the top of the containing object.

Remarks

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Unit Property

Glossary Item Box

Gets or sets the unit for both left and top.

Syntax

Visual Basic (Declaration)
Public Property Unit As MapUnit
C#
public MapUnit Unit {get; set;}

Property Value

A MapUnit representing the unit of measurement for the distances.

Remarks

The default value is MapUnit.Percentage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLocation Class
MapLocation Members


MapSize Class

[image]
ActiveReports 19 .NET Edition
MapSize Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class

Glossary Item Box

Represents the properties for map sub-item size.

Object Model

MapSize Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MapSize
C#
public sealed class MapSize

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapSize Class Members

[image]
ActiveReports 19 .NET Edition
MapSize Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class

Glossary Item Box

The following tables list the members exposed by MapSize.

Public Constructors

 | Name | Description
Public Constructor | MapSize Constructor |
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the item.
Public Property | Unit | Gets or sets the unit for both width and height.
Public Property | Width | Gets or sets the width of the item.
Top

See Also

Reference

MapSize Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapSize Constructor

[image]
ActiveReports 19 .NET Edition
MapSize Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : MapSize Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapSize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


MapSize Class Properties

[image]
ActiveReports 19 .NET Edition
MapSize Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class

Glossary Item Box

For a list of all members of this type, see MapSize members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the item.
Public Property | Unit | Gets or sets the unit for both width and height.
Public Property | Width | Gets or sets the width of the item.
Top

See Also

Reference

MapSize Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Height Property

Glossary Item Box

Gets or sets the height of the item.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
C#
public double Height {get; set;}

Property Value

A System.Double representing the height of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


Unit Property

[image]
ActiveReports 19 .NET Edition
Unit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Unit Property

Glossary Item Box

Gets or sets the unit for both width and height.

Syntax

Visual Basic (Declaration)
Public Property Unit As MapUnit
C#
public MapUnit Unit {get; set;}

Property Value

A MapUnit representing the unit of measurement for the dimensions.

Remarks

The default value is MapUnit.Percentage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Width Property

Glossary Item Box

Gets or sets the width of the item.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
C#
public double Width {get; set;}

Property Value

A System.Double representing the width of the item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapSize Class
MapSize Members


MapCoordinateSystem Enumeration

[image]
ActiveReports 19 .NET Edition
MapCoordinateSystem Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapCoordinateSystem Enumeration

Glossary Item Box

Specifies the map coordinate system.

Syntax

Visual Basic (Declaration)
Public Enum MapCoordinateSystem
   Inherits System.Enum
C#
public enum MapCoordinateSystem : System.Enum

Members

Member | Description
Geographic | Geographic coordinate system (longitude and latitude).
Planar | Planar coordinate system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapCoordinateSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapImageResizeMode Enumeration

[image]
ActiveReports 19 .NET Edition
MapImageResizeMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapImageResizeMode Enumeration

Glossary Item Box

Specifies whether the content will resize to fit in the available space.

Syntax

Visual Basic (Declaration)
Public Enum MapImageResizeMode
   Inherits System.Enum
C#
public enum MapImageResizeMode : System.Enum

Members

Member | Description
AutoFit | Fits the available size.
None | No fitting.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapImageResizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelBehavior Enumeration

[image]
ActiveReports 19 .NET Edition
MapLabelBehavior Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelBehavior Enumeration

Glossary Item Box

Specifies the positioning of the color scale labels.

Syntax

Visual Basic (Declaration)
Public Enum MapLabelBehavior
   Inherits System.Enum
C#
public enum MapLabelBehavior : System.Enum

Members

Member | Description
Auto | Automatically determined
ShowBorderValue | Labels are displayed at the borders between color divisions.
ShowMiddleValue | Labels are displayed in the middle of each color division.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelPlacement Enumeration

Glossary Item Box

Specifies the labels placement along the color bar.

Syntax

Visual Basic (Declaration)
Public Enum MapLabelPlacement
   Inherits System.Enum
C#
public enum MapLabelPlacement : System.Enum

Members

Member | Description
Alternate | Odd labels are below the color bar and even ones are above.
Bottom | Labels are positioned below the color bar.
Top | Labels are positioned above the color bar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelPositionType Enumeration

[image]
ActiveReports 19 .NET Edition
MapLabelPositionType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelPositionType Enumeration

Glossary Item Box

Specifies the possible label positions for map meridians/parallels.

Syntax

Visual Basic (Declaration)
Public Enum MapLabelPositionType
   Inherits System.Enum
C#
public enum MapLabelPositionType : System.Enum

Members

Member | Description
Center | Labels are centered.
Far | Labels are on the right for parallels and on bottom for meridians.
Near | Labels are on the left for parallels and on top for meridians.
OneQuarter | Labels are between the left and center for parallels and between top and center for meridians.
ThreeQuarters | Labels are between the center and right for parallels and between center and bottom for meridians.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelPositionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendLayout Enumeration

[image]
ActiveReports 19 .NET Edition
MapLegendLayout Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendLayout Enumeration

Glossary Item Box

Specifies the arrangement of labels within the legend.

Syntax

Visual Basic (Declaration)
Public Enum MapLegendLayout
   Inherits System.Enum
C#
public enum MapLegendLayout : System.Enum

Members

Member | Description
AutoTable | Autoarrange labels to fit
Column | Arrange labels in a column
Row | Arrange labels in a row
TallTable | Arrange labels in a tall table
WideTable | Arrange labels in a wide table

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendMarkerStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MapLegendMarkerStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendMarkerStyle Enumeration

Glossary Item Box

Specifies the style for legend rendering.

Syntax

Visual Basic (Declaration)
Public Enum MapLegendMarkerStyle
   Inherits System.Enum
C#
public enum MapLegendMarkerStyle : System.Enum

Members

Member | Description
Circle | A circle-shaped marker is used.
Diamond | A diamond-shaped marker is used.
Image | An image marker is used.
Line | A line-shaped marker is used.
None | No marker is used.
Pentagon | A pentagon-shaped marker is used.
PushPin | A pushpin-shaped marker is used.
Rectangle | A rectangle-shaped marker is used.
Square | A square-shaped marker is used.
Star | A star-shaped marker is used.
Trapezoid | A trapezoid-shaped marker is used.
Triangle | A triangle-shaped marker is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendMarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendTitleSeparator Enumeration

[image]
ActiveReports 19 .NET Edition
MapLegendTitleSeparator Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendTitleSeparator Enumeration

Glossary Item Box

Specifies what type of separator to use for the legend title.

Syntax

Visual Basic (Declaration)
Public Enum MapLegendTitleSeparator
   Inherits System.Enum
C#
public enum MapLegendTitleSeparator : System.Enum

Members

Member | Description
DashLine | Separate with dash line.
DotLine | Separate with dot line.
DoubleLine | Separate with double line.
GradientLine | Separate with gradient line.
Line | Separate with a line.
None | No separator .
ThickGradientLine | Separate with thick gradient line.
ThickLine | Separate with a thick line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendTitleSeparator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLineLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapLineLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLineLabelPlacement Enumeration

Glossary Item Box

Specifies the label placement for the line.

Syntax

Visual Basic (Declaration)
Public Enum MapLineLabelPlacement
   Inherits System.Enum
C#
public enum MapLineLabelPlacement : System.Enum

Members

Member | Description
Above | Label placed above.
Below | Label placed below.
Center | Label placed to the center.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLineLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapMarkerLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapMarkerLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapMarkerLabelPlacement Enumeration

Glossary Item Box

Specifies the label placement for the marker.

Syntax

Visual Basic (Declaration)
Public Enum MapMarkerLabelPlacement
   Inherits System.Enum
C#
public enum MapMarkerLabelPlacement : System.Enum

Members

Member | Description
Bottom | Label placed to the bottom.
Center | Label placed to the center.
Left | Label placed to the left.
Right | Label placed to the right.
Top | Label placed to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapMarkerLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapMarkerStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MapMarkerStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapMarkerStyle Enumeration

Glossary Item Box

Specifies the point marker style.

Syntax

Visual Basic (Declaration)
Public Enum MapMarkerStyle
   Inherits System.Enum
C#
public enum MapMarkerStyle : System.Enum

Members

Member | Description
Circle | Circle marker.
Diamond | Diamond marker.
Image | Image marker.
None | Default.
Pentagon | Pentagon marker.
PushPin | Push Pin marker.
Rectangle | Rectangle marker.
Star | Star marker.
Trapezoid | Trapezoid marker.
Triangle | Triangle marker.
Wedge | Wedge marker.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapMarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPolygonLabelPlacement Enumeration

[image]
ActiveReports 19 .NET Edition
MapPolygonLabelPlacement Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPolygonLabelPlacement Enumeration

Glossary Item Box

Specifies the label placement for the polygon.

Syntax

Visual Basic (Declaration)
Public Enum MapPolygonLabelPlacement
   Inherits System.Enum
C#
public enum MapPolygonLabelPlacement : System.Enum

Members

Member | Description
BottomCenter | Label placed to the bottom center.
BottomLeft | Label placed to the bottom left.
BottomRight | Label placed to the bottom right.
MiddleCenter | Label placed to the middle center.
MiddleLeft | Label placed to the middle left.
MiddleRight | Label placed to the middle right.
TopCenter | Label placed to the top center.
TopLeft | Label placed to the top left.
TopRight | Label placed to the top right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPolygonLabelPlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPolygonLabelVisibility Enumeration

[image]
ActiveReports 19 .NET Edition
MapPolygonLabelVisibility Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPolygonLabelVisibility Enumeration

Glossary Item Box

Specifies the visibility mode of a map polygon label.

Syntax

Visual Basic (Declaration)
Public Enum MapPolygonLabelVisibility
   Inherits System.Enum
C#
public enum MapPolygonLabelVisibility : System.Enum

Members

Member | Description
Auto | Defines mode when labels are conditionally visible.
Hidden | Defines mode when polygon label is unconditionally hidden.
Visible | Defines mode when polygon label is unconditionally visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPolygonLabelVisibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPosition Enumeration

[image]
ActiveReports 19 .NET Edition
MapPosition Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPosition Enumeration

Glossary Item Box

Specifies the position of the dockable subitem.

Syntax

Visual Basic (Declaration)
Public Enum MapPosition
   Inherits System.Enum
C#
public enum MapPosition : System.Enum

Members

Member | Description
BottomCenter | Position title at BottomCenter.
BottomLeft | Position title at BottomLeft.
BottomRight | Position title at BottomRight.
LeftBottom | Position title at LeftBottom.
LeftCenter | Position title at LeftCenter.
LeftTop | Position title at LeftTop.
RightBottom | Position title at RightBottom.
RightCenter | Position title at RightCenter.
RightTop | Position title at RightTop.
TopCenter | Position title at TopCenter.
TopLeft | Position title at TopLeft.
TopRight | Position title at TopRight.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapProjection Enumeration

[image]
ActiveReports 19 .NET Edition
MapProjection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapProjection Enumeration

Glossary Item Box

Specifies the map projection.

Syntax

Visual Basic (Declaration)
Public Enum MapProjection
   Inherits System.Enum
C#
public enum MapProjection : System.Enum

Members

Member | Description
Bonne | Bonne projection
Eckert1 | Eckert1 projection
Eckert3 | Eckert3 projection
Equirectangular | Equirectangular projection
Fahey | Fahey projection
HammerAitoff | HammerAitoff projection
Mercator | Mercator projection
Robinson | Robinson projection
Wagner3 | Wagner3 projection

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapProjection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileStyle Enumeration

[image]
ActiveReports 19 .NET Edition
MapTileStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileStyle Enumeration

Glossary Item Box

Specifies the tiles style.

Syntax

Visual Basic (Declaration)
Public Enum MapTileStyle
   Inherits System.Enum
C#
public enum MapTileStyle : System.Enum

Members

Member | Description
Aerial | Tiles containing aerial imagery of the earth.
Hybrid | Tiles containing aerial imagery of borders and roads.
Road | Tiles containing roads and streets.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapUnit Enumeration

[image]
ActiveReports 19 .NET Edition
MapUnit Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapUnit Enumeration

Glossary Item Box

Specifies the unit for both width and height.

Syntax

Visual Basic (Declaration)
Public Enum MapUnit
   Inherits System.Enum
C#
public enum MapUnit : System.Enum

Members

Member | Description
Centimeter | Unit is Centimeter.
Inch | Unit is Inch.
Millimeter | Unit is Millimeter.
Percentage | Unit is percentage of the containing object’s width/height.
Pica | Unit is Pica (12 Points).
Point | Unit is Point.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapViewCenterUnits Enumeration

[image]
ActiveReports 19 .NET Edition
MapViewCenterUnits Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapViewCenterUnits Enumeration

Glossary Item Box

Specify the type of the MapViewport.MapView.

Syntax

Visual Basic (Declaration)
Public Enum MapViewCenterUnits
   Inherits System.Enum
C#
public enum MapViewCenterUnits : System.Enum

Members

Member | Description
Coordinates | MapViewport uses MapDataBoundView or MapElementView (coordinates are calculated based on data).
Percents | MapViewport uses MapCustomView.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapViewCenterUnits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapVisibilityMode Enumeration

[image]
ActiveReports 19 .NET Edition
MapVisibilityMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapVisibilityMode Enumeration

Glossary Item Box

Specifies the layer visibility mode.

Syntax

Visual Basic (Declaration)
Public Enum MapVisibilityMode
   Inherits System.Enum
C#
public enum MapVisibilityMode : System.Enum

Members

Member | Description
Hidden | Layer is hidden.
Visible | Layer is Shown.
ZoomBased | Layer is shown within a zoom level range defined by Minimum Zoomn / MaximumZoom of a map layer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapVisibilityMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Structure

[image]
ActiveReports 19 .NET Edition
MapTileKey Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

Glossary Item Box

Represents the tile identifier.

Object Model

MapTileKey Structure

Syntax

Visual Basic (Declaration)
Public Structure MapTileKey
   Inherits System.ValueType
C#
public struct MapTileKey : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Structure Members

[image]
ActiveReports 19 .NET Edition
MapTileKey Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

Glossary Item Box

The following tables list the members exposed by MapTileKey.

Public Constructors

 | Name | Description
Public Constructor | MapTileKey Constructor | Initializes a new instance of the MapTileKey struct.
Top

Public Fields

 | Name | Description
Public Field | Col | Gets the X coordinate (column in layer grid).
Public Field | LevelOfDetail | Gets the level of detail.
Public Field | Row | Gets the Y coordinate (row in layer grid).
Top

Public Methods

 | Name | Description
Public Method | ToQuadKey | Calculates the quad key (unique identifier) for the provided x, y, and level of detail values.
Public Method | ToWorldPos | Gets the tile's center latitude and longitude.
Top

Public Operators

public Operator Equality | Equality operator implementation.
public Operator Inequality | Inequality operator implementation.
Top

See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Constructor

[image]
ActiveReports 19 .NET Edition
MapTileKey Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : MapTileKey Constructor

col
X coordinate (column in layer grid).
row
Y coordinate (row in layer grid).
levelOfDetail
Level of detail.

Glossary Item Box

Initializes a new instance of the MapTileKey struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal col As Integer, _
   ByVal row As Integer, _
   ByVal levelOfDetail As Integer _
)
C#
public MapTileKey(
   int col,
   int row,
   int levelOfDetail
)

Parameters

col
X coordinate (column in layer grid).
row
Y coordinate (row in layer grid).
levelOfDetail
Level of detail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


MapTileKey Structure Methods

[image]
ActiveReports 19 .NET Edition
MapTileKey Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

Glossary Item Box

For a list of all members of this type, see MapTileKey members.

Public Methods

 | Name | Description
Public Method | ToQuadKey | Calculates the quad key (unique identifier) for the provided x, y, and level of detail values.
Public Method | ToWorldPos | Gets the tile's center latitude and longitude.
Top

See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ToQuadKey Method

[image]
ActiveReports 19 .NET Edition
ToQuadKey Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : ToQuadKey Method

Glossary Item Box

Calculates the quad key (unique identifier) for the provided x, y, and level of detail values.

Syntax

Visual Basic (Declaration)
Public Function ToQuadKey() As String
C#
public string ToQuadKey()

Return Value

A System.String representing the quad key.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


ToWorldPos Method

[image]
ActiveReports 19 .NET Edition
ToWorldPos Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : ToWorldPos Method

Glossary Item Box

Gets the tile's center latitude and longitude.

Syntax

Visual Basic (Declaration)
Public Function ToWorldPos() As PointF
C#
public PointF ToWorldPos()

Return Value

A System.Drawing.PointF representing the center latitude and longitude of the tile.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


MapTileKey Structure Fields

[image]
ActiveReports 19 .NET Edition
MapTileKey Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

Glossary Item Box

For a list of all members of this type, see MapTileKey members.

Public Fields

 | Name | Description
Public Field | Col | Gets the X coordinate (column in layer grid).
Public Field | LevelOfDetail | Gets the level of detail.
Public Field | Row | Gets the Y coordinate (row in layer grid).
Top

See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Col Field

[image]
ActiveReports 19 .NET Edition
Col Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Col Field

Glossary Item Box

Gets the X coordinate (column in layer grid).

Syntax

Visual Basic (Declaration)
Public ReadOnly Col As Integer
C#
public readonly int Col

Field Value

An System.Int32 representing the X coordinate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


LevelOfDetail Field

[image]
ActiveReports 19 .NET Edition
LevelOfDetail Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : LevelOfDetail Field

Glossary Item Box

Gets the level of detail.

Syntax

Visual Basic (Declaration)
Public ReadOnly LevelOfDetail As Integer
C#
public readonly int LevelOfDetail

Field Value

An System.Int32 representing the level of detail.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


Row Field

[image]
ActiveReports 19 .NET Edition
Row Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Row Field

Glossary Item Box

Gets the Y coordinate (row in layer grid).

Syntax

Visual Basic (Declaration)
Public ReadOnly Row As Integer
C#
public readonly int Row

Field Value

An System.Int32 representing the Y coordinate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


Equality Operator

[image]
ActiveReports 19 .NET Edition
Equality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Equality Operator

x
Left operand.
y
Right operand.

Glossary Item Box

Equality operator implementation.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal x As MapTileKey, _
   ByVal y As MapTileKey _
) As Boolean
C#
public bool operator ==(
   MapTileKey x,
   MapTileKey y
)

Parameters

x
Left operand.
y
Right operand.

Return Value

true if the specified operands are equal; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


Inequality Operator

[image]
ActiveReports 19 .NET Edition
Inequality Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Inequality Operator

x
Left operand.
y
Right operand.

Glossary Item Box

Inequality operator implementation.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal x As MapTileKey, _
   ByVal y As MapTileKey _
) As Boolean
C#
public bool operator !=(
   MapTileKey x,
   MapTileKey y
)

Parameters

x
Left operand.
y
Right operand.

Return Value

true if the specified operands are not equal; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileKey Structure
MapTileKey Members


IEmbeddedMapTile Interface

[image]
ActiveReports 19 .NET Edition
IEmbeddedMapTile Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface

Glossary Item Box

Represents the embedded map tile.

Syntax

Visual Basic (Declaration)
Public Interface IEmbeddedMapTile
C#
public interface IEmbeddedMapTile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmbeddedMapTile Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IEmbeddedMapTile Interface Members

[image]
ActiveReports 19 .NET Edition
IEmbeddedMapTile Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface

Glossary Item Box

The following tables list the members exposed by IEmbeddedMapTile.

Public Properties

 | Name | Description
Property | Image | Gets the tile image.
Property | Name | Gets the tile name.
Top

See Also

Reference

IEmbeddedMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IEmbeddedMapTile Interface Properties

[image]
ActiveReports 19 .NET Edition
IEmbeddedMapTile Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface

Glossary Item Box

For a list of all members of this type, see IEmbeddedMapTile members.

Public Properties

 | Name | Description
Property | Image | Gets the tile image.
Property | Name | Gets the tile name.
Top

See Also

Reference

IEmbeddedMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Image Property

[image]
ActiveReports 19 .NET Edition
Image Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IEmbeddedMapTile Interface : Image Property

Glossary Item Box

Gets the tile image.

Syntax

Visual Basic (Declaration)
ReadOnly Property Image As ImageInfo
C#
ImageInfo Image {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo representing the tile image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmbeddedMapTile Interface
IEmbeddedMapTile Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IEmbeddedMapTile Interface : Name Property

Glossary Item Box

Gets the tile name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the tile name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmbeddedMapTile Interface
IEmbeddedMapTile Members


IMap Interface

[image]
ActiveReports 19 .NET Edition
IMap Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

Glossary Item Box

Represents the map rendering component.

Syntax

Visual Basic (Declaration)
Public Interface IMap
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
C#
public interface IMap : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMap Interface Members

[image]
ActiveReports 19 .NET Edition
IMap Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

Glossary Item Box

The following tables list the members exposed by IMap.

Public Properties

 | Name | Description
Property | AntiAliasing | Gets the smoothing mode for map rendering.
Property | ColorScale | Gets the color scale rendering settings.
Property | DistanceScale | Gets the distance scale rendering settings.
Property | Layers | Gets the collection of map rendering layers.
Property | Legends | Gets the collection of map rendering legends.
Property | MaximumSpatialElementCount | Gets the maximum number of spatial elements in the map.
Property | MaximumTotalPointCount | Gets the maximum number of points in the map.
Property | ShadowIntensity | Gets the shadow opacity in percents.
Property | TextAntiAliasingQuality | Gets the text rendering hints for map rendering.
Property | TileLanguage | Gets the Bing server setting for tile layer rendering.
Property | Titles | Gets the collection of map rendering titles.
Property | Viewport | Gets the viewport rendering settings.
Top

See Also

Reference

IMap Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMap Interface Properties

[image]
ActiveReports 19 .NET Edition
IMap Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

Glossary Item Box

For a list of all members of this type, see IMap members.

Public Properties

 | Name | Description
Property | AntiAliasing | Gets the smoothing mode for map rendering.
Property | ColorScale | Gets the color scale rendering settings.
Property | DistanceScale | Gets the distance scale rendering settings.
Property | Layers | Gets the collection of map rendering layers.
Property | Legends | Gets the collection of map rendering legends.
Property | MaximumSpatialElementCount | Gets the maximum number of spatial elements in the map.
Property | MaximumTotalPointCount | Gets the maximum number of points in the map.
Property | ShadowIntensity | Gets the shadow opacity in percents.
Property | TextAntiAliasingQuality | Gets the text rendering hints for map rendering.
Property | TileLanguage | Gets the Bing server setting for tile layer rendering.
Property | Titles | Gets the collection of map rendering titles.
Property | Viewport | Gets the viewport rendering settings.
Top

See Also

Reference

IMap Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


AntiAliasing Property

[image]
ActiveReports 19 .NET Edition
AntiAliasing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : AntiAliasing Property

Glossary Item Box

Gets the smoothing mode for map rendering.

Syntax

Visual Basic (Declaration)
ReadOnly Property AntiAliasing As AntiAliasing
C#
AntiAliasing AntiAliasing {get;}

Property Value

An AntiAliasing representing the smoothing mode for map rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


ColorScale Property

[image]
ActiveReports 19 .NET Edition
ColorScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : ColorScale Property

Glossary Item Box

Gets the color scale rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColorScale As IMapColorScale
C#
IMapColorScale ColorScale {get;}

Property Value

An IMapColorScale representing the color scale rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


DistanceScale Property

[image]
ActiveReports 19 .NET Edition
DistanceScale Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : DistanceScale Property

Glossary Item Box

Gets the distance scale rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property DistanceScale As IMapDistanceScale
C#
IMapDistanceScale DistanceScale {get;}

Property Value

An IMapDistanceScale representing the distance scale rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


Layers Property

[image]
ActiveReports 19 .NET Edition
Layers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Layers Property

Glossary Item Box

Gets the collection of map rendering layers.

Syntax

Visual Basic (Declaration)
ReadOnly Property Layers As IEnumerable(Of IMapLayer)
C#
IEnumerable<IMapLayer> Layers {get;}

Property Value

A collection of IMapLayer objects representing the map rendering layers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


Legends Property

[image]
ActiveReports 19 .NET Edition
Legends Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Legends Property

Glossary Item Box

Gets the collection of map rendering legends.

Syntax

Visual Basic (Declaration)
ReadOnly Property Legends As IEnumerable(Of IMapLegend)
C#
IEnumerable<IMapLegend> Legends {get;}

Property Value

A collection of IMapLegend objects representing the map rendering legends.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


MaximumSpatialElementCount Property

[image]
ActiveReports 19 .NET Edition
MaximumSpatialElementCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : MaximumSpatialElementCount Property

Glossary Item Box

Gets the maximum number of spatial elements in the map.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumSpatialElementCount As Nullable(Of Integer)
C#
Nullable<int> MaximumSpatialElementCount {get;}

Property Value

An Nullable representing the maximum number of spatial elements in the map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


MaximumTotalPointCount Property

[image]
ActiveReports 19 .NET Edition
MaximumTotalPointCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : MaximumTotalPointCount Property

Glossary Item Box

Gets the maximum number of points in the map.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumTotalPointCount As Nullable(Of Integer)
C#
Nullable<int> MaximumTotalPointCount {get;}

Property Value

An Nullable representing the maximum number of points in the map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


ShadowIntensity Property

[image]
ActiveReports 19 .NET Edition
ShadowIntensity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : ShadowIntensity Property

Glossary Item Box

Gets the shadow opacity in percents.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShadowIntensity As Double
C#
double ShadowIntensity {get;}

Property Value

A System.Double representing the shadow opacity in percents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


TextAntiAliasingQuality Property

[image]
ActiveReports 19 .NET Edition
TextAntiAliasingQuality Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : TextAntiAliasingQuality Property

Glossary Item Box

Gets the text rendering hints for map rendering.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextAntiAliasingQuality As TextAntiAliasingQuality
C#
TextAntiAliasingQuality TextAntiAliasingQuality {get;}

Property Value

A TextAntiAliasingQuality representing the text rendering hints for map rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


TileLanguage Property

[image]
ActiveReports 19 .NET Edition
TileLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : TileLanguage Property

Glossary Item Box

Gets the Bing server setting for tile layer rendering.

Syntax

Visual Basic (Declaration)
ReadOnly Property TileLanguage As String
C#
string TileLanguage {get;}

Property Value

A System.String representing the Bing server setting for tile layer rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


Titles Property

[image]
ActiveReports 19 .NET Edition
Titles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Titles Property

Glossary Item Box

Gets the collection of map rendering titles.

Syntax

Visual Basic (Declaration)
ReadOnly Property Titles As IEnumerable(Of IMapTitle)
C#
IEnumerable<IMapTitle> Titles {get;}

Property Value

A collection of IMapTitle objects representing the map rendering titles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


Viewport Property

[image]
ActiveReports 19 .NET Edition
Viewport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Viewport Property

Glossary Item Box

Gets the viewport rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Viewport As IMapViewport
C#
IMapViewport Viewport {get;}

Property Value

An IMapViewport representing the viewport rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMap Interface
IMap Members


IMapColorScale Interface

[image]
ActiveReports 19 .NET Edition
IMapColorScale Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface

Glossary Item Box

Represents the map color scale rendering settings.

Syntax

Visual Basic (Declaration)
Public Interface IMapColorScale
   Inherits IMapDockableSubItem, IMapSubItem
C#
public interface IMapColorScale : IMapDockableSubItem, IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScale Interface Members

[image]
ActiveReports 19 .NET Edition
IMapColorScale Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface

Glossary Item Box

The following tables list the members exposed by IMapColorScale.

Public Properties

 | Name | Description
Property | ColorBarBorderColor | Gets the border color of the color bar.
Property | Elements | Gets the collection of internal rendering elements.
Property | HideEndLabels | Gets a value indicating whether the end labels for a IMapColorScale will be hidden.
Property | LabelBehavior | Gets the label behavior specifying how the labels display the values.
Property | LabelFormat | Gets the label format.
Property | LabelInterval | Gets the interval between labels.
Property | LabelPlacement | Gets the label placement specifying the placement of labels.
Property | NoDataText | Gets the label for the IMapColorScale that is to be used with colors that have no data associated with them.
Property | RangeGapColor | Gets the color used in a IMapColorScale to fill the undefined color divisions.
Property | TickMarkLength | Gets the length of the tick mark.
Property | Title | Gets the color scale title rendering settings.
Top

See Also

Reference

IMapColorScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScale Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapColorScale Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface

Glossary Item Box

For a list of all members of this type, see IMapColorScale members.

Public Properties

 | Name | Description
Property | ColorBarBorderColor | Gets the border color of the color bar.
Property | Elements | Gets the collection of internal rendering elements.
Property | HideEndLabels | Gets a value indicating whether the end labels for a IMapColorScale will be hidden.
Property | LabelBehavior | Gets the label behavior specifying how the labels display the values.
Property | LabelFormat | Gets the label format.
Property | LabelInterval | Gets the interval between labels.
Property | LabelPlacement | Gets the label placement specifying the placement of labels.
Property | NoDataText | Gets the label for the IMapColorScale that is to be used with colors that have no data associated with them.
Property | RangeGapColor | Gets the color used in a IMapColorScale to fill the undefined color divisions.
Property | TickMarkLength | Gets the length of the tick mark.
Property | Title | Gets the color scale title rendering settings.
Top

See Also

Reference

IMapColorScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ColorBarBorderColor Property

[image]
ActiveReports 19 .NET Edition
ColorBarBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : ColorBarBorderColor Property

Glossary Item Box

Gets the border color of the color bar.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColorBarBorderColor As Color
C#
Color ColorBarBorderColor {get;}

Property Value

A System.Drawing.Color specifying the border color of the color bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : Elements Property

Glossary Item Box

Gets the collection of internal rendering elements.

Syntax

Visual Basic (Declaration)
ReadOnly Property Elements As IEnumerable(Of IMapColorScaleElement)
C#
IEnumerable<IMapColorScaleElement> Elements {get;}

Property Value

A collection of IMapColorScaleElement representing the internal rendering elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


HideEndLabels Property

[image]
ActiveReports 19 .NET Edition
HideEndLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : HideEndLabels Property

Glossary Item Box

Gets a value indicating whether the end labels for a IMapColorScale will be hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property HideEndLabels As Boolean
C#
bool HideEndLabels {get;}

Property Value

A System.Boolean value. true if the end labels will be hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelBehavior Property

[image]
ActiveReports 19 .NET Edition
LabelBehavior Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelBehavior Property

Glossary Item Box

Gets the label behavior specifying how the labels display the values.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelBehavior As MapLabelBehavior
C#
MapLabelBehavior LabelBehavior {get;}

Property Value

A MapLabelBehavior specifying how the labels display the values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelFormat Property

[image]
ActiveReports 19 .NET Edition
LabelFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelFormat Property

Glossary Item Box

Gets the label format.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelFormat As String
C#
string LabelFormat {get;}

Property Value

A System.String representing the label format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelInterval Property

[image]
ActiveReports 19 .NET Edition
LabelInterval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelInterval Property

Glossary Item Box

Gets the interval between labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelInterval As Integer
C#
int LabelInterval {get;}

Property Value

An System.Int32 specifying the interval between labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelPlacement Property

Glossary Item Box

Gets the label placement specifying the placement of labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelPlacement As MapLabelPlacement
C#
MapLabelPlacement LabelPlacement {get;}

Property Value

A MapLabelPlacement specifying the placement of labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


NoDataText Property

[image]
ActiveReports 19 .NET Edition
NoDataText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : NoDataText Property

Glossary Item Box

Gets the label for the IMapColorScale that is to be used with colors that have no data associated with them.

Syntax

Visual Basic (Declaration)
ReadOnly Property NoDataText As String
C#
string NoDataText {get;}

Property Value

A System.String representing the label for colors with no data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


RangeGapColor Property

[image]
ActiveReports 19 .NET Edition
RangeGapColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : RangeGapColor Property

Glossary Item Box

Gets the color used in a IMapColorScale to fill the undefined color divisions.

Syntax

Visual Basic (Declaration)
ReadOnly Property RangeGapColor As String
C#
string RangeGapColor {get;}

Property Value

A System.String representing the color to fill the undefined color divisions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


TickMarkLength Property

[image]
ActiveReports 19 .NET Edition
TickMarkLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : TickMarkLength Property

Glossary Item Box

Gets the length of the tick mark.

Syntax

Visual Basic (Declaration)
ReadOnly Property TickMarkLength As Length
C#
Length TickMarkLength {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length specifying the length of the tick mark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : Title Property

Glossary Item Box

Gets the color scale title rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Title As IMapColorScaleTitle
C#
IMapColorScaleTitle Title {get;}

Property Value

An IMapColorScaleTitle representing the color scale title rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScale Interface
IMapColorScale Members


IMapColorScaleElement Interface

[image]
ActiveReports 19 .NET Edition
IMapColorScaleElement Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface

Glossary Item Box

Represents the MapColorScale rendering 'ticks'.

Syntax

Visual Basic (Declaration)
Public Interface IMapColorScaleElement
C#
public interface IMapColorScaleElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleElement Interface Members

[image]
ActiveReports 19 .NET Edition
IMapColorScaleElement Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface

Glossary Item Box

The following tables list the members exposed by IMapColorScaleElement.

Public Properties

 | Name | Description
Property | End | Gets the end value of the color range.
Property | IsScalar | Gets a value indicating whether the value is discrete or continuous.
Property | Middle | Gets the middle value of the color range if necessary.
Property | Start | Gets the start value of the color range.
Property | Style | Gets the bar rendering style.
Top

See Also

Reference

IMapColorScaleElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleElement Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapColorScaleElement Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface

Glossary Item Box

For a list of all members of this type, see IMapColorScaleElement members.

Public Properties

 | Name | Description
Property | End | Gets the end value of the color range.
Property | IsScalar | Gets a value indicating whether the value is discrete or continuous.
Property | Middle | Gets the middle value of the color range if necessary.
Property | Start | Gets the start value of the color range.
Property | Style | Gets the bar rendering style.
Top

See Also

Reference

IMapColorScaleElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


End Property

[image]
ActiveReports 19 .NET Edition
End Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : End Property

Glossary Item Box

Gets the end value of the color range.

Syntax

Visual Basic (Declaration)
ReadOnly Property End As Object
C#
object End {get;}

Property Value

An System.Object representing the end value of the color range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


IsScalar Property

[image]
ActiveReports 19 .NET Edition
IsScalar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : IsScalar Property

Glossary Item Box

Gets a value indicating whether the value is discrete or continuous.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsScalar As Boolean
C#
bool IsScalar {get;}

Property Value

A System.Boolean value. true if the value is continuous; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Middle Property

[image]
ActiveReports 19 .NET Edition
Middle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Middle Property

Glossary Item Box

Gets the middle value of the color range if necessary.

Syntax

Visual Basic (Declaration)
ReadOnly Property Middle As Object
C#
object Middle {get;}

Property Value

An System.Object representing the middle value of the color range if necessary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Start Property

[image]
ActiveReports 19 .NET Edition
Start Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Start Property

Glossary Item Box

Gets the start value of the color range.

Syntax

Visual Basic (Declaration)
ReadOnly Property Start As Object
C#
object Start {get;}

Property Value

An System.Object representing the start value of the color range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Style Property

Glossary Item Box

Gets the bar rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the bar rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


IMapColorScaleTitle Interface

[image]
ActiveReports 19 .NET Edition
IMapColorScaleTitle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface

Glossary Item Box

Represents the rendering settings for IMapColorScale title rendering.

Syntax

Visual Basic (Declaration)
Public Interface IMapColorScaleTitle
C#
public interface IMapColorScaleTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleTitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleTitle Interface Members

[image]
ActiveReports 19 .NET Edition
IMapColorScaleTitle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface

Glossary Item Box

The following tables list the members exposed by IMapColorScaleTitle.

Public Properties

 | Name | Description
Property | Caption | Gets the title text.
Property | Style | Gets the title rendering style.
Top

See Also

Reference

IMapColorScaleTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleTitle Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapColorScaleTitle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface

Glossary Item Box

For a list of all members of this type, see IMapColorScaleTitle members.

Public Properties

 | Name | Description
Property | Caption | Gets the title text.
Property | Style | Gets the title rendering style.
Top

See Also

Reference

IMapColorScaleTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleTitle Interface : Caption Property

Glossary Item Box

Gets the title text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Caption As String
C#
string Caption {get;}

Property Value

A System.String representing the title text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleTitle Interface
IMapColorScaleTitle Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleTitle Interface : Style Property

Glossary Item Box

Gets the title rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the title rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapColorScaleTitle Interface
IMapColorScaleTitle Members


IMapDistanceScale Interface

[image]
ActiveReports 19 .NET Edition
IMapDistanceScale Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface

Glossary Item Box

Represents the map distance scale rendering settings.

Syntax

Visual Basic (Declaration)
Public Interface IMapDistanceScale
   Inherits IMapDockableSubItem, IMapSubItem
C#
public interface IMapDistanceScale : IMapDockableSubItem, IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDistanceScale Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDistanceScale Interface Members

[image]
ActiveReports 19 .NET Edition
IMapDistanceScale Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface

Glossary Item Box

The following tables list the members exposed by IMapDistanceScale.

Public Properties

 | Name | Description
Property | ScaleBorderColor | Gets the border color for the scale.
Property | ScaleColor | Gets the color for the scale.
Property | ScaleFactor | Gets the twips to kilometers scale factor.
Top

See Also

Reference

IMapDistanceScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDistanceScale Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapDistanceScale Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface

Glossary Item Box

For a list of all members of this type, see IMapDistanceScale members.

Public Properties

 | Name | Description
Property | ScaleBorderColor | Gets the border color for the scale.
Property | ScaleColor | Gets the color for the scale.
Property | ScaleFactor | Gets the twips to kilometers scale factor.
Top

See Also

Reference

IMapDistanceScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ScaleBorderColor Property

[image]
ActiveReports 19 .NET Edition
ScaleBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleBorderColor Property

Glossary Item Box

Gets the border color for the scale.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleBorderColor As Color
C#
Color ScaleBorderColor {get;}

Property Value

A System.Drawing.Color representing the border color for the scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


ScaleColor Property

[image]
ActiveReports 19 .NET Edition
ScaleColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleColor Property

Glossary Item Box

Gets the color for the scale.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleColor As Color
C#
Color ScaleColor {get;}

Property Value

A System.Drawing.Color representing the color for the scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


ScaleFactor Property

[image]
ActiveReports 19 .NET Edition
ScaleFactor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleFactor Property

Glossary Item Box

Gets the twips to kilometers scale factor.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleFactor As Double
C#
double ScaleFactor {get;}

Property Value

A System.Double representing the twips to kilometers scale factor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


IMapDockableSubItem Interface

[image]
ActiveReports 19 .NET Edition
IMapDockableSubItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface

Glossary Item Box

Represents the dockable subitem of a map.

Syntax

Visual Basic (Declaration)
Public Interface IMapDockableSubItem
   Inherits IMapSubItem
C#
public interface IMapDockableSubItem : IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDockableSubItem Interface Members

[image]
ActiveReports 19 .NET Edition
IMapDockableSubItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface

Glossary Item Box

The following tables list the members exposed by IMapDockableSubItem.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the element if any, otherwise null.
Property | DockOutsideViewport | Gets a value indicating whether the sub item should be docked outside the viewport. Ignored if MapLocation is defined.
Property | Hidden | Gets a value indicating whether the item is hidden.
Property | Position | Gets the position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.
Property | ToolTip | Gets the tooltip.
Top

See Also

Reference

IMapDockableSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDockableSubItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapDockableSubItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface

Glossary Item Box

For a list of all members of this type, see IMapDockableSubItem members.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the element if any, otherwise null.
Property | DockOutsideViewport | Gets a value indicating whether the sub item should be docked outside the viewport. Ignored if MapLocation is defined.
Property | Hidden | Gets a value indicating whether the item is hidden.
Property | Position | Gets the position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.
Property | ToolTip | Gets the tooltip.
Top

See Also

Reference

IMapDockableSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Action Property

Glossary Item Box

Gets the action associated with the element if any, otherwise null.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction representing the action associated with the element, or null if there is no associated action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


DockOutsideViewport Property

[image]
ActiveReports 19 .NET Edition
DockOutsideViewport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : DockOutsideViewport Property

Glossary Item Box

Gets a value indicating whether the sub item should be docked outside the viewport. Ignored if MapLocation is defined.

Syntax

Visual Basic (Declaration)
ReadOnly Property DockOutsideViewport As Boolean
C#
bool DockOutsideViewport {get;}

Property Value

A System.Boolean value. true if the sub item should be docked outside the viewport; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether the item is hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the item is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


Position Property

[image]
ActiveReports 19 .NET Edition
Position Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Position Property

Glossary Item Box

Gets the position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As MapPosition
C#
MapPosition Position {get;}

Property Value

A MapPosition representing the position of the sub item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : ToolTip Property

Glossary Item Box

Gets the tooltip.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolTip As String
C#
string ToolTip {get;}

Property Value

A System.String representing the tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


IMapGridLines Interface

[image]
ActiveReports 19 .NET Edition
IMapGridLines Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface

Glossary Item Box

Represents the base interface for map meridians/parallels rendering.

Syntax

Visual Basic (Declaration)
Public Interface IMapGridLines
C#
public interface IMapGridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapGridLines Interface Members

[image]
ActiveReports 19 .NET Edition
IMapGridLines Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface

Glossary Item Box

The following tables list the members exposed by IMapGridLines.

Public Properties

 | Name | Description
Property | Hidden | Gets a value indicating whether this meridian/parallel should be rendered.
Property | Interval | Gets the interval between meridians/parallels.
Property | LabelPosition | Gets the positions of grid labels.
Property | ShowLabels | Gets a value indicating whether grid labels are visible.
Property | Style | Gets the map grid labels style.
Top

See Also

Reference

IMapGridLines Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapGridLines Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapGridLines Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface

Glossary Item Box

For a list of all members of this type, see IMapGridLines members.

Public Properties

 | Name | Description
Property | Hidden | Gets a value indicating whether this meridian/parallel should be rendered.
Property | Interval | Gets the interval between meridians/parallels.
Property | LabelPosition | Gets the positions of grid labels.
Property | ShowLabels | Gets a value indicating whether grid labels are visible.
Property | Style | Gets the map grid labels style.
Top

See Also

Reference

IMapGridLines Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether this meridian/parallel should be rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if this meridian/parallel should not be rendered; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Interface
IMapGridLines Members


Interval Property

[image]
ActiveReports 19 .NET Edition
Interval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Interval Property

Glossary Item Box

Gets the interval between meridians/parallels.

Syntax

Visual Basic (Declaration)
ReadOnly Property Interval As Double
C#
double Interval {get;}

Property Value

A System.Double representing the interval between meridians/parallels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Interface
IMapGridLines Members


LabelPosition Property

[image]
ActiveReports 19 .NET Edition
LabelPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : LabelPosition Property

Glossary Item Box

Gets the positions of grid labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelPosition As MapLabelPositionType
C#
MapLabelPositionType LabelPosition {get;}

Property Value

A MapLabelPositionType representing the positions of the grid labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Interface
IMapGridLines Members


ShowLabels Property

[image]
ActiveReports 19 .NET Edition
ShowLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : ShowLabels Property

Glossary Item Box

Gets a value indicating whether grid labels are visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShowLabels As Boolean
C#
bool ShowLabels {get;}

Property Value

A System.Boolean value. true if grid labels are visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Interface
IMapGridLines Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Style Property

Glossary Item Box

Gets the map grid labels style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the style of the map grid labels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapGridLines Interface
IMapGridLines Members


IMapLayer Interface

[image]
ActiveReports 19 .NET Edition
IMapLayer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface

Glossary Item Box

Represents a map layer rendering item.

Syntax

Visual Basic (Declaration)
Public Interface IMapLayer
C#
public interface IMapLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLayer Interface Members

[image]
ActiveReports 19 .NET Edition
IMapLayer Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface

Glossary Item Box

The following tables list the members exposed by IMapLayer.

Public Properties

 | Name | Description
Property | MaxZoom | Gets the maximum zoom level at which the layer is visible.
Property | MinZoom | Gets the minimum zoom level at which the layer is visible.
Property | Name | Gets the layer name.
Property | Transparency | Gets the map layer transparency.
Property | VisibilityMode | Gets the map layer visibility mode.
Top

See Also

Reference

IMapLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLayer Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapLayer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface

Glossary Item Box

For a list of all members of this type, see IMapLayer members.

Public Properties

 | Name | Description
Property | MaxZoom | Gets the maximum zoom level at which the layer is visible.
Property | MinZoom | Gets the minimum zoom level at which the layer is visible.
Property | Name | Gets the layer name.
Property | Transparency | Gets the map layer transparency.
Property | VisibilityMode | Gets the map layer visibility mode.
Top

See Also

Reference

IMapLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MaxZoom Property

[image]
ActiveReports 19 .NET Edition
MaxZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : MaxZoom Property

Glossary Item Box

Gets the maximum zoom level at which the layer is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxZoom As Double
C#
double MaxZoom {get;}

Property Value

A System.Double representing the maximum zoom level at which the layer is visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Interface
IMapLayer Members


MinZoom Property

[image]
ActiveReports 19 .NET Edition
MinZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : MinZoom Property

Glossary Item Box

Gets the minimum zoom level at which the layer is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinZoom As Double
C#
double MinZoom {get;}

Property Value

A System.Double representing the minimum zoom level at which the layer is visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Interface
IMapLayer Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : Name Property

Glossary Item Box

Gets the layer name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the layer name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Interface
IMapLayer Members


Transparency Property

[image]
ActiveReports 19 .NET Edition
Transparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : Transparency Property

Glossary Item Box

Gets the map layer transparency.

Syntax

Visual Basic (Declaration)
ReadOnly Property Transparency As Double
C#
double Transparency {get;}

Property Value

A System.Double representing the map layer transparency.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Interface
IMapLayer Members


VisibilityMode Property

[image]
ActiveReports 19 .NET Edition
VisibilityMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : VisibilityMode Property

Glossary Item Box

Gets the map layer visibility mode.

Syntax

Visual Basic (Declaration)
ReadOnly Property VisibilityMode As MapVisibilityMode
C#
MapVisibilityMode VisibilityMode {get;}

Property Value

A MapVisibilityMode representing the map layer visibility mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLayer Interface
IMapLayer Members


IMapLegend Interface

[image]
ActiveReports 19 .NET Edition
IMapLegend Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface

Glossary Item Box

Represents the map legend rendering settings.

Syntax

Visual Basic (Declaration)
Public Interface IMapLegend
   Inherits IMapDockableSubItem, IMapSubItem
C#
public interface IMapLegend : IMapDockableSubItem, IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegend Interface Members

[image]
ActiveReports 19 .NET Edition
IMapLegend Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface

Glossary Item Box

The following tables list the members exposed by IMapLegend.

Public Properties

 | Name | Description
Property | AutoFitText | Gets a value indicating whether text will be autosized to fit in the map legend area.
Property | Caption | Gets the caption for the title of a map legend.
Property | EquallySpacedItems | Gets a value indicating whether legend items are equally spaced in the map legend.
Property | InterlacedRows | Gets a value indicating whether the legend rows will use interlaced colors.
Property | InterlacedRowsColor | Gets the color of the interlaced rows in the map legend.
Property | LegendItems | Gets the collection of legend subitems.
Property | LegendLayout | Gets the arrangement of labels in a map legend.
Property | MinFontSize | Gets the minimum font size for the auto-sizing algorithm of the map legend text.
Property | Name | Gets the RDL name of the legend item.
Property | TextWrapThreshold | Gets the number of characters after which to wrap the legend text in the map legend.
Property | TitleSeparator | Gets the style of the separator between the legend title and legend body.
Property | TitleSeparatorColor | Gets the color of the separator between the legend title and legend body.
Property | TitleStyle | Gets the map caption rendering style.
Top

See Also

Reference

IMapLegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegend Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapLegend Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface

Glossary Item Box

For a list of all members of this type, see IMapLegend members.

Public Properties

 | Name | Description
Property | AutoFitText | Gets a value indicating whether text will be autosized to fit in the map legend area.
Property | Caption | Gets the caption for the title of a map legend.
Property | EquallySpacedItems | Gets a value indicating whether legend items are equally spaced in the map legend.
Property | InterlacedRows | Gets a value indicating whether the legend rows will use interlaced colors.
Property | InterlacedRowsColor | Gets the color of the interlaced rows in the map legend.
Property | LegendItems | Gets the collection of legend subitems.
Property | LegendLayout | Gets the arrangement of labels in a map legend.
Property | MinFontSize | Gets the minimum font size for the auto-sizing algorithm of the map legend text.
Property | Name | Gets the RDL name of the legend item.
Property | TextWrapThreshold | Gets the number of characters after which to wrap the legend text in the map legend.
Property | TitleSeparator | Gets the style of the separator between the legend title and legend body.
Property | TitleSeparatorColor | Gets the color of the separator between the legend title and legend body.
Property | TitleStyle | Gets the map caption rendering style.
Top

See Also

Reference

IMapLegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


AutoFitText Property

[image]
ActiveReports 19 .NET Edition
AutoFitText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : AutoFitText Property

Glossary Item Box

Gets a value indicating whether text will be autosized to fit in the map legend area.

Syntax

Visual Basic (Declaration)
ReadOnly Property AutoFitText As Boolean
C#
bool AutoFitText {get;}

Property Value

A System.Boolean value. true if the text will be autosized to fit in the map legend area; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


Caption Property

[image]
ActiveReports 19 .NET Edition
Caption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : Caption Property

Glossary Item Box

Gets the caption for the title of a map legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property Caption As String
C#
string Caption {get;}

Property Value

A System.String representing the caption for the title of the map legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


EquallySpacedItems Property

[image]
ActiveReports 19 .NET Edition
EquallySpacedItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : EquallySpacedItems Property

Glossary Item Box

Gets a value indicating whether legend items are equally spaced in the map legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property EquallySpacedItems As Boolean
C#
bool EquallySpacedItems {get;}

Property Value

A System.Boolean value. true if legend items are equally spaced; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


InterlacedRows Property

[image]
ActiveReports 19 .NET Edition
InterlacedRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : InterlacedRows Property

Glossary Item Box

Gets a value indicating whether the legend rows will use interlaced colors.

Syntax

Visual Basic (Declaration)
ReadOnly Property InterlacedRows As Boolean
C#
bool InterlacedRows {get;}

Property Value

A System.Boolean value. true if the legend rows will use interlaced colors; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


InterlacedRowsColor Property

[image]
ActiveReports 19 .NET Edition
InterlacedRowsColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : InterlacedRowsColor Property

Glossary Item Box

Gets the color of the interlaced rows in the map legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property InterlacedRowsColor As String
C#
string InterlacedRowsColor {get;}

Property Value

A System.String representing the color of the interlaced rows in the map legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


LegendItems Property

[image]
ActiveReports 19 .NET Edition
LegendItems Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : LegendItems Property

Glossary Item Box

Gets the collection of legend subitems.

Syntax

Visual Basic (Declaration)
ReadOnly Property LegendItems As IEnumerable(Of IMapLegendItem)
C#
IEnumerable<IMapLegendItem> LegendItems {get;}

Property Value

A collection of IMapLegendItem representing the legend subitems.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


LegendLayout Property

[image]
ActiveReports 19 .NET Edition
LegendLayout Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : LegendLayout Property

Glossary Item Box

Gets the arrangement of labels in a map legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property LegendLayout As MapLegendLayout
C#
MapLegendLayout LegendLayout {get;}

Property Value

A MapLegendLayout representing the arrangement of labels in the map legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


MinFontSize Property

[image]
ActiveReports 19 .NET Edition
MinFontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : MinFontSize Property

Glossary Item Box

Gets the minimum font size for the auto-sizing algorithm of the map legend text.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinFontSize As Length
C#
Length MinFontSize {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the minimum font size for the auto-sizing algorithm of the map legend text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : Name Property

Glossary Item Box

Gets the RDL name of the legend item.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the RDL name of the legend item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


TextWrapThreshold Property

[image]
ActiveReports 19 .NET Edition
TextWrapThreshold Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TextWrapThreshold Property

Glossary Item Box

Gets the number of characters after which to wrap the legend text in the map legend.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextWrapThreshold As Integer
C#
int TextWrapThreshold {get;}

Property Value

An System.Int32 representing the number of characters after which to wrap the legend text in the map legend.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleSeparator Property

[image]
ActiveReports 19 .NET Edition
TitleSeparator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleSeparator Property

Glossary Item Box

Gets the style of the separator between the legend title and legend body.

Syntax

Visual Basic (Declaration)
ReadOnly Property TitleSeparator As MapLegendTitleSeparator
C#
MapLegendTitleSeparator TitleSeparator {get;}

Property Value

A MapLegendTitleSeparator representing the style of the separator between the legend title and legend body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleSeparatorColor Property

[image]
ActiveReports 19 .NET Edition
TitleSeparatorColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleSeparatorColor Property

Glossary Item Box

Gets the color of the separator between the legend title and legend body.

Syntax

Visual Basic (Declaration)
ReadOnly Property TitleSeparatorColor As String
C#
string TitleSeparatorColor {get;}

Property Value

A System.String representing the color of the separator between the legend title and legend body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleStyle Property

[image]
ActiveReports 19 .NET Edition
TitleStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleStyle Property

Glossary Item Box

Gets the map caption rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property TitleStyle As IStyle
C#
IStyle TitleStyle {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the map caption rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegend Interface
IMapLegend Members


IMapLegendItem Interface

[image]
ActiveReports 19 .NET Edition
IMapLegendItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface

Glossary Item Box

Represents a map legend rendering subitem.

Syntax

Visual Basic (Declaration)
Public Interface IMapLegendItem
C#
public interface IMapLegendItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegendItem Interface Members

[image]
ActiveReports 19 .NET Edition
IMapLegendItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface

Glossary Item Box

The following tables list the members exposed by IMapLegendItem.

Public Properties

 | Name | Description
Property | Label | Gets the map legend item text.
Property | MarkerImage | Gets the image settings for Image MarkerStyle.
Property | MarkerStyle | Gets the map legend rendering style.
Property | Size | Gets the height and width of the plotting area of the point marker.
Property | Style | Gets the map legend item text rendering style.
Top

See Also

Reference

IMapLegendItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegendItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapLegendItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface

Glossary Item Box

For a list of all members of this type, see IMapLegendItem members.

Public Properties

 | Name | Description
Property | Label | Gets the map legend item text.
Property | MarkerImage | Gets the image settings for Image MarkerStyle.
Property | MarkerStyle | Gets the map legend rendering style.
Property | Size | Gets the height and width of the plotting area of the point marker.
Property | Style | Gets the map legend item text rendering style.
Top

See Also

Reference

IMapLegendItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Label Property

Glossary Item Box

Gets the map legend item text.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Property Value

A System.String representing the map legend item text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


MarkerImage Property

[image]
ActiveReports 19 .NET Edition
MarkerImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : MarkerImage Property

Glossary Item Box

Gets the image settings for Image MarkerStyle.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerImage As IMapMarkerImage
C#
IMapMarkerImage MarkerImage {get;}

Property Value

An IMapMarkerImage representing the image settings for Image MarkerStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


MarkerStyle Property

[image]
ActiveReports 19 .NET Edition
MarkerStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : MarkerStyle Property

Glossary Item Box

Gets the map legend rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerStyle As MapLegendMarkerStyle
C#
MapLegendMarkerStyle MarkerStyle {get;}

Property Value

A MapLegendMarkerStyle representing the map legend rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Size Property

Glossary Item Box

Gets the height and width of the plotting area of the point marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As Length
C#
Length Size {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height and width of the plotting area of the point marker.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Style Property

Glossary Item Box

Gets the map legend item text rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the map legend item text rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


IMapLimits Interface

[image]
ActiveReports 19 .NET Edition
IMapLimits Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface

Glossary Item Box

Represents the limits of a IMapViewport element.

Syntax

Visual Basic (Declaration)
Public Interface IMapLimits
C#
public interface IMapLimits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLimits Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLimits Interface Members

[image]
ActiveReports 19 .NET Edition
IMapLimits Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface

Glossary Item Box

The following tables list the members exposed by IMapLimits.

Public Properties

 | Name | Description
Property | MaximumX | Gets the maximum X value in map coordinates for a IMapViewport element.
Property | MaximumY | Gets the maximum Y value in map coordinates for a IMapViewport element.
Property | MinimumX | Gets the minimum X value in map coordinates for a IMapViewport element.
Property | MinimumY | Gets the minimum Y value in map coordinates for a IMapViewport element.
Top

See Also

Reference

IMapLimits Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLimits Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapLimits Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface

Glossary Item Box

For a list of all members of this type, see IMapLimits members.

Public Properties

 | Name | Description
Property | MaximumX | Gets the maximum X value in map coordinates for a IMapViewport element.
Property | MaximumY | Gets the maximum Y value in map coordinates for a IMapViewport element.
Property | MinimumX | Gets the minimum X value in map coordinates for a IMapViewport element.
Property | MinimumY | Gets the minimum Y value in map coordinates for a IMapViewport element.
Top

See Also

Reference

IMapLimits Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MaximumX Property

[image]
ActiveReports 19 .NET Edition
MaximumX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MaximumX Property

Glossary Item Box

Gets the maximum X value in map coordinates for a IMapViewport element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumX As Double
C#
double MaximumX {get;}

Property Value

A System.Double representing the maximum X value in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLimits Interface
IMapLimits Members


MaximumY Property

[image]
ActiveReports 19 .NET Edition
MaximumY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MaximumY Property

Glossary Item Box

Gets the maximum Y value in map coordinates for a IMapViewport element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumY As Double
C#
double MaximumY {get;}

Property Value

A System.Double representing the maximum Y value in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLimits Interface
IMapLimits Members


MinimumX Property

[image]
ActiveReports 19 .NET Edition
MinimumX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MinimumX Property

Glossary Item Box

Gets the minimum X value in map coordinates for a IMapViewport element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinimumX As Double
C#
double MinimumX {get;}

Property Value

A System.Double representing the minimum X value in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLimits Interface
IMapLimits Members


MinimumY Property

[image]
ActiveReports 19 .NET Edition
MinimumY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MinimumY Property

Glossary Item Box

Gets the minimum Y value in map coordinates for a IMapViewport element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinimumY As Double
C#
double MinimumY {get;}

Property Value

A System.Double representing the minimum Y value in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLimits Interface
IMapLimits Members


IMapLineElement Interface

[image]
ActiveReports 19 .NET Edition
IMapLineElement Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface

Glossary Item Box

Represents the map spatial line.

Syntax

Visual Basic (Declaration)
Public Interface IMapLineElement
   Inherits IMapSpatialElement
C#
public interface IMapLineElement : IMapSpatialElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLineElement Interface Members

[image]
ActiveReports 19 .NET Edition
IMapLineElement Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface

Glossary Item Box

The following tables list the members exposed by IMapLineElement.

Public Properties

 | Name | Description
Property | Label | Gets the label text for the map line.
Property | LabelPlacement | Gets the label placement.
Property | Style | Gets the text rendering style.
Property | Tooltip | Gets the line tooltip.
Property | Width | Gets the line width.
Top

See Also

Reference

IMapLineElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLineElement Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapLineElement Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface

Glossary Item Box

For a list of all members of this type, see IMapLineElement members.

Public Properties

 | Name | Description
Property | Label | Gets the label text for the map line.
Property | LabelPlacement | Gets the label placement.
Property | Style | Gets the text rendering style.
Property | Tooltip | Gets the line tooltip.
Property | Width | Gets the line width.
Top

See Also

Reference

IMapLineElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Label Property

Glossary Item Box

Gets the label text for the map line.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Property Value

A System.String representing the label text for the map line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Interface
IMapLineElement Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : LabelPlacement Property

Glossary Item Box

Gets the label placement.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelPlacement As MapLineLabelPlacement
C#
MapLineLabelPlacement LabelPlacement {get;}

Property Value

A MapLineLabelPlacement representing the label placement.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Style Property

Glossary Item Box

Gets the text rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the text rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Tooltip Property

Glossary Item Box

Gets the line tooltip.

Syntax

Visual Basic (Declaration)
ReadOnly Property Tooltip As String
C#
string Tooltip {get;}

Property Value

A System.String representing the line tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Width Property

Glossary Item Box

Gets the line width.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the line width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapLineElement Interface
IMapLineElement Members


IMapMarker Interface

[image]
ActiveReports 19 .NET Edition
IMapMarker Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface

Glossary Item Box

Represents the marker for map spatial elements.

Syntax

Visual Basic (Declaration)
Public Interface IMapMarker
C#
public interface IMapMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarker Interface Members

[image]
ActiveReports 19 .NET Edition
IMapMarker Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface

Glossary Item Box

The following tables list the members exposed by IMapMarker.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the marker if any, otherwise null.
Property | Hidden | Gets a value indicating whether the marker is hidden.
Property | Label | Gets the marker label.
Property | LabelPlacement | Gets the label placement.
Property | MarkerImage | Gets the marker image.
Property | MarkerStyle | Gets the marker style.
Property | Name | Gets the marker name.
Property | OffsetX | Gets the offset of the x-coordinate specifying in pixels.
Property | OffsetY | Gets the offset of the y-coordinate specifying in pixels.
Property | Size | Gets the marker size.
Property | Style | Gets the style.
Property | Tooltip | Gets the tooltip.
Top

See Also

Reference

IMapMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarker Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapMarker Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface

Glossary Item Box

For a list of all members of this type, see IMapMarker members.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the marker if any, otherwise null.
Property | Hidden | Gets a value indicating whether the marker is hidden.
Property | Label | Gets the marker label.
Property | LabelPlacement | Gets the label placement.
Property | MarkerImage | Gets the marker image.
Property | MarkerStyle | Gets the marker style.
Property | Name | Gets the marker name.
Property | OffsetX | Gets the offset of the x-coordinate specifying in pixels.
Property | OffsetY | Gets the offset of the y-coordinate specifying in pixels.
Property | Size | Gets the marker size.
Property | Style | Gets the style.
Property | Tooltip | Gets the tooltip.
Top

See Also

Reference

IMapMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Action Property

Glossary Item Box

Gets the action associated with the marker if any, otherwise null.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction representing the action associated with the marker, or null if there is no associated action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether the marker is hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the marker is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Label Property

Glossary Item Box

Gets the marker label.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Property Value

A System.String representing the marker label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : LabelPlacement Property

Glossary Item Box

Gets the label placement.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelPlacement As MapMarkerLabelPlacement
C#
MapMarkerLabelPlacement LabelPlacement {get;}

Property Value

A MapMarkerLabelPlacement representing the label placement.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


MarkerImage Property

[image]
ActiveReports 19 .NET Edition
MarkerImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : MarkerImage Property

Glossary Item Box

Gets the marker image.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerImage As IMapMarkerImage
C#
IMapMarkerImage MarkerImage {get;}

Property Value

An IMapMarkerImage representing the marker image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


MarkerStyle Property

[image]
ActiveReports 19 .NET Edition
MarkerStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : MarkerStyle Property

Glossary Item Box

Gets the marker style.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerStyle As MapMarkerStyle
C#
MapMarkerStyle MarkerStyle {get;}

Property Value

A MapMarkerStyle representing the marker style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Name Property

Glossary Item Box

Gets the marker name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the marker name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


OffsetX Property

[image]
ActiveReports 19 .NET Edition
OffsetX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : OffsetX Property

Glossary Item Box

Gets the offset of the x-coordinate specifying in pixels.

Syntax

Visual Basic (Declaration)
ReadOnly Property OffsetX As Double
C#
double OffsetX {get;}

Property Value

A System.Double representing the offset of the x-coordinate in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


OffsetY Property

[image]
ActiveReports 19 .NET Edition
OffsetY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : OffsetY Property

Glossary Item Box

Gets the offset of the y-coordinate specifying in pixels.

Syntax

Visual Basic (Declaration)
ReadOnly Property OffsetY As Double
C#
double OffsetY {get;}

Property Value

A System.Double representing the offset of the y-coordinate in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Size Property

Glossary Item Box

Gets the marker size.

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As Length
C#
Length Size {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the marker size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Style Property

Glossary Item Box

Gets the style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Tooltip Property

Glossary Item Box

Gets the tooltip.

Syntax

Visual Basic (Declaration)
ReadOnly Property Tooltip As String
C#
string Tooltip {get;}

Property Value

A System.String representing the tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarker Interface
IMapMarker Members


IMapMarkerImage Interface

[image]
ActiveReports 19 .NET Edition
IMapMarkerImage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface

Glossary Item Box

Represents the rendering settings for a IMapMarker with Image style.

Syntax

Visual Basic (Declaration)
Public Interface IMapMarkerImage
C#
public interface IMapMarkerImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarkerImage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarkerImage Interface Members

[image]
ActiveReports 19 .NET Edition
IMapMarkerImage Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface

Glossary Item Box

The following tables list the members exposed by IMapMarkerImage.

Public Properties

 | Name | Description
Property | Image | Gets the image object to render.
Property | ResizeMode | Gets the rendering resize mode for the image.
Property | TransparentColor | Gets the color to make transparent.
Top

See Also

Reference

IMapMarkerImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarkerImage Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapMarkerImage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface

Glossary Item Box

For a list of all members of this type, see IMapMarkerImage members.

Public Properties

 | Name | Description
Property | Image | Gets the image object to render.
Property | ResizeMode | Gets the rendering resize mode for the image.
Property | TransparentColor | Gets the color to make transparent.
Top

See Also

Reference

IMapMarkerImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Image Property

[image]
ActiveReports 19 .NET Edition
Image Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarkerImage Interface : Image Property

Glossary Item Box

Gets the image object to render.

Syntax

Visual Basic (Declaration)
ReadOnly Property Image As ImageInfo
C#
ImageInfo Image {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo representing the image object to render.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarkerImage Interface
IMapMarkerImage Members


ResizeMode Property

[image]
ActiveReports 19 .NET Edition
ResizeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarkerImage Interface : ResizeMode Property

Glossary Item Box

Gets the rendering resize mode for the image.

Syntax

Visual Basic (Declaration)
ReadOnly Property ResizeMode As MapImageResizeMode
C#
MapImageResizeMode ResizeMode {get;}

Property Value

A MapImageResizeMode representing the rendering resize mode for the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarkerImage Interface
IMapMarkerImage Members


TransparentColor Property

[image]
ActiveReports 19 .NET Edition
TransparentColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarkerImage Interface : TransparentColor Property

Glossary Item Box

Gets the color to make transparent.

Syntax

Visual Basic (Declaration)
ReadOnly Property TransparentColor As Color
C#
Color TransparentColor {get;}

Property Value

A System.Drawing.Color representing the color to make transparent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapMarkerImage Interface
IMapMarkerImage Members


IMapPointElement Interface

[image]
ActiveReports 19 .NET Edition
IMapPointElement Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface

Glossary Item Box

Represents the map spatial point.

Syntax

Visual Basic (Declaration)
Public Interface IMapPointElement
   Inherits IMapSpatialElement
C#
public interface IMapPointElement : IMapSpatialElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPointElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPointElement Interface Members

[image]
ActiveReports 19 .NET Edition
IMapPointElement Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface

Glossary Item Box

The following tables list the members exposed by IMapPointElement.

Public Properties

 | Name | Description
Property | Marker | Gets the point rendering marker.
Top

See Also

Reference

IMapPointElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPointElement Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapPointElement Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface

Glossary Item Box

For a list of all members of this type, see IMapPointElement members.

Public Properties

 | Name | Description
Property | Marker | Gets the point rendering marker.
Top

See Also

Reference

IMapPointElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPointElement Interface : Marker Property

Glossary Item Box

Gets the point rendering marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property Marker As IMapMarker
C#
IMapMarker Marker {get;}

Property Value

An IMapMarker representing the point rendering marker.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPointElement Interface
IMapPointElement Members


IMapPolygonElement Interface

[image]
ActiveReports 19 .NET Edition
IMapPolygonElement Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface

Glossary Item Box

Represents the map spatial polygon.

Syntax

Visual Basic (Declaration)
Public Interface IMapPolygonElement
   Inherits IMapSpatialElement
C#
public interface IMapPolygonElement : IMapSpatialElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPolygonElement Interface Members

[image]
ActiveReports 19 .NET Edition
IMapPolygonElement Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface

Glossary Item Box

The following tables list the members exposed by IMapPolygonElement.

Public Properties

 | Name | Description
Property | CenterPointOffsetX | Gets the X offset for the center point of a polygon.
Property | CenterPointOffsetY | Gets the Y offset for the center point of a polygon.
Property | Label | Gets the label text for map polygons.
Property | LabelPlacement | Gets the label placement.
Property | LabelVisibility | Gets the label visibility.
Property | Marker | Gets the polygon rendering marker.
Property | ScaleFactor | Gets the twips to kilometers scale factor.
Property | Style | Gets the text rendering style.
Property | Tooltip | Gets the polygon tooltip.
Top

See Also

Reference

IMapPolygonElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPolygonElement Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapPolygonElement Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface

Glossary Item Box

For a list of all members of this type, see IMapPolygonElement members.

Public Properties

 | Name | Description
Property | CenterPointOffsetX | Gets the X offset for the center point of a polygon.
Property | CenterPointOffsetY | Gets the Y offset for the center point of a polygon.
Property | Label | Gets the label text for map polygons.
Property | LabelPlacement | Gets the label placement.
Property | LabelVisibility | Gets the label visibility.
Property | Marker | Gets the polygon rendering marker.
Property | ScaleFactor | Gets the twips to kilometers scale factor.
Property | Style | Gets the text rendering style.
Property | Tooltip | Gets the polygon tooltip.
Top

See Also

Reference

IMapPolygonElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


CenterPointOffsetX Property

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : CenterPointOffsetX Property

Glossary Item Box

Gets the X offset for the center point of a polygon.

Syntax

Visual Basic (Declaration)
ReadOnly Property CenterPointOffsetX As Double
C#
double CenterPointOffsetX {get;}

Property Value

A System.Double representing the X offset for the center point of a polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


CenterPointOffsetY Property

[image]
ActiveReports 19 .NET Edition
CenterPointOffsetY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : CenterPointOffsetY Property

Glossary Item Box

Gets the Y offset for the center point of a polygon.

Syntax

Visual Basic (Declaration)
ReadOnly Property CenterPointOffsetY As Double
C#
double CenterPointOffsetY {get;}

Property Value

A System.Double representing the Y offset for the center point of a polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Label Property

Glossary Item Box

Gets the label text for map polygons.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Property Value

A System.String representing the label text for map polygons.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


LabelPlacement Property

[image]
ActiveReports 19 .NET Edition
LabelPlacement Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : LabelPlacement Property

Glossary Item Box

Gets the label placement.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelPlacement As MapPolygonLabelPlacement
C#
MapPolygonLabelPlacement LabelPlacement {get;}

Property Value

A MapPolygonLabelPlacement representing the label placement.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


LabelVisibility Property

[image]
ActiveReports 19 .NET Edition
LabelVisibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : LabelVisibility Property

Glossary Item Box

Gets the label visibility.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelVisibility As MapPolygonLabelVisibility
C#
MapPolygonLabelVisibility LabelVisibility {get;}

Property Value

A MapPolygonLabelVisibility representing the label visibility.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Marker Property

[image]
ActiveReports 19 .NET Edition
Marker Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Marker Property

Glossary Item Box

Gets the polygon rendering marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property Marker As IMapMarker
C#
IMapMarker Marker {get;}

Property Value

An IMapMarker representing the polygon rendering marker.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


ScaleFactor Property

[image]
ActiveReports 19 .NET Edition
ScaleFactor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : ScaleFactor Property

Glossary Item Box

Gets the twips to kilometers scale factor.

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleFactor As Double
C#
double ScaleFactor {get;}

Property Value

A System.Double representing the twips to kilometers scale factor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Style Property

Glossary Item Box

Gets the text rendering style.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the text rendering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Tooltip Property

[image]
ActiveReports 19 .NET Edition
Tooltip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Tooltip Property

Glossary Item Box

Gets the polygon tooltip.

Syntax

Visual Basic (Declaration)
ReadOnly Property Tooltip As String
C#
string Tooltip {get;}

Property Value

A System.String representing the polygon tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


IMapSpatialElement Interface

[image]
ActiveReports 19 .NET Edition
IMapSpatialElement Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface

Glossary Item Box

Represents the map spatial element.

Syntax

Visual Basic (Declaration)
Public Interface IMapSpatialElement
C#
public interface IMapSpatialElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSpatialElement Interface Members

[image]
ActiveReports 19 .NET Edition
IMapSpatialElement Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface

Glossary Item Box

The following tables list the members exposed by IMapSpatialElement.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the element if any, otherwise null.
Property | DataElementLabel | Gets the data element label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the data element output.
Property | Hidden | Gets a value indicating whether the element is hidden.
Property | Name | Gets the name.
Property | OffsetX | Gets the offset of the x-coordinate specified in degrees.
Property | OffsetY | Gets the offset of the y-coordinate specified in degrees.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Shape | Gets the spatial shape.
Property | Transparency | Gets the transparency.
Property | Values | Gets the spatial element values.
Top

See Also

Reference

IMapSpatialElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSpatialElement Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapSpatialElement Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface

Glossary Item Box

For a list of all members of this type, see IMapSpatialElement members.

Public Properties

 | Name | Description
Property | Action | Gets the action associated with the element if any, otherwise null.
Property | DataElementLabel | Gets the data element label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the data element output.
Property | Hidden | Gets a value indicating whether the element is hidden.
Property | Name | Gets the name.
Property | OffsetX | Gets the offset of the x-coordinate specified in degrees.
Property | OffsetY | Gets the offset of the y-coordinate specified in degrees.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Shape | Gets the spatial shape.
Property | Transparency | Gets the transparency.
Property | Values | Gets the spatial element values.
Top

See Also

Reference

IMapSpatialElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Action Property

Glossary Item Box

Gets the action associated with the element if any, otherwise null.

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As IAction
C#
IAction Action {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction representing the action associated with the element, or null if there is no associated action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementLabel Property

[image]
ActiveReports 19 .NET Edition
DataElementLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementLabel Property

Glossary Item Box

Gets the data element label.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementLabel As String
C#
string DataElementLabel {get;}

Property Value

A System.String representing the data element label.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementName Property

Glossary Item Box

Gets the name of the data element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name of the data element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementOutput Property

Glossary Item Box

Gets the data element output.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput representing the data element output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Hidden Property

Glossary Item Box

Gets a value indicating whether the element is hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Property Value

A System.Boolean value. true if the element is hidden; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Name Property

Glossary Item Box

Gets the name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


OffsetX Property

[image]
ActiveReports 19 .NET Edition
OffsetX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : OffsetX Property

Glossary Item Box

Gets the offset of the x-coordinate specified in degrees.

Syntax

Visual Basic (Declaration)
ReadOnly Property OffsetX As Double
C#
double OffsetX {get;}

Property Value

A System.Double representing the offset of the x-coordinate in degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


OffsetY Property

[image]
ActiveReports 19 .NET Edition
OffsetY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : OffsetY Property

Glossary Item Box

Gets the offset of the y-coordinate specified in degrees.

Syntax

Visual Basic (Declaration)
ReadOnly Property OffsetY As Double
C#
double OffsetY {get;}

Property Value

A System.Double representing the offset of the y-coordinate in degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


ShadowIntensity Property

[image]
ActiveReports 19 .NET Edition
ShadowIntensity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : ShadowIntensity Property

Glossary Item Box

Gets the shadow intensity.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShadowIntensity As Double
C#
double ShadowIntensity {get;}

Property Value

A System.Double representing the shadow intensity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Shape Property

[image]
ActiveReports 19 .NET Edition
Shape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Shape Property

Glossary Item Box

Gets the spatial shape.

Syntax

Visual Basic (Declaration)
ReadOnly Property Shape As GeoShape
C#
GeoShape Shape {get;}

Property Value

A GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape representing the spatial shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Transparency Property

[image]
ActiveReports 19 .NET Edition
Transparency Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Transparency Property

Glossary Item Box

Gets the transparency.

Syntax

Visual Basic (Declaration)
ReadOnly Property Transparency As Double
C#
double Transparency {get;}

Property Value

A System.Double representing the transparency.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Values Property

Glossary Item Box

Gets the spatial element values.

Syntax

Visual Basic (Declaration)
ReadOnly Property Values As IEnumerable(Of KeyValuePair(Of String,Object))
C#
IEnumerable<KeyValuePair<string,object>> Values {get;}

Property Value

An enumerable representing the spatial element values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


IMapSubItem Interface

[image]
ActiveReports 19 .NET Edition
IMapSubItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface

Glossary Item Box

Represents the base interface for all map rendering parts: viewport, titles, legends, distance scale, color scale.

Syntax

Visual Basic (Declaration)
Public Interface IMapSubItem
C#
public interface IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSubItem Interface Members

[image]
ActiveReports 19 .NET Edition
IMapSubItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface

Glossary Item Box

The following tables list the members exposed by IMapSubItem.

Public Properties

 | Name | Description
Property | BottomMargin | Gets the width of the bottom margin. The default value is 0in.
Property | LeftMargin | Gets the width of the left margin. The default value is 0in.
Property | MapLocation | Gets the subitem location within the map.
Property | MapSize | Gets the subitem size within the map.
Property | RightMargin | Gets the width of the right margin. The default value is 0in.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Style | Gets the style properties for the map subitem.
Property | TopMargin | Gets the width of the top margin. The default value is 0in.
Property | ZIndex | Gets the drawing order of the item within the map. The default value is 0.
Top

See Also

Reference

IMapSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSubItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapSubItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface

Glossary Item Box

For a list of all members of this type, see IMapSubItem members.

Public Properties

 | Name | Description
Property | BottomMargin | Gets the width of the bottom margin. The default value is 0in.
Property | LeftMargin | Gets the width of the left margin. The default value is 0in.
Property | MapLocation | Gets the subitem location within the map.
Property | MapSize | Gets the subitem size within the map.
Property | RightMargin | Gets the width of the right margin. The default value is 0in.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Style | Gets the style properties for the map subitem.
Property | TopMargin | Gets the width of the top margin. The default value is 0in.
Property | ZIndex | Gets the drawing order of the item within the map. The default value is 0.
Top

See Also

Reference

IMapSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : BottomMargin Property

Glossary Item Box

Gets the width of the bottom margin. The default value is 0in.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomMargin As Length
C#
Length BottomMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the bottom margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : LeftMargin Property

Glossary Item Box

Gets the width of the left margin. The default value is 0in.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftMargin As Length
C#
Length LeftMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the left margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


MapLocation Property

[image]
ActiveReports 19 .NET Edition
MapLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : MapLocation Property

Glossary Item Box

Gets the subitem location within the map.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapLocation As MapLocation
C#
MapLocation MapLocation {get;}

Property Value

A MapLocation representing the subitem location within the map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


MapSize Property

[image]
ActiveReports 19 .NET Edition
MapSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : MapSize Property

Glossary Item Box

Gets the subitem size within the map.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapSize As MapSize
C#
MapSize MapSize {get;}

Property Value

A MapSize representing the subitem size within the map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : RightMargin Property

Glossary Item Box

Gets the width of the right margin. The default value is 0in.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightMargin As Length
C#
Length RightMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the right margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


ShadowIntensity Property

[image]
ActiveReports 19 .NET Edition
ShadowIntensity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : ShadowIntensity Property

Glossary Item Box

Gets the shadow intensity.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShadowIntensity As Double
C#
double ShadowIntensity {get;}

Property Value

A System.Double representing the shadow intensity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : Style Property

Glossary Item Box

Gets the style properties for the map subitem.

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As IStyle
C#
IStyle Style {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle representing the style properties for the map subitem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : TopMargin Property

Glossary Item Box

Gets the width of the top margin. The default value is 0in.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopMargin As Length
C#
Length TopMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of the top margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


ZIndex Property

[image]
ActiveReports 19 .NET Edition
ZIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : ZIndex Property

Glossary Item Box

Gets the drawing order of the item within the map. The default value is 0.

Syntax

Visual Basic (Declaration)
ReadOnly Property ZIndex As Integer
C#
int ZIndex {get;}

Property Value

An System.Int32 representing the drawing order of the item within the map.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapSubItem Interface
IMapSubItem Members


IMapTile Interface

[image]
ActiveReports 19 .NET Edition
IMapTile Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface

Glossary Item Box

Represents a tile of a map tile layer.

Syntax

Visual Basic (Declaration)
Public Interface IMapTile
C#
public interface IMapTile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTile Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTile Interface Members

[image]
ActiveReports 19 .NET Edition
IMapTile Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface

Glossary Item Box

The following tables list the members exposed by IMapTile.

Public Properties

 | Name | Description
Property | Id | Gets the unique tile identifier within the layer.
Property | Image | Gets the tile image.
Top

See Also

Reference

IMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTile Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapTile Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface

Glossary Item Box

For a list of all members of this type, see IMapTile members.

Public Properties

 | Name | Description
Property | Id | Gets the unique tile identifier within the layer.
Property | Image | Gets the tile image.
Top

See Also

Reference

IMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTile Interface : Id Property

Glossary Item Box

Gets the unique tile identifier within the layer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Id As MapTileKey
C#
MapTileKey Id {get;}

Property Value

A MapTileKey representing the unique tile identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTile Interface
IMapTile Members


Image Property

[image]
ActiveReports 19 .NET Edition
Image Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTile Interface : Image Property

Glossary Item Box

Gets the tile image.

Syntax

Visual Basic (Declaration)
ReadOnly Property Image As ImageInfo
C#
ImageInfo Image {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo representing the tile image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTile Interface
IMapTile Members


IMapTileLayer Interface

[image]
ActiveReports 19 .NET Edition
IMapTileLayer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface

Glossary Item Box

Represents a map layer with image tiles as data.

Syntax

Visual Basic (Declaration)
Public Interface IMapTileLayer
   Inherits IMapLayer
C#
public interface IMapTileLayer : IMapLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileLayer Interface Members

[image]
ActiveReports 19 .NET Edition
IMapTileLayer Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface

Glossary Item Box

The following tables list the members exposed by IMapTileLayer.

Public Properties

 | Name | Description
Property | EmbeddedTiles | Gets the collection of embedded tiles.
Property | Provider | Gets the name of the tile provider. 'Bing' by default.
Property | TileLanguage | Gets the language of the tile.
Property | TileStyle | Gets the tiles style.
Property | UseSecureConnection | Gets a value indicating whether a secure connection should be used for retrieving tiles.
Top

See Also

Reference

IMapTileLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileLayer Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapTileLayer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface

Glossary Item Box

For a list of all members of this type, see IMapTileLayer members.

Public Properties

 | Name | Description
Property | EmbeddedTiles | Gets the collection of embedded tiles.
Property | Provider | Gets the name of the tile provider. 'Bing' by default.
Property | TileLanguage | Gets the language of the tile.
Property | TileStyle | Gets the tiles style.
Property | UseSecureConnection | Gets a value indicating whether a secure connection should be used for retrieving tiles.
Top

See Also

Reference

IMapTileLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


EmbeddedTiles Property

[image]
ActiveReports 19 .NET Edition
EmbeddedTiles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : EmbeddedTiles Property

Glossary Item Box

Gets the collection of embedded tiles.

Syntax

Visual Basic (Declaration)
ReadOnly Property EmbeddedTiles As IEnumerable(Of IEmbeddedMapTile)
C#
IEnumerable<IEmbeddedMapTile> EmbeddedTiles {get;}

Property Value

An IEnumerable representing the collection of embedded tiles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


Provider Property

[image]
ActiveReports 19 .NET Edition
Provider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : Provider Property

Glossary Item Box

Gets the name of the tile provider. 'Bing' by default.

Syntax

Visual Basic (Declaration)
ReadOnly Property Provider As String
C#
string Provider {get;}

Property Value

A System.String representing the name of the tile provider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


TileLanguage Property

[image]
ActiveReports 19 .NET Edition
TileLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : TileLanguage Property

Glossary Item Box

Gets the language of the tile.

Syntax

Visual Basic (Declaration)
ReadOnly Property TileLanguage As String
C#
string TileLanguage {get;}

Property Value

A System.String representing the language of the tile.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


TileStyle Property

[image]
ActiveReports 19 .NET Edition
TileStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : TileStyle Property

Glossary Item Box

Gets the tiles style.

Syntax

Visual Basic (Declaration)
ReadOnly Property TileStyle As MapTileStyle
C#
MapTileStyle TileStyle {get;}

Property Value

A MapTileStyle representing the style of the tiles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


UseSecureConnection Property

[image]
ActiveReports 19 .NET Edition
UseSecureConnection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : UseSecureConnection Property

Glossary Item Box

Gets a value indicating whether a secure connection should be used for retrieving tiles.

Syntax

Visual Basic (Declaration)
ReadOnly Property UseSecureConnection As Boolean
C#
bool UseSecureConnection {get;}

Property Value

A System.Boolean value. true if a secure connection should be used; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


IMapTileProvider Interface

[image]
ActiveReports 19 .NET Edition
IMapTileProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

Glossary Item Box

Represents the provider of tiles for a particular tile layer.

Syntax

Visual Basic (Declaration)
Public Interface IMapTileProvider
C#
public interface IMapTileProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProvider Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IMapTileProvider Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

Glossary Item Box

The following tables list the members exposed by IMapTileProvider.

Public Properties

 | Name | Description
Property | Copyright | Gets the copyright information displayed for the tile provider.
Property | Settings | Gets the tile provider settings, such as ApiKey, Language, Style, etc.
Top

Public Methods

 | Name | Description
Method | GetTile | Gets an instance of a tile by specified coordinates and level of detail.
Top

See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IMapTileProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

Glossary Item Box

For a list of all members of this type, see IMapTileProvider members.

Public Methods

 | Name | Description
Method | GetTile | Gets an instance of a tile by specified coordinates and level of detail.
Top

See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


GetTile Method

[image]
ActiveReports 19 .NET Edition
GetTile Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : GetTile Method

key
The tile identifier.
success
The success result handler.
error
The error handler.

Glossary Item Box

Gets an instance of a tile by specified coordinates and level of detail.

Syntax

Visual Basic (Declaration)
Sub GetTile( _
   ByVal key As MapTileKey, _
   ByVal success As Action(Of IMapTile), _
   ByVal error As Action(Of Exception) _
)
C#
void GetTile(
   MapTileKey key,
   Action<IMapTile> success,
   Action<Exception> error
)

Parameters

key
The tile identifier.
success
The success result handler.
error
The error handler.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


IMapTileProvider Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapTileProvider Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

Glossary Item Box

For a list of all members of this type, see IMapTileProvider members.

Public Properties

 | Name | Description
Property | Copyright | Gets the copyright information displayed for the tile provider.
Property | Settings | Gets the tile provider settings, such as ApiKey, Language, Style, etc.
Top

See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Copyright Property

[image]
ActiveReports 19 .NET Edition
Copyright Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : Copyright Property

Glossary Item Box

Gets the copyright information displayed for the tile provider.

Syntax

Visual Basic (Declaration)
ReadOnly Property Copyright As String
C#
string Copyright {get;}

Property Value

A System.String representing the copyright information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


Settings Property

[image]
ActiveReports 19 .NET Edition
Settings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : Settings Property

Glossary Item Box

Gets the tile provider settings, such as ApiKey, Language, Style, etc.

Syntax

Visual Basic (Declaration)
ReadOnly Property Settings As NameValueCollection
C#
NameValueCollection Settings {get;}

Property Value

A System.Collections.Specialized.NameValueCollection representing the tile provider settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


IMapTileProviderFactory Interface

[image]
ActiveReports 19 .NET Edition
IMapTileProviderFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderFactory Interface

Glossary Item Box

Represents a factory for creating map tile providers.

Syntax

Visual Basic (Declaration)
Public Interface IMapTileProviderFactory
C#
public interface IMapTileProviderFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProviderFactory Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProviderFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IMapTileProviderFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderFactory Interface

Glossary Item Box

The following tables list the members exposed by IMapTileProviderFactory.

Public Methods

 | Name | Description
Method | CreateProvider | Create provider for the tile layer
Top

See Also

Reference

IMapTileProviderFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProviderFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IMapTileProviderFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderFactory Interface

Glossary Item Box

For a list of all members of this type, see IMapTileProviderFactory members.

Public Methods

 | Name | Description
Method | CreateProvider | Create provider for the tile layer
Top

See Also

Reference

IMapTileProviderFactory Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


CreateProvider Method

[image]
ActiveReports 19 .NET Edition
CreateProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProviderFactory Interface : CreateProvider Method

layer

Glossary Item Box

Create provider for the tile layer

Syntax

Visual Basic (Declaration)
Function CreateProvider( _
   ByVal layer As IMapTileLayer _
) As IMapTileProviderInternal
C#
IMapTileProviderInternal CreateProvider(
   IMapTileLayer layer
)

Parameters

layer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTileProviderFactory Interface
IMapTileProviderFactory Members


IMapTitle Interface

[image]
ActiveReports 19 .NET Edition
IMapTitle Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface

Glossary Item Box

Represents the map title.

Syntax

Visual Basic (Declaration)
Public Interface IMapTitle
   Inherits IMapDockableSubItem, IMapSubItem
C#
public interface IMapTitle : IMapDockableSubItem, IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTitle Interface Members

[image]
ActiveReports 19 .NET Edition
IMapTitle Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface

Glossary Item Box

The following tables list the members exposed by IMapTitle.

Public Properties

 | Name | Description
Property | Angle | Gets the angle of rotation for the title.
Property | Name | Gets the title name.
Property | Text | Gets the text of the title.
Property | TextShadowOffset | Gets the size of the text shadow. The default value is 0.
Top

See Also

Reference

IMapTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTitle Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapTitle Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface

Glossary Item Box

For a list of all members of this type, see IMapTitle members.

Public Properties

 | Name | Description
Property | Angle | Gets the angle of rotation for the title.
Property | Name | Gets the title name.
Property | Text | Gets the text of the title.
Property | TextShadowOffset | Gets the size of the text shadow. The default value is 0.
Top

See Also

Reference

IMapTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Angle Property

Glossary Item Box

Gets the angle of rotation for the title.

Syntax

Visual Basic (Declaration)
ReadOnly Property Angle As Double
C#
double Angle {get;}

Property Value

A System.Double representing the angle of rotation for the title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTitle Interface
IMapTitle Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Name Property

Glossary Item Box

Gets the title name.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Property Value

A System.String representing the title name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTitle Interface
IMapTitle Members


Text Property

[image]
ActiveReports 19 .NET Edition
Text Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Text Property

Glossary Item Box

Gets the text of the title.

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
C#
string Text {get;}

Property Value

A System.String representing the text of the title.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTitle Interface
IMapTitle Members


TextShadowOffset Property

[image]
ActiveReports 19 .NET Edition
TextShadowOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : TextShadowOffset Property

Glossary Item Box

Gets the size of the text shadow. The default value is 0.

Syntax

Visual Basic (Declaration)
ReadOnly Property TextShadowOffset As Length
C#
Length TextShadowOffset {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the size of the text shadow.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapTitle Interface
IMapTitle Members


IMapVectorLayer Interface

[image]
ActiveReports 19 .NET Edition
IMapVectorLayer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

Glossary Item Box

Represents a map layer with spatial data rendering item.

Syntax

Visual Basic (Declaration)
Public Interface IMapVectorLayer
   Inherits IMapLayer
C#
public interface IMapVectorLayer : IMapLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapVectorLayer Interface Members

[image]
ActiveReports 19 .NET Edition
IMapVectorLayer Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

Glossary Item Box

The following tables list the members exposed by IMapVectorLayer.

Public Properties

 | Name | Description
Property | ColorScaleElements | Gets the color scale settings.
Property | DataElementName | Gets the XML export custom element name.
Property | DataElementOutput | Gets the XML export custom element output type.
Property | Elements | Gets the spatial elements to render in the layer.
Top

Public Methods

 | Name | Description
Method | ProcessLegend | Obtains rendering legend items.
Top

See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapVectorLayer Interface Methods

[image]
ActiveReports 19 .NET Edition
IMapVectorLayer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

Glossary Item Box

For a list of all members of this type, see IMapVectorLayer members.

Public Methods

 | Name | Description
Method | ProcessLegend | Obtains rendering legend items.
Top

See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ProcessLegend Method

[image]
ActiveReports 19 .NET Edition
ProcessLegend Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : ProcessLegend Method

legend
The map legend to process.

Glossary Item Box

Obtains rendering legend items.

Syntax

Visual Basic (Declaration)
Function ProcessLegend( _
   ByVal legend As IMapLegend _
) As IEnumerable(Of IMapLegendItem)
C#
IEnumerable<IMapLegendItem> ProcessLegend(
   IMapLegend legend
)

Parameters

legend
The map legend to process.

Return Value

An IEnumerable representing the processed legend items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


IMapVectorLayer Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapVectorLayer Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

Glossary Item Box

For a list of all members of this type, see IMapVectorLayer members.

Public Properties

 | Name | Description
Property | ColorScaleElements | Gets the color scale settings.
Property | DataElementName | Gets the XML export custom element name.
Property | DataElementOutput | Gets the XML export custom element output type.
Property | Elements | Gets the spatial elements to render in the layer.
Top

See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ColorScaleElements Property

[image]
ActiveReports 19 .NET Edition
ColorScaleElements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : ColorScaleElements Property

Glossary Item Box

Gets the color scale settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColorScaleElements As IEnumerable(Of IMapColorScaleElement)
C#
IEnumerable<IMapColorScaleElement> ColorScaleElements {get;}

Property Value

An IEnumerable representing the color scale settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : DataElementName Property

Glossary Item Box

Gets the XML export custom element name.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the XML export custom element name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : DataElementOutput Property

Glossary Item Box

Gets the XML export custom element output type.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput representing the XML export custom element output type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


Elements Property

[image]
ActiveReports 19 .NET Edition
Elements Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : Elements Property

Glossary Item Box

Gets the spatial elements to render in the layer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Elements As IEnumerable(Of IMapSpatialElement)
C#
IEnumerable<IMapSpatialElement> Elements {get;}

Property Value

An IEnumerable representing the spatial elements to render in the layer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


IMapView Interface

[image]
ActiveReports 19 .NET Edition
IMapView Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface

Glossary Item Box

Represents the main view rendering settings for a map viewport.

Syntax

Visual Basic (Declaration)
Public Interface IMapView
C#
public interface IMapView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapView Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapView Interface Members

[image]
ActiveReports 19 .NET Edition
IMapView Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface

Glossary Item Box

The following tables list the members exposed by IMapView.

Public Properties

 | Name | Description
Property | CenterUnits | Gets the type of the MapViewport.MapView.
Property | CenterX | Gets the x-coordinate of the MapViewport element center as a percentage of the map content.
Property | CenterY | Gets the y-coordinate of the MapViewport element center as a percentage of the map content.
Property | Zoom | Gets the zoom level of a MapViewport element.
Top

See Also

Reference

IMapView Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapView Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapView Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface

Glossary Item Box

For a list of all members of this type, see IMapView members.

Public Properties

 | Name | Description
Property | CenterUnits | Gets the type of the MapViewport.MapView.
Property | CenterX | Gets the x-coordinate of the MapViewport element center as a percentage of the map content.
Property | CenterY | Gets the y-coordinate of the MapViewport element center as a percentage of the map content.
Property | Zoom | Gets the zoom level of a MapViewport element.
Top

See Also

Reference

IMapView Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


CenterUnits Property

[image]
ActiveReports 19 .NET Edition
CenterUnits Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterUnits Property

Glossary Item Box

Gets the type of the MapViewport.MapView.

Syntax

Visual Basic (Declaration)
ReadOnly Property CenterUnits As MapViewCenterUnits
C#
MapViewCenterUnits CenterUnits {get;}

Property Value

A MapViewCenterUnits representing the type of the MapViewport.MapView.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapView Interface
IMapView Members


CenterX Property

[image]
ActiveReports 19 .NET Edition
CenterX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterX Property

Glossary Item Box

Gets the x-coordinate of the MapViewport element center as a percentage of the map content.

Syntax

Visual Basic (Declaration)
ReadOnly Property CenterX As Double
C#
double CenterX {get;}

Property Value

A System.Double representing the x-coordinate of the MapViewport element center.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapView Interface
IMapView Members


CenterY Property

[image]
ActiveReports 19 .NET Edition
CenterY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterY Property

Glossary Item Box

Gets the y-coordinate of the MapViewport element center as a percentage of the map content.

Syntax

Visual Basic (Declaration)
ReadOnly Property CenterY As Double
C#
double CenterY {get;}

Property Value

A System.Double representing the y-coordinate of the MapViewport element center.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapView Interface
IMapView Members


Zoom Property

[image]
ActiveReports 19 .NET Edition
Zoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : Zoom Property

Glossary Item Box

Gets the zoom level of a MapViewport element.

Syntax

Visual Basic (Declaration)
ReadOnly Property Zoom As Double
C#
double Zoom {get;}

Property Value

A System.Double representing the zoom level of a MapViewport element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapView Interface
IMapView Members


IMapViewport Interface

[image]
ActiveReports 19 .NET Edition
IMapViewport Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface

Glossary Item Box

Represents the map viewport rendering item.

Syntax

Visual Basic (Declaration)
Public Interface IMapViewport
   Inherits IMapSubItem
C#
public interface IMapViewport : IMapSubItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapViewport Interface Members

[image]
ActiveReports 19 .NET Edition
IMapViewport Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface

Glossary Item Box

The following tables list the members exposed by IMapViewport.

Public Properties

 | Name | Description
Property | ContentMargin | Gets the margin between a MapViewport element and its content.
Property | GridUnderContent | Gets a value indicating whether the map meridians and map parallels will be drawn under the map content.
Property | MapCoordinateSystem | Gets the coordinate system rendering settings.
Property | MapLimits | Gets the map viewport rendering limits.
Property | MapMeridians | Gets the meridians rendering settings.
Property | MapParallels | Gets the parallels rendering settings.
Property | MapProjection | Gets the used map projection.
Property | MapView | Gets the map viewport main view settings.
Property | MaximumZoom | Gets the maximum zoom level that is allowed in a Map element.
Property | MinimumZoom | Gets the minimum zoom level that is allowed in a Map element.
Property | ProjectionCenterX | Gets the X projection center of a MapViewport element in map coordinates.
Property | ProjectionCenterY | Gets the Y projection center of a MapViewport element in map coordinates.
Property | ScaleFactor | Gets or sets the twips to kilometers scale factor.
Property | SimplificationResolution | Gets the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.
Top

See Also

Reference

IMapViewport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapViewport Interface Properties

[image]
ActiveReports 19 .NET Edition
IMapViewport Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface

Glossary Item Box

For a list of all members of this type, see IMapViewport members.

Public Properties

 | Name | Description
Property | ContentMargin | Gets the margin between a MapViewport element and its content.
Property | GridUnderContent | Gets a value indicating whether the map meridians and map parallels will be drawn under the map content.
Property | MapCoordinateSystem | Gets the coordinate system rendering settings.
Property | MapLimits | Gets the map viewport rendering limits.
Property | MapMeridians | Gets the meridians rendering settings.
Property | MapParallels | Gets the parallels rendering settings.
Property | MapProjection | Gets the used map projection.
Property | MapView | Gets the map viewport main view settings.
Property | MaximumZoom | Gets the maximum zoom level that is allowed in a Map element.
Property | MinimumZoom | Gets the minimum zoom level that is allowed in a Map element.
Property | ProjectionCenterX | Gets the X projection center of a MapViewport element in map coordinates.
Property | ProjectionCenterY | Gets the Y projection center of a MapViewport element in map coordinates.
Property | ScaleFactor | Gets or sets the twips to kilometers scale factor.
Property | SimplificationResolution | Gets the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.
Top

See Also

Reference

IMapViewport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ContentMargin Property

[image]
ActiveReports 19 .NET Edition
ContentMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ContentMargin Property

Glossary Item Box

Gets the margin between a MapViewport element and its content.

Syntax

Visual Basic (Declaration)
ReadOnly Property ContentMargin As Length
C#
Length ContentMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the margin between a MapViewport element and its content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


GridUnderContent Property

[image]
ActiveReports 19 .NET Edition
GridUnderContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : GridUnderContent Property

Glossary Item Box

Gets a value indicating whether the map meridians and map parallels will be drawn under the map content.

Syntax

Visual Basic (Declaration)
ReadOnly Property GridUnderContent As Boolean
C#
bool GridUnderContent {get;}

Property Value

A System.Boolean value. true if the map meridians and map parallels will be drawn under the map content; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapCoordinateSystem Property

[image]
ActiveReports 19 .NET Edition
MapCoordinateSystem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapCoordinateSystem Property

Glossary Item Box

Gets the coordinate system rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapCoordinateSystem As MapCoordinateSystem
C#
MapCoordinateSystem MapCoordinateSystem {get;}

Property Value

A MapCoordinateSystem representing the coordinate system rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapLimits Property

[image]
ActiveReports 19 .NET Edition
MapLimits Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapLimits Property

Glossary Item Box

Gets the map viewport rendering limits.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapLimits As IMapLimits
C#
IMapLimits MapLimits {get;}

Property Value

An IMapLimits representing the map viewport rendering limits.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapMeridians Property

[image]
ActiveReports 19 .NET Edition
MapMeridians Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapMeridians Property

Glossary Item Box

Gets the meridians rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapMeridians As IMapGridLines
C#
IMapGridLines MapMeridians {get;}

Property Value

An IMapGridLines representing the meridians rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapParallels Property

[image]
ActiveReports 19 .NET Edition
MapParallels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapParallels Property

Glossary Item Box

Gets the parallels rendering settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapParallels As IMapGridLines
C#
IMapGridLines MapParallels {get;}

Property Value

An IMapGridLines representing the parallels rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapProjection Property

[image]
ActiveReports 19 .NET Edition
MapProjection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapProjection Property

Glossary Item Box

Gets the used map projection.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapProjection As MapProjection
C#
MapProjection MapProjection {get;}

Property Value

A MapProjection representing the used map projection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MapView Property

[image]
ActiveReports 19 .NET Edition
MapView Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapView Property

Glossary Item Box

Gets the map viewport main view settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapView As IMapView
C#
IMapView MapView {get;}

Property Value

An IMapView representing the map viewport main view settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MaximumZoom Property

[image]
ActiveReports 19 .NET Edition
MaximumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MaximumZoom Property

Glossary Item Box

Gets the maximum zoom level that is allowed in a Map element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumZoom As Double
C#
double MaximumZoom {get;}

Property Value

A System.Double representing the maximum zoom level that is allowed in a Map element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


MinimumZoom Property

[image]
ActiveReports 19 .NET Edition
MinimumZoom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MinimumZoom Property

Glossary Item Box

Gets the minimum zoom level that is allowed in a Map element.

Syntax

Visual Basic (Declaration)
ReadOnly Property MinimumZoom As Double
C#
double MinimumZoom {get;}

Property Value

A System.Double representing the minimum zoom level that is allowed in a Map element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


ProjectionCenterX Property

[image]
ActiveReports 19 .NET Edition
ProjectionCenterX Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ProjectionCenterX Property

Glossary Item Box

Gets the X projection center of a MapViewport element in map coordinates.

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectionCenterX As Double
C#
double ProjectionCenterX {get;}

Property Value

A System.Double representing the X projection center of a MapViewport element in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


ProjectionCenterY Property

[image]
ActiveReports 19 .NET Edition
ProjectionCenterY Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ProjectionCenterY Property

Glossary Item Box

Gets the Y projection center of a MapViewport element in map coordinates.

Syntax

Visual Basic (Declaration)
ReadOnly Property ProjectionCenterY As Double
C#
double ProjectionCenterY {get;}

Property Value

A System.Double representing the Y projection center of a MapViewport element in map coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


ScaleFactor Property

[image]
ActiveReports 19 .NET Edition
ScaleFactor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ScaleFactor Property

Glossary Item Box

Gets or sets the twips to kilometers scale factor.

Syntax

Visual Basic (Declaration)
Property ScaleFactor As Double
C#
double ScaleFactor {get; set;}

Property Value

A System.Double representing the twips to kilometers scale factor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


SimplificationResolution Property

[image]
ActiveReports 19 .NET Edition
SimplificationResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : SimplificationResolution Property

Glossary Item Box

Gets the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.

Syntax

Visual Basic (Declaration)
ReadOnly Property SimplificationResolution As Double
C#
double SimplificationResolution {get;}

Property Value

A System.Double representing the resolution used to simplify map polygons and map lines.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapViewport Interface
IMapViewport Members


GeoCurve Class

[image]
ActiveReports 19 .NET Edition
GeoCurve Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoCurve Class

Glossary Item Box

Represents the base type for geospatial curve.

Object Model

GeoCurve Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GeoCurve
   Inherits GeoShape
C#
public abstract class GeoCurve : GeoShape

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoCurve Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoCurve Class Members

[image]
ActiveReports 19 .NET Edition
GeoCurve Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoCurve Class

Glossary Item Box

The following tables list the members exposed by GeoCurve.

See Also

Reference

GeoCurve Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Class

[image]
ActiveReports 19 .NET Edition
GeoGeometryCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class

Glossary Item Box

Represents the collection of geospatial shapes.

Object Model

GeoGeometryCollection Class

Syntax

Visual Basic (Declaration)
Public Class GeoGeometryCollection
   Inherits GeoShape
C#
public class GeoGeometryCollection : GeoShape

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPolygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Class Members

[image]
ActiveReports 19 .NET Edition
GeoGeometryCollection Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class

Glossary Item Box

The following tables list the members exposed by GeoGeometryCollection.

Public Constructors

 | Name | Description
Public Constructor | GeoGeometryCollection Constructor | Initializes a new instance of the GeoGeometryCollection class.
Top

Public Properties

 | Name | Description
Public Property | Is3D | Overridden. Gets a value indicating whether any shape in the collection has Z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the collection is empty or all shapes in the collection are empty geometries.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any shape in the collection has M-coordinate values.
Public Property | PointsCount | Overridden. Gets the total number of points used in the shapes.
Public Property | Shapes | Gets the inner shapes.
Top

See Also

Reference

GeoGeometryCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Constructor

[image]
ActiveReports 19 .NET Edition
GeoGeometryCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : GeoGeometryCollection Constructor

shapes
Collection of geospatial shapes

Glossary Item Box

Initializes a new instance of the GeoGeometryCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal shapes As IEnumerable(Of GeoShape) _
)
C#
public GeoGeometryCollection(
   IEnumerable<GeoShape> shapes
)

Parameters

shapes
Collection of geospatial shapes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


GeoGeometryCollection Class Properties

[image]
ActiveReports 19 .NET Edition
GeoGeometryCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class

Glossary Item Box

For a list of all members of this type, see GeoGeometryCollection members.

Public Properties

 | Name | Description
Public Property | Is3D | Overridden. Gets a value indicating whether any shape in the collection has Z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the collection is empty or all shapes in the collection are empty geometries.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any shape in the collection has M-coordinate values.
Public Property | PointsCount | Overridden. Gets the total number of points used in the shapes.
Public Property | Shapes | Gets the inner shapes.
Top

See Also

Reference

GeoGeometryCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : Is3D Property

Glossary Item Box

Gets a value indicating whether any shape in the collection has Z-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Is3D As Boolean
C#
public override bool Is3D {get;}

Property Value

A System.Boolean value. true if any shape in the collection has Z-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the collection is empty or all shapes in the collection are empty geometries.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

A System.Boolean value. true if the collection is empty or all shapes in the collection are empty geometries; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : IsMeasured Property

Glossary Item Box

Gets a value indicating whether any shape in the collection has M-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsMeasured As Boolean
C#
public override bool IsMeasured {get;}

Property Value

A System.Boolean value. true if any shape in the collection has M-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : PointsCount Property

Glossary Item Box

Gets the total number of points used in the shapes.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PointsCount As Integer
C#
public override int PointsCount {get;}

Property Value

The total number of points used in the shapes contained in this GeoGeometryCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


Shapes Property

[image]
ActiveReports 19 .NET Edition
Shapes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : Shapes Property

Glossary Item Box

Gets the inner shapes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shapes As IEnumerable(Of GeoShape)
C#
public IEnumerable<GeoShape> Shapes {get;}

Property Value

The collection of geospatial shapes contained in this GeoGeometryCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


GeoLine Class

[image]
ActiveReports 19 .NET Edition
GeoLine Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLine Class

Glossary Item Box

Represents the geospatial line

Object Model

GeoLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoLine
   Inherits GeoLineString
C#
public sealed class GeoLine : GeoLineString

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLine Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLine Class Members

[image]
ActiveReports 19 .NET Edition
GeoLine Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLine Class

Glossary Item Box

The following tables list the members exposed by GeoLine.

Public Constructors

 | Name | Description
Public Constructor | GeoLine Constructor | Initializes a new instance of the GeoLine class.
Top

See Also

Reference

GeoLine Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLine Constructor

[image]
ActiveReports 19 .NET Edition
GeoLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLine Class : GeoLine Constructor

points
The points.

Glossary Item Box

Initializes a new instance of the GeoLine class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points As IEnumerable(Of GeoPoint) _
)
C#
public GeoLine(
   IEnumerable<GeoPoint> points
)

Parameters

points
The points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLine Class
GeoLine Members


GeoLinearRing Class

[image]
ActiveReports 19 .NET Edition
GeoLinearRing Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class

Glossary Item Box

Represents the geospatial ring for the polygons.

Object Model

GeoLinearRing Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoLinearRing
   Inherits GeoLineString
C#
public sealed class GeoLinearRing : GeoLineString

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLinearRing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLinearRing Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLinearRing Class Members

[image]
ActiveReports 19 .NET Edition
GeoLinearRing Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class

Glossary Item Box

The following tables list the members exposed by GeoLinearRing.

Public Constructors

 | Name | Description
Public Constructor | GeoLinearRing Constructor | Initializes a new instance of the GeoLinearRing class.
Top

Public Properties

 | Name | Description
Public Property | Center | Overridden. Gets the centroid of the polygon.
Top

See Also

Reference

GeoLinearRing Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLinearRing Constructor

[image]
ActiveReports 19 .NET Edition
GeoLinearRing Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLinearRing Class : GeoLinearRing Constructor

points
The points.

Glossary Item Box

Initializes a new instance of the GeoLinearRing class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points As IEnumerable(Of GeoPoint) _
)
C#
public GeoLinearRing(
   IEnumerable<GeoPoint> points
)

Parameters

points
The points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLinearRing Class
GeoLinearRing Members


GeoLinearRing Class Properties

[image]
ActiveReports 19 .NET Edition
GeoLinearRing Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class

Glossary Item Box

For a list of all members of this type, see GeoLinearRing members.

Public Properties

 | Name | Description
Public Property | Center | Overridden. Gets the centroid of the polygon.
Top

See Also

Reference

GeoLinearRing Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Center Property

[image]
ActiveReports 19 .NET Edition
Center Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLinearRing Class : Center Property

Glossary Item Box

Gets the centroid of the polygon.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Center As PointF
C#
public override PointF Center {get;}

Property Value

A System.Drawing.PointF representing the centroid of the polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLinearRing Class
GeoLinearRing Members


GeoLineString Class

[image]
ActiveReports 19 .NET Edition
GeoLineString Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class

Glossary Item Box

Represents the geospatial line shape.

Object Model

GeoLineString Class

Syntax

Visual Basic (Declaration)
Public Class GeoLineString
   Inherits GeoCurve
C#
public class GeoLineString : GeoCurve

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLine
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLinearRing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLineString Class Members

[image]
ActiveReports 19 .NET Edition
GeoLineString Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class

Glossary Item Box

The following tables list the members exposed by GeoLineString.

Public Constructors

 | Name | Description
Public Constructor | GeoLineString Constructor | Initializes a new instance of the GeoLineString class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the line shape.
Public Property | Is3D | Overridden. Returns true if any point in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns a value indicating whether the collection of line points is empty.
Public Property | IsMeasured | Overridden. Returns true if any point in the collection has m-coordinate values.
Public Property | Points | Gets the line points.
Public Property | PointsCount | Overridden. Returns the number of points in the line.
Top

See Also

Reference

GeoLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLineString Constructor

[image]
ActiveReports 19 .NET Edition
GeoLineString Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : GeoLineString Constructor

points
The line points.

Glossary Item Box

Initializes a new instance of the GeoLineString class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points As IEnumerable(Of GeoPoint) _
)
C#
public GeoLineString(
   IEnumerable<GeoPoint> points
)

Parameters

points
The line points.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when the points argument is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


GeoLineString Class Properties

[image]
ActiveReports 19 .NET Edition
GeoLineString Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class

Glossary Item Box

For a list of all members of this type, see GeoLineString members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the line shape.
Public Property | Is3D | Overridden. Returns true if any point in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns a value indicating whether the collection of line points is empty.
Public Property | IsMeasured | Overridden. Returns true if any point in the collection has m-coordinate values.
Public Property | Points | Gets the line points.
Public Property | PointsCount | Overridden. Returns the number of points in the line.
Top

See Also

Reference

GeoLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Bounds Property

Glossary Item Box

Returns the bounds of the line shape.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounding rectangle of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Is3D Property

Glossary Item Box

Returns true if any point in the collection has z-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Is3D As Boolean
C#
public override bool Is3D {get;}

Property Value

true if any point has z-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : IsEmpty Property

Glossary Item Box

Returns a value indicating whether the collection of line points is empty.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

true if the collection of line points is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : IsMeasured Property

Glossary Item Box

Returns true if any point in the collection has m-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsMeasured As Boolean
C#
public override bool IsMeasured {get;}

Property Value

true if any point has m-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


Points Property

[image]
ActiveReports 19 .NET Edition
Points Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Points Property

Glossary Item Box

Gets the line points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As IEnumerable(Of GeoPoint)
C#
public IEnumerable<GeoPoint> Points {get;}

Property Value

An IEnumerable representing the points of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : PointsCount Property

Glossary Item Box

Returns the number of points in the line.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PointsCount As Integer
C#
public override int PointsCount {get;}

Property Value

An System.Int32 representing the number of points in the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoLineString Class
GeoLineString Members


GeoMultiLineString Class

[image]
ActiveReports 19 .NET Edition
GeoMultiLineString Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class

Glossary Item Box

Represents the geospatial multi line shape.

Object Model

GeoMultiLineString Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoMultiLineString
   Inherits GeoGeometryCollection
C#
public sealed class GeoMultiLineString : GeoGeometryCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiLineString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiLineString Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiLineString Class Members

[image]
ActiveReports 19 .NET Edition
GeoMultiLineString Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class

Glossary Item Box

The following tables list the members exposed by GeoMultiLineString.

Public Constructors

 | Name | Description
Public Constructor | GeoMultiLineString Constructor | Initializes a new instance of the GeoMultiLineString class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi-line shape.
Public Property | Lines | Gets the line shapes.
Top

See Also

Reference

GeoMultiLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiLineString Constructor

[image]
ActiveReports 19 .NET Edition
GeoMultiLineString Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : GeoMultiLineString Constructor

lines
The collection of line strings.

Glossary Item Box

Initializes a new instance of the GeoMultiLineString class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lines As IEnumerable(Of GeoLineString) _
)
C#
public GeoMultiLineString(
   IEnumerable<GeoLineString> lines
)

Parameters

lines
The collection of line strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


GeoMultiLineString Class Properties

[image]
ActiveReports 19 .NET Edition
GeoMultiLineString Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class

Glossary Item Box

For a list of all members of this type, see GeoMultiLineString members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi-line shape.
Public Property | Lines | Gets the line shapes.
Top

See Also

Reference

GeoMultiLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : Bounds Property

Glossary Item Box

Returns the bounds of the multi-line shape.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the multi-line shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


Lines Property

[image]
ActiveReports 19 .NET Edition
Lines Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : Lines Property

Glossary Item Box

Gets the line shapes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lines As IEnumerable(Of GeoLineString)
C#
public IEnumerable<GeoLineString> Lines {get;}

Property Value

An IEnumerable representing the line shapes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


GeoMultiPoint Class

[image]
ActiveReports 19 .NET Edition
GeoMultiPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class

Glossary Item Box

Represents the geospatial multi-point shape.

Object Model

GeoMultiPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoMultiPoint
   Inherits GeoGeometryCollection
C#
public sealed class GeoMultiPoint : GeoGeometryCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPoint Class Members

[image]
ActiveReports 19 .NET Edition
GeoMultiPoint Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class

Glossary Item Box

The following tables list the members exposed by GeoMultiPoint.

Public Constructors

 | Name | Description
Public Constructor | GeoMultiPoint Constructor | Initializes a new instance of the GeoMultiPoint class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi-point shape.
Public Property | IsEmpty | Overridden. Returns a value indicating whether the collection is empty.
Public Property | Points | Gets the inner points shapes.
Top

See Also

Reference

GeoMultiPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPoint Constructor

[image]
ActiveReports 19 .NET Edition
GeoMultiPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : GeoMultiPoint Constructor

points
The collection of points.

Glossary Item Box

Initializes a new instance of the GeoMultiPoint class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points As IEnumerable(Of GeoPoint) _
)
C#
public GeoMultiPoint(
   IEnumerable<GeoPoint> points
)

Parameters

points
The collection of points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


GeoMultiPoint Class Properties

[image]
ActiveReports 19 .NET Edition
GeoMultiPoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class

Glossary Item Box

For a list of all members of this type, see GeoMultiPoint members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi-point shape.
Public Property | IsEmpty | Overridden. Returns a value indicating whether the collection is empty.
Public Property | Points | Gets the inner points shapes.
Top

See Also

Reference

GeoMultiPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : Bounds Property

Glossary Item Box

Returns the bounds of the multi-point shape.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the multi-point shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : IsEmpty Property

Glossary Item Box

Returns a value indicating whether the collection is empty.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

true if the collection is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


Points Property

[image]
ActiveReports 19 .NET Edition
Points Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : Points Property

Glossary Item Box

Gets the inner points shapes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As IEnumerable(Of GeoPoint)
C#
public IEnumerable<GeoPoint> Points {get;}

Property Value

An IEnumerable representing the inner point shapes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


GeoMultiPolygon Class

[image]
ActiveReports 19 .NET Edition
GeoMultiPolygon Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class

Glossary Item Box

Represents the multi polygon shape.

Object Model

GeoMultiPolygon Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoMultiPolygon
   Inherits GeoGeometryCollection
C#
public sealed class GeoMultiPolygon : GeoGeometryCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPolygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPolygon Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPolygon Class Members

[image]
ActiveReports 19 .NET Edition
GeoMultiPolygon Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class

Glossary Item Box

The following tables list the members exposed by GeoMultiPolygon.

Public Constructors

 | Name | Description
Public Constructor | GeoMultiPolygon Constructor | Initializes new instance of GeoMultiPolygon.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi polygon shape.
Public Property | Center | Overridden. Gets the centroid of the multi polygon shape.
Public Property | Polygons | Gets the inner polygon shapes.
Top

See Also

Reference

GeoMultiPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPolygon Constructor

[image]
ActiveReports 19 .NET Edition
GeoMultiPolygon Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : GeoMultiPolygon Constructor

polygons
The inner polygon shapes.

Glossary Item Box

Initializes new instance of GeoMultiPolygon.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal polygons As IEnumerable(Of GeoPolygon) _
)
C#
public GeoMultiPolygon(
   IEnumerable<GeoPolygon> polygons
)

Parameters

polygons
The inner polygon shapes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


GeoMultiPolygon Class Properties

[image]
ActiveReports 19 .NET Edition
GeoMultiPolygon Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class

Glossary Item Box

For a list of all members of this type, see GeoMultiPolygon members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi polygon shape.
Public Property | Center | Overridden. Gets the centroid of the multi polygon shape.
Public Property | Polygons | Gets the inner polygon shapes.
Top

See Also

Reference

GeoMultiPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Bounds Property

Glossary Item Box

Returns the bounds of the multi polygon shape.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the multi polygon shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


Center Property

[image]
ActiveReports 19 .NET Edition
Center Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Center Property

Glossary Item Box

Gets the centroid of the multi polygon shape.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Center As PointF
C#
public override PointF Center {get;}

Property Value

A System.Drawing.PointF representing the centroid of the multi polygon shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


Polygons Property

[image]
ActiveReports 19 .NET Edition
Polygons Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Polygons Property

Glossary Item Box

Gets the inner polygon shapes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Polygons As IEnumerable(Of GeoPolygon)
C#
public IEnumerable<GeoPolygon> Polygons {get;}

Property Value

An IEnumerable representing the inner polygon shapes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


GeoPoint Class

[image]
ActiveReports 19 .NET Edition
GeoPoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class

Glossary Item Box

Represents the geospatial point shape.

Object Model

GeoPoint Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoPoint
   Inherits GeoShape
C#
public sealed class GeoPoint : GeoShape

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPoint Class Members

[image]
ActiveReports 19 .NET Edition
GeoPoint Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class

Glossary Item Box

The following tables list the members exposed by GeoPoint.

Public Constructors

 | Name | Description
Public Constructor | GeoPoint Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the point shape.
Public Property | Is3D | Overridden. Gets a value indicating whether the point shape has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the point shape is empty geometry.
Public Property | IsMeasured | Overridden. Gets a value indicating whether the point shape has m-coordinate values.
Public Property | M | Gets the m-coordinate.
Public Property | PointsCount | Overridden. Gets the count of the points.
Public Property | X | Gets the x-coordinate.
Public Property | Y | Gets the y-coordinate.
Public Property | Z | Gets the z-coordinate.
Top

See Also

Reference

GeoPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPoint Constructor

[image]
ActiveReports 19 .NET Edition
GeoPoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : GeoPoint Constructor

Glossary Item Box

Overload List

Overload | Description
GeoPoint Constructor(Double,Double) | Initializes a new instance of the GeoPoint class.
GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>) | Initializes a new instance of the GeoPoint class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


GeoPoint Constructor(Double,Double)

[image]
ActiveReports 19 .NET Edition
GeoPoint Constructor(Double,Double)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class > GeoPoint Constructor : GeoPoint Constructor(Double,Double)

x
The x-coordinate.
y
The y-coordinate.

Glossary Item Box

Initializes a new instance of the GeoPoint class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
C#
public GeoPoint(
   double x,
   double y
)

Parameters

x
The x-coordinate.
y
The y-coordinate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members
Overload List


GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)

[image]
ActiveReports 19 .NET Edition
GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class > GeoPoint Constructor : GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)

x
The x-coordinate.
y
The y-coordinate.
z
The z-coordinate.
m
The m-coordinate.

Glossary Item Box

Initializes a new instance of the GeoPoint class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal z As Nullable(Of Double), _
   ByVal m As Nullable(Of Double) _
)
C#
public GeoPoint(
   double x,
   double y,
   Nullable<double> z,
   Nullable<double> m
)

Parameters

x
The x-coordinate.
y
The y-coordinate.
z
The z-coordinate.
m
The m-coordinate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members
Overload List


GeoPoint Class Properties

[image]
ActiveReports 19 .NET Edition
GeoPoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class

Glossary Item Box

For a list of all members of this type, see GeoPoint members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the point shape.
Public Property | Is3D | Overridden. Gets a value indicating whether the point shape has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the point shape is empty geometry.
Public Property | IsMeasured | Overridden. Gets a value indicating whether the point shape has m-coordinate values.
Public Property | M | Gets the m-coordinate.
Public Property | PointsCount | Overridden. Gets the count of the points.
Public Property | X | Gets the x-coordinate.
Public Property | Y | Gets the y-coordinate.
Public Property | Z | Gets the z-coordinate.
Top

See Also

Reference

GeoPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Bounds Property

Glossary Item Box

Gets the bounds of the point shape.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the point shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Is3D Property

Glossary Item Box

Gets a value indicating whether the point shape has z-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Is3D As Boolean
C#
public override bool Is3D {get;}

Property Value

Returns true if the z-coordinate has a value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the point shape is empty geometry.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

Always returns false as a System.Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : IsMeasured Property

Glossary Item Box

Gets a value indicating whether the point shape has m-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsMeasured As Boolean
C#
public override bool IsMeasured {get;}

Property Value

Returns true if the m-coordinate has a value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


M Property

[image]
ActiveReports 19 .NET Edition
M Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : M Property

Glossary Item Box

Gets the m-coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property M As Nullable(Of Double)
C#
public Nullable<double> M {get;}

Property Value

The m-coordinate as a nullable System.Double value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : PointsCount Property

Glossary Item Box

Gets the count of the points.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property PointsCount As Integer
C#
public override int PointsCount {get;}

Property Value

Always returns 1 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : X Property

Glossary Item Box

Gets the x-coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Double
C#
public double X {get;}

Property Value

The x-coordinate as a System.Double value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Y Property

Glossary Item Box

Gets the y-coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Double
C#
public double Y {get;}

Property Value

The y-coordinate as a System.Double value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


Z Property

[image]
ActiveReports 19 .NET Edition
Z Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Z Property

Glossary Item Box

Gets the z-coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Z As Nullable(Of Double)
C#
public Nullable<double> Z {get;}

Property Value

The z-coordinate as a nullable System.Double value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPoint Class
GeoPoint Members


GeoPolygon Class

[image]
ActiveReports 19 .NET Edition
GeoPolygon Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class

Glossary Item Box

Represents the geospatial polygon shape.

Object Model

GeoPolygon Class

Syntax

Visual Basic (Declaration)
Public Class GeoPolygon
   Inherits GeoSurface
C#
public class GeoPolygon : GeoSurface

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTriangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolygon Class Members

[image]
ActiveReports 19 .NET Edition
GeoPolygon Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class

Glossary Item Box

The following tables list the members exposed by GeoPolygon.

Public Constructors

 | Name | Description
Public Constructor | GeoPolygon Constructor | Initializes new instance of GeoPolygon.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the polygon shape.
Public Property | Center | Overridden. Gets the centroid of the polygon shape.
Public Property | ExteriorRing | Gets the exterior ring of the polygon shape.
Public Property | InteriorRings | Gets the interior rings of the polygon shape.
Public Property | Is3D | Overridden. Gets a value indicating whether any ring in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the exterior ring is null or empty.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any ring in the collection has m-coordinate values.
Public Property | PointsCount | Overridden. Gets the sum of the points count of all rings.
Public Property | Rings | Gets the polygon rings.
Top

See Also

Reference

GeoPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolygon Constructor

[image]
ActiveReports 19 .NET Edition
GeoPolygon Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : GeoPolygon Constructor

rings
The polygon rings.

Glossary Item Box

Initializes new instance of GeoPolygon.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rings As IEnumerable(Of GeoLinearRing) _
)
C#
public GeoPolygon(
   IEnumerable<GeoLinearRing> rings
)

Parameters

rings
The polygon rings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


GeoPolygon Class Properties

[image]
ActiveReports 19 .NET Edition
GeoPolygon Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class

Glossary Item Box

For a list of all members of this type, see GeoPolygon members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the polygon shape.
Public Property | Center | Overridden. Gets the centroid of the polygon shape.
Public Property | ExteriorRing | Gets the exterior ring of the polygon shape.
Public Property | InteriorRings | Gets the interior rings of the polygon shape.
Public Property | Is3D | Overridden. Gets a value indicating whether any ring in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the exterior ring is null or empty.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any ring in the collection has m-coordinate values.
Public Property | PointsCount | Overridden. Gets the sum of the points count of all rings.
Public Property | Rings | Gets the polygon rings.
Top

See Also

Reference

GeoPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Bounds Property

Glossary Item Box

Gets the bounds of the polygon shape.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the polygon shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


Center Property

[image]
ActiveReports 19 .NET Edition
Center Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Center Property

Glossary Item Box

Gets the centroid of the polygon shape.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Center As PointF
C#
public override PointF Center {get;}

Property Value

A System.Drawing.PointF representing the centroid of the polygon shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


ExteriorRing Property

[image]
ActiveReports 19 .NET Edition
ExteriorRing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : ExteriorRing Property

Glossary Item Box

Gets the exterior ring of the polygon shape.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExteriorRing As GeoLinearRing
C#
public GeoLinearRing ExteriorRing {get;}

Property Value

The exterior ring as a GeoLinearRing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


InteriorRings Property

[image]
ActiveReports 19 .NET Edition
InteriorRings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : InteriorRings Property

Glossary Item Box

Gets the interior rings of the polygon shape.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InteriorRings As IEnumerable(Of GeoLinearRing)
C#
public IEnumerable<GeoLinearRing> InteriorRings {get;}

Property Value

An IEnumerable representing the interior rings of the polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Is3D Property

Glossary Item Box

Gets a value indicating whether any ring in the collection has z-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Is3D As Boolean
C#
public override bool Is3D {get;}

Property Value

true if any ring has z-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the exterior ring is null or empty.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

true if the exterior ring is null or empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : IsMeasured Property

Glossary Item Box

Gets a value indicating whether any ring in the collection has m-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsMeasured As Boolean
C#
public override bool IsMeasured {get;}

Property Value

true if any ring has m-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : PointsCount Property

Glossary Item Box

Gets the sum of the points count of all rings.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PointsCount As Integer
C#
public override int PointsCount {get;}

Property Value

The total number of points in the polygon as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


Rings Property

[image]
ActiveReports 19 .NET Edition
Rings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Rings Property

Glossary Item Box

Gets the polygon rings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rings As IEnumerable(Of GeoLinearRing)
C#
public IEnumerable<GeoLinearRing> Rings {get;}

Property Value

An IEnumerable representing the rings of the polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolygon Class
GeoPolygon Members


GeoPolyhedralSurface Class

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class

Glossary Item Box

Represents the geospatial polyhedral surface.

Object Model

GeoPolyhedralSurface Class

Syntax

Visual Basic (Declaration)
Public Class GeoPolyhedralSurface
   Inherits GeoSurface
C#
public class GeoPolyhedralSurface : GeoSurface

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolyhedralSurface Class Members

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class

Glossary Item Box

The following tables list the members exposed by GeoPolyhedralSurface.

Public Constructors

 | Name | Description
Public Constructor | GeoPolyhedralSurface Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the polyhedral surface.
Public Property | Is3D | Overridden. Gets a value indicating whether any polygon in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the collection is empty or all polygons in the collection are empty geometry.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any polygon in the collection has m-coordinate values.
Public Property | PointsCount | Overridden. Gets the sum of the points count of all polygons.
Public Property | Polygons | Gets the surface polygons.
Top

See Also

Reference

GeoPolyhedralSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolyhedralSurface Constructor

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : GeoPolyhedralSurface Constructor

Glossary Item Box

Overload List

Overload | Description
GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>) | Initializes a new instance of the GeoPolyhedralSurface class.
GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>) | Initializes a new instance of the GeoPolyhedralSurface class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class > GeoPolyhedralSurface Constructor : GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)

type
The type.
polygons
The polygons.

Glossary Item Box

Initializes a new instance of the GeoPolyhedralSurface class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As GeometryType, _
   ByVal polygons As IEnumerable(Of GeoPolygon) _
)
C#
public GeoPolyhedralSurface(
   GeometryType type,
   IEnumerable<GeoPolygon> polygons
)

Parameters

type
The type.
polygons
The polygons.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when polygons is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members
Overload List


GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class > GeoPolyhedralSurface Constructor : GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)

polygons
The polygons.

Glossary Item Box

Initializes a new instance of the GeoPolyhedralSurface class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal polygons As IEnumerable(Of GeoPolygon) _
)
C#
public GeoPolyhedralSurface(
   IEnumerable<GeoPolygon> polygons
)

Parameters

polygons
The polygons.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members
Overload List


GeoPolyhedralSurface Class Properties

[image]
ActiveReports 19 .NET Edition
GeoPolyhedralSurface Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class

Glossary Item Box

For a list of all members of this type, see GeoPolyhedralSurface members.

Public Properties

 | Name | Description
Public Property | Bounds | Overridden. Gets the bounds of the polyhedral surface.
Public Property | Is3D | Overridden. Gets a value indicating whether any polygon in the collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Gets a value indicating whether the collection is empty or all polygons in the collection are empty geometry.
Public Property | IsMeasured | Overridden. Gets a value indicating whether any polygon in the collection has m-coordinate values.
Public Property | PointsCount | Overridden. Gets the sum of the points count of all polygons.
Public Property | Polygons | Gets the surface polygons.
Top

See Also

Reference

GeoPolyhedralSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Bounds Property

Glossary Item Box

Gets the bounds of the polyhedral surface.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Bounds As RectangleF
C#
public override RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the polyhedral surface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Is3D Property

Glossary Item Box

Gets a value indicating whether any polygon in the collection has z-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Is3D As Boolean
C#
public override bool Is3D {get;}

Property Value

true if any polygon has z-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the collection is empty or all polygons in the collection are empty geometry.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
C#
public override bool IsEmpty {get;}

Property Value

true if the collection is empty or all polygons are empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : IsMeasured Property

Glossary Item Box

Gets a value indicating whether any polygon in the collection has m-coordinate values.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsMeasured As Boolean
C#
public override bool IsMeasured {get;}

Property Value

true if any polygon has m-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : PointsCount Property

Glossary Item Box

Gets the sum of the points count of all polygons.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PointsCount As Integer
C#
public override int PointsCount {get;}

Property Value

The total number of points in the polyhedral surface as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


Polygons Property

[image]
ActiveReports 19 .NET Edition
Polygons Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Polygons Property

Glossary Item Box

Gets the surface polygons.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Polygons As IEnumerable(Of GeoPolygon)
C#
public IEnumerable<GeoPolygon> Polygons {get;}

Property Value

An IEnumerable representing the polygons of the polyhedral surface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


GeoShape Class

[image]
ActiveReports 19 .NET Edition
GeoShape Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class

Glossary Item Box

Represents the geospatial shape base class.

Object Model

GeoShape Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GeoShape
C#
public abstract class GeoShape

Remarks

Based on Open Geospatial Consortium Simple Feature Access v1.2.1 spec (http://www.opengeospatial.org/standards/sfa).

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoShape Class Members

[image]
ActiveReports 19 .NET Edition
GeoShape Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class

Glossary Item Box

The following tables list the members exposed by GeoShape.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the shape.
Public Property | Center | Gets the centroid of the shape.
Public Property | Is3D | Gets a value indicating whether the shape has z-coordinate values.
Public Property | IsEmpty | Gets a value indicating whether the shape is empty geometry.
Public Property | IsMeasured | Gets a value indicating whether the shape has m-coordinate values.
Public Property | PointsCount | Gets the number of points used in the shape.
Public Property | Type | Gets the geometry type.
Top

See Also

Reference

GeoShape Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoShape Class Properties

[image]
ActiveReports 19 .NET Edition
GeoShape Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class

Glossary Item Box

For a list of all members of this type, see GeoShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets the bounds of the shape.
Public Property | Center | Gets the centroid of the shape.
Public Property | Is3D | Gets a value indicating whether the shape has z-coordinate values.
Public Property | IsEmpty | Gets a value indicating whether the shape is empty geometry.
Public Property | IsMeasured | Gets a value indicating whether the shape has m-coordinate values.
Public Property | PointsCount | Gets the number of points used in the shape.
Public Property | Type | Gets the geometry type.
Top

See Also

Reference

GeoShape Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property

[image]
ActiveReports 19 .NET Edition
Bounds Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Bounds Property

Glossary Item Box

Gets the bounds of the shape.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Bounds As RectangleF
C#
public virtual RectangleF Bounds {get;}

Property Value

A System.Drawing.RectangleF representing the bounds of the shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


Center Property

[image]
ActiveReports 19 .NET Edition
Center Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Center Property

Glossary Item Box

Gets the centroid of the shape.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Center As PointF
C#
public virtual PointF Center {get;}

Property Value

A System.Drawing.PointF representing the centroid of the shape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


Is3D Property

[image]
ActiveReports 19 .NET Edition
Is3D Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Is3D Property

Glossary Item Box

Gets a value indicating whether the shape has z-coordinate values.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Is3D As Boolean
C#
public abstract bool Is3D {get;}

Property Value

true if the shape has z-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the shape is empty geometry.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsEmpty As Boolean
C#
public abstract bool IsEmpty {get;}

Property Value

true if the shape is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


IsMeasured Property

[image]
ActiveReports 19 .NET Edition
IsMeasured Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : IsMeasured Property

Glossary Item Box

Gets a value indicating whether the shape has m-coordinate values.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsMeasured As Boolean
C#
public abstract bool IsMeasured {get;}

Property Value

true if the shape has m-coordinate values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


PointsCount Property

[image]
ActiveReports 19 .NET Edition
PointsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : PointsCount Property

Glossary Item Box

Gets the number of points used in the shape.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PointsCount As Integer
C#
public abstract int PointsCount {get;}

Property Value

The number of points in the shape as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Type Property

Glossary Item Box

Gets the geometry type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As GeometryType
C#
public GeometryType Type {get;}

Property Value

The type of geometry as a GeometryType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoShape Class
GeoShape Members


GeoSurface Class

[image]
ActiveReports 19 .NET Edition
GeoSurface Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoSurface Class

Glossary Item Box

Represents the base class for geospatial surface.

Object Model

GeoSurface Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GeoSurface
   Inherits GeoShape
C#
public abstract class GeoSurface : GeoShape

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoSurface Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoSurface Class Members

[image]
ActiveReports 19 .NET Edition
GeoSurface Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoSurface Class

Glossary Item Box

The following tables list the members exposed by GeoSurface.

See Also

Reference

GeoSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Class

[image]
ActiveReports 19 .NET Edition
GeoTin Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class

Glossary Item Box

Represents the geospatial triangulated irregular network.

Object Model

GeoTin Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoTin
   Inherits GeoPolyhedralSurface
C#
public sealed class GeoTin : GeoPolyhedralSurface

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoTin Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Class Members

[image]
ActiveReports 19 .NET Edition
GeoTin Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class

Glossary Item Box

The following tables list the members exposed by GeoTin.

Public Constructors

 | Name | Description
Public Constructor | GeoTin Constructor | Initializes a new instance of the GeoTin class.
Top

Public Properties

 | Name | Description
Public Property | Triangles | Gets the TIN triangles.
Top

See Also

Reference

GeoTin Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Constructor

[image]
ActiveReports 19 .NET Edition
GeoTin Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTin Class : GeoTin Constructor

triangles
The triangles.

Glossary Item Box

Initializes a new instance of the GeoTin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal triangles As IEnumerable(Of GeoTriangle) _
)
C#
public GeoTin(
   IEnumerable<GeoTriangle> triangles
)

Parameters

triangles
The triangles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoTin Class
GeoTin Members


GeoTin Class Properties

[image]
ActiveReports 19 .NET Edition
GeoTin Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class

Glossary Item Box

For a list of all members of this type, see GeoTin members.

Public Properties

 | Name | Description
Public Property | Triangles | Gets the TIN triangles.
Top

See Also

Reference

GeoTin Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Triangles Property

[image]
ActiveReports 19 .NET Edition
Triangles Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTin Class : Triangles Property

Glossary Item Box

Gets the TIN triangles.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Triangles As IEnumerable(Of GeoTriangle)
C#
public IEnumerable<GeoTriangle> Triangles {get;}

Property Value

An IEnumerable representing the triangles of the TIN.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoTin Class
GeoTin Members


GeoTriangle Class

[image]
ActiveReports 19 .NET Edition
GeoTriangle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTriangle Class

Glossary Item Box

Represents the geospatial triangle shape.

Object Model

GeoTriangle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GeoTriangle
   Inherits GeoPolygon
C#
public sealed class GeoTriangle : GeoPolygon

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTriangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoTriangle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTriangle Class Members

[image]
ActiveReports 19 .NET Edition
GeoTriangle Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTriangle Class

Glossary Item Box

The following tables list the members exposed by GeoTriangle.

Public Constructors

 | Name | Description
Public Constructor | GeoTriangle Constructor | Initializes new instance of GeoTriangle.
Top

See Also

Reference

GeoTriangle Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTriangle Constructor

[image]
ActiveReports 19 .NET Edition
GeoTriangle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTriangle Class : GeoTriangle Constructor

rings
The triangle rings.

Glossary Item Box

Initializes new instance of GeoTriangle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rings As IEnumerable(Of GeoLinearRing) _
)
C#
public GeoTriangle(
   IEnumerable<GeoLinearRing> rings
)

Parameters

rings
The triangle rings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GeoTriangle Class
GeoTriangle Members


ShapePoint Class

[image]
ActiveReports 19 .NET Edition
ShapePoint Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class

Glossary Item Box

Represents the 2D point.

Object Model

ShapePoint Class

Syntax

Visual Basic (Declaration)
Public Class ShapePoint
C#
public class ShapePoint

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointM
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZ
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZM

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePoint Class Members

[image]
ActiveReports 19 .NET Edition
ShapePoint Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class

Glossary Item Box

The following tables list the members exposed by ShapePoint.

Public Constructors

 | Name | Description
Public Constructor | ShapePoint Constructor | Initializes new instance of ShapePoint.
Top

Public Properties

 | Name | Description
Public Property | X | Gets the X coordinate.
Public Property | Y | Gets the Y coordinate.
Top

See Also

Reference

ShapePoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePoint Constructor

[image]
ActiveReports 19 .NET Edition
ShapePoint Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : ShapePoint Constructor

x
The x coordinate value.
y
The y coordinate value.

Glossary Item Box

Initializes new instance of ShapePoint.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
C#
public ShapePoint(
   double x,
   double y
)

Parameters

x
The x coordinate value.
y
The y coordinate value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePoint Class
ShapePoint Members


ShapePoint Class Properties

[image]
ActiveReports 19 .NET Edition
ShapePoint Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class

Glossary Item Box

For a list of all members of this type, see ShapePoint members.

Public Properties

 | Name | Description
Public Property | X | Gets the X coordinate.
Public Property | Y | Gets the Y coordinate.
Top

See Also

Reference

ShapePoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : X Property

Glossary Item Box

Gets the X coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Double
C#
public double X {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePoint Class
ShapePoint Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : Y Property

Glossary Item Box

Gets the Y coordinate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Double
C#
public double Y {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePoint Class
ShapePoint Members


ShapePointM Class

[image]
ActiveReports 19 .NET Edition
ShapePointM Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class

Glossary Item Box

Represents 2D point with M value.

Object Model

ShapePointM Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ShapePointM
   Inherits ShapePoint
C#
public sealed class ShapePointM : ShapePoint

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointM

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointM Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointM Class Members

[image]
ActiveReports 19 .NET Edition
ShapePointM Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class

Glossary Item Box

The following tables list the members exposed by ShapePointM.

Public Constructors

 | Name | Description
Public Constructor | ShapePointM Constructor | Initializes new instance of ShapePointM.
Top

Public Properties

 | Name | Description
Public Property | M | Gets the M value.
Top

See Also

Reference

ShapePointM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointM Constructor

[image]
ActiveReports 19 .NET Edition
ShapePointM Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointM Class : ShapePointM Constructor

x
The x coordinate value.
y
The y coordinate value.
m
The m value.

Glossary Item Box

Initializes new instance of ShapePointM.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal m As Double _
)
C#
public ShapePointM(
   double x,
   double y,
   double m
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
m
The m value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointM Class
ShapePointM Members


ShapePointM Class Properties

[image]
ActiveReports 19 .NET Edition
ShapePointM Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class

Glossary Item Box

For a list of all members of this type, see ShapePointM members.

Public Properties

 | Name | Description
Public Property | M | Gets the M value.
Top

See Also

Reference

ShapePointM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


M Property

[image]
ActiveReports 19 .NET Edition
M Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointM Class : M Property

Glossary Item Box

Gets the M value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property M As Double
C#
public double M {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointM Class
ShapePointM Members


ShapePointZ Class

[image]
ActiveReports 19 .NET Edition
ShapePointZ Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class

Glossary Item Box

Represents the 3D point.

Object Model

ShapePointZ Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ShapePointZ
   Inherits ShapePoint
C#
public sealed class ShapePointZ : ShapePoint

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZ

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZ Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZ Class Members

[image]
ActiveReports 19 .NET Edition
ShapePointZ Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class

Glossary Item Box

The following tables list the members exposed by ShapePointZ.

Public Constructors

 | Name | Description
Public Constructor | ShapePointZ Constructor | Initializes new instance of ShapePointZ
Top

Public Properties

 | Name | Description
Public Property | Z | Gets the Z coordinate value.
Top

See Also

Reference

ShapePointZ Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZ Constructor

[image]
ActiveReports 19 .NET Edition
ShapePointZ Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZ Class : ShapePointZ Constructor

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.

Glossary Item Box

Initializes new instance of ShapePointZ

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal z As Double _
)
C#
public ShapePointZ(
   double x,
   double y,
   double z
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZ Class
ShapePointZ Members


ShapePointZ Class Properties

[image]
ActiveReports 19 .NET Edition
ShapePointZ Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class

Glossary Item Box

For a list of all members of this type, see ShapePointZ members.

Public Properties

 | Name | Description
Public Property | Z | Gets the Z coordinate value.
Top

See Also

Reference

ShapePointZ Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Z Property

[image]
ActiveReports 19 .NET Edition
Z Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZ Class : Z Property

Glossary Item Box

Gets the Z coordinate value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Z As Double
C#
public double Z {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZ Class
ShapePointZ Members


ShapePointZM Class

[image]
ActiveReports 19 .NET Edition
ShapePointZM Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class

Glossary Item Box

Represents the 3D point with M value.

Object Model

ShapePointZM Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ShapePointZM
   Inherits ShapePoint
C#
public sealed class ShapePointZM : ShapePoint

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZM

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZM Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZM Class Members

[image]
ActiveReports 19 .NET Edition
ShapePointZM Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class

Glossary Item Box

The following tables list the members exposed by ShapePointZM.

Public Constructors

 | Name | Description
Public Constructor | ShapePointZM Constructor | Initializes new instance of ShapePointZM.
Top

Public Properties

 | Name | Description
Public Property | M | Gets the M value.
Public Property | Z | Gets the Z coordinate value.
Top

See Also

Reference

ShapePointZM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZM Constructor

[image]
ActiveReports 19 .NET Edition
ShapePointZM Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : ShapePointZM Constructor

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.
m
The m value.

Glossary Item Box

Initializes new instance of ShapePointZM.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal z As Double, _
   ByVal m As Double _
)
C#
public ShapePointZM(
   double x,
   double y,
   double z,
   double m
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.
m
The m value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZM Class
ShapePointZM Members


ShapePointZM Class Properties

[image]
ActiveReports 19 .NET Edition
ShapePointZM Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class

Glossary Item Box

For a list of all members of this type, see ShapePointZM members.

Public Properties

 | Name | Description
Public Property | M | Gets the M value.
Public Property | Z | Gets the Z coordinate value.
Top

See Also

Reference

ShapePointZM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


M Property

[image]
ActiveReports 19 .NET Edition
M Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : M Property

Glossary Item Box

Gets the M value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property M As Double
C#
public double M {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZM Class
ShapePointZM Members


Z Property

[image]
ActiveReports 19 .NET Edition
Z Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : Z Property

Glossary Item Box

Gets the Z coordinate value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Z As Double
C#
public double Z {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapePointZM Class
ShapePointZM Members


GeometryType Enumeration

[image]
ActiveReports 19 .NET Edition
GeometryType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeometryType Enumeration

Glossary Item Box

Specifies the geometry types according to OGC Simple Access specification.

Syntax

Visual Basic (Declaration)
Public Enum GeometryType
   Inherits System.Enum
C#
public enum GeometryType : System.Enum

Members

Member | Description
CircularString | The CircularString is the basic curve type, similar to a LINESTRING in the linear world. A single segment required three points, the start and end points (first and third) and any other point on the arc.
CompoundCurve | A compound curve is a single, continuous curve that has both curved (circular) segments and linear segments.
Curve | 1-dimensional geometric object usually stored as a sequence of Points.
CurvePolygon | A CurvePolygon is just like a polygon, with an outer ring and zero or more inner rings. The difference is that a ring can take the form of a circular string, linear string or compound string.
GeometryCollection | Geometric object that is a collection of some number of geometric objects.
LineString | Curve with linear interpolation between Points.
MultiCurve | 1-dimensional GeometryCollection whose elements are Curves.
MultiLineString | MultiCurve whose elements are LineStrings.
MultiPoint | 0-dimensional GeometryCollection.
MultiPolygon | MultiSurface whose elements are Polygons.
MultiSurface | 2-dimensional GeometryCollection whose elements are Surfaces.
Point | 0-dimensional geometric object and represents a single location in coordinate space.
Polygon | Planar Surface defined by 1 exterior boundary and 0 or more interior boundaries.
PolyhedralSurface | Contiguous collection of Polygons, which share common boundary segments.
Surface | 2-dimensional geometric object.
Tin | Contiguous collection of Triangles, which share common boundary segments.
Triangle | Special tringle Polygon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeometryType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


MatrixGroupingDefinition Class

[image]
ActiveReports 19 .NET Edition
MatrixGroupingDefinition Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class

Glossary Item Box

Represents a matrix data grouping definition.

Object Model

MatrixGroupingDefinition Class

Syntax

Visual Basic (Declaration)
Public Class MatrixGroupingDefinition
C#
public class MatrixGroupingDefinition

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix.MatrixGroupingDefinition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


MatrixGroupingDefinition Class Members

[image]
ActiveReports 19 .NET Edition
MatrixGroupingDefinition Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class

Glossary Item Box

The following tables list the members exposed by MatrixGroupingDefinition.

Public Constructors

 | Name | Description
Public Constructor | MatrixGroupingDefinition Constructor | Initializes a new instance of the MatrixGroupingDefinition class.
Top

Public Fields

 | Name | Description
Public Field | HasTotal | Gets a value indicating whether the grouping has a total.
Public Field | IsStatic | Gets a value indicating whether this is a static grouping.
Public Field | Length | Gets the length of the grouping.
Public Field | ToggleItem | Gets the grouping toggle item name.
Top

See Also

Reference

MatrixGroupingDefinition Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


MatrixGroupingDefinition Constructor

[image]
ActiveReports 19 .NET Edition
MatrixGroupingDefinition Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : MatrixGroupingDefinition Constructor

length
The length of the grouping.
isStatic
Indicates if this is a static grouping.
hasTotal
Indicates whether the grouping has a total.
toggleItem
The grouping toggle item name.

Glossary Item Box

Initializes a new instance of the MatrixGroupingDefinition class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Length, _
   ByVal isStatic As Boolean, _
   ByVal hasTotal As Boolean, _
   ByVal toggleItem As String _
)
C#
public MatrixGroupingDefinition(
   Length length,
   bool isStatic,
   bool hasTotal,
   string toggleItem
)

Parameters

length
The length of the grouping.
isStatic
Indicates if this is a static grouping.
hasTotal
Indicates whether the grouping has a total.
toggleItem
The grouping toggle item name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


MatrixGroupingDefinition Class Fields

[image]
ActiveReports 19 .NET Edition
MatrixGroupingDefinition Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class

Glossary Item Box

For a list of all members of this type, see MatrixGroupingDefinition members.

Public Fields

 | Name | Description
Public Field | HasTotal | Gets a value indicating whether the grouping has a total.
Public Field | IsStatic | Gets a value indicating whether this is a static grouping.
Public Field | Length | Gets the length of the grouping.
Public Field | ToggleItem | Gets the grouping toggle item name.
Top

See Also

Reference

MatrixGroupingDefinition Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


HasTotal Field

[image]
ActiveReports 19 .NET Edition
HasTotal Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : HasTotal Field

Glossary Item Box

Gets a value indicating whether the grouping has a total.

Syntax

Visual Basic (Declaration)
Public ReadOnly HasTotal As Boolean
C#
public readonly bool HasTotal

Field Value

A System.Boolean value indicating whether the grouping has a total.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


IsStatic Field

[image]
ActiveReports 19 .NET Edition
IsStatic Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : IsStatic Field

Glossary Item Box

Gets a value indicating whether this is a static grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly IsStatic As Boolean
C#
public readonly bool IsStatic

Field Value

A System.Boolean value indicating whether this is a static grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : Length Field

Glossary Item Box

Gets the length of the grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Length As Length
C#
public readonly Length Length

Field Value

A Length representing the length of the grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


ToggleItem Field

[image]
ActiveReports 19 .NET Edition
ToggleItem Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : ToggleItem Field

Glossary Item Box

Gets the grouping toggle item name.

Syntax

Visual Basic (Declaration)
Public ReadOnly ToggleItem As String
C#
public readonly string ToggleItem

Field Value

A System.String representing the name of the grouping toggle item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


IMatrix Interface

[image]
ActiveReports 19 .NET Edition
IMatrix Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

Glossary Item Box

Represents an interface for the Matrix object.

Syntax

Visual Basic (Declaration)
Public Interface IMatrix
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
C#
public interface IMatrix : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrix Interface Members

[image]
ActiveReports 19 .NET Edition
IMatrix Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

Glossary Item Box

The following tables list the members exposed by IMatrix.

Public Properties

 | Name | Description
Property | CellCollection | Gets the cells in the matrix.
Property | CellColumns | Gets the number of columns in the CellCollection.
Property | CellHeights | Gets the height of each renderable row in the matrix.
Property | CellRows | Gets the number of rows in the CellCollection.
Property | CellsBeforeRowHeaders | Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).
Property | CellWidths | Gets the width of each renderable column in the matrix.
Property | ColumnGroupings | Gets the set of groupings on the column axis for the matrix.
Property | ColumnMemberCollection | Gets a collection of MatrixMember objects or null if there is no column grouping defined.
Property | Columns | Gets the number of columns in this matrix's definition.
Property | Corner | Gets the GrapeCity.ActiveReports.PageReportModel.ReportItem to be displayed in the upper left corner area for this Matrix instance.
Property | DataCells | Gets the collection of matrix data cells.
Property | GroupsBeforeRowHeaders | Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).
Property | LayoutDirection | Gets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Property | RowGroupings | Gets the set of groupings on the row axis for the matrix.
Property | RowMemberCollection | Gets a collection of MatrixMember objects or null if there is no row grouping defined.
Property | Rows | Gets the number of rows in this matrix's definition.
Top

See Also

Reference

IMatrix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrix Interface Properties

[image]
ActiveReports 19 .NET Edition
IMatrix Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

Glossary Item Box

For a list of all members of this type, see IMatrix members.

Public Properties

 | Name | Description
Property | CellCollection | Gets the cells in the matrix.
Property | CellColumns | Gets the number of columns in the CellCollection.
Property | CellHeights | Gets the height of each renderable row in the matrix.
Property | CellRows | Gets the number of rows in the CellCollection.
Property | CellsBeforeRowHeaders | Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).
Property | CellWidths | Gets the width of each renderable column in the matrix.
Property | ColumnGroupings | Gets the set of groupings on the column axis for the matrix.
Property | ColumnMemberCollection | Gets a collection of MatrixMember objects or null if there is no column grouping defined.
Property | Columns | Gets the number of columns in this matrix's definition.
Property | Corner | Gets the GrapeCity.ActiveReports.PageReportModel.ReportItem to be displayed in the upper left corner area for this Matrix instance.
Property | DataCells | Gets the collection of matrix data cells.
Property | GroupsBeforeRowHeaders | Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).
Property | LayoutDirection | Gets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Property | RowGroupings | Gets the set of groupings on the row axis for the matrix.
Property | RowMemberCollection | Gets a collection of MatrixMember objects or null if there is no row grouping defined.
Property | Rows | Gets the number of rows in this matrix's definition.
Top

See Also

Reference

IMatrix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


CellCollection Property

[image]
ActiveReports 19 .NET Edition
CellCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellCollection Property

Glossary Item Box

Gets the cells in the matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellCollection As IMatrixCellCollection
C#
IMatrixCellCollection CellCollection {get;}

Property Value

A collection of IMatrixCell objects representing the cells in the matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


CellColumns Property

[image]
ActiveReports 19 .NET Edition
CellColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellColumns Property

Glossary Item Box

Gets the number of columns in the CellCollection.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellColumns As Integer
C#
int CellColumns {get;}

Property Value

An integer representing the number of columns in the CellCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


CellHeights Property

[image]
ActiveReports 19 .NET Edition
CellHeights Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellHeights Property

Glossary Item Box

Gets the height of each renderable row in the matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellHeights As IList(Of Length)
C#
IList<Length> CellHeights {get;}

Property Value

A list of GrapeCity.ActiveReports.PageReportModel.Length objects representing the height of each renderable row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


CellRows Property

[image]
ActiveReports 19 .NET Edition
CellRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellRows Property

Glossary Item Box

Gets the number of rows in the CellCollection.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellRows As Integer
C#
int CellRows {get;}

Property Value

An integer representing the number of rows in the CellCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


CellsBeforeRowHeaders Property

[image]
ActiveReports 19 .NET Edition
CellsBeforeRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellsBeforeRowHeaders Property

Glossary Item Box

Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).

Syntax

Visual Basic (Declaration)
ReadOnly Property CellsBeforeRowHeaders As Integer
C#
int CellsBeforeRowHeaders {get;}

Property Value

An System.Int32 representing the number of instances of the outermost column group before the row headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


CellWidths Property

[image]
ActiveReports 19 .NET Edition
CellWidths Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellWidths Property

Glossary Item Box

Gets the width of each renderable column in the matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellWidths As IList(Of Length)
C#
IList<Length> CellWidths {get;}

Property Value

A list of GrapeCity.ActiveReports.PageReportModel.Length objects representing the width of each renderable column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


ColumnGroupings Property

[image]
ActiveReports 19 .NET Edition
ColumnGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : ColumnGroupings Property

Glossary Item Box

Gets the set of groupings on the column axis for the matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnGroupings As IList(Of MatrixGroupingDefinition)
C#
IList<MatrixGroupingDefinition> ColumnGroupings {get;}

Property Value

A list of MatrixGroupingDefinition objects representing the groupings on the column axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


ColumnMemberCollection Property

[image]
ActiveReports 19 .NET Edition
ColumnMemberCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : ColumnMemberCollection Property

Glossary Item Box

Gets a collection of MatrixMember objects or null if there is no column grouping defined.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnMemberCollection As IItemCollection(Of IMatrixMember)
C#
IItemCollection<IMatrixMember> ColumnMemberCollection {get;}

Property Value

A collection of IMatrixMember objects representing the column groupings, or null if none are defined.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Columns Property

Glossary Item Box

Gets the number of columns in this matrix's definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property Columns As Integer
C#
int Columns {get;}

Property Value

An System.Int32 representing the number of columns in this matrix's definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


Corner Property

[image]
ActiveReports 19 .NET Edition
Corner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Corner Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.PageReportModel.ReportItem to be displayed in the upper left corner area for this Matrix instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Corner As IReportItem
C#
IReportItem Corner {get;}

Property Value

The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem to be displayed in the upper left corner area for this Matrix instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


DataCells Property

[image]
ActiveReports 19 .NET Edition
DataCells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : DataCells Property

Glossary Item Box

Gets the collection of matrix data cells.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataCells As IMatrixCellCollection
C#
IMatrixCellCollection DataCells {get;}

Property Value

A collection of IMatrixCell objects representing the data cells in the matrix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


GroupsBeforeRowHeaders Property

[image]
ActiveReports 19 .NET Edition
GroupsBeforeRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : GroupsBeforeRowHeaders Property

Glossary Item Box

Gets the number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrices).

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupsBeforeRowHeaders As Integer
C#
int GroupsBeforeRowHeaders {get;}

Property Value

An System.Int32 representing the number of instances of the outermost column group before the row headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


LayoutDirection Property

[image]
ActiveReports 19 .NET Edition
LayoutDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : LayoutDirection Property

Glossary Item Box

Gets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).

Syntax

Visual Basic (Declaration)
ReadOnly Property LayoutDirection As LayoutDirection
C#
LayoutDirection LayoutDirection {get;}

Property Value

A LayoutDirection value indicating the direction in which the matrix columns grow.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


RowGroupings Property

[image]
ActiveReports 19 .NET Edition
RowGroupings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : RowGroupings Property

Glossary Item Box

Gets the set of groupings on the row axis for the matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowGroupings As IList(Of MatrixGroupingDefinition)
C#
IList<MatrixGroupingDefinition> RowGroupings {get;}

Property Value

A list of MatrixGroupingDefinition objects representing the groupings on the row axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


RowMemberCollection Property

[image]
ActiveReports 19 .NET Edition
RowMemberCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : RowMemberCollection Property

Glossary Item Box

Gets a collection of MatrixMember objects or null if there is no row grouping defined.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowMemberCollection As IItemCollection(Of IMatrixMember)
C#
IItemCollection<IMatrixMember> RowMemberCollection {get;}

Property Value

A collection of IMatrixMember objects representing the row groupings, or null if none are defined.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Rows Property

Glossary Item Box

Gets the number of rows in this matrix's definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rows As Integer
C#
int Rows {get;}

Property Value

An System.Int32 representing the number of rows in this matrix's definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrix Interface
IMatrix Members


IMatrixCell Interface

[image]
ActiveReports 19 .NET Edition
IMatrixCell Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

Glossary Item Box

Represents the interface for the cell of a matrix.

Syntax

Visual Basic (Declaration)
Public Interface IMatrixCell
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
C#
public interface IMatrixCell : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCell Interface Members

[image]
ActiveReports 19 .NET Edition
IMatrixCell Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

Glossary Item Box

The following tables list the members exposed by IMatrixCell.

Public Properties

 | Name | Description
Property | CellLabel | Gets the cell's label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the output of the data element.
Property | Height | Gets the cell height.
Property | ReportItem | Gets the report item.
Property | Width | Gets the cell width.
Top

See Also

Reference

IMatrixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCell Interface Properties

[image]
ActiveReports 19 .NET Edition
IMatrixCell Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

Glossary Item Box

For a list of all members of this type, see IMatrixCell members.

Public Properties

 | Name | Description
Property | CellLabel | Gets the cell's label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the output of the data element.
Property | Height | Gets the cell height.
Property | ReportItem | Gets the report item.
Property | Width | Gets the cell width.
Top

See Also

Reference

IMatrixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


CellLabel Property

[image]
ActiveReports 19 .NET Edition
CellLabel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : CellLabel Property

Glossary Item Box

Gets the cell's label.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellLabel As String
C#
string CellLabel {get;}

Property Value

A System.String representing the label of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : DataElementName Property

Glossary Item Box

Gets the name of the data element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name of the data element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : DataElementOutput Property

Glossary Item Box

Gets the output of the data element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value representing the output of the data element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : Height Property

Glossary Item Box

Gets the cell height.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the height of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : ReportItem Property

Glossary Item Box

Gets the report item.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem representing the report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : Width Property

Glossary Item Box

Gets the cell width.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCell Interface
IMatrixCell Members


IMatrixCellCollection Interface

[image]
ActiveReports 19 .NET Edition
IMatrixCellCollection Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface

Glossary Item Box

Represents an interface for a collection of matrix cell objects.

Syntax

Visual Basic (Declaration)
Public Interface IMatrixCellCollection
C#
public interface IMatrixCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCellCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCellCollection Interface Members

[image]
ActiveReports 19 .NET Edition
IMatrixCellCollection Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface

Glossary Item Box

The following tables list the members exposed by IMatrixCellCollection.

Public Properties

 | Name | Description
Property | ColumnCount | Gets the count of the number of columns rendered.
Property | Count | Gets the count of the number of cells rendered.
Property | Item | Gets the matrix cell by the specified row and column index.
Property | RowCount | Gets the count of the number of rows rendered.
Top

See Also

Reference

IMatrixCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCellCollection Interface Properties

[image]
ActiveReports 19 .NET Edition
IMatrixCellCollection Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface

Glossary Item Box

For a list of all members of this type, see IMatrixCellCollection members.

Public Properties

 | Name | Description
Property | ColumnCount | Gets the count of the number of columns rendered.
Property | Count | Gets the count of the number of cells rendered.
Property | Item | Gets the matrix cell by the specified row and column index.
Property | RowCount | Gets the count of the number of rows rendered.
Top

See Also

Reference

IMatrixCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


ColumnCount Property

[image]
ActiveReports 19 .NET Edition
ColumnCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : ColumnCount Property

Glossary Item Box

Gets the count of the number of columns rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnCount As Integer
C#
int ColumnCount {get;}

Property Value

An System.Int32 representing the number of columns rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : Count Property

Glossary Item Box

Gets the count of the number of cells rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Property Value

An System.Int32 representing the total number of cells rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : Item Property

row
The row index of the matrix cell.
column
The column index of the matrix cell.

Glossary Item Box

Gets the matrix cell by the specified row and column index.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As IMatrixCell
C#
IMatrixCell this[
   int row,
   int column
]; {get;}

Parameters

row
The row index of the matrix cell.
column
The column index of the matrix cell.

Property Value

The IMatrixCell at the specified row and column index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


RowCount Property

[image]
ActiveReports 19 .NET Edition
RowCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : RowCount Property

Glossary Item Box

Gets the count of the number of rows rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCount As Integer
C#
int RowCount {get;}

Property Value

An System.Int32 representing the number of rows rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


IMatrixMember Interface

[image]
ActiveReports 19 .NET Edition
IMatrixMember Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface

Glossary Item Box

Represents the interface for a matrix member.

Syntax

Visual Basic (Declaration)
Public Interface IMatrixMember
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
C#
public interface IMatrixMember : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMember Interface Members

[image]
ActiveReports 19 .NET Edition
IMatrixMember Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface

Glossary Item Box

The following tables list the members exposed by IMatrixMember.

Public Properties

 | Name | Description
Property | AllChildren | Gets all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.
Property | Children | Gets the collection of child group members for the inner hierarchy or null if this member is the innermost leaf grouping.
Property | ColumnSpan | Gets the number of columns this member's heading spans.
Property | DataMemberId | Gets the id of the data member.
Property | GroupingIndex | Gets a grouping index.
Property | Height | Gets the height of this member from the report definition.
Property | IsStatic | Gets a value indicating whether this is a member of a static grouping.
Property | IsTotal | Gets a value indicating whether this is a subtotal member.
Property | MemberCellIndex | Gets the index into the CellCollection for this member's axis.
Property | Parent | Gets the parent group of this group member or null if this is the outermost group.
Property | ReportItem | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem displayed in the header area.
Property | RowSpan | Gets the number of rows this member's heading spans.
Property | StaticIndex | Gets the index of this member within its static grouping.
Property | Width | Gets the width of this member from the report definition.
Top

See Also

Reference

IMatrixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMember Interface Properties

[image]
ActiveReports 19 .NET Edition
IMatrixMember Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface

Glossary Item Box

For a list of all members of this type, see IMatrixMember members.

Public Properties

 | Name | Description
Property | AllChildren | Gets all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.
Property | Children | Gets the collection of child group members for the inner hierarchy or null if this member is the innermost leaf grouping.
Property | ColumnSpan | Gets the number of columns this member's heading spans.
Property | DataMemberId | Gets the id of the data member.
Property | GroupingIndex | Gets a grouping index.
Property | Height | Gets the height of this member from the report definition.
Property | IsStatic | Gets a value indicating whether this is a member of a static grouping.
Property | IsTotal | Gets a value indicating whether this is a subtotal member.
Property | MemberCellIndex | Gets the index into the CellCollection for this member's axis.
Property | Parent | Gets the parent group of this group member or null if this is the outermost group.
Property | ReportItem | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem displayed in the header area.
Property | RowSpan | Gets the number of rows this member's heading spans.
Property | StaticIndex | Gets the index of this member within its static grouping.
Property | Width | Gets the width of this member from the report definition.
Top

See Also

Reference

IMatrixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


AllChildren Property

[image]
ActiveReports 19 .NET Edition
AllChildren Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : AllChildren Property

Glossary Item Box

Gets all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.

Syntax

Visual Basic (Declaration)
ReadOnly Property AllChildren As IItemCollection(Of IMatrixMember)
C#
IItemCollection<IMatrixMember> AllChildren {get;}

Property Value

A collection of all child IMatrixMember objects, including subtotals and hidden members.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Children Property

Glossary Item Box

Gets the collection of child group members for the inner hierarchy or null if this member is the innermost leaf grouping.

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IItemCollection(Of IMatrixMember)
C#
IItemCollection<IMatrixMember> Children {get;}

Property Value

A collection of child IMatrixMember objects, or null if this is the innermost leaf grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


ColumnSpan Property

[image]
ActiveReports 19 .NET Edition
ColumnSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : ColumnSpan Property

Glossary Item Box

Gets the number of columns this member's heading spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnSpan As Integer
C#
int ColumnSpan {get;}

Property Value

An System.Int32 representing the number of columns this member's heading spans.

Remarks

Only valid if this is a member of a grouping on the row axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


DataMemberId Property

[image]
ActiveReports 19 .NET Edition
DataMemberId Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : DataMemberId Property

Glossary Item Box

Gets the id of the data member.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMemberId As Integer
C#
int DataMemberId {get;}

Property Value

An System.Int32 representing the id of the data member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


GroupingIndex Property

[image]
ActiveReports 19 .NET Edition
GroupingIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : GroupingIndex Property

Glossary Item Box

Gets a grouping index.

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupingIndex As Integer
C#
int GroupingIndex {get;}

Property Value

An System.Int32 representing a grouping index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Height Property

Glossary Item Box

Gets the height of this member from the report definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value specifying the height of this member.

Remarks

Only valid for members of a grouping on the column axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : IsStatic Property

Glossary Item Box

Gets a value indicating whether this is a member of a static grouping.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Property Value

A System.Boolean value indicating whether this is a member of a static grouping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


IsTotal Property

[image]
ActiveReports 19 .NET Edition
IsTotal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : IsTotal Property

Glossary Item Box

Gets a value indicating whether this is a subtotal member.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTotal As Boolean
C#
bool IsTotal {get;}

Property Value

A System.Boolean value indicating whether this is a subtotal member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


MemberCellIndex Property

[image]
ActiveReports 19 .NET Edition
MemberCellIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : MemberCellIndex Property

Glossary Item Box

Gets the index into the CellCollection for this member's axis.

Syntax

Visual Basic (Declaration)
ReadOnly Property MemberCellIndex As Integer
C#
int MemberCellIndex {get;}

Property Value

An System.Int32 representing the index into the CellCollection for this member's axis.

Remarks

If this member is on the column axis, MemberCellIndex is a cell column index. If this member is on the row axis, MemberCellIndex is a cell row index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Parent Property

[image]
ActiveReports 19 .NET Edition
Parent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Parent Property

Glossary Item Box

Gets the parent group of this group member or null if this is the outermost group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As IMatrixMember
C#
IMatrixMember Parent {get;}

Property Value

The parent IMatrixMember group, or null if this is the outermost group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : ReportItem Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem displayed in the header area.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Property Value

The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem displayed in the header area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : RowSpan Property

Glossary Item Box

Gets the number of rows this member's heading spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowSpan As Integer
C#
int RowSpan {get;}

Property Value

An System.Int32 representing the number of rows this member's heading spans.

Remarks

Only valid if this is a member of a grouping on the column axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


StaticIndex Property

[image]
ActiveReports 19 .NET Edition
StaticIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : StaticIndex Property

Glossary Item Box

Gets the index of this member within its static grouping.

Syntax

Visual Basic (Declaration)
ReadOnly Property StaticIndex As Integer
C#
int StaticIndex {get;}

Property Value

An System.Int32 representing the index of this member within its static grouping.

Remarks

If this member is not a member of a static grouping, then its parents will be checked. If any parent is a StaticMember, its StaticIndex value will be returned. If there are no static ancestors, then zero is returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Width Property

Glossary Item Box

Gets the width of this member from the report definition.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value specifying the width of this member.

Remarks

Only valid for members of a grouping on the row axis.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMatrixMember Interface
IMatrixMember Members


ITable Interface

[image]
ActiveReports 19 .NET Edition
ITable Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

Glossary Item Box

Represents an interface for a Table rendering component.

Syntax

Visual Basic (Declaration)
Public Interface ITable
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
C#
public interface ITable : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITable Interface Members

[image]
ActiveReports 19 .NET Edition
ITable Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

Glossary Item Box

The following tables list the members exposed by ITable.

Public Properties

 | Name | Description
Property | CanGrowHorizontally | Gets a value indicating whether the table content can grow horizontally.
Property | Columns | Gets the collection of columns for this table instance.
Property | DetailDataCollectionName | Gets the name for the collection of all instances of the table's details used by data-oriented rendering extensions.
Property | DetailDataElementName | Gets the name for each detail instance of the table used by data-oriented rendering extensions.
Property | DetailDataElementOutput | Gets the detail data element output.
Property | Details | Gets the collection of details rows for this table.
Property | Footer | Gets the table's footer.
Property | Header | Gets the table's header.
Property | NewGroupingSection | Gets a value indicating whether the grouping is in its own section.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | RepeatToFill | Gets a value indicating whether the table should fill the space with empty rows to reach its fixed height. Applicable to FPL reports only.
Property | TableGroups | Gets the collection of table groups.
Top

See Also

Reference

ITable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITable Interface Properties

[image]
ActiveReports 19 .NET Edition
ITable Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

Glossary Item Box

For a list of all members of this type, see ITable members.

Public Properties

 | Name | Description
Property | CanGrowHorizontally | Gets a value indicating whether the table content can grow horizontally.
Property | Columns | Gets the collection of columns for this table instance.
Property | DetailDataCollectionName | Gets the name for the collection of all instances of the table's details used by data-oriented rendering extensions.
Property | DetailDataElementName | Gets the name for each detail instance of the table used by data-oriented rendering extensions.
Property | DetailDataElementOutput | Gets the detail data element output.
Property | Details | Gets the collection of details rows for this table.
Property | Footer | Gets the table's footer.
Property | Header | Gets the table's header.
Property | NewGroupingSection | Gets a value indicating whether the grouping is in its own section.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | RepeatToFill | Gets a value indicating whether the table should fill the space with empty rows to reach its fixed height. Applicable to FPL reports only.
Property | TableGroups | Gets the collection of table groups.
Top

See Also

Reference

ITable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


CanGrowHorizontally Property

[image]
ActiveReports 19 .NET Edition
CanGrowHorizontally Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : CanGrowHorizontally Property

Glossary Item Box

Gets a value indicating whether the table content can grow horizontally.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanGrowHorizontally As Boolean
C#
bool CanGrowHorizontally {get;}

Property Value

A System.Boolean value. true if the table content can grow horizontally; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Columns Property

Glossary Item Box

Gets the collection of columns for this table instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Columns As IItemCollection(Of ITableColumn)
C#
IItemCollection<ITableColumn> Columns {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableColumn representing the table's columns.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


DetailDataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DetailDataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataCollectionName Property

Glossary Item Box

Gets the name for the collection of all instances of the table's details used by data-oriented rendering extensions.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataCollectionName As String
C#
string DetailDataCollectionName {get;}

Property Value

A System.String representing the name for the collection of detail instances.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


DetailDataElementName Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataElementName Property

Glossary Item Box

Gets the name for each detail instance of the table used by data-oriented rendering extensions.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataElementName As String
C#
string DetailDataElementName {get;}

Property Value

A System.String representing the name for each detail instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


DetailDataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataElementOutput Property

Glossary Item Box

Gets the detail data element output.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataElementOutput As DataElementOutput
C#
DataElementOutput DetailDataElementOutput {get;}

Property Value

An instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput indicating whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Details Property

Glossary Item Box

Gets the collection of details rows for this table.

Syntax

Visual Basic (Declaration)
ReadOnly Property Details As IItemCollection(Of ITableDetail)
C#
IItemCollection<ITableDetail> Details {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableDetail representing the table's details.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Footer Property

Glossary Item Box

Gets the table's footer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Footer As ITableHeaderFooterRows
C#
ITableHeaderFooterRows Footer {get;}

Property Value

An instance of ITableHeaderFooterRows representing the table's footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Header Property

Glossary Item Box

Gets the table's header.

Syntax

Visual Basic (Declaration)
ReadOnly Property Header As ITableHeaderFooterRows
C#
ITableHeaderFooterRows Header {get;}

Property Value

An instance of ITableHeaderFooterRows representing the table's header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


NewGroupingSection Property

[image]
ActiveReports 19 .NET Edition
NewGroupingSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : NewGroupingSection Property

Glossary Item Box

Gets a value indicating whether the grouping is in its own section.

Syntax

Visual Basic (Declaration)
ReadOnly Property NewGroupingSection As Boolean
C#
bool NewGroupingSection {get;}

Property Value

A System.Boolean value. true if the grouping is in its own section; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : PreventOrphanedFooter Property

Glossary Item Box

Gets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedFooter As Boolean
C#
bool PreventOrphanedFooter {get;}

Property Value

A System.Boolean value. true if the orphaned footer is displayed on the next page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


RepeatToFill Property

[image]
ActiveReports 19 .NET Edition
RepeatToFill Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : RepeatToFill Property

Glossary Item Box

Gets a value indicating whether the table should fill the space with empty rows to reach its fixed height. Applicable to FPL reports only.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatToFill As Boolean
C#
bool RepeatToFill {get;}

Property Value

A System.Boolean value. true if the table should fill the space with empty rows; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


TableGroups Property

[image]
ActiveReports 19 .NET Edition
TableGroups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : TableGroups Property

Glossary Item Box

Gets the collection of table groups.

Syntax

Visual Basic (Declaration)
ReadOnly Property TableGroups As IItemCollection(Of ITableGroup)
C#
IItemCollection<ITableGroup> TableGroups {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableGroup representing the table's groups.

Remarks

The instances of each of the subsequent groupings defined by the table are accessible via each group instance's ITableGroup.SubGroups property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITable Interface
ITable Members


ITableCell Interface

[image]
ActiveReports 19 .NET Edition
ITableCell Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

Glossary Item Box

Represents an interface for table cells.

Syntax

Visual Basic (Declaration)
Public Interface ITableCell
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
C#
public interface ITableCell : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCell Interface Members

[image]
ActiveReports 19 .NET Edition
ITableCell Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

Glossary Item Box

The following tables list the members exposed by ITableCell.

Public Properties

 | Name | Description
Property | AutoMerge | Gets the policy for merging nearby cells with the same content.
Property | ColSpan | Gets the number of columns that the table cell spans.
Property | RowSpan | Gets the number of rows that the table cell spans.
Top

See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCell Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableCell Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

Glossary Item Box

For a list of all members of this type, see ITableCell members.

Public Properties

 | Name | Description
Property | AutoMerge | Gets the policy for merging nearby cells with the same content.
Property | ColSpan | Gets the number of columns that the table cell spans.
Property | RowSpan | Gets the number of rows that the table cell spans.
Top

See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


AutoMerge Property

[image]
ActiveReports 19 .NET Edition
AutoMerge Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : AutoMerge Property

Glossary Item Box

Gets the policy for merging nearby cells with the same content.

Syntax

Visual Basic (Declaration)
ReadOnly Property AutoMerge As MergePolicy
C#
MergePolicy AutoMerge {get;}

Property Value

An instance of GrapeCity.ActiveReports.PageReportModel.MergePolicy representing the auto-merge policy for the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableCell Interface
ITableCell Members


ColSpan Property

[image]
ActiveReports 19 .NET Edition
ColSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : ColSpan Property

Glossary Item Box

Gets the number of columns that the table cell spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColSpan As Integer
C#
int ColSpan {get;}

Property Value

An System.Int32 representing the number of columns that the table cell spans.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableCell Interface
ITableCell Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : RowSpan Property

Glossary Item Box

Gets the number of rows that the table cell spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowSpan As Integer
C#
int RowSpan {get;}

Property Value

An System.Int32 representing the number of rows that the table cell spans.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableCell Interface
ITableCell Members


ITableColumn Interface

[image]
ActiveReports 19 .NET Edition
ITableColumn Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

Glossary Item Box

Represents an interface for a table column.

Syntax

Visual Basic (Declaration)
Public Interface ITableColumn
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public interface ITableColumn : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableColumn Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumn Interface Members

[image]
ActiveReports 19 .NET Edition
ITableColumn Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

Glossary Item Box

The following tables list the members exposed by ITableColumn.

Public Properties

 | Name | Description
Property | AutoWidth | Gets the auto width setting for the table column.
Property | Width | Gets the width of the table column.
Top

See Also

Reference

ITableColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumn Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableColumn Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

Glossary Item Box

For a list of all members of this type, see ITableColumn members.

Public Properties

 | Name | Description
Property | AutoWidth | Gets the auto width setting for the table column.
Property | Width | Gets the width of the table column.
Top

See Also

Reference

ITableColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


AutoWidth Property

[image]
ActiveReports 19 .NET Edition
AutoWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumn Interface : AutoWidth Property

Glossary Item Box

Gets the auto width setting for the table column.

Syntax

Visual Basic (Declaration)
ReadOnly Property AutoWidth As AutoWidth
C#
AutoWidth AutoWidth {get;}

Property Value

An instance of AutoWidth representing the auto width setting for the table column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableColumn Interface
ITableColumn Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumn Interface : Width Property

Glossary Item Box

Gets the width of the table column.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

An instance of GrapeCity.ActiveReports.PageReportModel.Length representing the width of the table column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableColumn Interface
ITableColumn Members


ITableDetail Interface

[image]
ActiveReports 19 .NET Edition
ITableDetail Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

Glossary Item Box

Represents an interface for a table detail object.

Syntax

Visual Basic (Declaration)
Public Interface ITableDetail
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public interface ITableDetail : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableDetail Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetail Interface Members

[image]
ActiveReports 19 .NET Edition
ITableDetail Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

Glossary Item Box

The following tables list the members exposed by ITableDetail.

Public Properties

 | Name | Description
Property | EndSection | Gets the location where the layout should continue.
Property | KeepTogether | Gets a value indicating whether the table details are kept together on a single page where possible.
Property | PageBreak | Gets the page breaking options.
Property | Rows | Gets a collection of table rows associated with this detail instance.
Top

See Also

Reference

ITableDetail Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetail Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableDetail Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

Glossary Item Box

For a list of all members of this type, see ITableDetail members.

Public Properties

 | Name | Description
Property | EndSection | Gets the location where the layout should continue.
Property | KeepTogether | Gets a value indicating whether the table details are kept together on a single page where possible.
Property | PageBreak | Gets the page breaking options.
Property | Rows | Gets a collection of table rows associated with this detail instance.
Top

See Also

Reference

ITableDetail Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : EndSection Property

Glossary Item Box

Gets the location where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An instance of EndSection representing where the layout should continue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableDetail Interface
ITableDetail Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the table details are kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepTogether As Boolean
C#
bool KeepTogether {get;}

Property Value

A System.Boolean value. true if the table details are kept together on a single page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableDetail Interface
ITableDetail Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

An instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation representing the page breaking options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableDetail Interface
ITableDetail Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : Rows Property

Glossary Item Box

Gets a collection of table rows associated with this detail instance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rows As IItemCollection(Of ITableRow)
C#
IItemCollection<ITableRow> Rows {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableRow representing the rows associated with this detail instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableDetail Interface
ITableDetail Members


ITableGroup Interface

[image]
ActiveReports 19 .NET Edition
ITableGroup Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

Glossary Item Box

Represents an interface for table group objects.

Syntax

Visual Basic (Declaration)
Public Interface ITableGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public interface ITableGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroup Interface Members

[image]
ActiveReports 19 .NET Edition
ITableGroup Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

Glossary Item Box

The following tables list the members exposed by ITableGroup.

Public Properties

 | Name | Description
Property | DataCollectionName | Gets the name of the table group element.
Property | DataElementName | Gets the name of this group instance element.
Property | DetailDataCollectionName | Gets the name that data-oriented rendering extensions should use for the collection of all instances of the table's details.
Property | DetailDataElementName | Gets the name that data-oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Gets a value indicating whether the details should appear in a data rendering.
Property | Details | Gets the details rows for this group.
Property | EndSection | Gets the location where the layout should continue.
Property | Footer | Gets the footer section of this group.
Property | Header | Gets the header section of this group.
Property | KeepTogether | Gets a value indicating whether the table group is kept together on a single page where possible.
Property | PageBreak | Gets the page breaking options.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | SubGroups | Gets the inner groups of the table that are nested within this one.
Property | Table | Gets the ITable that this group is a member of.
Top

See Also

Reference

ITableGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroup Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableGroup Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

Glossary Item Box

For a list of all members of this type, see ITableGroup members.

Public Properties

 | Name | Description
Property | DataCollectionName | Gets the name of the table group element.
Property | DataElementName | Gets the name of this group instance element.
Property | DetailDataCollectionName | Gets the name that data-oriented rendering extensions should use for the collection of all instances of the table's details.
Property | DetailDataElementName | Gets the name that data-oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Gets a value indicating whether the details should appear in a data rendering.
Property | Details | Gets the details rows for this group.
Property | EndSection | Gets the location where the layout should continue.
Property | Footer | Gets the footer section of this group.
Property | Header | Gets the header section of this group.
Property | KeepTogether | Gets a value indicating whether the table group is kept together on a single page where possible.
Property | PageBreak | Gets the page breaking options.
Property | PreventOrphanedFooter | Gets a value indicating whether the orphaned footer is displayed on the next page.
Property | SubGroups | Gets the inner groups of the table that are nested within this one.
Property | Table | Gets the ITable that this group is a member of.
Top

See Also

Reference

ITableGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


DataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DataCollectionName Property

Glossary Item Box

Gets the name of the table group element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataCollectionName As String
C#
string DataCollectionName {get;}

Property Value

A System.String representing the name of the table group element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DataElementName Property

Glossary Item Box

Gets the name of this group instance element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name of this group instance element.

Remarks

Group instance elements are subelements of the table group element (i.e. DataCollectionName).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataCollectionName Property

[image]
ActiveReports 19 .NET Edition
DetailDataCollectionName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataCollectionName Property

Glossary Item Box

Gets the name that data-oriented rendering extensions should use for the collection of all instances of the table's details.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataCollectionName As String
C#
string DetailDataCollectionName {get;}

Property Value

A System.String representing the name for the collection of detail instances.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataElementName Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataElementName Property

Glossary Item Box

Gets the name that data-oriented rendering extensions should use for each detail instance of the table.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataElementName As String
C#
string DetailDataElementName {get;}

Property Value

A System.String representing the name for each detail instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DetailDataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataElementOutput Property

Glossary Item Box

Gets a value indicating whether the details should appear in a data rendering.

Syntax

Visual Basic (Declaration)
ReadOnly Property DetailDataElementOutput As DataElementOutput
C#
DataElementOutput DetailDataElementOutput {get;}

Property Value

An instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


Details Property

[image]
ActiveReports 19 .NET Edition
Details Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Details Property

Glossary Item Box

Gets the details rows for this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Details As IItemCollection(Of ITableDetail)
C#
IItemCollection<ITableDetail> Details {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableDetail representing the details rows for this group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : EndSection Property

Glossary Item Box

Gets the location where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An instance of EndSection representing where the layout should continue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


Footer Property

[image]
ActiveReports 19 .NET Edition
Footer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Footer Property

Glossary Item Box

Gets the footer section of this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Footer As ITableHeaderFooterRows
C#
ITableHeaderFooterRows Footer {get;}

Property Value

An instance of ITableHeaderFooterRows representing the footer section of this group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Header Property

Glossary Item Box

Gets the header section of this group.

Syntax

Visual Basic (Declaration)
ReadOnly Property Header As ITableHeaderFooterRows
C#
ITableHeaderFooterRows Header {get;}

Property Value

An instance of ITableHeaderFooterRows representing the header section of this group.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the table group is kept together on a single page where possible.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepTogether As Boolean
C#
bool KeepTogether {get;}

Property Value

A System.Boolean value. true if the table group is kept together on a single page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

An instance of GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation representing the page breaking options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


PreventOrphanedFooter Property

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : PreventOrphanedFooter Property

Glossary Item Box

Gets a value indicating whether the orphaned footer is displayed on the next page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PreventOrphanedFooter As Boolean
C#
bool PreventOrphanedFooter {get;}

Property Value

A System.Boolean value. true if the orphaned footer is displayed on the next page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


SubGroups Property

[image]
ActiveReports 19 .NET Edition
SubGroups Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : SubGroups Property

Glossary Item Box

Gets the inner groups of the table that are nested within this one.

Syntax

Visual Basic (Declaration)
ReadOnly Property SubGroups As IItemCollection(Of ITableGroup)
C#
IItemCollection<ITableGroup> SubGroups {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> of ITableGroup representing the nested inner groups.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


Table Property

[image]
ActiveReports 19 .NET Edition
Table Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Table Property

Glossary Item Box

Gets the ITable that this group is a member of.

Syntax

Visual Basic (Declaration)
ReadOnly Property Table As ITable
C#
ITable Table {get;}

Property Value

An instance of ITable representing the table that this group belongs to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableGroup Interface
ITableGroup Members


ITableHeaderFooterRows Interface

[image]
ActiveReports 19 .NET Edition
ITableHeaderFooterRows Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface

Glossary Item Box

Represents an interface for table header or footer row objects.

Syntax

Visual Basic (Declaration)
Public Interface ITableHeaderFooterRows
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableRow)
C#
public interface ITableHeaderFooterRows : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableHeaderFooterRows Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableHeaderFooterRows Interface Members

[image]
ActiveReports 19 .NET Edition
ITableHeaderFooterRows Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface

Glossary Item Box

The following tables list the members exposed by ITableHeaderFooterRows.

Public Properties

 | Name | Description
Property | PrintAtBottom | Gets a value indicating whether these rows should be printed at the bottom of the page.
Property | RepeatOnNewPage | Gets a value indicating whether these rows should be repeated on each page that the table or group is displayed on.
Top

See Also

Reference

ITableHeaderFooterRows Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableHeaderFooterRows Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableHeaderFooterRows Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface

Glossary Item Box

For a list of all members of this type, see ITableHeaderFooterRows members.

Public Properties

 | Name | Description
Property | PrintAtBottom | Gets a value indicating whether these rows should be printed at the bottom of the page.
Property | RepeatOnNewPage | Gets a value indicating whether these rows should be repeated on each page that the table or group is displayed on.
Top

See Also

Reference

ITableHeaderFooterRows Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


PrintAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableHeaderFooterRows Interface : PrintAtBottom Property

Glossary Item Box

Gets a value indicating whether these rows should be printed at the bottom of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintAtBottom As Boolean
C#
bool PrintAtBottom {get;}

Property Value

A System.Boolean value. true if the rows should be printed at the bottom of the page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableHeaderFooterRows Interface
ITableHeaderFooterRows Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableHeaderFooterRows Interface : RepeatOnNewPage Property

Glossary Item Box

Gets a value indicating whether these rows should be repeated on each page that the table or group is displayed on.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatOnNewPage As Boolean
C#
bool RepeatOnNewPage {get;}

Property Value

A System.Boolean value. true if the rows should be repeated on each page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableHeaderFooterRows Interface
ITableHeaderFooterRows Members


ITableRow Interface

[image]
ActiveReports 19 .NET Edition
ITableRow Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

Glossary Item Box

Represents an interface for a table row object.

Syntax

Visual Basic (Declaration)
Public Interface ITableRow
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IActionableItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public interface ITableRow : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IActionableItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableRow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRow Interface Members

[image]
ActiveReports 19 .NET Edition
ITableRow Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

Glossary Item Box

The following tables list the members exposed by ITableRow.

Public Properties

 | Name | Description
Property | CanShrink | Gets a value indicating whether the row contains only cells with CanShrink set to true.
Property | Cells | Gets a collection of table cells.
Property | Height | Gets the table row height.
Top

See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRow Interface Properties

[image]
ActiveReports 19 .NET Edition
ITableRow Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

Glossary Item Box

For a list of all members of this type, see ITableRow members.

Public Properties

 | Name | Description
Property | CanShrink | Gets a value indicating whether the row contains only cells with CanShrink set to true.
Property | Cells | Gets a collection of table cells.
Property | Height | Gets the table row height.
Top

See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : CanShrink Property

Glossary Item Box

Gets a value indicating whether the row contains only cells with CanShrink set to true.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanShrink As Boolean
C#
bool CanShrink {get;}

Property Value

A System.Boolean value. true if the row contains only cells with CanShrink set to true; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableRow Interface
ITableRow Members


Cells Property

[image]
ActiveReports 19 .NET Edition
Cells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : Cells Property

Glossary Item Box

Gets a collection of table cells.

Syntax

Visual Basic (Declaration)
ReadOnly Property Cells As IEnumerable(Of ITableCell)
C#
IEnumerable<ITableCell> Cells {get;}

Property Value

An IEnumerable collection representing the cells in the table row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableRow Interface
ITableRow Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : Height Property

Glossary Item Box

Gets the table row height.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value specifying the height of the table row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableRow Interface
ITableRow Members


TablixLayoutDirection Enumeration

[image]
ActiveReports 19 .NET Edition
TablixLayoutDirection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : TablixLayoutDirection Enumeration

Glossary Item Box

Specifies the overall direction of the layout.

Syntax

Visual Basic (Declaration)
Public Enum TablixLayoutDirection
   Inherits System.Enum
C#
public enum TablixLayoutDirection : System.Enum

Members

Member | Description
LTR | Dynamic columns grow left-to-right with headers on the left.
RTL | Dynamic columns grow right-to-left with headers on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix.TablixLayoutDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


IBandLayoutOptions Interface

[image]
ActiveReports 19 .NET Edition
IBandLayoutOptions Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IBandLayoutOptions Interface

Glossary Item Box

Represents the specific layout options to use when the Tablix is rendered on the canvas.

Syntax

Visual Basic (Declaration)
Public Interface IBandLayoutOptions
C#
public interface IBandLayoutOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


IBandLayoutOptions Interface Members

[image]
ActiveReports 19 .NET Edition
IBandLayoutOptions Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IBandLayoutOptions Interface

Glossary Item Box

The following tables list the members exposed by IBandLayoutOptions.

Public Properties

 | Name | Description
Property | ColumnCount | Gets the number of columns that should be displayed on each band sheet when the Tablix is rendered.
Property | CoverFlow | Gets the coverflow settings.
Property | PlayAxis | Gets the play axis settings.
Property | RowCount | Gets the number of rows that should be displayed on each band sheet when the Tablix is rendered.
Property | TabStrip | Gets the tabstrip settings.
Top

See Also

Reference

IBandLayoutOptions Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


IBandLayoutOptions Interface Properties

[image]
ActiveReports 19 .NET Edition
IBandLayoutOptions Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IBandLayoutOptions Interface

Glossary Item Box

For a list of all members of this type, see IBandLayoutOptions members.

Public Properties

 | Name | Description
Property | ColumnCount | Gets the number of columns that should be displayed on each band sheet when the Tablix is rendered.
Property | CoverFlow | Gets the coverflow settings.
Property | PlayAxis | Gets the play axis settings.
Property | RowCount | Gets the number of rows that should be displayed on each band sheet when the Tablix is rendered.
Property | TabStrip | Gets the tabstrip settings.
Top

See Also

Reference

IBandLayoutOptions Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ColumnCount Property

[image]
ActiveReports 19 .NET Edition
ColumnCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IBandLayoutOptions Interface : ColumnCount Property

Glossary Item Box

Gets the number of columns that should be displayed on each band sheet when the Tablix is rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnCount As Integer
C#
int ColumnCount {get;}

Property Value

An integer representing the number of columns per band sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Interface
IBandLayoutOptions Members


CoverFlow Property

[image]
ActiveReports 19 .NET Edition
CoverFlow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IBandLayoutOptions Interface : CoverFlow Property

Glossary Item Box

Gets the coverflow settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property CoverFlow As ICoverFlow
C#
ICoverFlow CoverFlow {get;}

Property Value

An ICoverFlow instance representing the coverflow settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Interface
IBandLayoutOptions Members


PlayAxis Property

[image]
ActiveReports 19 .NET Edition
PlayAxis Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IBandLayoutOptions Interface : PlayAxis Property

Glossary Item Box

Gets the play axis settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property PlayAxis As IPlayAxis
C#
IPlayAxis PlayAxis {get;}

Property Value

An IPlayAxis instance representing the play axis settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Interface
IBandLayoutOptions Members


RowCount Property

[image]
ActiveReports 19 .NET Edition
RowCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IBandLayoutOptions Interface : RowCount Property

Glossary Item Box

Gets the number of rows that should be displayed on each band sheet when the Tablix is rendered.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCount As Integer
C#
int RowCount {get;}

Property Value

An integer representing the number of rows per band sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Interface
IBandLayoutOptions Members


TabStrip Property

[image]
ActiveReports 19 .NET Edition
TabStrip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IBandLayoutOptions Interface : TabStrip Property

Glossary Item Box

Gets the tabstrip settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property TabStrip As ITabStrip
C#
ITabStrip TabStrip {get;}

Property Value

An ITabStrip instance representing the tabstrip settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBandLayoutOptions Interface
IBandLayoutOptions Members


ICellContents Interface

[image]
ActiveReports 19 .NET Edition
ICellContents Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICellContents Interface

Glossary Item Box

Represents a report item contained in the body, header, or corner cell of a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ICellContents
C#
public interface ICellContents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellContents Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ICellContents Interface Members

[image]
ActiveReports 19 .NET Edition
ICellContents Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICellContents Interface

Glossary Item Box

The following tables list the members exposed by ICellContents.

Public Properties

 | Name | Description
Property | ColSpan | Gets the number of columns this cell spans.
Property | ReportItem | Gets the report item for this cell.
Property | RowSpan | Gets the number of rows this cell spans.
Top

See Also

Reference

ICellContents Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ICellContents Interface Properties

[image]
ActiveReports 19 .NET Edition
ICellContents Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICellContents Interface

Glossary Item Box

For a list of all members of this type, see ICellContents members.

Public Properties

 | Name | Description
Property | ColSpan | Gets the number of columns this cell spans.
Property | ReportItem | Gets the report item for this cell.
Property | RowSpan | Gets the number of rows this cell spans.
Top

See Also

Reference

ICellContents Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ColSpan Property

[image]
ActiveReports 19 .NET Edition
ColSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ICellContents Interface : ColSpan Property

Glossary Item Box

Gets the number of columns this cell spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColSpan As Integer
C#
int ColSpan {get;}

Property Value

An System.Int32 representing the number of columns this cell spans.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellContents Interface
ICellContents Members


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ICellContents Interface : ReportItem Property

Glossary Item Box

Gets the report item for this cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem representing the report item for this cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellContents Interface
ICellContents Members


RowSpan Property

[image]
ActiveReports 19 .NET Edition
RowSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ICellContents Interface : RowSpan Property

Glossary Item Box

Gets the number of rows this cell spans.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowSpan As Integer
C#
int RowSpan {get;}

Property Value

An System.Int32 representing the number of rows this cell spans.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellContents Interface
ICellContents Members


ICoverFlow Interface

[image]
ActiveReports 19 .NET Edition
ICoverFlow Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICoverFlow Interface

Glossary Item Box

Represents a band navigation style in which a flow of images is integrated the navigation of the tablix band.

Syntax

Visual Basic (Declaration)
Public Interface ICoverFlow
C#
public interface ICoverFlow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICoverFlow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ICoverFlow Interface Members

[image]
ActiveReports 19 .NET Edition
ICoverFlow Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICoverFlow Interface

Glossary Item Box

The following tables list the members exposed by ICoverFlow.

Public Properties

 | Name | Description
Property | NavigationItem | Gets the navigation item to use to draw the cover flow navigation layout.
Property | Slider | Gets the slider settings for the cover flow navigation layout.
Top

See Also

Reference

ICoverFlow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ICoverFlow Interface Properties

[image]
ActiveReports 19 .NET Edition
ICoverFlow Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ICoverFlow Interface

Glossary Item Box

For a list of all members of this type, see ICoverFlow members.

Public Properties

 | Name | Description
Property | NavigationItem | Gets the navigation item to use to draw the cover flow navigation layout.
Property | Slider | Gets the slider settings for the cover flow navigation layout.
Top

See Also

Reference

ICoverFlow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


NavigationItem Property

[image]
ActiveReports 19 .NET Edition
NavigationItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ICoverFlow Interface : NavigationItem Property

Glossary Item Box

Gets the navigation item to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property NavigationItem As INavigationItem
C#
INavigationItem NavigationItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICoverFlow Interface
ICoverFlow Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ICoverFlow Interface : Slider Property

Glossary Item Box

Gets the slider settings for the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property Slider As ISlider
C#
ISlider Slider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICoverFlow Interface
ICoverFlow Members


ILabelData Interface

[image]
ActiveReports 19 .NET Edition
ILabelData Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ILabelData Interface

Glossary Item Box

Represents the dataset used to populate the data for the slider labels.

Syntax

Visual Basic (Declaration)
Public Interface ILabelData
C#
public interface ILabelData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILabelData Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ILabelData Interface Members

[image]
ActiveReports 19 .NET Edition
ILabelData Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ILabelData Interface

Glossary Item Box

The following tables list the members exposed by ILabelData.

Public Properties

 | Name | Description
Property | DataSetName | Gets the dataset name.
Property | Key | Gets the field name in the dataset to be matched with band group expression value.
Property | Label | Gets the field name in the dataset to be displayed as navigation labels.
Top

See Also

Reference

ILabelData Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ILabelData Interface Properties

[image]
ActiveReports 19 .NET Edition
ILabelData Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ILabelData Interface

Glossary Item Box

For a list of all members of this type, see ILabelData members.

Public Properties

 | Name | Description
Property | DataSetName | Gets the dataset name.
Property | Key | Gets the field name in the dataset to be matched with band group expression value.
Property | Label | Gets the field name in the dataset to be displayed as navigation labels.
Top

See Also

Reference

ILabelData Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ILabelData Interface : DataSetName Property

Glossary Item Box

Gets the dataset name.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataSetName As String
C#
string DataSetName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILabelData Interface
ILabelData Members


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ILabelData Interface : Key Property

Glossary Item Box

Gets the field name in the dataset to be matched with band group expression value.

Syntax

Visual Basic (Declaration)
ReadOnly Property Key As String
C#
string Key {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILabelData Interface
ILabelData Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ILabelData Interface : Label Property

Glossary Item Box

Gets the field name in the dataset to be displayed as navigation labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILabelData Interface
ILabelData Members


INavigationItem Interface

[image]
ActiveReports 19 .NET Edition
INavigationItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : INavigationItem Interface

Glossary Item Box

Represents the navigation item to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Public Interface INavigationItem
C#
public interface INavigationItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INavigationItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


INavigationItem Interface Members

[image]
ActiveReports 19 .NET Edition
INavigationItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : INavigationItem Interface

Glossary Item Box

The following tables list the members exposed by INavigationItem.

Public Properties

 | Name | Description
Property | ReportItem | Gets or sets the report item to use to draw the cover flow navigation layout.
Property | ReportItemReference | Gets or sets the report item reference to use to draw the cover flow navigation layout.
Top

See Also

Reference

INavigationItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


INavigationItem Interface Properties

[image]
ActiveReports 19 .NET Edition
INavigationItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : INavigationItem Interface

Glossary Item Box

For a list of all members of this type, see INavigationItem members.

Public Properties

 | Name | Description
Property | ReportItem | Gets or sets the report item to use to draw the cover flow navigation layout.
Property | ReportItemReference | Gets or sets the report item reference to use to draw the cover flow navigation layout.
Top

See Also

Reference

INavigationItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > INavigationItem Interface : ReportItem Property

Glossary Item Box

Gets or sets the report item to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Property ReportItem As IReportItem
C#
IReportItem ReportItem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INavigationItem Interface
INavigationItem Members


ReportItemReference Property

[image]
ActiveReports 19 .NET Edition
ReportItemReference Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > INavigationItem Interface : ReportItemReference Property

Glossary Item Box

Gets or sets the report item reference to use to draw the cover flow navigation layout.

Syntax

Visual Basic (Declaration)
Property ReportItemReference As String
C#
string ReportItemReference {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INavigationItem Interface
INavigationItem Members


IPlayAxis Interface

[image]
ActiveReports 19 .NET Edition
IPlayAxis Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IPlayAxis Interface

Glossary Item Box

Represents a play axis navigation type.

Syntax

Visual Basic (Declaration)
Public Interface IPlayAxis
C#
public interface IPlayAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlayAxis Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


IPlayAxis Interface Members

[image]
ActiveReports 19 .NET Edition
IPlayAxis Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IPlayAxis Interface

Glossary Item Box

The following tables list the members exposed by IPlayAxis.

Public Properties

 | Name | Description
Property | DockingOption | Gets the docking option of the slider.
Property | Slider | Gets the slider settings.
Top

See Also

Reference

IPlayAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


IPlayAxis Interface Properties

[image]
ActiveReports 19 .NET Edition
IPlayAxis Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : IPlayAxis Interface

Glossary Item Box

For a list of all members of this type, see IPlayAxis members.

Public Properties

 | Name | Description
Property | DockingOption | Gets the docking option of the slider.
Property | Slider | Gets the slider settings.
Top

See Also

Reference

IPlayAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


DockingOption Property

[image]
ActiveReports 19 .NET Edition
DockingOption Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IPlayAxis Interface : DockingOption Property

Glossary Item Box

Gets the docking option of the slider.

Syntax

Visual Basic (Declaration)
ReadOnly Property DockingOption As String
C#
string DockingOption {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlayAxis Interface
IPlayAxis Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > IPlayAxis Interface : Slider Property

Glossary Item Box

Gets the slider settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Slider As ISlider
C#
ISlider Slider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPlayAxis Interface
IPlayAxis Members


ISlider Interface

[image]
ActiveReports 19 .NET Edition
ISlider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ISlider Interface

Glossary Item Box

Represents a slider in a navigation control.

Syntax

Visual Basic (Declaration)
Public Interface ISlider
C#
public interface ISlider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISlider Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ISlider Interface Members

[image]
ActiveReports 19 .NET Edition
ISlider Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ISlider Interface

Glossary Item Box

The following tables list the members exposed by ISlider.

Public Properties

 | Name | Description
Property | Hidden | Gets a System.Boolean value that indicates whether the slider is hidden.
Property | LabelData | Gets the dataset used to populate the data for the slider labels.
Top

See Also

Reference

ISlider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ISlider Interface Properties

[image]
ActiveReports 19 .NET Edition
ISlider Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ISlider Interface

Glossary Item Box

For a list of all members of this type, see ISlider members.

Public Properties

 | Name | Description
Property | Hidden | Gets a System.Boolean value that indicates whether the slider is hidden.
Property | LabelData | Gets the dataset used to populate the data for the slider labels.
Top

See Also

Reference

ISlider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ISlider Interface : Hidden Property

Glossary Item Box

Gets a System.Boolean value that indicates whether the slider is hidden.

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As Boolean
C#
bool Hidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISlider Interface
ISlider Members


LabelData Property

[image]
ActiveReports 19 .NET Edition
LabelData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ISlider Interface : LabelData Property

Glossary Item Box

Gets the dataset used to populate the data for the slider labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelData As ILabelData
C#
ILabelData LabelData {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISlider Interface
ISlider Members


ITablix Interface

[image]
ActiveReports 19 .NET Edition
ITablix Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablix Interface

Glossary Item Box

Represents a flexible layout grid with nested repeating column groups and row groups.

Syntax

Visual Basic (Declaration)
Public Interface ITablix
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
C#
public interface ITablix : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IFixedSizeItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablix Interface Members

[image]
ActiveReports 19 .NET Edition
ITablix Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablix Interface

Glossary Item Box

The following tables list the members exposed by ITablix.

Public Properties

 | Name | Description
Property | BandLayoutOptions | Gets the band layout options.
Property | Body | Gets the bottom right region that contains the data of the tablix.
Property | BottomMargin | Gets the width of the bottom margin.
Property | CanScroll | Gets a value indicating whether the tablix will get scroll bars when the content size grows beyond the definition size of the tablix.
Property | ColumnHierarchy | Gets the column hierarchy for the tablix.
Property | Columns | Gets the number of columns in the tablix (equals the number of leaf-members in the column hierarchy).
Property | Corner | Gets the upper left corner area of the tablix.
Property | FixedColumnHeaders | Gets a value indicating whether the column headers should be displayed on the page even when the user scrolls part of the tablix off the page.
Property | FixedRowHeaders | Gets a value indicating whether the row headers should be displayed on the page even when the user scrolls part of the tablix off the page.
Property | GroupsBeforeRowHeaders | Gets the number of instances of the leftmost outer column member that should appear to the left of the row headers (right of the row headers for RTL tablixes).
Property | HideStaticsIfNoRows | Gets a value indicating whether all static members in the tablix without dynamic descendants or dynamic ancestors have HideIfNoRows set to true.
Property | LayoutDirection | Gets the overall direction of the tablix layout.
Property | LeftMargin | Gets the width of the left margin.
Property | OmitBorderOnPageBreak | Gets a value indicating whether the borders should not appear at locations where the tablix spans multiple pages. Also causes repeated background images to continue rather than restart after a page break.
Property | RepeatColumnHeaders | Gets a value indicating whether the column headers should be repeated on each page on which a portion of the tablix appears.
Property | RepeatRowHeaders | Gets a value indicating whether the row headers should be repeated on each page on which a portion of the tablix appears.
Property | RepeatToFill | Gets a value indicating whether the Tablix should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Property | RightMargin | Gets the width of the right margin.
Property | RowHierarchy | Gets the row hierarchy of the tablix.
Property | Rows | Gets the number of rows in the tablix (equals the number of leaf-members in the row hierarchy).
Property | TopMargin | Gets the width of the top margin.
Top

See Also

Reference

ITablix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablix Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablix Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablix Interface

Glossary Item Box

For a list of all members of this type, see ITablix members.

Public Properties

 | Name | Description
Property | BandLayoutOptions | Gets the band layout options.
Property | Body | Gets the bottom right region that contains the data of the tablix.
Property | BottomMargin | Gets the width of the bottom margin.
Property | CanScroll | Gets a value indicating whether the tablix will get scroll bars when the content size grows beyond the definition size of the tablix.
Property | ColumnHierarchy | Gets the column hierarchy for the tablix.
Property | Columns | Gets the number of columns in the tablix (equals the number of leaf-members in the column hierarchy).
Property | Corner | Gets the upper left corner area of the tablix.
Property | FixedColumnHeaders | Gets a value indicating whether the column headers should be displayed on the page even when the user scrolls part of the tablix off the page.
Property | FixedRowHeaders | Gets a value indicating whether the row headers should be displayed on the page even when the user scrolls part of the tablix off the page.
Property | GroupsBeforeRowHeaders | Gets the number of instances of the leftmost outer column member that should appear to the left of the row headers (right of the row headers for RTL tablixes).
Property | HideStaticsIfNoRows | Gets a value indicating whether all static members in the tablix without dynamic descendants or dynamic ancestors have HideIfNoRows set to true.
Property | LayoutDirection | Gets the overall direction of the tablix layout.
Property | LeftMargin | Gets the width of the left margin.
Property | OmitBorderOnPageBreak | Gets a value indicating whether the borders should not appear at locations where the tablix spans multiple pages. Also causes repeated background images to continue rather than restart after a page break.
Property | RepeatColumnHeaders | Gets a value indicating whether the column headers should be repeated on each page on which a portion of the tablix appears.
Property | RepeatRowHeaders | Gets a value indicating whether the row headers should be repeated on each page on which a portion of the tablix appears.
Property | RepeatToFill | Gets a value indicating whether the Tablix should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Property | RightMargin | Gets the width of the right margin.
Property | RowHierarchy | Gets the row hierarchy of the tablix.
Property | Rows | Gets the number of rows in the tablix (equals the number of leaf-members in the row hierarchy).
Property | TopMargin | Gets the width of the top margin.
Top

See Also

Reference

ITablix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


BandLayoutOptions Property

[image]
ActiveReports 19 .NET Edition
BandLayoutOptions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : BandLayoutOptions Property

Glossary Item Box

Gets the band layout options.

Syntax

Visual Basic (Declaration)
ReadOnly Property BandLayoutOptions As IBandLayoutOptions
C#
IBandLayoutOptions BandLayoutOptions {get;}

Property Value

An IBandLayoutOptions instance representing the band layout options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


Body Property

[image]
ActiveReports 19 .NET Edition
Body Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : Body Property

Glossary Item Box

Gets the bottom right region that contains the data of the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property Body As ITablixBody
C#
ITablixBody Body {get;}

Property Value

An ITablixBody instance representing the bottom right region that contains the data of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


BottomMargin Property

[image]
ActiveReports 19 .NET Edition
BottomMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : BottomMargin Property

Glossary Item Box

Gets the width of the bottom margin.

Syntax

Visual Basic (Declaration)
ReadOnly Property BottomMargin As Length
C#
Length BottomMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the bottom margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


CanScroll Property

[image]
ActiveReports 19 .NET Edition
CanScroll Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : CanScroll Property

Glossary Item Box

Gets a value indicating whether the tablix will get scroll bars when the content size grows beyond the definition size of the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanScroll As Boolean
C#
bool CanScroll {get;}

Property Value

A System.Boolean value indicating whether the tablix will get scroll bars when the content size exceeds the defined size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


ColumnHierarchy Property

[image]
ActiveReports 19 .NET Edition
ColumnHierarchy Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : ColumnHierarchy Property

Glossary Item Box

Gets the column hierarchy for the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnHierarchy As ITablixHierarchy
C#
ITablixHierarchy ColumnHierarchy {get;}

Property Value

An ITablixHierarchy instance representing the column hierarchy of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


Columns Property

[image]
ActiveReports 19 .NET Edition
Columns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : Columns Property

Glossary Item Box

Gets the number of columns in the tablix (equals the number of leaf-members in the column hierarchy).

Syntax

Visual Basic (Declaration)
ReadOnly Property Columns As Integer
C#
int Columns {get;}

Property Value

An System.Int32 representing the number of columns in the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


Corner Property

[image]
ActiveReports 19 .NET Edition
Corner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : Corner Property

Glossary Item Box

Gets the upper left corner area of the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property Corner As ITablixCorner
C#
ITablixCorner Corner {get;}

Property Value

An ITablixCorner instance representing the upper left corner area of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


FixedColumnHeaders Property

[image]
ActiveReports 19 .NET Edition
FixedColumnHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : FixedColumnHeaders Property

Glossary Item Box

Gets a value indicating whether the column headers should be displayed on the page even when the user scrolls part of the tablix off the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property FixedColumnHeaders As Boolean
C#
bool FixedColumnHeaders {get;}

Property Value

A System.Boolean value indicating whether the column headers should remain visible when scrolling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


FixedRowHeaders Property

[image]
ActiveReports 19 .NET Edition
FixedRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : FixedRowHeaders Property

Glossary Item Box

Gets a value indicating whether the row headers should be displayed on the page even when the user scrolls part of the tablix off the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property FixedRowHeaders As Boolean
C#
bool FixedRowHeaders {get;}

Property Value

A System.Boolean value indicating whether the row headers should remain visible when scrolling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


GroupsBeforeRowHeaders Property

[image]
ActiveReports 19 .NET Edition
GroupsBeforeRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : GroupsBeforeRowHeaders Property

Glossary Item Box

Gets the number of instances of the leftmost outer column member that should appear to the left of the row headers (right of the row headers for RTL tablixes).

Syntax

Visual Basic (Declaration)
ReadOnly Property GroupsBeforeRowHeaders As Integer
C#
int GroupsBeforeRowHeaders {get;}

Property Value

An System.Int32 representing the number of instances of the outermost column member before the row headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


HideStaticsIfNoRows Property

[image]
ActiveReports 19 .NET Edition
HideStaticsIfNoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : HideStaticsIfNoRows Property

Glossary Item Box

Gets a value indicating whether all static members in the tablix without dynamic descendants or dynamic ancestors have HideIfNoRows set to true.

Syntax

Visual Basic (Declaration)
ReadOnly Property HideStaticsIfNoRows As Boolean
C#
bool HideStaticsIfNoRows {get;}

Property Value

A System.Boolean value indicating whether to hide static members if there are no rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


LayoutDirection Property

[image]
ActiveReports 19 .NET Edition
LayoutDirection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : LayoutDirection Property

Glossary Item Box

Gets the overall direction of the tablix layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property LayoutDirection As TablixLayoutDirection
C#
TablixLayoutDirection LayoutDirection {get;}

Property Value

A TablixLayoutDirection value indicating the overall direction of the tablix layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


LeftMargin Property

[image]
ActiveReports 19 .NET Edition
LeftMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : LeftMargin Property

Glossary Item Box

Gets the width of the left margin.

Syntax

Visual Basic (Declaration)
ReadOnly Property LeftMargin As Length
C#
Length LeftMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the left margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


OmitBorderOnPageBreak Property

[image]
ActiveReports 19 .NET Edition
OmitBorderOnPageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : OmitBorderOnPageBreak Property

Glossary Item Box

Gets a value indicating whether the borders should not appear at locations where the tablix spans multiple pages. Also causes repeated background images to continue rather than restart after a page break.

Syntax

Visual Basic (Declaration)
ReadOnly Property OmitBorderOnPageBreak As Boolean
C#
bool OmitBorderOnPageBreak {get;}

Property Value

A System.Boolean value indicating whether to omit borders on page breaks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


RepeatColumnHeaders Property

[image]
ActiveReports 19 .NET Edition
RepeatColumnHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : RepeatColumnHeaders Property

Glossary Item Box

Gets a value indicating whether the column headers should be repeated on each page on which a portion of the tablix appears.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatColumnHeaders As Boolean
C#
bool RepeatColumnHeaders {get;}

Property Value

A System.Boolean value indicating whether to repeat column headers on each page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


RepeatRowHeaders Property

[image]
ActiveReports 19 .NET Edition
RepeatRowHeaders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : RepeatRowHeaders Property

Glossary Item Box

Gets a value indicating whether the row headers should be repeated on each page on which a portion of the tablix appears.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatRowHeaders As Boolean
C#
bool RepeatRowHeaders {get;}

Property Value

A System.Boolean value indicating whether to repeat row headers on each page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


RepeatToFill Property

[image]
ActiveReports 19 .NET Edition
RepeatToFill Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : RepeatToFill Property

Glossary Item Box

Gets a value indicating whether the Tablix should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatToFill As Boolean
C#
bool RepeatToFill {get;}

Property Value

A System.Boolean value indicating whether to fill the space with empty rows to reach the fixed height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


RightMargin Property

[image]
ActiveReports 19 .NET Edition
RightMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : RightMargin Property

Glossary Item Box

Gets the width of the right margin.

Syntax

Visual Basic (Declaration)
ReadOnly Property RightMargin As Length
C#
Length RightMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the right margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


RowHierarchy Property

[image]
ActiveReports 19 .NET Edition
RowHierarchy Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : RowHierarchy Property

Glossary Item Box

Gets the row hierarchy of the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowHierarchy As ITablixHierarchy
C#
ITablixHierarchy RowHierarchy {get;}

Property Value

An ITablixHierarchy instance representing the row hierarchy of the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


Rows Property

[image]
ActiveReports 19 .NET Edition
Rows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : Rows Property

Glossary Item Box

Gets the number of rows in the tablix (equals the number of leaf-members in the row hierarchy).

Syntax

Visual Basic (Declaration)
ReadOnly Property Rows As Integer
C#
int Rows {get;}

Property Value

An System.Int32 representing the number of rows in the tablix.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


TopMargin Property

[image]
ActiveReports 19 .NET Edition
TopMargin Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablix Interface : TopMargin Property

Glossary Item Box

Gets the width of the top margin.

Syntax

Visual Basic (Declaration)
ReadOnly Property TopMargin As Length
C#
Length TopMargin {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length value representing the width of the top margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablix Interface
ITablix Members


ITablixBody Interface

[image]
ActiveReports 19 .NET Edition
ITablixBody Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixBody Interface

Glossary Item Box

Represents the layout and structure of the bottom right region that contains the data elements of the tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixBody
C#
public interface ITablixBody

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixBody Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixBody Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixBody Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixBody Interface

Glossary Item Box

The following tables list the members exposed by ITablixBody.

Public Properties

 | Name | Description
Property | ColumnCollection | Gets the columns of the tablix body.
Property | IgnoreCellPageBreaks | Gets a value indicating whether the complexity of the tablix should result in page breaks in the body of the tablix being ignored.
Property | RowCollection | Gets the rows of the tablix body.
Top

See Also

Reference

ITablixBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixBody Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixBody Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixBody Interface

Glossary Item Box

For a list of all members of this type, see ITablixBody members.

Public Properties

 | Name | Description
Property | ColumnCollection | Gets the columns of the tablix body.
Property | IgnoreCellPageBreaks | Gets a value indicating whether the complexity of the tablix should result in page breaks in the body of the tablix being ignored.
Property | RowCollection | Gets the rows of the tablix body.
Top

See Also

Reference

ITablixBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ColumnCollection Property

[image]
ActiveReports 19 .NET Edition
ColumnCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixBody Interface : ColumnCollection Property

Glossary Item Box

Gets the columns of the tablix body.

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnCollection As IItemCollection(Of ITablixColumn)
C#
IItemCollection<ITablixColumn> ColumnCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the columns of the tablix body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixBody Interface
ITablixBody Members


IgnoreCellPageBreaks Property

[image]
ActiveReports 19 .NET Edition
IgnoreCellPageBreaks Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixBody Interface : IgnoreCellPageBreaks Property

Glossary Item Box

Gets a value indicating whether the complexity of the tablix should result in page breaks in the body of the tablix being ignored.

Syntax

Visual Basic (Declaration)
ReadOnly Property IgnoreCellPageBreaks As Boolean
C#
bool IgnoreCellPageBreaks {get;}

Property Value

A System.Boolean value indicating whether to ignore page breaks in the tablix body due to complexity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixBody Interface
ITablixBody Members


RowCollection Property

[image]
ActiveReports 19 .NET Edition
RowCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixBody Interface : RowCollection Property

Glossary Item Box

Gets the rows of the tablix body.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCollection As IItemCollection(Of ITablixRow)
C#
IItemCollection<ITablixRow> RowCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the rows of the tablix body.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixBody Interface
ITablixBody Members


ITablixCell Interface

[image]
ActiveReports 19 .NET Edition
ITablixCell Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCell Interface

Glossary Item Box

Represents the contents of each cell in the body section of a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixCell
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent
C#
public interface ITablixCell : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCell Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixCell Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCell Interface

Glossary Item Box

The following tables list the members exposed by ITablixCell.

Public Properties

 | Name | Description
Property | AutoMerge | Gets the policy for merging nearby cells with the same content.
Property | CellContents | Gets the contents of a cell in a tablix body.
Property | DataElementName | Gets the name to use for the cell element.
Property | DataElementOutput | Gets a value that indicates whether the cell contents should appear in a data rendering.
Top

See Also

Reference

ITablixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCell Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixCell Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCell Interface

Glossary Item Box

For a list of all members of this type, see ITablixCell members.

Public Properties

 | Name | Description
Property | AutoMerge | Gets the policy for merging nearby cells with the same content.
Property | CellContents | Gets the contents of a cell in a tablix body.
Property | DataElementName | Gets the name to use for the cell element.
Property | DataElementOutput | Gets a value that indicates whether the cell contents should appear in a data rendering.
Top

See Also

Reference

ITablixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


AutoMerge Property

[image]
ActiveReports 19 .NET Edition
AutoMerge Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCell Interface : AutoMerge Property

Glossary Item Box

Gets the policy for merging nearby cells with the same content.

Syntax

Visual Basic (Declaration)
ReadOnly Property AutoMerge As MergePolicy
C#
MergePolicy AutoMerge {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.MergePolicy value indicating the policy for merging nearby cells with the same content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCell Interface
ITablixCell Members


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCell Interface : CellContents Property

Glossary Item Box

Gets the contents of a cell in a tablix body.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellContents As ICellContents
C#
ICellContents CellContents {get;}

Property Value

An ICellContents representing the contents of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCell Interface
ITablixCell Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCell Interface : DataElementName Property

Glossary Item Box

Gets the name to use for the cell element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name to use for the cell element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCell Interface
ITablixCell Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCell Interface : DataElementOutput Property

Glossary Item Box

Gets a value that indicates whether the cell contents should appear in a data rendering.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value indicating whether the cell contents should appear in a data rendering.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCell Interface
ITablixCell Members


ITablixColumn Interface

[image]
ActiveReports 19 .NET Edition
ITablixColumn Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixColumn Interface

Glossary Item Box

Represents a column in the body section of a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixColumn
C#
public interface ITablixColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixColumn Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixColumn Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixColumn Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixColumn Interface

Glossary Item Box

The following tables list the members exposed by ITablixColumn.

Public Properties

 | Name | Description
Property | Width | Gets the width of each cell in this column.
Top

See Also

Reference

ITablixColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixColumn Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixColumn Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixColumn Interface

Glossary Item Box

For a list of all members of this type, see ITablixColumn members.

Public Properties

 | Name | Description
Property | Width | Gets the width of each cell in this column.
Top

See Also

Reference

ITablixColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixColumn Interface : Width Property

Glossary Item Box

Gets the width of each cell in this column.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the width of each cell in this column.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixColumn Interface
ITablixColumn Members


ITablixCorner Interface

[image]
ActiveReports 19 .NET Edition
ITablixCorner Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCorner Interface

Glossary Item Box

Represents the layout and structure of the upper left-hand corner region of a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixCorner
C#
public interface ITablixCorner

Remarks

The height of the corner is the sum of the heights of the column headers. The width of the corner is the sum of the widths of the row headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCorner Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCorner Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixCorner Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCorner Interface

Glossary Item Box

The following tables list the members exposed by ITablixCorner.

Public Properties

 | Name | Description
Property | RowCollection | Gets the rows of the tablix corner.
Top

See Also

Reference

ITablixCorner Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCorner Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixCorner Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCorner Interface

Glossary Item Box

For a list of all members of this type, see ITablixCorner members.

Public Properties

 | Name | Description
Property | RowCollection | Gets the rows of the tablix corner.
Top

See Also

Reference

ITablixCorner Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


RowCollection Property

[image]
ActiveReports 19 .NET Edition
RowCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCorner Interface : RowCollection Property

Glossary Item Box

Gets the rows of the tablix corner.

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCollection As IItemCollection(Of ITablixCornerRow)
C#
IItemCollection<ITablixCornerRow> RowCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the rows of the tablix corner.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCorner Interface
ITablixCorner Members


ITablixCornerCell Interface

[image]
ActiveReports 19 .NET Edition
ITablixCornerCell Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerCell Interface

Glossary Item Box

Represents the contents of each corner cell in the tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixCornerCell
C#
public interface ITablixCornerCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCornerCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCornerCell Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixCornerCell Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerCell Interface

Glossary Item Box

The following tables list the members exposed by ITablixCornerCell.

Public Properties

 | Name | Description
Property | CellContents | Gets the contents of a cell in the tablix corner.
Top

See Also

Reference

ITablixCornerCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCornerCell Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixCornerCell Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerCell Interface

Glossary Item Box

For a list of all members of this type, see ITablixCornerCell members.

Public Properties

 | Name | Description
Property | CellContents | Gets the contents of a cell in the tablix corner.
Top

See Also

Reference

ITablixCornerCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCornerCell Interface : CellContents Property

Glossary Item Box

Gets the contents of a cell in the tablix corner.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellContents As ICellContents
C#
ICellContents CellContents {get;}

Property Value

An ICellContents representing the contents of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCornerCell Interface
ITablixCornerCell Members


ITablixCornerRow Interface

[image]
ActiveReports 19 .NET Edition
ITablixCornerRow Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerRow Interface

Glossary Item Box

Represents the list of cells in a row of the corner section of a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixCornerRow
C#
public interface ITablixCornerRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCornerRow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCornerRow Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixCornerRow Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerRow Interface

Glossary Item Box

The following tables list the members exposed by ITablixCornerRow.

Public Properties

 | Name | Description
Property | CellCollection | Gets the list of cells in a row of the corner section of a tablix.
Top

See Also

Reference

ITablixCornerRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixCornerRow Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixCornerRow Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixCornerRow Interface

Glossary Item Box

For a list of all members of this type, see ITablixCornerRow members.

Public Properties

 | Name | Description
Property | CellCollection | Gets the list of cells in a row of the corner section of a tablix.
Top

See Also

Reference

ITablixCornerRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


CellCollection Property

[image]
ActiveReports 19 .NET Edition
CellCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixCornerRow Interface : CellCollection Property

Glossary Item Box

Gets the list of cells in a row of the corner section of a tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellCollection As IItemCollection(Of ITablixCornerCell)
C#
IItemCollection<ITablixCornerCell> CellCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the cells in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixCornerRow Interface
ITablixCornerRow Members


ITablixHeader Interface

[image]
ActiveReports 19 .NET Edition
ITablixHeader Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHeader Interface

Glossary Item Box

Represents a group header in a tablix.

Syntax

Visual Basic (Declaration)
Public Interface ITablixHeader
C#
public interface ITablixHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHeader Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixHeader Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixHeader Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHeader Interface

Glossary Item Box

The following tables list the members exposed by ITablixHeader.

Public Properties

 | Name | Description
Property | CellContents | Gets the report item contained in the cell.
Property | Size | Gets the height or width of the group header.
Property | SpanCount | Gets the number of columns for row headers (rows for column headers).
Top

See Also

Reference

ITablixHeader Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixHeader Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixHeader Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHeader Interface

Glossary Item Box

For a list of all members of this type, see ITablixHeader members.

Public Properties

 | Name | Description
Property | CellContents | Gets the report item contained in the cell.
Property | Size | Gets the height or width of the group header.
Property | SpanCount | Gets the number of columns for row headers (rows for column headers).
Top

See Also

Reference

ITablixHeader Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


CellContents Property

[image]
ActiveReports 19 .NET Edition
CellContents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixHeader Interface : CellContents Property

Glossary Item Box

Gets the report item contained in the cell.

Syntax

Visual Basic (Declaration)
ReadOnly Property CellContents As ICellContents
C#
ICellContents CellContents {get;}

Property Value

An ICellContents representing the report item contained in the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHeader Interface
ITablixHeader Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixHeader Interface : Size Property

Glossary Item Box

Gets the height or width of the group header.

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As Length
C#
Length Size {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height or width of the group header.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHeader Interface
ITablixHeader Members


SpanCount Property

[image]
ActiveReports 19 .NET Edition
SpanCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixHeader Interface : SpanCount Property

Glossary Item Box

Gets the number of columns for row headers (rows for column headers).

Syntax

Visual Basic (Declaration)
ReadOnly Property SpanCount As Integer
C#
int SpanCount {get;}

Property Value

An System.Int32 representing the number of columns for row headers or rows for column headers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHeader Interface
ITablixHeader Members


ITablixHierarchy Interface

[image]
ActiveReports 19 .NET Edition
ITablixHierarchy Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHierarchy Interface

Glossary Item Box

Represents rows or columns hierarchy.

Syntax

Visual Basic (Declaration)
Public Interface ITablixHierarchy
C#
public interface ITablixHierarchy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHierarchy Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixHierarchy Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixHierarchy Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHierarchy Interface

Glossary Item Box

The following tables list the members exposed by ITablixHierarchy.

Public Properties

 | Name | Description
Property | LevelSizes | Gets the size (i.e. height for row hierarchy and width for column hierarchy) of each hierarchy level.
Property | MemberCollection | Gets the root members collection.
Top

See Also

Reference

ITablixHierarchy Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixHierarchy Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixHierarchy Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixHierarchy Interface

Glossary Item Box

For a list of all members of this type, see ITablixHierarchy members.

Public Properties

 | Name | Description
Property | LevelSizes | Gets the size (i.e. height for row hierarchy and width for column hierarchy) of each hierarchy level.
Property | MemberCollection | Gets the root members collection.
Top

See Also

Reference

ITablixHierarchy Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


LevelSizes Property

[image]
ActiveReports 19 .NET Edition
LevelSizes Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixHierarchy Interface : LevelSizes Property

Glossary Item Box

Gets the size (i.e. height for row hierarchy and width for column hierarchy) of each hierarchy level.

Syntax

Visual Basic (Declaration)
ReadOnly Property LevelSizes As IItemCollection(Of Integer)
C#
IItemCollection<int> LevelSizes {get;}

Property Value

An item collection representing the size of each hierarchy level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHierarchy Interface
ITablixHierarchy Members


MemberCollection Property

[image]
ActiveReports 19 .NET Edition
MemberCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixHierarchy Interface : MemberCollection Property

Glossary Item Box

Gets the root members collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property MemberCollection As IItemCollection(Of ITablixMember)
C#
IItemCollection<ITablixMember> MemberCollection {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the root members collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixHierarchy Interface
ITablixHierarchy Members


ITablixMember Interface

[image]
ActiveReports 19 .NET Edition
ITablixMember Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixMember Interface

Glossary Item Box

Represents a member in a tablix hierarchy.

Syntax

Visual Basic (Declaration)
Public Interface ITablixMember
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public interface ITablixMember : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixMember Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixMember Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixMember Interface

Glossary Item Box

The following tables list the members exposed by ITablixMember.

Public Properties

 | Name | Description
Property | Children | Gets the children of this tablix member.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets a value that indicates whether this tablix member should be included in the rendered output.
Property | EndSection | Gets the section where the layout should continue.
Property | FixedData | Gets a value indicating whether the tablix member should be kept in the viewing window when the user scrolls the page.
Property | HideIfNoRows | Gets a value indicating whether to hide this tablix member when it contains no rows.
Property | IsAlwaysVisible | Gets a value indicating that the member cannot be hidden by toggle.
Property | IsCollection | Gets a value indicating whether the member is a collection.
Property | IsColumn | Gets a value indicating whether this tablix member is a member of the column (as opposed to row) hierarchy.
Property | IsExtraTotal | Gets a value indicating that the member has been added for interactivity.
Property | IsStatic | Gets a value indicating whether the member is a static member.
Property | IsZeroSpan | Gets a value indicating that the member must be zero span when layout.
Property | KeepTogether | Gets a value indicating whether the data region (all repeated sections) is kept together on one page if possible.
Property | KeepWithGroup | Gets a value indicating whether a static tablix member should be kept on the page with the previous or next non-hidden sibling, if possible.
Property | MemberCellIndex | Gets the cell index for this data region member.
Property | PageBreak | Gets the page breaking options.
Property | PrintFooterAtBottom | Gets a value indicating that these rows should be printed at the bottom of the page.
Property | RenderMembers | Gets a value indicating whether members should be rendered or not.
Property | RepeatOnNewPage | Gets a value indicating whether a static tablix member should be repeated on every page whenever a visible dynamic member sibling with the corresponding KeepWithGroup or its children appear on that page.
Property | TablixHeader | Gets the header cell of the tablix member.
Top

See Also

Reference

ITablixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixMember Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixMember Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixMember Interface

Glossary Item Box

For a list of all members of this type, see ITablixMember members.

Public Properties

 | Name | Description
Property | Children | Gets the children of this tablix member.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets a value that indicates whether this tablix member should be included in the rendered output.
Property | EndSection | Gets the section where the layout should continue.
Property | FixedData | Gets a value indicating whether the tablix member should be kept in the viewing window when the user scrolls the page.
Property | HideIfNoRows | Gets a value indicating whether to hide this tablix member when it contains no rows.
Property | IsAlwaysVisible | Gets a value indicating that the member cannot be hidden by toggle.
Property | IsCollection | Gets a value indicating whether the member is a collection.
Property | IsColumn | Gets a value indicating whether this tablix member is a member of the column (as opposed to row) hierarchy.
Property | IsExtraTotal | Gets a value indicating that the member has been added for interactivity.
Property | IsStatic | Gets a value indicating whether the member is a static member.
Property | IsZeroSpan | Gets a value indicating that the member must be zero span when layout.
Property | KeepTogether | Gets a value indicating whether the data region (all repeated sections) is kept together on one page if possible.
Property | KeepWithGroup | Gets a value indicating whether a static tablix member should be kept on the page with the previous or next non-hidden sibling, if possible.
Property | MemberCellIndex | Gets the cell index for this data region member.
Property | PageBreak | Gets the page breaking options.
Property | PrintFooterAtBottom | Gets a value indicating that these rows should be printed at the bottom of the page.
Property | RenderMembers | Gets a value indicating whether members should be rendered or not.
Property | RepeatOnNewPage | Gets a value indicating whether a static tablix member should be repeated on every page whenever a visible dynamic member sibling with the corresponding KeepWithGroup or its children appear on that page.
Property | TablixHeader | Gets the header cell of the tablix member.
Top

See Also

Reference

ITablixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : Children Property

Glossary Item Box

Gets the children of this tablix member.

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IItemCollection(Of ITablixMember)
C#
IItemCollection<ITablixMember> Children {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the children of this tablix member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : DataElementName Property

Glossary Item Box

Gets the name of the data element.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementName As String
C#
string DataElementName {get;}

Property Value

A System.String representing the name of the data element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : DataElementOutput Property

Glossary Item Box

Gets a value that indicates whether this tablix member should be included in the rendered output.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataElementOutput As DataElementOutput
C#
DataElementOutput DataElementOutput {get;}

Property Value

A DataElementOutput value indicating whether this tablix member should be included in the rendered output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : EndSection Property

Glossary Item Box

Gets the section where the layout should continue.

Syntax

Visual Basic (Declaration)
ReadOnly Property EndSection As EndSection
C#
EndSection EndSection {get;}

Property Value

An EndSection value specifying where the layout should continue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


FixedData Property

[image]
ActiveReports 19 .NET Edition
FixedData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : FixedData Property

Glossary Item Box

Gets a value indicating whether the tablix member should be kept in the viewing window when the user scrolls the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property FixedData As Boolean
C#
bool FixedData {get;}

Property Value

A System.Boolean value indicating whether the tablix member should be kept in the viewing window when the user scrolls the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


HideIfNoRows Property

[image]
ActiveReports 19 .NET Edition
HideIfNoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : HideIfNoRows Property

Glossary Item Box

Gets a value indicating whether to hide this tablix member when it contains no rows.

Syntax

Visual Basic (Declaration)
ReadOnly Property HideIfNoRows As Boolean
C#
bool HideIfNoRows {get;}

Property Value

A System.Boolean value indicating whether to hide this tablix member when it contains no rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsAlwaysVisible Property

[image]
ActiveReports 19 .NET Edition
IsAlwaysVisible Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsAlwaysVisible Property

Glossary Item Box

Gets a value indicating that the member cannot be hidden by toggle.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAlwaysVisible As Boolean
C#
bool IsAlwaysVisible {get;}

Property Value

A System.Boolean value indicating that the member cannot be hidden by toggle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsCollection Property

[image]
ActiveReports 19 .NET Edition
IsCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsCollection Property

Glossary Item Box

Gets a value indicating whether the member is a collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsCollection As Boolean
C#
bool IsCollection {get;}

Property Value

A System.Boolean value indicating whether the member is a collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsColumn Property

[image]
ActiveReports 19 .NET Edition
IsColumn Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsColumn Property

Glossary Item Box

Gets a value indicating whether this tablix member is a member of the column (as opposed to row) hierarchy.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsColumn As Boolean
C#
bool IsColumn {get;}

Property Value

A System.Boolean value indicating whether this tablix member is a member of the column hierarchy.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsExtraTotal Property

[image]
ActiveReports 19 .NET Edition
IsExtraTotal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsExtraTotal Property

Glossary Item Box

Gets a value indicating that the member has been added for interactivity.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsExtraTotal As Boolean
C#
bool IsExtraTotal {get;}

Property Value

A System.Boolean value indicating that the member has been added for interactivity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsStatic Property

Glossary Item Box

Gets a value indicating whether the member is a static member.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Property Value

A System.Boolean value indicating whether the member is a static member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


IsZeroSpan Property

[image]
ActiveReports 19 .NET Edition
IsZeroSpan Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : IsZeroSpan Property

Glossary Item Box

Gets a value indicating that the member must be zero span when layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsZeroSpan As Boolean
C#
bool IsZeroSpan {get;}

Property Value

A System.Boolean value indicating that the member must be zero span when layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the data region (all repeated sections) is kept together on one page if possible.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepTogether As Boolean
C#
bool KeepTogether {get;}

Property Value

A System.Boolean value indicating whether the data region is kept together on one page if possible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


KeepWithGroup Property

[image]
ActiveReports 19 .NET Edition
KeepWithGroup Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : KeepWithGroup Property

Glossary Item Box

Gets a value indicating whether a static tablix member should be kept on the page with the previous or next non-hidden sibling, if possible.

Syntax

Visual Basic (Declaration)
ReadOnly Property KeepWithGroup As KeepWithGroup
C#
KeepWithGroup KeepWithGroup {get;}

Property Value

A KeepWithGroup value indicating whether a static tablix member should be kept on the page with the previous or next non-hidden sibling.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


MemberCellIndex Property

[image]
ActiveReports 19 .NET Edition
MemberCellIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : MemberCellIndex Property

Glossary Item Box

Gets the cell index for this data region member.

Syntax

Visual Basic (Declaration)
ReadOnly Property MemberCellIndex As Integer
C#
int MemberCellIndex {get;}

Property Value

An System.Int32 representing the cell index for this data region member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


PageBreak Property

[image]
ActiveReports 19 .NET Edition
PageBreak Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : PageBreak Property

Glossary Item Box

Gets the page breaking options.

Syntax

Visual Basic (Declaration)
ReadOnly Property PageBreak As PageBreakLocation
C#
PageBreakLocation PageBreak {get;}

Property Value

A GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation value defining the page breaking options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


PrintFooterAtBottom Property

[image]
ActiveReports 19 .NET Edition
PrintFooterAtBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : PrintFooterAtBottom Property

Glossary Item Box

Gets a value indicating that these rows should be printed at the bottom of the page.

Syntax

Visual Basic (Declaration)
ReadOnly Property PrintFooterAtBottom As Boolean
C#
bool PrintFooterAtBottom {get;}

Property Value

A System.Boolean value indicating that these rows should be printed at the bottom of the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


RenderMembers Property

[image]
ActiveReports 19 .NET Edition
RenderMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : RenderMembers Property

Glossary Item Box

Gets a value indicating whether members should be rendered or not.

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderMembers As Boolean
C#
bool RenderMembers {get;}

Property Value

A System.Boolean value indicating whether members should be rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


RepeatOnNewPage Property

[image]
ActiveReports 19 .NET Edition
RepeatOnNewPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : RepeatOnNewPage Property

Glossary Item Box

Gets a value indicating whether a static tablix member should be repeated on every page whenever a visible dynamic member sibling with the corresponding KeepWithGroup or its children appear on that page.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepeatOnNewPage As Boolean
C#
bool RepeatOnNewPage {get;}

Property Value

A System.Boolean value indicating whether a static tablix member should be repeated on every page whenever a visible dynamic member sibling appears on that page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


TablixHeader Property

[image]
ActiveReports 19 .NET Edition
TablixHeader Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixMember Interface : TablixHeader Property

Glossary Item Box

Gets the header cell of the tablix member.

Syntax

Visual Basic (Declaration)
ReadOnly Property TablixHeader As ITablixHeader
C#
ITablixHeader TablixHeader {get;}

Property Value

An ITablixHeader representing the header cell of the tablix member.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixMember Interface
ITablixMember Members


ITablixRow Interface

[image]
ActiveReports 19 .NET Edition
ITablixRow Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixRow Interface

Glossary Item Box

Represents a tablix row that has a list of cells.

Syntax

Visual Basic (Declaration)
Public Interface ITablixRow
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent
C#
public interface ITablixRow : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixRow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixRow Interface Members

[image]
ActiveReports 19 .NET Edition
ITablixRow Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixRow Interface

Glossary Item Box

The following tables list the members exposed by ITablixRow.

Public Properties

 | Name | Description
Property | Cells | Gets the list of cells in a row in the body section of the tablix.
Property | Height | Gets the height of each cell in this row.
Top

See Also

Reference

ITablixRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITablixRow Interface Properties

[image]
ActiveReports 19 .NET Edition
ITablixRow Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITablixRow Interface

Glossary Item Box

For a list of all members of this type, see ITablixRow members.

Public Properties

 | Name | Description
Property | Cells | Gets the list of cells in a row in the body section of the tablix.
Property | Height | Gets the height of each cell in this row.
Top

See Also

Reference

ITablixRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


Cells Property

[image]
ActiveReports 19 .NET Edition
Cells Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixRow Interface : Cells Property

Glossary Item Box

Gets the list of cells in a row in the body section of the tablix.

Syntax

Visual Basic (Declaration)
ReadOnly Property Cells As IItemCollection(Of ITablixCell)
C#
IItemCollection<ITablixCell> Cells {get;}

Property Value

An GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<T> representing the list of cells in the row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixRow Interface
ITablixRow Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITablixRow Interface : Height Property

Glossary Item Box

Gets the height of each cell in this row.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

A GrapeCity.ActiveReports.PageReportModel.Length representing the height of each cell in this row.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITablixRow Interface
ITablixRow Members


ITabStrip Interface

[image]
ActiveReports 19 .NET Edition
ITabStrip Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITabStrip Interface

Glossary Item Box

Represents a tabstrip navigation layout.

Syntax

Visual Basic (Declaration)
Public Interface ITabStrip
C#
public interface ITabStrip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITabStrip Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITabStrip Interface Members

[image]
ActiveReports 19 .NET Edition
ITabStrip Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITabStrip Interface

Glossary Item Box

The following tables list the members exposed by ITabStrip.

Public Properties

 | Name | Description
Property | NavigationItem | Gets the report item or report item reference to use to draw the tabtrip navigation layout.
Property | Slider | Gets the slider settings for the tabstrip.
Top

See Also

Reference

ITabStrip Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


ITabStrip Interface Properties

[image]
ActiveReports 19 .NET Edition
ITabStrip Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace : ITabStrip Interface

Glossary Item Box

For a list of all members of this type, see ITabStrip members.

Public Properties

 | Name | Description
Property | NavigationItem | Gets the report item or report item reference to use to draw the tabtrip navigation layout.
Property | Slider | Gets the slider settings for the tabstrip.
Top

See Also

Reference

ITabStrip Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace


NavigationItem Property

[image]
ActiveReports 19 .NET Edition
NavigationItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITabStrip Interface : NavigationItem Property

Glossary Item Box

Gets the report item or report item reference to use to draw the tabtrip navigation layout.

Syntax

Visual Basic (Declaration)
ReadOnly Property NavigationItem As INavigationItem
C#
INavigationItem NavigationItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITabStrip Interface
ITabStrip Members


Slider Property

[image]
ActiveReports 19 .NET Edition
Slider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Tablix Namespace > ITabStrip Interface : Slider Property

Glossary Item Box

Gets the slider settings for the tabstrip.

Syntax

Visual Basic (Declaration)
ReadOnly Property Slider As ISlider
C#
ISlider Slider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITabStrip Interface
ITabStrip Members


IBookmarkService Interface

[image]
ActiveReports 19 .NET Edition
IBookmarkService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace : IBookmarkService Interface

Glossary Item Box

Interface for TOC bookmarks service.

Syntax

Visual Basic (Declaration)
Public Interface IBookmarkService
C#
public interface IBookmarkService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBookmarkService Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace


IBookmarkService Interface Members

[image]
ActiveReports 19 .NET Edition
IBookmarkService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace : IBookmarkService Interface

Glossary Item Box

The following tables list the members exposed by IBookmarkService.

Public Methods

 | Name | Description
Method | ResolvePageNumber | Resolves page number for specified bookmark.
Top

See Also

Reference

IBookmarkService Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace


IBookmarkService Interface Methods

[image]
ActiveReports 19 .NET Edition
IBookmarkService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace : IBookmarkService Interface

Glossary Item Box

For a list of all members of this type, see IBookmarkService members.

Public Methods

 | Name | Description
Method | ResolvePageNumber | Resolves page number for specified bookmark.
Top

See Also

Reference

IBookmarkService Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace


ResolvePageNumber Method

[image]
ActiveReports 19 .NET Edition
ResolvePageNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC Namespace > IBookmarkService Interface : ResolvePageNumber Method

bookmark
The TOC item bookmark to resolve page number for.

Glossary Item Box

Resolves page number for specified bookmark.

Syntax

Visual Basic (Declaration)
Function ResolvePageNumber( _
   ByVal bookmark As String _
) As Nullable(Of Integer)
C#
Nullable<int> ResolvePageNumber(
   string bookmark
)

Parameters

bookmark
The TOC item bookmark to resolve page number for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBookmarkService Interface
IBookmarkService Members


ImageMapArea Class

[image]
ActiveReports 19 .NET Edition
ImageMapArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapArea Class

Glossary Item Box

Represents an image map area for creating image maps for an image.

Object Model

ImageMapArea Class

Syntax

Visual Basic (Declaration)
Public Class ImageMapArea
C#
public class ImageMapArea

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.ImageMapArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Members
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


ImageMapArea Class Members

[image]
ActiveReports 19 .NET Edition
ImageMapArea Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapArea Class

Glossary Item Box

The following tables list the members exposed by ImageMapArea.

Public Constructors

 | Name | Description
Public Constructor | ImageMapArea Constructor | Initializes a new instance of the ImageMapArea class with specified coordinates, shape, and optional ID.
Top

Public Properties

 | Name | Description
Public Property | Coordinates | Gets the coordinates for this instance.
Public Property | Id | Gets the ID for this instance.
Public Property | Shape | Gets the ImageMapShape this instance represents.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Polygon | Creates a polygonal image map area.
static (Shared in Visual Basic) | Rect | Creates a rectangular image map area.
Top

See Also

Reference

ImageMapArea Class
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


ImageMapArea Constructor

[image]
ActiveReports 19 .NET Edition
ImageMapArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : ImageMapArea Constructor

coordinates
The coordinates defining the area.
shape
The shape of the area.
id
The optional ID of the area.

Glossary Item Box

Initializes a new instance of the ImageMapArea class with specified coordinates, shape, and optional ID.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coordinates() As Single, _
   ByVal shape As ImageMapShape, _
   Optional ByVal id As String _
)
C#
public ImageMapArea(
   float[] coordinates,
   ImageMapShape shape,
   string id
)

Parameters

coordinates
The coordinates defining the area.
shape
The shape of the area.
id
The optional ID of the area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


ImageMapArea Class Methods

[image]
ActiveReports 19 .NET Edition
ImageMapArea Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapArea Class

Glossary Item Box

For a list of all members of this type, see ImageMapArea members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Polygon | Creates a polygonal image map area.
static (Shared in Visual Basic) | Rect | Creates a rectangular image map area.
Top

See Also

Reference

ImageMapArea Class
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


Polygon Method

[image]
ActiveReports 19 .NET Edition
Polygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : Polygon Method

points
The points defining the polygon.

Glossary Item Box

Creates a polygonal image map area.

Syntax

Visual Basic (Declaration)
Public Shared Function Polygon( _
   ByVal points As IList(Of PointF) _
) As ImageMapArea
C#
public static ImageMapArea Polygon(
   IList<PointF> points
)

Parameters

points
The points defining the polygon.

Return Value

A new instance of the ImageMapArea class representing a polygonal area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


Rect Method

[image]
ActiveReports 19 .NET Edition
Rect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : Rect Method

rect
The rectangle defining the area.

Glossary Item Box

Creates a rectangular image map area.

Syntax

Visual Basic (Declaration)
Public Shared Function Rect( _
   ByVal rect As RectangleF _
) As ImageMapArea
C#
public static ImageMapArea Rect(
   RectangleF rect
)

Parameters

rect
The rectangle defining the area.

Return Value

A new instance of the ImageMapArea class representing a rectangular area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


ImageMapArea Class Properties

[image]
ActiveReports 19 .NET Edition
ImageMapArea Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapArea Class

Glossary Item Box

For a list of all members of this type, see ImageMapArea members.

Public Properties

 | Name | Description
Public Property | Coordinates | Gets the coordinates for this instance.
Public Property | Id | Gets the ID for this instance.
Public Property | Shape | Gets the ImageMapShape this instance represents.
Top

See Also

Reference

ImageMapArea Class
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


Coordinates Property

[image]
ActiveReports 19 .NET Edition
Coordinates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : Coordinates Property

Glossary Item Box

Gets the coordinates for this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coordinates As Single()
C#
public float[] Coordinates {get;}

Property Value

An array of System.Single representing the coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : Id Property

Glossary Item Box

Gets the ID for this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As String
C#
public string Id {get;}

Property Value

The ID as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


Shape Property

[image]
ActiveReports 19 .NET Edition
Shape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > ImageMapArea Class : Shape Property

Glossary Item Box

Gets the ImageMapShape this instance represents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shape As ImageMapShape
C#
public ImageMapShape Shape {get;}

Property Value

The shape of the image map area as an ImageMapShape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageMapArea Class
ImageMapArea Members


ImageMapShape Enumeration

[image]
ActiveReports 19 .NET Edition
ImageMapShape Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapShape Enumeration

Glossary Item Box

Specifies shapes used by ImageMapArea

Syntax

Visual Basic (Declaration)
Public Enum ImageMapShape
   Inherits System.Enum
C#
public enum ImageMapShape : System.Enum

Members

Member | Description
Polygon | The shape is a Polygon
Rectangle | The shape is a Rectangle.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.ImageMapShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


FormattedTextException Class

[image]
ActiveReports 19 .NET Edition
FormattedTextException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace : FormattedTextException Class

Glossary Item Box

The exception thrown when an error is caused by an inapplicable value of the control.

Object Model

FormattedTextException Class

Syntax

Visual Basic (Declaration)
Public Class FormattedTextException
   Inherits System.Xml.XmlException
C#
public class FormattedTextException : System.Xml.XmlException

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.Xml.XmlException
GrapeCity.ActiveReports.FormattedText.FormattedTextException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormattedTextException Members
GrapeCity.ActiveReports.FormattedText Namespace


FormattedTextException Class Members

[image]
ActiveReports 19 .NET Edition
FormattedTextException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace : FormattedTextException Class

Glossary Item Box

The following tables list the members exposed by FormattedTextException.

Public Properties

 | Name | Description
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SpecifyErrorMessage | Specifies a custom error message for the exception.
Top

See Also

Reference

FormattedTextException Class
GrapeCity.ActiveReports.FormattedText Namespace


FormattedTextException Class Methods

[image]
ActiveReports 19 .NET Edition
FormattedTextException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace : FormattedTextException Class

Glossary Item Box

For a list of all members of this type, see FormattedTextException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SpecifyErrorMessage | Specifies a custom error message for the exception.
Top

See Also

Reference

FormattedTextException Class
GrapeCity.ActiveReports.FormattedText Namespace


SpecifyErrorMessage Method

[image]
ActiveReports 19 .NET Edition
SpecifyErrorMessage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace > FormattedTextException Class : SpecifyErrorMessage Method

errorMessage
The custom error message.

Glossary Item Box

Specifies a custom error message for the exception.

Syntax

Visual Basic (Declaration)
Public Shared Sub SpecifyErrorMessage( _
   ByVal errorMessage As String _
)
C#
public static void SpecifyErrorMessage(
   string errorMessage
)

Parameters

errorMessage
The custom error message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormattedTextException Class
FormattedTextException Members


FormattedTextException Class Properties

[image]
ActiveReports 19 .NET Edition
FormattedTextException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace : FormattedTextException Class

Glossary Item Box

For a list of all members of this type, see FormattedTextException members.

Public Properties

 | Name | Description
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

See Also

Reference

FormattedTextException Class
GrapeCity.ActiveReports.FormattedText Namespace


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText Namespace > FormattedTextException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormattedTextException Class
FormattedTextException Members


WHtmlChunkWriter Class

[image]
ActiveReports 19 .NET Edition
WHtmlChunkWriter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace : WHtmlChunkWriter Class

Glossary Item Box

Helper renders FormattedText report item to Word Html format.

Object Model

WHtmlChunkWriter Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WHtmlChunkWriter
C#
public static class WHtmlChunkWriter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.FormattedText.Layout.Utils.WHtmlChunkWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WHtmlChunkWriter Members
GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace


WHtmlChunkWriter Class Members

[image]
ActiveReports 19 .NET Edition
WHtmlChunkWriter Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace : WHtmlChunkWriter Class

Glossary Item Box

The following tables list the members exposed by WHtmlChunkWriter.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenerateHtml |
Top

See Also

Reference

WHtmlChunkWriter Class
GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace


WHtmlChunkWriter Class Methods

[image]
ActiveReports 19 .NET Edition
WHtmlChunkWriter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace : WHtmlChunkWriter Class

Glossary Item Box

For a list of all members of this type, see WHtmlChunkWriter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenerateHtml |
Top

See Also

Reference

WHtmlChunkWriter Class
GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace


GenerateHtml Method

[image]
ActiveReports 19 .NET Edition
GenerateHtml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.FormattedText.Layout.Utils Namespace > WHtmlChunkWriter Class : GenerateHtml Method

ftLayoutArea

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GenerateHtml( _
   ByVal ftLayoutArea As ILayoutArea _
) As String
C#
public static string GenerateHtml(
   ILayoutArea ftLayoutArea
)

Parameters

ftLayoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WHtmlChunkWriter Class
WHtmlChunkWriter Members


PageControllerSettings Class

[image]
ActiveReports 19 .NET Edition
PageControllerSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : PageControllerSettings Class

Glossary Item Box

The settings class to be PageController created with.

Object Model

PageControllerSettings Class

Syntax

Visual Basic (Declaration)
Public Class PageControllerSettings
C#
public class PageControllerSettings

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ImageRenderers.PageControl.PageControllerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Members
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


PageControllerSettings Class Members

[image]
ActiveReports 19 .NET Edition
PageControllerSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : PageControllerSettings Class

Glossary Item Box

The following tables list the members exposed by PageControllerSettings.

Public Constructors

 | Name | Description
Public Constructor | PageControllerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EndPage |
Public Property | IsPaginated |
Public Property | MarginBottom |
Public Property | MarginLeft |
Public Property | MarginRight |
Public Property | MarginTop |
Public Property | PageHeight |
Public Property | PageWidth |
Public Property | PrintLayoutMode |
Public Property | SizeToFit | Specifies whether the content width should be adjusted to fit page.
Public Property | StartPage |
Top

See Also

Reference

PageControllerSettings Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


PageControllerSettings Constructor

[image]
ActiveReports 19 .NET Edition
PageControllerSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : PageControllerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageControllerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


PageControllerSettings Class Properties

[image]
ActiveReports 19 .NET Edition
PageControllerSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : PageControllerSettings Class

Glossary Item Box

For a list of all members of this type, see PageControllerSettings members.

Public Properties

 | Name | Description
Public Property | EndPage |
Public Property | IsPaginated |
Public Property | MarginBottom |
Public Property | MarginLeft |
Public Property | MarginRight |
Public Property | MarginTop |
Public Property | PageHeight |
Public Property | PageWidth |
Public Property | PrintLayoutMode |
Public Property | SizeToFit | Specifies whether the content width should be adjusted to fit page.
Public Property | StartPage |
Top

See Also

Reference

PageControllerSettings Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


EndPage Property

[image]
ActiveReports 19 .NET Edition
EndPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : EndPage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property EndPage As Integer
C#
public int EndPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


IsPaginated Property

[image]
ActiveReports 19 .NET Edition
IsPaginated Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : IsPaginated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsPaginated As Boolean
C#
public bool IsPaginated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


MarginBottom Property

[image]
ActiveReports 19 .NET Edition
MarginBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : MarginBottom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MarginBottom As String
C#
public string MarginBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


MarginLeft Property

[image]
ActiveReports 19 .NET Edition
MarginLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : MarginLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MarginLeft As String
C#
public string MarginLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


MarginRight Property

[image]
ActiveReports 19 .NET Edition
MarginRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : MarginRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MarginRight As String
C#
public string MarginRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


MarginTop Property

[image]
ActiveReports 19 .NET Edition
MarginTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : MarginTop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MarginTop As String
C#
public string MarginTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


PageHeight Property

[image]
ActiveReports 19 .NET Edition
PageHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : PageHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PageHeight As String
C#
public string PageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


PageWidth Property

[image]
ActiveReports 19 .NET Edition
PageWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : PageWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PageWidth As String
C#
public string PageWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


PrintLayoutMode Property

[image]
ActiveReports 19 .NET Edition
PrintLayoutMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : PrintLayoutMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PrintLayoutMode As PrintLayoutMode
C#
public PrintLayoutMode PrintLayoutMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


SizeToFit Property

[image]
ActiveReports 19 .NET Edition
SizeToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : SizeToFit Property

Glossary Item Box

Specifies whether the content width should be adjusted to fit page.

Syntax

Visual Basic (Declaration)
Public Property SizeToFit As Boolean
C#
public bool SizeToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


StartPage Property

[image]
ActiveReports 19 .NET Edition
StartPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > PageControllerSettings Class : StartPage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property StartPage As Integer
C#
public int StartPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageControllerSettings Class
PageControllerSettings Members


WatermarkExtensions Class

[image]
ActiveReports 19 .NET Edition
WatermarkExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkExtensions Class

Glossary Item Box

Represents an extension methods for WatermarkSettings.

Object Model

WatermarkExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WatermarkExtensions
C#
public static class WatermarkExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ImageRenderers.PageControl.WatermarkExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkExtensions Members
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


WatermarkExtensions Class Members

[image]
ActiveReports 19 .NET Edition
WatermarkExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkExtensions Class

Glossary Item Box

The following tables list the members exposed by WatermarkExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw |
static (Shared in Visual Basic) | SetSettings |
static (Shared in Visual Basic) | UpdateSettings |
Top

See Also

Reference

WatermarkExtensions Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


WatermarkExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
WatermarkExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkExtensions Class

Glossary Item Box

For a list of all members of this type, see WatermarkExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw |
static (Shared in Visual Basic) | SetSettings |
static (Shared in Visual Basic) | UpdateSettings |
Top

See Also

Reference

WatermarkExtensions Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


Draw Method

[image]
ActiveReports 19 .NET Edition
Draw Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkExtensions Class : Draw Method

settings
canvas
pageSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Draw( _
   ByVal settings As WatermarkSettings, _
   ByVal canvas As IDrawingCanvas, _
   ByVal pageSize As RectangleF _
)
C#
public static void Draw(
   WatermarkSettings settings,
   IDrawingCanvas canvas,
   RectangleF pageSize
)

Parameters

settings
canvas
pageSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkExtensions Class
WatermarkExtensions Members


SetSettings Method

[image]
ActiveReports 19 .NET Edition
SetSettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkExtensions Class : SetSettings Method

settings
data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub SetSettings( _
   ByVal settings As NameValueCollection, _
   ByVal data As WatermarkSettings _
)
C#
public static void SetSettings(
   NameValueCollection settings,
   WatermarkSettings data
)

Parameters

settings
data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkExtensions Class
WatermarkExtensions Members


UpdateSettings Method

[image]
ActiveReports 19 .NET Edition
UpdateSettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkExtensions Class : UpdateSettings Method

collection
settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub UpdateSettings( _
   ByVal collection As NameValueCollection, _
   ByVal settings As WatermarkSettings _
)
C#
public static void UpdateSettings(
   NameValueCollection collection,
   WatermarkSettings settings
)

Parameters

collection
settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkExtensions Class
WatermarkExtensions Members


WatermarkSettings Class

[image]
ActiveReports 19 .NET Edition
WatermarkSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkSettings Class

Glossary Item Box

Represents watermark settings.

Object Model

WatermarkSettings Class

Syntax

Visual Basic (Declaration)
Public Class WatermarkSettings
C#
public class WatermarkSettings

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ImageRenderers.PageControl.WatermarkSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Members
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


WatermarkSettings Class Members

[image]
ActiveReports 19 .NET Edition
WatermarkSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkSettings Class

Glossary Item Box

The following tables list the members exposed by WatermarkSettings.

Public Constructors

 | Name | Description
Public Constructor | WatermarkSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | Color |
Public Property | Font |
Public Property | PrintOnly |
Public Property | Title |
Top

See Also

Reference

WatermarkSettings Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


WatermarkSettings Constructor

[image]
ActiveReports 19 .NET Edition
WatermarkSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : WatermarkSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WatermarkSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


WatermarkSettings Class Properties

[image]
ActiveReports 19 .NET Edition
WatermarkSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : WatermarkSettings Class

Glossary Item Box

For a list of all members of this type, see WatermarkSettings members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | Color |
Public Property | Font |
Public Property | PrintOnly |
Public Property | Title |
Top

See Also

Reference

WatermarkSettings Class
GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : Angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


Font Property

[image]
ActiveReports 19 .NET Edition
Font Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Font As FontInfo
C#
public FontInfo Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


PrintOnly Property

[image]
ActiveReports 19 .NET Edition
PrintOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : PrintOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PrintOnly As Boolean
C#
public bool PrintOnly {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


Title Property

[image]
ActiveReports 19 .NET Edition
Title Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace > WatermarkSettings Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkSettings Class
WatermarkSettings Members


PrintLayoutMode Enumeration

[image]
ActiveReports 19 .NET Edition
PrintLayoutMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace : PrintLayoutMode Enumeration

Glossary Item Box

Specifies the layout modes for rendering pages.

Syntax

Visual Basic (Declaration)
Public Enum PrintLayoutMode
   Inherits System.Enum
C#
public enum PrintLayoutMode : System.Enum

Members

Member | Description
BookletMode | Render logical pages to physical pages in booklet mode.
EightLogicalPagesOnSinglePhysicalPage | Render eight logical pages to single physical page. Rendering appears without additional manipulation.
FourLogicalPagesOnSinglePhysicalPage | Render four logical pages to single physical page. Rendering appears without additional manipulation.
OneLogicalPageOnSinglePhysicalPage | Render one logical page to single physical page. Rendering appears without additional manipulation.
TwoLogicalPagesOnSinglePhysicalPage | Render two logical pages to single physical page. Rendering appears without additional manipulation.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ImageRenderers.PageControl.PrintLayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.ImageRenderers.PageControl Namespace


LayersUtils Class

[image]
ActiveReports 19 .NET Edition
LayersUtils Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayersUtils Class

Glossary Item Box

Layers filtering utilities.

Object Model

LayersUtils Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class LayersUtils
C#
public static class LayersUtils

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Layout.LayersUtils

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayersUtils Members
GrapeCity.ActiveReports.Layout Namespace


LayersUtils Class Members

[image]
ActiveReports 19 .NET Edition
LayersUtils Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayersUtils Class

Glossary Item Box

The following tables list the members exposed by LayersUtils.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsVisible | Checks whether specified report item visible on rendering device
Top

See Also

Reference

LayersUtils Class
GrapeCity.ActiveReports.Layout Namespace


LayersUtils Class Methods

[image]
ActiveReports 19 .NET Edition
LayersUtils Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayersUtils Class

Glossary Item Box

For a list of all members of this type, see LayersUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsVisible | Checks whether specified report item visible on rendering device
Top

See Also

Reference

LayersUtils Class
GrapeCity.ActiveReports.Layout Namespace


IsVisible Method

[image]
ActiveReports 19 .NET Edition
IsVisible Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > LayersUtils Class : IsVisible Method

itemDevice
Target device of report item
renderDevice
Target device of rendering extension

Glossary Item Box

Checks whether specified report item visible on rendering device

Syntax

Visual Basic (Declaration)
Public Shared Function IsVisible( _
   ByVal itemDevice As TargetDeviceKind, _
   ByVal renderDevice As TargetDeviceKind _
) As Boolean
C#
public static bool IsVisible(
   TargetDeviceKind itemDevice,
   TargetDeviceKind renderDevice
)

Parameters

itemDevice
Target device of report item
renderDevice
Target device of rendering extension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayersUtils Class
LayersUtils Members


LayoutEngineFactory Class

[image]
ActiveReports 19 .NET Edition
LayoutEngineFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayoutEngineFactory Class

Glossary Item Box

Provides layout engine factory

Object Model

LayoutEngineFactory Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayoutEngineFactory
   Implements GrapeCity.ActiveReports.Extensibility.Layout.ILayoutEngineFactory
C#
public sealed class LayoutEngineFactory : GrapeCity.ActiveReports.Extensibility.Layout.ILayoutEngineFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Layout.LayoutEngineFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEngineFactory Members
GrapeCity.ActiveReports.Layout Namespace


LayoutEngineFactory Class Members

[image]
ActiveReports 19 .NET Edition
LayoutEngineFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayoutEngineFactory Class

Glossary Item Box

The following tables list the members exposed by LayoutEngineFactory.

Public Constructors

 | Name | Description
Public Constructor | LayoutEngineFactory Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetLayoutEngine | Creates a new instance of layout engine, see also .
Top

See Also

Reference

LayoutEngineFactory Class
GrapeCity.ActiveReports.Layout Namespace


LayoutEngineFactory Constructor

[image]
ActiveReports 19 .NET Edition
LayoutEngineFactory Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > LayoutEngineFactory Class : LayoutEngineFactory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LayoutEngineFactory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEngineFactory Class
LayoutEngineFactory Members


LayoutEngineFactory Class Methods

[image]
ActiveReports 19 .NET Edition
LayoutEngineFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : LayoutEngineFactory Class

Glossary Item Box

For a list of all members of this type, see LayoutEngineFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetLayoutEngine | Creates a new instance of layout engine, see also .
Top

See Also

Reference

LayoutEngineFactory Class
GrapeCity.ActiveReports.Layout Namespace


GetLayoutEngine Method

[image]
ActiveReports 19 .NET Edition
GetLayoutEngine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > LayoutEngineFactory Class : GetLayoutEngine Method

Glossary Item Box

Creates a new instance of layout engine, see also .

Syntax

Visual Basic (Declaration)
Public Shared Function GetLayoutEngine() As ILayoutEngine
C#
public static ILayoutEngine GetLayoutEngine()

Return Value

GrapeCity.ActiveReports.Extensibility.Layout.ILayoutEngine interface to access the layout engine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEngineFactory Class
LayoutEngineFactory Members
ILayoutEngine Interface


Line<T> Class

T
[image]
ActiveReports 19 .NET Edition
Line<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Line<T> Class

Glossary Item Box

Represents the Line.

Object Model

Line<T> Class

Syntax

Visual Basic (Declaration)
Public Class Line(Of T As {New, Struct})
C#
public class Line<T>
where T: new(), struct

Type Parameters

T

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Layout.Line<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line<T> Members
GrapeCity.ActiveReports.Layout Namespace


Line<T> Class Members

[image]
ActiveReports 19 .NET Edition
Line<T> Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Line<T> Class

Glossary Item Box

The following tables list the members exposed by Line<T>.

Public Constructors

 | Name | Description
Public Constructor | Line<T> Constructor | Initializes a new instance of the Line<T> struct.
Top

Public Properties

 | Name | Description
Public Property | P1 | The starting point of the line.
Public Property | P2 | The ending point of the line.
Top

See Also

Reference

Line<T> Class
GrapeCity.ActiveReports.Layout Namespace


Line<T> Constructor

[image]
ActiveReports 19 .NET Edition
Line<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Line<T> Class : Line<T> Constructor

p1
The starting point of the line.
p2
The ending point of the line.

Glossary Item Box

Initializes a new instance of the Line<T> struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p1 As Point(Of T), _
   ByVal p2 As Point(Of T) _
)
C#
public Line<T>(
   Point<T> p1,
   Point<T> p2
)

Parameters

p1
The starting point of the line.
p2
The ending point of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line<T> Class
Line<T> Members


Line<T> Class Properties

[image]
ActiveReports 19 .NET Edition
Line<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Line<T> Class

Glossary Item Box

For a list of all members of this type, see Line<T> members.

Public Properties

 | Name | Description
Public Property | P1 | The starting point of the line.
Public Property | P2 | The ending point of the line.
Top

See Also

Reference

Line<T> Class
GrapeCity.ActiveReports.Layout Namespace


P1 Property

[image]
ActiveReports 19 .NET Edition
P1 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Line<T> Class : P1 Property

Glossary Item Box

The starting point of the line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property P1 As Point(Of T)
C#
public Point<T> P1 {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line<T> Class
Line<T> Members


P2 Property

[image]
ActiveReports 19 .NET Edition
P2 Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Line<T> Class : P2 Property

Glossary Item Box

The ending point of the line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property P2 As Point(Of T)
C#
public Point<T> P2 {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line<T> Class
Line<T> Members


EndSection Enumeration

[image]
ActiveReports 19 .NET Edition
EndSection Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : EndSection Enumeration

Glossary Item Box

Specifies where the layout should continue.

Syntax

Visual Basic (Declaration)
Public Enum EndSection
   Inherits System.Enum
C#
public enum EndSection : System.Enum

Members

Member | Description
None | Continue layout on the current page.
PageBreak | Continue layout on the next page.
PageBreakEven | Continue layout on the next even page.
PageBreakOdd | Continue layout on the next odd page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Layout.EndSection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Layout Namespace


PageInfoStatus Enumeration

[image]
ActiveReports 19 .NET Edition
PageInfoStatus Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : PageInfoStatus Enumeration

Glossary Item Box

Defines status associated with the page information

Syntax

Visual Basic (Declaration)
Public Enum PageInfoStatus
   Inherits System.Enum
C#
public enum PageInfoStatus : System.Enum

Members

Member | Description
Invalid | Invalid value because of error or some other failure
Pending | Not available, evaluation is in progress
Valid | Result has been evaluated

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Layout.PageInfoStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Layout Namespace


GroupOptions Structure

[image]
ActiveReports 19 .NET Edition
GroupOptions Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : GroupOptions Structure

Glossary Item Box

Options for group layout combiner.

Object Model

GroupOptions Structure

Syntax

Visual Basic (Declaration)
Public Structure GroupOptions
   Inherits System.ValueType
C#
public struct GroupOptions : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Layout.GroupOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Members
GrapeCity.ActiveReports.Layout Namespace


GroupOptions Structure Members

[image]
ActiveReports 19 .NET Edition
GroupOptions Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : GroupOptions Structure

Glossary Item Box

The following tables list the members exposed by GroupOptions.

Public Fields

 | Name | Description
Public Field | ParallelismDegree | The parallelism degree.
Public Field | PreventOrphanedFooter | Option to prevent orphaned footer.
Public Field | PreventOrphanedHeader | Option to prevent orphaned header.
Public Field | PreventOrphanStepback | The space to step back in attempt to prevent orphans.
Public Field | PrintFooterAtBottom | Option to print footer at bottom.
Public Field | RepeatFooter | Option to repeat footer.
Public Field | RepeatHeader | Option to repeat header.
Top

Public Properties

 | Name | Description
Public Property | OptimismEnabled | This property is used for 'RepeatHeader' option and defines the behavior when header+body doesn't fit in its place. True means lets try the next page and we'll be lucky.
Top

See Also

Reference

GroupOptions Structure
GrapeCity.ActiveReports.Layout Namespace


GroupOptions Structure Properties

[image]
ActiveReports 19 .NET Edition
GroupOptions Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : GroupOptions Structure

Glossary Item Box

For a list of all members of this type, see GroupOptions members.

Public Properties

 | Name | Description
Public Property | OptimismEnabled | This property is used for 'RepeatHeader' option and defines the behavior when header+body doesn't fit in its place. True means lets try the next page and we'll be lucky.
Top

See Also

Reference

GroupOptions Structure
GrapeCity.ActiveReports.Layout Namespace


OptimismEnabled Property

[image]
ActiveReports 19 .NET Edition
OptimismEnabled Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : OptimismEnabled Property

Glossary Item Box

This property is used for 'RepeatHeader' option and defines the behavior when header+body doesn't fit in its place. True means lets try the next page and we'll be lucky.

Syntax

Visual Basic (Declaration)
Public Property OptimismEnabled As Boolean
C#
public bool OptimismEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


GroupOptions Structure Fields

[image]
ActiveReports 19 .NET Edition
GroupOptions Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : GroupOptions Structure

Glossary Item Box

For a list of all members of this type, see GroupOptions members.

Public Fields

 | Name | Description
Public Field | ParallelismDegree | The parallelism degree.
Public Field | PreventOrphanedFooter | Option to prevent orphaned footer.
Public Field | PreventOrphanedHeader | Option to prevent orphaned header.
Public Field | PreventOrphanStepback | The space to step back in attempt to prevent orphans.
Public Field | PrintFooterAtBottom | Option to print footer at bottom.
Public Field | RepeatFooter | Option to repeat footer.
Public Field | RepeatHeader | Option to repeat header.
Top

See Also

Reference

GroupOptions Structure
GrapeCity.ActiveReports.Layout Namespace


ParallelismDegree Field

[image]
ActiveReports 19 .NET Edition
ParallelismDegree Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : ParallelismDegree Field

Glossary Item Box

The parallelism degree.

Syntax

Visual Basic (Declaration)
Public ParallelismDegree As Integer
C#
public int ParallelismDegree

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


PreventOrphanedFooter Field

[image]
ActiveReports 19 .NET Edition
PreventOrphanedFooter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : PreventOrphanedFooter Field

Glossary Item Box

Option to prevent orphaned footer.

Syntax

Visual Basic (Declaration)
Public PreventOrphanedFooter As Boolean
C#
public bool PreventOrphanedFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


PreventOrphanedHeader Field

[image]
ActiveReports 19 .NET Edition
PreventOrphanedHeader Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : PreventOrphanedHeader Field

Glossary Item Box

Option to prevent orphaned header.

Syntax

Visual Basic (Declaration)
Public PreventOrphanedHeader As Boolean
C#
public bool PreventOrphanedHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


PreventOrphanStepback Field

[image]
ActiveReports 19 .NET Edition
PreventOrphanStepback Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : PreventOrphanStepback Field

Glossary Item Box

The space to step back in attempt to prevent orphans.

Syntax

Visual Basic (Declaration)
Public PreventOrphanStepback As Integer
C#
public int PreventOrphanStepback

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


PrintFooterAtBottom Field

[image]
ActiveReports 19 .NET Edition
PrintFooterAtBottom Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : PrintFooterAtBottom Field

Glossary Item Box

Option to print footer at bottom.

Syntax

Visual Basic (Declaration)
Public PrintFooterAtBottom As Boolean
C#
public bool PrintFooterAtBottom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


RepeatFooter Field

[image]
ActiveReports 19 .NET Edition
RepeatFooter Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : RepeatFooter Field

Glossary Item Box

Option to repeat footer.

Syntax

Visual Basic (Declaration)
Public RepeatFooter As Boolean
C#
public bool RepeatFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


RepeatHeader Field

[image]
ActiveReports 19 .NET Edition
RepeatHeader Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > GroupOptions Structure : RepeatHeader Field

Glossary Item Box

Option to repeat header.

Syntax

Visual Basic (Declaration)
Public RepeatHeader As Boolean
C#
public bool RepeatHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupOptions Structure
GroupOptions Members


PageInfoResult Structure

[image]
ActiveReports 19 .NET Edition
PageInfoResult Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : PageInfoResult Structure

Glossary Item Box

Encapsulates results returned by page information service

Object Model

PageInfoResult Structure

Syntax

Visual Basic (Declaration)
Public Structure PageInfoResult
   Inherits System.ValueType
C#
public struct PageInfoResult : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Layout.PageInfoResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Members
GrapeCity.ActiveReports.Layout Namespace


PageInfoResult Structure Members

[image]
ActiveReports 19 .NET Edition
PageInfoResult Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : PageInfoResult Structure

Glossary Item Box

The following tables list the members exposed by PageInfoResult.

Public Constructors

 | Name | Description
Public Constructor | PageInfoResult Constructor | Initializes result with supplied value and PageInfoStatus.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Invalid | The invalid page info result constant.
Top

Public Properties

 | Name | Description
Public Property | HasValue | Specifies if Value property was assigned
Public Property | Status | Specifies the status of this result.
Public Property | Value | Specifies a value of result returned by page information service
Public Property | ValueIsValid | Specifies that value in this result is valid and completely evaluated
Top

See Also

Reference

PageInfoResult Structure
GrapeCity.ActiveReports.Layout Namespace


PageInfoResult Constructor

[image]
ActiveReports 19 .NET Edition
PageInfoResult Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : PageInfoResult Constructor

value
status
hasValue

Glossary Item Box

Initializes result with supplied value and PageInfoStatus.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Object, _
   ByVal status As PageInfoStatus, _
   ByVal hasValue As Boolean _
)
C#
public PageInfoResult(
   object value,
   PageInfoStatus status,
   bool hasValue
)

Parameters

value
status
hasValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


PageInfoResult Structure Properties

[image]
ActiveReports 19 .NET Edition
PageInfoResult Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : PageInfoResult Structure

Glossary Item Box

For a list of all members of this type, see PageInfoResult members.

Public Properties

 | Name | Description
Public Property | HasValue | Specifies if Value property was assigned
Public Property | Status | Specifies the status of this result.
Public Property | Value | Specifies a value of result returned by page information service
Public Property | ValueIsValid | Specifies that value in this result is valid and completely evaluated
Top

See Also

Reference

PageInfoResult Structure
GrapeCity.ActiveReports.Layout Namespace


HasValue Property

[image]
ActiveReports 19 .NET Edition
HasValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : HasValue Property

Glossary Item Box

Specifies if Value property was assigned

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasValue As Boolean
C#
public bool HasValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


Status Property

[image]
ActiveReports 19 .NET Edition
Status Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : Status Property

Glossary Item Box

Specifies the status of this result.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As PageInfoStatus
C#
public PageInfoStatus Status {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : Value Property

Glossary Item Box

Specifies a value of result returned by page information service

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Remarks

Value may or not be valid depending on the Status

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


ValueIsValid Property

[image]
ActiveReports 19 .NET Edition
ValueIsValid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : ValueIsValid Property

Glossary Item Box

Specifies that value in this result is valid and completely evaluated

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueIsValid As Boolean
C#
public bool ValueIsValid {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


PageInfoResult Structure Fields

[image]
ActiveReports 19 .NET Edition
PageInfoResult Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : PageInfoResult Structure

Glossary Item Box

For a list of all members of this type, see PageInfoResult members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Invalid | The invalid page info result constant.
Top

See Also

Reference

PageInfoResult Structure
GrapeCity.ActiveReports.Layout Namespace


Invalid Field

[image]
ActiveReports 19 .NET Edition
Invalid Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > PageInfoResult Structure : Invalid Field

Glossary Item Box

The invalid page info result constant.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Invalid As PageInfoResult
C#
public static readonly PageInfoResult Invalid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfoResult Structure
PageInfoResult Members


Point<T> Structure

T
[image]
ActiveReports 19 .NET Edition
Point<T> Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Point<T> Structure

Glossary Item Box

Represents the Point.

Object Model

Point<T> Structure

Syntax

Visual Basic (Declaration)
Public Structure Point(Of T As {New, Struct})
   Inherits System.ValueType
C#
public struct Point<T> : System.ValueType
where T: new(), struct

Type Parameters

T

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Layout.Point<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point<T> Members
GrapeCity.ActiveReports.Layout Namespace


Point<T> Structure Members

[image]
ActiveReports 19 .NET Edition
Point<T> Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Point<T> Structure

Glossary Item Box

The following tables list the members exposed by Point<T>.

Public Constructors

 | Name | Description
Public Constructor | Point<T> Constructor | Initialized a new instance of Point struct.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Origin | The instance of Point struct with default for current Type values set for the coordinates.
Top

Public Properties

 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top

See Also

Reference

Point<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Point<T> Constructor

[image]
ActiveReports 19 .NET Edition
Point<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Point<T> Structure : Point<T> Constructor

x
y

Glossary Item Box

Initialized a new instance of Point struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As T, _
   ByVal y As T _
)
C#
public Point<T>(
   T x,
   T y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point<T> Structure
Point<T> Members


Point<T> Structure Properties

[image]
ActiveReports 19 .NET Edition
Point<T> Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Point<T> Structure

Glossary Item Box

For a list of all members of this type, see Point<T> members.

Public Properties

 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top

See Also

Reference

Point<T> Structure
GrapeCity.ActiveReports.Layout Namespace


X Property

[image]
ActiveReports 19 .NET Edition
X Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Point<T> Structure : X Property

Glossary Item Box

Gets or sets the x-coordinate of this Point.

Syntax

Visual Basic (Declaration)
Public Property X As T
C#
public T X {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point<T> Structure
Point<T> Members


Y Property

[image]
ActiveReports 19 .NET Edition
Y Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Point<T> Structure : Y Property

Glossary Item Box

Gets or sets the y-coordinate of this Point.

Syntax

Visual Basic (Declaration)
Public Property Y As T
C#
public T Y {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point<T> Structure
Point<T> Members


Point<T> Structure Fields

[image]
ActiveReports 19 .NET Edition
Point<T> Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Point<T> Structure

Glossary Item Box

For a list of all members of this type, see Point<T> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Origin | The instance of Point struct with default for current Type values set for the coordinates.
Top

See Also

Reference

Point<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Origin Field

[image]
ActiveReports 19 .NET Edition
Origin Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Point<T> Structure : Origin Field

Glossary Item Box

The instance of Point struct with default for current Type values set for the coordinates.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Origin As Point(Of T)
C#
public static readonly Point<T> Origin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point<T> Structure
Point<T> Members


Rect<T> Structure

T
[image]
ActiveReports 19 .NET Edition
Rect<T> Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Rect<T> Structure

Glossary Item Box

Represents the Rect.

Object Model

Rect<T> Structure

Syntax

Visual Basic (Declaration)
Public Structure Rect(Of T As {New, Struct})
   Inherits System.ValueType
C#
public struct Rect<T> : System.ValueType
where T: new(), struct

Type Parameters

T

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Layout.Rect<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Members
GrapeCity.ActiveReports.Layout Namespace


Rect<T> Structure Members

[image]
ActiveReports 19 .NET Edition
Rect<T> Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Rect<T> Structure

Glossary Item Box

The following tables list the members exposed by Rect<T>.

Public Constructors

 | Name | Description
Public Constructor | Rect<T> Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty instance ofthe Rect structure.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets the height of this Rect structure.
Public Property | Left | Gets the x-coordinate of the left edge of this Rect structure.
Public Property | Location | Gets a Point<T> that represents the upper-left corner of the Rect.
Public Property | Size | Gets a Size that represents the width and height of the Rect.
Public Property | Top | Gets the y-coordinate of the top edge of this Rect structure.
Public Property | Width | Gets the width of this Rect structure.
Top

See Also

Reference

Rect<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Rect<T> Constructor

[image]
ActiveReports 19 .NET Edition
Rect<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Rect<T> Constructor

Glossary Item Box

Overload List

Overload | Description
Rect<T> Constructor(T,T,T,T) | Initializes a new instance of the Rect<T> struct.
Rect<T> Constructor(Point<T>,Size<T>) | Initializes a new instance of the Rect<T> struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Rect<T> Constructor(T,T,T,T)

[image]
ActiveReports 19 .NET Edition
Rect<T> Constructor(T,T,T,T)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure > Rect<T> Constructor : Rect<T> Constructor(T,T,T,T)

left
The x-coordinate of the left edge of this Rect structure.
top
The y-coordinate of the top edge of this Rect structure.
width
The width of this Rect structure.
height
the height of this Rect structure.

Glossary Item Box

Initializes a new instance of the Rect<T> struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As T, _
   ByVal top As T, _
   ByVal width As T, _
   ByVal height As T _
)
C#
public Rect<T>(
   T left,
   T top,
   T width,
   T height
)

Parameters

left
The x-coordinate of the left edge of this Rect structure.
top
The y-coordinate of the top edge of this Rect structure.
width
The width of this Rect structure.
height
the height of this Rect structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members
Overload List


Rect<T> Constructor(Point<T>,Size<T>)

[image]
ActiveReports 19 .NET Edition
Rect<T> Constructor(Point<T>,Size<T>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure > Rect<T> Constructor : Rect<T> Constructor(Point<T>,Size<T>)

location
A Point<T> that represents the upper-left corner of the Rect.
size
A Size that represents the width and height of the Rect.

Glossary Item Box

Initializes a new instance of the Rect<T> struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal location As Point(Of T), _
   ByVal size As Size(Of T) _
)
C#
public Rect<T>(
   Point<T> location,
   Size<T> size
)

Parameters

location
A Point<T> that represents the upper-left corner of the Rect.
size
A Size that represents the width and height of the Rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members
Overload List


Rect<T> Structure Properties

[image]
ActiveReports 19 .NET Edition
Rect<T> Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Rect<T> Structure

Glossary Item Box

For a list of all members of this type, see Rect<T> members.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of this Rect structure.
Public Property | Left | Gets the x-coordinate of the left edge of this Rect structure.
Public Property | Location | Gets a Point<T> that represents the upper-left corner of the Rect.
Public Property | Size | Gets a Size that represents the width and height of the Rect.
Public Property | Top | Gets the y-coordinate of the top edge of this Rect structure.
Public Property | Width | Gets the width of this Rect structure.
Top

See Also

Reference

Rect<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Height Property

Glossary Item Box

Gets the height of this Rect structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As T
C#
public T Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Left Property

Glossary Item Box

Gets the x-coordinate of the left edge of this Rect structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As T
C#
public T Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Location Property

[image]
ActiveReports 19 .NET Edition
Location Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Location Property

Glossary Item Box

Gets a Point<T> that represents the upper-left corner of the Rect.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As Point(Of T)
C#
public Point<T> Location {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Size Property

Glossary Item Box

Gets a Size that represents the width and height of the Rect.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size(Of T)
C#
public Size<T> Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Top Property

Glossary Item Box

Gets the y-coordinate of the top edge of this Rect structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As T
C#
public T Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Width Property

Glossary Item Box

Gets the width of this Rect structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As T
C#
public T Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Rect<T> Structure Fields

[image]
ActiveReports 19 .NET Edition
Rect<T> Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Rect<T> Structure

Glossary Item Box

For a list of all members of this type, see Rect<T> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty instance ofthe Rect structure.
Top

See Also

Reference

Rect<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Rect<T> Structure : Empty Field

Glossary Item Box

The empty instance ofthe Rect structure.

Syntax

Visual Basic (Declaration)
Public Shared Empty As Rect(Of T)
C#
public static Rect<T> Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect<T> Structure
Rect<T> Members


Size<T> Structure

T
Type
[image]
ActiveReports 19 .NET Edition
Size<T> Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Size<T> Structure

Glossary Item Box

Represents the Size.

Object Model

Size<T> Structure

Syntax

Visual Basic (Declaration)
Public Structure Size(Of T As {New, Struct})
   Inherits System.ValueType
C#
public struct Size<T> : System.ValueType
where T: new(), struct

Type Parameters

T
Type

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Layout.Size<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size<T> Members
GrapeCity.ActiveReports.Layout Namespace


Size<T> Structure Members

[image]
ActiveReports 19 .NET Edition
Size<T> Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Size<T> Structure

Glossary Item Box

The following tables list the members exposed by Size<T>.

Public Constructors

 | Name | Description
Public Constructor | Size<T> Constructor | Initializes a new instance of the Size<T> struct.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty instance of the Size<T> struct.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the vertical component of this Size<T> struct.
Public Property | Width | Gets or sets the horizontal component of this Size<T> struct.
Top

See Also

Reference

Size<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Size<T> Constructor

[image]
ActiveReports 19 .NET Edition
Size<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Size<T> Structure : Size<T> Constructor

width
The horizontal component of this Size<T> struct.
height
The vertical component of this Size<T> struct.

Glossary Item Box

Initializes a new instance of the Size<T> struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As T, _
   ByVal height As T _
)
C#
public Size<T>(
   T width,
   T height
)

Parameters

width
The horizontal component of this Size<T> struct.
height
The vertical component of this Size<T> struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size<T> Structure
Size<T> Members


Size<T> Structure Properties

[image]
ActiveReports 19 .NET Edition
Size<T> Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Size<T> Structure

Glossary Item Box

For a list of all members of this type, see Size<T> members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the vertical component of this Size<T> struct.
Public Property | Width | Gets or sets the horizontal component of this Size<T> struct.
Top

See Also

Reference

Size<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Size<T> Structure : Height Property

Glossary Item Box

Gets or sets the vertical component of this Size<T> struct.

Syntax

Visual Basic (Declaration)
Public Property Height As T
C#
public T Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size<T> Structure
Size<T> Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Size<T> Structure : Width Property

Glossary Item Box

Gets or sets the horizontal component of this Size<T> struct.

Syntax

Visual Basic (Declaration)
Public Property Width As T
C#
public T Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size<T> Structure
Size<T> Members


Size<T> Structure Fields

[image]
ActiveReports 19 .NET Edition
Size<T> Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : Size<T> Structure

Glossary Item Box

For a list of all members of this type, see Size<T> members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty instance of the Size<T> struct.
Top

See Also

Reference

Size<T> Structure
GrapeCity.ActiveReports.Layout Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > Size<T> Structure : Empty Field

Glossary Item Box

The empty instance of the Size<T> struct.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Size(Of T)
C#
public static readonly Size<T> Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size<T> Structure
Size<T> Members


IPageInformationService Interface

[image]
ActiveReports 19 .NET Edition
IPageInformationService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : IPageInformationService Interface

Glossary Item Box

Defines an interface for communicating pagination information.

Syntax

Visual Basic (Declaration)
Public Interface IPageInformationService
C#
public interface IPageInformationService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Members
GrapeCity.ActiveReports.Layout Namespace


IPageInformationService Interface Members

[image]
ActiveReports 19 .NET Edition
IPageInformationService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : IPageInformationService Interface

Glossary Item Box

The following tables list the members exposed by IPageInformationService.

Public Methods

 | Name | Description
Method | GetCumulativePageCount | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative page count.
Method | GetCumulativePageNumber | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative pagenumber.
Method | GetPageCount | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count.
Method | GetPageCountInSection | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count within the active section.
Method | GetPageNumber | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the pagenumber.
Method | GetPageNumberInSection | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page number within the active section.
Method | GetReportItemsOnCurrentPage | Returns a PageInfoResult whose PageInfoResult.Value will be the report items clollection containing the list of ReportItems on the current page.
Top

See Also

Reference

IPageInformationService Interface
GrapeCity.ActiveReports.Layout Namespace


IPageInformationService Interface Methods

[image]
ActiveReports 19 .NET Edition
IPageInformationService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace : IPageInformationService Interface

Glossary Item Box

For a list of all members of this type, see IPageInformationService members.

Public Methods

 | Name | Description
Method | GetCumulativePageCount | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative page count.
Method | GetCumulativePageNumber | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative pagenumber.
Method | GetPageCount | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count.
Method | GetPageCountInSection | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count within the active section.
Method | GetPageNumber | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the pagenumber.
Method | GetPageNumberInSection | Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page number within the active section.
Method | GetReportItemsOnCurrentPage | Returns a PageInfoResult whose PageInfoResult.Value will be the report items clollection containing the list of ReportItems on the current page.
Top

See Also

Reference

IPageInformationService Interface
GrapeCity.ActiveReports.Layout Namespace


GetCumulativePageCount Method

[image]
ActiveReports 19 .NET Edition
GetCumulativePageCount Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetCumulativePageCount Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative page count.

Syntax

Visual Basic (Declaration)
Function GetCumulativePageCount() As PageInfoResult
C#
PageInfoResult GetCumulativePageCount()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetCumulativePageNumber Method

[image]
ActiveReports 19 .NET Edition
GetCumulativePageNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetCumulativePageNumber Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the cumulative pagenumber.

Syntax

Visual Basic (Declaration)
Function GetCumulativePageNumber() As PageInfoResult
C#
PageInfoResult GetCumulativePageNumber()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetPageCount Method

[image]
ActiveReports 19 .NET Edition
GetPageCount Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetPageCount Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count.

Syntax

Visual Basic (Declaration)
Function GetPageCount() As PageInfoResult
C#
PageInfoResult GetPageCount()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetPageCountInSection Method

[image]
ActiveReports 19 .NET Edition
GetPageCountInSection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetPageCountInSection Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page count within the active section.

Syntax

Visual Basic (Declaration)
Function GetPageCountInSection() As PageInfoResult
C#
PageInfoResult GetPageCountInSection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetPageNumber Method

[image]
ActiveReports 19 .NET Edition
GetPageNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetPageNumber Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the pagenumber.

Syntax

Visual Basic (Declaration)
Function GetPageNumber() As PageInfoResult
C#
PageInfoResult GetPageNumber()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetPageNumberInSection Method

[image]
ActiveReports 19 .NET Edition
GetPageNumberInSection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetPageNumberInSection Method

Glossary Item Box

Returns a PageInfoResult who's PageInfoResult.Value will be an integer representing the page number within the active section.

Syntax

Visual Basic (Declaration)
Function GetPageNumberInSection() As PageInfoResult
C#
PageInfoResult GetPageNumberInSection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


GetReportItemsOnCurrentPage Method

[image]
ActiveReports 19 .NET Edition
GetReportItemsOnCurrentPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Layout Namespace > IPageInformationService Interface : GetReportItemsOnCurrentPage Method

reportItemName
The name of the report item to retrieve.

Glossary Item Box

Returns a PageInfoResult whose PageInfoResult.Value will be the report items clollection containing the list of ReportItems on the current page.

Syntax

Visual Basic (Declaration)
Function GetReportItemsOnCurrentPage( _
   ByVal reportItemName As String _
) As PageInfoResult
C#
PageInfoResult GetReportItemsOnCurrentPage(
   string reportItemName
)

Parameters

reportItemName
The name of the report item to retrieve.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInformationService Interface
IPageInformationService Members


BarcodeGraphicalRenderer Class

[image]
ActiveReports 19 .NET Edition
BarcodeGraphicalRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : BarcodeGraphicalRenderer Class

Glossary Item Box

Provides a GrapeCity.ActiveReports.Drawing.IGraphicsRenderer for GrapeCity.ActiveReports.Rendering.Components.Barcode.Barcode report item.

Object Model

BarcodeGraphicalRenderer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BarcodeGraphicalRenderer
   Implements GrapeCity.ActiveReports.Drawing.IGraphicsRenderer, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer
C#
public sealed class BarcodeGraphicalRenderer : GrapeCity.ActiveReports.Drawing.IGraphicsRenderer, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.BarcodeGraphicalRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeGraphicalRenderer Members
GrapeCity.ActiveReports.Rendering Namespace


BarcodeGraphicalRenderer Class Members

[image]
ActiveReports 19 .NET Edition
BarcodeGraphicalRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : BarcodeGraphicalRenderer Class

Glossary Item Box

The following tables list the members exposed by BarcodeGraphicalRenderer.

Public Methods

 | Name | Description
Public Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext
static (Shared in Visual Basic) | RenderBarcode | Renders the barcode.
Top

See Also

Reference

BarcodeGraphicalRenderer Class
GrapeCity.ActiveReports.Rendering Namespace


BarcodeGraphicalRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
BarcodeGraphicalRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : BarcodeGraphicalRenderer Class

Glossary Item Box

For a list of all members of this type, see BarcodeGraphicalRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext
static (Shared in Visual Basic) | RenderBarcode | Renders the barcode.
Top

See Also

Reference

BarcodeGraphicalRenderer Class
GrapeCity.ActiveReports.Rendering Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > BarcodeGraphicalRenderer Class : Render Method

context
area

Glossary Item Box

Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal context As GraphicsRenderContext, _
   ByVal area As ILayoutArea _
)
C#
public void Render(
   GraphicsRenderContext context,
   ILayoutArea area
)

Parameters

context
area

Remarks

Each GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea represent GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem or its part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeGraphicalRenderer Class
BarcodeGraphicalRenderer Members


RenderBarcode Method

[image]
ActiveReports 19 .NET Edition
RenderBarcode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > BarcodeGraphicalRenderer Class : RenderBarcode Method

barcode
The barcode report item.
bounds
The area in which the barcode (bars, caption, quiet zone) resides.
bgBounds
Background area bounds.
canvas
The drawing canvas to draw upon.
metricsProvider
Text metrics provider.
errorText
The text to be rendered in case of error.

Glossary Item Box

Renders the barcode.

Syntax

Visual Basic (Declaration)
Public Shared Sub RenderBarcode( _
   ByVal barcode As IBarcodeReportItem, _
   ByVal bounds As RectangleF, _
   ByVal bgBounds As RectangleF, _
   ByVal canvas As IDrawingCanvas, _
   ByVal metricsProvider As ITextMetricsProvider, _
   ByVal errorText As String _
)
C#
public static void RenderBarcode(
   IBarcodeReportItem barcode,
   RectangleF bounds,
   RectangleF bgBounds,
   IDrawingCanvas canvas,
   ITextMetricsProvider metricsProvider,
   string errorText
)

Parameters

barcode
The barcode report item.
bounds
The area in which the barcode (bars, caption, quiet zone) resides.
bgBounds
Background area bounds.
canvas
The drawing canvas to draw upon.
metricsProvider
Text metrics provider.
errorText
The text to be rendered in case of error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeGraphicalRenderer Class
BarcodeGraphicalRenderer Members


CustomContextArgs Class

[image]
ActiveReports 19 .NET Edition
CustomContextArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomContextArgs Class

Glossary Item Box

Provides custom context arguments for report processing.

Object Model

CustomContextArgs Class

Syntax

Visual Basic (Declaration)
Public Class CustomContextArgs
C#
public class CustomContextArgs

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.CustomContextArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomContextArgs Members
GrapeCity.ActiveReports.Rendering Namespace


CustomContextArgs Class Members

[image]
ActiveReports 19 .NET Edition
CustomContextArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomContextArgs Class

Glossary Item Box

The following tables list the members exposed by CustomContextArgs.

Public Constructors

 | Name | Description
Public Constructor | CustomContextArgs Constructor | Initializes a new instance of the CustomContextArgs class.
Top

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameters for the report.
Public Property | Report | Gets the report for which the context is being created.
Top

See Also

Reference

CustomContextArgs Class
GrapeCity.ActiveReports.Rendering Namespace


CustomContextArgs Constructor

[image]
ActiveReports 19 .NET Edition
CustomContextArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomContextArgs Class : CustomContextArgs Constructor

report
The report for which the context is being created.
parameters
A lazy-loaded parameters object.

Glossary Item Box

Initializes a new instance of the CustomContextArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   ByVal parameters As Lazy(Of Parameters) _
)
C#
public CustomContextArgs(
   Report report,
   Lazy<Parameters> parameters
)

Parameters

report
The report for which the context is being created.
parameters
A lazy-loaded parameters object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomContextArgs Class
CustomContextArgs Members


CustomContextArgs Class Properties

[image]
ActiveReports 19 .NET Edition
CustomContextArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomContextArgs Class

Glossary Item Box

For a list of all members of this type, see CustomContextArgs members.

Public Properties

 | Name | Description
Public Property | Parameters | Gets the parameters for the report.
Public Property | Report | Gets the report for which the context is being created.
Top

See Also

Reference

CustomContextArgs Class
GrapeCity.ActiveReports.Rendering Namespace


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomContextArgs Class : Parameters Property

Glossary Item Box

Gets the parameters for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomContextArgs Class
CustomContextArgs Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomContextArgs Class : Report Property

Glossary Item Box

Gets the report for which the context is being created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomContextArgs Class
CustomContextArgs Members


CustomReportItemExtension Class

[image]
ActiveReports 19 .NET Edition
CustomReportItemExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomReportItemExtension Class

Glossary Item Box

Provides extension methods for handling custom properties in GrapeCity.ActiveReports.PageReportModel.CustomReportItem objects.

Object Model

CustomReportItemExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CustomReportItemExtension
C#
public static class CustomReportItemExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.CustomReportItemExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Members
GrapeCity.ActiveReports.Rendering Namespace


CustomReportItemExtension Class Members

[image]
ActiveReports 19 .NET Edition
CustomReportItemExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomReportItemExtension Class

Glossary Item Box

The following tables list the members exposed by CustomReportItemExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetCustomPropertyAsBoolean | Gets the custom property value as a boolean.
static (Shared in Visual Basic) | GetCustomPropertyAsEnum<T> | Gets the custom property value as an enum.
static (Shared in Visual Basic) | GetCustomPropertyAsExpression | Gets the custom property value as an expression.
static (Shared in Visual Basic) | GetCustomPropertyAsInteger | Gets the custom property value as an integer.
static (Shared in Visual Basic) | GetCustomPropertyAsString | Gets the custom property value as a string.
static (Shared in Visual Basic) | SetCustomProperty | Overloaded. Sets the custom property value.
Top

See Also

Reference

CustomReportItemExtension Class
GrapeCity.ActiveReports.Rendering Namespace


CustomReportItemExtension Class Methods

[image]
ActiveReports 19 .NET Edition
CustomReportItemExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : CustomReportItemExtension Class

Glossary Item Box

For a list of all members of this type, see CustomReportItemExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetCustomPropertyAsBoolean | Gets the custom property value as a boolean.
static (Shared in Visual Basic) | GetCustomPropertyAsEnum<T> | Gets the custom property value as an enum.
static (Shared in Visual Basic) | GetCustomPropertyAsExpression | Gets the custom property value as an expression.
static (Shared in Visual Basic) | GetCustomPropertyAsInteger | Gets the custom property value as an integer.
static (Shared in Visual Basic) | GetCustomPropertyAsString | Gets the custom property value as a string.
static (Shared in Visual Basic) | SetCustomProperty | Overloaded. Sets the custom property value.
Top

See Also

Reference

CustomReportItemExtension Class
GrapeCity.ActiveReports.Rendering Namespace


GetCustomPropertyAsBoolean Method

[image]
ActiveReports 19 .NET Edition
GetCustomPropertyAsBoolean Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : GetCustomPropertyAsBoolean Method

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Glossary Item Box

Gets the custom property value as a boolean.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomPropertyAsBoolean( _
   ByVal reportItem As CustomReportItem, _
   ByVal propertyName As String, _
   ByVal defaultValue As Boolean _
) As Boolean
C#
public static bool GetCustomPropertyAsBoolean(
   CustomReportItem reportItem,
   string propertyName,
   bool defaultValue
)

Parameters

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Return Value

The custom property value as a boolean, or the default value if the property does not exist or cannot be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


GetCustomPropertyAsEnum<T> Method

T
The enum type.
[image]
ActiveReports 19 .NET Edition
GetCustomPropertyAsEnum<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : GetCustomPropertyAsEnum<T> Method

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Glossary Item Box

Gets the custom property value as an enum.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomPropertyAsEnum(Of T)( _
   ByVal reportItem As CustomReportItem, _
   ByVal propertyName As String, _
   ByVal defaultValue As T _
) As T
C#
public static T GetCustomPropertyAsEnum<T>(
   CustomReportItem reportItem,
   string propertyName,
   T defaultValue
)

Parameters

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Type Parameters

T
The enum type.

Return Value

The custom property value as an enum, or the default value if the property does not exist or cannot be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


GetCustomPropertyAsExpression Method

[image]
ActiveReports 19 .NET Edition
GetCustomPropertyAsExpression Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : GetCustomPropertyAsExpression Method

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist.

Glossary Item Box

Gets the custom property value as an expression.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomPropertyAsExpression( _
   ByVal reportItem As CustomReportItem, _
   ByVal propertyName As String, _
   ByVal defaultValue As ExpressionInfo _
) As ExpressionInfo
C#
public static ExpressionInfo GetCustomPropertyAsExpression(
   CustomReportItem reportItem,
   string propertyName,
   ExpressionInfo defaultValue
)

Parameters

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist.

Return Value

The custom property value as an GrapeCity.Enterprise.Data.Expressions.ExpressionInfo object, or the default value if the property does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


GetCustomPropertyAsInteger Method

[image]
ActiveReports 19 .NET Edition
GetCustomPropertyAsInteger Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : GetCustomPropertyAsInteger Method

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Glossary Item Box

Gets the custom property value as an integer.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomPropertyAsInteger( _
   ByVal reportItem As CustomReportItem, _
   ByVal propertyName As String, _
   ByVal defaultValue As Integer _
) As Integer
C#
public static int GetCustomPropertyAsInteger(
   CustomReportItem reportItem,
   string propertyName,
   int defaultValue
)

Parameters

reportItem
The custom report item.
propertyName
The name of the custom property.
defaultValue
The default value to return if the property does not exist or cannot be converted.

Return Value

The custom property value as an integer, or the default value if the property does not exist or cannot be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


GetCustomPropertyAsString Method

[image]
ActiveReports 19 .NET Edition
GetCustomPropertyAsString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : GetCustomPropertyAsString Method

reportItem
The custom report item.
propertyName
The name of the custom property.

Glossary Item Box

Gets the custom property value as a string.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomPropertyAsString( _
   ByVal reportItem As CustomReportItem, _
   ByVal propertyName As String _
) As String
C#
public static string GetCustomPropertyAsString(
   CustomReportItem reportItem,
   string propertyName
)

Parameters

reportItem
The custom report item.
propertyName
The name of the custom property.

Return Value

The custom property value as a string, or an empty string if the property does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


SetCustomProperty Method

[image]
ActiveReports 19 .NET Edition
SetCustomProperty Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class : SetCustomProperty Method

Glossary Item Box

Sets the custom property value.

Overload List

Overload | Description
SetCustomProperty(CustomReportItem,String,ExpressionInfo) | Sets the custom property value.
SetCustomProperty(CustomReportItem,String,String) | Sets the custom property value as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members


SetCustomProperty(CustomReportItem,String,ExpressionInfo) Method

[image]
ActiveReports 19 .NET Edition
SetCustomProperty(CustomReportItem,String,ExpressionInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class > SetCustomProperty Method : SetCustomProperty(CustomReportItem,String,ExpressionInfo) Method

reportItem
The custom report item.
name
The name of the custom property.
value
The value to set for the custom property.

Glossary Item Box

Sets the custom property value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetCustomProperty( _
   ByVal reportItem As CustomReportItem, _
   ByVal name As String, _
   ByVal value As ExpressionInfo _
)
C#
public static void SetCustomProperty(
   CustomReportItem reportItem,
   string name,
   ExpressionInfo value
)

Parameters

reportItem
The custom report item.
name
The name of the custom property.
value
The value to set for the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members
Overload List


SetCustomProperty(CustomReportItem,String,String) Method

[image]
ActiveReports 19 .NET Edition
SetCustomProperty(CustomReportItem,String,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > CustomReportItemExtension Class > SetCustomProperty Method : SetCustomProperty(CustomReportItem,String,String) Method

reportItem
The custom report item.
name
The name of the custom property.
value
The string value to set for the custom property.

Glossary Item Box

Sets the custom property value as a string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetCustomProperty( _
   ByVal reportItem As CustomReportItem, _
   ByVal name As String, _
   ByVal value As String _
)
C#
public static void SetCustomProperty(
   CustomReportItem reportItem,
   string name,
   string value
)

Parameters

reportItem
The custom report item.
name
The name of the custom property.
value
The string value to set for the custom property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomReportItemExtension Class
CustomReportItemExtension Members
Overload List


DataBuilderException Class

[image]
ActiveReports 19 .NET Edition
DataBuilderException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataBuilderException Class

Glossary Item Box

Exception raised when a report definition is invalid.

Object Model

DataBuilderException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataBuilderException
   Inherits System.Exception
C#
public sealed class DataBuilderException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.DataBuilderException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataBuilderException Members
GrapeCity.ActiveReports.Rendering Namespace


DataBuilderException Class Members

[image]
ActiveReports 19 .NET Edition
DataBuilderException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataBuilderException Class

Glossary Item Box

The following tables list the members exposed by DataBuilderException.

Public Properties

 | Name | Description
Public Property | ErrorCode | The error code.
Top

See Also

Reference

DataBuilderException Class
GrapeCity.ActiveReports.Rendering Namespace


DataBuilderException Class Properties

[image]
ActiveReports 19 .NET Edition
DataBuilderException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataBuilderException Class

Glossary Item Box

For a list of all members of this type, see DataBuilderException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | The error code.
Top

See Also

Reference

DataBuilderException Class
GrapeCity.ActiveReports.Rendering Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataBuilderException Class : ErrorCode Property

Glossary Item Box

The error code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As DataBuilderException.ErrorCodes
C#
public DataBuilderException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataBuilderException Class
DataBuilderException Members


DataProcessingException Class

[image]
ActiveReports 19 .NET Edition
DataProcessingException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataProcessingException Class

Glossary Item Box

Represents data processing exceptions.

Object Model

DataProcessingException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataProcessingException
   Inherits System.Exception
C#
public sealed class DataProcessingException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.DataProcessingException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Members
GrapeCity.ActiveReports.Rendering Namespace


DataProcessingException Class Members

[image]
ActiveReports 19 .NET Edition
DataProcessingException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataProcessingException Class

Glossary Item Box

The following tables list the members exposed by DataProcessingException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with the exception.
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DataProviderNotFound | Creates a new DataProcessingException indicating that the data provider was not found.
static (Shared in Visual Basic) | DataProviderNotSpecified | Creates a new DataProcessingException indicating that the data provider was not specified.
static (Shared in Visual Basic) | SharedDataSourceNotLoaded | Creates a new DataProcessingException indicating that the shared data source could not be loaded.
Top

See Also

Reference

DataProcessingException Class
GrapeCity.ActiveReports.Rendering Namespace


DataProcessingException Class Methods

[image]
ActiveReports 19 .NET Edition
DataProcessingException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataProcessingException Class

Glossary Item Box

For a list of all members of this type, see DataProcessingException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DataProviderNotFound | Creates a new DataProcessingException indicating that the data provider was not found.
static (Shared in Visual Basic) | DataProviderNotSpecified | Creates a new DataProcessingException indicating that the data provider was not specified.
static (Shared in Visual Basic) | SharedDataSourceNotLoaded | Creates a new DataProcessingException indicating that the shared data source could not be loaded.
Top

See Also

Reference

DataProcessingException Class
GrapeCity.ActiveReports.Rendering Namespace


DataProviderNotFound Method

[image]
ActiveReports 19 .NET Edition
DataProviderNotFound Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataProcessingException Class : DataProviderNotFound Method

dataProviderName
The name of the data provider.

Glossary Item Box

Creates a new DataProcessingException indicating that the data provider was not found.

Syntax

Visual Basic (Declaration)
Public Shared Function DataProviderNotFound( _
   ByVal dataProviderName As String _
) As Exception
C#
public static Exception DataProviderNotFound(
   string dataProviderName
)

Parameters

dataProviderName
The name of the data provider.

Return Value

A new instance of DataProcessingException.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Class
DataProcessingException Members


DataProviderNotSpecified Method

[image]
ActiveReports 19 .NET Edition
DataProviderNotSpecified Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataProcessingException Class : DataProviderNotSpecified Method

dataSetName
The name of the data set.

Glossary Item Box

Creates a new DataProcessingException indicating that the data provider was not specified.

Syntax

Visual Basic (Declaration)
Public Shared Function DataProviderNotSpecified( _
   ByVal dataSetName As String _
) As DataProcessingException
C#
public static DataProcessingException DataProviderNotSpecified(
   string dataSetName
)

Parameters

dataSetName
The name of the data set.

Return Value

A new instance of DataProcessingException.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Class
DataProcessingException Members


SharedDataSourceNotLoaded Method

[image]
ActiveReports 19 .NET Edition
SharedDataSourceNotLoaded Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataProcessingException Class : SharedDataSourceNotLoaded Method

dsRef
The reference to the shared data source.

Glossary Item Box

Creates a new DataProcessingException indicating that the shared data source could not be loaded.

Syntax

Visual Basic (Declaration)
Public Shared Function SharedDataSourceNotLoaded( _
   ByVal dsRef As String _
) As DataProcessingException
C#
public static DataProcessingException SharedDataSourceNotLoaded(
   string dsRef
)

Parameters

dsRef
The reference to the shared data source.

Return Value

A new instance of DataProcessingException.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Class
DataProcessingException Members


DataProcessingException Class Properties

[image]
ActiveReports 19 .NET Edition
DataProcessingException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataProcessingException Class

Glossary Item Box

For a list of all members of this type, see DataProcessingException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with the exception.
Public Property | Message | Overridden. Gets a message that describes the current exception.
Top

See Also

Reference

DataProcessingException Class
GrapeCity.ActiveReports.Rendering Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataProcessingException Class : ErrorCode Property

Glossary Item Box

Gets the error code associated with the exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As DataProcessingException.ErrorCodes
C#
public DataProcessingException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Class
DataProcessingException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataProcessingException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessingException Class
DataProcessingException Members


DataTreeBuilder Class

[image]
ActiveReports 19 .NET Edition
DataTreeBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilder Class

Glossary Item Box

Represents a class that implements data retrieval for a given GrapeCity.ActiveReports.PageReportModel.Report object.

Object Model

DataTreeBuilder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataTreeBuilder
C#
public static class DataTreeBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DataTreeBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Members
GrapeCity.ActiveReports.Rendering Namespace


DataTreeBuilder Class Members

[image]
ActiveReports 19 .NET Edition
DataTreeBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilder Class

Glossary Item Box

The following tables list the members exposed by DataTreeBuilder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildData | Builds data for the given ReportStore and other parameters.
static (Shared in Visual Basic) | BuildQuery | Builds a query for the given ReportStore and GrapeCity.ActiveReports.Core.Rendering.Data.SubreportsInfo templates.
static (Shared in Visual Basic) | CreateReportParametersManager | Overloaded. Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.
static (Shared in Visual Basic) | CreateSnapshotEvaluationContext | Creates a snapshot evaluation context.
static (Shared in Visual Basic) | RebuildResultTree | Overloaded. Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.
Top

See Also

Reference

DataTreeBuilder Class
GrapeCity.ActiveReports.Rendering Namespace


DataTreeBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
DataTreeBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilder Class

Glossary Item Box

For a list of all members of this type, see DataTreeBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildData | Builds data for the given ReportStore and other parameters.
static (Shared in Visual Basic) | BuildQuery | Builds a query for the given ReportStore and GrapeCity.ActiveReports.Core.Rendering.Data.SubreportsInfo templates.
static (Shared in Visual Basic) | CreateReportParametersManager | Overloaded. Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.
static (Shared in Visual Basic) | CreateSnapshotEvaluationContext | Creates a snapshot evaluation context.
static (Shared in Visual Basic) | RebuildResultTree | Overloaded. Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.
Top

See Also

Reference

DataTreeBuilder Class
GrapeCity.ActiveReports.Rendering Namespace


BuildData(ReportStore,CancellationToken,Report,DataTreeBuilderConfig,DataParameter[],InteractiveSortState,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

[image]
ActiveReports 19 .NET Edition
BuildData(ReportStore,CancellationToken,Report,DataTreeBuilderConfig,DataParameter[],InteractiveSortState,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class : BuildData(ReportStore,CancellationToken,Report,DataTreeBuilderConfig,DataParameter[],InteractiveSortState,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

reportStore
The report store.
cancel
The cancellation token.
reportQuery
The report query, optional.
config
The data tree builder configuration, optional.
parameters
The data parameters, optional.
sortStates
The interactive sort states, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Glossary Item Box

Builds data for the given ReportStore and other parameters.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildData( _
   ByVal reportStore As ReportStore, _
   ByVal cancel As CancellationToken, _
   Optional ByVal reportQuery As Def.Report, _
   Optional ByVal config As DataTreeBuilderConfig, _
   Optional ByVal parameters() As DataParameter, _
   Optional ByVal sortStates As InteractiveSortState, _
   Optional ByVal reportInfo As IReportInformationService, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As ReportDataSnapshot
C#
public static ReportDataSnapshot BuildData(
   ReportStore reportStore,
   CancellationToken cancel,
   Def.Report reportQuery,
   DataTreeBuilderConfig config,
   DataParameter[] parameters,
   InteractiveSortState sortStates,
   IReportInformationService reportInfo,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

reportStore
The report store.
cancel
The cancellation token.
reportQuery
The report query, optional.
config
The data tree builder configuration, optional.
parameters
The data parameters, optional.
sortStates
The interactive sort states, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Return Value

A GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot containing the built data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members


BuildQuery Method

[image]
ActiveReports 19 .NET Edition
BuildQuery Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class : BuildQuery Method

reportStore
The report store.

Glossary Item Box

Builds a query for the given ReportStore and GrapeCity.ActiveReports.Core.Rendering.Data.SubreportsInfo templates.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildQuery( _
   ByVal reportStore As ReportStore _
) As Def.Report
C#
public static Def.Report BuildQuery(
   ReportStore reportStore
)

Parameters

reportStore
The report store.

Return Value

A GrapeCity.Enterprise.Data.DataEngine.Def.Report object representing the built query.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members


CreateReportParametersManager Method

[image]
ActiveReports 19 .NET Edition
CreateReportParametersManager Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class : CreateReportParametersManager Method

Glossary Item Box

Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.

Overload List

Overload | Description
CreateReportParametersManager(Report,DataParameter[],Boolean,DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) | Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.
CreateReportParametersManager(Report,DataParameter[],DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) | Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members


CreateReportParametersManager(Report,DataParameter[],Boolean,DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

[image]
ActiveReports 19 .NET Edition
CreateReportParametersManager(Report,DataParameter[],Boolean,DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class > CreateReportParametersManager Method : CreateReportParametersManager(Report,DataParameter[],Boolean,DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

report
The report.
parameters
The data parameters.
skipValidValues
Specifies whether to skip valid values.
dataBuilderCfg
The data tree builder configuration, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Glossary Item Box

Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateReportParametersManager( _
   ByVal report As Report, _
   ByVal parameters() As DataParameter, _
   ByVal skipValidValues As Boolean, _
   Optional ByVal dataBuilderCfg As DataTreeBuilderConfig, _
   Optional ByVal reportInfo As IReportInformationService, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As IReportParametersManager
C#
public static IReportParametersManager CreateReportParametersManager(
   Report report,
   DataParameter[] parameters,
   bool skipValidValues,
   DataTreeBuilderConfig dataBuilderCfg,
   IReportInformationService reportInfo,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

report
The report.
parameters
The data parameters.
skipValidValues
Specifies whether to skip valid values.
dataBuilderCfg
The data tree builder configuration, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Return Value

An GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members
Overload List


CreateReportParametersManager(Report,DataParameter[],DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

[image]
ActiveReports 19 .NET Edition
CreateReportParametersManager(Report,DataParameter[],DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class > CreateReportParametersManager Method : CreateReportParametersManager(Report,DataParameter[],DataTreeBuilderConfig,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

report
The report.
parameters
The data parameters.
dataBuilderCfg
The data tree builder configuration, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Glossary Item Box

Creates an GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for a given report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateReportParametersManager( _
   ByVal report As Report, _
   ByVal parameters() As DataParameter, _
   Optional ByVal dataBuilderCfg As DataTreeBuilderConfig, _
   Optional ByVal reportInfo As IReportInformationService, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As IReportParametersManager
C#
public static IReportParametersManager CreateReportParametersManager(
   Report report,
   DataParameter[] parameters,
   DataTreeBuilderConfig dataBuilderCfg,
   IReportInformationService reportInfo,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

report
The report.
parameters
The data parameters.
dataBuilderCfg
The data tree builder configuration, optional.
reportInfo
The report information service, optional.
customContext
The custom context dictionary, optional.

Return Value

An GrapeCity.ActiveReports.Core.Rendering.ReportParameters.IReportParametersManager for the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members
Overload List


CreateSnapshotEvaluationContext Method

[image]
ActiveReports 19 .NET Edition
CreateSnapshotEvaluationContext Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class : CreateSnapshotEvaluationContext Method

report
The report.
parameters
The data parameters.
resourceLocator
The resource locator.
reportInfo
The report information service.
customContext
The custom context dictionary, optional.

Glossary Item Box

Creates a snapshot evaluation context.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateSnapshotEvaluationContext( _
   ByVal report As Report, _
   ByVal parameters() As DataParameter, _
   ByVal resourceLocator As ResourceLocator, _
   ByVal reportInfo As IReportInformationService, _
   ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As IEvaluationContext
C#
public static IEvaluationContext CreateSnapshotEvaluationContext(
   Report report,
   DataParameter[] parameters,
   ResourceLocator resourceLocator,
   IReportInformationService reportInfo,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

report
The report.
parameters
The data parameters.
resourceLocator
The resource locator.
reportInfo
The report information service.
customContext
The custom context dictionary, optional.

Return Value

An GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext for the snapshot.

Remarks

Used by GCES.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members


RebuildResultTree Method

[image]
ActiveReports 19 .NET Edition
RebuildResultTree Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class : RebuildResultTree Method

Glossary Item Box

Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.

Overload List

Overload | Description
RebuildResultTree(ReportDataSnapshot,ReportStore,IExpressionContext,DataParameter[],InteractiveSortState,IReadOnlyDictionary<String,Object>) | Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.
RebuildResultTree(ReportDataSnapshot,DataParameter[],Func<Report,DataParameter[],IExpressionContext>,InteractiveSortState) | Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members


RebuildResultTree(ReportDataSnapshot,ReportStore,IExpressionContext,DataParameter[],InteractiveSortState,IReadOnlyDictionary<String,Object>) Method

[image]
ActiveReports 19 .NET Edition
RebuildResultTree(ReportDataSnapshot,ReportStore,IExpressionContext,DataParameter[],InteractiveSortState,IReadOnlyDictionary<String,Object>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class > RebuildResultTree Method : RebuildResultTree(ReportDataSnapshot,ReportStore,IExpressionContext,DataParameter[],InteractiveSortState,IReadOnlyDictionary<String,Object>) Method

data
The data snapshot.
reportStore
The report store.
rootExpressionContext
The root expression context.
parameters
The data parameters, optional.
sortStates
The interactive sort states, optional.
customContext
The custom context dictionary, optional.

Glossary Item Box

Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function RebuildResultTree( _
   ByVal data As ReportDataSnapshot, _
   ByVal reportStore As ReportStore, _
   ByVal rootExpressionContext As IExpressionContext, _
   Optional ByVal parameters() As DataParameter, _
   Optional ByVal sortStates As InteractiveSortState, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Object) _
) As DataTree.Snapshot(Of Object)
C#
public static DataTree.Snapshot<object> RebuildResultTree(
   ReportDataSnapshot data,
   ReportStore reportStore,
   IExpressionContext rootExpressionContext,
   DataParameter[] parameters,
   InteractiveSortState sortStates,
   IReadOnlyDictionary<string,object> customContext
)

Parameters

data
The data snapshot.
reportStore
The report store.
rootExpressionContext
The root expression context.
parameters
The data parameters, optional.
sortStates
The interactive sort states, optional.
customContext
The custom context dictionary, optional.

Return Value

A rebuilt GrapeCity.Enterprise.Data.DataEngine.DataTree.Snapshot<T>.

Remarks

Used by AR

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members
Overload List


RebuildResultTree(ReportDataSnapshot,DataParameter[],Func<Report,DataParameter[],IExpressionContext>,InteractiveSortState) Method

[image]
ActiveReports 19 .NET Edition
RebuildResultTree(ReportDataSnapshot,DataParameter[],Func<Report,DataParameter[],IExpressionContext>,InteractiveSortState) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilder Class > RebuildResultTree Method : RebuildResultTree(ReportDataSnapshot,DataParameter[],Func<Report,DataParameter[],IExpressionContext>,InteractiveSortState) Method

data
The data snapshot.
parameters
The data parameters.
makeExpressionContext
The function to create expression contexts.
sortState
The interactive sort state.

Glossary Item Box

Rebuilds the result tree of the given GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function RebuildResultTree( _
   ByVal data As ReportDataSnapshot, _
   ByVal parameters() As DataParameter, _
   ByVal makeExpressionContext As Func(Of Def.Report,DataParameter(),IExpressionContext), _
   ByVal sortState As InteractiveSortState _
) As DataTree.Snapshot(Of Object)
C#
public static DataTree.Snapshot<object> RebuildResultTree(
   ReportDataSnapshot data,
   DataParameter[] parameters,
   Func<Def.Report,DataParameter[],IExpressionContext> makeExpressionContext,
   InteractiveSortState sortState
)

Parameters

data
The data snapshot.
parameters
The data parameters.
makeExpressionContext
The function to create expression contexts.
sortState
The interactive sort state.

Return Value

A rebuilt GrapeCity.Enterprise.Data.DataEngine.DataTree.Snapshot<T>.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilder Class
DataTreeBuilder Members
Overload List


DataTreeBuilderConfig Class

[image]
ActiveReports 19 .NET Edition
DataTreeBuilderConfig Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilderConfig Class

Glossary Item Box

Configuration for building the data tree.

Object Model

DataTreeBuilderConfig Class

Syntax

Visual Basic (Declaration)
Public Class DataTreeBuilderConfig
C#
public class DataTreeBuilderConfig

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DataTreeBuilderConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Members
GrapeCity.ActiveReports.Rendering Namespace


DataTreeBuilderConfig Class Members

[image]
ActiveReports 19 .NET Edition
DataTreeBuilderConfig Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilderConfig Class

Glossary Item Box

The following tables list the members exposed by DataTreeBuilderConfig.

Public Constructors

 | Name | Description
Public Constructor | DataTreeBuilderConfig Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the factory for creating data providers.
Public Property | LocateDataSource | Gets or sets the function for locating data sources.
Public Property | PrefetchData | Gets or sets a value indicating whether data should be prefetched.
Public Property | ResolveCredentials | Gets or sets the method for resolving credentials.
Top

See Also

Reference

DataTreeBuilderConfig Class
GrapeCity.ActiveReports.Rendering Namespace


DataTreeBuilderConfig Constructor

[image]
ActiveReports 19 .NET Edition
DataTreeBuilderConfig Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilderConfig Class : DataTreeBuilderConfig Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataTreeBuilderConfig()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Class
DataTreeBuilderConfig Members


DataTreeBuilderConfig Class Properties

[image]
ActiveReports 19 .NET Edition
DataTreeBuilderConfig Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataTreeBuilderConfig Class

Glossary Item Box

For a list of all members of this type, see DataTreeBuilderConfig members.

Public Properties

 | Name | Description
Public Property | DataProviders | Gets or sets the factory for creating data providers.
Public Property | LocateDataSource | Gets or sets the function for locating data sources.
Public Property | PrefetchData | Gets or sets a value indicating whether data should be prefetched.
Public Property | ResolveCredentials | Gets or sets the method for resolving credentials.
Top

See Also

Reference

DataTreeBuilderConfig Class
GrapeCity.ActiveReports.Rendering Namespace


DataProviders Property

[image]
ActiveReports 19 .NET Edition
DataProviders Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilderConfig Class : DataProviders Property

Glossary Item Box

Gets or sets the factory for creating data providers.

Syntax

Visual Basic (Declaration)
Public Property DataProviders As IDataProvidersFactory
C#
public IDataProvidersFactory DataProviders {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Class
DataTreeBuilderConfig Members


LocateDataSource Property

[image]
ActiveReports 19 .NET Edition
LocateDataSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilderConfig Class : LocateDataSource Property

Glossary Item Box

Gets or sets the function for locating data sources.

Syntax

Visual Basic (Declaration)
Public Property LocateDataSource As Func(Of LocateDataSourceArgs,Object)
C#
public Func<LocateDataSourceArgs,object> LocateDataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Class
DataTreeBuilderConfig Members


PrefetchData Property

[image]
ActiveReports 19 .NET Edition
PrefetchData Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilderConfig Class : PrefetchData Property

Glossary Item Box

Gets or sets a value indicating whether data should be prefetched.

Syntax

Visual Basic (Declaration)
Public Property PrefetchData As Boolean
C#
public bool PrefetchData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Class
DataTreeBuilderConfig Members


ResolveCredentials Property

[image]
ActiveReports 19 .NET Edition
ResolveCredentials Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DataTreeBuilderConfig Class : ResolveCredentials Property

Glossary Item Box

Gets or sets the method for resolving credentials.

Syntax

Visual Basic (Declaration)
Public Property ResolveCredentials As ResolveCredentials
C#
public ResolveCredentials ResolveCredentials {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTreeBuilderConfig Class
DataTreeBuilderConfig Members


DocumentMapNode Class

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DocumentMapNode Class

Glossary Item Box

Represents a document map node.

Object Model

DocumentMapNode Class

Syntax

Visual Basic (Declaration)
Public Class DocumentMapNode
C#
public class DocumentMapNode

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DocumentMapNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Members
GrapeCity.ActiveReports.Rendering Namespace


DocumentMapNode Class Members

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DocumentMapNode Class

Glossary Item Box

The following tables list the members exposed by DocumentMapNode.

Public Constructors

 | Name | Description
Public Constructor | DocumentMapNode Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets an empty document map node.
Top

Public Properties

 | Name | Description
Public Property | Bookmark | Gets the bookmark of the document map node.
Public Property | Children | Gets the child nodes of the document map node.
Public Property | Label | Gets the label of the document map node.
Public Property | Levels | Gets the levels of the document map node.
Public Property | Numerics | Gets the numeric elements of the document map node.
Top

See Also

Reference

DocumentMapNode Class
GrapeCity.ActiveReports.Rendering Namespace


DocumentMapNode Constructor

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : DocumentMapNode Constructor

Glossary Item Box

Overload List

Overload | Description
DocumentMapNode Constructor(String,String,Int32[],Int32[],IEnumerable<DocumentMapNode>) | Initializes a new instance of the DocumentMapNode class with the specified properties.
DocumentMapNode Constructor(String,String,Int32[],Int32[],Func<IEnumerable<DocumentMapNode>>) | Initializes a new instance of the DocumentMapNode class with the specified properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


DocumentMapNode Constructor(String,String,Int32[],Int32[],IEnumerable<DocumentMapNode>)

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Constructor(String,String,Int32[],Int32[],IEnumerable<DocumentMapNode>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class > DocumentMapNode Constructor : DocumentMapNode Constructor(String,String,Int32[],Int32[],IEnumerable<DocumentMapNode>)

label
The label of the document map node.
bookmark
The bookmark of the document map node.
levels
The levels of the document map node.
numerics
The numeric elements of the document map node.
children
The child nodes of the document map node.

Glossary Item Box

Initializes a new instance of the DocumentMapNode class with the specified properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String, _
   ByVal bookmark As String, _
   ByVal levels() As Integer, _
   ByVal numerics() As Integer, _
   ByVal children As IEnumerable(Of DocumentMapNode) _
)
C#
public DocumentMapNode(
   string label,
   string bookmark,
   int[] levels,
   int[] numerics,
   IEnumerable<DocumentMapNode> children
)

Parameters

label
The label of the document map node.
bookmark
The bookmark of the document map node.
levels
The levels of the document map node.
numerics
The numeric elements of the document map node.
children
The child nodes of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members
Overload List


DocumentMapNode Constructor(String,String,Int32[],Int32[],Func<IEnumerable<DocumentMapNode>>)

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Constructor(String,String,Int32[],Int32[],Func<IEnumerable<DocumentMapNode>>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class > DocumentMapNode Constructor : DocumentMapNode Constructor(String,String,Int32[],Int32[],Func<IEnumerable<DocumentMapNode>>)

label
The label of the document map node.
bookmark
The bookmark of the document map node.
levels
The levels of the document map node.
numerics
The numeric elements of the document map node.
childrenFn
A function that returns the child nodes of the document map node.

Glossary Item Box

Initializes a new instance of the DocumentMapNode class with the specified properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String, _
   ByVal bookmark As String, _
   ByVal levels() As Integer, _
   ByVal numerics() As Integer, _
   ByVal childrenFn As Func(Of IEnumerable(Of DocumentMapNode)) _
)
C#
public DocumentMapNode(
   string label,
   string bookmark,
   int[] levels,
   int[] numerics,
   Func<IEnumerable<DocumentMapNode>> childrenFn
)

Parameters

label
The label of the document map node.
bookmark
The bookmark of the document map node.
levels
The levels of the document map node.
numerics
The numeric elements of the document map node.
childrenFn
A function that returns the child nodes of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members
Overload List


DocumentMapNode Class Properties

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DocumentMapNode Class

Glossary Item Box

For a list of all members of this type, see DocumentMapNode members.

Public Properties

 | Name | Description
Public Property | Bookmark | Gets the bookmark of the document map node.
Public Property | Children | Gets the child nodes of the document map node.
Public Property | Label | Gets the label of the document map node.
Public Property | Levels | Gets the levels of the document map node.
Public Property | Numerics | Gets the numeric elements of the document map node.
Top

See Also

Reference

DocumentMapNode Class
GrapeCity.ActiveReports.Rendering Namespace


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Bookmark Property

Glossary Item Box

Gets the bookmark of the document map node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As String
C#
public string Bookmark {get;}

Property Value

The bookmark of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


Children Property

[image]
ActiveReports 19 .NET Edition
Children Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Children Property

Glossary Item Box

Gets the child nodes of the document map node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Children As IItemCollection(Of DocumentMapNode)
C#
public IItemCollection<DocumentMapNode> Children {get;}

Property Value

The child nodes of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Label Property

Glossary Item Box

Gets the label of the document map node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As String
C#
public string Label {get;}

Property Value

The label of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


Levels Property

[image]
ActiveReports 19 .NET Edition
Levels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Levels Property

Glossary Item Box

Gets the levels of the document map node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Levels As Integer()
C#
public int[] Levels {get;}

Property Value

The levels of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


Numerics Property

[image]
ActiveReports 19 .NET Edition
Numerics Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Numerics Property

Glossary Item Box

Gets the numeric elements of the document map node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Numerics As Integer()
C#
public int[] Numerics {get;}

Property Value

The numeric elements of the document map node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


DocumentMapNode Class Fields

[image]
ActiveReports 19 .NET Edition
DocumentMapNode Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DocumentMapNode Class

Glossary Item Box

For a list of all members of this type, see DocumentMapNode members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets an empty document map node.
Top

See Also

Reference

DocumentMapNode Class
GrapeCity.ActiveReports.Rendering Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > DocumentMapNode Class : Empty Field

Glossary Item Box

Gets an empty document map node.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As DocumentMapNode
C#
public static readonly DocumentMapNode Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentMapNode Class
DocumentMapNode Members


EngineDataProcessor Class

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor Class

Glossary Item Box

Process data and build GrapeCity.ActiveReports.Core.Rendering.Data.ReportDataSnapshot

Object Model

EngineDataProcessor Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EngineDataProcessor
C#
public static class EngineDataProcessor

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.EngineDataProcessor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor Members
GrapeCity.ActiveReports.Rendering Namespace


EngineDataProcessor Class Members

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor Class

Glossary Item Box

The following tables list the members exposed by EngineDataProcessor.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate |
static (Shared in Visual Basic) | FetchData |
static (Shared in Visual Basic) | MakeEvalFunc | Creates expression evaluator with given evaluation context.
Top

See Also

Reference

EngineDataProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


EngineDataProcessor Class Methods

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor Class

Glossary Item Box

For a list of all members of this type, see EngineDataProcessor members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Evaluate |
static (Shared in Visual Basic) | FetchData |
static (Shared in Visual Basic) | MakeEvalFunc | Creates expression evaluator with given evaluation context.
Top

See Also

Reference

EngineDataProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor Class : Evaluate Method

expr
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Evaluate( _
   ByVal expr As ExpressionInfo, _
   ByVal context As IExpressionContext _
) As Object
C#
public static object Evaluate(
   ExpressionInfo expr,
   IExpressionContext context
)

Parameters

expr
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor Class
EngineDataProcessor Members


FetchData(Report,Func<String,DataExecutionContext>,ResourceLocator,Func<Report,DataParameter[],IExpressionContext>,CancellationToken,DataParameter[],Func<String,Func<LocateDataSourceArgs,Object>>,Func<String,Func<DataSource,LoginPasswordCredentials>>,InteractiveSortState,IDataProvidersFactory) Metho

[image]
ActiveReports 19 .NET Edition
FetchData(Report,Func<String,DataExecutionContext>,ResourceLocator,Func<Report,DataParameter[],IExpressionContext>,CancellationToken,DataParameter[],Func<String,Func<LocateDataSourceArgs,Object>>,Func<String,Func<DataSource,LoginPasswordCredentials>>,InteractiveSortState,IDataProvidersFactory) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor Class : FetchData(Report,Func<String,DataExecutionContext>,ResourceLocator,Func<Report,DataParameter[],IExpressionContext>,CancellationToken,DataParameter[],Func<String,Func<LocateDataSourceArgs,Object>>,Func<String,Func<DataSource,LoginPasswordCredentials>>,InteractiveSortState,IDataProvidersFactory) Method

query
getContext
resourceLocator
makeExpressionContext
token
parameters
locateDataSource
resolveCredentials
sortState
dpf

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function FetchData( _
   ByVal query As Def.Report, _
   ByVal getContext As Func(Of String,EngineDataProcessor.DataExecutionContext), _
   ByVal resourceLocator As ResourceLocator, _
   ByVal makeExpressionContext As Func(Of Def.Report,DataParameter(),IExpressionContext), _
   ByVal token As CancellationToken, _
   ByVal parameters() As DataParameter, _
   ByVal locateDataSource As Func(Of String,Func(Of LocateDataSourceArgs,Object)), _
   ByVal resolveCredentials As Func(Of String,Func(Of DataSource,LoginPasswordCredentials)), _
   Optional ByVal sortState As InteractiveSortState, _
   Optional ByVal dpf As IDataProvidersFactory _
) As ReportDataSnapshot
C#
public static ReportDataSnapshot FetchData(
   Def.Report query,
   Func<string,EngineDataProcessor.DataExecutionContext> getContext,
   ResourceLocator resourceLocator,
   Func<Def.Report,DataParameter[],IExpressionContext> makeExpressionContext,
   CancellationToken token,
   DataParameter[] parameters,
   Func<string,Func<LocateDataSourceArgs,object>> locateDataSource,
   Func<string,Func<DataSource,LoginPasswordCredentials>> resolveCredentials,
   InteractiveSortState sortState,
   IDataProvidersFactory dpf
)

Parameters

query
getContext
resourceLocator
makeExpressionContext
token
parameters
locateDataSource
resolveCredentials
sortState
dpf

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor Class
EngineDataProcessor Members


MakeEvalFunc Method

[image]
ActiveReports 19 .NET Edition
MakeEvalFunc Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor Class : MakeEvalFunc Method

context
Specifies custom evaluation context.

Glossary Item Box

Creates expression evaluator with given evaluation context.

Syntax

Visual Basic (Declaration)
Public Shared Function MakeEvalFunc( _
   ByVal context As IExpressionContext _
) As Func(Of ExpressionInfo,Object)
C#
public static Func<ExpressionInfo,object> MakeEvalFunc(
   IExpressionContext context
)

Parameters

context
Specifies custom evaluation context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor Class
EngineDataProcessor Members


EngineDataProcessor.DataExecutionContext Class

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor.DataExecutionContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor.DataExecutionContext Class

Glossary Item Box

Environment for data execution.

Object Model

EngineDataProcessor.DataExecutionContext Class

Syntax

Visual Basic (Declaration)
Public Class EngineDataProcessor.DataExecutionContext
C#
public class EngineDataProcessor.DataExecutionContext

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.EngineDataProcessor.DataExecutionContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor.DataExecutionContext Members
GrapeCity.ActiveReports.Rendering Namespace


EngineDataProcessor.DataExecutionContext Class Members

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor.DataExecutionContext Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor.DataExecutionContext Class

Glossary Item Box

The following tables list the members exposed by EngineDataProcessor.DataExecutionContext.

Public Constructors

 | Name | Description
Public Constructor | EngineDataProcessor.DataExecutionContext Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSets | DataSets
Public Property | DataSources | DataSources
Public Property | ReportParameters | ReportParameters
Top

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
GrapeCity.ActiveReports.Rendering Namespace


EngineDataProcessor.DataExecutionContext Constructor

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor.DataExecutionContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor.DataExecutionContext Class : EngineDataProcessor.DataExecutionContext Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EngineDataProcessor.DataExecutionContext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
EngineDataProcessor.DataExecutionContext Members


EngineDataProcessor.DataExecutionContext Class Properties

[image]
ActiveReports 19 .NET Edition
EngineDataProcessor.DataExecutionContext Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : EngineDataProcessor.DataExecutionContext Class

Glossary Item Box

For a list of all members of this type, see EngineDataProcessor.DataExecutionContext members.

Public Properties

 | Name | Description
Public Property | DataSets | DataSets
Public Property | DataSources | DataSources
Public Property | ReportParameters | ReportParameters
Top

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
GrapeCity.ActiveReports.Rendering Namespace


DataSets Property

[image]
ActiveReports 19 .NET Edition
DataSets Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor.DataExecutionContext Class : DataSets Property

Glossary Item Box

DataSets

Syntax

Visual Basic (Declaration)
Public Property DataSets As DataSet()
C#
public DataSet[] DataSets {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
EngineDataProcessor.DataExecutionContext Members


DataSources Property

[image]
ActiveReports 19 .NET Edition
DataSources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor.DataExecutionContext Class : DataSources Property

Glossary Item Box

DataSources

Syntax

Visual Basic (Declaration)
Public Property DataSources As DataSource()
C#
public DataSource[] DataSources {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
EngineDataProcessor.DataExecutionContext Members


ReportParameters Property

[image]
ActiveReports 19 .NET Edition
ReportParameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > EngineDataProcessor.DataExecutionContext Class : ReportParameters Property

Glossary Item Box

ReportParameters

Syntax

Visual Basic (Declaration)
Public Property ReportParameters As ReportParameter()
C#
public ReportParameter[] ReportParameters {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EngineDataProcessor.DataExecutionContext Class
EngineDataProcessor.DataExecutionContext Members


GraphicalUtils Class

[image]
ActiveReports 19 .NET Edition
GraphicalUtils Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils Class

Glossary Item Box

Provisional methods and helpers supporting rendering on GrapeCity.ActiveReports.Drawing.IDrawingCanvas Utility methods to help to obtain right string format for line breaking.

Object Model

GraphicalUtils Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class GraphicalUtils
C#
public static class GraphicalUtils

Remarks

Made public temporarily to aid FormattedTextGraphicalRendererThis class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalUtils

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Members
GrapeCity.ActiveReports.Rendering Namespace


GraphicalUtils Class Members

[image]
ActiveReports 19 .NET Edition
GraphicalUtils Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils Class

Glossary Item Box

The following tables list the members exposed by GraphicalUtils.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultBackgroundColor | Specifies a default background color
static (Shared in Visual Basic) | SortingImageHeight |
static (Shared in Visual Basic) | SortingImageTextSpacing |
static (Shared in Visual Basic) | SortingImageWidth |
Public Field | TocPageNumberHolder |
static (Shared in Visual Basic) | ToggleImageHeight |
static (Shared in Visual Basic) | ToggleImageLeftOffset |
static (Shared in Visual Basic) | ToggleImageTopOffset |
static (Shared in Visual Basic) | ToggleImageWidth |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBrush | Overloaded.
static (Shared in Visual Basic) | DashStyleFromString | Returns GrapeCity.ActiveReports.Drawing.PenStyleEx value from a specified string designating dash style.
static (Shared in Visual Basic) | DrawDoubleLine |
static (Shared in Visual Basic) | DrawLine | Overloaded. Draws line of the specified width, color, style and alignment
static (Shared in Visual Basic) | FillBackground |
static (Shared in Visual Basic) | GetNumberOfColumns |
static (Shared in Visual Basic) | GetNumberOfRows |
static (Shared in Visual Basic) | IntersectClip |
static (Shared in Visual Basic) | RenderFrame | Renders a frame and background for layout area according to the specified parameters
Top

See Also

Reference

GraphicalUtils Class
GrapeCity.ActiveReports.Rendering Namespace


GraphicalUtils Class Methods

[image]
ActiveReports 19 .NET Edition
GraphicalUtils Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils Class

Glossary Item Box

For a list of all members of this type, see GraphicalUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBrush | Overloaded.
static (Shared in Visual Basic) | DashStyleFromString | Returns GrapeCity.ActiveReports.Drawing.PenStyleEx value from a specified string designating dash style.
static (Shared in Visual Basic) | DrawDoubleLine |
static (Shared in Visual Basic) | DrawLine | Overloaded. Draws line of the specified width, color, style and alignment
static (Shared in Visual Basic) | FillBackground |
static (Shared in Visual Basic) | GetNumberOfColumns |
static (Shared in Visual Basic) | GetNumberOfRows |
static (Shared in Visual Basic) | IntersectClip |
static (Shared in Visual Basic) | RenderFrame | Renders a frame and background for layout area according to the specified parameters
Top

See Also

Reference

GraphicalUtils Class
GrapeCity.ActiveReports.Rendering Namespace


CreateBrush Method

[image]
ActiveReports 19 .NET Edition
CreateBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : CreateBrush Method

Glossary Item Box

Overload List

Overload | Description
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Boolean) |
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double) |
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double,Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


CreateBrush(IDrawingCanvas,IStyle,RectangleF,Boolean) Method

[image]
ActiveReports 19 .NET Edition
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class > CreateBrush Method : CreateBrush(IDrawingCanvas,IStyle,RectangleF,Boolean) Method

canvas
style
boundRectEx
backgroundExist

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateBrush( _
   ByVal canvas As IDrawingCanvas, _
   ByVal style As IStyle, _
   ByVal boundRectEx As RectangleF, _
   ByRef backgroundExist As Boolean _
) As BrushEx
C#
public static BrushEx CreateBrush(
   IDrawingCanvas canvas,
   IStyle style,
   RectangleF boundRectEx,
   out bool backgroundExist
)

Parameters

canvas
style
boundRectEx
backgroundExist

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members
Overload List


CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double) Method

[image]
ActiveReports 19 .NET Edition
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class > CreateBrush Method : CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double) Method

canvas
style
boundRectEx
transparency

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateBrush( _
   ByVal canvas As IDrawingCanvas, _
   ByVal style As IStyle, _
   ByVal boundRectEx As RectangleF, _
   ByVal transparency As Double _
) As BrushEx
C#
public static BrushEx CreateBrush(
   IDrawingCanvas canvas,
   IStyle style,
   RectangleF boundRectEx,
   double transparency
)

Parameters

canvas
style
boundRectEx
transparency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members
Overload List


CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double,Boolean) Method

[image]
ActiveReports 19 .NET Edition
CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class > CreateBrush Method : CreateBrush(IDrawingCanvas,IStyle,RectangleF,Double,Boolean) Method

canvas
style
boundRectEx
transparency
backgroundExist

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateBrush( _
   ByVal canvas As IDrawingCanvas, _
   ByVal style As IStyle, _
   ByVal boundRectEx As RectangleF, _
   ByVal transparency As Double, _
   ByRef backgroundExist As Boolean _
) As BrushEx
C#
public static BrushEx CreateBrush(
   IDrawingCanvas canvas,
   IStyle style,
   RectangleF boundRectEx,
   double transparency,
   out bool backgroundExist
)

Parameters

canvas
style
boundRectEx
transparency
backgroundExist

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members
Overload List


DashStyleFromString Method

[image]
ActiveReports 19 .NET Edition
DashStyleFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : DashStyleFromString Method

style

Glossary Item Box

Returns GrapeCity.ActiveReports.Drawing.PenStyleEx value from a specified string designating dash style.

Syntax

Visual Basic (Declaration)
Public Shared Function DashStyleFromString( _
   ByVal style As String _
) As Nullable(Of PenStyleEx)
C#
public static Nullable<PenStyleEx> DashStyleFromString(
   string style
)

Parameters

style

Remarks

Valid style are Solid, Dotted and Dashed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


DrawDoubleLine Method

[image]
ActiveReports 19 .NET Edition
DrawDoubleLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : DrawDoubleLine Method

canvas
width
color
from
to

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawDoubleLine( _
   ByVal canvas As IDrawingCanvas, _
   ByVal width As Single, _
   ByVal color As Color, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
public static void DrawDoubleLine(
   IDrawingCanvas canvas,
   float width,
   Color color,
   PointF from,
   PointF to
)

Parameters

canvas
width
color
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : DrawLine Method

Glossary Item Box

Draws line of the specified width, color, style and alignment

Overload List

Overload | Description
DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PenAlignment,PointF,PointF) | Draws line of the specified width, color, style and alignment
DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PointF,PointF,PenAlignment,LineCap,LineCap) | Draws line of the specified width, color, style, line caps and alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PenAlignment,PointF,PointF) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PenAlignment,PointF,PointF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class > DrawLine Method : DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PenAlignment,PointF,PointF) Method

canvas
width
color
styleEx
alignment
from
to

Glossary Item Box

Draws line of the specified width, color, style and alignment

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub DrawLine( _
   ByVal canvas As IDrawingCanvas, _
   ByVal width As Single, _
   ByVal color As Color, _
   ByVal styleEx As PenStyleEx, _
   ByVal alignment As PenAlignment, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
public static void DrawLine(
   IDrawingCanvas canvas,
   float width,
   Color color,
   PenStyleEx styleEx,
   PenAlignment alignment,
   PointF from,
   PointF to
)

Parameters

canvas
width
color
styleEx
alignment
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members
Overload List


DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PointF,PointF,PenAlignment,LineCap,LineCap) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PointF,PointF,PenAlignment,LineCap,LineCap) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class > DrawLine Method : DrawLine(IDrawingCanvas,Single,Color,PenStyleEx,PointF,PointF,PenAlignment,LineCap,LineCap) Method

canvas
width
color
styleEx
from
to
alignment
startCap
endCap

Glossary Item Box

Draws line of the specified width, color, style, line caps and alignment

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub DrawLine( _
   ByVal canvas As IDrawingCanvas, _
   ByVal width As Single, _
   ByVal color As Color, _
   ByVal styleEx As PenStyleEx, _
   ByVal from As PointF, _
   ByVal to As PointF, _
   ByVal alignment As PenAlignment, _
   ByVal startCap As LineCap, _
   ByVal endCap As LineCap _
)
C#
public static void DrawLine(
   IDrawingCanvas canvas,
   float width,
   Color color,
   PenStyleEx styleEx,
   PointF from,
   PointF to,
   PenAlignment alignment,
   LineCap startCap,
   LineCap endCap
)

Parameters

canvas
width
color
styleEx
from
to
alignment
startCap
endCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members
Overload List


FillBackground(ImageInfo,IDrawingCanvas,RectangleF,BackgroundRepeatOption,ITextMetricsProvider,ResourceLocator) Method

[image]
ActiveReports 19 .NET Edition
FillBackground(ImageInfo,IDrawingCanvas,RectangleF,BackgroundRepeatOption,ITextMetricsProvider,ResourceLocator) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : FillBackground(ImageInfo,IDrawingCanvas,RectangleF,BackgroundRepeatOption,ITextMetricsProvider,ResourceLocator) Method

drawImage
canvas
area
repeatOption
textMetrics
resourceLocator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub FillBackground( _
   ByVal drawImage As ImageInfo, _
   ByVal canvas As IDrawingCanvas, _
   ByVal area As RectangleF, _
   ByVal repeatOption As BackgroundRepeatOption, _
   Optional ByVal textMetrics As ITextMetricsProvider, _
   Optional ByVal resourceLocator As ResourceLocator _
)
C#
public static void FillBackground(
   ImageInfo drawImage,
   IDrawingCanvas canvas,
   RectangleF area,
   BackgroundRepeatOption repeatOption,
   ITextMetricsProvider textMetrics,
   ResourceLocator resourceLocator
)

Parameters

drawImage
canvas
area
repeatOption
textMetrics
resourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


GetNumberOfColumns Method

[image]
ActiveReports 19 .NET Edition
GetNumberOfColumns Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : GetNumberOfColumns Method

repeatOption
areaWidth
imageWidth

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetNumberOfColumns( _
   ByVal repeatOption As BackgroundRepeatOption, _
   ByVal areaWidth As Single, _
   ByVal imageWidth As Single _
) As Integer
C#
public static int GetNumberOfColumns(
   BackgroundRepeatOption repeatOption,
   float areaWidth,
   float imageWidth
)

Parameters

repeatOption
areaWidth
imageWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


GetNumberOfRows Method

[image]
ActiveReports 19 .NET Edition
GetNumberOfRows Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : GetNumberOfRows Method

repeatOption
areaHeight
imageHeight

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetNumberOfRows( _
   ByVal repeatOption As BackgroundRepeatOption, _
   ByVal areaHeight As Single, _
   ByVal imageHeight As Single _
) As Integer
C#
public static int GetNumberOfRows(
   BackgroundRepeatOption repeatOption,
   float areaHeight,
   float imageHeight
)

Parameters

repeatOption
areaHeight
imageHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : IntersectClip Method

canvas
clip

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub IntersectClip( _
   ByVal canvas As IDrawingCanvas, _
   ByVal clip As GraphicalUtils.Clip _
)
C#
public static void IntersectClip(
   IDrawingCanvas canvas,
   GraphicalUtils.Clip clip
)

Parameters

canvas
clip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


RenderFrame Method

[image]
ActiveReports 19 .NET Edition
RenderFrame Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : RenderFrame Method

context
area
doBackground
doBorders

Glossary Item Box

Renders a frame and background for layout area according to the specified parameters

Syntax

Visual Basic (Declaration)
Public Shared Function RenderFrame( _
   ByVal context As GraphicsRenderContext, _
   ByVal area As ILayoutArea, _
   ByVal doBackground As Boolean, _
   ByVal doBorders As Boolean _
) As GraphicalUtils.Clip
C#
public static GraphicalUtils.Clip RenderFrame(
   GraphicsRenderContext context,
   ILayoutArea area,
   bool doBackground,
   bool doBorders
)

Parameters

context
area
doBackground
doBorders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


GraphicalUtils Class Fields

[image]
ActiveReports 19 .NET Edition
GraphicalUtils Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils Class

Glossary Item Box

For a list of all members of this type, see GraphicalUtils members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultBackgroundColor | Specifies a default background color
static (Shared in Visual Basic) | SortingImageHeight |
static (Shared in Visual Basic) | SortingImageTextSpacing |
static (Shared in Visual Basic) | SortingImageWidth |
Public Field | TocPageNumberHolder |
static (Shared in Visual Basic) | ToggleImageHeight |
static (Shared in Visual Basic) | ToggleImageLeftOffset |
static (Shared in Visual Basic) | ToggleImageTopOffset |
static (Shared in Visual Basic) | ToggleImageWidth |
Top

See Also

Reference

GraphicalUtils Class
GrapeCity.ActiveReports.Rendering Namespace


DefaultBackgroundColor Field

[image]
ActiveReports 19 .NET Edition
DefaultBackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : DefaultBackgroundColor Field

Glossary Item Box

Specifies a default background color

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultBackgroundColor As Color
C#
public static readonly Color DefaultBackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


SortingImageHeight Field

[image]
ActiveReports 19 .NET Edition
SortingImageHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : SortingImageHeight Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SortingImageHeight As Single
C#
public static readonly float SortingImageHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


SortingImageTextSpacing Field

[image]
ActiveReports 19 .NET Edition
SortingImageTextSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : SortingImageTextSpacing Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SortingImageTextSpacing As Single
C#
public static readonly float SortingImageTextSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


SortingImageWidth Field

[image]
ActiveReports 19 .NET Edition
SortingImageWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : SortingImageWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SortingImageWidth As Single
C#
public static readonly float SortingImageWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


TocPageNumberHolder Field

[image]
ActiveReports 19 .NET Edition
TocPageNumberHolder Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : TocPageNumberHolder Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const TocPageNumberHolder As String
C#
public const string TocPageNumberHolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


ToggleImageHeight Field

[image]
ActiveReports 19 .NET Edition
ToggleImageHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : ToggleImageHeight Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ToggleImageHeight As Single
C#
public static readonly float ToggleImageHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


ToggleImageLeftOffset Field

[image]
ActiveReports 19 .NET Edition
ToggleImageLeftOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : ToggleImageLeftOffset Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ToggleImageLeftOffset As Single
C#
public static readonly float ToggleImageLeftOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


ToggleImageTopOffset Field

[image]
ActiveReports 19 .NET Edition
ToggleImageTopOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : ToggleImageTopOffset Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ToggleImageTopOffset As Single
C#
public static readonly float ToggleImageTopOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


ToggleImageWidth Field

[image]
ActiveReports 19 .NET Edition
ToggleImageWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils Class : ToggleImageWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ToggleImageWidth As Single
C#
public static readonly float ToggleImageWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils Class
GraphicalUtils Members


GraphicalUtils.Clip Class

[image]
ActiveReports 19 .NET Edition
GraphicalUtils.Clip Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils.Clip Class

Glossary Item Box

Object Model

GraphicalUtils.Clip Class

Syntax

Visual Basic (Declaration)
Public Class GraphicalUtils.Clip
C#
public class GraphicalUtils.Clip

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalUtils.Clip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils.Clip Members
GrapeCity.ActiveReports.Rendering Namespace


GraphicalUtils.Clip Class Members

[image]
ActiveReports 19 .NET Edition
GraphicalUtils.Clip Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils.Clip Class

Glossary Item Box

The following tables list the members exposed by GraphicalUtils.Clip.

Public Properties

 | Name | Description
Public Property | Path |
Public Property | Rect |
Top

Public Operators

public Operator Implicit Type Conversion Overloaded.
Top

See Also

Reference

GraphicalUtils.Clip Class
GrapeCity.ActiveReports.Rendering Namespace


GraphicalUtils.Clip Class Properties

[image]
ActiveReports 19 .NET Edition
GraphicalUtils.Clip Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : GraphicalUtils.Clip Class

Glossary Item Box

For a list of all members of this type, see GraphicalUtils.Clip members.

Public Properties

 | Name | Description
Public Property | Path |
Public Property | Rect |
Top

See Also

Reference

GraphicalUtils.Clip Class
GrapeCity.ActiveReports.Rendering Namespace


Path Property

[image]
ActiveReports 19 .NET Edition
Path Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils.Clip Class : Path Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As PathEx
C#
public PathEx Path {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils.Clip Class
GraphicalUtils.Clip Members


Rect Property

[image]
ActiveReports 19 .NET Edition
Rect Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils.Clip Class : Rect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rect As RectangleF
C#
public RectangleF Rect {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils.Clip Class
GraphicalUtils.Clip Members


Implicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > GraphicalUtils.Clip Class : Implicit Type Conversion Operator

Glossary Item Box

Overload List

Overload | Description
Implicit Type Conversion(Clip,RectangleF) |
Implicit Type Conversion(Clip,PathEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicalUtils.Clip Class
GraphicalUtils.Clip Members


LocateDataSourceArgs Class

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : LocateDataSourceArgs Class

Glossary Item Box

Provides data for the DataProviders used in DataTreeBuilder.

Object Model

LocateDataSourceArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateDataSourceArgs
C#
public sealed class LocateDataSourceArgs

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.LocateDataSourceArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Members
GrapeCity.ActiveReports.Rendering Namespace


LocateDataSourceArgs Class Members

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : LocateDataSourceArgs Class

Glossary Item Box

The following tables list the members exposed by LocateDataSourceArgs.

Public Constructors

 | Name | Description
Public Constructor | LocateDataSourceArgs Constructor | Initializes a new instance of the LocateDataSourceArgs class.
Top

Public Properties

 | Name | Description
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Name | Gets the name of the requested data source. The meaning depends on the data provider type.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the GrapeCity.ActiveReports.PageReportModel.Report for which is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceArgs Class
GrapeCity.ActiveReports.Rendering Namespace


LocateDataSourceArgs Constructor

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > LocateDataSourceArgs Class : LocateDataSourceArgs Constructor

report
The report for which the data set is being located.
dataSet
The data set object to locate data for.
parameters
The parameters collection specified for the report instance.
name
The name of the requested data source.

Glossary Item Box

Initializes a new instance of the LocateDataSourceArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   ByVal dataSet As IDataSet, _
   ByVal parameters As IReadOnlyList(Of DataParameter), _
   Optional ByVal name As String _
)
C#
public LocateDataSourceArgs(
   Report report,
   IDataSet dataSet,
   IReadOnlyList<DataParameter> parameters,
   string name
)

Parameters

report
The report for which the data set is being located.
dataSet
The data set object to locate data for.
parameters
The parameters collection specified for the report instance.
name
The name of the requested data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


LocateDataSourceArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LocateDataSourceArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : LocateDataSourceArgs Class

Glossary Item Box

For a list of all members of this type, see LocateDataSourceArgs members.

Public Properties

 | Name | Description
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Name | Gets the name of the requested data source. The meaning depends on the data provider type.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the GrapeCity.ActiveReports.PageReportModel.Report for which is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceArgs Class
GrapeCity.ActiveReports.Rendering Namespace


DataSet Property

[image]
ActiveReports 19 .NET Edition
DataSet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > LocateDataSourceArgs Class : DataSet Property

Glossary Item Box

Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSet As IDataSet
C#
public IDataSet DataSet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > LocateDataSourceArgs Class : Name Property

Glossary Item Box

Gets the name of the requested data source. The meaning depends on the data provider type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of the requested data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > LocateDataSourceArgs Class : Parameters Property

Glossary Item Box

Gets the Parameters collection specified for a given report instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IReadOnlyList(Of DataParameter)
C#
public IReadOnlyList<DataParameter> Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > LocateDataSourceArgs Class : Report Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.PageReportModel.Report for which is trying to locate the data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceArgs Class
LocateDataSourceArgs Members


RenderingTreeBuilderConfig Class

[image]
ActiveReports 19 .NET Edition
RenderingTreeBuilderConfig Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : RenderingTreeBuilderConfig Class

Glossary Item Box

Configuration for the GrapeCity.ActiveReports.Rendering.RenderingTreeBuilder.

Object Model

RenderingTreeBuilderConfig Class

Syntax

Visual Basic (Declaration)
Public Class RenderingTreeBuilderConfig
C#
public class RenderingTreeBuilderConfig

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.RenderingTreeBuilderConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingTreeBuilderConfig Members
GrapeCity.ActiveReports.Rendering Namespace


RenderingTreeBuilderConfig Class Members

[image]
ActiveReports 19 .NET Edition
RenderingTreeBuilderConfig Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : RenderingTreeBuilderConfig Class

Glossary Item Box

The following tables list the members exposed by RenderingTreeBuilderConfig.

Public Constructors

 | Name | Description
Public Constructor | RenderingTreeBuilderConfig Constructor |
Top

Public Fields

 | Name | Description
Public Field | ReportItemFactory | Gets or sets the factory used to create report items.
Public Field | Services | Gets or sets the service provider.
Top

See Also

Reference

RenderingTreeBuilderConfig Class
GrapeCity.ActiveReports.Rendering Namespace


RenderingTreeBuilderConfig Constructor

[image]
ActiveReports 19 .NET Edition
RenderingTreeBuilderConfig Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > RenderingTreeBuilderConfig Class : RenderingTreeBuilderConfig Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderingTreeBuilderConfig()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingTreeBuilderConfig Class
RenderingTreeBuilderConfig Members


RenderingTreeBuilderConfig Class Fields

[image]
ActiveReports 19 .NET Edition
RenderingTreeBuilderConfig Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : RenderingTreeBuilderConfig Class

Glossary Item Box

For a list of all members of this type, see RenderingTreeBuilderConfig members.

Public Fields

 | Name | Description
Public Field | ReportItemFactory | Gets or sets the factory used to create report items.
Public Field | Services | Gets or sets the service provider.
Top

See Also

Reference

RenderingTreeBuilderConfig Class
GrapeCity.ActiveReports.Rendering Namespace


ReportItemFactory Field

[image]
ActiveReports 19 .NET Edition
ReportItemFactory Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > RenderingTreeBuilderConfig Class : ReportItemFactory Field

Glossary Item Box

Gets or sets the factory used to create report items.

Syntax

Visual Basic (Declaration)
Public ReportItemFactory As IRenderReportItemFactory
C#
public IRenderReportItemFactory ReportItemFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingTreeBuilderConfig Class
RenderingTreeBuilderConfig Members


Services Field

[image]
ActiveReports 19 .NET Edition
Services Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > RenderingTreeBuilderConfig Class : Services Field

Glossary Item Box

Gets or sets the service provider.

Syntax

Visual Basic (Declaration)
Public Services As IServiceProvider
C#
public IServiceProvider Services

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingTreeBuilderConfig Class
RenderingTreeBuilderConfig Members


ReportExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportExtensions Class

Glossary Item Box

Provides extension methods for ReportStore.

Object Model

ReportExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportExtensions
C#
public static class ReportExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.ReportExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Members
GrapeCity.ActiveReports.Rendering Namespace


ReportExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildReport | Creates GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport object.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Rendering Namespace


ReportExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BuildReport | Creates GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport object.
Top

See Also

Reference

ReportExtensions Class
GrapeCity.ActiveReports.Rendering Namespace


BuildReport Method

[image]
ActiveReports 19 .NET Edition
BuildReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportExtensions Class : BuildReport Method

reportStore
Report bundle with root report definition, subreports and other resources.
data
Report data.
parameters
Report parameters values.
config
Builder configuration.
subreports
Subreports information.
actions
Action keys.
customContext
Custom context.

Glossary Item Box

Creates GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport object.

Syntax

Visual Basic (Declaration)
Public Shared Function BuildReport( _
   ByVal reportStore As ReportStore, _
   Optional ByVal data As ReportDataSnapshot, _
   Optional ByVal parameters() As DataParameter, _
   Optional ByVal config As RenderingTreeBuilderConfig, _
   Optional ByVal subreports As SubreportsInfo, _
   Optional ByVal actions() As ActionKey, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As IReport
C#
public static IReport BuildReport(
   ReportStore reportStore,
   ReportDataSnapshot data,
   DataParameter[] parameters,
   RenderingTreeBuilderConfig config,
   SubreportsInfo subreports,
   ActionKey[] actions,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

reportStore
Report bundle with root report definition, subreports and other resources.
data
Report data.
parameters
Report parameters values.
config
Builder configuration.
subreports
Subreports information.
actions
Action keys.
customContext
Custom context.

Return Value

GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport object that is root of rendering tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExtensions Class
ReportExtensions Members


ReportProcessor Class

[image]
ActiveReports 19 .NET Edition
ReportProcessor Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportProcessor Class

Glossary Item Box

Handles gathering data for a PageReport and creating the rendering components for a report. The rendering components can then be passed to a rendering extension for rendering.

Object Model

ReportProcessor Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportProcessor
C#
public sealed class ReportProcessor

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.ReportProcessor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Members
GrapeCity.ActiveReports.Rendering Namespace


ReportProcessor Class Members

[image]
ActiveReports 19 .NET Edition
ReportProcessor Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportProcessor Class

Glossary Item Box

The following tables list the members exposed by ReportProcessor.

Public Constructors

 | Name | Description
Public Constructor | ReportProcessor Constructor | Creates ReportProcessor instance for root report.
Top

Public Fields

 | Name | Description
Public Field | ReportItemFactory |
Top

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Parameters |
Public Property | PreValidation | Specifies whether the report needs to be validated or not.
Public Property | ResourceLocator |
Top

Public Methods

 | Name | Description
Public Method | Process | Overloaded. Processes the data for renderable report as needed. If it has already been processed and there is no need to re-process it, a cached instance will be returned.
Public Method | SetErrorMessageLocalizationService |
Public Method | SetEvaluationMessagePosition |
Top

See Also

Reference

ReportProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


ReportProcessor Constructor

[image]
ActiveReports 19 .NET Edition
ReportProcessor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : ReportProcessor Constructor

report
The report definition.
resourceLocator
Report resource locator.
config
Report configuration.
customContext
Custom evaluation context objects (custom code, user context, etc.)
snapshot
The report snapshot.
services
Service provider.

Glossary Item Box

Creates ReportProcessor instance for root report.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   Optional ByVal resourceLocator As ResourceLocator, _
   Optional ByVal config As DataTreeBuilderConfig, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)), _
   Optional ByVal snapshot As ReportSnapshot, _
   Optional ByVal services As IServiceProvider _
)
C#
public ReportProcessor(
   Report report,
   ResourceLocator resourceLocator,
   DataTreeBuilderConfig config,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext,
   ReportSnapshot snapshot,
   IServiceProvider services
)

Parameters

report
The report definition.
resourceLocator
Report resource locator.
config
Report configuration.
customContext
Custom evaluation context objects (custom code, user context, etc.)
snapshot
The report snapshot.
services
Service provider.

Exceptions

Exception | Description
System.ArgumentNullException | The exception that is thrown when a null reference (Nothing in Visual Basic) is passed to a method that does not accept it as a valid argument.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ReportProcessor Class Methods

[image]
ActiveReports 19 .NET Edition
ReportProcessor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportProcessor Class

Glossary Item Box

For a list of all members of this type, see ReportProcessor members.

Public Methods

 | Name | Description
Public Method | Process | Overloaded. Processes the data for renderable report as needed. If it has already been processed and there is no need to re-process it, a cached instance will be returned.
Public Method | SetErrorMessageLocalizationService |
Public Method | SetEvaluationMessagePosition |
Top

See Also

Reference

ReportProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


Process Method

[image]
ActiveReports 19 .NET Edition
Process Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : Process Method

Glossary Item Box

Processes the data for renderable report as needed. If it has already been processed and there is no need to re-process it, a cached instance will be returned.

Overload List

Overload | Description
Process(Boolean,Boolean) | Processes the data for renderable report as needed. If it has already been processed and there is no need to re-process it, a cached instance will be returned.
Process(Boolean,CancellationToken,Boolean,ActionKey[]) | Processes the data for renderable report as needed.
Process(Boolean,Boolean,CancellationToken,Boolean,ActionKey[]) | Processes the data for renderable report as needed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


Process(Boolean,Boolean) Method

[image]
ActiveReports 19 .NET Edition
Process(Boolean,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class > Process Method : Process(Boolean,Boolean) Method

forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
skipValidation
True to skip parameters validation. False by default.

Glossary Item Box

Processes the data for renderable report as needed. If it has already been processed and there is no need to re-process it, a cached instance will be returned.

Syntax

Visual Basic (Declaration)
Public Overloads Function Process( _
   ByVal forceParameterDataRefresh As Boolean, _
   Optional ByVal skipValidation As Boolean _
) As IReport
C#
public IReport Process(
   bool forceParameterDataRefresh,
   bool skipValidation
)

Parameters

forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
skipValidation
True to skip parameters validation. False by default.

Return Value

A renderable _report that can be passed directly to a IRenderingExtension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


Process(Boolean,CancellationToken,Boolean,ActionKey[]) Method

[image]
ActiveReports 19 .NET Edition
Process(Boolean,CancellationToken,Boolean,ActionKey[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class > Process Method : Process(Boolean,CancellationToken,Boolean,ActionKey[]) Method

forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
token
The cancellation token.
skipValidation
True to skip parameters validation. False by default.
interactiveActions
An array of interactive actions to apply during processing.

Glossary Item Box

Processes the data for renderable report as needed.

Syntax

Visual Basic (Declaration)
Public Overloads Function Process( _
   ByVal forceParameterDataRefresh As Boolean, _
   ByVal token As CancellationToken, _
   Optional ByVal skipValidation As Boolean, _
   Optional ByVal interactiveActions() As ActionKey _
) As IReport
C#
public IReport Process(
   bool forceParameterDataRefresh,
   CancellationToken token,
   bool skipValidation,
   ActionKey[] interactiveActions
)

Parameters

forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
token
The cancellation token.
skipValidation
True to skip parameters validation. False by default.
interactiveActions
An array of interactive actions to apply during processing.

Return Value

A renderable _report that can be passed directly to a IRenderingExtension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


Process(Boolean,Boolean,CancellationToken,Boolean,ActionKey[]) Method

[image]
ActiveReports 19 .NET Edition
Process(Boolean,Boolean,CancellationToken,Boolean,ActionKey[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class > Process Method : Process(Boolean,Boolean,CancellationToken,Boolean,ActionKey[]) Method

forceDataRefresh
If False the previously requested data tree will used to render the report (if the data exists).
forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
token
Cancellation token.
skipValidation
True to skip parameters validation. False by default.
interactiveActions
An array of interactive actions to apply during processing.

Glossary Item Box

Processes the data for renderable report as needed.

Syntax

Visual Basic (Declaration)
Public Overloads Function Process( _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean, _
   ByVal token As CancellationToken, _
   Optional ByVal skipValidation As Boolean, _
   Optional ByVal interactiveActions() As ActionKey _
) As IReport
C#
public IReport Process(
   bool forceDataRefresh,
   bool forceParameterDataRefresh,
   CancellationToken token,
   bool skipValidation,
   ActionKey[] interactiveActions
)

Parameters

forceDataRefresh
If False the previously requested data tree will used to render the report (if the data exists).
forceParameterDataRefresh
Indicates whether to force a refresh of the parameter data.
token
Cancellation token.
skipValidation
True to skip parameters validation. False by default.
interactiveActions
An array of interactive actions to apply during processing.

Return Value

A renderable _report that can be passed directly to an IRenderingExtension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


SetErrorMessageLocalizationService Method

[image]
ActiveReports 19 .NET Edition
SetErrorMessageLocalizationService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : SetErrorMessageLocalizationService Method

msgSvc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetErrorMessageLocalizationService( _
   ByVal msgSvc As ILocalizedTextService _
)
C#
public void SetErrorMessageLocalizationService(
   ILocalizedTextService msgSvc
)

Parameters

msgSvc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


SetEvaluationMessagePosition Method

[image]
ActiveReports 19 .NET Edition
SetEvaluationMessagePosition Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : SetEvaluationMessagePosition Method

pos

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetEvaluationMessagePosition( _
   ByVal pos As EvalPosition _
)
C#
public void SetEvaluationMessagePosition(
   EvalPosition pos
)

Parameters

pos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ReportProcessor Class Properties

[image]
ActiveReports 19 .NET Edition
ReportProcessor Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportProcessor Class

Glossary Item Box

For a list of all members of this type, see ReportProcessor members.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Parameters |
Public Property | PreValidation | Specifies whether the report needs to be validated or not.
Public Property | ResourceLocator |
Top

See Also

Reference

ReportProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As ReportSnapshot
C#
public ReportSnapshot Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


Parameters Property

[image]
ActiveReports 19 .NET Edition
Parameters Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : Parameters Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


PreValidation Property

[image]
ActiveReports 19 .NET Edition
PreValidation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : PreValidation Property

Glossary Item Box

Specifies whether the report needs to be validated or not.

Syntax

Visual Basic (Declaration)
Public Property PreValidation As Boolean
C#
public bool PreValidation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : ResourceLocator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As ResourceLocator
C#
public ResourceLocator ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ReportProcessor Class Fields

[image]
ActiveReports 19 .NET Edition
ReportProcessor Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportProcessor Class

Glossary Item Box

For a list of all members of this type, see ReportProcessor members.

Public Fields

 | Name | Description
Public Field | ReportItemFactory |
Top

See Also

Reference

ReportProcessor Class
GrapeCity.ActiveReports.Rendering Namespace


ReportItemFactory Field

[image]
ActiveReports 19 .NET Edition
ReportItemFactory Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportProcessor Class : ReportItemFactory Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReportItemFactory As IRenderReportItemFactory
C#
public IRenderReportItemFactory ReportItemFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ReportStore Class

[image]
ActiveReports 19 .NET Edition
ReportStore Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore Class

Glossary Item Box

Stores reports obtained during build of data tree definition.

Object Model

ReportStore Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportStore
C#
public sealed class ReportStore

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.ReportStore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Members
GrapeCity.ActiveReports.Rendering Namespace


ReportStore Class Members

[image]
ActiveReports 19 .NET Edition
ReportStore Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore Class

Glossary Item Box

The following tables list the members exposed by ReportStore.

Public Constructors

 | Name | Description
Public Constructor | ReportStore Constructor |
Top

Public Fields

 | Name | Description
Public Field | ResourceLocator |
Public Field | RootReport |
Top

Public Properties

 | Name | Description
Public Property | IsInteractive | Determines whether the root report has interactive sortings.
Top

Public Methods

 | Name | Description
Public Method | GetCumulativeExpressions |
Public Method | GetNextReportName |
Public Method | GetReport | Gets page report definition for given data tree query definition.
Public Method | GetSubReport | Gets page report for given subreport control.
Public Method | GetSubreports | Returns list of registered subreports and subreports dependency map for snapshot creation.
Public Method | Register | Overloaded. Registers association of page report with its data tree definition.
Public Method | RegisterCumulatives |
Top

See Also

Reference

ReportStore Class
GrapeCity.ActiveReports.Rendering Namespace


ReportStore Constructor

[image]
ActiveReports 19 .NET Edition
ReportStore Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : ReportStore Constructor

report
resourceLocator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator _
)
C#
public ReportStore(
   Report report,
   ResourceLocator resourceLocator
)

Parameters

report
resourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


ReportStore Class Methods

[image]
ActiveReports 19 .NET Edition
ReportStore Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore Class

Glossary Item Box

For a list of all members of this type, see ReportStore members.

Public Methods

 | Name | Description
Public Method | GetCumulativeExpressions |
Public Method | GetNextReportName |
Public Method | GetReport | Gets page report definition for given data tree query definition.
Public Method | GetSubReport | Gets page report for given subreport control.
Public Method | GetSubreports | Returns list of registered subreports and subreports dependency map for snapshot creation.
Public Method | Register | Overloaded. Registers association of page report with its data tree definition.
Public Method | RegisterCumulatives |
Top

See Also

Reference

ReportStore Class
GrapeCity.ActiveReports.Rendering Namespace


GetCumulativeExpressions Method

[image]
ActiveReports 19 .NET Edition
GetCumulativeExpressions Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : GetCumulativeExpressions Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCumulativeExpressions() As IEnumerable(Of ExpressionInfo)
C#
public IEnumerable<ExpressionInfo> GetCumulativeExpressions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


GetNextReportName Method

[image]
ActiveReports 19 .NET Edition
GetNextReportName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : GetNextReportName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNextReportName() As String
C#
public string GetNextReportName()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


GetReport Method

[image]
ActiveReports 19 .NET Edition
GetReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : GetReport Method

defName

Glossary Item Box

Gets page report definition for given data tree query definition.

Syntax

Visual Basic (Declaration)
Public Function GetReport( _
   ByVal defName As String _
) As Report
C#
public Report GetReport(
   string defName
)

Parameters

defName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


GetSubReport Method

[image]
ActiveReports 19 .NET Edition
GetSubReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : GetSubReport Method

subreport

Glossary Item Box

Gets page report for given subreport control.

Syntax

Visual Basic (Declaration)
Public Function GetSubReport( _
   ByVal subreport As Subreport _
) As Report
C#
public Report GetSubReport(
   Subreport subreport
)

Parameters

subreport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


GetSubreports Method

[image]
ActiveReports 19 .NET Edition
GetSubreports Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : GetSubreports Method

rootResourceLocator

Glossary Item Box

Returns list of registered subreports and subreports dependency map for snapshot creation.

Syntax

Visual Basic (Declaration)
Public Function GetSubreports( _
   ByVal rootResourceLocator As ResourceLocator _
) As ReportStore.SubreportsStore
C#
public ReportStore.SubreportsStore GetSubreports(
   ResourceLocator rootResourceLocator
)

Parameters

rootResourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


Register Method

[image]
ActiveReports 19 .NET Edition
Register Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : Register Method

Glossary Item Box

Registers association of page report with its data tree definition.

Overload List

Overload | Description
Register(String,Report) | Registers association of page report with its data tree definition.
Register(Subreport,Report) | Registers association of subreport control with its page report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


Register(String,Report) Method

[image]
ActiveReports 19 .NET Edition
Register(String,Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class > Register Method : Register(String,Report) Method

name
Internal report name (id).
report
Page report definition.

Glossary Item Box

Registers association of page report with its data tree definition.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Register( _
   ByVal name As String, _
   ByVal report As Report _
)
C#
public void Register(
   string name,
   Report report
)

Parameters

name
Internal report name (id).
report
Page report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members
Overload List


Register(Subreport,Report) Method

[image]
ActiveReports 19 .NET Edition
Register(Subreport,Report) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class > Register Method : Register(Subreport,Report) Method

subreport
report

Glossary Item Box

Registers association of subreport control with its page report definition.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Register( _
   ByVal subreport As Subreport, _
   ByVal report As Report _
)
C#
public void Register(
   Subreport subreport,
   Report report
)

Parameters

subreport
report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members
Overload List


RegisterCumulatives Method

[image]
ActiveReports 19 .NET Edition
RegisterCumulatives Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : RegisterCumulatives Method

expr

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterCumulatives( _
   ByVal expr As IEnumerable(Of ExpressionInfo) _
)
C#
public void RegisterCumulatives(
   IEnumerable<ExpressionInfo> expr
)

Parameters

expr

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


ReportStore Class Properties

[image]
ActiveReports 19 .NET Edition
ReportStore Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore Class

Glossary Item Box

For a list of all members of this type, see ReportStore members.

Public Properties

 | Name | Description
Public Property | IsInteractive | Determines whether the root report has interactive sortings.
Top

See Also

Reference

ReportStore Class
GrapeCity.ActiveReports.Rendering Namespace


IsInteractive Property

[image]
ActiveReports 19 .NET Edition
IsInteractive Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : IsInteractive Property

Glossary Item Box

Determines whether the root report has interactive sortings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInteractive As Boolean
C#
public bool IsInteractive {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


ReportStore Class Fields

[image]
ActiveReports 19 .NET Edition
ReportStore Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore Class

Glossary Item Box

For a list of all members of this type, see ReportStore members.

Public Fields

 | Name | Description
Public Field | ResourceLocator |
Public Field | RootReport |
Top

See Also

Reference

ReportStore Class
GrapeCity.ActiveReports.Rendering Namespace


ResourceLocator Field

[image]
ActiveReports 19 .NET Edition
ResourceLocator Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : ResourceLocator Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ResourceLocator As ResourceLocator
C#
public readonly ResourceLocator ResourceLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


RootReport Field

[image]
ActiveReports 19 .NET Edition
RootReport Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore Class : RootReport Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RootReport As Report
C#
public readonly Report RootReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore Class
ReportStore Members


ReportStoreException Class

[image]
ActiveReports 19 .NET Edition
ReportStoreException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStoreException Class

Glossary Item Box

Describes an exception which may be thrown by the ReportStore class.

Object Model

ReportStoreException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportStoreException
   Inherits System.Exception
C#
public sealed class ReportStoreException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.ReportStoreException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreException Members
GrapeCity.ActiveReports.Rendering Namespace


ReportStoreException Class Members

[image]
ActiveReports 19 .NET Edition
ReportStoreException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStoreException Class

Glossary Item Box

The following tables list the members exposed by ReportStoreException.

Public Properties

 | Name | Description
Public Property | Code |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | InvalidLibraryReference |
static (Shared in Visual Basic) | LibraryReportItemNotFound |
Top

See Also

Reference

ReportStoreException Class
GrapeCity.ActiveReports.Rendering Namespace


ReportStoreException Class Methods

[image]
ActiveReports 19 .NET Edition
ReportStoreException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStoreException Class

Glossary Item Box

For a list of all members of this type, see ReportStoreException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | InvalidLibraryReference |
static (Shared in Visual Basic) | LibraryReportItemNotFound |
Top

See Also

Reference

ReportStoreException Class
GrapeCity.ActiveReports.Rendering Namespace


InvalidLibraryReference Method

[image]
ActiveReports 19 .NET Edition
InvalidLibraryReference Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStoreException Class : InvalidLibraryReference Method

libraryName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function InvalidLibraryReference( _
   ByVal libraryName As String _
) As ReportStoreException
C#
public static ReportStoreException InvalidLibraryReference(
   string libraryName
)

Parameters

libraryName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreException Class
ReportStoreException Members


LibraryReportItemNotFound Method

[image]
ActiveReports 19 .NET Edition
LibraryReportItemNotFound Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStoreException Class : LibraryReportItemNotFound Method

reportPartName
reportItemName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function LibraryReportItemNotFound( _
   ByVal reportPartName As String, _
   ByVal reportItemName As String _
) As ReportStoreException
C#
public static ReportStoreException LibraryReportItemNotFound(
   string reportPartName,
   string reportItemName
)

Parameters

reportPartName
reportItemName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreException Class
ReportStoreException Members


ReportStoreException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportStoreException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStoreException Class

Glossary Item Box

For a list of all members of this type, see ReportStoreException members.

Public Properties

 | Name | Description
Public Property | Code |
Top

See Also

Reference

ReportStoreException Class
GrapeCity.ActiveReports.Rendering Namespace


Code Property

[image]
ActiveReports 19 .NET Edition
Code Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStoreException Class : Code Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As ReportStoreException.Errors
C#
public ReportStoreException.Errors Code {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreException Class
ReportStoreException Members


StyleSheetService Class

[image]
ActiveReports 19 .NET Edition
StyleSheetService Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : StyleSheetService Class

Glossary Item Box

Specifies information about a report's evaluated styles.

Object Model

StyleSheetService Class

Syntax

Visual Basic (Declaration)
Public Class StyleSheetService
   Implements IStyleSheetService
C#
public class StyleSheetService : IStyleSheetService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.StyleSheetService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetService Members
GrapeCity.ActiveReports.Rendering Namespace


StyleSheetService Class Members

[image]
ActiveReports 19 .NET Edition
StyleSheetService Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : StyleSheetService Class

Glossary Item Box

The following tables list the members exposed by StyleSheetService.

Public Constructors

 | Name | Description
Public Constructor | StyleSheetService Constructor | Initializes a new instance of the GrapeCity.ActiveReports.PageReportModel.StyleSheetService class for specified GrapeCity.ActiveReports.PageReportModel.Report object.
Top

See Also

Reference

StyleSheetService Class
GrapeCity.ActiveReports.Rendering Namespace


StyleSheetService Constructor

[image]
ActiveReports 19 .NET Edition
StyleSheetService Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > StyleSheetService Class : StyleSheetService Constructor

report
Specified GrapeCity.ActiveReports.Report object.
resourceLocator
Resource locator.
serviceProvider
Service provider.
expressionEvaluatorService
The expression evaluator service.

Glossary Item Box

Initializes a new instance of the GrapeCity.ActiveReports.PageReportModel.StyleSheetService class for specified GrapeCity.ActiveReports.PageReportModel.Report object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator, _
   ByVal serviceProvider As IServiceProvider, _
   Optional ByVal expressionEvaluatorService As IExpressionEvaluatorService _
)
C#
public StyleSheetService(
   Report report,
   ResourceLocator resourceLocator,
   IServiceProvider serviceProvider,
   IExpressionEvaluatorService expressionEvaluatorService
)

Parameters

report
Specified GrapeCity.ActiveReports.Report object.
resourceLocator
Resource locator.
serviceProvider
Service provider.
expressionEvaluatorService
The expression evaluator service.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheetService Class
StyleSheetService Members


DataBuilderException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
DataBuilderException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataBuilderException.ErrorCodes Enumeration

Glossary Item Box

Describes possible error codes of the data engine errors.

Syntax

Visual Basic (Declaration)
Public Enum DataBuilderException.ErrorCodes
   Inherits System.Enum
C#
public enum DataBuilderException.ErrorCodes : System.Enum

Members

Member | Description
CyclicSubreportReferences | Report uses itself as subreport.
DataSetNotFound | The data set name specified for the data region is not found in the report.
DataSetNotSpecified | DataSet name is not specified for the data region.
NoDataSets | There are no data sets defined in the report.
SubreportNotFound | Unable to locate subreport specified in the report.
SubreportNotSpecified | Subreport name is not specified.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.DataBuilderException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering Namespace


DataProcessingException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
DataProcessingException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : DataProcessingException.ErrorCodes Enumeration

Glossary Item Box

Error codes for data processing exceptions.

Syntax

Visual Basic (Declaration)
Public Enum DataProcessingException.ErrorCodes
   Inherits System.Enum
C#
public enum DataProcessingException.ErrorCodes : System.Enum

Members

Member | Description
DataProviderNotFound | Indicates that the data provider was not found.
DataProviderNotSpecified | Indicates that the data provider was not specified.
DataSourceNotFound | Indicates that the data source was not found.
SharedDataSourceNotLoaded | Indicates that the shared data source could not be loaded.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.DataProcessingException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering Namespace


ReportStoreException.Errors Enumeration

[image]
ActiveReports 19 .NET Edition
ReportStoreException.Errors Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStoreException.Errors Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ReportStoreException.Errors
   Inherits System.Enum
C#
public enum ReportStoreException.Errors : System.Enum

Members

Member | Description
LibraryNotFound | Shared reports library was not found.
LibraryReferenceNotFound | The part item references the library which is not presented in the GrapeCity.ActiveReports.PageReportModel.Report.Libraries collection.
LibraryReportItemNotFound | Shared report part references the report item which can not be found in the library.
LibraryReportPartNotFound | Shared report part not found in the library.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.ReportStoreException.Errors

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering Namespace


ReportStore.SubreportsStore Structure

[image]
ActiveReports 19 .NET Edition
ReportStore.SubreportsStore Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore.SubreportsStore Structure

Glossary Item Box

Object Model

ReportStore.SubreportsStore Structure

Syntax

Visual Basic (Declaration)
Public Structure ReportStore.SubreportsStore
   Inherits System.ValueType
C#
public struct ReportStore.SubreportsStore : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.ReportStore.SubreportsStore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore.SubreportsStore Members
GrapeCity.ActiveReports.Rendering Namespace


ReportStore.SubreportsStore Structure Members

[image]
ActiveReports 19 .NET Edition
ReportStore.SubreportsStore Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore.SubreportsStore Structure

Glossary Item Box

The following tables list the members exposed by ReportStore.SubreportsStore.

Public Constructors

 | Name | Description
Public Constructor | ReportStore.SubreportsStore Constructor |
Top

Public Fields

 | Name | Description
Public Field | Map | Index - report index: 0 - main report; 1,2,etc - index of subreport from Subreports starting from 1. Value - dictionary to resolve report subreports. Key is subreport name in definition, Value is report index (0 - main report; 1,2,etc - index of subreport from Subreports starting from 1).
Public Field | Subreports | List of subreports definitions.
Top

See Also

Reference

ReportStore.SubreportsStore Structure
GrapeCity.ActiveReports.Rendering Namespace


ReportStore.SubreportsStore Constructor

[image]
ActiveReports 19 .NET Edition
ReportStore.SubreportsStore Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore.SubreportsStore Structure : ReportStore.SubreportsStore Constructor

subreports
map

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal subreports As List(Of String), _
   ByVal map As List(Of Dictionary(Of String,Integer)) _
)
C#
public ReportStore.SubreportsStore(
   List<string> subreports,
   List<Dictionary<string,int>> map
)

Parameters

subreports
map

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore.SubreportsStore Structure
ReportStore.SubreportsStore Members


ReportStore.SubreportsStore Structure Fields

[image]
ActiveReports 19 .NET Edition
ReportStore.SubreportsStore Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ReportStore.SubreportsStore Structure

Glossary Item Box

For a list of all members of this type, see ReportStore.SubreportsStore members.

Public Fields

 | Name | Description
Public Field | Map | Index - report index: 0 - main report; 1,2,etc - index of subreport from Subreports starting from 1. Value - dictionary to resolve report subreports. Key is subreport name in definition, Value is report index (0 - main report; 1,2,etc - index of subreport from Subreports starting from 1).
Public Field | Subreports | List of subreports definitions.
Top

See Also

Reference

ReportStore.SubreportsStore Structure
GrapeCity.ActiveReports.Rendering Namespace


Map Field

[image]
ActiveReports 19 .NET Edition
Map Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore.SubreportsStore Structure : Map Field

Glossary Item Box

Index - report index: 0 - main report; 1,2,etc - index of subreport from Subreports starting from 1. Value - dictionary to resolve report subreports. Key is subreport name in definition, Value is report index (0 - main report; 1,2,etc - index of subreport from Subreports starting from 1).

Syntax

Visual Basic (Declaration)
Public Map As List(Of Dictionary(Of String,Integer))
C#
public List<Dictionary<string,int>> Map

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore.SubreportsStore Structure
ReportStore.SubreportsStore Members


Subreports Field

[image]
ActiveReports 19 .NET Edition
Subreports Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > ReportStore.SubreportsStore Structure : Subreports Field

Glossary Item Box

List of subreports definitions.

Syntax

Visual Basic (Declaration)
Public Subreports As List(Of String)
C#
public List<string> Subreports

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStore.SubreportsStore Structure
ReportStore.SubreportsStore Members


IStyleSheetService Interface

[image]
ActiveReports 19 .NET Edition
IStyleSheetService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : IStyleSheetService Interface

Glossary Item Box

Allows to get report's evaluated styles.

Syntax

Visual Basic (Declaration)
Public Interface IStyleSheetService
C#
public interface IStyleSheetService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetService Members
GrapeCity.ActiveReports.Rendering Namespace


IStyleSheetService Interface Members

[image]
ActiveReports 19 .NET Edition
IStyleSheetService Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : IStyleSheetService Interface

Glossary Item Box

The following tables list the members exposed by IStyleSheetService.

Public Properties

 | Name | Description
Property | StyleSheet | Gets a report's GrapeCity.ActiveReports.PageReportModel.StyleSheet object.
Top

Public Methods

 | Name | Description
Method | GetStyle | Overloaded. Gets evaluated style by specified name.
Top

See Also

Reference

IStyleSheetService Interface
GrapeCity.ActiveReports.Rendering Namespace


IStyleSheetService Interface Methods

[image]
ActiveReports 19 .NET Edition
IStyleSheetService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : IStyleSheetService Interface

Glossary Item Box

For a list of all members of this type, see IStyleSheetService members.

Public Methods

 | Name | Description
Method | GetStyle | Overloaded. Gets evaluated style by specified name.
Top

See Also

Reference

IStyleSheetService Interface
GrapeCity.ActiveReports.Rendering Namespace


GetStyle Method

[image]
ActiveReports 19 .NET Edition
GetStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > IStyleSheetService Interface : GetStyle Method

Glossary Item Box

Gets evaluated style by specified name.

Overload List

Overload | Description
GetStyle(String) | Gets evaluated style by specified name.
GetStyle(Int32) | Gets evaluated style by specified heading level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetService Interface
IStyleSheetService Members


GetStyle(String) Method

[image]
ActiveReports 19 .NET Edition
GetStyle(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > IStyleSheetService Interface > GetStyle Method : GetStyle(String) Method

styleName
A String indicating the name of the GrapeCity.ActiveReports.PageReportModel.Style object.

Glossary Item Box

Gets evaluated style by specified name.

Syntax

Visual Basic (Declaration)
Overloads Function GetStyle( _
   ByVal styleName As String _
) As Style
C#
Style GetStyle(
   string styleName
)

Parameters

styleName
A String indicating the name of the GrapeCity.ActiveReports.PageReportModel.Style object.

Return Value

The evaluated style if GrapeCity.ActiveReports.PageReportModel.Style object whith specified name found in the report's stylesheet; otherwise, default style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetService Interface
IStyleSheetService Members
Overload List


GetStyle(Int32) Method

[image]
ActiveReports 19 .NET Edition
GetStyle(Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > IStyleSheetService Interface > GetStyle Method : GetStyle(Int32) Method

level
A zero-based Integer indicating the value of HeadingLevel property of the GrapeCity.ActiveReports.PageReportModel.Style object.

Glossary Item Box

Gets evaluated style by specified heading level.

Syntax

Visual Basic (Declaration)
Overloads Function GetStyle( _
   ByVal level As Integer _
) As Style
C#
Style GetStyle(
   int level
)

Parameters

level
A zero-based Integer indicating the value of HeadingLevel property of the GrapeCity.ActiveReports.PageReportModel.Style object.

Return Value

The evaluated style if GrapeCity.ActiveReports.PageReportModel.Style object whith specified heading level found in the report's stylesheet; otherwise, default style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetService Interface
IStyleSheetService Members
Overload List


IStyleSheetService Interface Properties

[image]
ActiveReports 19 .NET Edition
IStyleSheetService Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : IStyleSheetService Interface

Glossary Item Box

For a list of all members of this type, see IStyleSheetService members.

Public Properties

 | Name | Description
Property | StyleSheet | Gets a report's GrapeCity.ActiveReports.PageReportModel.StyleSheet object.
Top

See Also

Reference

IStyleSheetService Interface
GrapeCity.ActiveReports.Rendering Namespace


StyleSheet Property

[image]
ActiveReports 19 .NET Edition
StyleSheet Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace > IStyleSheetService Interface : StyleSheet Property

Glossary Item Box

Gets a report's GrapeCity.ActiveReports.PageReportModel.StyleSheet object.

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleSheet As StyleSheet
C#
StyleSheet StyleSheet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleSheetService Interface
IStyleSheetService Members


ResolveCredentials Delegate

[image]
ActiveReports 19 .NET Edition
ResolveCredentials Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering Namespace : ResolveCredentials Delegate

dataSource
The data source to locate credentials for.
reportName
The name of the report to resolve credentials for.

Glossary Item Box

Gets the credentials for specified report and data source.

Syntax

Visual Basic (Declaration)
Public Delegate Function ResolveCredentials( _
   ByVal dataSource As DataSource, _
   ByVal reportName As String _
) As LoginPasswordCredentials
C#
public delegate LoginPasswordCredentials ResolveCredentials(
   DataSource dataSource,
   string reportName
)

Parameters

dataSource
The data source to locate credentials for.
reportName
The name of the report to resolve credentials for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResolveCredentials Members
GrapeCity.ActiveReports.Rendering Namespace


BiDiHelper Class

[image]
ActiveReports 19 .NET Edition
BiDiHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : BiDiHelper Class

Glossary Item Box

Utility class to help with implementation of the Bi-Directional algorithm.

Object Model

BiDiHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class BiDiHelper
C#
public static class BiDiHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Bidi.BiDiHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BiDiHelper Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


BiDiHelper Class Members

[image]
ActiveReports 19 .NET Edition
BiDiHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : BiDiHelper Class

Glossary Item Box

The following tables list the members exposed by BiDiHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ContainsRtlCharacters | Searches text for RightToLeft characters.
static (Shared in Visual Basic) | ProcessString | Deals with the bidirectional algorithm.
static (Shared in Visual Basic) | ResolveEmbeddingLevels | Processes a collection of CharType and determines the final embedding direction and level.
Top

See Also

Reference

BiDiHelper Class
GrapeCity.ActiveReports.Rendering.Bidi Namespace


BiDiHelper Class Methods

[image]
ActiveReports 19 .NET Edition
BiDiHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : BiDiHelper Class

Glossary Item Box

For a list of all members of this type, see BiDiHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ContainsRtlCharacters | Searches text for RightToLeft characters.
static (Shared in Visual Basic) | ProcessString | Deals with the bidirectional algorithm.
static (Shared in Visual Basic) | ResolveEmbeddingLevels | Processes a collection of CharType and determines the final embedding direction and level.
Top

See Also

Reference

BiDiHelper Class
GrapeCity.ActiveReports.Rendering.Bidi Namespace


ContainsRtlCharacters Method

[image]
ActiveReports 19 .NET Edition
ContainsRtlCharacters Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > BiDiHelper Class : ContainsRtlCharacters Method

text

Glossary Item Box

Searches text for RightToLeft characters.

Syntax

Visual Basic (Declaration)
Public Shared Function ContainsRtlCharacters( _
   ByVal text As String _
) As Boolean
C#
public static bool ContainsRtlCharacters(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BiDiHelper Class
BiDiHelper Members


ProcessString Method

[image]
ActiveReports 19 .NET Edition
ProcessString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > BiDiHelper Class : ProcessString Method

source
rightToLeft

Glossary Item Box

Deals with the bidirectional algorithm.

Syntax

Visual Basic (Declaration)
Public Shared Function ProcessString( _
   ByVal source As String, _
   ByVal rightToLeft As Boolean _
) As String
C#
public static string ProcessString(
   string source,
   bool rightToLeft
)

Parameters

source
rightToLeft

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BiDiHelper Class
BiDiHelper Members


ResolveEmbeddingLevels Method

[image]
ActiveReports 19 .NET Edition
ResolveEmbeddingLevels Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > BiDiHelper Class : ResolveEmbeddingLevels Method

charTypes
paragraphLevel
map

Glossary Item Box

Processes a collection of CharType and determines the final embedding direction and level.

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveEmbeddingLevels( _
   ByVal charTypes As List(Of CharType), _
   ByVal paragraphLevel As LevelOverride, _
   ByVal map As List(Of MapEntry) _
) As CharType()
C#
public static CharType[] ResolveEmbeddingLevels(
   List<CharType> charTypes,
   LevelOverride paragraphLevel,
   List<MapEntry> map
)

Parameters

charTypes
paragraphLevel
map

Remarks

Based on 3.3.2 Explicit Levels and Directions http://www.unicode.org/reports/tr9/index.html#Explicit_Levels_and_Directions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BiDiHelper Class
BiDiHelper Members


Helper Class

[image]
ActiveReports 19 .NET Edition
Helper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : Helper Class

Glossary Item Box

Provides helper methods for handling Unicode characters and bidirectional text processing.

Object Model

Helper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Helper
C#
public static class Helper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Bidi.Helper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


Helper Class Members

[image]
ActiveReports 19 .NET Edition
Helper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : Helper Class

Glossary Item Box

The following tables list the members exposed by Helper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateCharTypesFromText | Creates an array of CharType based on the text parameter.
static (Shared in Visual Basic) | DetermineCategory | Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned.
static (Shared in Visual Basic) | DetermineStrongTextCategory | Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned, including Numbers as Strong.
static (Shared in Visual Basic) | DetermineUnicodeClass | Determines which bidirectional class the Unicode character belongs to.
static (Shared in Visual Basic) | DetermineUnicodeClassIs | Overloaded. Determines if a Unicode character belongs to a specified bidirectional class.
static (Shared in Visual Basic) | GetCodes | Gets the codes for the specified text.
static (Shared in Visual Basic) | GetSplitRanges | Creates a collection of ranges with common levels.
static (Shared in Visual Basic) | IsFirstStrongCharacterType | Determines if the Unicode class is a strong character type.
static (Shared in Visual Basic) | MirrorUnicodeString | Searches the Mirroring table to determine if characters in the string need to be mirrored.
static (Shared in Visual Basic) | NeedsSplit | Determines if an array of CharType needs to be split into different embedding objects.
static (Shared in Visual Basic) | StringFromCharType | Overloaded. Converts a portion of an array of CharType to a Unicode string.
static (Shared in Visual Basic) | UpdateMap | Allows the map to update all entries affected when a character is removed.
Top

See Also

Reference

Helper Class
GrapeCity.ActiveReports.Rendering.Bidi Namespace


Helper Class Methods

[image]
ActiveReports 19 .NET Edition
Helper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : Helper Class

Glossary Item Box

For a list of all members of this type, see Helper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateCharTypesFromText | Creates an array of CharType based on the text parameter.
static (Shared in Visual Basic) | DetermineCategory | Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned.
static (Shared in Visual Basic) | DetermineStrongTextCategory | Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned, including Numbers as Strong.
static (Shared in Visual Basic) | DetermineUnicodeClass | Determines which bidirectional class the Unicode character belongs to.
static (Shared in Visual Basic) | DetermineUnicodeClassIs | Overloaded. Determines if a Unicode character belongs to a specified bidirectional class.
static (Shared in Visual Basic) | GetCodes | Gets the codes for the specified text.
static (Shared in Visual Basic) | GetSplitRanges | Creates a collection of ranges with common levels.
static (Shared in Visual Basic) | IsFirstStrongCharacterType | Determines if the Unicode class is a strong character type.
static (Shared in Visual Basic) | MirrorUnicodeString | Searches the Mirroring table to determine if characters in the string need to be mirrored.
static (Shared in Visual Basic) | NeedsSplit | Determines if an array of CharType needs to be split into different embedding objects.
static (Shared in Visual Basic) | StringFromCharType | Overloaded. Converts a portion of an array of CharType to a Unicode string.
static (Shared in Visual Basic) | UpdateMap | Allows the map to update all entries affected when a character is removed.
Top

See Also

Reference

Helper Class
GrapeCity.ActiveReports.Rendering.Bidi Namespace


CreateCharTypesFromText Method

[image]
ActiveReports 19 .NET Edition
CreateCharTypesFromText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : CreateCharTypesFromText Method

text
The text to create CharType from.
paragraphLevel
The paragraph level override.

Glossary Item Box

Creates an array of CharType based on the text parameter.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateCharTypesFromText( _
   ByVal text As String, _
   ByVal paragraphLevel As LevelOverride _
) As CharType()
C#
public static CharType[] CreateCharTypesFromText(
   string text,
   LevelOverride paragraphLevel
)

Parameters

text
The text to create CharType from.
paragraphLevel
The paragraph level override.

Return Value

An array of CharType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DetermineCategory Method

[image]
ActiveReports 19 .NET Edition
DetermineCategory Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : DetermineCategory Method

unicodeClass
The Unicode class to check.

Glossary Item Box

Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned.

Syntax

Visual Basic (Declaration)
Public Shared Function DetermineCategory( _
   ByVal unicodeClass As UnicodeClass _
) As UnicodeCharacterCategory
C#
public static UnicodeCharacterCategory DetermineCategory(
   UnicodeClass unicodeClass
)

Parameters

unicodeClass
The Unicode class to check.

Return Value

The corresponding Unicode character category.

Remarks

Based on http://www.unicode.org/reports/tr9/index.html#Bidirectional_Character_Types

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DetermineStrongTextCategory Method

[image]
ActiveReports 19 .NET Edition
DetermineStrongTextCategory Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : DetermineStrongTextCategory Method

unicodeClass
The Unicode class to check.

Glossary Item Box

Based on the UnicodeClass parameter, the UnicodeCharacterCategory is returned, including Numbers as Strong.

Syntax

Visual Basic (Declaration)
Public Shared Function DetermineStrongTextCategory( _
   ByVal unicodeClass As UnicodeClass _
) As UnicodeCharacterCategory
C#
public static UnicodeCharacterCategory DetermineStrongTextCategory(
   UnicodeClass unicodeClass
)

Parameters

unicodeClass
The Unicode class to check.

Return Value

The corresponding Unicode character category.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DetermineUnicodeClass(String) Method

[image]
ActiveReports 19 .NET Edition
DetermineUnicodeClass(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : DetermineUnicodeClass(String) Method

unicodeCharacter
The Unicode character as a string.

Glossary Item Box

Determines which bidirectional class the Unicode character belongs to.

Syntax

Visual Basic (Declaration)
Public Shared Function DetermineUnicodeClass( _
   ByVal unicodeCharacter As String _
) As UnicodeClass
C#
public static UnicodeClass DetermineUnicodeClass(
   string unicodeCharacter
)

Parameters

unicodeCharacter
The Unicode character as a string.

Return Value

The bidirectional class of the character.

Remarks

Based on http://www.unicode.org/Public/UNIDATA/extracted/DerivedBidiClass.txt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DetermineUnicodeClassIs Method

[image]
ActiveReports 19 .NET Edition
DetermineUnicodeClassIs Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : DetermineUnicodeClassIs Method

Glossary Item Box

Determines if a Unicode character belongs to a specified bidirectional class.

Overload List

Overload | Description
DetermineUnicodeClassIs(String,UnicodeClass) | Determines if a Unicode character belongs to a specified bidirectional class.
DetermineUnicodeClassIs(Int32,UnicodeClass) | Determines if a Unicode character belongs to a specified bidirectional class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DetermineUnicodeClassIs(String,UnicodeClass) Method

[image]
ActiveReports 19 .NET Edition
DetermineUnicodeClassIs(String,UnicodeClass) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class > DetermineUnicodeClassIs Method : DetermineUnicodeClassIs(String,UnicodeClass) Method

unicodeCharacter
The Unicode character as a string.
unicodeClass
The bidirectional class to check.

Glossary Item Box

Determines if a Unicode character belongs to a specified bidirectional class.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DetermineUnicodeClassIs( _
   ByVal unicodeCharacter As String, _
   ByVal unicodeClass As UnicodeClass _
) As Boolean
C#
public static bool DetermineUnicodeClassIs(
   string unicodeCharacter,
   UnicodeClass unicodeClass
)

Parameters

unicodeCharacter
The Unicode character as a string.
unicodeClass
The bidirectional class to check.

Return Value

true if the character belongs to the specified class; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members
Overload List


DetermineUnicodeClassIs(Int32,UnicodeClass) Method

[image]
ActiveReports 19 .NET Edition
DetermineUnicodeClassIs(Int32,UnicodeClass) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class > DetermineUnicodeClassIs Method : DetermineUnicodeClassIs(Int32,UnicodeClass) Method

unicodeValue
The Unicode character as an integer.
unicodeClass
The bidirectional class to check.

Glossary Item Box

Determines if a Unicode character belongs to a specified bidirectional class.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DetermineUnicodeClassIs( _
   ByVal unicodeValue As Integer, _
   ByVal unicodeClass As UnicodeClass _
) As Boolean
C#
public static bool DetermineUnicodeClassIs(
   int unicodeValue,
   UnicodeClass unicodeClass
)

Parameters

unicodeValue
The Unicode character as an integer.
unicodeClass
The bidirectional class to check.

Return Value

true if the character belongs to the specified class; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members
Overload List


GetCodes Method

[image]
ActiveReports 19 .NET Edition
GetCodes Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : GetCodes Method

text
The text to get codes for.

Glossary Item Box

Gets the codes for the specified text.

Syntax

Visual Basic (Declaration)
Public Shared Function GetCodes( _
   ByVal text As String _
) As Byte()
C#
public static byte[] GetCodes(
   string text
)

Parameters

text
The text to get codes for.

Return Value

An array of bytes representing the codes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


GetSplitRanges Method

[image]
ActiveReports 19 .NET Edition
GetSplitRanges Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : GetSplitRanges Method

types
The array of CharType.

Glossary Item Box

Creates a collection of ranges with common levels.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSplitRanges( _
   ByVal types() As CharType _
) As List(Of MapEntry)
C#
public static List<MapEntry> GetSplitRanges(
   CharType[] types
)

Parameters

types
The array of CharType.

Return Value

A list of MapEntry representing the ranges.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


IsFirstStrongCharacterType Method

[image]
ActiveReports 19 .NET Edition
IsFirstStrongCharacterType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : IsFirstStrongCharacterType Method

unicodeClass
The Unicode class to check.

Glossary Item Box

Determines if the Unicode class is a strong character type.

Syntax

Visual Basic (Declaration)
Public Shared Function IsFirstStrongCharacterType( _
   ByVal unicodeClass As UnicodeClass _
) As Boolean
C#
public static bool IsFirstStrongCharacterType(
   UnicodeClass unicodeClass
)

Parameters

unicodeClass
The Unicode class to check.

Return Value

true if the class is a strong character type; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


MirrorUnicodeString Method

[image]
ActiveReports 19 .NET Edition
MirrorUnicodeString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : MirrorUnicodeString Method

s
The input string.

Glossary Item Box

Searches the Mirroring table to determine if characters in the string need to be mirrored.

Syntax

Visual Basic (Declaration)
Public Shared Function MirrorUnicodeString( _
   ByVal s As String _
) As String
C#
public static string MirrorUnicodeString(
   string s
)

Parameters

s
The input string.

Return Value

The mirrored string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


NeedsSplit Method

[image]
ActiveReports 19 .NET Edition
NeedsSplit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : NeedsSplit Method

types
The array of CharType.

Glossary Item Box

Determines if an array of CharType needs to be split into different embedding objects.

Syntax

Visual Basic (Declaration)
Public Shared Function NeedsSplit( _
   ByVal types() As CharType _
) As Boolean
C#
public static bool NeedsSplit(
   CharType[] types
)

Parameters

types
The array of CharType.

Return Value

true if the array needs to be split; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


StringFromCharType Method

[image]
ActiveReports 19 .NET Edition
StringFromCharType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : StringFromCharType Method

Glossary Item Box

Converts a portion of an array of CharType to a Unicode string.

Overload List

Overload | Description
StringFromCharType(CharType[],Int32,Int32) | Converts a portion of an array of CharType to a Unicode string.
StringFromCharType(CharType[]) | Converts an array of CharType to a Unicode string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


StringFromCharType(CharType[],Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
StringFromCharType(CharType[],Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class > StringFromCharType Method : StringFromCharType(CharType[],Int32,Int32) Method

types
The array of CharType.
start
The starting index.
length
The length of the portion.

Glossary Item Box

Converts a portion of an array of CharType to a Unicode string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function StringFromCharType( _
   ByVal types() As CharType, _
   ByVal start As Integer, _
   ByVal length As Integer _
) As String
C#
public static string StringFromCharType(
   CharType[] types,
   int start,
   int length
)

Parameters

types
The array of CharType.
start
The starting index.
length
The length of the portion.

Return Value

The Unicode string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members
Overload List


StringFromCharType(CharType[]) Method

[image]
ActiveReports 19 .NET Edition
StringFromCharType(CharType[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class > StringFromCharType Method : StringFromCharType(CharType[]) Method

types
The array of CharType.

Glossary Item Box

Converts an array of CharType to a Unicode string.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function StringFromCharType( _
   ByVal types() As CharType _
) As String
C#
public static string StringFromCharType(
   CharType[] types
)

Parameters

types
The array of CharType.

Return Value

The Unicode string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members
Overload List


UpdateMap Method

[image]
ActiveReports 19 .NET Edition
UpdateMap Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > Helper Class : UpdateMap Method

indexRemoved
The index of the removed character.
map
The list of map entries to update.

Glossary Item Box

Allows the map to update all entries affected when a character is removed.

Syntax

Visual Basic (Declaration)
Public Shared Sub UpdateMap( _
   ByVal indexRemoved As Integer, _
   ByVal map As IList(Of MapEntry) _
)
C#
public static void UpdateMap(
   int indexRemoved,
   IList<MapEntry> map
)

Parameters

indexRemoved
The index of the removed character.
map
The list of map entries to update.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Helper Class
Helper Members


DirectionalOverrideStatus Enumeration

[image]
ActiveReports 19 .NET Edition
DirectionalOverrideStatus Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : DirectionalOverrideStatus Enumeration

Glossary Item Box

Defines the directional override status for the bidirectional algorithm.

Syntax

Visual Basic (Declaration)
Public Enum DirectionalOverrideStatus
   Inherits System.Enum
C#
public enum DirectionalOverrideStatus : System.Enum

Members

Member | Description
LeftToRight | Indicates a left-to-right directional override status.
Neutral | Indicates a neutral directional override status.
RightToLeft | Indicates a right-to-left directional override status.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Bidi.DirectionalOverrideStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Bidi Namespace


UnicodeCharacterCategory Enumeration

[image]
ActiveReports 19 .NET Edition
UnicodeCharacterCategory Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : UnicodeCharacterCategory Enumeration

Glossary Item Box

Represents different categories of Unicode characters.

Syntax

Visual Basic (Declaration)
Public Enum UnicodeCharacterCategory
   Inherits System.Enum
C#
public enum UnicodeCharacterCategory : System.Enum

Members

Member | Description
Neutral | Represents neutral Unicode character categories.
Strong | Represents strong Unicode character categories.
Weak | Represents weak Unicode character categories.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Bidi.UnicodeCharacterCategory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Bidi Namespace


UnicodeClass Enumeration

[image]
ActiveReports 19 .NET Edition
UnicodeClass Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : UnicodeClass Enumeration

Glossary Item Box

Different classes of Unicode characters.

Syntax

Visual Basic (Declaration)
Public Enum UnicodeClass
   Inherits System.Enum
C#
public enum UnicodeClass : System.Enum

Members

Member | Description
ArabicLetter | Right-to-Left Arabic
ArabicNumber | Arabic Number
BoundaryNeutral | Boundary Neutral
CommonSeparator | Common Number Separator
EmbedLtr | Left-to-Right Embedding
EmbedRtl | Right-to-Left Embedding
EuropeanNumber | European Number
EuropeanSeparator | European Number Separator
EuropeanTerminator | European Number Terminator
LeftToRight | Left-to-right
NonSpacingMark | Non-Spacing Mark
OtherNeutral | Other Neutrals
OverrideLtr | Left-to-Right Override
OverrideRtl | Right-to-Left Override
ParagraphSeparator | Paragraph Separator
Pop | Pop Directional Format
RightToLeft | Right-to-Left
SegmentSeparator | Segment Separator
WhiteSpace | Whitespace

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Bidi.UnicodeClass

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Bidi Namespace


CharType Structure

[image]
ActiveReports 19 .NET Edition
CharType Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : CharType Structure

Glossary Item Box

Represents a character for processing the bidirectional algorithm.

Object Model

CharType Structure

Syntax

Visual Basic (Declaration)
Public Structure CharType
   Inherits System.ValueType
C#
public struct CharType : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Bidi.CharType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


CharType Structure Members

[image]
ActiveReports 19 .NET Edition
CharType Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : CharType Structure

Glossary Item Box

The following tables list the members exposed by CharType.

Public Constructors

 | Name | Description
Public Constructor | CharType Constructor | Initializes a new instance of the CharType struct with the specified Unicode character and level override.
Top

Public Fields

 | Name | Description
Public Field | HighValue | Gets or sets the high character value.
Public Field | LevelOverride | Gets or sets the level override for the character.
Public Field | LowValue | Gets or sets the low character value.
Public Field | UnicodeClass | Gets or sets the Unicode class of the character.
Public Field | Value | Gets or sets the original Unicode character as a string.
Top

See Also

Reference

CharType Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


CharType Constructor

[image]
ActiveReports 19 .NET Edition
CharType Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : CharType Constructor

unicodeChar
The Unicode character as a string.
levelOverride
The level override for the character.

Glossary Item Box

Initializes a new instance of the CharType struct with the specified Unicode character and level override.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal unicodeChar As String, _
   ByVal levelOverride As LevelOverride _
)
C#
public CharType(
   string unicodeChar,
   LevelOverride levelOverride
)

Parameters

unicodeChar
The Unicode character as a string.
levelOverride
The level override for the character.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


CharType Structure Fields

[image]
ActiveReports 19 .NET Edition
CharType Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : CharType Structure

Glossary Item Box

For a list of all members of this type, see CharType members.

Public Fields

 | Name | Description
Public Field | HighValue | Gets or sets the high character value.
Public Field | LevelOverride | Gets or sets the level override for the character.
Public Field | LowValue | Gets or sets the low character value.
Public Field | UnicodeClass | Gets or sets the Unicode class of the character.
Public Field | Value | Gets or sets the original Unicode character as a string.
Top

See Also

Reference

CharType Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


HighValue Field

[image]
ActiveReports 19 .NET Edition
HighValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : HighValue Field

Glossary Item Box

Gets or sets the high character value.

Syntax

Visual Basic (Declaration)
Public HighValue As Char
C#
public char HighValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


LevelOverride Field

[image]
ActiveReports 19 .NET Edition
LevelOverride Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : LevelOverride Field

Glossary Item Box

Gets or sets the level override for the character.

Syntax

Visual Basic (Declaration)
Public LevelOverride As LevelOverride
C#
public LevelOverride LevelOverride

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


LowValue Field

[image]
ActiveReports 19 .NET Edition
LowValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : LowValue Field

Glossary Item Box

Gets or sets the low character value.

Syntax

Visual Basic (Declaration)
Public LowValue As Char
C#
public char LowValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


UnicodeClass Field

[image]
ActiveReports 19 .NET Edition
UnicodeClass Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : UnicodeClass Field

Glossary Item Box

Gets or sets the Unicode class of the character.

Syntax

Visual Basic (Declaration)
Public UnicodeClass As UnicodeClass
C#
public UnicodeClass UnicodeClass

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > CharType Structure : Value Field

Glossary Item Box

Gets or sets the original Unicode character as a string.

Syntax

Visual Basic (Declaration)
Public Value As String
C#
public string Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CharType Structure
CharType Members


LevelOverride Structure

[image]
ActiveReports 19 .NET Edition
LevelOverride Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelOverride Structure

Glossary Item Box

Represents an embedding level and embedding direction.

Object Model

LevelOverride Structure

Syntax

Visual Basic (Declaration)
Public Structure LevelOverride
   Inherits System.ValueType
C#
public struct LevelOverride : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Bidi.LevelOverride

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelOverride Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


LevelOverride Structure Members

[image]
ActiveReports 19 .NET Edition
LevelOverride Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelOverride Structure

Glossary Item Box

The following tables list the members exposed by LevelOverride.

Public Constructors

 | Name | Description
Public Constructor | LevelOverride Constructor | Initializes a new instance of the LevelOverride struct with the specified level and directional override status.
Top

Public Fields

 | Name | Description
Public Field | Level | Gets or sets the embedding level.
Public Field | OverrideStatus | Gets or sets the directional override status.
Top

See Also

Reference

LevelOverride Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


LevelOverride Constructor

[image]
ActiveReports 19 .NET Edition
LevelOverride Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelOverride Structure : LevelOverride Constructor

level
The embedding level.
overrideStatus
The directional override status.

Glossary Item Box

Initializes a new instance of the LevelOverride struct with the specified level and directional override status.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal level As Integer, _
   ByVal overrideStatus As DirectionalOverrideStatus _
)
C#
public LevelOverride(
   int level,
   DirectionalOverrideStatus overrideStatus
)

Parameters

level
The embedding level.
overrideStatus
The directional override status.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelOverride Structure
LevelOverride Members


LevelOverride Structure Fields

[image]
ActiveReports 19 .NET Edition
LevelOverride Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelOverride Structure

Glossary Item Box

For a list of all members of this type, see LevelOverride members.

Public Fields

 | Name | Description
Public Field | Level | Gets or sets the embedding level.
Public Field | OverrideStatus | Gets or sets the directional override status.
Top

See Also

Reference

LevelOverride Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


Level Field

[image]
ActiveReports 19 .NET Edition
Level Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelOverride Structure : Level Field

Glossary Item Box

Gets or sets the embedding level.

Syntax

Visual Basic (Declaration)
Public Level As Integer
C#
public int Level

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelOverride Structure
LevelOverride Members


OverrideStatus Field

[image]
ActiveReports 19 .NET Edition
OverrideStatus Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelOverride Structure : OverrideStatus Field

Glossary Item Box

Gets or sets the directional override status.

Syntax

Visual Basic (Declaration)
Public OverrideStatus As DirectionalOverrideStatus
C#
public DirectionalOverrideStatus OverrideStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelOverride Structure
LevelOverride Members


LevelRun Structure

[image]
ActiveReports 19 .NET Edition
LevelRun Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelRun Structure

Glossary Item Box

Represents a level run - an array of CharType, embedding level of the run, and the start and end of the run.

Object Model

LevelRun Structure

Syntax

Visual Basic (Declaration)
Public Structure LevelRun
   Inherits System.ValueType
C#
public struct LevelRun : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Bidi.LevelRun

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


LevelRun Structure Members

[image]
ActiveReports 19 .NET Edition
LevelRun Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelRun Structure

Glossary Item Box

The following tables list the members exposed by LevelRun.

Public Fields

 | Name | Description
Public Field | Characters | Gets or sets the array of CharType that make up the run.
Public Field | Eor | Gets or sets the end of run Unicode class.
Public Field | Level | Gets or sets the embedding level of the run.
Public Field | Sor | Gets or sets the start of run Unicode class.
Top

Public Properties

 | Name | Description
Public Property | OrderingType | Gets the ordering type of the run based on the embedding level.
Top

See Also

Reference

LevelRun Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


LevelRun Structure Properties

[image]
ActiveReports 19 .NET Edition
LevelRun Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelRun Structure

Glossary Item Box

For a list of all members of this type, see LevelRun members.

Public Properties

 | Name | Description
Public Property | OrderingType | Gets the ordering type of the run based on the embedding level.
Top

See Also

Reference

LevelRun Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


OrderingType Property

[image]
ActiveReports 19 .NET Edition
OrderingType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelRun Structure : OrderingType Property

Glossary Item Box

Gets the ordering type of the run based on the embedding level.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderingType As UnicodeClass
C#
public UnicodeClass OrderingType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Structure
LevelRun Members


LevelRun Structure Fields

[image]
ActiveReports 19 .NET Edition
LevelRun Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : LevelRun Structure

Glossary Item Box

For a list of all members of this type, see LevelRun members.

Public Fields

 | Name | Description
Public Field | Characters | Gets or sets the array of CharType that make up the run.
Public Field | Eor | Gets or sets the end of run Unicode class.
Public Field | Level | Gets or sets the embedding level of the run.
Public Field | Sor | Gets or sets the start of run Unicode class.
Top

See Also

Reference

LevelRun Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


Characters Field

[image]
ActiveReports 19 .NET Edition
Characters Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelRun Structure : Characters Field

Glossary Item Box

Gets or sets the array of CharType that make up the run.

Syntax

Visual Basic (Declaration)
Public Characters As CharType()
C#
public CharType[] Characters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Structure
LevelRun Members


Eor Field

[image]
ActiveReports 19 .NET Edition
Eor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelRun Structure : Eor Field

Glossary Item Box

Gets or sets the end of run Unicode class.

Syntax

Visual Basic (Declaration)
Public Eor As UnicodeClass
C#
public UnicodeClass Eor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Structure
LevelRun Members


Level Field

[image]
ActiveReports 19 .NET Edition
Level Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelRun Structure : Level Field

Glossary Item Box

Gets or sets the embedding level of the run.

Syntax

Visual Basic (Declaration)
Public Level As Integer
C#
public int Level

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Structure
LevelRun Members


Sor Field

[image]
ActiveReports 19 .NET Edition
Sor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > LevelRun Structure : Sor Field

Glossary Item Box

Gets or sets the start of run Unicode class.

Syntax

Visual Basic (Declaration)
Public Sor As UnicodeClass
C#
public UnicodeClass Sor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LevelRun Structure
LevelRun Members


MapEntry Structure

[image]
ActiveReports 19 .NET Edition
MapEntry Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : MapEntry Structure

Glossary Item Box

Stores the start and length of a text run.

Object Model

MapEntry Structure

Syntax

Visual Basic (Declaration)
Public Structure MapEntry
   Inherits System.ValueType
C#
public struct MapEntry : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Bidi.MapEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapEntry Members
GrapeCity.ActiveReports.Rendering.Bidi Namespace


MapEntry Structure Members

[image]
ActiveReports 19 .NET Edition
MapEntry Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : MapEntry Structure

Glossary Item Box

The following tables list the members exposed by MapEntry.

Public Constructors

 | Name | Description
Public Constructor | MapEntry Constructor | Initializes a new instance of the MapEntry struct with the specified start and length.
Top

Public Fields

 | Name | Description
Public Field | Length | Gets or sets the length of the text run.
Public Field | Start | Gets or sets the start index of the text run.
Top

See Also

Reference

MapEntry Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


MapEntry Constructor

[image]
ActiveReports 19 .NET Edition
MapEntry Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > MapEntry Structure : MapEntry Constructor

start
The start index of the text run.
length
The length of the text run.

Glossary Item Box

Initializes a new instance of the MapEntry struct with the specified start and length.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
C#
public MapEntry(
   int start,
   int length
)

Parameters

start
The start index of the text run.
length
The length of the text run.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapEntry Structure
MapEntry Members


MapEntry Structure Fields

[image]
ActiveReports 19 .NET Edition
MapEntry Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace : MapEntry Structure

Glossary Item Box

For a list of all members of this type, see MapEntry members.

Public Fields

 | Name | Description
Public Field | Length | Gets or sets the length of the text run.
Public Field | Start | Gets or sets the start index of the text run.
Top

See Also

Reference

MapEntry Structure
GrapeCity.ActiveReports.Rendering.Bidi Namespace


Length Field

[image]
ActiveReports 19 .NET Edition
Length Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > MapEntry Structure : Length Field

Glossary Item Box

Gets or sets the length of the text run.

Syntax

Visual Basic (Declaration)
Public Length As Integer
C#
public int Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapEntry Structure
MapEntry Members


Start Field

[image]
ActiveReports 19 .NET Edition
Start Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Bidi Namespace > MapEntry Structure : Start Field

Glossary Item Box

Gets or sets the start index of the text run.

Syntax

Visual Basic (Declaration)
Public Start As Integer
C#
public int Start

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapEntry Structure
MapEntry Members


ActionProgram Class

[image]
ActiveReports 19 .NET Edition
ActionProgram Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ActionProgram Class

Glossary Item Box

DNA for GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction objects.

Object Model

ActionProgram Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ActionProgram
   Inherits ProgramBase
   Implements IProgram
C#
public sealed class ActionProgram : ProgramBase, IProgram

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ProgramBase
GrapeCity.ActiveReports.Rendering.Components.ActionProgram

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ActionProgram Class Members

[image]
ActiveReports 19 .NET Edition
ActionProgram Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ActionProgram Class

Glossary Item Box

The following tables list the members exposed by ActionProgram.

Public Constructors

 | Name | Description
Public Constructor | ActionProgram Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | ActionType |
Public Field | BookmarkLink |
Public Field | Definition |
Public Field | DrillThroughReportName |
Public Field | HyperLink |
Top

Public Methods

 | Name | Description
Public Method | Create |
Top

See Also

Reference

ActionProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ActionProgram Constructor

[image]
ActiveReports 19 .NET Edition
ActionProgram Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : ActionProgram Constructor

Glossary Item Box

Overload List

Overload | Description
ActionProgram Constructor(IProgramServices,Action,Content) |
ActionProgram Constructor(ProgramBase,Action) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


ActionProgram Constructor(IProgramServices,Action,Content)

[image]
ActiveReports 19 .NET Edition
ActionProgram Constructor(IProgramServices,Action,Content)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class > ActionProgram Constructor : ActionProgram Constructor(IProgramServices,Action,Content)

services
action
dataContent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal services As IProgramServices, _
   ByVal action As Action, _
   ByVal dataContent As Def.Content _
)
C#
public ActionProgram(
   IProgramServices services,
   Action action,
   Def.Content dataContent
)

Parameters

services
action
dataContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members
Overload List


ActionProgram Constructor(ProgramBase,Action)

[image]
ActiveReports 19 .NET Edition
ActionProgram Constructor(ProgramBase,Action)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class > ActionProgram Constructor : ActionProgram Constructor(ProgramBase,Action)

item
action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As ProgramBase, _
   ByVal action As Action _
)
C#
public ActionProgram(
   ProgramBase item,
   Action action
)

Parameters

item
action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members
Overload List


ActionProgram Class Methods

[image]
ActiveReports 19 .NET Edition
ActionProgram Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ActionProgram Class

Glossary Item Box

For a list of all members of this type, see ActionProgram members.

Public Methods

 | Name | Description
Public Method | Create |
Top

See Also

Reference

ActionProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : Create Method

scope
evaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Create( _
   ByVal scope As IDataScopeInternal, _
   Optional ByVal evaluator As IExpressionEvaluatorService _
) As IAction
C#
public IAction Create(
   IDataScopeInternal scope,
   IExpressionEvaluatorService evaluator
)

Parameters

scope
evaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


ActionProgram Class Fields

[image]
ActiveReports 19 .NET Edition
ActionProgram Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ActionProgram Class

Glossary Item Box

For a list of all members of this type, see ActionProgram members.

Public Fields

 | Name | Description
Public Field | ActionType |
Public Field | BookmarkLink |
Public Field | Definition |
Public Field | DrillThroughReportName |
Public Field | HyperLink |
Top

See Also

Reference

ActionProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ActionType Field

[image]
ActiveReports 19 .NET Edition
ActionType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : ActionType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ActionType As ActionType
C#
public readonly ActionType ActionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


BookmarkLink Field

[image]
ActiveReports 19 .NET Edition
BookmarkLink Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : BookmarkLink Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BookmarkLink As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BookmarkLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


Definition Field

[image]
ActiveReports 19 .NET Edition
Definition Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : Definition Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Definition As Action
C#
public readonly Action Definition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


DrillThroughReportName Field

[image]
ActiveReports 19 .NET Edition
DrillThroughReportName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : DrillThroughReportName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly DrillThroughReportName As EvalFunc(Of String)
C#
public readonly EvalFunc<string> DrillThroughReportName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


HyperLink Field

[image]
ActiveReports 19 .NET Edition
HyperLink Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ActionProgram Class : HyperLink Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HyperLink As EvalFunc(Of String)
C#
public readonly EvalFunc<string> HyperLink

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionProgram Class
ActionProgram Members


DataRegion Class

[image]
ActiveReports 19 .NET Edition
DataRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegion Class

Glossary Item Box

Provides a base class for ReportItems that represent the layout of a data set in the report.

Object Model

DataRegion Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataRegion
   Inherits ReportItem
   Implements GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Layout.IContentRange, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageNameProvider, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemRenderInfo, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticable, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver, GrapeCity.ActiveReports.Rendering.Components.Interfaces.ITocAnchoredItem, GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject
C#
public abstract class DataRegion : ReportItem, GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Layout.IContentRange, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageNameProvider, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemRenderInfo, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticable, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver, GrapeCity.ActiveReports.Rendering.Components.Interfaces.ITocAnchoredItem, GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.RenderComponent
GrapeCity.ActiveReports.Rendering.Components.ReportItem
GrapeCity.ActiveReports.Rendering.Components.DataRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Members
GrapeCity.ActiveReports.Rendering.Components Namespace


DataRegion Class Members

[image]
ActiveReports 19 .NET Edition
DataRegion Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegion Class

Glossary Item Box

The following tables list the members exposed by DataRegion.

Public Properties

 | Name | Description
Public Property | DataSetName | Specifies which data set to use for this data region.
Public Property | EndSection | Specifies where the layout should continue.
Public Property | FixedHeight |
Public Property | FixedWidth |
Public Property | NewSection |
Public Property | NoRows | Indicates if the DataRegion has no rows available.
Public Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available.
Public Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Public Property | OverflowName |
Public Property | PageBreakAtEnd | Indicates the report should page break at the end of the data region.
Public Property | PageBreakAtStart | Indicates the report should page break at the start of the data region
Public Property | PageName |
Top

See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.Rendering.Components Namespace


DataRegion Class Properties

[image]
ActiveReports 19 .NET Edition
DataRegion Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegion Class

Glossary Item Box

For a list of all members of this type, see DataRegion members.

Public Properties

 | Name | Description
Public Property | DataSetName | Specifies which data set to use for this data region.
Public Property | EndSection | Specifies where the layout should continue.
Public Property | FixedHeight |
Public Property | FixedWidth |
Public Property | NewSection |
Public Property | NoRows | Indicates if the DataRegion has no rows available.
Public Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available.
Public Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Public Property | OverflowName |
Public Property | PageBreakAtEnd | Indicates the report should page break at the end of the data region.
Public Property | PageBreakAtStart | Indicates the report should page break at the start of the data region
Public Property | PageName |
Top

See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.Rendering.Components Namespace


DataSetName Property

[image]
ActiveReports 19 .NET Edition
DataSetName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : DataSetName Property

Glossary Item Box

Specifies which data set to use for this data region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSetName As String
C#
public string DataSetName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


EndSection Property

[image]
ActiveReports 19 .NET Edition
EndSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : EndSection Property

Glossary Item Box

Specifies where the layout should continue.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndSection As EndSection
C#
public EndSection EndSection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


FixedHeight Property

[image]
ActiveReports 19 .NET Edition
FixedHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : FixedHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FixedHeight As Length
C#
public Length FixedHeight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


FixedWidth Property

[image]
ActiveReports 19 .NET Edition
FixedWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : FixedWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FixedWidth As Length
C#
public Length FixedWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NewSection Property

[image]
ActiveReports 19 .NET Edition
NewSection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : NewSection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NewSection As Boolean
C#
public virtual bool NewSection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : NoRows Property

Glossary Item Box

Indicates if the DataRegion has no rows available.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NoRows As Boolean
C#
public virtual bool NoRows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NoRowsMessage Property

[image]
ActiveReports 19 .NET Edition
NoRowsMessage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : NoRowsMessage Property

Glossary Item Box

Message to display in the DataRegion when no rows of data are available.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoRowsMessage As String
C#
public string NoRowsMessage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


NoRowsTextBox Property

[image]
ActiveReports 19 .NET Edition
NoRowsTextBox Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : NoRowsTextBox Property

Glossary Item Box

Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoRowsTextBox As ITextBox
C#
public ITextBox NoRowsTextBox {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


OverflowName Property

[image]
ActiveReports 19 .NET Edition
OverflowName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : OverflowName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OverflowName As String
C#
public string OverflowName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtEnd Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtEnd Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : PageBreakAtEnd Property

Glossary Item Box

Indicates the report should page break at the end of the data region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageBreakAtEnd As Boolean
C#
public bool PageBreakAtEnd {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtStart Property

[image]
ActiveReports 19 .NET Edition
PageBreakAtStart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : PageBreakAtStart Property

Glossary Item Box

Indicates the report should page break at the start of the data region

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageBreakAtStart As Boolean
C#
public bool PageBreakAtStart {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegion Class : PageName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageName As String
C#
public string PageName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegion Class
DataRegion Members


DataRegionProgram<T> Class

T
[image]
ActiveReports 19 .NET Edition
DataRegionProgram<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegionProgram<T> Class

Glossary Item Box

Represents a data region program.

Object Model

DataRegionProgram<T> Class

Syntax

Visual Basic (Declaration)
Public Class DataRegionProgram(Of T As DataRegion)
   Inherits ReportItemProgram(Of T)
   Implements IProgram, IReportItemProgram(Of T), IReportItemProgram(Of )
C#
public class DataRegionProgram<T> : ReportItemProgram<T>, IProgram, IReportItemProgram<T>, IReportItemProgram<>
where T: DataRegion

Type Parameters

T

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ProgramBase
GrapeCity.ActiveReports.Rendering.Components.ReportItemProgram<T>
GrapeCity.ActiveReports.Rendering.Components.DataRegionProgram<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegionProgram<T> Members
GrapeCity.ActiveReports.Rendering.Components Namespace


DataRegionProgram<T> Class Members

[image]
ActiveReports 19 .NET Edition
DataRegionProgram<T> Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegionProgram<T> Class

Glossary Item Box

The following tables list the members exposed by DataRegionProgram<T>.

Public Constructors

 | Name | Description
Public Constructor | DataRegionProgram<T> Constructor |
Top

Public Properties

 | Name | Description
Public Property | NoRows |
Public Property | PageName |
Top

See Also

Reference

DataRegionProgram<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


DataRegionProgram<T> Constructor

[image]
ActiveReports 19 .NET Edition
DataRegionProgram<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegionProgram<T> Class : DataRegionProgram<T> Constructor

services
item
dataContent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal services As IProgramServices, _
   ByVal item As T, _
   ByVal dataContent As Def.Content _
)
C#
public DataRegionProgram<T>(
   IProgramServices services,
   T item,
   Def.Content dataContent
)

Parameters

services
item
dataContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegionProgram<T> Class
DataRegionProgram<T> Members


DataRegionProgram<T> Class Properties

[image]
ActiveReports 19 .NET Edition
DataRegionProgram<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : DataRegionProgram<T> Class

Glossary Item Box

For a list of all members of this type, see DataRegionProgram<T> members.

Public Properties

 | Name | Description
Public Property | NoRows |
Public Property | PageName |
Top

See Also

Reference

DataRegionProgram<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegionProgram<T> Class : NoRows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoRows As EvalFunc(Of String)
C#
public EvalFunc<string> NoRows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegionProgram<T> Class
DataRegionProgram<T> Members


PageName Property

[image]
ActiveReports 19 .NET Edition
PageName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > DataRegionProgram<T> Class : PageName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageName As EvalFunc(Of String)
C#
public EvalFunc<string> PageName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRegionProgram<T> Class
DataRegionProgram<T> Members


EvalFunc<T> Class

T
[image]
ActiveReports 19 .NET Edition
EvalFunc<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : EvalFunc<T> Class

Glossary Item Box

Represents an expression eval interface.

Object Model

EvalFunc<T> Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class EvalFunc(Of T)
C#
public abstract class EvalFunc<T>

Type Parameters

T

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.EvalFunc<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalFunc<T> Members
GrapeCity.ActiveReports.Rendering.Components Namespace


EvalFunc<T> Class Members

[image]
ActiveReports 19 .NET Edition
EvalFunc<T> Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : EvalFunc<T> Class

Glossary Item Box

The following tables list the members exposed by EvalFunc<T>.

Public Properties

 | Name | Description
Public Property | IsConst |
Top

Public Methods

 | Name | Description
Public Method | Invoke |
Top

See Also

Reference

EvalFunc<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


EvalFunc<T> Class Methods

[image]
ActiveReports 19 .NET Edition
EvalFunc<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : EvalFunc<T> Class

Glossary Item Box

For a list of all members of this type, see EvalFunc<T> members.

Public Methods

 | Name | Description
Public Method | Invoke |
Top

See Also

Reference

EvalFunc<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Invoke Method

[image]
ActiveReports 19 .NET Edition
Invoke Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > EvalFunc<T> Class : Invoke Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MustOverride Function Invoke( _
   ByVal scope As IDataScopeInternal _
) As T
C#
public abstract T Invoke(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalFunc<T> Class
EvalFunc<T> Members


EvalFunc<T> Class Properties

[image]
ActiveReports 19 .NET Edition
EvalFunc<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : EvalFunc<T> Class

Glossary Item Box

For a list of all members of this type, see EvalFunc<T> members.

Public Properties

 | Name | Description
Public Property | IsConst |
Top

See Also

Reference

EvalFunc<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


IsConst Property

[image]
ActiveReports 19 .NET Edition
IsConst Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > EvalFunc<T> Class : IsConst Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsConst As Boolean
C#
public abstract bool IsConst {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvalFunc<T> Class
EvalFunc<T> Members


ImageExtensions Class

[image]
ActiveReports 19 .NET Edition
ImageExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ImageExtensions Class

Glossary Item Box

Represents an extension methods for GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage

Object Model

ImageExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ImageExtensions
C#
public static class ImageExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ImageExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageExtensions Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ImageExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ImageExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ImageExtensions Class

Glossary Item Box

The following tables list the members exposed by ImageExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImageData | Resolve GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo for GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage This method is using GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService service for image retreival. Returns an GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo instance.
Top

See Also

Reference

ImageExtensions Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ImageExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ImageExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ImageExtensions Class

Glossary Item Box

For a list of all members of this type, see ImageExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImageData | Resolve GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo for GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage This method is using GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService service for image retreival. Returns an GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo instance.
Top

See Also

Reference

ImageExtensions Class
GrapeCity.ActiveReports.Rendering.Components Namespace


GetImageData Method

[image]
ActiveReports 19 .NET Edition
GetImageData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ImageExtensions Class : GetImageData Method

image
allowEmfWmf

Glossary Item Box

Resolve GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo for GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage This method is using GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService service for image retreival. Returns an GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo instance.

Syntax

Visual Basic (Declaration)
Public Shared Function GetImageData( _
   ByVal image As IImage, _
   Optional ByVal allowEmfWmf As Boolean _
) As ImageInfo
C#
public static ImageInfo GetImageData(
   IImage image,
   bool allowEmfWmf
)

Parameters

image
allowEmfWmf

Remarks

This method is using GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService service for image retreival.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageExtensions Class
ImageExtensions Members


InteractiveArea Class

[image]
ActiveReports 19 .NET Edition
InteractiveArea Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveArea Class

Glossary Item Box

Encapsulates interactivity area shape and related action.

Object Model

InteractiveArea Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InteractiveArea
C#
public sealed class InteractiveArea

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.InteractiveArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Members
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveArea Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveArea Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveArea Class

Glossary Item Box

The following tables list the members exposed by InteractiveArea.

Public Constructors

 | Name | Description
Public Constructor | InteractiveArea Constructor | Creates area.
Top

Public Fields

 | Name | Description
Public Field | Action | Interactive action.
Public Field | ActionKey | Describes Action key (report item+sorting/toggle type hint)
Public Field | ControllerState | Specifies IToggleController/ISortingController state.
Public Field | EventType |
Public Field | Id | Identifier of the area.
Public Field | Region | Bounds of the interactive area.
Public Field | Tooltip | Tooltip shown for the interactive area.
Top

Public Properties

 | Name | Description
Public Property | PageNumber |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateSorting |
static (Shared in Visual Basic) | CreateToggle |
Top

See Also

Reference

InteractiveArea Class
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveArea Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveArea Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : InteractiveArea Constructor

id
Identifier.
shape
Interactive area.
action
Interactive action attached to the area.
tooltip
Tooltip to be shown on hover on the area.

Glossary Item Box

Creates area.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String, _
   ByVal shape As RegionEx, _
   ByVal action As IAction, _
   Optional ByVal tooltip As Tooltip _
)
C#
public InteractiveArea(
   string id,
   RegionEx shape,
   IAction action,
   Tooltip tooltip
)

Parameters

id
Identifier.
shape
Interactive area.
action
Interactive action attached to the area.
tooltip
Tooltip to be shown on hover on the area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


InteractiveArea Class Methods

[image]
ActiveReports 19 .NET Edition
InteractiveArea Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveArea Class

Glossary Item Box

For a list of all members of this type, see InteractiveArea members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateSorting |
static (Shared in Visual Basic) | CreateToggle |
Top

See Also

Reference

InteractiveArea Class
GrapeCity.ActiveReports.Rendering.Components Namespace


CreateSorting Method

[image]
ActiveReports 19 .NET Edition
CreateSorting Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : CreateSorting Method

sortState
region
actionKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateSorting( _
   ByVal sortState As SortState, _
   ByVal region As RegionEx, _
   ByVal actionKey As ActionKey _
) As InteractiveArea
C#
public static InteractiveArea CreateSorting(
   SortState sortState,
   RegionEx region,
   ActionKey actionKey
)

Parameters

sortState
region
actionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


CreateToggle Method

[image]
ActiveReports 19 .NET Edition
CreateToggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : CreateToggle Method

expanded
region
actionKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateToggle( _
   ByVal expanded As Boolean, _
   ByVal region As RegionEx, _
   ByVal actionKey As ActionKey _
) As InteractiveArea
C#
public static InteractiveArea CreateToggle(
   bool expanded,
   RegionEx region,
   ActionKey actionKey
)

Parameters

expanded
region
actionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


InteractiveArea Class Properties

[image]
ActiveReports 19 .NET Edition
InteractiveArea Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveArea Class

Glossary Item Box

For a list of all members of this type, see InteractiveArea members.

Public Properties

 | Name | Description
Public Property | PageNumber |
Top

See Also

Reference

InteractiveArea Class
GrapeCity.ActiveReports.Rendering.Components Namespace


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : PageNumber Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
C#
public int PageNumber {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


InteractiveArea Class Fields

[image]
ActiveReports 19 .NET Edition
InteractiveArea Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveArea Class

Glossary Item Box

For a list of all members of this type, see InteractiveArea members.

Public Fields

 | Name | Description
Public Field | Action | Interactive action.
Public Field | ActionKey | Describes Action key (report item+sorting/toggle type hint)
Public Field | ControllerState | Specifies IToggleController/ISortingController state.
Public Field | EventType |
Public Field | Id | Identifier of the area.
Public Field | Region | Bounds of the interactive area.
Public Field | Tooltip | Tooltip shown for the interactive area.
Top

See Also

Reference

InteractiveArea Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Action Field

[image]
ActiveReports 19 .NET Edition
Action Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : Action Field

Glossary Item Box

Interactive action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Action As IAction
C#
public readonly IAction Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


ActionKey Field

[image]
ActiveReports 19 .NET Edition
ActionKey Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : ActionKey Field

Glossary Item Box

Describes Action key (report item+sorting/toggle type hint)

Syntax

Visual Basic (Declaration)
Public ReadOnly ActionKey As ActionKey
C#
public readonly ActionKey ActionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


ControllerState Field

[image]
ActiveReports 19 .NET Edition
ControllerState Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : ControllerState Field

Glossary Item Box

Specifies IToggleController/ISortingController state.

Syntax

Visual Basic (Declaration)
Public ReadOnly ControllerState As String
C#
public readonly string ControllerState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


EventType Field

[image]
ActiveReports 19 .NET Edition
EventType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : EventType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly EventType As InteractiveEventTypes
C#
public readonly InteractiveEventTypes EventType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


Id Field

[image]
ActiveReports 19 .NET Edition
Id Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : Id Field

Glossary Item Box

Identifier of the area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Id As String
C#
public readonly string Id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


Region Field

[image]
ActiveReports 19 .NET Edition
Region Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : Region Field

Glossary Item Box

Bounds of the interactive area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Region As RegionEx
C#
public readonly RegionEx Region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


Tooltip Field

[image]
ActiveReports 19 .NET Edition
Tooltip Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveArea Class : Tooltip Field

Glossary Item Box

Tooltip shown for the interactive area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Tooltip As Tooltip
C#
public readonly Tooltip Tooltip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveArea Class
InteractiveArea Members


InteractiveStateStore Class

[image]
ActiveReports 19 .NET Edition
InteractiveStateStore Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStore Class

Glossary Item Box

Provides state of toggle/sort items within the report instance.

Object Model

InteractiveStateStore Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InteractiveStateStore
C#
public sealed class InteractiveStateStore

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.InteractiveStateStore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Members
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveStateStore Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveStateStore Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStore Class

Glossary Item Box

The following tables list the members exposed by InteractiveStateStore.

Public Constructors

 | Name | Description
Public Constructor | InteractiveStateStore Constructor | Default constructor.
Top

Public Properties

 | Name | Description
Public Property | SortStates |
Public Property | ToggleStates |
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates copy of the object.
Public Method | Reset |
Top

See Also

Reference

InteractiveStateStore Class
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveStateStore Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveStateStore Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStore Class : InteractiveStateStore Constructor

Glossary Item Box

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InteractiveStateStore()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Class
InteractiveStateStore Members


InteractiveStateStore Class Methods

[image]
ActiveReports 19 .NET Edition
InteractiveStateStore Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStore Class

Glossary Item Box

For a list of all members of this type, see InteractiveStateStore members.

Public Methods

 | Name | Description
Public Method | Clone | Creates copy of the object.
Public Method | Reset |
Top

See Also

Reference

InteractiveStateStore Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStore Class : Clone Method

Glossary Item Box

Creates copy of the object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As InteractiveStateStore
C#
public InteractiveStateStore Clone()

Return Value

New InteractiveStateStore object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Class
InteractiveStateStore Members


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStore Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Class
InteractiveStateStore Members


InteractiveStateStore Class Properties

[image]
ActiveReports 19 .NET Edition
InteractiveStateStore Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStore Class

Glossary Item Box

For a list of all members of this type, see InteractiveStateStore members.

Public Properties

 | Name | Description
Public Property | SortStates |
Public Property | ToggleStates |
Top

See Also

Reference

InteractiveStateStore Class
GrapeCity.ActiveReports.Rendering.Components Namespace


SortStates Property

[image]
ActiveReports 19 .NET Edition
SortStates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStore Class : SortStates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortStates As InteractiveSortState
C#
public InteractiveSortState SortStates {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Class
InteractiveStateStore Members


ToggleStates Property

[image]
ActiveReports 19 .NET Edition
ToggleStates Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStore Class : ToggleStates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToggleStates As InteractiveToggleState
C#
public InteractiveToggleState ToggleStates {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStore Class
InteractiveStateStore Members


InteractiveStateStoreExtensions Class

[image]
ActiveReports 19 .NET Edition
InteractiveStateStoreExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStoreExtensions Class

Glossary Item Box

Represents extension methods for interactive state store.

Object Model

InteractiveStateStoreExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class InteractiveStateStoreExtensions
C#
public static class InteractiveStateStoreExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.InteractiveStateStoreExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStoreExtensions Members
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveStateStoreExtensions Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveStateStoreExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStoreExtensions Class

Glossary Item Box

The following tables list the members exposed by InteractiveStateStoreExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Apply |
static (Shared in Visual Basic) | ApplyMany |
Top

See Also

Reference

InteractiveStateStoreExtensions Class
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveStateStoreExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
InteractiveStateStoreExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveStateStoreExtensions Class

Glossary Item Box

For a list of all members of this type, see InteractiveStateStoreExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Apply |
static (Shared in Visual Basic) | ApplyMany |
Top

See Also

Reference

InteractiveStateStoreExtensions Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Apply Method

[image]
ActiveReports 19 .NET Edition
Apply Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStoreExtensions Class : Apply Method

store
reportStore
actionKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Apply( _
   ByVal store As InteractiveStateStore, _
   ByVal reportStore As ReportStore, _
   ByVal actionKey As ActionKey _
)
C#
public static void Apply(
   InteractiveStateStore store,
   ReportStore reportStore,
   ActionKey actionKey
)

Parameters

store
reportStore
actionKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStoreExtensions Class
InteractiveStateStoreExtensions Members


ApplyMany Method

[image]
ActiveReports 19 .NET Edition
ApplyMany Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveStateStoreExtensions Class : ApplyMany Method

store
reportStore
keys

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub ApplyMany( _
   ByVal store As InteractiveStateStore, _
   ByVal reportStore As ReportStore, _
   ByVal keys As IEnumerable(Of ActionKey) _
)
C#
public static void ApplyMany(
   InteractiveStateStore store,
   ReportStore reportStore,
   IEnumerable<ActionKey> keys
)

Parameters

store
reportStore
keys

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveStateStoreExtensions Class
InteractiveStateStoreExtensions Members


InteractiveToggleState Class

[image]
ActiveReports 19 .NET Edition
InteractiveToggleState Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveToggleState Class

Glossary Item Box

Represents interactive toggle state.

Object Model

InteractiveToggleState Class

Syntax

Visual Basic (Declaration)
Public Class InteractiveToggleState
C#
public class InteractiveToggleState

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.InteractiveToggleState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Members
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveToggleState Class Members

[image]
ActiveReports 19 .NET Edition
InteractiveToggleState Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveToggleState Class

Glossary Item Box

The following tables list the members exposed by InteractiveToggleState.

Public Constructors

 | Name | Description
Public Constructor | InteractiveToggleState Constructor | Default constructor.
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CreateToggleMap | Creates the dependency of ReportItem from other ReportItems that contain toggles.Used to determine the visibility of nested items
Public Method | GetOrCreateRecursiveHierarchyMap |
Public Method | GetParentToggles | Returns a list containing the ReportItemKey on which the depends
Public Method | HasToggledContent |
Public Method | IsToggleStateChanged | Check if state of toggle item has been changed.
Public Method | SetEmptyToggle | Mark the toggle item as the one without content to be toggled. Used for recursive grouping.
Public Method | SetInitialState | Set initial state of the toggle item.
Public Method | Toggle | Toggles state of given toggle item withing the given data scope.
Top

See Also

Reference

InteractiveToggleState Class
GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveToggleState Constructor

[image]
ActiveReports 19 .NET Edition
InteractiveToggleState Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : InteractiveToggleState Constructor

Glossary Item Box

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InteractiveToggleState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


InteractiveToggleState Class Methods

[image]
ActiveReports 19 .NET Edition
InteractiveToggleState Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveToggleState Class

Glossary Item Box

For a list of all members of this type, see InteractiveToggleState members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CreateToggleMap | Creates the dependency of ReportItem from other ReportItems that contain toggles.Used to determine the visibility of nested items
Public Method | GetOrCreateRecursiveHierarchyMap |
Public Method | GetParentToggles | Returns a list containing the ReportItemKey on which the depends
Public Method | HasToggledContent |
Public Method | IsToggleStateChanged | Check if state of toggle item has been changed.
Public Method | SetEmptyToggle | Mark the toggle item as the one without content to be toggled. Used for recursive grouping.
Public Method | SetInitialState | Set initial state of the toggle item.
Public Method | Toggle | Toggles state of given toggle item withing the given data scope.
Top

See Also

Reference

InteractiveToggleState Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As InteractiveToggleState
C#
public InteractiveToggleState Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


CreateToggleMap Method

[image]
ActiveReports 19 .NET Edition
CreateToggleMap Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : CreateToggleMap Method

reportItemKey
A ReportItemKey that represents an element whose visibility can be changed by another ReportItemKey.
parentToggles
The list that contains the ReportItemKey on which the key depends.

Glossary Item Box

Creates the dependency of ReportItem from other ReportItems that contain toggles.Used to determine the visibility of nested items

Syntax

Visual Basic (Declaration)
Public Sub CreateToggleMap( _
   ByVal reportItemKey As ReportItemKey, _
   ByVal parentToggles As IList(Of ReportItemKey) _
)
C#
public void CreateToggleMap(
   ReportItemKey reportItemKey,
   IList<ReportItemKey> parentToggles
)

Parameters

reportItemKey
A ReportItemKey that represents an element whose visibility can be changed by another ReportItemKey.
parentToggles
The list that contains the ReportItemKey on which the key depends.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


GetOrCreateRecursiveHierarchyMap Method

[image]
ActiveReports 19 .NET Edition
GetOrCreateRecursiveHierarchyMap Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : GetOrCreateRecursiveHierarchyMap Method

key
createMap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetOrCreateRecursiveHierarchyMap( _
   ByVal key As ReportItemKey, _
   ByVal createMap As Func(Of IDictionary(Of Integer,Integer)) _
) As IDictionary(Of Integer,Integer)
C#
public IDictionary<int,int> GetOrCreateRecursiveHierarchyMap(
   ReportItemKey key,
   Func<IDictionary<int,int>> createMap
)

Parameters

key
createMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


GetParentToggles Method

[image]
ActiveReports 19 .NET Edition
GetParentToggles Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : GetParentToggles Method

key
A ReportItemKey that represents an element whose visibility can be changed by another ReportItemKey.

Glossary Item Box

Returns a list containing the ReportItemKey on which the depends

Syntax

Visual Basic (Declaration)
Public Function GetParentToggles( _
   ByVal key As ReportItemKey _
) As IList(Of ReportItemKey)
C#
public IList<ReportItemKey> GetParentToggles(
   ReportItemKey key
)

Parameters

key
A ReportItemKey that represents an element whose visibility can be changed by another ReportItemKey.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


HasToggledContent Method

[image]
ActiveReports 19 .NET Edition
HasToggledContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : HasToggledContent Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasToggledContent( _
   ByVal key As ReportItemKey _
) As Boolean
C#
public bool HasToggledContent(
   ReportItemKey key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


IsToggleStateChanged Method

[image]
ActiveReports 19 .NET Edition
IsToggleStateChanged Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : IsToggleStateChanged Method

toggleKey
The toggle's ReportItemKey. I.e. the key of item which toggle something.

Glossary Item Box

Check if state of toggle item has been changed.

Syntax

Visual Basic (Declaration)
Public Function IsToggleStateChanged( _
   ByVal toggleKey As ReportItemKey _
) As Boolean
C#
public bool IsToggleStateChanged(
   ReportItemKey toggleKey
)

Parameters

toggleKey
The toggle's ReportItemKey. I.e. the key of item which toggle something.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


SetEmptyToggle Method

[image]
ActiveReports 19 .NET Edition
SetEmptyToggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : SetEmptyToggle Method

toggleKey

Glossary Item Box

Mark the toggle item as the one without content to be toggled. Used for recursive grouping.

Syntax

Visual Basic (Declaration)
Public Sub SetEmptyToggle( _
   ByVal toggleKey As ReportItemKey _
)
C#
public void SetEmptyToggle(
   ReportItemKey toggleKey
)

Parameters

toggleKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


SetInitialState Method

[image]
ActiveReports 19 .NET Edition
SetInitialState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : SetInitialState Method

key

Glossary Item Box

Set initial state of the toggle item.

Syntax

Visual Basic (Declaration)
Public Sub SetInitialState( _
   ByVal key As ReportItemKey _
)
C#
public void SetInitialState(
   ReportItemKey key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


Toggle Method

[image]
ActiveReports 19 .NET Edition
Toggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > InteractiveToggleState Class : Toggle Method

key

Glossary Item Box

Toggles state of given toggle item withing the given data scope.

Syntax

Visual Basic (Declaration)
Public Sub Toggle( _
   ByVal key As ReportItemKey _
)
C#
public void Toggle(
   ReportItemKey key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveToggleState Class
InteractiveToggleState Members


LayoutAreaExtensionsPublic Class

[image]
ActiveReports 19 .NET Edition
LayoutAreaExtensionsPublic Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : LayoutAreaExtensionsPublic Class

Glossary Item Box

Represents extension methods for layout members.

Object Model

LayoutAreaExtensionsPublic Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class LayoutAreaExtensionsPublic
C#
public static class LayoutAreaExtensionsPublic

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.LayoutAreaExtensionsPublic

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutAreaExtensionsPublic Members
GrapeCity.ActiveReports.Rendering.Components Namespace


LayoutAreaExtensionsPublic Class Members

[image]
ActiveReports 19 .NET Edition
LayoutAreaExtensionsPublic Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : LayoutAreaExtensionsPublic Class

Glossary Item Box

The following tables list the members exposed by LayoutAreaExtensionsPublic.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAction | Gets the action for given area.
static (Shared in Visual Basic) | GetStyle | Gets the style for given area.
static (Shared in Visual Basic) | IsFixedPage | Returns true if report has FPL semantics.
static (Shared in Visual Basic) | SortedChildren | Gets sorted children of the given layout area.
Top

See Also

Reference

LayoutAreaExtensionsPublic Class
GrapeCity.ActiveReports.Rendering.Components Namespace


LayoutAreaExtensionsPublic Class Methods

[image]
ActiveReports 19 .NET Edition
LayoutAreaExtensionsPublic Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : LayoutAreaExtensionsPublic Class

Glossary Item Box

For a list of all members of this type, see LayoutAreaExtensionsPublic members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAction | Gets the action for given area.
static (Shared in Visual Basic) | GetStyle | Gets the style for given area.
static (Shared in Visual Basic) | IsFixedPage | Returns true if report has FPL semantics.
static (Shared in Visual Basic) | SortedChildren | Gets sorted children of the given layout area.
Top

See Also

Reference

LayoutAreaExtensionsPublic Class
GrapeCity.ActiveReports.Rendering.Components Namespace


GetAction Method

[image]
ActiveReports 19 .NET Edition
GetAction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > LayoutAreaExtensionsPublic Class : GetAction Method

area
The area.

Glossary Item Box

Gets the action for given area.

Syntax

Visual Basic (Declaration)
Public Shared Function GetAction( _
   ByVal area As ILayoutArea _
) As IAction
C#
public static IAction GetAction(
   ILayoutArea area
)

Parameters

area
The area.

Return Value

IAction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutAreaExtensionsPublic Class
LayoutAreaExtensionsPublic Members


GetStyle Method

[image]
ActiveReports 19 .NET Edition
GetStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > LayoutAreaExtensionsPublic Class : GetStyle Method

area
The area.

Glossary Item Box

Gets the style for given area.

Syntax

Visual Basic (Declaration)
Public Shared Function GetStyle( _
   ByVal area As ILayoutArea _
) As IStyle
C#
public static IStyle GetStyle(
   ILayoutArea area
)

Parameters

area
The area.

Return Value

IStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutAreaExtensionsPublic Class
LayoutAreaExtensionsPublic Members


IsFixedPage Method

[image]
ActiveReports 19 .NET Edition
IsFixedPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > LayoutAreaExtensionsPublic Class : IsFixedPage Method

report

Glossary Item Box

Returns true if report has FPL semantics.

Syntax

Visual Basic (Declaration)
Public Shared Function IsFixedPage( _
   ByVal report As IReport _
) As Boolean
C#
public static bool IsFixedPage(
   IReport report
)

Parameters

report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutAreaExtensionsPublic Class
LayoutAreaExtensionsPublic Members


SortedChildren Method

[image]
ActiveReports 19 .NET Edition
SortedChildren Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > LayoutAreaExtensionsPublic Class : SortedChildren Method

area
The area.

Glossary Item Box

Gets sorted children of the given layout area.

Syntax

Visual Basic (Declaration)
Public Shared Function SortedChildren( _
   ByVal area As ILayoutArea _
) As IEnumerable(Of ILayoutArea)
C#
public static IEnumerable<ILayoutArea> SortedChildren(
   ILayoutArea area
)

Parameters

area
The area.

Return Value

Sorted children of the given layout area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutAreaExtensionsPublic Class
LayoutAreaExtensionsPublic Members


MemoryImage Class

[image]
ActiveReports 19 .NET Edition
MemoryImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryImage Class

Glossary Item Box

Implementation of GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage that stores image properties in memory.

Object Model

MemoryImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MemoryImage
   Inherits MemoryReportItem
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public sealed class MemoryImage : MemoryReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IImage, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.MemoryReportItem
GrapeCity.ActiveReports.Rendering.Components.MemoryImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Members
GrapeCity.ActiveReports.Rendering.Components Namespace


MemoryImage Class Members

[image]
ActiveReports 19 .NET Edition
MemoryImage Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryImage Class

Glossary Item Box

The following tables list the members exposed by MemoryImage.

Public Constructors

 | Name | Description
Public Constructor | MemoryImage Constructor | Initializes a new instance of the MemoryImage class.
Top

Public Properties

 | Name | Description
Public Property | CanGrow | Gets the value specifing whether the image can grow.
Public Property | CanShrink | Gets the value specifing whether the image can shrink.
Public Property | HorizontalAlignment | Returns a copy of image data as System.Drawing.Image Gets or sets the horizontal alignment of the picture.
Public Property | MimeType | Gets or sets the mime type.
Public Property | Sizing | Gets or sets the GrapeCity.ActiveReports.PageReportModel.ImageSizing determining how a picture should be sized within the image report control area.
Public Property | Source | Gets or sets the image source.
Public Property | Value | Gets or sets the image object.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of the picture.
Top

Public Methods

 | Name | Description
Public Method | GetService | Overridden.
Top

See Also

Reference

MemoryImage Class
GrapeCity.ActiveReports.Rendering.Components Namespace


MemoryImage Constructor

[image]
ActiveReports 19 .NET Edition
MemoryImage Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : MemoryImage Constructor

Glossary Item Box

Initializes a new instance of the MemoryImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MemoryImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


MemoryImage Class Methods

[image]
ActiveReports 19 .NET Edition
MemoryImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryImage Class

Glossary Item Box

For a list of all members of this type, see MemoryImage members.

Public Methods

 | Name | Description
Public Method | GetService | Overridden.
Top

See Also

Reference

MemoryImage Class
GrapeCity.ActiveReports.Rendering.Components Namespace


GetService Method

[image]
ActiveReports 19 .NET Edition
GetService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : GetService Method

serviceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetService( _
   ByVal serviceType As Type _
) As Object
C#
public override object GetService(
   Type serviceType
)

Parameters

serviceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


MemoryImage Class Properties

[image]
ActiveReports 19 .NET Edition
MemoryImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryImage Class

Glossary Item Box

For a list of all members of this type, see MemoryImage members.

Public Properties

 | Name | Description
Public Property | CanGrow | Gets the value specifing whether the image can grow.
Public Property | CanShrink | Gets the value specifing whether the image can shrink.
Public Property | HorizontalAlignment | Returns a copy of image data as System.Drawing.Image Gets or sets the horizontal alignment of the picture.
Public Property | MimeType | Gets or sets the mime type.
Public Property | Sizing | Gets or sets the GrapeCity.ActiveReports.PageReportModel.ImageSizing determining how a picture should be sized within the image report control area.
Public Property | Source | Gets or sets the image source.
Public Property | Value | Gets or sets the image object.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of the picture.
Top

See Also

Reference

MemoryImage Class
GrapeCity.ActiveReports.Rendering.Components Namespace


CanGrow Property

[image]
ActiveReports 19 .NET Edition
CanGrow Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : CanGrow Property

Glossary Item Box

Gets the value specifing whether the image can grow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanGrow As Boolean
C#
public bool CanGrow {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


CanShrink Property

[image]
ActiveReports 19 .NET Edition
CanShrink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : CanShrink Property

Glossary Item Box

Gets the value specifing whether the image can shrink.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanShrink As Boolean
C#
public bool CanShrink {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


HorizontalAlignment Property

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : HorizontalAlignment Property

Glossary Item Box

Returns a copy of image data as System.Drawing.Image Gets or sets the horizontal alignment of the picture.

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlignment As String
C#
public string HorizontalAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


MimeType Property

[image]
ActiveReports 19 .NET Edition
MimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : MimeType Property

Glossary Item Box

Gets or sets the mime type.

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
C#
public string MimeType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


Sizing Property

[image]
ActiveReports 19 .NET Edition
Sizing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : Sizing Property

Glossary Item Box

Gets or sets the GrapeCity.ActiveReports.PageReportModel.ImageSizing determining how a picture should be sized within the image report control area.

Syntax

Visual Basic (Declaration)
Public Property Sizing As ImageSizing
C#
public ImageSizing Sizing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : Source Property

Glossary Item Box

Gets or sets the image source.

Syntax

Visual Basic (Declaration)
Public Property Source As ImageSource
C#
public ImageSource Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : Value Property

Glossary Item Box

Gets or sets the image object.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


VerticalAlignment Property

[image]
ActiveReports 19 .NET Edition
VerticalAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryImage Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the vertical alignment of the picture.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As String
C#
public string VerticalAlignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryImage Class
MemoryImage Members


MemoryReportItem Class

[image]
ActiveReports 19 .NET Edition
MemoryReportItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryReportItem Class

Glossary Item Box

Base implementation of GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem that stores report item properties in memory.

Object Model

MemoryReportItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MemoryReportItem
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
C#
public abstract class MemoryReportItem : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.MemoryReportItem
GrapeCity.ActiveReports.Rendering.Components.MemoryImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Members
GrapeCity.ActiveReports.Rendering.Components Namespace


MemoryReportItem Class Members

[image]
ActiveReports 19 .NET Edition
MemoryReportItem Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryReportItem Class

Glossary Item Box

The following tables list the members exposed by MemoryReportItem.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the Action object of this report item.
Public Property | Bookmark | Gets or sets a bookmark that can be linked to via a Bookmark action.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for this MemoryReportItem when rendered via a data oriented rendering extension (e.g. XML).
Public Property | DataElementOutput | Gets or sets the definition how the MemoryReportItem should appear in data output.
Public Property | Height | Gets or sets the height of the item.
Public Property | Hidden | Gets or sets the original visibility of the report item. Gets or sets the Indicator that this report item should be hidden.
Public Property | IsDynamicallyHidden | Gets or sets the Indicator that this report item has dynamic visiblity and is hidden.
Public Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Public Property | Label | Gets or sets a document map label.
Public Property | Left | Gets or sets the distance of the item from the left of the containing object.
Public Property | Name | Gets or sets the name of the MemoryReportItem.
Public Property | RenderComponents | Gets the render component objects.
Public Property | Style | Gets or sets the style of the report item.
Public Property | StyleName | Gets or sets a style name.
Public Property | TargetDevice | Gets output kinds in which report item is present (Screen, Export etc.)
Public Property | ToggleItem | Gets or sets the report item that users can click toggle the visibility of this item.
Public Property | ToolTip | Gets or sets a textual label for the item.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Width | Gets or sets the width of the item.
Public Property | ZIndex | Gets or sets the drawing order of the item within the containing object.
Top

Public Methods

 | Name | Description
Public Method | GetService | Gets the service object of the specified type.
Public Method | Initialize | Initializes the MemoryReportItem.
Public Method | OnClick | The wrapper for the OnClick event.
Top

See Also

Reference

MemoryReportItem Class
GrapeCity.ActiveReports.Rendering.Components Namespace


MemoryReportItem Class Methods

[image]
ActiveReports 19 .NET Edition
MemoryReportItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryReportItem Class

Glossary Item Box

For a list of all members of this type, see MemoryReportItem members.

Public Methods

 | Name | Description
Public Method | GetService | Gets the service object of the specified type.
Public Method | Initialize | Initializes the MemoryReportItem.
Public Method | OnClick | The wrapper for the OnClick event.
Top

See Also

Reference

MemoryReportItem Class
GrapeCity.ActiveReports.Rendering.Components Namespace


GetService Method

[image]
ActiveReports 19 .NET Edition
GetService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : GetService Method

serviceType
An object that specifies the type of service object to get.

Glossary Item Box

Gets the service object of the specified type.

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetService( _
   ByVal serviceType As Type _
) As Object
C#
public abstract object GetService(
   Type serviceType
)

Parameters

serviceType
An object that specifies the type of service object to get.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Initialize Method

[image]
ActiveReports 19 .NET Edition
Initialize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Initialize Method

dataContext
The data context associated with this report item.
properties
The property bag associated with this report item.

Glossary Item Box

Initializes the MemoryReportItem.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Initialize( _
   ByVal dataContext As IDataScope, _
   ByVal properties As IPropertyBag _
)
C#
public virtual void Initialize(
   IDataScope dataContext,
   IPropertyBag properties
)

Parameters

dataContext
The data context associated with this report item.
properties
The property bag associated with this report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


OnClick Method

[image]
ActiveReports 19 .NET Edition
OnClick Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : OnClick Method

reportItem
The report item clicked.
xPosition
The x position of the click.
yPosition
The y position of the click.
imageMapId
The image map ID.
button
The button that was clicked.

Glossary Item Box

The wrapper for the OnClick event.

Syntax

Visual Basic (Declaration)
Public Overridable Function OnClick( _
   ByVal reportItem As IReportItem, _
   ByVal xPosition As Integer, _
   ByVal yPosition As Integer, _
   ByVal imageMapId As String, _
   ByVal button As MouseButton _
) As ChangeResult
C#
public virtual ChangeResult OnClick(
   IReportItem reportItem,
   int xPosition,
   int yPosition,
   string imageMapId,
   MouseButton button
)

Parameters

reportItem
The report item clicked.
xPosition
The x position of the click.
yPosition
The y position of the click.
imageMapId
The image map ID.
button
The button that was clicked.

Return Value

The change result of the button click.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


MemoryReportItem Class Properties

[image]
ActiveReports 19 .NET Edition
MemoryReportItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : MemoryReportItem Class

Glossary Item Box

For a list of all members of this type, see MemoryReportItem members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the Action object of this report item.
Public Property | Bookmark | Gets or sets a bookmark that can be linked to via a Bookmark action.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for this MemoryReportItem when rendered via a data oriented rendering extension (e.g. XML).
Public Property | DataElementOutput | Gets or sets the definition how the MemoryReportItem should appear in data output.
Public Property | Height | Gets or sets the height of the item.
Public Property | Hidden | Gets or sets the original visibility of the report item. Gets or sets the Indicator that this report item should be hidden.
Public Property | IsDynamicallyHidden | Gets or sets the Indicator that this report item has dynamic visiblity and is hidden.
Public Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Public Property | Label | Gets or sets a document map label.
Public Property | Left | Gets or sets the distance of the item from the left of the containing object.
Public Property | Name | Gets or sets the name of the MemoryReportItem.
Public Property | RenderComponents | Gets the render component objects.
Public Property | Style | Gets or sets the style of the report item.
Public Property | StyleName | Gets or sets a style name.
Public Property | TargetDevice | Gets output kinds in which report item is present (Screen, Export etc.)
Public Property | ToggleItem | Gets or sets the report item that users can click toggle the visibility of this item.
Public Property | ToolTip | Gets or sets a textual label for the item.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Width | Gets or sets the width of the item.
Public Property | ZIndex | Gets or sets the drawing order of the item within the containing object.
Top

See Also

Reference

MemoryReportItem Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Action Property

Glossary Item Box

Gets or sets the Action object of this report item.

Syntax

Visual Basic (Declaration)
Public Property Action As IAction
C#
public IAction Action {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Bookmark Property

Glossary Item Box

Gets or sets a bookmark that can be linked to via a Bookmark action.

Syntax

Visual Basic (Declaration)
Public Property Bookmark As String
C#
public string Bookmark {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


DataElementName Property

[image]
ActiveReports 19 .NET Edition
DataElementName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : DataElementName Property

Glossary Item Box

Gets or sets the name to use for the data element or attribute for this MemoryReportItem when rendered via a data oriented rendering extension (e.g. XML).

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
C#
public string DataElementName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


DataElementOutput Property

[image]
ActiveReports 19 .NET Edition
DataElementOutput Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : DataElementOutput Property

Glossary Item Box

Gets or sets the definition how the MemoryReportItem should appear in data output.

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutput
C#
public DataElementOutput DataElementOutput {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Height Property

Glossary Item Box

Gets or sets the height of the item.

Syntax

Visual Basic (Declaration)
Public Property Height As Length
C#
public Length Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Hidden Property

Glossary Item Box

Gets or sets the original visibility of the report item. Gets or sets the Indicator that this report item should be hidden.

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


IsDynamicallyHidden Property

[image]
ActiveReports 19 .NET Edition
IsDynamicallyHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : IsDynamicallyHidden Property

Glossary Item Box

Gets or sets the Indicator that this report item has dynamic visiblity and is hidden.

Syntax

Visual Basic (Declaration)
Public Property IsDynamicallyHidden As Boolean
C#
public bool IsDynamicallyHidden {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


KeepTogether Property

[image]
ActiveReports 19 .NET Edition
KeepTogether Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : KeepTogether Property

Glossary Item Box

Gets a value indicating whether the report item is kept together on one page if possible.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeepTogether As Boolean
C#
public bool KeepTogether {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Label Property

Glossary Item Box

Gets or sets a document map label.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Left Property

Glossary Item Box

Gets or sets the distance of the item from the left of the containing object.

Syntax

Visual Basic (Declaration)
Public Property Left As Length
C#
public Length Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Name Property

Glossary Item Box

Gets or sets the name of the MemoryReportItem.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


RenderComponents Property

[image]
ActiveReports 19 .NET Edition
RenderComponents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : RenderComponents Property

Glossary Item Box

Gets the render component objects.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RenderComponents As IEnumerable(Of IRenderComponent)
C#
public virtual IEnumerable<IRenderComponent> RenderComponents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Style Property

Glossary Item Box

Gets or sets the style of the report item.

Syntax

Visual Basic (Declaration)
Public Overridable Property Style As IStyle
C#
public virtual IStyle Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


StyleName Property

[image]
ActiveReports 19 .NET Edition
StyleName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : StyleName Property

Glossary Item Box

Gets or sets a style name.

Syntax

Visual Basic (Declaration)
Public Property StyleName As String
C#
public string StyleName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : TargetDevice Property

Glossary Item Box

Gets output kinds in which report item is present (Screen, Export etc.)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetDevice As TargetDeviceKind
C#
public TargetDeviceKind TargetDevice {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


ToggleItem Property

[image]
ActiveReports 19 .NET Edition
ToggleItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : ToggleItem Property

Glossary Item Box

Gets or sets the report item that users can click toggle the visibility of this item.

Syntax

Visual Basic (Declaration)
Public Property ToggleItem As String
C#
public string ToggleItem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : ToolTip Property

Glossary Item Box

Gets or sets a textual label for the item.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Top Property

Glossary Item Box

Gets or sets the distance of the item from the top of the containing object.

Syntax

Visual Basic (Declaration)
Public Property Top As Length
C#
public Length Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : Width Property

Glossary Item Box

Gets or sets the width of the item.

Syntax

Visual Basic (Declaration)
Public Property Width As Length
C#
public Length Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


ZIndex Property

[image]
ActiveReports 19 .NET Edition
ZIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > MemoryReportItem Class : ZIndex Property

Glossary Item Box

Gets or sets the drawing order of the item within the containing object.

Syntax

Visual Basic (Declaration)
Public Property ZIndex As Integer
C#
public int ZIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryReportItem Class
MemoryReportItem Members


ProgramBase Class

[image]
ActiveReports 19 .NET Edition
ProgramBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ProgramBase Class

Glossary Item Box

Base class to build RDL programs like StyleProgram or ReportItemProgram<T>. Compiles "DNA" of ROM object.

Object Model

ProgramBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ProgramBase
   Implements IProgram
C#
public abstract class ProgramBase : IProgram

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ProgramBase
GrapeCity.ActiveReports.Rendering.Components.ActionProgram
GrapeCity.ActiveReports.Rendering.Components.ReportItemProgram<T>
GrapeCity.ActiveReports.Rendering.Components.StyleProgram

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ProgramBase Class Members

[image]
ActiveReports 19 .NET Edition
ProgramBase Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ProgramBase Class

Glossary Item Box

The following tables list the members exposed by ProgramBase.

Public Properties

 | Name | Description
Public Property | DataContent |
Public Property | IsConst | Returns true if all expressions are constant.
Public Property | IsStatic | Returns true if all expressions are not depending from the data scope. It can be constants or expressions that references Themes or Parameters only.
Public Property | RenderingContext |
Public Property | Report |
Public Property | RequiresRenderingServices | Returns true if any expression contains renderTime-dependent values (themes, page numbers and etc..)
Public Property | Services |
Top

Public Methods

 | Name | Description
Public Method | CompileExpression<T> |
Top

See Also

Reference

ProgramBase Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ProgramBase Class Methods

[image]
ActiveReports 19 .NET Edition
ProgramBase Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ProgramBase Class

Glossary Item Box

For a list of all members of this type, see ProgramBase members.

Public Methods

 | Name | Description
Public Method | CompileExpression<T> |
Top

See Also

Reference

ProgramBase Class
GrapeCity.ActiveReports.Rendering.Components Namespace


CompileExpression<T> Method

T
[image]
ActiveReports 19 .NET Edition
CompileExpression<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : CompileExpression<T> Method

expression
defval
disableCache
convert

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function CompileExpression(Of T)( _
   ByVal expression As ExpressionInfo, _
   ByVal defval As T, _
   Optional ByVal disableCache As Boolean, _
   Optional ByVal convert As Func(Of T,T) _
) As EvalFunc(Of T)
C#
public virtual EvalFunc<T> CompileExpression<T>(
   ExpressionInfo expression,
   T defval,
   bool disableCache,
   Func<T,T> convert
)

Parameters

expression
defval
disableCache
convert

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


ProgramBase Class Properties

[image]
ActiveReports 19 .NET Edition
ProgramBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ProgramBase Class

Glossary Item Box

For a list of all members of this type, see ProgramBase members.

Public Properties

 | Name | Description
Public Property | DataContent |
Public Property | IsConst | Returns true if all expressions are constant.
Public Property | IsStatic | Returns true if all expressions are not depending from the data scope. It can be constants or expressions that references Themes or Parameters only.
Public Property | RenderingContext |
Public Property | Report |
Public Property | RequiresRenderingServices | Returns true if any expression contains renderTime-dependent values (themes, page numbers and etc..)
Public Property | Services |
Top

See Also

Reference

ProgramBase Class
GrapeCity.ActiveReports.Rendering.Components Namespace


DataContent Property

[image]
ActiveReports 19 .NET Edition
DataContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : DataContent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataContent As Def.Content
C#
public Def.Content DataContent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


IsConst Property

[image]
ActiveReports 19 .NET Edition
IsConst Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : IsConst Property

Glossary Item Box

Returns true if all expressions are constant.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsConst As Boolean
C#
public bool IsConst {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : IsStatic Property

Glossary Item Box

Returns true if all expressions are not depending from the data scope. It can be constants or expressions that references Themes or Parameters only.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsStatic As Boolean
C#
public virtual bool IsStatic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


RenderingContext Property

[image]
ActiveReports 19 .NET Edition
RenderingContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : RenderingContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RenderingContext As IReportRenderingContext
C#
public IReportRenderingContext RenderingContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : Report Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As IReport
C#
public IReport Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


RequiresRenderingServices Property

[image]
ActiveReports 19 .NET Edition
RequiresRenderingServices Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : RequiresRenderingServices Property

Glossary Item Box

Returns true if any expression contains renderTime-dependent values (themes, page numbers and etc..)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RequiresRenderingServices As Boolean
C#
public virtual bool RequiresRenderingServices {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


Services Property

[image]
ActiveReports 19 .NET Edition
Services Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ProgramBase Class : Services Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As IProgramServices
C#
public IProgramServices Services {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgramBase Class
ProgramBase Members


RenderComponent Class

[image]
ActiveReports 19 .NET Edition
RenderComponent Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderComponent Class

Glossary Item Box

Defines the base class for all renderable report items.

Object Model

RenderComponent Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class RenderComponent
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent
C#
public abstract class RenderComponent : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.RenderComponent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderComponent Members
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderComponent Class Members

[image]
ActiveReports 19 .NET Edition
RenderComponent Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderComponent Class

Glossary Item Box

The following tables list the members exposed by RenderComponent.

Public Properties

 | Name | Description
Public Property | RenderComponents | Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent.RenderComponents.
Top

Public Methods

 | Name | Description
Public Method | GetService | Implements System.IServiceProvider.GetService(System.Type).
Top

See Also

Reference

RenderComponent Class
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderComponent Class Methods

[image]
ActiveReports 19 .NET Edition
RenderComponent Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderComponent Class

Glossary Item Box

For a list of all members of this type, see RenderComponent members.

Public Methods

 | Name | Description
Public Method | GetService | Implements System.IServiceProvider.GetService(System.Type).
Top

See Also

Reference

RenderComponent Class
GrapeCity.ActiveReports.Rendering.Components Namespace


GetService Method

[image]
ActiveReports 19 .NET Edition
GetService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderComponent Class : GetService Method

serviceType

Glossary Item Box

Implements System.IServiceProvider.GetService(System.Type).

Syntax

Visual Basic (Declaration)
Public Overridable Function GetService( _
   ByVal serviceType As Type _
) As Object
C#
public virtual object GetService(
   Type serviceType
)

Parameters

serviceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderComponent Class
RenderComponent Members


RenderComponent Class Properties

[image]
ActiveReports 19 .NET Edition
RenderComponent Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderComponent Class

Glossary Item Box

For a list of all members of this type, see RenderComponent members.

Public Properties

 | Name | Description
Public Property | RenderComponents | Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent.RenderComponents.
Top

See Also

Reference

RenderComponent Class
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderComponents Property

[image]
ActiveReports 19 .NET Edition
RenderComponents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderComponent Class : RenderComponents Property

Glossary Item Box

Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent.RenderComponents.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RenderComponents As IEnumerable(Of IRenderComponent)
C#
public virtual IEnumerable<IRenderComponent> RenderComponents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderComponent Class
RenderComponent Members


RenderReportItemFactory Class

[image]
ActiveReports 19 .NET Edition
RenderReportItemFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderReportItemFactory Class

Glossary Item Box

Handles creation of rendering report items.

Object Model

RenderReportItemFactory Class

Syntax

Visual Basic (Declaration)
Public Class RenderReportItemFactory
   Implements IRenderReportItemFactory
C#
public class RenderReportItemFactory : IRenderReportItemFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.RenderReportItemFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderReportItemFactory Members
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderReportItemFactory Class Members

[image]
ActiveReports 19 .NET Edition
RenderReportItemFactory Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderReportItemFactory Class

Glossary Item Box

The following tables list the members exposed by RenderReportItemFactory.

Public Constructors

 | Name | Description
Public Constructor | RenderReportItemFactory Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

Public Methods

 | Name | Description
Public Method | Create | Creates report item from the specified definition and data context.
Public Method | CreateCustomReportItem |
Top

See Also

Reference

RenderReportItemFactory Class
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderReportItemFactory Constructor

[image]
ActiveReports 19 .NET Edition
RenderReportItemFactory Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderReportItemFactory Class : RenderReportItemFactory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderReportItemFactory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderReportItemFactory Class
RenderReportItemFactory Members


RenderReportItemFactory Class Methods

[image]
ActiveReports 19 .NET Edition
RenderReportItemFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderReportItemFactory Class

Glossary Item Box

For a list of all members of this type, see RenderReportItemFactory members.

Public Methods

 | Name | Description
Public Method | Create | Creates report item from the specified definition and data context.
Public Method | CreateCustomReportItem |
Top

See Also

Reference

RenderReportItemFactory Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderReportItemFactory Class : Create Method

reportRenderingContext
The GrapeCity.ActiveReports.Rendering.ReportRenderingContext used for this report.
rdlItem
The RDL definition of the report item to construct.
currentDataContext
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope to use as a data source for the created ReportItems.

Glossary Item Box

Creates report item from the specified definition and data context.

Syntax

Visual Basic (Declaration)
Public Overridable Function Create( _
   ByVal reportRenderingContext As IReportRenderingContext, _
   ByVal rdlItem As ReportItem, _
   ByVal currentDataContext As IDataScopeInternal _
) As IReportItem
C#
public virtual IReportItem Create(
   IReportRenderingContext reportRenderingContext,
   ReportItem rdlItem,
   IDataScopeInternal currentDataContext
)

Parameters

reportRenderingContext
The GrapeCity.ActiveReports.Rendering.ReportRenderingContext used for this report.
rdlItem
The RDL definition of the report item to construct.
currentDataContext
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope to use as a data source for the created ReportItems.

Remarks

NOTE: The returned array of items very well may have more items than the input definitions due to composition of simple report items like rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderReportItemFactory Class
RenderReportItemFactory Members


CreateCustomReportItem Method

[image]
ActiveReports 19 .NET Edition
CreateCustomReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderReportItemFactory Class : CreateCustomReportItem Method

context
definition
dataContext
program

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateCustomReportItem( _
   ByVal context As IReportRenderingContext, _
   ByVal definition As CustomReportItem, _
   ByVal dataContext As IDataScopeInternal, _
   ByVal program As IReportItemProgram(Of ReportItem) _
) As IReportItem
C#
public virtual IReportItem CreateCustomReportItem(
   IReportRenderingContext context,
   CustomReportItem definition,
   IDataScopeInternal dataContext,
   IReportItemProgram<ReportItem> program
)

Parameters

context
definition
dataContext
program

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderReportItemFactory Class
RenderReportItemFactory Members


RenderReportItemFactory Class Fields

[image]
ActiveReports 19 .NET Edition
RenderReportItemFactory Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderReportItemFactory Class

Glossary Item Box

For a list of all members of this type, see RenderReportItemFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

See Also

Reference

RenderReportItemFactory Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderReportItemFactory Class : Instance Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As RenderReportItemFactory
C#
public static readonly RenderReportItemFactory Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderReportItemFactory Class
RenderReportItemFactory Members


RenderTools Class

[image]
ActiveReports 19 .NET Edition
RenderTools Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderTools Class

Glossary Item Box

Provides some utility methods useful for the rendering components.

Object Model

RenderTools Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class RenderTools
C#
public static class RenderTools

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.RenderTools

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderTools Members
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderTools Class Members

[image]
ActiveReports 19 .NET Edition
RenderTools Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderTools Class

Glossary Item Box

The following tables list the members exposed by RenderTools.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertRdlDataElementOutput | Converts the RDL GrapeCity.ActiveReports.PageReportModel.DataElementOutput to the rendering namespace GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.
static (Shared in Visual Basic) | GetReportDefinition | Gets report definition from IReport implementation.
Top

See Also

Reference

RenderTools Class
GrapeCity.ActiveReports.Rendering.Components Namespace


RenderTools Class Methods

[image]
ActiveReports 19 .NET Edition
RenderTools Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : RenderTools Class

Glossary Item Box

For a list of all members of this type, see RenderTools members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertRdlDataElementOutput | Converts the RDL GrapeCity.ActiveReports.PageReportModel.DataElementOutput to the rendering namespace GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.
static (Shared in Visual Basic) | GetReportDefinition | Gets report definition from IReport implementation.
Top

See Also

Reference

RenderTools Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ConvertRdlDataElementOutput Method

[image]
ActiveReports 19 .NET Edition
ConvertRdlDataElementOutput Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderTools Class : ConvertRdlDataElementOutput Method

rdlDataElementOutput
reportItemDefinition

Glossary Item Box

Converts the RDL GrapeCity.ActiveReports.PageReportModel.DataElementOutput to the rendering namespace GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertRdlDataElementOutput( _
   ByVal rdlDataElementOutput As DataElementOutput, _
   ByVal reportItemDefinition As ReportItem _
) As DataElementOutput
C#
public static DataElementOutput ConvertRdlDataElementOutput(
   DataElementOutput rdlDataElementOutput,
   ReportItem reportItemDefinition
)

Parameters

rdlDataElementOutput
reportItemDefinition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderTools Class
RenderTools Members


GetReportDefinition Method

[image]
ActiveReports 19 .NET Edition
GetReportDefinition Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > RenderTools Class : GetReportDefinition Method

report

Glossary Item Box

Gets report definition from IReport implementation.

Syntax

Visual Basic (Declaration)
Public Shared Function GetReportDefinition( _
   ByVal report As IReport _
) As Report
C#
public static Report GetReportDefinition(
   IReport report
)

Parameters

report

Return Value

Report definition or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderTools Class
RenderTools Members


ReportItem Class

[image]
ActiveReports 19 .NET Edition
ReportItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItem Class

Glossary Item Box

Non-generic base class for report items.

Object Model

ReportItem Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItem
   Inherits GrapeCity.ActiveReports.Rendering.Components.ReportItem(Of ReportItem,IReportItemProgram(Of ReportItem))
   Implements GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Layout.IContentRange, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemRenderInfo, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticable, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver, GrapeCity.ActiveReports.Rendering.Components.Interfaces.ITocAnchoredItem, GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject
C#
public abstract class ReportItem : GrapeCity.ActiveReports.Rendering.Components.ReportItem<ReportItem,IReportItemProgram<ReportItem>>, GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Layout.IContentRange, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemRenderInfo, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticable, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver, GrapeCity.ActiveReports.Rendering.Components.Interfaces.ITocAnchoredItem, GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext, GrapeCity.Enterprise.Data.Expressions.Evaluation.IDynamicObject

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.RenderComponent
GrapeCity.ActiveReports.Rendering.Components.ReportItem
GrapeCity.ActiveReports.Rendering.Components.DataRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItem Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItem Class Members

[image]
ActiveReports 19 .NET Edition
ReportItem Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItem Class

Glossary Item Box

The following tables list the members exposed by ReportItem.

See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemProgram<T> Class

T
[image]
ActiveReports 19 .NET Edition
ReportItemProgram<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemProgram<T> Class

Glossary Item Box

Represents a report item program.

Object Model

ReportItemProgram<T> Class

Syntax

Visual Basic (Declaration)
Public Class ReportItemProgram(Of T As ReportItem)
   Inherits ProgramBase
   Implements IProgram, IReportItemProgram(Of T)
C#
public class ReportItemProgram<T> : ProgramBase, IProgram, IReportItemProgram<T>
where T: ReportItem

Type Parameters

T

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ProgramBase
GrapeCity.ActiveReports.Rendering.Components.ReportItemProgram<T>
GrapeCity.ActiveReports.Rendering.Components.DataRegionProgram<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemProgram<T> Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemProgram<T> Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemProgram<T> Class

Glossary Item Box

The following tables list the members exposed by ReportItemProgram<T>.

Public Constructors

 | Name | Description
Public Constructor | ReportItemProgram<T> Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Bookmark |
Public Property | Definition |
Public Property | Height |
Public Property | Hidden |
Public Property | IsDelayedHidden |
Public Property | IsDynamicallyHidden |
Public Property | IsHostedInFixedPage |
Public Property | IsStatic |
Public Property | Label |
Public Property | RequiresRenderingServices | Overridden.
Public Property | Style |
Public Property | TargetDevice |
Public Property | ToolTip |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | MakeStyle |
Top

See Also

Reference

ReportItemProgram<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemProgram<T> Constructor

[image]
ActiveReports 19 .NET Edition
ReportItemProgram<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : ReportItemProgram<T> Constructor

services
item
dataContent
style
isRenderTime

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal services As IProgramServices, _
   ByVal item As T, _
   ByVal dataContent As Def.Content, _
   Optional ByVal style As StyleProgram, _
   Optional ByVal isRenderTime As Boolean _
)
C#
public ReportItemProgram<T>(
   IProgramServices services,
   T item,
   Def.Content dataContent,
   StyleProgram style,
   bool isRenderTime
)

Parameters

services
item
dataContent
style
isRenderTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


ReportItemProgram<T> Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemProgram<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemProgram<T> Class

Glossary Item Box

For a list of all members of this type, see ReportItemProgram<T> members.

Public Methods

 | Name | Description
Public Method | MakeStyle |
Top

See Also

Reference

ReportItemProgram<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


MakeStyle Method

[image]
ActiveReports 19 .NET Edition
MakeStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : MakeStyle Method

itemStyle
dataContent
isLine
isRenderTime

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MakeStyle( _
   ByVal itemStyle As Style, _
   ByVal dataContent As Def.Content, _
   Optional ByVal isLine As Boolean, _
   Optional ByVal isRenderTime As Boolean _
) As StyleProgram
C#
public StyleProgram MakeStyle(
   Style itemStyle,
   Def.Content dataContent,
   bool isLine,
   bool isRenderTime
)

Parameters

itemStyle
dataContent
isLine
isRenderTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


ReportItemProgram<T> Class Properties

[image]
ActiveReports 19 .NET Edition
ReportItemProgram<T> Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemProgram<T> Class

Glossary Item Box

For a list of all members of this type, see ReportItemProgram<T> members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Bookmark |
Public Property | Definition |
Public Property | Height |
Public Property | Hidden |
Public Property | IsDelayedHidden |
Public Property | IsDynamicallyHidden |
Public Property | IsHostedInFixedPage |
Public Property | IsStatic |
Public Property | Label |
Public Property | RequiresRenderingServices | Overridden.
Public Property | Style |
Public Property | TargetDevice |
Public Property | ToolTip |
Public Property | Width |
Top

See Also

Reference

ReportItemProgram<T> Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Action Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As ActionProgram
C#
public ActionProgram Action {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Bookmark Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As EvalFunc(Of String)
C#
public EvalFunc<string> Bookmark {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Definition Property

[image]
ActiveReports 19 .NET Edition
Definition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Definition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Definition As T
C#
public T Definition {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Length
C#
public Length Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Hidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hidden As EvalFunc(Of Boolean)
C#
public EvalFunc<bool> Hidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


IsDelayedHidden Property

[image]
ActiveReports 19 .NET Edition
IsDelayedHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : IsDelayedHidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDelayedHidden As Boolean
C#
public bool IsDelayedHidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


IsDynamicallyHidden Property

[image]
ActiveReports 19 .NET Edition
IsDynamicallyHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : IsDynamicallyHidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDynamicallyHidden As Boolean
C#
public bool IsDynamicallyHidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


IsHostedInFixedPage Property

[image]
ActiveReports 19 .NET Edition
IsHostedInFixedPage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : IsHostedInFixedPage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHostedInFixedPage As Boolean
C#
public bool IsHostedInFixedPage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : IsStatic Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Shadows ReadOnly Property IsStatic As Boolean
C#
public virtual new bool IsStatic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Label Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As EvalFunc(Of String)
C#
public EvalFunc<string> Label {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


RequiresRenderingServices Property

[image]
ActiveReports 19 .NET Edition
RequiresRenderingServices Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : RequiresRenderingServices Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property RequiresRenderingServices As Boolean
C#
public override bool RequiresRenderingServices {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As StyleProgram
C#
public StyleProgram Style {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : TargetDevice Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetDevice As TargetDeviceKind
C#
public TargetDeviceKind TargetDevice {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToolTip As EvalFunc(Of String)
C#
public EvalFunc<string> ToolTip {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemProgram<T> Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Length
C#
public Length Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemProgram<T> Class
ReportItemProgram<T> Members


StyleProgram Class

[image]
ActiveReports 19 .NET Edition
StyleProgram Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : StyleProgram Class

Glossary Item Box

Builds program to implement GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Object Model

StyleProgram Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StyleProgram
   Inherits ProgramBase
   Implements IProgram
C#
public sealed class StyleProgram : ProgramBase, IProgram

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ProgramBase
GrapeCity.ActiveReports.Rendering.Components.StyleProgram

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Members
GrapeCity.ActiveReports.Rendering.Components Namespace


StyleProgram Class Members

[image]
ActiveReports 19 .NET Edition
StyleProgram Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : StyleProgram Class

Glossary Item Box

The following tables list the members exposed by StyleProgram.

Public Constructors

 | Name | Description
Public Constructor | StyleProgram Constructor |
Top

Public Fields

 | Name | Description
Public Field | Angle |
Public Field | BackgroundColor |
Public Field | BackgroundGradientEndColor |
Public Field | BackgroundGradientType |
Public Field | BackgroundImageMimeType |
Public Field | BackgroundImageValue |
Public Field | BackgroundRepeat |
Public Field | BottomBorderColor |
Public Field | BottomBorderStyle |
Public Field | BottomBorderWidth |
Public Field | Calendar |
Public Field | CharacterSpacing |
Public Field | Color |
Public Field | DefaultBorderColor |
Public Field | DefaultBorderStyle |
Public Field | DefaultBorderWidth |
Public Field | Direction |
Public Field | FontFamily |
Public Field | FontSize |
Public Field | FontStyle |
Public Field | FontWeight |
Public Field | Format |
Public Field | HasConstantDigitSubstitution |
Public Field | HasConstantDirections |
Public Field | HasConstFontInfo |
Public Field | HeadingLevel |
Public Field | Language |
Public Field | LeadingChar |
Public Field | LeftBorderColor |
Public Field | LeftBorderStyle |
Public Field | LeftBorderWidth |
Public Field | LineHeight |
Public Field | LineSpacing |
Public Field | MaxLevel |
Public Field | MinCondenseRate |
Public Field | NeedsFormatting |
Public Field | NumeralLanguage |
Public Field | NumeralVariant |
Public Field | PaddingBottom |
Public Field | PaddingLeft |
Public Field | PaddingRight |
Public Field | PaddingTop |
Public Field | RightBorderColor |
Public Field | RightBorderStyle |
Public Field | RightBorderWidth |
Public Field | ShadowOffset |
Public Field | ShrinkToFit |
Public Field | Style |
Public Field | TextAlign |
Public Field | TextDecoration |
Public Field | TextIndent |
Public Field | TextJustify |
Public Field | TopBorderColor |
Public Field | TopBorderStyle |
Public Field | TopBorderWidth |
Public Field | UprightInVerticalText |
Public Field | VerticalAlign |
Public Field | WrapMode |
Public Field | WritingMode |
Top

Public Properties

 | Name | Description
Public Property | HasDelayedProperties | Returns true if there is at least one expression with 'PageNumber', 'PageTotal' and so on.
Public Property | HasThemeRefs |
Public Property | StaticInstance | Slot to cache GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle instance if Style definition is completly const (this case has high probability).
Top

Public Methods

 | Name | Description
Public Method | BottomBorderStyleValue |
Public Method | CompileExpression<T> | Overridden.
Public Method | DefaultBorderStyleValue |
Public Method | GetCulture |
Public Method | GetCultureForNumbers |
Public Method | GetFontDescriptor |
Public Method | GetNegativeStringFormat |
Public Method | GetPositiveStringFormat |
Public Method | HorizontalAlignment |
Public Method | IsRTL |
Public Method | IsVertical |
Public Method | LeftBorderStyleValue |
Public Method | LineAlignment |
Public Method | RightBorderStyleValue |
Public Method | TopBorderStyleValue |
Top

See Also

Reference

StyleProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


StyleProgram Constructor

[image]
ActiveReports 19 .NET Edition
StyleProgram Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : StyleProgram Constructor

services
style
dataContent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal services As IProgramServices, _
   ByVal style As Style, _
   ByVal dataContent As Def.Content _
)
C#
public StyleProgram(
   IProgramServices services,
   Style style,
   Def.Content dataContent
)

Parameters

services
style
dataContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


StyleProgram Class Methods

[image]
ActiveReports 19 .NET Edition
StyleProgram Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : StyleProgram Class

Glossary Item Box

For a list of all members of this type, see StyleProgram members.

Public Methods

 | Name | Description
Public Method | BottomBorderStyleValue |
Public Method | CompileExpression<T> | Overridden.
Public Method | DefaultBorderStyleValue |
Public Method | GetCulture |
Public Method | GetCultureForNumbers |
Public Method | GetFontDescriptor |
Public Method | GetNegativeStringFormat |
Public Method | GetPositiveStringFormat |
Public Method | HorizontalAlignment |
Public Method | IsRTL |
Public Method | IsVertical |
Public Method | LeftBorderStyleValue |
Public Method | LineAlignment |
Public Method | RightBorderStyleValue |
Public Method | TopBorderStyleValue |
Top

See Also

Reference

StyleProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


BottomBorderStyleValue Method

[image]
ActiveReports 19 .NET Edition
BottomBorderStyleValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BottomBorderStyleValue Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function BottomBorderStyleValue( _
   ByVal scope As IDataScopeInternal _
) As Nullable(Of BorderDrawingStyle)
C#
public Nullable<BorderDrawingStyle> BottomBorderStyleValue(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


CompileExpression<T> Method

T
[image]
ActiveReports 19 .NET Edition
CompileExpression<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : CompileExpression<T> Method

expression
defval
disableCache
convert

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function CompileExpression(Of T)( _
   ByVal expression As ExpressionInfo, _
   ByVal defval As T, _
   Optional ByVal disableCache As Boolean, _
   Optional ByVal convert As Func(Of T,T) _
) As EvalFunc(Of T)
C#
public override EvalFunc<T> CompileExpression<T>(
   ExpressionInfo expression,
   T defval,
   bool disableCache,
   Func<T,T> convert
)

Parameters

expression
defval
disableCache
convert

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


DefaultBorderStyleValue Method

[image]
ActiveReports 19 .NET Edition
DefaultBorderStyleValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : DefaultBorderStyleValue Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function DefaultBorderStyleValue( _
   ByVal scope As IDataScopeInternal _
) As BorderDrawingStyle
C#
public BorderDrawingStyle DefaultBorderStyleValue(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


GetCulture Method

[image]
ActiveReports 19 .NET Edition
GetCulture Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : GetCulture Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCulture( _
   ByVal scope As IDataScopeInternal _
) As CultureInfo
C#
public CultureInfo GetCulture(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


GetCultureForNumbers Method

[image]
ActiveReports 19 .NET Edition
GetCultureForNumbers Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : GetCultureForNumbers Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCultureForNumbers( _
   ByVal scope As IDataScopeInternal _
) As CultureInfo
C#
public CultureInfo GetCultureForNumbers(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


GetFontDescriptor Method

[image]
ActiveReports 19 .NET Edition
GetFontDescriptor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : GetFontDescriptor Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFontDescriptor( _
   ByVal scope As IDataScopeInternal _
) As FontInfo
C#
public FontInfo GetFontDescriptor(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


GetNegativeStringFormat Method

[image]
ActiveReports 19 .NET Edition
GetNegativeStringFormat Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : GetNegativeStringFormat Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNegativeStringFormat( _
   ByVal scope As IDataScopeInternal _
) As StringFormatEx
C#
public StringFormatEx GetNegativeStringFormat(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


GetPositiveStringFormat Method

[image]
ActiveReports 19 .NET Edition
GetPositiveStringFormat Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : GetPositiveStringFormat Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPositiveStringFormat( _
   ByVal scope As IDataScopeInternal _
) As StringFormatEx
C#
public StringFormatEx GetPositiveStringFormat(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HorizontalAlignment Method

[image]
ActiveReports 19 .NET Edition
HorizontalAlignment Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HorizontalAlignment Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HorizontalAlignment( _
   ByVal scope As IDataScopeInternal _
) As StringAlignmentEx
C#
public StringAlignmentEx HorizontalAlignment(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


IsRTL Method

[image]
ActiveReports 19 .NET Edition
IsRTL Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : IsRTL Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsRTL( _
   ByVal scope As IDataScopeInternal _
) As Boolean
C#
public bool IsRTL(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


IsVertical Method

[image]
ActiveReports 19 .NET Edition
IsVertical Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : IsVertical Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsVertical( _
   ByVal scope As IDataScopeInternal _
) As Boolean
C#
public bool IsVertical(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LeftBorderStyleValue Method

[image]
ActiveReports 19 .NET Edition
LeftBorderStyleValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LeftBorderStyleValue Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LeftBorderStyleValue( _
   ByVal scope As IDataScopeInternal _
) As Nullable(Of BorderDrawingStyle)
C#
public Nullable<BorderDrawingStyle> LeftBorderStyleValue(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LineAlignment Method

[image]
ActiveReports 19 .NET Edition
LineAlignment Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LineAlignment Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LineAlignment( _
   ByVal scope As IDataScopeInternal _
) As StringLineAlignmentEx
C#
public StringLineAlignmentEx LineAlignment(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


RightBorderStyleValue Method

[image]
ActiveReports 19 .NET Edition
RightBorderStyleValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : RightBorderStyleValue Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RightBorderStyleValue( _
   ByVal scope As IDataScopeInternal _
) As Nullable(Of BorderDrawingStyle)
C#
public Nullable<BorderDrawingStyle> RightBorderStyleValue(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TopBorderStyleValue Method

[image]
ActiveReports 19 .NET Edition
TopBorderStyleValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TopBorderStyleValue Method

scope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function TopBorderStyleValue( _
   ByVal scope As IDataScopeInternal _
) As Nullable(Of BorderDrawingStyle)
C#
public Nullable<BorderDrawingStyle> TopBorderStyleValue(
   IDataScopeInternal scope
)

Parameters

scope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


StyleProgram Class Properties

[image]
ActiveReports 19 .NET Edition
StyleProgram Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : StyleProgram Class

Glossary Item Box

For a list of all members of this type, see StyleProgram members.

Public Properties

 | Name | Description
Public Property | HasDelayedProperties | Returns true if there is at least one expression with 'PageNumber', 'PageTotal' and so on.
Public Property | HasThemeRefs |
Public Property | StaticInstance | Slot to cache GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle instance if Style definition is completly const (this case has high probability).
Top

See Also

Reference

StyleProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


HasDelayedProperties Property

[image]
ActiveReports 19 .NET Edition
HasDelayedProperties Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HasDelayedProperties Property

Glossary Item Box

Returns true if there is at least one expression with 'PageNumber', 'PageTotal' and so on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasDelayedProperties As Boolean
C#
public bool HasDelayedProperties {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HasThemeRefs Property

[image]
ActiveReports 19 .NET Edition
HasThemeRefs Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HasThemeRefs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasThemeRefs As Boolean
C#
public bool HasThemeRefs {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


StaticInstance Property

[image]
ActiveReports 19 .NET Edition
StaticInstance Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : StaticInstance Property

Glossary Item Box

Slot to cache GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle instance if Style definition is completly const (this case has high probability).

Syntax

Visual Basic (Declaration)
Public Property StaticInstance As IStyle
C#
public IStyle StaticInstance {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


StyleProgram Class Fields

[image]
ActiveReports 19 .NET Edition
StyleProgram Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : StyleProgram Class

Glossary Item Box

For a list of all members of this type, see StyleProgram members.

Public Fields

 | Name | Description
Public Field | Angle |
Public Field | BackgroundColor |
Public Field | BackgroundGradientEndColor |
Public Field | BackgroundGradientType |
Public Field | BackgroundImageMimeType |
Public Field | BackgroundImageValue |
Public Field | BackgroundRepeat |
Public Field | BottomBorderColor |
Public Field | BottomBorderStyle |
Public Field | BottomBorderWidth |
Public Field | Calendar |
Public Field | CharacterSpacing |
Public Field | Color |
Public Field | DefaultBorderColor |
Public Field | DefaultBorderStyle |
Public Field | DefaultBorderWidth |
Public Field | Direction |
Public Field | FontFamily |
Public Field | FontSize |
Public Field | FontStyle |
Public Field | FontWeight |
Public Field | Format |
Public Field | HasConstantDigitSubstitution |
Public Field | HasConstantDirections |
Public Field | HasConstFontInfo |
Public Field | HeadingLevel |
Public Field | Language |
Public Field | LeadingChar |
Public Field | LeftBorderColor |
Public Field | LeftBorderStyle |
Public Field | LeftBorderWidth |
Public Field | LineHeight |
Public Field | LineSpacing |
Public Field | MaxLevel |
Public Field | MinCondenseRate |
Public Field | NeedsFormatting |
Public Field | NumeralLanguage |
Public Field | NumeralVariant |
Public Field | PaddingBottom |
Public Field | PaddingLeft |
Public Field | PaddingRight |
Public Field | PaddingTop |
Public Field | RightBorderColor |
Public Field | RightBorderStyle |
Public Field | RightBorderWidth |
Public Field | ShadowOffset |
Public Field | ShrinkToFit |
Public Field | Style |
Public Field | TextAlign |
Public Field | TextDecoration |
Public Field | TextIndent |
Public Field | TextJustify |
Public Field | TopBorderColor |
Public Field | TopBorderStyle |
Public Field | TopBorderWidth |
Public Field | UprightInVerticalText |
Public Field | VerticalAlign |
Public Field | WrapMode |
Public Field | WritingMode |
Top

See Also

Reference

StyleProgram Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Angle Field

[image]
ActiveReports 19 .NET Edition
Angle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Angle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Angle As EvalFunc(Of Single)
C#
public readonly EvalFunc<float> Angle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BackgroundColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundGradientEndColor Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundGradientEndColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundGradientEndColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BackgroundGradientEndColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundGradientType Field

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundGradientType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundGradientType As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BackgroundGradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundImageMimeType Field

[image]
ActiveReports 19 .NET Edition
BackgroundImageMimeType Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundImageMimeType Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundImageMimeType As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BackgroundImageMimeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundImageValue Field

[image]
ActiveReports 19 .NET Edition
BackgroundImageValue Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundImageValue Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundImageValue As EvalFunc(Of Object)
C#
public readonly EvalFunc<object> BackgroundImageValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BackgroundRepeat Field

[image]
ActiveReports 19 .NET Edition
BackgroundRepeat Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BackgroundRepeat Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BackgroundRepeat As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BackgroundRepeat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BottomBorderColor Field

[image]
ActiveReports 19 .NET Edition
BottomBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BottomBorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BottomBorderColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BottomBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BottomBorderStyle Field

[image]
ActiveReports 19 .NET Edition
BottomBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BottomBorderStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BottomBorderStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> BottomBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


BottomBorderWidth Field

[image]
ActiveReports 19 .NET Edition
BottomBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : BottomBorderWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly BottomBorderWidth As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> BottomBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Calendar Field

[image]
ActiveReports 19 .NET Edition
Calendar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Calendar Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Calendar As EvalFunc(Of String)
C#
public readonly EvalFunc<string> Calendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


CharacterSpacing Field

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : CharacterSpacing Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly CharacterSpacing As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> CharacterSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Color Field

[image]
ActiveReports 19 .NET Edition
Color Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Color Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Color As EvalFunc(Of String)
C#
public readonly EvalFunc<string> Color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


DefaultBorderColor Field

[image]
ActiveReports 19 .NET Edition
DefaultBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : DefaultBorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly DefaultBorderColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> DefaultBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


DefaultBorderStyle Field

[image]
ActiveReports 19 .NET Edition
DefaultBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : DefaultBorderStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly DefaultBorderStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> DefaultBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


DefaultBorderWidth Field

[image]
ActiveReports 19 .NET Edition
DefaultBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : DefaultBorderWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly DefaultBorderWidth As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> DefaultBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Direction Field

[image]
ActiveReports 19 .NET Edition
Direction Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Direction Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Direction As EvalFunc(Of String)
C#
public readonly EvalFunc<string> Direction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


FontFamily Field

[image]
ActiveReports 19 .NET Edition
FontFamily Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : FontFamily Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly FontFamily As EvalFunc(Of String)
C#
public readonly EvalFunc<string> FontFamily

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


FontSize Field

[image]
ActiveReports 19 .NET Edition
FontSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : FontSize Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly FontSize As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> FontSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


FontStyle Field

[image]
ActiveReports 19 .NET Edition
FontStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : FontStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly FontStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> FontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


FontWeight Field

[image]
ActiveReports 19 .NET Edition
FontWeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : FontWeight Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly FontWeight As EvalFunc(Of String)
C#
public readonly EvalFunc<string> FontWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Format Field

[image]
ActiveReports 19 .NET Edition
Format Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Format Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Format As EvalFunc(Of String)
C#
public readonly EvalFunc<string> Format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HasConstantDigitSubstitution Field

[image]
ActiveReports 19 .NET Edition
HasConstantDigitSubstitution Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HasConstantDigitSubstitution Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HasConstantDigitSubstitution As Boolean
C#
public readonly bool HasConstantDigitSubstitution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HasConstantDirections Field

[image]
ActiveReports 19 .NET Edition
HasConstantDirections Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HasConstantDirections Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HasConstantDirections As Boolean
C#
public readonly bool HasConstantDirections

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HasConstFontInfo Field

[image]
ActiveReports 19 .NET Edition
HasConstFontInfo Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HasConstFontInfo Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HasConstFontInfo As Boolean
C#
public readonly bool HasConstFontInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


HeadingLevel Field

[image]
ActiveReports 19 .NET Edition
HeadingLevel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : HeadingLevel Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly HeadingLevel As EvalFunc(Of Integer)
C#
public readonly EvalFunc<int> HeadingLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Language Field

[image]
ActiveReports 19 .NET Edition
Language Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Language Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Language As EvalFunc(Of String)
C#
public readonly EvalFunc<string> Language

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LeadingChar Field

[image]
ActiveReports 19 .NET Edition
LeadingChar Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LeadingChar Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LeadingChar As EvalFunc(Of String)
C#
public readonly EvalFunc<string> LeadingChar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LeftBorderColor Field

[image]
ActiveReports 19 .NET Edition
LeftBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LeftBorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LeftBorderColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> LeftBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LeftBorderStyle Field

[image]
ActiveReports 19 .NET Edition
LeftBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LeftBorderStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LeftBorderStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> LeftBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LeftBorderWidth Field

[image]
ActiveReports 19 .NET Edition
LeftBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LeftBorderWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LeftBorderWidth As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> LeftBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LineHeight Field

[image]
ActiveReports 19 .NET Edition
LineHeight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LineHeight Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LineHeight As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> LineHeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


LineSpacing Field

[image]
ActiveReports 19 .NET Edition
LineSpacing Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : LineSpacing Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly LineSpacing As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> LineSpacing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


MaxLevel Field

[image]
ActiveReports 19 .NET Edition
MaxLevel Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : MaxLevel Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly MaxLevel As EvalFunc(Of Integer)
C#
public readonly EvalFunc<int> MaxLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


MinCondenseRate Field

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : MinCondenseRate Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly MinCondenseRate As EvalFunc(Of Integer)
C#
public readonly EvalFunc<int> MinCondenseRate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


NeedsFormatting Field

[image]
ActiveReports 19 .NET Edition
NeedsFormatting Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : NeedsFormatting Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly NeedsFormatting As Boolean
C#
public readonly bool NeedsFormatting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


NumeralLanguage Field

[image]
ActiveReports 19 .NET Edition
NumeralLanguage Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : NumeralLanguage Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly NumeralLanguage As EvalFunc(Of String)
C#
public readonly EvalFunc<string> NumeralLanguage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


NumeralVariant Field

[image]
ActiveReports 19 .NET Edition
NumeralVariant Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : NumeralVariant Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly NumeralVariant As EvalFunc(Of Integer)
C#
public readonly EvalFunc<int> NumeralVariant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


PaddingBottom Field

[image]
ActiveReports 19 .NET Edition
PaddingBottom Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : PaddingBottom Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly PaddingBottom As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> PaddingBottom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


PaddingLeft Field

[image]
ActiveReports 19 .NET Edition
PaddingLeft Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : PaddingLeft Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly PaddingLeft As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> PaddingLeft

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


PaddingRight Field

[image]
ActiveReports 19 .NET Edition
PaddingRight Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : PaddingRight Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly PaddingRight As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> PaddingRight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


PaddingTop Field

[image]
ActiveReports 19 .NET Edition
PaddingTop Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : PaddingTop Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly PaddingTop As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> PaddingTop

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


RightBorderColor Field

[image]
ActiveReports 19 .NET Edition
RightBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : RightBorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RightBorderColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> RightBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


RightBorderStyle Field

[image]
ActiveReports 19 .NET Edition
RightBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : RightBorderStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RightBorderStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> RightBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


RightBorderWidth Field

[image]
ActiveReports 19 .NET Edition
RightBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : RightBorderWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly RightBorderWidth As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> RightBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


ShadowOffset Field

[image]
ActiveReports 19 .NET Edition
ShadowOffset Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : ShadowOffset Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ShadowOffset As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> ShadowOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


ShrinkToFit Field

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : ShrinkToFit Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ShrinkToFit As EvalFunc(Of Boolean)
C#
public readonly EvalFunc<bool> ShrinkToFit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Style Field

[image]
ActiveReports 19 .NET Edition
Style Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : Style Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Style As Style
C#
public readonly Style Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TextAlign Field

[image]
ActiveReports 19 .NET Edition
TextAlign Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TextAlign Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TextAlign As EvalFunc(Of String)
C#
public readonly EvalFunc<string> TextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TextDecoration Field

[image]
ActiveReports 19 .NET Edition
TextDecoration Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TextDecoration Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TextDecoration As EvalFunc(Of String)
C#
public readonly EvalFunc<string> TextDecoration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TextIndent Field

[image]
ActiveReports 19 .NET Edition
TextIndent Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TextIndent Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TextIndent As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> TextIndent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TextJustify Field

[image]
ActiveReports 19 .NET Edition
TextJustify Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TextJustify Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TextJustify As EvalFunc(Of String)
C#
public readonly EvalFunc<string> TextJustify

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TopBorderColor Field

[image]
ActiveReports 19 .NET Edition
TopBorderColor Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TopBorderColor Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TopBorderColor As EvalFunc(Of String)
C#
public readonly EvalFunc<string> TopBorderColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TopBorderStyle Field

[image]
ActiveReports 19 .NET Edition
TopBorderStyle Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TopBorderStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TopBorderStyle As EvalFunc(Of String)
C#
public readonly EvalFunc<string> TopBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


TopBorderWidth Field

[image]
ActiveReports 19 .NET Edition
TopBorderWidth Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : TopBorderWidth Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly TopBorderWidth As EvalFunc(Of Length)
C#
public readonly EvalFunc<Length> TopBorderWidth

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


UprightInVerticalText Field

[image]
ActiveReports 19 .NET Edition
UprightInVerticalText Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : UprightInVerticalText Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly UprightInVerticalText As EvalFunc(Of String)
C#
public readonly EvalFunc<string> UprightInVerticalText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


VerticalAlign Field

[image]
ActiveReports 19 .NET Edition
VerticalAlign Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : VerticalAlign Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly VerticalAlign As EvalFunc(Of String)
C#
public readonly EvalFunc<string> VerticalAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


WrapMode Field

[image]
ActiveReports 19 .NET Edition
WrapMode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : WrapMode Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly WrapMode As EvalFunc(Of String)
C#
public readonly EvalFunc<string> WrapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


WritingMode Field

[image]
ActiveReports 19 .NET Edition
WritingMode Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > StyleProgram Class : WritingMode Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly WritingMode As EvalFunc(Of String)
C#
public readonly EvalFunc<string> WritingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleProgram Class
StyleProgram Members


Tooltip Class

[image]
ActiveReports 19 .NET Edition
Tooltip Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : Tooltip Class

Glossary Item Box

Defines tooltip shown for the interactive area.

Object Model

Tooltip Class

Syntax

Visual Basic (Declaration)
Public Class Tooltip
C#
public class Tooltip

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Tooltip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tooltip Members
GrapeCity.ActiveReports.Rendering.Components Namespace


Tooltip Class Members

[image]
ActiveReports 19 .NET Edition
Tooltip Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : Tooltip Class

Glossary Item Box

The following tables list the members exposed by Tooltip.

Public Constructors

 | Name | Description
Public Constructor | Tooltip Constructor | Initializes a new instance of the Tooltip class.
Top

Public Fields

 | Name | Description
Public Field | Id | Id of the tooltip.
Public Field | Label | Label of the tooltip.
Public Field | Value | Text of the tooltip.
Top

See Also

Reference

Tooltip Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Tooltip Constructor

[image]
ActiveReports 19 .NET Edition
Tooltip Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > Tooltip Class : Tooltip Constructor

id
Id of the tooltip.
label
Label of the tooltip.
value
Text of the tooltip.

Glossary Item Box

Initializes a new instance of the Tooltip class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String, _
   ByVal label As String, _
   ByVal value As String _
)
C#
public Tooltip(
   string id,
   string label,
   string value
)

Parameters

id
Id of the tooltip.
label
Label of the tooltip.
value
Text of the tooltip.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tooltip Class
Tooltip Members


Tooltip Class Fields

[image]
ActiveReports 19 .NET Edition
Tooltip Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : Tooltip Class

Glossary Item Box

For a list of all members of this type, see Tooltip members.

Public Fields

 | Name | Description
Public Field | Id | Id of the tooltip.
Public Field | Label | Label of the tooltip.
Public Field | Value | Text of the tooltip.
Top

See Also

Reference

Tooltip Class
GrapeCity.ActiveReports.Rendering.Components Namespace


Id Field

[image]
ActiveReports 19 .NET Edition
Id Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > Tooltip Class : Id Field

Glossary Item Box

Id of the tooltip.

Syntax

Visual Basic (Declaration)
Public ReadOnly Id As String
C#
public readonly string Id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tooltip Class
Tooltip Members


Label Field

[image]
ActiveReports 19 .NET Edition
Label Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > Tooltip Class : Label Field

Glossary Item Box

Label of the tooltip.

Syntax

Visual Basic (Declaration)
Public ReadOnly Label As String
C#
public readonly string Label

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tooltip Class
Tooltip Members


Value Field

[image]
ActiveReports 19 .NET Edition
Value Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > Tooltip Class : Value Field

Glossary Item Box

Text of the tooltip.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As String
C#
public readonly string Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tooltip Class
Tooltip Members


CheckStyle Enumeration

[image]
ActiveReports 19 .NET Edition
CheckStyle Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : CheckStyle Enumeration

Glossary Item Box

Specifies the style of a checkbox.

Syntax

Visual Basic (Declaration)
Public Enum CheckStyle
   Inherits System.Enum
C#
public enum CheckStyle : System.Enum

Members

Member | Description
Check | The checkbox style is a check.
Circle | The checkbox style is a circle.
Cross | The checkbox style is a cross.
Diamond | The checkbox style is a diamond.
Square | The checkbox style is a square.
Star | The checkbox style is a star.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.CheckStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components Namespace


InputType Enumeration

[image]
ActiveReports 19 .NET Edition
InputType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InputType Enumeration

Glossary Item Box

Specifies the type of input field.

Syntax

Visual Basic (Declaration)
Public Enum InputType
   Inherits System.Enum
C#
public enum InputType : System.Enum

Members

Member | Description
CheckBox | The input field is a checkbox.
Text | The input field is a text field.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.InputType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components Namespace


InteractiveEventTypes Enumeration

[image]
ActiveReports 19 .NET Edition
InteractiveEventTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : InteractiveEventTypes Enumeration

Glossary Item Box

Specifies the types of interactive events.

Syntax

Visual Basic (Declaration)
Public Enum InteractiveEventTypes
   Inherits System.Enum
C#
public enum InteractiveEventTypes : System.Enum

Members

Member | Description
Action |
None |
Sorting |
Toggle |

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.InteractiveEventTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemKey Structure

[image]
ActiveReports 19 .NET Edition
ReportItemKey Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemKey Structure

Glossary Item Box

Represents report item key.

Object Model

ReportItemKey Structure

Syntax

Visual Basic (Declaration)
Public Structure ReportItemKey
   Inherits System.ValueType
C#
public struct ReportItemKey : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Components.ReportItemKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Members
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemKey Structure Members

[image]
ActiveReports 19 .NET Edition
ReportItemKey Structure Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemKey Structure

Glossary Item Box

The following tables list the members exposed by ReportItemKey.

Public Constructors

 | Name | Description
Public Constructor | ReportItemKey Constructor |
Top

Public Fields

 | Name | Description
Public Field | Name |
static (Shared in Visual Basic) | Null |
Public Field | ReportName |
Public Field | ScopeId |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Public Method | ToString |
Top

Public Operators

public Operator Explicit Type Conversion
Top

See Also

Reference

ReportItemKey Structure
GrapeCity.ActiveReports.Rendering.Components Namespace


ReportItemKey Constructor

[image]
ActiveReports 19 .NET Edition
ReportItemKey Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : ReportItemKey Constructor

scopeId
name
reportName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scopeId As Integer, _
   ByVal name As String, _
   ByVal reportName As String _
)
C#
public ReportItemKey(
   int scopeId,
   string name,
   string reportName
)

Parameters

scopeId
name
reportName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


ReportItemKey Structure Methods

[image]
ActiveReports 19 .NET Edition
ReportItemKey Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemKey Structure

Glossary Item Box

For a list of all members of this type, see ReportItemKey members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

ReportItemKey Structure
GrapeCity.ActiveReports.Rendering.Components Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : Equals Method

Glossary Item Box

Overload List

Overload | Description
Equals(ReportItemKey) |
Equals(Object) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


Equals(ReportItemKey) Method

[image]
ActiveReports 19 .NET Edition
Equals(ReportItemKey) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure > Equals Method : Equals(ReportItemKey) Method

other

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As ReportItemKey _
) As Boolean
C#
public bool Equals(
   ReportItemKey other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members
Overload List


Equals(Object) Method

[image]
ActiveReports 19 .NET Edition
Equals(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure > Equals Method : Equals(Object) Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


ReportItemKey Structure Fields

[image]
ActiveReports 19 .NET Edition
ReportItemKey Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : ReportItemKey Structure

Glossary Item Box

For a list of all members of this type, see ReportItemKey members.

Public Fields

 | Name | Description
Public Field | Name |
static (Shared in Visual Basic) | Null |
Public Field | ReportName |
Public Field | ScopeId |
Top

See Also

Reference

ReportItemKey Structure
GrapeCity.ActiveReports.Rendering.Components Namespace


Name Field

[image]
ActiveReports 19 .NET Edition
Name Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : Name Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


Null Field

[image]
ActiveReports 19 .NET Edition
Null Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : Null Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As ReportItemKey
C#
public static readonly ReportItemKey Null

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


ReportName Field

[image]
ActiveReports 19 .NET Edition
ReportName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : ReportName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ReportName As String
C#
public readonly string ReportName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


ScopeId Field

[image]
ActiveReports 19 .NET Edition
ScopeId Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : ScopeId Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly ScopeId As Integer
C#
public readonly int ScopeId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


Explicit Type Conversion Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > ReportItemKey Structure : Explicit Type Conversion Operator

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal s As String _
) As ReportItemKey
C#
public ReportItemKey operator explicit(
   string s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemKey Structure
ReportItemKey Members


IInputCheckBoxField Interface

[image]
ActiveReports 19 .NET Edition
IInputCheckBoxField Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputCheckBoxField Interface

Glossary Item Box

Represents a checkbox input field in a report.

Syntax

Visual Basic (Declaration)
Public Interface IInputCheckBoxField
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField
C#
public interface IInputCheckBoxField : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputCheckBoxField Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputCheckBoxField Interface Members

[image]
ActiveReports 19 .NET Edition
IInputCheckBoxField Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputCheckBoxField Interface

Glossary Item Box

The following tables list the members exposed by IInputCheckBoxField.

Public Properties

 | Name | Description
Property | Checked | Gets a value indicating whether the checkbox is checked.
Property | CheckStyle | Gets the style of the checkbox.
Top

See Also

Reference

IInputCheckBoxField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputCheckBoxField Interface Properties

[image]
ActiveReports 19 .NET Edition
IInputCheckBoxField Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputCheckBoxField Interface

Glossary Item Box

For a list of all members of this type, see IInputCheckBoxField members.

Public Properties

 | Name | Description
Property | Checked | Gets a value indicating whether the checkbox is checked.
Property | CheckStyle | Gets the style of the checkbox.
Top

See Also

Reference

IInputCheckBoxField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


Checked Property

[image]
ActiveReports 19 .NET Edition
Checked Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputCheckBoxField Interface : Checked Property

Glossary Item Box

Gets a value indicating whether the checkbox is checked.

Syntax

Visual Basic (Declaration)
ReadOnly Property Checked As Boolean
C#
bool Checked {get;}

Property Value

A System.Boolean value. true if the checkbox is checked; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputCheckBoxField Interface
IInputCheckBoxField Members


CheckStyle Property

[image]
ActiveReports 19 .NET Edition
CheckStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputCheckBoxField Interface : CheckStyle Property

Glossary Item Box

Gets the style of the checkbox.

Syntax

Visual Basic (Declaration)
ReadOnly Property CheckStyle As CheckStyle
C#
CheckStyle CheckStyle {get;}

Property Value

The style of the checkbox as a CheckStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputCheckBoxField Interface
IInputCheckBoxField Members


IInputField Interface

[image]
ActiveReports 19 .NET Edition
IInputField Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputField Interface

Glossary Item Box

Represents a generic input field in a report.

Syntax

Visual Basic (Declaration)
Public Interface IInputField
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem
C#
public interface IInputField : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputField Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputField Interface Members

[image]
ActiveReports 19 .NET Edition
IInputField Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputField Interface

Glossary Item Box

The following tables list the members exposed by IInputField.

Public Properties

 | Name | Description
Property | FieldName | Gets the name of the field.
Property | ReadOnly | Gets a value indicating whether the input field is read-only.
Property | Required | Gets a value indicating whether the input field is required.
Property | Type | Gets the type of the input field.
Top

See Also

Reference

IInputField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputField Interface Properties

[image]
ActiveReports 19 .NET Edition
IInputField Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputField Interface

Glossary Item Box

For a list of all members of this type, see IInputField members.

Public Properties

 | Name | Description
Property | FieldName | Gets the name of the field.
Property | ReadOnly | Gets a value indicating whether the input field is read-only.
Property | Required | Gets a value indicating whether the input field is required.
Property | Type | Gets the type of the input field.
Top

See Also

Reference

IInputField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


FieldName Property

[image]
ActiveReports 19 .NET Edition
FieldName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputField Interface : FieldName Property

Glossary Item Box

Gets the name of the field.

Syntax

Visual Basic (Declaration)
ReadOnly Property FieldName As String
C#
string FieldName {get;}

Property Value

The name of the field as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputField Interface
IInputField Members


ReadOnly Property

[image]
ActiveReports 19 .NET Edition
ReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputField Interface : ReadOnly Property

Glossary Item Box

Gets a value indicating whether the input field is read-only.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReadOnly As Boolean
C#
bool ReadOnly {get;}

Property Value

true if the input field is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputField Interface
IInputField Members


Required Property

[image]
ActiveReports 19 .NET Edition
Required Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputField Interface : Required Property

Glossary Item Box

Gets a value indicating whether the input field is required.

Syntax

Visual Basic (Declaration)
ReadOnly Property Required As Boolean
C#
bool Required {get;}

Property Value

true if the input field is required; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputField Interface
IInputField Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputField Interface : Type Property

Glossary Item Box

Gets the type of the input field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As InputType
C#
InputType Type {get;}

Property Value

The type of the input field as an InputType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputField Interface
IInputField Members


IInputFieldWithTabIndex Interface

[image]
ActiveReports 19 .NET Edition
IInputFieldWithTabIndex Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputFieldWithTabIndex Interface

Glossary Item Box

Represents an input field with a tab index in a report.

Syntax

Visual Basic (Declaration)
Public Interface IInputFieldWithTabIndex
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField
C#
public interface IInputFieldWithTabIndex : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputFieldWithTabIndex Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputFieldWithTabIndex Interface Members

[image]
ActiveReports 19 .NET Edition
IInputFieldWithTabIndex Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputFieldWithTabIndex Interface

Glossary Item Box

The following tables list the members exposed by IInputFieldWithTabIndex.

Public Properties

 | Name | Description
Property | TabIndex | Gets the tab index of the input field.
Top

See Also

Reference

IInputFieldWithTabIndex Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputFieldWithTabIndex Interface Properties

[image]
ActiveReports 19 .NET Edition
IInputFieldWithTabIndex Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputFieldWithTabIndex Interface

Glossary Item Box

For a list of all members of this type, see IInputFieldWithTabIndex members.

Public Properties

 | Name | Description
Property | TabIndex | Gets the tab index of the input field.
Top

See Also

Reference

IInputFieldWithTabIndex Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


TabIndex Property

[image]
ActiveReports 19 .NET Edition
TabIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputFieldWithTabIndex Interface : TabIndex Property

Glossary Item Box

Gets the tab index of the input field.

Syntax

Visual Basic (Declaration)
ReadOnly Property TabIndex As Integer
C#
int TabIndex {get;}

Property Value

The tab index of the input field as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputFieldWithTabIndex Interface
IInputFieldWithTabIndex Members


IInputTextField Interface

[image]
ActiveReports 19 .NET Edition
IInputTextField Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputTextField Interface

Glossary Item Box

Represents a text input field in a report.

Syntax

Visual Basic (Declaration)
Public Interface IInputTextField
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField
C#
public interface IInputTextField : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, IInputField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputTextField Interface Members

[image]
ActiveReports 19 .NET Edition
IInputTextField Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputTextField Interface

Glossary Item Box

The following tables list the members exposed by IInputTextField.

Public Properties

 | Name | Description
Property | ContentValue | Gets the content value of the input field as a string.
Property | MaxLength | Gets the maximum length of the input field.
Property | Multiline | Gets a value indicating whether the input field supports multiple lines.
Property | Password | Gets a value indicating whether the input field is a password field.
Property | SpellCheck | Gets a value indicating whether spell check is enabled for the input field.
Property | Value | Gets the value of the input field.
Top

See Also

Reference

IInputTextField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IInputTextField Interface Properties

[image]
ActiveReports 19 .NET Edition
IInputTextField Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IInputTextField Interface

Glossary Item Box

For a list of all members of this type, see IInputTextField members.

Public Properties

 | Name | Description
Property | ContentValue | Gets the content value of the input field as a string.
Property | MaxLength | Gets the maximum length of the input field.
Property | Multiline | Gets a value indicating whether the input field supports multiple lines.
Property | Password | Gets a value indicating whether the input field is a password field.
Property | SpellCheck | Gets a value indicating whether spell check is enabled for the input field.
Property | Value | Gets the value of the input field.
Top

See Also

Reference

IInputTextField Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


ContentValue Property

[image]
ActiveReports 19 .NET Edition
ContentValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : ContentValue Property

Glossary Item Box

Gets the content value of the input field as a string.

Syntax

Visual Basic (Declaration)
ReadOnly Property ContentValue As String
C#
string ContentValue {get;}

Property Value

The content value of the input field as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


MaxLength Property

[image]
ActiveReports 19 .NET Edition
MaxLength Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : MaxLength Property

Glossary Item Box

Gets the maximum length of the input field.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxLength As Integer
C#
int MaxLength {get;}

Property Value

The maximum length of the input field as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


Multiline Property

[image]
ActiveReports 19 .NET Edition
Multiline Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : Multiline Property

Glossary Item Box

Gets a value indicating whether the input field supports multiple lines.

Syntax

Visual Basic (Declaration)
ReadOnly Property Multiline As Boolean
C#
bool Multiline {get;}

Property Value

true if the input field supports multiple lines; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : Password Property

Glossary Item Box

Gets a value indicating whether the input field is a password field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Password As Boolean
C#
bool Password {get;}

Property Value

true if the input field is a password field; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


SpellCheck Property

[image]
ActiveReports 19 .NET Edition
SpellCheck Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : SpellCheck Property

Glossary Item Box

Gets a value indicating whether spell check is enabled for the input field.

Syntax

Visual Basic (Declaration)
ReadOnly Property SpellCheck As Boolean
C#
bool SpellCheck {get;}

Property Value

true if spell check is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IInputTextField Interface : Value Property

Glossary Item Box

Gets the value of the input field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Object
C#
object Value {get;}

Property Value

The value of the input field as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInputTextField Interface
IInputTextField Members


IProgram Interface

[image]
ActiveReports 19 .NET Edition
IProgram Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgram Interface

Glossary Item Box

Represents a program interface.

Syntax

Visual Basic (Declaration)
Public Interface IProgram
C#
public interface IProgram

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgram Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IProgram Interface Members

[image]
ActiveReports 19 .NET Edition
IProgram Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgram Interface

Glossary Item Box

The following tables list the members exposed by IProgram.

Public Properties

 | Name | Description
Property | IsStatic | Returns ture if all expressions are constant.
Property | RenderingContext |
Property | Report |
Top

See Also

Reference

IProgram Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IProgram Interface Properties

[image]
ActiveReports 19 .NET Edition
IProgram Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgram Interface

Glossary Item Box

For a list of all members of this type, see IProgram members.

Public Properties

 | Name | Description
Property | IsStatic | Returns ture if all expressions are constant.
Property | RenderingContext |
Property | Report |
Top

See Also

Reference

IProgram Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IsStatic Property

[image]
ActiveReports 19 .NET Edition
IsStatic Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgram Interface : IsStatic Property

Glossary Item Box

Returns ture if all expressions are constant.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgram Interface
IProgram Members


RenderingContext Property

[image]
ActiveReports 19 .NET Edition
RenderingContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgram Interface : RenderingContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderingContext As IReportRenderingContext
C#
IReportRenderingContext RenderingContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgram Interface
IProgram Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgram Interface : Report Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Report As IReport
C#
IReport Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgram Interface
IProgram Members


IProgramServices Interface

[image]
ActiveReports 19 .NET Edition
IProgramServices Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgramServices Interface

Glossary Item Box

Defines services required for ProgramBase.

Syntax

Visual Basic (Declaration)
Public Interface IProgramServices
C#
public interface IProgramServices

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IProgramServices Interface Members

[image]
ActiveReports 19 .NET Edition
IProgramServices Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgramServices Interface

Glossary Item Box

The following tables list the members exposed by IProgramServices.

Public Properties

 | Name | Description
Property | ConstEvaluator |
Property | LocalizationResources |
Property | RenderingContext |
Property | Report |
Property | StyleSheetService |
Property | ThemeCount |
Top

See Also

Reference

IProgramServices Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IProgramServices Interface Properties

[image]
ActiveReports 19 .NET Edition
IProgramServices Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IProgramServices Interface

Glossary Item Box

For a list of all members of this type, see IProgramServices members.

Public Properties

 | Name | Description
Property | ConstEvaluator |
Property | LocalizationResources |
Property | RenderingContext |
Property | Report |
Property | StyleSheetService |
Property | ThemeCount |
Top

See Also

Reference

IProgramServices Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


ConstEvaluator Property

[image]
ActiveReports 19 .NET Edition
ConstEvaluator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : ConstEvaluator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ConstEvaluator As IExpressionEvaluatorService
C#
IExpressionEvaluatorService ConstEvaluator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


LocalizationResources Property

[image]
ActiveReports 19 .NET Edition
LocalizationResources Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : LocalizationResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LocalizationResources As LocalizationResource
C#
LocalizationResource LocalizationResources {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


RenderingContext Property

[image]
ActiveReports 19 .NET Edition
RenderingContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : RenderingContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderingContext As IReportRenderingContext
C#
IReportRenderingContext RenderingContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : Report Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Report As IReport
C#
IReport Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


StyleSheetService Property

[image]
ActiveReports 19 .NET Edition
StyleSheetService Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : StyleSheetService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleSheetService As IStyleSheetService
C#
IStyleSheetService StyleSheetService {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


ThemeCount Property

[image]
ActiveReports 19 .NET Edition
ThemeCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IProgramServices Interface : ThemeCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ThemeCount As Integer
C#
int ThemeCount {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IProgramServices Interface
IProgramServices Members


IRenderReportItemFactory Interface

[image]
ActiveReports 19 .NET Edition
IRenderReportItemFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IRenderReportItemFactory Interface

Glossary Item Box

Factory interface for creating report items.

Syntax

Visual Basic (Declaration)
Public Interface IRenderReportItemFactory
C#
public interface IRenderReportItemFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderReportItemFactory Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IRenderReportItemFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IRenderReportItemFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IRenderReportItemFactory Interface

Glossary Item Box

The following tables list the members exposed by IRenderReportItemFactory.

Public Methods

 | Name | Description
Method | Create | Creates a report item from the specified definition and data context.
Method | CreateCustomReportItem | Creates a custom report item from the specified definition, data context, and program.
Top

See Also

Reference

IRenderReportItemFactory Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IRenderReportItemFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IRenderReportItemFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IRenderReportItemFactory Interface

Glossary Item Box

For a list of all members of this type, see IRenderReportItemFactory members.

Public Methods

 | Name | Description
Method | Create | Creates a report item from the specified definition and data context.
Method | CreateCustomReportItem | Creates a custom report item from the specified definition, data context, and program.
Top

See Also

Reference

IRenderReportItemFactory Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


Create Method

[image]
ActiveReports 19 .NET Edition
Create Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IRenderReportItemFactory Interface : Create Method

reportRenderingContext
The GrapeCity.ActiveReports.Rendering.Components.Interfaces.IReportRenderingContext used for this report.
rdlItem
The RDL definition of the report item to construct.
currentDataContext
The GrapeCity.ActiveReports.Rendering.IDataScopeInternal to use as a data source for the created report items.

Glossary Item Box

Creates a report item from the specified definition and data context.

Syntax

Visual Basic (Declaration)
Function Create( _
   ByVal reportRenderingContext As IReportRenderingContext, _
   ByVal rdlItem As ReportItem, _
   ByVal currentDataContext As IDataScopeInternal _
) As IReportItem
C#
IReportItem Create(
   IReportRenderingContext reportRenderingContext,
   ReportItem rdlItem,
   IDataScopeInternal currentDataContext
)

Parameters

reportRenderingContext
The GrapeCity.ActiveReports.Rendering.Components.Interfaces.IReportRenderingContext used for this report.
rdlItem
The RDL definition of the report item to construct.
currentDataContext
The GrapeCity.ActiveReports.Rendering.IDataScopeInternal to use as a data source for the created report items.

Return Value

An array of GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem instances.

Remarks

NOTE: The returned array of items may have more items than the input definitions due to the composition of simple report items like rectangles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderReportItemFactory Interface
IRenderReportItemFactory Members


CreateCustomReportItem Method

[image]
ActiveReports 19 .NET Edition
CreateCustomReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IRenderReportItemFactory Interface : CreateCustomReportItem Method

context
The GrapeCity.ActiveReports.Rendering.Components.Interfaces.IReportRenderingContext used for this report.
definition
The custom report item definition.
dataContext
The GrapeCity.ActiveReports.Rendering.IDataScopeInternal to use as a data source for the created report items.
program
The program used to create the custom report item.

Glossary Item Box

Creates a custom report item from the specified definition, data context, and program.

Syntax

Visual Basic (Declaration)
Function CreateCustomReportItem( _
   ByVal context As IReportRenderingContext, _
   ByVal definition As CustomReportItem, _
   ByVal dataContext As IDataScopeInternal, _
   ByVal program As IReportItemProgram(Of ReportItem) _
) As IReportItem
C#
IReportItem CreateCustomReportItem(
   IReportRenderingContext context,
   CustomReportItem definition,
   IDataScopeInternal dataContext,
   IReportItemProgram<ReportItem> program
)

Parameters

context
The GrapeCity.ActiveReports.Rendering.Components.Interfaces.IReportRenderingContext used for this report.
definition
The custom report item definition.
dataContext
The GrapeCity.ActiveReports.Rendering.IDataScopeInternal to use as a data source for the created report items.
program
The program used to create the custom report item.

Return Value

A custom GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderReportItemFactory Interface
IRenderReportItemFactory Members


IReportItemProgram<T> Interface

T
[image]
ActiveReports 19 .NET Edition
IReportItemProgram<T> Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IReportItemProgram<T> Interface

Glossary Item Box

Represents a report item program interface.

Syntax

Visual Basic (Declaration)
Public Interface IReportItemProgram(Of T)
   Inherits IProgram
C#
public interface IReportItemProgram<T> : IProgram

Type Parameters

T

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IReportItemProgram<T> Interface Members

[image]
ActiveReports 19 .NET Edition
IReportItemProgram<T> Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IReportItemProgram<T> Interface

Glossary Item Box

The following tables list the members exposed by IReportItemProgram<T>.

Public Properties

 | Name | Description
Property | Action |
Property | Bookmark |
Property | Definition |
Property | Height |
Property | Hidden |
Property | IsDelayedHidden |
Property | IsDynamicallyHidden |
Property | Label |
Property | RequiresRenderingServices |
Property | Services |
Property | Style |
Property | TargetDevice |
Property | ToolTip |
Property | Width |
Top

See Also

Reference

IReportItemProgram<T> Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IReportItemProgram<T> Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportItemProgram<T> Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IReportItemProgram<T> Interface

Glossary Item Box

For a list of all members of this type, see IReportItemProgram<T> members.

Public Properties

 | Name | Description
Property | Action |
Property | Bookmark |
Property | Definition |
Property | Height |
Property | Hidden |
Property | IsDelayedHidden |
Property | IsDynamicallyHidden |
Property | Label |
Property | RequiresRenderingServices |
Property | Services |
Property | Style |
Property | TargetDevice |
Property | ToolTip |
Property | Width |
Top

See Also

Reference

IReportItemProgram<T> Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


Action Property

[image]
ActiveReports 19 .NET Edition
Action Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Action Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Action As ActionProgram
C#
ActionProgram Action {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Bookmark Property

[image]
ActiveReports 19 .NET Edition
Bookmark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Bookmark Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Bookmark As EvalFunc(Of String)
C#
EvalFunc<string> Bookmark {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Definition Property

[image]
ActiveReports 19 .NET Edition
Definition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Definition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Definition As T
C#
T Definition {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Hidden Property

[image]
ActiveReports 19 .NET Edition
Hidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Hidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hidden As EvalFunc(Of Boolean)
C#
EvalFunc<bool> Hidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


IsDelayedHidden Property

[image]
ActiveReports 19 .NET Edition
IsDelayedHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : IsDelayedHidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDelayedHidden As Boolean
C#
bool IsDelayedHidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


IsDynamicallyHidden Property

[image]
ActiveReports 19 .NET Edition
IsDynamicallyHidden Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : IsDynamicallyHidden Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDynamicallyHidden As Boolean
C#
bool IsDynamicallyHidden {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Label Property

[image]
ActiveReports 19 .NET Edition
Label Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Label Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As EvalFunc(Of String)
C#
EvalFunc<string> Label {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


RequiresRenderingServices Property

[image]
ActiveReports 19 .NET Edition
RequiresRenderingServices Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : RequiresRenderingServices Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresRenderingServices As Boolean
C#
bool RequiresRenderingServices {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Services Property

[image]
ActiveReports 19 .NET Edition
Services Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Services Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Services As IProgramServices
C#
IProgramServices Services {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Style Property

[image]
ActiveReports 19 .NET Edition
Style Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As StyleProgram
C#
StyleProgram Style {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


TargetDevice Property

[image]
ActiveReports 19 .NET Edition
TargetDevice Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : TargetDevice Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TargetDevice As TargetDeviceKind
C#
TargetDeviceKind TargetDevice {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


ToolTip Property

[image]
ActiveReports 19 .NET Edition
ToolTip Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolTip As EvalFunc(Of String)
C#
EvalFunc<string> ToolTip {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IReportItemProgram<T> Interface : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportItemProgram<T> Interface
IReportItemProgram<T> Members


IStyleEvaluatorFactory Interface

[image]
ActiveReports 19 .NET Edition
IStyleEvaluatorFactory Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IStyleEvaluatorFactory Interface

Glossary Item Box

Defines a factory for StyleEvaluator.

Syntax

Visual Basic (Declaration)
Public Interface IStyleEvaluatorFactory
C#
public interface IStyleEvaluatorFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleEvaluatorFactory Members
GrapeCity.ActiveReports.Rendering.Components Namespace


IStyleEvaluatorFactory Interface Members

[image]
ActiveReports 19 .NET Edition
IStyleEvaluatorFactory Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IStyleEvaluatorFactory Interface

Glossary Item Box

The following tables list the members exposed by IStyleEvaluatorFactory.

Public Methods

 | Name | Description
Method | CreateStyleEvaluator |
Top

See Also

Reference

IStyleEvaluatorFactory Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


IStyleEvaluatorFactory Interface Methods

[image]
ActiveReports 19 .NET Edition
IStyleEvaluatorFactory Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace : IStyleEvaluatorFactory Interface

Glossary Item Box

For a list of all members of this type, see IStyleEvaluatorFactory members.

Public Methods

 | Name | Description
Method | CreateStyleEvaluator |
Top

See Also

Reference

IStyleEvaluatorFactory Interface
GrapeCity.ActiveReports.Rendering.Components Namespace


CreateStyleEvaluator Method

[image]
ActiveReports 19 .NET Edition
CreateStyleEvaluator Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components Namespace > IStyleEvaluatorFactory Interface : CreateStyleEvaluator Method

style
expressionEvaluatorService

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateStyleEvaluator( _
   ByVal style As Style, _
   ByVal expressionEvaluatorService As IExpressionEvaluatorService _
) As IStyle
C#
IStyle CreateStyleEvaluator(
   Style style,
   IExpressionEvaluatorService expressionEvaluatorService
)

Parameters

style
expressionEvaluatorService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleEvaluatorFactory Interface
IStyleEvaluatorFactory Members


BarcodeUtils Class

[image]
ActiveReports 19 .NET Edition
BarcodeUtils Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : BarcodeUtils Class

Glossary Item Box

Methods used to get information for barcode rendering.

Object Model

BarcodeUtils Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class BarcodeUtils
C#
public static class BarcodeUtils

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Barcode.BarcodeUtils

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeUtils Members
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


BarcodeUtils Class Members

[image]
ActiveReports 19 .NET Edition
BarcodeUtils Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : BarcodeUtils Class

Glossary Item Box

The following tables list the members exposed by BarcodeUtils.

See Also

Reference

BarcodeUtils Class
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


ErrorCorrectionLevel Enumeration

[image]
ActiveReports 19 .NET Edition
ErrorCorrectionLevel Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : ErrorCorrectionLevel Enumeration

Glossary Item Box

Specifies the error correction level used by PDF417.

Syntax

Visual Basic (Declaration)
Public Enum ErrorCorrectionLevel
   Inherits System.Enum
C#
public enum ErrorCorrectionLevel : System.Enum

Members

Member | Description
Level0 | Specifies error correction level 0.
Level1 | Specifies error correction level 1.
Level2 | Specifies error correction level 2.
Level3 | Specifies error correction level 3.
Level4 | Specifies error correction level 4.
Level5 | Specifies error correction level 5.
Level6 | Specifies error correction level 6.
Level7 | Specifies error correction level 7.
Level8 | Specifies error correction level 8.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Barcode.ErrorCorrectionLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


Mask Enumeration

[image]
ActiveReports 19 .NET Edition
Mask Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : Mask Enumeration

Glossary Item Box

Specifies the masks for the QRCode barcode symbology.

Syntax

Visual Basic (Declaration)
Public Enum Mask
   Inherits System.Enum
C#
public enum Mask : System.Enum

Members

Member | Description
Auto | Specifies that the mask pattern will be selected automatically.
Mask000 | Specifies the mask pattern 000.
Mask001 | Specifies the mask pattern 001.
Mask010 | Specifies the mask pattern 010.
Mask011 | Specifies the mask pattern 011.
Mask100 | Specifies the mask pattern 100.
Mask101 | Specifies the mask pattern 101.
Mask110 | Specifies the mask pattern 110.
Mask111 | Specifies the mask pattern 111.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Barcode.Mask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


Model Enumeration

[image]
ActiveReports 19 .NET Edition
Model Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : Model Enumeration

Glossary Item Box

Specifies the models for the QRCode barcode symbology.

Syntax

Visual Basic (Declaration)
Public Enum Model
   Inherits System.Enum
C#
public enum Model : System.Enum

Members

Member | Description
Model1 | Specifies QRCode Model 1.
Model2 | Specifies QRCode Model 2.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Barcode.Model

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


Pdf417Type Enumeration

[image]
ActiveReports 19 .NET Edition
Pdf417Type Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : Pdf417Type Enumeration

Glossary Item Box

Specifies the type of PDF417.

Syntax

Visual Basic (Declaration)
Public Enum Pdf417Type
   Inherits System.Enum
C#
public enum Pdf417Type : System.Enum

Members

Member | Description
Normal | Specifies the normal type of PDF417.
Simple | Specifies the simple type of PDF417.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Barcode.Pdf417Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


IAztecBarcode Interface

[image]
ActiveReports 19 .NET Edition
IAztecBarcode Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IAztecBarcode Interface

Glossary Item Box

Represents an Aztec barcode.

Syntax

Visual Basic (Declaration)
Public Interface IAztecBarcode
C#
public interface IAztecBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAztecBarcode Members
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


IAztecBarcode Interface Members

[image]
ActiveReports 19 .NET Edition
IAztecBarcode Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IAztecBarcode Interface

Glossary Item Box

The following tables list the members exposed by IAztecBarcode.

Public Properties

 | Name | Description
Property | AztecEncoding | Gets the encoding used for the Aztec barcode.
Property | AztecErrorCorrection | Gets the error correction level for the Aztec barcode.
Property | AztecLayers | Gets the number of layers for the Aztec barcode.
Top

See Also

Reference

IAztecBarcode Interface
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


IAztecBarcode Interface Properties

[image]
ActiveReports 19 .NET Edition
IAztecBarcode Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IAztecBarcode Interface

Glossary Item Box

For a list of all members of this type, see IAztecBarcode members.

Public Properties

 | Name | Description
Property | AztecEncoding | Gets the encoding used for the Aztec barcode.
Property | AztecErrorCorrection | Gets the error correction level for the Aztec barcode.
Property | AztecLayers | Gets the number of layers for the Aztec barcode.
Top

See Also

Reference

IAztecBarcode Interface
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


AztecEncoding Property

[image]
ActiveReports 19 .NET Edition
AztecEncoding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IAztecBarcode Interface : AztecEncoding Property

Glossary Item Box

Gets the encoding used for the Aztec barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property AztecEncoding As Encoding
C#
Encoding AztecEncoding {get;}

Property Value

The encoding as an System.Text.Encoding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAztecBarcode Interface
IAztecBarcode Members


AztecErrorCorrection Property

[image]
ActiveReports 19 .NET Edition
AztecErrorCorrection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IAztecBarcode Interface : AztecErrorCorrection Property

Glossary Item Box

Gets the error correction level for the Aztec barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property AztecErrorCorrection As Integer
C#
int AztecErrorCorrection {get;}

Property Value

The error correction level as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAztecBarcode Interface
IAztecBarcode Members


AztecLayers Property

[image]
ActiveReports 19 .NET Edition
AztecLayers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IAztecBarcode Interface : AztecLayers Property

Glossary Item Box

Gets the number of layers for the Aztec barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property AztecLayers As Integer
C#
int AztecLayers {get;}

Property Value

The number of layers as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAztecBarcode Interface
IAztecBarcode Members


IBarcodeReportItem Interface

[image]
ActiveReports 19 .NET Edition
IBarcodeReportItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IBarcodeReportItem Interface

Glossary Item Box

Represents information about a barcode.

Syntax

Visual Basic (Declaration)
Public Interface IBarcodeReportItem
C#
public interface IBarcodeReportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Members
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


IBarcodeReportItem Interface Members

[image]
ActiveReports 19 .NET Edition
IBarcodeReportItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IBarcodeReportItem Interface

Glossary Item Box

The following tables list the members exposed by IBarcodeReportItem.

Public Properties

 | Name | Description
Property | BarHeight | Gets the bar height of the barcode.
Property | CaptionAlignment | Gets the alignment of the caption.
Property | CaptionGrouping | Gets a value indicating whether caption grouping is enabled.
Property | CaptionLocation | Gets the location of the caption.
Property | CheckSum | Gets a value indicating whether the checksum is enabled.
Property | Code49Grouping | Gets a value indicating whether code 49 grouping is enabled.
Property | Code49GroupNumber | Gets the group number for code 49.
Property | DataMatrixEcc000_140SymbolSize | Gets the symbol size for Data Matrix ECC 000-140.
Property | DataMatrixEcc200EncodingMode | Gets the encoding mode for Data Matrix ECC 200.
Property | DataMatrixEcc200SymbolSize | Gets the symbol size for Data Matrix ECC 200.
Property | DataMatrixEccMode | Gets the ECC mode for Data Matrix.
Property | DataMatrixEncoding | Gets the encoding for Data Matrix.
Property | DataMatrixFileIdentifier | Gets the file identifier for Data Matrix.
Property | DataMatrixStructuredAppend | Gets a value indicating whether structured append is enabled for Data Matrix.
Property | DataMatrixStructureNumber | Gets the structure number for Data Matrix.
Property | Ean128Fnc1BarAdjust | Gets the bar adjust value for EAN-128 FNC1.
Property | Ean128Fnc1Dpi | Gets the DPI for EAN-128 FNC1.
Property | Ean128Fnc1ModuleSize | Gets the module size for EAN-128 FNC1.
Property | FontInfo | Gets the font information.
Property | FormattedGS1CompositeValue | Gets the formatted GS1 composite value.
Property | FormattedSupplementValue | Gets the formatted supplement value of the barcode.
Property | FormattedValue | Gets the formatted value of the barcode.
Property | GS1CompositeType | Gets the GS1 composite type.
Property | GS1CompositeValue | Gets the GS1 composite value.
Property | Height | Gets the height of the barcode.
Property | InvalidBarcodeText | Gets the invalid barcode text.
Property | Left | Gets the left position of the barcode.
Property | MaxiCodeMode | Gets the mode for MaxiCode.
Property | MicroPDF417CompactionMode | Gets the compaction mode for MicroPDF417.
Property | MicroPDF417FileID | Gets the file ID for MicroPDF417.
Property | MicroPDF417SegmentCount | Gets the segment count for MicroPDF417.
Property | MicroPDF417SegmentIndex | Gets the segment index for MicroPDF417.
Property | MicroPDF417Version | Gets the version for MicroPDF417.
Property | MicroQrEncoding | Gets the encoding for Micro QR code.
Property | MicroQrErrorLevel | Gets the error level for Micro QR code.
Property | MicroQrMask | Gets the mask for Micro QR code.
Property | MicroQrVersion | Gets the version for Micro QR code.
Property | NarrowBarWidth | Gets the narrow bar width of the barcode.
Property | NWRatio | Gets the narrow-to-wide ratio of the barcode.
Property | Pdf417ErrorCorrectionLevel | Gets the error correction level for PDF417.
Property | Pdf417OptionsColumns | Gets the number of columns for PDF417 options.
Property | Pdf417OptionsRows | Gets the number of rows for PDF417 options.
Property | Pdf417OptionsType | Gets the type of PDF417 options.
Property | QRCodeConnection | Gets a value indicating whether QR code connection is enabled.
Property | QRCodeConnectionNumber | Gets the QR code connection number.
Property | QRCodeEncoding | Gets the encoding for QR code.
Property | QRCodeErrorLevel | Gets the error level for QR code.
Property | QRCodeMask | Gets the mask for QR code.
Property | QRCodeModel | Gets the model for QR code.
Property | QRCodeVersion | Gets the QR code version.
Property | QuietZoneBottom | Gets the bottom quiet zone of the barcode.
Property | QuietZoneLeft | Gets the left quiet zone of the barcode.
Property | QuietZoneRight | Gets the right quiet zone of the barcode.
Property | QuietZoneTop | Gets the top quiet zone of the barcode.
Property | Rotation | Gets the rotation of the barcode.
Property | RssExpandedStackedRowCount | Gets the row count for RSS expanded stacked barcodes.
Property | StyleEvaluator | Gets the style evaluator.
Property | SupplementBarHeight | Gets the supplement bar height of the barcode.
Property | SupplementCaptionLocation | Gets the location of the supplement caption.
Property | SupplementSpacing | Gets the supplement spacing of the barcode.
Property | SupplementValue | Gets the supplement value of the barcode.
Property | Symbology | Gets the barcode symbology.
Property | Top | Gets the top position of the barcode.
Property | Value | Gets the value of the barcode.
Property | Width | Gets the width of the barcode.
Top

See Also

Reference

IBarcodeReportItem Interface
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


IBarcodeReportItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IBarcodeReportItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace : IBarcodeReportItem Interface

Glossary Item Box

For a list of all members of this type, see IBarcodeReportItem members.

Public Properties

 | Name | Description
Property | BarHeight | Gets the bar height of the barcode.
Property | CaptionAlignment | Gets the alignment of the caption.
Property | CaptionGrouping | Gets a value indicating whether caption grouping is enabled.
Property | CaptionLocation | Gets the location of the caption.
Property | CheckSum | Gets a value indicating whether the checksum is enabled.
Property | Code49Grouping | Gets a value indicating whether code 49 grouping is enabled.
Property | Code49GroupNumber | Gets the group number for code 49.
Property | DataMatrixEcc000_140SymbolSize | Gets the symbol size for Data Matrix ECC 000-140.
Property | DataMatrixEcc200EncodingMode | Gets the encoding mode for Data Matrix ECC 200.
Property | DataMatrixEcc200SymbolSize | Gets the symbol size for Data Matrix ECC 200.
Property | DataMatrixEccMode | Gets the ECC mode for Data Matrix.
Property | DataMatrixEncoding | Gets the encoding for Data Matrix.
Property | DataMatrixFileIdentifier | Gets the file identifier for Data Matrix.
Property | DataMatrixStructuredAppend | Gets a value indicating whether structured append is enabled for Data Matrix.
Property | DataMatrixStructureNumber | Gets the structure number for Data Matrix.
Property | Ean128Fnc1BarAdjust | Gets the bar adjust value for EAN-128 FNC1.
Property | Ean128Fnc1Dpi | Gets the DPI for EAN-128 FNC1.
Property | Ean128Fnc1ModuleSize | Gets the module size for EAN-128 FNC1.
Property | FontInfo | Gets the font information.
Property | FormattedGS1CompositeValue | Gets the formatted GS1 composite value.
Property | FormattedSupplementValue | Gets the formatted supplement value of the barcode.
Property | FormattedValue | Gets the formatted value of the barcode.
Property | GS1CompositeType | Gets the GS1 composite type.
Property | GS1CompositeValue | Gets the GS1 composite value.
Property | Height | Gets the height of the barcode.
Property | InvalidBarcodeText | Gets the invalid barcode text.
Property | Left | Gets the left position of the barcode.
Property | MaxiCodeMode | Gets the mode for MaxiCode.
Property | MicroPDF417CompactionMode | Gets the compaction mode for MicroPDF417.
Property | MicroPDF417FileID | Gets the file ID for MicroPDF417.
Property | MicroPDF417SegmentCount | Gets the segment count for MicroPDF417.
Property | MicroPDF417SegmentIndex | Gets the segment index for MicroPDF417.
Property | MicroPDF417Version | Gets the version for MicroPDF417.
Property | MicroQrEncoding | Gets the encoding for Micro QR code.
Property | MicroQrErrorLevel | Gets the error level for Micro QR code.
Property | MicroQrMask | Gets the mask for Micro QR code.
Property | MicroQrVersion | Gets the version for Micro QR code.
Property | NarrowBarWidth | Gets the narrow bar width of the barcode.
Property | NWRatio | Gets the narrow-to-wide ratio of the barcode.
Property | Pdf417ErrorCorrectionLevel | Gets the error correction level for PDF417.
Property | Pdf417OptionsColumns | Gets the number of columns for PDF417 options.
Property | Pdf417OptionsRows | Gets the number of rows for PDF417 options.
Property | Pdf417OptionsType | Gets the type of PDF417 options.
Property | QRCodeConnection | Gets a value indicating whether QR code connection is enabled.
Property | QRCodeConnectionNumber | Gets the QR code connection number.
Property | QRCodeEncoding | Gets the encoding for QR code.
Property | QRCodeErrorLevel | Gets the error level for QR code.
Property | QRCodeMask | Gets the mask for QR code.
Property | QRCodeModel | Gets the model for QR code.
Property | QRCodeVersion | Gets the QR code version.
Property | QuietZoneBottom | Gets the bottom quiet zone of the barcode.
Property | QuietZoneLeft | Gets the left quiet zone of the barcode.
Property | QuietZoneRight | Gets the right quiet zone of the barcode.
Property | QuietZoneTop | Gets the top quiet zone of the barcode.
Property | Rotation | Gets the rotation of the barcode.
Property | RssExpandedStackedRowCount | Gets the row count for RSS expanded stacked barcodes.
Property | StyleEvaluator | Gets the style evaluator.
Property | SupplementBarHeight | Gets the supplement bar height of the barcode.
Property | SupplementCaptionLocation | Gets the location of the supplement caption.
Property | SupplementSpacing | Gets the supplement spacing of the barcode.
Property | SupplementValue | Gets the supplement value of the barcode.
Property | Symbology | Gets the barcode symbology.
Property | Top | Gets the top position of the barcode.
Property | Value | Gets the value of the barcode.
Property | Width | Gets the width of the barcode.
Top

See Also

Reference

IBarcodeReportItem Interface
GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace


BarHeight Property

[image]
ActiveReports 19 .NET Edition
BarHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : BarHeight Property

Glossary Item Box

Gets the bar height of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property BarHeight As Length
C#
Length BarHeight {get;}

Property Value

The bar height of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


CaptionAlignment Property

[image]
ActiveReports 19 .NET Edition
CaptionAlignment Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : CaptionAlignment Property

Glossary Item Box

Gets the alignment of the caption.

Syntax

Visual Basic (Declaration)
ReadOnly Property CaptionAlignment As StringAlignmentEx
C#
StringAlignmentEx CaptionAlignment {get;}

Property Value

The alignment of the caption as a GrapeCity.ActiveReports.Drawing.StringAlignmentEx.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


CaptionGrouping Property

[image]
ActiveReports 19 .NET Edition
CaptionGrouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : CaptionGrouping Property

Glossary Item Box

Gets a value indicating whether caption grouping is enabled.

Syntax

Visual Basic (Declaration)
ReadOnly Property CaptionGrouping As Boolean
C#
bool CaptionGrouping {get;}

Property Value

true if caption grouping is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


CaptionLocation Property

[image]
ActiveReports 19 .NET Edition
CaptionLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : CaptionLocation Property

Glossary Item Box

Gets the location of the caption.

Syntax

Visual Basic (Declaration)
ReadOnly Property CaptionLocation As BarCodeCaptionPosition
C#
BarCodeCaptionPosition CaptionLocation {get;}

Property Value

The location of the caption as a GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeCaptionPosition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


CheckSum Property

[image]
ActiveReports 19 .NET Edition
CheckSum Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : CheckSum Property

Glossary Item Box

Gets a value indicating whether the checksum is enabled.

Syntax

Visual Basic (Declaration)
ReadOnly Property CheckSum As Boolean
C#
bool CheckSum {get;}

Property Value

true if the checksum is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Code49Grouping Property

[image]
ActiveReports 19 .NET Edition
Code49Grouping Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Code49Grouping Property

Glossary Item Box

Gets a value indicating whether code 49 grouping is enabled.

Syntax

Visual Basic (Declaration)
ReadOnly Property Code49Grouping As Boolean
C#
bool Code49Grouping {get;}

Property Value

true if code 49 grouping is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Code49GroupNumber Property

[image]
ActiveReports 19 .NET Edition
Code49GroupNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Code49GroupNumber Property

Glossary Item Box

Gets the group number for code 49.

Syntax

Visual Basic (Declaration)
ReadOnly Property Code49GroupNumber As Integer
C#
int Code49GroupNumber {get;}

Property Value

The group number for code 49 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixEcc000_140SymbolSize Property

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc000_140SymbolSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixEcc000_140SymbolSize Property

Glossary Item Box

Gets the symbol size for Data Matrix ECC 000-140.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixEcc000_140SymbolSize As DataMatrixEcc000_140SymbolSize
C#
DataMatrixEcc000_140SymbolSize DataMatrixEcc000_140SymbolSize {get;}

Property Value

The symbol size for Data Matrix ECC 000-140 as a DataMatrixEcc000_140SymbolSize.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixEcc200EncodingMode Property

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc200EncodingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixEcc200EncodingMode Property

Glossary Item Box

Gets the encoding mode for Data Matrix ECC 200.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixEcc200EncodingMode As DataMatrixEcc200EncodingMode
C#
DataMatrixEcc200EncodingMode DataMatrixEcc200EncodingMode {get;}

Property Value

The encoding mode for Data Matrix ECC 200 as a DataMatrixEcc200EncodingMode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixEcc200SymbolSize Property

[image]
ActiveReports 19 .NET Edition
DataMatrixEcc200SymbolSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixEcc200SymbolSize Property

Glossary Item Box

Gets the symbol size for Data Matrix ECC 200.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixEcc200SymbolSize As DataMatrixEcc200SymbolSize
C#
DataMatrixEcc200SymbolSize DataMatrixEcc200SymbolSize {get;}

Property Value

The symbol size for Data Matrix ECC 200 as a DataMatrixEcc200SymbolSize.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixEccMode Property

[image]
ActiveReports 19 .NET Edition
DataMatrixEccMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixEccMode Property

Glossary Item Box

Gets the ECC mode for Data Matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixEccMode As DataMatrixEccMode
C#
DataMatrixEccMode DataMatrixEccMode {get;}

Property Value

The ECC mode for Data Matrix as a DataMatrixEccMode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixEncoding Property

[image]
ActiveReports 19 .NET Edition
DataMatrixEncoding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixEncoding Property

Glossary Item Box

Gets the encoding for Data Matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixEncoding As Encoding
C#
Encoding DataMatrixEncoding {get;}

Property Value

The encoding for Data Matrix as an System.Text.Encoding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixFileIdentifier Property

[image]
ActiveReports 19 .NET Edition
DataMatrixFileIdentifier Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixFileIdentifier Property

Glossary Item Box

Gets the file identifier for Data Matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixFileIdentifier As Byte
C#
byte DataMatrixFileIdentifier {get;}

Property Value

The file identifier for Data Matrix as a System.Byte.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixStructuredAppend Property

[image]
ActiveReports 19 .NET Edition
DataMatrixStructuredAppend Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixStructuredAppend Property

Glossary Item Box

Gets a value indicating whether structured append is enabled for Data Matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixStructuredAppend As Boolean
C#
bool DataMatrixStructuredAppend {get;}

Property Value

true if structured append is enabled for Data Matrix; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


DataMatrixStructureNumber Property

[image]
ActiveReports 19 .NET Edition
DataMatrixStructureNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : DataMatrixStructureNumber Property

Glossary Item Box

Gets the structure number for Data Matrix.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataMatrixStructureNumber As Integer
C#
int DataMatrixStructureNumber {get;}

Property Value

The structure number for Data Matrix as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Ean128Fnc1BarAdjust Property

[image]
ActiveReports 19 .NET Edition
Ean128Fnc1BarAdjust Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Ean128Fnc1BarAdjust Property

Glossary Item Box

Gets the bar adjust value for EAN-128 FNC1.

Syntax

Visual Basic (Declaration)
ReadOnly Property Ean128Fnc1BarAdjust As Integer
C#
int Ean128Fnc1BarAdjust {get;}

Property Value

The bar adjust value for EAN-128 FNC1 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Ean128Fnc1Dpi Property

[image]
ActiveReports 19 .NET Edition
Ean128Fnc1Dpi Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Ean128Fnc1Dpi Property

Glossary Item Box

Gets the DPI for EAN-128 FNC1.

Syntax

Visual Basic (Declaration)
ReadOnly Property Ean128Fnc1Dpi As Integer
C#
int Ean128Fnc1Dpi {get;}

Property Value

The DPI for EAN-128 FNC1 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Ean128Fnc1ModuleSize Property

[image]
ActiveReports 19 .NET Edition
Ean128Fnc1ModuleSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Ean128Fnc1ModuleSize Property

Glossary Item Box

Gets the module size for EAN-128 FNC1.

Syntax

Visual Basic (Declaration)
ReadOnly Property Ean128Fnc1ModuleSize As Integer
C#
int Ean128Fnc1ModuleSize {get;}

Property Value

The module size for EAN-128 FNC1 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


FontInfo Property

[image]
ActiveReports 19 .NET Edition
FontInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : FontInfo Property

Glossary Item Box

Gets the font information.

Syntax

Visual Basic (Declaration)
ReadOnly Property FontInfo As FontInfo
C#
FontInfo FontInfo {get;}

Property Value

The font information as a FontInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


FormattedGS1CompositeValue Property

[image]
ActiveReports 19 .NET Edition
FormattedGS1CompositeValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : FormattedGS1CompositeValue Property

Glossary Item Box

Gets the formatted GS1 composite value.

Syntax

Visual Basic (Declaration)
ReadOnly Property FormattedGS1CompositeValue As String
C#
string FormattedGS1CompositeValue {get;}

Property Value

The formatted GS1 composite value as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


FormattedSupplementValue Property

[image]
ActiveReports 19 .NET Edition
FormattedSupplementValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : FormattedSupplementValue Property

Glossary Item Box

Gets the formatted supplement value of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property FormattedSupplementValue As String
C#
string FormattedSupplementValue {get;}

Property Value

The formatted supplement value of the barcode as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


FormattedValue Property

[image]
ActiveReports 19 .NET Edition
FormattedValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : FormattedValue Property

Glossary Item Box

Gets the formatted value of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property FormattedValue As String
C#
string FormattedValue {get;}

Property Value

The formatted value of the barcode as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


GS1CompositeType Property

[image]
ActiveReports 19 .NET Edition
GS1CompositeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : GS1CompositeType Property

Glossary Item Box

Gets the GS1 composite type.

Syntax

Visual Basic (Declaration)
ReadOnly Property GS1CompositeType As GS1CompositeType
C#
GS1CompositeType GS1CompositeType {get;}

Property Value

The GS1 composite type as a GS1CompositeType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


GS1CompositeValue Property

[image]
ActiveReports 19 .NET Edition
GS1CompositeValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : GS1CompositeValue Property

Glossary Item Box

Gets the GS1 composite value.

Syntax

Visual Basic (Declaration)
ReadOnly Property GS1CompositeValue As Object
C#
object GS1CompositeValue {get;}

Property Value

The GS1 composite value as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Height Property

[image]
ActiveReports 19 .NET Edition
Height Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Height Property

Glossary Item Box

Gets the height of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Height As Length
C#
Length Height {get;}

Property Value

The height of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


InvalidBarcodeText Property

[image]
ActiveReports 19 .NET Edition
InvalidBarcodeText Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : InvalidBarcodeText Property

Glossary Item Box

Gets the invalid barcode text.

Syntax

Visual Basic (Declaration)
ReadOnly Property InvalidBarcodeText As String
C#
string InvalidBarcodeText {get;}

Property Value

The invalid barcode text as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Left Property

[image]
ActiveReports 19 .NET Edition
Left Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Left Property

Glossary Item Box

Gets the left position of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Left As Length
C#
Length Left {get;}

Property Value

The left position of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MaxiCodeMode Property

[image]
ActiveReports 19 .NET Edition
MaxiCodeMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MaxiCodeMode Property

Glossary Item Box

Gets the mode for MaxiCode.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxiCodeMode As MaxiCodeMode
C#
MaxiCodeMode MaxiCodeMode {get;}

Property Value

The mode for MaxiCode as a MaxiCodeMode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroPDF417CompactionMode Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417CompactionMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroPDF417CompactionMode Property

Glossary Item Box

Gets the compaction mode for MicroPDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroPDF417CompactionMode As MicroPDF417SymbolCompactionMode
C#
MicroPDF417SymbolCompactionMode MicroPDF417CompactionMode {get;}

Property Value

The compaction mode for MicroPDF417 as a GrapeCity.ActiveReports.BarCodes.MicroPDF417SymbolCompactionMode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroPDF417FileID Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417FileID Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroPDF417FileID Property

Glossary Item Box

Gets the file ID for MicroPDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroPDF417FileID As Integer
C#
int MicroPDF417FileID {get;}

Property Value

The file ID for MicroPDF417 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroPDF417SegmentCount Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417SegmentCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroPDF417SegmentCount Property

Glossary Item Box

Gets the segment count for MicroPDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroPDF417SegmentCount As Integer
C#
int MicroPDF417SegmentCount {get;}

Property Value

The segment count for MicroPDF417 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroPDF417SegmentIndex Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417SegmentIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroPDF417SegmentIndex Property

Glossary Item Box

Gets the segment index for MicroPDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroPDF417SegmentIndex As Integer
C#
int MicroPDF417SegmentIndex {get;}

Property Value

The segment index for MicroPDF417 as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroPDF417Version Property

[image]
ActiveReports 19 .NET Edition
MicroPDF417Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroPDF417Version Property

Glossary Item Box

Gets the version for MicroPDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroPDF417Version As MicroPDF417SymbolVersion
C#
MicroPDF417SymbolVersion MicroPDF417Version {get;}

Property Value

The version for MicroPDF417 as a GrapeCity.ActiveReports.BarCodes.MicroPDF417SymbolVersion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroQrEncoding Property

[image]
ActiveReports 19 .NET Edition
MicroQrEncoding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroQrEncoding Property

Glossary Item Box

Gets the encoding for Micro QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroQrEncoding As Integer
C#
int MicroQrEncoding {get;}

Property Value

The encoding for Micro QR code as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroQrErrorLevel Property

[image]
ActiveReports 19 .NET Edition
MicroQrErrorLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroQrErrorLevel Property

Glossary Item Box

Gets the error level for Micro QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroQrErrorLevel As MicroQRCodeErrorLevel
C#
MicroQRCodeErrorLevel MicroQrErrorLevel {get;}

Property Value

The error level for Micro QR code as a GrapeCity.ActiveReports.BarCodes.MicroQRCodeErrorLevel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroQrMask Property

[image]
ActiveReports 19 .NET Edition
MicroQrMask Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroQrMask Property

Glossary Item Box

Gets the mask for Micro QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroQrMask As MicroQRCodeMask
C#
MicroQRCodeMask MicroQrMask {get;}

Property Value

The mask for Micro QR code as a GrapeCity.ActiveReports.BarCodes.MicroQRCodeMask.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


MicroQrVersion Property

[image]
ActiveReports 19 .NET Edition
MicroQrVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : MicroQrVersion Property

Glossary Item Box

Gets the version for Micro QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property MicroQrVersion As MicroQRVersion
C#
MicroQRVersion MicroQrVersion {get;}

Property Value

The version for Micro QR code as a GrapeCity.ActiveReports.BarCodes.MicroQRVersion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


NarrowBarWidth Property

[image]
ActiveReports 19 .NET Edition
NarrowBarWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : NarrowBarWidth Property

Glossary Item Box

Gets the narrow bar width of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property NarrowBarWidth As Length
C#
Length NarrowBarWidth {get;}

Property Value

The narrow bar width of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


NWRatio Property

[image]
ActiveReports 19 .NET Edition
NWRatio Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : NWRatio Property

Glossary Item Box

Gets the narrow-to-wide ratio of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property NWRatio As Single
C#
float NWRatio {get;}

Property Value

The narrow-to-wide ratio of the barcode as a System.Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Pdf417ErrorCorrectionLevel Property

[image]
ActiveReports 19 .NET Edition
Pdf417ErrorCorrectionLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Pdf417ErrorCorrectionLevel Property

Glossary Item Box

Gets the error correction level for PDF417.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pdf417ErrorCorrectionLevel As ErrorCorrectionLevel
C#
ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get;}

Property Value

The error correction level for PDF417 as a ErrorCorrectionLevel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Pdf417OptionsColumns Property

[image]
ActiveReports 19 .NET Edition
Pdf417OptionsColumns Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Pdf417OptionsColumns Property

Glossary Item Box

Gets the number of columns for PDF417 options.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pdf417OptionsColumns As Integer
C#
int Pdf417OptionsColumns {get;}

Property Value

The number of columns for PDF417 options as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Pdf417OptionsRows Property

[image]
ActiveReports 19 .NET Edition
Pdf417OptionsRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Pdf417OptionsRows Property

Glossary Item Box

Gets the number of rows for PDF417 options.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pdf417OptionsRows As Integer
C#
int Pdf417OptionsRows {get;}

Property Value

The number of rows for PDF417 options as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Pdf417OptionsType Property

[image]
ActiveReports 19 .NET Edition
Pdf417OptionsType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Pdf417OptionsType Property

Glossary Item Box

Gets the type of PDF417 options.

Syntax

Visual Basic (Declaration)
ReadOnly Property Pdf417OptionsType As Pdf417Type
C#
Pdf417Type Pdf417OptionsType {get;}

Property Value

The type of PDF417 options as a Pdf417Type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeConnection Property

[image]
ActiveReports 19 .NET Edition
QRCodeConnection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeConnection Property

Glossary Item Box

Gets a value indicating whether QR code connection is enabled.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeConnection As Boolean
C#
bool QRCodeConnection {get;}

Property Value

true if QR code connection is enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeConnectionNumber Property

[image]
ActiveReports 19 .NET Edition
QRCodeConnectionNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeConnectionNumber Property

Glossary Item Box

Gets the QR code connection number.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeConnectionNumber As Integer
C#
int QRCodeConnectionNumber {get;}

Property Value

The QR code connection number as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeEncoding Property

[image]
ActiveReports 19 .NET Edition
QRCodeEncoding Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeEncoding Property

Glossary Item Box

Gets the encoding for QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeEncoding As Encoding
C#
Encoding QRCodeEncoding {get;}

Property Value

The encoding for QR code as an System.Text.Encoding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeErrorLevel Property

[image]
ActiveReports 19 .NET Edition
QRCodeErrorLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeErrorLevel Property

Glossary Item Box

Gets the error level for QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeErrorLevel As QRCodeErrorLevel
C#
QRCodeErrorLevel QRCodeErrorLevel {get;}

Property Value

The error level for QR code as a QRCodeErrorLevel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeMask Property

[image]
ActiveReports 19 .NET Edition
QRCodeMask Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeMask Property

Glossary Item Box

Gets the mask for QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeMask As Mask
C#
Mask QRCodeMask {get;}

Property Value

The mask for QR code as a Mask.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeModel Property

[image]
ActiveReports 19 .NET Edition
QRCodeModel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeModel Property

Glossary Item Box

Gets the model for QR code.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeModel As Model
C#
Model QRCodeModel {get;}

Property Value

The model for QR code as a Model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QRCodeVersion Property

[image]
ActiveReports 19 .NET Edition
QRCodeVersion Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QRCodeVersion Property

Glossary Item Box

Gets the QR code version.

Syntax

Visual Basic (Declaration)
ReadOnly Property QRCodeVersion As Integer
C#
int QRCodeVersion {get;}

Property Value

The QR code version as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QuietZoneBottom Property

[image]
ActiveReports 19 .NET Edition
QuietZoneBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QuietZoneBottom Property

Glossary Item Box

Gets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property QuietZoneBottom As Length
C#
Length QuietZoneBottom {get;}

Property Value

The bottom quiet zone of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QuietZoneLeft Property

[image]
ActiveReports 19 .NET Edition
QuietZoneLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QuietZoneLeft Property

Glossary Item Box

Gets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property QuietZoneLeft As Length
C#
Length QuietZoneLeft {get;}

Property Value

The left quiet zone of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QuietZoneRight Property

[image]
ActiveReports 19 .NET Edition
QuietZoneRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QuietZoneRight Property

Glossary Item Box

Gets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property QuietZoneRight As Length
C#
Length QuietZoneRight {get;}

Property Value

The right quiet zone of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


QuietZoneTop Property

[image]
ActiveReports 19 .NET Edition
QuietZoneTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : QuietZoneTop Property

Glossary Item Box

Gets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property QuietZoneTop As Length
C#
Length QuietZoneTop {get;}

Property Value

The top quiet zone of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Rotation Property

[image]
ActiveReports 19 .NET Edition
Rotation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Rotation Property

Glossary Item Box

Gets the rotation of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Rotation As Rotation
C#
Rotation Rotation {get;}

Property Value

The rotation of the barcode as a Rotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


RssExpandedStackedRowCount Property

[image]
ActiveReports 19 .NET Edition
RssExpandedStackedRowCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : RssExpandedStackedRowCount Property

Glossary Item Box

Gets the row count for RSS expanded stacked barcodes.

Syntax

Visual Basic (Declaration)
ReadOnly Property RssExpandedStackedRowCount As Integer
C#
int RssExpandedStackedRowCount {get;}

Property Value

The row count for RSS expanded stacked barcodes as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


StyleEvaluator Property

[image]
ActiveReports 19 .NET Edition
StyleEvaluator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : StyleEvaluator Property

Glossary Item Box

Gets the style evaluator.

Syntax

Visual Basic (Declaration)
ReadOnly Property StyleEvaluator As IStyle
C#
IStyle StyleEvaluator {get;}

Property Value

The style evaluator as an GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


SupplementBarHeight Property

[image]
ActiveReports 19 .NET Edition
SupplementBarHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : SupplementBarHeight Property

Glossary Item Box

Gets the supplement bar height of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property SupplementBarHeight As Length
C#
Length SupplementBarHeight {get;}

Property Value

The supplement bar height of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


SupplementCaptionLocation Property

[image]
ActiveReports 19 .NET Edition
SupplementCaptionLocation Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : SupplementCaptionLocation Property

Glossary Item Box

Gets the location of the supplement caption.

Syntax

Visual Basic (Declaration)
ReadOnly Property SupplementCaptionLocation As BarCodeCaptionPosition
C#
BarCodeCaptionPosition SupplementCaptionLocation {get;}

Property Value

The location of the supplement caption as a GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeCaptionPosition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


SupplementSpacing Property

[image]
ActiveReports 19 .NET Edition
SupplementSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : SupplementSpacing Property

Glossary Item Box

Gets the supplement spacing of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property SupplementSpacing As Length
C#
Length SupplementSpacing {get;}

Property Value

The supplement spacing of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


SupplementValue Property

[image]
ActiveReports 19 .NET Edition
SupplementValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : SupplementValue Property

Glossary Item Box

Gets the supplement value of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property SupplementValue As Object
C#
object SupplementValue {get;}

Property Value

The supplement value of the barcode as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Symbology Property

[image]
ActiveReports 19 .NET Edition
Symbology Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Symbology Property

Glossary Item Box

Gets the barcode symbology.

Syntax

Visual Basic (Declaration)
ReadOnly Property Symbology As BarCodeStyle
C#
BarCodeStyle Symbology {get;}

Property Value

The barcode symbology as a GrapeCity.ActiveReports.Extensibility.Rendering.Components.Barcode.BarCodeStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Top Property

[image]
ActiveReports 19 .NET Edition
Top Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Top Property

Glossary Item Box

Gets the top position of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Top As Length
C#
Length Top {get;}

Property Value

The top position of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Value Property

Glossary Item Box

Gets the value of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Object
C#
object Value {get;}

Property Value

The value of the barcode as an System.Object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


Width Property

[image]
ActiveReports 19 .NET Edition
Width Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Barcode Namespace > IBarcodeReportItem Interface : Width Property

Glossary Item Box

Gets the width of the barcode.

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Length
C#
Length Width {get;}

Property Value

The width of the barcode as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBarcodeReportItem Interface
IBarcodeReportItem Members


BulletChartConstants Class

[image]
ActiveReports 19 .NET Edition
BulletChartConstants Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : BulletChartConstants Class

Glossary Item Box

Represents constant values for Bullet Chart properties.

Object Model

BulletChartConstants Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class BulletChartConstants
C#
public static class BulletChartConstants

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Bullet.BulletChartConstants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Members
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


BulletChartConstants Class Members

[image]
ActiveReports 19 .NET Edition
BulletChartConstants Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : BulletChartConstants Class

Glossary Item Box

The following tables list the members exposed by BulletChartConstants.

Public Fields

 | Name | Description
Public Field | BackgroundColorPropertyName |
Public Field | BulletChartPrefix |
Public Field | BulletTypePropertyName |
Public Field | IntervalPropertyName |
Public Field | LabelFormatPropertyName |
Public Field | LabelsPropertyName |
Public Field | MarkerShapePropertyName |
Public Field | MarkerValuePropertyName |
Public Field | MaxPropertyName |
Public Field | MinPropertyName |
Public Field | RangesPropertyName |
Public Field | ShowLabelsPropertyName |
Public Field | TickMarksPropertyName |
Public Field | TicksPropertyName |
Public Field | ValueColorPropertyName |
Public Field | ValuePropertyName |
Top

See Also

Reference

BulletChartConstants Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


BulletChartConstants Class Fields

[image]
ActiveReports 19 .NET Edition
BulletChartConstants Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : BulletChartConstants Class

Glossary Item Box

For a list of all members of this type, see BulletChartConstants members.

Public Fields

 | Name | Description
Public Field | BackgroundColorPropertyName |
Public Field | BulletChartPrefix |
Public Field | BulletTypePropertyName |
Public Field | IntervalPropertyName |
Public Field | LabelFormatPropertyName |
Public Field | LabelsPropertyName |
Public Field | MarkerShapePropertyName |
Public Field | MarkerValuePropertyName |
Public Field | MaxPropertyName |
Public Field | MinPropertyName |
Public Field | RangesPropertyName |
Public Field | ShowLabelsPropertyName |
Public Field | TickMarksPropertyName |
Public Field | TicksPropertyName |
Public Field | ValueColorPropertyName |
Public Field | ValuePropertyName |
Top

See Also

Reference

BulletChartConstants Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


BackgroundColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
BackgroundColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : BackgroundColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BackgroundColorPropertyName As String
C#
public const string BackgroundColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


BulletChartPrefix Field

[image]
ActiveReports 19 .NET Edition
BulletChartPrefix Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : BulletChartPrefix Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BulletChartPrefix As String
C#
public const string BulletChartPrefix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


BulletTypePropertyName Field

[image]
ActiveReports 19 .NET Edition
BulletTypePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : BulletTypePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BulletTypePropertyName As String
C#
public const string BulletTypePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


IntervalPropertyName Field

[image]
ActiveReports 19 .NET Edition
IntervalPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : IntervalPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const IntervalPropertyName As String
C#
public const string IntervalPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


LabelFormatPropertyName Field

[image]
ActiveReports 19 .NET Edition
LabelFormatPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : LabelFormatPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LabelFormatPropertyName As String
C#
public const string LabelFormatPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


LabelsPropertyName Field

[image]
ActiveReports 19 .NET Edition
LabelsPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : LabelsPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LabelsPropertyName As String
C#
public const string LabelsPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


MarkerShapePropertyName Field

[image]
ActiveReports 19 .NET Edition
MarkerShapePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : MarkerShapePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MarkerShapePropertyName As String
C#
public const string MarkerShapePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


MarkerValuePropertyName Field

[image]
ActiveReports 19 .NET Edition
MarkerValuePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : MarkerValuePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MarkerValuePropertyName As String
C#
public const string MarkerValuePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


MaxPropertyName Field

[image]
ActiveReports 19 .NET Edition
MaxPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : MaxPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MaxPropertyName As String
C#
public const string MaxPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


MinPropertyName Field

[image]
ActiveReports 19 .NET Edition
MinPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : MinPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MinPropertyName As String
C#
public const string MinPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


RangesPropertyName Field

[image]
ActiveReports 19 .NET Edition
RangesPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : RangesPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RangesPropertyName As String
C#
public const string RangesPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


ShowLabelsPropertyName Field

[image]
ActiveReports 19 .NET Edition
ShowLabelsPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : ShowLabelsPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ShowLabelsPropertyName As String
C#
public const string ShowLabelsPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


TickMarksPropertyName Field

[image]
ActiveReports 19 .NET Edition
TickMarksPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : TickMarksPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const TickMarksPropertyName As String
C#
public const string TickMarksPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


TicksPropertyName Field

[image]
ActiveReports 19 .NET Edition
TicksPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : TicksPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const TicksPropertyName As String
C#
public const string TicksPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


ValueColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
ValueColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : ValueColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ValueColorPropertyName As String
C#
public const string ValueColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


ValuePropertyName Field

[image]
ActiveReports 19 .NET Edition
ValuePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > BulletChartConstants Class : ValuePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ValuePropertyName As String
C#
public const string ValuePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BulletChartConstants Class
BulletChartConstants Members


Range Class

[image]
ActiveReports 19 .NET Edition
Range Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : Range Class

Glossary Item Box

Represents a qualitative range for BulletChart.

Object Model

Range Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Range
C#
public sealed class Range

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Bullet.Range

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Members
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


Range Class Members

[image]
ActiveReports 19 .NET Edition
Range Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : Range Class

Glossary Item Box

The following tables list the members exposed by Range.

Public Constructors

 | Name | Description
Public Constructor | Range Constructor | Initializes a new instance of the Range class with the specified boundary value and fill style.
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle to draw the range.
Public Property | BoundValue | Gets the ending bound.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


Range Constructor

[image]
ActiveReports 19 .NET Edition
Range Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > Range Class : Range Constructor

boundValue
The boundary value of the range.
fillStyle
The fill style used to draw the range.

Glossary Item Box

Initializes a new instance of the Range class with the specified boundary value and fill style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal boundValue As Double, _
   ByVal fillStyle As FillStyle _
)
C#
public Range(
   double boundValue,
   FillStyle fillStyle
)

Parameters

boundValue
The boundary value of the range.
fillStyle
The fill style used to draw the range.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when fillStyle is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Range Class Properties

[image]
ActiveReports 19 .NET Edition
Range Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : Range Class

Glossary Item Box

For a list of all members of this type, see Range members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle to draw the range.
Public Property | BoundValue | Gets the ending bound.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > Range Class : Backdrop Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle to draw the range.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Backdrop As FillStyle
C#
public FillStyle Backdrop {get;}

Property Value

The fill style used to draw the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


BoundValue Property

[image]
ActiveReports 19 .NET Edition
BoundValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > Range Class : BoundValue Property

Glossary Item Box

Gets the ending bound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundValue As Double
C#
public double BoundValue {get;}

Property Value

The boundary value of the range as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


RangeCollection Class

[image]
ActiveReports 19 .NET Edition
RangeCollection Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : RangeCollection Class

Glossary Item Box

Represents a collection of the Range objects for BulletChart.

Object Model

RangeCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RangeCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class RangeCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Rendering.Components.Bullet.RangeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Members
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


RangeCollection Class Members

[image]
ActiveReports 19 .NET Edition
RangeCollection Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : RangeCollection Class

Glossary Item Box

The following tables list the members exposed by RangeCollection.

Public Constructors

 | Name | Description
Public Constructor | RangeCollection Constructor |
Top

Public Fields

 | Name | Description
Public Field | BoundValuePropertyName |
Public Field | CountPropertyName |
Top

Public Properties

 | Name | Description
Public Property | Item | Gets the Range at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the Range to the collection.
static (Shared in Visual Basic) | Parse | Collects range collection from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag.
Top

See Also

Reference

RangeCollection Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


RangeCollection Constructor

[image]
ActiveReports 19 .NET Edition
RangeCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : RangeCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RangeCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


RangeCollection Class Methods

[image]
ActiveReports 19 .NET Edition
RangeCollection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : RangeCollection Class

Glossary Item Box

For a list of all members of this type, see RangeCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the Range to the collection.
static (Shared in Visual Basic) | Parse | Collects range collection from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag.
Top

See Also

Reference

RangeCollection Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : Add Method

range

Glossary Item Box

Adds the Range to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal range As Range _
)
C#
public void Add(
   Range range
)

Parameters

range

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


Parse Method

[image]
ActiveReports 19 .NET Edition
Parse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : Parse Method

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of collection

Glossary Item Box

Collects range collection from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal properties As IPropertyBag, _
   ByVal substitution As String _
) As RangeCollection
C#
public static RangeCollection Parse(
   IPropertyBag properties,
   string substitution
)

Parameters

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


RangeCollection Class Properties

[image]
ActiveReports 19 .NET Edition
RangeCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : RangeCollection Class

Glossary Item Box

For a list of all members of this type, see RangeCollection members.

Public Properties

 | Name | Description
Public Property | Item | Gets the Range at the specified index.
Top

See Also

Reference

RangeCollection Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : Item Property

index

Glossary Item Box

Gets the Range at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Range
C#
public Range this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


RangeCollection Class Fields

[image]
ActiveReports 19 .NET Edition
RangeCollection Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : RangeCollection Class

Glossary Item Box

For a list of all members of this type, see RangeCollection members.

Public Fields

 | Name | Description
Public Field | BoundValuePropertyName |
Public Field | CountPropertyName |
Top

See Also

Reference

RangeCollection Class
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


BoundValuePropertyName Field

[image]
ActiveReports 19 .NET Edition
BoundValuePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : BoundValuePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BoundValuePropertyName As String
C#
public const string BoundValuePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


CountPropertyName Field

[image]
ActiveReports 19 .NET Edition
CountPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > RangeCollection Class : CountPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const CountPropertyName As String
C#
public const string CountPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RangeCollection Class
RangeCollection Members


BulletType Enumeration

[image]
ActiveReports 19 .NET Edition
BulletType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : BulletType Enumeration

Glossary Item Box

Specifies the type of a bullet chart.

Syntax

Visual Basic (Declaration)
Public Enum BulletType
   Inherits System.Enum
C#
public enum BulletType : System.Enum

Members

Member | Description
Horizontal | A horizontal bullet chart.
Vertical | A vertical bullet chart.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Bullet.BulletType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


MarkerShape Enumeration

[image]
ActiveReports 19 .NET Edition
MarkerShape Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : MarkerShape Enumeration

Glossary Item Box

Specifies the marker shape to use in a bullet chart.

Syntax

Visual Basic (Declaration)
Public Enum MarkerShape
   Inherits System.Enum
C#
public enum MarkerShape : System.Enum

Members

Member | Description
Dot | Specifies a dot marker.
Line | Specifies a line marker.
Square | Specifies a square marker.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Bullet.MarkerShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


TickMark Enumeration

[image]
ActiveReports 19 .NET Edition
TickMark Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : TickMark Enumeration

Glossary Item Box

Specifies the kind of tick marks in a bullet chart.

Syntax

Visual Basic (Declaration)
Public Enum TickMark
   Inherits System.Enum
C#
public enum TickMark : System.Enum

Members

Member | Description
Inside | Specifies tick marks inside the chart area.
None | Specifies no tick marks.
Outside | Specifies tick marks outside the chart area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Bullet.TickMark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


IBulletChart Interface

[image]
ActiveReports 19 .NET Edition
IBulletChart Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : IBulletChart Interface

Glossary Item Box

Represented the boilerplate of a bullet chart.

Syntax

Visual Basic (Declaration)
Public Interface IBulletChart
C#
public interface IBulletChart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Members
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


IBulletChart Interface Members

[image]
ActiveReports 19 .NET Edition
IBulletChart Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : IBulletChart Interface

Glossary Item Box

The following tables list the members exposed by IBulletChart.

Public Properties

 | Name | Description
Property | BackgroundColor | Gets the color used to paint the background.
Property | BulletType | Gets the bullet chart type.
Property | HasValue | Gets a value indicating whether the bullet chart has a value.
Property | Interval | Gets the interval of the quantitative scale.
Property | LabelFormat | Gets the format code to use for labels.
Property | LabelStyle | Gets the style of the labels.
Property | MarkerShape | Gets the shape of the performance measure marker.
Property | MarkerStyle | Gets the style of the marker.
Property | MarkerValue | Gets the value of a comparative measure.
Property | Max | Gets the maximum value of the quantitative scale.
Property | Min | Gets the minimum value of the quantitative scale.
Property | Ranges | Gets the qualitative ranges.
Property | ShowLabels | Gets a value indicating whether to show labels.
Property | TickLineStyle | Gets the style of the ticks.
Property | TickMark | Gets the tick mark style.
Property | Value | Gets the value of the performance measure.
Property | ValueColor | Gets the color used to paint the performance measure marker.
Top

See Also

Reference

IBulletChart Interface
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


IBulletChart Interface Properties

[image]
ActiveReports 19 .NET Edition
IBulletChart Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace : IBulletChart Interface

Glossary Item Box

For a list of all members of this type, see IBulletChart members.

Public Properties

 | Name | Description
Property | BackgroundColor | Gets the color used to paint the background.
Property | BulletType | Gets the bullet chart type.
Property | HasValue | Gets a value indicating whether the bullet chart has a value.
Property | Interval | Gets the interval of the quantitative scale.
Property | LabelFormat | Gets the format code to use for labels.
Property | LabelStyle | Gets the style of the labels.
Property | MarkerShape | Gets the shape of the performance measure marker.
Property | MarkerStyle | Gets the style of the marker.
Property | MarkerValue | Gets the value of a comparative measure.
Property | Max | Gets the maximum value of the quantitative scale.
Property | Min | Gets the minimum value of the quantitative scale.
Property | Ranges | Gets the qualitative ranges.
Property | ShowLabels | Gets a value indicating whether to show labels.
Property | TickLineStyle | Gets the style of the ticks.
Property | TickMark | Gets the tick mark style.
Property | Value | Gets the value of the performance measure.
Property | ValueColor | Gets the color used to paint the performance measure marker.
Top

See Also

Reference

IBulletChart Interface
GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : BackgroundColor Property

Glossary Item Box

Gets the color used to paint the background.

Syntax

Visual Basic (Declaration)
ReadOnly Property BackgroundColor As Color
C#
Color BackgroundColor {get;}

Property Value

The background color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


BulletType Property

[image]
ActiveReports 19 .NET Edition
BulletType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : BulletType Property

Glossary Item Box

Gets the bullet chart type.

Syntax

Visual Basic (Declaration)
ReadOnly Property BulletType As BulletType
C#
BulletType BulletType {get;}

Property Value

The type of the bullet chart as a BulletType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


HasValue Property

[image]
ActiveReports 19 .NET Edition
HasValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : HasValue Property

Glossary Item Box

Gets a value indicating whether the bullet chart has a value.

Syntax

Visual Basic (Declaration)
ReadOnly Property HasValue As Boolean
C#
bool HasValue {get;}

Property Value

true if the bullet chart has a value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


Interval Property

[image]
ActiveReports 19 .NET Edition
Interval Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : Interval Property

Glossary Item Box

Gets the interval of the quantitative scale.

Syntax

Visual Basic (Declaration)
ReadOnly Property Interval As Nullable(Of Double)
C#
Nullable<double> Interval {get;}

Property Value

The interval value as a Nullable of System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


LabelFormat Property

[image]
ActiveReports 19 .NET Edition
LabelFormat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : LabelFormat Property

Glossary Item Box

Gets the format code to use for labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelFormat As String
C#
string LabelFormat {get;}

Property Value

The label format code as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


LabelStyle Property

[image]
ActiveReports 19 .NET Edition
LabelStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : LabelStyle Property

Glossary Item Box

Gets the style of the labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property LabelStyle As TextStyle
C#
TextStyle LabelStyle {get;}

Property Value

The label style as a GrapeCity.ActiveReports.Rendering.Components.Dashboard.TextStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


MarkerShape Property

[image]
ActiveReports 19 .NET Edition
MarkerShape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : MarkerShape Property

Glossary Item Box

Gets the shape of the performance measure marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerShape As MarkerShape
C#
MarkerShape MarkerShape {get;}

Property Value

The marker shape as a MarkerShape.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


MarkerStyle Property

[image]
ActiveReports 19 .NET Edition
MarkerStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : MarkerStyle Property

Glossary Item Box

Gets the style of the marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerStyle As LineStyle
C#
LineStyle MarkerStyle {get;}

Property Value

The marker style as a GrapeCity.ActiveReports.Rendering.Components.Dashboard.LineStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


MarkerValue Property

[image]
ActiveReports 19 .NET Edition
MarkerValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : MarkerValue Property

Glossary Item Box

Gets the value of a comparative measure.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerValue As Nullable(Of Double)
C#
Nullable<double> MarkerValue {get;}

Property Value

The comparative measure value as a Nullable of System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


Max Property

[image]
ActiveReports 19 .NET Edition
Max Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : Max Property

Glossary Item Box

Gets the maximum value of the quantitative scale.

Syntax

Visual Basic (Declaration)
ReadOnly Property Max As Nullable(Of Double)
C#
Nullable<double> Max {get;}

Property Value

The maximum value as a Nullable of System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


Min Property

[image]
ActiveReports 19 .NET Edition
Min Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : Min Property

Glossary Item Box

Gets the minimum value of the quantitative scale.

Syntax

Visual Basic (Declaration)
ReadOnly Property Min As Nullable(Of Double)
C#
Nullable<double> Min {get;}

Property Value

The minimum value as a Nullable of System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


Ranges Property

[image]
ActiveReports 19 .NET Edition
Ranges Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : Ranges Property

Glossary Item Box

Gets the qualitative ranges.

Syntax

Visual Basic (Declaration)
ReadOnly Property Ranges As RangeCollection
C#
RangeCollection Ranges {get;}

Property Value

The qualitative ranges as a RangeCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


ShowLabels Property

[image]
ActiveReports 19 .NET Edition
ShowLabels Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : ShowLabels Property

Glossary Item Box

Gets a value indicating whether to show labels.

Syntax

Visual Basic (Declaration)
ReadOnly Property ShowLabels As Boolean
C#
bool ShowLabels {get;}

Property Value

true if labels should be shown; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


TickLineStyle Property

[image]
ActiveReports 19 .NET Edition
TickLineStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : TickLineStyle Property

Glossary Item Box

Gets the style of the ticks.

Syntax

Visual Basic (Declaration)
ReadOnly Property TickLineStyle As LineStyle
C#
LineStyle TickLineStyle {get;}

Property Value

The tick line style as a GrapeCity.ActiveReports.Rendering.Components.Dashboard.LineStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


TickMark Property

[image]
ActiveReports 19 .NET Edition
TickMark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : TickMark Property

Glossary Item Box

Gets the tick mark style.

Syntax

Visual Basic (Declaration)
ReadOnly Property TickMark As TickMark
C#
TickMark TickMark {get;}

Property Value

The tick mark style as a TickMark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


Value Property

[image]
ActiveReports 19 .NET Edition
Value Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : Value Property

Glossary Item Box

Gets the value of the performance measure.

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Double
C#
double Value {get;}

Property Value

The performance measure value as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


ValueColor Property

[image]
ActiveReports 19 .NET Edition
ValueColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Bullet Namespace > IBulletChart Interface : ValueColor Property

Glossary Item Box

Gets the color used to paint the performance measure marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property ValueColor As Color
C#
Color ValueColor {get;}

Property Value

The value color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBulletChart Interface
IBulletChart Members


LegendDefaultsInfo Class

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo Class

Glossary Item Box

Used for receiving default legend settings if UseSmartSettings option in Legend instance is true.

Object Model

LegendDefaultsInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LegendDefaultsInfo
C#
public sealed class LegendDefaultsInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Chart.LegendDefaultsInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo Members
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


LegendDefaultsInfo Class Members

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo Class

Glossary Item Box

The following tables list the members exposed by LegendDefaultsInfo.

Public Properties

 | Name | Description
Public Property | Item | Returned description of legend default settings.
static (Shared in Visual Basic) | Items | Returned static instance of LegendDefaultsInfo.
Top

See Also

Reference

LegendDefaultsInfo Class
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


LegendDefaultsInfo Class Properties

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo Class

Glossary Item Box

For a list of all members of this type, see LegendDefaultsInfo members.

Public Properties

 | Name | Description
Public Property | Item | Returned description of legend default settings.
static (Shared in Visual Basic) | Items | Returned static instance of LegendDefaultsInfo.
Top

See Also

Reference

LegendDefaultsInfo Class
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > LegendDefaultsInfo Class : Item Property

chartType
Type of chart for determining of appropriate legend settings.

Glossary Item Box

Returned description of legend default settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal chartType As ChartType _
) As LegendDefaultsInfo.LegendDefault
C#
public LegendDefaultsInfo.LegendDefault this[
   ChartType chartType
]; {get;}

Parameters

chartType
Type of chart for determining of appropriate legend settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo Class
LegendDefaultsInfo Members


Items Property

[image]
ActiveReports 19 .NET Edition
Items Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > LegendDefaultsInfo Class : Items Property

Glossary Item Box

Returned static instance of LegendDefaultsInfo.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Items As LegendDefaultsInfo
C#
public static LegendDefaultsInfo Items {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo Class
LegendDefaultsInfo Members


StubChartRenderer.DesignStyle Class

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : StubChartRenderer.DesignStyle Class

Glossary Item Box

Object Model

StubChartRenderer.DesignStyle Class

Syntax

Visual Basic (Declaration)
Public Class StubChartRenderer.DesignStyle
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle
C#
public class StubChartRenderer.DesignStyle : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Chart.StubChartRenderer.DesignStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Members
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


StubChartRenderer.DesignStyle Class Members

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : StubChartRenderer.DesignStyle Class

Glossary Item Box

The following tables list the members exposed by StubChartRenderer.DesignStyle.

Public Constructors

 | Name | Description
Public Constructor | StubChartRenderer.DesignStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BackgroundColor |
Public Property | BackgroundGradientEndColor |
Public Property | BackgroundGradientType |
Public Property | BackgroundImage |
Public Property | BackgroundImageMimeType |
Public Property | BackgroundImageSource |
Public Property | BackgroundImageValue |
Public Property | BackgroundRepeat |
Public Property | BottomBorderColor |
Public Property | BottomBorderStyle |
Public Property | BottomBorderWidth |
Public Property | Calendar |
Public Property | CharacterSpacing |
Public Property | Color |
Public Property | DefaultBorderColor |
Public Property | DefaultBorderStyle |
Public Property | DefaultBorderWidth |
Public Property | Direction |
Public Property | DisplayPageNumber |
Public Property | FontFamily |
Public Property | FontSize |
Public Property | FontStyle |
Public Property | FontWeight |
Public Property | Format |
Public Property | HeadingLevel |
Public Property | LabelExpression |
Public Property | Language |
Public Property | LeadingChar |
Public Property | LeftBorderColor |
Public Property | LeftBorderStyle |
Public Property | LeftBorderWidth |
Public Property | LineHeight |
Public Property | LineSpacing |
Public Property | MaxLevel |
Public Property | MinCondenseRate |
Public Property | NumeralLanguage |
Public Property | NumeralVariant |
Public Property | PaddingBottom |
Public Property | PaddingLeft |
Public Property | PaddingRight |
Public Property | PaddingTop |
Public Property | RightBorderColor |
Public Property | RightBorderStyle |
Public Property | RightBorderWidth |
Public Property | ShadowOffset |
Public Property | ShrinkToFit |
Public Property | TextAlign |
Public Property | TextDecoration |
Public Property | TextIndent |
Public Property | TextJustify |
Public Property | TopBorderColor |
Public Property | TopBorderStyle |
Public Property | TopBorderWidth |
Public Property | VerticalAlign |
Public Property | WrapMode |
Public Property | WritingMode |
Top

See Also

Reference

StubChartRenderer.DesignStyle Class
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


StubChartRenderer.DesignStyle Constructor

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : StubChartRenderer.DesignStyle Constructor

Glossary Item Box

Overload List

Overload | Description
StubChartRenderer.DesignStyle Constructor(Style,IExpressionEvaluatorService) |
StubChartRenderer.DesignStyle Constructor(Style,IStyleSheetService,IExpressionEvaluatorService) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


StubChartRenderer.DesignStyle Constructor(Style,IExpressionEvaluatorService)

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Constructor(Style,IExpressionEvaluatorService)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class > StubChartRenderer.DesignStyle Constructor : StubChartRenderer.DesignStyle Constructor(Style,IExpressionEvaluatorService)

style
evaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style, _
   ByVal evaluator As IExpressionEvaluatorService _
)
C#
public StubChartRenderer.DesignStyle(
   Style style,
   IExpressionEvaluatorService evaluator
)

Parameters

style
evaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members
Overload List


StubChartRenderer.DesignStyle Constructor(Style,IStyleSheetService,IExpressionEvaluatorService)

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Constructor(Style,IStyleSheetService,IExpressionEvaluatorService)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class > StubChartRenderer.DesignStyle Constructor : StubChartRenderer.DesignStyle Constructor(Style,IStyleSheetService,IExpressionEvaluatorService)

style
styleSheetService
evaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style, _
   ByVal styleSheetService As IStyleSheetService, _
   ByVal evaluator As IExpressionEvaluatorService _
)
C#
public StubChartRenderer.DesignStyle(
   Style style,
   IStyleSheetService styleSheetService,
   IExpressionEvaluatorService evaluator
)

Parameters

style
styleSheetService
evaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members
Overload List


StubChartRenderer.DesignStyle Class Properties

[image]
ActiveReports 19 .NET Edition
StubChartRenderer.DesignStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : StubChartRenderer.DesignStyle Class

Glossary Item Box

For a list of all members of this type, see StubChartRenderer.DesignStyle members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BackgroundColor |
Public Property | BackgroundGradientEndColor |
Public Property | BackgroundGradientType |
Public Property | BackgroundImage |
Public Property | BackgroundImageMimeType |
Public Property | BackgroundImageSource |
Public Property | BackgroundImageValue |
Public Property | BackgroundRepeat |
Public Property | BottomBorderColor |
Public Property | BottomBorderStyle |
Public Property | BottomBorderWidth |
Public Property | Calendar |
Public Property | CharacterSpacing |
Public Property | Color |
Public Property | DefaultBorderColor |
Public Property | DefaultBorderStyle |
Public Property | DefaultBorderWidth |
Public Property | Direction |
Public Property | DisplayPageNumber |
Public Property | FontFamily |
Public Property | FontSize |
Public Property | FontStyle |
Public Property | FontWeight |
Public Property | Format |
Public Property | HeadingLevel |
Public Property | LabelExpression |
Public Property | Language |
Public Property | LeadingChar |
Public Property | LeftBorderColor |
Public Property | LeftBorderStyle |
Public Property | LeftBorderWidth |
Public Property | LineHeight |
Public Property | LineSpacing |
Public Property | MaxLevel |
Public Property | MinCondenseRate |
Public Property | NumeralLanguage |
Public Property | NumeralVariant |
Public Property | PaddingBottom |
Public Property | PaddingLeft |
Public Property | PaddingRight |
Public Property | PaddingTop |
Public Property | RightBorderColor |
Public Property | RightBorderStyle |
Public Property | RightBorderWidth |
Public Property | ShadowOffset |
Public Property | ShrinkToFit |
Public Property | TextAlign |
Public Property | TextDecoration |
Public Property | TextIndent |
Public Property | TextJustify |
Public Property | TopBorderColor |
Public Property | TopBorderStyle |
Public Property | TopBorderWidth |
Public Property | VerticalAlign |
Public Property | WrapMode |
Public Property | WritingMode |
Top

See Also

Reference

StubChartRenderer.DesignStyle Class
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


Angle Property

[image]
ActiveReports 19 .NET Edition
Angle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Angle As Single
C#
public float Angle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundColor As String
C#
public string BackgroundColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundGradientEndColor Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundGradientEndColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundGradientEndColor As String
C#
public string BackgroundGradientEndColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundGradientType Property

[image]
ActiveReports 19 .NET Edition
BackgroundGradientType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundGradientType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundGradientType As String
C#
public string BackgroundGradientType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundImage Property

[image]
ActiveReports 19 .NET Edition
BackgroundImage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Stream
C#
public Stream BackgroundImage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundImageMimeType Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageMimeType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundImageMimeType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageMimeType As String
C#
public string BackgroundImageMimeType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundImageSource Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageSource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundImageSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageSource As ImageSource
C#
public ImageSource BackgroundImageSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundImageValue Property

[image]
ActiveReports 19 .NET Edition
BackgroundImageValue Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundImageValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageValue As Object
C#
public object BackgroundImageValue {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BackgroundRepeat Property

[image]
ActiveReports 19 .NET Edition
BackgroundRepeat Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BackgroundRepeat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BackgroundRepeat As String
C#
public string BackgroundRepeat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BottomBorderColor Property

[image]
ActiveReports 19 .NET Edition
BottomBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BottomBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BottomBorderColor As String
C#
public string BottomBorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BottomBorderStyle Property

[image]
ActiveReports 19 .NET Edition
BottomBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BottomBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BottomBorderStyle As String
C#
public string BottomBorderStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


BottomBorderWidth Property

[image]
ActiveReports 19 .NET Edition
BottomBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : BottomBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BottomBorderWidth As Length
C#
public Length BottomBorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


Calendar Property

[image]
ActiveReports 19 .NET Edition
Calendar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Calendar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Calendar As String
C#
public string Calendar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


CharacterSpacing Property

[image]
ActiveReports 19 .NET Edition
CharacterSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : CharacterSpacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CharacterSpacing As Length
C#
public Length CharacterSpacing {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


Color Property

[image]
ActiveReports 19 .NET Edition
Color Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Color As String
C#
public string Color {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


DefaultBorderColor Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : DefaultBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DefaultBorderColor As String
C#
public virtual string DefaultBorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


DefaultBorderStyle Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : DefaultBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultBorderStyle As String
C#
public string DefaultBorderStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


DefaultBorderWidth Property

[image]
ActiveReports 19 .NET Edition
DefaultBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : DefaultBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultBorderWidth As Length
C#
public Length DefaultBorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


Direction Property

[image]
ActiveReports 19 .NET Edition
Direction Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Direction As String
C#
public string Direction {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


DisplayPageNumber Property

[image]
ActiveReports 19 .NET Edition
DisplayPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : DisplayPageNumber Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayPageNumber As Boolean
C#
public bool DisplayPageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : FontFamily Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontFamily As String
C#
public string FontFamily {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : FontSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontSize As Length
C#
public Length FontSize {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : FontStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontStyle As String
C#
public string FontStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


FontWeight Property

[image]
ActiveReports 19 .NET Edition
FontWeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : FontWeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontWeight As String
C#
public string FontWeight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


Format Property

[image]
ActiveReports 19 .NET Edition
Format Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Format Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


HeadingLevel Property

[image]
ActiveReports 19 .NET Edition
HeadingLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : HeadingLevel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HeadingLevel As Integer
C#
public int HeadingLevel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LabelExpression Property

[image]
ActiveReports 19 .NET Edition
LabelExpression Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LabelExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LabelExpression As String
C#
public string LabelExpression {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


Language Property

[image]
ActiveReports 19 .NET Edition
Language Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : Language Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LeadingChar Property

[image]
ActiveReports 19 .NET Edition
LeadingChar Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LeadingChar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeadingChar As String
C#
public string LeadingChar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LeftBorderColor Property

[image]
ActiveReports 19 .NET Edition
LeftBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LeftBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftBorderColor As String
C#
public string LeftBorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LeftBorderStyle Property

[image]
ActiveReports 19 .NET Edition
LeftBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LeftBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftBorderStyle As String
C#
public string LeftBorderStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LeftBorderWidth Property

[image]
ActiveReports 19 .NET Edition
LeftBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LeftBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftBorderWidth As Length
C#
public Length LeftBorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LineHeight Property

[image]
ActiveReports 19 .NET Edition
LineHeight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LineHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LineHeight As Length
C#
public Length LineHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LineSpacing Property

[image]
ActiveReports 19 .NET Edition
LineSpacing Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : LineSpacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Length
C#
public Length LineSpacing {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


MaxLevel Property

[image]
ActiveReports 19 .NET Edition
MaxLevel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : MaxLevel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLevel As Integer
C#
public int MaxLevel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


MinCondenseRate Property

[image]
ActiveReports 19 .NET Edition
MinCondenseRate Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : MinCondenseRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinCondenseRate As Integer
C#
public int MinCondenseRate {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


NumeralLanguage Property

[image]
ActiveReports 19 .NET Edition
NumeralLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : NumeralLanguage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NumeralLanguage As String
C#
public string NumeralLanguage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


NumeralVariant Property

[image]
ActiveReports 19 .NET Edition
NumeralVariant Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : NumeralVariant Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NumeralVariant As Integer
C#
public int NumeralVariant {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


PaddingBottom Property

[image]
ActiveReports 19 .NET Edition
PaddingBottom Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : PaddingBottom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PaddingBottom As Length
C#
public Length PaddingBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


PaddingLeft Property

[image]
ActiveReports 19 .NET Edition
PaddingLeft Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : PaddingLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PaddingLeft As Length
C#
public Length PaddingLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


PaddingRight Property

[image]
ActiveReports 19 .NET Edition
PaddingRight Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : PaddingRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PaddingRight As Length
C#
public Length PaddingRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


PaddingTop Property

[image]
ActiveReports 19 .NET Edition
PaddingTop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : PaddingTop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PaddingTop As Length
C#
public Length PaddingTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


RightBorderColor Property

[image]
ActiveReports 19 .NET Edition
RightBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : RightBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightBorderColor As String
C#
public string RightBorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


RightBorderStyle Property

[image]
ActiveReports 19 .NET Edition
RightBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : RightBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightBorderStyle As String
C#
public string RightBorderStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


RightBorderWidth Property

[image]
ActiveReports 19 .NET Edition
RightBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : RightBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightBorderWidth As Length
C#
public Length RightBorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


ShadowOffset Property

[image]
ActiveReports 19 .NET Edition
ShadowOffset Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : ShadowOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShadowOffset As Length
C#
public Length ShadowOffset {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


ShrinkToFit Property

[image]
ActiveReports 19 .NET Edition
ShrinkToFit Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : ShrinkToFit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TextAlign Property

[image]
ActiveReports 19 .NET Edition
TextAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TextAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextAlign As String
C#
public string TextAlign {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TextDecoration Property

[image]
ActiveReports 19 .NET Edition
TextDecoration Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TextDecoration Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextDecoration As String
C#
public string TextDecoration {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TextIndent Property

[image]
ActiveReports 19 .NET Edition
TextIndent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TextIndent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextIndent As Length
C#
public Length TextIndent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TextJustify Property

[image]
ActiveReports 19 .NET Edition
TextJustify Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TextJustify Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextJustify As String
C#
public string TextJustify {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TopBorderColor Property

[image]
ActiveReports 19 .NET Edition
TopBorderColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TopBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopBorderColor As String
C#
public string TopBorderColor {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TopBorderStyle Property

[image]
ActiveReports 19 .NET Edition
TopBorderStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TopBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopBorderStyle As String
C#
public string TopBorderStyle {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


TopBorderWidth Property

[image]
ActiveReports 19 .NET Edition
TopBorderWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : TopBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopBorderWidth As Length
C#
public Length TopBorderWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


VerticalAlign Property

[image]
ActiveReports 19 .NET Edition
VerticalAlign Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : VerticalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalAlign As String
C#
public string VerticalAlign {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


WrapMode Property

[image]
ActiveReports 19 .NET Edition
WrapMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : WrapMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WrapMode As String
C#
public string WrapMode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


WritingMode Property

[image]
ActiveReports 19 .NET Edition
WritingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > StubChartRenderer.DesignStyle Class : WritingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WritingMode As String
C#
public string WritingMode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StubChartRenderer.DesignStyle Class
StubChartRenderer.DesignStyle Members


LegendDefaultsInfo.LegendDefault Structure

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo.LegendDefault Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo.LegendDefault Structure

Glossary Item Box

Represented legend default settings.

Object Model

LegendDefaultsInfo.LegendDefault Structure

Syntax

Visual Basic (Declaration)
Public Structure LegendDefaultsInfo.LegendDefault
   Inherits System.ValueType
C#
public struct LegendDefaultsInfo.LegendDefault : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Components.Chart.LegendDefaultsInfo.LegendDefault

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo.LegendDefault Members
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


LegendDefaultsInfo.LegendDefault Structure Members

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo.LegendDefault Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo.LegendDefault Structure

Glossary Item Box

The following tables list the members exposed by LegendDefaultsInfo.LegendDefault.

Public Fields

 | Name | Description
Public Field | Layout |
Public Field | Position |
Public Field | UseDataPointSeries |
Top

See Also

Reference

LegendDefaultsInfo.LegendDefault Structure
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


LegendDefaultsInfo.LegendDefault Structure Fields

[image]
ActiveReports 19 .NET Edition
LegendDefaultsInfo.LegendDefault Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace : LegendDefaultsInfo.LegendDefault Structure

Glossary Item Box

For a list of all members of this type, see LegendDefaultsInfo.LegendDefault members.

Public Fields

 | Name | Description
Public Field | Layout |
Public Field | Position |
Public Field | UseDataPointSeries |
Top

See Also

Reference

LegendDefaultsInfo.LegendDefault Structure
GrapeCity.ActiveReports.Rendering.Components.Chart Namespace


Layout Field

[image]
ActiveReports 19 .NET Edition
Layout Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > LegendDefaultsInfo.LegendDefault Structure : Layout Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Layout As LegendLayout
C#
public readonly LegendLayout Layout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo.LegendDefault Structure
LegendDefaultsInfo.LegendDefault Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > LegendDefaultsInfo.LegendDefault Structure : Position Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Position As LegendPosition
C#
public readonly LegendPosition Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo.LegendDefault Structure
LegendDefaultsInfo.LegendDefault Members


UseDataPointSeries Field

[image]
ActiveReports 19 .NET Edition
UseDataPointSeries Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Chart Namespace > LegendDefaultsInfo.LegendDefault Structure : UseDataPointSeries Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly UseDataPointSeries As Boolean
C#
public readonly bool UseDataPointSeries

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendDefaultsInfo.LegendDefault Structure
LegendDefaultsInfo.LegendDefault Members


FillStyle Class

[image]
ActiveReports 19 .NET Edition
FillStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : FillStyle Class

Glossary Item Box

Represents the type of fill style.

Object Model

FillStyle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FillStyle
C#
public sealed class FillStyle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Members
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FillStyle Class Members

[image]
ActiveReports 19 .NET Edition
FillStyle Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : FillStyle Class

Glossary Item Box

The following tables list the members exposed by FillStyle.

Public Constructors

 | Name | Description
Public Constructor | FillStyle Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | FillColorPropertyName |
Public Field | GradientEndColorPropertyName |
Public Field | GradientStylePropertyName |
Top

Public Properties

 | Name | Description
Public Property | FillColor | Gets the primary color.
Public Property | GradientEndColor | Gets the secondary color used for a gradient filling.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects FillStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

FillStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FillStyle Constructor

[image]
ActiveReports 19 .NET Edition
FillStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : FillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
FillStyle Constructor(Color) | Initializes a new instance of the FillStyle class with the specified fill color.
FillStyle Constructor(GradientType,Color,Color) | Initializes a new instance of the FillStyle class with the specified gradient type, fill color, and gradient end color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


FillStyle Constructor(Color)

[image]
ActiveReports 19 .NET Edition
FillStyle Constructor(Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color)

fillColor
The fill color.

Glossary Item Box

Initializes a new instance of the FillStyle class with the specified fill color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillColor As Color _
)
C#
public FillStyle(
   Color fillColor
)

Parameters

fillColor
The fill color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(GradientType,Color,Color)

[image]
ActiveReports 19 .NET Edition
FillStyle Constructor(GradientType,Color,Color)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(GradientType,Color,Color)

gradientType
The gradient type.
fillColor
The fill color.
gradientEndColor
The gradient end color.

Glossary Item Box

Initializes a new instance of the FillStyle class with the specified gradient type, fill color, and gradient end color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gradientType As GradientType, _
   ByVal fillColor As Color, _
   ByVal gradientEndColor As Color _
)
C#
public FillStyle(
   GradientType gradientType,
   Color fillColor,
   Color gradientEndColor
)

Parameters

gradientType
The gradient type.
fillColor
The fill color.
gradientEndColor
The gradient end color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Class Methods

[image]
ActiveReports 19 .NET Edition
FillStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : FillStyle Class

Glossary Item Box

For a list of all members of this type, see FillStyle members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects FillStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

FillStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


Parse(IPropertyBag,String,FillStyle) Method

[image]
ActiveReports 19 .NET Edition
Parse(IPropertyBag,String,FillStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : Parse(IPropertyBag,String,FillStyle) Method

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultValue
the default value will be returned if properties do not contain fill style values

Glossary Item Box

Collects FillStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal properties As IPropertyBag, _
   ByVal substitution As String, _
   ByVal defaultValue As FillStyle _
) As FillStyle
C#
public static FillStyle Parse(
   IPropertyBag properties,
   string substitution,
   FillStyle defaultValue
)

Parameters

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultValue
the default value will be returned if properties do not contain fill style values

Remarks

If default value is null and there are no fill style properties in property bag then the White color will be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


FillStyle Class Properties

[image]
ActiveReports 19 .NET Edition
FillStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : FillStyle Class

Glossary Item Box

For a list of all members of this type, see FillStyle members.

Public Properties

 | Name | Description
Public Property | FillColor | Gets the primary color.
Public Property | GradientEndColor | Gets the secondary color used for a gradient filling.
Top

See Also

Reference

FillStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FillColor Property

[image]
ActiveReports 19 .NET Edition
FillColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : FillColor Property

Glossary Item Box

Gets the primary color.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillColor As Color
C#
public Color FillColor {get;}

Property Value

The fill color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


GradientEndColor Property

[image]
ActiveReports 19 .NET Edition
GradientEndColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : GradientEndColor Property

Glossary Item Box

Gets the secondary color used for a gradient filling.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GradientEndColor As Color
C#
public Color GradientEndColor {get;}

Property Value

The gradient end color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


FillStyle Class Fields

[image]
ActiveReports 19 .NET Edition
FillStyle Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : FillStyle Class

Glossary Item Box

For a list of all members of this type, see FillStyle members.

Public Fields

 | Name | Description
Public Field | FillColorPropertyName |
Public Field | GradientEndColorPropertyName |
Public Field | GradientStylePropertyName |
Top

See Also

Reference

FillStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FillColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
FillColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : FillColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FillColorPropertyName As String
C#
public const string FillColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


GradientEndColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
GradientEndColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : GradientEndColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const GradientEndColorPropertyName As String
C#
public const string GradientEndColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


GradientStylePropertyName Field

[image]
ActiveReports 19 .NET Edition
GradientStylePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > FillStyle Class : GradientStylePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const GradientStylePropertyName As String
C#
public const string GradientStylePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FillStyle Class
FillStyle Members


LineStyle Class

[image]
ActiveReports 19 .NET Edition
LineStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : LineStyle Class

Glossary Item Box

Represents the type of line style.

Object Model

LineStyle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LineStyle
C#
public sealed class LineStyle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Dashboard.LineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Members
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


LineStyle Class Members

[image]
ActiveReports 19 .NET Edition
LineStyle Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : LineStyle Class

Glossary Item Box

The following tables list the members exposed by LineStyle.

Public Constructors

 | Name | Description
Public Constructor | LineStyle Constructor | Initializes a new instance of the LineStyle class with the specified color and width.
Top

Public Fields

 | Name | Description
Public Field | ColorPropertyName |
Public Field | WidthPropertyName |
Top

Public Properties

 | Name | Description
Public Property | LineColor | Gets the color of the current line.
Public Property | LineWidth | Gets the width of the current line.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects LineStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

LineStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


LineStyle Constructor

[image]
ActiveReports 19 .NET Edition
LineStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : LineStyle Constructor

color
The color of the line.
width
The width of the line.

Glossary Item Box

Initializes a new instance of the LineStyle class with the specified color and width.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Length _
)
C#
public LineStyle(
   Color color,
   Length width
)

Parameters

color
The color of the line.
width
The width of the line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


LineStyle Class Methods

[image]
ActiveReports 19 .NET Edition
LineStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : LineStyle Class

Glossary Item Box

For a list of all members of this type, see LineStyle members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects LineStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

LineStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


Parse(IPropertyBag,String,LineStyle) Method

[image]
ActiveReports 19 .NET Edition
Parse(IPropertyBag,String,LineStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : Parse(IPropertyBag,String,LineStyle) Method

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultValue
the default value will be returned if properties do not contain line style values

Glossary Item Box

Collects LineStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal properties As IPropertyBag, _
   ByVal substitution As String, _
   ByVal defaultValue As LineStyle _
) As LineStyle
C#
public static LineStyle Parse(
   IPropertyBag properties,
   string substitution,
   LineStyle defaultValue
)

Parameters

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultValue
the default value will be returned if properties do not contain line style values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


LineStyle Class Properties

[image]
ActiveReports 19 .NET Edition
LineStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : LineStyle Class

Glossary Item Box

For a list of all members of this type, see LineStyle members.

Public Properties

 | Name | Description
Public Property | LineColor | Gets the color of the current line.
Public Property | LineWidth | Gets the width of the current line.
Top

See Also

Reference

LineStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


LineColor Property

[image]
ActiveReports 19 .NET Edition
LineColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : LineColor Property

Glossary Item Box

Gets the color of the current line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineColor As Color
C#
public Color LineColor {get;}

Property Value

The line color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


LineWidth Property

[image]
ActiveReports 19 .NET Edition
LineWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : LineWidth Property

Glossary Item Box

Gets the width of the current line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineWidth As Length
C#
public Length LineWidth {get;}

Property Value

The line width as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


LineStyle Class Fields

[image]
ActiveReports 19 .NET Edition
LineStyle Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : LineStyle Class

Glossary Item Box

For a list of all members of this type, see LineStyle members.

Public Fields

 | Name | Description
Public Field | ColorPropertyName |
Public Field | WidthPropertyName |
Top

See Also

Reference

LineStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


ColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
ColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : ColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColorPropertyName As String
C#
public const string ColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


WidthPropertyName Field

[image]
ActiveReports 19 .NET Edition
WidthPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > LineStyle Class : WidthPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const WidthPropertyName As String
C#
public const string WidthPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineStyle Class
LineStyle Members


TextStyle Class

[image]
ActiveReports 19 .NET Edition
TextStyle Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : TextStyle Class

Glossary Item Box

Represents the type of text style.

Object Model

TextStyle Class

Syntax

Visual Basic (Declaration)
Public Class TextStyle
C#
public class TextStyle

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Dashboard.TextStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Members
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


TextStyle Class Members

[image]
ActiveReports 19 .NET Edition
TextStyle Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : TextStyle Class

Glossary Item Box

The following tables list the members exposed by TextStyle.

Public Constructors

 | Name | Description
Public Constructor | TextStyle Constructor | Initializes a new instance of the TextStyle class with the specified font family, font size, font style, and color.
Top

Public Fields

 | Name | Description
Public Field | FontColorPropertyName |
Public Field | FontFamilyPropertyName |
Public Field | FontSizePropertyName |
Public Field | FontStylePropertyName |
Top

Public Properties

 | Name | Description
Public Property | FontColor | Gets the color used to draw the text.
Public Property | FontFamily | Gets the font family.
Public Property | FontSize | Gets the font size measured in points.
Public Property | FontStyle | Gets the font style.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects TextStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


TextStyle Constructor

[image]
ActiveReports 19 .NET Edition
TextStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : TextStyle Constructor

fontFamily
The font family.
fontSize
The font size.
fontStyle
The font style.
color
The color of the font.

Glossary Item Box

Initializes a new instance of the TextStyle class with the specified font family, font size, font style, and color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fontFamily As String, _
   ByVal fontSize As Length, _
   ByVal fontStyle As FontStyleEx, _
   ByVal color As Color _
)
C#
public TextStyle(
   string fontFamily,
   Length fontSize,
   FontStyleEx fontStyle,
   Color color
)

Parameters

fontFamily
The font family.
fontSize
The font size.
fontStyle
The font style.
color
The color of the font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Class Methods

[image]
ActiveReports 19 .NET Edition
TextStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : TextStyle Class

Glossary Item Box

For a list of all members of this type, see TextStyle members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Parse | Collects TextStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


Parse(IPropertyBag,String,TextStyle) Method

[image]
ActiveReports 19 .NET Edition
Parse(IPropertyBag,String,TextStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : Parse(IPropertyBag,String,TextStyle) Method

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultStyle
the default value will be returned if properties do not contain text style values

Glossary Item Box

Collects TextStyle instance from GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag using the given substitution.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal properties As IPropertyBag, _
   ByVal substitution As String, _
   ByVal defaultStyle As TextStyle _
) As TextStyle
C#
public static TextStyle Parse(
   IPropertyBag properties,
   string substitution,
   TextStyle defaultStyle
)

Parameters

properties
property collections represented by GrapeCity.ActiveReports.Extensibility.Rendering.IPropertyBag
substitution
substitution to resolve a full name of property
defaultStyle
the default value will be returned if properties do not contain text style values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Class Properties

[image]
ActiveReports 19 .NET Edition
TextStyle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : TextStyle Class

Glossary Item Box

For a list of all members of this type, see TextStyle members.

Public Properties

 | Name | Description
Public Property | FontColor | Gets the color used to draw the text.
Public Property | FontFamily | Gets the font family.
Public Property | FontSize | Gets the font size measured in points.
Public Property | FontStyle | Gets the font style.
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FontColor Property

[image]
ActiveReports 19 .NET Edition
FontColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontColor Property

Glossary Item Box

Gets the color used to draw the text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontColor As Color
C#
public Color FontColor {get;}

Property Value

The font color as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontFamily Property

[image]
ActiveReports 19 .NET Edition
FontFamily Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontFamily Property

Glossary Item Box

Gets the font family.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontFamily As String
C#
public string FontFamily {get;}

Property Value

The font family as a System.String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontSize Property

[image]
ActiveReports 19 .NET Edition
FontSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontSize Property

Glossary Item Box

Gets the font size measured in points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontSize As Length
C#
public Length FontSize {get;}

Property Value

The font size as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontStyle Property

[image]
ActiveReports 19 .NET Edition
FontStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontStyle Property

Glossary Item Box

Gets the font style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontStyle As FontStyleEx
C#
public FontStyleEx FontStyle {get;}

Property Value

The font style as a GrapeCity.ActiveReports.Drawing.FontStyleEx.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


TextStyle Class Fields

[image]
ActiveReports 19 .NET Edition
TextStyle Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : TextStyle Class

Glossary Item Box

For a list of all members of this type, see TextStyle members.

Public Fields

 | Name | Description
Public Field | FontColorPropertyName |
Public Field | FontFamilyPropertyName |
Public Field | FontSizePropertyName |
Public Field | FontStylePropertyName |
Top

See Also

Reference

TextStyle Class
GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


FontColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
FontColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FontColorPropertyName As String
C#
public const string FontColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontFamilyPropertyName Field

[image]
ActiveReports 19 .NET Edition
FontFamilyPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontFamilyPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FontFamilyPropertyName As String
C#
public const string FontFamilyPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontSizePropertyName Field

[image]
ActiveReports 19 .NET Edition
FontSizePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontSizePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FontSizePropertyName As String
C#
public const string FontSizePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


FontStylePropertyName Field

[image]
ActiveReports 19 .NET Edition
FontStylePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace > TextStyle Class : FontStylePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const FontStylePropertyName As String
C#
public const string FontStylePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextStyle Class
TextStyle Members


GradientType Enumeration

[image]
ActiveReports 19 .NET Edition
GradientType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace : GradientType Enumeration

Glossary Item Box

Specifies the type of gradient styles.

Syntax

Visual Basic (Declaration)
Public Enum GradientType
   Inherits System.Enum
C#
public enum GradientType : System.Enum

Members

Member | Description
Center | Gradient fill from the center.
DiagonalLeft | Forward diagonal gradient style.
DiagonalRight | Backward diagonal gradient style.
HorizontalCenter | Horizontal gradient style from center.
LeftRight | Gradient fill from left to right.
None | Solid fill (default).
TopBottom | Gradient fill from top to bottom.
VerticalCenter | Vertical gradient style from center.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Dashboard.GradientType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Dashboard Namespace


ToggleMap Class

[image]
ActiveReports 19 .NET Edition
ToggleMap Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace : ToggleMap Class

Glossary Item Box

Represents toggle map.

Object Model

ToggleMap Class

Syntax

Visual Basic (Declaration)
Public Class ToggleMap
C#
public class ToggleMap

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Interactivity.ToggleMap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Members
GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace


ToggleMap Class Members

[image]
ActiveReports 19 .NET Edition
ToggleMap Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace : ToggleMap Class

Glossary Item Box

The following tables list the members exposed by ToggleMap.

Public Constructors

 | Name | Description
Public Constructor | ToggleMap Constructor |
Top

Public Methods

 | Name | Description
Public Method | AddToggleItem |
Public Method | IsToggle |
Public Method | TryGetValue | Overloaded.
Top

See Also

Reference

ToggleMap Class
GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace


ToggleMap Constructor

[image]
ActiveReports 19 .NET Edition
ToggleMap Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class : ToggleMap Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToggleMap()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members


ToggleMap Class Methods

[image]
ActiveReports 19 .NET Edition
ToggleMap Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace : ToggleMap Class

Glossary Item Box

For a list of all members of this type, see ToggleMap members.

Public Methods

 | Name | Description
Public Method | AddToggleItem |
Public Method | IsToggle |
Public Method | TryGetValue | Overloaded.
Top

See Also

Reference

ToggleMap Class
GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace


AddToggleItem Method

[image]
ActiveReports 19 .NET Edition
AddToggleItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class : AddToggleItem Method

definition
toggle
steps
parentIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddToggleItem( _
   ByVal definition As Object, _
   ByVal toggle As TextBox, _
   ByVal steps As Integer, _
   Optional ByVal parentIndex As Integer _
)
C#
public void AddToggleItem(
   object definition,
   TextBox toggle,
   int steps,
   int parentIndex
)

Parameters

definition
toggle
steps
parentIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members


IsToggle Method

[image]
ActiveReports 19 .NET Edition
IsToggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class : IsToggle Method

toggleItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsToggle( _
   ByVal toggleItem As TextBox _
) As Boolean
C#
public bool IsToggle(
   TextBox toggleItem
)

Parameters

toggleItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members


TryGetValue Method

[image]
ActiveReports 19 .NET Edition
TryGetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class : TryGetValue Method

Glossary Item Box

Overload List

Overload | Description
TryGetValue(Object,Int32) |
TryGetValue(Object,Int32,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members


TryGetValue(Object,Int32) Method

[image]
ActiveReports 19 .NET Edition
TryGetValue(Object,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class > TryGetValue Method : TryGetValue(Object,Int32) Method

definition
steps

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function TryGetValue( _
   ByVal definition As Object, _
   ByRef steps As Integer _
) As Boolean
C#
public bool TryGetValue(
   object definition,
   out int steps
)

Parameters

definition
steps

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members
Overload List


TryGetValue(Object,Int32,Int32) Method

[image]
ActiveReports 19 .NET Edition
TryGetValue(Object,Int32,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interactivity Namespace > ToggleMap Class > TryGetValue Method : TryGetValue(Object,Int32,Int32) Method

definition
steps
parentIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function TryGetValue( _
   ByVal definition As Object, _
   ByRef steps As Integer, _
   ByRef parentIndex As Integer _
) As Boolean
C#
public bool TryGetValue(
   object definition,
   out int steps,
   out int parentIndex
)

Parameters

definition
steps
parentIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToggleMap Class
ToggleMap Members
Overload List


ICustomReportItemAdapter Interface

[image]
ActiveReports 19 .NET Edition
ICustomReportItemAdapter Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ICustomReportItemAdapter Interface

Glossary Item Box

Interface for CustomReportItemAdapter

Syntax

Visual Basic (Declaration)
Public Interface ICustomReportItemAdapter
C#
public interface ICustomReportItemAdapter

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomReportItemAdapter Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


ICustomReportItemAdapter Interface Members

[image]
ActiveReports 19 .NET Edition
ICustomReportItemAdapter Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ICustomReportItemAdapter Interface

Glossary Item Box

The following tables list the members exposed by ICustomReportItemAdapter.

Public Properties

 | Name | Description
Property | OriginalReportItem |
Top

See Also

Reference

ICustomReportItemAdapter Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


ICustomReportItemAdapter Interface Properties

[image]
ActiveReports 19 .NET Edition
ICustomReportItemAdapter Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ICustomReportItemAdapter Interface

Glossary Item Box

For a list of all members of this type, see ICustomReportItemAdapter members.

Public Properties

 | Name | Description
Property | OriginalReportItem |
Top

See Also

Reference

ICustomReportItemAdapter Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


OriginalReportItem Property

[image]
ActiveReports 19 .NET Edition
OriginalReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > ICustomReportItemAdapter Interface : OriginalReportItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OriginalReportItem As ICustomReportItem
C#
ICustomReportItem OriginalReportItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomReportItemAdapter Interface
ICustomReportItemAdapter Members


IDocumentMapProvider Interface

[image]
ActiveReports 19 .NET Edition
IDocumentMapProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IDocumentMapProvider Interface

Glossary Item Box

Represents document map provider.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentMapProvider
C#
public interface IDocumentMapProvider

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IDocumentMapProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IDocumentMapProvider Interface Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IDocumentMapProvider Interface

Glossary Item Box

The following tables list the members exposed by IDocumentMapProvider.

Public Properties

 | Name | Description
Property | DocumentMap | Gets document map.
Top

Public Methods

 | Name | Description
Method | FindNode |
Method | Reset |
Method | ResolveNode |
Top

Public Events

 | Name | Description
Event | DocumentMapChanged | Raised when DocumentMap is changed.
Top

See Also

Reference

IDocumentMapProvider Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IDocumentMapProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IDocumentMapProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IDocumentMapProvider Interface

Glossary Item Box

For a list of all members of this type, see IDocumentMapProvider members.

Public Methods

 | Name | Description
Method | FindNode |
Method | Reset |
Method | ResolveNode |
Top

See Also

Reference

IDocumentMapProvider Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


FindNode Method

[image]
ActiveReports 19 .NET Edition
FindNode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IDocumentMapProvider Interface : FindNode Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function FindNode( _
   ByVal item As IReportItem _
) As DocumentMapNode
C#
DocumentMapNode FindNode(
   IReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Interface
IDocumentMapProvider Members


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IDocumentMapProvider Interface : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub Reset()
C#
void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Interface
IDocumentMapProvider Members


ResolveNode Method

[image]
ActiveReports 19 .NET Edition
ResolveNode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IDocumentMapProvider Interface : ResolveNode Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function ResolveNode( _
   ByVal item As IReportItem _
) As DocumentMapNode
C#
DocumentMapNode ResolveNode(
   IReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Interface
IDocumentMapProvider Members


IDocumentMapProvider Interface Properties

[image]
ActiveReports 19 .NET Edition
IDocumentMapProvider Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IDocumentMapProvider Interface

Glossary Item Box

For a list of all members of this type, see IDocumentMapProvider members.

Public Properties

 | Name | Description
Property | DocumentMap | Gets document map.
Top

See Also

Reference

IDocumentMapProvider Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


DocumentMap Property

[image]
ActiveReports 19 .NET Edition
DocumentMap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IDocumentMapProvider Interface : DocumentMap Property

Glossary Item Box

Gets document map.

Syntax

Visual Basic (Declaration)
ReadOnly Property DocumentMap As DocumentMapNode
C#
DocumentMapNode DocumentMap {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Interface
IDocumentMapProvider Members


IDocumentMapProvider Interface Events

[image]
ActiveReports 19 .NET Edition
IDocumentMapProvider Interface Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IDocumentMapProvider Interface

Glossary Item Box

For a list of all members of this type, see IDocumentMapProvider members.

Public Events

 | Name | Description
Event | DocumentMapChanged | Raised when DocumentMap is changed.
Top

See Also

Reference

IDocumentMapProvider Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


DocumentMapChanged Event

[image]
ActiveReports 19 .NET Edition
DocumentMapChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IDocumentMapProvider Interface : DocumentMapChanged Event

Glossary Item Box

Raised when DocumentMap is changed.

Syntax

Visual Basic (Declaration)
Event DocumentMapChanged As EventHandler
C#
event EventHandler DocumentMapChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentMapProvider Interface
IDocumentMapProvider Members


IFormattingService Interface

[image]
ActiveReports 19 .NET Edition
IFormattingService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IFormattingService Interface

Glossary Item Box

Providers functionality for values converting and formatting according to the current language.

Syntax

Visual Basic (Declaration)
Public Interface IFormattingService
C#
public interface IFormattingService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattingService Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IFormattingService Interface Members

[image]
ActiveReports 19 .NET Edition
IFormattingService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IFormattingService Interface

Glossary Item Box

The following tables list the members exposed by IFormattingService.

Public Methods

 | Name | Description
Method | Format | Overloaded. Returns a string representation of the specified value using GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle and according to the language settings defined in the report or current server language.
Top

See Also

Reference

IFormattingService Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IFormattingService Interface Methods

[image]
ActiveReports 19 .NET Edition
IFormattingService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IFormattingService Interface

Glossary Item Box

For a list of all members of this type, see IFormattingService members.

Public Methods

 | Name | Description
Method | Format | Overloaded. Returns a string representation of the specified value using GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle and according to the language settings defined in the report or current server language.
Top

See Also

Reference

IFormattingService Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


Format Method

[image]
ActiveReports 19 .NET Edition
Format Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IFormattingService Interface : Format Method

Glossary Item Box

Returns a string representation of the specified value using GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle and according to the language settings defined in the report or current server language.

Overload List

Overload | Description
Format(Object,IStyle) | Returns a string representation of the specified value using GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle and according to the language settings defined in the report or current server language.
Format(Object,String) | Returns a string representation of the specified value consistent with the current report language settings and using the specified format string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattingService Interface
IFormattingService Members


Format(Object,IStyle) Method

[image]
ActiveReports 19 .NET Edition
Format(Object,IStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IFormattingService Interface > Format Method : Format(Object,IStyle) Method

value
style

Glossary Item Box

Returns a string representation of the specified value using GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStyle and according to the language settings defined in the report or current server language.

Syntax

Visual Basic (Declaration)
Overloads Function Format( _
   ByVal value As Object, _
   ByVal style As IStyle _
) As String
C#
string Format(
   object value,
   IStyle style
)

Parameters

value
style

Remarks

According to RDL specs. report item language takes precedence over report language and everything fallbacks on a default (server -- whatever it is) language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattingService Interface
IFormattingService Members
Overload List


Format(Object,String) Method

[image]
ActiveReports 19 .NET Edition
Format(Object,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IFormattingService Interface > Format Method : Format(Object,String) Method

value
formatSpecifier

Glossary Item Box

Returns a string representation of the specified value consistent with the current report language settings and using the specified format string.

Syntax

Visual Basic (Declaration)
Overloads Function Format( _
   ByVal value As Object, _
   ByVal formatSpecifier As String _
) As String
C#
string Format(
   object value,
   string formatSpecifier
)

Parameters

value
formatSpecifier

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormattingService Interface
IFormattingService Members
Overload List


IMapImageLocator Interface

[image]
ActiveReports 19 .NET Edition
IMapImageLocator Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IMapImageLocator Interface

Glossary Item Box

Represents an interface for retrieving images from a specified source.

Syntax

Visual Basic (Declaration)
Public Interface IMapImageLocator
C#
public interface IMapImageLocator

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapImageLocator Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IMapImageLocator Interface Members

[image]
ActiveReports 19 .NET Edition
IMapImageLocator Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IMapImageLocator Interface

Glossary Item Box

The following tables list the members exposed by IMapImageLocator.

Public Methods

 | Name | Description
Method | GetImageInfo | Retrieves image information from the specified source.
Top

See Also

Reference

IMapImageLocator Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IMapImageLocator Interface Methods

[image]
ActiveReports 19 .NET Edition
IMapImageLocator Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IMapImageLocator Interface

Glossary Item Box

For a list of all members of this type, see IMapImageLocator members.

Public Methods

 | Name | Description
Method | GetImageInfo | Retrieves image information from the specified source.
Top

See Also

Reference

IMapImageLocator Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


GetImageInfo Method

[image]
ActiveReports 19 .NET Edition
GetImageInfo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IMapImageLocator Interface : GetImageInfo Method

imageSource
The source of the image.
mimeType
The MIME type of the image.
value
The value associated with the image.

Glossary Item Box

Retrieves image information from the specified source.

Syntax

Visual Basic (Declaration)
Function GetImageInfo( _
   ByVal imageSource As ImageSource, _
   ByVal mimeType As String, _
   ByVal value As Object _
) As ImageInfo
C#
ImageInfo GetImageInfo(
   ImageSource imageSource,
   string mimeType,
   object value
)

Parameters

imageSource
The source of the image.
mimeType
The MIME type of the image.
value
The value associated with the image.

Return Value

An GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo object containing the image information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMapImageLocator Interface
IMapImageLocator Members


IReportRenderingContext Interface

[image]
ActiveReports 19 .NET Edition
IReportRenderingContext Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IReportRenderingContext Interface

Glossary Item Box

Represents report rendering context.

Syntax

Visual Basic (Declaration)
Public Interface IReportRenderingContext
   Inherits GrapeCity.ActiveReports.Rendering.Components.IProgramServices, GrapeCity.ActiveReports.Rendering.Components.IStyleEvaluatorFactory
C#
public interface IReportRenderingContext : GrapeCity.ActiveReports.Rendering.Components.IProgramServices, GrapeCity.ActiveReports.Rendering.Components.IStyleEvaluatorFactory

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IReportRenderingContext Interface Members

[image]
ActiveReports 19 .NET Edition
IReportRenderingContext Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IReportRenderingContext Interface

Glossary Item Box

The following tables list the members exposed by IReportRenderingContext.

Public Properties

 | Name | Description
Property | ConstEvaluator |
Property | DocumentMapContext |
Property | Interactivity |
Property | IsSubreport |
Property | ParentDocumentMapContext |
Property | Report |
Property | ReportLanguage |
Property | ReportStore |
Property | ResourceLocator |
Property | RootReportRenderingContext |
Property | ToggleMap |
Top

Public Methods

 | Name | Description
Method | CreateAction |
Method | CreateColorPalette |
Method | CreateCustomReportItem |
Method | CreateReportItem |
Method | CreateReportItems |
Method | CreateStyle | Overloaded.
Method | CreateSubreportReport | Creates IReport rendering component for a given subreport
Method | GetService |
Top

See Also

Reference

IReportRenderingContext Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


IReportRenderingContext Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportRenderingContext Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IReportRenderingContext Interface

Glossary Item Box

For a list of all members of this type, see IReportRenderingContext members.

Public Methods

 | Name | Description
Method | CreateAction |
Method | CreateColorPalette |
Method | CreateCustomReportItem |
Method | CreateReportItem |
Method | CreateReportItems |
Method | CreateStyle | Overloaded.
Method | CreateSubreportReport | Creates IReport rendering component for a given subreport
Method | GetService |
Top

See Also

Reference

IReportRenderingContext Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


CreateAction Method

[image]
ActiveReports 19 .NET Edition
CreateAction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateAction Method

owner
action
dataScope
evaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateAction( _
   ByVal owner As IReportItem, _
   ByVal action As Action, _
   ByVal dataScope As IDataScopeInternal, _
   Optional ByVal evaluator As IExpressionEvaluatorService _
) As IAction
C#
IAction CreateAction(
   IReportItem owner,
   Action action,
   IDataScopeInternal dataScope,
   IExpressionEvaluatorService evaluator
)

Parameters

owner
action
dataScope
evaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateColorPalette Method

[image]
ActiveReports 19 .NET Edition
CreateColorPalette Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateColorPalette Method

name
customPalette
expressionEvaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateColorPalette( _
   ByVal name As String, _
   ByVal customPalette As CustomPaletteColorsCollection, _
   ByVal expressionEvaluator As IExpressionEvaluatorService _
) As Color()
C#
Color[] CreateColorPalette(
   string name,
   CustomPaletteColorsCollection customPalette,
   IExpressionEvaluatorService expressionEvaluator
)

Parameters

name
customPalette
expressionEvaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateCustomReportItem Method

[image]
ActiveReports 19 .NET Edition
CreateCustomReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateCustomReportItem Method

customAdapterReportItemDefinition
dataScope
customAdapterProgram

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateCustomReportItem( _
   ByVal customAdapterReportItemDefinition As CustomReportItem, _
   ByVal dataScope As IDataScopeInternal, _
   ByVal customAdapterProgram As IReportItemProgram(Of ReportItem) _
) As IReportItem
C#
IReportItem CreateCustomReportItem(
   CustomReportItem customAdapterReportItemDefinition,
   IDataScopeInternal dataScope,
   IReportItemProgram<ReportItem> customAdapterProgram
)

Parameters

customAdapterReportItemDefinition
dataScope
customAdapterProgram

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateReportItem Method

[image]
ActiveReports 19 .NET Edition
CreateReportItem Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateReportItem Method

item
dataScope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateReportItem( _
   ByVal item As ReportItem, _
   ByVal dataScope As IDataScopeInternal _
) As IReportItem
C#
IReportItem CreateReportItem(
   ReportItem item,
   IDataScopeInternal dataScope
)

Parameters

item
dataScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateReportItems Method

[image]
ActiveReports 19 .NET Edition
CreateReportItems Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateReportItems Method

items
dataScope

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateReportItems( _
   ByVal items As IEnumerable(Of ReportItem), _
   ByVal dataScope As IDataScopeInternal _
) As IEnumerable(Of IReportItem)
C#
IEnumerable<IReportItem> CreateReportItems(
   IEnumerable<ReportItem> items,
   IDataScopeInternal dataScope
)

Parameters

items
dataScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateStyle Method

[image]
ActiveReports 19 .NET Edition
CreateStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateStyle Method

Glossary Item Box

Overload List

Overload | Description
CreateStyle(Style,IServiceProvider) |
CreateStyle(Style,IExpressionEvaluatorService) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


CreateStyle(Style,IServiceProvider) Method

[image]
ActiveReports 19 .NET Edition
CreateStyle(Style,IServiceProvider) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface > CreateStyle Method : CreateStyle(Style,IServiceProvider) Method

style
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads Function CreateStyle( _
   ByVal style As Style, _
   ByVal item As IServiceProvider _
) As IStyle
C#
IStyle CreateStyle(
   Style style,
   IServiceProvider item
)

Parameters

style
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members
Overload List


CreateStyle(Style,IExpressionEvaluatorService) Method

[image]
ActiveReports 19 .NET Edition
CreateStyle(Style,IExpressionEvaluatorService) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface > CreateStyle Method : CreateStyle(Style,IExpressionEvaluatorService) Method

style
expressionEvaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads Function CreateStyle( _
   ByVal style As Style, _
   ByVal expressionEvaluator As IExpressionEvaluatorService _
) As IStyle
C#
IStyle CreateStyle(
   Style style,
   IExpressionEvaluatorService expressionEvaluator
)

Parameters

style
expressionEvaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members
Overload List


CreateSubreportReport Method

[image]
ActiveReports 19 .NET Edition
CreateSubreportReport Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : CreateSubreportReport Method

def
Subreport definition.
dataScope
DataScope to subreport be craeted from.
language
Parent language if any.

Glossary Item Box

Creates IReport rendering component for a given subreport

Syntax

Visual Basic (Declaration)
Function CreateSubreportReport( _
   ByVal def As Subreport, _
   ByVal dataScope As IDataScopeInternal, _
   Optional ByVal language As CultureInfo _
) As IReport
C#
IReport CreateSubreportReport(
   Subreport def,
   IDataScopeInternal dataScope,
   CultureInfo language
)

Parameters

def
Subreport definition.
dataScope
DataScope to subreport be craeted from.
language
Parent language if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


GetService Method

[image]
ActiveReports 19 .NET Edition
GetService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : GetService Method

serviceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetService( _
   ByVal serviceType As Type _
) As Object
C#
object GetService(
   Type serviceType
)

Parameters

serviceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


IReportRenderingContext Interface Properties

[image]
ActiveReports 19 .NET Edition
IReportRenderingContext Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : IReportRenderingContext Interface

Glossary Item Box

For a list of all members of this type, see IReportRenderingContext members.

Public Properties

 | Name | Description
Property | ConstEvaluator |
Property | DocumentMapContext |
Property | Interactivity |
Property | IsSubreport |
Property | ParentDocumentMapContext |
Property | Report |
Property | ReportLanguage |
Property | ReportStore |
Property | ResourceLocator |
Property | RootReportRenderingContext |
Property | ToggleMap |
Top

See Also

Reference

IReportRenderingContext Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


ConstEvaluator Property

[image]
ActiveReports 19 .NET Edition
ConstEvaluator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ConstEvaluator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Shadows ReadOnly Property ConstEvaluator As IExpressionEvaluatorService
C#
new IExpressionEvaluatorService ConstEvaluator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


DocumentMapContext Property

[image]
ActiveReports 19 .NET Edition
DocumentMapContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : DocumentMapContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DocumentMapContext As IDocumentMapProvider
C#
IDocumentMapProvider DocumentMapContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


Interactivity Property

[image]
ActiveReports 19 .NET Edition
Interactivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : Interactivity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Interactivity As InteractiveStateStore
C#
InteractiveStateStore Interactivity {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


IsSubreport Property

[image]
ActiveReports 19 .NET Edition
IsSubreport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : IsSubreport Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSubreport As Boolean
C#
bool IsSubreport {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ParentDocumentMapContext Property

[image]
ActiveReports 19 .NET Edition
ParentDocumentMapContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ParentDocumentMapContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ParentDocumentMapContext As IDocumentMapProvider
C#
IDocumentMapProvider ParentDocumentMapContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : Report Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Shadows Property Report As IReport
C#
new IReport Report {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ReportLanguage Property

[image]
ActiveReports 19 .NET Edition
ReportLanguage Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ReportLanguage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportLanguage As String
C#
string ReportLanguage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ReportStore Property

[image]
ActiveReports 19 .NET Edition
ReportStore Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ReportStore Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportStore As ReportStore
C#
ReportStore ReportStore {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ResourceLocator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ResourceLocator As ResourceLocator
C#
ResourceLocator ResourceLocator {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


RootReportRenderingContext Property

[image]
ActiveReports 19 .NET Edition
RootReportRenderingContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : RootReportRenderingContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RootReportRenderingContext As IReportRenderingContext
C#
IReportRenderingContext RootReportRenderingContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ToggleMap Property

[image]
ActiveReports 19 .NET Edition
ToggleMap Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > IReportRenderingContext Interface : ToggleMap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ToggleMap As ToggleMap
C#
ToggleMap ToggleMap {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportRenderingContext Interface
IReportRenderingContext Members


ITocAnchoredItem Interface

[image]
ActiveReports 19 .NET Edition
ITocAnchoredItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ITocAnchoredItem Interface

Glossary Item Box

Represents an interface for ToC-anchored items.

Syntax

Visual Basic (Declaration)
Public Interface ITocAnchoredItem
C#
public interface ITocAnchoredItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocAnchoredItem Members
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


ITocAnchoredItem Interface Members

[image]
ActiveReports 19 .NET Edition
ITocAnchoredItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ITocAnchoredItem Interface

Glossary Item Box

The following tables list the members exposed by ITocAnchoredItem.

Public Properties

 | Name | Description
Property | Anchor | Gets the anchor.
Top

See Also

Reference

ITocAnchoredItem Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


ITocAnchoredItem Interface Properties

[image]
ActiveReports 19 .NET Edition
ITocAnchoredItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace : ITocAnchoredItem Interface

Glossary Item Box

For a list of all members of this type, see ITocAnchoredItem members.

Public Properties

 | Name | Description
Property | Anchor | Gets the anchor.
Top

See Also

Reference

ITocAnchoredItem Interface
GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace


Anchor Property

[image]
ActiveReports 19 .NET Edition
Anchor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Interfaces Namespace > ITocAnchoredItem Interface : Anchor Property

Glossary Item Box

Gets the anchor.

Syntax

Visual Basic (Declaration)
ReadOnly Property Anchor As String
C#
string Anchor {get;}

Property Value

A System.String representing the anchor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITocAnchoredItem Interface
ITocAnchoredItem Members


DbfReader Class

[image]
ActiveReports 19 .NET Edition
DbfReader Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : DbfReader Class

Glossary Item Box

dBASE (Dbf) format reader.

Object Model

DbfReader Class

Syntax

Visual Basic (Declaration)
Public Class DbfReader
C#
public class DbfReader

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf.DbfReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


DbfReader Class Members

[image]
ActiveReports 19 .NET Edition
DbfReader Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : DbfReader Class

Glossary Item Box

The following tables list the members exposed by DbfReader.

Public Constructors

 | Name | Description
Public Constructor | DbfReader Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Fields | Fields descriptors collection
Public Property | RecordsCount | Total count of records.
Public Property | Version | Version of the Dbf file format (3 - dBASE III, dBASE IV, dBASE V, 4 - dBASE 7).
Top

Public Methods

 | Name | Description
Public Method | Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | ReadRecords | Reads records from the input data.
Top

See Also

Reference

DbfReader Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


DbfReader Constructor

[image]
ActiveReports 19 .NET Edition
DbfReader Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : DbfReader Constructor

Glossary Item Box

Overload List

Overload | Description
DbfReader Constructor(String) | Initializes a new instance of the DbfReader class.
DbfReader Constructor(Stream) | Initializes a new instance of the DbfReader class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


DbfReader Constructor(String)

[image]
ActiveReports 19 .NET Edition
DbfReader Constructor(String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class > DbfReader Constructor : DbfReader Constructor(String)

fileName
The file containing the input data.

Glossary Item Box

Initializes a new instance of the DbfReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
C#
public DbfReader(
   string fileName
)

Parameters

fileName
The file containing the input data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members
Overload List


DbfReader Constructor(Stream)

[image]
ActiveReports 19 .NET Edition
DbfReader Constructor(Stream)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class > DbfReader Constructor : DbfReader Constructor(Stream)

inputStream
The stream with input data.

Glossary Item Box

Initializes a new instance of the DbfReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inputStream As Stream _
)
C#
public DbfReader(
   Stream inputStream
)

Parameters

inputStream
The stream with input data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members
Overload List


DbfReader Class Methods

[image]
ActiveReports 19 .NET Edition
DbfReader Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : DbfReader Class

Glossary Item Box

For a list of all members of this type, see DbfReader members.

Public Methods

 | Name | Description
Public Method | Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method | ReadRecords | Reads records from the input data.
Top

See Also

Reference

DbfReader Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : Dispose Method

Glossary Item Box

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


ReadRecords Method

[image]
ActiveReports 19 .NET Edition
ReadRecords Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : ReadRecords Method

Glossary Item Box

Reads records from the input data.

Syntax

Visual Basic (Declaration)
Public Function ReadRecords() As IEnumerable(Of IDbfRecord)
C#
public IEnumerable<IDbfRecord> ReadRecords()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


DbfReader Class Properties

[image]
ActiveReports 19 .NET Edition
DbfReader Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : DbfReader Class

Glossary Item Box

For a list of all members of this type, see DbfReader members.

Public Properties

 | Name | Description
Public Property | Fields | Fields descriptors collection
Public Property | RecordsCount | Total count of records.
Public Property | Version | Version of the Dbf file format (3 - dBASE III, dBASE IV, dBASE V, 4 - dBASE 7).
Top

See Also

Reference

DbfReader Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


Fields Property

[image]
ActiveReports 19 .NET Edition
Fields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : Fields Property

Glossary Item Box

Fields descriptors collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As IDbfField()
C#
public IDbfField[] Fields {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


RecordsCount Property

[image]
ActiveReports 19 .NET Edition
RecordsCount Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : RecordsCount Property

Glossary Item Box

Total count of records.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordsCount As Integer
C#
public int RecordsCount {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


Version Property

[image]
ActiveReports 19 .NET Edition
Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > DbfReader Class : Version Property

Glossary Item Box

Version of the Dbf file format (3 - dBASE III, dBASE IV, dBASE V, 4 - dBASE 7).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbfReader Class
DbfReader Members


DbfType Enumeration

[image]
ActiveReports 19 .NET Edition
DbfType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : DbfType Enumeration

Glossary Item Box

dBASE (Dbf) format value types.

Syntax

Visual Basic (Declaration)
Public Enum DbfType
   Inherits System.Enum
C#
public enum DbfType : System.Enum

Members

Member | Description
Autoincrement | Autoincrement.
Binary | Binary.
Char | Char.
Date | Date.
Double | Double.
Float | Float.
Logical | Logical.
Long | Long.
Memo | Memo.
Numeric | Numeric.
Ole | Ole.
Timestamp | Timestamp.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf.DbfType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


IDbfField Interface

[image]
ActiveReports 19 .NET Edition
IDbfField Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfField Interface

Glossary Item Box

dBASE (Dbf) format field description.

Syntax

Visual Basic (Declaration)
Public Interface IDbfField
C#
public interface IDbfField

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfField Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


IDbfField Interface Members

[image]
ActiveReports 19 .NET Edition
IDbfField Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfField Interface

Glossary Item Box

The following tables list the members exposed by IDbfField.

Public Properties

 | Name | Description
Property | Length | Gets the length of the field in bytes.
Property | Name | Gets the name of the field.
Property | Ordinal | Gets the ordinal number of the field.
Property | Type | Gets the format value type of the field.
Top

See Also

Reference

IDbfField Interface
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


IDbfField Interface Properties

[image]
ActiveReports 19 .NET Edition
IDbfField Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfField Interface

Glossary Item Box

For a list of all members of this type, see IDbfField members.

Public Properties

 | Name | Description
Property | Length | Gets the length of the field in bytes.
Property | Name | Gets the name of the field.
Property | Ordinal | Gets the ordinal number of the field.
Property | Type | Gets the format value type of the field.
Top

See Also

Reference

IDbfField Interface
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


Length Property

[image]
ActiveReports 19 .NET Edition
Length Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfField Interface : Length Property

Glossary Item Box

Gets the length of the field in bytes.

Syntax

Visual Basic (Declaration)
ReadOnly Property Length As Integer
C#
int Length {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfField Interface
IDbfField Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfField Interface : Name Property

Glossary Item Box

Gets the name of the field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfField Interface
IDbfField Members


Ordinal Property

[image]
ActiveReports 19 .NET Edition
Ordinal Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfField Interface : Ordinal Property

Glossary Item Box

Gets the ordinal number of the field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Ordinal As Integer
C#
int Ordinal {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfField Interface
IDbfField Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfField Interface : Type Property

Glossary Item Box

Gets the format value type of the field.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As DbfType
C#
DbfType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfField Interface
IDbfField Members


IDbfRecord Interface

[image]
ActiveReports 19 .NET Edition
IDbfRecord Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfRecord Interface

Glossary Item Box

dBASE (Dbf) format single record.

Syntax

Visual Basic (Declaration)
Public Interface IDbfRecord
C#
public interface IDbfRecord

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


IDbfRecord Interface Members

[image]
ActiveReports 19 .NET Edition
IDbfRecord Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfRecord Interface

Glossary Item Box

The following tables list the members exposed by IDbfRecord.

Public Properties

 | Name | Description
Property | Fields | Gets the fields of the record.
Property | Item | Overloaded. Gets the field value by it's index.
Top

Public Methods

 | Name | Description
Method | GetInvariantString | Gets the Gets the field value by it's ordinal number.
Top

See Also

Reference

IDbfRecord Interface
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


IDbfRecord Interface Methods

[image]
ActiveReports 19 .NET Edition
IDbfRecord Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfRecord Interface

Glossary Item Box

For a list of all members of this type, see IDbfRecord members.

Public Methods

 | Name | Description
Method | GetInvariantString | Gets the Gets the field value by it's ordinal number.
Top

See Also

Reference

IDbfRecord Interface
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


GetInvariantString Method

[image]
ActiveReports 19 .NET Edition
GetInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfRecord Interface : GetInvariantString Method

ordinal
The ordinal number of the record's field.

Glossary Item Box

Gets the Gets the field value by it's ordinal number.

Syntax

Visual Basic (Declaration)
Function GetInvariantString( _
   ByVal ordinal As Integer _
) As String
C#
string GetInvariantString(
   int ordinal
)

Parameters

ordinal
The ordinal number of the record's field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Interface
IDbfRecord Members


IDbfRecord Interface Properties

[image]
ActiveReports 19 .NET Edition
IDbfRecord Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace : IDbfRecord Interface

Glossary Item Box

For a list of all members of this type, see IDbfRecord members.

Public Properties

 | Name | Description
Property | Fields | Gets the fields of the record.
Property | Item | Overloaded. Gets the field value by it's index.
Top

See Also

Reference

IDbfRecord Interface
GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace


Fields Property

[image]
ActiveReports 19 .NET Edition
Fields Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfRecord Interface : Fields Property

Glossary Item Box

Gets the fields of the record.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fields As IEnumerable(Of IDbfField)
C#
IEnumerable<IDbfField> Fields {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Interface
IDbfRecord Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfRecord Interface : Item Property

Glossary Item Box

Gets the field value by it's index.

Overload List

Overload | Description
Item(Int32) | Gets the field value by it's index.
Item(String) | Gets the field value by it's name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Interface
IDbfRecord Members


Item(Int32) Property

[image]
ActiveReports 19 .NET Edition
Item(Int32) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfRecord Interface > Item Property : Item(Int32) Property

index
The index of the record's field.

Glossary Item Box

Gets the field value by it's index.

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
C#
object Item(
   int index
) {get;}

Parameters

index
The index of the record's field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Interface
IDbfRecord Members
Overload List


Item(String) Property

[image]
ActiveReports 19 .NET Edition
Item(String) Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.Dbf Namespace > IDbfRecord Interface > Item Property : Item(String) Property

name
The name of the record's field.

Glossary Item Box

Gets the field value by it's name.

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Object
C#
object Item(
   string name
) {get;}

Parameters

name
The name of the record's field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbfRecord Interface
IDbfRecord Members
Overload List


EsriDataDecoder Class

[image]
ActiveReports 19 .NET Edition
EsriDataDecoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriDataDecoder Class

Glossary Item Box

Provides parsing capabilities for ESRI shapefile format. http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf

Object Model

EsriDataDecoder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EsriDataDecoder
C#
public static class EsriDataDecoder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI.EsriDataDecoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


EsriDataDecoder Class Members

[image]
ActiveReports 19 .NET Edition
EsriDataDecoder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriDataDecoder Class

Glossary Item Box

The following tables list the members exposed by EsriDataDecoder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Decode | Overloaded. Decodes the data from esri data sources. Retrieves both spatial and geodataset data.
static (Shared in Visual Basic) | DecodeSpatial | Overloaded. Decodes spatial data represented in ESRI shapefile format into geospatial object model.
static (Shared in Visual Basic) | DetermineOrientation | Returns the orientation of the polygon specified by points.
Top

See Also

Reference

EsriDataDecoder Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


EsriDataDecoder Class Methods

[image]
ActiveReports 19 .NET Edition
EsriDataDecoder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriDataDecoder Class

Glossary Item Box

For a list of all members of this type, see EsriDataDecoder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Decode | Overloaded. Decodes the data from esri data sources. Retrieves both spatial and geodataset data.
static (Shared in Visual Basic) | DecodeSpatial | Overloaded. Decodes spatial data represented in ESRI shapefile format into geospatial object model.
static (Shared in Visual Basic) | DetermineOrientation | Returns the orientation of the polygon specified by points.
Top

See Also

Reference

EsriDataDecoder Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


Decode Method

[image]
ActiveReports 19 .NET Edition
Decode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class : Decode Method

Glossary Item Box

Decodes the data from esri data sources. Retrieves both spatial and geodataset data.

Overload List

Overload | Description
Decode(String) | Decodes the data from esri data sources. Retrieves both spatial and geodataset data.
Decode(String,Single) | Decodes the data from esri data sources. Retrieves both spatial and geodataset data.
Decode(String,Single,Action<Exception>) | Overload for Decode(string filePath, float ratio)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members


Decode(String) Method

[image]
ActiveReports 19 .NET Edition
Decode(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class > Decode Method : Decode(String) Method

filePath
Esri file path.

Glossary Item Box

Decodes the data from esri data sources. Retrieves both spatial and geodataset data.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Decode( _
   ByVal filePath As String _
) As IEnumerable(Of EsriRecord)
C#
public static IEnumerable<EsriRecord> Decode(
   string filePath
)

Parameters

filePath
Esri file path.

Return Value

The collection of esri data source records.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members
Overload List


Decode(String,Single) Method

[image]
ActiveReports 19 .NET Edition
Decode(String,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class > Decode Method : Decode(String,Single) Method

filePath
Esri file path.
ratio
Simplification ratio

Glossary Item Box

Decodes the data from esri data sources. Retrieves both spatial and geodataset data.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Decode( _
   ByVal filePath As String, _
   ByVal ratio As Single _
) As IEnumerable(Of EsriRecord)
C#
public static IEnumerable<EsriRecord> Decode(
   string filePath,
   float ratio
)

Parameters

filePath
Esri file path.
ratio
Simplification ratio

Return Value

The collection of esri data source records.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members
Overload List


Decode(String,Single,Action<Exception>) Method

[image]
ActiveReports 19 .NET Edition
Decode(String,Single,Action<Exception>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class > Decode Method : Decode(String,Single,Action<Exception>) Method

filePath
Esri file path.
ratio
Simplification ratio
errorAction
Error callback handler function.

Glossary Item Box

Overload for Decode(string filePath, float ratio)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Decode( _
   ByVal filePath As String, _
   ByVal ratio As Single, _
   ByVal errorAction As Action(Of Exception) _
) As IEnumerable(Of EsriRecord)
C#
public static IEnumerable<EsriRecord> Decode(
   string filePath,
   float ratio,
   Action<Exception> errorAction
)

Parameters

filePath
Esri file path.
ratio
Simplification ratio
errorAction
Error callback handler function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members
Overload List


DecodeSpatial Method

[image]
ActiveReports 19 .NET Edition
DecodeSpatial Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class : DecodeSpatial Method

Glossary Item Box

Decodes spatial data represented in ESRI shapefile format into geospatial object model.

Overload List

Overload | Description
DecodeSpatial(Stream) | Decodes spatial data represented in ESRI shapefile format into geospatial object model.
DecodeSpatial(Byte[]) | Decodes spatial data represented in ESRI shapefile format into geospatial object model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members


DecodeSpatial(Stream) Method

[image]
ActiveReports 19 .NET Edition
DecodeSpatial(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class > DecodeSpatial Method : DecodeSpatial(Stream) Method

stream
The geospatial data at raw ESRI shapefile representation.

Glossary Item Box

Decodes spatial data represented in ESRI shapefile format into geospatial object model.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DecodeSpatial( _
   ByVal stream As Stream _
) As IEnumerable(Of GeoShape)
C#
public static IEnumerable<GeoShape> DecodeSpatial(
   Stream stream
)

Parameters

stream
The geospatial data at raw ESRI shapefile representation.

Return Value

Decoded geospatial object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members
Overload List


DecodeSpatial(Byte[]) Method

[image]
ActiveReports 19 .NET Edition
DecodeSpatial(Byte[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class > DecodeSpatial Method : DecodeSpatial(Byte[]) Method

data
The geospatial data at raw ESRI shapefile representation.

Glossary Item Box

Decodes spatial data represented in ESRI shapefile format into geospatial object model.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function DecodeSpatial( _
   ByVal data() As Byte _
) As IEnumerable(Of GeoShape)
C#
public static IEnumerable<GeoShape> DecodeSpatial(
   byte[] data
)

Parameters

data
The geospatial data at raw ESRI shapefile representation.

Return Value

Decoded geospatial object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members
Overload List


DetermineOrientation Method

[image]
ActiveReports 19 .NET Edition
DetermineOrientation Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriDataDecoder Class : DetermineOrientation Method

points

Glossary Item Box

Returns the orientation of the polygon specified by points.

Syntax

Visual Basic (Declaration)
Public Shared Function DetermineOrientation( _
   ByVal points As IItemCollection(Of GeoPoint) _
) As EsriDataDecoder.Orientation
C#
public static EsriDataDecoder.Orientation DetermineOrientation(
   IItemCollection<GeoPoint> points
)

Parameters

points

Remarks

The algorithm was found at http://en.wikipedia.org/wiki/Curve_orientation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriDataDecoder Class
EsriDataDecoder Members


EsriRecord Class

[image]
ActiveReports 19 .NET Edition
EsriRecord Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriRecord Class

Glossary Item Box

Represents single ESRI data source record.

Object Model

EsriRecord Class

Syntax

Visual Basic (Declaration)
Public Class EsriRecord
C#
public class EsriRecord

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI.EsriRecord

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriRecord Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


EsriRecord Class Members

[image]
ActiveReports 19 .NET Edition
EsriRecord Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriRecord Class

Glossary Item Box

The following tables list the members exposed by EsriRecord.

Public Constructors

 | Name | Description
Public Constructor | EsriRecord Constructor | Initializes a new instance of the EsriRecord class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets the data attributes.
Public Property | Shape | Gets the spatial data.
Top

See Also

Reference

EsriRecord Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


EsriRecord Constructor

[image]
ActiveReports 19 .NET Edition
EsriRecord Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriRecord Class : EsriRecord Constructor

shape
The spatial data.
data
The data attributes.

Glossary Item Box

Initializes a new instance of the EsriRecord class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal shape As GeoShape, _
   ByVal data As IDbfRecord _
)
C#
public EsriRecord(
   GeoShape shape,
   IDbfRecord data
)

Parameters

shape
The spatial data.
data
The data attributes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriRecord Class
EsriRecord Members


EsriRecord Class Properties

[image]
ActiveReports 19 .NET Edition
EsriRecord Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriRecord Class

Glossary Item Box

For a list of all members of this type, see EsriRecord members.

Public Properties

 | Name | Description
Public Property | Data | Gets the data attributes.
Public Property | Shape | Gets the spatial data.
Top

See Also

Reference

EsriRecord Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriRecord Class : Data Property

Glossary Item Box

Gets the data attributes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As IDbfRecord
C#
public IDbfRecord Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriRecord Class
EsriRecord Members


Shape Property

[image]
ActiveReports 19 .NET Edition
Shape Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace > EsriRecord Class : Shape Property

Glossary Item Box

Gets the spatial data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shape As GeoShape
C#
public GeoShape Shape {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EsriRecord Class
EsriRecord Members


EsriDataDecoder.Orientation Enumeration

[image]
ActiveReports 19 .NET Edition
EsriDataDecoder.Orientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace : EsriDataDecoder.Orientation Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum EsriDataDecoder.Orientation
   Inherits System.Enum
C#
public enum EsriDataDecoder.Orientation : System.Enum

Members

Member | Description
Clockwise | Specifies that orientation is clockwise.
Collinear | Specifies the value indicating when no way to resolve the orientation.
Counterclockwise | Specifies that orientation is counterclockwise.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI.EsriDataDecoder.Orientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Map.Data.ESRI Namespace


WkCoder Class

[image]
ActiveReports 19 .NET Edition
WkCoder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace : WkCoder Class

Glossary Item Box

Provides parsing capabilities for WellKnownBinary format.

Object Model

WkCoder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WkCoder
C#
public static class WkCoder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown.WkCoder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Members
GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace


WkCoder Class Members

[image]
ActiveReports 19 .NET Edition
WkCoder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace : WkCoder Class

Glossary Item Box

The following tables list the members exposed by WkCoder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromBase64String | Converts the provided WKB base64 string encoded data to object model.
static (Shared in Visual Basic) | FromByteArray | Converts the provided WKB binary data to object model.
static (Shared in Visual Basic) | FromString | Converts the provided WKT data to object model.
static (Shared in Visual Basic) | ToBase64String | Converts the provided shape data to base64 encoded string.
static (Shared in Visual Basic) | ToByteArray | Converts the provided WKB shape data to byte array.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the provided shape data into string representation.
Top

See Also

Reference

WkCoder Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace


WkCoder Class Methods

[image]
ActiveReports 19 .NET Edition
WkCoder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace : WkCoder Class

Glossary Item Box

For a list of all members of this type, see WkCoder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromBase64String | Converts the provided WKB base64 string encoded data to object model.
static (Shared in Visual Basic) | FromByteArray | Converts the provided WKB binary data to object model.
static (Shared in Visual Basic) | FromString | Converts the provided WKT data to object model.
static (Shared in Visual Basic) | ToBase64String | Converts the provided shape data to base64 encoded string.
static (Shared in Visual Basic) | ToByteArray | Converts the provided WKB shape data to byte array.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the provided shape data into string representation.
Top

See Also

Reference

WkCoder Class
GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace


FromBase64String Method

[image]
ActiveReports 19 .NET Edition
FromBase64String Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : FromBase64String Method

wkb
The WKB base64 encoded data.

Glossary Item Box

Converts the provided WKB base64 string encoded data to object model.

Syntax

Visual Basic (Declaration)
Public Shared Function FromBase64String( _
   ByVal wkb As String _
) As GeoShape
C#
public static GeoShape FromBase64String(
   string wkb
)

Parameters

wkb
The WKB base64 encoded data.

Return Value

Parsed object model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


FromByteArray Method

[image]
ActiveReports 19 .NET Edition
FromByteArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : FromByteArray Method

wkb
The WKB binary data.

Glossary Item Box

Converts the provided WKB binary data to object model.

Syntax

Visual Basic (Declaration)
Public Shared Function FromByteArray( _
   ByVal wkb() As Byte _
) As GeoShape
C#
public static GeoShape FromByteArray(
   byte[] wkb
)

Parameters

wkb
The WKB binary data.

Return Value

Parsed object model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : FromString Method

shapeString

Glossary Item Box

Converts the provided WKT data to object model.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal shapeString As String _
) As GeoShape
C#
public static GeoShape FromString(
   string shapeString
)

Parameters

shapeString

Return Value

Parsed object model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


ToBase64String Method

[image]
ActiveReports 19 .NET Edition
ToBase64String Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : ToBase64String Method

shape
The shape data.
byteOrder
The byteOrder.

Glossary Item Box

Converts the provided shape data to base64 encoded string.

Syntax

Visual Basic (Declaration)
Public Shared Function ToBase64String( _
   ByVal shape As GeoShape, _
   ByVal byteOrder As WkCoder.WkbByteOrder _
) As String
C#
public static string ToBase64String(
   GeoShape shape,
   WkCoder.WkbByteOrder byteOrder
)

Parameters

shape
The shape data.
byteOrder
The byteOrder.

Return Value

Base64 encoded string with encoded data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


ToByteArray Method

[image]
ActiveReports 19 .NET Edition
ToByteArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : ToByteArray Method

shape
The shape data.
byteOrder
The byte order.

Glossary Item Box

Converts the provided WKB shape data to byte array.

Syntax

Visual Basic (Declaration)
Public Shared Function ToByteArray( _
   ByVal shape As GeoShape, _
   ByVal byteOrder As WkCoder.WkbByteOrder _
) As Byte()
C#
public static byte[] ToByteArray(
   GeoShape shape,
   WkCoder.WkbByteOrder byteOrder
)

Parameters

shape
The shape data.
byteOrder
The byte order.

Return Value

Byte array with encoded data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class : ToString Method

Glossary Item Box

Converts the provided shape data into string representation.

Overload List

Overload | Description
ToString(GeoShape) | Converts the provided shape data into string representation.
ToString(GeoShape,String) | Converts the provided shape data into string representation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members


ToString(GeoShape) Method

[image]
ActiveReports 19 .NET Edition
ToString(GeoShape) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class > ToString Method : ToString(GeoShape) Method

shape

Glossary Item Box

Converts the provided shape data into string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToString( _
   ByVal shape As GeoShape _
) As String
C#
public static string ToString(
   GeoShape shape
)

Parameters

shape

Return Value

Byte array with encoded data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members
Overload List


ToString(GeoShape,String) Method

[image]
ActiveReports 19 .NET Edition
ToString(GeoShape,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace > WkCoder Class > ToString Method : ToString(GeoShape,String) Method

shape
The shape.
format
The format string to apply to point values.

Glossary Item Box

Converts the provided shape data into string representation.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToString( _
   ByVal shape As GeoShape, _
   ByVal format As String _
) As String
C#
public static string ToString(
   GeoShape shape,
   string format
)

Parameters

shape
The shape.
format
The format string to apply to point values.

Return Value

Byte array with encoded data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WkCoder Class
WkCoder Members
Overload List


WkCoder.WkbByteOrder Enumeration

[image]
ActiveReports 19 .NET Edition
WkCoder.WkbByteOrder Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace : WkCoder.WkbByteOrder Enumeration

Glossary Item Box

Describes the order in which a sequence of bytes are stored in computer memory - big-endian and little-endian.

Syntax

Visual Basic (Declaration)
Public Enum WkCoder.WkbByteOrder
   Inherits System.Enum
C#
public enum WkCoder.WkbByteOrder : System.Enum

Members

Member | Description
BigEndian | Big Endian byte order
LittleEndian | Little Endian byte order

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown.WkCoder.WkbByteOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Map.Data.WellKnown Namespace


TileProviderInfo Class

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

Glossary Item Box

Descriptor for map tile provider.

Object Model

TileProviderInfo Class

Syntax

Visual Basic (Declaration)
Public Class TileProviderInfo
C#
public class TileProviderInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders.TileProviderInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Members
GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace


TileProviderInfo Class Members

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

Glossary Item Box

The following tables list the members exposed by TileProviderInfo.

Public Constructors

 | Name | Description
Public Constructor | TileProviderInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Settings | The settings of map tile provider.
Top

Public Properties

 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements ITileProvider
Public Property | DisplayName | The display name of tile provider.
Public Property | Name | The name that can be used to refer to the tile provider in reports.
Top

See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace


TileProviderInfo Constructor

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : TileProviderInfo Constructor

Glossary Item Box

Overload List

Overload | Description
TileProviderInfo Constructor(String,String) | Initializes a new instance of this class.
TileProviderInfo Constructor(String,String,String) | Initializes a new instance of this class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


TileProviderInfo Constructor(String,String)

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Constructor(String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class > TileProviderInfo Constructor : TileProviderInfo Constructor(String,String)

name
The name that can be used to refer to the tile provider in reports.
typeName
Fully assembly-qualified name of the class that implements ITileProvider.

Glossary Item Box

Initializes a new instance of this class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal typeName As String _
)
C#
public TileProviderInfo(
   string name,
   string typeName
)

Parameters

name
The name that can be used to refer to the tile provider in reports.
typeName
Fully assembly-qualified name of the class that implements ITileProvider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members
Overload List


TileProviderInfo Constructor(String,String,String)

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Constructor(String,String,String)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class > TileProviderInfo Constructor : TileProviderInfo Constructor(String,String,String)

name
The name that can be used to refer to the tile provider in reports.
displayName
The display name of map tile provider.
typeName
Fully assembly-qualified name of the class that implements ITileProvider.

Glossary Item Box

Initializes a new instance of this class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal displayName As String, _
   ByVal typeName As String _
)
C#
public TileProviderInfo(
   string name,
   string displayName,
   string typeName
)

Parameters

name
The name that can be used to refer to the tile provider in reports.
displayName
The display name of map tile provider.
typeName
Fully assembly-qualified name of the class that implements ITileProvider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members
Overload List


TileProviderInfo Class Properties

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

Glossary Item Box

For a list of all members of this type, see TileProviderInfo members.

Public Properties

 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements ITileProvider
Public Property | DisplayName | The display name of tile provider.
Public Property | Name | The name that can be used to refer to the tile provider in reports.
Top

See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace


AssemblyQualifiedName Property

[image]
ActiveReports 19 .NET Edition
AssemblyQualifiedName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : AssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements ITileProvider

Syntax

Visual Basic (Declaration)
Public Property AssemblyQualifiedName As String
C#
public string AssemblyQualifiedName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


DisplayName Property

[image]
ActiveReports 19 .NET Edition
DisplayName Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : DisplayName Property

Glossary Item Box

The display name of tile provider.

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : Name Property

Glossary Item Box

The name that can be used to refer to the tile provider in reports.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


TileProviderInfo Class Fields

[image]
ActiveReports 19 .NET Edition
TileProviderInfo Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

Glossary Item Box

For a list of all members of this type, see TileProviderInfo members.

Public Fields

 | Name | Description
Public Field | Settings | The settings of map tile provider.
Top

See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace


Settings Field

[image]
ActiveReports 19 .NET Edition
Settings Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : Settings Field

Glossary Item Box

The settings of map tile provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Settings As NameValueCollection
C#
public readonly NameValueCollection Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


Range Class

[image]
ActiveReports 19 .NET Edition
Range Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Range Class

Glossary Item Box

Represents a qualitative range for SparklineChart.

Object Model

Range Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Range
C#
public sealed class Range

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Sparkline.Range

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Members
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Range Class Members

[image]
ActiveReports 19 .NET Edition
Range Class Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Range Class

Glossary Item Box

The following tables list the members exposed by Range.

Public Constructors

 | Name | Description
Public Constructor | Range Constructor | Initializes a new instance of the Range class with the specified lower and upper bounds and fill style.
Top

Public Fields

 | Name | Description
Public Field | MaxPropertyName |
Public Field | MinPropertyName |
Top

Public Properties

 | Name | Description
Public Property | Backdrop | Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle used to draw the range.
Public Property | IsEmpty | Gets a value indicating whether the range is empty, i.e., the lower bound is equal to the upper bound.
Public Property | LowerBound | Gets the lower bound of the range.
Public Property | UpperBound | Gets the upper bound of the range.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Range Constructor

[image]
ActiveReports 19 .NET Edition
Range Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : Range Constructor

lowValue
The lower bound of the range.
highValue
The upper bound of the range.
fillStyle
The fill style used to draw the range.

Glossary Item Box

Initializes a new instance of the Range class with the specified lower and upper bounds and fill style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lowValue As Double, _
   ByVal highValue As Double, _
   ByVal fillStyle As FillStyle _
)
C#
public Range(
   double lowValue,
   double highValue,
   FillStyle fillStyle
)

Parameters

lowValue
The lower bound of the range.
highValue
The upper bound of the range.
fillStyle
The fill style used to draw the range.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when fillStyle is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Range Class Properties

[image]
ActiveReports 19 .NET Edition
Range Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Range Class

Glossary Item Box

For a list of all members of this type, see Range members.

Public Properties

 | Name | Description
Public Property | Backdrop | Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle used to draw the range.
Public Property | IsEmpty | Gets a value indicating whether the range is empty, i.e., the lower bound is equal to the upper bound.
Public Property | LowerBound | Gets the lower bound of the range.
Public Property | UpperBound | Gets the upper bound of the range.
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Backdrop Property

[image]
ActiveReports 19 .NET Edition
Backdrop Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : Backdrop Property

Glossary Item Box

Gets the GrapeCity.ActiveReports.Rendering.Components.Dashboard.FillStyle used to draw the range.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Backdrop As FillStyle
C#
public FillStyle Backdrop {get;}

Property Value

The fill style used to draw the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


IsEmpty Property

[image]
ActiveReports 19 .NET Edition
IsEmpty Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : IsEmpty Property

Glossary Item Box

Gets a value indicating whether the range is empty, i.e., the lower bound is equal to the upper bound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Property Value

true if the range is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


LowerBound Property

[image]
ActiveReports 19 .NET Edition
LowerBound Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : LowerBound Property

Glossary Item Box

Gets the lower bound of the range.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LowerBound As Double
C#
public double LowerBound {get;}

Property Value

The lower bound of the range as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


UpperBound Property

[image]
ActiveReports 19 .NET Edition
UpperBound Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : UpperBound Property

Glossary Item Box

Gets the upper bound of the range.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpperBound As Double
C#
public double UpperBound {get;}

Property Value

The upper bound of the range as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Range Class Fields

[image]
ActiveReports 19 .NET Edition
Range Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Range Class

Glossary Item Box

For a list of all members of this type, see Range members.

Public Fields

 | Name | Description
Public Field | MaxPropertyName |
Public Field | MinPropertyName |
Top

See Also

Reference

Range Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


MaxPropertyName Field

[image]
ActiveReports 19 .NET Edition
MaxPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : MaxPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MaxPropertyName As String
C#
public const string MaxPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


MinPropertyName Field

[image]
ActiveReports 19 .NET Edition
MinPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Range Class : MinPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MinPropertyName As String
C#
public const string MinPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Range Class
Range Members


Series Class

[image]
ActiveReports 19 .NET Edition
Series Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Series Class

Glossary Item Box

Represents the series of a chart.

Object Model

Series Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Series
C#
public sealed class Series

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Sparkline.Series

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Members
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Series Class Members

[image]
ActiveReports 19 .NET Edition
Series Class Members
See Also Fields Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Series Class

Glossary Item Box

The following tables list the members exposed by Series.

Public Fields

 | Name | Description
Public Field | ValuePropertyName |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the count of series values.
Public Property | Item | Gets the value at the specified index.
Public Property | Statistics | Gets the statistics bound to the current series.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates the dummy series to use in the designer.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Series Class Methods

[image]
ActiveReports 19 .NET Edition
Series Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates the dummy series to use in the designer.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Create(Double[]) Method

[image]
ActiveReports 19 .NET Edition
Create(Double[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Series Class : Create(Double[]) Method

dummyValues
the dummy data to use for a glyph

Glossary Item Box

Creates the dummy series to use in the designer.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal dummyValues() As Double _
) As Series
C#
public static Series Create(
   double[] dummyValues
)

Parameters

dummyValues
the dummy data to use for a glyph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Series Class Properties

[image]
ActiveReports 19 .NET Edition
Series Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of series values.
Public Property | Item | Gets the value at the specified index.
Public Property | Statistics | Gets the statistics bound to the current series.
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Series Class : Count Property

Glossary Item Box

Gets the count of series values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The count of series values as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Series Class : Item Property

index
The index of the value.

Glossary Item Box

Gets the value at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Double
C#
public double this[
   int index
]; {get;}

Parameters

index
The index of the value.

Property Value

The value at the specified index as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Statistics Property

[image]
ActiveReports 19 .NET Edition
Statistics Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Series Class : Statistics Property

Glossary Item Box

Gets the statistics bound to the current series.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statistics As SeriesStatistics
C#
public SeriesStatistics Statistics {get;}

Property Value

The statistics bound to the current series as a SeriesStatistics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Series Class Fields

[image]
ActiveReports 19 .NET Edition
Series Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Fields

 | Name | Description
Public Field | ValuePropertyName |
Top

See Also

Reference

Series Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


ValuePropertyName Field

[image]
ActiveReports 19 .NET Edition
ValuePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > Series Class : ValuePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ValuePropertyName As String
C#
public const string ValuePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


SeriesStatistics Class

[image]
ActiveReports 19 .NET Edition
SeriesStatistics Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SeriesStatistics Class

Glossary Item Box

Represents additional information about bound series.

Object Model

SeriesStatistics Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SeriesStatistics
C#
public sealed class SeriesStatistics

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Sparkline.SeriesStatistics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Members
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


SeriesStatistics Class Members

[image]
ActiveReports 19 .NET Edition
SeriesStatistics Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SeriesStatistics Class

Glossary Item Box

The following tables list the members exposed by SeriesStatistics.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of series values.
Public Property | Max | Gets the maximum value.
Public Property | Min | Gets the minimum value.
Public Property | Sum | Gets the sum of values.
Top

Public Methods

 | Name | Description
Public Method | Accumulate | Processes next series value to update statistics.
Top

See Also

Reference

SeriesStatistics Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


SeriesStatistics Class Methods

[image]
ActiveReports 19 .NET Edition
SeriesStatistics Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SeriesStatistics Class

Glossary Item Box

For a list of all members of this type, see SeriesStatistics members.

Public Methods

 | Name | Description
Public Method | Accumulate | Processes next series value to update statistics.
Top

See Also

Reference

SeriesStatistics Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Accumulate Method

[image]
ActiveReports 19 .NET Edition
Accumulate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SeriesStatistics Class : Accumulate Method

value

Glossary Item Box

Processes next series value to update statistics.

Syntax

Visual Basic (Declaration)
Public Sub Accumulate( _
   ByVal value As Double _
)
C#
public void Accumulate(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Class
SeriesStatistics Members


SeriesStatistics Class Properties

[image]
ActiveReports 19 .NET Edition
SeriesStatistics Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SeriesStatistics Class

Glossary Item Box

For a list of all members of this type, see SeriesStatistics members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of series values.
Public Property | Max | Gets the maximum value.
Public Property | Min | Gets the minimum value.
Public Property | Sum | Gets the sum of values.
Top

See Also

Reference

SeriesStatistics Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SeriesStatistics Class : Count Property

Glossary Item Box

Gets the count of series values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The count of series values as an System.Int32.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Class
SeriesStatistics Members


Max Property

[image]
ActiveReports 19 .NET Edition
Max Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SeriesStatistics Class : Max Property

Glossary Item Box

Gets the maximum value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max As Double
C#
public double Max {get;}

Property Value

The maximum value as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Class
SeriesStatistics Members


Min Property

[image]
ActiveReports 19 .NET Edition
Min Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SeriesStatistics Class : Min Property

Glossary Item Box

Gets the minimum value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Min As Double
C#
public double Min {get;}

Property Value

The minimum value as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Class
SeriesStatistics Members


Sum Property

[image]
ActiveReports 19 .NET Edition
Sum Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SeriesStatistics Class : Sum Property

Glossary Item Box

Gets the sum of values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sum As Double
C#
public double Sum {get;}

Property Value

The sum of values as a System.Double.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStatistics Class
SeriesStatistics Members


SparklineChartConstants Class

[image]
ActiveReports 19 .NET Edition
SparklineChartConstants Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SparklineChartConstants Class

Glossary Item Box

Provides constant values for properties used in a sparkline chart.

Object Model

SparklineChartConstants Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SparklineChartConstants
C#
public static class SparklineChartConstants

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.Sparkline.SparklineChartConstants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Members
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


SparklineChartConstants Class Members

[image]
ActiveReports 19 .NET Edition
SparklineChartConstants Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SparklineChartConstants Class

Glossary Item Box

The following tables list the members exposed by SparklineChartConstants.

Public Fields

 | Name | Description
Public Field | ChartStylePropertyName |
Public Field | MarkerColorPropertyName |
Public Field | MarkerVisibilityPropertyName |
Public Field | MaxColumnWidthPropertyName |
Public Field | RangePropertyName |
Public Field | RangeVisibilityPropertyName |
Public Field | SparklineChartPrefix |
Public Field | TypePropertyName |
Top

See Also

Reference

SparklineChartConstants Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


SparklineChartConstants Class Fields

[image]
ActiveReports 19 .NET Edition
SparklineChartConstants Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SparklineChartConstants Class

Glossary Item Box

For a list of all members of this type, see SparklineChartConstants members.

Public Fields

 | Name | Description
Public Field | ChartStylePropertyName |
Public Field | MarkerColorPropertyName |
Public Field | MarkerVisibilityPropertyName |
Public Field | MaxColumnWidthPropertyName |
Public Field | RangePropertyName |
Public Field | RangeVisibilityPropertyName |
Public Field | SparklineChartPrefix |
Public Field | TypePropertyName |
Top

See Also

Reference

SparklineChartConstants Class
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


ChartStylePropertyName Field

[image]
ActiveReports 19 .NET Edition
ChartStylePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : ChartStylePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ChartStylePropertyName As String
C#
public const string ChartStylePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


MarkerColorPropertyName Field

[image]
ActiveReports 19 .NET Edition
MarkerColorPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : MarkerColorPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MarkerColorPropertyName As String
C#
public const string MarkerColorPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


MarkerVisibilityPropertyName Field

[image]
ActiveReports 19 .NET Edition
MarkerVisibilityPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : MarkerVisibilityPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MarkerVisibilityPropertyName As String
C#
public const string MarkerVisibilityPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


MaxColumnWidthPropertyName Field

[image]
ActiveReports 19 .NET Edition
MaxColumnWidthPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : MaxColumnWidthPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MaxColumnWidthPropertyName As String
C#
public const string MaxColumnWidthPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


RangePropertyName Field

[image]
ActiveReports 19 .NET Edition
RangePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : RangePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RangePropertyName As String
C#
public const string RangePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


RangeVisibilityPropertyName Field

[image]
ActiveReports 19 .NET Edition
RangeVisibilityPropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : RangeVisibilityPropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RangeVisibilityPropertyName As String
C#
public const string RangeVisibilityPropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


SparklineChartPrefix Field

[image]
ActiveReports 19 .NET Edition
SparklineChartPrefix Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : SparklineChartPrefix Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SparklineChartPrefix As String
C#
public const string SparklineChartPrefix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


TypePropertyName Field

[image]
ActiveReports 19 .NET Edition
TypePropertyName Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > SparklineChartConstants Class : TypePropertyName Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const TypePropertyName As String
C#
public const string TypePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SparklineChartConstants Class
SparklineChartConstants Members


SparklineType Enumeration

[image]
ActiveReports 19 .NET Edition
SparklineType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : SparklineType Enumeration

Glossary Item Box

Specifies the type of sparkline chart.

Syntax

Visual Basic (Declaration)
Public Enum SparklineType
   Inherits System.Enum
C#
public enum SparklineType : System.Enum

Members

Member | Description
Area | The area sparkline chart.
Columns | The column sparkline chart.
Line | The line sparkline chart.
StackedBar | The stacked bar sparkline chart.
Whiskers | The whiskers sparkline chart.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Components.Sparkline.SparklineType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


ISparklineChart Interface

[image]
ActiveReports 19 .NET Edition
ISparklineChart Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : ISparklineChart Interface

Glossary Item Box

Represented the boilerplate of a sparkline chart.

Syntax

Visual Basic (Declaration)
Public Interface ISparklineChart
C#
public interface ISparklineChart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Members
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


ISparklineChart Interface Members

[image]
ActiveReports 19 .NET Edition
ISparklineChart Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : ISparklineChart Interface

Glossary Item Box

The following tables list the members exposed by ISparklineChart.

Public Properties

 | Name | Description
Property | FillStyle | Gets the fill style used to draw the chart.
Property | LineStyle | Gets the line style used to draw the chart.
Property | MarkerColor | Gets the color of the last value marker.
Property | MarkerVisibility | Gets a value indicating whether the last value marker is visible.
Property | MaximumColumnWidth | Gets the maximum width of each column.
Property | Range | Gets the qualitative range.
Property | RangeVisibility | Gets a value indicating whether the qualitative range is visible.
Property | Series | Gets the series of the chart.
Property | SparklineType | Gets the sparkline chart type.
Top

See Also

Reference

ISparklineChart Interface
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


ISparklineChart Interface Properties

[image]
ActiveReports 19 .NET Edition
ISparklineChart Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace : ISparklineChart Interface

Glossary Item Box

For a list of all members of this type, see ISparklineChart members.

Public Properties

 | Name | Description
Property | FillStyle | Gets the fill style used to draw the chart.
Property | LineStyle | Gets the line style used to draw the chart.
Property | MarkerColor | Gets the color of the last value marker.
Property | MarkerVisibility | Gets a value indicating whether the last value marker is visible.
Property | MaximumColumnWidth | Gets the maximum width of each column.
Property | Range | Gets the qualitative range.
Property | RangeVisibility | Gets a value indicating whether the qualitative range is visible.
Property | Series | Gets the series of the chart.
Property | SparklineType | Gets the sparkline chart type.
Top

See Also

Reference

ISparklineChart Interface
GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace


FillStyle Property

[image]
ActiveReports 19 .NET Edition
FillStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : FillStyle Property

Glossary Item Box

Gets the fill style used to draw the chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property FillStyle As FillStyle
C#
FillStyle FillStyle {get;}

Property Value

The fill style as a FillStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


LineStyle Property

[image]
ActiveReports 19 .NET Edition
LineStyle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : LineStyle Property

Glossary Item Box

Gets the line style used to draw the chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property LineStyle As LineStyle
C#
LineStyle LineStyle {get;}

Property Value

The line style as a LineStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


MarkerColor Property

[image]
ActiveReports 19 .NET Edition
MarkerColor Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : MarkerColor Property

Glossary Item Box

Gets the color of the last value marker.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerColor As Color
C#
Color MarkerColor {get;}

Property Value

The color of the last value marker as a System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


MarkerVisibility Property

[image]
ActiveReports 19 .NET Edition
MarkerVisibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : MarkerVisibility Property

Glossary Item Box

Gets a value indicating whether the last value marker is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property MarkerVisibility As Boolean
C#
bool MarkerVisibility {get;}

Property Value

true if the last value marker is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


MaximumColumnWidth Property

[image]
ActiveReports 19 .NET Edition
MaximumColumnWidth Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : MaximumColumnWidth Property

Glossary Item Box

Gets the maximum width of each column.

Syntax

Visual Basic (Declaration)
ReadOnly Property MaximumColumnWidth As Length
C#
Length MaximumColumnWidth {get;}

Property Value

The maximum column width as a GrapeCity.ActiveReports.PageReportModel.Length.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


Range Property

[image]
ActiveReports 19 .NET Edition
Range Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : Range Property

Glossary Item Box

Gets the qualitative range.

Syntax

Visual Basic (Declaration)
ReadOnly Property Range As Range
C#
Range Range {get;}

Property Value

The qualitative range as a Range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


RangeVisibility Property

[image]
ActiveReports 19 .NET Edition
RangeVisibility Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : RangeVisibility Property

Glossary Item Box

Gets a value indicating whether the qualitative range is visible.

Syntax

Visual Basic (Declaration)
ReadOnly Property RangeVisibility As Boolean
C#
bool RangeVisibility {get;}

Property Value

true if the qualitative range is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


Series Property

[image]
ActiveReports 19 .NET Edition
Series Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : Series Property

Glossary Item Box

Gets the series of the chart.

Syntax

Visual Basic (Declaration)
ReadOnly Property Series As Series
C#
Series Series {get;}

Property Value

The series of the chart as a Series.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


SparklineType Property

[image]
ActiveReports 19 .NET Edition
SparklineType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.Sparkline Namespace > ISparklineChart Interface : SparklineType Property

Glossary Item Box

Gets the sparkline chart type.

Syntax

Visual Basic (Declaration)
ReadOnly Property SparklineType As SparklineType
C#
SparklineType SparklineType {get;}

Property Value

The type of the sparkline chart as a SparklineType.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISparklineChart Interface
ISparklineChart Members


BookmarkInfo Class

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkInfo Class

Glossary Item Box

Contains bookmark information.

Object Model

BookmarkInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BookmarkInfo
C#
public sealed class BookmarkInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ToC.BookmarkInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Members
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


BookmarkInfo Class Members

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkInfo Class

Glossary Item Box

The following tables list the members exposed by BookmarkInfo.

Public Properties

 | Name | Description
Public Property | Area | Gets the area of the bookmark.
Public Property | LogicalPageNumber | The page number as it evaluated by Globals!PageNumber expression.
Public Property | PhysicalPageNumber | The physical page number.
Top

See Also

Reference

BookmarkInfo Class
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


BookmarkInfo Class Properties

[image]
ActiveReports 19 .NET Edition
BookmarkInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkInfo Class

Glossary Item Box

For a list of all members of this type, see BookmarkInfo members.

Public Properties

 | Name | Description
Public Property | Area | Gets the area of the bookmark.
Public Property | LogicalPageNumber | The page number as it evaluated by Globals!PageNumber expression.
Public Property | PhysicalPageNumber | The physical page number.
Top

See Also

Reference

BookmarkInfo Class
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


Area Property

[image]
ActiveReports 19 .NET Edition
Area Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkInfo Class : Area Property

Glossary Item Box

Gets the area of the bookmark.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Area As RectangleF
C#
public RectangleF Area {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


LogicalPageNumber Property

[image]
ActiveReports 19 .NET Edition
LogicalPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkInfo Class : LogicalPageNumber Property

Glossary Item Box

The page number as it evaluated by Globals!PageNumber expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogicalPageNumber As Integer
C#
public int LogicalPageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


PhysicalPageNumber Property

[image]
ActiveReports 19 .NET Edition
PhysicalPageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkInfo Class : PhysicalPageNumber Property

Glossary Item Box

The physical page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PhysicalPageNumber As Integer
C#
public int PhysicalPageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkInfo Class
BookmarkInfo Members


BookmarkService Class

[image]
ActiveReports 19 .NET Edition
BookmarkService Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkService Class

Glossary Item Box

Manages bookmarks for TOC rendering.

Object Model

BookmarkService Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BookmarkService
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC.IBookmarkService
C#
public sealed class BookmarkService : GrapeCity.ActiveReports.Extensibility.Rendering.Components.ToC.IBookmarkService

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Components.ToC.BookmarkService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkService Members
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


BookmarkService Class Members

[image]
ActiveReports 19 .NET Edition
BookmarkService Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkService Class

Glossary Item Box

The following tables list the members exposed by BookmarkService.

Public Constructors

 | Name | Description
Public Constructor | BookmarkService Constructor | Initializes new instance of BookmarkService class.
Top

Public Methods

 | Name | Description
Public Method | ExtractTocBookmarks | Extracts the bookmarks tree from layout tree.
Public Method | ResolveBookmark | Returns bookmark info.
Public Method | ResolvePageNumber | Resolves page number for specified bookmark.
Top

See Also

Reference

BookmarkService Class
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


BookmarkService Constructor

[image]
ActiveReports 19 .NET Edition
BookmarkService Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkService Class : BookmarkService Constructor

metadata
Dictionary contained toc bookmarks meta data.
startPageNumber
The page number used to start the numeration in the report.

Glossary Item Box

Initializes new instance of BookmarkService class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal metadata As IMetadataDictionary, _
   Optional ByVal startPageNumber As Integer _
)
C#
public BookmarkService(
   IMetadataDictionary metadata,
   int startPageNumber
)

Parameters

metadata
Dictionary contained toc bookmarks meta data.
startPageNumber
The page number used to start the numeration in the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkService Class
BookmarkService Members


BookmarkService Class Methods

[image]
ActiveReports 19 .NET Edition
BookmarkService Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace : BookmarkService Class

Glossary Item Box

For a list of all members of this type, see BookmarkService members.

Public Methods

 | Name | Description
Public Method | ExtractTocBookmarks | Extracts the bookmarks tree from layout tree.
Public Method | ResolveBookmark | Returns bookmark info.
Public Method | ResolvePageNumber | Resolves page number for specified bookmark.
Top

See Also

Reference

BookmarkService Class
GrapeCity.ActiveReports.Rendering.Components.ToC Namespace


ExtractTocBookmarks Method

[image]
ActiveReports 19 .NET Edition
ExtractTocBookmarks Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkService Class : ExtractTocBookmarks Method

Glossary Item Box

Extracts the bookmarks tree from layout tree.

Syntax

Visual Basic (Declaration)
Public Function ExtractTocBookmarks() As TocTreeNode
C#
public TocTreeNode ExtractTocBookmarks()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkService Class
BookmarkService Members


ResolveBookmark Method

[image]
ActiveReports 19 .NET Edition
ResolveBookmark Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkService Class : ResolveBookmark Method

bookmark

Glossary Item Box

Returns bookmark info.

Syntax

Visual Basic (Declaration)
Public Function ResolveBookmark( _
   ByVal bookmark As String _
) As BookmarkInfo
C#
public BookmarkInfo ResolveBookmark(
   string bookmark
)

Parameters

bookmark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkService Class
BookmarkService Members


ResolvePageNumber Method

[image]
ActiveReports 19 .NET Edition
ResolvePageNumber Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Components.ToC Namespace > BookmarkService Class : ResolvePageNumber Method

bookmark
The TOC item bookmark to resolve page number for.

Glossary Item Box

Resolves page number for specified bookmark.

Syntax

Visual Basic (Declaration)
Public Function ResolvePageNumber( _
   ByVal bookmark As String _
) As Nullable(Of Integer)
C#
public Nullable<int> ResolvePageNumber(
   string bookmark
)

Parameters

bookmark
The TOC item bookmark to resolve page number for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkService Class
BookmarkService Members


DataScopeBase Class

[image]
ActiveReports 19 .NET Edition
DataScopeBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : DataScopeBase Class

Glossary Item Box

Provides a base data scope implementation.

Object Model

DataScopeBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataScopeBase
   Implements GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope
C#
public abstract class DataScopeBase : GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Data.DataScopeBase
GrapeCity.ActiveReports.Rendering.Data.TablixData
GrapeCity.ActiveReports.Rendering.Data.TablixDataMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Members
GrapeCity.ActiveReports.Rendering.Data Namespace


DataScopeBase Class Members

[image]
ActiveReports 19 .NET Edition
DataScopeBase Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : DataScopeBase Class

Glossary Item Box

The following tables list the members exposed by DataScopeBase.

Public Properties

 | Name | Description
Public Property | DataContent |
Public Property | EvaluationContext |
Public Property | Id |
Public Property | Name |
Public Property | Parents |
Public Property | Scope |
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | Evaluate |
Public Method | GetFieldValue |
Public Method | GetHashCode |
Public Method | GetRegion |
Public Method | IsValid |
Top

See Also

Reference

DataScopeBase Class
GrapeCity.ActiveReports.Rendering.Data Namespace


DataScopeBase Class Methods

[image]
ActiveReports 19 .NET Edition
DataScopeBase Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : DataScopeBase Class

Glossary Item Box

For a list of all members of this type, see DataScopeBase members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | Evaluate |
Public Method | GetFieldValue |
Public Method | GetHashCode |
Public Method | GetRegion |
Public Method | IsValid |
Top

See Also

Reference

DataScopeBase Class
GrapeCity.ActiveReports.Rendering.Data Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


Evaluate Method

[image]
ActiveReports 19 .NET Edition
Evaluate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Evaluate Method

expression

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Evaluate( _
   ByVal expression As ExpressionInfo _
) As Object
C#
public object Evaluate(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


GetFieldValue Method

[image]
ActiveReports 19 .NET Edition
GetFieldValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : GetFieldValue Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFieldValue( _
   ByVal index As Integer _
) As Object
C#
public object GetFieldValue(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


GetRegion(String) Method

[image]
ActiveReports 19 .NET Edition
GetRegion(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : GetRegion(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetRegion( _
   ByVal name As String _
) As IDataScopeInternal
C#
public IDataScopeInternal GetRegion(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : IsValid Method

expression

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsValid( _
   ByVal expression As ExpressionInfo _
) As Boolean
C#
public bool IsValid(
   ExpressionInfo expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


DataScopeBase Class Properties

[image]
ActiveReports 19 .NET Edition
DataScopeBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : DataScopeBase Class

Glossary Item Box

For a list of all members of this type, see DataScopeBase members.

Public Properties

 | Name | Description
Public Property | DataContent |
Public Property | EvaluationContext |
Public Property | Id |
Public Property | Name |
Public Property | Parents |
Public Property | Scope |
Top

See Also

Reference

DataScopeBase Class
GrapeCity.ActiveReports.Rendering.Data Namespace


DataContent Property

[image]
ActiveReports 19 .NET Edition
DataContent Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : DataContent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataContent As Def.Content
C#
public Def.Content DataContent {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


EvaluationContext Property

[image]
ActiveReports 19 .NET Edition
EvaluationContext Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : EvaluationContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EvaluationContext As IEvaluationContext
C#
public IEvaluationContext EvaluationContext {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


Id Property

[image]
ActiveReports 19 .NET Edition
Id Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As Integer
C#
public int Id {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


Parents Property

[image]
ActiveReports 19 .NET Edition
Parents Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Parents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parents As IDataScope()
C#
public IDataScope[] Parents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


Scope Property

[image]
ActiveReports 19 .NET Edition
Scope Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > DataScopeBase Class : Scope Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scope As DataTree.Scope(Of Object)
C#
public DataTree.Scope<object> Scope {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataScopeBase Class
DataScopeBase Members


TablixData Class

[image]
ActiveReports 19 .NET Edition
TablixData Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixData Class

Glossary Item Box

Tablix-aware custom data implementation.

Object Model

TablixData Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixData
   Inherits DataScopeBase
   Implements GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope
C#
public sealed class TablixData : DataScopeBase, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Data.DataScopeBase
GrapeCity.ActiveReports.Rendering.Data.TablixData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Members
GrapeCity.ActiveReports.Rendering.Data Namespace


TablixData Class Members

[image]
ActiveReports 19 .NET Edition
TablixData Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixData Class

Glossary Item Box

The following tables list the members exposed by TablixData.

Public Constructors

 | Name | Description
Public Constructor | TablixData Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnMembers |
Public Property | Corner |
Public Property | Data |
Public Property | Definition |
Public Property | Name |
Public Property | NoRows |
Public Property | RowMembers |
Top

Public Methods

 | Name | Description
Public Method | GetCell |
Top

See Also

Reference

TablixData Class
GrapeCity.ActiveReports.Rendering.Data Namespace


TablixData Constructor

[image]
ActiveReports 19 .NET Edition
TablixData Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : TablixData Constructor

def
data
evaluationContext
parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal def As Def.Tablix, _
   ByVal data As DataTree.Tablix(Of Object), _
   ByVal evaluationContext As IEvaluationContext, _
   ByVal parent As IDataScope _
)
C#
public TablixData(
   Def.Tablix def,
   DataTree.Tablix<object> data,
   IEvaluationContext evaluationContext,
   IDataScope parent
)

Parameters

def
data
evaluationContext
parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


TablixData Class Methods

[image]
ActiveReports 19 .NET Edition
TablixData Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixData Class

Glossary Item Box

For a list of all members of this type, see TablixData members.

Public Methods

 | Name | Description
Public Method | GetCell |
Top

See Also

Reference

TablixData Class
GrapeCity.ActiveReports.Rendering.Data Namespace


GetCell Method

[image]
ActiveReports 19 .NET Edition
GetCell Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : GetCell Method

rowMember
columnMember

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCell( _
   ByVal rowMember As TablixDataMember, _
   ByVal columnMember As TablixDataMember _
) As IDataScopeInternal
C#
public IDataScopeInternal GetCell(
   TablixDataMember rowMember,
   TablixDataMember columnMember
)

Parameters

rowMember
columnMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


TablixData Class Properties

[image]
ActiveReports 19 .NET Edition
TablixData Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixData Class

Glossary Item Box

For a list of all members of this type, see TablixData members.

Public Properties

 | Name | Description
Public Property | ColumnMembers |
Public Property | Corner |
Public Property | Data |
Public Property | Definition |
Public Property | Name |
Public Property | NoRows |
Public Property | RowMembers |
Top

See Also

Reference

TablixData Class
GrapeCity.ActiveReports.Rendering.Data Namespace


ColumnMembers Property

[image]
ActiveReports 19 .NET Edition
ColumnMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : ColumnMembers Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnMembers As IItemCollection(Of TablixDataMember)
C#
public IItemCollection<TablixDataMember> ColumnMembers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


Corner Property

[image]
ActiveReports 19 .NET Edition
Corner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : Corner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Corner As IDataScopeInternal
C#
public IDataScopeInternal Corner {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As DataTree.Tablix(Of Object)
C#
public DataTree.Tablix<object> Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


Definition Property

[image]
ActiveReports 19 .NET Edition
Definition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : Definition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Definition As Def.Tablix
C#
public Def.Tablix Definition {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Name As String
C#
public new string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


NoRows Property

[image]
ActiveReports 19 .NET Edition
NoRows Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : NoRows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoRows As Boolean
C#
public bool NoRows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


RowMembers Property

[image]
ActiveReports 19 .NET Edition
RowMembers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixData Class : RowMembers Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowMembers As IItemCollection(Of TablixDataMember)
C#
public IItemCollection<TablixDataMember> RowMembers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixData Class
TablixData Members


TablixDataMember Class

[image]
ActiveReports 19 .NET Edition
TablixDataMember Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixDataMember Class

Glossary Item Box

Tablix-aware custom data member implementation.

Object Model

TablixDataMember Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TablixDataMember
   Inherits DataScopeBase
   Implements GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope
C#
public sealed class TablixDataMember : DataScopeBase, GrapeCity.ActiveReports.Core.Rendering.IExpressionEvaluatorService, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataScope

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Data.DataScopeBase
GrapeCity.ActiveReports.Rendering.Data.TablixDataMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Members
GrapeCity.ActiveReports.Rendering.Data Namespace


TablixDataMember Class Members

[image]
ActiveReports 19 .NET Edition
TablixDataMember Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixDataMember Class

Glossary Item Box

The following tables list the members exposed by TablixDataMember.

Public Constructors

 | Name | Description
Public Constructor | TablixDataMember Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data |
Public Property | DefIndex |
Public Property | Definition |
Public Property | Header |
Public Property | Index |
Public Property | IsCollection |
Public Property | Members |
Public Property | Name | Overridden.
Top

See Also

Reference

TablixDataMember Class
GrapeCity.ActiveReports.Rendering.Data Namespace


TablixDataMember Constructor

[image]
ActiveReports 19 .NET Edition
TablixDataMember Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : TablixDataMember Constructor

def
data
defIndex
parent
evalContext
createChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal def As Def.TablixMember, _
   ByVal data As DataTree.TablixMember(Of Object), _
   ByVal defIndex As Integer, _
   ByVal parent As IDataScope, _
   ByVal evalContext As IEvaluationContext, _
   ByVal createChildren As Func(Of TablixDataMember,IEnumerable(Of TablixDataMember)) _
)
C#
public TablixDataMember(
   Def.TablixMember def,
   DataTree.TablixMember<object> data,
   int defIndex,
   IDataScope parent,
   IEvaluationContext evalContext,
   Func<TablixDataMember,IEnumerable<TablixDataMember>> createChildren
)

Parameters

def
data
defIndex
parent
evalContext
createChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


TablixDataMember Class Properties

[image]
ActiveReports 19 .NET Edition
TablixDataMember Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace : TablixDataMember Class

Glossary Item Box

For a list of all members of this type, see TablixDataMember members.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | DefIndex |
Public Property | Definition |
Public Property | Header |
Public Property | Index |
Public Property | IsCollection |
Public Property | Members |
Public Property | Name | Overridden.
Top

See Also

Reference

TablixDataMember Class
GrapeCity.ActiveReports.Rendering.Data Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As DataTree.TablixMember(Of Object)
C#
public DataTree.TablixMember<object> Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


DefIndex Property

[image]
ActiveReports 19 .NET Edition
DefIndex Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : DefIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefIndex As Integer
C#
public int DefIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


Definition Property

[image]
ActiveReports 19 .NET Edition
Definition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Definition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Definition As Def.TablixMember
C#
public Def.TablixMember Definition {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


Header Property

[image]
ActiveReports 19 .NET Edition
Header Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Header Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Header As IDataScopeInternal
C#
public IDataScopeInternal Header {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


Index Property

[image]
ActiveReports 19 .NET Edition
Index Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
C#
public int Index {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


IsCollection Property

[image]
ActiveReports 19 .NET Edition
IsCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : IsCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCollection As Boolean
C#
public bool IsCollection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


Members Property

[image]
ActiveReports 19 .NET Edition
Members Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Members Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Members As IItemCollection(Of TablixDataMember)
C#
public IItemCollection<TablixDataMember> Members {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Data Namespace > TablixDataMember Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Name As String
C#
public override string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TablixDataMember Class
TablixDataMember Members


RecordsAdapter Class

[image]
ActiveReports 19 .NET Edition
RecordsAdapter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : RecordsAdapter Class

Glossary Item Box

Wraps DbDataReader and provides IEnumerable<Record> interface to accept the data.

Object Model

RecordsAdapter Class

Syntax

Visual Basic (Declaration)
Public Class RecordsAdapter
C#
public class RecordsAdapter

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DataProcessing.RecordsAdapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecordsAdapter Members
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


RecordsAdapter Class Members

[image]
ActiveReports 19 .NET Edition
RecordsAdapter Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : RecordsAdapter Class

Glossary Item Box

The following tables list the members exposed by RecordsAdapter.

See Also

Reference

RecordsAdapter Class
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


ReportDataSnapshotExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshotExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : ReportDataSnapshotExtensions Class

Glossary Item Box

Represents an extension methods to work with Data tree.

Object Model

ReportDataSnapshotExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportDataSnapshotExtensions
C#
public static class ReportDataSnapshotExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DataProcessing.ReportDataSnapshotExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshotExtensions Members
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


ReportDataSnapshotExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshotExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : ReportDataSnapshotExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportDataSnapshotExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyInteractivity | Creates a report data snapshot from a given one by applying interactive actions.
Top

See Also

Reference

ReportDataSnapshotExtensions Class
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


ReportDataSnapshotExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportDataSnapshotExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : ReportDataSnapshotExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportDataSnapshotExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyInteractivity | Creates a report data snapshot from a given one by applying interactive actions.
Top

See Also

Reference

ReportDataSnapshotExtensions Class
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


ApplyInteractivity Method

[image]
ActiveReports 19 .NET Edition
ApplyInteractivity Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace > ReportDataSnapshotExtensions Class : ApplyInteractivity Method

snapshot
The initial snapshot.
reportStore
The report store.
actions
Interactive actions to be applied.
customContext
Custom evaluation context objects (custom code, user context, etc.).

Glossary Item Box

Creates a report data snapshot from a given one by applying interactive actions.

Syntax

Visual Basic (Declaration)
Public Shared Function ApplyInteractivity( _
   ByVal snapshot As ReportSnapshot, _
   ByVal reportStore As ReportStore, _
   ByVal actions As IEnumerable(Of ActionKey), _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As ReportDataSnapshot
C#
public static ReportDataSnapshot ApplyInteractivity(
   ReportSnapshot snapshot,
   ReportStore reportStore,
   IEnumerable<ActionKey> actions,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

snapshot
The initial snapshot.
reportStore
The report store.
actions
Interactive actions to be applied.
customContext
Custom evaluation context objects (custom code, user context, etc.).

Return Value

The updated report data snapshot.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataSnapshotExtensions Class
ReportDataSnapshotExtensions Members


LoginPasswordCredentials Structure

[image]
ActiveReports 19 .NET Edition
LoginPasswordCredentials Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : LoginPasswordCredentials Structure

Glossary Item Box

Represents the login and password credentials.

Object Model

LoginPasswordCredentials Structure

Syntax

Visual Basic (Declaration)
Public Structure LoginPasswordCredentials
   Inherits System.ValueType
C#
public struct LoginPasswordCredentials : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.DataProcessing.LoginPasswordCredentials

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoginPasswordCredentials Members
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


LoginPasswordCredentials Structure Members

[image]
ActiveReports 19 .NET Edition
LoginPasswordCredentials Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : LoginPasswordCredentials Structure

Glossary Item Box

The following tables list the members exposed by LoginPasswordCredentials.

Public Constructors

 | Name | Description
Public Constructor | LoginPasswordCredentials Constructor | Initializes a new instance of the LoginPasswordCredentials struct.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

Public Properties

 | Name | Description
Public Property | Login | Gets the user login.
Public Property | Password | Gets the user password.
Top

See Also

Reference

LoginPasswordCredentials Structure
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


LoginPasswordCredentials Constructor

[image]
ActiveReports 19 .NET Edition
LoginPasswordCredentials Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace > LoginPasswordCredentials Structure : LoginPasswordCredentials Constructor

login
The user login
password
The user password

Glossary Item Box

Initializes a new instance of the LoginPasswordCredentials struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal login As String, _
   ByVal password As String _
)
C#
public LoginPasswordCredentials(
   string login,
   string password
)

Parameters

login
The user login
password
The user password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


LoginPasswordCredentials Structure Properties

[image]
ActiveReports 19 .NET Edition
LoginPasswordCredentials Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : LoginPasswordCredentials Structure

Glossary Item Box

For a list of all members of this type, see LoginPasswordCredentials members.

Public Properties

 | Name | Description
Public Property | Login | Gets the user login.
Public Property | Password | Gets the user password.
Top

See Also

Reference

LoginPasswordCredentials Structure
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


Login Property

[image]
ActiveReports 19 .NET Edition
Login Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace > LoginPasswordCredentials Structure : Login Property

Glossary Item Box

Gets the user login.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Login As String
C#
public string Login {get;}

Property Value

A System.String representing the user login.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


Password Property

[image]
ActiveReports 19 .NET Edition
Password Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace > LoginPasswordCredentials Structure : Password Property

Glossary Item Box

Gets the user password.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Password As String
C#
public string Password {get;}

Property Value

A System.String representing the user password.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


LoginPasswordCredentials Structure Fields

[image]
ActiveReports 19 .NET Edition
LoginPasswordCredentials Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace : LoginPasswordCredentials Structure

Glossary Item Box

For a list of all members of this type, see LoginPasswordCredentials members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

See Also

Reference

LoginPasswordCredentials Structure
GrapeCity.ActiveReports.Rendering.DataProcessing Namespace


Empty Field

[image]
ActiveReports 19 .NET Edition
Empty Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing Namespace > LoginPasswordCredentials Structure : Empty Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As LoginPasswordCredentials
C#
public static readonly LoginPasswordCredentials Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


DateTimeConverter Class

[image]
ActiveReports 19 .NET Edition
DateTimeConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DateTimeConverter Class

Glossary Item Box

Converts a System.DateTime object to and from JSON.

Object Model

DateTimeConverter Class

Syntax

Visual Basic (Declaration)
Public Class DateTimeConverter
   Inherits System.Text.Json.Serialization.JsonConverter(Of Date)
C#
public class DateTimeConverter : System.Text.Json.Serialization.JsonConverter<DateTime>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Text.Json.Serialization.JsonConverter
System.Text.Json.Serialization.JsonConverter<T>
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters.DateTimeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverter Members
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


DateTimeConverter Class Members

[image]
ActiveReports 19 .NET Edition
DateTimeConverter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DateTimeConverter Class

Glossary Item Box

The following tables list the members exposed by DateTimeConverter.

Public Constructors

 | Name | Description
Public Constructor | DateTimeConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | Read | Overridden.
Public Method | Write | Overridden.
Top

See Also

Reference

DateTimeConverter Class
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


DateTimeConverter Constructor

[image]
ActiveReports 19 .NET Edition
DateTimeConverter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DateTimeConverter Class : DateTimeConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DateTimeConverter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverter Class
DateTimeConverter Members


DateTimeConverter Class Methods

[image]
ActiveReports 19 .NET Edition
DateTimeConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DateTimeConverter Class

Glossary Item Box

For a list of all members of this type, see DateTimeConverter members.

Public Methods

 | Name | Description
Public Method | Read | Overridden.
Public Method | Write | Overridden.
Top

See Also

Reference

DateTimeConverter Class
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


Read Method

[image]
ActiveReports 19 .NET Edition
Read Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DateTimeConverter Class : Read Method

reader
typeToConvert
options

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByRef reader As Utf8JsonReader, _
   ByVal typeToConvert As Type, _
   ByVal options As JsonSerializerOptions _
) As Date
C#
public override DateTime Read(
   ref Utf8JsonReader reader,
   Type typeToConvert,
   JsonSerializerOptions options
)

Parameters

reader
typeToConvert
options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverter Class
DateTimeConverter Members


Write Method

[image]
ActiveReports 19 .NET Edition
Write Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DateTimeConverter Class : Write Method

writer
value
options

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal writer As Utf8JsonWriter, _
   ByVal value As Date, _
   ByVal options As JsonSerializerOptions _
)
C#
public override void Write(
   Utf8JsonWriter writer,
   DateTime value,
   JsonSerializerOptions options
)

Parameters

writer
value
options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverter Class
DateTimeConverter Members


DoubleConverter Class

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DoubleConverter Class

Glossary Item Box

By default, NaN, Infinite, -Infinite are not supported. This converter solves this problem.

Object Model

DoubleConverter Class

Syntax

Visual Basic (Declaration)
Public Class DoubleConverter
   Inherits System.Text.Json.Serialization.JsonConverter(Of Double)
C#
public class DoubleConverter : System.Text.Json.Serialization.JsonConverter<double>

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Text.Json.Serialization.JsonConverter
System.Text.Json.Serialization.JsonConverter<T>
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters.DoubleConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Members
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


DoubleConverter Class Members

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DoubleConverter Class

Glossary Item Box

The following tables list the members exposed by DoubleConverter.

Public Constructors

 | Name | Description
Public Constructor | DoubleConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | Read | Overridden.
Public Method | Write | Overridden.
Top

See Also

Reference

DoubleConverter Class
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


DoubleConverter Constructor

[image]
ActiveReports 19 .NET Edition
DoubleConverter Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DoubleConverter Class : DoubleConverter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleConverter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


DoubleConverter Class Methods

[image]
ActiveReports 19 .NET Edition
DoubleConverter Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace : DoubleConverter Class

Glossary Item Box

For a list of all members of this type, see DoubleConverter members.

Public Methods

 | Name | Description
Public Method | Read | Overridden.
Public Method | Write | Overridden.
Top

See Also

Reference

DoubleConverter Class
GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace


Read Method

[image]
ActiveReports 19 .NET Edition
Read Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DoubleConverter Class : Read Method

reader
typeToConvert
options

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByRef reader As Utf8JsonReader, _
   ByVal typeToConvert As Type, _
   ByVal options As JsonSerializerOptions _
) As Double
C#
public override double Read(
   ref Utf8JsonReader reader,
   Type typeToConvert,
   JsonSerializerOptions options
)

Parameters

reader
typeToConvert
options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


Write Method

[image]
ActiveReports 19 .NET Edition
Write Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.JsonConverters Namespace > DoubleConverter Class : Write Method

writer
value
options

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal writer As Utf8JsonWriter, _
   ByVal value As Double, _
   ByVal options As JsonSerializerOptions _
)
C#
public override void Write(
   Utf8JsonWriter writer,
   double value,
   JsonSerializerOptions options
)

Parameters

writer
value
options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


SnapshotSerializer Class

[image]
ActiveReports 19 .NET Edition
SnapshotSerializer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace : SnapshotSerializer Class

Glossary Item Box

Represents a module containing the implementation of a data tree serializer.

Object Model

SnapshotSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SnapshotSerializer
C#
public static class SnapshotSerializer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence.SnapshotSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Members
GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace


SnapshotSerializer Class Members

[image]
ActiveReports 19 .NET Edition
SnapshotSerializer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace : SnapshotSerializer Class

Glossary Item Box

The following tables list the members exposed by SnapshotSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Overloaded. Loads report snapshot.
static (Shared in Visual Basic) | LoadAsync<T> | Async loads report snapshot.
static (Shared in Visual Basic) | Parse<T> | Parses snapshot from specified string.
static (Shared in Visual Basic) | Save | Overloaded. Save snapshot to specified stream.
static (Shared in Visual Basic) | SaveAsync<T> | Async save snapshot to specified stream.
Top

See Also

Reference

SnapshotSerializer Class
GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace


SnapshotSerializer Class Methods

[image]
ActiveReports 19 .NET Edition
SnapshotSerializer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace : SnapshotSerializer Class

Glossary Item Box

For a list of all members of this type, see SnapshotSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Load | Overloaded. Loads report snapshot.
static (Shared in Visual Basic) | LoadAsync<T> | Async loads report snapshot.
static (Shared in Visual Basic) | Parse<T> | Parses snapshot from specified string.
static (Shared in Visual Basic) | Save | Overloaded. Save snapshot to specified stream.
static (Shared in Visual Basic) | SaveAsync<T> | Async save snapshot to specified stream.
Top

See Also

Reference

SnapshotSerializer Class
GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace


Load Method

[image]
ActiveReports 19 .NET Edition
Load Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class : Load Method

Glossary Item Box

Loads report snapshot.

Overload List

Overload | Description
Load<T>(Stream) | Loads report snapshot.
Load<T>(TextReader) | Loads report snapshot.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members


Load<T>(Stream) Method

T
Snapshot Type
[image]
ActiveReports 19 .NET Edition
Load<T>(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class > Load Method : Load<T>(Stream) Method

input
Input strem

Glossary Item Box

Loads report snapshot.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Load(Of T)( _
   ByVal input As Stream _
) As T
C#
public static T Load<T>(
   Stream input
)

Parameters

input
Input strem

Type Parameters

T
Snapshot Type

Return Value

Snapshot of specified type T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members
Overload List


Load<T>(TextReader) Method

T
Snapshot Type
[image]
ActiveReports 19 .NET Edition
Load<T>(TextReader) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class > Load Method : Load<T>(TextReader) Method

textReader
Text reader

Glossary Item Box

Loads report snapshot.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Load(Of T)( _
   ByVal textReader As TextReader _
) As T
C#
public static T Load<T>(
   TextReader textReader
)

Parameters

textReader
Text reader

Type Parameters

T
Snapshot Type

Return Value

Snapshot of specified type T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members
Overload List


LoadAsync<T> Method

T
[image]
ActiveReports 19 .NET Edition
LoadAsync<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class : LoadAsync<T> Method

input
token

Glossary Item Box

Async loads report snapshot.

Syntax

Visual Basic (Declaration)
Public Shared Function LoadAsync(Of T)( _
   ByVal input As Stream, _
   ByVal token As CancellationToken _
) As ValueTask(Of T)
C#
public static ValueTask<T> LoadAsync<T>(
   Stream input,
   CancellationToken token
)

Parameters

input
token

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members


Parse<T> Method

T
snapshot type
[image]
ActiveReports 19 .NET Edition
Parse<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class : Parse<T> Method

s
input string

Glossary Item Box

Parses snapshot from specified string.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse(Of T)( _
   ByVal s As String _
) As T
C#
public static T Parse<T>(
   string s
)

Parameters

s
input string

Type Parameters

T
snapshot type

Return Value

snapshot of specified type T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members


Save Method

[image]
ActiveReports 19 .NET Edition
Save Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class : Save Method

Glossary Item Box

Save snapshot to specified stream.

Overload List

Overload | Description
Save<T>(Stream,T,Boolean) | Save snapshot to specified stream.
Save<T>(TextWriter,T,Boolean) | Save snapshot using specified textwriter.
Save<T>(FileInfo,T,Boolean) | Save snapshot to specified file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members


Save<T>(Stream,T,Boolean) Method

T
snapshot Type
[image]
ActiveReports 19 .NET Edition
Save<T>(Stream,T,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class > Save Method : Save<T>(Stream,T,Boolean) Method

output
output stream
data
snapshot data
formatted
specifies if snapshot data is formatted

Glossary Item Box

Save snapshot to specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Save(Of T)( _
   ByVal output As Stream, _
   ByVal data As T, _
   Optional ByVal formatted As Boolean _
)
C#
public static void Save<T>(
   Stream output,
   T data,
   bool formatted
)

Parameters

output
output stream
data
snapshot data
formatted
specifies if snapshot data is formatted

Type Parameters

T
snapshot Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members
Overload List


Save<T>(TextWriter,T,Boolean) Method

T
snapshot Type
[image]
ActiveReports 19 .NET Edition
Save<T>(TextWriter,T,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class > Save Method : Save<T>(TextWriter,T,Boolean) Method

textWriter
text writer
data
snapshot data
formatted
specifies if snapshot data is formatted

Glossary Item Box

Save snapshot using specified textwriter.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Save(Of T)( _
   ByVal textWriter As TextWriter, _
   ByVal data As T, _
   Optional ByVal formatted As Boolean _
)
C#
public static void Save<T>(
   TextWriter textWriter,
   T data,
   bool formatted
)

Parameters

textWriter
text writer
data
snapshot data
formatted
specifies if snapshot data is formatted

Type Parameters

T
snapshot Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members
Overload List


Save<T>(FileInfo,T,Boolean) Method

T
snapshot Type
[image]
ActiveReports 19 .NET Edition
Save<T>(FileInfo,T,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class > Save Method : Save<T>(FileInfo,T,Boolean) Method

file
output file
data
snapshot data
formatted
specifies if snapshot data is formatted

Glossary Item Box

Save snapshot to specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Save(Of T)( _
   ByVal file As FileInfo, _
   ByVal data As T, _
   Optional ByVal formatted As Boolean _
)
C#
public static void Save<T>(
   FileInfo file,
   T data,
   bool formatted
)

Parameters

file
output file
data
snapshot data
formatted
specifies if snapshot data is formatted

Type Parameters

T
snapshot Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members
Overload List


SaveAsync<T> Method

T
[image]
ActiveReports 19 .NET Edition
SaveAsync<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.DataProcessing.Persistence Namespace > SnapshotSerializer Class : SaveAsync<T> Method

output
data
token

Glossary Item Box

Async save snapshot to specified stream.

Syntax

Visual Basic (Declaration)
Public Shared Function SaveAsync(Of T)( _
   ByVal output As Stream, _
   ByVal data As T, _
   ByVal token As CancellationToken _
) As Task
C#
public static Task SaveAsync<T>(
   Stream output,
   T data,
   CancellationToken token
)

Parameters

output
data
token

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SnapshotSerializer Class
SnapshotSerializer Members


DocumentRenderer Class

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DocumentRenderer Class

Glossary Item Box

Base class to render report as document.

Object Model

DocumentRenderer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DocumentRenderer
C#
public sealed class DocumentRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.DocumentRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Members
GrapeCity.ActiveReports.Rendering.Export Namespace


DocumentRenderer Class Members

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DocumentRenderer Class

Glossary Item Box

The following tables list the members exposed by DocumentRenderer.

Public Constructors

 | Name | Description
Public Constructor | DocumentRenderer Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Render | Overloaded. Renders document.
Top

See Also

Reference

DocumentRenderer Class
GrapeCity.ActiveReports.Rendering.Export Namespace


DocumentRenderer Constructor

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class : DocumentRenderer Constructor

Glossary Item Box

Overload List

Overload | Description
DocumentRenderer Constructor(IReport,IGenerator,CancellationToken,Boolean) | Creates new document renderer.
DocumentRenderer Constructor(IReport,IGenerator,CancellationToken) | Creates new document renderer.
DocumentRenderer Constructor(IReport,IGenerator) | Creates new document renderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members


DocumentRenderer Constructor(IReport,IGenerator,CancellationToken,Boolean)

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Constructor(IReport,IGenerator,CancellationToken,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class > DocumentRenderer Constructor : DocumentRenderer Constructor(IReport,IGenerator,CancellationToken,Boolean)

report
Reports to render.
generator
Generator, which should be used to render the report.
cancel
The cancellation token.
forceInBackground
Specifies whether to use a separate thread for layout building.

Glossary Item Box

Creates new document renderer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal generator As IGenerator, _
   ByVal cancel As CancellationToken, _
   ByVal forceInBackground As Boolean _
)
C#
public DocumentRenderer(
   IReport report,
   IGenerator generator,
   CancellationToken cancel,
   bool forceInBackground
)

Parameters

report
Reports to render.
generator
Generator, which should be used to render the report.
cancel
The cancellation token.
forceInBackground
Specifies whether to use a separate thread for layout building.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members
Overload List


DocumentRenderer Constructor(IReport,IGenerator,CancellationToken)

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Constructor(IReport,IGenerator,CancellationToken)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class > DocumentRenderer Constructor : DocumentRenderer Constructor(IReport,IGenerator,CancellationToken)

report
Reports to render.
generator
Generator, which should be used to render the report.
cancel
The cancellation token.

Glossary Item Box

Creates new document renderer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal generator As IGenerator, _
   ByVal cancel As CancellationToken _
)
C#
public DocumentRenderer(
   IReport report,
   IGenerator generator,
   CancellationToken cancel
)

Parameters

report
Reports to render.
generator
Generator, which should be used to render the report.
cancel
The cancellation token.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members
Overload List


DocumentRenderer Constructor(IReport,IGenerator)

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Constructor(IReport,IGenerator)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class > DocumentRenderer Constructor : DocumentRenderer Constructor(IReport,IGenerator)

report
Reports to render.
generator
Generator, which should be used to render the report.

Glossary Item Box

Creates new document renderer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal generator As IGenerator _
)
C#
public DocumentRenderer(
   IReport report,
   IGenerator generator
)

Parameters

report
Reports to render.
generator
Generator, which should be used to render the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members
Overload List


DocumentRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
DocumentRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DocumentRenderer Class

Glossary Item Box

For a list of all members of this type, see DocumentRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Overloaded. Renders document.
Top

See Also

Reference

DocumentRenderer Class
GrapeCity.ActiveReports.Rendering.Export Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class : Render Method

Glossary Item Box

Renders document.

Overload List

Overload | Description
Render(PageGeneratorSettings,LayoutTreeKeeper) | Renders document.
Render(PageGeneratorSettings,IProgress<ProgressInfo>,LayoutTreeKeeper) | Renders document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members


Render(PageGeneratorSettings,LayoutTreeKeeper) Method

[image]
ActiveReports 19 .NET Edition
Render(PageGeneratorSettings,LayoutTreeKeeper) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class > Render Method : Render(PageGeneratorSettings,LayoutTreeKeeper) Method

settings
keeper

Glossary Item Box

Renders document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal settings As PageGeneratorSettings, _
   Optional ByVal keeper As LayoutTreeKeeper _
)
C#
public void Render(
   PageGeneratorSettings settings,
   LayoutTreeKeeper keeper
)

Parameters

settings
keeper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members
Overload List


Render(PageGeneratorSettings,IProgress<ProgressInfo>,LayoutTreeKeeper) Method

[image]
ActiveReports 19 .NET Edition
Render(PageGeneratorSettings,IProgress<ProgressInfo>,LayoutTreeKeeper) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DocumentRenderer Class > Render Method : Render(PageGeneratorSettings,IProgress<ProgressInfo>,LayoutTreeKeeper) Method

settings
progress
keeper

Glossary Item Box

Renders document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal settings As PageGeneratorSettings, _
   ByVal progress As IProgress(Of ProgressInfo), _
   Optional ByVal keeper As LayoutTreeKeeper _
)
C#
public void Render(
   PageGeneratorSettings settings,
   IProgress<ProgressInfo> progress,
   LayoutTreeKeeper keeper
)

Parameters

settings
progress
keeper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRenderer Class
DocumentRenderer Members
Overload List


DrawingCanvasBase Class

[image]
ActiveReports 19 .NET Edition
DrawingCanvasBase Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DrawingCanvasBase Class

Glossary Item Box

Delegates drawing logic to wrapped instance. Used to extend existing canvas with additional logic, for example implement IReportDrawingCanvas.

Object Model

DrawingCanvasBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DrawingCanvasBase
   Implements GrapeCity.ActiveReports.Drawing.IDrawingCanvas
C#
public abstract class DrawingCanvasBase : GrapeCity.ActiveReports.Drawing.IDrawingCanvas

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.DrawingCanvasBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Members
GrapeCity.ActiveReports.Rendering.Export Namespace


DrawingCanvasBase Class Members

[image]
ActiveReports 19 .NET Edition
DrawingCanvasBase Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DrawingCanvasBase Class

Glossary Item Box

The following tables list the members exposed by DrawingCanvasBase.

Public Properties

 | Name | Description
Public Property | SmoothingMode |
Public Property | TextRenderingHint |
Public Property | Transform |
Top

Public Methods

 | Name | Description
Public Method | CreateHatchBrush |
Public Method | CreateImage | Overloaded.
Public Method | CreateLinearGradientBrush | Overloaded.
Public Method | CreatePen | Overloaded.
Public Method | CreateRadialGradientBrush |
Public Method | CreateSolidBrush |
Public Method | Dispose |
Public Method | DrawAndFillPath |
Public Method | DrawEllipse |
Public Method | DrawImage |
Public Method | DrawLine |
Public Method | DrawLines |
Public Method | DrawPolygon |
Public Method | DrawRectangle |
Public Method | DrawString |
Public Method | FillEllipse |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | IntersectClip | Overloaded.
Public Method | PopState |
Public Method | PushState |
Top

See Also

Reference

DrawingCanvasBase Class
GrapeCity.ActiveReports.Rendering.Export Namespace


DrawingCanvasBase Class Methods

[image]
ActiveReports 19 .NET Edition
DrawingCanvasBase Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DrawingCanvasBase Class

Glossary Item Box

For a list of all members of this type, see DrawingCanvasBase members.

Public Methods

 | Name | Description
Public Method | CreateHatchBrush |
Public Method | CreateImage | Overloaded.
Public Method | CreateLinearGradientBrush | Overloaded.
Public Method | CreatePen | Overloaded.
Public Method | CreateRadialGradientBrush |
Public Method | CreateSolidBrush |
Public Method | Dispose |
Public Method | DrawAndFillPath |
Public Method | DrawEllipse |
Public Method | DrawImage |
Public Method | DrawLine |
Public Method | DrawLines |
Public Method | DrawPolygon |
Public Method | DrawRectangle |
Public Method | DrawString |
Public Method | FillEllipse |
Public Method | FillPolygon |
Public Method | FillRectangle |
Public Method | IntersectClip | Overloaded.
Public Method | PopState |
Public Method | PushState |
Top

See Also

Reference

DrawingCanvasBase Class
GrapeCity.ActiveReports.Rendering.Export Namespace


CreateHatchBrush Method

[image]
ActiveReports 19 .NET Edition
CreateHatchBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreateHatchBrush Method

hatchStyle
foreColor
backColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateHatchBrush( _
   ByVal hatchStyle As HatchStyleEx, _
   ByVal foreColor As Color, _
   ByVal backColor As Color _
) As BrushEx
C#
public BrushEx CreateHatchBrush(
   HatchStyleEx hatchStyle,
   Color foreColor,
   Color backColor
)

Parameters

hatchStyle
foreColor
backColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


CreateImage Method

[image]
ActiveReports 19 .NET Edition
CreateImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreateImage Method

Glossary Item Box

Overload List

Overload | Description
CreateImage(ImageInfo) |
CreateImage(ImageInfo,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


CreateImage(ImageInfo) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreateImage Method : CreateImage(ImageInfo) Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateImage( _
   ByVal image As ImageInfo _
) As ImageEx
C#
public ImageEx CreateImage(
   ImageInfo image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreateImage(ImageInfo,String) Method

[image]
ActiveReports 19 .NET Edition
CreateImage(ImageInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreateImage Method : CreateImage(ImageInfo,String) Method

image
cacheId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateImage( _
   ByVal image As ImageInfo, _
   ByVal cacheId As String _
) As ImageEx
C#
public ImageEx CreateImage(
   ImageInfo image,
   string cacheId
)

Parameters

image
cacheId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreateLinearGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreateLinearGradientBrush Method

Glossary Item Box

Overload List

Overload | Description
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) |
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,BlendEx) Method

point1
point2
color1
color2
blend

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   Optional ByVal blend As BlendEx _
) As BrushEx
C#
public BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   BlendEx blend
)

Parameters

point1
point2
color1
color2
blend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

[image]
ActiveReports 19 .NET Edition
CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointF,PointF,Color,Color,IEnumerable<GradientStopColor>) Method

point1
point2
color1
color2
stops

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF, _
   ByVal color1 As Color, _
   ByVal color2 As Color, _
   ByVal stops As IEnumerable(Of GradientStopColor) _
) As BrushEx
C#
public BrushEx CreateLinearGradientBrush(
   PointF point1,
   PointF point2,
   Color color1,
   Color color2,
   IEnumerable<GradientStopColor> stops
)

Parameters

point1
point2
color1
color2
stops

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreatePen Method

[image]
ActiveReports 19 .NET Edition
CreatePen Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreatePen Method

Glossary Item Box

Overload List

Overload | Description
CreatePen(Color,Single) |
CreatePen(Color) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


CreatePen(Color,Single) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreatePen Method : CreatePen(Color,Single) Method

color
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreatePen( _
   ByVal color As Color, _
   ByVal width As Single _
) As PenEx
C#
public PenEx CreatePen(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreatePen(Color) Method

[image]
ActiveReports 19 .NET Edition
CreatePen(Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > CreatePen Method : CreatePen(Color) Method

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreatePen( _
   ByVal color As Color _
) As PenEx
C#
public PenEx CreatePen(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


CreateRadialGradientBrush Method

[image]
ActiveReports 19 .NET Edition
CreateRadialGradientBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreateRadialGradientBrush Method

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateRadialGradientBrush( _
   ByVal centerPoint As PointF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal centerColor As Color, _
   ByVal surroundingColor As Color _
) As BrushEx
C#
public BrushEx CreateRadialGradientBrush(
   PointF centerPoint,
   float radiusX,
   float radiusY,
   Color centerColor,
   Color surroundingColor
)

Parameters

centerPoint
radiusX
radiusY
centerColor
surroundingColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


CreateSolidBrush Method

[image]
ActiveReports 19 .NET Edition
CreateSolidBrush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : CreateSolidBrush Method

color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateSolidBrush( _
   ByVal color As Color _
) As BrushEx
C#
public BrushEx CreateSolidBrush(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawAndFillPath Method

[image]
ActiveReports 19 .NET Edition
DrawAndFillPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawAndFillPath Method

pen
brush
path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawAndFillPath( _
   ByVal pen As PenEx, _
   ByVal brush As BrushEx, _
   ByVal path As PathEx _
)
C#
public void DrawAndFillPath(
   PenEx pen,
   BrushEx brush,
   PathEx path
)

Parameters

pen
brush
path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawEllipse Method

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
public void DrawEllipse(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawImage Method

image
x
y
width
height
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   Optional ByVal opacity As Single _
)
C#
public virtual void DrawImage(
   ImageEx image,
   float x,
   float y,
   float width,
   float height,
   float opacity
)

Parameters

image
x
y
width
height
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawLine Method

pen
from
to

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
   ByVal pen As PenEx, _
   ByVal from As PointF, _
   ByVal to As PointF _
)
C#
public void DrawLine(
   PenEx pen,
   PointF from,
   PointF to
)

Parameters

pen
from
to

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawLines Method

[image]
ActiveReports 19 .NET Edition
DrawLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawLines Method

pen
polyLine

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawLines( _
   ByVal pen As PenEx, _
   ByVal polyLine() As PointF _
)
C#
public void DrawLines(
   PenEx pen,
   PointF[] polyLine
)

Parameters

pen
polyLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawPolygon Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawPolygon Method

pen
polygon

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawPolygon( _
   ByVal pen As PenEx, _
   ByVal polygon() As PointF _
)
C#
public void DrawPolygon(
   PenEx pen,
   PointF[] polygon
)

Parameters

pen
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawRectangle Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawRectangle Method

pen
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawRectangle( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleF _
)
C#
public void DrawRectangle(
   PenEx pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : DrawString Method

value
font
brush
layoutRectangle
format

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DrawString( _
   ByVal value As String, _
   ByVal font As FontInfo, _
   ByVal brush As BrushEx, _
   ByVal layoutRectangle As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
public virtual void DrawString(
   string value,
   FontInfo font,
   BrushEx brush,
   RectangleF layoutRectangle,
   StringFormatEx format
)

Parameters

value
font
brush
layoutRectangle
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


FillEllipse Method

[image]
ActiveReports 19 .NET Edition
FillEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : FillEllipse Method

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public void FillEllipse(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : FillPolygon Method

brush
polygon

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillPolygon( _
   ByVal brush As BrushEx, _
   ByVal polygon() As PointF _
)
C#
public void FillPolygon(
   BrushEx brush,
   PointF[] polygon
)

Parameters

brush
polygon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : FillRectangle Method

brush
rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillRectangle( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleF _
)
C#
public void FillRectangle(
   BrushEx brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


IntersectClip Method

[image]
ActiveReports 19 .NET Edition
IntersectClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : IntersectClip Method

Glossary Item Box

Overload List

Overload | Description
IntersectClip(RectangleF) |
IntersectClip(PathEx) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


IntersectClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > IntersectClip Method : IntersectClip(RectangleF) Method

rect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal rect As RectangleF _
)
C#
public void IntersectClip(
   RectangleF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


IntersectClip(PathEx) Method

[image]
ActiveReports 19 .NET Edition
IntersectClip(PathEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class > IntersectClip Method : IntersectClip(PathEx) Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub IntersectClip( _
   ByVal path As PathEx _
)
C#
public void IntersectClip(
   PathEx path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members
Overload List


PopState Method

[image]
ActiveReports 19 .NET Edition
PopState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : PopState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PopState()
C#
public void PopState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


PushState Method

[image]
ActiveReports 19 .NET Edition
PushState Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : PushState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PushState()
C#
public void PushState()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


DrawingCanvasBase Class Properties

[image]
ActiveReports 19 .NET Edition
DrawingCanvasBase Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : DrawingCanvasBase Class

Glossary Item Box

For a list of all members of this type, see DrawingCanvasBase members.

Public Properties

 | Name | Description
Public Property | SmoothingMode |
Public Property | TextRenderingHint |
Public Property | Transform |
Top

See Also

Reference

DrawingCanvasBase Class
GrapeCity.ActiveReports.Rendering.Export Namespace


SmoothingMode Property

[image]
ActiveReports 19 .NET Edition
SmoothingMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : SmoothingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SmoothingMode As SmoothingModeEx
C#
public SmoothingModeEx SmoothingMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


TextRenderingHint Property

[image]
ActiveReports 19 .NET Edition
TextRenderingHint Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : TextRenderingHint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TextRenderingHint As TextRenderingHintEx
C#
public TextRenderingHintEx TextRenderingHint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


Transform Property

[image]
ActiveReports 19 .NET Edition
Transform Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > DrawingCanvasBase Class : Transform Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Transform As Matrix3x2
C#
public Matrix3x2 Transform {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasBase Class
DrawingCanvasBase Members


ItemRenderer Class

[image]
ActiveReports 19 .NET Edition
ItemRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ItemRenderer Class

Glossary Item Box

Renders a single item, not a complete report.

Object Model

ItemRenderer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ItemRenderer
C#
public sealed class ItemRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.ItemRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemRenderer Members
GrapeCity.ActiveReports.Rendering.Export Namespace


ItemRenderer Class Members

[image]
ActiveReports 19 .NET Edition
ItemRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ItemRenderer Class

Glossary Item Box

The following tables list the members exposed by ItemRenderer.

Public Constructors

 | Name | Description
Public Constructor | ItemRenderer Constructor | Initializes a new instance of the ItemRenderer class with the specified layout area and generator.
Top

Public Methods

 | Name | Description
Public Method | Render | Renders the specified area.
Top

See Also

Reference

ItemRenderer Class
GrapeCity.ActiveReports.Rendering.Export Namespace


ItemRenderer Constructor

[image]
ActiveReports 19 .NET Edition
ItemRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > ItemRenderer Class : ItemRenderer Constructor

area
The area to render.
generator
The generator to use for rendering the area.

Glossary Item Box

Initializes a new instance of the ItemRenderer class with the specified layout area and generator.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal area As ILayoutArea, _
   ByVal generator As IGenerator _
)
C#
public ItemRenderer(
   ILayoutArea area,
   IGenerator generator
)

Parameters

area
The area to render.
generator
The generator to use for rendering the area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemRenderer Class
ItemRenderer Members


ItemRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
ItemRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ItemRenderer Class

Glossary Item Box

For a list of all members of this type, see ItemRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Renders the specified area.
Top

See Also

Reference

ItemRenderer Class
GrapeCity.ActiveReports.Rendering.Export Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > ItemRenderer Class : Render Method

target
The target device kind.
doContent
If set to true, renders the content of the area. Default is true.
doBackground
If set to true, renders the background of the area. Default is true.
doBorders
If set to true, renders the borders of the area. Default is false.

Glossary Item Box

Renders the specified area.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal target As TargetDeviceKind, _
   Optional ByVal doContent As Boolean, _
   Optional ByVal doBackground As Boolean, _
   Optional ByVal doBorders As Boolean _
)
C#
public void Render(
   TargetDeviceKind target,
   bool doContent,
   bool doBackground,
   bool doBorders
)

Parameters

target
The target device kind.
doContent
If set to true, renders the content of the area. Default is true.
doBackground
If set to true, renders the background of the area. Default is true.
doBorders
If set to true, renders the borders of the area. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemRenderer Class
ItemRenderer Members


LayoutEngineExtensions Class

[image]
ActiveReports 19 .NET Edition
LayoutEngineExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutEngineExtensions Class

Glossary Item Box

Provides extension methods for the GrapeCity.ActiveReports.Extensibility.Layout.ILayoutEngine interface.

Object Model

LayoutEngineExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class LayoutEngineExtensions
C#
public static class LayoutEngineExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.LayoutEngineExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEngineExtensions Members
GrapeCity.ActiveReports.Rendering.Export Namespace


LayoutEngineExtensions Class Members

[image]
ActiveReports 19 .NET Edition
LayoutEngineExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutEngineExtensions Class

Glossary Item Box

The following tables list the members exposed by LayoutEngineExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Layout | Creates a report layout using the specified layout engine.
Top

See Also

Reference

LayoutEngineExtensions Class
GrapeCity.ActiveReports.Rendering.Export Namespace


LayoutEngineExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
LayoutEngineExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutEngineExtensions Class

Glossary Item Box

For a list of all members of this type, see LayoutEngineExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Layout | Creates a report layout using the specified layout engine.
Top

See Also

Reference

LayoutEngineExtensions Class
GrapeCity.ActiveReports.Rendering.Export Namespace


Layout Method

[image]
ActiveReports 19 .NET Edition
Layout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutEngineExtensions Class : Layout Method

engine
The layout engine to use.
report
The report to layout.
textMetricsProvider
The text metrics provider to use for layout calculations.
targetDevice
The target device kind for which the layout is being created.
interactivity
The type of interactivity for the layout.
paginated
Indicates whether the layout should be paginated. Default is true.
pro
Indicates whether the layout should use professional features. Default is true.

Glossary Item Box

Creates a report layout using the specified layout engine.

Syntax

Visual Basic (Declaration)
Public Shared Function Layout( _
   ByVal engine As ILayoutEngine, _
   ByVal report As IReport, _
   ByVal textMetricsProvider As ITextMetricsProvider, _
   ByVal targetDevice As TargetDeviceKind, _
   ByVal interactivity As InteractivityType, _
   Optional ByVal paginated As Boolean, _
   Optional ByVal pro As Boolean _
) As IReportLayout
C#
public static IReportLayout Layout(
   ILayoutEngine engine,
   IReport report,
   ITextMetricsProvider textMetricsProvider,
   TargetDeviceKind targetDevice,
   InteractivityType interactivity,
   bool paginated,
   bool pro
)

Parameters

engine
The layout engine to use.
report
The report to layout.
textMetricsProvider
The text metrics provider to use for layout calculations.
targetDevice
The target device kind for which the layout is being created.
interactivity
The type of interactivity for the layout.
paginated
Indicates whether the layout should be paginated. Default is true.
pro
Indicates whether the layout should use professional features. Default is true.

Return Value

An GrapeCity.ActiveReports.Extensibility.Layout.IReportLayout object representing the layout of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEngineExtensions Class
LayoutEngineExtensions Members


LayoutTreeKeeper Class

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutTreeKeeper Class

Glossary Item Box

Interface tries to keep layout tree between sessions to optimize re-rendering time.

Object Model

LayoutTreeKeeper Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayoutTreeKeeper
C#
public sealed class LayoutTreeKeeper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.LayoutTreeKeeper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Members
GrapeCity.ActiveReports.Rendering.Export Namespace


LayoutTreeKeeper Class Members

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper Class Members
See Also Properties Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutTreeKeeper Class

Glossary Item Box

The following tables list the members exposed by LayoutTreeKeeper.

Public Constructors

 | Name | Description
Public Constructor | LayoutTreeKeeper Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsPaginated | Galley/paginated mode.
Public Property | LayoutTree | Gets the tree.
Public Property | Version | Layout rendering tree version.
Top

Public Events

 | Name | Description
Public Event | PageReady | Notify about new page.
Top

See Also

Reference

LayoutTreeKeeper Class
GrapeCity.ActiveReports.Rendering.Export Namespace


LayoutTreeKeeper Constructor

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutTreeKeeper Class : LayoutTreeKeeper Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LayoutTreeKeeper()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Class
LayoutTreeKeeper Members


LayoutTreeKeeper Class Properties

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutTreeKeeper Class

Glossary Item Box

For a list of all members of this type, see LayoutTreeKeeper members.

Public Properties

 | Name | Description
Public Property | IsPaginated | Galley/paginated mode.
Public Property | LayoutTree | Gets the tree.
Public Property | Version | Layout rendering tree version.
Top

See Also

Reference

LayoutTreeKeeper Class
GrapeCity.ActiveReports.Rendering.Export Namespace


IsPaginated Property

[image]
ActiveReports 19 .NET Edition
IsPaginated Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutTreeKeeper Class : IsPaginated Property

Glossary Item Box

Galley/paginated mode.

Syntax

Visual Basic (Declaration)
Public Property IsPaginated As Boolean
C#
public bool IsPaginated {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Class
LayoutTreeKeeper Members


LayoutTree Property

[image]
ActiveReports 19 .NET Edition
LayoutTree Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutTreeKeeper Class : LayoutTree Property

Glossary Item Box

Gets the tree.

Syntax

Visual Basic (Declaration)
Public Property LayoutTree As ILayoutTree
C#
public ILayoutTree LayoutTree {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Class
LayoutTreeKeeper Members


Version Property

[image]
ActiveReports 19 .NET Edition
Version Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutTreeKeeper Class : Version Property

Glossary Item Box

Layout rendering tree version.

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Class
LayoutTreeKeeper Members


LayoutTreeKeeper Class Events

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutTreeKeeper Class

Glossary Item Box

For a list of all members of this type, see LayoutTreeKeeper members.

Public Events

 | Name | Description
Public Event | PageReady | Notify about new page.
Top

See Also

Reference

LayoutTreeKeeper Class
GrapeCity.ActiveReports.Rendering.Export Namespace


PageReady Event

[image]
ActiveReports 19 .NET Edition
PageReady Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > LayoutTreeKeeper Class : PageReady Event

Glossary Item Box

Notify about new page.

Syntax

Visual Basic (Declaration)
Public Event PageReady As LayoutTreeKeeper.RenderingPageEventHandler
C#
public event LayoutTreeKeeper.RenderingPageEventHandler PageReady

Event Data

The event handler receives an argument of type RenderingPageEventArgs containing data related to this event. The following RenderingPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Specifies that further processing should be canceled
CurrentPage | Specifies a page number for which event was raised

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper Class
LayoutTreeKeeper Members


PageGeneratorSettings Class

[image]
ActiveReports 19 .NET Edition
PageGeneratorSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : PageGeneratorSettings Class

Glossary Item Box

Represents settings for page generator.

Object Model

PageGeneratorSettings Class

Syntax

Visual Basic (Declaration)
Public Class PageGeneratorSettings
C#
public class PageGeneratorSettings

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.PageGeneratorSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Members
GrapeCity.ActiveReports.Rendering.Export Namespace


PageGeneratorSettings Class Members

[image]
ActiveReports 19 .NET Edition
PageGeneratorSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : PageGeneratorSettings Class

Glossary Item Box

The following tables list the members exposed by PageGeneratorSettings.

Public Constructors

 | Name | Description
Public Constructor | PageGeneratorSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EvalPosition | Gets or sets the evaluation position.
Public Property | IncludePageMargins | Gets or sets a value indicating whether to include page margins in the rendering.
Public Property | InteractivitySupport | Gets or sets the type of interactivity support.
Public Property | IsDelayedContentSupported | Supports delayed content or not.
Public Property | PageSettings | Gets or sets the page controller settings.
Public Property | ProfessionalEdition | Forces pro license check.
Public Property | TargetDeviceKind | Gets or sets the target device type for rendering.
Public Property | Watermark | Gets or sets the watermark settings.
Top

See Also

Reference

PageGeneratorSettings Class
GrapeCity.ActiveReports.Rendering.Export Namespace


PageGeneratorSettings Constructor

[image]
ActiveReports 19 .NET Edition
PageGeneratorSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : PageGeneratorSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageGeneratorSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


PageGeneratorSettings Class Properties

[image]
ActiveReports 19 .NET Edition
PageGeneratorSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : PageGeneratorSettings Class

Glossary Item Box

For a list of all members of this type, see PageGeneratorSettings members.

Public Properties

 | Name | Description
Public Property | EvalPosition | Gets or sets the evaluation position.
Public Property | IncludePageMargins | Gets or sets a value indicating whether to include page margins in the rendering.
Public Property | InteractivitySupport | Gets or sets the type of interactivity support.
Public Property | IsDelayedContentSupported | Supports delayed content or not.
Public Property | PageSettings | Gets or sets the page controller settings.
Public Property | ProfessionalEdition | Forces pro license check.
Public Property | TargetDeviceKind | Gets or sets the target device type for rendering.
Public Property | Watermark | Gets or sets the watermark settings.
Top

See Also

Reference

PageGeneratorSettings Class
GrapeCity.ActiveReports.Rendering.Export Namespace


EvalPosition Property

[image]
ActiveReports 19 .NET Edition
EvalPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : EvalPosition Property

Glossary Item Box

Gets or sets the evaluation position.

Syntax

Visual Basic (Declaration)
Public Property EvalPosition As EvalPosition
C#
public EvalPosition EvalPosition {get; set;}

Property Value

The evaluation position. The default is GrapeCity.ActiveReports.Extensibility.Layout.EvalPosition.Bottom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


IncludePageMargins Property

[image]
ActiveReports 19 .NET Edition
IncludePageMargins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : IncludePageMargins Property

Glossary Item Box

Gets or sets a value indicating whether to include page margins in the rendering.

Syntax

Visual Basic (Declaration)
Public Property IncludePageMargins As Boolean
C#
public bool IncludePageMargins {get; set;}

Property Value

true if page margins should be included; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


InteractivitySupport Property

[image]
ActiveReports 19 .NET Edition
InteractivitySupport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : InteractivitySupport Property

Glossary Item Box

Gets or sets the type of interactivity support.

Syntax

Visual Basic (Declaration)
Public Property InteractivitySupport As InteractivityType
C#
public InteractivityType InteractivitySupport {get; set;}

Property Value

The interactivity support type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


IsDelayedContentSupported Property

[image]
ActiveReports 19 .NET Edition
IsDelayedContentSupported Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : IsDelayedContentSupported Property

Glossary Item Box

Supports delayed content or not.

Syntax

Visual Basic (Declaration)
Public Property IsDelayedContentSupported As Boolean
C#
public bool IsDelayedContentSupported {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


PageSettings Property

[image]
ActiveReports 19 .NET Edition
PageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : PageSettings Property

Glossary Item Box

Gets or sets the page controller settings.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As PageControllerSettings
C#
public PageControllerSettings PageSettings {get; set;}

Property Value

The page controller settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


ProfessionalEdition Property

[image]
ActiveReports 19 .NET Edition
ProfessionalEdition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : ProfessionalEdition Property

Glossary Item Box

Forces pro license check.

Syntax

Visual Basic (Declaration)
Public Property ProfessionalEdition As Boolean
C#
public bool ProfessionalEdition {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


TargetDeviceKind Property

[image]
ActiveReports 19 .NET Edition
TargetDeviceKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : TargetDeviceKind Property

Glossary Item Box

Gets or sets the target device type for rendering.

Syntax

Visual Basic (Declaration)
Public Property TargetDeviceKind As TargetDeviceKind
C#
public TargetDeviceKind TargetDeviceKind {get; set;}

Property Value

The target device kind. The default is GrapeCity.ActiveReports.PageReportModel.TargetDeviceKind.All.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


Watermark Property

[image]
ActiveReports 19 .NET Edition
Watermark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > PageGeneratorSettings Class : Watermark Property

Glossary Item Box

Gets or sets the watermark settings.

Syntax

Visual Basic (Declaration)
Public Property Watermark As WatermarkSettings
C#
public WatermarkSettings Watermark {get; set;}

Property Value

The watermark settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageGeneratorSettings Class
PageGeneratorSettings Members


ProgressInfo Class

[image]
ActiveReports 19 .NET Edition
ProgressInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ProgressInfo Class

Glossary Item Box

Represents information about the progress of a report export.

Object Model

ProgressInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ProgressInfo
C#
public sealed class ProgressInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.ProgressInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgressInfo Members
GrapeCity.ActiveReports.Rendering.Export Namespace


ProgressInfo Class Members

[image]
ActiveReports 19 .NET Edition
ProgressInfo Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ProgressInfo Class

Glossary Item Box

The following tables list the members exposed by ProgressInfo.

Public Constructors

 | Name | Description
Public Constructor | ProgressInfo Constructor | Initializes a new instance of the ProgressInfo class with the specified page number and last page indicator.
Top

Public Properties

 | Name | Description
Public Property | IsLast | Gets a value indicating whether the current page is the last page in the document.
Public Property | PageNumber | Gets the report export page number.
Top

See Also

Reference

ProgressInfo Class
GrapeCity.ActiveReports.Rendering.Export Namespace


ProgressInfo Constructor

[image]
ActiveReports 19 .NET Edition
ProgressInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > ProgressInfo Class : ProgressInfo Constructor

pageNumber
The report export page number.
isLast
Indicates whether the current page is the last in the document.

Glossary Item Box

Initializes a new instance of the ProgressInfo class with the specified page number and last page indicator.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal isLast As Boolean _
)
C#
public ProgressInfo(
   int pageNumber,
   bool isLast
)

Parameters

pageNumber
The report export page number.
isLast
Indicates whether the current page is the last in the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgressInfo Class
ProgressInfo Members


ProgressInfo Class Properties

[image]
ActiveReports 19 .NET Edition
ProgressInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : ProgressInfo Class

Glossary Item Box

For a list of all members of this type, see ProgressInfo members.

Public Properties

 | Name | Description
Public Property | IsLast | Gets a value indicating whether the current page is the last page in the document.
Public Property | PageNumber | Gets the report export page number.
Top

See Also

Reference

ProgressInfo Class
GrapeCity.ActiveReports.Rendering.Export Namespace


IsLast Property

[image]
ActiveReports 19 .NET Edition
IsLast Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > ProgressInfo Class : IsLast Property

Glossary Item Box

Gets a value indicating whether the current page is the last page in the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLast As Boolean
C#
public bool IsLast {get;}

Property Value

true if the current page is the last page; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgressInfo Class
ProgressInfo Members


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > ProgressInfo Class : PageNumber Property

Glossary Item Box

Gets the report export page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Property Value

An System.Int32 representing the report export page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProgressInfo Class
ProgressInfo Members


TargetDevice Class

[image]
ActiveReports 19 .NET Edition
TargetDevice Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : TargetDevice Class

Glossary Item Box

Represents the device capabilities provider.

Object Model

TargetDevice Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TargetDevice
   Implements GrapeCity.ActiveReports.Extensibility.Layout.ITargetDevice
C#
public sealed class TargetDevice : GrapeCity.ActiveReports.Extensibility.Layout.ITargetDevice

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.TargetDevice

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Members
GrapeCity.ActiveReports.Rendering.Export Namespace


TargetDevice Class Members

[image]
ActiveReports 19 .NET Edition
TargetDevice Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : TargetDevice Class

Glossary Item Box

The following tables list the members exposed by TargetDevice.

Public Constructors

 | Name | Description
Public Constructor | TargetDevice Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | PageInfo |
Top

Public Methods

 | Name | Description
Public Method | AddFeature |
Top

See Also

Reference

TargetDevice Class
GrapeCity.ActiveReports.Rendering.Export Namespace


TargetDevice Constructor

[image]
ActiveReports 19 .NET Edition
TargetDevice Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > TargetDevice Class : TargetDevice Constructor

Glossary Item Box

Overload List

Overload | Description
TargetDevice Constructor(TargetDeviceKind,InteractivityType,SupportedPageInfo,Boolean,Boolean) |
TargetDevice Constructor(IReport,TargetDeviceKind,InteractivityType,Boolean,Boolean,Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Class
TargetDevice Members


TargetDevice Constructor(TargetDeviceKind,InteractivityType,SupportedPageInfo,Boolean,Boolean)

[image]
ActiveReports 19 .NET Edition
TargetDevice Constructor(TargetDeviceKind,InteractivityType,SupportedPageInfo,Boolean,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > TargetDevice Class > TargetDevice Constructor : TargetDevice Constructor(TargetDeviceKind,InteractivityType,SupportedPageInfo,Boolean,Boolean)

target
interactivity
pageInfo
paginated
pro

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal target As TargetDeviceKind, _
   ByVal interactivity As InteractivityType, _
   ByVal pageInfo As SupportedPageInfo, _
   ByVal paginated As Boolean, _
   ByVal pro As Boolean _
)
C#
public TargetDevice(
   TargetDeviceKind target,
   InteractivityType interactivity,
   SupportedPageInfo pageInfo,
   bool paginated,
   bool pro
)

Parameters

target
interactivity
pageInfo
paginated
pro

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Class
TargetDevice Members
Overload List


TargetDevice Constructor(IReport,TargetDeviceKind,InteractivityType,Boolean,Boolean,Boolean)

[image]
ActiveReports 19 .NET Edition
TargetDevice Constructor(IReport,TargetDeviceKind,InteractivityType,Boolean,Boolean,Boolean)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > TargetDevice Class > TargetDevice Constructor : TargetDevice Constructor(IReport,TargetDeviceKind,InteractivityType,Boolean,Boolean,Boolean)

report
target
interactivity
includePageMargins
paginated
pro

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As IReport, _
   ByVal target As TargetDeviceKind, _
   ByVal interactivity As InteractivityType, _
   ByVal includePageMargins As Boolean, _
   ByVal paginated As Boolean, _
   ByVal pro As Boolean _
)
C#
public TargetDevice(
   IReport report,
   TargetDeviceKind target,
   InteractivityType interactivity,
   bool includePageMargins,
   bool paginated,
   bool pro
)

Parameters

report
target
interactivity
includePageMargins
paginated
pro

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Class
TargetDevice Members
Overload List


TargetDevice Class Methods

[image]
ActiveReports 19 .NET Edition
TargetDevice Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : TargetDevice Class

Glossary Item Box

For a list of all members of this type, see TargetDevice members.

Public Methods

 | Name | Description
Public Method | AddFeature |
Top

See Also

Reference

TargetDevice Class
GrapeCity.ActiveReports.Rendering.Export Namespace


AddFeature Method

[image]
ActiveReports 19 .NET Edition
AddFeature Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > TargetDevice Class : AddFeature Method

feature
device

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddFeature( _
   ByVal feature As Features, _
   ByVal device As DeviceCapabilities _
)
C#
public void AddFeature(
   Features feature,
   DeviceCapabilities device
)

Parameters

feature
device

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Class
TargetDevice Members


TargetDevice Class Properties

[image]
ActiveReports 19 .NET Edition
TargetDevice Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : TargetDevice Class

Glossary Item Box

For a list of all members of this type, see TargetDevice members.

Public Properties

 | Name | Description
Public Property | PageInfo |
Top

See Also

Reference

TargetDevice Class
GrapeCity.ActiveReports.Rendering.Export Namespace


PageInfo Property

[image]
ActiveReports 19 .NET Edition
PageInfo Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > TargetDevice Class : PageInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageInfo As SupportedPageInfo
C#
public SupportedPageInfo PageInfo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TargetDevice Class
TargetDevice Members


InteractivityType Enumeration

[image]
ActiveReports 19 .NET Edition
InteractivityType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : InteractivityType Enumeration

Glossary Item Box

Allows to choose interactivity strategy.

Syntax

Visual Basic (Declaration)
Public Enum InteractivityType
   Inherits System.Enum
C#
public enum InteractivityType : System.Enum

Members

Member | Description
BuiltinHyperlinks | File-level interactivity only.
InteractivityAreas | Application-level interactivity.
None | No interactivity

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Export.InteractivityType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Export Namespace


IActionRenderingSupported Interface

[image]
ActiveReports 19 .NET Edition
IActionRenderingSupported Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IActionRenderingSupported Interface

Glossary Item Box

Additional to IGenerator interface to render arbitrary action (ApplyParameters for now)

Syntax

Visual Basic (Declaration)
Public Interface IActionRenderingSupported
C#
public interface IActionRenderingSupported

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionRenderingSupported Members
GrapeCity.ActiveReports.Rendering.Export Namespace


IActionRenderingSupported Interface Members

[image]
ActiveReports 19 .NET Edition
IActionRenderingSupported Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IActionRenderingSupported Interface

Glossary Item Box

The following tables list the members exposed by IActionRenderingSupported.

Public Methods

 | Name | Description
Method | AddAction | Renders action.
Top

See Also

Reference

IActionRenderingSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


IActionRenderingSupported Interface Methods

[image]
ActiveReports 19 .NET Edition
IActionRenderingSupported Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IActionRenderingSupported Interface

Glossary Item Box

For a list of all members of this type, see IActionRenderingSupported members.

Public Methods

 | Name | Description
Method | AddAction | Renders action.
Top

See Also

Reference

IActionRenderingSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


AddAction Method

[image]
ActiveReports 19 .NET Edition
AddAction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IActionRenderingSupported Interface : AddAction Method

pageNumber
Source page index.
area
Source area in twips
actionBase
Action to be rendered.

Glossary Item Box

Renders action.

Syntax

Visual Basic (Declaration)
Function AddAction( _
   ByVal pageNumber As Integer, _
   ByVal area As RectangleF, _
   ByVal actionBase As ActionBase _
) As Boolean
C#
bool AddAction(
   int pageNumber,
   RectangleF area,
   ActionBase actionBase
)

Parameters

pageNumber
Source page index.
area
Source area in twips
actionBase
Action to be rendered.

Return Value

True if action was rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionRenderingSupported Interface
IActionRenderingSupported Members


IGenerator Interface

[image]
ActiveReports 19 .NET Edition
IGenerator Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IGenerator Interface

Glossary Item Box

Pages generator.

Syntax

Visual Basic (Declaration)
Public Interface IGenerator
C#
public interface IGenerator

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Members
GrapeCity.ActiveReports.Rendering.Export Namespace


IGenerator Interface Members

[image]
ActiveReports 19 .NET Edition
IGenerator Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IGenerator Interface

Glossary Item Box

The following tables list the members exposed by IGenerator.

Public Properties

 | Name | Description
Property | InteractivityRenderer | Interactivity renderer.
Property | MetricsProvider | Metrics provider.
Property | RenderersFactory | Report items renderers factory.
Top

Public Methods

 | Name | Description
Method | Init | Init.
Method | NewPage | Starts new page.
Top

See Also

Reference

IGenerator Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


IGenerator Interface Methods

[image]
ActiveReports 19 .NET Edition
IGenerator Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IGenerator Interface

Glossary Item Box

For a list of all members of this type, see IGenerator members.

Public Methods

 | Name | Description
Method | Init | Init.
Method | NewPage | Starts new page.
Top

See Also

Reference

IGenerator Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


Init Method

[image]
ActiveReports 19 .NET Edition
Init Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IGenerator Interface : Init Method

report
Report to render.

Glossary Item Box

Init.

Syntax

Visual Basic (Declaration)
Sub Init( _
   ByVal report As IReport _
)
C#
void Init(
   IReport report
)

Parameters

report
Report to render.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Interface
IGenerator Members


NewPage Method

[image]
ActiveReports 19 .NET Edition
NewPage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IGenerator Interface : NewPage Method

pageNumber
Page number.
pageSize
Page size in twips.

Glossary Item Box

Starts new page.

Syntax

Visual Basic (Declaration)
Function NewPage( _
   ByVal pageNumber As Integer, _
   ByVal pageSize As SizeF _
) As IDrawingCanvas
C#
IDrawingCanvas NewPage(
   int pageNumber,
   SizeF pageSize
)

Parameters

pageNumber
Page number.
pageSize
Page size in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Interface
IGenerator Members


IGenerator Interface Properties

[image]
ActiveReports 19 .NET Edition
IGenerator Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IGenerator Interface

Glossary Item Box

For a list of all members of this type, see IGenerator members.

Public Properties

 | Name | Description
Property | InteractivityRenderer | Interactivity renderer.
Property | MetricsProvider | Metrics provider.
Property | RenderersFactory | Report items renderers factory.
Top

See Also

Reference

IGenerator Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


InteractivityRenderer Property

[image]
ActiveReports 19 .NET Edition
InteractivityRenderer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IGenerator Interface : InteractivityRenderer Property

Glossary Item Box

Interactivity renderer.

Syntax

Visual Basic (Declaration)
ReadOnly Property InteractivityRenderer As IInteractivityRenderer
C#
IInteractivityRenderer InteractivityRenderer {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Interface
IGenerator Members


MetricsProvider Property

[image]
ActiveReports 19 .NET Edition
MetricsProvider Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IGenerator Interface : MetricsProvider Property

Glossary Item Box

Metrics provider.

Syntax

Visual Basic (Declaration)
ReadOnly Property MetricsProvider As ITextMetricsProvider
C#
ITextMetricsProvider MetricsProvider {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Interface
IGenerator Members


RenderersFactory Property

[image]
ActiveReports 19 .NET Edition
RenderersFactory Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IGenerator Interface : RenderersFactory Property

Glossary Item Box

Report items renderers factory.

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderersFactory As IRenderersFactory
C#
IRenderersFactory RenderersFactory {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IGenerator Interface
IGenerator Members


IInteractiveSupported Interface

[image]
ActiveReports 19 .NET Edition
IInteractiveSupported Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractiveSupported Interface

Glossary Item Box

Additional to IGenerator interface to render interactive actions (like Slicer)

Syntax

Visual Basic (Declaration)
Public Interface IInteractiveSupported
C#
public interface IInteractiveSupported

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractiveSupported Members
GrapeCity.ActiveReports.Rendering.Export Namespace


IInteractiveSupported Interface Members

[image]
ActiveReports 19 .NET Edition
IInteractiveSupported Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractiveSupported Interface

Glossary Item Box

The following tables list the members exposed by IInteractiveSupported.

Public Methods

 | Name | Description
Method | AddInteractiveGoTo | Adds interactive link.
Top

See Also

Reference

IInteractiveSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


IInteractiveSupported Interface Methods

[image]
ActiveReports 19 .NET Edition
IInteractiveSupported Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractiveSupported Interface

Glossary Item Box

For a list of all members of this type, see IInteractiveSupported members.

Public Methods

 | Name | Description
Method | AddInteractiveGoTo | Adds interactive link.
Top

See Also

Reference

IInteractiveSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


AddInteractiveGoTo Method

[image]
ActiveReports 19 .NET Edition
AddInteractiveGoTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractiveSupported Interface : AddInteractiveGoTo Method

pageNumber
Source page index.
area
Source area in twips
keys
Actions keys.

Glossary Item Box

Adds interactive link.

Syntax

Visual Basic (Declaration)
Sub AddInteractiveGoTo( _
   ByVal pageNumber As Integer, _
   ByVal area As RectangleF, _
   ByVal keys() As String _
)
C#
void AddInteractiveGoTo(
   int pageNumber,
   RectangleF area,
   string[] keys
)

Parameters

pageNumber
Source page index.
area
Source area in twips
keys
Actions keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractiveSupported Interface
IInteractiveSupported Members


IInteractivityRenderer Interface

[image]
ActiveReports 19 .NET Edition
IInteractivityRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractivityRenderer Interface

Glossary Item Box

Represents a renderer for managing interactive elements.

Syntax

Visual Basic (Declaration)
Public Interface IInteractivityRenderer
C#
public interface IInteractivityRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Members
GrapeCity.ActiveReports.Rendering.Export Namespace


IInteractivityRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IInteractivityRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractivityRenderer Interface

Glossary Item Box

The following tables list the members exposed by IInteractivityRenderer.

Public Methods

 | Name | Description
Method | AddBookmark | Adds a bookmark to the document.
Method | AddOutline | Adds an outline entry.
Method | AddSorting | Adds a sorting action to the document.
Method | AddToggle | Adds a toggle action to the document.
Method | DrillthroughGoTo | Starts a drill-through link to navigate to a different report.
Method | UrlGoTo | Starts a hyperlink that navigates to a specified URL.
Top

See Also

Reference

IInteractivityRenderer Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


IInteractivityRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
IInteractivityRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IInteractivityRenderer Interface

Glossary Item Box

For a list of all members of this type, see IInteractivityRenderer members.

Public Methods

 | Name | Description
Method | AddBookmark | Adds a bookmark to the document.
Method | AddOutline | Adds an outline entry.
Method | AddSorting | Adds a sorting action to the document.
Method | AddToggle | Adds a toggle action to the document.
Method | DrillthroughGoTo | Starts a drill-through link to navigate to a different report.
Method | UrlGoTo | Starts a hyperlink that navigates to a specified URL.
Top

See Also

Reference

IInteractivityRenderer Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


AddBookmark Method

[image]
ActiveReports 19 .NET Edition
AddBookmark Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : AddBookmark Method

key
The unique key of the bookmark.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.
targetPage
The index of the target page.
targetArea
The target area in twips on the page.

Glossary Item Box

Adds a bookmark to the document.

Syntax

Visual Basic (Declaration)
Sub AddBookmark( _
   ByVal key As String, _
   ByVal sourcePage As Integer, _
   ByVal sourceArea As RectangleF, _
   ByVal targetPage As Integer, _
   ByVal targetArea As RectangleF _
)
C#
void AddBookmark(
   string key,
   int sourcePage,
   RectangleF sourceArea,
   int targetPage,
   RectangleF targetArea
)

Parameters

key
The unique key of the bookmark.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.
targetPage
The index of the target page.
targetArea
The target area in twips on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


AddOutline Method

[image]
ActiveReports 19 .NET Edition
AddOutline Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : AddOutline Method

key
The unique key of the bookmark.
parentKey
The unique key of the parent bookmark.
targetPage
The index of the target page.
targetArea
The target area in twips on the page.
name
The user-friendly name for the outline entry.

Glossary Item Box

Adds an outline entry.

Syntax

Visual Basic (Declaration)
Sub AddOutline( _
   ByVal key As String, _
   ByVal parentKey As String, _
   ByVal targetPage As Integer, _
   ByVal targetArea As RectangleF, _
   ByVal name As String _
)
C#
void AddOutline(
   string key,
   string parentKey,
   int targetPage,
   RectangleF targetArea,
   string name
)

Parameters

key
The unique key of the bookmark.
parentKey
The unique key of the parent bookmark.
targetPage
The index of the target page.
targetArea
The target area in twips on the page.
name
The user-friendly name for the outline entry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


AddSorting Method

[image]
ActiveReports 19 .NET Edition
AddSorting Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : AddSorting Method

key
The unique key for the sorting action.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Glossary Item Box

Adds a sorting action to the document.

Syntax

Visual Basic (Declaration)
Sub AddSorting( _
   ByVal key As String, _
   ByVal sourcePage As Integer, _
   ByVal sourceArea As RectangleF _
)
C#
void AddSorting(
   string key,
   int sourcePage,
   RectangleF sourceArea
)

Parameters

key
The unique key for the sorting action.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


AddToggle Method

[image]
ActiveReports 19 .NET Edition
AddToggle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : AddToggle Method

key
The unique key for the toggle action.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Glossary Item Box

Adds a toggle action to the document.

Syntax

Visual Basic (Declaration)
Sub AddToggle( _
   ByVal key As String, _
   ByVal sourcePage As Integer, _
   ByVal sourceArea As RectangleF _
)
C#
void AddToggle(
   string key,
   int sourcePage,
   RectangleF sourceArea
)

Parameters

key
The unique key for the toggle action.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


DrillthroughGoTo Method

[image]
ActiveReports 19 .NET Edition
DrillthroughGoTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : DrillthroughGoTo Method

reportName
The name of the target report.
parameters
A dictionary of parameters for the target report.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Glossary Item Box

Starts a drill-through link to navigate to a different report.

Syntax

Visual Basic (Declaration)
Sub DrillthroughGoTo( _
   ByVal reportName As String, _
   ByVal parameters As IDictionary(Of String,Object), _
   ByVal sourcePage As Integer, _
   ByVal sourceArea As RectangleF _
)
C#
void DrillthroughGoTo(
   string reportName,
   IDictionary<string,object> parameters,
   int sourcePage,
   RectangleF sourceArea
)

Parameters

reportName
The name of the target report.
parameters
A dictionary of parameters for the target report.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


UrlGoTo Method

[image]
ActiveReports 19 .NET Edition
UrlGoTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IInteractivityRenderer Interface : UrlGoTo Method

link
The URL to navigate to.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Glossary Item Box

Starts a hyperlink that navigates to a specified URL.

Syntax

Visual Basic (Declaration)
Sub UrlGoTo( _
   ByVal link As String, _
   ByVal sourcePage As Integer, _
   ByVal sourceArea As RectangleF _
)
C#
void UrlGoTo(
   string link,
   int sourcePage,
   RectangleF sourceArea
)

Parameters

link
The URL to navigate to.
sourcePage
The index of the source page.
sourceArea
The source area in twips on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivityRenderer Interface
IInteractivityRenderer Members


IWatermarkSupported Interface

[image]
ActiveReports 19 .NET Edition
IWatermarkSupported Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IWatermarkSupported Interface

Glossary Item Box

Watermark support interface.

Syntax

Visual Basic (Declaration)
Public Interface IWatermarkSupported
C#
public interface IWatermarkSupported

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWatermarkSupported Members
GrapeCity.ActiveReports.Rendering.Export Namespace


IWatermarkSupported Interface Members

[image]
ActiveReports 19 .NET Edition
IWatermarkSupported Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IWatermarkSupported Interface

Glossary Item Box

The following tables list the members exposed by IWatermarkSupported.

Public Methods

 | Name | Description
Method | AddWatermark<T> | Adds watermark.
Top

See Also

Reference

IWatermarkSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


IWatermarkSupported Interface Methods

[image]
ActiveReports 19 .NET Edition
IWatermarkSupported Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : IWatermarkSupported Interface

Glossary Item Box

For a list of all members of this type, see IWatermarkSupported members.

Public Methods

 | Name | Description
Method | AddWatermark<T> | Adds watermark.
Top

See Also

Reference

IWatermarkSupported Interface
GrapeCity.ActiveReports.Rendering.Export Namespace


AddWatermark<T> Method

T
[image]
ActiveReports 19 .NET Edition
AddWatermark<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace > IWatermarkSupported Interface : AddWatermark<T> Method

settings
Watermark settings.
pageSize
Page size.
processWatermark
Watermark processing method.

Glossary Item Box

Adds watermark.

Syntax

Visual Basic (Declaration)
Sub AddWatermark(Of T As Class)( _
   ByVal settings As WatermarkSettings, _
   ByVal pageSize As SizeF, _
   ByVal processWatermark As Action(Of T) _
)
C#
void AddWatermark<T>(
   WatermarkSettings settings,
   SizeF pageSize,
   Action<T> processWatermark
)
where T: class

Parameters

settings
Watermark settings.
pageSize
Page size.
processWatermark
Watermark processing method.

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWatermarkSupported Interface
IWatermarkSupported Members


LayoutTreeKeeper.RenderingPageEventHandler Delegate

[image]
ActiveReports 19 .NET Edition
LayoutTreeKeeper.RenderingPageEventHandler Delegate
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export Namespace : LayoutTreeKeeper.RenderingPageEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayoutTreeKeeper.RenderingPageEventHandler( _
   ByVal sender As Object, _
   ByVal e As RenderingPageEventArgs _
)
C#
public delegate void LayoutTreeKeeper.RenderingPageEventHandler(
   object sender,
   RenderingPageEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutTreeKeeper.RenderingPageEventHandler Members
GrapeCity.ActiveReports.Rendering.Export Namespace


DocumentStreamingRenderer Class

[image]
ActiveReports 19 .NET Edition
DocumentStreamingRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : DocumentStreamingRenderer Class

Glossary Item Box

Object Model

DocumentStreamingRenderer Class

Syntax

Visual Basic (Declaration)
Public Class DocumentStreamingRenderer
C#
public class DocumentStreamingRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.Streaming.DocumentStreamingRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentStreamingRenderer Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


DocumentStreamingRenderer Class Members

[image]
ActiveReports 19 .NET Edition
DocumentStreamingRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : DocumentStreamingRenderer Class

Glossary Item Box

The following tables list the members exposed by DocumentStreamingRenderer.

Public Constructors

 | Name | Description
Public Constructor | DocumentStreamingRenderer Constructor | Initializes a new instance of the DocumentStreamingRenderer class.
Top

Public Methods

 | Name | Description
Public Method | Render | Renders the document.
Top

See Also

Reference

DocumentStreamingRenderer Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


DocumentStreamingRenderer Constructor

[image]
ActiveReports 19 .NET Edition
DocumentStreamingRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > DocumentStreamingRenderer Class : DocumentStreamingRenderer Constructor

textMetricsProvider
The text metrics provider.
generator
The streaming generator.
renderersFactory
The renderers factory.

Glossary Item Box

Initializes a new instance of the DocumentStreamingRenderer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textMetricsProvider As ITextMetricsProvider, _
   ByVal generator As IStreamingGenerator, _
   ByVal renderersFactory As IRenderersFactory _
)
C#
public DocumentStreamingRenderer(
   ITextMetricsProvider textMetricsProvider,
   IStreamingGenerator generator,
   IRenderersFactory renderersFactory
)

Parameters

textMetricsProvider
The text metrics provider.
generator
The streaming generator.
renderersFactory
The renderers factory.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentStreamingRenderer Class
DocumentStreamingRenderer Members


DocumentStreamingRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
DocumentStreamingRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : DocumentStreamingRenderer Class

Glossary Item Box

For a list of all members of this type, see DocumentStreamingRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Renders the document.
Top

See Also

Reference

DocumentStreamingRenderer Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > DocumentStreamingRenderer Class : Render Method

report
The report to render.
settings
The streaming renderer settings.
cancel
The cancellation token to cancel the operation.
progress
The progress reporter.

Glossary Item Box

Renders the document.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal report As IReport, _
   ByVal settings As StreamingRendererSettings, _
   ByVal cancel As CancellationToken, _
   ByVal progress As IProgress(Of ProgressInfo) _
)
C#
public void Render(
   IReport report,
   StreamingRendererSettings settings,
   CancellationToken cancel,
   IProgress<ProgressInfo> progress
)

Parameters

report
The report to render.
settings
The streaming renderer settings.
cancel
The cancellation token to cancel the operation.
progress
The progress reporter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentStreamingRenderer Class
DocumentStreamingRenderer Members


PageInfo Class

[image]
ActiveReports 19 .NET Edition
PageInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : PageInfo Class

Glossary Item Box

Represents information about a page in a document.

Object Model

PageInfo Class

Syntax

Visual Basic (Declaration)
Public Class PageInfo
C#
public class PageInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.Streaming.PageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


PageInfo Class Members

[image]
ActiveReports 19 .NET Edition
PageInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : PageInfo Class

Glossary Item Box

The following tables list the members exposed by PageInfo.

Public Constructors

 | Name | Description
Public Constructor | PageInfo Constructor | Initializes a new instance of the PageInfo class with the specified size and page number.
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number.
Public Property | Size | Gets the size of the page.
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

PageInfo Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


PageInfo Constructor

[image]
ActiveReports 19 .NET Edition
PageInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > PageInfo Class : PageInfo Constructor

size
The size of the page.
pageNumber
The page number.

Glossary Item Box

Initializes a new instance of the PageInfo class with the specified size and page number.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As SizeF, _
   ByVal pageNumber As Integer _
)
C#
public PageInfo(
   SizeF size,
   int pageNumber
)

Parameters

size
The size of the page.
pageNumber
The page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Class
PageInfo Members


PageInfo Class Methods

[image]
ActiveReports 19 .NET Edition
PageInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : PageInfo Class

Glossary Item Box

For a list of all members of this type, see PageInfo members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Top

See Also

Reference

PageInfo Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > PageInfo Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Class
PageInfo Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > PageInfo Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Class
PageInfo Members


PageInfo Class Properties

[image]
ActiveReports 19 .NET Edition
PageInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : PageInfo Class

Glossary Item Box

For a list of all members of this type, see PageInfo members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number.
Public Property | Size | Gets the size of the page.
Top

See Also

Reference

PageInfo Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


PageNumber Property

[image]
ActiveReports 19 .NET Edition
PageNumber Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > PageInfo Class : PageNumber Property

Glossary Item Box

Gets the page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Class
PageInfo Members


Size Property

[image]
ActiveReports 19 .NET Edition
Size Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > PageInfo Class : Size Property

Glossary Item Box

Gets the size of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
C#
public SizeF Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageInfo Class
PageInfo Members


StreamingRendererSettings Class

[image]
ActiveReports 19 .NET Edition
StreamingRendererSettings Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : StreamingRendererSettings Class

Glossary Item Box

Settings for streaming rendering.

Object Model

StreamingRendererSettings Class

Syntax

Visual Basic (Declaration)
Public Class StreamingRendererSettings
C#
public class StreamingRendererSettings

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Export.Streaming.StreamingRendererSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


StreamingRendererSettings Class Members

[image]
ActiveReports 19 .NET Edition
StreamingRendererSettings Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : StreamingRendererSettings Class

Glossary Item Box

The following tables list the members exposed by StreamingRendererSettings.

Public Constructors

 | Name | Description
Public Constructor | StreamingRendererSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EvalPosition | Gets or sets the evaluation position.
Public Property | IncludePageMargins | Gets or sets a value indicating whether to include page margins in the rendering.
Public Property | InteractivitySupport | Gets or sets the type of interactivity support.
Public Property | PageSettings | Gets or sets the page controller settings.
Public Property | TargetDeviceKind | Gets or sets the target device type for rendering.
Public Property | Watermark | Gets or sets the watermark settings.
Top

See Also

Reference

StreamingRendererSettings Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


StreamingRendererSettings Constructor

[image]
ActiveReports 19 .NET Edition
StreamingRendererSettings Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : StreamingRendererSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public StreamingRendererSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


StreamingRendererSettings Class Properties

[image]
ActiveReports 19 .NET Edition
StreamingRendererSettings Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : StreamingRendererSettings Class

Glossary Item Box

For a list of all members of this type, see StreamingRendererSettings members.

Public Properties

 | Name | Description
Public Property | EvalPosition | Gets or sets the evaluation position.
Public Property | IncludePageMargins | Gets or sets a value indicating whether to include page margins in the rendering.
Public Property | InteractivitySupport | Gets or sets the type of interactivity support.
Public Property | PageSettings | Gets or sets the page controller settings.
Public Property | TargetDeviceKind | Gets or sets the target device type for rendering.
Public Property | Watermark | Gets or sets the watermark settings.
Top

See Also

Reference

StreamingRendererSettings Class
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


EvalPosition Property

[image]
ActiveReports 19 .NET Edition
EvalPosition Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : EvalPosition Property

Glossary Item Box

Gets or sets the evaluation position.

Syntax

Visual Basic (Declaration)
Public Property EvalPosition As EvalPosition
C#
public EvalPosition EvalPosition {get; set;}

Property Value

The evaluation position. The default is GrapeCity.ActiveReports.Extensibility.Layout.EvalPosition.Bottom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


IncludePageMargins Property

[image]
ActiveReports 19 .NET Edition
IncludePageMargins Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : IncludePageMargins Property

Glossary Item Box

Gets or sets a value indicating whether to include page margins in the rendering.

Syntax

Visual Basic (Declaration)
Public Property IncludePageMargins As Boolean
C#
public bool IncludePageMargins {get; set;}

Property Value

true if page margins should be included; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


InteractivitySupport Property

[image]
ActiveReports 19 .NET Edition
InteractivitySupport Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : InteractivitySupport Property

Glossary Item Box

Gets or sets the type of interactivity support.

Syntax

Visual Basic (Declaration)
Public Property InteractivitySupport As InteractivityType
C#
public InteractivityType InteractivitySupport {get; set;}

Property Value

The interactivity support type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


PageSettings Property

[image]
ActiveReports 19 .NET Edition
PageSettings Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : PageSettings Property

Glossary Item Box

Gets or sets the page controller settings.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As PageControllerSettings
C#
public PageControllerSettings PageSettings {get; set;}

Property Value

The page controller settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


TargetDeviceKind Property

[image]
ActiveReports 19 .NET Edition
TargetDeviceKind Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : TargetDeviceKind Property

Glossary Item Box

Gets or sets the target device type for rendering.

Syntax

Visual Basic (Declaration)
Public Property TargetDeviceKind As TargetDeviceKind
C#
public TargetDeviceKind TargetDeviceKind {get; set;}

Property Value

The target device kind. The default is GrapeCity.ActiveReports.PageReportModel.TargetDeviceKind.All.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


Watermark Property

[image]
ActiveReports 19 .NET Edition
Watermark Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > StreamingRendererSettings Class : Watermark Property

Glossary Item Box

Gets or sets the watermark settings.

Syntax

Visual Basic (Declaration)
Public Property Watermark As WatermarkSettings
C#
public WatermarkSettings Watermark {get; set;}

Property Value

The watermark settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamingRendererSettings Class
StreamingRendererSettings Members


IInteractivity Interface

[image]
ActiveReports 19 .NET Edition
IInteractivity Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IInteractivity Interface

Glossary Item Box

Represents the interactivity features of a rendered document page.

Syntax

Visual Basic (Declaration)
Public Interface IInteractivity
C#
public interface IInteractivity

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivity Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IInteractivity Interface Members

[image]
ActiveReports 19 .NET Edition
IInteractivity Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IInteractivity Interface

Glossary Item Box

The following tables list the members exposed by IInteractivity.

Public Methods

 | Name | Description
Method | AddAction | Adds an interactive action, such as drillthrough, represented by the GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase class.
Method | AddInteractivity | Adds interactivity features such as sorting or toggling, represented by an action key.
Top

See Also

Reference

IInteractivity Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IInteractivity Interface Methods

[image]
ActiveReports 19 .NET Edition
IInteractivity Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IInteractivity Interface

Glossary Item Box

For a list of all members of this type, see IInteractivity members.

Public Methods

 | Name | Description
Method | AddAction | Adds an interactive action, such as drillthrough, represented by the GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase class.
Method | AddInteractivity | Adds interactivity features such as sorting or toggling, represented by an action key.
Top

See Also

Reference

IInteractivity Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


AddAction Method

[image]
ActiveReports 19 .NET Edition
AddAction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IInteractivity Interface : AddAction Method

action
The action to add.
bounds
The bounds of the area associated with the action.

Glossary Item Box

Adds an interactive action, such as drillthrough, represented by the GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionBase class.

Syntax

Visual Basic (Declaration)
Function AddAction( _
   ByVal action As ActionBase, _
   ByVal bounds As RectangleF _
) As Boolean
C#
bool AddAction(
   ActionBase action,
   RectangleF bounds
)

Parameters

action
The action to add.
bounds
The bounds of the area associated with the action.

Return Value

true if the action was successfully added; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivity Interface
IInteractivity Members


AddInteractivity Method

[image]
ActiveReports 19 .NET Edition
AddInteractivity Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IInteractivity Interface : AddInteractivity Method

actionKey
The key identifying the action.
area
The area associated with the action.

Glossary Item Box

Adds interactivity features such as sorting or toggling, represented by an action key.

Syntax

Visual Basic (Declaration)
Sub AddInteractivity( _
   ByVal actionKey As String, _
   ByVal area As RectangleF _
)
C#
void AddInteractivity(
   string actionKey,
   RectangleF area
)

Parameters

actionKey
The key identifying the action.
area
The area associated with the action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IInteractivity Interface
IInteractivity Members


IPage Interface

[image]
ActiveReports 19 .NET Edition
IPage Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IPage Interface

Glossary Item Box

Represents a page in the document rendering process.

Syntax

Visual Basic (Declaration)
Public Interface IPage
C#
public interface IPage

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IPage Interface Members

[image]
ActiveReports 19 .NET Edition
IPage Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IPage Interface

Glossary Item Box

The following tables list the members exposed by IPage.

Public Properties

 | Name | Description
Property | Canvas | Gets the drawing canvas associated with this page.
Property | Interactivity | Gets the interactivity features associated with this page.
Top

Public Methods

 | Name | Description
Method | Flush | Flushes the current state of the page, finalizing any pending drawing operations.
Top

See Also

Reference

IPage Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IPage Interface Methods

[image]
ActiveReports 19 .NET Edition
IPage Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IPage Interface

Glossary Item Box

For a list of all members of this type, see IPage members.

Public Methods

 | Name | Description
Method | Flush | Flushes the current state of the page, finalizing any pending drawing operations.
Top

See Also

Reference

IPage Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


Flush Method

[image]
ActiveReports 19 .NET Edition
Flush Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IPage Interface : Flush Method

Glossary Item Box

Flushes the current state of the page, finalizing any pending drawing operations.

Syntax

Visual Basic (Declaration)
Sub Flush()
C#
void Flush()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Interface
IPage Members


IPage Interface Properties

[image]
ActiveReports 19 .NET Edition
IPage Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IPage Interface

Glossary Item Box

For a list of all members of this type, see IPage members.

Public Properties

 | Name | Description
Property | Canvas | Gets the drawing canvas associated with this page.
Property | Interactivity | Gets the interactivity features associated with this page.
Top

See Also

Reference

IPage Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


Canvas Property

[image]
ActiveReports 19 .NET Edition
Canvas Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IPage Interface : Canvas Property

Glossary Item Box

Gets the drawing canvas associated with this page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Canvas As IDrawingCanvas
C#
IDrawingCanvas Canvas {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Interface
IPage Members


Interactivity Property

[image]
ActiveReports 19 .NET Edition
Interactivity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IPage Interface : Interactivity Property

Glossary Item Box

Gets the interactivity features associated with this page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Interactivity As IInteractivity
C#
IInteractivity Interactivity {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPage Interface
IPage Members


IStreamingGenerator Interface

[image]
ActiveReports 19 .NET Edition
IStreamingGenerator Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IStreamingGenerator Interface

Glossary Item Box

Interface for streaming generator implementations.

Syntax

Visual Basic (Declaration)
Public Interface IStreamingGenerator
C#
public interface IStreamingGenerator

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStreamingGenerator Members
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IStreamingGenerator Interface Members

[image]
ActiveReports 19 .NET Edition
IStreamingGenerator Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IStreamingGenerator Interface

Glossary Item Box

The following tables list the members exposed by IStreamingGenerator.

Public Properties

 | Name | Description
Property | PatchCollector | Gets the patch collector associated with this generator.
Top

Public Methods

 | Name | Description
Method | CreatePage | Creates a new page based on the provided page information.
Method | Init | Initializes the streaming generator with the specified bookmark service.
Top

See Also

Reference

IStreamingGenerator Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


IStreamingGenerator Interface Methods

[image]
ActiveReports 19 .NET Edition
IStreamingGenerator Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IStreamingGenerator Interface

Glossary Item Box

For a list of all members of this type, see IStreamingGenerator members.

Public Methods

 | Name | Description
Method | CreatePage | Creates a new page based on the provided page information.
Method | Init | Initializes the streaming generator with the specified bookmark service.
Top

See Also

Reference

IStreamingGenerator Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


CreatePage Method

[image]
ActiveReports 19 .NET Edition
CreatePage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IStreamingGenerator Interface : CreatePage Method

pageInfo
The information about the page to create.

Glossary Item Box

Creates a new page based on the provided page information.

Syntax

Visual Basic (Declaration)
Function CreatePage( _
   ByVal pageInfo As PageInfo _
) As IPage
C#
IPage CreatePage(
   PageInfo pageInfo
)

Parameters

pageInfo
The information about the page to create.

Return Value

A new IPage instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStreamingGenerator Interface
IStreamingGenerator Members


Init Method

[image]
ActiveReports 19 .NET Edition
Init Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IStreamingGenerator Interface : Init Method

bookmarkService
The bookmark service to use.

Glossary Item Box

Initializes the streaming generator with the specified bookmark service.

Syntax

Visual Basic (Declaration)
Sub Init( _
   ByVal bookmarkService As IBookmarkService _
)
C#
void Init(
   IBookmarkService bookmarkService
)

Parameters

bookmarkService
The bookmark service to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStreamingGenerator Interface
IStreamingGenerator Members


IStreamingGenerator Interface Properties

[image]
ActiveReports 19 .NET Edition
IStreamingGenerator Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace : IStreamingGenerator Interface

Glossary Item Box

For a list of all members of this type, see IStreamingGenerator members.

Public Properties

 | Name | Description
Property | PatchCollector | Gets the patch collector associated with this generator.
Top

See Also

Reference

IStreamingGenerator Interface
GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace


PatchCollector Property

[image]
ActiveReports 19 .NET Edition
PatchCollector Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Export.Streaming Namespace > IStreamingGenerator Interface : PatchCollector Property

Glossary Item Box

Gets the patch collector associated with this generator.

Syntax

Visual Basic (Declaration)
ReadOnly Property PatchCollector As IPatchCollector
C#
IPatchCollector PatchCollector {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStreamingGenerator Interface
IStreamingGenerator Members


IForkableReportItem Interface

[image]
ActiveReports 19 .NET Edition
IForkableReportItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace : IForkableReportItem Interface

Glossary Item Box

Represents an interface that provides the ability to create a copy of the report item with a new data scope.

Syntax

Visual Basic (Declaration)
Public Interface IForkableReportItem
C#
public interface IForkableReportItem

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForkableReportItem Members
GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace


IForkableReportItem Interface Members

[image]
ActiveReports 19 .NET Edition
IForkableReportItem Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace : IForkableReportItem Interface

Glossary Item Box

The following tables list the members exposed by IForkableReportItem.

Public Methods

 | Name | Description
Method | Fork | Creates a copy of the report item with the specified data scope.
Top

See Also

Reference

IForkableReportItem Interface
GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace


IForkableReportItem Interface Methods

[image]
ActiveReports 19 .NET Edition
IForkableReportItem Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace : IForkableReportItem Interface

Glossary Item Box

For a list of all members of this type, see IForkableReportItem members.

Public Methods

 | Name | Description
Method | Fork | Creates a copy of the report item with the specified data scope.
Top

See Also

Reference

IForkableReportItem Interface
GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace


Fork Method

[image]
ActiveReports 19 .NET Edition
Fork Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Facade.RenderingTree Namespace > IForkableReportItem Interface : Fork Method

dataScope
The data scope to be applied to the new report item.

Glossary Item Box

Creates a copy of the report item with the specified data scope.

Syntax

Visual Basic (Declaration)
Function Fork( _
   ByVal dataScope As IDataScope _
) As IReportItem
C#
IReportItem Fork(
   IDataScope dataScope
)

Parameters

dataScope
The data scope to be applied to the new report item.

Return Value

A new GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem instance with the specified data scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForkableReportItem Interface
IForkableReportItem Members


AccessibleContainer Class

[image]
ActiveReports 19 .NET Edition
AccessibleContainer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleContainer Class

Glossary Item Box

Defines properties for Container

Object Model

AccessibleContainer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleContainer
   Inherits AccessibleElement
C#
public sealed class AccessibleContainer : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleContainer Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleContainer Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleContainer Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleContainer Class

Glossary Item Box

The following tables list the members exposed by AccessibleContainer.

See Also

Reference

AccessibleContainer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleElement Class

[image]
ActiveReports 19 .NET Edition
AccessibleElement Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleElement Class

Glossary Item Box

Base class for accessible elements

Object Model

AccessibleElement Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class AccessibleElement
C#
public abstract class AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleContainer
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleHeading
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleImage
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleList
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleListItem
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleListItemLabel
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleParagraph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleElement Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleElement Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleElement Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleElement Class

Glossary Item Box

The following tables list the members exposed by AccessibleElement.

See Also

Reference

AccessibleElement Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleHeading Class

[image]
ActiveReports 19 .NET Edition
AccessibleHeading Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleHeading Class

Glossary Item Box

Defines properties for headings

Object Model

AccessibleHeading Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleHeading
   Inherits AccessibleElement
C#
public sealed class AccessibleHeading : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleHeading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleHeading Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleHeading Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleHeading Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleHeading Class

Glossary Item Box

The following tables list the members exposed by AccessibleHeading.

Public Fields

 | Name | Description
Public Field | Level |
Top

See Also

Reference

AccessibleHeading Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleHeading Class Fields

[image]
ActiveReports 19 .NET Edition
AccessibleHeading Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleHeading Class

Glossary Item Box

For a list of all members of this type, see AccessibleHeading members.

Public Fields

 | Name | Description
Public Field | Level |
Top

See Also

Reference

AccessibleHeading Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


Level Field

[image]
ActiveReports 19 .NET Edition
Level Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > AccessibleHeading Class : Level Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Level As Integer
C#
public readonly int Level

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleHeading Class
AccessibleHeading Members


AccessibleImage Class

[image]
ActiveReports 19 .NET Edition
AccessibleImage Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleImage Class

Glossary Item Box

Defines properties for image element

Object Model

AccessibleImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleImage
   Inherits AccessibleElement
C#
public sealed class AccessibleImage : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleImage Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleImage Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleImage Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleImage Class

Glossary Item Box

The following tables list the members exposed by AccessibleImage.

Public Fields

 | Name | Description
Public Field | AccessibleDescription |
Public Field | Size |
Top

See Also

Reference

AccessibleImage Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleImage Class Fields

[image]
ActiveReports 19 .NET Edition
AccessibleImage Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleImage Class

Glossary Item Box

For a list of all members of this type, see AccessibleImage members.

Public Fields

 | Name | Description
Public Field | AccessibleDescription |
Public Field | Size |
Top

See Also

Reference

AccessibleImage Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleDescription Field

[image]
ActiveReports 19 .NET Edition
AccessibleDescription Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > AccessibleImage Class : AccessibleDescription Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly AccessibleDescription As String
C#
public readonly string AccessibleDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleImage Class
AccessibleImage Members


Size Field

[image]
ActiveReports 19 .NET Edition
Size Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > AccessibleImage Class : Size Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Size As RectangleF
C#
public readonly RectangleF Size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleImage Class
AccessibleImage Members


AccessibleList Class

[image]
ActiveReports 19 .NET Edition
AccessibleList Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleList Class

Glossary Item Box

Defines properties for List element

Object Model

AccessibleList Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleList
   Inherits AccessibleElement
C#
public sealed class AccessibleList : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleList Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleList Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleList Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleList Class

Glossary Item Box

The following tables list the members exposed by AccessibleList.

See Also

Reference

AccessibleList Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleListItem Class

[image]
ActiveReports 19 .NET Edition
AccessibleListItem Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleListItem Class

Glossary Item Box

Defines properties for list item

Object Model

AccessibleListItem Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleListItem
   Inherits AccessibleElement
C#
public sealed class AccessibleListItem : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleListItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleListItem Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleListItem Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleListItem Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleListItem Class

Glossary Item Box

The following tables list the members exposed by AccessibleListItem.

See Also

Reference

AccessibleListItem Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleListItemLabel Class

[image]
ActiveReports 19 .NET Edition
AccessibleListItemLabel Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleListItemLabel Class

Glossary Item Box

Defines properties for list item label

Object Model

AccessibleListItemLabel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleListItemLabel
   Inherits AccessibleElement
C#
public sealed class AccessibleListItemLabel : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleListItemLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleListItemLabel Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleListItemLabel Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleListItemLabel Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleListItemLabel Class

Glossary Item Box

The following tables list the members exposed by AccessibleListItemLabel.

See Also

Reference

AccessibleListItemLabel Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleParagraph Class

[image]
ActiveReports 19 .NET Edition
AccessibleParagraph Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleParagraph Class

Glossary Item Box

Defines properties for paragraph

Object Model

AccessibleParagraph Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AccessibleParagraph
   Inherits AccessibleElement
C#
public sealed class AccessibleParagraph : AccessibleElement

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleElement
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.AccessibleParagraph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AccessibleParagraph Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AccessibleParagraph Class Members

[image]
ActiveReports 19 .NET Edition
AccessibleParagraph Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : AccessibleParagraph Class

Glossary Item Box

The following tables list the members exposed by AccessibleParagraph.

See Also

Reference

AccessibleParagraph Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerInfo Class

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfo Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerInfo Class

Glossary Item Box

Represents an information about data visualizer.

Object Model

DataVisualizerInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataVisualizerInfo
C#
public sealed class DataVisualizerInfo

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DataVisualizerInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfo Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerInfo Class Members

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfo Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerInfo Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerInfo.

Public Constructors

 | Name | Description
Public Constructor | DataVisualizerInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataVisualizerArgs |
Public Property | DataVisualizerType |
Top

Public Methods

 | Name | Description
Public Method | ComputeHash |
Top

See Also

Reference

DataVisualizerInfo Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerInfo Constructor

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerInfo Class : DataVisualizerInfo Constructor

dataVisualizerType
dataVisualizerArgs

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataVisualizerType As DataVisualizerType, _
   ByVal dataVisualizerArgs() As Object _
)
C#
public DataVisualizerInfo(
   DataVisualizerType dataVisualizerType,
   object[] dataVisualizerArgs
)

Parameters

dataVisualizerType
dataVisualizerArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfo Class
DataVisualizerInfo Members


DataVisualizerInfo Class Methods

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerInfo Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerInfo members.

Public Methods

 | Name | Description
Public Method | ComputeHash |
Top

See Also

Reference

DataVisualizerInfo Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ComputeHash Method

[image]
ActiveReports 19 .NET Edition
ComputeHash Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerInfo Class : ComputeHash Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ComputeHash() As String
C#
public string ComputeHash()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfo Class
DataVisualizerInfo Members


DataVisualizerInfo Class Properties

[image]
ActiveReports 19 .NET Edition
DataVisualizerInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerInfo Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerInfo members.

Public Properties

 | Name | Description
Public Property | DataVisualizerArgs |
Public Property | DataVisualizerType |
Top

See Also

Reference

DataVisualizerInfo Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerArgs Property

[image]
ActiveReports 19 .NET Edition
DataVisualizerArgs Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerInfo Class : DataVisualizerArgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataVisualizerArgs As Object()
C#
public object[] DataVisualizerArgs {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfo Class
DataVisualizerInfo Members


DataVisualizerType Property

[image]
ActiveReports 19 .NET Edition
DataVisualizerType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerInfo Class : DataVisualizerType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataVisualizerType As DataVisualizerType
C#
public DataVisualizerType DataVisualizerType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfo Class
DataVisualizerInfo Members


DataVisualizerRenderer Class

[image]
ActiveReports 19 .NET Edition
DataVisualizerRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerRenderer Class

Glossary Item Box

Represents extension methods to render.

Object Model

DataVisualizerRenderer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataVisualizerRenderer
C#
public static class DataVisualizerRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DataVisualizerRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerRenderer Class Members

[image]
ActiveReports 19 .NET Edition
DataVisualizerRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerRenderer Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerRenderer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsDataVisualizer | Overloaded.
static (Shared in Visual Basic) | Render |
Top

See Also

Reference

DataVisualizerRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
DataVisualizerRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerRenderer Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerRenderer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsDataVisualizer | Overloaded.
static (Shared in Visual Basic) | Render |
Top

See Also

Reference

DataVisualizerRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IsDataVisualizer Method

[image]
ActiveReports 19 .NET Edition
IsDataVisualizer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerRenderer Class : IsDataVisualizer Method

Glossary Item Box

Overload List

Overload | Description
IsDataVisualizer(IImage) |
IsDataVisualizer(IStyle) |
IsDataVisualizer(ILayoutArea) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Class
DataVisualizerRenderer Members


IsDataVisualizer(IImage) Method

[image]
ActiveReports 19 .NET Edition
IsDataVisualizer(IImage) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerRenderer Class > IsDataVisualizer Method : IsDataVisualizer(IImage) Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function IsDataVisualizer( _
   ByVal image As IImage _
) As Boolean
C#
public static bool IsDataVisualizer(
   IImage image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Class
DataVisualizerRenderer Members
Overload List


IsDataVisualizer(IStyle) Method

[image]
ActiveReports 19 .NET Edition
IsDataVisualizer(IStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerRenderer Class > IsDataVisualizer Method : IsDataVisualizer(IStyle) Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function IsDataVisualizer( _
   ByVal style As IStyle _
) As Boolean
C#
public static bool IsDataVisualizer(
   IStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Class
DataVisualizerRenderer Members
Overload List


IsDataVisualizer(ILayoutArea) Method

[image]
ActiveReports 19 .NET Edition
IsDataVisualizer(ILayoutArea) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerRenderer Class > IsDataVisualizer Method : IsDataVisualizer(ILayoutArea) Method

area

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function IsDataVisualizer( _
   ByVal area As ILayoutArea _
) As Boolean
C#
public static bool IsDataVisualizer(
   ILayoutArea area
)

Parameters

area

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Class
DataVisualizerRenderer Members
Overload List


Render(DataVisualizerInfo,IDrawingCanvas,RectangleF,ResourceLocator,Nullable<BackgroundRepeatOption>) Method

[image]
ActiveReports 19 .NET Edition
Render(DataVisualizerInfo,IDrawingCanvas,RectangleF,ResourceLocator,Nullable<BackgroundRepeatOption>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > DataVisualizerRenderer Class : Render(DataVisualizerInfo,IDrawingCanvas,RectangleF,ResourceLocator,Nullable<BackgroundRepeatOption>) Method

dataVisualizerInfo
canvas
area
resourceLocator
repeatOption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Render( _
   ByVal dataVisualizerInfo As DataVisualizerInfo, _
   ByVal canvas As IDrawingCanvas, _
   ByVal area As RectangleF, _
   ByVal resourceLocator As ResourceLocator, _
   Optional ByVal repeatOption As Nullable(Of BackgroundRepeatOption) _
)
C#
public static void Render(
   DataVisualizerInfo dataVisualizerInfo,
   IDrawingCanvas canvas,
   RectangleF area,
   ResourceLocator resourceLocator,
   Nullable<BackgroundRepeatOption> repeatOption
)

Parameters

dataVisualizerInfo
canvas
area
resourceLocator
repeatOption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerRenderer Class
DataVisualizerRenderer Members


DrawingCanvasExtension Class

[image]
ActiveReports 19 .NET Edition
DrawingCanvasExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DrawingCanvasExtension Class

Glossary Item Box

Represents an extension methods for GrapeCity.ActiveReports.Drawing.IDrawingCanvas

Object Model

DrawingCanvasExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DrawingCanvasExtension
C#
public static class DrawingCanvasExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DrawingCanvasExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DrawingCanvasExtension Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DrawingCanvasExtension Class Members

[image]
ActiveReports 19 .NET Edition
DrawingCanvasExtension Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DrawingCanvasExtension Class

Glossary Item Box

The following tables list the members exposed by DrawingCanvasExtension.

See Also

Reference

DrawingCanvasExtension Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PatchContext Class

[image]
ActiveReports 19 .NET Edition
PatchContext Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : PatchContext Class

Glossary Item Box

Represents the context to be used to create a patch.

Object Model

PatchContext Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PatchContext
C#
public sealed class PatchContext

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.PatchContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchContext Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PatchContext Class Members

[image]
ActiveReports 19 .NET Edition
PatchContext Class Members
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : PatchContext Class

Glossary Item Box

The following tables list the members exposed by PatchContext.

See Also

Reference

PatchContext Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ReportItemExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemExtensions Class

Glossary Item Box

Represents an extension methods for report items.

Object Model

ReportItemExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemExtensions
C#
public static class ReportItemExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.ReportItemExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ReportItemExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportItemExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | HasStyleDelayedProperties |
static (Shared in Visual Basic) | IsDelayedHidded |
static (Shared in Visual Basic) | IsInteractive |
static (Shared in Visual Basic) | IsVerticalAngled | Overloaded. Check if we need special processing for the text.
Top

See Also

Reference

ReportItemExtensions Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ReportItemExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportItemExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | HasStyleDelayedProperties |
static (Shared in Visual Basic) | IsDelayedHidded |
static (Shared in Visual Basic) | IsInteractive |
static (Shared in Visual Basic) | IsVerticalAngled | Overloaded. Check if we need special processing for the text.
Top

See Also

Reference

ReportItemExtensions Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


HasStyleDelayedProperties Method

[image]
ActiveReports 19 .NET Edition
HasStyleDelayedProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class : HasStyleDelayedProperties Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function HasStyleDelayedProperties( _
   ByVal item As IReportItem _
) As Boolean
C#
public static bool HasStyleDelayedProperties(
   IReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


IsDelayedHidded Method

[image]
ActiveReports 19 .NET Edition
IsDelayedHidded Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class : IsDelayedHidded Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function IsDelayedHidded( _
   ByVal item As IReportItem _
) As Boolean
C#
public static bool IsDelayedHidded(
   IReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


IsInteractive Method

[image]
ActiveReports 19 .NET Edition
IsInteractive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class : IsInteractive Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function IsInteractive( _
   ByVal item As IReportItem _
) As Boolean
C#
public static bool IsInteractive(
   IReportItem item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


IsVerticalAngled Method

[image]
ActiveReports 19 .NET Edition
IsVerticalAngled Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class : IsVerticalAngled Method

Glossary Item Box

Check if we need special processing for the text.

Overload List

Overload | Description
IsVerticalAngled(ITextBox) | Check if we need special processing for the text.
IsVerticalAngled(Single) | Check if we need special processing for the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members


IsVerticalAngled(ITextBox) Method

[image]
ActiveReports 19 .NET Edition
IsVerticalAngled(ITextBox) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class > IsVerticalAngled Method : IsVerticalAngled(ITextBox) Method

tb

Glossary Item Box

Check if we need special processing for the text.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function IsVerticalAngled( _
   ByVal tb As ITextBox _
) As Boolean
C#
public static bool IsVerticalAngled(
   ITextBox tb
)

Parameters

tb

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members
Overload List


IsVerticalAngled(Single) Method

[image]
ActiveReports 19 .NET Edition
IsVerticalAngled(Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemExtensions Class > IsVerticalAngled Method : IsVerticalAngled(Single) Method

textBoxAngle

Glossary Item Box

Check if we need special processing for the text.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function IsVerticalAngled( _
   ByVal textBoxAngle As Single _
) As Boolean
C#
public static bool IsVerticalAngled(
   float textBoxAngle
)

Parameters

textBoxAngle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemExtensions Class
ReportItemExtensions Members
Overload List


ReportItemImageRenderer Class

[image]
ActiveReports 19 .NET Edition
ReportItemImageRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemImageRenderer Class

Glossary Item Box

Extension methods to render. Required for situation when no layout is available.

Object Model

ReportItemImageRenderer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportItemImageRenderer
C#
public static class ReportItemImageRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.ReportItemImageRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemImageRenderer Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ReportItemImageRenderer Class Members

[image]
ActiveReports 19 .NET Edition
ReportItemImageRenderer Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemImageRenderer Class

Glossary Item Box

The following tables list the members exposed by ReportItemImageRenderer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Render | Renders report item's content.
static (Shared in Visual Basic) | RenderBackground | Renders report item's background.
Top

See Also

Reference

ReportItemImageRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ReportItemImageRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
ReportItemImageRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : ReportItemImageRenderer Class

Glossary Item Box

For a list of all members of this type, see ReportItemImageRenderer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Render | Renders report item's content.
static (Shared in Visual Basic) | RenderBackground | Renders report item's background.
Top

See Also

Reference

ReportItemImageRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemImageRenderer Class : Render Method

reportItem
imageRenderer
size
dpi
mimeType

Glossary Item Box

Renders report item's content.

Syntax

Visual Basic (Declaration)
Public Shared Function Render( _
   ByVal reportItem As IReportItem, _
   ByVal imageRenderer As IImageRenderer, _
   ByVal size As SizeF, _
   ByVal dpi As SizeF, _
   Optional ByVal mimeType As String _
) As ImageInfo
C#
public static ImageInfo Render(
   IReportItem reportItem,
   IImageRenderer imageRenderer,
   SizeF size,
   SizeF dpi,
   string mimeType
)

Parameters

reportItem
imageRenderer
size
dpi
mimeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemImageRenderer Class
ReportItemImageRenderer Members


RenderBackground Method

[image]
ActiveReports 19 .NET Edition
RenderBackground Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > ReportItemImageRenderer Class : RenderBackground Method

reportItem
imageRenderer
size
dpi
mimeType

Glossary Item Box

Renders report item's background.

Syntax

Visual Basic (Declaration)
Public Shared Function RenderBackground( _
   ByVal reportItem As IReportItem, _
   ByVal imageRenderer As IImageRenderer, _
   ByVal size As SizeF, _
   ByVal dpi As SizeF, _
   Optional ByVal mimeType As String _
) As ImageInfo
C#
public static ImageInfo RenderBackground(
   IReportItem reportItem,
   IImageRenderer imageRenderer,
   SizeF size,
   SizeF dpi,
   string mimeType
)

Parameters

reportItem
imageRenderer
size
dpi
mimeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemImageRenderer Class
ReportItemImageRenderer Members


BackgroundRepeatOption Enumeration

[image]
ActiveReports 19 .NET Edition
BackgroundRepeatOption Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : BackgroundRepeatOption Enumeration

Glossary Item Box

Types of background repeating.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundRepeatOption
   Inherits System.Enum
C#
public enum BackgroundRepeatOption : System.Enum

Members

Member | Description
NoRepeat | Do not repeat the background.
Repeat | Repeate the background in whole space.
RepeatX | Repeat the background in horizontal direction only.
RepeatY | Repeat the background in vertical direction only.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.BackgroundRepeatOption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


DataVisualizerType Enumeration

[image]
ActiveReports 19 .NET Edition
DataVisualizerType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : DataVisualizerType Enumeration

Glossary Item Box

Represents data visualizer types.

Syntax

Visual Basic (Declaration)
Public Enum DataVisualizerType
   Inherits System.Enum
C#
public enum DataVisualizerType : System.Enum

Members

Member | Description
DataBar |
Gradient |
Hatch |
IconSet |
RangeBar |
RangeBarProgress |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DataVisualizerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PatchTargetId Structure

[image]
ActiveReports 19 .NET Edition
PatchTargetId Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : PatchTargetId Structure

Glossary Item Box

Object Model

PatchTargetId Structure

Syntax

Visual Basic (Declaration)
Public Structure PatchTargetId
   Inherits System.ValueType
C#
public struct PatchTargetId : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.PatchTargetId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchTargetId Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PatchTargetId Structure Members

[image]
ActiveReports 19 .NET Edition
PatchTargetId Structure Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : PatchTargetId Structure

Glossary Item Box

The following tables list the members exposed by PatchTargetId.

Public Constructors

 | Name | Description
Public Constructor | PatchTargetId Constructor |
Top

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

PatchTargetId Structure
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PatchTargetId Constructor

[image]
ActiveReports 19 .NET Edition
PatchTargetId Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > PatchTargetId Structure : PatchTargetId Constructor

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As Integer _
)
C#
public PatchTargetId(
   int id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchTargetId Structure
PatchTargetId Members


PatchTargetId Structure Methods

[image]
ActiveReports 19 .NET Edition
PatchTargetId Structure Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : PatchTargetId Structure

Glossary Item Box

For a list of all members of this type, see PatchTargetId members.

Public Methods

 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top

See Also

Reference

PatchTargetId Structure
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > PatchTargetId Structure : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchTargetId Structure
PatchTargetId Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > PatchTargetId Structure : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchTargetId Structure
PatchTargetId Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > PatchTargetId Structure : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PatchTargetId Structure
PatchTargetId Members


IAccessibleCanvas Interface

[image]
ActiveReports 19 .NET Edition
IAccessibleCanvas Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IAccessibleCanvas Interface

Glossary Item Box

APIs used for rendering accessible page elements (PDFA/UA).

Syntax

Visual Basic (Declaration)
Public Interface IAccessibleCanvas
C#
public interface IAccessibleCanvas

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAccessibleCanvas Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IAccessibleCanvas Interface Members

[image]
ActiveReports 19 .NET Edition
IAccessibleCanvas Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IAccessibleCanvas Interface

Glossary Item Box

The following tables list the members exposed by IAccessibleCanvas.

Public Methods

 | Name | Description
Method | EndElement | Executes actions required to finish previously added content
Method | StartElement | Executes actions required to make current rendering content accessible
Top

See Also

Reference

IAccessibleCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IAccessibleCanvas Interface Methods

[image]
ActiveReports 19 .NET Edition
IAccessibleCanvas Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IAccessibleCanvas Interface

Glossary Item Box

For a list of all members of this type, see IAccessibleCanvas members.

Public Methods

 | Name | Description
Method | EndElement | Executes actions required to finish previously added content
Method | StartElement | Executes actions required to make current rendering content accessible
Top

See Also

Reference

IAccessibleCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


EndElement Method

[image]
ActiveReports 19 .NET Edition
EndElement Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IAccessibleCanvas Interface : EndElement Method

Glossary Item Box

Executes actions required to finish previously added content

Syntax

Visual Basic (Declaration)
Sub EndElement()
C#
void EndElement()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAccessibleCanvas Interface
IAccessibleCanvas Members


StartElement Method

[image]
ActiveReports 19 .NET Edition
StartElement Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IAccessibleCanvas Interface : StartElement Method

element

Glossary Item Box

Executes actions required to make current rendering content accessible

Syntax

Visual Basic (Declaration)
Sub StartElement( _
   ByVal element As AccessibleElement _
)
C#
void StartElement(
   AccessibleElement element
)

Parameters

element

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAccessibleCanvas Interface
IAccessibleCanvas Members


IActionRenderer Interface

[image]
ActiveReports 19 .NET Edition
IActionRenderer Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IActionRenderer Interface

Glossary Item Box

Represents a renderer for any action.

Syntax

Visual Basic (Declaration)
Public Interface IActionRenderer
C#
public interface IActionRenderer

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionRenderer Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IActionRenderer Interface Members

[image]
ActiveReports 19 .NET Edition
IActionRenderer Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IActionRenderer Interface

Glossary Item Box

The following tables list the members exposed by IActionRenderer.

Public Methods

 | Name | Description
Method | RenderAction | Renders the specified action within a given region on the specified page number.
Top

See Also

Reference

IActionRenderer Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IActionRenderer Interface Methods

[image]
ActiveReports 19 .NET Edition
IActionRenderer Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IActionRenderer Interface

Glossary Item Box

For a list of all members of this type, see IActionRenderer members.

Public Methods

 | Name | Description
Method | RenderAction | Renders the specified action within a given region on the specified page number.
Top

See Also

Reference

IActionRenderer Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


RenderAction Method

[image]
ActiveReports 19 .NET Edition
RenderAction Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IActionRenderer Interface : RenderAction Method

action
The action to be rendered.
area
The area in which the action will be rendered.
pageNumber
The page number on which the action will be rendered.

Glossary Item Box

Renders the specified action within a given region on the specified page number.

Syntax

Visual Basic (Declaration)
Function RenderAction( _
   ByVal action As IAction, _
   ByVal area As RectangleF, _
   ByVal pageNumber As Integer _
) As Boolean
C#
bool RenderAction(
   IAction action,
   RectangleF area,
   int pageNumber
)

Parameters

action
The action to be rendered.
area
The area in which the action will be rendered.
pageNumber
The page number on which the action will be rendered.

Return Value

Returns true if the action was successfully processed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IActionRenderer Interface
IActionRenderer Members


IPatchableCanvas Interface

[image]
ActiveReports 19 .NET Edition
IPatchableCanvas Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchableCanvas Interface

Glossary Item Box

Represents a renderer for delayed content.

Syntax

Visual Basic (Declaration)
Public Interface IPatchableCanvas
C#
public interface IPatchableCanvas

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchableCanvas Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IPatchableCanvas Interface Members

[image]
ActiveReports 19 .NET Edition
IPatchableCanvas Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchableCanvas Interface

Glossary Item Box

The following tables list the members exposed by IPatchableCanvas.

Public Methods

 | Name | Description
Method | ApplyPatchToString | Apply patch to the text which was previously drawn using the DrawPatchableString method.
Method | DrawPatchableString | Draws a temporary text to the canvas (if necessary) and remembers a place to be updated later.
Top

See Also

Reference

IPatchableCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IPatchableCanvas Interface Methods

[image]
ActiveReports 19 .NET Edition
IPatchableCanvas Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchableCanvas Interface

Glossary Item Box

For a list of all members of this type, see IPatchableCanvas members.

Public Methods

 | Name | Description
Method | ApplyPatchToString | Apply patch to the text which was previously drawn using the DrawPatchableString method.
Method | DrawPatchableString | Draws a temporary text to the canvas (if necessary) and remembers a place to be updated later.
Top

See Also

Reference

IPatchableCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


ApplyPatchToString Method

[image]
ActiveReports 19 .NET Edition
ApplyPatchToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IPatchableCanvas Interface : ApplyPatchToString Method

id
The text identifier to be updated.
patch
The patch to be applied to the text.

Glossary Item Box

Apply patch to the text which was previously drawn using the DrawPatchableString method.

Syntax

Visual Basic (Declaration)
Sub ApplyPatchToString( _
   ByVal id As PatchTargetId, _
   ByVal patch As StringPatch _
)
C#
void ApplyPatchToString(
   PatchTargetId id,
   StringPatch patch
)

Parameters

id
The text identifier to be updated.
patch
The patch to be applied to the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchableCanvas Interface
IPatchableCanvas Members


DrawPatchableString Method

[image]
ActiveReports 19 .NET Edition
DrawPatchableString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IPatchableCanvas Interface : DrawPatchableString Method

id
The text identifier by which it can be found and updated later.
text
The temporary text to be drawn first time.
font
The font to be used to draw the temporary and final texts.
brush
The brush to be used to draw the temporary and final texts.
bounds
The bounds to be the temporary text drawn
format
The GrapeCity.ActiveReports.Drawing.StringFormatEx object representing text draw settings.

Glossary Item Box

Draws a temporary text to the canvas (if necessary) and remembers a place to be updated later.

Syntax

Visual Basic (Declaration)
Sub DrawPatchableString( _
   ByVal id As PatchTargetId, _
   ByVal text As String, _
   ByVal font As FontInfo, _
   ByVal brush As BrushEx, _
   ByVal bounds As RectangleF, _
   ByVal format As StringFormatEx _
)
C#
void DrawPatchableString(
   PatchTargetId id,
   string text,
   FontInfo font,
   BrushEx brush,
   RectangleF bounds,
   StringFormatEx format
)

Parameters

id
The text identifier by which it can be found and updated later.
text
The temporary text to be drawn first time.
font
The font to be used to draw the temporary and final texts.
brush
The brush to be used to draw the temporary and final texts.
bounds
The bounds to be the temporary text drawn
format
The GrapeCity.ActiveReports.Drawing.StringFormatEx object representing text draw settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchableCanvas Interface
IPatchableCanvas Members


IPatchCollector Interface

[image]
ActiveReports 19 .NET Edition
IPatchCollector Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchCollector Interface

Glossary Item Box

Represents a store to collect patches which should be applied to the canvas when layout is ready.

Syntax

Visual Basic (Declaration)
Public Interface IPatchCollector
C#
public interface IPatchCollector

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchCollector Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IPatchCollector Interface Members

[image]
ActiveReports 19 .NET Edition
IPatchCollector Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchCollector Interface

Glossary Item Box

The following tables list the members exposed by IPatchCollector.

Public Methods

 | Name | Description
Method | AddStringPatch |
Method | NewId |
Top

See Also

Reference

IPatchCollector Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IPatchCollector Interface Methods

[image]
ActiveReports 19 .NET Edition
IPatchCollector Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IPatchCollector Interface

Glossary Item Box

For a list of all members of this type, see IPatchCollector members.

Public Methods

 | Name | Description
Method | AddStringPatch |
Method | NewId |
Top

See Also

Reference

IPatchCollector Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


AddStringPatch Method

[image]
ActiveReports 19 .NET Edition
AddStringPatch Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IPatchCollector Interface : AddStringPatch Method

id
createPatch

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub AddStringPatch( _
   ByVal id As PatchTargetId, _
   ByVal createPatch As Func(Of PatchContext,StringPatch) _
)
C#
void AddStringPatch(
   PatchTargetId id,
   Func<PatchContext,StringPatch> createPatch
)

Parameters

id
createPatch

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchCollector Interface
IPatchCollector Members


NewId Method

[image]
ActiveReports 19 .NET Edition
NewId Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IPatchCollector Interface : NewId Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function NewId() As PatchTargetId
C#
PatchTargetId NewId()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPatchCollector Interface
IPatchCollector Members


IReportDrawingCanvas Interface

[image]
ActiveReports 19 .NET Edition
IReportDrawingCanvas Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IReportDrawingCanvas Interface

Glossary Item Box

Filter report items to render.

Syntax

Visual Basic (Declaration)
Public Interface IReportDrawingCanvas
   Inherits GrapeCity.ActiveReports.Drawing.IDrawingCanvas
C#
public interface IReportDrawingCanvas : GrapeCity.ActiveReports.Drawing.IDrawingCanvas

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDrawingCanvas Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IReportDrawingCanvas Interface Members

[image]
ActiveReports 19 .NET Edition
IReportDrawingCanvas Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IReportDrawingCanvas Interface

Glossary Item Box

The following tables list the members exposed by IReportDrawingCanvas.

Public Methods

 | Name | Description
Method | PostRender | Just post render callback.
Method | PreRender | Returns true if report item should be rendered.
Top

See Also

Reference

IReportDrawingCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


IReportDrawingCanvas Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportDrawingCanvas Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace : IReportDrawingCanvas Interface

Glossary Item Box

For a list of all members of this type, see IReportDrawingCanvas members.

Public Methods

 | Name | Description
Method | PostRender | Just post render callback.
Method | PreRender | Returns true if report item should be rendered.
Top

See Also

Reference

IReportDrawingCanvas Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace


PostRender Method

[image]
ActiveReports 19 .NET Edition
PostRender Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IReportDrawingCanvas Interface : PostRender Method

layoutArea

Glossary Item Box

Just post render callback.

Syntax

Visual Basic (Declaration)
Sub PostRender( _
   ByVal layoutArea As ILayoutArea _
)
C#
void PostRender(
   ILayoutArea layoutArea
)

Parameters

layoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDrawingCanvas Interface
IReportDrawingCanvas Members


PreRender Method

[image]
ActiveReports 19 .NET Edition
PreRender Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers Namespace > IReportDrawingCanvas Interface : PreRender Method

layoutArea

Glossary Item Box

Returns true if report item should be rendered.

Syntax

Visual Basic (Declaration)
Function PreRender( _
   ByVal layoutArea As ILayoutArea _
) As Boolean
C#
bool PreRender(
   ILayoutArea layoutArea
)

Parameters

layoutArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportDrawingCanvas Interface
IReportDrawingCanvas Members


InputFieldRenderer Class

[image]
ActiveReports 19 .NET Edition
InputFieldRenderer Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace : InputFieldRenderer Class

Glossary Item Box

Provides a GrapeCity.ActiveReports.Drawing.IGraphicsRenderer for GrapeCity.ActiveReports.Rendering.Components.IInputField report item.

Object Model

InputFieldRenderer Class

Syntax

Visual Basic (Declaration)
Public Class InputFieldRenderer
   Implements GrapeCity.ActiveReports.Drawing.IGraphicsRenderer, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer
C#
public class InputFieldRenderer : GrapeCity.ActiveReports.Drawing.IGraphicsRenderer, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField.InputFieldRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldRenderer Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace


InputFieldRenderer Class Members

[image]
ActiveReports 19 .NET Edition
InputFieldRenderer Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace : InputFieldRenderer Class

Glossary Item Box

The following tables list the members exposed by InputFieldRenderer.

Public Constructors

 | Name | Description
Public Constructor | InputFieldRenderer Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

Public Methods

 | Name | Description
Public Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext
Top

See Also

Reference

InputFieldRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace


InputFieldRenderer Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldRenderer Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace > InputFieldRenderer Class : InputFieldRenderer Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InputFieldRenderer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldRenderer Class
InputFieldRenderer Members


InputFieldRenderer Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldRenderer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace : InputFieldRenderer Class

Glossary Item Box

For a list of all members of this type, see InputFieldRenderer members.

Public Methods

 | Name | Description
Public Method | Render | Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext
Top

See Also

Reference

InputFieldRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace > InputFieldRenderer Class : Render Method

context
area

Glossary Item Box

Performs GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea rendering in specified GrapeCity.ActiveReports.Drawing.GraphicsRenderContext

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal context As GraphicsRenderContext, _
   ByVal area As ILayoutArea _
)
C#
public void Render(
   GraphicsRenderContext context,
   ILayoutArea area
)

Parameters

context
area

Remarks

Each GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea represent GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem or its part.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldRenderer Class
InputFieldRenderer Members


InputFieldRenderer Class Fields

[image]
ActiveReports 19 .NET Edition
InputFieldRenderer Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace : InputFieldRenderer Class

Glossary Item Box

For a list of all members of this type, see InputFieldRenderer members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

See Also

Reference

InputFieldRenderer Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.InputField Namespace > InputFieldRenderer Class : Instance Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As InputFieldRenderer
C#
public static readonly InputFieldRenderer Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldRenderer Class
InputFieldRenderer Members


TileProvidersManager Class

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : TileProvidersManager Class

Glossary Item Box

Map tiles providers factory.

Object Model

TileProvidersManager Class

Syntax

Visual Basic (Declaration)
Public Class TileProvidersManager
   Implements ITileProvidersManager
C#
public class TileProvidersManager : ITileProvidersManager

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.ConfigurableTileProvidersManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


TileProvidersManager Class Members

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : TileProvidersManager Class

Glossary Item Box

The following tables list the members exposed by TileProvidersManager.

Public Constructors

 | Name | Description
Public Constructor | TileProvidersManager Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Providers |
Top

Public Methods

 | Name | Description
Public Method | CreateTileProvider | Create and configure specified tile provider
Top

See Also

Reference

TileProvidersManager Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


TileProvidersManager Constructor

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > TileProvidersManager Class : TileProvidersManager Constructor

Glossary Item Box

Overload List

Overload | Description
TileProvidersManager Constructor() |
TileProvidersManager Constructor(IEnumerable<TileProviderInfo>) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Class
TileProvidersManager Members


TileProvidersManager Constructor()

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > TileProvidersManager Class > TileProvidersManager Constructor : TileProvidersManager Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TileProvidersManager()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Class
TileProvidersManager Members
Overload List


TileProvidersManager Constructor(IEnumerable<TileProviderInfo>)

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Constructor(IEnumerable<TileProviderInfo>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > TileProvidersManager Class > TileProvidersManager Constructor : TileProvidersManager Constructor(IEnumerable<TileProviderInfo>)

providers

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal providers As IEnumerable(Of TileProviderInfo) _
)
C#
public TileProvidersManager(
   IEnumerable<TileProviderInfo> providers
)

Parameters

providers

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Class
TileProvidersManager Members
Overload List


TileProvidersManager Class Methods

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : TileProvidersManager Class

Glossary Item Box

For a list of all members of this type, see TileProvidersManager members.

Public Methods

 | Name | Description
Public Method | CreateTileProvider | Create and configure specified tile provider
Top

See Also

Reference

TileProvidersManager Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


CreateTileProvider Method

[image]
ActiveReports 19 .NET Edition
CreateTileProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > TileProvidersManager Class : CreateTileProvider Method

name
Invariant tile provider name
useSecureConnection
Specifies if the secure connection have to be used.
tileStyle
The style of the tile.
tileLanguage
Language of the tile.

Glossary Item Box

Create and configure specified tile provider

Syntax

Visual Basic (Declaration)
Public Function CreateTileProvider( _
   ByVal name As String, _
   ByVal useSecureConnection As Boolean, _
   ByVal tileStyle As MapTileStyle, _
   ByVal tileLanguage As String _
) As IMapTileProvider
C#
public IMapTileProvider CreateTileProvider(
   string name,
   bool useSecureConnection,
   MapTileStyle tileStyle,
   string tileLanguage
)

Parameters

name
Invariant tile provider name
useSecureConnection
Specifies if the secure connection have to be used.
tileStyle
The style of the tile.
tileLanguage
Language of the tile.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Class
TileProvidersManager Members


TileProvidersManager Class Properties

[image]
ActiveReports 19 .NET Edition
TileProvidersManager Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : TileProvidersManager Class

Glossary Item Box

For a list of all members of this type, see TileProvidersManager members.

Public Properties

 | Name | Description
Public Property | Providers |
Top

See Also

Reference

TileProvidersManager Class
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


Providers Property

[image]
ActiveReports 19 .NET Edition
Providers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > TileProvidersManager Class : Providers Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Providers As IEnumerable(Of TileProviderInfo)
C#
public IEnumerable<TileProviderInfo> Providers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TileProvidersManager Class
TileProvidersManager Members


ITileProvidersManager Interface

[image]
ActiveReports 19 .NET Edition
ITileProvidersManager Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : ITileProvidersManager Interface

Glossary Item Box

Defines interface for managing map tile provider.

Syntax

Visual Basic (Declaration)
Public Interface ITileProvidersManager
C#
public interface ITileProvidersManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITileProvidersManager Members
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


ITileProvidersManager Interface Members

[image]
ActiveReports 19 .NET Edition
ITileProvidersManager Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : ITileProvidersManager Interface

Glossary Item Box

The following tables list the members exposed by ITileProvidersManager.

Public Properties

 | Name | Description
Property | Providers | Returns the map tile providers enumeration.
Top

Public Methods

 | Name | Description
Method | CreateTileProvider | Create and configure specified tile provider.
Top

See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


ITileProvidersManager Interface Methods

[image]
ActiveReports 19 .NET Edition
ITileProvidersManager Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : ITileProvidersManager Interface

Glossary Item Box

For a list of all members of this type, see ITileProvidersManager members.

Public Methods

 | Name | Description
Method | CreateTileProvider | Create and configure specified tile provider.
Top

See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


CreateTileProvider Method

[image]
ActiveReports 19 .NET Edition
CreateTileProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > ITileProvidersManager Interface : CreateTileProvider Method

provider
Invariant tile provider name.
useSecureConnection
True if secured connection to tile provider should be used.
tileStyle
The style of tiles to be returned by tile provider.
tileLanguage
The language of tiles to be returned by tile provider.

Glossary Item Box

Create and configure specified tile provider.

Syntax

Visual Basic (Declaration)
Function CreateTileProvider( _
   ByVal provider As String, _
   ByVal useSecureConnection As Boolean, _
   ByVal tileStyle As MapTileStyle, _
   ByVal tileLanguage As String _
) As IMapTileProvider
C#
IMapTileProvider CreateTileProvider(
   string provider,
   bool useSecureConnection,
   MapTileStyle tileStyle,
   string tileLanguage
)

Parameters

provider
Invariant tile provider name.
useSecureConnection
True if secured connection to tile provider should be used.
tileStyle
The style of tiles to be returned by tile provider.
tileLanguage
The language of tiles to be returned by tile provider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITileProvidersManager Interface
ITileProvidersManager Members


ITileProvidersManager Interface Properties

[image]
ActiveReports 19 .NET Edition
ITileProvidersManager Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace : ITileProvidersManager Interface

Glossary Item Box

For a list of all members of this type, see ITileProvidersManager members.

Public Properties

 | Name | Description
Property | Providers | Returns the map tile providers enumeration.
Top

See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace


Providers Property

[image]
ActiveReports 19 .NET Edition
Providers Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders Namespace > ITileProvidersManager Interface : Providers Property

Glossary Item Box

Returns the map tile providers enumeration.

Syntax

Visual Basic (Declaration)
ReadOnly Property Providers As IEnumerable(Of TileProviderInfo)
C#
IEnumerable<TileProviderInfo> Providers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITileProvidersManager Interface
ITileProvidersManager Members


DataVisualizerResourceException Class

[image]
ActiveReports 19 .NET Edition
DataVisualizerResourceException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : DataVisualizerResourceException Class

Glossary Item Box

Exception to provide informative message if data visualizer resource was not found.

Object Model

DataVisualizerResourceException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataVisualizerResourceException
   Inherits System.ArgumentException
C#
public sealed class DataVisualizerResourceException : System.ArgumentException

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
GrapeCity.ActiveReports.Rendering.Image.DataVisualizerResourceException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerResourceException Members
GrapeCity.ActiveReports.Rendering.Image Namespace


DataVisualizerResourceException Class Members

[image]
ActiveReports 19 .NET Edition
DataVisualizerResourceException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : DataVisualizerResourceException Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerResourceException.

Public Properties

 | Name | Description
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Resource | Image name.
Public Property | Source | Image source (something is wrong if not Database).
Public Property | Type | Data visualizer type.
Top

See Also

Reference

DataVisualizerResourceException Class
GrapeCity.ActiveReports.Rendering.Image Namespace


DataVisualizerResourceException Class Properties

[image]
ActiveReports 19 .NET Edition
DataVisualizerResourceException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : DataVisualizerResourceException Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerResourceException members.

Public Properties

 | Name | Description
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Resource | Image name.
Public Property | Source | Image source (something is wrong if not Database).
Public Property | Type | Data visualizer type.
Top

See Also

Reference

DataVisualizerResourceException Class
GrapeCity.ActiveReports.Rendering.Image Namespace


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > DataVisualizerResourceException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerResourceException Class
DataVisualizerResourceException Members


Resource Property

[image]
ActiveReports 19 .NET Edition
Resource Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > DataVisualizerResourceException Class : Resource Property

Glossary Item Box

Image name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Resource As String
C#
public string Resource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerResourceException Class
DataVisualizerResourceException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > DataVisualizerResourceException Class : Source Property

Glossary Item Box

Image source (something is wrong if not Database).

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Source As ImageSource
C#
public new ImageSource Source {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerResourceException Class
DataVisualizerResourceException Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > DataVisualizerResourceException Class : Type Property

Glossary Item Box

Data visualizer type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As DataVisualizerType
C#
public DataVisualizerType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerResourceException Class
DataVisualizerResourceException Members


ImageHelper Class

[image]
ActiveReports 19 .NET Edition
ImageHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : ImageHelper Class

Glossary Item Box

Contains platform-independed implementation of methods to extract image info from image stream.

Object Model

ImageHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ImageHelper
C#
public static class ImageHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Image.ImageHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Members
GrapeCity.ActiveReports.Rendering.Image Namespace


ImageHelper Class Members

[image]
ActiveReports 19 .NET Edition
ImageHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : ImageHelper Class

Glossary Item Box

The following tables list the members exposed by ImageHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDimensions | Gets the dimensions of an BMP, PNG, JPEG or GIF image.
static (Shared in Visual Basic) | GetExifOrientation | Returns Exif orientation of an image, if it is JPEG and has one
static (Shared in Visual Basic) | GetMimeType | Overloaded. Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.
Top

See Also

Reference

ImageHelper Class
GrapeCity.ActiveReports.Rendering.Image Namespace


ImageHelper Class Methods

[image]
ActiveReports 19 .NET Edition
ImageHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : ImageHelper Class

Glossary Item Box

For a list of all members of this type, see ImageHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDimensions | Gets the dimensions of an BMP, PNG, JPEG or GIF image.
static (Shared in Visual Basic) | GetExifOrientation | Returns Exif orientation of an image, if it is JPEG and has one
static (Shared in Visual Basic) | GetMimeType | Overloaded. Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.
Top

See Also

Reference

ImageHelper Class
GrapeCity.ActiveReports.Rendering.Image Namespace


GetDimensions(Stream) Method

[image]
ActiveReports 19 .NET Edition
GetDimensions(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > ImageHelper Class : GetDimensions(Stream) Method

image
The image to get the dimensions of.

Glossary Item Box

Gets the dimensions of an BMP, PNG, JPEG or GIF image.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDimensions( _
   ByVal image As Stream _
) As SizeF
C#
public static SizeF GetDimensions(
   Stream image
)

Parameters

image
The image to get the dimensions of.

Return Value

The dimensions (in twips) of the specified image.

Exceptions

Exception | Description
System.NotSupportedException | The image was of an unrecognized format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members


GetExifOrientation Method

[image]
ActiveReports 19 .NET Edition
GetExifOrientation Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > ImageHelper Class : GetExifOrientation Method

stream

Glossary Item Box

Returns Exif orientation of an image, if it is JPEG and has one

Syntax

Visual Basic (Declaration)
Public Shared Function GetExifOrientation( _
   ByVal stream As Stream _
) As Nullable(Of ImageHelper.JpegExifOrientation)
C#
public static Nullable<ImageHelper.JpegExifOrientation> GetExifOrientation(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members


GetMimeType Method

[image]
ActiveReports 19 .NET Edition
GetMimeType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > ImageHelper Class : GetMimeType Method

Glossary Item Box

Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.

Overload List

Overload | Description
GetMimeType(Stream) | Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.
GetMimeType(Byte[]) | Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members


GetMimeType(Stream) Method

[image]
ActiveReports 19 .NET Edition
GetMimeType(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > ImageHelper Class > GetMimeType Method : GetMimeType(Stream) Method

imageData
The data of the image to get the mime type of.

Glossary Item Box

Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetMimeType( _
   ByVal imageData As Stream _
) As String
C#
public static string GetMimeType(
   Stream imageData
)

Parameters

imageData
The data of the image to get the mime type of.

Return Value

The mime type of the specified image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members
Overload List


GetMimeType(Byte[]) Method

[image]
ActiveReports 19 .NET Edition
GetMimeType(Byte[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > ImageHelper Class > GetMimeType Method : GetMimeType(Byte[]) Method

imageData
The data of the image to get the mime type of.

Glossary Item Box

Gets the type of an BMP, PNG, JPEG, WMF, EMF, TIFF or GIF image.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetMimeType( _
   ByVal imageData() As Byte _
) As String
C#
public static string GetMimeType(
   byte[] imageData
)

Parameters

imageData
The data of the image to get the mime type of.

Return Value

The mime type of the specified image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageHelper Class
ImageHelper Members
Overload List


OleImageHelper Class

[image]
ActiveReports 19 .NET Edition
OleImageHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : OleImageHelper Class

Glossary Item Box

Helper class to parse images stored as OLE object (from MS SQL and Access).

Object Model

OleImageHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class OleImageHelper
C#
public static class OleImageHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Image.OleImageHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleImageHelper Members
GrapeCity.ActiveReports.Rendering.Image Namespace


OleImageHelper Class Members

[image]
ActiveReports 19 .NET Edition
OleImageHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : OleImageHelper Class

Glossary Item Box

The following tables list the members exposed by OleImageHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | TryParseImageFromIPictureStream | Convert image from OLE IPicture: https://docs.microsoft.com/en-us/windows/win32/api/olectl/nf-olectl-oleloadpicture.
Top

See Also

Reference

OleImageHelper Class
GrapeCity.ActiveReports.Rendering.Image Namespace


OleImageHelper Class Methods

[image]
ActiveReports 19 .NET Edition
OleImageHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : OleImageHelper Class

Glossary Item Box

For a list of all members of this type, see OleImageHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | TryParseImageFromIPictureStream | Convert image from OLE IPicture: https://docs.microsoft.com/en-us/windows/win32/api/olectl/nf-olectl-oleloadpicture.
Top

See Also

Reference

OleImageHelper Class
GrapeCity.ActiveReports.Rendering.Image Namespace


TryParseImageFromIPictureStream Method

[image]
ActiveReports 19 .NET Edition
TryParseImageFromIPictureStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > OleImageHelper Class : TryParseImageFromIPictureStream Method

data

Glossary Item Box

Convert image from OLE IPicture: https://docs.microsoft.com/en-us/windows/win32/api/olectl/nf-olectl-oleloadpicture.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParseImageFromIPictureStream( _
   ByVal data() As Byte _
) As Byte()
C#
public static byte[] TryParseImageFromIPictureStream(
   byte[] data
)

Parameters

data

Return Value

Picture byte array or null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleImageHelper Class
OleImageHelper Members


ImageHelper.JpegExifOrientation Enumeration

[image]
ActiveReports 19 .NET Edition
ImageHelper.JpegExifOrientation Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : ImageHelper.JpegExifOrientation Enumeration

Glossary Item Box

JPEG EXIF Orientation Values

Syntax

Visual Basic (Declaration)
Public Enum ImageHelper.JpegExifOrientation
   Inherits System.Enum
C#
public enum ImageHelper.JpegExifOrientation : System.Enum

Members

Member | Description
Mirrored |
Normal |
Rotated180 |
Rotated180Mirrored |
Rotated270 |
Rotated270Mirrored |
Rotated90 |
Rotated90Mirrored |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Image.ImageHelper.JpegExifOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Image Namespace


IImageConverterService Interface

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : IImageConverterService Interface

Glossary Item Box

Converts to supported image types.

Syntax

Visual Basic (Declaration)
Public Interface IImageConverterService
C#
public interface IImageConverterService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageConverterService Members
GrapeCity.ActiveReports.Rendering.Image Namespace


IImageConverterService Interface Members

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : IImageConverterService Interface

Glossary Item Box

The following tables list the members exposed by IImageConverterService.

Public Methods

 | Name | Description
Method | Convert | Useful for Metafiles and TIFF files.
Top

See Also

Reference

IImageConverterService Interface
GrapeCity.ActiveReports.Rendering.Image Namespace


IImageConverterService Interface Methods

[image]
ActiveReports 19 .NET Edition
IImageConverterService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace : IImageConverterService Interface

Glossary Item Box

For a list of all members of this type, see IImageConverterService members.

Public Methods

 | Name | Description
Method | Convert | Useful for Metafiles and TIFF files.
Top

See Also

Reference

IImageConverterService Interface
GrapeCity.ActiveReports.Rendering.Image Namespace


Convert Method

[image]
ActiveReports 19 .NET Edition
Convert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Image Namespace > IImageConverterService Interface : Convert Method

image

Glossary Item Box

Useful for Metafiles and TIFF files.

Syntax

Visual Basic (Declaration)
Function Convert( _
   ByVal image As ImageInfo _
) As ImageInfo
C#
ImageInfo Convert(
   ImageInfo image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageConverterService Interface
IImageConverterService Members


LayoutException Class

[image]
ActiveReports 19 .NET Edition
LayoutException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Layout Namespace : LayoutException Class

Glossary Item Box

Represents layout errors that occur during report rendering.

Object Model

LayoutException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayoutException
   Inherits System.Exception
C#
public sealed class LayoutException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.Layout.LayoutException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutException Members
GrapeCity.ActiveReports.Rendering.Layout Namespace


LayoutException Class Members

[image]
ActiveReports 19 .NET Edition
LayoutException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Layout Namespace : LayoutException Class

Glossary Item Box

The following tables list the members exposed by LayoutException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with the exception.
Top

See Also

Reference

LayoutException Class
GrapeCity.ActiveReports.Rendering.Layout Namespace


LayoutException Class Properties

[image]
ActiveReports 19 .NET Edition
LayoutException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Layout Namespace : LayoutException Class

Glossary Item Box

For a list of all members of this type, see LayoutException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code associated with the exception.
Top

See Also

Reference

LayoutException Class
GrapeCity.ActiveReports.Rendering.Layout Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Layout Namespace > LayoutException Class : ErrorCode Property

Glossary Item Box

Gets the error code associated with the exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As LayoutException.ErrorCodes
C#
public LayoutException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutException Class
LayoutException Members


LayoutException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Layout Namespace : LayoutException.ErrorCodes Enumeration

Glossary Item Box

Error codes for layout exceptions.

Syntax

Visual Basic (Declaration)
Public Enum LayoutException.ErrorCodes
   Inherits System.Enum
C#
public enum LayoutException.ErrorCodes : System.Enum

Members

Member | Description
InfinitePages | Indicates an infinite pages error.
InvalidColumnSpacing | Indicates an invalid column spacing error.
SubreportTooSmall | Indicates that the subreport is too small.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Layout.LayoutException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Layout Namespace


ExpressionContextBuilder Class

[image]
ActiveReports 19 .NET Edition
ExpressionContextBuilder Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace : ExpressionContextBuilder Class

Glossary Item Box

Defines an expression context builder used to build expression evaluation context.

Object Model

ExpressionContextBuilder Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ExpressionContextBuilder
C#
public static class ExpressionContextBuilder

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.RenderingTree.ExpressionContextBuilder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionContextBuilder Members
GrapeCity.ActiveReports.Rendering.RenderingTree Namespace


ExpressionContextBuilder Class Members

[image]
ActiveReports 19 .NET Edition
ExpressionContextBuilder Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace : ExpressionContextBuilder Class

Glossary Item Box

The following tables list the members exposed by ExpressionContextBuilder.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Build | Overloaded. Creates a simplified evaluation context sufficient to populate the data tree.
Top

See Also

Reference

ExpressionContextBuilder Class
GrapeCity.ActiveReports.Rendering.RenderingTree Namespace


ExpressionContextBuilder Class Methods

[image]
ActiveReports 19 .NET Edition
ExpressionContextBuilder Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace : ExpressionContextBuilder Class

Glossary Item Box

For a list of all members of this type, see ExpressionContextBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Build | Overloaded. Creates a simplified evaluation context sufficient to populate the data tree.
Top

See Also

Reference

ExpressionContextBuilder Class
GrapeCity.ActiveReports.Rendering.RenderingTree Namespace


Build Method

[image]
ActiveReports 19 .NET Edition
Build Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace > ExpressionContextBuilder Class : Build Method

Glossary Item Box

Creates a simplified evaluation context sufficient to populate the data tree.

Overload List

Overload | Description
Build(String,DataExecutionContext,DataParameter[],IReadOnlyDictionary<String,Object>) | Creates a simplified evaluation context sufficient to populate the data tree.
Build(Report,Lazy<Parameters>,ResourceLocator,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) | Creates an evaluation context for the specified report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionContextBuilder Class
ExpressionContextBuilder Members


Build(String,DataExecutionContext,DataParameter[],IReadOnlyDictionary<String,Object>) Method

[image]
ActiveReports 19 .NET Edition
Build(String,DataExecutionContext,DataParameter[],IReadOnlyDictionary<String,Object>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace > ExpressionContextBuilder Class > Build Method : Build(String,DataExecutionContext,DataParameter[],IReadOnlyDictionary<String,Object>) Method

reportName
The name of the report.
context
The data execution context.
dataParameters
The data parameters.
customContext
An optional dictionary of custom context objects.

Glossary Item Box

Creates a simplified evaluation context sufficient to populate the data tree.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Build( _
   ByVal reportName As String, _
   ByVal context As EngineDataProcessor.DataExecutionContext, _
   ByVal dataParameters() As DataParameter, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Object) _
) As IExpressionContext
C#
public static IExpressionContext Build(
   string reportName,
   EngineDataProcessor.DataExecutionContext context,
   DataParameter[] dataParameters,
   IReadOnlyDictionary<string,object> customContext
)

Parameters

reportName
The name of the report.
context
The data execution context.
dataParameters
The data parameters.
customContext
An optional dictionary of custom context objects.

Return Value

An GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.IExpressionContext instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionContextBuilder Class
ExpressionContextBuilder Members
Overload List


Build(Report,Lazy<Parameters>,ResourceLocator,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

[image]
ActiveReports 19 .NET Edition
Build(Report,Lazy<Parameters>,ResourceLocator,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree Namespace > ExpressionContextBuilder Class > Build Method : Build(Report,Lazy<Parameters>,ResourceLocator,IReportInformationService,IReadOnlyDictionary<String,Func<CustomContextArgs,Object>>) Method

reportDef
The report definition.
parameters
The lazy-loaded parameters.
resourceLocator
The resource locator.
ris
The report information service.
customContext
An optional dictionary of custom context functions.

Glossary Item Box

Creates an evaluation context for the specified report definition.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Build( _
   ByVal reportDef As Report, _
   ByVal parameters As Lazy(Of Parameters), _
   ByVal resourceLocator As ResourceLocator, _
   ByVal ris As IReportInformationService, _
   Optional ByVal customContext As IReadOnlyDictionary(Of String,Func(Of CustomContextArgs,Object)) _
) As IEvaluationContext
C#
public static IEvaluationContext Build(
   Report reportDef,
   Lazy<Parameters> parameters,
   ResourceLocator resourceLocator,
   IReportInformationService ris,
   IReadOnlyDictionary<string,Func<CustomContextArgs,object>> customContext
)

Parameters

reportDef
The report definition.
parameters
The lazy-loaded parameters.
resourceLocator
The resource locator.
ris
The report information service.
customContext
An optional dictionary of custom context functions.

Return Value

An GrapeCity.ActiveReports.Core.Rendering.IEvaluationContext instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionContextBuilder Class
ExpressionContextBuilder Members
Overload List


IHasActionsMap Interface

[image]
ActiveReports 19 .NET Edition
IHasActionsMap Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace : IHasActionsMap Interface

Glossary Item Box

Interface that defines a map of actions.

Syntax

Visual Basic (Declaration)
Public Interface IHasActionsMap
C#
public interface IHasActionsMap

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHasActionsMap Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace


IHasActionsMap Interface Members

[image]
ActiveReports 19 .NET Edition
IHasActionsMap Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace : IHasActionsMap Interface

Glossary Item Box

The following tables list the members exposed by IHasActionsMap.

Public Properties

 | Name | Description
Property | Actions | Gets the dictionary of actions.
Top

See Also

Reference

IHasActionsMap Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace


IHasActionsMap Interface Properties

[image]
ActiveReports 19 .NET Edition
IHasActionsMap Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace : IHasActionsMap Interface

Glossary Item Box

For a list of all members of this type, see IHasActionsMap members.

Public Properties

 | Name | Description
Property | Actions | Gets the dictionary of actions.
Top

See Also

Reference

IHasActionsMap Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace


Actions Property

[image]
ActiveReports 19 .NET Edition
Actions Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText Namespace > IHasActionsMap Interface : Actions Property

Glossary Item Box

Gets the dictionary of actions.

Syntax

Visual Basic (Declaration)
ReadOnly Property Actions As Dictionary(Of String,IAction)
C#
Dictionary<string,IAction> Actions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHasActionsMap Interface
IHasActionsMap Members


AttributePresence Enumeration

[image]
ActiveReports 19 .NET Edition
AttributePresence Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : AttributePresence Enumeration

Glossary Item Box

Defines the different constraints on an attribute's presence on an element.

Syntax

Visual Basic (Declaration)
Public Enum AttributePresence
   Inherits System.Enum
C#
public enum AttributePresence : System.Enum

Members

Member | Description
Default | The attribute has a default value, and its presence is optional.
Fixed | The attribute has a fixed value, if present.
Implied | The element is optional.
Required | The attribute must always be present on every element.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.AttributePresence

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


AttributeType Enumeration

[image]
ActiveReports 19 .NET Edition
AttributeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : AttributeType Enumeration

Glossary Item Box

Defines the different possible attribute types.

Syntax

Visual Basic (Declaration)
Public Enum AttributeType
   Inherits System.Enum
C#
public enum AttributeType : System.Enum

Members

Member | Description
CDATA | The attribute contains text (with no markup).
Default | Attribute type not specified.
ENTITIES | The attribute contains a number of entities declared in a DTD.
ENTITY | The attribute contains an entity declared in a DTD.
ENUMERATION | The attribute value is one of a set of allowed names.
ID | The attribute is an id attribute uniquely identifie the element it appears on.
IDREF | The attribute value can be any declared subdocument or data entity name.
IDREFS | The attribute value is a list of (space separated) declared subdocument or data entity names.
NAME | The attribute value is a SGML Name.
NAMES | The attribute value is a list of (space separated) SGML Names.
NMTOKEN | The attribute value is an XML name token (i.e. contains only name characters, but in this case with digits and other valid name characters accepted as the first character).
NMTOKENS | The attribute value is a list of (space separated) XML NMTokens.
NOTATION | Attribute value is a member of the bracketed list of notation names that qualifies this reserved name.
NUMBER | The attribute value is a number.
NUMBERS | The attribute value is a list of (space separated) numbers.
NUTOKEN | The attribute value is a number token (i.e. a name that starts with a number).
NUTOKENS | The attribute value is a list of number tokens.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.AttributeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


DeclaredContent Enumeration

[image]
ActiveReports 19 .NET Edition
DeclaredContent Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : DeclaredContent Enumeration

Glossary Item Box

Where nested subelements cannot occur within an element, its contents can be declared to consist of one of the types of declared content contained in this enumeration.

Syntax

Visual Basic (Declaration)
Public Enum DeclaredContent
   Inherits System.Enum
C#
public enum DeclaredContent : System.Enum

Members

Member | Description
CDATA | Character data (CDATA), which contains only valid SGML characters.
Default | Not defined.
EMPTY | Empty element (EMPTY), i.e. having no contents, or contents that can be generated by the program.
RCDATA | Replaceable character data (RCDATA), which can contain text, character references and/or general entity references that resolve to character data.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.DeclaredContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


GroupType Enumeration

[image]
ActiveReports 19 .NET Edition
GroupType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : GroupType Enumeration

Glossary Item Box

The type of the content model group, defining the order in which child elements can occur.

Syntax

Visual Basic (Declaration)
Public Enum GroupType
   Inherits System.Enum
C#
public enum GroupType : System.Enum

Members

Member | Description
And | All elements must occur, in any order.
None | No model group.
Or | One (and only one) must occur.
Sequence | All element must occur, in the specified order.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.GroupType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


Occurrence Enumeration

[image]
ActiveReports 19 .NET Edition
Occurrence Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : Occurrence Enumeration

Glossary Item Box

Qualifies the occurrence of a child element within a content model group.

Syntax

Visual Basic (Declaration)
Public Enum Occurrence
   Inherits System.Enum
C#
public enum Occurrence : System.Enum

Members

Member | Description
OneOrMore | The element must occur at least once or more times.
Optional | The element is optional and must occur once at most.
Required | The element is required and must occur only once.
ZeroOrMore | The element is optional and can be repeated.

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.Occurrence

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


WhitespaceHandling Enumeration

[image]
ActiveReports 19 .NET Edition
WhitespaceHandling Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace : WhitespaceHandling Enumeration

Glossary Item Box

Specifies how white space is handled. (Not defined in PORTABLE framework, so we added it here).

Syntax

Visual Basic (Declaration)
Public Enum WhitespaceHandling
   Inherits System.Enum
C#
public enum WhitespaceHandling : System.Enum

Members

Member | Description
All |
None |
Significant |

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader.WhitespaceHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.RenderingTree.Components.FormattedText.SgmlReader Namespace


ICustomCssStyles Interface

[image]
ActiveReports 19 .NET Edition
ICustomCssStyles Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : ICustomCssStyles Interface

Glossary Item Box

Represents an interface for providing custom CSS class names for a report item.

Syntax

Visual Basic (Declaration)
Public Interface ICustomCssStyles
C#
public interface ICustomCssStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomCssStyles Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


ICustomCssStyles Interface Members

[image]
ActiveReports 19 .NET Edition
ICustomCssStyles Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : ICustomCssStyles Interface

Glossary Item Box

The following tables list the members exposed by ICustomCssStyles.

Public Properties

 | Name | Description
Property | CustomCSSClasses | Gets the custom CSS class names.
Top

See Also

Reference

ICustomCssStyles Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


ICustomCssStyles Interface Properties

[image]
ActiveReports 19 .NET Edition
ICustomCssStyles Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : ICustomCssStyles Interface

Glossary Item Box

For a list of all members of this type, see ICustomCssStyles members.

Public Properties

 | Name | Description
Property | CustomCSSClasses | Gets the custom CSS class names.
Top

See Also

Reference

ICustomCssStyles Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


CustomCSSClasses Property

[image]
ActiveReports 19 .NET Edition
CustomCSSClasses Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace > ICustomCssStyles Interface : CustomCSSClasses Property

Glossary Item Box

Gets the custom CSS class names.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomCSSClasses As String
C#
string CustomCSSClasses {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICustomCssStyles Interface
ICustomCssStyles Members


IPartItem Interface

[image]
ActiveReports 19 .NET Edition
IPartItem Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : IPartItem Interface

Glossary Item Box

Interface for GrapeCity.ActiveReports.Rendering.Components.PartItem rendering component.

Syntax

Visual Basic (Declaration)
Public Interface IPartItem
C#
public interface IPartItem

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPartItem Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


IPartItem Interface Members

[image]
ActiveReports 19 .NET Edition
IPartItem Interface Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : IPartItem Interface

Glossary Item Box

The following tables list the members exposed by IPartItem.

Public Properties

 | Name | Description
Property | ReportItem |
Top

See Also

Reference

IPartItem Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


IPartItem Interface Properties

[image]
ActiveReports 19 .NET Edition
IPartItem Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace : IPartItem Interface

Glossary Item Box

For a list of all members of this type, see IPartItem members.

Public Properties

 | Name | Description
Property | ReportItem |
Top

See Also

Reference

IPartItem Interface
GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace


ReportItem Property

[image]
ActiveReports 19 .NET Edition
ReportItem Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Components.Interfaces Namespace > IPartItem Interface : ReportItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItem As IReportItem
C#
IReportItem ReportItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPartItem Interface
IPartItem Members


DateTimeExtension Class

[image]
ActiveReports 19 .NET Edition
DateTimeExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : DateTimeExtension Class

Glossary Item Box

Provides extension methods for System.DateTime to get the quarter number or quarter name depending on the culture.

Object Model

DateTimeExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DateTimeExtension
C#
public static class DateTimeExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools.DateTimeExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeExtension Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


DateTimeExtension Class Members

[image]
ActiveReports 19 .NET Edition
DateTimeExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : DateTimeExtension Class

Glossary Item Box

The following tables list the members exposed by DateTimeExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetQuarter | Gets the number of the quarter for the specified date.
static (Shared in Visual Basic) | GetQuarterName | Gets the name of the quarter for the specified date and culture.
Top

See Also

Reference

DateTimeExtension Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


DateTimeExtension Class Methods

[image]
ActiveReports 19 .NET Edition
DateTimeExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : DateTimeExtension Class

Glossary Item Box

For a list of all members of this type, see DateTimeExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetQuarter | Gets the number of the quarter for the specified date.
static (Shared in Visual Basic) | GetQuarterName | Gets the name of the quarter for the specified date and culture.
Top

See Also

Reference

DateTimeExtension Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


GetQuarter Method

[image]
ActiveReports 19 .NET Edition
GetQuarter Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace > DateTimeExtension Class : GetQuarter Method

date
The date for which to get the quarter number.

Glossary Item Box

Gets the number of the quarter for the specified date.

Syntax

Visual Basic (Declaration)
Public Shared Function GetQuarter( _
   ByVal date As Date _
) As Integer
C#
public static int GetQuarter(
   DateTime date
)

Parameters

date
The date for which to get the quarter number.

Return Value

The number of the quarter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeExtension Class
DateTimeExtension Members


GetQuarterName Method

[image]
ActiveReports 19 .NET Edition
GetQuarterName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace > DateTimeExtension Class : GetQuarterName Method

date
The date for which to get the quarter name.
culture
The culture to use for the quarter name. If null, the quarter number is returned.

Glossary Item Box

Gets the name of the quarter for the specified date and culture.

Syntax

Visual Basic (Declaration)
Public Shared Function GetQuarterName( _
   ByVal date As Date, _
   Optional ByVal culture As CultureInfo _
) As String
C#
public static string GetQuarterName(
   DateTime date,
   CultureInfo culture
)

Parameters

date
The date for which to get the quarter name.
culture
The culture to use for the quarter name. If null, the quarter number is returned.

Return Value

The name of the quarter, or the quarter number as a string if the culture is not specified or not supported.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeExtension Class
DateTimeExtension Members


NewPageExtension Class

[image]
ActiveReports 19 .NET Edition
NewPageExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : NewPageExtension Class

Glossary Item Box

Provides extension methods for page breaking functionality.

Object Model

NewPageExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class NewPageExtension
C#
public static class NewPageExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools.NewPageExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewPageExtension Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


NewPageExtension Class Members

[image]
ActiveReports 19 .NET Edition
NewPageExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : NewPageExtension Class

Glossary Item Box

The following tables list the members exposed by NewPageExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToEndSection | Converts a GrapeCity.ActiveReports.PageReportModel.StartNewPage value to an GrapeCity.ActiveReports.Layout.EndSection value.
Top

See Also

Reference

NewPageExtension Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


NewPageExtension Class Methods

[image]
ActiveReports 19 .NET Edition
NewPageExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : NewPageExtension Class

Glossary Item Box

For a list of all members of this type, see NewPageExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToEndSection | Converts a GrapeCity.ActiveReports.PageReportModel.StartNewPage value to an GrapeCity.ActiveReports.Layout.EndSection value.
Top

See Also

Reference

NewPageExtension Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


ToEndSection Method

[image]
ActiveReports 19 .NET Edition
ToEndSection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace > NewPageExtension Class : ToEndSection Method

from
The GrapeCity.ActiveReports.PageReportModel.StartNewPage value to convert.

Glossary Item Box

Converts a GrapeCity.ActiveReports.PageReportModel.StartNewPage value to an GrapeCity.ActiveReports.Layout.EndSection value.

Syntax

Visual Basic (Declaration)
Public Shared Function ToEndSection( _
   ByVal from As StartNewPage _
) As EndSection
C#
public static EndSection ToEndSection(
   StartNewPage from
)

Parameters

from
The GrapeCity.ActiveReports.PageReportModel.StartNewPage value to convert.

Return Value

The corresponding GrapeCity.ActiveReports.Layout.EndSection value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NewPageExtension Class
NewPageExtension Members


SlicersHelper Class

[image]
ActiveReports 19 .NET Edition
SlicersHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : SlicersHelper Class

Glossary Item Box

Helper methods for slicers.

Object Model

SlicersHelper Class

Syntax

Visual Basic (Declaration)
Public Class SlicersHelper
C#
public class SlicersHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools.SlicersHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicersHelper Members
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


SlicersHelper Class Members

[image]
ActiveReports 19 .NET Edition
SlicersHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : SlicersHelper Class

Glossary Item Box

The following tables list the members exposed by SlicersHelper.

Public Constructors

 | Name | Description
Public Constructor | SlicersHelper Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | EvaluateInitialState | Evaluates initial slicers states.
Top

See Also

Reference

SlicersHelper Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


SlicersHelper Constructor

[image]
ActiveReports 19 .NET Edition
SlicersHelper Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace > SlicersHelper Class : SlicersHelper Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SlicersHelper()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicersHelper Class
SlicersHelper Members


SlicersHelper Class Methods

[image]
ActiveReports 19 .NET Edition
SlicersHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace : SlicersHelper Class

Glossary Item Box

For a list of all members of this type, see SlicersHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | EvaluateInitialState | Evaluates initial slicers states.
Top

See Also

Reference

SlicersHelper Class
GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace


EvaluateInitialState(Report,ResourceLocator,DataTreeBuilderConfig) Method

[image]
ActiveReports 19 .NET Edition
EvaluateInitialState(Report,ResourceLocator,DataTreeBuilderConfig) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.RenderingTree.Tools Namespace > SlicersHelper Class : EvaluateInitialState(Report,ResourceLocator,DataTreeBuilderConfig) Method

report
Report definition.
resourceLocator
Resource locator.
dataConfig
Data providers configuration.

Glossary Item Box

Evaluates initial slicers states.

Syntax

Visual Basic (Declaration)
Public Shared Function EvaluateInitialState( _
   ByVal report As Report, _
   ByVal resourceLocator As ResourceLocator, _
   ByVal dataConfig As DataTreeBuilderConfig _
) As SlicerState()
C#
public static SlicerState[] EvaluateInitialState(
   Report report,
   ResourceLocator resourceLocator,
   DataTreeBuilderConfig dataConfig
)

Parameters

report
Report definition.
resourceLocator
Resource locator.
dataConfig
Data providers configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SlicersHelper Class
SlicersHelper Members


ITextLayoutService Interface

[image]
ActiveReports 19 .NET Edition
ITextLayoutService Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace : ITextLayoutService Interface

Glossary Item Box

Providers functionality for values converting and formatting as well as evaluation of the layout and rendering information and styles according to the current language.

Syntax

Visual Basic (Declaration)
Public Interface ITextLayoutService
   Inherits GrapeCity.ActiveReports.Rendering.Components.Interfaces.IFormattingService
C#
public interface ITextLayoutService : GrapeCity.ActiveReports.Rendering.Components.Interfaces.IFormattingService

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Members
GrapeCity.ActiveReports.Rendering.Text Namespace


ITextLayoutService Interface Members

[image]
ActiveReports 19 .NET Edition
ITextLayoutService Interface Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace : ITextLayoutService Interface

Glossary Item Box

The following tables list the members exposed by ITextLayoutService.

Public Properties

 | Name | Description
Property | CurrentCulture |
Top

Public Methods

 | Name | Description
Method | GetDigitSubstitution | Gets or sets the language that is used when local digits are substituted for western digits.
Method | GetTextLayoutService | Overloaded. Returns a ITextLayoutService for the specified language. In the case of same language returns itself, otherwise it will be created a new instance.
Top

See Also

Reference

ITextLayoutService Interface
GrapeCity.ActiveReports.Rendering.Text Namespace


ITextLayoutService Interface Methods

[image]
ActiveReports 19 .NET Edition
ITextLayoutService Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace : ITextLayoutService Interface

Glossary Item Box

For a list of all members of this type, see ITextLayoutService members.

Public Methods

 | Name | Description
Method | GetDigitSubstitution | Gets or sets the language that is used when local digits are substituted for western digits.
Method | GetTextLayoutService | Overloaded. Returns a ITextLayoutService for the specified language. In the case of same language returns itself, otherwise it will be created a new instance.
Top

See Also

Reference

ITextLayoutService Interface
GrapeCity.ActiveReports.Rendering.Text Namespace


GetDigitSubstitution Method

[image]
ActiveReports 19 .NET Edition
GetDigitSubstitution Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace > ITextLayoutService Interface : GetDigitSubstitution Method

style
language
substitute

Glossary Item Box

Gets or sets the language that is used when local digits are substituted for western digits.

Syntax

Visual Basic (Declaration)
Function GetDigitSubstitution( _
   ByVal style As IStyle, _
   ByRef language As Integer, _
   ByRef substitute As StringDigitSubstituteEx _
) As Boolean
C#
bool GetDigitSubstitution(
   IStyle style,
   out int language,
   out StringDigitSubstituteEx substitute
)

Parameters

style
language
substitute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Interface
ITextLayoutService Members


GetTextLayoutService Method

[image]
ActiveReports 19 .NET Edition
GetTextLayoutService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace > ITextLayoutService Interface : GetTextLayoutService Method

Glossary Item Box

Returns a ITextLayoutService for the specified language. In the case of same language returns itself, otherwise it will be created a new instance.

Overload List

Overload | Description
GetTextLayoutService(String) | Returns a ITextLayoutService for the specified language. In the case of same language returns itself, otherwise it will be created a new instance.
GetTextLayoutService(IReportItem) | Returns a ITextLayoutService for the language which is used for given report item. In the case of same language returns itself, otherwise it will be created a new instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Interface
ITextLayoutService Members


GetTextLayoutService(String) Method

[image]
ActiveReports 19 .NET Edition
GetTextLayoutService(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace > ITextLayoutService Interface > GetTextLayoutService Method : GetTextLayoutService(String) Method

language

Glossary Item Box

Returns a ITextLayoutService for the specified language. In the case of same language returns itself, otherwise it will be created a new instance.

Syntax

Visual Basic (Declaration)
Overloads Function GetTextLayoutService( _
   ByVal language As String _
) As ITextLayoutService
C#
ITextLayoutService GetTextLayoutService(
   string language
)

Parameters

language

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Interface
ITextLayoutService Members
Overload List


GetTextLayoutService(IReportItem) Method

[image]
ActiveReports 19 .NET Edition
GetTextLayoutService(IReportItem) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace > ITextLayoutService Interface > GetTextLayoutService Method : GetTextLayoutService(IReportItem) Method

reportItem

Glossary Item Box

Returns a ITextLayoutService for the language which is used for given report item. In the case of same language returns itself, otherwise it will be created a new instance.

Syntax

Visual Basic (Declaration)
Overloads Function GetTextLayoutService( _
   ByVal reportItem As IReportItem _
) As ITextLayoutService
C#
ITextLayoutService GetTextLayoutService(
   IReportItem reportItem
)

Parameters

reportItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Interface
ITextLayoutService Members
Overload List


ITextLayoutService Interface Properties

[image]
ActiveReports 19 .NET Edition
ITextLayoutService Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace : ITextLayoutService Interface

Glossary Item Box

For a list of all members of this type, see ITextLayoutService members.

Public Properties

 | Name | Description
Property | CurrentCulture |
Top

See Also

Reference

ITextLayoutService Interface
GrapeCity.ActiveReports.Rendering.Text Namespace


CurrentCulture Property

[image]
ActiveReports 19 .NET Edition
CurrentCulture Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Text Namespace > ITextLayoutService Interface : CurrentCulture Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentCulture As CultureInfo
C#
CultureInfo CurrentCulture {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITextLayoutService Interface
ITextLayoutService Members


ChartPaletteHelper Class

[image]
ActiveReports 19 .NET Edition
ChartPaletteHelper Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteHelper Class

Glossary Item Box

Represents methods for work with chart palettes.

Object Model

ChartPaletteHelper Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ChartPaletteHelper
C#
public static class ChartPaletteHelper

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ChartPaletteHelper

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteHelper Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ChartPaletteHelper Class Members

[image]
ActiveReports 19 .NET Edition
ChartPaletteHelper Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteHelper Class

Glossary Item Box

The following tables list the members exposed by ChartPaletteHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateColorPalette |
static (Shared in Visual Basic) | GetAvailablePalettes | Returns the list of available palettes.
Top

See Also

Reference

ChartPaletteHelper Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ChartPaletteHelper Class Methods

[image]
ActiveReports 19 .NET Edition
ChartPaletteHelper Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteHelper Class

Glossary Item Box

For a list of all members of this type, see ChartPaletteHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateColorPalette |
static (Shared in Visual Basic) | GetAvailablePalettes | Returns the list of available palettes.
Top

See Also

Reference

ChartPaletteHelper Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


CreateColorPalette Method

[image]
ActiveReports 19 .NET Edition
CreateColorPalette Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteHelper Class : CreateColorPalette Method

name
customPalette
iTheme
expressionEvaluator

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateColorPalette( _
   ByVal name As String, _
   ByVal customPalette As CustomPaletteColorsCollection, _
   ByVal iTheme As ITheme, _
   ByVal expressionEvaluator As IExpressionEvaluatorService _
) As Color()
C#
public static Color[] CreateColorPalette(
   string name,
   CustomPaletteColorsCollection customPalette,
   ITheme iTheme,
   IExpressionEvaluatorService expressionEvaluator
)

Parameters

name
customPalette
iTheme
expressionEvaluator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteHelper Class
ChartPaletteHelper Members


GetAvailablePalettes Method

[image]
ActiveReports 19 .NET Edition
GetAvailablePalettes Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteHelper Class : GetAvailablePalettes Method

Glossary Item Box

Returns the list of available palettes.

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailablePalettes() As ChartPaletteInfo()
C#
public static ChartPaletteInfo[] GetAvailablePalettes()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteHelper Class
ChartPaletteHelper Members


ColorExtension Class

[image]
ActiveReports 19 .NET Edition
ColorExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ColorExtension Class

Glossary Item Box

Provides extension methods for working with colors in the context of HTML color names and color manipulation.

Object Model

ColorExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ColorExtension
C#
public static class ColorExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ColorExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ColorExtension Class Members

[image]
ActiveReports 19 .NET Edition
ColorExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ColorExtension Class

Glossary Item Box

The following tables list the members exposed by ColorExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyTransparency | Adjusts the color with the provided transparency.
static (Shared in Visual Basic) | IsKnownColor | Determines whether the color is a known color.
static (Shared in Visual Basic) | IsTransparent | Determines whether the color is fully transparent.
static (Shared in Visual Basic) | ToColor | Overloaded. Converts an HTML color name to a System.Drawing.Color object.
static (Shared in Visual Basic) | ToHtml | Converts a given color to a string that can be used in HTML code.
static (Shared in Visual Basic) | ToRgbString | Converts a given color to a hexadecimal string representation.
Top

See Also

Reference

ColorExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ColorExtension Class Methods

[image]
ActiveReports 19 .NET Edition
ColorExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ColorExtension Class

Glossary Item Box

For a list of all members of this type, see ColorExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyTransparency | Adjusts the color with the provided transparency.
static (Shared in Visual Basic) | IsKnownColor | Determines whether the color is a known color.
static (Shared in Visual Basic) | IsTransparent | Determines whether the color is fully transparent.
static (Shared in Visual Basic) | ToColor | Overloaded. Converts an HTML color name to a System.Drawing.Color object.
static (Shared in Visual Basic) | ToHtml | Converts a given color to a string that can be used in HTML code.
static (Shared in Visual Basic) | ToRgbString | Converts a given color to a hexadecimal string representation.
Top

See Also

Reference

ColorExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ApplyTransparency Method

[image]
ActiveReports 19 .NET Edition
ApplyTransparency Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : ApplyTransparency Method

color
The original color to be adjusted.
transparency
Transparency in percent, where 0% is opaque and 100% is fully transparent.

Glossary Item Box

Adjusts the color with the provided transparency.

Syntax

Visual Basic (Declaration)
Public Shared Function ApplyTransparency( _
   ByVal color As Color, _
   ByVal transparency As Double _
) As Color
C#
public static Color ApplyTransparency(
   Color color,
   double transparency
)

Parameters

color
The original color to be adjusted.
transparency
Transparency in percent, where 0% is opaque and 100% is fully transparent.

Return Value

A new System.Drawing.Color object with the applied transparency.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


IsKnownColor Method

[image]
ActiveReports 19 .NET Edition
IsKnownColor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : IsKnownColor Method

color
The color to check.

Glossary Item Box

Determines whether the color is a known color.

Syntax

Visual Basic (Declaration)
Public Shared Function IsKnownColor( _
   ByVal color As Color _
) As Boolean
C#
public static bool IsKnownColor(
   Color color
)

Parameters

color
The color to check.

Return Value

true if the color is a known color; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


IsTransparent Method

[image]
ActiveReports 19 .NET Edition
IsTransparent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : IsTransparent Method

color
The color to check.

Glossary Item Box

Determines whether the color is fully transparent.

Syntax

Visual Basic (Declaration)
Public Shared Function IsTransparent( _
   ByVal color As Color _
) As Boolean
C#
public static bool IsTransparent(
   Color color
)

Parameters

color
The color to check.

Return Value

true if the color is fully transparent; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


ToColor Method

[image]
ActiveReports 19 .NET Edition
ToColor Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : ToColor Method

Glossary Item Box

Converts an HTML color name to a System.Drawing.Color object.

Overload List

Overload | Description
ToColor(String) | Converts an HTML color name to a System.Drawing.Color object.
ToColor(String,Color) | Converts an HTML color name to a System.Drawing.Color object, or returns a default color if the name is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


ToColor(String) Method

[image]
ActiveReports 19 .NET Edition
ToColor(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class > ToColor Method : ToColor(String) Method

htmlColorName
The HTML color name to convert.

Glossary Item Box

Converts an HTML color name to a System.Drawing.Color object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToColor( _
   ByVal htmlColorName As String _
) As Color
C#
public static Color ToColor(
   string htmlColorName
)

Parameters

htmlColorName
The HTML color name to convert.

Return Value

A System.Drawing.Color object representing the HTML color name, or System.Drawing.Color.Transparent if the name is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members
Overload List


ToColor(String,Color) Method

[image]
ActiveReports 19 .NET Edition
ToColor(String,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class > ToColor Method : ToColor(String,Color) Method

htmlColorName
The HTML color name to convert.
def
The default color to return if the HTML color name is null or empty.

Glossary Item Box

Converts an HTML color name to a System.Drawing.Color object, or returns a default color if the name is null or empty.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToColor( _
   ByVal htmlColorName As String, _
   ByVal def As Color _
) As Color
C#
public static Color ToColor(
   string htmlColorName,
   Color def
)

Parameters

htmlColorName
The HTML color name to convert.
def
The default color to return if the HTML color name is null or empty.

Return Value

A System.Drawing.Color object representing the HTML color name, or the default color if the name is null or empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members
Overload List


ToHtml Method

[image]
ActiveReports 19 .NET Edition
ToHtml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : ToHtml Method

color
The color to convert.

Glossary Item Box

Converts a given color to a string that can be used in HTML code.

Syntax

Visual Basic (Declaration)
Public Shared Function ToHtml( _
   ByVal color As Color _
) As String
C#
public static string ToHtml(
   Color color
)

Parameters

color
The color to convert.

Return Value

A string representing the color for use in HTML code. The string can be a color name or a hexadecimal value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


ToRgbString Method

[image]
ActiveReports 19 .NET Edition
ToRgbString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ColorExtension Class : ToRgbString Method

color
The color to convert.

Glossary Item Box

Converts a given color to a hexadecimal string representation.

Syntax

Visual Basic (Declaration)
Public Shared Function ToRgbString( _
   ByVal color As Color _
) As String
C#
public static string ToRgbString(
   Color color
)

Parameters

color
The color to convert.

Return Value

A string representing the color in the format #RRGGBB or #AARRGGBB if the color has transparency.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorExtension Class
ColorExtension Members


CompiledRegion Class

[image]
ActiveReports 19 .NET Edition
CompiledRegion Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion Class

Glossary Item Box

Represents a region that is defined by a set of rectangles and polygons.

Object Model

CompiledRegion Class

Syntax

Visual Basic (Declaration)
Public Class CompiledRegion
C#
public class CompiledRegion

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.CompiledRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegion Class Members

[image]
ActiveReports 19 .NET Edition
CompiledRegion Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion Class

Glossary Item Box

The following tables list the members exposed by CompiledRegion.

Public Constructors

 | Name | Description
Public Constructor | CompiledRegion Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Entities | Gets a read-only collection of entities defining the region.
Top

Public Methods

 | Name | Description
Public Method | Exclude | Overloaded. Excludes the specified rectangle from the region.
Public Method | Intersect | Overloaded. Intersects the region with the specified rectangle.
Public Method | Union | Overloaded. Adds a rectangle to the region.
Top

See Also

Reference

CompiledRegion Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegion Constructor

[image]
ActiveReports 19 .NET Edition
CompiledRegion Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class : CompiledRegion Constructor

Glossary Item Box

Overload List

Overload | Description
CompiledRegion Constructor() | Initializes a new instance of the CompiledRegion class.
CompiledRegion Constructor(List<Entity>) | Initializes a new instance of the CompiledRegion class with the specified entities.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members


CompiledRegion Constructor()

[image]
ActiveReports 19 .NET Edition
CompiledRegion Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > CompiledRegion Constructor : CompiledRegion Constructor()

Glossary Item Box

Initializes a new instance of the CompiledRegion class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CompiledRegion()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


CompiledRegion Constructor(List<Entity>)

[image]
ActiveReports 19 .NET Edition
CompiledRegion Constructor(List<Entity>)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > CompiledRegion Constructor : CompiledRegion Constructor(List<Entity>)

entities
A list of entities to initialize the region with.

Glossary Item Box

Initializes a new instance of the CompiledRegion class with the specified entities.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal entities As List(Of CompiledRegion.Entity) _
)
C#
public CompiledRegion(
   List<CompiledRegion.Entity> entities
)

Parameters

entities
A list of entities to initialize the region with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


CompiledRegion Class Methods

[image]
ActiveReports 19 .NET Edition
CompiledRegion Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion Class

Glossary Item Box

For a list of all members of this type, see CompiledRegion members.

Public Methods

 | Name | Description
Public Method | Exclude | Overloaded. Excludes the specified rectangle from the region.
Public Method | Intersect | Overloaded. Intersects the region with the specified rectangle.
Public Method | Union | Overloaded. Adds a rectangle to the region.
Top

See Also

Reference

CompiledRegion Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Exclude Method

[image]
ActiveReports 19 .NET Edition
Exclude Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class : Exclude Method

Glossary Item Box

Excludes the specified rectangle from the region.

Overload List

Overload | Description
Exclude(RectangleF) | Excludes the specified rectangle from the region.
Exclude(PointF[]) | Exclude polygon from the region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members


Exclude(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Exclude(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Exclude Method : Exclude(RectangleF) Method

rect
The rectangle to exclude.

Glossary Item Box

Excludes the specified rectangle from the region.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Exclude( _
   ByVal rect As RectangleF _
)
C#
public void Exclude(
   RectangleF rect
)

Parameters

rect
The rectangle to exclude.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


Exclude(PointF[]) Method

[image]
ActiveReports 19 .NET Edition
Exclude(PointF[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Exclude Method : Exclude(PointF[]) Method

polygonPoints
Polygon points

Glossary Item Box

Exclude polygon from the region.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Exclude( _
   ByVal polygonPoints() As PointF _
)
C#
public void Exclude(
   PointF[] polygonPoints
)

Parameters

polygonPoints
Polygon points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


Intersect Method

[image]
ActiveReports 19 .NET Edition
Intersect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class : Intersect Method

Glossary Item Box

Intersects the region with the specified rectangle.

Overload List

Overload | Description
Intersect(RectangleF) | Intersects the region with the specified rectangle.
Intersect(PointF[]) | Intersects with polygon.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members


Intersect(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Intersect(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Intersect Method : Intersect(RectangleF) Method

rect
The rectangle to intersect with.

Glossary Item Box

Intersects the region with the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Intersect( _
   ByVal rect As RectangleF _
)
C#
public void Intersect(
   RectangleF rect
)

Parameters

rect
The rectangle to intersect with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


Intersect(PointF[]) Method

[image]
ActiveReports 19 .NET Edition
Intersect(PointF[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Intersect Method : Intersect(PointF[]) Method

polygonPoints
Polygon points

Glossary Item Box

Intersects with polygon.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Intersect( _
   ByVal polygonPoints() As PointF _
)
C#
public void Intersect(
   PointF[] polygonPoints
)

Parameters

polygonPoints
Polygon points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


Union Method

[image]
ActiveReports 19 .NET Edition
Union Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class : Union Method

Glossary Item Box

Adds a rectangle to the region.

Overload List

Overload | Description
Union(RectangleF) | Adds a rectangle to the region.
Union(PointF[]) | Adds polygon to the region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members


Union(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
Union(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Union Method : Union(RectangleF) Method

rect
The rectangle to add.

Glossary Item Box

Adds a rectangle to the region.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Union( _
   ByVal rect As RectangleF _
)
C#
public void Union(
   RectangleF rect
)

Parameters

rect
The rectangle to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


Union(PointF[]) Method

[image]
ActiveReports 19 .NET Edition
Union(PointF[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class > Union Method : Union(PointF[]) Method

polygonPoints
Polygon points

Glossary Item Box

Adds polygon to the region.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Union( _
   ByVal polygonPoints() As PointF _
)
C#
public void Union(
   PointF[] polygonPoints
)

Parameters

polygonPoints
Polygon points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members
Overload List


CompiledRegion Class Properties

[image]
ActiveReports 19 .NET Edition
CompiledRegion Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion Class

Glossary Item Box

For a list of all members of this type, see CompiledRegion members.

Public Properties

 | Name | Description
Public Property | Entities | Gets a read-only collection of entities defining the region.
Top

See Also

Reference

CompiledRegion Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Entities Property

[image]
ActiveReports 19 .NET Edition
Entities Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion Class : Entities Property

Glossary Item Box

Gets a read-only collection of entities defining the region.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Entities As IReadOnlyCollection(Of CompiledRegion.Entity)
C#
public IReadOnlyCollection<CompiledRegion.Entity> Entities {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion Class
CompiledRegion Members


CompiledRegionExtensions Class

[image]
ActiveReports 19 .NET Edition
CompiledRegionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegionExtensions Class

Glossary Item Box

Contains helper methods for the CompiledRegion.

Object Model

CompiledRegionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CompiledRegionExtensions
C#
public static class CompiledRegionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.CompiledRegionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegionExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
CompiledRegionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegionExtensions Class

Glossary Item Box

The following tables list the members exposed by CompiledRegionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compile | Converts the GrapeCity.ActiveReports.Drawing.RegionEx to a CompiledRegion.
static (Shared in Visual Basic) | Exclude | Excludes the specified path from the compiled region.
static (Shared in Visual Basic) | Intersect | Intersects the compiled region with the specified path.
static (Shared in Visual Basic) | Union | Adds the specified path to the compiled region.
Top

See Also

Reference

CompiledRegionExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
CompiledRegionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegionExtensions Class

Glossary Item Box

For a list of all members of this type, see CompiledRegionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compile | Converts the GrapeCity.ActiveReports.Drawing.RegionEx to a CompiledRegion.
static (Shared in Visual Basic) | Exclude | Excludes the specified path from the compiled region.
static (Shared in Visual Basic) | Intersect | Intersects the compiled region with the specified path.
static (Shared in Visual Basic) | Union | Adds the specified path to the compiled region.
Top

See Also

Reference

CompiledRegionExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Compile(RegionEx) Method

[image]
ActiveReports 19 .NET Edition
Compile(RegionEx) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegionExtensions Class : Compile(RegionEx) Method

region
The original region.

Glossary Item Box

Converts the GrapeCity.ActiveReports.Drawing.RegionEx to a CompiledRegion.

Syntax

Visual Basic (Declaration)
Public Shared Function Compile( _
   ByVal region As RegionEx _
) As CompiledRegion
C#
public static CompiledRegion Compile(
   RegionEx region
)

Parameters

region
The original region.

Return Value

A CompiledRegion representing the compiled region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegionExtensions Class
CompiledRegionExtensions Members


Exclude Method

[image]
ActiveReports 19 .NET Edition
Exclude Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegionExtensions Class : Exclude Method

rgn
The compiled region.
path
The path to exclude.

Glossary Item Box

Excludes the specified path from the compiled region.

Syntax

Visual Basic (Declaration)
Public Shared Sub Exclude( _
   ByVal rgn As CompiledRegion, _
   ByVal path As PathEx _
)
C#
public static void Exclude(
   CompiledRegion rgn,
   PathEx path
)

Parameters

rgn
The compiled region.
path
The path to exclude.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegionExtensions Class
CompiledRegionExtensions Members


Intersect Method

[image]
ActiveReports 19 .NET Edition
Intersect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegionExtensions Class : Intersect Method

rgn
The compiled region.
path
The path to intersect with.

Glossary Item Box

Intersects the compiled region with the specified path.

Syntax

Visual Basic (Declaration)
Public Shared Sub Intersect( _
   ByVal rgn As CompiledRegion, _
   ByVal path As PathEx _
)
C#
public static void Intersect(
   CompiledRegion rgn,
   PathEx path
)

Parameters

rgn
The compiled region.
path
The path to intersect with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegionExtensions Class
CompiledRegionExtensions Members


Union Method

[image]
ActiveReports 19 .NET Edition
Union Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegionExtensions Class : Union Method

rgn
The compiled region.
path
The path to add.

Glossary Item Box

Adds the specified path to the compiled region.

Syntax

Visual Basic (Declaration)
Public Shared Sub Union( _
   ByVal rgn As CompiledRegion, _
   ByVal path As PathEx _
)
C#
public static void Union(
   CompiledRegion rgn,
   PathEx path
)

Parameters

rgn
The compiled region.
path
The path to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegionExtensions Class
CompiledRegionExtensions Members


Constants Class

[image]
ActiveReports 19 .NET Edition
Constants Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Constants Class

Glossary Item Box

Contains constant values used throughout.

Object Model

Constants Class

Syntax

Visual Basic (Declaration)
Public Class Constants
C#
public class Constants

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.Constants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


Constants Class Members

[image]
ActiveReports 19 .NET Edition
Constants Class Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Constants Class

Glossary Item Box

The following tables list the members exposed by Constants.

Public Constructors

 | Name | Description
Public Constructor | Constants Constructor |
Top

Public Fields

 | Name | Description
Public Field | TWIPSPERINCH | The number of twips per inch. A twip is 1/1440th of an inch.
Top

See Also

Reference

Constants Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Constants Constructor

[image]
ActiveReports 19 .NET Edition
Constants Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Constants Class : Constants Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Constants()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


Constants Class Fields

[image]
ActiveReports 19 .NET Edition
Constants Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Constants Class

Glossary Item Box

For a list of all members of this type, see Constants members.

Public Fields

 | Name | Description
Public Field | TWIPSPERINCH | The number of twips per inch. A twip is 1/1440th of an inch.
Top

See Also

Reference

Constants Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


TWIPSPERINCH Field

[image]
ActiveReports 19 .NET Edition
TWIPSPERINCH Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Constants Class : TWIPSPERINCH Field

Glossary Item Box

The number of twips per inch. A twip is 1/1440th of an inch.

Syntax

Visual Basic (Declaration)
Public Const TWIPSPERINCH As Single
C#
public const float TWIPSPERINCH

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Constants Class
Constants Members


Converters Class

[image]
ActiveReports 19 .NET Edition
Converters Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Converters Class

Glossary Item Box

Provides methods to convert string representations to specific enumeration values.

Object Model

Converters Class

Syntax

Visual Basic (Declaration)
Public Class Converters
C#
public class Converters

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.Converters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Converters Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


Converters Class Members

[image]
ActiveReports 19 .NET Edition
Converters Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Converters Class

Glossary Item Box

The following tables list the members exposed by Converters.

Public Constructors

 | Name | Description
Public Constructor | Converters Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | TextJustifyFromString | Converts a string representation of text justify to the corresponding GrapeCity.ActiveReports.Drawing.TextJustify enumeration value.
static (Shared in Visual Basic) | WrapModeFromString | Converts a string representation of wrap mode to the corresponding GrapeCity.ActiveReports.Drawing.WrapMode enumeration value.
Top

See Also

Reference

Converters Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Converters Constructor

[image]
ActiveReports 19 .NET Edition
Converters Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Converters Class : Converters Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Converters()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Converters Class
Converters Members


Converters Class Methods

[image]
ActiveReports 19 .NET Edition
Converters Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Converters Class

Glossary Item Box

For a list of all members of this type, see Converters members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | TextJustifyFromString | Converts a string representation of text justify to the corresponding GrapeCity.ActiveReports.Drawing.TextJustify enumeration value.
static (Shared in Visual Basic) | WrapModeFromString | Converts a string representation of wrap mode to the corresponding GrapeCity.ActiveReports.Drawing.WrapMode enumeration value.
Top

See Also

Reference

Converters Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


TextJustifyFromString Method

[image]
ActiveReports 19 .NET Edition
TextJustifyFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Converters Class : TextJustifyFromString Method

textJustify
The string representation of text justify.

Glossary Item Box

Converts a string representation of text justify to the corresponding GrapeCity.ActiveReports.Drawing.TextJustify enumeration value.

Syntax

Visual Basic (Declaration)
Public Shared Function TextJustifyFromString( _
   ByVal textJustify As String _
) As TextJustify
C#
public static TextJustify TextJustifyFromString(
   string textJustify
)

Parameters

textJustify
The string representation of text justify.

Return Value

The corresponding GrapeCity.ActiveReports.Drawing.TextJustify enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Converters Class
Converters Members


WrapModeFromString Method

[image]
ActiveReports 19 .NET Edition
WrapModeFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Converters Class : WrapModeFromString Method

wrapMode
The string representation of wrap mode.

Glossary Item Box

Converts a string representation of wrap mode to the corresponding GrapeCity.ActiveReports.Drawing.WrapMode enumeration value.

Syntax

Visual Basic (Declaration)
Public Shared Function WrapModeFromString( _
   ByVal wrapMode As String _
) As WrapMode
C#
public static WrapMode WrapModeFromString(
   string wrapMode
)

Parameters

wrapMode
The string representation of wrap mode.

Return Value

The corresponding GrapeCity.ActiveReports.Drawing.WrapMode enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Converters Class
Converters Members


ConvertNumber Class

[image]
ActiveReports 19 .NET Edition
ConvertNumber Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ConvertNumber Class

Glossary Item Box

Provides methods to convert integers to strings using various numbering styles compatible with CSS2.

Object Model

ConvertNumber Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ConvertNumber
C#
public static class ConvertNumber

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ConvertNumber

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConvertNumber Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ConvertNumber Class Members

[image]
ActiveReports 19 .NET Edition
ConvertNumber Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ConvertNumber Class

Glossary Item Box

The following tables list the members exposed by ConvertNumber.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToString | Overloaded. Converts an integer to a string using the specified GrapeCity.ActiveReports.PageReportModel.NumberingStyle.
Top

See Also

Reference

ConvertNumber Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ConvertNumber Class Methods

[image]
ActiveReports 19 .NET Edition
ConvertNumber Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ConvertNumber Class

Glossary Item Box

For a list of all members of this type, see ConvertNumber members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToString | Overloaded. Converts an integer to a string using the specified GrapeCity.ActiveReports.PageReportModel.NumberingStyle.
Top

See Also

Reference

ConvertNumber Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ConvertNumber Class : ToString Method

Glossary Item Box

Converts an integer to a string using the specified GrapeCity.ActiveReports.PageReportModel.NumberingStyle.

Overload List

Overload | Description
ToString(Int32,NumberingStyle) | Converts an integer to a string using the specified GrapeCity.ActiveReports.PageReportModel.NumberingStyle.
ToString(Int32,String) | Converts an integer to a string using the specified numbering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConvertNumber Class
ConvertNumber Members


ToString(Int32,NumberingStyle) Method

[image]
ActiveReports 19 .NET Edition
ToString(Int32,NumberingStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ConvertNumber Class > ToString Method : ToString(Int32,NumberingStyle) Method

value
The integer to convert.
style
The numbering style to use for the conversion.

Glossary Item Box

Converts an integer to a string using the specified GrapeCity.ActiveReports.PageReportModel.NumberingStyle.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToString( _
   ByVal value As Integer, _
   ByVal style As NumberingStyle _
) As String
C#
public static string ToString(
   int value,
   NumberingStyle style
)

Parameters

value
The integer to convert.
style
The numbering style to use for the conversion.

Return Value

A string representation of the integer using the specified numbering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConvertNumber Class
ConvertNumber Members
Overload List


ToString(Int32,String) Method

[image]
ActiveReports 19 .NET Edition
ToString(Int32,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ConvertNumber Class > ToString Method : ToString(Int32,String) Method

value
The integer to convert.
style
The string representation of the numbering style to use for the conversion.

Glossary Item Box

Converts an integer to a string using the specified numbering style.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ToString( _
   ByVal value As Integer, _
   ByVal style As String _
) As String
C#
public static string ToString(
   int value,
   string style
)

Parameters

value
The integer to convert.
style
The string representation of the numbering style to use for the conversion.

Return Value

A string representation of the integer using the specified numbering style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConvertNumber Class
ConvertNumber Members
Overload List


CultureInfoExt Class

[image]
ActiveReports 19 .NET Edition
CultureInfoExt Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CultureInfoExt Class

Glossary Item Box

Provides extension methods for working with System.Globalization.CultureInfo.

Object Model

CultureInfoExt Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CultureInfoExt
C#
public static class CultureInfoExt

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.CultureInfoExt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CultureInfoExt Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


CultureInfoExt Class Members

[image]
ActiveReports 19 .NET Edition
CultureInfoExt Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CultureInfoExt Class

Glossary Item Box

The following tables list the members exposed by CultureInfoExt.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SetCalendar | Returns a System.Globalization.CultureInfo object with the specified calendar applied.
Top

See Also

Reference

CultureInfoExt Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


CultureInfoExt Class Methods

[image]
ActiveReports 19 .NET Edition
CultureInfoExt Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CultureInfoExt Class

Glossary Item Box

For a list of all members of this type, see CultureInfoExt members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SetCalendar | Returns a System.Globalization.CultureInfo object with the specified calendar applied.
Top

See Also

Reference

CultureInfoExt Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


SetCalendar Method

[image]
ActiveReports 19 .NET Edition
SetCalendar Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CultureInfoExt Class : SetCalendar Method

culture
The original culture.
calendarName
The name of the calendar to apply.

Glossary Item Box

Returns a System.Globalization.CultureInfo object with the specified calendar applied.

Syntax

Visual Basic (Declaration)
Public Shared Function SetCalendar( _
   ByVal culture As CultureInfo, _
   ByVal calendarName As String _
) As CultureInfo
C#
public static CultureInfo SetCalendar(
   CultureInfo culture,
   string calendarName
)

Parameters

culture
The original culture.
calendarName
The name of the calendar to apply.

Return Value

A System.Globalization.CultureInfo object with the specified calendar.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the specified calendar name is invalid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CultureInfoExt Class
CultureInfoExt Members


DataSourceTools Class

[image]
ActiveReports 19 .NET Edition
DataSourceTools Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : DataSourceTools Class

Glossary Item Box

Represents the methods for saving and loading shared data sources.

Object Model

DataSourceTools Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataSourceTools
C#
public static class DataSourceTools

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.DataSourceTools

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


DataSourceTools Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceTools Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : DataSourceTools Class

Glossary Item Box

The following tables list the members exposed by DataSourceTools.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadSharedDataSource | Overloaded. Loads a shared data source from the specified file path.
static (Shared in Visual Basic) | SaveSharedDataSource | Overloaded. Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.
static (Shared in Visual Basic) | ToStream | Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML stream.
Top

See Also

Reference

DataSourceTools Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


DataSourceTools Class Methods

[image]
ActiveReports 19 .NET Edition
DataSourceTools Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : DataSourceTools Class

Glossary Item Box

For a list of all members of this type, see DataSourceTools members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadSharedDataSource | Overloaded. Loads a shared data source from the specified file path.
static (Shared in Visual Basic) | SaveSharedDataSource | Overloaded. Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.
static (Shared in Visual Basic) | ToStream | Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML stream.
Top

See Also

Reference

DataSourceTools Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


LoadSharedDataSource Method

[image]
ActiveReports 19 .NET Edition
LoadSharedDataSource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class : LoadSharedDataSource Method

Glossary Item Box

Loads a shared data source from the specified file path.

Overload List

Overload | Description
LoadSharedDataSource(String) | Loads a shared data source from the specified file path.
LoadSharedDataSource(Stream) | Loads a shared data source from the specified XML stream.
LoadSharedDataSource(ResourceLocator,String) | Loads a shared data source using the specified resource locator and data source reference.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members


LoadSharedDataSource(String) Method

[image]
ActiveReports 19 .NET Edition
LoadSharedDataSource(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class > LoadSharedDataSource Method : LoadSharedDataSource(String) Method

filePath
The path to the .rdsx file.

Glossary Item Box

Loads a shared data source from the specified file path.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LoadSharedDataSource( _
   ByVal filePath As String _
) As DataSource
C#
public static DataSource LoadSharedDataSource(
   string filePath
)

Parameters

filePath
The path to the .rdsx file.

Return Value

The loaded GrapeCity.ActiveReports.PageReportModel.DataSource.

Exceptions

Exception | Description
System.IO.FileNotFoundException | Thrown if the file does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members
Overload List


LoadSharedDataSource(Stream) Method

[image]
ActiveReports 19 .NET Edition
LoadSharedDataSource(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class > LoadSharedDataSource Method : LoadSharedDataSource(Stream) Method

sharedDataSource
The System.IO.Stream containing the XML data of the shared data source.

Glossary Item Box

Loads a shared data source from the specified XML stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LoadSharedDataSource( _
   ByVal sharedDataSource As Stream _
) As DataSource
C#
public static DataSource LoadSharedDataSource(
   Stream sharedDataSource
)

Parameters

sharedDataSource
The System.IO.Stream containing the XML data of the shared data source.

Return Value

The loaded GrapeCity.ActiveReports.PageReportModel.DataSource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members
Overload List


LoadSharedDataSource(ResourceLocator,String) Method

[image]
ActiveReports 19 .NET Edition
LoadSharedDataSource(ResourceLocator,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class > LoadSharedDataSource Method : LoadSharedDataSource(ResourceLocator,String) Method

resourceLocator
The GrapeCity.ActiveReports.ResourceLocator instance.
dataSourceReference
The reference string of the shared data source.

Glossary Item Box

Loads a shared data source using the specified resource locator and data source reference.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function LoadSharedDataSource( _
   ByVal resourceLocator As ResourceLocator, _
   ByVal dataSourceReference As String _
) As DataSource
C#
public static DataSource LoadSharedDataSource(
   ResourceLocator resourceLocator,
   string dataSourceReference
)

Parameters

resourceLocator
The GrapeCity.ActiveReports.ResourceLocator instance.
dataSourceReference
The reference string of the shared data source.

Return Value

The loaded GrapeCity.ActiveReports.PageReportModel.DataSource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members
Overload List


SaveSharedDataSource Method

[image]
ActiveReports 19 .NET Edition
SaveSharedDataSource Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class : SaveSharedDataSource Method

Glossary Item Box

Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.

Overload List

Overload | Description
SaveSharedDataSource(FileInfo,DataSource) | Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.
SaveSharedDataSource(Stream,DataSource) | Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members


SaveSharedDataSource(FileInfo,DataSource) Method

[image]
ActiveReports 19 .NET Edition
SaveSharedDataSource(FileInfo,DataSource) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class > SaveSharedDataSource Method : SaveSharedDataSource(FileInfo,DataSource) Method

file
A System.IO.FileInfo containing information about where to save the XML file.
sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Glossary Item Box

Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SaveSharedDataSource( _
   ByVal file As FileInfo, _
   ByVal sharedDataSource As DataSource _
)
C#
public static void SaveSharedDataSource(
   FileInfo file,
   DataSource sharedDataSource
)

Parameters

file
A System.IO.FileInfo containing information about where to save the XML file.
sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members
Overload List


SaveSharedDataSource(Stream,DataSource) Method

[image]
ActiveReports 19 .NET Edition
SaveSharedDataSource(Stream,DataSource) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class > SaveSharedDataSource Method : SaveSharedDataSource(Stream,DataSource) Method

stream
A System.IO.Stream where the XML data will be written.
sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Glossary Item Box

Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SaveSharedDataSource( _
   ByVal stream As Stream, _
   ByVal sharedDataSource As DataSource _
)
C#
public static void SaveSharedDataSource(
   Stream stream,
   DataSource sharedDataSource
)

Parameters

stream
A System.IO.Stream where the XML data will be written.
sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members
Overload List


ToStream Method

[image]
ActiveReports 19 .NET Edition
ToStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > DataSourceTools Class : ToStream Method

sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Glossary Item Box

Saves the specified GrapeCity.ActiveReports.PageReportModel.DataSource to a shared data source XML stream.

Syntax

Visual Basic (Declaration)
Public Shared Function ToStream( _
   ByVal sharedDataSource As DataSource _
) As Stream
C#
public static Stream ToStream(
   DataSource sharedDataSource
)

Parameters

sharedDataSource
The GrapeCity.ActiveReports.PageReportModel.DataSource to save.

Return Value

A System.IO.Stream containing the XML data of the shared data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceTools Class
DataSourceTools Members


EnumerableExtension Class

[image]
ActiveReports 19 .NET Edition
EnumerableExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EnumerableExtension Class

Glossary Item Box

Provides extension methods for working with IEnumerable collections.

Object Model

EnumerableExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EnumerableExtension
C#
public static class EnumerableExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.EnumerableExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


EnumerableExtension Class Members

[image]
ActiveReports 19 .NET Edition
EnumerableExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EnumerableExtension Class

Glossary Item Box

The following tables list the members exposed by EnumerableExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ForceInBackground | Overloaded. Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.
static (Shared in Visual Basic) | Range<T> | Returns a range of elements from the list starting at the specified index.
static (Shared in Visual Basic) | SelectManyTransposed<T> | Selects many items in N-order.
static (Shared in Visual Basic) | SelectManyWithPrev<TSource,TResult> | Selects many items with a previous element reference.
static (Shared in Visual Basic) | SelectWithPrevNext<T,TResult> | Selects items with references to the previous and next elements.
static (Shared in Visual Basic) | ThrowIfCancelled<T> | Provides support for LINQ queries with a System.Threading.CancellationToken.
static (Shared in Visual Basic) | WithCancellation<T> | Enumerates the items with cancellation support.
static (Shared in Visual Basic) | WithProgress<T,T2> | Provides support for LINQ queries with a progress provider.
Top

See Also

Reference

EnumerableExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


EnumerableExtension Class Methods

[image]
ActiveReports 19 .NET Edition
EnumerableExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EnumerableExtension Class

Glossary Item Box

For a list of all members of this type, see EnumerableExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ForceInBackground | Overloaded. Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.
static (Shared in Visual Basic) | Range<T> | Returns a range of elements from the list starting at the specified index.
static (Shared in Visual Basic) | SelectManyTransposed<T> | Selects many items in N-order.
static (Shared in Visual Basic) | SelectManyWithPrev<TSource,TResult> | Selects many items with a previous element reference.
static (Shared in Visual Basic) | SelectWithPrevNext<T,TResult> | Selects items with references to the previous and next elements.
static (Shared in Visual Basic) | ThrowIfCancelled<T> | Provides support for LINQ queries with a System.Threading.CancellationToken.
static (Shared in Visual Basic) | WithCancellation<T> | Enumerates the items with cancellation support.
static (Shared in Visual Basic) | WithProgress<T,T2> | Provides support for LINQ queries with a progress provider.
Top

See Also

Reference

EnumerableExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ForceInBackground Method

[image]
ActiveReports 19 .NET Edition
ForceInBackground Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : ForceInBackground Method

Glossary Item Box

Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.

Overload List

Overload | Description
ForceInBackground<T>(IEnumerable<T>,CancellationToken) | Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.
ForceInBackground<T>(IEnumerable<T>,CancellationToken,Int32) | Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


ForceInBackground<T>(IEnumerable<T>,CancellationToken) Method

T
The type of elements in the sequence.
[image]
ActiveReports 19 .NET Edition
ForceInBackground<T>(IEnumerable<T>,CancellationToken) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class > ForceInBackground Method : ForceInBackground<T>(IEnumerable<T>,CancellationToken) Method

src
The source sequence.
cancellationToken
A token to cancel enumeration.

Glossary Item Box

Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ForceInBackground(Of T)( _
   ByVal src As IEnumerable(Of T), _
   ByVal cancellationToken As CancellationToken _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> ForceInBackground<T>(
   IEnumerable<T> src,
   CancellationToken cancellationToken
)

Parameters

src
The source sequence.
cancellationToken
A token to cancel enumeration.

Type Parameters

T
The type of elements in the sequence.

Return Value

A sequence that is evaluated in a background thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members
Overload List


ForceInBackground<T>(IEnumerable<T>,CancellationToken,Int32) Method

T
The type of elements in the sequence.
[image]
ActiveReports 19 .NET Edition
ForceInBackground<T>(IEnumerable<T>,CancellationToken,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class > ForceInBackground Method : ForceInBackground<T>(IEnumerable<T>,CancellationToken,Int32) Method

src
The source sequence.
cancellationToken
A token to cancel enumeration.
maxBufferSize
The maximum buffer size. If zero, the size is unlimited.

Glossary Item Box

Forces evaluation of the given IEnumerable in a separate thread and returns a new IEnumerable to be enumerated in the current thread.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ForceInBackground(Of T)( _
   ByVal src As IEnumerable(Of T), _
   ByVal cancellationToken As CancellationToken, _
   ByVal maxBufferSize As Integer _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> ForceInBackground<T>(
   IEnumerable<T> src,
   CancellationToken cancellationToken,
   int maxBufferSize
)

Parameters

src
The source sequence.
cancellationToken
A token to cancel enumeration.
maxBufferSize
The maximum buffer size. If zero, the size is unlimited.

Type Parameters

T
The type of elements in the sequence.

Return Value

A sequence that is evaluated in a background thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members
Overload List


Range<T> Method

T
The type of elements in the list.
[image]
ActiveReports 19 .NET Edition
Range<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : Range<T> Method

list
The list from which to retrieve elements.
startIndex
The zero-based starting index of the range.
count
The number of elements to retrieve.

Glossary Item Box

Returns a range of elements from the list starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Shared Function Range(Of T)( _
   ByVal list As IList(Of T), _
   ByVal startIndex As Integer, _
   ByVal count As Integer _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Range<T>(
   IList<T> list,
   int startIndex,
   int count
)

Parameters

list
The list from which to retrieve elements.
startIndex
The zero-based starting index of the range.
count
The number of elements to retrieve.

Type Parameters

T
The type of elements in the list.

Return Value

A sequence of elements from the list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


SelectManyTransposed<T> Method

T
The type of elements in the sequence.
[image]
ActiveReports 19 .NET Edition
SelectManyTransposed<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : SelectManyTransposed<T> Method

src
The source sequence of sequences.

Glossary Item Box

Selects many items in N-order.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectManyTransposed(Of T)( _
   ByVal src As IEnumerable(Of IEnumerable(Of T)) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> SelectManyTransposed<T>(
   IEnumerable<IEnumerable<T>> src
)

Parameters

src
The source sequence of sequences.

Type Parameters

T
The type of elements in the sequence.

Return Value

A sequence of elements transposed from the source sequences.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


SelectManyWithPrev<TSource,TResult> Method

TSource
The type of elements in the source sequence.
TResult
The type of elements in the result sequence.
[image]
ActiveReports 19 .NET Edition
SelectManyWithPrev<TSource,TResult> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : SelectManyWithPrev<TSource,TResult> Method

source
The source sequence.
selector
A function to project each element and its previous element into a sequence of results.

Glossary Item Box

Selects many items with a previous element reference.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectManyWithPrev
    (Of TSource,TResult)( _
   ByVal source As IEnumerable(Of TSource), _
   ByVal selector As Func(Of TResult,TSource,IEnumerable(Of TResult)) _
) As IEnumerable(Of TResult)
C#
public static IEnumerable<TResult> SelectManyWithPrev<TSource,TResult>(
   IEnumerable<TSource> source,
   Func<TResult,TSource,IEnumerable<TResult>> selector
)

Parameters

source
The source sequence.
selector
A function to project each element and its previous element into a sequence of results.

Type Parameters

TSource
The type of elements in the source sequence.
TResult
The type of elements in the result sequence.

Return Value

A sequence of projected elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


SelectWithPrevNext<T,TResult> Method

T
The type of elements in the sequence.
TResult
The type of elements in the result sequence.
[image]
ActiveReports 19 .NET Edition
SelectWithPrevNext<T,TResult> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : SelectWithPrevNext<T,TResult> Method

items
The source sequence.
selector
A function to project each element with references to the previous and next elements.

Glossary Item Box

Selects items with references to the previous and next elements.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWithPrevNext
    (Of T As Class,
     TResult)( _
   ByVal items As IEnumerable(Of T), _
   ByVal selector As Func(Of T,T,T,TResult) _
) As IEnumerable(Of TResult)
C#
public static IEnumerable<TResult> SelectWithPrevNext<T,TResult>(
   IEnumerable<T> items,
   Func<T,T,T,TResult> selector
)
where T: class

Parameters

items
The source sequence.
selector
A function to project each element with references to the previous and next elements.

Type Parameters

T
The type of elements in the sequence.
TResult
The type of elements in the result sequence.

Return Value

A sequence of projected elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


ThrowIfCancelled<T> Method

T
The type of elements in the sequence.
[image]
ActiveReports 19 .NET Edition
ThrowIfCancelled<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : ThrowIfCancelled<T> Method

items
The source sequence.
token
A token to cancel enumeration.

Glossary Item Box

Provides support for LINQ queries with a System.Threading.CancellationToken.

Syntax

Visual Basic (Declaration)
Public Shared Function ThrowIfCancelled(Of T)( _
   ByVal items As IEnumerable(Of T), _
   ByVal token As CancellationToken _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> ThrowIfCancelled<T>(
   IEnumerable<T> items,
   CancellationToken token
)

Parameters

items
The source sequence.
token
A token to cancel enumeration.

Type Parameters

T
The type of elements in the sequence.

Return Value

A sequence that supports throwing if cancelled.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


WithCancellation<T> Method

T
The type of elements in the sequence.
[image]
ActiveReports 19 .NET Edition
WithCancellation<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : WithCancellation<T> Method

items
The source sequence.
token
A token to cancel enumeration.

Glossary Item Box

Enumerates the items with cancellation support.

Syntax

Visual Basic (Declaration)
Public Shared Function WithCancellation(Of T)( _
   ByVal items As IEnumerable(Of T), _
   ByVal token As CancellationToken _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> WithCancellation<T>(
   IEnumerable<T> items,
   CancellationToken token
)

Parameters

items
The source sequence.
token
A token to cancel enumeration.

Type Parameters

T
The type of elements in the sequence.

Return Value

A sequence that supports cancellation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


WithProgress<T,T2> Method

T
The type of elements in the sequence.
T2
The type of progress information.
[image]
ActiveReports 19 .NET Edition
WithProgress<T,T2> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EnumerableExtension Class : WithProgress<T,T2> Method

items
The source sequence.
progress
The IProgress instance to report progress to.
getProgressInfo
A function to get progress information from an element.

Glossary Item Box

Provides support for LINQ queries with a progress provider.

Syntax

Visual Basic (Declaration)
Public Shared Function WithProgress
    (Of T,T2)( _
   ByVal items As IEnumerable(Of T), _
   ByVal progress As IProgress(Of T2), _
   ByVal getProgressInfo As Func(Of T,T2) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> WithProgress<T,T2>(
   IEnumerable<T> items,
   IProgress<T2> progress,
   Func<T,T2> getProgressInfo
)

Parameters

items
The source sequence.
progress
The IProgress instance to report progress to.
getProgressInfo
A function to get progress information from an element.

Type Parameters

T
The type of elements in the sequence.
T2
The type of progress information.

Return Value

A sequence that reports progress.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtension Class
EnumerableExtension Members


FloatExtensions Class

[image]
ActiveReports 19 .NET Edition
FloatExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FloatExtensions Class

Glossary Item Box

Provides extension methods for converting between different measurement units for floating-point values.

Object Model

FloatExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FloatExtensions
C#
public static class FloatExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.FloatExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FloatExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


FloatExtensions Class Members

[image]
ActiveReports 19 .NET Edition
FloatExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FloatExtensions Class

Glossary Item Box

The following tables list the members exposed by FloatExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromPixelToTwips | Converts a value from pixels to twips.
static (Shared in Visual Basic) | FromPointsToTwips | Converts a value from points to twips.
Top

See Also

Reference

FloatExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


FloatExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
FloatExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FloatExtensions Class

Glossary Item Box

For a list of all members of this type, see FloatExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromPixelToTwips | Converts a value from pixels to twips.
static (Shared in Visual Basic) | FromPointsToTwips | Converts a value from points to twips.
Top

See Also

Reference

FloatExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


FromPixelToTwips Method

[image]
ActiveReports 19 .NET Edition
FromPixelToTwips Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FloatExtensions Class : FromPixelToTwips Method

val
The value in pixels.

Glossary Item Box

Converts a value from pixels to twips.

Syntax

Visual Basic (Declaration)
Public Shared Function FromPixelToTwips( _
   ByVal val As Single _
) As Single
C#
public static float FromPixelToTwips(
   float val
)

Parameters

val
The value in pixels.

Return Value

The equivalent value in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FloatExtensions Class
FloatExtensions Members


FromPointsToTwips Method

[image]
ActiveReports 19 .NET Edition
FromPointsToTwips Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FloatExtensions Class : FromPointsToTwips Method

val
The value in points.

Glossary Item Box

Converts a value from points to twips.

Syntax

Visual Basic (Declaration)
Public Shared Function FromPointsToTwips( _
   ByVal val As Single _
) As Single
C#
public static float FromPointsToTwips(
   float val
)

Parameters

val
The value in points.

Return Value

The equivalent value in twips.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FloatExtensions Class
FloatExtensions Members


FuncExtensions Class

[image]
ActiveReports 19 .NET Edition
FuncExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FuncExtensions Class

Glossary Item Box

Provides extension methods for memoizing functions.

Object Model

FuncExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class FuncExtensions
C#
public static class FuncExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.FuncExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


FuncExtensions Class Members

[image]
ActiveReports 19 .NET Edition
FuncExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FuncExtensions Class

Glossary Item Box

The following tables list the members exposed by FuncExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Memoize | Overloaded. Memoizes a function with a single parameter.
Top

See Also

Reference

FuncExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


FuncExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
FuncExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : FuncExtensions Class

Glossary Item Box

For a list of all members of this type, see FuncExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Memoize | Overloaded. Memoizes a function with a single parameter.
Top

See Also

Reference

FuncExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Memoize Method

[image]
ActiveReports 19 .NET Edition
Memoize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FuncExtensions Class : Memoize Method

Glossary Item Box

Memoizes a function with a single parameter.

Overload List

Overload | Description
Memoize<T,TResult>(Func<T,TResult>,Boolean,IEqualityComparer<T>,Func<T,Boolean>) | Memoizes a function with a single parameter.
Memoize<T1,T2,TResult>(Func<T1,T2,TResult>,Boolean,Func<T1,T2,Boolean>) | Memoizes a function with two parameters.
Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean) | Memoizes a function with three parameters.
Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean,Func<T1,T2,T3,Boolean>) | Memoizes a function with three parameters, with a condition to determine if the result should be cached.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Class
FuncExtensions Members


Memoize<T,TResult>(Func<T,TResult>,Boolean,IEqualityComparer<T>,Func<T,Boolean>) Method

T
The type of the input parameter.
TResult
The type of the result.
[image]
ActiveReports 19 .NET Edition
Memoize<T,TResult>(Func<T,TResult>,Boolean,IEqualityComparer<T>,Func<T,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FuncExtensions Class > Memoize Method : Memoize<T,TResult>(Func<T,TResult>,Boolean,IEqualityComparer<T>,Func<T,Boolean>) Method

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
comparer
The equality comparer to use for the input parameter.
useCacheCondition
A function to determine if the result should be cached.

Glossary Item Box

Memoizes a function with a single parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Memoize
    (Of T,TResult)( _
   ByVal func As Func(Of T,TResult), _
   Optional ByVal threadSafe As Boolean, _
   Optional ByVal comparer As IEqualityComparer(Of T), _
   Optional ByVal useCacheCondition As Func(Of T,Boolean) _
) As Func(Of T,TResult)
C#
public static Func<T,TResult> Memoize<T,TResult>(
   Func<T,TResult> func,
   bool threadSafe,
   IEqualityComparer<T> comparer,
   Func<T,bool> useCacheCondition
)

Parameters

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
comparer
The equality comparer to use for the input parameter.
useCacheCondition
A function to determine if the result should be cached.

Type Parameters

T
The type of the input parameter.
TResult
The type of the result.

Return Value

A memoized version of the function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Class
FuncExtensions Members
Overload List


Memoize<T1,T2,TResult>(Func<T1,T2,TResult>,Boolean,Func<T1,T2,Boolean>) Method

T1
The type of the first input parameter.
T2
The type of the second input parameter.
TResult
The type of the result.
[image]
ActiveReports 19 .NET Edition
Memoize<T1,T2,TResult>(Func<T1,T2,TResult>,Boolean,Func<T1,T2,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FuncExtensions Class > Memoize Method : Memoize<T1,T2,TResult>(Func<T1,T2,TResult>,Boolean,Func<T1,T2,Boolean>) Method

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
useCacheCondition
A function to determine if the result should be cached.

Glossary Item Box

Memoizes a function with two parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Memoize
    (Of T1,T2,TResult)( _
   ByVal func As Func(Of T1,T2,TResult), _
   Optional ByVal threadSafe As Boolean, _
   Optional ByVal useCacheCondition As Func(Of T1,T2,Boolean) _
) As Func(Of T1,T2,TResult)
C#
public static Func<T1,T2,TResult> Memoize<T1,T2,TResult>(
   Func<T1,T2,TResult> func,
   bool threadSafe,
   Func<T1,T2,bool> useCacheCondition
)

Parameters

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
useCacheCondition
A function to determine if the result should be cached.

Type Parameters

T1
The type of the first input parameter.
T2
The type of the second input parameter.
TResult
The type of the result.

Return Value

A memoized version of the function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Class
FuncExtensions Members
Overload List


Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean) Method

T1
The type of the first input parameter.
T2
The type of the second input parameter.
T3
The type of the third input parameter.
TResult
The type of the result.
[image]
ActiveReports 19 .NET Edition
Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FuncExtensions Class > Memoize Method : Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean) Method

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.

Glossary Item Box

Memoizes a function with three parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Memoize
    (Of T1,T2,T3,TResult)( _
   ByVal func As Func(Of T1,T2,T3,TResult), _
   Optional ByVal threadSafe As Boolean _
) As Func(Of T1,T2,T3,TResult)
C#
public static Func<T1,T2,T3,TResult> Memoize<T1,T2,T3,TResult>(
   Func<T1,T2,T3,TResult> func,
   bool threadSafe
)

Parameters

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.

Type Parameters

T1
The type of the first input parameter.
T2
The type of the second input parameter.
T3
The type of the third input parameter.
TResult
The type of the result.

Return Value

A memoized version of the function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Class
FuncExtensions Members
Overload List


Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean,Func<T1,T2,T3,Boolean>) Method

T1
The type of the first input parameter.
T2
The type of the second input parameter.
T3
The type of the third input parameter.
TResult
The type of the result.
[image]
ActiveReports 19 .NET Edition
Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean,Func<T1,T2,T3,Boolean>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > FuncExtensions Class > Memoize Method : Memoize<T1,T2,T3,TResult>(Func<T1,T2,T3,TResult>,Boolean,Func<T1,T2,T3,Boolean>) Method

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
useCacheCondition
A function to determine if the result should be cached.

Glossary Item Box

Memoizes a function with three parameters, with a condition to determine if the result should be cached.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Memoize
    (Of T1,T2,T3,TResult)( _
   ByVal func As Func(Of T1,T2,T3,TResult), _
   ByVal threadSafe As Boolean, _
   ByVal useCacheCondition As Func(Of T1,T2,T3,Boolean) _
) As Func(Of T1,T2,T3,TResult)
C#
public static Func<T1,T2,T3,TResult> Memoize<T1,T2,T3,TResult>(
   Func<T1,T2,T3,TResult> func,
   bool threadSafe,
   Func<T1,T2,T3,bool> useCacheCondition
)

Parameters

func
The function to memoize.
threadSafe
Indicates whether the memoization should be thread-safe.
useCacheCondition
A function to determine if the result should be cached.

Type Parameters

T1
The type of the first input parameter.
T2
The type of the second input parameter.
T3
The type of the third input parameter.
TResult
The type of the result.

Return Value

A memoized version of the function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncExtensions Class
FuncExtensions Members
Overload List


HashCalculator Class

[image]
ActiveReports 19 .NET Edition
HashCalculator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : HashCalculator Class

Glossary Item Box

Provides MD5 digest calculation implementation.

Object Model

HashCalculator Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class HashCalculator
C#
public static class HashCalculator

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.HashCalculator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


HashCalculator Class Members

[image]
ActiveReports 19 .NET Edition
HashCalculator Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : HashCalculator Class

Glossary Item Box

The following tables list the members exposed by HashCalculator.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ComputeMD5 | Overloaded. Computes the MD5 hash for the specified binary stream.
static (Shared in Visual Basic) | ComputeSimpleHash | Overloaded. Computes a simplified hash for the specified binary stream.
static (Shared in Visual Basic) | ComputeSimpleStringHash | Overloaded. Computes a simplified hash for the specified binary stream.
Top

See Also

Reference

HashCalculator Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


HashCalculator Class Methods

[image]
ActiveReports 19 .NET Edition
HashCalculator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : HashCalculator Class

Glossary Item Box

For a list of all members of this type, see HashCalculator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ComputeMD5 | Overloaded. Computes the MD5 hash for the specified binary stream.
static (Shared in Visual Basic) | ComputeSimpleHash | Overloaded. Computes a simplified hash for the specified binary stream.
static (Shared in Visual Basic) | ComputeSimpleStringHash | Overloaded. Computes a simplified hash for the specified binary stream.
Top

See Also

Reference

HashCalculator Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ComputeMD5 Method

[image]
ActiveReports 19 .NET Edition
ComputeMD5 Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class : ComputeMD5 Method

Glossary Item Box

Computes the MD5 hash for the specified binary stream.

Overload List

Overload | Description
ComputeMD5(Stream) | Computes the MD5 hash for the specified binary stream.
ComputeMD5(Byte[]) | Computes the MD5 hash for the specified binary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members


ComputeMD5(Stream) Method

[image]
ActiveReports 19 .NET Edition
ComputeMD5(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeMD5 Method : ComputeMD5(Stream) Method

stream
The binary stream.

Glossary Item Box

Computes the MD5 hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeMD5( _
   ByVal stream As Stream _
) As Byte()
C#
public static byte[] ComputeMD5(
   Stream stream
)

Parameters

stream
The binary stream.

Return Value

The computed MD5 hash.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


ComputeMD5(Byte[]) Method

[image]
ActiveReports 19 .NET Edition
ComputeMD5(Byte[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeMD5 Method : ComputeMD5(Byte[]) Method

stream
The binary stream as a byte array.

Glossary Item Box

Computes the MD5 hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeMD5( _
   ByVal stream() As Byte _
) As Byte()
C#
public static byte[] ComputeMD5(
   byte[] stream
)

Parameters

stream
The binary stream as a byte array.

Return Value

The computed MD5 hash.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


ComputeSimpleHash Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleHash Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class : ComputeSimpleHash Method

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Overload List

Overload | Description
ComputeSimpleHash(Stream) | Computes a simplified hash for the specified binary stream.
ComputeSimpleHash(Byte[]) | Computes a simplified hash for the specified binary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members


ComputeSimpleHash(Stream) Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleHash(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeSimpleHash Method : ComputeSimpleHash(Stream) Method

stream
The binary stream.

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeSimpleHash( _
   ByVal stream As Stream _
) As Byte()
C#
public static byte[] ComputeSimpleHash(
   Stream stream
)

Parameters

stream
The binary stream.

Return Value

The computed simplified hash.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


ComputeSimpleHash(Byte[]) Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleHash(Byte[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeSimpleHash Method : ComputeSimpleHash(Byte[]) Method

stream
The binary stream as a byte array.

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeSimpleHash( _
   ByVal stream() As Byte _
) As Byte()
C#
public static byte[] ComputeSimpleHash(
   byte[] stream
)

Parameters

stream
The binary stream as a byte array.

Return Value

The computed simplified hash.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


ComputeSimpleStringHash Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleStringHash Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class : ComputeSimpleStringHash Method

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Overload List

Overload | Description
ComputeSimpleStringHash(Stream) | Computes a simplified hash for the specified binary stream.
ComputeSimpleStringHash(Byte[]) | Computes a simplified hash for the specified binary stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members


ComputeSimpleStringHash(Stream) Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleStringHash(Stream) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeSimpleStringHash Method : ComputeSimpleStringHash(Stream) Method

stream
The binary stream.

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeSimpleStringHash( _
   ByVal stream As Stream _
) As String
C#
public static string ComputeSimpleStringHash(
   Stream stream
)

Parameters

stream
The binary stream.

Return Value

The computed simplified hash as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


ComputeSimpleStringHash(Byte[]) Method

[image]
ActiveReports 19 .NET Edition
ComputeSimpleStringHash(Byte[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > HashCalculator Class > ComputeSimpleStringHash Method : ComputeSimpleStringHash(Byte[]) Method

stream
The binary stream as a byte array.

Glossary Item Box

Computes a simplified hash for the specified binary stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ComputeSimpleStringHash( _
   ByVal stream() As Byte _
) As String
C#
public static string ComputeSimpleStringHash(
   byte[] stream
)

Parameters

stream
The binary stream as a byte array.

Return Value

The computed simplified hash as a string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HashCalculator Class
HashCalculator Members
Overload List


IReportExtensions Class

[image]
ActiveReports 19 .NET Edition
IReportExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : IReportExtensions Class

Glossary Item Box

Provides extension methods for the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport interface.

Object Model

IReportExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class IReportExtensions
C#
public static class IReportExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.IReportExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


IReportExtensions Class Members

[image]
ActiveReports 19 .NET Edition
IReportExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : IReportExtensions Class

Glossary Item Box

The following tables list the members exposed by IReportExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | HasDelayedContent | Checks if the report has items with delayed expressions.
static (Shared in Visual Basic) | HasDelayedPageName | Checks if the report has items with delayed expressions in their page name settings.
static (Shared in Visual Basic) | HasDelayedStyle | Checks if the report has items with delayed expressions in their styles.
static (Shared in Visual Basic) | HasDelayedValue | Checks if the report has items which Value has the delayed expression.
static (Shared in Visual Basic) | HasDelayedVisibility | Checks if the report has items with delayed expressions in their visibility settings.
static (Shared in Visual Basic) | HasNumberingStyle | Checks if the report has items which Value has numbering style.
static (Shared in Visual Basic) | SetCustomEvaluationBanner | Sets a custom evaluation banner for the specified report.
Top

See Also

Reference

IReportExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


IReportExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
IReportExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : IReportExtensions Class

Glossary Item Box

For a list of all members of this type, see IReportExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | HasDelayedContent | Checks if the report has items with delayed expressions.
static (Shared in Visual Basic) | HasDelayedPageName | Checks if the report has items with delayed expressions in their page name settings.
static (Shared in Visual Basic) | HasDelayedStyle | Checks if the report has items with delayed expressions in their styles.
static (Shared in Visual Basic) | HasDelayedValue | Checks if the report has items which Value has the delayed expression.
static (Shared in Visual Basic) | HasDelayedVisibility | Checks if the report has items with delayed expressions in their visibility settings.
static (Shared in Visual Basic) | HasNumberingStyle | Checks if the report has items which Value has numbering style.
static (Shared in Visual Basic) | SetCustomEvaluationBanner | Sets a custom evaluation banner for the specified report.
Top

See Also

Reference

IReportExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


HasDelayedContent(IReport) Method

[image]
ActiveReports 19 .NET Edition
HasDelayedContent(IReport) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasDelayedContent(IReport) Method

report
The report to check.

Glossary Item Box

Checks if the report has items with delayed expressions.

Syntax

Visual Basic (Declaration)
Public Shared Function HasDelayedContent( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasDelayedContent(
   IReport report
)

Parameters

report
The report to check.

Return Value

true if the report has items with delayed expressions; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


HasDelayedPageName Method

[image]
ActiveReports 19 .NET Edition
HasDelayedPageName Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasDelayedPageName Method

report
The report to check.

Glossary Item Box

Checks if the report has items with delayed expressions in their page name settings.

Syntax

Visual Basic (Declaration)
Public Shared Function HasDelayedPageName( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasDelayedPageName(
   IReport report
)

Parameters

report
The report to check.

Return Value

true if the report has items with delayed expressions in their page name settings; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


HasDelayedStyle Method

[image]
ActiveReports 19 .NET Edition
HasDelayedStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasDelayedStyle Method

report
The report to check.

Glossary Item Box

Checks if the report has items with delayed expressions in their styles.

Syntax

Visual Basic (Declaration)
Public Shared Function HasDelayedStyle( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasDelayedStyle(
   IReport report
)

Parameters

report
The report to check.

Return Value

true if the report has items with delayed expressions in their styles; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


HasDelayedValue Method

[image]
ActiveReports 19 .NET Edition
HasDelayedValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasDelayedValue Method

report
Report

Glossary Item Box

Checks if the report has items which Value has the delayed expression.

Syntax

Visual Basic (Declaration)
Public Shared Function HasDelayedValue( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasDelayedValue(
   IReport report
)

Parameters

report
Report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


HasDelayedVisibility Method

[image]
ActiveReports 19 .NET Edition
HasDelayedVisibility Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasDelayedVisibility Method

report
The report to check.

Glossary Item Box

Checks if the report has items with delayed expressions in their visibility settings.

Syntax

Visual Basic (Declaration)
Public Shared Function HasDelayedVisibility( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasDelayedVisibility(
   IReport report
)

Parameters

report
The report to check.

Return Value

true if the report has items with delayed expressions in their visibility settings; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


HasNumberingStyle Method

[image]
ActiveReports 19 .NET Edition
HasNumberingStyle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : HasNumberingStyle Method

report
Report

Glossary Item Box

Checks if the report has items which Value has numbering style.

Syntax

Visual Basic (Declaration)
Public Shared Function HasNumberingStyle( _
   ByVal report As IReport _
) As Boolean
C#
public static bool HasNumberingStyle(
   IReport report
)

Parameters

report
Report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


SetCustomEvaluationBanner Method

[image]
ActiveReports 19 .NET Edition
SetCustomEvaluationBanner Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > IReportExtensions Class : SetCustomEvaluationBanner Method

report
The report to set the evaluation banner for.
banner
The settings for the evaluation banner.

Glossary Item Box

Sets a custom evaluation banner for the specified report.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetCustomEvaluationBanner( _
   ByVal report As IReport, _
   ByVal banner As EvaluationBannerSettings _
)
C#
public static void SetCustomEvaluationBanner(
   IReport report,
   EvaluationBannerSettings banner
)

Parameters

report
The report to set the evaluation banner for.
banner
The settings for the evaluation banner.

Exceptions

Exception | Description
System.Exception | Thrown when the license level is not Professional.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportExtensions Class
IReportExtensions Members


Kinsoku Class

[image]
ActiveReports 19 .NET Edition
Kinsoku Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Kinsoku Class

Glossary Item Box

Provides support for Japanese Kinsoku line-breaking rules.

Object Model

Kinsoku Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Kinsoku
C#
public static class Kinsoku

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.Kinsoku

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Kinsoku Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


Kinsoku Class Members

[image]
ActiveReports 19 .NET Edition
Kinsoku Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Kinsoku Class

Glossary Item Box

The following tables list the members exposed by Kinsoku.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CanBeFirstCharOnNextLineJap | Determines whether the specified character can be the first character on the next line according to Japanese Kinsoku line-breaking rules.
static (Shared in Visual Basic) | CanBeLastCharOnLineJap | Determines whether the specified character can be the last character on a line according to Japanese Kinsoku line-breaking rules.
static (Shared in Visual Basic) | GetLineBreak | Find latest possible line break position before 'lineBreakPos'.
Top

See Also

Reference

Kinsoku Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Kinsoku Class Methods

[image]
ActiveReports 19 .NET Edition
Kinsoku Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : Kinsoku Class

Glossary Item Box

For a list of all members of this type, see Kinsoku members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CanBeFirstCharOnNextLineJap | Determines whether the specified character can be the first character on the next line according to Japanese Kinsoku line-breaking rules.
static (Shared in Visual Basic) | CanBeLastCharOnLineJap | Determines whether the specified character can be the last character on a line according to Japanese Kinsoku line-breaking rules.
static (Shared in Visual Basic) | GetLineBreak | Find latest possible line break position before 'lineBreakPos'.
Top

See Also

Reference

Kinsoku Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


CanBeFirstCharOnNextLineJap Method

[image]
ActiveReports 19 .NET Edition
CanBeFirstCharOnNextLineJap Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Kinsoku Class : CanBeFirstCharOnNextLineJap Method

ch
The character to check.

Glossary Item Box

Determines whether the specified character can be the first character on the next line according to Japanese Kinsoku line-breaking rules.

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeFirstCharOnNextLineJap( _
   ByVal ch As Char _
) As Boolean
C#
public static bool CanBeFirstCharOnNextLineJap(
   char ch
)

Parameters

ch
The character to check.

Return Value

true if the character can be the first character on the next line; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Kinsoku Class
Kinsoku Members


CanBeLastCharOnLineJap Method

[image]
ActiveReports 19 .NET Edition
CanBeLastCharOnLineJap Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Kinsoku Class : CanBeLastCharOnLineJap Method

ch
The character to check.

Glossary Item Box

Determines whether the specified character can be the last character on a line according to Japanese Kinsoku line-breaking rules.

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeLastCharOnLineJap( _
   ByVal ch As Char _
) As Boolean
C#
public static bool CanBeLastCharOnLineJap(
   char ch
)

Parameters

ch
The character to check.

Return Value

true if the character can be the last character on the line; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Kinsoku Class
Kinsoku Members


GetLineBreak(String,Int32,Boolean,Boolean,Boolean) Method

[image]
ActiveReports 19 .NET Edition
GetLineBreak(String,Int32,Boolean,Boolean,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > Kinsoku Class : GetLineBreak(String,Int32,Boolean,Boolean,Boolean) Method

text
Source text.
lineBreakPos
Desired line break position.
useKinsoku
If False, kinsoku rules will be ignored.
breakNotJapan
If True, non-japanese words can be splitted.
firstInLine
The source text locates at the start of the line.

Glossary Item Box

Find latest possible line break position before 'lineBreakPos'.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLineBreak( _
   ByVal text As String, _
   ByVal lineBreakPos As Integer, _
   ByVal useKinsoku As Boolean, _
   ByVal breakNotJapan As Boolean, _
   Optional ByVal firstInLine As Boolean _
) As Integer
C#
public static int GetLineBreak(
   string text,
   int lineBreakPos,
   bool useKinsoku,
   bool breakNotJapan,
   bool firstInLine
)

Parameters

text
Source text.
lineBreakPos
Desired line break position.
useKinsoku
If False, kinsoku rules will be ignored.
breakNotJapan
If True, non-japanese words can be splitted.
firstInLine
The source text locates at the start of the line.

Return Value

Line break position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Kinsoku Class
Kinsoku Members


NameValueCollectionExtensions Class

[image]
ActiveReports 19 .NET Edition
NameValueCollectionExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : NameValueCollectionExtensions Class

Glossary Item Box

Provides extension methods for updating and applying settings in a System.Collections.Specialized.NameValueCollection.

Object Model

NameValueCollectionExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class NameValueCollectionExtensions
C#
public static class NameValueCollectionExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.NameValueCollectionExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameValueCollectionExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


NameValueCollectionExtensions Class Members

[image]
ActiveReports 19 .NET Edition
NameValueCollectionExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : NameValueCollectionExtensions Class

Glossary Item Box

The following tables list the members exposed by NameValueCollectionExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyTo<T> | Applies settings from the System.Collections.Specialized.NameValueCollection to the specified object.
static (Shared in Visual Basic) | UpdateSettings | Updates the System.Collections.Specialized.NameValueCollection with data from the object's fields and properties.
Top

See Also

Reference

NameValueCollectionExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


NameValueCollectionExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
NameValueCollectionExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : NameValueCollectionExtensions Class

Glossary Item Box

For a list of all members of this type, see NameValueCollectionExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyTo<T> | Applies settings from the System.Collections.Specialized.NameValueCollection to the specified object.
static (Shared in Visual Basic) | UpdateSettings | Updates the System.Collections.Specialized.NameValueCollection with data from the object's fields and properties.
Top

See Also

Reference

NameValueCollectionExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ApplyTo<T> Method

T
The type of the target object.
[image]
ActiveReports 19 .NET Edition
ApplyTo<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > NameValueCollectionExtensions Class : ApplyTo<T> Method

settings
The System.Collections.Specialized.NameValueCollection containing the settings.
target
The object to apply the settings to.
setInnerSetting
Indicates whether to set inner settings.
suppressExceptions
Indicates whether to suppress exceptions.

Glossary Item Box

Applies settings from the System.Collections.Specialized.NameValueCollection to the specified object.

Syntax

Visual Basic (Declaration)
Public Shared Function ApplyTo(Of T)( _
   ByVal settings As NameValueCollection, _
   ByVal target As T, _
   Optional ByVal setInnerSetting As Boolean, _
   Optional ByVal suppressExceptions As Boolean _
) As T
C#
public static T ApplyTo<T>(
   NameValueCollection settings,
   T target,
   bool setInnerSetting,
   bool suppressExceptions
)

Parameters

settings
The System.Collections.Specialized.NameValueCollection containing the settings.
target
The object to apply the settings to.
setInnerSetting
Indicates whether to set inner settings.
suppressExceptions
Indicates whether to suppress exceptions.

Type Parameters

T
The type of the target object.

Return Value

The target object with the applied settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameValueCollectionExtensions Class
NameValueCollectionExtensions Members


UpdateSettings Method

[image]
ActiveReports 19 .NET Edition
UpdateSettings Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > NameValueCollectionExtensions Class : UpdateSettings Method

settings
The System.Collections.Specialized.NameValueCollection to update.
data
The object containing the data.

Glossary Item Box

Updates the System.Collections.Specialized.NameValueCollection with data from the object's fields and properties.

Syntax

Visual Basic (Declaration)
Public Shared Sub UpdateSettings( _
   ByVal settings As NameValueCollection, _
   ByVal data As Object _
)
C#
public static void UpdateSettings(
   NameValueCollection settings,
   object data
)

Parameters

settings
The System.Collections.Specialized.NameValueCollection to update.
data
The object containing the data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameValueCollectionExtensions Class
NameValueCollectionExtensions Members


ObjectRefComparer<T> Class

T
The type of objects to compare.
[image]
ActiveReports 19 .NET Edition
ObjectRefComparer<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ObjectRefComparer<T> Class

Glossary Item Box

Provides a comparer for objects that compares by reference equality.

Object Model

ObjectRefComparer<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectRefComparer(Of T As Class)
C#
public sealed class ObjectRefComparer<T>
where T: class

Type Parameters

T
The type of objects to compare.

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ObjectRefComparer<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ObjectRefComparer<T> Class Members

[image]
ActiveReports 19 .NET Edition
ObjectRefComparer<T> Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ObjectRefComparer<T> Class

Glossary Item Box

The following tables list the members exposed by ObjectRefComparer<T>.

Public Constructors

 | Name | Description
Public Constructor | ObjectRefComparer<T> Constructor |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified objects are equal by comparing their references.
Public Method | GetHashCode | Overloaded. Returns a hash code for the specified object.
Top

See Also

Reference

ObjectRefComparer<T> Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ObjectRefComparer<T> Constructor

[image]
ActiveReports 19 .NET Edition
ObjectRefComparer<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ObjectRefComparer<T> Class : ObjectRefComparer<T> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ObjectRefComparer<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Class
ObjectRefComparer<T> Members


ObjectRefComparer<T> Class Methods

[image]
ActiveReports 19 .NET Edition
ObjectRefComparer<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ObjectRefComparer<T> Class

Glossary Item Box

For a list of all members of this type, see ObjectRefComparer<T> members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified objects are equal by comparing their references.
Public Method | GetHashCode | Overloaded. Returns a hash code for the specified object.
Top

See Also

Reference

ObjectRefComparer<T> Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ObjectRefComparer<T> Class : Equals Method

Glossary Item Box

Determines whether the specified objects are equal by comparing their references.

Overload List

Overload | Description
Equals(T,T) | Determines whether the specified objects are equal by comparing their references.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Class
ObjectRefComparer<T> Members


Equals(T,T) Method

[image]
ActiveReports 19 .NET Edition
Equals(T,T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ObjectRefComparer<T> Class > Equals Method : Equals(T,T) Method

x
The first object to compare.
y
The second object to compare.

Glossary Item Box

Determines whether the specified objects are equal by comparing their references.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal x As T, _
   ByVal y As T _
) As Boolean
C#
public bool Equals(
   T x,
   T y
)

Parameters

x
The first object to compare.
y
The second object to compare.

Return Value

true if the objects are the same reference; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Class
ObjectRefComparer<T> Members
Overload List


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ObjectRefComparer<T> Class : GetHashCode Method

Glossary Item Box

Returns a hash code for the specified object.

Overload List

Overload | Description
GetHashCode(T) | Returns a hash code for the specified object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Class
ObjectRefComparer<T> Members


GetHashCode(T) Method

[image]
ActiveReports 19 .NET Edition
GetHashCode(T) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ObjectRefComparer<T> Class > GetHashCode Method : GetHashCode(T) Method

obj
The object for which a hash code is to be returned.

Glossary Item Box

Returns a hash code for the specified object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetHashCode( _
   ByVal obj As T _
) As Integer
C#
public int GetHashCode(
   T obj
)

Parameters

obj
The object for which a hash code is to be returned.

Return Value

A hash code for the specified object, based on its reference.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRefComparer<T> Class
ObjectRefComparer<T> Members
Overload List


PageReportModelExtensions Class

[image]
ActiveReports 19 .NET Edition
PageReportModelExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PageReportModelExtensions Class

Glossary Item Box

Provides extension methods for the GrapeCity.ActiveReports.PageReportModel class.

Object Model

PageReportModelExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PageReportModelExtensions
C#
public static class PageReportModelExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.PageReportModelExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReportModelExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


PageReportModelExtensions Class Members

[image]
ActiveReports 19 .NET Edition
PageReportModelExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PageReportModelExtensions Class

Glossary Item Box

The following tables list the members exposed by PageReportModelExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsOneFigureChart | Determines whether the specified chart is a single figure chart.
Top

See Also

Reference

PageReportModelExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


PageReportModelExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
PageReportModelExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PageReportModelExtensions Class

Glossary Item Box

For a list of all members of this type, see PageReportModelExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | IsOneFigureChart | Determines whether the specified chart is a single figure chart.
Top

See Also

Reference

PageReportModelExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


IsOneFigureChart Method

[image]
ActiveReports 19 .NET Edition
IsOneFigureChart Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > PageReportModelExtensions Class : IsOneFigureChart Method

chart
The chart to check.

Glossary Item Box

Determines whether the specified chart is a single figure chart.

Syntax

Visual Basic (Declaration)
Public Shared Function IsOneFigureChart( _
   ByVal chart As Chart _
) As Boolean
C#
public static bool IsOneFigureChart(
   Chart chart
)

Parameters

chart
The chart to check.

Return Value

true if the chart is a single figure chart (Pie, Doughnut, Funnel, or Pyramid); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReportModelExtensions Class
PageReportModelExtensions Members


RenderersFactory Class

[image]
ActiveReports 19 .NET Edition
RenderersFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : RenderersFactory Class

Glossary Item Box

Factory for creating standard component renderers.

Object Model

RenderersFactory Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RenderersFactory
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory
C#
public sealed class RenderersFactory : GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.RenderersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderersFactory Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


RenderersFactory Class Members

[image]
ActiveReports 19 .NET Edition
RenderersFactory Class Members
See Also Fields Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : RenderersFactory Class

Glossary Item Box

The following tables list the members exposed by RenderersFactory.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the singleton instance of the RenderersFactory.
Top

Public Methods

 | Name | Description
Public Method | GetRenderer<T> | Gets the renderer for the specified report item.
Top

See Also

Reference

RenderersFactory Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


RenderersFactory Class Methods

[image]
ActiveReports 19 .NET Edition
RenderersFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : RenderersFactory Class

Glossary Item Box

For a list of all members of this type, see RenderersFactory members.

Public Methods

 | Name | Description
Public Method | GetRenderer<T> | Gets the renderer for the specified report item.
Top

See Also

Reference

RenderersFactory Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


GetRenderer<T> Method

T
The type of the renderer.
[image]
ActiveReports 19 .NET Edition
GetRenderer<T> Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > RenderersFactory Class : GetRenderer<T> Method

item
The report item.

Glossary Item Box

Gets the renderer for the specified report item.

Syntax

Visual Basic (Declaration)
Public Function GetRenderer(Of T As {Class, IRenderer})( _
   ByVal item As IReportItem _
) As T
C#
public T GetRenderer<T>(
   IReportItem item
)
where T: class, IRenderer

Parameters

item
The report item.

Type Parameters

T
The type of the renderer.

Return Value

The renderer for the specified report item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderersFactory Class
RenderersFactory Members


RenderersFactory Class Fields

[image]
ActiveReports 19 .NET Edition
RenderersFactory Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : RenderersFactory Class

Glossary Item Box

For a list of all members of this type, see RenderersFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the singleton instance of the RenderersFactory.
Top

See Also

Reference

RenderersFactory Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Instance Field

[image]
ActiveReports 19 .NET Edition
Instance Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > RenderersFactory Class : Instance Field

Glossary Item Box

Gets the singleton instance of the RenderersFactory.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As RenderersFactory
C#
public static readonly RenderersFactory Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderersFactory Class
RenderersFactory Members


ReportStoreValidationExtensions Class

[image]
ActiveReports 19 .NET Edition
ReportStoreValidationExtensions Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ReportStoreValidationExtensions Class

Glossary Item Box

Extends the GrapeCity.ActiveReports.Rendering.ReportStore class with report validation features.

Object Model

ReportStoreValidationExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ReportStoreValidationExtensions
C#
public static class ReportStoreValidationExtensions

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ReportStoreValidationExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreValidationExtensions Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ReportStoreValidationExtensions Class Members

[image]
ActiveReports 19 .NET Edition
ReportStoreValidationExtensions Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ReportStoreValidationExtensions Class

Glossary Item Box

The following tables list the members exposed by ReportStoreValidationExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ValidateReport | Validates the report in the specified report store using the specified validation mode.
Top

See Also

Reference

ReportStoreValidationExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ReportStoreValidationExtensions Class Methods

[image]
ActiveReports 19 .NET Edition
ReportStoreValidationExtensions Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ReportStoreValidationExtensions Class

Glossary Item Box

For a list of all members of this type, see ReportStoreValidationExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ValidateReport | Validates the report in the specified report store using the specified validation mode.
Top

See Also

Reference

ReportStoreValidationExtensions Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ValidateReport(ReportStore,ValidationMode) Method

[image]
ActiveReports 19 .NET Edition
ValidateReport(ReportStore,ValidationMode) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ReportStoreValidationExtensions Class : ValidateReport(ReportStore,ValidationMode) Method

store
The report store to validate.
mode
The validation mode.

Glossary Item Box

Validates the report in the specified report store using the specified validation mode.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateReport( _
   ByVal store As ReportStore, _
   ByVal mode As ValidationMode _
) As ValidationEntry()
C#
public static ValidationEntry[] ValidateReport(
   ReportStore store,
   ValidationMode mode
)

Parameters

store
The report store to validate.
mode
The validation mode.

Return Value

An array of validation entries representing the validation errors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportStoreValidationExtensions Class
ReportStoreValidationExtensions Members


SharedDataSourceLoadException Class

[image]
ActiveReports 19 .NET Edition
SharedDataSourceLoadException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : SharedDataSourceLoadException Class

Glossary Item Box

Represents errors that occur during the loading of a shared data source.

Object Model

SharedDataSourceLoadException Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SharedDataSourceLoadException
   Inherits System.Exception
C#
public sealed class SharedDataSourceLoadException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.Tools.SharedDataSourceLoadException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceLoadException Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


SharedDataSourceLoadException Class Members

[image]
ActiveReports 19 .NET Edition
SharedDataSourceLoadException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : SharedDataSourceLoadException Class

Glossary Item Box

The following tables list the members exposed by SharedDataSourceLoadException.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code indicating the type of error that occurred.
Top

See Also

Reference

SharedDataSourceLoadException Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


SharedDataSourceLoadException Class Properties

[image]
ActiveReports 19 .NET Edition
SharedDataSourceLoadException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : SharedDataSourceLoadException Class

Glossary Item Box

For a list of all members of this type, see SharedDataSourceLoadException members.

Public Properties

 | Name | Description
Public Property | ErrorCode | Gets the error code indicating the type of error that occurred.
Top

See Also

Reference

SharedDataSourceLoadException Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ErrorCode Property

[image]
ActiveReports 19 .NET Edition
ErrorCode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > SharedDataSourceLoadException Class : ErrorCode Property

Glossary Item Box

Gets the error code indicating the type of error that occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As SharedDataSourceLoadException.ErrorCodes
C#
public SharedDataSourceLoadException.ErrorCodes ErrorCode {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedDataSourceLoadException Class
SharedDataSourceLoadException Members


StreamExtension Class

[image]
ActiveReports 19 .NET Edition
StreamExtension Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : StreamExtension Class

Glossary Item Box

Provides extension methods for working with streams.

Object Model

StreamExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class StreamExtension
C#
public static class StreamExtension

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.StreamExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamExtension Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


StreamExtension Class Members

[image]
ActiveReports 19 .NET Edition
StreamExtension Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : StreamExtension Class

Glossary Item Box

The following tables list the members exposed by StreamExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | MakeUndisposable | Creates a wrapper around the specified stream that prevents the Dispose method from being called.
static (Shared in Visual Basic) | ReadToEnd | Reads the stream to the end and returns the content as a string.
static (Shared in Visual Basic) | ToArray | Converts the specified stream to a byte array.
Top

See Also

Reference

StreamExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


StreamExtension Class Methods

[image]
ActiveReports 19 .NET Edition
StreamExtension Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : StreamExtension Class

Glossary Item Box

For a list of all members of this type, see StreamExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | MakeUndisposable | Creates a wrapper around the specified stream that prevents the Dispose method from being called.
static (Shared in Visual Basic) | ReadToEnd | Reads the stream to the end and returns the content as a string.
static (Shared in Visual Basic) | ToArray | Converts the specified stream to a byte array.
Top

See Also

Reference

StreamExtension Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


MakeUndisposable Method

[image]
ActiveReports 19 .NET Edition
MakeUndisposable Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > StreamExtension Class : MakeUndisposable Method

stream
The stream to wrap.

Glossary Item Box

Creates a wrapper around the specified stream that prevents the Dispose method from being called.

Syntax

Visual Basic (Declaration)
Public Shared Function MakeUndisposable( _
   ByVal stream As Stream _
) As Stream
C#
public static Stream MakeUndisposable(
   Stream stream
)

Parameters

stream
The stream to wrap.

Return Value

A System.IO.Stream that does not call Dispose.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamExtension Class
StreamExtension Members


ReadToEnd Method

[image]
ActiveReports 19 .NET Edition
ReadToEnd Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > StreamExtension Class : ReadToEnd Method

stream
The stream to read.

Glossary Item Box

Reads the stream to the end and returns the content as a string.

Syntax

Visual Basic (Declaration)
Public Shared Function ReadToEnd( _
   ByVal stream As Stream _
) As String
C#
public static string ReadToEnd(
   Stream stream
)

Parameters

stream
The stream to read.

Return Value

A string containing the contents of the stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamExtension Class
StreamExtension Members


ToArray Method

[image]
ActiveReports 19 .NET Edition
ToArray Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > StreamExtension Class : ToArray Method

stream
The stream to convert.

Glossary Item Box

Converts the specified stream to a byte array.

Syntax

Visual Basic (Declaration)
Public Shared Function ToArray( _
   ByVal stream As Stream _
) As Byte()
C#
public static byte[] ToArray(
   Stream stream
)

Parameters

stream
The stream to convert.

Return Value

A byte array containing the contents of the stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamExtension Class
StreamExtension Members


ValidationException Class

[image]
ActiveReports 19 .NET Edition
ValidationException Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ValidationException Class

Glossary Item Box

Represents errors that occur during validation.

Object Model

ValidationException Class

Syntax

Visual Basic (Declaration)
Public Class ValidationException
   Inherits System.Exception
C#
public class ValidationException : System.Exception

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Rendering.Tools.ValidationException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationException Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ValidationException Class Members

[image]
ActiveReports 19 .NET Edition
ValidationException Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ValidationException Class

Glossary Item Box

The following tables list the members exposed by ValidationException.

Public Constructors

 | Name | Description
Public Constructor | ValidationException Constructor | Initializes a new instance of the ValidationException class with a specified error message.
Top

See Also

Reference

ValidationException Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ValidationException Constructor

[image]
ActiveReports 19 .NET Edition
ValidationException Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ValidationException Class : ValidationException Constructor

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the ValidationException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public ValidationException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationException Class
ValidationException Members


ValidatorBase<T> Class

T
Type of object to validate
[image]
ActiveReports 19 .NET Edition
ValidatorBase<T> Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ValidatorBase<T> Class

Glossary Item Box

Base class for validation classes

Object Model

ValidatorBase<T> Class

Syntax

Visual Basic (Declaration)
Public Class ValidatorBase(Of T As Class)
C#
public class ValidatorBase<T>
where T: class

Type Parameters

T
Type of object to validate

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.ValidatorBase<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidatorBase<T> Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ValidatorBase<T> Class Members

[image]
ActiveReports 19 .NET Edition
ValidatorBase<T> Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ValidatorBase<T> Class

Glossary Item Box

The following tables list the members exposed by ValidatorBase<T>.

Public Constructors

 | Name | Description
Public Constructor | ValidatorBase<T> Constructor |
Top

Public Methods

 | Name | Description
Public Method | Validate | Runs validation
Public Method | ValidateAndTrow | Runs validation and throws a ValidationException if fail
Top

See Also

Reference

ValidatorBase<T> Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


ValidatorBase<T> Constructor

[image]
ActiveReports 19 .NET Edition
ValidatorBase<T> Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ValidatorBase<T> Class : ValidatorBase<T> Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ValidatorBase<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidatorBase<T> Class
ValidatorBase<T> Members


ValidatorBase<T> Class Methods

[image]
ActiveReports 19 .NET Edition
ValidatorBase<T> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ValidatorBase<T> Class

Glossary Item Box

For a list of all members of this type, see ValidatorBase<T> members.

Public Methods

 | Name | Description
Public Method | Validate | Runs validation
Public Method | ValidateAndTrow | Runs validation and throws a ValidationException if fail
Top

See Also

Reference

ValidatorBase<T> Class
GrapeCity.ActiveReports.Rendering.Tools Namespace


Validate Method

[image]
ActiveReports 19 .NET Edition
Validate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ValidatorBase<T> Class : Validate Method

obj
Object to validate

Glossary Item Box

Runs validation

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal obj As T _
) As IEnumerable(Of Tuple(Of Boolean,String))
C#
public IEnumerable<Tuple<bool,string>> Validate(
   T obj
)

Parameters

obj
Object to validate

Return Value

Validation result as Tuple<bool, string> where Item1 - is a boolean that says whether the validation succeeded, Item2 - a collection of error messages about any validation failures

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidatorBase<T> Class
ValidatorBase<T> Members


ValidateAndTrow Method

[image]
ActiveReports 19 .NET Edition
ValidateAndTrow Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ValidatorBase<T> Class : ValidateAndTrow Method

obj
Object to validate

Glossary Item Box

Runs validation and throws a ValidationException if fail

Syntax

Visual Basic (Declaration)
Public Sub ValidateAndTrow( _
   ByVal obj As T _
)
C#
public void ValidateAndTrow(
   T obj
)

Parameters

obj
Object to validate

Exceptions

Exception | Description
ValidationException | Validation failed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidatorBase<T> Class
ValidatorBase<T> Members


ChartPaletteType Enumeration

[image]
ActiveReports 19 .NET Edition
ChartPaletteType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteType Enumeration

Glossary Item Box

The chart pallete type.

Syntax

Visual Basic (Declaration)
Public Enum ChartPaletteType
   Inherits System.Enum
C#
public enum ChartPaletteType : System.Enum

Members

Member | Description
Custom | Custom palette type
Standard | Standard palette type
Theme | Theme palette type

Remarks

This enumeration should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Tools.ChartPaletteType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Tools Namespace


PaperSizesProvider.PaperSizes Enumeration

[image]
ActiveReports 19 .NET Edition
PaperSizesProvider.PaperSizes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PaperSizesProvider.PaperSizes Enumeration

Glossary Item Box

Valid paper size values.

Syntax

Visual Basic (Declaration)
Public Enum PaperSizesProvider.PaperSizes
   Inherits System.Enum
C#
public enum PaperSizesProvider.PaperSizes : System.Enum

Members

Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.)
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Tools.PaperSizesProvider.PaperSizes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Tools Namespace


SharedDataSourceLoadException.ErrorCodes Enumeration

[image]
ActiveReports 19 .NET Edition
SharedDataSourceLoadException.ErrorCodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : SharedDataSourceLoadException.ErrorCodes Enumeration

Glossary Item Box

Enum representing error codes for SharedDataSourceLoadException.

Syntax

Visual Basic (Declaration)
Public Enum SharedDataSourceLoadException.ErrorCodes
   Inherits System.Enum
C#
public enum SharedDataSourceLoadException.ErrorCodes : System.Enum

Members

Member | Description
CanNotBeLoaded | Indicates that the shared data source cannot be loaded.
MissingElement | Indicates a missing required XML element.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Rendering.Tools.SharedDataSourceLoadException.ErrorCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Rendering.Tools Namespace


ChartPaletteInfo Structure

[image]
ActiveReports 19 .NET Edition
ChartPaletteInfo Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteInfo Structure

Glossary Item Box

Represents information about chart palette.

Object Model

ChartPaletteInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure ChartPaletteInfo
   Inherits System.ValueType
C#
public struct ChartPaletteInfo : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Tools.ChartPaletteInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteInfo Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


ChartPaletteInfo Structure Members

[image]
ActiveReports 19 .NET Edition
ChartPaletteInfo Structure Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteInfo Structure

Glossary Item Box

The following tables list the members exposed by ChartPaletteInfo.

Public Constructors

 | Name | Description
Public Constructor | ChartPaletteInfo Constructor | Initializes a new instance of the ChartPaletteInfo struct.
Top

Public Properties

 | Name | Description
Public Property | Key | Gets the palette key.
Public Property | Name | Gets the palette name.
Public Property | Type | Gets the palette type.
Top

See Also

Reference

ChartPaletteInfo Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


ChartPaletteInfo Constructor

[image]
ActiveReports 19 .NET Edition
ChartPaletteInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteInfo Structure : ChartPaletteInfo Constructor

key
The palette key.
name
The palette name.
type
The palette type.

Glossary Item Box

Initializes a new instance of the ChartPaletteInfo struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal key As String, _
   ByVal name As String, _
   ByVal type As ChartPaletteType _
)
C#
public ChartPaletteInfo(
   string key,
   string name,
   ChartPaletteType type
)

Parameters

key
The palette key.
name
The palette name.
type
The palette type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteInfo Structure
ChartPaletteInfo Members


ChartPaletteInfo Structure Properties

[image]
ActiveReports 19 .NET Edition
ChartPaletteInfo Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : ChartPaletteInfo Structure

Glossary Item Box

For a list of all members of this type, see ChartPaletteInfo members.

Public Properties

 | Name | Description
Public Property | Key | Gets the palette key.
Public Property | Name | Gets the palette name.
Public Property | Type | Gets the palette type.
Top

See Also

Reference

ChartPaletteInfo Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


Key Property

[image]
ActiveReports 19 .NET Edition
Key Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteInfo Structure : Key Property

Glossary Item Box

Gets the palette key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Key As String
C#
public string Key {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteInfo Structure
ChartPaletteInfo Members


Name Property

[image]
ActiveReports 19 .NET Edition
Name Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteInfo Structure : Name Property

Glossary Item Box

Gets the palette name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteInfo Structure
ChartPaletteInfo Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > ChartPaletteInfo Structure : Type Property

Glossary Item Box

Gets the palette type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ChartPaletteType
C#
public ChartPaletteType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPaletteInfo Structure
ChartPaletteInfo Members


CompiledRegion.Entity Structure

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion.Entity Structure

Glossary Item Box

Represents an entity defined by a set of points. Can be used to represent a rectangle.

Object Model

CompiledRegion.Entity Structure

Syntax

Visual Basic (Declaration)
Public Structure CompiledRegion.Entity
   Inherits System.ValueType
C#
public struct CompiledRegion.Entity : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Tools.CompiledRegion.Entity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegion.Entity Structure Members

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Structure Members
See Also Fields Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion.Entity Structure

Glossary Item Box

The following tables list the members exposed by CompiledRegion.Entity.

Public Constructors

 | Name | Description
Public Constructor | CompiledRegion.Entity Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Points | The points defining the entity.
Top

Public Properties

 | Name | Description
Public Property | IsRect | Gets a value indicating whether the entity is a rectangle.
Public Property | Rectangle | Gets the rectangle represented by the entity.
Top

See Also

Reference

CompiledRegion.Entity Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


CompiledRegion.Entity Constructor

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure : CompiledRegion.Entity Constructor

Glossary Item Box

Overload List

Overload | Description
CompiledRegion.Entity Constructor(PointF[]) | Initializes a new instance of the CompiledRegion.Entity struct with the specified points.
CompiledRegion.Entity Constructor(RectangleF) | Initializes a new instance of the CompiledRegion.Entity struct from a System.Drawing.RectangleF.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members


CompiledRegion.Entity Constructor(PointF[])

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Constructor(PointF[])
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure > CompiledRegion.Entity Constructor : CompiledRegion.Entity Constructor(PointF[])

points
An array of points defining the entity.

Glossary Item Box

Initializes a new instance of the CompiledRegion.Entity struct with the specified points.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points() As PointF _
)
C#
public CompiledRegion.Entity(
   PointF[] points
)

Parameters

points
An array of points defining the entity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members
Overload List


CompiledRegion.Entity Constructor(RectangleF)

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Constructor(RectangleF)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure > CompiledRegion.Entity Constructor : CompiledRegion.Entity Constructor(RectangleF)

rect
The rectangle to be represented as an entity.

Glossary Item Box

Initializes a new instance of the CompiledRegion.Entity struct from a System.Drawing.RectangleF.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF _
)
C#
public CompiledRegion.Entity(
   RectangleF rect
)

Parameters

rect
The rectangle to be represented as an entity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members
Overload List


CompiledRegion.Entity Structure Properties

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Structure Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion.Entity Structure

Glossary Item Box

For a list of all members of this type, see CompiledRegion.Entity members.

Public Properties

 | Name | Description
Public Property | IsRect | Gets a value indicating whether the entity is a rectangle.
Public Property | Rectangle | Gets the rectangle represented by the entity.
Top

See Also

Reference

CompiledRegion.Entity Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


IsRect Property

[image]
ActiveReports 19 .NET Edition
IsRect Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure : IsRect Property

Glossary Item Box

Gets a value indicating whether the entity is a rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRect As Boolean
C#
public bool IsRect {get;}

Property Value

true if the entity is defined by exactly two points, representing a rectangle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members


Rectangle Property

[image]
ActiveReports 19 .NET Edition
Rectangle Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure : Rectangle Property

Glossary Item Box

Gets the rectangle represented by the entity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rectangle As RectangleF
C#
public RectangleF Rectangle {get;}

Property Value

A System.Drawing.RectangleF structure that represents the entity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members


CompiledRegion.Entity Structure Fields

[image]
ActiveReports 19 .NET Edition
CompiledRegion.Entity Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : CompiledRegion.Entity Structure

Glossary Item Box

For a list of all members of this type, see CompiledRegion.Entity members.

Public Fields

 | Name | Description
Public Field | Points | The points defining the entity.
Top

See Also

Reference

CompiledRegion.Entity Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


Points Field

[image]
ActiveReports 19 .NET Edition
Points Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > CompiledRegion.Entity Structure : Points Field

Glossary Item Box

The points defining the entity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Points As PointF()
C#
public readonly PointF[] Points

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledRegion.Entity Structure
CompiledRegion.Entity Members


EvaluationBannerSettings Structure

[image]
ActiveReports 19 .NET Edition
EvaluationBannerSettings Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EvaluationBannerSettings Structure

Glossary Item Box

Represents settings for displaying an evaluation banner.

Object Model

EvaluationBannerSettings Structure

Syntax

Visual Basic (Declaration)
Public Structure EvaluationBannerSettings
   Inherits System.ValueType
C#
public struct EvaluationBannerSettings : System.ValueType

Remarks

This structure should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Tools.EvaluationBannerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationBannerSettings Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


EvaluationBannerSettings Structure Members

[image]
ActiveReports 19 .NET Edition
EvaluationBannerSettings Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EvaluationBannerSettings Structure

Glossary Item Box

The following tables list the members exposed by EvaluationBannerSettings.

Public Fields

 | Name | Description
Public Field | Color | Gets or sets the color of the evaluation banner text.
Public Field | Font | Gets or sets the font information for the evaluation banner text.
Public Field | Position | Gets or sets the position of the evaluation banner.
Public Field | Text | Gets or sets the text to be displayed on the evaluation banner.
Top

See Also

Reference

EvaluationBannerSettings Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


EvaluationBannerSettings Structure Fields

[image]
ActiveReports 19 .NET Edition
EvaluationBannerSettings Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : EvaluationBannerSettings Structure

Glossary Item Box

For a list of all members of this type, see EvaluationBannerSettings members.

Public Fields

 | Name | Description
Public Field | Color | Gets or sets the color of the evaluation banner text.
Public Field | Font | Gets or sets the font information for the evaluation banner text.
Public Field | Position | Gets or sets the position of the evaluation banner.
Public Field | Text | Gets or sets the text to be displayed on the evaluation banner.
Top

See Also

Reference

EvaluationBannerSettings Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


Color Field

[image]
ActiveReports 19 .NET Edition
Color Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EvaluationBannerSettings Structure : Color Field

Glossary Item Box

Gets or sets the color of the evaluation banner text.

Syntax

Visual Basic (Declaration)
Public Color As Color
C#
public Color Color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationBannerSettings Structure
EvaluationBannerSettings Members


Font Field

[image]
ActiveReports 19 .NET Edition
Font Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EvaluationBannerSettings Structure : Font Field

Glossary Item Box

Gets or sets the font information for the evaluation banner text.

Syntax

Visual Basic (Declaration)
Public Font As FontInfo
C#
public FontInfo Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationBannerSettings Structure
EvaluationBannerSettings Members


Position Field

[image]
ActiveReports 19 .NET Edition
Position Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EvaluationBannerSettings Structure : Position Field

Glossary Item Box

Gets or sets the position of the evaluation banner.

Syntax

Visual Basic (Declaration)
Public Position As EvalPosition
C#
public EvalPosition Position

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationBannerSettings Structure
EvaluationBannerSettings Members


Text Field

[image]
ActiveReports 19 .NET Edition
Text Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > EvaluationBannerSettings Structure : Text Field

Glossary Item Box

Gets or sets the text to be displayed on the evaluation banner.

Syntax

Visual Basic (Declaration)
Public Text As String
C#
public string Text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EvaluationBannerSettings Structure
EvaluationBannerSettings Members


PaperSizesProvider.PaperDescriptor Structure

[image]
ActiveReports 19 .NET Edition
PaperSizesProvider.PaperDescriptor Structure
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PaperSizesProvider.PaperDescriptor Structure

Glossary Item Box

Paper descriptor with few details.

Object Model

PaperSizesProvider.PaperDescriptor Structure

Syntax

Visual Basic (Declaration)
Public Structure PaperSizesProvider.PaperDescriptor
   Inherits System.ValueType
C#
public struct PaperSizesProvider.PaperDescriptor : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Rendering.Tools.PaperSizesProvider.PaperDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSizesProvider.PaperDescriptor Members
GrapeCity.ActiveReports.Rendering.Tools Namespace


PaperSizesProvider.PaperDescriptor Structure Members

[image]
ActiveReports 19 .NET Edition
PaperSizesProvider.PaperDescriptor Structure Members
See Also Fields

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PaperSizesProvider.PaperDescriptor Structure

Glossary Item Box

The following tables list the members exposed by PaperSizesProvider.PaperDescriptor.

Public Constructors

 | Name | Description
Public Constructor | PaperSizesProvider.PaperDescriptor Constructor | Creates a new descriptor.
Top

Public Fields

 | Name | Description
Public Field | Height | Paper height.
Public Field | PaperSize | Paper size name.
Public Field | Width | Paper width.
Top

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


PaperSizesProvider.PaperDescriptor Constructor

[image]
ActiveReports 19 .NET Edition
PaperSizesProvider.PaperDescriptor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > PaperSizesProvider.PaperDescriptor Structure : PaperSizesProvider.PaperDescriptor Constructor

paperSize
width
height

Glossary Item Box

Creates a new descriptor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paperSize As PaperSizesProvider.PaperSizes, _
   ByVal width As Length, _
   ByVal height As Length _
)
C#
public PaperSizesProvider.PaperDescriptor(
   PaperSizesProvider.PaperSizes paperSize,
   Length width,
   Length height
)

Parameters

paperSize
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
PaperSizesProvider.PaperDescriptor Members


PaperSizesProvider.PaperDescriptor Structure Fields

[image]
ActiveReports 19 .NET Edition
PaperSizesProvider.PaperDescriptor Structure Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace : PaperSizesProvider.PaperDescriptor Structure

Glossary Item Box

For a list of all members of this type, see PaperSizesProvider.PaperDescriptor members.

Public Fields

 | Name | Description
Public Field | Height | Paper height.
Public Field | PaperSize | Paper size name.
Public Field | Width | Paper width.
Top

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
GrapeCity.ActiveReports.Rendering.Tools Namespace


Height Field

[image]
ActiveReports 19 .NET Edition
Height Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > PaperSizesProvider.PaperDescriptor Structure : Height Field

Glossary Item Box

Paper height.

Syntax

Visual Basic (Declaration)
Public ReadOnly Height As Length
C#
public readonly Length Height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
PaperSizesProvider.PaperDescriptor Members


PaperSize Field

[image]
ActiveReports 19 .NET Edition
PaperSize Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > PaperSizesProvider.PaperDescriptor Structure : PaperSize Field

Glossary Item Box

Paper size name.

Syntax

Visual Basic (Declaration)
Public ReadOnly PaperSize As PaperSizesProvider.PaperSizes
C#
public readonly PaperSizesProvider.PaperSizes PaperSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
PaperSizesProvider.PaperDescriptor Members


Width Field

[image]
ActiveReports 19 .NET Edition
Width Field
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools Namespace > PaperSizesProvider.PaperDescriptor Structure : Width Field

Glossary Item Box

Paper width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Width As Length
C#
public readonly Length Width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaperSizesProvider.PaperDescriptor Structure
PaperSizesProvider.PaperDescriptor Members


MapImageLocator Class

[image]
ActiveReports 19 .NET Edition
MapImageLocator Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace : MapImageLocator Class

Glossary Item Box

Image locator for map.

Object Model

MapImageLocator Class

Syntax

Visual Basic (Declaration)
Public Class MapImageLocator
   Implements GrapeCity.ActiveReports.Rendering.Components.Interfaces.IMapImageLocator
C#
public class MapImageLocator : GrapeCity.ActiveReports.Rendering.Components.Interfaces.IMapImageLocator

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.Tools.Image.MapImageLocator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapImageLocator Members
GrapeCity.ActiveReports.Rendering.Tools.Image Namespace


MapImageLocator Class Members

[image]
ActiveReports 19 .NET Edition
MapImageLocator Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace : MapImageLocator Class

Glossary Item Box

The following tables list the members exposed by MapImageLocator.

Public Constructors

 | Name | Description
Public Constructor | MapImageLocator Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetImageInfo | Retrieves image from specified source.
Top

See Also

Reference

MapImageLocator Class
GrapeCity.ActiveReports.Rendering.Tools.Image Namespace


MapImageLocator Constructor

[image]
ActiveReports 19 .NET Edition
MapImageLocator Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace > MapImageLocator Class : MapImageLocator Constructor

Glossary Item Box

Overload List

Overload | Description
MapImageLocator Constructor(IImageLocatorService) | Initializes new instance of MapImageLocator class.
MapImageLocator Constructor(ResourceLocator,IImageConverterService,Report) | Initializes new instance of MapImageLocator class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapImageLocator Class
MapImageLocator Members


MapImageLocator Constructor(IImageLocatorService)

[image]
ActiveReports 19 .NET Edition
MapImageLocator Constructor(IImageLocatorService)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace > MapImageLocator Class > MapImageLocator Constructor : MapImageLocator Constructor(IImageLocatorService)

service
GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService instance.

Glossary Item Box

Initializes new instance of MapImageLocator class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal service As IImageLocatorService _
)
C#
public MapImageLocator(
   IImageLocatorService service
)

Parameters

service
GrapeCity.ActiveReports.Extensibility.Rendering.IImageLocatorService instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapImageLocator Class
MapImageLocator Members
Overload List


MapImageLocator Constructor(ResourceLocator,IImageConverterService,Report)

[image]
ActiveReports 19 .NET Edition
MapImageLocator Constructor(ResourceLocator,IImageConverterService,Report)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace > MapImageLocator Class > MapImageLocator Constructor : MapImageLocator Constructor(ResourceLocator,IImageConverterService,Report)

resourceLocator
Resource locator instance.
imageConverterService
Image converter.
report
The Report element.

Glossary Item Box

Initializes new instance of MapImageLocator class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceLocator As ResourceLocator, _
   ByVal imageConverterService As IImageConverterService, _
   ByVal report As Report _
)
C#
public MapImageLocator(
   ResourceLocator resourceLocator,
   IImageConverterService imageConverterService,
   Report report
)

Parameters

resourceLocator
Resource locator instance.
imageConverterService
Image converter.
report
The Report element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapImageLocator Class
MapImageLocator Members
Overload List


MapImageLocator Class Methods

[image]
ActiveReports 19 .NET Edition
MapImageLocator Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace : MapImageLocator Class

Glossary Item Box

For a list of all members of this type, see MapImageLocator members.

Public Methods

 | Name | Description
Public Method | GetImageInfo | Retrieves image from specified source.
Top

See Also

Reference

MapImageLocator Class
GrapeCity.ActiveReports.Rendering.Tools.Image Namespace


GetImageInfo Method

[image]
ActiveReports 19 .NET Edition
GetImageInfo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.Rendering.Tools.Image Namespace > MapImageLocator Class : GetImageInfo Method

imageSource
The image source.
mimeType
The image mime type.
value
The value.

Glossary Item Box

Retrieves image from specified source.

Syntax

Visual Basic (Declaration)
Public Function GetImageInfo( _
   ByVal imageSource As ImageSource, _
   ByVal mimeType As String, _
   ByVal value As Object _
) As ImageInfo
C#
public ImageInfo GetImageInfo(
   ImageSource imageSource,
   string mimeType,
   object value
)

Parameters

imageSource
The image source.
mimeType
The image mime type.
value
The value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapImageLocator Class
MapImageLocator Members


MapTileProviderFactory Class

[image]
ActiveReports 19 .NET Edition
MapTileProviderFactory Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace : MapTileProviderFactory Class

Glossary Item Box

Represents a factory for creating map tile providers.

Object Model

MapTileProviderFactory Class

Syntax

Visual Basic (Declaration)
Public Class MapTileProviderFactory
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTileProviderFactory
C#
public class MapTileProviderFactory : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTileProviderFactory

Remarks

This class should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.MapTileProviderFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileProviderFactory Members
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace


MapTileProviderFactory Class Members

[image]
ActiveReports 19 .NET Edition
MapTileProviderFactory Class Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace : MapTileProviderFactory Class

Glossary Item Box

The following tables list the members exposed by MapTileProviderFactory.

Public Constructors

 | Name | Description
Public Constructor | MapTileProviderFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | CreateProvider | Create tile provider and configure it by settings from layer.
Top

See Also

Reference

MapTileProviderFactory Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace


MapTileProviderFactory Constructor

[image]
ActiveReports 19 .NET Edition
MapTileProviderFactory Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace > MapTileProviderFactory Class : MapTileProviderFactory Constructor

tileProvidersManager
factory

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tileProvidersManager As ITileProvidersManager, _
   Optional ByVal factory As IMapTileProviderFactory _
)
C#
public MapTileProviderFactory(
   ITileProvidersManager tileProvidersManager,
   IMapTileProviderFactory factory
)

Parameters

tileProvidersManager
factory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileProviderFactory Class
MapTileProviderFactory Members


MapTileProviderFactory Class Methods

[image]
ActiveReports 19 .NET Edition
MapTileProviderFactory Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace : MapTileProviderFactory Class

Glossary Item Box

For a list of all members of this type, see MapTileProviderFactory members.

Public Methods

 | Name | Description
Public Method | CreateProvider | Create tile provider and configure it by settings from layer.
Top

See Also

Reference

MapTileProviderFactory Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace


CreateProvider Method

[image]
ActiveReports 19 .NET Edition
CreateProvider Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map Namespace > MapTileProviderFactory Class : CreateProvider Method

layer
Layer for which to create a provider.

Glossary Item Box

Create tile provider and configure it by settings from layer.

Syntax

Visual Basic (Declaration)
Public Function CreateProvider( _
   ByVal layer As IMapTileLayer _
) As IMapTileProviderInternal
C#
public IMapTileProviderInternal CreateProvider(
   IMapTileLayer layer
)

Parameters

layer
Layer for which to create a provider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileProviderFactory Class
MapTileProviderFactory Members


IConnectionStringProvider Interface

[image]
ActiveReports 19 .NET Edition
IConnectionStringProvider Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.BI.Data.DataProviders Namespace : IConnectionStringProvider Interface

Glossary Item Box

Extension for IDataProvidersFactory if you are going to specify connection string name.

Syntax

Visual Basic (Declaration)
Public Interface IConnectionStringProvider
C#
public interface IConnectionStringProvider

Remarks

This interface should not be used directly in application code. It is designed for internal operations within the product libraries and may change or be removed in future versions without notice.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConnectionStringProvider Members
GrapeCity.BI.Data.DataProviders Namespace


IConnectionStringProvider Interface Members

[image]
ActiveReports 19 .NET Edition
IConnectionStringProvider Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.BI.Data.DataProviders Namespace : IConnectionStringProvider Interface

Glossary Item Box

The following tables list the members exposed by IConnectionStringProvider.

Public Methods

 | Name | Description
Method | GetExternalConnectionString | Maps connection string if possible.
Top

See Also

Reference

IConnectionStringProvider Interface
GrapeCity.BI.Data.DataProviders Namespace


IConnectionStringProvider Interface Methods

[image]
ActiveReports 19 .NET Edition
IConnectionStringProvider Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.BI.Data.DataProviders Namespace : IConnectionStringProvider Interface

Glossary Item Box

For a list of all members of this type, see IConnectionStringProvider members.

Public Methods

 | Name | Description
Method | GetExternalConnectionString | Maps connection string if possible.
Top

See Also

Reference

IConnectionStringProvider Interface
GrapeCity.BI.Data.DataProviders Namespace


GetExternalConnectionString Method

[image]
ActiveReports 19 .NET Edition
GetExternalConnectionString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Rendering Assembly > GrapeCity.BI.Data.DataProviders Namespace > IConnectionStringProvider Interface : GetExternalConnectionString Method

connectionString

Glossary Item Box

Maps connection string if possible.

Syntax

Visual Basic (Declaration)
Function GetExternalConnectionString( _
   ByVal connectionString As String _
) As String
C#
string GetExternalConnectionString(
   string connectionString
)

Parameters

connectionString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConnectionStringProvider Interface
IConnectionStringProvider Members


ChartDataSourceClickedEventArgs Class

[image]
ActiveReports 19 .NET Edition
ChartDataSourceClickedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

Provides data for the Designer.ChartDataSourceClicked event.

Object Model

ChartDataSourceClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartDataSourceClickedEventArgs
   Inherits System.EventArgs
C#
public sealed class ChartDataSourceClickedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
ChartDataSourceClickedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ChartDataSourceClickedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ChartDataSourceClickedEventArgs Constructor | Initializes a new instance of the ChartDataSourceClickedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top

See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
ChartDataSourceClickedEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : ChartDataSourceClickedEventArgs Constructor

control
Control whose data source icon is clicked.

Glossary Item Box

Initializes a new instance of the ChartDataSourceClickedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As ChartControl _
)
C#
public ChartDataSourceClickedEventArgs(
   ChartControl control
)

Parameters

control
Control whose data source icon is clicked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ChartDataSourceClickedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ChartDataSourceClickedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ChartDataSourceClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top

See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Cancel Property

Glossary Item Box

Indicates that the default action should be skipped.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


Chart Property

[image]
ActiveReports 19 .NET Edition
Chart Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Chart Property

Glossary Item Box

Provides access to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Chart As ChartControl
C#
public ChartControl Chart {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ContextMenuOpenArgs Class

[image]
ActiveReports 19 .NET Edition
ContextMenuOpenArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

The ContextMenuOpenArgs class provides data needed for the ContextMenuOpen event.

Object Model

ContextMenuOpenArgs Class

Syntax

Visual Basic (Declaration)
Public Class ContextMenuOpenArgs
   Inherits System.EventArgs
C#
public class ContextMenuOpenArgs : System.EventArgs

Remarks

This class encapsulates information about the context menu that is being requested, including the source component and the specific type of context menu. It also allows the opening of the context menu to be cancelled.

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ContextMenuOpenArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Members
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Members

[image]
ActiveReports 19 .NET Edition
ContextMenuOpenArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

The following tables list the members exposed by ContextMenuOpenArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top

See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ContextMenuOpenArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

For a list of all members of this type, see ContextMenuOpenArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top

See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Cancel Property

Glossary Item Box

Determines whether the default menu handler should be cancelled.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Property Value

Boolean value.

Remarks

This parameter should be set to True to disable or replace built-in context menus.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


MenuType Property

[image]
ActiveReports 19 .NET Edition
MenuType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : MenuType Property

Glossary Item Box

Specifies the type of menu that will be opened for this sourceObject.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuType As ContextMenuTypes
C#
public ContextMenuTypes MenuType {get;}

Property Value

The type of the context menu ContextMenuTypes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members
ActiveReports.Design6~GrapeCity.ActiveReports.Design.ContextMenuTypes


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Source Property

Glossary Item Box

A reference to the object that is opening the menu.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Object
C#
public object Source {get;}

Property Value

The source component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


DataSourceIconClickedEventArgs Class

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

This class retrieves the value from the DialogResult after the data source icon is clicked.

Object Model

DataSourceIconClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceIconClickedEventArgs
   Inherits System.EventArgs
C#
public class DataSourceIconClickedEventArgs : System.EventArgs

Remarks

This event is raised when the data source icon within the designer is clicked, potentially opening a dialog. The DialogResult property indicates the result of this dialog if one was shown.

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataSourceIconClickedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataSourceIconClickedEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top

See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickedEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DataSourceIconClickedEventArgs Constructor

dialogResult
The enumerated DialogResult value returned from the dialog.

Glossary Item Box

Initializes a new instance of the DatasourceClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dialogResult As DialogResult _
)
C#
public DataSourceIconClickedEventArgs(
   DialogResult dialogResult
)

Parameters

dialogResult
The enumerated DialogResult value returned from the dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataSourceIconClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top

See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DialogResult Property

[image]
ActiveReports 19 .NET Edition
DialogResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DialogResult Property

Glossary Item Box

Gets the value from the data source dialog.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DialogResult As DialogResult
C#
public DialogResult DialogResult {get;}

Property Value

An enumerated System.Windows.Forms.DialogResult value:

  • None
  • OK
  • Cancel
  • Abort
  • Retry
  • Ignore
  • Yes
  • No

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickEventArgs Class

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickEventArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

DatasourceClickEventArgs holds the cancel value to stop the default Datasource dialog from showing.

Object Model

DataSourceIconClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceIconClickEventArgs
   Inherits System.EventArgs
C#
public class DataSourceIconClickEventArgs : System.EventArgs

Remarks

This event is triggered when the data source icon is clicked in the End User Designer. Setting the Cancel property to true prevents the default DataSourceDialog from opening, allowing for a custom dialog or action to be initiated instead.

Example

C# Copy Code
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
Visual Basic Copy Code
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataSourceIconClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataSourceIconClickEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top

See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : DataSourceIconClickEventArgs Constructor

Glossary Item Box

Initializes a new instance of the DatasourceClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSourceIconClickEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


DataSourceIconClickEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
DataSourceIconClickEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataSourceIconClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top

See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : Cancel Property

Glossary Item Box

Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Property Value

true if the dialog should not open; otherwise, false.

Remarks

For End-User Designer only. The DataSourceClick event must be attached to the Designer in order for this to take effect. If the value is set to True, the default Datasource dialog will not open when the Datasource Icon is clicked in End-User Designer. In a typical scenario a custom dialog can be showed instead.

Example

C# Copy Code
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
Visual Basic Copy Code
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


Designer Class

[image]
ActiveReports 19 .NET Edition
Designer Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

The Designer class is the base class for the End-User Report Designer control.

Object Model

Designer Class

Syntax

Visual Basic (Declaration)
Public Class Designer
   Inherits System.Windows.Forms.UserControl
C#
public class Designer : System.Windows.Forms.UserControl

Remarks

The designer control is used to customize report layouts at run time.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
this.designer1.DrawGrid = true;
this.designer1.GridX = 16;
this.designer1.GridY = 16;
this.designer1.LockControls = false;
this.designer1.ShowDataSourceIcon = true;
this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Designer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Members
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Class Members

[image]
ActiveReports 19 .NET Edition
Designer Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

The following tables list the members exposed by Designer.

Public Constructors

 | Name | Description
Public Constructor | Designer Constructor | Creates a new Instance of Designer class.
Top

Public Properties

 | Name | Description
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | FontResolver | Gets or sets a value representing the font resolver used by the designer to resolve fonts in reports.
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | LaunchDataSourceWizard | Gets or sets a value indicating whether the Data Source Dialog should be launched automatically. This property is obsolete and should not be used in new development.
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | PageReportDesignerActions | Gets or sets a value representing the allowed actions in PageReport Designer.
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets a value representing the directory path where report parts are stored for use in the report items library.
Public Property | ReportTabsPanelVisible | Gets or sets a value indicating whether the panel containing the tabs for switching between Design, Script, and Preview modes is visible.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Gets a value indicating the type of the currently loaded report.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | ScrollingMode | Gets or sets a value representing the scrolling mode for the designer view.
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top

Public Methods

 | Name | Description
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | LoadReport | Overloaded. Loads an existing report XML layout into the designer.
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RunDataWizard | Opens the Data Source Dialog automatically when creating a new report.
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | ScaleSizeToDpi | Scales a System.Drawing.Size from the default DPI (dots per inch) settings to the DPI settings of the current device.
Public Method | SectionAt | Returns the section at the specified point.
Top

Public Events

 | Name | Description
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | ReportChanged | Occurs when any modification is made to the report, such as changes to the design, data sources, or properties.
Public Event | ReportNameChanged | Occurs when the name of the report changes. This event can be used to respond to changes in the report's name, such as updating UI elements or performing additional logic.
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Constructor()

[image]
ActiveReports 19 .NET Edition
Designer Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Designer Constructor : Designer Constructor()

Glossary Item Box

Creates a new Instance of Designer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Designer()

Remarks

This constructor initializes the designer with default settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Designer Class Methods

[image]
ActiveReports 19 .NET Edition
Designer Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Methods

 | Name | Description
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | LoadReport | Overloaded. Loads an existing report XML layout into the designer.
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RunDataWizard | Opens the Data Source Dialog automatically when creating a new report.
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | ScaleSizeToDpi | Scales a System.Drawing.Size from the default DPI (dots per inch) settings to the DPI settings of the current device.
Public Method | SectionAt | Returns the section at the specified point.
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


CreateToolStrips Method

[image]
ActiveReports 19 .NET Edition
CreateToolStrips Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateToolStrips Method

strips
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.

Glossary Item Box

Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.

Syntax

Visual Basic (Declaration)
Public Function CreateToolStrips( _
   ByVal ParamArray strips() As DesignerToolStrips _
) As ToolStrip()
C#
public ToolStrip[] CreateToolStrips(
   params DesignerToolStrips[] strips
)

Parameters

strips
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.

Return Value

An array of System.Windows.Forms.ToolStrip objects that have been created based on the specified strips.

Remarks

This method facilitates the dynamic creation of toolstrips for the designer interface, allowing for customization of the toolset presented to the user. The method can generate a specific set of toolstrips or all available toolstrips if no specific set is requested.

Example

Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
C# Copy Code
private void designer1_Load(object sender, EventArgs e)
       {
           ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
           ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
           ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
           ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
           ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
           ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
           ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
           this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
           this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
           this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
           this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
           this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
           this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
           this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
       }

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ExecuteAction Method

[image]
ActiveReports 19 .NET Edition
ExecuteAction Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ExecuteAction Method

Glossary Item Box

Executes a specified DesignerAction command.

Overload List

Overload | Description
ExecuteAction(DesignerAction) | Executes the specified DesignerAction command within the designer environment.
ExecuteAction(DesignerAction,Object) | Executes the specified DesignerAction command with an optional parameter. This method can be utilized when implementing custom toolbars or menus within the designer environment. It enables the execution of report actions in response to user interactions with toolbar or menu items.

Remarks

This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.

Example

C# Copy Code
private void mnuLoadLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileOpen);
}

private void mnuSaveLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileSave);
}

private void mnuPageSetup_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.ReportSettings);
}
Visual Basic Copy Code
Private Sub mnuLoadLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoadLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileOpen)
End Sub

Private Sub mnuSaveLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSaveLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileSave)
End Sub

Private Sub mnuPageSetup_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPageSetup.Click
    Me.Designer1.ExecuteAction(DesignerAction.ReportSettings)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ExecuteAction(DesignerAction) Method

[image]
ActiveReports 19 .NET Edition
ExecuteAction(DesignerAction) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction) Method

action
The DesignerAction to be executed. This action corresponds to various design-time operations such as adding new controls, deleting controls, or changing properties.

Glossary Item Box

Executes the specified DesignerAction command within the designer environment.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction _
)
C#
public void ExecuteAction(
   DesignerAction action
)

Parameters

action
The DesignerAction to be executed. This action corresponds to various design-time operations such as adding new controls, deleting controls, or changing properties.

Remarks

This method facilitates the execution of design-time actions, typically triggered by user interaction with custom toolbars or menus in the designer interface. It allows for the extension of the designer's functionality by enabling the execution of predefined actions programmatically.

Example

C# Copy Code
// The following example demonstrates how to remove selected items from the designer surface by executing the EditDelete action:
private void RemoveSelectedItems()
{
    designer.ExecuteAction(DesignerAction.EditDelete);
}
// You can also clear the designer surface by selecting all items and deleting them
private void Clear()
{
    designer.ExecuteAction(DesignerAction.SelectAll);
    designer.ExecuteAction(DesignerAction.EditDelete);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ExecuteAction(DesignerAction,Object) Method

[image]
ActiveReports 19 .NET Edition
ExecuteAction(DesignerAction,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction,Object) Method

action
The DesignerAction to execute. This parameter specifies the action to be performed by the designer.
parameter
A parameter that can be passed to the action. This can be used to provide additional context or data required for the action's execution.

Glossary Item Box

Executes the specified DesignerAction command with an optional parameter. This method can be utilized when implementing custom toolbars or menus within the designer environment. It enables the execution of report actions in response to user interactions with toolbar or menu items.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction, _
   ByVal parameter As Object _
)
C#
public void ExecuteAction(
   DesignerAction action,
   object parameter
)

Parameters

action
The DesignerAction to execute. This parameter specifies the action to be performed by the designer.
parameter
A parameter that can be passed to the action. This can be used to provide additional context or data required for the action's execution.

Remarks

The method supports a wide range of design-time actions, including but not limited to adding or removing controls, modifying properties, and triggering custom logic defined in extensions or plugins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport Method

[image]
ActiveReports 19 .NET Edition
LoadReport Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LoadReport Method

Glossary Item Box

Loads an existing report XML layout into the designer.

Overload List

Overload | Description
LoadReport(FileInfo) | Loads existing report XML layout into the designer.
LoadReport(Stream) | Loads an existing report XML layout from the specified Stream into the designer.
LoadReport(XmlReader,DesignerReportType) | Loads an existing report of the specified type from the provided System.Xml.XmlReader into the designer.
LoadReport(XmlReader,DesignerReportType,String) | Loads an existing report of the specified type and name from the provided System.Xml.XmlReader into the designer.

Example

C# Copy Code
// SetReportViaStream - sets a report design stream to the Designer
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LoadReport(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
LoadReport(FileInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(FileInfo) Method

fileInfo
FileInfo wrapper for the section or page report to load. The report file should be in XML format and compatible with the ActiveReports designer.

Glossary Item Box

Loads existing report XML layout into the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadReport( _
   ByVal fileInfo As FileInfo _
)
C#
public void LoadReport(
   FileInfo fileInfo
)

Parameters

fileInfo
FileInfo wrapper for the section or page report to load. The report file should be in XML format and compatible with the ActiveReports designer.

Exceptions

Exception | Description
System.ArgumentNullException | Thrown when fileInfo is null.
System.IO.FileNotFoundException | Thrown when the file specified in fileInfo does not exist.

Remarks

This method opens a report from a file, allowing the user to edit the report's design within the ActiveReports designer environment. It supports both section and page report types. Ensure that the file specified by fileInfo exists and is accessible.

Example

C# Copy Code
/// <summary>
/// OpenReportFile - Open the 'Open File' dialog, select the rpx file of the report and open it
/// </summary>
private void OpenReportFile()
{
    try
    {
        this.dlgOpenFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx";
        this.dlgOpenFile.FilterIndex = 2;
        this.dlgOpenFile.RestoreDirectory = true ;
        this.dlgOpenFile.DefaultExt = ".rpx";

        if(dlgOpenFile.ShowDialog() == DialogResult.OK)
        {
            this._alreadySaved = true;

            //Add the opened report to the latest cache
            if(System.IO.File.Exists(Application.StartupPath + @"\Settings\recent.xml"))
            {

                DataSet _reportsDS = new DataSet();
                _reportsDS.Locale = CultureInfo.InvariantCulture;
                _reportsDS.ReadXml(Application.StartupPath + @"\Settings\recent.xml");
                DataTable _reportsTable = _reportsDS.Tables["Reports"];
                _reportsTable.Locale = CultureInfo.InvariantCulture;

                //Create a row
                DataRow _rowReports = _reportsTable.NewRow();
                object [] _myArray = new object[2];
                this._savedPath = this.dlgOpenFile.FileName;
                _myArray[0] = this.dlgOpenFile.FileName;
                _myArray[1] = System.DateTime.Now;
                _rowReports.ItemArray = _myArray;
                _reportsTable.Rows.Add(_rowReports);
                _reportsDS.WriteXml(Application.StartupPath + @"\Settings\recent.xml", XmlWriteMode.WriteSchema);
            }

            //Load the report
            this.ardMain.LoadReport(new System.IO.FileInfo(this._savedPath));
        }

        //Fill the designer's combo box
        this.FillCombo();

    }
    catch(System.IO.IOException ex)
    {
        MessageBox.Show(ex.ToString());
    }
}
Visual Basic Copy Code
'OpenReportFile - Open the 'Open File' dialog, select the rpx file of the report and open it
Private Sub OpenReportFile()
    Try
        Me.dlgOpenFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx"
        Me.dlgOpenFile.FilterIndex = 2
        Me.dlgOpenFile.RestoreDirectory = True
        Me.dlgOpenFile.DefaultExt = ".rpx"

        If dlgOpenFile.ShowDialog() = DialogResult.OK Then
            Me._alreadySaved = True

            'Add the opened report to the latest cache
            If System.IO.File.Exists((Application.StartupPath + "\Settings\recent.xml")) Then

                Dim _reportsDS As New DataSet()
                _reportsDS.Locale = CultureInfo.InvariantCulture
                _reportsDS.ReadXml((Application.StartupPath + "\Settings\recent.xml"))
                Dim _reportsTable As DataTable = _reportsDS.Tables("Reports")
                _reportsTable.Locale = CultureInfo.InvariantCulture

                'Create a row
                Dim _rowReports As DataRow = _reportsTable.NewRow()
                Dim _myArray(1) As Object
                Me._savedPath = Me.dlgOpenFile.FileName
                _myArray(0) = Me.dlgOpenFile.FileName
                _myArray(1) = System.DateTime.Now
                _rowReports.ItemArray = _myArray
                _reportsTable.Rows.Add(_rowReports)
                _reportsDS.WriteXml(Application.StartupPath + "\Settings\recent.xml", XmlWriteMode.WriteSchema)
            End If

            'Load the report
            Me.ardMain.LoadReport(New System.IO.FileInfo(Me._savedPath))
        End If

        'Fill the designer's combo box
        Me.FillCombo()

    Catch ex As System.IO.IOException
        MessageBox.Show(ex.ToString())
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport(Stream) Method

[image]
ActiveReports 19 .NET Edition
LoadReport(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(Stream) Method

stream
Specifies the Stream object that contains the report layout.The stream to be loaded.

Glossary Item Box

Loads an existing report XML layout from the specified Stream into the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadReport( _
   ByVal stream As Stream _
)
C#
public void LoadReport(
   Stream stream
)

Parameters

stream
Specifies the Stream object that contains the report layout.The stream to be loaded.

Example

C# Copy Code
/// <summary>
/// SetReportViaStream - sets a report design stream to the Designer
/// </summary>
/// <param name="memStream">Report Memory Stream to set to the designer</param>
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
'Parameter Name: memStream - Report Memory Stream to set to the designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport(XmlReader,DesignerReportType) Method

[image]
ActiveReports 19 .NET Edition
LoadReport(XmlReader,DesignerReportType) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(XmlReader,DesignerReportType) Method

reader
Reader containing section or page report.
type
Section or Page report.

Glossary Item Box

Loads an existing report of the specified type from the provided System.Xml.XmlReader into the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadReport( _
   ByVal reader As XmlReader, _
   ByVal type As DesignerReportType _
)
C#
public void LoadReport(
   XmlReader reader,
   DesignerReportType type
)

Parameters

reader
Reader containing section or page report.
type
Section or Page report.

Remarks

This method allows for more flexible report loading by accepting an System.Xml.XmlReader, which can be used to load reports from various sources, including streams, strings, or files.

Example

The following example demonstrates how to load a report from a string containing XML data:
C# Copy Code
var report = new PageReport {
    Report = {
        DataSources = {
            new DataSource {
                Name = "MainDataSource",
                ConnectionProperties = {
                    ConnectString = "your_connection_string",
                    DataProvider = "MSSQL",
                }
            }
        }
    }
};
//Serialize and load report into the designer
designer.LoadReport(XmlReader.Create(new StringReader(report.ToRdlString())), DesignerReportType.Rdl);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport(XmlReader,DesignerReportType,String) Method

[image]
ActiveReports 19 .NET Edition
LoadReport(XmlReader,DesignerReportType,String) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(XmlReader,DesignerReportType,String) Method

reader
An System.Xml.XmlReader instance that reads the report XML data. This can be either a section report or a page report.
type
The type of the report being loaded, specified by the DesignerReportType enumeration. This determines how the report is processed and displayed in the designer.
reportName
The name of the report. This parameter can be used to specify a name for the report being loaded. If null or empty, the name may be derived from the XML content or remain unspecified.

Glossary Item Box

Loads an existing report of the specified type and name from the provided System.Xml.XmlReader into the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadReport( _
   ByVal reader As XmlReader, _
   ByVal type As DesignerReportType, _
   ByVal reportName As String _
)
C#
public void LoadReport(
   XmlReader reader,
   DesignerReportType type,
   string reportName
)

Parameters

reader
An System.Xml.XmlReader instance that reads the report XML data. This can be either a section report or a page report.
type
The type of the report being loaded, specified by the DesignerReportType enumeration. This determines how the report is processed and displayed in the designer.
reportName
The name of the report. This parameter can be used to specify a name for the report being loaded. If null or empty, the name may be derived from the XML content or remain unspecified.

Remarks

This overload of the LoadReport method provides an additional parameter for specifying the name of the report. This can be useful for identifying the report within the designer environment, especially when working with multiple reports or when the report's name is not defined within the XML structure.

Example

The following example demonstrates how to load a report from a string containing XML data, specifying a name for the report:
C# Copy Code
// Assume that 'pageReport' is a PageReport object containing the report layout
using (var designer = new Designer())
{
    var xml = new StringBuilder();
    using (XmlWriter xmlWriter = XmlWriter.Create(xml))
        pageReport.Save(xmlWriter);
    using (XmlReader xmlReader = XmlReader.Create(new StringReader(xml.ToString())))
        designer.LoadReport(xmlReader, DesignerReportType.Page, "MyCustomReportName");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


NewReport Method

[image]
ActiveReports 19 .NET Edition
NewReport Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : NewReport Method

Glossary Item Box

Initializes the designer with a new report layout.

Overload List

Overload | Description
NewReport() | Initializes the designer with a new report layout.
NewReport(DesignerReportType) | Initializes the designer with a new report layout with specified type.
NewReport(DesignerReportType,Boolean) | Initializes the designer with a new report layout of the specified type and, if requested, launches the Data Source Dialog. This method facilitates the creation of a new report by allowing the specification of the report type (e.g., Section, Page) and provides an option to immediately launch the Data Source Dialog, which assists in setting up data connections and queries for the report.

Example

C# Copy Code
/// <summary>
/// NewReport - an Interface function from IPlugInHost
/// </summary>
/// <param name="name">Name to use for the Document</param>
/// <returns>Current report object in the designer</returns>
public object NewReport(string name)
{
    try
    {
        this.ardMain.NewReport();
        this.ardMain.Report.Document.Name = name;
        return this.ardMain.Report;
    }
    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
Visual Basic Copy Code
'NewReport - an Interface function from IPlugInHost
'Parameter Name: name - Name to use for the Document
'Returns: Current report object in the designer
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function 'NewReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


NewReport() Method

[image]
ActiveReports 19 .NET Edition
NewReport() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport() Method

Glossary Item Box

Initializes the designer with a new report layout.

Syntax

Visual Basic (Declaration)
Public Overloads Sub NewReport()
C#
public void NewReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


NewReport(DesignerReportType) Method

[image]
ActiveReports 19 .NET Edition
NewReport(DesignerReportType) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport(DesignerReportType) Method

type
Section or Page report.

Glossary Item Box

Initializes the designer with a new report layout with specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Sub NewReport( _
   ByVal type As DesignerReportType _
)
C#
public void NewReport(
   DesignerReportType type
)

Parameters

type
Section or Page report.

Remarks

This method is part of the public API of the designer and can be used to programmatically initiate the creation of a new report within the designer environment. It is particularly useful in scenarios where the type of report to be created is determined at runtime based on user input or other dynamic conditions.

Example

Creates new empty report of specific type and initializes the designer with it.
C# Copy Code
//Assume that '_designer' is a Designer object
_designer.NewReport(DesignerReportType.Rdl);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


NewReport(DesignerReportType,Boolean) Method

[image]
ActiveReports 19 .NET Edition
NewReport(DesignerReportType,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport(DesignerReportType,Boolean) Method

type
The type of the new report to be created, as defined by the DesignerReportType enumeration.
launchDataSourceWizard
If set to true, the Data Source Dialog is launched after the report is initialized; otherwise, it is not launched.

Glossary Item Box

Initializes the designer with a new report layout of the specified type and, if requested, launches the Data Source Dialog. This method facilitates the creation of a new report by allowing the specification of the report type (e.g., Section, Page) and provides an option to immediately launch the Data Source Dialog, which assists in setting up data connections and queries for the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub NewReport( _
   ByVal type As DesignerReportType, _
   ByVal launchDataSourceWizard As Boolean _
)
C#
public void NewReport(
   DesignerReportType type,
   bool launchDataSourceWizard
)

Parameters

type
The type of the new report to be created, as defined by the DesignerReportType enumeration.
launchDataSourceWizard
If set to true, the Data Source Dialog is launched after the report is initialized; otherwise, it is not launched.

Remarks

The Data Source Dialog is a tool that simplifies the process of connecting a report to data by guiding the user through the steps required to define a data source and create queries. This method is particularly useful when creating a new report that requires immediate data binding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


PointToSection Method

[image]
ActiveReports 19 .NET Edition
PointToSection Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToSection Method

section
The section that contains the specified point.
point
The point in designer coordinates that needs to be translated.

Glossary Item Box

Returns the screen coordinates of a specified point in a given section.

Syntax

Visual Basic (Declaration)
Public Function PointToSection( _
   ByVal section As Object, _
   ByVal point As Point _
) As Point
C#
public Point PointToSection(
   object section,
   Point point
)

Parameters

section
The section that contains the specified point.
point
The point in designer coordinates that needs to be translated.

Return Value

A System.Drawing.Point representing the translated coordinates within the context of the specified section.

Exceptions

Exception | Description
System.NullReferenceException | Thrown if the section parameter is null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


QueryActionChecked Method

[image]
ActiveReports 19 .NET Edition
QueryActionChecked Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionChecked Method

action
DesignerAction Types

Glossary Item Box

Queries the object for the checked status of one or more commands.

Syntax

Visual Basic (Declaration)
Public Function QueryActionChecked( _
   ByVal action As DesignerAction _
) As Boolean
C#
public bool QueryActionChecked(
   DesignerAction action
)

Parameters

action
DesignerAction Types

Return Value

true if the specified action is checked; otherwise, false. The return value indicates the current state of the action within the designer environment.

Remarks

This method is used to query the state of actions that can be toggled on or off within the designer. For example, it can be used to check whether grid alignment is enabled or whether a specific tool is currently active.

Example

C# Copy Code
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
Visual Basic Copy Code
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.DesignerAction


QueryActionEnabled Method

[image]
ActiveReports 19 .NET Edition
QueryActionEnabled Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionEnabled Method

action
DesignerAction Types

Glossary Item Box

Queries the object for the enabled status of one or more commands.

Syntax

Visual Basic (Declaration)
Public Function QueryActionEnabled( _
   ByVal action As DesignerAction _
) As Boolean
C#
public bool QueryActionEnabled(
   DesignerAction action
)

Parameters

action
DesignerAction Types

Return Value

True, if the enabled status is true, else False.

Remarks

This method is utilized to determine the availability of actions within the designer, such as commands related to editing, formatting, or other design-time operations. An action being enabled implies that it is available for use under the current state of the designer.

Example

This example shows how to determine if the "Convert to Master" action is enabled for the current report loaded in the designer.
C# Copy Code
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
Visual Basic Copy Code
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.DesignerAction


RunDataWizard Method

[image]
ActiveReports 19 .NET Edition
RunDataWizard Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RunDataWizard Method

Glossary Item Box

Opens the Data Source Dialog automatically when creating a new report.

Syntax

Visual Basic (Declaration)
Public Sub RunDataWizard()
C#
public void RunDataWizard()

Remarks

This method triggers the Data Source Dialog to open, facilitating the process of connecting data sources to the new report.

Example

The following example demonstrates how to invoke the Data Wizard programmatically:
C# Copy Code
private void RunDataWizardButtonClick(object sender, EventArgs e)
{
    _designer.RunDataWizard();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SaveReport Method

[image]
ActiveReports 19 .NET Edition
SaveReport Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SaveReport Method

Glossary Item Box

Saves a report XML layout to the filename or stream specified.

Overload List

Overload | Description
SaveReport(FileInfo) | Saves a report layout as an XML file to the specified file name.
SaveReport(Stream) | Saves a report layout as an XML file to the specified Stream.
SaveReport(XmlWriter) | Saves a report XML layout to the specified writer.

Example

C# Copy Code
// SetReportViaStream - sets a report design stream to the Designer
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SaveReport(FileInfo) Method

[image]
ActiveReports 19 .NET Edition
SaveReport(FileInfo) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(FileInfo) Method

file
Specifies the File object to contain the report layout.

Glossary Item Box

Saves a report layout as an XML file to the specified file name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal file As FileInfo _
)
C#
public void SaveReport(
   FileInfo file
)

Parameters

file
Specifies the File object to contain the report layout.

Remarks

This method first ensures that any pending changes to the report are committed by flushing the designer loader. It then delegates the save operation to the implementation layer, which handles the specifics of saving the report to the file system. The file path is obtained from the FileInfo object.

Example

The following example demonstrates how to save a report to a file:
C# Copy Code
/// <summary>
/// SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
/// </summary>
private void SaveReportFile()
{
    //If the Report was saved once, we already have a valid path, call Save on it.
    if(this._alreadySaved)
    {
        this.ardMain.SaveReport(this._savedPath);
    }
    else
    {
        //Open Save dialog to retrieve a file and path to save to
        this.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx";
        this.dlgSaveFile.FileName = "Report.rpx";
        this.dlgSaveFile.FilterIndex = 2;
        this.dlgSaveFile.RestoreDirectory = true ;
        this.dlgSaveFile.DefaultExt = ".rpx";

        if(dlgSaveFile.ShowDialog() == DialogResult.OK)
        {
            //Add new saved report to the recent documents cache
            if(System.IO.File.Exists(Application.StartupPath + @"\Settings\recent.xml"))
            {
                DataSet _reportsDS = new DataSet();
                _reportsDS.Locale = CultureInfo.InvariantCulture;
                _reportsDS.ReadXml(Application.StartupPath + @"\Settings\recent.xml");
                DataTable _reportsTable = _reportsDS.Tables["Reports"];
                _reportsTable.Locale = CultureInfo.InvariantCulture;

                //Create a Row
                DataRow _rowReports = _reportsTable.NewRow();
                object [] _myArray = new object[2];
                this._savedPath = this.dlgSaveFile.FileName;
                _myArray[0] = this.dlgSaveFile.FileName;
                _myArray[1] = System.DateTime.Now;
                _rowReports.ItemArray = _myArray;
                _reportsTable.Rows.Add(_rowReports);
                _reportsDS.WriteXml(Application.StartupPath + @"\Settings\recent.xml", XmlWriteMode.WriteSchema);
            }
            this.ardMain.SaveReport(this._savedPath);
        }
    }
}
Visual Basic Copy Code
'SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
Private Sub SaveReportFile()
    'If the Report was saved once, we already have a valid path, call Save on it.
    If Me._alreadySaved Then
        Me.ardMain.SaveReport(Me._savedPath)
    Else
        'Open Save dialog to retrieve a file and path to save to
        Me.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx"
        Me.dlgSaveFile.FileName = "Report.rpx"
        Me.dlgSaveFile.FilterIndex = 2
        Me.dlgSaveFile.RestoreDirectory = True
        Me.dlgSaveFile.DefaultExt = ".rpx"

        If dlgSaveFile.ShowDialog() = DialogResult.OK Then
            'Add new saved report to the recent documents cache
            If System.IO.File.Exists((Application.StartupPath + "\Settings\recent.xml")) Then
                Dim _reportsDS As New DataSet()
                _reportsDS.Locale = CultureInfo.InvariantCulture
                _reportsDS.ReadXml((Application.StartupPath + "\Settings\recent.xml"))
                Dim _reportsTable As DataTable = _reportsDS.Tables("Reports")
                _reportsTable.Locale = CultureInfo.InvariantCulture

                'Create a Row
                Dim _rowReports As DataRow = _reportsTable.NewRow()
                Dim _myArray(1) As Object
                Me._savedPath = Me.dlgSaveFile.FileName
                _myArray(0) = Me.dlgSaveFile.FileName
                _myArray(1) = System.DateTime.Now
                _rowReports.ItemArray = _myArray
                _reportsTable.Rows.Add(_rowReports)
                _reportsDS.WriteXml(Application.StartupPath + "\Settings\recent.xml", XmlWriteMode.WriteSchema)
            End If
            Me.ardMain.SaveReport(Me._savedPath)
        End If
    End If
End Sub 'SaveReportFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(Stream) Method

[image]
ActiveReports 19 .NET Edition
SaveReport(Stream) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(Stream) Method

stream
Specifies the Stream object to contain the report layout.

Glossary Item Box

Saves a report layout as an XML file to the specified Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal stream As Stream _
)
C#
public void SaveReport(
   Stream stream
)

Parameters

stream
Specifies the Stream object to contain the report layout.

Remarks

This method has been deprecated. Please use SaveReport(XmlWriter) method instead.

Example

C# Copy Code
/// <summary>
/// SetReportViaStream - sets a report design stream to the Designer
/// </summary>
/// <param name="memStream">Report Memory Stream to set to the designer</param>
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
'Parameter Name: memStream - Report Memory Stream to set to the designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(XmlWriter) Method

[image]
ActiveReports 19 .NET Edition
SaveReport(XmlWriter) Method
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(XmlWriter) Method

writer
The writer used to save the report.

Glossary Item Box

Saves a report XML layout to the specified writer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal writer As XmlWriter _
)
C#
public void SaveReport(
   XmlWriter writer
)

Parameters

writer
The writer used to save the report.

Remarks

This method allows saving the report's XML layout directly to an XmlWriter, providing flexibility in how and where the report is saved. It checks for a null XmlWriter to avoid exceptions and delegates the save operation to the implementation layer, which handles the serialization of the report layout.

Example

The following example demonstrates how to use an XmlWriter to save a report:
C# Copy Code
using (var stream = new FileStream("path/to/your/report.rdlx", FileMode.Create))
using (var writer = XmlWriter.Create(stream))
{
    designer.SaveReport(writer);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ScaleSizeToDpi Method

[image]
ActiveReports 19 .NET Edition
ScaleSizeToDpi Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScaleSizeToDpi Method

size
The original System.Drawing.Size to scale.

Glossary Item Box

Scales a System.Drawing.Size from the default DPI (dots per inch) settings to the DPI settings of the current device.

Syntax

Visual Basic (Declaration)
Public Function ScaleSizeToDpi( _
   ByVal size As Size _
) As Size
C#
public Size ScaleSizeToDpi(
   Size size
)

Parameters

size
The original System.Drawing.Size to scale.

Return Value

A new System.Drawing.Size that has been scaled to match the current device's DPI settings.

Remarks

This method is useful for ensuring that sizes are correctly scaled in environments with varying DPI settings. It adjusts the provided System.Drawing.Size based on the system's current DPI settings compared to the default DPI, ensuring consistent sizing across different display settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SectionAt Method

[image]
ActiveReports 19 .NET Edition
SectionAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SectionAt Method

point
Screen point.

Glossary Item Box

Returns the section at the specified point.

Syntax

Visual Basic (Declaration)
Public Function SectionAt( _
   ByVal point As Point _
) As Object
C#
public object SectionAt(
   Point point
)

Parameters

point
Screen point.

Return Value

An object representing the section found at the specified location. The exact type of the object returned depends on the type of report being designed.

Remarks

This method determines the section that corresponds to a given point on the designer surface. The behavior of this method depends on the type of report currently being designed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Properties

[image]
ActiveReports 19 .NET Edition
Designer Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Properties

 | Name | Description
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | FontResolver | Gets or sets a value representing the font resolver used by the designer to resolve fonts in reports.
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | LaunchDataSourceWizard | Gets or sets a value indicating whether the Data Source Dialog should be launched automatically. This property is obsolete and should not be used in new development.
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | PageReportDesignerActions | Gets or sets a value representing the allowed actions in PageReport Designer.
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets a value representing the directory path where report parts are stored for use in the report items library.
Public Property | ReportTabsPanelVisible | Gets or sets a value indicating whether the panel containing the tabs for switching between Design, Script, and Preview modes is visible.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Gets a value indicating the type of the currently loaded report.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | ScrollingMode | Gets or sets a value representing the scrolling mode for the designer view.
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


DesignerUnits Property

[image]
ActiveReports 19 .NET Edition
DesignerUnits Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerUnits Property

Glossary Item Box

Gets or sets the measurement units for the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerUnits As MeasurementUnits
C#
public MeasurementUnits DesignerUnits {get; set;}

Property Value

Integer.

Remarks

This property influences how dimensions are displayed and interpreted throughout the design process. Changing the measurement units can be useful for adapting the designer to different regional settings or user preferences. It's important to ensure that the value set is valid within the MeasurementUnits enumeration.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
    this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.MeasurementUnits


DrawGrid Property

[image]
ActiveReports 19 .NET Edition
DrawGrid Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DrawGrid Property

Glossary Item Box

Gets or sets a value indicating whether a grid is drawn in the designer.

Syntax

Visual Basic (Declaration)
Public Property DrawGrid As Boolean
C#
public bool DrawGrid {get; set;}

Property Value

Boolean value.

Remarks

When set to true, a grid overlay appears in the designer, aiding in the alignment and precise placement of report elements.

Example

You can configure this property during the designer's initialization or set it later as needed.
C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnableOleObject Property

[image]
ActiveReports 19 .NET Edition
EnableOleObject Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableOleObject Property

Glossary Item Box

Enable or disable the OleObject control in the Visual Studio Toolbox.

Syntax

Visual Basic (Declaration)
Public Property EnableOleObject As Boolean
C#
public bool EnableOleObject {get; set;}

Property Value

true if OLE object support is enabled; otherwise, false. The default is false.

Remarks

Enabling OLE object support allows the designer to incorporate OLE objects, such as charts or spreadsheets, into the report designs. This can enhance the interactivity and data representation capabilities of the reports. However, it may also increase the complexity and resource requirements of the report design process. Use this feature according to the specific needs of your reporting application.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnablePreview Property

[image]
ActiveReports 19 .NET Edition
EnablePreview Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnablePreview Property

Glossary Item Box

Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.

Syntax

Visual Basic (Declaration)
Public Property EnablePreview As Boolean
C#
public bool EnablePreview {get; set;}

Property Value

true if the 'Preview' tab is enabled and visible; otherwise, false. The default is true.

Remarks

This property controls the visibility of the 'Preview' tab, which allows users to view a rendered preview of the current report. When set to false, the 'Preview' tab is hidden, and users cannot access the preview functionality directly from the design surface.

Example

C# Copy Code
// Enable the preview tab in the designer
designer.EnablePreview = true;
// Disable the preview tab in the designer
designer.EnablePreview = false;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnableScripting Property

[image]
ActiveReports 19 .NET Edition
EnableScripting Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableScripting Property

Glossary Item Box

Sets or returns a value indicating whether scripting is enabled for the designer.

Syntax

Visual Basic (Declaration)
Public Property EnableScripting As Boolean
C#
public bool EnableScripting {get; set;}

Property Value

true if the 'Script' tab is enabled and visible; otherwise, false. The default is true.

Remarks

This property controls the visibility of the 'Script' tab, allowing users to interact with the scripting features of the report designer. When set to false, the 'Script' tab is hidden, restricting access to script editing functionalities.

Example

C# Copy Code
// Enable the scripting tab in the designer
designer.EnableScripting = true;
// Disable the scripting tab in the designer
designer.EnableScripting = false;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
ReportTabsVisible Property


FontResolver Property

[image]
ActiveReports 19 .NET Edition
FontResolver Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : FontResolver Property

Glossary Item Box

Gets or sets a value representing the font resolver used by the designer to resolve fonts in reports.

Syntax

Visual Basic (Declaration)
Public Property FontResolver As IFontResolver
C#
public IFontResolver FontResolver {get; set;}

Property Value

An GrapeCity.ActiveReports.IFontResolver that handles font resolution. The default is null, which indicates that the default font resolver is used.

Remarks

The font resolver is responsible for determining the specific font instance to use when rendering text in reports. This can be particularly useful in scenarios where custom fonts are used or when there is a need to map generic font names to specific font files. Implementing a custom GrapeCity.ActiveReports.IFontResolver allows for precise control over font selection and rendering in the designer environment.

Note: Setting this property to a custom font resolver overrides the default font resolution mechanism. Ensure that the custom resolver properly handles all font requests to avoid rendering issues.

Example

This property allows you to specify custom fonts for use in both the preview and design of reports. To utilize this feature, you must first define a custom font resolver: After defining a custom font resolver, you can then associate it with the designer instance.
C# Copy Code
//Custom font resolver
public sealed class DirectoryFontResolver : GrapeCity.ActiveReports.IFontResolver
{
    Documents.Text.FontCollection _fonts;
    public DirectoryFontResolver(string fontsDirectory)
    {
        _fonts = new Documents.Text.FontCollection();
        // load standard Windows fonts
        _fonts.RegisterDirectory(Environment.GetFolderPath(Environment.SpecialFolder.Fonts));
        // load fonts from custom directory
        _fonts.RegisterDirectory(fontsDirectory);
        _fonts.DefaultFont = _fonts.FindFamilyName("Arial");
    }
    Documents.Text.FontCollection IFontResolver.GetFonts(string familyName, bool isBold, bool isItalic)
    {
        var fonts = new Documents.Text.FontCollection();
        fonts.Add(_fonts.FindFamilyName(familyName, isBold, isItalic) ?? _fonts.DefaultFont);
        return fonts;
    }
}
C# Copy Code
class MyDesignerForm : Form
{
    public MyDesignerForm()
    {
        InitializeComponent();
        //note the designer must be added to the form and its name have to be '_designer'.
        _designer.FontResolver = new DirectoryFontResolver("c:\\Fonts");
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GridMode Property

[image]
ActiveReports 19 .NET Edition
GridMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridMode Property

Glossary Item Box

Gets or sets the GridMode in the designer.

Syntax

Visual Basic (Declaration)
Public Property GridMode As GridMode
C#
public GridMode GridMode {get; set;}

Property Value

The mode of the grid as defined by the GridMode enumeration. This determines how the grid lines are drawn in the designer, affecting the visual guidance provided for aligning and placing report elements.

Remarks

The grid mode can be set to different styles such as dots or lines, depending on the user's preference or the specific requirements of the report design task at hand. Changing the grid mode can enhance the design experience by providing the appropriate level of visual guidance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GridX Property

[image]
ActiveReports 19 .NET Edition
GridX Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridX Property

Glossary Item Box

Determines how coarse the designer grid should be.

Syntax

Visual Basic (Declaration)
Public Property GridX As Integer
C#
public int GridX {get; set;}

Property Value

An integer value that represents the number of horizontal grid points per ruler unit.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | Thrown when the set value is less than or equal to 0, as grid spacing must be a positive integer.

Remarks

This property affects the alignment and placement of controls on the design surface. This property is applicable only when working with Section Reports in the designer.

Example

The following code demonstrates how to set the grid spacing:
C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GridY Property

[image]
ActiveReports 19 .NET Edition
GridY Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridY Property

Glossary Item Box

Determines how coarse the designer grid should be.

Syntax

Visual Basic (Declaration)
Public Property GridY As Integer
C#
public int GridY {get; set;}

Property Value

An integer value that represents the number of vertical grid points per ruler unit.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | Thrown when the set value is less than or equal to 0, as grid spacing must be a positive integer.

Remarks

This property affects the alignment and placement of controls on the design surface. This property is applicable only when working with Section Reports in the designer.

Example

The following code demonstrates how to set the grid spacing:
C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LaunchDataSourceWizard Property

[image]
ActiveReports 19 .NET Edition
LaunchDataSourceWizard Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LaunchDataSourceWizard Property

Glossary Item Box

Gets or sets a value indicating whether the Data Source Dialog should be launched automatically. This property is obsolete and should not be used in new development.

Syntax

Visual Basic (Declaration)
Public Property LaunchDataSourceWizard As Boolean
C#
public bool LaunchDataSourceWizard {get; set;}

Remarks

The Data Source Dialog is a tool that assists users in connecting their reports to data sources. While this property was previously used to control the automatic launching of the dialog, it has been deprecated in favor of more explicit methods of invoking the dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutMode Property

[image]
ActiveReports 19 .NET Edition
LayoutMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutMode Property

Glossary Item Box

Gets or sets the value that determines how the end user can lay out controls on the report design surface.

Syntax

Visual Basic (Declaration)
Public Property LayoutMode As LayoutMode
C#
public LayoutMode LayoutMode {get; set;}

Property Value

The layout mode as defined by the LayoutMode enumeration.

Remarks

Select from an enumerated value:

  • None allows free movement of controls.
  • SnapGrid snaps controls to the grid.
  • SnapLines snaps controls to lines showing alignment to other controls.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
}
VB.NET Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LockControls Property

[image]
ActiveReports 19 .NET Edition
LockControls Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LockControls Property

Glossary Item Box

Specifies whether the controls are locked in place.

Syntax

Visual Basic (Declaration)
Public Property LockControls As Boolean
C#
public bool LockControls {get; set;}

Property Value

Boolean value. If True, the controls cannot be moved or sized. If False, the controls can be moved or sized.

Remarks

When set to true, this property prevents any modifications to the controls' properties, size, or position within the designer, effectively making the design surface read-only. This is useful in scenarios where the design of the report is finalized and should not be altered.

Example

The sample below opens a Windows Form with the designer, featuring a pre-built report. Users can modify certain properties of existing controls, but changing the report layout-specifically the position or size of report items-is not possible.
C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
    this.designer1.LockControls = false;
    this.designer1.ShowDataSourceIcon = true;
    this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PageReportDesignerActions Property

[image]
ActiveReports 19 .NET Edition
PageReportDesignerActions Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PageReportDesignerActions Property

Glossary Item Box

Gets or sets a value representing the allowed actions in PageReport Designer.

Syntax

Visual Basic (Declaration)
Public Property PageReportDesignerActions As PageReportDesignerActions
C#
public PageReportDesignerActions PageReportDesignerActions {get; set;}

Property Value

The page report designer actions as defined by the PageReportDesignerActions enumeration. The default value is PageReportDesignerActions.All.

Remarks

This property controls the actions that are permitted within the PageReport Designer. It allows for granular control over the functionality available to the user, such as editing, deleting, or adding new pages to the report. By adjusting the allowed actions, the designer can be customized to fit specific user roles or workflows, enhancing security and usability.

Example

You can disable certain actions for pages in page reports.
C# Copy Code
// Disable the action to add a new page.
designer.PageReportDesignerActions = PageReportDesignerActions.All ^ PageReportDesignerActions.AddPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreviewPages Property

[image]
ActiveReports 19 .NET Edition
PreviewPages Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreviewPages Property

Glossary Item Box

Gets or sets the number of pages of report that should be generated for preview.

Syntax

Visual Basic (Declaration)
Public Property PreviewPages As Integer
C#
public int PreviewPages {get; set;}

Property Value

The number of preview pages.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | Thrown when the provided value is less than 0 or greater than 10000.

Remarks

Note: This property does not determine the total number of pages generated when the report is run to completion. If this value is set to 0, all pages of the report is generated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PromptUser Property

[image]
ActiveReports 19 .NET Edition
PromptUser Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PromptUser Property

Glossary Item Box

Determines whether to display a dialog when a control is deleted.

Syntax

Visual Basic (Declaration)
Public Property PromptUser As Boolean
C#
public bool PromptUser {get; set;}

Property Value

true if a confirmation dialog should be displayed when a control is deleted; otherwise, false.

Remarks

If set to true, the dialog is presented when a control is deleted at report design time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PropertyGrid Property

[image]
ActiveReports 19 .NET Edition
PropertyGrid Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PropertyGrid Property

Glossary Item Box

Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.

Syntax

Visual Basic (Declaration)
Public Property PropertyGrid As PropertyGrid
C#
public PropertyGrid PropertyGrid {get; set;}

Property Value

The System.Windows.Forms.PropertyGrid that is attached to the designer. This grid displays the properties of the report item currently selected in the designer, allowing the user to view and modify those properties.

Remarks

The PropertyGrid property plays a crucial role in the report design process, providing a user-friendly interface for inspecting and editing the properties of report items. By integrating a System.Windows.Forms.PropertyGrid into the designer, developers can offer end-users a powerful tool for customizing reports to meet their specific requirements.

This property is essential for enabling interactive report design experiences in applications that incorporate the GrapeCity ActiveReports Designer.

Example

This example shows how to integrate the Designer component with a PropertyGrid in a Windows Forms application.
C# Copy Code
class MyForm : Form
{
    MyForm()
    {
        var designer = new Designer() { Dock = DockStyle.Fill };
        var propertyGrid = new PropertyGrid { Dock = DockStyle.Right };
        designer.PropertyGrid = propertyGrid;
        Controls.Add(designer);
        Controls.Add(propertyGrid);
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Report Property

[image]
ActiveReports 19 .NET Edition
Report Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Report Property

Glossary Item Box

Returns a reference to the designer's report object.

Syntax

Visual Basic (Declaration)
Public Property Report As Object
C#
public object Report {get; set;}

Property Value

ActiveReport

Exceptions

Exception | Description
System.Exception | Thrown if an attempt is made to set the report to an invalid or unsupported type.

Remarks

This report object is used to gain access to the layout and controls properties.

Example

C# Copy Code
public object NewReport(string name)
{
    try
    {
     this.ardMain.NewReport();
      GrapeCity.ActiveReports.SectionReport rpt = (GrapeCity.ActiveReports.SectionReport)this.ardMain.Report;
      rpt.Document.Name = name;
      return this.ardMain.Report;
     }

    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
Visual Basic Copy Code
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportPartsDirectory Property

[image]
ActiveReports 19 .NET Edition
ReportPartsDirectory Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportPartsDirectory Property

Glossary Item Box

Gets or sets a value representing the directory path where report parts are stored for use in the report items library.

Syntax

Visual Basic (Declaration)
Public Property ReportPartsDirectory As String
C#
public string ReportPartsDirectory {get; set;}

Property Value

The directory path for report parts.

Remarks

This property specifies the location from which report parts are loaded into the report items library. Report parts can include reusable report components, templates, or other resources that enhance report design efficiency. By default, this path is set to the current user's Documents folder, but it can be customized to point to any accessible directory containing the desired report parts.

Example

C# Copy Code
designer.ReportPartsDirectory = "c:\\Data\Reports Library\\";

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportTabsPanelVisible Property

[image]
ActiveReports 19 .NET Edition
ReportTabsPanelVisible Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportTabsPanelVisible Property

Glossary Item Box

Gets or sets a value indicating whether the panel containing the tabs for switching between Design, Script, and Preview modes is visible.

Syntax

Visual Basic (Declaration)
Public Property ReportTabsPanelVisible As Boolean
C#
public bool ReportTabsPanelVisible {get; set;}

Property Value

true if the panel with the tabs is visible; otherwise, false. The default is true.

Remarks

This property allows for the customization of the report designer's interface by controlling the visibility of the panel that contains the Design, Script, and Preview tabs. It can be used to streamline the interface in scenarios where switching between these modes is not necessary.

Example

C# Copy Code
// You can hide the whole report tabs/tool pane.
designer.ReportTabxPanelVisible = false;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportTabsVisible Property

[image]
ActiveReports 19 .NET Edition
ReportTabsVisible Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportTabsVisible Property

Glossary Item Box

Sets or returns a value indicating whether the report tabs are shown below the designer.

Syntax

Visual Basic (Declaration)
Public Property ReportTabsVisible As Boolean
C#
public bool ReportTabsVisible {get; set;}

Property Value

true if the tabs are displayed; otherwise, false. The default is true.

Remarks

The report tabs allow the user to choose between the preview, the script view and the designer view.

Example

C# Copy Code
// Hide the tabs for switching between Design, Script, and Preview modes. To enable the tabs, set the property to true.
designer.ReportTabsVisible = false;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
EnableScripting Property


ReportType Property

[image]
ActiveReports 19 .NET Edition
ReportType Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportType Property

Glossary Item Box

Gets a value indicating the type of the currently loaded report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportType As DesignerReportType
C#
public DesignerReportType ReportType {get;}

Property Value

A DesignerReportType value that indicates the type of the report. This can be one of the following:
  • Page for Fixed Page Layout reports,
  • RdlDashboard for RDLX Dashboard reports,
  • RdlMultiSection for RDLX Multi-Section reports, or
  • Section for Section reports.
The determination is made based on the report's structure and specific features, such as whether it is a Fixed Page Layout report or has dashboard capabilities.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResourceLocator Property

[image]
ActiveReports 19 .NET Edition
ResourceLocator Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResourceLocator Property

Glossary Item Box

Gets or sets the resource locator implementation that used to locate the custom resources.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As ResourceLocator
C#
public ResourceLocator ResourceLocator {get; set;}

Property Value

An instance of GrapeCity.ActiveReports.ResourceLocator that is responsible for locating and retrieving resources needed by the report. If not set, the designer uses a default implementation.

Remarks

The ResourceLocator plays a critical role in the report generation process by enabling dynamic resolution of resources at design time and runtime. This property allows for customization of the resource resolution process, which can be essential for applications that store report resources in non-standard locations or need to apply custom logic to resource retrieval.

Setting this property to a custom implementation can provide greater flexibility and control over how resources are located and loaded, thereby accommodating complex application scenarios and resource management strategies.

Example

This property allows you to define a custom resource locator for accessing resources such as images and subreports from a specific location, whether it's a custom storage solution or a particular directory on the disk. To utilize this feature, you must implement a custom resource locator. See the example below for guidance on implementation: Then, you can utilize this custom resource locator within the designer.
C# Copy Code
class MyResourceLocator : ResourceLocator
{
    public override Resource GetResource(ResourceInfo resourceInfo)
    {
        if (resourceInfo.Name == "redSquare.png")
        {
            //Here we draw the image with the red square in the center.
            //You can load the image from file system, or from data base, or from assembly resources.
            var img = new Bitmap(100, 100);
            using var graphics = Graphics.FromImage(img);
            using var redBrush = new SolidBrush(Color.Red);
            graphics.FillRectangle(redBrush, 10, 10, 80, 80);
            var tmpStream = new MemoryStream();
            img.Save(tmpStream, System.Drawing.Imaging.ImageFormat.Png);
            tmpStream.Position = 0;
            return new Resource(tmpStream, new Uri("redSquare.png", UriKind.Relative));
        }
        return new Resource();
    }
}
C# Copy Code
class MyDesignerForm : Form
{
    public MyDesignerForm()
    {
        InitializeComponent();
        //note the designer must be added to the form and its name have to be '_designer'.
        _designer.ResourceLocator = new MyResourceLocator();
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ScrollingMode Property

[image]
ActiveReports 19 .NET Edition
ScrollingMode Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScrollingMode Property

Glossary Item Box

Gets or sets a value representing the scrolling mode for the designer view.

Syntax

Visual Basic (Declaration)
Public Property ScrollingMode As ScrollingMode
C#
public ScrollingMode ScrollingMode {get; set;}

Property Value

The scrolling modes as defined by the GrapeCity.Viewer.Common.Model.ScrollingMode enumeration.

Remarks

The default value is ScrollingMode.Continuous, which allows for smooth scrolling through the designer. This property can be set to ScrollingMode.Paged to restrict the view to a single page at a time, enhancing the focus on individual report sections during design.

Example

C# Copy Code
// Set the designer to use paged scrolling mode.
designer.ScrollingMode = ScrollingMode.Paged;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Selection Property

[image]
ActiveReports 19 .NET Edition
Selection Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Selection Property

Glossary Item Box

Returns the collection of selected objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
C#
public Selection Selection {get;}

Property Value

A Selection object representing the current selection within the designer. This collection includes all report elements or components that the user has selected.

Remarks

This property is essential for operations that need to act on the user's selection, such as property editing, deletion, or manipulation of report elements. It provides a way to programmatically access and interact with the selected items in the designer.

Example

C# Copy Code
designer.SelectionChanged += () {
    removeButton.Enabled =
    designer.Selection.OfType<ReportItem>().Count() > 0
    || designer.Selection.OfType<ARControl>().Count() > 0;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ShowDataSourceIcon Property

[image]
ActiveReports 19 .NET Edition
ShowDataSourceIcon Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ShowDataSourceIcon Property

Glossary Item Box

Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.

Syntax

Visual Basic (Declaration)
Public Property ShowDataSourceIcon As Boolean
C#
public bool ShowDataSourceIcon {get; set;}

Property Value

Boolean. If True, the data source icon will be visible; otherwise, False.

Remarks

You can use this property to hide the Data Source icon and provide your own interface for manipulating the report's data source.

Example

This example demonstrates how to show or hide the data source icon in the section tab for section reports.
C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.ShowDataSourceIcon = false;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.ShowDataSourceIcon = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SnapGrid Property

[image]
ActiveReports 19 .NET Edition
SnapGrid Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SnapGrid Property

Glossary Item Box

Sets or returns a value indicating whether the controls should be snapped to the grid points.

Syntax

Visual Basic (Declaration)
Public Property SnapGrid As Boolean
C#
public bool SnapGrid {get; set;}

Property Value

Boolean value. If True, the controls are snapped to the grid points. If False, the controls can be sized and positioned freely.

Remarks

This property is obsolete and maintained for backward compatibility. Use the LayoutMode property to control the layout behavior of controls on the design surface.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Toolbox Property

[image]
ActiveReports 19 .NET Edition
Toolbox Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Toolbox Property

Glossary Item Box

Gets or Sets the IToolboxService for the Report Designer.

Syntax

Visual Basic (Declaration)
Public Property Toolbox As IToolboxService
C#
public IToolboxService Toolbox {get; set;}

Property Value

An instance of System.Drawing.Design.IToolboxService that provides access to the toolbox service used by the report designer.

Remarks

The toolbox service is a key component in the report designer that manages the toolbox items, such as controls and components, which can be dragged onto the report design surface. This property allows for the customization or replacement of the toolbox service, enabling advanced scenarios such as dynamically changing the available toolbox items based on certain conditions.

Note: Setting this property with a custom implementation of System.Drawing.Design.IToolboxService can significantly alter the behavior and capabilities of the report designer's toolbox. It should be done with understanding of the underlying mechanics and implications.

Example

This example illustrates how to add a Designer component and a Toolbox to a Windows Forms application, configuring the Toolbox as the Designer's toolbox. Demonstrates how to control the availability of toolbox items in the designer's toolbox. Then, configure the toolbox with the state provider to control the enabled items. This example shows how to remove a specific item from the toolbox. It demonstrates finding the item by its type name and then removing it.
C# Copy Code
class MyForm : Form
{
    MyForm()
    {
        var designer = new Designer() { Dock = DockStyle.Fill };
        var toolbox = new Toolbox { Dock = DockStyle.Right };
        designer.Toolbox = toolbox;
        Controls.Add(designer);
        Controls.Add(toolbox);
    }
}
C# Copy Code
// First, define a state provider by implementing the IToolboxUser interface. This example enables only the BandedListDesigner tool.
class ToolboxStateProvider : IToolboxUser
{
    public bool GetToolSupported(ToolboxItem tool)
    {
        if (tool.TypeName == "GrapeCity.ActiveReports.Design.DdrDesigner.Designers.BandedList.BandedListDesigner")
            return true;
        return false;
    }
    public void ToolPicked(ToolboxItem tool) { }
}
C# Copy Code
toolbox.ConfigureToolboxItems(new ToolboxStateProvider());
C# Copy Code
private static void RemoveBandedListFromToolBox(Toolbox toolbox)
{
    // Find the item to be removed by its type name.
    var bandedList = toolbox.GetToolboxItems()
        .OfType<ToolboxItem>()
        .Single(items => items.TypeName.EndsWith("BandedListDesigner"));
    // Remove the found banded list item from the toolbox.
    toolbox.RemoveToolboxItem(items);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ToolBoxItem Property

[image]
ActiveReports 19 .NET Edition
ToolBoxItem Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolBoxItem Property

Glossary Item Box

Sets the type of control in the toolbox.

Syntax

Visual Basic (Declaration)
Public Property ToolBoxItem As Object
C#
public object ToolBoxItem {get; set;}

Property Value

The object that represents the toolbox item for the GrapeCity.ActiveReports.SectionReport.

Remarks

This property is used to implement a custom toolbox toolbar.

Example

C# Copy Code
private GrapeCity.ActiveReports.Design.Toolbox.Toolbox arToolbox;
private void formDesigner_Load(object sender, System.EventArgs e)
{
    this.arDesigner.Toolbox = this.arToolbox;
    System.Drawing.Design.ToolboxItem tbItem = new System.Drawing.Design.ToolboxItem(typeof(GrapeCity.ActiveReports.Viewer.Win.Viewer));
    this.arToolbox.AddToolboxItem(tbItem, "General");
}
Visual Basic Copy Code
Private arToolbox As GrapeCity.ActiveReports.Design.Toolbox.Toolbox
Private Sub formDesigner_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.arDesigner.Toolbox = Me.arToolbox
    Dim tbItem As System.Drawing.Design.ToolboxItem = New System.Drawing.Design.ToolboxItem(GetType(GrapeCity.ActiveReports.Viewer.Win.Viewer))
    arToolbox.AddToolboxItem(tbItem, "General")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ToolPanel Property

[image]
ActiveReports 19 .NET Edition
ToolPanel Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolPanel Property

Glossary Item Box

Gets or sets the value that indicate the tools that are available in the designer tool panel.

Syntax

Visual Basic (Declaration)
Public Property ToolPanel As ToolPanelButton
C#
public ToolPanelButton ToolPanel {get; set;}

Property Value

A ToolPanelButton value that specifies the buttons displayed in the tool panel. The default is All, which displays all available tools.

Remarks

The tool panel provides quick access to various actions and settings within the designer. This property allows for customization of the tool panel by specifying which buttons should be available. For example, you can limit the tool panel to only show zoom controls or the grid toggle button, depending on the needs of your application.

Use the ToolPanelButton enumeration to configure the available tools. This can enhance the user interface by simplifying the tool panel based on the context of the task being performed.

Example

C# Copy Code
// To hide specific items from the tool panel, use the ToolPanel property.
// The following code removes the zoom slider from the tool panel:
designer.ToolPanel = ToolPanelButton.All ^ ToolPanelButton.ZoomSlider;
// To remove multiple items, such as Dimension Lines, Grid Mode, Snap Grid, Snap Lines, and Mouse Mode, you can combine them like this:
designer.ToolPanel = ToolPanelButton.All ^ ToolPanelButton.DimensionLines ^ ToolPanelButton.GridMode;

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


UndoManager Property

[image]
ActiveReports 19 .NET Edition
UndoManager Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : UndoManager Property

Glossary Item Box

The UndoManager allows users to undo and redo changes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UndoManager As UndoManager
C#
public UndoManager UndoManager {get;}

Property Value

The UndoManager that allows for the undoing and redoing of changes made in the designer.

Remarks

The UndoManager is a critical component of the designer's user experience, providing users with the ability to reverse actions or restore them if reversed unintentionally. This property exposes the undo manager associated with the current instance of the designer, enabling programmatic access to its functionality.

Through the UndoManager, developers can programmatically trigger undo or redo operations, check the availability of such operations, and even integrate more complex undo/redo scenarios into their applications.

Example

C# Copy Code
private void mnuEditUndo_Click(object sender, System.EventArgs e)
{
    this.ardMain.UndoManager.Undo();
}
Visual Basic Copy Code
'mnuEditUndo_Click - calls the UndoManager.Undo command from the Designer
Private Sub mnuEditUndo_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles mnuEditUndo.Click
    Me.ardMain.UndoManager.Undo()
End Sub 'mnuEditUndo_Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Zoom Property

[image]
ActiveReports 19 .NET Edition
Zoom Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Zoom Property

Glossary Item Box

Gets or sets the zoom value for the Designer.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
C#
public float Zoom {get; set;}

Property Value

A System.Single representing the zoom level. Valid values range from 0.5 (50%) to 4.0 (400%).

Exceptions

Exception | Description
System.ArgumentException | Thrown if the set value is outside the allowable range of 0.5 to 4.0.

Remarks

Values can range from >= 1.0f to <= 8.0f.

Example

C# Copy Code
private void ResetZoom_Click(object sender, EventArgs e)
{
    designer.Zoom = 1;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Events

[image]
ActiveReports 19 .NET Edition
Designer Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Events

 | Name | Description
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | ReportChanged | Occurs when any modification is made to the report, such as changes to the design, data sources, or properties.
Public Event | ReportNameChanged | Occurs when the name of the report changes. This event can be used to respond to changes in the report's name, such as updating UI elements or performing additional logic.
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ChartDataSourceClicked Event

[image]
ActiveReports 19 .NET Edition
ChartDataSourceClicked Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ChartDataSourceClicked Event

Glossary Item Box

Fires after a chart data source item has been clicked.

Syntax

Visual Basic (Declaration)
Public Event ChartDataSourceClicked As EventHandler(Of ChartDataSourceClickedEventArgs)
C#
public event EventHandler<ChartDataSourceClickedEventArgs> ChartDataSourceClicked

Event Data

The event handler receives an argument of type ChartDataSourceClickedEventArgs containing data related to this event. The following ChartDataSourceClickedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Indicates that the default action should be skipped.
Chart | Provides access to the control.

Remarks

This event is raised in response to the user clicking on a data source item specifically for a chart component within the designer. It provides an opportunity to respond to the selection of a chart's data source, allowing for custom logic or UI to be invoked, such as displaying the data source properties or initiating data source configuration.

The ChartDataSourceClickedEventArgs parameter contains information about the clicked data source item, enabling detailed handling of the event.

Example

Visual Basic Copy Code
'Disable the Chart DataSource dialog
Private Sub arDesigner_ChartDataSourceClicked(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs) Handles arDesigner.ChartDataSourceClicked
    e.Cancel = True
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!")
End Sub
C# Copy Code
//Disable the Chart DataSource dialog
void arDesigner_ChartDataSourceClicked(object sender, ChartDataSourceClickedEventArgs e)
{
    e.Cancel = true;
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenuOpen Event

[image]
ActiveReports 19 .NET Edition
ContextMenuOpen Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuOpen Event

Glossary Item Box

Fires before a context menu is opened.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuOpen As ContextMenuOpenEventHandler
C#
public event ContextMenuOpenEventHandler ContextMenuOpen

Remarks

This event provides an opportunity to customize the context menu before it is shown to the user. You can add, remove, or modify menu items based on the current state of the designer or the selected elements within it.

Handlers for this event receive an argument of type ContextMenuOpenArgs, which provides information about the context menu and allows for its customization.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DataSourceIconClick Event

[image]
ActiveReports 19 .NET Edition
DataSourceIconClick Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClick Event

Glossary Item Box

Raised when the Datasource icon is clicked in the designer.

Syntax

Visual Basic (Declaration)
Public Event DataSourceIconClick As DataSourceIconClickEventHandler
C#
public event DataSourceIconClickEventHandler DataSourceIconClick

Event Data

The event handler receives an argument of type DataSourceIconClickEventArgs containing data related to this event. The following DataSourceIconClickEventArgs properties provide information specific to this event.

Property | Description
Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.

Remarks

This event is triggered as a direct response to the user's action of clicking the DataSource icon, typically used to initiate the process of connecting to or modifying the data source for the report being designed. It provides a hook for implementing custom behavior or displaying additional UI elements related to data source configuration.

Handlers attached to this event can access the event arguments to obtain context-specific information, enabling fine-grained control over the application's response to the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DataSourceIconClicked Event

[image]
ActiveReports 19 .NET Edition
DataSourceIconClicked Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClicked Event

Glossary Item Box

Gets the value from the DialogResult when the data source icon is clicked.

Syntax

Visual Basic (Declaration)
Public Event DataSourceIconClicked As DataSourceIconClickedEventHandler
C#
public event DataSourceIconClickedEventHandler DataSourceIconClicked

Event Data

The event handler receives an argument of type DataSourceIconClickedEventArgs containing data related to this event. The following DataSourceIconClickedEventArgs properties provide information specific to this event.

Property | Description
DialogResult | Gets the value from the data source dialog.

Remarks

This event is fired following the closure of the DataSource dialog, which is typically used for configuring or selecting the data source for the report. It signifies that the user has completed their interaction with the DataSource dialog, allowing for post-dialog actions or updates to be initiated in response.

Event handlers can utilize this event to implement custom logic, such as refreshing data or UI elements based on the new or modified data source settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerTabChanged Event

[image]
ActiveReports 19 .NET Edition
DesignerTabChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerTabChanged Event

Glossary Item Box

Raised when the designer tab changes.

Syntax

Visual Basic (Declaration)
Public Event DesignerTabChanged As DesignerTabChangedEventHandler
C#
public event DesignerTabChangedEventHandler DesignerTabChanged

Event Data

The event handler receives an argument of type DesignerTabChangedEventArgs containing data related to this event. The following DesignerTabChangedEventArgs properties provide information specific to this event.

Property | Description
ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.

Remarks

This event is fired when the user switches between different tabs in the designer interface, such as moving from the "Design" tab to the "Preview" tab. It allows for the execution of custom logic in response to this change, such as updating UI elements or performing cleanup tasks related to the tab change.

Event handlers can use this event to adapt the application's behavior to the newly active designer tab, enhancing the user experience and ensuring the application remains responsive to user actions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EditModeEntering Event

[image]
ActiveReports 19 .NET Edition
EditModeEntering Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeEntering Event

Glossary Item Box

This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.

Syntax

Visual Basic (Declaration)
Public Event EditModeEntering As EditModeEnteringEventHandler
C#
public event EditModeEnteringEventHandler EditModeEntering

Event Data

The event handler receives an argument of type EditModeEnteringEventArgs containing data related to this event. The following EditModeEnteringEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Control | Gets the type of control that enters edit mode.

Remarks

This event provides an opportunity to intercept the action of entering edit mode. It can be used to implement custom logic before the designer allows editing of report component properties directly within the designer interface.

Listeners can use this event to, for example, validate conditions before editing is permitted or to prevent editing under certain circumstances by cancelling the edit mode transition.

Example

This code allows you to disable edit mode for the TextBox control.
C# Copy Code
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }
This code allows you to disable edit mode for the TextBox control.
Visual Basic Copy Code
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EditModeExit Event

[image]
ActiveReports 19 .NET Edition
EditModeExit Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeExit Event

Glossary Item Box

This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.

Syntax

Visual Basic (Declaration)
Public Event EditModeExit As EditModeExitEventHandler
C#
public event EditModeExitEventHandler EditModeExit

Event Data

The event handler receives an argument of type EditModeExitEventArgs containing data related to this event. The following EditModeExitEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the type of control that is exiting edit mode.
Type | Gets the exit type.

Remarks

This event is triggered when the designer transitions out of edit mode, which could be due to the user completing their modifications or cancelling the edit operation. It provides an opportunity to execute custom logic after editing has concluded, such as validation, cleanup, or updating other parts of the UI in response to the changes made.

Listeners can use this event to perform actions that need to occur once editing is no longer active, ensuring that any necessary adjustments or checks are made following the edit session.

Example

C# Copy Code
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            string a=((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name;
            if (e.Type == ExitType.Save && a == "txtDocumentOwner")
            {
                // save the new value of textbox control in the temporary field
                _global_do = (e.Control as TextBox).Text;
            }
        }
Visual Basic Copy Code
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If (e.Type = ExitType.Save) And (((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name = "txtDocumentOwner") Then
            ' save the new value of textbox control in the temporary field
            _global_do = CType(e.Control, TextBox).Text
        End If
    End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutChanged Event

[image]
ActiveReports 19 .NET Edition
LayoutChanged Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanged Event

Glossary Item Box

Raised when the layout is changed.

Syntax

Visual Basic (Declaration)
Public Event LayoutChanged As LayoutChangedEventHandler
C#
public event LayoutChangedEventHandler LayoutChanged

Remarks

You can use this event to monitor changes to the report layout and update any dependent data such as SQL queries or custom user interfaces (report explorers, group sections dialog, etc).

Example

This example shows how to perform specific actions immediately after the report layout has changed. Use this event to handle report layout changes. The following example prevents the addition of new controls until the report has a data set:
C# Copy Code
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutChanging Event

[image]
ActiveReports 19 .NET Edition
LayoutChanging Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanging Event

Glossary Item Box

Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.

Syntax

Visual Basic (Declaration)
Public Event LayoutChanging As LayoutChangingEventHandler
C#
public event LayoutChangingEventHandler LayoutChanging

Remarks

This event provides a mechanism to monitor and potentially cancel changes to the report's layout before they are applied. It can be useful for enforcing constraints, validating changes, or implementing custom behavior in response to layout adjustments.

Handlers can inspect the event arguments to determine the nature of the proposed change and decide whether to allow it, modify it, or prevent it from occurring.

Example

Visual Basic Copy Code
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
C# Copy Code
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocateCredentials Event

[image]
ActiveReports 19 .NET Edition
LocateCredentials Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateCredentials Event

Glossary Item Box

Occurs when the report is previewed and credentials are needed.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSource | Gets the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.

Remarks

This event is raised when accessing a data source requires authentication, and credentials are not available or need to be confirmed. It provides a secure way to request and apply credentials without hard-coding them into the report or application.

Handlers for this event can prompt the user for credentials, retrieve them from a secure store, or apply default credentials based on application logic.

Example

It can be necessary for report preview. Use this event to provide the credentials for the data providers.
C# Copy Code
designer.LocateCredentials += (sender, args) => {
    args.UserName = "sa";
    args.Password = "12345";
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocateDataSource Event

[image]
ActiveReports 19 .NET Edition
LocateDataSource Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateDataSource Event

Glossary Item Box

Occurs when a data provider of the previewed report needs to locate the data at runtime.

Syntax

Visual Basic (Declaration)
Public Event LocateDataSource As LocateDataSourceEventHandler
C#
public event LocateDataSourceEventHandler LocateDataSource

Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Parameters | Gets the Parameters collection specified for a given report instance.
Report | Gets the Report that is trying to locate the data set.

Remarks

This event is triggered when the report requires a data source that has not been predefined or needs to be resolved at runtime. It allows for the dynamic provision of data sources based on the report's requirements or user input.

Event handlers can use this opportunity to present data source selection dialogs, perform custom data source configuration, or apply logic to determine the appropriate data source for the current context.

Example

Utilize the specified event to supply data necessary for the preview functionality of page reports. This ensures that the report previews are populated with the latest data.
C# Copy Code
designer.LocateDataSource += (sender, args) => {
    var dataSourceName = args.DataSet.Query.DataSourceName;
    var dataSource = ((PageReport)designer.Report).Report.DataSources.First(x => x.Name == dataSourceName);
    if(dataSource.ConnectionProperties.DataProvider == "OBJECT")
    {
        args.Data = new[] { new { CustomerName = "Gc Inc." } };
    }
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportChanged Event

[image]
ActiveReports 19 .NET Edition
ReportChanged Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportChanged Event

Glossary Item Box

Occurs when any modification is made to the report, such as changes to the design, data sources, or properties.

Syntax

Visual Basic (Declaration)
Public Event ReportChanged As EventHandler
C#
public event EventHandler ReportChanged

Remarks

This event is a broad notification that the report has been altered in some way. It can be triggered by a variety of actions, including but not limited to adding or removing report elements, modifying properties, or changing the report's data source. Handlers for this event can be used to implement functionality such as enabling save operations, refreshing previews, or updating UI elements to reflect the changes made to the report.

Example

C# Copy Code
// Subscribe to the ReportChanged event to react to changes in the report.
// For instance, enabling a 'Save' button to indicate that unsaved changes are present.
designer.ReportChanged += (sender, args) => {
saveButton.Enabled = true;
};

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportNameChanged Event

[image]
ActiveReports 19 .NET Edition
ReportNameChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportNameChanged Event

Glossary Item Box

Occurs when the name of the report changes. This event can be used to respond to changes in the report's name, such as updating UI elements or performing additional logic.

Syntax

Visual Basic (Declaration)
Public Event ReportNameChanged As EventHandler(Of ReportNameChangedEventArgs)
C#
public event EventHandler<ReportNameChangedEventArgs> ReportNameChanged

Event Data

The event handler receives an argument of type ReportNameChangedEventArgs containing data related to this event. The following ReportNameChangedEventArgs properties provide information specific to this event.

Property | Description
ReportName | Gets the name of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ScriptChanged Event

[image]
ActiveReports 19 .NET Edition
ScriptChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScriptChanged Event

Glossary Item Box

Raised when the script for a report in the End User Report Designer is changed.

Syntax

Visual Basic (Declaration)
Public Event ScriptChanged As ScriptChangedEventHandler
C#
public event ScriptChangedEventHandler ScriptChanged

Remarks

This event is raised when the user switches from the Design view to the Script view of the report. It is not raised by changes to the script.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SelectionChanged Event

[image]
ActiveReports 19 .NET Edition
SelectionChanged Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SelectionChanged Event

Glossary Item Box

Raised when the selection changes.

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler
C#
public event SelectionChangedEventHandler SelectionChanged

Remarks

You can use the Selection property to inspect the current selection.

Example

C# Copy Code
// ardMain_SelectionChanged - runs when a control/section in the layout is selected

private void ardMain_SelectionChanged()
{
    //Update the property grid with the new control/section properties
    this.SelChangePropGrid();

    if(this._controlAdded)  //Control is newly added
    {
        //Add item to ComboBox and PropGrid
        this._isCboDirty = true;
        this._controlAdded = false;
    }

    if(this._controlDeleted)  //Control is newly deleted
    {
        this._isCboDirty = true;
    }

    if(this._sectionAdded)  //Section is newly added
    {
        this._isCboDirty = true;
    }

    if(this._sectionDeleted)  //Section is newly deleted
    {
        this._isCboDirty = true;
    }
}
Visual Basic Copy Code
'ardMain_SelectionChanged - runs when a control/section in the layout is selected
Private Sub ardMain_SelectionChanged() Handles ardMain.SelectionChanged
    'Update the property grid with the new control/section properties
    Me.SelChangePropGrid()

    If Me._controlAdded Then 'Control is newly added
        'Add item to ComboBox and PropGrid
        Me._isCboDirty = True
        Me._controlAdded = False
    End If

    If Me._controlDeleted Then 'Control is newly deleted
        Me._isCboDirty = True
    End If

    If Me._sectionAdded Then 'Section is newly added
        Me._isCboDirty = True
    End If

    If Me._sectionDeleted Then 'Section is newly deleted
        Me._isCboDirty = True
    End If
End Sub 'ardMain_SelectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


StatusChanged Event

[image]
ActiveReports 19 .NET Edition
StatusChanged Event
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : StatusChanged Event

Glossary Item Box

This event is raised for each change in the status of the designer actions.

Syntax

Visual Basic (Declaration)
Public Event StatusChanged As StatusChangedEventHandler
C#
public event StatusChangedEventHandler StatusChanged

Remarks

Designer actions represent the commands that are typically invoked from UI elements such as a toolbar or a menu. You can use the QueryAction methods to check the status of the changed action and update your custom UI elements.

Example

C# Copy Code
// ardMain_StatusChanged - runs with the status of the Designer has changed
// (button is pressed)

private void ardMain_StatusChanged(object sender, System.EventArgs e)
{
    for(int i=0;i<this.tbAlign.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbAlign.Buttons[i];
        if(tb.Tag != null)
        {
            //If Alignment toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }
    for(int i=0;i<this.tbFormat.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbFormat.Buttons[i];
        if(tb.Tag != null)
        {
            //if Format toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }

    //Update Menus and other toolbars
    StatusStandardToolbar();
    UpdateFormatMenus();
}
Visual Basic Copy Code
'ardMain_StatusChanged - runs with the status of the Designer has changed
'(button is pressed)
Private Sub ardMain_StatusChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ardMain.StatusChanged
    Dim i As Integer
    For i = 0 To (Me.tbAlign.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbAlign.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'If Alignment toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    For i = 0 To (Me.tbFormat.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbFormat.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'if Format toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    'Update Menus and other toolbars
    StatusStandardToolbar()
    UpdateFormatMenus()
End Sub 'ardMain_StatusChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


ToolboxItemChanged Event

[image]
ActiveReports 19 .NET Edition
ToolboxItemChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolboxItemChanged Event

Glossary Item Box

Raised when a toolbox control is drawn on the Report Designer.

Syntax

Visual Basic (Declaration)
Public Event ToolboxItemChanged As ToolboxItemChangedEventHandler
C#
public event ToolboxItemChangedEventHandler ToolboxItemChanged

Remarks

This event is raised in response to changes in the toolbox item, such as when a new item is selected or an existing item's properties are modified. It provides an opportunity to execute custom logic in response to these changes, enabling dynamic updates to the UI or other components based on the current toolbox item state.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerTabChangedEventArgs Class

[image]
ActiveReports 19 .NET Edition
DesignerTabChangedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

Contains the active tab information.

Object Model

DesignerTabChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DesignerTabChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class DesignerTabChangedEventArgs : System.EventArgs

Remarks

This class is used to convey information about which tab has become active in a designer environment, allowing event handlers to respond to changes in the active tab. This can be useful for updating UI elements or performing other actions based on the newly activated tab.

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DesignerTabChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerTabChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
DesignerTabChangedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by DesignerTabChangedEventArgs.

Public Properties

 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top

See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
DesignerTabChangedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see DesignerTabChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top

See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ActiveTab Property

[image]
ActiveReports 19 .NET Edition
ActiveTab Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DesignerTabChangedEventArgs Class : ActiveTab Property

Glossary Item Box

Gets the DesignerTab enumeration that indicates what tab is currently active.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveTab As DesignerTab
C#
public DesignerTab ActiveTab {get;}

Property Value

The active tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerTabChangedEventArgs Class
DesignerTabChangedEventArgs Members


EditModeEnteringEventArgs Class

[image]
ActiveReports 19 .NET Edition
EditModeEnteringEventArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

This class retrieves the type of control to be edited when the user enters edit mode, allowing you to cancel editing for specified types of controls.

Object Model

EditModeEnteringEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EditModeEnteringEventArgs
   Inherits System.EventArgs
C#
public sealed class EditModeEnteringEventArgs : System.EventArgs

Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label

Example

Visual Basic Copy Code
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub
C# Copy Code
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
EditModeEnteringEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

The following tables list the members exposed by EditModeEnteringEventArgs.

Public Constructors

 | Name | Description
Public Constructor | EditModeEnteringEventArgs Constructor | Initializes a new instance of the EditModeEnteringEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top

See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
EditModeEnteringEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : EditModeEnteringEventArgs Constructor

control

The type of control that is entering edit mode.

Glossary Item Box

Initializes a new instance of the EditModeEnteringEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As Object _
)
C#
public EditModeEnteringEventArgs(
   object control
)

Parameters

control

The type of control that is entering edit mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeEnteringEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
EditModeEnteringEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

For a list of all members of this type, see EditModeEnteringEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top

See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 19 .NET Edition
Cancel Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Cancel Property

Glossary Item Box

Gets or sets a value indicating whether to cancel edit mode for the control.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Property Value

true if entering edit mode should be canceled; otherwise, false.

Remarks

Setting this property to true prevents the control from entering edit mode. This can be used to enforce custom validation or other pre-editing conditions. The default value is false, allowing edit mode to be entered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


Control Property

[image]
ActiveReports 19 .NET Edition
Control Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Control Property

Glossary Item Box

Gets the type of control that enters edit mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Object
C#
public object Control {get;}

Property Value

The control that is about to enter edit mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeExitEventArgs Class

[image]
ActiveReports 19 .NET Edition
EditModeExitEventArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

This class retrieves the type of control edited when the user exits edit mode.

Object Model

EditModeExitEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EditModeExitEventArgs
   Inherits System.EventArgs
C#
public sealed class EditModeExitEventArgs : System.EventArgs

Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label

Example

C# Copy Code
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.Label)
            {
                (e.Control as GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!";
            }
        }
Visual Basic Copy Code
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.Label Then
            CType(e.Control, GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!"
        End If
    End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeExitEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
EditModeExitEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

The following tables list the members exposed by EditModeExitEventArgs.

Public Constructors

 | Name | Description
Public Constructor | EditModeExitEventArgs Constructor | Initializes a new instance of the EditModeExitEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top

See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
EditModeExitEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : EditModeExitEventArgs Constructor

control

The type of control that is exiting edit mode.

type
Exit type.

Glossary Item Box

Initializes a new instance of the EditModeExitEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As Object, _
   ByVal type As ExitType _
)
C#
public EditModeExitEventArgs(
   object control,
   ExitType type
)

Parameters

control

The type of control that is exiting edit mode.

type
Exit type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


EditModeExitEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
EditModeExitEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

For a list of all members of this type, see EditModeExitEventArgs members.

Public Properties

 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top

See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Control Property

[image]
ActiveReports 19 .NET Edition
Control Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Control Property

Glossary Item Box

Gets the type of control that is exiting edit mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Object
C#
public object Control {get;}

Property Value

The control or component instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Type Property

Glossary Item Box

Gets the exit type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ExitType
C#
public ExitType Type {get;}

Property Value

The exit type, as defined by the ExitType enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


LayerList Class

[image]
ActiveReports 19 .NET Edition
LayerList Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

Represents a user control that displays and manages a list of layers within an ActiveReports report.

Object Model

LayerList Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayerList
   Inherits System.Windows.Forms.UserControl
C#
public sealed class LayerList : System.Windows.Forms.UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.LayerList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Members
GrapeCity.ActiveReports.Design Namespace


LayerList Class Members

[image]
ActiveReports 19 .NET Edition
LayerList Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

The following tables list the members exposed by LayerList.

Public Constructors

 | Name | Description
Public Constructor | LayerList Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Top

Public Events

 | Name | Description
Public Event | SelectionChanged | Occurs when the selection within the layers list changes, such as when a different layer is selected by the user.
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


LayerList Constructor

[image]
ActiveReports 19 .NET Edition
LayerList Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LayerList Constructor

Glossary Item Box

Overload List

Overload | Description
LayerList Constructor() | Initializes a new instance of layer list.
LayerList Constructor(IThemeManager) | Initializes a new instance of layer list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerList Constructor()

[image]
ActiveReports 19 .NET Edition
LayerList Constructor()
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LayerList Constructor : LayerList Constructor()

Glossary Item Box

Initializes a new instance of layer list.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LayerList()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LayerList Constructor(IThemeManager)

[image]
ActiveReports 19 .NET Edition
LayerList Constructor(IThemeManager)
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LayerList Constructor : LayerList Constructor(IThemeManager)

themeManager
An object for managing colors of the UI-controls

Glossary Item Box

Initializes a new instance of layer list.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal themeManager As IThemeManager _
)
C#
public LayerList(
   IThemeManager themeManager
)

Parameters

themeManager
An object for managing colors of the UI-controls

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LayerList Class Properties

[image]
ActiveReports 19 .NET Edition
LayerList Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

For a list of all members of this type, see LayerList members.

Public Properties

 | Name | Description
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


ReportDesigner Property

[image]
ActiveReports 19 .NET Edition
ReportDesigner Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ReportDesigner Property

Glossary Item Box

Gets or sets the Designer instance to bind to this control.

Syntax

Visual Basic (Declaration)
Public Property ReportDesigner As Designer
C#
public Designer ReportDesigner {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerList Class Events

[image]
ActiveReports 19 .NET Edition
LayerList Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

For a list of all members of this type, see LayerList members.

Public Events

 | Name | Description
Public Event | SelectionChanged | Occurs when the selection within the layers list changes, such as when a different layer is selected by the user.
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


SelectionChanged Event

[image]
ActiveReports 19 .NET Edition
SelectionChanged Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SelectionChanged Event

Glossary Item Box

Occurs when the selection within the layers list changes, such as when a different layer is selected by the user.

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged As Action(Of LayerSelectionChangedEventArgs)
C#
public event Action<LayerSelectionChangedEventArgs> SelectionChanged

Remarks

This event provides notification that the current selection within the layers list has changed, which can occur through user interaction or programmatically. This is useful for updating property grids, toolbars, or other UI elements to reflect the properties and actions relevant to the newly selected components.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerSelectionChangedEventArgs Class

[image]
ActiveReports 19 .NET Edition
LayerSelectionChangedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

Provides data for the SelectionChanged event of the LayerList

Object Model

LayerSelectionChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayerSelectionChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class LayerSelectionChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayerSelectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
LayerSelectionChangedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by LayerSelectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LayerSelectionChangedEventArgs Constructor | Initializes a new instance of the LayoutSelectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top

See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Constructor

[image]
ActiveReports 19 .NET Edition
LayerSelectionChangedEventArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : LayerSelectionChangedEventArgs Constructor

selectedLayer
The selected layer.

Glossary Item Box

Initializes a new instance of the LayoutSelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectedLayer As IComponent _
)
C#
public LayerSelectionChangedEventArgs(
   IComponent selectedLayer
)

Parameters

selectedLayer
The selected layer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayerSelectionChangedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LayerSelectionChangedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see LayerSelectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top

See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


SelectedLayer Property

[image]
ActiveReports 19 .NET Edition
SelectedLayer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : SelectedLayer Property

Glossary Item Box

Gets the currently selected Layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedLayer As IComponent
C#
public IComponent SelectedLayer {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayoutChangedArgs Class

[image]
ActiveReports 19 .NET Edition
LayoutChangedArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

The LayoutChangedArgs class provides data required for the LayoutChanged event.

Object Model

LayoutChangedArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutChangedArgs
   Inherits System.EventArgs
C#
public class LayoutChangedArgs : System.EventArgs

Remarks

The LayoutChangedArgs class contains information about the type of layout change that occurred, allowing event handlers to respond appropriately. This can include changes such as adding, removing, or modifying components within the designer's layout. The type of change is categorized by the LayoutChangeType enumeration.

Example

C# Copy Code
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangedArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Members
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Class Members

[image]
ActiveReports 19 .NET Edition
LayoutChangedArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

The following tables list the members exposed by LayoutChangedArgs.

Public Constructors

 | Name | Description
Public Constructor | LayoutChangedArgs Constructor | Initializes a new instance of the LayoutChangedArgs class.
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top

See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Constructor

[image]
ActiveReports 19 .NET Edition
LayoutChangedArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : LayoutChangedArgs Constructor

type
Specifies the type of layout change.

Glossary Item Box

Initializes a new instance of the LayoutChangedArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As LayoutChangeType _
)
C#
public LayoutChangedArgs(
   LayoutChangeType type
)

Parameters

type
Specifies the type of layout change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members


LayoutChangedArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LayoutChangedArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

For a list of all members of this type, see LayoutChangedArgs members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top

See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


Type Property

[image]
ActiveReports 19 .NET Edition
Type Property
See Also Example

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : Type Property

Glossary Item Box

Gets or sets the type of layout change that caused the event to be raised.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As LayoutChangeType
C#
public LayoutChangeType Type {get;}

Property Value

LayoutChangeType enumeration value that determines the type of change.

Example

C# Copy Code
/// <summary>
/// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
/// </summary>
private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.LayoutChangeType


LayoutChangingArgs Class

[image]
ActiveReports 19 .NET Edition
LayoutChangingArgs Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

The LayoutChangingArgs class provides data required for the LayoutChanging event.

Object Model

LayoutChangingArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutChangingArgs
   Inherits System.EventArgs
C#
public class LayoutChangingArgs : System.EventArgs

Example

Visual Basic Copy Code
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
C# Copy Code
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangingArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Class Members

[image]
ActiveReports 19 .NET Edition
LayoutChangingArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

The following tables list the members exposed by LayoutChangingArgs.

Public Constructors

 | Name | Description
Public Constructor | LayoutChangingArgs Constructor | Initializes a new instance of the LayoutChangingArgs class with specified details about the layout change.
Top

Public Properties

 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top

See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Constructor

[image]
ActiveReports 19 .NET Edition
LayoutChangingArgs Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : LayoutChangingArgs Constructor

type
The type of layout change that is to occur.
selectionType
Specifies the selection type involved in the layout change, categorized by the SelectionType enumeration.
name
The array of names of the controls or sections to be updated or changed.
newValue
The array of controls or sections to be added.
oldValue
The array of controls or sections to be deleted.
oldSectionName
Name of the old section.
newSectionName
Name of the new section.

Glossary Item Box

Initializes a new instance of the LayoutChangingArgs class with specified details about the layout change.

Initializes a new instance of the LayoutChangingArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As LayoutChangeType, _
   ByVal selectionType As SelectionType, _
   ByVal name As String, _
   ByVal newValue As Object, _
   ByVal oldValue As Object, _
   ByVal oldSectionName As String, _
   ByVal newSectionName As String _
)
C#
public LayoutChangingArgs(
   LayoutChangeType type,
   SelectionType selectionType,
   string name,
   object newValue,
   object oldValue,
   string oldSectionName,
   string newSectionName
)

Parameters

type
The type of layout change that is to occur.
selectionType
Specifies the selection type involved in the layout change, categorized by the SelectionType enumeration.
name
The array of names of the controls or sections to be updated or changed.
newValue
The array of controls or sections to be added.
oldValue
The array of controls or sections to be deleted.
oldSectionName
Name of the old section.
newSectionName
Name of the new section.

Remarks

In the type parameter, any of the enumerated values except ReportClear, ReportLoad, and ReportSize may be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members
LayoutChangeType Enumeration


LayoutChangingArgs Class Properties

[image]
ActiveReports 19 .NET Edition
LayoutChangingArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

For a list of all members of this type, see LayoutChangingArgs members.

Public Properties

 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top

See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


AllowChange Property

Collapse All Expand All Language Filter: All Language Filter: Multiple Language Filter: Visual Basic (Declaration) Language Filter: C#

ActiveReports 19 .NET Edition

AllowChange Property

See Also
Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : AllowChange Property

Visual Basic (Declaration)
C#

Glossary Item Box

Sets or returns a value indicating whether to allow the change.
Syntax

Visual Basic (Declaration)
Public Property AllowChange As Boolean
C#
public bool AllowChange {get; set;}
Property Value
Boolean.

Remarks

The default value of this property is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference
LayoutChangingArgs Class
LayoutChangingArgs Members


ReportNameChangedEventArgs Class

[image]
ActiveReports 19 .NET Edition
ReportNameChangedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportNameChangedEventArgs Class

Glossary Item Box

Represents the arguments for the Designer.ReportNameChanged event raised when the report name changes.

Object Model

ReportNameChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportNameChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class ReportNameChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ReportNameChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNameChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ReportNameChangedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
ReportNameChangedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportNameChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ReportNameChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ReportNameChangedEventArgs Constructor | Initializes a new instance of the ReportNameChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ReportName | Gets the name of the report.
Top

See Also

Reference

ReportNameChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ReportNameChangedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ReportNameChangedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportNameChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ReportNameChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ReportName | Gets the name of the report.
Top

See Also

Reference

ReportNameChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Selection Class

[image]
ActiveReports 19 .NET Edition
Selection Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

Indicates the currently selected items in the report layout.

Object Model

Selection Class

Syntax

Visual Basic (Declaration)
Public Class Selection
C#
public class Selection

Remarks

This class provides functionality to manage the selection of components in the designer. It allows querying the current selection, changing the selection, and listening for selection changes. The selection can include controls, sections, or other design-time components. This class is particularly useful for extending the designer's functionality or integrating with other parts of the application that need to react to changes in the designer's selection state.

Example

C# Copy Code
// cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed

private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
Visual Basic Copy Code
'cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.Selection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Members
GrapeCity.ActiveReports.Design Namespace


Selection Class Members

[image]
ActiveReports 19 .NET Edition
Selection Class Members
See Also Properties Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

The following tables list the members exposed by Selection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Selection Class Methods

[image]
ActiveReports 19 .NET Edition
Selection Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Selection Class Properties

[image]
ActiveReports 19 .NET Edition
Selection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Class

[image]
ActiveReports 19 .NET Edition
ServerConnectionChangedEventArgs Class
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

Provides data for the ServerConnectionChanged event.

Object Model

ServerConnectionChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ServerConnectionChangedEventArgs
   Inherits System.EventArgs
C#
public class ServerConnectionChangedEventArgs : System.EventArgs

Remarks

This class contains information related to changes in the server connection status. It is used by the ServerConnectionChanged event to convey the new connection state and the server URL to event handlers. This allows subscribers to react appropriately to changes in server connectivity, such as updating UI elements or handling disconnections.

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ServerConnectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Class Members

[image]
ActiveReports 19 .NET Edition
ServerConnectionChangedEventArgs Class Members
See Also Properties

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ServerConnectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ServerConnectionChangedEventArgs Constructor | Initializes a new instance of the ServerConnectionChangedEventArgs class with specified connection state and server URL.
Top

Public Properties

 | Name | Description
Public Property | Connected | Gets a value indicating whether the connection to the server is established.
Public Property | ServerUrl | Gets a value representing the URL of the server to which the connection status has changed.
Top

See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Class Properties

[image]
ActiveReports 19 .NET Edition
ServerConnectionChangedEventArgs Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ServerConnectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Connected | Gets a value indicating whether the connection to the server is established.
Public Property | ServerUrl | Gets a value representing the URL of the server to which the connection status has changed.
Top

See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class

[image]
ActiveReports 19 .NET Edition
UndoManager Class
Members Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

The UndoManager class allows users to undo and redo changes.

Object Model

UndoManager Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UndoManager
C#
public sealed class UndoManager

Remarks

The UndoManager class encapsulates the functionality required to manage a history of operations performed in the ActiveReports designer, allowing users to undo and redo actions. This class interacts with an underlying undo engine to track changes and manage the undo/redo stack.

It provides methods to perform undo and redo operations, query the count of operations available for undo and redo, and retrieve descriptions of these operations for display in a user interface. The class also supports clearing the undo/redo history and raises events to notify subscribers when changes occur in the history.

This class implements the System.IDisposable interface to properly release resources associated with the undo engine.

Example

C# Copy Code
// tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
// based on the button clicked.

private void tbStandard_ButtonClick(object sender, System.Windows.Forms.ToolBarButtonClickEventArgs e)
{
    if((string)e.Button.Tag == "NewReport")  //New Report was Clicked
    {
        this.ardMain.NewReport();
        this.FillCombo();
    }
    if((string)e.Button.Tag == "Open")  //Open Report was Clicked
    {
        this.OpenReportFile();
    }
    if((string)e.Button.Tag == "Save")  //Save Report was Clicked
    {
        this.SaveReportFile();
    }
    if((string)e.Button.Tag == "SaveAs")  //SaveAs was Clicked
    {
        this.SaveAsReportFile();
    }
    if((string)e.Button.Tag == "ReportSettings")  //ReportSettings was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReportSettings);
    }
    if((string)e.Button.Tag == "Undo")  //Undo was Clicked
    {
        this.ardMain.UndoManager.Undo();
    }
    if((string)e.Button.Tag == "Cut")  //Cut was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCut);
    }
    if((string)e.Button.Tag == "Copy")  //Copy was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCopy);
    }
    if((string)e.Button.Tag == "Paste")  //Paste was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditPaste);
    }
    if((string)e.Button.Tag == "Delete")  //Delete was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditDelete);
    }
    if((string)e.Button.Tag == "ReorderGroups")  //ReorderGroups was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReorderGroups);
    }
}
Visual Basic Copy Code
'tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
'based on the button clicked.
Private Sub tbStandard_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbStandard.ButtonClick
    If CStr(e.Button.Tag) = "NewReport" Then 'New Report was Clicked
        Me.ardMain.NewReport()
        Me.FillCombo()
    End If
    If CStr(e.Button.Tag) = "Open" Then 'Open Report was Clicked
        Me.OpenReportFile()
    End If
    If CStr(e.Button.Tag) = "Save" Then 'Save Report was Clicked
        Me.SaveReportFile()
    End If
    If CStr(e.Button.Tag) = "SaveAs" Then 'SaveAs was Clicked
        Me.SaveAsReportFile()
    End If
    If CStr(e.Button.Tag) = "ReportSettings" Then 'ReportSettings was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReportSettings)
    End If
    If CStr(e.Button.Tag) = "Undo" Then 'Undo was Clicked
        Me.ardMain.UndoManager.Undo()
    End If
    If CStr(e.Button.Tag) = "Cut" Then 'Cut was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCut)
    End If
    If CStr(e.Button.Tag) = "Copy" Then 'Copy was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCopy)
    End If
    If CStr(e.Button.Tag) = "Paste" Then 'Paste was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditPaste)
    End If
    If CStr(e.Button.Tag) = "Delete" Then 'Delete was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditDelete)
    End If
    If CStr(e.Button.Tag) = "ReorderGroups" Then 'ReorderGroups was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReorderGroups)
    End If
End Sub 'tbStandard_ButtonClick

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.UndoManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Members
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Members

[image]
ActiveReports 19 .NET Edition
UndoManager Class Members
See Also Properties Methods Events

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

The following tables list the members exposed by UndoManager.

Public Properties

 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top

Public Events

 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Methods

[image]
ActiveReports 19 .NET Edition
UndoManager Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Properties

[image]
ActiveReports 19 .NET Edition
UndoManager Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Properties

 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Events

[image]
ActiveReports 19 .NET Edition
UndoManager Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Events

 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


ContextMenuTypes Enumeration

[image]
ActiveReports 19 .NET Edition
ContextMenuTypes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuTypes Enumeration

Glossary Item Box

Specifies the type of menu that will be opened for this sourceObject.

Syntax

Visual Basic (Declaration)
Public Enum ContextMenuTypes
   Inherits System.Enum
C#
public enum ContextMenuTypes : System.Enum

Members

Member | Description
Control | Control context menu.
Page | Represents a context menu for a page within the report. This menu might include options related to page setup, background, and other page-specific settings.
PageTab | Represents a context menu for the page tab area within the designer. This menu could offer options for managing report pages, such as adding or removing pages.
Report | Report object context menu.
RichText | RichText context menu.
Section | Section context menu.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ContextMenuTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.ContextMenuOpenArgs~MenuType


DebugMode Enumeration

[image]
ActiveReports 19 .NET Edition
DebugMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DebugMode Enumeration

Glossary Item Box

Specifies the type of debugging.

Syntax

Visual Basic (Declaration)
Public Enum DebugMode
   Inherits System.Enum
C#
public enum DebugMode : System.Enum

Members

Member | Description
Break | Debugging during a break in run time.
Design | Design time debugging.
Run | Run time debugging.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DebugMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerAction Enumeration

[image]
ActiveReports 19 .NET Edition
DesignerAction Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerAction Enumeration

Glossary Item Box

Enumerates the available designer commands (actions) that can be executed within the ActiveReports designer environment.

Syntax

Visual Basic (Declaration)
Public Enum DesignerAction
   Inherits System.Enum
C#
public enum DesignerAction : System.Enum

Members

Member | Description
AddLayer | Adds and activates new layer.
BackColorDlg | Opens the back color editor.
BorderBottom | Sets bottom border.
BorderLeft | Sets left border.
BorderRight | Sets right border.
BordersAll | Sets all borders.
BordersNone | Sets no borders.
BorderTop | Sets top border.
ConvertToMaster | Converts the regular RDL report to the RDL Master report.
ConvertToMultiSection | Represents the command to convert the current report to a multi-section report.
DataSourceSetup | View: Data Source setup.
DeleteLayer | Removes active layer.
EditCopy | Edit: Copy.
EditCut | Edit: Cut.
EditDelete | Edit: Delete.
EditDesigner | View report Designer tab.
EditOleObject | Edit: Ole object.
EditPaste | Edit: Paste.
EditPreview | View report Preview tab.
EditRedo | Edit: Redo.
EditScript | View: Script code editor.
EditUndo | Edit: Undo.
EnableChartWizard | Enable the chart wizard.
FileOpen | File: Open.
FileSave | File: Save.
ForeColorDlg | Opens the dialog for setting the foreground color for a control.
FormatAlignBottom | Format: Align control bottom.
FormatAlignCenter | Format: Align control center.
FormatAlignLeft | Format: Align control left.
FormatAlignMiddle | Format: Align control middle.
FormatAlignRight | Format: Align control right.
FormatAlignToGrid | Format: Align controls to grid.
FormatAlignTop | Format: Align control top.
FormatBackColor | Format: Background color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatBorder | Format: Border.
FormatBringToFront | Brings a control to the front of the z-order.
FormatCenterHorizontally | Format: Center control horizontally.
FormatCenterVertically | Format: Center control vertically.
FormatFontBold | Format: Bold. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontItalic | Format: Italic. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontName | Format: Font name. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontSize | Format: Font size. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontUnderline | Format: Underline. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatForeColor | Format: Foreground color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineColor | Format: Line color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineStyle | Format: Line style. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLockControls | Format: Lock control size and position.
FormatOrderBringToFront | Format: Bring control to the foreground.
FormatOrderSendToBack | Format: Send control to the background.
FormatRTFBullets | Format: Set RTF bullet style.
FormatRTFIndent | Format: Indent RTF text.
FormatRTFOutdent | Format: Outdent RTF text.
FormatSendToBack | Sends a control to the back of the z-order.
FormatSizeBoth | Format: Size controls to the same width and height.
FormatSizeSameHeight | Format: Size controls to the same height.
FormatSizeSameWidth | Format: Size controls to the same width.
FormatSizeToGrid | Format: Make control sizes correspond to grid marks.
FormatSpaceDecreaseHorizontal | Format: Decrease horizontal spacing.
FormatSpaceDecreaseVertical | Format: Decrease vertical spacing.
FormatSpaceEquallyHorizontal | Format: Space horizontal controls evenly.
FormatSpaceEquallyVertical | Format: Space vertical controls evenly.
FormatSpaceIncreaseHorizontal | Format: Increase horizontal spacing.
FormatSpaceIncreaseVertical | Format: Increase vertical spacing.
FormatSpaceRemoveHorizontal | Format: Remove horizontal spacing.
FormatSpaceRemoveVertical | Format: Remove vertical spacing.
FormatStyle | Format: Style.
FormatTextAlignBottom | Format : Align text bottom
FormatTextAlignCenter | Format: Align text center.
FormatTextAlignJustify | Format: Justify text.
FormatTextAlignLeft | Format: Align text left.
FormatTextAlignMiddle | Format: Align text middle.
FormatTextAlignRight | Format: Align text right.
FormatTextAlignTop | Format: Align text top
GridMode | Switches the grid mode.
InsertGroupHF | Edit: Insert a Group Header/Footer section pair.
InsertPageHF | Edit: Insert a Page Header/Footer section pair.
InsertReportHF | Edit: Insert a Report Header/Footer section pair.
InsertRTFField | Edit: Insert an RTF Field.
LayerBringToFront | Brings all layers of active layer to the foreground.
LayerSendToBack | Send all controls of active layer to the background.
LayerSetActive | Sets active layer by name.
MouseModePan | Sets the pan mouse mode.
MouseModeSelect | Sets the selection mouse mode
NewReport | Displays the new report dialog.
OpenChartCustomize | Represents the command to open the chart customization dialog in the designer.
OpenChartWizard | Represents the command to open the chart wizard dialog in the designer.
OpenDataRegionWizard | Represents the command to open the data region wizard dialog in the designer.
OpenOutputFormatDialog | Open the OutputFormat dialog.
OpenTableWizard | Represents the command to open the table wizard dialog in the designer.
OpenTablixWizard | Represents the command to open the tablix wizard dialog in the designer.
PageFooter | Adds or removes the page footer of the RDL report.
PageHeader | Adds or removes the page header of the RDL report.
ReorderGroups | Edit: Reorder Groups.
ReportImages | Displays the page report images dialog.
ReportParams | Displays the page report parameters dialog.
ReportParts | Represents the command to open the report parts dialog in the designer.
ReportProperties | Displays the page report properties dialog.
ReportSection | Represents the command to insert or edit a report section in the designer.
ReportSettings | File: Report Settings.
ReportSlicers | Represents the command to open the report slicers dialog in the designer.
SelectAll | Selects all the report controls.
SetMasterReport | Sets the master report of the RDL report.
ToggleDimensionLines | Turns on/off the dimensions helper lines.
ToggleSnapToGrid | View: Snap to grid instead of using snap lines.
ToggleSnapToLines | View: Use Snap Lines instead of snap to grid.
ToggleViewGrid | View: Grid.
ZoomActual | Resets the zoom.
ZoomIn | Zooms the report design surface in.
ZoomOut | Zooms the report design surface out.
ZoomValue | Sets the zoom value of the report design surface.

Remarks

The DesignerAction enumeration provides a comprehensive list of actions that can be performed by the user or programmatically within the ActiveReports designer. These actions cover a wide range of functionalities, including file operations, editing, formatting, alignment, and more, to facilitate a rich design experience.

Actions include operations like opening and saving files, cutting, copying, pasting, undoing, redoing, and deleting elements, as well as more specific design tasks such as aligning objects, setting font properties, managing borders, and working with data sources.

This enumeration allows for the implementation of a dynamic and user-friendly interface in the ActiveReports designer, enabling users to efficiently create and modify reports.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerReportType Enumeration

[image]
ActiveReports 19 .NET Edition
DesignerReportType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerReportType Enumeration

Glossary Item Box

Represents the types of reports that can be created or edited within the ActiveReports designer.

Syntax

Visual Basic (Declaration)
Public Enum DesignerReportType
   Inherits System.Enum
C#
public enum DesignerReportType : System.Enum

Members

Member | Description
Page | Specifies page report type.
Rdl | Represents an RDLX report type. This type is obsolete and should not be used in new development.
RdlDashboard | Represents an RDLX dashboard report type, designed for dashboard layouts.
RdlMultiSection | Represents an RDLX report type with support for multiple sections.
Section | Specifies section report type.

Remarks

The DesignerReportType enumeration provides a way to specify the type of report being worked on in the ActiveReports designer. This allows for the customization and functionality of the designer to be tailored to the specific type of report being edited.

The enumeration includes:

  • Section for section-based reports,
  • Page for page-based reports,
  • Rdl for RDLX reports, which is now obsolete,
  • RdlMultiSection for RDLX reports with multiple sections, and
  • RdlDashboard for RDLX dashboard reports.

Note: The Rdl type is marked as obsolete and should not be used in new development. It will be removed in a future release.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerReportType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerTab Enumeration

[image]
ActiveReports 19 .NET Edition
DesignerTab Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTab Enumeration

Glossary Item Box

Lists the available designer tab options.

Syntax

Visual Basic (Declaration)
Public Enum DesignerTab
   Inherits System.Enum
C#
public enum DesignerTab : System.Enum

Members

Member | Description
Designer | Designer tab.
Preview | Preview tab.
Script | Script tab.

Remarks

This enumeration defines the different tabs that can be selected within the ActiveReports designer interface. Each member represents a specific view or functionality provided by the designer, allowing users to switch between designing, scripting, and previewing reports.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerToolStrips Enumeration

[image]
ActiveReports 19 .NET Edition
DesignerToolStrips Enumeration
Example See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerToolStrips Enumeration

Glossary Item Box

Enumeration of the types of tool strips to use with the designer.

Syntax

Visual Basic (Declaration)
Public Enum DesignerToolStrips
   Inherits System.Enum
C#
public enum DesignerToolStrips : System.Enum

Members

Member | Description
All | Adds all of the available tool strips.
Borders | The toolstrip contains the border editors.
Edit | The Edit tool strip includes these tools: Cut, Copy, Paste, and Delete.
Format | The Format tool strip includes these tools: Font Name, Font Size, Bold, Italic, Underline, Fore Color, Back Color, Align Left, Align Center, Align Right, Align Justify, Indent and Outdent.
Layout | The Layout tool strip includes these tools: Align to Grid, Align Lefts, Align Centers, Align Rights, Align Tops, Align Middles, Align Bottoms, Bring to Front, and Send to Back.
Menu | Adds the menu tool strip, which includes the File and Edit menus. The File menu includes these commands: New, Open, Save, and Export. The Edit menu includes these commands: Undo, Redo, Cut, Copy, Paste, Delete, and Select All.
Report | The Report tool strip includes these tools: New, Open, and Save.
Undo | The Undo tool strip includes these tools: Undo and Redo.
Zoom | The Zoom tool strip includes these tools: Zoom Out, Zoom In, Zoom %, and Actual Size.

Example

Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
C# Copy Code
private void designer1_Load(object sender, EventArgs e)
        {
            ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
            ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
            ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
            ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
            ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
            ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
            ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
            this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
            this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
            this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
            this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
            this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
            this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
            this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
        }

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerToolStrips

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
CreateToolStrips Method


DesignMode Enumeration

[image]
ActiveReports 19 .NET Edition
DesignMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignMode Enumeration

Glossary Item Box

Represents the different design modes available in the Page Report Designer.

Syntax

Visual Basic (Declaration)
Public Enum DesignMode
   Inherits System.Enum
C#
public enum DesignMode : System.Enum

Members

Member | Description
Dashboard | Represents the dashboard design mode.
MultiSection | Represents the multi-section design mode.
Standard | Represents the standard design mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ExitType Enumeration

[image]
ActiveReports 19 .NET Edition
ExitType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ExitType Enumeration

Glossary Item Box

Specifies the action to perform when the user exits edit mode.

Syntax

Visual Basic (Declaration)
Public Enum ExitType
   Inherits System.Enum
C#
public enum ExitType : System.Enum

Members

Member | Description
Cancel | Restore the previous state of the control.
Save | Save any changes made to the control during edit mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ExitType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


GridMode Enumeration

[image]
ActiveReports 19 .NET Edition
GridMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : GridMode Enumeration

Glossary Item Box

Specifies the type of the grid to draw in the designer surface.

Syntax

Visual Basic (Declaration)
Public Enum GridMode
   Inherits System.Enum
C#
public enum GridMode : System.Enum

Members

Member | Description
Dots | Specifies the dots grid type.
Lines | Specifies the lines grid type.

Remarks

This enumeration specifies the visual representation of the grid in the ActiveReports designer. The grid helps in aligning report controls and can be displayed either as dots or lines, depending on the user's preference.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.GridMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


LayoutChangeType Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutChangeType Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangeType Enumeration

Glossary Item Box

Enumeration of change settings for the report layout.

Syntax

Visual Basic (Declaration)
Public Enum LayoutChangeType
   Inherits System.Enum
C#
public enum LayoutChangeType : System.Enum

Members

Member | Description
ControlAdd | A control has been added.
ControlDelete | A control has been deleted.
ControlMove | A control has been moved.
ControlSize | The size of a control has changed.
ControlZOrder | A control's ZOrder has been changed.
ReportClear | The report has been cleared.
ReportLoad | A report has been loaded.
ReportSize | A report's size has changed.
SectionAdd | A section has been added.
SectionDelete | A section has been deleted.
SectionMove | A section has been moved.
SectionSize | The size of a section has changed.

Remarks

This enumeration is used to categorize the various types of layout modifications that can be made to controls, sections, and the report itself within the designer. It is utilized by events and methods that deal with layout changes to provide detailed information about the nature of the change.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutChangeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.LayoutChangedArgs


LayoutMode Enumeration

[image]
ActiveReports 19 .NET Edition
LayoutMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutMode Enumeration

Glossary Item Box

Enumeration of modes for laying out controls on the report designer.

Syntax

Visual Basic (Declaration)
Public Enum LayoutMode
   Inherits System.Enum
C#
public enum LayoutMode : System.Enum

Members

Member | Description
DimHelperLines | Specifies dimensions helper line layout mode.
None | Allow free movement of controls.
SnapGrid | Snap controls to the grid.
SnapLines | Snap controls to lines showing alignment to other controls.

Remarks

The LayoutMode enumeration allows for the customization of the design surface behavior in the ActiveReports designer. Users can enable or combine different layout modes to facilitate precise placement and alignment of report elements.

Available modes include:

  • None for no snapping or alignment aids,
  • SnapGrid to enable snapping to a grid pattern,
  • SnapLines to enable snapping to alignment lines based on the positions of other elements,
  • DimHelperLines to make helper lines less prominent, aiding in design without distraction.

This enumeration supports a bitwise combination of its member values, allowing multiple layout modes to be active simultaneously for enhanced design flexibility.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
LayoutMode Property


MeasurementUnits Enumeration

[image]
ActiveReports 19 .NET Edition
MeasurementUnits Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : MeasurementUnits Enumeration

Glossary Item Box

Specifies the ruler measurement units.

Syntax

Visual Basic (Declaration)
Public Enum MeasurementUnits
   Inherits System.Enum
C#
public enum MeasurementUnits : System.Enum

Members

Member | Description
Inches | Inches.
Metric | Centimeters.
Point | Points.
System | Unit specified in the system.

Remarks

The MeasurementUnits enumeration provides options for setting the measurement units in the ActiveReports designer. This allows users to work in their preferred unit of measurement, enhancing usability and precision in report design.

Available units include:

  • Inches for measurements in inches,
  • Metric for measurements in millimeters,
  • System for using the system's default measurement unit,
  • Point for measurements in points (1/72 of an inch).

This enumeration allows for flexible configuration of measurement units, catering to various regional preferences and design requirements.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MeasurementUnits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
GrapeCity.ActiveReports.Design.Win~GrapeCity.ActiveReports.Design.Designer~DesignerUnits


MouseMode Enumeration

[image]
ActiveReports 19 .NET Edition
MouseMode Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : MouseMode Enumeration

Glossary Item Box

Available designer MouseMode types.

Syntax

Visual Basic (Declaration)
Public Enum MouseMode
   Inherits System.Enum
C#
public enum MouseMode : System.Enum

Members

Member | Description
Pan | Pan Mode.
Select | Select Mode.

Remarks

This enumeration allows for the specification of how mouse actions are interpreted in the designer environment. It supports modes for selecting components and panning across the design surface, providing flexibility in user interaction.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MouseMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


PageReportDesignerActions Enumeration

[image]
ActiveReports 19 .NET Edition
PageReportDesignerActions Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : PageReportDesignerActions Enumeration

Glossary Item Box

Represents the set of actions that can be performed on pages within the Page Report Designer.

Syntax

Visual Basic (Declaration)
Public Enum PageReportDesignerActions
   Inherits System.Enum
C#
public enum PageReportDesignerActions : System.Enum

Members

Member | Description
AddPage | Represents the action of adding a new page to the report.
All | Represents the state where all actions related to page manipulation are enabled.
DeletePage | Represents the action of deleting existing pages from the report.
DuplicatePage | Represents the action of duplicating existing pages in the report.
InsertPage | Represents the action of inserting new pages at specific positions in the report.
None | Represents the state where no actions related to page manipulation are enabled.
RearrangePage | Represents the action of rearranging the order of pages in the report.

Remarks

This enumeration uses the System.FlagsAttribute to allow a bitwise combination of its member values. It controls the availability of certain actions in the Page Report Designer's tab control, such as adding, deleting, duplicating, inserting, and rearranging pages. This enables fine-grained control over the user's ability to modify the report's structure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.PageReportDesignerActions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ReportExplorerEnabledNodes Enumeration

[image]
ActiveReports 19 .NET Edition
ReportExplorerEnabledNodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportExplorerEnabledNodes Enumeration

Glossary Item Box

Represents the modifiability of nodes within the Report Explorer in ActiveReports.

Syntax

Visual Basic (Declaration)
Public Enum ReportExplorerEnabledNodes
   Inherits System.Enum
C#
public enum ReportExplorerEnabledNodes : System.Enum

Members

Member | Description
All | Represents the ability to modify all supported node types.
DataSets | Represents the ability to modify data sets.
DataSources | Represents the ability to modify data sources.
None | Represents the state where no nodes can be modified.
Parameters | Represents the ability to modify report parameters.

Remarks

This enumeration is used to specify which nodes within the Report Explorer can be modified. It allows for the configuration of the Report Explorer to be more dynamic and adaptable to different reporting needs, by enabling or disabling the modification of parameters, data sources, and data sets.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ReportExplorerEnabledNodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ReportExplorerNodes Enumeration

[image]
ActiveReports 19 .NET Edition
ReportExplorerNodes Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportExplorerNodes Enumeration

Glossary Item Box

Represents the visibility options for nodes within the Report Explorer.

Syntax

Visual Basic (Declaration)
Public Enum ReportExplorerNodes
   Inherits System.Enum
C#
public enum ReportExplorerNodes : System.Enum

Members

Member | Description
All | Represents the state where all available nodes are displayed within the Report Explorer.
CommonValues | Represents the state where the nodes related to common values used in the report are displayed within the Report Explorer.
DataSourceAndFields | Represents the state where the nodes related to data sources and their fields are displayed within the Report Explorer.
None | Represents the state where no nodes are displayed within the Report Explorer.
Parameters | Represents the state where the nodes related to report parameters are displayed within the Report Explorer.
Settings | Represents the state where the nodes related to report settings are displayed within the Report Explorer.

Remarks

This enumeration allows for the customization of the Report Explorer by controlling the visibility of various node types. It supports granular visibility options, including data sources, fields, parameters, settings, and common values, enabling a tailored experience based on the user's needs.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ReportExplorerNodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ToolPanelButton Enumeration

[image]
ActiveReports 19 .NET Edition
ToolPanelButton Enumeration
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ToolPanelButton Enumeration

Glossary Item Box

Controls the visibility of ToolPanelButton controls on the Designer.

Syntax

Visual Basic (Declaration)
Public Enum ToolPanelButton
   Inherits System.Enum
C#
public enum ToolPanelButton : System.Enum

Members

Member | Description
All | Show or hide all the available buttons
DimensionLines | Show or hide the DimensionLines button
GridMode | Show or hide the GridMode button
MouseMode | Show or hide the MouseMode button
None | Displays no button
SnapGrid | Show or hide the SnapGrid button
SnapLines | Show or hide the SnapLines button
ZoomSlider | Show or hide the ZoomSlider button

Remarks

Use this enumeration to configure which tool panel buttons are visible in the ActiveReports designer. Each flag represents a specific button on the tool panel, allowing for granular control over the user interface. The All flag is provided for convenience, enabling or disabling all tool panel buttons with a single assignment.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ToolPanelButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface

[image]
ActiveReports 19 .NET Edition
IVsPackageIntegration Interface
Members See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

Provides an interface for the IVsPackageIntegration service.

Syntax

Visual Basic (Declaration)
Public Interface IVsPackageIntegration
C#
public interface IVsPackageIntegration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Members
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Members

[image]
ActiveReports 19 .NET Edition
IVsPackageIntegration Interface Members
See Also Methods

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

The following tables list the members exposed by IVsPackageIntegration.

Public Methods

 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top

See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Methods

[image]
ActiveReports 19 .NET Edition
IVsPackageIntegration Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

For a list of all members of this type, see IVsPackageIntegration members.

Public Methods

 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top

See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


GetStyleSheets Method

[image]
ActiveReports 19 .NET Edition
GetStyleSheets Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : GetStyleSheets Method

Glossary Item Box

Returns the Stylesheets.

Syntax

Visual Basic (Declaration)
Function GetStyleSheets() As String()
C#
string[] GetStyleSheets()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnDebugModeChanged Method

[image]
ActiveReports 19 .NET Edition
OnDebugModeChanged Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnDebugModeChanged Method

dbgmodeNew
A value from the DebugMode enumeration, indicating the new debugger mode.

Glossary Item Box

Specifies the function that is called if the debugging mode changes.

Syntax

Visual Basic (Declaration)
Sub OnDebugModeChanged( _
   ByVal dbgmodeNew As DebugMode _
)
C#
void OnDebugModeChanged(
   DebugMode dbgmodeNew
)

Parameters

dbgmodeNew
A value from the DebugMode enumeration, indicating the new debugger mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnSolutionBuilding Method

[image]
ActiveReports 19 .NET Edition
OnSolutionBuilding Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnSolutionBuilding Method

Glossary Item Box

Specifies the function that is called before any solution build action is initialized.

Syntax

Visual Basic (Declaration)
Sub OnSolutionBuilding()
C#
void OnSolutionBuilding()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


Troubleshooting

Troubleshooting

Glossary Item Box

Show All Show All
Hide All Hide All

If you run into an issue while using ActiveReports, you will probably find the solution within this section. Click any short description below to drop down the symptoms, cause, and solution. Or click a link to another section of the troubleshooting guide.

General Troubleshooting

Show The missing Microsoft.SqlServer.Types assembly may cause the query execution failure in VQD

Symptoms: The missing Microsoft.SqlServer.Types assembly may cause the invalid query error at executing a dataset in the Visual Query Designer.

Cause: The missing Microsoft.SqlServer.Types assembly is required to execute the query.

Solution: To resolve this problem, install the Microsoft.SqlServer.Types assembly manually.

Show Compilation Error related to conflicting assembly/package versions

Symptoms: Errors like - could not load file or assembly or one of its dependencies, or Found conflicts between different versions of the same dependent assembly appear on compiling.

Cause: Due to inability of Visual Studio to resolve assembly versions on its own.

Solution: To resolve this problem, add a binding redirect in your config file. You can quickly add a binding redirect by double-clicking on the error in Visual Studio.

Example to add bindingRedirect to config file Copy Code
<dependentAssembly>
  <assemblyIdentity name="someAssembly"
    publicKeyToken="tokenName"
    culture="neutral" />
  <bindingRedirect oldVersion="7.0.0.0" newVersion="8.0.0.0" />
</dependentAssembly>

Show Error appears on exporting Page/RDLX reports from JSViewer run on ASP.NET Core MVC application

Symptoms: "Export report error" appears on exporting Page/RDLX Report from JSViewer when run through ASP.NET Core MVC applications.

Cause: ASP.NET Core MVC has undergone some changes that disable the synchronous server operations. See Microsoft documentation for more information.

Solution: Add following content in Startup.cs to turn on the synchronous operations.

Startup.cs Copy Code
services.Configure<IISServerOptions>(options =>
{
    options.AllowSynchronousIO = true;
});

Show Error appears on using parameterized queries with OLE DB provider in .NET core applications

Symptoms: Error is thrown on using parameterized queries with OLE DB provider in .NET Core applications.

Cause: The number of query parameters specified in the dataset do not match the parameters used in the SQL query for dataset. Note that this works perfectly well for OLE DB provider from Full .NET Framework.

Solution: The number of query parameters specified in the SQL query should be same as number of query parameters in dataset.

Show Report menu does not appear in the main menu of Visual Studio 2019 or Visual Studio 2022

Symptoms: When a report is opened in Visual Studio 2019 or Visual Studio 2022, Report menu does not appear in the main menu.

Cause: Due to new behavior relating to extensions, Report menu is removed as main menu.

Solution: Go to Extensions menu. You can see that the Report menu is available as submenu.

Show References missing from Visual Studio Add Reference dialog

Symptoms: When you try to add references to your project, only a few of the ActiveReports references are available.

Cause: The project's target framework is set to an old version of the .NET framework that does not support the new assemblies.

Solution:

  1. In the Solution Explorer, right click the project and choose Properties.
  2. On the Application tab in C# projects (or the Compile tab, then the Advanced Compile Options button in Visual Basic projects), drop down the Target framework box and select .NET Framework 4.7.2.

Show Errors after installing a new build

Symptoms: When you open a project created with a previous build of ActiveReports after installing a new build, there are errors related to being unable to find the previous build.

Cause: Visual Studio has a property on references called Specific Version. If this property is set to True, the project looks for the specific version that you had installed when you created the report, and throws errors when it cannot find it.

Solution: For each of the ActiveReports references in the Solution Explorer, select the reference and change the Specific Version property to False in the Properties Panel.

Show An Exception occurs on previewing reports connecting Microsoft Access OLE DB provider in a 64-bit system

Symptoms: "System.InvalidOperationException: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine." occurs on previewing reports connecting to Microsoft.Jet.OLEDB.4.0 provider on a 64-bit operating system.

Cause: The Microsoft Access OLE DB provider, Microsoft.Jet.OLEDB.4.0, is not compatible with 64 bit, so it fails on a 64-bit operating systems.

Solution: To avoid this, you have two options.

1. (Preferred) Change the OLE DB Provider to Microsoft.ACE.OLEDB.12.0.

Note that both 32-bit and 64-bit version of Microsoft.ACE.OLEDB.12.0 should be available in your machine.

2. Change the project settings to use only 32 bit.

  1. With the project open in Visual Studio, from the Project menu, select Project Properties.
  2. In the page that appears, select the Compile tab in a VB project, or the Build tab in a C# project.
  3. Scroll to the bottom of the page and click the Advanced Compile Options button in VB, or skip this step in C#.
  4. Drop down the Target CPU list in VB, or Platform target in C#, (set to use AnyCPU by default) and select x86.
  5. Click OK to save the changes, or skip this step in C#.

Show The printing thread dies before the report finishes printing

Symptoms: The printing thread dies before the report is printed.

Cause: If printing is done in a separate thread and the application is shut down right after the print call, the separate thread dies before the report is printed.

Solution: Set the usePrintingThread parameter of the Print() method to False to keep the printing on the same thread. This applies to all Page reports, RDLX reports and Section Reports.

  1. In the project where you call the Print method, add a reference to the MESCIUS.ActiveReports.Viewer.Win package.
  2. At the top of the code file where you call the Print method, add a using directive (Imports for VB) for GrapeCity.ActiveReports.
  3. Call the Print method with the usePrintingThread parameter (the third parameter) set to false with code like the following.
C# code. Copy Code
document.Print(false, false, false);
Visual Basic code. Copy Code
document.Print(False, False, False)

Show Exception thrown when using Viewer.Print to print a report

Symptoms: An exception is thrown when the Viewer.Print method is used to print a report.

Cause: Print method was called before the page was loaded completely.

Solution: Use the Viewer.Print method in the LoadCompleted event.

Show Code generation error appears with code-based report applications

Symptoms: The Code generation error appears when working with a code-based application in Visual Studio.

Cause: This is because of the cache problems in Visual Studio 2019 and Visual Studio 2022.

Solution: Use one of the solutions described below.

  • Clean Visual Studio cache.
    • Remove the folder C:\Users\[user name]\AppData\Local\Microsoft\VisualStudio\[VS version dir]\ProjectAssemblies.
  • Reset Visual Studio settings. For example, in Visual Studio,
    1. Open cmd.
    2. Switch to C:\Program Files (x86)\Microsoft Visual Studio\2019 or 2022\Community\Common7\IDE folder.
    3. Run devenv/resetsettings.
    The Visual Studio settings reset may result in the loss of important data.

Show Timeout error appears on running Angular(Core) samples for WebDesigner and JSViewer with default settings

Symptoms: The timeout error sometimes appears when running the WebDesigner_Angular(Core) and JSViewer_Angular(Core) samples with default settings. See Web Samples for more information.

Cause: The connection timeout period is not sufficient and must be increased.

Solution: To increase the solution timeout period, add the following code to the Startup.cs file.

Startup.cs Copy Code
if (env.IsDevelopment())
  {
  spa.UseAngularCliServer(npmScript: "start");
  spa.Options.StartupTimeout = TimeSpan.FromSeconds(200); //timeout
  }

Show System.NotSupportedException occurs on previewing reports with scripts in Windows Forms Viewer or WPF Viewer in the .NET Core desktop applications

Symptoms: When you preview reports using Windows Forms Viewer, WPF Viewer, and Windows Designer components in .NET Core applications, the exception "System.NotSupportedException. No data is available for encoding 1252" occurs. For information on defining a custom encoding, see the documentation for the Encoding.RegisterProvider method.

Cause: You need to register encodings before using .NET Core applications with Windows Forms Viewer, WPF Viewer, and Windows Designer components.

Solution: To avoid this situation, please do the following.

  1. Add the System.Text.Encoding.CodePages package from NuGet .
  2. Add Encoding.RegisterProvider to Program.cs.
    Program.cs Copy Code
    static void Main()
{
System.Text.Encoding.RegisterProvider(System.Text.CodePagesEncodingProvider.Instance);Application.EnableVisualStyles();
Application.SetCompatibleTextRenderingDefault(false);
Application.Run(new DesignerForm());
}

Show An exception appears when using a relative path in the connection string in Linux

Symptoms: When you run a project in Linux, an exception appears on rendering a report in Linux, but the same works correctly in Windows.

Cause: This may occur when the connection string uses slash other than forward '/' slash.

Solution: In the connection strings with a relative path to the reports, always use forward slash '/' for the report to render correctly across all platforms.

Show SqlException appears with the message like "The certificate chain was issued by an authority that is not trusted"

Symptoms: The SqlException with the message like "The certificate chain was issued by an authority that is not trusted" appears.

Cause: This error occurs because the default behavior of client drivers was changed. Now the new driver tries to validate the server's certificate and fails if the certificate is not installed. See The certificate chain was issued by an authority that isn't trusted for details.

Solution: Install the required certificate or use one of the following workarounds.

  1. Update the connection string. Add the TrustServerCertificate=True setting to the data source connection string.
    Example:
    “Data Source=20.186.17.78;Initial Catalog=Northwind;User ID=qatester;Password=qatesting;TrustServerCertificate=True”
  2. Rollback to the old System.Data.SqlClient
    1. Configure a required MSSQL data provider in the ActiveReports.config file.
      ActiveReports.config file Copy Code
      <Configuration>
    <Extensions>
        <Data>
            <Extension Name="MYSQL" Type="System.Data.SqlClient.SqlClientFactory, System.Data.SqlClient" DisplayName="Microsoft SQL Server" />
        </Data>
    </Extensions>
</Configuration>
    2. Reference the System.Data.SqlClient NuGet package.

Section Report Troubleshooting

Show Warning related to conflicting assemblies when working with code-based section reports

Symptoms: Visual Studio throws some warnings related to conflicting assemblies when creating projects from our code-based section report templates, or when adding code-based reports to existing projects.

  • Found conflicts between different versions of 'System.Runtime.CompilerServices.Unsafe' that could not be resolved.
  • Found conflicts between different versions of 'Microsoft.Bcl.AsyncInterfaces' that could not be resolved.

Cause: Due to dependency on different versions of VS SDK required by MESCIUS.ActiveReports.Serializer.VS2022.dll and VS2022. See about MSBuild3277 in article and discussion.

Solution:

  • In case of C# projects, add the following tag to project properties to suppress the warning:
Add following tag in .csproj Copy Code
<Project ToolsVersion="4.0" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
     ...
    <NoWarn>MSB3277</NoWarn>
     ...
  </PropertyGroup>
  • Update System.Runtime.CompilerServices.Unsafe and Microsoft.Bcl.AsyncInterfaces to version requested by Visual Studio (6.0.0).

Show Blank pages printed between pages, or a red line appears in the viewer

Symptoms: Blank pages are printed between pages of the report.

Cause: This problem occurs when the PrintWidth plus the left and right margins exceeds the paper width. For example, if the paper size were set to A4, the PrintWidth plus the left and right margins cannot exceed 8.27"; otherwise blank pages will be printed. At run time, ActiveReports marks a page overflow by displaying a red line in the viewer at the position in which the breach has occurred.

Solution: Adjust the PrintWidth in the report designer using either the property grid or by dragging the right edge of the report. Adjust page margins, height, and width either through the print properties dialog box (in the Report menu under Settings), or programmatically in the Report_Start event.

Show Copying reports results in stacked controls

Symptoms: A report file copied into a new project has all of its controls piled up at location 0, 0.

Cause: The report has become disconnected from its resource file. When you set a report"s Localizable property to True, the Size and Location properties of the report"s controls are moved to the associated *.resx file, so if you copy or move the report, you must move the *.resx file along with it.

Solution: When you copy a report"s *.vb or *.cs file from one project's App_Code folder into the App_Code folder of a new project, you need to also copy its *.resx file from the original project"s App_GlobalResources folder into the new project's App_GlobalResources folder.

Show No data appears in a report containing the OleObject control

Symptoms: No data appears in a report containing the OleObject control.

Cause: This issue occurs when the Microsoft .NET Framework 4.7.2 or above is used and the useLegacyV2RuntimeActivationPolicy attribute is not set to True.

Solution: Open the app.config file and set the useLegacyV2RuntimeActivationPolicy attribute to true.

XML code. Paste INSIDE the app.config file. Copy Code
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="MyRunTimeVersion"/>
</startup>
</configuration>

Show An error message appears in the Fields list

Symptoms: An error message is displayed in the Fields list in the Report Explorer instead of the fields.

Cause: This is an expected error if no default value is given for a parameter. If the field is a data type other than text, memo, or date/time in Access, the report still runs normally.

Solution: To display the fields in the Fields list in the Report Explorer, supply a default value for the parameter in the Properties Panel, or in the SQL query as below:

SQL Query Copy Code
<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Only the Name parameter is required. To use some, but not all, of the optional parameters, use all of the separator characters but with no text between one and the next for unused parameters. For example:

SQL Query Copy Code
<%Name | | DefaultValue | |%>

Show An unhandled exception of type "System.Data..." occurs when the report is run

Symptoms: When the report is run, an exception like the following occurs: "An unhandled exception of type "System.Data.OleDb.OleDbException" occurred in system.data.dll"

Cause: If the field is a text, memo, or date/time data type in Access, the parameter syntax requires single quotes for text or memo fields, or pound signs for date/time fields. Please note that for different data sources, these requirements may differ.

Solution: To avoid the exception when the report is run against an Access database, use pound signs for date/time values, or single quotes for string values in your SQL query, for example:

SQL Query Copy Code
#<%InvoiceDate | Choose invoice date: | 11/2/04 | D | True%>#

or

SQL Query Copy Code
"<%Country | Country: | Germany | S | True%>"

Show User is prompted for parameters for subreports even though they are supplied by the main report

Symptoms: The parameter user interface pops up at run time asking for a value even though the main report is supplying the parameter values for the subreports.

Cause: The default value of the ShowParameterUI property of the report is True.

Solution: Set the ShowParameterUI property of the report to False. This can be done in the property grid or in code in the ReportStart event.

Show The viewer shows the report on the wrong paper size

Symptoms: In the viewer, the report renders to a different paper size than the one specified.

Cause: ActiveReports polls the printer driver assigned to the report to check for clipping, margins, and paper sizes supported by the printer. If the paper size specified for the report is not supported by the printer, ActiveReports uses the printer's default paper size to render the report.

Solution: If the report is to be printed, the printer assigned to the report must support the paper size and margins. Please note that any changes to the print settings in code must be made in or before the ReportStart event. To use custom paper sizes not supported by the driver, set the PrinterName to an empty string to use the ActiveReports virtual print driver. This does not allow printing, but is recommended for reports that are only exported or viewed. This prevents ActiveReports from making a call to the default printer driver. Use the following code in the ReportStart event, or just before .Run is called.

C# code. Paste INSIDE the ReportStart event. Copy Code
this.Document.Printer.PrinterName = '';
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
Me.Document.Printer.PrinterName = ''

The PaperHeight and PaperWidth properties, which take a float value defined in inches, have no effect unless you set the PaperKind property to Custom. Here is some sample code which can be placed in the ReportStart event, or just before .Run.

C# code. Paste INSIDE the ReportStart event. Copy Code
this.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom;
this.PageSettings.PaperHeight = 2;
//sets the height to two inches
this.PageSettings.PaperWidth = 4;
//sets the width to four inches
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
Me.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom
Me.PageSettings.PaperHeight = 2
'sets the height to two inches
Me.PageSettings.PaperWidth = 4
'sets the width to four inches

Show Custom paper sizes do not work

Symptoms: Custom paper sizes do not work.

Cause: You can create more than one custom paper size, so setting only the PaperKind property is not enough to create a custom paper size.

Solution: In addition to setting the PaperKind property to Custom, you must also set the PaperName property to a unique string.

Show An exception relating to System.Data.SqlClient occurs on previewing Section Reports in Windows Forms Viewer or WPF Viewer in the .NET Core 3.1 desktop application

Symptoms: The "Could not load file or assembly 'System.Data.SqlClient" exception occurs when you preview a Section Report in the Windows Forms Viewer or WPF Viewer in the .NET Core 3.1 desktop application. This exception also occurs when you design a Section Report in the Designer in the .NET Core 3.1 desktop application.

Cause: This is a Microsoft compatibility issue.

Solution: You need to manually add the Microsoft.Windows.Compatibility NuGet package. For more information, see this article.

Page/RDLX Report Troubleshooting

Show An expression containing a numeric field name does not display any data at run time.

Symptoms: An expression containing a numeric field name does not display any data at runtime.

Cause: Visual Basic syntax does not allow an identifier that begins with a number, for example:

=Fields!2004.Value

Solution: Make the numeric field name a string, for example:

=Fields("2004").Value
or,
=Fields.Item("2004").Value

Show DataSet field in PageHeader of an RDLX report

Symptoms: Cannot set a dataset field (bound field) in the PageHeader of an RDLX report.

Cause: ActiveReports is based on the RDLX 2005 specifications, therefore, referencing datasets in the PageHeader of an RDLX report is not supported.

Solution: There is no direct way to add a DataField in a PageHeader, however, as a workaround you can create a hidden report parameter that is bound to your dataset and has the default value set to your expression. For example,

="*" & First(Fields!name.Value)

You can then use this parameter in the page header.

Alternatively, you can use a Page Report, which lets you place data fields anywhere on a page.

Show Exception thrown when using Viewer.Document property

Symptoms: An exception is raised when Viewer.Document is used with a Page Report or RDLX report.

Cause: Document property is available for Section Reports only.

Show Error when previewing the content report in Visual Studio if the master report is not added to the project

Symptoms: The "Unable to load the master report for the specified content report" error appears at previewing the content report in Visual Studio if the master report is not added to the project.

Solution: There are two options to resolve this problem.

  • On the Form.cs, add the following code inside the Form_Load event.
    Paste inside the Form_Load event Copy Code
    private void Form1_Load(object sender, EventArgs e)
{
        viewer1.LoadDocument(Application.StartupPath + @"\..\..\..\Report.rdlx");
}
  • For the other option, follow these steps:
    1. Place the master report and the content report into the same folder.
    2. In Visual Studio, open your project and under Project, select Add Existing Item... to add the master report.
    3. Go to Properties and set the Copy to Output Directory property of the master report to Copy always or Copy if newer.

WPF Viewer Troubleshooting

Show Report is not previewed properly in WPF Viewer when DPI is set to 125% or higher

Symptoms: A report is rendered on top of the WPF Viewer in the continuous mode on scrolling, when DPI is set to 125% or higher.

Cause: This is a WPF continuous mode limitation.

Solution: To resolve this problem, add the following code to the project.

Add to the Viewer.LoadCompleted event Copy Code
Viewer.LoadCompleted += (_, __) =>
{
Viewer.ViewType = GrapeCity.Viewer.Common.Model.ViewType.Continuous;
};

Show Toolbox for WPF Viewer is missing from WPF Project

Symptoms: The Toolbox for WPF Viewer does not appear in a new WPF project in Visual Studio on adding WPF package, MESCIUS.ActiveReports.Viewer.Wpf.

Cause: It is a Visual Studio limitation where XAML Hot Reload does not work correctly.

Solution: The XAML Hot Reload should be enabled. To enable the XAML Hot Reload, follow these steps.

  1. Go to Debug > Options > General.
  2. Select options Enable UI Debugging Tools for XAML and Enable XAML Hot Reload.
  3. Open MainWindow.xaml. The Toolbar should now display the WPF Viewer tab.

See Troubleshooting XAML Hot Reload for more information.

Show TargetInvocationException occurs when running the WPF browser application

Symptoms: When running the WPF browser application, the TargetInvocationException occurs.

Cause: The WPF browser application does not support Partial Trust.

Solution: Make sure that the WPF browser application uses Full Trust. To do that, in the Visual Studio Project menu, go to YourProject Properties and on the Security tab, under EnableClickOnce security settings, select the option This is a full trust application.

Show Design-time error appears on adding the WPF Viewer to the xaml page if the project is targeting .NET Core 3.1.

Symptoms: A design-time error appears on adding the WPF Viewer to the xaml page if the project is targeting .NET Core 3.1.

Cause: This is the .NET limitation.

Solution: To resolve this problem, add the Microsoft.Windows.Compatibility NuGet package to the project and then rebuild the project.

Memory Troubleshooting

Note: According to Microsoft it is not necessary to call GC.Collect and it should be avoided. However, if calling GC.Collect reduces the memory leak, then this indicates that it is not a leak after all. A leak in managed code is caused by holding a reference to an object indefinitely. If ActiveReports is holding a reference to an object, then the object cannot be collected by the garbage collector.

Symptoms: ActiveReports is consuming too much memory; CPU usage always goes to 100% when using ActiveReports.

Cause: There are several reasons why too much memory may be consumed:

Show The report is not being disposed of properly

Cause: The report is not being disposed of properly. The incorrect syntax is as follows.

C# code. Copy Code
//Incorrect!
rpt.Dispose();
rpt=null;
Visual Basic code. Copy Code
'Incorrect!
rpt.Dispose()
rpt=Nothing

Solution: The correct syntax for disposing of a Section Report is as follows.

C# code. Copy Code
//Correct!
rpt.Document.Dispose();
rpt.Dispose();
rpt=null;
Visual Basic code. Copy Code
'Correct!
rpt.Document.Dispose()
rpt.Dispose()
rpt=Nothing

Show Report never finishes processing

Cause: In some cases, very large reports can consume so much memory that the report never finishes processing. Some of the things that can cause this include:

  1. Many non-repeating images, or a high resolution repeating image
  2. Instantiating a new instance of a subreport each time the format event of a section fires
  3. Using a lot of subreports instead of grouping with joins in the SQL query
  4. Pulling in all of the data when only a few fields are needed (e.g. Select * from db instead of Select First, Last, Address from db)

Solution: In cases where the report is too large to run any other way, the CacheToDisk property may be set to True. This property should only be used when there is no other way to run the report to completion. Before resorting to this method, please see the Optimize Section Reports topic.

Show Task manager indicates the current "working set" of the process

Cause: If inflated memory usage is seen in the Task Manager it is not necessarily in use by the code. Task manager indicates the current "working set" of the process and, upon request, other processes can gain access to that memory. It is managed by the Operating System.

Solution: For an example of some working set behavior anomalies (which are considered normal), create a WinForms application and run it. Look in Task Manager at the working set for that process (it should be several megabytes), then minimize and maximize the form and notice that the working set reclaims to <1MB. Obviously, the code was not using all that memory even though Task Manager showed that it was allocated to that process. Similarly, you'll see ASP.NET and other managed service processes continue to gradually grow their working set even though the managed code in that process is not using all of it. To see whether this is the case, try using the two lines of code below in a button Click event after running the project.

System.Diagnostics.Process pc = System.Diagnostics.Process.GetCurrentProcess();
pc.MaxWorkingSet = pc.MinWorkingSet;

If that reclaims the memory then the Operating System trimmed the working set down to the minimum amount necessary and this indicates that the extra memory was not actually in use.

Web Applications Troubleshooting

Show Some locale issues occur when generating reports on Linux Docker

Symptoms: When creating or using Docker images, locale-related problems such as missing fonts are discovered.

Cause: Due to missing configuration or incorrectly configured locale for Linux.

Solution: To avoid this problem, the invariant mode needs to be disabled, and the locale settings should be set explicitly in the Dockerfile from which the image is built when creating Docker images.

To do this, specify the following lines explicitly :

Add after the base layer in the Dockerfile Copy Code
# Disable the invariant mode (set in base image)
ENV DOTNET_SYSTEM_GLOBALIZATION_INVARIANT=false\
    # Set the locale
    LC_ALL=en_US.UTF-8 \
    LANG=en_US.UTF-8

Show Chart and Image controls not showing in WebViewer in IIS

Symptoms: The charts and images are broken in the report preview in Web Viewer.

Cause: It is because IIS tries to search the physical files instead of handling the request in the back end.

Solution: To resolve this problem, add the following in web.config file:

Add to web.config file Copy Code
<handlers>
      <add verb="*" path="/api/reporting/*" type="System.Web.Handlers.ScriptModule" name="nostaticfile" resourceType="Unspecified" preCondition="integratedMode" />
</handlers>

This tells the IIS to redirect to our specific handler all requests which starts from "api/reporting". See WebViewer_ASP.NET_C# sample.

Show Error appears on adding MESCIUS.ActiveReports.Web.Design.VS2022 package in Visual Studio 2022

Symptoms: On installing MESCIUS.ActiveReports.Web.Design.VS2022 package, an error "Could not install this package. You are trying to install this package into a project that targets '.NETFramework=v4.7.1', but the package does not contain any assembly references or content files that are compatible with that framework."

Cause: In Visual Studio 2022, MESCIUS.ActiveReports.Web.Design.VS2022 package is not supported for .NET applications targeting .NET Framework 4.7.1 or below.

Solution: Change the target framework to .NET Framework 4.7.2, .NET Framework 4.8, or .NET Framework 4.8.1, and then try installing the package again. The package should be installed without any errors.

Show PDF opens in a new window when an application contains the WebViewer

Symptoms: When using Internet Explorer and Acrobat Reader to view a page containing a WebViewer in PDF mode, the resulting PDF always opens in a new window.

Cause: Acrobat Reader is only available in a 32-bit version. When the 64-bit version of Internet Explorer is used, it opens up an instance of the 32-bit version of Internet Explorer so that the plug-in and the PDF can load, rendering the resulting PDF in a new window.

Solution:

  • Install a PDF reader plug-in that is 64-bit compatible.
    OR
  • Use the 32-bit version of Internet Explorer.

Show PlatformNotSupportedException occurs on using WebViewer, JSViewer, and WebDesigner

Symptoms: PlatformNotSupportedException occurs in Web Applications using WebViewer, JSViewer, and WebDesigner in Classic Pipeline Mode.
Cause: The WebViewer, JSViewer, and WebDesigner are supported only in the Integrated pipeline mode.
Solution: Change the Application Pool mode as follows:

  1. Open IIS Manager.
  2. Go to Application Pools.
  3. Select the application pool where your app runs.
  4. Select Basic Settings.
  5. In the Edit Application Pool dialog, change the Managed Pipeline Mode to Integrated.

Show The "Report not found" error occurs when a report name contains special symbols

Symptoms: When you specify a report name with special symbols, e.g. webViewer.ReportName="Folder\Report.rdlx", you may get a "Report not found" error.

Cause: Additional code needs to be added to the Web.config file to have the WebViewer use report names with the corresponding folders.

Solution: Add the following code to the Web.config file.

Paste inside the Web.config file Copy Code
<system.web>
<httpRuntime requestPathInvalidCharacters="" requestValidationMode="2.0"/>
<pages validateRequest="false"/>
</system.web>

<system.webServer>
<security>
<requestFiltering allowDoubleEscaping="true"/>
</security>
</system.webServer>

Show The 'The type or namespace name 'Linq' does not exist in the namespace 'System'' error occurs when adding the WebViewer control in an ASP.NET Web Site project

Symptoms: When you add the WebViewer control in an ASP.NET Web Site project, the 'The type or namespace name 'Linq' does not exist in the namespace 'System' error occurs.

Cause: This is a known NuGet limitation.

Solution: You should install or upgrade the Microsoft.CodeDom.Providers.DotNetCompilerPlatform NuGet package.

Show "This application will be terminated because it was built without a license for PageReport" error occurs on deploying an application on Azure Functions Application.

Symptoms: When you deploy an application in an Azure Functions application, error "This application will be terminated because it was built without a license for PageReport" occurs.

Cause: This is because the application being deployed is not licensed properly.

Solution: You should follow the steps provided in the Licensing Compiled Code topic for correctly licensing the application before deploying it to the Azure Functions application.

Show The export file extension appears incorrect in Chrome while exporting using JSViewer in a reporting service hosted in an external application.

Symptoms: When using JSViewer in a reporting service hosted in an external application to export a report, the export file extension for download appears as .rdlx (in Chrome) instead of the corresponding format extension.

Cause: This issue occurs because of the restriction to access response headers when using Fetch API (which we use to download the exported file) over CORS.

Solution: You should add the following line in your CORS policy:

HttpContext.Current.Response.AddHeader("Access-Control-Expose-Headers", "Content-Disposition");

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Create Multi-Category Scatter Chart

Create Multi-Category Scatter Chart

Glossary Item Box

This walkthrough creates a Multi-Category Scatter Chart. The chart shows the relationship between the 'GDP per Capita' and 'Life Expectancy' for different continents. In a multi-category scatter chart, the data values are broken down into subcategories and are distinguished using the data points' color, shape, or both. The final chart appears like this:

Multi Category Scatter Chart

Create a Report and Bind Report to Data

In the ActiveReports Designer, create a new RDLX report and follow the New Report wizard to bind the report to data. You can also perform data binding later using the Report Data Source dialog accessed from the Report Explorer.

Connect to a Data Source

  1. In the Report Data Source dialog, select the General page and enter the name of the data source.
  2. Under Type, select 'Json Provider'.
  3. Go to the Content tab under Connection and set the type of JSON data to 'Embedded'.
  4. In the Select or type the file name or URL or enter the data to be embedded field, enter the following data:

    Show JSON Data

    Copy Code
    [
 {
   "country": "Afghanistan",
   "continent": "Asia",
   "lifeExp": 43.828,
   "gdpPercap": 974.5803384,
   "pop": 31889923
 },
 {
   "country": "Albania",
   "continent": "Europe",
   "lifeExp": 76.423,
   "gdpPercap": 5937.029526,
   "pop": 3600523
 },
 {
   "country": "Algeria",
   "continent": "Africa",
   "lifeExp": 72.301,
   "gdpPercap": 6223.367465,
   "pop": 33333216
 },
 {
   "country": "Angola",
   "continent": "Africa",
   "lifeExp": 42.731,
   "gdpPercap": 4797.231267,
   "pop": 12420476
 },
 {
   "country": "Argentina",
   "continent": "Americas",
   "lifeExp": 75.32,
   "gdpPercap": 12779.37964,
   "pop": 40301927
 },
 {
   "country": "Australia",
   "continent": "Oceania",
   "lifeExp": 81.235,
   "gdpPercap": 34435.36744,
   "pop": 20434176
 },
 {
   "country": "Austria",
   "continent": "Europe",
   "lifeExp": 79.829,
   "gdpPercap": 36126.4927,
   "pop": 8199783
 },
 {
   "country": "Bahrain",
   "continent": "Asia",
   "lifeExp": 75.635,
   "gdpPercap": 29796.04834,
   "pop": 708573
 },
 {
   "country": "Bangladesh",
   "continent": "Asia",
   "lifeExp": 64.062,
   "gdpPercap": 1391.253792,
   "pop": 150448339
 },
 {
   "country": "Belgium",
   "continent": "Europe",
   "lifeExp": 79.441,
   "gdpPercap": 33692.60508,
   "pop": 10392226
 },
 {
   "country": "Benin",
   "continent": "Africa",
   "lifeExp": 56.728,
   "gdpPercap": 1441.284873,
   "pop": 8078314
 },
 {
   "country": "Bolivia",
   "continent": "Americas",
   "lifeExp": 65.554,
   "gdpPercap": 3822.137084,
   "pop": 9119152
 },
 {
   "country": "Bosnia and Herzegovina",
   "continent": "Europe",
   "lifeExp": 74.852,
   "gdpPercap": 7446.298803,
   "pop": 4552198
 },
 {
   "country": "Botswana",
   "continent": "Africa",
   "lifeExp": 50.728,
   "gdpPercap": 12569.85177,
   "pop": 1639131
 },
 {
   "country": "Brazil",
   "continent": "Americas",
   "lifeExp": 72.39,
   "gdpPercap": 9065.800825,
   "pop": 190010647
 },
 {
   "country": "Bulgaria",
   "continent": "Europe",
   "lifeExp": 73.005,
   "gdpPercap": 10680.79282,
   "pop": 7322858
 },
 {
   "country": "Burkina Faso",
   "continent": "Africa",
   "lifeExp": 52.295,
   "gdpPercap": 1217.032994,
   "pop": 14326203
 },
 {
   "country": "Burundi",
   "continent": "Africa",
   "lifeExp": 49.58,
   "gdpPercap": 430.0706916,
   "pop": 8390505
 },
 {
   "country": "Cambodia",
   "continent": "Asia",
   "lifeExp": 59.723,
   "gdpPercap": 1713.778686,
   "pop": 14131858
 },
 {
   "country": "Cameroon",
   "continent": "Africa",
   "lifeExp": 50.43,
   "gdpPercap": 2042.09524,
   "pop": 17696293
 },
 {
   "country": "Canada",
   "continent": "Americas",
   "lifeExp": 80.653,
   "gdpPercap": 36319.23501,
   "pop": 33390141
 },
 {
   "country": "Central African Republic",
   "continent": "Africa",
   "lifeExp": 44.741,
   "gdpPercap": 706.016537,
   "pop": 4369038
 },
 {
   "country": "Chad",
   "continent": "Africa",
   "lifeExp": 50.651,
   "gdpPercap": 1704.063724,
   "pop": 10238807
 },
 {
   "country": "Chile",
   "continent": "Americas",
   "lifeExp": 78.553,
   "gdpPercap": 13171.63885,
   "pop": 16284741
 },
 {
   "country": "China",
   "continent": "Asia",
   "lifeExp": 72.961,
   "gdpPercap": 4959.114854,
   "pop": 1318683096
 },
 {
   "country": "Colombia",
   "continent": "Americas",
   "lifeExp": 72.889,
   "gdpPercap": 7006.580419,
   "pop": 44227550
 },
 {
   "country": "Comoros",
   "continent": "Africa",
   "lifeExp": 65.152,
   "gdpPercap": 986.1478792,
   "pop": 710960
 },
 {
   "country": "Congo, Dem. Rep.",
   "continent": "Africa",
   "lifeExp": 46.462,
   "gdpPercap": 277.5518587,
   "pop": 64606759
 },
 {
   "country": "Congo, Rep.",
   "continent": "Africa",
   "lifeExp": 55.322,
   "gdpPercap": 3632.557798,
   "pop": 3800610
 },
 {
   "country": "Costa Rica",
   "continent": "Americas",
   "lifeExp": 78.782,
   "gdpPercap": 9645.06142,
   "pop": 4133884
 },
 {
   "country": "Cote d'Ivoire",
   "continent": "Africa",
   "lifeExp": 48.328,
   "gdpPercap": 1544.750112,
   "pop": 18013409
 },
 {
   "country": "Croatia",
   "continent": "Europe",
   "lifeExp": 75.748,
   "gdpPercap": 14619.22272,
   "pop": 4493312
 },
 {
   "country": "Cuba",
   "continent": "Americas",
   "lifeExp": 78.273,
   "gdpPercap": 8948.102923,
   "pop": 11416987
 },
 {
   "country": "Czech Republic",
   "continent": "Europe",
   "lifeExp": 76.486,
   "gdpPercap": 22833.30851,
   "pop": 10228744
 },
 {
   "country": "Denmark",
   "continent": "Europe",
   "lifeExp": 78.332,
   "gdpPercap": 35278.41874,
   "pop": 5468120
 },
 {
   "country": "Djibouti",
   "continent": "Africa",
   "lifeExp": 54.791,
   "gdpPercap": 2082.481567,
   "pop": 496374
 },
 {
   "country": "Dominican Republic",
   "continent": "Americas",
   "lifeExp": 72.235,
   "gdpPercap": 6025.374752,
   "pop": 9319622
 },
 {
   "country": "Ecuador",
   "continent": "Americas",
   "lifeExp": 74.994,
   "gdpPercap": 6873.262326,
   "pop": 13755680
 },
 {
   "country": "Egypt",
   "continent": "Africa",
   "lifeExp": 71.338,
   "gdpPercap": 5581.180998,
   "pop": 80264543
 },
 {
   "country": "El Salvador",
   "continent": "Americas",
   "lifeExp": 71.878,
   "gdpPercap": 5728.353514,
   "pop": 6939688
 },
 {
   "country": "Equatorial Guinea",
   "continent": "Africa",
   "lifeExp": 51.579,
   "gdpPercap": 12154.08975,
   "pop": 551201
 },
 {
   "country": "Eritrea",
   "continent": "Africa",
   "lifeExp": 58.04,
   "gdpPercap": 641.3695236,
   "pop": 4906585
 },
 {
   "country": "Ethiopia",
   "continent": "Africa",
   "lifeExp": 52.947,
   "gdpPercap": 690.8055759,
   "pop": 76511887
 },
 {
   "country": "Finland",
   "continent": "Europe",
   "lifeExp": 79.313,
   "gdpPercap": 33207.0844,
   "pop": 5238460
 },
 {
   "country": "France",
   "continent": "Europe",
   "lifeExp": 80.657,
   "gdpPercap": 30470.0167,
   "pop": 61083916
 },
 {
   "country": "Gabon",
   "continent": "Africa",
   "lifeExp": 56.735,
   "gdpPercap": 13206.48452,
   "pop": 1454867
 },
 {
   "country": "Gambia",
   "continent": "Africa",
   "lifeExp": 59.448,
   "gdpPercap": 752.7497265,
   "pop": 1688359
 },
 {
   "country": "Germany",
   "continent": "Europe",
   "lifeExp": 79.406,
   "gdpPercap": 32170.37442,
   "pop": 82400996
 },
 {
   "country": "Ghana",
   "continent": "Africa",
   "lifeExp": 60.022,
   "gdpPercap": 1327.60891,
   "pop": 22873338
 },
 {
   "country": "Greece",
   "continent": "Europe",
   "lifeExp": 79.483,
   "gdpPercap": 27538.41188,
   "pop": 10706290
 },
 {
   "country": "Guatemala",
   "continent": "Americas",
   "lifeExp": 70.259,
   "gdpPercap": 5186.050003,
   "pop": 12572928
 },
 {
   "country": "Guinea",
   "continent": "Africa",
   "lifeExp": 56.007,
   "gdpPercap": 942.6542111,
   "pop": 9947814
 },
 {
   "country": "Guinea-Bissau",
   "continent": "Africa",
   "lifeExp": 46.388,
   "gdpPercap": 579.231743,
   "pop": 1472041
 },
 {
   "country": "Haiti",
   "continent": "Americas",
   "lifeExp": 60.916,
   "gdpPercap": 1201.637154,
   "pop": 8502814
 },
 {
   "country": "Honduras",
   "continent": "Americas",
   "lifeExp": 70.198,
   "gdpPercap": 3548.330846,
   "pop": 7483763
 },
 {
   "country": "Hong Kong, China",
   "continent": "Asia",
   "lifeExp": 82.208,
   "gdpPercap": 39724.97867,
   "pop": 6980412
 },
 {
   "country": "Hungary",
   "continent": "Europe",
   "lifeExp": 73.338,
   "gdpPercap": 18008.94444,
   "pop": 9956108
 },
 {
   "country": "Iceland",
   "continent": "Europe",
   "lifeExp": 81.757,
   "gdpPercap": 36180.78919,
   "pop": 301931
 },
 {
   "country": "India",
   "continent": "Asia",
   "lifeExp": 64.698,
   "gdpPercap": 2452.210407,
   "pop": 1110396331
 },
 {
   "country": "Indonesia",
   "continent": "Asia",
   "lifeExp": 70.65,
   "gdpPercap": 3540.651564,
   "pop": 223547000
 },
 {
   "country": "Iran",
   "continent": "Asia",
   "lifeExp": 70.964,
   "gdpPercap": 11605.71449,
   "pop": 69453570
 },
 {
   "country": "Iraq",
   "continent": "Asia",
   "lifeExp": 59.545,
   "gdpPercap": 4471.061906,
   "pop": 27499638
 },
 {
   "country": "Ireland",
   "continent": "Europe",
   "lifeExp": 78.885,
   "gdpPercap": 40675.99635,
   "pop": 4109086
 },
 {
   "country": "Israel",
   "continent": "Asia",
   "lifeExp": 80.745,
   "gdpPercap": 25523.2771,
   "pop": 6426679
 },
 {
   "country": "Italy",
   "continent": "Europe",
   "lifeExp": 80.546,
   "gdpPercap": 28569.7197,
   "pop": 58147733
 },
 {
   "country": "Jamaica",
   "continent": "Americas",
   "lifeExp": 72.567,
   "gdpPercap": 7320.880262,
   "pop": 2780132
 },
 {
   "country": "Japan",
   "continent": "Asia",
   "lifeExp": 82.603,
   "gdpPercap": 31656.06806,
   "pop": 127467972
 },
 {
   "country": "Jordan",
   "continent": "Asia",
   "lifeExp": 72.535,
   "gdpPercap": 4519.461171,
   "pop": 6053193
 },
 {
   "country": "Kenya",
   "continent": "Africa",
   "lifeExp": 54.11,
   "gdpPercap": 1463.249282,
   "pop": 35610177
 },
 {
   "country": "Korea, Dem. Rep.",
   "continent": "Asia",
   "lifeExp": 67.297,
   "gdpPercap": 1593.06548,
   "pop": 23301725
 },
 {
   "country": "Korea, Rep.",
   "continent": "Asia",
   "lifeExp": 78.623,
   "gdpPercap": 23348.13973,
   "pop": 49044790
 },
 {
   "country": "Kuwait",
   "continent": "Asia",
   "lifeExp": 77.588,
   "gdpPercap": 47306.98978,
   "pop": 2505559
 },
 {
   "country": "Lebanon",
   "continent": "Asia",
   "lifeExp": 71.993,
   "gdpPercap": 10461.05868,
   "pop": 3921278
 },
 {
   "country": "Lesotho",
   "continent": "Africa",
   "lifeExp": 42.592,
   "gdpPercap": 1569.331442,
   "pop": 2012649
 },
 {
   "country": "Liberia",
   "continent": "Africa",
   "lifeExp": 45.678,
   "gdpPercap": 414.5073415,
   "pop": 3193942
 },
 {
   "country": "Libya",
   "continent": "Africa",
   "lifeExp": 73.952,
   "gdpPercap": 12057.49928,
   "pop": 6036914
 },
 {
   "country": "Madagascar",
   "continent": "Africa",
   "lifeExp": 59.443,
   "gdpPercap": 1044.770126,
   "pop": 19167654
 },
 {
   "country": "Malawi",
   "continent": "Africa",
   "lifeExp": 48.303,
   "gdpPercap": 759.3499101,
   "pop": 13327079
 },
 {
   "country": "Malaysia",
   "continent": "Asia",
   "lifeExp": 74.241,
   "gdpPercap": 12451.6558,
   "pop": 24821286
 },
 {
   "country": "Mali",
   "continent": "Africa",
   "lifeExp": 54.467,
   "gdpPercap": 1042.581557,
   "pop": 12031795
 },
 {
   "country": "Mauritania",
   "continent": "Africa",
   "lifeExp": 64.164,
   "gdpPercap": 1803.151496,
   "pop": 3270065
 },
 {
   "country": "Mauritius",
   "continent": "Africa",
   "lifeExp": 72.801,
   "gdpPercap": 10956.99112,
   "pop": 1250882
 },
 {
   "country": "Mexico",
   "continent": "Americas",
   "lifeExp": 76.195,
   "gdpPercap": 11977.57496,
   "pop": 108700891
 },
 {
   "country": "Mongolia",
   "continent": "Asia",
   "lifeExp": 66.803,
   "gdpPercap": 3095.772271,
   "pop": 2874127
 },
 {
   "country": "Montenegro",
   "continent": "Europe",
   "lifeExp": 74.543,
   "gdpPercap": 9253.896111,
   "pop": 684736
 },
 {
   "country": "Morocco",
   "continent": "Africa",
   "lifeExp": 71.164,
   "gdpPercap": 3820.17523,
   "pop": 33757175
 },
 {
   "country": "Mozambique",
   "continent": "Africa",
   "lifeExp": 42.082,
   "gdpPercap": 823.6856205,
   "pop": 19951656
 },
 {
   "country": "Myanmar",
   "continent": "Asia",
   "lifeExp": 62.069,
   "gdpPercap": 944,
   "pop": 47761980
 },
 {
   "country": "Namibia",
   "continent": "Africa",
   "lifeExp": 52.906,
   "gdpPercap": 4811.060429,
   "pop": 2055080
 },
 {
   "country": "Nepal",
   "continent": "Asia",
   "lifeExp": 63.785,
   "gdpPercap": 1091.359778,
   "pop": 28901790
 },
 {
   "country": "Netherlands",
   "continent": "Europe",
   "lifeExp": 79.762,
   "gdpPercap": 36797.93332,
   "pop": 16570613
 },
 {
   "country": "New Zealand",
   "continent": "Oceania",
   "lifeExp": 80.204,
   "gdpPercap": 25185.00911,
   "pop": 4115771
 },
 {
   "country": "Nicaragua",
   "continent": "Americas",
   "lifeExp": 72.899,
   "gdpPercap": 2749.320965,
   "pop": 5675356
 },
 {
   "country": "Niger",
   "continent": "Africa",
   "lifeExp": 56.867,
   "gdpPercap": 619.6768924,
   "pop": 12894865
 },
 {
   "country": "Nigeria",
   "continent": "Africa",
   "lifeExp": 46.859,
   "gdpPercap": 2013.977305,
   "pop": 135031164
 },
 {
   "country": "Norway",
   "continent": "Europe",
   "lifeExp": 80.196,
   "gdpPercap": 49357.19017,
   "pop": 4627926
 },
 {
   "country": "Oman",
   "continent": "Asia",
   "lifeExp": 75.64,
   "gdpPercap": 22316.19287,
   "pop": 3204897
 },
 {
   "country": "Pakistan",
   "continent": "Asia",
   "lifeExp": 65.483,
   "gdpPercap": 2605.94758,
   "pop": 169270617
 },
 {
   "country": "Panama",
   "continent": "Americas",
   "lifeExp": 75.537,
   "gdpPercap": 9809.185636,
   "pop": 3242173
 },
 {
   "country": "Paraguay",
   "continent": "Americas",
   "lifeExp": 71.752,
   "gdpPercap": 4172.838464,
   "pop": 6667147
 },
 {
   "country": "Peru",
   "continent": "Americas",
   "lifeExp": 71.421,
   "gdpPercap": 7408.905561,
   "pop": 28674757
 },
 {
   "country": "Philippines",
   "continent": "Asia",
   "lifeExp": 71.688,
   "gdpPercap": 3190.481016,
   "pop": 91077287
 },
 {
   "country": "Poland",
   "continent": "Europe",
   "lifeExp": 75.563,
   "gdpPercap": 15389.92468,
   "pop": 38518241
 },
 {
   "country": "Portugal",
   "continent": "Europe",
   "lifeExp": 78.098,
   "gdpPercap": 20509.64777,
   "pop": 10642836
 },
 {
   "country": "Puerto Rico",
   "continent": "Americas",
   "lifeExp": 78.746,
   "gdpPercap": 19328.70901,
   "pop": 3942491
 },
 {
   "country": "Reunion",
   "continent": "Africa",
   "lifeExp": 76.442,
   "gdpPercap": 7670.122558,
   "pop": 798094
 },
 {
   "country": "Romania",
   "continent": "Europe",
   "lifeExp": 72.476,
   "gdpPercap": 10808.47561,
   "pop": 22276056
 },
 {
   "country": "Rwanda",
   "continent": "Africa",
   "lifeExp": 46.242,
   "gdpPercap": 863.0884639,
   "pop": 8860588
 },
 {
   "country": "Sao Tome and Principe",
   "continent": "Africa",
   "lifeExp": 65.528,
   "gdpPercap": 1598.435089,
   "pop": 199579
 },
 {
   "country": "Saudi Arabia",
   "continent": "Asia",
   "lifeExp": 72.777,
   "gdpPercap": 21654.83194,
   "pop": 27601038
 },
 {
   "country": "Senegal",
   "continent": "Africa",
   "lifeExp": 63.062,
   "gdpPercap": 1712.472136,
   "pop": 12267493
 },
 {
   "country": "Serbia",
   "continent": "Europe",
   "lifeExp": 74.002,
   "gdpPercap": 9786.534714,
   "pop": 10150265
 },
 {
   "country": "Sierra Leone",
   "continent": "Africa",
   "lifeExp": 42.568,
   "gdpPercap": 862.5407561,
   "pop": 6144562
 },
 {
   "country": "Singapore",
   "continent": "Asia",
   "lifeExp": 79.972,
   "gdpPercap": 47143.17964,
   "pop": 4553009
 },
 {
   "country": "Slovak Republic",
   "continent": "Europe",
   "lifeExp": 74.663,
   "gdpPercap": 18678.31435,
   "pop": 5447502
 },
 {
   "country": "Slovenia",
   "continent": "Europe",
   "lifeExp": 77.926,
   "gdpPercap": 25768.25759,
   "pop": 2009245
 },
 {
   "country": "Somalia",
   "continent": "Africa",
   "lifeExp": 48.159,
   "gdpPercap": 926.1410683,
   "pop": 9118773
 },
 {
   "country": "South Africa",
   "continent": "Africa",
   "lifeExp": 49.339,
   "gdpPercap": 9269.657808,
   "pop": 43997828
 },
 {
   "country": "Spain",
   "continent": "Europe",
   "lifeExp": 80.941,
   "gdpPercap": 28821.0637,
   "pop": 40448191
 },
 {
   "country": "Sri Lanka",
   "continent": "Asia",
   "lifeExp": 72.396,
   "gdpPercap": 3970.095407,
   "pop": 20378239
 },
 {
   "country": "Sudan",
   "continent": "Africa",
   "lifeExp": 58.556,
   "gdpPercap": 2602.394995,
   "pop": 42292929
 },
 {
   "country": "Swaziland",
   "continent": "Africa",
   "lifeExp": 39.613,
   "gdpPercap": 4513.480643,
   "pop": 1133066
 },
 {
   "country": "Sweden",
   "continent": "Europe",
   "lifeExp": 80.884,
   "gdpPercap": 33859.74835,
   "pop": 9031088
 },
 {
   "country": "Switzerland",
   "continent": "Europe",
   "lifeExp": 81.701,
   "gdpPercap": 37506.41907,
   "pop": 7554661
 },
 {
   "country": "Syria",
   "continent": "Asia",
   "lifeExp": 74.143,
   "gdpPercap": 4184.548089,
   "pop": 19314747
 },
 {
   "country": "Taiwan",
   "continent": "Asia",
   "lifeExp": 78.4,
   "gdpPercap": 28718.27684,
   "pop": 23174294
 },
 {
   "country": "Tanzania",
   "continent": "Africa",
   "lifeExp": 52.517,
   "gdpPercap": 1107.482182,
   "pop": 38139640
 },
 {
   "country": "Thailand",
   "continent": "Asia",
   "lifeExp": 70.616,
   "gdpPercap": 7458.396327,
   "pop": 65068149
 },
 {
   "country": "Togo",
   "continent": "Africa",
   "lifeExp": 58.42,
   "gdpPercap": 882.9699438,
   "pop": 5701579
 },
 {
   "country": "Trinidad and Tobago",
   "continent": "Americas",
   "lifeExp": 69.819,
   "gdpPercap": 18008.50924,
   "pop": 1056608
 },
 {
   "country": "Tunisia",
   "continent": "Africa",
   "lifeExp": 73.923,
   "gdpPercap": 7092.923025,
   "pop": 10276158
 },
 {
   "country": "Turkey",
   "continent": "Europe",
   "lifeExp": 71.777,
   "gdpPercap": 8458.276384,
   "pop": 71158647
 },
 {
   "country": "Uganda",
   "continent": "Africa",
   "lifeExp": 51.542,
   "gdpPercap": 1056.380121,
   "pop": 29170398
 },
 {
   "country": "United Kingdom",
   "continent": "Europe",
   "lifeExp": 79.425,
   "gdpPercap": 33203.26128,
   "pop": 60776238
 },
 {
   "country": "United States",
   "continent": "Americas",
   "lifeExp": 78.242,
   "gdpPercap": 42951.65309,
   "pop": 301139947
 },
 {
   "country": "Uruguay",
   "continent": "Americas",
   "lifeExp": 76.384,
   "gdpPercap": 10611.46299,
   "pop": 3447496
 },
 {
   "country": "Venezuela",
   "continent": "Americas",
   "lifeExp": 73.747,
   "gdpPercap": 11415.80569,
   "pop": 26084662
 },
 {
   "country": "Vietnam",
   "continent": "Asia",
   "lifeExp": 74.249,
   "gdpPercap": 2441.576404,
   "pop": 85262356
 },
 {
   "country": "West Bank and Gaza",
   "continent": "Asia",
   "lifeExp": 73.422,
   "gdpPercap": 3025.349798,
   "pop": 4018332
 },
 {
   "country": "Yemen, Rep.",
   "continent": "Asia",
   "lifeExp": 62.698,
   "gdpPercap": 2280.769906,
   "pop": 22211743
 },
 {
   "country": "Zambia",
   "continent": "Africa",
   "lifeExp": 42.384,
   "gdpPercap": 1271.211593,
   "pop": 11746035
 },
 {
   "country": "Zimbabwe",
   "continent": "Africa",
   "lifeExp": 43.487,
   "gdpPercap": 469.7092981,
   "pop": 12311143
 }
]
    For more information, see the JSON Provider topic.
  5. Go to the Connection String tab and verify the generated connection string by clicking the Validate DataSource Validate Icon icon.
  6. Click OK to save the changes and open the DataSet dialog.

Add a Dataset

  1. In the Dataset dialog, select the General page and enter the name of the dataset, 'Stats'.
  2. Go to the Query page and enter the following query to fetch the required fields:
    Query Copy Code
    $.[*]
  3. Click OK to save the changes.

Create a Chart

We will use the Chart Wizard dialog to configure chart data values. The wizard appears by default if you have a dataset added to your report. See the topic on Chart Wizard for more information.

  1. Drag-drop Chart data region onto the design area. The Chart Wizard dialog appears with an option to select the data and the chart type.
  2. Select the Dataset Name as 'Stats' and the Chart Type as 'Scatter'.
  3. Click Next to proceed. Here, you need to specify the scatter settings.
  4. In Choose Data values section, we will define two data values to display 'GDP Per Capita' and 'Life Expectancy' along the horizontal and vertical axes of the chart.
    1. From the drop-down, set the X Field to =[gdpPercap].
    2. From the drop-down, set the Y Field to =[lifeExp].
  5. Click Next to preview your chart.
    Multi Category Scatter Chart at Preview Time
    You can also modify the chart palette and do other customizations as the last step in the process of chart creation. Or, you can exit the wizard and access these smart panels as explained below.

Set Advanced Customization

Now that the chart is configured with data values, let us do some customizations on the chart elements using the smart panels.

Plot Settings

  1. To open the smart panel for advanced plot settings, right-click 'Plot - Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Encodings page.
  3. Navigate to the Color tab, add a new value and set the Expression to ={continent}, so that the color of the data points in the chart varies by continent.
  4. Then, go to the Shape tab, add a new value and set the Expression to ={continent} to display the shape of the data points based on the continent values.
  5. Click OK to complete setting up the plot.

Y-Axis

  1. To open the smart panel for advanced Y-axis settings, right-click 'Y Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties.
    • Title: Life Expectancy
    • Font > Size: 10pt
    • Font > Color: DimGray
  3. Go to the Labels page > Appearance tab and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  4. Go to the Line page and uncheck the Show Line option.
  5. Go to the Major Gridline page and set the following properties.
    • Grid Interval: 20
    • Show Grid: Check-on
    • Grid appearance > Width: 0.25pt
    • Grid appearance > Color: #cccccc
    • Grid appearance > Style: Dashed
  6. Click OK to complete setting up the Y-axis.

X-Axis

  1. To open the smart panel for advanced X-axis settings, right-click 'X Axis' on the Report Explorer and choose Property Dialog.
  2. Go to the Title page and set the following properties.
    • Title: GDP per Capita
    • Font > Size: 10pt
    • Font > Color: DimGray
  3. Go to the Labels page > General tab and set the Format to 'Currency (with 0 decimal points)'.
  4. Then, navigate to the Appearance page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  5. Go to the Line page and set the following properties:
    • Color: #cccccc
    • Width: 2pt
  6. Go to the Scale page and set the Scale Type to 'Logarithmic'.
  7. Click OK to complete setting up the X-axis.

Chart Palette

  1. To open the smart panel for advanced chart settings, right-click 'Chart' on the Report Explorer and choose Property Dialog.
  2. Go to the Palette page, select Custom from the drop-down, and add the below colors.
    • #f26324
    • #1fd537
    • #e40010
    • #8fcd37
    • #00b32c
  3. Click OK to complete setting up the custom palette.

Legend - Color

  1. To open the smart panel for the legend, right-click 'Legend - Color' on the Report Explorer and choose Property Dialog.
  2. Go to the Layout page and set the following properties.
    • Position: Top
    • Orientation: Horizontal
  3. Go to the Appearance page and set the following properties.
    • Font > Size: 10pt
    • Font > Color: DimGray
  4. Click OK to complete setting up the chart legend.

Chart Header

  1. To open the smart panel for the chart header, right-click 'Header' on the Report Explorer and choose Property Dialog.
  2. Go to the General page and set Text to 'Life Expectancy vs. GDP per Capita'.
  3. Go to the Font page and set the properties as below.
    • Size: 24pt
    • Color: #3da7a8
  4. Click OK to complete setting up the chart header.
    You may want to resize the chart.
    Multi Category Scatter Chart at Design Time
    Note: We use stub data at design time and not real data. So to view the actual final chart, you need to view the chart on the preview.
  5. Once you are done with configuring and customizing the chart, press F5 to preview the report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Extensibility Options

Extensibility Options

Glossary Item Box

Reports

ActiveReports provides the following extension possibilities for reports:

  • Scripts or external assemblies
  • Custom report items
  • Сustom data providers
  • Сustom map tile providers

Viewers

ActiveReports provides various ways to create your own preview control, including different platforms for custom viewers based on the JS Viewer component and the Blazor Viewer control.

Exports

You can create custom exports in your ActiveReports applications.

Environment

ActiveReports delivers implementation solutions that can work in different environments. We recommend that you consider this logic when making a decision on what option to choose:

  • Use Page/RDLX reports (Section report requires some knowledge on writing scripts and is intended for developers only).
  • Use custom font resolving (and distribute fonts together with your application).
  • Use the new Blazor viewer for the cross-platform UI (see https://visualstudiomagazine.com/articles/2021/02/17/net-6-preview-1.aspx and https://visualstudiomagazine.com/articles/2021/04/09/blazorwebview.aspx).

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Glossary

Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

C

CPL report
Report Definition Layout (RDL) is a report type that allows report controls to increase in size to accommodate your data.

D

data region
Data regions are report controls (Table, List, Banded List, Tablix and Chart) in page reports that can contain other report controls.

design surface
Part of the report design view that lets you create or edit report layouts using controls or data regions in Visual Studio or Stand-Alone Designer Application.

Design View

designer buttons
Buttons located at the bottom of the report designer tabs adjacent to the designer surface.

Designer tab
Default tab that is used to create layouts, connect to a data source or implement other design time features.

designer tabs
Designer, Script and Preview tabs located at the bottom of the report designer surface.

detail

The only required section in a section-based report. This section repeats once for every row of data in the report.

document map
A table of contents for the report in the viewer. When a user clicks an item in the document map, the viewer jumps to that item in the report.

E

ESRI shapefile
An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, go to www.census.gov/geo/maps-data/data/tiger.html.

F

field selection adorner
An icon that appears when you hover over a textbox. It is used to quickly bind the textbox to a field from the DataSet. Selecting a field through this adorner adds a field expression similar to the one that is added when you drag a field into a control from the ReportExplorer.

fixed page
Refers to a page in the Page report represented by the Page node in the Report Explorer.

Fixed Page Layout report
Report type where designing is done on a page to provide a dynamic layout environment. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

FixedPage dialog
Dialog that contains the properties to be set for the fixed page in a Page report. You can access this dialog when you right-click on the gray area of the report designer and select Fixed Layout Settings... from the context menu. Alternatively, with the Page selected on the report, right-click and open the Properties window to select the Property dialog... link at the bottom.

FixedSize
FixedSize property expands the area of a data region upto a set size in case of excessive data. You can use the Properties Window to enter the property value manually, or you can also set the FixedSize by dragging the grey adorners that appears at the bottom and on the right side of a data region.

G

Group Editor
Group Editor window is specifically designed to manage the tablix structure. It consists of a Row Groups pane and a Column Groups pane. The Group Editor window displays the row and column groups for the currently selected Tablix data region on the design surface.

group footer
Section inserted below the detail section in a section report, where grouping is set.

group header
Section inserted above the detail section in a section report, where grouping is set.

L

Layers
Layers are a named group of controls.

layers pane
The area labeled "right-click to add the new layer." that appears at the bottom of the Map data region. It display the list of layers that are defined for the map. Use this pane to add, delete or edit a layer.

P

Page
Report type where designing is done on a page to provide a dynamic layout environment. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

page footer
Section that appears at the bottom of each page of a section report. You can also add a page footer to a page report if you convert it to an RDLX report.

page header
Section that appears at the top of each page of a section report. You can also add a page header to a page report if you convert it to an RDLX report.

page layout
Report layout type where designing is done on a page to provide a dynamic layout environment.

Page Report
Report type where designing is done on a page to provide a dynamic layout environment. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

polygon center points
Markers that gets displayed at the center of each polygon

preview
Tab to view the report without actually running the application containing the report.

Preview tab
Tab to view the report without actually running the application containing the report.

Professional Edition
This is a license for ActiveReports that includes all of the features of the Standard Edition, plus the WebViewer control, HTTP Handlers, the Designer control, the ReportExplorer control, the Toolbox control, and advanced PDF and Font features.

properties window

R

RDLX

Report Definition Language (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDLX
Report Definition Language Extended file. This is a layout file for page reports and RDLX reports.

RDLX Dashboard Report
An RDL dashboard report is similar to RDL report that displays report in one scrollable view. It can also have multiple sections like an RDL Multi-Section Report.

RDLX report

Report type that allows you to define multiple layouts and change the size of the controls to accommodate your data.

RDLX report

RDLX report
Report Definition Language (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDLX-master
Report Definition Language Extended Master file. This is a layout file for RDL reports that allows you to specify standard elements to apply to all content reports that use it.

report layout
Layouts available in ActiveReports for designing reports. The two layout types are, Section Layout and Page Layout.

RPX
Report XML file. This is a layout file for section-based reports. It can contain VB.NET or C# script, but does not contain code that may have been added behind the report.

S

Scope
A parameter for functions, which the grouping, data region, or dataset to be considered when calculating the aggregate or other function.

Script tab
Tab used to add VB.NET or C# functionality through script.

section layout
Report layout type where designing is done in banded sections. There is always a detail section present, while header and footer sections (report, page, or group) can be added or removed as you require.

Section Report
Report type where designing is done in banded sections. There is always a detail section present, while header and footer sections(report, page, or group) can be added or removed as you require.

snap to grid
Feature to move controls and data regions from one grid line to another on the report design surface.

Stand-alone Designer Application
Refers to GrapeCity.ActiveReports.Designer.exe bundled with ActiveReports. This application provides major features of the Designer to create or save reports and works on systems which do not have Visual Studio installed.

Standard Edition
This is a license for ActiveReports that includes the Windows Forms Viewer control, all of the exports, and the Visual Studio report designer.

T

table details
Middle row of the Table data region, that functions as the detail row for the table. When you drag a field into a cell in the table detail row, a label is added automatically in the table header row.

Tablix
A Tablix data region provides enhanced layout capabilities ranging from creation of simple tables to complex grid layouts in Page and RDL reports.

V

View Pane

View Pane display the view center keys and zoom level slider for the map viewport. Use the arrow keys to adjust the view center and the slider to adjust the zoom level.

Viewer
A stand-alone application where you can preview your report.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Map Related Configuration

Map Related Configuration

Glossary Item Box

The Map report item allows configuring built-in tile providers and extensions with custom report items.

In general, external providers have a limited support of resources. They require an external key for unlimited access. ActiveReports allows configuring such keys:

  • The Bing provider requires the Bing account - for details, see https://www.microsoft.com/en-us/maps/licensing/licensing-options
  • The Google provider requires the Google Developer account:
  • The MapQuest provider requires the MapQuest Developer Network account - for details, see https://developer.mapquest.com/documentation/open

The example of the configuration file.

XML code. Add to the configuration file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <MapTileProviders>
            <MapTileProvider Name="MapQuest" DisplayName="MapQuest Tyles">
                <Settings>
                    <add key="ApiKey" value="Fmjtd%7Cluur21ua2l%2C2x%3Do5-90t5h6" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
            <MapTileProvider Name="Google" DisplayName="Google Tiles">
                <Settings>
                    <add key="ApiKey" value="AIzaSyBdJ88HN7LTGkHHK5whfaVv8a5ozlx2E_k" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
            <MapTileProvider Name="Bing" DisplayName="Bing Tiles" >
                <Settings>
                    <add key="ApiKey" value="Al3SxHf0LOva-5GI5fOajO0LCuKjYKLarjWQFcdGiKfaJNRrE6SBbH9o3-HJDOX7" />
                    <add key="Timeout" value="5000" />
                </Settings>
            </MapTileProvider>
        </MapTileProviders>
    </Extensions>
</Configuration>

You can also implement your own tile provider and register it in ActiveReports as follows:

XML code. Add to the configuration file Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
    <Extensions>
        <MapTileProviders>
            <MapTileProvider Name="MapQuest-Sample" DisplayName="MapQuest-Sample" Type="GrapeCity.ActiveReports.Samples.CustomTileProviders.MapQuestTileProvider, CustomTileProviders, Version=1.0.0.0">
                <Settings>
                    <add key="ApiKey" value="Fmjtd%7Cluur21ua2l%2C2x%3Do5-90t5h6" />
                    <add key="Timeout" value="3000" />
                </Settings>
            </MapTileProvider>
        </MapTileProviders>
    </Extensions>
</Configuration>

See the Custom Tile Provider sample.

Copyright © MESCIUS inc. All rights reserved.

Product Support Forum | Print this page

©2025. All Rights Reserved.


Assembly Overview

MESCIUS.ActiveReports.Aspnet.Designer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnet |
GrapeCity.ActiveReports.Aspnet.Designer |
GrapeCity.ActiveReports.Aspnet.Designer.I |
GrapeCity.ActiveReports.Aspnet.Designer.Utilities |
GrapeCity.ActiveReports.Web.Designer |


Getting Started - ActiveReports 19 .NET Edition

Getting Started

Product Support Forum | Print this page

Glossary Item Box


Introduction - ActiveReports 19 .NET Edition

Introduction

Product Support Forum | Print this page

Glossary Item Box


GrapeCity.ActiveReports.Aspnet.Designer.I Namespace

GrapeCity.ActiveReports.Aspnet.Designer.I Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.I Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Designer.I Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer.I Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.I Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


ToXml Method

[image]
ActiveReports 19 .NET Edition
ToXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace > ReportConverter Class : ToXml Method

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Overload List

Overload | Description
ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ReportConverter | Represents methods for converting report content.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Utilities.ReportConverter

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Designer Namespace

GrapeCity.ActiveReports.Aspnet.Designer Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ConfigureExtensions | Represents methods for configuring the web host application.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Designer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.ConfigureExtensions

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Designer)

GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Designer)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet Namespace

Glossary Item Box

Classes

 | Class | Description
Class | WebDesigner | Dummy class for obtaining a license.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Designer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Designer) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.WebDesigner

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


ImageNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


IReportDesignerBackendApi Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

For a list of all members of this type, see IReportDesignerBackendApi members.

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ThemeNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnet.Designer)

GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnet.Designer)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Web.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DataSetTemplate | Represents a dataset template.
Class | DataSetTemplateExtensions | Represents an extension methods for DataSetTemplate.
Class | ImageNotFoundException | Represents the exception that is thrown when an image cannot be found.
Class | ImageResourceDescriptor | Represents a descriptor for an image resource.
Class | InvalidReportContentException | Represents the exception that is thrown when a report contains invalid content.
Class | InvalidThemeContentException | Represents the exception that is thrown when a theme contains invalid content.
Class | ReportDesignerConfiguration | Represents configuration options for the report designer.
Class | ReportDesignerSettings | Represents the settings for the report designer.
Class | ReportExtensions | Represents extension methods for working with reports.
Class | ReportInfo | Represents information about a report.
Class | ReportNotFoundException | Represents the exception that is thrown when a report cannot be found.
Class | ReportResourceDescriptor | Represents a descriptor for a report resource.
Class | ResourceDescriptor | Represents a descriptor for a resource.
Class | SharedDataSourceResourceDescriptor | Represents a descriptor for a shared data source resource.
Class | ThemeNotFoundException | Represents the exception that is thrown when a theme cannot be found.
Class | ThemeResourceDescriptor | Represents a descriptor for a theme resource.
Class | Thumbnail | Represents a thumbnail image.

Interfaces

 | Interface | Description
Interface | IReportDesignerBackendApi | Represents the full configuration for the report designer.
Interface | IReportStore | Represents methods for storing and managing reports.
Interface | IResourceRepositoryProvider | Represents methods for accessing and managing report resources.

Enumerations

 | Enumeration | Description
Enumeration | FileStoreOptions | Specifies the options for file storage.
Enumeration | RdlSubtype | Specifies the RDL subtypes.
Enumeration | SaveSettings | Represents the save settings for a report.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnet.Designer) Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnet.Designer) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Web.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplate
GrapeCity.ActiveReports.Web.Designer.DataSetTemplateExtensions
GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration
GrapeCity.ActiveReports.Web.Designer.ReportDesignerSettings
GrapeCity.ActiveReports.Web.Designer.ReportExtensions
GrapeCity.ActiveReports.Web.Designer.ReportInfo
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.Thumbnail
System.Exception
GrapeCity.ActiveReports.Web.Designer.ImageNotFoundException
GrapeCity.ActiveReports.Web.Designer.InvalidReportContentException
GrapeCity.ActiveReports.Web.Designer.InvalidThemeContentException
GrapeCity.ActiveReports.Web.Designer.ThemeNotFoundException
GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Designer Assembly


Assembly Overview

MESCIUS.ActiveReports.Aspnet.Viewer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnet |
GrapeCity.ActiveReports.Aspnet.Viewer |


GrapeCity.ActiveReports.Aspnet.Viewer Namespace

GrapeCity.ActiveReports.Aspnet.Viewer Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ConfigureExtensions | Represents a set of methods for configuring the web host application.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Viewer Assembly


GrapeCity.ActiveReports.Aspnet.Viewer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Viewer Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Viewer.ConfigureExtensions

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Viewer Assembly


GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Viewer)

GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Viewer)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet Namespace

Glossary Item Box

Classes

 | Class | Description
Class | WebViewer | Represents the dummy class for obtaining a license.

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Viewer Assembly


GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet Namespace (MESCIUS.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.WebViewer

See Also

Reference

MESCIUS.ActiveReports.Aspnet.Viewer Assembly


Assembly Overview

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnetcore.Designer |
GrapeCity.ActiveReports.Aspnetcore.Designer.I |
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities |
GrapeCity.ActiveReports.Web.Designer |


GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.I Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


ToXml Method

[image]
ActiveReports 19 .NET Edition
ToXml Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace > ReportConverter Class : ToXml Method

Glossary Item Box

Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Overload List

Overload | Description
ToXml | Serializes the specified GrapeCity.ActiveReports.PageReportModel.Report to XML content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportConverter Class
ReportConverter Members


GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ReportConverter | Represents methods for converting report content.

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities.ReportConverter

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ConfigureExtensions | Represents methods for configuring the web host application.

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Designer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.ConfigureExtensions

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


ImageNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ImageNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ImageNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : GetType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ImageNotFoundException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidReportContentException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidReportContentException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : GetType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidReportContentException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


InvalidThemeContentException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidThemeContentException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : GetType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > InvalidThemeContentException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


IReportDesignerBackendApi Interface Methods

[image]
ActiveReports 19 .NET Edition
IReportDesignerBackendApi Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : IReportDesignerBackendApi Interface

Glossary Item Box

For a list of all members of this type, see IReportDesignerBackendApi members.

See Also

Reference

IReportDesignerBackendApi Interface
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ReportNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ThemeNotFoundException Class Methods

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


ThemeNotFoundException Class Properties

[image]
ActiveReports 19 .NET Edition
ThemeNotFoundException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Web.Designer Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : GetType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HResult As Integer
C#
public int HResult {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Web.Designer Namespace > ThemeNotFoundException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnetcore.Designer)

GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnetcore.Designer)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Web.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DataSetTemplate | Represents a dataset template.
Class | DataSetTemplateExtensions | Represents an extension methods for DataSetTemplate.
Class | ImageNotFoundException | Represents the exception that is thrown when an image cannot be found.
Class | ImageResourceDescriptor | Represents a descriptor for an image resource.
Class | InvalidReportContentException | Represents the exception that is thrown when a report contains invalid content.
Class | InvalidThemeContentException | Represents the exception that is thrown when a theme contains invalid content.
Class | ReportDesignerConfiguration | Represents configuration options for the report designer.
Class | ReportDesignerSettings | Represents the settings for the report designer.
Class | ReportExtensions | Represents extension methods for working with reports.
Class | ReportInfo | Represents information about a report.
Class | ReportNotFoundException | Represents the exception that is thrown when a report cannot be found.
Class | ReportResourceDescriptor | Represents a descriptor for a report resource.
Class | ResourceDescriptor | Represents a descriptor for a resource.
Class | SharedDataSourceResourceDescriptor | Represents a descriptor for a shared data source resource.
Class | ThemeNotFoundException | Represents the exception that is thrown when a theme cannot be found.
Class | ThemeResourceDescriptor | Represents a descriptor for a theme resource.
Class | Thumbnail | Represents a thumbnail image.

Interfaces

 | Interface | Description
Interface | IReportDesignerBackendApi | Represents the full configuration for the report designer.
Interface | IReportStore | Represents methods for storing and managing reports.
Interface | IResourceRepositoryProvider | Represents methods for accessing and managing report resources.

Enumerations

 | Enumeration | Description
Enumeration | FileStoreOptions | Specifies the options for file storage.
Enumeration | RdlSubtype | Specifies the RDL subtypes.
Enumeration | SaveSettings | Represents the save settings for a report.

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnetcore.Designer) Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Designer Namespace (MESCIUS.ActiveReports.Aspnetcore.Designer) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Web.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Designer.DataSetTemplate
GrapeCity.ActiveReports.Web.Designer.DataSetTemplateExtensions
GrapeCity.ActiveReports.Web.Designer.ReportDesignerConfiguration
GrapeCity.ActiveReports.Web.Designer.ReportDesignerSettings
GrapeCity.ActiveReports.Web.Designer.ReportExtensions
GrapeCity.ActiveReports.Web.Designer.ReportInfo
GrapeCity.ActiveReports.Web.Designer.ResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ImageResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ReportResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.SharedDataSourceResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.ThemeResourceDescriptor
GrapeCity.ActiveReports.Web.Designer.Thumbnail
System.Exception
GrapeCity.ActiveReports.Web.Designer.ImageNotFoundException
GrapeCity.ActiveReports.Web.Designer.InvalidReportContentException
GrapeCity.ActiveReports.Web.Designer.InvalidThemeContentException
GrapeCity.ActiveReports.Web.Designer.ThemeNotFoundException
GrapeCity.ActiveReports.Web.Viewer.ReportNotFoundException
GrapeCity.ActiveReports.Web.Designer.ReportNotFoundException

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Designer Assembly


Assembly Overview

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnetcore.Viewer |


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (MESCIUS.ActiveReports.Aspnetcore.Viewer)

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (MESCIUS.ActiveReports.Aspnetcore.Viewer)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ConfigureExtensions | Represents a set of methods for configuring the web host application.

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (MESCIUS.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (MESCIUS.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ConfigureExtensions

See Also

Reference

MESCIUS.ActiveReports.Aspnetcore.Viewer Assembly


Assembly Overview

MESCIUS.ActiveReports.Blazor.Designer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Blazor.Designer |
GrapeCity.ActiveReports.Blazor.Designer.I |


_Imports Class Methods

[image]
ActiveReports 19 .NET Edition
_Imports Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : _Imports Class

Glossary Item Box

For a list of all members of this type, see _Imports members.

See Also

Reference

_Imports Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SetParametersAsync Method

[image]
ActiveReports 19 .NET Edition
SetParametersAsync Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > _Imports Class : SetParametersAsync Method

parameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function SetParametersAsync( _
   ByVal parameters As ParameterView _
) As Task
C#
public virtual Task SetParametersAsync(
   ParameterView parameters
)

Parameters

parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Class
_Imports Members


GrapeCity.ActiveReports.Blazor.Designer.I Namespace

GrapeCity.ActiveReports.Blazor.Designer.I Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly : GrapeCity.ActiveReports.Blazor.Designer.I Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Blazor.Designer Assembly


GrapeCity.ActiveReports.Blazor.Designer.I Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Blazor.Designer.I Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly : GrapeCity.ActiveReports.Blazor.Designer.I Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Blazor.Designer Assembly


ReportDesigner Class Methods

[image]
ActiveReports 19 .NET Edition
ReportDesigner Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace : ReportDesigner Class

Glossary Item Box

For a list of all members of this type, see ReportDesigner members.

See Also

Reference

ReportDesigner Class
GrapeCity.ActiveReports.Blazor.Designer Namespace


SetParametersAsync Method

[image]
ActiveReports 19 .NET Edition
SetParametersAsync Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly > GrapeCity.ActiveReports.Blazor.Designer Namespace > ReportDesigner Class : SetParametersAsync Method

parameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function SetParametersAsync( _
   ByVal parameters As ParameterView _
) As Task
C#
public virtual Task SetParametersAsync(
   ParameterView parameters
)

Parameters

parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDesigner Class
ReportDesigner Members


GrapeCity.ActiveReports.Blazor.Designer Namespace

GrapeCity.ActiveReports.Blazor.Designer Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly : GrapeCity.ActiveReports.Blazor.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | _Imports |
Class | About | Represents the documentation links and application info.
Class | AboutButton | Represents the settings for the About button.
Class | App | Represents the main application class, providing access to application-level functionalities.
Class | AppBarSettings | Represents the settings for the App Bar, providing quick access to common actions and controls.
Class | Barcore | Represents the features for barcode items.
Class | BorderStyle | Represents the border style for a report item.
Class | BulletStyleContent | Represents the style content for a bullet report item.
Class | CellStyleContent | Represents the style content for a cell in a table report item.
Class | ChangedDocumentOptions | Represents the options for changed document information.
Class | CommonValues | Represents the settings for the common values section.
Class | ContainerStyleContent | Represents the style content for a container report item.
Class | ContextActionsTab | Represents the settings for the Context Actions tab.
Class | CreateDocumentInfo | Represents the information about a created document.
Class | CreateDocumentOptions | Represents an options for creating a new document.
Class | CurrentDocumentInfo | Represents the information about the currently open document.
Class | Dashboard | Represents the settings for RDL Dashboard.
Class | DataSets | Represents the settings for the data sets section.
Class | DataSetsInfo | Represents the information about data sets.
Class | DataSettings | Represents the settings related to data management.
Class | DataSources | Represents the settings for the data sources.
Class | DataSourcesOptions | Represents the options for data sources and the data source editor.
Class | DataTab | Represents the settings for the data tab.
Class | DesignerSettings | Represents the initialization settings for the Designer.
Class | Details | Represents the style content for the details section of a table report item.
Class | Document | Represents a document to open on app startup.
Class | DocumentExplorer | Represents the Document Explorer settings.
Class | Documents | Represents methods for managing documents, allowing the creation, opening, saving, and status checking of reports being edited.
Class | DocumentsSettings | Contains settings and handlers for managing documents.
Class | DocumentTemplate | Represents the information about a document template.
Class | FileView | Represents the settings for the File View.
Class | Font | Represents the configuration for a font.
Class | FontHeader | Represents the configuration for a font header.
Class | Footer | Represents the style content for the footer of a table report item.
Class | Fpl | Represents the settings for FPL.
Class | Handlers | Represents handlers for various document events.
Class | Header | Represents the style content for the header of a table report item.
Class | Help | Represents the designer-related documentation links.
Class | HomeTab | Represents the settings for the Home tab.
Class | InitTemplates | Represents the templates for creating new items from RDLX-JSON strings.
Class | InsertTab | Represents the settings for the Insert tab.
Class | Levels | Represents the style content for the levels of a table of contents report item.
Class | Library | Represents a library for report parts.
Class | Link | Represents the link.
Class | LocalizationResources | Represents localization resources for a specific language.
Class | Logo | Represents the logo settings.
Class | MasterReport | Represents the settings for RDL MasterReport.
Class | Menu | Represents methods to interact with the menu in the UI.
Class | MenuIcon | Represents a custom menu icon.
Class | MenuSettings | Represents the settings for the Main Menu, providing access to various features and tools.
Class | Msl | Represents the settings for RDL Multi-Section (MSL).
Class | Notifications | Represents methods for sending and managing notifications, allowing the sending of notifications of various levels (info, warning, error) and managing their display and dismissal.
Class | OpenButton | Represents the settings for the Open button.
Class | OpenDocumentInfo | Represents the information about an opened document.
Class | Panels | Represents access to the menu and sidebar panels.
Class | Parameters | Represents the settings for the Parameters section.
Class | ParametersTab | Represents the settings for the Parameters tab.
Class | PreviewSettings | Represents settings related to the document preview functionality, allowing configuration of the preview button visibility and integration of a viewer component.
Class | PropertiesModeButton | Represents the settings for the properties mode button.
Class | PropertiesTab | Represents the settings for the Properties tab.
Class | PropertyGridSettings | Represents the settings for the Property Grid, allowing the viewing and editing of properties of selected objects.
Class | RdlxReportItemsSettings | Represents the customizable features for various report items in RDLX.
Class | RdlxSettings | Represents the settings specific to the RDLX platform.
Class | ReportDesigner |
Class | ReportItemStyle<T> | Represents a style for a report item.
Class | ReportPartsSettings | Represents the settings related to the Report Parts feature.
Class | ReportStyles | Represents the styles for various report items.
Class | RequestInit | Represents the initialization settings for a request.
Class | RpxSettings | Represents the settings specific to the RPX platform.
Class | Rulers | Represents the settings for rulers.
Class | RulersButton | Represents the settings for the rulers button.
Class | SaveAsButton | Represents the settings for the Save As button.
Class | SaveButton | Represents the settings for the Save button.
Class | SaveDocumentInfo | Represents the information about a saved document.
Class | ScriptTab | Represents the settings for the Script tab.
Class | ServerSettings | Represents the settings related to the backend server, including the base URL and request modification handlers.
Class | SharedDataSourceOptions | Represents the options for shared data sources.
Class | Sidebar | Represents methods to interact with the sidebar in the UI.
Class | SnapStep | Represents the snap step value.
Class | SparklineStyleContent | Represents the style content for a sparkline report item.
Class | StatusBarSettings | Represents the settings for the Status Bar, providing various controls and information at the bottom of the designer.
Class | Stylesheet | Represents settings for the RPX report stylesheet.
Class | StylesSettings | Represents settings related to RPX Styles.
Class | StylesTab | Represents settings for the Styles tab in RPX reports.
Class | Table | Represents the features for table items.
Class | TableGroups | Represents the style content for the groups of a table report item.
Class | TableOfContentsStyleContent | Represents the style content for a table of contents report item.
Class | TableStyleContent | Represents the style content for a table report item.
Class | TableStyles | Represents the style content for the table styles of a table report item.
Class | Tablix | Represents the features for tablix items.
Class | TextBoxStyleContent | Represents the style content for a text box report item.
Class | TitleSettings | Represents a settings related to the document title, allowing configuration of whether the browser tab title can be updated by the designer.
Class | ToggleGridButton | Represents the settings for the toggle grid button.
Class | ToggleUnitsButton | Represents the settings for the toggle units button.
Class | ToolBarSettings | Represents a settings for the Tool Bar.
Class | ToolBox | Represents the Tool Box settings.
Class | ToolBoxContent | Represents report items on toolBox and their order.
Class | UpdateDocumentOptions | Represents the options for updating document information.
Class | ViewerSettings | Represents the settings for the viewer.
Class | ViewerSettings.ViewerDocumentInfo | Represents information about the document to be previewed in the viewer.

Enumerations

 | Enumeration | Description
Enumeration | DocumentType | Represents the document type.
Enumeration | ExpressionSyntax | Specifies the expression syntax used in Designer.
Enumeration | Level | Notification level. Determines the color and icons used for the notifications.
Enumeration | Mode | Specifies the default properties mode.
Enumeration | PlatformType | Represents the platform type.
Enumeration | Providers | Specifies the various data providers.
Enumeration | RdlxBarcodeSymbology | Represents the barcode symbology types available for RDLX.
Enumeration | RdlxToolBoxItem | Specifies the RDLX toolbox item types.
Enumeration | RpxToolBoxItem | Represents the RPX toolbox item types.
Enumeration | Sort | Specifies the default properties sort mode.
Enumeration | SupportedDocumentType | Specifies the type of documents supported by the AR Web Designer.
Enumeration | Units | Specifies the measurement units used in the Designer.
Enumeration | ViewerSettings.PreferredFormat | Enum representing preferred rendering formats.

See Also

Reference

MESCIUS.ActiveReports.Blazor.Designer Assembly


GrapeCity.ActiveReports.Blazor.Designer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Blazor.Designer Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Designer Assembly : GrapeCity.ActiveReports.Blazor.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Designer.About
GrapeCity.ActiveReports.Blazor.Designer.AboutButton
GrapeCity.ActiveReports.Blazor.Designer.App
GrapeCity.ActiveReports.Blazor.Designer.AppBarSettings
GrapeCity.ActiveReports.Blazor.Designer.Barcore
GrapeCity.ActiveReports.Blazor.Designer.BorderStyle
GrapeCity.ActiveReports.Blazor.Designer.BulletStyleContent
GrapeCity.ActiveReports.Blazor.Designer.ChangedDocumentOptions
GrapeCity.ActiveReports.Blazor.Designer.CommonValues
GrapeCity.ActiveReports.Blazor.Designer.ContainerStyleContent
GrapeCity.ActiveReports.Blazor.Designer.ContextActionsTab
GrapeCity.ActiveReports.Blazor.Designer.CreateDocumentInfo
GrapeCity.ActiveReports.Blazor.Designer.CreateDocumentOptions
GrapeCity.ActiveReports.Blazor.Designer.CurrentDocumentInfo
GrapeCity.ActiveReports.Blazor.Designer.Dashboard
GrapeCity.ActiveReports.Blazor.Designer.DataSets
GrapeCity.ActiveReports.Blazor.Designer.DataSetsInfo
GrapeCity.ActiveReports.Blazor.Designer.DataSettings
GrapeCity.ActiveReports.Blazor.Designer.DataSources
GrapeCity.ActiveReports.Blazor.Designer.DataSourcesOptions
GrapeCity.ActiveReports.Blazor.Designer.DataTab
GrapeCity.ActiveReports.Blazor.Designer.DesignerSettings
GrapeCity.ActiveReports.Blazor.Designer.Details
GrapeCity.ActiveReports.Blazor.Designer.Document
GrapeCity.ActiveReports.Blazor.Designer.DocumentExplorer
GrapeCity.ActiveReports.Blazor.Designer.Documents
GrapeCity.ActiveReports.Blazor.Designer.DocumentsSettings
GrapeCity.ActiveReports.Blazor.Designer.DocumentTemplate
GrapeCity.ActiveReports.Blazor.Designer.FileView
GrapeCity.ActiveReports.Blazor.Designer.Font
GrapeCity.ActiveReports.Blazor.Designer.FontHeader
GrapeCity.ActiveReports.Blazor.Designer.Footer
GrapeCity.ActiveReports.Blazor.Designer.Fpl
GrapeCity.ActiveReports.Blazor.Designer.Handlers
GrapeCity.ActiveReports.Blazor.Designer.Header
GrapeCity.ActiveReports.Blazor.Designer.Help
GrapeCity.ActiveReports.Blazor.Designer.HomeTab
GrapeCity.ActiveReports.Blazor.Designer.InitTemplates
GrapeCity.ActiveReports.Blazor.Designer.InsertTab
GrapeCity.ActiveReports.Blazor.Designer.Levels
GrapeCity.ActiveReports.Blazor.Designer.Library
GrapeCity.ActiveReports.Blazor.Designer.Link
GrapeCity.ActiveReports.Blazor.Designer.LocalizationResources
GrapeCity.ActiveReports.Blazor.Designer.Logo
GrapeCity.ActiveReports.Blazor.Designer.MasterReport
GrapeCity.ActiveReports.Blazor.Designer.Menu
GrapeCity.ActiveReports.Blazor.Designer.MenuIcon
GrapeCity.ActiveReports.Blazor.Designer.MenuSettings
GrapeCity.ActiveReports.Blazor.Designer.Msl
GrapeCity.ActiveReports.Blazor.Designer.Notifications
GrapeCity.ActiveReports.Blazor.Designer.OpenButton
GrapeCity.ActiveReports.Blazor.Designer.OpenDocumentInfo
GrapeCity.ActiveReports.Blazor.Designer.Panels
GrapeCity.ActiveReports.Blazor.Designer.Parameters
GrapeCity.ActiveReports.Blazor.Designer.ParametersTab
GrapeCity.ActiveReports.Blazor.Designer.PreviewSettings
GrapeCity.ActiveReports.Blazor.Designer.PropertiesModeButton
GrapeCity.ActiveReports.Blazor.Designer.PropertiesTab
GrapeCity.ActiveReports.Blazor.Designer.PropertyGridSettings
GrapeCity.ActiveReports.Blazor.Designer.RdlxReportItemsSettings
GrapeCity.ActiveReports.Blazor.Designer.RdlxSettings
GrapeCity.ActiveReports.Blazor.Designer.ReportItemStyle<T>
GrapeCity.ActiveReports.Blazor.Designer.ReportPartsSettings
GrapeCity.ActiveReports.Blazor.Designer.ReportStyles
GrapeCity.ActiveReports.Blazor.Designer.RequestInit
GrapeCity.ActiveReports.Blazor.Designer.RpxSettings
GrapeCity.ActiveReports.Blazor.Designer.Rulers
GrapeCity.ActiveReports.Blazor.Designer.RulersButton
GrapeCity.ActiveReports.Blazor.Designer.SaveAsButton
GrapeCity.ActiveReports.Blazor.Designer.SaveButton
GrapeCity.ActiveReports.Blazor.Designer.SaveDocumentInfo
GrapeCity.ActiveReports.Blazor.Designer.ScriptTab
GrapeCity.ActiveReports.Blazor.Designer.ServerSettings
GrapeCity.ActiveReports.Blazor.Designer.SharedDataSourceOptions
GrapeCity.ActiveReports.Blazor.Designer.Sidebar
GrapeCity.ActiveReports.Blazor.Designer.SnapStep
GrapeCity.ActiveReports.Blazor.Designer.SparklineStyleContent
GrapeCity.ActiveReports.Blazor.Designer.StatusBarSettings
GrapeCity.ActiveReports.Blazor.Designer.Stylesheet
GrapeCity.ActiveReports.Blazor.Designer.StylesSettings
GrapeCity.ActiveReports.Blazor.Designer.StylesTab
GrapeCity.ActiveReports.Blazor.Designer.Table
GrapeCity.ActiveReports.Blazor.Designer.TableGroups
GrapeCity.ActiveReports.Blazor.Designer.TableOfContentsStyleContent
GrapeCity.ActiveReports.Blazor.Designer.TableStyleContent
GrapeCity.ActiveReports.Blazor.Designer.TableStyles
GrapeCity.ActiveReports.Blazor.Designer.Tablix
GrapeCity.ActiveReports.Blazor.Designer.TextBoxStyleContent
GrapeCity.ActiveReports.Blazor.Designer.CellStyleContent
GrapeCity.ActiveReports.Blazor.Designer.TitleSettings
GrapeCity.ActiveReports.Blazor.Designer.ToggleGridButton
GrapeCity.ActiveReports.Blazor.Designer.ToggleUnitsButton
GrapeCity.ActiveReports.Blazor.Designer.ToolBarSettings
GrapeCity.ActiveReports.Blazor.Designer.ToolBox
GrapeCity.ActiveReports.Blazor.Designer.ToolBoxContent
GrapeCity.ActiveReports.Blazor.Designer.UpdateDocumentOptions
GrapeCity.ActiveReports.Blazor.Designer.ViewerSettings
GrapeCity.ActiveReports.Blazor.Designer.ViewerSettings.ViewerDocumentInfo
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Designer._Imports
GrapeCity.ActiveReports.Blazor.Designer.ReportDesigner

See Also

Reference

MESCIUS.ActiveReports.Blazor.Designer Assembly


Assembly Overview

MESCIUS.ActiveReports.Blazor.Viewer Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Blazor.Viewer |


_Imports Class Methods

[image]
ActiveReports 19 .NET Edition
_Imports Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace : _Imports Class

Glossary Item Box

For a list of all members of this type, see _Imports members.

See Also

Reference

_Imports Class
GrapeCity.ActiveReports.Blazor.Viewer Namespace


SetParametersAsync Method

[image]
ActiveReports 19 .NET Edition
SetParametersAsync Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > _Imports Class : SetParametersAsync Method

parameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function SetParametersAsync( _
   ByVal parameters As ParameterView _
) As Task
C#
public virtual Task SetParametersAsync(
   ParameterView parameters
)

Parameters

parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

_Imports Class
_Imports Members


SetParametersAsync Method

[image]
ActiveReports 19 .NET Edition
SetParametersAsync Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly > GrapeCity.ActiveReports.Blazor.Viewer Namespace > ReportViewer Class : SetParametersAsync Method

parameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function SetParametersAsync( _
   ByVal parameters As ParameterView _
) As Task
C#
public virtual Task SetParametersAsync(
   ParameterView parameters
)

Parameters

parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportViewer Class
ReportViewer Members


GrapeCity.ActiveReports.Blazor.Viewer Namespace

GrapeCity.ActiveReports.Blazor.Viewer Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly : GrapeCity.ActiveReports.Blazor.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | _Imports |
Class | Area | Represents a rectangular area defined by its position and dimensions.
Class | BookmarkInfo | Represents information about a bookmark in a document.
Class | ColorTheme | Represents a color theme.
Class | ColorThemeItem | Represents a base class for color theme items.
Class | ColorThemes | Predefined color themes.
Class | ErrorInfo | Represents detailed information about an error.
Class | ExportSetting | Represents a single setting used in the configuration of report export operations.
Class | InitializationOptions | Represents an options can be set during initialization.
Class | InitialZoomMode | Represents the settings for the initial zoom level.
Class | OnRequestInfo | Represents the information that can be used to modify or provide additional details for a web request, such as credentials and headers.
Class | Parameter | Represents a parameter used to run the report.
Class | ParameterDescriptor | Represents the descriptor of a report parameter.
Class | ParametersPanelSettings | Represents the settings for a parameters panel.
Class | ParameterValue | Represents a specific value for a report parameter.
Class | Range | Represents a specific range of text, defined by a starting position and the number of characters it encompasses.
Class | ReportInfo | Represents detailed information about a report.
Class | ReportServiceSettings | Represents the settings necessary for establishing a connection to a Web API.
Class | ReportViewer |
Class | SearchOptions | Represents the configuration options for performing text searches.
Class | SearchResult | Represents a search result, including details about the text appearance, its location, and its context.
Class | ShadesColorItem | Represents a color item with multiple shades.
Class | Sidebar | The viewer's sidebar, used to toggle its visibility.
Class | SingleColorItem | Represents a single color item in a color theme.
Class | ThemeSelector | Represents theme selector settings.
Class | ThemeSettings | Represents the UI theme settings for customizing the appearance.
Class | Toolbar | Represents the viewer's toolbar.
Class | ToolbarItem | Represents a toolbar item in a viewer's toolbar.
Class | ToolbarItems | Represents a collection of toolbar items in the viewer's toolbar.

Enumerations

 | Enumeration | Description
Enumeration | ColorThemeType | Specifies the type of the color theme.
Enumeration | ErrorSeverity | Describes the error severity levels.
Enumeration | ExportTypes | Defines the export types.
Enumeration | PanelsLocation | Defines the position of panels (search, parameters etc.).
Enumeration | ParameterPanelLocation | Defines the parameters panel location settings.
Enumeration | ParameterPanelOpen | Defines the parameters panel opening behavior.
Enumeration | RenderFormat | Specifies the render format for the report.
Enumeration | RenderMode | Defines the report render modes.
Enumeration | ReportType | Defines the report types.
Enumeration | SizeType | Defines the size types.
Enumeration | ViewMode | Defines the different paging modes.
Enumeration | ZoomMode | Defines the different zoom modes.

See Also

Reference

MESCIUS.ActiveReports.Blazor.Viewer Assembly


GrapeCity.ActiveReports.Blazor.Viewer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Blazor.Viewer Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Blazor.Viewer Assembly : GrapeCity.ActiveReports.Blazor.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Blazor.Viewer.Area
GrapeCity.ActiveReports.Blazor.Viewer.BookmarkInfo
GrapeCity.ActiveReports.Blazor.Viewer.ColorTheme
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemeItem
GrapeCity.ActiveReports.Blazor.Viewer.ShadesColorItem
GrapeCity.ActiveReports.Blazor.Viewer.SingleColorItem
GrapeCity.ActiveReports.Blazor.Viewer.ColorThemes
GrapeCity.ActiveReports.Blazor.Viewer.ErrorInfo
GrapeCity.ActiveReports.Blazor.Viewer.ExportSetting
GrapeCity.ActiveReports.Blazor.Viewer.InitializationOptions
GrapeCity.ActiveReports.Blazor.Viewer.InitialZoomMode
GrapeCity.ActiveReports.Blazor.Viewer.OnRequestInfo
GrapeCity.ActiveReports.Blazor.Viewer.Parameter
GrapeCity.ActiveReports.Blazor.Viewer.ParameterDescriptor
GrapeCity.ActiveReports.Blazor.Viewer.ParametersPanelSettings
GrapeCity.ActiveReports.Blazor.Viewer.ParameterValue
GrapeCity.ActiveReports.Blazor.Viewer.Range
GrapeCity.ActiveReports.Blazor.Viewer.ReportInfo
GrapeCity.ActiveReports.Blazor.Viewer.ReportServiceSettings
GrapeCity.ActiveReports.Blazor.Viewer.SearchOptions
GrapeCity.ActiveReports.Blazor.Viewer.SearchResult
GrapeCity.ActiveReports.Blazor.Viewer.Sidebar
GrapeCity.ActiveReports.Blazor.Viewer.ThemeSelector
GrapeCity.ActiveReports.Blazor.Viewer.ThemeSettings
GrapeCity.ActiveReports.Blazor.Viewer.Toolbar
GrapeCity.ActiveReports.Blazor.Viewer.ToolbarItem
GrapeCity.ActiveReports.Blazor.Viewer.ToolbarItems
Microsoft.AspNetCore.Components.ComponentBase
GrapeCity.ActiveReports.Blazor.Viewer._Imports
GrapeCity.ActiveReports.Blazor.Viewer.ReportViewer

See Also

Reference

MESCIUS.ActiveReports.Blazor.Viewer Assembly


Assembly Overview

MESCIUS.ActiveReports.Chart Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Chart | The GrapeCity.ActiveReports.Chart namespace contains the chart classes.
GrapeCity.ActiveReports.Chart.Annotations | The GrapeCity.ActiveReports.Chart.Annotations namespace contains the chart annotations classes.
GrapeCity.ActiveReports.Chart.Core |
GrapeCity.ActiveReports.Chart.Drawing |
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D |
GrapeCity.ActiveReports.Chart.Drawing.Imaging |
GrapeCity.ActiveReports.Chart.Graphics | The GrapeCity.ActiveReports.Chart.Graphics namespace contains the chart graphics components and settings.
GrapeCity.ActiveReports.Chart.Parser |


AnnotationLine Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationLine Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : AnnotationLine Constructor

Glossary Item Box

Initializes a new instance of the AnnotationLine class.

Overload List

Overload | Description
AnnotationLine Constructor | Initializes a new instance of the AnnotationLine class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationTextBar Constructor

[image]
ActiveReports 19 .NET Edition
AnnotationTextBar Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnnotationTextBar Constructor

Glossary Item Box

Initializes a new instance of the AnnotationTextBar class.

Overload List

Overload | Description
AnnotationTextBar Constructor | Initializes new instance of AnnotationTextBar object with all properties set to its defaults.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


GrapeCity.ActiveReports.Chart.Annotations Namespace

GrapeCity.ActiveReports.Chart.Annotations Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Annotations Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Chart.Annotations namespace contains the chart annotations classes.

Classes

 | Class | Description
Class | Annotation | Represents the base class for all of the annotation classes.
Class | AnnotationLine | Represents the settings for the AnnotationLine class.
Class | AnnotationsCollection | Represents the settings of the AnnotationsCollection class.
Class | AnnotationTextBar | Represents the settings for the AnnotationTextBar class.

Enumerations

 | Enumeration | Description
Enumeration | AnchorPlacementType | Specifies how an annotation bar anchors to the position of an Annotation.

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Annotations Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Annotations Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Annotations Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.MouseEnabledItem
GrapeCity.ActiveReports.Chart.MouseEnabledComponent
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.Annotations.AnnotationsCollection

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Clear Method

Glossary Item Box

Clears all axes from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : RemoveAt Method

index

The index of the axis to remove.

Glossary Item Box

Removes the specified axis from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

The index of the axis to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxesCollection Class
AxesCollection Members


AxisScroll Constructor

[image]
ActiveReports 19 .NET Edition
AxisScroll Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : AxisScroll Constructor

Glossary Item Box

Initializes a new instance of the AxisScroll class.

Overload List

Overload | Description
AxisScroll Constructor | Initializes a new instance of the AxisScroll class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisScroll Class
AxisScroll Members


Axis Constructor

[image]
ActiveReports 19 .NET Edition
Axis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Axis Constructor

Glossary Item Box

Initializes an instance of the Axis class.

Overload List

Overload | Description
Axis Constructor | Creates default (numerical) axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


GrapeCity.ActiveReports.Chart.Core Namespace

GrapeCity.ActiveReports.Chart.Core Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Core Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Core Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Core Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Core Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


CustomAxis Constructor

[image]
ActiveReports 19 .NET Edition
CustomAxis Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : CustomAxis Constructor

Glossary Item Box

Initializes a new instance of the CustomAxis class.

Overload List

Overload | Description
CustomAxis Constructor | Creates default axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAxis Class
CustomAxis Members


CanConvertFrom Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : CanConvertFrom Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


CanConvertTo Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : CanConvertTo Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFrom Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertFrom Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetProperties Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetStandardValues Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetStandardValuesExclusive Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : GetStandardValuesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection.Converter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection.Converter Class
DataPointsCollection.Converter Members
Overload List


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetProperties Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public virtual PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetStandardValues Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public virtual TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetStandardValuesExclusive Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : GetStandardValuesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray.Converter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleArray.Converter Class
DoubleArray.Converter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetProperties Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverterWithAuto Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverterWithAuto Class
DoubleConverterWithAuto Members
Overload List


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetProperties Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public virtual PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetStandardValues Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public virtual TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetStandardValuesExclusive Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : GetStandardValuesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleConverter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members
Overload List


GraphicsPath Constructor

[image]
ActiveReports 19 .NET Edition
GraphicsPath Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace > GraphicsPath Class : GraphicsPath Constructor

Glossary Item Box

Overload List

Overload | Description
GraphicsPath Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsPath Class
GraphicsPath Members


GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace

GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace

Glossary Item Box

Classes

 | Class | Description
Class | GraphicsPath | Cross-platform graphics path implementation. Represents a series of connected lines and curves.

Enumerations

 | Enumeration | Description
Enumeration | HatchStyle | See System.Drawing.Drawing2D.HatchStyle

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing.Drawing2D Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Drawing2D.GraphicsPath

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace

GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ImageFormat |

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing.Imaging Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Imaging.ImageFormat

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


Region Constructor

[image]
ActiveReports 19 .NET Edition
Region Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Drawing Namespace > Region Class : Region Constructor

Glossary Item Box

Overload List

Overload | Description
Region Constructor | Initializes a new Region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Region Class
Region Members


GrapeCity.ActiveReports.Chart.Drawing Namespace

GrapeCity.ActiveReports.Chart.Drawing Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Font | GDI-like font descriptor.
Class | Image | GDI-like image descriptor.
Class | Region | Cross-platform range implementation. Describes the interior of a graphics shape composed of rectangles and paths.

Enumerations

 | Enumeration | Description
Enumeration | FontStyle |
Enumeration | GraphicsUnit |

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Drawing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Drawing Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Drawing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Drawing.Font
GrapeCity.ActiveReports.Chart.Drawing.Image
GrapeCity.ActiveReports.Chart.Drawing.Region

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetStandardValues Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public virtual TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetStandardValuesExclusive Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : GetStandardValuesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.Converter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.Converter Class
Line.Converter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValues Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : GetStandardValues Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValues(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
C#
public virtual TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValuesExclusive Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : GetStandardValuesExclusive Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValuesExclusive(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesExclusive( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValuesSupported Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : GetStandardValuesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line.SeriesLineConverter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line.SeriesLineConverter Class
Line.SeriesLineConverter Members
Overload List


GrapeCity.ActiveReports.Chart.Graphics Namespace

GrapeCity.ActiveReports.Chart.Graphics Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Graphics Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Chart.Graphics namespace contains the chart graphics components and settings.

Classes

 | Class | Description
Class | Backdrop | Specifies the settings used to draw the background of the Chart object.
Class | DrawParams |
Class | ImageMap | ImageMap class provides mapping from image coordinates to Shapes
Class | Line | Holds all of the visual attributes of a Line object.
Class | Line.Converter | The type converter for Line.
Class | Line.SeriesLineConverter | The type converter for series lines.
Class | Point2d | Specifies a point in two dimensions.
Class | Point3d | Specifies a point in 3 dimensional geometric space.
Class | ShapeArea | ImageMap entry
Class | TextStyle | Specified text output settings

Structures

 | Structure | Description
Structure | Bar | Stores the location and size of the Bar area.

Enumerations

 | Enumeration | Description
Enumeration | AntiAliasMode | Specifies the antialiasing settings used to draw the object.
Enumeration | BackdropStyle | Specifies the style used to draw the backdrop of an object.
Enumeration | GradientType | Specifies the type of gradient to draw.
Enumeration | LineStyle | Specifies the line style to use.
Enumeration | PicturePutStyle | Specifies how the image is aligned inside the backdrop.
Enumeration | ProjectionType | Specifies the projection type used.
Enumeration | TextAlign | Specifies how text is aligned within its rectangle.
Enumeration | TextAnchor | Specifies how the text shape anchors to its position.

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Graphics Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Graphics Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Graphics Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.DrawParams
GrapeCity.ActiveReports.Chart.Graphics.ImageMap
GrapeCity.ActiveReports.Chart.Graphics.ShapeArea
GrapeCity.ActiveReports.Chart.Graphics.TextStyle
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem
GrapeCity.ActiveReports.Chart.Graphics.Line
GrapeCity.ActiveReports.Chart.Graphics.Point2d
GrapeCity.ActiveReports.Chart.Graphics.Point3d
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
GrapeCity.ActiveReports.Chart.TxExpandableObjectConverter
GrapeCity.ActiveReports.Chart.Graphics.Line.Converter
GrapeCity.ActiveReports.Chart.Graphics.Line.SeriesLineConverter
System.ValueType
GrapeCity.ActiveReports.Chart.Graphics.Bar

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFromString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertFromString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertFromString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertFromString Method : ConvertFromString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertTo(Object,Type) Method

[image]
ActiveReports 19 .NET Edition
ConvertTo(Object,Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertTo Method : ConvertTo(Object,Type) Method

value
destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertTo( _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
C#
public object ConvertTo(
   object value,
   Type destinationType
)

Parameters

value
destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertToInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertToInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertToInvariantString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertToInvariantString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToInvariantString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertToInvariantString Method : ConvertToInvariantString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToInvariantString( _
   ByVal value As Object _
) As String
C#
public string ConvertToInvariantString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertToString Method

[image]
ActiveReports 19 .NET Edition
ConvertToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : ConvertToString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertToString(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertToString Method : ConvertToString(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


ConvertToString(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertToString(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > ConvertToString Method : ConvertToString(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertToString( _
   ByVal value As Object _
) As String
C#
public string ConvertToString(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


CreateInstance Method

[image]
ActiveReports 19 .NET Edition
CreateInstance Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : CreateInstance Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


CreateInstance(IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CreateInstance Method : CreateInstance(IDictionary) Method

propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateInstance( _
   ByVal propertyValues As IDictionary _
) As Object
C#
public object CreateInstance(
   IDictionary propertyValues
)

Parameters

propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
ActiveReports 19 .NET Edition
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
C#
public virtual object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
propertyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetCreateInstanceSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetCreateInstanceSupported() Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetCreateInstanceSupported() As Boolean
C#
public bool GetCreateInstanceSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetProperties Method

[image]
ActiveReports 19 .NET Edition
GetProperties Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetProperties Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetProperties(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
value
attributes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
C#
public virtual PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
value
attributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetProperties(Object) Method

[image]
ActiveReports 19 .NET Edition
GetProperties(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetProperties Method : GetProperties(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProperties( _
   ByVal value As Object _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetProperties(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetPropertiesSupported Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : GetPropertiesSupported Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


GetPropertiesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetPropertiesSupported Method : GetPropertiesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPropertiesSupported() As Boolean
C#
public bool GetPropertiesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
ActiveReports 19 .NET Edition
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
C#
public virtual bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValues() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValues() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValues Method : GetStandardValues() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValues() As ICollection
C#
public ICollection GetStandardValues()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValuesExclusive() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesExclusive() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValuesExclusive Method : GetStandardValuesExclusive() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesExclusive() As Boolean
C#
public bool GetStandardValuesExclusive()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GetStandardValuesSupported() Method

[image]
ActiveReports 19 .NET Edition
GetStandardValuesSupported() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetStandardValuesSupported() As Boolean
C#
public bool GetStandardValuesSupported()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


IsValid Method

[image]
ActiveReports 19 .NET Edition
IsValid Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class : IsValid Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members


IsValid(ITypeDescriptorContext,Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(ITypeDescriptorContext,Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > IsValid Method : IsValid(ITypeDescriptorContext,Object) Method

context
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsValid( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
C#
public virtual bool IsValid(
   ITypeDescriptorContext context,
   object value
)

Parameters

context
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


IsValid(Object) Method

[image]
ActiveReports 19 .NET Edition
IsValid(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphReferenceConverter Class > IsValid Method : IsValid(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsValid( _
   ByVal value As Object _
) As Boolean
C#
public bool IsValid(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphReferenceConverter Class
GraphReferenceConverter Members
Overload List


GraphXmlNonSerializableAttribute Class Methods

[image]
ActiveReports 19 .NET Edition
GraphXmlNonSerializableAttribute Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlNonSerializableAttribute Class

Glossary Item Box

For a list of all members of this type, see GraphXmlNonSerializableAttribute members.

See Also

Reference

GraphXmlNonSerializableAttribute Class
GrapeCity.ActiveReports.Chart Namespace


GraphXmlNonSerializableAttribute Class Properties

[image]
ActiveReports 19 .NET Edition
GraphXmlNonSerializableAttribute Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphXmlNonSerializableAttribute Class

Glossary Item Box

For a list of all members of this type, see GraphXmlNonSerializableAttribute members.

See Also

Reference

GraphXmlNonSerializableAttribute Class
GrapeCity.ActiveReports.Chart Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : Equals Method

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Glossary Item Box

Returns a value that indicates whether this instance is equal to a specified object.

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Return Value

true if obj and this instance are of the same type and have identical field values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : GetHashCode Method

Glossary Item Box

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


IsDefaultAttribute Method

[image]
ActiveReports 19 .NET Edition
IsDefaultAttribute Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : IsDefaultAttribute Method

Glossary Item Box

When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.

Syntax

Visual Basic (Declaration)
Public Function IsDefaultAttribute() As Boolean
C#
public bool IsDefaultAttribute()

Return Value

true if this instance is the default attribute for the class; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


Match Method

[image]
ActiveReports 19 .NET Edition
Match Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : Match Method

obj
An System.Object to compare with this instance of System.Attribute.

Glossary Item Box

When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.

Syntax

Visual Basic (Declaration)
Public Function Match( _
   ByVal obj As Object _
) As Boolean
C#
public bool Match(
   object obj
)

Parameters

obj
An System.Object to compare with this instance of System.Attribute.

Return Value

true if this instance equals obj; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


TypeId Property

[image]
ActiveReports 19 .NET Edition
TypeId Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphXmlNonSerializableAttribute Class : TypeId Property

Glossary Item Box

When implemented in a derived class, gets a unique identifier for this System.Attribute.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeId As Object
C#
public object TypeId {get;}

Property Value

An System.Object that is a unique identifier for the attribute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphXmlNonSerializableAttribute Class
GraphXmlNonSerializableAttribute Members


BeginInit Method

[image]
ActiveReports 19 .NET Edition
BeginInit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : BeginInit Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub BeginInit()
C#
void BeginInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Sub Dispose()
C#
void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


EndInit Method

[image]
ActiveReports 19 .NET Edition
EndInit Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > ISharpGraph Interface : EndInit Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Sub EndInit()
C#
void EndInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISharpGraph Interface
ISharpGraph Members


LegendItemsCollection Constructor

[image]
ActiveReports 19 .NET Edition
LegendItemsCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : LegendItemsCollection Constructor

Glossary Item Box

Initializes a new instance of the LegendItemsCollection class.

Overload List

Overload | Description
LegendItemsCollection Constructor | Initializes new instance of the LegendItemsCollection class

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItem Constructor

[image]
ActiveReports 19 .NET Edition
LegendItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : LegendItem Constructor

Glossary Item Box

Initializes a new instance of the LegendItem class.

Overload List

Overload | Description
LegendItem Constructor | Initializes new instance of the LegendItem class

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendItem Class
LegendItem Members


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendsCollection Class
LegendsCollection Members


Legend Constructor

[image]
ActiveReports 19 .NET Edition
Legend Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Legend Constructor

Glossary Item Box

Initializes a new instance of the Legend class.

Overload List

Overload | Description
Legend Constructor | Initializes new instance of the LegendItem object with the default properties set

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Legend Class
Legend Members


GrapeCity.ActiveReports.Chart.Parser Namespace

GrapeCity.ActiveReports.Chart.Parser Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Parser Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart.Parser Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Parser Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart.Parser Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Series Constructor

[image]
ActiveReports 19 .NET Edition
Series Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Series Constructor

Glossary Item Box

Initializes a new instance of the Series class.

Overload List

Overload | Description
Series Constructor | Creates default series

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TitlesCollection Class
TitlesCollection Members


Title Constructor

[image]
ActiveReports 19 .NET Edition
Title Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Title Constructor

Glossary Item Box

Initializes a new instance of the Title class.

Overload List

Overload | Description
Title Constructor | Initializes new instance of the Title object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Title Class
Title Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


WallRange Constructor

[image]
ActiveReports 19 .NET Edition
WallRange Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : WallRange Constructor

Glossary Item Box

Initializes a new instance of the WallRange object.

Overload List

Overload | Description
WallRange Constructor | Initializes new instance of the WallRange class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WallRange Class
WallRange Members


GrapeCity.ActiveReports.Chart Namespace

GrapeCity.ActiveReports.Chart Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Chart namespace contains the chart classes.

Classes

 | Class | Description
Class | AxesCollection | Represents a collection of axis.
Class | Axis | Represents the axis of the chart.
Class | AxisBase | Represents the set of properties of an axis.
Class | AxisScroll | Represents the scroll bar on an axis.
Class | BackdropItem | Represents the backdrop that acts as a separate item and handles mouse events.
Class | Border | Represents the information required to draw the borders of the graph.
Class | BorderSizes | Describes the size of the border around the rectangular area.
Class | ChartArea | Specifies the properties of the chart area.
Class | ChartAreasCollection | Specifies the settings for the chart areas collection.
Class | ChartTypeConfig | Represents the settings for the ChartTypeConfig object.
Class | CustomAxis | Represents the properties of a custom axis.
Class | CustomDrawEventArgs | Represents the properties of the custom draw event arguments for the chart.
Class | CustomProperties | Represents the set of custom properties for the chart.
Class | DataPoint | Represents the set of properties for a data point.
Class | DataPointsCollection | Specifies the settings for the DataPoints collection.
Class | DataPointsCollection.Converter | Provides a way to process converting of instances ot DataPointsCollection class.
Class | DoubleArray | Represents the settings for the DoubleArray class.
Class | DoubleArray.Converter | Provides a way to process converting of instances ot DoubleArray class.
Class | DoubleConverter | this class is created to fix error of visualization in vs.net property grid values like 0.2 of double
Class | DoubleConverterWithAuto | Converter for double with "automatic calculate" values support.
Class | FontInfo | Represents the settings for the FontInfo class.
Class | GraphMouseEventArgs | Represents the properties of the mouse event arguments for the chart.
Class | GraphReferenceConverter | Provides a unified way to process converting.
Class | GraphXmlNonSerializableAttribute |
Class | GraphXmlSerializationContext | Represents contextual information about a serialization, such as its DirectionType, document and other.
Class | GridLayout | Represents the settings for the GridLayout object.
Class | HitTest | Represents the properties of the HitTest object.
Class | KeyValuePair | Represents the settings for the KeyValuePair object.
Class | LabelInfo | Represents the settings for the LabelInfo class.
Class | LabelsCollection | Specifies the settings for the labels collection.
Class | Legend | Represents the settings for the Legend object.
Class | LegendItem | Represents the settings for the LegendItem object.
Class | LegendItemsCollection | Represents the settings for the LegendItemsCollection class.
Class | LegendsCollection | Represents the settings for the LegendsCollection class.
Class | Light | Represents the settings of the Light object.
Class | Marker | Represents the settings for the Marker object.
Class | PlaneItem | Represents the settings for the PlaneItem object used for the chart walls.
Class | Projection | Represents the settings of the geometric Projection object.
Class | Series | Represents the settings for the Series object.
Class | SeriesCollection | Represents the settings for the SeriesCollection class.
Class | SharpGraphCore |
Class | Tick | Represents the settings of the Tick object.
Class | Title | Represents the settings for the Title object.
Class | TitlesCollection | Represents the settings for the TitlesCollection object.
Class | WallRange | Represents the settings of the WallRange object.
Class | WallRangesCollection | Represents the settings of the WallRangesCollection object.
Class | XmlDataProvider | Provides access to XML data.

Interfaces

 | Interface | Description
Interface | IChartMemberNameProvider | Provides a name for the chart member name provider.
Interface | ISharpGraph |

Structures

 | Structure | Description
Structure | Padding | Provides the settings used to set a margin (four edges) inside a control.

Delegates

 | Delegate | Description
Delegate | CustomDrawEventHandler | Represents the method that handles the CustomDraw event.
Delegate | GraphMouseEventHandler | Represents the method that handles the GraphMouse event.

Enumerations

 | Enumeration | Description
Enumeration | Alignment | Specifies how the text item anchors to its position.
Enumeration | ArrowType | Specifies the arrow type used for the axis line.
Enumeration | AxisType | Specifies the axis type.
Enumeration | BarType | Specifies the type of bars to use.
Enumeration | BaseStyle | Gets or sets a circular or square base drawing style for the 3D funnel chart or 3D pyramid chart.
Enumeration | ChartType | Specifies the ChartType used for the Series.
Enumeration | ColorPalette | Specifies what color palette is used.
Enumeration | DeviceModes | Specifies the device drawing mode used to render the chart.
Enumeration | DockType | Specifies the docking area.
Enumeration | FunnelStyle | Specifies whether the Y value for the series points to the width or the height of the funnel. The default value is YIsHeight.
Enumeration | LabelsPlacement | Specifies whether the data point labels appear on the left or right side of the funnel or pyramid chart.
Enumeration | LegendMode | Specifies the mode used to render legend items.
Enumeration | LightType | Specifies the type of light source used.
Enumeration | MarkerStyle | Specifies the shape of the marker.
Enumeration | StandardAxis | Specifies which axis is the standard axis.
Enumeration | StdLegendMarker | Specifies the standard legend marker shape to use.
Enumeration | UICommand | Specifies the command to be used for the DoCommand method of the Chart control.
Enumeration | UIOptions | Specifies the user interface settings for the Chart control.

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


GrapeCity.ActiveReports.Chart Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Chart Assembly : GrapeCity.ActiveReports.Chart Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.BorderSizes
GrapeCity.ActiveReports.Chart.ChartTypeConfig
GrapeCity.ActiveReports.Chart.GraphXmlSerializationContext
GrapeCity.ActiveReports.Chart.HitTest
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.Border
GrapeCity.ActiveReports.Chart.CustomProperties
GrapeCity.ActiveReports.Chart.DataPoint
GrapeCity.ActiveReports.Chart.DoubleArray
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.DrawCustomizableComponent
GrapeCity.ActiveReports.Chart.ChartArea
GrapeCity.ActiveReports.Chart.Legend
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem
GrapeCity.ActiveReports.Chart.LabelInfo
GrapeCity.ActiveReports.Chart.MouseEnabledItem
GrapeCity.ActiveReports.Chart.Marker
GrapeCity.ActiveReports.Chart.MouseEnabledComponent
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis
GrapeCity.ActiveReports.Chart.CustomAxis
GrapeCity.ActiveReports.Chart.Series
GrapeCity.ActiveReports.Chart.Title
GrapeCity.ActiveReports.Chart.WallRange
GrapeCity.ActiveReports.Chart.PlaneItem
GrapeCity.ActiveReports.Chart.FontInfo
GrapeCity.ActiveReports.Chart.GridLayout
GrapeCity.ActiveReports.Chart.ItemComponent
GrapeCity.ActiveReports.Chart.AxisScroll
GrapeCity.ActiveReports.Chart.LegendItem
GrapeCity.ActiveReports.Chart.Light
GrapeCity.ActiveReports.Chart.Projection
GrapeCity.ActiveReports.Chart.Tick
GrapeCity.ActiveReports.Chart.KeyValuePair
GrapeCity.ActiveReports.Chart.LabelsCollection
GrapeCity.ActiveReports.Chart.SharpGraphCore
GrapeCity.ActiveReports.Chart.XmlDataProvider
System.Attribute
GrapeCity.ActiveReports.Chart.GraphXmlNonSerializableAttribute
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.AxesCollection
GrapeCity.ActiveReports.Chart.ChartAreasCollection
GrapeCity.ActiveReports.Chart.DataPointsCollection
GrapeCity.ActiveReports.Chart.LegendItemsCollection
GrapeCity.ActiveReports.Chart.LegendsCollection
GrapeCity.ActiveReports.Chart.SeriesCollection
GrapeCity.ActiveReports.Chart.TitlesCollection
GrapeCity.ActiveReports.Chart.WallRangesCollection
System.ComponentModel.TypeConverter
GrapeCity.ActiveReports.Chart.DoubleArray.Converter
GrapeCity.ActiveReports.Chart.DoubleConverter
GrapeCity.ActiveReports.Chart.DoubleConverterWithAuto
GrapeCity.ActiveReports.Chart.GraphReferenceConverter
System.ComponentModel.ExpandableObjectConverter
GrapeCity.ActiveReports.Chart.DataPointsCollection.Converter
System.EventArgs
GrapeCity.ActiveReports.Chart.CustomDrawEventArgs
GrapeCity.ActiveReports.Chart.GraphMouseEventArgs
System.ValueType
GrapeCity.ActiveReports.Chart.Padding

See Also

Reference

MESCIUS.ActiveReports.Chart Assembly


Assembly Overview

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.Enterprise.Data.DataEngine |
GrapeCity.Enterprise.Data.DataEngine.Aggregates |
GrapeCity.Enterprise.Data.DataEngine.DataProcessing |
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation |
GrapeCity.Enterprise.Data.DataEngine.Expressions |
GrapeCity.Enterprise.Data.DataEngine.Extensions |


Accumulate Method

[image]
ActiveReports 19 .NET Edition
Accumulate Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace > Aggregate Structure : Accumulate Method

Glossary Item Box

Accumulates value into aggregate state.

Overload List

Overload | Description
Accumulate | Accumulates value into aggregate state.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Aggregate Structure
Aggregate Members


GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace

GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace

Glossary Item Box

Classes

 | Class | Description
Class | AggregateDataProviderExtension | Contains operations over IAggregateDataProvider
Class | AggregateFunctions | Mapper for aggregate functions names.
Class | AggregateHelper | Provides utility methods for working with aggregate functions in conjunction with the GrapeCity.Enterprise.Data.Expressions.ExpressionInfo instances.
Class | AggregateInfo | Represents an aggregate function in an expression.

Interfaces

 | Interface | Description
Interface | IAggregateDataProvider | Contract for the describing ot the aggregate fields in semantic data provider.

Structures

 | Structure | Description
Structure | Aggregate | Represents the state of the aggregate function.

Enumerations

 | Enumeration | Description
Enumeration | AggregateFunction | Specifies the available intrinsic aggregate function names

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Aggregates Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateDataProviderExtension
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateFunctions
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateHelper
GrapeCity.Enterprise.Data.DataEngine.Aggregates.AggregateInfo
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.Aggregates.Aggregate

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


DataEngineException Class Methods

[image]
ActiveReports 19 .NET Edition
DataEngineException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataEngineException Class

Glossary Item Box

For a list of all members of this type, see DataEngineException members.

See Also

Reference

DataEngineException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


DataEngineException Class Properties

[image]
ActiveReports 19 .NET Edition
DataEngineException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : DataEngineException Class

Glossary Item Box

For a list of all members of this type, see DataEngineException members.

See Also

Reference

DataEngineException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataEngineException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngineException Class
DataEngineException Members


GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace

GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace

Glossary Item Box

Classes

 | Class | Description
Class | TablixExtensions | Helper methods for tablix members hierarchy.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.DataProcessing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataProcessing.TablixExtensions

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


Run Method

[image]
ActiveReports 19 .NET Edition
Run Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > DataProcessor Class : Run Method

Glossary Item Box

Executes specified report.

Overload List

Overload | Description
Run | Executes specified report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProcessor Class
DataProcessor Members


Def.Report Class Fields

[image]
ActiveReports 19 .NET Edition
Def.Report Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.Report Class

Glossary Item Box

For a list of all members of this type, see Def.Report members.

See Also

Reference

Def.Report Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Def.SimpleRegion Class Fields

[image]
ActiveReports 19 .NET Edition
Def.SimpleRegion Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : Def.SimpleRegion Class

Glossary Item Box

For a list of all members of this type, see Def.SimpleRegion members.

See Also

Reference

Def.SimpleRegion Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Eval.CompileContext Constructor

[image]
ActiveReports 19 .NET Edition
Eval.CompileContext Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval.CompileContext Class : Eval.CompileContext Constructor

Glossary Item Box

Overload List

Overload | Description
Eval.CompileContext Constructor | Creates new instance on CompileContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval.CompileContext Class
Eval.CompileContext Members


Compile Method

[image]
ActiveReports 19 .NET Edition
Compile Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace > Eval Class : Compile Method

Glossary Item Box

Compiles given expression to be evaluated within Eval.Context.

Overload List

Overload | Description
Compile | Compiles given expression to be evaluated within Eval.Context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Eval Class
Eval Members


IExpressionContext Interface Methods

[image]
ActiveReports 19 .NET Edition
IExpressionContext Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace : IExpressionContext Interface

Glossary Item Box

For a list of all members of this type, see IExpressionContext members.

See Also

Reference

IExpressionContext Interface
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace


GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace

GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Eval | Expression evaluation facility based on compilation of expression to lambda function.
Class | Eval.CompileContext | Defines expression compilation context.
Class | Field | Defines field proxy class to be used in the expression computation process.

Interfaces

 | Interface | Description
Interface | Eval.IContext | Defines expression evaluation context.
Interface | IExpressionContext | Defines application context used to extend expression evaluation context.

Delegates

 | Delegate | Description
Delegate | Eval.EvalFn | Signature of eval function.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Eval
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Eval.CompileContext
GrapeCity.Enterprise.Data.DataEngine.ExpressionEvaluation.Field

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace

GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ExpressionExtensions | Provides additional methods to work with expressions

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Expressions Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Expressions.ExpressionExtensions

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


IBuffer<T> Interface Properties

[image]
ActiveReports 19 .NET Edition
IBuffer<T> Interface Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace : IBuffer<T> Interface

Glossary Item Box

For a list of all members of this type, see IBuffer<T> members.

See Also

Reference

IBuffer<T> Interface
GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace > IBuffer<T> Interface : Count Property

Glossary Item Box

Gets the number of elements in the collection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Property Value

The number of elements in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuffer<T> Interface
IBuffer<T> Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace > IBuffer<T> Interface : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Sub Dispose()
C#
void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuffer<T> Interface
IBuffer<T> Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace > IBuffer<T> Interface : Item Property

index
The zero-based index of the element to get.

Glossary Item Box

Gets the element at the specified index in the read-only list.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As T
C#
T this[
   int index
]; {get;}

Parameters

index
The zero-based index of the element to get.

Property Value

The element at the specified index in the read-only list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuffer<T> Interface
IBuffer<T> Members


GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace

GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace

Glossary Item Box

Classes

 | Class | Description
Class | MemoizeEnumerableExtensions | Represents Memoize methods to work with collection buffers

Interfaces

 | Interface | Description
Interface | IBuffer<T> | Represents a buffer exposing a shared view over an underlying enumerable sequence.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine.Extensions Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.Extensions.MemoizeEnumerableExtensions

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


InteractiveSortState Class Properties

[image]
ActiveReports 19 .NET Edition
InteractiveSortState Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InteractiveSortState Class

Glossary Item Box

For a list of all members of this type, see InteractiveSortState members.

See Also

Reference

InteractiveSortState Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Add Method

key
The key of the element to add.
value
The value of the element to add. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Adds the specified key and value to the dictionary.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal key As Integer, _
   ByVal value As InteractiveSort _
)
C#
public void Add(
   int key,
   InteractiveSort value
)

Parameters

key
The key of the element to add.
value
The value of the element to add. The value can be a null reference (Nothing in Visual Basic) for reference types.

Exceptions

Exception | Description
System.ArgumentNullException | key is a null reference (Nothing in Visual Basic).
System.ArgumentException | An element with the same key already exists in the Dictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Clear Method

Glossary Item Box

Removes all keys and values from the Dictionary.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Comparer Property

[image]
ActiveReports 19 .NET Edition
Comparer Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Comparer Property

Glossary Item Box

Gets the IEqualityComparer that is used to determine equality of keys for the dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Comparer As IEqualityComparer(Of TKey)
C#
public IEqualityComparer<TKey> Comparer {get;}

Property Value

The IEqualityComparer generic interface implementation that is used to determine equality of keys for the current Dictionary and to provide hash values for the keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


ContainsKey Method

[image]
ActiveReports 19 .NET Edition
ContainsKey Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : ContainsKey Method

key
The key to locate in the Dictionary.

Glossary Item Box

Determines whether the Dictionary contains the specified key.

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As Integer _
) As Boolean
C#
public bool ContainsKey(
   int key
)

Parameters

key
The key to locate in the Dictionary.

Return Value

true if the Dictionary contains an element with the specified key; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | key is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


ContainsValue Method

[image]
ActiveReports 19 .NET Edition
ContainsValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : ContainsValue Method

value
The value to locate in the Dictionary. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Determines whether the Dictionary contains a specific value.

Syntax

Visual Basic (Declaration)
Public Function ContainsValue( _
   ByVal value As InteractiveSort _
) As Boolean
C#
public bool ContainsValue(
   InteractiveSort value
)

Parameters

value
The value to locate in the Dictionary. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if the Dictionary contains an element with the specified value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Count Property

Glossary Item Box

Gets the number of key/value pairs contained in the Dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of key/value pairs contained in the Dictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : GetObjectData Method

info
A System.Runtime.Serialization.SerializationInfo object that contains the information required to serialize the Dictionary instance.
context
A System.Runtime.Serialization.StreamingContext structure that contains the source and destination of the serialized stream associated with the Dictionary instance.

Glossary Item Box

Implements the System.Runtime.Serialization.ISerializable interface and returns the data needed to serialize the Dictionary instance.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
A System.Runtime.Serialization.SerializationInfo object that contains the information required to serialize the Dictionary instance.
context
A System.Runtime.Serialization.StreamingContext structure that contains the source and destination of the serialized stream associated with the Dictionary instance.

Exceptions

Exception | Description
System.ArgumentNullException | info is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Item Property

key
The key of the value to get or set.

Glossary Item Box

Gets or sets the value associated with the specified key.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal key As Integer _
) As InteractiveSort
C#
public InteractiveSort this[
   int key
]; {get; set;}

Parameters

key
The key of the value to get or set.

Property Value

The value associated with the specified key. If the specified key is not found, a get operation throws a System.Collections.Generic.KeyNotFoundException, and a set operation creates a new element with the specified key.

Exceptions

Exception | Description
System.ArgumentNullException | key is a null reference (Nothing in Visual Basic).
System.Collections.Generic.KeyNotFoundException | The property is retrieved and key does not exist in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Keys Property

[image]
ActiveReports 19 .NET Edition
Keys Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Keys Property

Glossary Item Box

Gets a collection containing the keys in the Dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As Dictionary.KeyCollection(Of TKey,TValue)
C#
public Dictionary.KeyCollection<TKey,TValue> Keys {get;}

Property Value

A KeyCollection containing the keys in the Dictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


OnDeserialization Method

[image]
ActiveReports 19 .NET Edition
OnDeserialization Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : OnDeserialization Method

sender
The source of the deserialization event.

Glossary Item Box

Implements the System.Runtime.Serialization.ISerializable interface and raises the deserialization event when the deserialization is complete.

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDeserialization( _
   ByVal sender As Object _
)
C#
public virtual void OnDeserialization(
   object sender
)

Parameters

sender
The source of the deserialization event.

Exceptions

Exception | Description
System.Runtime.Serialization.SerializationException | The System.Runtime.Serialization.SerializationInfo object associated with the current Dictionary instance is invalid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Remove Method

key
The key of the element to remove.

Glossary Item Box

Removes the value with the specified key from the Dictionary.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal key As Integer _
) As Boolean
C#
public bool Remove(
   int key
)

Parameters

key
The key of the element to remove.

Return Value

true if the element is successfully found and removed; otherwise, false. This method returns false if key is not found in the Dictionary.

Exceptions

Exception | Description
System.ArgumentNullException | key is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


TryGetValue Method

[image]
ActiveReports 19 .NET Edition
TryGetValue Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : TryGetValue Method

key
The key of the value to get.
value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Glossary Item Box

Gets the value associated with the specified key.

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
   ByVal key As Integer, _
   ByRef value As InteractiveSort _
) As Boolean
C#
public bool TryGetValue(
   int key,
   out InteractiveSort value
)

Parameters

key
The key of the value to get.
value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

true if the Dictionary contains an element with the specified key; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | key is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


Values Property

[image]
ActiveReports 19 .NET Edition
Values Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InteractiveSortState Class : Values Property

Glossary Item Box

Gets a collection containing the values in the Dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As Dictionary.ValueCollection(Of TKey,TValue)
C#
public Dictionary.ValueCollection<TKey,TValue> Values {get;}

Property Value

A ValueCollection containing the values in the Dictionary.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InteractiveSortState Class
InteractiveSortState Members


InvalidDefinitionException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidDefinitionException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InvalidDefinitionException Class

Glossary Item Box

For a list of all members of this type, see InvalidDefinitionException members.

See Also

Reference

InvalidDefinitionException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


InvalidDefinitionException Class Properties

[image]
ActiveReports 19 .NET Edition
InvalidDefinitionException Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace : InvalidDefinitionException Class

Glossary Item Box

For a list of all members of this type, see InvalidDefinitionException members.

See Also

Reference

InvalidDefinitionException Class
GrapeCity.Enterprise.Data.DataEngine Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > InvalidDefinitionException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDefinitionException Class
InvalidDefinitionException Members


Record Constructor

[image]
ActiveReports 19 .NET Edition
Record Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly > GrapeCity.Enterprise.Data.DataEngine Namespace > Record Class : Record Constructor

Glossary Item Box

Overload List

Overload | Description
Record Constructor | Initializes a new instance of the Record.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Record Class
Record Members


GrapeCity.Enterprise.Data.DataEngine Namespace

GrapeCity.Enterprise.Data.DataEngine Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DataEngineException | Base class for data engine exceptions.
Class | DataProcessor | Represents the data tree building and transformation functions.
Class | DataTree<T> | Defines data tree result structures.
Class | DataTree.DataRegion<T> | Base class for data regions.
Class | DataTree.List<T> | List data region.
Class | DataTree.Scope<T> | Data scope.
Class | DataTree.Snapshot<T> | Defines data tree with its definition.
Class | DataTree.Tablix<T> | Tablix data.
Class | DataTree.TablixMember<T> | Tablix member data.
Class | DataTree.TablixRow<T> | Tablix row data
Class | Def | Defines data query definition classes.
Class | Def.Content | Content definition
Class | Def.DataSet | DataSet region definition
Class | Def.Filter | Defines filter.
Class | Def.Group | Group definition
Class | Def.List | List region definition
Class | Def.Parameter | Parameter definition
Class | Def.Region | Base class for regions definitions
Class | Def.Report | Report data region definition
Class | Def.SimpleRegion | Simple data region definition
Class | Def.Sort | Specifies how to sort members.
Class | Def.Subreport | Subreport definition
Class | Def.Tablix | Tablix data region definition
Class | Def.TablixMember | Tablix member data definition
Class | Def.TablixRow | Tablix row data definition
Class | GetAggregateDataProviderArgs | Contains information which is necessary to get the IAggregateDataProvider object.
Class | GetRecordSetArgs | Contains information which is necessary to provide appropriate data set.
Class | InteractiveSortState | Dictionary with state of all interactive sorts.
Class | InteractiveState | Represents the state of the interactive levers.
Class | InvalidDefinitionException | Raised when data query definition (filters, sorting, etc.) is not valid in specific scope.
Class | Record | Defines single data record.
Class | RecordSet | Defines the source records collection.
Class | RecordSetProvider | Defines report scope.
Class | ReportContext | Represents the context for the data query execution.

Structures

 | Structure | Description
Structure | DataParameter | Represents the data query parameter.
Structure | DataProcessor.Result | Represents the result of data processing.
Structure | InteractiveSort | Defines interactive sorting. Represents a single interactive sorting operation, including the sort expression, its scope, and the direction of sorting.
Structure | SlicerKey | Represents a unique identifier for a slicer within a data tree.
Structure | SlicerState | Describes state of the specific slicer.

Delegates

 | Delegate | Description
Delegate | ReportContextFn | Declares the function type ofr the ReportContext creation during the data processing.

Enumerations

 | Enumeration | Description
Enumeration | Def.FilterOperator | Specifies the available filter operators.
Enumeration | Def.SortDirection | Defines the directions in which data can be sorted.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


GrapeCity.Enterprise.Data.DataEngine Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.DataEngine Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly : GrapeCity.Enterprise.Data.DataEngine Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.DataEngine.DataProcessor
GrapeCity.Enterprise.Data.DataEngine.DataTree<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.DataRegion<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.List<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Tablix<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Scope<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.Snapshot<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.TablixMember<T>
GrapeCity.Enterprise.Data.DataEngine.DataTree`1.TablixRow<T>
GrapeCity.Enterprise.Data.DataEngine.Def
GrapeCity.Enterprise.Data.DataEngine.Def.Content
GrapeCity.Enterprise.Data.DataEngine.Def.Filter
GrapeCity.Enterprise.Data.DataEngine.Def.Group
GrapeCity.Enterprise.Data.DataEngine.Def.Parameter
GrapeCity.Enterprise.Data.DataEngine.Def.Region
GrapeCity.Enterprise.Data.DataEngine.Def.DataSet
GrapeCity.Enterprise.Data.DataEngine.Def.List
GrapeCity.Enterprise.Data.DataEngine.Def.Report
GrapeCity.Enterprise.Data.DataEngine.Def.SimpleRegion
GrapeCity.Enterprise.Data.DataEngine.Def.Subreport
GrapeCity.Enterprise.Data.DataEngine.Def.Tablix
GrapeCity.Enterprise.Data.DataEngine.Def.Sort
GrapeCity.Enterprise.Data.DataEngine.Def.TablixMember
GrapeCity.Enterprise.Data.DataEngine.Def.TablixRow
GrapeCity.Enterprise.Data.DataEngine.GetAggregateDataProviderArgs
GrapeCity.Enterprise.Data.DataEngine.GetRecordSetArgs
GrapeCity.Enterprise.Data.DataEngine.InteractiveState
GrapeCity.Enterprise.Data.DataEngine.Record
GrapeCity.Enterprise.Data.DataEngine.RecordSet
GrapeCity.Enterprise.Data.DataEngine.RecordSetProvider
GrapeCity.Enterprise.Data.DataEngine.ReportContext
System.Collections.Generic.Dictionary<TKey,TValue>
GrapeCity.Enterprise.Data.DataEngine.InteractiveSortState
System.Exception
GrapeCity.Enterprise.Data.DataEngine.DataEngineException
GrapeCity.Enterprise.Data.DataEngine.InvalidDefinitionException
System.ValueType
GrapeCity.Enterprise.Data.DataEngine.DataParameter
GrapeCity.Enterprise.Data.DataEngine.DataProcessor.Result
GrapeCity.Enterprise.Data.DataEngine.InteractiveSort
GrapeCity.Enterprise.Data.DataEngine.SlicerKey
GrapeCity.Enterprise.Data.DataEngine.SlicerState

See Also

Reference

MESCIUS.ActiveReports.Core.Data.DataEngine Assembly


Assembly Overview

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.Enterprise.Data.Expressions |
GrapeCity.Enterprise.Data.Expressions.Evaluation |
GrapeCity.Enterprise.Data.Expressions.Parser |
GrapeCity.Enterprise.Data.Expressions.Parser.Trees |
GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions |
GrapeCity.Enterprise.Data.Expressions.Tools |


InvalidVariantOperationException Class Methods

[image]
ActiveReports 19 .NET Edition
InvalidVariantOperationException Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace : InvalidVariantOperationException Class

Glossary Item Box

For a list of all members of this type, see InvalidVariantOperationException members.

See Also

Reference

InvalidVariantOperationException Class
GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace


Data Property

[image]
ActiveReports 19 .NET Edition
Data Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As IDictionary
C#
public IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


GetBaseException Method

[image]
ActiveReports 19 .NET Edition
GetBaseException Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Function GetBaseException() As Exception
C#
public Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


GetObjectData Method

[image]
ActiveReports 19 .NET Edition
GetObjectData Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


GetType Method

[image]
ActiveReports 19 .NET Edition
GetType Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


HelpLink Property

[image]
ActiveReports 19 .NET Edition
HelpLink Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Property HelpLink As String
C#
public string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


HResult Property

[image]
ActiveReports 19 .NET Edition
HResult Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


InnerException Property

[image]
ActiveReports 19 .NET Edition
InnerException Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


Message Property

[image]
ActiveReports 19 .NET Edition
Message Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


Source Property

[image]
ActiveReports 19 .NET Edition
Source Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


StackTrace Property

[image]
ActiveReports 19 .NET Edition
StackTrace Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StackTrace As String
C#
public string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


TargetSite Property

[image]
ActiveReports 19 .NET Edition
TargetSite Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > InvalidVariantOperationException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidVariantOperationException Class
InvalidVariantOperationException Members


Addition(Variant,Int64) Operator

[image]
ActiveReports 19 .NET Edition
Addition(Variant,Int64) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Addition Operator : Addition(Variant,Int64) Operator

a
The variant to be summed.
b
The long integer to be summed.

Glossary Item Box

Sums the Variant and long value.

Syntax

Visual Basic (Declaration)
Overloads Public Operator +( _
   ByVal a As Variant, _
   ByVal b As Long _
) As Variant
C#
public Variant operator +(
   Variant a,
   long b
)

Parameters

a
The variant to be summed.
b
The long integer to be summed.

Return Value

The Variant which represents the sum of passed parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Addition(Variant,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Addition(Variant,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Addition Operator : Addition(Variant,Variant) Operator

a
The first Variant to be summed.
b
The second Variant to be summed.

Glossary Item Box

Sums two variants.

Syntax

Visual Basic (Declaration)
Overloads Public Operator +( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public Variant operator +(
   Variant a,
   Variant b
)

Parameters

a
The first Variant to be summed.
b
The second Variant to be summed.

Return Value

The sum of a and b.

Exceptions

Exception | Description
InvalidVariantOperationException | Raised if any of variants is not numeric and can't be converted to numeric.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Division(Variant,Double) Operator

[image]
ActiveReports 19 .NET Edition
Division(Variant,Double) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Division Operator : Division(Variant,Double) Operator

a
The Variant to be divided.
b
The double divider.

Glossary Item Box

Divides Variant by double.

Syntax

Visual Basic (Declaration)
Overloads Public Operator /( _
   ByVal a As Variant, _
   ByVal b As Double _
) As Variant
C#
public Variant operator /(
   Variant a,
   double b
)

Parameters

a
The Variant to be divided.
b
The double divider.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Division(Variant,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Division(Variant,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Division Operator : Division(Variant,Variant) Operator

a
The Variant to be divided.
b
The divider Variant.

Glossary Item Box

Divides one variant by another.

Syntax

Visual Basic (Declaration)
Overloads Public Operator /( _
   ByVal a As Variant, _
   ByVal b As Variant _
) As Variant
C#
public Variant operator /(
   Variant a,
   Variant b
)

Parameters

a
The Variant to be divided.
b
The divider Variant.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Boolean,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Boolean,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Boolean,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts given Variant to boolean.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Boolean
C#
public bool operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Return Value

Returns true if:
  • the Variant is boolean 'True';
  • the Variant is numeric non-zero;
  • the Variant is string represents numeric non-zero value;
  • the Variant is string other than 'False';
  • the Variant is TimeSpan other than TimeSpan.Zero;
  • the Variant is DateTime other than default(DateTime);
  • the Variant is object other than null.
Returns False in all other cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(DateTime,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(DateTime,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(DateTime,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.DateTime.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Date
C#
public DateTime operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Decimal,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Decimal,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Decimal,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.Decimal.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Decimal
C#
public decimal operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Double,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Double,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Double,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.Double.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Double
C#
public double operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Int32,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Int32,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Int32,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.Int32.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Integer
C#
public int operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Int64,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Int64,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Int64,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.Int64.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Long
C#
public long operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(Single,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(Single,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Single,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.Single.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As Single
C#
public float operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(String,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(String,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(String,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.String.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As String
C#
public string operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(TimeSpan,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(TimeSpan,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(TimeSpan,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to TimeSpan.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As TimeSpan
C#
public TimeSpan operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


Explicit Type Conversion(UInt64,Variant) Operator

[image]
ActiveReports 19 .NET Edition
Explicit Type Conversion(UInt64,Variant) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace > Variant Structure > Explicit Type Conversion Operator : Explicit Type Conversion(UInt64,Variant) Operator

v
The Variant to be converted.

Glossary Item Box

Converts Variant value to System.UInt64.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal v As Variant _
) As ULong
C#
public ulong operator explicit(
   Variant v
)

Parameters

v
The Variant to be converted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Variant Structure
Variant Members
Overload List


GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace

GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DynamicDispatch | Module containing implementation of simple dynamic dispatch.
Class | ExpressionExtensions | Provides additional methods to work with expressions
Class | FrameworkInvoke | Represents methods for .NET API late bindings.
Class | InvalidVariantOperationException | Raised when an evaluation operation is not applicable to the given arguments.
Class | Variant.VariantComparer | Comparer for the Variant type.

Interfaces

 | Interface | Description
Interface | IDynamicObject | Represents an object with late binding mechanism.

Structures

 | Structure | Description
Structure | Variant | Defines a variant type.

Enumerations

 | Enumeration | Description
Enumeration | VariantType | Defines variant types.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Evaluation Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Evaluation.DynamicDispatch
GrapeCity.Enterprise.Data.Expressions.Evaluation.ExpressionExtensions
GrapeCity.Enterprise.Data.Expressions.Evaluation.FrameworkInvoke
GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant.VariantComparer
System.Exception
System.SystemException
System.InvalidOperationException
GrapeCity.Enterprise.Data.Expressions.Evaluation.InvalidVariantOperationException
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Evaluation.Variant

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


Replace Method

[image]
ActiveReports 19 .NET Edition
Replace Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionExtensions Class : Replace Method

Glossary Item Box

Re-creates new expression tree with renamed identifier.

Overload List

Overload | Description
Replace | Re-creates new expression tree with renamed identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionExtensions Class
ExpressionExtensions Members


FromString Method

[image]
ActiveReports 19 .NET Edition
FromString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class : FromString Method

Glossary Item Box

Creates an ExpressionInfo object from a string expression representation.

Overload List

Overload | Description
FromString | Creates an ExpressionInfo object from a string expression representation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Implicit Type Conversion(ExpressionInfo,String) Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion(ExpressionInfo,String) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Implicit Type Conversion Operator : Implicit Type Conversion(ExpressionInfo,String) Operator

expressionString
The string representation of expression.

Glossary Item Box

Defines an operator that allows implicit conversion from a System.String to an ExpressionInfo.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal expressionString As String _
) As ExpressionInfo
C#
public ExpressionInfo operator implicit(
   string expressionString
)

Parameters

expressionString
The string representation of expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Implicit Type Conversion(String,ExpressionInfo) Operator

[image]
ActiveReports 19 .NET Edition
Implicit Type Conversion(String,ExpressionInfo) Operator
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace > ExpressionInfo Class > Implicit Type Conversion Operator : Implicit Type Conversion(String,ExpressionInfo) Operator

expression
The expression to be converted.

Glossary Item Box

Defines an operator that allows implicit conversion from an ExpressionInfo to a System.String.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal expression As ExpressionInfo _
) As String
C#
public string operator implicit(
   ExpressionInfo expression
)

Parameters

expression
The expression to be converted.

Return Value

The string representation of expression.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


NothingExpressionInfo Class Properties

[image]
ActiveReports 19 .NET Edition
NothingExpressionInfo Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly > GrapeCity.Enterprise.Data.Expressions Namespace : NothingExpressionInfo Class

Glossary Item Box

For a list of all members of this type, see NothingExpressionInfo members.

See Also

Reference

NothingExpressionInfo Class
GrapeCity.Enterprise.Data.Expressions Namespace


GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace

GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace

Glossary Item Box

Enumerations

 | Enumeration | Description
Enumeration | OperatorType | Represents operator types

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser.Trees.Expressions Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace

GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace

Glossary Item Box

Enumerations

 | Enumeration | Description
Enumeration | IntrinsicType | Represents Intrinsic types

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser.Trees Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Parser Namespace

GrapeCity.Enterprise.Data.Expressions.Parser Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser Namespace

Glossary Item Box

Structures

 | Structure | Description
Structure | Location | Represents a location in text.
Structure | Span | Represents the location of a span of text within original GrapeCity.Enterprise.Data.Expressions.ExpressionInfo string.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Parser Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions.Parser Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Parser Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Parser.Location
GrapeCity.Enterprise.Data.Expressions.Parser.Span

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Tools Namespace

GrapeCity.Enterprise.Data.Expressions.Tools Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Tools Namespace

Glossary Item Box

Classes

 | Class | Description
Class | EnumerableExtensions | Provides additional LINQ extensions.

Structures

 | Structure | Description
Structure | OrderedItem<T> | Representation of item with index.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions.Tools Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions.Tools Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions.Tools Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.Tools.EnumerableExtensions
System.ValueType
GrapeCity.Enterprise.Data.Expressions.Tools.OrderedItem<T>

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions Namespace

GrapeCity.Enterprise.Data.Expressions Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions Namespace

Glossary Item Box

Classes

 | Class | Description
Class | CompoundExpressionInfo | Represents unary or binary expression.
Class | ConstantExpressionInfo | Represents an expression that is a constant value.
Class | ExpressionExtensions | Provides additional methods to work with ExpressionInfo instances.
Class | ExpressionInfo | The ExpressionInfo class stores, parses, and provides information about an expression. ExpressionInfo provides aggregates, global collections, etc., as well as information about the expected data type of the expression's result.
Class | FunctionExpressionInfo | Represents an expression that is a constant value.
Class | IdentifierExpressionInfo | Represents an identifier in an expression, such as constants or enums.
Class | IntrinsicCastExpressionInfo | Represents type cast expression.
Class | NewExpressionInfo | Represents a constructor in an expression, such as new.
Class | NothingExpressionInfo | Represents the value "Nothing" in the ExpressionInfo.
Class | ValidationResults | Represents the results of ExpressionInfo validation.
Class | ValidationResults.ErrorInformation | Represents the information about an error (message and location).

Enumerations

 | Enumeration | Description
Enumeration | ExpressionResultType | Specifies the type of the evaluation result of an ExpressionInfo object.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


GrapeCity.Enterprise.Data.Expressions Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.Expressions Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly : GrapeCity.Enterprise.Data.Expressions Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.Expressions.ExpressionExtensions
GrapeCity.Enterprise.Data.Expressions.ExpressionInfo
GrapeCity.Enterprise.Data.Expressions.CompoundExpressionInfo
GrapeCity.Enterprise.Data.Expressions.ConstantExpressionInfo
GrapeCity.Enterprise.Data.Expressions.FunctionExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IdentifierExpressionInfo
GrapeCity.Enterprise.Data.Expressions.IntrinsicCastExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NewExpressionInfo
GrapeCity.Enterprise.Data.Expressions.NothingExpressionInfo
GrapeCity.Enterprise.Data.Expressions.ValidationResults
GrapeCity.Enterprise.Data.Expressions.ValidationResults.ErrorInformation

See Also

Reference

MESCIUS.ActiveReports.Core.Data.ExpressionInfo Assembly


Assembly Overview

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.Enterprise.Data.VisualBasicReplacement |


ToInt Method

[image]
ActiveReports 19 .NET Edition
ToInt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly > GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace > Conversions Class : ToInt Method

Glossary Item Box

Rounds a specified System.Decimal number to the closest integer toward negative infinity.

Overload List

Overload | Description
ToInt | Rounds a specified System.Decimal number to the closest integer toward negative infinity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Conversions Class
Conversions Members


GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly : GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace

Glossary Item Box

Classes

 | Class | Description
Class | BooleanType | Represents conversions to Boolean
Class | ByteType | Represents conversions to Byte
Class | CharType | Represents conversions to Char
Class | Constants | The Constants module contains miscellaneous constants. These constants can be used anywhere in your code.
Class | Conversion | Represents conversions in Visual Basic style
Class | Conversions | Represents conversion methods
Class | DateAndTime | Represents DateAndTime operations in Visual Basic style
Class | DecimalType | Represents conversions to Decimal
Class | DoubleType | Represents conversions to Double
Class | Financial | References the Financial enumeration when reflecting financial methods.
Class | Information | Represents VisualBasic Information methods
Class | IntegerType | Represents conversions to Integer
Class | Interaction | Contains methods used to interact with objects, applications, and systems in VisualBasic style.
Class | LongType | Represents conversions to Long
Class | ObjectType |
Class | ShortType | Represents conversions to Short
Class | SingleType | Represents conversions to Single
Class | Strings | Represents strings operations.
Class | StringType | Represents conversions to String
Class | VBMath | The VbMath module contains procedures used to perform mathematical operations.

Enumerations

 | Enumeration | Description
Enumeration | AppWinStyle | Indicates the window style to use for the invoked program when calling the Shell function.
Enumeration | CallType | Indicates the type of procedure being invoked when calling the CallByName function.
Enumeration | CompareMethod | Indicates how to compare strings when calling comparison functions.
Enumeration | DateFormat | Indicates how to display dates when calling the FormatDateTime function.
Enumeration | DateInterval | Indicates how to determine and format date intervals when calling date-related functions.
Enumeration | DueDate | References the DueDate enumeration when reflecting financial methods.
Enumeration | FileAttribute | Indicates the file attributes to use when calling file-access functions.
Enumeration | FirstDayOfWeek | Indicates the first day of the week to use when calling date-related functions.
Enumeration | FirstWeekOfYear | Indicates the first week of the year to use when calling date-related functions.
Enumeration | MsgBoxResult | Indicates which button was pressed on a message box, returned by the MsgBox function.
Enumeration | MsgBoxStyle | Indicates which buttons to display when calling the MsgBox function.
Enumeration | Strings.FormatType | Represent format type
Enumeration | TriState | Indicates a Boolean value or whether the default should be used when calling number-formatting functions.
Enumeration | VariantType | Indicates the type of a variant object, returned by the VarType function.
Enumeration | VbStrConv | Indicates which type of conversion to perform when calling the StrConv function.

See Also

Reference

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly


GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace Inheritance Hierarchy

GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly : GrapeCity.Enterprise.Data.VisualBasicReplacement Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Enterprise.Data.VisualBasicReplacement.BooleanType
GrapeCity.Enterprise.Data.VisualBasicReplacement.ByteType
GrapeCity.Enterprise.Data.VisualBasicReplacement.CharType
GrapeCity.Enterprise.Data.VisualBasicReplacement.Constants
GrapeCity.Enterprise.Data.VisualBasicReplacement.Conversion
GrapeCity.Enterprise.Data.VisualBasicReplacement.Conversions
GrapeCity.Enterprise.Data.VisualBasicReplacement.DateAndTime
GrapeCity.Enterprise.Data.VisualBasicReplacement.DecimalType
GrapeCity.Enterprise.Data.VisualBasicReplacement.DoubleType
GrapeCity.Enterprise.Data.VisualBasicReplacement.Financial
GrapeCity.Enterprise.Data.VisualBasicReplacement.Information
GrapeCity.Enterprise.Data.VisualBasicReplacement.IntegerType
GrapeCity.Enterprise.Data.VisualBasicReplacement.Interaction
GrapeCity.Enterprise.Data.VisualBasicReplacement.LongType
GrapeCity.Enterprise.Data.VisualBasicReplacement.ObjectType
GrapeCity.Enterprise.Data.VisualBasicReplacement.ShortType
GrapeCity.Enterprise.Data.VisualBasicReplacement.SingleType
GrapeCity.Enterprise.Data.VisualBasicReplacement.Strings
GrapeCity.Enterprise.Data.VisualBasicReplacement.StringType
GrapeCity.Enterprise.Data.VisualBasicReplacement.VBMath

See Also

Reference

MESCIUS.ActiveReports.Core.Data.VBFunctionLib Assembly


Assembly Overview

MESCIUS.ActiveReports.Core.Document Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports |
GrapeCity.ActiveReports.Core.Document |
GrapeCity.ActiveReports.Core.Document.DDLib.Table |
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib |
GrapeCity.ActiveReports.Core.Document.I |
GrapeCity.ActiveReports.Core.Document.Utility |
GrapeCity.ActiveReports.Document.Drawing |
GrapeCity.ActiveReports.Document.Drawing.Drawing2D |
GrapeCity.ActiveReports.Document.Drawing.Imaging |
GrapeCity.ActiveReports.Document.Section |
GrapeCity.ActiveReports.Document.Section.Annotations |


Assembly Overview

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly
See Also

Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi |
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi |
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document |
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I |
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text |
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility |
GrapeCity.ActiveReports.Document.Section |


GcGdiGraphics Class Methods

[image]
ActiveReports 19 .NET Edition
GcGdiGraphics Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace : GcGdiGraphics Class

Glossary Item Box

For a list of all members of this type, see GcGdiGraphics members.

See Also

Reference

GcGdiGraphics Class
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace


BlendMode Property

[image]
ActiveReports 19 .NET Edition
BlendMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : BlendMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property BlendMode As GrapeCity.Documents.Drawing.BlendMode
C#
public GrapeCity.Documents.Drawing.BlendMode BlendMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


CreateClipRegion Method

[image]
ActiveReports 19 .NET Edition
CreateClipRegion Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : CreateClipRegion Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


CreateClipRegion(IPath) Method

[image]
ActiveReports 19 .NET Edition
CreateClipRegion(IPath) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > CreateClipRegion Method : CreateClipRegion(IPath) Method

graphicsPath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateClipRegion( _
   ByVal graphicsPath As GrapeCity.Documents.Drawing.IPath _
) As GrapeCity.Documents.Drawing.IClipRegion
C#
public GrapeCity.Documents.Drawing.IClipRegion CreateClipRegion(
   GrapeCity.Documents.Drawing.IPath graphicsPath
)

Parameters

graphicsPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


CreateClipRegion(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
CreateClipRegion(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > CreateClipRegion Method : CreateClipRegion(RectangleF) Method

bounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateClipRegion( _
   ByVal bounds As RectangleF _
) As GrapeCity.Documents.Drawing.IClipRegion
C#
public GrapeCity.Documents.Drawing.IClipRegion CreateClipRegion(
   RectangleF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


CreatePath Method

[image]
ActiveReports 19 .NET Edition
CreatePath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : CreatePath Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


CreatePath() Method

[image]
ActiveReports 19 .NET Edition
CreatePath() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : CreatePath() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreatePath() As GrapeCity.Documents.Drawing.IPath
C#
public GrapeCity.Documents.Drawing.IPath CreatePath()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


CreateRoundBordersPath Method

[image]
ActiveReports 19 .NET Edition
CreateRoundBordersPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : CreateRoundBordersPath Method

bounds
cornerRadius

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateRoundBordersPath( _
   ByVal bounds As RectangleF, _
   ByVal cornerRadius As GrapeCity.Documents.Drawing.CornerRadius _
) As GrapeCity.Documents.Drawing.IPath
C#
public GrapeCity.Documents.Drawing.IPath CreateRoundBordersPath(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.CornerRadius cornerRadius
)

Parameters

bounds
cornerRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


CreateTextLayout Method

[image]
ActiveReports 19 .NET Edition
CreateTextLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : CreateTextLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateTextLayout() As GrapeCity.Documents.Text.TextLayout
C#
public GrapeCity.Documents.Text.TextLayout CreateTextLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


Disposed Property

[image]
ActiveReports 19 .NET Edition
Disposed Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : Disposed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposed As Boolean
C#
public bool Disposed {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawEllipse Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawEllipse Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawEllipse(RectangleF,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse(RectangleF,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawEllipse Method : DrawEllipse(RectangleF,Color,Single,DashStyle) Method

bounds
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawEllipse( _
   ByVal bounds As RectangleF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawEllipse(
   RectangleF bounds,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

bounds
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawEllipse(RectangleF,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse(RectangleF,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawEllipse Method : DrawEllipse(RectangleF,Color,Single,Single[]) Method

bounds
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawEllipse( _
   ByVal bounds As RectangleF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawEllipse(
   RectangleF bounds,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

bounds
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawEllipse(RectangleF,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawEllipse(RectangleF,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawEllipse Method : DrawEllipse(RectangleF,Pen) Method

bounds
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawEllipse( _
   ByVal bounds As RectangleF, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawEllipse(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

bounds
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawImage Method

[image]
ActiveReports 19 .NET Edition
DrawImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawImage Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,RectangleF[],Single) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,RectangleF[],Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawImage Method : DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,RectangleF[],Single) Method

image
destBounds
clipBounds
align
imageBounds
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As GrapeCity.Documents.Drawing.IImage, _
   ByVal destBounds As RectangleF, _
   ByVal clipBounds As Nullable(Of RectangleF), _
   ByVal align As GrapeCity.Documents.Drawing.ImageAlign, _
   ByRef imageBounds() As RectangleF, _
   Optional ByVal opacity As Single _
)
C#
public void DrawImage(
   GrapeCity.Documents.Drawing.IImage image,
   RectangleF destBounds,
   Nullable<RectangleF> clipBounds,
   GrapeCity.Documents.Drawing.ImageAlign align,
   out RectangleF[] imageBounds,
   float opacity
)

Parameters

image
destBounds
clipBounds
align
imageBounds
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawImage Method : DrawImage(IImage,RectangleF,Nullable<RectangleF>,ImageAlign,Single) Method

image
destBounds
clipBounds
align
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As GrapeCity.Documents.Drawing.IImage, _
   ByVal destBounds As RectangleF, _
   ByVal clipBounds As Nullable(Of RectangleF), _
   ByVal align As GrapeCity.Documents.Drawing.ImageAlign, _
   Optional ByVal opacity As Single _
)
C#
public void DrawImage(
   GrapeCity.Documents.Drawing.IImage image,
   RectangleF destBounds,
   Nullable<RectangleF> clipBounds,
   GrapeCity.Documents.Drawing.ImageAlign align,
   float opacity
)

Parameters

image
destBounds
clipBounds
align
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine Method

[image]
ActiveReports 19 .NET Edition
DrawLine Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawLine Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawLine(PointF,PointF,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(PointF,PointF,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(PointF,PointF,Color,Single,DashStyle) Method

p1
p2
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal p1 As PointF, _
   ByVal p2 As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawLine(
   PointF p1,
   PointF p2,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

p1
p2
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine(PointF,PointF,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(PointF,PointF,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(PointF,PointF,Color,Single,Single[]) Method

p1
p2
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal p1 As PointF, _
   ByVal p2 As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawLine(
   PointF p1,
   PointF p2,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

p1
p2
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine(PointF,PointF,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(PointF,PointF,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(PointF,PointF,Pen) Method

p1
p2
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal p1 As PointF, _
   ByVal p2 As PointF, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawLine(
   PointF p1,
   PointF p2,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

p1
p2
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine(Single,Single,Single,Single,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(Single,Single,Single,Single,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(Single,Single,Single,Single,Color,Single,DashStyle) Method

x1
y1
x2
y2
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

x1
y1
x2
y2
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine(Single,Single,Single,Single,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(Single,Single,Single,Single,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(Single,Single,Single,Single,Color,Single,Single[]) Method

x1
y1
x2
y2
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

x1
y1
x2
y2
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLine(Single,Single,Single,Single,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawLine(Single,Single,Single,Single,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLine Method : DrawLine(Single,Single,Single,Single,Pen) Method

x1
y1
x2
y2
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

x1
y1
x2
y2
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLines Method

[image]
ActiveReports 19 .NET Edition
DrawLines Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawLines Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawLines(PointF[],Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawLines(PointF[],Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLines Method : DrawLines(PointF[],Color,Single,DashStyle) Method

points
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLines( _
   ByVal points() As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawLines(
   PointF[] points,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

points
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLines(PointF[],Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawLines(PointF[],Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLines Method : DrawLines(PointF[],Color,Single,Single[]) Method

points
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLines( _
   ByVal points() As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawLines(
   PointF[] points,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

points
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawLines(PointF[],Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawLines(PointF[],Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawLines Method : DrawLines(PointF[],Pen) Method

points
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawLines( _
   ByVal points() As PointF, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawLines(
   PointF[] points,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

points
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPath Method

[image]
ActiveReports 19 .NET Edition
DrawPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawPath Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawPath(IPath,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawPath(IPath,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPath Method : DrawPath(IPath,Color,Single,DashStyle) Method

path
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPath( _
   ByVal path As GrapeCity.Documents.Drawing.IPath, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawPath(
   GrapeCity.Documents.Drawing.IPath path,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

path
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPath(IPath,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawPath(IPath,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPath Method : DrawPath(IPath,Color,Single,Single[]) Method

path
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPath( _
   ByVal path As GrapeCity.Documents.Drawing.IPath, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawPath(
   GrapeCity.Documents.Drawing.IPath path,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

path
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPath(IPath,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawPath(IPath,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPath Method : DrawPath(IPath,Pen) Method

path
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPath( _
   ByVal path As GrapeCity.Documents.Drawing.IPath, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawPath(
   GrapeCity.Documents.Drawing.IPath path,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

path
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawPolygon Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawPolygon(PointF[],Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(PointF[],Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(PointF[],Color,Single,DashStyle) Method

points
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal points() As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawPolygon(
   PointF[] points,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

points
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon(PointF[],Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(PointF[],Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(PointF[],Color,Single,Single[]) Method

points
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal points() As PointF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawPolygon(
   PointF[] points,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

points
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon(PointF[],Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(PointF[],Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(PointF[],Pen) Method

points
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal points() As PointF, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawPolygon(
   PointF[] points,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

points
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon(Quadrilateral,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(Quadrilateral,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(Quadrilateral,Color,Single,DashStyle) Method

quadrilateral
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal quadrilateral As GrapeCity.Documents.Common.Quadrilateral, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawPolygon(
   GrapeCity.Documents.Common.Quadrilateral quadrilateral,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

quadrilateral
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon(Quadrilateral,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(Quadrilateral,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(Quadrilateral,Color,Single,Single[]) Method

quadrilateral
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal quadrilateral As GrapeCity.Documents.Common.Quadrilateral, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawPolygon(
   GrapeCity.Documents.Common.Quadrilateral quadrilateral,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

quadrilateral
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawPolygon(Quadrilateral,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawPolygon(Quadrilateral,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawPolygon Method : DrawPolygon(Quadrilateral,Pen) Method

quadrilateral
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawPolygon( _
   ByVal quadrilateral As GrapeCity.Documents.Common.Quadrilateral, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawPolygon(
   GrapeCity.Documents.Common.Quadrilateral quadrilateral,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

quadrilateral
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRectangle Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawRectangle Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawRectangle(RectangleF,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle(RectangleF,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRectangle Method : DrawRectangle(RectangleF,Color,Single,DashStyle) Method

bounds
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRectangle( _
   ByVal bounds As RectangleF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawRectangle(
   RectangleF bounds,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

bounds
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRectangle(RectangleF,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle(RectangleF,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRectangle Method : DrawRectangle(RectangleF,Color,Single,Single[]) Method

bounds
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRectangle( _
   ByVal bounds As RectangleF, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawRectangle(
   RectangleF bounds,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

bounds
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRectangle(RectangleF,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawRectangle(RectangleF,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRectangle Method : DrawRectangle(RectangleF,Pen) Method

bounds
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRectangle( _
   ByVal bounds As RectangleF, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawRectangle(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

bounds
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRotatedText Method

[image]
ActiveReports 19 .NET Edition
DrawRotatedText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawRotatedText Method

textLayout
angle
verticalStacking
rect
alignment

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawRotatedText( _
   ByVal textLayout As GrapeCity.Documents.Text.TextLayout, _
   ByVal angle As Integer, _
   ByVal verticalStacking As Boolean, _
   ByVal rect As RectangleF, _
   ByVal alignment As GrapeCity.Documents.Drawing.RotatedTextAlignment _
)
C#
public void DrawRotatedText(
   GrapeCity.Documents.Text.TextLayout textLayout,
   int angle,
   bool verticalStacking,
   RectangleF rect,
   GrapeCity.Documents.Drawing.RotatedTextAlignment alignment
)

Parameters

textLayout
angle
verticalStacking
rect
alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawRoundRect Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawRoundRect Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawRoundRect(RectangleF,Pen,Pen,Pen,Pen,CornerRadius) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Pen,Pen,Pen,Pen,CornerRadius) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Pen,Pen,Pen,Pen,CornerRadius) Method

bounds
left
top
right
bottom
cornerRadius

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal left As GrapeCity.Documents.Drawing.Pen, _
   ByVal top As GrapeCity.Documents.Drawing.Pen, _
   ByVal right As GrapeCity.Documents.Drawing.Pen, _
   ByVal bottom As GrapeCity.Documents.Drawing.Pen, _
   ByVal cornerRadius As GrapeCity.Documents.Drawing.CornerRadius _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.Pen left,
   GrapeCity.Documents.Drawing.Pen top,
   GrapeCity.Documents.Drawing.Pen right,
   GrapeCity.Documents.Drawing.Pen bottom,
   GrapeCity.Documents.Drawing.CornerRadius cornerRadius
)

Parameters

bounds
left
top
right
bottom
cornerRadius

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Color,Single,DashStyle) Method

bounds
radius
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radius As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radius,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

bounds
radius
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Color,Single,Single[]) Method

bounds
radius
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radius As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radius,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

bounds
radius
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Pen) Method

bounds
radius
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radius As Single, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radius,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

bounds
radius
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Single,Color,Single,DashStyle) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Single,Color,Single,DashStyle) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Single,Color,Single,DashStyle) Method

bounds
radiusX
radiusY
lineColor
lineWidth
lineStyle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   Optional ByVal lineStyle As GrapeCity.Documents.Drawing.DashStyle _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radiusX,
   float radiusY,
   Color lineColor,
   float lineWidth,
   GrapeCity.Documents.Drawing.DashStyle lineStyle
)

Parameters

bounds
radiusX
radiusY
lineColor
lineWidth
lineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Single,Color,Single,Single[]) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Single,Color,Single,Single[]) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Single,Color,Single,Single[]) Method

bounds
radiusX
radiusY
lineColor
lineWidth
dashPattern

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal lineColor As Color, _
   ByVal lineWidth As Single, _
   ByVal dashPattern() As Single _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radiusX,
   float radiusY,
   Color lineColor,
   float lineWidth,
   float[] dashPattern
)

Parameters

bounds
radiusX
radiusY
lineColor
lineWidth
dashPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawRoundRect(RectangleF,Single,Single,Pen) Method

[image]
ActiveReports 19 .NET Edition
DrawRoundRect(RectangleF,Single,Single,Pen) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawRoundRect Method : DrawRoundRect(RectangleF,Single,Single,Pen) Method

bounds
radiusX
radiusY
pen

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal pen As GrapeCity.Documents.Drawing.Pen _
)
C#
public void DrawRoundRect(
   RectangleF bounds,
   float radiusX,
   float radiusY,
   GrapeCity.Documents.Drawing.Pen pen
)

Parameters

bounds
radiusX
radiusY
pen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawSlantedText Method

[image]
ActiveReports 19 .NET Edition
DrawSlantedText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawSlantedText Method

textLayout
angle
verticalStacking
rect
alignment

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawSlantedText( _
   ByVal textLayout As GrapeCity.Documents.Text.TextLayout, _
   ByVal angle As Integer, _
   ByVal verticalStacking As Boolean, _
   ByVal rect As RectangleF, _
   ByVal alignment As GrapeCity.Documents.Drawing.SlantedTextAlignment _
)
C#
public void DrawSlantedText(
   GrapeCity.Documents.Text.TextLayout textLayout,
   int angle,
   bool verticalStacking,
   RectangleF rect,
   GrapeCity.Documents.Drawing.SlantedTextAlignment alignment
)

Parameters

textLayout
angle
verticalStacking
rect
alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawString Method

[image]
ActiveReports 19 .NET Edition
DrawString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawString(String,Font,Single,Color,PointF) Method

[image]
ActiveReports 19 .NET Edition
DrawString(String,Font,Single,Color,PointF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawString Method : DrawString(String,Font,Single,Color,PointF) Method

text
font
fontSize
foreColor
location

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawString( _
   ByVal text As String, _
   ByVal font As GrapeCity.Documents.Text.Font, _
   ByVal fontSize As Single, _
   ByVal foreColor As Color, _
   ByVal location As PointF _
)
C#
public void DrawString(
   string text,
   GrapeCity.Documents.Text.Font font,
   float fontSize,
   Color foreColor,
   PointF location
)

Parameters

text
font
fontSize
foreColor
location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawString(String,TextFormat,PointF) Method

[image]
ActiveReports 19 .NET Edition
DrawString(String,TextFormat,PointF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawString Method : DrawString(String,TextFormat,PointF) Method

text
textFormat
location

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawString( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   ByVal location As PointF _
)
C#
public void DrawString(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   PointF location
)

Parameters

text
textFormat
location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawString(String,TextFormat,RectangleF,TextAlignment,ParagraphAlignment,Boolean) Method

[image]
ActiveReports 19 .NET Edition
DrawString(String,TextFormat,RectangleF,TextAlignment,ParagraphAlignment,Boolean) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawString Method : DrawString(String,TextFormat,RectangleF,TextAlignment,ParagraphAlignment,Boolean) Method

text
textFormat
rect
textAlignment
paragraphAlignment
wordWrap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawString( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   ByVal rect As RectangleF, _
   Optional ByVal textAlignment As GrapeCity.Documents.Text.TextAlignment, _
   Optional ByVal paragraphAlignment As GrapeCity.Documents.Text.ParagraphAlignment, _
   Optional ByVal wordWrap As Boolean _
)
C#
public void DrawString(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   RectangleF rect,
   GrapeCity.Documents.Text.TextAlignment textAlignment,
   GrapeCity.Documents.Text.ParagraphAlignment paragraphAlignment,
   bool wordWrap
)

Parameters

text
textFormat
rect
textAlignment
paragraphAlignment
wordWrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawSvg Method

[image]
ActiveReports 19 .NET Edition
DrawSvg Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawSvg Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawSvg(GcSvgDocument,PointF,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawSvg(GcSvgDocument,PointF,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawSvg Method : DrawSvg(GcSvgDocument,PointF,Single) Method

svgDocument
viewportPosition
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawSvg( _
   ByVal svgDocument As GrapeCity.Documents.Svg.GcSvgDocument, _
   ByVal viewportPosition As PointF, _
   Optional ByVal opacity As Single _
)
C#
public void DrawSvg(
   GrapeCity.Documents.Svg.GcSvgDocument svgDocument,
   PointF viewportPosition,
   float opacity
)

Parameters

svgDocument
viewportPosition
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawSvg(GcSvgDocument,RectangleF,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawSvg(GcSvgDocument,RectangleF,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawSvg Method : DrawSvg(GcSvgDocument,RectangleF,Single) Method

svgDocument
viewportRect
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawSvg( _
   ByVal svgDocument As GrapeCity.Documents.Svg.GcSvgDocument, _
   ByVal viewportRect As RectangleF, _
   Optional ByVal opacity As Single _
)
C#
public void DrawSvg(
   GrapeCity.Documents.Svg.GcSvgDocument svgDocument,
   RectangleF viewportRect,
   float opacity
)

Parameters

svgDocument
viewportRect
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawSvgContent Method

[image]
ActiveReports 19 .NET Edition
DrawSvgContent Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawSvgContent Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawSvgContent(GcSvgDocument,PointF,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawSvgContent(GcSvgDocument,PointF,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawSvgContent Method : DrawSvgContent(GcSvgDocument,PointF,Single) Method

svgDocument
contentPosition
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawSvgContent( _
   ByVal svgDocument As GrapeCity.Documents.Svg.GcSvgDocument, _
   ByVal contentPosition As PointF, _
   Optional ByVal opacity As Single _
)
C#
public void DrawSvgContent(
   GrapeCity.Documents.Svg.GcSvgDocument svgDocument,
   PointF contentPosition,
   float opacity
)

Parameters

svgDocument
contentPosition
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawSvgContent(GcSvgDocument,RectangleF,Single) Method

[image]
ActiveReports 19 .NET Edition
DrawSvgContent(GcSvgDocument,RectangleF,Single) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > DrawSvgContent Method : DrawSvgContent(GcSvgDocument,RectangleF,Single) Method

svgDocument
contentRect
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawSvgContent( _
   ByVal svgDocument As GrapeCity.Documents.Svg.GcSvgDocument, _
   ByVal contentRect As RectangleF, _
   Optional ByVal opacity As Single _
)
C#
public void DrawSvgContent(
   GrapeCity.Documents.Svg.GcSvgDocument svgDocument,
   RectangleF contentRect,
   float opacity
)

Parameters

svgDocument
contentRect
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


DrawTextAsPath Property

[image]
ActiveReports 19 .NET Edition
DrawTextAsPath Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawTextAsPath Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DrawTextAsPath As Boolean
C#
public bool DrawTextAsPath {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


DrawTextLayout Method

[image]
ActiveReports 19 .NET Edition
DrawTextLayout Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : DrawTextLayout Method

layout
location

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DrawTextLayout( _
   ByVal layout As GrapeCity.Documents.Text.TextLayout, _
   ByVal location As PointF _
)
C#
public void DrawTextLayout(
   GrapeCity.Documents.Text.TextLayout layout,
   PointF location
)

Parameters

layout
location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillEllipse Method

[image]
ActiveReports 19 .NET Edition
FillEllipse Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FillEllipse Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillEllipse(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillEllipse(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillEllipse Method : FillEllipse(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

bounds
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillEllipse( _
   ByVal bounds As RectangleF, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillEllipse(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

bounds
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillEllipse(RectangleF,Color) Method

[image]
ActiveReports 19 .NET Edition
FillEllipse(RectangleF,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillEllipse Method : FillEllipse(RectangleF,Color) Method

bounds
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillEllipse( _
   ByVal bounds As RectangleF, _
   ByVal color As Color _
)
C#
public void FillEllipse(
   RectangleF bounds,
   Color color
)

Parameters

bounds
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPath Method

[image]
ActiveReports 19 .NET Edition
FillPath Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FillPath Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillPath(IPath,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillPath(IPath,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPath Method : FillPath(IPath,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

path
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPath( _
   ByVal path As GrapeCity.Documents.Drawing.IPath, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillPath(
   GrapeCity.Documents.Drawing.IPath path,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

path
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPath(IPath,Color) Method

[image]
ActiveReports 19 .NET Edition
FillPath(IPath,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPath Method : FillPath(IPath,Color) Method

path
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPath( _
   ByVal path As GrapeCity.Documents.Drawing.IPath, _
   ByVal color As Color _
)
C#
public void FillPath(
   GrapeCity.Documents.Drawing.IPath path,
   Color color
)

Parameters

path
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPolygon Method

[image]
ActiveReports 19 .NET Edition
FillPolygon Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FillPolygon Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillPolygon(PointF[],Brush,FillMode,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillPolygon(PointF[],Brush,FillMode,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPolygon Method : FillPolygon(PointF[],Brush,FillMode,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

points
brush
fillMode
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPolygon( _
   ByVal points() As PointF, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal fillMode As GrapeCity.Documents.Drawing.FillMode, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillPolygon(
   PointF[] points,
   GrapeCity.Documents.Drawing.Brush brush,
   GrapeCity.Documents.Drawing.FillMode fillMode,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

points
brush
fillMode
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPolygon(PointF[],Color,FillMode) Method

[image]
ActiveReports 19 .NET Edition
FillPolygon(PointF[],Color,FillMode) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPolygon Method : FillPolygon(PointF[],Color,FillMode) Method

points
color
fillMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPolygon( _
   ByVal points() As PointF, _
   ByVal color As Color, _
   Optional ByVal fillMode As GrapeCity.Documents.Drawing.FillMode _
)
C#
public void FillPolygon(
   PointF[] points,
   Color color,
   GrapeCity.Documents.Drawing.FillMode fillMode
)

Parameters

points
color
fillMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPolygon(Quadrilateral,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillPolygon(Quadrilateral,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPolygon Method : FillPolygon(Quadrilateral,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

quadrilateral
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPolygon( _
   ByVal quadrilateral As GrapeCity.Documents.Common.Quadrilateral, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillPolygon(
   GrapeCity.Documents.Common.Quadrilateral quadrilateral,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

quadrilateral
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillPolygon(Quadrilateral,Color) Method

[image]
ActiveReports 19 .NET Edition
FillPolygon(Quadrilateral,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillPolygon Method : FillPolygon(Quadrilateral,Color) Method

quadrilateral
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillPolygon( _
   ByVal quadrilateral As GrapeCity.Documents.Common.Quadrilateral, _
   ByVal color As Color _
)
C#
public void FillPolygon(
   GrapeCity.Documents.Common.Quadrilateral quadrilateral,
   Color color
)

Parameters

quadrilateral
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRectangle Method

[image]
ActiveReports 19 .NET Edition
FillRectangle Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FillRectangle Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillRectangle(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillRectangle(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRectangle Method : FillRectangle(RectangleF,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

bounds
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRectangle( _
   ByVal bounds As RectangleF, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillRectangle(
   RectangleF bounds,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

bounds
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRectangle(RectangleF,Color) Method

[image]
ActiveReports 19 .NET Edition
FillRectangle(RectangleF,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRectangle Method : FillRectangle(RectangleF,Color) Method

bounds
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRectangle( _
   ByVal bounds As RectangleF, _
   ByVal color As Color _
)
C#
public void FillRectangle(
   RectangleF bounds,
   Color color
)

Parameters

bounds
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRoundRect Method

[image]
ActiveReports 19 .NET Edition
FillRoundRect Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FillRoundRect Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


FillRoundRect(RectangleF,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillRoundRect(RectangleF,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRoundRect Method : FillRoundRect(RectangleF,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

bounds
radius
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radius As Single, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillRoundRect(
   RectangleF bounds,
   float radius,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

bounds
radius
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRoundRect(RectangleF,Single,Color) Method

[image]
ActiveReports 19 .NET Edition
FillRoundRect(RectangleF,Single,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRoundRect Method : FillRoundRect(RectangleF,Single,Color) Method

bounds
radius
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radius As Single, _
   ByVal color As Color _
)
C#
public void FillRoundRect(
   RectangleF bounds,
   float radius,
   Color color
)

Parameters

bounds
radius
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRoundRect(RectangleF,Single,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

[image]
ActiveReports 19 .NET Edition
FillRoundRect(RectangleF,Single,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRoundRect Method : FillRoundRect(RectangleF,Single,Single,Brush,Nullable<RectangleF>,Nullable<Matrix3x2>) Method

bounds
radiusX
radiusY
brush
brushBounds
brushTransform

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal brush As GrapeCity.Documents.Drawing.Brush, _
   Optional ByVal brushBounds As Nullable(Of RectangleF), _
   Optional ByVal brushTransform As Nullable(Of Matrix3x2) _
)
C#
public void FillRoundRect(
   RectangleF bounds,
   float radiusX,
   float radiusY,
   GrapeCity.Documents.Drawing.Brush brush,
   Nullable<RectangleF> brushBounds,
   Nullable<Matrix3x2> brushTransform
)

Parameters

bounds
radiusX
radiusY
brush
brushBounds
brushTransform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FillRoundRect(RectangleF,Single,Single,Color) Method

[image]
ActiveReports 19 .NET Edition
FillRoundRect(RectangleF,Single,Single,Color) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > FillRoundRect Method : FillRoundRect(RectangleF,Single,Single,Color) Method

bounds
radiusX
radiusY
color

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRoundRect( _
   ByVal bounds As RectangleF, _
   ByVal radiusX As Single, _
   ByVal radiusY As Single, _
   ByVal color As Color _
)
C#
public void FillRoundRect(
   RectangleF bounds,
   float radiusX,
   float radiusY,
   Color color
)

Parameters

bounds
radiusX
radiusY
color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


FontCollection Property

[image]
ActiveReports 19 .NET Edition
FontCollection Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : FontCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FontCollection As GrapeCity.Documents.Text.FontCollection
C#
public GrapeCity.Documents.Text.FontCollection FontCollection {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


GetImageSize Method

[image]
ActiveReports 19 .NET Edition
GetImageSize Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : GetImageSize Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetImageSize( _
   ByVal image As GrapeCity.Documents.Drawing.IImage _
) As SizeF
C#
public SizeF GetImageSize(
   GrapeCity.Documents.Drawing.IImage image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


InterpolationMode Property

[image]
ActiveReports 19 .NET Edition
InterpolationMode Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : InterpolationMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As GrapeCity.Documents.Drawing.InterpolationMode
C#
public GrapeCity.Documents.Drawing.InterpolationMode InterpolationMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


IsBlendModeSupported Method

[image]
ActiveReports 19 .NET Edition
IsBlendModeSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : IsBlendModeSupported Method

blendMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBlendModeSupported( _
   ByVal blendMode As GrapeCity.Documents.Drawing.BlendMode _
) As Boolean
C#
public bool IsBlendModeSupported(
   GrapeCity.Documents.Drawing.BlendMode blendMode
)

Parameters

blendMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


IsInterpolationModeSupported Method

[image]
ActiveReports 19 .NET Edition
IsInterpolationModeSupported Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : IsInterpolationModeSupported Method

interpolationMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInterpolationModeSupported( _
   ByVal interpolationMode As GrapeCity.Documents.Drawing.InterpolationMode _
) As Boolean
C#
public bool IsInterpolationModeSupported(
   GrapeCity.Documents.Drawing.InterpolationMode interpolationMode
)

Parameters

interpolationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


MeasureImage Method

[image]
ActiveReports 19 .NET Edition
MeasureImage Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : MeasureImage Method

image
destBounds
align

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MeasureImage( _
   ByVal image As GrapeCity.Documents.Drawing.IImage, _
   ByVal destBounds As RectangleF, _
   ByVal align As GrapeCity.Documents.Drawing.ImageAlign _
) As RectangleF()
C#
public RectangleF[] MeasureImage(
   GrapeCity.Documents.Drawing.IImage image,
   RectangleF destBounds,
   GrapeCity.Documents.Drawing.ImageAlign align
)

Parameters

image
destBounds
align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


MeasureRotatedText Method

[image]
ActiveReports 19 .NET Edition
MeasureRotatedText Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : MeasureRotatedText Method

textLayout
angle
verticalStacking
rect
alignment

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MeasureRotatedText( _
   ByVal textLayout As GrapeCity.Documents.Text.TextLayout, _
   ByVal angle As Integer, _
   ByVal verticalStacking As Boolean, _
   ByVal rect As RectangleF, _
   ByVal alignment As GrapeCity.Documents.Drawing.RotatedTextAlignment _
) As RectangleF
C#
public RectangleF MeasureRotatedText(
   GrapeCity.Documents.Text.TextLayout textLayout,
   int angle,
   bool verticalStacking,
   RectangleF rect,
   GrapeCity.Documents.Drawing.RotatedTextAlignment alignment
)

Parameters

textLayout
angle
verticalStacking
rect
alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


MeasureString Method

[image]
ActiveReports 19 .NET Edition
MeasureString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : MeasureString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


MeasureString(String,Font,Single,Nullable<Single>) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(String,Font,Single,Nullable<Single>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureString Method : MeasureString(String,Font,Single,Nullable<Single>) Method

text
font
fontSize
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureString( _
   ByVal text As String, _
   ByVal font As GrapeCity.Documents.Text.Font, _
   ByVal fontSize As Single, _
   Optional ByVal width As Nullable(Of Single) _
) As SizeF
C#
public SizeF MeasureString(
   string text,
   GrapeCity.Documents.Text.Font font,
   float fontSize,
   Nullable<float> width
)

Parameters

text
font
fontSize
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureString(String,TextFormat,Nullable<Single>) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(String,TextFormat,Nullable<Single>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureString Method : MeasureString(String,TextFormat,Nullable<Single>) Method

text
textFormat
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureString( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   Optional ByVal width As Nullable(Of Single) _
) As SizeF
C#
public SizeF MeasureString(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   Nullable<float> width
)

Parameters

text
textFormat
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureString(String,TextFormat,SizeF,Int32) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(String,TextFormat,SizeF,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureString Method : MeasureString(String,TextFormat,SizeF,Int32) Method

text
textFormat
layoutSize
fitCharCount

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureString( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   ByVal layoutSize As SizeF, _
   ByRef fitCharCount As Integer _
) As SizeF
C#
public SizeF MeasureString(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   SizeF layoutSize,
   out int fitCharCount
)

Parameters

text
textFormat
layoutSize
fitCharCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureString(String,TextFormat,SizeF,TextSplitOptions,Int32) Method

[image]
ActiveReports 19 .NET Edition
MeasureString(String,TextFormat,SizeF,TextSplitOptions,Int32) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureString Method : MeasureString(String,TextFormat,SizeF,TextSplitOptions,Int32) Method

text
textFormat
layoutSize
splitOptions
fitCharCount

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureString( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   ByVal layoutSize As SizeF, _
   ByVal splitOptions As GrapeCity.Documents.Text.TextSplitOptions, _
   ByRef fitCharCount As Integer _
) As SizeF
C#
public SizeF MeasureString(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   SizeF layoutSize,
   GrapeCity.Documents.Text.TextSplitOptions splitOptions,
   out int fitCharCount
)

Parameters

text
textFormat
layoutSize
splitOptions
fitCharCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureStringWithTrailingWhitespace Method

[image]
ActiveReports 19 .NET Edition
MeasureStringWithTrailingWhitespace Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : MeasureStringWithTrailingWhitespace Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


MeasureStringWithTrailingWhitespace(String,Font,Single,Nullable<Single>) Method

[image]
ActiveReports 19 .NET Edition
MeasureStringWithTrailingWhitespace(String,Font,Single,Nullable<Single>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureStringWithTrailingWhitespace Method : MeasureStringWithTrailingWhitespace(String,Font,Single,Nullable<Single>) Method

text
font
fontSize
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureStringWithTrailingWhitespace( _
   ByVal text As String, _
   ByVal font As GrapeCity.Documents.Text.Font, _
   ByVal fontSize As Single, _
   Optional ByVal width As Nullable(Of Single) _
) As SizeF
C#
public SizeF MeasureStringWithTrailingWhitespace(
   string text,
   GrapeCity.Documents.Text.Font font,
   float fontSize,
   Nullable<float> width
)

Parameters

text
font
fontSize
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureStringWithTrailingWhitespace(String,TextFormat,Nullable<Single>) Method

[image]
ActiveReports 19 .NET Edition
MeasureStringWithTrailingWhitespace(String,TextFormat,Nullable<Single>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > MeasureStringWithTrailingWhitespace Method : MeasureStringWithTrailingWhitespace(String,TextFormat,Nullable<Single>) Method

text
textFormat
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureStringWithTrailingWhitespace( _
   ByVal text As String, _
   ByVal textFormat As GrapeCity.Documents.Text.TextFormat, _
   Optional ByVal width As Nullable(Of Single) _
) As SizeF
C#
public SizeF MeasureStringWithTrailingWhitespace(
   string text,
   GrapeCity.Documents.Text.TextFormat textFormat,
   Nullable<float> width
)

Parameters

text
textFormat
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


MeasureSvg Method

[image]
ActiveReports 19 .NET Edition
MeasureSvg Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : MeasureSvg Method

svgDocument
viewportPosition

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MeasureSvg( _
   ByVal svgDocument As GrapeCity.Documents.Svg.GcSvgDocument, _
   ByVal viewportPosition As PointF _
) As RectangleF
C#
public RectangleF MeasureSvg(
   GrapeCity.Documents.Svg.GcSvgDocument svgDocument,
   PointF viewportPosition
)

Parameters

svgDocument
viewportPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


PopClip Method

[image]
ActiveReports 19 .NET Edition
PopClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : PopClip Method

clipRegion

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PopClip( _
   ByVal clipRegion As GrapeCity.Documents.Drawing.IClipRegion _
)
C#
public void PopClip(
   GrapeCity.Documents.Drawing.IClipRegion clipRegion
)

Parameters

clipRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


PopTransparencyLayer Method

[image]
ActiveReports 19 .NET Edition
PopTransparencyLayer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : PopTransparencyLayer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PopTransparencyLayer()
C#
public void PopTransparencyLayer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


PushClip Method

[image]
ActiveReports 19 .NET Edition
PushClip Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : PushClip Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


PushClip(IClipRegion) Method

[image]
ActiveReports 19 .NET Edition
PushClip(IClipRegion) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > PushClip Method : PushClip(IClipRegion) Method

clipRegion

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PushClip( _
   ByVal clipRegion As GrapeCity.Documents.Drawing.IClipRegion _
)
C#
public void PushClip(
   GrapeCity.Documents.Drawing.IClipRegion clipRegion
)

Parameters

clipRegion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


PushClip(IPath) Method

[image]
ActiveReports 19 .NET Edition
PushClip(IPath) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > PushClip Method : PushClip(IPath) Method

clipPath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PushClip( _
   ByVal clipPath As GrapeCity.Documents.Drawing.IPath _
) As GrapeCity.Documents.Drawing.GcGraphics.Clip
C#
public GrapeCity.Documents.Drawing.GcGraphics.Clip PushClip(
   GrapeCity.Documents.Drawing.IPath clipPath
)

Parameters

clipPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


PushClip(Nullable<RectangleF>) Method

[image]
ActiveReports 19 .NET Edition
PushClip(Nullable<RectangleF>) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > PushClip Method : PushClip(Nullable<RectangleF>) Method

clipRect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PushClip( _
   ByVal clipRect As Nullable(Of RectangleF) _
) As GrapeCity.Documents.Drawing.GcGraphics.Clip
C#
public GrapeCity.Documents.Drawing.GcGraphics.Clip PushClip(
   Nullable<RectangleF> clipRect
)

Parameters

clipRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


PushClip(RectangleF) Method

[image]
ActiveReports 19 .NET Edition
PushClip(RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > PushClip Method : PushClip(RectangleF) Method

clipRect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PushClip( _
   ByVal clipRect As RectangleF _
) As GrapeCity.Documents.Drawing.GcGraphics.Clip
C#
public GrapeCity.Documents.Drawing.GcGraphics.Clip PushClip(
   RectangleF clipRect
)

Parameters

clipRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


PushClip(RectangleF,RectangleF) Method

[image]
ActiveReports 19 .NET Edition
PushClip(RectangleF,RectangleF) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class > PushClip Method : PushClip(RectangleF,RectangleF) Method

clipRect
containerRect

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PushClip( _
   ByVal clipRect As RectangleF, _
   ByVal containerRect As RectangleF _
) As GrapeCity.Documents.Drawing.GcGraphics.Clip
C#
public GrapeCity.Documents.Drawing.GcGraphics.Clip PushClip(
   RectangleF clipRect,
   RectangleF containerRect
)

Parameters

clipRect
containerRect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members
Overload List


PushTransparencyLayer Method

[image]
ActiveReports 19 .NET Edition
PushTransparencyLayer Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : PushTransparencyLayer Method

contentBounds
opacity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PushTransparencyLayer( _
   ByVal contentBounds As Nullable(Of RectangleF), _
   ByVal opacity As Single _
)
C#
public void PushTransparencyLayer(
   Nullable<RectangleF> contentBounds,
   float opacity
)

Parameters

contentBounds
opacity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


SurfaceResolution Property

[image]
ActiveReports 19 .NET Edition
SurfaceResolution Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace > GcGdiGraphics Class : SurfaceResolution Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SurfaceResolution As Nullable(Of Single)
C#
public Nullable<float> SurfaceResolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GcGdiGraphics Class
GcGdiGraphics Members


GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace

Glossary Item Box

Classes

 | Class | Description
Class | GcGdiGraphics | It is a bridge between GcDoc and GDI+ which allows to draw in viewers. Limitations: doesn't support some pen alignments, smoothing...

Enumerations

 | Enumeration | Description
Enumeration | FontHinting | Specifies the algorithm used for font hinting in text layout.

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Documents.Drawing.GcGraphics
GrapeCity.ActiveReports.Core.Document.Drawing.GcGdi.GcGdiGraphics

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


Render Method

[image]
ActiveReports 19 .NET Edition
Render Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > BorderRenderer Class : Render Method

Glossary Item Box

Renders the border around the specified rectangle.

Overload List

Overload | Description
Render | Renders the border around the specified rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRenderer Class
BorderRenderer Members


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace

Glossary Item Box

Classes

 | Class | Description
Class | PaddingExtension | Represents the extension for padding.

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Document.PaddingExtension

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


Reset Method

[image]
ActiveReports 19 .NET Edition
Reset Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace > GdiCanvasItemRenderer Class : Reset Method

Glossary Item Box

Resets the clip region.

Overload List

Overload | Description
Reset | Resets the clip region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiCanvasItemRenderer Class
GdiCanvasItemRenderer Members


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.I Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


RText.TextPiece Class Fields

[image]
ActiveReports 19 .NET Edition
RText.TextPiece Class Fields
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace : RText.TextPiece Class

Glossary Item Box

For a list of all members of this type, see RText.TextPiece members.

See Also

Reference

RText.TextPiece Class
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace


FormatTextAndTrim Method

[image]
ActiveReports 19 .NET Edition
FormatTextAndTrim Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly > GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace > RText Class : FormatTextAndTrim Method

Glossary Item Box

Overload List

Overload | Description
FormatTextAndTrim |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RText Class
RText Members


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace

Glossary Item Box

Classes

 | Class | Description
Class | GraphicsCache | Represents the graphics cache.
Class | RText | GDI/GDI+ based text renderer. Limitations: - Right to left word ordering for BIDI not supported, but right to left text is. - Tab characters are ignored unless alignment=left. ShrinkToFit algorithm part
Class | RText.Line | Represents the line.
Class | RText.LinePiece | Represents the line piece.
Class | RText.TabPiece | Represents the tab piece.
Class | RText.TabStop | Represents the custom tab stop.
Class | RText.TextPiece | Represents the text piece.

Structures

 | Structure | Description
Structure | RText.PaddingEx | Represents the padding.
Structure | RText.SelectionRange | Represents text selection range.

Enumerations

 | Enumeration | Description
Enumeration | RText.TabType | Specifies tab stop types.

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.GraphicsCache
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.Line
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.LinePiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabPiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TextPiece
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.TabStop
System.ValueType
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.PaddingEx
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Text.RText.SelectionRange

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.Utility Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace

Glossary Item Box

Classes

 | Class | Description
Class | BorderRenderer | Represents the GDI implementation of border rendering.
Class | GdiCanvasItemRenderer | Represents the GDI canvas item renderer.
Class | GdiImageConverterService | Service for converting image data to another format through System.Drawing.
Class | GdiTextLayoutService | Represents the GDI text layout service.

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Core.Document.Drawing.Gdi Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.BorderRenderer
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiImageConverterService
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiTextLayoutService
GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer
GrapeCity.ActiveReports.Core.Document.Drawing.Gdi.GdiCanvasItemRenderer

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document.Drawing.Gdi)

GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document.Drawing.Gdi)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

Classes

 | Class | Description
Class | PageExtensions | Represents the extensions for the page.

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document.Drawing.Gdi) Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document.Drawing.Gdi) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageExtensions

See Also

Reference

MESCIUS.ActiveReports.Core.Document.Drawing.Gdi Assembly


GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace

GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.DDLib.Table Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace

GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ZlibExtensions | Used to compress/decompress simple zlib stream (without structure).

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.DDLib.ZLib Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DDLib.ZLib.ZlibExtensions

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > DocumentBase<PageType> Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources. If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources. If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentBase<PageType> Class
DocumentBase<PageType> Members


FontsCollection Class Properties

[image]
ActiveReports 19 .NET Edition
FontsCollection Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : FontsCollection Class

Glossary Item Box

For a list of all members of this type, see FontsCollection members.

See Also

Reference

FontsCollection Class
GrapeCity.ActiveReports.Core.Document Namespace


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > FontsCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontsCollection Class
FontsCollection Members


GenericDocument<PageType,PagesCollectionType> Class Events

[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : GenericDocument<PageType,PagesCollectionType> Class

Glossary Item Box

For a list of all members of this type, see GenericDocument<PageType,PagesCollectionType> members.

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GrapeCity.ActiveReports.Core.Document Namespace


GenericDocument<PageType,PagesCollectionType> Class Methods

[image]
ActiveReports 19 .NET Edition
GenericDocument<PageType,PagesCollectionType> Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : GenericDocument<PageType,PagesCollectionType> Class

Glossary Item Box

For a list of all members of this type, see GenericDocument<PageType,PagesCollectionType> members.

See Also

Reference

GenericDocument<PageType,PagesCollectionType> Class
GrapeCity.ActiveReports.Core.Document Namespace


GrapeCity.ActiveReports.Core.Document.I Namespace

GrapeCity.ActiveReports.Core.Document.I Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.I Namespace

Glossary Item Box

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document.I Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.I Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.I Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IDocument<T> Interface : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Sub Dispose()
C#
void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocument<T> Interface
IDocument<T> Members


IPagesCollection<T> Interface Methods

[image]
ActiveReports 19 .NET Edition
IPagesCollection<T> Interface Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace : IPagesCollection<T> Interface

Glossary Item Box

For a list of all members of this type, see IPagesCollection<T> members.

See Also

Reference

IPagesCollection<T> Interface
GrapeCity.ActiveReports.Core.Document Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Add Method

value
The object to add to the System.Collections.IList.

Glossary Item Box

Adds an item to the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Function Add( _
   ByVal value As Object _
) As Integer
C#
int Add(
   object value
)

Parameters

value
The object to add to the System.Collections.IList.

Return Value

The position into which the new element was inserted, or -1 to indicate that the item was not inserted into the collection.

Exceptions

Exception | Description
System.NotSupportedException | The System.Collections.IList is read-only. -or- The System.Collections.IList has a fixed size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Clear Method

Glossary Item Box

Removes all items from the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Sub Clear()
C#
void Clear()

Exceptions

Exception | Description
System.NotSupportedException | The System.Collections.IList is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Clone Method

[image]
ActiveReports 19 .NET Edition
Clone Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Function Clone() As Object
C#
object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Contains Method

value
The object to locate in the System.Collections.IList.

Glossary Item Box

Determines whether the System.Collections.IList contains a specific value.

Syntax

Visual Basic (Declaration)
Function Contains( _
   ByVal value As Object _
) As Boolean
C#
bool Contains(
   object value
)

Parameters

value
The object to locate in the System.Collections.IList.

Return Value

true if the System.Object is found in the System.Collections.IList; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the elements of the System.Collections.ICollection to an System.Array, starting at a particular System.Array index.

Syntax

Visual Basic (Declaration)
Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from System.Collections.ICollection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | array is multidimensional. -or- The number of elements in the source System.Collections.ICollection is greater than the available space from index to the end of the destination array. -or- The type of the source System.Collections.ICollection cannot be cast automatically to the type of the destination array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Property Value

The number of elements contained in the System.Collections.ICollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Syntax

Visual Basic (Declaration)
Sub Dispose()
C#
void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : IndexOf Method

value
The object to locate in the System.Collections.IList.

Glossary Item Box

Determines the index of a specific item in the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
int IndexOf(
   object value
)

Parameters

value
The object to locate in the System.Collections.IList.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Insert Method

index
The zero-based index at which value should be inserted.
value
The object to insert into the System.Collections.IList.

Glossary Item Box

Inserts an item to the System.Collections.IList at the specified index.

Syntax

Visual Basic (Declaration)
Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert into the System.Collections.IList.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is not a valid index in the System.Collections.IList.
System.NotSupportedException | The System.Collections.IList is read-only. -or- The System.Collections.IList has a fixed size.
System.NullReferenceException | value is null reference in the System.Collections.IList.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


IsFixedSize Property

[image]
ActiveReports 19 .NET Edition
IsFixedSize Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : IsFixedSize Property

Glossary Item Box

Gets a value indicating whether the System.Collections.IList has a fixed size.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFixedSize As Boolean
C#
bool IsFixedSize {get;}

Property Value

true if the System.Collections.IList has a fixed size; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


IsReadOnly Property

[image]
ActiveReports 19 .NET Edition
IsReadOnly Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the System.Collections.IList is read-only.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsReadOnly As Boolean
C#
bool IsReadOnly {get;}

Property Value

true if the System.Collections.IList is read-only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


IsSynchronized Property

[image]
ActiveReports 19 .NET Edition
IsSynchronized Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the System.Collections.ICollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSynchronized As Boolean
C#
bool IsSynchronized {get;}

Property Value

true if access to the System.Collections.ICollection is synchronized (thread safe); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Item Property

index
The zero-based index of the element to get or set.

Glossary Item Box

Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal index As Integer _
) As Object
C#
object this[
   int index
]; {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is not a valid index in the System.Collections.IList.
System.NotSupportedException | The property is set and the System.Collections.IList is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : Remove Method

value
The object to remove from the System.Collections.IList.

Glossary Item Box

Removes the first occurrence of a specific object from the System.Collections.IList.

Syntax

Visual Basic (Declaration)
Sub Remove( _
   ByVal value As Object _
)
C#
void Remove(
   object value
)

Parameters

value
The object to remove from the System.Collections.IList.

Exceptions

Exception | Description
System.NotSupportedException | The System.Collections.IList is read-only. -or- The System.Collections.IList has a fixed size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : RemoveAt Method

index
The zero-based index of the item to remove.

Glossary Item Box

Removes the System.Collections.IList item at the specified index.

Syntax

Visual Basic (Declaration)
Sub RemoveAt( _
   ByVal index As Integer _
)
C#
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is not a valid index in the System.Collections.IList.
System.NotSupportedException | The System.Collections.IList is read-only. -or- The System.Collections.IList has a fixed size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


SyncRoot Property

[image]
ActiveReports 19 .NET Edition
SyncRoot Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > IPagesCollection<T> Interface : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the System.Collections.ICollection.

Syntax

Visual Basic (Declaration)
ReadOnly Property SyncRoot As Object
C#
object SyncRoot {get;}

Property Value

An object that can be used to synchronize access to the System.Collections.ICollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPagesCollection<T> Interface
IPagesCollection<T> Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > PagesCollection<T> Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection<T> Class
PagesCollection<T> Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Core.Document Namespace > Page Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


GrapeCity.ActiveReports.Core.Document.Utility Namespace

GrapeCity.ActiveReports.Core.Document.Utility Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.Utility Namespace

Glossary Item Box

Classes

 | Class | Description
Class | BorderLine | Represents the border line.
Class | ImageHelper | Contains platform-independent implementation of methods to extract image info from image stream.

Structures

 | Structure | Description
Structure | ImageHelper.DecodeImageResult | Represents the result of decoding an image.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document.Utility Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document.Utility Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document.Utility Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.Utility.BorderLine
GrapeCity.ActiveReports.Core.Document.Utility.ImageHelper
System.ValueType
GrapeCity.ActiveReports.Core.Document.Utility.ImageHelper.DecodeImageResult

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document Namespace

GrapeCity.ActiveReports.Core.Document Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DocumentBase<PageType> | Represents vector graphics document.
Class | FindOptions | Represents the find options.
Class | FontsCollection | Represents the font collection.
Class | GenericDocument<PageType,PagesCollectionType> | Represents a vector graphics document.
Class | Globals | Presents global units of measurement and methods for evaluation.
Class | Page | Represents the page.
Class | PagesCollection<T> | Contains a collection of Page objects.

Interfaces

 | Interface | Description
Interface | IDocument<T> | Represents the document interface
Interface | IImageConverterService | Represents service that converts image data from one format to another.
Interface | IPagesCollection<T> | Represents the pages collection.

Structures

 | Structure | Description
Structure | DeviceInfo | Presents information on the drawing device.
Structure | ImageData | Represents the data stream from which the image can be loaded and the format of the image.
Structure | TextLayoutParams | Text layout parameters. Please ensure to specify WrapMode/EnableKinsoku/MultiLine to obtain right output.
Structure | TextLayoutResult | Represents text layout result.

Delegates

 | Delegate | Description
Delegate | ChangedEventHandler | The change event handler.
Delegate | LoadCompletedEventHandler | Event occurs when load completed.
Delegate | StateChangedHandler | Event occurs when state changes.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Core.Document Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Core.Document Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Core.Document Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Core.Document.DocumentBase<PageType>
GrapeCity.ActiveReports.Core.Document.GenericDocument<PageType,PagesCollectionType>
GrapeCity.ActiveReports.Core.Document.FindOptions
GrapeCity.ActiveReports.Core.Document.Globals
GrapeCity.ActiveReports.Core.Document.Page
GrapeCity.ActiveReports.Core.Document.PagesCollection<T>
System.Collections.CollectionBase
GrapeCity.ActiveReports.Core.Document.FontsCollection
System.ValueType
GrapeCity.ActiveReports.Core.Document.DeviceInfo
GrapeCity.ActiveReports.Core.Document.ImageData
GrapeCity.ActiveReports.Core.Document.TextLayoutParams
GrapeCity.ActiveReports.Core.Document.TextLayoutResult

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace

GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace

Glossary Item Box

Enumerations

 | Enumeration | Description
Enumeration | DashCap | Specifies the type of graphic shape to use on both ends of each dash in a dashed line. It is a cross-platform version of DashCap.
Enumeration | DashStyle | Specifies the style of dashed lines drawn with a Pen object. It is a cross-platform version of DashStyle.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing.Drawing2D Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


FromStream Method

[image]
ActiveReports 19 .NET Edition
FromStream Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Drawing Namespace > Image Class : FromStream Method

Glossary Item Box

Creates an Image from the specified data stream.

Overload List

Overload | Description
FromStream | Creates an Image from the specified data stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Image Class
Image Members


GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace

GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ImageFormat | Represents the file format of the image. It is a cross-platform version of ImageFormat.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing.Imaging Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.Imaging.ImageFormat

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Drawing Namespace

GrapeCity.ActiveReports.Document.Drawing Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Font | Defines a particular format for text, including font face, size, and style attributes. It is a cross-platform version of Font.
Class | Image | It is a cross-platform Image-like image descriptor.
Class | StringFormat | Encapsulates text layout information: text alignment and line alignment. This is a simplified cross-platform version of System.Drawing.StringFormat.

Enumerations

 | Enumeration | Description
Enumeration | FontStyle | Specifies style information applied to text. It is a cross-platform version of System.Drawing.FontStyle.
Enumeration | GraphicsUnit | Specifies the unit of measure for the given data. It is a cross-platform version of System.Drawing.GraphicsUnit.
Enumeration | StringAlignment | Specifies the alignment of a text string relative to its layout rectangle. It is a cross-platform version of StringAlignment.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Drawing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Drawing Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Drawing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Drawing.Font
GrapeCity.ActiveReports.Document.Drawing.Image
GrapeCity.ActiveReports.Document.Drawing.StringFormat

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


Align Class Methods

[image]
ActiveReports 19 .NET Edition
Align Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Align Class

Glossary Item Box

For a list of all members of this type, see Align members.

See Also

Reference

Align Class
GrapeCity.ActiveReports.Document.Section Namespace


AnnotationArrow Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationArrow Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationBalloon Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationBaseText Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationBaseText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationCircle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationImage Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationLine Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationRectangle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class Events

[image]
ActiveReports 19 .NET Edition
AnnotationText Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Methods

[image]
ActiveReports 19 .NET Edition
AnnotationText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Properties

[image]
ActiveReports 19 .NET Edition
AnnotationText Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Container Property

[image]
ActiveReports 19 .NET Edition
Container Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


CreateObjRef Method

[image]
ActiveReports 19 .NET Edition
CreateObjRef Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Dispose Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Dispose() Method

[image]
ActiveReports 19 .NET Edition
Dispose() Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Disposed Event

[image]
ActiveReports 19 .NET Edition
Disposed Event
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


GetLifetimeService Method

[image]
ActiveReports 19 .NET Edition
GetLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


InitializeLifetimeService Method

[image]
ActiveReports 19 .NET Edition
InitializeLifetimeService Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Site Property

[image]
ActiveReports 19 .NET Edition
Site Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


ToString Method

[image]
ActiveReports 19 .NET Edition
ToString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


BorderCircle Class Events

[image]
ActiveReports 19 .NET Edition
BorderCircle Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

For a list of all members of this type, see BorderCircle members.

See Also

Reference

BorderCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Class Properties

[image]
ActiveReports 19 .NET Edition
BorderCircle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

For a list of all members of this type, see BorderCircle members.

See Also

Reference

BorderCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Class Events

[image]
ActiveReports 19 .NET Edition
BorderRectangle Class Events
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

For a list of all members of this type, see BorderRectangle members.

See Also

Reference

BorderRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Class Properties

[image]
ActiveReports 19 .NET Edition
BorderRectangle Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

For a list of all members of this type, see BorderRectangle members.

See Also

Reference

BorderRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


GrapeCity.ActiveReports.Document.Section.Annotations Namespace

GrapeCity.ActiveReports.Document.Section.Annotations Namespace
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Annotation | Represents the annotation.
Class | AnnotationArrow | Summary description for AnnotationArrow.
Class | AnnotationBalloon | Summary description for AnnotationBalloon.
Class | AnnotationBaseText | Represents the base class of all Annotation objects.
Class | AnnotationCircle | Represents the circle of the annotation.
Class | AnnotationCollection | Represents a collection that contains a set of annotations.
Class | AnnotationImage | Represents the annotation image.
Class | AnnotationLine | Summary description for AnnotationLine
Class | AnnotationRectangle | Represents the annotation rectangle.
Class | AnnotationText | Represents a summarized description for AnnotationText.
Class | Border | Represents the border around the Annotations object.
Class | BorderCircle | Represents the border around the circle annotation.
Class | BorderRectangle | Represents the border around the rectangle annotation.

Enumerations

 | Enumeration | Description
Enumeration | AnnotationBalloon.BallonQuadrant | Represents quadrant of the baloon
Enumeration | AnnotationLine.LinePlacement | Represents where the border of the object is drawn.
Enumeration | AnnotationLine.ShowArrowCap | Represents whether to draw arrowheads or not.
Enumeration | ArrowDirection | Represents arrow annotation direction
Enumeration | ImageLayout | Represents image annotation layout

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


BackColor Class Methods

[image]
ActiveReports 19 .NET Edition
BackColor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackColor Class

Glossary Item Box

For a list of all members of this type, see BackColor members.

See Also

Reference

BackColor Class
GrapeCity.ActiveReports.Document.Section Namespace


BackStyle Class Methods

[image]
ActiveReports 19 .NET Edition
BackStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackStyle Class

Glossary Item Box

For a list of all members of this type, see BackStyle members.

See Also

Reference

BackStyle Class
GrapeCity.ActiveReports.Document.Section Namespace


BitmapImage Class Methods

[image]
ActiveReports 19 .NET Edition
BitmapImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BitmapImage Class

Glossary Item Box

For a list of all members of this type, see BitmapImage members.

See Also

Reference

BitmapImage Class
GrapeCity.ActiveReports.Document.Section Namespace


BitmapImage Class Properties

[image]
ActiveReports 19 .NET Edition
BitmapImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BitmapImage Class

Glossary Item Box

For a list of all members of this type, see BitmapImage members.

See Also

Reference

BitmapImage Class
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Constructor

[image]
ActiveReports 19 .NET Edition
BookmarksCollection Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor

Glossary Item Box

Overload List

Overload | Description
BookmarksCollection Constructor | Initializes a new instance of the BookmarksCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Capacity Property

[image]
ActiveReports 19 .NET Edition
Capacity Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Bookmark Constructor

[image]
ActiveReports 19 .NET Edition
Bookmark Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor

Glossary Item Box

Overload List

Overload | Description
Bookmark Constructor | Default bookark constructor. Initializes the Bookmark structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


BorderItem Class Methods

[image]
ActiveReports 19 .NET Edition
BorderItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BorderItem Class

Glossary Item Box

For a list of all members of this type, see BorderItem members.

See Also

Reference

BorderItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method

[image]
ActiveReports 19 .NET Edition
Add Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Add Method

item
The object to be added to the end of the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Adds an object to the end of the Collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As CanvasItem _
)
C#
public void Add(
   CanvasItem item
)

Parameters

item
The object to be added to the end of the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Clear Method

[image]
ActiveReports 19 .NET Edition
Clear Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Clear Method

Glossary Item Box

Removes all elements from the Collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Contains Method

[image]
ActiveReports 19 .NET Edition
Contains Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Contains Method

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Determines whether an element is in the Collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As CanvasItem _
) As Boolean
C#
public bool Contains(
   CanvasItem item
)

Parameters

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


CopyTo Method

[image]
ActiveReports 19 .NET Edition
CopyTo Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As CanvasItem, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   CanvasItem[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Count Property

[image]
ActiveReports 19 .NET Edition
Count Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Count Property

Glossary Item Box

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


IndexOf Method

[image]
ActiveReports 19 .NET Edition
IndexOf Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : IndexOf Method

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As CanvasItem _
) As Integer
C#
public int IndexOf(
   CanvasItem item
)

Parameters

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

The zero-based index of the first occurrence of item within the entire Collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Insert Method

[image]
ActiveReports 19 .NET Edition
Insert Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Insert Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Inserts an element into the Collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As CanvasItem _
)
C#
public void Insert(
   int index,
   CanvasItem item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Item Property

[image]
ActiveReports 19 .NET Edition
Item Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Item Property

index
The zero-based index of the element to get or set.

Glossary Item Box

Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As CanvasItem
C#
public CanvasItem this[
   int index
]; {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


Remove Method

[image]
ActiveReports 19 .NET Edition
Remove Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : Remove Method

item
The object to remove from the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Removes the first occurrence of a specific object from the Collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As CanvasItem _
) As Boolean
C#
public bool Remove(
   CanvasItem item
)

Parameters

item
The object to remove from the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the original Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


RemoveAt Method

[image]
ActiveReports 19 .NET Edition
RemoveAt Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > CanvasItemCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the Collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CanvasItemCollection Class
CanvasItemCollection Members


ClipRect Class Methods

[image]
ActiveReports 19 .NET Edition
ClipRect Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ClipRect Class

Glossary Item Box

For a list of all members of this type, see ClipRect members.

See Also

Reference

ClipRect Class
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfo Class Methods

[image]
ActiveReports 19 .NET Edition
ControlInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfo Class

Glossary Item Box

For a list of all members of this type, see ControlInfo members.

See Also

Reference

ControlInfo Class
GrapeCity.ActiveReports.Document.Section Namespace


ControlInfoEnd Class Methods

[image]
ActiveReports 19 .NET Edition
ControlInfoEnd Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ControlInfoEnd Class

Glossary Item Box

For a list of all members of this type, see ControlInfoEnd members.

See Also

Reference

ControlInfoEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawText2 Class Methods

[image]
ActiveReports 19 .NET Edition
DrawText2 Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText2 Class

Glossary Item Box

For a list of all members of this type, see DrawText2 members.

See Also

Reference

DrawText2 Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawText Class Methods

[image]
ActiveReports 19 .NET Edition
DrawText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawText Class

Glossary Item Box

For a list of all members of this type, see DrawText members.

See Also

Reference

DrawText Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawTextLink Class Methods

[image]
ActiveReports 19 .NET Edition
DrawTextLink Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : DrawTextLink Class

Glossary Item Box

For a list of all members of this type, see DrawTextLink members.

See Also

Reference

DrawTextLink Class
GrapeCity.ActiveReports.Document.Section Namespace


Ellipse Class Methods

[image]
ActiveReports 19 .NET Edition
Ellipse Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Ellipse Class

Glossary Item Box

For a list of all members of this type, see Ellipse members.

See Also

Reference

Ellipse Class
GrapeCity.ActiveReports.Document.Section Namespace


EnhMeta Class Methods

[image]
ActiveReports 19 .NET Edition
EnhMeta Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMeta Class

Glossary Item Box

For a list of all members of this type, see EnhMeta members.

See Also

Reference

EnhMeta Class
GrapeCity.ActiveReports.Document.Section Namespace


EnhMeta Class Properties

[image]
ActiveReports 19 .NET Edition
EnhMeta Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMeta Class

Glossary Item Box

For a list of all members of this type, see EnhMeta members.

See Also

Reference

EnhMeta Class
GrapeCity.ActiveReports.Document.Section Namespace


EnhMetaLink Class Methods

[image]
ActiveReports 19 .NET Edition
EnhMetaLink Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMetaLink Class

Glossary Item Box

For a list of all members of this type, see EnhMetaLink members.

See Also

Reference

EnhMetaLink Class
GrapeCity.ActiveReports.Document.Section Namespace


EnhMetaLink Class Properties

[image]
ActiveReports 19 .NET Edition
EnhMetaLink Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EnhMetaLink Class

Glossary Item Box

For a list of all members of this type, see EnhMetaLink members.

See Also

Reference

EnhMetaLink Class
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationEnd Class Methods

[image]
ActiveReports 19 .NET Edition
EvaluationEnd Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationEnd Class

Glossary Item Box

For a list of all members of this type, see EvaluationEnd members.

See Also

Reference

EvaluationEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


EvaluationStart Class Methods

[image]
ActiveReports 19 .NET Edition
EvaluationStart Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : EvaluationStart Class

Glossary Item Box

For a list of all members of this type, see EvaluationStart members.

See Also

Reference

EvaluationStart Class
GrapeCity.ActiveReports.Document.Section Namespace


FillRect Class Methods

[image]
ActiveReports 19 .NET Edition
FillRect Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : FillRect Class

Glossary Item Box

For a list of all members of this type, see FillRect members.

See Also

Reference

FillRect Class
GrapeCity.ActiveReports.Document.Section Namespace


ForeColor Class Methods

[image]
ActiveReports 19 .NET Edition
ForeColor Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ForeColor Class

Glossary Item Box

For a list of all members of this type, see ForeColor members.

See Also

Reference

ForeColor Class
GrapeCity.ActiveReports.Document.Section Namespace


ForeColor Constructor

[image]
ActiveReports 19 .NET Edition
ForeColor Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ForeColor Class : ForeColor Constructor

Glossary Item Box

Overload List

Overload | Description
ForeColor Constructor | Initializes a new instance of the ForeColor class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeColor Class
ForeColor Members


InputFieldCheckBoxItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldCheckBoxItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldCheckBoxItem Class : InputFieldCheckBoxItem Constructor

Glossary Item Box

Overload List

Overload | Description
InputFieldCheckBoxItem Constructor | Initializes an instance of class InputFieldCheckBoxItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldCheckBoxItem Class
InputFieldCheckBoxItem Members


InputFieldItem Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldItem members.

See Also

Reference

InputFieldItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTabIndexItem Class Methods

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : InputFieldTabIndexItem Class

Glossary Item Box

For a list of all members of this type, see InputFieldTabIndexItem members.

See Also

Reference

InputFieldTabIndexItem Class
GrapeCity.ActiveReports.Document.Section Namespace


InputFieldTabIndexItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldTabIndexItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTabIndexItem Class : InputFieldTabIndexItem Constructor

Glossary Item Box

Overload List

Overload | Description
InputFieldTabIndexItem Constructor | Initializes an instance of class InputFieldTabIndexItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTabIndexItem Class
InputFieldTabIndexItem Members


InputFieldTextItem Constructor

[image]
ActiveReports 19 .NET Edition
InputFieldTextItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > InputFieldTextItem Class : InputFieldTextItem Constructor

Glossary Item Box

Overload List

Overload | Description
InputFieldTextItem Constructor | Initializes an instance of class InputFieldTextItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InputFieldTextItem Class
InputFieldTextItem Members


IntersectClip Class Methods

[image]
ActiveReports 19 .NET Edition
IntersectClip Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : IntersectClip Class

Glossary Item Box

For a list of all members of this type, see IntersectClip members.

See Also

Reference

IntersectClip Class
GrapeCity.ActiveReports.Document.Section Namespace


JPEGImage Class Methods

[image]
ActiveReports 19 .NET Edition
JPEGImage Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGImage Class

Glossary Item Box

For a list of all members of this type, see JPEGImage members.

See Also

Reference

JPEGImage Class
GrapeCity.ActiveReports.Document.Section Namespace


JPEGImage Class Properties

[image]
ActiveReports 19 .NET Edition
JPEGImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGImage Class

Glossary Item Box

For a list of all members of this type, see JPEGImage members.

See Also

Reference

JPEGImage Class
GrapeCity.ActiveReports.Document.Section Namespace


JPEGLink Class Methods

[image]
ActiveReports 19 .NET Edition
JPEGLink Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGLink Class

Glossary Item Box

For a list of all members of this type, see JPEGLink members.

See Also

Reference

JPEGLink Class
GrapeCity.ActiveReports.Document.Section Namespace


JPEGLink Class Properties

[image]
ActiveReports 19 .NET Edition
JPEGLink Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : JPEGLink Class

Glossary Item Box

For a list of all members of this type, see JPEGLink members.

See Also

Reference

JPEGLink Class
GrapeCity.ActiveReports.Document.Section Namespace


LabelAttribute Class Methods

[image]
ActiveReports 19 .NET Edition
LabelAttribute Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LabelAttribute Class

Glossary Item Box

For a list of all members of this type, see LabelAttribute members.

See Also

Reference

LabelAttribute Class
GrapeCity.ActiveReports.Document.Section Namespace


Equals Method

[image]
ActiveReports 19 .NET Edition
Equals Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : Equals Method

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Glossary Item Box

Returns a value that indicates whether this instance is equal to a specified object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public virtual bool Equals(
   object obj
)

Parameters

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Return Value

true if obj and this instance are of the same type and have identical field values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


GetHashCode Method

[image]
ActiveReports 19 .NET Edition
GetHashCode Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : GetHashCode Method

Glossary Item Box

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
C#
public virtual int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


IsDefaultAttribute Method

[image]
ActiveReports 19 .NET Edition
IsDefaultAttribute Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : IsDefaultAttribute Method

Glossary Item Box

When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
C#
public virtual bool IsDefaultAttribute()

Return Value

true if this instance is the default attribute for the class; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


Match Method

[image]
ActiveReports 19 .NET Edition
Match Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : Match Method

obj
An System.Object to compare with this instance of System.Attribute.

Glossary Item Box

When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
C#
public virtual bool Match(
   object obj
)

Parameters

obj
An System.Object to compare with this instance of System.Attribute.

Return Value

true if this instance equals obj; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


TypeId Property

[image]
ActiveReports 19 .NET Edition
TypeId Property
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > LabelAttribute Class : TypeId Property

Glossary Item Box

When implemented in a derived class, gets a unique identifier for this System.Attribute.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
C#
public virtual object TypeId {get;}

Property Value

An System.Object that is a unique identifier for the attribute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAttribute Class
LabelAttribute Members


LinkItem Class Methods

[image]
ActiveReports 19 .NET Edition
LinkItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LinkItem Class

Glossary Item Box

For a list of all members of this type, see LinkItem members.

See Also

Reference

LinkItem Class
GrapeCity.ActiveReports.Document.Section Namespace


LinkItem Class Properties

[image]
ActiveReports 19 .NET Edition
LinkItem Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : LinkItem Class

Glossary Item Box

For a list of all members of this type, see LinkItem members.

See Also

Reference

LinkItem Class
GrapeCity.ActiveReports.Document.Section Namespace


Dispose Method

[image]
ActiveReports 19 .NET Edition
Dispose Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageCell Class : Dispose Method

Glossary Item Box

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Overload List

Overload | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged/managed resources.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageCell Class
PageCell Members


PenStyle Class Methods

[image]
ActiveReports 19 .NET Edition
PenStyle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyle Class

Glossary Item Box

For a list of all members of this type, see PenStyle members.

See Also

Reference

PenStyle Class
GrapeCity.ActiveReports.Document.Section Namespace


PenStyle Constructor

[image]
ActiveReports 19 .NET Edition
PenStyle Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PenStyle Class : PenStyle Constructor

Glossary Item Box

Overload List

Overload | Description
PenStyle Constructor | Initializes a new instance of the PenStyle class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenStyle Class
PenStyle Members


PenWidth Class Methods

[image]
ActiveReports 19 .NET Edition
PenWidth Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenWidth Class

Glossary Item Box

For a list of all members of this type, see PenWidth members.

See Also

Reference

PenWidth Class
GrapeCity.ActiveReports.Document.Section Namespace


PenWidth Constructor

[image]
ActiveReports 19 .NET Edition
PenWidth Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PenWidth Class : PenWidth Constructor

Glossary Item Box

Overload List

Overload | Description
PenWidth Constructor | Initializes a new instance of the PenWidth class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PenWidth Class
PenWidth Members


PngImage Class Properties

[image]
ActiveReports 19 .NET Edition
PngImage Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngImage Class

Glossary Item Box

For a list of all members of this type, see PngImage members.

See Also

Reference

PngImage Class
GrapeCity.ActiveReports.Document.Section Namespace


PngLink Class Methods

[image]
ActiveReports 19 .NET Edition
PngLink Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngLink Class

Glossary Item Box

For a list of all members of this type, see PngLink members.

See Also

Reference

PngLink Class
GrapeCity.ActiveReports.Document.Section Namespace


PngLink Class Properties

[image]
ActiveReports 19 .NET Edition
PngLink Class Properties
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PngLink Class

Glossary Item Box

For a list of all members of this type, see PngLink members.

See Also

Reference

PngLink Class
GrapeCity.ActiveReports.Document.Section Namespace


Rect Class Methods

[image]
ActiveReports 19 .NET Edition
Rect Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Rect Class

Glossary Item Box

For a list of all members of this type, see Rect members.

See Also

Reference

Rect Class
GrapeCity.ActiveReports.Document.Section Namespace


Rect Constructor

[image]
ActiveReports 19 .NET Edition
Rect Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Rect Class : Rect Constructor

Glossary Item Box

Overload List

Overload | Description
Rect Constructor | Initializes a new instance of the Rect class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Class
Rect Members


ResetContext Class Methods

[image]
ActiveReports 19 .NET Edition
ResetContext Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ResetContext Class

Glossary Item Box

For a list of all members of this type, see ResetContext members.

See Also

Reference

ResetContext Class
GrapeCity.ActiveReports.Document.Section Namespace


RoundRect Class Methods

[image]
ActiveReports 19 .NET Edition
RoundRect Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRect Class

Glossary Item Box

For a list of all members of this type, see RoundRect members.

See Also

Reference

RoundRect Class
GrapeCity.ActiveReports.Document.Section Namespace


RoundRectEx Class Methods

[image]
ActiveReports 19 .NET Edition
RoundRectEx Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RoundRectEx Class

Glossary Item Box

For a list of all members of this type, see RoundRectEx members.

See Also

Reference

RoundRectEx Class
GrapeCity.ActiveReports.Document.Section Namespace


RoundRect Constructor

[image]
ActiveReports 19 .NET Edition
RoundRect Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RoundRect Class : RoundRect Constructor

Glossary Item Box

Overload List

Overload | Description
RoundRect Constructor | Initializes a new instance of the RoundRect class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RoundRect Class
RoundRect Members


RTL Class Methods

[image]
ActiveReports 19 .NET Edition
RTL Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RTL Class

Glossary Item Box

For a list of all members of this type, see RTL members.

See Also

Reference

RTL Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfo Class Methods

[image]
ActiveReports 19 .NET Edition
SectionInfo Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfo Class

Glossary Item Box

For a list of all members of this type, see SectionInfo members.

See Also

Reference

SectionInfo Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfoEnd Class Methods

[image]
ActiveReports 19 .NET Edition
SectionInfoEnd Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SectionInfoEnd Class

Glossary Item Box

For a list of all members of this type, see SectionInfoEnd members.

See Also

Reference

SectionInfoEnd Class
GrapeCity.ActiveReports.Document.Section Namespace


SectionInfo Constructor

[image]
ActiveReports 19 .NET Edition
SectionInfo Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SectionInfo Class : SectionInfo Constructor

Glossary Item Box

Overload List

Overload | Description
SectionInfo Constructor | Initializes an instance of class SectionInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionInfo Class
SectionInfo Members


SelectFont Class Methods

[image]
ActiveReports 19 .NET Edition
SelectFont Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SelectFont Class

Glossary Item Box

For a list of all members of this type, see SelectFont members.

See Also

Reference

SelectFont Class
GrapeCity.ActiveReports.Document.Section Namespace


SetPadding Class Methods

[image]
ActiveReports 19 .NET Edition
SetPadding Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetPadding Class

Glossary Item Box

For a list of all members of this type, see SetPadding members.

See Also

Reference

SetPadding Class
GrapeCity.ActiveReports.Document.Section Namespace


SVG Class Methods

[image]
ActiveReports 19 .NET Edition
SVG Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SVG Class

Glossary Item Box

For a list of all members of this type, see SVG members.

See Also

Reference

SVG Class
GrapeCity.ActiveReports.Document.Section Namespace


TextAngle Class Methods

[image]
ActiveReports 19 .NET Edition
TextAngle Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextAngle Class

Glossary Item Box

For a list of all members of this type, see TextAngle members.

See Also

Reference

TextAngle Class
GrapeCity.ActiveReports.Document.Section Namespace


TextInfoItem Constructor

[image]
ActiveReports 19 .NET Edition
TextInfoItem Constructor
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextInfoItem Class : TextInfoItem Constructor

Glossary Item Box

Overload List

Overload | Description
TextInfoItem Constructor | Initialize the instance of the TextInfoItem class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextInfoItem Class
TextInfoItem Members


TextOut Class Methods

[image]
ActiveReports 19 .NET Edition
TextOut Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextOut Class

Glossary Item Box

For a list of all members of this type, see TextOut members.

See Also

Reference

TextOut Class
GrapeCity.ActiveReports.Document.Section Namespace


TextRenderHintItem Class Methods

[image]
ActiveReports 19 .NET Edition
TextRenderHintItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextRenderHintItem Class

Glossary Item Box

For a list of all members of this type, see TextRenderHintItem members.

See Also

Reference

TextRenderHintItem Class
GrapeCity.ActiveReports.Document.Section Namespace


VerticalText Class Methods

[image]
ActiveReports 19 .NET Edition
VerticalText Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : VerticalText Class

Glossary Item Box

For a list of all members of this type, see VerticalText members.

See Also

Reference

VerticalText Class
GrapeCity.ActiveReports.Document.Section Namespace


WordWrap Class Methods

[image]
ActiveReports 19 .NET Edition
WordWrap Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WordWrap Class

Glossary Item Box

For a list of all members of this type, see WordWrap members.

See Also

Reference

WordWrap Class
GrapeCity.ActiveReports.Document.Section Namespace


WrapModeItem Class Methods

[image]
ActiveReports 19 .NET Edition
WrapModeItem Class Methods
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapModeItem Class

Glossary Item Box

For a list of all members of this type, see WrapModeItem members.

See Also

Reference

WrapModeItem Class
GrapeCity.ActiveReports.Document.Section Namespace


GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document)

GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document)
See Also Inheritance Hierarchy

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Align | Represents the align canvas item.
Class | BackColor | Represents the background color.
Class | BackStyle | Represents the BackStyle.
Class | BitmapImage | Represents the abstract bitmap canvas item.
Class | Bookmark | Represents a bookmark.
Class | BookmarksCollection | Represents the bookmarks collection.
Class | BorderItem | Represents the border canvas item.
Class | CanvasItem | Represents an abstract class of a canvas element.
Class | CanvasItemCollection | Represents a collection of canvas elements.
Class | CanvasItemRenderer | Represents the rederer for canvas items.
Class | ClippingStack | Represents the clipping stack.
Class | ClipRect | Represents the rectangle of the clip.
Class | ControlInfo | Represents the inforamtion about control.
Class | ControlInfoEnd | Represents the end of the control information.
Class | DrawCanvas | Represents a canvas for painting.
Class | DrawText | Represents the text for drawing.
Class | DrawText2 | Represents the text for drawing.
Class | DrawTextLink | Represents a text link to draw.
Class | Ellipse | Represents the ellipse canvas item.
Class | EnhMeta | Represents the canvas item for WMF or EMF images. Represents the canvas item for WMF or EMF images.
Class | EnhMetaLink | Represents the canvas item for WMF or EMF images with hyperlink. Represents the canvas item for WMF or EMF images with hyperlink.
Class | EvaluationEnd | Represents the end of the evalution.
Class | EvaluationStart | Represents the beginning of the evaluation.
Class | FillRect | Represents a canvas element with a rectangular fill.
Class | ForeColor | Represents the foreground color.
Class | InputFieldCheckBoxItem | Represents the canvas item for checkBox fields.
Class | InputFieldItem | Represents the base canvas item for input field.
Class | InputFieldTabIndexItem | Represents the canvas item to specify tab order.
Class | InputFieldTextItem | Represents the canvas item for text fields.
Class | IntersectClip | Represents a canvas element with an intersection clip.
Class | JPEGImage | Represents the canvas item for JPEG image.
Class | JPEGLink | Represents the canvas item for JPEG image with hyperlink.
Class | LabelAttribute | Represents the class for setting the Label attribute.
Class | LineItem | Represents an line item element.
Class | LinkItem | Represents the abstract canvas item for image with hyperlink.
Class | Margins | Represents the margins.
Class | PageCell | Represents the page cell.
Class | PageDoubleLineExtensions | Provides extension methods for GrapeCity.ActiveReports.Core.Document.Page
Class | PageTable | Represents the table.
Class | PenStyle | Represents the style of pen.
Class | PenWidth | Represents the width of pen.
Class | PngImage | Represents the canvas item for PNG image.
Class | PngLink | Represents the canvas item for PNG image with hyperlink.
Class | Rect | Represents a rectangle canvas element.
Class | RenderState | Represents the rendering state
Class | ResetContext | Represents the context for reset.
Class | ResourcedCanvasItem | Represents a canvas element with resources.
Class | RoundRect | Represents a canvas element with a rounded rectangle.
Class | RoundRectEx | Represents the extended version of RoundRect canvas item. It provides ability to change radius of each corner separately.
Class | RTL | Represents the Right To Left canvas item.
Class | SectionInfo | Provides information about the section.
Class | SectionInfoEnd | Represents the end of the section information.
Class | SelectFont | Represents the selected font.
Class | SetCharacterSpacing | Represents the setter of character spacing.
Class | SetLineSpacing | Represents the setter of line spacing.
Class | SetPadding | Represents the setter of the padding.
Class | SetScaleX | Represents the setter of minimal character condensed rate for the X coordinate.
Class | StateChangedArgs | Represents the arguments of a state change.
Class | SVG | Represents a SVG canvas element.
Class | Table | Represents the table canvas item. The Table CanvasItems contains an arrayList of TableRow Object which contain an array list of TableCell Objects which contains an array list of canvasItems. This class saves, load, and renders a table.
Class | TabStopsItem | Represents an element of a collection of custom tab stops.
Class | TextAngle | Represents the angle of the text.
Class | TextBoundsRange | Represents the range of text boundaries.
Class | TextInfoItem | Represents the text information canvas item. Used for TextBox control while exporting report to Excel.
Class | TextOut | Represents the text output.
Class | TextRenderHintItem | Represents a hint when rendering text.
Class | UrlErrorEventArgs | Represents the arguments of the url error event
Class | UserPreferences | Represents the user preferences.
Class | VerticalText | Represents the vertical text.
Class | WordWrap | Represents the word wrap.
Class | WrapModeItem | Represents text wrap mode

Interfaces

 | Interface | Description
Interface | IBordered | Represents the interface with bounds.
Interface | ICanvasItemRenderer | Represents the canvas item rederer.
Interface | ICanvasItemsModifier | Representing modified canvas elements.
Interface | ILinkItem | Represents the common interface for link items.

Structures

 | Structure | Description
Structure | TabStopsItem.TabStop | Represents the structure of tab stops.

Delegates

 | Delegate | Description
Delegate | UrlErrorEventHandler | Event handler for url errors.

Enumerations

 | Enumeration | Description
Enumeration | AlignmentTypes | Represents the types of alignment. This AlignmentTypes enumeration specifies how text will be aligned in a table cell.
Enumeration | BackgroundStyle | Represents the background style when using the lower level page rendering API.
Enumeration | CanvasType | The enumeration of canvas types.
Enumeration | ControlType | Specifies control type
Enumeration | FindResult | Represents the results of the search.
Enumeration | InputBorderStyle | Border styles for input fields
Enumeration | InputCheckStyle | Check styles for checkBox input fields
Enumeration | InputTextAlign | Alignment for text input fields
Enumeration | PageOrientation | Indicates the orientation of the page when outputting to the printer.
Enumeration | PenStyles | Represents the type of pen used when drawing lines on a page.
Enumeration | RdfFormat | Represents the file format used for saving report documents.
Enumeration | SaveOptions | Represents the save options.
Enumeration | SectionType | Specifies report section type
Enumeration | State | Represents the states
Enumeration | TabStopsItem.TabStopTypes | Represents the Tab Stop types
Enumeration | TextAlignment | Represents the text alignment enumeration.
Enumeration | TextJustify | Represents the text justification.
Enumeration | TextRenderHint | Hint options for TextRenderHint canvas item
Enumeration | Units | Represents the unit of measure of the document when using the low level rendering API on the document page.
Enumeration | VerticalTextAlignment | Represents the vertical text alignment enumeration.
Enumeration | WrapMode | Specifies whether the text is written from left to right or right to left.

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document) Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section Namespace (MESCIUS.ActiveReports.Core.Document) Inheritance Hierarchy
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.Align
GrapeCity.ActiveReports.Document.Section.BackColor
GrapeCity.ActiveReports.Document.Section.BackStyle
GrapeCity.ActiveReports.Document.Section.BorderItem
GrapeCity.ActiveReports.Document.Section.ClipRect
GrapeCity.ActiveReports.Document.Section.ControlInfo
GrapeCity.ActiveReports.Document.Section.ControlInfoEnd
GrapeCity.ActiveReports.Document.Section.DrawText
GrapeCity.ActiveReports.Document.Section.DrawText2
GrapeCity.ActiveReports.Document.Section.DrawTextLink
GrapeCity.ActiveReports.Document.Section.Ellipse
GrapeCity.ActiveReports.Document.Section.EvaluationEnd
GrapeCity.ActiveReports.Document.Section.EvaluationStart
GrapeCity.ActiveReports.Document.Section.FillRect
GrapeCity.ActiveReports.Document.Section.ForeColor
GrapeCity.ActiveReports.Document.Section.InputFieldItem
GrapeCity.ActiveReports.Document.Section.InputFieldCheckBoxItem
GrapeCity.ActiveReports.Document.Section.InputFieldTextItem
GrapeCity.ActiveReports.Document.Section.InputFieldTabIndexItem
GrapeCity.ActiveReports.Document.Section.IntersectClip
GrapeCity.ActiveReports.Document.Section.LineItem
GrapeCity.ActiveReports.Document.Section.PenStyle
GrapeCity.ActiveReports.Document.Section.PenWidth
GrapeCity.ActiveReports.Document.Section.Rect
GrapeCity.ActiveReports.Document.Section.ResetContext
GrapeCity.ActiveReports.Document.Section.ResourcedCanvasItem
GrapeCity.ActiveReports.Document.Section.BitmapImage
GrapeCity.ActiveReports.Document.Section.JPEGImage
GrapeCity.ActiveReports.Document.Section.PngImage
GrapeCity.ActiveReports.Document.Section.EnhMeta
GrapeCity.ActiveReports.Document.Section.LinkItem
GrapeCity.ActiveReports.Document.Section.EnhMetaLink
GrapeCity.ActiveReports.Document.Section.JPEGLink
GrapeCity.ActiveReports.Document.Section.PngLink
GrapeCity.ActiveReports.Document.Section.RoundRect
GrapeCity.ActiveReports.Document.Section.RoundRectEx
GrapeCity.ActiveReports.Document.Section.RTL
GrapeCity.ActiveReports.Document.Section.SectionInfo
GrapeCity.ActiveReports.Document.Section.SectionInfoEnd
GrapeCity.ActiveReports.Document.Section.SelectFont
GrapeCity.ActiveReports.Document.Section.SetCharacterSpacing
GrapeCity.ActiveReports.Document.Section.SetLineSpacing
GrapeCity.ActiveReports.Document.Section.SetPadding
GrapeCity.ActiveReports.Document.Section.SetScaleX
GrapeCity.ActiveReports.Document.Section.SVG
GrapeCity.ActiveReports.Document.Section.Table
GrapeCity.ActiveReports.Document.Section.TabStopsItem
GrapeCity.ActiveReports.Document.Section.TextAngle
GrapeCity.ActiveReports.Document.Section.TextBoundsRange
GrapeCity.ActiveReports.Document.Section.TextInfoItem
GrapeCity.ActiveReports.Document.Section.TextOut
GrapeCity.ActiveReports.Document.Section.TextRenderHintItem
GrapeCity.ActiveReports.Document.Section.VerticalText
GrapeCity.ActiveReports.Document.Section.WordWrap
GrapeCity.ActiveReports.Document.Section.WrapModeItem
GrapeCity.ActiveReports.Document.Section.CanvasItemRenderer
GrapeCity.ActiveReports.Document.Section.ClippingStack
GrapeCity.ActiveReports.Document.Section.DrawCanvas
GrapeCity.ActiveReports.Document.Section.Margins
GrapeCity.ActiveReports.Document.Section.PageCell
GrapeCity.ActiveReports.Document.Section.PageDoubleLineExtensions
GrapeCity.ActiveReports.Document.Section.PageTable
GrapeCity.ActiveReports.Document.Section.RenderState
GrapeCity.ActiveReports.Document.Section.UserPreferences
System.Attribute
GrapeCity.ActiveReports.Document.Section.LabelAttribute
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.BookmarksCollection
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Document.Section.CanvasItemCollection
System.EventArgs
GrapeCity.ActiveReports.Document.Section.StateChangedArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs
System.ValueType
GrapeCity.ActiveReports.Document.Section.TabStopsItem.TabStop

See Also

Reference

MESCIUS.ActiveReports.Core.Document Assembly


CanConvertFrom(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertFrom(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > CanConvertFrom Method : CanConvertFrom(Type) Method

sourceType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertFrom( _
   ByVal sourceType As Type _
) As Boolean
C#
public bool CanConvertFrom(
   Type sourceType
)

Parameters

sourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


CanConvertTo(Type) Method

[image]
ActiveReports 19 .NET Edition
CanConvertTo(Type) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > CanConvertTo Method : CanConvertTo(Type) Method

destinationType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function CanConvertTo( _
   ByVal destinationType As Type _
) As Boolean
C#
public bool CanConvertTo(
   Type destinationType
)

Parameters

destinationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFrom(Object) Method

[image]
ActiveReports 19 .NET Edition
ConvertFrom(Object) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFrom Method : ConvertFrom(Object) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFrom( _
   ByVal value As Object _
) As Object
C#
public object ConvertFrom(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFromInvariantString Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class : ConvertFromInvariantString Method

Glossary Item Box

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members


ConvertFromInvariantString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFromInvariantString(String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromInvariantString(String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFromInvariantString Method : ConvertFromInvariantString(String) Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromInvariantString( _
   ByVal text As String _
) As Object
C#
public object ConvertFromInvariantString(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,CultureInfo,String) Method

context
culture
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   CultureInfo culture,
   string text
)

Parameters

context
culture
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List


ConvertFromString(ITypeDescriptorContext,String) Method

[image]
ActiveReports 19 .NET Edition
ConvertFromString(ITypeDescriptorContext,String) Method
See Also

Product Support Forum | Print this page

MESCIUS.ActiveReports.Core.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx.PaddingExConverter Class > ConvertFromString Method : ConvertFromString(ITypeDescriptorContext,String) Method

context
text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ConvertFromString( _
   ByVal context As ITypeDescriptorContext, _
   ByVal text As String _
) As Object
C#
public object ConvertFromString(
   ITypeDescriptorContext context,
   string text
)

Parameters

context
text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx.PaddingExConverter Class
PaddingEx.PaddingExConverter Members
Overload List